VisualComponents.Create3D Namespace

Classes
 | Class | Description
Public class | AbstractSimInterfaceConnectionChange | Stores Undo/Redo information for interface connections done in the interface connection editor.
Public class | ActiveComponentChangedEventArgs | Event data for ActiveComponentChanged event.
Public class | ActiveNodeChangedEventArgs | Event data for ActiveNodeChanged event.
Public class | ActiveRobotChangeEventArgs |
Public class | ActiveWindowChangedEventArgs | Event arguments for ActiveWindowChanged event
Public class | AddOnConfigCollection |
Public class | AddOnSetting |
Public class | AnnotationCreationChange | Stores undo/redo information of annotations
Public class | AppBootstrapperHelper | Common helper methods which are used during loading the application.
Public class | AppConfig | Usage is like this: using(AppConfig.Change(tempFileName)) { the app.config in tempFileName is used } If you want to change the used app.config for the whole runtime of your application, simply put AppConfig.Change(tempFileName) without the using somewhere at the start of your application. ( http://stackoverflow.com/questions/6150644/change-default-app-config-at-runtime )
Public class | ApplicationContextChangedMessage | Message is broadcasted before the application context is about to be changed.
Public class | ApplicationExitMessage | Message is broadcasted before the application object is about to be destroyed.
Public class | ApplicationExtensions | The application helper class.
Public class | ApplicationSubContextRequestMessage | Message is broadcasted before the application context is about to be switched.
Public class | ApplicationTheme | Helper class to work with the application theme.
 | AppLoader | The helper application loader which is responsible for initializating the application.
Public class | AppLoaderHelper | The helper application loading utility class.
Public class | AssemblyFeatureRequestAttribute | Provides a license request for an assembly
Public class | AssemblyLicenseAttribute | Provides a license requirement for an assembly
Public class | AssemblyLicenseKeyPatternAttribute | Provides a license key validation pattern for an assembly
Public class | BaseContext |
Public class | BaseContextConfigElement | Configuration file element for context dependent options.
Public class | BatchesChangedEventArgs | Event arguments for BatchesChanged event.
Public class | BehaviorAddedEventArgs | Event data for BehaviorAdded event.
Public class | BehaviorRemovedEventArgs | Event data for BehaviorRemoved event.
Public class | BehaviorRemovingEventArgs | Event data for BehaviorRemoving event.
Public class | BinaryInputValueChangedEventArgs |
Public class | ButtonPropertyClickedEventArgs |
Public class | CallInterceptor | Intercepts API calls and forces IsValid check.
Public class | CaseAddedEventArgs | Provides data for CaseAdded event.
Public class | CaseMovedEventArgs | Provides data for CaseMoved event.
Public class | CaseRemovedEventArgs | Provides data for CaseAdded event.
Public class | CategoryChangedEventArgs |
Public class | Change | Represents an individual change or set of changes that are required to be processed in order to undo and redo a command.
Public class | Changeset | Represents a collection of changes that are undone/redone atomically.
Public class | ChartLayout | Defines a set of layout positions that can be populated with charts.
Public class | ChartPosition | Defines a layout position. Specifies row/column start and span.
Public class | ChartPositionExtensions | Extension helper for ChartLayout and ChartPosition classes.
Public class | ChildAddedEventArgs | Event data for ChildAdded event.
Public class | CollisionDetectedEventArgs | Event data for CollisionDetected event.
Public class | CollisionDetectionActivatedEventArgs | Represents a collision detection activated event arguments. It derives from the EventArgs class EventArgs.
Public class | CollisionDetectionConfigElement | Configuration file element for collision options.
Public class | CollisionDetectionSection | Configuration file section for collision options.
Public class | CollisionMessage | Message published by the instance of ICollisionListenerService via IEventAggregator.
Public class | CombinableItemCollectionT |
Public class | CombinableItemCollectionExtensions |
Public class | ComponentAddedEventArgs | Component added event arguments
Public class | ComponentCreatedEventArgs | Represents a component creating event arguments. It derives from the EventArgs class EventArgs.
Public class | ComponentDeleteChange | PropertyChange contains information about a change of a individual property value.
Public class | ComponentRemovingEventArgs | Component removed event arguments
Public class | ComponentSavedEventArgs | Represents a saved component event arguments. It derives from the EventArgs class EventArgs.
Public class | ComponentSavingEventArgs | Represents a component saving event arguments. It derives from the EventArgs class EventArgs.
Public class | ConditionalListT | Extends IListT with Condition that allows restrict items that are accepted in the list.
Public class | ConfigurationHelper | Helper class for managing configuration files.
Public class | Connection | Checks internet connection
Public class | ConnectionEditorConfigElement | Configuration file element for Connection Editor Options.
Public class | ConnectionEditorSection | Configuration file section for Connection Editor Options.
Public class | ConnectorAddedEventArgs | Provides the data for ConnectorAdded event.
Public class | ConnectorRemovingEventArgs | Provides the data for ConnectorRemoving event.
Public class | ConstantDistributionParameters | Constant distribution parameters
Public class | ContainerTransitionEventArgs | Event trigger trigger by ISimContainer when component is arriving or leaving the container
Public class | ContextConfigCollection | Configuration file element collection for context dependent options.
Public class | Contexts | Static class that shows all possible Application contexts IDs.
Public class | ContextSection | Configuration file section for context dependent options.
Public class | CurveBase | Base class for curves creation
Public class | CurveLoop | This class contains information to create a loop
Public class | CustomBehaviorBase |
Public class | CustomBehaviorFactory |
Public class | CustomExecutorBase |
Public class | CustomPositionStatementBase |
Public class | CustomScopeStatementBase |
Public class | CustomSimulationUpdateEventArgs | CustomSimulationUpdate event args
Public class | CustomSnapInfo | Class used in SnapResult to add extra information about snap result. Populated by ICustomSnapper implementors.
Public class | CustomStatementBase | Base statement class, custom statements should derive from this
Public class | D3DToolBarConfigElement | Configuration file element for 3D toolbar options.
Public class | DatabaseChangedEventArgs |
Public class | DateHelper | Helper functions for DateTime formatting, etc.
Public class | DeviceInputs |
Public class | DimensionChange | Stores undo/redo information of IDimension -object.
Public class | DimensionCreationChange | Stores undo/redo information of dimensions
Public class | DisplayConfigElement | Configuration file element for Display Options.
Public class | DisplaySection | Configuration file section for Display Options.
Public class | DistanceResult | Distance measurement result class
Public class | EcatConfigCollection | Configuration file element collection for ECat options.
Public class | EcatConfigElement |
Public class | EcatSection | Configuration file section for General Options.
 | EmbeddedAppLoader | The helper application loader which is responsible for initializating the embedded application version.
Public class | ExecutingAssemblyInfo | Gets the application assembly info.
Public class | ExponentialDistributionParameters | Exponential distribution parameters
Public class | FeatureHierarchyChange | PropertyChange contains information about a change of a individual property value.
Public class | FeatureHierarchyChangedEventArgs | Feature hierarchy changed event arguments. It derives from EventArgs
Public class | FeatureTreeChangedEventArgs |
Public class | FileSystemHelpers | File system helpers
Public class | FloorSizeChangedEventArgs | Returns data from IFloor.FloorSizeChanged events.
Public class | FrameTypeStateConfigElement | Configuration file element for frame type options.
Public class | GammaDistributionParameters | Gamma distribution parameters
Public class | GeneralConfigElement | Configuration file element for General Options.
Public class | GeneralSection | Configuration file section for General Options.
Public class | GenericEnumeratorT | Generic enumerator, that also disposes of "Current" value.
Public class | GenericEventListener | Helper class that makes it easier to listen to various events. Also it makes sure that target instances are garbage collected, by referencing "_target" with a weak reference. Note: Typically there are multiple GenericEventListener instances listening to the same component's TransformationChanged event. This is because garbage collector is slow to dispose of old instances.
Public class | GenericLicensingHelper | Licensing helper that mostly works on the feature set level, and does not require main application licensing data structures. For main application licensing, see LicensingHelper.
Public class | GroupChange |
Public class | HeartbeatEventArgs | Heartbeat event args
Public class | HiddenLineRepresentation | Class that represents the result of a hidden line from a given layout or part of a layout.
Public class | IdentityMap | Internal wrapper utility class.
Public class | ImageSourceExporter | This class has utility methods to export ISimWorld objects into a RenderTargetBitmap class or VisualHost (FrameworkElement) class
Public class | ImportConfigElement | Configuration file element for import options.
Public class | ImportSection | Configuration file section for import options.
Public class | ImportSummaryMessage | Represents a summary of a CAD file
Public class | InteractInfoMessage | Broad casted when navigation starts and ends.
Public class | InterfaceConnections | Class returned when calling GetConnectionsComponents of IPlugAndPlayLogicalHelper
Public class | InterfaceConnectPostEventArgs | Provides data for Connected and Disconnected events.
Public class | InterfaceConnectPreEventArgs | Provides data for Connecting and Disconnecting events.
Public class | InterfaceMatchEventArgs | Provides data for Match event.
Public class | InterfacePosition | Class returned when calling GetNodeInterfaces of IPlugAndPlayLogicalHelper
Public class | InvalidWrapperException | Exception is thrown is an attempt to use an invalidated wrapper object is detected.
Public class | ItemCollectionChangedEventArgs |
Public class | ItemsDeselectedEventArgs |
Public class | ItemsDeselectingEventArgs |
Public class | ItemSelectedMessageT |
Public class | ItemsSelectedEventArgs |
Public class | ItemsSelectingEventArgs |
Public class | JointAddedEventArgs | Joint added event args JointAdded
Public class | JointLimitExceededEventArgs | Contains event data for JointLimitExceeded event.
Public class | JointLimitSettingChangedEventArgs | Contains event data for JointLimitSettingChanged event.
Public class | JointRemovedEventArgs | Joint removed event args JointRemoved
Public class | LanguageChangedEventArgs | Language changed event arguments
Public class | LayerPropertyChangedEventArgs |
Public class | LayoutClosedEventArgs | Represents a layout closed event arguments. It derives from the EventArgs class EventArgs.
Public class | LayoutClosingEventArgs | Represents a layout closing event arguments. It derives from the EventArgs class EventArgs.
Public class | LayoutItemAddedEventArgs |
Public class | LayoutItemRemovingEventArgs |
Public class | LayoutLoadedEventArgs | Represents layout loading event arguments. It derives from the EventArgs class EventArgs
Public class | LayoutLoadingEventArgs | Represents layout loading event arguments. It derives from the EventArgs class EventArgs
Public class | LayoutModifiedChangedEventArgs | Represents LayoutModified value changed event arguments. It derives from the EventArgs class EventArgs.
Public class | LayoutSavedEventArgs | Represents a saved layout event arguments. It derives from the EventArgs class EventArgs.
Public class | LayoutSavingEventArgs | Represents a layout saving event arguments. It derives from the EventArgs class EventArgs.
Public class | LicenseCheckFailedEventArgs | License check failure event argument class.
Public class | LicenseCheckingCatalog | Composition catalog that only allows parts with correct license.
Public class | LicenseFeatures | License features utility class.
Public class | LicenseInfo | Basic license information object.
Public class | LicenseMetadata | License metadata class.
Public class | LicensingHelper | Licensing Helper for working with the main application license.
Public class | LightSimNode |
Public class | LinkAddedEventArgs | Event data for LinkAdded event.
Public class | LinkRemovingEventArgs | Event data for LinkRemoving event.
Public class | LoadComponentChange |
Public class | Log4NetHelper | Log4Net Helper class.
Public class | Logger | Extended logger.
Public class | LogNormalDistributionParameters | Log Normal distribution parameters
Public class | ManipulationTargetHelper |
Public class | ManipulationTargetPreviewMessage | Message broadcasted on [!:ILocalManipulationTarget.TransformationInWorld] changes.
Public class | MathHelper |
Public class | Matrix3DExtension |
Public class | MessageAddedEventArgs | Event data for MessageAdded event.
Public class | MethodChangeTTarget | MethodChange contains information about a change that requires a method call.
Public class | NameChangedEventArgs |
Public class | NativeConfigCollection | Configuration file element collection for native options.
Public class | NativeConfigElement | Configuration file element for native options.
Public class | NativeSection | Configuration file section for native options.
Public class | NodeFeatureList | Class that associates a node to the list of features.
Public class | NodeListEntry | NodeListEntry instances can be used to form a list of instances of ISimNode.
Public class | NodeTemplateChangedEventArgs |
Public class | NodeTreeFinalizedEventArgs |
Public class | NormalDistributionParameters | Normal distribution parameters
Public class | PathUtility | Path utility
Public class | PdfExporter | Utility class to export elements into PDF file
Public class | PerformanceMeasurement | performance measurement helper
Public class | PlugIndication |
Public class | PolylineCurve | This class contains information to create a polyline
Public class | PositionFrameAddedEventArgs | Provides data for PositionAdded event.
Public class | PositionFrameCollection | Collection of position statements and frames. Used for easier iteration of all position frames.
Public class | PositionFrameHelper | Helper class for converting IMotionTarget to IPositionStatement and back.
Public class | PositionFrameIterator | Position frame iterator. Use internally by PositionFrameCollection.
Public class | PositionFrameRemovingEventArgs | Provides data for PositionRemoving event.
Public class | PositionFrameTransformationChangedEventArgs | Provides data for PositionTransformationChanged event.
Public class | PositionStatementFrame | Encapsultes together a position frame and a position statement. Used for easier iteration of all position frames.
Public class | PossibleConnection | Class returned when calling CheckInNode or CheckProximity of IPlugAndPlayLogicalHelper
Public class | ProcessAddedEventArgs | Provides data for ProcessAdded event.
Public class | ProcessFlowGroupAddedEventArgs | Data for GroupAdded event.
Public class | ProcessFlowGroupDeleteChange |
Public class | ProcessFlowGroupRemovingEventArgs | Data for GroupRemoving event.
Public class | ProcessGroupIdChangedEventArgs | Provides data for ProcessGroupIdChanged event.
Public class | ProcessRemovedEventArgs | Provides data for ProcessRemoved event.
Public class | ProcessRemovingEventArgs | Provides data for ProcessRemoving event.
Public class | ProductEntriesChangedEventArgs | Event arguments for ProductEntriesChanged event.
Public class | ProductLicenseConfiguration | Product license configuration settings persistency class.
Public class | ProductTypeAddedEventArgs | Provides data for ProductTypeAdded and ProductTypeRemoving events.
Public class | ProductTypeRemovedEventArgs | Provides data for ProductTypeRemoved event.
Public class | ProductTypeRemovingEventArgs | Provides data for ProductTypeRemoving and ProductTypeRemoving events.
Public class | ProductTypeReplacedEventArgs | Provides data for ProductTypeReplaced and ProductTypeReplaced events.
Public class | ProgramAddedEventArgs | Provides data for ProgramAdded event.
Public class | ProgramRemovingEventArgs | Provides data for ProgramRemoving event.
Public class | ProgressEventArgs | Component added event arguments
Public class | PropertyChange | PropertyChange contains information about a change of a individual property value.
Public class | PropertyCollection | PropertyList tracks the lifetime of contained properties, removing invalidated objects.
Public class | PropertyComparer | Compares two properties and returns true if the values strings are equal.
Public class | PropertyContainerChangedEventArgs | Property modified event arguments class.
Public class | PropertyException | For errors related to IProperty.
Public class | PropertyProxyCollection | Collection class to refer by proxy to properties in other containers. This class can be used to collect properties from various property containers so that they can be manipulated as a group.
Public class | PythonCommandIsCheckedChangedEventArgs |
Public class | PythonCommandIsEnabledChangedEventArgs |
Public class | PythonScriptTriggerEventArgs | Python trace event argument class.
Public class | RaycastPoint |
Public class | RecordingStartStopEventArgs |
Public class | RenderPresetModeChangedEventArgs |
Public class | RibbonProgramConfigElement | Configuration element for Program ribbon tab.
Public class | RobotFrameAddedEventArgs | Event data for ToolAdded and BaseAdded events.
Public class | RobotFrameRemovingEventArgs | Event data for BaseRemoving and ToolRemoving events.
Public class | RoutineAddedEventArgs | Provides data for RoutineAddedEvent event.
Public class | RoutineRemovingEventArgs | Provides data for RoutineRemoving event.
Public class | RunNotifiedEventArgs |
Public class | SchemaFrameCollection | Helper class that converts ISchemaFrame[] to IEnumerableT. See ICombinable interface. Note: This is needed because ISchemaFrame inherits from ICombinable interface.
Public class | SchemaPositionFrameCollection | Helper class that converts IPositionFrame[] to IEnumerableT. See ICombinable interface. Note: This is needed because ISchemaPositionFrame inherits from ICombinable interface.
Public class | SchemaRecordChangedEventArgs | Provides data for: - RecordAppended - RecordInserted - RecordRemoved
Public class | SchemaValueChangedEventArgs | Provides data for SchemaValueChanged.
Public class | ScopeExecutedEventArgs | Provides data for ScopeExecuted event.
Public class | SecondarySnapResult | Class used to save secondary snap results, such as arc centers and bound box corners.
Public class | SelectedRibbonTabChangedMessage |
Public class | SelectionChange | Represents a change of selection in ISelectionManager using complete "Before" and "After" selection sets.
Public class | SelectionHighlightRequestMessage | Message that temporarely disables highlighting of features and nodes.
Public class | SequenceAddedEventArgs | Provides data for SequenceAdded event.
Public class | SequenceRemovingEventArgs | Provides data for SequenceRemoving event.
Public class | Serializer |
Public class | SetupPythonActionMessage | Signals a request to setup a managed command for executing a python/native command.
Public class | SignalMapSignalValueChangedEventArgs | Contains data for SignalValueChanged event.
Public class | SignalTriggerEventArgs | Provides the data for SignalTrigger event.
Public class | SimInterfaceConnectionChange | Stores SimInterface state changes.
Public class | SimSignalConnectionChange | Stores Undo/Redo information for signal connections done in the signal connection editor.
Public class | SimulationRunTimeChangedEventArgs | Contains event data for RunTimeChanged event.
Public class | SimulationSpeedFactorChangedEventArgs | Contains event data for SpeedFactorChanged event.
Public class | SimulationTimeModeChangedEventArgs | Contains event data for VisualComponents.Create3D.ISimulation.SpeedFactorChanged event.
Public class | SnapOptionsContext |
Public class | SnapperPropertyList | Class the implements IListT and accepts only instance of ISnapperProperty which are unique within the list.
Public class | SoftwareReleaseInfo |
Public class | SoftwareUpdateHelper |
Public class | SplineCurve | This class contains information to create a spline
Public class | StatementAddedEventArgs | Provides data for StatementAdded event.
Public class | StatementDoubleClickEventArgs |
Public class | StatementExecutedEventArgs | Provides data for statement post execution events.
Public class | StatementExecutingEventArgs | Provides data for statement pre execution events.
Public class | StatementMovedEventArgs | Provides data for StatementMoved.
Public class | StatementRemovedEventArgs | Provides data for StatementRemoved event.
Public class | StatementRemovingEventArgs | Provides data for StatementRemoving event.
Public class | StatisticsConfigElement | Configuration file element for Statistics Dashboard Settings.
Public class | StatisticsDataRow | Defines a set of values recorded at a particular moment of simulation time.
Public class | StatisticsSection | Configuration file section for Statistics Dashboard Settings.
Public class | StatisticsSourceInfo | Additional information about a source, listed in IStatisticsChart.AllSourceInfos, and used for populating a pie chart.
Public class | StatusAddedEventArgs | Status message event arguments class.
Public class | StringCipher |
Public class | SubInstallation | Information on sub installation
Public class | Surface |
Public class | ThemeChangedEventArgs | Theme changed event arguments.
Public class | ThreadSafeGC |
Public class | TimerResultUpdatedEventArgs | Provides data for TargetReached event.
Public class | ToggleEcatIndexingMessage |
Public class | Topic |
Public class | TransportControllerAddedEventArgs | Provides data for TransportControllerAdded event.
Public class | TransportControllerRemovingEventArgs | Provides data for TransportControllerRemoving event.
Public class | TransportLinkAddedEventArgs | Provides data for TransportLinkAdded event.
Public class | TransportLinkDeleteChange | Transport link deletion change memento class.
Public class | TransportLinkRemovedEventArgs | Provides data for TransportLinkRemoved event.
Public class | TransportLinkRemovingEventArgs | Provides data for TransportLinkRemoving event.
Public class | TransportNodeAddedEventArgs | Provides data for TransportNodeAdded event.
Public class | TransportNodeRemovingEventArgs | Provides data for TransportNodeRemoving event.
Public class | TriangularDistributionParameters | Triangular distribution parameters
Public class | UndoEventArgs |
Public class | UndoScope |
Public class | UniformDistributionParameters | Uniform distribution parameters
Public class | UnionListProperty |
Public class | UnionProperty | Property that aggregates multiple properties.
Public class | UnionPropertyBase |
Public class | UnitFamilyChangedEventArgs |
Public class | UnSetupPythonActionMessage | Defines which action should be removed from UI.
Public class | VCPath |
Public class | VCPathObject |
Public class | WeakEventManager |
Public class | WeibullDistributionParameters | Triangular distribution parameters
Public class | VerboseException | Helper class for logging "inner" exceptions to log4net. Note: normal InnerException:s are working without this class.
Public class | VideoCreationFrameEventArgs | Represents video recording frame event arguments. It derives from the EventArgs class EventArgs
Public class | VideoCreationNotificationEventArgs | Represents video recording notification event arguments. It derives from the EventArgs class EventArgs
Public class | VideoCreationProgressEventArgs | Represents video recording progress status event arguments. It derives from the EventArgs class EventArgs
Public class | ViewCollectionChangedEventArgs | View added event arguments
Public class | WindowConfigElement | Configuration file element for window options.
Public class | WindowPoint | Window 2D position.
Public class | WindowRectangle | Window rectangular position.
Public class | WindowSection | Configuration file section for window options.
Public class | VisitorBase | Base class for node visitors
Public class | VisualHost | DrawingVisual container helper class. Used in ImageSourceExporter
Public class | WpfApplication | A helper class to encapsulate the WPF Application instance.
Structures
 | Structure | Description
Public structure | CartesianTarget | A target given in Cartesian coordinates.
Public structure | Color | Structure representing a color using red, green, blue and alpha channels
Public structure | Completion | Completion string record.
Public structure | CurrentTraceData |
Public structure | ExpressionFunction | Function details struct.
Public structure | FacePointAndFirstDerivate | Face point and first derivate
Public structure | FacePointAndSecondDerivate | Face point and second derivate
Public structure | FlybyParameterData | Information required by an RCS module when setting flyby settings
Public structure | GeoPrimitivePickResult |
Public structure | HistoryItem |
Public structure | IndexedLoadingPoint | Specifies loading parameters, e.g. on a robot's tool or additional load on one of its links.
Public structure | IntersectingGeometry | Represents the intersection or minimum distance between 2 triangles from 2 triangle sets
Public structure | LayoutSize | Row and column counts of the layout.
Public structure | LicensingServiceFeature | A versioned feature.
Public structure | LoadingPoint | Specifies loading parameters, e.g. on a robot's tool or additional load on one of its links.
Public structure | Matrix | Represents a 4x4 matrix in column major format.
Public structure | PickResult |
Public structure | ProductCreatorTableRow | Defines a single ISimProduct to be created at simulation time CreationTime. Used in IProductCreatorTableMode.
Public structure | ProductFeature | Product licensing feature identifier value class.
Public structure | PropertyAllowedValue | Information about a single allowed value used in properties with allowed value set constraint.
Public structure | PropertyAllowedValueT |
Public structure | PxRigidDynamicSerialization | Replicates `rPxRigidDynamicSerialization` struct from Revolution in VisualComponents.Create3D.
Public structure | PxShapeSerialization | Replicates `rPxShapeSerialization` struct from Revolution in VisualComponents.Create3D.
Public structure | RaycastResult | Contains a result scene raycast, see IWindow3D
Public structure | RenderingMode |
Public structure | RenderingPreset |
Public structure | SnapResult | SnapResult is used to indicate 3D position in space and visual object touching it in some way. SnapResult can be a position on edge, end-point of edge, center-point of a face, center-point of an edge, etc. Also it's possible to get extra info from SnapResult.GeoPickResult.GeoPrimitive instance (for example with GetTopologyPolyline).
Public structure | SurfaceGeometric | various geometric surface properties
Public structure | TexturePoint | Represents a u,v texture coordinate point
Public structure | TraceFrame | Python trace frame struct.
Public structure | TrajectoryNode | Trajectory node structure.
Public structure | VCFlybyParameters | Rounding information for the VC robot controller
Public structure | Vector3 | Represents a vector in 3D space
Interfaces
 | Interface | Description
Public interface | IActionContainer | Behavior used for storing information about various actions, such as grab, release, toggle trace on and others.
Public interface | IAngularCloneFeature | Represents an angular clone feature object
Public interface | IAnimationRecorder | Interface for recording vcax animation files.
Public interface | IAnnotation | Annotation layout item interface.
Public interface | IApiType |
Public interface | IAppConfigBlockedRibbonItemsSection | Receives visibility status of Ribbon item.
Public interface | IAppConfigSettings | Receive values from the app config section (appSettings) of the app config file.
Public interface | IAppendToListStatement | Joins source variable to the target variable.
Public interface | IApplication | Provides access to the application instance.
Public interface | IApplicationBootstrap | The IApplicationBootstrap is responsible for the application initialization.
Public interface | IApplicationContext | Provides access to the application context.
Public interface | IApplicationSettingService | The service to work with the user's config file settings.
Public interface | IArticulatedKinematics | An interface for articulated kinematics behavior.
Public interface | IArticulatedKinematics2 | An interface for articulated kinematics 2 behavior.
Public interface | IAttachProductStatement | Attaches child product(s) to a parent product.
Public interface | IAuthorContext | This interface represents the Author context of the application
Public interface | IAuthoringService | Helper functions for modeling tab.
Public interface | IAutoPlugPlayService | Auto plug and play service interface can be used for automatically connecting two components
Public interface | IBaseContainer | Data container for base IRobotFrame instances.
Public interface | IBatchModeObject |
Public interface | IBehavior | An interface for behavior objects.
Public interface | IBitmapProperty |
Public interface | IBlockFeature | Block feature interface
Public interface | IBooleanFeature |
Public interface | IBooleanPropertyCreator | Property creation behavior used to create and modify boolean property values.
Public interface | IBooleanSignal | An interface for boolean signal behavior.
Public interface | IBooleanSignalMap | An interface for boolean signal map behavior.
Public interface | IBoundBox | Bound box defines the smallest enclosing volume for associated object(s).
Public interface | IBreakStatement |
Public interface | IBucketPath | An interface for bucket path container flow behavior.
Public interface | IBufferProductsStatement | Creates a temporary storage for products in a grid pattern. Multiple products can be coming in and leaving the buffer in parallel. Continues execution until the break condition is met and the buffer has emptied.
Public interface | IButtonProperty |
Public interface | ICallStatement |
Public interface | ICamera | Interface to access the world camera
Public interface | ICapacityController | An interface for capacity controller behavior.Capacity Controller controls the global capacity for a group of behaviors.
Public interface | ICartesianKinematics | An interface for cartesian kinematics behavior.
Public interface | ICaseScope | A case statement to use in an ISwitchCaseStatement.
Public interface | IChangeProductTypeStatement | Process statement for changing the type of an ISimProduct instance.
Public interface | ICloneableT |
Public interface | ICloneGroup | Clone group interface.
Public interface | ICloneGroupFactory | Clone group factory interface.
Public interface | ICollisionDetectionSection | Configuration file section for collision options.
Public interface | ICollisionDetector | Collision detector layout item interface
Public interface | ICollisionListenerService | Service to provide centralized events for collisions occuring in the layout.
Public interface | ICollisionRecord | The information returned by ICollisionDetector when testing for collisions
Public interface | ICombinableT | Class whose instance can encapsulate/combine multiple instances of the same class. For example ISchemaPositionFrame and ISchemaFrame.
Public interface | ICommandExecution |
Public interface | ICommentStatement |
Public interface | ICompletionInfo | Completion information object.
Public interface | IComponentContainer | An interface for component container behavior.
Public interface | IComponentCreator | An interface for component creator behavior.
Public interface | IComponentFlowProxy | An interface for component flow proxy behavior.
Public interface | IComponentGrabber | An interface for component grabber behavior.
Public interface | IComponentMemento | Interface for storing component's state.
Public interface | IComponentPathSensor | An interface for component path sensor behavior.
Public interface | IComponentPdfInfo | Represents an object to be included in the PDF
Public interface | IComponentProperty | A property attached to a component.
Public interface | IComponentSignal | An interface for component signal behavior.
Public interface | IConeFeature | Cone feature interface
Public interface | IConnectingLinePoint | Interface for adding additional points to the connecting lines service.
Public interface | IConnectingLinesService | Service for rendering 3D polyline along robot's position frames. Polyline is rendered in the same order as position statements are executed.
Public interface | IConnectionEditorSection | Configuration file section for Connection Editor Options.
Public interface | IConsoleViewModel | Output window printing interface.
Public interface | IContainerFiller | An interface for container filler flow behavior.
Public interface | IContext | Interface that represents an application context.
Public interface | IContextSection | Configuration file section for application context dependent Options.
Public interface | IContinueStatement |
Public interface | ICreateProductStatement | A statement for creating an ISimProduct instance from inside a PM process. Also see IProductCreator.
Public interface | ICurveTopology | Curve topology interface for ILineSet
Public interface | ICustomBehavior |
Public interface | ICustomizationService | It provides customization functionality
Public interface | ICustomScopeStatement |
Public interface | ICustomSnapper |
Public interface | ICustomStatement |
Public interface | ICustomTypeWrapper |
Public interface | ICycleTimeService | A service that provides the cycle time for a range of statements.
Public interface | ICylinderFeature | Cylinder feature interface
Public interface | IDelayStatement |
Public interface | IDeltaKinematics | An interface for delta kinematics behavior.
Public interface | IDerivedProperty |
Public interface | IDetachProductStatement | A statement to child detach ISimProduct(s) from a parent ISimProduct.
Public interface | IDimension | Dimension layout item interface.
Public interface | IDirect3DViewportViewModel |
Public interface | IDisplaySection | Configuration file section for Display Options.
Public interface | IDistributionModeProductLineEntry | Defines a IProductType option and its creation probability for IProductCreatorDistributionMode.
Public interface | IDistributionParameters | Base interface for Distribution Parameters
Public interface | IDistributionProperty | Distribution property interface.
Public interface | IDllFeatureRequest | Dll license feature request interface.
Public interface | IDllLicenseCheck | Dll license check interface.
Public interface | IDllLicenseKeyPattern | Dll license key pattern interface.
Public interface | IDocumentContent | Represents tabbed documents within a XamDockManager
Public interface | IDocumentLink | An interface for document link behavior.
Public interface | IDof |
Public interface | IDofManipulationTarget |
Public interface | IDoubleProperty | Interface for double properties Provides more information about this type of property.
Public interface | IDrawingContext | This interface represents the Drawing context of the application
Public interface | IDrawingView | Drawing view layout item interface
Public interface | IDurable | Objects implementing this marker interface have object lifetime equal to applications.
Public interface | IEcatSection | Configuration file section for General Options.
Public interface | IEdge |
Public interface | IExecutor | Executor behavior base interface
Public interface | IExpressionContext | Expression context interface.
Public interface | IExpressionEvaluator |
Public interface | IExpressionProperty | Expression property interface.
Public interface | IExtrudeFeature | Represents a extrude feature object
Public interface | IFace | Interface that provides additional information of a ITopologyFace
Public interface | IFeature | Interface that represents simulation node feature tree objects. Features define the geometry of objects either by themselves or as a result of operations on other features. The result of the feature tree evaluation is placed in to the geometry container in ISimNode. This process is governed by properties in the feature objects, which are accessible through this class. Only the Geometry feature has a specific Python class vcGeometryFeature which is derived from vcFeature in order to support creation of custom geometry. All other features can be manipulated through the generic IFeature interface.
Public interface | IFloor | Floor and Grid attributes
Public interface | IFlowBehavior | A base interface for behaviors supporting material flow.
Public interface | IFrame |
Public interface | IFrameFeature | Frame feature interface
Public interface | IFrameSet | Interface for frame sets. A collection of frame primitives.
Public interface | IGeneralSection | Configuration file section for General Options.
Public interface | IGenericEnumeratorOwnerT |
Public interface | IGenericEventChecker | Used in cases when it's possible to check if OnGenericEvent() should be called or not. Makes it easier to debug instances that are not used anymore, nor garbage collected yet.
Public interface | IGenericEventTarget | Classes that use GenericEventListener class should implement this interface.
Public interface | IGeometryContainer | Geometry container interface
Public interface | IGeometryFeature | Geometry feature interface
Public interface | IGeometrySet | Base interface for all geometry sets
Public interface | IGetProductsStatement | A process statement that gets the list of accepted products from component container.
Public interface | IGetPropertyStatement | A process statement for getting an IProperty from a static ISimComponent and storing it into a process variable.
Public interface | IGroup | Logical group of components.
Public interface | IGroupableItem | interface layout items that can be groupped
Public interface | IHaltStatement | Interface for halt statement
Public interface | IHeaderModel | PDF templates header information
Public interface | IHiddenLineService | Service for creating hidden line representations
Public interface | IIdentityMapObject |
Public interface | IIfStatement |
Public interface | IImportSection | Configuration file section for import options.
Public interface | IIntegerPropertyCreator | Property creation behavior used to create and modify property values.
Public interface | IIntegerSignal | An interface for integer signal behavior.
Public interface | IIntegerSignalMap | An interface for integer signal map behavior.
Public interface | IInteractionService | Interface to interaction services
Public interface | IInterpolatable | Interface for interpolatable objects
Public interface | IJogInfo | An interface for jog info behavior.
Public interface | IJoint | Robot's joint definition.
Public interface | IJointMotionStatement |
Public interface | ILayerControl |
Public interface | ILayoutItem | Base interface for layout items
Public interface | ILayoutItemGroup | Logical group of ILayoutItem.
Public interface | ILayoutPackFolder | Interface for layout item that contains a pack folder instance.
Public interface | ILayoutPropertyList | Modifiable property list object that is saved with a layout.
Public interface | ILayoutSchemaPropertyList | Modifiable property list object that is saved with a layout. Designed for handling large amounts of data.
Public interface | ILayoutViewAnimation | View animation layout item interface.
Public interface | ILicenseHandle | License handle interface.
Public interface | ILicenseMetadata | License metadata interface.
Public interface | ILicensingChallenge | Licensing challenge interface.
 | ILicensingService | Licensing service interface.
Public interface | ILightSimNode | Read-only accessible simulation node.
Public interface | ILinearCloneFeature | Represents a linear clone feature object
Public interface | ILinearMotionStatement |
Public interface | ILineSet | Interface for line sets. Can be used for creating and reading line geometries. A line is represented as a collection of two or more points
Public interface | IListProperty | Non-generic list property interface.
Public interface | IListPropertyT | Generic list property interface.
Public interface | ILocalizationService | It provides a localization functionality.
Public interface | ILocalManipulationTarget | Manipulation target object interface.
Public interface | ILockableObject |
Public interface | ILogExt | Extended logger.
Public interface | IManipulateViewModel |
Public interface | IManipulationTarget | Manipulation target object interface.
Public interface | IManipulator | Identifies 3D WPF manipulators. (not related to System.Windows.Input.IManipulator, nor HelixToolkit.Wpf.Manipulator)
Public interface | IMaterial | Material interface
Public interface | IMaterialProperty | Interface for material properties Provides more information about this type of property.
Public interface | IMathematicalFace | Interface that provides addtional methods of a ITopologyFace which is of type Nurbs or Offset.
Public interface | IMatrixSignal | An interface for matrix signal behavior.
Public interface | IMementoT |
Public interface | IMessageBoxService | MessageBox Service interface
Public interface | IMessageService | Application messaging service interface.
Public interface | IMirrorFeature | Represents a mirror feature object
Public interface | IModelMetadata | Component metadata
Public interface | IMotionInterpolator | An interface for interpolating motion target paths. The motion interpolator's life time is managed by its user, see remarks.
Public interface | IMotionModeStatement | Interface for motion mode statement.
Public interface | IMotionPath | Base interface for motion path behaviors.
Public interface | IMotionTarget | Motion target for a robot, which may include joint and tool behavior as well as speed and configuration settings for orientation solutions.
Public interface | IMotionTester | Interface for changing robot's state with IMotionTarget.
Public interface | IMoveJointStatement | Moves Joint to TargetValue over [!:MotionTime].
Public interface | INamed | Interface for named objects
Public interface | INativeSection | Configuration file section for native options.
 | INodeEntryListHelper | Helper utility interface for working with instances of NodeListEntry.
Public interface | INonvisualManipulationTarget |
Public interface | INote | An interface for note behavior.
Public interface | IOneDirectionalPath | One-directional path behavior used to move components along a path.
Public interface | IOneToManyInterface | An interface for one to many interface behavior.
Public interface | IOneToOneInterface | An interface for one to one interface behavior.
Public interface | IOneWayPath | An interface for one-way path behavior.
Public interface | IOriginManipulationTarget |
Public interface | IPackFolder | Pack folder interface.
Public interface | IParallelogramKinematics | An interface for parallelogram kinematics behavior.
Public interface | IPathObject | Path object layout item interface. Path object is an object consisting of motion nodes, action nodes, parameter nodes and reference nodes. It also contains segments that consists of trajectory nodes.
Public interface | IPathObjectActionNode |
Public interface | IPathObjectMotionNode |
Public interface | IPathObjectNode | Path object node interface.There are four different types of nodes in the IvcPathObject. These include action nodes, motion nodes, parameter nodes and reference nodes. A reference node is comparable with a base frame in robotics. It may be relative to a simulation node. It may also be relative to the world origin. If it is relative to a simulation node, it follows the simulation node if it moves. Motion nodes and parameter nodes may be relative to reference node. If so, then they move when reference node moves. Action nodes are relative to motion nodes but their physical location in 3D space is defined by the trajectory segment. So its location depends on LogicalDistance property, that in turn is calculated from the LogicalDistance of the motion node it is relative to and Offset value.
Public interface | IPathObjectParameterNode |
Public interface | IPathObjectReferenceNode |
Public interface | IPathObjectSegment | Path object segment interface.
 | IPathStatement | Statement for moving a robot along a path. Similar to ILayoutSchemaPropertyList class, but requires a robot. Note that internally position frames are stored differently from [!:IPositionStatement.Positions]. Use SchemaPositions instead of [!:IPathStatement.Positions].
Public interface | IPdfRecorder | Service to create pdf from simulation recording
Public interface | IPdfRecordExporter | Represents a UI entry for the IPDFReportBuilder which is coupled with a specific PDF template file.
Public interface | IPdfReportBuilder | A component which can create a PDF report from a U3D model.
Public interface | IPhysicsCable | An interface for physical cable behavior.
Public interface | IPhysicsContactModifier | An interface for physics contact modifier behavior.
Public interface | IPhysicsContainer | An interface for physics container behavior.
Public interface | IPhysicsEntity | An interface for physics entity behavior.
Public interface | IPhysicsJointD6 | An interface for physics joing d6 behavior.
Public interface | IPhysicsJointD6ManipulationTarget |
Public interface | IPhysicsPath | An interface for physics path behavior.
Public interface | IPlaneFeature | Plane feature interface
Public interface | IPlugAndPlayHelper |
Public interface | IPlugAndPlayLogicalHelper | Helper interface that provides methods relating to abstract interfaces behaviors
Public interface | IPointSet | Interface for point sets.
Public interface | IPosition | Interface for object that have position.
Public interface | IPositionFrame | Defines 3D position and joint values.
Public interface | IPositionFrameContainer |
Public interface | IPositionStatement | Interface for robot statements that include positions
Public interface | IPositionValidator |
Public interface | IPrimitive |
Public interface | IPrimitiveFeature | Primitive feature interface
Public interface | IPrintStatement |
Public interface | IProcessBooleanTableStatement |
Public interface | IProcessController | The process controller is a central object that ties in different aspects of a Process Modeling system.
Public interface | IProcessDelayStatement | Delays process execution for a variable amount of simulation time.
Public interface | IProcessExecutor | IProcessExecutor is a IBehavior that holds and runs IProcessRoutines. Each IProcessRoutine is an implementation of a process. The execution order of the IProcessRoutines is controlled by the parent IProcessController.
Public interface | IProcessFlowGroup | A IProcessFlowGroup is a grouping of IProductTypes that share same IProcessSequence and can navigate through the same ITransportLinks.
Public interface | IProcessFlowGroupManager | The IProcessFlowGroupManager is used to manage the IProcessFlowGroup objects within its owner IProcessController.
Public interface | IProcessFlowTable | The IProcessFlowTable holds the IProcessSequences that each ISimProduct belonging to a certain IProcessFlowGroups shall follow as it travels through the simulation under this IProcessController.
Public interface | IProcessGroup | IProcessGroup is an automatic grouping of all IProcessRoutine implementations that have the same identifier (ProcessId).
Public interface | IProcessHandler | An interface for process handlers.
Public interface | IProcessIfStatement | Executes ThenScope when ConditionExpression evaluates to True or ElseScope when it evaluates to False.
Public interface | IProcessIntegerTableStatement |
Public interface | IProcessManager | The IProcessManager service automatically creates, updates and removes IProcessGroups when IProcessRoutines are added, renamed or removed within its parent IProcessController. The IProcessGroups can be used to easily find all implementations of a IProcessRoutine. IProcessRoutine implementations are owned by IProcessExecutor instances.
Public interface | IProcessNormalStatement |
Public interface | IProcessPointSensor | An interface for process point sensor behavior.
Public interface | IProcessPrintStatement | Prints result of MessageExpression to the Output panel.
Public interface | IProcessRealTableStatement |
Public interface | IProcessRequirementsRoutine | A IProcessRequirementsRoutine holds the IRequirementStatements that need to pass before the IProcessRoutine can be started.
Public interface | IProcessRoutine | IProcessRoutine is a routine in the IProcessExecutor’s program that implements a Process Modeling process. It has an additional internal IRoutine for the special IRequirementStatements that control when this process’ execution starts.
Public interface | IProcessRuleLineStatement |
Public interface | IProcessRuleStatement |
Public interface | IProcessSequence | Defines the sequence of process steps (see IProcessGroup) that any IProductType belonging to a particular IProcessFlowGroup shall follow in the Process Modeling system.
Public interface | IProcessStatement |
Public interface | IProcessStringTableStatement |
Public interface | IProcessTableLineStatement |
Public interface | IProcessTableStatement |
Public interface | IProcessUniformStatement |
Public interface | IProcessWhileStatement | Executes Scope in a loop as long as ConditionExpression evaluates to True.
Public interface | IProductConfiguration | Product license configuration interface.
Public interface | IProductCreator | Product creator is a IBehavior that creates ISimProduct instances during simulation.
Public interface | IProductCreatorBatchMode | Configuration for creating batches of products from IProductCreator Multiple batches can be defined and they are executed in sequence.
Public interface | IProductCreatorDistributionMode | Configuration for creating products of different types in randomized order from IProductCreator.
Public interface | IProductCreatorFeedBatch | Configuration for creating a single batch of products from IProductCreator
Public interface | IProductCreatorSingleMode | Configuration for Single mode.
Public interface | IProductCreatorTableMode | Configuration for creating products at specific sequence and time from IProductCreator.
Public interface | IProductItem | Product add-on information interface.
Public interface | IProductType | A product definition that is used to create ISimProduct instances.
Public interface | IProductTypeComponentTemplate | An interface to provide restricted access to the template ISimComponent that is used when creating ISimProduct objects of a certain IProductType.
Public interface | IProductTypeManager | The product type manager is used to create, modify and delete IProductType objects. It is owned by an IProcessController.
Public interface | IProgram | Robot program interface.
Public interface | IProgramSerializer | Utility to serialize and deserialize IProgram instances.
Public interface | IProgramSyncStatement |
Public interface | IProgressContext | Progress context manages progress bar data.
Public interface | IProgressStatusSource | Progress status source interface.
Public interface | IProperty | Non-generic property interface.
Public interface | IPropertyT | Generic property object interface.
Public interface | IPropertyChangedScriptEventHandler |
Public interface | IPropertyChangeFilter | Property change notification filtering interface.
Public interface | IPropertyConditionStatement | A process requirement statement for evaluating if a given property's value matches the given condition. Triggers re-evaluation of the requirements section if the property's value changes.
Public interface | IPropertyContainer | Property container interface.
Public interface | IPropertyContainerProperty | Property container property interface.
Public interface | IPropertyEditorDisplayName | Interface for objects that want to customize the property editor header to be different from Name.
Public interface | IPySnapCommand |
Public interface | IPythonActionPanelCommand | Provides access to the python action panel.
Public interface | IPythonCommand | An interface for Python commands.
Public interface | IPythonFeature | Represents a python feature object
Public interface | IPythonInstance | Python script instance interface.
Public interface | IPythonProcessHandler | An interface for python process handler behavior.
Public interface | IPythonScript | An interface for Python Script behavior.
Public interface | IPythonSimInstance | Python simulation script instance interface.
Public interface | IPythonTransportController | Delegates implementation of the transport of ISimProduct instances over ITransportLinks to user-made Python script(s). Custom controllers can be created with CreateBehaviorByType(BehaviorType) using PythonTransportController.
Public interface | IRay |
Public interface | IRaycastCurveHelper |
Public interface | IRaycastSensor | An interface for ray cast behavior.
Public interface | IRealPropertyCreator | An interface for real property creator behavior.
Public interface | IRealSignal | An interface for real signal behavior.
Public interface | IRealSignalMap | An interface for real signal map behavior.
Public interface | IRecord | Record list property value element object interface.
Public interface | IRecorder | Simulation recorder interface
Public interface | IRecordExporter | Recorder base interfaec
Public interface | IRecordListProperty | Record list property interface.
Public interface | IRecordTemplate | Record template interface.
Public interface | IReferenceListProperty | A property that holds a reference to an object instead of a value.
Public interface | IReferenceProperty | A property that holds a reference to an object instead of a value.
Public interface | IReleaseProductReservationStatement | A process statement for releasing a pre-reserved product instance, e.g. so that it can be offered to another process.
Public interface | IRemoveProductStatement | A statement for deleting a ISimProduct instance. Also deletes Component.
Public interface | IRenderService |
Public interface | IRenderStage |
Public interface | IRequirementStatement | Represents a process requirement statement. For a process to start, all of it's requirements must pass.
Public interface | IReserveProductStatement | Represents a process requirement to reserve a single ISimProduct instance.
Public interface | IReturnStatement |
Public interface | IRevolveFeature | Represents a revolve feature object
Public interface | IRibbonProgramSection | Configuration section for Program ribbon tab.
Public interface | IRibbonService | Application Ribboon Service
Public interface | IRobot | Robot or servo interface.
Public interface | IRobotController | Defines robot's joints, bases, and tools.
Public interface | IRobotConverter | Helper class for converting old RSL programs to the new IRobotExecutor format.
Public interface | IRobotExecutor | Robot executor behavior interface.
Public interface | IRobotFrame | Base/tool frame interface.
Public interface | IRobotPositionManipulationTarget |
Public interface | IRobotTcpManipulationTarget |
Public interface | IRobotTcpSettings | Robot TCP manipulation settings interface.
Public interface | IRobotTraceDataService |
Public interface | IRouteBooleanTableStatement | Uses component boolean variable value to define where routing is done It is compused by one or multiple IRouteTableLineStatement statements
Public interface | IRouteCapacityStatement | Routing is done to the first connection where is capacity for the connected component
Public interface | IRouteCyclicStatement | Routing is cycled between user defined connections
Public interface | IRouteFixedLineStatement | Defines a fixed rule for a IRouteFixedStatement statements
Public interface | IRouteFixedStatement | Routing in each input can have a equivalent output where a component is routed. It is compused by one or multiple IRouteFixedLineStatement statements
Public interface | IRouteIntegerTableStatement | Uses component integer variable value to define where routing is done It is compused by one or multiple IRouteTableLineStatement statements
Public interface | IRoutePercentageLineStatement | Defines a percentage rule for a IRoutePercentageStatement statements
Public interface | IRoutePercentageStatement | routing is done dividing material flow between connections using connection specific percentage It is compused by one or multiple IRoutePercentageLineStatement statements
Public interface | IRouteRealTableStatement | Uses component real variable value to define where routing is done It is compused by one or multiple IRouteTableLineStatement statements
Public interface | IRouteRuleLineStatement | Base interface for all line statements
Public interface | IRouteRuleStatement | Routing Rule can be used to divide and merge a material flow by connecting it into existing paths or to moving containers. Routing Rule makes routing decision either using a fixed value or by applying rules. Some rules support hierarchical decisions.
Public interface | IRouteStringTableStatement | Uses component string variable value to define where routing is done It is compused by one or multiple IRouteTableLineStatement statements
Public interface | IRouteTableLineStatement | Defines a fixed rule for a IRouteTableStatement statements
Public interface | IRouteTableStatement | Base interface for all rule table statements
Public interface | IRouteTransportSolutionLineStatement | Defines a single rule for a IRouteTransportSolutionStatement routing rule statement.
Public interface | IRouteTransportSolutionStatement | A routing rule, where the routing is based on the transport solution of the ISimProduct object.
Public interface | IRoutine | Interface for program routines. These routines are contained and managed by an instance of IProgram.
Public interface | IRoutingRule | Interface for routing rule behavior.
Public interface | IRslExecutor | An interface for RSL Executor behavior.
Public interface | IRunRobotRoutineStatement | A process statement that waits until the selected IRobotExecutor is idle, and then runs the selected IRoutine synchronously.
Public interface | ISamplingTimer | Simulation timer.
Public interface | IScalarQuantity | Interface representing a type of value that parameter contains.
Public interface | IScaraKinematics | An interface for scara kinematics behavior.
Public interface | IScaraKinematics2 | An interface for scara kinematics 2 behavior.
Public interface | ISchemaFrame |
Public interface | ISchemaPositionFrame | Position frame belonging to IPathStatement.
Public interface | IScreenRecorder | Simulation recorder interface
Public interface | IScriptProperty |
Public interface | ISection | User configuration section.
Public interface | ISelectionHandler | SelectionHandler implementations are responsible to implemenet logic what should happen when the object is being added or removed from selection. However, these are not used directly, but are invoked through SelectionManager, which is responsible for maintaining bookkeeping of selections.
Public interface | ISelectionManager | SelectionManager tracks selected objects in scene and delegates selection and deselection to associated selection handlers.
Public interface | ISelectProductsStatement | A process statement for filtering IProductTypes from a given list variable to a new list variable.
Public interface | ISendSignalStatement | Process statement that sends the selected ISignal with the provided value.
Public interface | IServoController | Servo controller behavior.
Public interface | ISetBaseStatement | Interface for set base statement
Public interface | ISetDigitalOutputStatement |
Public interface | ISetNodeMaterialStatement | Process statement for changing IMaterial of an ISimNode in an ISimProduct instance.
Public interface | ISetNodeVisibilityStatement | A process statement for changing the visibility of an ISimNode in one or more ISimProducts.
Public interface | ISetPropertyStatement |
Public interface | ISetStatisticsFlowStatement | Controls flow-type statistics for individual ISimProducts in the machine.
Public interface | ISetStatisticsStateStatement | Sets statistical state of the machine.
Public interface | ISetToolStatement | Interface for set tool statement.
Public interface | ISharedCloneable | Interface for objects that can share data when being cloned.
Public interface | IShutdownNotifier | Notifies when shutting down.
Public interface | ISignal | An interface for signal behavior. A signal is used to transmit information received from a sensor in a component or relay information between two or more components.
Public interface | ISignalMap | Signal map behavior interface. Signal maps are used to signals to I/O space of IExecutor.
Public interface | ISimAction | Property container storing information about actions such as grab, release, toggle trace, etc.
Public interface | ISimComponent |
Public interface | ISimConnector | Interface defining a connection port. Used to implement material flow between containers.
Public interface | ISimContainer | Container behavior used for placing components into a logical container.
Public interface | ISimDoubleVariableCreator | Obsolete.
Public interface | ISimInterface | An simulation interface behavior.
Public interface | ISimInterfaceActionField | Field for connecting IActionContainer containers and plug&playing components.
Public interface | ISimInterfaceAttachmentField | Field for hierarchically attaching physical objects.
Public interface | ISimInterfaceBaseExportField | Field for adding additional base frames to a robot controller.
Public interface | ISimInterfaceField | Plug&play interface field.
Public interface | ISimInterfaceFlowField | Field for connecting two ISimConnector connectors and facilitating a material flow between component containers.
Public interface | ISimInterfaceHierarchyField | Field for connecting components hierarchically.
Public interface | ISimInterfaceIntegerCompatibilityField | Field defining comparison mechanism for interfaces, which have the same amount of fields, but different restrictions.
Public interface | ISimInterfaceJointExportField | Field for adding servo's joints to a servo controller.
Public interface | ISimInterfaceProcessorField | Field for connecting process points to motion paths.
Public interface | ISimInterfaceRSLField | Field connecting RSL publishers.
Public interface | ISimInterfaceSection | Simulation interface section.
Public interface | ISimInterfaceSignalField | Field for connecting signal behaviors.
Public interface | ISimInterfaceToolExportField | Field for adding additional tool frames to a IRobotController.
Public interface | ISimInterfaceTransportField | Field for connecting ITransportProtocol containers/behaviors.
Public interface | ISimNode |
Public interface | ISimProduct | Instance of a IProductType, a single Product.
Public interface | ISimulation | Simulation object interface.
Public interface | ISimulationService |
Public interface | ISimWorld | SimWorld is the root node of the simulation. It provides access to the layout items, components, groups and views.
Public interface | ISimWorldObject |
Public interface | ISnapOptionsViewModel |
Public interface | ISnapperPosition | Interface for positions produced by path snappers.
Public interface | ISnapperProperty | Interface for properties in path snapper objects.
Public interface | ISnapperPropertyContainer | Interface for snapper related objects with properties.
Public interface | ISolidTopology | Curve topology interface for ITriangleSet
Public interface | ISphereFeature | Sphere feature interface
Public interface | IStartTransportInStatement | Transports ISimProducts in asynchronously.
Public interface | IStartTransportOutStatement | Transports ISimProducts out asynchronously.
Public interface | IStatement | Statement interface. Statement defines a functionality that can be executed by the instance of IStatementExecutor. Statement is always owned by an instance of IStatementScope.
Public interface | IStatementExecutor | Base class of any executor
Public interface | IStatementScope | Statement scope is a set of statements. Statement scope can be either a routine, a statement (e.g. while statement) or a child scope inside a statement (e.g if then/else).
Public interface | IStatistics | An interface for collecting statistics of material flow.
Public interface | IStatisticsChart | Base interface for selectable chart item (StatisticsChartBase), chart's UI (StatisticsChartViewModel), and placeholder chart UI (StatisticsChartViewModel).
Public interface | IStatisticsChartBase | Base interface for selectable chart item (StatisticsChartBase), chart's UI (StatisticsChartViewModel), and placeholder chart UI (StatisticsChartViewModel).
Public interface | IStatisticsDashboard | Statistics dashboard, which consists of tabs, layouts, and charts.
Public interface | IStatisticsManager | Global statistics manager.
Public interface | IStatisticsManager2 | Encapsulates a dashboard collection, that is stored as a layout item.
Public interface | IStatisticsSection | Configuration file section for Statistics Dashboard Settings.
Public interface | IStatisticsSeries | Defines graph sources, settings, and sampled values. Note: one instance can have multiple sources, so "Series" can also mean "Multiple Series".
Public interface | IStatisticsSource | Helper interface, used only for reading final properties and components, which are deduced from IStatisticsSeries.Property and IStatisticsSeries.Components. These values are calculated automatically, and cannot be modified.
Public interface | IStatisticsState | States for which statistics are collected.
Public interface | IStatisticsTab | Defines a single tab in statistics dashboard.
Public interface | IStringProperty | Interface for string properties. Provides more information about this type of property.
Public interface | IStringPropertyCreator | Property creation behavior used to create and modify string property values.
Public interface | IStringSignal | Simulation signal behaviour.
Public interface | IStringSignalMap | String signal map behavior.
Public interface | ISweptVolume | Swept volume layout item interface.
Public interface | ISwitchCaseStatement | A switch statement that executes the first ICaseScope who's ConditionExpression matches ConditionExpression.
Public interface | ISwitchFeature | Represents a switch feature object
Public interface | ITeachContext | This interface represents the Teach context of the application
Public interface | IText2DSet | Interface for 2d text sets. Implements a geometry set that renders bill boarded text in the world.
Public interface | IText3DSet | Interface for 3d text sets. Implements a geometry set that renders 3d text in the world.
Public interface | ITextFeature | Text type of feature
Public interface | ITimerStatement | Interface for timer statement.
Public interface | IToolContainer | Data container for tool IRobotFrame instances.
Public interface | ITopologyBaseCurve | Curves topology base interface
Public interface | ITopologyCurve | Curve topological information
Public interface | ITopologyCurveLoop | Curve loop topological information
Public interface | ITopologyFace | Face topological information
Public interface | ITransformFeature | Represents a transform feature object
Public interface | ITranslationRotationService | ITranslationRotationService privides methods to rotate and translate an IPosition target. It provides a method to get the position in which the manipulation handler for this target should be located in the 3d World. Additionaly, a handle can be set so the service will update its position automatically after each transformation in the target
Public interface | ITransportController | Implements transport of ISimProduct instances over ITransportLinks.
Public interface | ITransportInStatement | Transports ISimProducts in.
Public interface | ITransportLink | A logical single-directional link between two ITransportNode objects. All links are managed by ITransportSystem, so only the Implementer can be changed after the link has been created.
Public interface | ITransportNode | Defines a logical place where ISimProducts can be transported to/from.
Public interface | ITransportOutStatement | Transports ISimProducts out.
Public interface | ITransportPatternInStatement | Process statement for transporting in multiple products to a pattern.
Public interface | ITransportProtocol | A transportation sender and target behaviour used to customize and standardize transportation process.
Public interface | ITransportSystem | Manager service for ITransportNode and ITransportLink objects that form a transportation graph.
Public interface | ITriangleSet | Interface for triangle sets.
Public interface | ITwoDirectionalPath | Two-directional path behavior used to move components along a path.
Public interface | ITwoWayPath |
Public interface | IU3DRecorder |
Public interface | IUndoHelper | Undo helper utility interface
Public interface | IUndoService | UndoService implements a linear model undo that tracks changesets and allows reverting objects back to their previous state as well as redoing undone operations.
Public interface | IUnionProperty | Union property interface.
Public interface | IUnit | Unit of measure object interface.
Public interface | IUnitFamily | Interface representing a group of units of the same measuring system.
Public interface | IUnitGroup | Interface representing a group of units of the same quantity and unit family.
Public interface | IUnitManager | Unit manager interface.
Public interface | IUnknownStatement | Interface for statements that could not be deserialized by IProgramSerializer.
Public interface | IUriProperty |
Public interface | IUrlHelper | URL helper interface, because the .NET Uri class is broken.
Public interface | IUserMaterialLibraryService | Service that provides methods to load, save or update user materials
Public interface | IUserSettingService | User setting interface
Public interface | IWaitDigitalInputStatement |
Public interface | IWaitPropertyConditionStatement | Waits until a property with VariableName fulfills the condition of ConditionExpression.
Public interface | IWaitSignalStatement | Process statement for waiting until a signal is triggered with value matching a condition.
Public interface | IWaitTransportStatement | Blocks and waits for one or more transport operations started by IStartTransportInStatement or IStartTransportOutStatement to complete. Transport operations are identified by ProductVariableName used in those statements.
Public interface | IWedgeFeature | Wedge feature interface
Public interface | IVehicle | Vehicle behavior that provides automnoumous movement scheduling for components.
Public interface | IWhileStatement |
Public interface | IVideoRecorder |
Public interface | IVideoRecordExporter | Video recording exporter
Public interface | IView3D |
Public interface | IViewport |
Public interface | IViewStatement |
Public interface | IWindow3D |
Public interface | IWindowSection | Configuration file section for window options.
Public interface | IVisitable | Nodes that allow visitors should implement this interface.
Public interface | IVisualObject | IVisualObjects are objects that can be manipulated using its position matrix.
Public interface | IVolumeSensor | Sensor behavior that uses bounding box to detect geometry.
Public interface | IWorkStatement | Reserves one resource from an IPythonTransportController to work in the process for the duration.
Public interface | IWrapper | Defines an interface for accessing a wrapped native object through a pointer.
Delegates
 | Delegate | Description
Public delegate | SimulationTimeCallback | Delegate type for scheduled simulation callbacks.
Enumerations
 | Enumeration | Description
Public enumeration | AccuracyMethod | Defines the zone of accuracy type to use for the target.
Public enumeration | ACIS | ACIS -> Up to 2019
Public enumeration | Action | Action enumeration.
Public enumeration | AmbientOcclusionMode | Defines if geometry shading uses Ambient Occlusion rendering.
Public enumeration | AnimationMessage |
Public enumeration | AnimationRecordingMethod |
Public enumeration | AppBootstrapperHelperELoadStep | Loading modules step.
Public enumeration | ASCIIPointCloudFile | ASCII Point Cloud file
Public enumeration | AutodeskInventor | Autodesk Inventor -> Up to 2020
Public enumeration | AutoPlugFlowDirection | Defines the allowed flow direction used by IAutoPlugPlayService
Public enumeration | BackfaceMode |
Public enumeration | BehaviorType | Behavior type
Public enumeration | BinaryPointCloudFile | Binary point cloud point
Public enumeration | BufferMode | Options for product output order in IBufferProductsStatement.
Public enumeration | CADSummary | CAD import summary report
Public enumeration | CameraAnimationTime |
Public enumeration | CatiaV4 | Catia V4 -> Up to 4.2.5
Public enumeration | CatiaV5 | Catia V5 -> Up to V5-6 R2019 (R29)
Public enumeration | CatiaV6 | Catia V6 -> up to 2013x
Public enumeration | ChartDataType | Type of information stored in IStatisticsChartBase.DataRows.
Public enumeration | ChartTileState | Represents the state of an individual tile
Public enumeration | ChartTileType | Layout position state: either placeholder or chart. Note: DummyTile is used only internally.
Public enumeration | ChartType | Statistics chart type.
Public enumeration | ClippingMode | Clipping mode enumeration
Public enumeration | CloningMode | Cloning mode enumeration.
Public enumeration | CollisionMessageType | Defines the collision message type.
Public enumeration | ColorConfiguration | Type of the geometry set
Public enumeration | CompletionType | Completion type enumeration.
Public enumeration | ConfigurationMode | Defines the robot's joint configuration during linear interpolation.
Public enumeration | ConfigurationWarnings | State of motion target inverse kinematics.
Public enumeration | ConnectorTestLocation | Conditions for testing behavior capacity.
Public enumeration | ConnectorType | Types of connectors.
Public enumeration | CoordinateSystem |
Public enumeration | Creo | Creo -> Pro/Engineer 19.0 to Creo 6.0
Public enumeration | CurveType | Curve type
Public enumeration | CustomSimulationUpdateType |
Public enumeration | DatabaseChangeType |
Public enumeration | DefaultUnit | DefaultUnit option restricted to those formats where unit never exists or is unreliable (U3D, CGR, STL, VRML)
Public enumeration | DegreeOfFreedom |
Public enumeration | DimensionType | Dimension type enumeration.
Public enumeration | DistinctionLevel | Level of difference between properties in a union property.
Public enumeration | DistributionType | Distribution type enumeration Remarks Determines the type of a IDistributionProperty
Public enumeration | DoEventsMethod |
Public enumeration | DWGInternalVersion | Internal version AutoCAD
Public enumeration | E3DStudio | 3D Studio
Public enumeration | E3MF | 3D Manufacturing Format
Public enumeration | EdgeColor |
Public enumeration | EdgeShading |
Public enumeration | EulerRotationOrder |
Public enumeration | ExecuteCommandResult | result type of executing command
Public enumeration | FaceType | Type of the geometry set
Public enumeration | Fbx | ASCII: from 7100 to 7400. Binary: all.
Public enumeration | FeatureMatch | Product feature comparison result type
Public enumeration | FeatureOperationLevel | Some actions require to specify a level of details when working with features
Public enumeration | FeatureTreeStructure | CAD import feature tree reading structure
Public enumeration | FeatureType | Different features available for creating components
Public enumeration | FunctionType | Function type enumeration.
Public enumeration | GenericEventType | Event type.
Public enumeration | GeometryFace | Faces Handling
Public enumeration | GeometrySetType | Type of the geometry set
Public enumeration | GeoPrimitiveType |
Public enumeration | GetAssemblyDataSource | Options for input source in IGetAssemblyStatement.
Public enumeration | GetAssemblyStepSelectionMode | Options for assembly step selection in IGetAssemblyStatement.
Public enumeration | HiddenPartsImport | CAD import hidden (visible) parts
Public enumeration | HierarchyChangeType | Specifies the type of a change in a feature hierarchy
Public enumeration | Ideas | I-deas -> Up to 13.x (NX 5), NX I-deas 6
Public enumeration | IFC | IFC -> IFC2x Editions 2, 3 and 4
Public enumeration | Iges | Iges -> 5.1, 5.2, 5.3
Public enumeration | ImageFormat | Image format
Public enumeration | IMaterialTextureFilter | Defines texture filtering modes for a texture rendering.
Public enumeration | IndicationStyle | Annotation attachment point indication style enumeration.
Public enumeration | InteractMode |
Public enumeration | JointAxis | Joint axis enumeration
Public enumeration | JointControlType | Joint control type.
Public enumeration | JointLimitTests |
Public enumeration | JointLimitTestSettings |
Public enumeration | JointTurnMode | Defines joint turn changes during linear interpolation.
Public enumeration | JointType | Joint type enumeration
Public enumeration | JT | JT -> Up to v10.0
Public enumeration | LicenseFeaturesFeatures | License Features
Public enumeration | LicenseState | State of licensing.
Public enumeration | LicensingHelperActivationLicenseType | The product license source type
Public enumeration | LicensingHelperLicenseWarning | License warning status.
Public enumeration | ManipulationMode |
Public enumeration | ManipulatorToolType |
Public enumeration | MaterialInheritance |
Public enumeration | MessageLevel | Message level.
Public enumeration | MotionPathDirection | Motion path directions.
Public enumeration | MotionPathInterpolation | Motion path interpolation
Public enumeration | MotionType | Interpolation type: point-to-point or linear.
Public enumeration | MouseInteractionType | Defines the type of interaction on an interactive node.
Public enumeration | NodeEntryScope | Defines the scope of NodeListEntry.
Public enumeration | NodeEntryType | Defines the type of NodeListEntry.
Public enumeration | NodeTreeStructure | CAD import into 1 node, many nodes or components
Public enumeration | NodeVisibilityStateChange | Defines how to change the ISimNode visibility with ISetNodeMaterialStatement.
Public enumeration | ObjectSelectionMode | Contains a list of available selection modes.
Public enumeration | OperationType |
Public enumeration | OrientationInterpolationMode | Interpolation method used for orientation.
Public enumeration | OutlineStyle | Annotation text outline style enumeration.
Public enumeration | PackFolderState | Pack folder state.
Public enumeration | Parasolid | Parasolid
Public enumeration | PathSnapperCornerStyle |
Public enumeration | PdbPlugin | Igrip/Quest/VNC geometry
Public enumeration | PdfExportLevel |
Public enumeration | PickFilter |
Public enumeration | PickPrimitives |
Public enumeration | PlugStatus |
Public enumeration | PositionStatus | State of motion target inverse kinematics. Note: Currently the NoSingularity flag is not checked in IsStatusValid.
Public enumeration | PRC | PRC -> All Versions
Public enumeration | PresetMode |
Public enumeration | PrimitiveType |
Public enumeration | ProcessDelayTimeSource | Options for delay time source in IProcessDelayStatement.
Public enumeration | ProcessWorkStatementTimeSource | Options for process time source in IWorkStatement.
Public enumeration | ProductCreatorFeedMode | Feed mode options for FeedMode selection.
Public enumeration | ProductLicenseType | The product license source type
Public enumeration | PropertyConstraintType | Property constraint type enumeration.
Public enumeration | PropertyContainerChangeType | Property change type enumeration.
Public enumeration | PropertyExceptionErrorType | Type of error that occured.
Public enumeration | PythonActionCommandType | CommandType defines what type of command python action invokes when executed.
Public enumeration | ReaderType | Application readers type
Public enumeration | RecordingType | Recording typess
Public enumeration | RenderEffectMode | List of available rendering effects.
Public enumeration | RenderingQuality |
Public enumeration | RenderShading |
Public enumeration | Revit | Revit
Public enumeration | Rhino | Rhino -> 4, 5
Public enumeration | RobFace | RobFace r4
Public enumeration | RobotConversionStatus | Robot conversion statuses.
Public enumeration | RobotFrameIpoMode | Robot frame IPO mode enumeration.
Public enumeration | RotationCoordinateSystem |
Public enumeration | RouteTransportSolutionStatementRuleType | Used in IRouteTransportSolutionStatement.
Public enumeration | SelectionTypes |
Public enumeration | SimEventSchedulingOrder | Options for user event execution order in simulation scheduler relative to other events scheduled at the same simulation time.
Public enumeration | SimInterfaceFieldType | Interface field types.
Public enumeration | SimplifiedGeometryType | Type of simplification.
Public enumeration | SimulationLevel |
Public enumeration | SimulationState |
Public enumeration | SimulationTimeMode |
Public enumeration | SnapPrimitiveMethod |
Public enumeration | SnapType | Snap filters and results.
Public enumeration | SolidEdge | SolidEdge -> V19 - 20, ST - ST7
Public enumeration | SolidWorks | SolidWorks -> From 97 up to 2017
Public enumeration | SourceVariableType | Can be used when it is to select from what type of property to get some real value, e.g. time, from, if there is just one of each type.
Public enumeration | State | Container states used in collecting statistics.
Public enumeration | StaticPdf | Static PDF
Public enumeration | StatisticsFlowDirection | Direction of component's transfer used in the flow-type statistics.
Public enumeration | STEP | STEP -> AP 203 E1/E2, AP 214, AP 242
Public enumeration | STL | STL (Stereo lithography file)
Public enumeration | SubInstallationESubInstallationType | Available sub installations
Public enumeration | SweptVolumeMethod | Enumeration for the method to be used when doing the swept volume.
Public enumeration | SweptVolumeRepresentation | Enumeration for how the list node will be represented when doing the swept volume.
Public enumeration | TargetMode | Target matrix relationship with a robot.
Public enumeration | TessellationDetail | CAD import tessellation detail quality
Public enumeration | TimerStatementMode | The mode a ITimerStatement will be used in.
Public enumeration | TraceStep | Python trace event type.
Public enumeration | TransparencyQuality |
Public enumeration | TransportInType | Options for product arrival for ITransportInStatement.
Public enumeration | TransportOutType | Options for product leaving for ITransportOutStatement.
Public enumeration | TransportStatementMode | Operation options in PM transport statements.
Public enumeration | TypeOfNode |
Public enumeration | U3D | U3D -> ECMA-363 (1st, 2nd and 3rd editions)
Public enumeration | UndoScopeOption | UndoScopeOption defines behavior of nested undo scopes.
Public enumeration | UndoState | Declares available states for UndoService.
Public enumeration | Unigraphics | (Siemens PLM Software NX) Unigraphics -> V11.0 to NX 9.0
Public enumeration | UpAxis | Axis from the CAD file that points up
Public enumeration | Wavefront | OBJ format
Public enumeration | VDA | VDA -> Version 1.0 and 2.0
Public enumeration | VectorDrawingFormat | List of Auto desk RealDWG formats.
Public enumeration | VideoCodec | Video recording available codecs
Public enumeration | VideoFormat | Video recording available formats
Public enumeration | ViewAnimationMode |
Public enumeration | ViewApplyOptions |
Public enumeration | VRML | VRML -> V1.0 and V2.0
Public enumeration | ZoomMode | Zoom mode enumaration

(C) Visual Components

Send comments on this topic to support@visualcomponents.com


AbstractSimInterfaceConnectionChange Class

Stores Undo/Redo information for interface connections done in the interface connection editor.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DChange
VisualComponents.Create3DAbstractSimInterfaceConnectionChange

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class AbstractSimInterfaceConnectionChange : Change
public ref class AbstractSimInterfaceConnectionChange sealed : public Change

The AbstractSimInterfaceConnectionChange type exposes the following members.

Constructors
 | Name | Description
Public method | AbstractSimInterfaceConnectionChange | Any kind of change can be supplied as parameter, but now we only Undo and Redo connections between the interfaces.
Top
Properties
 | Name | Description
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from Change.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
RedoRequest |
UndoRequest |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


AbstractSimInterfaceConnectionChange Constructor

Any kind of change can be supplied as parameter, but now we only Undo and Redo connections between the interfaces.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AbstractSimInterfaceConnectionChange(
    Object change,
    IApplication application
)
public:
AbstractSimInterfaceConnectionChange(
    Object^ change,
    IApplication^ application
)

Parameters

change
Type: SystemObject
application
Type: VisualComponents.Create3DIApplication
See Also

Reference

AbstractSimInterfaceConnectionChange Class
VisualComponents.Create3D Namespace


AbstractSimInterfaceConnectionChange Properties

The AbstractSimInterfaceConnectionChange type exposes the following members.

Properties
 | Name | Description
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Top
See Also

Reference

AbstractSimInterfaceConnectionChange Class
VisualComponents.Create3D Namespace


AbstractSimInterfaceConnectionChange Methods

The AbstractSimInterfaceConnectionChange type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from Change.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AbstractSimInterfaceConnectionChange Class
VisualComponents.Create3D Namespace


AbstractSimInterfaceConnectionChange Fields

The AbstractSimInterfaceConnectionChange type exposes the following members.

Fields
Name | Description
RedoRequest |
UndoRequest |
Top
See Also

Reference

AbstractSimInterfaceConnectionChange Class
VisualComponents.Create3D Namespace


AbstractSimInterfaceConnectionChange.RedoRequest Field

Visual Components Public API Reference

AbstractSimInterfaceConnectionChangeRedoRequest Field

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static EventHandler<Object> RedoRequest
public:
static EventHandler<Object^>^ RedoRequest

Field Value

Type: EventHandlerObject
See Also

Reference

AbstractSimInterfaceConnectionChange Class
VisualComponents.Create3D Namespace


AbstractSimInterfaceConnectionChange.UndoRequest Field

AbstractSimInterfaceConnectionChangeUndoRequest Field

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static EventHandler<Object> UndoRequest
public:
static EventHandler<Object^>^ UndoRequest

Field Value

Type: EventHandlerObject
See Also

Reference

AbstractSimInterfaceConnectionChange Class
VisualComponents.Create3D Namespace


AccuracyMethod Enumeration

Defines the zone of accuracy type to use for the target.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum AccuracyMethod
public enum class AccuracyMethod
Members
Member name | Value | Description
Time | 0 | Time based accuracy. Interpolation starts moving towards the next target when time is right.
Distance | 1 | Distance based accuracy. Interpolation starts moving towards the next target when distance is small enough.
Velocity | 2 | Velocity based accuracy. Interpolation starts moving towards the next target when velocity is low enough.
See Also

Reference

VisualComponents.Create3D Namespace


ACIS Enumeration

ACIS -> Up to 2019

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ACIS
public enum class ACIS
Members
Member name | Value | Description
SAT | 0 |
SAB | 1 |
See Also

Reference

VisualComponents.Create3D Namespace


Action Enumeration

Action enumeration.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum Action
public enum class Action
Members
Member name | Value | Description
Invalid | 0 | Invalid value.
Translate | 1 | Translate transform.
ObjectRotate | 2 | Rotate transform.
Decimate | 3 | Decimate.
Measure | 4 | Measure.
Manipulate | 5 | Combined rotate & translate transforms.
Custom | 6 | Custom.
Select | 7 | Single selection
AreaSelect | 8 | Area selection.
LassoSelect | 9 | Lasso selection.
PlugPlay | 10 | Physical plug and play.
PlugPlayLogical | 11 | Logical plug and play.
Interact | 12 | Interact.
Pick | 13 | Pick.
SnapAction | 14 | SnapAction
SnapPrimitive | 15 | Snap.
SnapAim | 16 | Snap by dragging the aim part of manipulation handles.
SnapByDragging | 17 | Snap with shift+lmb dragging.
See Also

Reference

VisualComponents.Create3D Namespace


ActiveComponentChangedEventArgs Class

Event data for ActiveComponentChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DActiveComponentChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ActiveComponentChangedEventArgs : EventArgs
public ref class ActiveComponentChangedEventArgs : public EventArgs

The ActiveComponentChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ActiveComponentChangedEventArgs | Initializes a new instance of the ActiveComponentChangedEventArgs class.
Top
Properties
 | Name | Description
Public property | ActiveComponent | Gets the active component.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ActiveComponentChangedEventArgs Constructor

Initializes a new instance of the ActiveComponentChangedEventArgs class.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActiveComponentChangedEventArgs(
    ISimComponent activeComponent
)
public:
ActiveComponentChangedEventArgs(
    ISimComponent^ activeComponent
)

Parameters

activeComponent
Type: VisualComponents.Create3DISimComponent
See Also

Reference

ActiveComponentChangedEventArgs Class
VisualComponents.Create3D Namespace


ActiveComponentChangedEventArgs Properties

The ActiveComponentChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ActiveComponent | Gets the active component.
Top
See Also

Reference

ActiveComponentChangedEventArgs Class
VisualComponents.Create3D Namespace


ActiveComponentChangedEventArgs.ActiveComponent Property

ActiveComponentChangedEventArgsActiveComponent Property

Gets the active component.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimComponent ActiveComponent { get; }
public:
property ISimComponent^ ActiveComponent {
    ISimComponent^ get ();
}

Property Value

Type: ISimComponent
See Also

Reference

ActiveComponentChangedEventArgs Class
VisualComponents.Create3D Namespace


ActiveComponentChangedEventArgs Methods

The ActiveComponentChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ActiveComponentChangedEventArgs Class
VisualComponents.Create3D Namespace


ActiveNodeChangedEventArgs Class

Event data for ActiveNodeChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DActiveNodeChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ActiveNodeChangedEventArgs : EventArgs
public ref class ActiveNodeChangedEventArgs : public EventArgs

The ActiveNodeChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ActiveNodeChangedEventArgs | Initializes a new instance of the ActiveNodeChangedEventArgs class.
Top
Properties
 | Name | Description
Public property | ActiveNode | Gets the active node.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ActiveNodeChangedEventArgs Constructor

Initializes a new instance of the ActiveNodeChangedEventArgs class.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActiveNodeChangedEventArgs(
    ISimNode activeNode
)
public:
ActiveNodeChangedEventArgs(
    ISimNode^ activeNode
)

Parameters

activeNode
Type: VisualComponents.Create3DISimNode
See Also

Reference

ActiveNodeChangedEventArgs Class
VisualComponents.Create3D Namespace


ActiveNodeChangedEventArgs Properties

The ActiveNodeChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ActiveNode | Gets the active node.
Top
See Also

Reference

ActiveNodeChangedEventArgs Class
VisualComponents.Create3D Namespace


ActiveNodeChangedEventArgs.ActiveNode Property

ActiveNodeChangedEventArgsActiveNode Property

Gets the active node.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimNode ActiveNode { get; }
public:
property ISimNode^ ActiveNode {
    ISimNode^ get ();
}

Property Value

Type: ISimNode
See Also

Reference

ActiveNodeChangedEventArgs Class
VisualComponents.Create3D Namespace


ActiveNodeChangedEventArgs Methods

The ActiveNodeChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ActiveNodeChangedEventArgs Class
VisualComponents.Create3D Namespace


ActiveRobotChangeEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DActiveRobotChangeEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ActiveRobotChangeEventArgs : EventArgs
public ref class ActiveRobotChangeEventArgs : public EventArgs

The ActiveRobotChangeEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ActiveRobotChangeEventArgs(IRobot, IRobot) | Initializes a new instance of the ActiveRobotChangeEventArgs class
Public method | ActiveRobotChangeEventArgs(IRobot, IRobot, IServoController) | Initializes a new instance of the ActiveRobotChangeEventArgs class
Top
Properties
 | Name | Description
Public property | CurrentController |
Public property | CurrentRobot |
Public property | PreviousRobot |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ActiveRobotChangeEventArgs Constructor

Overload List
 | Name | Description
Public method | ActiveRobotChangeEventArgs(IRobot, IRobot) | Initializes a new instance of the ActiveRobotChangeEventArgs class
Public method | ActiveRobotChangeEventArgs(IRobot, IRobot, IServoController) | Initializes a new instance of the ActiveRobotChangeEventArgs class
Top
See Also

Reference

ActiveRobotChangeEventArgs Class
VisualComponents.Create3D Namespace


ActiveRobotChangeEventArgs Constructor (IRobot, IRobot)

Initializes a new instance of the ActiveRobotChangeEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActiveRobotChangeEventArgs(
    IRobot newRobot,
    IRobot previousRobot
)
public:
ActiveRobotChangeEventArgs(
    IRobot^ newRobot,
    IRobot^ previousRobot
)

Parameters

newRobot
Type: VisualComponents.Create3DIRobot
previousRobot
Type: VisualComponents.Create3DIRobot
See Also

Reference

ActiveRobotChangeEventArgs Class
ActiveRobotChangeEventArgs Overload
VisualComponents.Create3D Namespace


ActiveRobotChangeEventArgs Constructor (IRobot, IRobot, IServoController)

Initializes a new instance of the ActiveRobotChangeEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActiveRobotChangeEventArgs(
    IRobot newRobot,
    IRobot previousRobot,
    IServoController currentController
)
public:
ActiveRobotChangeEventArgs(
    IRobot^ newRobot,
    IRobot^ previousRobot,
    IServoController^ currentController
)

Parameters

newRobot
Type: VisualComponents.Create3DIRobot
previousRobot
Type: VisualComponents.Create3DIRobot
currentController
Type: VisualComponents.Create3DIServoController
See Also

Reference

ActiveRobotChangeEventArgs Class
ActiveRobotChangeEventArgs Overload
VisualComponents.Create3D Namespace


ActiveRobotChangeEventArgs Properties

The ActiveRobotChangeEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | CurrentController |
Public property | CurrentRobot |
Public property | PreviousRobot |
Top
See Also

Reference

ActiveRobotChangeEventArgs Class
VisualComponents.Create3D Namespace


ActiveRobotChangeEventArgs.CurrentController Property

ActiveRobotChangeEventArgsCurrentController Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IServoController CurrentController { get; }
public:
property IServoController^ CurrentController {
    IServoController^ get ();
}

Property Value

Type: IServoController
See Also

Reference

ActiveRobotChangeEventArgs Class
VisualComponents.Create3D Namespace


ActiveRobotChangeEventArgs.CurrentRobot Property

ActiveRobotChangeEventArgsCurrentRobot Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IRobot CurrentRobot { get; }
public:
property IRobot^ CurrentRobot {
    IRobot^ get ();
}

Property Value

Type: IRobot
See Also

Reference

ActiveRobotChangeEventArgs Class
VisualComponents.Create3D Namespace


ActiveRobotChangeEventArgs.PreviousRobot Property

ActiveRobotChangeEventArgsPreviousRobot Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IRobot PreviousRobot { get; }
public:
property IRobot^ PreviousRobot {
    IRobot^ get ();
}

Property Value

Type: IRobot
See Also

Reference

ActiveRobotChangeEventArgs Class
VisualComponents.Create3D Namespace


ActiveRobotChangeEventArgs Methods

The ActiveRobotChangeEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ActiveRobotChangeEventArgs Class
VisualComponents.Create3D Namespace


ActiveWindowChangedEventArgs Class

Event arguments for ActiveWindowChanged event
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DActiveWindowChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ActiveWindowChangedEventArgs : EventArgs
public ref class ActiveWindowChangedEventArgs : public EventArgs

The ActiveWindowChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ActiveWindowChangedEventArgs | Initializes a new instance of the ActiveWindowChangedEventArgs class
Top
Properties
 | Name | Description
Public property | NewWindow |
Public property | OldWindow |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ActiveWindowChangedEventArgs Constructor

Initializes a new instance of the ActiveWindowChangedEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActiveWindowChangedEventArgs(
    IWindow3D oldWindow,
    IWindow3D newWindow
)
public:
ActiveWindowChangedEventArgs(
    IWindow3D^ oldWindow,
    IWindow3D^ newWindow
)

Parameters

oldWindow
Type: VisualComponents.Create3DIWindow3D
newWindow
Type: VisualComponents.Create3DIWindow3D
See Also

Reference

ActiveWindowChangedEventArgs Class
VisualComponents.Create3D Namespace


ActiveWindowChangedEventArgs Properties

The ActiveWindowChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewWindow |
Public property | OldWindow |
Top
See Also

Reference

ActiveWindowChangedEventArgs Class
VisualComponents.Create3D Namespace


ActiveWindowChangedEventArgs.NewWindow Property

ActiveWindowChangedEventArgsNewWindow Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IWindow3D NewWindow { get; }
public:
property IWindow3D^ NewWindow {
    IWindow3D^ get ();
}

Property Value

Type: IWindow3D
See Also

Reference

ActiveWindowChangedEventArgs Class
VisualComponents.Create3D Namespace


ActiveWindowChangedEventArgs.OldWindow Property

ActiveWindowChangedEventArgsOldWindow Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IWindow3D OldWindow { get; }
public:
property IWindow3D^ OldWindow {
    IWindow3D^ get ();
}

Property Value

Type: IWindow3D
See Also

Reference

ActiveWindowChangedEventArgs Class
VisualComponents.Create3D Namespace


ActiveWindowChangedEventArgs Methods

The ActiveWindowChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ActiveWindowChangedEventArgs Class
VisualComponents.Create3D Namespace


AddOnConfigCollection Class

Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationElementCollection
VisualComponents.Create3DAddOnConfigCollection

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class AddOnConfigCollection : ConfigurationElementCollection,
    ICollection<AddOnConfigElement>, IEnumerable<AddOnConfigElement>, IEnumerable
public ref class AddOnConfigCollection : public ConfigurationElementCollection,
    ICollection<AddOnConfigElement^>, IEnumerable<AddOnConfigElement^>, IEnumerable

The AddOnConfigCollection type exposes the following members.

Constructors
 | Name | Description
Public method | AddOnConfigCollection | Initializes a new instance of the AddOnConfigCollection class
Top
Properties
 | Name | Description
Protected property | AddElementName | Gets or sets the name of the ConfigurationElement to associate with the add operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected property | ClearElementName | Gets or sets the name for the ConfigurationElement to associate with the clear operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementName | Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is . (Inherited from ConfigurationElement.)
Public property | IsReadOnly |
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Public property | ItemInt32 |
Public property | ItemString |
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Protected property | RemoveElementName | Gets or sets the name of the ConfigurationElement to associate with the remove operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected property | ThrowOnDuplicate | Gets a value indicating whether an attempt to add a duplicate ConfigurationElement to the ConfigurationElementCollection will cause an exception to be thrown. (Inherited from ConfigurationElementCollection.)
Top
Methods
 | Name | Description
Public method | Add |
Protected method | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseClear | Removes all configuration element objects from the collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGet(Object) | Returns the configuration element with the specified key. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGet(Int32) | Gets the configuration element at the specified index location. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGetAllKeys | Returns an array of the keys for all of the configuration elements contained in the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGetKey | Gets the key for the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
Protected method | BaseIndexOf | Indicates the index of the specified ConfigurationElement. (Inherited from ConfigurationElementCollection.)
Protected method | BaseIsRemoved | Indicates whether the ConfigurationElement with the specified key has been removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseRemove | Removes a ConfigurationElement from the collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseRemoveAt | Removes the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
Public method | Clear |
Public method | Contains |
Public method | CopyTo(ConfigurationElement, Int32) | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | CopyTo(AddOnConfigElement, Int32) |
Protected method | CreateNewElement | (Overrides ConfigurationElementCollectionCreateNewElement.)
Protected method | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetElementKey | (Overrides ConfigurationElementCollectionGetElementKey(ConfigurationElement).)
Public method | GetEnumerator |
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsElementName | Indicates whether the specified ConfigurationElement exists in the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | IsElementRemovable | Indicates whether the specified ConfigurationElement can be removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | IsModified | Indicates whether this ConfigurationElementCollection has been modified since it was last saved or loaded when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Causes the configuration system to throw an exception. (Inherited from ConfigurationElementCollection.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Public method | Remove(String) |
Public method | Remove(AddOnConfigElement) |
Protected method | Reset | Resets the ConfigurationElementCollection to its unmodified state when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | ResetModified | Resets the value of the IsModified property to when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | SerializeElement | Writes the configuration data to an XML element in the configuration file when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElementCollection object and for all sub-elements. (Inherited from ConfigurationElementCollection.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Reverses the effect of merging configuration information from different levels of the configuration hierarchy (Inherited from ConfigurationElementCollection.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachAddOnConfigElement | Enumerate a cached collection performing the specified action on each item. (Defined by ForEachHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | HasMoreThanAddOnConfigElement | (Defined by EnumerableHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToObservableCollectionAddOnConfigElement | (Defined by Extensions.)
Public Extension Method | ToObservableCollectionExAddOnConfigElement | (Defined by Extensions.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


AddOnConfigCollection Constructor

Initializes a new instance of the AddOnConfigCollection class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddOnConfigCollection()
public:
AddOnConfigCollection()
See Also

Reference

AddOnConfigCollection Class
VisualComponents.Create3D Namespace


AddOnConfigCollection Properties

The AddOnConfigCollection type exposes the following members.

Properties
 | Name | Description
Protected property | AddElementName | Gets or sets the name of the ConfigurationElement to associate with the add operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected property | ClearElementName | Gets or sets the name for the ConfigurationElement to associate with the clear operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementName | Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is . (Inherited from ConfigurationElement.)
Public property | IsReadOnly |
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Public property | ItemInt32 |
Public property | ItemString |
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Protected property | RemoveElementName | Gets or sets the name of the ConfigurationElement to associate with the remove operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected property | ThrowOnDuplicate | Gets a value indicating whether an attempt to add a duplicate ConfigurationElement to the ConfigurationElementCollection will cause an exception to be thrown. (Inherited from ConfigurationElementCollection.)
Top
See Also

Reference

AddOnConfigCollection Class
VisualComponents.Create3D Namespace


AddOnConfigCollection.IsReadOnly Property

AddOnConfigCollectionIsReadOnly Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsReadOnly { get; }
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ICollectionTIsReadOnly
See Also

Reference

AddOnConfigCollection Class
VisualComponents.Create3D Namespace


AddOnConfigCollection.Item Property

AddOnConfigCollectionItem Property

Overload List
 | Name | Description
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Public property | ItemInt32 |
Public property | ItemString |
Top
See Also

Reference

AddOnConfigCollection Class
VisualComponents.Create3D Namespace


AddOnConfigCollection.Item Property (Int32)

AddOnConfigCollectionItem Property (Int32)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddOnConfigElement this[
    int index
] { get; }
public:
property AddOnConfigElement^ default[int index] {
    AddOnConfigElement^ get (int index);
}

Parameters

index
Type: SystemInt32

Property Value

Type: AddOnConfigElement
See Also

Reference

AddOnConfigCollection Class
Item Overload
VisualComponents.Create3D Namespace


AddOnConfigCollection.Item Property (String)

AddOnConfigCollectionItem Property (String)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddOnConfigElement this[
    string key
] { get; set; }
public:
property AddOnConfigElement^ default[String^ key] {
    AddOnConfigElement^ get (String^ key);
    void set (String^ key, AddOnConfigElement^ value);
}

Parameters

key
Type: SystemString

Property Value

Type: AddOnConfigElement
See Also

Reference

AddOnConfigCollection Class
Item Overload
VisualComponents.Create3D Namespace


AddOnConfigCollection Methods

The AddOnConfigCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Protected method | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseClear | Removes all configuration element objects from the collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGet(Object) | Returns the configuration element with the specified key. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGet(Int32) | Gets the configuration element at the specified index location. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGetAllKeys | Returns an array of the keys for all of the configuration elements contained in the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGetKey | Gets the key for the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
Protected method | BaseIndexOf | Indicates the index of the specified ConfigurationElement. (Inherited from ConfigurationElementCollection.)
Protected method | BaseIsRemoved | Indicates whether the ConfigurationElement with the specified key has been removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseRemove | Removes a ConfigurationElement from the collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseRemoveAt | Removes the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
Public method | Clear |
Public method | Contains |
Public method | CopyTo(ConfigurationElement, Int32) | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | CopyTo(AddOnConfigElement, Int32) |
Protected method | CreateNewElement | (Overrides ConfigurationElementCollectionCreateNewElement.)
Protected method | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetElementKey | (Overrides ConfigurationElementCollectionGetElementKey(ConfigurationElement).)
Public method | GetEnumerator |
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsElementName | Indicates whether the specified ConfigurationElement exists in the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | IsElementRemovable | Indicates whether the specified ConfigurationElement can be removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | IsModified | Indicates whether this ConfigurationElementCollection has been modified since it was last saved or loaded when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Causes the configuration system to throw an exception. (Inherited from ConfigurationElementCollection.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Public method | Remove(String) |
Public method | Remove(AddOnConfigElement) |
Protected method | Reset | Resets the ConfigurationElementCollection to its unmodified state when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | ResetModified | Resets the value of the IsModified property to when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | SerializeElement | Writes the configuration data to an XML element in the configuration file when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElementCollection object and for all sub-elements. (Inherited from ConfigurationElementCollection.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Reverses the effect of merging configuration information from different levels of the configuration hierarchy (Inherited from ConfigurationElementCollection.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachAddOnConfigElement | Enumerate a cached collection performing the specified action on each item. (Defined by ForEachHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | HasMoreThanAddOnConfigElement | (Defined by EnumerableHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToObservableCollectionAddOnConfigElement | (Defined by Extensions.)
Public Extension Method | ToObservableCollectionExAddOnConfigElement | (Defined by Extensions.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AddOnConfigCollection Class
VisualComponents.Create3D Namespace


AddOnConfigCollection.Add Method

AddOnConfigCollectionAdd Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Add(
    AddOnConfigElement item
)
public:
virtual void Add(
    AddOnConfigElement^ item
) sealed

Parameters

item
Type: AddOnConfigElement

Implements

ICollectionTAdd(T)
See Also

Reference

AddOnConfigCollection Class
VisualComponents.Create3D Namespace


AddOnConfigCollection.Clear Method

AddOnConfigCollectionClear Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Clear()
public:
virtual void Clear() sealed

Implements

ICollectionTClear
See Also

Reference

AddOnConfigCollection Class
VisualComponents.Create3D Namespace


AddOnConfigCollection.Contains Method

AddOnConfigCollectionContains Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Contains(
    AddOnConfigElement item
)
public:
virtual bool Contains(
    AddOnConfigElement^ item
) sealed

Parameters

item
Type: AddOnConfigElement

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.AddOnConfigCollection.Contains(VisualComponents.Create3D.AddOnConfigElement)"]

Implements

ICollectionTContains(T)
See Also

Reference

AddOnConfigCollection Class
VisualComponents.Create3D Namespace


AddOnConfigCollection.CopyTo Method

AddOnConfigCollectionCopyTo Method

Overload List
 | Name | Description
Public method | CopyTo(ConfigurationElement, Int32) | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | CopyTo(AddOnConfigElement, Int32) |
Top
See Also

Reference

AddOnConfigCollection Class
VisualComponents.Create3D Namespace


AddOnConfigCollection.CopyTo Method (AddOnConfigElement[], Int32)

AddOnConfigCollectionCopyTo Method (AddOnConfigElement, Int32)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CopyTo(
    AddOnConfigElement[] array,
    int arrayIndex
)
public:
virtual void CopyTo(
    array<AddOnConfigElement^>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: AddOnConfigElement
arrayIndex
Type: SystemInt32

Implements

ICollectionTCopyTo(T, Int32)
See Also

Reference

AddOnConfigCollection Class
CopyTo Overload
VisualComponents.Create3D Namespace


AddOnConfigCollection.CreateNewElement Method

AddOnConfigCollectionCreateNewElement Method

Overload List
 | Name | Description
Protected method | CreateNewElement | (Overrides ConfigurationElementCollectionCreateNewElement.)
Protected method | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Top
See Also

Reference

AddOnConfigCollection Class
VisualComponents.Create3D Namespace


AddOnConfigCollection.CreateNewElement Method

AddOnConfigCollectionCreateNewElement Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override ConfigurationElement CreateNewElement()
protected:
virtual ConfigurationElement^ CreateNewElement() override

Return Value

Type: ConfigurationElement

[Missing <returns> documentation for "M:VisualComponents.Create3D.AddOnConfigCollection.CreateNewElement"]

See Also

Reference

AddOnConfigCollection Class
CreateNewElement Overload
VisualComponents.Create3D Namespace


AddOnConfigCollection.GetElementKey Method

AddOnConfigCollectionGetElementKey Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Object GetElementKey(
    ConfigurationElement element
)
protected:
virtual Object^ GetElementKey(
    ConfigurationElement^ element
) override

Parameters

element
Type: System.ConfigurationConfigurationElement

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.Create3D.AddOnConfigCollection.GetElementKey(System.Configuration.ConfigurationElement)"]

See Also

Reference

AddOnConfigCollection Class
VisualComponents.Create3D Namespace


AddOnConfigCollection.GetEnumerator Method

AddOnConfigCollectionGetEnumerator Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerator<AddOnConfigElement> GetEnumerator()
public:
virtual IEnumerator<AddOnConfigElement^>^ GetEnumerator() sealed

Return Value

Type: IEnumeratorAddOnConfigElement

[Missing <returns> documentation for "M:VisualComponents.Create3D.AddOnConfigCollection.GetEnumerator"]

Implements

IEnumerableTGetEnumerator
See Also

Reference

AddOnConfigCollection Class
VisualComponents.Create3D Namespace


AddOnConfigCollection.Remove Method

AddOnConfigCollectionRemove Method

Overload List
 | Name | Description
Public method | Remove(String) |
Public method | Remove(AddOnConfigElement) |
Top
See Also

Reference

AddOnConfigCollection Class
VisualComponents.Create3D Namespace


AddOnConfigCollection.Remove Method (String)

AddOnConfigCollectionRemove Method (String)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Remove(
    string name
)
public:
void Remove(
    String^ name
)

Parameters

name
Type: SystemString
See Also

Reference

AddOnConfigCollection Class
Remove Overload
VisualComponents.Create3D Namespace


AddOnConfigCollection.Remove Method (AddOnConfigElement)

AddOnConfigCollectionRemove Method (AddOnConfigElement)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Remove(
    AddOnConfigElement item
)
public:
virtual bool Remove(
    AddOnConfigElement^ item
) sealed

Parameters

item
Type: AddOnConfigElement

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.AddOnConfigCollection.Remove(VisualComponents.Create3D.AddOnConfigElement)"]

Implements

ICollectionTRemove(T)
See Also

Reference

AddOnConfigCollection Class
Remove Overload
VisualComponents.Create3D Namespace


AddOnSetting Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DAddOnSetting

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class AddOnSetting
public ref class AddOnSetting

The AddOnSetting type exposes the following members.

Constructors
 | Name | Description
Public method | AddOnSetting | Initializes a new instance of the AddOnSetting class
Top
Properties
 | Name | Description
Public property | Description |
Public property | IsActivated |
Public property | Order |
Public property | SettingViewModel |
Public property | Title |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


AddOnSetting Constructor

Initializes a new instance of the AddOnSetting class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddOnSetting(
    string title,
    string description,
    bool isActivated,
    Object viewModel,
    uint order
)
public:
AddOnSetting(
    String^ title,
    String^ description,
    bool isActivated,
    Object^ viewModel,
    unsigned int order
)

Parameters

title
Type: SystemString
description
Type: SystemString
isActivated
Type: SystemBoolean
viewModel
Type: SystemObject
order
Type: SystemUInt32
See Also

Reference

AddOnSetting Class
VisualComponents.Create3D Namespace


AddOnSetting Properties

The AddOnSetting type exposes the following members.

Properties
 | Name | Description
Public property | Description |
Public property | IsActivated |
Public property | Order |
Public property | SettingViewModel |
Public property | Title |
Top
See Also

Reference

AddOnSetting Class
VisualComponents.Create3D Namespace


AddOnSetting.Description Property

AddOnSettingDescription Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; protected set; }
public:
property String^ Description {
    String^ get ();
    protected: void set (String^ value);
}

Property Value

Type: String
See Also

Reference

AddOnSetting Class
VisualComponents.Create3D Namespace


AddOnSetting.IsActivated Property

AddOnSettingIsActivated Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsActivated { get; protected set; }
public:
property bool IsActivated {
    bool get ();
    protected: void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AddOnSetting Class
VisualComponents.Create3D Namespace


AddOnSetting.Order Property

AddOnSettingOrder Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint Order { get; protected set; }
public:
property unsigned int Order {
    unsigned int get ();
    protected: void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

AddOnSetting Class
VisualComponents.Create3D Namespace


AddOnSetting.SettingViewModel Property

AddOnSettingSettingViewModel Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object SettingViewModel { get; protected set; }
public:
property Object^ SettingViewModel {
    Object^ get ();
    protected: void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

AddOnSetting Class
VisualComponents.Create3D Namespace


AddOnSetting.Title Property

AddOnSettingTitle Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; protected set; }
public:
property String^ Title {
    String^ get ();
    protected: void set (String^ value);
}

Property Value

Type: String
See Also

Reference

AddOnSetting Class
VisualComponents.Create3D Namespace


AddOnSetting Methods

The AddOnSetting type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AddOnSetting Class
VisualComponents.Create3D Namespace


AmbientOcclusionMode Enumeration

Defines if geometry shading uses Ambient Occlusion rendering.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum AmbientOcclusionMode
public enum class AmbientOcclusionMode
Members
Member name | Value | Description
None | 0 | Disables ambient occlusion rendering for the geometry
Vertex | 1 | Uses vertex texture coordinate U value for ambient occlusion in the rendering
Texture | 2 | Uses applied material texture for ambient occlusion in the rendering
See Also

Reference

VisualComponents.Create3D Namespace


AnimationMessage Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum AnimationMessage
public enum class AnimationMessage
Members
Member name | Value | Description
Unknown | 0 |
ConnectStream | 1 |
StartSocket | 2 |
StartStream | 3 |
AddMaterial | 10 |
AddTexture | 20 |
AddShaderMaterial | 30 |
AddMesh | 40 |
AddSubMesh | 50 |
AddSubLine | 51 |
AddSubMeshTopology | 52 |
AddSubMeshTopologyCurve | 53 |
AddComponent | 60 |
AddNode | 70 |
SetNodeMatrix | 71 |
AddTimestep | 80 |
FinishMessage | 81 |
AddSync | 82 |
AbsoluteKey | 91 |
AbsoluteKey_Old | 90 |
RemoveComponentKey | 92 |
SetParentKey | 100 |
ChangeMeshKey | 111 |
ChangeMeshKey_Old | 110 |
SetUVKey | 120 |
AddView | 130 |
AddCamera | 131 |
CloseStream | 140 |
InvokeMethod | 150 |
PropertyChanged | 160 |
GetProperty | 170 |
SetNodeMaterials | 180 |
PreviewImages | 190 |
SetBackground | 200 |
SetFloor | 210 |
LastMessageId | 210 |
See Also

Reference

VisualComponents.Create3D Namespace


AnimationRecordingMethod Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum AnimationRecordingMethod
public enum class AnimationRecordingMethod
Members
Member name | Value | Description
None | 0 |
WriteVcax | 1 |
StreamToServer | 2 |
StreamToClient | 3 |
See Also

Reference

VisualComponents.Create3D Namespace


AnnotationCreationChange Class

Stores undo/redo information of annotations
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DChange
VisualComponents.Create3DAnnotationCreationChange

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class AnnotationCreationChange : Change
public ref class AnnotationCreationChange sealed : public Change

The AnnotationCreationChange type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationCreationChange | Annotation and world cannot be null
Top
Properties
 | Name | Description
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from Change.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


AnnotationCreationChange Constructor

Annotation and world cannot be null

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AnnotationCreationChange(
    IAnnotation annotation,
    bool isCreationChange,
    ISimWorld world
)
public:
AnnotationCreationChange(
    IAnnotation^ annotation,
    bool isCreationChange,
    ISimWorld^ world
)

Parameters

annotation
Type: VisualComponents.Create3DIAnnotation
isCreationChange
Type: SystemBoolean
world
Type: VisualComponents.Create3DISimWorld
See Also

Reference

AnnotationCreationChange Class
VisualComponents.Create3D Namespace


AnnotationCreationChange Properties

The AnnotationCreationChange type exposes the following members.

Properties
 | Name | Description
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Top
See Also

Reference

AnnotationCreationChange Class
VisualComponents.Create3D Namespace


AnnotationCreationChange Methods

The AnnotationCreationChange type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from Change.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AnnotationCreationChange Class
VisualComponents.Create3D Namespace


AppBootstrapperHelper Class

Common helper methods which are used during loading the application.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DAppBootstrapperHelper

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class AppBootstrapperHelper
public ref class AppBootstrapperHelper abstract sealed

The AppBootstrapperHelper type exposes the following members.

Properties
Name | Description
MainContainer | First composition container created by ConfigureMEF. Used by [!:TryGetMefInstance].
MultipleInstances |
Top
Methods
Name | Description
CleanupBootstrapper | Cleans up the environment. It's called from AppLoader.
GetAppSettingValue | Returns the application setting value without using MEF.
GetFileInfo | Get an assembly FileInfo.
InitLog4netConfig | Helper function to setup log4net configuration settings. It's called from AppLoader or from EmbeddedAppLoader.
InitProductLicenseConfiguration | Initializes the Product license configuration.
LoadAddOns |
LoadAssemblies | loads and configures assemblies.
LoadUserAssembly | Loads additional user assembly and registers it in MEF
LoadUserLanguageConfigSettings | Loads the user language config settings.
LoadUserThemeConfigSettings | Loads the user theme config settings.
Top
Fields
Name | Description
OnLoadProgress |
Top
See Also

Reference

VisualComponents.Create3D Namespace


AppBootstrapperHelper Properties

The AppBootstrapperHelper type exposes the following members.

Properties
Name | Description
MainContainer | First composition container created by ConfigureMEF. Used by [!:TryGetMefInstance].
MultipleInstances |
Top
See Also

Reference

AppBootstrapperHelper Class
VisualComponents.Create3D Namespace


AppBootstrapperHelper.MainContainer Property

AppBootstrapperHelperMainContainer Property

First composition container created by ConfigureMEF. Used by [!:TryGetMefInstance].

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static CompositionContainer MainContainer { get; set; }
public:
static property CompositionContainer^ MainContainer {
    CompositionContainer^ get ();
    void set (CompositionContainer^ value);
}

Property Value

Type: CompositionContainer
See Also

Reference

AppBootstrapperHelper Class
VisualComponents.Create3D Namespace


AppBootstrapperHelper.MultipleInstances Property

AppBootstrapperHelperMultipleInstances Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool MultipleInstances { get; }
public:
static property bool MultipleInstances {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

AppBootstrapperHelper Class
VisualComponents.Create3D Namespace


AppBootstrapperHelper Methods

The AppBootstrapperHelper type exposes the following members.

Methods
Name | Description
CleanupBootstrapper | Cleans up the environment. It's called from AppLoader.
GetAppSettingValue | Returns the application setting value without using MEF.
GetFileInfo | Get an assembly FileInfo.
InitLog4netConfig | Helper function to setup log4net configuration settings. It's called from AppLoader or from EmbeddedAppLoader.
InitProductLicenseConfiguration | Initializes the Product license configuration.
LoadAddOns |
LoadAssemblies | loads and configures assemblies.
LoadUserAssembly | Loads additional user assembly and registers it in MEF
LoadUserLanguageConfigSettings | Loads the user language config settings.
LoadUserThemeConfigSettings | Loads the user theme config settings.
Top
See Also

Reference

AppBootstrapperHelper Class
VisualComponents.Create3D Namespace


AppBootstrapperHelper.CleanupBootstrapper Method

AppBootstrapperHelperCleanupBootstrapper Method

Cleans up the environment.

It's called from AppLoader.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void CleanupBootstrapper()
public:
static void CleanupBootstrapper()
Remarks
It's used for testing purposes only.
See Also

Reference

AppBootstrapperHelper Class
VisualComponents.Create3D Namespace


AppBootstrapperHelper.GetAppSettingValue Method

AppBootstrapperHelperGetAppSettingValue Method

Returns the application setting value without using MEF.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetAppSettingValue(
    string key
)
public:
static String^ GetAppSettingValue(
    String^ key
)

Parameters

key
Type: SystemString
key value

Return Value

Type: String
the path
See Also

Reference

AppBootstrapperHelper Class
VisualComponents.Create3D Namespace


AppBootstrapperHelper.GetFileInfo Method

AppBootstrapperHelperGetFileInfo Method

Get an assembly FileInfo.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static FileInfo GetFileInfo(
    string assemblyName,
    DirectoryInfo directory,
    ILog log = null
)
public:
static FileInfo^ GetFileInfo(
    String^ assemblyName,
    DirectoryInfo^ directory,
    ILog^ log = nullptr
)

Parameters

assemblyName
Type: SystemString
assembly file name
directory
Type: System.IODirectoryInfo
directory info where assembly is located
log (Optional)
Type: ILog
instance of ILog.

Return Value

Type: FileInfo
FileInfo object for assembly
Remarks
This method is called from UX.Launcher project also
See Also

Reference

AppBootstrapperHelper Class
VisualComponents.Create3D Namespace


AppBootstrapperHelper.InitLog4netConfig Method

AppBootstrapperHelperInitLog4netConfig Method

Helper function to setup log4net configuration settings.

It's called from AppLoader or from EmbeddedAppLoader.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void InitLog4netConfig()
public:
static void InitLog4netConfig()
See Also

Reference

AppBootstrapperHelper Class
VisualComponents.Create3D Namespace


AppBootstrapperHelper.InitProductLicenseConfiguration Method

AppBootstrapperHelperInitProductLicenseConfiguration Method

Initializes the Product license configuration.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void InitProductLicenseConfiguration()
public:
static void InitProductLicenseConfiguration()
See Also

Reference

AppBootstrapperHelper Class
VisualComponents.Create3D Namespace


AppBootstrapperHelper.LoadAddOns Method

AppBootstrapperHelperLoadAddOns Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static List<FileInfo> LoadAddOns(
    DirectoryInfo directory
)
public:
static List<FileInfo^>^ LoadAddOns(
    DirectoryInfo^ directory
)

Parameters

directory
Type: System.IODirectoryInfo

Return Value

Type: ListFileInfo

[Missing <returns> documentation for "M:VisualComponents.Create3D.AppBootstrapperHelper.LoadAddOns(System.IO.DirectoryInfo)"]

See Also

Reference

AppBootstrapperHelper Class
VisualComponents.Create3D Namespace


AppBootstrapperHelper.LoadAssemblies Method

AppBootstrapperHelperLoadAssemblies Method

loads and configures assemblies.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static CompositionContainer LoadAssemblies(
    ILog log,
    AppBootstrapperHelperELoadStep loadingStep
)
public:
static CompositionContainer^ LoadAssemblies(
    ILog^ log,
    AppBootstrapperHelperELoadStep loadingStep
)

Parameters

log
Type: ILog
instance of ILog.
loadingStep
Type: VisualComponents.Create3DAppBootstrapperHelperELoadStep
the instance of the loading step.

Return Value

Type: CompositionContainer
instance of MEF object.
See Also

Reference

AppBootstrapperHelper Class
VisualComponents.Create3D Namespace


AppBootstrapperHelper.LoadUserAssembly Method

AppBootstrapperHelperLoadUserAssembly Method

Loads additional user assembly and registers it in MEF

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void LoadUserAssembly(
    ILog log,
    string userAssembly
)
public:
static void LoadUserAssembly(
    ILog^ log,
    String^ userAssembly
)

Parameters

log
Type: ILog
instance of ILog
userAssembly
Type: SystemString
additional assebly name which should be loaded
See Also

Reference

AppBootstrapperHelper Class
VisualComponents.Create3D Namespace


AppBootstrapperHelper.LoadUserLanguageConfigSettings Method

AppBootstrapperHelperLoadUserLanguageConfigSettings Method

Loads the user language config settings.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void LoadUserLanguageConfigSettings()
public:
static void LoadUserLanguageConfigSettings()
See Also

Reference

AppBootstrapperHelper Class
VisualComponents.Create3D Namespace


AppBootstrapperHelper.LoadUserThemeConfigSettings Method

AppBootstrapperHelperLoadUserThemeConfigSettings Method

Loads the user theme config settings.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void LoadUserThemeConfigSettings(
    ILog log
)
public:
static void LoadUserThemeConfigSettings(
    ILog^ log
)

Parameters

log
Type: ILog
logger instance
See Also

Reference

AppBootstrapperHelper Class
VisualComponents.Create3D Namespace


AppBootstrapperHelper Fields

The AppBootstrapperHelper type exposes the following members.

Fields
Name | Description
OnLoadProgress |
Top
See Also

Reference

AppBootstrapperHelper Class
VisualComponents.Create3D Namespace


AppBootstrapperHelper.OnLoadProgress Field

AppBootstrapperHelperOnLoadProgress Field

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Action<string, string> OnLoadProgress
public:
static Action<String^, String^>^ OnLoadProgress

Field Value

Type: ActionString, String
See Also

Reference

AppBootstrapperHelper Class
VisualComponents.Create3D Namespace


AppBootstrapperHelper.ELoadStep Enumeration

AppBootstrapperHelperELoadStep Enumeration

Loading modules step.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ELoadStep
public enum class ELoadStep
Members
Member name | Value | Description
BaseModules | 0 |
CoreModules | 1 |
UXCore | 2 |
UXMainModules | 3 |
OemUXModules | 4 |
AddOns | 5 |
User3rdPartyAssembly | 6 |
See Also

Reference

VisualComponents.Create3D Namespace


AppConfig Class

Usage is like this: using(AppConfig.Change(tempFileName)) { the app.config in tempFileName is used } If you want to change the used app.config for the whole runtime of your application, simply put AppConfig.Change(tempFileName) without the using somewhere at the start of your application. ( http://stackoverflow.com/questions/6150644/change-default-app-config-at-runtime )
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DAppConfig

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract class AppConfig : IDisposable
public ref class AppConfig abstract : IDisposable

The AppConfig type exposes the following members.

Constructors
 | Name | Description
Protected method | AppConfig | Initializes a new instance of the AppConfig class
Top
Methods
 | Name | Description
 | Change | Changes configuration to specific one
Public method | Dispose | Releases all resources used by the AppConfig
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


AppConfig Constructor

Initializes a new instance of the AppConfig class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected AppConfig()
protected:
AppConfig()
See Also

Reference

AppConfig Class
VisualComponents.Create3D Namespace


AppConfig Methods

The AppConfig type exposes the following members.

Methods
 | Name | Description
 | Change | Changes configuration to specific one
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AppConfig Class
VisualComponents.Create3D Namespace


AppConfig.Change Method

AppConfigChange Method

Changes configuration to specific one

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static AppConfig Change(
    string path
)
public:
static AppConfig^ Change(
    String^ path
)

Parameters

path
Type: SystemString
.config file path

Return Value

Type: AppConfig
old configuration
See Also

Reference

AppConfig Class
VisualComponents.Create3D Namespace


AppConfig.Dispose Method

AppConfigDispose Method

Releases all resources used by the AppConfig

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract void Dispose()
public:
virtual void Dispose() abstract

Implements

IDisposableDispose
See Also

Reference

AppConfig Class
VisualComponents.Create3D Namespace


ApplicationContextChangedMessage Class

Message is broadcasted before the application context is about to be changed.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DApplicationContextChangedMessage

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ApplicationContextChangedMessage
public ref class ApplicationContextChangedMessage sealed

The ApplicationContextChangedMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ApplicationContextChangedMessage | Initializes a new instance of the ApplicationContextChangedMessage class
Top
Properties
 | Name | Description
Public property | NewContext |
Public property | OldContext |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ApplicationContextChangedMessage Constructor

Initializes a new instance of the ApplicationContextChangedMessage class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ApplicationContextChangedMessage()
public:
ApplicationContextChangedMessage()
See Also

Reference

ApplicationContextChangedMessage Class
VisualComponents.Create3D Namespace


ApplicationContextChangedMessage Properties

The ApplicationContextChangedMessage type exposes the following members.

Properties
 | Name | Description
Public property | NewContext |
Public property | OldContext |
Top
See Also

Reference

ApplicationContextChangedMessage Class
VisualComponents.Create3D Namespace


ApplicationContextChangedMessage.NewContext Property

ApplicationContextChangedMessageNewContext Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IContext NewContext { get; set; }
public:
property IContext^ NewContext {
    IContext^ get ();
    void set (IContext^ value);
}

Property Value

Type: IContext
See Also

Reference

ApplicationContextChangedMessage Class
VisualComponents.Create3D Namespace


ApplicationContextChangedMessage.OldContext Property

ApplicationContextChangedMessageOldContext Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IContext OldContext { get; set; }
public:
property IContext^ OldContext {
    IContext^ get ();
    void set (IContext^ value);
}

Property Value

Type: IContext
See Also

Reference

ApplicationContextChangedMessage Class
VisualComponents.Create3D Namespace


ApplicationContextChangedMessage Methods

The ApplicationContextChangedMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ApplicationContextChangedMessage Class
VisualComponents.Create3D Namespace


ApplicationExitMessage Class

Message is broadcasted before the application object is about to be destroyed.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DApplicationExitMessage

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ApplicationExitMessage
public ref class ApplicationExitMessage

The ApplicationExitMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ApplicationExitMessage | Initializes a new instance of the ApplicationExitMessage class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ApplicationExitMessage Constructor

Initializes a new instance of the ApplicationExitMessage class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ApplicationExitMessage()
public:
ApplicationExitMessage()
See Also

Reference

ApplicationExitMessage Class
VisualComponents.Create3D Namespace


ApplicationExitMessage Methods

The ApplicationExitMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ApplicationExitMessage Class
VisualComponents.Create3D Namespace


ApplicationExtensions Class

The application helper class.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DApplicationExtensions

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class ApplicationExtensions
[ExtensionAttribute]
public ref class ApplicationExtensions abstract sealed
Methods
Name | Description
DoEvents(Boolean) |
DoEvents(DispatcherObject) | Flushes dispatcher message queue.
DoEvents(DispatcherObject, Boolean) | Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often.
Top
See Also

Reference

VisualComponents.Create3D Namespace


ApplicationExtensions Methods

Methods
Name | Description
DoEvents(Boolean) |
DoEvents(DispatcherObject) | Flushes dispatcher message queue.
DoEvents(DispatcherObject, Boolean) | Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often.
Top
See Also

Reference

ApplicationExtensions Class
VisualComponents.Create3D Namespace


ApplicationExtensions.DoEvents Method

ApplicationExtensionsDoEvents Method

Overload List
Name | Description
DoEvents(Boolean) |
DoEvents(DispatcherObject) | Flushes dispatcher message queue.
DoEvents(DispatcherObject, Boolean) | Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often.
Top
See Also

Reference

ApplicationExtensions Class
VisualComponents.Create3D Namespace


ApplicationExtensions.DoEvents Method (Boolean)

ApplicationExtensionsDoEvents Method (Boolean)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void DoEvents(
    bool full
)
public:
static void DoEvents(
    bool full
)

Parameters

full
Type: SystemBoolean
See Also

Reference

ApplicationExtensions Class
DoEvents Overload
VisualComponents.Create3D Namespace


ApplicationExtensions.DoEvents Method (DispatcherObject)

ApplicationExtensionsDoEvents Method (DispatcherObject)

Flushes dispatcher message queue.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void DoEvents(
    this DispatcherObject app
)
public:
[ExtensionAttribute]
static void DoEvents(
    DispatcherObject^ app
)

Parameters

app
Type: System.Windows.ThreadingDispatcherObject

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DispatcherObject. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ApplicationExtensions Class
DoEvents Overload
VisualComponents.Create3D Namespace


ApplicationExtensions.DoEvents Method (DispatcherObject, Boolean)

ApplicationExtensionsDoEvents Method (DispatcherObject, Boolean)

Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void DoEvents(
    this DispatcherObject app,
    bool full
)
public:
[ExtensionAttribute]
static void DoEvents(
    DispatcherObject^ app,
    bool full
)

Parameters

app
Type: System.Windows.ThreadingDispatcherObject
full
Type: SystemBoolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DispatcherObject. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ApplicationExtensions Class
DoEvents Overload
VisualComponents.Create3D Namespace


ApplicationSubContextRequestMessage Class

Message is broadcasted before the application context is about to be switched.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DApplicationSubContextRequestMessage

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ApplicationSubContextRequestMessage
public ref class ApplicationSubContextRequestMessage sealed

The ApplicationSubContextRequestMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ApplicationSubContextRequestMessage | Initializes a new instance of the ApplicationSubContextRequestMessage class
Top
Properties
 | Name | Description
Public property | SubContext | Returns a string or null that represents the sub context.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ApplicationSubContextRequestMessage Constructor

Initializes a new instance of the ApplicationSubContextRequestMessage class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ApplicationSubContextRequestMessage()
public:
ApplicationSubContextRequestMessage()
See Also

Reference

ApplicationSubContextRequestMessage Class
VisualComponents.Create3D Namespace


ApplicationSubContextRequestMessage Properties

The ApplicationSubContextRequestMessage type exposes the following members.

Properties
 | Name | Description
Public property | SubContext | Returns a string or null that represents the sub context.
Top
See Also

Reference

ApplicationSubContextRequestMessage Class
VisualComponents.Create3D Namespace


ApplicationSubContextRequestMessage.SubContext Property

ApplicationSubContextRequestMessageSubContext Property

Returns a string or null that represents the sub context.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SubContext { get; set; }
public:
property String^ SubContext {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ApplicationSubContextRequestMessage Class
VisualComponents.Create3D Namespace


ApplicationSubContextRequestMessage Methods

The ApplicationSubContextRequestMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ApplicationSubContextRequestMessage Class
VisualComponents.Create3D Namespace


ApplicationTheme Class

Helper class to work with the application theme.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DApplicationTheme

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ApplicationTheme
public ref class ApplicationTheme sealed

The ApplicationTheme type exposes the following members.

Properties
Name | Description
ThemesFiles | Gets list of loaded themes.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LoadStyles | Loads additional theme.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
Name | Description
ThemeChanged | Represents the method that will handle an ThemeChangedEventArgs event when the event provides data.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ApplicationTheme Properties

The ApplicationTheme type exposes the following members.

Properties
Name | Description
ThemesFiles | Gets list of loaded themes.
Top
See Also

Reference

ApplicationTheme Class
VisualComponents.Create3D Namespace


ApplicationTheme.ThemesFiles Property

ApplicationThemeThemesFiles Property

Gets list of loaded themes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ReadOnlyCollection<FileInfo> ThemesFiles { get; }
public:
static property ReadOnlyCollection<FileInfo^>^ ThemesFiles {
    ReadOnlyCollection<FileInfo^>^ get ();
}

Property Value

Type: ReadOnlyCollectionFileInfo
See Also

Reference

ApplicationTheme Class
VisualComponents.Create3D Namespace


ApplicationTheme Methods

The ApplicationTheme type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LoadStyles | Loads additional theme.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ApplicationTheme Class
VisualComponents.Create3D Namespace


ApplicationTheme.LoadStyles Method

ApplicationThemeLoadStyles Method

Loads additional theme.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool LoadStyles(
    string themeType
)
public:
static bool LoadStyles(
    String^ themeType
)

Parameters

themeType
Type: SystemString
theme name.

Return Value

Type: Boolean
true if the theme was loaded.
See Also

Reference

ApplicationTheme Class
VisualComponents.Create3D Namespace


ApplicationTheme Events

The ApplicationTheme type exposes the following members.

Events
Name | Description
ThemeChanged | Represents the method that will handle an ThemeChangedEventArgs event when the event provides data.
Top
See Also

Reference

ApplicationTheme Class
VisualComponents.Create3D Namespace


ApplicationTheme.ThemeChanged Event

ApplicationThemeThemeChanged Event

Represents the method that will handle an ThemeChangedEventArgs event when the event provides data.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static event EventHandler<ThemeChangedEventArgs> ThemeChanged
public:
static  event EventHandler<ThemeChangedEventArgs^>^ ThemeChanged {
    void add (EventHandler<ThemeChangedEventArgs^>^ value);
    void remove (EventHandler<ThemeChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerThemeChangedEventArgs
See Also

Reference

ApplicationTheme Class
VisualComponents.Create3D Namespace


AppLoader Class

The helper application loader which is responsible for initializating the application.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DAppLoader

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class AppLoader
public ref class AppLoader

The AppLoader type exposes the following members.

Constructors
 | Name | Description
Protected method | AppLoader | default constructor
Top
Properties
 | Name | Description
 | Instance | Get instance of the AppLoader.
Public property | ProductLicense | Gets the user config settings.
Top
Methods
 | Name | Description
Public method | AddExportedValueT | Creates a part from the specified value and registeres it in the CompositionContainer.
 | ApplyUnitFamilyConfigSetting | Apply unit family config settings.
Public method | CheckLicense |
Public method | CleanupEngine | Cleans up the environment.
Protected method | ConfigureContainer | Initializes the application container.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllComponentInstances | Returns all instances of the requested type.
 | GetAssemblyAttributeT | Returns Assembly attribute
Public method | GetComponentInstance | Returns an instance of the requested type.
Public method | GetExportT | Returns the export with the contract name derived from the specified type parameter. If there is not exactly one matching export, an exception is thrown.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitApplication(ILog) | Loads core modules, constructs them and loads the user config settings.
Public method | InitApplication(ILog, Boolean) | Loads core modules, constructs them and loads the user config settings.
Public method | InitApplication(ILog, Boolean, Boolean) | Loads core modules, constructs them and loads the user config settings.
Public method | InitApplicationPass1 |
Public method | InitApplicationPass2 |
Public method | InitApplicationWithoutLicensing |
Protected method | InitCore | Initializes the application core.
Public method | InitEngine | Loads and initializes all needed modules.
Public method | InitEngineHeadless | Loads and initializes all needed modules for the Headless execution.
 | InitLog4NetConfig | Setup log4net configuration settings.
Public method | LoadUserAssembly | Loads additional user assembly and registers it in MEF
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RefreshUserConfigSections | refresh loaded user config sections.
Public method | SatisfyImportsOnce | Composes the specified part by using the specified composition service, with recomposition disabled.
 | TestMetadata | Tests the metadata item against the license features.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetComponentInstanceT | Tries to get an instance of the requested type.
Top
Events
 | Name | Description
Public event | StatusAdded |
Top
Fields
Name | Description
OnLoadProgress |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks
It should not be called directly.
Examples
This example demonstrates how the application must be constructed.
Copy
// App.xaml.cs file

public partial class App : Application
{
    public App()
    {
        // etc

        AppLoader.InitLog4NetConfig();
    }
}

// AppBootstrapper.cs file

public class AppBootstrapper : Bootstrapper<IShell>
{
    private static readonly log4net.ILog log = log4net.LogManager.GetLogger(MethodBase.GetCurrentMethod().DeclaringType);

    private AppLoader _appLoader;
    private IApplication _appInstance;
    LicensingHelper.ProductLicenseType _validLicense;

    protected override void Configure()
    {
        _appLoader = AppLoader.Instance;
        _appInstance = _appLoader.InitApplication(log);
        _validLicense = _appLoader.ProductLicense;
    }

    protected override void StartRuntime()
    {
        // etc
        base.StartRuntime();

        if (_validLicense != LicensingHelper.ProductLicenseType.NotFound)
        {
            XamDockWindowManagerLoader.CreateXamDockWindowManager();
            _appLoader.InitEngine(log);
            // etc, for example
            var renewDate = LicensingHelper.RenewProductKeys();
        }
    }

    protected override void OnStartup(object sender, System.Windows.StartupEventArgs e)
    {
        base.OnStartup(sender, e);

        _appInstance.Initialized = true;

        // etc

        if (_validLicense != LicensingHelper.ProductLicenseType.NotFound)
        {
            var shell = IoC.Get<IShell>();
            shell.InitializePlugins();
        }

        // etc
        Application.MainWindow.Closing += OnMainWindowClosing;
        Application.MainWindow.Closed += OnMainWindowClosed;

        _appInstance.MainWindowReady = true;
    }

    void OnMainWindowClosing(object sender, System.ComponentModel.CancelEventArgs e)
    {
    }

    private void OnMainWindowClosed(object sender, EventArgs e)
    {
        _appInstance.UnloadAppFeature();
        _appInstance = null;
    }

    protected override object GetInstance(Type serviceType, string key)
    {
        return _appLoader.GetComponentInstance(serviceType, key);
    }

    protected override IEnumerable<object> GetAllInstances(Type serviceType)
    {
        return _appLoader.GetAllComponentInstances(serviceType);
    }

    protected override void BuildUp(object instance)
    {
        _appLoader.BuildUp(instance);
    }
}
See Also

Reference

VisualComponents.Create3D Namespace


AppLoader Constructor

default constructor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected AppLoader()
protected:
AppLoader()
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader Properties

The AppLoader type exposes the following members.

Properties
 | Name | Description
 | Instance | Get instance of the AppLoader.
Public property | ProductLicense | Gets the user config settings.
Top
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader.Instance Property

AppLoaderInstance Property

Get instance of the AppLoader.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static AppLoader Instance { get; }
public:
static property AppLoader^ Instance {
    AppLoader^ get ();
}

Property Value

Type: AppLoader
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader.ProductLicense Property

AppLoaderProductLicense Property

Gets the user config settings.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProductLicenseType ProductLicense { get; }
public:
property ProductLicenseType ProductLicense {
    ProductLicenseType get ();
}

Return Value

Type: ProductLicenseType
Product configuration. Determines which features are enabled.
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader Methods

The AppLoader type exposes the following members.

Methods
 | Name | Description
Public method | AddExportedValueT | Creates a part from the specified value and registeres it in the CompositionContainer.
 | ApplyUnitFamilyConfigSetting | Apply unit family config settings.
Public method | CheckLicense |
Public method | CleanupEngine | Cleans up the environment.
Protected method | ConfigureContainer | Initializes the application container.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllComponentInstances | Returns all instances of the requested type.
 | GetAssemblyAttributeT | Returns Assembly attribute
Public method | GetComponentInstance | Returns an instance of the requested type.
Public method | GetExportT | Returns the export with the contract name derived from the specified type parameter. If there is not exactly one matching export, an exception is thrown.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitApplication(ILog) | Loads core modules, constructs them and loads the user config settings.
Public method | InitApplication(ILog, Boolean) | Loads core modules, constructs them and loads the user config settings.
Public method | InitApplication(ILog, Boolean, Boolean) | Loads core modules, constructs them and loads the user config settings.
Public method | InitApplicationPass1 |
Public method | InitApplicationPass2 |
Public method | InitApplicationWithoutLicensing |
Protected method | InitCore | Initializes the application core.
Public method | InitEngine | Loads and initializes all needed modules.
Public method | InitEngineHeadless | Loads and initializes all needed modules for the Headless execution.
 | InitLog4NetConfig | Setup log4net configuration settings.
Public method | LoadUserAssembly | Loads additional user assembly and registers it in MEF
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RefreshUserConfigSections | refresh loaded user config sections.
Public method | SatisfyImportsOnce | Composes the specified part by using the specified composition service, with recomposition disabled.
 | TestMetadata | Tests the metadata item against the license features.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetComponentInstanceT | Tries to get an instance of the requested type.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader.AddExportedValue(T) Method

AppLoaderAddExportedValueT Method

Creates a part from the specified value and registeres it in the CompositionContainer.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void AddExportedValue<T>(
    T exportedValue
)

public:
generic<typename T>
void AddExportedValue(
    T exportedValue
)

Parameters

exportedValue
Type: T
The value to add.

Type Parameters

T
The type of the new part.
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader.ApplyUnitFamilyConfigSetting Method

AppLoaderApplyUnitFamilyConfigSetting Method

Apply unit family config settings.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected static void ApplyUnitFamilyConfigSetting()
protected:
static void ApplyUnitFamilyConfigSetting()
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader.CheckLicense Method

AppLoaderCheckLicense Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CheckLicense()
public:
void CheckLicense()
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader.CleanupEngine Method

AppLoaderCleanupEngine Method

Cleans up the environment.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CleanupEngine()
public:
void CleanupEngine()
Remarks
It's used for testing purposes only.
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader.ConfigureContainer Method

AppLoaderConfigureContainer Method

Initializes the application container.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected void ConfigureContainer()
protected:
void ConfigureContainer()
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader.GetAllComponentInstances Method

AppLoaderGetAllComponentInstances Method

Returns all instances of the requested type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<Object> GetAllComponentInstances(
    Type serviceType
)
public:
IEnumerable<Object^>^ GetAllComponentInstances(
    Type^ serviceType
)

Parameters

serviceType
Type: SystemType
service type

Return Value

Type: IEnumerableObject
instances of the requested type
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader.GetAssemblyAttribute(T) Method

AppLoaderGetAssemblyAttributeT Method

Returns Assembly attribute

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static T GetAssemblyAttribute<T>(
    Assembly ass
)
where T : Attribute

public:
generic<typename T>
where T : Attribute
static T GetAssemblyAttribute(
    Assembly^ ass
)

Parameters

ass
Type: System.ReflectionAssembly
Assembly

Type Parameters

T
Assembly attribute type

Return Value

Type: T
Assembly attribute instance
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader.GetComponentInstance Method

AppLoaderGetComponentInstance Method

Returns an instance of the requested type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object GetComponentInstance(
    Type type,
    string key
)
public:
Object^ GetComponentInstance(
    Type^ type,
    String^ key
)

Parameters

type
Type: SystemType
service type
key
Type: SystemString
key

Return Value

Type: Object
instance of the requested type
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader.GetExport(T) Method

AppLoaderGetExportT Method

Returns the export with the contract name derived from the specified type parameter. If there is not exactly one matching export, an exception is thrown.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Lazy<T> GetExport<T>()
where T : class

public:
generic<typename T>
where T : ref class
Lazy<T>^ GetExport()

Type Parameters

T
The type parameter of the System.Lazy object to return. The contract name is also derived from this type parameter.

Return Value

Type: LazyT
The export with the contract name derived from the specified type parameter.
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader.InitApplication Method

AppLoaderInitApplication Method

Overload List
 | Name | Description
Public method | InitApplication(ILog) | Loads core modules, constructs them and loads the user config settings.
Public method | InitApplication(ILog, Boolean) | Loads core modules, constructs them and loads the user config settings.
Public method | InitApplication(ILog, Boolean, Boolean) | Loads core modules, constructs them and loads the user config settings.
Top
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader.InitApplication Method (ILog)

AppLoaderInitApplication Method (ILog)

Loads core modules, constructs them and loads the user config settings.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IApplication InitApplication(
    ILog log
)
public:
IApplication^ InitApplication(
    ILog^ log
)

Parameters

log
Type: ILog
instance of ILog.

Return Value

Type: IApplication
The instance of the application.
See Also

Reference

AppLoader Class
InitApplication Overload
VisualComponents.Create3D Namespace


AppLoader.InitApplication Method (ILog, Boolean)

AppLoaderInitApplication Method (ILog, Boolean)

Loads core modules, constructs them and loads the user config settings.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IApplication InitApplication(
    ILog log,
    bool isInHeadlessMode
)
public:
IApplication^ InitApplication(
    ILog^ log,
    bool isInHeadlessMode
)

Parameters

log
Type: ILog
instance of ILog.
isInHeadlessMode
Type: SystemBoolean
Whether is running as a server or a destop application.

Return Value

Type: IApplication
The instance of the application.
See Also

Reference

AppLoader Class
InitApplication Overload
VisualComponents.Create3D Namespace


AppLoader.InitApplication Method (ILog, Boolean, Boolean)

AppLoaderInitApplication Method (ILog, Boolean, Boolean)

Loads core modules, constructs them and loads the user config settings.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IApplication InitApplication(
    ILog log,
    bool isInHeadlessMode,
    bool checkLicense
)
public:
IApplication^ InitApplication(
    ILog^ log,
    bool isInHeadlessMode,
    bool checkLicense
)

Parameters

log
Type: ILog
instance of ILog.
isInHeadlessMode
Type: SystemBoolean
Whether is running as a server or a destop application.
checkLicense
Type: SystemBoolean
Whether to init ProductLicense.

Return Value

Type: IApplication
The instance of the application.
See Also

Reference

AppLoader Class
InitApplication Overload
VisualComponents.Create3D Namespace


AppLoader.InitApplicationPass1 Method

AppLoaderInitApplicationPass1 Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitApplicationPass1(
    ILog log
)
public:
void InitApplicationPass1(
    ILog^ log
)

Parameters

log
Type: ILog
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader.InitApplicationPass2 Method

AppLoaderInitApplicationPass2 Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IApplication InitApplicationPass2(
    bool isInHeadlessMode,
    bool checkLicense
)
public:
IApplication^ InitApplicationPass2(
    bool isInHeadlessMode,
    bool checkLicense
)

Parameters

isInHeadlessMode
Type: SystemBoolean
checkLicense
Type: SystemBoolean

Return Value

Type: IApplication

[Missing <returns> documentation for "M:VisualComponents.Create3D.AppLoader.InitApplicationPass2(System.Boolean,System.Boolean)"]

See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader.InitApplicationWithoutLicensing Method

AppLoaderInitApplicationWithoutLicensing Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitApplicationWithoutLicensing(
    ILog log
)
public:
void InitApplicationWithoutLicensing(
    ILog^ log
)

Parameters

log
Type: ILog
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader.InitCore Method

AppLoaderInitCore Method

Initializes the application core.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected void InitCore()
protected:
void InitCore()
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader.InitEngine Method

AppLoaderInitEngine Method

Loads and initializes all needed modules.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitEngine(
    ILog log,
    bool loadUXMainModules = true
)
public:
void InitEngine(
    ILog^ log,
    bool loadUXMainModules = true
)

Parameters

log
Type: ILog
the logger instance
loadUXMainModules (Optional)
Type: SystemBoolean
load UX main plugins also
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader.InitEngineHeadless Method

AppLoaderInitEngineHeadless Method

Loads and initializes all needed modules for the Headless execution.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitEngineHeadless(
    ILog log,
    string[] assembliesToLoad
)
public:
void InitEngineHeadless(
    ILog^ log,
    array<String^>^ assembliesToLoad
)

Parameters

log
Type: ILog
assembliesToLoad
Type: SystemString
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader.InitLog4NetConfig Method

AppLoaderInitLog4NetConfig Method

Setup log4net configuration settings.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void InitLog4NetConfig()
public:
static void InitLog4NetConfig()
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader.LoadUserAssembly Method

AppLoaderLoadUserAssembly Method

Loads additional user assembly and registers it in MEF

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void LoadUserAssembly(
    ILog log,
    string userAssembly
)
public:
void LoadUserAssembly(
    ILog^ log,
    String^ userAssembly
)

Parameters

log
Type: ILog
instance of ILog
userAssembly
Type: SystemString
additional assebly name which should be loaded
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader.RefreshUserConfigSections Method

AppLoaderRefreshUserConfigSections Method

refresh loaded user config sections.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected static void RefreshUserConfigSections()
protected:
static void RefreshUserConfigSections()
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader.SatisfyImportsOnce Method

AppLoaderSatisfyImportsOnce Method

Composes the specified part by using the specified composition service, with recomposition disabled.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SatisfyImportsOnce(
    Object attributedPart
)
public:
void SatisfyImportsOnce(
    Object^ attributedPart
)

Parameters

attributedPart
Type: SystemObject
The part to compose.
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader.TestMetadata Method

AppLoaderTestMetadata Method

Tests the metadata item against the license features.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool TestMetadata(
    ILicenseMetadata metadata
)
public:
static bool TestMetadata(
    ILicenseMetadata^ metadata
)

Parameters

metadata
Type: VisualComponents.Create3DILicenseMetadata
metadata item.

Return Value

Type: Boolean
true if the metadata item is included.
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader.TryGetComponentInstance(T) Method

AppLoaderTryGetComponentInstanceT Method

Tries to get an instance of the requested type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public T TryGetComponentInstance<T>()
where T : class

public:
generic<typename T>
where T : ref class
T TryGetComponentInstance()

Type Parameters

T
The requested type.

Return Value

Type: T
instance of the requested type.
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader Events

The AppLoader type exposes the following members.

Events
 | Name | Description
Public event | StatusAdded |
Top
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader.StatusAdded Event

AppLoaderStatusAdded Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<StatusAddedEventArgs> StatusAdded
public:
 event EventHandler<StatusAddedEventArgs^>^ StatusAdded {
    void add (EventHandler<StatusAddedEventArgs^>^ value);
    void remove (EventHandler<StatusAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerStatusAddedEventArgs
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader Fields

The AppLoader type exposes the following members.

Fields
Name | Description
OnLoadProgress |
Top
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoader.OnLoadProgress Field

AppLoaderOnLoadProgress Field

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Action<string, string> OnLoadProgress
public:
static Action<String^, String^>^ OnLoadProgress

Field Value

Type: ActionString, String
See Also

Reference

AppLoader Class
VisualComponents.Create3D Namespace


AppLoaderHelper Class

The helper application loading utility class.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DAppLoaderHelper

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class AppLoaderHelper
public ref class AppLoaderHelper abstract sealed

The AppLoaderHelper type exposes the following members.

Properties
Name | Description
MultipleInstances |
OemResourceFolderName | The OEM resource folder name.
Top
Methods
Name | Description
ExitApp(Application) | Shutdown current instance of the application with exit code 0.
ExitApp(Application, Int32) | Shutdown current instance of the application
GetFilePath(String, String) | Get absolute path to installed file, if it exists.
GetFilePath(String, String, String) | Get absolute path to installed file, if it exists.
GetImagePath | Get a path string to an image resource.
LoadConfigurationT | Load a license configuration
LoadConfigurationFile | Load license configuration file.
LoadLicenseTypeT |
LoadProductConfiguration(String, String) | Load the current product license configuration.
LoadProductConfiguration(String, String, String, String) | Load the current product license configuration.
RunAnotherProcess(String) | Start another process.
RunAnotherProcess(String, String) | Start another process with the given arguments.
RunAnotherProcess(String, String, Boolean) | Start another process with the given arguments.
ShowInExplorer | Opens File Explorer with selection on file specified in parameter.
Top
Remarks

This class implements functionality to resolve paths relative to the application base path, in order to load configuration files, resource files, related executables etc.

See Also

Reference

VisualComponents.Create3D Namespace


AppLoaderHelper Properties

The AppLoaderHelper type exposes the following members.

Properties
Name | Description
MultipleInstances |
OemResourceFolderName | The OEM resource folder name.
Top
See Also

Reference

AppLoaderHelper Class
VisualComponents.Create3D Namespace


AppLoaderHelper.MultipleInstances Property

AppLoaderHelperMultipleInstances Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool MultipleInstances { get; }
public:
static property bool MultipleInstances {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

AppLoaderHelper Class
VisualComponents.Create3D Namespace


AppLoaderHelper.OemResourceFolderName Property

AppLoaderHelperOemResourceFolderName Property

The OEM resource folder name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string OemResourceFolderName { get; }
public:
static property String^ OemResourceFolderName {
    String^ get ();
}

Property Value

Type: String
Remarks

This folder is determined by the configuration, and contains OEM specific resource files.

See Also

Reference

AppLoaderHelper Class
VisualComponents.Create3D Namespace


AppLoaderHelper Methods

The AppLoaderHelper type exposes the following members.

Methods
Name | Description
ExitApp(Application) | Shutdown current instance of the application with exit code 0.
ExitApp(Application, Int32) | Shutdown current instance of the application
GetFilePath(String, String) | Get absolute path to installed file, if it exists.
GetFilePath(String, String, String) | Get absolute path to installed file, if it exists.
GetImagePath | Get a path string to an image resource.
LoadConfigurationT | Load a license configuration
LoadConfigurationFile | Load license configuration file.
LoadLicenseTypeT |
LoadProductConfiguration(String, String) | Load the current product license configuration.
LoadProductConfiguration(String, String, String, String) | Load the current product license configuration.
RunAnotherProcess(String) | Start another process.
RunAnotherProcess(String, String) | Start another process with the given arguments.
RunAnotherProcess(String, String, Boolean) | Start another process with the given arguments.
ShowInExplorer | Opens File Explorer with selection on file specified in parameter.
Top
See Also

Reference

AppLoaderHelper Class
VisualComponents.Create3D Namespace


AppLoaderHelper.ExitApp Method

AppLoaderHelperExitApp Method

Overload List
Name | Description
ExitApp(Application) | Shutdown current instance of the application with exit code 0.
ExitApp(Application, Int32) | Shutdown current instance of the application
Top
See Also

Reference

AppLoaderHelper Class
VisualComponents.Create3D Namespace


AppLoaderHelper.ExitApp Method (Application)

AppLoaderHelperExitApp Method (Application)

Shutdown current instance of the application with exit code 0.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void ExitApp(
    Application app
)
public:
static void ExitApp(
    Application^ app
)

Parameters

app
Type: System.WindowsApplication
current instance of the application
Remarks
This method also gracefully handles the case where app is null.
See Also

Reference

AppLoaderHelper Class
ExitApp Overload
VisualComponents.Create3D Namespace


AppLoaderHelper.ExitApp Method (Application, Int32)

AppLoaderHelperExitApp Method (Application, Int32)

Shutdown current instance of the application

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void ExitApp(
    Application app,
    int exitCode
)
public:
static void ExitApp(
    Application^ app,
    int exitCode
)

Parameters

app
Type: System.WindowsApplication
current instance of the application
exitCode
Type: SystemInt32
An integer exit code for an application. The default exit code is 0.
Remarks
This method also gracefully handles the case where app is null.
See Also

Reference

AppLoaderHelper Class
ExitApp Overload
VisualComponents.Create3D Namespace


AppLoaderHelper.GetFilePath Method

AppLoaderHelperGetFilePath Method

Overload List
Name | Description
GetFilePath(String, String) | Get absolute path to installed file, if it exists.
GetFilePath(String, String, String) | Get absolute path to installed file, if it exists.
Top
See Also

Reference

AppLoaderHelper Class
VisualComponents.Create3D Namespace


AppLoaderHelper.GetFilePath Method (String, String)

AppLoaderHelperGetFilePath Method (String, String)

Get absolute path to installed file, if it exists.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetFilePath(
    string relativePath,
    string fileName
)
public:
static String^ GetFilePath(
    String^ relativePath,
    String^ fileName
)

Parameters

relativePath
Type: SystemString
Containing folder relative to base directory
fileName
Type: SystemString
Name and extension of file

Return Value

Type: String
The absolute path to the given file, or an empty string if it does not exist.
See Also

Reference

AppLoaderHelper Class
GetFilePath Overload
VisualComponents.Create3D Namespace


AppLoaderHelper.GetFilePath Method (String, String, String)

AppLoaderHelperGetFilePath Method (String, String, String)

Get absolute path to installed file, if it exists.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetFilePath(
    string relativePath,
    string fileName,
    string fileExt
)
public:
static String^ GetFilePath(
    String^ relativePath,
    String^ fileName,
    String^ fileExt
)

Parameters

relativePath
Type: SystemString
Containing folder relative to base directory
fileName
Type: SystemString
Name of file
fileExt
Type: SystemString
File extension

Return Value

Type: String
The absolute path to the given file, or an empty string if it does not exist.
See Also

Reference

AppLoaderHelper Class
GetFilePath Overload
VisualComponents.Create3D Namespace


AppLoaderHelper.GetImagePath Method

AppLoaderHelperGetImagePath Method

Get a path string to an image resource.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetImagePath(
    string fileName,
    bool canAppResourceBeCustomizedByOem
)
public:
static String^ GetImagePath(
    String^ fileName,
    bool canAppResourceBeCustomizedByOem
)

Parameters

fileName
Type: SystemString
File name of image
canAppResourceBeCustomizedByOem
Type: SystemBoolean
Whether OEM can customize this resource

Return Value

Type: String
Path to image resource, for use in the UI.
Remarks
This method returns a path to an embedded image resource, or, if canAppResourceBeCustomizedByOem is true, a path to the OEM specific replacement file, if one exists.
See Also

Reference

AppLoaderHelper Class
VisualComponents.Create3D Namespace


AppLoaderHelper.LoadConfiguration(T) Method

AppLoaderHelperLoadConfigurationT Method

Load a license configuration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static T LoadConfiguration<T>(
    string licenseFilePath
)

public:
generic<typename T>
static T LoadConfiguration(
    String^ licenseFilePath
)

Parameters

licenseFilePath
Type: SystemString
license file path name

Type Parameters

T

Return Value

Type: T
new instance of loaded license
See Also

Reference

AppLoaderHelper Class
VisualComponents.Create3D Namespace


AppLoaderHelper.LoadConfigurationFile Method

AppLoaderHelperLoadConfigurationFile Method

Load license configuration file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ProductLicenseConfiguration LoadConfigurationFile(
    string licenseFilePath
)
public:
static ProductLicenseConfiguration^ LoadConfigurationFile(
    String^ licenseFilePath
)

Parameters

licenseFilePath
Type: SystemString
License configuration file path, relative to base directory.

Return Value

Type: ProductLicenseConfiguration
Product license configuration object instance
See Also

Reference

AppLoaderHelper Class
VisualComponents.Create3D Namespace


AppLoaderHelper.LoadLicenseType(T) Method

AppLoaderHelperLoadLicenseTypeT Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static T LoadLicenseType<T>(
    string appSettingLicenseFolder,
    string licenseFileName,
    string defaultAppSettingLicenseFolder,
    string defaultLicenseFileName
)

public:
generic<typename T>
static T LoadLicenseType(
    String^ appSettingLicenseFolder,
    String^ licenseFileName,
    String^ defaultAppSettingLicenseFolder,
    String^ defaultLicenseFileName
)

Parameters

appSettingLicenseFolder
Type: SystemString
licenseFileName
Type: SystemString
defaultAppSettingLicenseFolder
Type: SystemString
defaultLicenseFileName
Type: SystemString

Type Parameters

T

Return Value

Type: T

[Missing <returns> documentation for "M:VisualComponents.Create3D.AppLoaderHelper.LoadLicenseType``1(System.String,System.String,System.String,System.String)"]

See Also

Reference

AppLoaderHelper Class
VisualComponents.Create3D Namespace


AppLoaderHelper.LoadProductConfiguration Method

AppLoaderHelperLoadProductConfiguration Method

Overload List
Name | Description
LoadProductConfiguration(String, String) | Load the current product license configuration.
LoadProductConfiguration(String, String, String, String) | Load the current product license configuration.
Top
See Also

Reference

AppLoaderHelper Class
VisualComponents.Create3D Namespace


AppLoaderHelper.LoadProductConfiguration Method (String, String)

AppLoaderHelperLoadProductConfiguration Method (String, String)

Load the current product license configuration.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IProductConfiguration LoadProductConfiguration(
    string appSettingLicenseFolder,
    string mainProductFileSettingName
)
public:
static IProductConfiguration^ LoadProductConfiguration(
    String^ appSettingLicenseFolder,
    String^ mainProductFileSettingName
)

Parameters

appSettingLicenseFolder
Type: SystemString
License configuration folder name, relative to default application settings folder.
mainProductFileSettingName
Type: SystemString
Name of application setting containing main product file in folder.

Return Value

Type: IProductConfiguration
New product configuration object.
Remarks

This method reads all XML files in the given folder, using the file name in the given settings variable to populate the main product settings. All other files in the folder are added as add-on modules.

See Also

Reference

AppLoaderHelper Class
LoadProductConfiguration Overload
VisualComponents.Create3D Namespace


AppLoaderHelper.LoadProductConfiguration Method (String, String, String, String)

AppLoaderHelperLoadProductConfiguration Method (String, String, String, String)

Load the current product license configuration.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IProductConfiguration LoadProductConfiguration(
    string appSettingLicenseFolder,
    string mainProductFileSettingName,
    string defaultAppSettingLicenseFolder,
    string defaultLicenseFileName
)
public:
static IProductConfiguration^ LoadProductConfiguration(
    String^ appSettingLicenseFolder,
    String^ mainProductFileSettingName,
    String^ defaultAppSettingLicenseFolder,
    String^ defaultLicenseFileName
)

Parameters

appSettingLicenseFolder
Type: SystemString
License configuration folder name, relative to executable path.
mainProductFileSettingName
Type: SystemString
Name of application setting containing main product file in folder.
defaultAppSettingLicenseFolder
Type: SystemString
Application settings folder.
defaultLicenseFileName
Type: SystemString
Default main product file name to use if the main product file setting is not set.

Return Value

Type: IProductConfiguration
New product configuration object.
Remarks

This method reads all XML files in the given folder, using the file name in the given settings variable to populate the main product settings. All other files in the folder are added as add-on modules.

See Also

Reference

AppLoaderHelper Class
LoadProductConfiguration Overload
VisualComponents.Create3D Namespace


AppLoaderHelper.RunAnotherProcess Method

AppLoaderHelperRunAnotherProcess Method

Overload List
Name | Description
RunAnotherProcess(String) | Start another process.
RunAnotherProcess(String, String) | Start another process with the given arguments.
RunAnotherProcess(String, String, Boolean) | Start another process with the given arguments.
Top
See Also

Reference

AppLoaderHelper Class
VisualComponents.Create3D Namespace


AppLoaderHelper.RunAnotherProcess Method (String)

AppLoaderHelperRunAnotherProcess Method (String)

Start another process.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool RunAnotherProcess(
    string appName
)
public:
static bool RunAnotherProcess(
    String^ appName
)

Parameters

appName
Type: SystemString
Executable path, relative to base directory.

Return Value

Type: Boolean
True if the process was successfully started.
See Also

Reference

AppLoaderHelper Class
RunAnotherProcess Overload
VisualComponents.Create3D Namespace


AppLoaderHelper.RunAnotherProcess Method (String, String)

AppLoaderHelperRunAnotherProcess Method (String, String)

Start another process with the given arguments.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool RunAnotherProcess(
    string appName,
    string commandLineArguments
)
public:
static bool RunAnotherProcess(
    String^ appName,
    String^ commandLineArguments
)

Parameters

appName
Type: SystemString
Executable path, relative to base directory.
commandLineArguments
Type: SystemString
Command line arguments

Return Value

Type: Boolean
True if the process was successfully started.
See Also

Reference

AppLoaderHelper Class
RunAnotherProcess Overload
VisualComponents.Create3D Namespace


AppLoaderHelper.RunAnotherProcess Method (String, String, Boolean)

AppLoaderHelperRunAnotherProcess Method (String, String, Boolean)

Start another process with the given arguments.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool RunAnotherProcess(
    string appName,
    string commandLineArguments,
    bool showMessageDialog
)
public:
static bool RunAnotherProcess(
    String^ appName,
    String^ commandLineArguments,
    bool showMessageDialog
)

Parameters

appName
Type: SystemString
Executable path, relative to base directory.
commandLineArguments
Type: SystemString
Command line arguments
showMessageDialog
Type: SystemBoolean
Whether to show a dialog on failure.

Return Value

Type: Boolean
True if the process was successfully started.
See Also

Reference

AppLoaderHelper Class
RunAnotherProcess Overload
VisualComponents.Create3D Namespace


AppLoaderHelper.ShowInExplorer Method

AppLoaderHelperShowInExplorer Method

Opens File Explorer with selection on file specified in parameter.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void ShowInExplorer(
    string path
)
public:
static void ShowInExplorer(
    String^ path
)

Parameters

path
Type: SystemString
Path to a file which should be selected.
See Also

Reference

AppLoaderHelper Class
VisualComponents.Create3D Namespace


ASCIIPointCloudFile Enumeration

ASCII Point Cloud file

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ASCIIPointCloudFile
public enum class ASCIIPointCloudFile
Members
Member name | Value | Description
XYZ | 0 |
PTS | 1 |
XYZRGB | 2 |
See Also

Reference

VisualComponents.Create3D Namespace


AssemblyFeatureRequestAttribute Class

Provides a license request for an assembly
Inheritance Hierarchy
SystemObject
SystemAttribute
VisualComponents.Create3DAssemblyFeatureRequestAttribute

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class AssemblyFeatureRequestAttribute : Attribute,
    IDllFeatureRequest
public ref class AssemblyFeatureRequestAttribute sealed : public Attribute,
    IDllFeatureRequest

The AssemblyFeatureRequestAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AssemblyFeatureRequestAttribute | Initializing constructor.
Public method | AssemblyFeatureRequestAttribute(String, String) | Initializing constructor.
Top
Properties
 | Name | Description
Public property | FeatureName | Name of the requested license feature.
Public property | FeatureVersion | Version of the requested license feature.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


AssemblyFeatureRequestAttribute Constructor

Overload List
 | Name | Description
Public method | AssemblyFeatureRequestAttribute | Initializing constructor.
Public method | AssemblyFeatureRequestAttribute(String, String) | Initializing constructor.
Top
See Also

Reference

AssemblyFeatureRequestAttribute Class
VisualComponents.Create3D Namespace


AssemblyFeatureRequestAttribute Constructor

Initializing constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AssemblyFeatureRequestAttribute()
public:
AssemblyFeatureRequestAttribute()
See Also

Reference

AssemblyFeatureRequestAttribute Class
AssemblyFeatureRequestAttribute Overload
VisualComponents.Create3D Namespace


AssemblyFeatureRequestAttribute Constructor (String, String)

Initializing constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AssemblyFeatureRequestAttribute(
    string featureName,
    string featureVersion
)
public:
AssemblyFeatureRequestAttribute(
    String^ featureName,
    String^ featureVersion
)

Parameters

featureName
Type: SystemString
License feature name
featureVersion
Type: SystemString
License feature version
See Also

Reference

AssemblyFeatureRequestAttribute Class
AssemblyFeatureRequestAttribute Overload
VisualComponents.Create3D Namespace


AssemblyFeatureRequestAttribute Properties

The AssemblyFeatureRequestAttribute type exposes the following members.

Properties
 | Name | Description
Public property | FeatureName | Name of the requested license feature.
Public property | FeatureVersion | Version of the requested license feature.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AssemblyFeatureRequestAttribute Class
VisualComponents.Create3D Namespace


AssemblyFeatureRequestAttribute.FeatureName Property

AssemblyFeatureRequestAttributeFeatureName Property

Name of the requested license feature.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string FeatureName { get; }
public:
virtual property String^ FeatureName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IDllFeatureRequestFeatureName
See Also

Reference

AssemblyFeatureRequestAttribute Class
VisualComponents.Create3D Namespace


AssemblyFeatureRequestAttribute.FeatureVersion Property

AssemblyFeatureRequestAttributeFeatureVersion Property

Version of the requested license feature.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string FeatureVersion { get; }
public:
virtual property String^ FeatureVersion {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IDllFeatureRequestFeatureVersion
See Also

Reference

AssemblyFeatureRequestAttribute Class
VisualComponents.Create3D Namespace


AssemblyFeatureRequestAttribute Methods

The AssemblyFeatureRequestAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AssemblyFeatureRequestAttribute Class
VisualComponents.Create3D Namespace


AssemblyLicenseAttribute Class

Provides a license requirement for an assembly
Inheritance Hierarchy
SystemObject
SystemAttribute
VisualComponents.Create3DAssemblyLicenseAttribute

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class AssemblyLicenseAttribute : Attribute,
    IDllLicenseCheck
public ref class AssemblyLicenseAttribute sealed : public Attribute,
    IDllLicenseCheck

The AssemblyLicenseAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AssemblyLicenseAttribute | Initializing constructor.
Public method | AssemblyLicenseAttribute(LicenseFeaturesFeatures, Type) | Initializing constructor.
Top
Properties
 | Name | Description
Public property | IsActivated | Determine if dll is activated or not.
Public property | RequiredFeatures | Required Feature
Public property | SettingType | Assembly setting ViewModel type
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


AssemblyLicenseAttribute Constructor

Overload List
 | Name | Description
Public method | AssemblyLicenseAttribute | Initializing constructor.
Public method | AssemblyLicenseAttribute(LicenseFeaturesFeatures, Type) | Initializing constructor.
Top
See Also

Reference

AssemblyLicenseAttribute Class
VisualComponents.Create3D Namespace


AssemblyLicenseAttribute Constructor

Initializing constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AssemblyLicenseAttribute()
public:
AssemblyLicenseAttribute()
See Also

Reference

AssemblyLicenseAttribute Class
AssemblyLicenseAttribute Overload
VisualComponents.Create3D Namespace


AssemblyLicenseAttribute Constructor (LicenseFeatures.Features, Type)

AssemblyLicenseAttribute Constructor (LicenseFeaturesFeatures, Type)

Initializing constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AssemblyLicenseAttribute(
    LicenseFeaturesFeatures requiredFeatures,
    Type settingType
)
public:
AssemblyLicenseAttribute(
    LicenseFeaturesFeatures requiredFeatures,
    Type^ settingType
)

Parameters

requiredFeatures
Type: VisualComponents.Create3DLicenseFeaturesFeatures
License Feature
settingType
Type: SystemType
Assembly Setting ViewModel type
See Also

Reference

AssemblyLicenseAttribute Class
AssemblyLicenseAttribute Overload
VisualComponents.Create3D Namespace


AssemblyLicenseAttribute Properties

The AssemblyLicenseAttribute type exposes the following members.

Properties
 | Name | Description
Public property | IsActivated | Determine if dll is activated or not.
Public property | RequiredFeatures | Required Feature
Public property | SettingType | Assembly setting ViewModel type
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AssemblyLicenseAttribute Class
VisualComponents.Create3D Namespace


AssemblyLicenseAttribute.IsActivated Property

AssemblyLicenseAttributeIsActivated Property

Determine if dll is activated or not.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsActivated { get; }
public:
virtual property bool IsActivated {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IDllLicenseCheckIsActivated
See Also

Reference

AssemblyLicenseAttribute Class
VisualComponents.Create3D Namespace


AssemblyLicenseAttribute.RequiredFeatures Property

AssemblyLicenseAttributeRequiredFeatures Property

Required Feature

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LicenseFeaturesFeatures RequiredFeatures { get; }
public:
virtual property LicenseFeaturesFeatures RequiredFeatures {
    LicenseFeaturesFeatures get () sealed;
}

Property Value

Type: LicenseFeaturesFeatures

Implements

IDllLicenseCheckRequiredFeatures
See Also

Reference

AssemblyLicenseAttribute Class
VisualComponents.Create3D Namespace


AssemblyLicenseAttribute.SettingType Property

AssemblyLicenseAttributeSettingType Property

Assembly setting ViewModel type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type SettingType { get; }
public:
virtual property Type^ SettingType {
    Type^ get () sealed;
}

Property Value

Type: Type

Implements

IDllLicenseCheckSettingType
See Also

Reference

AssemblyLicenseAttribute Class
VisualComponents.Create3D Namespace


AssemblyLicenseAttribute Methods

The AssemblyLicenseAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AssemblyLicenseAttribute Class
VisualComponents.Create3D Namespace


AssemblyLicenseKeyPatternAttribute Class

Provides a license key validation pattern for an assembly
Inheritance Hierarchy
SystemObject
SystemAttribute
VisualComponents.Create3DAssemblyLicenseKeyPatternAttribute

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class AssemblyLicenseKeyPatternAttribute : Attribute,
    IDllLicenseKeyPattern
public ref class AssemblyLicenseKeyPatternAttribute sealed : public Attribute,
    IDllLicenseKeyPattern

The AssemblyLicenseKeyPatternAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AssemblyLicenseKeyPatternAttribute | Initializing constructor.
Public method | AssemblyLicenseKeyPatternAttribute(String) | Initializing constructor.
Top
Properties
 | Name | Description
Public property | Pattern | RegEx pattern the license key should match.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


AssemblyLicenseKeyPatternAttribute Constructor

Overload List
 | Name | Description
Public method | AssemblyLicenseKeyPatternAttribute | Initializing constructor.
Public method | AssemblyLicenseKeyPatternAttribute(String) | Initializing constructor.
Top
See Also

Reference

AssemblyLicenseKeyPatternAttribute Class
VisualComponents.Create3D Namespace


AssemblyLicenseKeyPatternAttribute Constructor

Initializing constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AssemblyLicenseKeyPatternAttribute()
public:
AssemblyLicenseKeyPatternAttribute()
See Also

Reference

AssemblyLicenseKeyPatternAttribute Class
AssemblyLicenseKeyPatternAttribute Overload
VisualComponents.Create3D Namespace


AssemblyLicenseKeyPatternAttribute Constructor (String)

Initializing constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AssemblyLicenseKeyPatternAttribute(
    string pattern
)
public:
AssemblyLicenseKeyPatternAttribute(
    String^ pattern
)

Parameters

pattern
Type: SystemString
License key RegEx pattern
See Also

Reference

AssemblyLicenseKeyPatternAttribute Class
AssemblyLicenseKeyPatternAttribute Overload
VisualComponents.Create3D Namespace


AssemblyLicenseKeyPatternAttribute Properties

The AssemblyLicenseKeyPatternAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Pattern | RegEx pattern the license key should match.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AssemblyLicenseKeyPatternAttribute Class
VisualComponents.Create3D Namespace


AssemblyLicenseKeyPatternAttribute.Pattern Property

AssemblyLicenseKeyPatternAttributePattern Property

RegEx pattern the license key should match.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Pattern { get; }
public:
virtual property String^ Pattern {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IDllLicenseKeyPatternPattern
See Also

Reference

AssemblyLicenseKeyPatternAttribute Class
VisualComponents.Create3D Namespace


AssemblyLicenseKeyPatternAttribute Methods

The AssemblyLicenseKeyPatternAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AssemblyLicenseKeyPatternAttribute Class
VisualComponents.Create3D Namespace


AutodeskInventor Enumeration

Autodesk Inventor -> Up to 2020

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum AutodeskInventor
public enum class AutodeskInventor
Members
Member name | Value | Description
IPT | 0 |
IAM | 1 |
See Also

Reference

VisualComponents.Create3D Namespace


AutoPlugFlowDirection Enumeration

Defines the allowed flow direction used by IAutoPlugPlayService

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum AutoPlugFlowDirection
public enum class AutoPlugFlowDirection
Members
Member name | Value | Description
Downstream | 0 | Connect only to the components defining an material flow output
Upstream | 1 | Connect only to the components defining an material flow input
DownstreamFirst | 2 | Allow connection to both input and output but use input when both available
UpstreamFirst | 3 | Allow connection to both input and output but use output when both available
See Also

Reference

VisualComponents.Create3D Namespace


BackfaceMode Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum BackfaceMode
public enum class BackfaceMode
Members
Member name | Value | Description
Feature | 0 | Uses settings defined for the geometry feature objects.
Off | 1 | Forces backfaces to be invisible for all geometry at component.
On | 2 | Forces backfaces to be visible for all geometry at component.
See Also

Reference

VisualComponents.Create3D Namespace


BaseContext Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DBaseContext

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract class BaseContext
public ref class BaseContext abstract

The BaseContext type exposes the following members.

Constructors
 | Name | Description
Protected method | BaseContext | Initializes a new instance of the BaseContext class
Top
Properties
 | Name | Description
Public property | IsActive |
Protected property | ManipulateViewModel |
Protected property | SelectionManager |
Public property | SupportedManipulationModes |
Top
Methods
 | Name | Description
Public method | Activate |
Protected method | AddSupportedManipulationMode |
Public method | Deactivate |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnActivate |
Public method | OnDeactivate |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


BaseContext Constructor

Initializes a new instance of the BaseContext class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected BaseContext()
protected:
BaseContext()
See Also

Reference

BaseContext Class
VisualComponents.Create3D Namespace


BaseContext Properties

The BaseContext type exposes the following members.

Properties
 | Name | Description
Public property | IsActive |
Protected property | ManipulateViewModel |
Protected property | SelectionManager |
Public property | SupportedManipulationModes |
Top
See Also

Reference

BaseContext Class
VisualComponents.Create3D Namespace


BaseContext.IsActive Property

BaseContextIsActive Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsActive { get; set; }
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

BaseContext Class
VisualComponents.Create3D Namespace


BaseContext.ManipulateViewModel Property

BaseContextManipulateViewModel Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected IManipulateViewModel ManipulateViewModel { get; }
protected:
property IManipulateViewModel^ ManipulateViewModel {
    IManipulateViewModel^ get ();
}

Property Value

Type: IManipulateViewModel
See Also

Reference

BaseContext Class
VisualComponents.Create3D Namespace


BaseContext.SelectionManager Property

BaseContextSelectionManager Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected ISelectionManager SelectionManager { get; }
protected:
property ISelectionManager^ SelectionManager {
    ISelectionManager^ get ();
}

Property Value

Type: ISelectionManager
See Also

Reference

BaseContext Class
VisualComponents.Create3D Namespace


BaseContext.SupportedManipulationModes Property

BaseContextSupportedManipulationModes Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<ManipulationMode> SupportedManipulationModes { get; }
public:
property ReadOnlyCollection<ManipulationMode>^ SupportedManipulationModes {
    ReadOnlyCollection<ManipulationMode>^ get ();
}

Property Value

Type: ReadOnlyCollectionManipulationMode
See Also

Reference

BaseContext Class
VisualComponents.Create3D Namespace


BaseContext Methods

The BaseContext type exposes the following members.

Methods
 | Name | Description
Public method | Activate |
Protected method | AddSupportedManipulationMode |
Public method | Deactivate |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnActivate |
Public method | OnDeactivate |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BaseContext Class
VisualComponents.Create3D Namespace


BaseContext.Activate Method

BaseContextActivate Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Activate()
public:
void Activate()
See Also

Reference

BaseContext Class
VisualComponents.Create3D Namespace


BaseContext.AddSupportedManipulationMode Method

BaseContextAddSupportedManipulationMode Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected void AddSupportedManipulationMode(
    ManipulationMode mode
)
protected:
void AddSupportedManipulationMode(
    ManipulationMode mode
)

Parameters

mode
Type: VisualComponents.Create3DManipulationMode
See Also

Reference

BaseContext Class
VisualComponents.Create3D Namespace


BaseContext.Deactivate Method

BaseContextDeactivate Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Deactivate()
public:
void Deactivate()
See Also

Reference

BaseContext Class
VisualComponents.Create3D Namespace


BaseContext.OnActivate Method

BaseContextOnActivate Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void OnActivate()
public:
virtual void OnActivate()
See Also

Reference

BaseContext Class
VisualComponents.Create3D Namespace


BaseContext.OnDeactivate Method

BaseContextOnDeactivate Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void OnDeactivate()
public:
virtual void OnDeactivate()
See Also

Reference

BaseContext Class
VisualComponents.Create3D Namespace


BaseContextConfigElement Class

Configuration file element for context dependent options.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.Create3DBaseContextConfigElement

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class BaseContextConfigElement : ConfigurationElement
public ref class BaseContextConfigElement : public ConfigurationElement

The BaseContextConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | BaseContextConfigElement | Constructor.
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | D3DToolBar | Configuration file element for 3d Toolbar options.
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is . (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | Key | Context id.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Top
Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


BaseContextConfigElement Constructor

Constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BaseContextConfigElement()
public:
BaseContextConfigElement()
See Also

Reference

BaseContextConfigElement Class
VisualComponents.Create3D Namespace


BaseContextConfigElement Properties

The BaseContextConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | D3DToolBar | Configuration file element for 3d Toolbar options.
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is . (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | Key | Context id.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Top
See Also

Reference

BaseContextConfigElement Class
VisualComponents.Create3D Namespace


BaseContextConfigElement.D3DToolBar Property

BaseContextConfigElementD3DToolBar Property

Configuration file element for 3d Toolbar options.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public D3DToolBarConfigElement D3DToolBar { get; set; }
public:
property D3DToolBarConfigElement^ D3DToolBar {
    D3DToolBarConfigElement^ get ();
    void set (D3DToolBarConfigElement^ value);
}

Property Value

Type: D3DToolBarConfigElement
See Also

Reference

BaseContextConfigElement Class
VisualComponents.Create3D Namespace


BaseContextConfigElement.Key Property

BaseContextConfigElementKey Property

Context id.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Key { get; set; }
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

BaseContextConfigElement Class
VisualComponents.Create3D Namespace


BaseContextConfigElement Methods

The BaseContextConfigElement type exposes the following members.

Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BaseContextConfigElement Class
VisualComponents.Create3D Namespace


BatchesChangedEventArgs Class

Event arguments for BatchesChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DBatchesChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class BatchesChangedEventArgs : EventArgs
public ref class BatchesChangedEventArgs : public EventArgs

The BatchesChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BatchesChangedEventArgs | Initializes a new instance of the BatchesChangedEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


BatchesChangedEventArgs Constructor

Initializes a new instance of the BatchesChangedEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BatchesChangedEventArgs()
public:
BatchesChangedEventArgs()
See Also

Reference

BatchesChangedEventArgs Class
VisualComponents.Create3D Namespace


BatchesChangedEventArgs Methods

The BatchesChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BatchesChangedEventArgs Class
VisualComponents.Create3D Namespace


BehaviorAddedEventArgs Class

Event data for BehaviorAdded event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DBehaviorAddedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class BehaviorAddedEventArgs : EventArgs
public ref class BehaviorAddedEventArgs : public EventArgs

The BehaviorAddedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BehaviorAddedEventArgs | Initializes a new instance of the BehaviorAddedEventArgs class.
Top
Properties
 | Name | Description
Public property | Behavior | Gets the added behavior.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


BehaviorAddedEventArgs Constructor

Initializes a new instance of the BehaviorAddedEventArgs class.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BehaviorAddedEventArgs(
    IBehavior behavior
)
public:
BehaviorAddedEventArgs(
    IBehavior^ behavior
)

Parameters

behavior
Type: VisualComponents.Create3DIBehavior
Behavior.
See Also

Reference

BehaviorAddedEventArgs Class
VisualComponents.Create3D Namespace


BehaviorAddedEventArgs Properties

The BehaviorAddedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Behavior | Gets the added behavior.
Top
See Also

Reference

BehaviorAddedEventArgs Class
VisualComponents.Create3D Namespace


BehaviorAddedEventArgs.Behavior Property

BehaviorAddedEventArgsBehavior Property

Gets the added behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IBehavior Behavior { get; }
public:
property IBehavior^ Behavior {
    IBehavior^ get ();
}

Property Value

Type: IBehavior
See Also

Reference

BehaviorAddedEventArgs Class
VisualComponents.Create3D Namespace


BehaviorAddedEventArgs Methods

The BehaviorAddedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BehaviorAddedEventArgs Class
VisualComponents.Create3D Namespace


BehaviorRemovedEventArgs Class

Event data for BehaviorRemoved event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DBehaviorRemovedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class BehaviorRemovedEventArgs : EventArgs
public ref class BehaviorRemovedEventArgs : public EventArgs

The BehaviorRemovedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BehaviorRemovedEventArgs | Initializes a new instance of the BehaviorRemovedEventArgs class.
Top
Properties
 | Name | Description
Public property | BehaviorName | Gets the behavior that's being removed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


BehaviorRemovedEventArgs Constructor

Initializes a new instance of the BehaviorRemovedEventArgs class.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BehaviorRemovedEventArgs(
    string behaviorName
)
public:
BehaviorRemovedEventArgs(
    String^ behaviorName
)

Parameters

behaviorName
Type: SystemString
Behavior name.
See Also

Reference

BehaviorRemovedEventArgs Class
VisualComponents.Create3D Namespace


BehaviorRemovedEventArgs Properties

The BehaviorRemovedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | BehaviorName | Gets the behavior that's being removed.
Top
See Also

Reference

BehaviorRemovedEventArgs Class
VisualComponents.Create3D Namespace


BehaviorRemovedEventArgs.BehaviorName Property

BehaviorRemovedEventArgsBehaviorName Property

Gets the behavior that's being removed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string BehaviorName { get; }
public:
property String^ BehaviorName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

BehaviorRemovedEventArgs Class
VisualComponents.Create3D Namespace


BehaviorRemovedEventArgs Methods

The BehaviorRemovedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BehaviorRemovedEventArgs Class
VisualComponents.Create3D Namespace


BehaviorRemovingEventArgs Class

Event data for BehaviorRemoving event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DBehaviorRemovingEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class BehaviorRemovingEventArgs : EventArgs
public ref class BehaviorRemovingEventArgs : public EventArgs

The BehaviorRemovingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BehaviorRemovingEventArgs | Initializes a new instance of the BehaviorRemovingEventArgs class.
Top
Properties
 | Name | Description
Public property | Behavior | Gets the behavior that's being removed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


BehaviorRemovingEventArgs Constructor

Initializes a new instance of the BehaviorRemovingEventArgs class.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BehaviorRemovingEventArgs(
    IBehavior behavior
)
public:
BehaviorRemovingEventArgs(
    IBehavior^ behavior
)

Parameters

behavior
Type: VisualComponents.Create3DIBehavior
Behavior.
See Also

Reference

BehaviorRemovingEventArgs Class
VisualComponents.Create3D Namespace


BehaviorRemovingEventArgs Properties

The BehaviorRemovingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Behavior | Gets the behavior that's being removed.
Top
See Also

Reference

BehaviorRemovingEventArgs Class
VisualComponents.Create3D Namespace


BehaviorRemovingEventArgs.Behavior Property

BehaviorRemovingEventArgsBehavior Property

Gets the behavior that's being removed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IBehavior Behavior { get; }
public:
property IBehavior^ Behavior {
    IBehavior^ get ();
}

Property Value

Type: IBehavior
See Also

Reference

BehaviorRemovingEventArgs Class
VisualComponents.Create3D Namespace


BehaviorRemovingEventArgs Methods

The BehaviorRemovingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BehaviorRemovingEventArgs Class
VisualComponents.Create3D Namespace


BehaviorType Enumeration

Behavior type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum BehaviorType
public enum class BehaviorType
Members
Member name | Value | Description
None | 0 | None
ActionContainer | 1 | IActionContainer behavior.
ArticulatedKinematics | 2 | IArticulatedKinematics behavior.
ArticulatedKinematics2 | 3 | IArticulatedKinematics2 behavior.
DeltaKinematics | 4 | IDeltaKinematics behavior.
CartesianKinematics | 5 | ICartesianKinematics behavior.
ParallelogramKinematics | 6 | IParallelogramKinematics behavior.
PythonKinematics | 7 | Python Kinematics behavior.
ScaraKinematics | 8 | IScaraKinematics behavior.
TriceptKinematics | 9 | Tricept Kinematics behavior.
BooleanSignal | 10 | IBooleanSignal behavior.
IntegerSignal | 11 | IIntegerSignal behavior.
RealSignal | 12 | IRealSignal behavior.
MatrixSignal | 13 | IMatrixSignal behavior.
ComponentSignal | 14 | IComponentSignal behavior.
StringSignal | 15 | IStringSignal behavior.
BooleanSignalMap | 16 | IBooleanSignalMap behavior.
IntegerSignalMap | 17 | IIntegerSignalMap behavior.
RealSignalMap | 18 | IRealSignalMap behavior.
StringSignalMap | 19 | IStringSignalMap behavior.
CapacityController | 20 | ICapacityController behavior.
RealPropertyCreator | 21 | IRealPropertyCreator behavior.
StringPropertyCreator | 22 | IStringPropertyCreator behavior.
BooleanPropertyCreator | 23 | IBooleanPropertyCreator behavior.
IntegerPropertyCreator | 24 | IIntegerPropertyCreator behavior.
Statistics | 25 | IStatistics behavior.
ComponentFlowProxy | 26 | IComponentFlowProxy behavior.
ComponentGrabber | 27 | IComponentGrabber behavior.
ComponentPathSensor | 28 | IComponentPathSensor behavior.
ProcessPointSensor | 29 | IProcessPointSensor behavior.
RaycastSensor | 30 | IRayCastSensor behavior.
VolumeSensor | 32 | IVolumeSensor behavior.
JogInfo | 33 | IJogInfo behavior.
Note | 34 | INote behavior.
DocumentLink | 35 | IDocumentLink behavior.
BucketPath | 36 | IBucketPath behavior.
OneDirectionalPath | 37 | IOneDirectionalPath behavior.
OneWayPath | 38 | IOneWayPath behavior.
RoutingRule | 39 | IRoutingRule behavior.
TwoDirectionalPath | 40 | ITwoDirectionalPath behavior.
TwoWayPath | 41 | ITwoWayPath behavior.
OneToManyInterface | 42 | IOneToManyInterface behavior.
OneToOneInterface | 43 | IOneToOneInterface behavior.
ParticleSystem | 44 | Particle System behavior.
ComponentContainer | 45 | IComponentContainer behavior.
BaseContainer | 46 | IBaseContainer behavior.
ToolContainer | 47 | IToolContainer behavior.
ComponentLocationContainer | 48 | Component Location behavior.
ComponentPatternContainer | 49 | Component Pattern Container behavior.
ComponentCreator | 50 | IComponentCreator behavior.
ContainerFiller | 51 | IContainerFiller behavior.
PythonProcessHandler | 52 | IProcessHandler behavior.
ServoController | 53 | IServoController behavior.
RobotController | 54 | IRobotController behavior.
RslExecutor | 55 | IRslExecutor behavior.
RobotExecutor | 56 | IRobotExecutor behavior.
TransportProtocol | 57 | ITransportProtocol behavior.
Vehicle | 58 | IVehicle behavior.
HandleInfo | 59 | IHandleInfo behavior.
PythonScript | 60 | IPythonScript behavior.
PhysicsEntity | 61 | IPhysicsEntity behavior.
PhysicsCable | 62 | IPhysicsCable behavior.
PhysicsJointD6 | 63 | IPhysicsJointD6 behavior.
PhysicsPath | 64 | IPhysicsPath behavior.
PhysicsContactModifier | 65 | IPhysicsContactModifier behavior.
PhysicsContainer | 66 | IPhysicsContainer behavior.
ProcessExecutor | 67 | IProcessExecutor behavior.
ProcessController | 68 | IProcessController behavior.
ProductCreator | 72 | IProductCreator behavior.
TransportNode | 73 | ITransportNode
PythonTransportController | 74 | IPythonTransportController
Custom | 75 | CustomBehaviorBase
ScaraKinematics2 | 76 | IKinScara2
See Also

Reference

VisualComponents.Create3D Namespace


BinaryInputValueChangedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DBinaryInputValueChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class BinaryInputValueChangedEventArgs : EventArgs
public ref class BinaryInputValueChangedEventArgs : public EventArgs

The BinaryInputValueChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BinaryInputValueChangedEventArgs | Initializes a new instance of the BinaryInputValueChangedEventArgs class
Top
Properties
 | Name | Description
Public property | PortIndex |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


BinaryInputValueChangedEventArgs Constructor

Initializes a new instance of the BinaryInputValueChangedEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BinaryInputValueChangedEventArgs(
    int portIndex,
    bool value
)
public:
BinaryInputValueChangedEventArgs(
    int portIndex,
    bool value
)

Parameters

portIndex
Type: SystemInt32
value
Type: SystemBoolean
See Also

Reference

BinaryInputValueChangedEventArgs Class
VisualComponents.Create3D Namespace


BinaryInputValueChangedEventArgs Properties

The BinaryInputValueChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | PortIndex |
Public property | Value |
Top
See Also

Reference

BinaryInputValueChangedEventArgs Class
VisualComponents.Create3D Namespace


BinaryInputValueChangedEventArgs.PortIndex Property

BinaryInputValueChangedEventArgsPortIndex Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int PortIndex { get; }
public:
property int PortIndex {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

BinaryInputValueChangedEventArgs Class
VisualComponents.Create3D Namespace


BinaryInputValueChangedEventArgs.Value Property

BinaryInputValueChangedEventArgsValue Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Value { get; }
public:
property bool Value {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

BinaryInputValueChangedEventArgs Class
VisualComponents.Create3D Namespace


BinaryInputValueChangedEventArgs Methods

The BinaryInputValueChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BinaryInputValueChangedEventArgs Class
VisualComponents.Create3D Namespace


BinaryPointCloudFile Enumeration

Binary point cloud point

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum BinaryPointCloudFile
public enum class BinaryPointCloudFile
Members
Member name | Value | Description
BXYZ | 0 |
See Also

Reference

VisualComponents.Create3D Namespace


BufferMode Enumeration

Options for product output order in IBufferProductsStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum BufferMode
public enum class BufferMode
Members
Member name | Value | Description
FIFO | 0 | First-In, First-Out order i.e. a queue.
LIFO | 1 | Last-In, First-Out order i.e. a stack.
See Also

Reference

VisualComponents.Create3D Namespace


ButtonPropertyClickedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DButtonPropertyClickedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ButtonPropertyClickedEventArgs : EventArgs
public ref class ButtonPropertyClickedEventArgs : public EventArgs

The ButtonPropertyClickedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ButtonPropertyClickedEventArgs | Initializes a new instance of the ButtonPropertyClickedEventArgs class
Top
Properties
 | Name | Description
Public property | Button |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ButtonPropertyClickedEventArgs Constructor

Initializes a new instance of the ButtonPropertyClickedEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ButtonPropertyClickedEventArgs(
    IButtonProperty button
)
public:
ButtonPropertyClickedEventArgs(
    IButtonProperty^ button
)

Parameters

button
Type: VisualComponents.Create3DIButtonProperty
See Also

Reference

ButtonPropertyClickedEventArgs Class
VisualComponents.Create3D Namespace


ButtonPropertyClickedEventArgs Properties

The ButtonPropertyClickedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Button |
Top
See Also

Reference

ButtonPropertyClickedEventArgs Class
VisualComponents.Create3D Namespace


ButtonPropertyClickedEventArgs.Button Property

ButtonPropertyClickedEventArgsButton Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IButtonProperty Button { get; }
public:
property IButtonProperty^ Button {
    IButtonProperty^ get ();
}

Property Value

Type: IButtonProperty
See Also

Reference

ButtonPropertyClickedEventArgs Class
VisualComponents.Create3D Namespace


ButtonPropertyClickedEventArgs Methods

The ButtonPropertyClickedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ButtonPropertyClickedEventArgs Class
VisualComponents.Create3D Namespace


CADSummary Enumeration

CAD import summary report

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum CADSummary
public enum class CADSummary
Members
Member name | Value | Description
Disable | 0 | Loading does not make summary report
Enable | 1 | Laoding does and send summary report
Exclusive | 2 | Loading only does and send summary report. No actually loading
See Also

Reference

VisualComponents.Create3D Namespace


CallInterceptor Class

Intercepts API calls and forces IsValid check.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DCallInterceptor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class CallInterceptor : IInterceptor
public ref class CallInterceptor : IInterceptor

The CallInterceptor type exposes the following members.

Constructors
 | Name | Description
Public method | CallInterceptor | Initializes a new instance of the CallInterceptor class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intercept | Intercepts the API call and calls IsValid -method to check validity of wrapper object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


CallInterceptor Constructor

Initializes a new instance of the CallInterceptor class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CallInterceptor()
public:
CallInterceptor()
See Also

Reference

CallInterceptor Class
VisualComponents.Create3D Namespace


CallInterceptor Methods

The CallInterceptor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intercept | Intercepts the API call and calls IsValid -method to check validity of wrapper object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CallInterceptor Class
VisualComponents.Create3D Namespace


CallInterceptor.Intercept Method

CallInterceptorIntercept Method

Intercepts the API call and calls IsValid -method to check validity of wrapper object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Intercept(
    IInvocation invocation
)
public:
virtual void Intercept(
    IInvocation^ invocation
) sealed

Parameters

invocation
Type: IInvocation
Invocation of the proxied method.

Implements

IInterceptor.Intercept(IInvocation)
Remarks
Interceptors should not be used in release version as they slow down API calls.
See Also

Reference

CallInterceptor Class
VisualComponents.Create3D Namespace


CameraAnimationTime Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum CameraAnimationTime
public enum class CameraAnimationTime
Members
Member name | Value | Description
SimulationTime | 0 |
RelativeTime | 1 |
See Also

Reference

VisualComponents.Create3D Namespace


CartesianTarget Structure

A target given in Cartesian coordinates.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct CartesianTarget
public value class CartesianTarget

The CartesianTarget type exposes the following members.

Constructors
 | Name | Description
Public method | CartesianTarget(CartesianTarget, Matrix) | Constructs by setting the target matrix and copying other values from the source.
Public method | CartesianTarget(Matrix, Boolean, Boolean) | Constructs by setting all values.
Top
Properties
 | Name | Description
Public property | OrientationIsEnabled | The orientation part of the matrix will be used only if this is true; otherwise it will be ignored.
Public property | PositionIsEnabled | The position part of the matrix will be used only if this is true; otherwise it will be ignored.
Public property | TargetMatrix | The desired transformation matrix between the selected base and tool frames.
Top
Methods
 | Name | Description
Public method | Equals | (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Equality |
Inequality |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


CartesianTarget Constructor

Overload List
 | Name | Description
Public method | CartesianTarget(CartesianTarget, Matrix) | Constructs by setting the target matrix and copying other values from the source.
Public method | CartesianTarget(Matrix, Boolean, Boolean) | Constructs by setting all values.
Top
See Also

Reference

CartesianTarget Structure
VisualComponents.Create3D Namespace


CartesianTarget Constructor (CartesianTarget, Matrix)

Constructs by setting the target matrix and copying other values from the source.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CartesianTarget(
    CartesianTarget other,
    Matrix targetMatrix
)
public:
CartesianTarget(
    CartesianTarget other,
    Matrix targetMatrix
)

Parameters

other
Type: VisualComponents.Create3DCartesianTarget
targetMatrix
Type: VisualComponents.Create3DMatrix
See Also

Reference

CartesianTarget Structure
CartesianTarget Overload
VisualComponents.Create3D Namespace


CartesianTarget Constructor (Matrix, Boolean, Boolean)

Constructs by setting all values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CartesianTarget(
    Matrix targetMatrix,
    bool positionIsEnabled,
    bool orientationIsEnabled
)
public:
CartesianTarget(
    Matrix targetMatrix,
    bool positionIsEnabled,
    bool orientationIsEnabled
)

Parameters

targetMatrix
Type: VisualComponents.Create3DMatrix
positionIsEnabled
Type: SystemBoolean
orientationIsEnabled
Type: SystemBoolean
See Also

Reference

CartesianTarget Structure
CartesianTarget Overload
VisualComponents.Create3D Namespace


CartesianTarget Properties

The CartesianTarget type exposes the following members.

Properties
 | Name | Description
Public property | OrientationIsEnabled | The orientation part of the matrix will be used only if this is true; otherwise it will be ignored.
Public property | PositionIsEnabled | The position part of the matrix will be used only if this is true; otherwise it will be ignored.
Public property | TargetMatrix | The desired transformation matrix between the selected base and tool frames.
Top
See Also

Reference

CartesianTarget Structure
VisualComponents.Create3D Namespace


CartesianTarget.OrientationIsEnabled Property

CartesianTargetOrientationIsEnabled Property

The orientation part of the matrix will be used only if this is true; otherwise it will be ignored.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool OrientationIsEnabled { get; }
public:
property bool OrientationIsEnabled {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

CartesianTarget Structure
VisualComponents.Create3D Namespace


CartesianTarget.PositionIsEnabled Property

CartesianTargetPositionIsEnabled Property

The position part of the matrix will be used only if this is true; otherwise it will be ignored.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool PositionIsEnabled { get; }
public:
property bool PositionIsEnabled {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

CartesianTarget Structure
VisualComponents.Create3D Namespace


CartesianTarget.TargetMatrix Property

CartesianTargetTargetMatrix Property

The desired transformation matrix between the selected base and tool frames.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Matrix TargetMatrix { get; }
public:
property Matrix TargetMatrix {
    Matrix get ();
}

Property Value

Type: Matrix
See Also

Reference

CartesianTarget Structure
VisualComponents.Create3D Namespace


CartesianTarget Methods

The CartesianTarget type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CartesianTarget Structure
VisualComponents.Create3D Namespace


CartesianTarget.Equals Method

CartesianTargetEquals Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.CartesianTarget.Equals(System.Object)"]

See Also

Reference

CartesianTarget Structure
VisualComponents.Create3D Namespace


CartesianTarget.GetHashCode Method

CartesianTargetGetHashCode Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.CartesianTarget.GetHashCode"]

See Also

Reference

CartesianTarget Structure
VisualComponents.Create3D Namespace


CartesianTarget Operators

The CartesianTarget type exposes the following members.

Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

CartesianTarget Structure
VisualComponents.Create3D Namespace


CartesianTarget.Equality Operator

CartesianTargetEquality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    CartesianTarget obj1,
    CartesianTarget obj2
)
public:
static bool operator ==(
    CartesianTarget obj1,
    CartesianTarget obj2
)

Parameters

obj1
Type: VisualComponents.Create3DCartesianTarget
obj2
Type: VisualComponents.Create3DCartesianTarget

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.CartesianTarget.op_Equality(VisualComponents.Create3D.CartesianTarget,VisualComponents.Create3D.CartesianTarget)"]

See Also

Reference

CartesianTarget Structure
VisualComponents.Create3D Namespace


CartesianTarget.Inequality Operator

CartesianTargetInequality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    CartesianTarget obj1,
    CartesianTarget obj2
)
public:
static bool operator !=(
    CartesianTarget obj1,
    CartesianTarget obj2
)

Parameters

obj1
Type: VisualComponents.Create3DCartesianTarget
obj2
Type: VisualComponents.Create3DCartesianTarget

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.CartesianTarget.op_Inequality(VisualComponents.Create3D.CartesianTarget,VisualComponents.Create3D.CartesianTarget)"]

See Also

Reference

CartesianTarget Structure
VisualComponents.Create3D Namespace


CaseAddedEventArgs Class

Provides data for CaseAdded event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DCaseAddedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class CaseAddedEventArgs : EventArgs
public ref class CaseAddedEventArgs : public EventArgs

The CaseAddedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CaseAddedEventArgs | Initializes a new instance of CaseAddedEventArgs.
Top
Properties
 | Name | Description
Public property | CaseScope | Gets the case that was added.
Public property | Index | The index that the case was added to.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


CaseAddedEventArgs Constructor

Initializes a new instance of CaseAddedEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CaseAddedEventArgs(
    ICaseScope caseScope,
    uint index
)
public:
CaseAddedEventArgs(
    ICaseScope^ caseScope,
    unsigned int index
)

Parameters

caseScope
Type: VisualComponents.Create3DICaseScope
index
Type: SystemUInt32
See Also

Reference

CaseAddedEventArgs Class
VisualComponents.Create3D Namespace


CaseAddedEventArgs Properties

The CaseAddedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | CaseScope | Gets the case that was added.
Public property | Index | The index that the case was added to.
Top
See Also

Reference

CaseAddedEventArgs Class
VisualComponents.Create3D Namespace


CaseAddedEventArgs.CaseScope Property

CaseAddedEventArgsCaseScope Property

Gets the case that was added.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ICaseScope CaseScope { get; }
public:
property ICaseScope^ CaseScope {
    ICaseScope^ get ();
}

Property Value

Type: ICaseScope
See Also

Reference

CaseAddedEventArgs Class
VisualComponents.Create3D Namespace


CaseAddedEventArgs.Index Property

CaseAddedEventArgsIndex Property

The index that the case was added to.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint Index { get; }
public:
property unsigned int Index {
    unsigned int get ();
}

Property Value

Type: UInt32
See Also

Reference

CaseAddedEventArgs Class
VisualComponents.Create3D Namespace


CaseAddedEventArgs Methods

The CaseAddedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CaseAddedEventArgs Class
VisualComponents.Create3D Namespace


CaseMovedEventArgs Class

Provides data for CaseMoved event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DCaseMovedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class CaseMovedEventArgs : EventArgs
public ref class CaseMovedEventArgs : public EventArgs

The CaseMovedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CaseMovedEventArgs | Initializes a new instance of CaseMovedEventArgs.
Top
Properties
 | Name | Description
Public property | CaseScope | Gets the case that was moved.
Public property | NewIndex | The index that the case was moved to.
Public property | OldIndex | The index that the case was in before it was moved.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


CaseMovedEventArgs Constructor

Initializes a new instance of CaseMovedEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CaseMovedEventArgs(
    ICaseScope caseScope,
    uint oldIndex,
    uint newIndex
)
public:
CaseMovedEventArgs(
    ICaseScope^ caseScope,
    unsigned int oldIndex,
    unsigned int newIndex
)

Parameters

caseScope
Type: VisualComponents.Create3DICaseScope
oldIndex
Type: SystemUInt32
newIndex
Type: SystemUInt32
See Also

Reference

CaseMovedEventArgs Class
VisualComponents.Create3D Namespace


CaseMovedEventArgs Properties

The CaseMovedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | CaseScope | Gets the case that was moved.
Public property | NewIndex | The index that the case was moved to.
Public property | OldIndex | The index that the case was in before it was moved.
Top
See Also

Reference

CaseMovedEventArgs Class
VisualComponents.Create3D Namespace


CaseMovedEventArgs.CaseScope Property

CaseMovedEventArgsCaseScope Property

Gets the case that was moved.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ICaseScope CaseScope { get; }
public:
property ICaseScope^ CaseScope {
    ICaseScope^ get ();
}

Property Value

Type: ICaseScope
See Also

Reference

CaseMovedEventArgs Class
VisualComponents.Create3D Namespace


CaseMovedEventArgs.NewIndex Property

CaseMovedEventArgsNewIndex Property

The index that the case was moved to.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint NewIndex { get; }
public:
property unsigned int NewIndex {
    unsigned int get ();
}

Property Value

Type: UInt32
See Also

Reference

CaseMovedEventArgs Class
VisualComponents.Create3D Namespace


CaseMovedEventArgs.OldIndex Property

CaseMovedEventArgsOldIndex Property

The index that the case was in before it was moved.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint OldIndex { get; }
public:
property unsigned int OldIndex {
    unsigned int get ();
}

Property Value

Type: UInt32
See Also

Reference

CaseMovedEventArgs Class
VisualComponents.Create3D Namespace


CaseMovedEventArgs Methods

The CaseMovedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CaseMovedEventArgs Class
VisualComponents.Create3D Namespace


CaseRemovedEventArgs Class

Provides data for CaseAdded event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DCaseRemovedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class CaseRemovedEventArgs : EventArgs
public ref class CaseRemovedEventArgs : public EventArgs

The CaseRemovedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CaseRemovedEventArgs | Initializes a new instance of CaseRemovedEventArgs.
Top
Properties
 | Name | Description
Public property | CaseScope | Gets the case that was removed. This object will be invalidated after the event is completed.
Public property | Index | The index that the case was removed from.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


CaseRemovedEventArgs Constructor

Initializes a new instance of CaseRemovedEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CaseRemovedEventArgs(
    ICaseScope caseScope,
    uint index
)
public:
CaseRemovedEventArgs(
    ICaseScope^ caseScope,
    unsigned int index
)

Parameters

caseScope
Type: VisualComponents.Create3DICaseScope
index
Type: SystemUInt32
See Also

Reference

CaseRemovedEventArgs Class
VisualComponents.Create3D Namespace


CaseRemovedEventArgs Properties

The CaseRemovedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | CaseScope | Gets the case that was removed. This object will be invalidated after the event is completed.
Public property | Index | The index that the case was removed from.
Top
See Also

Reference

CaseRemovedEventArgs Class
VisualComponents.Create3D Namespace


CaseRemovedEventArgs.CaseScope Property

CaseRemovedEventArgsCaseScope Property

Gets the case that was removed. This object will be invalidated after the event is completed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ICaseScope CaseScope { get; }
public:
property ICaseScope^ CaseScope {
    ICaseScope^ get ();
}

Property Value

Type: ICaseScope
See Also

Reference

CaseRemovedEventArgs Class
VisualComponents.Create3D Namespace


CaseRemovedEventArgs.Index Property

CaseRemovedEventArgsIndex Property

The index that the case was removed from.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint Index { get; }
public:
property unsigned int Index {
    unsigned int get ();
}

Property Value

Type: UInt32
See Also

Reference

CaseRemovedEventArgs Class
VisualComponents.Create3D Namespace


CaseRemovedEventArgs Methods

The CaseRemovedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CaseRemovedEventArgs Class
VisualComponents.Create3D Namespace


CategoryChangedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DCategoryChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class CategoryChangedEventArgs : EventArgs
public ref class CategoryChangedEventArgs : public EventArgs

The CategoryChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CategoryChangedEventArgs | Initializes a new instance of the CategoryChangedEventArgs class.
Top
Properties
 | Name | Description
Public property | NewValue | Gets the new category name.
Public property | OldValue | Gets the old category name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


CategoryChangedEventArgs Constructor

Initializes a new instance of the CategoryChangedEventArgs class.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CategoryChangedEventArgs(
    string oldValue,
    string newValue
)
public:
CategoryChangedEventArgs(
    String^ oldValue,
    String^ newValue
)

Parameters

oldValue
Type: SystemString
Old Value.
newValue
Type: SystemString
New Value.
See Also

Reference

CategoryChangedEventArgs Class
VisualComponents.Create3D Namespace


CategoryChangedEventArgs Properties

The CategoryChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets the new category name.
Public property | OldValue | Gets the old category name.
Top
See Also

Reference

CategoryChangedEventArgs Class
VisualComponents.Create3D Namespace


CategoryChangedEventArgs.NewValue Property

CategoryChangedEventArgsNewValue Property

Gets the new category name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string NewValue { get; }
public:
property String^ NewValue {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

CategoryChangedEventArgs Class
VisualComponents.Create3D Namespace


CategoryChangedEventArgs.OldValue Property

CategoryChangedEventArgsOldValue Property

Gets the old category name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string OldValue { get; }
public:
property String^ OldValue {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

CategoryChangedEventArgs Class
VisualComponents.Create3D Namespace


CategoryChangedEventArgs Methods

The CategoryChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CategoryChangedEventArgs Class
VisualComponents.Create3D Namespace


CatiaV4 Enumeration

Catia V4 -> Up to 4.2.5

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum CatiaV4
public enum class CatiaV4
Members
Member name | Value | Description
MODEL | 0 |
SESSION | 1 |
DLV | 2 |
EXP | 3 |
See Also

Reference

VisualComponents.Create3D Namespace


CatiaV5 Enumeration

Catia V5 -> Up to V5-6 R2019 (R29)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum CatiaV5
public enum class CatiaV5
Members
Member name | Value | Description
CATDrawing | 0 |
CATPart | 1 |
CATProduct | 2 |
CATShape | 3 |
CGR | 4 |
See Also

Reference

VisualComponents.Create3D Namespace


CatiaV6 Enumeration

Catia V6 -> up to 2013x

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum CatiaV6
public enum class CatiaV6
Members
Member name | Value | Description
FORMAT_3DXML | 0 |
See Also

Reference

VisualComponents.Create3D Namespace


Change Class

Represents an individual change or set of changes that are required to be processed in order to undo and redo a command.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DChange
More...

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract class Change : IDisposable
public ref class Change abstract : IDisposable

The Change type exposes the following members.

Constructors
 | Name | Description
Protected method | Change | Initializes a new instance of the Change class
Top
Properties
 | Name | Description
Protected property | Changeset |
Public property | Targets | Target object(s) for this change.
Protected property | TargetsList | Access to easier manipulation of targets in derived classes.
Top
Methods
 | Name | Description
Protected method | AddTarget |
Public method | Dispose | Releases all resources used by the Change
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Change and optionally releases the managed resources
Protected method | DoRedo | Implement redo logic.
Protected method | DoUndo | Implement undo logic.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasValueChanged |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DChange
VisualComponents.Create3DAbstractSimInterfaceConnectionChange
VisualComponents.Create3DAnnotationCreationChange
VisualComponents.Create3DComponentDeleteChange
VisualComponents.Create3DDimensionChange
VisualComponents.Create3DDimensionCreationChange
VisualComponents.Create3DFeatureHierarchyChange
VisualComponents.Create3DGroupChange
VisualComponents.Create3DLoadComponentChange
VisualComponents.Create3DMethodChangeTTarget
VisualComponents.Create3DProcessFlowGroupDeleteChange
VisualComponents.Create3DPropertyChange
VisualComponents.Create3DSelectionChange
VisualComponents.Create3DSimInterfaceConnectionChange
VisualComponents.Create3DSimSignalConnectionChange
VisualComponents.Create3DTransportLinkDeleteChange


Change Constructor

Initializes a new instance of the Change class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected Change()
protected:
Change()
See Also

Reference

Change Class
VisualComponents.Create3D Namespace


Change Properties

The Change type exposes the following members.

Properties
 | Name | Description
Protected property | Changeset |
Public property | Targets | Target object(s) for this change.
Protected property | TargetsList | Access to easier manipulation of targets in derived classes.
Top
See Also

Reference

Change Class
VisualComponents.Create3D Namespace


Change.Changeset Property

ChangeChangeset Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected Changeset Changeset { get; set; }
protected:
property Changeset^ Changeset {
    Changeset^ get ();
    void set (Changeset^ value);
}

Property Value

Type: Changeset
See Also

Reference

Change Class
VisualComponents.Create3D Namespace


Change.Targets Property

ChangeTargets Property

Target object(s) for this change.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<Object> Targets { get; }
public:
property ReadOnlyCollection<Object^>^ Targets {
    ReadOnlyCollection<Object^>^ get ();
}

Property Value

Type: ReadOnlyCollectionObject
See Also

Reference

Change Class
VisualComponents.Create3D Namespace


Change.TargetsList Property

ChangeTargetsList Property

Access to easier manipulation of targets in derived classes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected IList<Object> TargetsList { get; }
protected:
property IList<Object^>^ TargetsList {
    IList<Object^>^ get ();
}

Property Value

Type: IListObject
See Also

Reference

Change Class
VisualComponents.Create3D Namespace


Change Methods

The Change type exposes the following members.

Methods
 | Name | Description
Protected method | AddTarget |
Public method | Dispose |
Protected method | Dispose(Boolean) |
Protected method | DoRedo | Implement redo logic.
Protected method | DoUndo | Implement undo logic.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasValueChanged |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

Change Class
VisualComponents.Create3D Namespace


Change.AddTarget Method

ChangeAddTarget Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected void AddTarget(
    Object newTarget
)
protected:
void AddTarget(
    Object^ newTarget
)

Parameters

newTarget
Type: SystemObject
See Also

Reference

Change Class
VisualComponents.Create3D Namespace


Change.Dispose Method

ChangeDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Change
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Change and optionally releases the managed resources
Top
See Also

Reference

Change Class
VisualComponents.Create3D Namespace


Change.Dispose Method

ChangeDispose Method

Releases all resources used by the Change

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Dispose()
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

Change Class
Dispose Overload
VisualComponents.Create3D Namespace


Change.Dispose Method (Boolean)

ChangeDispose Method (Boolean)

Releases the unmanaged resources used by the Change and optionally releases the managed resources

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void Dispose(
    bool disposing
)
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

Change Class
Dispose Overload
VisualComponents.Create3D Namespace


Change.DoRedo Method

ChangeDoRedo Method

Implement redo logic.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected abstract void DoRedo()
protected:
virtual void DoRedo() abstract
See Also

Reference

Change Class
VisualComponents.Create3D Namespace


Change.DoUndo Method

ChangeDoUndo Method

Implement undo logic.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected abstract void DoUndo()
protected:
virtual void DoUndo() abstract
See Also

Reference

Change Class
VisualComponents.Create3D Namespace


Change.HasValueChanged Method

ChangeHasValueChanged Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual bool HasValueChanged()
protected:
virtual bool HasValueChanged()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.Change.HasValueChanged"]

See Also

Reference

Change Class
VisualComponents.Create3D Namespace


Changeset Class

Represents a collection of changes that are undone/redone atomically.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DChangeset

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class Changeset : IDisposable
public ref class Changeset sealed : IDisposable

The Changeset type exposes the following members.

Constructors
 | Name | Description
Public method | Changeset | Initializes new changeset with list of changes.
Top
Properties
 | Name | Description
Public property | Changes | Returns changes associated to this change set.
Public property | OperationSucceeded | Notifies UndoService whether changes in this changeset were Undone or Redone successfully.
Top
Methods
 | Name | Description
Public method | AddChange | Add a change to this changeset.
Public method | Dispose | Releases all resources used by the Changeset
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Redo | Redo changes in this change set.
Public method | RemoveChange | Remove change from this changeset.
Public method | RemoveUnchangedChanges | Removes changes which did not contain state changes (e.g. new and old values were equal).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Undo | Undo changes in this change set.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


Changeset Constructor

Initializes new changeset with list of changes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Changeset(
    IList<Change> changes
)
public:
Changeset(
    IList<Change^>^ changes
)

Parameters

changes
Type: System.Collections.GenericIListChange
Changes to add to this changeset.
See Also

Reference

Changeset Class
VisualComponents.Create3D Namespace


Changeset Properties

The Changeset type exposes the following members.

Properties
 | Name | Description
Public property | Changes | Returns changes associated to this change set.
Public property | OperationSucceeded | Notifies UndoService whether changes in this changeset were Undone or Redone successfully.
Top
See Also

Reference

Changeset Class
VisualComponents.Create3D Namespace


Changeset.Changes Property

ChangesetChanges Property

Returns changes associated to this change set.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<Change> Changes { get; }
public:
property ReadOnlyCollection<Change^>^ Changes {
    ReadOnlyCollection<Change^>^ get ();
}

Property Value

Type: ReadOnlyCollectionChange
See Also

Reference

Changeset Class
VisualComponents.Create3D Namespace


Changeset.OperationSucceeded Property

ChangesetOperationSucceeded Property

Notifies UndoService whether changes in this changeset were Undone or Redone successfully.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool OperationSucceeded { get; set; }
public:
property bool OperationSucceeded {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Changeset Class
VisualComponents.Create3D Namespace


Changeset Methods

The Changeset type exposes the following members.

Methods
 | Name | Description
Public method | AddChange | Add a change to this changeset.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Redo | Redo changes in this change set.
Public method | RemoveChange | Remove change from this changeset.
Public method | RemoveUnchangedChanges | Removes changes which did not contain state changes (e.g. new and old values were equal).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Undo | Undo changes in this change set.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

Changeset Class
VisualComponents.Create3D Namespace


Changeset.AddChange Method

ChangesetAddChange Method

Add a change to this changeset.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void AddChange(
    Change change
)
public:
void AddChange(
    Change^ change
)

Parameters

change
Type: VisualComponents.Create3DChange
Change to be added.
See Also

Reference

Changeset Class
VisualComponents.Create3D Namespace


Changeset.Dispose Method

ChangesetDispose Method

Releases all resources used by the Changeset

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Dispose()
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

Changeset Class
VisualComponents.Create3D Namespace


Changeset.Redo Method

ChangesetRedo Method

Redo changes in this change set.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Redo()
public:
void Redo()
See Also

Reference

Changeset Class
VisualComponents.Create3D Namespace


Changeset.RemoveChange Method

ChangesetRemoveChange Method

Remove change from this changeset.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RemoveChange(
    Change change
)
public:
void RemoveChange(
    Change^ change
)

Parameters

change
Type: VisualComponents.Create3DChange
Change to be removed.
See Also

Reference

Changeset Class
VisualComponents.Create3D Namespace


Changeset.RemoveUnchangedChanges Method

ChangesetRemoveUnchangedChanges Method

Removes changes which did not contain state changes (e.g. new and old values were equal).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RemoveUnchangedChanges()
public:
void RemoveUnchangedChanges()
See Also

Reference

Changeset Class
VisualComponents.Create3D Namespace


Changeset.Undo Method

ChangesetUndo Method

Undo changes in this change set.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Undo()
public:
void Undo()
See Also

Reference

Changeset Class
VisualComponents.Create3D Namespace


ChartDataType Enumeration

Type of information stored in IStatisticsChartBase.DataRows.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ChartDataType
public enum class ChartDataType
Members
Member name | Value | Description
OneSampledValue | 0 | RowFields contains one Y-value per component/property.
MinMaxAverageValues | 1 | RowFields contains one 5 double values for each component/property: Average Min during sampling period Max during sampling period Reserved Reserved
See Also

Reference

VisualComponents.Create3D Namespace


ChartLayout Class

Defines a set of layout positions that can be populated with charts.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DChartLayout

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ChartLayout : ICloneable
public ref class ChartLayout : ICloneable

The ChartLayout type exposes the following members.

Constructors
 | Name | Description
Public method | ChartLayout | Default constructor.
Public method | ChartLayout(String, ListChartPosition) | Initializes a new instance of the ChartLayout class
Public method | ChartLayout(String, ListChartPosition, String) | Layout constructor.
Top
Properties
 | Name | Description
Public property | ActualColumns | Actual number of columns in the layout.
Public property | ActualRows | Actual number of rows in the layout.
Public property | Configuration | Set of layout positions.
Public property | DashboardType | Outputs the layout type as a String.
Public property | Description |
Public property | LayoutSize | Maximum number of columns and rows. Calculated based on all layout positions.
Public property | Name | Layout name.
Top
Methods
 | Name | Description
Public method | Clone | ICloneable interface implementation.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ChartLayout Constructor

Overload List
 | Name | Description
Public method | ChartLayout | Default constructor.
Public method | ChartLayout(String, ListChartPosition) | Initializes a new instance of the ChartLayout class
Public method | ChartLayout(String, ListChartPosition, String) | Layout constructor.
Top
See Also

Reference

ChartLayout Class
VisualComponents.Create3D Namespace


ChartLayout Constructor

Default constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ChartLayout()
public:
ChartLayout()
See Also

Reference

ChartLayout Class
ChartLayout Overload
VisualComponents.Create3D Namespace


ChartLayout Constructor (String, List(ChartPosition))

ChartLayout Constructor (String, ListChartPosition)

Initializes a new instance of the ChartLayout class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ChartLayout(
    string name,
    List<ChartPosition> positions
)
public:
ChartLayout(
    String^ name,
    List<ChartPosition^>^ positions
)

Parameters

name
Type: SystemString
positions
Type: System.Collections.GenericListChartPosition
See Also

Reference

ChartLayout Class
ChartLayout Overload
VisualComponents.Create3D Namespace


ChartLayout Constructor (String, List(ChartPosition), String)

ChartLayout Constructor (String, ListChartPosition, String)

Layout constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ChartLayout(
    string name,
    List<ChartPosition> positions,
    string description
)
public:
ChartLayout(
    String^ name,
    List<ChartPosition^>^ positions,
    String^ description
)

Parameters

name
Type: SystemString
Layout name
positions
Type: System.Collections.GenericListChartPosition
Set of positions
description
Type: SystemString
Layout description
See Also

Reference

ChartLayout Class
ChartLayout Overload
VisualComponents.Create3D Namespace


ChartLayout Properties

The ChartLayout type exposes the following members.

Properties
 | Name | Description
Public property | ActualColumns | Actual number of columns in the layout.
Public property | ActualRows | Actual number of rows in the layout.
Public property | Configuration | Set of layout positions.
Public property | DashboardType | Outputs the layout type as a String.
Public property | Description |
Public property | LayoutSize | Maximum number of columns and rows. Calculated based on all layout positions.
Public property | Name | Layout name.
Top
See Also

Reference

ChartLayout Class
VisualComponents.Create3D Namespace


ChartLayout.ActualColumns Property

ChartLayoutActualColumns Property

Actual number of columns in the layout.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ActualColumns { get; }
public:
property int ActualColumns {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ChartLayout Class
VisualComponents.Create3D Namespace


ChartLayout.ActualRows Property

ChartLayoutActualRows Property

Actual number of rows in the layout.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ActualRows { get; }
public:
property int ActualRows {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ChartLayout Class
VisualComponents.Create3D Namespace


ChartLayout.Configuration Property

ChartLayoutConfiguration Property

Set of layout positions.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<ChartPosition> Configuration { get; set; }
public:
property List<ChartPosition^>^ Configuration {
    List<ChartPosition^>^ get ();
    void set (List<ChartPosition^>^ value);
}

Property Value

Type: ListChartPosition
See Also

Reference

ChartLayout Class
VisualComponents.Create3D Namespace


ChartLayout.DashboardType Property

ChartLayoutDashboardType Property

Outputs the layout type as a String.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string DashboardType { get; }
public:
property String^ DashboardType {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ChartLayout Class
VisualComponents.Create3D Namespace


ChartLayout.Description Property

ChartLayoutDescription Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; set; }
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ChartLayout Class
VisualComponents.Create3D Namespace


ChartLayout.LayoutSize Property

ChartLayoutLayoutSize Property

Maximum number of columns and rows. Calculated based on all layout positions.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LayoutSize LayoutSize { get; }
public:
property LayoutSize LayoutSize {
    LayoutSize get ();
}

Property Value

Type: LayoutSize
See Also

Reference

ChartLayout Class
VisualComponents.Create3D Namespace


ChartLayout.Name Property

ChartLayoutName Property

Layout name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; set; }
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ChartLayout Class
VisualComponents.Create3D Namespace


ChartLayout Methods

The ChartLayout type exposes the following members.

Methods
 | Name | Description
Public method | Clone | ICloneable interface implementation.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ChartLayout Class
VisualComponents.Create3D Namespace


ChartLayout.Clone Method

ChartLayoutClone Method

ICloneable interface implementation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Clone()
public:
virtual Object^ Clone() sealed

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.Create3D.ChartLayout.Clone"]

Implements

ICloneableClone
See Also

Reference

ChartLayout Class
VisualComponents.Create3D Namespace


ChartPosition Class

Defines a layout position. Specifies row/column start and span.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DChartPosition

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ChartPosition : INotifyPropertyChanged,
    ICloneable
public ref class ChartPosition : INotifyPropertyChanged,
    ICloneable

The ChartPosition type exposes the following members.

Constructors
 | Name | Description
Public method | ChartPosition | Default constructor.
Public method | ChartPosition(String) | Constructor.
Public method | ChartPosition(Int32, Int32, Int32, Int32, Int32) | Initializes a new instance of the ChartPosition class
Public method | ChartPosition(String, Int32, Int32, Int32, Int32, Int32) | Constructor.
Top
Properties
 | Name | Description
Public property | Column | Start column.
Public property | ColumnSpan | Column span.
Public property | Index | Position index in layout.
Public property | Name | Position label.
Public property | Row | Start row.
Public property | RowSpan | Row span.
Top
Methods
 | Name | Description
Public method | Clone | ICloneable interface implementation.
Public method | Equals | Equality comparison. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | INotifyPropertyChanged interface implementation.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ChartPosition Constructor

Overload List
 | Name | Description
Public method | ChartPosition | Default constructor.
Public method | ChartPosition(String) | Constructor.
Public method | ChartPosition(Int32, Int32, Int32, Int32, Int32) | Initializes a new instance of the ChartPosition class
Public method | ChartPosition(String, Int32, Int32, Int32, Int32, Int32) | Constructor.
Top
See Also

Reference

ChartPosition Class
VisualComponents.Create3D Namespace


ChartPosition Constructor

Default constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ChartPosition()
public:
ChartPosition()
See Also

Reference

ChartPosition Class
ChartPosition Overload
VisualComponents.Create3D Namespace


ChartPosition Constructor (String)

Constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ChartPosition(
    string name
)
public:
ChartPosition(
    String^ name
)

Parameters

name
Type: SystemString
Position label
See Also

Reference

ChartPosition Class
ChartPosition Overload
VisualComponents.Create3D Namespace


ChartPosition Constructor (Int32, Int32, Int32, Int32, Int32)

Initializes a new instance of the ChartPosition class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ChartPosition(
    int index,
    int column,
    int row,
    int columnSpan,
    int rowSpan
)
public:
ChartPosition(
    int index,
    int column,
    int row,
    int columnSpan,
    int rowSpan
)

Parameters

index
Type: SystemInt32
column
Type: SystemInt32
row
Type: SystemInt32
columnSpan
Type: SystemInt32
rowSpan
Type: SystemInt32
See Also

Reference

ChartPosition Class
ChartPosition Overload
VisualComponents.Create3D Namespace


ChartPosition Constructor (String, Int32, Int32, Int32, Int32, Int32)

Constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ChartPosition(
    string name,
    int index,
    int column,
    int row,
    int columnSpan,
    int rowSpan
)
public:
ChartPosition(
    String^ name,
    int index,
    int column,
    int row,
    int columnSpan,
    int rowSpan
)

Parameters

name
Type: SystemString
Position label
index
Type: SystemInt32
Index in layout
column
Type: SystemInt32
Start column
row
Type: SystemInt32
Start row
columnSpan
Type: SystemInt32
Column span
rowSpan
Type: SystemInt32
Row span
See Also

Reference

ChartPosition Class
ChartPosition Overload
VisualComponents.Create3D Namespace


ChartPosition Properties

The ChartPosition type exposes the following members.

Properties
 | Name | Description
Public property | Column | Start column.
Public property | ColumnSpan | Column span.
Public property | Index | Position index in layout.
Public property | Name | Position label.
Public property | Row | Start row.
Public property | RowSpan | Row span.
Top
See Also

Reference

ChartPosition Class
VisualComponents.Create3D Namespace


ChartPosition.Column Property

ChartPositionColumn Property

Start column.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Column { get; set; }
public:
property int Column {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ChartPosition Class
VisualComponents.Create3D Namespace


ChartPosition.ColumnSpan Property

ChartPositionColumnSpan Property

Column span.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ColumnSpan { get; set; }
public:
property int ColumnSpan {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ChartPosition Class
VisualComponents.Create3D Namespace


ChartPosition.Index Property

ChartPositionIndex Property

Position index in layout.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Index { get; set; }
public:
property int Index {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ChartPosition Class
VisualComponents.Create3D Namespace


ChartPosition.Name Property

ChartPositionName Property

Position label.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; set; }
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ChartPosition Class
VisualComponents.Create3D Namespace


ChartPosition.Row Property

ChartPositionRow Property

Start row.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Row { get; set; }
public:
property int Row {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ChartPosition Class
VisualComponents.Create3D Namespace


ChartPosition.RowSpan Property

ChartPositionRowSpan Property

Row span.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int RowSpan { get; set; }
public:
property int RowSpan {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ChartPosition Class
VisualComponents.Create3D Namespace


ChartPosition Methods

The ChartPosition type exposes the following members.

Methods
 | Name | Description
Public method | Clone | ICloneable interface implementation.
Public method | Equals | Equality comparison. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Hash code. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ChartPosition Class
VisualComponents.Create3D Namespace


ChartPosition.Clone Method

ChartPositionClone Method

ICloneable interface implementation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Clone()
public:
virtual Object^ Clone() sealed

Return Value

Type: Object
Cloned position

Implements

ICloneableClone
See Also

Reference

ChartPosition Class
VisualComponents.Create3D Namespace


ChartPosition.Equals Method

ChartPositionEquals Method

Equality comparison.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
Another position

Return Value

Type: Boolean
Equality check result
See Also

Reference

ChartPosition Class
VisualComponents.Create3D Namespace


ChartPosition.GetHashCode Method

ChartPositionGetHashCode Method

Hash code.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32
Hash code
See Also

Reference

ChartPosition Class
VisualComponents.Create3D Namespace


ChartPosition.OnPropertyChanged Method

ChartPositionOnPropertyChanged Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected void OnPropertyChanged(
    string name
)
protected:
void OnPropertyChanged(
    String^ name
)

Parameters

name
Type: SystemString
See Also

Reference

ChartPosition Class
VisualComponents.Create3D Namespace


ChartPosition Events

The ChartPosition type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | INotifyPropertyChanged interface implementation.
Top
See Also

Reference

ChartPosition Class
VisualComponents.Create3D Namespace


ChartPosition.PropertyChanged Event

ChartPositionPropertyChanged Event

INotifyPropertyChanged interface implementation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event PropertyChangedEventHandler PropertyChanged
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

ChartPosition Class
VisualComponents.Create3D Namespace


ChartPositionExtensions Class

Extension helper for ChartLayout and ChartPosition classes.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DChartPositionExtensions

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class ChartPositionExtensions
[ExtensionAttribute]
public ref class ChartPositionExtensions abstract sealed

The ChartPositionExtensions type exposes the following members.

Methods
Name | Description
ToClonedList |
Top
See Also

Reference

VisualComponents.Create3D Namespace


ChartPositionExtensions Methods

The ChartPositionExtensions type exposes the following members.

Methods
Name | Description
ToClonedList |
Top
See Also

Reference

ChartPositionExtensions Class
VisualComponents.Create3D Namespace


ChartPositionExtensions.ToClonedList Method

ChartPositionExtensionsToClonedList Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static List<ChartPosition> ToClonedList(
    this IEnumerable<ChartPosition> source
)
public:
[ExtensionAttribute]
static List<ChartPosition^>^ ToClonedList(
    IEnumerable<ChartPosition^>^ source
)

Parameters

source
Type: System.Collections.GenericIEnumerableChartPosition

Return Value

Type: ListChartPosition

[Missing <returns> documentation for "M:VisualComponents.Create3D.ChartPositionExtensions.ToClonedList(System.Collections.Generic.IEnumerable{VisualComponents.Create3D.ChartPosition})"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerableChartPosition . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ChartPositionExtensions Class
VisualComponents.Create3D Namespace


ChartTileState Enumeration

Represents the state of an individual tile

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ChartTileState
public enum class ChartTileState
Members
Member name | Value | Description
Normal | 0 | All tiles will return 'Normal' as long as no tile is in a 'Maximized' state. Conversely if any Tile is 'Maximized' then no Tile with return 'Normal'.
Maximized | 1 | If any tile is in a 'Maximized' state then all other tiles can only be 'Maximized', 'Minimized' or 'MinimizedExpanded'.
Minimized | 2 | 'Minimized' is only returned if there is at least one tile in a 'Maximized' state. A Tile in the 'Minimized' state will usually just display its Header not its Content.
MinimizedExpanded | 3 | 'MinimizedExpanded' is only returned if there is at least one tile in a 'Maximized' state. A Tile in the 'MinimizedExpanded' state will usually display its Header and its Content but the Tile will be grouped with all other minimized Tiles, both collapsed and expanded.
See Also

Reference

VisualComponents.Create3D Namespace


ChartTileType Enumeration

Layout position state: either placeholder or chart. Note: DummyTile is used only internally.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ChartTileType
public enum class ChartTileType
Members
Member name | Value | Description
DummyTile | 0 |
PlaceholderTile | 1 |
ActualTile | 2 |
See Also

Reference

VisualComponents.Create3D Namespace


ChartType Enumeration

Statistics chart type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ChartType
public enum class ChartType
Members
Member name | Value | Description
None | 0 | Unknown.
LineSeries | 1 | Line chart.
ColumnSeries | 2 | Bar chart.
AreaSeries | 3 | Area chart.
PieSeries | 4 | Pie chart.
See Also

Reference

VisualComponents.Create3D Namespace


ChildAddedEventArgs Class

Event data for ChildAdded event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DChildAddedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ChildAddedEventArgs : EventArgs
public ref class ChildAddedEventArgs : public EventArgs

The ChildAddedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ChildAddedEventArgs | Initializes a new instance of the ChildAddedEventArgs class.
Top
Properties
 | Name | Description
Public property | Node | Gets the added child node.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ChildAddedEventArgs Constructor

Initializes a new instance of the ChildAddedEventArgs class.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ChildAddedEventArgs(
    ISimNode node
)
public:
ChildAddedEventArgs(
    ISimNode^ node
)

Parameters

node
Type: VisualComponents.Create3DISimNode
Node.
See Also

Reference

ChildAddedEventArgs Class
VisualComponents.Create3D Namespace


ChildAddedEventArgs Properties

The ChildAddedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Node | Gets the added child node.
Top
See Also

Reference

ChildAddedEventArgs Class
VisualComponents.Create3D Namespace


ChildAddedEventArgs.Node Property

ChildAddedEventArgsNode Property

Gets the added child node.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimNode Node { get; }
public:
property ISimNode^ Node {
    ISimNode^ get ();
}

Property Value

Type: ISimNode
See Also

Reference

ChildAddedEventArgs Class
VisualComponents.Create3D Namespace


ChildAddedEventArgs Methods

The ChildAddedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ChildAddedEventArgs Class
VisualComponents.Create3D Namespace


ClippingMode Enumeration

Clipping mode enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ClippingMode
public enum class ClippingMode
Members
Member name | Value | Description
Automatic | 0 | Get world dimensions and calculate bound to fit everything.
Classic | 1 | Use gaze length based scaling of clipping planes
Manual | 2 | Manual clipping using far and near planes
See Also

Reference

VisualComponents.Create3D Namespace


CloningMode Enumeration

Cloning mode enumeration.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum CloningMode
public enum class CloningMode
Members
Member name | Value | Description
Shared | 0 | Create a clone that shares data with the original.
Unique | 1 | Create a clone with its own unique copy of the data.
See Also

Reference

VisualComponents.Create3D Namespace


CollisionDetectedEventArgs Class

Event data for CollisionDetected event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DCollisionDetectedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class CollisionDetectedEventArgs : EventArgs
public ref class CollisionDetectedEventArgs : public EventArgs

The CollisionDetectedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CollisionDetectedEventArgs | Initializes a new instance of CollisionDetectedEventArgs
Top
Properties
 | Name | Description
Public property | CollisionDetector | Gets the collision detector.
Public property | Collisions | Gets the collision records.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


CollisionDetectedEventArgs Constructor

Initializes a new instance of CollisionDetectedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CollisionDetectedEventArgs(
    ICollisionDetector detector,
    IEnumerable<ICollisionRecord> records
)
public:
CollisionDetectedEventArgs(
    ICollisionDetector^ detector,
    IEnumerable<ICollisionRecord^>^ records
)

Parameters

detector
Type: VisualComponents.Create3DICollisionDetector
Collision detector.
records
Type: System.Collections.GenericIEnumerableICollisionRecord
List of collision records.
See Also

Reference

CollisionDetectedEventArgs Class
VisualComponents.Create3D Namespace


CollisionDetectedEventArgs Properties

The CollisionDetectedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | CollisionDetector | Gets the collision detector.
Public property | Collisions | Gets the collision records.
Top
See Also

Reference

CollisionDetectedEventArgs Class
VisualComponents.Create3D Namespace


CollisionDetectedEventArgs.CollisionDetector Property

CollisionDetectedEventArgsCollisionDetector Property

Gets the collision detector.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ICollisionDetector CollisionDetector { get; }
public:
property ICollisionDetector^ CollisionDetector {
    ICollisionDetector^ get ();
}

Property Value

Type: ICollisionDetector
See Also

Reference

CollisionDetectedEventArgs Class
VisualComponents.Create3D Namespace


CollisionDetectedEventArgs.Collisions Property

CollisionDetectedEventArgsCollisions Property

Gets the collision records.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<ICollisionRecord> Collisions { get; }
public:
property ReadOnlyCollection<ICollisionRecord^>^ Collisions {
    ReadOnlyCollection<ICollisionRecord^>^ get ();
}

Property Value

Type: ReadOnlyCollectionICollisionRecord
See Also

Reference

CollisionDetectedEventArgs Class
VisualComponents.Create3D Namespace


CollisionDetectedEventArgs Methods

The CollisionDetectedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CollisionDetectedEventArgs Class
VisualComponents.Create3D Namespace


CollisionDetectionActivatedEventArgs Class

Represents a collision detection activated event arguments. It derives from the EventArgs class EventArgs.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DCollisionDetectionActivatedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class CollisionDetectionActivatedEventArgs : EventArgs
public ref class CollisionDetectionActivatedEventArgs : public EventArgs

The CollisionDetectionActivatedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CollisionDetectionActivatedEventArgs | Initializes a new instance of the collision detection activated EventArgs with a Boolean parameters.
Top
Properties
 | Name | Description
Public property | Activated | Gets a Boolean value, true or false, which indicates if the collision detection is activated.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


CollisionDetectionActivatedEventArgs Constructor

Initializes a new instance of the collision detection activated EventArgs with a Boolean parameters.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CollisionDetectionActivatedEventArgs(
    bool activated
)
public:
CollisionDetectionActivatedEventArgs(
    bool activated
)

Parameters

activated
Type: SystemBoolean
See Also

Reference

CollisionDetectionActivatedEventArgs Class
VisualComponents.Create3D Namespace


CollisionDetectionActivatedEventArgs Properties

The CollisionDetectionActivatedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Activated | Gets a Boolean value, true or false, which indicates if the collision detection is activated.
Top
See Also

Reference

CollisionDetectionActivatedEventArgs Class
VisualComponents.Create3D Namespace


CollisionDetectionActivatedEventArgs.Activated Property

CollisionDetectionActivatedEventArgsActivated Property

Gets a Boolean value, true or false, which indicates if the collision detection is activated.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Activated { get; protected set; }
public:
property bool Activated {
    bool get ();
    protected: void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CollisionDetectionActivatedEventArgs Class
VisualComponents.Create3D Namespace


CollisionDetectionActivatedEventArgs Methods

The CollisionDetectionActivatedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CollisionDetectionActivatedEventArgs Class
VisualComponents.Create3D Namespace


CollisionDetectionConfigElement Class

Configuration file element for collision options.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.Create3DCollisionDetectionConfigElement

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class CollisionDetectionConfigElement : ConfigurationElement
public ref class CollisionDetectionConfigElement : public ConfigurationElement

The CollisionDetectionConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | CollisionDetectionConfigElement | Constructor.
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | DetectFirst | Whether to stop collision detected on first collision.
Public property | Distance | Collision tolerance.
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Public property | Environment |
Public property | EnvironmentTools |
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is . (Inherited from ConfigurationElement.)
Public property | Highlight | Whether to highlight colliding simulation nodes.
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | MinimumDistance | Whether to render the minimum distance.
Public property | OtherRobots |
Public property | OtherRobotsTools |
Public property | Others |
Public property | OthersTools |
Public property | Pedestals |
Public property | PedestalsTools |
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | ServoTracks |
Public property | ServoTracksTools |
Public property | Stop | Whether to stop the simulation when a collision is detected.
Public property | Tables |
Public property | TablesTools |
Public property | Tools |
Public property | ToolsTools |
Top
Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks
These options are visibile in Program tab -> Collision Detection group -> Detectors dropdown. These options are similar to the ones in ICollisionDetector.
See Also

Reference

VisualComponents.Create3D Namespace


CollisionDetectionConfigElement Constructor

Constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CollisionDetectionConfigElement()
public:
CollisionDetectionConfigElement()
See Also

Reference

CollisionDetectionConfigElement Class
VisualComponents.Create3D Namespace


CollisionDetectionConfigElement Properties

The CollisionDetectionConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | DetectFirst | Whether to stop collision detected on first collision.
Public property | Distance | Collision tolerance.
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Public property | Environment |
Public property | EnvironmentTools |
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is . (Inherited from ConfigurationElement.)
Public property | Highlight | Whether to highlight colliding simulation nodes.
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | MinimumDistance | Whether to render the minimum distance.
Public property | OtherRobots |
Public property | OtherRobotsTools |
Public property | Others |
Public property | OthersTools |
Public property | Pedestals |
Public property | PedestalsTools |
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | ServoTracks |
Public property | ServoTracksTools |
Public property | Stop | Whether to stop the simulation when a collision is detected.
Public property | Tables |
Public property | TablesTools |
Public property | Tools |
Public property | ToolsTools |
Top
See Also

Reference

CollisionDetectionConfigElement Class
VisualComponents.Create3D Namespace


CollisionDetectionConfigElement.DetectFirst Property

CollisionDetectionConfigElementDetectFirst Property

Whether to stop collision detected on first collision.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool DetectFirst { get; set; }
public:
property bool DetectFirst {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CollisionDetectionConfigElement Class
VisualComponents.Create3D Namespace


CollisionDetectionConfigElement.Distance Property

CollisionDetectionConfigElementDistance Property

Collision tolerance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Distance { get; set; }
public:
property double Distance {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

CollisionDetectionConfigElement Class
VisualComponents.Create3D Namespace


CollisionDetectionConfigElement.Environment Property

CollisionDetectionConfigElementEnvironment Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Environment { get; set; }
public:
property bool Environment {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CollisionDetectionConfigElement Class
VisualComponents.Create3D Namespace


CollisionDetectionConfigElement.EnvironmentTools Property

CollisionDetectionConfigElementEnvironmentTools Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool EnvironmentTools { get; set; }
public:
property bool EnvironmentTools {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CollisionDetectionConfigElement Class
VisualComponents.Create3D Namespace


CollisionDetectionConfigElement.Highlight Property

CollisionDetectionConfigElementHighlight Property

Whether to highlight colliding simulation nodes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Highlight { get; set; }
public:
property bool Highlight {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CollisionDetectionConfigElement Class
VisualComponents.Create3D Namespace


CollisionDetectionConfigElement.MinimumDistance Property

CollisionDetectionConfigElementMinimumDistance Property

Whether to render the minimum distance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool MinimumDistance { get; set; }
public:
property bool MinimumDistance {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CollisionDetectionConfigElement Class
VisualComponents.Create3D Namespace


CollisionDetectionConfigElement.OtherRobots Property

CollisionDetectionConfigElementOtherRobots Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool OtherRobots { get; set; }
public:
property bool OtherRobots {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CollisionDetectionConfigElement Class
VisualComponents.Create3D Namespace


CollisionDetectionConfigElement.OtherRobotsTools Property

CollisionDetectionConfigElementOtherRobotsTools Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool OtherRobotsTools { get; set; }
public:
property bool OtherRobotsTools {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CollisionDetectionConfigElement Class
VisualComponents.Create3D Namespace


CollisionDetectionConfigElement.Others Property

CollisionDetectionConfigElementOthers Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Others { get; set; }
public:
property bool Others {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CollisionDetectionConfigElement Class
VisualComponents.Create3D Namespace


CollisionDetectionConfigElement.OthersTools Property

CollisionDetectionConfigElementOthersTools Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool OthersTools { get; set; }
public:
property bool OthersTools {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CollisionDetectionConfigElement Class
VisualComponents.Create3D Namespace


CollisionDetectionConfigElement.Pedestals Property

CollisionDetectionConfigElementPedestals Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Pedestals { get; set; }
public:
property bool Pedestals {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CollisionDetectionConfigElement Class
VisualComponents.Create3D Namespace


CollisionDetectionConfigElement.PedestalsTools Property

CollisionDetectionConfigElementPedestalsTools Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool PedestalsTools { get; set; }
public:
property bool PedestalsTools {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CollisionDetectionConfigElement Class
VisualComponents.Create3D Namespace


CollisionDetectionConfigElement.ServoTracks Property

CollisionDetectionConfigElementServoTracks Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ServoTracks { get; set; }
public:
property bool ServoTracks {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CollisionDetectionConfigElement Class
VisualComponents.Create3D Namespace


CollisionDetectionConfigElement.ServoTracksTools Property

CollisionDetectionConfigElementServoTracksTools Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ServoTracksTools { get; set; }
public:
property bool ServoTracksTools {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CollisionDetectionConfigElement Class
VisualComponents.Create3D Namespace


CollisionDetectionConfigElement.Stop Property

CollisionDetectionConfigElementStop Property

Whether to stop the simulation when a collision is detected.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Stop { get; set; }
public:
property bool Stop {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CollisionDetectionConfigElement Class
VisualComponents.Create3D Namespace


CollisionDetectionConfigElement.Tables Property

CollisionDetectionConfigElementTables Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Tables { get; set; }
public:
property bool Tables {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CollisionDetectionConfigElement Class
VisualComponents.Create3D Namespace


CollisionDetectionConfigElement.TablesTools Property

CollisionDetectionConfigElementTablesTools Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool TablesTools { get; set; }
public:
property bool TablesTools {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CollisionDetectionConfigElement Class
VisualComponents.Create3D Namespace


CollisionDetectionConfigElement.Tools Property

CollisionDetectionConfigElementTools Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Tools { get; set; }
public:
property bool Tools {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CollisionDetectionConfigElement Class
VisualComponents.Create3D Namespace


CollisionDetectionConfigElement.ToolsTools Property

CollisionDetectionConfigElementToolsTools Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ToolsTools { get; set; }
public:
property bool ToolsTools {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CollisionDetectionConfigElement Class
VisualComponents.Create3D Namespace


CollisionDetectionConfigElement Methods

The CollisionDetectionConfigElement type exposes the following members.

Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CollisionDetectionConfigElement Class
VisualComponents.Create3D Namespace


CollisionDetectionSection Class

Configuration file section for collision options.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationSection
VisualComponents.Create3DCollisionDetectionSection

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class CollisionDetectionSection : ConfigurationSection,
    ICollisionDetectionSection, ISection
public ref class CollisionDetectionSection sealed : public ConfigurationSection,
    ICollisionDetectionSection, ISection

The CollisionDetectionSection type exposes the following members.

Constructors
 | Name | Description
Public method | CollisionDetectionSection | Constructor.
Top
Properties
 | Name | Description
Public property | CollisionDetectionElement | Configuration file element for collision options.
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName | Section's name in configuration file.
Public property | SectionType | Interface type.
Public property | SectionVersion | Section's version number.
Top
Methods
 | Name | Description
Public method | CheckVersion | Upgrade configuration to the latest version.
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection | Finds typed section by name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


CollisionDetectionSection Constructor

Constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CollisionDetectionSection()
public:
CollisionDetectionSection()
See Also

Reference

CollisionDetectionSection Class
VisualComponents.Create3D Namespace


CollisionDetectionSection Properties

The CollisionDetectionSection type exposes the following members.

Properties
 | Name | Description
Public property | CollisionDetectionElement | Configuration file element for collision options.
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName | Section's name in configuration file.
Public property | SectionType | Interface type.
Public property | SectionVersion | Section's version number.
Top
See Also

Reference

CollisionDetectionSection Class
VisualComponents.Create3D Namespace


CollisionDetectionSection.CollisionDetectionElement Property

CollisionDetectionSectionCollisionDetectionElement Property

Configuration file element for collision options.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CollisionDetectionConfigElement CollisionDetectionElement { get; set; }
public:
virtual property CollisionDetectionConfigElement^ CollisionDetectionElement {
    CollisionDetectionConfigElement^ get () sealed;
    void set (CollisionDetectionConfigElement^ value) sealed;
}

Property Value

Type: CollisionDetectionConfigElement

Implements

ICollisionDetectionSectionCollisionDetectionElement
See Also

Reference

CollisionDetectionSection Class
VisualComponents.Create3D Namespace


CollisionDetectionSection.SectionName Property

CollisionDetectionSectionSectionName Property

Section's name in configuration file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SectionName { get; }
public:
virtual property String^ SectionName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ISectionSectionName
See Also

Reference

CollisionDetectionSection Class
VisualComponents.Create3D Namespace


CollisionDetectionSection.SectionType Property

CollisionDetectionSectionSectionType Property

Interface type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type SectionType { get; }
public:
virtual property Type^ SectionType {
    Type^ get () sealed;
}

Property Value

Type: Type

Implements

ISectionSectionType
See Also

Reference

CollisionDetectionSection Class
VisualComponents.Create3D Namespace


CollisionDetectionSection.SectionVersion Property

CollisionDetectionSectionSectionVersion Property

Section's version number.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int SectionVersion { get; }
public:
virtual property int SectionVersion {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISectionSectionVersion
See Also

Reference

CollisionDetectionSection Class
VisualComponents.Create3D Namespace


CollisionDetectionSection Methods

The CollisionDetectionSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion | Upgrade configuration to the latest version.
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection | Finds typed section by name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CollisionDetectionSection Class
VisualComponents.Create3D Namespace


CollisionDetectionSection.CheckVersion Method

CollisionDetectionSectionCheckVersion Method

Upgrade configuration to the latest version.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CheckVersion()
public:
virtual void CheckVersion() sealed

Implements

ISectionCheckVersion
See Also

Reference

CollisionDetectionSection Class
VisualComponents.Create3D Namespace


CollisionDetectionSection.GetSection Method

CollisionDetectionSectionGetSection Method

Finds typed section by name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISection GetSection(
    Configuration userSettingConfiguration
)
public:
virtual ISection^ GetSection(
    Configuration^ userSettingConfiguration
) sealed

Parameters

userSettingConfiguration
Type: System.ConfigurationConfiguration

Return Value

Type: ISection

[Missing <returns> documentation for "M:VisualComponents.Create3D.CollisionDetectionSection.GetSection(System.Configuration.Configuration)"]

Implements

ISectionGetSection(Configuration)
See Also

Reference

CollisionDetectionSection Class
VisualComponents.Create3D Namespace


CollisionDetectionSection.ToString Method

CollisionDetectionSectionToString Method

Converts this instance to string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String
String representation of this instance
See Also

Reference

CollisionDetectionSection Class
VisualComponents.Create3D Namespace


CollisionMessage Class

Message published by the instance of ICollisionListenerService via IEventAggregator.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DCollisionMessage

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class CollisionMessage
public ref class CollisionMessage

The CollisionMessage type exposes the following members.

Constructors
 | Name | Description
Public method | CollisionMessage(ICollisionDetector) | Initializes a new instance of CollisionMessage class that is initialized to Cleared.
Public method | CollisionMessage(ICollisionDetector, IEnumerableICollisionRecord) | Initializes a new instance of CollisionMessage class that is initialized to Detected.
Top
Properties
 | Name | Description
Public property | CollisionRecords | Gets the occurred collisions. Returns null if the value of CollisionType property is [!:CollisionMessage.MessageType.Cleared].
Public property | CollisionType | Gets the type of the message.
Public property | Detector | Gets the instance of ICollisionDetector that triggered the message.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


CollisionMessage Constructor

Overload List
 | Name | Description
Public method | CollisionMessage(ICollisionDetector) | Initializes a new instance of CollisionMessage class that is initialized to Cleared.
Public method | CollisionMessage(ICollisionDetector, IEnumerableICollisionRecord) | Initializes a new instance of CollisionMessage class that is initialized to Detected.
Top
See Also

Reference

CollisionMessage Class
VisualComponents.Create3D Namespace


CollisionMessage Constructor (ICollisionDetector)

Initializes a new instance of CollisionMessage class that is initialized to Cleared.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CollisionMessage(
    ICollisionDetector detector
)
public:
CollisionMessage(
    ICollisionDetector^ detector
)

Parameters

detector
Type: VisualComponents.Create3DICollisionDetector
Collision detector.
See Also

Reference

CollisionMessage Class
CollisionMessage Overload
VisualComponents.Create3D Namespace


CollisionMessage Constructor (ICollisionDetector, IEnumerable(ICollisionRecord))

CollisionMessage Constructor (ICollisionDetector, IEnumerableICollisionRecord)

Initializes a new instance of CollisionMessage class that is initialized to Detected.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CollisionMessage(
    ICollisionDetector detector,
    IEnumerable<ICollisionRecord> collisions
)
public:
CollisionMessage(
    ICollisionDetector^ detector,
    IEnumerable<ICollisionRecord^>^ collisions
)

Parameters

detector
Type: VisualComponents.Create3DICollisionDetector
Collision detector.
collisions
Type: System.Collections.GenericIEnumerableICollisionRecord
Collisions detected by the given detector.
See Also

Reference

CollisionMessage Class
CollisionMessage Overload
VisualComponents.Create3D Namespace


CollisionMessage Properties

The CollisionMessage type exposes the following members.

Properties
 | Name | Description
Public property | CollisionRecords | Gets the occurred collisions. Returns null if the value of CollisionType property is [!:CollisionMessage.MessageType.Cleared].
Public property | CollisionType | Gets the type of the message.
Public property | Detector | Gets the instance of ICollisionDetector that triggered the message.
Top
See Also

Reference

CollisionMessage Class
VisualComponents.Create3D Namespace


CollisionMessage.CollisionRecords Property

CollisionMessageCollisionRecords Property

Gets the occurred collisions. Returns null if the value of CollisionType property is [!:CollisionMessage.MessageType.Cleared].

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<ICollisionRecord> CollisionRecords { get; }
public:
property IEnumerable<ICollisionRecord^>^ CollisionRecords {
    IEnumerable<ICollisionRecord^>^ get ();
}

Property Value

Type: IEnumerableICollisionRecord
See Also

Reference

CollisionMessage Class
VisualComponents.Create3D Namespace


CollisionMessage.CollisionType Property

CollisionMessageCollisionType Property

Gets the type of the message.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CollisionMessageType CollisionType { get; }
public:
property CollisionMessageType CollisionType {
    CollisionMessageType get ();
}

Property Value

Type: CollisionMessageType
See Also

Reference

CollisionMessage Class
VisualComponents.Create3D Namespace


CollisionMessage.Detector Property

CollisionMessageDetector Property

Gets the instance of ICollisionDetector that triggered the message.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ICollisionDetector Detector { get; }
public:
property ICollisionDetector^ Detector {
    ICollisionDetector^ get ();
}

Property Value

Type: ICollisionDetector
See Also

Reference

CollisionMessage Class
VisualComponents.Create3D Namespace


CollisionMessage Methods

The CollisionMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CollisionMessage Class
VisualComponents.Create3D Namespace


CollisionMessageType Enumeration

Defines the collision message type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum CollisionMessageType
public enum class CollisionMessageType
Members
Member name | Value | Description
Cleared | 0 | Published when the value of IsActive is set false, the collision detector is deleted or when there is no colliding nodes anymore.
Detected | 1 | Published when the collision detector detects a collision.
See Also

Reference

VisualComponents.Create3D Namespace


Color Structure

Structure representing a color using red, green, blue and alpha channels

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct Color
public value class Color

The Color type exposes the following members.

Constructors
 | Name | Description
Public method | Color(Color) | Initializes a new Color instance using given brush
Public method | Color(Byte, Byte, Byte, Byte) | Initializes a new Color instance using given values
Top
Properties
 | Name | Description
Public property | Alpha | Alpha channel
Public property | Blue | Blue channel
Public property | Green | Green channel
Public property | Item | Gets or sets a channel value using index (R = 0, G = 1, B = 2, A = 3)
Public property | Red | Red channel
Top
Methods
 | Name | Description
Public method | Equals(Object) | Compares two Color instances for equality (Overrides ValueTypeEquals(Object).)
 | Equals(Color, Color) | Compares two Color instances for equality
 | FromVector |
Public method | GetHashCode | Gets a hash code for this structure (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Public method | ToVector |
Top
Operators
Name | Description
Equality | Compares two Color instances for equality
Inequality | Compares two Color instances for inequality
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


Color Constructor

Overload List
 | Name | Description
Public method | Color(Color) | Initializes a new Color instance using given brush
Public method | Color(Byte, Byte, Byte, Byte) | Initializes a new Color instance using given values
Top
See Also

Reference

Color Structure
VisualComponents.Create3D Namespace


Color Constructor (Color)

Initializes a new Color instance using given brush

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Color(
    Color color
)
public:
Color(
    Color color
)

Parameters

color
Type: System.Windows.MediaColor
Color instance
See Also

Reference

Color Structure
Color Overload
VisualComponents.Create3D Namespace


Color Constructor (Byte, Byte, Byte, Byte)

Initializes a new Color instance using given values

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Color(
    byte red,
    byte green,
    byte blue,
    byte alpha
)
public:
Color(
    unsigned char red,
    unsigned char green,
    unsigned char blue,
    unsigned char alpha
)

Parameters

red
Type: SystemByte
Red
green
Type: SystemByte
Green
blue
Type: SystemByte
Blue
alpha
Type: SystemByte
Alpha
See Also

Reference

Color Structure
Color Overload
VisualComponents.Create3D Namespace


Color Properties

The Color type exposes the following members.

Properties
 | Name | Description
Public property | Alpha | Alpha channel
Public property | Blue | Blue channel
Public property | Green | Green channel
Public property | Item | Gets or sets a channel value using index (R = 0, G = 1, B = 2, A = 3)
Public property | Red | Red channel
Top
See Also

Reference

Color Structure
VisualComponents.Create3D Namespace


Color.Alpha Property

ColorAlpha Property

Alpha channel

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public byte Alpha { get; set; }
public:
property unsigned char Alpha {
    unsigned char get ();
    void set (unsigned char value);
}

Property Value

Type: Byte
See Also

Reference

Color Structure
VisualComponents.Create3D Namespace


Color.Blue Property

ColorBlue Property

Blue channel

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public byte Blue { get; set; }
public:
property unsigned char Blue {
    unsigned char get ();
    void set (unsigned char value);
}

Property Value

Type: Byte
See Also

Reference

Color Structure
VisualComponents.Create3D Namespace


Color.Green Property

ColorGreen Property

Green channel

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public byte Green { get; set; }
public:
property unsigned char Green {
    unsigned char get ();
    void set (unsigned char value);
}

Property Value

Type: Byte
See Also

Reference

Color Structure
VisualComponents.Create3D Namespace


Color.Item Property

ColorItem Property

Gets or sets a channel value using index (R = 0, G = 1, B = 2, A = 3)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public byte this[
    int index
] { get; set; }
public:
property unsigned char default[int index] {
    unsigned char get (int index);
    void set (int index, unsigned char value);
}

Parameters

index
Type: SystemInt32
Index

Return Value

Type: Byte
Channel value
See Also

Reference

Color Structure
VisualComponents.Create3D Namespace


Color.Red Property

ColorRed Property

Red channel

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public byte Red { get; set; }
public:
property unsigned char Red {
    unsigned char get ();
    void set (unsigned char value);
}

Property Value

Type: Byte
See Also

Reference

Color Structure
VisualComponents.Create3D Namespace


Color Methods

The Color type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Compares two Color instances for equality (Overrides ValueTypeEquals(Object).)
 | Equals(Color, Color) | Compares two Color instances for equality
 | FromVector |
Public method | GetHashCode | Gets a hash code for this structure (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Public method | ToVector |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

Color Structure
VisualComponents.Create3D Namespace


Color.Equals Method

ColorEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Compares two Color instances for equality (Overrides ValueTypeEquals(Object).)
 | Equals(Color, Color) | Compares two Color instances for equality
Top
See Also

Reference

Color Structure
VisualComponents.Create3D Namespace


Color.Equals Method (Object)

ColorEquals Method (Object)

Compares two Color instances for equality

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
The color to compare

Return Value

Type: Boolean
True if obj is identical with this color; false otherwise.
See Also

Reference

Color Structure
Equals Overload
VisualComponents.Create3D Namespace


Color.Equals Method (Color, Color)

ColorEquals Method (Color, Color)

Compares two Color instances for equality

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool Equals(
    Color color1,
    Color color2
)
public:
static bool Equals(
    Color color1,
    Color color2
)

Parameters

color1
Type: VisualComponents.Create3DColor
The first color
color2
Type: VisualComponents.Create3DColor
The second color

Return Value

Type: Boolean
True if the colors are identical; false otherwise.
See Also

Reference

Color Structure
Equals Overload
VisualComponents.Create3D Namespace


Color.FromVector Method

ColorFromVector Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Color FromVector(
    Vector3 vector
)
public:
static Color FromVector(
    Vector3 vector
)

Parameters

vector
Type: VisualComponents.Create3DVector3

Return Value

Type: Color

[Missing <returns> documentation for "M:VisualComponents.Create3D.Color.FromVector(VisualComponents.Create3D.Vector3)"]

See Also

Reference

Color Structure
VisualComponents.Create3D Namespace


Color.GetHashCode Method

ColorGetHashCode Method

Gets a hash code for this structure

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32
Hash code
See Also

Reference

Color Structure
VisualComponents.Create3D Namespace


Color.ToVector Method

ColorToVector Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 ToVector()
public:
Vector3 ToVector()

Return Value

Type: Vector3

[Missing <returns> documentation for "M:VisualComponents.Create3D.Color.ToVector"]

See Also

Reference

Color Structure
VisualComponents.Create3D Namespace


Color Operators

The Color type exposes the following members.

Operators
Name | Description
Equality | Compares two Color instances for equality
Inequality | Compares two Color instances for inequality
Top
See Also

Reference

Color Structure
VisualComponents.Create3D Namespace


Color.Equality Operator

ColorEquality Operator

Compares two Color instances for equality

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    Color color1,
    Color color2
)
public:
static bool operator ==(
    Color color1,
    Color color2
)

Parameters

color1
Type: VisualComponents.Create3DColor
The first color to compare
color2
Type: VisualComponents.Create3DColor
The second color to compare against

Return Value

Type: Boolean
True if the colors are identical; false otherwise.
See Also

Reference

Color Structure
VisualComponents.Create3D Namespace


Color.Inequality Operator

ColorInequality Operator

Compares two Color instances for inequality

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    Color color1,
    Color color2
)
public:
static bool operator !=(
    Color color1,
    Color color2
)

Parameters

color1
Type: VisualComponents.Create3DColor
The first color to compare
color2
Type: VisualComponents.Create3DColor
The second color to compare against

Return Value

Type: Boolean
True if the colors are inequal, false otherwise
See Also

Reference

Color Structure
VisualComponents.Create3D Namespace


ColorConfiguration Enumeration

Type of the geometry set

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ColorConfiguration
public enum class ColorConfiguration
Members
Member name | Value | Description
RGBA | 0 | red green blue alpha
BGRA | 1 | blue green red alpha
See Also

Reference

VisualComponents.Create3D Namespace


CombinableItemCollection(T) Class

CombinableItemCollectionT Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DCombinableItemCollectionT
VisualComponents.Create3DSchemaFrameCollection
VisualComponents.Create3DSchemaPositionFrameCollection

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract class CombinableItemCollection<T>
where T : class

generic<typename T>
where T : ref class
public ref class CombinableItemCollection abstract

Type Parameters

T

The CombinableItemCollectionT type exposes the following members.

Constructors
 | Name | Description
Protected method | CombinableItemCollectionT | Initializes a new instance of the CombinableItemCollectionT class
Top
Properties
 | Name | Description
Public property | OriginalFrames |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | Wrap | Converts IEnumerable<T> to another IEnumerable<T>, which takes into account ICombinable items. See ICombinable.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


CombinableItemCollection(T) Constructor

CombinableItemCollectionT Constructor

Initializes a new instance of the CombinableItemCollectionT class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected CombinableItemCollection()
protected:
CombinableItemCollection()
See Also

Reference

CombinableItemCollectionT Class
VisualComponents.Create3D Namespace


CombinableItemCollection(T) Properties

CombinableItemCollectionT Properties

The CombinableItemCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | OriginalFrames |
Top
See Also

Reference

CombinableItemCollectionT Class
VisualComponents.Create3D Namespace


CombinableItemCollection(T).OriginalFrames Property

CombinableItemCollectionTOriginalFrames Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract IEnumerable<T> OriginalFrames { get; }
public:
virtual property IEnumerable<T>^ OriginalFrames {
    IEnumerable<T>^ get () abstract;
}

Property Value

Type: IEnumerableT
See Also

Reference

CombinableItemCollectionT Class
VisualComponents.Create3D Namespace


CombinableItemCollection(T) Methods

CombinableItemCollectionT Methods

The CombinableItemCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | Wrap | Converts IEnumerable<T> to another IEnumerable<T>, which takes into account ICombinable items. See ICombinable.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CombinableItemCollectionT Class
VisualComponents.Create3D Namespace


CombinableItemCollection(T).Wrap Method

CombinableItemCollectionTWrap Method

Converts IEnumerable<T> to another IEnumerable<T>, which takes into account ICombinable items. See ICombinable.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IEnumerable<T> Wrap(
    IEnumerable<T> list
)
public:
static IEnumerable<T>^ Wrap(
    IEnumerable<T>^ list
)

Parameters

list
Type: System.Collections.GenericIEnumerableT

Return Value

Type: IEnumerableT

[Missing <returns> documentation for "M:VisualComponents.Create3D.CombinableItemCollection`1.Wrap(System.Collections.Generic.IEnumerable{`0})"]

See Also

Reference

CombinableItemCollectionT Class
VisualComponents.Create3D Namespace


CombinableItemCollectionExtensions Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DCombinableItemCollectionExtensions

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class CombinableItemCollectionExtensions
[ExtensionAttribute]
public ref class CombinableItemCollectionExtensions abstract sealed
Methods
Name | Description
ToCollection(IPositionFrame) |
ToCollection(IPositionFrame) |
ToCollection(ISchemaFrame) |
ToCollection(ISchemaFrame) |
Top
See Also

Reference

VisualComponents.Create3D Namespace


CombinableItemCollectionExtensions Methods

Methods
Name | Description
ToCollection(IPositionFrame) |
ToCollection(IPositionFrame) |
ToCollection(ISchemaFrame) |
ToCollection(ISchemaFrame) |
Top
See Also

Reference

CombinableItemCollectionExtensions Class
VisualComponents.Create3D Namespace


CombinableItemCollectionExtensions.ToCollection Method

CombinableItemCollectionExtensionsToCollection Method

Overload List
Name | Description
ToCollection(IPositionFrame) |
ToCollection(IPositionFrame) |
ToCollection(ISchemaFrame) |
ToCollection(ISchemaFrame) |
Top
See Also

Reference

CombinableItemCollectionExtensions Class
VisualComponents.Create3D Namespace


CombinableItemCollectionExtensions.ToCollection Method (IPositionFrame)

CombinableItemCollectionExtensionsToCollection Method (IPositionFrame)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IEnumerable<IPositionFrame> ToCollection(
    this IPositionFrame item
)
public:
[ExtensionAttribute]
static IEnumerable<IPositionFrame^>^ ToCollection(
    IPositionFrame^ item
)

Parameters

item
Type: VisualComponents.Create3DIPositionFrame

Return Value

Type: IEnumerableIPositionFrame

[Missing <returns> documentation for "M:VisualComponents.Create3D.CombinableItemCollectionExtensions.ToCollection(VisualComponents.Create3D.IPositionFrame)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IPositionFrame. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CombinableItemCollectionExtensions Class
ToCollection Overload
VisualComponents.Create3D Namespace


CombinableItemCollectionExtensions.ToCollection Method (IPositionFrame[])

CombinableItemCollectionExtensionsToCollection Method (IPositionFrame)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IEnumerable<IPositionFrame> ToCollection(
    this IPositionFrame[] items
)
public:
[ExtensionAttribute]
static IEnumerable<IPositionFrame^>^ ToCollection(
    array<IPositionFrame^>^ items
)

Parameters

items
Type: VisualComponents.Create3DIPositionFrame

Return Value

Type: IEnumerableIPositionFrame

[Missing <returns> documentation for "M:VisualComponents.Create3D.CombinableItemCollectionExtensions.ToCollection(VisualComponents.Create3D.IPositionFrame[])"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CombinableItemCollectionExtensions Class
ToCollection Overload
VisualComponents.Create3D Namespace


CombinableItemCollectionExtensions.ToCollection Method (ISchemaFrame)

CombinableItemCollectionExtensionsToCollection Method (ISchemaFrame)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IEnumerable<ISchemaFrame> ToCollection(
    this ISchemaFrame item
)
public:
[ExtensionAttribute]
static IEnumerable<ISchemaFrame^>^ ToCollection(
    ISchemaFrame^ item
)

Parameters

item
Type: VisualComponents.Create3DISchemaFrame

Return Value

Type: IEnumerableISchemaFrame

[Missing <returns> documentation for "M:VisualComponents.Create3D.CombinableItemCollectionExtensions.ToCollection(VisualComponents.Create3D.ISchemaFrame)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISchemaFrame. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CombinableItemCollectionExtensions Class
ToCollection Overload
VisualComponents.Create3D Namespace


CombinableItemCollectionExtensions.ToCollection Method (ISchemaFrame[])

CombinableItemCollectionExtensionsToCollection Method (ISchemaFrame)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IEnumerable<ISchemaFrame> ToCollection(
    this ISchemaFrame[] items
)
public:
[ExtensionAttribute]
static IEnumerable<ISchemaFrame^>^ ToCollection(
    array<ISchemaFrame^>^ items
)

Parameters

items
Type: VisualComponents.Create3DISchemaFrame

Return Value

Type: IEnumerableISchemaFrame

[Missing <returns> documentation for "M:VisualComponents.Create3D.CombinableItemCollectionExtensions.ToCollection(VisualComponents.Create3D.ISchemaFrame[])"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CombinableItemCollectionExtensions Class
ToCollection Overload
VisualComponents.Create3D Namespace


Completion Structure

Completion string record.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct Completion : IComparable<Completion>
public value class Completion : IComparable<Completion>

The Completion type exposes the following members.

Properties
 | Name | Description
Public property | CompletionType | Completion type.
Public property | Name | Completion name. Note that this is from the start index, not the caret position.
Top
Methods
 | Name | Description
Public method | CompareTo |
Public method | Equals | (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Equality |
GreaterThan |
GreaterThanOrEqual |
Inequality |
LessThan |
LessThanOrEqual |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


Completion Properties

The Completion type exposes the following members.

Properties
 | Name | Description
Public property | CompletionType | Completion type.
Public property | Name | Completion name. Note that this is from the start index, not the caret position.
Top
See Also

Reference

Completion Structure
VisualComponents.Create3D Namespace


Completion.CompletionType Property

CompletionCompletionType Property

Completion type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CompletionType CompletionType { get; set; }
public:
property CompletionType CompletionType {
    CompletionType get ();
    void set (CompletionType value);
}

Property Value

Type: CompletionType
See Also

Reference

Completion Structure
VisualComponents.Create3D Namespace


Completion.Name Property

CompletionName Property

Completion name. Note that this is from the start index, not the caret position.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; set; }
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Completion Structure
VisualComponents.Create3D Namespace


Completion Methods

The Completion type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo |
Public method | Equals | (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

Completion Structure
VisualComponents.Create3D Namespace


Completion.CompareTo Method

CompletionCompareTo Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CompareTo(
    Completion other
)
public:
virtual int CompareTo(
    Completion other
) sealed

Parameters

other
Type: VisualComponents.Create3DCompletion

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.Completion.CompareTo(VisualComponents.Create3D.Completion)"]

Implements

IComparableTCompareTo(T)
See Also

Reference

Completion Structure
VisualComponents.Create3D Namespace


Completion.Equals Method

CompletionEquals Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.Completion.Equals(System.Object)"]

See Also

Reference

Completion Structure
VisualComponents.Create3D Namespace


Completion.GetHashCode Method

CompletionGetHashCode Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.Completion.GetHashCode"]

See Also

Reference

Completion Structure
VisualComponents.Create3D Namespace


Completion Operators

The Completion type exposes the following members.

Operators
Name | Description
Equality |
GreaterThan |
GreaterThanOrEqual |
Inequality |
LessThan |
LessThanOrEqual |
Top
See Also

Reference

Completion Structure
VisualComponents.Create3D Namespace


Completion.Equality Operator

CompletionEquality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    Completion left,
    Completion right
)
public:
static bool operator ==(
    Completion left,
    Completion right
)

Parameters

left
Type: VisualComponents.Create3DCompletion
right
Type: VisualComponents.Create3DCompletion

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.Completion.op_Equality(VisualComponents.Create3D.Completion,VisualComponents.Create3D.Completion)"]

See Also

Reference

Completion Structure
VisualComponents.Create3D Namespace


Completion.GreaterThan Operator

CompletionGreaterThan Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator >(
    Completion left,
    Completion right
)
public:
static bool operator >(
    Completion left,
    Completion right
)

Parameters

left
Type: VisualComponents.Create3DCompletion
right
Type: VisualComponents.Create3DCompletion

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.Completion.op_GreaterThan(VisualComponents.Create3D.Completion,VisualComponents.Create3D.Completion)"]

See Also

Reference

Completion Structure
VisualComponents.Create3D Namespace


Completion.GreaterThanOrEqual Operator

CompletionGreaterThanOrEqual Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator >=(
    Completion left,
    Completion right
)
public:
static bool operator >=(
    Completion left,
    Completion right
)

Parameters

left
Type: VisualComponents.Create3DCompletion
right
Type: VisualComponents.Create3DCompletion

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.Completion.op_GreaterThanOrEqual(VisualComponents.Create3D.Completion,VisualComponents.Create3D.Completion)"]

See Also

Reference

Completion Structure
VisualComponents.Create3D Namespace


Completion.Inequality Operator

CompletionInequality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    Completion left,
    Completion right
)
public:
static bool operator !=(
    Completion left,
    Completion right
)

Parameters

left
Type: VisualComponents.Create3DCompletion
right
Type: VisualComponents.Create3DCompletion

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.Completion.op_Inequality(VisualComponents.Create3D.Completion,VisualComponents.Create3D.Completion)"]

See Also

Reference

Completion Structure
VisualComponents.Create3D Namespace


Completion.LessThan Operator

CompletionLessThan Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator <(
    Completion left,
    Completion right
)
public:
static bool operator <(
    Completion left,
    Completion right
)

Parameters

left
Type: VisualComponents.Create3DCompletion
right
Type: VisualComponents.Create3DCompletion

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.Completion.op_LessThan(VisualComponents.Create3D.Completion,VisualComponents.Create3D.Completion)"]

See Also

Reference

Completion Structure
VisualComponents.Create3D Namespace


Completion.LessThanOrEqual Operator

CompletionLessThanOrEqual Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator <=(
    Completion left,
    Completion right
)
public:
static bool operator <=(
    Completion left,
    Completion right
)

Parameters

left
Type: VisualComponents.Create3DCompletion
right
Type: VisualComponents.Create3DCompletion

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.Completion.op_LessThanOrEqual(VisualComponents.Create3D.Completion,VisualComponents.Create3D.Completion)"]

See Also

Reference

Completion Structure
VisualComponents.Create3D Namespace


CompletionType Enumeration

Completion type enumeration.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum CompletionType
public enum class CompletionType
Members
Member name | Value | Description
Namespace | 0 | Completion is a namespace name.
Variable | 1 | Completion is a variable name.
Function | 2 | Completion is a function name.
Property | 3 | Completion is an object property name.
Method | 4 | Completion is an object method name.
Type | 5 | Completion is a type name.
Unit | 6 | Completion is a unit name.
See Also

Reference

VisualComponents.Create3D Namespace


ComponentAddedEventArgs Class

Component added event arguments
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DComponentAddedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ComponentAddedEventArgs : EventArgs
public ref class ComponentAddedEventArgs : public EventArgs

The ComponentAddedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ComponentAddedEventArgs | Constructor
Top
Properties
 | Name | Description
Public property | Component | Component that has been added to the simulation world
Public property | ComponentLight |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ComponentAddedEventArgs Constructor

Constructor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ComponentAddedEventArgs(
    ISimComponent component
)
public:
ComponentAddedEventArgs(
    ISimComponent^ component
)

Parameters

component
Type: VisualComponents.Create3DISimComponent
Component
See Also

Reference

ComponentAddedEventArgs Class
VisualComponents.Create3D Namespace


ComponentAddedEventArgs Properties

The ComponentAddedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Component | Component that has been added to the simulation world
Public property | ComponentLight |
Top
See Also

Reference

ComponentAddedEventArgs Class
VisualComponents.Create3D Namespace


ComponentAddedEventArgs.Component Property

ComponentAddedEventArgsComponent Property

Component that has been added to the simulation world

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimComponent Component { get; }
public:
property ISimComponent^ Component {
    ISimComponent^ get ();
}

Property Value

Type: ISimComponent
See Also

Reference

ComponentAddedEventArgs Class
VisualComponents.Create3D Namespace


ComponentAddedEventArgs.ComponentLight Property

ComponentAddedEventArgsComponentLight Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ILightSimNode ComponentLight { get; }
public:
property ILightSimNode^ ComponentLight {
    ILightSimNode^ get ();
}

Property Value

Type: ILightSimNode
See Also

Reference

ComponentAddedEventArgs Class
VisualComponents.Create3D Namespace


ComponentAddedEventArgs Methods

The ComponentAddedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ComponentAddedEventArgs Class
VisualComponents.Create3D Namespace


ComponentCreatedEventArgs Class

Represents a component creating event arguments. It derives from the EventArgs class EventArgs.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DComponentCreatedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ComponentCreatedEventArgs : EventArgs
public ref class ComponentCreatedEventArgs : public EventArgs

The ComponentCreatedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ComponentCreatedEventArgs | Initializes a new instance of the ComponentCreatedEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ComponentCreatedEventArgs Constructor

Initializes a new instance of the ComponentCreatedEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ComponentCreatedEventArgs()
public:
ComponentCreatedEventArgs()
See Also

Reference

ComponentCreatedEventArgs Class
VisualComponents.Create3D Namespace


ComponentCreatedEventArgs Methods

The ComponentCreatedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ComponentCreatedEventArgs Class
VisualComponents.Create3D Namespace


ComponentDeleteChange Class

PropertyChange contains information about a change of a individual property value.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DChange
VisualComponents.Create3DComponentDeleteChange

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ComponentDeleteChange : Change
public ref class ComponentDeleteChange sealed : public Change

The ComponentDeleteChange type exposes the following members.

Constructors
 | Name | Description
Public method | ComponentDeleteChange | Initializes a new instance of the ComponentDeleteChange class
Top
Properties
 | Name | Description
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from Change.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ComponentDeleteChange Constructor

Initializes a new instance of the ComponentDeleteChange class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ComponentDeleteChange(
    ISimWorld world,
    IComponentMemento memento
)
public:
ComponentDeleteChange(
    ISimWorld^ world,
    IComponentMemento^ memento
)

Parameters

world
Type: VisualComponents.Create3DISimWorld
memento
Type: VisualComponents.Create3DIComponentMemento
See Also

Reference

ComponentDeleteChange Class
VisualComponents.Create3D Namespace


ComponentDeleteChange Properties

The ComponentDeleteChange type exposes the following members.

Properties
 | Name | Description
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Top
See Also

Reference

ComponentDeleteChange Class
VisualComponents.Create3D Namespace


ComponentDeleteChange Methods

The ComponentDeleteChange type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from Change.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ComponentDeleteChange Class
VisualComponents.Create3D Namespace


ComponentRemovingEventArgs Class

Component removed event arguments
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DComponentRemovingEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ComponentRemovingEventArgs : EventArgs
public ref class ComponentRemovingEventArgs : public EventArgs

The ComponentRemovingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ComponentRemovingEventArgs | Constructor
Top
Properties
 | Name | Description
Public property | Component | Component that has been removed from the simulation world
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ComponentRemovingEventArgs Constructor

Constructor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ComponentRemovingEventArgs(
    ISimComponent component
)
public:
ComponentRemovingEventArgs(
    ISimComponent^ component
)

Parameters

component
Type: VisualComponents.Create3DISimComponent
See Also

Reference

ComponentRemovingEventArgs Class
VisualComponents.Create3D Namespace


ComponentRemovingEventArgs Properties

The ComponentRemovingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Component | Component that has been removed from the simulation world
Top
See Also

Reference

ComponentRemovingEventArgs Class
VisualComponents.Create3D Namespace


ComponentRemovingEventArgs.Component Property

ComponentRemovingEventArgsComponent Property

Component that has been removed from the simulation world

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimComponent Component { get; }
public:
property ISimComponent^ Component {
    ISimComponent^ get ();
}

Property Value

Type: ISimComponent
See Also

Reference

ComponentRemovingEventArgs Class
VisualComponents.Create3D Namespace


ComponentRemovingEventArgs Methods

The ComponentRemovingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ComponentRemovingEventArgs Class
VisualComponents.Create3D Namespace


ComponentSavedEventArgs Class

Represents a saved component event arguments. It derives from the EventArgs class EventArgs.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DComponentSavedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ComponentSavedEventArgs : EventArgs
public ref class ComponentSavedEventArgs : public EventArgs

The ComponentSavedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ComponentSavedEventArgs | Initializes a new instance of the saved component EventArgs with a given Uri and Boolean parameters.
Top
Properties
 | Name | Description
Public property | Succeeded | Gets a Boolean value, true or false, which indicates if the component was succesfully saved.
Public property | Uri | Gets the Uri where the component was saved.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ComponentSavedEventArgs Constructor

Initializes a new instance of the saved component EventArgs with a given Uri and Boolean parameters.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ComponentSavedEventArgs(
    Uri uri,
    bool succeeded
)
public:
ComponentSavedEventArgs(
    Uri^ uri,
    bool succeeded
)

Parameters

uri
Type: SystemUri
Uri
succeeded
Type: SystemBoolean
See Also

Reference

ComponentSavedEventArgs Class
VisualComponents.Create3D Namespace


ComponentSavedEventArgs Properties

The ComponentSavedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Succeeded | Gets a Boolean value, true or false, which indicates if the component was succesfully saved.
Public property | Uri | Gets the Uri where the component was saved.
Top
See Also

Reference

ComponentSavedEventArgs Class
VisualComponents.Create3D Namespace


ComponentSavedEventArgs.Succeeded Property

ComponentSavedEventArgsSucceeded Property

Gets a Boolean value, true or false, which indicates if the component was succesfully saved.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Succeeded { get; }
public:
property bool Succeeded {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ComponentSavedEventArgs Class
VisualComponents.Create3D Namespace


ComponentSavedEventArgs.Uri Property

ComponentSavedEventArgsUri Property

Gets the Uri where the component was saved.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Uri Uri { get; }
public:
property Uri^ Uri {
    Uri^ get ();
}

Property Value

Type: Uri
See Also

Reference

ComponentSavedEventArgs Class
VisualComponents.Create3D Namespace


ComponentSavedEventArgs Methods

The ComponentSavedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ComponentSavedEventArgs Class
VisualComponents.Create3D Namespace


ComponentSavingEventArgs Class

Represents a component saving event arguments. It derives from the EventArgs class EventArgs.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DComponentSavingEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ComponentSavingEventArgs : EventArgs
public ref class ComponentSavingEventArgs : public EventArgs

The ComponentSavingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ComponentSavingEventArgs | Initializes a new instance of the saving component EventArgs with a given Uri
Top
Properties
 | Name | Description
Public property | Uri | Gets the Uri where the component is being saved
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ComponentSavingEventArgs Constructor

Initializes a new instance of the saving component EventArgs with a given Uri

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ComponentSavingEventArgs(
    Uri uri
)
public:
ComponentSavingEventArgs(
    Uri^ uri
)

Parameters

uri
Type: SystemUri
Indicates the Uri
See Also

Reference

ComponentSavingEventArgs Class
VisualComponents.Create3D Namespace


ComponentSavingEventArgs Properties

The ComponentSavingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Uri | Gets the Uri where the component is being saved
Top
See Also

Reference

ComponentSavingEventArgs Class
VisualComponents.Create3D Namespace


ComponentSavingEventArgs.Uri Property

ComponentSavingEventArgsUri Property

Gets the Uri where the component is being saved

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Uri Uri { get; }
public:
property Uri^ Uri {
    Uri^ get ();
}

Property Value

Type: Uri
See Also

Reference

ComponentSavingEventArgs Class
VisualComponents.Create3D Namespace


ComponentSavingEventArgs Methods

The ComponentSavingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ComponentSavingEventArgs Class
VisualComponents.Create3D Namespace


ConditionalList(T) Class

ConditionalListT Class

Extends IListT with Condition that allows restrict items that are accepted in the list.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DConditionalListT
VisualComponents.Create3DSnapperPropertyList

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ConditionalList<T> : IList<T>,
    ICollection<T>, IEnumerable<T>, IEnumerable

generic<typename T>
public ref class ConditionalList : IList<T>,
    ICollection<T>, IEnumerable<T>, IEnumerable

Type Parameters

T

The ConditionalListT type exposes the following members.

Constructors
 | Name | Description
Public method | ConditionalListT | Initializes a new instance of the ConditionalListT class
Top
Properties
 | Name | Description
Public property | Condition | Gets or sets the instance of ActionT that is used for evaluating the items to be added in the list. The condition should throw an instance of Exception if the item is not allowed in the list.
Public property | Count |
Public property | IsReadOnly |
Public property | Item |
Top
Methods
 | Name | Description
Public method | Add |
Public method | Clear |
Public method | Contains |
Public method | CopyTo |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf |
Public method | Insert |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove |
Public method | RemoveAt |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachT | Enumerate a cached collection performing the specified action on each item. (Defined by ForEachHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | HasMoreThanT | (Defined by EnumerableHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToObservableCollectionT | (Defined by Extensions.)
Public Extension Method | ToObservableCollectionExT | (Defined by Extensions.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ConditionalList(T) Constructor

ConditionalListT Constructor

Initializes a new instance of the ConditionalListT class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConditionalList()
public:
ConditionalList()
See Also

Reference

ConditionalListT Class
VisualComponents.Create3D Namespace


ConditionalList(T) Properties

ConditionalListT Properties

The ConditionalListT generic type exposes the following members.

Properties
 | Name | Description
Public property | Condition | Gets or sets the instance of ActionT that is used for evaluating the items to be added in the list. The condition should throw an instance of Exception if the item is not allowed in the list.
Public property | Count |
Public property | IsReadOnly |
Public property | Item |
Top
See Also

Reference

ConditionalListT Class
VisualComponents.Create3D Namespace


ConditionalList(T).Condition Property

ConditionalListTCondition Property

Gets or sets the instance of ActionT that is used for evaluating the items to be added in the list. The condition should throw an instance of Exception if the item is not allowed in the list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Action<T> Condition { get; set; }
public:
property Action<T>^ Condition {
    Action<T>^ get ();
    void set (Action<T>^ value);
}

Property Value

Type: ActionT
See Also

Reference

ConditionalListT Class
VisualComponents.Create3D Namespace


ConditionalList(T).Count Property

ConditionalListTCount Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Count { get; }
public:
virtual property int Count {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ICollectionTCount
See Also

Reference

ConditionalListT Class
VisualComponents.Create3D Namespace


ConditionalList(T).IsReadOnly Property

ConditionalListTIsReadOnly Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsReadOnly { get; }
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ICollectionTIsReadOnly
See Also

Reference

ConditionalListT Class
VisualComponents.Create3D Namespace


ConditionalList(T).Item Property

ConditionalListTItem Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public T this[
    int index
] { get; set; }
public:
virtual property T default[int index] {
    T get (int index) sealed;
    void set (int index, T value) sealed;
}

Parameters

index
Type: SystemInt32

Property Value

Type: T

Implements

IListTItemInt32
See Also

Reference

ConditionalListT Class
VisualComponents.Create3D Namespace


ConditionalList(T) Methods

ConditionalListT Methods

The ConditionalListT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Public method | Clear |
Public method | Contains |
Public method | CopyTo |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf |
Public method | Insert |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove |
Public method | RemoveAt |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachT | Enumerate a cached collection performing the specified action on each item. (Defined by ForEachHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | HasMoreThanT | (Defined by EnumerableHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToObservableCollectionT | (Defined by Extensions.)
Public Extension Method | ToObservableCollectionExT | (Defined by Extensions.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ConditionalListT Class
VisualComponents.Create3D Namespace


ConditionalList(T).Add Method

ConditionalListTAdd Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Add(
    T item
)
public:
virtual void Add(
    T item
) sealed

Parameters

item
Type: T

Implements

ICollectionTAdd(T)
See Also

Reference

ConditionalListT Class
VisualComponents.Create3D Namespace


ConditionalList(T).Clear Method

ConditionalListTClear Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Clear()
public:
virtual void Clear() sealed

Implements

ICollectionTClear
See Also

Reference

ConditionalListT Class
VisualComponents.Create3D Namespace


ConditionalList(T).Contains Method

ConditionalListTContains Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Contains(
    T item
)
public:
virtual bool Contains(
    T item
) sealed

Parameters

item
Type: T

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ConditionalList`1.Contains(`0)"]

Implements

ICollectionTContains(T)
See Also

Reference

ConditionalListT Class
VisualComponents.Create3D Namespace


ConditionalList(T).CopyTo Method

ConditionalListTCopyTo Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CopyTo(
    T[] array,
    int arrayIndex
)
public:
virtual void CopyTo(
    array<T>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: T
arrayIndex
Type: SystemInt32

Implements

ICollectionTCopyTo(T, Int32)
See Also

Reference

ConditionalListT Class
VisualComponents.Create3D Namespace


ConditionalList(T).GetEnumerator Method

ConditionalListTGetEnumerator Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerator<T> GetEnumerator()
public:
virtual IEnumerator<T>^ GetEnumerator() sealed

Return Value

Type: IEnumeratorT

[Missing <returns> documentation for "M:VisualComponents.Create3D.ConditionalList`1.GetEnumerator"]

Implements

IEnumerableTGetEnumerator
See Also

Reference

ConditionalListT Class
VisualComponents.Create3D Namespace


ConditionalList(T).IndexOf Method

ConditionalListTIndexOf Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int IndexOf(
    T item
)
public:
virtual int IndexOf(
    T item
) sealed

Parameters

item
Type: T

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.ConditionalList`1.IndexOf(`0)"]

Implements

IListTIndexOf(T)
See Also

Reference

ConditionalListT Class
VisualComponents.Create3D Namespace


ConditionalList(T).Insert Method

ConditionalListTInsert Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Insert(
    int index,
    T item
)
public:
virtual void Insert(
    int index,
    T item
) sealed

Parameters

index
Type: SystemInt32
item
Type: T

Implements

IListTInsert(Int32, T)
See Also

Reference

ConditionalListT Class
VisualComponents.Create3D Namespace


ConditionalList(T).Remove Method

ConditionalListTRemove Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Remove(
    T item
)
public:
virtual bool Remove(
    T item
) sealed

Parameters

item
Type: T

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ConditionalList`1.Remove(`0)"]

Implements

ICollectionTRemove(T)
See Also

Reference

ConditionalListT Class
VisualComponents.Create3D Namespace


ConditionalList(T).RemoveAt Method

ConditionalListTRemoveAt Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RemoveAt(
    int index
)
public:
virtual void RemoveAt(
    int index
) sealed

Parameters

index
Type: SystemInt32

Implements

IListTRemoveAt(Int32)
See Also

Reference

ConditionalListT Class
VisualComponents.Create3D Namespace


ConfigurationHelper Class

Helper class for managing configuration files.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DConfigurationHelper

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ConfigurationHelper
public ref class ConfigurationHelper sealed

The ConfigurationHelper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | GetConfigurationSectionT | Loads configuration section from file.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | RefreshSection | Refreshes the section from the config file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | UpdateSection | Saves the section to the config file and refreshes it after that.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ConfigurationHelper Methods

The ConfigurationHelper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | GetConfigurationSectionT | Loads configuration section from file.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | RefreshSection | Refreshes the section from the config file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | UpdateSection | Saves the section to the config file and refreshes it after that.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ConfigurationHelper Class
VisualComponents.Create3D Namespace


ConfigurationHelper.GetConfigurationSection(T) Method

ConfigurationHelperGetConfigurationSectionT Method

Loads configuration section from file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static T GetConfigurationSection<T>(
    string sectionName,
    Configuration configurationObject
)
where T : new(), ConfigurationSection

public:
generic<typename T>
where T : gcnew(), ConfigurationSection
static T GetConfigurationSection(
    String^ sectionName,
    Configuration^ configurationObject
)

Parameters

sectionName
Type: SystemString
Section's name
configurationObject
Type: System.ConfigurationConfiguration
Source configuration to load from

Type Parameters

T
Section's type

Return Value

Type: T
Loaded configuration section
See Also

Reference

ConfigurationHelper Class
VisualComponents.Create3D Namespace


ConfigurationHelper.RefreshSection Method

ConfigurationHelperRefreshSection Method

Refreshes the section from the config file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void RefreshSection(
    string sectionName
)
public:
static void RefreshSection(
    String^ sectionName
)

Parameters

sectionName
Type: SystemString
See Also

Reference

ConfigurationHelper Class
VisualComponents.Create3D Namespace


ConfigurationHelper.UpdateSection Method

ConfigurationHelperUpdateSection Method

Saves the section to the config file and refreshes it after that.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void UpdateSection(
    ConfigurationSection currentSection,
    Configuration configurationObject
)
public:
static void UpdateSection(
    ConfigurationSection^ currentSection,
    Configuration^ configurationObject
)

Parameters

currentSection
Type: System.ConfigurationConfigurationSection
curent section
configurationObject
Type: System.ConfigurationConfiguration
configuration object
See Also

Reference

ConfigurationHelper Class
VisualComponents.Create3D Namespace


ConfigurationMode Enumeration

Defines the robot's joint configuration during linear interpolation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ConfigurationMode
public enum class ConfigurationMode
Members
Member name | Value | Description
Fixed | 0 | A robot's configuration does not change.
FollowFrame | 1 | A robot's configuration changes slightly to minimize joint value difference between its previous configuration (small change).
InterpolateJoints | 2 | A robot's configuration is determined by point to point interpolation of its joint values.
See Also

Reference

VisualComponents.Create3D Namespace


ConfigurationWarnings Enumeration

State of motion target inverse kinematics.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[FlagsAttribute]
public enum ConfigurationWarnings
[FlagsAttribute]
public enum class ConfigurationWarnings
Members
Member name | Value | Description
None | 0 | Target can be reached.
Unreachable | 1 | Target cannot be reached.
JointLimit | 2 | Target cannot be reached due to joint limit constraints.
Singularity | 4 | Target position creates a singularity, i.e. infinite solutions when one or two joints no longer represent independent controlling variables. For example, joints have a 0° value and become parallel.
NotCalculated | 8 | Inverse kinematics not calculated.
See Also

Reference

VisualComponents.Create3D Namespace


Connection Class

Checks internet connection
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DConnection

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class Connection
public ref class Connection abstract sealed

The Connection type exposes the following members.

Methods
Name | Description
IsConnectionAvailable | check if a connection to the Internet can be established
Top
See Also

Reference

VisualComponents.Create3D Namespace


Connection Methods

The Connection type exposes the following members.

Methods
Name | Description
IsConnectionAvailable | check if a connection to the Internet can be established
Top
See Also

Reference

Connection Class
VisualComponents.Create3D Namespace


Connection.IsConnectionAvailable Method

ConnectionIsConnectionAvailable Method

check if a connection to the Internet can be established

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsConnectionAvailable()
public:
static bool IsConnectionAvailable()

Return Value

Type: Boolean
True if Internet is available.
See Also

Reference

Connection Class
VisualComponents.Create3D Namespace


ConnectionEditorConfigElement Class

Configuration file element for Connection Editor Options.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.Create3DConnectionEditorConfigElement

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ConnectionEditorConfigElement : ConfigurationElement
public ref class ConnectionEditorConfigElement sealed : public ConfigurationElement

The ConnectionEditorConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionEditorConfigElement | Constructor.
Top
Properties
Name Description
Public property AllowConnectionDragging
If this is enabled, connections can be dragged out of connectors and dropped on other connectors or components (interfaces) and buttons/check-boxes to show or hide connection lines will be available. If this is disabled, those buttons will be hidden and it will not be possible to drag connections.
Public property ChangeSelectionOnComponentDoubleClick
If this is enabled, double-clicking a component in 3D World will change the currently selected component to the one you double-clicked. If the option is disabled, all clicks will be interpreted as single clicks.
Public property ChangeSelectionOnNodeTitleDoubleClick
If this is enabled, double-clicking the node's title will change the currently selected component to a component which the double-clicked node represents.
Public property CurrentConfiguration
Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to.
(Inherited from ConfigurationElement.)
Public property ElementInformation
Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object.
(Inherited from ConfigurationElement.)
Public property EnableNodeVirtualization
Defines whether UI virtualization is enabled in a canvas that hosts the Network Map.
Public property IndirectInterfaceConnectionsVisibility
Determines if the Network Map should contain (and show) connections going from/to an adjacent component to another adjacent component or another interface of the selected component. This option affects only Network Map and is useless when AllowConnectionDragging option is disabled. Available values: All - All indirect connections from/to all components in the 3D World which have the corresponding node in the Network Map will be shown. Component - Indirect connections between adjacent components (components that have at least one interface which can be or is already connected to any of interfaces in selected component) will be shown. Interface - Only indirect connections from/to interfaces of the selected component will be shown. None - No indirect connections will be shown.
Public property InterfacesListItemAlternativeNamingThreshold
The number of matching interfaces a node must contain to have connections (to it) in the list represented with alternative (includes interface's name in the brackets) name. For example, if the value of this option is 2 and a certain node has 2 interfaces that are already connected or can be connected to the selected node, then the corresponding connections in the list will be represented as component name + interface name.
Public property InterfacesNodeExpansionMode
Controls how and which nodes in the Interfaces Network Map will be expanded. Available values: All - All nodes will be expanded by default. Every node can be collapsed and expanded again. Connected - Main node and all nodes that have at least one connection to any other node will be expanded. ConnectedToMain - Main node and all nodes that have at least one connection to the main node will be expanded. Locked - Expanding/collapsing nodes is not possible. Corresponding buttons will be hidden from the UI and collapsed nodes will be hidden from the view. Main - Only main node will be expanded. Every node can be collapsed and expanded again.
Public property InterfacesNodePinningMode
Controls whether and how pinning of the nodes in Interfaces Network Map will be preserved. Available values: PreserveOnActionDeactivate - Pinned nodes will remain pinned even if you cancel the Interfaces Action. Every node can be pinned/unpinned manually.Pinning will be reset only on application restart. PreserveOnComponentChange - Pinned nodes will remain pinned even if you change the selected component. Closing the panel (cancels the Action) will reset all pinning. Every node can be pinned/unpinned manually. PreserveOnInterfaceChange - Pinned nodes will remain pinned even if you change the selected interface. Changing the selected component or closing the panel will reset all pinning. Nodes can be pinned/unpinned manually. ResetOnNodeVisibilityChange - Same as PreserveOnInterfaceChange, but pinning will be reset for nodes that are hidden from the view. For example, if ShowOnlyMatchingInterfaces option is enabled, some nodes might have no matching interface if you change the selected interface and thus will be hidden. Pinning of such nodes will be preserved with PreserveOnInterfaceChange option, but with this option they will be unpinned. Changing the selected component or closing the panel will reset all pinning. Nodes can be pinned/unpinned manually. DoNotPreserve - Pinned nodes will remain pinned only on basic actions (i.e.connect/disconnect, drag connection, etc.). Changing the selected interface/component or closing the panel will reset all pinning.Nodes can be pinned/unpinned manually. Disabled - Pinning is completely disabled. Nodes can be pinned/unpinned only programmatically. The corresponding button will be hidden from the UI.
Public property InterfacesNodeVisibilityThreshold
The number of matching interfaces a node must contain in order to be shown. For example, if the value of this option is 2 and a certain node contains 5 interfaces, but only one interface can be connecte to the selected interface, that node will be hidden. [Requires InterfacesNodeExpansionMode == Locked].
Public property LockAllAttributesExcept
Gets the collection of locked attributes.
(Inherited from ConfigurationElement.)
Public property LockAllElementsExcept
Gets the collection of locked elements.
(Inherited from ConfigurationElement.)
Public property LockAttributes
Gets the collection of locked attributes
(Inherited from ConfigurationElement.)
Public property LockElements
Gets the collection of locked elements.
(Inherited from ConfigurationElement.)
Public property LockItem
Gets or sets a value indicating whether the element is locked.
(Inherited from ConfigurationElement.)
Public property ShowInterfacesNetworkMapByDefault
Determines the default value of the "Show Network Map" checbox in Interfaces action.
Public property ShowOnlyMatchingInterfaces
If this is enabled, only interfaces that can be connected to the selected interface will be shown in the nodes. All interfaces will be shown otherwise.
Public property ShowSignalsNetworkMapByDefault
Determines the default value of the "Show Network Map" checbox in Signals action.
Public property SignalsNodeExpansionMode
Controls how and which nodes in the Signals Network Map will be expanded. Available values: All - All nodes will be expanded by default. Every node can be collapsed and expanded again. Connected - Main node and all nodes that have at least one connection to any other node will be expanded. ConnectedToMain - Main node and all nodes that have at least one connection to the main node will be expanded. Main - Only main node will be expanded. Every node can be collapsed and expanded again.
Public property SignalsNodePinningMode
Controls whether and how pinning of the nodes in Signals Network Map will be preserved. Available values: PreserveOnActionDeactivate - Pinned nodes will remain pinned even if you cancel the Signals Action. Every node can be pinned/unpinned manually. Pinning will be reset only on application restart. PreserveOnComponentChange - Pinned nodes will remain pinned even if you change the selected component. Closing the panel (cancels the Action) will reset all pinning. Every node can be pinned/unpinned manually. PreserveOnSignalChange - Pinned nodes will remain pinned even if you change the selected signal. Changing the selected component or closing the panel will reset all pinning. Nodes can be pinned/unpinned manually. ResetOnNodeVisibilityChange - Same as PreserveOnSignalChange, but pinning will be reset for nodes that are hidden from the view. For example, if ShowOnlyMatchingInterfaces option is enabled, some nodes might have no matching interface if you change the selected interface and thus will be hidden. Pinning of such nodes will be preserved with PreserveOnInterfaceChange option, but with this option they will be unpinned. Changing the selected component or closing the panel will reset all pinning. Nodes can be pinned/unpinned manually. DoNotPreserve - Pinned nodes will remain pinned only on basic actions (i.e.connect/disconnect, drag connection, etc.). Changing the selected interface/component or closing the panel will reset all pinning.Nodes can be pinned/unpinned manually. Disabled - Pinning is completely disabled. Nodes can be pinned/unpinned only programmatically. The corresponding button will be hidden from the UI.
Public property UseSimplifiedMaterialInGhostMode
Defines whether components in ghost-mode should be rendered with a simple solid gray material or using a semi- transparent ghost material calculated from their original materials. If this option is enabled, ghost component highlighting will happen faster and will not have a significant performance impact on 3D World navigation.
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks
These options are used in Interfaces and Signals commands.
See Also

Reference

VisualComponents.Create3D Namespace


ConnectionEditorConfigElement Constructor

Constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectionEditorConfigElement()
public:
ConnectionEditorConfigElement()
See Also

Reference

ConnectionEditorConfigElement Class
VisualComponents.Create3D Namespace


ConnectionEditorConfigElement Properties

The ConnectionEditorConfigElement type exposes the following members.

Properties
Name Description
Public property AllowConnectionDragging
If this is enabled, connections can be dragged out of connectors and dropped on other connectors or components (interfaces) and buttons/check-boxes to show or hide connection lines will be available. If this is disabled, those buttons will be hidden and it will not be possible to drag connections.
Public property ChangeSelectionOnComponentDoubleClick
If this is enabled, double-clicking a component in 3D World will change the currently selected component to the one you double-clicked. If the option is disabled, all clicks will be interpreted as single clicks.
Public property ChangeSelectionOnNodeTitleDoubleClick
If this is enabled, double-clicking the node's title will change the currently selected component to a component which the double-clicked node represents.
Public property CurrentConfiguration
Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to.
(Inherited from ConfigurationElement.)
Public property ElementInformation
Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object.
(Inherited from ConfigurationElement.)
Public property EnableNodeVirtualization
Defines whether UI virtualization is enabled in a canvas that hosts the Network Map.
Public property IndirectInterfaceConnectionsVisibility
Determines if the Network Map should contain (and show) connections going from/to an adjacent component to another adjacent component or another interface of the selected component. This option affects only Network Map and is useless when AllowConnectionDragging option is disabled. Available values: All - All indirect connections from/to all components in the 3D World which have the corresponding node in the Network Map will be shown. Component - Indirect connections between adjacent components (components that have at least one interface which can be or is already connected to any of interfaces in selected component) will be shown. Interface - Only indirect connections from/to interfaces of the selected component will be shown. None - No indirect connections will be shown.
Public property InterfacesListItemAlternativeNamingThreshold
The number of matching interfaces a node must contain to have connections (to it) in the list represented with alternative (includes interface's name in the brackets) name. For example, if the value of this option is 2 and a certain node has 2 interfaces that are already connected or can be connected to the selected node, then the corresponding connections in the list will be represented as component name + interface name.
Public property InterfacesNodeExpansionMode
Controls how and which nodes in the Interfaces Network Map will be expanded. Available values: All - All nodes will be expanded by default. Every node can be collapsed and expanded again. Connected - Main node and all nodes that have at least one connection to any other node will be expanded. ConnectedToMain - Main node and all nodes that have at least one connection to the main node will be expanded. Locked - Expanding/collapsing nodes is not possible. Corresponding buttons will be hidden from the UI and collapsed nodes will be hidden from the view. Main - Only main node will be expanded. Every node can be collapsed and expanded again.
Public property InterfacesNodePinningMode
Controls whether and how pinning of the nodes in Interfaces Network Map will be preserved. Available values: PreserveOnActionDeactivate - Pinned nodes will remain pinned even if you cancel the Interfaces Action. Every node can be pinned/unpinned manually.Pinning will be reset only on application restart. PreserveOnComponentChange - Pinned nodes will remain pinned even if you change the selected component. Closing the panel (cancels the Action) will reset all pinning. Every node can be pinned/unpinned manually. PreserveOnInterfaceChange - Pinned nodes will remain pinned even if you change the selected interface. Changing the selected component or closing the panel will reset all pinning. Nodes can be pinned/unpinned manually. ResetOnNodeVisibilityChange - Same as PreserveOnInterfaceChange, but pinning will be reset for nodes that are hidden from the view. For example, if ShowOnlyMatchingInterfaces option is enabled, some nodes might have no matching interface if you change the selected interface and thus will be hidden. Pinning of such nodes will be preserved with PreserveOnInterfaceChange option, but with this option they will be unpinned. Changing the selected component or closing the panel will reset all pinning. Nodes can be pinned/unpinned manually. DoNotPreserve - Pinned nodes will remain pinned only on basic actions (i.e.connect/disconnect, drag connection, etc.). Changing the selected interface/component or closing the panel will reset all pinning.Nodes can be pinned/unpinned manually. Disabled - Pinning is completely disabled. Nodes can be pinned/unpinned only programmatically. The corresponding button will be hidden from the UI.
Public property InterfacesNodeVisibilityThreshold
The number of matching interfaces a node must contain in order to be shown. For example, if the value of this option is 2 and a certain node contains 5 interfaces, but only one interface can be connecte to the selected interface, that node will be hidden. [Requires InterfacesNodeExpansionMode == Locked].
Public property LockAllAttributesExcept
Gets the collection of locked attributes.
(Inherited from ConfigurationElement.)
Public property LockAllElementsExcept
Gets the collection of locked elements.
(Inherited from ConfigurationElement.)
Public property LockAttributes
Gets the collection of locked attributes
(Inherited from ConfigurationElement.)
Public property LockElements
Gets the collection of locked elements.
(Inherited from ConfigurationElement.)
Public property LockItem
Gets or sets a value indicating whether the element is locked.
(Inherited from ConfigurationElement.)
Public property ShowInterfacesNetworkMapByDefault
Determines the default value of the "Show Network Map" checbox in Interfaces action.
Public property ShowOnlyMatchingInterfaces
If this is enabled, only interfaces that can be connected to the selected interface will be shown in the nodes. All interfaces will be shown otherwise.
Public property ShowSignalsNetworkMapByDefault
Determines the default value of the "Show Network Map" checbox in Signals action.
Public property SignalsNodeExpansionMode
Controls how and which nodes in the Signals Network Map will be expanded. Available values: All - All nodes will be expanded by default. Every node can be collapsed and expanded again. Connected - Main node and all nodes that have at least one connection to any other node will be expanded. ConnectedToMain - Main node and all nodes that have at least one connection to the main node will be expanded. Main - Only main node will be expanded. Every node can be collapsed and expanded again.
Public property SignalsNodePinningMode
Controls whether and how pinning of the nodes in Signals Network Map will be preserved. Available values: PreserveOnActionDeactivate - Pinned nodes will remain pinned even if you cancel the Signals Action. Every node can be pinned/unpinned manually. Pinning will be reset only on application restart. PreserveOnComponentChange - Pinned nodes will remain pinned even if you change the selected component. Closing the panel (cancels the Action) will reset all pinning. Every node can be pinned/unpinned manually. PreserveOnSignalChange - Pinned nodes will remain pinned even if you change the selected signal. Changing the selected component or closing the panel will reset all pinning. Nodes can be pinned/unpinned manually. ResetOnNodeVisibilityChange - Same as PreserveOnSignalChange, but pinning will be reset for nodes that are hidden from the view. For example, if ShowOnlyMatchingInterfaces option is enabled, some nodes might have no matching interface if you change the selected interface and thus will be hidden. Pinning of such nodes will be preserved with PreserveOnInterfaceChange option, but with this option they will be unpinned. Changing the selected component or closing the panel will reset all pinning. Nodes can be pinned/unpinned manually. DoNotPreserve - Pinned nodes will remain pinned only on basic actions (i.e.connect/disconnect, drag connection, etc.). Changing the selected interface/component or closing the panel will reset all pinning.Nodes can be pinned/unpinned manually. Disabled - Pinning is completely disabled. Nodes can be pinned/unpinned only programmatically. The corresponding button will be hidden from the UI.
Public property UseSimplifiedMaterialInGhostMode
Defines whether components in ghost-mode should be rendered with a simple solid gray material or using a semi- transparent ghost material calculated from their original materials. If this option is enabled, ghost component highlighting will happen faster and will not have a significant performance impact on 3D World navigation.
Top
See Also

Reference

ConnectionEditorConfigElement Class
VisualComponents.Create3D Namespace


ConnectionEditorConfigElement.AllowConnectionDragging Property

ConnectionEditorConfigElementAllowConnectionDragging Property

If this is enabled, connections can be dragged out of connectors and dropped on other connectors or components (interfaces) and buttons/check-boxes to show or hide connection lines will be available. If this is disabled, those buttons will be hidden and it will not be possible to drag connections.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool AllowConnectionDragging { get; set; }
public:
property bool AllowConnectionDragging {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectionEditorConfigElement Class
VisualComponents.Create3D Namespace


ConnectionEditorConfigElement.ChangeSelectionOnComponentDoubleClick Property

ConnectionEditorConfigElementChangeSelectionOnComponentDoubleClick Property

If this is enabled, double-clicking a component in 3D World will change the currently selected component to the one you double-clicked. If the option is disabled, all clicks will be interpreted as single clicks.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ChangeSelectionOnComponentDoubleClick { get; set; }
public:
property bool ChangeSelectionOnComponentDoubleClick {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectionEditorConfigElement Class
VisualComponents.Create3D Namespace


ConnectionEditorConfigElement.ChangeSelectionOnNodeTitleDoubleClick Property

ConnectionEditorConfigElementChangeSelectionOnNodeTitleDoubleClick Property

If this is enabled, double-clicking the node's title will change the currently selected component to a component which the double-clicked node represents.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ChangeSelectionOnNodeTitleDoubleClick { get; set; }
public:
property bool ChangeSelectionOnNodeTitleDoubleClick {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectionEditorConfigElement Class
VisualComponents.Create3D Namespace


ConnectionEditorConfigElement.EnableNodeVirtualization Property

ConnectionEditorConfigElementEnableNodeVirtualization Property

Defines whether UI virtualization is enabled in a canvas that hosts the Network Map.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool EnableNodeVirtualization { get; set; }
public:
property bool EnableNodeVirtualization {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectionEditorConfigElement Class
VisualComponents.Create3D Namespace


ConnectionEditorConfigElement.IndirectInterfaceConnectionsVisibility Property

ConnectionEditorConfigElementIndirectInterfaceConnectionsVisibility Property

Determines if the Network Map should contain (and show) connections going from/to an adjacent component to another adjacent component or another interface of the selected component. This option affects only Network Map and is useless when AllowConnectionDragging option is disabled. Available values: All - All indirect connections from/to all components in the 3D World which have the corresponding node in the Network Map will be shown. Component - Indirect connections between adjacent components (components that have at least one interface which can be or is already connected to any of interfaces in selected component) will be shown. Interface - Only indirect connections from/to interfaces of the selected component will be shown. None - No indirect connections will be shown.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string IndirectInterfaceConnectionsVisibility { get; set; }
public:
property String^ IndirectInterfaceConnectionsVisibility {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ConnectionEditorConfigElement Class
VisualComponents.Create3D Namespace


ConnectionEditorConfigElement.InterfacesListItemAlternativeNamingThreshold Property

ConnectionEditorConfigElementInterfacesListItemAlternativeNamingThreshold Property

The number of matching interfaces a node must contain to have connections (to it) in the list represented with alternative (includes interface's name in the brackets) name. For example, if the value of this option is 2 and a certain node has 2 interfaces that are already connected or can be connected to the selected node, then the corresponding connections in the list will be represented as component name + interface name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int InterfacesListItemAlternativeNamingThreshold { get; set; }
public:
property int InterfacesListItemAlternativeNamingThreshold {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ConnectionEditorConfigElement Class
VisualComponents.Create3D Namespace


ConnectionEditorConfigElement.InterfacesNodeExpansionMode Property

ConnectionEditorConfigElementInterfacesNodeExpansionMode Property

Controls how and which nodes in the Interfaces Network Map will be expanded. Available values: All - All nodes will be expanded by default. Every node can be collapsed and expanded again. Connected - Main node and all nodes that have at least one connection to any other node will be expanded. ConnectedToMain - Main node and all nodes that have at least one connection to the main node will be expanded. Locked - Expanding/collapsing nodes is not possible. Corresponding buttons will be hidden from the UI and collapsed nodes will be hidden from the view. Main - Only main node will be expanded. Every node can be collapsed and expanded again.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string InterfacesNodeExpansionMode { get; set; }
public:
property String^ InterfacesNodeExpansionMode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ConnectionEditorConfigElement Class
VisualComponents.Create3D Namespace


ConnectionEditorConfigElement.InterfacesNodePinningMode Property

ConnectionEditorConfigElementInterfacesNodePinningMode Property

Controls whether and how pinning of the nodes in Interfaces Network Map will be preserved. Available values: PreserveOnActionDeactivate - Pinned nodes will remain pinned even if you cancel the Interfaces Action. Every node can be pinned/unpinned manually.Pinning will be reset only on application restart. PreserveOnComponentChange - Pinned nodes will remain pinned even if you change the selected component. Closing the panel (cancels the Action) will reset all pinning. Every node can be pinned/unpinned manually. PreserveOnInterfaceChange - Pinned nodes will remain pinned even if you change the selected interface. Changing the selected component or closing the panel will reset all pinning. Nodes can be pinned/unpinned manually. ResetOnNodeVisibilityChange - Same as PreserveOnInterfaceChange, but pinning will be reset for nodes that are hidden from the view. For example, if ShowOnlyMatchingInterfaces option is enabled, some nodes might have no matching interface if you change the selected interface and thus will be hidden. Pinning of such nodes will be preserved with PreserveOnInterfaceChange option, but with this option they will be unpinned. Changing the selected component or closing the panel will reset all pinning. Nodes can be pinned/unpinned manually. DoNotPreserve - Pinned nodes will remain pinned only on basic actions (i.e.connect/disconnect, drag connection, etc.). Changing the selected interface/component or closing the panel will reset all pinning.Nodes can be pinned/unpinned manually. Disabled - Pinning is completely disabled. Nodes can be pinned/unpinned only programmatically. The corresponding button will be hidden from the UI.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string InterfacesNodePinningMode { get; set; }
public:
property String^ InterfacesNodePinningMode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ConnectionEditorConfigElement Class
VisualComponents.Create3D Namespace


ConnectionEditorConfigElement.InterfacesNodeVisibilityThreshold Property

ConnectionEditorConfigElementInterfacesNodeVisibilityThreshold Property

The number of matching interfaces a node must contain in order to be shown. For example, if the value of this option is 2 and a certain node contains 5 interfaces, but only one interface can be connecte to the selected interface, that node will be hidden. [Requires InterfacesNodeExpansionMode == Locked].

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int InterfacesNodeVisibilityThreshold { get; set; }
public:
property int InterfacesNodeVisibilityThreshold {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ConnectionEditorConfigElement Class
VisualComponents.Create3D Namespace


ConnectionEditorConfigElement.ShowInterfacesNetworkMapByDefault Property

ConnectionEditorConfigElementShowInterfacesNetworkMapByDefault Property

Determines the default value of the "Show Network Map" checbox in Interfaces action.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowInterfacesNetworkMapByDefault { get; set; }
public:
property bool ShowInterfacesNetworkMapByDefault {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectionEditorConfigElement Class
VisualComponents.Create3D Namespace


ConnectionEditorConfigElement.ShowOnlyMatchingInterfaces Property

ConnectionEditorConfigElementShowOnlyMatchingInterfaces Property

If this is enabled, only interfaces that can be connected to the selected interface will be shown in the nodes. All interfaces will be shown otherwise.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowOnlyMatchingInterfaces { get; set; }
public:
property bool ShowOnlyMatchingInterfaces {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectionEditorConfigElement Class
VisualComponents.Create3D Namespace


ConnectionEditorConfigElement.ShowSignalsNetworkMapByDefault Property

ConnectionEditorConfigElementShowSignalsNetworkMapByDefault Property

Determines the default value of the "Show Network Map" checbox in Signals action.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowSignalsNetworkMapByDefault { get; set; }
public:
property bool ShowSignalsNetworkMapByDefault {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectionEditorConfigElement Class
VisualComponents.Create3D Namespace


ConnectionEditorConfigElement.SignalsNodeExpansionMode Property

ConnectionEditorConfigElementSignalsNodeExpansionMode Property

Controls how and which nodes in the Signals Network Map will be expanded. Available values: All - All nodes will be expanded by default. Every node can be collapsed and expanded again. Connected - Main node and all nodes that have at least one connection to any other node will be expanded. ConnectedToMain - Main node and all nodes that have at least one connection to the main node will be expanded. Main - Only main node will be expanded. Every node can be collapsed and expanded again.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SignalsNodeExpansionMode { get; set; }
public:
property String^ SignalsNodeExpansionMode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ConnectionEditorConfigElement Class
VisualComponents.Create3D Namespace


ConnectionEditorConfigElement.SignalsNodePinningMode Property

ConnectionEditorConfigElementSignalsNodePinningMode Property

Controls whether and how pinning of the nodes in Signals Network Map will be preserved. Available values: PreserveOnActionDeactivate - Pinned nodes will remain pinned even if you cancel the Signals Action. Every node can be pinned/unpinned manually. Pinning will be reset only on application restart. PreserveOnComponentChange - Pinned nodes will remain pinned even if you change the selected component. Closing the panel (cancels the Action) will reset all pinning. Every node can be pinned/unpinned manually. PreserveOnSignalChange - Pinned nodes will remain pinned even if you change the selected signal. Changing the selected component or closing the panel will reset all pinning. Nodes can be pinned/unpinned manually. ResetOnNodeVisibilityChange - Same as PreserveOnSignalChange, but pinning will be reset for nodes that are hidden from the view. For example, if ShowOnlyMatchingInterfaces option is enabled, some nodes might have no matching interface if you change the selected interface and thus will be hidden. Pinning of such nodes will be preserved with PreserveOnInterfaceChange option, but with this option they will be unpinned. Changing the selected component or closing the panel will reset all pinning. Nodes can be pinned/unpinned manually. DoNotPreserve - Pinned nodes will remain pinned only on basic actions (i.e.connect/disconnect, drag connection, etc.). Changing the selected interface/component or closing the panel will reset all pinning.Nodes can be pinned/unpinned manually. Disabled - Pinning is completely disabled. Nodes can be pinned/unpinned only programmatically. The corresponding button will be hidden from the UI.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SignalsNodePinningMode { get; set; }
public:
property String^ SignalsNodePinningMode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ConnectionEditorConfigElement Class
VisualComponents.Create3D Namespace


ConnectionEditorConfigElement.UseSimplifiedMaterialInGhostMode Property

ConnectionEditorConfigElementUseSimplifiedMaterialInGhostMode Property

Defines whether components in ghost-mode should be rendered with a simple solid gray material or using a semi- transparent ghost material calculated from their original materials. If this option is enabled, ghost component highlighting will happen faster and will not have a significant performance impact on 3D World navigation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool UseSimplifiedMaterialInGhostMode { get; set; }
public:
property bool UseSimplifiedMaterialInGhostMode {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectionEditorConfigElement Class
VisualComponents.Create3D Namespace


ConnectionEditorConfigElement Methods

The ConnectionEditorConfigElement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ConnectionEditorConfigElement Class
VisualComponents.Create3D Namespace


ConnectionEditorSection Class

Configuration file section for Connection Editor Options.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationSection
VisualComponents.Create3DConnectionEditorSection

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ConnectionEditorSection : ConfigurationSection,
    IConnectionEditorSection, ISection
public ref class ConnectionEditorSection sealed : public ConfigurationSection,
    IConnectionEditorSection, ISection

The ConnectionEditorSection type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionEditorSection | Contructor.
Top
Properties
 | Name | Description
Public property | ConnectionEditorElement | Configuration file element for Connection Editor Options.
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName | Section's name in configuration file.
Public property | SectionType | Interface type.
Public property | SectionVersion | Section's version number.
Top
Methods
 | Name | Description
Public method | CheckVersion | Upgrade configuration to the latest version.
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection | Finds typed section by name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ConnectionEditorSection Constructor

Contructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectionEditorSection()
public:
ConnectionEditorSection()
See Also

Reference

ConnectionEditorSection Class
VisualComponents.Create3D Namespace


ConnectionEditorSection Properties

The ConnectionEditorSection type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionEditorElement | Configuration file element for Connection Editor Options.
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName | Section's name in configuration file.
Public property | SectionType | Interface type.
Public property | SectionVersion | Section's version number.
Top
See Also

Reference

ConnectionEditorSection Class
VisualComponents.Create3D Namespace


ConnectionEditorSection.ConnectionEditorElement Property

ConnectionEditorSectionConnectionEditorElement Property

Configuration file element for Connection Editor Options.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectionEditorConfigElement ConnectionEditorElement { get; set; }
public:
virtual property ConnectionEditorConfigElement^ ConnectionEditorElement {
    ConnectionEditorConfigElement^ get () sealed;
    void set (ConnectionEditorConfigElement^ value) sealed;
}

Property Value

Type: ConnectionEditorConfigElement

Implements

IConnectionEditorSectionConnectionEditorElement
See Also

Reference

ConnectionEditorSection Class
VisualComponents.Create3D Namespace


ConnectionEditorSection.SectionName Property

ConnectionEditorSectionSectionName Property

Section's name in configuration file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SectionName { get; }
public:
virtual property String^ SectionName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ISectionSectionName
See Also

Reference

ConnectionEditorSection Class
VisualComponents.Create3D Namespace


ConnectionEditorSection.SectionType Property

ConnectionEditorSectionSectionType Property

Interface type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type SectionType { get; }
public:
virtual property Type^ SectionType {
    Type^ get () sealed;
}

Property Value

Type: Type

Implements

ISectionSectionType
See Also

Reference

ConnectionEditorSection Class
VisualComponents.Create3D Namespace


ConnectionEditorSection.SectionVersion Property

ConnectionEditorSectionSectionVersion Property

Section's version number.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int SectionVersion { get; }
public:
virtual property int SectionVersion {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISectionSectionVersion
See Also

Reference

ConnectionEditorSection Class
VisualComponents.Create3D Namespace


ConnectionEditorSection Methods

The ConnectionEditorSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion | Upgrade configuration to the latest version.
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection | Finds typed section by name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ConnectionEditorSection Class
VisualComponents.Create3D Namespace


ConnectionEditorSection.CheckVersion Method

ConnectionEditorSectionCheckVersion Method

Upgrade configuration to the latest version.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CheckVersion()
public:
virtual void CheckVersion() sealed

Implements

ISectionCheckVersion
See Also

Reference

ConnectionEditorSection Class
VisualComponents.Create3D Namespace


ConnectionEditorSection.GetSection Method

ConnectionEditorSectionGetSection Method

Finds typed section by name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISection GetSection(
    Configuration userSettingConfiguration
)
public:
virtual ISection^ GetSection(
    Configuration^ userSettingConfiguration
) sealed

Parameters

userSettingConfiguration
Type: System.ConfigurationConfiguration
Configuration containing this section

Return Value

Type: ISection
Instance of ConnectionEditorSection

Implements

ISectionGetSection(Configuration)
See Also

Reference

ConnectionEditorSection Class
VisualComponents.Create3D Namespace


ConnectionEditorSection.ToString Method

ConnectionEditorSectionToString Method

Converts this instance to string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String
String representation of this instance
See Also

Reference

ConnectionEditorSection Class
VisualComponents.Create3D Namespace


ConnectorAddedEventArgs Class

Provides the data for ConnectorAdded event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DConnectorAddedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ConnectorAddedEventArgs : EventArgs
public ref class ConnectorAddedEventArgs : public EventArgs

The ConnectorAddedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectorAddedEventArgs | Initializes a new instance of the ConnectorAddedEventArgs class.
Top
Properties
 | Name | Description
Public property | Connector | Gets the instance of ISimConnector that has been added.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ConnectorAddedEventArgs Constructor

Initializes a new instance of the ConnectorAddedEventArgs class.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectorAddedEventArgs(
    ISimConnector connector
)
public:
ConnectorAddedEventArgs(
    ISimConnector^ connector
)

Parameters

connector
Type: VisualComponents.Create3DISimConnector
The connector that has been added.
See Also

Reference

ConnectorAddedEventArgs Class
VisualComponents.Create3D Namespace


ConnectorAddedEventArgs Properties

The ConnectorAddedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Connector | Gets the instance of ISimConnector that has been added.
Top
See Also

Reference

ConnectorAddedEventArgs Class
VisualComponents.Create3D Namespace


ConnectorAddedEventArgs.Connector Property

ConnectorAddedEventArgsConnector Property

Gets the instance of ISimConnector that has been added.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimConnector Connector { get; }
public:
property ISimConnector^ Connector {
    ISimConnector^ get ();
}

Property Value

Type: ISimConnector
See Also

Reference

ConnectorAddedEventArgs Class
VisualComponents.Create3D Namespace


ConnectorAddedEventArgs Methods

The ConnectorAddedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ConnectorAddedEventArgs Class
VisualComponents.Create3D Namespace


ConnectorRemovingEventArgs Class

Provides the data for ConnectorRemoving event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DConnectorRemovingEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ConnectorRemovingEventArgs : EventArgs
public ref class ConnectorRemovingEventArgs : public EventArgs

The ConnectorRemovingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectorRemovingEventArgs | Initializes a new instance of the ConnectorRemovingEventArgs class.
Top
Properties
 | Name | Description
Public property | Connector | Gets the instance of ISimConnector that is being removed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ConnectorRemovingEventArgs Constructor

Initializes a new instance of the ConnectorRemovingEventArgs class.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectorRemovingEventArgs(
    ISimConnector connector
)
public:
ConnectorRemovingEventArgs(
    ISimConnector^ connector
)

Parameters

connector
Type: VisualComponents.Create3DISimConnector
The connector that has been added.
See Also

Reference

ConnectorRemovingEventArgs Class
VisualComponents.Create3D Namespace


ConnectorRemovingEventArgs Properties

The ConnectorRemovingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Connector | Gets the instance of ISimConnector that is being removed.
Top
See Also

Reference

ConnectorRemovingEventArgs Class
VisualComponents.Create3D Namespace


ConnectorRemovingEventArgs.Connector Property

ConnectorRemovingEventArgsConnector Property

Gets the instance of ISimConnector that is being removed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimConnector Connector { get; }
public:
property ISimConnector^ Connector {
    ISimConnector^ get ();
}

Property Value

Type: ISimConnector
See Also

Reference

ConnectorRemovingEventArgs Class
VisualComponents.Create3D Namespace


ConnectorRemovingEventArgs Methods

The ConnectorRemovingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ConnectorRemovingEventArgs Class
VisualComponents.Create3D Namespace


ConnectorTestLocation Enumeration

Conditions for testing behavior capacity.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ConnectorTestLocation
public enum class ConnectorTestLocation
Members
Member name | Value | Description
Leading | 0 | Capacity is checked when component's leading edge enters the container.
Origin | 1 | Capacity is checked when component's origin enters the container.
Trailing | 2 | Capacity is checked when component's trailing edge enter's the container.
See Also

Reference

VisualComponents.Create3D Namespace


ConnectorType Enumeration

Types of connectors.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ConnectorType
public enum class ConnectorType
Members
Member name | Value | Description
None | 0 | Not defined
Input | 1 | Connector used to accept material flow.
Output | 2 | Connector used as output.
InputOutput | 3 | Both input and output
See Also

Reference

VisualComponents.Create3D Namespace


ConstantDistributionParameters Class

Constant distribution parameters
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DConstantDistributionParameters

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ConstantDistributionParameters : IDistributionParameters
public ref class ConstantDistributionParameters : IDistributionParameters

The ConstantDistributionParameters type exposes the following members.

Constructors
 | Name | Description
Public method | ConstantDistributionParameters | Initializes a new instance of the ConstantDistributionParameters class
Public method | ConstantDistributionParameters(IProperty) | Initializes a new instance of the ConstantDistributionParameters class
Top
Properties
 | Name | Description
Public property | DistributionType |
Public property | Expression |
Public property | Property |
Public property | Value | Constant value
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ConstantDistributionParameters Constructor

Overload List
 | Name | Description
Public method | ConstantDistributionParameters | Initializes a new instance of the ConstantDistributionParameters class
Public method | ConstantDistributionParameters(IProperty) | Initializes a new instance of the ConstantDistributionParameters class
Top
See Also

Reference

ConstantDistributionParameters Class
VisualComponents.Create3D Namespace


ConstantDistributionParameters Constructor

Initializes a new instance of the ConstantDistributionParameters class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConstantDistributionParameters()
public:
ConstantDistributionParameters()
See Also

Reference

ConstantDistributionParameters Class
ConstantDistributionParameters Overload
VisualComponents.Create3D Namespace


ConstantDistributionParameters Constructor (IProperty)

Initializes a new instance of the ConstantDistributionParameters class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConstantDistributionParameters(
    IProperty property
)
public:
ConstantDistributionParameters(
    IProperty^ property
)

Parameters

property
Type: VisualComponents.Create3DIProperty
See Also

Reference

ConstantDistributionParameters Class
ConstantDistributionParameters Overload
VisualComponents.Create3D Namespace


ConstantDistributionParameters Properties

The ConstantDistributionParameters type exposes the following members.

Properties
 | Name | Description
Public property | DistributionType |
Public property | Expression |
Public property | Property |
Public property | Value | Constant value
Top
See Also

Reference

ConstantDistributionParameters Class
VisualComponents.Create3D Namespace


ConstantDistributionParameters.DistributionType Property

ConstantDistributionParametersDistributionType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DistributionType DistributionType { get; }
public:
virtual property DistributionType DistributionType {
    DistributionType get () sealed;
}

Property Value

Type: DistributionType

Implements

IDistributionParametersDistributionType
See Also

Reference

ConstantDistributionParameters Class
VisualComponents.Create3D Namespace


ConstantDistributionParameters.Expression Property

ConstantDistributionParametersExpression Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Expression { get; }
public:
virtual property String^ Expression {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IDistributionParametersExpression
See Also

Reference

ConstantDistributionParameters Class
VisualComponents.Create3D Namespace


ConstantDistributionParameters.Property Property

ConstantDistributionParametersProperty Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty Property { get; }
public:
property IProperty^ Property {
    IProperty^ get ();
}

Property Value

Type: IProperty
See Also

Reference

ConstantDistributionParameters Class
VisualComponents.Create3D Namespace


ConstantDistributionParameters.Value Property

ConstantDistributionParametersValue Property

Constant value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Value { get; set; }
public:
property double Value {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ConstantDistributionParameters Class
VisualComponents.Create3D Namespace


ConstantDistributionParameters Methods

The ConstantDistributionParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ConstantDistributionParameters Class
VisualComponents.Create3D Namespace


ContainerTransitionEventArgs Class

Event trigger trigger by ISimContainer when component is arriving or leaving the container
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DContainerTransitionEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ContainerTransitionEventArgs : EventArgs
public ref class ContainerTransitionEventArgs : public EventArgs

The ContainerTransitionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ContainerTransitionEventArgs | constructor
Top
Properties
 | Name | Description
Public property | Component | Component in question
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ContainerTransitionEventArgs Constructor

constructor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ContainerTransitionEventArgs(
    ISimComponent component
)
public:
ContainerTransitionEventArgs(
    ISimComponent^ component
)

Parameters

component
Type: VisualComponents.Create3DISimComponent
See Also

Reference

ContainerTransitionEventArgs Class
VisualComponents.Create3D Namespace


ContainerTransitionEventArgs Properties

The ContainerTransitionEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Component | Component in question
Top
See Also

Reference

ContainerTransitionEventArgs Class
VisualComponents.Create3D Namespace


ContainerTransitionEventArgs.Component Property

ContainerTransitionEventArgsComponent Property

Component in question

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimComponent Component { get; }
public:
property ISimComponent^ Component {
    ISimComponent^ get ();
}

Property Value

Type: ISimComponent
See Also

Reference

ContainerTransitionEventArgs Class
VisualComponents.Create3D Namespace


ContainerTransitionEventArgs Methods

The ContainerTransitionEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ContainerTransitionEventArgs Class
VisualComponents.Create3D Namespace


ContextConfigCollection Class

Configuration file element collection for context dependent options.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationElementCollection
VisualComponents.Create3DContextConfigCollection

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ContextConfigCollection : ConfigurationElementCollection
public ref class ContextConfigCollection : public ConfigurationElementCollection

The ContextConfigCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ContextConfigCollection | Initializes a new instance of the ContextConfigCollection class
Top
Properties
 | Name | Description
Protected property | AddElementName | Gets or sets the name of the ConfigurationElement to associate with the add operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected property | ClearElementName | Gets or sets the name for the ConfigurationElement to associate with the clear operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementName | Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is . (Inherited from ConfigurationElement.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Public property | ItemInt32 | Gets item by index.
Public property | ItemString | Gets item by key.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Protected property | RemoveElementName | Gets or sets the name of the ConfigurationElement to associate with the remove operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected property | ThrowOnDuplicate | Gets a value indicating whether an attempt to add a duplicate ConfigurationElement to the ConfigurationElementCollection will cause an exception to be thrown. (Inherited from ConfigurationElementCollection.)
Top
Methods
 | Name | Description
Public method | Add | Adds item to this collection.
Protected method | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseClear | Removes all configuration element objects from the collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGet(Object) | Returns the configuration element with the specified key. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGet(Int32) | Gets the configuration element at the specified index location. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGetAllKeys | Returns an array of the keys for all of the configuration elements contained in the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGetKey | Gets the key for the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
Protected method | BaseIndexOf | Indicates the index of the specified ConfigurationElement. (Inherited from ConfigurationElementCollection.)
Protected method | BaseIsRemoved | Indicates whether the ConfigurationElement with the specified key has been removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseRemove | Removes a ConfigurationElement from the collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseRemoveAt | Removes the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
Public method | Clear | Clears collection.
Public method | Contains | Returns a value indicating whether the container contains a specified key.
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Protected method | CreateNewElement | Creates new configuration element. (Overrides ConfigurationElementCollectionCreateNewElement.)
Protected method | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetElementKey | Returns the key of specified configuration element. (Overrides ConfigurationElementCollectionGetElementKey(ConfigurationElement).)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsElementName | Indicates whether the specified ConfigurationElement exists in the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | IsElementRemovable | Indicates whether the specified ConfigurationElement can be removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | IsModified | Indicates whether this ConfigurationElementCollection has been modified since it was last saved or loaded when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Causes the configuration system to throw an exception. (Inherited from ConfigurationElementCollection.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Public method | Remove | Removes item from this collection.
Protected method | Reset | Resets the ConfigurationElementCollection to its unmodified state when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | ResetModified | Resets the value of the IsModified property to when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | SerializeElement | Writes the configuration data to an XML element in the configuration file when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElementCollection object and for all sub-elements. (Inherited from ConfigurationElementCollection.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Reverses the effect of merging configuration information from different levels of the configuration hierarchy (Inherited from ConfigurationElementCollection.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ContextConfigCollection Constructor

Initializes a new instance of the ContextConfigCollection class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ContextConfigCollection()
public:
ContextConfigCollection()
See Also

Reference

ContextConfigCollection Class
VisualComponents.Create3D Namespace


ContextConfigCollection Properties

The ContextConfigCollection type exposes the following members.

Properties
 | Name | Description
Protected property | AddElementName | Gets or sets the name of the ConfigurationElement to associate with the add operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected property | ClearElementName | Gets or sets the name for the ConfigurationElement to associate with the clear operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementName | Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is . (Inherited from ConfigurationElement.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Public property | ItemInt32 | Gets item by index.
Public property | ItemString | Gets item by key.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Protected property | RemoveElementName | Gets or sets the name of the ConfigurationElement to associate with the remove operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected property | ThrowOnDuplicate | Gets a value indicating whether an attempt to add a duplicate ConfigurationElement to the ConfigurationElementCollection will cause an exception to be thrown. (Inherited from ConfigurationElementCollection.)
Top
See Also

Reference

ContextConfigCollection Class
VisualComponents.Create3D Namespace


ContextConfigCollection.Item Property

ContextConfigCollectionItem Property

Overload List
 | Name | Description
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Public property | ItemInt32 | Gets item by index.
Public property | ItemString | Gets item by key.
Top
See Also

Reference

ContextConfigCollection Class
VisualComponents.Create3D Namespace


ContextConfigCollection.Item Property (Int32)

ContextConfigCollectionItem Property (Int32)

Gets item by index.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BaseContextConfigElement this[
    int index
] { get; }
public:
property BaseContextConfigElement^ default[int index] {
    BaseContextConfigElement^ get (int index);
}

Parameters

index
Type: SystemInt32

Property Value

Type: BaseContextConfigElement
See Also

Reference

ContextConfigCollection Class
Item Overload
VisualComponents.Create3D Namespace


ContextConfigCollection.Item Property (String)

ContextConfigCollectionItem Property (String)

Gets item by key.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BaseContextConfigElement this[
    string key
] { get; set; }
public:
property BaseContextConfigElement^ default[String^ key] {
    BaseContextConfigElement^ get (String^ key);
    void set (String^ key, BaseContextConfigElement^ value);
}

Parameters

key
Type: SystemString

Property Value

Type: BaseContextConfigElement
See Also

Reference

ContextConfigCollection Class
Item Overload
VisualComponents.Create3D Namespace


ContextConfigCollection Methods

The ContextConfigCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds item to this collection.
Protected method | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseClear | Removes all configuration element objects from the collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGet(Object) | Returns the configuration element with the specified key. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGet(Int32) | Gets the configuration element at the specified index location. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGetAllKeys | Returns an array of the keys for all of the configuration elements contained in the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGetKey | Gets the key for the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
Protected method | BaseIndexOf | Indicates the index of the specified ConfigurationElement. (Inherited from ConfigurationElementCollection.)
Protected method | BaseIsRemoved | Indicates whether the ConfigurationElement with the specified key has been removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseRemove | Removes a ConfigurationElement from the collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseRemoveAt | Removes the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
Public method | Clear | Clears collection.
Public method | Contains | Returns a value indicating whether the container contains a specified key.
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Protected method | CreateNewElement | Creates new configuration element. (Overrides ConfigurationElementCollectionCreateNewElement.)
Protected method | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetElementKey | Returns the key of specified configuration element. (Overrides ConfigurationElementCollectionGetElementKey(ConfigurationElement).)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsElementName | Indicates whether the specified ConfigurationElement exists in the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | IsElementRemovable | Indicates whether the specified ConfigurationElement can be removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | IsModified | Indicates whether this ConfigurationElementCollection has been modified since it was last saved or loaded when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Causes the configuration system to throw an exception. (Inherited from ConfigurationElementCollection.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Public method | Remove | Removes item from this collection.
Protected method | Reset | Resets the ConfigurationElementCollection to its unmodified state when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | ResetModified | Resets the value of the IsModified property to when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | SerializeElement | Writes the configuration data to an XML element in the configuration file when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElementCollection object and for all sub-elements. (Inherited from ConfigurationElementCollection.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Reverses the effect of merging configuration information from different levels of the configuration hierarchy (Inherited from ConfigurationElementCollection.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ContextConfigCollection Class
VisualComponents.Create3D Namespace


ContextConfigCollection.Add Method

ContextConfigCollectionAdd Method

Adds item to this collection.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Add(
    BaseContextConfigElement configItem
)
public:
void Add(
    BaseContextConfigElement^ configItem
)

Parameters

configItem
Type: VisualComponents.Create3DBaseContextConfigElement
See Also

Reference

ContextConfigCollection Class
VisualComponents.Create3D Namespace


ContextConfigCollection.Clear Method

ContextConfigCollectionClear Method

Clears collection.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Clear()
public:
void Clear()
See Also

Reference

ContextConfigCollection Class
VisualComponents.Create3D Namespace


ContextConfigCollection.Contains Method

ContextConfigCollectionContains Method

Returns a value indicating whether the container contains a specified key.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Contains(
    string key
)
public:
bool Contains(
    String^ key
)

Parameters

key
Type: SystemString

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ContextConfigCollection.Contains(System.String)"]

See Also

Reference

ContextConfigCollection Class
VisualComponents.Create3D Namespace


ContextConfigCollection.CreateNewElement Method

ContextConfigCollectionCreateNewElement Method

Overload List
 | Name | Description
Protected method | CreateNewElement | Creates new configuration element. (Overrides ConfigurationElementCollectionCreateNewElement.)
Protected method | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Top
See Also

Reference

ContextConfigCollection Class
VisualComponents.Create3D Namespace


ContextConfigCollection.CreateNewElement Method

ContextConfigCollectionCreateNewElement Method

Creates new configuration element.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override ConfigurationElement CreateNewElement()
protected:
virtual ConfigurationElement^ CreateNewElement() override

Return Value

Type: ConfigurationElement

[Missing <returns> documentation for "M:VisualComponents.Create3D.ContextConfigCollection.CreateNewElement"]

See Also

Reference

ContextConfigCollection Class
CreateNewElement Overload
VisualComponents.Create3D Namespace


ContextConfigCollection.GetElementKey Method

ContextConfigCollectionGetElementKey Method

Returns the key of specified configuration element.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Object GetElementKey(
    ConfigurationElement element
)
protected:
virtual Object^ GetElementKey(
    ConfigurationElement^ element
) override

Parameters

element
Type: System.ConfigurationConfigurationElement
Specified configuration element

Return Value

Type: Object
Key of specified configuration element
See Also

Reference

ContextConfigCollection Class
VisualComponents.Create3D Namespace


ContextConfigCollection.Remove Method

ContextConfigCollectionRemove Method

Removes item from this collection.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Remove(
    string name
)
public:
void Remove(
    String^ name
)

Parameters

name
Type: SystemString
See Also

Reference

ContextConfigCollection Class
VisualComponents.Create3D Namespace


Contexts Class

Static class that shows all possible Application contexts IDs.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DContexts

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class Contexts
public ref class Contexts abstract sealed

The Contexts type exposes the following members.

Fields
Name | Description
All |
Author |
Configure |
Connections | Implemented by [A:VisualComponents.UXAddOn.Connectivity]
Drawing |
None | Viewmodel is only shown explicitly.
Process |
Teach |
Top
See Also

Reference

VisualComponents.Create3D Namespace


Contexts Fields

The Contexts type exposes the following members.

Fields
Name | Description
All |
Author |
Configure |
Connections | Implemented by [A:VisualComponents.UXAddOn.Connectivity]
Drawing |
None | Viewmodel is only shown explicitly.
Process |
Teach |
Top
See Also

Reference

Contexts Class
VisualComponents.Create3D Namespace


Contexts.All Field

ContextsAll Field

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string All = "All"
public:
literal String^ All = "All"

Field Value

Type: String
See Also

Reference

Contexts Class
VisualComponents.Create3D Namespace


Contexts.Author Field

ContextsAuthor Field

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Author = "Author"
public:
literal String^ Author = "Author"

Field Value

Type: String
See Also

Reference

Contexts Class
VisualComponents.Create3D Namespace


Contexts.Configure Field

ContextsConfigure Field

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Configure = "Configure"
public:
literal String^ Configure = "Configure"

Field Value

Type: String
See Also

Reference

Contexts Class
VisualComponents.Create3D Namespace


Contexts.Connections Field

ContextsConnections Field

Implemented by [A:VisualComponents.UXAddOn.Connectivity]

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Connections = "Connections"
public:
literal String^ Connections = "Connections"

Field Value

Type: String
See Also

Reference

Contexts Class
VisualComponents.Create3D Namespace


Contexts.Drawing Field

ContextsDrawing Field

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Drawing = "Drawing"
public:
literal String^ Drawing = "Drawing"

Field Value

Type: String
See Also

Reference

Contexts Class
VisualComponents.Create3D Namespace


Contexts.None Field

ContextsNone Field

Viewmodel is only shown explicitly.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string None = "None"
public:
literal String^ None = "None"

Field Value

Type: String
See Also

Reference

Contexts Class
VisualComponents.Create3D Namespace


Contexts.Process Field

ContextsProcess Field

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Process = "Process"
public:
literal String^ Process = "Process"

Field Value

Type: String
See Also

Reference

Contexts Class
VisualComponents.Create3D Namespace


Contexts.Teach Field

ContextsTeach Field

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Teach = "Teach"
public:
literal String^ Teach = "Teach"

Field Value

Type: String
See Also

Reference

Contexts Class
VisualComponents.Create3D Namespace


ContextSection Class

Configuration file section for context dependent options.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationSection
VisualComponents.Create3DContextSection

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ContextSection : ConfigurationSection,
    IContextSection, ISection
public ref class ContextSection sealed : public ConfigurationSection,
    IContextSection, ISection

The ContextSection type exposes the following members.

Constructors
 | Name | Description
Public method | ContextSection | Contructor.
Top
Properties
 | Name | Description
Public property | ContextConfiguration | Collection of context.
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName | Section's name in configuration file.
Public property | SectionType | Interface type.
Public property | SectionVersion | Section's version number.
Top
Methods
 | Name | Description
Public method | CheckVersion | Upgrade configuration to the latest version.
Public method | Contains | Determines whether an element is in the BaseContextConfigElement.
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection | Finds typed section by name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserValue | Gets configuration file element for context option.
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ContextSection Constructor

Contructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ContextSection()
public:
ContextSection()
See Also

Reference

ContextSection Class
VisualComponents.Create3D Namespace


ContextSection Properties

The ContextSection type exposes the following members.

Properties
 | Name | Description
Public property | ContextConfiguration | Collection of context.
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName | Section's name in configuration file.
Public property | SectionType | Interface type.
Public property | SectionVersion | Section's version number.
Top
See Also

Reference

ContextSection Class
VisualComponents.Create3D Namespace


ContextSection.ContextConfiguration Property

ContextSectionContextConfiguration Property

Collection of context.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ContextConfigCollection ContextConfiguration { get; }
public:
virtual property ContextConfigCollection^ ContextConfiguration {
    ContextConfigCollection^ get () sealed;
}

Property Value

Type: ContextConfigCollection

Implements

IContextSectionContextConfiguration
See Also

Reference

ContextSection Class
VisualComponents.Create3D Namespace


ContextSection.SectionName Property

ContextSectionSectionName Property

Section's name in configuration file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SectionName { get; }
public:
virtual property String^ SectionName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ISectionSectionName
See Also

Reference

ContextSection Class
VisualComponents.Create3D Namespace


ContextSection.SectionType Property

ContextSectionSectionType Property

Interface type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type SectionType { get; }
public:
virtual property Type^ SectionType {
    Type^ get () sealed;
}

Property Value

Type: Type

Implements

ISectionSectionType
See Also

Reference

ContextSection Class
VisualComponents.Create3D Namespace


ContextSection.SectionVersion Property

ContextSectionSectionVersion Property

Section's version number.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int SectionVersion { get; }
public:
virtual property int SectionVersion {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISectionSectionVersion
See Also

Reference

ContextSection Class
VisualComponents.Create3D Namespace


ContextSection Methods

The ContextSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion | Upgrade configuration to the latest version.
Public method | Contains | Determines whether an element is in the BaseContextConfigElement.
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection | Finds typed section by name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserValue | Gets configuration file element for context option.
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ContextSection Class
VisualComponents.Create3D Namespace


ContextSection.CheckVersion Method

ContextSectionCheckVersion Method

Upgrade configuration to the latest version.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CheckVersion()
public:
virtual void CheckVersion() sealed

Implements

ISectionCheckVersion
See Also

Reference

ContextSection Class
VisualComponents.Create3D Namespace


ContextSection.Contains Method

ContextSectionContains Method

Determines whether an element is in the BaseContextConfigElement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Contains(
    string key
)
public:
virtual bool Contains(
    String^ key
) sealed

Parameters

key
Type: SystemString
Context key

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ContextSection.Contains(System.String)"]

Implements

IContextSectionContains(String)
See Also

Reference

ContextSection Class
VisualComponents.Create3D Namespace


ContextSection.GetSection Method

ContextSectionGetSection Method

Finds typed section by name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISection GetSection(
    Configuration userSettingConfiguration
)
public:
virtual ISection^ GetSection(
    Configuration^ userSettingConfiguration
) sealed

Parameters

userSettingConfiguration
Type: System.ConfigurationConfiguration
Configuration containing this section

Return Value

Type: ISection
Instance of DisplaySection

Implements

ISectionGetSection(Configuration)
See Also

Reference

ContextSection Class
VisualComponents.Create3D Namespace


ContextSection.GetUserValue Method

ContextSectionGetUserValue Method

Gets configuration file element for context option.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BaseContextConfigElement GetUserValue(
    string key
)
public:
virtual BaseContextConfigElement^ GetUserValue(
    String^ key
) sealed

Parameters

key
Type: SystemString

Return Value

Type: BaseContextConfigElement

[Missing <returns> documentation for "M:VisualComponents.Create3D.ContextSection.GetUserValue(System.String)"]

Implements

IContextSectionGetUserValue(String)
See Also

Reference

ContextSection Class
VisualComponents.Create3D Namespace


ContextSection.ToString Method

ContextSectionToString Method

Converts this instance to string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String
String representation of this instance
See Also

Reference

ContextSection Class
VisualComponents.Create3D Namespace


CoordinateSystem Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum CoordinateSystem
public enum class CoordinateSystem
Members
Member name | Value | Description
World | 0 |
Parent | 1 |
Object | 2 |
See Also

Reference

VisualComponents.Create3D Namespace


Creo Enumeration

Creo -> Pro/Engineer 19.0 to Creo 6.0

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum Creo
public enum class Creo
Members
Member name | Value | Description
WILDCARD_ASM | 0 |
WILDCARD_NEU | 1 |
WILDCARD_PRT | 2 |
WILDCARD_XAS | 3 |
WILDCARD_XPR | 4 |
See Also

Reference

VisualComponents.Create3D Namespace


CurrentTraceData Structure

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct CurrentTraceData
public value class CurrentTraceData

The CurrentTraceData type exposes the following members.

Constructors
 | Name | Description
Public method | CurrentTraceData(CurrentTraceData) | Constructs by setting the CurrentTraceData and copying other values from the source.
Public method | CurrentTraceData(Double, String, IListDouble, IListDouble, IListDouble, Matrix, Matrix, Matrix) | Initializes a new instance of the CurrentTraceData class
Top
Properties
 | Name | Description
Public property | CurrentStatement | Robot program statement during execution of which the data was collected
Public property | JointAcceleration | Joint acceleration values, set to true in traceConfig.xml to get updated values
Public property | JointPosition | Joint position values, set to true in traceConfig.xml to get updated values
Public property | JointVelocity | Joint velocity values, set to true in traceConfig.xml to get updated values
Public property | SimulationTimeStamp | Simulation time at which the data was collected
Public property | TcpAcceleration | TCP acceleration, set to true in traceConfig.xml to get updated values
Public property | TcpPosition | TCP position, set to true in traceConfig.xml to get updated values
Public property | TcpVelocity | TCP velocity, set to true in traceConfig.xml to get updated values
Top
Methods
 | Name | Description
Public method | Equals | (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Equality |
Inequality |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


CurrentTraceData Constructor

Overload List
 | Name | Description
Public method | CurrentTraceData(CurrentTraceData) | Constructs by setting the CurrentTraceData and copying other values from the source.
Public method | CurrentTraceData(Double, String, IListDouble, IListDouble, IListDouble, Matrix, Matrix, Matrix) | Initializes a new instance of the CurrentTraceData class
Top
See Also

Reference

CurrentTraceData Structure
VisualComponents.Create3D Namespace


CurrentTraceData Constructor (CurrentTraceData)

Constructs by setting the CurrentTraceData and copying other values from the source.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CurrentTraceData(
    CurrentTraceData other
)
public:
CurrentTraceData(
    CurrentTraceData other
)

Parameters

other
Type: VisualComponents.Create3DCurrentTraceData
See Also

Reference

CurrentTraceData Structure
CurrentTraceData Overload
VisualComponents.Create3D Namespace


CurrentTraceData Constructor (Double, String, IList(Double), IList(Double), IList(Double), Matrix, Matrix, Matrix)

CurrentTraceData Constructor (Double, String, IListDouble, IListDouble, IListDouble, Matrix, Matrix, Matrix)

Initializes a new instance of the CurrentTraceData class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CurrentTraceData(
    double simulationTimeStamp,
    string currentStatement,
    IList<double> jointPosition,
    IList<double> jointVelocity,
    IList<double> jointAcceleration,
    Matrix tcpPosition,
    Matrix tcpVelocity,
    Matrix tcpAcceleration
)
public:
CurrentTraceData(
    double simulationTimeStamp,
    String^ currentStatement,
    IList<double>^ jointPosition,
    IList<double>^ jointVelocity,
    IList<double>^ jointAcceleration,
    Matrix tcpPosition,
    Matrix tcpVelocity,
    Matrix tcpAcceleration
)

Parameters

simulationTimeStamp
Type: SystemDouble
currentStatement
Type: SystemString
jointPosition
Type: System.Collections.GenericIListDouble
jointVelocity
Type: System.Collections.GenericIListDouble
jointAcceleration
Type: System.Collections.GenericIListDouble
tcpPosition
Type: VisualComponents.Create3DMatrix
tcpVelocity
Type: VisualComponents.Create3DMatrix
tcpAcceleration
Type: VisualComponents.Create3DMatrix
See Also

Reference

CurrentTraceData Structure
CurrentTraceData Overload
VisualComponents.Create3D Namespace


CurrentTraceData Properties

The CurrentTraceData type exposes the following members.

Properties
 | Name | Description
Public property | CurrentStatement | Robot program statement during execution of which the data was collected
Public property | JointAcceleration | Joint acceleration values, set to true in traceConfig.xml to get updated values
Public property | JointPosition | Joint position values, set to true in traceConfig.xml to get updated values
Public property | JointVelocity | Joint velocity values, set to true in traceConfig.xml to get updated values
Public property | SimulationTimeStamp | Simulation time at which the data was collected
Public property | TcpAcceleration | TCP acceleration, set to true in traceConfig.xml to get updated values
Public property | TcpPosition | TCP position, set to true in traceConfig.xml to get updated values
Public property | TcpVelocity | TCP velocity, set to true in traceConfig.xml to get updated values
Top
See Also

Reference

CurrentTraceData Structure
VisualComponents.Create3D Namespace


CurrentTraceData.CurrentStatement Property

CurrentTraceDataCurrentStatement Property

Robot program statement during execution of which the data was collected

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CurrentStatement { get; }
public:
property String^ CurrentStatement {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

CurrentTraceData Structure
VisualComponents.Create3D Namespace


CurrentTraceData.JointAcceleration Property

CurrentTraceDataJointAcceleration Property

Joint acceleration values, set to true in traceConfig.xml to get updated values

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList<double> JointAcceleration { get; }
public:
property IList<double>^ JointAcceleration {
    IList<double>^ get ();
}

Property Value

Type: IListDouble
See Also

Reference

CurrentTraceData Structure
VisualComponents.Create3D Namespace


CurrentTraceData.JointPosition Property

CurrentTraceDataJointPosition Property

Joint position values, set to true in traceConfig.xml to get updated values

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList<double> JointPosition { get; }
public:
property IList<double>^ JointPosition {
    IList<double>^ get ();
}

Property Value

Type: IListDouble
See Also

Reference

CurrentTraceData Structure
VisualComponents.Create3D Namespace


CurrentTraceData.JointVelocity Property

CurrentTraceDataJointVelocity Property

Joint velocity values, set to true in traceConfig.xml to get updated values

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList<double> JointVelocity { get; }
public:
property IList<double>^ JointVelocity {
    IList<double>^ get ();
}

Property Value

Type: IListDouble
See Also

Reference

CurrentTraceData Structure
VisualComponents.Create3D Namespace


CurrentTraceData.SimulationTimeStamp Property

CurrentTraceDataSimulationTimeStamp Property

Simulation time at which the data was collected

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double SimulationTimeStamp { get; }
public:
property double SimulationTimeStamp {
    double get ();
}

Property Value

Type: Double
See Also

Reference

CurrentTraceData Structure
VisualComponents.Create3D Namespace


CurrentTraceData.TcpAcceleration Property

CurrentTraceDataTcpAcceleration Property

TCP acceleration, set to true in traceConfig.xml to get updated values

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Matrix TcpAcceleration { get; }
public:
property Matrix TcpAcceleration {
    Matrix get ();
}

Property Value

Type: Matrix
See Also

Reference

CurrentTraceData Structure
VisualComponents.Create3D Namespace


CurrentTraceData.TcpPosition Property

CurrentTraceDataTcpPosition Property

TCP position, set to true in traceConfig.xml to get updated values

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Matrix TcpPosition { get; }
public:
property Matrix TcpPosition {
    Matrix get ();
}

Property Value

Type: Matrix
See Also

Reference

CurrentTraceData Structure
VisualComponents.Create3D Namespace


CurrentTraceData.TcpVelocity Property

CurrentTraceDataTcpVelocity Property

TCP velocity, set to true in traceConfig.xml to get updated values

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Matrix TcpVelocity { get; }
public:
property Matrix TcpVelocity {
    Matrix get ();
}

Property Value

Type: Matrix
See Also

Reference

CurrentTraceData Structure
VisualComponents.Create3D Namespace


CurrentTraceData Methods

The CurrentTraceData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CurrentTraceData Structure
VisualComponents.Create3D Namespace


CurrentTraceData.Equals Method

CurrentTraceDataEquals Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.CurrentTraceData.Equals(System.Object)"]

See Also

Reference

CurrentTraceData Structure
VisualComponents.Create3D Namespace


CurrentTraceData.GetHashCode Method

CurrentTraceDataGetHashCode Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.CurrentTraceData.GetHashCode"]

See Also

Reference

CurrentTraceData Structure
VisualComponents.Create3D Namespace


CurrentTraceData Operators

The CurrentTraceData type exposes the following members.

Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

CurrentTraceData Structure
VisualComponents.Create3D Namespace


CurrentTraceData.Equality Operator

CurrentTraceDataEquality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    CurrentTraceData obj1,
    CurrentTraceData obj2
)
public:
static bool operator ==(
    CurrentTraceData obj1,
    CurrentTraceData obj2
)

Parameters

obj1
Type: VisualComponents.Create3DCurrentTraceData
obj2
Type: VisualComponents.Create3DCurrentTraceData

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.CurrentTraceData.op_Equality(VisualComponents.Create3D.CurrentTraceData,VisualComponents.Create3D.CurrentTraceData)"]

See Also

Reference

CurrentTraceData Structure
VisualComponents.Create3D Namespace


CurrentTraceData.Inequality Operator

CurrentTraceDataInequality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    CurrentTraceData obj1,
    CurrentTraceData obj2
)
public:
static bool operator !=(
    CurrentTraceData obj1,
    CurrentTraceData obj2
)

Parameters

obj1
Type: VisualComponents.Create3DCurrentTraceData
obj2
Type: VisualComponents.Create3DCurrentTraceData

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.CurrentTraceData.op_Inequality(VisualComponents.Create3D.CurrentTraceData,VisualComponents.Create3D.CurrentTraceData)"]

See Also

Reference

CurrentTraceData Structure
VisualComponents.Create3D Namespace


CurveBase Class

Base class for curves creation
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DCurveBase
VisualComponents.Create3DPolylineCurve
VisualComponents.Create3DSplineCurve

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract class CurveBase
public ref class CurveBase abstract

The CurveBase type exposes the following members.

Constructors
 | Name | Description
Protected method | CurveBase | Initializes a new instance of the CurveBase class
Top
Properties
 | Name | Description
Public property | ControlPoints |
Public property | CurveType |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


CurveBase Constructor

Initializes a new instance of the CurveBase class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected CurveBase()
protected:
CurveBase()
See Also

Reference

CurveBase Class
VisualComponents.Create3D Namespace


CurveBase Properties

The CurveBase type exposes the following members.

Properties
 | Name | Description
Public property | ControlPoints |
Public property | CurveType |
Top
See Also

Reference

CurveBase Class
VisualComponents.Create3D Namespace


CurveBase.ControlPoints Property

CurveBaseControlPoints Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract ReadOnlyCollection<Vector3> ControlPoints { get; }
public:
virtual property ReadOnlyCollection<Vector3>^ ControlPoints {
    ReadOnlyCollection<Vector3>^ get () abstract;
}

Property Value

Type: ReadOnlyCollectionVector3
See Also

Reference

CurveBase Class
VisualComponents.Create3D Namespace


CurveBase.CurveType Property

CurveBaseCurveType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract CurveType CurveType { get; }
public:
virtual property CurveType CurveType {
    CurveType get () abstract;
}

Property Value

Type: CurveType
See Also

Reference

CurveBase Class
VisualComponents.Create3D Namespace


CurveBase Methods

The CurveBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CurveBase Class
VisualComponents.Create3D Namespace


CurveLoop Class

This class contains information to create a loop
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DCurveLoop

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class CurveLoop
public ref class CurveLoop

The CurveLoop type exposes the following members.

Constructors
 | Name | Description
Public method | CurveLoop | Initializes a new instance of the CurveLoop class
Top
Properties
 | Name | Description
Public property | Curves |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


CurveLoop Constructor

Initializes a new instance of the CurveLoop class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CurveLoop(
    ICollection<CurveBase> curves
)
public:
CurveLoop(
    ICollection<CurveBase^>^ curves
)

Parameters

curves
Type: System.Collections.GenericICollectionCurveBase
See Also

Reference

CurveLoop Class
VisualComponents.Create3D Namespace


CurveLoop Properties

The CurveLoop type exposes the following members.

Properties
 | Name | Description
Public property | Curves |
Top
See Also

Reference

CurveLoop Class
VisualComponents.Create3D Namespace


CurveLoop.Curves Property

CurveLoopCurves Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<CurveBase> Curves { get; }
public:
property ReadOnlyCollection<CurveBase^>^ Curves {
    ReadOnlyCollection<CurveBase^>^ get ();
}

Property Value

Type: ReadOnlyCollectionCurveBase
See Also

Reference

CurveLoop Class
VisualComponents.Create3D Namespace


CurveLoop Methods

The CurveLoop type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CurveLoop Class
VisualComponents.Create3D Namespace


CurveType Enumeration

Curve type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum CurveType
public enum class CurveType
Members
Member name | Value | Description
Polyline | 0 | Polyline
Spline | 1 | Spline
Tessellated | 2 | Tessellated
See Also

Reference

VisualComponents.Create3D Namespace


CustomBehaviorBase Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DCustomBehaviorBase
VisualComponents.Create3DCustomExecutorBase

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract class CustomBehaviorBase : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed, ICustomBehavior
public ref class CustomBehaviorBase abstract : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed, ICustomBehavior

The CustomBehaviorBase type exposes the following members.

Constructors
 | Name | Description
Protected method | CustomBehaviorBase | Initializes a new instance of the CustomBehaviorBase class
Top
Properties
 | Name | Description
Public property | Application |
Public property | ChangeBatchLevel |
Public property | ContainerExpressionContext |
Public property | IsValid |
Public property | Name |
Public property | Node |
Public property | Pointer |
Public property | Properties |
Public property | PropertyNames |
Public property | PropertyNamesAndValues |
Public property | PropertyValues |
Public property | Type |
Top
Methods
 | Name | Description
Public method | Accept |
Public method | BeginChangeBatch |
Public method | ChangeNode |
Protected method | Construct |
Public method | CreateProperty(Type, PropertyConstraintType) |
Public method | CreateProperty(Type, PropertyConstraintType, String) |
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) |
Public method | DeleteProperty |
Public method | Destroy |
Public method | Dispose | Releases all resources used by the CustomBehaviorBase
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CustomBehaviorBase and optionally releases the managed resources
Public method | EndChangeBatch |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Evaluate |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperty |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnFinalize |
Protected method | OnInvalidate |
Public method | SetPropertyValues(IEnumerableObject) |
Public method | SetPropertyValues(IEnumerableTupleString, Object) |
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) |
Public method | SetPropertyValues(Int32, IEnumerableObject) |
Public method | SimulationContinued |
Public method | SimulationReset |
Public method | SimulationStarted |
Public method | SimulationStopped |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated |
Public event | PropertyContainerChanged |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


CustomBehaviorBase Constructor

Initializes a new instance of the CustomBehaviorBase class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected CustomBehaviorBase()
protected:
CustomBehaviorBase()
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase Properties

The CustomBehaviorBase type exposes the following members.

Properties
 | Name | Description
Public property | Application |
Public property | ChangeBatchLevel |
Public property | ContainerExpressionContext |
Public property | IsValid |
Public property | Name |
Public property | Node |
Public property | Pointer |
Public property | Properties |
Public property | PropertyNames |
Public property | PropertyNamesAndValues |
Public property | PropertyValues |
Public property | Type |
Top
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.Application Property

CustomBehaviorBaseApplication Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IApplication Application { get; }
public:
property IApplication^ Application {
    IApplication^ get ();
}

Property Value

Type: IApplication
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.ChangeBatchLevel Property

CustomBehaviorBaseChangeBatchLevel Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ChangeBatchLevel { get; }
public:
virtual property int ChangeBatchLevel {
    int get () sealed;
}

Property Value

Type: Int32

Implements

IBatchModeObjectChangeBatchLevel
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.ContainerExpressionContext Property

CustomBehaviorBaseContainerExpressionContext Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IExpressionContext ContainerExpressionContext { get; }
public:
virtual property IExpressionContext^ ContainerExpressionContext {
    IExpressionContext^ get () sealed;
}

Property Value

Type: IExpressionContext

Implements

IPropertyContainerContainerExpressionContext
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.IsValid Property

CustomBehaviorBaseIsValid Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsValid { get; }
public:
virtual property bool IsValid {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IWrapperIsValid
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.Name Property

CustomBehaviorBaseName Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; set; }
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INamedName
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.Node Property

CustomBehaviorBaseNode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimNode Node { get; }
public:
virtual property ISimNode^ Node {
    ISimNode^ get () sealed;
}

Property Value

Type: ISimNode

Implements

IBehaviorNode
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.Pointer Property

CustomBehaviorBasePointer Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IntPtr Pointer { get; }
public:
virtual property IntPtr Pointer {
    IntPtr get () sealed;
}

Property Value

Type: IntPtr

Implements

IWrapperPointer
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.Properties Property

CustomBehaviorBaseProperties Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList<IProperty> Properties { get; }
public:
virtual property IList<IProperty^>^ Properties {
    IList<IProperty^>^ get () sealed;
}

Property Value

Type: IListIProperty

Implements

IPropertyContainerProperties
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.PropertyNames Property

CustomBehaviorBasePropertyNames Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<string> PropertyNames { get; }
public:
virtual property IEnumerable<String^>^ PropertyNames {
    IEnumerable<String^>^ get () sealed;
}

Property Value

Type: IEnumerableString

Implements

IPropertyContainerPropertyNames
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.PropertyNamesAndValues Property

CustomBehaviorBasePropertyNamesAndValues Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<Tuple<string, Object>> PropertyNamesAndValues { get; }
public:
virtual property IEnumerable<Tuple<String^, Object^>^>^ PropertyNamesAndValues {
    IEnumerable<Tuple<String^, Object^>^>^ get () sealed;
}

Property Value

Type: IEnumerableTupleString, Object

Implements

IPropertyContainerPropertyNamesAndValues
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.PropertyValues Property

CustomBehaviorBasePropertyValues Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<Object> PropertyValues { get; }
public:
virtual property IEnumerable<Object^>^ PropertyValues {
    IEnumerable<Object^>^ get () sealed;
}

Property Value

Type: IEnumerableObject

Implements

IPropertyContainerPropertyValues
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.Type Property

CustomBehaviorBaseType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BehaviorType Type { get; }
public:
virtual property BehaviorType Type {
    BehaviorType get () sealed;
}

Property Value

Type: BehaviorType

Implements

IBehaviorType
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase Methods

The CustomBehaviorBase type exposes the following members.

Methods
 | Name | Description
Public method | Accept |
Public method | BeginChangeBatch |
Public method | ChangeNode |
Protected method | Construct |
Public method | CreateProperty(Type, PropertyConstraintType) |
Public method | CreateProperty(Type, PropertyConstraintType, String) |
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) |
Public method | DeleteProperty |
Public method | Destroy |
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | EndChangeBatch |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Evaluate |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperty |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnFinalize |
Protected method | OnInvalidate |
Public method | SetPropertyValues(IEnumerableObject) |
Public method | SetPropertyValues(IEnumerableTupleString, Object) |
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) |
Public method | SetPropertyValues(Int32, IEnumerableObject) |
Public method | SimulationContinued |
Public method | SimulationReset |
Public method | SimulationStarted |
Public method | SimulationStopped |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.Accept Method

CustomBehaviorBaseAccept Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Accept(
    VisitorBase visitor
)
public:
virtual void Accept(
    VisitorBase^ visitor
) sealed

Parameters

visitor
Type: VisualComponents.Create3DVisitorBase

Implements

IVisitableAccept(VisitorBase)
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.BeginChangeBatch Method

CustomBehaviorBaseBeginChangeBatch Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void BeginChangeBatch()
public:
virtual void BeginChangeBatch() sealed

Implements

IBatchModeObjectBeginChangeBatch
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.ChangeNode Method

CustomBehaviorBaseChangeNode Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ChangeNode(
    ISimNode newNode,
    IBehavior insertPosition,
    bool after
)
public:
virtual bool ChangeNode(
    ISimNode^ newNode,
    IBehavior^ insertPosition,
    bool after
) sealed

Parameters

newNode
Type: VisualComponents.Create3DISimNode
insertPosition
Type: VisualComponents.Create3DIBehavior
after
Type: SystemBoolean

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.CustomBehaviorBase.ChangeNode(VisualComponents.Create3D.ISimNode,VisualComponents.Create3D.IBehavior,System.Boolean)"]

Implements

IBehaviorChangeNode(ISimNode, IBehavior, Boolean)
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.Construct Method

CustomBehaviorBaseConstruct Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void Construct()
protected:
virtual void Construct()
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.CreateProperty Method

CustomBehaviorBaseCreateProperty Method

Overload List
 | Name | Description
Public method | CreateProperty(Type, PropertyConstraintType) |
Public method | CreateProperty(Type, PropertyConstraintType, String) |
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) |
Top
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.CreateProperty Method (Type, PropertyConstraintType)

CustomBehaviorBaseCreateProperty Method (Type, PropertyConstraintType)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty CreateProperty(
    Type valueType,
    PropertyConstraintType constraintType
)
public:
virtual IProperty^ CreateProperty(
    Type^ valueType,
    PropertyConstraintType constraintType
) sealed

Parameters

valueType
Type: SystemType
constraintType
Type: VisualComponents.Create3DPropertyConstraintType

Return Value

Type: IProperty

[Missing <returns> documentation for "M:VisualComponents.Create3D.CustomBehaviorBase.CreateProperty(System.Type,VisualComponents.Create3D.PropertyConstraintType)"]

Implements

IPropertyContainerCreateProperty(Type, PropertyConstraintType)
See Also

Reference

CustomBehaviorBase Class
CreateProperty Overload
VisualComponents.Create3D Namespace


CustomBehaviorBase.CreateProperty Method (Type, PropertyConstraintType, String)

CustomBehaviorBaseCreateProperty Method (Type, PropertyConstraintType, String)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty CreateProperty(
    Type valueType,
    PropertyConstraintType constraintType,
    string name
)
public:
virtual IProperty^ CreateProperty(
    Type^ valueType,
    PropertyConstraintType constraintType,
    String^ name
) sealed

Parameters

valueType
Type: SystemType
constraintType
Type: VisualComponents.Create3DPropertyConstraintType
name
Type: SystemString

Return Value

Type: IProperty

[Missing <returns> documentation for "M:VisualComponents.Create3D.CustomBehaviorBase.CreateProperty(System.Type,VisualComponents.Create3D.PropertyConstraintType,System.String)"]

Implements

IPropertyContainerCreateProperty(Type, PropertyConstraintType, String)
See Also

Reference

CustomBehaviorBase Class
CreateProperty Overload
VisualComponents.Create3D Namespace


CustomBehaviorBase.CreateProperty Method (Type, PropertyConstraintType, String, IProperty)

CustomBehaviorBaseCreateProperty Method (Type, PropertyConstraintType, String, IProperty)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty CreateProperty(
    Type valueType,
    PropertyConstraintType constraintType,
    string name,
    IProperty toBeReplaced
)
public:
virtual IProperty^ CreateProperty(
    Type^ valueType,
    PropertyConstraintType constraintType,
    String^ name,
    IProperty^ toBeReplaced
) sealed

Parameters

valueType
Type: SystemType
constraintType
Type: VisualComponents.Create3DPropertyConstraintType
name
Type: SystemString
toBeReplaced
Type: VisualComponents.Create3DIProperty

Return Value

Type: IProperty

[Missing <returns> documentation for "M:VisualComponents.Create3D.CustomBehaviorBase.CreateProperty(System.Type,VisualComponents.Create3D.PropertyConstraintType,System.String,VisualComponents.Create3D.IProperty)"]

Implements

IPropertyContainerCreateProperty(Type, PropertyConstraintType, String, IProperty)
See Also

Reference

CustomBehaviorBase Class
CreateProperty Overload
VisualComponents.Create3D Namespace


CustomBehaviorBase.DeleteProperty Method

CustomBehaviorBaseDeleteProperty Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void DeleteProperty(
    IProperty prop
)
public:
virtual void DeleteProperty(
    IProperty^ prop
) sealed

Parameters

prop
Type: VisualComponents.Create3DIProperty

Implements

IPropertyContainerDeleteProperty(IProperty)
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.Destroy Method

CustomBehaviorBaseDestroy Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Destroy()
public:
virtual void Destroy() sealed

Implements

IBehaviorDestroy
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.Dispose Method

CustomBehaviorBaseDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the CustomBehaviorBase
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CustomBehaviorBase and optionally releases the managed resources
Top
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.Dispose Method

CustomBehaviorBaseDispose Method

Releases all resources used by the CustomBehaviorBase

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Dispose()
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

CustomBehaviorBase Class
Dispose Overload
VisualComponents.Create3D Namespace


CustomBehaviorBase.Dispose Method (Boolean)

CustomBehaviorBaseDispose Method (Boolean)

Releases the unmanaged resources used by the CustomBehaviorBase and optionally releases the managed resources

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void Dispose(
    bool disposing
)
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

CustomBehaviorBase Class
Dispose Overload
VisualComponents.Create3D Namespace


CustomBehaviorBase.EndChangeBatch Method

CustomBehaviorBaseEndChangeBatch Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void EndChangeBatch()
public:
virtual void EndChangeBatch() sealed

Implements

IBatchModeObjectEndChangeBatch
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.Evaluate Method

CustomBehaviorBaseEvaluate Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Evaluate()
public:
virtual void Evaluate() sealed

Implements

IBehaviorEvaluate
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.GetProperty Method

CustomBehaviorBaseGetProperty Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty GetProperty(
    string name
)
public:
virtual IProperty^ GetProperty(
    String^ name
) sealed

Parameters

name
Type: SystemString

Return Value

Type: IProperty

[Missing <returns> documentation for "M:VisualComponents.Create3D.CustomBehaviorBase.GetProperty(System.String)"]

Implements

IPropertyContainerGetProperty(String)
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.OnFinalize Method

CustomBehaviorBaseOnFinalize Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void OnFinalize()
public:
virtual void OnFinalize()
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.OnInvalidate Method

CustomBehaviorBaseOnInvalidate Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void OnInvalidate()
protected:
virtual void OnInvalidate()
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.SetPropertyValues Method

CustomBehaviorBaseSetPropertyValues Method

Overload List
 | Name | Description
Public method | SetPropertyValues(IEnumerableObject) |
Public method | SetPropertyValues(IEnumerableTupleString, Object) |
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) |
Public method | SetPropertyValues(Int32, IEnumerableObject) |
Top
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.SetPropertyValues Method (IEnumerable(Object))

CustomBehaviorBaseSetPropertyValues Method (IEnumerableObject)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetPropertyValues(
    IEnumerable<Object> values
)
public:
virtual void SetPropertyValues(
    IEnumerable<Object^>^ values
) sealed

Parameters

values
Type: System.Collections.GenericIEnumerableObject

Implements

IPropertyContainerSetPropertyValues(IEnumerableObject)
See Also

Reference

CustomBehaviorBase Class
SetPropertyValues Overload
VisualComponents.Create3D Namespace


CustomBehaviorBase.SetPropertyValues Method (IEnumerable(Tuple(String, Object)))

CustomBehaviorBaseSetPropertyValues Method (IEnumerableTupleString, Object)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetPropertyValues(
    IEnumerable<Tuple<string, Object>> namesAndValues
)
public:
virtual void SetPropertyValues(
    IEnumerable<Tuple<String^, Object^>^>^ namesAndValues
) sealed

Parameters

namesAndValues
Type: System.Collections.GenericIEnumerableTupleString, Object

Implements

IPropertyContainerSetPropertyValues(IEnumerableTupleString, Object)
See Also

Reference

CustomBehaviorBase Class
SetPropertyValues Overload
VisualComponents.Create3D Namespace


CustomBehaviorBase.SetPropertyValues Method (IEnumerable(String), IEnumerable(Object))

CustomBehaviorBaseSetPropertyValues Method (IEnumerableString, IEnumerableObject)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetPropertyValues(
    IEnumerable<string> names,
    IEnumerable<Object> values
)
public:
virtual void SetPropertyValues(
    IEnumerable<String^>^ names,
    IEnumerable<Object^>^ values
) sealed

Parameters

names
Type: System.Collections.GenericIEnumerableString
values
Type: System.Collections.GenericIEnumerableObject

Implements

IPropertyContainerSetPropertyValues(IEnumerableString, IEnumerableObject)
See Also

Reference

CustomBehaviorBase Class
SetPropertyValues Overload
VisualComponents.Create3D Namespace


CustomBehaviorBase.SetPropertyValues Method (Int32, IEnumerable(Object))

CustomBehaviorBaseSetPropertyValues Method (Int32, IEnumerableObject)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetPropertyValues(
    int startIndex,
    IEnumerable<Object> values
)
public:
virtual void SetPropertyValues(
    int startIndex,
    IEnumerable<Object^>^ values
) sealed

Parameters

startIndex
Type: SystemInt32
values
Type: System.Collections.GenericIEnumerableObject

Implements

IPropertyContainerSetPropertyValues(Int32, IEnumerableObject)
See Also

Reference

CustomBehaviorBase Class
SetPropertyValues Overload
VisualComponents.Create3D Namespace


CustomBehaviorBase.SimulationContinued Method

CustomBehaviorBaseSimulationContinued Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void SimulationContinued()
public:
virtual void SimulationContinued()
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.SimulationReset Method

CustomBehaviorBaseSimulationReset Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void SimulationReset()
public:
virtual void SimulationReset()
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.SimulationStarted Method

CustomBehaviorBaseSimulationStarted Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void SimulationStarted()
public:
virtual void SimulationStarted()
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.SimulationStopped Method

CustomBehaviorBaseSimulationStopped Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void SimulationStopped()
public:
virtual void SimulationStopped()
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase Events

The CustomBehaviorBase type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated |
Public event | PropertyContainerChanged |
Top
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.ObjectInvalidated Event

CustomBehaviorBaseObjectInvalidated Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler ObjectInvalidated
public:
virtual  event EventHandler^ ObjectInvalidated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IWrapperObjectInvalidated
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorBase.PropertyContainerChanged Event

CustomBehaviorBasePropertyContainerChanged Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<PropertyContainerChangedEventArgs> PropertyContainerChanged
public:
virtual  event EventHandler<PropertyContainerChangedEventArgs^>^ PropertyContainerChanged {
    void add (EventHandler<PropertyContainerChangedEventArgs^>^ value);
    void remove (EventHandler<PropertyContainerChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerPropertyContainerChangedEventArgs

Implements

IPropertyContainerPropertyContainerChanged
See Also

Reference

CustomBehaviorBase Class
VisualComponents.Create3D Namespace


CustomBehaviorFactory Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DCustomBehaviorFactory

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class CustomBehaviorFactory
public ref class CustomBehaviorFactory abstract sealed

The CustomBehaviorFactory type exposes the following members.

Methods
Name | Description
CreateInstance |
Top
See Also

Reference

VisualComponents.Create3D Namespace


CustomBehaviorFactory Methods

The CustomBehaviorFactory type exposes the following members.

Methods
Name | Description
CreateInstance |
Top
See Also

Reference

CustomBehaviorFactory Class
VisualComponents.Create3D Namespace


CustomBehaviorFactory.CreateInstance Method

CustomBehaviorFactoryCreateInstance Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static CustomBehaviorBase CreateInstance(
    string apiType
)
public:
static CustomBehaviorBase^ CreateInstance(
    String^ apiType
)

Parameters

apiType
Type: SystemString

Return Value

Type: CustomBehaviorBase

[Missing <returns> documentation for "M:VisualComponents.Create3D.CustomBehaviorFactory.CreateInstance(System.String)"]

See Also

Reference

CustomBehaviorFactory Class
VisualComponents.Create3D Namespace


CustomExecutorBase Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DCustomBehaviorBase
VisualComponents.Create3DCustomExecutorBase

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract class CustomExecutorBase : CustomBehaviorBase
public ref class CustomExecutorBase abstract : public CustomBehaviorBase

The CustomExecutorBase type exposes the following members.

Constructors
 | Name | Description
Protected method | CustomExecutorBase | Initializes a new instance of the CustomExecutorBase class
Top
Properties
 | Name | Description
Public property | Application | (Inherited from CustomBehaviorBase.)
Public property | ChangeBatchLevel | (Inherited from CustomBehaviorBase.)
Public property | ContainerExpressionContext | (Inherited from CustomBehaviorBase.)
Public property | Controller |
Public property | DigitalInputSignals |
Public property | DigitalOutputSignals |
Public property | IsValid | (Inherited from CustomBehaviorBase.)
Public property | Name | (Inherited from CustomBehaviorBase.)
Public property | Node | (Inherited from CustomBehaviorBase.)
Public property | Pointer | (Inherited from CustomBehaviorBase.)
Public property | Properties | (Inherited from CustomBehaviorBase.)
Public property | PropertyNames | (Inherited from CustomBehaviorBase.)
Public property | PropertyNamesAndValues | (Inherited from CustomBehaviorBase.)
Public property | PropertyValues | (Inherited from CustomBehaviorBase.)
Public property | Type | (Inherited from CustomBehaviorBase.)
Top
Methods
 | Name | Description
Public method | Accept | (Inherited from CustomBehaviorBase.)
Public method | BeginChangeBatch | (Inherited from CustomBehaviorBase.)
Public method | ChangeNode | (Inherited from CustomBehaviorBase.)
Protected method | Construct | (Inherited from CustomBehaviorBase.)
Public method | CreateProperty(Type, PropertyConstraintType) | (Inherited from CustomBehaviorBase.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | (Inherited from CustomBehaviorBase.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from CustomBehaviorBase.)
Public method | DeleteProperty | (Inherited from CustomBehaviorBase.)
Public method | Destroy | (Inherited from CustomBehaviorBase.)
Public method | Dispose | (Inherited from CustomBehaviorBase.)
Protected method | Dispose(Boolean) | (Inherited from CustomBehaviorBase.)
Public method | EndChangeBatch | (Inherited from CustomBehaviorBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Evaluate | (Inherited from CustomBehaviorBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperty | (Inherited from CustomBehaviorBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnFinalize | (Inherited from CustomBehaviorBase.)
Protected method | OnInvalidate | (Inherited from CustomBehaviorBase.)
Protected method | RobotControllerChanged |
Public method | SetPropertyValues(IEnumerableObject) | (Inherited from CustomBehaviorBase.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | (Inherited from CustomBehaviorBase.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | (Inherited from CustomBehaviorBase.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | (Inherited from CustomBehaviorBase.)
Public method | SimulationContinued | (Inherited from CustomBehaviorBase.)
Public method | SimulationReset | (Inherited from CustomBehaviorBase.)
Public method | SimulationStarted | (Inherited from CustomBehaviorBase.)
Public method | SimulationStopped | (Inherited from CustomBehaviorBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from CustomBehaviorBase.)
Public event | PropertyContainerChanged | (Inherited from CustomBehaviorBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


CustomExecutorBase Constructor

Initializes a new instance of the CustomExecutorBase class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected CustomExecutorBase()
protected:
CustomExecutorBase()
See Also

Reference

CustomExecutorBase Class
VisualComponents.Create3D Namespace


CustomExecutorBase Properties

The CustomExecutorBase type exposes the following members.

Properties
 | Name | Description
Public property | Application | (Inherited from CustomBehaviorBase.)
Public property | ChangeBatchLevel | (Inherited from CustomBehaviorBase.)
Public property | ContainerExpressionContext | (Inherited from CustomBehaviorBase.)
Public property | Controller |
Public property | DigitalInputSignals |
Public property | DigitalOutputSignals |
Public property | IsValid | (Inherited from CustomBehaviorBase.)
Public property | Name | (Inherited from CustomBehaviorBase.)
Public property | Node | (Inherited from CustomBehaviorBase.)
Public property | Pointer | (Inherited from CustomBehaviorBase.)
Public property | Properties | (Inherited from CustomBehaviorBase.)
Public property | PropertyNames | (Inherited from CustomBehaviorBase.)
Public property | PropertyNamesAndValues | (Inherited from CustomBehaviorBase.)
Public property | PropertyValues | (Inherited from CustomBehaviorBase.)
Public property | Type | (Inherited from CustomBehaviorBase.)
Top
See Also

Reference

CustomExecutorBase Class
VisualComponents.Create3D Namespace


CustomExecutorBase.Controller Property

CustomExecutorBaseController Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IRrsRobotController Controller { get; set; }
public:
property IRrsRobotController^ Controller {
    IRrsRobotController^ get ();
    void set (IRrsRobotController^ value);
}

Property Value

Type: IRrsRobotController
See Also

Reference

CustomExecutorBase Class
VisualComponents.Create3D Namespace


CustomExecutorBase.DigitalInputSignals Property

CustomExecutorBaseDigitalInputSignals Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IBooleanSignalMap DigitalInputSignals { get; set; }
public:
property IBooleanSignalMap^ DigitalInputSignals {
    IBooleanSignalMap^ get ();
    void set (IBooleanSignalMap^ value);
}

Property Value

Type: IBooleanSignalMap
See Also

Reference

CustomExecutorBase Class
VisualComponents.Create3D Namespace


CustomExecutorBase.DigitalOutputSignals Property

CustomExecutorBaseDigitalOutputSignals Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IBooleanSignalMap DigitalOutputSignals { get; set; }
public:
property IBooleanSignalMap^ DigitalOutputSignals {
    IBooleanSignalMap^ get ();
    void set (IBooleanSignalMap^ value);
}

Property Value

Type: IBooleanSignalMap
See Also

Reference

CustomExecutorBase Class
VisualComponents.Create3D Namespace


CustomExecutorBase Methods

The CustomExecutorBase type exposes the following members.

Methods
 | Name | Description
Public method | Accept | (Inherited from CustomBehaviorBase.)
Public method | BeginChangeBatch | (Inherited from CustomBehaviorBase.)
Public method | ChangeNode | (Inherited from CustomBehaviorBase.)
Protected method | Construct | (Inherited from CustomBehaviorBase.)
Public method | CreateProperty(Type, PropertyConstraintType) | (Inherited from CustomBehaviorBase.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | (Inherited from CustomBehaviorBase.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from CustomBehaviorBase.)
Public method | DeleteProperty | (Inherited from CustomBehaviorBase.)
Public method | Destroy | (Inherited from CustomBehaviorBase.)
Public method | Dispose | (Inherited from CustomBehaviorBase.)
Protected method | Dispose(Boolean) | (Inherited from CustomBehaviorBase.)
Public method | EndChangeBatch | (Inherited from CustomBehaviorBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Evaluate | (Inherited from CustomBehaviorBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperty | (Inherited from CustomBehaviorBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnFinalize | (Inherited from CustomBehaviorBase.)
Protected method | OnInvalidate | (Inherited from CustomBehaviorBase.)
Protected method | RobotControllerChanged |
Public method | SetPropertyValues(IEnumerableObject) | (Inherited from CustomBehaviorBase.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | (Inherited from CustomBehaviorBase.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | (Inherited from CustomBehaviorBase.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | (Inherited from CustomBehaviorBase.)
Public method | SimulationContinued | (Inherited from CustomBehaviorBase.)
Public method | SimulationReset | (Inherited from CustomBehaviorBase.)
Public method | SimulationStarted | (Inherited from CustomBehaviorBase.)
Public method | SimulationStopped | (Inherited from CustomBehaviorBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CustomExecutorBase Class
VisualComponents.Create3D Namespace


CustomExecutorBase.RobotControllerChanged Method

CustomExecutorBaseRobotControllerChanged Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void RobotControllerChanged()
protected:
virtual void RobotControllerChanged()
See Also

Reference

CustomExecutorBase Class
VisualComponents.Create3D Namespace


CustomExecutorBase Events

The CustomExecutorBase type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from CustomBehaviorBase.)
Public event | PropertyContainerChanged | (Inherited from CustomBehaviorBase.)
Top
See Also

Reference

CustomExecutorBase Class
VisualComponents.Create3D Namespace


CustomPositionStatementBase Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DCustomStatementBase
VisualComponents.Create3DCustomPositionStatementBase

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract class CustomPositionStatementBase : CustomStatementBase,
    IPositionStatement, IStatement, INamed, IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, IApiType, ICloneable<IStatement>,
    ICloneable, IInterpolatable, IPositionFrameContainer
public ref class CustomPositionStatementBase abstract : public CustomStatementBase,
    IPositionStatement, IStatement, INamed, IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, IApiType, ICloneable<IStatement^>,
    ICloneable, IInterpolatable, IPositionFrameContainer

The CustomPositionStatementBase type exposes the following members.

Constructors
 | Name | Description
Protected method | CustomPositionStatementBase | Initializes a new instance of the CustomPositionStatementBase class
Top
Properties
 | Name | Description
Public property | ApiType | (Inherited from CustomStatementBase.)
Public property | Base |
Public property | ChangeBatchLevel | (Inherited from CustomStatementBase.)
Public property | ContainerExpressionContext | (Inherited from CustomStatementBase.)
Public property | ControlExecutedExEvent | (Inherited from CustomStatementBase.)
Public property | CustomStatement | (Inherited from CustomStatementBase.)
Public property | ExecutedCycleTime | (Inherited from CustomStatementBase.)
Public property | ExternalTcp |
Public property | IsExecuting | (Inherited from CustomStatementBase.)
Public property | IsLoop | (Inherited from CustomStatementBase.)
Public property | IsValid | (Inherited from CustomStatementBase.)
Public property | Name | (Inherited from CustomStatementBase.)
Public property | ParentScope | (Inherited from CustomStatementBase.)
Public property | Pointer | (Inherited from CustomStatementBase.)
Public property | Positions |
Public property | Properties | (Inherited from CustomStatementBase.)
Public property | PropertyNames | (Inherited from CustomStatementBase.)
Public property | PropertyNamesAndValues | (Inherited from CustomStatementBase.)
Public property | PropertyValues | (Inherited from CustomStatementBase.)
Public property | Routine | (Inherited from CustomStatementBase.)
Public property | Statement | (Inherited from CustomStatementBase.)
Public property | Tool |
Top
Methods
 | Name | Description
Public method | AddPositionFromProgram |
Public method | BeginChangeBatch | (Inherited from CustomStatementBase.)
Public method | ClearPositions |
Public method | Clone | (Inherited from CustomStatementBase.)
Public method | Clone(Boolean) | (Inherited from CustomStatementBase.)
Public method | CreatePosition |
Public method | CreateProperty(Type, PropertyConstraintType) | (Inherited from CustomStatementBase.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | (Inherited from CustomStatementBase.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from CustomStatementBase.)
Public method | DeletePosition |
Public method | DeleteProperty | (Inherited from CustomStatementBase.)
Public method | Dispose | (Inherited from CustomStatementBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CustomPositionStatementBase and optionally releases the managed resources (Overrides CustomStatementBaseDispose(Boolean).)
Public method | EndChangeBatch | (Inherited from CustomStatementBase.)
Public method | EndInterpolation |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | (Inherited from CustomStatementBase.)
Public method | ExecuteImmediate | (Inherited from CustomStatementBase.)
Public method | ExecuteImmediate(IExecutor) | (Inherited from CustomStatementBase.)
Public method | ExecuteImmediatePosition(IPositionFrame) |
Public method | ExecuteImmediatePosition(IExecutor, IPositionFrame) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperty | (Inherited from CustomStatementBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightAll |
Public method | Initialize(Boolean) | Called when the statement is ready to be constructed. This is called before the statement is added to the IRoutine. (Inherited from CustomStatementBase.)
Public method | Initialize(CustomStatementBase) | Called after the statement has been cloned. Additional initialization can be placed here. (Inherited from CustomStatementBase.)
Public method | Interpolate |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnAdd | (Inherited from CustomStatementBase.)
Public method | OnRemove | (Inherited from CustomStatementBase.)
Public method | OnReset | (Inherited from CustomStatementBase.)
Public method | ReadIn |
Public method | SetExternalTcp |
Public method | SetPropertyValues(IEnumerableObject) | (Inherited from CustomStatementBase.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | (Inherited from CustomStatementBase.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | (Inherited from CustomStatementBase.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | (Inherited from CustomStatementBase.)
Public method | SetStatement | (Overrides CustomStatementBaseSetStatement(IStatement).)
Public method | StartInterpolation |
Protected method | StatementInvalidated | (Overrides CustomStatementBaseStatementInvalidated.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Executed | (Inherited from CustomStatementBase.)
Public event | ExecutedEx | (Inherited from CustomStatementBase.)
Public event | Executing | (Inherited from CustomStatementBase.)
Public event | ExecutingEx | (Inherited from CustomStatementBase.)
Public event | ObjectInvalidated | (Inherited from CustomStatementBase.)
Public event | PositionAdded |
Public event | PositionRemoving |
Public event | PositionTransformationChanged |
Public event | PropertyContainerChanged | (Inherited from CustomStatementBase.)
Public event | Reset | (Inherited from CustomStatementBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


CustomPositionStatementBase Constructor

Initializes a new instance of the CustomPositionStatementBase class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected CustomPositionStatementBase()
protected:
CustomPositionStatementBase()
See Also

Reference

CustomPositionStatementBase Class
VisualComponents.Create3D Namespace


CustomPositionStatementBase Properties

The CustomPositionStatementBase type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from CustomStatementBase.)
Public property | Base |
Public property | ChangeBatchLevel | (Inherited from CustomStatementBase.)
Public property | ContainerExpressionContext | (Inherited from CustomStatementBase.)
Public property | ControlExecutedExEvent | (Inherited from CustomStatementBase.)
Public property | CustomStatement | (Inherited from CustomStatementBase.)
Public property | ExecutedCycleTime | (Inherited from CustomStatementBase.)
Public property | ExternalTcp |
Public property | IsExecuting | (Inherited from CustomStatementBase.)
Public property | IsLoop | (Inherited from CustomStatementBase.)
Public property | IsValid | (Inherited from CustomStatementBase.)
Public property | Name | (Inherited from CustomStatementBase.)
Public property | ParentScope | (Inherited from CustomStatementBase.)
Public property | Pointer | (Inherited from CustomStatementBase.)
Public property | Positions |
Public property | Properties | (Inherited from CustomStatementBase.)
Public property | PropertyNames | (Inherited from CustomStatementBase.)
Public property | PropertyNamesAndValues | (Inherited from CustomStatementBase.)
Public property | PropertyValues | (Inherited from CustomStatementBase.)
Public property | Routine | (Inherited from CustomStatementBase.)
Public property | Statement | (Inherited from CustomStatementBase.)
Public property | Tool |
Top
See Also

Reference

CustomPositionStatementBase Class
VisualComponents.Create3D Namespace


CustomPositionStatementBase.Base Property

CustomPositionStatementBaseBase Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IRobotFrame Base { get; set; }
public:
virtual property IRobotFrame^ Base {
    IRobotFrame^ get () sealed;
    void set (IRobotFrame^ value) sealed;
}

Property Value

Type: IRobotFrame

Implements

IPositionStatementBase
See Also

Reference

CustomPositionStatementBase Class
VisualComponents.Create3D Namespace


CustomPositionStatementBase.ExternalTcp Property

CustomPositionStatementBaseExternalTcp Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ExternalTcp { get; set; }
public:
virtual property bool ExternalTcp {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPositionStatementExternalTcp
See Also

Reference

CustomPositionStatementBase Class
VisualComponents.Create3D Namespace


CustomPositionStatementBase.Positions Property

CustomPositionStatementBasePositions Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<IPositionFrame> Positions { get; }
public:
virtual property ReadOnlyCollection<IPositionFrame^>^ Positions {
    ReadOnlyCollection<IPositionFrame^>^ get () sealed;
}

Property Value

Type: ReadOnlyCollectionIPositionFrame

Implements

IPositionFrameContainerPositions
See Also

Reference

CustomPositionStatementBase Class
VisualComponents.Create3D Namespace


CustomPositionStatementBase.Tool Property

CustomPositionStatementBaseTool Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IRobotFrame Tool { get; set; }
public:
virtual property IRobotFrame^ Tool {
    IRobotFrame^ get () sealed;
    void set (IRobotFrame^ value) sealed;
}

Property Value

Type: IRobotFrame

Implements

IPositionStatementTool
See Also

Reference

CustomPositionStatementBase Class
VisualComponents.Create3D Namespace


CustomPositionStatementBase Methods

The CustomPositionStatementBase type exposes the following members.

Methods
 | Name | Description
Public method | AddPositionFromProgram |
Public method | BeginChangeBatch | (Inherited from CustomStatementBase.)
Public method | ClearPositions |
Public method | Clone | (Inherited from CustomStatementBase.)
Public method | Clone(Boolean) | (Inherited from CustomStatementBase.)
Public method | CreatePosition |
Public method | CreateProperty(Type, PropertyConstraintType) | (Inherited from CustomStatementBase.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | (Inherited from CustomStatementBase.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from CustomStatementBase.)
Public method | DeletePosition |
Public method | DeleteProperty | (Inherited from CustomStatementBase.)
Public method | Dispose | (Inherited from CustomStatementBase.)
Protected method | Dispose(Boolean) | (Overrides CustomStatementBaseDispose(Boolean).)
Public method | EndChangeBatch | (Inherited from CustomStatementBase.)
Public method | EndInterpolation |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | (Inherited from CustomStatementBase.)
Public method | ExecuteImmediate | (Inherited from CustomStatementBase.)
Public method | ExecuteImmediate(IExecutor) | (Inherited from CustomStatementBase.)
Public method | ExecuteImmediatePosition(IPositionFrame) |
Public method | ExecuteImmediatePosition(IExecutor, IPositionFrame) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperty | (Inherited from CustomStatementBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightAll |
Public method | Initialize(Boolean) | Called when the statement is ready to be constructed. This is called before the statement is added to the IRoutine. (Inherited from CustomStatementBase.)
Public method | Initialize(CustomStatementBase) | Called after the statement has been cloned. Additional initialization can be placed here. (Inherited from CustomStatementBase.)
Public method | Interpolate |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnAdd | (Inherited from CustomStatementBase.)
Public method | OnRemove | (Inherited from CustomStatementBase.)
Public method | OnReset | (Inherited from CustomStatementBase.)
Public method | ReadIn |
Public method | SetExternalTcp |
Public method | SetPropertyValues(IEnumerableObject) | (Inherited from CustomStatementBase.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | (Inherited from CustomStatementBase.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | (Inherited from CustomStatementBase.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | (Inherited from CustomStatementBase.)
Public method | SetStatement | (Overrides CustomStatementBaseSetStatement(IStatement).)
Public method | StartInterpolation |
Protected method | StatementInvalidated | (Overrides CustomStatementBaseStatementInvalidated.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CustomPositionStatementBase Class
VisualComponents.Create3D Namespace


CustomPositionStatementBase.AddPositionFromProgram Method

CustomPositionStatementBaseAddPositionFromProgram Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void AddPositionFromProgram(
    IPositionFrame position
)
public:
virtual void AddPositionFromProgram(
    IPositionFrame^ position
) sealed

Parameters

position
Type: VisualComponents.Create3DIPositionFrame

Implements

IPositionStatementAddPositionFromProgram(IPositionFrame)
See Also

Reference

CustomPositionStatementBase Class
VisualComponents.Create3D Namespace


CustomPositionStatementBase.ClearPositions Method

CustomPositionStatementBaseClearPositions Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ClearPositions()
public:
virtual void ClearPositions() sealed

Implements

IPositionFrameContainerClearPositions
See Also

Reference

CustomPositionStatementBase Class
VisualComponents.Create3D Namespace


CustomPositionStatementBase.CreatePosition Method

CustomPositionStatementBaseCreatePosition Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IPositionFrame CreatePosition(
    string name
)
public:
virtual IPositionFrame^ CreatePosition(
    String^ name
) sealed

Parameters

name
Type: SystemString

Return Value

Type: IPositionFrame

[Missing <returns> documentation for "M:VisualComponents.Create3D.CustomPositionStatementBase.CreatePosition(System.String)"]

Implements

IPositionFrameContainerCreatePosition(String)
See Also

Reference

CustomPositionStatementBase Class
VisualComponents.Create3D Namespace


CustomPositionStatementBase.DeletePosition Method

CustomPositionStatementBaseDeletePosition Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void DeletePosition(
    IPositionFrame position
)
public:
virtual void DeletePosition(
    IPositionFrame^ position
) sealed

Parameters

position
Type: VisualComponents.Create3DIPositionFrame

Implements

IPositionFrameContainerDeletePosition(IPositionFrame)
See Also

Reference

CustomPositionStatementBase Class
VisualComponents.Create3D Namespace


CustomPositionStatementBase.Dispose Method

CustomPositionStatementBaseDispose Method

Overload List
 | Name | Description
Public method | Dispose | (Inherited from CustomStatementBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CustomPositionStatementBase and optionally releases the managed resources (Overrides CustomStatementBaseDispose(Boolean).)
Top
See Also

Reference

CustomPositionStatementBase Class
VisualComponents.Create3D Namespace


CustomPositionStatementBase.Dispose Method (Boolean)

CustomPositionStatementBaseDispose Method (Boolean)

Releases the unmanaged resources used by the CustomPositionStatementBase and optionally releases the managed resources

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void Dispose(
    bool disposing
)
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

CustomPositionStatementBase Class
Dispose Overload
VisualComponents.Create3D Namespace


CustomPositionStatementBase.EndInterpolation Method

CustomPositionStatementBaseEndInterpolation Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void EndInterpolation()
public:
virtual void EndInterpolation()

Implements

IInterpolatableEndInterpolation
See Also

Reference

CustomPositionStatementBase Class
VisualComponents.Create3D Namespace


CustomPositionStatementBase.ExecuteImmediatePosition Method

CustomPositionStatementBaseExecuteImmediatePosition Method

Overload List
 | Name | Description
Public method | ExecuteImmediatePosition(IPositionFrame) |
Public method | ExecuteImmediatePosition(IExecutor, IPositionFrame) |
Top
See Also

Reference

CustomPositionStatementBase Class
VisualComponents.Create3D Namespace


CustomPositionStatementBase.ExecuteImmediatePosition Method (IPositionFrame)

CustomPositionStatementBaseExecuteImmediatePosition Method (IPositionFrame)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void ExecuteImmediatePosition(
    IPositionFrame frame
)
public:
virtual void ExecuteImmediatePosition(
    IPositionFrame^ frame
)

Parameters

frame
Type: VisualComponents.Create3DIPositionFrame

Implements

IPositionStatementExecuteImmediatePosition(IPositionFrame)
See Also

Reference

CustomPositionStatementBase Class
ExecuteImmediatePosition Overload
VisualComponents.Create3D Namespace


CustomPositionStatementBase.ExecuteImmediatePosition Method (IExecutor, IPositionFrame)

CustomPositionStatementBaseExecuteImmediatePosition Method (IExecutor, IPositionFrame)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void ExecuteImmediatePosition(
    IExecutor executor,
    IPositionFrame position
)
public:
virtual void ExecuteImmediatePosition(
    IExecutor^ executor,
    IPositionFrame^ position
)

Parameters

executor
Type: VisualComponents.Create3DIExecutor
position
Type: VisualComponents.Create3DIPositionFrame
See Also

Reference

CustomPositionStatementBase Class
ExecuteImmediatePosition Overload
VisualComponents.Create3D Namespace


CustomPositionStatementBase.HighlightAll Method

CustomPositionStatementBaseHighlightAll Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void HighlightAll(
    bool value
)
public:
virtual void HighlightAll(
    bool value
) sealed

Parameters

value
Type: SystemBoolean

Implements

IPositionStatementHighlightAll(Boolean)
See Also

Reference

CustomPositionStatementBase Class
VisualComponents.Create3D Namespace


CustomPositionStatementBase.Interpolate Method

CustomPositionStatementBaseInterpolate Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void Interpolate(
    double length,
    ref IMotionTarget target
)
public:
virtual void Interpolate(
    double length,
    IMotionTarget^% target
)

Parameters

length
Type: SystemDouble
target
Type: VisualComponents.Create3DIMotionTarget

Implements

IInterpolatableInterpolate(Double, IMotionTarget)
See Also

Reference

CustomPositionStatementBase Class
VisualComponents.Create3D Namespace


CustomPositionStatementBase.ReadIn Method

CustomPositionStatementBaseReadIn Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ReadIn(
    IPositionFrame frame
)
public:
virtual void ReadIn(
    IPositionFrame^ frame
) sealed

Parameters

frame
Type: VisualComponents.Create3DIPositionFrame

Implements

IPositionStatementReadIn(IPositionFrame)
See Also

Reference

CustomPositionStatementBase Class
VisualComponents.Create3D Namespace


CustomPositionStatementBase.SetExternalTcp Method

CustomPositionStatementBaseSetExternalTcp Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetExternalTcp(
    bool value,
    bool keepWorldPosition
)
public:
virtual void SetExternalTcp(
    bool value,
    bool keepWorldPosition
) sealed

Parameters

value
Type: SystemBoolean
keepWorldPosition
Type: SystemBoolean

Implements

IPositionStatementSetExternalTcp(Boolean, Boolean)
See Also

Reference

CustomPositionStatementBase Class
VisualComponents.Create3D Namespace


CustomPositionStatementBase.SetStatement Method

CustomPositionStatementBaseSetStatement Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void SetStatement(
    IStatement statement
)
public:
virtual void SetStatement(
    IStatement^ statement
) override

Parameters

statement
Type: VisualComponents.Create3DIStatement

Implements

ICustomStatementSetStatement(IStatement)
See Also

Reference

CustomPositionStatementBase Class
VisualComponents.Create3D Namespace


CustomPositionStatementBase.StartInterpolation Method

CustomPositionStatementBaseStartInterpolation Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual double StartInterpolation(
    IMotionTarget from
)
public:
virtual double StartInterpolation(
    IMotionTarget^ from
)

Parameters

from
Type: VisualComponents.Create3DIMotionTarget

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.Create3D.CustomPositionStatementBase.StartInterpolation(VisualComponents.Create3D.IMotionTarget)"]

Implements

IInterpolatableStartInterpolation(IMotionTarget)
See Also

Reference

CustomPositionStatementBase Class
VisualComponents.Create3D Namespace


CustomPositionStatementBase.StatementInvalidated Method

CustomPositionStatementBaseStatementInvalidated Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void StatementInvalidated()
protected:
virtual void StatementInvalidated() override
See Also

Reference

CustomPositionStatementBase Class
VisualComponents.Create3D Namespace


CustomPositionStatementBase Events

The CustomPositionStatementBase type exposes the following members.

Events
 | Name | Description
Public event | Executed | (Inherited from CustomStatementBase.)
Public event | ExecutedEx | (Inherited from CustomStatementBase.)
Public event | Executing | (Inherited from CustomStatementBase.)
Public event | ExecutingEx | (Inherited from CustomStatementBase.)
Public event | ObjectInvalidated | (Inherited from CustomStatementBase.)
Public event | PositionAdded |
Public event | PositionRemoving |
Public event | PositionTransformationChanged |
Public event | PropertyContainerChanged | (Inherited from CustomStatementBase.)
Public event | Reset | (Inherited from CustomStatementBase.)
Top
See Also

Reference

CustomPositionStatementBase Class
VisualComponents.Create3D Namespace


CustomPositionStatementBase.PositionAdded Event

CustomPositionStatementBasePositionAdded Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<PositionFrameAddedEventArgs> PositionAdded
public:
virtual  event EventHandler<PositionFrameAddedEventArgs^>^ PositionAdded {
    void add (EventHandler<PositionFrameAddedEventArgs^>^ value);
    void remove (EventHandler<PositionFrameAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerPositionFrameAddedEventArgs

Implements

IPositionFrameContainerPositionAdded
See Also

Reference

CustomPositionStatementBase Class
VisualComponents.Create3D Namespace


CustomPositionStatementBase.PositionRemoving Event

CustomPositionStatementBasePositionRemoving Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<PositionFrameRemovingEventArgs> PositionRemoving
public:
virtual  event EventHandler<PositionFrameRemovingEventArgs^>^ PositionRemoving {
    void add (EventHandler<PositionFrameRemovingEventArgs^>^ value);
    void remove (EventHandler<PositionFrameRemovingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerPositionFrameRemovingEventArgs

Implements

IPositionFrameContainerPositionRemoving
See Also

Reference

CustomPositionStatementBase Class
VisualComponents.Create3D Namespace


CustomPositionStatementBase.PositionTransformationChanged Event

CustomPositionStatementBasePositionTransformationChanged Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<PositionFrameTransformationChangedEventArgs> PositionTransformationChanged
public:
virtual  event EventHandler<PositionFrameTransformationChangedEventArgs^>^ PositionTransformationChanged {
    void add (EventHandler<PositionFrameTransformationChangedEventArgs^>^ value);
    void remove (EventHandler<PositionFrameTransformationChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerPositionFrameTransformationChangedEventArgs

Implements

IPositionStatementPositionTransformationChanged
See Also

Reference

CustomPositionStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DCustomStatementBase
VisualComponents.Create3DCustomScopeStatementBase

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract class CustomScopeStatementBase : CustomStatementBase,
    ICustomScopeStatement, IStatementScope, IInterpolatable, IApiType
public ref class CustomScopeStatementBase abstract : public CustomStatementBase,
    ICustomScopeStatement, IStatementScope, IInterpolatable, IApiType

The CustomScopeStatementBase type exposes the following members.

Constructors
 | Name | Description
Protected method | CustomScopeStatementBase | Initializes a new instance of the CustomScopeStatementBase class
Top
Properties
 | Name | Description
Public property | ApiType |
Public property | ChangeBatchLevel | (Inherited from CustomStatementBase.)
Public property | ContainerExpressionContext | (Inherited from CustomStatementBase.)
Public property | ControlExecutedExEvent | (Inherited from CustomStatementBase.)
Public property | CustomStatement | (Inherited from CustomStatementBase.)
Public property | ExecutedCycleTime | (Inherited from CustomStatementBase.)
Public property | IsExecuting | (Inherited from CustomStatementBase.)
Public property | IsLoop |
Public property | IsValid | (Inherited from CustomStatementBase.)
Public property | Name | (Inherited from CustomStatementBase.)
Public property | ParentScope | (Inherited from CustomStatementBase.)
Public property | ParentStatement |
Public property | Pointer | (Inherited from CustomStatementBase.)
Public property | Properties | (Inherited from CustomStatementBase.)
Public property | PropertyNames | (Inherited from CustomStatementBase.)
Public property | PropertyNamesAndValues | (Inherited from CustomStatementBase.)
Public property | PropertyValues | (Inherited from CustomStatementBase.)
Public property | Routine | (Inherited from CustomStatementBase.)
Public property | ScopePtr |
Public property | Statement | (Inherited from CustomStatementBase.)
Public property | StatementCount |
Public property | Statements |
Top
Methods
 | Name | Description
Public method | AddStatement(Type, Boolean) |
Public method | AddStatement(IStatement, Boolean) |
Public method | AddStatementT |
Public method | AddStatementT(Int32) |
Public method | AddStatementBegin |
Public method | AddStatementEnd |
Public method | BeginChangeBatch | (Inherited from CustomStatementBase.)
Public method | Clear |
Public method | Clone | (Inherited from CustomStatementBase.)
Public method | Clone(Boolean) | (Inherited from CustomStatementBase.)
Public method | CreateProperty(Type, PropertyConstraintType) | (Inherited from CustomStatementBase.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | (Inherited from CustomStatementBase.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from CustomStatementBase.)
Public method | DeleteProperty | (Inherited from CustomStatementBase.)
Public method | DeleteStatement |
Public method | Dispose | (Inherited from CustomStatementBase.)
Protected method | Dispose(Boolean) | (Inherited from CustomStatementBase.)
Public method | EndChangeBatch | (Inherited from CustomStatementBase.)
Public method | EndInterpolation |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | (Overrides CustomStatementBaseExecute(IExecutor).)
Public method | ExecuteEnd |
Public method | ExecuteEndImmediate |
Public method | ExecuteImmediate | (Inherited from CustomStatementBase.)
Public method | ExecuteImmediate(IExecutor) | (Overrides CustomStatementBaseExecuteImmediate(IExecutor).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperty | (Inherited from CustomStatementBase.)
Public method | GetStatement |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize(Boolean) | Called when the statement is ready to be constructed. This is called before the statement is added to the IRoutine. (Inherited from CustomStatementBase.)
Public method | Initialize(CustomStatementBase) | Called after the statement has been cloned. Additional initialization can be placed here. (Inherited from CustomStatementBase.)
Public method | InsertStatement |
Public method | Interpolate |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveStatement |
Public method | OnAdd | (Inherited from CustomStatementBase.)
Public method | OnRemove | (Inherited from CustomStatementBase.)
Public method | OnReset | (Inherited from CustomStatementBase.)
Public method | SetPropertyValues(IEnumerableObject) | (Inherited from CustomStatementBase.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | (Inherited from CustomStatementBase.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | (Inherited from CustomStatementBase.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | (Inherited from CustomStatementBase.)
Public method | SetScope |
Public method | SetStatement | (Inherited from CustomStatementBase.)
Public method | StartInterpolation |
Protected method | StatementInvalidated | (Inherited from CustomStatementBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Executed | (Inherited from CustomStatementBase.)
Public event | ExecutedEx | (Inherited from CustomStatementBase.)
Public event | Executing | (Inherited from CustomStatementBase.)
Public event | ExecutingEx | (Inherited from CustomStatementBase.)
Public event | ObjectInvalidated | (Inherited from CustomStatementBase.)
Public event | PropertyContainerChanged | (Inherited from CustomStatementBase.)
Public event | Reset | (Inherited from CustomStatementBase.)
Public event | ScopeExecuted |
Public event | StatementAdded |
Public event | StatementMoved |
Public event | StatementRemoved |
Public event | StatementRemoving |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


CustomScopeStatementBase Constructor

Initializes a new instance of the CustomScopeStatementBase class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected CustomScopeStatementBase()
protected:
CustomScopeStatementBase()
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase Properties

The CustomScopeStatementBase type exposes the following members.

Properties
 | Name | Description
Public property | ApiType |
Public property | ChangeBatchLevel | (Inherited from CustomStatementBase.)
Public property | ContainerExpressionContext | (Inherited from CustomStatementBase.)
Public property | ControlExecutedExEvent | (Inherited from CustomStatementBase.)
Public property | CustomStatement | (Inherited from CustomStatementBase.)
Public property | ExecutedCycleTime | (Inherited from CustomStatementBase.)
Public property | IsExecuting | (Inherited from CustomStatementBase.)
Public property | IsLoop |
Public property | IsValid | (Inherited from CustomStatementBase.)
Public property | Name | (Inherited from CustomStatementBase.)
Public property | ParentScope | (Inherited from CustomStatementBase.)
Public property | ParentStatement |
Public property | Pointer | (Inherited from CustomStatementBase.)
Public property | Properties | (Inherited from CustomStatementBase.)
Public property | PropertyNames | (Inherited from CustomStatementBase.)
Public property | PropertyNamesAndValues | (Inherited from CustomStatementBase.)
Public property | PropertyValues | (Inherited from CustomStatementBase.)
Public property | Routine | (Inherited from CustomStatementBase.)
Public property | ScopePtr |
Public property | Statement | (Inherited from CustomStatementBase.)
Public property | StatementCount |
Public property | Statements |
Top
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase.ApiType Property

CustomScopeStatementBaseApiType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type ApiType { get; }
public:
virtual property Type^ ApiType {
    Type^ get () sealed;
}

Property Value

Type: Type

Implements

IApiTypeApiType
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase.IsLoop Property

CustomScopeStatementBaseIsLoop Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsLoop { get; set; }
public:
property bool IsLoop {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase.ParentStatement Property

CustomScopeStatementBaseParentStatement Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IStatement ParentStatement { get; }
public:
virtual property IStatement^ ParentStatement {
    IStatement^ get () sealed;
}

Property Value

Type: IStatement

Implements

IStatementScopeParentStatement
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase.ScopePtr Property

CustomScopeStatementBaseScopePtr Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IntPtr ScopePtr { get; }
public:
virtual property IntPtr ScopePtr {
    IntPtr get () sealed;
}

Property Value

Type: IntPtr
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase.StatementCount Property

CustomScopeStatementBaseStatementCount Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int StatementCount { get; }
public:
virtual property int StatementCount {
    int get () sealed;
}

Property Value

Type: Int32

Implements

IStatementScopeStatementCount
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase.Statements Property

CustomScopeStatementBaseStatements Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<IStatement> Statements { get; }
public:
virtual property ReadOnlyCollection<IStatement^>^ Statements {
    ReadOnlyCollection<IStatement^>^ get () sealed;
}

Property Value

Type: ReadOnlyCollectionIStatement

Implements

IStatementScopeStatements
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase Methods

The CustomScopeStatementBase type exposes the following members.

Methods
 | Name | Description
Public method | AddStatement(Type, Boolean) |
Public method | AddStatement(IStatement, Boolean) |
Public method | AddStatementT |
Public method | AddStatementT(Int32) |
Public method | AddStatementBegin |
Public method | AddStatementEnd |
Public method | BeginChangeBatch | (Inherited from CustomStatementBase.)
Public method | Clear |
Public method | Clone | (Inherited from CustomStatementBase.)
Public method | Clone(Boolean) | (Inherited from CustomStatementBase.)
Public method | CreateProperty(Type, PropertyConstraintType) | (Inherited from CustomStatementBase.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | (Inherited from CustomStatementBase.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from CustomStatementBase.)
Public method | DeleteProperty | (Inherited from CustomStatementBase.)
Public method | DeleteStatement |
Public method | Dispose | (Inherited from CustomStatementBase.)
Protected method | Dispose(Boolean) | (Inherited from CustomStatementBase.)
Public method | EndChangeBatch | (Inherited from CustomStatementBase.)
Public method | EndInterpolation |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | (Overrides CustomStatementBaseExecute(IExecutor).)
Public method | ExecuteEnd |
Public method | ExecuteEndImmediate |
Public method | ExecuteImmediate | (Inherited from CustomStatementBase.)
Public method | ExecuteImmediate(IExecutor) | (Overrides CustomStatementBaseExecuteImmediate(IExecutor).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperty | (Inherited from CustomStatementBase.)
Public method | GetStatement |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize(Boolean) | Called when the statement is ready to be constructed. This is called before the statement is added to the IRoutine. (Inherited from CustomStatementBase.)
Public method | Initialize(CustomStatementBase) | Called after the statement has been cloned. Additional initialization can be placed here. (Inherited from CustomStatementBase.)
Public method | InsertStatement |
Public method | Interpolate |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveStatement |
Public method | OnAdd | (Inherited from CustomStatementBase.)
Public method | OnRemove | (Inherited from CustomStatementBase.)
Public method | OnReset | (Inherited from CustomStatementBase.)
Public method | SetPropertyValues(IEnumerableObject) | (Inherited from CustomStatementBase.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | (Inherited from CustomStatementBase.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | (Inherited from CustomStatementBase.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | (Inherited from CustomStatementBase.)
Public method | SetScope |
Public method | SetStatement | (Inherited from CustomStatementBase.)
Public method | StartInterpolation |
Protected method | StatementInvalidated | (Inherited from CustomStatementBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase.AddStatement Method

CustomScopeStatementBaseAddStatement Method

Overload List
 | Name | Description
Public method | AddStatementT |
Public method | AddStatementT(Int32) |
Public method | AddStatement(Type, Boolean) |
Public method | AddStatement(IStatement, Boolean) |
Top
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase.AddStatement(T) Method

CustomScopeStatementBaseAddStatementT Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public T AddStatement<T>()
where T : IStatement

public:
generic<typename T>
where T : IStatement
virtual T AddStatement() sealed

Type Parameters

T

Return Value

Type: T

[Missing <returns> documentation for "M:VisualComponents.Create3D.CustomScopeStatementBase.AddStatement``1"]

See Also

Reference

CustomScopeStatementBase Class
AddStatement Overload
VisualComponents.Create3D Namespace


CustomScopeStatementBase.AddStatement(T) Method (Int32)

CustomScopeStatementBaseAddStatementT Method (Int32)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public T AddStatement<T>(
    int index
)
where T : IStatement

public:
generic<typename T>
where T : IStatement
virtual T AddStatement(
    int index
) sealed

Parameters

index
Type: SystemInt32

Type Parameters

T

Return Value

Type: T

[Missing <returns> documentation for "M:VisualComponents.Create3D.CustomScopeStatementBase.AddStatement``1(System.Int32)"]

See Also

Reference

CustomScopeStatementBase Class
AddStatement Overload
VisualComponents.Create3D Namespace


CustomScopeStatementBase.AddStatement Method (Type, Boolean)

CustomScopeStatementBaseAddStatement Method (Type, Boolean)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IStatement AddStatement(
    Type typeOfStatement,
    bool isRestored
)
public:
virtual IStatement^ AddStatement(
    Type^ typeOfStatement,
    bool isRestored
) sealed

Parameters

typeOfStatement
Type: SystemType
isRestored
Type: SystemBoolean

Return Value

Type: IStatement

[Missing <returns> documentation for "M:VisualComponents.Create3D.CustomScopeStatementBase.AddStatement(System.Type,System.Boolean)"]

See Also

Reference

CustomScopeStatementBase Class
AddStatement Overload
VisualComponents.Create3D Namespace


CustomScopeStatementBase.AddStatement Method (IStatement, Boolean)

CustomScopeStatementBaseAddStatement Method (IStatement, Boolean)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IStatement AddStatement(
    IStatement basedOn,
    bool cloneContent
)
public:
virtual IStatement^ AddStatement(
    IStatement^ basedOn,
    bool cloneContent
) sealed

Parameters

basedOn
Type: VisualComponents.Create3DIStatement
cloneContent
Type: SystemBoolean

Return Value

Type: IStatement

[Missing <returns> documentation for "M:VisualComponents.Create3D.CustomScopeStatementBase.AddStatement(VisualComponents.Create3D.IStatement,System.Boolean)"]

See Also

Reference

CustomScopeStatementBase Class
AddStatement Overload
VisualComponents.Create3D Namespace


CustomScopeStatementBase.AddStatementBegin Method

CustomScopeStatementBaseAddStatementBegin Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IStatement AddStatementBegin(
    Type typeOfStatement
)
public:
virtual IStatement^ AddStatementBegin(
    Type^ typeOfStatement
) sealed

Parameters

typeOfStatement
Type: SystemType

Return Value

Type: IStatement

[Missing <returns> documentation for "M:VisualComponents.Create3D.CustomScopeStatementBase.AddStatementBegin(System.Type)"]

See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase.AddStatementEnd Method

CustomScopeStatementBaseAddStatementEnd Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void AddStatementEnd(
    IStatement statement
)
public:
virtual void AddStatementEnd(
    IStatement^ statement
) sealed

Parameters

statement
Type: VisualComponents.Create3DIStatement
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase.Clear Method

CustomScopeStatementBaseClear Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Clear()
public:
virtual void Clear() sealed

Implements

IStatementScopeClear
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase.DeleteStatement Method

CustomScopeStatementBaseDeleteStatement Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void DeleteStatement(
    IStatement statement
)
public:
virtual void DeleteStatement(
    IStatement^ statement
) sealed

Parameters

statement
Type: VisualComponents.Create3DIStatement

Implements

IStatementScopeDeleteStatement(IStatement)
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase.EndInterpolation Method

CustomScopeStatementBaseEndInterpolation Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void EndInterpolation()
public:
virtual void EndInterpolation()

Implements

IInterpolatableEndInterpolation
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase.Execute Method

CustomScopeStatementBaseExecute Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Execute(
    IExecutor executor
)
public:
virtual void Execute(
    IExecutor^ executor
) override

Parameters

executor
Type: VisualComponents.Create3DIExecutor
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase.ExecuteEnd Method

CustomScopeStatementBaseExecuteEnd Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void ExecuteEnd(
    IExecutor executor
)
public:
virtual void ExecuteEnd(
    IExecutor^ executor
)

Parameters

executor
Type: VisualComponents.Create3DIExecutor
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase.ExecuteEndImmediate Method

CustomScopeStatementBaseExecuteEndImmediate Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void ExecuteEndImmediate(
    IExecutor executor
)
public:
virtual void ExecuteEndImmediate(
    IExecutor^ executor
)

Parameters

executor
Type: VisualComponents.Create3DIExecutor
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase.ExecuteImmediate Method

CustomScopeStatementBaseExecuteImmediate Method

Overload List
 | Name | Description
Public method | ExecuteImmediate | (Inherited from CustomStatementBase.)
Public method | ExecuteImmediate(IExecutor) | (Overrides CustomStatementBaseExecuteImmediate(IExecutor).)
Top
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase.ExecuteImmediate Method (IExecutor)

CustomScopeStatementBaseExecuteImmediate Method (IExecutor)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void ExecuteImmediate(
    IExecutor executor
)
public:
virtual void ExecuteImmediate(
    IExecutor^ executor
) override

Parameters

executor
Type: VisualComponents.Create3DIExecutor
See Also

Reference

CustomScopeStatementBase Class
ExecuteImmediate Overload
VisualComponents.Create3D Namespace


CustomScopeStatementBase.GetStatement Method

CustomScopeStatementBaseGetStatement Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IStatement GetStatement(
    int index
)
public:
virtual IStatement^ GetStatement(
    int index
) sealed

Parameters

index
Type: SystemInt32

Return Value

Type: IStatement

[Missing <returns> documentation for "M:VisualComponents.Create3D.CustomScopeStatementBase.GetStatement(System.Int32)"]

Implements

IStatementScopeGetStatement(Int32)
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase.InsertStatement Method

CustomScopeStatementBaseInsertStatement Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InsertStatement(
    IStatement statement,
    int index
)
public:
virtual void InsertStatement(
    IStatement^ statement,
    int index
) sealed

Parameters

statement
Type: VisualComponents.Create3DIStatement
index
Type: SystemInt32

Implements

IStatementScopeInsertStatement(IStatement, Int32)
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase.Interpolate Method

CustomScopeStatementBaseInterpolate Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void Interpolate(
    double length,
    ref IMotionTarget target
)
public:
virtual void Interpolate(
    double length,
    IMotionTarget^% target
)

Parameters

length
Type: SystemDouble
target
Type: VisualComponents.Create3DIMotionTarget

Implements

IInterpolatableInterpolate(Double, IMotionTarget)
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase.MoveStatement Method

CustomScopeStatementBaseMoveStatement Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MoveStatement(
    IStatement statement,
    int index
)
public:
virtual void MoveStatement(
    IStatement^ statement,
    int index
) sealed

Parameters

statement
Type: VisualComponents.Create3DIStatement
index
Type: SystemInt32

Implements

IStatementScopeMoveStatement(IStatement, Int32)
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase.SetScope Method

CustomScopeStatementBaseSetScope Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetScope(
    ICustomScopeStatement scope
)
public:
void SetScope(
    ICustomScopeStatement^ scope
)

Parameters

scope
Type: VisualComponents.Create3DICustomScopeStatement
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase.StartInterpolation Method

CustomScopeStatementBaseStartInterpolation Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual double StartInterpolation(
    IMotionTarget from
)
public:
virtual double StartInterpolation(
    IMotionTarget^ from
)

Parameters

from
Type: VisualComponents.Create3DIMotionTarget

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.Create3D.CustomScopeStatementBase.StartInterpolation(VisualComponents.Create3D.IMotionTarget)"]

Implements

IInterpolatableStartInterpolation(IMotionTarget)
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase Events

The CustomScopeStatementBase type exposes the following members.

Events
 | Name | Description
Public event | Executed | (Inherited from CustomStatementBase.)
Public event | ExecutedEx | (Inherited from CustomStatementBase.)
Public event | Executing | (Inherited from CustomStatementBase.)
Public event | ExecutingEx | (Inherited from CustomStatementBase.)
Public event | ObjectInvalidated | (Inherited from CustomStatementBase.)
Public event | PropertyContainerChanged | (Inherited from CustomStatementBase.)
Public event | Reset | (Inherited from CustomStatementBase.)
Public event | ScopeExecuted |
Public event | StatementAdded |
Public event | StatementMoved |
Public event | StatementRemoved |
Public event | StatementRemoving |
Top
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase.ScopeExecuted Event

CustomScopeStatementBaseScopeExecuted Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ScopeExecutedEventArgs> ScopeExecuted
public:
virtual  event EventHandler<ScopeExecutedEventArgs^>^ ScopeExecuted {
    void add (EventHandler<ScopeExecutedEventArgs^>^ value);
    void remove (EventHandler<ScopeExecutedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerScopeExecutedEventArgs

Implements

IStatementScopeScopeExecuted
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase.StatementAdded Event

CustomScopeStatementBaseStatementAdded Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<StatementAddedEventArgs> StatementAdded
public:
virtual  event EventHandler<StatementAddedEventArgs^>^ StatementAdded {
    void add (EventHandler<StatementAddedEventArgs^>^ value);
    void remove (EventHandler<StatementAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerStatementAddedEventArgs

Implements

IStatementScopeStatementAdded
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase.StatementMoved Event

CustomScopeStatementBaseStatementMoved Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<StatementMovedEventArgs> StatementMoved
public:
virtual  event EventHandler<StatementMovedEventArgs^>^ StatementMoved {
    void add (EventHandler<StatementMovedEventArgs^>^ value);
    void remove (EventHandler<StatementMovedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerStatementMovedEventArgs

Implements

IStatementScopeStatementMoved
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase.StatementRemoved Event

CustomScopeStatementBaseStatementRemoved Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<StatementRemovedEventArgs> StatementRemoved
public:
virtual  event EventHandler<StatementRemovedEventArgs^>^ StatementRemoved {
    void add (EventHandler<StatementRemovedEventArgs^>^ value);
    void remove (EventHandler<StatementRemovedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerStatementRemovedEventArgs

Implements

IStatementScopeStatementRemoved
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomScopeStatementBase.StatementRemoving Event

CustomScopeStatementBaseStatementRemoving Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<StatementRemovingEventArgs> StatementRemoving
public:
virtual  event EventHandler<StatementRemovingEventArgs^>^ StatementRemoving {
    void add (EventHandler<StatementRemovingEventArgs^>^ value);
    void remove (EventHandler<StatementRemovingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerStatementRemovingEventArgs

Implements

IStatementScopeStatementRemoving
See Also

Reference

CustomScopeStatementBase Class
VisualComponents.Create3D Namespace


CustomSimulationUpdateEventArgs Class

CustomSimulationUpdate event args
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DCustomSimulationUpdateEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class CustomSimulationUpdateEventArgs : EventArgs
public ref class CustomSimulationUpdateEventArgs : public EventArgs

The CustomSimulationUpdateEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CustomSimulationUpdateEventArgs | Constructor
Top
Properties
 | Name | Description
Public property | Time | CustomSimulationUpdate interval
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


CustomSimulationUpdateEventArgs Constructor

Constructor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CustomSimulationUpdateEventArgs(
    double time
)
public:
CustomSimulationUpdateEventArgs(
    double time
)

Parameters

time
Type: SystemDouble
CustomSimulationUpdate interval
See Also

Reference

CustomSimulationUpdateEventArgs Class
VisualComponents.Create3D Namespace


CustomSimulationUpdateEventArgs Properties

The CustomSimulationUpdateEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Time | CustomSimulationUpdate interval
Top
See Also

Reference

CustomSimulationUpdateEventArgs Class
VisualComponents.Create3D Namespace


CustomSimulationUpdateEventArgs.Time Property

CustomSimulationUpdateEventArgsTime Property

CustomSimulationUpdate interval

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Time { get; }
public:
property double Time {
    double get ();
}

Property Value

Type: Double
See Also

Reference

CustomSimulationUpdateEventArgs Class
VisualComponents.Create3D Namespace


CustomSimulationUpdateEventArgs Methods

The CustomSimulationUpdateEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CustomSimulationUpdateEventArgs Class
VisualComponents.Create3D Namespace


CustomSimulationUpdateType Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum CustomSimulationUpdateType
public enum class CustomSimulationUpdateType
Members
Member name | Value | Description
ComponentUpdate | 0 | A CustomSimulationUpdate event is triggered on any component update, or at the specified time. Note: This kind of updates is limited to moving the robot and scheduling next statement execution. You cannot, for example, change ISignalMap signals.
Timed | 1 | CustomSimulationUpdate event is triggered at the specified time.
See Also

Reference

VisualComponents.Create3D Namespace


CustomSnapInfo Class

Class used in SnapResult to add extra information about snap result. Populated by ICustomSnapper implementors.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DCustomSnapInfo

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class CustomSnapInfo
public ref class CustomSnapInfo

The CustomSnapInfo type exposes the following members.

Constructors
 | Name | Description
Public method | CustomSnapInfo(ICustomSnapper, String) | Initializes a new instance of the CustomSnapInfo class
Public method | CustomSnapInfo(ICustomSnapper, String, NullableInt32, NullableMatrix, Double, Double, NullableVector3) | Initializes a new instance of the CustomSnapInfo class
Top
Properties
 | Name | Description
Public property | AlignAxis |
Public property | CustomSnapper |
Public property | Description |
Public property | GeometryIndex |
Public property | GeometryOpacity |
Public property | GeometryPivot |
Public property | GeometryScale |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


CustomSnapInfo Constructor

Overload List
 | Name | Description
Public method | CustomSnapInfo(ICustomSnapper, String) | Initializes a new instance of the CustomSnapInfo class
Public method | CustomSnapInfo(ICustomSnapper, String, NullableInt32, NullableMatrix, Double, Double, NullableVector3) | Initializes a new instance of the CustomSnapInfo class
Top
See Also

Reference

CustomSnapInfo Class
VisualComponents.Create3D Namespace


CustomSnapInfo Constructor (ICustomSnapper, String)

Initializes a new instance of the CustomSnapInfo class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CustomSnapInfo(
    ICustomSnapper customSnapper,
    string description
)
public:
CustomSnapInfo(
    ICustomSnapper^ customSnapper,
    String^ description
)

Parameters

customSnapper
Type: VisualComponents.Create3DICustomSnapper
description
Type: SystemString
See Also

Reference

CustomSnapInfo Class
CustomSnapInfo Overload
VisualComponents.Create3D Namespace


CustomSnapInfo Constructor (ICustomSnapper, String, Nullable(Int32), Nullable(Matrix), Double, Double, Nullable(Vector3))

CustomSnapInfo Constructor (ICustomSnapper, String, NullableInt32, NullableMatrix, Double, Double, NullableVector3)

Initializes a new instance of the CustomSnapInfo class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CustomSnapInfo(
    ICustomSnapper customSnapper,
    string description,
    Nullable<int> geometryIndex,
    Nullable<Matrix> geometryPivot,
    double geometryScale,
    double geometryOpacity,
    Nullable<Vector3> alignAxis
)
public:
CustomSnapInfo(
    ICustomSnapper^ customSnapper,
    String^ description,
    Nullable<int> geometryIndex,
    Nullable<Matrix> geometryPivot,
    double geometryScale,
    double geometryOpacity,
    Nullable<Vector3> alignAxis
)

Parameters

customSnapper
Type: VisualComponents.Create3DICustomSnapper
description
Type: SystemString
geometryIndex
Type: SystemNullableInt32
geometryPivot
Type: SystemNullableMatrix
geometryScale
Type: SystemDouble
geometryOpacity
Type: SystemDouble
alignAxis
Type: SystemNullableVector3
See Also

Reference

CustomSnapInfo Class
CustomSnapInfo Overload
VisualComponents.Create3D Namespace


CustomSnapInfo Properties

The CustomSnapInfo type exposes the following members.

Properties
 | Name | Description
Public property | AlignAxis |
Public property | CustomSnapper |
Public property | Description |
Public property | GeometryIndex |
Public property | GeometryOpacity |
Public property | GeometryPivot |
Public property | GeometryScale |
Top
See Also

Reference

CustomSnapInfo Class
VisualComponents.Create3D Namespace


CustomSnapInfo.AlignAxis Property

CustomSnapInfoAlignAxis Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<Vector3> AlignAxis { get; set; }
public:
property Nullable<Vector3> AlignAxis {
    Nullable<Vector3> get ();
    void set (Nullable<Vector3> value);
}

Property Value

Type: NullableVector3
See Also

Reference

CustomSnapInfo Class
VisualComponents.Create3D Namespace


CustomSnapInfo.CustomSnapper Property

CustomSnapInfoCustomSnapper Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ICustomSnapper CustomSnapper { get; set; }
public:
property ICustomSnapper^ CustomSnapper {
    ICustomSnapper^ get ();
    void set (ICustomSnapper^ value);
}

Property Value

Type: ICustomSnapper
See Also

Reference

CustomSnapInfo Class
VisualComponents.Create3D Namespace


CustomSnapInfo.Description Property

CustomSnapInfoDescription Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; set; }
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

CustomSnapInfo Class
VisualComponents.Create3D Namespace


CustomSnapInfo.GeometryIndex Property

CustomSnapInfoGeometryIndex Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<int> GeometryIndex { get; set; }
public:
property Nullable<int> GeometryIndex {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Property Value

Type: NullableInt32
See Also

Reference

CustomSnapInfo Class
VisualComponents.Create3D Namespace


CustomSnapInfo.GeometryOpacity Property

CustomSnapInfoGeometryOpacity Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double GeometryOpacity { get; set; }
public:
property double GeometryOpacity {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

CustomSnapInfo Class
VisualComponents.Create3D Namespace


CustomSnapInfo.GeometryPivot Property

CustomSnapInfoGeometryPivot Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<Matrix> GeometryPivot { get; set; }
public:
property Nullable<Matrix> GeometryPivot {
    Nullable<Matrix> get ();
    void set (Nullable<Matrix> value);
}

Property Value

Type: NullableMatrix
See Also

Reference

CustomSnapInfo Class
VisualComponents.Create3D Namespace


CustomSnapInfo.GeometryScale Property

CustomSnapInfoGeometryScale Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double GeometryScale { get; set; }
public:
property double GeometryScale {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

CustomSnapInfo Class
VisualComponents.Create3D Namespace


CustomSnapInfo Methods

The CustomSnapInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CustomSnapInfo Class
VisualComponents.Create3D Namespace


CustomStatementBase Class

Base statement class, custom statements should derive from this
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DCustomStatementBase
VisualComponents.Create3DCustomPositionStatementBase
VisualComponents.Create3DCustomScopeStatementBase
VisualComponents.UX.SharedSchemaPathStatement

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract class CustomStatementBase : ICustomStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement>, ICloneable
public ref class CustomStatementBase abstract : ICustomStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement^>, ICloneable

The CustomStatementBase type exposes the following members.

Constructors
 | Name | Description
Protected method | CustomStatementBase | Initializes a new instance of the CustomStatementBase class
Top
Properties
 | Name | Description
Public property | ApiType |
Public property | ChangeBatchLevel |
Public property | ContainerExpressionContext |
Public property | ControlExecutedExEvent |
Public property | CustomStatement |
Public property | ExecutedCycleTime |
Public property | IsExecuting |
Public property | IsLoop |
Public property | IsValid |
Public property | Name |
Public property | ParentScope |
Public property | Pointer |
Public property | Properties |
Public property | PropertyNames |
Public property | PropertyNamesAndValues |
Public property | PropertyValues |
Public property | Routine |
Public property | Statement |
Top
Methods
 | Name | Description
Public method | BeginChangeBatch |
Public method | Clone |
Public method | Clone(Boolean) |
Public method | CreateProperty(Type, PropertyConstraintType) |
Public method | CreateProperty(Type, PropertyConstraintType, String) |
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) |
Public method | DeleteProperty |
Public method | Dispose | Releases all resources used by the CustomStatementBase
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CustomStatementBase and optionally releases the managed resources
Public method | EndChangeBatch |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Public method | ExecuteImmediate |
Public method | ExecuteImmediate(IExecutor) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperty |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize(Boolean) | Called when the statement is ready to be constructed. This is called before the statement is added to the IRoutine.
Public method | Initialize(CustomStatementBase) | Called after the statement has been cloned. Additional initialization can be placed here.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnAdd |
Public method | OnRemove |
Public method | OnReset |
Public method | SetPropertyValues(IEnumerableObject) |
Public method | SetPropertyValues(IEnumerableTupleString, Object) |
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) |
Public method | SetPropertyValues(Int32, IEnumerableObject) |
Public method | SetStatement |
Protected method | StatementInvalidated |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Executed |
Public event | ExecutedEx |
Public event | Executing |
Public event | ExecutingEx |
Public event | ObjectInvalidated |
Public event | PropertyContainerChanged |
Public event | Reset |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


CustomStatementBase Constructor

Initializes a new instance of the CustomStatementBase class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected CustomStatementBase()
protected:
CustomStatementBase()
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase Properties

The CustomStatementBase type exposes the following members.

Properties
 | Name | Description
Public property | ApiType |
Public property | ChangeBatchLevel |
Public property | ContainerExpressionContext |
Public property | ControlExecutedExEvent |
Public property | CustomStatement |
Public property | ExecutedCycleTime |
Public property | IsExecuting |
Public property | IsLoop |
Public property | IsValid |
Public property | Name |
Public property | ParentScope |
Public property | Pointer |
Public property | Properties |
Public property | PropertyNames |
Public property | PropertyNamesAndValues |
Public property | PropertyValues |
Public property | Routine |
Public property | Statement |
Top
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.ApiType Property

CustomStatementBaseApiType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type ApiType { get; }
public:
virtual property Type^ ApiType {
    Type^ get () sealed;
}

Property Value

Type: Type

Implements

IApiTypeApiType
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.ChangeBatchLevel Property

CustomStatementBaseChangeBatchLevel Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ChangeBatchLevel { get; }
public:
virtual property int ChangeBatchLevel {
    int get () sealed;
}

Property Value

Type: Int32

Implements

IBatchModeObjectChangeBatchLevel
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.ContainerExpressionContext Property

CustomStatementBaseContainerExpressionContext Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IExpressionContext ContainerExpressionContext { get; }
public:
virtual property IExpressionContext^ ContainerExpressionContext {
    IExpressionContext^ get () sealed;
}

Property Value

Type: IExpressionContext

Implements

IPropertyContainerContainerExpressionContext
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.ControlExecutedExEvent Property

CustomStatementBaseControlExecutedExEvent Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ControlExecutedExEvent { get; set; }
public:
virtual property bool ControlExecutedExEvent {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IStatementControlExecutedExEvent
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.CustomStatement Property

CustomStatementBaseCustomStatement Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ICustomStatement CustomStatement { get; }
public:
virtual property ICustomStatement^ CustomStatement {
    ICustomStatement^ get () sealed;
}

Property Value

Type: ICustomStatement

Implements

IStatementCustomStatement
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.ExecutedCycleTime Property

CustomStatementBaseExecutedCycleTime Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double ExecutedCycleTime { get; }
public:
virtual property double ExecutedCycleTime {
    double get () sealed;
}

Property Value

Type: Double

Implements

IStatementExecutedCycleTime
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.IsExecuting Property

CustomStatementBaseIsExecuting Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsExecuting { get; }
public:
virtual property bool IsExecuting {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IStatementIsExecuting
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.IsLoop Property

CustomStatementBaseIsLoop Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsLoop { get; }
public:
virtual property bool IsLoop {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IStatementIsLoop
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.IsValid Property

CustomStatementBaseIsValid Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsValid { get; }
public:
virtual property bool IsValid {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IWrapperIsValid
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.Name Property

CustomStatementBaseName Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; set; }
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INamedName
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.ParentScope Property

CustomStatementBaseParentScope Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IStatementScope ParentScope { get; }
public:
virtual property IStatementScope^ ParentScope {
    IStatementScope^ get () sealed;
}

Property Value

Type: IStatementScope

Implements

IStatementParentScope
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.Pointer Property

CustomStatementBasePointer Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IntPtr Pointer { get; }
public:
virtual property IntPtr Pointer {
    IntPtr get () sealed;
}

Property Value

Type: IntPtr

Implements

IWrapperPointer
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.Properties Property

CustomStatementBaseProperties Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList<IProperty> Properties { get; }
public:
virtual property IList<IProperty^>^ Properties {
    IList<IProperty^>^ get () sealed;
}

Property Value

Type: IListIProperty

Implements

IPropertyContainerProperties
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.PropertyNames Property

CustomStatementBasePropertyNames Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<string> PropertyNames { get; }
public:
virtual property IEnumerable<String^>^ PropertyNames {
    IEnumerable<String^>^ get () sealed;
}

Property Value

Type: IEnumerableString

Implements

IPropertyContainerPropertyNames
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.PropertyNamesAndValues Property

CustomStatementBasePropertyNamesAndValues Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<Tuple<string, Object>> PropertyNamesAndValues { get; }
public:
virtual property IEnumerable<Tuple<String^, Object^>^>^ PropertyNamesAndValues {
    IEnumerable<Tuple<String^, Object^>^>^ get () sealed;
}

Property Value

Type: IEnumerableTupleString, Object

Implements

IPropertyContainerPropertyNamesAndValues
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.PropertyValues Property

CustomStatementBasePropertyValues Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<Object> PropertyValues { get; }
public:
virtual property IEnumerable<Object^>^ PropertyValues {
    IEnumerable<Object^>^ get () sealed;
}

Property Value

Type: IEnumerableObject

Implements

IPropertyContainerPropertyValues
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.Routine Property

CustomStatementBaseRoutine Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IRoutine Routine { get; }
public:
virtual property IRoutine^ Routine {
    IRoutine^ get () sealed;
}

Property Value

Type: IRoutine

Implements

IStatementRoutine
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.Statement Property

CustomStatementBaseStatement Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IStatement Statement { get; }
public:
property IStatement^ Statement {
    IStatement^ get ();
}

Property Value

Type: IStatement
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase Methods

The CustomStatementBase type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch |
Public method | Clone |
Public method | Clone(Boolean) |
Public method | CreateProperty(Type, PropertyConstraintType) |
Public method | CreateProperty(Type, PropertyConstraintType, String) |
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) |
Public method | DeleteProperty |
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | EndChangeBatch |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Public method | ExecuteImmediate |
Public method | ExecuteImmediate(IExecutor) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperty |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize(Boolean) | Called when the statement is ready to be constructed. This is called before the statement is added to the IRoutine.
Public method | Initialize(CustomStatementBase) | Called after the statement has been cloned. Additional initialization can be placed here.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnAdd |
Public method | OnRemove |
Public method | OnReset |
Public method | SetPropertyValues(IEnumerableObject) |
Public method | SetPropertyValues(IEnumerableTupleString, Object) |
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) |
Public method | SetPropertyValues(Int32, IEnumerableObject) |
Public method | SetStatement |
Protected method | StatementInvalidated |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.BeginChangeBatch Method

CustomStatementBaseBeginChangeBatch Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void BeginChangeBatch()
public:
virtual void BeginChangeBatch() sealed

Implements

IBatchModeObjectBeginChangeBatch
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.Clone Method

CustomStatementBaseClone Method

Overload List
 | Name | Description
Public method | Clone |
Public method | Clone(Boolean) |
Top
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.Clone Method

CustomStatementBaseClone Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IStatement Clone()
public:
virtual IStatement^ Clone() sealed

Return Value

Type: IStatement

[Missing <returns> documentation for "M:VisualComponents.Create3D.CustomStatementBase.Clone"]

Implements

ICloneableTClone
See Also

Reference

CustomStatementBase Class
Clone Overload
VisualComponents.Create3D Namespace


CustomStatementBase.Clone Method (Boolean)

CustomStatementBaseClone Method (Boolean)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IStatement Clone(
    bool cloneContents
)
public:
virtual IStatement^ Clone(
    bool cloneContents
) sealed

Parameters

cloneContents
Type: SystemBoolean

Return Value

Type: IStatement

[Missing <returns> documentation for "M:VisualComponents.Create3D.CustomStatementBase.Clone(System.Boolean)"]

Implements

IStatementClone(Boolean)
See Also

Reference

CustomStatementBase Class
Clone Overload
VisualComponents.Create3D Namespace


CustomStatementBase.CreateProperty Method

CustomStatementBaseCreateProperty Method

Overload List
 | Name | Description
Public method | CreateProperty(Type, PropertyConstraintType) |
Public method | CreateProperty(Type, PropertyConstraintType, String) |
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) |
Top
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.CreateProperty Method (Type, PropertyConstraintType)

CustomStatementBaseCreateProperty Method (Type, PropertyConstraintType)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty CreateProperty(
    Type valueType,
    PropertyConstraintType constraintType
)
public:
virtual IProperty^ CreateProperty(
    Type^ valueType,
    PropertyConstraintType constraintType
) sealed

Parameters

valueType
Type: SystemType
constraintType
Type: VisualComponents.Create3DPropertyConstraintType

Return Value

Type: IProperty

[Missing <returns> documentation for "M:VisualComponents.Create3D.CustomStatementBase.CreateProperty(System.Type,VisualComponents.Create3D.PropertyConstraintType)"]

Implements

IPropertyContainerCreateProperty(Type, PropertyConstraintType)
See Also

Reference

CustomStatementBase Class
CreateProperty Overload
VisualComponents.Create3D Namespace


CustomStatementBase.CreateProperty Method (Type, PropertyConstraintType, String)

CustomStatementBaseCreateProperty Method (Type, PropertyConstraintType, String)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty CreateProperty(
    Type valueType,
    PropertyConstraintType constraintType,
    string name
)
public:
virtual IProperty^ CreateProperty(
    Type^ valueType,
    PropertyConstraintType constraintType,
    String^ name
) sealed

Parameters

valueType
Type: SystemType
constraintType
Type: VisualComponents.Create3DPropertyConstraintType
name
Type: SystemString

Return Value

Type: IProperty

[Missing <returns> documentation for "M:VisualComponents.Create3D.CustomStatementBase.CreateProperty(System.Type,VisualComponents.Create3D.PropertyConstraintType,System.String)"]

Implements

IPropertyContainerCreateProperty(Type, PropertyConstraintType, String)
See Also

Reference

CustomStatementBase Class
CreateProperty Overload
VisualComponents.Create3D Namespace


CustomStatementBase.CreateProperty Method (Type, PropertyConstraintType, String, IProperty)

CustomStatementBaseCreateProperty Method (Type, PropertyConstraintType, String, IProperty)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty CreateProperty(
    Type valueType,
    PropertyConstraintType constraintType,
    string name,
    IProperty toBeReplaced
)
public:
virtual IProperty^ CreateProperty(
    Type^ valueType,
    PropertyConstraintType constraintType,
    String^ name,
    IProperty^ toBeReplaced
) sealed

Parameters

valueType
Type: SystemType
constraintType
Type: VisualComponents.Create3DPropertyConstraintType
name
Type: SystemString
toBeReplaced
Type: VisualComponents.Create3DIProperty

Return Value

Type: IProperty

[Missing <returns> documentation for "M:VisualComponents.Create3D.CustomStatementBase.CreateProperty(System.Type,VisualComponents.Create3D.PropertyConstraintType,System.String,VisualComponents.Create3D.IProperty)"]

Implements

IPropertyContainerCreateProperty(Type, PropertyConstraintType, String, IProperty)
See Also

Reference

CustomStatementBase Class
CreateProperty Overload
VisualComponents.Create3D Namespace


CustomStatementBase.DeleteProperty Method

CustomStatementBaseDeleteProperty Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void DeleteProperty(
    IProperty prop
)
public:
virtual void DeleteProperty(
    IProperty^ prop
) sealed

Parameters

prop
Type: VisualComponents.Create3DIProperty

Implements

IPropertyContainerDeleteProperty(IProperty)
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.Dispose Method

CustomStatementBaseDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the CustomStatementBase
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CustomStatementBase and optionally releases the managed resources
Top
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.Dispose Method

CustomStatementBaseDispose Method

Releases all resources used by the CustomStatementBase

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Dispose()
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

CustomStatementBase Class
Dispose Overload
VisualComponents.Create3D Namespace


CustomStatementBase.Dispose Method (Boolean)

CustomStatementBaseDispose Method (Boolean)

Releases the unmanaged resources used by the CustomStatementBase and optionally releases the managed resources

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void Dispose(
    bool disposing
)
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

CustomStatementBase Class
Dispose Overload
VisualComponents.Create3D Namespace


CustomStatementBase.EndChangeBatch Method

CustomStatementBaseEndChangeBatch Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void EndChangeBatch()
public:
virtual void EndChangeBatch() sealed

Implements

IBatchModeObjectEndChangeBatch
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.Execute Method

CustomStatementBaseExecute Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract void Execute(
    IExecutor executor
)
public:
virtual void Execute(
    IExecutor^ executor
) abstract

Parameters

executor
Type: VisualComponents.Create3DIExecutor
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.ExecuteImmediate Method

CustomStatementBaseExecuteImmediate Method

Overload List
 | Name | Description
Public method | ExecuteImmediate |
Public method | ExecuteImmediate(IExecutor) |
Top
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.ExecuteImmediate Method

CustomStatementBaseExecuteImmediate Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ExecuteImmediate()
public:
virtual void ExecuteImmediate() sealed

Implements

IStatementExecuteImmediate
See Also

Reference

CustomStatementBase Class
ExecuteImmediate Overload
VisualComponents.Create3D Namespace


CustomStatementBase.ExecuteImmediate Method (IExecutor)

CustomStatementBaseExecuteImmediate Method (IExecutor)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract void ExecuteImmediate(
    IExecutor executor
)
public:
virtual void ExecuteImmediate(
    IExecutor^ executor
) abstract

Parameters

executor
Type: VisualComponents.Create3DIExecutor
See Also

Reference

CustomStatementBase Class
ExecuteImmediate Overload
VisualComponents.Create3D Namespace


CustomStatementBase.GetProperty Method

CustomStatementBaseGetProperty Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty GetProperty(
    string name
)
public:
virtual IProperty^ GetProperty(
    String^ name
) sealed

Parameters

name
Type: SystemString

Return Value

Type: IProperty

[Missing <returns> documentation for "M:VisualComponents.Create3D.CustomStatementBase.GetProperty(System.String)"]

Implements

IPropertyContainerGetProperty(String)
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.Initialize Method

CustomStatementBaseInitialize Method

Overload List
 | Name | Description
Public method | Initialize(Boolean) | Called when the statement is ready to be constructed. This is called before the statement is added to the IRoutine.
Public method | Initialize(CustomStatementBase) | Called after the statement has been cloned. Additional initialization can be placed here.
Top
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.Initialize Method (Boolean)

CustomStatementBaseInitialize Method (Boolean)

Called when the statement is ready to be constructed. This is called before the statement is added to the IRoutine.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void Initialize(
    bool isRestored
)
public:
virtual void Initialize(
    bool isRestored
)

Parameters

isRestored
Type: SystemBoolean
Defines if the statement is being restored. This happens when the layout is loaded and the program is recreated. In this case the persistent objects will be created by the persistency model and the statement should not try to create those.
See Also

Reference

CustomStatementBase Class
Initialize Overload
VisualComponents.Create3D Namespace


CustomStatementBase.Initialize Method (CustomStatementBase)

CustomStatementBaseInitialize Method (CustomStatementBase)

Called after the statement has been cloned. Additional initialization can be placed here.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void Initialize(
    CustomStatementBase original
)
public:
virtual void Initialize(
    CustomStatementBase^ original
)

Parameters

original
Type: VisualComponents.Create3DCustomStatementBase
Original instance.
See Also

Reference

CustomStatementBase Class
Initialize Overload
VisualComponents.Create3D Namespace


CustomStatementBase.OnAdd Method

CustomStatementBaseOnAdd Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void OnAdd()
public:
virtual void OnAdd()
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.OnRemove Method

CustomStatementBaseOnRemove Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void OnRemove()
public:
virtual void OnRemove()
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.OnReset Method

CustomStatementBaseOnReset Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void OnReset()
public:
virtual void OnReset()
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.SetPropertyValues Method

CustomStatementBaseSetPropertyValues Method

Overload List
 | Name | Description
Public method | SetPropertyValues(IEnumerableObject) |
Public method | SetPropertyValues(IEnumerableTupleString, Object) |
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) |
Public method | SetPropertyValues(Int32, IEnumerableObject) |
Top
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.SetPropertyValues Method (IEnumerable(Object))

CustomStatementBaseSetPropertyValues Method (IEnumerableObject)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetPropertyValues(
    IEnumerable<Object> values
)
public:
virtual void SetPropertyValues(
    IEnumerable<Object^>^ values
) sealed

Parameters

values
Type: System.Collections.GenericIEnumerableObject

Implements

IPropertyContainerSetPropertyValues(IEnumerableObject)
See Also

Reference

CustomStatementBase Class
SetPropertyValues Overload
VisualComponents.Create3D Namespace


CustomStatementBase.SetPropertyValues Method (IEnumerable(Tuple(String, Object)))

CustomStatementBaseSetPropertyValues Method (IEnumerableTupleString, Object)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetPropertyValues(
    IEnumerable<Tuple<string, Object>> namesAndValues
)
public:
virtual void SetPropertyValues(
    IEnumerable<Tuple<String^, Object^>^>^ namesAndValues
) sealed

Parameters

namesAndValues
Type: System.Collections.GenericIEnumerableTupleString, Object

Implements

IPropertyContainerSetPropertyValues(IEnumerableTupleString, Object)
See Also

Reference

CustomStatementBase Class
SetPropertyValues Overload
VisualComponents.Create3D Namespace


CustomStatementBase.SetPropertyValues Method (IEnumerable(String), IEnumerable(Object))

CustomStatementBaseSetPropertyValues Method (IEnumerableString, IEnumerableObject)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetPropertyValues(
    IEnumerable<string> names,
    IEnumerable<Object> values
)
public:
virtual void SetPropertyValues(
    IEnumerable<String^>^ names,
    IEnumerable<Object^>^ values
) sealed

Parameters

names
Type: System.Collections.GenericIEnumerableString
values
Type: System.Collections.GenericIEnumerableObject

Implements

IPropertyContainerSetPropertyValues(IEnumerableString, IEnumerableObject)
See Also

Reference

CustomStatementBase Class
SetPropertyValues Overload
VisualComponents.Create3D Namespace


CustomStatementBase.SetPropertyValues Method (Int32, IEnumerable(Object))

CustomStatementBaseSetPropertyValues Method (Int32, IEnumerableObject)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetPropertyValues(
    int startIndex,
    IEnumerable<Object> values
)
public:
virtual void SetPropertyValues(
    int startIndex,
    IEnumerable<Object^>^ values
) sealed

Parameters

startIndex
Type: SystemInt32
values
Type: System.Collections.GenericIEnumerableObject

Implements

IPropertyContainerSetPropertyValues(Int32, IEnumerableObject)
See Also

Reference

CustomStatementBase Class
SetPropertyValues Overload
VisualComponents.Create3D Namespace


CustomStatementBase.SetStatement Method

CustomStatementBaseSetStatement Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void SetStatement(
    IStatement statement
)
public:
virtual void SetStatement(
    IStatement^ statement
)

Parameters

statement
Type: VisualComponents.Create3DIStatement

Implements

ICustomStatementSetStatement(IStatement)
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.StatementInvalidated Method

CustomStatementBaseStatementInvalidated Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void StatementInvalidated()
protected:
virtual void StatementInvalidated()
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase Events

The CustomStatementBase type exposes the following members.

Events
 | Name | Description
Public event | Executed |
Public event | ExecutedEx |
Public event | Executing |
Public event | ExecutingEx |
Public event | ObjectInvalidated |
Public event | PropertyContainerChanged |
Public event | Reset |
Top
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.Executed Event

CustomStatementBaseExecuted Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<StatementExecutedEventArgs> Executed
public:
virtual  event EventHandler<StatementExecutedEventArgs^>^ Executed {
    void add (EventHandler<StatementExecutedEventArgs^>^ value);
    void remove (EventHandler<StatementExecutedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerStatementExecutedEventArgs

Implements

IStatementExecuted
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.ExecutedEx Event

CustomStatementBaseExecutedEx Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<StatementExecutedEventArgs> ExecutedEx
public:
virtual  event EventHandler<StatementExecutedEventArgs^>^ ExecutedEx {
    void add (EventHandler<StatementExecutedEventArgs^>^ value);
    void remove (EventHandler<StatementExecutedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerStatementExecutedEventArgs

Implements

IStatementExecutedEx
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.Executing Event

CustomStatementBaseExecuting Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<StatementExecutingEventArgs> Executing
public:
virtual  event EventHandler<StatementExecutingEventArgs^>^ Executing {
    void add (EventHandler<StatementExecutingEventArgs^>^ value);
    void remove (EventHandler<StatementExecutingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerStatementExecutingEventArgs

Implements

IStatementExecuting
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.ExecutingEx Event

CustomStatementBaseExecutingEx Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<StatementExecutingEventArgs> ExecutingEx
public:
virtual  event EventHandler<StatementExecutingEventArgs^>^ ExecutingEx {
    void add (EventHandler<StatementExecutingEventArgs^>^ value);
    void remove (EventHandler<StatementExecutingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerStatementExecutingEventArgs

Implements

IStatementExecutingEx
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.ObjectInvalidated Event

CustomStatementBaseObjectInvalidated Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler ObjectInvalidated
public:
virtual  event EventHandler^ ObjectInvalidated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IWrapperObjectInvalidated
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.PropertyContainerChanged Event

CustomStatementBasePropertyContainerChanged Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<PropertyContainerChangedEventArgs> PropertyContainerChanged
public:
virtual  event EventHandler<PropertyContainerChangedEventArgs^>^ PropertyContainerChanged {
    void add (EventHandler<PropertyContainerChangedEventArgs^>^ value);
    void remove (EventHandler<PropertyContainerChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerPropertyContainerChangedEventArgs

Implements

IPropertyContainerPropertyContainerChanged
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


CustomStatementBase.Reset Event

CustomStatementBaseReset Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<EventArgs> Reset
public:
virtual  event EventHandler<EventArgs^>^ Reset {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs

Implements

IStatementReset
See Also

Reference

CustomStatementBase Class
VisualComponents.Create3D Namespace


D3DToolBarConfigElement Class

Configuration file element for 3D toolbar options.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.Create3DD3DToolBarConfigElement

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class D3DToolBarConfigElement : ConfigurationElement
public ref class D3DToolBarConfigElement sealed : public ConfigurationElement

The D3DToolBarConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | D3DToolBarConfigElement | Initializes a new instance of the D3DToolBarConfigElement class
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | FrameType | Configuration file element for frame type options.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


D3DToolBarConfigElement Constructor

Initializes a new instance of the D3DToolBarConfigElement class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public D3DToolBarConfigElement()
public:
D3DToolBarConfigElement()
See Also

Reference

D3DToolBarConfigElement Class
VisualComponents.Create3D Namespace


D3DToolBarConfigElement Properties

The D3DToolBarConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | FrameType | Configuration file element for frame type options.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Top
See Also

Reference

D3DToolBarConfigElement Class
VisualComponents.Create3D Namespace


D3DToolBarConfigElement.FrameType Property

D3DToolBarConfigElementFrameType Property

Configuration file element for frame type options.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FrameTypeStateConfigElement FrameType { get; set; }
public:
property FrameTypeStateConfigElement^ FrameType {
    FrameTypeStateConfigElement^ get ();
    void set (FrameTypeStateConfigElement^ value);
}

Property Value

Type: FrameTypeStateConfigElement
See Also

Reference

D3DToolBarConfigElement Class
VisualComponents.Create3D Namespace


D3DToolBarConfigElement Methods

The D3DToolBarConfigElement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

D3DToolBarConfigElement Class
VisualComponents.Create3D Namespace


DatabaseChangedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DDatabaseChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class DatabaseChangedEventArgs : EventArgs
public ref class DatabaseChangedEventArgs : public EventArgs

The DatabaseChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DatabaseChangedEventArgs | Initializes a new instance of the DatabaseChangedEventArgs class
Top
Properties
 | Name | Description
Public property | ChangeType |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


DatabaseChangedEventArgs Constructor

Initializes a new instance of the DatabaseChangedEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DatabaseChangedEventArgs()
public:
DatabaseChangedEventArgs()
See Also

Reference

DatabaseChangedEventArgs Class
VisualComponents.Create3D Namespace


DatabaseChangedEventArgs Properties

The DatabaseChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ChangeType |
Top
See Also

Reference

DatabaseChangedEventArgs Class
VisualComponents.Create3D Namespace


DatabaseChangedEventArgs.ChangeType Property

DatabaseChangedEventArgsChangeType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DatabaseChangeType ChangeType { get; set; }
public:
property DatabaseChangeType ChangeType {
    DatabaseChangeType get ();
    void set (DatabaseChangeType value);
}

Property Value

Type: DatabaseChangeType
See Also

Reference

DatabaseChangedEventArgs Class
VisualComponents.Create3D Namespace


DatabaseChangedEventArgs Methods

The DatabaseChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DatabaseChangedEventArgs Class
VisualComponents.Create3D Namespace


DatabaseChangeType Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum DatabaseChangeType
public enum class DatabaseChangeType
Members
Member name | Value | Description
Reorder | 2 |
EditOne | 3 |
EditMultiple | 4 |
See Also

Reference

VisualComponents.Create3D Namespace


DateHelper Class

Helper functions for DateTime formatting, etc.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DDateHelper

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class DateHelper
public ref class DateHelper abstract sealed

The DateHelper type exposes the following members.

Methods
Name | Description
GetLongDate(DateTime) | Returns long date pattern e.g. Thursday, April 10, 2008 (for en)
GetLongDate(DateTime, IFormatProvider) | Returns long date pattern e.g. Thursday, April 10, 2008 (for en)
GetLongDateWithoutWeekday | Returns e.g. October 20, 2017 (for en), or 20. Oktober 2017 (for de).
Top
See Also

Reference

VisualComponents.Create3D Namespace


DateHelper Methods

The DateHelper type exposes the following members.

Methods
Name | Description
GetLongDate(DateTime) | Returns long date pattern e.g. Thursday, April 10, 2008 (for en)
GetLongDate(DateTime, IFormatProvider) | Returns long date pattern e.g. Thursday, April 10, 2008 (for en)
GetLongDateWithoutWeekday | Returns e.g. October 20, 2017 (for en), or 20. Oktober 2017 (for de).
Top
See Also

Reference

DateHelper Class
VisualComponents.Create3D Namespace


DateHelper.GetLongDate Method

DateHelperGetLongDate Method

Overload List
Name | Description
GetLongDate(DateTime) | Returns long date pattern e.g. Thursday, April 10, 2008 (for en)
GetLongDate(DateTime, IFormatProvider) | Returns long date pattern e.g. Thursday, April 10, 2008 (for en)
Top
See Also

Reference

DateHelper Class
VisualComponents.Create3D Namespace


DateHelper.GetLongDate Method (DateTime)

DateHelperGetLongDate Method (DateTime)

Returns long date pattern e.g. Thursday, April 10, 2008 (for en)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetLongDate(
    DateTime dateTime
)
public:
static String^ GetLongDate(
    DateTime dateTime
)

Parameters

dateTime
Type: SystemDateTime

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.DateHelper.GetLongDate(System.DateTime)"]

See Also

Reference

DateHelper Class
GetLongDate Overload
VisualComponents.Create3D Namespace


DateHelper.GetLongDate Method (DateTime, IFormatProvider)

DateHelperGetLongDate Method (DateTime, IFormatProvider)

Returns long date pattern e.g. Thursday, April 10, 2008 (for en)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetLongDate(
    DateTime dateTime,
    IFormatProvider culture
)
public:
static String^ GetLongDate(
    DateTime dateTime,
    IFormatProvider^ culture
)

Parameters

dateTime
Type: SystemDateTime
culture
Type: SystemIFormatProvider

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.DateHelper.GetLongDate(System.DateTime,System.IFormatProvider)"]

See Also

Reference

DateHelper Class
GetLongDate Overload
VisualComponents.Create3D Namespace


DateHelper.GetLongDateWithoutWeekday Method

DateHelperGetLongDateWithoutWeekday Method

Returns e.g. October 20, 2017 (for en), or 20. Oktober 2017 (for de).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetLongDateWithoutWeekday(
    DateTime dateTime,
    CultureInfo culture
)
public:
static String^ GetLongDateWithoutWeekday(
    DateTime dateTime,
    CultureInfo^ culture
)

Parameters

dateTime
Type: SystemDateTime
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.DateHelper.GetLongDateWithoutWeekday(System.DateTime,System.Globalization.CultureInfo)"]

See Also

Reference

DateHelper Class
VisualComponents.Create3D Namespace


DefaultUnit Enumeration

DefaultUnit option restricted to those formats where unit never exists or is unreliable (U3D, CGR, STL, VRML)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum DefaultUnit
public enum class DefaultUnit
Members
Member name | Value | Description
Point | 0 | Point
Inch | 1 | Inch
Millimeter | 2 | Millimeter
Centimeter | 3 | Centimeter
Picas | 4 | Picas
Foot | 5 | Foot
Yard | 6 | Yard
Meter | 7 | Meter
Kilometer | 8 | Kilometer
Mile | 9 | Mile
Default | 10 | File units
See Also

Reference

VisualComponents.Create3D Namespace


DegreeOfFreedom Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum DegreeOfFreedom
public enum class DegreeOfFreedom
Members
Member name | Value | Description
Invalid | 0 |
TX | 1 | X-axis translation.
TY | 2 | Y-axis translation.
TZ | 3 | Z-axis translation.
RX | 4 | X-axis rotation.
RY | 5 | Y-axis rotation.
RZ | 6 | Z-axis rotation.
See Also

Reference

VisualComponents.Create3D Namespace


DeviceInputs Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DDeviceInputs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class DeviceInputs
public ref class DeviceInputs

The DeviceInputs type exposes the following members.

Constructors
 | Name | Description
Public method | DeviceInputs | Initializes a new instance of the DeviceInputs class
Top
Properties
 | Name | Description
Public property | Axis2DInputs |
Public property | AxisInputs |
Public property | ButtonInputs |
Public property | DeviceRole |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


DeviceInputs Constructor

Initializes a new instance of the DeviceInputs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DeviceInputs()
public:
DeviceInputs()
See Also

Reference

DeviceInputs Class
VisualComponents.Create3D Namespace


DeviceInputs Properties

The DeviceInputs type exposes the following members.

Properties
 | Name | Description
Public property | Axis2DInputs |
Public property | AxisInputs |
Public property | ButtonInputs |
Public property | DeviceRole |
Top
See Also

Reference

DeviceInputs Class
VisualComponents.Create3D Namespace


DeviceInputs.Axis2DInputs Property

DeviceInputsAxis2DInputs Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Dictionary<string, Tuple<float, float>> Axis2DInputs { get; }
public:
property Dictionary<String^, Tuple<float, float>^>^ Axis2DInputs {
    Dictionary<String^, Tuple<float, float>^>^ get ();
}

Property Value

Type: DictionaryString, TupleSingle, Single
See Also

Reference

DeviceInputs Class
VisualComponents.Create3D Namespace


DeviceInputs.AxisInputs Property

DeviceInputsAxisInputs Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Dictionary<string, float> AxisInputs { get; }
public:
property Dictionary<String^, float>^ AxisInputs {
    Dictionary<String^, float>^ get ();
}

Property Value

Type: DictionaryString, Single
See Also

Reference

DeviceInputs Class
VisualComponents.Create3D Namespace


DeviceInputs.ButtonInputs Property

DeviceInputsButtonInputs Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Dictionary<string, bool> ButtonInputs { get; }
public:
property Dictionary<String^, bool>^ ButtonInputs {
    Dictionary<String^, bool>^ get ();
}

Property Value

Type: DictionaryString, Boolean
See Also

Reference

DeviceInputs Class
VisualComponents.Create3D Namespace


DeviceInputs.DeviceRole Property

DeviceInputsDeviceRole Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string DeviceRole { get; set; }
public:
property String^ DeviceRole {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DeviceInputs Class
VisualComponents.Create3D Namespace


DeviceInputs Methods

The DeviceInputs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DeviceInputs Class
VisualComponents.Create3D Namespace


DimensionChange Class

Stores undo/redo information of IDimension -object.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DChange
VisualComponents.Create3DDimensionChange

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class DimensionChange : Change
public ref class DimensionChange sealed : public Change

The DimensionChange type exposes the following members.

Constructors
 | Name | Description
Public method | DimensionChange | Constructor
Top
Properties
 | Name | Description
Public property | Dimension | Dimension that changed.
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Top
Methods
 | Name | Description
Public method | CollectChanges |
Public method | Dispose | (Inherited from Change.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


DimensionChange Constructor

Constructor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DimensionChange(
    IDimension dimensionToChange
)
public:
DimensionChange(
    IDimension^ dimensionToChange
)

Parameters

dimensionToChange
Type: VisualComponents.Create3DIDimension
Dimension that changed
See Also

Reference

DimensionChange Class
VisualComponents.Create3D Namespace


DimensionChange Properties

The DimensionChange type exposes the following members.

Properties
 | Name | Description
Public property | Dimension | Dimension that changed.
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Top
See Also

Reference

DimensionChange Class
VisualComponents.Create3D Namespace


DimensionChange.Dimension Property

DimensionChangeDimension Property

Dimension that changed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IDimension Dimension { get; }
public:
property IDimension^ Dimension {
    IDimension^ get ();
}

Property Value

Type: IDimension
See Also

Reference

DimensionChange Class
VisualComponents.Create3D Namespace


DimensionChange Methods

The DimensionChange type exposes the following members.

Methods
 | Name | Description
Public method | CollectChanges |
Public method | Dispose | (Inherited from Change.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DimensionChange Class
VisualComponents.Create3D Namespace


DimensionChange.CollectChanges Method

DimensionChangeCollectChanges Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CollectChanges()
public:
void CollectChanges()
See Also

Reference

DimensionChange Class
VisualComponents.Create3D Namespace


DimensionCreationChange Class

Stores undo/redo information of dimensions
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DChange
VisualComponents.Create3DDimensionCreationChange

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class DimensionCreationChange : Change
public ref class DimensionCreationChange sealed : public Change

The DimensionCreationChange type exposes the following members.

Constructors
 | Name | Description
Public method | DimensionCreationChange | Initializes a new instance of the DimensionCreationChange class
Top
Properties
 | Name | Description
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from Change.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


DimensionCreationChange Constructor

Initializes a new instance of the DimensionCreationChange class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DimensionCreationChange(
    IDimension dimension,
    bool isCreationChange,
    ISimWorld world
)
public:
DimensionCreationChange(
    IDimension^ dimension,
    bool isCreationChange,
    ISimWorld^ world
)

Parameters

dimension
Type: VisualComponents.Create3DIDimension
isCreationChange
Type: SystemBoolean
world
Type: VisualComponents.Create3DISimWorld
See Also

Reference

DimensionCreationChange Class
VisualComponents.Create3D Namespace


DimensionCreationChange Properties

The DimensionCreationChange type exposes the following members.

Properties
 | Name | Description
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Top
See Also

Reference

DimensionCreationChange Class
VisualComponents.Create3D Namespace


DimensionCreationChange Methods

The DimensionCreationChange type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from Change.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DimensionCreationChange Class
VisualComponents.Create3D Namespace


DimensionType Enumeration

Dimension type enumeration.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum DimensionType
public enum class DimensionType
Members
Member name | Value | Description
Linear | 0 | Dimension will calculate distances
Angular | 1 | Dimension will calculate angles
See Also

Reference

VisualComponents.Create3D Namespace


DisplayConfigElement Class

Configuration file element for Display Options.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.Create3DDisplayConfigElement

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class DisplayConfigElement : ConfigurationElement
public ref class DisplayConfigElement sealed : public ConfigurationElement

The DisplayConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | DisplayConfigElement | Constructor.
Top
Properties
 | Name | Description
Public property | ActualColorMap | Actual color map serialized string
Public property | AmbientOcclusionQuality | Ambient occlusion quality.
Public property | AutoResizeFloor | Floor auto-resize.
Public property | BackgroundColor | Background color.
Public property | ClearPaintOnReset | Clear paint on reset.
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | D3DPdfBackgroundColor | 3D Pdf Background color.
Public property | DecimalPrecision | Decimal precision property
Public property | DimensionsAccuracy | Dimension accuracy property
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | FloorColor | Floor color.
Public property | FloorReflection | Floor reflection.
Public property | FloorSizeX | Floor size along x.
Public property | FloorSizeY | Floor size along y.
Public property | FloorTexture | Floor texture.
Public property | FloorTextureFillAll | Floor texture fill.
Public property | FloorVisibility | Floor visibility.
Public property | FontSize3D | Grid snap size.
Public property | FrameVisibility | Frame visibility.
Public property | GridSnapSize | Grid snap size.
Public property | GridVisibility | Grid visibility.
Public property | Headlight | Turn on/off additional light which direction is always facing to the viewpoint
Public property | IsAlignPositionFull | Projected or full position align.
Public property | IsAmbientOcclusionEnabled | Ambient occlusion state.
Public property | IsAntialiasingEnabled | Antialiasing state.
Public property | IsEffectShaderEnabled | Effect shader state.
Public property | IsFastRobotProgramOverlayVisible | Simulation control visibility.
Public property | IsGridSnapAlwaysSnap | Grid snap always.
Public property | IsGridSnapZoomBased | Grid snap based on zoom.
Public property | IsJointLimitDetectionOn | Joint limit detection.
Public property | IsMaterialShaderEnabled | Material shader state.
Public property | IsOrthographicProjectionOn | Orthographic projection.
Public property | IsShadowsEnabled | Shadows state.
Public property | IsSimulationControlVisible | Simulation control visibility.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | MajorGridLineColor | Maror grid color.
Public property | MajorGridLineWidth | Major grid line width.
Public property | MajorGridSizeX | Major grid size along x.
Public property | MajorGridSizeY | Major grid size along y.
Public property | MinorGridLineColor | Minor grid color.
Public property | MinorGridLineWidth | Minor grid line width.
Public property | MultisamplingMode | Effect shader state.
Public property | PatternEditorHeadlight | Same as Headlight, but specific to Pattern Editor.
Public property | PatternEditorIsOrthographicProjectionOn | Same as IsOrthographicProjectionOn, but specific to Pattern Editor.
Public property | PatternEditorRenderingPreset | Same as RenderingPreset, but specific to Pattern Editor.
Public property | PositionFrameCenter | Position frame center visibility.
Public property | PositionFrameLabel | Position frame lable visibility.
Public property | PositionFrameXAxis | Position frame x-axis visibility.
Public property | PositionFrameYAxis | Position frame y-axis visibility.
Public property | PositionFrameZAxis | Position frame z-axis visibility.
Public property | RenderingMode | Rendering mode.
Public property | RenderingPreset | Rendering preset.
Public property | RenderTiles | Major grid size along y.
Public property | RobotFrameVisibility | Robot frame visibility type.
Public property | SelectionFillColor | Selection fill color.
Public property | SelectionSilhouetteColor | Selection silhouette color.
Public property | ShadingMode | Shading mode.
Public property | ShadowSoftness | Shadow softness.
Public property | ShowBehaviors | Behaviour visibility in authoring tree.
Public property | ShowProperties | Properties visibility in authoring tree.
Public property | SnapWay | Align setting. 0 position, 1 orientation, 2 both
Public property | SoftwareFallbackMode | Effect shader state.
Public property | ThicknessColorMap | Thickness color map serialized string
Public property | TrailingZeroVisible | Trailing zero visible property
Public property | WorldOriginFrameVisibility | World origin frame visibility.
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InitDefaults |
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks
These options are visibile in application backstage, and stored to user-specific configuration file.
See Also

Reference

VisualComponents.Create3D Namespace


DisplayConfigElement Constructor

Constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DisplayConfigElement()
public:
DisplayConfigElement()
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement Properties

The DisplayConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | ActualColorMap | Actual color map serialized string
Public property | AmbientOcclusionQuality | Ambient occlusion quality.
Public property | AutoResizeFloor | Floor auto-resize.
Public property | BackgroundColor | Background color.
Public property | ClearPaintOnReset | Clear paint on reset.
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | D3DPdfBackgroundColor | 3D Pdf Background color.
Public property | DecimalPrecision | Decimal precision property
Public property | DimensionsAccuracy | Dimension accuracy property
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | FloorColor | Floor color.
Public property | FloorReflection | Floor reflection.
Public property | FloorSizeX | Floor size along x.
Public property | FloorSizeY | Floor size along y.
Public property | FloorTexture | Floor texture.
Public property | FloorTextureFillAll | Floor texture fill.
Public property | FloorVisibility | Floor visibility.
Public property | FontSize3D | Grid snap size.
Public property | FrameVisibility | Frame visibility.
Public property | GridSnapSize | Grid snap size.
Public property | GridVisibility | Grid visibility.
Public property | Headlight | Turn on/off additional light which direction is always facing to the viewpoint
Public property | IsAlignPositionFull | Projected or full position align.
Public property | IsAmbientOcclusionEnabled | Ambient occlusion state.
Public property | IsAntialiasingEnabled | Antialiasing state.
Public property | IsEffectShaderEnabled | Effect shader state.
Public property | IsFastRobotProgramOverlayVisible | Simulation control visibility.
Public property | IsGridSnapAlwaysSnap | Grid snap always.
Public property | IsGridSnapZoomBased | Grid snap based on zoom.
Public property | IsJointLimitDetectionOn | Joint limit detection.
Public property | IsMaterialShaderEnabled | Material shader state.
Public property | IsOrthographicProjectionOn | Orthographic projection.
Public property | IsShadowsEnabled | Shadows state.
Public property | IsSimulationControlVisible | Simulation control visibility.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | MajorGridLineColor | Maror grid color.
Public property | MajorGridLineWidth | Major grid line width.
Public property | MajorGridSizeX | Major grid size along x.
Public property | MajorGridSizeY | Major grid size along y.
Public property | MinorGridLineColor | Minor grid color.
Public property | MinorGridLineWidth | Minor grid line width.
Public property | MultisamplingMode | Effect shader state.
Public property | PatternEditorHeadlight | Same as Headlight, but specific to Pattern Editor.
Public property | PatternEditorIsOrthographicProjectionOn | Same as IsOrthographicProjectionOn, but specific to Pattern Editor.
Public property | PatternEditorRenderingPreset | Same as RenderingPreset, but specific to Pattern Editor.
Public property | PositionFrameCenter | Position frame center visibility.
Public property | PositionFrameLabel | Position frame lable visibility.
Public property | PositionFrameXAxis | Position frame x-axis visibility.
Public property | PositionFrameYAxis | Position frame y-axis visibility.
Public property | PositionFrameZAxis | Position frame z-axis visibility.
Public property | RenderingMode | Rendering mode.
Public property | RenderingPreset | Rendering preset.
Public property | RenderTiles | Major grid size along y.
Public property | RobotFrameVisibility | Robot frame visibility type.
Public property | SelectionFillColor | Selection fill color.
Public property | SelectionSilhouetteColor | Selection silhouette color.
Public property | ShadingMode | Shading mode.
Public property | ShadowSoftness | Shadow softness.
Public property | ShowBehaviors | Behaviour visibility in authoring tree.
Public property | ShowProperties | Properties visibility in authoring tree.
Public property | SnapWay | Align setting. 0 position, 1 orientation, 2 both
Public property | SoftwareFallbackMode | Effect shader state.
Public property | ThicknessColorMap | Thickness color map serialized string
Public property | TrailingZeroVisible | Trailing zero visible property
Public property | WorldOriginFrameVisibility | World origin frame visibility.
Top
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.ActualColorMap Property

DisplayConfigElementActualColorMap Property

Actual color map serialized string

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ActualColorMap { get; set; }
public:
property String^ ActualColorMap {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.AmbientOcclusionQuality Property

DisplayConfigElementAmbientOcclusionQuality Property

Ambient occlusion quality.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AmbientOcclusionQuality { get; set; }
public:
property String^ AmbientOcclusionQuality {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.AutoResizeFloor Property

DisplayConfigElementAutoResizeFloor Property

Floor auto-resize.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool AutoResizeFloor { get; set; }
public:
property bool AutoResizeFloor {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.BackgroundColor Property

DisplayConfigElementBackgroundColor Property

Background color.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string BackgroundColor { get; set; }
public:
property String^ BackgroundColor {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.ClearPaintOnReset Property

DisplayConfigElementClearPaintOnReset Property

Clear paint on reset.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ClearPaintOnReset { get; set; }
public:
property bool ClearPaintOnReset {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.D3DPdfBackgroundColor Property

DisplayConfigElementD3DPdfBackgroundColor Property

3D Pdf Background color.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string D3DPdfBackgroundColor { get; set; }
public:
property String^ D3DPdfBackgroundColor {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.DecimalPrecision Property

DisplayConfigElementDecimalPrecision Property

Decimal precision property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<uint> DecimalPrecision { get; set; }
public:
property Nullable<unsigned int> DecimalPrecision {
    Nullable<unsigned int> get ();
    void set (Nullable<unsigned int> value);
}

Property Value

Type: NullableUInt32
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.DimensionsAccuracy Property

DisplayConfigElementDimensionsAccuracy Property

Dimension accuracy property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<uint> DimensionsAccuracy { get; set; }
public:
property Nullable<unsigned int> DimensionsAccuracy {
    Nullable<unsigned int> get ();
    void set (Nullable<unsigned int> value);
}

Property Value

Type: NullableUInt32
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.FloorColor Property

DisplayConfigElementFloorColor Property

Floor color.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string FloorColor { get; set; }
public:
property String^ FloorColor {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.FloorReflection Property

DisplayConfigElementFloorReflection Property

Floor reflection.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double FloorReflection { get; set; }
public:
property double FloorReflection {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.FloorSizeX Property

DisplayConfigElementFloorSizeX Property

Floor size along x.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double FloorSizeX { get; set; }
public:
property double FloorSizeX {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.FloorSizeY Property

DisplayConfigElementFloorSizeY Property

Floor size along y.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double FloorSizeY { get; set; }
public:
property double FloorSizeY {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.FloorTexture Property

DisplayConfigElementFloorTexture Property

Floor texture.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string FloorTexture { get; set; }
public:
property String^ FloorTexture {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.FloorTextureFillAll Property

DisplayConfigElementFloorTextureFillAll Property

Floor texture fill.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool FloorTextureFillAll { get; set; }
public:
property bool FloorTextureFillAll {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.FloorVisibility Property

DisplayConfigElementFloorVisibility Property

Floor visibility.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool FloorVisibility { get; set; }
public:
property bool FloorVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.FontSize3D Property

DisplayConfigElementFontSize3D Property

Grid snap size.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double FontSize3D { get; set; }
public:
property double FontSize3D {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.FrameVisibility Property

DisplayConfigElementFrameVisibility Property

Frame visibility.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool FrameVisibility { get; set; }
public:
property bool FrameVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.GridSnapSize Property

DisplayConfigElementGridSnapSize Property

Grid snap size.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double GridSnapSize { get; set; }
public:
property double GridSnapSize {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.GridVisibility Property

DisplayConfigElementGridVisibility Property

Grid visibility.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool GridVisibility { get; set; }
public:
property bool GridVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.Headlight Property

DisplayConfigElementHeadlight Property

Turn on/off additional light which direction is always facing to the viewpoint

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<bool> Headlight { get; set; }
public:
property Nullable<bool> Headlight {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: NullableBoolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.IsAlignPositionFull Property

DisplayConfigElementIsAlignPositionFull Property

Projected or full position align.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsAlignPositionFull { get; set; }
public:
property bool IsAlignPositionFull {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.IsAmbientOcclusionEnabled Property

DisplayConfigElementIsAmbientOcclusionEnabled Property

Ambient occlusion state.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsAmbientOcclusionEnabled { get; set; }
public:
property bool IsAmbientOcclusionEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.IsAntialiasingEnabled Property

DisplayConfigElementIsAntialiasingEnabled Property

Antialiasing state.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsAntialiasingEnabled { get; set; }
public:
property bool IsAntialiasingEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.IsEffectShaderEnabled Property

DisplayConfigElementIsEffectShaderEnabled Property

Effect shader state.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsEffectShaderEnabled { get; set; }
public:
property bool IsEffectShaderEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.IsFastRobotProgramOverlayVisible Property

DisplayConfigElementIsFastRobotProgramOverlayVisible Property

Simulation control visibility.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<bool> IsFastRobotProgramOverlayVisible { get; set; }
public:
property Nullable<bool> IsFastRobotProgramOverlayVisible {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: NullableBoolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.IsGridSnapAlwaysSnap Property

DisplayConfigElementIsGridSnapAlwaysSnap Property

Grid snap always.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsGridSnapAlwaysSnap { get; set; }
public:
property bool IsGridSnapAlwaysSnap {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.IsGridSnapZoomBased Property

DisplayConfigElementIsGridSnapZoomBased Property

Grid snap based on zoom.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsGridSnapZoomBased { get; set; }
public:
property bool IsGridSnapZoomBased {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.IsJointLimitDetectionOn Property

DisplayConfigElementIsJointLimitDetectionOn Property

Joint limit detection.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsJointLimitDetectionOn { get; set; }
public:
property bool IsJointLimitDetectionOn {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.IsMaterialShaderEnabled Property

DisplayConfigElementIsMaterialShaderEnabled Property

Material shader state.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsMaterialShaderEnabled { get; set; }
public:
property bool IsMaterialShaderEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.IsOrthographicProjectionOn Property

DisplayConfigElementIsOrthographicProjectionOn Property

Orthographic projection.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsOrthographicProjectionOn { get; set; }
public:
property bool IsOrthographicProjectionOn {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.IsShadowsEnabled Property

DisplayConfigElementIsShadowsEnabled Property

Shadows state.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsShadowsEnabled { get; set; }
public:
property bool IsShadowsEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.IsSimulationControlVisible Property

DisplayConfigElementIsSimulationControlVisible Property

Simulation control visibility.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsSimulationControlVisible { get; set; }
public:
property bool IsSimulationControlVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.MajorGridLineColor Property

DisplayConfigElementMajorGridLineColor Property

Maror grid color.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string MajorGridLineColor { get; set; }
public:
property String^ MajorGridLineColor {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.MajorGridLineWidth Property

DisplayConfigElementMajorGridLineWidth Property

Major grid line width.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double MajorGridLineWidth { get; set; }
public:
property double MajorGridLineWidth {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.MajorGridSizeX Property

DisplayConfigElementMajorGridSizeX Property

Major grid size along x.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double MajorGridSizeX { get; set; }
public:
property double MajorGridSizeX {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.MajorGridSizeY Property

DisplayConfigElementMajorGridSizeY Property

Major grid size along y.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double MajorGridSizeY { get; set; }
public:
property double MajorGridSizeY {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.MinorGridLineColor Property

DisplayConfigElementMinorGridLineColor Property

Minor grid color.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string MinorGridLineColor { get; set; }
public:
property String^ MinorGridLineColor {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.MinorGridLineWidth Property

DisplayConfigElementMinorGridLineWidth Property

Minor grid line width.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double MinorGridLineWidth { get; set; }
public:
property double MinorGridLineWidth {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.MultisamplingMode Property

DisplayConfigElementMultisamplingMode Property

Effect shader state.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int MultisamplingMode { get; set; }
public:
property int MultisamplingMode {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.PatternEditorHeadlight Property

DisplayConfigElementPatternEditorHeadlight Property

Same as Headlight, but specific to Pattern Editor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<bool> PatternEditorHeadlight { get; set; }
public:
property Nullable<bool> PatternEditorHeadlight {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: NullableBoolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.PatternEditorIsOrthographicProjectionOn Property

DisplayConfigElementPatternEditorIsOrthographicProjectionOn Property

Same as IsOrthographicProjectionOn, but specific to Pattern Editor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool PatternEditorIsOrthographicProjectionOn { get; set; }
public:
property bool PatternEditorIsOrthographicProjectionOn {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.PatternEditorRenderingPreset Property

DisplayConfigElementPatternEditorRenderingPreset Property

Same as RenderingPreset, but specific to Pattern Editor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string PatternEditorRenderingPreset { get; set; }
public:
property String^ PatternEditorRenderingPreset {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.PositionFrameCenter Property

DisplayConfigElementPositionFrameCenter Property

Position frame center visibility.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool PositionFrameCenter { get; set; }
public:
property bool PositionFrameCenter {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.PositionFrameLabel Property

DisplayConfigElementPositionFrameLabel Property

Position frame lable visibility.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool PositionFrameLabel { get; set; }
public:
property bool PositionFrameLabel {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.PositionFrameXAxis Property

DisplayConfigElementPositionFrameXAxis Property

Position frame x-axis visibility.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool PositionFrameXAxis { get; set; }
public:
property bool PositionFrameXAxis {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.PositionFrameYAxis Property

DisplayConfigElementPositionFrameYAxis Property

Position frame y-axis visibility.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool PositionFrameYAxis { get; set; }
public:
property bool PositionFrameYAxis {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.PositionFrameZAxis Property

DisplayConfigElementPositionFrameZAxis Property

Position frame z-axis visibility.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool PositionFrameZAxis { get; set; }
public:
property bool PositionFrameZAxis {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.RenderingMode Property

DisplayConfigElementRenderingMode Property

Rendering mode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string RenderingMode { get; set; }
public:
property String^ RenderingMode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.RenderingPreset Property

DisplayConfigElementRenderingPreset Property

Rendering preset.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string RenderingPreset { get; set; }
public:
property String^ RenderingPreset {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.RenderTiles Property

DisplayConfigElementRenderTiles Property

Major grid size along y.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int RenderTiles { get; set; }
public:
property int RenderTiles {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.RobotFrameVisibility Property

DisplayConfigElementRobotFrameVisibility Property

Robot frame visibility type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int RobotFrameVisibility { get; set; }
public:
property int RobotFrameVisibility {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.SelectionFillColor Property

DisplayConfigElementSelectionFillColor Property

Selection fill color.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SelectionFillColor { get; set; }
public:
property String^ SelectionFillColor {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.SelectionSilhouetteColor Property

DisplayConfigElementSelectionSilhouetteColor Property

Selection silhouette color.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SelectionSilhouetteColor { get; set; }
public:
property String^ SelectionSilhouetteColor {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.ShadingMode Property

DisplayConfigElementShadingMode Property

Shading mode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ShadingMode { get; set; }
public:
property String^ ShadingMode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.ShadowSoftness Property

DisplayConfigElementShadowSoftness Property

Shadow softness.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double ShadowSoftness { get; set; }
public:
property double ShadowSoftness {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.ShowBehaviors Property

DisplayConfigElementShowBehaviors Property

Behaviour visibility in authoring tree.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowBehaviors { get; set; }
public:
property bool ShowBehaviors {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.ShowProperties Property

DisplayConfigElementShowProperties Property

Properties visibility in authoring tree.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowProperties { get; set; }
public:
property bool ShowProperties {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.SnapWay Property

DisplayConfigElementSnapWay Property

Align setting. 0 position, 1 orientation, 2 both

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int SnapWay { get; set; }
public:
property int SnapWay {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.SoftwareFallbackMode Property

DisplayConfigElementSoftwareFallbackMode Property

Effect shader state.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool SoftwareFallbackMode { get; set; }
public:
property bool SoftwareFallbackMode {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.ThicknessColorMap Property

DisplayConfigElementThicknessColorMap Property

Thickness color map serialized string

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ThicknessColorMap { get; set; }
public:
property String^ ThicknessColorMap {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.TrailingZeroVisible Property

DisplayConfigElementTrailingZeroVisible Property

Trailing zero visible property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<bool> TrailingZeroVisible { get; set; }
public:
property Nullable<bool> TrailingZeroVisible {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: NullableBoolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.WorldOriginFrameVisibility Property

DisplayConfigElementWorldOriginFrameVisibility Property

World origin frame visibility.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool WorldOriginFrameVisibility { get; set; }
public:
property bool WorldOriginFrameVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement Methods

The DisplayConfigElement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InitDefaults |
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplayConfigElement.InitDefaults Method

DisplayConfigElementInitDefaults Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void InitDefaults(
    IAppConfigSettings appConfigSettings
)
public:
static void InitDefaults(
    IAppConfigSettings^ appConfigSettings
)

Parameters

appConfigSettings
Type: VisualComponents.Create3DIAppConfigSettings
See Also

Reference

DisplayConfigElement Class
VisualComponents.Create3D Namespace


DisplaySection Class

Configuration file section for Display Options.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationSection
VisualComponents.Create3DDisplaySection

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class DisplaySection : ConfigurationSection,
    IDisplaySection, ISection
public ref class DisplaySection sealed : public ConfigurationSection,
    IDisplaySection, ISection

The DisplaySection type exposes the following members.

Constructors
 | Name | Description
Public method | DisplaySection | Contructor.
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | DisplayElement | Configuration file element for Display Options.
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName | Section's name in configuration file.
Public property | SectionType | Interface type.
Public property | SectionVersion | Section's version number.
Top
Methods
 | Name | Description
Public method | CheckVersion | Upgrade configuration to the latest version.
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection | Finds typed section by name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


DisplaySection Constructor

Contructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DisplaySection()
public:
DisplaySection()
See Also

Reference

DisplaySection Class
VisualComponents.Create3D Namespace


DisplaySection Properties

The DisplaySection type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | DisplayElement | Configuration file element for Display Options.
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName | Section's name in configuration file.
Public property | SectionType | Interface type.
Public property | SectionVersion | Section's version number.
Top
See Also

Reference

DisplaySection Class
VisualComponents.Create3D Namespace


DisplaySection.DisplayElement Property

DisplaySectionDisplayElement Property

Configuration file element for Display Options.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DisplayConfigElement DisplayElement { get; set; }
public:
virtual property DisplayConfigElement^ DisplayElement {
    DisplayConfigElement^ get () sealed;
    void set (DisplayConfigElement^ value) sealed;
}

Property Value

Type: DisplayConfigElement

Implements

IDisplaySectionDisplayElement
See Also

Reference

DisplaySection Class
VisualComponents.Create3D Namespace


DisplaySection.SectionName Property

DisplaySectionSectionName Property

Section's name in configuration file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SectionName { get; }
public:
virtual property String^ SectionName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ISectionSectionName
See Also

Reference

DisplaySection Class
VisualComponents.Create3D Namespace


DisplaySection.SectionType Property

DisplaySectionSectionType Property

Interface type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type SectionType { get; }
public:
virtual property Type^ SectionType {
    Type^ get () sealed;
}

Property Value

Type: Type

Implements

ISectionSectionType
See Also

Reference

DisplaySection Class
VisualComponents.Create3D Namespace


DisplaySection.SectionVersion Property

DisplaySectionSectionVersion Property

Section's version number.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int SectionVersion { get; }
public:
virtual property int SectionVersion {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISectionSectionVersion
See Also

Reference

DisplaySection Class
VisualComponents.Create3D Namespace


DisplaySection Methods

The DisplaySection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion | Upgrade configuration to the latest version.
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection | Finds typed section by name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DisplaySection Class
VisualComponents.Create3D Namespace


DisplaySection.CheckVersion Method

DisplaySectionCheckVersion Method

Upgrade configuration to the latest version.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CheckVersion()
public:
virtual void CheckVersion() sealed

Implements

ISectionCheckVersion
See Also

Reference

DisplaySection Class
VisualComponents.Create3D Namespace


DisplaySection.GetSection Method

DisplaySectionGetSection Method

Finds typed section by name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISection GetSection(
    Configuration userSettingConfiguration
)
public:
virtual ISection^ GetSection(
    Configuration^ userSettingConfiguration
) sealed

Parameters

userSettingConfiguration
Type: System.ConfigurationConfiguration
Configuration containing this section

Return Value

Type: ISection
Instance of DisplaySection

Implements

ISectionGetSection(Configuration)
See Also

Reference

DisplaySection Class
VisualComponents.Create3D Namespace


DisplaySection.ToString Method

DisplaySectionToString Method

Converts this instance to string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String
String representation of this instance
See Also

Reference

DisplaySection Class
VisualComponents.Create3D Namespace


DistanceResult Class

Distance measurement result class
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DDistanceResult

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class DistanceResult
public ref class DistanceResult

The DistanceResult type exposes the following members.

Constructors
 | Name | Description
Public method | DistanceResult | Initializes a new instance of the DistanceResult class
Top
Properties
 | Name | Description
Public property | PointA | Closest point on side A.
Public property | PointB | Closest point on side B.
Public property | ScalarDistance | Scalar distance between points.
Public property | VectorDistance | Distance vector from point A to point B.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


DistanceResult Constructor

Initializes a new instance of the DistanceResult class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DistanceResult()
public:
DistanceResult()
See Also

Reference

DistanceResult Class
VisualComponents.Create3D Namespace


DistanceResult Properties

The DistanceResult type exposes the following members.

Properties
 | Name | Description
Public property | PointA | Closest point on side A.
Public property | PointB | Closest point on side B.
Public property | ScalarDistance | Scalar distance between points.
Public property | VectorDistance | Distance vector from point A to point B.
Top
See Also

Reference

DistanceResult Class
VisualComponents.Create3D Namespace


DistanceResult.PointA Property

DistanceResultPointA Property

Closest point on side A.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 PointA { get; set; }
public:
property Vector3 PointA {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

DistanceResult Class
VisualComponents.Create3D Namespace


DistanceResult.PointB Property

DistanceResultPointB Property

Closest point on side B.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 PointB { get; set; }
public:
property Vector3 PointB {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

DistanceResult Class
VisualComponents.Create3D Namespace


DistanceResult.ScalarDistance Property

DistanceResultScalarDistance Property

Scalar distance between points.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double ScalarDistance { get; set; }
public:
property double ScalarDistance {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

DistanceResult Class
VisualComponents.Create3D Namespace


DistanceResult.VectorDistance Property

DistanceResultVectorDistance Property

Distance vector from point A to point B.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 VectorDistance { get; set; }
public:
property Vector3 VectorDistance {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

DistanceResult Class
VisualComponents.Create3D Namespace


DistanceResult Methods

The DistanceResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DistanceResult Class
VisualComponents.Create3D Namespace


DistinctionLevel Enumeration

Level of difference between properties in a union property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum DistinctionLevel
public enum class DistinctionLevel
Members
Member name | Value | Description
DifferentTypes | 0 | The properties have different types. Value cannot be changed.
IncompatibleConstraints | 1 | The properties have no common allowed values. Value cannot be changed.
DifferentValues | 2 | The properties have different values, but there is a common set of allowed values. Value is settable.
SameValue | 3 | The properties all have the same value. Value is settable.
See Also

Reference

VisualComponents.Create3D Namespace


DistributionType Enumeration

Distribution type enumeration
Remarks
Determines the type of a IDistributionProperty

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum DistributionType
public enum class DistributionType
Members
Member name | Value | Description
Constant | 0 | Constant value
Normal | 1 | Normal distribution with the mean value μ and the standard deviation σ
LogNormal | 2 | Log-Normal distribution with the mean value μ and the standard deviation σ
Uniform | 3 | Uniform distribution in the range Min <= x < Max
Exponential | 4 | Exponential distribution where the mean is 1/λ and the variance is 1/λ^2
Gamma | 5 | Gamma distribution with shape (K) and scale theta (Ɵ)
Triangular | 6 | Triangular distribution with the specified minimun, medium and maximum values
Weibull | 7 | Weidbull distribution with shape k and scale lamba (λ)
See Also

Reference

VisualComponents.Create3D Namespace


DoEventsMethod Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum DoEventsMethod
public enum class DoEventsMethod
Members
Member name | Value | Description
FlushDispatcherPriorityRender | 0 |
FlushDispatcherPriorityInputWhenMouseNotDown | 1 |
WinFormsWay | 2 |
FlushDispatcherPriorityInput | 3 |
See Also

Reference

VisualComponents.Create3D Namespace


DWGInternalVersion Enumeration

Internal version AutoCAD

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum DWGInternalVersion
public enum class DWGInternalVersion
Members
Member name | Value | Description
AC1027 | 0 |
AC1024 | 1 |
AC1021 | 2 |
AC1800 | 3 |
AC1015 | 4 |
DXF | 5 |
UNKNOWN | 6 |
See Also

Reference

VisualComponents.Create3D Namespace


E3DStudio Enumeration

3D Studio

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum E3DStudio
public enum class E3DStudio
Members
Member name | Value | Description
FORMAT_3DS | 0 |
See Also

Reference

VisualComponents.Create3D Namespace


E3MF Enumeration

3D Manufacturing Format

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum E3MF
public enum class E3MF
Members
Member name | Value | Description
FORMAT_3MF | 0 |
See Also

Reference

VisualComponents.Create3D Namespace


EcatConfigCollection Class

Configuration file element collection for ECat options.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationElementCollection
VisualComponents.Create3DEcatConfigCollection

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class EcatConfigCollection : ConfigurationElementCollection,
    ICollection<EcatConfigElement>, IEnumerable<EcatConfigElement>, IEnumerable
public ref class EcatConfigCollection sealed : public ConfigurationElementCollection,
    ICollection<EcatConfigElement^>, IEnumerable<EcatConfigElement^>, IEnumerable

The EcatConfigCollection type exposes the following members.

Constructors
 | Name | Description
Public method | EcatConfigCollection | Initializes a new instance of the EcatConfigCollection class
Top
Properties
 | Name | Description
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Public property | IsReadOnly |
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Public property | ItemInt32 |
Public property | ItemString |
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Top
Methods
 | Name | Description
Public method | Add |
Public method | Clear |
Public method | Contains(String) | Returns a value indicating whether the container contains a specified key.
Public method | Contains(EcatConfigElement) |
Public method | CopyTo(ConfigurationElement, Int32) | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | CopyTo(EcatConfigElement, Int32) |
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator |
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf |
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Public method | Remove(String) |
Public method | Remove(EcatConfigElement) |
Public method | RemoveAt |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachEcatConfigElement | Enumerate a cached collection performing the specified action on each item. (Defined by ForEachHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | HasMoreThanEcatConfigElement | (Defined by EnumerableHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToObservableCollectionEcatConfigElement | (Defined by Extensions.)
Public Extension Method | ToObservableCollectionExEcatConfigElement | (Defined by Extensions.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


EcatConfigCollection Constructor

Initializes a new instance of the EcatConfigCollection class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EcatConfigCollection()
public:
EcatConfigCollection()
See Also

Reference

EcatConfigCollection Class
VisualComponents.Create3D Namespace


EcatConfigCollection Properties

The EcatConfigCollection type exposes the following members.

Properties
 | Name | Description
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Public property | IsReadOnly |
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Public property | ItemInt32 |
Public property | ItemString |
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Top
See Also

Reference

EcatConfigCollection Class
VisualComponents.Create3D Namespace


EcatConfigCollection.IsReadOnly Property

EcatConfigCollectionIsReadOnly Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsReadOnly { get; }
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ICollectionTIsReadOnly
See Also

Reference

EcatConfigCollection Class
VisualComponents.Create3D Namespace


EcatConfigCollection.Item Property

EcatConfigCollectionItem Property

Overload List
 | Name | Description
Public property | ItemInt32 |
Public property | ItemString |
Top
See Also

Reference

EcatConfigCollection Class
VisualComponents.Create3D Namespace


EcatConfigCollection.Item Property (Int32)

EcatConfigCollectionItem Property (Int32)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EcatConfigElement this[
    int index
] { get; set; }
public:
property EcatConfigElement^ default[int index] {
    EcatConfigElement^ get (int index);
    void set (int index, EcatConfigElement^ value);
}

Parameters

index
Type: SystemInt32

Property Value

Type: EcatConfigElement
See Also

Reference

EcatConfigCollection Class
Item Overload
VisualComponents.Create3D Namespace


EcatConfigCollection.Item Property (String)

EcatConfigCollectionItem Property (String)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EcatConfigElement this[
    string key
] { get; set; }
public:
property EcatConfigElement^ default[String^ key] {
    EcatConfigElement^ get (String^ key);
    void set (String^ key, EcatConfigElement^ value);
}

Parameters

key
Type: SystemString

Property Value

Type: EcatConfigElement
See Also

Reference

EcatConfigCollection Class
Item Overload
VisualComponents.Create3D Namespace


EcatConfigCollection Methods

The EcatConfigCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Public method | Clear |
Public method | Contains(String) | Returns a value indicating whether the container contains a specified key.
Public method | Contains(EcatConfigElement) |
Public method | CopyTo(ConfigurationElement, Int32) | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | CopyTo(EcatConfigElement, Int32) |
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator |
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf |
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Public method | Remove(String) |
Public method | Remove(EcatConfigElement) |
Public method | RemoveAt |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachEcatConfigElement | Enumerate a cached collection performing the specified action on each item. (Defined by ForEachHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | HasMoreThanEcatConfigElement | (Defined by EnumerableHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToObservableCollectionEcatConfigElement | (Defined by Extensions.)
Public Extension Method | ToObservableCollectionExEcatConfigElement | (Defined by Extensions.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

EcatConfigCollection Class
VisualComponents.Create3D Namespace


EcatConfigCollection.Add Method

EcatConfigCollectionAdd Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Add(
    EcatConfigElement item
)
public:
virtual void Add(
    EcatConfigElement^ item
) sealed

Parameters

item
Type: VisualComponents.Create3DEcatConfigElement

Implements

ICollectionTAdd(T)
See Also

Reference

EcatConfigCollection Class
VisualComponents.Create3D Namespace


EcatConfigCollection.Clear Method

EcatConfigCollectionClear Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Clear()
public:
virtual void Clear() sealed

Implements

ICollectionTClear
See Also

Reference

EcatConfigCollection Class
VisualComponents.Create3D Namespace


EcatConfigCollection.Contains Method

EcatConfigCollectionContains Method

Overload List
 | Name | Description
Public method | Contains(String) | Returns a value indicating whether the container contains a specified key.
Public method | Contains(EcatConfigElement) |
Top
See Also

Reference

EcatConfigCollection Class
VisualComponents.Create3D Namespace


EcatConfigCollection.Contains Method (String)

EcatConfigCollectionContains Method (String)

Returns a value indicating whether the container contains a specified key.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Contains(
    string key
)
public:
bool Contains(
    String^ key
)

Parameters

key
Type: SystemString

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.EcatConfigCollection.Contains(System.String)"]

See Also

Reference

EcatConfigCollection Class
Contains Overload
VisualComponents.Create3D Namespace


EcatConfigCollection.Contains Method (EcatConfigElement)

EcatConfigCollectionContains Method (EcatConfigElement)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Contains(
    EcatConfigElement item
)
public:
virtual bool Contains(
    EcatConfigElement^ item
) sealed

Parameters

item
Type: VisualComponents.Create3DEcatConfigElement

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.EcatConfigCollection.Contains(VisualComponents.Create3D.EcatConfigElement)"]

Implements

ICollectionTContains(T)
See Also

Reference

EcatConfigCollection Class
Contains Overload
VisualComponents.Create3D Namespace


EcatConfigCollection.CopyTo Method

EcatConfigCollectionCopyTo Method

Overload List
 | Name | Description
Public method | CopyTo(ConfigurationElement, Int32) | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | CopyTo(EcatConfigElement, Int32) |
Top
See Also

Reference

EcatConfigCollection Class
VisualComponents.Create3D Namespace


EcatConfigCollection.CopyTo Method (EcatConfigElement[], Int32)

EcatConfigCollectionCopyTo Method (EcatConfigElement, Int32)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CopyTo(
    EcatConfigElement[] array,
    int arrayIndex
)
public:
virtual void CopyTo(
    array<EcatConfigElement^>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: VisualComponents.Create3DEcatConfigElement
arrayIndex
Type: SystemInt32

Implements

ICollectionTCopyTo(T, Int32)
See Also

Reference

EcatConfigCollection Class
CopyTo Overload
VisualComponents.Create3D Namespace


EcatConfigCollection.GetEnumerator Method

EcatConfigCollectionGetEnumerator Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerator<EcatConfigElement> GetEnumerator()
public:
virtual IEnumerator<EcatConfigElement^>^ GetEnumerator() sealed

Return Value

Type: IEnumeratorEcatConfigElement

[Missing <returns> documentation for "M:VisualComponents.Create3D.EcatConfigCollection.GetEnumerator"]

Implements

IEnumerableTGetEnumerator
See Also

Reference

EcatConfigCollection Class
VisualComponents.Create3D Namespace


EcatConfigCollection.IndexOf Method

EcatConfigCollectionIndexOf Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int IndexOf(
    EcatConfigElement element
)
public:
int IndexOf(
    EcatConfigElement^ element
)

Parameters

element
Type: VisualComponents.Create3DEcatConfigElement

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.EcatConfigCollection.IndexOf(VisualComponents.Create3D.EcatConfigElement)"]

See Also

Reference

EcatConfigCollection Class
VisualComponents.Create3D Namespace


EcatConfigCollection.Remove Method

EcatConfigCollectionRemove Method

Overload List
 | Name | Description
Public method | Remove(String) |
Public method | Remove(EcatConfigElement) |
Top
See Also

Reference

EcatConfigCollection Class
VisualComponents.Create3D Namespace


EcatConfigCollection.Remove Method (String)

EcatConfigCollectionRemove Method (String)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Remove(
    string key
)
public:
void Remove(
    String^ key
)

Parameters

key
Type: SystemString
See Also

Reference

EcatConfigCollection Class
Remove Overload
VisualComponents.Create3D Namespace


EcatConfigCollection.Remove Method (EcatConfigElement)

EcatConfigCollectionRemove Method (EcatConfigElement)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Remove(
    EcatConfigElement item
)
public:
virtual bool Remove(
    EcatConfigElement^ item
) sealed

Parameters

item
Type: VisualComponents.Create3DEcatConfigElement

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.EcatConfigCollection.Remove(VisualComponents.Create3D.EcatConfigElement)"]

Implements

ICollectionTRemove(T)
See Also

Reference

EcatConfigCollection Class
Remove Overload
VisualComponents.Create3D Namespace


EcatConfigCollection.RemoveAt Method

EcatConfigCollectionRemoveAt Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RemoveAt(
    int index
)
public:
void RemoveAt(
    int index
)

Parameters

index
Type: SystemInt32
See Also

Reference

EcatConfigCollection Class
VisualComponents.Create3D Namespace


EcatConfigElement Class

Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.Create3DEcatConfigElement

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class EcatConfigElement : ConfigurationElement
public ref class EcatConfigElement sealed : public ConfigurationElement

The EcatConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | EcatConfigElement | Constructor.
Public method | EcatConfigElement(String, String) | Initializes a new instance of the EcatConfigElement class
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | Key | Key id.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | Value | Key value.
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


EcatConfigElement Constructor

Overload List
 | Name | Description
Public method | EcatConfigElement | Constructor.
Public method | EcatConfigElement(String, String) | Initializes a new instance of the EcatConfigElement class
Top
See Also

Reference

EcatConfigElement Class
VisualComponents.Create3D Namespace


EcatConfigElement Constructor

Constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EcatConfigElement()
public:
EcatConfigElement()
See Also

Reference

EcatConfigElement Class
EcatConfigElement Overload
VisualComponents.Create3D Namespace


EcatConfigElement Constructor (String, String)

Initializes a new instance of the EcatConfigElement class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EcatConfigElement(
    string key,
    string value
)
public:
EcatConfigElement(
    String^ key,
    String^ value
)

Parameters

key
Type: SystemString
value
Type: SystemString
See Also

Reference

EcatConfigElement Class
EcatConfigElement Overload
VisualComponents.Create3D Namespace


EcatConfigElement Properties

The EcatConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | Key | Key id.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | Value | Key value.
Top
See Also

Reference

EcatConfigElement Class
VisualComponents.Create3D Namespace


EcatConfigElement.Key Property

EcatConfigElementKey Property

Key id.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Key { get; set; }
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

EcatConfigElement Class
VisualComponents.Create3D Namespace


EcatConfigElement.Value Property

EcatConfigElementValue Property

Key value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Value { get; set; }
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

EcatConfigElement Class
VisualComponents.Create3D Namespace


EcatConfigElement Methods

The EcatConfigElement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

EcatConfigElement Class
VisualComponents.Create3D Namespace


EcatSection Class

Configuration file section for General Options.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationSection
VisualComponents.Create3DEcatSection

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class EcatSection : ConfigurationSection,
    IEcatSection, ISection
public ref class EcatSection sealed : public ConfigurationSection,
    IEcatSection, ISection

The EcatSection type exposes the following members.

Constructors
 | Name | Description
Public method | EcatSection | Constructor.
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | Elements | Gets Ecat configuration items.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName | Section's name in configuration file.
Public property | SectionType | Interface type.
Public property | SectionVersion | Section's version number.
Top
Methods
 | Name | Description
Public method | CheckVersion | Upgrade configuration to the latest version.
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | FixFirstVersionIssue | Fixes an issue relating to the Offline folder
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection | Finds typed section by name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks
These options are visibile in application backstage, and stored to user-specific configuration file.
See Also

Reference

VisualComponents.Create3D Namespace


EcatSection Constructor

Constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EcatSection()
public:
EcatSection()
See Also

Reference

EcatSection Class
VisualComponents.Create3D Namespace


EcatSection Properties

The EcatSection type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | Elements | Gets Ecat configuration items.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName | Section's name in configuration file.
Public property | SectionType | Interface type.
Public property | SectionVersion | Section's version number.
Top
See Also

Reference

EcatSection Class
VisualComponents.Create3D Namespace


EcatSection.Elements Property

EcatSectionElements Property

Gets Ecat configuration items.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EcatConfigCollection Elements { get; }
public:
virtual property EcatConfigCollection^ Elements {
    EcatConfigCollection^ get () sealed;
}

Property Value

Type: EcatConfigCollection

Implements

IEcatSectionElements
See Also

Reference

EcatSection Class
VisualComponents.Create3D Namespace


EcatSection.SectionName Property

EcatSectionSectionName Property

Section's name in configuration file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SectionName { get; }
public:
virtual property String^ SectionName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ISectionSectionName
See Also

Reference

EcatSection Class
VisualComponents.Create3D Namespace


EcatSection.SectionType Property

EcatSectionSectionType Property

Interface type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type SectionType { get; }
public:
virtual property Type^ SectionType {
    Type^ get () sealed;
}

Property Value

Type: Type

Implements

ISectionSectionType
See Also

Reference

EcatSection Class
VisualComponents.Create3D Namespace


EcatSection.SectionVersion Property

EcatSectionSectionVersion Property

Section's version number.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int SectionVersion { get; }
public:
virtual property int SectionVersion {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISectionSectionVersion
See Also

Reference

EcatSection Class
VisualComponents.Create3D Namespace


EcatSection Methods

The EcatSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion | Upgrade configuration to the latest version.
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | FixFirstVersionIssue | Fixes an issue relating to the Offline folder
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection | Finds typed section by name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

EcatSection Class
VisualComponents.Create3D Namespace


EcatSection.CheckVersion Method

EcatSectionCheckVersion Method

Upgrade configuration to the latest version.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CheckVersion()
public:
virtual void CheckVersion() sealed

Implements

ISectionCheckVersion
See Also

Reference

EcatSection Class
VisualComponents.Create3D Namespace


EcatSection.FixFirstVersionIssue Method

EcatSectionFixFirstVersionIssue Method

Fixes an issue relating to the Offline folder

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool FixFirstVersionIssue()
public:
virtual bool FixFirstVersionIssue() sealed

Return Value

Type: Boolean
true if it's first version of the section

Implements

IEcatSectionFixFirstVersionIssue
See Also

Reference

EcatSection Class
VisualComponents.Create3D Namespace


EcatSection.GetSection Method

EcatSectionGetSection Method

Finds typed section by name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISection GetSection(
    Configuration userSettingConfiguration
)
public:
virtual ISection^ GetSection(
    Configuration^ userSettingConfiguration
) sealed

Parameters

userSettingConfiguration
Type: System.ConfigurationConfiguration

Return Value

Type: ISection

[Missing <returns> documentation for "M:VisualComponents.Create3D.EcatSection.GetSection(System.Configuration.Configuration)"]

Implements

ISectionGetSection(Configuration)
See Also

Reference

EcatSection Class
VisualComponents.Create3D Namespace


EcatSection.ToString Method

EcatSectionToString Method

Converts this instance to string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String
String representation of this instance
See Also

Reference

EcatSection Class
VisualComponents.Create3D Namespace


EdgeColor Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum EdgeColor
public enum class EdgeColor
Members
Member name | Value | Description
None | 0 |
BlackEdge | 1 |
WhiteEdge | 2 |
MaterialEdge | 3 |
ComplimentaryMaterialEdge | 4 |
See Also

Reference

VisualComponents.Create3D Namespace


EdgeShading Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum EdgeShading
public enum class EdgeShading
Members
Member name | Value | Description
None | 0 |
AllEdges | 1 |
Silhouette | 2 |
See Also

Reference

VisualComponents.Create3D Namespace


EmbeddedAppLoader Class

The helper application loader which is responsible for initializating the embedded application version.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DEmbeddedAppLoader

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class EmbeddedAppLoader
public ref class EmbeddedAppLoader

The EmbeddedAppLoader type exposes the following members.

Constructors
 | Name | Description
Protected method | EmbeddedAppLoader | default costructor.
Top
Properties
 | Name | Description
 | Instance | Get instance of the AppLoader.
Public property | ProductLicense | Gets the user config settings.
Top
Methods
 | Name | Description
Public method | AddExportedValueT | Creates a part from the specified value and registeres it in the MEF.
Public method | CleanupEngine | Cleanup the engine.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllComponentInstances | Returns all instances of the requested type.
Public method | GetComponentInstance | Returns instance of the requested type.
Public method | GetExportT | Returns the export with the contract name derived from the specified type parameter. If there is not exactly one matching export, an exception is thrown.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitApplication | Loads core modules, constructs them and loads the user config settings
Public method | InitEmbeddedEngine | Load and initialize all needed modules.
 | InitLog4NetConfig | Setup log4net configuration settings.
Public method | LoadUserAssembly | Loads additional user assembly and registers it in MEF.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SatisfyImportsOnce | Composes the specified part by using the specified composition service, with recomposition disabled.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetComponentInstanceT | Try to get an instance of the requested type.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks
It should not be called directly.
Examples
This example demonstrates how the application must be constructed.
Copy
// App.xaml.cs file

public partial class App : Application
{
    public App()
    {
        // etc

        EmbeddedAppLoader.InitLog4NetConfig();
    }
}

// AppBootstrapper.cs file

public class AppBootstrapper : Bootstrapper<IShell>
{
    private static readonly log4net.ILog log = log4net.LogManager.GetLogger(MethodBase.GetCurrentMethod().DeclaringType);

    private EmbeddedAppLoader _appLoader;
    private IApplication _appInstance;
    LicensingHelper.ProductLicenseType _validLicense;

    protected override void Configure()
    {
        _appLoader = EmbeddedAppLoader.Instance;
        _appInstance = _appLoader.InitApplication(log);
        _validLicense = _appLoader.ProductLicense;
    }

    protected override void StartRuntime()
    {
        // etc
        base.StartRuntime();

        if (_validLicense != LicensingHelper.ProductLicenseType.NotFound)
        {
            XamDockWindowManagerLoader.CreateXamDockWindowManager();
            _appLoader.InitEmbeddedEngine(log);
            // etc, for example
            var renewDate = LicensingHelper.RenewProductKeys();
        }
        // etc
    }

    protected override void OnStartup(object sender, System.Windows.StartupEventArgs e)
    {
        base.OnStartup(sender, e);

        _appInstance.Initialized = true;

        // etc

        if (_validLicense != LicensingHelper.ProductLicenseType.NotFound)
        {
            var shell = IoC.Get<IShell>();
            shell.InitializePlugins();
        }

        // etc
        Application.MainWindow.Closing += OnMainWindowClosing;
        Application.MainWindow.Closed += OnMainWindowClosed;

        _appInstance.MainWindowReady = true;
    }

    void OnMainWindowClosing(object sender, System.ComponentModel.CancelEventArgs e)
    {
    }

    private void OnMainWindowClosed(object sender, EventArgs e)
    {
        _appInstance.UnloadAppFeature();
        _appInstance = null;
    }

    protected override object GetInstance(Type serviceType, string key)
    {
        return _appLoader.GetComponentInstance(serviceType, key);
    }

    protected override IEnumerable<object> GetAllInstances(Type serviceType)
    {
        return _appLoader.GetAllComponentInstances(serviceType);
    }

    protected override void BuildUp(object instance)
    {
        _appLoader.BuildUp(instance);
    }
}
See Also

Reference

VisualComponents.Create3D Namespace


EmbeddedAppLoader Constructor

default costructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected EmbeddedAppLoader()
protected:
EmbeddedAppLoader()
See Also

Reference

EmbeddedAppLoader Class
VisualComponents.Create3D Namespace


EmbeddedAppLoader Properties

The EmbeddedAppLoader type exposes the following members.

Properties
 | Name | Description
 | Instance | Get instance of the AppLoader.
Public property | ProductLicense | Gets the user config settings.
Top
See Also

Reference

EmbeddedAppLoader Class
VisualComponents.Create3D Namespace


EmbeddedAppLoader.Instance Property

EmbeddedAppLoaderInstance Property

Get instance of the AppLoader.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static EmbeddedAppLoader Instance { get; }
public:
static property EmbeddedAppLoader^ Instance {
    EmbeddedAppLoader^ get ();
}

Property Value

Type: EmbeddedAppLoader
See Also

Reference

EmbeddedAppLoader Class
VisualComponents.Create3D Namespace


EmbeddedAppLoader.ProductLicense Property

EmbeddedAppLoaderProductLicense Property

Gets the user config settings.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProductLicenseType ProductLicense { get; }
public:
property ProductLicenseType ProductLicense {
    ProductLicenseType get ();
}

Return Value

Type: ProductLicenseType
Product configuration. Determines which features are enabled.
See Also

Reference

EmbeddedAppLoader Class
VisualComponents.Create3D Namespace


EmbeddedAppLoader Methods

The EmbeddedAppLoader type exposes the following members.

Methods
 | Name | Description
Public method | AddExportedValueT | Creates a part from the specified value and registeres it in the MEF.
Public method | CleanupEngine | Cleanup the engine.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllComponentInstances | Returns all instances of the requested type.
Public method | GetComponentInstance | Returns instance of the requested type.
Public method | GetExportT | Returns the export with the contract name derived from the specified type parameter. If there is not exactly one matching export, an exception is thrown.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitApplication | Loads core modules, constructs them and loads the user config settings
Public method | InitEmbeddedEngine | Load and initialize all needed modules.
 | InitLog4NetConfig | Setup log4net configuration settings.
Public method | LoadUserAssembly | Loads additional user assembly and registers it in MEF.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SatisfyImportsOnce | Composes the specified part by using the specified composition service, with recomposition disabled.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetComponentInstanceT | Try to get an instance of the requested type.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

EmbeddedAppLoader Class
VisualComponents.Create3D Namespace


EmbeddedAppLoader.AddExportedValue(T) Method

EmbeddedAppLoaderAddExportedValueT Method

Creates a part from the specified value and registeres it in the MEF.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void AddExportedValue<T>(
    T exportedValue
)

public:
generic<typename T>
void AddExportedValue(
    T exportedValue
)

Parameters

exportedValue
Type: T
The value to add.

Type Parameters

T
The type of the new part.
See Also

Reference

EmbeddedAppLoader Class
VisualComponents.Create3D Namespace


EmbeddedAppLoader.CleanupEngine Method

EmbeddedAppLoaderCleanupEngine Method

Cleanup the engine.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CleanupEngine()
public:
void CleanupEngine()
Remarks
It's used for testing purposes only.
See Also

Reference

EmbeddedAppLoader Class
VisualComponents.Create3D Namespace


EmbeddedAppLoader.GetAllComponentInstances Method

EmbeddedAppLoaderGetAllComponentInstances Method

Returns all instances of the requested type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<Object> GetAllComponentInstances(
    Type serviceType
)
public:
IEnumerable<Object^>^ GetAllComponentInstances(
    Type^ serviceType
)

Parameters

serviceType
Type: SystemType
service type

Return Value

Type: IEnumerableObject
instances of the requested type
See Also

Reference

EmbeddedAppLoader Class
VisualComponents.Create3D Namespace


EmbeddedAppLoader.GetComponentInstance Method

EmbeddedAppLoaderGetComponentInstance Method

Returns instance of the requested type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object GetComponentInstance(
    Type type,
    string key
)
public:
Object^ GetComponentInstance(
    Type^ type,
    String^ key
)

Parameters

type
Type: SystemType
service type
key
Type: SystemString
key

Return Value

Type: Object
instance of the requested type
See Also

Reference

EmbeddedAppLoader Class
VisualComponents.Create3D Namespace


EmbeddedAppLoader.GetExport(T) Method

EmbeddedAppLoaderGetExportT Method

Returns the export with the contract name derived from the specified type parameter. If there is not exactly one matching export, an exception is thrown.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Lazy<T> GetExport<T>()
where T : class

public:
generic<typename T>
where T : ref class
Lazy<T>^ GetExport()

Type Parameters

T
The type parameter of the System.Lazy object to return. The contract name is also derived from this type parameter.

Return Value

Type: LazyT
The export with the contract name derived from the specified type parameter.
See Also

Reference

EmbeddedAppLoader Class
VisualComponents.Create3D Namespace


EmbeddedAppLoader.InitApplication Method

EmbeddedAppLoaderInitApplication Method

Loads core modules, constructs them and loads the user config settings

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IApplication InitApplication(
    ILog log
)
public:
IApplication^ InitApplication(
    ILog^ log
)

Parameters

log
Type: ILog
instance of ILog.

Return Value

Type: IApplication
The instance of the application.
See Also

Reference

EmbeddedAppLoader Class
VisualComponents.Create3D Namespace


EmbeddedAppLoader.InitEmbeddedEngine Method

EmbeddedAppLoaderInitEmbeddedEngine Method

Load and initialize all needed modules.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitEmbeddedEngine(
    ILog log
)
public:
void InitEmbeddedEngine(
    ILog^ log
)

Parameters

log
Type: ILog
the logger instance
See Also

Reference

EmbeddedAppLoader Class
VisualComponents.Create3D Namespace


EmbeddedAppLoader.InitLog4NetConfig Method

EmbeddedAppLoaderInitLog4NetConfig Method

Setup log4net configuration settings.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void InitLog4NetConfig()
public:
static void InitLog4NetConfig()
See Also

Reference

EmbeddedAppLoader Class
VisualComponents.Create3D Namespace


EmbeddedAppLoader.LoadUserAssembly Method

EmbeddedAppLoaderLoadUserAssembly Method

Loads additional user assembly and registers it in MEF.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void LoadUserAssembly(
    ILog log,
    string userAssembly
)
public:
void LoadUserAssembly(
    ILog^ log,
    String^ userAssembly
)

Parameters

log
Type: ILog
instance of ILog.
userAssembly
Type: SystemString
additional assebly name which should be loaded.
See Also

Reference

EmbeddedAppLoader Class
VisualComponents.Create3D Namespace


EmbeddedAppLoader.SatisfyImportsOnce Method

EmbeddedAppLoaderSatisfyImportsOnce Method

Composes the specified part by using the specified composition service, with recomposition disabled.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SatisfyImportsOnce(
    Object attributedPart
)
public:
void SatisfyImportsOnce(
    Object^ attributedPart
)

Parameters

attributedPart
Type: SystemObject
The part to compose.
See Also

Reference

EmbeddedAppLoader Class
VisualComponents.Create3D Namespace


EmbeddedAppLoader.TryGetComponentInstance(T) Method

EmbeddedAppLoaderTryGetComponentInstanceT Method

Try to get an instance of the requested type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public T TryGetComponentInstance<T>()
where T : class

public:
generic<typename T>
where T : ref class
T TryGetComponentInstance()

Type Parameters

T
The requested type.

Return Value

Type: T
instance of the requested type.
See Also

Reference

EmbeddedAppLoader Class
VisualComponents.Create3D Namespace


EulerRotationOrder Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum EulerRotationOrder
public enum class EulerRotationOrder
Members
Member name | Value | Description
XYZ | 0 |
XZY | 1 |
YXZ | 2 |
YZX | 3 |
ZXY | 4 |
ZYX | 5 |
See Also

Reference

VisualComponents.Create3D Namespace


ExecuteCommandResult Enumeration

result type of executing command

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ExecuteCommandResult
public enum class ExecuteCommandResult
Members
Member name | Value | Description
Completed | 0 |
Failed | 1 |
See Also

Reference

VisualComponents.Create3D Namespace


ExecutingAssemblyInfo Class

Gets the application assembly info.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DExecutingAssemblyInfo

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class ExecutingAssemblyInfo
public ref class ExecutingAssemblyInfo abstract sealed

The ExecutingAssemblyInfo type exposes the following members.

Properties
Name | Description
AssemblyBuildVersion | Gets the assembly build version.
AssemblyFileVersion | Returns a FileVersionInfo representing the version information associated with the application.
ClipboardVersion | Gets formatted application version for the clipboard.
EntryAssemblyName | Gets the process executable in the default application domain. In other application domains, this is the first executable that was executed by System.AppDomain.ExecuteAssembly(System.String).
ExecutingAssemblyLocation | gets the assembly location path.
ProductBuildDate | Gets product build date.
ProductVersion | Gets the product version.
TheAssemblyVersion | Gets the assembly file version.
Top
See Also

Reference

VisualComponents.Create3D Namespace


ExecutingAssemblyInfo Properties

The ExecutingAssemblyInfo type exposes the following members.

Properties
Name | Description
AssemblyBuildVersion | Gets the assembly build version.
AssemblyFileVersion | Returns a FileVersionInfo representing the version information associated with the application.
ClipboardVersion | Gets formatted application version for the clipboard.
EntryAssemblyName | Gets the process executable in the default application domain. In other application domains, this is the first executable that was executed by System.AppDomain.ExecuteAssembly(System.String).
ExecutingAssemblyLocation | gets the assembly location path.
ProductBuildDate | Gets product build date.
ProductVersion | Gets the product version.
TheAssemblyVersion | Gets the assembly file version.
Top
See Also

Reference

ExecutingAssemblyInfo Class
VisualComponents.Create3D Namespace


ExecutingAssemblyInfo.AssemblyBuildVersion Property

ExecutingAssemblyInfoAssemblyBuildVersion Property

Gets the assembly build version.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string AssemblyBuildVersion { get; }
public:
static property String^ AssemblyBuildVersion {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ExecutingAssemblyInfo Class
VisualComponents.Create3D Namespace


ExecutingAssemblyInfo.AssemblyFileVersion Property

ExecutingAssemblyInfoAssemblyFileVersion Property

Returns a FileVersionInfo representing the version information associated with the application.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static FileVersionInfo AssemblyFileVersion { get; }
public:
static property FileVersionInfo^ AssemblyFileVersion {
    FileVersionInfo^ get ();
}

Property Value

Type: FileVersionInfo
See Also

Reference

ExecutingAssemblyInfo Class
VisualComponents.Create3D Namespace


ExecutingAssemblyInfo.ClipboardVersion Property

ExecutingAssemblyInfoClipboardVersion Property

Gets formatted application version for the clipboard.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string ClipboardVersion { get; }
public:
static property String^ ClipboardVersion {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ExecutingAssemblyInfo Class
VisualComponents.Create3D Namespace


ExecutingAssemblyInfo.EntryAssemblyName Property

ExecutingAssemblyInfoEntryAssemblyName Property

Gets the process executable in the default application domain. In other application domains, this is the first executable that was executed by System.AppDomain.ExecuteAssembly(System.String).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string EntryAssemblyName { get; }
public:
static property String^ EntryAssemblyName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ExecutingAssemblyInfo Class
VisualComponents.Create3D Namespace


ExecutingAssemblyInfo.ExecutingAssemblyLocation Property

ExecutingAssemblyInfoExecutingAssemblyLocation Property

gets the assembly location path.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string ExecutingAssemblyLocation { get; }
public:
static property String^ ExecutingAssemblyLocation {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ExecutingAssemblyInfo Class
VisualComponents.Create3D Namespace


ExecutingAssemblyInfo.ProductBuildDate Property

ExecutingAssemblyInfoProductBuildDate Property

Gets product build date.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DateTime ProductBuildDate { get; }
public:
static property DateTime ProductBuildDate {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

ExecutingAssemblyInfo Class
VisualComponents.Create3D Namespace


ExecutingAssemblyInfo.ProductVersion Property

ExecutingAssemblyInfoProductVersion Property

Gets the product version.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string ProductVersion { get; }
public:
static property String^ ProductVersion {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ExecutingAssemblyInfo Class
VisualComponents.Create3D Namespace


ExecutingAssemblyInfo.TheAssemblyVersion Property

ExecutingAssemblyInfoTheAssemblyVersion Property

Gets the assembly file version.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string TheAssemblyVersion { get; }
public:
static property String^ TheAssemblyVersion {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ExecutingAssemblyInfo Class
VisualComponents.Create3D Namespace


ExponentialDistributionParameters Class

Exponential distribution parameters
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DExponentialDistributionParameters

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ExponentialDistributionParameters : IDistributionParameters
public ref class ExponentialDistributionParameters : IDistributionParameters

The ExponentialDistributionParameters type exposes the following members.

Constructors
 | Name | Description
Public method | ExponentialDistributionParameters | Initializes a new instance of the ExponentialDistributionParameters class
Public method | ExponentialDistributionParameters(IProperty) | Initializes a new instance of the ExponentialDistributionParameters class
Top
Properties
 | Name | Description
Public property | DistributionType |
Public property | Expression |
Public property | Lambda | Mean λ value
Public property | Property |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ExponentialDistributionParameters Constructor

Overload List
 | Name | Description
Public method | ExponentialDistributionParameters | Initializes a new instance of the ExponentialDistributionParameters class
Public method | ExponentialDistributionParameters(IProperty) | Initializes a new instance of the ExponentialDistributionParameters class
Top
See Also

Reference

ExponentialDistributionParameters Class
VisualComponents.Create3D Namespace


ExponentialDistributionParameters Constructor

Initializes a new instance of the ExponentialDistributionParameters class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ExponentialDistributionParameters()
public:
ExponentialDistributionParameters()
See Also

Reference

ExponentialDistributionParameters Class
ExponentialDistributionParameters Overload
VisualComponents.Create3D Namespace


ExponentialDistributionParameters Constructor (IProperty)

Initializes a new instance of the ExponentialDistributionParameters class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ExponentialDistributionParameters(
    IProperty property
)
public:
ExponentialDistributionParameters(
    IProperty^ property
)

Parameters

property
Type: VisualComponents.Create3DIProperty
See Also

Reference

ExponentialDistributionParameters Class
ExponentialDistributionParameters Overload
VisualComponents.Create3D Namespace


ExponentialDistributionParameters Properties

The ExponentialDistributionParameters type exposes the following members.

Properties
 | Name | Description
Public property | DistributionType |
Public property | Expression |
Public property | Lambda | Mean λ value
Public property | Property |
Top
See Also

Reference

ExponentialDistributionParameters Class
VisualComponents.Create3D Namespace


ExponentialDistributionParameters.DistributionType Property

ExponentialDistributionParametersDistributionType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DistributionType DistributionType { get; }
public:
virtual property DistributionType DistributionType {
    DistributionType get () sealed;
}

Property Value

Type: DistributionType

Implements

IDistributionParametersDistributionType
See Also

Reference

ExponentialDistributionParameters Class
VisualComponents.Create3D Namespace


ExponentialDistributionParameters.Expression Property

ExponentialDistributionParametersExpression Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Expression { get; }
public:
virtual property String^ Expression {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IDistributionParametersExpression
See Also

Reference

ExponentialDistributionParameters Class
VisualComponents.Create3D Namespace


ExponentialDistributionParameters.Lambda Property

ExponentialDistributionParametersLambda Property

Mean λ value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Lambda { get; set; }
public:
property double Lambda {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ExponentialDistributionParameters Class
VisualComponents.Create3D Namespace


ExponentialDistributionParameters.Property Property

ExponentialDistributionParametersProperty Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty Property { get; }
public:
property IProperty^ Property {
    IProperty^ get ();
}

Property Value

Type: IProperty
See Also

Reference

ExponentialDistributionParameters Class
VisualComponents.Create3D Namespace


ExponentialDistributionParameters Methods

The ExponentialDistributionParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ExponentialDistributionParameters Class
VisualComponents.Create3D Namespace


ExpressionFunction Structure

Function details struct.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct ExpressionFunction
public value class ExpressionFunction

The ExpressionFunction type exposes the following members.

Properties
 | Name | Description
Public property | FunctionType | Function category.
Public property | Name | Name of function.
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks

This is used in objects implementing IExpressionContext to list all available functions.

See Also

Reference

VisualComponents.Create3D Namespace


ExpressionFunction Properties

The ExpressionFunction type exposes the following members.

Properties
 | Name | Description
Public property | FunctionType | Function category.
Public property | Name | Name of function.
Top
See Also

Reference

ExpressionFunction Structure
VisualComponents.Create3D Namespace


ExpressionFunction.FunctionType Property

ExpressionFunctionFunctionType Property

Function category.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FunctionType FunctionType { get; set; }
public:
property FunctionType FunctionType {
    FunctionType get ();
    void set (FunctionType value);
}

Property Value

Type: FunctionType
See Also

Reference

ExpressionFunction Structure
VisualComponents.Create3D Namespace


ExpressionFunction.Name Property

ExpressionFunctionName Property

Name of function.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; set; }
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ExpressionFunction Structure
VisualComponents.Create3D Namespace


ExpressionFunction Methods

The ExpressionFunction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ExpressionFunction Structure
VisualComponents.Create3D Namespace


FacePointAndFirstDerivate Structure

Face point and first derivate

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct FacePointAndFirstDerivate
public value class FacePointAndFirstDerivate

The FacePointAndFirstDerivate type exposes the following members.

Constructors
 | Name | Description
Public method | FacePointAndFirstDerivate | Initializes a new instance of the FacePointAndFirstDerivate class
Top
Properties
 | Name | Description
Public property | FirstDerivateU |
Public property | FirstDerivateV |
Public property | Position |
Top
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides ValueTypeEquals(Object).)
 | Equals(FacePointAndFirstDerivate, FacePointAndFirstDerivate) |
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Equality |
Inequality |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


FacePointAndFirstDerivate Constructor

Initializes a new instance of the FacePointAndFirstDerivate class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FacePointAndFirstDerivate(
    Vector3 position,
    Vector3 firstDerivateU,
    Vector3 firstDerivateV
)
public:
FacePointAndFirstDerivate(
    Vector3 position,
    Vector3 firstDerivateU,
    Vector3 firstDerivateV
)

Parameters

position
Type: VisualComponents.Create3DVector3
firstDerivateU
Type: VisualComponents.Create3DVector3
firstDerivateV
Type: VisualComponents.Create3DVector3
See Also

Reference

FacePointAndFirstDerivate Structure
VisualComponents.Create3D Namespace


FacePointAndFirstDerivate Properties

The FacePointAndFirstDerivate type exposes the following members.

Properties
 | Name | Description
Public property | FirstDerivateU |
Public property | FirstDerivateV |
Public property | Position |
Top
See Also

Reference

FacePointAndFirstDerivate Structure
VisualComponents.Create3D Namespace


FacePointAndFirstDerivate.FirstDerivateU Property

FacePointAndFirstDerivateFirstDerivateU Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 FirstDerivateU { get; set; }
public:
property Vector3 FirstDerivateU {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

FacePointAndFirstDerivate Structure
VisualComponents.Create3D Namespace


FacePointAndFirstDerivate.FirstDerivateV Property

FacePointAndFirstDerivateFirstDerivateV Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 FirstDerivateV { get; set; }
public:
property Vector3 FirstDerivateV {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

FacePointAndFirstDerivate Structure
VisualComponents.Create3D Namespace


FacePointAndFirstDerivate.Position Property

FacePointAndFirstDerivatePosition Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 Position { get; set; }
public:
property Vector3 Position {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

FacePointAndFirstDerivate Structure
VisualComponents.Create3D Namespace


FacePointAndFirstDerivate Methods

The FacePointAndFirstDerivate type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | (Overrides ValueTypeEquals(Object).)
 | Equals(FacePointAndFirstDerivate, FacePointAndFirstDerivate) |
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

FacePointAndFirstDerivate Structure
VisualComponents.Create3D Namespace


FacePointAndFirstDerivate.Equals Method

FacePointAndFirstDerivateEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ValueTypeEquals(Object).)
 | Equals(FacePointAndFirstDerivate, FacePointAndFirstDerivate) |
Top
See Also

Reference

FacePointAndFirstDerivate Structure
VisualComponents.Create3D Namespace


FacePointAndFirstDerivate.Equals Method (Object)

FacePointAndFirstDerivateEquals Method (Object)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.FacePointAndFirstDerivate.Equals(System.Object)"]

See Also

Reference

FacePointAndFirstDerivate Structure
Equals Overload
VisualComponents.Create3D Namespace


FacePointAndFirstDerivate.Equals Method (FacePointAndFirstDerivate, FacePointAndFirstDerivate)

FacePointAndFirstDerivateEquals Method (FacePointAndFirstDerivate, FacePointAndFirstDerivate)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool Equals(
    FacePointAndFirstDerivate value1,
    FacePointAndFirstDerivate value2
)
public:
static bool Equals(
    FacePointAndFirstDerivate value1,
    FacePointAndFirstDerivate value2
)

Parameters

value1
Type: VisualComponents.Create3DFacePointAndFirstDerivate
value2
Type: VisualComponents.Create3DFacePointAndFirstDerivate

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.FacePointAndFirstDerivate.Equals(VisualComponents.Create3D.FacePointAndFirstDerivate,VisualComponents.Create3D.FacePointAndFirstDerivate)"]

See Also

Reference

FacePointAndFirstDerivate Structure
Equals Overload
VisualComponents.Create3D Namespace


FacePointAndFirstDerivate.GetHashCode Method

FacePointAndFirstDerivateGetHashCode Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.FacePointAndFirstDerivate.GetHashCode"]

See Also

Reference

FacePointAndFirstDerivate Structure
VisualComponents.Create3D Namespace


FacePointAndFirstDerivate Operators

The FacePointAndFirstDerivate type exposes the following members.

Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

FacePointAndFirstDerivate Structure
VisualComponents.Create3D Namespace


FacePointAndFirstDerivate.Equality Operator

FacePointAndFirstDerivateEquality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    FacePointAndFirstDerivate value1,
    FacePointAndFirstDerivate value2
)
public:
static bool operator ==(
    FacePointAndFirstDerivate value1,
    FacePointAndFirstDerivate value2
)

Parameters

value1
Type: VisualComponents.Create3DFacePointAndFirstDerivate
value2
Type: VisualComponents.Create3DFacePointAndFirstDerivate

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.FacePointAndFirstDerivate.op_Equality(VisualComponents.Create3D.FacePointAndFirstDerivate,VisualComponents.Create3D.FacePointAndFirstDerivate)"]

See Also

Reference

FacePointAndFirstDerivate Structure
VisualComponents.Create3D Namespace


FacePointAndFirstDerivate.Inequality Operator

FacePointAndFirstDerivateInequality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    FacePointAndFirstDerivate value1,
    FacePointAndFirstDerivate value2
)
public:
static bool operator !=(
    FacePointAndFirstDerivate value1,
    FacePointAndFirstDerivate value2
)

Parameters

value1
Type: VisualComponents.Create3DFacePointAndFirstDerivate
value2
Type: VisualComponents.Create3DFacePointAndFirstDerivate

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.FacePointAndFirstDerivate.op_Inequality(VisualComponents.Create3D.FacePointAndFirstDerivate,VisualComponents.Create3D.FacePointAndFirstDerivate)"]

See Also

Reference

FacePointAndFirstDerivate Structure
VisualComponents.Create3D Namespace


FacePointAndSecondDerivate Structure

Face point and second derivate

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct FacePointAndSecondDerivate
public value class FacePointAndSecondDerivate

The FacePointAndSecondDerivate type exposes the following members.

Constructors
 | Name | Description
Public method | FacePointAndSecondDerivate | Initializes a new instance of the FacePointAndSecondDerivate class
Top
Properties
 | Name | Description
Public property | FirstDerivateU |
Public property | FirstDerivateV |
Public property | Position |
Public property | SecondDerivateUU |
Public property | SecondDerivateUV |
Public property | SecondDerivateVV |
Top
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides ValueTypeEquals(Object).)
 | Equals(FacePointAndSecondDerivate, FacePointAndSecondDerivate) |
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Equality |
Inequality |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


FacePointAndSecondDerivate Constructor

Initializes a new instance of the FacePointAndSecondDerivate class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FacePointAndSecondDerivate(
    Vector3 position,
    Vector3 firstDerivateU,
    Vector3 firstDerivateV,
    Vector3 secondDerivateUV,
    Vector3 secondDerivateUU,
    Vector3 secondDerivateVV
)
public:
FacePointAndSecondDerivate(
    Vector3 position,
    Vector3 firstDerivateU,
    Vector3 firstDerivateV,
    Vector3 secondDerivateUV,
    Vector3 secondDerivateUU,
    Vector3 secondDerivateVV
)

Parameters

position
Type: VisualComponents.Create3DVector3
firstDerivateU
Type: VisualComponents.Create3DVector3
firstDerivateV
Type: VisualComponents.Create3DVector3
secondDerivateUV
Type: VisualComponents.Create3DVector3
secondDerivateUU
Type: VisualComponents.Create3DVector3
secondDerivateVV
Type: VisualComponents.Create3DVector3
See Also

Reference

FacePointAndSecondDerivate Structure
VisualComponents.Create3D Namespace


FacePointAndSecondDerivate Properties

The FacePointAndSecondDerivate type exposes the following members.

Properties
 | Name | Description
Public property | FirstDerivateU |
Public property | FirstDerivateV |
Public property | Position |
Public property | SecondDerivateUU |
Public property | SecondDerivateUV |
Public property | SecondDerivateVV |
Top
See Also

Reference

FacePointAndSecondDerivate Structure
VisualComponents.Create3D Namespace


FacePointAndSecondDerivate.FirstDerivateU Property

FacePointAndSecondDerivateFirstDerivateU Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 FirstDerivateU { get; set; }
public:
property Vector3 FirstDerivateU {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

FacePointAndSecondDerivate Structure
VisualComponents.Create3D Namespace


FacePointAndSecondDerivate.FirstDerivateV Property

FacePointAndSecondDerivateFirstDerivateV Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 FirstDerivateV { get; set; }
public:
property Vector3 FirstDerivateV {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

FacePointAndSecondDerivate Structure
VisualComponents.Create3D Namespace


FacePointAndSecondDerivate.Position Property

FacePointAndSecondDerivatePosition Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 Position { get; set; }
public:
property Vector3 Position {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

FacePointAndSecondDerivate Structure
VisualComponents.Create3D Namespace


FacePointAndSecondDerivate.SecondDerivateUU Property

FacePointAndSecondDerivateSecondDerivateUU Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 SecondDerivateUU { get; set; }
public:
property Vector3 SecondDerivateUU {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

FacePointAndSecondDerivate Structure
VisualComponents.Create3D Namespace


FacePointAndSecondDerivate.SecondDerivateUV Property

FacePointAndSecondDerivateSecondDerivateUV Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 SecondDerivateUV { get; set; }
public:
property Vector3 SecondDerivateUV {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

FacePointAndSecondDerivate Structure
VisualComponents.Create3D Namespace


FacePointAndSecondDerivate.SecondDerivateVV Property

FacePointAndSecondDerivateSecondDerivateVV Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 SecondDerivateVV { get; set; }
public:
property Vector3 SecondDerivateVV {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

FacePointAndSecondDerivate Structure
VisualComponents.Create3D Namespace


FacePointAndSecondDerivate Methods

The FacePointAndSecondDerivate type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | (Overrides ValueTypeEquals(Object).)
 | Equals(FacePointAndSecondDerivate, FacePointAndSecondDerivate) |
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

FacePointAndSecondDerivate Structure
VisualComponents.Create3D Namespace


FacePointAndSecondDerivate.Equals Method

FacePointAndSecondDerivateEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ValueTypeEquals(Object).)
 | Equals(FacePointAndSecondDerivate, FacePointAndSecondDerivate) |
Top
See Also

Reference

FacePointAndSecondDerivate Structure
VisualComponents.Create3D Namespace


FacePointAndSecondDerivate.Equals Method (Object)

FacePointAndSecondDerivateEquals Method (Object)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.FacePointAndSecondDerivate.Equals(System.Object)"]

See Also

Reference

FacePointAndSecondDerivate Structure
Equals Overload
VisualComponents.Create3D Namespace


FacePointAndSecondDerivate.Equals Method (FacePointAndSecondDerivate, FacePointAndSecondDerivate)

FacePointAndSecondDerivateEquals Method (FacePointAndSecondDerivate, FacePointAndSecondDerivate)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool Equals(
    FacePointAndSecondDerivate value1,
    FacePointAndSecondDerivate value2
)
public:
static bool Equals(
    FacePointAndSecondDerivate value1,
    FacePointAndSecondDerivate value2
)

Parameters

value1
Type: VisualComponents.Create3DFacePointAndSecondDerivate
value2
Type: VisualComponents.Create3DFacePointAndSecondDerivate

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.FacePointAndSecondDerivate.Equals(VisualComponents.Create3D.FacePointAndSecondDerivate,VisualComponents.Create3D.FacePointAndSecondDerivate)"]

See Also

Reference

FacePointAndSecondDerivate Structure
Equals Overload
VisualComponents.Create3D Namespace


FacePointAndSecondDerivate.GetHashCode Method

FacePointAndSecondDerivateGetHashCode Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.FacePointAndSecondDerivate.GetHashCode"]

See Also

Reference

FacePointAndSecondDerivate Structure
VisualComponents.Create3D Namespace


FacePointAndSecondDerivate Operators

The FacePointAndSecondDerivate type exposes the following members.

Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

FacePointAndSecondDerivate Structure
VisualComponents.Create3D Namespace


FacePointAndSecondDerivate.Equality Operator

FacePointAndSecondDerivateEquality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    FacePointAndSecondDerivate value1,
    FacePointAndSecondDerivate value2
)
public:
static bool operator ==(
    FacePointAndSecondDerivate value1,
    FacePointAndSecondDerivate value2
)

Parameters

value1
Type: VisualComponents.Create3DFacePointAndSecondDerivate
value2
Type: VisualComponents.Create3DFacePointAndSecondDerivate

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.FacePointAndSecondDerivate.op_Equality(VisualComponents.Create3D.FacePointAndSecondDerivate,VisualComponents.Create3D.FacePointAndSecondDerivate)"]

See Also

Reference

FacePointAndSecondDerivate Structure
VisualComponents.Create3D Namespace


FacePointAndSecondDerivate.Inequality Operator

FacePointAndSecondDerivateInequality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    FacePointAndSecondDerivate value1,
    FacePointAndSecondDerivate value2
)
public:
static bool operator !=(
    FacePointAndSecondDerivate value1,
    FacePointAndSecondDerivate value2
)

Parameters

value1
Type: VisualComponents.Create3DFacePointAndSecondDerivate
value2
Type: VisualComponents.Create3DFacePointAndSecondDerivate

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.FacePointAndSecondDerivate.op_Inequality(VisualComponents.Create3D.FacePointAndSecondDerivate,VisualComponents.Create3D.FacePointAndSecondDerivate)"]

See Also

Reference

FacePointAndSecondDerivate Structure
VisualComponents.Create3D Namespace


FaceType Enumeration

Type of the geometry set

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum FaceType
public enum class FaceType
Members
Member name | Value | Description
Tessellated | 0 | tessellation face without mathematical representation
Planar | 1 | mathematical planar face
Nurbs | 2 |
Offset | 3 | mathematical nurbs offset face
See Also

Reference

VisualComponents.Create3D Namespace


Fbx Enumeration

ASCII: from 7100 to 7400. Binary: all.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum Fbx
public enum class Fbx
Members
Member name | Value | Description
FBX | 0 |
See Also

Reference

VisualComponents.Create3D Namespace


FeatureHierarchyChange Class

PropertyChange contains information about a change of a individual property value.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DChange
VisualComponents.Create3DFeatureHierarchyChange

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class FeatureHierarchyChange : Change
public ref class FeatureHierarchyChange sealed : public Change

The FeatureHierarchyChange type exposes the following members.

Constructors
 | Name | Description
Public method | FeatureHierarchyChange | Constructor.
Top
Properties
 | Name | Description
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from Change.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


FeatureHierarchyChange Constructor

Constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FeatureHierarchyChange(
    IFeature relocatedFeature,
    IFeature newParent,
    int newNodeIndex,
    Matrix newTransformation
)
public:
FeatureHierarchyChange(
    IFeature^ relocatedFeature,
    IFeature^ newParent,
    int newNodeIndex,
    Matrix newTransformation
)

Parameters

relocatedFeature
Type: VisualComponents.Create3DIFeature
Feature that was relocated
newParent
Type: VisualComponents.Create3DIFeature
New parent
newNodeIndex
Type: SystemInt32
New node index
newTransformation
Type: VisualComponents.Create3DMatrix
New position
See Also

Reference

FeatureHierarchyChange Class
VisualComponents.Create3D Namespace


FeatureHierarchyChange Properties

The FeatureHierarchyChange type exposes the following members.

Properties
 | Name | Description
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Top
See Also

Reference

FeatureHierarchyChange Class
VisualComponents.Create3D Namespace


FeatureHierarchyChange Methods

The FeatureHierarchyChange type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from Change.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

FeatureHierarchyChange Class
VisualComponents.Create3D Namespace


FeatureHierarchyChangedEventArgs Class

Feature hierarchy changed event arguments. It derives from EventArgs
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DFeatureHierarchyChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class FeatureHierarchyChangedEventArgs : EventArgs
public ref class FeatureHierarchyChangedEventArgs : public EventArgs

The FeatureHierarchyChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | FeatureHierarchyChangedEventArgs | Initializes a new instance of the FeatureHierarchyChangedEventArgs class
Top
Properties
 | Name | Description
Public property | ChangeType |
Public property | Node1 |
Public property | Node2 |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


FeatureHierarchyChangedEventArgs Constructor

Initializes a new instance of the FeatureHierarchyChangedEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FeatureHierarchyChangedEventArgs(
    HierarchyChangeType changeType,
    IFeature node1,
    IFeature node2
)
public:
FeatureHierarchyChangedEventArgs(
    HierarchyChangeType changeType,
    IFeature^ node1,
    IFeature^ node2
)

Parameters

changeType
Type: VisualComponents.Create3DHierarchyChangeType
node1
Type: VisualComponents.Create3DIFeature
node2
Type: VisualComponents.Create3DIFeature
See Also

Reference

FeatureHierarchyChangedEventArgs Class
VisualComponents.Create3D Namespace


FeatureHierarchyChangedEventArgs Properties

The FeatureHierarchyChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ChangeType |
Public property | Node1 |
Public property | Node2 |
Top
See Also

Reference

FeatureHierarchyChangedEventArgs Class
VisualComponents.Create3D Namespace


FeatureHierarchyChangedEventArgs.ChangeType Property

FeatureHierarchyChangedEventArgsChangeType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public HierarchyChangeType ChangeType { get; set; }
public:
property HierarchyChangeType ChangeType {
    HierarchyChangeType get ();
    void set (HierarchyChangeType value);
}

Property Value

Type: HierarchyChangeType
See Also

Reference

FeatureHierarchyChangedEventArgs Class
VisualComponents.Create3D Namespace


FeatureHierarchyChangedEventArgs.Node1 Property

FeatureHierarchyChangedEventArgsNode1 Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IFeature Node1 { get; set; }
public:
property IFeature^ Node1 {
    IFeature^ get ();
    void set (IFeature^ value);
}

Property Value

Type: IFeature
See Also

Reference

FeatureHierarchyChangedEventArgs Class
VisualComponents.Create3D Namespace


FeatureHierarchyChangedEventArgs.Node2 Property

FeatureHierarchyChangedEventArgsNode2 Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IFeature Node2 { get; set; }
public:
property IFeature^ Node2 {
    IFeature^ get ();
    void set (IFeature^ value);
}

Property Value

Type: IFeature
See Also

Reference

FeatureHierarchyChangedEventArgs Class
VisualComponents.Create3D Namespace


FeatureHierarchyChangedEventArgs Methods

The FeatureHierarchyChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

FeatureHierarchyChangedEventArgs Class
VisualComponents.Create3D Namespace


FeatureMatch Enumeration

Product feature comparison result type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum FeatureMatch
public enum class FeatureMatch
Members
Member name | Value | Description
SuperSetMatch | 0 | Product key has fewer features than needed.
ExactMatch | 1 | Product key has exact features needed.
ReverseSuperSetMatch | 2 | Product key has more features than needed.
NoMatch | 3 | Could not determine product key or required features.
See Also

Reference

VisualComponents.Create3D Namespace


FeatureOperationLevel Enumeration

Some actions require to specify a level of details when working with features

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum FeatureOperationLevel
public enum class FeatureOperationLevel
Members
Member name | Value | Description
Set | 0 | geometry set level IGeometrySet
Face | 1 | single face, logically connected triangles
Faces | 2 | multiple faces
Feature | 3 | all sets under feature (if any)
Node | 4 | All sets in node
Component | 5 | All sets in component Component
See Also

Reference

VisualComponents.Create3D Namespace


FeatureTreeChangedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DFeatureTreeChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class FeatureTreeChangedEventArgs : EventArgs
public ref class FeatureTreeChangedEventArgs : public EventArgs

The FeatureTreeChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | FeatureTreeChangedEventArgs | Initializes a new instance of the FeatureTreeChangedEventArgs class
Top
Properties
 | Name | Description
Public property | Component |
Public property | Node |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


FeatureTreeChangedEventArgs Constructor

Initializes a new instance of the FeatureTreeChangedEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FeatureTreeChangedEventArgs(
    ISimComponent component,
    ISimNode node
)
public:
FeatureTreeChangedEventArgs(
    ISimComponent^ component,
    ISimNode^ node
)

Parameters

component
Type: VisualComponents.Create3DISimComponent
node
Type: VisualComponents.Create3DISimNode
See Also

Reference

FeatureTreeChangedEventArgs Class
VisualComponents.Create3D Namespace


FeatureTreeChangedEventArgs Properties

The FeatureTreeChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Component |
Public property | Node |
Top
See Also

Reference

FeatureTreeChangedEventArgs Class
VisualComponents.Create3D Namespace


FeatureTreeChangedEventArgs.Component Property

FeatureTreeChangedEventArgsComponent Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimComponent Component { get; }
public:
property ISimComponent^ Component {
    ISimComponent^ get ();
}

Property Value

Type: ISimComponent
See Also

Reference

FeatureTreeChangedEventArgs Class
VisualComponents.Create3D Namespace


FeatureTreeChangedEventArgs.Node Property

FeatureTreeChangedEventArgsNode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimNode Node { get; }
public:
property ISimNode^ Node {
    ISimNode^ get ();
}

Property Value

Type: ISimNode
See Also

Reference

FeatureTreeChangedEventArgs Class
VisualComponents.Create3D Namespace


FeatureTreeChangedEventArgs Methods

The FeatureTreeChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

FeatureTreeChangedEventArgs Class
VisualComponents.Create3D Namespace


FeatureTreeStructure Enumeration

CAD import feature tree reading structure

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum FeatureTreeStructure
public enum class FeatureTreeStructure
Members
Member name | Value | Description
Full | 0 | Every assembly part will be store in a feature creating large number of features
Optimized | 1 | Reader will find the best way to store assembly parts into features creating an ideal number of features
Collapsed | 2 | Only feature will be created
See Also

Reference

VisualComponents.Create3D Namespace


FeatureType Enumeration

Different features available for creating components

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum FeatureType
public enum class FeatureType
Members
Member name | Value | Description
Invalid | 0 | Invalid value
Root | 1 | Root feature
Block | 2 | A rectangular box
Geometry | 3 | Geometry object
Frame | 4 | Frame object
Transform | 5 | Transformation expression
Plane | 6 | Plane object
Sphere | 7 | Shere object
Wedge | 8 | Wedge-like shape object
Cylinder | 9 | Cylinder object
Text | 10 | Text object
Cone | 11 | Cone or frustum object
Resolve | 12 | Object that revolves all polylines in a feature's sub features around the Z axis
Extrude | 13 | Object that extrudes all geometries in the feature's sub tree
AngularClone | 14 | Object that clones all a feature's sub features the specified number of times, rotating each copy about the Z axis
LinearClone | 15 | Object that generates clones of all sub features, translating each by a specified amount
Switch | 16 | Object that selects one sub tree for further evaluation and ignores the rest
Mirror | 17 | Object that generates a mirror image of all sub features through the Y-Z plane
Boolean | 18 | Object that generates the boolean result of the 2 child features
Python | 19 | Object that uses a custom Python script to generate the geometry
See Also

Reference

VisualComponents.Create3D Namespace


FileSystemHelpers Class

File system helpers
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DFileSystemHelpers

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class FileSystemHelpers
public ref class FileSystemHelpers abstract sealed

The FileSystemHelpers type exposes the following members.

Methods
Name | Description
SizeSuffix | Gets file size with suffix. E.g. "341 MB"
Top
See Also

Reference

VisualComponents.Create3D Namespace


FileSystemHelpers Methods

The FileSystemHelpers type exposes the following members.

Methods
Name | Description
SizeSuffix | Gets file size with suffix. E.g. "341 MB"
Top
See Also

Reference

FileSystemHelpers Class
VisualComponents.Create3D Namespace


FileSystemHelpers.SizeSuffix Method

FileSystemHelpersSizeSuffix Method

Gets file size with suffix. E.g. "341 MB"

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string SizeSuffix(
    long value,
    int decimalPlaces = 1
)
public:
static String^ SizeSuffix(
    long long value,
    int decimalPlaces = 1
)

Parameters

value
Type: SystemInt64
value to convert
decimalPlaces (Optional)
Type: SystemInt32
how many decimal places

Return Value

Type: String
Formatted string
See Also

Reference

FileSystemHelpers Class
VisualComponents.Create3D Namespace


FloorSizeChangedEventArgs Class

Returns data from IFloor.FloorSizeChanged events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DFloorSizeChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class FloorSizeChangedEventArgs : EventArgs
public ref class FloorSizeChangedEventArgs : public EventArgs

The FloorSizeChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | FloorSizeChangedEventArgs | Constructor
Top
Properties
 | Name | Description
Public property | Height |
Public property | IsHeightChanged |
Public property | IsWidthChanged |
Public property | Width |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


FloorSizeChangedEventArgs Constructor

Constructor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FloorSizeChangedEventArgs(
    double width,
    double height,
    bool widthChanged,
    bool heightChanged
)
public:
FloorSizeChangedEventArgs(
    double width,
    double height,
    bool widthChanged,
    bool heightChanged
)

Parameters

width
Type: SystemDouble
Floor width
height
Type: SystemDouble
Floor height
widthChanged
Type: SystemBoolean
heightChanged
Type: SystemBoolean
See Also

Reference

FloorSizeChangedEventArgs Class
VisualComponents.Create3D Namespace


FloorSizeChangedEventArgs Properties

The FloorSizeChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Height |
Public property | IsHeightChanged |
Public property | IsWidthChanged |
Public property | Width |
Top
See Also

Reference

FloorSizeChangedEventArgs Class
VisualComponents.Create3D Namespace


FloorSizeChangedEventArgs.Height Property

FloorSizeChangedEventArgsHeight Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Height { get; }
public:
property double Height {
    double get ();
}

Property Value

Type: Double
See Also

Reference

FloorSizeChangedEventArgs Class
VisualComponents.Create3D Namespace


FloorSizeChangedEventArgs.IsHeightChanged Property

FloorSizeChangedEventArgsIsHeightChanged Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsHeightChanged { get; }
public:
property bool IsHeightChanged {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

FloorSizeChangedEventArgs Class
VisualComponents.Create3D Namespace


FloorSizeChangedEventArgs.IsWidthChanged Property

FloorSizeChangedEventArgsIsWidthChanged Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsWidthChanged { get; }
public:
property bool IsWidthChanged {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

FloorSizeChangedEventArgs Class
VisualComponents.Create3D Namespace


FloorSizeChangedEventArgs.Width Property

FloorSizeChangedEventArgsWidth Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Width { get; }
public:
property double Width {
    double get ();
}

Property Value

Type: Double
See Also

Reference

FloorSizeChangedEventArgs Class
VisualComponents.Create3D Namespace


FloorSizeChangedEventArgs Methods

The FloorSizeChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

FloorSizeChangedEventArgs Class
VisualComponents.Create3D Namespace


FlybyParameterData Structure

Information required by an RCS module when setting flyby settings

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct FlybyParameterData
public value class FlybyParameterData

The FlybyParameterData type exposes the following members.

Constructors
 | Name | Description
Public method | FlybyParameterData | Initializes a new instance of the FlybyParameterData class
Top
Properties
 | Name | Description
Public property | JointNumber |
Public property | ParameterNumber |
Public property | ParameterValue |
Top
Methods
 | Name | Description
Public method | Equals | (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Equality |
Inequality |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


FlybyParameterData Constructor

Initializes a new instance of the FlybyParameterData class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FlybyParameterData(
    int parameterNumber,
    int jointNumber,
    double parameterValue
)
public:
FlybyParameterData(
    int parameterNumber,
    int jointNumber,
    double parameterValue
)

Parameters

parameterNumber
Type: SystemInt32
jointNumber
Type: SystemInt32
parameterValue
Type: SystemDouble
See Also

Reference

FlybyParameterData Structure
VisualComponents.Create3D Namespace


FlybyParameterData Properties

The FlybyParameterData type exposes the following members.

Properties
 | Name | Description
Public property | JointNumber |
Public property | ParameterNumber |
Public property | ParameterValue |
Top
See Also

Reference

FlybyParameterData Structure
VisualComponents.Create3D Namespace


FlybyParameterData.JointNumber Property

FlybyParameterDataJointNumber Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int JointNumber { get; }
public:
property int JointNumber {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

FlybyParameterData Structure
VisualComponents.Create3D Namespace


FlybyParameterData.ParameterNumber Property

FlybyParameterDataParameterNumber Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ParameterNumber { get; }
public:
property int ParameterNumber {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

FlybyParameterData Structure
VisualComponents.Create3D Namespace


FlybyParameterData.ParameterValue Property

FlybyParameterDataParameterValue Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double ParameterValue { get; }
public:
property double ParameterValue {
    double get ();
}

Property Value

Type: Double
See Also

Reference

FlybyParameterData Structure
VisualComponents.Create3D Namespace


FlybyParameterData Methods

The FlybyParameterData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

FlybyParameterData Structure
VisualComponents.Create3D Namespace


FlybyParameterData.Equals Method

FlybyParameterDataEquals Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.FlybyParameterData.Equals(System.Object)"]

See Also

Reference

FlybyParameterData Structure
VisualComponents.Create3D Namespace


FlybyParameterData.GetHashCode Method

FlybyParameterDataGetHashCode Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.FlybyParameterData.GetHashCode"]

See Also

Reference

FlybyParameterData Structure
VisualComponents.Create3D Namespace


FlybyParameterData Operators

The FlybyParameterData type exposes the following members.

Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

FlybyParameterData Structure
VisualComponents.Create3D Namespace


FlybyParameterData.Equality Operator

FlybyParameterDataEquality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    FlybyParameterData obj1,
    FlybyParameterData obj2
)
public:
static bool operator ==(
    FlybyParameterData obj1,
    FlybyParameterData obj2
)

Parameters

obj1
Type: VisualComponents.Create3DFlybyParameterData
obj2
Type: VisualComponents.Create3DFlybyParameterData

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.FlybyParameterData.op_Equality(VisualComponents.Create3D.FlybyParameterData,VisualComponents.Create3D.FlybyParameterData)"]

See Also

Reference

FlybyParameterData Structure
VisualComponents.Create3D Namespace


FlybyParameterData.Inequality Operator

FlybyParameterDataInequality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    FlybyParameterData obj1,
    FlybyParameterData obj2
)
public:
static bool operator !=(
    FlybyParameterData obj1,
    FlybyParameterData obj2
)

Parameters

obj1
Type: VisualComponents.Create3DFlybyParameterData
obj2
Type: VisualComponents.Create3DFlybyParameterData

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.FlybyParameterData.op_Inequality(VisualComponents.Create3D.FlybyParameterData,VisualComponents.Create3D.FlybyParameterData)"]

See Also

Reference

FlybyParameterData Structure
VisualComponents.Create3D Namespace


FrameTypeStateConfigElement Class

Configuration file element for frame type options.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.Create3DFrameTypeStateConfigElement

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class FrameTypeStateConfigElement : ConfigurationElement
public ref class FrameTypeStateConfigElement : public ConfigurationElement

The FrameTypeStateConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | FrameTypeStateConfigElement | Constructor.
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | FrameFeatures | Turn on/off robot positions frames.
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is . (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | RobotBaseFrame | Turn on/off robot base frames.
Public property | RobotFrameVisible | Turn on/off robot frames.
Public property | RobotPositions | Turn on/off robot positions frames.
Public property | RobotToolFrame | Turn on/off robot Tool frames.
Public property | RobotWorldFrame | Turn on/off robot World frames.
Top
Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


FrameTypeStateConfigElement Constructor

Constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FrameTypeStateConfigElement()
public:
FrameTypeStateConfigElement()
See Also

Reference

FrameTypeStateConfigElement Class
VisualComponents.Create3D Namespace


FrameTypeStateConfigElement Properties

The FrameTypeStateConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | FrameFeatures | Turn on/off robot positions frames.
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is . (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | RobotBaseFrame | Turn on/off robot base frames.
Public property | RobotFrameVisible | Turn on/off robot frames.
Public property | RobotPositions | Turn on/off robot positions frames.
Public property | RobotToolFrame | Turn on/off robot Tool frames.
Public property | RobotWorldFrame | Turn on/off robot World frames.
Top
See Also

Reference

FrameTypeStateConfigElement Class
VisualComponents.Create3D Namespace


FrameTypeStateConfigElement.FrameFeatures Property

FrameTypeStateConfigElementFrameFeatures Property

Turn on/off robot positions frames.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<bool> FrameFeatures { get; set; }
public:
property Nullable<bool> FrameFeatures {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: NullableBoolean
See Also

Reference

FrameTypeStateConfigElement Class
VisualComponents.Create3D Namespace


FrameTypeStateConfigElement.RobotBaseFrame Property

FrameTypeStateConfigElementRobotBaseFrame Property

Turn on/off robot base frames.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool RobotBaseFrame { get; set; }
public:
property bool RobotBaseFrame {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

FrameTypeStateConfigElement Class
VisualComponents.Create3D Namespace


FrameTypeStateConfigElement.RobotFrameVisible Property

FrameTypeStateConfigElementRobotFrameVisible Property

Turn on/off robot frames.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<bool> RobotFrameVisible { get; set; }
public:
property Nullable<bool> RobotFrameVisible {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: NullableBoolean
See Also

Reference

FrameTypeStateConfigElement Class
VisualComponents.Create3D Namespace


FrameTypeStateConfigElement.RobotPositions Property

FrameTypeStateConfigElementRobotPositions Property

Turn on/off robot positions frames.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<bool> RobotPositions { get; set; }
public:
property Nullable<bool> RobotPositions {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: NullableBoolean
See Also

Reference

FrameTypeStateConfigElement Class
VisualComponents.Create3D Namespace


FrameTypeStateConfigElement.RobotToolFrame Property

FrameTypeStateConfigElementRobotToolFrame Property

Turn on/off robot Tool frames.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool RobotToolFrame { get; set; }
public:
property bool RobotToolFrame {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

FrameTypeStateConfigElement Class
VisualComponents.Create3D Namespace


FrameTypeStateConfigElement.RobotWorldFrame Property

FrameTypeStateConfigElementRobotWorldFrame Property

Turn on/off robot World frames.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool RobotWorldFrame { get; set; }
public:
property bool RobotWorldFrame {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

FrameTypeStateConfigElement Class
VisualComponents.Create3D Namespace


FrameTypeStateConfigElement Methods

The FrameTypeStateConfigElement type exposes the following members.

Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

FrameTypeStateConfigElement Class
VisualComponents.Create3D Namespace


FunctionType Enumeration

Function type enumeration.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum FunctionType
public enum class FunctionType
Members
Member name | Value | Description
Cast | 1 | Cast operation.
ExpressionOperator | 2 | Unary or binary operator function.
Trigonometric | 3 | Trigonometric function.
Power | 4 | Power function.
Hyperbolic | 5 | Hyperbolic function.
VectorConstruction | 6 | Vector construction function.
MatrixConstruction | 7 | Matrix construction function.
Construction | 8 | Miscellaneous object construction function.
StringFunc | 9 | String function.
Miscellaneous | 10 | Miscellaneous function.
PseudorandomDistribution | 11 | Pseudo-random distribution function.
Member | 12 | Object member function.
Rsl | 13 | RSL function.
Unknown | 14 | Unknown function category.
See Also

Reference

VisualComponents.Create3D Namespace


GammaDistributionParameters Class

Gamma distribution parameters
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DGammaDistributionParameters

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class GammaDistributionParameters : IDistributionParameters
public ref class GammaDistributionParameters : IDistributionParameters

The GammaDistributionParameters type exposes the following members.

Constructors
 | Name | Description
Public method | GammaDistributionParameters | Initializes a new instance of the GammaDistributionParameters class
Public method | GammaDistributionParameters(IProperty) | Initializes a new instance of the GammaDistributionParameters class
Top
Properties
 | Name | Description
Public property | DistributionType |
Public property | Expression |
Public property | Property |
Public property | Scale | Scale theta (Ɵ) value
Public property | Shape | Shape (k) value
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


GammaDistributionParameters Constructor

Overload List
 | Name | Description
Public method | GammaDistributionParameters | Initializes a new instance of the GammaDistributionParameters class
Public method | GammaDistributionParameters(IProperty) | Initializes a new instance of the GammaDistributionParameters class
Top
See Also

Reference

GammaDistributionParameters Class
VisualComponents.Create3D Namespace


GammaDistributionParameters Constructor

Initializes a new instance of the GammaDistributionParameters class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GammaDistributionParameters()
public:
GammaDistributionParameters()
See Also

Reference

GammaDistributionParameters Class
GammaDistributionParameters Overload
VisualComponents.Create3D Namespace


GammaDistributionParameters Constructor (IProperty)

Initializes a new instance of the GammaDistributionParameters class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GammaDistributionParameters(
    IProperty property
)
public:
GammaDistributionParameters(
    IProperty^ property
)

Parameters

property
Type: VisualComponents.Create3DIProperty
See Also

Reference

GammaDistributionParameters Class
GammaDistributionParameters Overload
VisualComponents.Create3D Namespace


GammaDistributionParameters Properties

The GammaDistributionParameters type exposes the following members.

Properties
 | Name | Description
Public property | DistributionType |
Public property | Expression |
Public property | Property |
Public property | Scale | Scale theta (Ɵ) value
Public property | Shape | Shape (k) value
Top
See Also

Reference

GammaDistributionParameters Class
VisualComponents.Create3D Namespace


GammaDistributionParameters.DistributionType Property

GammaDistributionParametersDistributionType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DistributionType DistributionType { get; }
public:
virtual property DistributionType DistributionType {
    DistributionType get () sealed;
}

Property Value

Type: DistributionType

Implements

IDistributionParametersDistributionType
See Also

Reference

GammaDistributionParameters Class
VisualComponents.Create3D Namespace


GammaDistributionParameters.Expression Property

GammaDistributionParametersExpression Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Expression { get; }
public:
virtual property String^ Expression {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IDistributionParametersExpression
See Also

Reference

GammaDistributionParameters Class
VisualComponents.Create3D Namespace


GammaDistributionParameters.Property Property

GammaDistributionParametersProperty Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty Property { get; }
public:
property IProperty^ Property {
    IProperty^ get ();
}

Property Value

Type: IProperty
See Also

Reference

GammaDistributionParameters Class
VisualComponents.Create3D Namespace


GammaDistributionParameters.Scale Property

GammaDistributionParametersScale Property

Scale theta (Ɵ) value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Scale { get; set; }
public:
property double Scale {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

GammaDistributionParameters Class
VisualComponents.Create3D Namespace


GammaDistributionParameters.Shape Property

GammaDistributionParametersShape Property

Shape (k) value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Shape { get; set; }
public:
property double Shape {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

GammaDistributionParameters Class
VisualComponents.Create3D Namespace


GammaDistributionParameters Methods

The GammaDistributionParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

GammaDistributionParameters Class
VisualComponents.Create3D Namespace


GeneralConfigElement Class

Configuration file element for General Options.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.Create3DGeneralConfigElement

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class GeneralConfigElement : ConfigurationElement
public ref class GeneralConfigElement sealed : public ConfigurationElement

The GeneralConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | GeneralConfigElement | Constructor.
Public method | GeneralConfigElement(String) | Constructor.
Top
Properties
 | Name | Description
Public property | AnimationStreamingPort | Animation streaming port.
Public property | AnimationStreamingUpdateRate | Animation streaming update rate.
Public property | ApplicationAccentColor | Application accent color.
Public property | BackupExpiration | Controls the maximum number of backup files per component/layout
Public property | BackupFileLimit | Controls the maximum number of backup files per component/layout
Public property | ClipFarScale | Controls clipping near plane distance based on gaze length
Public property | ClipNearScale | Controls clipping near plane distance based on gaze length
Public property | ClockDisplayModeId | Clock display mode. Default is hms.
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | CustomBackupFolder | Custom backup folder
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | IncludeComponentPathAtSave | Controls if component original path is stored into the layout for detecting later where component can be found
Public property | IsAnimationStreamingEnabled | Is animation streaming enabled.
Public property | IsApplicationRunningFirstTime | True if application executing for the first time.
Public property | IsAutoSaveEnabled | Auto save state.
Public property | IsDefaultSimulationRuntimeSelected | True if simulation execution time is Not specified.
Public property | IsDefaultSimulationWarmupTimeSelected | True if simulation warmup time is Not specified.
Public property | IsPackAndGo | Controls if current layout included compressed components
Public property | Language | Current language. Default is English.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | NoteFontSize | Note font size.
Public property | PythonEditorIsWhite | Controls the expansion of HowTo-section in snap-related actions.
Public property | ScrollWellZoomSensitivity | Obsolete. Deprecated.
Public property | ScrollWheelZoomMode | Mouse wheel scroll mode. AdjustCoi (Zoom Through) = 0, AdjustGazeLength (Keep Center of Interest) = 1
Public property | ScrollWheelZoomSensitivity | Sensitivity of mouse wheel scroll. Minimum 0, maximum recommended 2.
Public property | ShowSnapActionHowTo | Controls the expansion of HowTo-section in snap-related actions.
Public property | SimulationRuntime | Simulation run time.
Public property | SimulationTimeMode | Simulation warm-up time.
Public property | SimulationWarmupTime | Simulation warm-up time.
Public property | SpaceMouseEnabled | Space mouse support enabled.
Public property | SpaceMouseInvert | Space mouse invert all axises.
Public property | SpaceMousePanFactor | Space mouse pan factor.
Public property | SpaceMouseRotationFactor | Space mouse rotation factor.
Public property | SpaceMouseZoomFactor | Space mouse zoom factor.
Public property | SupplyVoltage | Floor color.
Public property | Theme | Selected color theme. Default is Dark Theme.
Public property | UnitFamily | Selected unit family. Default is Metric
Public property | UseBackupExpiration | Controls whether the backup file limit is used or not
Public property | UseBackupFileLimit | Controls whether the backup file limit is used or not
Public property | UseCustomBackupFolder | Controls whether a custom backup folder is used or not
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InitDefaults |
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


GeneralConfigElement Constructor

Overload List
 | Name | Description
Public method | GeneralConfigElement | Constructor.
Public method | GeneralConfigElement(String) | Constructor.
Top
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement Constructor

Constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GeneralConfigElement()
public:
GeneralConfigElement()
See Also

Reference

GeneralConfigElement Class
GeneralConfigElement Overload
VisualComponents.Create3D Namespace


GeneralConfigElement Constructor (String)

Constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GeneralConfigElement(
    string language
)
public:
GeneralConfigElement(
    String^ language
)

Parameters

language
Type: SystemString
Initial Language value
See Also

Reference

GeneralConfigElement Class
GeneralConfigElement Overload
VisualComponents.Create3D Namespace


GeneralConfigElement Properties

The GeneralConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | AnimationStreamingPort | Animation streaming port.
Public property | AnimationStreamingUpdateRate | Animation streaming update rate.
Public property | ApplicationAccentColor | Application accent color.
Public property | BackupExpiration | Controls the maximum number of backup files per component/layout
Public property | BackupFileLimit | Controls the maximum number of backup files per component/layout
Public property | ClipFarScale | Controls clipping near plane distance based on gaze length
Public property | ClipNearScale | Controls clipping near plane distance based on gaze length
Public property | ClockDisplayModeId | Clock display mode. Default is hms.
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | CustomBackupFolder | Custom backup folder
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | IncludeComponentPathAtSave | Controls if component original path is stored into the layout for detecting later where component can be found
Public property | IsAnimationStreamingEnabled | Is animation streaming enabled.
Public property | IsApplicationRunningFirstTime | True if application executing for the first time.
Public property | IsAutoSaveEnabled | Auto save state.
Public property | IsDefaultSimulationRuntimeSelected | True if simulation execution time is Not specified.
Public property | IsDefaultSimulationWarmupTimeSelected | True if simulation warmup time is Not specified.
Public property | IsPackAndGo | Controls if current layout included compressed components
Public property | Language | Current language. Default is English.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | NoteFontSize | Note font size.
Public property | PythonEditorIsWhite | Controls the expansion of HowTo-section in snap-related actions.
Public property | ScrollWellZoomSensitivity | Obsolete. Deprecated.
Public property | ScrollWheelZoomMode | Mouse wheel scroll mode. AdjustCoi (Zoom Through) = 0, AdjustGazeLength (Keep Center of Interest) = 1
Public property | ScrollWheelZoomSensitivity | Sensitivity of mouse wheel scroll. Minimum 0, maximum recommended 2.
Public property | ShowSnapActionHowTo | Controls the expansion of HowTo-section in snap-related actions.
Public property | SimulationRuntime | Simulation run time.
Public property | SimulationTimeMode | Simulation warm-up time.
Public property | SimulationWarmupTime | Simulation warm-up time.
Public property | SpaceMouseEnabled | Space mouse support enabled.
Public property | SpaceMouseInvert | Space mouse invert all axises.
Public property | SpaceMousePanFactor | Space mouse pan factor.
Public property | SpaceMouseRotationFactor | Space mouse rotation factor.
Public property | SpaceMouseZoomFactor | Space mouse zoom factor.
Public property | SupplyVoltage | Floor color.
Public property | Theme | Selected color theme. Default is Dark Theme.
Public property | UnitFamily | Selected unit family. Default is Metric
Public property | UseBackupExpiration | Controls whether the backup file limit is used or not
Public property | UseBackupFileLimit | Controls whether the backup file limit is used or not
Public property | UseCustomBackupFolder | Controls whether a custom backup folder is used or not
Top
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.AnimationStreamingPort Property

GeneralConfigElementAnimationStreamingPort Property

Animation streaming port.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint AnimationStreamingPort { get; set; }
public:
property unsigned int AnimationStreamingPort {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.AnimationStreamingUpdateRate Property

GeneralConfigElementAnimationStreamingUpdateRate Property

Animation streaming update rate.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int AnimationStreamingUpdateRate { get; set; }
public:
property int AnimationStreamingUpdateRate {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.ApplicationAccentColor Property

GeneralConfigElementApplicationAccentColor Property

Application accent color.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ApplicationAccentColor { get; set; }
public:
property String^ ApplicationAccentColor {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.BackupExpiration Property

GeneralConfigElementBackupExpiration Property

Controls the maximum number of backup files per component/layout

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int BackupExpiration { get; set; }
public:
property int BackupExpiration {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.BackupFileLimit Property

GeneralConfigElementBackupFileLimit Property

Controls the maximum number of backup files per component/layout

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int BackupFileLimit { get; set; }
public:
property int BackupFileLimit {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.ClipFarScale Property

GeneralConfigElementClipFarScale Property

Controls clipping near plane distance based on gaze length

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double ClipFarScale { get; set; }
public:
property double ClipFarScale {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.ClipNearScale Property

GeneralConfigElementClipNearScale Property

Controls clipping near plane distance based on gaze length

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double ClipNearScale { get; set; }
public:
property double ClipNearScale {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.ClockDisplayModeId Property

GeneralConfigElementClockDisplayModeId Property

Clock display mode. Default is hms.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ClockDisplayModeId { get; set; }
public:
property String^ ClockDisplayModeId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.CustomBackupFolder Property

GeneralConfigElementCustomBackupFolder Property

Custom backup folder

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Uri CustomBackupFolder { get; set; }
public:
property Uri^ CustomBackupFolder {
    Uri^ get ();
    void set (Uri^ value);
}

Property Value

Type: Uri
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.IncludeComponentPathAtSave Property

GeneralConfigElementIncludeComponentPathAtSave Property

Controls if component original path is stored into the layout for detecting later where component can be found

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IncludeComponentPathAtSave { get; set; }
public:
property bool IncludeComponentPathAtSave {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.IsAnimationStreamingEnabled Property

GeneralConfigElementIsAnimationStreamingEnabled Property

Is animation streaming enabled.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsAnimationStreamingEnabled { get; set; }
public:
property bool IsAnimationStreamingEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.IsApplicationRunningFirstTime Property

GeneralConfigElementIsApplicationRunningFirstTime Property

True if application executing for the first time.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsApplicationRunningFirstTime { get; set; }
public:
property bool IsApplicationRunningFirstTime {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.IsAutoSaveEnabled Property

GeneralConfigElementIsAutoSaveEnabled Property

Auto save state.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsAutoSaveEnabled { get; set; }
public:
property bool IsAutoSaveEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.IsDefaultSimulationRuntimeSelected Property

GeneralConfigElementIsDefaultSimulationRuntimeSelected Property

True if simulation execution time is Not specified.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsDefaultSimulationRuntimeSelected { get; set; }
public:
property bool IsDefaultSimulationRuntimeSelected {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.IsDefaultSimulationWarmupTimeSelected Property

GeneralConfigElementIsDefaultSimulationWarmupTimeSelected Property

True if simulation warmup time is Not specified.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsDefaultSimulationWarmupTimeSelected { get; set; }
public:
property bool IsDefaultSimulationWarmupTimeSelected {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.IsPackAndGo Property

GeneralConfigElementIsPackAndGo Property

Controls if current layout included compressed components

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<bool> IsPackAndGo { get; set; }
public:
property Nullable<bool> IsPackAndGo {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: NullableBoolean
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.Language Property

GeneralConfigElementLanguage Property

Current language. Default is English.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Language { get; set; }
public:
property String^ Language {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.NoteFontSize Property

GeneralConfigElementNoteFontSize Property

Note font size.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double NoteFontSize { get; set; }
public:
property double NoteFontSize {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.PythonEditorIsWhite Property

GeneralConfigElementPythonEditorIsWhite Property

Controls the expansion of HowTo-section in snap-related actions.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool PythonEditorIsWhite { get; set; }
public:
property bool PythonEditorIsWhite {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.ScrollWellZoomSensitivity Property

GeneralConfigElementScrollWellZoomSensitivity Property

Note: This API is now obsolete.

Deprecated.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Use ScrollWheelZoomSensitivity instead.")]
public double ScrollWellZoomSensitivity { get; set; }
public:
[ObsoleteAttribute(L"Use ScrollWheelZoomSensitivity instead.")]
property double ScrollWellZoomSensitivity {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.ScrollWheelZoomMode Property

GeneralConfigElementScrollWheelZoomMode Property

Mouse wheel scroll mode. AdjustCoi (Zoom Through) = 0, AdjustGazeLength (Keep Center of Interest) = 1

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<ZoomMode> ScrollWheelZoomMode { get; set; }
public:
property Nullable<ZoomMode> ScrollWheelZoomMode {
    Nullable<ZoomMode> get ();
    void set (Nullable<ZoomMode> value);
}

Property Value

Type: NullableZoomMode
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.ScrollWheelZoomSensitivity Property

GeneralConfigElementScrollWheelZoomSensitivity Property

Sensitivity of mouse wheel scroll. Minimum 0, maximum recommended 2.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double ScrollWheelZoomSensitivity { get; set; }
public:
property double ScrollWheelZoomSensitivity {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.ShowSnapActionHowTo Property

GeneralConfigElementShowSnapActionHowTo Property

Controls the expansion of HowTo-section in snap-related actions.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowSnapActionHowTo { get; set; }
public:
property bool ShowSnapActionHowTo {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.SimulationRuntime Property

GeneralConfigElementSimulationRuntime Property

Simulation run time.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double SimulationRuntime { get; set; }
public:
property double SimulationRuntime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.SimulationTimeMode Property

GeneralConfigElementSimulationTimeMode Property

Simulation warm-up time.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SimulationTimeMode { get; set; }
public:
property String^ SimulationTimeMode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.SimulationWarmupTime Property

GeneralConfigElementSimulationWarmupTime Property

Simulation warm-up time.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double SimulationWarmupTime { get; set; }
public:
property double SimulationWarmupTime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.SpaceMouseEnabled Property

GeneralConfigElementSpaceMouseEnabled Property

Space mouse support enabled.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool SpaceMouseEnabled { get; set; }
public:
property bool SpaceMouseEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.SpaceMouseInvert Property

GeneralConfigElementSpaceMouseInvert Property

Space mouse invert all axises.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool SpaceMouseInvert { get; set; }
public:
property bool SpaceMouseInvert {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.SpaceMousePanFactor Property

GeneralConfigElementSpaceMousePanFactor Property

Space mouse pan factor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double SpaceMousePanFactor { get; set; }
public:
property double SpaceMousePanFactor {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.SpaceMouseRotationFactor Property

GeneralConfigElementSpaceMouseRotationFactor Property

Space mouse rotation factor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double SpaceMouseRotationFactor { get; set; }
public:
property double SpaceMouseRotationFactor {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.SpaceMouseZoomFactor Property

GeneralConfigElementSpaceMouseZoomFactor Property

Space mouse zoom factor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double SpaceMouseZoomFactor { get; set; }
public:
property double SpaceMouseZoomFactor {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.SupplyVoltage Property

GeneralConfigElementSupplyVoltage Property

Floor color.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SupplyVoltage { get; set; }
public:
property String^ SupplyVoltage {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.Theme Property

GeneralConfigElementTheme Property

Selected color theme. Default is Dark Theme.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Theme { get; set; }
public:
property String^ Theme {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.UnitFamily Property

GeneralConfigElementUnitFamily Property

Selected unit family. Default is Metric

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string UnitFamily { get; set; }
public:
property String^ UnitFamily {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.UseBackupExpiration Property

GeneralConfigElementUseBackupExpiration Property

Controls whether the backup file limit is used or not

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool UseBackupExpiration { get; set; }
public:
property bool UseBackupExpiration {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.UseBackupFileLimit Property

GeneralConfigElementUseBackupFileLimit Property

Controls whether the backup file limit is used or not

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool UseBackupFileLimit { get; set; }
public:
property bool UseBackupFileLimit {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.UseCustomBackupFolder Property

GeneralConfigElementUseCustomBackupFolder Property

Controls whether a custom backup folder is used or not

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool UseCustomBackupFolder { get; set; }
public:
property bool UseCustomBackupFolder {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement Methods

The GeneralConfigElement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InitDefaults |
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralConfigElement.InitDefaults Method

GeneralConfigElementInitDefaults Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void InitDefaults(
    IAppConfigSettings appConfigSettings
)
public:
static void InitDefaults(
    IAppConfigSettings^ appConfigSettings
)

Parameters

appConfigSettings
Type: VisualComponents.Create3DIAppConfigSettings
See Also

Reference

GeneralConfigElement Class
VisualComponents.Create3D Namespace


GeneralSection Class

Configuration file section for General Options.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationSection
VisualComponents.Create3DGeneralSection

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class GeneralSection : ConfigurationSection,
    IGeneralSection, ISection
public ref class GeneralSection sealed : public ConfigurationSection,
    IGeneralSection, ISection

The GeneralSection type exposes the following members.

Constructors
 | Name | Description
Public method | GeneralSection | Constructor.
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | GeneralElement | Configuration file element for General Options.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName | Section's name in configuration file.
Public property | SectionType | Interface type.
Public property | SectionVersion | Section's version number.
Top
Methods
 | Name | Description
Public method | CheckVersion | Upgrade configuration to the latest version.
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection | Finds typed section by name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks
These options are visibile in application backstage, and stored to user-specific configuration file.
See Also

Reference

VisualComponents.Create3D Namespace


GeneralSection Constructor

Constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GeneralSection()
public:
GeneralSection()
See Also

Reference

GeneralSection Class
VisualComponents.Create3D Namespace


GeneralSection Properties

The GeneralSection type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | GeneralElement | Configuration file element for General Options.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName | Section's name in configuration file.
Public property | SectionType | Interface type.
Public property | SectionVersion | Section's version number.
Top
See Also

Reference

GeneralSection Class
VisualComponents.Create3D Namespace


GeneralSection.GeneralElement Property

GeneralSectionGeneralElement Property

Configuration file element for General Options.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GeneralConfigElement GeneralElement { get; set; }
public:
virtual property GeneralConfigElement^ GeneralElement {
    GeneralConfigElement^ get () sealed;
    void set (GeneralConfigElement^ value) sealed;
}

Property Value

Type: GeneralConfigElement

Implements

IGeneralSectionGeneralElement
See Also

Reference

GeneralSection Class
VisualComponents.Create3D Namespace


GeneralSection.SectionName Property

GeneralSectionSectionName Property

Section's name in configuration file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SectionName { get; }
public:
virtual property String^ SectionName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ISectionSectionName
See Also

Reference

GeneralSection Class
VisualComponents.Create3D Namespace


GeneralSection.SectionType Property

GeneralSectionSectionType Property

Interface type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type SectionType { get; }
public:
virtual property Type^ SectionType {
    Type^ get () sealed;
}

Property Value

Type: Type

Implements

ISectionSectionType
See Also

Reference

GeneralSection Class
VisualComponents.Create3D Namespace


GeneralSection.SectionVersion Property

GeneralSectionSectionVersion Property

Section's version number.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int SectionVersion { get; }
public:
virtual property int SectionVersion {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISectionSectionVersion
See Also

Reference

GeneralSection Class
VisualComponents.Create3D Namespace


GeneralSection Methods

The GeneralSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion | Upgrade configuration to the latest version.
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection | Finds typed section by name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

GeneralSection Class
VisualComponents.Create3D Namespace


GeneralSection.CheckVersion Method

GeneralSectionCheckVersion Method

Upgrade configuration to the latest version.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CheckVersion()
public:
virtual void CheckVersion() sealed

Implements

ISectionCheckVersion
See Also

Reference

GeneralSection Class
VisualComponents.Create3D Namespace


GeneralSection.GetSection Method

GeneralSectionGetSection Method

Finds typed section by name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISection GetSection(
    Configuration userSettingConfiguration
)
public:
virtual ISection^ GetSection(
    Configuration^ userSettingConfiguration
) sealed

Parameters

userSettingConfiguration
Type: System.ConfigurationConfiguration

Return Value

Type: ISection

[Missing <returns> documentation for "M:VisualComponents.Create3D.GeneralSection.GetSection(System.Configuration.Configuration)"]

Implements

ISectionGetSection(Configuration)
See Also

Reference

GeneralSection Class
VisualComponents.Create3D Namespace


GeneralSection.ToString Method

GeneralSectionToString Method

Converts this instance to string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String
String representation of this instance
See Also

Reference

GeneralSection Class
VisualComponents.Create3D Namespace


GenericEnumerator(T) Class

GenericEnumeratorT Class

Generic enumerator, that also disposes of "Current" value.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DGenericEnumeratorT

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class GenericEnumerator<T> : IEnumerator<T>,
    IDisposable, IEnumerator
where T : IDisposable

generic<typename T>
where T : IDisposable
public ref class GenericEnumerator sealed : IEnumerator<T>,
    IDisposable, IEnumerator

Type Parameters

T

The GenericEnumeratorT type exposes the following members.

Constructors
 | Name | Description
Public method | GenericEnumeratorT | Initializes a new instance of the GenericEnumeratorT class
Top
Properties
 | Name | Description
Public property | Count2 |
Public property | Current |
Public property | CurrentItem |
Public property | Index1 |
Public property | Index2 |
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the GenericEnumeratorT
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext |
Public method | Reset |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


GenericEnumerator(T) Constructor

GenericEnumeratorT Constructor

Initializes a new instance of the GenericEnumeratorT class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GenericEnumerator(
    IGenericEnumeratorOwner<T> owner
)
public:
GenericEnumerator(
    IGenericEnumeratorOwner<T>^ owner
)

Parameters

owner
Type: VisualComponents.Create3DIGenericEnumeratorOwner T
See Also

Reference

GenericEnumeratorT Class
VisualComponents.Create3D Namespace


GenericEnumerator(T) Properties

GenericEnumeratorT Properties

The GenericEnumeratorT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count2 |
Public property | Current |
Public property | CurrentItem |
Public property | Index1 |
Public property | Index2 |
Top
See Also

Reference

GenericEnumeratorT Class
VisualComponents.Create3D Namespace


GenericEnumerator(T).Count2 Property

GenericEnumeratorTCount2 Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Count2 { get; set; }
public:
property int Count2 {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

GenericEnumeratorT Class
VisualComponents.Create3D Namespace


GenericEnumerator(T).Current Property

GenericEnumeratorTCurrent Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public T Current { get; }
public:
virtual property T Current {
    T get () sealed;
}

Property Value

Type: T

Implements

IEnumeratorTCurrent
See Also

Reference

GenericEnumeratorT Class
VisualComponents.Create3D Namespace


GenericEnumerator(T).CurrentItem Property

GenericEnumeratorTCurrentItem Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public T CurrentItem { get; set; }
public:
property T CurrentItem {
    T get ();
    void set (T value);
}

Property Value

Type: T
See Also

Reference

GenericEnumeratorT Class
VisualComponents.Create3D Namespace


GenericEnumerator(T).Index1 Property

GenericEnumeratorTIndex1 Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Index1 { get; set; }
public:
property int Index1 {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

GenericEnumeratorT Class
VisualComponents.Create3D Namespace


GenericEnumerator(T).Index2 Property

GenericEnumeratorTIndex2 Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Index2 { get; set; }
public:
property int Index2 {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

GenericEnumeratorT Class
VisualComponents.Create3D Namespace


GenericEnumerator(T) Methods

GenericEnumeratorT Methods

The GenericEnumeratorT generic type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext |
Public method | Reset |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

GenericEnumeratorT Class
VisualComponents.Create3D Namespace


GenericEnumerator(T).Dispose Method

GenericEnumeratorTDispose Method

Releases all resources used by the GenericEnumeratorT

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Dispose()
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

GenericEnumeratorT Class
VisualComponents.Create3D Namespace


GenericEnumerator(T).MoveNext Method

GenericEnumeratorTMoveNext Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool MoveNext()
public:
virtual bool MoveNext() sealed

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.GenericEnumerator`1.MoveNext"]

Implements

IEnumeratorMoveNext
See Also

Reference

GenericEnumeratorT Class
VisualComponents.Create3D Namespace


GenericEnumerator(T).Reset Method

GenericEnumeratorTReset Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Reset()
public:
virtual void Reset() sealed

Implements

IEnumeratorReset
See Also

Reference

GenericEnumeratorT Class
VisualComponents.Create3D Namespace


GenericEventListener Class

Helper class that makes it easier to listen to various events. Also it makes sure that target instances are garbage collected, by referencing "_target" with a weak reference. Note: Typically there are multiple GenericEventListener instances listening to the same component's TransformationChanged event. This is because garbage collector is slow to dispose of old instances.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DGenericEventListener

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class GenericEventListener : IDisposable
public ref class GenericEventListener : IDisposable

The GenericEventListener type exposes the following members.

Constructors
 | Name | Description
Public method | GenericEventListener | Initializes a new instance of the GenericEventListener class
Top
Methods
 | Name | Description
Public method | Connect(IEnumerableObject, GenericEventType) |
Public method | Connect(Object, GenericEventType) |
Public method | Connect(IEnumerableObject, GenericEventType, Int32) |
Public method | Connect(Object, GenericEventType, Int32) |
Public method | DisconnectAll |
Public method | DisconnectAll(NullableGenericEventType) |
Public method | Dispose | Releases all resources used by the GenericEventListener
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the GenericEventListener and optionally releases the managed resources
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
ConnectCount |
TotalCount |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


GenericEventListener Constructor

Initializes a new instance of the GenericEventListener class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GenericEventListener(
    IGenericEventTarget target
)
public:
GenericEventListener(
    IGenericEventTarget^ target
)

Parameters

target
Type: VisualComponents.Create3DIGenericEventTarget
See Also

Reference

GenericEventListener Class
VisualComponents.Create3D Namespace


GenericEventListener Methods

The GenericEventListener type exposes the following members.

Methods
 | Name | Description
Public method | Connect(IEnumerableObject, GenericEventType) |
Public method | Connect(Object, GenericEventType) |
Public method | Connect(IEnumerableObject, GenericEventType, Int32) |
Public method | Connect(Object, GenericEventType, Int32) |
Public method | DisconnectAll |
Public method | DisconnectAll(NullableGenericEventType) |
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

GenericEventListener Class
VisualComponents.Create3D Namespace


GenericEventListener.Connect Method

GenericEventListenerConnect Method

Overload List
 | Name | Description
Public method | Connect(IEnumerableObject, GenericEventType) |
Public method | Connect(Object, GenericEventType) |
Public method | Connect(IEnumerableObject, GenericEventType, Int32) |
Public method | Connect(Object, GenericEventType, Int32) |
Top
See Also

Reference

GenericEventListener Class
VisualComponents.Create3D Namespace


GenericEventListener.Connect Method (IEnumerable(Object), GenericEventType)

GenericEventListenerConnect Method (IEnumerableObject, GenericEventType)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Connect(
    IEnumerable<Object> items,
    GenericEventType type
)
public:
void Connect(
    IEnumerable<Object^>^ items,
    GenericEventType type
)

Parameters

items
Type: System.Collections.GenericIEnumerableObject
type
Type: VisualComponents.Create3DGenericEventType
See Also

Reference

GenericEventListener Class
Connect Overload
VisualComponents.Create3D Namespace


GenericEventListener.Connect Method (Object, GenericEventType)

GenericEventListenerConnect Method (Object, GenericEventType)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Connect(
    Object item,
    GenericEventType type
)
public:
void Connect(
    Object^ item,
    GenericEventType type
)

Parameters

item
Type: SystemObject
type
Type: VisualComponents.Create3DGenericEventType
See Also

Reference

GenericEventListener Class
Connect Overload
VisualComponents.Create3D Namespace


GenericEventListener.Connect Method (IEnumerable(Object), GenericEventType, Int32)

GenericEventListenerConnect Method (IEnumerableObject, GenericEventType, Int32)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Connect(
    IEnumerable<Object> items,
    GenericEventType type,
    int id
)
public:
void Connect(
    IEnumerable<Object^>^ items,
    GenericEventType type,
    int id
)

Parameters

items
Type: System.Collections.GenericIEnumerableObject
type
Type: VisualComponents.Create3DGenericEventType
id
Type: SystemInt32
See Also

Reference

GenericEventListener Class
Connect Overload
VisualComponents.Create3D Namespace


GenericEventListener.Connect Method (Object, GenericEventType, Int32)

GenericEventListenerConnect Method (Object, GenericEventType, Int32)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Connect(
    Object item,
    GenericEventType type,
    int id
)
public:
void Connect(
    Object^ item,
    GenericEventType type,
    int id
)

Parameters

item
Type: SystemObject
type
Type: VisualComponents.Create3DGenericEventType
id
Type: SystemInt32
See Also

Reference

GenericEventListener Class
Connect Overload
VisualComponents.Create3D Namespace


GenericEventListener.DisconnectAll Method

GenericEventListenerDisconnectAll Method

Overload List
 | Name | Description
Public method | DisconnectAll |
Public method | DisconnectAll(NullableGenericEventType) |
Top
See Also

Reference

GenericEventListener Class
VisualComponents.Create3D Namespace


GenericEventListener.DisconnectAll Method

GenericEventListenerDisconnectAll Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void DisconnectAll()
public:
void DisconnectAll()
See Also

Reference

GenericEventListener Class
DisconnectAll Overload
VisualComponents.Create3D Namespace


GenericEventListener.DisconnectAll Method (Nullable(GenericEventType))

GenericEventListenerDisconnectAll Method (NullableGenericEventType)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void DisconnectAll(
    Nullable<GenericEventType> onEvent
)
public:
void DisconnectAll(
    Nullable<GenericEventType> onEvent
)

Parameters

onEvent
Type: SystemNullableGenericEventType
See Also

Reference

GenericEventListener Class
DisconnectAll Overload
VisualComponents.Create3D Namespace


GenericEventListener.Dispose Method

GenericEventListenerDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the GenericEventListener
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the GenericEventListener and optionally releases the managed resources
Top
See Also

Reference

GenericEventListener Class
VisualComponents.Create3D Namespace


GenericEventListener.Dispose Method

GenericEventListenerDispose Method

Releases all resources used by the GenericEventListener

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Dispose()
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

GenericEventListener Class
Dispose Overload
VisualComponents.Create3D Namespace


GenericEventListener.Dispose Method (Boolean)

GenericEventListenerDispose Method (Boolean)

Releases the unmanaged resources used by the GenericEventListener and optionally releases the managed resources

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void Dispose(
    bool disposing
)
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

GenericEventListener Class
Dispose Overload
VisualComponents.Create3D Namespace


GenericEventListener.Finalize Method

GenericEventListenerFinalize Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void Finalize()
protected:
virtual void Finalize() override

Implements

ObjectFinalize
See Also

Reference

GenericEventListener Class
VisualComponents.Create3D Namespace


GenericEventListener Fields

The GenericEventListener type exposes the following members.

Fields
Name | Description
ConnectCount |
TotalCount |
Top
See Also

Reference

GenericEventListener Class
VisualComponents.Create3D Namespace


GenericEventListener.ConnectCount Field

GenericEventListenerConnectCount Field

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int ConnectCount
public:
static int ConnectCount

Field Value

Type: Int32
See Also

Reference

GenericEventListener Class
VisualComponents.Create3D Namespace


GenericEventListener.TotalCount Field

GenericEventListenerTotalCount Field

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int TotalCount
public:
static int TotalCount

Field Value

Type: Int32
See Also

Reference

GenericEventListener Class
VisualComponents.Create3D Namespace


GenericEventType Enumeration

Event type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum GenericEventType
public enum class GenericEventType
Members
Member name | Value | Description
ObjectInvalidated | 0 |
TransformationChanged | 1 |
CurrentStateChange | 2 |
PropertyChanged | 3 |
IsLockedChanged | 4 |
LastEventType | 5 |
See Also

Reference

VisualComponents.Create3D Namespace


GenericLicensingHelper Class

Licensing helper that mostly works on the feature set level, and does not require main application licensing data structures.

For main application licensing, see LicensingHelper.

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DGenericLicensingHelper

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class GenericLicensingHelper
public ref class GenericLicensingHelper abstract sealed

The GenericLicensingHelper type exposes the following members.

Methods
Name | Description
CheckNetworkLicenseState | Checks if a license for the given feature set is found on the server, and if there is a seat available.
CompareFeatureListToReferenceFeatures | Compares the given (string) list of features against another given set features. "SuperSetMatch" means the given list has fewer features than in the other set. "ReverseSuperSetMatch" means the given list has more features than in the other set.
CompareProductFeatureSets | Compares the given feature set to the other feature set. "SuperSetMatch" mean the subject has only some of the items in other. "ReverseSuperSetMatch" mean the subject has the same items than in other, and more.
DeactivateStandaloneLicenseKey | Deactivate a given product key.
DoesFeatureListIncludeFeatures | Returns true if featureList contains referenceFeatures.
GetActiveStandaloneProductKey | Return active standalone product key that have a particular key string.
GetActiveStandaloneProductKeys | Return the first active standalone product key which have the same feature defined in license setting.
GetMainFeatureLicensingAvailability | For local licenses and borrowed network licenses, checks if a license that would activate the requested features is available. For network licenses, checks if the server has available licenses for all requested features. Note that the network license seat still needs to reserved by calling RequestNetworkLicense(ISetProductFeature, String). Returns the type of licensing that is available.
IsCommuterCodeInUse(ISetProductFeature) | Checks if commuted license is used for the given product. Returns true if a commuter license is used for the product.
IsCommuterCodeInUse(IProductManager, ISetProductFeature) | Checks if commuted license is used for the given product. Returns true if a commuter license is used for the product.
IsStandaloneLicenseInUse | A helper method to redirect to either GetActiveStandaloneProductKey(String, ISetProductFeature) or GetActiveStandaloneProductKeys(ISetProductFeature).
ReleaseNetworkLicense | Releases a network license seat, see RequestNetworkLicense(ISetProductFeature, String).
RequestNetworkLicense | For all requiredFeatures, reserve a seat and get an object that represents it. See ReleaseNetworkLicense(ILicense) to release the seat. This method can be called many times and each time it will return a different objects. All of these objects need to be released in order to release the seat.
Top
See Also

Reference

VisualComponents.Create3D Namespace


GenericLicensingHelper Methods

The GenericLicensingHelper type exposes the following members.

Methods
Name | Description
CheckNetworkLicenseState | Checks if a license for the given feature set is found on the server, and if there is a seat available.
CompareFeatureListToReferenceFeatures | Compares the given (string) list of features against another given set features. "SuperSetMatch" means the given list has fewer features than in the other set. "ReverseSuperSetMatch" means the given list has more features than in the other set.
CompareProductFeatureSets | Compares the given feature set to the other feature set. "SuperSetMatch" mean the subject has only some of the items in other. "ReverseSuperSetMatch" mean the subject has the same items than in other, and more.
DeactivateStandaloneLicenseKey | Deactivate a given product key.
DoesFeatureListIncludeFeatures | Returns true if featureList contains referenceFeatures.
GetActiveStandaloneProductKey | Return active standalone product key that have a particular key string.
GetActiveStandaloneProductKeys | Return the first active standalone product key which have the same feature defined in license setting.
GetMainFeatureLicensingAvailability | For local licenses and borrowed network licenses, checks if a license that would activate the requested features is available. For network licenses, checks if the server has available licenses for all requested features. Note that the network license seat still needs to reserved by calling RequestNetworkLicense(ISetProductFeature, String). Returns the type of licensing that is available.
IsCommuterCodeInUse(ISetProductFeature) | Checks if commuted license is used for the given product. Returns true if a commuter license is used for the product.
IsCommuterCodeInUse(IProductManager, ISetProductFeature) | Checks if commuted license is used for the given product. Returns true if a commuter license is used for the product.
IsStandaloneLicenseInUse | A helper method to redirect to either GetActiveStandaloneProductKey(String, ISetProductFeature) or GetActiveStandaloneProductKeys(ISetProductFeature).
ReleaseNetworkLicense | Releases a network license seat, see RequestNetworkLicense(ISetProductFeature, String).
RequestNetworkLicense | For all requiredFeatures, reserve a seat and get an object that represents it. See ReleaseNetworkLicense(ILicense) to release the seat. This method can be called many times and each time it will return a different objects. All of these objects need to be released in order to release the seat.
Top
See Also

Reference

GenericLicensingHelper Class
VisualComponents.Create3D Namespace


GenericLicensingHelper.CheckNetworkLicenseState Method

GenericLicensingHelperCheckNetworkLicenseState Method

Checks if a license for the given feature set is found on the server, and if there is a seat available.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static LicenseState CheckNetworkLicenseState(
    ISet<ProductFeature> requiredFeatures,
    out string errorMessage
)
public:
static LicenseState CheckNetworkLicenseState(
    ISet<ProductFeature>^ requiredFeatures,
    [OutAttribute] String^% errorMessage
)

Parameters

requiredFeatures
Type: System.Collections.GenericISetProductFeature
errorMessage
Type: SystemString

Return Value

Type: LicenseState

[Missing <returns> documentation for "M:VisualComponents.Create3D.GenericLicensingHelper.CheckNetworkLicenseState(System.Collections.Generic.ISet{VisualComponents.Create3D.ProductFeature},System.String@)"]

See Also

Reference

GenericLicensingHelper Class
VisualComponents.Create3D Namespace


GenericLicensingHelper.CompareFeatureListToReferenceFeatures Method

GenericLicensingHelperCompareFeatureListToReferenceFeatures Method

Compares the given (string) list of features against another given set features.

"SuperSetMatch" means the given list has fewer features than in the other set. "ReverseSuperSetMatch" means the given list has more features than in the other set.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static FeatureMatch CompareFeatureListToReferenceFeatures(
    string productKeyFeatures,
    ISet<ProductFeature> referenceFeatures
)
public:
static FeatureMatch CompareFeatureListToReferenceFeatures(
    String^ productKeyFeatures,
    ISet<ProductFeature>^ referenceFeatures
)

Parameters

productKeyFeatures
Type: SystemString
A list of feature, e.g. the features that a product key activates.
referenceFeatures
Type: System.Collections.GenericISetProductFeature
The set of features to compare to.

Return Value

Type: FeatureMatch

[Missing <returns> documentation for "M:VisualComponents.Create3D.GenericLicensingHelper.CompareFeatureListToReferenceFeatures(System.String,System.Collections.Generic.ISet{VisualComponents.Create3D.ProductFeature})"]

See Also

Reference

GenericLicensingHelper Class
VisualComponents.Create3D Namespace


GenericLicensingHelper.CompareProductFeatureSets Method

GenericLicensingHelperCompareProductFeatureSets Method

Compares the given feature set to the other feature set.

"SuperSetMatch" mean the subject has only some of the items in other. "ReverseSuperSetMatch" mean the subject has the same items than in other, and more.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static FeatureMatch CompareProductFeatureSets(
    ISet<ProductFeature> subject,
    ISet<ProductFeature> other
)
public:
static FeatureMatch CompareProductFeatureSets(
    ISet<ProductFeature>^ subject,
    ISet<ProductFeature>^ other
)

Parameters

subject
Type: System.Collections.GenericISetProductFeature
other
Type: System.Collections.GenericISetProductFeature

Return Value

Type: FeatureMatch

[Missing <returns> documentation for "M:VisualComponents.Create3D.GenericLicensingHelper.CompareProductFeatureSets(System.Collections.Generic.ISet{VisualComponents.Create3D.ProductFeature},System.Collections.Generic.ISet{VisualComponents.Create3D.ProductFeature})"]

Exceptions
Exception | Condition
ArgumentNullException |
See Also

Reference

GenericLicensingHelper Class
VisualComponents.Create3D Namespace


GenericLicensingHelper.DeactivateStandaloneLicenseKey Method

GenericLicensingHelperDeactivateStandaloneLicenseKey Method

Deactivate a given product key.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void DeactivateStandaloneLicenseKey(
    IProductKey productKey
)
public:
static void DeactivateStandaloneLicenseKey(
    IProductKey^ productKey
)

Parameters

productKey
Type: IProductKey
See Also

Reference

GenericLicensingHelper Class
VisualComponents.Create3D Namespace


GenericLicensingHelper.DoesFeatureListIncludeFeatures Method

GenericLicensingHelperDoesFeatureListIncludeFeatures Method

Returns true if featureList contains referenceFeatures.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool DoesFeatureListIncludeFeatures(
    string featureList,
    ISet<ProductFeature> referenceFeatures
)
public:
static bool DoesFeatureListIncludeFeatures(
    String^ featureList,
    ISet<ProductFeature>^ referenceFeatures
)

Parameters

featureList
Type: SystemString
referenceFeatures
Type: System.Collections.GenericISetProductFeature

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.GenericLicensingHelper.DoesFeatureListIncludeFeatures(System.String,System.Collections.Generic.ISet{VisualComponents.Create3D.ProductFeature})"]

See Also

Reference

GenericLicensingHelper Class
VisualComponents.Create3D Namespace


GenericLicensingHelper.GetActiveStandaloneProductKey Method

GenericLicensingHelperGetActiveStandaloneProductKey Method

Return active standalone product key that have a particular key string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IProductKey GetActiveStandaloneProductKey(
    string productKey,
    ISet<ProductFeature> requiredFeatures
)
public:
static IProductKey^ GetActiveStandaloneProductKey(
    String^ productKey,
    ISet<ProductFeature>^ requiredFeatures
)

Parameters

productKey
Type: SystemString
requiredFeatures
Type: System.Collections.GenericISetProductFeature

Return Value

Type: IProductKey

[Missing <returns> documentation for "M:VisualComponents.Create3D.GenericLicensingHelper.GetActiveStandaloneProductKey(System.String,System.Collections.Generic.ISet{VisualComponents.Create3D.ProductFeature})"]

See Also

Reference

GenericLicensingHelper Class
VisualComponents.Create3D Namespace


GenericLicensingHelper.GetActiveStandaloneProductKeys Method

GenericLicensingHelperGetActiveStandaloneProductKeys Method

Return the first active standalone product key which have the same feature defined in license setting.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IProductKey[] GetActiveStandaloneProductKeys(
    ISet<ProductFeature> productFeatures
)
public:
static array<IProductKey^>^ GetActiveStandaloneProductKeys(
    ISet<ProductFeature>^ productFeatures
)

Parameters

productFeatures
Type: System.Collections.GenericISetProductFeature

Return Value

Type: IProductKey
active standalone proudct key
See Also

Reference

GenericLicensingHelper Class
VisualComponents.Create3D Namespace


GenericLicensingHelper.GetMainFeatureLicensingAvailability Method

GenericLicensingHelperGetMainFeatureLicensingAvailability Method

For local licenses and borrowed network licenses, checks if a license that would activate the requested features is available.

For network licenses, checks if the server has available licenses for all requested features. Note that the network license seat still needs to reserved by calling RequestNetworkLicense(ISetProductFeature, String).

Returns the type of licensing that is available.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ProductLicenseType GetMainFeatureLicensingAvailability(
    LicenseLocations acceptedLocations,
    Action<string> setStatus,
    ISet<ProductFeature> productFeatures,
    ISet<ProductFeature> addOnFeatures,
    string knownProductKey
)
public:
static ProductLicenseType GetMainFeatureLicensingAvailability(
    LicenseLocations acceptedLocations,
    Action<String^>^ setStatus,
    ISet<ProductFeature>^ productFeatures,
    ISet<ProductFeature>^ addOnFeatures,
    String^ knownProductKey
)

Parameters

acceptedLocations
Type: LicenseLocations
setStatus
Type: SystemActionString
productFeatures
Type: System.Collections.GenericISetProductFeature
addOnFeatures
Type: System.Collections.GenericISetProductFeature
knownProductKey
Type: SystemString

Return Value

Type: ProductLicenseType

[Missing <returns> documentation for "M:VisualComponents.Create3D.GenericLicensingHelper.GetMainFeatureLicensingAvailability(VisualComponents.Licensor.LicenseLocations,System.Action{System.String},System.Collections.Generic.ISet{VisualComponents.Create3D.ProductFeature},System.Collections.Generic.ISet{VisualComponents.Create3D.ProductFeature},System.String)"]

See Also

Reference

GenericLicensingHelper Class
VisualComponents.Create3D Namespace


GenericLicensingHelper.IsCommuterCodeInUse Method

GenericLicensingHelperIsCommuterCodeInUse Method

Overload List
Name | Description
IsCommuterCodeInUse(ISetProductFeature) | Checks if commuted license is used for the given product. Returns true if a commuter license is used for the product.
IsCommuterCodeInUse(IProductManager, ISetProductFeature) | Checks if commuted license is used for the given product. Returns true if a commuter license is used for the product.
Top
See Also

Reference

GenericLicensingHelper Class
VisualComponents.Create3D Namespace


GenericLicensingHelper.IsCommuterCodeInUse Method (ISet(ProductFeature))

GenericLicensingHelperIsCommuterCodeInUse Method (ISetProductFeature)

Checks if commuted license is used for the given product. Returns true if a commuter license is used for the product.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsCommuterCodeInUse(
    ISet<ProductFeature> featureSet
)
public:
static bool IsCommuterCodeInUse(
    ISet<ProductFeature>^ featureSet
)

Parameters

featureSet
Type: System.Collections.GenericISetProductFeature
The set of features that the product has.

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.GenericLicensingHelper.IsCommuterCodeInUse(System.Collections.Generic.ISet{VisualComponents.Create3D.ProductFeature})"]

See Also

Reference

GenericLicensingHelper Class
IsCommuterCodeInUse Overload
VisualComponents.Create3D Namespace


GenericLicensingHelper.IsCommuterCodeInUse Method (IProductManager, ISet(ProductFeature))

GenericLicensingHelperIsCommuterCodeInUse Method (IProductManager, ISetProductFeature)

Checks if commuted license is used for the given product. Returns true if a commuter license is used for the product.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsCommuterCodeInUse(
    IProductManager manager,
    ISet<ProductFeature> productFeatureSet
)
public:
static bool IsCommuterCodeInUse(
    IProductManager^ manager,
    ISet<ProductFeature>^ productFeatureSet
)

Parameters

manager
Type: IProductManager
IProductManager instance to use.
productFeatureSet
Type: System.Collections.GenericISetProductFeature
The set of features that the product has.

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.GenericLicensingHelper.IsCommuterCodeInUse(VisualComponents.Licensor.IProductManager,System.Collections.Generic.ISet{VisualComponents.Create3D.ProductFeature})"]

Exceptions
Exception | Condition
ArgumentNullException |
See Also

Reference

GenericLicensingHelper Class
IsCommuterCodeInUse Overload
VisualComponents.Create3D Namespace


GenericLicensingHelper.IsStandaloneLicenseInUse Method

GenericLicensingHelperIsStandaloneLicenseInUse Method

A helper method to redirect to either GetActiveStandaloneProductKey(String, ISetProductFeature) or GetActiveStandaloneProductKeys(ISetProductFeature).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsStandaloneLicenseInUse(
    string optionalKey,
    ISet<ProductFeature> requiredFeatures
)
public:
static bool IsStandaloneLicenseInUse(
    String^ optionalKey,
    ISet<ProductFeature>^ requiredFeatures
)

Parameters

optionalKey
Type: SystemString
requiredFeatures
Type: System.Collections.GenericISetProductFeature

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.GenericLicensingHelper.IsStandaloneLicenseInUse(System.String,System.Collections.Generic.ISet{VisualComponents.Create3D.ProductFeature})"]

See Also

Reference

GenericLicensingHelper Class
VisualComponents.Create3D Namespace


GenericLicensingHelper.ReleaseNetworkLicense Method

GenericLicensingHelperReleaseNetworkLicense Method

Releases a network license seat, see RequestNetworkLicense(ISetProductFeature, String).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void ReleaseNetworkLicense(
    ILicense license
)
public:
static void ReleaseNetworkLicense(
    ILicense^ license
)

Parameters

license
Type: ILicense
See Also

Reference

GenericLicensingHelper Class
VisualComponents.Create3D Namespace


GenericLicensingHelper.RequestNetworkLicense Method

GenericLicensingHelperRequestNetworkLicense Method

For all requiredFeatures, reserve a seat and get an object that represents it. See ReleaseNetworkLicense(ILicense) to release the seat.

This method can be called many times and each time it will return a different objects. All of these objects need to be released in order to release the seat.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static (LicenseState combinedState, ILicense[] ) RequestNetworkLicense(
    ISet<ProductFeature> requiredFeatures,
    out string errorMessage
)
public:
static ValueTuple<LicenseState, array<ILicense^>^> RequestNetworkLicense(
    ISet<ProductFeature>^ requiredFeatures,
    [OutAttribute] String^% errorMessage
)

Parameters

requiredFeatures
Type: System.Collections.GenericISetProductFeature
errorMessage
Type: SystemString

Return Value

Type: ValueTupleLicenseState, ILicense

[Missing <returns> documentation for "M:VisualComponents.Create3D.GenericLicensingHelper.RequestNetworkLicense(System.Collections.Generic.ISet{VisualComponents.Create3D.ProductFeature},System.String@)"]

See Also

Reference

GenericLicensingHelper Class
VisualComponents.Create3D Namespace


GeometryFace Enumeration

Faces Handling

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum GeometryFace
public enum class GeometryFace
Members
Member name | Value | Description
GeometryPerFace | 0 | 1 triangle set per face
GeometryPerMaterialFace | 1 | All faces with same color in same geometry sey
Optimize | 2 | All faces in a single set + additional sets if hight number of points or triangles
See Also

Reference

VisualComponents.Create3D Namespace


GeometrySetType Enumeration

Type of the geometry set

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum GeometrySetType
public enum class GeometrySetType
Members
Member name | Value | Description
TriangleSet | 0 | Triangle set
LineSet | 1 | Line set
Text3DSet | 2 | 3d text set
Text2DSet | 3 | 2d text set
PointSet | 4 | Point set
FrameSet | 5 | Frame set
See Also

Reference

VisualComponents.Create3D Namespace


GeoPrimitivePickResult Structure

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct GeoPrimitivePickResult
public value class GeoPrimitivePickResult

The GeoPrimitivePickResult type exposes the following members.

Constructors
 | Name | Description
Public method | GeoPrimitivePickResult | Initializes a new instance of the GeoPrimitivePickResult class
Top
Properties
 | Name | Description
 | Empty |
Public property | GeometrySet |
Public property | GeoPrimitive |
Public property | GeoPrimitiveType |
Public property | NodeReference |
Public property | VisualObject |
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object instances are considered equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(GeoPrimitivePickResult) | Determines whether the specified object instances are considered equal.
Public method | GetHashCode | Returns a hashcode for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Equality | Determines whether the specified object instances are considered equal.
Inequality | Determines whether the specified object instances are not considered equal.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


GeoPrimitivePickResult Constructor

Initializes a new instance of the GeoPrimitivePickResult class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GeoPrimitivePickResult(
    IVisualObject visualObject,
    IGeometrySet geometry,
    GeoPrimitiveType geoPrimitiveType,
    Object geoPrimitive,
    IntPtr nodeReference
)
public:
GeoPrimitivePickResult(
    IVisualObject^ visualObject,
    IGeometrySet^ geometry,
    GeoPrimitiveType geoPrimitiveType,
    Object^ geoPrimitive,
    IntPtr nodeReference
)

Parameters

visualObject
Type: VisualComponents.Create3DIVisualObject
geometry
Type: VisualComponents.Create3DIGeometrySet
geoPrimitiveType
Type: VisualComponents.Create3DGeoPrimitiveType
geoPrimitive
Type: SystemObject
nodeReference
Type: SystemIntPtr
See Also

Reference

GeoPrimitivePickResult Structure
VisualComponents.Create3D Namespace


GeoPrimitivePickResult Properties

The GeoPrimitivePickResult type exposes the following members.

Properties
 | Name | Description
 | Empty |
Public property | GeometrySet |
Public property | GeoPrimitive |
Public property | GeoPrimitiveType |
Public property | NodeReference |
Public property | VisualObject |
Top
See Also

Reference

GeoPrimitivePickResult Structure
VisualComponents.Create3D Namespace


GeoPrimitivePickResult.Empty Property

GeoPrimitivePickResultEmpty Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static GeoPrimitivePickResult Empty { get; }
public:
static property GeoPrimitivePickResult Empty {
    GeoPrimitivePickResult get ();
}

Property Value

Type: GeoPrimitivePickResult
See Also

Reference

GeoPrimitivePickResult Structure
VisualComponents.Create3D Namespace


GeoPrimitivePickResult.GeometrySet Property

GeoPrimitivePickResultGeometrySet Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IGeometrySet GeometrySet { get; }
public:
property IGeometrySet^ GeometrySet {
    IGeometrySet^ get ();
}

Property Value

Type: IGeometrySet
See Also

Reference

GeoPrimitivePickResult Structure
VisualComponents.Create3D Namespace


GeoPrimitivePickResult.GeoPrimitive Property

GeoPrimitivePickResultGeoPrimitive Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object GeoPrimitive { get; set; }
public:
property Object^ GeoPrimitive {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

GeoPrimitivePickResult Structure
VisualComponents.Create3D Namespace


GeoPrimitivePickResult.GeoPrimitiveType Property

GeoPrimitivePickResultGeoPrimitiveType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GeoPrimitiveType GeoPrimitiveType { get; }
public:
property GeoPrimitiveType GeoPrimitiveType {
    GeoPrimitiveType get ();
}

Property Value

Type: GeoPrimitiveType
See Also

Reference

GeoPrimitivePickResult Structure
VisualComponents.Create3D Namespace


GeoPrimitivePickResult.NodeReference Property

GeoPrimitivePickResultNodeReference Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IntPtr NodeReference { get; }
public:
property IntPtr NodeReference {
    IntPtr get ();
}

Property Value

Type: IntPtr
See Also

Reference

GeoPrimitivePickResult Structure
VisualComponents.Create3D Namespace


GeoPrimitivePickResult.VisualObject Property

GeoPrimitivePickResultVisualObject Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IVisualObject VisualObject { get; }
public:
property IVisualObject^ VisualObject {
    IVisualObject^ get ();
}

Property Value

Type: IVisualObject
See Also

Reference

GeoPrimitivePickResult Structure
VisualComponents.Create3D Namespace


GeoPrimitivePickResult Methods

The GeoPrimitivePickResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object instances are considered equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(GeoPrimitivePickResult) | Determines whether the specified object instances are considered equal.
Public method | GetHashCode | Returns a hashcode for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

GeoPrimitivePickResult Structure
VisualComponents.Create3D Namespace


GeoPrimitivePickResult.Equals Method

GeoPrimitivePickResultEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object instances are considered equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(GeoPrimitivePickResult) | Determines whether the specified object instances are considered equal.
Top
See Also

Reference

GeoPrimitivePickResult Structure
VisualComponents.Create3D Namespace


GeoPrimitivePickResult.Equals Method (Object)

GeoPrimitivePickResultEquals Method (Object)

Determines whether the specified object instances are considered equal.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
The object to compare with the current object.

Return Value

Type: Boolean
true if the objects are considered equal; otherwise, false.
See Also

Reference

GeoPrimitivePickResult Structure
Equals Overload
VisualComponents.Create3D Namespace


GeoPrimitivePickResult.Equals Method (GeoPrimitivePickResult)

GeoPrimitivePickResultEquals Method (GeoPrimitivePickResult)

Determines whether the specified object instances are considered equal.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    GeoPrimitivePickResult other
)
public:
bool Equals(
    GeoPrimitivePickResult other
)

Parameters

other
Type: VisualComponents.Create3DGeoPrimitivePickResult
The object to compare with the current object.

Return Value

Type: Boolean
true if the objects are considered equal; otherwise, false.
See Also

Reference

GeoPrimitivePickResult Structure
Equals Overload
VisualComponents.Create3D Namespace


GeoPrimitivePickResult.GetHashCode Method

GeoPrimitivePickResultGetHashCode Method

Returns a hashcode for this object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32
the hahscode.
See Also

Reference

GeoPrimitivePickResult Structure
VisualComponents.Create3D Namespace


GeoPrimitivePickResult Operators

The GeoPrimitivePickResult type exposes the following members.

Operators
Name | Description
Equality | Determines whether the specified object instances are considered equal.
Inequality | Determines whether the specified object instances are not considered equal.
Top
See Also

Reference

GeoPrimitivePickResult Structure
VisualComponents.Create3D Namespace


GeoPrimitivePickResult.Equality Operator

GeoPrimitivePickResultEquality Operator

Determines whether the specified object instances are considered equal.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    GeoPrimitivePickResult result1,
    GeoPrimitivePickResult result2
)
public:
static bool operator ==(
    GeoPrimitivePickResult result1,
    GeoPrimitivePickResult result2
)

Parameters

result1
Type: VisualComponents.Create3DGeoPrimitivePickResult
The first object to compare.
result2
Type: VisualComponents.Create3DGeoPrimitivePickResult
The second object to compare.

Return Value

Type: Boolean
true if the objects are considered equal; otherwise, false.
See Also

Reference

GeoPrimitivePickResult Structure
VisualComponents.Create3D Namespace


GeoPrimitivePickResult.Inequality Operator

GeoPrimitivePickResultInequality Operator

Determines whether the specified object instances are not considered equal.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    GeoPrimitivePickResult result1,
    GeoPrimitivePickResult result2
)
public:
static bool operator !=(
    GeoPrimitivePickResult result1,
    GeoPrimitivePickResult result2
)

Parameters

result1
Type: VisualComponents.Create3DGeoPrimitivePickResult
The first object to compare.
result2
Type: VisualComponents.Create3DGeoPrimitivePickResult
The second object to compare.

Return Value

Type: Boolean
true if the objects are not considered equal; otherwise, true.
See Also

Reference

GeoPrimitivePickResult Structure
VisualComponents.Create3D Namespace


GeoPrimitiveType Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum GeoPrimitiveType
public enum class GeoPrimitiveType
Members
Member name | Value | Description
None | 0 |
Point | 1 |
Face | 2 |
Edge | 3 |
EdgeLoop | 4 |
GuideFrame | 5 |
See Also

Reference

VisualComponents.Create3D Namespace


GetAssemblyDataSource Enumeration

Options for input source in IGetAssemblyStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum GetAssemblyDataSource
public enum class GetAssemblyDataSource
Members
Member name | Value | Description
AssemblyInstance | 0 | Read the data from an assembly product instance.
AssemblyProductType | 1 | Read the data from an assembly Product Type definition in the layout.
See Also

Reference

VisualComponents.Create3D Namespace


GetAssemblyStepSelectionMode Enumeration

Options for assembly step selection in IGetAssemblyStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum GetAssemblyStepSelectionMode
public enum class GetAssemblyStepSelectionMode
Members
Member name | Value | Description
FirstIncomplete | 0 | Select the first assembly step which has at least one of its slots filled, but not all of them.
FirstEmpty | 1 | Select the first assembly step which has none of its slots filled.
FirstComplete | 2 | Select the first assembly step which has all of its slots filled.
LastWithProduct | 3 | Select the last assembly step which has at least one of its slots filled.
See Also

Reference

VisualComponents.Create3D Namespace


GroupChange Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DChange
VisualComponents.Create3DGroupChange

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class GroupChange : Change
public ref class GroupChange sealed : public Change

The GroupChange type exposes the following members.

Constructors
 | Name | Description
Public method | GroupChange | Initializes a new instance of the GroupChange class
Top
Properties
 | Name | Description
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from Change.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


GroupChange Constructor

Initializes a new instance of the GroupChange class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GroupChange(
    IGroup group,
    IApplication app,
    bool isCreated
)
public:
GroupChange(
    IGroup^ group,
    IApplication^ app,
    bool isCreated
)

Parameters

group
Type: VisualComponents.Create3DIGroup
app
Type: VisualComponents.Create3DIApplication
isCreated
Type: SystemBoolean
See Also

Reference

GroupChange Class
VisualComponents.Create3D Namespace


GroupChange Properties

The GroupChange type exposes the following members.

Properties
 | Name | Description
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Top
See Also

Reference

GroupChange Class
VisualComponents.Create3D Namespace


GroupChange Methods

The GroupChange type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from Change.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

GroupChange Class
VisualComponents.Create3D Namespace


HeartbeatEventArgs Class

Heartbeat event args
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DHeartbeatEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class HeartbeatEventArgs : EventArgs
public ref class HeartbeatEventArgs : public EventArgs

The HeartbeatEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | HeartbeatEventArgs | Constructor
Top
Properties
 | Name | Description
Public property | Time | Heartbeat interval
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


HeartbeatEventArgs Constructor

Constructor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public HeartbeatEventArgs(
    double time
)
public:
HeartbeatEventArgs(
    double time
)

Parameters

time
Type: SystemDouble
Heartbeat interval
See Also

Reference

HeartbeatEventArgs Class
VisualComponents.Create3D Namespace


HeartbeatEventArgs Properties

The HeartbeatEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Time | Heartbeat interval
Top
See Also

Reference

HeartbeatEventArgs Class
VisualComponents.Create3D Namespace


HeartbeatEventArgs.Time Property

HeartbeatEventArgsTime Property

Heartbeat interval

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Time { get; }
public:
property double Time {
    double get ();
}

Property Value

Type: Double
See Also

Reference

HeartbeatEventArgs Class
VisualComponents.Create3D Namespace


HeartbeatEventArgs Methods

The HeartbeatEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

HeartbeatEventArgs Class
VisualComponents.Create3D Namespace


HiddenLineRepresentation Class

Class that represents the result of a hidden line from a given layout or part of a layout.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DHiddenLineRepresentation

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class HiddenLineRepresentation
public ref class HiddenLineRepresentation

The HiddenLineRepresentation type exposes the following members.

Constructors
 | Name | Description
Public method | HiddenLineRepresentation | Initializes a new instance of the HiddenLineRepresentation class
Top
Properties
 | Name | Description
Public property | Frames | List of frames.
Public property | Lines | List of lines.
Public property | Position | Position of this item.
Public property | Texts | List of texts.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetFrames | Set the frames of the result.
Public method | SetLines | Set the lines of the result.
Public method | SetTexts | Set the texts of the result.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


HiddenLineRepresentation Constructor

Initializes a new instance of the HiddenLineRepresentation class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public HiddenLineRepresentation()
public:
HiddenLineRepresentation()
See Also

Reference

HiddenLineRepresentation Class
VisualComponents.Create3D Namespace


HiddenLineRepresentation Properties

The HiddenLineRepresentation type exposes the following members.

Properties
 | Name | Description
Public property | Frames | List of frames.
Public property | Lines | List of lines.
Public property | Position | Position of this item.
Public property | Texts | List of texts.
Top
See Also

Reference

HiddenLineRepresentation Class
VisualComponents.Create3D Namespace


HiddenLineRepresentation.Frames Property

HiddenLineRepresentationFrames Property

List of frames.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<IFrame> Frames { get; }
public:
property ReadOnlyCollection<IFrame^>^ Frames {
    ReadOnlyCollection<IFrame^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIFrame
See Also

Reference

HiddenLineRepresentation Class
VisualComponents.Create3D Namespace


HiddenLineRepresentation.Lines Property

HiddenLineRepresentationLines Property

List of lines.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<ILineSet> Lines { get; }
public:
property ReadOnlyCollection<ILineSet^>^ Lines {
    ReadOnlyCollection<ILineSet^>^ get ();
}

Property Value

Type: ReadOnlyCollectionILineSet
See Also

Reference

HiddenLineRepresentation Class
VisualComponents.Create3D Namespace


HiddenLineRepresentation.Position Property

HiddenLineRepresentationPosition Property

Position of this item.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 Position { get; set; }
public:
property Vector3 Position {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

HiddenLineRepresentation Class
VisualComponents.Create3D Namespace


HiddenLineRepresentation.Texts Property

HiddenLineRepresentationTexts Property

List of texts.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<IText3DSet> Texts { get; }
public:
property ReadOnlyCollection<IText3DSet^>^ Texts {
    ReadOnlyCollection<IText3DSet^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIText3DSet
See Also

Reference

HiddenLineRepresentation Class
VisualComponents.Create3D Namespace


HiddenLineRepresentation Methods

The HiddenLineRepresentation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetFrames | Set the frames of the result.
Public method | SetLines | Set the lines of the result.
Public method | SetTexts | Set the texts of the result.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

HiddenLineRepresentation Class
VisualComponents.Create3D Namespace


HiddenLineRepresentation.SetFrames Method

HiddenLineRepresentationSetFrames Method

Set the frames of the result.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetFrames(
    IEnumerable<IFrame> frames
)
public:
void SetFrames(
    IEnumerable<IFrame^>^ frames
)

Parameters

frames
Type: System.Collections.GenericIEnumerableIFrame
See Also

Reference

HiddenLineRepresentation Class
VisualComponents.Create3D Namespace


HiddenLineRepresentation.SetLines Method

HiddenLineRepresentationSetLines Method

Set the lines of the result.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetLines(
    IEnumerable<ILineSet> lines
)
public:
void SetLines(
    IEnumerable<ILineSet^>^ lines
)

Parameters

lines
Type: System.Collections.GenericIEnumerableILineSet
See Also

Reference

HiddenLineRepresentation Class
VisualComponents.Create3D Namespace


HiddenLineRepresentation.SetTexts Method

HiddenLineRepresentationSetTexts Method

Set the texts of the result.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetTexts(
    IEnumerable<IText3DSet> texts
)
public:
void SetTexts(
    IEnumerable<IText3DSet^>^ texts
)

Parameters

texts
Type: System.Collections.GenericIEnumerableIText3DSet
See Also

Reference

HiddenLineRepresentation Class
VisualComponents.Create3D Namespace


HiddenPartsImport Enumeration

CAD import hidden (visible) parts

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum HiddenPartsImport
public enum class HiddenPartsImport
Members
Member name | Value | Description
Load | 0 | Read hidden parts
Skip | 1 | Skip hidden parts
Ondemand | 2 | (for feature use)
See Also

Reference

VisualComponents.Create3D Namespace


HierarchyChangeType Enumeration

Specifies the type of a change in a feature hierarchy

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum HierarchyChangeType
public enum class HierarchyChangeType
Members
Member name | Value | Description
Rebuild | 0 |
UpdateNode | 1 |
AddFirstChild | 2 |
AddLastChild | 3 |
RemoveNode | 4 |
InsertFirstSibling | 5 |
InsertLastSibling | 6 |
InsertAfterSibling | 7 |
InsertBeforeSibling | 8 |
See Also

Reference

VisualComponents.Create3D Namespace


HistoryItem Structure

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct HistoryItem
public value class HistoryItem

The HistoryItem type exposes the following members.

Properties
 | Name | Description
Public property | Timestamp |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Equality |
Inequality |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


HistoryItem Properties

The HistoryItem type exposes the following members.

Properties
 | Name | Description
Public property | Timestamp |
Public property | Value |
Top
See Also

Reference

HistoryItem Structure
VisualComponents.Create3D Namespace


HistoryItem.Timestamp Property

HistoryItemTimestamp Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float Timestamp { get; set; }
public:
property float Timestamp {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

HistoryItem Structure
VisualComponents.Create3D Namespace


HistoryItem.Value Property

HistoryItemValue Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float Value { get; set; }
public:
property float Value {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

HistoryItem Structure
VisualComponents.Create3D Namespace


HistoryItem Methods

The HistoryItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

HistoryItem Structure
VisualComponents.Create3D Namespace


HistoryItem.Equals Method

HistoryItemEquals Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.HistoryItem.Equals(System.Object)"]

See Also

Reference

HistoryItem Structure
VisualComponents.Create3D Namespace


HistoryItem.GetHashCode Method

HistoryItemGetHashCode Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.HistoryItem.GetHashCode"]

See Also

Reference

HistoryItem Structure
VisualComponents.Create3D Namespace


HistoryItem Operators

The HistoryItem type exposes the following members.

Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

HistoryItem Structure
VisualComponents.Create3D Namespace


HistoryItem.Equality Operator

HistoryItemEquality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    HistoryItem first,
    HistoryItem second
)
public:
static bool operator ==(
    HistoryItem first,
    HistoryItem second
)

Parameters

first
Type: VisualComponents.Create3DHistoryItem
second
Type: VisualComponents.Create3DHistoryItem

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.HistoryItem.op_Equality(VisualComponents.Create3D.HistoryItem,VisualComponents.Create3D.HistoryItem)"]

See Also

Reference

HistoryItem Structure
VisualComponents.Create3D Namespace


HistoryItem.Inequality Operator

HistoryItemInequality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    HistoryItem first,
    HistoryItem second
)
public:
static bool operator !=(
    HistoryItem first,
    HistoryItem second
)

Parameters

first
Type: VisualComponents.Create3DHistoryItem
second
Type: VisualComponents.Create3DHistoryItem

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.HistoryItem.op_Inequality(VisualComponents.Create3D.HistoryItem,VisualComponents.Create3D.HistoryItem)"]

See Also

Reference

HistoryItem Structure
VisualComponents.Create3D Namespace


IActionContainer Interface

Behavior used for storing information about various actions, such as grab, release, toggle trace on and others.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IActionContainer : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IActionContainer : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IActionContainer type exposes the following members.

Properties
 | Name | Description
Public property | Actions | Retrieves the list of ISimAction objects in the container.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddAction | Adds an existing ISimAction to this action container.
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateAction | Creates and returns a new ISimAction.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | RemoveAction | Deletes the given ISimAction.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SwapActions | Swaps ISimAction objects between the given action container.
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
Container actions are activated with plug&play functionality and ISimInterfaceActionField field.
See Also

Reference

VisualComponents.Create3D Namespace


IActionContainer Properties

The IActionContainer type exposes the following members.

Properties
 | Name | Description
Public property | Actions | Retrieves the list of ISimAction objects in the container.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IActionContainer Interface
VisualComponents.Create3D Namespace


IActionContainer.Actions Property

IActionContainerActions Property

Retrieves the list of ISimAction objects in the container.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ISimAction> Actions { get; }
property ReadOnlyCollection<ISimAction^>^ Actions {
    ReadOnlyCollection<ISimAction^>^ get ();
}

Property Value

Type: ReadOnlyCollectionISimAction
See Also

Reference

IActionContainer Interface
VisualComponents.Create3D Namespace


IActionContainer Methods

The IActionContainer type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddAction | Adds an existing ISimAction to this action container.
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateAction | Creates and returns a new ISimAction.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | RemoveAction | Deletes the given ISimAction.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SwapActions | Swaps ISimAction objects between the given action container.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IActionContainer Interface
VisualComponents.Create3D Namespace


IActionContainer.AddAction Method

IActionContainerAddAction Method

Adds an existing ISimAction to this action container.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddAction(
    ISimAction action
)
void AddAction(
    ISimAction^ action
)

Parameters

action
Type: VisualComponents.Create3DISimAction
Action to be added.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when action parameter is null.
See Also

Reference

IActionContainer Interface
VisualComponents.Create3D Namespace


IActionContainer.CreateAction Method

IActionContainerCreateAction Method

Creates and returns a new ISimAction.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimAction CreateAction()
ISimAction^ CreateAction()

Return Value

Type: ISimAction

[Missing <returns> documentation for "M:VisualComponents.Create3D.IActionContainer.CreateAction"]

See Also

Reference

IActionContainer Interface
VisualComponents.Create3D Namespace


IActionContainer.RemoveAction Method

IActionContainerRemoveAction Method

Deletes the given ISimAction.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RemoveAction(
    ISimAction action
)
void RemoveAction(
    ISimAction^ action
)

Parameters

action
Type: VisualComponents.Create3DISimAction
Action to be deleted.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when action parameter is null.
See Also

Reference

IActionContainer Interface
VisualComponents.Create3D Namespace


IActionContainer.SwapActions Method

IActionContainerSwapActions Method

Swaps ISimAction objects between the given action container.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SwapActions(
    IActionContainer actionContainer
)
void SwapActions(
    IActionContainer^ actionContainer
)

Parameters

actionContainer
Type: VisualComponents.Create3DIActionContainer
Action container to be swapped.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when actionContainer parameter is null
See Also

Reference

IActionContainer Interface
VisualComponents.Create3D Namespace


IActionContainer Events

The IActionContainer type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IActionContainer Interface
VisualComponents.Create3D Namespace


IAngularCloneFeature Interface

Represents an angular clone feature object

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IAngularCloneFeature : IFeature,
    IVisualObject, INamed, IWrapper, IDisposable, IVisitable,
    IPropertyContainer, IBatchModeObject, ISharedCloneable
public interface class IAngularCloneFeature : IFeature,
    IVisualObject, INamed, IWrapper, IDisposable, IVisitable,
    IPropertyContainer, IBatchModeObject, ISharedCloneable

The IAngularCloneFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
The Angular Clone operation feature clones all its sub features the specified number of times, rotating each copy about the Z axis.
See Also

Reference

VisualComponents.Create3D Namespace


IAngularCloneFeature Properties

The IAngularCloneFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
See Also

Reference

IAngularCloneFeature Interface
VisualComponents.Create3D Namespace


IAngularCloneFeature Methods

The IAngularCloneFeature type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IAngularCloneFeature Interface
VisualComponents.Create3D Namespace


IAngularCloneFeature Events

The IAngularCloneFeature type exposes the following members.

Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

IAngularCloneFeature Interface
VisualComponents.Create3D Namespace


IAnimationRecorder Interface

Interface for recording vcax animation files.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IAnimationRecorder : IRecorder,
    IDisposable
public interface class IAnimationRecorder : IRecorder,
    IDisposable

The IAnimationRecorder type exposes the following members.

Properties
 | Name | Description
Public property | ClientCount |
Public property | CompressionLevel | Select specific compression plugin, 0 - uncompressed
Public property | FrameRate | Defines the frame rate (fps) of the recorder. (Inherited from IRecorder.)
Public property | IsRecording | Defines if the recorder has been started. (Inherited from IRecorder.)
Public property | IsStarted | Note: IRecorder.IsRecording is not suitable for animation recorder, because animation recorder can also be connected to a server (streaming).
Public property | ProtobufMode |
Public property | RecordingMethod |
Public property | SimulationTimeStreaming |
Top
Methods
 | Name | Description
Public method | ClearMessages |
Public method | CloseClient |
Public method | ConsumePendingMessage |
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | FindObject |
Public method | GetClientId |
Public method | GetObjectId |
Public method | GetPendingMessage |
Public method | IsPeriodicSyncNeeded |
Public method | LoadLayoutEcatInit |
Public method | OnOfflineRecordingStep | Write incremental changes when IsRecording==true and DoStreaming==true.
Public method | OnPeriodicSync |
Public method | SendToSocket |
Public method | SendToSockets |
Public method | Start | Starts and initializes the recorder. (Inherited from IRecorder.)
Public method | Start(AnimationRecordingMethod, Uri, String, String, String, IEnumerableSocket, Boolean, Boolean) | Starts recording. This method should be called after starting simulation.
Public method | Start(AnimationRecordingMethod, Uri, String, String, String, IEnumerableSocket, Boolean, Boolean, Int32) |
Public method | StartAdd(IEnumerableSocket, Boolean, Boolean) |
Public method | StartAdd(IEnumerableSocket, Boolean, Boolean, Int32) |
Public method | Stop | Stops recording.
Public method | Stop(Uri) | Stops the recorder and saves the result to the given file. (Inherited from IRecorder.)
Top
Events
 | Name | Description
Public event | RecordingStartStop | Event triggered when recording starts and stops.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IAnimationRecorder Properties

The IAnimationRecorder type exposes the following members.

Properties
 | Name | Description
Public property | ClientCount |
Public property | CompressionLevel | Select specific compression plugin, 0 - uncompressed
Public property | FrameRate | Defines the frame rate (fps) of the recorder. (Inherited from IRecorder.)
Public property | IsRecording | Defines if the recorder has been started. (Inherited from IRecorder.)
Public property | IsStarted | Note: IRecorder.IsRecording is not suitable for animation recorder, because animation recorder can also be connected to a server (streaming).
Public property | ProtobufMode |
Public property | RecordingMethod |
Public property | SimulationTimeStreaming |
Top
See Also

Reference

IAnimationRecorder Interface
VisualComponents.Create3D Namespace


IAnimationRecorder.ClientCount Property

IAnimationRecorderClientCount Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int ClientCount { get; }
property int ClientCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IAnimationRecorder Interface
VisualComponents.Create3D Namespace


IAnimationRecorder.CompressionLevel Property

IAnimationRecorderCompressionLevel Property

Select specific compression plugin, 0 - uncompressed

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int CompressionLevel { get; set; }
property int CompressionLevel {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IAnimationRecorder Interface
VisualComponents.Create3D Namespace


IAnimationRecorder.IsStarted Property

IAnimationRecorderIsStarted Property

Note: IRecorder.IsRecording is not suitable for animation recorder, because animation recorder can also be connected to a server (streaming).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsStarted { get; }
property bool IsStarted {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IAnimationRecorder Interface
VisualComponents.Create3D Namespace


IAnimationRecorder.ProtobufMode Property

IAnimationRecorderProtobufMode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ProtobufMode { get; }
property bool ProtobufMode {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IAnimationRecorder Interface
VisualComponents.Create3D Namespace


IAnimationRecorder.RecordingMethod Property

IAnimationRecorderRecordingMethod Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
AnimationRecordingMethod RecordingMethod { get; }
property AnimationRecordingMethod RecordingMethod {
    AnimationRecordingMethod get ();
}

Property Value

Type: AnimationRecordingMethod
See Also

Reference

IAnimationRecorder Interface
VisualComponents.Create3D Namespace


IAnimationRecorder.SimulationTimeStreaming Property

IAnimationRecorderSimulationTimeStreaming Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SimulationTimeStreaming { get; set; }
property bool SimulationTimeStreaming {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IAnimationRecorder Interface
VisualComponents.Create3D Namespace


IAnimationRecorder Methods

The IAnimationRecorder type exposes the following members.

Methods
 | Name | Description
Public method | ClearMessages |
Public method | CloseClient |
Public method | ConsumePendingMessage |
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | FindObject |
Public method | GetClientId |
Public method | GetObjectId |
Public method | GetPendingMessage |
Public method | IsPeriodicSyncNeeded |
Public method | LoadLayoutEcatInit |
Public method | OnOfflineRecordingStep | Write incremental changes when IsRecording==true and DoStreaming==true.
Public method | OnPeriodicSync |
Public method | SendToSocket |
Public method | SendToSockets |
Public method | Start | Starts and initializes the recorder. (Inherited from IRecorder.)
Public method | Start(AnimationRecordingMethod, Uri, String, String, String, IEnumerableSocket, Boolean, Boolean) | Starts recording. This method should be called after starting simulation.
Public method | Start(AnimationRecordingMethod, Uri, String, String, String, IEnumerableSocket, Boolean, Boolean, Int32) |
Public method | StartAdd(IEnumerableSocket, Boolean, Boolean) |
Public method | StartAdd(IEnumerableSocket, Boolean, Boolean, Int32) |
Public method | Stop | Stops recording.
Public method | Stop(Uri) | Stops the recorder and saves the result to the given file. (Inherited from IRecorder.)
Top
See Also

Reference

IAnimationRecorder Interface
VisualComponents.Create3D Namespace


IAnimationRecorder.ClearMessages Method

IAnimationRecorderClearMessages Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ClearMessages(
    int exceptStreamId
)
void ClearMessages(
    int exceptStreamId
)

Parameters

exceptStreamId
Type: SystemInt32
See Also

Reference

IAnimationRecorder Interface
VisualComponents.Create3D Namespace


IAnimationRecorder.CloseClient Method

IAnimationRecorderCloseClient Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void CloseClient(
    int clientId
)
void CloseClient(
    int clientId
)

Parameters

clientId
Type: SystemInt32
See Also

Reference

IAnimationRecorder Interface
VisualComponents.Create3D Namespace


IAnimationRecorder.ConsumePendingMessage Method

IAnimationRecorderConsumePendingMessage Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ConsumePendingMessage(
    int clientId,
    int streamId,
    int consumeLength
)
void ConsumePendingMessage(
    int clientId,
    int streamId,
    int consumeLength
)

Parameters

clientId
Type: SystemInt32
streamId
Type: SystemInt32
consumeLength
Type: SystemInt32
See Also

Reference

IAnimationRecorder Interface
VisualComponents.Create3D Namespace


IAnimationRecorder.FindObject Method

IAnimationRecorderFindObject Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object FindObject(
    int type,
    int id
)
Object^ FindObject(
    int type,
    int id
)

Parameters

type
Type: SystemInt32
id
Type: SystemInt32

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.Create3D.IAnimationRecorder.FindObject(System.Int32,System.Int32)"]

See Also

Reference

IAnimationRecorder Interface
VisualComponents.Create3D Namespace


IAnimationRecorder.GetClientId Method

IAnimationRecorderGetClientId Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int GetClientId(
    int clientSelfId
)
int GetClientId(
    int clientSelfId
)

Parameters

clientSelfId
Type: SystemInt32

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.IAnimationRecorder.GetClientId(System.Int32)"]

See Also

Reference

IAnimationRecorder Interface
VisualComponents.Create3D Namespace


IAnimationRecorder.GetObjectId Method

IAnimationRecorderGetObjectId Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int GetObjectId(
    int type,
    Object item
)
int GetObjectId(
    int type,
    Object^ item
)

Parameters

type
Type: SystemInt32
item
Type: SystemObject

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.IAnimationRecorder.GetObjectId(System.Int32,System.Object)"]

See Also

Reference

IAnimationRecorder Interface
VisualComponents.Create3D Namespace


IAnimationRecorder.GetPendingMessage Method

IAnimationRecorderGetPendingMessage Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IntPtr GetPendingMessage(
    int clientId,
    int streamId,
    ref int size,
    ref bool webSocketMode,
    ref bool protobufMode
)
IntPtr GetPendingMessage(
    int clientId,
    int streamId,
    int% size,
    bool% webSocketMode,
    bool% protobufMode
)

Parameters

clientId
Type: SystemInt32
streamId
Type: SystemInt32
size
Type: SystemInt32
webSocketMode
Type: SystemBoolean
protobufMode
Type: SystemBoolean

Return Value

Type: IntPtr

[Missing <returns> documentation for "M:VisualComponents.Create3D.IAnimationRecorder.GetPendingMessage(System.Int32,System.Int32,System.Int32@,System.Boolean@,System.Boolean@)"]

See Also

Reference

IAnimationRecorder Interface
VisualComponents.Create3D Namespace


IAnimationRecorder.IsPeriodicSyncNeeded Method

IAnimationRecorderIsPeriodicSyncNeeded Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsPeriodicSyncNeeded(
    int streamId
)
bool IsPeriodicSyncNeeded(
    int streamId
)

Parameters

streamId
Type: SystemInt32

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IAnimationRecorder.IsPeriodicSyncNeeded(System.Int32)"]

See Also

Reference

IAnimationRecorder Interface
VisualComponents.Create3D Namespace


IAnimationRecorder.LoadLayoutEcatInit Method

IAnimationRecorderLoadLayoutEcatInit Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void LoadLayoutEcatInit(
    bool enable,
    int client,
    int startIndex
)
void LoadLayoutEcatInit(
    bool enable,
    int client,
    int startIndex
)

Parameters

enable
Type: SystemBoolean
client
Type: SystemInt32
startIndex
Type: SystemInt32
See Also

Reference

IAnimationRecorder Interface
VisualComponents.Create3D Namespace


IAnimationRecorder.OnOfflineRecordingStep Method

IAnimationRecorderOnOfflineRecordingStep Method

Write incremental changes when IsRecording==true and DoStreaming==true.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void OnOfflineRecordingStep()
void OnOfflineRecordingStep()
See Also

Reference

IAnimationRecorder Interface
VisualComponents.Create3D Namespace


IAnimationRecorder.OnPeriodicSync Method

IAnimationRecorderOnPeriodicSync Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool OnPeriodicSync()
bool OnPeriodicSync()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IAnimationRecorder.OnPeriodicSync"]

See Also

Reference

IAnimationRecorder Interface
VisualComponents.Create3D Namespace


IAnimationRecorder.SendToSocket Method

IAnimationRecorderSendToSocket Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SendToSocket(
    int clientId,
    int streamId,
    byte[] buffer
)
void SendToSocket(
    int clientId,
    int streamId,
    array<unsigned char>^ buffer
)

Parameters

clientId
Type: SystemInt32
streamId
Type: SystemInt32
buffer
Type: SystemByte
See Also

Reference

IAnimationRecorder Interface
VisualComponents.Create3D Namespace


IAnimationRecorder.SendToSockets Method

IAnimationRecorderSendToSockets Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SendToSockets(
    int streamId,
    byte[] buffer,
    bool protobufMode
)
void SendToSockets(
    int streamId,
    array<unsigned char>^ buffer,
    bool protobufMode
)

Parameters

streamId
Type: SystemInt32
buffer
Type: SystemByte
protobufMode
Type: SystemBoolean
See Also

Reference

IAnimationRecorder Interface
VisualComponents.Create3D Namespace


IAnimationRecorder.Start Method

IAnimationRecorderStart Method

Overload List
 | Name | Description
Public method | Start | Starts and initializes the recorder. (Inherited from IRecorder.)
Public method | Start(AnimationRecordingMethod, Uri, String, String, String, IEnumerableSocket, Boolean, Boolean) | Starts recording. This method should be called after starting simulation.
Public method | Start(AnimationRecordingMethod, Uri, String, String, String, IEnumerableSocket, Boolean, Boolean, Int32) |
Top
See Also

Reference

IAnimationRecorder Interface
VisualComponents.Create3D Namespace


IAnimationRecorder.Start Method (AnimationRecordingMethod, Uri, String, String, String, IEnumerable(Socket), Boolean, Boolean)

IAnimationRecorderStart Method (AnimationRecordingMethod, Uri, String, String, String, IEnumerableSocket, Boolean, Boolean)

Starts recording. This method should be called after starting simulation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool Start(
    AnimationRecordingMethod recordingMethod,
    Uri file,
    string recordingName,
    string host,
    string port,
    IEnumerable<Socket> sockets,
    bool webSocketMode,
    bool protobufMode
)
bool Start(
    AnimationRecordingMethod recordingMethod,
    Uri^ file,
    String^ recordingName,
    String^ host,
    String^ port,
    IEnumerable<Socket^>^ sockets,
    bool webSocketMode,
    bool protobufMode
)

Parameters

recordingMethod
Type: VisualComponents.Create3DAnimationRecordingMethod
file
Type: SystemUri
File where the recorder animation is saved to.
recordingName
Type: SystemString
Name of the recording.
host
Type: SystemString
port
Type: SystemString
sockets
Type: System.Collections.GenericIEnumerableSocket
webSocketMode
Type: SystemBoolean
protobufMode
Type: SystemBoolean

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IAnimationRecorder.Start(VisualComponents.Create3D.AnimationRecordingMethod,System.Uri,System.String,System.String,System.String,System.Collections.Generic.IEnumerable{System.Net.Sockets.Socket},System.Boolean,System.Boolean)"]

See Also

Reference

IAnimationRecorder Interface
Start Overload
VisualComponents.Create3D Namespace


IAnimationRecorder.Start Method (AnimationRecordingMethod, Uri, String, String, String, IEnumerable(Socket), Boolean, Boolean, Int32)

IAnimationRecorderStart Method (AnimationRecordingMethod, Uri, String, String, String, IEnumerableSocket, Boolean, Boolean, Int32)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool Start(
    AnimationRecordingMethod recordingMethod,
    Uri file,
    string recordingName,
    string host,
    string port,
    IEnumerable<Socket> sockets,
    bool webSocketMode,
    bool protobufMode,
    int clientSelfId
)
bool Start(
    AnimationRecordingMethod recordingMethod,
    Uri^ file,
    String^ recordingName,
    String^ host,
    String^ port,
    IEnumerable<Socket^>^ sockets,
    bool webSocketMode,
    bool protobufMode,
    int clientSelfId
)

Parameters

recordingMethod
Type: VisualComponents.Create3DAnimationRecordingMethod
file
Type: SystemUri
recordingName
Type: SystemString
host
Type: SystemString
port
Type: SystemString
sockets
Type: System.Collections.GenericIEnumerableSocket
webSocketMode
Type: SystemBoolean
protobufMode
Type: SystemBoolean
clientSelfId
Type: SystemInt32

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IAnimationRecorder.Start(VisualComponents.Create3D.AnimationRecordingMethod,System.Uri,System.String,System.String,System.String,System.Collections.Generic.IEnumerable{System.Net.Sockets.Socket},System.Boolean,System.Boolean,System.Int32)"]

See Also

Reference

IAnimationRecorder Interface
Start Overload
VisualComponents.Create3D Namespace


IAnimationRecorder.StartAdd Method

IAnimationRecorderStartAdd Method

Overload List
 | Name | Description
Public method | StartAdd(IEnumerableSocket, Boolean, Boolean) |
Public method | StartAdd(IEnumerableSocket, Boolean, Boolean, Int32) |
Top
See Also

Reference

IAnimationRecorder Interface
VisualComponents.Create3D Namespace


IAnimationRecorder.StartAdd Method (IEnumerable(Socket), Boolean, Boolean)

IAnimationRecorderStartAdd Method (IEnumerableSocket, Boolean, Boolean)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool StartAdd(
    IEnumerable<Socket> sockets,
    bool webSocketMode,
    bool protobufMode
)
bool StartAdd(
    IEnumerable<Socket^>^ sockets,
    bool webSocketMode,
    bool protobufMode
)

Parameters

sockets
Type: System.Collections.GenericIEnumerableSocket
webSocketMode
Type: SystemBoolean
protobufMode
Type: SystemBoolean

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IAnimationRecorder.StartAdd(System.Collections.Generic.IEnumerable{System.Net.Sockets.Socket},System.Boolean,System.Boolean)"]

See Also

Reference

IAnimationRecorder Interface
StartAdd Overload
VisualComponents.Create3D Namespace


IAnimationRecorder.StartAdd Method (IEnumerable(Socket), Boolean, Boolean, Int32)

IAnimationRecorderStartAdd Method (IEnumerableSocket, Boolean, Boolean, Int32)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool StartAdd(
    IEnumerable<Socket> sockets,
    bool webSocketMode,
    bool protobufMode,
    int clientSelfId
)
bool StartAdd(
    IEnumerable<Socket^>^ sockets,
    bool webSocketMode,
    bool protobufMode,
    int clientSelfId
)

Parameters

sockets
Type: System.Collections.GenericIEnumerableSocket
webSocketMode
Type: SystemBoolean
protobufMode
Type: SystemBoolean
clientSelfId
Type: SystemInt32

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IAnimationRecorder.StartAdd(System.Collections.Generic.IEnumerable{System.Net.Sockets.Socket},System.Boolean,System.Boolean,System.Int32)"]

See Also

Reference

IAnimationRecorder Interface
StartAdd Overload
VisualComponents.Create3D Namespace


IAnimationRecorder.Stop Method

IAnimationRecorderStop Method

Overload List
 | Name | Description
Public method | Stop | Stops recording.
Public method | Stop(Uri) | Stops the recorder and saves the result to the given file. (Inherited from IRecorder.)
Top
See Also

Reference

IAnimationRecorder Interface
VisualComponents.Create3D Namespace


IAnimationRecorder.Stop Method

IAnimationRecorderStop Method

Stops recording.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Stop()
void Stop()
See Also

Reference

IAnimationRecorder Interface
Stop Overload
VisualComponents.Create3D Namespace


IAnimationRecorder Events

The IAnimationRecorder type exposes the following members.

Events
 | Name | Description
Public event | RecordingStartStop | Event triggered when recording starts and stops.
Top
See Also

Reference

IAnimationRecorder Interface
VisualComponents.Create3D Namespace


IAnimationRecorder.RecordingStartStop Event

IAnimationRecorderRecordingStartStop Event

Event triggered when recording starts and stops.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<RecordingStartStopEventArgs> RecordingStartStop
 event EventHandler<RecordingStartStopEventArgs^>^ RecordingStartStop {
    void add (EventHandler<RecordingStartStopEventArgs^>^ value);
    void remove (EventHandler<RecordingStartStopEventArgs^>^ value);
}

Value

Type: SystemEventHandlerRecordingStartStopEventArgs
See Also

Reference

IAnimationRecorder Interface
VisualComponents.Create3D Namespace


IAnnotation Interface

Annotation layout item interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IAnnotation : IVisualObject,
    INamed, IWrapper, IDisposable, IGroupableItem, ILayoutItem,
    IPropertyContainer, IBatchModeObject
public interface class IAnnotation : IVisualObject,
    INamed, IWrapper, IDisposable, IGroupableItem, ILayoutItem,
    IPropertyContainer, IBatchModeObject

The IAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Background | Specifies if background is displayed for the annotation
Public property | BackgroundMaterial | Annotation background rendering material
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Drawing | Drawing item where the annotation is attached, if any
Public property | Geometry | Annotation geometry, as rendered
Public property | Group | (Inherited from IGroupableItem.)
Public property | Height | Font height of the annotation text
Public property | IndicationSize | Indication rendering size
Public property | IndicationStyle | Annotation attachment indication rendering style
Public property | IsFloating | Specifies if the annotation is floating. Floating annotations are facing the camera.
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsPersistent | Defines if the ILayoutItem is stored with the layout. (Inherited from ILayoutItem.)
Public property | IsTextSetForMultipleLines | Annotation text supports multiple lines
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | LockToNode | Whether the annotation will follow the node, or stay fixed
Public property | Material | Annotation text rendering material
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Simulation node where the annotation is attached, if any
Public property | NodePosition | Attachment point position, relative to current visual object
Public property | NodePositionInWorld | Attachment point position in world coordinates
Public property | OutlineMaterial | Annotation outline rendering material
Public property | OutlineSpacing | Margin between the annotation text and outline
Public property | OutlineStyle | Annotation outline rendering style
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | Property | Associated property value to display
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | Text | Annotation text string
Public property | Thickness | Font boldness of the annotation text
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IVisualObject.)
Public property | TransformationInWorld | Gets or sets the world transformation matrix (Inherited from IVisualObject.)
Public property | VisualObjectPosition | Position of the attachment point visual object
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks

An annotation is a floating text object in the layout or in the drawing view.

The position of the annotation determines where the text is displayed. In addition to this, an annotation has an attachment point which may be connected to an object in the layout or drawing view. This attachment point can be indicated with a point or a line from the annotation text.

An annotation can also be associated with a dynamic property through the Property property. In this case, it will display the property value in the annotation text.

See Also

Reference

VisualComponents.Create3D Namespace


IAnnotation Properties

The IAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | Background | Specifies if background is displayed for the annotation
Public property | BackgroundMaterial | Annotation background rendering material
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Drawing | Drawing item where the annotation is attached, if any
Public property | Geometry | Annotation geometry, as rendered
Public property | Group | (Inherited from IGroupableItem.)
Public property | Height | Font height of the annotation text
Public property | IndicationSize | Indication rendering size
Public property | IndicationStyle | Annotation attachment indication rendering style
Public property | IsFloating | Specifies if the annotation is floating. Floating annotations are facing the camera.
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsPersistent | Defines if the ILayoutItem is stored with the layout. (Inherited from ILayoutItem.)
Public property | IsTextSetForMultipleLines | Annotation text supports multiple lines
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | LockToNode | Whether the annotation will follow the node, or stay fixed
Public property | Material | Annotation text rendering material
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Simulation node where the annotation is attached, if any
Public property | NodePosition | Attachment point position, relative to current visual object
Public property | NodePositionInWorld | Attachment point position in world coordinates
Public property | OutlineMaterial | Annotation outline rendering material
Public property | OutlineSpacing | Margin between the annotation text and outline
Public property | OutlineStyle | Annotation outline rendering style
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | Property | Associated property value to display
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | Text | Annotation text string
Public property | Thickness | Font boldness of the annotation text
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IVisualObject.)
Public property | TransformationInWorld | Gets or sets the world transformation matrix (Inherited from IVisualObject.)
Public property | VisualObjectPosition | Position of the attachment point visual object
Top
See Also

Reference

IAnnotation Interface
VisualComponents.Create3D Namespace


IAnnotation.Background Property

IAnnotationBackground Property

Specifies if background is displayed for the annotation

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool Background { get; set; }
property bool Background {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IAnnotation Interface
VisualComponents.Create3D Namespace


IAnnotation.BackgroundMaterial Property

IAnnotationBackgroundMaterial Property

Annotation background rendering material

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMaterial BackgroundMaterial { get; set; }
property IMaterial^ BackgroundMaterial {
    IMaterial^ get ();
    void set (IMaterial^ value);
}

Property Value

Type: IMaterial
See Also

Reference

IAnnotation Interface
VisualComponents.Create3D Namespace


IAnnotation.Drawing Property

IAnnotationDrawing Property

Drawing item where the annotation is attached, if any

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IDrawingView Drawing { get; set; }
property IDrawingView^ Drawing {
    IDrawingView^ get ();
    void set (IDrawingView^ value);
}

Property Value

Type: IDrawingView
Remarks

If the annotation is attached to a simulation node, or has a custom visual object position matrix, this is null.

Setting this property sets the Node property to null.

See Also

Reference

IAnnotation Interface
VisualComponents.Create3D Namespace


IAnnotation.Geometry Property

IAnnotationGeometry Property

Annotation geometry, as rendered

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IGeometrySet> Geometry { get; }
property ReadOnlyCollection<IGeometrySet^>^ Geometry {
    ReadOnlyCollection<IGeometrySet^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIGeometrySet
See Also

Reference

IAnnotation Interface
VisualComponents.Create3D Namespace


IAnnotation.Height Property

IAnnotationHeight Property

Font height of the annotation text

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Height { get; set; }
property double Height {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IAnnotation Interface
VisualComponents.Create3D Namespace


IAnnotation.IndicationSize Property

IAnnotationIndicationSize Property

Indication rendering size

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double IndicationSize { get; set; }
property double IndicationSize {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IAnnotation Interface
VisualComponents.Create3D Namespace


IAnnotation.IndicationStyle Property

IAnnotationIndicationStyle Property

Annotation attachment indication rendering style

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IndicationStyle IndicationStyle { get; set; }
property IndicationStyle IndicationStyle {
    IndicationStyle get ();
    void set (IndicationStyle value);
}

Property Value

Type: IndicationStyle
See Also

Reference

IAnnotation Interface
VisualComponents.Create3D Namespace


IAnnotation.IsFloating Property

IAnnotationIsFloating Property

Specifies if the annotation is floating. Floating annotations are facing the camera.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsFloating { get; set; }
property bool IsFloating {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IAnnotation Interface
VisualComponents.Create3D Namespace


IAnnotation.IsTextSetForMultipleLines Property

IAnnotationIsTextSetForMultipleLines Property

Annotation text supports multiple lines

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsTextSetForMultipleLines { get; set; }
property bool IsTextSetForMultipleLines {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IAnnotation Interface
VisualComponents.Create3D Namespace


IAnnotation.LockToNode Property

IAnnotationLockToNode Property

Whether the annotation will follow the node, or stay fixed

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool LockToNode { get; set; }
property bool LockToNode {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks

If LockToNode is set, the annotation text will follow the attachment point as the attached node or drawing item is moved, otherwise it will stay in place.

The indication point or line will always follow the attachment point.

See Also

Reference

IAnnotation Interface
VisualComponents.Create3D Namespace


IAnnotation.Material Property

IAnnotationMaterial Property

Annotation text rendering material

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMaterial Material { get; set; }
property IMaterial^ Material {
    IMaterial^ get ();
    void set (IMaterial^ value);
}

Property Value

Type: IMaterial
See Also

Reference

IAnnotation Interface
VisualComponents.Create3D Namespace


IAnnotation.Node Property

IAnnotationNode Property

Simulation node where the annotation is attached, if any

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode Node { get; set; }
property ISimNode^ Node {
    ISimNode^ get ();
    void set (ISimNode^ value);
}

Property Value

Type: ISimNode
Remarks

If the annotation is attached to a drawing item, or has a custom visual object position matrix, this is null.

Setting this property sets the Drawing property to null.

See Also

Reference

IAnnotation Interface
VisualComponents.Create3D Namespace


IAnnotation.NodePosition Property

IAnnotationNodePosition Property

Attachment point position, relative to current visual object

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix NodePosition { get; set; }
property Matrix NodePosition {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

IAnnotation Interface
VisualComponents.Create3D Namespace


IAnnotation.NodePositionInWorld Property

IAnnotationNodePositionInWorld Property

Attachment point position in world coordinates

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix NodePositionInWorld { get; set; }
property Matrix NodePositionInWorld {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

IAnnotation Interface
VisualComponents.Create3D Namespace


IAnnotation.OutlineMaterial Property

IAnnotationOutlineMaterial Property

Annotation outline rendering material

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMaterial OutlineMaterial { get; set; }
property IMaterial^ OutlineMaterial {
    IMaterial^ get ();
    void set (IMaterial^ value);
}

Property Value

Type: IMaterial
See Also

Reference

IAnnotation Interface
VisualComponents.Create3D Namespace


IAnnotation.OutlineSpacing Property

IAnnotationOutlineSpacing Property

Margin between the annotation text and outline

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double OutlineSpacing { get; set; }
property double OutlineSpacing {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IAnnotation Interface
VisualComponents.Create3D Namespace


IAnnotation.OutlineStyle Property

IAnnotationOutlineStyle Property

Annotation outline rendering style

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
OutlineStyle OutlineStyle { get; set; }
property OutlineStyle OutlineStyle {
    OutlineStyle get ();
    void set (OutlineStyle value);
}

Property Value

Type: OutlineStyle
See Also

Reference

IAnnotation Interface
VisualComponents.Create3D Namespace


IAnnotation.Property Property

IAnnotationProperty Property

Associated property value to display

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProperty<string> Property { get; set; }
property IProperty<String^>^ Property {
    IProperty<String^>^ get ();
    void set (IProperty<String^>^ value);
}

Property Value

Type: IProperty String
See Also

Reference

IAnnotation Interface
VisualComponents.Create3D Namespace


IAnnotation.Text Property

IAnnotationText Property

Annotation text string

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Text { get; set; }
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IAnnotation Interface
VisualComponents.Create3D Namespace


IAnnotation.Thickness Property

IAnnotationThickness Property

Font boldness of the annotation text

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Thickness { get; set; }
property double Thickness {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IAnnotation Interface
VisualComponents.Create3D Namespace


IAnnotation.VisualObjectPosition Property

IAnnotationVisualObjectPosition Property

Position of the attachment point visual object

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix VisualObjectPosition { get; set; }
property Matrix VisualObjectPosition {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
Remarks

This is the position of the node or drawing item to which the annotation is attached. It is the reference point for NodePosition.

Setting VisualObjectPosition directly will cause the annotation to be detached from its previous node or drawing item, if any. This can be used to make the annotation follow a custom position.

See Also

Reference

IAnnotation Interface
VisualComponents.Create3D Namespace


IAnnotation Methods

The IAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IAnnotation Interface
VisualComponents.Create3D Namespace


IAnnotation Events

The IAnnotation type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

IAnnotation Interface
VisualComponents.Create3D Namespace


IApiType Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IApiType
public interface class IApiType

The IApiType type exposes the following members.

Properties
 | Name | Description
Public property | ApiType |
Top
See Also

Reference

VisualComponents.Create3D Namespace


IApiType Properties

The IApiType type exposes the following members.

Properties
 | Name | Description
Public property | ApiType |
Top
See Also

Reference

IApiType Interface
VisualComponents.Create3D Namespace


IApiType.ApiType Property

IApiTypeApiType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Type ApiType { get; }
property Type^ ApiType {
    Type^ get ();
}

Property Value

Type: Type
See Also

Reference

IApiType Interface
VisualComponents.Create3D Namespace


IAppConfigBlockedRibbonItemsSection Interface

Receives visibility status of Ribbon item.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IAppConfigBlockedRibbonItemsSection
public interface class IAppConfigBlockedRibbonItemsSection

The IAppConfigBlockedRibbonItemsSection type exposes the following members.

Methods
 | Name | Description
Public method | CanNonRibbonControlItemBeAddedToGui | Returns NonRibbon control item status of visibility
Public method | CanPaneItemBeAddedToGui | Returns panes item status of visibility
Public method | CanQuickMenuItemBeAddedToGui | Returns QuickMenu item status of visibility
Public method | CanRibbonBackstageItemBeAddedToGui | Returns RibbonBackstage item status of visibility
Public method | CanRibbonGroupItemBeAddedToGui | Returns RibbonGroup item status of visibility
Public method | CanRibbonTabItemBeAddedToGui | Returns RibbonTab item status of visibility
Public method | CanRibbonToolItemBeAddedToGui | Returns RibbonTool item status of visibility
Public method | IsItemVisibleInToolsInRibbon | Returns Ribbon item status of visibility
Top
See Also

Reference

VisualComponents.Create3D Namespace


IAppConfigBlockedRibbonItemsSection Methods

The IAppConfigBlockedRibbonItemsSection type exposes the following members.

Methods
 | Name | Description
Public method | CanNonRibbonControlItemBeAddedToGui | Returns NonRibbon control item status of visibility
Public method | CanPaneItemBeAddedToGui | Returns panes item status of visibility
Public method | CanQuickMenuItemBeAddedToGui | Returns QuickMenu item status of visibility
Public method | CanRibbonBackstageItemBeAddedToGui | Returns RibbonBackstage item status of visibility
Public method | CanRibbonGroupItemBeAddedToGui | Returns RibbonGroup item status of visibility
Public method | CanRibbonTabItemBeAddedToGui | Returns RibbonTab item status of visibility
Public method | CanRibbonToolItemBeAddedToGui | Returns RibbonTool item status of visibility
Public method | IsItemVisibleInToolsInRibbon | Returns Ribbon item status of visibility
Top
See Also

Reference

IAppConfigBlockedRibbonItemsSection Interface
VisualComponents.Create3D Namespace


IAppConfigBlockedRibbonItemsSection.CanNonRibbonControlItemBeAddedToGui Method

IAppConfigBlockedRibbonItemsSectionCanNonRibbonControlItemBeAddedToGui Method

Returns NonRibbon control item status of visibility

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanNonRibbonControlItemBeAddedToGui(
    string itemId
)
bool CanNonRibbonControlItemBeAddedToGui(
    String^ itemId
)

Parameters

itemId
Type: SystemString
control item name

Return Value

Type: Boolean
true if the item can be shown
See Also

Reference

IAppConfigBlockedRibbonItemsSection Interface
VisualComponents.Create3D Namespace


IAppConfigBlockedRibbonItemsSection.CanPaneItemBeAddedToGui Method

IAppConfigBlockedRibbonItemsSectionCanPaneItemBeAddedToGui Method

Returns panes item status of visibility

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanPaneItemBeAddedToGui(
    string itemId
)
bool CanPaneItemBeAddedToGui(
    String^ itemId
)

Parameters

itemId
Type: SystemString
Pane item name

Return Value

Type: Boolean
true if the item can be shown
See Also

Reference

IAppConfigBlockedRibbonItemsSection Interface
VisualComponents.Create3D Namespace


IAppConfigBlockedRibbonItemsSection.CanQuickMenuItemBeAddedToGui Method

IAppConfigBlockedRibbonItemsSectionCanQuickMenuItemBeAddedToGui Method

Returns QuickMenu item status of visibility

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanQuickMenuItemBeAddedToGui(
    string itemId
)
bool CanQuickMenuItemBeAddedToGui(
    String^ itemId
)

Parameters

itemId
Type: SystemString
ribbon item name

Return Value

Type: Boolean
true if the item can be shown
See Also

Reference

IAppConfigBlockedRibbonItemsSection Interface
VisualComponents.Create3D Namespace


IAppConfigBlockedRibbonItemsSection.CanRibbonBackstageItemBeAddedToGui Method

IAppConfigBlockedRibbonItemsSectionCanRibbonBackstageItemBeAddedToGui Method

Returns RibbonBackstage item status of visibility

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanRibbonBackstageItemBeAddedToGui(
    string itemId
)
bool CanRibbonBackstageItemBeAddedToGui(
    String^ itemId
)

Parameters

itemId
Type: SystemString
ribbon item name

Return Value

Type: Boolean
true if the item can be shown
See Also

Reference

IAppConfigBlockedRibbonItemsSection Interface
VisualComponents.Create3D Namespace


IAppConfigBlockedRibbonItemsSection.CanRibbonGroupItemBeAddedToGui Method

IAppConfigBlockedRibbonItemsSectionCanRibbonGroupItemBeAddedToGui Method

Returns RibbonGroup item status of visibility

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanRibbonGroupItemBeAddedToGui(
    string itemId
)
bool CanRibbonGroupItemBeAddedToGui(
    String^ itemId
)

Parameters

itemId
Type: SystemString
ribbon item name

Return Value

Type: Boolean
true if the item can be shown
See Also

Reference

IAppConfigBlockedRibbonItemsSection Interface
VisualComponents.Create3D Namespace


IAppConfigBlockedRibbonItemsSection.CanRibbonTabItemBeAddedToGui Method

IAppConfigBlockedRibbonItemsSectionCanRibbonTabItemBeAddedToGui Method

Returns RibbonTab item status of visibility

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanRibbonTabItemBeAddedToGui(
    string itemId
)
bool CanRibbonTabItemBeAddedToGui(
    String^ itemId
)

Parameters

itemId
Type: SystemString
ribbon item name

Return Value

Type: Boolean
true if the item can be shown
See Also

Reference

IAppConfigBlockedRibbonItemsSection Interface
VisualComponents.Create3D Namespace


IAppConfigBlockedRibbonItemsSection.CanRibbonToolItemBeAddedToGui Method

IAppConfigBlockedRibbonItemsSectionCanRibbonToolItemBeAddedToGui Method

Returns RibbonTool item status of visibility

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanRibbonToolItemBeAddedToGui(
    string itemId
)
bool CanRibbonToolItemBeAddedToGui(
    String^ itemId
)

Parameters

itemId
Type: SystemString
ribbon item name

Return Value

Type: Boolean
true if the item can be shown
See Also

Reference

IAppConfigBlockedRibbonItemsSection Interface
VisualComponents.Create3D Namespace


IAppConfigBlockedRibbonItemsSection.IsItemVisibleInToolsInRibbon Method

IAppConfigBlockedRibbonItemsSectionIsItemVisibleInToolsInRibbon Method

Returns Ribbon item status of visibility

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsItemVisibleInToolsInRibbon(
    string itemId
)
bool IsItemVisibleInToolsInRibbon(
    String^ itemId
)

Parameters

itemId
Type: SystemString
ribbon item name

Return Value

Type: Boolean
true if the item can be shown
See Also

Reference

IAppConfigBlockedRibbonItemsSection Interface
VisualComponents.Create3D Namespace


IAppConfigSettings Interface

Receive values from the app config section (appSettings) of the app config file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IAppConfigSettings
public interface class IAppConfigSettings

The IAppConfigSettings type exposes the following members.

Methods
 | Name | Description
Public method | GetAppValueT(String) | Gets value from the appSettings section (the application config file)
Public method | GetAppValueT(String, T) | Gets value from the appSettings section (the application config file).
Public method | GetValueT(String) | Gets value from the appSettings section (the application config file)
Public method | GetValueT(String, T) | Gets value from the appSettings section (the application config file)
Public method | SetAppValueT | Set value to the appSettings section (the application config file)
Public method | SetValueT | Set value to the appSettings section (the application config file)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IAppConfigSettings Methods

The IAppConfigSettings type exposes the following members.

Methods
 | Name | Description
Public method | GetAppValueT(String) | Gets value from the appSettings section (the application config file)
Public method | GetAppValueT(String, T) | Gets value from the appSettings section (the application config file).
Public method | GetValueT(String) | Gets value from the appSettings section (the application config file)
Public method | GetValueT(String, T) | Gets value from the appSettings section (the application config file)
Public method | SetAppValueT | Set value to the appSettings section (the application config file)
Public method | SetValueT | Set value to the appSettings section (the application config file)
Top
See Also

Reference

IAppConfigSettings Interface
VisualComponents.Create3D Namespace


IAppConfigSettings.GetAppValue Method

IAppConfigSettingsGetAppValue Method

Overload List
 | Name | Description
Public method | GetAppValueT(String) | Gets value from the appSettings section (the application config file)
Public method | GetAppValueT(String, T) | Gets value from the appSettings section (the application config file).
Top
See Also

Reference

IAppConfigSettings Interface
VisualComponents.Create3D Namespace


IAppConfigSettings.GetAppValue(T) Method (String)

IAppConfigSettingsGetAppValueT Method (String)

Gets value from the appSettings section (the application config file)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
T GetAppValue<T>(
    string key
)

generic<typename T>
T GetAppValue(
    String^ key
)

Parameters

key
Type: SystemString
application setting key

Type Parameters

T
type of value

Return Value

Type: T
config value
See Also

Reference

IAppConfigSettings Interface
GetAppValue Overload
VisualComponents.Create3D Namespace


IAppConfigSettings.GetAppValue(T) Method (String, T)

IAppConfigSettingsGetAppValueT Method (String, T)

Gets value from the appSettings section (the application config file).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
T GetAppValue<T>(
    string key,
    T defaultValue
)

generic<typename T>
T GetAppValue(
    String^ key,
    T defaultValue
)

Parameters

key
Type: SystemString
application setting key
defaultValue
Type: T
default value if the key was not found

Type Parameters

T
type of value

Return Value

Type: T
config value
See Also

Reference

IAppConfigSettings Interface
GetAppValue Overload
VisualComponents.Create3D Namespace


IAppConfigSettings.GetValue Method

IAppConfigSettingsGetValue Method

Overload List
 | Name | Description
Public method | GetValueT(String) | Gets value from the appSettings section (the application config file)
Public method | GetValueT(String, T) | Gets value from the appSettings section (the application config file)
Top
See Also

Reference

IAppConfigSettings Interface
VisualComponents.Create3D Namespace


IAppConfigSettings.GetValue(T) Method (String)

IAppConfigSettingsGetValueT Method (String)

Gets value from the appSettings section (the application config file)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
T GetValue<T>(
    string key
)

generic<typename T>
T GetValue(
    String^ key
)

Parameters

key
Type: SystemString
application setting key

Type Parameters

T
type of value

Return Value

Type: T
config value
See Also

Reference

IAppConfigSettings Interface
GetValue Overload
VisualComponents.Create3D Namespace


IAppConfigSettings.GetValue(T) Method (String, T)

IAppConfigSettingsGetValueT Method (String, T)

Gets value from the appSettings section (the application config file)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
T GetValue<T>(
    string key,
    T defaultValue
)

generic<typename T>
T GetValue(
    String^ key,
    T defaultValue
)

Parameters

key
Type: SystemString
application setting key
defaultValue
Type: T
default value if the key was not found

Type Parameters

T
type of value

Return Value

Type: T
config value
See Also

Reference

IAppConfigSettings Interface
GetValue Overload
VisualComponents.Create3D Namespace


IAppConfigSettings.SetAppValue(T) Method

IAppConfigSettingsSetAppValueT Method

Set value to the appSettings section (the application config file)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetAppValue<T>(
    string key,
    T value
)

generic<typename T>
void SetAppValue(
    String^ key,
    T value
)

Parameters

key
Type: SystemString
applcation setting key
value
Type: T
key value

Type Parameters

T
value type
See Also

Reference

IAppConfigSettings Interface
VisualComponents.Create3D Namespace


IAppConfigSettings.SetValue(T) Method

IAppConfigSettingsSetValueT Method

Set value to the appSettings section (the application config file)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetValue<T>(
    string key,
    T value
)

generic<typename T>
void SetValue(
    String^ key,
    T value
)

Parameters

key
Type: SystemString
applcation setting key
value
Type: T
key value

Type Parameters

T
value type
See Also

Reference

IAppConfigSettings Interface
VisualComponents.Create3D Namespace


IAppendToListStatement Interface

Joins source variable to the target variable.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IAppendToListStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IAppendToListStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IAppendToListStatement type exposes the following members.

Properties
 | Name | Description
Public property | AllowDuplicates | Defines whether already existing values should be added to the target.
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | SourceVariableName | Gets or sets the name of the variable from which values are copied.
Public property | TargetVariableName | Gets or sets the name of the variable where values are appended. A new list variable is created if necessary.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
Both source and target variables can be lists, but don't have to be.
See Also

Reference

VisualComponents.Create3D Namespace


IAppendToListStatement Properties

The IAppendToListStatement type exposes the following members.

Properties
 | Name | Description
Public property | AllowDuplicates | Defines whether already existing values should be added to the target.
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | SourceVariableName | Gets or sets the name of the variable from which values are copied.
Public property | TargetVariableName | Gets or sets the name of the variable where values are appended. A new list variable is created if necessary.
Top
See Also

Reference

IAppendToListStatement Interface
VisualComponents.Create3D Namespace


IAppendToListStatement.AllowDuplicates Property

IAppendToListStatementAllowDuplicates Property

Defines whether already existing values should be added to the target.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool AllowDuplicates { get; set; }
property bool AllowDuplicates {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IAppendToListStatement Interface
VisualComponents.Create3D Namespace


IAppendToListStatement.SourceVariableName Property

IAppendToListStatementSourceVariableName Property

Gets or sets the name of the variable from which values are copied.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string SourceVariableName { get; set; }
property String^ SourceVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown by setter when supplied value is null.
See Also

Reference

IAppendToListStatement Interface
VisualComponents.Create3D Namespace


IAppendToListStatement.TargetVariableName Property

IAppendToListStatementTargetVariableName Property

Gets or sets the name of the variable where values are appended. A new list variable is created if necessary.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string TargetVariableName { get; set; }
property String^ TargetVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown by setter when supplied value is null.
See Also

Reference

IAppendToListStatement Interface
VisualComponents.Create3D Namespace


IAppendToListStatement Methods

The IAppendToListStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IAppendToListStatement Interface
VisualComponents.Create3D Namespace


IAppendToListStatement Events

The IAppendToListStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IAppendToListStatement Interface
VisualComponents.Create3D Namespace


IApplication Interface

Provides access to the application instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IApplication
public interface class IApplication

The IApplication type exposes the following members.

Properties
 | Name | Description
Public property | ActiveWindow | Retrieves or sets the active IWindow3D instance.
Public property | AuxWorlds | Gets all the auxiliary instance of ISimWorld.
Public property | BackupExpiration | Backups older than this are deleted. Expressed in days.
Public property | BackupFileLimit | How many backup files are stored per layout/component.
Public property | BaseFramesLocked | Gets or sets a Boolean value that indicates that frames should maintain their world location.
Public property | CustomBackupFolder | Custom location for layout/component backup files.
Public property | DrawingContext | Gets or sets a Boolean value that indicates drawing context. It is used to switch between 3D and 2D drawing view
Public property | DrawingWorld | Gets the 2D drawing world ISimWorld.
Public property | FileExtension | File extension for reading and saving files
Public property | FileExtensionOld | Old file extension for reading files
Public property | Floor | Obsolete. Gets the IFloor of the main 3D world, includes both floor and grid.
Public property | Initialized | Gets a boolean value that indicates if the application has been properly initialized and ActiveWindow is created
Public property | IsClosingLayout | Indicates that all active tasks should abort (when executed with dispatcher).
Public property | IsCollisionDetectionActivated | Gets or sets a Boolean value that indicates if CollisionDetectors LayoutItems are consider during simulation
Public property | IsInHeadlessMode | If true, the application is running as a server without a local UI.
Public property | IsInOperationDebug | Special operation debug mode, enabled with Ctrl+Shift+Alt+O.
Public property | IsInSafeMode | Special safe mode, enabled with command line argument /safemode or /safemodall.
Public property | IsOriginalComponentPathSaved | Gets a Boolean value that indicates if layout saving includes the original component path.
Public property | IsPackAndGo | Gets a Boolean value that indicates if current layout included compressed components.
Public property | IsReady | Gets a Boolean value that indicates if the application is ready. True if ready.
Public property | LayoutModified | Defines if the world has been modified after last saving
Public property | LayoutUri | Gets the uri of the current layout
Public property | LicenseConfiguration | Product license configuration.
Public property | MainWindow | Gets the instance of IWindow3D that is the main window for the application.
Public property | MainWindowReady | Gets a boolean value that indicates if the main window has been shown at first time
Public property | Materials | Gets a list of IMaterial available in the application.
Public property | MultisamplingMode | Gets or sets a Boolean value that indicates the use of effect shaders in the visual space
Public property | ProgressContext | Gets the progress context.
Public property | RendererReady | Gets a boolean value that indicates if the renderer is fully initialized.
Public property | SelectionManager | Gets the ISelectionManager instance
Public property | Simulation | Gets the ISimulation.
Public property | StatisticsManager | Gets the IStatisticsManager
Public property | UnicodeWarnings | When enabled will print warning messages to the Output window when using country-specific encoded strings.
Public property | UseBackupExpiration | Are old backups deleted.
Public property | UseBackupFileLimit | Is the number of backup files limited.
Public property | UseCustomBackupFolder | Is the custom backup folder used.
Public property | UseEffectShaders | Gets or sets a Boolean value that indicates the use of effect shaders in the visual space
Public property | UseMaterialShaders | Obsolete. Gets or sets a Boolean value that indicates the use of material shaders in the main instance of IWindow3D.
Public property | ValidLicenseExists | Gets a Boolean value that indicates if a valid license is available.
Public property | Windows | Gets the collection of existing IWindow3D instances.
Public property | World | Gets the 3D simulation world ISimWorld.
Top
Methods
 | Name | Description
Public method | AutoShareFeatureTrees | Combine identical feature trees. This operation is performed on the whole layout at once.
Public method | CheckConfigurations(Object) | Obsolete. Check that attached bases and tools are not attached to nodes between RootNode and FlangeNode. Prints an error message and shows a popup message box if attachment is invalid.
Public method | CheckConfigurations(IEnumerableISimComponent, IRobotFrame, IRobotFrame, Boolean, Boolean) | Checks that attached bases and tools are not attached to nodes between RootNode and FlangeNode. Prints an error message and/or shows a popup message box if the attachment is invalid.
Public method | CheckFileExtension | check and add a file extension if it is missed
Public method | CheckRebuild | Check if some behaviours require evaluation, after visual objects where moved.
Public method | CheckRebuildOnRender | Check if we need to recalculate robot position statuses.
Public method | ClearDispatcherQueueWhenClosingLayout | Additional helper used to enable IsClosingLayout-flag and flush dispatcher queue.
Public method | ClearMessages | Clears internal messages.
Public method | CloseLayout | Closes current layout and clear the virtual space.
Public method | Create3DWindow(String) | Creates a new IWindow3D instance.
Public method | Create3DWindow(ISimWorld) | Creates a new IWindow3D instance, displaying the given world.
Public method | Create3DWindow(String, Boolean) | Creates a new IWindow3D instance, displaying the default 3d/drawing world.
Public method | CreateAuxWorld | Creates a new auxiliary (non system) instance of ISimWorld.
Public method | CreateCollisionDetector | Creates a nonpersistent instance of ICollisionDetector
Public method | CreateComponent | Creates a new component
Public method | CreateMaterial(String) | Creates a new IMaterial instance.
Public method | CreateMaterial(String, Boolean) | Creates a new IMaterial instance. Specifies if it is system material which by default is false
Public method | CustomProjection | Deprecated: Sets temporary window size. Similar to SurfaceSetSize().
Public method | Delete3DWindow | Deletes the existing IWindow3D instance.
Public method | DeleteAuxWorld | Deletes the given axiliary instance of ISimWorld. Note that the system instances cannot be deleted.
Public method | DeleteMaterial | Deletes an existing IMaterial instance
Public method | DestroyGlobalData |
Public method | ExecuteCommand | execute command
Public method | ExecuteCommand2 | execute command
Public method | ExecuteCommandMethod | Invoke a function in a specific python command or behavior.
Public method | ExecutePythonCommandMethod | Invoke a function in a specific python command or behavior.
Public method | ExecutePythonFile |
Public method | ExportLayout(Uri) | Export current layout to the given Uri
Public method | ExportLayout(Uri, Boolean) | Export current layout ignorning the non selected components to the given Uri
Public method | FindMaterial | Returns IMaterial based on a specified material name. Returns Null if material name is not found.
Public method | FindPythonCommand | Alternative to using ExecuteCommand and ExecuteCommand2.
Public method | FlushAutoShare | This is needed only when using FeatureTreeAutoSharing-option, which is typically disabled. Tries to reuse already existing feature tree and geometries. Returns the count of components optimized.
Public method | GetCommandIsEnabled | Get enabled state of a python command.
Public method | GetGhostMaterial | Retrieves the temporary ghost material for a particular node/component.
Public method | GetPythonScriptLocation | Get path of a python script based on command id.
Public method | GetSessionValueT | Allows user to retrieve a bool value previously defined by name
Public method | GetSurface | Returns the surface of the current renderer without adding a reference
Public method | InitSafeMode | Will enable assert dialog and log all errors to log file (can be used in release build).
Public method | IsFileFormatNew | verify a file format
Public method | IsFileFormatOld | verify a old file format
Public method | LoadLayout(Uri) | Loads a model into the current world from the given Uri
Public method | LoadLayout(Uri, Vector3) | Loads the layout into the current world from the given Uri to the given position.
Public method | LoadLayout(Uri, Vector3, Boolean) | Loads the layout into the current world from the given Uri to the given position.
Public method | LoadLayout(Uri, Vector3, Boolean, ISimWorld) | Loads the layout into the target world from the given Uri to the given position.
Public method | LoadPythonCommand | Alternative to using getApplication().loadCommand() in python.
Public method | MaterialPreview | Renders into 3d word a mesh with a given material. Mesh is not attached to any component.
Public method | NotifyVREventsEvent | VR Events are sent by the Experience viewer if IVREventsServer.EventsEnabled is true.
Public method | RecompileCommand | Recompile python script.
Public method | SaveComponent | Save the given component to a file
Public method | SaveLayout | Save current layout to the given Uri
Public method | SetAntialiasingMode | Sets the anti-aliasing Rendering mode
Public method | SetAntialiasingQuality | set the anti-aliasing Rendering quality
Public method | SetCommandIsEnabled | Set enabled state of a python command.
Public method | SetForceExDevice |
Public method | SetForceUnlocked |
Public method | SetLayoutModified | Notifies the application that the world has been modified
Public method | SetRecordingMode | Disable every other rendering method except SurfaceToContinuousBuffer().
Public method | SetSessionValueT | Allows user to store a bool value defined by name
Public method | SetShaderMode | Turns the shader On/Off
Public method | SetTransparentQuality | Obsolete. Sets transparent Material Rendering quality
Public method | SetUseAlpha |
Public method | SurfaceDestroy |
Public method | SurfacePrepareRender | Prepares the IWindow3D to be rendered asyncronously
Public method | SurfaceRender | Renders the IWindow3D
Public method | SurfaceSetEffect | Selects the shader effect
Public method | SurfaceSetSize(IWindow3D, UInt32, UInt32) | Update the size of the surface of the given window. Next render will create a new surface.
Public method | SurfaceSetSize(IWindow3D, UInt32, UInt32, Boolean) | Update the size of the surface of the given window. Next render will create a new surface.
Public method | SurfaceStartRender | Starts IWindow3D rendering asyncronously
Public method | SurfaceTileToBuffer | Render a portion of the 3D scene delimited by min and max vectors into a buffer
Public method | SurfaceToBuffer(ImageFormat) | Renders the 3D scene into a buffer of bytes using current width and height image resolution
Public method | SurfaceToBuffer(ImageFormat, UInt32, UInt32) | Renders the 3D scene into a buffer of bytes using the given width and height image resolution
Public method | SurfaceToBuffer(ImageFormat, UInt32, UInt32, FuncBoolean) | Renders the 3D scene into a buffer of bytes using the given width and height image resolution
Public method | SurfaceToContinuousBuffer | Renders the 3D scene into a temporary buffer, that stays in memory until SetRecordingMode(false) is called. This can be used only together with SetRecordingMode(true). Buffer format is a raw BGRA bitmap without any header information.
Public method | SurfaceToImage(ImageFormat, String) | Renders the 3D scene into an image saved into the given location
Public method | SurfaceToImage(ImageFormat, String, UInt32, UInt32) | Renders the 3D scene into an image saved into the given location with the given width and height resolution
Public method | SurfaceToImage(ImageFormat, String, UInt32, UInt32, FuncBoolean) | Renders the 3D scene into an image saved into the given location with the given width and height resolution
Public method | SurfaceWaitRender | Waits IWindow3D asyncronous rendering to be finished
Public method | TestAllCollisionDetectors | Execute collision test.
Public method | TestRenderDevice | Returns the state of 3D Device.
Public method | TestRenderInternalException | Returns true if rendering id disabled due to internal exception.
Public method | UnloadAppFeature | Shuts down the application.
Public method | UpdateDimensionsDisplayAccuracy | Update accuracy of dimensions for model.
Public method | WriteLine | Obsolete. Writes a message to the output console
Top
Events
 | Name | Description
Public event | ActiveWindowChanged | Occurs when ActiveWindow property changes.
Public event | CollisionDetectionActivated | Occurs when collision detection is enabled or disabled.
Public event | ComponentCreated |
Public event | ComponentSaved | Occurs when a Component has been saved.
Public event | ComponentSaving | Occurs when a component is being saved.
Public event | InitializedChanged | Raised after Initialized has changed and ActiveWindow is created.
Public event | IsInitializedChanged | Obsolete.
Public event | LayoutClosed | Occurs when a layout has been closed.
Public event | LayoutClosing | Occurs when a layout is being closed.
Public event | LayoutLoaded | Occurs when a layout has been loaded.
Public event | LayoutLoading | Occurs when a layout is loading.
Public event | LayoutModifiedChanged | Occurs when the value of LayoutModified changes.
Public event | LayoutSaved | Occurs when a layout has been saved.
Public event | LayoutSaving | Occurs when a layout is being saved.
Public event | MainWindowShown | Raised after MainWindowReady has changed and MainWindow is shown at first time.
Public event | PythonCommandIsCheckedChanged | Occurs when python command checked state changes.
Public event | PythonCommandIsEnabledChanged | Occurs when python command enabled state changes.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IApplication Properties

The IApplication type exposes the following members.

Properties
 | Name | Description
Public property | ActiveWindow | Retrieves or sets the active IWindow3D instance.
Public property | AuxWorlds | Gets all the auxiliary instance of ISimWorld.
Public property | BackupExpiration | Backups older than this are deleted. Expressed in days.
Public property | BackupFileLimit | How many backup files are stored per layout/component.
Public property | BaseFramesLocked | Gets or sets a Boolean value that indicates that frames should maintain their world location.
Public property | CustomBackupFolder | Custom location for layout/component backup files.
Public property | DrawingContext | Gets or sets a Boolean value that indicates drawing context. It is used to switch between 3D and 2D drawing view
Public property | DrawingWorld | Gets the 2D drawing world ISimWorld.
Public property | FileExtension | File extension for reading and saving files
Public property | FileExtensionOld | Old file extension for reading files
Public property | Floor | Obsolete. Gets the IFloor of the main 3D world, includes both floor and grid.
Public property | Initialized | Gets a boolean value that indicates if the application has been properly initialized and ActiveWindow is created
Public property | IsClosingLayout | Indicates that all active tasks should abort (when executed with dispatcher).
Public property | IsCollisionDetectionActivated | Gets or sets a Boolean value that indicates if CollisionDetectors LayoutItems are consider during simulation
Public property | IsInHeadlessMode | If true, the application is running as a server without a local UI.
Public property | IsInOperationDebug | Special operation debug mode, enabled with Ctrl+Shift+Alt+O.
Public property | IsInSafeMode | Special safe mode, enabled with command line argument /safemode or /safemodall.
Public property | IsOriginalComponentPathSaved | Gets a Boolean value that indicates if layout saving includes the original component path.
Public property | IsPackAndGo | Gets a Boolean value that indicates if current layout included compressed components.
Public property | IsReady | Gets a Boolean value that indicates if the application is ready. True if ready.
Public property | LayoutModified | Defines if the world has been modified after last saving
Public property | LayoutUri | Gets the uri of the current layout
Public property | LicenseConfiguration | Product license configuration.
Public property | MainWindow | Gets the instance of IWindow3D that is the main window for the application.
Public property | MainWindowReady | Gets a boolean value that indicates if the main window has been shown at first time
Public property | Materials | Gets a list of IMaterial available in the application.
Public property | MultisamplingMode | Gets or sets a Boolean value that indicates the use of effect shaders in the visual space
Public property | ProgressContext | Gets the progress context.
Public property | RendererReady | Gets a boolean value that indicates if the renderer is fully initialized.
Public property | SelectionManager | Gets the ISelectionManager instance
Public property | Simulation | Gets the ISimulation.
Public property | StatisticsManager | Gets the IStatisticsManager
Public property | UnicodeWarnings | When enabled will print warning messages to the Output window when using country-specific encoded strings.
Public property | UseBackupExpiration | Are old backups deleted.
Public property | UseBackupFileLimit | Is the number of backup files limited.
Public property | UseCustomBackupFolder | Is the custom backup folder used.
Public property | UseEffectShaders | Gets or sets a Boolean value that indicates the use of effect shaders in the visual space
Public property | UseMaterialShaders | Obsolete. Gets or sets a Boolean value that indicates the use of material shaders in the main instance of IWindow3D.
Public property | ValidLicenseExists | Gets a Boolean value that indicates if a valid license is available.
Public property | Windows | Gets the collection of existing IWindow3D instances.
Public property | World | Gets the 3D simulation world ISimWorld.
Top
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.ActiveWindow Property

IApplicationActiveWindow Property

Retrieves or sets the active IWindow3D instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IWindow3D ActiveWindow { get; set; }
property IWindow3D^ ActiveWindow {
    IWindow3D^ get ();
    void set (IWindow3D^ value);
}

Property Value

Type: IWindow3D
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.AuxWorlds Property

IApplicationAuxWorlds Property

Gets all the auxiliary instance of ISimWorld.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ISimWorld> AuxWorlds { get; }
property ReadOnlyCollection<ISimWorld^>^ AuxWorlds {
    ReadOnlyCollection<ISimWorld^>^ get ();
}

Property Value

Type: ReadOnlyCollectionISimWorld
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.BackupExpiration Property

IApplicationBackupExpiration Property

Backups older than this are deleted. Expressed in days.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int BackupExpiration { get; set; }
property int BackupExpiration {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.BackupFileLimit Property

IApplicationBackupFileLimit Property

How many backup files are stored per layout/component.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int BackupFileLimit { get; set; }
property int BackupFileLimit {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.BaseFramesLocked Property

IApplicationBaseFramesLocked Property

Gets or sets a Boolean value that indicates that frames should maintain their world location.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool BaseFramesLocked { get; set; }
property bool BaseFramesLocked {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
This won't work during simulation.
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.CustomBackupFolder Property

IApplicationCustomBackupFolder Property

Custom location for layout/component backup files.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Uri CustomBackupFolder { get; set; }
property Uri^ CustomBackupFolder {
    Uri^ get ();
    void set (Uri^ value);
}

Property Value

Type: Uri
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.DrawingContext Property

IApplicationDrawingContext Property

Gets or sets a Boolean value that indicates drawing context. It is used to switch between 3D and 2D drawing view

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool DrawingContext { get; set; }
property bool DrawingContext {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.DrawingWorld Property

IApplicationDrawingWorld Property

Gets the 2D drawing world ISimWorld.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimWorld DrawingWorld { get; }
property ISimWorld^ DrawingWorld {
    ISimWorld^ get ();
}

Property Value

Type: ISimWorld
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.FileExtension Property

IApplicationFileExtension Property

File extension for reading and saving files

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string FileExtension { get; }
property String^ FileExtension {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.FileExtensionOld Property

IApplicationFileExtensionOld Property

Old file extension for reading files

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string FileExtensionOld { get; }
property String^ FileExtensionOld {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.Floor Property

IApplicationFloor Property

Note: This API is now obsolete.

Gets the IFloor of the main 3D world, includes both floor and grid.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Use ISimWorld.Floor instead.")]
IFloor Floor { get; }
[ObsoleteAttribute(L"Use ISimWorld.Floor instead.")]
property IFloor^ Floor {
    IFloor^ get ();
}

Property Value

Type: IFloor
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.Initialized Property

IApplicationInitialized Property

Gets a boolean value that indicates if the application has been properly initialized and ActiveWindow is created

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool Initialized { get; set; }
property bool Initialized {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.IsClosingLayout Property

IApplicationIsClosingLayout Property

Indicates that all active tasks should abort (when executed with dispatcher).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsClosingLayout { get; }
property bool IsClosingLayout {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.IsCollisionDetectionActivated Property

IApplicationIsCollisionDetectionActivated Property

Gets or sets a Boolean value that indicates if CollisionDetectors LayoutItems are consider during simulation

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsCollisionDetectionActivated { get; set; }
property bool IsCollisionDetectionActivated {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.IsInHeadlessMode Property

IApplicationIsInHeadlessMode Property

If true, the application is running as a server without a local UI.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsInHeadlessMode { get; }
property bool IsInHeadlessMode {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.IsInOperationDebug Property

IApplicationIsInOperationDebug Property

Special operation debug mode, enabled with Ctrl+Shift+Alt+O.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsInOperationDebug { get; }
property bool IsInOperationDebug {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.IsInSafeMode Property

IApplicationIsInSafeMode Property

Special safe mode, enabled with command line argument /safemode or /safemodall.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsInSafeMode { get; }
property bool IsInSafeMode {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.IsOriginalComponentPathSaved Property

IApplicationIsOriginalComponentPathSaved Property

Gets a Boolean value that indicates if layout saving includes the original component path.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsOriginalComponentPathSaved { get; set; }
property bool IsOriginalComponentPathSaved {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.IsPackAndGo Property

IApplicationIsPackAndGo Property

Gets a Boolean value that indicates if current layout included compressed components.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsPackAndGo { get; set; }
property bool IsPackAndGo {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.IsReady Property

IApplicationIsReady Property

Gets a Boolean value that indicates if the application is ready. True if ready.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsReady { get; set; }
property bool IsReady {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.LayoutModified Property

IApplicationLayoutModified Property

Defines if the world has been modified after last saving

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool LayoutModified { get; }
property bool LayoutModified {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.LayoutUri Property

IApplicationLayoutUri Property

Gets the uri of the current layout

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Uri LayoutUri { get; }
property Uri^ LayoutUri {
    Uri^ get ();
}

Property Value

Type: Uri
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.LicenseConfiguration Property

IApplicationLicenseConfiguration Property

Product license configuration.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProductConfiguration LicenseConfiguration { get; }
property IProductConfiguration^ LicenseConfiguration {
    IProductConfiguration^ get ();
}

Property Value

Type: IProductConfiguration
Remarks

Before the application is initialized, this property is null. When the application is initialized, this property is set to a copy of the object that was passed to Init().

See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.MainWindow Property

IApplicationMainWindow Property

Gets the instance of IWindow3D that is the main window for the application.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IWindow3D MainWindow { get; }
property IWindow3D^ MainWindow {
    IWindow3D^ get ();
}

Property Value

Type: IWindow3D
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.MainWindowReady Property

IApplicationMainWindowReady Property

Gets a boolean value that indicates if the main window has been shown at first time

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool MainWindowReady { get; set; }
property bool MainWindowReady {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.Materials Property

IApplicationMaterials Property

Gets a list of IMaterial available in the application.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IMaterial> Materials { get; }
property ReadOnlyCollection<IMaterial^>^ Materials {
    ReadOnlyCollection<IMaterial^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIMaterial
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.MultisamplingMode Property

IApplicationMultisamplingMode Property

Gets or sets a Boolean value that indicates the use of effect shaders in the visual space

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int MultisamplingMode { get; set; }
property int MultisamplingMode {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.ProgressContext Property

IApplicationProgressContext Property

Gets the progress context.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProgressContext ProgressContext { get; }
property IProgressContext^ ProgressContext {
    IProgressContext^ get ();
}

Property Value

Type: IProgressContext
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.RendererReady Property

IApplicationRendererReady Property

Gets a boolean value that indicates if the renderer is fully initialized.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool RendererReady { get; }
property bool RendererReady {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.SelectionManager Property

IApplicationSelectionManager Property

Gets the ISelectionManager instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISelectionManager SelectionManager { get; }
property ISelectionManager^ SelectionManager {
    ISelectionManager^ get ();
}

Property Value

Type: ISelectionManager
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.Simulation Property

IApplicationSimulation Property

Gets the ISimulation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimulation Simulation { get; }
property ISimulation^ Simulation {
    ISimulation^ get ();
}

Property Value

Type: ISimulation
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.StatisticsManager Property

IApplicationStatisticsManager Property

Gets the IStatisticsManager

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatisticsManager StatisticsManager { get; }
property IStatisticsManager^ StatisticsManager {
    IStatisticsManager^ get ();
}

Property Value

Type: IStatisticsManager
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.UnicodeWarnings Property

IApplicationUnicodeWarnings Property

When enabled will print warning messages to the Output window when using country-specific encoded strings.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool UnicodeWarnings { get; set; }
property bool UnicodeWarnings {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.UseBackupExpiration Property

IApplicationUseBackupExpiration Property

Are old backups deleted.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool UseBackupExpiration { get; set; }
property bool UseBackupExpiration {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.UseBackupFileLimit Property

IApplicationUseBackupFileLimit Property

Is the number of backup files limited.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool UseBackupFileLimit { get; set; }
property bool UseBackupFileLimit {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.UseCustomBackupFolder Property

IApplicationUseCustomBackupFolder Property

Is the custom backup folder used.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool UseCustomBackupFolder { get; set; }
property bool UseCustomBackupFolder {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.UseEffectShaders Property

IApplicationUseEffectShaders Property

Gets or sets a Boolean value that indicates the use of effect shaders in the visual space

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool UseEffectShaders { get; set; }
property bool UseEffectShaders {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.UseMaterialShaders Property

IApplicationUseMaterialShaders Property

Note: This API is now obsolete.

Gets or sets a Boolean value that indicates the use of material shaders in the main instance of IWindow3D.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Use window specific property IWindow3D.UseMaterialShaders instead.")]
bool UseMaterialShaders { get; set; }
[ObsoleteAttribute(L"Use window specific property IWindow3D.UseMaterialShaders instead.")]
property bool UseMaterialShaders {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.ValidLicenseExists Property

IApplicationValidLicenseExists Property

Gets a Boolean value that indicates if a valid license is available.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ValidLicenseExists { get; }
property bool ValidLicenseExists {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.Windows Property

IApplicationWindows Property

Gets the collection of existing IWindow3D instances.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IWindow3D> Windows { get; }
property ReadOnlyCollection<IWindow3D^>^ Windows {
    ReadOnlyCollection<IWindow3D^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIWindow3D
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.World Property

IApplicationWorld Property

Gets the 3D simulation world ISimWorld.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimWorld World { get; }
property ISimWorld^ World {
    ISimWorld^ get ();
}

Property Value

Type: ISimWorld
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication Methods

The IApplication type exposes the following members.

Methods
 | Name | Description
Public method | AutoShareFeatureTrees | Combine identical feature trees. This operation is performed on the whole layout at once.
Public method | CheckConfigurations(Object) | Obsolete. Check that attached bases and tools are not attached to nodes between RootNode and FlangeNode. Prints an error message and shows a popup message box if attachment is invalid.
Public method | CheckConfigurations(IEnumerableISimComponent, IRobotFrame, IRobotFrame, Boolean, Boolean) | Checks that attached bases and tools are not attached to nodes between RootNode and FlangeNode. Prints an error message and/or shows a popup message box if the attachment is invalid.
Public method | CheckFileExtension | check and add a file extension if it is missed
Public method | CheckRebuild | Check if some behaviours require evaluation, after visual objects where moved.
Public method | CheckRebuildOnRender | Check if we need to recalculate robot position statuses.
Public method | ClearDispatcherQueueWhenClosingLayout | Additional helper used to enable IsClosingLayout-flag and flush dispatcher queue.
Public method | ClearMessages | Clears internal messages.
Public method | CloseLayout | Closes current layout and clear the virtual space.
Public method | Create3DWindow(String) | Creates a new IWindow3D instance.
Public method | Create3DWindow(ISimWorld) | Creates a new IWindow3D instance, displaying the given world.
Public method | Create3DWindow(String, Boolean) | Creates a new IWindow3D instance, displaying the default 3d/drawing world.
Public method | CreateAuxWorld | Creates a new auxiliary (non system) instance of ISimWorld.
Public method | CreateCollisionDetector | Creates a nonpersistent instance of ICollisionDetector
Public method | CreateComponent | Creates a new component
Public method | CreateMaterial(String) | Creates a new IMaterial instance.
Public method | CreateMaterial(String, Boolean) | Creates a new IMaterial instance. Specifies if it is system material which by default is false
Public method | CustomProjection | Deprecated: Sets temporary window size. Similar to SurfaceSetSize().
Public method | Delete3DWindow | Deletes the existing IWindow3D instance.
Public method | DeleteAuxWorld | Deletes the given axiliary instance of ISimWorld. Note that the system instances cannot be deleted.
Public method | DeleteMaterial | Deletes an existing IMaterial instance
Public method | DestroyGlobalData |
Public method | ExecuteCommand | execute command
Public method | ExecuteCommand2 | execute command
Public method | ExecuteCommandMethod | Invoke a function in a specific python command or behavior.
Public method | ExecutePythonCommandMethod | Invoke a function in a specific python command or behavior.
Public method | ExecutePythonFile |
Public method | ExportLayout(Uri) | Export current layout to the given Uri
Public method | ExportLayout(Uri, Boolean) | Export current layout ignorning the non selected components to the given Uri
Public method | FindMaterial | Returns IMaterial based on a specified material name. Returns Null if material name is not found.
Public method | FindPythonCommand | Alternative to using ExecuteCommand and ExecuteCommand2.
Public method | FlushAutoShare | This is needed only when using FeatureTreeAutoSharing-option, which is typically disabled. Tries to reuse already existing feature tree and geometries. Returns the count of components optimized.
Public method | GetCommandIsEnabled | Get enabled state of a python command.
Public method | GetGhostMaterial | Retrieves the temporary ghost material for a particular node/component.
Public method | GetPythonScriptLocation | Get path of a python script based on command id.
Public method | GetSessionValueT | Allows user to retrieve a bool value previously defined by name
Public method | GetSurface | Returns the surface of the current renderer without adding a reference
Public method | InitSafeMode | Will enable assert dialog and log all errors to log file (can be used in release build).
Public method | IsFileFormatNew | verify a file format
Public method | IsFileFormatOld | verify a old file format
Public method | LoadLayout(Uri) | Loads a model into the current world from the given Uri
Public method | LoadLayout(Uri, Vector3) | Loads the layout into the current world from the given Uri to the given position.
Public method | LoadLayout(Uri, Vector3, Boolean) | Loads the layout into the current world from the given Uri to the given position.
Public method | LoadLayout(Uri, Vector3, Boolean, ISimWorld) | Loads the layout into the target world from the given Uri to the given position.
Public method | LoadPythonCommand | Alternative to using getApplication().loadCommand() in python.
Public method | MaterialPreview | Renders into 3d word a mesh with a given material. Mesh is not attached to any component.
Public method | NotifyVREventsEvent | VR Events are sent by the Experience viewer if IVREventsServer.EventsEnabled is true.
Public method | RecompileCommand | Recompile python script.
Public method | SaveComponent | Save the given component to a file
Public method | SaveLayout | Save current layout to the given Uri
Public method | SetAntialiasingMode | Sets the anti-aliasing Rendering mode
Public method | SetAntialiasingQuality | set the anti-aliasing Rendering quality
Public method | SetCommandIsEnabled | Set enabled state of a python command.
Public method | SetForceExDevice |
Public method | SetForceUnlocked |
Public method | SetLayoutModified | Notifies the application that the world has been modified
Public method | SetRecordingMode | Disable every other rendering method except SurfaceToContinuousBuffer().
Public method | SetSessionValueT | Allows user to store a bool value defined by name
Public method | SetShaderMode | Turns the shader On/Off
Public method | SetTransparentQuality | Obsolete. Sets transparent Material Rendering quality
Public method | SetUseAlpha |
Public method | SurfaceDestroy |
Public method | SurfacePrepareRender | Prepares the IWindow3D to be rendered asyncronously
Public method | SurfaceRender | Renders the IWindow3D
Public method | SurfaceSetEffect | Selects the shader effect
Public method | SurfaceSetSize(IWindow3D, UInt32, UInt32) | Update the size of the surface of the given window. Next render will create a new surface.
Public method | SurfaceSetSize(IWindow3D, UInt32, UInt32, Boolean) | Update the size of the surface of the given window. Next render will create a new surface.
Public method | SurfaceStartRender | Starts IWindow3D rendering asyncronously
Public method | SurfaceTileToBuffer | Render a portion of the 3D scene delimited by min and max vectors into a buffer
Public method | SurfaceToBuffer(ImageFormat) | Renders the 3D scene into a buffer of bytes using current width and height image resolution
Public method | SurfaceToBuffer(ImageFormat, UInt32, UInt32) | Renders the 3D scene into a buffer of bytes using the given width and height image resolution
Public method | SurfaceToBuffer(ImageFormat, UInt32, UInt32, FuncBoolean) | Renders the 3D scene into a buffer of bytes using the given width and height image resolution
Public method | SurfaceToContinuousBuffer | Renders the 3D scene into a temporary buffer, that stays in memory until SetRecordingMode(false) is called. This can be used only together with SetRecordingMode(true). Buffer format is a raw BGRA bitmap without any header information.
Public method | SurfaceToImage(ImageFormat, String) | Renders the 3D scene into an image saved into the given location
Public method | SurfaceToImage(ImageFormat, String, UInt32, UInt32) | Renders the 3D scene into an image saved into the given location with the given width and height resolution
Public method | SurfaceToImage(ImageFormat, String, UInt32, UInt32, FuncBoolean) | Renders the 3D scene into an image saved into the given location with the given width and height resolution
Public method | SurfaceWaitRender | Waits IWindow3D asyncronous rendering to be finished
Public method | TestAllCollisionDetectors | Execute collision test.
Public method | TestRenderDevice | Returns the state of 3D Device.
Public method | TestRenderInternalException | Returns true if rendering id disabled due to internal exception.
Public method | UnloadAppFeature | Shuts down the application.
Public method | UpdateDimensionsDisplayAccuracy | Update accuracy of dimensions for model.
Public method | WriteLine | Obsolete. Writes a message to the output console
Top
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.AutoShareFeatureTrees Method

IApplicationAutoShareFeatureTrees Method

Combine identical feature trees. This operation is performed on the whole layout at once.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AutoShareFeatureTrees()
void AutoShareFeatureTrees()
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.CheckConfigurations Method

IApplicationCheckConfigurations Method

Overload List
 | Name | Description
Public method | CheckConfigurations(Object) | Obsolete. Check that attached bases and tools are not attached to nodes between RootNode and FlangeNode. Prints an error message and shows a popup message box if attachment is invalid.
Public method | CheckConfigurations(IEnumerableISimComponent, IRobotFrame, IRobotFrame, Boolean, Boolean) | Checks that attached bases and tools are not attached to nodes between RootNode and FlangeNode. Prints an error message and/or shows a popup message box if the attachment is invalid.
Top
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.CheckConfigurations Method (Object)

IApplicationCheckConfigurations Method (Object)

Note: This API is now obsolete.

Check that attached bases and tools are not attached to nodes between RootNode and FlangeNode. Prints an error message and shows a popup message box if attachment is invalid.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Use the strongly-typed method instead", false)]
void CheckConfigurations(
    Object items
)
[ObsoleteAttribute(L"Use the strongly-typed method instead", false)]
void CheckConfigurations(
    Object^ items
)

Parameters

items
Type: SystemObject
A list of components
See Also

Reference

IApplication Interface
CheckConfigurations Overload
VisualComponents.Create3D Namespace


IApplication.CheckConfigurations Method (IEnumerable(ISimComponent), IRobotFrame, IRobotFrame, Boolean, Boolean)

IApplicationCheckConfigurations Method (IEnumerableISimComponent, IRobotFrame, IRobotFrame, Boolean, Boolean)

Checks that attached bases and tools are not attached to nodes between RootNode and FlangeNode. Prints an error message and/or shows a popup message box if the attachment is invalid.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void CheckConfigurations(
    IEnumerable<ISimComponent> componentsAttached,
    IRobotFrame activatedBaseTool,
    IRobotFrame nodeChangedInBaseTool,
    bool printError,
    bool popupError
)
void CheckConfigurations(
    IEnumerable<ISimComponent^>^ componentsAttached,
    IRobotFrame^ activatedBaseTool,
    IRobotFrame^ nodeChangedInBaseTool,
    bool printError,
    bool popupError
)

Parameters

componentsAttached
Type: System.Collections.GenericIEnumerableISimComponent
activatedBaseTool
Type: VisualComponents.Create3DIRobotFrame
nodeChangedInBaseTool
Type: VisualComponents.Create3DIRobotFrame
printError
Type: SystemBoolean
popupError
Type: SystemBoolean
See Also

Reference

IApplication Interface
CheckConfigurations Overload
VisualComponents.Create3D Namespace


IApplication.CheckFileExtension Method

IApplicationCheckFileExtension Method

check and add a file extension if it is missed

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string CheckFileExtension(
    string filePath
)
String^ CheckFileExtension(
    String^ filePath
)

Parameters

filePath
Type: SystemString
file path

Return Value

Type: String
new file name
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.CheckRebuild Method

IApplicationCheckRebuild Method

Check if some behaviours require evaluation, after visual objects where moved.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void CheckRebuild(
    IList<IVisualObject> objects
)
void CheckRebuild(
    IList<IVisualObject^>^ objects
)

Parameters

objects
Type: System.Collections.GenericIListIVisualObject
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.CheckRebuildOnRender Method

IApplicationCheckRebuildOnRender Method

Check if we need to recalculate robot position statuses.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void CheckRebuildOnRender()
void CheckRebuildOnRender()
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.ClearDispatcherQueueWhenClosingLayout Method

IApplicationClearDispatcherQueueWhenClosingLayout Method

Additional helper used to enable IsClosingLayout-flag and flush dispatcher queue.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ClearDispatcherQueueWhenClosingLayout()
void ClearDispatcherQueueWhenClosingLayout()
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.ClearMessages Method

IApplicationClearMessages Method

Clears internal messages.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ClearMessages()
void ClearMessages()
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.CloseLayout Method

IApplicationCloseLayout Method

Closes current layout and clear the virtual space.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void CloseLayout()
void CloseLayout()
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.Create3DWindow Method

IApplicationCreate3DWindow Method

Overload List
 | Name | Description
Public method | Create3DWindow(String) | Creates a new IWindow3D instance.
Public method | Create3DWindow(ISimWorld) | Creates a new IWindow3D instance, displaying the given world.
Public method | Create3DWindow(String, Boolean) | Creates a new IWindow3D instance, displaying the default 3d/drawing world.
Top
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.Create3DWindow Method (String)

IApplicationCreate3DWindow Method (String)

Creates a new IWindow3D instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IWindow3D Create3DWindow(
    string name
)
IWindow3D^ Create3DWindow(
    String^ name
)

Parameters

name
Type: SystemString
The name of the window to be created.

Return Value

Type: IWindow3D
New 3D window
See Also

Reference

IApplication Interface
Create3DWindow Overload
VisualComponents.Create3D Namespace


IApplication.Create3DWindow Method (ISimWorld)

IApplicationCreate3DWindow Method (ISimWorld)

Creates a new IWindow3D instance, displaying the given world.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IWindow3D Create3DWindow(
    ISimWorld world
)
IWindow3D^ Create3DWindow(
    ISimWorld^ world
)

Parameters

world
Type: VisualComponents.Create3DISimWorld
World to display.

Return Value

Type: IWindow3D
New 3D window.
Exceptions
Exception | Condition
NullReferenceException | Occurs when world argument is null or empty.
See Also

Reference

IApplication Interface
Create3DWindow Overload
VisualComponents.Create3D Namespace


IApplication.Create3DWindow Method (String, Boolean)

IApplicationCreate3DWindow Method (String, Boolean)

Creates a new IWindow3D instance, displaying the default 3d/drawing world.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IWindow3D Create3DWindow(
    string name,
    bool isMainWindow
)
IWindow3D^ Create3DWindow(
    String^ name,
    bool isMainWindow
)

Parameters

name
Type: SystemString
The name of the window to be created.
isMainWindow
Type: SystemBoolean
Defines if the window is the main window for the application.

Return Value

Type: IWindow3D
New 3D window.
Exceptions
Exception | Condition
InvalidOperationException | Occurs when the application already contains a main window.
NullReferenceException | Occurs when name argument is null or empty.
See Also

Reference

IApplication Interface
Create3DWindow Overload
VisualComponents.Create3D Namespace


IApplication.CreateAuxWorld Method

IApplicationCreateAuxWorld Method

Creates a new auxiliary (non system) instance of ISimWorld.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimWorld CreateAuxWorld()
ISimWorld^ CreateAuxWorld()

Return Value

Type: ISimWorld
Created world.
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.CreateCollisionDetector Method

IApplicationCreateCollisionDetector Method

Creates a nonpersistent instance of ICollisionDetector

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ICollisionDetector CreateCollisionDetector()
ICollisionDetector^ CreateCollisionDetector()

Return Value

Type: ICollisionDetector
Created collision detector
Remarks
Collision detector instance created using this method will remain in the memory until it is explicitly released by using its Destroy() method. This collision detector is nonpersistent, which means it is not saved with the layout.
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.CreateComponent Method

IApplicationCreateComponent Method

Creates a new component

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent CreateComponent(
    string name
)
ISimComponent^ CreateComponent(
    String^ name
)

Parameters

name
Type: SystemString
Name of the component to be created

Return Value

Type: ISimComponent
Created component
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.CreateMaterial Method

IApplicationCreateMaterial Method

Overload List
 | Name | Description
Public method | CreateMaterial(String) | Creates a new IMaterial instance.
Public method | CreateMaterial(String, Boolean) | Creates a new IMaterial instance. Specifies if it is system material which by default is false
Top
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.CreateMaterial Method (String)

IApplicationCreateMaterial Method (String)

Creates a new IMaterial instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMaterial CreateMaterial(
    string name
)
IMaterial^ CreateMaterial(
    String^ name
)

Parameters

name
Type: SystemString
Indicates the name of the material to create

Return Value

Type: IMaterial
The created IMaterial
See Also

Reference

IApplication Interface
CreateMaterial Overload
VisualComponents.Create3D Namespace


IApplication.CreateMaterial Method (String, Boolean)

IApplicationCreateMaterial Method (String, Boolean)

Creates a new IMaterial instance. Specifies if it is system material which by default is false

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMaterial CreateMaterial(
    string name,
    bool isSystem
)
IMaterial^ CreateMaterial(
    String^ name,
    bool isSystem
)

Parameters

name
Type: SystemString
Indicates the name of the material to create
isSystem
Type: SystemBoolean

Return Value

Type: IMaterial
The created IMaterial.
See Also

Reference

IApplication Interface
CreateMaterial Overload
VisualComponents.Create3D Namespace


IApplication.CustomProjection Method

IApplicationCustomProjection Method

Deprecated: Sets temporary window size. Similar to SurfaceSetSize().

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void CustomProjection(
    bool enable,
    uint width,
    uint height
)
void CustomProjection(
    bool enable,
    unsigned int width,
    unsigned int height
)

Parameters

enable
Type: SystemBoolean
width
Type: SystemUInt32
height
Type: SystemUInt32
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.Delete3DWindow Method

IApplicationDelete3DWindow Method

Deletes the existing IWindow3D instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Delete3DWindow(
    IWindow3D window
)
void Delete3DWindow(
    IWindow3D^ window
)

Parameters

window
Type: VisualComponents.Create3DIWindow3D
Window to be deleted
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.DeleteAuxWorld Method

IApplicationDeleteAuxWorld Method

Deletes the given axiliary instance of ISimWorld. Note that the system instances cannot be deleted.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteAuxWorld(
    ISimWorld world
)
void DeleteAuxWorld(
    ISimWorld^ world
)

Parameters

world
Type: VisualComponents.Create3DISimWorld
World to delete.
Exceptions
Exception | Condition
ArgumentNullException | Occurs when given world is null.
InvalidOperationException | Occurs when attempting to delete system world.
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.DeleteMaterial Method

IApplicationDeleteMaterial Method

Deletes an existing IMaterial instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteMaterial(
    IMaterial material
)
void DeleteMaterial(
    IMaterial^ material
)

Parameters

material
Type: VisualComponents.Create3DIMaterial
Indicates IMaterial to delete.
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.DestroyGlobalData Method

IApplicationDestroyGlobalData Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DestroyGlobalData()
void DestroyGlobalData()
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.ExecuteCommand Method

IApplicationExecuteCommand Method

execute command

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ExecuteCommandResult ExecuteCommand(
    string commandName,
    PropertyCollection parameters
)
ExecuteCommandResult ExecuteCommand(
    String^ commandName,
    PropertyCollection^ parameters
)

Parameters

commandName
Type: SystemString
command name
parameters
Type: VisualComponents.Create3DPropertyCollection
additional parameters

Return Value

Type: ExecuteCommandResult
status of command executing
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.ExecuteCommand2 Method

IApplicationExecuteCommand2 Method

execute command

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ExecuteCommandResult ExecuteCommand2(
    string commandName,
    params Object[] args
)
ExecuteCommandResult ExecuteCommand2(
    String^ commandName,
    ... array<Object^>^ args
)

Parameters

commandName
Type: SystemString
command name
args
Type: SystemObject
additional parameters

Return Value

Type: ExecuteCommandResult
status of command executing
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.ExecuteCommandMethod Method

IApplicationExecuteCommandMethod Method

Invoke a function in a specific python command or behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ExecuteCommandMethod(
    string commandName,
    string methodName,
    Object argument
)
void ExecuteCommandMethod(
    String^ commandName,
    String^ methodName,
    Object^ argument
)

Parameters

commandName
Type: SystemString
methodName
Type: SystemString
argument
Type: SystemObject
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.ExecutePythonCommandMethod Method

IApplicationExecutePythonCommandMethod Method

Invoke a function in a specific python command or behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ExecutePythonCommandMethod(
    string commandName,
    string methodName,
    string[] arguments,
    out Object result
)
bool ExecutePythonCommandMethod(
    String^ commandName,
    String^ methodName,
    array<String^>^ arguments,
    [OutAttribute] Object^% result
)

Parameters

commandName
Type: SystemString
methodName
Type: SystemString
arguments
Type: SystemString
result
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IApplication.ExecutePythonCommandMethod(System.String,System.String,System.String[],System.Object@)"]

See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.ExecutePythonFile Method

IApplicationExecutePythonFile Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ExecutePythonFile(
    string file
)
void ExecutePythonFile(
    String^ file
)

Parameters

file
Type: SystemString
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.ExportLayout Method

IApplicationExportLayout Method

Overload List
 | Name | Description
Public method | ExportLayout(Uri) | Export current layout to the given Uri
Public method | ExportLayout(Uri, Boolean) | Export current layout ignorning the non selected components to the given Uri
Top
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.ExportLayout Method (Uri)

IApplicationExportLayout Method (Uri)

Export current layout to the given Uri

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ExportLayout(
    Uri uri
)
void ExportLayout(
    Uri^ uri
)

Parameters

uri
Type: SystemUri
URI of the file where the 3D model to be saved
See Also

Reference

IApplication Interface
ExportLayout Overload
VisualComponents.Create3D Namespace


IApplication.ExportLayout Method (Uri, Boolean)

IApplicationExportLayout Method (Uri, Boolean)

Export current layout ignorning the non selected components to the given Uri

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ExportLayout(
    Uri uri,
    bool onlySelectedComponents
)
void ExportLayout(
    Uri^ uri,
    bool onlySelectedComponents
)

Parameters

uri
Type: SystemUri
URI of the file where the 3D model to be saved
onlySelectedComponents
Type: SystemBoolean
defines if the export should contain only selected components
See Also

Reference

IApplication Interface
ExportLayout Overload
VisualComponents.Create3D Namespace


IApplication.FindMaterial Method

IApplicationFindMaterial Method

Returns IMaterial based on a specified material name. Returns Null if material name is not found.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMaterial FindMaterial(
    string name,
    bool caseSensitive
)
IMaterial^ FindMaterial(
    String^ name,
    bool caseSensitive
)

Parameters

name
Type: SystemString
Indicates the name of the material to return
caseSensitive
Type: SystemBoolean
Indicates search text case sensitivity

Return Value

Type: IMaterial
The IMaterial with the given name.
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.FindPythonCommand Method

IApplicationFindPythonCommand Method

Alternative to using ExecuteCommand and ExecuteCommand2.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPythonCommand FindPythonCommand(
    string commandName
)
IPythonCommand^ FindPythonCommand(
    String^ commandName
)

Parameters

commandName
Type: SystemString

Return Value

Type: IPythonCommand

[Missing <returns> documentation for "M:VisualComponents.Create3D.IApplication.FindPythonCommand(System.String)"]

See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.FlushAutoShare Method

IApplicationFlushAutoShare Method

This is needed only when using FeatureTreeAutoSharing-option, which is typically disabled. Tries to reuse already existing feature tree and geometries. Returns the count of components optimized.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int FlushAutoShare()
int FlushAutoShare()

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.IApplication.FlushAutoShare"]

See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.GetCommandIsEnabled Method

IApplicationGetCommandIsEnabled Method

Get enabled state of a python command.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool GetCommandIsEnabled(
    string commandName
)
bool GetCommandIsEnabled(
    String^ commandName
)

Parameters

commandName
Type: SystemString
command name

Return Value

Type: Boolean
Enabled state of the command
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.GetGhostMaterial Method

IApplicationGetGhostMaterial Method

Retrieves the temporary ghost material for a particular node/component.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMaterial GetGhostMaterial(
    IVisualObject visual
)
IMaterial^ GetGhostMaterial(
    IVisualObject^ visual
)

Parameters

visual
Type: VisualComponents.Create3DIVisualObject
Visual representation of component in the 3D World

Return Value

Type: IMaterial
The ghost IMaterial for given node/component.
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.GetPythonScriptLocation Method

IApplicationGetPythonScriptLocation Method

Get path of a python script based on command id.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string GetPythonScriptLocation(
    string commandName
)
String^ GetPythonScriptLocation(
    String^ commandName
)

Parameters

commandName
Type: SystemString

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.IApplication.GetPythonScriptLocation(System.String)"]

See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.GetSessionValue(T) Method

IApplicationGetSessionValueT Method

Allows user to retrieve a bool value previously defined by name

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
T GetSessionValue<T>(
    string name
)

generic<typename T>
T GetSessionValue(
    String^ name
)

Parameters

name
Type: SystemString

Type Parameters

T

Return Value

Type: T

[Missing <returns> documentation for "M:VisualComponents.Create3D.IApplication.GetSessionValue``1(System.String)"]

See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.GetSurface Method

IApplicationGetSurface Method

Returns the surface of the current renderer without adding a reference

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IntPtr GetSurface(
    IWindow3D window,
    IntPtr surf
)
IntPtr GetSurface(
    IWindow3D^ window,
    IntPtr surf
)

Parameters

window
Type: VisualComponents.Create3DIWindow3D
Indicates the IWindow3D
surf
Type: SystemIntPtr

Return Value

Type: IntPtr
Returns IntPtr
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.InitSafeMode Method

IApplicationInitSafeMode Method

Will enable assert dialog and log all errors to log file (can be used in release build).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void InitSafeMode()
void InitSafeMode()
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.IsFileFormatNew Method

IApplicationIsFileFormatNew Method

verify a file format

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsFileFormatNew(
    string filePath
)
bool IsFileFormatNew(
    String^ filePath
)

Parameters

filePath
Type: SystemString
file path

Return Value

Type: Boolean
true if the file has new format
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.IsFileFormatOld Method

IApplicationIsFileFormatOld Method

verify a old file format

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsFileFormatOld(
    string filePath
)
bool IsFileFormatOld(
    String^ filePath
)

Parameters

filePath
Type: SystemString
file path

Return Value

Type: Boolean
true if the file has old format
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.LoadLayout Method

IApplicationLoadLayout Method

Overload List
 | Name | Description
Public method | LoadLayout(Uri) | Loads a model into the current world from the given Uri
Public method | LoadLayout(Uri, Vector3) | Loads the layout into the current world from the given Uri to the given position.
Public method | LoadLayout(Uri, Vector3, Boolean) | Loads the layout into the current world from the given Uri to the given position.
Public method | LoadLayout(Uri, Vector3, Boolean, ISimWorld) | Loads the layout into the target world from the given Uri to the given position.
Top
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.LoadLayout Method (Uri)

IApplicationLoadLayout Method (Uri)

Loads a model into the current world from the given Uri

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent[] LoadLayout(
    Uri uri
)
array<ISimComponent^>^ LoadLayout(
    Uri^ uri
)

Parameters

uri
Type: SystemUri
URI of the model to be loaded

Return Value

Type: ISimComponent
Array of loaded components
See Also

Reference

IApplication Interface
LoadLayout Overload
VisualComponents.Create3D Namespace


IApplication.LoadLayout Method (Uri, Vector3)

IApplicationLoadLayout Method (Uri, Vector3)

Loads the layout into the current world from the given Uri to the given position.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent[] LoadLayout(
    Uri uri,
    Vector3 initialPosition
)
array<ISimComponent^>^ LoadLayout(
    Uri^ uri,
    Vector3 initialPosition
)

Parameters

uri
Type: SystemUri
URI of the model to be loaded
initialPosition
Type: VisualComponents.Create3DVector3
Position where the model is loaded to

Return Value

Type: ISimComponent
Array of loaded components
See Also

Reference

IApplication Interface
LoadLayout Overload
VisualComponents.Create3D Namespace


IApplication.LoadLayout Method (Uri, Vector3, Boolean)

IApplicationLoadLayout Method (Uri, Vector3, Boolean)

Loads the layout into the current world from the given Uri to the given position.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent[] LoadLayout(
    Uri uri,
    Vector3 initialPosition,
    out bool isComponent
)
array<ISimComponent^>^ LoadLayout(
    Uri^ uri,
    Vector3 initialPosition,
    [OutAttribute] bool% isComponent
)

Parameters

uri
Type: SystemUri
URI of the model to be loaded
initialPosition
Type: VisualComponents.Create3DVector3
Position where the model is loaded to
isComponent
Type: SystemBoolean
True if loaded uri was a component or geometry, false otherwise.

Return Value

Type: ISimComponent
Array of loaded components
See Also

Reference

IApplication Interface
LoadLayout Overload
VisualComponents.Create3D Namespace


IApplication.LoadLayout Method (Uri, Vector3, Boolean, ISimWorld)

IApplicationLoadLayout Method (Uri, Vector3, Boolean, ISimWorld)

Loads the layout into the target world from the given Uri to the given position.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent[] LoadLayout(
    Uri uri,
    Vector3 initialPosition,
    out bool isComponent,
    ISimWorld targetWorld
)
array<ISimComponent^>^ LoadLayout(
    Uri^ uri,
    Vector3 initialPosition,
    [OutAttribute] bool% isComponent,
    ISimWorld^ targetWorld
)

Parameters

uri
Type: SystemUri
URI of the model to be loaded
initialPosition
Type: VisualComponents.Create3DVector3
Position where the model is loaded to
isComponent
Type: SystemBoolean
True if loaded uri was a component or geometry, false otherwise.
targetWorld
Type: VisualComponents.Create3DISimWorld
ISimWorld ISimWorld where loaded components are added. If targetWorld is null, current world is used. If current world differs from target world application context will change accordingly.

Return Value

Type: ISimComponent
Array of loaded components
See Also

Reference

IApplication Interface
LoadLayout Overload
VisualComponents.Create3D Namespace


IApplication.LoadPythonCommand Method

IApplicationLoadPythonCommand Method

Alternative to using getApplication().loadCommand() in python.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPythonCommand LoadPythonCommand(
    string commandName,
    string fileName
)
IPythonCommand^ LoadPythonCommand(
    String^ commandName,
    String^ fileName
)

Parameters

commandName
Type: SystemString
fileName
Type: SystemString

Return Value

Type: IPythonCommand

[Missing <returns> documentation for "M:VisualComponents.Create3D.IApplication.LoadPythonCommand(System.String,System.String)"]

See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.MaterialPreview Method

IApplicationMaterialPreview Method

Renders into 3d word a mesh with a given material. Mesh is not attached to any component.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void MaterialPreview(
    bool add,
    IMaterial material
)
void MaterialPreview(
    bool add,
    IMaterial^ material
)

Parameters

add
Type: SystemBoolean
If True, adds a preview mesh. Otherwise it removes any preview mesh
material
Type: VisualComponents.Create3DIMaterial
Material to be applied to the rendered mesh
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.NotifyVREventsEvent Method

IApplicationNotifyVREventsEvent Method

VR Events are sent by the Experience viewer if IVREventsServer.EventsEnabled is true.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void NotifyVREventsEvent(
    Object data
)
void NotifyVREventsEvent(
    Object^ data
)

Parameters

data
Type: SystemObject
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.RecompileCommand Method

IApplicationRecompileCommand Method

Recompile python script.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool RecompileCommand(
    string commandName
)
bool RecompileCommand(
    String^ commandName
)

Parameters

commandName
Type: SystemString

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IApplication.RecompileCommand(System.String)"]

See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.SaveComponent Method

IApplicationSaveComponent Method

Save the given component to a file

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SaveComponent(
    ISimComponent component,
    Uri url,
    Vector3 minBound,
    Vector3 maxBound
)
void SaveComponent(
    ISimComponent^ component,
    Uri^ url,
    Vector3 minBound,
    Vector3 maxBound
)

Parameters

component
Type: VisualComponents.Create3DISimComponent
Component to save
url
Type: SystemUri
File path to write
minBound
Type: VisualComponents.Create3DVector3
minimum component bound
maxBound
Type: VisualComponents.Create3DVector3
maximum component bound
Remarks
This requires the modeling pack license to be present.
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.SaveLayout Method

IApplicationSaveLayout Method

Save current layout to the given Uri

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SaveLayout(
    Uri uri
)
void SaveLayout(
    Uri^ uri
)

Parameters

uri
Type: SystemUri
URI of the file where the 3D model to be saved
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.SetAntialiasingMode Method

IApplicationSetAntialiasingMode Method

Sets the anti-aliasing Rendering mode

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetAntialiasingMode(
    int qualityIndex
)
void SetAntialiasingMode(
    int qualityIndex
)

Parameters

qualityIndex
Type: SystemInt32
0 = no anti-aliasing, 1 = simple antialiasing and 2 = multisampling
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.SetAntialiasingQuality Method

IApplicationSetAntialiasingQuality Method

set the anti-aliasing Rendering quality

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetAntialiasingQuality(
    int qualityIndex
)
void SetAntialiasingQuality(
    int qualityIndex
)

Parameters

qualityIndex
Type: SystemInt32
0 = no antialias, 1 = 2 samples and 2 = 4 samples
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.SetCommandIsEnabled Method

IApplicationSetCommandIsEnabled Method

Set enabled state of a python command.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetCommandIsEnabled(
    string commandName,
    bool isEnabled
)
void SetCommandIsEnabled(
    String^ commandName,
    bool isEnabled
)

Parameters

commandName
Type: SystemString
command name
isEnabled
Type: SystemBoolean
command state
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.SetForceExDevice Method

IApplicationSetForceExDevice Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetForceExDevice(
    bool mode
)
void SetForceExDevice(
    bool mode
)

Parameters

mode
Type: SystemBoolean
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.SetForceUnlocked Method

IApplicationSetForceUnlocked Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetForceUnlocked(
    bool mode
)
void SetForceUnlocked(
    bool mode
)

Parameters

mode
Type: SystemBoolean
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.SetLayoutModified Method

IApplicationSetLayoutModified Method

Notifies the application that the world has been modified

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetLayoutModified()
void SetLayoutModified()
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.SetRecordingMode Method

IApplicationSetRecordingMode Method

Disable every other rendering method except SurfaceToContinuousBuffer().

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int SetRecordingMode(
    IWindow3D window,
    bool enable,
    uint width,
    uint height
)
int SetRecordingMode(
    IWindow3D^ window,
    bool enable,
    unsigned int width,
    unsigned int height
)

Parameters

window
Type: VisualComponents.Create3DIWindow3D
enable
Type: SystemBoolean
width
Type: SystemUInt32
height
Type: SystemUInt32

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.IApplication.SetRecordingMode(VisualComponents.Create3D.IWindow3D,System.Boolean,System.UInt32,System.UInt32)"]

See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.SetSessionValue(T) Method

IApplicationSetSessionValueT Method

Allows user to store a bool value defined by name

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetSessionValue<T>(
    string name,
    T value
)

generic<typename T>
void SetSessionValue(
    String^ name,
    T value
)

Parameters

name
Type: SystemString
value
Type: T
Only bool, int, double and string types allowed

Type Parameters

T
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.SetShaderMode Method

IApplicationSetShaderMode Method

Turns the shader On/Off

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetShaderMode(
    bool mode
)
void SetShaderMode(
    bool mode
)

Parameters

mode
Type: SystemBoolean
Used to indicate if shader mode is on/off
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.SetTransparentQuality Method

IApplicationSetTransparentQuality Method

Note: This API is now obsolete.

Sets transparent Material Rendering quality

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Use window specific setting in IWindow3D interface.")]
void SetTransparentQuality(
    int qualityIndex
)
[ObsoleteAttribute(L"Use window specific setting in IWindow3D interface.")]
void SetTransparentQuality(
    int qualityIndex
)

Parameters

qualityIndex
Type: SystemInt32
0 = 1peel, 1 = 2peels and 2 = 4peels
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.SetUseAlpha Method

IApplicationSetUseAlpha Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetUseAlpha(
    bool mode
)
void SetUseAlpha(
    bool mode
)

Parameters

mode
Type: SystemBoolean
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.SurfaceDestroy Method

IApplicationSurfaceDestroy Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SurfaceDestroy()
void SurfaceDestroy()
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.SurfacePrepareRender Method

IApplicationSurfacePrepareRender Method

Prepares the IWindow3D to be rendered asyncronously

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int SurfacePrepareRender(
    IWindow3D window
)
int SurfacePrepareRender(
    IWindow3D^ window
)

Parameters

window
Type: VisualComponents.Create3DIWindow3D
Used to indicates the IWindow3D

Return Value

Type: Int32
Returns an integer
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.SurfaceRender Method

IApplicationSurfaceRender Method

Renders the IWindow3D

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int SurfaceRender(
    IWindow3D window
)
int SurfaceRender(
    IWindow3D^ window
)

Parameters

window
Type: VisualComponents.Create3DIWindow3D
Used to indicates the IWindow3D

Return Value

Type: Int32
Returns an integer
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.SurfaceSetEffect Method

IApplicationSurfaceSetEffect Method

Selects the shader effect

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SurfaceSetEffect(
    int renderEffectType
)
bool SurfaceSetEffect(
    int renderEffectType
)

Parameters

renderEffectType
Type: SystemInt32
Used to indicate the effect type

Return Value

Type: Boolean
Returns true or false
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.SurfaceSetSize Method

IApplicationSurfaceSetSize Method

Overload List
 | Name | Description
Public method | SurfaceSetSize(IWindow3D, UInt32, UInt32) | Update the size of the surface of the given window. Next render will create a new surface.
Public method | SurfaceSetSize(IWindow3D, UInt32, UInt32, Boolean) | Update the size of the surface of the given window. Next render will create a new surface.
Top
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.SurfaceSetSize Method (IWindow3D, UInt32, UInt32)

IApplicationSurfaceSetSize Method (IWindow3D, UInt32, UInt32)

Update the size of the surface of the given window. Next render will create a new surface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SurfaceSetSize(
    IWindow3D window,
    uint width,
    uint height
)
bool SurfaceSetSize(
    IWindow3D^ window,
    unsigned int width,
    unsigned int height
)

Parameters

window
Type: VisualComponents.Create3DIWindow3D
Indicates the IWindow3D
width
Type: SystemUInt32
Indicates the width
height
Type: SystemUInt32
Indicates the height

Return Value

Type: Boolean
True/False.
See Also

Reference

IApplication Interface
SurfaceSetSize Overload
VisualComponents.Create3D Namespace


IApplication.SurfaceSetSize Method (IWindow3D, UInt32, UInt32, Boolean)

IApplicationSurfaceSetSize Method (IWindow3D, UInt32, UInt32, Boolean)

Update the size of the surface of the given window. Next render will create a new surface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SurfaceSetSize(
    IWindow3D window,
    uint width,
    uint height,
    bool force
)
bool SurfaceSetSize(
    IWindow3D^ window,
    unsigned int width,
    unsigned int height,
    bool force
)

Parameters

window
Type: VisualComponents.Create3DIWindow3D
Indicates the IWindow3D
width
Type: SystemUInt32
Indicates the width
height
Type: SystemUInt32
Indicates the height
force
Type: SystemBoolean
Force update even if size doesn't change

Return Value

Type: Boolean
True/False.
See Also

Reference

IApplication Interface
SurfaceSetSize Overload
VisualComponents.Create3D Namespace


IApplication.SurfaceStartRender Method

IApplicationSurfaceStartRender Method

Starts IWindow3D rendering asyncronously

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int SurfaceStartRender(
    IWindow3D window
)
int SurfaceStartRender(
    IWindow3D^ window
)

Parameters

window
Type: VisualComponents.Create3DIWindow3D
Used to indicates the IWindow3D

Return Value

Type: Int32
Returns an integer
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.SurfaceTileToBuffer Method

IApplicationSurfaceTileToBuffer Method

Render a portion of the 3D scene delimited by min and max vectors into a buffer

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
byte[] SurfaceTileToBuffer(
    ImageFormat format,
    Vector3 min,
    Vector3 max,
    Func<bool> videoMemoryCheck
)
array<unsigned char>^ SurfaceTileToBuffer(
    ImageFormat format,
    Vector3 min,
    Vector3 max,
    Func<bool>^ videoMemoryCheck
)

Parameters

format
Type: VisualComponents.Create3DImageFormat
Image format
min
Type: VisualComponents.Create3DVector3
min point in screen coordiante system (0 is center of the screen)
max
Type: VisualComponents.Create3DVector3
max point in screen coordiante system (0 is center of the screen)
videoMemoryCheck
Type: SystemFuncBoolean
available video memory will be precalculated and in case of possible missing memory this function will be called

Return Value

Type: Byte

[Missing <returns> documentation for "M:VisualComponents.Create3D.IApplication.SurfaceTileToBuffer(VisualComponents.Create3D.ImageFormat,VisualComponents.Create3D.Vector3,VisualComponents.Create3D.Vector3,System.Func{System.Boolean})"]

See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.SurfaceToBuffer Method

IApplicationSurfaceToBuffer Method

Overload List
 | Name | Description
Public method | SurfaceToBuffer(ImageFormat) | Renders the 3D scene into a buffer of bytes using current width and height image resolution
Public method | SurfaceToBuffer(ImageFormat, UInt32, UInt32) | Renders the 3D scene into a buffer of bytes using the given width and height image resolution
Public method | SurfaceToBuffer(ImageFormat, UInt32, UInt32, FuncBoolean) | Renders the 3D scene into a buffer of bytes using the given width and height image resolution
Top
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.SurfaceToBuffer Method (ImageFormat)

IApplicationSurfaceToBuffer Method (ImageFormat)

Renders the 3D scene into a buffer of bytes using current width and height image resolution

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
byte[] SurfaceToBuffer(
    ImageFormat format
)
array<unsigned char>^ SurfaceToBuffer(
    ImageFormat format
)

Parameters

format
Type: VisualComponents.Create3DImageFormat
Image format

Return Value

Type: Byte

[Missing <returns> documentation for "M:VisualComponents.Create3D.IApplication.SurfaceToBuffer(VisualComponents.Create3D.ImageFormat)"]

See Also

Reference

IApplication Interface
SurfaceToBuffer Overload
VisualComponents.Create3D Namespace


IApplication.SurfaceToBuffer Method (ImageFormat, UInt32, UInt32)

IApplicationSurfaceToBuffer Method (ImageFormat, UInt32, UInt32)

Renders the 3D scene into a buffer of bytes using the given width and height image resolution

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
byte[] SurfaceToBuffer(
    ImageFormat format,
    uint width,
    uint height
)
array<unsigned char>^ SurfaceToBuffer(
    ImageFormat format,
    unsigned int width,
    unsigned int height
)

Parameters

format
Type: VisualComponents.Create3DImageFormat
Image format
width
Type: SystemUInt32
Image width
height
Type: SystemUInt32
Image height

Return Value

Type: Byte

[Missing <returns> documentation for "M:VisualComponents.Create3D.IApplication.SurfaceToBuffer(VisualComponents.Create3D.ImageFormat,System.UInt32,System.UInt32)"]

See Also

Reference

IApplication Interface
SurfaceToBuffer Overload
VisualComponents.Create3D Namespace


IApplication.SurfaceToBuffer Method (ImageFormat, UInt32, UInt32, Func(Boolean))

IApplicationSurfaceToBuffer Method (ImageFormat, UInt32, UInt32, FuncBoolean)

Renders the 3D scene into a buffer of bytes using the given width and height image resolution

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
byte[] SurfaceToBuffer(
    ImageFormat format,
    uint width,
    uint height,
    Func<bool> videoMemoryCheck
)
array<unsigned char>^ SurfaceToBuffer(
    ImageFormat format,
    unsigned int width,
    unsigned int height,
    Func<bool>^ videoMemoryCheck
)

Parameters

format
Type: VisualComponents.Create3DImageFormat
Image format
width
Type: SystemUInt32
Image width
height
Type: SystemUInt32
Image height
videoMemoryCheck
Type: SystemFuncBoolean
available video memory will be precalculated and in case of possible missing memory this function will be called

Return Value

Type: Byte

[Missing <returns> documentation for "M:VisualComponents.Create3D.IApplication.SurfaceToBuffer(VisualComponents.Create3D.ImageFormat,System.UInt32,System.UInt32,System.Func{System.Boolean})"]

See Also

Reference

IApplication Interface
SurfaceToBuffer Overload
VisualComponents.Create3D Namespace


IApplication.SurfaceToContinuousBuffer Method

IApplicationSurfaceToContinuousBuffer Method

Renders the 3D scene into a temporary buffer, that stays in memory until SetRecordingMode(false) is called. This can be used only together with SetRecordingMode(true). Buffer format is a raw BGRA bitmap without any header information.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
byte[] SurfaceToContinuousBuffer(
    uint width,
    uint height
)
array<unsigned char>^ SurfaceToContinuousBuffer(
    unsigned int width,
    unsigned int height
)

Parameters

width
Type: SystemUInt32
height
Type: SystemUInt32

Return Value

Type: Byte

[Missing <returns> documentation for "M:VisualComponents.Create3D.IApplication.SurfaceToContinuousBuffer(System.UInt32,System.UInt32)"]

See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.SurfaceToImage Method

IApplicationSurfaceToImage Method

Overload List
 | Name | Description
Public method | SurfaceToImage(ImageFormat, String) | Renders the 3D scene into an image saved into the given location
Public method | SurfaceToImage(ImageFormat, String, UInt32, UInt32) | Renders the 3D scene into an image saved into the given location with the given width and height resolution
Public method | SurfaceToImage(ImageFormat, String, UInt32, UInt32, FuncBoolean) | Renders the 3D scene into an image saved into the given location with the given width and height resolution
Top
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.SurfaceToImage Method (ImageFormat, String)

IApplicationSurfaceToImage Method (ImageFormat, String)

Renders the 3D scene into an image saved into the given location

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SurfaceToImage(
    ImageFormat format,
    string fileName
)
bool SurfaceToImage(
    ImageFormat format,
    String^ fileName
)

Parameters

format
Type: VisualComponents.Create3DImageFormat
Image format
fileName
Type: SystemString
Image location (it will create a new one or will override an existing one

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IApplication.SurfaceToImage(VisualComponents.Create3D.ImageFormat,System.String)"]

See Also

Reference

IApplication Interface
SurfaceToImage Overload
VisualComponents.Create3D Namespace


IApplication.SurfaceToImage Method (ImageFormat, String, UInt32, UInt32)

IApplicationSurfaceToImage Method (ImageFormat, String, UInt32, UInt32)

Renders the 3D scene into an image saved into the given location with the given width and height resolution

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SurfaceToImage(
    ImageFormat format,
    string fileName,
    uint width,
    uint height
)
bool SurfaceToImage(
    ImageFormat format,
    String^ fileName,
    unsigned int width,
    unsigned int height
)

Parameters

format
Type: VisualComponents.Create3DImageFormat
Image format
fileName
Type: SystemString
Image location (it will create a new one or will override an existing one
width
Type: SystemUInt32
Image width
height
Type: SystemUInt32
Image height

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IApplication.SurfaceToImage(VisualComponents.Create3D.ImageFormat,System.String,System.UInt32,System.UInt32)"]

See Also

Reference

IApplication Interface
SurfaceToImage Overload
VisualComponents.Create3D Namespace


IApplication.SurfaceToImage Method (ImageFormat, String, UInt32, UInt32, Func(Boolean))

IApplicationSurfaceToImage Method (ImageFormat, String, UInt32, UInt32, FuncBoolean)

Renders the 3D scene into an image saved into the given location with the given width and height resolution

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SurfaceToImage(
    ImageFormat format,
    string fileName,
    uint width,
    uint height,
    Func<bool> videoMemoryCheck
)
bool SurfaceToImage(
    ImageFormat format,
    String^ fileName,
    unsigned int width,
    unsigned int height,
    Func<bool>^ videoMemoryCheck
)

Parameters

format
Type: VisualComponents.Create3DImageFormat
Image format
fileName
Type: SystemString
Image location (it will create a new one or will override an existing one
width
Type: SystemUInt32
Image width
height
Type: SystemUInt32
Image height
videoMemoryCheck
Type: SystemFuncBoolean
available video memory will be precalculated and in case of possible missing memory this function will be called

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IApplication.SurfaceToImage(VisualComponents.Create3D.ImageFormat,System.String,System.UInt32,System.UInt32,System.Func{System.Boolean})"]

See Also

Reference

IApplication Interface
SurfaceToImage Overload
VisualComponents.Create3D Namespace


IApplication.SurfaceWaitRender Method

IApplicationSurfaceWaitRender Method

Waits IWindow3D asyncronous rendering to be finished

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int SurfaceWaitRender(
    IWindow3D window
)
int SurfaceWaitRender(
    IWindow3D^ window
)

Parameters

window
Type: VisualComponents.Create3DIWindow3D
Used to indicates the IWindow3D

Return Value

Type: Int32
Returns an integer
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.TestAllCollisionDetectors Method

IApplicationTestAllCollisionDetectors Method

Execute collision test.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void TestAllCollisionDetectors()
void TestAllCollisionDetectors()
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.TestRenderDevice Method

IApplicationTestRenderDevice Method

Returns the state of 3D Device.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int TestRenderDevice()
int TestRenderDevice()

Return Value

Type: Int32
Returns an integer
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.TestRenderInternalException Method

IApplicationTestRenderInternalException Method

Returns true if rendering id disabled due to internal exception.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int TestRenderInternalException()
int TestRenderInternalException()

Return Value

Type: Int32
Returns an integer
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.UnloadAppFeature Method

IApplicationUnloadAppFeature Method

Shuts down the application.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UnloadAppFeature()
void UnloadAppFeature()
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.UpdateDimensionsDisplayAccuracy Method

IApplicationUpdateDimensionsDisplayAccuracy Method

Update accuracy of dimensions for model.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateDimensionsDisplayAccuracy(
    uint dimensionsAccuracy
)
void UpdateDimensionsDisplayAccuracy(
    unsigned int dimensionsAccuracy
)

Parameters

dimensionsAccuracy
Type: SystemUInt32
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.WriteLine Method

IApplicationWriteLine Method

Note: This API is now obsolete.

Writes a message to the output console

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("This method is deprecated. Use IMessageService instead",
    false)]
void WriteLine(
    string message
)
[ObsoleteAttribute(L"This method is deprecated. Use IMessageService instead",
    false)]
void WriteLine(
    String^ message
)

Parameters

message
Type: SystemString
Message.
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication Events

The IApplication type exposes the following members.

Events
 | Name | Description
Public event | ActiveWindowChanged | Occurs when ActiveWindow property changes.
Public event | CollisionDetectionActivated | Occurs when collision detection is enabled or disabled.
Public event | ComponentCreated |
Public event | ComponentSaved | Occurs when a Component has been saved.
Public event | ComponentSaving | Occurs when a component is being saved.
Public event | InitializedChanged | Raised after Initialized has changed and ActiveWindow is created.
Public event | IsInitializedChanged | Obsolete.
Public event | LayoutClosed | Occurs when a layout has been closed.
Public event | LayoutClosing | Occurs when a layout is being closed.
Public event | LayoutLoaded | Occurs when a layout has been loaded.
Public event | LayoutLoading | Occurs when a layout is loading.
Public event | LayoutModifiedChanged | Occurs when the value of LayoutModified changes.
Public event | LayoutSaved | Occurs when a layout has been saved.
Public event | LayoutSaving | Occurs when a layout is being saved.
Public event | MainWindowShown | Raised after MainWindowReady has changed and MainWindow is shown at first time.
Public event | PythonCommandIsCheckedChanged | Occurs when python command checked state changes.
Public event | PythonCommandIsEnabledChanged | Occurs when python command enabled state changes.
Top
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.ActiveWindowChanged Event

IApplicationActiveWindowChanged Event

Occurs when ActiveWindow property changes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ActiveWindowChangedEventArgs> ActiveWindowChanged
 event EventHandler<ActiveWindowChangedEventArgs^>^ ActiveWindowChanged {
    void add (EventHandler<ActiveWindowChangedEventArgs^>^ value);
    void remove (EventHandler<ActiveWindowChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerActiveWindowChangedEventArgs
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.CollisionDetectionActivated Event

IApplicationCollisionDetectionActivated Event

Occurs when collision detection is enabled or disabled.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<CollisionDetectionActivatedEventArgs> CollisionDetectionActivated
 event EventHandler<CollisionDetectionActivatedEventArgs^>^ CollisionDetectionActivated {
    void add (EventHandler<CollisionDetectionActivatedEventArgs^>^ value);
    void remove (EventHandler<CollisionDetectionActivatedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerCollisionDetectionActivatedEventArgs
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.ComponentCreated Event

IApplicationComponentCreated Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ComponentCreatedEventArgs> ComponentCreated
 event EventHandler<ComponentCreatedEventArgs^>^ ComponentCreated {
    void add (EventHandler<ComponentCreatedEventArgs^>^ value);
    void remove (EventHandler<ComponentCreatedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerComponentCreatedEventArgs
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.ComponentSaved Event

IApplicationComponentSaved Event

Occurs when a Component has been saved.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ComponentSavedEventArgs> ComponentSaved
 event EventHandler<ComponentSavedEventArgs^>^ ComponentSaved {
    void add (EventHandler<ComponentSavedEventArgs^>^ value);
    void remove (EventHandler<ComponentSavedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerComponentSavedEventArgs
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.ComponentSaving Event

IApplicationComponentSaving Event

Occurs when a component is being saved.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ComponentSavingEventArgs> ComponentSaving
 event EventHandler<ComponentSavingEventArgs^>^ ComponentSaving {
    void add (EventHandler<ComponentSavingEventArgs^>^ value);
    void remove (EventHandler<ComponentSavingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerComponentSavingEventArgs
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.InitializedChanged Event

IApplicationInitializedChanged Event

Raised after Initialized has changed and ActiveWindow is created.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler InitializedChanged
 event EventHandler^ InitializedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.IsInitializedChanged Event

IApplicationIsInitializedChanged Event

Note: This API is now obsolete.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Use InitializedChanged event handler instead.",
    true)]
event EventHandler IsInitializedChanged
[ObsoleteAttribute(L"Use InitializedChanged event handler instead.",
    true)]
 event EventHandler^ IsInitializedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
Remarks
Obsolete code is used for backward compatibility
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.LayoutClosed Event

IApplicationLayoutClosed Event

Occurs when a layout has been closed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<LayoutClosedEventArgs> LayoutClosed
 event EventHandler<LayoutClosedEventArgs^>^ LayoutClosed {
    void add (EventHandler<LayoutClosedEventArgs^>^ value);
    void remove (EventHandler<LayoutClosedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerLayoutClosedEventArgs
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.LayoutClosing Event

IApplicationLayoutClosing Event

Occurs when a layout is being closed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<LayoutClosingEventArgs> LayoutClosing
 event EventHandler<LayoutClosingEventArgs^>^ LayoutClosing {
    void add (EventHandler<LayoutClosingEventArgs^>^ value);
    void remove (EventHandler<LayoutClosingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerLayoutClosingEventArgs
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.LayoutLoaded Event

IApplicationLayoutLoaded Event

Occurs when a layout has been loaded.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<LayoutLoadedEventArgs> LayoutLoaded
 event EventHandler<LayoutLoadedEventArgs^>^ LayoutLoaded {
    void add (EventHandler<LayoutLoadedEventArgs^>^ value);
    void remove (EventHandler<LayoutLoadedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerLayoutLoadedEventArgs
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.LayoutLoading Event

IApplicationLayoutLoading Event

Occurs when a layout is loading.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<LayoutLoadingEventArgs> LayoutLoading
 event EventHandler<LayoutLoadingEventArgs^>^ LayoutLoading {
    void add (EventHandler<LayoutLoadingEventArgs^>^ value);
    void remove (EventHandler<LayoutLoadingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerLayoutLoadingEventArgs
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.LayoutModifiedChanged Event

IApplicationLayoutModifiedChanged Event

Occurs when the value of LayoutModified changes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<LayoutModifiedChangedEventArgs> LayoutModifiedChanged
 event EventHandler<LayoutModifiedChangedEventArgs^>^ LayoutModifiedChanged {
    void add (EventHandler<LayoutModifiedChangedEventArgs^>^ value);
    void remove (EventHandler<LayoutModifiedChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerLayoutModifiedChangedEventArgs
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.LayoutSaved Event

IApplicationLayoutSaved Event

Occurs when a layout has been saved.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<LayoutSavedEventArgs> LayoutSaved
 event EventHandler<LayoutSavedEventArgs^>^ LayoutSaved {
    void add (EventHandler<LayoutSavedEventArgs^>^ value);
    void remove (EventHandler<LayoutSavedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerLayoutSavedEventArgs
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.LayoutSaving Event

IApplicationLayoutSaving Event

Occurs when a layout is being saved.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<LayoutSavingEventArgs> LayoutSaving
 event EventHandler<LayoutSavingEventArgs^>^ LayoutSaving {
    void add (EventHandler<LayoutSavingEventArgs^>^ value);
    void remove (EventHandler<LayoutSavingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerLayoutSavingEventArgs
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.MainWindowShown Event

IApplicationMainWindowShown Event

Raised after MainWindowReady has changed and MainWindow is shown at first time.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler MainWindowShown
 event EventHandler^ MainWindowShown {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.PythonCommandIsCheckedChanged Event

IApplicationPythonCommandIsCheckedChanged Event

Occurs when python command checked state changes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<PythonCommandIsCheckedChangedEventArgs> PythonCommandIsCheckedChanged
 event EventHandler<PythonCommandIsCheckedChangedEventArgs^>^ PythonCommandIsCheckedChanged {
    void add (EventHandler<PythonCommandIsCheckedChangedEventArgs^>^ value);
    void remove (EventHandler<PythonCommandIsCheckedChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerPythonCommandIsCheckedChangedEventArgs
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplication.PythonCommandIsEnabledChanged Event

IApplicationPythonCommandIsEnabledChanged Event

Occurs when python command enabled state changes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<PythonCommandIsEnabledChangedEventArgs> PythonCommandIsEnabledChanged
 event EventHandler<PythonCommandIsEnabledChangedEventArgs^>^ PythonCommandIsEnabledChanged {
    void add (EventHandler<PythonCommandIsEnabledChangedEventArgs^>^ value);
    void remove (EventHandler<PythonCommandIsEnabledChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerPythonCommandIsEnabledChangedEventArgs
See Also

Reference

IApplication Interface
VisualComponents.Create3D Namespace


IApplicationBootstrap Interface

The IApplicationBootstrap is responsible for the application initialization.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IApplicationBootstrap
public interface class IApplicationBootstrap

The IApplicationBootstrap type exposes the following members.

Methods
 | Name | Description
Public method | ConfigureContainer | Initializes the application container.
Public method | InitCore | Initializes the application core.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IApplicationBootstrap Methods

The IApplicationBootstrap type exposes the following members.

Methods
 | Name | Description
Public method | ConfigureContainer | Initializes the application container.
Public method | InitCore | Initializes the application core.
Top
See Also

Reference

IApplicationBootstrap Interface
VisualComponents.Create3D Namespace


IApplicationBootstrap.ConfigureContainer Method

IApplicationBootstrapConfigureContainer Method

Initializes the application container.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ConfigureContainer()
void ConfigureContainer()
See Also

Reference

IApplicationBootstrap Interface
VisualComponents.Create3D Namespace


IApplicationBootstrap.InitCore Method

IApplicationBootstrapInitCore Method

Initializes the application core.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void InitCore(
    IProductConfiguration productConfiguration
)
void InitCore(
    IProductConfiguration^ productConfiguration
)

Parameters

productConfiguration
Type: VisualComponents.Create3DIProductConfiguration
Product configuration. Determines which features are enabled.
See Also

Reference

IApplicationBootstrap Interface
VisualComponents.Create3D Namespace


IApplicationContext Interface

Provides access to the application context.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IApplicationContext
public interface class IApplicationContext

The IApplicationContext type exposes the following members.

Properties
 | Name | Description
Public property | Current | Current application context
Top
Methods
 | Name | Description
Public method | SetContext | Sets the context using context ID.
Top
Events
 | Name | Description
Public event | ContextChanged | Event trigger when current context changes
Top
See Also

Reference

VisualComponents.Create3D Namespace


IApplicationContext Properties

The IApplicationContext type exposes the following members.

Properties
 | Name | Description
Public property | Current | Current application context
Top
See Also

Reference

IApplicationContext Interface
VisualComponents.Create3D Namespace


IApplicationContext.Current Property

IApplicationContextCurrent Property

Current application context

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IContext Current { get; set; }
property IContext^ Current {
    IContext^ get ();
    void set (IContext^ value);
}

Property Value

Type: IContext
See Also

Reference

IApplicationContext Interface
VisualComponents.Create3D Namespace


IApplicationContext Methods

The IApplicationContext type exposes the following members.

Methods
 | Name | Description
Public method | SetContext | Sets the context using context ID.
Top
See Also

Reference

IApplicationContext Interface
VisualComponents.Create3D Namespace


IApplicationContext.SetContext Method

IApplicationContextSetContext Method

Sets the context using context ID.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetContext(
    string contextId
)
void SetContext(
    String^ contextId
)

Parameters

contextId
Type: SystemString
Remarks
All context IDs can be found in Contexts static class
See Also

Reference

IApplicationContext Interface
VisualComponents.Create3D Namespace


IApplicationContext Events

The IApplicationContext type exposes the following members.

Events
 | Name | Description
Public event | ContextChanged | Event trigger when current context changes
Top
See Also

Reference

IApplicationContext Interface
VisualComponents.Create3D Namespace


IApplicationContext.ContextChanged Event

IApplicationContextContextChanged Event

Event trigger when current context changes

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler ContextChanged
 event EventHandler^ ContextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IApplicationContext Interface
VisualComponents.Create3D Namespace


IApplicationSettingService Interface

The service to work with the user's config file settings.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IApplicationSettingService : IAppConfigSettings
public interface class IApplicationSettingService : IAppConfigSettings

The IApplicationSettingService type exposes the following members.

Properties
 | Name | Description
Public property | AppLogFolder | Gets the application logging folder.
Public property | UserConfigFolder | Gets the application user config folder.
Public property | UserSettingConfigurationFile | Obsolete. Represents a user configuration file for the application.
Top
Methods
 | Name | Description
Public method | GetAppValueT(String) | Gets value from the appSettings section (the application config file) (Inherited from IAppConfigSettings.)
Public method | GetAppValueT(String, T) | Gets value from the appSettings section (the application config file). (Inherited from IAppConfigSettings.)
Public method | GetSection(String) | Obsolete. Gets custom configuration section.
Public method | GetSection(String, Configuration) | Obsolete. Gets custom configuration section.
Public method | GetSectionT | Get custom configuration section.
Public method | GetSectionT(Configuration) | Obsolete. Gets custom configuration section.
Public method | GetValueT(String) | Gets value from the appSettings section (the application config file) (Inherited from IAppConfigSettings.)
Public method | GetValueT(String, T) | Gets value from the appSettings section (the application config file) (Inherited from IAppConfigSettings.)
Public method | OnFinalize |
Public method | RefreshSection(ISection) | Saves section changes to the user config file.
Public method | RefreshSection(ISection, Configuration) | Obsolete. Saves section changes to the user config file.
Public method | RefreshSections | Refreshes all user config sections.
Public method | SetAppValueT | Set value to the appSettings section (the application config file) (Inherited from IAppConfigSettings.)
Public method | SetValueT | Set value to the appSettings section (the application config file) (Inherited from IAppConfigSettings.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IApplicationSettingService Properties

The IApplicationSettingService type exposes the following members.

Properties
 | Name | Description
Public property | AppLogFolder | Gets the application logging folder.
Public property | UserConfigFolder | Gets the application user config folder.
Public property | UserSettingConfigurationFile | Obsolete. Represents a user configuration file for the application.
Top
See Also

Reference

IApplicationSettingService Interface
VisualComponents.Create3D Namespace


IApplicationSettingService.AppLogFolder Property

IApplicationSettingServiceAppLogFolder Property

Gets the application logging folder.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string AppLogFolder { get; }
property String^ AppLogFolder {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IApplicationSettingService Interface
VisualComponents.Create3D Namespace


IApplicationSettingService.UserConfigFolder Property

IApplicationSettingServiceUserConfigFolder Property

Gets the application user config folder.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string UserConfigFolder { get; }
property String^ UserConfigFolder {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IApplicationSettingService Interface
VisualComponents.Create3D Namespace


IApplicationSettingService.UserSettingConfigurationFile Property

IApplicationSettingServiceUserSettingConfigurationFile Property

Note: This API is now obsolete.

Represents a user configuration file for the application.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Use GetSection<IMySection>() instead.", false)]
Configuration UserSettingConfigurationFile { get; }
[ObsoleteAttribute(L"Use GetSection<IMySection>() instead.", false)]
property Configuration^ UserSettingConfigurationFile {
    Configuration^ get ();
}

Property Value

Type: Configuration
See Also

Reference

IApplicationSettingService Interface
VisualComponents.Create3D Namespace


IApplicationSettingService Methods

The IApplicationSettingService type exposes the following members.

Methods
 | Name | Description
Public method | GetAppValueT(String) | Gets value from the appSettings section (the application config file) (Inherited from IAppConfigSettings.)
Public method | GetAppValueT(String, T) | Gets value from the appSettings section (the application config file). (Inherited from IAppConfigSettings.)
Public method | GetSection(String) | Obsolete. Gets custom configuration section.
Public method | GetSection(String, Configuration) | Obsolete. Gets custom configuration section.
Public method | GetSectionT | Get custom configuration section.
Public method | GetSectionT(Configuration) | Obsolete. Gets custom configuration section.
Public method | GetValueT(String) | Gets value from the appSettings section (the application config file) (Inherited from IAppConfigSettings.)
Public method | GetValueT(String, T) | Gets value from the appSettings section (the application config file) (Inherited from IAppConfigSettings.)
Public method | OnFinalize |
Public method | RefreshSection(ISection) | Saves section changes to the user config file.
Public method | RefreshSection(ISection, Configuration) | Obsolete. Saves section changes to the user config file.
Public method | RefreshSections | Refreshes all user config sections.
Public method | SetAppValueT | Set value to the appSettings section (the application config file) (Inherited from IAppConfigSettings.)
Public method | SetValueT | Set value to the appSettings section (the application config file) (Inherited from IAppConfigSettings.)
Top
See Also

Reference

IApplicationSettingService Interface
VisualComponents.Create3D Namespace


IApplicationSettingService.GetSection Method

IApplicationSettingServiceGetSection Method

Overload List
 | Name | Description
Public method | GetSectionT | Get custom configuration section.
Public method | GetSectionT(Configuration) | Obsolete. Gets custom configuration section.
Public method | GetSection(String) | Obsolete. Gets custom configuration section.
Public method | GetSection(String, Configuration) | Obsolete. Gets custom configuration section.
Top
See Also

Reference

IApplicationSettingService Interface
VisualComponents.Create3D Namespace


IApplicationSettingService.GetSection(T) Method

IApplicationSettingServiceGetSectionT Method

Get custom configuration section.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
T GetSection<T>()
where T : class

generic<typename T>
where T : ref class
T GetSection()

Type Parameters

T

Return Value

Type: T

[Missing <returns> documentation for "M:VisualComponents.Create3D.IApplicationSettingService.GetSection``1"]

See Also

Reference

IApplicationSettingService Interface
GetSection Overload
VisualComponents.Create3D Namespace


IApplicationSettingService.GetSection(T) Method (Configuration)

IApplicationSettingServiceGetSectionT Method (Configuration)

Note: This API is now obsolete.

Gets custom configuration section.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Use GetSection<IMySection>() instead.", false)]
T GetSection<T>(
    Configuration config
)

[ObsoleteAttribute(L"Use GetSection<IMySection>() instead.", false)]
generic<typename T>
T GetSection(
    Configuration^ config
)

Parameters

config
Type: System.ConfigurationConfiguration

Type Parameters

T
section type

Return Value

Type: T
instance of the section
See Also

Reference

IApplicationSettingService Interface
GetSection Overload
VisualComponents.Create3D Namespace


IApplicationSettingService.GetSection Method (String)

IApplicationSettingServiceGetSection Method (String)

Note: This API is now obsolete.

Gets custom configuration section.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Use GetSection<IMySection>() instead.", false)]
ISection GetSection(
    string sectionName
)
[ObsoleteAttribute(L"Use GetSection<IMySection>() instead.", false)]
ISection^ GetSection(
    String^ sectionName
)

Parameters

sectionName
Type: SystemString
section name

Return Value

Type: ISection
instance of the section
See Also

Reference

IApplicationSettingService Interface
GetSection Overload
VisualComponents.Create3D Namespace


IApplicationSettingService.GetSection Method (String, Configuration)

IApplicationSettingServiceGetSection Method (String, Configuration)

Note: This API is now obsolete.

Gets custom configuration section.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Use GetSection<IMySection>() instead.", false)]
ISection GetSection(
    string sectionName,
    Configuration config
)
[ObsoleteAttribute(L"Use GetSection<IMySection>() instead.", false)]
ISection^ GetSection(
    String^ sectionName,
    Configuration^ config
)

Parameters

sectionName
Type: SystemString
section name
config
Type: System.ConfigurationConfiguration
configuration instance

Return Value

Type: ISection
instance of the section
See Also

Reference

IApplicationSettingService Interface
GetSection Overload
VisualComponents.Create3D Namespace


IApplicationSettingService.OnFinalize Method

IApplicationSettingServiceOnFinalize Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void OnFinalize()
void OnFinalize()
See Also

Reference

IApplicationSettingService Interface
VisualComponents.Create3D Namespace


IApplicationSettingService.RefreshSection Method

IApplicationSettingServiceRefreshSection Method

Overload List
 | Name | Description
Public method | RefreshSection(ISection) | Saves section changes to the user config file.
Public method | RefreshSection(ISection, Configuration) | Obsolete. Saves section changes to the user config file.
Top
See Also

Reference

IApplicationSettingService Interface
VisualComponents.Create3D Namespace


IApplicationSettingService.RefreshSection Method (ISection)

IApplicationSettingServiceRefreshSection Method (ISection)

Saves section changes to the user config file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RefreshSection(
    ISection currentSection
)
void RefreshSection(
    ISection^ currentSection
)

Parameters

currentSection
Type: VisualComponents.Create3DISection
section name
See Also

Reference

IApplicationSettingService Interface
RefreshSection Overload
VisualComponents.Create3D Namespace


IApplicationSettingService.RefreshSection Method (ISection, Configuration)

IApplicationSettingServiceRefreshSection Method (ISection, Configuration)

Note: This API is now obsolete.

Saves section changes to the user config file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Use RefreshSection(currentSection) instead.", false)]
void RefreshSection(
    ISection currentSection,
    Configuration config
)
[ObsoleteAttribute(L"Use RefreshSection(currentSection) instead.", false)]
void RefreshSection(
    ISection^ currentSection,
    Configuration^ config
)

Parameters

currentSection
Type: VisualComponents.Create3DISection
section name
config
Type: System.ConfigurationConfiguration
configuration instance
See Also

Reference

IApplicationSettingService Interface
RefreshSection Overload
VisualComponents.Create3D Namespace


IApplicationSettingService.RefreshSections Method

IApplicationSettingServiceRefreshSections Method

Refreshes all user config sections.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RefreshSections()
void RefreshSections()
See Also

Reference

IApplicationSettingService Interface
VisualComponents.Create3D Namespace


IArticulatedKinematics Interface

An interface for articulated kinematics behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IArticulatedKinematics : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IArticulatedKinematics : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IArticulatedKinematics type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IArticulatedKinematics Properties

The IArticulatedKinematics type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IArticulatedKinematics Interface
VisualComponents.Create3D Namespace


IArticulatedKinematics Methods

The IArticulatedKinematics type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IArticulatedKinematics Interface
VisualComponents.Create3D Namespace


IArticulatedKinematics Events

The IArticulatedKinematics type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IArticulatedKinematics Interface
VisualComponents.Create3D Namespace


IArticulatedKinematics2 Interface

An interface for articulated kinematics 2 behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IArticulatedKinematics2 : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IArticulatedKinematics2 : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IArticulatedKinematics2 type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IArticulatedKinematics2 Properties

The IArticulatedKinematics2 type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IArticulatedKinematics2 Interface
VisualComponents.Create3D Namespace


IArticulatedKinematics2 Methods

The IArticulatedKinematics2 type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IArticulatedKinematics2 Interface
VisualComponents.Create3D Namespace


IArticulatedKinematics2 Events

The IArticulatedKinematics2 type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IArticulatedKinematics2 Interface
VisualComponents.Create3D Namespace


IAttachProductStatement Interface

Attaches child product(s) to a parent product.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IAttachProductStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IAttachProductStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IAttachProductStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildProductVariableName | Gets or sets the name of the variable that holds reference to the child ISimProduct instance.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentProductVariableName | Gets or sets the name of the variable that holds reference to the parent ISimProduct instance.
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IAttachProductStatement Properties

The IAttachProductStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildProductVariableName | Gets or sets the name of the variable that holds reference to the child ISimProduct instance.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentProductVariableName | Gets or sets the name of the variable that holds reference to the parent ISimProduct instance.
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
See Also

Reference

IAttachProductStatement Interface
VisualComponents.Create3D Namespace


IAttachProductStatement.ChildProductVariableName Property

IAttachProductStatementChildProductVariableName Property

Gets or sets the name of the variable that holds reference to the child ISimProduct instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ChildProductVariableName { get; set; }
property String^ ChildProductVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown by setter when supplied value is null.
Remarks
With GetProperty(String) use "Child".
See Also

Reference

IAttachProductStatement Interface
VisualComponents.Create3D Namespace


IAttachProductStatement.ParentProductVariableName Property

IAttachProductStatementParentProductVariableName Property

Gets or sets the name of the variable that holds reference to the parent ISimProduct instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ParentProductVariableName { get; set; }
property String^ ParentProductVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown by setter when supplied value is null.
Remarks
With GetProperty(String) use "Parent".
See Also

Reference

IAttachProductStatement Interface
VisualComponents.Create3D Namespace


IAttachProductStatement Methods

The IAttachProductStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IAttachProductStatement Interface
VisualComponents.Create3D Namespace


IAttachProductStatement Events

The IAttachProductStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IAttachProductStatement Interface
VisualComponents.Create3D Namespace


IAuthorContext Interface

This interface represents the Author context of the application

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IAuthorContext : IContext
public interface class IAuthorContext : IContext

The IAuthorContext type exposes the following members.

Properties
 | Name | Description
Public property | ActiveComponent | Gets or sets the component that is currently selected for authoring. Setting this will clear ActiveFeatures.
Public property | ActiveFeatures | Gets all the active features and the nodes they belong to.
Public property | ActiveFeaturesCount | How many features are selected in total, in all nodes.
Public property | ActiveNode | Gets or sets the active node that is currently selected for authoring. If multiple nodes are selected returns the first one.
Public property | ActiveNodeFeatures | Gets all features selected in ActiveNode.
Public property | Id | Context ID. Possible values can be found in Contexts static class. (Inherited from IContext.)
Public property | IsActive | Determine if the context is active, hence, the current application context. (Inherited from IContext.)
Public property | SupportedManipulationModes | Gets the list of manipulation modes that are allowed in this context. (Inherited from IContext.)
Top
Methods
 | Name | Description
Public method | Activate | Activates the context making it this application context. (Inherited from IContext.)
Public method | Deactivate | Deactivates this context. (Inherited from IContext.)
Public method | SetActiveFeature | Sets the active feature for authoring.
Public method | SetActiveFeatures(IEnumerableIFeature, Boolean) | Deprecated. Used only by python scripts.
Public method | SetActiveFeatures(IEnumerableNodeFeatureList, Boolean) | Sets the active features for authoring.
Public method | SetActiveFeatures(IEnumerableIFeature, ISimNode, Boolean) | Sets the active features for authoring.
Public method | SetActiveFeatures(IEnumerableNodeFeatureList, Boolean, Boolean) | Sets the active features for authoring.
Public method | SetActiveNodes | Sets the active nodes for authoring
Top
Events
 | Name | Description
Public event | ActiveComponentChanged | Occurs when active component is changed.
Public event | ActiveFeaturesChanged | Occurs when active features are changed.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IAuthorContext Properties

The IAuthorContext type exposes the following members.

Properties
 | Name | Description
Public property | ActiveComponent | Gets or sets the component that is currently selected for authoring. Setting this will clear ActiveFeatures.
Public property | ActiveFeatures | Gets all the active features and the nodes they belong to.
Public property | ActiveFeaturesCount | How many features are selected in total, in all nodes.
Public property | ActiveNode | Gets or sets the active node that is currently selected for authoring. If multiple nodes are selected returns the first one.
Public property | ActiveNodeFeatures | Gets all features selected in ActiveNode.
Public property | Id | Context ID. Possible values can be found in Contexts static class. (Inherited from IContext.)
Public property | IsActive | Determine if the context is active, hence, the current application context. (Inherited from IContext.)
Public property | SupportedManipulationModes | Gets the list of manipulation modes that are allowed in this context. (Inherited from IContext.)
Top
See Also

Reference

IAuthorContext Interface
VisualComponents.Create3D Namespace


IAuthorContext.ActiveComponent Property

IAuthorContextActiveComponent Property

Gets or sets the component that is currently selected for authoring. Setting this will clear ActiveFeatures.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent ActiveComponent { get; set; }
property ISimComponent^ ActiveComponent {
    ISimComponent^ get ();
    void set (ISimComponent^ value);
}

Property Value

Type: ISimComponent
See Also

Reference

IAuthorContext Interface
VisualComponents.Create3D Namespace


IAuthorContext.ActiveFeatures Property

IAuthorContextActiveFeatures Property

Gets all the active features and the nodes they belong to.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<NodeFeatureList> ActiveFeatures { get; }
property ReadOnlyCollection<NodeFeatureList^>^ ActiveFeatures {
    ReadOnlyCollection<NodeFeatureList^>^ get ();
}

Property Value

Type: ReadOnlyCollectionNodeFeatureList
See Also

Reference

IAuthorContext Interface
VisualComponents.Create3D Namespace


IAuthorContext.ActiveFeaturesCount Property

IAuthorContextActiveFeaturesCount Property

How many features are selected in total, in all nodes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int ActiveFeaturesCount { get; }
property int ActiveFeaturesCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IAuthorContext Interface
VisualComponents.Create3D Namespace


IAuthorContext.ActiveNode Property

IAuthorContextActiveNode Property

Gets or sets the active node that is currently selected for authoring. If multiple nodes are selected returns the first one.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode ActiveNode { get; set; }
property ISimNode^ ActiveNode {
    ISimNode^ get ();
    void set (ISimNode^ value);
}

Property Value

Type: ISimNode
See Also

Reference

IAuthorContext Interface
VisualComponents.Create3D Namespace


IAuthorContext.ActiveNodeFeatures Property

IAuthorContextActiveNodeFeatures Property

Gets all features selected in ActiveNode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IFeature> ActiveNodeFeatures { get; }
property ReadOnlyCollection<IFeature^>^ ActiveNodeFeatures {
    ReadOnlyCollection<IFeature^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIFeature
See Also

Reference

IAuthorContext Interface
VisualComponents.Create3D Namespace


IAuthorContext Methods

The IAuthorContext type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the context making it this application context. (Inherited from IContext.)
Public method | Deactivate | Deactivates this context. (Inherited from IContext.)
Public method | SetActiveFeature | Sets the active feature for authoring.
Public method | SetActiveFeatures(IEnumerableIFeature, Boolean) | Deprecated. Used only by python scripts.
Public method | SetActiveFeatures(IEnumerableNodeFeatureList, Boolean) | Sets the active features for authoring.
Public method | SetActiveFeatures(IEnumerableIFeature, ISimNode, Boolean) | Sets the active features for authoring.
Public method | SetActiveFeatures(IEnumerableNodeFeatureList, Boolean, Boolean) | Sets the active features for authoring.
Public method | SetActiveNodes | Sets the active nodes for authoring
Top
See Also

Reference

IAuthorContext Interface
VisualComponents.Create3D Namespace


IAuthorContext.SetActiveFeature Method

IAuthorContextSetActiveFeature Method

Sets the active feature for authoring.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetActiveFeature(
    IFeature activeFeature,
    ISimNode activeNode,
    bool append
)
void SetActiveFeature(
    IFeature^ activeFeature,
    ISimNode^ activeNode,
    bool append
)

Parameters

activeFeature
Type: VisualComponents.Create3DIFeature
Feature to be set for authoring.
activeNode
Type: VisualComponents.Create3DISimNode
Node associated to the feature.
append
Type: SystemBoolean
If false, clears the current active features.
See Also

Reference

IAuthorContext Interface
VisualComponents.Create3D Namespace


IAuthorContext.SetActiveFeatures Method

IAuthorContextSetActiveFeatures Method

Overload List
 | Name | Description
Public method | SetActiveFeatures(IEnumerableIFeature, Boolean) | Deprecated. Used only by python scripts.
Public method | SetActiveFeatures(IEnumerableNodeFeatureList, Boolean) | Sets the active features for authoring.
Public method | SetActiveFeatures(IEnumerableIFeature, ISimNode, Boolean) | Sets the active features for authoring.
Public method | SetActiveFeatures(IEnumerableNodeFeatureList, Boolean, Boolean) | Sets the active features for authoring.
Top
See Also

Reference

IAuthorContext Interface
VisualComponents.Create3D Namespace


IAuthorContext.SetActiveFeatures Method (IEnumerable(IFeature), Boolean)

IAuthorContextSetActiveFeatures Method (IEnumerableIFeature, Boolean)

Deprecated. Used only by python scripts.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetActiveFeatures(
    IEnumerable<IFeature> activeFeatures,
    bool append
)
void SetActiveFeatures(
    IEnumerable<IFeature^>^ activeFeatures,
    bool append
)

Parameters

activeFeatures
Type: System.Collections.GenericIEnumerableIFeature
append
Type: SystemBoolean
See Also

Reference

IAuthorContext Interface
SetActiveFeatures Overload
VisualComponents.Create3D Namespace


IAuthorContext.SetActiveFeatures Method (IEnumerable(NodeFeatureList), Boolean)

IAuthorContextSetActiveFeatures Method (IEnumerableNodeFeatureList, Boolean)

Sets the active features for authoring.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetActiveFeatures(
    IEnumerable<NodeFeatureList> activeFeatures,
    bool append
)
void SetActiveFeatures(
    IEnumerable<NodeFeatureList^>^ activeFeatures,
    bool append
)

Parameters

activeFeatures
Type: System.Collections.GenericIEnumerableNodeFeatureList
Features to be set for authoring.
append
Type: SystemBoolean
If false, clears the current active features.
See Also

Reference

IAuthorContext Interface
SetActiveFeatures Overload
VisualComponents.Create3D Namespace


IAuthorContext.SetActiveFeatures Method (IEnumerable(IFeature), ISimNode, Boolean)

IAuthorContextSetActiveFeatures Method (IEnumerableIFeature, ISimNode, Boolean)

Sets the active features for authoring.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetActiveFeatures(
    IEnumerable<IFeature> activeFeatures,
    ISimNode activeNode,
    bool append
)
void SetActiveFeatures(
    IEnumerable<IFeature^>^ activeFeatures,
    ISimNode^ activeNode,
    bool append
)

Parameters

activeFeatures
Type: System.Collections.GenericIEnumerableIFeature
Sets the active features for authoring.
activeNode
Type: VisualComponents.Create3DISimNode
Node associated to the features.
append
Type: SystemBoolean
If false, clears the current active features.
See Also

Reference

IAuthorContext Interface
SetActiveFeatures Overload
VisualComponents.Create3D Namespace


IAuthorContext.SetActiveFeatures Method (IEnumerable(NodeFeatureList), Boolean, Boolean)

IAuthorContextSetActiveFeatures Method (IEnumerableNodeFeatureList, Boolean, Boolean)

Sets the active features for authoring.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetActiveFeatures(
    IEnumerable<NodeFeatureList> activeFeatures,
    bool append,
    bool removeDuplicates
)
void SetActiveFeatures(
    IEnumerable<NodeFeatureList^>^ activeFeatures,
    bool append,
    bool removeDuplicates
)

Parameters

activeFeatures
Type: System.Collections.GenericIEnumerableNodeFeatureList
Features to be set for authoring.
append
Type: SystemBoolean
If false, clears the current active features.
removeDuplicates
Type: SystemBoolean
If true, already selected features will be removed from selection
See Also

Reference

IAuthorContext Interface
SetActiveFeatures Overload
VisualComponents.Create3D Namespace


IAuthorContext.SetActiveNodes Method

IAuthorContextSetActiveNodes Method

Sets the active nodes for authoring

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetActiveNodes(
    IEnumerable<ISimNode> activeNodes
)
void SetActiveNodes(
    IEnumerable<ISimNode^>^ activeNodes
)

Parameters

activeNodes
Type: System.Collections.GenericIEnumerableISimNode
See Also

Reference

IAuthorContext Interface
VisualComponents.Create3D Namespace


IAuthorContext Events

The IAuthorContext type exposes the following members.

Events
 | Name | Description
Public event | ActiveComponentChanged | Occurs when active component is changed.
Public event | ActiveFeaturesChanged | Occurs when active features are changed.
Top
See Also

Reference

IAuthorContext Interface
VisualComponents.Create3D Namespace


IAuthorContext.ActiveComponentChanged Event

IAuthorContextActiveComponentChanged Event

Occurs when active component is changed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ActiveComponentChangedEventArgs> ActiveComponentChanged
 event EventHandler<ActiveComponentChangedEventArgs^>^ ActiveComponentChanged {
    void add (EventHandler<ActiveComponentChangedEventArgs^>^ value);
    void remove (EventHandler<ActiveComponentChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerActiveComponentChangedEventArgs
See Also

Reference

IAuthorContext Interface
VisualComponents.Create3D Namespace


IAuthorContext.ActiveFeaturesChanged Event

IAuthorContextActiveFeaturesChanged Event

Occurs when active features are changed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler ActiveFeaturesChanged
 event EventHandler^ ActiveFeaturesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IAuthorContext Interface
VisualComponents.Create3D Namespace


IAuthoringService Interface

Helper functions for modeling tab.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IAuthoringService
public interface class IAuthoringService

The IAuthoringService type exposes the following members.

Methods
 | Name | Description
Public method | AcceptSimplifiedPreview | Constructs final features from simplified geometries.
Public method | ClearSimplifiedPreviews | Deletes temporary ITriangleSet used for showing simplified geometries.
Public method | CreateSimplifiedPreview | Generates cubes or cylinders based on a given geometry. Generated geometry is stored to a temporary geometry set: mainComponent.RootNode.Geometry.CreateGeometrySet(GeometrySetType.TriangleSet)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IAuthoringService Methods

The IAuthoringService type exposes the following members.

Methods
 | Name | Description
Public method | AcceptSimplifiedPreview | Constructs final features from simplified geometries.
Public method | ClearSimplifiedPreviews | Deletes temporary ITriangleSet used for showing simplified geometries.
Public method | CreateSimplifiedPreview | Generates cubes or cylinders based on a given geometry. Generated geometry is stored to a temporary geometry set: mainComponent.RootNode.Geometry.CreateGeometrySet(GeometrySetType.TriangleSet)
Top
See Also

Reference

IAuthoringService Interface
VisualComponents.Create3D Namespace


IAuthoringService.AcceptSimplifiedPreview Method

IAuthoringServiceAcceptSimplifiedPreview Method

Constructs final features from simplified geometries.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFeature AcceptSimplifiedPreview(
    ISimComponent mainComponent,
    IFeature feat,
    SimplifiedGeometryType geometryType,
    bool byCollapsing,
    IList<ITriangleSet> previewGeometries,
    IList<IGeometrySet> geometries,
    IList<IMaterial> sourceMaterials,
    double customScale
)
IFeature^ AcceptSimplifiedPreview(
    ISimComponent^ mainComponent,
    IFeature^ feat,
    SimplifiedGeometryType geometryType,
    bool byCollapsing,
    IList<ITriangleSet^>^ previewGeometries,
    IList<IGeometrySet^>^ geometries,
    IList<IMaterial^>^ sourceMaterials,
    double customScale
)

Parameters

mainComponent
Type: VisualComponents.Create3DISimComponent
feat
Type: VisualComponents.Create3DIFeature
geometryType
Type: VisualComponents.Create3DSimplifiedGeometryType
byCollapsing
Type: SystemBoolean
previewGeometries
Type: System.Collections.GenericIListITriangleSet
geometries
Type: System.Collections.GenericIListIGeometrySet
sourceMaterials
Type: System.Collections.GenericIListIMaterial
customScale
Type: SystemDouble

Return Value

Type: IFeature

[Missing <returns> documentation for "M:VisualComponents.Create3D.IAuthoringService.AcceptSimplifiedPreview(VisualComponents.Create3D.ISimComponent,VisualComponents.Create3D.IFeature,VisualComponents.Create3D.SimplifiedGeometryType,System.Boolean,System.Collections.Generic.IList{VisualComponents.Create3D.ITriangleSet},System.Collections.Generic.IList{VisualComponents.Create3D.IGeometrySet},System.Collections.Generic.IList{VisualComponents.Create3D.IMaterial},System.Double)"]

See Also

Reference

IAuthoringService Interface
VisualComponents.Create3D Namespace


IAuthoringService.ClearSimplifiedPreviews Method

IAuthoringServiceClearSimplifiedPreviews Method

Deletes temporary ITriangleSet used for showing simplified geometries.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ClearSimplifiedPreviews(
    IList<IFeature> features,
    IList<IList<IGeometrySet>> geometries,
    IList<bool> needsCollapsing,
    IList<IList<ITriangleSet>> previewGeometries,
    bool final
)
void ClearSimplifiedPreviews(
    IList<IFeature^>^ features,
    IList<IList<IGeometrySet^>^>^ geometries,
    IList<bool>^ needsCollapsing,
    IList<IList<ITriangleSet^>^>^ previewGeometries,
    bool final
)

Parameters

features
Type: System.Collections.GenericIListIFeature
geometries
Type: System.Collections.GenericIListIListIGeometrySet
needsCollapsing
Type: System.Collections.GenericIListBoolean
previewGeometries
Type: System.Collections.GenericIListIListITriangleSet
final
Type: SystemBoolean
See Also

Reference

IAuthoringService Interface
VisualComponents.Create3D Namespace


IAuthoringService.CreateSimplifiedPreview Method

IAuthoringServiceCreateSimplifiedPreview Method

Generates cubes or cylinders based on a given geometry. Generated geometry is stored to a temporary geometry set: mainComponent.RootNode.Geometry.CreateGeometrySet(GeometrySetType.TriangleSet)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void CreateSimplifiedPreview(
    ISimComponent mainComponent,
    IFeature feature,
    IList<IGeometrySet> geometries,
    SimplifiedGeometryType geometryType,
    bool needsCollapsing,
    bool oneMesh,
    bool showOriginals,
    IList<ITriangleSet> previewGeometries,
    IList<IMaterial> sourceMaterials,
    double customScale
)
void CreateSimplifiedPreview(
    ISimComponent^ mainComponent,
    IFeature^ feature,
    IList<IGeometrySet^>^ geometries,
    SimplifiedGeometryType geometryType,
    bool needsCollapsing,
    bool oneMesh,
    bool showOriginals,
    IList<ITriangleSet^>^ previewGeometries,
    IList<IMaterial^>^ sourceMaterials,
    double customScale
)

Parameters

mainComponent
Type: VisualComponents.Create3DISimComponent
feature
Type: VisualComponents.Create3DIFeature
geometries
Type: System.Collections.GenericIListIGeometrySet
geometryType
Type: VisualComponents.Create3DSimplifiedGeometryType
needsCollapsing
Type: SystemBoolean
oneMesh
Type: SystemBoolean
showOriginals
Type: SystemBoolean
previewGeometries
Type: System.Collections.GenericIListITriangleSet
sourceMaterials
Type: System.Collections.GenericIListIMaterial
customScale
Type: SystemDouble
See Also

Reference

IAuthoringService Interface
VisualComponents.Create3D Namespace


IAutoPlugPlayService Interface

Auto plug and play service interface can be used for automatically connecting two components

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IAutoPlugPlayService
public interface class IAutoPlugPlayService

The IAutoPlugPlayService type exposes the following members.

Properties
 | Name | Description
Public property | FlowDirection | Gets or sets the allowed flow direction when connecting interfaces defining material flow
Public property | IsParentToChildHierarchyAllowed | Defines if parent to child connections are allowed when connecting interfaces defining hierarchy
Public property | ResolveParentToChildHierarchyConflicts | When parent to childd connections allowed, in case of multiple matches this will allow connection to the first match.
Public property | UpdatePosition | Defines if the position of the connected component will be updated
Top
Methods
 | Name | Description
Public method | AutoConnect | Tries to auto connect the given components
Top
See Also

Reference

VisualComponents.Create3D Namespace


IAutoPlugPlayService Properties

The IAutoPlugPlayService type exposes the following members.

Properties
 | Name | Description
Public property | FlowDirection | Gets or sets the allowed flow direction when connecting interfaces defining material flow
Public property | IsParentToChildHierarchyAllowed | Defines if parent to child connections are allowed when connecting interfaces defining hierarchy
Public property | ResolveParentToChildHierarchyConflicts | When parent to childd connections allowed, in case of multiple matches this will allow connection to the first match.
Public property | UpdatePosition | Defines if the position of the connected component will be updated
Top
See Also

Reference

IAutoPlugPlayService Interface
VisualComponents.Create3D Namespace


IAutoPlugPlayService.FlowDirection Property

IAutoPlugPlayServiceFlowDirection Property

Gets or sets the allowed flow direction when connecting interfaces defining material flow

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
AutoPlugFlowDirection FlowDirection { get; set; }
property AutoPlugFlowDirection FlowDirection {
    AutoPlugFlowDirection get ();
    void set (AutoPlugFlowDirection value);
}

Property Value

Type: AutoPlugFlowDirection
See Also

Reference

IAutoPlugPlayService Interface
VisualComponents.Create3D Namespace


IAutoPlugPlayService.IsParentToChildHierarchyAllowed Property

IAutoPlugPlayServiceIsParentToChildHierarchyAllowed Property

Defines if parent to child connections are allowed when connecting interfaces defining hierarchy

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsParentToChildHierarchyAllowed { get; set; }
property bool IsParentToChildHierarchyAllowed {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IAutoPlugPlayService Interface
VisualComponents.Create3D Namespace


IAutoPlugPlayService.ResolveParentToChildHierarchyConflicts Property

IAutoPlugPlayServiceResolveParentToChildHierarchyConflicts Property

When parent to childd connections allowed, in case of multiple matches this will allow connection to the first match.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ResolveParentToChildHierarchyConflicts { get; set; }
property bool ResolveParentToChildHierarchyConflicts {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IAutoPlugPlayService Interface
VisualComponents.Create3D Namespace


IAutoPlugPlayService.UpdatePosition Property

IAutoPlugPlayServiceUpdatePosition Property

Defines if the position of the connected component will be updated

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool UpdatePosition { get; set; }
property bool UpdatePosition {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IAutoPlugPlayService Interface
VisualComponents.Create3D Namespace


IAutoPlugPlayService Methods

The IAutoPlugPlayService type exposes the following members.

Methods
 | Name | Description
Public method | AutoConnect | Tries to auto connect the given components
Top
See Also

Reference

IAutoPlugPlayService Interface
VisualComponents.Create3D Namespace


IAutoPlugPlayService.AutoConnect Method

IAutoPlugPlayServiceAutoConnect Method

Tries to auto connect the given components

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Tuple<ISimInterface, ISimInterface> AutoConnect(
    ISimComponent component1,
    ISimComponent component2
)
Tuple<ISimInterface^, ISimInterface^>^ AutoConnect(
    ISimComponent^ component1,
    ISimComponent^ component2
)

Parameters

component1
Type: VisualComponents.Create3DISimComponent
Component that will be connected to component2
component2
Type: VisualComponents.Create3DISimComponent
Component to which the component1 is connected to

Return Value

Type: TupleISimInterface, ISimInterface
Tuple containing the connected interfaces, null if no matching interfaces were found or the match was not unambiguous
See Also

Reference

IAutoPlugPlayService Interface
VisualComponents.Create3D Namespace


IBaseContainer Interface

Data container for base IRobotFrame instances.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IBaseContainer : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IBaseContainer : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IBaseContainer type exposes the following members.

Properties
 | Name | Description
Public property | Bases | Gets the bases as a list of IRobotFrame instances.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateBase(String) | Creates and returns a new base IRobotFrame instance.
Public method | CreateBase(String, Boolean) | Creates and returns a new IRobotFrame instance.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteBase | Deletes the given IRobotFrame instance.
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IBaseContainer Properties

The IBaseContainer type exposes the following members.

Properties
 | Name | Description
Public property | Bases | Gets the bases as a list of IRobotFrame instances.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IBaseContainer Interface
VisualComponents.Create3D Namespace


IBaseContainer.Bases Property

IBaseContainerBases Property

Gets the bases as a list of IRobotFrame instances.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IRobotFrame> Bases { get; }
property IList<IRobotFrame^>^ Bases {
    IList<IRobotFrame^>^ get ();
}

Property Value

Type: IListIRobotFrame
See Also

Reference

IBaseContainer Interface
VisualComponents.Create3D Namespace


IBaseContainer Methods

The IBaseContainer type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateBase(String) | Creates and returns a new base IRobotFrame instance.
Public method | CreateBase(String, Boolean) | Creates and returns a new IRobotFrame instance.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteBase | Deletes the given IRobotFrame instance.
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IBaseContainer Interface
VisualComponents.Create3D Namespace


IBaseContainer.CreateBase Method

IBaseContainerCreateBase Method

Overload List
 | Name | Description
Public method | CreateBase(String) | Creates and returns a new base IRobotFrame instance.
Public method | CreateBase(String, Boolean) | Creates and returns a new IRobotFrame instance.
Top
See Also

Reference

IBaseContainer Interface
VisualComponents.Create3D Namespace


IBaseContainer.CreateBase Method (String)

IBaseContainerCreateBase Method (String)

Creates and returns a new base IRobotFrame instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotFrame CreateBase(
    string name
)
IRobotFrame^ CreateBase(
    String^ name
)

Parameters

name
Type: SystemString
Name of the base to be created.

Return Value

Type: IRobotFrame
Created base frame.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when name parameter is null.
ArgumentException | Thrown when a base with the given name exists already.
See Also

Reference

IBaseContainer Interface
CreateBase Overload
VisualComponents.Create3D Namespace


IBaseContainer.CreateBase Method (String, Boolean)

IBaseContainerCreateBase Method (String, Boolean)

Creates and returns a new IRobotFrame instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotFrame CreateBase(
    string name,
    bool renameIfExists
)
IRobotFrame^ CreateBase(
    String^ name,
    bool renameIfExists
)

Parameters

name
Type: SystemString
Name of the base to be created.
renameIfExists
Type: SystemBoolean
Defines if the base to be created is automatically renamed if a base with the given name exists already.

Return Value

Type: IRobotFrame
Created base frame.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when name parameter is null.
See Also

Reference

IBaseContainer Interface
CreateBase Overload
VisualComponents.Create3D Namespace


IBaseContainer.DeleteBase Method

IBaseContainerDeleteBase Method

Deletes the given IRobotFrame instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteBase(
    IRobotFrame baseFrame
)
void DeleteBase(
    IRobotFrame^ baseFrame
)

Parameters

baseFrame
Type: VisualComponents.Create3DIRobotFrame
Base frame to be deleted.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when baseFrame parameter is null.
See Also

Reference

IBaseContainer Interface
VisualComponents.Create3D Namespace


IBaseContainer Events

The IBaseContainer type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IBaseContainer Interface
VisualComponents.Create3D Namespace


IBatchModeObject Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IBatchModeObject
public interface class IBatchModeObject

The IBatchModeObject type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch().
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended.
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IBatchModeObject Properties

The IBatchModeObject type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch().
Top
See Also

Reference

IBatchModeObject Interface
VisualComponents.Create3D Namespace


IBatchModeObject.ChangeBatchLevel Property

IBatchModeObjectChangeBatchLevel Property

Number of times BeginChangeBatch() has been called without calling EndChangeBatch().

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int ChangeBatchLevel { get; }
property int ChangeBatchLevel {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IBatchModeObject Interface
VisualComponents.Create3D Namespace


IBatchModeObject Methods

The IBatchModeObject type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended.
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events.
Top
See Also

Reference

IBatchModeObject Interface
VisualComponents.Create3D Namespace


IBatchModeObject.BeginChangeBatch Method

IBatchModeObjectBeginChangeBatch Method

Begin a change batch during which change notification events are suspended.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void BeginChangeBatch()
void BeginChangeBatch()
Remarks
To resume change notification events, EndChangeBatch() must be called as many times as BeginChangeBatch() has been called.
See Also

Reference

IBatchModeObject Interface
VisualComponents.Create3D Namespace


IBatchModeObject.EndChangeBatch Method

IBatchModeObjectEndChangeBatch Method

End a previously begun change batch, and trigger any notification events.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void EndChangeBatch()
void EndChangeBatch()
See Also

Reference

IBatchModeObject Interface
VisualComponents.Create3D Namespace


IBehavior Interface

An interface for behavior objects.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IBehavior : IPropertyContainer,
    IBatchModeObject, IVisitable, IWrapper, IDisposable, INamed
public interface class IBehavior : IPropertyContainer,
    IBatchModeObject, IVisitable, IWrapper, IDisposable, INamed

The IBehavior type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance.
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated.
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IBehavior Properties

The IBehavior type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance.
Top
See Also

Reference

IBehavior Interface
VisualComponents.Create3D Namespace


IBehavior.Node Property

IBehaviorNode Property

Get the ISimNode instance that owns this IBehavior instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode Node { get; }
property ISimNode^ Node {
    ISimNode^ get ();
}

Property Value

Type: ISimNode
See Also

Reference

IBehavior Interface
VisualComponents.Create3D Namespace


IBehavior.Type Property

IBehaviorType Property

Gets the type of this IBehavior instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
BehaviorType Type { get; }
property BehaviorType Type {
    BehaviorType get ();
}

Property Value

Type: BehaviorType
See Also

Reference

IBehavior Interface
VisualComponents.Create3D Namespace


IBehavior Methods

The IBehavior type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated.
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IBehavior Interface
VisualComponents.Create3D Namespace


IBehavior.ChangeNode Method

IBehaviorChangeNode Method

Changes the ISimNode container of this IBehavior instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ChangeNode(
    ISimNode newNode,
    IBehavior insertPosition,
    bool after
)
bool ChangeNode(
    ISimNode^ newNode,
    IBehavior^ insertPosition,
    bool after
)

Parameters

newNode
Type: VisualComponents.Create3DISimNode
insertPosition
Type: VisualComponents.Create3DIBehavior
after
Type: SystemBoolean

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IBehavior.ChangeNode(VisualComponents.Create3D.ISimNode,VisualComponents.Create3D.IBehavior,System.Boolean)"]

See Also

Reference

IBehavior Interface
VisualComponents.Create3D Namespace


IBehavior.Destroy Method

IBehaviorDestroy Method

Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Destroy()
void Destroy()
See Also

Reference

IBehavior Interface
VisualComponents.Create3D Namespace


IBehavior.Evaluate Method

IBehaviorEvaluate Method

Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Evaluate()
void Evaluate()
See Also

Reference

IBehavior Interface
VisualComponents.Create3D Namespace


IBehavior Events

The IBehavior type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IBehavior Interface
VisualComponents.Create3D Namespace


IBitmapProperty Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IBitmapProperty : IProperty,
    INotifyPropertyChanged, IDisposable, INamed
public interface class IBitmapProperty : IProperty,
    INotifyPropertyChanged, IDisposable, INamed

The IBitmapProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Allowed maximum value for the property. (Inherited from IProperty.)
Public property | AllowedMinimum | Allowed minimum value for the property. (Inherited from IProperty.)
Public property | AllowedValues | Collection of allowed values for constrained properties. (Inherited from IProperty.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Property value as an object. (Inherited from IProperty.)
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | SetFromPath |
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IBitmapProperty Properties

The IBitmapProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Allowed maximum value for the property. (Inherited from IProperty.)
Public property | AllowedMinimum | Allowed minimum value for the property. (Inherited from IProperty.)
Public property | AllowedValues | Collection of allowed values for constrained properties. (Inherited from IProperty.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Property value as an object. (Inherited from IProperty.)
Top
See Also

Reference

IBitmapProperty Interface
VisualComponents.Create3D Namespace


IBitmapProperty Methods

The IBitmapProperty type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | SetFromPath |
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

IBitmapProperty Interface
VisualComponents.Create3D Namespace


IBitmapProperty.SetFromPath Method

IBitmapPropertySetFromPath Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetFromPath(
    string path
)
void SetFromPath(
    String^ path
)

Parameters

path
Type: SystemString
See Also

Reference

IBitmapProperty Interface
VisualComponents.Create3D Namespace


IBitmapProperty Events

The IBitmapProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IBitmapProperty Interface
VisualComponents.Create3D Namespace


IBlockFeature Interface

Block feature interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IBlockFeature : IPrimitiveFeature,
    IFeature, IVisualObject, INamed, IWrapper, IDisposable,
    IVisitable, IPropertyContainer, IBatchModeObject, ISharedCloneable
public interface class IBlockFeature : IPrimitiveFeature,
    IFeature, IVisualObject, INamed, IWrapper, IDisposable,
    IVisitable, IPropertyContainer, IBatchModeObject, ISharedCloneable

The IBlockFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
The Block geometry primitive produces an axis-aligned cuboid with the specified dimensions.
See Also

Reference

VisualComponents.Create3D Namespace


IBlockFeature Properties

The IBlockFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
See Also

Reference

IBlockFeature Interface
VisualComponents.Create3D Namespace


IBlockFeature Methods

The IBlockFeature type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IBlockFeature Interface
VisualComponents.Create3D Namespace


IBlockFeature Events

The IBlockFeature type exposes the following members.

Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

IBlockFeature Interface
VisualComponents.Create3D Namespace


IBooleanFeature Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IBooleanFeature : IFeature,
    IVisualObject, INamed, IWrapper, IDisposable, IVisitable,
    IPropertyContainer, IBatchModeObject, ISharedCloneable
public interface class IBooleanFeature : IFeature,
    IVisualObject, INamed, IWrapper, IDisposable, IVisitable,
    IPropertyContainer, IBatchModeObject, ISharedCloneable

The IBooleanFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IBooleanFeature Properties

The IBooleanFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
See Also

Reference

IBooleanFeature Interface
VisualComponents.Create3D Namespace


IBooleanFeature Methods

The IBooleanFeature type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IBooleanFeature Interface
VisualComponents.Create3D Namespace


IBooleanFeature Events

The IBooleanFeature type exposes the following members.

Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

IBooleanFeature Interface
VisualComponents.Create3D Namespace


IBooleanPropertyCreator Interface

Property creation behavior used to create and modify boolean property values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IBooleanPropertyCreator : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IBooleanPropertyCreator : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IBooleanPropertyCreator type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace
VisualComponents.Create3DIStringPropertyCreator
VisualComponents.Create3DIIntegerPropertyCreator
VisualComponents.Create3DISimDoubleVariableCreator


IBooleanPropertyCreator Properties

The IBooleanPropertyCreator type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IBooleanPropertyCreator Interface
VisualComponents.Create3D Namespace


IBooleanPropertyCreator Methods

The IBooleanPropertyCreator type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IBooleanPropertyCreator Interface
VisualComponents.Create3D Namespace


IBooleanPropertyCreator Events

The IBooleanPropertyCreator type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IBooleanPropertyCreator Interface
VisualComponents.Create3D Namespace


IBooleanSignal Interface

An interface for boolean signal behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IBooleanSignal : ISignal,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed
public interface class IBooleanSignal : ISignal,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed

The IBooleanSignal type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsApplication | Defines if this ISignal instance has been created by the application for its internal use. (Inherited from ISignal.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Public property | Value | Gets or sets the value of this ISignal instance. (Inherited from ISignal.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanConnectTo | Defines if this ISignal instance can be connected to the given signal. (Inherited from ISignal.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect | Connects the given ISignal instance to the given signal. (Inherited from ISignal.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects this ISignal instance from the given signal. (Inherited from ISignal.)
Public method | DisconnectAll | Disconnects all ISignal instances connected to this signal. (Inherited from ISignal.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | SignalTrigger | Event that is raised when the value of this ISignal instance is changing. (Inherited from ISignal.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IBooleanSignal Properties

The IBooleanSignal type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsApplication | Defines if this ISignal instance has been created by the application for its internal use. (Inherited from ISignal.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Public property | Value | Gets or sets the value of this ISignal instance. (Inherited from ISignal.)
Top
See Also

Reference

IBooleanSignal Interface
VisualComponents.Create3D Namespace


IBooleanSignal Methods

The IBooleanSignal type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanConnectTo | Defines if this ISignal instance can be connected to the given signal. (Inherited from ISignal.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect | Connects the given ISignal instance to the given signal. (Inherited from ISignal.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects this ISignal instance from the given signal. (Inherited from ISignal.)
Public method | DisconnectAll | Disconnects all ISignal instances connected to this signal. (Inherited from ISignal.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IBooleanSignal Interface
VisualComponents.Create3D Namespace


IBooleanSignal Events

The IBooleanSignal type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | SignalTrigger | Event that is raised when the value of this ISignal instance is changing. (Inherited from ISignal.)
Top
See Also

Reference

IBooleanSignal Interface
VisualComponents.Create3D Namespace


IBooleanSignalMap Interface

An interface for boolean signal map behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IBooleanSignalMap : ISignalMap,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed
public interface class IBooleanSignalMap : ISignalMap,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed

The IBooleanSignalMap type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConnectedExternalPorts | Returns all the connected external ports. The return value is a collection of tuples where the first item is the internal port number number and the second item is a port number in connected external map. (Inherited from ISignalMap.)
Public property | ConnectedExternalSignals | Returns all the connected signals in external components. The return value is a collection of tuples where the first item is the internal port number number and the second item is an external signal connected to the port. (Inherited from ISignalMap.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | MapCount | Gets the number of ports connected to ISignal instances. This matches SignalCount. (Inherited from ISignalMap.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | PortCount | Gets the total number of ports in this signal map. (Inherited from ISignalMap.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SignalCount | Gets the number of ISignal instances behind this signal map. (Inherited from ISignalMap.)
Public property | StartIndex | Gets the ports starting index. (Inherited from ISignalMap.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect(Int32, ISignal) | Connects the signal behind the given port to the given ISignal instance. (Inherited from ISignalMap.)
Public method | Connect(Int32, ISignalMap, Int32) | Connects the ISignal instance behind the given port to the signal behind the port behind the given map. (Inherited from ISignalMap.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | CreateSignal | Creates a ISignal instance at the given port. (Inherited from ISignalMap.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteSignalConnection(Int32) | Deletes all ISignal instances connected to the signal at the given port. Also deletes disconnected application signals. (Inherited from ISignalMap.)
Public method | DeleteSignalConnection(Int32, Boolean) | Deletes all ISignal instances connected to the signal at the given port. (Inherited from ISignalMap.)
Public method | DeleteSignalConnection(Int32, Boolean, ISignal) | Disconnects the ISignal instance at the given port from the given signal. The signal will maintain its other connections (if any). (Inherited from ISignalMap.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects the ISignal instance behind the given port. (Inherited from ISignalMap.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | FindSignalIndexesLocation | Gets the map indexes associated to the given ISignal instance. (Inherited from ISignalMap.)
Public method | FindSignalIndexLocation | Obsolete. This method is obsolete. Use FindSignalIndexesLocation(ISignal) instead. (Inherited from ISignalMap.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetPort | Returns the port number at the given map index. Works in opposite way than GetPortIndex(Int32). (Inherited from ISignalMap.)
Public method | GetPortIndex | Returns the map index of the port defined by port number. Works in opposite way than GetPort(Int32). (Inherited from ISignalMap.)
Public method | GetPortName | Returns the name of the port at the given map index. (Inherited from ISignalMap.)
Public method | GetPortValue | Reads the value from a port defined by the map index if there is a signal in that port. (Inherited from ISignalMap.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetSignal | Gets a ISignal instance behind the map at the given map index. (Inherited from ISignalMap.)
Public method | MapGetPortSignal | Gets the ISignal instance behind the given port number. (Inherited from ISignalMap.)
Public method | SetPortName | Sets a port name given map index Remarks There should be a signal in this port in order to associate a name (Inherited from ISignalMap.)
Public method | SetPortValue | Sends a signal to a port defined by map index. (Inherited from ISignalMap.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetSignal | Associates a component signal into the given port (Inherited from ISignalMap.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | SignalValueChanged | Triggered when the value of the signal associated to the port changes. (Inherited from ISignalMap.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IBooleanSignalMap Properties

The IBooleanSignalMap type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConnectedExternalPorts | Returns all the connected external ports. The return value is a collection of tuples where the first item is the internal port number number and the second item is a port number in connected external map. (Inherited from ISignalMap.)
Public property | ConnectedExternalSignals | Returns all the connected signals in external components. The return value is a collection of tuples where the first item is the internal port number number and the second item is an external signal connected to the port. (Inherited from ISignalMap.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | MapCount | Gets the number of ports connected to ISignal instances. This matches SignalCount. (Inherited from ISignalMap.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | PortCount | Gets the total number of ports in this signal map. (Inherited from ISignalMap.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SignalCount | Gets the number of ISignal instances behind this signal map. (Inherited from ISignalMap.)
Public property | StartIndex | Gets the ports starting index. (Inherited from ISignalMap.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IBooleanSignalMap Interface
VisualComponents.Create3D Namespace


IBooleanSignalMap Methods

The IBooleanSignalMap type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect(Int32, ISignal) | Connects the signal behind the given port to the given ISignal instance. (Inherited from ISignalMap.)
Public method | Connect(Int32, ISignalMap, Int32) | Connects the ISignal instance behind the given port to the signal behind the port behind the given map. (Inherited from ISignalMap.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | CreateSignal | Creates a ISignal instance at the given port. (Inherited from ISignalMap.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteSignalConnection(Int32) | Deletes all ISignal instances connected to the signal at the given port. Also deletes disconnected application signals. (Inherited from ISignalMap.)
Public method | DeleteSignalConnection(Int32, Boolean) | Deletes all ISignal instances connected to the signal at the given port. (Inherited from ISignalMap.)
Public method | DeleteSignalConnection(Int32, Boolean, ISignal) | Disconnects the ISignal instance at the given port from the given signal. The signal will maintain its other connections (if any). (Inherited from ISignalMap.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects the ISignal instance behind the given port. (Inherited from ISignalMap.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | FindSignalIndexesLocation | Gets the map indexes associated to the given ISignal instance. (Inherited from ISignalMap.)
Public method | FindSignalIndexLocation | Obsolete. This method is obsolete. Use FindSignalIndexesLocation(ISignal) instead. (Inherited from ISignalMap.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetPort | Returns the port number at the given map index. Works in opposite way than GetPortIndex(Int32). (Inherited from ISignalMap.)
Public method | GetPortIndex | Returns the map index of the port defined by port number. Works in opposite way than GetPort(Int32). (Inherited from ISignalMap.)
Public method | GetPortName | Returns the name of the port at the given map index. (Inherited from ISignalMap.)
Public method | GetPortValue | Reads the value from a port defined by the map index if there is a signal in that port. (Inherited from ISignalMap.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetSignal | Gets a ISignal instance behind the map at the given map index. (Inherited from ISignalMap.)
Public method | MapGetPortSignal | Gets the ISignal instance behind the given port number. (Inherited from ISignalMap.)
Public method | SetPortName | Sets a port name given map index Remarks There should be a signal in this port in order to associate a name (Inherited from ISignalMap.)
Public method | SetPortValue | Sends a signal to a port defined by map index. (Inherited from ISignalMap.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetSignal | Associates a component signal into the given port (Inherited from ISignalMap.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IBooleanSignalMap Interface
VisualComponents.Create3D Namespace


IBooleanSignalMap Events

The IBooleanSignalMap type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | SignalValueChanged | Triggered when the value of the signal associated to the port changes. (Inherited from ISignalMap.)
Top
See Also

Reference

IBooleanSignalMap Interface
VisualComponents.Create3D Namespace


IBoundBox Interface

Bound box defines the smallest enclosing volume for associated object(s).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IBoundBox : IWrapper,
    IDisposable
public interface class IBoundBox : IWrapper,
    IDisposable

The IBoundBox type exposes the following members.

Properties
 | Name | Description
Public property | Center | Gets the center of this IBoundBox in reference to the node's matrix
Public property | HalfDiagonal | Gets the vector from the center to the positive corner of this IBoundBox
Public property | IsDefined | Query whether this IBoundBox is defined
Public property | IsValid | (Inherited from IWrapper.)
Public property | MaxCorner | Gets the maximum corner of this IBoundBox
Public property | MinCorner | Gets the minimum corner of this IBoundBox
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Radius | Gets the radius of this IBoundBox
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetCornerPoints | Gets the corner points of this IBoundBox
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | IntersectsBoundBox(IBoundBox) |
Public method | IntersectsBoundBox(IBoundBox, Matrix) |
Public method | IntersectsPoint | Tests if the given point is inside this IBoundBox
Public method | IntersectsSphere(IBoundBox) | Tests if this IBoundBox
Public method | IntersectsSphere(IBoundBox, Matrix) | Tests if this IBoundBox
Public method | MergeBoundBox(IListIVisualObject) |
Public method | MergeBoundBox(IListMatrix) |
Public method | Transform |
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IBoundBox Properties

The IBoundBox type exposes the following members.

Properties
 | Name | Description
Public property | Center | Gets the center of this IBoundBox in reference to the node's matrix
Public property | HalfDiagonal | Gets the vector from the center to the positive corner of this IBoundBox
Public property | IsDefined | Query whether this IBoundBox is defined
Public property | IsValid | (Inherited from IWrapper.)
Public property | MaxCorner | Gets the maximum corner of this IBoundBox
Public property | MinCorner | Gets the minimum corner of this IBoundBox
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Radius | Gets the radius of this IBoundBox
Top
See Also

Reference

IBoundBox Interface
VisualComponents.Create3D Namespace


IBoundBox.Center Property

IBoundBoxCenter Property

Gets the center of this IBoundBox in reference to the node's matrix

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 Center { get; }
property Vector3 Center {
    Vector3 get ();
}

Property Value

Type: Vector3
See Also

Reference

IBoundBox Interface
VisualComponents.Create3D Namespace


IBoundBox.HalfDiagonal Property

IBoundBoxHalfDiagonal Property

Gets the vector from the center to the positive corner of this IBoundBox

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 HalfDiagonal { get; }
property Vector3 HalfDiagonal {
    Vector3 get ();
}

Property Value

Type: Vector3
See Also

Reference

IBoundBox Interface
VisualComponents.Create3D Namespace


IBoundBox.IsDefined Property

IBoundBoxIsDefined Property

Query whether this IBoundBox is defined

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsDefined { get; }
property bool IsDefined {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IBoundBox Interface
VisualComponents.Create3D Namespace


IBoundBox.MaxCorner Property

IBoundBoxMaxCorner Property

Gets the maximum corner of this IBoundBox

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 MaxCorner { get; }
property Vector3 MaxCorner {
    Vector3 get ();
}

Property Value

Type: Vector3
See Also

Reference

IBoundBox Interface
VisualComponents.Create3D Namespace


IBoundBox.MinCorner Property

IBoundBoxMinCorner Property

Gets the minimum corner of this IBoundBox

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 MinCorner { get; }
property Vector3 MinCorner {
    Vector3 get ();
}

Property Value

Type: Vector3
See Also

Reference

IBoundBox Interface
VisualComponents.Create3D Namespace


IBoundBox.Radius Property

IBoundBoxRadius Property

Gets the radius of this IBoundBox

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Radius { get; }
property double Radius {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IBoundBox Interface
VisualComponents.Create3D Namespace


IBoundBox Methods

The IBoundBox type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetCornerPoints | Gets the corner points of this IBoundBox
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | IntersectsBoundBox(IBoundBox) |
Public method | IntersectsBoundBox(IBoundBox, Matrix) |
Public method | IntersectsPoint | Tests if the given point is inside this IBoundBox
Public method | IntersectsSphere(IBoundBox) | Tests if this IBoundBox
Public method | IntersectsSphere(IBoundBox, Matrix) | Tests if this IBoundBox
Public method | MergeBoundBox(IListIVisualObject) |
Public method | MergeBoundBox(IListMatrix) |
Public method | Transform |
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IBoundBox Interface
VisualComponents.Create3D Namespace


IBoundBox.GetCornerPoints Method

IBoundBoxGetCornerPoints Method

Gets the corner points of this IBoundBox

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3[] GetCornerPoints()
array<Vector3>^ GetCornerPoints()

Return Value

Type: Vector3

[Missing <returns> documentation for "M:VisualComponents.Create3D.IBoundBox.GetCornerPoints"]

See Also

Reference

IBoundBox Interface
VisualComponents.Create3D Namespace


IBoundBox.IntersectsBoundBox Method

IBoundBoxIntersectsBoundBox Method

Overload List
 | Name | Description
Public method | IntersectsBoundBox(IBoundBox) |
Public method | IntersectsBoundBox(IBoundBox, Matrix) |
Top
See Also

Reference

IBoundBox Interface
VisualComponents.Create3D Namespace


IBoundBox.IntersectsBoundBox Method (IBoundBox)

IBoundBoxIntersectsBoundBox Method (IBoundBox)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IntersectsBoundBox(
    IBoundBox otherBound
)
bool IntersectsBoundBox(
    IBoundBox^ otherBound
)

Parameters

otherBound
Type: VisualComponents.Create3DIBoundBox

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IBoundBox.IntersectsBoundBox(VisualComponents.Create3D.IBoundBox)"]

See Also

Reference

IBoundBox Interface
IntersectsBoundBox Overload
VisualComponents.Create3D Namespace


IBoundBox.IntersectsBoundBox Method (IBoundBox, Matrix)

IBoundBoxIntersectsBoundBox Method (IBoundBox, Matrix)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IntersectsBoundBox(
    IBoundBox otherBound,
    Matrix transformation
)
bool IntersectsBoundBox(
    IBoundBox^ otherBound,
    Matrix transformation
)

Parameters

otherBound
Type: VisualComponents.Create3DIBoundBox
transformation
Type: VisualComponents.Create3DMatrix

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IBoundBox.IntersectsBoundBox(VisualComponents.Create3D.IBoundBox,VisualComponents.Create3D.Matrix)"]

See Also

Reference

IBoundBox Interface
IntersectsBoundBox Overload
VisualComponents.Create3D Namespace


IBoundBox.IntersectsPoint Method

IBoundBoxIntersectsPoint Method

Tests if the given point is inside this IBoundBox

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IntersectsPoint(
    Vector3 point
)
bool IntersectsPoint(
    Vector3 point
)

Parameters

point
Type: VisualComponents.Create3DVector3
Point to test

Return Value

Type: Boolean
True if the point is inside
See Also

Reference

IBoundBox Interface
VisualComponents.Create3D Namespace


IBoundBox.IntersectsSphere Method

IBoundBoxIntersectsSphere Method

Overload List
 | Name | Description
Public method | IntersectsSphere(IBoundBox) | Tests if this IBoundBox
Public method | IntersectsSphere(IBoundBox, Matrix) | Tests if this IBoundBox
Top
See Also

Reference

IBoundBox Interface
VisualComponents.Create3D Namespace


IBoundBox.IntersectsSphere Method (IBoundBox)

IBoundBoxIntersectsSphere Method (IBoundBox)

Tests if this IBoundBox

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IntersectsSphere(
    IBoundBox otherBound
)
bool IntersectsSphere(
    IBoundBox^ otherBound
)

Parameters

otherBound
Type: VisualComponents.Create3DIBoundBox
Other bound box.

Return Value

Type: Boolean
True if the boundbox is inside.
See Also

Reference

IBoundBox Interface
IntersectsSphere Overload
VisualComponents.Create3D Namespace


IBoundBox.IntersectsSphere Method (IBoundBox, Matrix)

IBoundBoxIntersectsSphere Method (IBoundBox, Matrix)

Tests if this IBoundBox

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IntersectsSphere(
    IBoundBox otherBound,
    Matrix transformation
)
bool IntersectsSphere(
    IBoundBox^ otherBound,
    Matrix transformation
)

Parameters

otherBound
Type: VisualComponents.Create3DIBoundBox
transformation
Type: VisualComponents.Create3DMatrix

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IBoundBox.IntersectsSphere(VisualComponents.Create3D.IBoundBox,VisualComponents.Create3D.Matrix)"]

See Also

Reference

IBoundBox Interface
IntersectsSphere Overload
VisualComponents.Create3D Namespace


IBoundBox.MergeBoundBox Method

IBoundBoxMergeBoundBox Method

Overload List
 | Name | Description
Public method | MergeBoundBox(IListIVisualObject) |
Public method | MergeBoundBox(IListMatrix) |
Top
See Also

Reference

IBoundBox Interface
VisualComponents.Create3D Namespace


IBoundBox.MergeBoundBox Method (IList(IVisualObject))

IBoundBoxMergeBoundBox Method (IListIVisualObject)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IBoundBox MergeBoundBox(
    IList<IVisualObject> objects
)
IBoundBox^ MergeBoundBox(
    IList<IVisualObject^>^ objects
)

Parameters

objects
Type: System.Collections.GenericIListIVisualObject

Return Value

Type: IBoundBox

[Missing <returns> documentation for "M:VisualComponents.Create3D.IBoundBox.MergeBoundBox(System.Collections.Generic.IList{VisualComponents.Create3D.IVisualObject})"]

See Also

Reference

IBoundBox Interface
MergeBoundBox Overload
VisualComponents.Create3D Namespace


IBoundBox.MergeBoundBox Method (IList(Matrix))

IBoundBoxMergeBoundBox Method (IListMatrix)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IBoundBox MergeBoundBox(
    IList<Matrix> positions
)
IBoundBox^ MergeBoundBox(
    IList<Matrix>^ positions
)

Parameters

positions
Type: System.Collections.GenericIListMatrix

Return Value

Type: IBoundBox

[Missing <returns> documentation for "M:VisualComponents.Create3D.IBoundBox.MergeBoundBox(System.Collections.Generic.IList{VisualComponents.Create3D.Matrix})"]

See Also

Reference

IBoundBox Interface
MergeBoundBox Overload
VisualComponents.Create3D Namespace


IBoundBox.Transform Method

IBoundBoxTransform Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IBoundBox Transform(
    Matrix mat
)
IBoundBox^ Transform(
    Matrix mat
)

Parameters

mat
Type: VisualComponents.Create3DMatrix

Return Value

Type: IBoundBox

[Missing <returns> documentation for "M:VisualComponents.Create3D.IBoundBox.Transform(VisualComponents.Create3D.Matrix)"]

See Also

Reference

IBoundBox Interface
VisualComponents.Create3D Namespace


IBoundBox Events

The IBoundBox type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
See Also

Reference

IBoundBox Interface
VisualComponents.Create3D Namespace


IBreakStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IBreakStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IBreakStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IBreakStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IBreakStatement Properties

The IBreakStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
See Also

Reference

IBreakStatement Interface
VisualComponents.Create3D Namespace


IBreakStatement Methods

The IBreakStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IBreakStatement Interface
VisualComponents.Create3D Namespace


IBreakStatement Events

The IBreakStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IBreakStatement Interface
VisualComponents.Create3D Namespace


IBucketPath Interface

An interface for bucket path container flow behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IBucketPath : ISimContainer,
    IFlowBehavior, IBehavior, IPropertyContainer, IBatchModeObject, IVisitable,
    IWrapper, IDisposable, INamed
public interface class IBucketPath : ISimContainer,
    IFlowBehavior, IBehavior, IPropertyContainer, IBatchModeObject, IVisitable,
    IWrapper, IDisposable, INamed

The IBucketPath type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Maximum logical capacity of the container. This determines the maximum number of components that can be contained in the container at any one time. (Inherited from ISimContainer.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Components | list of components currently contained in the container (Inherited from ISimContainer.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | HeadComponent | Returns component in the head of container (Inherited from ISimContainer.)
Public property | IsContentVisible | Defines whether components held by the container are displayed or not (Inherited from ISimContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | TailComponent | Returns component in the tail of container (Inherited from ISimContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetContainerProximity | Calculate the orthogonal distance from position to this container (Inherited from ISimContainer.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Grab | Grab the component into this container (Inherited from ISimContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ComponentArriving | Triggered when a component is arriving to the container (Inherited from ISimContainer.)
Public event | ComponentLeaving | Triggered when a component is leaving from the container (Inherited from ISimContainer.)
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IBucketPath Properties

The IBucketPath type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Maximum logical capacity of the container. This determines the maximum number of components that can be contained in the container at any one time. (Inherited from ISimContainer.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Components | list of components currently contained in the container (Inherited from ISimContainer.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | HeadComponent | Returns component in the head of container (Inherited from ISimContainer.)
Public property | IsContentVisible | Defines whether components held by the container are displayed or not (Inherited from ISimContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | TailComponent | Returns component in the tail of container (Inherited from ISimContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IBucketPath Interface
VisualComponents.Create3D Namespace


IBucketPath Methods

The IBucketPath type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetContainerProximity | Calculate the orthogonal distance from position to this container (Inherited from ISimContainer.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Grab | Grab the component into this container (Inherited from ISimContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IBucketPath Interface
VisualComponents.Create3D Namespace


IBucketPath Events

The IBucketPath type exposes the following members.

Events
 | Name | Description
Public event | ComponentArriving | Triggered when a component is arriving to the container (Inherited from ISimContainer.)
Public event | ComponentLeaving | Triggered when a component is leaving from the container (Inherited from ISimContainer.)
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IBucketPath Interface
VisualComponents.Create3D Namespace


IBufferProductsStatement Interface

Creates a temporary storage for products in a grid pattern. Multiple products can be coming in and leaving the buffer in parallel. Continues execution until the break condition is met and the buffer has emptied.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IBufferProductsStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IBufferProductsStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IBufferProductsStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | BreakConditionExpression | Gets or sets the expression, which causes the buffer to stop accepting new producs when evaluated to True.
Public property | BufferMode | Gets or sets the product access order of the buffer.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | Destination | Gets or sets the destination where products are transported out.
Public property | DestinationContainer | Gets or sets IComponentContainer where outgoing products will be placed.
Public property | DestinationTransportNode | Gets or sets ITransportNode products will be sent to.
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | InputResourcePositionFrame | Gets or sets resource position offset from product position and XY plane on which resource position is projected to while filling the buffer.
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Offset | Gets or sets offset of the first product from ProductPositionFrame.
Public property | OutputResourcePositionFrame | Gets or sets resource position offset from product position and XY plane on which resource position is projected to while emptying the buffer.
Public property | ParallelInputLimit | Defines how many products can fill the buffer in parallel.
Public property | ParallelOutputLimit | Defines how many products can leave the buffer in parallel.
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | PatternCount | Gets or sets the number of product per X,Y,Z axis.
Public property | PatternStep | Gets or sets the step between products in pattern per X,Y,Z axis.
Public property | PatternTotalCount | Gets the total number of products defined in the pattern.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductPositionFrame | Gets or sets frame location where products should be placed.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReservedProductVariableName | Gets or sets the name of the variable containing products already reserved using IReserveProductStatement. The buffer will be first filled using these products and then will continue to receive further products as defined by the Source property.
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | Source | Gets or sets the source used to transport products in.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
Transport of products is handled similarly to the Transport statements.
See Also

Reference

VisualComponents.Create3D Namespace


IBufferProductsStatement Properties

The IBufferProductsStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | BreakConditionExpression | Gets or sets the expression, which causes the buffer to stop accepting new producs when evaluated to True.
Public property | BufferMode | Gets or sets the product access order of the buffer.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | Destination | Gets or sets the destination where products are transported out.
Public property | DestinationContainer | Gets or sets IComponentContainer where outgoing products will be placed.
Public property | DestinationTransportNode | Gets or sets ITransportNode products will be sent to.
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | InputResourcePositionFrame | Gets or sets resource position offset from product position and XY plane on which resource position is projected to while filling the buffer.
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Offset | Gets or sets offset of the first product from ProductPositionFrame.
Public property | OutputResourcePositionFrame | Gets or sets resource position offset from product position and XY plane on which resource position is projected to while emptying the buffer.
Public property | ParallelInputLimit | Defines how many products can fill the buffer in parallel.
Public property | ParallelOutputLimit | Defines how many products can leave the buffer in parallel.
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | PatternCount | Gets or sets the number of product per X,Y,Z axis.
Public property | PatternStep | Gets or sets the step between products in pattern per X,Y,Z axis.
Public property | PatternTotalCount | Gets the total number of products defined in the pattern.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductPositionFrame | Gets or sets frame location where products should be placed.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReservedProductVariableName | Gets or sets the name of the variable containing products already reserved using IReserveProductStatement. The buffer will be first filled using these products and then will continue to receive further products as defined by the Source property.
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | Source | Gets or sets the source used to transport products in.
Top
See Also

Reference

IBufferProductsStatement Interface
VisualComponents.Create3D Namespace


IBufferProductsStatement.BreakConditionExpression Property

IBufferProductsStatementBreakConditionExpression Property

Gets or sets the expression, which causes the buffer to stop accepting new producs when evaluated to True.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string BreakConditionExpression { get; set; }
property String^ BreakConditionExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown by setter when supplied value is null.
See Also

Reference

IBufferProductsStatement Interface
VisualComponents.Create3D Namespace


IBufferProductsStatement.BufferMode Property

IBufferProductsStatementBufferMode Property

Gets or sets the product access order of the buffer.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
BufferMode BufferMode { get; set; }
property BufferMode BufferMode {
    BufferMode get ();
    void set (BufferMode value);
}

Property Value

Type: BufferMode
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown by getter when native BufferMode property has an invalid value or by setter when an invalid value is supplied.
See Also

Reference

IBufferProductsStatement Interface
VisualComponents.Create3D Namespace


IBufferProductsStatement.Destination Property

IBufferProductsStatementDestination Property

Gets or sets the destination where products are transported out.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
TransportOutType Destination { get; set; }
property TransportOutType Destination {
    TransportOutType get ();
    void set (TransportOutType value);
}

Property Value

Type: TransportOutType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown by getter when native Destination property has an invalid value or by setter when an invalid value is supplied.
See Also

Reference

IBufferProductsStatement Interface
VisualComponents.Create3D Namespace


IBufferProductsStatement.DestinationContainer Property

IBufferProductsStatementDestinationContainer Property

Gets or sets IComponentContainer where outgoing products will be placed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IComponentContainer DestinationContainer { get; set; }
property IComponentContainer^ DestinationContainer {
    IComponentContainer^ get ();
    void set (IComponentContainer^ value);
}

Property Value

Type: IComponentContainer
See Also

Reference

IBufferProductsStatement Interface
VisualComponents.Create3D Namespace


IBufferProductsStatement.DestinationTransportNode Property

IBufferProductsStatementDestinationTransportNode Property

Gets or sets ITransportNode products will be sent to.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ITransportNode DestinationTransportNode { get; set; }
property ITransportNode^ DestinationTransportNode {
    ITransportNode^ get ();
    void set (ITransportNode^ value);
}

Property Value

Type: ITransportNode
See Also

Reference

IBufferProductsStatement Interface
VisualComponents.Create3D Namespace


IBufferProductsStatement.InputResourcePositionFrame Property

IBufferProductsStatementInputResourcePositionFrame Property

Gets or sets resource position offset from product position and XY plane on which resource position is projected to while filling the buffer.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFrameFeature InputResourcePositionFrame { get; set; }
property IFrameFeature^ InputResourcePositionFrame {
    IFrameFeature^ get ();
    void set (IFrameFeature^ value);
}

Property Value

Type: IFrameFeature
See Also

Reference

IBufferProductsStatement Interface
VisualComponents.Create3D Namespace


IBufferProductsStatement.Offset Property

IBufferProductsStatementOffset Property

Gets or sets offset of the first product from ProductPositionFrame.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix Offset { get; set; }
property Matrix Offset {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

IBufferProductsStatement Interface
VisualComponents.Create3D Namespace


IBufferProductsStatement.OutputResourcePositionFrame Property

IBufferProductsStatementOutputResourcePositionFrame Property

Gets or sets resource position offset from product position and XY plane on which resource position is projected to while emptying the buffer.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFrameFeature OutputResourcePositionFrame { get; set; }
property IFrameFeature^ OutputResourcePositionFrame {
    IFrameFeature^ get ();
    void set (IFrameFeature^ value);
}

Property Value

Type: IFrameFeature
See Also

Reference

IBufferProductsStatement Interface
VisualComponents.Create3D Namespace


IBufferProductsStatement.ParallelInputLimit Property

IBufferProductsStatementParallelInputLimit Property

Defines how many products can fill the buffer in parallel.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int ParallelInputLimit { get; set; }
property int ParallelInputLimit {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown by setter when supplied value is not in the range of 1 to 2147483647.
See Also

Reference

IBufferProductsStatement Interface
VisualComponents.Create3D Namespace


IBufferProductsStatement.ParallelOutputLimit Property

IBufferProductsStatementParallelOutputLimit Property

Defines how many products can leave the buffer in parallel.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int ParallelOutputLimit { get; set; }
property int ParallelOutputLimit {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown by setter when supplied value is not in the range of 1 to 2147483647.
See Also

Reference

IBufferProductsStatement Interface
VisualComponents.Create3D Namespace


IBufferProductsStatement.PatternCount Property

IBufferProductsStatementPatternCount Property

Gets or sets the number of product per X,Y,Z axis.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 PatternCount { get; set; }
property Vector3 PatternCount {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

IBufferProductsStatement Interface
VisualComponents.Create3D Namespace


IBufferProductsStatement.PatternStep Property

IBufferProductsStatementPatternStep Property

Gets or sets the step between products in pattern per X,Y,Z axis.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 PatternStep { get; set; }
property Vector3 PatternStep {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

IBufferProductsStatement Interface
VisualComponents.Create3D Namespace


IBufferProductsStatement.PatternTotalCount Property

IBufferProductsStatementPatternTotalCount Property

Gets the total number of products defined in the pattern.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int PatternTotalCount { get; }
property int PatternTotalCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IBufferProductsStatement Interface
VisualComponents.Create3D Namespace


IBufferProductsStatement.ProductPositionFrame Property

IBufferProductsStatementProductPositionFrame Property

Gets or sets frame location where products should be placed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFrameFeature ProductPositionFrame { get; set; }
property IFrameFeature^ ProductPositionFrame {
    IFrameFeature^ get ();
    void set (IFrameFeature^ value);
}

Property Value

Type: IFrameFeature
See Also

Reference

IBufferProductsStatement Interface
VisualComponents.Create3D Namespace


IBufferProductsStatement.ReservedProductVariableName Property

IBufferProductsStatementReservedProductVariableName Property

Gets or sets the name of the variable containing products already reserved using IReserveProductStatement. The buffer will be first filled using these products and then will continue to receive further products as defined by the Source property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ReservedProductVariableName { get; set; }
property String^ ReservedProductVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown by setter when supplied value is null.
See Also

Reference

IBufferProductsStatement Interface
VisualComponents.Create3D Namespace


IBufferProductsStatement.Source Property

IBufferProductsStatementSource Property

Gets or sets the source used to transport products in.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
TransportInType Source { get; set; }
property TransportInType Source {
    TransportInType get ();
    void set (TransportInType value);
}

Property Value

Type: TransportInType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown by getter when native Source property has an invalid value or by setter when an invalid value is supplied.
See Also

Reference

IBufferProductsStatement Interface
VisualComponents.Create3D Namespace


IBufferProductsStatement Methods

The IBufferProductsStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IBufferProductsStatement Interface
VisualComponents.Create3D Namespace


IBufferProductsStatement Events

The IBufferProductsStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IBufferProductsStatement Interface
VisualComponents.Create3D Namespace


IButtonProperty Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IButtonProperty : IProperty,
    INotifyPropertyChanged, IDisposable, INamed
public interface class IButtonProperty : IProperty,
    INotifyPropertyChanged, IDisposable, INamed

The IButtonProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Allowed maximum value for the property. (Inherited from IProperty.)
Public property | AllowedMinimum | Allowed minimum value for the property. (Inherited from IProperty.)
Public property | AllowedValues | Collection of allowed values for constrained properties. (Inherited from IProperty.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Property value as an object. (Inherited from IProperty.)
Top
Methods
 | Name | Description
Public method | Click |
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Events
 | Name | Description
Public event | OnClick |
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IButtonProperty Properties

The IButtonProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Allowed maximum value for the property. (Inherited from IProperty.)
Public property | AllowedMinimum | Allowed minimum value for the property. (Inherited from IProperty.)
Public property | AllowedValues | Collection of allowed values for constrained properties. (Inherited from IProperty.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Property value as an object. (Inherited from IProperty.)
Top
See Also

Reference

IButtonProperty Interface
VisualComponents.Create3D Namespace


IButtonProperty Methods

The IButtonProperty type exposes the following members.

Methods
 | Name | Description
Public method | Click |
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

IButtonProperty Interface
VisualComponents.Create3D Namespace


IButtonProperty.Click Method

IButtonPropertyClick Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Click()
void Click()
See Also

Reference

IButtonProperty Interface
VisualComponents.Create3D Namespace


IButtonProperty Events

The IButtonProperty type exposes the following members.

Events
 | Name | Description
Public event | OnClick |
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IButtonProperty Interface
VisualComponents.Create3D Namespace


IButtonProperty.OnClick Event

IButtonPropertyOnClick Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ButtonPropertyClickedEventArgs> OnClick
 event EventHandler<ButtonPropertyClickedEventArgs^>^ OnClick {
    void add (EventHandler<ButtonPropertyClickedEventArgs^>^ value);
    void remove (EventHandler<ButtonPropertyClickedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerButtonPropertyClickedEventArgs
See Also

Reference

IButtonProperty Interface
VisualComponents.Create3D Namespace


ICallStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICallStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class ICallStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The ICallStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | CallRoutine |
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ICallStatement Properties

The ICallStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | CallRoutine |
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
See Also

Reference

ICallStatement Interface
VisualComponents.Create3D Namespace


ICallStatement.CallRoutine Property

ICallStatementCallRoutine Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRoutine CallRoutine { get; set; }
property IRoutine^ CallRoutine {
    IRoutine^ get ();
    void set (IRoutine^ value);
}

Property Value

Type: IRoutine
See Also

Reference

ICallStatement Interface
VisualComponents.Create3D Namespace


ICallStatement Methods

The ICallStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ICallStatement Interface
VisualComponents.Create3D Namespace


ICallStatement Events

The ICallStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

ICallStatement Interface
VisualComponents.Create3D Namespace


ICamera Interface

Interface to access the world camera

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICamera : INotifyPropertyChanged,
    IWrapper, IDisposable, IDurable
public interface class ICamera : INotifyPropertyChanged,
    IWrapper, IDisposable, IDurable

The ICamera type exposes the following members.

Properties
 | Name | Description
Public property | AspectRatio | Camera aspect ration
Public property | CenterOfInterest | This property also moves the camera.
Public property | ClipFarScale | Far plane clipping scale factor
Public property | ClipNearScale | Near plane clipping scale factor
Public property | Clipping |
Public property | FarZ | Far z plane
Public property | FieldOfViewY | Field of View in Y direction. Angle in degrees.
Public property | GazeLength | Distance from camera lens (eye) to center of view (COI).
Public property | IsNavigationDisabled | Defines if navigation commands in GUI are turned on or off to allow camera orientation with other tools
Public property | IsOrthographic | Determines if the camera is in orthographic mode
Public property | IsValid | (Inherited from IWrapper.)
Public property | NearZ | Near z plane
Public property | OrthographicWidth | Orthographic width
Public property | PanValue | Angle between the camera and the worlds negative Y axis.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProjectionMatrix | The matrix describing the camera location in screen coordinates
Public property | TiltValue | Angle between camera and worlds positive Z axis
Public property | ViewMatrix | The matrix describing the camera location in world coordinates
Public property | Window | Gets the instance IWindow3D who owns the instance of this ICamera.
Top
Methods
 | Name | Description
Public method | ChangeFocus(IEnumerableIVisualObject) | Adjusts GazeLength using the diagonal of the merge bounds of the given objects
Public method | ChangeFocus(Vector3, Vector3) | Adjusts GazeLength using the diagonal of given bounds
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FillWorld | Set the camera to fill the 3DWorld with the layout in the current pose
Public method | GetGeometryScaleFactor | For legacy reasons this value equals to 0.1 * IWindow3D.GetProjectedPointPixelSize(position)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | Pan |
Public method | PickCenterOfInterest | This method also moves the camera.
Public method | RefreshParameters |
Public method | Rotate |
Public method | SetCameraLookAt | Updates camera matrix using the given parameters
Public method | SetPanValue | Sets pan value
Public method | SetTiltValue | Sets tilt value
Public method | UnProject | Unprojects a 2D position. Sets the near and far position.
Public method | Update | Updates camera position and view parameters
Public method | ViewBack | Update tilt and pan values to face back
Public method | ViewBottom | Update tilt and pan values to face bottom
Public method | ViewFront | Updates tilt and pan values to face front
Public method | ViewLeft | Update tilt and pan values to face left
Public method | ViewRight | Update tilt and pan values to face right
Public method | ViewTop | Update tilt and pan values to face top
Public method | Zoom(Point, Double) |
Public method | Zoom(Point, Point) |
Public method | Zoom(Point, Double, ZoomMode) |
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Public event | PropertyUpdated | This event is trigger when a property is updated from the application core or python API
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ICamera Properties

The ICamera type exposes the following members.

Properties
 | Name | Description
Public property | AspectRatio | Camera aspect ration
Public property | CenterOfInterest | This property also moves the camera.
Public property | ClipFarScale | Far plane clipping scale factor
Public property | ClipNearScale | Near plane clipping scale factor
Public property | Clipping |
Public property | FarZ | Far z plane
Public property | FieldOfViewY | Field of View in Y direction. Angle in degrees.
Public property | GazeLength | Distance from camera lens (eye) to center of view (COI).
Public property | IsNavigationDisabled | Defines if navigation commands in GUI are turned on or off to allow camera orientation with other tools
Public property | IsOrthographic | Determines if the camera is in orthographic mode
Public property | IsValid | (Inherited from IWrapper.)
Public property | NearZ | Near z plane
Public property | OrthographicWidth | Orthographic width
Public property | PanValue | Angle between the camera and the worlds negative Y axis.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProjectionMatrix | The matrix describing the camera location in screen coordinates
Public property | TiltValue | Angle between camera and worlds positive Z axis
Public property | ViewMatrix | The matrix describing the camera location in world coordinates
Public property | Window | Gets the instance IWindow3D who owns the instance of this ICamera.
Top
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.AspectRatio Property

ICameraAspectRatio Property

Camera aspect ration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double AspectRatio { get; set; }
property double AspectRatio {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.CenterOfInterest Property

ICameraCenterOfInterest Property

This property also moves the camera.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 CenterOfInterest { get; set; }
property Vector3 CenterOfInterest {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.ClipFarScale Property

ICameraClipFarScale Property

Far plane clipping scale factor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double ClipFarScale { get; set; }
property double ClipFarScale {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.ClipNearScale Property

ICameraClipNearScale Property

Near plane clipping scale factor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double ClipNearScale { get; set; }
property double ClipNearScale {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.Clipping Property

ICameraClipping Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int Clipping { get; set; }
property int Clipping {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.FarZ Property

ICameraFarZ Property

Far z plane

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double FarZ { get; set; }
property double FarZ {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.FieldOfViewY Property

ICameraFieldOfViewY Property

Field of View in Y direction. Angle in degrees.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double FieldOfViewY { get; set; }
property double FieldOfViewY {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.GazeLength Property

ICameraGazeLength Property

Distance from camera lens (eye) to center of view (COI).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double GazeLength { get; set; }
property double GazeLength {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.IsNavigationDisabled Property

ICameraIsNavigationDisabled Property

Defines if navigation commands in GUI are turned on or off to allow camera orientation with other tools

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsNavigationDisabled { get; set; }
property bool IsNavigationDisabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.IsOrthographic Property

ICameraIsOrthographic Property

Determines if the camera is in orthographic mode

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsOrthographic { get; set; }
property bool IsOrthographic {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.NearZ Property

ICameraNearZ Property

Near z plane

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double NearZ { get; set; }
property double NearZ {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.OrthographicWidth Property

ICameraOrthographicWidth Property

Orthographic width

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double OrthographicWidth { get; }
property double OrthographicWidth {
    double get ();
}

Property Value

Type: Double
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.PanValue Property

ICameraPanValue Property

Angle between the camera and the worlds negative Y axis.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double PanValue { get; set; }
property double PanValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.ProjectionMatrix Property

ICameraProjectionMatrix Property

The matrix describing the camera location in screen coordinates

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix ProjectionMatrix { get; }
property Matrix ProjectionMatrix {
    Matrix get ();
}

Property Value

Type: Matrix
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.TiltValue Property

ICameraTiltValue Property

Angle between camera and worlds positive Z axis

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double TiltValue { get; set; }
property double TiltValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.ViewMatrix Property

ICameraViewMatrix Property

The matrix describing the camera location in world coordinates

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix ViewMatrix { get; set; }
property Matrix ViewMatrix {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.Window Property

ICameraWindow Property

Gets the instance IWindow3D who owns the instance of this ICamera.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IWindow3D Window { get; }
property IWindow3D^ Window {
    IWindow3D^ get ();
}

Property Value

Type: IWindow3D
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera Methods

The ICamera type exposes the following members.

Methods
 | Name | Description
Public method | ChangeFocus(IEnumerableIVisualObject) | Adjusts GazeLength using the diagonal of the merge bounds of the given objects
Public method | ChangeFocus(Vector3, Vector3) | Adjusts GazeLength using the diagonal of given bounds
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FillWorld | Set the camera to fill the 3DWorld with the layout in the current pose
Public method | GetGeometryScaleFactor | For legacy reasons this value equals to 0.1 * IWindow3D.GetProjectedPointPixelSize(position)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | Pan |
Public method | PickCenterOfInterest | This method also moves the camera.
Public method | RefreshParameters |
Public method | Rotate |
Public method | SetCameraLookAt | Updates camera matrix using the given parameters
Public method | SetPanValue | Sets pan value
Public method | SetTiltValue | Sets tilt value
Public method | UnProject | Unprojects a 2D position. Sets the near and far position.
Public method | Update | Updates camera position and view parameters
Public method | ViewBack | Update tilt and pan values to face back
Public method | ViewBottom | Update tilt and pan values to face bottom
Public method | ViewFront | Updates tilt and pan values to face front
Public method | ViewLeft | Update tilt and pan values to face left
Public method | ViewRight | Update tilt and pan values to face right
Public method | ViewTop | Update tilt and pan values to face top
Public method | Zoom(Point, Double) |
Public method | Zoom(Point, Point) |
Public method | Zoom(Point, Double, ZoomMode) |
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.ChangeFocus Method

ICameraChangeFocus Method

Overload List
 | Name | Description
Public method | ChangeFocus(IEnumerableIVisualObject) | Adjusts GazeLength using the diagonal of the merge bounds of the given objects
Public method | ChangeFocus(Vector3, Vector3) | Adjusts GazeLength using the diagonal of given bounds
Top
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.ChangeFocus Method (IEnumerable(IVisualObject))

ICameraChangeFocus Method (IEnumerableIVisualObject)

Adjusts GazeLength using the diagonal of the merge bounds of the given objects

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ChangeFocus(
    IEnumerable<IVisualObject> objects
)
void ChangeFocus(
    IEnumerable<IVisualObject^>^ objects
)

Parameters

objects
Type: System.Collections.GenericIEnumerableIVisualObject
See Also

Reference

ICamera Interface
ChangeFocus Overload
VisualComponents.Create3D Namespace


ICamera.ChangeFocus Method (Vector3, Vector3)

ICameraChangeFocus Method (Vector3, Vector3)

Adjusts GazeLength using the diagonal of given bounds

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ChangeFocus(
    Vector3 boundMin,
    Vector3 boundMax
)
void ChangeFocus(
    Vector3 boundMin,
    Vector3 boundMax
)

Parameters

boundMin
Type: VisualComponents.Create3DVector3
bound min
boundMax
Type: VisualComponents.Create3DVector3
bound max
See Also

Reference

ICamera Interface
ChangeFocus Overload
VisualComponents.Create3D Namespace


ICamera.FillWorld Method

ICameraFillWorld Method

Set the camera to fill the 3DWorld with the layout in the current pose

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void FillWorld()
void FillWorld()
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.GetGeometryScaleFactor Method

ICameraGetGeometryScaleFactor Method

For legacy reasons this value equals to 0.1 * IWindow3D.GetProjectedPointPixelSize(position)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double GetGeometryScaleFactor(
    Vector3 position
)
double GetGeometryScaleFactor(
    Vector3 position
)

Parameters

position
Type: VisualComponents.Create3DVector3

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.Create3D.ICamera.GetGeometryScaleFactor(VisualComponents.Create3D.Vector3)"]

See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.Pan Method

ICameraPan Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Pan(
    Point fromPoint,
    Point toPoint
)
void Pan(
    Point fromPoint,
    Point toPoint
)

Parameters

fromPoint
Type: System.WindowsPoint
toPoint
Type: System.WindowsPoint
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.PickCenterOfInterest Method

ICameraPickCenterOfInterest Method

This method also moves the camera.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void PickCenterOfInterest()
void PickCenterOfInterest()
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.RefreshParameters Method

ICameraRefreshParameters Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RefreshParameters()
void RefreshParameters()
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.Rotate Method

ICameraRotate Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Rotate(
    Point fromPoint,
    Point toPoint
)
void Rotate(
    Point fromPoint,
    Point toPoint
)

Parameters

fromPoint
Type: System.WindowsPoint
toPoint
Type: System.WindowsPoint
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.SetCameraLookAt Method

ICameraSetCameraLookAt Method

Updates camera matrix using the given parameters

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetCameraLookAt(
    Vector3 eye,
    Vector3 centerOfInterest,
    Vector3 sky
)
void SetCameraLookAt(
    Vector3 eye,
    Vector3 centerOfInterest,
    Vector3 sky
)

Parameters

eye
Type: VisualComponents.Create3DVector3
eye position
centerOfInterest
Type: VisualComponents.Create3DVector3
center of interest
sky
Type: VisualComponents.Create3DVector3
sky position
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.SetPanValue Method

ICameraSetPanValue Method

Sets pan value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetPanValue(
    double value,
    bool update
)
void SetPanValue(
    double value,
    bool update
)

Parameters

value
Type: SystemDouble
pan value
update
Type: SystemBoolean
If true, updates camera parameters after this call
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.SetTiltValue Method

ICameraSetTiltValue Method

Sets tilt value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetTiltValue(
    double value,
    bool update
)
void SetTiltValue(
    double value,
    bool update
)

Parameters

value
Type: SystemDouble
tilt value
update
Type: SystemBoolean
If true, updates camera parameters after this call
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.UnProject Method

ICameraUnProject Method

Unprojects a 2D position. Sets the near and far position.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool UnProject(
    int x,
    int y,
    ref Vector3 nearPosition,
    ref Vector3 farPosition
)
bool UnProject(
    int x,
    int y,
    Vector3% nearPosition,
    Vector3% farPosition
)

Parameters

x
Type: SystemInt32
x coordinate
y
Type: SystemInt32
y coordinate
nearPosition
Type: VisualComponents.Create3DVector3
near position
farPosition
Type: VisualComponents.Create3DVector3
far position

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ICamera.UnProject(System.Int32,System.Int32,VisualComponents.Create3D.Vector3@,VisualComponents.Create3D.Vector3@)"]

See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.Update Method

ICameraUpdate Method

Updates camera position and view parameters

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Update()
void Update()
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.ViewBack Method

ICameraViewBack Method

Update tilt and pan values to face back

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ViewBack()
void ViewBack()
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.ViewBottom Method

ICameraViewBottom Method

Update tilt and pan values to face bottom

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ViewBottom()
void ViewBottom()
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.ViewFront Method

ICameraViewFront Method

Updates tilt and pan values to face front

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ViewFront()
void ViewFront()
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.ViewLeft Method

ICameraViewLeft Method

Update tilt and pan values to face left

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ViewLeft()
void ViewLeft()
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.ViewRight Method

ICameraViewRight Method

Update tilt and pan values to face right

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ViewRight()
void ViewRight()
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.ViewTop Method

ICameraViewTop Method

Update tilt and pan values to face top

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ViewTop()
void ViewTop()
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.Zoom Method

ICameraZoom Method

Overload List
 | Name | Description
Public method | Zoom(Point, Double) |
Public method | Zoom(Point, Point) |
Public method | Zoom(Point, Double, ZoomMode) |
Top
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.Zoom Method (Point, Double)

ICameraZoom Method (Point, Double)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Zoom(
    Point fromPoint,
    double zoomFactor
)
void Zoom(
    Point fromPoint,
    double zoomFactor
)

Parameters

fromPoint
Type: System.WindowsPoint
zoomFactor
Type: SystemDouble
See Also

Reference

ICamera Interface
Zoom Overload
VisualComponents.Create3D Namespace


ICamera.Zoom Method (Point, Point)

ICameraZoom Method (Point, Point)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Zoom(
    Point fromPoint,
    Point toPoint
)
void Zoom(
    Point fromPoint,
    Point toPoint
)

Parameters

fromPoint
Type: System.WindowsPoint
toPoint
Type: System.WindowsPoint
See Also

Reference

ICamera Interface
Zoom Overload
VisualComponents.Create3D Namespace


ICamera.Zoom Method (Point, Double, ZoomMode)

ICameraZoom Method (Point, Double, ZoomMode)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Zoom(
    Point fromPoint,
    double zoomFactor,
    ZoomMode zoomMode
)
void Zoom(
    Point fromPoint,
    double zoomFactor,
    ZoomMode zoomMode
)

Parameters

fromPoint
Type: System.WindowsPoint
zoomFactor
Type: SystemDouble
zoomMode
Type: VisualComponents.Create3DZoomMode
See Also

Reference

ICamera Interface
Zoom Overload
VisualComponents.Create3D Namespace


ICamera Events

The ICamera type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Public event | PropertyUpdated | This event is trigger when a property is updated from the application core or python API
Top
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICamera.PropertyUpdated Event

ICameraPropertyUpdated Event

This event is trigger when a property is updated from the application core or python API

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> PropertyUpdated
 event EventHandler<EventArgs^>^ PropertyUpdated {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

ICamera Interface
VisualComponents.Create3D Namespace


ICapacityController Interface

An interface for capacity controller behavior.Capacity Controller controls the global capacity for a group of behaviors.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICapacityController : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class ICapacityController : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The ICapacityController type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ICapacityController Properties

The ICapacityController type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

ICapacityController Interface
VisualComponents.Create3D Namespace


ICapacityController Methods

The ICapacityController type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ICapacityController Interface
VisualComponents.Create3D Namespace


ICapacityController Events

The ICapacityController type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ICapacityController Interface
VisualComponents.Create3D Namespace


ICartesianKinematics Interface

An interface for cartesian kinematics behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICartesianKinematics : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class ICartesianKinematics : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The ICartesianKinematics type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ICartesianKinematics Properties

The ICartesianKinematics type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

ICartesianKinematics Interface
VisualComponents.Create3D Namespace


ICartesianKinematics Methods

The ICartesianKinematics type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ICartesianKinematics Interface
VisualComponents.Create3D Namespace


ICartesianKinematics Events

The ICartesianKinematics type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ICartesianKinematics Interface
VisualComponents.Create3D Namespace


ICaseScope Interface

A case statement to use in an ISwitchCaseStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICaseScope : IStatementScope,
    IInterpolatable, IApiType, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, INamed, ICloneable<ICaseScope>, ICloneable
public interface class ICaseScope : IStatementScope,
    IInterpolatable, IApiType, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, INamed, ICloneable<ICaseScope^>, ICloneable

The ICaseScope type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConditionExpression | The condition to compare to ConditionExpression.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ICaseScope Properties

The ICaseScope type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConditionExpression | The condition to compare to ConditionExpression.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
See Also

Reference

ICaseScope Interface
VisualComponents.Create3D Namespace


ICaseScope.ConditionExpression Property

ICaseScopeConditionExpression Property

The condition to compare to ConditionExpression.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ConditionExpression { get; set; }
property String^ ConditionExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
This expression has access to UPM variables stored in IProcessRoutine.
See Also

Reference

ICaseScope Interface
VisualComponents.Create3D Namespace


ICaseScope Methods

The ICaseScope type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ICaseScope Interface
VisualComponents.Create3D Namespace


ICaseScope Events

The ICaseScope type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

ICaseScope Interface
VisualComponents.Create3D Namespace


IChangeProductTypeStatement Interface

Process statement for changing the type of an ISimProduct instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IChangeProductTypeStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IChangeProductTypeStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IChangeProductTypeStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | DeleteAttached | If true, all ISimComponent attached to Component will be deleted before the main operation takes place. If false, attached ISimComponents will get reparented to RootNode, if the new node hierarchy does not have an ISimNode with the same name that the previous parent ISimNode.
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NewType | The new IProductType to change to.
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductVariableName | Name of the Process variable that holds a reference to the ISimProduct instance to change.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IChangeProductTypeStatement Properties

The IChangeProductTypeStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | DeleteAttached | If true, all ISimComponent attached to Component will be deleted before the main operation takes place. If false, attached ISimComponents will get reparented to RootNode, if the new node hierarchy does not have an ISimNode with the same name that the previous parent ISimNode.
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NewType | The new IProductType to change to.
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductVariableName | Name of the Process variable that holds a reference to the ISimProduct instance to change.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
See Also

Reference

IChangeProductTypeStatement Interface
VisualComponents.Create3D Namespace


IChangeProductTypeStatement.DeleteAttached Property

IChangeProductTypeStatementDeleteAttached Property

If true, all ISimComponent attached to Component will be deleted before the main operation takes place.

If false, attached ISimComponents will get reparented to RootNode, if the new node hierarchy does not have an ISimNode with the same name that the previous parent ISimNode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool DeleteAttached { get; set; }
property bool DeleteAttached {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IChangeProductTypeStatement Interface
VisualComponents.Create3D Namespace


IChangeProductTypeStatement.NewType Property

IChangeProductTypeStatementNewType Property

The new IProductType to change to.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProductType NewType { get; set; }
property IProductType^ NewType {
    IProductType^ get ();
    void set (IProductType^ value);
}

Property Value

Type: IProductType
See Also

Reference

IChangeProductTypeStatement Interface
VisualComponents.Create3D Namespace


IChangeProductTypeStatement.ProductVariableName Property

IChangeProductTypeStatementProductVariableName Property

Name of the Process variable that holds a reference to the ISimProduct instance to change.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ProductVariableName { get; set; }
property String^ ProductVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IChangeProductTypeStatement Interface
VisualComponents.Create3D Namespace


IChangeProductTypeStatement Methods

The IChangeProductTypeStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IChangeProductTypeStatement Interface
VisualComponents.Create3D Namespace


IChangeProductTypeStatement Events

The IChangeProductTypeStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IChangeProductTypeStatement Interface
VisualComponents.Create3D Namespace


ICloneable(T) Interface

ICloneableT Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICloneable<T> : ICloneable

generic<typename T>
public interface class ICloneable : ICloneable

Type Parameters

T

The ICloneableT type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Top
See Also

Reference

VisualComponents.Create3D Namespace


ICloneable(T) Methods

ICloneableT Methods

The ICloneableT generic type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Top
See Also

Reference

ICloneableT Interface
VisualComponents.Create3D Namespace


ICloneable(T).Clone Method

ICloneableTClone Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
T Clone()
T Clone()

Return Value

Type: T

[Missing <returns> documentation for "M:VisualComponents.Create3D.ICloneable`1.Clone"]

See Also

Reference

ICloneableT Interface
VisualComponents.Create3D Namespace


ICloneGroup Interface

Clone group interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICloneGroup
public interface class ICloneGroup

The ICloneGroup type exposes the following members.

Properties
 | Name | Description
Public property | Clones | Read only list of clones.
Public property | Originals | Read only list of originals.
Top
Methods
 | Name | Description
Public method | AddClonePair | Add an original-clone pair to the group.
Public method | AddClonePairs | Add list of original-clone pairs to the group.
Public method | Clear | Remove all original-clone pairs from the group.
Public method | UpdateCloneReferences | Update clone references to point to the clones, rather than the originals.
Top
Remarks

A clone group is used to update internal references among items cloned as a group, so that references inside the group are updated to the cloned items, rather than the originals.

The items must be cloned before adding them to the clone group.

See Also

Reference

VisualComponents.Create3D Namespace


ICloneGroup Properties

The ICloneGroup type exposes the following members.

Properties
 | Name | Description
Public property | Clones | Read only list of clones.
Public property | Originals | Read only list of originals.
Top
See Also

Reference

ICloneGroup Interface
VisualComponents.Create3D Namespace


ICloneGroup.Clones Property

ICloneGroupClones Property

Read only list of clones.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<Object> Clones { get; }
property IList<Object^>^ Clones {
    IList<Object^>^ get ();
}

Property Value

Type: IListObject
See Also

Reference

ICloneGroup Interface
VisualComponents.Create3D Namespace


ICloneGroup.Originals Property

ICloneGroupOriginals Property

Read only list of originals.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<Object> Originals { get; }
property IList<Object^>^ Originals {
    IList<Object^>^ get ();
}

Property Value

Type: IListObject
See Also

Reference

ICloneGroup Interface
VisualComponents.Create3D Namespace


ICloneGroup Methods

The ICloneGroup type exposes the following members.

Methods
 | Name | Description
Public method | AddClonePair | Add an original-clone pair to the group.
Public method | AddClonePairs | Add list of original-clone pairs to the group.
Public method | Clear | Remove all original-clone pairs from the group.
Public method | UpdateCloneReferences | Update clone references to point to the clones, rather than the originals.
Top
See Also

Reference

ICloneGroup Interface
VisualComponents.Create3D Namespace


ICloneGroup.AddClonePair Method

ICloneGroupAddClonePair Method

Add an original-clone pair to the group.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int AddClonePair(
    Object original,
    Object clone
)
int AddClonePair(
    Object^ original,
    Object^ clone
)

Parameters

original
Type: SystemObject
clone
Type: SystemObject

Return Value

Type: Int32
Number of pairs added.
Remarks
If the items added are hierarchical, the hierarchy is traversed and any child pairs are added as well.
See Also

Reference

ICloneGroup Interface
VisualComponents.Create3D Namespace


ICloneGroup.AddClonePairs Method

ICloneGroupAddClonePairs Method

Add list of original-clone pairs to the group.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int AddClonePairs(
    IEnumerable<Object> originals,
    IEnumerable<Object> clones
)
int AddClonePairs(
    IEnumerable<Object^>^ originals,
    IEnumerable<Object^>^ clones
)

Parameters

originals
Type: System.Collections.GenericIEnumerableObject
List of originals.
clones
Type: System.Collections.GenericIEnumerableObject
List of corresponding clones.

Return Value

Type: Int32
Number of pairs added.
See Also

Reference

ICloneGroup Interface
VisualComponents.Create3D Namespace


ICloneGroup.Clear Method

ICloneGroupClear Method

Remove all original-clone pairs from the group.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Clear()
void Clear()
See Also

Reference

ICloneGroup Interface
VisualComponents.Create3D Namespace


ICloneGroup.UpdateCloneReferences Method

ICloneGroupUpdateCloneReferences Method

Update clone references to point to the clones, rather than the originals.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int UpdateCloneReferences()
int UpdateCloneReferences()

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.ICloneGroup.UpdateCloneReferences"]

See Also

Reference

ICloneGroup Interface
VisualComponents.Create3D Namespace


ICloneGroupFactory Interface

Clone group factory interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICloneGroupFactory
public interface class ICloneGroupFactory

The ICloneGroupFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateComponentCloneGroup | Create new, empty component clone group.
Top
See Also

Reference

VisualComponents.Create3D Namespace


ICloneGroupFactory Methods

The ICloneGroupFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateComponentCloneGroup | Create new, empty component clone group.
Top
See Also

Reference

ICloneGroupFactory Interface
VisualComponents.Create3D Namespace


ICloneGroupFactory.CreateComponentCloneGroup Method

ICloneGroupFactoryCreateComponentCloneGroup Method

Create new, empty component clone group.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ICloneGroup CreateComponentCloneGroup()
ICloneGroup^ CreateComponentCloneGroup()

Return Value

Type: ICloneGroup

[Missing <returns> documentation for "M:VisualComponents.Create3D.ICloneGroupFactory.CreateComponentCloneGroup"]

See Also

Reference

ICloneGroupFactory Interface
VisualComponents.Create3D Namespace


ICollisionDetectionSection Interface

Configuration file section for collision options.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICollisionDetectionSection : ISection
public interface class ICollisionDetectionSection : ISection

The ICollisionDetectionSection type exposes the following members.

Properties
 | Name | Description
Public property | CollisionDetectionElement | Configuration file element for collision options.
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | GetSection | Gets the section (Inherited from ISection.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ICollisionDetectionSection Properties

The ICollisionDetectionSection type exposes the following members.

Properties
 | Name | Description
Public property | CollisionDetectionElement | Configuration file element for collision options.
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
See Also

Reference

ICollisionDetectionSection Interface
VisualComponents.Create3D Namespace


ICollisionDetectionSection.CollisionDetectionElement Property

ICollisionDetectionSectionCollisionDetectionElement Property

Configuration file element for collision options.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
CollisionDetectionConfigElement CollisionDetectionElement { get; }
property CollisionDetectionConfigElement^ CollisionDetectionElement {
    CollisionDetectionConfigElement^ get ();
}

Property Value

Type: CollisionDetectionConfigElement
See Also

Reference

ICollisionDetectionSection Interface
VisualComponents.Create3D Namespace


ICollisionDetectionSection Methods

The ICollisionDetectionSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | GetSection | Gets the section (Inherited from ISection.)
Top
See Also

Reference

ICollisionDetectionSection Interface
VisualComponents.Create3D Namespace


ICollisionDetector Interface

Collision detector layout item interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICollisionDetector : ILayoutItem,
    IWrapper, IDisposable, INamed, IPropertyContainer, IBatchModeObject
public interface class ICollisionDetector : ILayoutItem,
    IWrapper, IDisposable, INamed, IPropertyContainer, IBatchModeObject

The ICollisionDetector type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | DetectFirstCollisionOnly | False means All collision detected
Public property | Highlight | Whether to highlight colliding simulation nodes
Public property | IgnoreClosestNodes | Set to ignore collisions between two nodes that make up a parent-child pair
Public property | IgnoreDifferentComponents | Set to ignore collisions between nodes on different components
Public property | IgnoreInvisible | Determines if invisible nodes should be ignore when doing collision test
Public property | IsActive | Whether this collision detector is actively testing collisions
Public property | IsCreatedFromPython | Determines if this item was created from Python API
Public property | IsManaged | Defines if the collision detector uses global settings.
Public property | IsPersistent | Defines if the ILayoutItem is stored with the layout. (Inherited from ILayoutItem.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Material | Collision material
Public property | MinimumDistance | Whether to calculate minimum distance between the collision lists
Public property | MinimumDistanceColor | Gets or sets minimum distance line and text label color.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeACollisionMaterial | Setting this material will supersede collision Material for collisions on geometries in NodeListA
Public property | NodeBCollisionMaterial | Setting this material will supersede collision Material for collisions on geometries in NodeListB
Public property | NodeListA | First collision node list
Public property | NodeListB | Second collision node list
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | StopOnCollision | Whether to stop the simulation when a collision is detected
Public property | Tolerance | Collision detection threshold distance. Cannot be negative value.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ClearCollisionHighlighting | Clears collision's hilighting
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes the instance of this ICollisionDetector
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetNodeListA | Set the first collision node list
Public method | SetNodeListB | Set the second collision node list
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | TestAllCollisions | Test for collisions and return all detected collision instances
Public method | TestAllIntersections | Test for collisions and return all detected collision instances
Public method | TestMinimumDistance | Compute minimum distance between node lists
Public method | TestNodeBoundBoxCollisions | Test for collisions between simulation node bound boxes only
Public method | TestOneCollision | Test for collisions and return the first collision
Public method | TestPointDistance | Compute the minimum distance from node list A to the given point
Top
Events
 | Name | Description
Public event | CollisionCleared | Occurs when collision has been cleared.
Public event | CollisionDetected | Occurs when collision has been detected.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks

The collision detector is a layout item that tests for collisions between two groups of nodes. These groups are defined as node lists, where each entry may include or exclude a single simulation node, component, or node subtree.

Depending on settings, the detector can highlight the colliding nodes during simulation, or stop the simulation if a collision is detected. It can also be used to test for collisions programmatically through this interface.

See Also

Reference

VisualComponents.Create3D Namespace


ICollisionDetector Properties

The ICollisionDetector type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | DetectFirstCollisionOnly | False means All collision detected
Public property | Highlight | Whether to highlight colliding simulation nodes
Public property | IgnoreClosestNodes | Set to ignore collisions between two nodes that make up a parent-child pair
Public property | IgnoreDifferentComponents | Set to ignore collisions between nodes on different components
Public property | IgnoreInvisible | Determines if invisible nodes should be ignore when doing collision test
Public property | IsActive | Whether this collision detector is actively testing collisions
Public property | IsCreatedFromPython | Determines if this item was created from Python API
Public property | IsManaged | Defines if the collision detector uses global settings.
Public property | IsPersistent | Defines if the ILayoutItem is stored with the layout. (Inherited from ILayoutItem.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Material | Collision material
Public property | MinimumDistance | Whether to calculate minimum distance between the collision lists
Public property | MinimumDistanceColor | Gets or sets minimum distance line and text label color.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeACollisionMaterial | Setting this material will supersede collision Material for collisions on geometries in NodeListA
Public property | NodeBCollisionMaterial | Setting this material will supersede collision Material for collisions on geometries in NodeListB
Public property | NodeListA | First collision node list
Public property | NodeListB | Second collision node list
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | StopOnCollision | Whether to stop the simulation when a collision is detected
Public property | Tolerance | Collision detection threshold distance. Cannot be negative value.
Top
See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.DetectFirstCollisionOnly Property

ICollisionDetectorDetectFirstCollisionOnly Property

False means All collision detected

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool DetectFirstCollisionOnly { get; set; }
property bool DetectFirstCollisionOnly {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.Highlight Property

ICollisionDetectorHighlight Property

Whether to highlight colliding simulation nodes

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool Highlight { get; set; }
property bool Highlight {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.IgnoreClosestNodes Property

ICollisionDetectorIgnoreClosestNodes Property

Set to ignore collisions between two nodes that make up a parent-child pair

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IgnoreClosestNodes { get; set; }
property bool IgnoreClosestNodes {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.IgnoreDifferentComponents Property

ICollisionDetectorIgnoreDifferentComponents Property

Set to ignore collisions between nodes on different components

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IgnoreDifferentComponents { get; set; }
property bool IgnoreDifferentComponents {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
Can be used to combine collision detectors into single one for checking self-collisions of multiple components.
See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.IgnoreInvisible Property

ICollisionDetectorIgnoreInvisible Property

Determines if invisible nodes should be ignore when doing collision test

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IgnoreInvisible { get; set; }
property bool IgnoreInvisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.IsActive Property

ICollisionDetectorIsActive Property

Whether this collision detector is actively testing collisions

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsActive { get; set; }
property bool IsActive {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.IsCreatedFromPython Property

ICollisionDetectorIsCreatedFromPython Property

Determines if this item was created from Python API

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsCreatedFromPython { get; }
property bool IsCreatedFromPython {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.IsManaged Property

ICollisionDetectorIsManaged Property

Defines if the collision detector uses global settings.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsManaged { get; set; }
property bool IsManaged {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.Material Property

ICollisionDetectorMaterial Property

Collision material

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMaterial Material { get; set; }
property IMaterial^ Material {
    IMaterial^ get ();
    void set (IMaterial^ value);
}

Property Value

Type: IMaterial
See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.MinimumDistance Property

ICollisionDetectorMinimumDistance Property

Whether to calculate minimum distance between the collision lists

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool MinimumDistance { get; set; }
property bool MinimumDistance {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.MinimumDistanceColor Property

ICollisionDetectorMinimumDistanceColor Property

Gets or sets minimum distance line and text label color.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Color MinimumDistanceColor { get; set; }
property Color MinimumDistanceColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.NodeACollisionMaterial Property

ICollisionDetectorNodeACollisionMaterial Property

Setting this material will supersede collision Material for collisions on geometries in NodeListA

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMaterial NodeACollisionMaterial { get; set; }
property IMaterial^ NodeACollisionMaterial {
    IMaterial^ get ();
    void set (IMaterial^ value);
}

Property Value

Type: IMaterial
See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.NodeBCollisionMaterial Property

ICollisionDetectorNodeBCollisionMaterial Property

Setting this material will supersede collision Material for collisions on geometries in NodeListB

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMaterial NodeBCollisionMaterial { get; set; }
property IMaterial^ NodeBCollisionMaterial {
    IMaterial^ get ();
    void set (IMaterial^ value);
}

Property Value

Type: IMaterial
See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.NodeListA Property

ICollisionDetectorNodeListA Property

First collision node list

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<NodeListEntry> NodeListA { get; }
property ReadOnlyCollection<NodeListEntry^>^ NodeListA {
    ReadOnlyCollection<NodeListEntry^>^ get ();
}

Property Value

Type: ReadOnlyCollectionNodeListEntry
See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.NodeListB Property

ICollisionDetectorNodeListB Property

Second collision node list

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<NodeListEntry> NodeListB { get; }
property ReadOnlyCollection<NodeListEntry^>^ NodeListB {
    ReadOnlyCollection<NodeListEntry^>^ get ();
}

Property Value

Type: ReadOnlyCollectionNodeListEntry
See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.StopOnCollision Property

ICollisionDetectorStopOnCollision Property

Whether to stop the simulation when a collision is detected

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool StopOnCollision { get; set; }
property bool StopOnCollision {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.Tolerance Property

ICollisionDetectorTolerance Property

Collision detection threshold distance. Cannot be negative value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Tolerance { get; set; }
property double Tolerance {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Remarks

A collision is registered when the smallest distance between geometries in list A and list B is less than this value.

See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector Methods

The ICollisionDetector type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ClearCollisionHighlighting | Clears collision's hilighting
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes the instance of this ICollisionDetector
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetNodeListA | Set the first collision node list
Public method | SetNodeListB | Set the second collision node list
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | TestAllCollisions | Test for collisions and return all detected collision instances
Public method | TestAllIntersections | Test for collisions and return all detected collision instances
Public method | TestMinimumDistance | Compute minimum distance between node lists
Public method | TestNodeBoundBoxCollisions | Test for collisions between simulation node bound boxes only
Public method | TestOneCollision | Test for collisions and return the first collision
Public method | TestPointDistance | Compute the minimum distance from node list A to the given point
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.ClearCollisionHighlighting Method

ICollisionDetectorClearCollisionHighlighting Method

Clears collision's hilighting

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ClearCollisionHighlighting()
void ClearCollisionHighlighting()
See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.Destroy Method

ICollisionDetectorDestroy Method

Deletes the instance of this ICollisionDetector

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Destroy()
void Destroy()
See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.SetNodeListA Method

ICollisionDetectorSetNodeListA Method

Set the first collision node list

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetNodeListA(
    IEnumerable<NodeListEntry> nodeList
)
void SetNodeListA(
    IEnumerable<NodeListEntry^>^ nodeList
)

Parameters

nodeList
Type: System.Collections.GenericIEnumerableNodeListEntry
Entries to
Remarks

This clears the current node list A and populates it with the given node entries.

See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.SetNodeListB Method

ICollisionDetectorSetNodeListB Method

Set the second collision node list

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetNodeListB(
    IEnumerable<NodeListEntry> nodeList
)
void SetNodeListB(
    IEnumerable<NodeListEntry^>^ nodeList
)

Parameters

nodeList
Type: System.Collections.GenericIEnumerableNodeListEntry
Entries to
Remarks

This clears the current node list B and populates it with the given node entries.

See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.TestAllCollisions Method

ICollisionDetectorTestAllCollisions Method

Test for collisions and return all detected collision instances

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ICollisionRecord> TestAllCollisions()
ReadOnlyCollection<ICollisionRecord^>^ TestAllCollisions()

Return Value

Type: ReadOnlyCollectionICollisionRecord
All detected collisions, or an empty collection if no collisions were detected.
See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.TestAllIntersections Method

ICollisionDetectorTestAllIntersections Method

Test for collisions and return all detected collision instances

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ICollisionRecord> TestAllIntersections()
ReadOnlyCollection<ICollisionRecord^>^ TestAllIntersections()

Return Value

Type: ReadOnlyCollectionICollisionRecord
Minimum distance information, or an empty collection if the maximum range was exceeded.
Remarks

It collects all intersecting triangles as well as intersecting points between those triangles

See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.TestMinimumDistance Method

ICollisionDetectorTestMinimumDistance Method

Compute minimum distance between node lists

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ICollisionRecord> TestMinimumDistance(
    double maxRange
)
ReadOnlyCollection<ICollisionRecord^>^ TestMinimumDistance(
    double maxRange
)

Parameters

maxRange
Type: SystemDouble
Maximum range.

Return Value

Type: ReadOnlyCollectionICollisionRecord
Minimum distance information, or an empty collection if the maximum range was exceeded.
Remarks

This method tests all nodes that are within the specified maximum range of each other, and returns a record of the minimum distance between the nodes.

If the minimum distance is greater than the maximum range, no result is returned.

See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.TestNodeBoundBoxCollisions Method

ICollisionDetectorTestNodeBoundBoxCollisions Method

Test for collisions between simulation node bound boxes only

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ICollisionRecord> TestNodeBoundBoxCollisions()
ReadOnlyCollection<ICollisionRecord^>^ TestNodeBoundBoxCollisions()

Return Value

Type: ReadOnlyCollectionICollisionRecord
All colliding bound boxes, or empty if no collisions.
Remarks

This is faster than geometry based collision testing, but not as accurate.

See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.TestOneCollision Method

ICollisionDetectorTestOneCollision Method

Test for collisions and return the first collision

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ICollisionRecord> TestOneCollision()
ReadOnlyCollection<ICollisionRecord^>^ TestOneCollision()

Return Value

Type: ReadOnlyCollectionICollisionRecord
The first detected collision, or an empty collection if no collisions were detected.
Remarks

This method stops testing after finding the first collision.

See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.TestPointDistance Method

ICollisionDetectorTestPointDistance Method

Compute the minimum distance from node list A to the given point

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ICollisionRecord> TestPointDistance(
    Vector3 point,
    double maxRange
)
ReadOnlyCollection<ICollisionRecord^>^ TestPointDistance(
    Vector3 point,
    double maxRange
)

Parameters

point
Type: VisualComponents.Create3DVector3
Position vector, in world coordinates.
maxRange
Type: SystemDouble
Maximum range.

Return Value

Type: ReadOnlyCollectionICollisionRecord
Minimum distance information, or an empty collection if the maximum range was exceeded.
Remarks

This method tests the minimum distance between the simulation nodes in list A to the given point position.

If the minimum distance is greater than the maximum range, no result is returned.

See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector Events

The ICollisionDetector type exposes the following members.

Events
 | Name | Description
Public event | CollisionCleared | Occurs when collision has been cleared.
Public event | CollisionDetected | Occurs when collision has been detected.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.CollisionCleared Event

ICollisionDetectorCollisionCleared Event

Occurs when collision has been cleared.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> CollisionCleared
 event EventHandler<EventArgs^>^ CollisionCleared {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionDetector.CollisionDetected Event

ICollisionDetectorCollisionDetected Event

Occurs when collision has been detected.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<CollisionDetectedEventArgs> CollisionDetected
 event EventHandler<CollisionDetectedEventArgs^>^ CollisionDetected {
    void add (EventHandler<CollisionDetectedEventArgs^>^ value);
    void remove (EventHandler<CollisionDetectedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerCollisionDetectedEventArgs
See Also

Reference

ICollisionDetector Interface
VisualComponents.Create3D Namespace


ICollisionListenerService Interface

Service to provide centralized events for collisions occuring in the layout.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICollisionListenerService
public interface class ICollisionListenerService

The ICollisionListenerService type exposes the following members.

Properties
 | Name | Description
Public property | IsStarted | Defines if the service is broadcasting events.
Top
Methods
 | Name | Description
Public method | Close | Stops broadcasting events.
Public method | Start | Starts broadcasting events.
Top
See Also

Reference

VisualComponents.Create3D Namespace


ICollisionListenerService Properties

The ICollisionListenerService type exposes the following members.

Properties
 | Name | Description
Public property | IsStarted | Defines if the service is broadcasting events.
Top
See Also

Reference

ICollisionListenerService Interface
VisualComponents.Create3D Namespace


ICollisionListenerService.IsStarted Property

ICollisionListenerServiceIsStarted Property

Defines if the service is broadcasting events.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsStarted { get; }
property bool IsStarted {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ICollisionListenerService Interface
VisualComponents.Create3D Namespace


ICollisionListenerService Methods

The ICollisionListenerService type exposes the following members.

Methods
 | Name | Description
Public method | Close | Stops broadcasting events.
Public method | Start | Starts broadcasting events.
Top
See Also

Reference

ICollisionListenerService Interface
VisualComponents.Create3D Namespace


ICollisionListenerService.Close Method

ICollisionListenerServiceClose Method

Stops broadcasting events.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Close()
void Close()
See Also

Reference

ICollisionListenerService Interface
VisualComponents.Create3D Namespace


ICollisionListenerService.Start Method

ICollisionListenerServiceStart Method

Starts broadcasting events.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Start()
void Start()
See Also

Reference

ICollisionListenerService Interface
VisualComponents.Create3D Namespace


ICollisionRecord Interface

The information returned by ICollisionDetector when testing for collisions

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICollisionRecord
public interface class ICollisionRecord

The ICollisionRecord type exposes the following members.

Properties
 | Name | Description
Public property | Distance | Gets the minimum distance if this records represents minimum distance.
Public property | FeatureA | First colliding feature
Public property | FeatureB | Second colliding feature
Public property | GeometrySetA | First colliding geometry set
Public property | GeometrySetB | Second colliding geometry set
Public property | Intersections | Gets a list of all intersecting triangles from geometry sets within the minimum distance.
Public property | IsMinimumDistance | Defines if this records represents collision or minimum distance.
Public property | NodeA | First colliding node
Public property | NodeB | Second colliding node
Public property | PointA | In case of minimun distance, First closest point
Public property | PointB | In case of minimun distance, second closest point
Top
See Also

Reference

VisualComponents.Create3D Namespace


ICollisionRecord Properties

The ICollisionRecord type exposes the following members.

Properties
 | Name | Description
Public property | Distance | Gets the minimum distance if this records represents minimum distance.
Public property | FeatureA | First colliding feature
Public property | FeatureB | Second colliding feature
Public property | GeometrySetA | First colliding geometry set
Public property | GeometrySetB | Second colliding geometry set
Public property | Intersections | Gets a list of all intersecting triangles from geometry sets within the minimum distance.
Public property | IsMinimumDistance | Defines if this records represents collision or minimum distance.
Public property | NodeA | First colliding node
Public property | NodeB | Second colliding node
Public property | PointA | In case of minimun distance, First closest point
Public property | PointB | In case of minimun distance, second closest point
Top
See Also

Reference

ICollisionRecord Interface
VisualComponents.Create3D Namespace


ICollisionRecord.Distance Property

ICollisionRecordDistance Property

Gets the minimum distance if this records represents minimum distance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Distance { get; }
property double Distance {
    double get ();
}

Property Value

Type: Double
See Also

Reference

ICollisionRecord Interface
VisualComponents.Create3D Namespace


ICollisionRecord.FeatureA Property

ICollisionRecordFeatureA Property

First colliding feature

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFeature FeatureA { get; }
property IFeature^ FeatureA {
    IFeature^ get ();
}

Property Value

Type: IFeature
See Also

Reference

ICollisionRecord Interface
VisualComponents.Create3D Namespace


ICollisionRecord.FeatureB Property

ICollisionRecordFeatureB Property

Second colliding feature

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFeature FeatureB { get; }
property IFeature^ FeatureB {
    IFeature^ get ();
}

Property Value

Type: IFeature
See Also

Reference

ICollisionRecord Interface
VisualComponents.Create3D Namespace


ICollisionRecord.GeometrySetA Property

ICollisionRecordGeometrySetA Property

First colliding geometry set

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IGeometrySet GeometrySetA { get; }
property IGeometrySet^ GeometrySetA {
    IGeometrySet^ get ();
}

Property Value

Type: IGeometrySet
See Also

Reference

ICollisionRecord Interface
VisualComponents.Create3D Namespace


ICollisionRecord.GeometrySetB Property

ICollisionRecordGeometrySetB Property

Second colliding geometry set

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IGeometrySet GeometrySetB { get; }
property IGeometrySet^ GeometrySetB {
    IGeometrySet^ get ();
}

Property Value

Type: IGeometrySet
See Also

Reference

ICollisionRecord Interface
VisualComponents.Create3D Namespace


ICollisionRecord.Intersections Property

ICollisionRecordIntersections Property

Gets a list of all intersecting triangles from geometry sets within the minimum distance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IntersectingGeometry> Intersections { get; }
property ReadOnlyCollection<IntersectingGeometry>^ Intersections {
    ReadOnlyCollection<IntersectingGeometry>^ get ();
}

Property Value

Type: ReadOnlyCollectionIntersectingGeometry
See Also

Reference

ICollisionRecord Interface
VisualComponents.Create3D Namespace


ICollisionRecord.IsMinimumDistance Property

ICollisionRecordIsMinimumDistance Property

Defines if this records represents collision or minimum distance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsMinimumDistance { get; }
property bool IsMinimumDistance {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ICollisionRecord Interface
VisualComponents.Create3D Namespace


ICollisionRecord.NodeA Property

ICollisionRecordNodeA Property

First colliding node

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode NodeA { get; }
property ISimNode^ NodeA {
    ISimNode^ get ();
}

Property Value

Type: ISimNode
See Also

Reference

ICollisionRecord Interface
VisualComponents.Create3D Namespace


ICollisionRecord.NodeB Property

ICollisionRecordNodeB Property

Second colliding node

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode NodeB { get; }
property ISimNode^ NodeB {
    ISimNode^ get ();
}

Property Value

Type: ISimNode
See Also

Reference

ICollisionRecord Interface
VisualComponents.Create3D Namespace


ICollisionRecord.PointA Property

ICollisionRecordPointA Property

In case of minimun distance, First closest point

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 PointA { get; }
property Vector3 PointA {
    Vector3 get ();
}

Property Value

Type: Vector3
See Also

Reference

ICollisionRecord Interface
VisualComponents.Create3D Namespace


ICollisionRecord.PointB Property

ICollisionRecordPointB Property

In case of minimun distance, second closest point

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 PointB { get; }
property Vector3 PointB {
    Vector3 get ();
}

Property Value

Type: Vector3
See Also

Reference

ICollisionRecord Interface
VisualComponents.Create3D Namespace


ICombinable(T) Interface

ICombinableT Interface

Class whose instance can encapsulate/combine multiple instances of the same class. For example ISchemaPositionFrame and ISchemaFrame.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICombinable<T>

generic<typename T>
public interface class ICombinable

Type Parameters

T

The ICombinableT type exposes the following members.

Properties
 | Name | Description
Public property | CombinedCount | How many instances are combined.
Public property | CombinedIndexes | Indexes that indicate which instances were combined.
Public property | CombinedItems |
Public property | Index | Item's index.
Public property | IsCombined | Whether or not this instances encapsulates another instances.
Top
See Also

Reference

VisualComponents.Create3D Namespace


ICombinable(T) Properties

ICombinableT Properties

The ICombinableT generic type exposes the following members.

Properties
 | Name | Description
Public property | CombinedCount | How many instances are combined.
Public property | CombinedIndexes | Indexes that indicate which instances were combined.
Public property | CombinedItems |
Public property | Index | Item's index.
Public property | IsCombined | Whether or not this instances encapsulates another instances.
Top
See Also

Reference

ICombinableT Interface
VisualComponents.Create3D Namespace


ICombinable(T).CombinedCount Property

ICombinableTCombinedCount Property

How many instances are combined.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int CombinedCount { get; }
property int CombinedCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ICombinableT Interface
VisualComponents.Create3D Namespace


ICombinable(T).CombinedIndexes Property

ICombinableTCombinedIndexes Property

Indexes that indicate which instances were combined.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<int> CombinedIndexes { get; }
property IEnumerable<int>^ CombinedIndexes {
    IEnumerable<int>^ get ();
}

Property Value

Type: IEnumerableInt32
See Also

Reference

ICombinableT Interface
VisualComponents.Create3D Namespace


ICombinable(T).CombinedItems Property

ICombinableTCombinedItems Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<T> CombinedItems { get; }
property IEnumerable<T>^ CombinedItems {
    IEnumerable<T>^ get ();
}

Property Value

Type: IEnumerableT
See Also

Reference

ICombinableT Interface
VisualComponents.Create3D Namespace


ICombinable(T).Index Property

ICombinableTIndex Property

Item's index.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int Index { get; }
property int Index {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ICombinableT Interface
VisualComponents.Create3D Namespace


ICombinable(T).IsCombined Property

ICombinableTIsCombined Property

Whether or not this instances encapsulates another instances.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsCombined { get; }
property bool IsCombined {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ICombinableT Interface
VisualComponents.Create3D Namespace


ICommandExecution Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICommandExecution
public interface class ICommandExecution

The ICommandExecution type exposes the following members.

Methods
 | Name | Description
Public method | ExecuteAction(String) | Executes action/command. Note: ICommandRegistry.Actions are actually commands, ie classes using naming convetion "*Command.cs". Note: this method doesn't call BeforeExecute().
Public method | ExecuteAction(String, PropertyCollection) |
Public method | ExecuteInPanel |
Top
See Also

Reference

VisualComponents.Create3D Namespace


ICommandExecution Methods

The ICommandExecution type exposes the following members.

Methods
 | Name | Description
Public method | ExecuteAction(String) | Executes action/command. Note: ICommandRegistry.Actions are actually commands, ie classes using naming convetion "*Command.cs". Note: this method doesn't call BeforeExecute().
Public method | ExecuteAction(String, PropertyCollection) |
Public method | ExecuteInPanel |
Top
See Also

Reference

ICommandExecution Interface
VisualComponents.Create3D Namespace


ICommandExecution.ExecuteAction Method

ICommandExecutionExecuteAction Method

Overload List
 | Name | Description
Public method | ExecuteAction(String) | Executes action/command. Note: ICommandRegistry.Actions are actually commands, ie classes using naming convetion "*Command.cs". Note: this method doesn't call BeforeExecute().
Public method | ExecuteAction(String, PropertyCollection) |
Top
See Also

Reference

ICommandExecution Interface
VisualComponents.Create3D Namespace


ICommandExecution.ExecuteAction Method (String)

ICommandExecutionExecuteAction Method (String)

Executes action/command. Note: ICommandRegistry.Actions are actually commands, ie classes using naming convetion "*Command.cs". Note: this method doesn't call BeforeExecute().

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ExecuteAction(
    string key
)
void ExecuteAction(
    String^ key
)

Parameters

key
Type: SystemString
Remarks
Does not throw exception if actions is not found with the key.
See Also

Reference

ICommandExecution Interface
ExecuteAction Overload
VisualComponents.Create3D Namespace


ICommandExecution.ExecuteAction Method (String, PropertyCollection)

ICommandExecutionExecuteAction Method (String, PropertyCollection)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ExecuteAction(
    string key,
    PropertyCollection properties
)
void ExecuteAction(
    String^ key,
    PropertyCollection^ properties
)

Parameters

key
Type: SystemString
properties
Type: VisualComponents.Create3DPropertyCollection
See Also

Reference

ICommandExecution Interface
ExecuteAction Overload
VisualComponents.Create3D Namespace


ICommandExecution.ExecuteInPanel Method

ICommandExecutionExecuteInPanel Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ExecuteInPanel(
    PropertyCollection properties
)
void ExecuteInPanel(
    PropertyCollection^ properties
)

Parameters

properties
Type: VisualComponents.Create3DPropertyCollection
See Also

Reference

ICommandExecution Interface
VisualComponents.Create3D Namespace


ICommentStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICommentStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class ICommentStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The ICommentStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Comment |
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ICommentStatement Properties

The ICommentStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Comment |
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
See Also

Reference

ICommentStatement Interface
VisualComponents.Create3D Namespace


ICommentStatement.Comment Property

ICommentStatementComment Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Comment { get; set; }
property String^ Comment {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ICommentStatement Interface
VisualComponents.Create3D Namespace


ICommentStatement Methods

The ICommentStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ICommentStatement Interface
VisualComponents.Create3D Namespace


ICommentStatement Events

The ICommentStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

ICommentStatement Interface
VisualComponents.Create3D Namespace


ICompletionInfo Interface

Completion information object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICompletionInfo
public interface class ICompletionInfo

The ICompletionInfo type exposes the following members.

Properties
 | Name | Description
Public property | Completions | List of completions. All completions start at StartIndex.
Public property | Context | Completion context. Use this as the key when caching last used completions.
Public property | StartIndex | Start index of completions. This may be before the caret position if the start of the symbol has been written.
Top
See Also

Reference

VisualComponents.Create3D Namespace


ICompletionInfo Properties

The ICompletionInfo type exposes the following members.

Properties
 | Name | Description
Public property | Completions | List of completions. All completions start at StartIndex.
Public property | Context | Completion context. Use this as the key when caching last used completions.
Public property | StartIndex | Start index of completions. This may be before the caret position if the start of the symbol has been written.
Top
See Also

Reference

ICompletionInfo Interface
VisualComponents.Create3D Namespace


ICompletionInfo.Completions Property

ICompletionInfoCompletions Property

List of completions. All completions start at StartIndex.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<Completion> Completions { get; }
property IList<Completion>^ Completions {
    IList<Completion>^ get ();
}

Property Value

Type: IListCompletion
See Also

Reference

ICompletionInfo Interface
VisualComponents.Create3D Namespace


ICompletionInfo.Context Property

ICompletionInfoContext Property

Completion context. Use this as the key when caching last used completions.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Context { get; }
property String^ Context {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ICompletionInfo Interface
VisualComponents.Create3D Namespace


ICompletionInfo.StartIndex Property

ICompletionInfoStartIndex Property

Start index of completions. This may be before the caret position if the start of the symbol has been written.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int StartIndex { get; }
property int StartIndex {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ICompletionInfo Interface
VisualComponents.Create3D Namespace


IComponentContainer Interface

An interface for component container behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IComponentContainer : ISimContainer,
    IFlowBehavior, IBehavior, IPropertyContainer, IBatchModeObject, IVisitable,
    IWrapper, IDisposable, INamed
public interface class IComponentContainer : ISimContainer,
    IFlowBehavior, IBehavior, IPropertyContainer, IBatchModeObject, IVisitable,
    IWrapper, IDisposable, INamed

The IComponentContainer type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Maximum logical capacity of the container. This determines the maximum number of components that can be contained in the container at any one time. (Inherited from ISimContainer.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Components | list of components currently contained in the container (Inherited from ISimContainer.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | HeadComponent | Returns component in the head of container (Inherited from ISimContainer.)
Public property | IsContentVisible | Defines whether components held by the container are displayed or not (Inherited from ISimContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | TailComponent | Returns component in the tail of container (Inherited from ISimContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetContainerProximity | Calculate the orthogonal distance from position to this container (Inherited from ISimContainer.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Grab | Grab the component into this container (Inherited from ISimContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ComponentArriving | Triggered when a component is arriving to the container (Inherited from ISimContainer.)
Public event | ComponentLeaving | Triggered when a component is leaving from the container (Inherited from ISimContainer.)
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IComponentContainer Properties

The IComponentContainer type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Maximum logical capacity of the container. This determines the maximum number of components that can be contained in the container at any one time. (Inherited from ISimContainer.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Components | list of components currently contained in the container (Inherited from ISimContainer.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | HeadComponent | Returns component in the head of container (Inherited from ISimContainer.)
Public property | IsContentVisible | Defines whether components held by the container are displayed or not (Inherited from ISimContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | TailComponent | Returns component in the tail of container (Inherited from ISimContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IComponentContainer Interface
VisualComponents.Create3D Namespace


IComponentContainer Methods

The IComponentContainer type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetContainerProximity | Calculate the orthogonal distance from position to this container (Inherited from ISimContainer.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Grab | Grab the component into this container (Inherited from ISimContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IComponentContainer Interface
VisualComponents.Create3D Namespace


IComponentContainer Events

The IComponentContainer type exposes the following members.

Events
 | Name | Description
Public event | ComponentArriving | Triggered when a component is arriving to the container (Inherited from ISimContainer.)
Public event | ComponentLeaving | Triggered when a component is leaving from the container (Inherited from ISimContainer.)
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IComponentContainer Interface
VisualComponents.Create3D Namespace


IComponentCreator Interface

An interface for component creator behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IComponentCreator : ISimContainer,
    IFlowBehavior, IBehavior, IPropertyContainer, IBatchModeObject, IVisitable,
    IWrapper, IDisposable, INamed
public interface class IComponentCreator : ISimContainer,
    IFlowBehavior, IBehavior, IPropertyContainer, IBatchModeObject, IVisitable,
    IWrapper, IDisposable, INamed

The IComponentCreator type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Maximum logical capacity of the container. This determines the maximum number of components that can be contained in the container at any one time. (Inherited from ISimContainer.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Components | list of components currently contained in the container (Inherited from ISimContainer.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | HeadComponent | Returns component in the head of container (Inherited from ISimContainer.)
Public property | IsContentVisible | Defines whether components held by the container are displayed or not (Inherited from ISimContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | TailComponent | Returns component in the tail of container (Inherited from ISimContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetContainerProximity | Calculate the orthogonal distance from position to this container (Inherited from ISimContainer.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Grab | Grab the component into this container (Inherited from ISimContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ComponentArriving | Triggered when a component is arriving to the container (Inherited from ISimContainer.)
Public event | ComponentLeaving | Triggered when a component is leaving from the container (Inherited from ISimContainer.)
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IComponentCreator Properties

The IComponentCreator type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Maximum logical capacity of the container. This determines the maximum number of components that can be contained in the container at any one time. (Inherited from ISimContainer.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Components | list of components currently contained in the container (Inherited from ISimContainer.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | HeadComponent | Returns component in the head of container (Inherited from ISimContainer.)
Public property | IsContentVisible | Defines whether components held by the container are displayed or not (Inherited from ISimContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | TailComponent | Returns component in the tail of container (Inherited from ISimContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IComponentCreator Interface
VisualComponents.Create3D Namespace


IComponentCreator Methods

The IComponentCreator type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetContainerProximity | Calculate the orthogonal distance from position to this container (Inherited from ISimContainer.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Grab | Grab the component into this container (Inherited from ISimContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IComponentCreator Interface
VisualComponents.Create3D Namespace


IComponentCreator Events

The IComponentCreator type exposes the following members.

Events
 | Name | Description
Public event | ComponentArriving | Triggered when a component is arriving to the container (Inherited from ISimContainer.)
Public event | ComponentLeaving | Triggered when a component is leaving from the container (Inherited from ISimContainer.)
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IComponentCreator Interface
VisualComponents.Create3D Namespace


IComponentFlowProxy Interface

An interface for component flow proxy behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IComponentFlowProxy : IFlowBehavior,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed
public interface class IComponentFlowProxy : IFlowBehavior,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed

The IComponentFlowProxy type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IComponentFlowProxy Properties

The IComponentFlowProxy type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IComponentFlowProxy Interface
VisualComponents.Create3D Namespace


IComponentFlowProxy Methods

The IComponentFlowProxy type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IComponentFlowProxy Interface
VisualComponents.Create3D Namespace


IComponentFlowProxy Events

The IComponentFlowProxy type exposes the following members.

Events
 | Name | Description
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IComponentFlowProxy Interface
VisualComponents.Create3D Namespace


IComponentGrabber Interface

An interface for component grabber behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IComponentGrabber : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IComponentGrabber : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IComponentGrabber type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IComponentGrabber Properties

The IComponentGrabber type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IComponentGrabber Interface
VisualComponents.Create3D Namespace


IComponentGrabber Methods

The IComponentGrabber type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IComponentGrabber Interface
VisualComponents.Create3D Namespace


IComponentGrabber Events

The IComponentGrabber type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IComponentGrabber Interface
VisualComponents.Create3D Namespace


IComponentMemento Interface

Interface for storing component's state.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IComponentMemento : IMemento<ISimComponent>,
    IDisposable
public interface class IComponentMemento : IMemento<ISimComponent^>,
    IDisposable

The IComponentMemento type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RestoreState | (Inherited from IMementoT.)
Public method | SaveState | (Inherited from IMementoT.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IComponentMemento Methods

The IComponentMemento type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RestoreState | (Inherited from IMementoT.)
Public method | SaveState | (Inherited from IMementoT.)
Top
See Also

Reference

IComponentMemento Interface
VisualComponents.Create3D Namespace


IComponentPathSensor Interface

An interface for component path sensor behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IComponentPathSensor : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IComponentPathSensor : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IComponentPathSensor type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IComponentPathSensor Properties

The IComponentPathSensor type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IComponentPathSensor Interface
VisualComponents.Create3D Namespace


IComponentPathSensor Methods

The IComponentPathSensor type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IComponentPathSensor Interface
VisualComponents.Create3D Namespace


IComponentPathSensor Events

The IComponentPathSensor type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IComponentPathSensor Interface
VisualComponents.Create3D Namespace


IComponentPdfInfo Interface

Represents an object to be included in the PDF

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IComponentPdfInfo
public interface class IComponentPdfInfo

The IComponentPdfInfo type exposes the following members.

Properties
 | Name | Description
Public property | CameraDistance | Distance from camera to object
Public property | Description | Object description
Public property | Id | Object id
Public property | Name | Object name
Public property | Origin | Object origin
Top
See Also

Reference

VisualComponents.Create3D Namespace


IComponentPdfInfo Properties

The IComponentPdfInfo type exposes the following members.

Properties
 | Name | Description
Public property | CameraDistance | Distance from camera to object
Public property | Description | Object description
Public property | Id | Object id
Public property | Name | Object name
Public property | Origin | Object origin
Top
See Also

Reference

IComponentPdfInfo Interface
VisualComponents.Create3D Namespace


IComponentPdfInfo.CameraDistance Property

IComponentPdfInfoCameraDistance Property

Distance from camera to object

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double CameraDistance { get; }
property double CameraDistance {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IComponentPdfInfo Interface
VisualComponents.Create3D Namespace


IComponentPdfInfo.Description Property

IComponentPdfInfoDescription Property

Object description

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Description { get; }
property String^ Description {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IComponentPdfInfo Interface
VisualComponents.Create3D Namespace


IComponentPdfInfo.Id Property

IComponentPdfInfoId Property

Object id

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Id { get; }
property String^ Id {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IComponentPdfInfo Interface
VisualComponents.Create3D Namespace


IComponentPdfInfo.Name Property

IComponentPdfInfoName Property

Object name

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Name { get; }
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IComponentPdfInfo Interface
VisualComponents.Create3D Namespace


IComponentPdfInfo.Origin Property

IComponentPdfInfoOrigin Property

Object origin

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Point3D Origin { get; }
property Point3D Origin {
    Point3D get ();
}

Property Value

Type: Point3D
See Also

Reference

IComponentPdfInfo Interface
VisualComponents.Create3D Namespace


IComponentProperty Interface

A property attached to a component.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IComponentProperty : IProperty,
    INotifyPropertyChanged, IDisposable, INamed
public interface class IComponentProperty : IProperty,
    INotifyPropertyChanged, IDisposable, INamed

The IComponentProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Allowed maximum value for the property. (Inherited from IProperty.)
Public property | AllowedMinimum | Allowed minimum value for the property. (Inherited from IProperty.)
Public property | AllowedValues | Collection of allowed values for constrained properties. (Inherited from IProperty.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConfiguresComponentWhenChanged |
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsEditableDuringSimulation |
Public property | IsEditableWhenConnected |
Public property | IsEditableWhenDisconnected |
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | RebuildsComponentWhenChanged |
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | UpdatesSimulationWhenChanged |
Public property | Value | Property value as an object. (Inherited from IProperty.)
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IComponentProperty Properties

The IComponentProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Allowed maximum value for the property. (Inherited from IProperty.)
Public property | AllowedMinimum | Allowed minimum value for the property. (Inherited from IProperty.)
Public property | AllowedValues | Collection of allowed values for constrained properties. (Inherited from IProperty.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConfiguresComponentWhenChanged |
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsEditableDuringSimulation |
Public property | IsEditableWhenConnected |
Public property | IsEditableWhenDisconnected |
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | RebuildsComponentWhenChanged |
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | UpdatesSimulationWhenChanged |
Public property | Value | Property value as an object. (Inherited from IProperty.)
Top
See Also

Reference

IComponentProperty Interface
VisualComponents.Create3D Namespace


IComponentProperty.ConfiguresComponentWhenChanged Property

IComponentPropertyConfiguresComponentWhenChanged Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ConfiguresComponentWhenChanged { get; set; }
property bool ConfiguresComponentWhenChanged {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IComponentProperty Interface
VisualComponents.Create3D Namespace


IComponentProperty.IsEditableDuringSimulation Property

IComponentPropertyIsEditableDuringSimulation Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsEditableDuringSimulation { get; set; }
property bool IsEditableDuringSimulation {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IComponentProperty Interface
VisualComponents.Create3D Namespace


IComponentProperty.IsEditableWhenConnected Property

IComponentPropertyIsEditableWhenConnected Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsEditableWhenConnected { get; set; }
property bool IsEditableWhenConnected {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IComponentProperty Interface
VisualComponents.Create3D Namespace


IComponentProperty.IsEditableWhenDisconnected Property

IComponentPropertyIsEditableWhenDisconnected Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsEditableWhenDisconnected { get; set; }
property bool IsEditableWhenDisconnected {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IComponentProperty Interface
VisualComponents.Create3D Namespace


IComponentProperty.RebuildsComponentWhenChanged Property

IComponentPropertyRebuildsComponentWhenChanged Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool RebuildsComponentWhenChanged { get; set; }
property bool RebuildsComponentWhenChanged {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IComponentProperty Interface
VisualComponents.Create3D Namespace


IComponentProperty.UpdatesSimulationWhenChanged Property

IComponentPropertyUpdatesSimulationWhenChanged Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool UpdatesSimulationWhenChanged { get; set; }
property bool UpdatesSimulationWhenChanged {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IComponentProperty Interface
VisualComponents.Create3D Namespace


IComponentProperty Methods

The IComponentProperty type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

IComponentProperty Interface
VisualComponents.Create3D Namespace


IComponentProperty Events

The IComponentProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IComponentProperty Interface
VisualComponents.Create3D Namespace


IComponentSignal Interface

An interface for component signal behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IComponentSignal : ISignal,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed
public interface class IComponentSignal : ISignal,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed

The IComponentSignal type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsApplication | Defines if this ISignal instance has been created by the application for its internal use. (Inherited from ISignal.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Public property | Value | Gets or sets the value of this ISignal instance. (Inherited from ISignal.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanConnectTo | Defines if this ISignal instance can be connected to the given signal. (Inherited from ISignal.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect | Connects the given ISignal instance to the given signal. (Inherited from ISignal.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects this ISignal instance from the given signal. (Inherited from ISignal.)
Public method | DisconnectAll | Disconnects all ISignal instances connected to this signal. (Inherited from ISignal.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | SignalTrigger | Event that is raised when the value of this ISignal instance is changing. (Inherited from ISignal.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IComponentSignal Properties

The IComponentSignal type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsApplication | Defines if this ISignal instance has been created by the application for its internal use. (Inherited from ISignal.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Public property | Value | Gets or sets the value of this ISignal instance. (Inherited from ISignal.)
Top
See Also

Reference

IComponentSignal Interface
VisualComponents.Create3D Namespace


IComponentSignal Methods

The IComponentSignal type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanConnectTo | Defines if this ISignal instance can be connected to the given signal. (Inherited from ISignal.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect | Connects the given ISignal instance to the given signal. (Inherited from ISignal.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects this ISignal instance from the given signal. (Inherited from ISignal.)
Public method | DisconnectAll | Disconnects all ISignal instances connected to this signal. (Inherited from ISignal.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IComponentSignal Interface
VisualComponents.Create3D Namespace


IComponentSignal Events

The IComponentSignal type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | SignalTrigger | Event that is raised when the value of this ISignal instance is changing. (Inherited from ISignal.)
Top
See Also

Reference

IComponentSignal Interface
VisualComponents.Create3D Namespace


IConeFeature Interface

Cone feature interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IConeFeature : IPrimitiveFeature,
    IFeature, IVisualObject, INamed, IWrapper, IDisposable,
    IVisitable, IPropertyContainer, IBatchModeObject, ISharedCloneable
public interface class IConeFeature : IPrimitiveFeature,
    IFeature, IVisualObject, INamed, IWrapper, IDisposable,
    IVisitable, IPropertyContainer, IBatchModeObject, ISharedCloneable

The IConeFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
The Cone geometry primitive produces a cone or a frustum
See Also

Reference

VisualComponents.Create3D Namespace


IConeFeature Properties

The IConeFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
See Also

Reference

IConeFeature Interface
VisualComponents.Create3D Namespace


IConeFeature Methods

The IConeFeature type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IConeFeature Interface
VisualComponents.Create3D Namespace


IConeFeature Events

The IConeFeature type exposes the following members.

Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

IConeFeature Interface
VisualComponents.Create3D Namespace


IConnectingLinePoint Interface

Interface for adding additional points to the connecting lines service.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IConnectingLinePoint
public interface class IConnectingLinePoint

The IConnectingLinePoint type exposes the following members.

Properties
 | Name | Description
Public property | LinePositions | Gets the line positions in world coordinate system.
Top
Events
 | Name | Description
Public event | LinePositionsChanged | Event that is raised when the value of LinePositions changes.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IConnectingLinePoint Properties

The IConnectingLinePoint type exposes the following members.

Properties
 | Name | Description
Public property | LinePositions | Gets the line positions in world coordinate system.
Top
See Also

Reference

IConnectingLinePoint Interface
VisualComponents.Create3D Namespace


IConnectingLinePoint.LinePositions Property

IConnectingLinePointLinePositions Property

Gets the line positions in world coordinate system.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<Vector3> LinePositions { get; }
property ReadOnlyCollection<Vector3>^ LinePositions {
    ReadOnlyCollection<Vector3>^ get ();
}

Property Value

Type: ReadOnlyCollectionVector3
See Also

Reference

IConnectingLinePoint Interface
VisualComponents.Create3D Namespace


IConnectingLinePoint Events

The IConnectingLinePoint type exposes the following members.

Events
 | Name | Description
Public event | LinePositionsChanged | Event that is raised when the value of LinePositions changes.
Top
See Also

Reference

IConnectingLinePoint Interface
VisualComponents.Create3D Namespace


IConnectingLinePoint.LinePositionsChanged Event

IConnectingLinePointLinePositionsChanged Event

Event that is raised when the value of LinePositions changes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler LinePositionsChanged
 event EventHandler^ LinePositionsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IConnectingLinePoint Interface
VisualComponents.Create3D Namespace


IConnectingLinesService Interface

Service for rendering 3D polyline along robot's position frames. Polyline is rendered in the same order as position statements are executed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IConnectingLinesService
public interface class IConnectingLinesService

The IConnectingLinesService type exposes the following members.

Properties
 | Name | Description
Public property | LineNode | Native pointer to visualization containing the polyline.
Top
Methods
 | Name | Description
Public method | BeginUpdate | Disables automatic updating of polyline rendering.
Public method | EndUpdate | Enables automatic updating of polyline rendering.
Public method | EndUpdate(Boolean) | Enables automatic updating of polyline rendering, and invokes ShowLines().
Public method | GetFrameAt | Helper function for iterating position frames retrieved from the given IRoutine.
Public method | GetFrameAtClosestPosition | Helper function for finding a position frame closest to the vector position.
Public method | HideAllLines | Removes polyline from 3D world.
Public method | ShowLines(IRoutine) | Connects rootRoutine positions with a polyline. Adds polyline to 3D world.
Public method | ShowLines(IRoutine, Boolean) | Connects rootRoutine positions with a polyline. Adds polyline to 3D world.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IConnectingLinesService Properties

The IConnectingLinesService type exposes the following members.

Properties
 | Name | Description
Public property | LineNode | Native pointer to visualization containing the polyline.
Top
See Also

Reference

IConnectingLinesService Interface
VisualComponents.Create3D Namespace


IConnectingLinesService.LineNode Property

IConnectingLinesServiceLineNode Property

Native pointer to visualization containing the polyline.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IntPtr LineNode { get; }
property IntPtr LineNode {
    IntPtr get ();
}

Property Value

Type: IntPtr
See Also

Reference

IConnectingLinesService Interface
VisualComponents.Create3D Namespace


IConnectingLinesService Methods

The IConnectingLinesService type exposes the following members.

Methods
 | Name | Description
Public method | BeginUpdate | Disables automatic updating of polyline rendering.
Public method | EndUpdate | Enables automatic updating of polyline rendering.
Public method | EndUpdate(Boolean) | Enables automatic updating of polyline rendering, and invokes ShowLines().
Public method | GetFrameAt | Helper function for iterating position frames retrieved from the given IRoutine.
Public method | GetFrameAtClosestPosition | Helper function for finding a position frame closest to the vector position.
Public method | HideAllLines | Removes polyline from 3D world.
Public method | ShowLines(IRoutine) | Connects rootRoutine positions with a polyline. Adds polyline to 3D world.
Public method | ShowLines(IRoutine, Boolean) | Connects rootRoutine positions with a polyline. Adds polyline to 3D world.
Top
See Also

Reference

IConnectingLinesService Interface
VisualComponents.Create3D Namespace


IConnectingLinesService.BeginUpdate Method

IConnectingLinesServiceBeginUpdate Method

Disables automatic updating of polyline rendering.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void BeginUpdate()
void BeginUpdate()
See Also

Reference

IConnectingLinesService Interface
VisualComponents.Create3D Namespace


IConnectingLinesService.EndUpdate Method

IConnectingLinesServiceEndUpdate Method

Overload List
 | Name | Description
Public method | EndUpdate | Enables automatic updating of polyline rendering.
Public method | EndUpdate(Boolean) | Enables automatic updating of polyline rendering, and invokes ShowLines().
Top
See Also

Reference

IConnectingLinesService Interface
VisualComponents.Create3D Namespace


IConnectingLinesService.EndUpdate Method

IConnectingLinesServiceEndUpdate Method

Enables automatic updating of polyline rendering.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void EndUpdate()
void EndUpdate()
See Also

Reference

IConnectingLinesService Interface
EndUpdate Overload
VisualComponents.Create3D Namespace


IConnectingLinesService.EndUpdate Method (Boolean)

IConnectingLinesServiceEndUpdate Method (Boolean)

Enables automatic updating of polyline rendering, and invokes ShowLines().

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void EndUpdate(
    bool refresh
)
void EndUpdate(
    bool refresh
)

Parameters

refresh
Type: SystemBoolean
See Also

Reference

IConnectingLinesService Interface
EndUpdate Overload
VisualComponents.Create3D Namespace


IConnectingLinesService.GetFrameAt Method

IConnectingLinesServiceGetFrameAt Method

Helper function for iterating position frames retrieved from the given IRoutine.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPositionFrame GetFrameAt(
    int index
)
IPositionFrame^ GetFrameAt(
    int index
)

Parameters

index
Type: SystemInt32
Position frame index

Return Value

Type: IPositionFrame
Position frame retrieved from the given IRoutine
See Also

Reference

IConnectingLinesService Interface
VisualComponents.Create3D Namespace


IConnectingLinesService.GetFrameAtClosestPosition Method

IConnectingLinesServiceGetFrameAtClosestPosition Method

Helper function for finding a position frame closest to the vector position.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPositionFrame GetFrameAtClosestPosition(
    Vector3 vector
)
IPositionFrame^ GetFrameAtClosestPosition(
    Vector3 vector
)

Parameters

vector
Type: VisualComponents.Create3DVector3
3D position defined in world coordinates

Return Value

Type: IPositionFrame
Closest position frame
See Also

Reference

IConnectingLinesService Interface
VisualComponents.Create3D Namespace


IConnectingLinesService.HideAllLines Method

IConnectingLinesServiceHideAllLines Method

Removes polyline from 3D world.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void HideAllLines()
void HideAllLines()
See Also

Reference

IConnectingLinesService Interface
VisualComponents.Create3D Namespace


IConnectingLinesService.ShowLines Method

IConnectingLinesServiceShowLines Method

Overload List
 | Name | Description
Public method | ShowLines(IRoutine) | Connects rootRoutine positions with a polyline. Adds polyline to 3D world.
Public method | ShowLines(IRoutine, Boolean) | Connects rootRoutine positions with a polyline. Adds polyline to 3D world.
Top
See Also

Reference

IConnectingLinesService Interface
VisualComponents.Create3D Namespace


IConnectingLinesService.ShowLines Method (IRoutine)

IConnectingLinesServiceShowLines Method (IRoutine)

Connects rootRoutine positions with a polyline. Adds polyline to 3D world.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ShowLines(
    IRoutine rootRoutine
)
void ShowLines(
    IRoutine^ rootRoutine
)

Parameters

rootRoutine
Type: VisualComponents.Create3DIRoutine
Routine whose position statements to consider
See Also

Reference

IConnectingLinesService Interface
ShowLines Overload
VisualComponents.Create3D Namespace


IConnectingLinesService.ShowLines Method (IRoutine, Boolean)

IConnectingLinesServiceShowLines Method (IRoutine, Boolean)

Connects rootRoutine positions with a polyline. Adds polyline to 3D world.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ShowLines(
    IRoutine rootRoutine,
    bool showVisibleOnly
)
void ShowLines(
    IRoutine^ rootRoutine,
    bool showVisibleOnly
)

Parameters

rootRoutine
Type: VisualComponents.Create3DIRoutine
Routine whose position statements to consider
showVisibleOnly
Type: SystemBoolean
Indicates whether hidden position frames should be ignored or not
See Also

Reference

IConnectingLinesService Interface
ShowLines Overload
VisualComponents.Create3D Namespace


IConnectionEditorSection Interface

Configuration file section for Connection Editor Options.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IConnectionEditorSection : ISection
public interface class IConnectionEditorSection : ISection

The IConnectionEditorSection type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionEditorElement | Configuration file element for Connection Editor Options.
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | GetSection | Gets the section (Inherited from ISection.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IConnectionEditorSection Properties

The IConnectionEditorSection type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionEditorElement | Configuration file element for Connection Editor Options.
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
See Also

Reference

IConnectionEditorSection Interface
VisualComponents.Create3D Namespace


IConnectionEditorSection.ConnectionEditorElement Property

IConnectionEditorSectionConnectionEditorElement Property

Configuration file element for Connection Editor Options.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ConnectionEditorConfigElement ConnectionEditorElement { get; }
property ConnectionEditorConfigElement^ ConnectionEditorElement {
    ConnectionEditorConfigElement^ get ();
}

Property Value

Type: ConnectionEditorConfigElement
See Also

Reference

IConnectionEditorSection Interface
VisualComponents.Create3D Namespace


IConnectionEditorSection Methods

The IConnectionEditorSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | GetSection | Gets the section (Inherited from ISection.)
Top
See Also

Reference

IConnectionEditorSection Interface
VisualComponents.Create3D Namespace


IConsoleViewModel Interface

Output window printing interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IConsoleViewModel
public interface class IConsoleViewModel

The IConsoleViewModel type exposes the following members.

Properties
 | Name | Description
Public property | CollapseDuplicates | Whether to print duplicate messages.
Public property | IsAutoScrollEnabled | Defines if the console automatically scrolls to end when new content is added.
Top
Methods
 | Name | Description
Public method | AppendDebug | Debug printing. By default disabled with "ConsoleViewMessageLevel" config value.
Public method | AppendError(String) | Print in red color.
Public method | AppendError(String, Exception) | Print in red color.
Public method | AppendMessage | Print in black color.
Public method | AppendText | Deprecated. Same as AppendMessage.
Public method | Clear | Clear Output window.
Public method | ResetCollapseDuplicates | Force print next message, even if duplicate.
Public method | ShowError(String, String) | Internal helper method. Use VcMessageBox.Show() instead.
Public method | ShowError(String, String, Boolean, Boolean) | Internal helper method. Use VcMessageBox.Show() instead.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IConsoleViewModel Properties

The IConsoleViewModel type exposes the following members.

Properties
 | Name | Description
Public property | CollapseDuplicates | Whether to print duplicate messages.
Public property | IsAutoScrollEnabled | Defines if the console automatically scrolls to end when new content is added.
Top
See Also

Reference

IConsoleViewModel Interface
VisualComponents.Create3D Namespace


IConsoleViewModel.CollapseDuplicates Property

IConsoleViewModelCollapseDuplicates Property

Whether to print duplicate messages.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CollapseDuplicates { get; set; }
property bool CollapseDuplicates {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IConsoleViewModel Interface
VisualComponents.Create3D Namespace


IConsoleViewModel.IsAutoScrollEnabled Property

IConsoleViewModelIsAutoScrollEnabled Property

Defines if the console automatically scrolls to end when new content is added.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsAutoScrollEnabled { get; set; }
property bool IsAutoScrollEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IConsoleViewModel Interface
VisualComponents.Create3D Namespace


IConsoleViewModel Methods

The IConsoleViewModel type exposes the following members.

Methods
 | Name | Description
Public method | AppendDebug | Debug printing. By default disabled with "ConsoleViewMessageLevel" config value.
Public method | AppendError(String) | Print in red color.
Public method | AppendError(String, Exception) | Print in red color.
Public method | AppendMessage | Print in black color.
Public method | AppendText | Deprecated. Same as AppendMessage.
Public method | Clear | Clear Output window.
Public method | ResetCollapseDuplicates | Force print next message, even if duplicate.
Public method | ShowError(String, String) | Internal helper method. Use VcMessageBox.Show() instead.
Public method | ShowError(String, String, Boolean, Boolean) | Internal helper method. Use VcMessageBox.Show() instead.
Top
See Also

Reference

IConsoleViewModel Interface
VisualComponents.Create3D Namespace


IConsoleViewModel.AppendDebug Method

IConsoleViewModelAppendDebug Method

Debug printing. By default disabled with "ConsoleViewMessageLevel" config value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AppendDebug(
    string text
)
void AppendDebug(
    String^ text
)

Parameters

text
Type: SystemString
See Also

Reference

IConsoleViewModel Interface
VisualComponents.Create3D Namespace


IConsoleViewModel.AppendError Method

IConsoleViewModelAppendError Method

Overload List
 | Name | Description
Public method | AppendError(String) | Print in red color.
Public method | AppendError(String, Exception) | Print in red color.
Top
See Also

Reference

IConsoleViewModel Interface
VisualComponents.Create3D Namespace


IConsoleViewModel.AppendError Method (String)

IConsoleViewModelAppendError Method (String)

Print in red color.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AppendError(
    string text
)
void AppendError(
    String^ text
)

Parameters

text
Type: SystemString
See Also

Reference

IConsoleViewModel Interface
AppendError Overload
VisualComponents.Create3D Namespace


IConsoleViewModel.AppendError Method (String, Exception)

IConsoleViewModelAppendError Method (String, Exception)

Print in red color.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AppendError(
    string text,
    Exception ex
)
void AppendError(
    String^ text,
    Exception^ ex
)

Parameters

text
Type: SystemString
ex
Type: SystemException
See Also

Reference

IConsoleViewModel Interface
AppendError Overload
VisualComponents.Create3D Namespace


IConsoleViewModel.AppendMessage Method

IConsoleViewModelAppendMessage Method

Print in black color.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AppendMessage(
    string text
)
void AppendMessage(
    String^ text
)

Parameters

text
Type: SystemString
See Also

Reference

IConsoleViewModel Interface
VisualComponents.Create3D Namespace


IConsoleViewModel.AppendText Method

IConsoleViewModelAppendText Method

Deprecated. Same as AppendMessage.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AppendText(
    string text
)
void AppendText(
    String^ text
)

Parameters

text
Type: SystemString
See Also

Reference

IConsoleViewModel Interface
VisualComponents.Create3D Namespace


IConsoleViewModel.Clear Method

IConsoleViewModelClear Method

Clear Output window.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Clear()
void Clear()
See Also

Reference

IConsoleViewModel Interface
VisualComponents.Create3D Namespace


IConsoleViewModel.ResetCollapseDuplicates Method

IConsoleViewModelResetCollapseDuplicates Method

Force print next message, even if duplicate.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ResetCollapseDuplicates()
void ResetCollapseDuplicates()
See Also

Reference

IConsoleViewModel Interface
VisualComponents.Create3D Namespace


IConsoleViewModel.ShowError Method

IConsoleViewModelShowError Method

Overload List
 | Name | Description
Public method | ShowError(String, String) | Internal helper method. Use VcMessageBox.Show() instead.
Public method | ShowError(String, String, Boolean, Boolean) | Internal helper method. Use VcMessageBox.Show() instead.
Top
See Also

Reference

IConsoleViewModel Interface
VisualComponents.Create3D Namespace


IConsoleViewModel.ShowError Method (String, String)

IConsoleViewModelShowError Method (String, String)

Internal helper method. Use VcMessageBox.Show() instead.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ShowError(
    string message,
    string caption
)
void ShowError(
    String^ message,
    String^ caption
)

Parameters

message
Type: SystemString
caption
Type: SystemString
See Also

Reference

IConsoleViewModel Interface
ShowError Overload
VisualComponents.Create3D Namespace


IConsoleViewModel.ShowError Method (String, String, Boolean, Boolean)

IConsoleViewModelShowError Method (String, String, Boolean, Boolean)

Internal helper method. Use VcMessageBox.Show() instead.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ShowError(
    string message,
    string caption,
    bool printError,
    bool popupError
)
void ShowError(
    String^ message,
    String^ caption,
    bool printError,
    bool popupError
)

Parameters

message
Type: SystemString
caption
Type: SystemString
printError
Type: SystemBoolean
popupError
Type: SystemBoolean
See Also

Reference

IConsoleViewModel Interface
ShowError Overload
VisualComponents.Create3D Namespace


IContainerFiller Interface

An interface for container filler flow behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IContainerFiller : IFlowBehavior,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed
public interface class IContainerFiller : IFlowBehavior,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed

The IContainerFiller type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IContainerFiller Properties

The IContainerFiller type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IContainerFiller Interface
VisualComponents.Create3D Namespace


IContainerFiller Methods

The IContainerFiller type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IContainerFiller Interface
VisualComponents.Create3D Namespace


IContainerFiller Events

The IContainerFiller type exposes the following members.

Events
 | Name | Description
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IContainerFiller Interface
VisualComponents.Create3D Namespace


IContext Interface

Interface that represents an application context.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IContext
public interface class IContext

The IContext type exposes the following members.

Properties
 | Name | Description
Public property | Id | Context ID. Possible values can be found in Contexts static class.
Public property | IsActive | Determine if the context is active, hence, the current application context.
Public property | SupportedManipulationModes | Gets the list of manipulation modes that are allowed in this context.
Top
Methods
 | Name | Description
Public method | Activate | Activates the context making it this application context.
Public method | Deactivate | Deactivates this context.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IContext Properties

The IContext type exposes the following members.

Properties
 | Name | Description
Public property | Id | Context ID. Possible values can be found in Contexts static class.
Public property | IsActive | Determine if the context is active, hence, the current application context.
Public property | SupportedManipulationModes | Gets the list of manipulation modes that are allowed in this context.
Top
See Also

Reference

IContext Interface
VisualComponents.Create3D Namespace


IContext.Id Property

IContextId Property

Context ID. Possible values can be found in Contexts static class.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Id { get; }
property String^ Id {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IContext Interface
VisualComponents.Create3D Namespace


IContext.IsActive Property

IContextIsActive Property

Determine if the context is active, hence, the current application context.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsActive { get; }
property bool IsActive {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IContext Interface
VisualComponents.Create3D Namespace


IContext.SupportedManipulationModes Property

IContextSupportedManipulationModes Property

Gets the list of manipulation modes that are allowed in this context.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ManipulationMode> SupportedManipulationModes { get; }
property ReadOnlyCollection<ManipulationMode>^ SupportedManipulationModes {
    ReadOnlyCollection<ManipulationMode>^ get ();
}

Property Value

Type: ReadOnlyCollectionManipulationMode
See Also

Reference

IContext Interface
VisualComponents.Create3D Namespace


IContext Methods

The IContext type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the context making it this application context.
Public method | Deactivate | Deactivates this context.
Top
See Also

Reference

IContext Interface
VisualComponents.Create3D Namespace


IContext.Activate Method

IContextActivate Method

Activates the context making it this application context.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Activate()
void Activate()
See Also

Reference

IContext Interface
VisualComponents.Create3D Namespace


IContext.Deactivate Method

IContextDeactivate Method

Deactivates this context.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Deactivate()
void Deactivate()
See Also

Reference

IContext Interface
VisualComponents.Create3D Namespace


IContextSection Interface

Configuration file section for application context dependent Options.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IContextSection : ISection
public interface class IContextSection : ISection

The IContextSection type exposes the following members.

Properties
 | Name | Description
Public property | ContextConfiguration | Collection of context related options.
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | Contains | Determines whether an element is in the BaseContextConfigElement.
Public method | GetSection | Gets the section (Inherited from ISection.)
Public method | GetUserValue | Gets configuration file element for context option.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IContextSection Properties

The IContextSection type exposes the following members.

Properties
 | Name | Description
Public property | ContextConfiguration | Collection of context related options.
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
See Also

Reference

IContextSection Interface
VisualComponents.Create3D Namespace


IContextSection.ContextConfiguration Property

IContextSectionContextConfiguration Property

Collection of context related options.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ContextConfigCollection ContextConfiguration { get; }
property ContextConfigCollection^ ContextConfiguration {
    ContextConfigCollection^ get ();
}

Property Value

Type: ContextConfigCollection
See Also

Reference

IContextSection Interface
VisualComponents.Create3D Namespace


IContextSection Methods

The IContextSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | Contains | Determines whether an element is in the BaseContextConfigElement.
Public method | GetSection | Gets the section (Inherited from ISection.)
Public method | GetUserValue | Gets configuration file element for context option.
Top
See Also

Reference

IContextSection Interface
VisualComponents.Create3D Namespace


IContextSection.Contains Method

IContextSectionContains Method

Determines whether an element is in the BaseContextConfigElement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool Contains(
    string key
)
bool Contains(
    String^ key
)

Parameters

key
Type: SystemString
Native option key

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IContextSection.Contains(System.String)"]

See Also

Reference

IContextSection Interface
VisualComponents.Create3D Namespace


IContextSection.GetUserValue Method

IContextSectionGetUserValue Method

Gets configuration file element for context option.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
BaseContextConfigElement GetUserValue(
    string key
)
BaseContextConfigElement^ GetUserValue(
    String^ key
)

Parameters

key
Type: SystemString
Application context Id

Return Value

Type: BaseContextConfigElement
context dependent option element
See Also

Reference

IContextSection Interface
VisualComponents.Create3D Namespace


IContinueStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IContinueStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IContinueStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IContinueStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IContinueStatement Properties

The IContinueStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
See Also

Reference

IContinueStatement Interface
VisualComponents.Create3D Namespace


IContinueStatement Methods

The IContinueStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IContinueStatement Interface
VisualComponents.Create3D Namespace


IContinueStatement Events

The IContinueStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IContinueStatement Interface
VisualComponents.Create3D Namespace


ICreateProductStatement Interface

A statement for creating an ISimProduct instance from inside a PM process. Also see IProductCreator.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICreateProductStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class ICreateProductStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The ICreateProductStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Container | If this statement is used as a process statement, gets or sets the instance of IPropertyT to place the created ISimProduct into.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductType | The type of ISimProduct to create.
Public property | ProductVariableName | If this IStatement is used as a process statement, name of a Process variable that will hold a reference to the created ISimProduct instance.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ICreateProductStatement Properties

The ICreateProductStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Container | If this statement is used as a process statement, gets or sets the instance of IPropertyT to place the created ISimProduct into.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductType | The type of ISimProduct to create.
Public property | ProductVariableName | If this IStatement is used as a process statement, name of a Process variable that will hold a reference to the created ISimProduct instance.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
See Also

Reference

ICreateProductStatement Interface
VisualComponents.Create3D Namespace


ICreateProductStatement.Container Property

ICreateProductStatementContainer Property

If this statement is used as a process statement, gets or sets the instance of IPropertyT to place the created ISimProduct into.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IComponentContainer Container { get; set; }
property IComponentContainer^ Container {
    IComponentContainer^ get ();
    void set (IComponentContainer^ value);
}

Property Value

Type: IComponentContainer
See Also

Reference

ICreateProductStatement Interface
VisualComponents.Create3D Namespace


ICreateProductStatement.ProductType Property

ICreateProductStatementProductType Property

The type of ISimProduct to create.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProductType ProductType { get; set; }
property IProductType^ ProductType {
    IProductType^ get ();
    void set (IProductType^ value);
}

Property Value

Type: IProductType
See Also

Reference

ICreateProductStatement Interface
VisualComponents.Create3D Namespace


ICreateProductStatement.ProductVariableName Property

ICreateProductStatementProductVariableName Property

If this IStatement is used as a process statement, name of a Process variable that will hold a reference to the created ISimProduct instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ProductVariableName { get; set; }
property String^ ProductVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
The variable reference is resolved when the statement executes.
See Also

Reference

ICreateProductStatement Interface
VisualComponents.Create3D Namespace


ICreateProductStatement Methods

The ICreateProductStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ICreateProductStatement Interface
VisualComponents.Create3D Namespace


ICreateProductStatement Events

The ICreateProductStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

ICreateProductStatement Interface
VisualComponents.Create3D Namespace


ICurveTopology Interface

Curve topology interface for ILineSet

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICurveTopology
public interface class ICurveTopology

The ICurveTopology type exposes the following members.

Properties
 | Name | Description
Public property | CurveCount | total number of curves in all the curve loops in the geometry
Public property | Curves | List of ITopologyBaseCurve present in the line set
Top
Methods
 | Name | Description
Public method | AddCurve | Ads a curve to the line set. Remarks All tessellated curves in this geometry set will be delated after this.
Top
See Also

Reference

VisualComponents.Create3D Namespace


ICurveTopology Properties

The ICurveTopology type exposes the following members.

Properties
 | Name | Description
Public property | CurveCount | total number of curves in all the curve loops in the geometry
Public property | Curves | List of ITopologyBaseCurve present in the line set
Top
See Also

Reference

ICurveTopology Interface
VisualComponents.Create3D Namespace


ICurveTopology.CurveCount Property

ICurveTopologyCurveCount Property

total number of curves in all the curve loops in the geometry

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int CurveCount { get; }
property int CurveCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ICurveTopology Interface
VisualComponents.Create3D Namespace


ICurveTopology.Curves Property

ICurveTopologyCurves Property

List of ITopologyBaseCurve present in the line set

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ITopologyBaseCurve> Curves { get; }
property ReadOnlyCollection<ITopologyBaseCurve^>^ Curves {
    ReadOnlyCollection<ITopologyBaseCurve^>^ get ();
}

Property Value

Type: ReadOnlyCollectionITopologyBaseCurve
See Also

Reference

ICurveTopology Interface
VisualComponents.Create3D Namespace


ICurveTopology Methods

The ICurveTopology type exposes the following members.

Methods
 | Name | Description
Public method | AddCurve | Ads a curve to the line set. Remarks All tessellated curves in this geometry set will be delated after this.
Top
See Also

Reference

ICurveTopology Interface
VisualComponents.Create3D Namespace


ICurveTopology.AddCurve Method

ICurveTopologyAddCurve Method

Ads a curve to the line set.
Remarks
All tessellated curves in this geometry set will be delated after this.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool AddCurve(
    CurveBase curve
)
bool AddCurve(
    CurveBase^ curve
)

Parameters

curve
Type: VisualComponents.Create3DCurveBase
curve to be added

Return Value

Type: Boolean
true if succeeed
See Also

Reference

ICurveTopology Interface
VisualComponents.Create3D Namespace


ICustomBehavior Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICustomBehavior
public interface class ICustomBehavior

The ICustomBehavior type exposes the following members.

Methods
 | Name | Description
Public method | SetBehavior |
Top
See Also

Reference

VisualComponents.Create3D Namespace


ICustomBehavior Methods

The ICustomBehavior type exposes the following members.

Methods
 | Name | Description
Public method | SetBehavior |
Top
See Also

Reference

ICustomBehavior Interface
VisualComponents.Create3D Namespace


ICustomBehavior.SetBehavior Method

ICustomBehaviorSetBehavior Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetBehavior(
    IBehavior behavior
)
void SetBehavior(
    IBehavior^ behavior
)

Parameters

behavior
Type: VisualComponents.Create3DIBehavior
See Also

Reference

ICustomBehavior Interface
VisualComponents.Create3D Namespace


ICustomizationService Interface

It provides customization functionality

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICustomizationService
public interface class ICustomizationService

The ICustomizationService type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationName | Gets the Application Name.(aka Product Name)
Public property | ApplicationNameWithoutVersion | Gets the Application Name with out version number.(aka Product Name)
Public property | ApplicationVersion | Gets the Application Version.(aka Product version)
Public property | AssemblyVersion | Gets the Assembly Version.
Public property | EcatDownloadedCommonFolder | Gets the parent path containing the "eCat Downloaded" folders for all instances.
Public property | EcatDownloadedFolder | Gets the "eCat Downloaded" folder path for this instance.
Public property | IsResourceEmbedded | Returns true if the resource is embedded
Public property | MyAnimationsFolder | Get the "My Animations" folder
Public property | MyImageFolder | Get the "My Image" folder
Public property | MyMaterialsFolder | Gets the "My Materials" folder path
Public property | MyModelsFolder | Gets the "My Models" folder path
Public property | MyTemplatesFolder | Get the "My Templates" folder
Public property | MyVideosFolder | Gets the "My Videos" folder path
Public property | OfflinePublicModelsFolder | Gets the "Offline Public Models" folder path
Public property | PublicModelsFolder | Gets the "Public Models" folder path
Public property | ResourceLocation | Gets resource location path
Top
Methods
 | Name | Description
Public method | GetIconFilePath | Get absolute filename.
Public method | GetIconPath | Gets icon from Svg file.
Public method | GetImagePath | Gets an image path
Public method | GetResourceValue | Gets value from the resource
Top
See Also

Reference

VisualComponents.Create3D Namespace


ICustomizationService Properties

The ICustomizationService type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationName | Gets the Application Name.(aka Product Name)
Public property | ApplicationNameWithoutVersion | Gets the Application Name with out version number.(aka Product Name)
Public property | ApplicationVersion | Gets the Application Version.(aka Product version)
Public property | AssemblyVersion | Gets the Assembly Version.
Public property | EcatDownloadedCommonFolder | Gets the parent path containing the "eCat Downloaded" folders for all instances.
Public property | EcatDownloadedFolder | Gets the "eCat Downloaded" folder path for this instance.
Public property | IsResourceEmbedded | Returns true if the resource is embedded
Public property | MyAnimationsFolder | Get the "My Animations" folder
Public property | MyImageFolder | Get the "My Image" folder
Public property | MyMaterialsFolder | Gets the "My Materials" folder path
Public property | MyModelsFolder | Gets the "My Models" folder path
Public property | MyTemplatesFolder | Get the "My Templates" folder
Public property | MyVideosFolder | Gets the "My Videos" folder path
Public property | OfflinePublicModelsFolder | Gets the "Offline Public Models" folder path
Public property | PublicModelsFolder | Gets the "Public Models" folder path
Public property | ResourceLocation | Gets resource location path
Top
See Also

Reference

ICustomizationService Interface
VisualComponents.Create3D Namespace


ICustomizationService.ApplicationName Property

ICustomizationServiceApplicationName Property

Gets the Application Name.(aka Product Name)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ApplicationName { get; }
property String^ ApplicationName {
    String^ get ();
}

Property Value

Type: String
Remarks
Application name is displayed in application Title. It can be customized in appconfig file with a key "ProductInformation". But initial value is set in resource.xaml file using ProductName.
See Also

Reference

ICustomizationService Interface
VisualComponents.Create3D Namespace


ICustomizationService.ApplicationNameWithoutVersion Property

ICustomizationServiceApplicationNameWithoutVersion Property

Gets the Application Name with out version number.(aka Product Name)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ApplicationNameWithoutVersion { get; }
property String^ ApplicationNameWithoutVersion {
    String^ get ();
}

Property Value

Type: String
Remarks
Application name with out version is displayed in software update dialogue. It can be customized in appconfig file with a key "ProductInformationWithOutVersion". But initial value is set in resource.xaml file using ProductNameWithOutVersion.
See Also

Reference

ICustomizationService Interface
VisualComponents.Create3D Namespace


ICustomizationService.ApplicationVersion Property

ICustomizationServiceApplicationVersion Property

Gets the Application Version.(aka Product version)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ApplicationVersion { get; }
property String^ ApplicationVersion {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ICustomizationService Interface
VisualComponents.Create3D Namespace


ICustomizationService.AssemblyVersion Property

ICustomizationServiceAssemblyVersion Property

Gets the Assembly Version.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string AssemblyVersion { get; }
property String^ AssemblyVersion {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ICustomizationService Interface
VisualComponents.Create3D Namespace


ICustomizationService.EcatDownloadedCommonFolder Property

ICustomizationServiceEcatDownloadedCommonFolder Property

Gets the parent path containing the "eCat Downloaded" folders for all instances.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string EcatDownloadedCommonFolder { get; }
property String^ EcatDownloadedCommonFolder {
    String^ get ();
}

Property Value

Type: String
Remarks
This is used to filter out files cached by other running instances.
See Also

Reference

ICustomizationService Interface
VisualComponents.Create3D Namespace


ICustomizationService.EcatDownloadedFolder Property

ICustomizationServiceEcatDownloadedFolder Property

Gets the "eCat Downloaded" folder path for this instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string EcatDownloadedFolder { get; }
property String^ EcatDownloadedFolder {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ICustomizationService Interface
VisualComponents.Create3D Namespace


ICustomizationService.IsResourceEmbedded Property

ICustomizationServiceIsResourceEmbedded Property

Returns true if the resource is embedded

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsResourceEmbedded { get; }
property bool IsResourceEmbedded {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ICustomizationService Interface
VisualComponents.Create3D Namespace


ICustomizationService.MyAnimationsFolder Property

ICustomizationServiceMyAnimationsFolder Property

Get the "My Animations" folder

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string MyAnimationsFolder { get; }
property String^ MyAnimationsFolder {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ICustomizationService Interface
VisualComponents.Create3D Namespace


ICustomizationService.MyImageFolder Property

ICustomizationServiceMyImageFolder Property

Get the "My Image" folder

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string MyImageFolder { get; }
property String^ MyImageFolder {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ICustomizationService Interface
VisualComponents.Create3D Namespace


ICustomizationService.MyMaterialsFolder Property

ICustomizationServiceMyMaterialsFolder Property

Gets the "My Materials" folder path

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string MyMaterialsFolder { get; }
property String^ MyMaterialsFolder {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ICustomizationService Interface
VisualComponents.Create3D Namespace


ICustomizationService.MyModelsFolder Property

ICustomizationServiceMyModelsFolder Property

Gets the "My Models" folder path

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string MyModelsFolder { get; }
property String^ MyModelsFolder {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ICustomizationService Interface
VisualComponents.Create3D Namespace


ICustomizationService.MyTemplatesFolder Property

ICustomizationServiceMyTemplatesFolder Property

Get the "My Templates" folder

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string MyTemplatesFolder { get; }
property String^ MyTemplatesFolder {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ICustomizationService Interface
VisualComponents.Create3D Namespace


ICustomizationService.MyVideosFolder Property

ICustomizationServiceMyVideosFolder Property

Gets the "My Videos" folder path

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string MyVideosFolder { get; }
property String^ MyVideosFolder {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ICustomizationService Interface
VisualComponents.Create3D Namespace


ICustomizationService.OfflinePublicModelsFolder Property

ICustomizationServiceOfflinePublicModelsFolder Property

Gets the "Offline Public Models" folder path

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string OfflinePublicModelsFolder { get; }
property String^ OfflinePublicModelsFolder {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ICustomizationService Interface
VisualComponents.Create3D Namespace


ICustomizationService.PublicModelsFolder Property

ICustomizationServicePublicModelsFolder Property

Gets the "Public Models" folder path

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string PublicModelsFolder { get; set; }
property String^ PublicModelsFolder {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ICustomizationService Interface
VisualComponents.Create3D Namespace


ICustomizationService.ResourceLocation Property

ICustomizationServiceResourceLocation Property

Gets resource location path

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ResourceLocation { get; }
property String^ ResourceLocation {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ICustomizationService Interface
VisualComponents.Create3D Namespace


ICustomizationService Methods

The ICustomizationService type exposes the following members.

Methods
 | Name | Description
Public method | GetIconFilePath | Get absolute filename.
Public method | GetIconPath | Gets icon from Svg file.
Public method | GetImagePath | Gets an image path
Public method | GetResourceValue | Gets value from the resource
Top
See Also

Reference

ICustomizationService Interface
VisualComponents.Create3D Namespace


ICustomizationService.GetIconFilePath Method

ICustomizationServiceGetIconFilePath Method

Get absolute filename.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string GetIconFilePath(
    string fileName
)
String^ GetIconFilePath(
    String^ fileName
)

Parameters

fileName
Type: SystemString

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.ICustomizationService.GetIconFilePath(System.String)"]

See Also

Reference

ICustomizationService Interface
VisualComponents.Create3D Namespace


ICustomizationService.GetIconPath Method

ICustomizationServiceGetIconPath Method

Gets icon from Svg file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string GetIconPath(
    string fileName
)
String^ GetIconPath(
    String^ fileName
)

Parameters

fileName
Type: SystemString
svg file name

Return Value

Type: String
Icon path
See Also

Reference

ICustomizationService Interface
VisualComponents.Create3D Namespace


ICustomizationService.GetImagePath Method

ICustomizationServiceGetImagePath Method

Gets an image path

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string GetImagePath(
    string fileName
)
String^ GetImagePath(
    String^ fileName
)

Parameters

fileName
Type: SystemString
image file name

Return Value

Type: String
resource image path
See Also

Reference

ICustomizationService Interface
VisualComponents.Create3D Namespace


ICustomizationService.GetResourceValue Method

ICustomizationServiceGetResourceValue Method

Gets value from the resource

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string GetResourceValue(
    string resourceKey
)
String^ GetResourceValue(
    String^ resourceKey
)

Parameters

resourceKey
Type: SystemString
resource key

Return Value

Type: String
resource value
See Also

Reference

ICustomizationService Interface
VisualComponents.Create3D Namespace


ICustomScopeStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICustomScopeStatement : IStatementScope,
    IInterpolatable, IApiType
public interface class ICustomScopeStatement : IStatementScope,
    IInterpolatable, IApiType

The ICustomScopeStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | IsLoop |
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
Methods
 | Name | Description
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ICustomScopeStatement Properties

The ICustomScopeStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | IsLoop |
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
See Also

Reference

ICustomScopeStatement Interface
VisualComponents.Create3D Namespace


ICustomScopeStatement.IsLoop Property

ICustomScopeStatementIsLoop Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsLoop { set; }
property bool IsLoop {
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ICustomScopeStatement Interface
VisualComponents.Create3D Namespace


ICustomScopeStatement Methods

The ICustomScopeStatement type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
See Also

Reference

ICustomScopeStatement Interface
VisualComponents.Create3D Namespace


ICustomScopeStatement Events

The ICustomScopeStatement type exposes the following members.

Events
 | Name | Description
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

ICustomScopeStatement Interface
VisualComponents.Create3D Namespace


ICustomSnapper Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICustomSnapper
public interface class ICustomSnapper

The ICustomSnapper type exposes the following members.

Methods
 | Name | Description
Public method | CustomRender |
Public method | CustomSnap |
Public method | GetCustomGeometry |
Top
See Also

Reference

VisualComponents.Create3D Namespace


ICustomSnapper Methods

The ICustomSnapper type exposes the following members.

Methods
 | Name | Description
Public method | CustomRender |
Public method | CustomSnap |
Public method | GetCustomGeometry |
Top
See Also

Reference

ICustomSnapper Interface
VisualComponents.Create3D Namespace


ICustomSnapper.CustomRender Method

ICustomSnapperCustomRender Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CustomRender(
    SnapResult result,
    int subMeshIndex,
    ref Geometry3D mesh,
    ref Color color
)
bool CustomRender(
    SnapResult result,
    int subMeshIndex,
    Geometry3D^% mesh,
    Color% color
)

Parameters

result
Type: VisualComponents.Create3DSnapResult
subMeshIndex
Type: SystemInt32
mesh
Type: System.Windows.Media.Media3DGeometry3D
color
Type: System.Windows.MediaColor

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ICustomSnapper.CustomRender(VisualComponents.Create3D.SnapResult,System.Int32,System.Windows.Media.Media3D.Geometry3D@,System.Windows.Media.Color@)"]

See Also

Reference

ICustomSnapper Interface
VisualComponents.Create3D Namespace


ICustomSnapper.CustomSnap Method

ICustomSnapperCustomSnap Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Nullable<SnapResult> CustomSnap(
    int x,
    int y,
    SnapResult[] baseResults
)
Nullable<SnapResult> CustomSnap(
    int x,
    int y,
    array<SnapResult>^ baseResults
)

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
baseResults
Type: VisualComponents.Create3DSnapResult

Return Value

Type: NullableSnapResult

[Missing <returns> documentation for "M:VisualComponents.Create3D.ICustomSnapper.CustomSnap(System.Int32,System.Int32,VisualComponents.Create3D.SnapResult[])"]

See Also

Reference

ICustomSnapper Interface
VisualComponents.Create3D Namespace


ICustomSnapper.GetCustomGeometry Method

ICustomSnapperGetCustomGeometry Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string[] GetCustomGeometry()
array<String^>^ GetCustomGeometry()

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.ICustomSnapper.GetCustomGeometry"]

See Also

Reference

ICustomSnapper Interface
VisualComponents.Create3D Namespace


ICustomStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICustomStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class ICustomStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The ICustomStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetStatement |
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ICustomStatement Properties

The ICustomStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
See Also

Reference

ICustomStatement Interface
VisualComponents.Create3D Namespace


ICustomStatement Methods

The ICustomStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetStatement |
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ICustomStatement Interface
VisualComponents.Create3D Namespace


ICustomStatement.SetStatement Method

ICustomStatementSetStatement Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetStatement(
    IStatement statement
)
void SetStatement(
    IStatement^ statement
)

Parameters

statement
Type: VisualComponents.Create3DIStatement
See Also

Reference

ICustomStatement Interface
VisualComponents.Create3D Namespace


ICustomStatement Events

The ICustomStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

ICustomStatement Interface
VisualComponents.Create3D Namespace


ICustomTypeWrapper Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICustomTypeWrapper
public interface class ICustomTypeWrapper

The ICustomTypeWrapper type exposes the following members.

Properties
 | Name | Description
Public property | CustomTypeName |
Top
See Also

Reference

VisualComponents.Create3D Namespace


ICustomTypeWrapper Properties

The ICustomTypeWrapper type exposes the following members.

Properties
 | Name | Description
Public property | CustomTypeName |
Top
See Also

Reference

ICustomTypeWrapper Interface
VisualComponents.Create3D Namespace


ICustomTypeWrapper.CustomTypeName Property

ICustomTypeWrapperCustomTypeName Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string CustomTypeName { get; set; }
property String^ CustomTypeName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ICustomTypeWrapper Interface
VisualComponents.Create3D Namespace


ICycleTimeService Interface

A service that provides the cycle time for a range of statements.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICycleTimeService : IDisposable
public interface class ICycleTimeService : IDisposable

The ICycleTimeService type exposes the following members.

Properties
 | Name | Description
Public property | CycleDuration | The cycle duration for a range of statements.
Public property | HasFirstMeasurementStarted | The start statement has been hit at least once.
Public property | IsFirstMeasurementReady | The end statement has been hit at least once.
Public property | RangeEnd | The statement defining the end of the range. The duration timing stops when this statement stops executing.
Public property | RangeStart | The statement defining the start of the range. The duration timing starts when this statement starts executing.
Top
Methods
 | Name | Description
Public method | Clear | Resets the timer and the cycle defining statements.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Reset | Resets the timer only (keeps cycle defining statements).
Top
See Also

Reference

VisualComponents.Create3D Namespace


ICycleTimeService Properties

The ICycleTimeService type exposes the following members.

Properties
 | Name | Description
Public property | CycleDuration | The cycle duration for a range of statements.
Public property | HasFirstMeasurementStarted | The start statement has been hit at least once.
Public property | IsFirstMeasurementReady | The end statement has been hit at least once.
Public property | RangeEnd | The statement defining the end of the range. The duration timing stops when this statement stops executing.
Public property | RangeStart | The statement defining the start of the range. The duration timing starts when this statement starts executing.
Top
See Also

Reference

ICycleTimeService Interface
VisualComponents.Create3D Namespace


ICycleTimeService.CycleDuration Property

ICycleTimeServiceCycleDuration Property

The cycle duration for a range of statements.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double CycleDuration { get; }
property double CycleDuration {
    double get ();
}

Return Value

Type: Double
If only the start statement has been hit: a running total. If one or more laps have been completed: the previous completed lap duration. If the start statement has not been hit or if there is no start or end statement: -1.0.
See Also

Reference

ICycleTimeService Interface
VisualComponents.Create3D Namespace


ICycleTimeService.HasFirstMeasurementStarted Property

ICycleTimeServiceHasFirstMeasurementStarted Property

The start statement has been hit at least once.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool HasFirstMeasurementStarted { get; }
property bool HasFirstMeasurementStarted {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ICycleTimeService Interface
VisualComponents.Create3D Namespace


ICycleTimeService.IsFirstMeasurementReady Property

ICycleTimeServiceIsFirstMeasurementReady Property

The end statement has been hit at least once.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsFirstMeasurementReady { get; }
property bool IsFirstMeasurementReady {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ICycleTimeService Interface
VisualComponents.Create3D Namespace


ICycleTimeService.RangeEnd Property

ICycleTimeServiceRangeEnd Property

The statement defining the end of the range. The duration timing stops when this statement stops executing.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatement RangeEnd { get; set; }
property IStatement^ RangeEnd {
    IStatement^ get ();
    void set (IStatement^ value);
}

Property Value

Type: IStatement
See Also

Reference

ICycleTimeService Interface
VisualComponents.Create3D Namespace


ICycleTimeService.RangeStart Property

ICycleTimeServiceRangeStart Property

The statement defining the start of the range. The duration timing starts when this statement starts executing.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatement RangeStart { get; set; }
property IStatement^ RangeStart {
    IStatement^ get ();
    void set (IStatement^ value);
}

Property Value

Type: IStatement
See Also

Reference

ICycleTimeService Interface
VisualComponents.Create3D Namespace


ICycleTimeService Methods

The ICycleTimeService type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Resets the timer and the cycle defining statements.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Reset | Resets the timer only (keeps cycle defining statements).
Top
See Also

Reference

ICycleTimeService Interface
VisualComponents.Create3D Namespace


ICycleTimeService.Clear Method

ICycleTimeServiceClear Method

Resets the timer and the cycle defining statements.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Clear()
void Clear()
See Also

Reference

ICycleTimeService Interface
VisualComponents.Create3D Namespace


ICycleTimeService.Reset Method

ICycleTimeServiceReset Method

Resets the timer only (keeps cycle defining statements).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Reset()
void Reset()
See Also

Reference

ICycleTimeService Interface
VisualComponents.Create3D Namespace


ICylinderFeature Interface

Cylinder feature interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICylinderFeature : IPrimitiveFeature,
    IFeature, IVisualObject, INamed, IWrapper, IDisposable,
    IVisitable, IPropertyContainer, IBatchModeObject, ISharedCloneable
public interface class ICylinderFeature : IPrimitiveFeature,
    IFeature, IVisualObject, INamed, IWrapper, IDisposable,
    IVisitable, IPropertyContainer, IBatchModeObject, ISharedCloneable

The ICylinderFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
The Cylinder geometry primitive generates a cylinder of the specified height and radius.
See Also

Reference

VisualComponents.Create3D Namespace


ICylinderFeature Properties

The ICylinderFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
See Also

Reference

ICylinderFeature Interface
VisualComponents.Create3D Namespace


ICylinderFeature Methods

The ICylinderFeature type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ICylinderFeature Interface
VisualComponents.Create3D Namespace


ICylinderFeature Events

The ICylinderFeature type exposes the following members.

Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

ICylinderFeature Interface
VisualComponents.Create3D Namespace


Ideas Enumeration

I-deas -> Up to 13.x (NX 5), NX I-deas 6

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum Ideas
public enum class Ideas
Members
Member name | Value | Description
MF1 | 0 |
ARC | 1 |
UNV | 2 |
PKG | 3 |
See Also

Reference

VisualComponents.Create3D Namespace


IDelayStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDelayStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IDelayStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IDelayStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | Delay |
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IDelayStatement Properties

The IDelayStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | Delay |
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
See Also

Reference

IDelayStatement Interface
VisualComponents.Create3D Namespace


IDelayStatement.Delay Property

IDelayStatementDelay Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Delay { get; set; }
property double Delay {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IDelayStatement Interface
VisualComponents.Create3D Namespace


IDelayStatement Methods

The IDelayStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IDelayStatement Interface
VisualComponents.Create3D Namespace


IDelayStatement Events

The IDelayStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IDelayStatement Interface
VisualComponents.Create3D Namespace


IDeltaKinematics Interface

An interface for delta kinematics behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDeltaKinematics : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IDeltaKinematics : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IDeltaKinematics type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IDeltaKinematics Properties

The IDeltaKinematics type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IDeltaKinematics Interface
VisualComponents.Create3D Namespace


IDeltaKinematics Methods

The IDeltaKinematics type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IDeltaKinematics Interface
VisualComponents.Create3D Namespace


IDeltaKinematics Events

The IDeltaKinematics type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IDeltaKinematics Interface
VisualComponents.Create3D Namespace


IdentityMap Class

Internal wrapper utility class.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DIdentityMap

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class IdentityMap
public ref class IdentityMap abstract sealed

The IdentityMap type exposes the following members.

Methods
Name | Description
Clear |
ClearDeleted | Remove invalidated wrapper references from list.
GetOrCreateT(IntPtr) | Retrieves a wrapper for a native object. If there is no wrapper, one will be created using the IntPtr constructor of T.
GetOrCreateT(IntPtr, FuncIntPtr, T) | Retrieves a wrapper for a native object. If there is no wrapper, one will be created using the given creation method.
GetOrCreateNoProxiesT | Get or create wrapper object without attaching debug proxies.
RemoveWrapperIdentity | Remove wrapper from list.
Top
Remarks

This class manages wrapper instances to Revolution.dll native objects, so that there is only one wrapper instance for each object at any one time.

The wrapper objects must implement IWrapper, and they are stored with weak references, so they may be garbage collected if there are no other instances. This allows native objects that are kept alive only by being referenced from the .NET side to be cleaned up.

See Also

Reference

VisualComponents.Create3D Namespace


IdentityMap Methods

The IdentityMap type exposes the following members.

Methods
Name | Description
Clear |
ClearDeleted | Remove invalidated wrapper references from list.
GetOrCreateT(IntPtr) | Retrieves a wrapper for a native object. If there is no wrapper, one will be created using the IntPtr constructor of T.
GetOrCreateT(IntPtr, FuncIntPtr, T) | Retrieves a wrapper for a native object. If there is no wrapper, one will be created using the given creation method.
GetOrCreateNoProxiesT | Get or create wrapper object without attaching debug proxies.
RemoveWrapperIdentity | Remove wrapper from list.
Top
See Also

Reference

IdentityMap Class
VisualComponents.Create3D Namespace


IdentityMap.Clear Method

IdentityMapClear Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void Clear()
public:
static void Clear()
See Also

Reference

IdentityMap Class
VisualComponents.Create3D Namespace


IdentityMap.ClearDeleted Method

IdentityMapClearDeleted Method

Remove invalidated wrapper references from list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int ClearDeleted()
public:
static int ClearDeleted()

Return Value

Type: Int32
Number of wrapper entries removed.
See Also

Reference

IdentityMap Class
VisualComponents.Create3D Namespace


IdentityMap.GetOrCreate Method

IdentityMapGetOrCreate Method

Overload List
Name | Description
GetOrCreateT(IntPtr) | Retrieves a wrapper for a native object. If there is no wrapper, one will be created using the IntPtr constructor of T.
GetOrCreateT(IntPtr, FuncIntPtr, T) | Retrieves a wrapper for a native object. If there is no wrapper, one will be created using the given creation method.
Top
See Also

Reference

IdentityMap Class
VisualComponents.Create3D Namespace


IdentityMap.GetOrCreate(T) Method (IntPtr)

IdentityMapGetOrCreateT Method (IntPtr)

Retrieves a wrapper for a native object. If there is no wrapper, one will be created using the IntPtr constructor of T.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static T GetOrCreate<T>(
    IntPtr pointer
)
where T : IWrapper

public:
generic<typename T>
where T : IWrapper
static T GetOrCreate(
    IntPtr pointer
)

Parameters

pointer
Type: SystemIntPtr
Pointer to native object.

Type Parameters

T
Object wrapper type.

Return Value

Type: T
Wrapper instance.
Remarks
Slower version to use from c++/cli as Func<IntPtr, T> can't be created in c++/cli. This method requires that T has a constructor that accepts a single IntPtr argument.
See Also

Reference

IdentityMap Class
GetOrCreate Overload
VisualComponents.Create3D Namespace


IdentityMap.GetOrCreate(T) Method (IntPtr, Func(IntPtr, T))

IdentityMapGetOrCreateT Method (IntPtr, FuncIntPtr, T)

Retrieves a wrapper for a native object. If there is no wrapper, one will be created using the given creation method.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static T GetOrCreate<T>(
    IntPtr nativeObject,
    Func<IntPtr, T> creationMethod
)
where T : IWrapper

public:
generic<typename T>
where T : IWrapper
static T GetOrCreate(
    IntPtr nativeObject,
    Func<IntPtr, T>^ creationMethod
)

Parameters

nativeObject
Type: SystemIntPtr
Pointer to native object.
creationMethod
Type: SystemFuncIntPtr, T
Wrapper creation method.

Type Parameters

T
Object wrapper type.

Return Value

Type: T
Wrapper instance.
See Also

Reference

IdentityMap Class
GetOrCreate Overload
VisualComponents.Create3D Namespace


IdentityMap.GetOrCreateNoProxies(T) Method

IdentityMapGetOrCreateNoProxiesT Method

Get or create wrapper object without attaching debug proxies.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static T GetOrCreateNoProxies<T>(
    IntPtr nativeObject,
    Func<IntPtr, T> creationMethod
)
where T : IWrapper

public:
generic<typename T>
where T : IWrapper
static T GetOrCreateNoProxies(
    IntPtr nativeObject,
    Func<IntPtr, T>^ creationMethod
)

Parameters

nativeObject
Type: SystemIntPtr
Pointer to native object.
creationMethod
Type: SystemFuncIntPtr, T
Wrapper creation method.

Type Parameters

T
Object wrapper type.

Return Value

Type: T

[Missing <returns> documentation for "M:VisualComponents.Create3D.IdentityMap.GetOrCreateNoProxies``1(System.IntPtr,System.Func{System.IntPtr,``0})"]

See Also

Reference

IdentityMap Class
VisualComponents.Create3D Namespace


IdentityMap.RemoveWrapperIdentity Method

IdentityMapRemoveWrapperIdentity Method

Remove wrapper from list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void RemoveWrapperIdentity(
    IWrapper wrapper
)
public:
static void RemoveWrapperIdentity(
    IWrapper^ wrapper
)

Parameters

wrapper
Type: VisualComponents.Create3DIWrapper
Wrapper instance to remove
Remarks

This method removes all type mappings that point to the given wrapper instance.

This is typically triggered by rObject::InvalidateWrappers, when the native object is deleted. The only exception is PropertyWrappers for dynamically created/loaded properties. Those wrappers increase the reference count of native variable and force keep it in memory, until wrapper is collected by garbage collector, or until IdentityMap is cleared (and wrapper's Dispose() and ReleaseNativeResources() methods are called).

See Also

Reference

IdentityMap Class
VisualComponents.Create3D Namespace


IDerivedProperty Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDerivedProperty
public interface class IDerivedProperty

The IDerivedProperty type exposes the following members.

Methods
 | Name | Description
Public method | UpdateDerivedValue |
Top
See Also

Reference

VisualComponents.Create3D Namespace


IDerivedProperty Methods

The IDerivedProperty type exposes the following members.

Methods
 | Name | Description
Public method | UpdateDerivedValue |
Top
See Also

Reference

IDerivedProperty Interface
VisualComponents.Create3D Namespace


IDerivedProperty.UpdateDerivedValue Method

IDerivedPropertyUpdateDerivedValue Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateDerivedValue()
void UpdateDerivedValue()
See Also

Reference

IDerivedProperty Interface
VisualComponents.Create3D Namespace


IDetachProductStatement Interface

A statement to child detach ISimProduct(s) from a parent ISimProduct.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDetachProductStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IDetachProductStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IDetachProductStatement type exposes the following members.

Properties
 | Name | Description
Public property | AcceptAllProductTypes | Whether to accept ISimProducts of any IProductType regardless of the other settings. Filters the ISimProduct instance(s) to detach.
Public property | AcceptedFlowGroups | An editable list of explicitly accepted IProcessFlowGroups. Filters the ISimProduct instance(s) to detach.
Public property | AcceptedProductTypes | An editable list of explicitly accepted IProductTypes. Filters the ISimProduct instance(s) to detach.
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | DetachedProductVariableName | Name of Process variable where a reference to the detached ISimProduct instance(s) will be stored by this statement.
Public property | DetachMany | If True, all ISimProduct instances that match the filtering rules defined in this IDetachProductStatement are detached. If false, only the first match is detached.
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentProductVariableName | Name of the Process variable that holds reference to the parent ISimProduct instance.
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IDetachProductStatement Properties

The IDetachProductStatement type exposes the following members.

Properties
 | Name | Description
Public property | AcceptAllProductTypes | Whether to accept ISimProducts of any IProductType regardless of the other settings. Filters the ISimProduct instance(s) to detach.
Public property | AcceptedFlowGroups | An editable list of explicitly accepted IProcessFlowGroups. Filters the ISimProduct instance(s) to detach.
Public property | AcceptedProductTypes | An editable list of explicitly accepted IProductTypes. Filters the ISimProduct instance(s) to detach.
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | DetachedProductVariableName | Name of Process variable where a reference to the detached ISimProduct instance(s) will be stored by this statement.
Public property | DetachMany | If True, all ISimProduct instances that match the filtering rules defined in this IDetachProductStatement are detached. If false, only the first match is detached.
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentProductVariableName | Name of the Process variable that holds reference to the parent ISimProduct instance.
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
See Also

Reference

IDetachProductStatement Interface
VisualComponents.Create3D Namespace


IDetachProductStatement.AcceptAllProductTypes Property

IDetachProductStatementAcceptAllProductTypes Property

Whether to accept ISimProducts of any IProductType regardless of the other settings. Filters the ISimProduct instance(s) to detach.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool AcceptAllProductTypes { get; set; }
property bool AcceptAllProductTypes {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IDetachProductStatement Interface
VisualComponents.Create3D Namespace


IDetachProductStatement.AcceptedFlowGroups Property

IDetachProductStatementAcceptedFlowGroups Property

An editable list of explicitly accepted IProcessFlowGroups. Filters the ISimProduct instance(s) to detach.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IProcessFlowGroup> AcceptedFlowGroups { get; }
property IList<IProcessFlowGroup^>^ AcceptedFlowGroups {
    IList<IProcessFlowGroup^>^ get ();
}

Property Value

Type: IListIProcessFlowGroup
See Also

Reference

IDetachProductStatement Interface
VisualComponents.Create3D Namespace


IDetachProductStatement.AcceptedProductTypes Property

IDetachProductStatementAcceptedProductTypes Property

An editable list of explicitly accepted IProductTypes. Filters the ISimProduct instance(s) to detach.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IProductType> AcceptedProductTypes { get; }
property IList<IProductType^>^ AcceptedProductTypes {
    IList<IProductType^>^ get ();
}

Property Value

Type: IListIProductType
See Also

Reference

IDetachProductStatement Interface
VisualComponents.Create3D Namespace


IDetachProductStatement.DetachedProductVariableName Property

IDetachProductStatementDetachedProductVariableName Property

Name of Process variable where a reference to the detached ISimProduct instance(s) will be stored by this statement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string DetachedProductVariableName { get; set; }
property String^ DetachedProductVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
The variable will be created if needed when this statement executes.
See Also

Reference

IDetachProductStatement Interface
VisualComponents.Create3D Namespace


IDetachProductStatement.DetachMany Property

IDetachProductStatementDetachMany Property

If True, all ISimProduct instances that match the filtering rules defined in this IDetachProductStatement are detached.

If false, only the first match is detached.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool DetachMany { get; set; }
property bool DetachMany {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IDetachProductStatement Interface
VisualComponents.Create3D Namespace


IDetachProductStatement.ParentProductVariableName Property

IDetachProductStatementParentProductVariableName Property

Name of the Process variable that holds reference to the parent ISimProduct instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ParentProductVariableName { get; set; }
property String^ ParentProductVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IDetachProductStatement Interface
VisualComponents.Create3D Namespace


IDetachProductStatement Methods

The IDetachProductStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IDetachProductStatement Interface
VisualComponents.Create3D Namespace


IDetachProductStatement Events

The IDetachProductStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IDetachProductStatement Interface
VisualComponents.Create3D Namespace


IDimension Interface

Dimension layout item interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDimension : IVisualObject,
    INamed, IWrapper, IDisposable, ILayoutItem, IPropertyContainer,
    IBatchModeObject
public interface class IDimension : IVisualObject,
    INamed, IWrapper, IDisposable, ILayoutItem, IPropertyContainer,
    IBatchModeObject

The IDimension type exposes the following members.

Properties
 | Name | Description
Public property | AngleCenter |
Public property | ArrowMaterial | Optional IMaterial for arrows. If null normal Material is used.
Public property | ArrowSize | size of the arrow in the dimension
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | Center |
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CustomText | Text set by the user. Will be shown if UseCustomText property is set to True
Public property | Dimension | Dimension value
Public property | Direction1 | In case of angular dimension, the direction of the edge of the first attached point
Public property | Direction2 | In case of angular dimension, the direction of the edge of the second attached point
Public property | Drawing1 | First attachment point. Setting a Drawing1 will cause Node1 to be null
Public property | Drawing2 | Second attachment point. Setting a Drawing2 will cause Node2 to be null
Public property | Geometry | Retrieves all geometry generated by the dimension
Public property | Height | Font height of the dimension text
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsMinAngle | Determines whether, in case of angular dimensions, the minimun angle will be shown
Public property | IsPersistent | Defines if the ILayoutItem is stored with the layout. (Inherited from ILayoutItem.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | LineWidth | width of the lines in the dimension
Public property | Material | IMaterial used in the geometry of the dimension
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node1 | First attachment point. Setting a Node1 will cause Drawing1 to be null
Public property | Node2 | Second attachment point. Setting a Node2 will cause Drawing2 to be null
Public property | NodePosition1 | Position of the first attachment point visual object
Public property | NodePosition1InWorld | Retrieves the first attachemnt position in world coordinates
Public property | NodePosition2 | Position of the second attachment point visual object
Public property | NodePosition2InWorld | Retrieves the second attachemnt position in world coordinates
Public property | Normal1 | In case of angular dimension, this vector represents the normal of the surface of the first attached point
Public property | Normal2 | In case of angular dimension, this vector represents the normal of the surface of the second attached point
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RenderAsMeasure | Determines whether the dimension should behaves as a measurement tool, it will show more information (only for linear dimension).
Public property | ScaleFactor | Scale factor used when calculating the dimension value
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | TextPosition | Dimension's text position
Public property | Thickness | Font boldness of the dimension text
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IVisualObject.)
Public property | TransformationInWorld | Gets or sets the world transformation matrix (Inherited from IVisualObject.)
Public property | Type | Dimension's type
Public property | UseCustomText | Defines whether CustomText will be shown instead of the calculated dimension
Public property | VisualObject1Position | Setting a VisualObjectPosition instead of Node1 will cause Node1 to be null and the dimension will be placed in this VisualObjectPosition position. This should be used when dimension should be attached to something different than a component, for example, a Drawing view
Public property | VisualObject2Position | Setting a VisualObjectPosition instead of Node2 will cause Node2 to be null and the dimension will be placed in this VisualObjectPosition position. This should be used when dimension should be attached to something different than a component, for example, a Drawing view
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetComponentTexts | Return precise measurement values. Used only for printing to console.
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | UpdateLocations | Helper method to refresh the dimension position and value
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks

Layout item that can be used for authoring new and manipulating existing dimensions in a layout or in the drawing view.

Dimensions will recalculate its value when the objects attached to it change their position

Dimensions can be attached to a ISimNode, IDrawingView or defined Matrix

See Also

Reference

VisualComponents.Create3D Namespace


IDimension Properties

The IDimension type exposes the following members.

Properties
 | Name | Description
Public property | AngleCenter |
Public property | ArrowMaterial | Optional IMaterial for arrows. If null normal Material is used.
Public property | ArrowSize | size of the arrow in the dimension
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | Center |
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CustomText | Text set by the user. Will be shown if UseCustomText property is set to True
Public property | Dimension | Dimension value
Public property | Direction1 | In case of angular dimension, the direction of the edge of the first attached point
Public property | Direction2 | In case of angular dimension, the direction of the edge of the second attached point
Public property | Drawing1 | First attachment point. Setting a Drawing1 will cause Node1 to be null
Public property | Drawing2 | Second attachment point. Setting a Drawing2 will cause Node2 to be null
Public property | Geometry | Retrieves all geometry generated by the dimension
Public property | Height | Font height of the dimension text
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsMinAngle | Determines whether, in case of angular dimensions, the minimun angle will be shown
Public property | IsPersistent | Defines if the ILayoutItem is stored with the layout. (Inherited from ILayoutItem.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | LineWidth | width of the lines in the dimension
Public property | Material | IMaterial used in the geometry of the dimension
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node1 | First attachment point. Setting a Node1 will cause Drawing1 to be null
Public property | Node2 | Second attachment point. Setting a Node2 will cause Drawing2 to be null
Public property | NodePosition1 | Position of the first attachment point visual object
Public property | NodePosition1InWorld | Retrieves the first attachemnt position in world coordinates
Public property | NodePosition2 | Position of the second attachment point visual object
Public property | NodePosition2InWorld | Retrieves the second attachemnt position in world coordinates
Public property | Normal1 | In case of angular dimension, this vector represents the normal of the surface of the first attached point
Public property | Normal2 | In case of angular dimension, this vector represents the normal of the surface of the second attached point
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RenderAsMeasure | Determines whether the dimension should behaves as a measurement tool, it will show more information (only for linear dimension).
Public property | ScaleFactor | Scale factor used when calculating the dimension value
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | TextPosition | Dimension's text position
Public property | Thickness | Font boldness of the dimension text
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IVisualObject.)
Public property | TransformationInWorld | Gets or sets the world transformation matrix (Inherited from IVisualObject.)
Public property | Type | Dimension's type
Public property | UseCustomText | Defines whether CustomText will be shown instead of the calculated dimension
Public property | VisualObject1Position | Setting a VisualObjectPosition instead of Node1 will cause Node1 to be null and the dimension will be placed in this VisualObjectPosition position. This should be used when dimension should be attached to something different than a component, for example, a Drawing view
Public property | VisualObject2Position | Setting a VisualObjectPosition instead of Node2 will cause Node2 to be null and the dimension will be placed in this VisualObjectPosition position. This should be used when dimension should be attached to something different than a component, for example, a Drawing view
Top
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.AngleCenter Property

IDimensionAngleCenter Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 AngleCenter { get; }
property Vector3 AngleCenter {
    Vector3 get ();
}

Property Value

Type: Vector3
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.ArrowMaterial Property

IDimensionArrowMaterial Property

Optional IMaterial for arrows. If null normal Material is used.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMaterial ArrowMaterial { get; set; }
property IMaterial^ ArrowMaterial {
    IMaterial^ get ();
    void set (IMaterial^ value);
}

Property Value

Type: IMaterial
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.ArrowSize Property

IDimensionArrowSize Property

size of the arrow in the dimension

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double ArrowSize { get; set; }
property double ArrowSize {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.Center Property

IDimensionCenter Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix Center { get; }
property Matrix Center {
    Matrix get ();
}

Property Value

Type: Matrix
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.CustomText Property

IDimensionCustomText Property

Text set by the user. Will be shown if UseCustomText property is set to True

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string CustomText { get; set; }
property String^ CustomText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.Dimension Property

IDimensionDimension Property

Dimension value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Dimension { get; set; }
property double Dimension {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.Direction1 Property

IDimensionDirection1 Property

In case of angular dimension, the direction of the edge of the first attached point

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 Direction1 { get; set; }
property Vector3 Direction1 {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.Direction2 Property

IDimensionDirection2 Property

In case of angular dimension, the direction of the edge of the second attached point

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 Direction2 { get; set; }
property Vector3 Direction2 {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.Drawing1 Property

IDimensionDrawing1 Property

First attachment point. Setting a Drawing1 will cause Node1 to be null

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IDrawingView Drawing1 { get; set; }
property IDrawingView^ Drawing1 {
    IDrawingView^ get ();
    void set (IDrawingView^ value);
}

Property Value

Type: IDrawingView
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.Drawing2 Property

IDimensionDrawing2 Property

Second attachment point. Setting a Drawing2 will cause Node2 to be null

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IDrawingView Drawing2 { get; set; }
property IDrawingView^ Drawing2 {
    IDrawingView^ get ();
    void set (IDrawingView^ value);
}

Property Value

Type: IDrawingView
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.Geometry Property

IDimensionGeometry Property

Retrieves all geometry generated by the dimension

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IGeometrySet> Geometry { get; }
property ReadOnlyCollection<IGeometrySet^>^ Geometry {
    ReadOnlyCollection<IGeometrySet^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIGeometrySet
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.Height Property

IDimensionHeight Property

Font height of the dimension text

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Height { get; set; }
property double Height {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.IsMinAngle Property

IDimensionIsMinAngle Property

Determines whether, in case of angular dimensions, the minimun angle will be shown

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsMinAngle { get; set; }
property bool IsMinAngle {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.LineWidth Property

IDimensionLineWidth Property

width of the lines in the dimension

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double LineWidth { get; set; }
property double LineWidth {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.Material Property

IDimensionMaterial Property

IMaterial used in the geometry of the dimension

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMaterial Material { get; set; }
property IMaterial^ Material {
    IMaterial^ get ();
    void set (IMaterial^ value);
}

Property Value

Type: IMaterial
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.Node1 Property

IDimensionNode1 Property

First attachment point. Setting a Node1 will cause Drawing1 to be null

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode Node1 { get; set; }
property ISimNode^ Node1 {
    ISimNode^ get ();
    void set (ISimNode^ value);
}

Property Value

Type: ISimNode
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.Node2 Property

IDimensionNode2 Property

Second attachment point. Setting a Node2 will cause Drawing2 to be null

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode Node2 { get; set; }
property ISimNode^ Node2 {
    ISimNode^ get ();
    void set (ISimNode^ value);
}

Property Value

Type: ISimNode
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.NodePosition1 Property

IDimensionNodePosition1 Property

Position of the first attachment point visual object

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix NodePosition1 { get; set; }
property Matrix NodePosition1 {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
Remarks

This is the position of the node or drawing item to which the dimension is attached.

See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.NodePosition1InWorld Property

IDimensionNodePosition1InWorld Property

Retrieves the first attachemnt position in world coordinates

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix NodePosition1InWorld { get; }
property Matrix NodePosition1InWorld {
    Matrix get ();
}

Property Value

Type: Matrix
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.NodePosition2 Property

IDimensionNodePosition2 Property

Position of the second attachment point visual object

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix NodePosition2 { get; set; }
property Matrix NodePosition2 {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
Remarks

This is the position of the node or drawing item to which the dimension is attached.

See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.NodePosition2InWorld Property

IDimensionNodePosition2InWorld Property

Retrieves the second attachemnt position in world coordinates

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix NodePosition2InWorld { get; }
property Matrix NodePosition2InWorld {
    Matrix get ();
}

Property Value

Type: Matrix
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.Normal1 Property

IDimensionNormal1 Property

In case of angular dimension, this vector represents the normal of the surface of the first attached point

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 Normal1 { get; set; }
property Vector3 Normal1 {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.Normal2 Property

IDimensionNormal2 Property

In case of angular dimension, this vector represents the normal of the surface of the second attached point

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 Normal2 { get; set; }
property Vector3 Normal2 {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.RenderAsMeasure Property

IDimensionRenderAsMeasure Property

Determines whether the dimension should behaves as a measurement tool, it will show more information (only for linear dimension).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool RenderAsMeasure { get; set; }
property bool RenderAsMeasure {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.ScaleFactor Property

IDimensionScaleFactor Property

Scale factor used when calculating the dimension value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double ScaleFactor { get; set; }
property double ScaleFactor {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.TextPosition Property

IDimensionTextPosition Property

Dimension's text position

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix TextPosition { get; set; }
property Matrix TextPosition {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.Thickness Property

IDimensionThickness Property

Font boldness of the dimension text

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Thickness { get; set; }
property double Thickness {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.Type Property

IDimensionType Property

Dimension's type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
DimensionType Type { get; set; }
property DimensionType Type {
    DimensionType get ();
    void set (DimensionType value);
}

Property Value

Type: DimensionType
Remarks
Depending on the type, dimension will calculate different parameter (distances or angles)
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.UseCustomText Property

IDimensionUseCustomText Property

Defines whether CustomText will be shown instead of the calculated dimension

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool UseCustomText { get; set; }
property bool UseCustomText {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.VisualObject1Position Property

IDimensionVisualObject1Position Property

Setting a VisualObjectPosition instead of Node1 will cause Node1 to be null and the dimension will be placed in this VisualObjectPosition position. This should be used when dimension should be attached to something different than a component, for example, a Drawing view

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix VisualObject1Position { get; set; }
property Matrix VisualObject1Position {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.VisualObject2Position Property

IDimensionVisualObject2Position Property

Setting a VisualObjectPosition instead of Node2 will cause Node2 to be null and the dimension will be placed in this VisualObjectPosition position. This should be used when dimension should be attached to something different than a component, for example, a Drawing view

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix VisualObject2Position { get; set; }
property Matrix VisualObject2Position {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension Methods

The IDimension type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetComponentTexts | Return precise measurement values. Used only for printing to console.
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | UpdateLocations | Helper method to refresh the dimension position and value
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.GetComponentTexts Method

IDimensionGetComponentTexts Method

Return precise measurement values. Used only for printing to console.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string[] GetComponentTexts()
array<String^>^ GetComponentTexts()

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.IDimension.GetComponentTexts"]

See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension.UpdateLocations Method

IDimensionUpdateLocations Method

Helper method to refresh the dimension position and value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateLocations()
void UpdateLocations()
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDimension Events

The IDimension type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

IDimension Interface
VisualComponents.Create3D Namespace


IDirect3DViewportViewModel Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDirect3DViewportViewModel
public interface class IDirect3DViewportViewModel

The IDirect3DViewportViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ControlGrid | Grid on which custom controls may be added (on top of the 3D viewport)
Public property | IsViewportBusy |
Top
See Also

Reference

VisualComponents.Create3D Namespace


IDirect3DViewportViewModel Properties

The IDirect3DViewportViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ControlGrid | Grid on which custom controls may be added (on top of the 3D viewport)
Public property | IsViewportBusy |
Top
See Also

Reference

IDirect3DViewportViewModel Interface
VisualComponents.Create3D Namespace


IDirect3DViewportViewModel.ControlGrid Property

IDirect3DViewportViewModelControlGrid Property

Grid on which custom controls may be added (on top of the 3D viewport)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Grid ControlGrid { get; }
property Grid^ ControlGrid {
    Grid^ get ();
}

Property Value

Type: Grid
See Also

Reference

IDirect3DViewportViewModel Interface
VisualComponents.Create3D Namespace


IDirect3DViewportViewModel.IsViewportBusy Property

IDirect3DViewportViewModelIsViewportBusy Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsViewportBusy { get; set; }
property bool IsViewportBusy {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IDirect3DViewportViewModel Interface
VisualComponents.Create3D Namespace


IDisplaySection Interface

Configuration file section for Display Options.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDisplaySection : ISection
public interface class IDisplaySection : ISection

The IDisplaySection type exposes the following members.

Properties
 | Name | Description
Public property | DisplayElement | Configuration file element for Display Options.
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | GetSection | Gets the section (Inherited from ISection.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IDisplaySection Properties

The IDisplaySection type exposes the following members.

Properties
 | Name | Description
Public property | DisplayElement | Configuration file element for Display Options.
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
See Also

Reference

IDisplaySection Interface
VisualComponents.Create3D Namespace


IDisplaySection.DisplayElement Property

IDisplaySectionDisplayElement Property

Configuration file element for Display Options.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
DisplayConfigElement DisplayElement { get; }
property DisplayConfigElement^ DisplayElement {
    DisplayConfigElement^ get ();
}

Property Value

Type: DisplayConfigElement
See Also

Reference

IDisplaySection Interface
VisualComponents.Create3D Namespace


IDisplaySection Methods

The IDisplaySection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | GetSection | Gets the section (Inherited from ISection.)
Top
See Also

Reference

IDisplaySection Interface
VisualComponents.Create3D Namespace


IDistributionModeProductLineEntry Interface

Defines a IProductType option and its creation probability for IProductCreatorDistributionMode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDistributionModeProductLineEntry : IWrapper,
    IDisposable
public interface class IDistributionModeProductLineEntry : IWrapper,
    IDisposable

The IDistributionModeProductLineEntry type exposes the following members.

Properties
 | Name | Description
Public property | IsValid | (Inherited from IWrapper.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Probability | The probability of this product type to be instantiated. It is evaluated as relative to the sum of all configured probabilities like a weight value in a weighted sum. The value must be greater or equal to zero.
Public property | ProductType | The product type to create from feeder.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IDistributionModeProductLineEntry Properties

The IDistributionModeProductLineEntry type exposes the following members.

Properties
 | Name | Description
Public property | IsValid | (Inherited from IWrapper.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Probability | The probability of this product type to be instantiated. It is evaluated as relative to the sum of all configured probabilities like a weight value in a weighted sum. The value must be greater or equal to zero.
Public property | ProductType | The product type to create from feeder.
Top
See Also

Reference

IDistributionModeProductLineEntry Interface
VisualComponents.Create3D Namespace


IDistributionModeProductLineEntry.Probability Property

IDistributionModeProductLineEntryProbability Property

The probability of this product type to be instantiated. It is evaluated as relative to the sum of all configured probabilities like a weight value in a weighted sum. The value must be greater or equal to zero.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Probability { get; set; }
property double Probability {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Occurs when trying to set a negative value.
See Also

Reference

IDistributionModeProductLineEntry Interface
VisualComponents.Create3D Namespace


IDistributionModeProductLineEntry.ProductType Property

IDistributionModeProductLineEntryProductType Property

The product type to create from feeder.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProductType ProductType { get; set; }
property IProductType^ ProductType {
    IProductType^ get ();
    void set (IProductType^ value);
}

Property Value

Type: IProductType
Exceptions
Exception | Condition
NullReferenceException | Occurs when trying to set a null value.
See Also

Reference

IDistributionModeProductLineEntry Interface
VisualComponents.Create3D Namespace


IDistributionModeProductLineEntry Methods

The IDistributionModeProductLineEntry type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IDistributionModeProductLineEntry Interface
VisualComponents.Create3D Namespace


IDistributionModeProductLineEntry Events

The IDistributionModeProductLineEntry type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
See Also

Reference

IDistributionModeProductLineEntry Interface
VisualComponents.Create3D Namespace


IDistributionParameters Interface

Base interface for Distribution Parameters

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDistributionParameters
public interface class IDistributionParameters

The IDistributionParameters type exposes the following members.

Properties
 | Name | Description
Public property | DistributionType |
Public property | Expression |
Top
See Also

Reference

VisualComponents.Create3D Namespace


IDistributionParameters Properties

The IDistributionParameters type exposes the following members.

Properties
 | Name | Description
Public property | DistributionType |
Public property | Expression |
Top
See Also

Reference

IDistributionParameters Interface
VisualComponents.Create3D Namespace


IDistributionParameters.DistributionType Property

IDistributionParametersDistributionType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
DistributionType DistributionType { get; }
property DistributionType DistributionType {
    DistributionType get ();
}

Property Value

Type: DistributionType
See Also

Reference

IDistributionParameters Interface
VisualComponents.Create3D Namespace


IDistributionParameters.Expression Property

IDistributionParametersExpression Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Expression { get; }
property String^ Expression {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IDistributionParameters Interface
VisualComponents.Create3D Namespace


IDistributionProperty Interface

Distribution property interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDistributionProperty : IProperty,
    INotifyPropertyChanged, IDisposable, INamed
public interface class IDistributionProperty : IProperty,
    INotifyPropertyChanged, IDisposable, INamed

The IDistributionProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Allowed maximum value for the property. (Inherited from IProperty.)
Public property | AllowedMinimum | Allowed minimum value for the property. (Inherited from IProperty.)
Public property | AllowedValues | Collection of allowed values for constrained properties. (Inherited from IProperty.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | Distribution | Distribution Expression that is evaluated to determine the property value.
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | DistributionType | Get/Set the distribution DistributionType
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | Parameters | Get/Sets the distribution expression based on distribution parameters
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | RandomStream | Get/Set ramdom stream used for this distribution
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Property value as an object. (Inherited from IProperty.)
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IDistributionProperty Properties

The IDistributionProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Allowed maximum value for the property. (Inherited from IProperty.)
Public property | AllowedMinimum | Allowed minimum value for the property. (Inherited from IProperty.)
Public property | AllowedValues | Collection of allowed values for constrained properties. (Inherited from IProperty.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | Distribution | Distribution Expression that is evaluated to determine the property value.
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | DistributionType | Get/Set the distribution DistributionType
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | Parameters | Get/Sets the distribution expression based on distribution parameters
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | RandomStream | Get/Set ramdom stream used for this distribution
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Property value as an object. (Inherited from IProperty.)
Top
See Also

Reference

IDistributionProperty Interface
VisualComponents.Create3D Namespace


IDistributionProperty.Distribution Property

IDistributionPropertyDistribution Property

Distribution Expression that is evaluated to determine the property value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Distribution { get; set; }
property String^ Distribution {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IDistributionProperty Interface
VisualComponents.Create3D Namespace


IDistributionProperty.DistributionType Property

IDistributionPropertyDistributionType Property

Get/Set the distribution DistributionType

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
DistributionType DistributionType { get; }
property DistributionType DistributionType {
    DistributionType get ();
}

Property Value

Type: DistributionType
See Also

Reference

IDistributionProperty Interface
VisualComponents.Create3D Namespace


IDistributionProperty.Parameters Property

IDistributionPropertyParameters Property

Get/Sets the distribution expression based on distribution parameters

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IDistributionParameters Parameters { get; set; }
property IDistributionParameters^ Parameters {
    IDistributionParameters^ get ();
    void set (IDistributionParameters^ value);
}

Property Value

Type: IDistributionParameters
See Also

Reference

IDistributionProperty Interface
VisualComponents.Create3D Namespace


IDistributionProperty.RandomStream Property

IDistributionPropertyRandomStream Property

Get/Set ramdom stream used for this distribution

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int RandomStream { get; set; }
property int RandomStream {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IDistributionProperty Interface
VisualComponents.Create3D Namespace


IDistributionProperty Methods

The IDistributionProperty type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

IDistributionProperty Interface
VisualComponents.Create3D Namespace


IDistributionProperty Events

The IDistributionProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IDistributionProperty Interface
VisualComponents.Create3D Namespace


IDllFeatureRequest Interface

Dll license feature request interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDllFeatureRequest
public interface class IDllFeatureRequest

The IDllFeatureRequest type exposes the following members.

Properties
 | Name | Description
Public property | FeatureName | Name of the requested license feature.
Public property | FeatureVersion | Version of the requested license feature.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IDllFeatureRequest Properties

The IDllFeatureRequest type exposes the following members.

Properties
 | Name | Description
Public property | FeatureName | Name of the requested license feature.
Public property | FeatureVersion | Version of the requested license feature.
Top
See Also

Reference

IDllFeatureRequest Interface
VisualComponents.Create3D Namespace


IDllFeatureRequest.FeatureName Property

IDllFeatureRequestFeatureName Property

Name of the requested license feature.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string FeatureName { get; }
property String^ FeatureName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IDllFeatureRequest Interface
VisualComponents.Create3D Namespace


IDllFeatureRequest.FeatureVersion Property

IDllFeatureRequestFeatureVersion Property

Version of the requested license feature.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string FeatureVersion { get; }
property String^ FeatureVersion {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IDllFeatureRequest Interface
VisualComponents.Create3D Namespace


IDllLicenseCheck Interface

Dll license check interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDllLicenseCheck
public interface class IDllLicenseCheck

The IDllLicenseCheck type exposes the following members.

Properties
 | Name | Description
Public property | IsActivated | Determine if AddOn is activated.
Public property | RequiredFeatures | Required feature associated with the dll .
Public property | SettingType | Addon Setting View Model interface Definition.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IDllLicenseCheck Properties

The IDllLicenseCheck type exposes the following members.

Properties
 | Name | Description
Public property | IsActivated | Determine if AddOn is activated.
Public property | RequiredFeatures | Required feature associated with the dll .
Public property | SettingType | Addon Setting View Model interface Definition.
Top
See Also

Reference

IDllLicenseCheck Interface
VisualComponents.Create3D Namespace


IDllLicenseCheck.IsActivated Property

IDllLicenseCheckIsActivated Property

Determine if AddOn is activated.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsActivated { get; }
property bool IsActivated {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IDllLicenseCheck Interface
VisualComponents.Create3D Namespace


IDllLicenseCheck.RequiredFeatures Property

IDllLicenseCheckRequiredFeatures Property

Required feature associated with the dll .

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
LicenseFeaturesFeatures RequiredFeatures { get; }
property LicenseFeaturesFeatures RequiredFeatures {
    LicenseFeaturesFeatures get ();
}

Property Value

Type: LicenseFeaturesFeatures
Remarks
The Dll owner needs to set the requird license feature that must exist in running machine. If there is no license control features can be set with Features.None>
See Also

Reference

IDllLicenseCheck Interface
VisualComponents.Create3D Namespace


IDllLicenseCheck.SettingType Property

IDllLicenseCheckSettingType Property

Addon Setting View Model interface Definition.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Type SettingType { get; }
property Type^ SettingType {
    Type^ get ();
}

Property Value

Type: Type
Remarks
AddOns can have external setting options that can be shown in backstage.Interface definition of the Addon setting ViewModel is specified in order to load the the associated View.
See Also

Reference

IDllLicenseCheck Interface
VisualComponents.Create3D Namespace


IDllLicenseKeyPattern Interface

Dll license key pattern interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDllLicenseKeyPattern
public interface class IDllLicenseKeyPattern

The IDllLicenseKeyPattern type exposes the following members.

Properties
 | Name | Description
Public property | Pattern | RegEx pattern the license key should match.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IDllLicenseKeyPattern Properties

The IDllLicenseKeyPattern type exposes the following members.

Properties
 | Name | Description
Public property | Pattern | RegEx pattern the license key should match.
Top
See Also

Reference

IDllLicenseKeyPattern Interface
VisualComponents.Create3D Namespace


IDllLicenseKeyPattern.Pattern Property

IDllLicenseKeyPatternPattern Property

RegEx pattern the license key should match.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Pattern { get; }
property String^ Pattern {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IDllLicenseKeyPattern Interface
VisualComponents.Create3D Namespace


IDocumentContent Interface

Represents tabbed documents within a XamDockManager

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDocumentContent
public interface class IDocumentContent

The IDocumentContent type exposes the following members.

Properties
 | Name | Description
Public property | CanDragFromDocumentHost |
Public property | CanDropToDocumentHost |
Top
See Also

Reference

VisualComponents.Create3D Namespace


IDocumentContent Properties

The IDocumentContent type exposes the following members.

Properties
 | Name | Description
Public property | CanDragFromDocumentHost |
Public property | CanDropToDocumentHost |
Top
See Also

Reference

IDocumentContent Interface
VisualComponents.Create3D Namespace


IDocumentContent.CanDragFromDocumentHost Property

IDocumentContentCanDragFromDocumentHost Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanDragFromDocumentHost { get; set; }
property bool CanDragFromDocumentHost {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IDocumentContent Interface
VisualComponents.Create3D Namespace


IDocumentContent.CanDropToDocumentHost Property

IDocumentContentCanDropToDocumentHost Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanDropToDocumentHost { get; set; }
property bool CanDropToDocumentHost {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IDocumentContent Interface
VisualComponents.Create3D Namespace


IDocumentLink Interface

An interface for document link behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDocumentLink : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IDocumentLink : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IDocumentLink type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IDocumentLink Properties

The IDocumentLink type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IDocumentLink Interface
VisualComponents.Create3D Namespace


IDocumentLink Methods

The IDocumentLink type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IDocumentLink Interface
VisualComponents.Create3D Namespace


IDocumentLink Events

The IDocumentLink type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IDocumentLink Interface
VisualComponents.Create3D Namespace


IDof Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDof : IPropertyContainer, IBatchModeObject,
    INamed
public interface class IDof : IPropertyContainer,
    IBatchModeObject, INamed

The IDof type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Component | Back reference to containing component. This is useful in case of dummy dof.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlType | Joint control type.
Public property | CurrentValueProperty | Current joint value property.
Public property | DegreeOfFreedomSign | Used by InteractionService.
Public property | DrivingJoint | The DOF that this DOF is following.
Public property | InitialValue | Initial value if active dof.
Public property | IsActive | True if the link is driven by a servo or robot.
Public property | IsFollower | Whether this DOF is a follower DOF.
Public property | IsJointParametric | Query if the link transform is non-constant.
Public property | IsStatic | True if the associated link does not move during simulation.
Public property | JogDegreeOfFreedom | Used by InteractionService.
Public property | JointAxis | Joint axis.
Public property | JointType | Joint type of DOF.
Public property | Link | Back reference to containing link.
Public property | MaxLimit | Gets or sets joint maximum limit.
Public property | MaxLimitExpression | Gets or sets joint maximum expression.
Public property | MinLimit | Gets or sets joint minimum limit.
Public property | MinLimitExpression | Gets or sets joint minimum limit expression
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Turn | Current turn if active dof.
Public property | Value | Current value if active dof.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | IsJointDependentOnProperty | Test if the link transform depends on the given property.
Public method | Recalculate | Recalculate final matrix.
Public method | SetJointValue | Sets the value of joint. lockTarget argument can be used for locking the end of the kinematic chain in place. This will keep robot TCP location in the same place.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IDof Properties

The IDof type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Component | Back reference to containing component. This is useful in case of dummy dof.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlType | Joint control type.
Public property | CurrentValueProperty | Current joint value property.
Public property | DegreeOfFreedomSign | Used by InteractionService.
Public property | DrivingJoint | The DOF that this DOF is following.
Public property | InitialValue | Initial value if active dof.
Public property | IsActive | True if the link is driven by a servo or robot.
Public property | IsFollower | Whether this DOF is a follower DOF.
Public property | IsJointParametric | Query if the link transform is non-constant.
Public property | IsStatic | True if the associated link does not move during simulation.
Public property | JogDegreeOfFreedom | Used by InteractionService.
Public property | JointAxis | Joint axis.
Public property | JointType | Joint type of DOF.
Public property | Link | Back reference to containing link.
Public property | MaxLimit | Gets or sets joint maximum limit.
Public property | MaxLimitExpression | Gets or sets joint maximum expression.
Public property | MinLimit | Gets or sets joint minimum limit.
Public property | MinLimitExpression | Gets or sets joint minimum limit expression
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Turn | Current turn if active dof.
Public property | Value | Current value if active dof.
Top
See Also

Reference

IDof Interface
VisualComponents.Create3D Namespace


IDof.Component Property

IDofComponent Property

Back reference to containing component. This is useful in case of dummy dof.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent Component { get; }
property ISimComponent^ Component {
    ISimComponent^ get ();
}

Property Value

Type: ISimComponent
See Also

Reference

IDof Interface
VisualComponents.Create3D Namespace


IDof.ControlType Property

IDofControlType Property

Joint control type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
JointControlType ControlType { get; }
property JointControlType ControlType {
    JointControlType get ();
}

Property Value

Type: JointControlType
See Also

Reference

IDof Interface
VisualComponents.Create3D Namespace


IDof.CurrentValueProperty Property

IDofCurrentValueProperty Property

Current joint value property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProperty CurrentValueProperty { get; }
property IProperty^ CurrentValueProperty {
    IProperty^ get ();
}

Property Value

Type: IProperty
See Also

Reference

IDof Interface
VisualComponents.Create3D Namespace


IDof.DegreeOfFreedomSign Property

IDofDegreeOfFreedomSign Property

Used by InteractionService.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int DegreeOfFreedomSign { get; }
property int DegreeOfFreedomSign {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IDof Interface
VisualComponents.Create3D Namespace


IDof.DrivingJoint Property

IDofDrivingJoint Property

The DOF that this DOF is following.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IDof DrivingJoint { get; set; }
property IDof^ DrivingJoint {
    IDof^ get ();
    void set (IDof^ value);
}

Property Value

Type: IDof
Remarks

This is always null for DOF types that are not follower types. Trying to set DrivingJoint for non-follower DOFs causes an exception.

See Also

Reference

IDof Interface
VisualComponents.Create3D Namespace


IDof.InitialValue Property

IDofInitialValue Property

Initial value if active dof.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double InitialValue { get; set; }
property double InitialValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IDof Interface
VisualComponents.Create3D Namespace


IDof.IsActive Property

IDofIsActive Property

True if the link is driven by a servo or robot.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsActive { get; }
property bool IsActive {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IDof Interface
VisualComponents.Create3D Namespace


IDof.IsFollower Property

IDofIsFollower Property

Whether this DOF is a follower DOF.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsFollower { get; }
property bool IsFollower {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IDof Interface
VisualComponents.Create3D Namespace


IDof.IsJointParametric Property

IDofIsJointParametric Property

Query if the link transform is non-constant.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsJointParametric { get; }
property bool IsJointParametric {
    bool get ();
}

Property Value

Type: Boolean
Remarks
This is true for all moving joints, and is also true for static joints which depend on component parameters.
See Also

Reference

IDof Interface
VisualComponents.Create3D Namespace


IDof.IsStatic Property

IDofIsStatic Property

True if the associated link does not move during simulation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsStatic { get; }
property bool IsStatic {
    bool get ();
}

Property Value

Type: Boolean
Remarks
This is true if the joint type is fixed, or if the joint value or transform expressions are constant.
See Also

Reference

IDof Interface
VisualComponents.Create3D Namespace


IDof.JogDegreeOfFreedom Property

IDofJogDegreeOfFreedom Property

Used by InteractionService.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
DegreeOfFreedom JogDegreeOfFreedom { get; }
property DegreeOfFreedom JogDegreeOfFreedom {
    DegreeOfFreedom get ();
}

Property Value

Type: DegreeOfFreedom
See Also

Reference

IDof Interface
VisualComponents.Create3D Namespace


IDof.JointAxis Property

IDofJointAxis Property

Joint axis.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
JointAxis JointAxis { get; set; }
property JointAxis JointAxis {
    JointAxis get ();
    void set (JointAxis value);
}

Property Value

Type: JointAxis
Remarks
This is read only for custom and dummy DOFs.
See Also

Reference

IDof Interface
VisualComponents.Create3D Namespace


IDof.JointType Property

IDofJointType Property

Joint type of DOF.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
JointType JointType { get; }
property JointType JointType {
    JointType get ();
}

Property Value

Type: JointType
See Also

Reference

IDof Interface
VisualComponents.Create3D Namespace


IDof.Link Property

IDofLink Property

Back reference to containing link.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode Link { get; }
property ISimNode^ Link {
    ISimNode^ get ();
}

Property Value

Type: ISimNode
See Also

Reference

IDof Interface
VisualComponents.Create3D Namespace


IDof.MaxLimit Property

IDofMaxLimit Property

Gets or sets joint maximum limit.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double MaxLimit { get; set; }
property double MaxLimit {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IDof Interface
VisualComponents.Create3D Namespace


IDof.MaxLimitExpression Property

IDofMaxLimitExpression Property

Gets or sets joint maximum expression.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string MaxLimitExpression { get; set; }
property String^ MaxLimitExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IDof Interface
VisualComponents.Create3D Namespace


IDof.MinLimit Property

IDofMinLimit Property

Gets or sets joint minimum limit.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double MinLimit { get; set; }
property double MinLimit {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IDof Interface
VisualComponents.Create3D Namespace


IDof.MinLimitExpression Property

IDofMinLimitExpression Property

Gets or sets joint minimum limit expression

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string MinLimitExpression { get; set; }
property String^ MinLimitExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IDof Interface
VisualComponents.Create3D Namespace


IDof.Turn Property

IDofTurn Property

Current turn if active dof.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int Turn { get; set; }
property int Turn {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IDof Interface
VisualComponents.Create3D Namespace


IDof.Value Property

IDofValue Property

Current value if active dof.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Value { get; set; }
property double Value {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IDof Interface
VisualComponents.Create3D Namespace


IDof Methods

The IDof type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | IsJointDependentOnProperty | Test if the link transform depends on the given property.
Public method | Recalculate | Recalculate final matrix.
Public method | SetJointValue | Sets the value of joint. lockTarget argument can be used for locking the end of the kinematic chain in place. This will keep robot TCP location in the same place.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IDof Interface
VisualComponents.Create3D Namespace


IDof.IsJointDependentOnProperty Method

IDofIsJointDependentOnProperty Method

Test if the link transform depends on the given property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsJointDependentOnProperty(
    IProperty propertyObject
)
bool IsJointDependentOnProperty(
    IProperty^ propertyObject
)

Parameters

propertyObject
Type: VisualComponents.Create3DIProperty

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IDof.IsJointDependentOnProperty(VisualComponents.Create3D.IProperty)"]

See Also

Reference

IDof Interface
VisualComponents.Create3D Namespace


IDof.Recalculate Method

IDofRecalculate Method

Recalculate final matrix.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Recalculate()
void Recalculate()
See Also

Reference

IDof Interface
VisualComponents.Create3D Namespace


IDof.SetJointValue Method

IDofSetJointValue Method

Sets the value of joint. lockTarget argument can be used for locking the end of the kinematic chain in place. This will keep robot TCP location in the same place.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetJointValue(
    double value,
    bool lockTarget
)
void SetJointValue(
    double value,
    bool lockTarget
)

Parameters

value
Type: SystemDouble
Value of the target property to be set.
lockTarget
Type: SystemBoolean
Defines if the target should be locked.
See Also

Reference

IDof Interface
VisualComponents.Create3D Namespace


IDof Events

The IDof type exposes the following members.

Events
 | Name | Description
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IDof Interface
VisualComponents.Create3D Namespace


IDofManipulationTarget Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDofManipulationTarget : IManipulationTarget,
    ILockableObject, IDisposable
public interface class IDofManipulationTarget : IManipulationTarget,
    ILockableObject, IDisposable

The IDofManipulationTarget type exposes the following members.

Properties
 | Name | Description
Public property | HandleInObjectCoordinates | Deprecated. Same as TransformationInObject. (Inherited from IManipulationTarget.)
Public property | HandleInReference | Deprecated. Same as TransformationInReference. (Inherited from IManipulationTarget.)
Public property | HandleInWorld | Deprecated. Same as TransformationInWorld. (Inherited from IManipulationTarget.)
Public property | HandleReferenceInWorld | Deprecated. Same as ParentTransformationInWorld. (Inherited from IManipulationTarget.)
Public property | IsHandleFixed | Deprecated. Same as IRobotTcpManipulationTarget.IsTcpExternal. (Inherited from IManipulationTarget.)
Public property | IsLocked | (Inherited from IManipulationTarget.)
Public property | IsTargetEnabled | This is similar to IsLocked, but for manual disabling. (Inherited from IManipulationTarget.)
Public property | IsValid | (Inherited from IManipulationTarget.)
Public property | IsVisible | (Inherited from IManipulationTarget.)
Public property | ParentTransformationInWorld | Position of pivot visual object parent. (Inherited from IManipulationTarget.)
Public property | PivotObject | (Inherited from IManipulationTarget.)
Public property | TargetObjects | Target objects. May exlude child objects. (Inherited from IManipulationTarget.)
Public property | TransformationInObject | Sets the transformation in reference to its own space (Inherited from IManipulationTarget.)
Public property | TransformationInReference | Gets or sets the transformation in reference to its parent (Inherited from IManipulationTarget.)
Public property | TransformationInWorld | Gets or sets the transformation in world (Inherited from IManipulationTarget.)
Top
Methods
 | Name | Description
Public method | ApplyChanges | Does dof manipulation on mouse release (when finalChange == false).
Public method | CollectUndoChanges | Collect all changes since the last call to StoreUndoState(). (Inherited from IManipulationTarget.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | StoreUndoState | Store information away to be used when creating an undo change set later. (Inherited from IManipulationTarget.)
Top
Events
 | Name | Description
Public event | IsLockedChanged | (Inherited from IManipulationTarget.)
Public event | IsVisibleChanged | (Inherited from IManipulationTarget.)
Public event | ObjectInvalidated | (Inherited from IManipulationTarget.)
Public event | TransformationChanged | (Inherited from IManipulationTarget.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IDofManipulationTarget Properties

The IDofManipulationTarget type exposes the following members.

Properties
 | Name | Description
Public property | HandleInObjectCoordinates | Deprecated. Same as TransformationInObject. (Inherited from IManipulationTarget.)
Public property | HandleInReference | Deprecated. Same as TransformationInReference. (Inherited from IManipulationTarget.)
Public property | HandleInWorld | Deprecated. Same as TransformationInWorld. (Inherited from IManipulationTarget.)
Public property | HandleReferenceInWorld | Deprecated. Same as ParentTransformationInWorld. (Inherited from IManipulationTarget.)
Public property | IsHandleFixed | Deprecated. Same as IRobotTcpManipulationTarget.IsTcpExternal. (Inherited from IManipulationTarget.)
Public property | IsLocked | (Inherited from IManipulationTarget.)
Public property | IsTargetEnabled | This is similar to IsLocked, but for manual disabling. (Inherited from IManipulationTarget.)
Public property | IsValid | (Inherited from IManipulationTarget.)
Public property | IsVisible | (Inherited from IManipulationTarget.)
Public property | ParentTransformationInWorld | Position of pivot visual object parent. (Inherited from IManipulationTarget.)
Public property | PivotObject | (Inherited from IManipulationTarget.)
Public property | TargetObjects | Target objects. May exlude child objects. (Inherited from IManipulationTarget.)
Public property | TransformationInObject | Sets the transformation in reference to its own space (Inherited from IManipulationTarget.)
Public property | TransformationInReference | Gets or sets the transformation in reference to its parent (Inherited from IManipulationTarget.)
Public property | TransformationInWorld | Gets or sets the transformation in world (Inherited from IManipulationTarget.)
Top
See Also

Reference

IDofManipulationTarget Interface
VisualComponents.Create3D Namespace


IDofManipulationTarget Methods

The IDofManipulationTarget type exposes the following members.

Methods
 | Name | Description
Public method | ApplyChanges | Does dof manipulation on mouse release (when finalChange == false).
Public method | CollectUndoChanges | Collect all changes since the last call to StoreUndoState(). (Inherited from IManipulationTarget.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | StoreUndoState | Store information away to be used when creating an undo change set later. (Inherited from IManipulationTarget.)
Top
See Also

Reference

IDofManipulationTarget Interface
VisualComponents.Create3D Namespace


IDofManipulationTarget.ApplyChanges Method

IDofManipulationTargetApplyChanges Method

Does dof manipulation on mouse release (when finalChange == false).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ApplyChanges(
    bool finalChange
)
void ApplyChanges(
    bool finalChange
)

Parameters

finalChange
Type: SystemBoolean

Implements

IManipulationTargetApplyChanges(Boolean)
See Also

Reference

IDofManipulationTarget Interface
VisualComponents.Create3D Namespace


IDofManipulationTarget Events

The IDofManipulationTarget type exposes the following members.

Events
 | Name | Description
Public event | IsLockedChanged | (Inherited from IManipulationTarget.)
Public event | IsVisibleChanged | (Inherited from IManipulationTarget.)
Public event | ObjectInvalidated | (Inherited from IManipulationTarget.)
Public event | TransformationChanged | (Inherited from IManipulationTarget.)
Top
See Also

Reference

IDofManipulationTarget Interface
VisualComponents.Create3D Namespace


IDoubleProperty Interface

Interface for double properties Provides more information about this type of property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDoubleProperty : IProperty<double>,
    IProperty, INotifyPropertyChanged, IDisposable, INamed
public interface class IDoubleProperty : IProperty<double>,
    IProperty, INotifyPropertyChanged, IDisposable, INamed

The IDoubleProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Strongly typed allowed maximum value. (Inherited from IPropertyT.)
Public property | AllowedMinimum | Strongly typed allowed minimum value. (Inherited from IPropertyT.)
Public property | AllowedValues | Strongly typed container of allowed values. (Inherited from IPropertyT.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | UseAsInteger | Specifies if double property is used as an integer.
Public property | Value | Strongly typed property value. (Inherited from IPropertyT.)
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IDoubleProperty Properties

The IDoubleProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Strongly typed allowed maximum value. (Inherited from IPropertyT.)
Public property | AllowedMinimum | Strongly typed allowed minimum value. (Inherited from IPropertyT.)
Public property | AllowedValues | Strongly typed container of allowed values. (Inherited from IPropertyT.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | UseAsInteger | Specifies if double property is used as an integer.
Public property | Value | Strongly typed property value. (Inherited from IPropertyT.)
Top
See Also

Reference

IDoubleProperty Interface
VisualComponents.Create3D Namespace


IDoubleProperty.UseAsInteger Property

IDoublePropertyUseAsInteger Property

Specifies if double property is used as an integer.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool UseAsInteger { get; set; }
property bool UseAsInteger {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IDoubleProperty Interface
VisualComponents.Create3D Namespace


IDoubleProperty Methods

The IDoubleProperty type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

IDoubleProperty Interface
VisualComponents.Create3D Namespace


IDoubleProperty Events

The IDoubleProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IDoubleProperty Interface
VisualComponents.Create3D Namespace


IDrawingContext Interface

This interface represents the Drawing context of the application

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDrawingContext : IContext
public interface class IDrawingContext : IContext

The IDrawingContext type exposes the following members.

Properties
 | Name | Description
Public property | ActiveTemplate | Last selected template
Public property | Id | Context ID. Possible values can be found in Contexts static class. (Inherited from IContext.)
Public property | IsActive | Determine if the context is active, hence, the current application context. (Inherited from IContext.)
Public property | SupportedManipulationModes | Gets the list of manipulation modes that are allowed in this context. (Inherited from IContext.)
Public property | WorldSelection | Returns a cache list of all valid selected objects in the 3d world
Top
Methods
 | Name | Description
Public method | Activate | Activates the context making it this application context. (Inherited from IContext.)
Public method | Deactivate | Deactivates this context. (Inherited from IContext.)
Public method | Refresh | Refresh all display and rendering settings applied to the drawing world
Top
Events
 | Name | Description
Public event | ActiveTemplateChanged | Raised after ActiveTemplate has changed.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IDrawingContext Properties

The IDrawingContext type exposes the following members.

Properties
 | Name | Description
Public property | ActiveTemplate | Last selected template
Public property | Id | Context ID. Possible values can be found in Contexts static class. (Inherited from IContext.)
Public property | IsActive | Determine if the context is active, hence, the current application context. (Inherited from IContext.)
Public property | SupportedManipulationModes | Gets the list of manipulation modes that are allowed in this context. (Inherited from IContext.)
Public property | WorldSelection | Returns a cache list of all valid selected objects in the 3d world
Top
See Also

Reference

IDrawingContext Interface
VisualComponents.Create3D Namespace


IDrawingContext.ActiveTemplate Property

IDrawingContextActiveTemplate Property

Last selected template

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent ActiveTemplate { get; }
property ISimComponent^ ActiveTemplate {
    ISimComponent^ get ();
}

Property Value

Type: ISimComponent
See Also

Reference

IDrawingContext Interface
VisualComponents.Create3D Namespace


IDrawingContext.WorldSelection Property

IDrawingContextWorldSelection Property

Returns a cache list of all valid selected objects in the 3d world

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<Object> WorldSelection { get; }
property ReadOnlyCollection<Object^>^ WorldSelection {
    ReadOnlyCollection<Object^>^ get ();
}

Property Value

Type: ReadOnlyCollectionObject
See Also

Reference

IDrawingContext Interface
VisualComponents.Create3D Namespace


IDrawingContext Methods

The IDrawingContext type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the context making it this application context. (Inherited from IContext.)
Public method | Deactivate | Deactivates this context. (Inherited from IContext.)
Public method | Refresh | Refresh all display and rendering settings applied to the drawing world
Top
See Also

Reference

IDrawingContext Interface
VisualComponents.Create3D Namespace


IDrawingContext.Refresh Method

IDrawingContextRefresh Method

Refresh all display and rendering settings applied to the drawing world

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Refresh()
void Refresh()
See Also

Reference

IDrawingContext Interface
VisualComponents.Create3D Namespace


IDrawingContext Events

The IDrawingContext type exposes the following members.

Events
 | Name | Description
Public event | ActiveTemplateChanged | Raised after ActiveTemplate has changed.
Top
See Also

Reference

IDrawingContext Interface
VisualComponents.Create3D Namespace


IDrawingContext.ActiveTemplateChanged Event

IDrawingContextActiveTemplateChanged Event

Raised after ActiveTemplate has changed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler ActiveTemplateChanged
 event EventHandler^ ActiveTemplateChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IDrawingContext Interface
VisualComponents.Create3D Namespace


IDrawingView Interface

Drawing view layout item interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDrawingView : IVisualObject,
    INamed, IWrapper, IDisposable, ILayoutItem, IPropertyContainer,
    IBatchModeObject, ILockableObject
public interface class IDrawingView : IVisualObject,
    INamed, IWrapper, IDisposable, ILayoutItem, IPropertyContainer,
    IBatchModeObject, ILockableObject

The IDrawingView type exposes the following members.

Properties
 | Name | Description
Public property | Annotations | List of IAnnotation attached to this drawing
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Frames | Retrieves a list of IFrame inside this drawing
Public property | Height | Height of the texture of the path if any
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsLocked | (Inherited from ILockableObject.)
Public property | IsPersistent | Defines if the ILayoutItem is stored with the layout. (Inherited from ILayoutItem.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Lines | Retrieves a list of ILineSet inside this drawing
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | Scale | Expressed in the format x:y
Public property | ScaleFactor | Returns the result of x/y
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | Texts | Retrieves a list of IText3DSet inside this drawing
Public property | TexturePath | Path of the texture if the drawing is not intended to use geometries
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IVisualObject.)
Public property | TransformationInWorld | Gets or sets the world transformation matrix (Inherited from IVisualObject.)
Public property | Width | Width of the texture of the path if any
Public property | VisualizationNode | For internal purpose only
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ClearFrames | Removes all frames in this drawing
Public method | ClearLines | Removes all lines in this drawing
Public method | ClearTexts | Removes all texts in this drawing
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetFrames | Set frames for the drawing
Public method | SetLines | Set lines for the drawing
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTexts | Set texts for the drawing
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | Update | Updates drawing parameters
Top
Events
 | Name | Description
Public event | IsLockedChanged | Event that is raised when Lock property of the component is changed (Inherited from ILockableObject.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
Represent a drawing in the drawing world. It is basially a collection of geometries or a texture.
See Also

Reference

VisualComponents.Create3D Namespace


IDrawingView Properties

The IDrawingView type exposes the following members.

Properties
 | Name | Description
Public property | Annotations | List of IAnnotation attached to this drawing
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Frames | Retrieves a list of IFrame inside this drawing
Public property | Height | Height of the texture of the path if any
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsLocked | (Inherited from ILockableObject.)
Public property | IsPersistent | Defines if the ILayoutItem is stored with the layout. (Inherited from ILayoutItem.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Lines | Retrieves a list of ILineSet inside this drawing
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | Scale | Expressed in the format x:y
Public property | ScaleFactor | Returns the result of x/y
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | Texts | Retrieves a list of IText3DSet inside this drawing
Public property | TexturePath | Path of the texture if the drawing is not intended to use geometries
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IVisualObject.)
Public property | TransformationInWorld | Gets or sets the world transformation matrix (Inherited from IVisualObject.)
Public property | Width | Width of the texture of the path if any
Public property | VisualizationNode | For internal purpose only
Top
See Also

Reference

IDrawingView Interface
VisualComponents.Create3D Namespace


IDrawingView.Annotations Property

IDrawingViewAnnotations Property

List of IAnnotation attached to this drawing

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IAnnotation> Annotations { get; }
property ReadOnlyCollection<IAnnotation^>^ Annotations {
    ReadOnlyCollection<IAnnotation^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIAnnotation
See Also

Reference

IDrawingView Interface
VisualComponents.Create3D Namespace


IDrawingView.Frames Property

IDrawingViewFrames Property

Retrieves a list of IFrame inside this drawing

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IFrame> Frames { get; }
property ReadOnlyCollection<IFrame^>^ Frames {
    ReadOnlyCollection<IFrame^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIFrame
See Also

Reference

IDrawingView Interface
VisualComponents.Create3D Namespace


IDrawingView.Height Property

IDrawingViewHeight Property

Height of the texture of the path if any

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Height { get; set; }
property double Height {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IDrawingView Interface
VisualComponents.Create3D Namespace


IDrawingView.Lines Property

IDrawingViewLines Property

Retrieves a list of ILineSet inside this drawing

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ILineSet> Lines { get; }
property ReadOnlyCollection<ILineSet^>^ Lines {
    ReadOnlyCollection<ILineSet^>^ get ();
}

Property Value

Type: ReadOnlyCollectionILineSet
See Also

Reference

IDrawingView Interface
VisualComponents.Create3D Namespace


IDrawingView.Scale Property

IDrawingViewScale Property

Expressed in the format x:y

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Scale { get; set; }
property String^ Scale {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IDrawingView Interface
VisualComponents.Create3D Namespace


IDrawingView.ScaleFactor Property

IDrawingViewScaleFactor Property

Returns the result of x/y

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double ScaleFactor { get; }
property double ScaleFactor {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IDrawingView Interface
VisualComponents.Create3D Namespace


IDrawingView.Texts Property

IDrawingViewTexts Property

Retrieves a list of IText3DSet inside this drawing

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IText3DSet> Texts { get; }
property ReadOnlyCollection<IText3DSet^>^ Texts {
    ReadOnlyCollection<IText3DSet^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIText3DSet
See Also

Reference

IDrawingView Interface
VisualComponents.Create3D Namespace


IDrawingView.TexturePath Property

IDrawingViewTexturePath Property

Path of the texture if the drawing is not intended to use geometries

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string TexturePath { get; set; }
property String^ TexturePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IDrawingView Interface
VisualComponents.Create3D Namespace


IDrawingView.Width Property

IDrawingViewWidth Property

Width of the texture of the path if any

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Width { get; set; }
property double Width {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IDrawingView Interface
VisualComponents.Create3D Namespace


IDrawingView.VisualizationNode Property

IDrawingViewVisualizationNode Property

For internal purpose only

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IntPtr VisualizationNode { get; }
property IntPtr VisualizationNode {
    IntPtr get ();
}

Property Value

Type: IntPtr
See Also

Reference

IDrawingView Interface
VisualComponents.Create3D Namespace


IDrawingView Methods

The IDrawingView type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ClearFrames | Removes all frames in this drawing
Public method | ClearLines | Removes all lines in this drawing
Public method | ClearTexts | Removes all texts in this drawing
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetFrames | Set frames for the drawing
Public method | SetLines | Set lines for the drawing
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTexts | Set texts for the drawing
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | Update | Updates drawing parameters
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IDrawingView Interface
VisualComponents.Create3D Namespace


IDrawingView.ClearFrames Method

IDrawingViewClearFrames Method

Removes all frames in this drawing

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ClearFrames()
void ClearFrames()
See Also

Reference

IDrawingView Interface
VisualComponents.Create3D Namespace


IDrawingView.ClearLines Method

IDrawingViewClearLines Method

Removes all lines in this drawing

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ClearLines()
void ClearLines()
See Also

Reference

IDrawingView Interface
VisualComponents.Create3D Namespace


IDrawingView.ClearTexts Method

IDrawingViewClearTexts Method

Removes all texts in this drawing

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ClearTexts()
void ClearTexts()
See Also

Reference

IDrawingView Interface
VisualComponents.Create3D Namespace


IDrawingView.SetFrames Method

IDrawingViewSetFrames Method

Set frames for the drawing

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetFrames(
    IEnumerable<IFrame> frames
)
void SetFrames(
    IEnumerable<IFrame^>^ frames
)

Parameters

frames
Type: System.Collections.GenericIEnumerableIFrame
See Also

Reference

IDrawingView Interface
VisualComponents.Create3D Namespace


IDrawingView.SetLines Method

IDrawingViewSetLines Method

Set lines for the drawing

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetLines(
    IEnumerable<ILineSet> lines
)
void SetLines(
    IEnumerable<ILineSet^>^ lines
)

Parameters

lines
Type: System.Collections.GenericIEnumerableILineSet
See Also

Reference

IDrawingView Interface
VisualComponents.Create3D Namespace


IDrawingView.SetTexts Method

IDrawingViewSetTexts Method

Set texts for the drawing

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetTexts(
    IEnumerable<IText3DSet> texts
)
void SetTexts(
    IEnumerable<IText3DSet^>^ texts
)

Parameters

texts
Type: System.Collections.GenericIEnumerableIText3DSet
See Also

Reference

IDrawingView Interface
VisualComponents.Create3D Namespace


IDrawingView.Update Method

IDrawingViewUpdate Method

Updates drawing parameters

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Update()
void Update()
See Also

Reference

IDrawingView Interface
VisualComponents.Create3D Namespace


IDrawingView Events

The IDrawingView type exposes the following members.

Events
 | Name | Description
Public event | IsLockedChanged | Event that is raised when Lock property of the component is changed (Inherited from ILockableObject.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

IDrawingView Interface
VisualComponents.Create3D Namespace


IDurable Interface

Objects implementing this marker interface have object lifetime equal to applications.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDurable
public interface class IDurable
See Also

Reference

VisualComponents.Create3D Namespace


IEcatSection Interface

Configuration file section for General Options.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IEcatSection : ISection
public interface class IEcatSection : ISection

The IEcatSection type exposes the following members.

Properties
 | Name | Description
Public property | Elements | Gets Ecat configuration items.
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | FixFirstVersionIssue | Fixes an issue relating to the Offline folder
Public method | GetSection | Gets the section (Inherited from ISection.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IEcatSection Properties

The IEcatSection type exposes the following members.

Properties
 | Name | Description
Public property | Elements | Gets Ecat configuration items.
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
See Also

Reference

IEcatSection Interface
VisualComponents.Create3D Namespace


IEcatSection.Elements Property

IEcatSectionElements Property

Gets Ecat configuration items.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
EcatConfigCollection Elements { get; }
property EcatConfigCollection^ Elements {
    EcatConfigCollection^ get ();
}

Property Value

Type: EcatConfigCollection
See Also

Reference

IEcatSection Interface
VisualComponents.Create3D Namespace


IEcatSection Methods

The IEcatSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | FixFirstVersionIssue | Fixes an issue relating to the Offline folder
Public method | GetSection | Gets the section (Inherited from ISection.)
Top
See Also

Reference

IEcatSection Interface
VisualComponents.Create3D Namespace


IEcatSection.FixFirstVersionIssue Method

IEcatSectionFixFirstVersionIssue Method

Fixes an issue relating to the Offline folder

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool FixFirstVersionIssue()
bool FixFirstVersionIssue()

Return Value

Type: Boolean
true if it's first version of the section
See Also

Reference

IEcatSection Interface
VisualComponents.Create3D Namespace


IEdge Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IEdge
public interface class IEdge

The IEdge type exposes the following members.

Properties
 | Name | Description
Public property | CurveIndex |
Public property | EndDirections |
Public property | Endpoints |
Public property | IsArc |
Public property | IsClosed |
Public property | IsSinglePart |
Public property | LineSet |
Public property | Midpoint |
Public property | TopologyCurve |
Public property | TopologyCurveLength |
Public property | TriangleSet |
Public property | UseMathData | Defines which one of {NURBS, tesselated trimesh} is used for other calculations
Top
Methods
 | Name | Description
Public method | Equals |
Public method | GetArcCenterAndNormal |
Public method | GetClosestPointAndDistance | Returns closest point pose and distance to the ray
Public method | GetHashCode |
Public method | GetSingleArc |
Public method | GetSingleLine |
Public method | GetTopologyCurveNormalDirection |
Public method | GetTopologyPolyline(NullableMatrix) |
Public method | GetTopologyPolyline(NullableMatrix, Double, Double, Double) |
Public method | GetTopologyPolyline(NullableMatrix, Double, Double, Double, Boolean) |
Top
See Also

Reference

VisualComponents.Create3D Namespace


IEdge Properties

The IEdge type exposes the following members.

Properties
 | Name | Description
Public property | CurveIndex |
Public property | EndDirections |
Public property | Endpoints |
Public property | IsArc |
Public property | IsClosed |
Public property | IsSinglePart |
Public property | LineSet |
Public property | Midpoint |
Public property | TopologyCurve |
Public property | TopologyCurveLength |
Public property | TriangleSet |
Public property | UseMathData | Defines which one of {NURBS, tesselated trimesh} is used for other calculations
Top
See Also

Reference

IEdge Interface
VisualComponents.Create3D Namespace


IEdge.CurveIndex Property

IEdgeCurveIndex Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int CurveIndex { get; }
property int CurveIndex {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IEdge Interface
VisualComponents.Create3D Namespace


IEdge.EndDirections Property

IEdgeEndDirections Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Tuple<Vector3, Vector3> EndDirections { get; }
property Tuple<Vector3, Vector3>^ EndDirections {
    Tuple<Vector3, Vector3>^ get ();
}

Property Value

Type: TupleVector3, Vector3
See Also

Reference

IEdge Interface
VisualComponents.Create3D Namespace


IEdge.Endpoints Property

IEdgeEndpoints Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Tuple<Vector3, Vector3> Endpoints { get; }
property Tuple<Vector3, Vector3>^ Endpoints {
    Tuple<Vector3, Vector3>^ get ();
}

Property Value

Type: TupleVector3, Vector3
See Also

Reference

IEdge Interface
VisualComponents.Create3D Namespace


IEdge.IsArc Property

IEdgeIsArc Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsArc { get; }
property bool IsArc {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IEdge Interface
VisualComponents.Create3D Namespace


IEdge.IsClosed Property

IEdgeIsClosed Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsClosed { get; }
property bool IsClosed {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IEdge Interface
VisualComponents.Create3D Namespace


IEdge.IsSinglePart Property

IEdgeIsSinglePart Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsSinglePart { get; }
property bool IsSinglePart {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IEdge Interface
VisualComponents.Create3D Namespace


IEdge.LineSet Property

IEdgeLineSet Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ILineSet LineSet { get; }
property ILineSet^ LineSet {
    ILineSet^ get ();
}

Property Value

Type: ILineSet
See Also

Reference

IEdge Interface
VisualComponents.Create3D Namespace


IEdge.Midpoint Property

IEdgeMidpoint Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 Midpoint { get; }
property Vector3 Midpoint {
    Vector3 get ();
}

Property Value

Type: Vector3
See Also

Reference

IEdge Interface
VisualComponents.Create3D Namespace


IEdge.TopologyCurve Property

IEdgeTopologyCurve Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ITopologyCurve TopologyCurve { get; }
property ITopologyCurve^ TopologyCurve {
    ITopologyCurve^ get ();
}

Property Value

Type: ITopologyCurve
See Also

Reference

IEdge Interface
VisualComponents.Create3D Namespace


IEdge.TopologyCurveLength Property

IEdgeTopologyCurveLength Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double TopologyCurveLength { get; }
property double TopologyCurveLength {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IEdge Interface
VisualComponents.Create3D Namespace


IEdge.TriangleSet Property

IEdgeTriangleSet Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ITriangleSet TriangleSet { get; }
property ITriangleSet^ TriangleSet {
    ITriangleSet^ get ();
}

Property Value

Type: ITriangleSet
See Also

Reference

IEdge Interface
VisualComponents.Create3D Namespace


IEdge.UseMathData Property

IEdgeUseMathData Property

Defines which one of {NURBS, tesselated trimesh} is used for other calculations

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool UseMathData { get; set; }
property bool UseMathData {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
By default, when NURBS data is available, it will be used. Toggling this off, will use the tesselated trimesh model in all cases. This allows to speed up some operations (e.g., path statement _preview_) where accuracy is not as important as the performance.
See Also

Reference

IEdge Interface
VisualComponents.Create3D Namespace


IEdge Methods

The IEdge type exposes the following members.

Methods
 | Name | Description
Public method | Equals |
Public method | GetArcCenterAndNormal |
Public method | GetClosestPointAndDistance | Returns closest point pose and distance to the ray
Public method | GetHashCode |
Public method | GetSingleArc |
Public method | GetSingleLine |
Public method | GetTopologyCurveNormalDirection |
Public method | GetTopologyPolyline(NullableMatrix) |
Public method | GetTopologyPolyline(NullableMatrix, Double, Double, Double) |
Public method | GetTopologyPolyline(NullableMatrix, Double, Double, Double, Boolean) |
Top
See Also

Reference

IEdge Interface
VisualComponents.Create3D Namespace


IEdge.Equals Method

IEdgeEquals Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool Equals(
    Object other
)
bool Equals(
    Object^ other
)

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IEdge.Equals(System.Object)"]

See Also

Reference

IEdge Interface
VisualComponents.Create3D Namespace


IEdge.GetArcCenterAndNormal Method

IEdgeGetArcCenterAndNormal Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Tuple<Vector3, Vector3> GetArcCenterAndNormal(
    double tolerance
)
Tuple<Vector3, Vector3>^ GetArcCenterAndNormal(
    double tolerance
)

Parameters

tolerance
Type: SystemDouble

Return Value

Type: TupleVector3, Vector3

[Missing <returns> documentation for "M:VisualComponents.Create3D.IEdge.GetArcCenterAndNormal(System.Double)"]

See Also

Reference

IEdge Interface
VisualComponents.Create3D Namespace


IEdge.GetClosestPointAndDistance Method

IEdgeGetClosestPointAndDistance Method

Returns closest point pose and distance to the ray

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Tuple<Vector3, Vector3, double> GetClosestPointAndDistance(
    Vector3 rayStart,
    Vector3 rayEnd
)
Tuple<Vector3, Vector3, double>^ GetClosestPointAndDistance(
    Vector3 rayStart,
    Vector3 rayEnd
)

Parameters

rayStart
Type: VisualComponents.Create3DVector3
rayEnd
Type: VisualComponents.Create3DVector3

Return Value

Type: TupleVector3, Vector3, Double
Tuple of (position, direction, distance)
See Also

Reference

IEdge Interface
VisualComponents.Create3D Namespace


IEdge.GetHashCode Method

IEdgeGetHashCode Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int GetHashCode()
int GetHashCode()

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.IEdge.GetHashCode"]

See Also

Reference

IEdge Interface
VisualComponents.Create3D Namespace


IEdge.GetSingleArc Method

IEdgeGetSingleArc Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEdge GetSingleArc(
    double atDistance
)
IEdge^ GetSingleArc(
    double atDistance
)

Parameters

atDistance
Type: SystemDouble

Return Value

Type: IEdge

[Missing <returns> documentation for "M:VisualComponents.Create3D.IEdge.GetSingleArc(System.Double)"]

See Also

Reference

IEdge Interface
VisualComponents.Create3D Namespace


IEdge.GetSingleLine Method

IEdgeGetSingleLine Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEdge GetSingleLine(
    double atDistance
)
IEdge^ GetSingleLine(
    double atDistance
)

Parameters

atDistance
Type: SystemDouble

Return Value

Type: IEdge

[Missing <returns> documentation for "M:VisualComponents.Create3D.IEdge.GetSingleLine(System.Double)"]

See Also

Reference

IEdge Interface
VisualComponents.Create3D Namespace


IEdge.GetTopologyCurveNormalDirection Method

IEdgeGetTopologyCurveNormalDirection Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Tuple<Vector3, Vector3, Vector3> GetTopologyCurveNormalDirection(
    double curveDistance
)
Tuple<Vector3, Vector3, Vector3>^ GetTopologyCurveNormalDirection(
    double curveDistance
)

Parameters

curveDistance
Type: SystemDouble

Return Value

Type: TupleVector3, Vector3, Vector3

[Missing <returns> documentation for "M:VisualComponents.Create3D.IEdge.GetTopologyCurveNormalDirection(System.Double)"]

See Also

Reference

IEdge Interface
VisualComponents.Create3D Namespace


IEdge.GetTopologyPolyline Method

IEdgeGetTopologyPolyline Method

Overload List
 | Name | Description
Public method | GetTopologyPolyline(NullableMatrix) |
Public method | GetTopologyPolyline(NullableMatrix, Double, Double, Double) |
Public method | GetTopologyPolyline(NullableMatrix, Double, Double, Double, Boolean) |
Top
See Also

Reference

IEdge Interface
VisualComponents.Create3D Namespace


IEdge.GetTopologyPolyline Method (Nullable(Matrix))

IEdgeGetTopologyPolyline Method (NullableMatrix)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<Vector3> GetTopologyPolyline(
    Nullable<Matrix> mat
)
ReadOnlyCollection<Vector3>^ GetTopologyPolyline(
    Nullable<Matrix> mat
)

Parameters

mat
Type: SystemNullableMatrix

Return Value

Type: ReadOnlyCollectionVector3

[Missing <returns> documentation for "M:VisualComponents.Create3D.IEdge.GetTopologyPolyline(System.Nullable{VisualComponents.Create3D.Matrix})"]

See Also

Reference

IEdge Interface
GetTopologyPolyline Overload
VisualComponents.Create3D Namespace


IEdge.GetTopologyPolyline Method (Nullable(Matrix), Double, Double, Double)

IEdgeGetTopologyPolyline Method (NullableMatrix, Double, Double, Double)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<Vector3> GetTopologyPolyline(
    Nullable<Matrix> mat,
    double fromDistance,
    double toDistance,
    double distanceThreshold
)
ReadOnlyCollection<Vector3>^ GetTopologyPolyline(
    Nullable<Matrix> mat,
    double fromDistance,
    double toDistance,
    double distanceThreshold
)

Parameters

mat
Type: SystemNullableMatrix
fromDistance
Type: SystemDouble
toDistance
Type: SystemDouble
distanceThreshold
Type: SystemDouble

Return Value

Type: ReadOnlyCollectionVector3

[Missing <returns> documentation for "M:VisualComponents.Create3D.IEdge.GetTopologyPolyline(System.Nullable{VisualComponents.Create3D.Matrix},System.Double,System.Double,System.Double)"]

See Also

Reference

IEdge Interface
GetTopologyPolyline Overload
VisualComponents.Create3D Namespace


IEdge.GetTopologyPolyline Method (Nullable(Matrix), Double, Double, Double, Boolean)

IEdgeGetTopologyPolyline Method (NullableMatrix, Double, Double, Double, Boolean)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<Vector3> GetTopologyPolyline(
    Nullable<Matrix> mat,
    double fromDistance,
    double toDistance,
    double distanceThreshold,
    bool allowEmpty
)
ReadOnlyCollection<Vector3>^ GetTopologyPolyline(
    Nullable<Matrix> mat,
    double fromDistance,
    double toDistance,
    double distanceThreshold,
    bool allowEmpty
)

Parameters

mat
Type: SystemNullableMatrix
fromDistance
Type: SystemDouble
toDistance
Type: SystemDouble
distanceThreshold
Type: SystemDouble
allowEmpty
Type: SystemBoolean

Return Value

Type: ReadOnlyCollectionVector3

[Missing <returns> documentation for "M:VisualComponents.Create3D.IEdge.GetTopologyPolyline(System.Nullable{VisualComponents.Create3D.Matrix},System.Double,System.Double,System.Double,System.Boolean)"]

See Also

Reference

IEdge Interface
GetTopologyPolyline Overload
VisualComponents.Create3D Namespace


IExecutor Interface

Executor behavior base interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IExecutor : IStatementExecutor,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed
public interface class IExecutor : IStatementExecutor,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed

The IExecutor type exposes the following members.

Properties
 | Name | Description
Public property | ActiveProgram | Gets or sets the currently active program. (Inherited from IStatementExecutor.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CurrentScope | Get the scope that is currently being executed. (Inherited from IStatementExecutor.)
Public property | CurrentStatement | Gets the current position of the program pointer. Returns null if in the beginning of scope. (Inherited from IStatementExecutor.)
Public property | DigitalInputSignals | Gets or sets the input ISignalMap associated to this IExecutor.
Public property | DigitalOutputSignals | Gets or sets the output ISignalMap associated to this IExecutor.
Public property | IsEnabled | Defines if the executor will execute its program. (Inherited from IStatementExecutor.)
Public property | IsIdle | Returns true if, and only if, the executor is currently not executing any IStatements or IStatementScopes.
Public property | IsLooping | Defines if the executor will restart the program automatically when finished. (Inherited from IStatementExecutor.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Program | Gets the first program contained by this IStatementExecutor instance. (Inherited from IStatementExecutor.)
Public property | Programs | Gets all the instances of IProgram in this executor. (Inherited from IStatementExecutor.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | StatementHandler | Gets or sets the instance of IProcessHandler that can be used for overriding or customizing the execution of IStatement instances.
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | ClearPrograms | (Inherited from IStatementExecutor.)
Public method | Continue | Continues execution. (Inherited from IStatementExecutor.)
Public method | Continue(Double) | Continues the execution after a given time. (Inherited from IStatementExecutor.)
Public method | CreateProgram | Creates a new instance of IProgram. (Inherited from IStatementExecutor.)
Public method | CreateProgram(String) | Creates a new instance of IProgram. (Inherited from IStatementExecutor.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProgram | Deletes the given instance of IProgram (Inherited from IStatementExecutor.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | ExecuteStep | Execute the next IStatement. (Inherited from IStatementExecutor.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | JumpToScope | Adds the current program position to the stack and jumps program execution to the given scope. When the scope is finished, the progam will continue from the current position. (Inherited from IStatementExecutor.)
Public method | NotifyStatementExecutedEx | Signals ExecutedEx event for this statement. This should only be used together with custom statements that have set the value of ControlExecutedExEvent to true. (Inherited from IStatementExecutor.)
Public method | Reset | Reset the execution to the beginning of the program. (Inherited from IStatementExecutor.)
Public method | SetProgramPointer | Sets the program pointer to the given position. When executed, the program will start from this position. (Inherited from IStatementExecutor.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ActiveProgramChanged | Occurs when the value of ActiveProgram has changed. (Inherited from IStatementExecutor.)
Public event | CurrentStatementChanged | Obsolete. An event that is raised when the executor begins to execute a IStatement.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | ProgramAdded | Occurs when a new instance of IProgram has been added to this instance of IStatementExecutor. (Inherited from IStatementExecutor.)
Public event | ProgramFinished | An event that is raised when the executor has executed its program.
Public event | ProgramRemoving | Occurs when an instance of IProgram is being removed from this instance of IStatementExecutor. (Inherited from IStatementExecutor.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | StatementExecuted | An event that is raised when the executor has executed a IStatement.
Public event | StatementExecuting | An event that is raised when the executor begins to execute a IStatement.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IExecutor Properties

The IExecutor type exposes the following members.

Properties
 | Name | Description
Public property | ActiveProgram | Gets or sets the currently active program. (Inherited from IStatementExecutor.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CurrentScope | Get the scope that is currently being executed. (Inherited from IStatementExecutor.)
Public property | CurrentStatement | Gets the current position of the program pointer. Returns null if in the beginning of scope. (Inherited from IStatementExecutor.)
Public property | DigitalInputSignals | Gets or sets the input ISignalMap associated to this IExecutor.
Public property | DigitalOutputSignals | Gets or sets the output ISignalMap associated to this IExecutor.
Public property | IsEnabled | Defines if the executor will execute its program. (Inherited from IStatementExecutor.)
Public property | IsIdle | Returns true if, and only if, the executor is currently not executing any IStatements or IStatementScopes.
Public property | IsLooping | Defines if the executor will restart the program automatically when finished. (Inherited from IStatementExecutor.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Program | Gets the first program contained by this IStatementExecutor instance. (Inherited from IStatementExecutor.)
Public property | Programs | Gets all the instances of IProgram in this executor. (Inherited from IStatementExecutor.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | StatementHandler | Gets or sets the instance of IProcessHandler that can be used for overriding or customizing the execution of IStatement instances.
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IExecutor Interface
VisualComponents.Create3D Namespace


IExecutor.DigitalInputSignals Property

IExecutorDigitalInputSignals Property

Gets or sets the input ISignalMap associated to this IExecutor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISignalMap DigitalInputSignals { get; set; }
property ISignalMap^ DigitalInputSignals {
    ISignalMap^ get ();
    void set (ISignalMap^ value);
}

Property Value

Type: ISignalMap
See Also

Reference

IExecutor Interface
VisualComponents.Create3D Namespace


IExecutor.DigitalOutputSignals Property

IExecutorDigitalOutputSignals Property

Gets or sets the output ISignalMap associated to this IExecutor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISignalMap DigitalOutputSignals { get; set; }
property ISignalMap^ DigitalOutputSignals {
    ISignalMap^ get ();
    void set (ISignalMap^ value);
}

Property Value

Type: ISignalMap
See Also

Reference

IExecutor Interface
VisualComponents.Create3D Namespace


IExecutor.IsIdle Property

IExecutorIsIdle Property

Returns true if, and only if, the executor is currently not executing any IStatements or IStatementScopes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsIdle { get; }
property bool IsIdle {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IExecutor Interface
VisualComponents.Create3D Namespace


IExecutor.StatementHandler Property

IExecutorStatementHandler Property

Gets or sets the instance of IProcessHandler that can be used for overriding or customizing the execution of IStatement instances.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessHandler StatementHandler { get; set; }
property IProcessHandler^ StatementHandler {
    IProcessHandler^ get ();
    void set (IProcessHandler^ value);
}

Property Value

Type: IProcessHandler
See Also

Reference

IExecutor Interface
VisualComponents.Create3D Namespace


IExecutor Methods

The IExecutor type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | ClearPrograms | (Inherited from IStatementExecutor.)
Public method | Continue | Continues execution. (Inherited from IStatementExecutor.)
Public method | Continue(Double) | Continues the execution after a given time. (Inherited from IStatementExecutor.)
Public method | CreateProgram | Creates a new instance of IProgram. (Inherited from IStatementExecutor.)
Public method | CreateProgram(String) | Creates a new instance of IProgram. (Inherited from IStatementExecutor.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProgram | Deletes the given instance of IProgram (Inherited from IStatementExecutor.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | ExecuteStep | Execute the next IStatement. (Inherited from IStatementExecutor.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | JumpToScope | Adds the current program position to the stack and jumps program execution to the given scope. When the scope is finished, the progam will continue from the current position. (Inherited from IStatementExecutor.)
Public method | NotifyStatementExecutedEx | Signals ExecutedEx event for this statement. This should only be used together with custom statements that have set the value of ControlExecutedExEvent to true. (Inherited from IStatementExecutor.)
Public method | Reset | Reset the execution to the beginning of the program. (Inherited from IStatementExecutor.)
Public method | SetProgramPointer | Sets the program pointer to the given position. When executed, the program will start from this position. (Inherited from IStatementExecutor.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IExecutor Interface
VisualComponents.Create3D Namespace


IExecutor Events

The IExecutor type exposes the following members.

Events
 | Name | Description
Public event | ActiveProgramChanged | Occurs when the value of ActiveProgram has changed. (Inherited from IStatementExecutor.)
Public event | CurrentStatementChanged | Obsolete. An event that is raised when the executor begins to execute a IStatement.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | ProgramAdded | Occurs when a new instance of IProgram has been added to this instance of IStatementExecutor. (Inherited from IStatementExecutor.)
Public event | ProgramFinished | An event that is raised when the executor has executed its program.
Public event | ProgramRemoving | Occurs when an instance of IProgram is being removed from this instance of IStatementExecutor. (Inherited from IStatementExecutor.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | StatementExecuted | An event that is raised when the executor has executed a IStatement.
Public event | StatementExecuting | An event that is raised when the executor begins to execute a IStatement.
Top
See Also

Reference

IExecutor Interface
VisualComponents.Create3D Namespace


IExecutor.CurrentStatementChanged Event

IExecutorCurrentStatementChanged Event

Note: This API is now obsolete.

An event that is raised when the executor begins to execute a IStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Use StatementExecuting event instead.")]
event EventHandler<EventArgs> CurrentStatementChanged
[ObsoleteAttribute(L"Use StatementExecuting event instead.")]
 event EventHandler<EventArgs^>^ CurrentStatementChanged {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
Remarks
This event is obsolete. Use StatementExecuting instead.
See Also

Reference

IExecutor Interface
VisualComponents.Create3D Namespace


IExecutor.ProgramFinished Event

IExecutorProgramFinished Event

An event that is raised when the executor has executed its program.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> ProgramFinished
 event EventHandler<EventArgs^>^ ProgramFinished {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

IExecutor Interface
VisualComponents.Create3D Namespace


IExecutor.StatementExecuted Event

IExecutorStatementExecuted Event

An event that is raised when the executor has executed a IStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<StatementExecutedEventArgs> StatementExecuted
 event EventHandler<StatementExecutedEventArgs^>^ StatementExecuted {
    void add (EventHandler<StatementExecutedEventArgs^>^ value);
    void remove (EventHandler<StatementExecutedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerStatementExecutedEventArgs
See Also

Reference

IExecutor Interface
VisualComponents.Create3D Namespace


IExecutor.StatementExecuting Event

IExecutorStatementExecuting Event

An event that is raised when the executor begins to execute a IStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<StatementExecutingEventArgs> StatementExecuting
 event EventHandler<StatementExecutingEventArgs^>^ StatementExecuting {
    void add (EventHandler<StatementExecutingEventArgs^>^ value);
    void remove (EventHandler<StatementExecutingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerStatementExecutingEventArgs
See Also

Reference

IExecutor Interface
VisualComponents.Create3D Namespace


IExpressionContext Interface

Expression context interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IExpressionContext
public interface class IExpressionContext

The IExpressionContext type exposes the following members.

Properties
 | Name | Description
Public property | FunctionList | List of function and operation names that may be used in expressions using this context.
Public property | Functions | Detailed list of all functions available in this context.
Top
Remarks

The expression context determines which operations are available for use in expression strings.

See Also

Reference

VisualComponents.Create3D Namespace


IExpressionContext Properties

The IExpressionContext type exposes the following members.

Properties
 | Name | Description
Public property | FunctionList | List of function and operation names that may be used in expressions using this context.
Public property | Functions | Detailed list of all functions available in this context.
Top
See Also

Reference

IExpressionContext Interface
VisualComponents.Create3D Namespace


IExpressionContext.FunctionList Property

IExpressionContextFunctionList Property

List of function and operation names that may be used in expressions using this context.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<string> FunctionList { get; }
property IEnumerable<String^>^ FunctionList {
    IEnumerable<String^>^ get ();
}

Property Value

Type: IEnumerableString
See Also

Reference

IExpressionContext Interface
VisualComponents.Create3D Namespace


IExpressionContext.Functions Property

IExpressionContextFunctions Property

Detailed list of all functions available in this context.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<ExpressionFunction> Functions { get; }
property IEnumerable<ExpressionFunction>^ Functions {
    IEnumerable<ExpressionFunction>^ get ();
}

Property Value

Type: IEnumerableExpressionFunction
See Also

Reference

IExpressionContext Interface
VisualComponents.Create3D Namespace


IExpressionEvaluator Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IExpressionEvaluator
public interface class IExpressionEvaluator

The IExpressionEvaluator type exposes the following members.

Methods
 | Name | Description
Public method | EvaluateExpression | Evaluate expression.
Public method | GetCompletions | Get completion information for expression.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IExpressionEvaluator Methods

The IExpressionEvaluator type exposes the following members.

Methods
 | Name | Description
Public method | EvaluateExpression | Evaluate expression.
Public method | GetCompletions | Get completion information for expression.
Top
See Also

Reference

IExpressionEvaluator Interface
VisualComponents.Create3D Namespace


IExpressionEvaluator.EvaluateExpression Method

IExpressionEvaluatorEvaluateExpression Method

Evaluate expression.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object EvaluateExpression(
    string value,
    IExpressionContext expressionContext
)
Object^ EvaluateExpression(
    String^ value,
    IExpressionContext^ expressionContext
)

Parameters

value
Type: SystemString
Expression string.
expressionContext
Type: VisualComponents.Create3DIExpressionContext
Expression context.

Return Value

Type: Object
Evaluated value
See Also

Reference

IExpressionEvaluator Interface
VisualComponents.Create3D Namespace


IExpressionEvaluator.GetCompletions Method

IExpressionEvaluatorGetCompletions Method

Get completion information for expression.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ICompletionInfo GetCompletions(
    string expression,
    int cursorPosition,
    IExpressionContext context,
    Type resultType
)
ICompletionInfo^ GetCompletions(
    String^ expression,
    int cursorPosition,
    IExpressionContext^ context,
    Type^ resultType
)

Parameters

expression
Type: SystemString
Expression string
cursorPosition
Type: SystemInt32
Cursor position for completions
context
Type: VisualComponents.Create3DIExpressionContext
Expression context.
resultType
Type: SystemType
Result type, or null for no restriction.

Return Value

Type: ICompletionInfo

[Missing <returns> documentation for "M:VisualComponents.Create3D.IExpressionEvaluator.GetCompletions(System.String,System.Int32,VisualComponents.Create3D.IExpressionContext,System.Type)"]

See Also

Reference

IExpressionEvaluator Interface
VisualComponents.Create3D Namespace


IExpressionProperty Interface

Expression property interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IExpressionProperty : IProperty,
    INotifyPropertyChanged, IDisposable, INamed
public interface class IExpressionProperty : IProperty,
    INotifyPropertyChanged, IDisposable, INamed

The IExpressionProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Allowed maximum value for the property. (Inherited from IProperty.)
Public property | AllowedMinimum | Allowed minimum value for the property. (Inherited from IProperty.)
Public property | AllowedValues | Collection of allowed values for constrained properties. (Inherited from IProperty.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | ErrorMessage | Error message that is caused after evaluating expression.
Public property | Expression | Expression that is evaluated to determine the property value.
Public property | ExpressionContext | Expression context in which the expression is evaluated.
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsConstant | Whether the expression is a constant expression.
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsDeterministic | Whether the expression value is deterministic.
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | RequiredExpressionType | Required type of the expression result.
Public property | ResultString | String representation of expression result.
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Property value as an object. (Inherited from IProperty.)
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | IsDependentOn | Whether the expression value is dependent on variable.
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IExpressionProperty Properties

The IExpressionProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Allowed maximum value for the property. (Inherited from IProperty.)
Public property | AllowedMinimum | Allowed minimum value for the property. (Inherited from IProperty.)
Public property | AllowedValues | Collection of allowed values for constrained properties. (Inherited from IProperty.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | ErrorMessage | Error message that is caused after evaluating expression.
Public property | Expression | Expression that is evaluated to determine the property value.
Public property | ExpressionContext | Expression context in which the expression is evaluated.
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsConstant | Whether the expression is a constant expression.
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsDeterministic | Whether the expression value is deterministic.
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | RequiredExpressionType | Required type of the expression result.
Public property | ResultString | String representation of expression result.
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Property value as an object. (Inherited from IProperty.)
Top
See Also

Reference

IExpressionProperty Interface
VisualComponents.Create3D Namespace


IExpressionProperty.ErrorMessage Property

IExpressionPropertyErrorMessage Property

Error message that is caused after evaluating expression.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ErrorMessage { get; }
property String^ ErrorMessage {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IExpressionProperty Interface
VisualComponents.Create3D Namespace


IExpressionProperty.Expression Property

IExpressionPropertyExpression Property

Expression that is evaluated to determine the property value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Expression { get; set; }
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IExpressionProperty Interface
VisualComponents.Create3D Namespace


IExpressionProperty.ExpressionContext Property

IExpressionPropertyExpressionContext Property

Expression context in which the expression is evaluated.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IExpressionContext ExpressionContext { get; }
property IExpressionContext^ ExpressionContext {
    IExpressionContext^ get ();
}

Property Value

Type: IExpressionContext
See Also

Reference

IExpressionProperty Interface
VisualComponents.Create3D Namespace


IExpressionProperty.IsConstant Property

IExpressionPropertyIsConstant Property

Whether the expression is a constant expression.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsConstant { get; }
property bool IsConstant {
    bool get ();
}

Property Value

Type: Boolean
Remarks
This property is true if the expression does not depend on any variables or random number input.
See Also

Reference

IExpressionProperty Interface
VisualComponents.Create3D Namespace


IExpressionProperty.IsDeterministic Property

IExpressionPropertyIsDeterministic Property

Whether the expression value is deterministic.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsDeterministic { get; }
property bool IsDeterministic {
    bool get ();
}

Property Value

Type: Boolean
Remarks
This property is false if the expression uses e.g. random number generation functions.
See Also

Reference

IExpressionProperty Interface
VisualComponents.Create3D Namespace


IExpressionProperty.RequiredExpressionType Property

IExpressionPropertyRequiredExpressionType Property

Required type of the expression result.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Type RequiredExpressionType { get; }
property Type^ RequiredExpressionType {
    Type^ get ();
}

Property Value

Type: Type
Remarks
This may be null if there is no required type for the expression.
See Also

Reference

IExpressionProperty Interface
VisualComponents.Create3D Namespace


IExpressionProperty.ResultString Property

IExpressionPropertyResultString Property

String representation of expression result.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ResultString { get; }
property String^ ResultString {
    String^ get ();
}

Property Value

Type: String
Remarks
This is intended for the user interface. It is empty if the expression is non-deterministic.
See Also

Reference

IExpressionProperty Interface
VisualComponents.Create3D Namespace


IExpressionProperty Methods

The IExpressionProperty type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | IsDependentOn | Whether the expression value is dependent on variable.
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

IExpressionProperty Interface
VisualComponents.Create3D Namespace


IExpressionProperty.IsDependentOn Method

IExpressionPropertyIsDependentOn Method

Whether the expression value is dependent on variable.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsDependentOn(
    IProperty propertyObject
)
bool IsDependentOn(
    IProperty^ propertyObject
)

Parameters

propertyObject
Type: VisualComponents.Create3DIProperty

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IExpressionProperty.IsDependentOn(VisualComponents.Create3D.IProperty)"]

See Also

Reference

IExpressionProperty Interface
VisualComponents.Create3D Namespace


IExpressionProperty Events

The IExpressionProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IExpressionProperty Interface
VisualComponents.Create3D Namespace


IExtrudeFeature Interface

Represents a extrude feature object

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IExtrudeFeature : IFeature,
    IVisualObject, INamed, IWrapper, IDisposable, IVisitable,
    IPropertyContainer, IBatchModeObject, ISharedCloneable
public interface class IExtrudeFeature : IFeature,
    IVisualObject, INamed, IWrapper, IDisposable, IVisitable,
    IPropertyContainer, IBatchModeObject, ISharedCloneable

The IExtrudeFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
The Extrude operation extrudes all geometries in the feature's sub trees. All faces are extruded into their normal direction and polylines to the direction defined by the Direction property. If a polyline is a convex loop top and bottom caps are generated for the extrusion, otherwise the top and bottom are left open.
See Also

Reference

VisualComponents.Create3D Namespace


IExtrudeFeature Properties

The IExtrudeFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
See Also

Reference

IExtrudeFeature Interface
VisualComponents.Create3D Namespace


IExtrudeFeature Methods

The IExtrudeFeature type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IExtrudeFeature Interface
VisualComponents.Create3D Namespace


IExtrudeFeature Events

The IExtrudeFeature type exposes the following members.

Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

IExtrudeFeature Interface
VisualComponents.Create3D Namespace


IFace Interface

Interface that provides additional information of a ITopologyFace

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IFace
public interface class IFace

The IFace type exposes the following members.

Properties
 | Name | Description
Public property | FaceIndex | Face index inside the triangle set
Public property | FaceType | Returns the face type
Public property | IsHighlighted | Determines if the face is highlighted
Public property | IsOuterLoopArc | Determines if an outer loop arc
Public property | IsPlanar | Determines if the face is planar
Public property | IsValid | Determines if this face wrapper instance is still valid
Public property | MathematicalFace | If this is a matematical face, this will give you access to addtional operation for this type of faces
Public property | Properties | Returns a tuple with the center and normal of the face
Public property | StartTriangle | First triangle index in this face
Public property | TopologyFace | Returns related topology face.
Public property | TopologyPolylineCount | For tesselated faces it returns 0, otherwise the number of face loops
Public property | TriangleCount | Number of triangles in this face
Public property | TriangleSet | Owner ITriangleSet
Top
Methods
 | Name | Description
Public method | Equals | Comparares if 2 IFace objects referred to the same instance
Public method | GetClosestCurve | Find face curve that is closest to ray.
Public method | GetClosestCurvePoint(Vector3) | Returns the closest curve point regarding a reference point
Public method | GetClosestCurvePoint(Vector3, Int32, Vector3, Int32, Int32) | Returns the closest curve point regarding a reference point
Public method | GetClosestFacePoint | Returns the closest face point regarding a reference point
Public method | GetClosestTriangle | For tesselated faces, returns the closet triangle index regarding a reference point
Public method | GetClosestTriangleEdge | Returns the closest triangle edge regarding a reference point
Public method | GetHashCode | internal purpose only
Public method | GetIntersection(Vector3, Vector3) | Intersect points between the given points.
Public method | GetIntersection(Vector3, Vector3, Boolean) | Intersect points between the given points.
Public method | GetPlaneIntersections | Returns face intersection (curve) points using plane defined by Matrix intersecting face
Public method | GetTopologyPolyline(NullableMatrix) | Returns a list of all points of all polylines in the given coordinate system
Public method | GetTopologyPolyline(NullableMatrix, Int32) | Returns a list of all points of all polylines in the given coordinate system
Public method | NeighborFaces | Returns a set of faces that are neighbor with this face. The set of faces includes this face as well
Top
See Also

Reference

VisualComponents.Create3D Namespace


IFace Properties

The IFace type exposes the following members.

Properties
 | Name | Description
Public property | FaceIndex | Face index inside the triangle set
Public property | FaceType | Returns the face type
Public property | IsHighlighted | Determines if the face is highlighted
Public property | IsOuterLoopArc | Determines if an outer loop arc
Public property | IsPlanar | Determines if the face is planar
Public property | IsValid | Determines if this face wrapper instance is still valid
Public property | MathematicalFace | If this is a matematical face, this will give you access to addtional operation for this type of faces
Public property | Properties | Returns a tuple with the center and normal of the face
Public property | StartTriangle | First triangle index in this face
Public property | TopologyFace | Returns related topology face.
Public property | TopologyPolylineCount | For tesselated faces it returns 0, otherwise the number of face loops
Public property | TriangleCount | Number of triangles in this face
Public property | TriangleSet | Owner ITriangleSet
Top
See Also

Reference

IFace Interface
VisualComponents.Create3D Namespace


IFace.FaceIndex Property

IFaceFaceIndex Property

Face index inside the triangle set

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int FaceIndex { get; }
property int FaceIndex {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IFace Interface
VisualComponents.Create3D Namespace


IFace.FaceType Property

IFaceFaceType Property

Returns the face type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
FaceType FaceType { get; }
property FaceType FaceType {
    FaceType get ();
}

Property Value

Type: FaceType
See Also

Reference

IFace Interface
VisualComponents.Create3D Namespace


IFace.IsHighlighted Property

IFaceIsHighlighted Property

Determines if the face is highlighted

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsHighlighted { get; set; }
property bool IsHighlighted {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IFace Interface
VisualComponents.Create3D Namespace


IFace.IsOuterLoopArc Property

IFaceIsOuterLoopArc Property

Determines if an outer loop arc

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsOuterLoopArc { get; }
property bool IsOuterLoopArc {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IFace Interface
VisualComponents.Create3D Namespace


IFace.IsPlanar Property

IFaceIsPlanar Property

Determines if the face is planar

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsPlanar { get; }
property bool IsPlanar {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IFace Interface
VisualComponents.Create3D Namespace


IFace.IsValid Property

IFaceIsValid Property

Determines if this face wrapper instance is still valid

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsValid { get; }
property bool IsValid {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IFace Interface
VisualComponents.Create3D Namespace


IFace.MathematicalFace Property

IFaceMathematicalFace Property

If this is a matematical face, this will give you access to addtional operation for this type of faces

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMathematicalFace MathematicalFace { get; }
property IMathematicalFace^ MathematicalFace {
    IMathematicalFace^ get ();
}

Property Value

Type: IMathematicalFace
See Also

Reference

IFace Interface
VisualComponents.Create3D Namespace


IFace.Properties Property

IFaceProperties Property

Returns a tuple with the center and normal of the face

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Tuple<Vector3, Vector3> Properties { get; }
property Tuple<Vector3, Vector3>^ Properties {
    Tuple<Vector3, Vector3>^ get ();
}

Property Value

Type: TupleVector3, Vector3
See Also

Reference

IFace Interface
VisualComponents.Create3D Namespace


IFace.StartTriangle Property

IFaceStartTriangle Property

First triangle index in this face

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int StartTriangle { get; }
property int StartTriangle {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IFace Interface
VisualComponents.Create3D Namespace


IFace.TopologyFace Property

IFaceTopologyFace Property

Returns related topology face.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ITopologyFace TopologyFace { get; }
property ITopologyFace^ TopologyFace {
    ITopologyFace^ get ();
}

Property Value

Type: ITopologyFace
See Also

Reference

IFace Interface
VisualComponents.Create3D Namespace


IFace.TopologyPolylineCount Property

IFaceTopologyPolylineCount Property

For tesselated faces it returns 0, otherwise the number of face loops

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int TopologyPolylineCount { get; }
property int TopologyPolylineCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IFace Interface
VisualComponents.Create3D Namespace


IFace.TriangleCount Property

IFaceTriangleCount Property

Number of triangles in this face

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int TriangleCount { get; }
property int TriangleCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IFace Interface
VisualComponents.Create3D Namespace


IFace.TriangleSet Property

IFaceTriangleSet Property

Owner ITriangleSet

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ITriangleSet TriangleSet { get; }
property ITriangleSet^ TriangleSet {
    ITriangleSet^ get ();
}

Property Value

Type: ITriangleSet
See Also

Reference

IFace Interface
VisualComponents.Create3D Namespace


IFace Methods

The IFace type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Comparares if 2 IFace objects referred to the same instance
Public method | GetClosestCurve | Find face curve that is closest to ray.
Public method | GetClosestCurvePoint(Vector3) | Returns the closest curve point regarding a reference point
Public method | GetClosestCurvePoint(Vector3, Int32, Vector3, Int32, Int32) | Returns the closest curve point regarding a reference point
Public method | GetClosestFacePoint | Returns the closest face point regarding a reference point
Public method | GetClosestTriangle | For tesselated faces, returns the closet triangle index regarding a reference point
Public method | GetClosestTriangleEdge | Returns the closest triangle edge regarding a reference point
Public method | GetHashCode | internal purpose only
Public method | GetIntersection(Vector3, Vector3) | Intersect points between the given points.
Public method | GetIntersection(Vector3, Vector3, Boolean) | Intersect points between the given points.
Public method | GetPlaneIntersections | Returns face intersection (curve) points using plane defined by Matrix intersecting face
Public method | GetTopologyPolyline(NullableMatrix) | Returns a list of all points of all polylines in the given coordinate system
Public method | GetTopologyPolyline(NullableMatrix, Int32) | Returns a list of all points of all polylines in the given coordinate system
Public method | NeighborFaces | Returns a set of faces that are neighbor with this face. The set of faces includes this face as well
Top
See Also

Reference

IFace Interface
VisualComponents.Create3D Namespace


IFace.Equals Method

IFaceEquals Method

Comparares if 2 IFace objects referred to the same instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool Equals(
    Object other
)
bool Equals(
    Object^ other
)

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IFace.Equals(System.Object)"]

See Also

Reference

IFace Interface
VisualComponents.Create3D Namespace


IFace.GetClosestCurve Method

IFaceGetClosestCurve Method

Find face curve that is closest to ray.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEdge GetClosestCurve(
    Vector3 rayStart,
    Vector3 rayEnd
)
IEdge^ GetClosestCurve(
    Vector3 rayStart,
    Vector3 rayEnd
)

Parameters

rayStart
Type: VisualComponents.Create3DVector3
rayEnd
Type: VisualComponents.Create3DVector3

Return Value

Type: IEdge

[Missing <returns> documentation for "M:VisualComponents.Create3D.IFace.GetClosestCurve(VisualComponents.Create3D.Vector3,VisualComponents.Create3D.Vector3)"]

See Also

Reference

IFace Interface
VisualComponents.Create3D Namespace


IFace.GetClosestCurvePoint Method

IFaceGetClosestCurvePoint Method

Overload List
 | Name | Description
Public method | GetClosestCurvePoint(Vector3) | Returns the closest curve point regarding a reference point
Public method | GetClosestCurvePoint(Vector3, Int32, Vector3, Int32, Int32) | Returns the closest curve point regarding a reference point
Top
See Also

Reference

IFace Interface
VisualComponents.Create3D Namespace


IFace.GetClosestCurvePoint Method (Vector3)

IFaceGetClosestCurvePoint Method (Vector3)

Returns the closest curve point regarding a reference point

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Nullable<Vector3> GetClosestCurvePoint(
    Vector3 referencePoint
)
Nullable<Vector3> GetClosestCurvePoint(
    Vector3 referencePoint
)

Parameters

referencePoint
Type: VisualComponents.Create3DVector3
Reference points

Return Value

Type: NullableVector3
Point
See Also

Reference

IFace Interface
GetClosestCurvePoint Overload
VisualComponents.Create3D Namespace


IFace.GetClosestCurvePoint Method (Vector3, Int32, Vector3, Int32, Int32)

IFaceGetClosestCurvePoint Method (Vector3, Int32, Vector3, Int32, Int32)

Returns the closest curve point regarding a reference point

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool GetClosestCurvePoint(
    Vector3 referencePoint,
    int curveLoopIndex,
    ref Vector3 resultPosition,
    ref int resultCurveLoopIndex,
    ref int resultCurveLoopEdgeIndex
)
bool GetClosestCurvePoint(
    Vector3 referencePoint,
    int curveLoopIndex,
    Vector3% resultPosition,
    int% resultCurveLoopIndex,
    int% resultCurveLoopEdgeIndex
)

Parameters

referencePoint
Type: VisualComponents.Create3DVector3
curveLoopIndex
Type: SystemInt32
resultPosition
Type: VisualComponents.Create3DVector3
resultCurveLoopIndex
Type: SystemInt32
resultCurveLoopEdgeIndex
Type: SystemInt32

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IFace.GetClosestCurvePoint(VisualComponents.Create3D.Vector3,System.Int32,VisualComponents.Create3D.Vector3@,System.Int32@,System.Int32@)"]

See Also

Reference

IFace Interface
GetClosestCurvePoint Overload
VisualComponents.Create3D Namespace


IFace.GetClosestFacePoint Method

IFaceGetClosestFacePoint Method

Returns the closest face point regarding a reference point

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Nullable<Vector3> GetClosestFacePoint(
    Vector3 referencePoint
)
Nullable<Vector3> GetClosestFacePoint(
    Vector3 referencePoint
)

Parameters

referencePoint
Type: VisualComponents.Create3DVector3
Reference points

Return Value

Type: NullableVector3
Point
See Also

Reference

IFace Interface
VisualComponents.Create3D Namespace


IFace.GetClosestTriangle Method

IFaceGetClosestTriangle Method

For tesselated faces, returns the closet triangle index regarding a reference point

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int GetClosestTriangle(
    Vector3 referencePoint
)
int GetClosestTriangle(
    Vector3 referencePoint
)

Parameters

referencePoint
Type: VisualComponents.Create3DVector3
Reference points

Return Value

Type: Int32
Triangle index
See Also

Reference

IFace Interface
VisualComponents.Create3D Namespace


IFace.GetClosestTriangleEdge Method

IFaceGetClosestTriangleEdge Method

Returns the closest triangle edge regarding a reference point

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool GetClosestTriangleEdge(
    Vector3 referencePoint,
    ref int[] pointsIndexes,
    ref Vector3 resultEdgeStart,
    ref Vector3 resultEdgeEnd,
    ref int resultTriangle,
    ref int resultEdgeIndex
)
bool GetClosestTriangleEdge(
    Vector3 referencePoint,
    array<int>^% pointsIndexes,
    Vector3% resultEdgeStart,
    Vector3% resultEdgeEnd,
    int% resultTriangle,
    int% resultEdgeIndex
)

Parameters

referencePoint
Type: VisualComponents.Create3DVector3
pointsIndexes
Type: SystemInt32
resultEdgeStart
Type: VisualComponents.Create3DVector3
resultEdgeEnd
Type: VisualComponents.Create3DVector3
resultTriangle
Type: SystemInt32
resultEdgeIndex
Type: SystemInt32

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IFace.GetClosestTriangleEdge(VisualComponents.Create3D.Vector3,System.Int32[]@,VisualComponents.Create3D.Vector3@,VisualComponents.Create3D.Vector3@,System.Int32@,System.Int32@)"]

See Also

Reference

IFace Interface
VisualComponents.Create3D Namespace


IFace.GetHashCode Method

IFaceGetHashCode Method

internal purpose only

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int GetHashCode()
int GetHashCode()

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.IFace.GetHashCode"]

See Also

Reference

IFace Interface
VisualComponents.Create3D Namespace


IFace.GetIntersection Method

IFaceGetIntersection Method

Overload List
 | Name | Description
Public method | GetIntersection(Vector3, Vector3) | Intersect points between the given points.
Public method | GetIntersection(Vector3, Vector3, Boolean) | Intersect points between the given points.
Top
See Also

Reference

IFace Interface
VisualComponents.Create3D Namespace


IFace.GetIntersection Method (Vector3, Vector3)

IFaceGetIntersection Method (Vector3, Vector3)

Intersect points between the given points.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Tuple<Vector3, Vector3> GetIntersection(
    Vector3 rayStart,
    Vector3 rayEnd
)
Tuple<Vector3, Vector3>^ GetIntersection(
    Vector3 rayStart,
    Vector3 rayEnd
)

Parameters

rayStart
Type: VisualComponents.Create3DVector3
ray start
rayEnd
Type: VisualComponents.Create3DVector3
ray end

Return Value

Type: TupleVector3, Vector3
Tuple with intersected points and normal
See Also

Reference

IFace Interface
GetIntersection Overload
VisualComponents.Create3D Namespace


IFace.GetIntersection Method (Vector3, Vector3, Boolean)

IFaceGetIntersection Method (Vector3, Vector3, Boolean)

Intersect points between the given points.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Tuple<Vector3, Vector3> GetIntersection(
    Vector3 rayStart,
    Vector3 rayEnd,
    bool intersectBackFaces
)
Tuple<Vector3, Vector3>^ GetIntersection(
    Vector3 rayStart,
    Vector3 rayEnd,
    bool intersectBackFaces
)

Parameters

rayStart
Type: VisualComponents.Create3DVector3
ray start
rayEnd
Type: VisualComponents.Create3DVector3
ray end
intersectBackFaces
Type: SystemBoolean
whether to intersect backfaces or not

Return Value

Type: TupleVector3, Vector3
Tuple with intersected points and normal
See Also

Reference

IFace Interface
GetIntersection Overload
VisualComponents.Create3D Namespace


IFace.GetPlaneIntersections Method

IFaceGetPlaneIntersections Method

Returns face intersection (curve) points using plane defined by Matrix intersecting face

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<Matrix> GetPlaneIntersections(
    Matrix plane,
    double minimumStep,
    double maximumStep,
    double maximumError,
    double maximumAngle
)
IEnumerable<Matrix>^ GetPlaneIntersections(
    Matrix plane,
    double minimumStep,
    double maximumStep,
    double maximumError,
    double maximumAngle
)

Parameters

plane
Type: VisualComponents.Create3DMatrix
minimumStep
Type: SystemDouble
maximumStep
Type: SystemDouble
maximumError
Type: SystemDouble
maximumAngle
Type: SystemDouble

Return Value

Type: IEnumerableMatrix

[Missing <returns> documentation for "M:VisualComponents.Create3D.IFace.GetPlaneIntersections(VisualComponents.Create3D.Matrix,System.Double,System.Double,System.Double,System.Double)"]

See Also

Reference

IFace Interface
VisualComponents.Create3D Namespace


IFace.GetTopologyPolyline Method

IFaceGetTopologyPolyline Method

Overload List
 | Name | Description
Public method | GetTopologyPolyline(NullableMatrix) | Returns a list of all points of all polylines in the given coordinate system
Public method | GetTopologyPolyline(NullableMatrix, Int32) | Returns a list of all points of all polylines in the given coordinate system
Top
See Also

Reference

IFace Interface
VisualComponents.Create3D Namespace


IFace.GetTopologyPolyline Method (Nullable(Matrix))

IFaceGetTopologyPolyline Method (NullableMatrix)

Returns a list of all points of all polylines in the given coordinate system

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<Vector3> GetTopologyPolyline(
    Nullable<Matrix> mat
)
ReadOnlyCollection<Vector3>^ GetTopologyPolyline(
    Nullable<Matrix> mat
)

Parameters

mat
Type: SystemNullableMatrix
coordinate system

Return Value

Type: ReadOnlyCollectionVector3
list of points
See Also

Reference

IFace Interface
GetTopologyPolyline Overload
VisualComponents.Create3D Namespace


IFace.GetTopologyPolyline Method (Nullable(Matrix), Int32)

IFaceGetTopologyPolyline Method (NullableMatrix, Int32)

Returns a list of all points of all polylines in the given coordinate system

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<Vector3> GetTopologyPolyline(
    Nullable<Matrix> space,
    int index
)
ReadOnlyCollection<Vector3>^ GetTopologyPolyline(
    Nullable<Matrix> space,
    int index
)

Parameters

space
Type: SystemNullableMatrix
index
Type: SystemInt32

Return Value

Type: ReadOnlyCollectionVector3

[Missing <returns> documentation for "M:VisualComponents.Create3D.IFace.GetTopologyPolyline(System.Nullable{VisualComponents.Create3D.Matrix},System.Int32)"]

See Also

Reference

IFace Interface
GetTopologyPolyline Overload
VisualComponents.Create3D Namespace


IFace.NeighborFaces Method

IFaceNeighborFaces Method

Returns a set of faces that are neighbor with this face. The set of faces includes this face as well

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<IFace> NeighborFaces()
IEnumerable<IFace^>^ NeighborFaces()

Return Value

Type: IEnumerableIFace

[Missing <returns> documentation for "M:VisualComponents.Create3D.IFace.NeighborFaces"]

See Also

Reference

IFace Interface
VisualComponents.Create3D Namespace


IFC Enumeration

IFC -> IFC2x Editions 2, 3 and 4

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum IFC
public enum class IFC
Members
Member name | Value | Description
IFC | 0 |
IFCZIP | 1 |
See Also

Reference

VisualComponents.Create3D Namespace


IFeature Interface

Interface that represents simulation node feature tree objects. Features define the geometry of objects either by themselves or as a result of operations on other features. The result of the feature tree evaluation is placed in to the geometry container in ISimNode. This process is governed by properties in the feature objects, which are accessible through this class. Only the Geometry feature has a specific Python class vcGeometryFeature which is derived from vcFeature in order to support creation of custom geometry. All other features can be manipulated through the generic IFeature interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IFeature : IVisualObject,
    INamed, IWrapper, IDisposable, IVisitable, IPropertyContainer,
    IBatchModeObject, ISharedCloneable
public interface class IFeature : IVisualObject,
    INamed, IWrapper, IDisposable, IVisitable, IPropertyContainer,
    IBatchModeObject, ISharedCloneable

The IFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates.
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features.
Public property | Children | Retrieves all children feature
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release.
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced
Public property | Parent | Feature's parent in the feature tree
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children.
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space.
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load.
Public property | TransformationInReference | Gets or sets the transformation matrix.
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead.
Public property | Type | Feature type
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted.
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features.
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present.
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space.
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld.
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move.
Public method | RebuildNodes | re evaluate the feature tree
Public method | SetDynamicProperty | This is used for variables, that are created on demand.
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name
Public method | SetName(String, Boolean) | This method sets the name of the feature.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list.
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one.
Top
Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
Assuming that SimNode.Geometry.Container is shared between all SimNodes and root feature is pointing to it. This is the only way feature can be manipulated as normal visual object.
See Also

Reference

VisualComponents.Create3D Namespace


IFeature Properties

The IFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates.
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features.
Public property | Children | Retrieves all children feature
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release.
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced
Public property | Parent | Feature's parent in the feature tree
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children.
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space.
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load.
Public property | TransformationInReference | Gets or sets the transformation matrix.
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead.
Public property | Type | Feature type
Top
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.AlignedBoundBox Property

IFeatureAlignedBoundBox Property

Retrieves the bounding box of this feature aligned to local coordinates.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Tuple<Vector3, Vector3> AlignedBoundBox { get; }
property Tuple<Vector3, Vector3>^ AlignedBoundBox {
    Tuple<Vector3, Vector3>^ get ();
}

Property Value

Type: TupleVector3, Vector3
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.ChildCount Property

IFeatureChildCount Property

Number of child features.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int ChildCount { get; }
property int ChildCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.Children Property

IFeatureChildren Property

Retrieves all children feature

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IFeature> Children { get; }
property ReadOnlyCollection<IFeature^>^ Children {
    ReadOnlyCollection<IFeature^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIFeature
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.CreatesOriginalGeoSet Property

IFeatureCreatesOriginalGeoSet Property

Indicates if the featue is a geometry feature or primitive feature

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CreatesOriginalGeoSet { get; }
property bool CreatesOriginalGeoSet {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.FeatureComplexity Property

IFeatureFeatureComplexity Property

Estimated complexity. If >1.0 manipulation is done on mouse release.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double FeatureComplexity { get; }
property double FeatureComplexity {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.NodeInstances Property

IFeatureNodeInstances Property

Retrieves all ISimNode instances where this feature is referenced

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ISimNode> NodeInstances { get; }
property ReadOnlyCollection<ISimNode^>^ NodeInstances {
    ReadOnlyCollection<ISimNode^>^ get ();
}

Property Value

Type: ReadOnlyCollectionISimNode
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.Parent Property

IFeatureParent Property

Feature's parent in the feature tree

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFeature Parent { get; }
property IFeature^ Parent {
    IFeature^ get ();
}

Property Value

Type: IFeature
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.RootFeature Property

IFeatureRootFeature Property

Retrieves the root node of the feature tree where this feature is located

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFeature RootFeature { get; }
property IFeature^ RootFeature {
    IFeature^ get ();
}

Property Value

Type: IFeature
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.TotalBoundBox Property

IFeatureTotalBoundBox Property

Retrieves the bounding box of this feature and it's children.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Tuple<Vector3, Vector3> TotalBoundBox { get; }
property Tuple<Vector3, Vector3>^ TotalBoundBox {
    Tuple<Vector3, Vector3>^ get ();
}

Property Value

Type: TupleVector3, Vector3
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.TransformationInNode Property

IFeatureTransformationInNode Property

Gets or sets the transformation matrix in simulation node's space.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix TransformationInNode { get; set; }
property Matrix TransformationInNode {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.TransformationInNodeReal Property

IFeatureTransformationInNodeReal Property

Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix TransformationInNodeReal { get; }
property Matrix TransformationInNodeReal {
    Matrix get ();
}

Property Value

Type: Matrix
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.TransformationInReference Property

IFeatureTransformationInReference Property

Gets or sets the transformation matrix.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix TransformationInReference { get; set; }
property Matrix TransformationInReference {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix

Implements

IVisualObjectTransformationInReference
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.TransformationInWorld Property

IFeatureTransformationInWorld Property

Note: This API is now obsolete.

This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Use ISimNode.GetFeatureTransformationInWorld(feature) instead")]
Matrix TransformationInWorld { get; set; }
[ObsoleteAttribute(L"Use ISimNode.GetFeatureTransformationInWorld(feature) instead")]
property Matrix TransformationInWorld {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix

Implements

IVisualObjectTransformationInWorld
Remarks
The features may be shared across multiple feature trees (i.e., they will have different world pose, while having same pose in node space).
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.Type Property

IFeatureType Property

Feature type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
FeatureType Type { get; }
property FeatureType Type {
    FeatureType get ();
}

Property Value

Type: FeatureType
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature Methods

The IFeature type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted.
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features.
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present.
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space.
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld.
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move.
Public method | RebuildNodes | re evaluate the feature tree
Public method | SetDynamicProperty | This is used for variables, that are created on demand.
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name
Public method | SetName(String, Boolean) | This method sets the name of the feature.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list.
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.AddChild Method

IFeatureAddChild Method

Overload List
 | Name | Description
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position
Top
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.AddChild Method (IFeature, Int32)

IFeatureAddChild Method (IFeature, Int32)

Adds a child feature in the given index position

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddChild(
    IFeature childFeature,
    int index
)
void AddChild(
    IFeature^ childFeature,
    int index
)

Parameters

childFeature
Type: VisualComponents.Create3DIFeature
index
Type: SystemInt32
See Also

Reference

IFeature Interface
AddChild Overload
VisualComponents.Create3D Namespace


IFeature.AddChild Method (IFeature, Int32, Boolean)

IFeatureAddChild Method (IFeature, Int32, Boolean)

Adds a child feature in the given index position

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddChild(
    IFeature childFeature,
    int index,
    bool validateName
)
void AddChild(
    IFeature^ childFeature,
    int index,
    bool validateName
)

Parameters

childFeature
Type: VisualComponents.Create3DIFeature
index
Type: SystemInt32
validateName
Type: SystemBoolean
See Also

Reference

IFeature Interface
AddChild Overload
VisualComponents.Create3D Namespace


IFeature.AddChild Method (IFeature, Int32, Boolean, Boolean)

IFeatureAddChild Method (IFeature, Int32, Boolean, Boolean)

Adds a child feature in the given index position

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddChild(
    IFeature childFeature,
    int index,
    bool validateName,
    bool rebuild
)
void AddChild(
    IFeature^ childFeature,
    int index,
    bool validateName,
    bool rebuild
)

Parameters

childFeature
Type: VisualComponents.Create3DIFeature
index
Type: SystemInt32
validateName
Type: SystemBoolean
rebuild
Type: SystemBoolean
specifies if rebuild is required after performing operation
See Also

Reference

IFeature Interface
AddChild Overload
VisualComponents.Create3D Namespace


IFeature.CanCollapse Method

IFeatureCanCollapse Method

Determines if an IFeature can be collapsed

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanCollapse()
bool CanCollapse()

Return Value

Type: Boolean
True if it can be collapsed
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.Collapse Method

IFeatureCollapse Method

Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFeature Collapse()
IFeature^ Collapse()

Return Value

Type: IFeature
New Feature or null if was not able to collapse
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.CreateFeature Method

IFeatureCreateFeature Method

Overload List
 | Name | Description
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features
Top
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.CreateFeature(T) Method

IFeatureCreateFeatureT Method

Creates a feature and it gives to it a valid name. It also perform a local update

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
T CreateFeature<T>()
where T : IFeature

generic<typename T>
where T : IFeature
T CreateFeature()

Type Parameters

T

Return Value

Type: T

[Missing <returns> documentation for "M:VisualComponents.Create3D.IFeature.CreateFeature``1"]

See Also

Reference

IFeature Interface
CreateFeature Overload
VisualComponents.Create3D Namespace


IFeature.CreateFeature(T) Method (Boolean)

IFeatureCreateFeatureT Method (Boolean)

Creates a feature and it gives to it a valid name

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
T CreateFeature<T>(
    bool localUpdate
)
where T : IFeature

generic<typename T>
where T : IFeature
T CreateFeature(
    bool localUpdate
)

Parameters

localUpdate
Type: SystemBoolean
do a local update after the feature creating

Type Parameters

T

Return Value

Type: T

[Missing <returns> documentation for "M:VisualComponents.Create3D.IFeature.CreateFeature``1(System.Boolean)"]

See Also

Reference

IFeature Interface
CreateFeature Overload
VisualComponents.Create3D Namespace


IFeature.CreateFeature(T) Method (Boolean, Boolean)

IFeatureCreateFeatureT Method (Boolean, Boolean)

Creates a features

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
T CreateFeature<T>(
    bool localUpdate,
    bool validateName
)
where T : IFeature

generic<typename T>
where T : IFeature
T CreateFeature(
    bool localUpdate,
    bool validateName
)

Parameters

localUpdate
Type: SystemBoolean
determines if valid name should be given
validateName
Type: SystemBoolean
do a local update after the feature creating

Type Parameters

T

Return Value

Type: T

[Missing <returns> documentation for "M:VisualComponents.Create3D.IFeature.CreateFeature``1(System.Boolean,System.Boolean)"]

See Also

Reference

IFeature Interface
CreateFeature Overload
VisualComponents.Create3D Namespace


IFeature.Delete Method

IFeatureDelete Method

Deletes the feature and all its child features.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Delete()
void Delete()
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.FindNode Method

IFeatureFindNode Method

From the given IVisualObject it will try to locate any node where this feature is present.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode FindNode(
    IVisualObject node
)
ISimNode^ FindNode(
    IVisualObject^ node
)

Parameters

node
Type: VisualComponents.Create3DIVisualObject

Return Value

Type: ISimNode

[Missing <returns> documentation for "M:VisualComponents.Create3D.IFeature.FindNode(VisualComponents.Create3D.IVisualObject)"]

See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.GetCombinedBoundBox Method

IFeatureGetCombinedBoundBox Method

Get bound box including specified features. Bounds are define in SimNode space.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Tuple<Vector3, Vector3> GetCombinedBoundBox(
    IEnumerable<IFeature> features
)
Tuple<Vector3, Vector3>^ GetCombinedBoundBox(
    IEnumerable<IFeature^>^ features
)

Parameters

features
Type: System.Collections.GenericIEnumerableIFeature

Return Value

Type: TupleVector3, Vector3

[Missing <returns> documentation for "M:VisualComponents.Create3D.IFeature.GetCombinedBoundBox(System.Collections.Generic.IEnumerable{VisualComponents.Create3D.IFeature})"]

See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.InvalidateBounds Method

IFeatureInvalidateBounds Method

Finalize changes after finished moving with IFeature.TransformationInWorld.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void InvalidateBounds()
void InvalidateBounds()
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.Rebuild Method

IFeatureRebuild Method

Update geosets affected by this feature. This method is called automatically on each move.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Rebuild()
void Rebuild()
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.RebuildNodes Method

IFeatureRebuildNodes Method

re evaluate the feature tree

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RebuildNodes(
    bool completeTree,
    bool alsoNodes
)
void RebuildNodes(
    bool completeTree,
    bool alsoNodes
)

Parameters

completeTree
Type: SystemBoolean
alsoNodes
Type: SystemBoolean
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.SetDynamicProperty Method

IFeatureSetDynamicProperty Method

This is used for variables, that are created on demand.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetDynamicProperty(
    string name,
    Object value
)
void SetDynamicProperty(
    String^ name,
    Object^ value
)

Parameters

name
Type: SystemString
value
Type: SystemObject
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.SetName Method

IFeatureSetName Method

Overload List
 | Name | Description
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name
Public method | SetName(String, Boolean) | This method sets the name of the feature.
Top
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.SetName Method (String)

IFeatureSetName Method (String)

This method sets the name of the feature without checking if it is valid name

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetName(
    string name
)
void SetName(
    String^ name
)

Parameters

name
Type: SystemString
See Also

Reference

IFeature Interface
SetName Overload
VisualComponents.Create3D Namespace


IFeature.SetName Method (String, Boolean)

IFeatureSetName Method (String, Boolean)

This method sets the name of the feature.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetName(
    string name,
    bool validate
)
void SetName(
    String^ name,
    bool validate
)

Parameters

name
Type: SystemString
validate
Type: SystemBoolean
See Also

Reference

IFeature Interface
SetName Overload
VisualComponents.Create3D Namespace


IFeature.SetTransformationsOptimized Method

IFeatureSetTransformationsOptimized Method

Batch update feature positions. This feature should be the first feature in the "features" list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetTransformationsOptimized(
    IEnumerable<IFeature> features,
    IList<Matrix> positions,
    bool invalidateBounds,
    bool inNodeSpace,
    bool normalizePositions,
    bool moveChildrenNormally
)
void SetTransformationsOptimized(
    IEnumerable<IFeature^>^ features,
    IList<Matrix>^ positions,
    bool invalidateBounds,
    bool inNodeSpace,
    bool normalizePositions,
    bool moveChildrenNormally
)

Parameters

features
Type: System.Collections.GenericIEnumerableIFeature
positions
Type: System.Collections.GenericIListMatrix
invalidateBounds
Type: SystemBoolean
inNodeSpace
Type: SystemBoolean
normalizePositions
Type: SystemBoolean
moveChildrenNormally
Type: SystemBoolean
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.ValidateName Method

IFeatureValidateName Method

Change name to the next valid one.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ValidateName()
void ValidateName()
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature Events

The IFeature type exposes the following members.

Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFeature.FeatureHierarchyChanged Event

IFeatureFeatureHierarchyChanged Event

Occurs when a feature hierarchy is modified. This event is only signaled from the root feature.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<FeatureHierarchyChangedEventArgs> FeatureHierarchyChanged
 event EventHandler<FeatureHierarchyChangedEventArgs^>^ FeatureHierarchyChanged {
    void add (EventHandler<FeatureHierarchyChangedEventArgs^>^ value);
    void remove (EventHandler<FeatureHierarchyChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerFeatureHierarchyChangedEventArgs
See Also

Reference

IFeature Interface
VisualComponents.Create3D Namespace


IFloor Interface

Floor and Grid attributes

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IFloor : IWrapper, IDisposable
public interface class IFloor : IWrapper,
    IDisposable

The IFloor type exposes the following members.

Properties
 | Name | Description
Public property | AutoFloorSizeX | Gets or sets default value for floor size x when auto resize option is enabled.
Public property | AutoFloorSizeY | Gets or sets default value for floor size y when auto resize option is enabled.
Public property | FloorColor | RGB vector
Public property | FloorReflection | Floor reflectivity (float - 0.0 = no reflection - 1.0 = full reflection)
Public property | FloorSizeX | Floor size x
Public property | FloorSizeY | Floor size y
Public property | GridMajorLineColor | RGB vector
Public property | GridMajorLineWidth | grid's major line width
Public property | GridMinorLineColor | RGB vector
Public property | GridSizeX | Grid size x
Public property | GridSizeY | Grid size y
Public property | IsFloorAutoResize | Automatically resizes the floor according to the placement of components in the 3DWorld.
Public property | IsFloorVisible | Floor Visible
Public property | IsGridVisible | Grid visible
Public property | IsValid | (Inherited from IWrapper.)
Public property | MajorGridSizeX | Major grid size x. Note: minor grid lines are usually rendered white, so they are blending into the background.
Public property | MajorGridSizeY | Major grid size y Note: minor grid lines are usually rendered white, so they are blending into the background.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Texture | Floor's texture
Public property | TextureFillAll | Specifies if, in case of the floor having a texture, texture fills all the grid
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Top
Events
 | Name | Description
Public event | FloorSizeChanged | Event trigger when floor size changes
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IFloor Properties

The IFloor type exposes the following members.

Properties
 | Name | Description
Public property | AutoFloorSizeX | Gets or sets default value for floor size x when auto resize option is enabled.
Public property | AutoFloorSizeY | Gets or sets default value for floor size y when auto resize option is enabled.
Public property | FloorColor | RGB vector
Public property | FloorReflection | Floor reflectivity (float - 0.0 = no reflection - 1.0 = full reflection)
Public property | FloorSizeX | Floor size x
Public property | FloorSizeY | Floor size y
Public property | GridMajorLineColor | RGB vector
Public property | GridMajorLineWidth | grid's major line width
Public property | GridMinorLineColor | RGB vector
Public property | GridSizeX | Grid size x
Public property | GridSizeY | Grid size y
Public property | IsFloorAutoResize | Automatically resizes the floor according to the placement of components in the 3DWorld.
Public property | IsFloorVisible | Floor Visible
Public property | IsGridVisible | Grid visible
Public property | IsValid | (Inherited from IWrapper.)
Public property | MajorGridSizeX | Major grid size x. Note: minor grid lines are usually rendered white, so they are blending into the background.
Public property | MajorGridSizeY | Major grid size y Note: minor grid lines are usually rendered white, so they are blending into the background.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Texture | Floor's texture
Public property | TextureFillAll | Specifies if, in case of the floor having a texture, texture fills all the grid
Top
See Also

Reference

IFloor Interface
VisualComponents.Create3D Namespace


IFloor.AutoFloorSizeX Property

IFloorAutoFloorSizeX Property

Gets or sets default value for floor size x when auto resize option is enabled.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double AutoFloorSizeX { get; set; }
property double AutoFloorSizeX {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IFloor Interface
VisualComponents.Create3D Namespace


IFloor.AutoFloorSizeY Property

IFloorAutoFloorSizeY Property

Gets or sets default value for floor size y when auto resize option is enabled.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double AutoFloorSizeY { get; set; }
property double AutoFloorSizeY {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IFloor Interface
VisualComponents.Create3D Namespace


IFloor.FloorColor Property

IFloorFloorColor Property

RGB vector

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Color FloorColor { get; set; }
property Color FloorColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

IFloor Interface
VisualComponents.Create3D Namespace


IFloor.FloorReflection Property

IFloorFloorReflection Property

Floor reflectivity (float - 0.0 = no reflection - 1.0 = full reflection)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double FloorReflection { get; set; }
property double FloorReflection {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IFloor Interface
VisualComponents.Create3D Namespace


IFloor.FloorSizeX Property

IFloorFloorSizeX Property

Floor size x

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double FloorSizeX { get; set; }
property double FloorSizeX {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IFloor Interface
VisualComponents.Create3D Namespace


IFloor.FloorSizeY Property

IFloorFloorSizeY Property

Floor size y

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double FloorSizeY { get; set; }
property double FloorSizeY {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IFloor Interface
VisualComponents.Create3D Namespace


IFloor.GridMajorLineColor Property

IFloorGridMajorLineColor Property

RGB vector

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Color GridMajorLineColor { get; set; }
property Color GridMajorLineColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

IFloor Interface
VisualComponents.Create3D Namespace


IFloor.GridMajorLineWidth Property

IFloorGridMajorLineWidth Property

grid's major line width

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double GridMajorLineWidth { get; set; }
property double GridMajorLineWidth {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IFloor Interface
VisualComponents.Create3D Namespace


IFloor.GridMinorLineColor Property

IFloorGridMinorLineColor Property

RGB vector

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Color GridMinorLineColor { get; set; }
property Color GridMinorLineColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

IFloor Interface
VisualComponents.Create3D Namespace


IFloor.GridSizeX Property

IFloorGridSizeX Property

Grid size x

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double GridSizeX { get; set; }
property double GridSizeX {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IFloor Interface
VisualComponents.Create3D Namespace


IFloor.GridSizeY Property

IFloorGridSizeY Property

Grid size y

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double GridSizeY { get; set; }
property double GridSizeY {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IFloor Interface
VisualComponents.Create3D Namespace


IFloor.IsFloorAutoResize Property

IFloorIsFloorAutoResize Property

Automatically resizes the floor according to the placement of components in the 3DWorld.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsFloorAutoResize { get; set; }
property bool IsFloorAutoResize {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IFloor Interface
VisualComponents.Create3D Namespace


IFloor.IsFloorVisible Property

IFloorIsFloorVisible Property

Floor Visible

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsFloorVisible { get; set; }
property bool IsFloorVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IFloor Interface
VisualComponents.Create3D Namespace


IFloor.IsGridVisible Property

IFloorIsGridVisible Property

Grid visible

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsGridVisible { get; set; }
property bool IsGridVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IFloor Interface
VisualComponents.Create3D Namespace


IFloor.MajorGridSizeX Property

IFloorMajorGridSizeX Property

Major grid size x. Note: minor grid lines are usually rendered white, so they are blending into the background.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double MajorGridSizeX { get; set; }
property double MajorGridSizeX {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IFloor Interface
VisualComponents.Create3D Namespace


IFloor.MajorGridSizeY Property

IFloorMajorGridSizeY Property

Major grid size y Note: minor grid lines are usually rendered white, so they are blending into the background.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double MajorGridSizeY { get; set; }
property double MajorGridSizeY {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IFloor Interface
VisualComponents.Create3D Namespace


IFloor.Texture Property

IFloorTexture Property

Floor's texture

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMaterial Texture { get; set; }
property IMaterial^ Texture {
    IMaterial^ get ();
    void set (IMaterial^ value);
}

Property Value

Type: IMaterial
See Also

Reference

IFloor Interface
VisualComponents.Create3D Namespace


IFloor.TextureFillAll Property

IFloorTextureFillAll Property

Specifies if, in case of the floor having a texture, texture fills all the grid

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool TextureFillAll { get; set; }
property bool TextureFillAll {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IFloor Interface
VisualComponents.Create3D Namespace


IFloor Methods

The IFloor type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IFloor Interface
VisualComponents.Create3D Namespace


IFloor Events

The IFloor type exposes the following members.

Events
 | Name | Description
Public event | FloorSizeChanged | Event trigger when floor size changes
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
See Also

Reference

IFloor Interface
VisualComponents.Create3D Namespace


IFloor.FloorSizeChanged Event

IFloorFloorSizeChanged Event

Event trigger when floor size changes

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<FloorSizeChangedEventArgs> FloorSizeChanged
 event EventHandler<FloorSizeChangedEventArgs^>^ FloorSizeChanged {
    void add (EventHandler<FloorSizeChangedEventArgs^>^ value);
    void remove (EventHandler<FloorSizeChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerFloorSizeChangedEventArgs
See Also

Reference

IFloor Interface
VisualComponents.Create3D Namespace


IFlowBehavior Interface

A base interface for behaviors supporting material flow.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IFlowBehavior : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IFlowBehavior : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IFlowBehavior type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior.
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector.
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector.
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetConnection | Connects the given ISimConnector instances.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior.
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IFlowBehavior Properties

The IFlowBehavior type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior.
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IFlowBehavior Interface
VisualComponents.Create3D Namespace


IFlowBehavior.Connectors Property

IFlowBehaviorConnectors Property

Retrieves the collection of ISimConnector instances owned by this behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ISimConnector> Connectors { get; }
property ReadOnlyCollection<ISimConnector^>^ Connectors {
    ReadOnlyCollection<ISimConnector^>^ get ();
}

Property Value

Type: ReadOnlyCollectionISimConnector
See Also

Reference

IFlowBehavior Interface
VisualComponents.Create3D Namespace


IFlowBehavior.HasCapacity Property

IFlowBehaviorHasCapacity Property

Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool HasCapacity { get; set; }
property bool HasCapacity {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IFlowBehavior Interface
VisualComponents.Create3D Namespace


IFlowBehavior.SupportsDynamicConnectors Property

IFlowBehaviorSupportsDynamicConnectors Property

Defines if connectors can be added or removed from this flow behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SupportsDynamicConnectors { get; }
property bool SupportsDynamicConnectors {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IFlowBehavior Interface
VisualComponents.Create3D Namespace


IFlowBehavior Methods

The IFlowBehavior type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector.
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector.
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetConnection | Connects the given ISimConnector instances.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IFlowBehavior Interface
VisualComponents.Create3D Namespace


IFlowBehavior.CheckCapacity Method

IFlowBehaviorCheckCapacity Method

Tests if the behavior has capacity for a component coming in through the given ISimConnector.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CheckCapacity(
    ISimComponent component,
    ISimConnector connector
)
bool CheckCapacity(
    ISimComponent^ component,
    ISimConnector^ connector
)

Parameters

component
Type: VisualComponents.Create3DISimComponent
The component to test.
connector
Type: VisualComponents.Create3DISimConnector
The connector to test.

Return Value

Type: Boolean
True if capacity available.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when component or connector parameter is null.
ArgumentException | The given connector is not in this behavior.
Remarks
Capacity testing will succeed when:

-The value of CapacityAvailable is true

-In case of ISimContainer, ComponentCount will not exceed the amout defined by Capacity property

-Physical capacity test passes based on the connector's CapacityTest property

See Also

Reference

IFlowBehavior Interface
VisualComponents.Create3D Namespace


IFlowBehavior.CreateConnector Method

IFlowBehaviorCreateConnector Method

Creates a new ISimConnector instance to this behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimConnector CreateConnector(
    string name
)
ISimConnector^ CreateConnector(
    String^ name
)

Parameters

name
Type: SystemString
Name of the connector to be created.

Return Value

Type: ISimConnector
The created connector.
Exceptions
Exception | Condition
InvalidOperationException | Thrown if this behavior does not support dynamic connectors.
See Also

Reference

IFlowBehavior Interface
VisualComponents.Create3D Namespace


IFlowBehavior.DeleteConnector Method

IFlowBehaviorDeleteConnector Method

Deletes the given ISimConnector.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteConnector(
    ISimConnector connector
)
void DeleteConnector(
    ISimConnector^ connector
)

Parameters

connector
Type: VisualComponents.Create3DISimConnector
Connector to be deleted.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when connector parameter is null.
See Also

Reference

IFlowBehavior Interface
VisualComponents.Create3D Namespace


IFlowBehavior.SetConnection Method

IFlowBehaviorSetConnection Method

Connects the given ISimConnector instances.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetConnection(
    ISimConnector fromConnector,
    ISimConnector toConnector
)
void SetConnection(
    ISimConnector^ fromConnector,
    ISimConnector^ toConnector
)

Parameters

fromConnector
Type: VisualComponents.Create3DISimConnector
Connector in this behavior.
toConnector
Type: VisualComponents.Create3DISimConnector
Connector to connect, if null fromConnector is disconnected from its connected connectors.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when fromConnector parameter is null.
See Also

Reference

IFlowBehavior Interface
VisualComponents.Create3D Namespace


IFlowBehavior Events

The IFlowBehavior type exposes the following members.

Events
 | Name | Description
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior.
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IFlowBehavior Interface
VisualComponents.Create3D Namespace


IFlowBehavior.ConnectorAdded Event

IFlowBehaviorConnectorAdded Event

Event that is raised when a new ISimConnector has been added to this behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ConnectorAddedEventArgs> ConnectorAdded
 event EventHandler<ConnectorAddedEventArgs^>^ ConnectorAdded {
    void add (EventHandler<ConnectorAddedEventArgs^>^ value);
    void remove (EventHandler<ConnectorAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerConnectorAddedEventArgs
See Also

Reference

IFlowBehavior Interface
VisualComponents.Create3D Namespace


IFlowBehavior.ConnectorRemoving Event

IFlowBehaviorConnectorRemoving Event

Event that is raised when an ISimConnector has been removed from this behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ConnectorRemovingEventArgs> ConnectorRemoving
 event EventHandler<ConnectorRemovingEventArgs^>^ ConnectorRemoving {
    void add (EventHandler<ConnectorRemovingEventArgs^>^ value);
    void remove (EventHandler<ConnectorRemovingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerConnectorRemovingEventArgs
See Also

Reference

IFlowBehavior Interface
VisualComponents.Create3D Namespace


IFrame Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IFrame : IPrimitive, IWrapper,
    IDisposable, INamed
public interface class IFrame : IPrimitive,
    IWrapper, IDisposable, INamed

The IFrame type exposes the following members.

Properties
 | Name | Description
Public property | Feature |
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ObjectPrimitiveType | (Inherited from IPrimitive.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Position |
Public property | UseAsGuide |
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IFrame Properties

The IFrame type exposes the following members.

Properties
 | Name | Description
Public property | Feature |
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ObjectPrimitiveType | (Inherited from IPrimitive.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Position |
Public property | UseAsGuide |
Top
See Also

Reference

IFrame Interface
VisualComponents.Create3D Namespace


IFrame.Feature Property

IFrameFeature Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFeature Feature { get; }
property IFeature^ Feature {
    IFeature^ get ();
}

Property Value

Type: IFeature
See Also

Reference

IFrame Interface
VisualComponents.Create3D Namespace


IFrame.Position Property

IFramePosition Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix Position { get; }
property Matrix Position {
    Matrix get ();
}

Property Value

Type: Matrix
See Also

Reference

IFrame Interface
VisualComponents.Create3D Namespace


IFrame.UseAsGuide Property

IFrameUseAsGuide Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool UseAsGuide { get; }
property bool UseAsGuide {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IFrame Interface
VisualComponents.Create3D Namespace


IFrame Methods

The IFrame type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IFrame Interface
VisualComponents.Create3D Namespace


IFrame Events

The IFrame type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
See Also

Reference

IFrame Interface
VisualComponents.Create3D Namespace


IFrameFeature Interface

Frame feature interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IFrameFeature : IFeature,
    IVisualObject, INamed, IWrapper, IDisposable, IVisitable,
    IPropertyContainer, IBatchModeObject, ISharedCloneable
public interface class IFrameFeature : IFeature,
    IVisualObject, INamed, IWrapper, IDisposable, IVisitable,
    IPropertyContainer, IBatchModeObject, ISharedCloneable

The IFrameFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsCurrentVisible | Indicates whether the frame is visible or not in the world
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
The Frame feature describes a position and orientation in the 3D world. Frames are used as "glue" between the physical and the simulation world, for instance to outline conveyor paths.
See Also

Reference

VisualComponents.Create3D Namespace


IFrameFeature Properties

The IFrameFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsCurrentVisible | Indicates whether the frame is visible or not in the world
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
See Also

Reference

IFrameFeature Interface
VisualComponents.Create3D Namespace


IFrameFeature.IsCurrentVisible Property

IFrameFeatureIsCurrentVisible Property

Indicates whether the frame is visible or not in the world

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsCurrentVisible { get; set; }
property bool IsCurrentVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IFrameFeature Interface
VisualComponents.Create3D Namespace


IFrameFeature Methods

The IFrameFeature type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IFrameFeature Interface
VisualComponents.Create3D Namespace


IFrameFeature Events

The IFrameFeature type exposes the following members.

Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

IFrameFeature Interface
VisualComponents.Create3D Namespace


IFrameSet Interface

Interface for frame sets. A collection of frame primitives.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IFrameSet : IGeometrySet,
    IPrimitive, IWrapper, IDisposable
public interface class IFrameSet : IGeometrySet,
    IPrimitive, IWrapper, IDisposable

The IFrameSet type exposes the following members.

Properties
 | Name | Description
Public property | BoundBox | Returns the bound box of the geometryset. (Inherited from IGeometrySet.)
Public property | Container | Geometry container object (Inherited from IGeometrySet.)
Public property | Feature | IGeometryFeature owning the geoset (Inherited from IGeometrySet.)
Public property | FrameCount | Returns a count of frames in this frame set
Public property | Frames | Gets all the IFrame instances belonging to this IFrameSet
Public property | HasMaterialInheritance | Determines if it has material inheritance (Inherited from IGeometrySet.)
Public property | HasNoHits | For internal purpose only (Inherited from IGeometrySet.)
Public property | IsHighlighted | Determines if set is highlighted (Inherited from IGeometrySet.)
Public property | IsLayerVisible | Determine if the layer where the geometry set is located is visible (Inherited from IGeometrySet.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Determines if set is visible (Inherited from IGeometrySet.)
Public property | Material | Material of the set (Inherited from IGeometrySet.)
Public property | Name | Name of the set (Inherited from IGeometrySet.)
Public property | ObjectPrimitiveType | (Inherited from IPrimitive.)
Public property | Original | Retrieves the original geometry set (Inherited from IGeometrySet.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ShowLabels | Indicates if the label should be displayed
Public property | TopologyCurves | Set topological information (Inherited from IGeometrySet.)
Top
Methods
 | Name | Description
Public method | AddFrame(String) | Creates a new instance of IFrame and adds it to this IFrameSet
Public method | AddFrame(String, Matrix) | Creates a new instance of IFrame and adds it to this IFrameSet
Public method | Clear | Clears all geometry information from the set (Inherited from IGeometrySet.)
Public method | Delete | Deletes the set. Instance gets invalidated (Inherited from IGeometrySet.)
Public method | DeleteFrame | Deletes the given IFrame instance
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetClosestPoint | Raycast geometry set. (Inherited from IGeometrySet.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | HighlightEdges | highlights only the edges (does not override normal highlighting) (Inherited from IGeometrySet.)
Public method | Update | Updates set information (Inherited from IGeometrySet.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IFrameSet Properties

The IFrameSet type exposes the following members.

Properties
 | Name | Description
Public property | BoundBox | Returns the bound box of the geometryset. (Inherited from IGeometrySet.)
Public property | Container | Geometry container object (Inherited from IGeometrySet.)
Public property | Feature | IGeometryFeature owning the geoset (Inherited from IGeometrySet.)
Public property | FrameCount | Returns a count of frames in this frame set
Public property | Frames | Gets all the IFrame instances belonging to this IFrameSet
Public property | HasMaterialInheritance | Determines if it has material inheritance (Inherited from IGeometrySet.)
Public property | HasNoHits | For internal purpose only (Inherited from IGeometrySet.)
Public property | IsHighlighted | Determines if set is highlighted (Inherited from IGeometrySet.)
Public property | IsLayerVisible | Determine if the layer where the geometry set is located is visible (Inherited from IGeometrySet.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Determines if set is visible (Inherited from IGeometrySet.)
Public property | Material | Material of the set (Inherited from IGeometrySet.)
Public property | Name | Name of the set (Inherited from IGeometrySet.)
Public property | ObjectPrimitiveType | (Inherited from IPrimitive.)
Public property | Original | Retrieves the original geometry set (Inherited from IGeometrySet.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ShowLabels | Indicates if the label should be displayed
Public property | TopologyCurves | Set topological information (Inherited from IGeometrySet.)
Top
See Also

Reference

IFrameSet Interface
VisualComponents.Create3D Namespace


IFrameSet.FrameCount Property

IFrameSetFrameCount Property

Returns a count of frames in this frame set

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int FrameCount { get; }
property int FrameCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IFrameSet Interface
VisualComponents.Create3D Namespace


IFrameSet.Frames Property

IFrameSetFrames Property

Gets all the IFrame instances belonging to this IFrameSet

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IFrame> Frames { get; }
property ReadOnlyCollection<IFrame^>^ Frames {
    ReadOnlyCollection<IFrame^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIFrame
See Also

Reference

IFrameSet Interface
VisualComponents.Create3D Namespace


IFrameSet.ShowLabels Property

IFrameSetShowLabels Property

Indicates if the label should be displayed

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ShowLabels { get; set; }
property bool ShowLabels {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IFrameSet Interface
VisualComponents.Create3D Namespace


IFrameSet Methods

The IFrameSet type exposes the following members.

Methods
 | Name | Description
Public method | AddFrame(String) | Creates a new instance of IFrame and adds it to this IFrameSet
Public method | AddFrame(String, Matrix) | Creates a new instance of IFrame and adds it to this IFrameSet
Public method | Clear | Clears all geometry information from the set (Inherited from IGeometrySet.)
Public method | Delete | Deletes the set. Instance gets invalidated (Inherited from IGeometrySet.)
Public method | DeleteFrame | Deletes the given IFrame instance
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetClosestPoint | Raycast geometry set. (Inherited from IGeometrySet.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | HighlightEdges | highlights only the edges (does not override normal highlighting) (Inherited from IGeometrySet.)
Public method | Update | Updates set information (Inherited from IGeometrySet.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IFrameSet Interface
VisualComponents.Create3D Namespace


IFrameSet.AddFrame Method

IFrameSetAddFrame Method

Overload List
 | Name | Description
Public method | AddFrame(String) | Creates a new instance of IFrame and adds it to this IFrameSet
Public method | AddFrame(String, Matrix) | Creates a new instance of IFrame and adds it to this IFrameSet
Top
See Also

Reference

IFrameSet Interface
VisualComponents.Create3D Namespace


IFrameSet.AddFrame Method (String)

IFrameSetAddFrame Method (String)

Creates a new instance of IFrame and adds it to this IFrameSet

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFrame AddFrame(
    string name
)
IFrame^ AddFrame(
    String^ name
)

Parameters

name
Type: SystemString
Name of the frame to be created

Return Value

Type: IFrame
Created frame
See Also

Reference

IFrameSet Interface
AddFrame Overload
VisualComponents.Create3D Namespace


IFrameSet.AddFrame Method (String, Matrix)

IFrameSetAddFrame Method (String, Matrix)

Creates a new instance of IFrame and adds it to this IFrameSet

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFrame AddFrame(
    string name,
    Matrix position
)
IFrame^ AddFrame(
    String^ name,
    Matrix position
)

Parameters

name
Type: SystemString
Name of the frame to be created
position
Type: VisualComponents.Create3DMatrix
Position of the frame

Return Value

Type: IFrame
Created frame
See Also

Reference

IFrameSet Interface
AddFrame Overload
VisualComponents.Create3D Namespace


IFrameSet.DeleteFrame Method

IFrameSetDeleteFrame Method

Deletes the given IFrame instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteFrame(
    IFrame frame
)
void DeleteFrame(
    IFrame^ frame
)

Parameters

frame
Type: VisualComponents.Create3DIFrame
Frame to be deleted
See Also

Reference

IFrameSet Interface
VisualComponents.Create3D Namespace


IFrameSet Events

The IFrameSet type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
See Also

Reference

IFrameSet Interface
VisualComponents.Create3D Namespace


IGeneralSection Interface

Configuration file section for General Options.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IGeneralSection : ISection
public interface class IGeneralSection : ISection

The IGeneralSection type exposes the following members.

Properties
 | Name | Description
Public property | GeneralElement | Configuration file element for General Options.
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | GetSection | Gets the section (Inherited from ISection.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IGeneralSection Properties

The IGeneralSection type exposes the following members.

Properties
 | Name | Description
Public property | GeneralElement | Configuration file element for General Options.
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
See Also

Reference

IGeneralSection Interface
VisualComponents.Create3D Namespace


IGeneralSection.GeneralElement Property

IGeneralSectionGeneralElement Property

Configuration file element for General Options.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
GeneralConfigElement GeneralElement { get; set; }
property GeneralConfigElement^ GeneralElement {
    GeneralConfigElement^ get ();
    void set (GeneralConfigElement^ value);
}

Property Value

Type: GeneralConfigElement
See Also

Reference

IGeneralSection Interface
VisualComponents.Create3D Namespace


IGeneralSection Methods

The IGeneralSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | GetSection | Gets the section (Inherited from ISection.)
Top
See Also

Reference

IGeneralSection Interface
VisualComponents.Create3D Namespace


IGenericEnumeratorOwner(T) Interface

IGenericEnumeratorOwnerT Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IGenericEnumeratorOwner<T>
where T : IDisposable

generic<typename T>
where T : IDisposable
public interface class IGenericEnumeratorOwner

Type Parameters

T

The IGenericEnumeratorOwnerT type exposes the following members.

Methods
 | Name | Description
Public method | MoveNext |
Top
See Also

Reference

VisualComponents.Create3D Namespace


IGenericEnumeratorOwner(T) Methods

IGenericEnumeratorOwnerT Methods

The IGenericEnumeratorOwnerT generic type exposes the following members.

Methods
 | Name | Description
Public method | MoveNext |
Top
See Also

Reference

IGenericEnumeratorOwnerT Interface
VisualComponents.Create3D Namespace


IGenericEnumeratorOwner(T).MoveNext Method

IGenericEnumeratorOwnerTMoveNext Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool MoveNext(
    GenericEnumerator<T> state
)
bool MoveNext(
    GenericEnumerator<T>^ state
)

Parameters

state
Type: VisualComponents.Create3DGenericEnumerator T

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IGenericEnumeratorOwner`1.MoveNext(VisualComponents.Create3D.GenericEnumerator{`0})"]

See Also

Reference

IGenericEnumeratorOwnerT Interface
VisualComponents.Create3D Namespace


IGenericEventChecker Interface

Used in cases when it's possible to check if OnGenericEvent() should be called or not. Makes it easier to debug instances that are not used anymore, nor garbage collected yet.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IGenericEventChecker
public interface class IGenericEventChecker

The IGenericEventChecker type exposes the following members.

Methods
 | Name | Description
Public method | IsGenericEventNeeded |
Top
See Also

Reference

VisualComponents.Create3D Namespace


IGenericEventChecker Methods

The IGenericEventChecker type exposes the following members.

Methods
 | Name | Description
Public method | IsGenericEventNeeded |
Top
See Also

Reference

IGenericEventChecker Interface
VisualComponents.Create3D Namespace


IGenericEventChecker.IsGenericEventNeeded Method

IGenericEventCheckerIsGenericEventNeeded Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsGenericEventNeeded(
    GenericEventType type,
    int id
)
bool IsGenericEventNeeded(
    GenericEventType type,
    int id
)

Parameters

type
Type: VisualComponents.Create3DGenericEventType
id
Type: SystemInt32

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IGenericEventChecker.IsGenericEventNeeded(VisualComponents.Create3D.GenericEventType,System.Int32)"]

See Also

Reference

IGenericEventChecker Interface
VisualComponents.Create3D Namespace


IGenericEventTarget Interface

Classes that use GenericEventListener class should implement this interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IGenericEventTarget
public interface class IGenericEventTarget

The IGenericEventTarget type exposes the following members.

Methods
 | Name | Description
Public method | OnGenericEvent | Generic method that is called on various events. See GenericEventType.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IGenericEventTarget Methods

The IGenericEventTarget type exposes the following members.

Methods
 | Name | Description
Public method | OnGenericEvent | Generic method that is called on various events. See GenericEventType.
Top
See Also

Reference

IGenericEventTarget Interface
VisualComponents.Create3D Namespace


IGenericEventTarget.OnGenericEvent Method

IGenericEventTargetOnGenericEvent Method

Generic method that is called on various events. See GenericEventType.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void OnGenericEvent(
    GenericEventType type,
    int id,
    Object sender,
    EventArgs e
)
void OnGenericEvent(
    GenericEventType type,
    int id,
    Object^ sender,
    EventArgs^ e
)

Parameters

type
Type: VisualComponents.Create3DGenericEventType
id
Type: SystemInt32
sender
Type: SystemObject
e
Type: SystemEventArgs
See Also

Reference

IGenericEventTarget Interface
VisualComponents.Create3D Namespace


IGeometryContainer Interface

Geometry container interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IGeometryContainer : IWrapper,
    IDisposable
public interface class IGeometryContainer : IWrapper,
    IDisposable

The IGeometryContainer type exposes the following members.

Properties
 | Name | Description
Public property | GeometrySets | Retrieves geometry sets from the geometry container
Public property | IsHighlighted | Determines if contained sets should be highlighted
Public property | IsModified | Defines if the geometry has been modified after last saving
Public property | IsValid | (Inherited from IWrapper.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Top
Methods
 | Name | Description
Public method | Clear | Clears this IGeometryContainer instance
Public method | CreateGeometrySet | Creates a new geometry set for this IGeometryContainer instance
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | SetModified | Notifies the application that the geometry has been modified
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
Provides basic functionality of the geometry sets stored in a IGeometryFeature
See Also

Reference

VisualComponents.Create3D Namespace


IGeometryContainer Properties

The IGeometryContainer type exposes the following members.

Properties
 | Name | Description
Public property | GeometrySets | Retrieves geometry sets from the geometry container
Public property | IsHighlighted | Determines if contained sets should be highlighted
Public property | IsModified | Defines if the geometry has been modified after last saving
Public property | IsValid | (Inherited from IWrapper.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Top
See Also

Reference

IGeometryContainer Interface
VisualComponents.Create3D Namespace


IGeometryContainer.GeometrySets Property

IGeometryContainerGeometrySets Property

Retrieves geometry sets from the geometry container

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IGeometrySet> GeometrySets { get; }
property ReadOnlyCollection<IGeometrySet^>^ GeometrySets {
    ReadOnlyCollection<IGeometrySet^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIGeometrySet
See Also

Reference

IGeometryContainer Interface
VisualComponents.Create3D Namespace


IGeometryContainer.IsHighlighted Property

IGeometryContainerIsHighlighted Property

Determines if contained sets should be highlighted

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsHighlighted { get; set; }
property bool IsHighlighted {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IGeometryContainer Interface
VisualComponents.Create3D Namespace


IGeometryContainer.IsModified Property

IGeometryContainerIsModified Property

Defines if the geometry has been modified after last saving

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsModified { get; }
property bool IsModified {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IGeometryContainer Interface
VisualComponents.Create3D Namespace


IGeometryContainer Methods

The IGeometryContainer type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clears this IGeometryContainer instance
Public method | CreateGeometrySet | Creates a new geometry set for this IGeometryContainer instance
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | SetModified | Notifies the application that the geometry has been modified
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IGeometryContainer Interface
VisualComponents.Create3D Namespace


IGeometryContainer.Clear Method

IGeometryContainerClear Method

Clears this IGeometryContainer instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Clear()
void Clear()
See Also

Reference

IGeometryContainer Interface
VisualComponents.Create3D Namespace


IGeometryContainer.CreateGeometrySet Method

IGeometryContainerCreateGeometrySet Method

Creates a new geometry set for this IGeometryContainer instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IGeometrySet CreateGeometrySet(
    GeometrySetType type
)
IGeometrySet^ CreateGeometrySet(
    GeometrySetType type
)

Parameters

type
Type: VisualComponents.Create3DGeometrySetType
Type of the geometry set to be created

Return Value

Type: IGeometrySet
Created geometry set
See Also

Reference

IGeometryContainer Interface
VisualComponents.Create3D Namespace


IGeometryContainer.SetModified Method

IGeometryContainerSetModified Method

Notifies the application that the geometry has been modified

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetModified()
void SetModified()
See Also

Reference

IGeometryContainer Interface
VisualComponents.Create3D Namespace


IGeometryContainer Events

The IGeometryContainer type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
See Also

Reference

IGeometryContainer Interface
VisualComponents.Create3D Namespace


IGeometryFeature Interface

Geometry feature interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IGeometryFeature : IFeature,
    IVisualObject, INamed, IWrapper, IDisposable, IVisitable,
    IPropertyContainer, IBatchModeObject, ISharedCloneable
public interface class IGeometryFeature : IFeature,
    IVisualObject, INamed, IWrapper, IDisposable, IVisitable,
    IPropertyContainer, IBatchModeObject, ISharedCloneable

The IGeometryFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | AmbientOcclusion | Defines if geometry shading uses Ambient Occlusion rendering
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreaseAngle | Adjacent polygons whose angle difference is less than the CreaseAngle value will be treated as one smooth surface during light calculations, with their normals averaged to provide reflection normals. A low value here will make the geometry appear faceted, while a high value will make it appear smooth.
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | Geometry | Geometry container
Public property | HasMathematicalData | Specifies if the geometry sets in this geometry feature have a mathematical data (a boundary representation)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | OnDemandLoad | If this is on, the geometry is loaded into the computer's memory only when needed. This property is typically used for large geometries in conjunction with the Switch feature
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | ShowBackfaces | Defines if the reverse faces of polygons in the geometry set are displayed
Public property | Source | Location of the source file. This is usually a file in the component file. Setting this to another geometry file will effectively import the geometry into the model
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | CanMerge | Determine if this feature can be merged
Public method | CanMergeWith | Determine if this feature can be merged with the given features All features should return True for IGeometryFeature.CanMerge() and they all should belong to same parent node
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | InvertGeometry(IEnumerableIFace) | Inverts (reverts) given geometry faces
Public method | InvertGeometry(IEnumerableIGeometrySet) | Inverts (reverts) given geometry sets
Public method | InvertGeometry(IEnumerableIFace, Boolean) | Inverts (reverts) given geometry faces
Public method | InvertGeometry(IEnumerableIGeometrySet, Boolean) | Inverts (reverts) given geometry sets
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Merge | Merges this feature and the given list of features. After the merge, all involved features and their children are invalidated
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationInReference | Similar to IFeature.TransformationInNodeReal except that it does not rebuild the feature and does not trigger transformation change event
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | SliceFeature | Cuts the feature with a plane.
Public method | Split(IEnumerableIFace) | Moves the given faces to a newly created geometry feature
Public method | Split(IEnumerableIGeometrySet) | Moves the given sets to a newly created geometry feature
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | UnloadMathematicalData | Unloads any mathematical data (boundary representation) in its geometry sets
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks

The Geometry feature stores generic geometry in the model. When geometry is imported from a geometry file, it is stored in a Geometry feature.

This is also the feature that is created when a feature sub tree is collapsed.

When a component is saved, geometries are stored inside a component file (*.vcm file) in a file format that best matches the geometry.

See Also

Reference

VisualComponents.Create3D Namespace


IGeometryFeature Properties

The IGeometryFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | AmbientOcclusion | Defines if geometry shading uses Ambient Occlusion rendering
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreaseAngle | Adjacent polygons whose angle difference is less than the CreaseAngle value will be treated as one smooth surface during light calculations, with their normals averaged to provide reflection normals. A low value here will make the geometry appear faceted, while a high value will make it appear smooth.
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | Geometry | Geometry container
Public property | HasMathematicalData | Specifies if the geometry sets in this geometry feature have a mathematical data (a boundary representation)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | OnDemandLoad | If this is on, the geometry is loaded into the computer's memory only when needed. This property is typically used for large geometries in conjunction with the Switch feature
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | ShowBackfaces | Defines if the reverse faces of polygons in the geometry set are displayed
Public property | Source | Location of the source file. This is usually a file in the component file. Setting this to another geometry file will effectively import the geometry into the model
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
See Also

Reference

IGeometryFeature Interface
VisualComponents.Create3D Namespace


IGeometryFeature.AmbientOcclusion Property

IGeometryFeatureAmbientOcclusion Property

Defines if geometry shading uses Ambient Occlusion rendering

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
AmbientOcclusionMode AmbientOcclusion { get; set; }
property AmbientOcclusionMode AmbientOcclusion {
    AmbientOcclusionMode get ();
    void set (AmbientOcclusionMode value);
}

Property Value

Type: AmbientOcclusionMode
See Also

Reference

IGeometryFeature Interface
VisualComponents.Create3D Namespace


IGeometryFeature.CreaseAngle Property

IGeometryFeatureCreaseAngle Property

Adjacent polygons whose angle difference is less than the CreaseAngle value will be treated as one smooth surface during light calculations, with their normals averaged to provide reflection normals.

A low value here will make the geometry appear faceted, while a high value will make it appear smooth.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double CreaseAngle { get; set; }
property double CreaseAngle {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IGeometryFeature Interface
VisualComponents.Create3D Namespace


IGeometryFeature.Geometry Property

IGeometryFeatureGeometry Property

Geometry container

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IGeometryContainer Geometry { get; set; }
property IGeometryContainer^ Geometry {
    IGeometryContainer^ get ();
    void set (IGeometryContainer^ value);
}

Property Value

Type: IGeometryContainer
See Also

Reference

IGeometryFeature Interface
VisualComponents.Create3D Namespace


IGeometryFeature.HasMathematicalData Property

IGeometryFeatureHasMathematicalData Property

Specifies if the geometry sets in this geometry feature have a mathematical data (a boundary representation)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool HasMathematicalData { get; }
property bool HasMathematicalData {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IGeometryFeature Interface
VisualComponents.Create3D Namespace


IGeometryFeature.OnDemandLoad Property

IGeometryFeatureOnDemandLoad Property

If this is on, the geometry is loaded into the computer's memory only when needed. This property is typically used for large geometries in conjunction with the Switch feature

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool OnDemandLoad { get; set; }
property bool OnDemandLoad {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IGeometryFeature Interface
VisualComponents.Create3D Namespace


IGeometryFeature.ShowBackfaces Property

IGeometryFeatureShowBackfaces Property

Defines if the reverse faces of polygons in the geometry set are displayed

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ShowBackfaces { get; set; }
property bool ShowBackfaces {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IGeometryFeature Interface
VisualComponents.Create3D Namespace


IGeometryFeature.Source Property

IGeometryFeatureSource Property

Location of the source file. This is usually a file in the component file. Setting this to another geometry file will effectively import the geometry into the model

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Uri Source { get; set; }
property Uri^ Source {
    Uri^ get ();
    void set (Uri^ value);
}

Property Value

Type: Uri
See Also

Reference

IGeometryFeature Interface
VisualComponents.Create3D Namespace


IGeometryFeature Methods

The IGeometryFeature type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | CanMerge | Determine if this feature can be merged
Public method | CanMergeWith | Determine if this feature can be merged with the given features All features should return True for IGeometryFeature.CanMerge() and they all should belong to same parent node
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | InvertGeometry(IEnumerableIFace) | Inverts (reverts) given geometry faces
Public method | InvertGeometry(IEnumerableIGeometrySet) | Inverts (reverts) given geometry sets
Public method | InvertGeometry(IEnumerableIFace, Boolean) | Inverts (reverts) given geometry faces
Public method | InvertGeometry(IEnumerableIGeometrySet, Boolean) | Inverts (reverts) given geometry sets
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Merge | Merges this feature and the given list of features. After the merge, all involved features and their children are invalidated
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationInReference | Similar to IFeature.TransformationInNodeReal except that it does not rebuild the feature and does not trigger transformation change event
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | SliceFeature | Cuts the feature with a plane.
Public method | Split(IEnumerableIFace) | Moves the given faces to a newly created geometry feature
Public method | Split(IEnumerableIGeometrySet) | Moves the given sets to a newly created geometry feature
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | UnloadMathematicalData | Unloads any mathematical data (boundary representation) in its geometry sets
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IGeometryFeature Interface
VisualComponents.Create3D Namespace


IGeometryFeature.CanMerge Method

IGeometryFeatureCanMerge Method

Determine if this feature can be merged

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanMerge()
bool CanMerge()

Return Value

Type: Boolean
True if it can be merged
See Also

Reference

IGeometryFeature Interface
VisualComponents.Create3D Namespace


IGeometryFeature.CanMergeWith Method

IGeometryFeatureCanMergeWith Method

Determine if this feature can be merged with the given features

All features should return True for IGeometryFeature.CanMerge() and they all should belong to same parent node

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanMergeWith(
    IEnumerable<IGeometryFeature> features
)
bool CanMergeWith(
    IEnumerable<IGeometryFeature^>^ features
)

Parameters

features
Type: System.Collections.GenericIEnumerableIGeometryFeature
features to evaluate

Return Value

Type: Boolean
True if they all can be mearged
See Also

Reference

IGeometryFeature Interface
VisualComponents.Create3D Namespace


IGeometryFeature.InvertGeometry Method

IGeometryFeatureInvertGeometry Method

Overload List
 | Name | Description
Public method | InvertGeometry(IEnumerableIFace) | Inverts (reverts) given geometry faces
Public method | InvertGeometry(IEnumerableIGeometrySet) | Inverts (reverts) given geometry sets
Public method | InvertGeometry(IEnumerableIFace, Boolean) | Inverts (reverts) given geometry faces
Public method | InvertGeometry(IEnumerableIGeometrySet, Boolean) | Inverts (reverts) given geometry sets
Top
See Also

Reference

IGeometryFeature Interface
VisualComponents.Create3D Namespace


IGeometryFeature.InvertGeometry Method (IEnumerable(IFace))

IGeometryFeatureInvertGeometry Method (IEnumerableIFace)

Inverts (reverts) given geometry faces

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool InvertGeometry(
    IEnumerable<IFace> faces
)
bool InvertGeometry(
    IEnumerable<IFace^>^ faces
)

Parameters

faces
Type: System.Collections.GenericIEnumerableIFace
faces to be inverted

Return Value

Type: Boolean
False if no geometry was inverted because no suitable to invert
Remarks
All givenfaces must belong to sets contained in this feature, otherwise it throws an exception
See Also

Reference

IGeometryFeature Interface
InvertGeometry Overload
VisualComponents.Create3D Namespace


IGeometryFeature.InvertGeometry Method (IEnumerable(IGeometrySet))

IGeometryFeatureInvertGeometry Method (IEnumerableIGeometrySet)

Inverts (reverts) given geometry sets

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool InvertGeometry(
    IEnumerable<IGeometrySet> sets
)
bool InvertGeometry(
    IEnumerable<IGeometrySet^>^ sets
)

Parameters

sets
Type: System.Collections.GenericIEnumerableIGeometrySet
sets to be inverted

Return Value

Type: Boolean
False if no geometry was inverted because no suitable to invert
Remarks
All given sets must belong to this feature, otherwise it throws an exception
See Also

Reference

IGeometryFeature Interface
InvertGeometry Overload
VisualComponents.Create3D Namespace


IGeometryFeature.InvertGeometry Method (IEnumerable(IFace), Boolean)

IGeometryFeatureInvertGeometry Method (IEnumerableIFace, Boolean)

Inverts (reverts) given geometry faces

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool InvertGeometry(
    IEnumerable<IFace> faces,
    bool rebuild
)
bool InvertGeometry(
    IEnumerable<IFace^>^ faces,
    bool rebuild
)

Parameters

faces
Type: System.Collections.GenericIEnumerableIFace
faces to be inverted
rebuild
Type: SystemBoolean
specifies if rebuild should be done when operation is completed

Return Value

Type: Boolean
False if no geometry was inverted because no suitable to invert
Remarks
All givenfaces must belong to sets contained in this feature, otherwise it throws an exception
See Also

Reference

IGeometryFeature Interface
InvertGeometry Overload
VisualComponents.Create3D Namespace


IGeometryFeature.InvertGeometry Method (IEnumerable(IGeometrySet), Boolean)

IGeometryFeatureInvertGeometry Method (IEnumerableIGeometrySet, Boolean)

Inverts (reverts) given geometry sets

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool InvertGeometry(
    IEnumerable<IGeometrySet> sets,
    bool rebuild
)
bool InvertGeometry(
    IEnumerable<IGeometrySet^>^ sets,
    bool rebuild
)

Parameters

sets
Type: System.Collections.GenericIEnumerableIGeometrySet
sets to be inverted
rebuild
Type: SystemBoolean
specifies if rebuild should be done when operation is completed

Return Value

Type: Boolean
False if no geometry was inverted because no suitable to invert
Remarks
All given sets must belong to this feature, otherwise it throws an exception
See Also

Reference

IGeometryFeature Interface
InvertGeometry Overload
VisualComponents.Create3D Namespace


IGeometryFeature.Merge Method

IGeometryFeatureMerge Method

Merges this feature and the given list of features. After the merge, all involved features and their children are invalidated

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IGeometryFeature Merge(
    IEnumerable<IGeometryFeature> features
)
IGeometryFeature^ Merge(
    IEnumerable<IGeometryFeature^>^ features
)

Parameters

features
Type: System.Collections.GenericIEnumerableIGeometryFeature

Return Value

Type: IGeometryFeature
Merged feature
See Also

Reference

IGeometryFeature Interface
VisualComponents.Create3D Namespace


IGeometryFeature.SetTransformationInReference Method

IGeometryFeatureSetTransformationInReference Method

Similar to IFeature.TransformationInNodeReal except that it does not rebuild the feature and does not trigger transformation change event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetTransformationInReference(
    Matrix matrix
)
void SetTransformationInReference(
    Matrix matrix
)

Parameters

matrix
Type: VisualComponents.Create3DMatrix
See Also

Reference

IGeometryFeature Interface
VisualComponents.Create3D Namespace


IGeometryFeature.SliceFeature Method

IGeometryFeatureSliceFeature Method

Cuts the feature with a plane.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IGeometryFeature SliceFeature(
    Vector3 planePosition,
    Vector3 planeNormal,
    bool includeCoplanar
)
IGeometryFeature^ SliceFeature(
    Vector3 planePosition,
    Vector3 planeNormal,
    bool includeCoplanar
)

Parameters

planePosition
Type: VisualComponents.Create3DVector3
planeNormal
Type: VisualComponents.Create3DVector3
includeCoplanar
Type: SystemBoolean

Return Value

Type: IGeometryFeature

[Missing <returns> documentation for "M:VisualComponents.Create3D.IGeometryFeature.SliceFeature(VisualComponents.Create3D.Vector3,VisualComponents.Create3D.Vector3,System.Boolean)"]

See Also

Reference

IGeometryFeature Interface
VisualComponents.Create3D Namespace


IGeometryFeature.Split Method

IGeometryFeatureSplit Method

Overload List
 | Name | Description
Public method | Split(IEnumerableIFace) | Moves the given faces to a newly created geometry feature
Public method | Split(IEnumerableIGeometrySet) | Moves the given sets to a newly created geometry feature
Top
See Also

Reference

IGeometryFeature Interface
VisualComponents.Create3D Namespace


IGeometryFeature.Split Method (IEnumerable(IFace))

IGeometryFeatureSplit Method (IEnumerableIFace)

Moves the given faces to a newly created geometry feature

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IGeometryFeature Split(
    IEnumerable<IFace> faces
)
IGeometryFeature^ Split(
    IEnumerable<IFace^>^ faces
)

Parameters

faces
Type: System.Collections.GenericIEnumerableIFace
Sets to be moved

Return Value

Type: IGeometryFeature
New feature containing given faces
Remarks
All givenfaces must belong to sets contained in this feature, otherwise it throws an exception
See Also

Reference

IGeometryFeature Interface
Split Overload
VisualComponents.Create3D Namespace


IGeometryFeature.Split Method (IEnumerable(IGeometrySet))

IGeometryFeatureSplit Method (IEnumerableIGeometrySet)

Moves the given sets to a newly created geometry feature

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IGeometryFeature Split(
    IEnumerable<IGeometrySet> sets
)
IGeometryFeature^ Split(
    IEnumerable<IGeometrySet^>^ sets
)

Parameters

sets
Type: System.Collections.GenericIEnumerableIGeometrySet
Sets to be moved

Return Value

Type: IGeometryFeature
New feature containing given sets
Remarks
All given sets must belong to this feature, otherwise it throws an exception
See Also

Reference

IGeometryFeature Interface
Split Overload
VisualComponents.Create3D Namespace


IGeometryFeature.UnloadMathematicalData Method

IGeometryFeatureUnloadMathematicalData Method

Unloads any mathematical data (boundary representation) in its geometry sets

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UnloadMathematicalData()
void UnloadMathematicalData()
See Also

Reference

IGeometryFeature Interface
VisualComponents.Create3D Namespace


IGeometryFeature Events

The IGeometryFeature type exposes the following members.

Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

IGeometryFeature Interface
VisualComponents.Create3D Namespace


IGeometrySet Interface

Base interface for all geometry sets

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IGeometrySet : IPrimitive,
    IWrapper, IDisposable
public interface class IGeometrySet : IPrimitive,
    IWrapper, IDisposable

The IGeometrySet type exposes the following members.

Properties
 | Name | Description
Public property | BoundBox | Returns the bound box of the geometryset.
Public property | Container | Geometry container object
Public property | Feature | IGeometryFeature owning the geoset
Public property | HasMaterialInheritance | Determines if it has material inheritance
Public property | HasNoHits | For internal purpose only
Public property | IsHighlighted | Determines if set is highlighted
Public property | IsLayerVisible | Determine if the layer where the geometry set is located is visible
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Determines if set is visible
Public property | Material | Material of the set
Public property | Name | Name of the set
Public property | ObjectPrimitiveType | (Inherited from IPrimitive.)
Public property | Original | Retrieves the original geometry set
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | TopologyCurves | Set topological information
Top
Methods
 | Name | Description
Public method | Clear | Clears all geometry information from the set
Public method | Delete | Deletes the set. Instance gets invalidated
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetClosestPoint | Raycast geometry set.
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | HighlightEdges | highlights only the edges (does not override normal highlighting)
Public method | Update | Updates set information
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
Geometry set is a collection of one type of geometry primitives
See Also

Reference

VisualComponents.Create3D Namespace


IGeometrySet Properties

The IGeometrySet type exposes the following members.

Properties
 | Name | Description
Public property | BoundBox | Returns the bound box of the geometryset.
Public property | Container | Geometry container object
Public property | Feature | IGeometryFeature owning the geoset
Public property | HasMaterialInheritance | Determines if it has material inheritance
Public property | HasNoHits | For internal purpose only
Public property | IsHighlighted | Determines if set is highlighted
Public property | IsLayerVisible | Determine if the layer where the geometry set is located is visible
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Determines if set is visible
Public property | Material | Material of the set
Public property | Name | Name of the set
Public property | ObjectPrimitiveType | (Inherited from IPrimitive.)
Public property | Original | Retrieves the original geometry set
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | TopologyCurves | Set topological information
Top
See Also

Reference

IGeometrySet Interface
VisualComponents.Create3D Namespace


IGeometrySet.BoundBox Property

IGeometrySetBoundBox Property

Returns the bound box of the geometryset.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IBoundBox BoundBox { get; }
property IBoundBox^ BoundBox {
    IBoundBox^ get ();
}

Property Value

Type: IBoundBox
See Also

Reference

IGeometrySet Interface
VisualComponents.Create3D Namespace


IGeometrySet.Container Property

IGeometrySetContainer Property

Geometry container object

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IGeometryContainer Container { get; set; }
property IGeometryContainer^ Container {
    IGeometryContainer^ get ();
    void set (IGeometryContainer^ value);
}

Property Value

Type: IGeometryContainer
See Also

Reference

IGeometrySet Interface
VisualComponents.Create3D Namespace


IGeometrySet.Feature Property

IGeometrySetFeature Property

IGeometryFeature owning the geoset

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFeature Feature { get; }
property IFeature^ Feature {
    IFeature^ get ();
}

Property Value

Type: IFeature
See Also

Reference

IGeometrySet Interface
VisualComponents.Create3D Namespace


IGeometrySet.HasMaterialInheritance Property

IGeometrySetHasMaterialInheritance Property

Determines if it has material inheritance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool HasMaterialInheritance { get; set; }
property bool HasMaterialInheritance {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IGeometrySet Interface
VisualComponents.Create3D Namespace


IGeometrySet.HasNoHits Property

IGeometrySetHasNoHits Property

For internal purpose only

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool HasNoHits { get; set; }
property bool HasNoHits {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IGeometrySet Interface
VisualComponents.Create3D Namespace


IGeometrySet.IsHighlighted Property

IGeometrySetIsHighlighted Property

Determines if set is highlighted

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsHighlighted { get; set; }
property bool IsHighlighted {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IGeometrySet Interface
VisualComponents.Create3D Namespace


IGeometrySet.IsLayerVisible Property

IGeometrySetIsLayerVisible Property

Determine if the layer where the geometry set is located is visible

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsLayerVisible { get; }
property bool IsLayerVisible {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IGeometrySet Interface
VisualComponents.Create3D Namespace


IGeometrySet.IsVisible Property

IGeometrySetIsVisible Property

Determines if set is visible

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsVisible { get; set; }
property bool IsVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IGeometrySet Interface
VisualComponents.Create3D Namespace


IGeometrySet.Material Property

IGeometrySetMaterial Property

Material of the set

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMaterial Material { get; set; }
property IMaterial^ Material {
    IMaterial^ get ();
    void set (IMaterial^ value);
}

Property Value

Type: IMaterial
See Also

Reference

IGeometrySet Interface
VisualComponents.Create3D Namespace


IGeometrySet.Name Property

IGeometrySetName Property

Name of the set

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Name { get; }
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IGeometrySet Interface
VisualComponents.Create3D Namespace


IGeometrySet.Original Property

IGeometrySetOriginal Property

Retrieves the original geometry set

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IGeometrySet Original { get; }
property IGeometrySet^ Original {
    IGeometrySet^ get ();
}

Property Value

Type: IGeometrySet
Remarks
In some cases where a operation feature was applied to a geometry feature, the set involved might be part of the evaluation but not part of the original set of the geometry feature
See Also

Reference

IGeometrySet Interface
VisualComponents.Create3D Namespace


IGeometrySet.TopologyCurves Property

IGeometrySetTopologyCurves Property

Set topological information

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ITopologyBaseCurve> TopologyCurves { get; }
property ReadOnlyCollection<ITopologyBaseCurve^>^ TopologyCurves {
    ReadOnlyCollection<ITopologyBaseCurve^>^ get ();
}

Property Value

Type: ReadOnlyCollectionITopologyBaseCurve
See Also

Reference

IGeometrySet Interface
VisualComponents.Create3D Namespace


IGeometrySet Methods

The IGeometrySet type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clears all geometry information from the set
Public method | Delete | Deletes the set. Instance gets invalidated
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetClosestPoint | Raycast geometry set.
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | HighlightEdges | highlights only the edges (does not override normal highlighting)
Public method | Update | Updates set information
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IGeometrySet Interface
VisualComponents.Create3D Namespace


IGeometrySet.Clear Method

IGeometrySetClear Method

Clears all geometry information from the set

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Clear()
void Clear()
See Also

Reference

IGeometrySet Interface
VisualComponents.Create3D Namespace


IGeometrySet.Delete Method

IGeometrySetDelete Method

Deletes the set. Instance gets invalidated

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Delete()
void Delete()
See Also

Reference

IGeometrySet Interface
VisualComponents.Create3D Namespace


IGeometrySet.GetClosestPoint Method

IGeometrySetGetClosestPoint Method

Raycast geometry set.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 GetClosestPoint(
    Vector3 rayStart,
    Vector3 rayEnd
)
Vector3 GetClosestPoint(
    Vector3 rayStart,
    Vector3 rayEnd
)

Parameters

rayStart
Type: VisualComponents.Create3DVector3
rayEnd
Type: VisualComponents.Create3DVector3

Return Value

Type: Vector3

[Missing <returns> documentation for "M:VisualComponents.Create3D.IGeometrySet.GetClosestPoint(VisualComponents.Create3D.Vector3,VisualComponents.Create3D.Vector3)"]

See Also

Reference

IGeometrySet Interface
VisualComponents.Create3D Namespace


IGeometrySet.HighlightEdges Method

IGeometrySetHighlightEdges Method

highlights only the edges (does not override normal highlighting)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void HighlightEdges()
void HighlightEdges()
See Also

Reference

IGeometrySet Interface
VisualComponents.Create3D Namespace


IGeometrySet.Update Method

IGeometrySetUpdate Method

Updates set information

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Update()
void Update()
See Also

Reference

IGeometrySet Interface
VisualComponents.Create3D Namespace


IGeometrySet Events

The IGeometrySet type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
See Also

Reference

IGeometrySet Interface
VisualComponents.Create3D Namespace


Iges Enumeration

Iges -> 5.1, 5.2, 5.3

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum Iges
public enum class Iges
Members
Member name | Value | Description
IGS | 0 |
IGES | 1 |
See Also

Reference

VisualComponents.Create3D Namespace


IGetProductsStatement Interface

A process statement that gets the list of accepted products from component container.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IGetProductsStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IGetProductsStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IGetProductsStatement type exposes the following members.

Properties
 | Name | Description
Public property | AcceptAllProductTypes | Defines whether ISimProducts of any IProductType should be accepted regardless of the other settings.
Public property | AcceptedFlowGroups | Gets an editable list of explicitly accepted IProcessFlowGroups.
Public property | AcceptedProductTypes | Gets an editable list of explicitly accepted IProductTypes.
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Container | Gets or sets component container to read the products from.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | MaxCountExpression | An expression that defines the maximum number of accepted products.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | VariableName | Gets or sets the name of the process variable to use for storing the result.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IGetProductsStatement Properties

The IGetProductsStatement type exposes the following members.

Properties
 | Name | Description
Public property | AcceptAllProductTypes | Defines whether ISimProducts of any IProductType should be accepted regardless of the other settings.
Public property | AcceptedFlowGroups | Gets an editable list of explicitly accepted IProcessFlowGroups.
Public property | AcceptedProductTypes | Gets an editable list of explicitly accepted IProductTypes.
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Container | Gets or sets component container to read the products from.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | MaxCountExpression | An expression that defines the maximum number of accepted products.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | VariableName | Gets or sets the name of the process variable to use for storing the result.
Top
See Also

Reference

IGetProductsStatement Interface
VisualComponents.Create3D Namespace


IGetProductsStatement.AcceptAllProductTypes Property

IGetProductsStatementAcceptAllProductTypes Property

Defines whether ISimProducts of any IProductType should be accepted regardless of the other settings.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool AcceptAllProductTypes { get; set; }
property bool AcceptAllProductTypes {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IGetProductsStatement Interface
VisualComponents.Create3D Namespace


IGetProductsStatement.AcceptedFlowGroups Property

IGetProductsStatementAcceptedFlowGroups Property

Gets an editable list of explicitly accepted IProcessFlowGroups.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IProcessFlowGroup> AcceptedFlowGroups { get; }
property IList<IProcessFlowGroup^>^ AcceptedFlowGroups {
    IList<IProcessFlowGroup^>^ get ();
}

Property Value

Type: IListIProcessFlowGroup
See Also

Reference

IGetProductsStatement Interface
VisualComponents.Create3D Namespace


IGetProductsStatement.AcceptedProductTypes Property

IGetProductsStatementAcceptedProductTypes Property

Gets an editable list of explicitly accepted IProductTypes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IProductType> AcceptedProductTypes { get; }
property IList<IProductType^>^ AcceptedProductTypes {
    IList<IProductType^>^ get ();
}

Property Value

Type: IListIProductType
See Also

Reference

IGetProductsStatement Interface
VisualComponents.Create3D Namespace


IGetProductsStatement.Container Property

IGetProductsStatementContainer Property

Gets or sets component container to read the products from.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IComponentContainer Container { get; set; }
property IComponentContainer^ Container {
    IComponentContainer^ get ();
    void set (IComponentContainer^ value);
}

Property Value

Type: IComponentContainer
See Also

Reference

IGetProductsStatement Interface
VisualComponents.Create3D Namespace


IGetProductsStatement.MaxCountExpression Property

IGetProductsStatementMaxCountExpression Property

An expression that defines the maximum number of accepted products.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string MaxCountExpression { get; set; }
property String^ MaxCountExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IGetProductsStatement Interface
VisualComponents.Create3D Namespace


IGetProductsStatement.VariableName Property

IGetProductsStatementVariableName Property

Gets or sets the name of the process variable to use for storing the result.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string VariableName { get; set; }
property String^ VariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
The variable reference is resolved when the statement executes.
See Also

Reference

IGetProductsStatement Interface
VisualComponents.Create3D Namespace


IGetProductsStatement Methods

The IGetProductsStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IGetProductsStatement Interface
VisualComponents.Create3D Namespace


IGetProductsStatement Events

The IGetProductsStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IGetProductsStatement Interface
VisualComponents.Create3D Namespace


IGetPropertyStatement Interface

A process statement for getting an IProperty from a static ISimComponent and storing it into a process variable.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IGetPropertyStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IGetPropertyStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IGetPropertyStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyVariableName | The name of the process variable to use for storing the result.
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | SelectedBehavior | The IBehavior to get the IProperty from. A null value means that the IProperty is selected from SelectedComponent.
Public property | SelectedComponent | The static ISimComponent to get the IProperty from. A null value means that SelectedBehavior is selected from the component owned by the IProcessExecutor that is running this IGetPropertyStatement.
Public property | SelectedProperty | The IProperty to get and then store into a process variable.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetSelectedProperty | Set the selected property and it's owning objects.
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IGetPropertyStatement Properties

The IGetPropertyStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyVariableName | The name of the process variable to use for storing the result.
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | SelectedBehavior | The IBehavior to get the IProperty from. A null value means that the IProperty is selected from SelectedComponent.
Public property | SelectedComponent | The static ISimComponent to get the IProperty from. A null value means that SelectedBehavior is selected from the component owned by the IProcessExecutor that is running this IGetPropertyStatement.
Public property | SelectedProperty | The IProperty to get and then store into a process variable.
Top
See Also

Reference

IGetPropertyStatement Interface
VisualComponents.Create3D Namespace


IGetPropertyStatement.PropertyVariableName Property

IGetPropertyStatementPropertyVariableName Property

The name of the process variable to use for storing the result.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string PropertyVariableName { get; set; }
property String^ PropertyVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IGetPropertyStatement Interface
VisualComponents.Create3D Namespace


IGetPropertyStatement.SelectedBehavior Property

IGetPropertyStatementSelectedBehavior Property

The IBehavior to get the IProperty from.

A null value means that the IProperty is selected from SelectedComponent.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IBehavior SelectedBehavior { get; }
property IBehavior^ SelectedBehavior {
    IBehavior^ get ();
}

Property Value

Type: IBehavior
See Also

Reference

IGetPropertyStatement Interface
VisualComponents.Create3D Namespace


IGetPropertyStatement.SelectedComponent Property

IGetPropertyStatementSelectedComponent Property

The static ISimComponent to get the IProperty from.

A null value means that SelectedBehavior is selected from the component owned by the IProcessExecutor that is running this IGetPropertyStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent SelectedComponent { get; }
property ISimComponent^ SelectedComponent {
    ISimComponent^ get ();
}

Property Value

Type: ISimComponent
See Also

Reference

IGetPropertyStatement Interface
VisualComponents.Create3D Namespace


IGetPropertyStatement.SelectedProperty Property

IGetPropertyStatementSelectedProperty Property

The IProperty to get and then store into a process variable.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProperty SelectedProperty { get; }
property IProperty^ SelectedProperty {
    IProperty^ get ();
}

Property Value

Type: IProperty
See Also

Reference

IGetPropertyStatement Interface
VisualComponents.Create3D Namespace


IGetPropertyStatement Methods

The IGetPropertyStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetSelectedProperty | Set the selected property and it's owning objects.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IGetPropertyStatement Interface
VisualComponents.Create3D Namespace


IGetPropertyStatement.SetSelectedProperty Method

IGetPropertyStatementSetSelectedProperty Method

Set the selected property and it's owning objects.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetSelectedProperty(
    ISimComponent selectedComponent,
    IBehavior selectedBehavior,
    IProperty selectedProperty
)
void SetSelectedProperty(
    ISimComponent^ selectedComponent,
    IBehavior^ selectedBehavior,
    IProperty^ selectedProperty
)

Parameters

selectedComponent
Type: VisualComponents.Create3DISimComponent
See SelectedComponent.
selectedBehavior
Type: VisualComponents.Create3DIBehavior
See SelectedBehavior.
selectedProperty
Type: VisualComponents.Create3DIProperty
See SelectedProperty.
Exceptions
Exception | Condition
ArgumentException | If all the given arguments do not match.
ArgumentNullException | If selectedProperty is null
See Also

Reference

IGetPropertyStatement Interface
VisualComponents.Create3D Namespace


IGetPropertyStatement Events

The IGetPropertyStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IGetPropertyStatement Interface
VisualComponents.Create3D Namespace


IGroup Interface

Logical group of components.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IGroup : IWrapper, IDisposable,
    INamed
public interface class IGroup : IWrapper,
    IDisposable, INamed

The IGroup type exposes the following members.

Properties
 | Name | Description
Public property | ChildGroups | Returns child groups.
Public property | ChildItems | Components that are directly added to this group.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Items | Components found in the group and it's child groups.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentGroup | Gets the parent group of this group.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | RootGroup | Gets the root group of this group.
Top
Methods
 | Name | Description
Public method | AddChildGroup | Add a child group to the group.
Public method | AddItem | Add new component to the group.
Public method | Delete | Deletes the group.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | RemoveChildGroup | Remove existing child group from this group.
Public method | RemoveItem | Removes the component from the group.
Public method | Ungroup | Performs ungroup to this group.
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IGroup Properties

The IGroup type exposes the following members.

Properties
 | Name | Description
Public property | ChildGroups | Returns child groups.
Public property | ChildItems | Components that are directly added to this group.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Items | Components found in the group and it's child groups.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentGroup | Gets the parent group of this group.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | RootGroup | Gets the root group of this group.
Top
See Also

Reference

IGroup Interface
VisualComponents.Create3D Namespace


IGroup.ChildGroups Property

IGroupChildGroups Property

Returns child groups.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IGroup> ChildGroups { get; }
property ReadOnlyCollection<IGroup^>^ ChildGroups {
    ReadOnlyCollection<IGroup^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIGroup
See Also

Reference

IGroup Interface
VisualComponents.Create3D Namespace


IGroup.ChildItems Property

IGroupChildItems Property

Components that are directly added to this group.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ISimComponent> ChildItems { get; }
property ReadOnlyCollection<ISimComponent^>^ ChildItems {
    ReadOnlyCollection<ISimComponent^>^ get ();
}

Property Value

Type: ReadOnlyCollectionISimComponent
See Also

Reference

IGroup Interface
VisualComponents.Create3D Namespace


IGroup.Items Property

IGroupItems Property

Components found in the group and it's child groups.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ISimComponent> Items { get; }
property ReadOnlyCollection<ISimComponent^>^ Items {
    ReadOnlyCollection<ISimComponent^>^ get ();
}

Property Value

Type: ReadOnlyCollectionISimComponent
See Also

Reference

IGroup Interface
VisualComponents.Create3D Namespace


IGroup.ParentGroup Property

IGroupParentGroup Property

Gets the parent group of this group.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IGroup ParentGroup { get; }
property IGroup^ ParentGroup {
    IGroup^ get ();
}

Property Value

Type: IGroup
See Also

Reference

IGroup Interface
VisualComponents.Create3D Namespace


IGroup.RootGroup Property

IGroupRootGroup Property

Gets the root group of this group.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IGroup RootGroup { get; }
property IGroup^ RootGroup {
    IGroup^ get ();
}

Property Value

Type: IGroup
See Also

Reference

IGroup Interface
VisualComponents.Create3D Namespace


IGroup Methods

The IGroup type exposes the following members.

Methods
 | Name | Description
Public method | AddChildGroup | Add a child group to the group.
Public method | AddItem | Add new component to the group.
Public method | Delete | Deletes the group.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | RemoveChildGroup | Remove existing child group from this group.
Public method | RemoveItem | Removes the component from the group.
Public method | Ungroup | Performs ungroup to this group.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IGroup Interface
VisualComponents.Create3D Namespace


IGroup.AddChildGroup Method

IGroupAddChildGroup Method

Add a child group to the group.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddChildGroup(
    IGroup groupToAdd
)
void AddChildGroup(
    IGroup^ groupToAdd
)

Parameters

groupToAdd
Type: VisualComponents.Create3DIGroup
Group to be added. If group is attached to another group that connection is removed.
See Also

Reference

IGroup Interface
VisualComponents.Create3D Namespace


IGroup.AddItem Method

IGroupAddItem Method

Add new component to the group.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddItem(
    ISimComponent itemToAdd
)
void AddItem(
    ISimComponent^ itemToAdd
)

Parameters

itemToAdd
Type: VisualComponents.Create3DISimComponent
Component to be added.
See Also

Reference

IGroup Interface
VisualComponents.Create3D Namespace


IGroup.Delete Method

IGroupDelete Method

Deletes the group.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Delete()
void Delete()
See Also

Reference

IGroup Interface
VisualComponents.Create3D Namespace


IGroup.RemoveChildGroup Method

IGroupRemoveChildGroup Method

Remove existing child group from this group.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RemoveChildGroup(
    IGroup groupToRemove
)
void RemoveChildGroup(
    IGroup^ groupToRemove
)

Parameters

groupToRemove
Type: VisualComponents.Create3DIGroup
Group to be removed.
See Also

Reference

IGroup Interface
VisualComponents.Create3D Namespace


IGroup.RemoveItem Method

IGroupRemoveItem Method

Removes the component from the group.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RemoveItem(
    ISimComponent itemToRemove
)
void RemoveItem(
    ISimComponent^ itemToRemove
)

Parameters

itemToRemove
Type: VisualComponents.Create3DISimComponent
Component to be removed.
See Also

Reference

IGroup Interface
VisualComponents.Create3D Namespace


IGroup.Ungroup Method

IGroupUngroup Method

Performs ungroup to this group.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Ungroup()
void Ungroup()
See Also

Reference

IGroup Interface
VisualComponents.Create3D Namespace


IGroup Events

The IGroup type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
See Also

Reference

IGroup Interface
VisualComponents.Create3D Namespace


IGroupableItem Interface

interface layout items that can be groupped

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IGroupableItem : ILayoutItem,
    IWrapper, IDisposable, INamed, IPropertyContainer, IBatchModeObject
public interface class IGroupableItem : ILayoutItem,
    IWrapper, IDisposable, INamed, IPropertyContainer, IBatchModeObject

The IGroupableItem type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Group |
Public property | IsPersistent | Defines if the ILayoutItem is stored with the layout. (Inherited from ILayoutItem.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IGroupableItem Properties

The IGroupableItem type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Group |
Public property | IsPersistent | Defines if the ILayoutItem is stored with the layout. (Inherited from ILayoutItem.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IGroupableItem Interface
VisualComponents.Create3D Namespace


IGroupableItem.Group Property

IGroupableItemGroup Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ILayoutItemGroup Group { get; }
property ILayoutItemGroup^ Group {
    ILayoutItemGroup^ get ();
}

Property Value

Type: ILayoutItemGroup
See Also

Reference

IGroupableItem Interface
VisualComponents.Create3D Namespace


IGroupableItem Methods

The IGroupableItem type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IGroupableItem Interface
VisualComponents.Create3D Namespace


IGroupableItem Events

The IGroupableItem type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IGroupableItem Interface
VisualComponents.Create3D Namespace


IHaltStatement Interface

Interface for halt statement

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IHaltStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IHaltStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IHaltStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | HaltSimulation | If true, this statement will halt simulation, if false only the program execution is halted.
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ResetSimulation | If true, simulation is reset.
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IHaltStatement Properties

The IHaltStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | HaltSimulation | If true, this statement will halt simulation, if false only the program execution is halted.
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ResetSimulation | If true, simulation is reset.
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
See Also

Reference

IHaltStatement Interface
VisualComponents.Create3D Namespace


IHaltStatement.HaltSimulation Property

IHaltStatementHaltSimulation Property

If true, this statement will halt simulation, if false only the program execution is halted.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool HaltSimulation { get; set; }
property bool HaltSimulation {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IHaltStatement Interface
VisualComponents.Create3D Namespace


IHaltStatement.ResetSimulation Property

IHaltStatementResetSimulation Property

If true, simulation is reset.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ResetSimulation { get; set; }
property bool ResetSimulation {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IHaltStatement Interface
VisualComponents.Create3D Namespace


IHaltStatement Methods

The IHaltStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IHaltStatement Interface
VisualComponents.Create3D Namespace


IHaltStatement Events

The IHaltStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IHaltStatement Interface
VisualComponents.Create3D Namespace


IHeaderModel Interface

PDF templates header information

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IHeaderModel
public interface class IHeaderModel

The IHeaderModel type exposes the following members.

Properties
 | Name | Description
Public property | HeaderIconPath | Icon in header
Public property | HeaderId | Header's id
Public property | HeaderName | Name in header
Top
See Also

Reference

VisualComponents.Create3D Namespace


IHeaderModel Properties

The IHeaderModel type exposes the following members.

Properties
 | Name | Description
Public property | HeaderIconPath | Icon in header
Public property | HeaderId | Header's id
Public property | HeaderName | Name in header
Top
See Also

Reference

IHeaderModel Interface
VisualComponents.Create3D Namespace


IHeaderModel.HeaderIconPath Property

IHeaderModelHeaderIconPath Property

Icon in header

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string HeaderIconPath { get; set; }
property String^ HeaderIconPath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IHeaderModel Interface
VisualComponents.Create3D Namespace


IHeaderModel.HeaderId Property

IHeaderModelHeaderId Property

Header's id

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string HeaderId { get; set; }
property String^ HeaderId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IHeaderModel Interface
VisualComponents.Create3D Namespace


IHeaderModel.HeaderName Property

IHeaderModelHeaderName Property

Name in header

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string HeaderName { get; set; }
property String^ HeaderName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IHeaderModel Interface
VisualComponents.Create3D Namespace


IHiddenLineService Interface

Service for creating hidden line representations

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IHiddenLineService
public interface class IHiddenLineService

The IHiddenLineService type exposes the following members.

Properties
 | Name | Description
Public property | DisableOptimization | Can be used to disable optimization in special cases.
Public property | RenderTiles | Negative value or 0 means use of raycast to detect visible lines, produces accurate result. Possitive values means use of render tiling, result might not be so accurate but will be faster to generate. The higher the values the better the result (max 100, recommended 25).
Top
Methods
 | Name | Description
Public method | Cancel | Stops current generation.
Public method | Create | Creates a HiddenLineRepresentation object of the part of the layout that is visible for the camera at that point.
Public method | Create(Int32, Int32, Int32, Int32) | Creates a HiddenLineRepresentation object of the part of the layout that is visible within the given boundaries. It uses the 3D world
Public method | Create(Int32, Int32, Int32, Int32, Boolean) | Creates a HiddenLineRepresentation object of the part of the layout that is visible within the given boundaries.
Public method | Export(String) | Exports a 2D file of the part of the layout that is visible for the camera at that point.
Public method | Export(String, Int32, Int32, Int32, Int32) | Exports a 2D file of the part of the layout that is visible within the given boundaries.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IHiddenLineService Properties

The IHiddenLineService type exposes the following members.

Properties
 | Name | Description
Public property | DisableOptimization | Can be used to disable optimization in special cases.
Public property | RenderTiles | Negative value or 0 means use of raycast to detect visible lines, produces accurate result. Possitive values means use of render tiling, result might not be so accurate but will be faster to generate. The higher the values the better the result (max 100, recommended 25).
Top
See Also

Reference

IHiddenLineService Interface
VisualComponents.Create3D Namespace


IHiddenLineService.DisableOptimization Property

IHiddenLineServiceDisableOptimization Property

Can be used to disable optimization in special cases.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool DisableOptimization { get; set; }
property bool DisableOptimization {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IHiddenLineService Interface
VisualComponents.Create3D Namespace


IHiddenLineService.RenderTiles Property

IHiddenLineServiceRenderTiles Property

Negative value or 0 means use of raycast to detect visible lines, produces accurate result. Possitive values means use of render tiling, result might not be so accurate but will be faster to generate. The higher the values the better the result (max 100, recommended 25).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int RenderTiles { get; set; }
property int RenderTiles {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IHiddenLineService Interface
VisualComponents.Create3D Namespace


IHiddenLineService Methods

The IHiddenLineService type exposes the following members.

Methods
 | Name | Description
Public method | Cancel | Stops current generation.
Public method | Create | Creates a HiddenLineRepresentation object of the part of the layout that is visible for the camera at that point.
Public method | Create(Int32, Int32, Int32, Int32) | Creates a HiddenLineRepresentation object of the part of the layout that is visible within the given boundaries. It uses the 3D world
Public method | Create(Int32, Int32, Int32, Int32, Boolean) | Creates a HiddenLineRepresentation object of the part of the layout that is visible within the given boundaries.
Public method | Export(String) | Exports a 2D file of the part of the layout that is visible for the camera at that point.
Public method | Export(String, Int32, Int32, Int32, Int32) | Exports a 2D file of the part of the layout that is visible within the given boundaries.
Top
See Also

Reference

IHiddenLineService Interface
VisualComponents.Create3D Namespace


IHiddenLineService.Cancel Method

IHiddenLineServiceCancel Method

Stops current generation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Cancel()
void Cancel()
See Also

Reference

IHiddenLineService Interface
VisualComponents.Create3D Namespace


IHiddenLineService.Create Method

IHiddenLineServiceCreate Method

Overload List
 | Name | Description
Public method | Create | Creates a HiddenLineRepresentation object of the part of the layout that is visible for the camera at that point.
Public method | Create(Int32, Int32, Int32, Int32) | Creates a HiddenLineRepresentation object of the part of the layout that is visible within the given boundaries. It uses the 3D world
Public method | Create(Int32, Int32, Int32, Int32, Boolean) | Creates a HiddenLineRepresentation object of the part of the layout that is visible within the given boundaries.
Top
See Also

Reference

IHiddenLineService Interface
VisualComponents.Create3D Namespace


IHiddenLineService.Create Method

IHiddenLineServiceCreate Method

Creates a HiddenLineRepresentation object of the part of the layout that is visible for the camera at that point.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
HiddenLineRepresentation Create()
HiddenLineRepresentation^ Create()

Return Value

Type: HiddenLineRepresentation
HiddenLineRepresentation object
See Also

Reference

IHiddenLineService Interface
Create Overload
VisualComponents.Create3D Namespace


IHiddenLineService.Create Method (Int32, Int32, Int32, Int32)

IHiddenLineServiceCreate Method (Int32, Int32, Int32, Int32)

Creates a HiddenLineRepresentation object of the part of the layout that is visible within the given boundaries. It uses the 3D world

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
HiddenLineRepresentation Create(
    int top,
    int bottom,
    int left,
    int right
)
HiddenLineRepresentation^ Create(
    int top,
    int bottom,
    int left,
    int right
)

Parameters

top
Type: SystemInt32
bottom
Type: SystemInt32
left
Type: SystemInt32
right
Type: SystemInt32

Return Value

Type: HiddenLineRepresentation
HiddenLineRepresentation object
See Also

Reference

IHiddenLineService Interface
Create Overload
VisualComponents.Create3D Namespace


IHiddenLineService.Create Method (Int32, Int32, Int32, Int32, Boolean)

IHiddenLineServiceCreate Method (Int32, Int32, Int32, Int32, Boolean)

Creates a HiddenLineRepresentation object of the part of the layout that is visible within the given boundaries.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
HiddenLineRepresentation Create(
    int top,
    int bottom,
    int left,
    int right,
    bool world3D
)
HiddenLineRepresentation^ Create(
    int top,
    int bottom,
    int left,
    int right,
    bool world3D
)

Parameters

top
Type: SystemInt32
bottom
Type: SystemInt32
left
Type: SystemInt32
right
Type: SystemInt32
world3D
Type: SystemBoolean

Return Value

Type: HiddenLineRepresentation
HiddenLineRepresentation object
See Also

Reference

IHiddenLineService Interface
Create Overload
VisualComponents.Create3D Namespace


IHiddenLineService.Export Method

IHiddenLineServiceExport Method

Overload List
 | Name | Description
Public method | Export(String) | Exports a 2D file of the part of the layout that is visible for the camera at that point.
Public method | Export(String, Int32, Int32, Int32, Int32) | Exports a 2D file of the part of the layout that is visible within the given boundaries.
Top
See Also

Reference

IHiddenLineService Interface
VisualComponents.Create3D Namespace


IHiddenLineService.Export Method (String)

IHiddenLineServiceExport Method (String)

Exports a 2D file of the part of the layout that is visible for the camera at that point.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Export(
    string path
)
void Export(
    String^ path
)

Parameters

path
Type: SystemString
path to file whre hidden line representation will be saved. File has to be .dfx, .svg or .eps
See Also

Reference

IHiddenLineService Interface
Export Overload
VisualComponents.Create3D Namespace


IHiddenLineService.Export Method (String, Int32, Int32, Int32, Int32)

IHiddenLineServiceExport Method (String, Int32, Int32, Int32, Int32)

Exports a 2D file of the part of the layout that is visible within the given boundaries.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Export(
    string path,
    int top,
    int bottom,
    int left,
    int right
)
void Export(
    String^ path,
    int top,
    int bottom,
    int left,
    int right
)

Parameters

path
Type: SystemString
path to file wehre hidden line representation will be saved. File has to be .dfx, .svg or .eps
top
Type: SystemInt32
top limit in screen coordinate system
bottom
Type: SystemInt32
bottom limit in screen coordinate system
left
Type: SystemInt32
left limit in screen coordinate system
right
Type: SystemInt32
right limit in screen coordinate system
See Also

Reference

IHiddenLineService Interface
Export Overload
VisualComponents.Create3D Namespace


IIdentityMapObject Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IIdentityMapObject
public interface class IIdentityMapObject

The IIdentityMapObject type exposes the following members.

Properties
 | Name | Description
Public property | IsInIdentityMap |
Top
See Also

Reference

VisualComponents.Create3D Namespace


IIdentityMapObject Properties

The IIdentityMapObject type exposes the following members.

Properties
 | Name | Description
Public property | IsInIdentityMap |
Top
See Also

Reference

IIdentityMapObject Interface
VisualComponents.Create3D Namespace


IIdentityMapObject.IsInIdentityMap Property

IIdentityMapObjectIsInIdentityMap Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsInIdentityMap { get; set; }
property bool IsInIdentityMap {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IIdentityMapObject Interface
VisualComponents.Create3D Namespace


IIfStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IIfStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IIfStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IIfStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Condition |
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ElseScope |
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | ThenScope |
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IIfStatement Properties

The IIfStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Condition |
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ElseScope |
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | ThenScope |
Top
See Also

Reference

IIfStatement Interface
VisualComponents.Create3D Namespace


IIfStatement.Condition Property

IIfStatementCondition Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Condition { get; set; }
property String^ Condition {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IIfStatement Interface
VisualComponents.Create3D Namespace


IIfStatement.ElseScope Property

IIfStatementElseScope Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatementScope ElseScope { get; }
property IStatementScope^ ElseScope {
    IStatementScope^ get ();
}

Property Value

Type: IStatementScope
See Also

Reference

IIfStatement Interface
VisualComponents.Create3D Namespace


IIfStatement.ThenScope Property

IIfStatementThenScope Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatementScope ThenScope { get; }
property IStatementScope^ ThenScope {
    IStatementScope^ get ();
}

Property Value

Type: IStatementScope
See Also

Reference

IIfStatement Interface
VisualComponents.Create3D Namespace


IIfStatement Methods

The IIfStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IIfStatement Interface
VisualComponents.Create3D Namespace


IIfStatement Events

The IIfStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IIfStatement Interface
VisualComponents.Create3D Namespace


IImportSection Interface

Configuration file section for import options.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IImportSection : ISection
public interface class IImportSection : ISection

The IImportSection type exposes the following members.

Properties
 | Name | Description
Public property | ImportElement | Configuration file element for import options.
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | GetSection | Gets the section (Inherited from ISection.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IImportSection Properties

The IImportSection type exposes the following members.

Properties
 | Name | Description
Public property | ImportElement | Configuration file element for import options.
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
See Also

Reference

IImportSection Interface
VisualComponents.Create3D Namespace


IImportSection.ImportElement Property

IImportSectionImportElement Property

Configuration file element for import options.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ImportConfigElement ImportElement { get; }
property ImportConfigElement^ ImportElement {
    ImportConfigElement^ get ();
}

Property Value

Type: ImportConfigElement
See Also

Reference

IImportSection Interface
VisualComponents.Create3D Namespace


IImportSection Methods

The IImportSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | GetSection | Gets the section (Inherited from ISection.)
Top
See Also

Reference

IImportSection Interface
VisualComponents.Create3D Namespace


IIntegerPropertyCreator Interface

Property creation behavior used to create and modify property values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IIntegerPropertyCreator : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IIntegerPropertyCreator : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IIntegerPropertyCreator type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace
VisualComponents.Create3DIStringPropertyCreator
VisualComponents.Create3DISimDoubleVariableCreator
VisualComponents.Create3DIBooleanPropertyCreator


IIntegerPropertyCreator Properties

The IIntegerPropertyCreator type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IIntegerPropertyCreator Interface
VisualComponents.Create3D Namespace


IIntegerPropertyCreator Methods

The IIntegerPropertyCreator type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IIntegerPropertyCreator Interface
VisualComponents.Create3D Namespace


IIntegerPropertyCreator Events

The IIntegerPropertyCreator type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IIntegerPropertyCreator Interface
VisualComponents.Create3D Namespace


IIntegerSignal Interface

An interface for integer signal behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IIntegerSignal : ISignal,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed
public interface class IIntegerSignal : ISignal,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed

The IIntegerSignal type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsApplication | Defines if this ISignal instance has been created by the application for its internal use. (Inherited from ISignal.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Public property | Value | Gets or sets the value of this ISignal instance. (Inherited from ISignal.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanConnectTo | Defines if this ISignal instance can be connected to the given signal. (Inherited from ISignal.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect | Connects the given ISignal instance to the given signal. (Inherited from ISignal.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects this ISignal instance from the given signal. (Inherited from ISignal.)
Public method | DisconnectAll | Disconnects all ISignal instances connected to this signal. (Inherited from ISignal.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | SignalTrigger | Event that is raised when the value of this ISignal instance is changing. (Inherited from ISignal.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IIntegerSignal Properties

The IIntegerSignal type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsApplication | Defines if this ISignal instance has been created by the application for its internal use. (Inherited from ISignal.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Public property | Value | Gets or sets the value of this ISignal instance. (Inherited from ISignal.)
Top
See Also

Reference

IIntegerSignal Interface
VisualComponents.Create3D Namespace


IIntegerSignal Methods

The IIntegerSignal type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanConnectTo | Defines if this ISignal instance can be connected to the given signal. (Inherited from ISignal.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect | Connects the given ISignal instance to the given signal. (Inherited from ISignal.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects this ISignal instance from the given signal. (Inherited from ISignal.)
Public method | DisconnectAll | Disconnects all ISignal instances connected to this signal. (Inherited from ISignal.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IIntegerSignal Interface
VisualComponents.Create3D Namespace


IIntegerSignal Events

The IIntegerSignal type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | SignalTrigger | Event that is raised when the value of this ISignal instance is changing. (Inherited from ISignal.)
Top
See Also

Reference

IIntegerSignal Interface
VisualComponents.Create3D Namespace


IIntegerSignalMap Interface

An interface for integer signal map behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IIntegerSignalMap : ISignalMap,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed
public interface class IIntegerSignalMap : ISignalMap,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed

The IIntegerSignalMap type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConnectedExternalPorts | Returns all the connected external ports. The return value is a collection of tuples where the first item is the internal port number number and the second item is a port number in connected external map. (Inherited from ISignalMap.)
Public property | ConnectedExternalSignals | Returns all the connected signals in external components. The return value is a collection of tuples where the first item is the internal port number number and the second item is an external signal connected to the port. (Inherited from ISignalMap.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | MapCount | Gets the number of ports connected to ISignal instances. This matches SignalCount. (Inherited from ISignalMap.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | PortCount | Gets the total number of ports in this signal map. (Inherited from ISignalMap.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SignalCount | Gets the number of ISignal instances behind this signal map. (Inherited from ISignalMap.)
Public property | StartIndex | Gets the ports starting index. (Inherited from ISignalMap.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect(Int32, ISignal) | Connects the signal behind the given port to the given ISignal instance. (Inherited from ISignalMap.)
Public method | Connect(Int32, ISignalMap, Int32) | Connects the ISignal instance behind the given port to the signal behind the port behind the given map. (Inherited from ISignalMap.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | CreateSignal | Creates a ISignal instance at the given port. (Inherited from ISignalMap.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteSignalConnection(Int32) | Deletes all ISignal instances connected to the signal at the given port. Also deletes disconnected application signals. (Inherited from ISignalMap.)
Public method | DeleteSignalConnection(Int32, Boolean) | Deletes all ISignal instances connected to the signal at the given port. (Inherited from ISignalMap.)
Public method | DeleteSignalConnection(Int32, Boolean, ISignal) | Disconnects the ISignal instance at the given port from the given signal. The signal will maintain its other connections (if any). (Inherited from ISignalMap.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects the ISignal instance behind the given port. (Inherited from ISignalMap.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | FindSignalIndexesLocation | Gets the map indexes associated to the given ISignal instance. (Inherited from ISignalMap.)
Public method | FindSignalIndexLocation | Obsolete. This method is obsolete. Use FindSignalIndexesLocation(ISignal) instead. (Inherited from ISignalMap.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetPort | Returns the port number at the given map index. Works in opposite way than GetPortIndex(Int32). (Inherited from ISignalMap.)
Public method | GetPortIndex | Returns the map index of the port defined by port number. Works in opposite way than GetPort(Int32). (Inherited from ISignalMap.)
Public method | GetPortName | Returns the name of the port at the given map index. (Inherited from ISignalMap.)
Public method | GetPortValue | Reads the value from a port defined by the map index if there is a signal in that port. (Inherited from ISignalMap.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetSignal | Gets a ISignal instance behind the map at the given map index. (Inherited from ISignalMap.)
Public method | MapGetPortSignal | Gets the ISignal instance behind the given port number. (Inherited from ISignalMap.)
Public method | SetPortName | Sets a port name given map index Remarks There should be a signal in this port in order to associate a name (Inherited from ISignalMap.)
Public method | SetPortValue | Sends a signal to a port defined by map index. (Inherited from ISignalMap.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetSignal | Associates a component signal into the given port (Inherited from ISignalMap.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | SignalValueChanged | Triggered when the value of the signal associated to the port changes. (Inherited from ISignalMap.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IIntegerSignalMap Properties

The IIntegerSignalMap type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConnectedExternalPorts | Returns all the connected external ports. The return value is a collection of tuples where the first item is the internal port number number and the second item is a port number in connected external map. (Inherited from ISignalMap.)
Public property | ConnectedExternalSignals | Returns all the connected signals in external components. The return value is a collection of tuples where the first item is the internal port number number and the second item is an external signal connected to the port. (Inherited from ISignalMap.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | MapCount | Gets the number of ports connected to ISignal instances. This matches SignalCount. (Inherited from ISignalMap.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | PortCount | Gets the total number of ports in this signal map. (Inherited from ISignalMap.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SignalCount | Gets the number of ISignal instances behind this signal map. (Inherited from ISignalMap.)
Public property | StartIndex | Gets the ports starting index. (Inherited from ISignalMap.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IIntegerSignalMap Interface
VisualComponents.Create3D Namespace


IIntegerSignalMap Methods

The IIntegerSignalMap type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect(Int32, ISignal) | Connects the signal behind the given port to the given ISignal instance. (Inherited from ISignalMap.)
Public method | Connect(Int32, ISignalMap, Int32) | Connects the ISignal instance behind the given port to the signal behind the port behind the given map. (Inherited from ISignalMap.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | CreateSignal | Creates a ISignal instance at the given port. (Inherited from ISignalMap.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteSignalConnection(Int32) | Deletes all ISignal instances connected to the signal at the given port. Also deletes disconnected application signals. (Inherited from ISignalMap.)
Public method | DeleteSignalConnection(Int32, Boolean) | Deletes all ISignal instances connected to the signal at the given port. (Inherited from ISignalMap.)
Public method | DeleteSignalConnection(Int32, Boolean, ISignal) | Disconnects the ISignal instance at the given port from the given signal. The signal will maintain its other connections (if any). (Inherited from ISignalMap.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects the ISignal instance behind the given port. (Inherited from ISignalMap.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | FindSignalIndexesLocation | Gets the map indexes associated to the given ISignal instance. (Inherited from ISignalMap.)
Public method | FindSignalIndexLocation | Obsolete. This method is obsolete. Use FindSignalIndexesLocation(ISignal) instead. (Inherited from ISignalMap.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetPort | Returns the port number at the given map index. Works in opposite way than GetPortIndex(Int32). (Inherited from ISignalMap.)
Public method | GetPortIndex | Returns the map index of the port defined by port number. Works in opposite way than GetPort(Int32). (Inherited from ISignalMap.)
Public method | GetPortName | Returns the name of the port at the given map index. (Inherited from ISignalMap.)
Public method | GetPortValue | Reads the value from a port defined by the map index if there is a signal in that port. (Inherited from ISignalMap.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetSignal | Gets a ISignal instance behind the map at the given map index. (Inherited from ISignalMap.)
Public method | MapGetPortSignal | Gets the ISignal instance behind the given port number. (Inherited from ISignalMap.)
Public method | SetPortName | Sets a port name given map index Remarks There should be a signal in this port in order to associate a name (Inherited from ISignalMap.)
Public method | SetPortValue | Sends a signal to a port defined by map index. (Inherited from ISignalMap.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetSignal | Associates a component signal into the given port (Inherited from ISignalMap.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IIntegerSignalMap Interface
VisualComponents.Create3D Namespace


IIntegerSignalMap Events

The IIntegerSignalMap type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | SignalValueChanged | Triggered when the value of the signal associated to the port changes. (Inherited from ISignalMap.)
Top
See Also

Reference

IIntegerSignalMap Interface
VisualComponents.Create3D Namespace


IInteractionService Interface

Interface to interaction services

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IInteractionService
public interface class IInteractionService

The IInteractionService type exposes the following members.

Properties
 | Name | Description
Public property | DegreeOfFreedom | Gets the degree of freedom
Public property | IsTargetJoint | Defines if the manipulated target property will manipulate a joint value.
Public property | Node | Gets the node that the service is initialized with.
Public property | ReferencePosition | Gets the reference position
Public property | Scale | Gets the scaling factor used for adjusting interaction
Public property | TargetControlType | The control type of the target property.
Public property | TargetProperty | Gets the variable being manipulated by the interaction
Top
Methods
 | Name | Description
Public method | Initialize | Initializes service using given node
Public method | IsInteractive | Determines if the ISimNode supports interactive operations
Public method | IsPhysical | Determines if the ISimNode is a rigid body or other physical object.
Public method | NotifyInteraction(MouseAction) | Obsolete. Notifies interactive object about mouse interaction.
Public method | NotifyInteraction(MouseInteractionType, MouseAction) | Notifies interactive object about mouse interaction.
Public method | SetTargetValue | Sets the value of the target property.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IInteractionService Properties

The IInteractionService type exposes the following members.

Properties
 | Name | Description
Public property | DegreeOfFreedom | Gets the degree of freedom
Public property | IsTargetJoint | Defines if the manipulated target property will manipulate a joint value.
Public property | Node | Gets the node that the service is initialized with.
Public property | ReferencePosition | Gets the reference position
Public property | Scale | Gets the scaling factor used for adjusting interaction
Public property | TargetControlType | The control type of the target property.
Public property | TargetProperty | Gets the variable being manipulated by the interaction
Top
See Also

Reference

IInteractionService Interface
VisualComponents.Create3D Namespace


IInteractionService.DegreeOfFreedom Property

IInteractionServiceDegreeOfFreedom Property

Gets the degree of freedom

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
DegreeOfFreedom DegreeOfFreedom { get; }
property DegreeOfFreedom DegreeOfFreedom {
    DegreeOfFreedom get ();
}

Property Value

Type: DegreeOfFreedom
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the service has not been initialized
See Also

Reference

IInteractionService Interface
VisualComponents.Create3D Namespace


IInteractionService.IsTargetJoint Property

IInteractionServiceIsTargetJoint Property

Defines if the manipulated target property will manipulate a joint value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsTargetJoint { get; }
property bool IsTargetJoint {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IInteractionService Interface
VisualComponents.Create3D Namespace


IInteractionService.Node Property

IInteractionServiceNode Property

Gets the node that the service is initialized with.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode Node { get; }
property ISimNode^ Node {
    ISimNode^ get ();
}

Property Value

Type: ISimNode
See Also

Reference

IInteractionService Interface
VisualComponents.Create3D Namespace


IInteractionService.ReferencePosition Property

IInteractionServiceReferencePosition Property

Gets the reference position

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix ReferencePosition { get; }
property Matrix ReferencePosition {
    Matrix get ();
}

Property Value

Type: Matrix
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the service has not been initialized
See Also

Reference

IInteractionService Interface
VisualComponents.Create3D Namespace


IInteractionService.Scale Property

IInteractionServiceScale Property

Gets the scaling factor used for adjusting interaction

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Scale { get; }
property double Scale {
    double get ();
}

Property Value

Type: Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the service has not been initialized
See Also

Reference

IInteractionService Interface
VisualComponents.Create3D Namespace


IInteractionService.TargetControlType Property

IInteractionServiceTargetControlType Property

The control type of the target property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
JointControlType TargetControlType { get; }
property JointControlType TargetControlType {
    JointControlType get ();
}

Property Value

Type: JointControlType
See Also

Reference

IInteractionService Interface
VisualComponents.Create3D Namespace


IInteractionService.TargetProperty Property

IInteractionServiceTargetProperty Property

Gets the variable being manipulated by the interaction

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProperty TargetProperty { get; }
property IProperty^ TargetProperty {
    IProperty^ get ();
}

Property Value

Type: IProperty
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the service has not been initialized
See Also

Reference

IInteractionService Interface
VisualComponents.Create3D Namespace


IInteractionService Methods

The IInteractionService type exposes the following members.

Methods
 | Name | Description
Public method | Initialize | Initializes service using given node
Public method | IsInteractive | Determines if the ISimNode supports interactive operations
Public method | IsPhysical | Determines if the ISimNode is a rigid body or other physical object.
Public method | NotifyInteraction(MouseAction) | Obsolete. Notifies interactive object about mouse interaction.
Public method | NotifyInteraction(MouseInteractionType, MouseAction) | Notifies interactive object about mouse interaction.
Public method | SetTargetValue | Sets the value of the target property.
Top
See Also

Reference

IInteractionService Interface
VisualComponents.Create3D Namespace


IInteractionService.Initialize Method

IInteractionServiceInitialize Method

Initializes service using given node

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Initialize(
    ISimNode node
)
void Initialize(
    ISimNode^ node
)

Parameters

node
Type: VisualComponents.Create3DISimNode
Node
Exceptions
Exception | Condition
ArgumentNullException | Thrown when reference to node is null
InvalidOperationException | Thrown when node does not support interaction
See Also

Reference

IInteractionService Interface
VisualComponents.Create3D Namespace


IInteractionService.IsInteractive Method

IInteractionServiceIsInteractive Method

Determines if the ISimNode supports interactive operations

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsInteractive(
    ISimNode node
)
bool IsInteractive(
    ISimNode^ node
)

Parameters

node
Type: VisualComponents.Create3DISimNode
Node to test

Return Value

Type: Boolean
True if the node supports interaction
Exceptions
Exception | Condition
ArgumentNullException | Thrown when reference to node is null
See Also

Reference

IInteractionService Interface
VisualComponents.Create3D Namespace


IInteractionService.IsPhysical Method

IInteractionServiceIsPhysical Method

Determines if the ISimNode is a rigid body or other physical object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsPhysical(
    ISimNode node
)
bool IsPhysical(
    ISimNode^ node
)

Parameters

node
Type: VisualComponents.Create3DISimNode
Node to test

Return Value

Type: Boolean
True if the node is simulated physically
Exceptions
Exception | Condition
ArgumentNullException | Thrown when reference to node is null
See Also

Reference

IInteractionService Interface
VisualComponents.Create3D Namespace


IInteractionService.NotifyInteraction Method

IInteractionServiceNotifyInteraction Method

Overload List
 | Name | Description
Public method | NotifyInteraction(MouseAction) | Obsolete. Notifies interactive object about mouse interaction.
Public method | NotifyInteraction(MouseInteractionType, MouseAction) | Notifies interactive object about mouse interaction.
Top
See Also

Reference

IInteractionService Interface
VisualComponents.Create3D Namespace


IInteractionService.NotifyInteraction Method (MouseAction)

IInteractionServiceNotifyInteraction Method (MouseAction)

Note: This API is now obsolete.

Notifies interactive object about mouse interaction.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Use NotifyInteraction(MouseInteractionType interactionType, MouseAction mouseAction) instead")]
void NotifyInteraction(
    MouseAction mouseAction
)
[ObsoleteAttribute(L"Use NotifyInteraction(MouseInteractionType interactionType, MouseAction mouseAction) instead")]
void NotifyInteraction(
    MouseAction mouseAction
)

Parameters

mouseAction
Type: System.Windows.InputMouseAction
Mouse action that has occurred.
See Also

Reference

IInteractionService Interface
NotifyInteraction Overload
VisualComponents.Create3D Namespace


IInteractionService.NotifyInteraction Method (MouseInteractionType, MouseAction)

IInteractionServiceNotifyInteraction Method (MouseInteractionType, MouseAction)

Notifies interactive object about mouse interaction.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void NotifyInteraction(
    MouseInteractionType interactionType,
    MouseAction mouseAction
)
void NotifyInteraction(
    MouseInteractionType interactionType,
    MouseAction mouseAction
)

Parameters

interactionType
Type: VisualComponents.Create3DMouseInteractionType
Type of interaction that has occurred.
mouseAction
Type: System.Windows.InputMouseAction
Mouse action that has occurred.
See Also

Reference

IInteractionService Interface
NotifyInteraction Overload
VisualComponents.Create3D Namespace


IInteractionService.SetTargetValue Method

IInteractionServiceSetTargetValue Method

Sets the value of the target property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetTargetValue(
    double value,
    bool lockTarget
)
void SetTargetValue(
    double value,
    bool lockTarget
)

Parameters

value
Type: SystemDouble
Value to be set.
lockTarget
Type: SystemBoolean
Defines if the kinematic chain target is locked in place.
See Also

Reference

IInteractionService Interface
VisualComponents.Create3D Namespace


IInterpolatable Interface

Interface for interpolatable objects

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IInterpolatable
public interface class IInterpolatable

The IInterpolatable type exposes the following members.

Methods
 | Name | Description
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given.
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IInterpolatable Methods

The IInterpolatable type exposes the following members.

Methods
 | Name | Description
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given.
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator.
Top
See Also

Reference

IInterpolatable Interface
VisualComponents.Create3D Namespace


IInterpolatable.EndInterpolation Method

IInterpolatableEndInterpolation Method

Notifies that that the interpolation has been finished and all the interpolation related data can be released

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void EndInterpolation()
void EndInterpolation()
See Also

Reference

IInterpolatable Interface
VisualComponents.Create3D Namespace


IInterpolatable.Interpolate Method

IInterpolatableInterpolate Method

Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Interpolate(
    double length,
    ref IMotionTarget target
)
void Interpolate(
    double length,
    IMotionTarget^% target
)

Parameters

length
Type: SystemDouble
Length for the interpolation.
target
Type: VisualComponents.Create3DIMotionTarget
Target where the interpolation result is assigned, new target is create if null is given
Remarks
Use StartInterpolation(IMotionTarget) to calculate the total length.
See Also

Reference

IInterpolatable Interface
VisualComponents.Create3D Namespace


IInterpolatable.StartInterpolation Method

IInterpolatableStartInterpolation Method

Calculates the cycle length and initializes the interpolator.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double StartInterpolation(
    IMotionTarget from
)
double StartInterpolation(
    IMotionTarget^ from
)

Parameters

from
Type: VisualComponents.Create3DIMotionTarget
Target from where the interpolation starts from, this is ignored if null.

Return Value

Type: Double
The length of the cycle.
See Also

Reference

IInterpolatable Interface
VisualComponents.Create3D Namespace


IJogInfo Interface

An interface for jog info behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IJogInfo : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IJogInfo : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IJogInfo type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | DegreeOfFreedom | Defines the degree of freedom (DOF), either rotation around x, y, or z or translation along x, y, or z.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Message | Message associated to this behavior.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Offset | Defines a pivot matrix in node's coordinate system.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | Property | Get or sets target property that is modified by interaction.
Public property | PropertyControlType | Defines if the Property manipulates a joint.
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Scale | Gets or sets the scaling value. Scale can be used for adjusting the jogging with a factor. Typical scale values are +1.0 and -1.0.
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | NotifyInteraction(MouseAction) | Obsolete. Notifies the jog info behavior about the occurred mouse interaction.
Public method | NotifyInteraction(MouseInteractionType, MouseAction) | Notifies the jog info behavior about the occurred mouse interaction.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTargetValue | Sets the value of the target property. If manipulating a joint lockTarget property can be used for locking the end of the kinematic chain in place. This is useful if for instance a robot positioner track position is changed, but the robot TCP location should remain in its place.
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks

Jog Info manipulates a component's parameter value interactively.

Jog Info can manipulate any component parameter, which uses real type values.

Typically Jog Info is used to manipulate robot/manipulator link nodes, covers or other physical dimensions in the component.

See Also

Reference

VisualComponents.Create3D Namespace


IJogInfo Properties

The IJogInfo type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | DegreeOfFreedom | Defines the degree of freedom (DOF), either rotation around x, y, or z or translation along x, y, or z.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Message | Message associated to this behavior.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Offset | Defines a pivot matrix in node's coordinate system.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | Property | Get or sets target property that is modified by interaction.
Public property | PropertyControlType | Defines if the Property manipulates a joint.
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Scale | Gets or sets the scaling value. Scale can be used for adjusting the jogging with a factor. Typical scale values are +1.0 and -1.0.
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IJogInfo Interface
VisualComponents.Create3D Namespace


IJogInfo.DegreeOfFreedom Property

IJogInfoDegreeOfFreedom Property

Defines the degree of freedom (DOF), either rotation around x, y, or z or translation along x, y, or z.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
DegreeOfFreedom DegreeOfFreedom { get; set; }
property DegreeOfFreedom DegreeOfFreedom {
    DegreeOfFreedom get ();
    void set (DegreeOfFreedom value);
}

Property Value

Type: DegreeOfFreedom
See Also

Reference

IJogInfo Interface
VisualComponents.Create3D Namespace


IJogInfo.Message Property

IJogInfoMessage Property

Message associated to this behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Message { get; set; }
property String^ Message {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IJogInfo Interface
VisualComponents.Create3D Namespace


IJogInfo.Offset Property

IJogInfoOffset Property

Defines a pivot matrix in node's coordinate system.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix Offset { get; set; }
property Matrix Offset {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

IJogInfo Interface
VisualComponents.Create3D Namespace


IJogInfo.Property Property

IJogInfoProperty Property

Get or sets target property that is modified by interaction.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProperty Property { get; set; }
property IProperty^ Property {
    IProperty^ get ();
    void set (IProperty^ value);
}

Property Value

Type: IProperty
Exceptions
Exception | Condition
Exception | Thrown when...
See Also

Reference

IJogInfo Interface
VisualComponents.Create3D Namespace


IJogInfo.PropertyControlType Property

IJogInfoPropertyControlType Property

Defines if the Property manipulates a joint.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
JointControlType PropertyControlType { get; }
property JointControlType PropertyControlType {
    JointControlType get ();
}

Property Value

Type: JointControlType
See Also

Reference

IJogInfo Interface
VisualComponents.Create3D Namespace


IJogInfo.Scale Property

IJogInfoScale Property

Gets or sets the scaling value. Scale can be used for adjusting the jogging with a factor. Typical scale values are +1.0 and -1.0.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Scale { get; set; }
property double Scale {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IJogInfo Interface
VisualComponents.Create3D Namespace


IJogInfo Methods

The IJogInfo type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | NotifyInteraction(MouseAction) | Obsolete. Notifies the jog info behavior about the occurred mouse interaction.
Public method | NotifyInteraction(MouseInteractionType, MouseAction) | Notifies the jog info behavior about the occurred mouse interaction.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTargetValue | Sets the value of the target property. If manipulating a joint lockTarget property can be used for locking the end of the kinematic chain in place. This is useful if for instance a robot positioner track position is changed, but the robot TCP location should remain in its place.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IJogInfo Interface
VisualComponents.Create3D Namespace


IJogInfo.NotifyInteraction Method

IJogInfoNotifyInteraction Method

Overload List
 | Name | Description
Public method | NotifyInteraction(MouseAction) | Obsolete. Notifies the jog info behavior about the occurred mouse interaction.
Public method | NotifyInteraction(MouseInteractionType, MouseAction) | Notifies the jog info behavior about the occurred mouse interaction.
Top
See Also

Reference

IJogInfo Interface
VisualComponents.Create3D Namespace


IJogInfo.NotifyInteraction Method (MouseAction)

IJogInfoNotifyInteraction Method (MouseAction)

Note: This API is now obsolete.

Notifies the jog info behavior about the occurred mouse interaction.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Use NotifyInteraction(InteractionType interactionType, MouseAction mouseAction) instead.")]
void NotifyInteraction(
    MouseAction mouseAction
)
[ObsoleteAttribute(L"Use NotifyInteraction(InteractionType interactionType, MouseAction mouseAction) instead.")]
void NotifyInteraction(
    MouseAction mouseAction
)

Parameters

mouseAction
Type: System.Windows.InputMouseAction
Mouse action that has occurred.
See Also

Reference

IJogInfo Interface
NotifyInteraction Overload
VisualComponents.Create3D Namespace


IJogInfo.NotifyInteraction Method (MouseInteractionType, MouseAction)

IJogInfoNotifyInteraction Method (MouseInteractionType, MouseAction)

Notifies the jog info behavior about the occurred mouse interaction.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void NotifyInteraction(
    MouseInteractionType interactionType,
    MouseAction mouseAction
)
void NotifyInteraction(
    MouseInteractionType interactionType,
    MouseAction mouseAction
)

Parameters

interactionType
Type: VisualComponents.Create3DMouseInteractionType
The type of interaction that has occurred.
mouseAction
Type: System.Windows.InputMouseAction
Mouse action that has occurred.
See Also

Reference

IJogInfo Interface
NotifyInteraction Overload
VisualComponents.Create3D Namespace


IJogInfo.SetTargetValue Method

IJogInfoSetTargetValue Method

Sets the value of the target property. If manipulating a joint lockTarget property can be used for locking the end of the kinematic chain in place. This is useful if for instance a robot positioner track position is changed, but the robot TCP location should remain in its place.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetTargetValue(
    double value,
    bool lockTarget
)
void SetTargetValue(
    double value,
    bool lockTarget
)

Parameters

value
Type: SystemDouble
Value of the target property to be set.
lockTarget
Type: SystemBoolean
Defines if the target should be locked.
See Also

Reference

IJogInfo Interface
VisualComponents.Create3D Namespace


IJogInfo Events

The IJogInfo type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IJogInfo Interface
VisualComponents.Create3D Namespace


IJoint Interface

Robot's joint definition.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IJoint
public interface class IJoint

The IJoint type exposes the following members.

Properties
 | Name | Description
Public property | Controller | Controller that contains the joint.
Public property | Dof | DOF that this joint drives.
Public property | InitialValue | Joint initial value.
Public property | LagTime | Joint lag time, in seconds.
Public property | MaxAcceleration | Maximum acceleration, in units per second squared.
Public property | MaxDeceleration | Maximum deceleration, in units per second squared.
Public property | MaxSpeed | Maximum velocity, in units per second.
Public property | MaxValue | Joint maximum value.
Public property | MaxValueExpression | Joint maximum value expression.
Public property | MinValue | Joint minimum value.
Public property | MinValueExpression | Joint minimum value expression.
Public property | Name | Name of joint.
Public property | SettleTime | Joint settle time, in seconds.
Public property | SoftMaxValue | Soft maximum limit.
Public property | SoftMaxValueExpression | Soft maximum limit expression.
Public property | SoftMinValue | Soft minimum limit.
Public property | SoftMinValueExpression | Soft minimum limit expression.
Public property | Type | Joint type; can be rotational or linear.
Public property | Value | Current joint value.
Top
Methods
 | Name | Description
Public method | SetJointValue | Advanced setter for Value.
Top
Events
 | Name | Description
Public event | ValueChanged | Event that is raised on every Value change.
Top
Remarks
Referenced by Joints and ExternalJoints.
See Also

Reference

VisualComponents.Create3D Namespace


IJoint Properties

The IJoint type exposes the following members.

Properties
 | Name | Description
Public property | Controller | Controller that contains the joint.
Public property | Dof | DOF that this joint drives.
Public property | InitialValue | Joint initial value.
Public property | LagTime | Joint lag time, in seconds.
Public property | MaxAcceleration | Maximum acceleration, in units per second squared.
Public property | MaxDeceleration | Maximum deceleration, in units per second squared.
Public property | MaxSpeed | Maximum velocity, in units per second.
Public property | MaxValue | Joint maximum value.
Public property | MaxValueExpression | Joint maximum value expression.
Public property | MinValue | Joint minimum value.
Public property | MinValueExpression | Joint minimum value expression.
Public property | Name | Name of joint.
Public property | SettleTime | Joint settle time, in seconds.
Public property | SoftMaxValue | Soft maximum limit.
Public property | SoftMaxValueExpression | Soft maximum limit expression.
Public property | SoftMinValue | Soft minimum limit.
Public property | SoftMinValueExpression | Soft minimum limit expression.
Public property | Type | Joint type; can be rotational or linear.
Public property | Value | Current joint value.
Top
See Also

Reference

IJoint Interface
VisualComponents.Create3D Namespace


IJoint.Controller Property

IJointController Property

Controller that contains the joint.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IServoController Controller { get; }
property IServoController^ Controller {
    IServoController^ get ();
}

Property Value

Type: IServoController
Remarks

In the case of external joints, this is the controller from which the joint was originally exported, and may not be the same as the IServo instance from which this instance was obtained.

See Also

Reference

IJoint Interface
VisualComponents.Create3D Namespace


IJoint.Dof Property

IJointDof Property

DOF that this joint drives.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IDof Dof { get; }
property IDof^ Dof {
    IDof^ get ();
}

Property Value

Type: IDof
See Also

Reference

IJoint Interface
VisualComponents.Create3D Namespace


IJoint.InitialValue Property

IJointInitialValue Property

Joint initial value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double InitialValue { get; set; }
property double InitialValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Remarks

The joint is set to its initial value when the layout is loaded or the simulation is reset.

See Also

Reference

IJoint Interface
VisualComponents.Create3D Namespace


IJoint.LagTime Property

IJointLagTime Property

Joint lag time, in seconds.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double LagTime { get; set; }
property double LagTime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Remarks

This value is used when calculating the motion profile for servo motions or robot PTP motions.

See Also

Reference

IJoint Interface
VisualComponents.Create3D Namespace


IJoint.MaxAcceleration Property

IJointMaxAcceleration Property

Maximum acceleration, in units per second squared.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double MaxAcceleration { get; set; }
property double MaxAcceleration {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Remarks

This value is used when calculating the motion profile for servo motions or robot PTP motions.

See Value for information about units.

See Also

Reference

IJoint Interface
VisualComponents.Create3D Namespace


IJoint.MaxDeceleration Property

IJointMaxDeceleration Property

Maximum deceleration, in units per second squared.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double MaxDeceleration { get; set; }
property double MaxDeceleration {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Remarks

This value is used when calculating the motion profile for servo motions or robot PTP motions.

See Value for information about units.

See Also

Reference

IJoint Interface
VisualComponents.Create3D Namespace


IJoint.MaxSpeed Property

IJointMaxSpeed Property

Maximum velocity, in units per second.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double MaxSpeed { get; set; }
property double MaxSpeed {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Remarks

This value is used when calculating the motion profile for servo motions or robot PTP motions.

See Value for information about units.

See Also

Reference

IJoint Interface
VisualComponents.Create3D Namespace


IJoint.MaxValue Property

IJointMaxValue Property

Joint maximum value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double MaxValue { get; set; }
property double MaxValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Remarks

Setting this value will also change the MaxValueExpression property to a constant expression.

See Also

Reference

IJoint Interface
VisualComponents.Create3D Namespace


IJoint.MaxValueExpression Property

IJointMaxValueExpression Property

Joint maximum value expression.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string MaxValueExpression { get; set; }
property String^ MaxValueExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks

The joint expression may refer to any properties inside the component, as well as behavior properties using double colon notation. This also includes other joint values.

Setting this property will also change the MaxValue property. Setting this property to an empty string will set the MaxValue property to a very large value.

See Also

Reference

IJoint Interface
VisualComponents.Create3D Namespace


IJoint.MinValue Property

IJointMinValue Property

Joint minimum value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double MinValue { get; set; }
property double MinValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Remarks

Setting this value will also change the MinValueExpression property to a constant expression.

See Also

Reference

IJoint Interface
VisualComponents.Create3D Namespace


IJoint.MinValueExpression Property

IJointMinValueExpression Property

Joint minimum value expression.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string MinValueExpression { get; set; }
property String^ MinValueExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks

The joint expression may refer to any properties inside the component, as well as behavior properties using double colon notation. This also includes other joint values.

Setting this property will also change the MinValue property. Setting this property to an empty string will set the MinValue property to a very small value.

See Also

Reference

IJoint Interface
VisualComponents.Create3D Namespace


IJoint.Name Property

IJointName Property

Name of joint.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Name { get; set; }
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IJoint Interface
VisualComponents.Create3D Namespace


IJoint.SettleTime Property

IJointSettleTime Property

Joint settle time, in seconds.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double SettleTime { get; set; }
property double SettleTime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Remarks

This value is used when calculating the motion profile for servo motions or robot PTP motions.

See Also

Reference

IJoint Interface
VisualComponents.Create3D Namespace


IJoint.SoftMaxValue Property

IJointSoftMaxValue Property

Soft maximum limit.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double SoftMaxValue { get; set; }
property double SoftMaxValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Remarks
This value is calculated from SoftMaxValueExpression.
See Also

Reference

IJoint Interface
VisualComponents.Create3D Namespace


IJoint.SoftMaxValueExpression Property

IJointSoftMaxValueExpression Property

Soft maximum limit expression.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string SoftMaxValueExpression { get; set; }
property String^ SoftMaxValueExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
This expression is also visible in DOF properties.
See Also

Reference

IJoint Interface
VisualComponents.Create3D Namespace


IJoint.SoftMinValue Property

IJointSoftMinValue Property

Soft minimum limit.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double SoftMinValue { get; set; }
property double SoftMinValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Remarks
This value is calculated from SoftMinValueExpression.
See Also

Reference

IJoint Interface
VisualComponents.Create3D Namespace


IJoint.SoftMinValueExpression Property

IJointSoftMinValueExpression Property

Soft minimum limit expression.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string SoftMinValueExpression { get; set; }
property String^ SoftMinValueExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
This expression is also visible in DOF properties.
See Also

Reference

IJoint Interface
VisualComponents.Create3D Namespace


IJoint.Type Property

IJointType Property

Joint type; can be rotational or linear.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
JointType Type { get; set; }
property JointType Type {
    JointType get ();
    void set (JointType value);
}

Property Value

Type: JointType
Remarks

The main difference for motion calculation is that for rotational joints, turn calculation is applied.

See Also

Reference

IJoint Interface
VisualComponents.Create3D Namespace


IJoint.Value Property

IJointValue Property

Current joint value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Value { get; set; }
property double Value {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Remarks

The unit of the joint value depends on the joint type. Conventionally, for rotational joints, the joint value is expressed in degrees, and for linear joints the value is expressed in millimeters.

This can be changed by modelling the servo or robot to use joint values in a different way; however, in that case, the following points must be observed:

  • In the case of servo controllers, all motions are joint value based, and the unit has no impact. The only exception is that turns of rotational joints are calculated based on degrees; however, this only affects the turn number seen through the API and has no impact on motion calculation, so it is safe to ignore.
  • In the case of robots, all the built-in kinematics types assume that the joints are expressed in degrees or millimeters, so changing the units requires a custom Python kinematic object.
  • In robots, there is also turn calculation for rotational joints, but here they are also subject to turn selection which affects the robot movement in some cases. Since the joint turn system assumes that the unit is degrees, in order to change the unit, the turn calculation must be disabled and handled manually in the custom kinematic object.
See Also

Reference

IJoint Interface
VisualComponents.Create3D Namespace


IJoint Methods

The IJoint type exposes the following members.

Methods
 | Name | Description
Public method | SetJointValue | Advanced setter for Value.
Top
See Also

Reference

IJoint Interface
VisualComponents.Create3D Namespace


IJoint.SetJointValue Method

IJointSetJointValue Method

Advanced setter for Value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetJointValue(
    double value,
    bool lockTarget
)
void SetJointValue(
    double value,
    bool lockTarget
)

Parameters

value
Type: SystemDouble
New joint value
lockTarget
Type: SystemBoolean
Indicates that robot's ToolCenterPoint should remain stationary
See Also

Reference

IJoint Interface
VisualComponents.Create3D Namespace


IJoint Events

The IJoint type exposes the following members.

Events
 | Name | Description
Public event | ValueChanged | Event that is raised on every Value change.
Top
See Also

Reference

IJoint Interface
VisualComponents.Create3D Namespace


IJoint.ValueChanged Event

IJointValueChanged Event

Event that is raised on every Value change.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> ValueChanged
 event EventHandler<EventArgs^>^ ValueChanged {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

IJoint Interface
VisualComponents.Create3D Namespace


IJointMotionStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IJointMotionStatement : IPositionStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement>, ICloneable,
    IInterpolatable, IPositionFrameContainer
public interface class IJointMotionStatement : IPositionStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement^>, ICloneable,
    IInterpolatable, IPositionFrameContainer

The IJointMotionStatement type exposes the following members.

Properties
 | Name | Description
Public property | AccuracyMethod | Gets or sets the zone of accuracy type to use for the target, for example distance, time or velocity.
Public property | AccuracyValue | Gets or sets the limit used in AccuracyMethod.
Public property | ApiType | (Inherited from IApiType.)
Public property | Base | Gets or sets the robot base for which the positions in this IPositionStatement are attached to. (Inherited from IPositionStatement.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Configuration | Gets or sets robot's joint/arm configuration index at the target position.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | CycleTime | Gets or sets the total elapsed time for executing motion statement, which may scale speed and acceleration of joints. If zero, this property is ignored.
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | ExternalJointValues | Gets external joint values.
Public property | ExternalTcp | Gets or sets external TCP mode. (Inherited from IPositionStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | JointForce | Gets or sets the percentage of joint acceleration and deceleration values to use in statement.
Public property | JointSpeed | Gets or sets the maximum speed for joints driven by robot controller as a percentage of nominal joint speed.
Public property | JointValues | Gets all joint values.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Positions | Gets all the positions in this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | Target | Movement target in local coordinates.
Public property | Tool | Gets or sets the robot tool (Inherited from IPositionStatement.)
Top
Methods
 | Name | Description
Public method | AddPositionFromProgram | Adds an existing IPositionFrame from IProgram to this IPositionStatement. (Inherited from IPositionStatement.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ClearPositions | Clears all IPositionFrame instances from this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreatePosition | Creates a new IPositionFrame instance and adds it to this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeletePosition | Deletes the given IPositionFrame from this IPositionFrameContainer and deletes it (see remarks). (Inherited from IPositionFrameContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | ExecuteImmediatePosition | Moves the robot to the given position. See also: IStatement.ExecuteImmediate(). (Inherited from IPositionStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | HighlightAll | Highlights all the positions in this IPositionStatement. (Inherited from IPositionStatement.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | ReadIn | Fill statement values from controller.
Public method | ReadIn(IPositionFrame) | Reads in the current state of from the associated instance of IServoController. (Inherited from IPositionStatement.)
Public method | SetExternalJoints | Sets external joint values.
Public method | SetExternalTcp | Gets or sets external TCP mode by keeping relative frame positions. (Inherited from IPositionStatement.)
Public method | SetJoints | Sets all joint values.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PositionAdded | Occurs when a new instance of IPositionFrame has been added to this instance of IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public event | PositionRemoving | Occurs when an instance of IPositionFrame is being removed from this instance of IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public event | PositionTransformationChanged | Occurs when transformation of an instance of IPositionFrame in this instance of IPositionStatement changes. (Inherited from IPositionStatement.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IJointMotionStatement Properties

The IJointMotionStatement type exposes the following members.

Properties
 | Name | Description
Public property | AccuracyMethod | Gets or sets the zone of accuracy type to use for the target, for example distance, time or velocity.
Public property | AccuracyValue | Gets or sets the limit used in AccuracyMethod.
Public property | ApiType | (Inherited from IApiType.)
Public property | Base | Gets or sets the robot base for which the positions in this IPositionStatement are attached to. (Inherited from IPositionStatement.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Configuration | Gets or sets robot's joint/arm configuration index at the target position.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | CycleTime | Gets or sets the total elapsed time for executing motion statement, which may scale speed and acceleration of joints. If zero, this property is ignored.
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | ExternalJointValues | Gets external joint values.
Public property | ExternalTcp | Gets or sets external TCP mode. (Inherited from IPositionStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | JointForce | Gets or sets the percentage of joint acceleration and deceleration values to use in statement.
Public property | JointSpeed | Gets or sets the maximum speed for joints driven by robot controller as a percentage of nominal joint speed.
Public property | JointValues | Gets all joint values.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Positions | Gets all the positions in this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | Target | Movement target in local coordinates.
Public property | Tool | Gets or sets the robot tool (Inherited from IPositionStatement.)
Top
See Also

Reference

IJointMotionStatement Interface
VisualComponents.Create3D Namespace


IJointMotionStatement.AccuracyMethod Property

IJointMotionStatementAccuracyMethod Property

Gets or sets the zone of accuracy type to use for the target, for example distance, time or velocity.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
AccuracyMethod AccuracyMethod { get; set; }
property AccuracyMethod AccuracyMethod {
    AccuracyMethod get ();
    void set (AccuracyMethod value);
}

Property Value

Type: AccuracyMethod
See Also

Reference

IJointMotionStatement Interface
VisualComponents.Create3D Namespace


IJointMotionStatement.AccuracyValue Property

IJointMotionStatementAccuracyValue Property

Gets or sets the limit used in AccuracyMethod.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double AccuracyValue { get; set; }
property double AccuracyValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IJointMotionStatement Interface
VisualComponents.Create3D Namespace


IJointMotionStatement.Configuration Property

IJointMotionStatementConfiguration Property

Gets or sets robot's joint/arm configuration index at the target position.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int Configuration { get; set; }
property int Configuration {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IJointMotionStatement Interface
VisualComponents.Create3D Namespace


IJointMotionStatement.CycleTime Property

IJointMotionStatementCycleTime Property

Gets or sets the total elapsed time for executing motion statement, which may scale speed and acceleration of joints. If zero, this property is ignored.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double CycleTime { get; set; }
property double CycleTime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IJointMotionStatement Interface
VisualComponents.Create3D Namespace


IJointMotionStatement.ExternalJointValues Property

IJointMotionStatementExternalJointValues Property

Gets external joint values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<double> ExternalJointValues { get; }
property ReadOnlyCollection<double>^ ExternalJointValues {
    ReadOnlyCollection<double>^ get ();
}

Property Value

Type: ReadOnlyCollectionDouble
See Also

Reference

IJointMotionStatement Interface
VisualComponents.Create3D Namespace


IJointMotionStatement.JointForce Property

IJointMotionStatementJointForce Property

Gets or sets the percentage of joint acceleration and deceleration values to use in statement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double JointForce { get; set; }
property double JointForce {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IJointMotionStatement Interface
VisualComponents.Create3D Namespace


IJointMotionStatement.JointSpeed Property

IJointMotionStatementJointSpeed Property

Gets or sets the maximum speed for joints driven by robot controller as a percentage of nominal joint speed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double JointSpeed { get; set; }
property double JointSpeed {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IJointMotionStatement Interface
VisualComponents.Create3D Namespace


IJointMotionStatement.JointValues Property

IJointMotionStatementJointValues Property

Gets all joint values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<double> JointValues { get; }
property ReadOnlyCollection<double>^ JointValues {
    ReadOnlyCollection<double>^ get ();
}

Property Value

Type: ReadOnlyCollectionDouble
See Also

Reference

IJointMotionStatement Interface
VisualComponents.Create3D Namespace


IJointMotionStatement.Target Property

IJointMotionStatementTarget Property

Movement target in local coordinates.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix Target { get; set; }
property Matrix Target {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

IJointMotionStatement Interface
VisualComponents.Create3D Namespace


IJointMotionStatement Methods

The IJointMotionStatement type exposes the following members.

Methods
 | Name | Description
Public method | AddPositionFromProgram | Adds an existing IPositionFrame from IProgram to this IPositionStatement. (Inherited from IPositionStatement.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ClearPositions | Clears all IPositionFrame instances from this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreatePosition | Creates a new IPositionFrame instance and adds it to this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeletePosition | Deletes the given IPositionFrame from this IPositionFrameContainer and deletes it (see remarks). (Inherited from IPositionFrameContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | ExecuteImmediatePosition | Moves the robot to the given position. See also: IStatement.ExecuteImmediate(). (Inherited from IPositionStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | HighlightAll | Highlights all the positions in this IPositionStatement. (Inherited from IPositionStatement.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | ReadIn | Fill statement values from controller.
Public method | ReadIn(IPositionFrame) | Reads in the current state of from the associated instance of IServoController. (Inherited from IPositionStatement.)
Public method | SetExternalJoints | Sets external joint values.
Public method | SetExternalTcp | Gets or sets external TCP mode by keeping relative frame positions. (Inherited from IPositionStatement.)
Public method | SetJoints | Sets all joint values.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IJointMotionStatement Interface
VisualComponents.Create3D Namespace


IJointMotionStatement.ReadIn Method

IJointMotionStatementReadIn Method

Overload List
 | Name | Description
Public method | ReadIn | Fill statement values from controller.
Public method | ReadIn(IPositionFrame) | Reads in the current state of from the associated instance of IServoController. (Inherited from IPositionStatement.)
Top
See Also

Reference

IJointMotionStatement Interface
VisualComponents.Create3D Namespace


IJointMotionStatement.ReadIn Method

IJointMotionStatementReadIn Method

Fill statement values from controller.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ReadIn()
void ReadIn()
See Also

Reference

IJointMotionStatement Interface
ReadIn Overload
VisualComponents.Create3D Namespace


IJointMotionStatement.SetExternalJoints Method

IJointMotionStatementSetExternalJoints Method

Sets external joint values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetExternalJoints(
    IEnumerable<double> jointValues
)
void SetExternalJoints(
    IEnumerable<double>^ jointValues
)

Parameters

jointValues
Type: System.Collections.GenericIEnumerableDouble
See Also

Reference

IJointMotionStatement Interface
VisualComponents.Create3D Namespace


IJointMotionStatement.SetJoints Method

IJointMotionStatementSetJoints Method

Sets all joint values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetJoints(
    IEnumerable<double> jointValues
)
void SetJoints(
    IEnumerable<double>^ jointValues
)

Parameters

jointValues
Type: System.Collections.GenericIEnumerableDouble
See Also

Reference

IJointMotionStatement Interface
VisualComponents.Create3D Namespace


IJointMotionStatement Events

The IJointMotionStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PositionAdded | Occurs when a new instance of IPositionFrame has been added to this instance of IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public event | PositionRemoving | Occurs when an instance of IPositionFrame is being removed from this instance of IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public event | PositionTransformationChanged | Occurs when transformation of an instance of IPositionFrame in this instance of IPositionStatement changes. (Inherited from IPositionStatement.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IJointMotionStatement Interface
VisualComponents.Create3D Namespace


ILayerControl Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ILayerControl
public interface class ILayerControl

The ILayerControl type exposes the following members.

Properties
 | Name | Description
Public property | FrameFeatureLayerVisibility |
Public property | RobotBaseFramesLayerVisibility |
Public property | RobotPositionAxisXVisibility |
Public property | RobotPositionAxisYVisibility |
Public property | RobotPositionAxisZVisibility |
Public property | RobotPositionCenterVisibility |
Public property | RobotPositionFramesLayerVisibility |
Public property | RobotPositionLabelVisibility |
Public property | RobotToolFramesLayerVisibility |
Public property | RobotTraceVisibility |
Public property | RobotWorldFramesLayerVisibility |
Public property | RootFrameLayerVisibility |
Public property | SchemaFramesLayerVisibility |
Public property | SelectedFrameFeatureLayerVisibility |
Public property | SelectedRobotBaseFramesLayerVisibility |
Public property | SelectedRobotPositionFramesLayerVisibility |
Public property | SelectedRobotToolFramesLayerVisibility |
Public property | SelectedRobotWorldFramesLayerVisibility |
Public property | SelectedRootFrameLayerVisibility |
Public property | WorldOriginLayerVisibility |
Top
Events
 | Name | Description
Public event | LayerPropertyChanged |
Top
See Also

Reference

VisualComponents.Create3D Namespace


ILayerControl Properties

The ILayerControl type exposes the following members.

Properties
 | Name | Description
Public property | FrameFeatureLayerVisibility |
Public property | RobotBaseFramesLayerVisibility |
Public property | RobotPositionAxisXVisibility |
Public property | RobotPositionAxisYVisibility |
Public property | RobotPositionAxisZVisibility |
Public property | RobotPositionCenterVisibility |
Public property | RobotPositionFramesLayerVisibility |
Public property | RobotPositionLabelVisibility |
Public property | RobotToolFramesLayerVisibility |
Public property | RobotTraceVisibility |
Public property | RobotWorldFramesLayerVisibility |
Public property | RootFrameLayerVisibility |
Public property | SchemaFramesLayerVisibility |
Public property | SelectedFrameFeatureLayerVisibility |
Public property | SelectedRobotBaseFramesLayerVisibility |
Public property | SelectedRobotPositionFramesLayerVisibility |
Public property | SelectedRobotToolFramesLayerVisibility |
Public property | SelectedRobotWorldFramesLayerVisibility |
Public property | SelectedRootFrameLayerVisibility |
Public property | WorldOriginLayerVisibility |
Top
See Also

Reference

ILayerControl Interface
VisualComponents.Create3D Namespace


ILayerControl.FrameFeatureLayerVisibility Property

ILayerControlFrameFeatureLayerVisibility Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool FrameFeatureLayerVisibility { get; set; }
property bool FrameFeatureLayerVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ILayerControl Interface
VisualComponents.Create3D Namespace


ILayerControl.RobotBaseFramesLayerVisibility Property

ILayerControlRobotBaseFramesLayerVisibility Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool RobotBaseFramesLayerVisibility { get; set; }
property bool RobotBaseFramesLayerVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ILayerControl Interface
VisualComponents.Create3D Namespace


ILayerControl.RobotPositionAxisXVisibility Property

ILayerControlRobotPositionAxisXVisibility Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool RobotPositionAxisXVisibility { get; set; }
property bool RobotPositionAxisXVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ILayerControl Interface
VisualComponents.Create3D Namespace


ILayerControl.RobotPositionAxisYVisibility Property

ILayerControlRobotPositionAxisYVisibility Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool RobotPositionAxisYVisibility { get; set; }
property bool RobotPositionAxisYVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ILayerControl Interface
VisualComponents.Create3D Namespace


ILayerControl.RobotPositionAxisZVisibility Property

ILayerControlRobotPositionAxisZVisibility Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool RobotPositionAxisZVisibility { get; set; }
property bool RobotPositionAxisZVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ILayerControl Interface
VisualComponents.Create3D Namespace


ILayerControl.RobotPositionCenterVisibility Property

ILayerControlRobotPositionCenterVisibility Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool RobotPositionCenterVisibility { get; set; }
property bool RobotPositionCenterVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ILayerControl Interface
VisualComponents.Create3D Namespace


ILayerControl.RobotPositionFramesLayerVisibility Property

ILayerControlRobotPositionFramesLayerVisibility Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool RobotPositionFramesLayerVisibility { get; set; }
property bool RobotPositionFramesLayerVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ILayerControl Interface
VisualComponents.Create3D Namespace


ILayerControl.RobotPositionLabelVisibility Property

ILayerControlRobotPositionLabelVisibility Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool RobotPositionLabelVisibility { get; set; }
property bool RobotPositionLabelVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ILayerControl Interface
VisualComponents.Create3D Namespace


ILayerControl.RobotToolFramesLayerVisibility Property

ILayerControlRobotToolFramesLayerVisibility Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool RobotToolFramesLayerVisibility { get; set; }
property bool RobotToolFramesLayerVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ILayerControl Interface
VisualComponents.Create3D Namespace


ILayerControl.RobotTraceVisibility Property

ILayerControlRobotTraceVisibility Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool RobotTraceVisibility { get; set; }
property bool RobotTraceVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ILayerControl Interface
VisualComponents.Create3D Namespace


ILayerControl.RobotWorldFramesLayerVisibility Property

ILayerControlRobotWorldFramesLayerVisibility Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool RobotWorldFramesLayerVisibility { get; set; }
property bool RobotWorldFramesLayerVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ILayerControl Interface
VisualComponents.Create3D Namespace


ILayerControl.RootFrameLayerVisibility Property

ILayerControlRootFrameLayerVisibility Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool RootFrameLayerVisibility { get; set; }
property bool RootFrameLayerVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ILayerControl Interface
VisualComponents.Create3D Namespace


ILayerControl.SchemaFramesLayerVisibility Property

ILayerControlSchemaFramesLayerVisibility Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SchemaFramesLayerVisibility { get; set; }
property bool SchemaFramesLayerVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ILayerControl Interface
VisualComponents.Create3D Namespace


ILayerControl.SelectedFrameFeatureLayerVisibility Property

ILayerControlSelectedFrameFeatureLayerVisibility Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SelectedFrameFeatureLayerVisibility { get; set; }
property bool SelectedFrameFeatureLayerVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ILayerControl Interface
VisualComponents.Create3D Namespace


ILayerControl.SelectedRobotBaseFramesLayerVisibility Property

ILayerControlSelectedRobotBaseFramesLayerVisibility Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SelectedRobotBaseFramesLayerVisibility { get; set; }
property bool SelectedRobotBaseFramesLayerVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ILayerControl Interface
VisualComponents.Create3D Namespace


ILayerControl.SelectedRobotPositionFramesLayerVisibility Property

ILayerControlSelectedRobotPositionFramesLayerVisibility Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SelectedRobotPositionFramesLayerVisibility { get; set; }
property bool SelectedRobotPositionFramesLayerVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ILayerControl Interface
VisualComponents.Create3D Namespace


ILayerControl.SelectedRobotToolFramesLayerVisibility Property

ILayerControlSelectedRobotToolFramesLayerVisibility Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SelectedRobotToolFramesLayerVisibility { get; set; }
property bool SelectedRobotToolFramesLayerVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ILayerControl Interface
VisualComponents.Create3D Namespace


ILayerControl.SelectedRobotWorldFramesLayerVisibility Property

ILayerControlSelectedRobotWorldFramesLayerVisibility Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SelectedRobotWorldFramesLayerVisibility { get; set; }
property bool SelectedRobotWorldFramesLayerVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ILayerControl Interface
VisualComponents.Create3D Namespace


ILayerControl.SelectedRootFrameLayerVisibility Property

ILayerControlSelectedRootFrameLayerVisibility Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SelectedRootFrameLayerVisibility { get; set; }
property bool SelectedRootFrameLayerVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ILayerControl Interface
VisualComponents.Create3D Namespace


ILayerControl.WorldOriginLayerVisibility Property

ILayerControlWorldOriginLayerVisibility Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool WorldOriginLayerVisibility { get; set; }
property bool WorldOriginLayerVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ILayerControl Interface
VisualComponents.Create3D Namespace


ILayerControl Events

The ILayerControl type exposes the following members.

Events
 | Name | Description
Public event | LayerPropertyChanged |
Top
See Also

Reference

ILayerControl Interface
VisualComponents.Create3D Namespace


ILayerControl.LayerPropertyChanged Event

ILayerControlLayerPropertyChanged Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<LayerPropertyChangedEventArgs> LayerPropertyChanged
 event EventHandler<LayerPropertyChangedEventArgs^>^ LayerPropertyChanged {
    void add (EventHandler<LayerPropertyChangedEventArgs^>^ value);
    void remove (EventHandler<LayerPropertyChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerLayerPropertyChangedEventArgs
See Also

Reference

ILayerControl Interface
VisualComponents.Create3D Namespace


ILayoutItem Interface

Base interface for layout items

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ILayoutItem : IWrapper,
    IDisposable, INamed, IPropertyContainer, IBatchModeObject
public interface class ILayoutItem : IWrapper,
    IDisposable, INamed, IPropertyContainer, IBatchModeObject

The ILayoutItem type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsPersistent | Defines if the ILayoutItem is stored with the layout.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ILayoutItem Properties

The ILayoutItem type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsPersistent | Defines if the ILayoutItem is stored with the layout.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ILayoutItem Interface
VisualComponents.Create3D Namespace


ILayoutItem.IsPersistent Property

ILayoutItemIsPersistent Property

Defines if the ILayoutItem is stored with the layout.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsPersistent { get; set; }
property bool IsPersistent {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ILayoutItem Interface
VisualComponents.Create3D Namespace


ILayoutItem Methods

The ILayoutItem type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ILayoutItem Interface
VisualComponents.Create3D Namespace


ILayoutItem Events

The ILayoutItem type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ILayoutItem Interface
VisualComponents.Create3D Namespace


ILayoutItemGroup Interface

Logical group of ILayoutItem.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ILayoutItemGroup : INamed
public interface class ILayoutItemGroup : INamed

The ILayoutItemGroup type exposes the following members.

Properties
 | Name | Description
Public property | Items | Components found via the root group of this group.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Top
Methods
 | Name | Description
Public method | AddItem | Add new ILayoutItem to the group.
Public method | RemoveItem | Remove a ILayoutItem from the group.
Public method | Ungroup | Performs ungroup to this group.
Top
See Also

Reference

VisualComponents.Create3D Namespace


ILayoutItemGroup Properties

The ILayoutItemGroup type exposes the following members.

Properties
 | Name | Description
Public property | Items | Components found via the root group of this group.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Top
See Also

Reference

ILayoutItemGroup Interface
VisualComponents.Create3D Namespace


ILayoutItemGroup.Items Property

ILayoutItemGroupItems Property

Components found via the root group of this group.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ILayoutItem> Items { get; }
property ReadOnlyCollection<ILayoutItem^>^ Items {
    ReadOnlyCollection<ILayoutItem^>^ get ();
}

Property Value

Type: ReadOnlyCollectionILayoutItem
See Also

Reference

ILayoutItemGroup Interface
VisualComponents.Create3D Namespace


ILayoutItemGroup Methods

The ILayoutItemGroup type exposes the following members.

Methods
 | Name | Description
Public method | AddItem | Add new ILayoutItem to the group.
Public method | RemoveItem | Remove a ILayoutItem from the group.
Public method | Ungroup | Performs ungroup to this group.
Top
See Also

Reference

ILayoutItemGroup Interface
VisualComponents.Create3D Namespace


ILayoutItemGroup.AddItem Method

ILayoutItemGroupAddItem Method

Add new ILayoutItem to the group.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddItem(
    IGroupableItem itemToAdd
)
void AddItem(
    IGroupableItem^ itemToAdd
)

Parameters

itemToAdd
Type: VisualComponents.Create3DIGroupableItem
layout item to be added.
See Also

Reference

ILayoutItemGroup Interface
VisualComponents.Create3D Namespace


ILayoutItemGroup.RemoveItem Method

ILayoutItemGroupRemoveItem Method

Remove a ILayoutItem from the group.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RemoveItem(
    IGroupableItem itemToAdd
)
void RemoveItem(
    IGroupableItem^ itemToAdd
)

Parameters

itemToAdd
Type: VisualComponents.Create3DIGroupableItem
layout item to be removed.
See Also

Reference

ILayoutItemGroup Interface
VisualComponents.Create3D Namespace


ILayoutItemGroup.Ungroup Method

ILayoutItemGroupUngroup Method

Performs ungroup to this group.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Ungroup()
void Ungroup()
See Also

Reference

ILayoutItemGroup Interface
VisualComponents.Create3D Namespace


ILayoutPackFolder Interface

Interface for layout item that contains a pack folder instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ILayoutPackFolder : ILayoutItem,
    IWrapper, IDisposable, INamed, IPropertyContainer, IBatchModeObject
public interface class ILayoutPackFolder : ILayoutItem,
    IWrapper, IDisposable, INamed, IPropertyContainer, IBatchModeObject

The ILayoutPackFolder type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Class | Pack folder class string
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsPersistent | Defines if the ILayoutItem is stored with the layout. (Inherited from ILayoutItem.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | PackFolder | Layout item pack folder object.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ILayoutPackFolder Properties

The ILayoutPackFolder type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Class | Pack folder class string
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsPersistent | Defines if the ILayoutItem is stored with the layout. (Inherited from ILayoutItem.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | PackFolder | Layout item pack folder object.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ILayoutPackFolder Interface
VisualComponents.Create3D Namespace


ILayoutPackFolder.Class Property

ILayoutPackFolderClass Property

Pack folder class string

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Class { get; set; }
property String^ Class {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks

The pack folder class string determines what happens when you load another layout with a pack folder layout item with the same name. If both classes are empty, or they do not match, the newly loaded layout item is renamed. If the classes match, the newly loaded layout item is discarded.

See Also

Reference

ILayoutPackFolder Interface
VisualComponents.Create3D Namespace


ILayoutPackFolder.PackFolder Property

ILayoutPackFolderPackFolder Property

Layout item pack folder object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPackFolder PackFolder { get; }
property IPackFolder^ PackFolder {
    IPackFolder^ get ();
}

Property Value

Type: IPackFolder
See Also

Reference

ILayoutPackFolder Interface
VisualComponents.Create3D Namespace


ILayoutPackFolder Methods

The ILayoutPackFolder type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ILayoutPackFolder Interface
VisualComponents.Create3D Namespace


ILayoutPackFolder Events

The ILayoutPackFolder type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ILayoutPackFolder Interface
VisualComponents.Create3D Namespace


ILayoutPropertyList Interface

Modifiable property list object that is saved with a layout.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ILayoutPropertyList : ILayoutItem,
    IWrapper, IDisposable, INamed, IPropertyContainer, IBatchModeObject
public interface class ILayoutPropertyList : ILayoutItem,
    IWrapper, IDisposable, INamed, IPropertyContainer, IBatchModeObject

The ILayoutPropertyList type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Class | Gets or sets the property list class name. Class string determines what happens when the layout is imported into an existing layout. If Class is an empty string, the property list is added to the existing layout. If the layout already has another layout item with the same name, the name of the new item is modified to avoid a name collision. If Class is not empty, and the existing layout has a layout property list with the same Class string, then the property values of the existing layout item are updated with the values from the layout being loaded. In this case, no new layout item is created. The default value for the Class property is an empty string.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsPersistent | Defines if the ILayoutItem is stored with the layout. (Inherited from ILayoutItem.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ILayoutPropertyList Properties

The ILayoutPropertyList type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Class | Gets or sets the property list class name. Class string determines what happens when the layout is imported into an existing layout. If Class is an empty string, the property list is added to the existing layout. If the layout already has another layout item with the same name, the name of the new item is modified to avoid a name collision. If Class is not empty, and the existing layout has a layout property list with the same Class string, then the property values of the existing layout item are updated with the values from the layout being loaded. In this case, no new layout item is created. The default value for the Class property is an empty string.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsPersistent | Defines if the ILayoutItem is stored with the layout. (Inherited from ILayoutItem.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ILayoutPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutPropertyList.Class Property

ILayoutPropertyListClass Property

Gets or sets the property list class name. Class string determines what happens when the layout is imported into an existing layout.

If Class is an empty string, the property list is added to the existing layout. If the layout already has another layout item with the same name, the name of the new item is modified to avoid a name collision.

If Class is not empty, and the existing layout has a layout property list with the same Class string, then the property values of the existing layout item are updated with the values from the layout being loaded. In this case, no new layout item is created.

The default value for the Class property is an empty string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Class { get; set; }
property String^ Class {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ILayoutPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutPropertyList Methods

The ILayoutPropertyList type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ILayoutPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutPropertyList Events

The ILayoutPropertyList type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ILayoutPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList Interface

Modifiable property list object that is saved with a layout. Designed for handling large amounts of data.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ILayoutSchemaPropertyList : ILayoutItem,
    IWrapper, IDisposable, INamed, IPropertyContainer, IBatchModeObject,
    IVisualObject
public interface class ILayoutSchemaPropertyList : ILayoutItem,
    IWrapper, IDisposable, INamed, IPropertyContainer, IBatchModeObject,
    IVisualObject

The ILayoutSchemaPropertyList type exposes the following members.

Properties
 | Name | Description
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | DataCount | Gets the number of data entries reserved for this schema property list.
Public property | FrameColorSchemaIndex | Gets or sets the index of a integer schema property that defines the color of the frame.
Public property | FrameDataSchemaIndex | Gets or sets the index of a matrix schema property to be visualized as a frame in 3D world.
Public property | FrameNameColorSchemaIndex | Gets or sets the index of a integer schema property that defines the color of the frame name.
Public property | FrameNameSchemaIndex | Gets or sets the index of a string schema property that defines the names of frame data entries.
Public property | FrameNameSizeSchemaIndex | Gets or sets the index of a integer schema property that defines the size of the frame. Must point to real property. Frame name label size is also configurable in the backstage.
Public property | FrameNameVisibleSchemaIndex | Gets or sets the index of a boolean schema property that defines the visibility of frame name data entries.
Public property | FrameVisibleSchemaIndex | Gets or sets the index of a boolean schema property that defines the visibility of frame data entries.
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsPersistent | Defines if the ILayoutItem is stored with the layout. (Inherited from ILayoutItem.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | LineColorSchemaIndex | Gets or sets the index of a vector property that defines the color of line display.
Public property | LineDisplaySchemaIndex | Gets or sets the index of a vector/matrix property that defines the position of line to be rendered. Typically this uses the same value as FrameDataSchemaIndex, allowing you to draw connecting lines between each frame.
Public property | LineWidthSchemaIndex | Gets or sets the index of a double property that defines the width of line display.\n Note that setting the width to a value other than 1 may incur a performance penalty.
Public property | LineVisibleSchemaIndex | Gets or sets the index of a boolean property that defines the visibility of line display.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Gets or sets the instance of ISimNode for which this schema property list is attached to.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | SchemaCount | Gets the number of schema properties in this schema property list.
Public property | SchemaProperties | Gets property container holding all the schema properties of this schema property list.
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IVisualObject.)
Public property | TransformationInWorld | Gets or sets the world transformation matrix (Inherited from IVisualObject.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Empties the schema, thereby removing all schema properties and setting the data count to zero.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | CreateSchemaProperty | Adds a new schema property of a given type and name to this schema property list.
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteSchemaProperty(Int32) | Deletes the schema property defined by the given index.
Public method | DeleteSchemaProperty(IProperty) | Deletes the given schema property.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetAllFrames | Gets an instance of ISchemaFrame wrapping all frames in this ILayoutSchemaPropertyList.
Public method | GetAllFrames(ISchemaFrame) | Gets an instance of ISchemaFrame wrapping all frames in this ILayoutSchemaPropertyList.
Public method | GetFrame(Int32) | Gets the instance of ISchemaFrame wrapping the frame at the given data index in this ILayoutSchemaPropertyList.
Public method | GetFrame(Int32, ISchemaFrame) | Gets the instance of ISchemaFrame wrapping the frame at the given data index in this ILayoutSchemaPropertyList.
Public method | GetFrames(IEnumerableInt32) | Gets the instance of ISchemaFrame wrapping the frames at given indexes in this ILayoutSchemaPropertyList. Uses the first given index as a pivot frame.
Public method | GetFrames(Int32, Int32) | Gets the instance of ISchemaFrame wrapping the frames at given indexes in this ILayoutSchemaPropertyList.
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetSchemaValue | Gets the value of schema property at the given data entry.
Public method | GetSchemaValues(Int32) | Gets the values of all schema properties at the given data entry.
Public method | GetSchemaValues(Int32, IListInt32) | Gets the values of multiple schema properties at the given data entry.
Public method | InsertSchemaEntries | Adds new data entries at the given index
Public method | InsertSchemaEntry(Int32) | Adds a new data entry at the given index.
Public method | InsertSchemaEntry(Int32, IListObject) | Obsolete. Adds a new data entry at the given index with given schema property values.
Public method | InsertSchemaValues | Adds a new data entry at the given index with given schema property values.
Public method | RemoveSchemaEntries | Removes the multiple data entries starting from the given data entry.
Public method | RemoveSchemaEntry | Removes the given data entry from this schema property list.
Public method | Reserve | Allocates the size of the schema to support the given number of data entries.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetSchemaValue | Sets the value of the schema property.
Public method | SetSchemaValues | Sets the value of multiple schema properties.
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | Update | Updates the visualization of all the data entries in this schema property list. This should be called after modifying schema properties that affect the schema visualization.
Public method | Update(Int32) | Updates the visualization of the given data entry. This should be called after modifying schema properties that affect the schema visualization.
Public method | UpdateLevelOfDetail | Updates level of detail visualization. This method is intended to be used internally only.
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | RecordAppended | Occurs when a record (row) has been appended to a schema.
Public event | RecordInserted | Occurs when a record (row) has been inserted to a schema.
Public event | RecordRemoved | Occurs when a record (row) has been removed from a schema.
Public event | SchemaValueChanged | Occurs when schema value has been changed.
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList Properties

The ILayoutSchemaPropertyList type exposes the following members.

Properties
 | Name | Description
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | DataCount | Gets the number of data entries reserved for this schema property list.
Public property | FrameColorSchemaIndex | Gets or sets the index of a integer schema property that defines the color of the frame.
Public property | FrameDataSchemaIndex | Gets or sets the index of a matrix schema property to be visualized as a frame in 3D world.
Public property | FrameNameColorSchemaIndex | Gets or sets the index of a integer schema property that defines the color of the frame name.
Public property | FrameNameSchemaIndex | Gets or sets the index of a string schema property that defines the names of frame data entries.
Public property | FrameNameSizeSchemaIndex | Gets or sets the index of a integer schema property that defines the size of the frame. Must point to real property. Frame name label size is also configurable in the backstage.
Public property | FrameNameVisibleSchemaIndex | Gets or sets the index of a boolean schema property that defines the visibility of frame name data entries.
Public property | FrameVisibleSchemaIndex | Gets or sets the index of a boolean schema property that defines the visibility of frame data entries.
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsPersistent | Defines if the ILayoutItem is stored with the layout. (Inherited from ILayoutItem.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | LineColorSchemaIndex | Gets or sets the index of a vector property that defines the color of line display.
Public property | LineDisplaySchemaIndex | Gets or sets the index of a vector/matrix property that defines the position of line to be rendered. Typically this uses the same value as FrameDataSchemaIndex, allowing you to draw connecting lines between each frame.
Public property | LineWidthSchemaIndex | Gets or sets the index of a double property that defines the width of line display.\n Note that setting the width to a value other than 1 may incur a performance penalty.
Public property | LineVisibleSchemaIndex | Gets or sets the index of a boolean property that defines the visibility of line display.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Gets or sets the instance of ISimNode for which this schema property list is attached to.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | SchemaCount | Gets the number of schema properties in this schema property list.
Public property | SchemaProperties | Gets property container holding all the schema properties of this schema property list.
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IVisualObject.)
Public property | TransformationInWorld | Gets or sets the world transformation matrix (Inherited from IVisualObject.)
Top
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.DataCount Property

ILayoutSchemaPropertyListDataCount Property

Gets the number of data entries reserved for this schema property list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int DataCount { get; }
property int DataCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.FrameColorSchemaIndex Property

ILayoutSchemaPropertyListFrameColorSchemaIndex Property

Gets or sets the index of a integer schema property that defines the color of the frame.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int FrameColorSchemaIndex { get; set; }
property int FrameColorSchemaIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.FrameDataSchemaIndex Property

ILayoutSchemaPropertyListFrameDataSchemaIndex Property

Gets or sets the index of a matrix schema property to be visualized as a frame in 3D world.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int FrameDataSchemaIndex { get; set; }
property int FrameDataSchemaIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.FrameNameColorSchemaIndex Property

ILayoutSchemaPropertyListFrameNameColorSchemaIndex Property

Gets or sets the index of a integer schema property that defines the color of the frame name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int FrameNameColorSchemaIndex { get; set; }
property int FrameNameColorSchemaIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.FrameNameSchemaIndex Property

ILayoutSchemaPropertyListFrameNameSchemaIndex Property

Gets or sets the index of a string schema property that defines the names of frame data entries.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int FrameNameSchemaIndex { get; set; }
property int FrameNameSchemaIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.FrameNameSizeSchemaIndex Property

ILayoutSchemaPropertyListFrameNameSizeSchemaIndex Property

Gets or sets the index of a integer schema property that defines the size of the frame. Must point to real property. Frame name label size is also configurable in the backstage.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int FrameNameSizeSchemaIndex { get; set; }
property int FrameNameSizeSchemaIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.FrameNameVisibleSchemaIndex Property

ILayoutSchemaPropertyListFrameNameVisibleSchemaIndex Property

Gets or sets the index of a boolean schema property that defines the visibility of frame name data entries.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int FrameNameVisibleSchemaIndex { get; set; }
property int FrameNameVisibleSchemaIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.FrameVisibleSchemaIndex Property

ILayoutSchemaPropertyListFrameVisibleSchemaIndex Property

Gets or sets the index of a boolean schema property that defines the visibility of frame data entries.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int FrameVisibleSchemaIndex { get; set; }
property int FrameVisibleSchemaIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.LineColorSchemaIndex Property

ILayoutSchemaPropertyListLineColorSchemaIndex Property

Gets or sets the index of a vector property that defines the color of line display.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int LineColorSchemaIndex { get; set; }
property int LineColorSchemaIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.LineDisplaySchemaIndex Property

ILayoutSchemaPropertyListLineDisplaySchemaIndex Property

Gets or sets the index of a vector/matrix property that defines the position of line to be rendered. Typically this uses the same value as FrameDataSchemaIndex, allowing you to draw connecting lines between each frame.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int LineDisplaySchemaIndex { get; set; }
property int LineDisplaySchemaIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.LineWidthSchemaIndex Property

ILayoutSchemaPropertyListLineWidthSchemaIndex Property

Gets or sets the index of a double property that defines the width of line display.\n

Note that setting the width to a value other than 1 may incur a performance penalty.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int LineWidthSchemaIndex { get; set; }
property int LineWidthSchemaIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.LineVisibleSchemaIndex Property

ILayoutSchemaPropertyListLineVisibleSchemaIndex Property

Gets or sets the index of a boolean property that defines the visibility of line display.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int LineVisibleSchemaIndex { get; set; }
property int LineVisibleSchemaIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.Node Property

ILayoutSchemaPropertyListNode Property

Gets or sets the instance of ISimNode for which this schema property list is attached to.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode Node { get; set; }
property ISimNode^ Node {
    ISimNode^ get ();
    void set (ISimNode^ value);
}

Property Value

Type: ISimNode
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.SchemaCount Property

ILayoutSchemaPropertyListSchemaCount Property

Gets the number of schema properties in this schema property list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int SchemaCount { get; }
property int SchemaCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.SchemaProperties Property

ILayoutSchemaPropertyListSchemaProperties Property

Gets property container holding all the schema properties of this schema property list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPropertyContainer SchemaProperties { get; }
property IPropertyContainer^ SchemaProperties {
    IPropertyContainer^ get ();
}

Property Value

Type: IPropertyContainer
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList Methods

The ILayoutSchemaPropertyList type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Empties the schema, thereby removing all schema properties and setting the data count to zero.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | CreateSchemaProperty | Adds a new schema property of a given type and name to this schema property list.
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteSchemaProperty(Int32) | Deletes the schema property defined by the given index.
Public method | DeleteSchemaProperty(IProperty) | Deletes the given schema property.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetAllFrames | Gets an instance of ISchemaFrame wrapping all frames in this ILayoutSchemaPropertyList.
Public method | GetAllFrames(ISchemaFrame) | Gets an instance of ISchemaFrame wrapping all frames in this ILayoutSchemaPropertyList.
Public method | GetFrame(Int32) | Gets the instance of ISchemaFrame wrapping the frame at the given data index in this ILayoutSchemaPropertyList.
Public method | GetFrame(Int32, ISchemaFrame) | Gets the instance of ISchemaFrame wrapping the frame at the given data index in this ILayoutSchemaPropertyList.
Public method | GetFrames(IEnumerableInt32) | Gets the instance of ISchemaFrame wrapping the frames at given indexes in this ILayoutSchemaPropertyList. Uses the first given index as a pivot frame.
Public method | GetFrames(Int32, Int32) | Gets the instance of ISchemaFrame wrapping the frames at given indexes in this ILayoutSchemaPropertyList.
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetSchemaValue | Gets the value of schema property at the given data entry.
Public method | GetSchemaValues(Int32) | Gets the values of all schema properties at the given data entry.
Public method | GetSchemaValues(Int32, IListInt32) | Gets the values of multiple schema properties at the given data entry.
Public method | InsertSchemaEntries | Adds new data entries at the given index
Public method | InsertSchemaEntry(Int32) | Adds a new data entry at the given index.
Public method | InsertSchemaEntry(Int32, IListObject) | Obsolete. Adds a new data entry at the given index with given schema property values.
Public method | InsertSchemaValues | Adds a new data entry at the given index with given schema property values.
Public method | RemoveSchemaEntries | Removes the multiple data entries starting from the given data entry.
Public method | RemoveSchemaEntry | Removes the given data entry from this schema property list.
Public method | Reserve | Allocates the size of the schema to support the given number of data entries.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetSchemaValue | Sets the value of the schema property.
Public method | SetSchemaValues | Sets the value of multiple schema properties.
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | Update | Updates the visualization of all the data entries in this schema property list. This should be called after modifying schema properties that affect the schema visualization.
Public method | Update(Int32) | Updates the visualization of the given data entry. This should be called after modifying schema properties that affect the schema visualization.
Public method | UpdateLevelOfDetail | Updates level of detail visualization. This method is intended to be used internally only.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.Clear Method

ILayoutSchemaPropertyListClear Method

Empties the schema, thereby removing all schema properties and setting the data count to zero.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Clear()
void Clear()
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.CreateSchemaProperty Method

ILayoutSchemaPropertyListCreateSchemaProperty Method

Adds a new schema property of a given type and name to this schema property list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProperty CreateSchemaProperty(
    Type propertyType,
    string propertyName
)
IProperty^ CreateSchemaProperty(
    Type^ propertyType,
    String^ propertyName
)

Parameters

propertyType
Type: SystemType
Type of the property.
propertyName
Type: SystemString
Name of the property.

Return Value

Type: IProperty
The instance of created property.
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.DeleteSchemaProperty Method

ILayoutSchemaPropertyListDeleteSchemaProperty Method

Overload List
 | Name | Description
Public method | DeleteSchemaProperty(Int32) | Deletes the schema property defined by the given index.
Public method | DeleteSchemaProperty(IProperty) | Deletes the given schema property.
Top
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.DeleteSchemaProperty Method (Int32)

ILayoutSchemaPropertyListDeleteSchemaProperty Method (Int32)

Deletes the schema property defined by the given index.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteSchemaProperty(
    int schemaPropertyIndex
)
void DeleteSchemaProperty(
    int schemaPropertyIndex
)

Parameters

schemaPropertyIndex
Type: SystemInt32
Index of the schema property to be deleted.
See Also

Reference

ILayoutSchemaPropertyList Interface
DeleteSchemaProperty Overload
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.DeleteSchemaProperty Method (IProperty)

ILayoutSchemaPropertyListDeleteSchemaProperty Method (IProperty)

Deletes the given schema property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteSchemaProperty(
    IProperty schemaProperty
)
void DeleteSchemaProperty(
    IProperty^ schemaProperty
)

Parameters

schemaProperty
Type: VisualComponents.Create3DIProperty
Property to be deleted.
See Also

Reference

ILayoutSchemaPropertyList Interface
DeleteSchemaProperty Overload
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.GetAllFrames Method

ILayoutSchemaPropertyListGetAllFrames Method

Overload List
 | Name | Description
Public method | GetAllFrames | Gets an instance of ISchemaFrame wrapping all frames in this ILayoutSchemaPropertyList.
Public method | GetAllFrames(ISchemaFrame) | Gets an instance of ISchemaFrame wrapping all frames in this ILayoutSchemaPropertyList.
Top
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.GetAllFrames Method

ILayoutSchemaPropertyListGetAllFrames Method

Gets an instance of ISchemaFrame wrapping all frames in this ILayoutSchemaPropertyList.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISchemaFrame GetAllFrames()
ISchemaFrame^ GetAllFrames()

Return Value

Type: ISchemaFrame
Frame that acts as a wrapper for all the frames in the schema.
See Also

Reference

ILayoutSchemaPropertyList Interface
GetAllFrames Overload
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.GetAllFrames Method (ISchemaFrame)

ILayoutSchemaPropertyListGetAllFrames Method (ISchemaFrame)

Gets an instance of ISchemaFrame wrapping all frames in this ILayoutSchemaPropertyList.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISchemaFrame GetAllFrames(
    ISchemaFrame pivot
)
ISchemaFrame^ GetAllFrames(
    ISchemaFrame^ pivot
)

Parameters

pivot
Type: VisualComponents.Create3DISchemaFrame
Frame that will be used as pivot frame in rotation manipulation.

Return Value

Type: ISchemaFrame
Frame that acts as a wrapper for all the frames in the schema.
See Also

Reference

ILayoutSchemaPropertyList Interface
GetAllFrames Overload
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.GetFrame Method

ILayoutSchemaPropertyListGetFrame Method

Overload List
 | Name | Description
Public method | GetFrame(Int32) | Gets the instance of ISchemaFrame wrapping the frame at the given data index in this ILayoutSchemaPropertyList.
Public method | GetFrame(Int32, ISchemaFrame) | Gets the instance of ISchemaFrame wrapping the frame at the given data index in this ILayoutSchemaPropertyList.
Top
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.GetFrame Method (Int32)

ILayoutSchemaPropertyListGetFrame Method (Int32)

Gets the instance of ISchemaFrame wrapping the frame at the given data index in this ILayoutSchemaPropertyList.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISchemaFrame GetFrame(
    int dataIndex
)
ISchemaFrame^ GetFrame(
    int dataIndex
)

Parameters

dataIndex
Type: SystemInt32
Data index.

Return Value

Type: ISchemaFrame
Matrix data entry as frame.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when dataIndex is out of range.
See Also

Reference

ILayoutSchemaPropertyList Interface
GetFrame Overload
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.GetFrame Method (Int32, ISchemaFrame)

ILayoutSchemaPropertyListGetFrame Method (Int32, ISchemaFrame)

Gets the instance of ISchemaFrame wrapping the frame at the given data index in this ILayoutSchemaPropertyList.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISchemaFrame GetFrame(
    int dataIndex,
    ISchemaFrame frame
)
ISchemaFrame^ GetFrame(
    int dataIndex,
    ISchemaFrame^ frame
)

Parameters

dataIndex
Type: SystemInt32
Data index.
frame
Type: VisualComponents.Create3DISchemaFrame
Frame instance to update.

Return Value

Type: ISchemaFrame
True if successful.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when dataIndex is out of range.
See Also

Reference

ILayoutSchemaPropertyList Interface
GetFrame Overload
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.GetFrames Method

ILayoutSchemaPropertyListGetFrames Method

Overload List
 | Name | Description
Public method | GetFrames(IEnumerableInt32) | Gets the instance of ISchemaFrame wrapping the frames at given indexes in this ILayoutSchemaPropertyList. Uses the first given index as a pivot frame.
Public method | GetFrames(Int32, Int32) | Gets the instance of ISchemaFrame wrapping the frames at given indexes in this ILayoutSchemaPropertyList.
Top
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.GetFrames Method (IEnumerable(Int32))

ILayoutSchemaPropertyListGetFrames Method (IEnumerableInt32)

Gets the instance of ISchemaFrame wrapping the frames at given indexes in this ILayoutSchemaPropertyList. Uses the first given index as a pivot frame.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISchemaFrame GetFrames(
    IEnumerable<int> indexes
)
ISchemaFrame^ GetFrames(
    IEnumerable<int>^ indexes
)

Parameters

indexes
Type: System.Collections.GenericIEnumerableInt32
Data indexes.

Return Value

Type: ISchemaFrame
Frame that acts as a wrapper for given frames.
See Also

Reference

ILayoutSchemaPropertyList Interface
GetFrames Overload
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.GetFrames Method (Int32, Int32)

ILayoutSchemaPropertyListGetFrames Method (Int32, Int32)

Gets the instance of ISchemaFrame wrapping the frames at given indexes in this ILayoutSchemaPropertyList.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISchemaFrame GetFrames(
    int startIndex,
    int count
)
ISchemaFrame^ GetFrames(
    int startIndex,
    int count
)

Parameters

startIndex
Type: SystemInt32
Zero-based starting frame index.
count
Type: SystemInt32
The number of indexes in wrapped frame.

Return Value

Type: ISchemaFrame
Frame that acts as a wrapper for given frames.
See Also

Reference

ILayoutSchemaPropertyList Interface
GetFrames Overload
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.GetSchemaValue Method

ILayoutSchemaPropertyListGetSchemaValue Method

Gets the value of schema property at the given data entry.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object GetSchemaValue(
    int dataIndex,
    int schemaPropertyIndex
)
Object^ GetSchemaValue(
    int dataIndex,
    int schemaPropertyIndex
)

Parameters

dataIndex
Type: SystemInt32
Index of the data entry.
schemaPropertyIndex
Type: SystemInt32
Index of the schema property.

Return Value

Type: Object
The value of the schema property of the given data entry.
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.GetSchemaValues Method

ILayoutSchemaPropertyListGetSchemaValues Method

Overload List
 | Name | Description
Public method | GetSchemaValues(Int32) | Gets the values of all schema properties at the given data entry.
Public method | GetSchemaValues(Int32, IListInt32) | Gets the values of multiple schema properties at the given data entry.
Top
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.GetSchemaValues Method (Int32)

ILayoutSchemaPropertyListGetSchemaValues Method (Int32)

Gets the values of all schema properties at the given data entry.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<Object> GetSchemaValues(
    int dataIndex
)
IEnumerable<Object^>^ GetSchemaValues(
    int dataIndex
)

Parameters

dataIndex
Type: SystemInt32
Index of the data entry.

Return Value

Type: IEnumerableObject
The values of all the schema properties at the given data entry.
See Also

Reference

ILayoutSchemaPropertyList Interface
GetSchemaValues Overload
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.GetSchemaValues Method (Int32, IList(Int32))

ILayoutSchemaPropertyListGetSchemaValues Method (Int32, IListInt32)

Gets the values of multiple schema properties at the given data entry.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<Object> GetSchemaValues(
    int dataIndex,
    IList<int> schemaPropertyIndexes
)
IEnumerable<Object^>^ GetSchemaValues(
    int dataIndex,
    IList<int>^ schemaPropertyIndexes
)

Parameters

dataIndex
Type: SystemInt32
Index of the data entry.
schemaPropertyIndexes
Type: System.Collections.GenericIListInt32
Indexes of the schema properties.

Return Value

Type: IEnumerableObject
The values of the schema properties at the given data entry.
See Also

Reference

ILayoutSchemaPropertyList Interface
GetSchemaValues Overload
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.InsertSchemaEntries Method

ILayoutSchemaPropertyListInsertSchemaEntries Method

Adds new data entries at the given index

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void InsertSchemaEntries(
    int dataIndex,
    int numberOfEntries
)
void InsertSchemaEntries(
    int dataIndex,
    int numberOfEntries
)

Parameters

dataIndex
Type: SystemInt32
The index of the first new data entry.
numberOfEntries
Type: SystemInt32
Number of data entries to be added.
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.InsertSchemaEntry Method

ILayoutSchemaPropertyListInsertSchemaEntry Method

Overload List
 | Name | Description
Public method | InsertSchemaEntry(Int32) | Adds a new data entry at the given index.
Public method | InsertSchemaEntry(Int32, IListObject) | Obsolete. Adds a new data entry at the given index with given schema property values.
Top
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.InsertSchemaEntry Method (Int32)

ILayoutSchemaPropertyListInsertSchemaEntry Method (Int32)

Adds a new data entry at the given index.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void InsertSchemaEntry(
    int dataIndex
)
void InsertSchemaEntry(
    int dataIndex
)

Parameters

dataIndex
Type: SystemInt32
Index of the new data entry.
See Also

Reference

ILayoutSchemaPropertyList Interface
InsertSchemaEntry Overload
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.InsertSchemaEntry Method (Int32, IList(Object))

ILayoutSchemaPropertyListInsertSchemaEntry Method (Int32, IListObject)

Note: This API is now obsolete.

Adds a new data entry at the given index with given schema property values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Prefer ILaoyutSchemaPropertyList.InsertSchemaValues.")]
void InsertSchemaEntry(
    int dataIndex,
    IList<Object> values
)
[ObsoleteAttribute(L"Prefer ILaoyutSchemaPropertyList.InsertSchemaValues.")]
void InsertSchemaEntry(
    int dataIndex,
    IList<Object^>^ values
)

Parameters

dataIndex
Type: SystemInt32
Index of the new data entry.
values
Type: System.Collections.GenericIListObject
Schema proeprty values for the new data entry.
See Also

Reference

ILayoutSchemaPropertyList Interface
InsertSchemaEntry Overload
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.InsertSchemaValues Method

ILayoutSchemaPropertyListInsertSchemaValues Method

Adds a new data entry at the given index with given schema property values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void InsertSchemaValues(
    int dataIndex,
    IList<Object> values
)
void InsertSchemaValues(
    int dataIndex,
    IList<Object^>^ values
)

Parameters

dataIndex
Type: SystemInt32
Index of the new data entry.
values
Type: System.Collections.GenericIListObject
Schema proeprty values for the new data entry.
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.RemoveSchemaEntries Method

ILayoutSchemaPropertyListRemoveSchemaEntries Method

Removes the multiple data entries starting from the given data entry.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RemoveSchemaEntries(
    int dataIndex,
    int numberOfEntries
)
void RemoveSchemaEntries(
    int dataIndex,
    int numberOfEntries
)

Parameters

dataIndex
Type: SystemInt32
The index of the first data entry to be removed.
numberOfEntries
Type: SystemInt32
Number of data entries to be removed.
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.RemoveSchemaEntry Method

ILayoutSchemaPropertyListRemoveSchemaEntry Method

Removes the given data entry from this schema property list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RemoveSchemaEntry(
    int dataIndex
)
void RemoveSchemaEntry(
    int dataIndex
)

Parameters

dataIndex
Type: SystemInt32
Index of tha data entry to be removed.
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.Reserve Method

ILayoutSchemaPropertyListReserve Method

Allocates the size of the schema to support the given number of data entries.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Reserve(
    int count
)
void Reserve(
    int count
)

Parameters

count
Type: SystemInt32
Number of data entries to schema can hold at maximum.
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.SetSchemaValue Method

ILayoutSchemaPropertyListSetSchemaValue Method

Sets the value of the schema property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetSchemaValue(
    int dataIndex,
    int schemaPropertyIndex,
    Object value
)
void SetSchemaValue(
    int dataIndex,
    int schemaPropertyIndex,
    Object^ value
)

Parameters

dataIndex
Type: SystemInt32
Index of the data entry.
schemaPropertyIndex
Type: SystemInt32
Index of the schema property.
value
Type: SystemObject
Value to be set.
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.SetSchemaValues Method

ILayoutSchemaPropertyListSetSchemaValues Method

Sets the value of multiple schema properties.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetSchemaValues(
    int dataIndex,
    IList<int> schemaPropertyIndexes,
    IList<Object> values
)
void SetSchemaValues(
    int dataIndex,
    IList<int>^ schemaPropertyIndexes,
    IList<Object^>^ values
)

Parameters

dataIndex
Type: SystemInt32
Index of the data entry
schemaPropertyIndexes
Type: System.Collections.GenericIListInt32
Indexes of the schema properties.
values
Type: System.Collections.GenericIListObject
Values to be set.
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.Update Method

ILayoutSchemaPropertyListUpdate Method

Overload List
 | Name | Description
Public method | Update | Updates the visualization of all the data entries in this schema property list. This should be called after modifying schema properties that affect the schema visualization.
Public method | Update(Int32) | Updates the visualization of the given data entry. This should be called after modifying schema properties that affect the schema visualization.
Top
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.Update Method

ILayoutSchemaPropertyListUpdate Method

Updates the visualization of all the data entries in this schema property list. This should be called after modifying schema properties that affect the schema visualization.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Update()
void Update()
See Also

Reference

ILayoutSchemaPropertyList Interface
Update Overload
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.Update Method (Int32)

ILayoutSchemaPropertyListUpdate Method (Int32)

Updates the visualization of the given data entry. This should be called after modifying schema properties that affect the schema visualization.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Update(
    int dataIndex
)
void Update(
    int dataIndex
)

Parameters

dataIndex
Type: SystemInt32
See Also

Reference

ILayoutSchemaPropertyList Interface
Update Overload
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.UpdateLevelOfDetail Method

ILayoutSchemaPropertyListUpdateLevelOfDetail Method

Updates level of detail visualization. This method is intended to be used internally only.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateLevelOfDetail()
void UpdateLevelOfDetail()
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList Events

The ILayoutSchemaPropertyList type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | RecordAppended | Occurs when a record (row) has been appended to a schema.
Public event | RecordInserted | Occurs when a record (row) has been inserted to a schema.
Public event | RecordRemoved | Occurs when a record (row) has been removed from a schema.
Public event | SchemaValueChanged | Occurs when schema value has been changed.
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.RecordAppended Event

ILayoutSchemaPropertyListRecordAppended Event

Occurs when a record (row) has been appended to a schema.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<SchemaRecordChangedEventArgs> RecordAppended
 event EventHandler<SchemaRecordChangedEventArgs^>^ RecordAppended {
    void add (EventHandler<SchemaRecordChangedEventArgs^>^ value);
    void remove (EventHandler<SchemaRecordChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerSchemaRecordChangedEventArgs
Remarks
Append is defined by the inserted records being located at the end of a schema, allowing the freedom not to consider following records (rows), if the data is sequential in nature (e.g. a sequence of positions). Hence, to comply with this notion, the first record inserted to an empty schema is considered as being "appended".
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.RecordInserted Event

ILayoutSchemaPropertyListRecordInserted Event

Occurs when a record (row) has been inserted to a schema.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<SchemaRecordChangedEventArgs> RecordInserted
 event EventHandler<SchemaRecordChangedEventArgs^>^ RecordInserted {
    void add (EventHandler<SchemaRecordChangedEventArgs^>^ value);
    void remove (EventHandler<SchemaRecordChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerSchemaRecordChangedEventArgs
Remarks
See remarks for RecordAppended.
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.RecordRemoved Event

ILayoutSchemaPropertyListRecordRemoved Event

Occurs when a record (row) has been removed from a schema.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<SchemaRecordChangedEventArgs> RecordRemoved
 event EventHandler<SchemaRecordChangedEventArgs^>^ RecordRemoved {
    void add (EventHandler<SchemaRecordChangedEventArgs^>^ value);
    void remove (EventHandler<SchemaRecordChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerSchemaRecordChangedEventArgs
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutSchemaPropertyList.SchemaValueChanged Event

ILayoutSchemaPropertyListSchemaValueChanged Event

Occurs when schema value has been changed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<SchemaValueChangedEventArgs> SchemaValueChanged
 event EventHandler<SchemaValueChangedEventArgs^>^ SchemaValueChanged {
    void add (EventHandler<SchemaValueChangedEventArgs^>^ value);
    void remove (EventHandler<SchemaValueChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerSchemaValueChangedEventArgs
See Also

Reference

ILayoutSchemaPropertyList Interface
VisualComponents.Create3D Namespace


ILayoutViewAnimation Interface

View animation layout item interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ILayoutViewAnimation : ILayoutItem,
    IWrapper, IDisposable, INamed, IPropertyContainer, IBatchModeObject,
    IStatementExecutor
public interface class ILayoutViewAnimation : ILayoutItem,
    IWrapper, IDisposable, INamed, IPropertyContainer, IBatchModeObject,
    IStatementExecutor

The ILayoutViewAnimation type exposes the following members.

Properties
 | Name | Description
Public property | ActiveProgram | Gets or sets the currently active program. (Inherited from IStatementExecutor.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CurrentScope | Get the scope that is currently being executed. (Inherited from IStatementExecutor.)
Public property | CurrentStatement | Gets the current position of the program pointer. Returns null if in the beginning of scope. (Inherited from IStatementExecutor.)
Public property | IsEnabled |
Public property | IsLooping | Defines if the executor will restart the program automatically when finished. (Inherited from IStatementExecutor.)
Public property | IsPersistent | Defines if the ILayoutItem is stored with the layout. (Inherited from ILayoutItem.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Program | Gets the first program contained by this IStatementExecutor instance. (Inherited from IStatementExecutor.)
Public property | Programs | Gets all the instances of IProgram in this executor. (Inherited from IStatementExecutor.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ClearPrograms | (Inherited from IStatementExecutor.)
Public method | Continue | Continues execution. (Inherited from IStatementExecutor.)
Public method | Continue(Double) | Continues the execution after a given time. (Inherited from IStatementExecutor.)
Public method | CreateProgram | Creates a new instance of IProgram. (Inherited from IStatementExecutor.)
Public method | CreateProgram(String) | Creates a new instance of IProgram. (Inherited from IStatementExecutor.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProgram | Deletes the given instance of IProgram (Inherited from IStatementExecutor.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteStep | Execute the next IStatement. (Inherited from IStatementExecutor.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | JumpToScope | Adds the current program position to the stack and jumps program execution to the given scope. When the scope is finished, the progam will continue from the current position. (Inherited from IStatementExecutor.)
Public method | NotifyStatementExecutedEx | Signals ExecutedEx event for this statement. This should only be used together with custom statements that have set the value of ControlExecutedExEvent to true. (Inherited from IStatementExecutor.)
Public method | Reset | Reset the execution to the beginning of the program. (Inherited from IStatementExecutor.)
Public method | SetProgramPointer | Sets the program pointer to the given position. When executed, the program will start from this position. (Inherited from IStatementExecutor.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ActiveProgramChanged | Occurs when the value of ActiveProgram has changed. (Inherited from IStatementExecutor.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | ProgramAdded | Occurs when a new instance of IProgram has been added to this instance of IStatementExecutor. (Inherited from IStatementExecutor.)
Public event | ProgramRemoving | Occurs when an instance of IProgram is being removed from this instance of IStatementExecutor. (Inherited from IStatementExecutor.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks

Layout item that can be used for authoring and manipulating view animation within layout.

Animation uses view animation statements to support view manipulation during simulation

See Also

Reference

VisualComponents.Create3D Namespace


ILayoutViewAnimation Properties

The ILayoutViewAnimation type exposes the following members.

Properties
 | Name | Description
Public property | ActiveProgram | Gets or sets the currently active program. (Inherited from IStatementExecutor.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CurrentScope | Get the scope that is currently being executed. (Inherited from IStatementExecutor.)
Public property | CurrentStatement | Gets the current position of the program pointer. Returns null if in the beginning of scope. (Inherited from IStatementExecutor.)
Public property | IsEnabled |
Public property | IsLooping | Defines if the executor will restart the program automatically when finished. (Inherited from IStatementExecutor.)
Public property | IsPersistent | Defines if the ILayoutItem is stored with the layout. (Inherited from ILayoutItem.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Program | Gets the first program contained by this IStatementExecutor instance. (Inherited from IStatementExecutor.)
Public property | Programs | Gets all the instances of IProgram in this executor. (Inherited from IStatementExecutor.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ILayoutViewAnimation Interface
VisualComponents.Create3D Namespace


ILayoutViewAnimation.IsEnabled Property

ILayoutViewAnimationIsEnabled Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsEnabled { get; set; }
property bool IsEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IStatementExecutorIsEnabled
See Also

Reference

ILayoutViewAnimation Interface
VisualComponents.Create3D Namespace


ILayoutViewAnimation Methods

The ILayoutViewAnimation type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ClearPrograms | (Inherited from IStatementExecutor.)
Public method | Continue | Continues execution. (Inherited from IStatementExecutor.)
Public method | Continue(Double) | Continues the execution after a given time. (Inherited from IStatementExecutor.)
Public method | CreateProgram | Creates a new instance of IProgram. (Inherited from IStatementExecutor.)
Public method | CreateProgram(String) | Creates a new instance of IProgram. (Inherited from IStatementExecutor.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProgram | Deletes the given instance of IProgram (Inherited from IStatementExecutor.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteStep | Execute the next IStatement. (Inherited from IStatementExecutor.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | JumpToScope | Adds the current program position to the stack and jumps program execution to the given scope. When the scope is finished, the progam will continue from the current position. (Inherited from IStatementExecutor.)
Public method | NotifyStatementExecutedEx | Signals ExecutedEx event for this statement. This should only be used together with custom statements that have set the value of ControlExecutedExEvent to true. (Inherited from IStatementExecutor.)
Public method | Reset | Reset the execution to the beginning of the program. (Inherited from IStatementExecutor.)
Public method | SetProgramPointer | Sets the program pointer to the given position. When executed, the program will start from this position. (Inherited from IStatementExecutor.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ILayoutViewAnimation Interface
VisualComponents.Create3D Namespace


ILayoutViewAnimation Events

The ILayoutViewAnimation type exposes the following members.

Events
 | Name | Description
Public event | ActiveProgramChanged | Occurs when the value of ActiveProgram has changed. (Inherited from IStatementExecutor.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | ProgramAdded | Occurs when a new instance of IProgram has been added to this instance of IStatementExecutor. (Inherited from IStatementExecutor.)
Public event | ProgramRemoving | Occurs when an instance of IProgram is being removed from this instance of IStatementExecutor. (Inherited from IStatementExecutor.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ILayoutViewAnimation Interface
VisualComponents.Create3D Namespace


ILicenseHandle Interface

License handle interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ILicenseHandle : IDisposable
public interface class ILicenseHandle : IDisposable

The ILicenseHandle type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Test | Test license validity.
Top
Remarks

The implementation of this interface retains a license handle during its lifetime, making it unavailable for use by other computers in case the license is a network license.

The license is released once the handle is disposed.

A license handle can be tested to see if it is still valid. See ILicensingChallenge for a description of the challenge-response mechanism.

See Also

Reference

VisualComponents.Create3D Namespace


ILicenseHandle Methods

The ILicenseHandle type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Test | Test license validity.
Top
See Also

Reference

ILicenseHandle Interface
VisualComponents.Create3D Namespace


ILicenseHandle.Test Method

ILicenseHandleTest Method

Test license validity.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Test(
    ILicensingChallenge challenge
)
void Test(
    ILicensingChallenge^ challenge
)

Parameters

challenge
Type: VisualComponents.Create3DILicensingChallenge
Optional challenge
Remarks

This will throw an exception if the license is no longer valid.

See Also

Reference

ILicenseHandle Interface
VisualComponents.Create3D Namespace


ILicenseMetadata Interface

License metadata interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ILicenseMetadata
public interface class ILicenseMetadata

The ILicenseMetadata type exposes the following members.

Properties
 | Name | Description
Public property | RequiredFeatures | Features required by this export.
Top
Remarks

This is used to mark MEF exports that have a license requirement.

Exports with this type of metadata are not instantiated if the required features are not present in the current license configuration.

Note that this check is only done for multiple import type exports.

The required features can be specified as any of the following:

  • A feature specification string.
  • A combination of LicenseFeaturesFeatures values, either as a LicenseFeaturesFeatures or a Int32.
  • Null to indicate no required features.

Note that these only guide the VisualComponents.Engine bootstrapper when deciding which MEF exports to instantiate; once instantiated, each exported class still has to implement its own license checking code to actually enforce the licensing.

See Also

Reference

VisualComponents.Create3D Namespace


ILicenseMetadata Properties

The ILicenseMetadata type exposes the following members.

Properties
 | Name | Description
Public property | RequiredFeatures | Features required by this export.
Top
See Also

Reference

ILicenseMetadata Interface
VisualComponents.Create3D Namespace


ILicenseMetadata.RequiredFeatures Property

ILicenseMetadataRequiredFeatures Property

Features required by this export.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object RequiredFeatures { get; }
property Object^ RequiredFeatures {
    Object^ get ();
}

Property Value

Type: Object
See Also

Reference

ILicenseMetadata Interface
VisualComponents.Create3D Namespace


ILicensingChallenge Interface

Licensing challenge interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ILicensingChallenge
public interface class ILicensingChallenge

The ILicensingChallenge type exposes the following members.

Properties
 | Name | Description
Public property | Challenge | Challenge string read by the licensing module.
Public property | Response | Response string to be set by the licensing module.
Top
Remarks

The licensing challenge interface is used for the VC proprietary challenge-response mechanism. The implementation provides a challenge string through the Challenge property, and receives a Response string during the operation. The implementation must then verify that the response is correct, and based on that decide whether to continue the operation.

See Also

Reference

VisualComponents.Create3D Namespace


ILicensingChallenge Properties

The ILicensingChallenge type exposes the following members.

Properties
 | Name | Description
Public property | Challenge | Challenge string read by the licensing module.
Public property | Response | Response string to be set by the licensing module.
Top
See Also

Reference

ILicensingChallenge Interface
VisualComponents.Create3D Namespace


ILicensingChallenge.Challenge Property

ILicensingChallengeChallenge Property

Challenge string read by the licensing module.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Challenge { get; }
property String^ Challenge {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ILicensingChallenge Interface
VisualComponents.Create3D Namespace


ILicensingChallenge.Response Property

ILicensingChallengeResponse Property

Response string to be set by the licensing module.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Response { get; set; }
property String^ Response {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ILicensingChallenge Interface
VisualComponents.Create3D Namespace


ILicensingService Interface

Licensing service interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ILicensingService
public interface class ILicensingService

The ILicensingService type exposes the following members.

Properties
 | Name | Description
Public property | MainLicenses | Information about all stored main licenses.
Public property | ProductMainFeature | Returns the main feature for the current software product.
Public property | VirtualConfiguration | Virtual feature configuration in this instance.
Top
Methods
 | Name | Description
Public method | GetAddOnLicense | Get add-on feature license.
Public method | GetMainFeatureForVirtualFeature | Given a virtual feature, returns the main feature that the virtual feature is mapped to.
Public method | GetMainLicense | Get main product feature license.
Top
Events
 | Name | Description
Public event | LicenseCheckFailed | Raised when a license check has failed.
Public event | LicenseCheckSucceeded | Raised when a license check has succeeded, after it has failed.
Top
Remarks

This interface is to a service that aggregates all license requests so that each feature is allocated only once. It is intended for use by the .NET-side UI and/or code elements that need licensing protection.

To protect code with a license, before running, make sure to get a license handle using one of the getters. Add-ons should use GetAddOnLicense. It is recommended that the handle be retained until the end of the session, and then disposed.

Examples

Example using the licensing service to protect licensed code:

Copy
class LicensedCodeImplementation : IDisposable
{
    ILicensingService   _licensingService;
    ILicenseHandle      _license;

    public LicensedCodeImplementation([Import] ILicensingService licensingService)
    {
        _licensingService = licensingService;

        // This will throw an exception if there is a problem with the
        // license.
        // NOTE: Challenge-response mechanism is not shown here.
        _license = _licensingService.GetMainLicense("feature", null);
    }

    public void Dispose()
    {
        if(_license != null)
        {
            _license.Dispose();
        }
    }
}
See Also

Reference

VisualComponents.Create3D Namespace


ILicensingService Properties

The ILicensingService type exposes the following members.

Properties
 | Name | Description
Public property | MainLicenses | Information about all stored main licenses.
Public property | ProductMainFeature | Returns the main feature for the current software product.
Public property | VirtualConfiguration | Virtual feature configuration in this instance.
Top
See Also

Reference

ILicensingService Interface
VisualComponents.Create3D Namespace


ILicensingService.MainLicenses Property

ILicensingServiceMainLicenses Property

Information about all stored main licenses.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<LicensingServiceFeature> MainLicenses { get; }
property IReadOnlyList<LicensingServiceFeature>^ MainLicenses {
    IReadOnlyList<LicensingServiceFeature>^ get ();
}

Property Value

Type: IReadOnlyListLicensingServiceFeature
See Also

Reference

ILicensingService Interface
VisualComponents.Create3D Namespace


ILicensingService.ProductMainFeature Property

ILicensingServiceProductMainFeature Property

Returns the main feature for the current software product.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
LicensingServiceFeature ProductMainFeature { get; }
property LicensingServiceFeature ProductMainFeature {
    LicensingServiceFeature get ();
}

Property Value

Type: LicensingServiceFeature
See Also

Reference

ILicensingService Interface
VisualComponents.Create3D Namespace


ILicensingService.VirtualConfiguration Property

ILicensingServiceVirtualConfiguration Property

Virtual feature configuration in this instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProductConfiguration VirtualConfiguration { get; }
property IProductConfiguration^ VirtualConfiguration {
    IProductConfiguration^ get ();
}

Property Value

Type: IProductConfiguration
Remarks
The virtual feature configuration contains a set of features enabled by the current licensing configuration.
See Also

Reference

ILicensingService Interface
VisualComponents.Create3D Namespace


ILicensingService Methods

The ILicensingService type exposes the following members.

Methods
 | Name | Description
Public method | GetAddOnLicense | Get add-on feature license.
Public method | GetMainFeatureForVirtualFeature | Given a virtual feature, returns the main feature that the virtual feature is mapped to.
Public method | GetMainLicense | Get main product feature license.
Top
See Also

Reference

ILicensingService Interface
VisualComponents.Create3D Namespace


ILicensingService.GetAddOnLicense Method

ILicensingServiceGetAddOnLicense Method

Get add-on feature license.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ILicenseHandle GetAddOnLicense(
    string featureName,
    string featureVersion,
    ILicensingChallenge challenge
)
ILicenseHandle^ GetAddOnLicense(
    String^ featureName,
    String^ featureVersion,
    ILicensingChallenge^ challenge
)

Parameters

featureName
Type: SystemString
Feature name.
featureVersion
Type: SystemString
Feature version.
challenge
Type: VisualComponents.Create3DILicensingChallenge
Optional challenge.

Return Value

Type: ILicenseHandle
Always returns a non-null license handle regardless of a license being available or not.
See Also

Reference

ILicensingService Interface
VisualComponents.Create3D Namespace


ILicensingService.GetMainFeatureForVirtualFeature Method

ILicensingServiceGetMainFeatureForVirtualFeature Method

Given a virtual feature, returns the main feature that the virtual feature is mapped to.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
LicensingServiceFeature GetMainFeatureForVirtualFeature(
    string virtualFeatureName,
    string virtualFeatureVersion
)
LicensingServiceFeature GetMainFeatureForVirtualFeature(
    String^ virtualFeatureName,
    String^ virtualFeatureVersion
)

Parameters

virtualFeatureName
Type: SystemString
Virtual feature name
virtualFeatureVersion
Type: SystemString
Virtual feature version

Return Value

Type: LicensingServiceFeature

[Missing <returns> documentation for "M:VisualComponents.Create3D.ILicensingService.GetMainFeatureForVirtualFeature(System.String,System.String)"]

See Also

Reference

ILicensingService Interface
VisualComponents.Create3D Namespace


ILicensingService.GetMainLicense Method

ILicensingServiceGetMainLicense Method

Get main product feature license.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ILicenseHandle GetMainLicense(
    string featureName,
    ILicensingChallenge challenge
)
ILicenseHandle^ GetMainLicense(
    String^ featureName,
    ILicensingChallenge^ challenge
)

Parameters

featureName
Type: SystemString
Feature name.
challenge
Type: VisualComponents.Create3DILicensingChallenge
Optional challenge.

Return Value

Type: ILicenseHandle

[Missing <returns> documentation for "M:VisualComponents.Create3D.ILicensingService.GetMainLicense(System.String,VisualComponents.Create3D.ILicensingChallenge)"]

Remarks

The differences between this and GetAddOnLicense(String, String, ILicensingChallenge) are:

  1. Main licenses always have the same version string as the main application, whereas add-on licenses specify their own version strings.
  2. If a valid license is not found, this method will close the application while the other won't.

See Also

Reference

ILicensingService Interface
VisualComponents.Create3D Namespace


ILicensingService Events

The ILicensingService type exposes the following members.

Events
 | Name | Description
Public event | LicenseCheckFailed | Raised when a license check has failed.
Public event | LicenseCheckSucceeded | Raised when a license check has succeeded, after it has failed.
Top
See Also

Reference

ILicensingService Interface
VisualComponents.Create3D Namespace


ILicensingService.LicenseCheckFailed Event

ILicensingServiceLicenseCheckFailed Event

Raised when a license check has failed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<LicenseCheckFailedEventArgs> LicenseCheckFailed
 event EventHandler<LicenseCheckFailedEventArgs^>^ LicenseCheckFailed {
    void add (EventHandler<LicenseCheckFailedEventArgs^>^ value);
    void remove (EventHandler<LicenseCheckFailedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerLicenseCheckFailedEventArgs
Remarks

This event is raised when e.g. the connection to the license server is lost. It contains a countdown parameter indicating how many times this event will be called before the software shuts down.

If there is a problem with the license check, this event will be raised every second, until the countdown reaches zero, at which point the software will exit.

If the error condition is remedied, LicenseCheckSucceeded will be raised once to indicate this.

See Also

Reference

ILicensingService Interface
VisualComponents.Create3D Namespace


ILicensingService.LicenseCheckSucceeded Event

ILicensingServiceLicenseCheckSucceeded Event

Raised when a license check has succeeded, after it has failed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler LicenseCheckSucceeded
 event EventHandler^ LicenseCheckSucceeded {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
Remarks

This event is raised only after LicenseCheckFailed has been raised, and the error condition has been remedied, e.g. if LicenseCheckFailed was raised because the connection to the license server was lost, this event is raised once the connection is restored.

See Also

Reference

ILicensingService Interface
VisualComponents.Create3D Namespace


ILightSimNode Interface

Read-only accessible simulation node.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ILightSimNode
public interface class ILightSimNode

The ILightSimNode type exposes the following members.

Properties
 | Name | Description
Public property | Children |
Public property | ComponentName |
Public property | Name |
Public property | NodeType |
Public property | Parent |
Top
See Also

Reference

VisualComponents.Create3D Namespace


ILightSimNode Properties

The ILightSimNode type exposes the following members.

Properties
 | Name | Description
Public property | Children |
Public property | ComponentName |
Public property | Name |
Public property | NodeType |
Public property | Parent |
Top
See Also

Reference

ILightSimNode Interface
VisualComponents.Create3D Namespace


ILightSimNode.Children Property

ILightSimNodeChildren Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ObservableCollection<ILightSimNode> Children { get; }
property ObservableCollection<ILightSimNode^>^ Children {
    ObservableCollection<ILightSimNode^>^ get ();
}

Property Value

Type: ObservableCollectionILightSimNode
See Also

Reference

ILightSimNode Interface
VisualComponents.Create3D Namespace


ILightSimNode.ComponentName Property

ILightSimNodeComponentName Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ComponentName { get; set; }
property String^ ComponentName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ILightSimNode Interface
VisualComponents.Create3D Namespace


ILightSimNode.Name Property

ILightSimNodeName Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Name { get; set; }
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ILightSimNode Interface
VisualComponents.Create3D Namespace


ILightSimNode.NodeType Property

ILightSimNodeNodeType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
TypeOfNode NodeType { get; set; }
property TypeOfNode NodeType {
    TypeOfNode get ();
    void set (TypeOfNode value);
}

Property Value

Type: TypeOfNode
See Also

Reference

ILightSimNode Interface
VisualComponents.Create3D Namespace


ILightSimNode.Parent Property

ILightSimNodeParent Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ILightSimNode Parent { get; set; }
property ILightSimNode^ Parent {
    ILightSimNode^ get ();
    void set (ILightSimNode^ value);
}

Property Value

Type: ILightSimNode
See Also

Reference

ILightSimNode Interface
VisualComponents.Create3D Namespace


ILinearCloneFeature Interface

Represents a linear clone feature object

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ILinearCloneFeature : IFeature,
    IVisualObject, INamed, IWrapper, IDisposable, IVisitable,
    IPropertyContainer, IBatchModeObject, ISharedCloneable
public interface class ILinearCloneFeature : IFeature,
    IVisualObject, INamed, IWrapper, IDisposable, IVisitable,
    IPropertyContainer, IBatchModeObject, ISharedCloneable

The ILinearCloneFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
The Linear Clone operation feature generates clones of all sub features, translating each by a specified amount.
See Also

Reference

VisualComponents.Create3D Namespace


ILinearCloneFeature Properties

The ILinearCloneFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
See Also

Reference

ILinearCloneFeature Interface
VisualComponents.Create3D Namespace


ILinearCloneFeature Methods

The ILinearCloneFeature type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ILinearCloneFeature Interface
VisualComponents.Create3D Namespace


ILinearCloneFeature Events

The ILinearCloneFeature type exposes the following members.

Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

ILinearCloneFeature Interface
VisualComponents.Create3D Namespace


ILinearMotionStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ILinearMotionStatement : IPositionStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement>, ICloneable,
    IInterpolatable, IPositionFrameContainer
public interface class ILinearMotionStatement : IPositionStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement^>, ICloneable,
    IInterpolatable, IPositionFrameContainer

The ILinearMotionStatement type exposes the following members.

Properties
 | Name | Description
Public property | Acceleration | Gets or sets the maximum cartesian acceleration of motion (units/s^2) used to calculate target trajectory.
Public property | AccuracyMethod | Gets or sets the zone of accuracy type to use for the target, for example distance, time or velocity.
Public property | AccuracyValue | Gets or sets the limit used in AccuracyMethod.
Public property | AngularAcceleration | Gets or sets the maximum angular acceleration of motion (degrees/s^2) used to calculate target trajectory.
Public property | AngularDeceleration | Gets or sets the maximum angular deceleration of motion (degrees/s^2) used to calculate target trajectory.
Public property | ApiType | (Inherited from IApiType.)
Public property | Base | Gets or sets the robot base for which the positions in this IPositionStatement are attached to. (Inherited from IPositionStatement.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConfigurationMode | Gets selected ConfigurationMode in statement's properties.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | CycleTime | Gets or sets the total elapsed time for executing motion statement, which may scale speed and acceleration of joints. If zero, this property is ignored.
Public property | Deceleration | Gets or sets the maximum Cartesian deceleration of motion (units/s^2) used to calculate target trajectory.
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | ExternalJointValues | Gets external joint values.
Public property | ExternalTcp | Gets or sets external TCP mode. (Inherited from IPositionStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | JointValues | Gets all joint values.
Public property | MaxAngularSpeed | Gets or sets the maximum angular speed (degrees/s^2) used to calculate target trajectory.
Public property | MaxSpeed | Gets or sets the maximum Cartesian speed (units/s) used to calculate target trajectory.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | OrientationInterpolationMode | Frame orientation interpolation mode
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Positions | Gets all the positions in this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | Target | Movement target in local coordinates.
Public property | Tool | Gets or sets the robot tool (Inherited from IPositionStatement.)
Top
Methods
 | Name | Description
Public method | AddPositionFromProgram | Adds an existing IPositionFrame from IProgram to this IPositionStatement. (Inherited from IPositionStatement.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ClearPositions | Clears all IPositionFrame instances from this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreatePosition | Creates a new IPositionFrame instance and adds it to this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeletePosition | Deletes the given IPositionFrame from this IPositionFrameContainer and deletes it (see remarks). (Inherited from IPositionFrameContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | ExecuteImmediatePosition | Moves the robot to the given position. See also: IStatement.ExecuteImmediate(). (Inherited from IPositionStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | HighlightAll | Highlights all the positions in this IPositionStatement. (Inherited from IPositionStatement.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | ReadIn | Fill statement values from controller.
Public method | ReadIn(IPositionFrame) | Reads in the current state of from the associated instance of IServoController. (Inherited from IPositionStatement.)
Public method | SetExternalJoints | Sets external joint values.
Public method | SetExternalTcp | Gets or sets external TCP mode by keeping relative frame positions. (Inherited from IPositionStatement.)
Public method | SetJoints | Sets all joint values.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PositionAdded | Occurs when a new instance of IPositionFrame has been added to this instance of IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public event | PositionRemoving | Occurs when an instance of IPositionFrame is being removed from this instance of IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public event | PositionTransformationChanged | Occurs when transformation of an instance of IPositionFrame in this instance of IPositionStatement changes. (Inherited from IPositionStatement.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ILinearMotionStatement Properties

The ILinearMotionStatement type exposes the following members.

Properties
 | Name | Description
Public property | Acceleration | Gets or sets the maximum cartesian acceleration of motion (units/s^2) used to calculate target trajectory.
Public property | AccuracyMethod | Gets or sets the zone of accuracy type to use for the target, for example distance, time or velocity.
Public property | AccuracyValue | Gets or sets the limit used in AccuracyMethod.
Public property | AngularAcceleration | Gets or sets the maximum angular acceleration of motion (degrees/s^2) used to calculate target trajectory.
Public property | AngularDeceleration | Gets or sets the maximum angular deceleration of motion (degrees/s^2) used to calculate target trajectory.
Public property | ApiType | (Inherited from IApiType.)
Public property | Base | Gets or sets the robot base for which the positions in this IPositionStatement are attached to. (Inherited from IPositionStatement.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConfigurationMode | Gets selected ConfigurationMode in statement's properties.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | CycleTime | Gets or sets the total elapsed time for executing motion statement, which may scale speed and acceleration of joints. If zero, this property is ignored.
Public property | Deceleration | Gets or sets the maximum Cartesian deceleration of motion (units/s^2) used to calculate target trajectory.
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | ExternalJointValues | Gets external joint values.
Public property | ExternalTcp | Gets or sets external TCP mode. (Inherited from IPositionStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | JointValues | Gets all joint values.
Public property | MaxAngularSpeed | Gets or sets the maximum angular speed (degrees/s^2) used to calculate target trajectory.
Public property | MaxSpeed | Gets or sets the maximum Cartesian speed (units/s) used to calculate target trajectory.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | OrientationInterpolationMode | Frame orientation interpolation mode
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Positions | Gets all the positions in this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | Target | Movement target in local coordinates.
Public property | Tool | Gets or sets the robot tool (Inherited from IPositionStatement.)
Top
See Also

Reference

ILinearMotionStatement Interface
VisualComponents.Create3D Namespace


ILinearMotionStatement.Acceleration Property

ILinearMotionStatementAcceleration Property

Gets or sets the maximum cartesian acceleration of motion (units/s^2) used to calculate target trajectory.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Acceleration { get; set; }
property double Acceleration {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ILinearMotionStatement Interface
VisualComponents.Create3D Namespace


ILinearMotionStatement.AccuracyMethod Property

ILinearMotionStatementAccuracyMethod Property

Gets or sets the zone of accuracy type to use for the target, for example distance, time or velocity.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
AccuracyMethod AccuracyMethod { get; set; }
property AccuracyMethod AccuracyMethod {
    AccuracyMethod get ();
    void set (AccuracyMethod value);
}

Property Value

Type: AccuracyMethod
See Also

Reference

ILinearMotionStatement Interface
VisualComponents.Create3D Namespace


ILinearMotionStatement.AccuracyValue Property

ILinearMotionStatementAccuracyValue Property

Gets or sets the limit used in AccuracyMethod.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double AccuracyValue { get; set; }
property double AccuracyValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ILinearMotionStatement Interface
VisualComponents.Create3D Namespace


ILinearMotionStatement.AngularAcceleration Property

ILinearMotionStatementAngularAcceleration Property

Gets or sets the maximum angular acceleration of motion (degrees/s^2) used to calculate target trajectory.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double AngularAcceleration { get; set; }
property double AngularAcceleration {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ILinearMotionStatement Interface
VisualComponents.Create3D Namespace


ILinearMotionStatement.AngularDeceleration Property

ILinearMotionStatementAngularDeceleration Property

Gets or sets the maximum angular deceleration of motion (degrees/s^2) used to calculate target trajectory.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double AngularDeceleration { get; set; }
property double AngularDeceleration {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ILinearMotionStatement Interface
VisualComponents.Create3D Namespace


ILinearMotionStatement.ConfigurationMode Property

ILinearMotionStatementConfigurationMode Property

Gets selected ConfigurationMode in statement's properties.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ConfigurationMode ConfigurationMode { get; }
property ConfigurationMode ConfigurationMode {
    ConfigurationMode get ();
}

Property Value

Type: ConfigurationMode
See Also

Reference

ILinearMotionStatement Interface
VisualComponents.Create3D Namespace


ILinearMotionStatement.CycleTime Property

ILinearMotionStatementCycleTime Property

Gets or sets the total elapsed time for executing motion statement, which may scale speed and acceleration of joints. If zero, this property is ignored.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double CycleTime { get; set; }
property double CycleTime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ILinearMotionStatement Interface
VisualComponents.Create3D Namespace


ILinearMotionStatement.Deceleration Property

ILinearMotionStatementDeceleration Property

Gets or sets the maximum Cartesian deceleration of motion (units/s^2) used to calculate target trajectory.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Deceleration { get; set; }
property double Deceleration {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ILinearMotionStatement Interface
VisualComponents.Create3D Namespace


ILinearMotionStatement.ExternalJointValues Property

ILinearMotionStatementExternalJointValues Property

Gets external joint values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<double> ExternalJointValues { get; }
property ReadOnlyCollection<double>^ ExternalJointValues {
    ReadOnlyCollection<double>^ get ();
}

Property Value

Type: ReadOnlyCollectionDouble
See Also

Reference

ILinearMotionStatement Interface
VisualComponents.Create3D Namespace


ILinearMotionStatement.JointValues Property

ILinearMotionStatementJointValues Property

Gets all joint values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<double> JointValues { get; }
property ReadOnlyCollection<double>^ JointValues {
    ReadOnlyCollection<double>^ get ();
}

Property Value

Type: ReadOnlyCollectionDouble
See Also

Reference

ILinearMotionStatement Interface
VisualComponents.Create3D Namespace


ILinearMotionStatement.MaxAngularSpeed Property

ILinearMotionStatementMaxAngularSpeed Property

Gets or sets the maximum angular speed (degrees/s^2) used to calculate target trajectory.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double MaxAngularSpeed { get; set; }
property double MaxAngularSpeed {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ILinearMotionStatement Interface
VisualComponents.Create3D Namespace


ILinearMotionStatement.MaxSpeed Property

ILinearMotionStatementMaxSpeed Property

Gets or sets the maximum Cartesian speed (units/s) used to calculate target trajectory.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double MaxSpeed { get; set; }
property double MaxSpeed {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ILinearMotionStatement Interface
VisualComponents.Create3D Namespace


ILinearMotionStatement.OrientationInterpolationMode Property

ILinearMotionStatementOrientationInterpolationMode Property

Frame orientation interpolation mode

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
OrientationInterpolationMode OrientationInterpolationMode { get; }
property OrientationInterpolationMode OrientationInterpolationMode {
    OrientationInterpolationMode get ();
}

Property Value

Type: OrientationInterpolationMode
See Also

Reference

ILinearMotionStatement Interface
VisualComponents.Create3D Namespace


ILinearMotionStatement.Target Property

ILinearMotionStatementTarget Property

Movement target in local coordinates.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix Target { get; set; }
property Matrix Target {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

ILinearMotionStatement Interface
VisualComponents.Create3D Namespace


ILinearMotionStatement Methods

The ILinearMotionStatement type exposes the following members.

Methods
 | Name | Description
Public method | AddPositionFromProgram | Adds an existing IPositionFrame from IProgram to this IPositionStatement. (Inherited from IPositionStatement.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ClearPositions | Clears all IPositionFrame instances from this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreatePosition | Creates a new IPositionFrame instance and adds it to this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeletePosition | Deletes the given IPositionFrame from this IPositionFrameContainer and deletes it (see remarks). (Inherited from IPositionFrameContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | ExecuteImmediatePosition | Moves the robot to the given position. See also: IStatement.ExecuteImmediate(). (Inherited from IPositionStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | HighlightAll | Highlights all the positions in this IPositionStatement. (Inherited from IPositionStatement.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | ReadIn | Fill statement values from controller.
Public method | ReadIn(IPositionFrame) | Reads in the current state of from the associated instance of IServoController. (Inherited from IPositionStatement.)
Public method | SetExternalJoints | Sets external joint values.
Public method | SetExternalTcp | Gets or sets external TCP mode by keeping relative frame positions. (Inherited from IPositionStatement.)
Public method | SetJoints | Sets all joint values.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ILinearMotionStatement Interface
VisualComponents.Create3D Namespace


ILinearMotionStatement.ReadIn Method

ILinearMotionStatementReadIn Method

Overload List
 | Name | Description
Public method | ReadIn | Fill statement values from controller.
Public method | ReadIn(IPositionFrame) | Reads in the current state of from the associated instance of IServoController. (Inherited from IPositionStatement.)
Top
See Also

Reference

ILinearMotionStatement Interface
VisualComponents.Create3D Namespace


ILinearMotionStatement.ReadIn Method

ILinearMotionStatementReadIn Method

Fill statement values from controller.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ReadIn()
void ReadIn()
See Also

Reference

ILinearMotionStatement Interface
ReadIn Overload
VisualComponents.Create3D Namespace


ILinearMotionStatement.SetExternalJoints Method

ILinearMotionStatementSetExternalJoints Method

Sets external joint values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetExternalJoints(
    IEnumerable<double> jointValues
)
void SetExternalJoints(
    IEnumerable<double>^ jointValues
)

Parameters

jointValues
Type: System.Collections.GenericIEnumerableDouble
See Also

Reference

ILinearMotionStatement Interface
VisualComponents.Create3D Namespace


ILinearMotionStatement.SetJoints Method

ILinearMotionStatementSetJoints Method

Sets all joint values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetJoints(
    IEnumerable<double> jointValues
)
void SetJoints(
    IEnumerable<double>^ jointValues
)

Parameters

jointValues
Type: System.Collections.GenericIEnumerableDouble
See Also

Reference

ILinearMotionStatement Interface
VisualComponents.Create3D Namespace


ILinearMotionStatement Events

The ILinearMotionStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PositionAdded | Occurs when a new instance of IPositionFrame has been added to this instance of IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public event | PositionRemoving | Occurs when an instance of IPositionFrame is being removed from this instance of IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public event | PositionTransformationChanged | Occurs when transformation of an instance of IPositionFrame in this instance of IPositionStatement changes. (Inherited from IPositionStatement.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

ILinearMotionStatement Interface
VisualComponents.Create3D Namespace


ILineSet Interface

Interface for line sets. Can be used for creating and reading line geometries. A line is represented as a collection of two or more points

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ILineSet : IGeometrySet,
    IPrimitive, IWrapper, IDisposable
public interface class ILineSet : IGeometrySet,
    IPrimitive, IWrapper, IDisposable

The ILineSet type exposes the following members.

Properties
 | Name | Description
Public property | BoundBox | Returns the bound box of the geometryset. (Inherited from IGeometrySet.)
Public property | Container | Geometry container object (Inherited from IGeometrySet.)
Public property | Feature | IGeometryFeature owning the geoset (Inherited from IGeometrySet.)
Public property | HasMaterialInheritance | Determines if it has material inheritance (Inherited from IGeometrySet.)
Public property | HasNoHits | For internal purpose only (Inherited from IGeometrySet.)
Public property | IsHighlighted | Determines if set is highlighted (Inherited from IGeometrySet.)
Public property | IsLayerVisible | Determine if the layer where the geometry set is located is visible (Inherited from IGeometrySet.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Determines if set is visible (Inherited from IGeometrySet.)
Public property | LineCount | Returns the number of lines in the geometry set
Public property | Lines | Returns a collection of lines which is an array of positions
Public property | LineWidth | The width of the line. Note that values other than 1 may incur a performance penalty.
Public property | Material | Material of the set (Inherited from IGeometrySet.)
Public property | Name | Name of the set (Inherited from IGeometrySet.)
Public property | ObjectPrimitiveType | (Inherited from IPrimitive.)
Public property | Original | Retrieves the original geometry set (Inherited from IGeometrySet.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Topology | Returns the topological information
Public property | TopologyCurves | Set topological information (Inherited from IGeometrySet.)
Top
Methods
 | Name | Description
Public method | AddCurvePtr | For internal use only
Public method | AddLine | Adds a 2-point line
Public method | AddPolyline | Adds a polyline
Public method | Clear | Clears all geometry information from the set (Inherited from IGeometrySet.)
Public method | Delete | Deletes the set. Instance gets invalidated (Inherited from IGeometrySet.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetClosestPoint | Raycast geometry set. (Inherited from IGeometrySet.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | HighlightEdges | highlights only the edges (does not override normal highlighting) (Inherited from IGeometrySet.)
Public method | Update | Updates set information (Inherited from IGeometrySet.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ILineSet Properties

The ILineSet type exposes the following members.

Properties
 | Name | Description
Public property | BoundBox | Returns the bound box of the geometryset. (Inherited from IGeometrySet.)
Public property | Container | Geometry container object (Inherited from IGeometrySet.)
Public property | Feature | IGeometryFeature owning the geoset (Inherited from IGeometrySet.)
Public property | HasMaterialInheritance | Determines if it has material inheritance (Inherited from IGeometrySet.)
Public property | HasNoHits | For internal purpose only (Inherited from IGeometrySet.)
Public property | IsHighlighted | Determines if set is highlighted (Inherited from IGeometrySet.)
Public property | IsLayerVisible | Determine if the layer where the geometry set is located is visible (Inherited from IGeometrySet.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Determines if set is visible (Inherited from IGeometrySet.)
Public property | LineCount | Returns the number of lines in the geometry set
Public property | Lines | Returns a collection of lines which is an array of positions
Public property | LineWidth | The width of the line. Note that values other than 1 may incur a performance penalty.
Public property | Material | Material of the set (Inherited from IGeometrySet.)
Public property | Name | Name of the set (Inherited from IGeometrySet.)
Public property | ObjectPrimitiveType | (Inherited from IPrimitive.)
Public property | Original | Retrieves the original geometry set (Inherited from IGeometrySet.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Topology | Returns the topological information
Public property | TopologyCurves | Set topological information (Inherited from IGeometrySet.)
Top
See Also

Reference

ILineSet Interface
VisualComponents.Create3D Namespace


ILineSet.LineCount Property

ILineSetLineCount Property

Returns the number of lines in the geometry set

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int LineCount { get; }
property int LineCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ILineSet Interface
VisualComponents.Create3D Namespace


ILineSet.Lines Property

ILineSetLines Property

Returns a collection of lines which is an array of positions

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<Vector3[]> Lines { get; }
property ReadOnlyCollection<array<Vector3>^>^ Lines {
    ReadOnlyCollection<array<Vector3>^>^ get ();
}

Property Value

Type: ReadOnlyCollectionVector3
See Also

Reference

ILineSet Interface
VisualComponents.Create3D Namespace


ILineSet.LineWidth Property

ILineSetLineWidth Property

The width of the line. Note that values other than 1 may incur a performance penalty.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double LineWidth { get; set; }
property double LineWidth {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ILineSet Interface
VisualComponents.Create3D Namespace


ILineSet.Topology Property

ILineSetTopology Property

Returns the topological information

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ICurveTopology Topology { get; }
property ICurveTopology^ Topology {
    ICurveTopology^ get ();
}

Property Value

Type: ICurveTopology
See Also

Reference

ILineSet Interface
VisualComponents.Create3D Namespace


ILineSet Methods

The ILineSet type exposes the following members.

Methods
 | Name | Description
Public method | AddCurvePtr | For internal use only
Public method | AddLine | Adds a 2-point line
Public method | AddPolyline | Adds a polyline
Public method | Clear | Clears all geometry information from the set (Inherited from IGeometrySet.)
Public method | Delete | Deletes the set. Instance gets invalidated (Inherited from IGeometrySet.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetClosestPoint | Raycast geometry set. (Inherited from IGeometrySet.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | HighlightEdges | highlights only the edges (does not override normal highlighting) (Inherited from IGeometrySet.)
Public method | Update | Updates set information (Inherited from IGeometrySet.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ILineSet Interface
VisualComponents.Create3D Namespace


ILineSet.AddCurvePtr Method

ILineSetAddCurvePtr Method

For internal use only

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddCurvePtr(
    IntPtr ptr,
    double units
)
void AddCurvePtr(
    IntPtr ptr,
    double units
)

Parameters

ptr
Type: SystemIntPtr
units
Type: SystemDouble
See Also

Reference

ILineSet Interface
VisualComponents.Create3D Namespace


ILineSet.AddLine Method

ILineSetAddLine Method

Adds a 2-point line

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddLine(
    Vector3 point1,
    Vector3 point2
)
void AddLine(
    Vector3 point1,
    Vector3 point2
)

Parameters

point1
Type: VisualComponents.Create3DVector3
points 1
point2
Type: VisualComponents.Create3DVector3
points 2
See Also

Reference

ILineSet Interface
VisualComponents.Create3D Namespace


ILineSet.AddPolyline Method

ILineSetAddPolyline Method

Adds a polyline

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddPolyline(
    Vector3[] points
)
void AddPolyline(
    array<Vector3>^ points
)

Parameters

points
Type: VisualComponents.Create3DVector3
polyline positions
See Also

Reference

ILineSet Interface
VisualComponents.Create3D Namespace


ILineSet Events

The ILineSet type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
See Also

Reference

ILineSet Interface
VisualComponents.Create3D Namespace


IListProperty Interface

Non-generic list property interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IListProperty : IProperty,
    INotifyPropertyChanged, IDisposable, INamed
public interface class IListProperty : IProperty,
    INotifyPropertyChanged, IDisposable, INamed

The IListProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Allowed maximum value for the property. (Inherited from IProperty.)
Public property | AllowedMinimum | Allowed minimum value for the property. (Inherited from IProperty.)
Public property | AllowedValues | Collection of allowed values for constrained properties. (Inherited from IProperty.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | List | Property value as an editable list.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Property value as an object. (Inherited from IProperty.)
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | MoveItem | Moves item from source index position to destination index position.
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IListProperty Properties

The IListProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Allowed maximum value for the property. (Inherited from IProperty.)
Public property | AllowedMinimum | Allowed minimum value for the property. (Inherited from IProperty.)
Public property | AllowedValues | Collection of allowed values for constrained properties. (Inherited from IProperty.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | List | Property value as an editable list.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Property value as an object. (Inherited from IProperty.)
Top
See Also

Reference

IListProperty Interface
VisualComponents.Create3D Namespace


IListProperty.List Property

IListPropertyList Property

Property value as an editable list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList List { get; }
property IList^ List {
    IList^ get ();
}

Property Value

Type: IList
See Also

Reference

IListProperty Interface
VisualComponents.Create3D Namespace


IListProperty Methods

The IListProperty type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | MoveItem | Moves item from source index position to destination index position.
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

IListProperty Interface
VisualComponents.Create3D Namespace


IListProperty.MoveItem Method

IListPropertyMoveItem Method

Moves item from source index position to destination index position.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool MoveItem(
    int source,
    int destination
)
bool MoveItem(
    int source,
    int destination
)

Parameters

source
Type: SystemInt32
destination
Type: SystemInt32

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IListProperty.MoveItem(System.Int32,System.Int32)"]

See Also

Reference

IListProperty Interface
VisualComponents.Create3D Namespace


IListProperty Events

The IListProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IListProperty Interface
VisualComponents.Create3D Namespace


IListProperty(T) Interface

IListPropertyT Interface

Generic list property interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IListProperty<T> : IProperty<T[]>,
    IProperty, INotifyPropertyChanged, IDisposable, INamed, IListProperty

generic<typename T>
public interface class IListProperty : IProperty<array<T>^>,
    IProperty, INotifyPropertyChanged, IDisposable, INamed, IListProperty

Type Parameters

T
Element type

The IListPropertyT type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Strongly typed allowed maximum value. (Inherited from IPropertyT.)
Public property | AllowedMinimum | Strongly typed allowed minimum value. (Inherited from IPropertyT.)
Public property | AllowedValues | Strongly typed container of allowed values. (Inherited from IPropertyT.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | List | Property value as an editable list.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Strongly typed property value. (Inherited from IPropertyT.)
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | MoveItem | Moves item from source index position to destination index position. (Inherited from IListProperty.)
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IListProperty(T) Properties

IListPropertyT Properties

The IListPropertyT generic type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Strongly typed allowed maximum value. (Inherited from IPropertyT.)
Public property | AllowedMinimum | Strongly typed allowed minimum value. (Inherited from IPropertyT.)
Public property | AllowedValues | Strongly typed container of allowed values. (Inherited from IPropertyT.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | List | Property value as an editable list.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Strongly typed property value. (Inherited from IPropertyT.)
Top
See Also

Reference

IListPropertyT Interface
VisualComponents.Create3D Namespace


IListProperty(T).List Property

IListPropertyTList Property

Property value as an editable list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<T> List { get; }
property IList<T>^ List {
    IList<T>^ get ();
}

Property Value

Type: IListT
See Also

Reference

IListPropertyT Interface
VisualComponents.Create3D Namespace


IListProperty(T) Methods

IListPropertyT Methods

The IListPropertyT generic type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | MoveItem | Moves item from source index position to destination index position. (Inherited from IListProperty.)
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

IListPropertyT Interface
VisualComponents.Create3D Namespace


IListProperty(T) Events

IListPropertyT Events

The IListPropertyT generic type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IListPropertyT Interface
VisualComponents.Create3D Namespace


ILocalizationService Interface

It provides a localization functionality.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ILocalizationService
public interface class ILocalizationService

The ILocalizationService type exposes the following members.

Properties
 | Name | Description
Public property | AvailableLanguages | Returns list of available language resources (i.e.: Resource.English.dll)
Public property | CurrentCultureInfo | Gets the information about a specific culture.
Public property | CurrentLanguage | Gets the current language
Public property | CurrentSystemLanguage | Gets the current system language that represents the culture installed with the operating system.
Public property | SystemCulture | Gets the system culture info.
Top
Methods
 | Name | Description
Public method | ApplyLanguage | Save and Set selected language
Public method | Contains | Determines whether the ILocalizationService instance contains an element with the specified key.
Public method | GetFormattedText(String, Object) | Searches for a localization string, and and calls String.Format(key, args).
Public method | GetFormattedText(String, String) | Searches for a localization string and calls String.Format().
Public method | GetFormattedText(String, String, String) | Searches for a localization string and calls String.Format().
Public method | GetFormattedText(String, String, String, String) | Searches for a localization string and calls String.Format().
Public method | GetText(String) | Searches for a localization string
Public method | GetText(String, String, String) | 3-key based localization, that finds localized string based on combination of 3 keys. Typically used for tooltips, where containerKey is the name of property container, itemKey is the name of property, and typeKey is "Description".
Public method | SetText | Provide custom translation for 3-key based localization.
Top
Events
 | Name | Description
Public event | LanguageChanged | Event that is raised when the language is changed
Top
See Also

Reference

VisualComponents.Create3D Namespace


ILocalizationService Properties

The ILocalizationService type exposes the following members.

Properties
 | Name | Description
Public property | AvailableLanguages | Returns list of available language resources (i.e.: Resource.English.dll)
Public property | CurrentCultureInfo | Gets the information about a specific culture.
Public property | CurrentLanguage | Gets the current language
Public property | CurrentSystemLanguage | Gets the current system language that represents the culture installed with the operating system.
Public property | SystemCulture | Gets the system culture info.
Top
See Also

Reference

ILocalizationService Interface
VisualComponents.Create3D Namespace


ILocalizationService.AvailableLanguages Property

ILocalizationServiceAvailableLanguages Property

Returns list of available language resources (i.e.: Resource.English.dll)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<string> AvailableLanguages { get; }
property IList<String^>^ AvailableLanguages {
    IList<String^>^ get ();
}

Property Value

Type: IListString
See Also

Reference

ILocalizationService Interface
VisualComponents.Create3D Namespace


ILocalizationService.CurrentCultureInfo Property

ILocalizationServiceCurrentCultureInfo Property

Gets the information about a specific culture.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
CultureInfo CurrentCultureInfo { get; }
property CultureInfo^ CurrentCultureInfo {
    CultureInfo^ get ();
}

Property Value

Type: CultureInfo
See Also

Reference

ILocalizationService Interface
VisualComponents.Create3D Namespace


ILocalizationService.CurrentLanguage Property

ILocalizationServiceCurrentLanguage Property

Gets the current language

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string CurrentLanguage { get; }
property String^ CurrentLanguage {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ILocalizationService Interface
VisualComponents.Create3D Namespace


ILocalizationService.CurrentSystemLanguage Property

ILocalizationServiceCurrentSystemLanguage Property

Gets the current system language that represents the culture installed with the operating system.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string CurrentSystemLanguage { get; }
property String^ CurrentSystemLanguage {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ILocalizationService Interface
VisualComponents.Create3D Namespace


ILocalizationService.SystemCulture Property

ILocalizationServiceSystemCulture Property

Gets the system culture info.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
CultureInfo SystemCulture { get; }
property CultureInfo^ SystemCulture {
    CultureInfo^ get ();
}

Property Value

Type: CultureInfo
See Also

Reference

ILocalizationService Interface
VisualComponents.Create3D Namespace


ILocalizationService Methods

The ILocalizationService type exposes the following members.

Methods
 | Name | Description
Public method | ApplyLanguage | Save and Set selected language
Public method | Contains | Determines whether the ILocalizationService instance contains an element with the specified key.
Public method | GetFormattedText(String, Object) | Searches for a localization string, and and calls String.Format(key, args).
Public method | GetFormattedText(String, String) | Searches for a localization string and calls String.Format().
Public method | GetFormattedText(String, String, String) | Searches for a localization string and calls String.Format().
Public method | GetFormattedText(String, String, String, String) | Searches for a localization string and calls String.Format().
Public method | GetText(String) | Searches for a localization string
Public method | GetText(String, String, String) | 3-key based localization, that finds localized string based on combination of 3 keys. Typically used for tooltips, where containerKey is the name of property container, itemKey is the name of property, and typeKey is "Description".
Public method | SetText | Provide custom translation for 3-key based localization.
Top
See Also

Reference

ILocalizationService Interface
VisualComponents.Create3D Namespace


ILocalizationService.ApplyLanguage Method

ILocalizationServiceApplyLanguage Method

Save and Set selected language

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ApplyLanguage(
    string selectedLanguage
)
void ApplyLanguage(
    String^ selectedLanguage
)

Parameters

selectedLanguage
Type: SystemString
selected language name
See Also

Reference

ILocalizationService Interface
VisualComponents.Create3D Namespace


ILocalizationService.Contains Method

ILocalizationServiceContains Method

Determines whether the ILocalizationService instance contains an element with the specified key.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool Contains(
    Object key
)
bool Contains(
    Object^ key
)

Parameters

key
Type: SystemObject
The key to locate in the System.Windows.ResourceDictionary.

Return Value

Type: Boolean
true if System.Windows.ResourceDictionary contains a key-value pair with the specified key; otherwise, false.
See Also

Reference

ILocalizationService Interface
VisualComponents.Create3D Namespace


ILocalizationService.GetFormattedText Method

ILocalizationServiceGetFormattedText Method

Overload List
 | Name | Description
Public method | GetFormattedText(String, Object) | Searches for a localization string, and and calls String.Format(key, args).
Public method | GetFormattedText(String, String) | Searches for a localization string and calls String.Format().
Public method | GetFormattedText(String, String, String) | Searches for a localization string and calls String.Format().
Public method | GetFormattedText(String, String, String, String) | Searches for a localization string and calls String.Format().
Top
See Also

Reference

ILocalizationService Interface
VisualComponents.Create3D Namespace


ILocalizationService.GetFormattedText Method (String, Object[])

ILocalizationServiceGetFormattedText Method (String, Object)

Searches for a localization string, and and calls String.Format(key, args).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string GetFormattedText(
    string key,
    params Object[] args
)
String^ GetFormattedText(
    String^ key,
    ... array<Object^>^ args
)

Parameters

key
Type: SystemString
The name of the string to find
args
Type: SystemObject
Objects to format.

Return Value

Type: String
Localized and formatted string or an error string.
See Also

Reference

ILocalizationService Interface
GetFormattedText Overload
VisualComponents.Create3D Namespace


ILocalizationService.GetFormattedText Method (String, String)

ILocalizationServiceGetFormattedText Method (String, String)

Searches for a localization string and calls String.Format().

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string GetFormattedText(
    string key,
    string arg0
)
String^ GetFormattedText(
    String^ key,
    String^ arg0
)

Parameters

key
Type: SystemString
The name of the string to find.
arg0
Type: SystemString
The first object to format.

Return Value

Type: String
Localized and formatted string or an error string.
See Also

Reference

ILocalizationService Interface
GetFormattedText Overload
VisualComponents.Create3D Namespace


ILocalizationService.GetFormattedText Method (String, String, String)

ILocalizationServiceGetFormattedText Method (String, String, String)

Searches for a localization string and calls String.Format().

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string GetFormattedText(
    string key,
    string arg0,
    string arg1
)
String^ GetFormattedText(
    String^ key,
    String^ arg0,
    String^ arg1
)

Parameters

key
Type: SystemString
The name of the string to find
arg0
Type: SystemString
The first object to format.
arg1
Type: SystemString
The second object to format.

Return Value

Type: String
Localized and formatted string or an error string.
See Also

Reference

ILocalizationService Interface
GetFormattedText Overload
VisualComponents.Create3D Namespace


ILocalizationService.GetFormattedText Method (String, String, String, String)

ILocalizationServiceGetFormattedText Method (String, String, String, String)

Searches for a localization string and calls String.Format().

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string GetFormattedText(
    string key,
    string arg0,
    string arg1,
    string arg2
)
String^ GetFormattedText(
    String^ key,
    String^ arg0,
    String^ arg1,
    String^ arg2
)

Parameters

key
Type: SystemString
The name of the string to find
arg0
Type: SystemString
The first object to format.
arg1
Type: SystemString
The second object to format.
arg2
Type: SystemString
The third object to format.

Return Value

Type: String
Localized and formatted string or an error string.
See Also

Reference

ILocalizationService Interface
GetFormattedText Overload
VisualComponents.Create3D Namespace


ILocalizationService.GetText Method

ILocalizationServiceGetText Method

Overload List
 | Name | Description
Public method | GetText(String) | Searches for a localization string
Public method | GetText(String, String, String) | 3-key based localization, that finds localized string based on combination of 3 keys. Typically used for tooltips, where containerKey is the name of property container, itemKey is the name of property, and typeKey is "Description".
Top
See Also

Reference

ILocalizationService Interface
VisualComponents.Create3D Namespace


ILocalizationService.GetText Method (String)

ILocalizationServiceGetText Method (String)

Searches for a localization string

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string GetText(
    string key
)
String^ GetText(
    String^ key
)

Parameters

key
Type: SystemString
The name of the string to find

Return Value

Type: String
The requested localized string or empty string
See Also

Reference

ILocalizationService Interface
GetText Overload
VisualComponents.Create3D Namespace


ILocalizationService.GetText Method (String, String, String)

ILocalizationServiceGetText Method (String, String, String)

3-key based localization, that finds localized string based on combination of 3 keys. Typically used for tooltips, where containerKey is the name of property container, itemKey is the name of property, and typeKey is "Description".

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string GetText(
    string containerKey,
    string itemKey,
    string typeKey
)
String^ GetText(
    String^ containerKey,
    String^ itemKey,
    String^ typeKey
)

Parameters

containerKey
Type: SystemString
itemKey
Type: SystemString
typeKey
Type: SystemString

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.ILocalizationService.GetText(System.String,System.String,System.String)"]

See Also

Reference

ILocalizationService Interface
GetText Overload
VisualComponents.Create3D Namespace


ILocalizationService.SetText Method

ILocalizationServiceSetText Method

Provide custom translation for 3-key based localization.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetText(
    string containerKey,
    string itemKey,
    string typeKey,
    string value
)
void SetText(
    String^ containerKey,
    String^ itemKey,
    String^ typeKey,
    String^ value
)

Parameters

containerKey
Type: SystemString
itemKey
Type: SystemString
typeKey
Type: SystemString
value
Type: SystemString
See Also

Reference

ILocalizationService Interface
VisualComponents.Create3D Namespace


ILocalizationService Events

The ILocalizationService type exposes the following members.

Events
 | Name | Description
Public event | LanguageChanged | Event that is raised when the language is changed
Top
See Also

Reference

ILocalizationService Interface
VisualComponents.Create3D Namespace


ILocalizationService.LanguageChanged Event

ILocalizationServiceLanguageChanged Event

Event that is raised when the language is changed

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<LanguageChangedEventArgs> LanguageChanged
 event EventHandler<LanguageChangedEventArgs^>^ LanguageChanged {
    void add (EventHandler<LanguageChangedEventArgs^>^ value);
    void remove (EventHandler<LanguageChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerLanguageChangedEventArgs
See Also

Reference

ILocalizationService Interface
VisualComponents.Create3D Namespace


ILocalManipulationTarget Interface

Manipulation target object interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ILocalManipulationTarget : IManipulationTarget,
    ILockableObject, IDisposable
public interface class ILocalManipulationTarget : IManipulationTarget,
    ILockableObject, IDisposable

The ILocalManipulationTarget type exposes the following members.

Properties
 | Name | Description
Public property | HandleInObjectCoordinates | Deprecated. Same as TransformationInObject. (Inherited from IManipulationTarget.)
Public property | HandleInReference | Deprecated. Same as TransformationInReference. (Inherited from IManipulationTarget.)
Public property | HandleInWorld | Deprecated. Same as TransformationInWorld. (Inherited from IManipulationTarget.)
Public property | HandleReferenceInWorld | Deprecated. Same as ParentTransformationInWorld. (Inherited from IManipulationTarget.)
Public property | IsHandleFixed | Deprecated. Same as IRobotTcpManipulationTarget.IsTcpExternal. (Inherited from IManipulationTarget.)
Public property | IsLocked | (Inherited from IManipulationTarget.)
Public property | IsTargetEnabled | This is similar to IsLocked, but for manual disabling. (Inherited from IManipulationTarget.)
Public property | IsValid | (Inherited from IManipulationTarget.)
Public property | IsVisible | (Inherited from IManipulationTarget.)
Public property | MoveOnRelease |
Public property | ParentTransformationInWorld | Position of pivot visual object parent. (Inherited from IManipulationTarget.)
Public property | PivotObject | (Inherited from IManipulationTarget.)
Public property | ReferenceObject |
Public property | TargetObjects | Target objects. May exlude child objects. (Inherited from IManipulationTarget.)
Public property | TransformationInObject | Sets the transformation in reference to its own space (Inherited from IManipulationTarget.)
Public property | TransformationInReference | Gets or sets the transformation in reference to its parent (Inherited from IManipulationTarget.)
Public property | TransformationInWorld | Gets or sets the transformation in world (Inherited from IManipulationTarget.)
Top
Methods
 | Name | Description
Public method | ApplyChanges | This is implemented by manipulators that do actual changes on action end or mouse relase. If finalChange==false, then it's only an intermediate change (on mouse release). (Inherited from IManipulationTarget.)
Public method | CollectUndoChanges | Collect all changes since the last call to StoreUndoState(). (Inherited from IManipulationTarget.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | StoreUndoState | Store information away to be used when creating an undo change set later. (Inherited from IManipulationTarget.)
Top
Events
 | Name | Description
Public event | IsLockedChanged | (Inherited from IManipulationTarget.)
Public event | IsVisibleChanged | (Inherited from IManipulationTarget.)
Public event | ObjectInvalidated | (Inherited from IManipulationTarget.)
Public event | TransformationChanged | (Inherited from IManipulationTarget.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ILocalManipulationTarget Properties

The ILocalManipulationTarget type exposes the following members.

Properties
 | Name | Description
Public property | HandleInObjectCoordinates | Deprecated. Same as TransformationInObject. (Inherited from IManipulationTarget.)
Public property | HandleInReference | Deprecated. Same as TransformationInReference. (Inherited from IManipulationTarget.)
Public property | HandleInWorld | Deprecated. Same as TransformationInWorld. (Inherited from IManipulationTarget.)
Public property | HandleReferenceInWorld | Deprecated. Same as ParentTransformationInWorld. (Inherited from IManipulationTarget.)
Public property | IsHandleFixed | Deprecated. Same as IRobotTcpManipulationTarget.IsTcpExternal. (Inherited from IManipulationTarget.)
Public property | IsLocked | (Inherited from IManipulationTarget.)
Public property | IsTargetEnabled | This is similar to IsLocked, but for manual disabling. (Inherited from IManipulationTarget.)
Public property | IsValid | (Inherited from IManipulationTarget.)
Public property | IsVisible | (Inherited from IManipulationTarget.)
Public property | MoveOnRelease |
Public property | ParentTransformationInWorld | Position of pivot visual object parent. (Inherited from IManipulationTarget.)
Public property | PivotObject | (Inherited from IManipulationTarget.)
Public property | ReferenceObject |
Public property | TargetObjects | Target objects. May exlude child objects. (Inherited from IManipulationTarget.)
Public property | TransformationInObject | Sets the transformation in reference to its own space (Inherited from IManipulationTarget.)
Public property | TransformationInReference | Gets or sets the transformation in reference to its parent (Inherited from IManipulationTarget.)
Public property | TransformationInWorld | Gets or sets the transformation in world (Inherited from IManipulationTarget.)
Top
See Also

Reference

ILocalManipulationTarget Interface
VisualComponents.Create3D Namespace


ILocalManipulationTarget.MoveOnRelease Property

ILocalManipulationTargetMoveOnRelease Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool MoveOnRelease { get; }
property bool MoveOnRelease {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ILocalManipulationTarget Interface
VisualComponents.Create3D Namespace


ILocalManipulationTarget.ReferenceObject Property

ILocalManipulationTargetReferenceObject Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IVisualObject ReferenceObject { get; }
property IVisualObject^ ReferenceObject {
    IVisualObject^ get ();
}

Property Value

Type: IVisualObject
See Also

Reference

ILocalManipulationTarget Interface
VisualComponents.Create3D Namespace


ILocalManipulationTarget Methods

The ILocalManipulationTarget type exposes the following members.

Methods
 | Name | Description
Public method | ApplyChanges | This is implemented by manipulators that do actual changes on action end or mouse relase. If finalChange==false, then it's only an intermediate change (on mouse release). (Inherited from IManipulationTarget.)
Public method | CollectUndoChanges | Collect all changes since the last call to StoreUndoState(). (Inherited from IManipulationTarget.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | StoreUndoState | Store information away to be used when creating an undo change set later. (Inherited from IManipulationTarget.)
Top
See Also

Reference

ILocalManipulationTarget Interface
VisualComponents.Create3D Namespace


ILocalManipulationTarget Events

The ILocalManipulationTarget type exposes the following members.

Events
 | Name | Description
Public event | IsLockedChanged | (Inherited from IManipulationTarget.)
Public event | IsVisibleChanged | (Inherited from IManipulationTarget.)
Public event | ObjectInvalidated | (Inherited from IManipulationTarget.)
Public event | TransformationChanged | (Inherited from IManipulationTarget.)
Top
See Also

Reference

ILocalManipulationTarget Interface
VisualComponents.Create3D Namespace


ILockableObject Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ILockableObject
public interface class ILockableObject

The ILockableObject type exposes the following members.

Properties
 | Name | Description
Public property | IsLocked |
Top
Events
 | Name | Description
Public event | IsLockedChanged | Event that is raised when Lock property of the component is changed
Top
See Also

Reference

VisualComponents.Create3D Namespace


ILockableObject Properties

The ILockableObject type exposes the following members.

Properties
 | Name | Description
Public property | IsLocked |
Top
See Also

Reference

ILockableObject Interface
VisualComponents.Create3D Namespace


ILockableObject.IsLocked Property

ILockableObjectIsLocked Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsLocked { get; set; }
property bool IsLocked {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ILockableObject Interface
VisualComponents.Create3D Namespace


ILockableObject Events

The ILockableObject type exposes the following members.

Events
 | Name | Description
Public event | IsLockedChanged | Event that is raised when Lock property of the component is changed
Top
See Also

Reference

ILockableObject Interface
VisualComponents.Create3D Namespace


ILockableObject.IsLockedChanged Event

ILockableObjectIsLockedChanged Event

Event that is raised when Lock property of the component is changed

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> IsLockedChanged
 event EventHandler<EventArgs^>^ IsLockedChanged {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

ILockableObject Interface
VisualComponents.Create3D Namespace


ILogExt Interface

Extended logger.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ILogExt
public interface class ILogExt

The ILogExt type exposes the following members.

Methods
 | Name | Description
Public method | DecreaseIndent | Decrease indentation level.
Public method | Error | Log Error-level messages.
Public method | ErrorFormat(String, Object) | Log Error-level messages.
Public method | ErrorFormat(String, Exception, Object) | Log Error-level messages.
Public method | IncreaseIndent | Increase indentation level.
Public method | Info | Log Info-level messages.
Public method | InfoFormat | Log Info-level messages.
Top
See Also

Reference

VisualComponents.Create3D Namespace


ILogExt Methods

The ILogExt type exposes the following members.

Methods
 | Name | Description
Public method | DecreaseIndent | Decrease indentation level.
Public method | Error | Log Error-level messages.
Public method | ErrorFormat(String, Object) | Log Error-level messages.
Public method | ErrorFormat(String, Exception, Object) | Log Error-level messages.
Public method | IncreaseIndent | Increase indentation level.
Public method | Info | Log Info-level messages.
Public method | InfoFormat | Log Info-level messages.
Top
See Also

Reference

ILogExt Interface
VisualComponents.Create3D Namespace


ILogExt.DecreaseIndent Method

ILogExtDecreaseIndent Method

Decrease indentation level.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int DecreaseIndent()
int DecreaseIndent()

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.ILogExt.DecreaseIndent"]

See Also

Reference

ILogExt Interface
VisualComponents.Create3D Namespace


ILogExt.Error Method

ILogExtError Method

Log Error-level messages.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Error(
    string message
)
void Error(
    String^ message
)

Parameters

message
Type: SystemString
See Also

Reference

ILogExt Interface
VisualComponents.Create3D Namespace


ILogExt.ErrorFormat Method

ILogExtErrorFormat Method

Overload List
 | Name | Description
Public method | ErrorFormat(String, Object) | Log Error-level messages.
Public method | ErrorFormat(String, Exception, Object) | Log Error-level messages.
Top
See Also

Reference

ILogExt Interface
VisualComponents.Create3D Namespace


ILogExt.ErrorFormat Method (String, Object[])

ILogExtErrorFormat Method (String, Object)

Log Error-level messages.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ErrorFormat(
    string format,
    params Object[] args
)
void ErrorFormat(
    String^ format,
    ... array<Object^>^ args
)

Parameters

format
Type: SystemString
args
Type: SystemObject
See Also

Reference

ILogExt Interface
ErrorFormat Overload
VisualComponents.Create3D Namespace


ILogExt.ErrorFormat Method (String, Exception, Object[])

ILogExtErrorFormat Method (String, Exception, Object)

Log Error-level messages.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ErrorFormat(
    string format,
    Exception ex,
    params Object[] args
)
void ErrorFormat(
    String^ format,
    Exception^ ex,
    ... array<Object^>^ args
)

Parameters

format
Type: SystemString
ex
Type: SystemException
args
Type: SystemObject
See Also

Reference

ILogExt Interface
ErrorFormat Overload
VisualComponents.Create3D Namespace


ILogExt.IncreaseIndent Method

ILogExtIncreaseIndent Method

Increase indentation level.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int IncreaseIndent()
int IncreaseIndent()

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.ILogExt.IncreaseIndent"]

See Also

Reference

ILogExt Interface
VisualComponents.Create3D Namespace


ILogExt.Info Method

ILogExtInfo Method

Log Info-level messages.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Info(
    string message
)
void Info(
    String^ message
)

Parameters

message
Type: SystemString
See Also

Reference

ILogExt Interface
VisualComponents.Create3D Namespace


ILogExt.InfoFormat Method

ILogExtInfoFormat Method

Log Info-level messages.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void InfoFormat(
    string format,
    params Object[] args
)
void InfoFormat(
    String^ format,
    ... array<Object^>^ args
)

Parameters

format
Type: SystemString
args
Type: SystemObject
See Also

Reference

ILogExt Interface
VisualComponents.Create3D Namespace


ImageFormat Enumeration

Image format

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ImageFormat
public enum class ImageFormat
Members
Member name | Value | Description
BMP | 0 | Windows bitmap (BMP) file format.
JPG | 1 | Joint Photographics Experts Group (JPEG) compressed file format.
TGA | 2 | Truevision (Targa, or TGA) image file format.
PNG | 3 | Portable Network Graphics (PNG) file format.
DDS | 4 | DirectDraw surface (DDS) file format.
PPM | 5 | Portable pixmap (PPM) file format.
DIB | 6 | Windows device-independent bitmap (DIB) file format.
HDR | 7 | High dynamic range (HDR) file format.
PFM | 8 | Portable float map file format.
Remarks
see D3DXIMAGE_FILEFORMAT enumeration defined in DirectX (d3dx9tex.h)
See Also

Reference

VisualComponents.Create3D Namespace


ImageSourceExporter Class

This class has utility methods to export ISimWorld objects into a RenderTargetBitmap class or VisualHost (FrameworkElement) class
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DImageSourceExporter

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ImageSourceExporter
public ref class ImageSourceExporter

The ImageSourceExporter type exposes the following members.

Constructors
 | Name | Description
Public method | ImageSourceExporter | Constructor
Top
Properties
 | Name | Description
Public property | LineThickness | Line thickness
Public property | OnlySelection | Export methods should consider only selected or all
Public property | TraverseLayoutItems | Specifies if the methods to export should consider layoutitems (like drawings) or not
Top
Methods
 | Name | Description
Public method | CheckWorld | This method indicates that the exporting word is current application world
Public method | ComponentSize | Returns an emtpy visualHost that contains the width and heigth of the given component
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Export | Export the world into RenderTargetBitmap mainteining its size
Public method | Export(Double) | Export the world into RenderTargetBitmap scaling its size to the give scale factor
Public method | Export(IEnumerableILineSet, IEnumerableIText3DSet) | Export the current world into RenderTargetBitmap, it adds all lines and text to the given lists
Public method | Export(Boolean, Double, Double) | Export the current world into RenderTargetBitmap scaling it to fit the given width and height
Public method | Export(IEnumerableILineSet, IEnumerableIText3DSet, Boolean, Double, Double) | Export the current world into RenderTargetBitmap scaling it to fit the given width and height, it adds all lines and text to the given lists
Public method | ExportManyVisuals | Export the current world into several VisualHost depending on the available drawing templates, it sacales the world to fit the given width and height
Public method | ExportVisual(Boolean, Double, Double) | Export the current world into VisualHost scaling it to fit the given width and height
Public method | ExportVisual(IEnumerableILineSet, IEnumerableIText3DSet, Boolean, Double, Double) | Export specified line and text items into VisualHost scaling it to fit the given width and height
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDrawingWorld | This method indicates that the exporting word is the drawing world
Public method | SetWorld | This method indicates that the exporting word is the 3d world
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ImageSourceExporter Constructor

Constructor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ImageSourceExporter()
public:
ImageSourceExporter()
See Also

Reference

ImageSourceExporter Class
VisualComponents.Create3D Namespace


ImageSourceExporter Properties

The ImageSourceExporter type exposes the following members.

Properties
 | Name | Description
Public property | LineThickness | Line thickness
Public property | OnlySelection | Export methods should consider only selected or all
Public property | TraverseLayoutItems | Specifies if the methods to export should consider layoutitems (like drawings) or not
Top
See Also

Reference

ImageSourceExporter Class
VisualComponents.Create3D Namespace


ImageSourceExporter.LineThickness Property

ImageSourceExporterLineThickness Property

Line thickness

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double LineThickness { get; set; }
public:
property double LineThickness {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ImageSourceExporter Class
VisualComponents.Create3D Namespace


ImageSourceExporter.OnlySelection Property

ImageSourceExporterOnlySelection Property

Export methods should consider only selected or all

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool OnlySelection { get; set; }
public:
property bool OnlySelection {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ImageSourceExporter Class
VisualComponents.Create3D Namespace


ImageSourceExporter.TraverseLayoutItems Property

ImageSourceExporterTraverseLayoutItems Property

Specifies if the methods to export should consider layoutitems (like drawings) or not

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool TraverseLayoutItems { get; set; }
public:
property bool TraverseLayoutItems {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ImageSourceExporter Class
VisualComponents.Create3D Namespace


ImageSourceExporter Methods

The ImageSourceExporter type exposes the following members.

Methods
 | Name | Description
Public method | CheckWorld | This method indicates that the exporting word is current application world
Public method | ComponentSize | Returns an emtpy visualHost that contains the width and heigth of the given component
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Export | Export the world into RenderTargetBitmap mainteining its size
Public method | Export(Double) | Export the world into RenderTargetBitmap scaling its size to the give scale factor
Public method | Export(IEnumerableILineSet, IEnumerableIText3DSet) | Export the current world into RenderTargetBitmap, it adds all lines and text to the given lists
Public method | Export(Boolean, Double, Double) | Export the current world into RenderTargetBitmap scaling it to fit the given width and height
Public method | Export(IEnumerableILineSet, IEnumerableIText3DSet, Boolean, Double, Double) | Export the current world into RenderTargetBitmap scaling it to fit the given width and height, it adds all lines and text to the given lists
Public method | ExportManyVisuals | Export the current world into several VisualHost depending on the available drawing templates, it sacales the world to fit the given width and height
Public method | ExportVisual(Boolean, Double, Double) | Export the current world into VisualHost scaling it to fit the given width and height
Public method | ExportVisual(IEnumerableILineSet, IEnumerableIText3DSet, Boolean, Double, Double) | Export specified line and text items into VisualHost scaling it to fit the given width and height
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDrawingWorld | This method indicates that the exporting word is the drawing world
Public method | SetWorld | This method indicates that the exporting word is the 3d world
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ImageSourceExporter Class
VisualComponents.Create3D Namespace


ImageSourceExporter.CheckWorld Method

ImageSourceExporterCheckWorld Method

This method indicates that the exporting word is current application world

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CheckWorld()
public:
void CheckWorld()
See Also

Reference

ImageSourceExporter Class
VisualComponents.Create3D Namespace


ImageSourceExporter.ComponentSize Method

ImageSourceExporterComponentSize Method

Returns an emtpy visualHost that contains the width and heigth of the given component

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VisualHost ComponentSize(
    ISimComponent component
)
public:
VisualHost^ ComponentSize(
    ISimComponent^ component
)

Parameters

component
Type: VisualComponents.Create3DISimComponent

Return Value

Type: VisualHost

[Missing <returns> documentation for "M:VisualComponents.Create3D.ImageSourceExporter.ComponentSize(VisualComponents.Create3D.ISimComponent)"]

See Also

Reference

ImageSourceExporter Class
VisualComponents.Create3D Namespace


ImageSourceExporter.Export Method

ImageSourceExporterExport Method

Overload List
 | Name | Description
Public method | Export | Export the world into RenderTargetBitmap mainteining its size
Public method | Export(Double) | Export the world into RenderTargetBitmap scaling its size to the give scale factor
Public method | Export(IEnumerableILineSet, IEnumerableIText3DSet) | Export the current world into RenderTargetBitmap, it adds all lines and text to the given lists
Public method | Export(Boolean, Double, Double) | Export the current world into RenderTargetBitmap scaling it to fit the given width and height
Public method | Export(IEnumerableILineSet, IEnumerableIText3DSet, Boolean, Double, Double) | Export the current world into RenderTargetBitmap scaling it to fit the given width and height, it adds all lines and text to the given lists
Top
See Also

Reference

ImageSourceExporter Class
VisualComponents.Create3D Namespace


ImageSourceExporter.Export Method

ImageSourceExporterExport Method

Export the world into RenderTargetBitmap mainteining its size

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RenderTargetBitmap Export()
public:
RenderTargetBitmap^ Export()

Return Value

Type: RenderTargetBitmap

[Missing <returns> documentation for "M:VisualComponents.Create3D.ImageSourceExporter.Export"]

See Also

Reference

ImageSourceExporter Class
Export Overload
VisualComponents.Create3D Namespace


ImageSourceExporter.Export Method (Double)

ImageSourceExporterExport Method (Double)

Export the world into RenderTargetBitmap scaling its size to the give scale factor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RenderTargetBitmap Export(
    double scale
)
public:
RenderTargetBitmap^ Export(
    double scale
)

Parameters

scale
Type: SystemDouble
scale factor

Return Value

Type: RenderTargetBitmap
RenderTargetBitmap image source
See Also

Reference

ImageSourceExporter Class
Export Overload
VisualComponents.Create3D Namespace


ImageSourceExporter.Export Method (IEnumerable(ILineSet), IEnumerable(IText3DSet))

ImageSourceExporterExport Method (IEnumerableILineSet, IEnumerableIText3DSet)

Export the current world into RenderTargetBitmap, it adds all lines and text to the given lists

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RenderTargetBitmap Export(
    IEnumerable<ILineSet> lineSets,
    IEnumerable<IText3DSet> textSets
)
public:
RenderTargetBitmap^ Export(
    IEnumerable<ILineSet^>^ lineSets,
    IEnumerable<IText3DSet^>^ textSets
)

Parameters

lineSets
Type: System.Collections.GenericIEnumerableILineSet
Set of lines to export
textSets
Type: System.Collections.GenericIEnumerableIText3DSet
Set of texts to export

Return Value

Type: RenderTargetBitmap
RenderTargetBitmap image source
See Also

Reference

ImageSourceExporter Class
Export Overload
VisualComponents.Create3D Namespace


ImageSourceExporter.Export Method (Boolean, Double, Double)

ImageSourceExporterExport Method (Boolean, Double, Double)

Export the current world into RenderTargetBitmap scaling it to fit the given width and height

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RenderTargetBitmap Export(
    bool scaleToFit,
    double width,
    double height
)
public:
RenderTargetBitmap^ Export(
    bool scaleToFit,
    double width,
    double height
)

Parameters

scaleToFit
Type: SystemBoolean
If true, it scales the result to fit in the given width and height
width
Type: SystemDouble
Expected image source width in pixels
height
Type: SystemDouble
Expected image source height in pixels

Return Value

Type: RenderTargetBitmap
RenderTargetBitmap image source
See Also

Reference

ImageSourceExporter Class
Export Overload
VisualComponents.Create3D Namespace


ImageSourceExporter.Export Method (IEnumerable(ILineSet), IEnumerable(IText3DSet), Boolean, Double, Double)

ImageSourceExporterExport Method (IEnumerableILineSet, IEnumerableIText3DSet, Boolean, Double, Double)

Export the current world into RenderTargetBitmap scaling it to fit the given width and height, it adds all lines and text to the given lists

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RenderTargetBitmap Export(
    IEnumerable<ILineSet> lineSets,
    IEnumerable<IText3DSet> textSets,
    bool scaleToFit,
    double screenWidth,
    double screenHeight
)
public:
RenderTargetBitmap^ Export(
    IEnumerable<ILineSet^>^ lineSets,
    IEnumerable<IText3DSet^>^ textSets,
    bool scaleToFit,
    double screenWidth,
    double screenHeight
)

Parameters

lineSets
Type: System.Collections.GenericIEnumerableILineSet
Set of lines to export
textSets
Type: System.Collections.GenericIEnumerableIText3DSet
Set of texts to export
scaleToFit
Type: SystemBoolean
If true, it scales the result to fit in the given width and height
screenWidth
Type: SystemDouble
Screen width size in pixels
screenHeight
Type: SystemDouble
Screen height size in pixels

Return Value

Type: RenderTargetBitmap
RenderTargetBitmap image source
See Also

Reference

ImageSourceExporter Class
Export Overload
VisualComponents.Create3D Namespace


ImageSourceExporter.ExportManyVisuals Method

ImageSourceExporterExportManyVisuals Method

Export the current world into several VisualHost depending on the available drawing templates, it sacales the world to fit the given width and height

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<VisualHost> ExportManyVisuals(
    bool scaleToFit,
    double screenWidth,
    double screenHeight
)
public:
IEnumerable<VisualHost^>^ ExportManyVisuals(
    bool scaleToFit,
    double screenWidth,
    double screenHeight
)

Parameters

scaleToFit
Type: SystemBoolean
If true, it scales the result to fit in the given width and height
screenWidth
Type: SystemDouble
Screen width size in pixels
screenHeight
Type: SystemDouble
Screen height size in pixels

Return Value

Type: IEnumerableVisualHost
List of visual host object
See Also

Reference

ImageSourceExporter Class
VisualComponents.Create3D Namespace


ImageSourceExporter.ExportVisual Method

ImageSourceExporterExportVisual Method

Overload List
 | Name | Description
Public method | ExportVisual(Boolean, Double, Double) | Export the current world into VisualHost scaling it to fit the given width and height
Public method | ExportVisual(IEnumerableILineSet, IEnumerableIText3DSet, Boolean, Double, Double) | Export specified line and text items into VisualHost scaling it to fit the given width and height
Top
See Also

Reference

ImageSourceExporter Class
VisualComponents.Create3D Namespace


ImageSourceExporter.ExportVisual Method (Boolean, Double, Double)

ImageSourceExporterExportVisual Method (Boolean, Double, Double)

Export the current world into VisualHost scaling it to fit the given width and height

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VisualHost ExportVisual(
    bool scaleToFit,
    double screenWidth,
    double screenHeight
)
public:
VisualHost^ ExportVisual(
    bool scaleToFit,
    double screenWidth,
    double screenHeight
)

Parameters

scaleToFit
Type: SystemBoolean
If true, it scales the result to fit in the given width and height
screenWidth
Type: SystemDouble
Screen width size in pixels
screenHeight
Type: SystemDouble
Screen height size in pixels

Return Value

Type: VisualHost
Visual host object
See Also

Reference

ImageSourceExporter Class
ExportVisual Overload
VisualComponents.Create3D Namespace


ImageSourceExporter.ExportVisual Method (IEnumerable(ILineSet), IEnumerable(IText3DSet), Boolean, Double, Double)

ImageSourceExporterExportVisual Method (IEnumerableILineSet, IEnumerableIText3DSet, Boolean, Double, Double)

Export specified line and text items into VisualHost scaling it to fit the given width and height

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VisualHost ExportVisual(
    IEnumerable<ILineSet> lineSets,
    IEnumerable<IText3DSet> textSets,
    bool scaleToFit,
    double screenWidth,
    double screenHeight
)
public:
VisualHost^ ExportVisual(
    IEnumerable<ILineSet^>^ lineSets,
    IEnumerable<IText3DSet^>^ textSets,
    bool scaleToFit,
    double screenWidth,
    double screenHeight
)

Parameters

lineSets
Type: System.Collections.GenericIEnumerableILineSet
Set of lines to export
textSets
Type: System.Collections.GenericIEnumerableIText3DSet
Set of texts to export
scaleToFit
Type: SystemBoolean
If true, it scales the result to fit in the given width and height
screenWidth
Type: SystemDouble
Screen width size in pixels
screenHeight
Type: SystemDouble
Screen height size in pixels

Return Value

Type: VisualHost
Visual host object
See Also

Reference

ImageSourceExporter Class
ExportVisual Overload
VisualComponents.Create3D Namespace


ImageSourceExporter.SetDrawingWorld Method

ImageSourceExporterSetDrawingWorld Method

This method indicates that the exporting word is the drawing world

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetDrawingWorld()
public:
void SetDrawingWorld()
See Also

Reference

ImageSourceExporter Class
VisualComponents.Create3D Namespace


ImageSourceExporter.SetWorld Method

ImageSourceExporterSetWorld Method

This method indicates that the exporting word is the 3d world

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetWorld()
public:
void SetWorld()
See Also

Reference

ImageSourceExporter Class
VisualComponents.Create3D Namespace


IManipulateViewModel Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IManipulateViewModel
public interface class IManipulateViewModel

The IManipulateViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActiveManipulationMode |
Public property | ForceLockGeometryToNode | Alters LockGeometryToNode method to return always true or true only for rope pins of it is set to false
Public property | GeometrySelectEdgeHighlightOnly | Get/Set special geometry selection highlighting. Setting this to True makes sence only if GeometrySelectEnabled is set to True as well.
Public property | GeometrySelectEnabled | Get/Set the status of geometry selection mode. Usually this mode is active only when some command panel action is executing.
Public property | GridRotationEnabled |
Public property | GridRotationValue |
Public property | GridTranslationEnabled |
Public property | GridTranslationValue |
Public property | IsHandleVisible | Get/Set the handle visibility.
Public property | IsInteractEnabled | Get/Set the status of Interact mode.
Public property | IsJogEnabled | Get/Set the status of Jog mode.
Public property | IsManipulationEditorEnabled |
Public property | LockedTarget | Locked target prevens setting new target.
Public property | LockObjectCoordinateSystemMatrix |
Public property | LogicalPnpEnabled | Get/Set the status of Logical Plug and play mode.
Public property | MoveEnabled | Get/Set the status of move mode.
Public property | ObjectCoordinateSystemMatrix |
Public property | PnpEnabled | Get/Set the status of plug and play mode.
Public property | RotateXValue | X-axis rotation in degrees.
Public property | RotateYValue | Y-axis rotation in degrees
Public property | RotateZValue | Z-axis rotation in degrees.
Public property | RotationSystem | ABC or XYZ
Public property | SelectEnabled | Get/Set the status of select mode.
Public property | Target | Reference to the previously selected object that is visible in Properties panel. See also IComponentEditorExViewModel.SelectedObject and ITranslationRotationService.Target. See also TeachContext.ActiveRobot instance. When executing SelectionManager.SelectionChanged event this reference is pointing to currently selected item.
Public property | TranslateXValue | X-axis translation value.
Public property | TranslateYValue | Y-axis translation value.
Public property | TranslateZValue | Z-axis translation value.
Top
Methods
 | Name | Description
Public method | AbortCommands | Temporary helper. Needed because managed c++ cannot see RequestActionAbortMessage class.
Public method | Initialize |
Public method | LockGeometryToNode | Returns true only for rope pins.
Public method | ResetObjectCoordinateSystemMatrix |
Public method | RestorePnpMode | Used to enable Pnp mode when loading a layout or component. Works only in Home context.
Public method | SetActiveManipulationMode | Helper for changing manipulation mode.
Public method | SetSelectionAction | Temporary helper. Needed because managed c++ cannot see SelectAction class.
Public method | UpdateManipulationControl |
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

VisualComponents.Create3D Namespace


IManipulateViewModel Properties

The IManipulateViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActiveManipulationMode |
Public property | ForceLockGeometryToNode | Alters LockGeometryToNode method to return always true or true only for rope pins of it is set to false
Public property | GeometrySelectEdgeHighlightOnly | Get/Set special geometry selection highlighting. Setting this to True makes sence only if GeometrySelectEnabled is set to True as well.
Public property | GeometrySelectEnabled | Get/Set the status of geometry selection mode. Usually this mode is active only when some command panel action is executing.
Public property | GridRotationEnabled |
Public property | GridRotationValue |
Public property | GridTranslationEnabled |
Public property | GridTranslationValue |
Public property | IsHandleVisible | Get/Set the handle visibility.
Public property | IsInteractEnabled | Get/Set the status of Interact mode.
Public property | IsJogEnabled | Get/Set the status of Jog mode.
Public property | IsManipulationEditorEnabled |
Public property | LockedTarget | Locked target prevens setting new target.
Public property | LockObjectCoordinateSystemMatrix |
Public property | LogicalPnpEnabled | Get/Set the status of Logical Plug and play mode.
Public property | MoveEnabled | Get/Set the status of move mode.
Public property | ObjectCoordinateSystemMatrix |
Public property | PnpEnabled | Get/Set the status of plug and play mode.
Public property | RotateXValue | X-axis rotation in degrees.
Public property | RotateYValue | Y-axis rotation in degrees
Public property | RotateZValue | Z-axis rotation in degrees.
Public property | RotationSystem | ABC or XYZ
Public property | SelectEnabled | Get/Set the status of select mode.
Public property | Target | Reference to the previously selected object that is visible in Properties panel. See also IComponentEditorExViewModel.SelectedObject and ITranslationRotationService.Target. See also TeachContext.ActiveRobot instance. When executing SelectionManager.SelectionChanged event this reference is pointing to currently selected item.
Public property | TranslateXValue | X-axis translation value.
Public property | TranslateYValue | Y-axis translation value.
Public property | TranslateZValue | Z-axis translation value.
Top
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.ActiveManipulationMode Property

IManipulateViewModelActiveManipulationMode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ManipulationMode ActiveManipulationMode { get; set; }
property ManipulationMode ActiveManipulationMode {
    ManipulationMode get ();
    void set (ManipulationMode value);
}

Property Value

Type: ManipulationMode
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.ForceLockGeometryToNode Property

IManipulateViewModelForceLockGeometryToNode Property

Alters LockGeometryToNode method to return always true or true only for rope pins of it is set to false

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ForceLockGeometryToNode { get; set; }
property bool ForceLockGeometryToNode {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.GeometrySelectEdgeHighlightOnly Property

IManipulateViewModelGeometrySelectEdgeHighlightOnly Property

Get/Set special geometry selection highlighting. Setting this to True makes sence only if GeometrySelectEnabled is set to True as well.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool GeometrySelectEdgeHighlightOnly { get; set; }
property bool GeometrySelectEdgeHighlightOnly {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.GeometrySelectEnabled Property

IManipulateViewModelGeometrySelectEnabled Property

Get/Set the status of geometry selection mode. Usually this mode is active only when some command panel action is executing.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool GeometrySelectEnabled { get; set; }
property bool GeometrySelectEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.GridRotationEnabled Property

IManipulateViewModelGridRotationEnabled Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool GridRotationEnabled { get; set; }
property bool GridRotationEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.GridRotationValue Property

IManipulateViewModelGridRotationValue Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double GridRotationValue { get; set; }
property double GridRotationValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.GridTranslationEnabled Property

IManipulateViewModelGridTranslationEnabled Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool GridTranslationEnabled { get; set; }
property bool GridTranslationEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.GridTranslationValue Property

IManipulateViewModelGridTranslationValue Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double GridTranslationValue { get; set; }
property double GridTranslationValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.IsHandleVisible Property

IManipulateViewModelIsHandleVisible Property

Get/Set the handle visibility.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsHandleVisible { get; set; }
property bool IsHandleVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.IsInteractEnabled Property

IManipulateViewModelIsInteractEnabled Property

Get/Set the status of Interact mode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsInteractEnabled { get; }
property bool IsInteractEnabled {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.IsJogEnabled Property

IManipulateViewModelIsJogEnabled Property

Get/Set the status of Jog mode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsJogEnabled { get; }
property bool IsJogEnabled {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.IsManipulationEditorEnabled Property

IManipulateViewModelIsManipulationEditorEnabled Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsManipulationEditorEnabled { get; set; }
property bool IsManipulationEditorEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.LockedTarget Property

IManipulateViewModelLockedTarget Property

Locked target prevens setting new target.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool LockedTarget { get; set; }
property bool LockedTarget {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.LockObjectCoordinateSystemMatrix Property

IManipulateViewModelLockObjectCoordinateSystemMatrix Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool LockObjectCoordinateSystemMatrix { get; set; }
property bool LockObjectCoordinateSystemMatrix {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.LogicalPnpEnabled Property

IManipulateViewModelLogicalPnpEnabled Property

Get/Set the status of Logical Plug and play mode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool LogicalPnpEnabled { get; set; }
property bool LogicalPnpEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.MoveEnabled Property

IManipulateViewModelMoveEnabled Property

Get/Set the status of move mode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool MoveEnabled { get; }
property bool MoveEnabled {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.ObjectCoordinateSystemMatrix Property

IManipulateViewModelObjectCoordinateSystemMatrix Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix ObjectCoordinateSystemMatrix { get; }
property Matrix ObjectCoordinateSystemMatrix {
    Matrix get ();
}

Property Value

Type: Matrix
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.PnpEnabled Property

IManipulateViewModelPnpEnabled Property

Get/Set the status of plug and play mode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool PnpEnabled { get; }
property bool PnpEnabled {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.RotateXValue Property

IManipulateViewModelRotateXValue Property

X-axis rotation in degrees.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double RotateXValue { get; set; }
property double RotateXValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.RotateYValue Property

IManipulateViewModelRotateYValue Property

Y-axis rotation in degrees

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double RotateYValue { get; set; }
property double RotateYValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.RotateZValue Property

IManipulateViewModelRotateZValue Property

Z-axis rotation in degrees.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double RotateZValue { get; set; }
property double RotateZValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.RotationSystem Property

IManipulateViewModelRotationSystem Property

ABC or XYZ

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
RotationCoordinateSystem RotationSystem { get; }
property RotationCoordinateSystem RotationSystem {
    RotationCoordinateSystem get ();
}

Property Value

Type: RotationCoordinateSystem
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.SelectEnabled Property

IManipulateViewModelSelectEnabled Property

Get/Set the status of select mode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SelectEnabled { get; }
property bool SelectEnabled {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.Target Property

IManipulateViewModelTarget Property

Reference to the previously selected object that is visible in Properties panel. See also IComponentEditorExViewModel.SelectedObject and ITranslationRotationService.Target. See also TeachContext.ActiveRobot instance. When executing SelectionManager.SelectionChanged event this reference is pointing to currently selected item.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IManipulationTarget Target { get; set; }
property IManipulationTarget^ Target {
    IManipulationTarget^ get ();
    void set (IManipulationTarget^ value);
}

Property Value

Type: IManipulationTarget
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.TranslateXValue Property

IManipulateViewModelTranslateXValue Property

X-axis translation value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double TranslateXValue { get; set; }
property double TranslateXValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.TranslateYValue Property

IManipulateViewModelTranslateYValue Property

Y-axis translation value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double TranslateYValue { get; set; }
property double TranslateYValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.TranslateZValue Property

IManipulateViewModelTranslateZValue Property

Z-axis translation value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double TranslateZValue { get; set; }
property double TranslateZValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel Methods

The IManipulateViewModel type exposes the following members.

Methods
 | Name | Description
Public method | AbortCommands | Temporary helper. Needed because managed c++ cannot see RequestActionAbortMessage class.
Public method | Initialize |
Public method | LockGeometryToNode | Returns true only for rope pins.
Public method | ResetObjectCoordinateSystemMatrix |
Public method | RestorePnpMode | Used to enable Pnp mode when loading a layout or component. Works only in Home context.
Public method | SetActiveManipulationMode | Helper for changing manipulation mode.
Public method | SetSelectionAction | Temporary helper. Needed because managed c++ cannot see SelectAction class.
Public method | UpdateManipulationControl |
Top
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.AbortCommands Method

IManipulateViewModelAbortCommands Method

Temporary helper. Needed because managed c++ cannot see RequestActionAbortMessage class.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AbortCommands(
    string requestedBy
)
void AbortCommands(
    String^ requestedBy
)

Parameters

requestedBy
Type: SystemString
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.Initialize Method

IManipulateViewModelInitialize Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Initialize(
    bool targetActiveRobot
)
void Initialize(
    bool targetActiveRobot
)

Parameters

targetActiveRobot
Type: SystemBoolean
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.LockGeometryToNode Method

IManipulateViewModelLockGeometryToNode Method

Returns true only for rope pins.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool LockGeometryToNode(
    ISimNode node
)
bool LockGeometryToNode(
    ISimNode^ node
)

Parameters

node
Type: VisualComponents.Create3DISimNode

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IManipulateViewModel.LockGeometryToNode(VisualComponents.Create3D.ISimNode)"]

See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.ResetObjectCoordinateSystemMatrix Method

IManipulateViewModelResetObjectCoordinateSystemMatrix Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ResetObjectCoordinateSystemMatrix()
void ResetObjectCoordinateSystemMatrix()
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.RestorePnpMode Method

IManipulateViewModelRestorePnpMode Method

Used to enable Pnp mode when loading a layout or component. Works only in Home context.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RestorePnpMode()
void RestorePnpMode()
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.SetActiveManipulationMode Method

IManipulateViewModelSetActiveManipulationMode Method

Helper for changing manipulation mode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetActiveManipulationMode(
    ManipulationMode mode,
    bool abortCommands,
    bool makePreferred
)
void SetActiveManipulationMode(
    ManipulationMode mode,
    bool abortCommands,
    bool makePreferred
)

Parameters

mode
Type: VisualComponents.Create3DManipulationMode
abortCommands
Type: SystemBoolean
Send abort message
makePreferred
Type: SystemBoolean
Retain this mode in current application context
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.SetSelectionAction Method

IManipulateViewModelSetSelectionAction Method

Temporary helper. Needed because managed c++ cannot see SelectAction class.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetSelectionAction(
    Object item
)
void SetSelectionAction(
    Object^ item
)

Parameters

item
Type: SystemObject
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.UpdateManipulationControl Method

IManipulateViewModelUpdateManipulationControl Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateManipulationControl()
void UpdateManipulationControl()
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel Events

The IManipulateViewModel type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulateViewModel.PropertyChanged Event

IManipulateViewModelPropertyChanged Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event PropertyChangedEventHandler PropertyChanged
 event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler
See Also

Reference

IManipulateViewModel Interface
VisualComponents.Create3D Namespace


IManipulationTarget Interface

Manipulation target object interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IManipulationTarget : ILockableObject,
    IDisposable
public interface class IManipulationTarget : ILockableObject,
    IDisposable

The IManipulationTarget type exposes the following members.

Properties
 | Name | Description
Public property | HandleInObjectCoordinates | Deprecated. Same as TransformationInObject.
Public property | HandleInReference | Deprecated. Same as TransformationInReference.
Public property | HandleInWorld | Deprecated. Same as TransformationInWorld.
Public property | HandleReferenceInWorld | Deprecated. Same as ParentTransformationInWorld.
Public property | IsHandleFixed | Deprecated. Same as IRobotTcpManipulationTarget.IsTcpExternal.
Public property | IsLocked |
Public property | IsTargetEnabled | This is similar to IsLocked, but for manual disabling.
Public property | IsValid |
Public property | IsVisible |
Public property | ParentTransformationInWorld | Position of pivot visual object parent.
Public property | PivotObject |
Public property | TargetObjects | Target objects. May exlude child objects.
Public property | TransformationInObject | Sets the transformation in reference to its own space
Public property | TransformationInReference | Gets or sets the transformation in reference to its parent
Public property | TransformationInWorld | Gets or sets the transformation in world
Top
Methods
 | Name | Description
Public method | ApplyChanges | This is implemented by manipulators that do actual changes on action end or mouse relase. If finalChange==false, then it's only an intermediate change (on mouse release).
Public method | CollectUndoChanges | Collect all changes since the last call to StoreUndoState().
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | StoreUndoState | Store information away to be used when creating an undo change set later.
Top
Events
 | Name | Description
Public event | IsLockedChanged |
Public event | IsVisibleChanged |
Public event | ObjectInvalidated |
Public event | TransformationChanged |
Top
See Also

Reference

VisualComponents.Create3D Namespace


IManipulationTarget Properties

The IManipulationTarget type exposes the following members.

Properties
 | Name | Description
Public property | HandleInObjectCoordinates | Deprecated. Same as TransformationInObject.
Public property | HandleInReference | Deprecated. Same as TransformationInReference.
Public property | HandleInWorld | Deprecated. Same as TransformationInWorld.
Public property | HandleReferenceInWorld | Deprecated. Same as ParentTransformationInWorld.
Public property | IsHandleFixed | Deprecated. Same as IRobotTcpManipulationTarget.IsTcpExternal.
Public property | IsLocked |
Public property | IsTargetEnabled | This is similar to IsLocked, but for manual disabling.
Public property | IsValid |
Public property | IsVisible |
Public property | ParentTransformationInWorld | Position of pivot visual object parent.
Public property | PivotObject |
Public property | TargetObjects | Target objects. May exlude child objects.
Public property | TransformationInObject | Sets the transformation in reference to its own space
Public property | TransformationInReference | Gets or sets the transformation in reference to its parent
Public property | TransformationInWorld | Gets or sets the transformation in world
Top
See Also

Reference

IManipulationTarget Interface
VisualComponents.Create3D Namespace


IManipulationTarget.HandleInObjectCoordinates Property

IManipulationTargetHandleInObjectCoordinates Property

Deprecated. Same as TransformationInObject.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix HandleInObjectCoordinates { get; set; }
property Matrix HandleInObjectCoordinates {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

IManipulationTarget Interface
VisualComponents.Create3D Namespace


IManipulationTarget.HandleInReference Property

IManipulationTargetHandleInReference Property

Deprecated. Same as TransformationInReference.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix HandleInReference { get; set; }
property Matrix HandleInReference {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

IManipulationTarget Interface
VisualComponents.Create3D Namespace


IManipulationTarget.HandleInWorld Property

IManipulationTargetHandleInWorld Property

Deprecated. Same as TransformationInWorld.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix HandleInWorld { get; set; }
property Matrix HandleInWorld {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

IManipulationTarget Interface
VisualComponents.Create3D Namespace


IManipulationTarget.HandleReferenceInWorld Property

IManipulationTargetHandleReferenceInWorld Property

Deprecated. Same as ParentTransformationInWorld.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix HandleReferenceInWorld { get; }
property Matrix HandleReferenceInWorld {
    Matrix get ();
}

Property Value

Type: Matrix
See Also

Reference

IManipulationTarget Interface
VisualComponents.Create3D Namespace


IManipulationTarget.IsHandleFixed Property

IManipulationTargetIsHandleFixed Property

Deprecated. Same as IRobotTcpManipulationTarget.IsTcpExternal.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsHandleFixed { get; }
property bool IsHandleFixed {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IManipulationTarget Interface
VisualComponents.Create3D Namespace


IManipulationTarget.IsLocked Property

IManipulationTargetIsLocked Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsLocked { get; set; }
property bool IsLocked {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

ILockableObjectIsLocked
See Also

Reference

IManipulationTarget Interface
VisualComponents.Create3D Namespace


IManipulationTarget.IsTargetEnabled Property

IManipulationTargetIsTargetEnabled Property

This is similar to IsLocked, but for manual disabling.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsTargetEnabled { get; set; }
property bool IsTargetEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IManipulationTarget Interface
VisualComponents.Create3D Namespace


IManipulationTarget.IsValid Property

IManipulationTargetIsValid Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsValid { get; }
property bool IsValid {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IManipulationTarget Interface
VisualComponents.Create3D Namespace


IManipulationTarget.IsVisible Property

IManipulationTargetIsVisible Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsVisible { get; }
property bool IsVisible {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IManipulationTarget Interface
VisualComponents.Create3D Namespace


IManipulationTarget.ParentTransformationInWorld Property

IManipulationTargetParentTransformationInWorld Property

Position of pivot visual object parent.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix ParentTransformationInWorld { get; }
property Matrix ParentTransformationInWorld {
    Matrix get ();
}

Property Value

Type: Matrix
See Also

Reference

IManipulationTarget Interface
VisualComponents.Create3D Namespace


IManipulationTarget.PivotObject Property

IManipulationTargetPivotObject Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object PivotObject { get; }
property Object^ PivotObject {
    Object^ get ();
}

Property Value

Type: Object
See Also

Reference

IManipulationTarget Interface
VisualComponents.Create3D Namespace


IManipulationTarget.TargetObjects Property

IManipulationTargetTargetObjects Property

Target objects. May exlude child objects.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<Object> TargetObjects { get; }
property IEnumerable<Object^>^ TargetObjects {
    IEnumerable<Object^>^ get ();
}

Property Value

Type: IEnumerableObject
See Also

Reference

IManipulationTarget Interface
VisualComponents.Create3D Namespace


IManipulationTarget.TransformationInObject Property

IManipulationTargetTransformationInObject Property

Sets the transformation in reference to its own space

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix TransformationInObject { set; }
property Matrix TransformationInObject {
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

IManipulationTarget Interface
VisualComponents.Create3D Namespace


IManipulationTarget.TransformationInReference Property

IManipulationTargetTransformationInReference Property

Gets or sets the transformation in reference to its parent

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix TransformationInReference { get; set; }
property Matrix TransformationInReference {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

IManipulationTarget Interface
VisualComponents.Create3D Namespace


IManipulationTarget.TransformationInWorld Property

IManipulationTargetTransformationInWorld Property

Gets or sets the transformation in world

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix TransformationInWorld { get; set; }
property Matrix TransformationInWorld {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

IManipulationTarget Interface
VisualComponents.Create3D Namespace


IManipulationTarget Methods

The IManipulationTarget type exposes the following members.

Methods
 | Name | Description
Public method | ApplyChanges | This is implemented by manipulators that do actual changes on action end or mouse relase. If finalChange==false, then it's only an intermediate change (on mouse release).
Public method | CollectUndoChanges | Collect all changes since the last call to StoreUndoState().
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | StoreUndoState | Store information away to be used when creating an undo change set later.
Top
See Also

Reference

IManipulationTarget Interface
VisualComponents.Create3D Namespace


IManipulationTarget.ApplyChanges Method

IManipulationTargetApplyChanges Method

This is implemented by manipulators that do actual changes on action end or mouse relase. If finalChange==false, then it's only an intermediate change (on mouse release).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ApplyChanges(
    bool finalChange
)
void ApplyChanges(
    bool finalChange
)

Parameters

finalChange
Type: SystemBoolean
See Also

Reference

IManipulationTarget Interface
VisualComponents.Create3D Namespace


IManipulationTarget.CollectUndoChanges Method

IManipulationTargetCollectUndoChanges Method

Collect all changes since the last call to StoreUndoState().

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void CollectUndoChanges(
    UndoScope targetScope
)
void CollectUndoChanges(
    UndoScope^ targetScope
)

Parameters

targetScope
Type: VisualComponents.Create3DUndoScope
See Also

Reference

IManipulationTarget Interface
VisualComponents.Create3D Namespace


IManipulationTarget.StoreUndoState Method

IManipulationTargetStoreUndoState Method

Store information away to be used when creating an undo change set later.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StoreUndoState()
void StoreUndoState()
See Also

Reference

IManipulationTarget Interface
VisualComponents.Create3D Namespace


IManipulationTarget Events

The IManipulationTarget type exposes the following members.

Events
 | Name | Description
Public event | IsLockedChanged |
Public event | IsVisibleChanged |
Public event | ObjectInvalidated |
Public event | TransformationChanged |
Top
See Also

Reference

IManipulationTarget Interface
VisualComponents.Create3D Namespace


IManipulationTarget.IsLockedChanged Event

IManipulationTargetIsLockedChanged Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> IsLockedChanged
 event EventHandler<EventArgs^>^ IsLockedChanged {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs

Implements

ILockableObjectIsLockedChanged
See Also

Reference

IManipulationTarget Interface
VisualComponents.Create3D Namespace


IManipulationTarget.IsVisibleChanged Event

IManipulationTargetIsVisibleChanged Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> IsVisibleChanged
 event EventHandler<EventArgs^>^ IsVisibleChanged {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

IManipulationTarget Interface
VisualComponents.Create3D Namespace


IManipulationTarget.ObjectInvalidated Event

IManipulationTargetObjectInvalidated Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler ObjectInvalidated
 event EventHandler^ ObjectInvalidated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IManipulationTarget Interface
VisualComponents.Create3D Namespace


IManipulationTarget.TransformationChanged Event

IManipulationTargetTransformationChanged Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> TransformationChanged
 event EventHandler<EventArgs^>^ TransformationChanged {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

IManipulationTarget Interface
VisualComponents.Create3D Namespace


IManipulator Interface

Identifies 3D WPF manipulators. (not related to System.Windows.Input.IManipulator, nor HelixToolkit.Wpf.Manipulator)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IManipulator
public interface class IManipulator

The IManipulator type exposes the following members.

Properties
 | Name | Description
Public property | UseManipulator |
Top
Remarks
Pay attention that WPF rendering is not as robust as native Direct3D. Avoid using complex geometries for handle representation.
See Also

Reference

VisualComponents.Create3D Namespace


IManipulator Properties

The IManipulator type exposes the following members.

Properties
 | Name | Description
Public property | UseManipulator |
Top
See Also

Reference

IManipulator Interface
VisualComponents.Create3D Namespace


IManipulator.UseManipulator Property

IManipulatorUseManipulator Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool UseManipulator { get; set; }
property bool UseManipulator {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IManipulator Interface
VisualComponents.Create3D Namespace


IMaterial Interface

Material interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IMaterial : IWrapper,
    IDisposable, IPropertyContainer, IBatchModeObject
public interface class IMaterial : IWrapper,
    IDisposable, IPropertyContainer, IBatchModeObject

The IMaterial type exposes the following members.

Properties
 | Name | Description
Public property | Ambient | RGBA Color representing the ambient.
Public property | BumpMap | Bumpmap bitmap
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Color | RGBA Color of this material (aka Diffuse color).
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Emissive | RGBA Color representing the emisive. The emissive component is applied evenly as is to the geometry. It is used to simulate stuff that glows in the dark.
Public property | HasShader | Defines if material has or not shader
Public property | HasTexture | Defines if the material has texture bitmap or not.
Public property | IsHidden | Defines if the material is hidden from the UI controls. This happens when the material name has '#' or '_' symbol at the beginning of its name
Public property | IsSystem | Defines if the material can be consider as part of the application material library. Remarks System materials stay in the system after closing the layout. Creating a system material does not imply that the material will be stored in the application.
Public property | IsUserDefined | Defines if the material is part of the user material library Remarks Setting true to this property does not impliy that the material will be stored, for that use IUserMaterialLibraryService.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets the name of this IMaterial instance.
Public property | Opacity | Defines Opacity value.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Shininess | The shininess is the value to which an exponent is applied to calculate the strength of the specular component.
Public property | Specular | RGBA Color representing the specular.
Public property | Texture | Texture bitmap
Public property | TextureFilter | Used when having texture in the material
Public property | TextureMapping | Texture mapping on or off.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ForceUpdate | Force material to update
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetShaderAttributeT | Get Shader's attributes defined by name
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetShader | For Internal use
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IMaterial Properties

The IMaterial type exposes the following members.

Properties
 | Name | Description
Public property | Ambient | RGBA Color representing the ambient.
Public property | BumpMap | Bumpmap bitmap
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Color | RGBA Color of this material (aka Diffuse color).
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Emissive | RGBA Color representing the emisive. The emissive component is applied evenly as is to the geometry. It is used to simulate stuff that glows in the dark.
Public property | HasShader | Defines if material has or not shader
Public property | HasTexture | Defines if the material has texture bitmap or not.
Public property | IsHidden | Defines if the material is hidden from the UI controls. This happens when the material name has '#' or '_' symbol at the beginning of its name
Public property | IsSystem | Defines if the material can be consider as part of the application material library. Remarks System materials stay in the system after closing the layout. Creating a system material does not imply that the material will be stored in the application.
Public property | IsUserDefined | Defines if the material is part of the user material library Remarks Setting true to this property does not impliy that the material will be stored, for that use IUserMaterialLibraryService.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets the name of this IMaterial instance.
Public property | Opacity | Defines Opacity value.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Shininess | The shininess is the value to which an exponent is applied to calculate the strength of the specular component.
Public property | Specular | RGBA Color representing the specular.
Public property | Texture | Texture bitmap
Public property | TextureFilter | Used when having texture in the material
Public property | TextureMapping | Texture mapping on or off.
Top
See Also

Reference

IMaterial Interface
VisualComponents.Create3D Namespace


IMaterial.Ambient Property

IMaterialAmbient Property

RGBA Color representing the ambient.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Color Ambient { get; set; }
property Color Ambient {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

IMaterial Interface
VisualComponents.Create3D Namespace


IMaterial.BumpMap Property

IMaterialBumpMap Property

Bumpmap bitmap

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Bitmap BumpMap { get; set; }
property Bitmap^ BumpMap {
    Bitmap^ get ();
    void set (Bitmap^ value);
}

Property Value

Type: Bitmap
See Also

Reference

IMaterial Interface
VisualComponents.Create3D Namespace


IMaterial.Color Property

IMaterialColor Property

RGBA Color of this material (aka Diffuse color).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Color Color { get; set; }
property Color Color {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

IMaterial Interface
VisualComponents.Create3D Namespace


IMaterial.Emissive Property

IMaterialEmissive Property

RGBA Color representing the emisive. The emissive component is applied evenly as is to the geometry. It is used to simulate stuff that glows in the dark.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Color Emissive { get; set; }
property Color Emissive {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

IMaterial Interface
VisualComponents.Create3D Namespace


IMaterial.HasShader Property

IMaterialHasShader Property

Defines if material has or not shader

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool HasShader { get; }
property bool HasShader {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IMaterial Interface
VisualComponents.Create3D Namespace


IMaterial.HasTexture Property

IMaterialHasTexture Property

Defines if the material has texture bitmap or not.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool HasTexture { get; }
property bool HasTexture {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IMaterial Interface
VisualComponents.Create3D Namespace


IMaterial.IsHidden Property

IMaterialIsHidden Property

Defines if the material is hidden from the UI controls. This happens when the material name has '#' or '_' symbol at the beginning of its name

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsHidden { get; }
property bool IsHidden {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IMaterial Interface
VisualComponents.Create3D Namespace


IMaterial.IsSystem Property

IMaterialIsSystem Property

Defines if the material can be consider as part of the application material library.
Remarks
System materials stay in the system after closing the layout. Creating a system material does not imply that the material will be stored in the application.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsSystem { get; }
property bool IsSystem {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IMaterial Interface
VisualComponents.Create3D Namespace


IMaterial.IsUserDefined Property

IMaterialIsUserDefined Property

Defines if the material is part of the user material library
Remarks
Setting true to this property does not impliy that the material will be stored, for that use IUserMaterialLibraryService.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsUserDefined { get; set; }
property bool IsUserDefined {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IMaterial Interface
VisualComponents.Create3D Namespace


IMaterial.Name Property

IMaterialName Property

Gets the name of this IMaterial instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Name { get; set; }
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IMaterial Interface
VisualComponents.Create3D Namespace


IMaterial.Opacity Property

IMaterialOpacity Property

Defines Opacity value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
byte Opacity { get; set; }
property unsigned char Opacity {
    unsigned char get ();
    void set (unsigned char value);
}

Property Value

Type: Byte
See Also

Reference

IMaterial Interface
VisualComponents.Create3D Namespace


IMaterial.Shininess Property

IMaterialShininess Property

The shininess is the value to which an exponent is applied to calculate the strength of the specular component.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Shininess { get; set; }
property double Shininess {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IMaterial Interface
VisualComponents.Create3D Namespace


IMaterial.Specular Property

IMaterialSpecular Property

RGBA Color representing the specular.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Color Specular { get; set; }
property Color Specular {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

IMaterial Interface
VisualComponents.Create3D Namespace


IMaterial.Texture Property

IMaterialTexture Property

Texture bitmap

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Bitmap Texture { get; set; }
property Bitmap^ Texture {
    Bitmap^ get ();
    void set (Bitmap^ value);
}

Property Value

Type: Bitmap
See Also

Reference

IMaterial Interface
VisualComponents.Create3D Namespace


IMaterial.TextureFilter Property

IMaterialTextureFilter Property

Used when having texture in the material

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMaterialTextureFilter TextureFilter { get; set; }
property IMaterialTextureFilter TextureFilter {
    IMaterialTextureFilter get ();
    void set (IMaterialTextureFilter value);
}

Property Value

Type: IMaterialTextureFilter
See Also

Reference

IMaterial Interface
VisualComponents.Create3D Namespace


IMaterial.TextureMapping Property

IMaterialTextureMapping Property

Texture mapping on or off.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool TextureMapping { get; set; }
property bool TextureMapping {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IMaterial Interface
VisualComponents.Create3D Namespace


IMaterial Methods

The IMaterial type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ForceUpdate | Force material to update
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetShaderAttributeT | Get Shader's attributes defined by name
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetShader | For Internal use
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IMaterial Interface
VisualComponents.Create3D Namespace


IMaterial.ForceUpdate Method

IMaterialForceUpdate Method

Force material to update

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ForceUpdate()
void ForceUpdate()
See Also

Reference

IMaterial Interface
VisualComponents.Create3D Namespace


IMaterial.GetShaderAttribute(T) Method

IMaterialGetShaderAttributeT Method

Get Shader's attributes defined by name

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
T GetShaderAttribute<T>(
    string name
)

generic<typename T>
T GetShaderAttribute(
    String^ name
)

Parameters

name
Type: SystemString
name of the attributes

Type Parameters

T

Return Value

Type: T
value of the attributes
See Also

Reference

IMaterial Interface
VisualComponents.Create3D Namespace


IMaterial.SetShader Method

IMaterialSetShader Method

For Internal use

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetShader(
    string shaderName
)
void SetShader(
    String^ shaderName
)

Parameters

shaderName
Type: SystemString
See Also

Reference

IMaterial Interface
VisualComponents.Create3D Namespace


IMaterial Events

The IMaterial type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IMaterial Interface
VisualComponents.Create3D Namespace


IMaterialProperty Interface

Interface for material properties Provides more information about this type of property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IMaterialProperty : IProperty,
    INotifyPropertyChanged, IDisposable, INamed
public interface class IMaterialProperty : IProperty,
    INotifyPropertyChanged, IDisposable, INamed

The IMaterialProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Allowed maximum value for the property. (Inherited from IProperty.)
Public property | AllowedMinimum | Allowed minimum value for the property. (Inherited from IProperty.)
Public property | AllowedValues | Collection of allowed values for constrained properties. (Inherited from IProperty.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | MaterialByName | Sets the material based on the given name or gets the material name. Remarks If material is not found, material property is set to null
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Property value as an object. (Inherited from IProperty.)
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IMaterialProperty Properties

The IMaterialProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Allowed maximum value for the property. (Inherited from IProperty.)
Public property | AllowedMinimum | Allowed minimum value for the property. (Inherited from IProperty.)
Public property | AllowedValues | Collection of allowed values for constrained properties. (Inherited from IProperty.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | MaterialByName | Sets the material based on the given name or gets the material name. Remarks If material is not found, material property is set to null
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Property value as an object. (Inherited from IProperty.)
Top
See Also

Reference

IMaterialProperty Interface
VisualComponents.Create3D Namespace


IMaterialProperty.MaterialByName Property

IMaterialPropertyMaterialByName Property

Sets the material based on the given name or gets the material name.
Remarks
If material is not found, material property is set to null

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string MaterialByName { get; set; }
property String^ MaterialByName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IMaterialProperty Interface
VisualComponents.Create3D Namespace


IMaterialProperty Methods

The IMaterialProperty type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

IMaterialProperty Interface
VisualComponents.Create3D Namespace


IMaterialProperty Events

The IMaterialProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IMaterialProperty Interface
VisualComponents.Create3D Namespace


IMaterialTextureFilter Enumeration

Defines texture filtering modes for a texture rendering.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum IMaterialTextureFilter
public enum class IMaterialTextureFilter
Members
Member name | Value | Description
Point | 0 | enables mipmapping and specifies that the rasterizer chooses the color from the texel of the nearest mip level
Linear | 1 | enables mipmapping and trilinear filtering; it specifies that the rasterizer interpolates between the two nearest mip levels
Anisotropic | 2 | Compensates for distortion caused by the difference in angle between the texture polygon and the plane of the screen
See Also

Reference

VisualComponents.Create3D Namespace


IMathematicalFace Interface

Interface that provides addtional methods of a ITopologyFace which is of type Nurbs or Offset.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IMathematicalFace : IFace
public interface class IMathematicalFace : IFace

The IMathematicalFace type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Returns face bound information using the matrix as bound box center position and orientation. The second vector defines the bound box half diagonal. The bound box is aligned into the geometry coordinate system. It is calculated from tessellated data.
Public property | Domain | Get the parameteric UV domain of a face (first value of the tuple is the minimum, the other is the maximum)
Public property | FaceIndex | Face index inside the triangle set (Inherited from IFace.)
Public property | FaceType | Returns the face type (Inherited from IFace.)
Public property | IsHighlighted | Determines if the face is highlighted (Inherited from IFace.)
Public property | IsOuterLoopArc | Determines if an outer loop arc (Inherited from IFace.)
Public property | IsPlanar | Determines if the face is planar (Inherited from IFace.)
Public property | IsValid | Determines if this face wrapper instance is still valid (Inherited from IFace.)
Public property | MathematicalFace | If this is a matematical face, this will give you access to addtional operation for this type of faces (Inherited from IFace.)
Public property | Offset | Offset distance (0 for non-offset interfaces)
Public property | Properties | Returns a tuple with the center and normal of the face (Inherited from IFace.)
Public property | StartTriangle | First triangle index in this face (Inherited from IFace.)
Public property | Surface | Underlying surface
Public property | TopologyFace | Returns related topology face. (Inherited from IFace.)
Public property | TopologyPolylineCount | For tesselated faces it returns 0, otherwise the number of face loops (Inherited from IFace.)
Public property | TriangleCount | Number of triangles in this face (Inherited from IFace.)
Public property | TriangleSet | Owner ITriangleSet (Inherited from IFace.)
Top
Methods
 | Name | Description
Public method | CalculateBoundingBox | Calculate the normal axis aligned bounding box of the Face
Public method | DropCurve | This method will create a set of curves corresponding to the normal projection of a curve onto the trimmed face
Public method | Equals | Comparares if 2 IFace objects referred to the same instance (Inherited from IFace.)
Public method | EvaluateGeometric | Compute various geometric properties at a point on a surface.
Public method | GetClosestCurve | Find face curve that is closest to ray. (Inherited from IFace.)
Public method | GetClosestCurvePoint(Vector3) | Returns the closest curve point regarding a reference point (Inherited from IFace.)
Public method | GetClosestCurvePoint(Vector3, Int32, Vector3, Int32, Int32) | Returns the closest curve point regarding a reference point (Inherited from IFace.)
Public method | GetClosestFacePoint | Returns the closest face point regarding a reference point (Inherited from IFace.)
Public method | GetClosestPoint | Closest point in face from given point
Public method | GetClosestTriangle | For tesselated faces, returns the closet triangle index regarding a reference point (Inherited from IFace.)
Public method | GetClosestTriangleEdge | Returns the closest triangle edge regarding a reference point (Inherited from IFace.)
Public method | GetClosestUV | Closest U,V coordinate in face from given point
Public method | GetFaceMinDistance | Minimun distance to face from given point
Public method | GetFaceNormal | Gets the normal of a points given u, v coordinates
Public method | GetFacePoint | Gets a point from given u, v coordinates
Public method | GetFacePointAndDerivate | Returns the point and U and V direction first derivates at the given face (surface) parametric UV coordinate location
Public method | GetFacePointAndSecondDerivate | Evaluate a point, partial first, and partial second derivatives of a surface.
Public method | GetHashCode | internal purpose only (Inherited from IFace.)
Public method | GetIntersection(Vector3, Vector3) | Intersect points between the given points. (Inherited from IFace.)
Public method | GetIntersection(Vector3, Vector3, Boolean) | Intersect points between the given points. (Inherited from IFace.)
Public method | GetPlaneIntersections | Returns face intersection (curve) points using plane defined by Matrix intersecting face (Inherited from IFace.)
Public method | GetTopologyPolyline(NullableMatrix) | Returns a list of all points of all polylines in the given coordinate system (Inherited from IFace.)
Public method | GetTopologyPolyline(NullableMatrix, Int32) | Returns a list of all points of all polylines in the given coordinate system (Inherited from IFace.)
Public method | IsOnFace(Vector3) | Evaluates if a 3d point lies on the face
Public method | IsOnFace(Double, Double) | Evaluate if the given u,v point lies on the boundaries of the face
Public method | IsSurfaceLinear | Determines if surface is linear in both u and v space
Public method | NeighborFaces | Returns a set of faces that are neighbor with this face. The set of faces includes this face as well (Inherited from IFace.)
Public method | ProjectCurve | Projects a curve that belongs to the given line set into this face, the result is placed in the given output line set
Public method | SwapUV | Swap the UV of the surface of a face and all curves.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IMathematicalFace Properties

The IMathematicalFace type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Returns face bound information using the matrix as bound box center position and orientation. The second vector defines the bound box half diagonal. The bound box is aligned into the geometry coordinate system. It is calculated from tessellated data.
Public property | Domain | Get the parameteric UV domain of a face (first value of the tuple is the minimum, the other is the maximum)
Public property | FaceIndex | Face index inside the triangle set (Inherited from IFace.)
Public property | FaceType | Returns the face type (Inherited from IFace.)
Public property | IsHighlighted | Determines if the face is highlighted (Inherited from IFace.)
Public property | IsOuterLoopArc | Determines if an outer loop arc (Inherited from IFace.)
Public property | IsPlanar | Determines if the face is planar (Inherited from IFace.)
Public property | IsValid | Determines if this face wrapper instance is still valid (Inherited from IFace.)
Public property | MathematicalFace | If this is a matematical face, this will give you access to addtional operation for this type of faces (Inherited from IFace.)
Public property | Offset | Offset distance (0 for non-offset interfaces)
Public property | Properties | Returns a tuple with the center and normal of the face (Inherited from IFace.)
Public property | StartTriangle | First triangle index in this face (Inherited from IFace.)
Public property | Surface | Underlying surface
Public property | TopologyFace | Returns related topology face. (Inherited from IFace.)
Public property | TopologyPolylineCount | For tesselated faces it returns 0, otherwise the number of face loops (Inherited from IFace.)
Public property | TriangleCount | Number of triangles in this face (Inherited from IFace.)
Public property | TriangleSet | Owner ITriangleSet (Inherited from IFace.)
Top
See Also

Reference

IMathematicalFace Interface
VisualComponents.Create3D Namespace


IMathematicalFace.Bounds Property

IMathematicalFaceBounds Property

Returns face bound information using the matrix as bound box center position and orientation. The second vector defines the bound box half diagonal. The bound box is aligned into the geometry coordinate system. It is calculated from tessellated data.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Tuple<Matrix, Vector3> Bounds { get; }
property Tuple<Matrix, Vector3>^ Bounds {
    Tuple<Matrix, Vector3>^ get ();
}

Property Value

Type: TupleMatrix, Vector3
See Also

Reference

IMathematicalFace Interface
VisualComponents.Create3D Namespace


IMathematicalFace.Domain Property

IMathematicalFaceDomain Property

Get the parameteric UV domain of a face (first value of the tuple is the minimum, the other is the maximum)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Tuple<TexturePoint, TexturePoint> Domain { get; }
property Tuple<TexturePoint, TexturePoint>^ Domain {
    Tuple<TexturePoint, TexturePoint>^ get ();
}

Property Value

Type: TupleTexturePoint, TexturePoint
See Also

Reference

IMathematicalFace Interface
VisualComponents.Create3D Namespace


IMathematicalFace.Offset Property

IMathematicalFaceOffset Property

Offset distance (0 for non-offset interfaces)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Offset { get; }
property double Offset {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IMathematicalFace Interface
VisualComponents.Create3D Namespace


IMathematicalFace.Surface Property

IMathematicalFaceSurface Property

Underlying surface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Surface Surface { get; }
property Surface^ Surface {
    Surface^ get ();
}

Property Value

Type: Surface
See Also

Reference

IMathematicalFace Interface
VisualComponents.Create3D Namespace


IMathematicalFace Methods

The IMathematicalFace type exposes the following members.

Methods
 | Name | Description
Public method | CalculateBoundingBox | Calculate the normal axis aligned bounding box of the Face
Public method | DropCurve | This method will create a set of curves corresponding to the normal projection of a curve onto the trimmed face
Public method | Equals | Comparares if 2 IFace objects referred to the same instance (Inherited from IFace.)
Public method | EvaluateGeometric | Compute various geometric properties at a point on a surface.
Public method | GetClosestCurve | Find face curve that is closest to ray. (Inherited from IFace.)
Public method | GetClosestCurvePoint(Vector3) | Returns the closest curve point regarding a reference point (Inherited from IFace.)
Public method | GetClosestCurvePoint(Vector3, Int32, Vector3, Int32, Int32) | Returns the closest curve point regarding a reference point (Inherited from IFace.)
Public method | GetClosestFacePoint | Returns the closest face point regarding a reference point (Inherited from IFace.)
Public method | GetClosestPoint | Closest point in face from given point
Public method | GetClosestTriangle | For tesselated faces, returns the closet triangle index regarding a reference point (Inherited from IFace.)
Public method | GetClosestTriangleEdge | Returns the closest triangle edge regarding a reference point (Inherited from IFace.)
Public method | GetClosestUV | Closest U,V coordinate in face from given point
Public method | GetFaceMinDistance | Minimun distance to face from given point
Public method | GetFaceNormal | Gets the normal of a points given u, v coordinates
Public method | GetFacePoint | Gets a point from given u, v coordinates
Public method | GetFacePointAndDerivate | Returns the point and U and V direction first derivates at the given face (surface) parametric UV coordinate location
Public method | GetFacePointAndSecondDerivate | Evaluate a point, partial first, and partial second derivatives of a surface.
Public method | GetHashCode | internal purpose only (Inherited from IFace.)
Public method | GetIntersection(Vector3, Vector3) | Intersect points between the given points. (Inherited from IFace.)
Public method | GetIntersection(Vector3, Vector3, Boolean) | Intersect points between the given points. (Inherited from IFace.)
Public method | GetPlaneIntersections | Returns face intersection (curve) points using plane defined by Matrix intersecting face (Inherited from IFace.)
Public method | GetTopologyPolyline(NullableMatrix) | Returns a list of all points of all polylines in the given coordinate system (Inherited from IFace.)
Public method | GetTopologyPolyline(NullableMatrix, Int32) | Returns a list of all points of all polylines in the given coordinate system (Inherited from IFace.)
Public method | IsOnFace(Vector3) | Evaluates if a 3d point lies on the face
Public method | IsOnFace(Double, Double) | Evaluate if the given u,v point lies on the boundaries of the face
Public method | IsSurfaceLinear | Determines if surface is linear in both u and v space
Public method | NeighborFaces | Returns a set of faces that are neighbor with this face. The set of faces includes this face as well (Inherited from IFace.)
Public method | ProjectCurve | Projects a curve that belongs to the given line set into this face, the result is placed in the given output line set
Public method | SwapUV | Swap the UV of the surface of a face and all curves.
Top
See Also

Reference

IMathematicalFace Interface
VisualComponents.Create3D Namespace


IMathematicalFace.CalculateBoundingBox Method

IMathematicalFaceCalculateBoundingBox Method

Calculate the normal axis aligned bounding box of the Face

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Tuple<Vector3, Vector3> CalculateBoundingBox(
    bool tight
)
Tuple<Vector3, Vector3>^ CalculateBoundingBox(
    bool tight
)

Parameters

tight
Type: SystemBoolean
TRUE = compute minimal box (expensive), FALSE = compute any box larger than this Face (cheaper)

Return Value

Type: TupleVector3, Vector3

[Missing <returns> documentation for "M:VisualComponents.Create3D.IMathematicalFace.CalculateBoundingBox(System.Boolean)"]

See Also

Reference

IMathematicalFace Interface
VisualComponents.Create3D Namespace


IMathematicalFace.DropCurve Method

IMathematicalFaceDropCurve Method

This method will create a set of curves corresponding to the normal projection of a curve onto the trimmed face

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool DropCurve(
    ILineSet inputCurveSet,
    int curveIndex,
    double approximateTolerance,
    ILineSet outputCurveSet
)
bool DropCurve(
    ILineSet^ inputCurveSet,
    int curveIndex,
    double approximateTolerance,
    ILineSet^ outputCurveSet
)

Parameters

inputCurveSet
Type: VisualComponents.Create3DILineSet
input line set
curveIndex
Type: SystemInt32
curve index of the input line set
approximateTolerance
Type: SystemDouble
max allowed distance to project curve to faces and max allowed deviation of projected curve to TRUE projection shape
outputCurveSet
Type: VisualComponents.Create3DILineSet
output line set

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IMathematicalFace.DropCurve(VisualComponents.Create3D.ILineSet,System.Int32,System.Double,VisualComponents.Create3D.ILineSet)"]

See Also

Reference

IMathematicalFace Interface
VisualComponents.Create3D Namespace


IMathematicalFace.EvaluateGeometric Method

IMathematicalFaceEvaluateGeometric Method

Compute various geometric properties at a point on a surface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
SurfaceGeometric EvaluateGeometric(
    TexturePoint uv
)
SurfaceGeometric EvaluateGeometric(
    TexturePoint uv
)

Parameters

uv
Type: VisualComponents.Create3DTexturePoint

Return Value

Type: SurfaceGeometric
Gaussian Curvature Mean Curvature 1st principal curvature value 2st principal curvature value 1st fundamental form 2st fundamental form 3d vector tangent to surface in 1st principal direction 3d vector tangent to surface in 2nd principal direction
See Also

Reference

IMathematicalFace Interface
VisualComponents.Create3D Namespace


IMathematicalFace.GetClosestPoint Method

IMathematicalFaceGetClosestPoint Method

Closest point in face from given point

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 GetClosestPoint(
    Vector3 points
)
Vector3 GetClosestPoint(
    Vector3 points
)

Parameters

points
Type: VisualComponents.Create3DVector3

Return Value

Type: Vector3

[Missing <returns> documentation for "M:VisualComponents.Create3D.IMathematicalFace.GetClosestPoint(VisualComponents.Create3D.Vector3)"]

See Also

Reference

IMathematicalFace Interface
VisualComponents.Create3D Namespace


IMathematicalFace.GetClosestUV Method

IMathematicalFaceGetClosestUV Method

Closest U,V coordinate in face from given point

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
TexturePoint GetClosestUV(
    Vector3 point
)
TexturePoint GetClosestUV(
    Vector3 point
)

Parameters

point
Type: VisualComponents.Create3DVector3

Return Value

Type: TexturePoint
U,V coordinate
See Also

Reference

IMathematicalFace Interface
VisualComponents.Create3D Namespace


IMathematicalFace.GetFaceMinDistance Method

IMathematicalFaceGetFaceMinDistance Method

Minimun distance to face from given point

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double GetFaceMinDistance(
    Vector3 points
)
double GetFaceMinDistance(
    Vector3 points
)

Parameters

points
Type: VisualComponents.Create3DVector3

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.Create3D.IMathematicalFace.GetFaceMinDistance(VisualComponents.Create3D.Vector3)"]

See Also

Reference

IMathematicalFace Interface
VisualComponents.Create3D Namespace


IMathematicalFace.GetFaceNormal Method

IMathematicalFaceGetFaceNormal Method

Gets the normal of a points given u, v coordinates

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Nullable<Vector3> GetFaceNormal(
    double u,
    double v
)
Nullable<Vector3> GetFaceNormal(
    double u,
    double v
)

Parameters

u
Type: SystemDouble
v
Type: SystemDouble

Return Value

Type: NullableVector3
null if u,v coordinate do not lie on the face
See Also

Reference

IMathematicalFace Interface
VisualComponents.Create3D Namespace


IMathematicalFace.GetFacePoint Method

IMathematicalFaceGetFacePoint Method

Gets a point from given u, v coordinates

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Nullable<Vector3> GetFacePoint(
    double u,
    double v
)
Nullable<Vector3> GetFacePoint(
    double u,
    double v
)

Parameters

u
Type: SystemDouble
v
Type: SystemDouble

Return Value

Type: NullableVector3
null if u,v coordinate do not lie on the face
See Also

Reference

IMathematicalFace Interface
VisualComponents.Create3D Namespace


IMathematicalFace.GetFacePointAndDerivate Method

IMathematicalFaceGetFacePointAndDerivate Method

Returns the point and U and V direction first derivates at the given face (surface) parametric UV coordinate location

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
FacePointAndFirstDerivate GetFacePointAndDerivate(
    TexturePoint uv
)
FacePointAndFirstDerivate GetFacePointAndDerivate(
    TexturePoint uv
)

Parameters

uv
Type: VisualComponents.Create3DTexturePoint

Return Value

Type: FacePointAndFirstDerivate
position,u and v direction tangent vectors
See Also

Reference

IMathematicalFace Interface
VisualComponents.Create3D Namespace


IMathematicalFace.GetFacePointAndSecondDerivate Method

IMathematicalFaceGetFacePointAndSecondDerivate Method

Evaluate a point, partial first, and partial second derivatives of a surface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
FacePointAndSecondDerivate GetFacePointAndSecondDerivate(
    TexturePoint uv
)
FacePointAndSecondDerivate GetFacePointAndSecondDerivate(
    TexturePoint uv
)

Parameters

uv
Type: VisualComponents.Create3DTexturePoint
position,u , v , uv, uu and vv direction tangent vectors

Return Value

Type: FacePointAndSecondDerivate

[Missing <returns> documentation for "M:VisualComponents.Create3D.IMathematicalFace.GetFacePointAndSecondDerivate(VisualComponents.Create3D.TexturePoint)"]

See Also

Reference

IMathematicalFace Interface
VisualComponents.Create3D Namespace


IMathematicalFace.IsOnFace Method

IMathematicalFaceIsOnFace Method

Overload List
 | Name | Description
Public method | IsOnFace(Vector3) | Evaluates if a 3d point lies on the face
Public method | IsOnFace(Double, Double) | Evaluate if the given u,v point lies on the boundaries of the face
Top
See Also

Reference

IMathematicalFace Interface
VisualComponents.Create3D Namespace


IMathematicalFace.IsOnFace Method (Vector3)

IMathematicalFaceIsOnFace Method (Vector3)

Evaluates if a 3d point lies on the face

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsOnFace(
    Vector3 point
)
bool IsOnFace(
    Vector3 point
)

Parameters

point
Type: VisualComponents.Create3DVector3

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IMathematicalFace.IsOnFace(VisualComponents.Create3D.Vector3)"]

See Also

Reference

IMathematicalFace Interface
IsOnFace Overload
VisualComponents.Create3D Namespace


IMathematicalFace.IsOnFace Method (Double, Double)

IMathematicalFaceIsOnFace Method (Double, Double)

Evaluate if the given u,v point lies on the boundaries of the face

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsOnFace(
    double u,
    double v
)
bool IsOnFace(
    double u,
    double v
)

Parameters

u
Type: SystemDouble
v
Type: SystemDouble

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IMathematicalFace.IsOnFace(System.Double,System.Double)"]

See Also

Reference

IMathematicalFace Interface
IsOnFace Overload
VisualComponents.Create3D Namespace


IMathematicalFace.IsSurfaceLinear Method

IMathematicalFaceIsSurfaceLinear Method

Determines if surface is linear in both u and v space

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Tuple<bool, bool> IsSurfaceLinear()
Tuple<bool, bool>^ IsSurfaceLinear()

Return Value

Type: TupleBoolean, Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IMathematicalFace.IsSurfaceLinear"]

See Also

Reference

IMathematicalFace Interface
VisualComponents.Create3D Namespace


IMathematicalFace.ProjectCurve Method

IMathematicalFaceProjectCurve Method

Projects a curve that belongs to the given line set into this face, the result is placed in the given output line set

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ProjectCurve(
    ILineSet inputCurveSet,
    int curveIndex,
    Vector3 direction,
    double approximateTolerance,
    double maximumDistance,
    double angleToleranceRadians,
    ILineSet outputCurveSet
)
bool ProjectCurve(
    ILineSet^ inputCurveSet,
    int curveIndex,
    Vector3 direction,
    double approximateTolerance,
    double maximumDistance,
    double angleToleranceRadians,
    ILineSet^ outputCurveSet
)

Parameters

inputCurveSet
Type: VisualComponents.Create3DILineSet
input line set
curveIndex
Type: SystemInt32
curve index of the input line set
direction
Type: VisualComponents.Create3DVector3
projection direction
approximateTolerance
Type: SystemDouble
if different than 0, defines the accuracy of the projection curve relative to the exact projection of the curve
maximumDistance
Type: SystemDouble
if different than 0, defines the distance of the projection
angleToleranceRadians
Type: SystemDouble
if different than 0, defines the maximum angle of a single segment of the resulting approximating curve
outputCurveSet
Type: VisualComponents.Create3DILineSet
output line set

Return Value

Type: Boolean
Number of projected curves
See Also

Reference

IMathematicalFace Interface
VisualComponents.Create3D Namespace


IMathematicalFace.SwapUV Method

IMathematicalFaceSwapUV Method

Swap the UV of the surface of a face and all curves.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SwapUV()
bool SwapUV()

Return Value

Type: Boolean
True if swapt was successfull
See Also

Reference

IMathematicalFace Interface
VisualComponents.Create3D Namespace


IMatrixSignal Interface

An interface for matrix signal behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IMatrixSignal : ISignal,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed
public interface class IMatrixSignal : ISignal,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed

The IMatrixSignal type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsApplication | Defines if this ISignal instance has been created by the application for its internal use. (Inherited from ISignal.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Public property | Value | Gets or sets the value of this ISignal instance. (Inherited from ISignal.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanConnectTo | Defines if this ISignal instance can be connected to the given signal. (Inherited from ISignal.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect | Connects the given ISignal instance to the given signal. (Inherited from ISignal.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects this ISignal instance from the given signal. (Inherited from ISignal.)
Public method | DisconnectAll | Disconnects all ISignal instances connected to this signal. (Inherited from ISignal.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | SignalTrigger | Event that is raised when the value of this ISignal instance is changing. (Inherited from ISignal.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IMatrixSignal Properties

The IMatrixSignal type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsApplication | Defines if this ISignal instance has been created by the application for its internal use. (Inherited from ISignal.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Public property | Value | Gets or sets the value of this ISignal instance. (Inherited from ISignal.)
Top
See Also

Reference

IMatrixSignal Interface
VisualComponents.Create3D Namespace


IMatrixSignal Methods

The IMatrixSignal type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanConnectTo | Defines if this ISignal instance can be connected to the given signal. (Inherited from ISignal.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect | Connects the given ISignal instance to the given signal. (Inherited from ISignal.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects this ISignal instance from the given signal. (Inherited from ISignal.)
Public method | DisconnectAll | Disconnects all ISignal instances connected to this signal. (Inherited from ISignal.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IMatrixSignal Interface
VisualComponents.Create3D Namespace


IMatrixSignal Events

The IMatrixSignal type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | SignalTrigger | Event that is raised when the value of this ISignal instance is changing. (Inherited from ISignal.)
Top
See Also

Reference

IMatrixSignal Interface
VisualComponents.Create3D Namespace


IMemento(T) Interface

IMementoT Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IMemento<T> : IDisposable

generic<typename T>
public interface class IMemento : IDisposable

Type Parameters

T

The IMementoT type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RestoreState |
Public method | SaveState |
Top
See Also

Reference

VisualComponents.Create3D Namespace


IMemento(T) Methods

IMementoT Methods

The IMementoT generic type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | RestoreState |
Public method | SaveState |
Top
See Also

Reference

IMementoT Interface
VisualComponents.Create3D Namespace


IMemento(T).RestoreState Method

IMementoTRestoreState Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
T RestoreState()
T RestoreState()

Return Value

Type: T

[Missing <returns> documentation for "M:VisualComponents.Create3D.IMemento`1.RestoreState"]

See Also

Reference

IMementoT Interface
VisualComponents.Create3D Namespace


IMemento(T).SaveState Method

IMementoTSaveState Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SaveState(
    T original
)
void SaveState(
    T original
)

Parameters

original
Type: T
See Also

Reference

IMementoT Interface
VisualComponents.Create3D Namespace


IMessageBoxService Interface

MessageBox Service interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IMessageBoxService
public interface class IMessageBoxService
Methods
 | Name | Description
Public method | Show(String) | Displays a message box with the specified text.
Public method | Show(String, Boolean) | Displays a message box with the specified text.
Public method | Show(String, String) | Displays a message box in front of the specified object and with the specified text and caption.
Public method | Show(String, MessageBoxResult) | Displays a message box in front of the specified object and with the specified text and default message box result.
Public method | Show(Window, String) | Displays a message box in front of the specified object and with the specified text.
Public method | Show(String, String, Boolean) | Displays a message box in front of the specified object and with the specified text and caption.
Public method | Show(String, String, MessageBoxButton) | Displays a message box in front of the specified object and with the specified text, caption, and buttons.
Public method | Show(String, String, MessageBoxResult) | Displays a message box in front of the specified object and with the specified text , caption and default message box result.
Public method | Show(String, MessageBoxResult, Boolean) | Displays a message box in front of the specified object and with the specified text and default message box result.
Public method | Show(Window, String, Boolean) | Displays a message box in front of the specified object and with the specified text.
Public method | Show(Window, String, String) | Displays a message box in front of the specified object and with specified text and caption.
Public method | Show(Window, String, MessageBoxResult) | Displays a message box in front of the specified object and with the specified text and default message box result.
Public method | Show(String, String, MessageBoxButton, Boolean) | Displays a message box in front of the specified object and with the specified text, caption, buttons and close button visibility option.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage) | Displays a message box with specified text, caption, buttons, and icon.
Public method | Show(String, String, MessageBoxButton, MessageBoxResult) | Displays a message box with the specified text, caption, buttons and default message box result.
Public method | Show(String, String, MessageBoxResult, Boolean) | Displays a message box in front of the specified object and with the specified text , caption and default message box result.
Public method | Show(Window, String, String, Boolean) | Displays a message box in front of the specified object and with specified text, caption, and close button visibility option.
Public method | Show(Window, String, String, MessageBoxButton) | Displays a message box in front of the specified object and with specified text, caption and buttons.
Public method | Show(Window, String, String, MessageBoxResult) | Displays a message box in front of the specified object and with specified text, caption and default message box result.
Public method | Show(Window, String, MessageBoxResult, Boolean) | Displays a message box in front of the specified object and with the specified text, default message box result and close button visibility option.
Public method | Show(String, String, MessageBoxButton, String, String) | Displays a message box with the specified text, caption, buttons , yes button content and no button content.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, Boolean) | Displays a message box with specified text, caption, buttons, icon and close button visibility option.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult) | Displays a message box with specified text, caption, buttons, icon and default message box result.
Public method | Show(String, String, MessageBoxButton, MessageBoxResult, Boolean) | Displays a message box with the specified text, caption, buttons , default message box result and close button visibility option.
Public method | Show(Window, String, String, MessageBoxButton, Boolean) | Displays a message box in front of the specified object and with specified text, caption, buttons and close button visibility option.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxImage) | Displays a message box in front of the specified object and with specified text, caption, buttons and icon.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxResult) | Displays a message box in front of the specified object and with specified text, caption, buttons and defualt message box result.
Public method | Show(Window, String, String, MessageBoxResult, Boolean) | Displays a message box in front of the specified object and with specified text, caption, buttons, default message box result and close button visibility option.
Public method | Show(String, String, MessageBoxButton, String, String, String) | Displays a message box with the specified text, caption, buttons, yes button content, no button content and cancel button content.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, String, String) | Displays a message box with specified text, caption, buttons, icon, yes button content and no button content.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, Boolean) | Displays a message box with specified text, caption, buttons, icon, default message box result and close button visibility option.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxImage, Boolean) | Displays a message box in front of the specified object and with specified text, caption, buttons, icon and close button visibility option.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult) | Displays a message box in front of the specified object and with specified text, caption, buttons, icon and default message box result.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxResult, Boolean) | Displays a message box in front of the specified object and with specified text, caption, buttons, default message box result and close button visibility option.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, String, String, String) | Displays a message box with specified text, caption, buttons, icon, yes button content, no button content and cancel button content.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String) | Displays a message box with specified text, caption, buttons, icon, default message box result, yes button content and no button content.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, Boolean) | Displays a message box in front of the specified object and with specified text, caption, buttons, icon, defult message box result and close button visibility option.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, String, String, String, Boolean) | /// Displays a message box with specified text, caption, buttons, icon, yes button content, no button content, cancel button content and close button visibility option.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String) | /// Displays a message box with specified text, caption, buttons, icon, default message box result, yes button content, no button content and cancel button content.
Public method | Show(String, String, MessageBoxButton, MessageBoxResult, String, String, String, Boolean) | Displays a message box with the specified text, caption, buttons,default message box result, yes button content, no button content, cancel button content and close button visibility option.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String) | Displays a message box in front of the specified object and with specified text, caption, buttons, icon, defult message box result, yes button content and no button content.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean) | Displays a message box with specified text, caption, buttons, icon, default message box result, yes button content, no button content, cancel button content and close button visibility option.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String) | Displays a message box in front of the specified object and with specified text, caption, buttons, icon, defult message box result, yes button content, no button content and cancel button content.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean) | Displays a message box in front of the specified object and with specified text, caption, buttons, icon, defult message box result, yes button content, no button content, cancel button content and close button visibility option.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean, Boolean, Boolean) | Displays a message box with specified text, caption, buttons, icon, default message box result, yes button content, no button content, cancel button content and close button visibility option.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean, Boolean) | Displays a message box in front of the specified object and with specified text, caption, buttons, icon, defult message box result, yes button content, no button content, cancel button content and option to set message box on top.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IMessageBoxService Methods

Methods
 | Name | Description
Public method | Show(String) | Displays a message box with the specified text.
Public method | Show(String, Boolean) | Displays a message box with the specified text.
Public method | Show(String, String) | Displays a message box in front of the specified object and with the specified text and caption.
Public method | Show(String, MessageBoxResult) | Displays a message box in front of the specified object and with the specified text and default message box result.
Public method | Show(Window, String) | Displays a message box in front of the specified object and with the specified text.
Public method | Show(String, String, Boolean) | Displays a message box in front of the specified object and with the specified text and caption.
Public method | Show(String, String, MessageBoxButton) | Displays a message box in front of the specified object and with the specified text, caption, and buttons.
Public method | Show(String, String, MessageBoxResult) | Displays a message box in front of the specified object and with the specified text , caption and default message box result.
Public method | Show(String, MessageBoxResult, Boolean) | Displays a message box in front of the specified object and with the specified text and default message box result.
Public method | Show(Window, String, Boolean) | Displays a message box in front of the specified object and with the specified text.
Public method | Show(Window, String, String) | Displays a message box in front of the specified object and with specified text and caption.
Public method | Show(Window, String, MessageBoxResult) | Displays a message box in front of the specified object and with the specified text and default message box result.
Public method | Show(String, String, MessageBoxButton, Boolean) | Displays a message box in front of the specified object and with the specified text, caption, buttons and close button visibility option.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage) | Displays a message box with specified text, caption, buttons, and icon.
Public method | Show(String, String, MessageBoxButton, MessageBoxResult) | Displays a message box with the specified text, caption, buttons and default message box result.
Public method | Show(String, String, MessageBoxResult, Boolean) | Displays a message box in front of the specified object and with the specified text , caption and default message box result.
Public method | Show(Window, String, String, Boolean) | Displays a message box in front of the specified object and with specified text, caption, and close button visibility option.
Public method | Show(Window, String, String, MessageBoxButton) | Displays a message box in front of the specified object and with specified text, caption and buttons.
Public method | Show(Window, String, String, MessageBoxResult) | Displays a message box in front of the specified object and with specified text, caption and default message box result.
Public method | Show(Window, String, MessageBoxResult, Boolean) | Displays a message box in front of the specified object and with the specified text, default message box result and close button visibility option.
Public method | Show(String, String, MessageBoxButton, String, String) | Displays a message box with the specified text, caption, buttons , yes button content and no button content.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, Boolean) | Displays a message box with specified text, caption, buttons, icon and close button visibility option.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult) | Displays a message box with specified text, caption, buttons, icon and default message box result.
Public method | Show(String, String, MessageBoxButton, MessageBoxResult, Boolean) | Displays a message box with the specified text, caption, buttons , default message box result and close button visibility option.
Public method | Show(Window, String, String, MessageBoxButton, Boolean) | Displays a message box in front of the specified object and with specified text, caption, buttons and close button visibility option.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxImage) | Displays a message box in front of the specified object and with specified text, caption, buttons and icon.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxResult) | Displays a message box in front of the specified object and with specified text, caption, buttons and defualt message box result.
Public method | Show(Window, String, String, MessageBoxResult, Boolean) | Displays a message box in front of the specified object and with specified text, caption, buttons, default message box result and close button visibility option.
Public method | Show(String, String, MessageBoxButton, String, String, String) | Displays a message box with the specified text, caption, buttons, yes button content, no button content and cancel button content.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, String, String) | Displays a message box with specified text, caption, buttons, icon, yes button content and no button content.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, Boolean) | Displays a message box with specified text, caption, buttons, icon, default message box result and close button visibility option.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxImage, Boolean) | Displays a message box in front of the specified object and with specified text, caption, buttons, icon and close button visibility option.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult) | Displays a message box in front of the specified object and with specified text, caption, buttons, icon and default message box result.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxResult, Boolean) | Displays a message box in front of the specified object and with specified text, caption, buttons, default message box result and close button visibility option.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, String, String, String) | Displays a message box with specified text, caption, buttons, icon, yes button content, no button content and cancel button content.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String) | Displays a message box with specified text, caption, buttons, icon, default message box result, yes button content and no button content.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, Boolean) | Displays a message box in front of the specified object and with specified text, caption, buttons, icon, defult message box result and close button visibility option.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, String, String, String, Boolean) | /// Displays a message box with specified text, caption, buttons, icon, yes button content, no button content, cancel button content and close button visibility option.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String) | /// Displays a message box with specified text, caption, buttons, icon, default message box result, yes button content, no button content and cancel button content.
Public method | Show(String, String, MessageBoxButton, MessageBoxResult, String, String, String, Boolean) | Displays a message box with the specified text, caption, buttons,default message box result, yes button content, no button content, cancel button content and close button visibility option.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String) | Displays a message box in front of the specified object and with specified text, caption, buttons, icon, defult message box result, yes button content and no button content.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean) | Displays a message box with specified text, caption, buttons, icon, default message box result, yes button content, no button content, cancel button content and close button visibility option.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String) | Displays a message box in front of the specified object and with specified text, caption, buttons, icon, defult message box result, yes button content, no button content and cancel button content.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean) | Displays a message box in front of the specified object and with specified text, caption, buttons, icon, defult message box result, yes button content, no button content, cancel button content and close button visibility option.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean, Boolean, Boolean) | Displays a message box with specified text, caption, buttons, icon, default message box result, yes button content, no button content, cancel button content and close button visibility option.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean, Boolean) | Displays a message box in front of the specified object and with specified text, caption, buttons, icon, defult message box result, yes button content, no button content, cancel button content and option to set message box on top.
Top
See Also

Reference

IMessageBoxService Interface
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method

IMessageBoxServiceShow Method

Overload List
 | Name | Description
Public method | Show(String) | Displays a message box with the specified text.
Public method | Show(String, Boolean) | Displays a message box with the specified text.
Public method | Show(String, String) | Displays a message box in front of the specified object and with the specified text and caption.
Public method | Show(String, MessageBoxResult) | Displays a message box in front of the specified object and with the specified text and default message box result.
Public method | Show(Window, String) | Displays a message box in front of the specified object and with the specified text.
Public method | Show(String, String, Boolean) | Displays a message box in front of the specified object and with the specified text and caption.
Public method | Show(String, String, MessageBoxButton) | Displays a message box in front of the specified object and with the specified text, caption, and buttons.
Public method | Show(String, String, MessageBoxResult) | Displays a message box in front of the specified object and with the specified text , caption and default message box result.
Public method | Show(String, MessageBoxResult, Boolean) | Displays a message box in front of the specified object and with the specified text and default message box result.
Public method | Show(Window, String, Boolean) | Displays a message box in front of the specified object and with the specified text.
Public method | Show(Window, String, String) | Displays a message box in front of the specified object and with specified text and caption.
Public method | Show(Window, String, MessageBoxResult) | Displays a message box in front of the specified object and with the specified text and default message box result.
Public method | Show(String, String, MessageBoxButton, Boolean) | Displays a message box in front of the specified object and with the specified text, caption, buttons and close button visibility option.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage) | Displays a message box with specified text, caption, buttons, and icon.
Public method | Show(String, String, MessageBoxButton, MessageBoxResult) | Displays a message box with the specified text, caption, buttons and default message box result.
Public method | Show(String, String, MessageBoxResult, Boolean) | Displays a message box in front of the specified object and with the specified text , caption and default message box result.
Public method | Show(Window, String, String, Boolean) | Displays a message box in front of the specified object and with specified text, caption, and close button visibility option.
Public method | Show(Window, String, String, MessageBoxButton) | Displays a message box in front of the specified object and with specified text, caption and buttons.
Public method | Show(Window, String, String, MessageBoxResult) | Displays a message box in front of the specified object and with specified text, caption and default message box result.
Public method | Show(Window, String, MessageBoxResult, Boolean) | Displays a message box in front of the specified object and with the specified text, default message box result and close button visibility option.
Public method | Show(String, String, MessageBoxButton, String, String) | Displays a message box with the specified text, caption, buttons , yes button content and no button content.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, Boolean) | Displays a message box with specified text, caption, buttons, icon and close button visibility option.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult) | Displays a message box with specified text, caption, buttons, icon and default message box result.
Public method | Show(String, String, MessageBoxButton, MessageBoxResult, Boolean) | Displays a message box with the specified text, caption, buttons , default message box result and close button visibility option.
Public method | Show(Window, String, String, MessageBoxButton, Boolean) | Displays a message box in front of the specified object and with specified text, caption, buttons and close button visibility option.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxImage) | Displays a message box in front of the specified object and with specified text, caption, buttons and icon.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxResult) | Displays a message box in front of the specified object and with specified text, caption, buttons and defualt message box result.
Public method | Show(Window, String, String, MessageBoxResult, Boolean) | Displays a message box in front of the specified object and with specified text, caption, buttons, default message box result and close button visibility option.
Public method | Show(String, String, MessageBoxButton, String, String, String) | Displays a message box with the specified text, caption, buttons, yes button content, no button content and cancel button content.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, String, String) | Displays a message box with specified text, caption, buttons, icon, yes button content and no button content.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, Boolean) | Displays a message box with specified text, caption, buttons, icon, default message box result and close button visibility option.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxImage, Boolean) | Displays a message box in front of the specified object and with specified text, caption, buttons, icon and close button visibility option.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult) | Displays a message box in front of the specified object and with specified text, caption, buttons, icon and default message box result.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxResult, Boolean) | Displays a message box in front of the specified object and with specified text, caption, buttons, default message box result and close button visibility option.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, String, String, String) | Displays a message box with specified text, caption, buttons, icon, yes button content, no button content and cancel button content.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String) | Displays a message box with specified text, caption, buttons, icon, default message box result, yes button content and no button content.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, Boolean) | Displays a message box in front of the specified object and with specified text, caption, buttons, icon, defult message box result and close button visibility option.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, String, String, String, Boolean) | /// Displays a message box with specified text, caption, buttons, icon, yes button content, no button content, cancel button content and close button visibility option.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String) | /// Displays a message box with specified text, caption, buttons, icon, default message box result, yes button content, no button content and cancel button content.
Public method | Show(String, String, MessageBoxButton, MessageBoxResult, String, String, String, Boolean) | Displays a message box with the specified text, caption, buttons,default message box result, yes button content, no button content, cancel button content and close button visibility option.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String) | Displays a message box in front of the specified object and with specified text, caption, buttons, icon, defult message box result, yes button content and no button content.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean) | Displays a message box with specified text, caption, buttons, icon, default message box result, yes button content, no button content, cancel button content and close button visibility option.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String) | Displays a message box in front of the specified object and with specified text, caption, buttons, icon, defult message box result, yes button content, no button content and cancel button content.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean) | Displays a message box in front of the specified object and with specified text, caption, buttons, icon, defult message box result, yes button content, no button content, cancel button content and close button visibility option.
Public method | Show(String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean, Boolean, Boolean) | Displays a message box with specified text, caption, buttons, icon, default message box result, yes button content, no button content, cancel button content and close button visibility option.
Public method | Show(Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean, Boolean) | Displays a message box in front of the specified object and with specified text, caption, buttons, icon, defult message box result, yes button content, no button content, cancel button content and option to set message box on top.
Top
See Also

Reference

IMessageBoxService Interface
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (String)

IMessageBoxServiceShow Method (String)

Displays a message box with the specified text.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    string messageBoxText
)
MessageBoxResult Show(
    String^ messageBoxText
)

Parameters

messageBoxText
Type: SystemString
The text to display in the message box.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (String, Boolean)

IMessageBoxServiceShow Method (String, Boolean)

Displays a message box with the specified text.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    string messageBoxText,
    bool closeCaptionButtonVisibility
)
MessageBoxResult Show(
    String^ messageBoxText,
    bool closeCaptionButtonVisibility
)

Parameters

messageBoxText
Type: SystemString
The text to display in the message box.
closeCaptionButtonVisibility
Type: SystemBoolean
True if Close caption button is visible. False otherwise.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (String, String)

IMessageBoxServiceShow Method (String, String)

Displays a message box in front of the specified object and with the specified text and caption.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    string messageBoxText,
    string caption
)
MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption
)

Parameters

messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (String, MessageBoxResult)

IMessageBoxServiceShow Method (String, MessageBoxResult)

Displays a message box in front of the specified object and with the specified text and default message box result.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    string messageBoxText,
    MessageBoxResult defaultMessageBoxResult
)
MessageBoxResult Show(
    String^ messageBoxText,
    MessageBoxResult defaultMessageBoxResult
)

Parameters

messageBoxText
Type: SystemString
The text to display in the message box.
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (Window, String)

IMessageBoxServiceShow Method (Window, String)

Displays a message box in front of the specified object and with the specified text.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    Window owner,
    string messageBoxText
)
MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText
)

Parameters

owner
Type: System.WindowsWindow
An implementation of IWin32Window that will own the modal dialog box.
messageBoxText
Type: SystemString
The text to display in the message box.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (String, String, Boolean)

IMessageBoxServiceShow Method (String, String, Boolean)

Displays a message box in front of the specified object and with the specified text and caption.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    string messageBoxText,
    string caption,
    bool closeCaptionButtonVisibility
)
MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    bool closeCaptionButtonVisibility
)

Parameters

messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
closeCaptionButtonVisibility
Type: SystemBoolean
True if Close caption button is visible. False otherwise.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (String, String, MessageBoxButton)

IMessageBoxServiceShow Method (String, String, MessageBoxButton)

Displays a message box in front of the specified object and with the specified text, caption, and buttons.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxButton button
)
MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button
)

Parameters

messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (String, String, MessageBoxResult)

IMessageBoxServiceShow Method (String, String, MessageBoxResult)

Displays a message box in front of the specified object and with the specified text , caption and default message box result.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxResult defaultMessageBoxResult
)
MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxResult defaultMessageBoxResult
)

Parameters

messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (String, MessageBoxResult, Boolean)

IMessageBoxServiceShow Method (String, MessageBoxResult, Boolean)

Displays a message box in front of the specified object and with the specified text and default message box result.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    string messageBoxText,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility
)
MessageBoxResult Show(
    String^ messageBoxText,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility
)

Parameters

messageBoxText
Type: SystemString
The text to display in the message box.
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult
closeCaptionButtonVisibility
Type: SystemBoolean
True if Close caption button is visible. False otherwise.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (Window, String, Boolean)

IMessageBoxServiceShow Method (Window, String, Boolean)

Displays a message box in front of the specified object and with the specified text.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    Window owner,
    string messageBoxText,
    bool closeCaptionButtonVisibility
)
MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText,
    bool closeCaptionButtonVisibility
)

Parameters

owner
Type: System.WindowsWindow
An implementation of IWin32Window that will own the modal dialog box.
messageBoxText
Type: SystemString
The text to display in the message box.
closeCaptionButtonVisibility
Type: SystemBoolean
True if Close caption button is visible. False otherwise.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (Window, String, String)

IMessageBoxServiceShow Method (Window, String, String)

Displays a message box in front of the specified object and with specified text and caption.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    Window owner,
    string messageBoxText,
    string caption
)
MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText,
    String^ caption
)

Parameters

owner
Type: System.WindowsWindow
An implementation of IWin32Window that will own the modal dialog box.
messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (Window, String, MessageBoxResult)

IMessageBoxServiceShow Method (Window, String, MessageBoxResult)

Displays a message box in front of the specified object and with the specified text and default message box result.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    Window owner,
    string messageBoxText,
    MessageBoxResult defaultMessageBoxResult
)
MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText,
    MessageBoxResult defaultMessageBoxResult
)

Parameters

owner
Type: System.WindowsWindow
An implementation of IWin32Window that will own the modal dialog box.
messageBoxText
Type: SystemString
The text to display in the message box.
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (String, String, MessageBoxButton, Boolean)

IMessageBoxServiceShow Method (String, String, MessageBoxButton, Boolean)

Displays a message box in front of the specified object and with the specified text, caption, buttons and close button visibility option.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    bool closeCaptionButtonVisibility
)
MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    bool closeCaptionButtonVisibility
)

Parameters

messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
closeCaptionButtonVisibility
Type: SystemBoolean
True if Close caption button is visible. False otherwise.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (String, String, MessageBoxButton, MessageBoxImage)

IMessageBoxServiceShow Method (String, String, MessageBoxButton, MessageBoxImage)

Displays a message box with specified text, caption, buttons, and icon.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxImage icon
)
MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxImage icon
)

Parameters

messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
icon
Type: System.WindowsMessageBoxImage
One of the MessageBoxIcon values that specifies which icon to display in the message box.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (String, String, MessageBoxButton, MessageBoxResult)

IMessageBoxServiceShow Method (String, String, MessageBoxButton, MessageBoxResult)

Displays a message box with the specified text, caption, buttons and default message box result.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxResult defaultMessageBoxResult
)
MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxResult defaultMessageBoxResult
)

Parameters

messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (String, String, MessageBoxResult, Boolean)

IMessageBoxServiceShow Method (String, String, MessageBoxResult, Boolean)

Displays a message box in front of the specified object and with the specified text , caption and default message box result.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility
)
MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility
)

Parameters

messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult
closeCaptionButtonVisibility
Type: SystemBoolean
True if Close caption button is visible. False otherwise.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (Window, String, String, Boolean)

IMessageBoxServiceShow Method (Window, String, String, Boolean)

Displays a message box in front of the specified object and with specified text, caption, and close button visibility option.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    Window owner,
    string messageBoxText,
    string caption,
    bool closeCaptionButtonVisibility
)
MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText,
    String^ caption,
    bool closeCaptionButtonVisibility
)

Parameters

owner
Type: System.WindowsWindow
An implementation of IWin32Window that will own the modal dialog box.
messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
closeCaptionButtonVisibility
Type: SystemBoolean
True if Close caption button is visible. False otherwise.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (Window, String, String, MessageBoxButton)

IMessageBoxServiceShow Method (Window, String, String, MessageBoxButton)

Displays a message box in front of the specified object and with specified text, caption and buttons.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    Window owner,
    string messageBoxText,
    string caption,
    MessageBoxButton button
)
MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button
)

Parameters

owner
Type: System.WindowsWindow
An implementation of IWin32Window that will own the modal dialog box.
messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (Window, String, String, MessageBoxResult)

IMessageBoxServiceShow Method (Window, String, String, MessageBoxResult)

Displays a message box in front of the specified object and with specified text, caption and default message box result.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    Window owner,
    string messageBoxText,
    string caption,
    MessageBoxResult defaultMessageBoxResult
)
MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText,
    String^ caption,
    MessageBoxResult defaultMessageBoxResult
)

Parameters

owner
Type: System.WindowsWindow
An implementation of IWin32Window that will own the modal dialog box.
messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (Window, String, MessageBoxResult, Boolean)

IMessageBoxServiceShow Method (Window, String, MessageBoxResult, Boolean)

Displays a message box in front of the specified object and with the specified text, default message box result and close button visibility option.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    Window owner,
    string messageBoxText,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility
)
MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility
)

Parameters

owner
Type: System.WindowsWindow
An implementation of IWin32Window that will own the modal dialog box.
messageBoxText
Type: SystemString
The text to display in the message box.
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult
closeCaptionButtonVisibility
Type: SystemBoolean
True if Close caption button is visible. False otherwise.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (String, String, MessageBoxButton, String, String)

IMessageBoxServiceShow Method (String, String, MessageBoxButton, String, String)

Displays a message box with the specified text, caption, buttons , yes button content and no button content.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    string yesButtonContent,
    string noButtonContent
)
MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    String^ yesButtonContent,
    String^ noButtonContent
)

Parameters

messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
yesButtonContent
Type: SystemString
The text to display in message box yes button.
noButtonContent
Type: SystemString
The text to display in message box no button.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (String, String, MessageBoxButton, MessageBoxImage, Boolean)

IMessageBoxServiceShow Method (String, String, MessageBoxButton, MessageBoxImage, Boolean)

Displays a message box with specified text, caption, buttons, icon and close button visibility option.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    bool closeCaptionButtonVisibility
)
MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    bool closeCaptionButtonVisibility
)

Parameters

messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
icon
Type: System.WindowsMessageBoxImage
One of the MessageBoxIcon values that specifies which icon to display in the message box.
closeCaptionButtonVisibility
Type: SystemBoolean
True if Close caption button is visible. False otherwise.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult)

IMessageBoxServiceShow Method (String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult)

Displays a message box with specified text, caption, buttons, icon and default message box result.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult
)
MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult
)

Parameters

messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
icon
Type: System.WindowsMessageBoxImage
One of the MessageBoxIcon values that specifies which icon to display in the message box.
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (String, String, MessageBoxButton, MessageBoxResult, Boolean)

IMessageBoxServiceShow Method (String, String, MessageBoxButton, MessageBoxResult, Boolean)

Displays a message box with the specified text, caption, buttons , default message box result and close button visibility option.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility
)
MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility
)

Parameters

messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult
closeCaptionButtonVisibility
Type: SystemBoolean
True if Close caption button is visible. False otherwise.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (Window, String, String, MessageBoxButton, Boolean)

IMessageBoxServiceShow Method (Window, String, String, MessageBoxButton, Boolean)

Displays a message box in front of the specified object and with specified text, caption, buttons and close button visibility option.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    Window owner,
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    bool closeCaptionButtonVisibility
)
MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    bool closeCaptionButtonVisibility
)

Parameters

owner
Type: System.WindowsWindow
An implementation of IWin32Window that will own the modal dialog box.
messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
closeCaptionButtonVisibility
Type: SystemBoolean
True if Close caption button is visible. False otherwise.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (Window, String, String, MessageBoxButton, MessageBoxImage)

IMessageBoxServiceShow Method (Window, String, String, MessageBoxButton, MessageBoxImage)

Displays a message box in front of the specified object and with specified text, caption, buttons and icon.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    Window owner,
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxImage icon
)
MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxImage icon
)

Parameters

owner
Type: System.WindowsWindow
An implementation of IWin32Window that will own the modal dialog box.
messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
icon
Type: System.WindowsMessageBoxImage
One of the MessageBoxIcon values that specifies which icon to display in the message box.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (Window, String, String, MessageBoxButton, MessageBoxResult)

IMessageBoxServiceShow Method (Window, String, String, MessageBoxButton, MessageBoxResult)

Displays a message box in front of the specified object and with specified text, caption, buttons and defualt message box result.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    Window owner,
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxResult defaultMessageBoxResult
)
MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxResult defaultMessageBoxResult
)

Parameters

owner
Type: System.WindowsWindow
An implementation of IWin32Window that will own the modal dialog box.
messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (Window, String, String, MessageBoxResult, Boolean)

IMessageBoxServiceShow Method (Window, String, String, MessageBoxResult, Boolean)

Displays a message box in front of the specified object and with specified text, caption, buttons, default message box result and close button visibility option.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    Window owner,
    string messageBoxText,
    string caption,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility
)
MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText,
    String^ caption,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility
)

Parameters

owner
Type: System.WindowsWindow
An implementation of IWin32Window that will own the modal dialog box.
messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult
closeCaptionButtonVisibility
Type: SystemBoolean
True if Close caption button is visible. False otherwise.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (String, String, MessageBoxButton, String, String, String)

IMessageBoxServiceShow Method (String, String, MessageBoxButton, String, String, String)

Displays a message box with the specified text, caption, buttons, yes button content, no button content and cancel button content.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    string yesButtonContent,
    string noButtonContent,
    string cancelButtonContent
)
MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    String^ yesButtonContent,
    String^ noButtonContent,
    String^ cancelButtonContent
)

Parameters

messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
yesButtonContent
Type: SystemString
The text to display in message box yes button.
noButtonContent
Type: SystemString
The text to display in message box no button.
cancelButtonContent
Type: SystemString
The text to display in message box cancel button.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (String, String, MessageBoxButton, MessageBoxImage, String, String)

IMessageBoxServiceShow Method (String, String, MessageBoxButton, MessageBoxImage, String, String)

Displays a message box with specified text, caption, buttons, icon, yes button content and no button content.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    string yesButtonContent,
    string noButtonContent
)
MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    String^ yesButtonContent,
    String^ noButtonContent
)

Parameters

messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
icon
Type: System.WindowsMessageBoxImage
One of the MessageBoxIcon values that specifies which icon to display in the message box.
yesButtonContent
Type: SystemString
The text to display in message box yes button.
noButtonContent
Type: SystemString
The text to display in message box no button.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, Boolean)

IMessageBoxServiceShow Method (String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, Boolean)

Displays a message box with specified text, caption, buttons, icon, default message box result and close button visibility option.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility
)
MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility
)

Parameters

messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
icon
Type: System.WindowsMessageBoxImage
One of the MessageBoxIcon values that specifies which icon to display in the message box.
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult
closeCaptionButtonVisibility
Type: SystemBoolean
True if Close caption button is visible. False otherwise.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (Window, String, String, MessageBoxButton, MessageBoxImage, Boolean)

IMessageBoxServiceShow Method (Window, String, String, MessageBoxButton, MessageBoxImage, Boolean)

Displays a message box in front of the specified object and with specified text, caption, buttons, icon and close button visibility option.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    Window owner,
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    bool closeCaptionButtonVisibility
)
MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    bool closeCaptionButtonVisibility
)

Parameters

owner
Type: System.WindowsWindow
An implementation of IWin32Window that will own the modal dialog box.
messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
icon
Type: System.WindowsMessageBoxImage
One of the MessageBoxIcon values that specifies which icon to display in the message box.
closeCaptionButtonVisibility
Type: SystemBoolean
True if Close caption button is visible. False otherwise.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult)

IMessageBoxServiceShow Method (Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult)

Displays a message box in front of the specified object and with specified text, caption, buttons, icon and default message box result.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    Window owner,
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult
)
MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult
)

Parameters

owner
Type: System.WindowsWindow
An implementation of IWin32Window that will own the modal dialog box.
messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
icon
Type: System.WindowsMessageBoxImage
One of the MessageBoxIcon values that specifies which icon to display in the message box.
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (Window, String, String, MessageBoxButton, MessageBoxResult, Boolean)

IMessageBoxServiceShow Method (Window, String, String, MessageBoxButton, MessageBoxResult, Boolean)

Displays a message box in front of the specified object and with specified text, caption, buttons, default message box result and close button visibility option.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    Window owner,
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility
)
MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility
)

Parameters

owner
Type: System.WindowsWindow
An implementation of IWin32Window that will own the modal dialog box.
messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult
closeCaptionButtonVisibility
Type: SystemBoolean
True if Close caption button is visible. False otherwise.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (String, String, MessageBoxButton, MessageBoxImage, String, String, String)

IMessageBoxServiceShow Method (String, String, MessageBoxButton, MessageBoxImage, String, String, String)

Displays a message box with specified text, caption, buttons, icon, yes button content, no button content and cancel button content.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    string yesButtonContent,
    string noButtonContent,
    string cancelButtonContent
)
MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    String^ yesButtonContent,
    String^ noButtonContent,
    String^ cancelButtonContent
)

Parameters

messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
icon
Type: System.WindowsMessageBoxImage
One of the MessageBoxIcon values that specifies which icon to display in the message box.
yesButtonContent
Type: SystemString
The text to display in message box yes button.
noButtonContent
Type: SystemString
The text to display in message box no button.
cancelButtonContent
Type: SystemString
The text to display in message box cancel button.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String)

IMessageBoxServiceShow Method (String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String)

Displays a message box with specified text, caption, buttons, icon, default message box result, yes button content and no button content.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult,
    string yesButtonContent,
    string noButtonContent
)
MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult,
    String^ yesButtonContent,
    String^ noButtonContent
)

Parameters

messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
icon
Type: System.WindowsMessageBoxImage
One of the MessageBoxIcon values that specifies which icon to display in the message box.
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult
yesButtonContent
Type: SystemString
The text to display in message box yes button.
noButtonContent
Type: SystemString
The text to display in message box no button.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, Boolean)

IMessageBoxServiceShow Method (Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, Boolean)

Displays a message box in front of the specified object and with specified text, caption, buttons, icon, defult message box result and close button visibility option.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    Window owner,
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility
)
MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult,
    bool closeCaptionButtonVisibility
)

Parameters

owner
Type: System.WindowsWindow
An implementation of IWin32Window that will own the modal dialog box.
messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
icon
Type: System.WindowsMessageBoxImage
One of the MessageBoxIcon values that specifies which icon to display in the message box.
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult
closeCaptionButtonVisibility
Type: SystemBoolean
True if Close caption button is visible. False otherwise.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (String, String, MessageBoxButton, MessageBoxImage, String, String, String, Boolean)

IMessageBoxServiceShow Method (String, String, MessageBoxButton, MessageBoxImage, String, String, String, Boolean)

/// Displays a message box with specified text, caption, buttons, icon, yes button content, no button content, cancel button content and close button visibility option.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    string yesButtonContent,
    string noButtonContent,
    string cancelButtonContent,
    bool closeCaptionButtonVisibility
)
MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    String^ yesButtonContent,
    String^ noButtonContent,
    String^ cancelButtonContent,
    bool closeCaptionButtonVisibility
)

Parameters

messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
icon
Type: System.WindowsMessageBoxImage
One of the MessageBoxIcon values that specifies which icon to display in the message box.
yesButtonContent
Type: SystemString
The text to display in message box yes button.
noButtonContent
Type: SystemString
The text to display in message box no button.
cancelButtonContent
Type: SystemString
The text to display in message box cancel button.
closeCaptionButtonVisibility
Type: SystemBoolean
True if Close caption button is visible. False otherwise.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String)

IMessageBoxServiceShow Method (String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String)

/// Displays a message box with specified text, caption, buttons, icon, default message box result, yes button content, no button content and cancel button content.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult,
    string yesButtonContent,
    string noButtonContent,
    string cancelButtonContent
)
MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult,
    String^ yesButtonContent,
    String^ noButtonContent,
    String^ cancelButtonContent
)

Parameters

messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
icon
Type: System.WindowsMessageBoxImage
One of the MessageBoxIcon values that specifies which icon to display in the message box.
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult
yesButtonContent
Type: SystemString
The text to display in message box yes button.
noButtonContent
Type: SystemString
The text to display in message box no button.
cancelButtonContent
Type: SystemString
The text to display in message box cancel button.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (String, String, MessageBoxButton, MessageBoxResult, String, String, String, Boolean)

IMessageBoxServiceShow Method (String, String, MessageBoxButton, MessageBoxResult, String, String, String, Boolean)

Displays a message box with the specified text, caption, buttons,default message box result, yes button content, no button content, cancel button content and close button visibility option.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxResult defaultMessageBoxResult,
    string yesButtonContent,
    string noButtonContent,
    string cancelButtonContent,
    bool closeCaptionButtonVisibility
)
MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxResult defaultMessageBoxResult,
    String^ yesButtonContent,
    String^ noButtonContent,
    String^ cancelButtonContent,
    bool closeCaptionButtonVisibility
)

Parameters

messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult
yesButtonContent
Type: SystemString
The text to display in message box yes button.
noButtonContent
Type: SystemString
The text to display in message box no button.
cancelButtonContent
Type: SystemString
The text to display in message box cancel button.
closeCaptionButtonVisibility
Type: SystemBoolean
True if Close caption button is visible. False otherwise.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String)

IMessageBoxServiceShow Method (Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String)

Displays a message box in front of the specified object and with specified text, caption, buttons, icon, defult message box result, yes button content and no button content.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    Window owner,
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult,
    string yesButtonContent,
    string noButtonContent
)
MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult,
    String^ yesButtonContent,
    String^ noButtonContent
)

Parameters

owner
Type: System.WindowsWindow
An implementation of IWin32Window that will own the modal dialog box.
messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
icon
Type: System.WindowsMessageBoxImage
One of the MessageBoxIcon values that specifies which icon to display in the message box.
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult
yesButtonContent
Type: SystemString
The text to display in message box yes button.
noButtonContent
Type: SystemString
The text to display in message box no button.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean)

IMessageBoxServiceShow Method (String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean)

Displays a message box with specified text, caption, buttons, icon, default message box result, yes button content, no button content, cancel button content and close button visibility option.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult,
    string yesButtonContent,
    string noButtonContent,
    string cancelButtonContent,
    bool closeCaptionButtonVisibility
)
MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult,
    String^ yesButtonContent,
    String^ noButtonContent,
    String^ cancelButtonContent,
    bool closeCaptionButtonVisibility
)

Parameters

messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
icon
Type: System.WindowsMessageBoxImage
One of the MessageBoxIcon values that specifies which icon to display in the message box.
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult
yesButtonContent
Type: SystemString
The text to display in message box yes button.
noButtonContent
Type: SystemString
The text to display in message box no button.
cancelButtonContent
Type: SystemString
The text to display in message box cancel button.
closeCaptionButtonVisibility
Type: SystemBoolean
True if Close caption button is visible. False otherwise.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String)

IMessageBoxServiceShow Method (Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String)

Displays a message box in front of the specified object and with specified text, caption, buttons, icon, defult message box result, yes button content, no button content and cancel button content.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    Window owner,
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult,
    string yesButtonContent,
    string noButtonContent,
    string cancelButtonContent
)
MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult,
    String^ yesButtonContent,
    String^ noButtonContent,
    String^ cancelButtonContent
)

Parameters

owner
Type: System.WindowsWindow
An implementation of IWin32Window that will own the modal dialog box.
messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
icon
Type: System.WindowsMessageBoxImage
One of the MessageBoxIcon values that specifies which icon to display in the message box.
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult
yesButtonContent
Type: SystemString
The text to display in message box yes button.
noButtonContent
Type: SystemString
The text to display in message box no button.
cancelButtonContent
Type: SystemString
The text to display in message box cancel button.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean)

IMessageBoxServiceShow Method (Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean)

Displays a message box in front of the specified object and with specified text, caption, buttons, icon, defult message box result, yes button content, no button content, cancel button content and close button visibility option.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    Window owner,
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult,
    string yesButtonContent,
    string noButtonContent,
    string cancelButtonContent,
    bool closeCaptionButtonVisibility
)
MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult,
    String^ yesButtonContent,
    String^ noButtonContent,
    String^ cancelButtonContent,
    bool closeCaptionButtonVisibility
)

Parameters

owner
Type: System.WindowsWindow
An implementation of IWin32Window that will own the modal dialog box.
messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
icon
Type: System.WindowsMessageBoxImage
One of the MessageBoxIcon values that specifies which icon to display in the message box.
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult
yesButtonContent
Type: SystemString
The text to display in message box yes button.
noButtonContent
Type: SystemString
The text to display in message box no button.
cancelButtonContent
Type: SystemString
The text to display in message box cancel button.
closeCaptionButtonVisibility
Type: SystemBoolean
True if Close caption button is visible. False otherwise.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean, Boolean, Boolean)

IMessageBoxServiceShow Method (String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean, Boolean, Boolean)

Displays a message box with specified text, caption, buttons, icon, default message box result, yes button content, no button content, cancel button content and close button visibility option.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult,
    string yesButtonContent,
    string noButtonContent,
    string cancelButtonContent,
    bool closeCaptionButtonVisibility,
    bool isRetryCancelButtonType,
    bool isAbortRetryCancelButtonType
)
MessageBoxResult Show(
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult,
    String^ yesButtonContent,
    String^ noButtonContent,
    String^ cancelButtonContent,
    bool closeCaptionButtonVisibility,
    bool isRetryCancelButtonType,
    bool isAbortRetryCancelButtonType
)

Parameters

messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
icon
Type: System.WindowsMessageBoxImage
One of the MessageBoxIcon values that specifies which icon to display in the message box.
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult
yesButtonContent
Type: SystemString
The text to display in message box yes button.
noButtonContent
Type: SystemString
The text to display in message box no button.
cancelButtonContent
Type: SystemString
The text to display in message box cancel button.
closeCaptionButtonVisibility
Type: SystemBoolean
True if Close caption button is visible. False otherwise.
isRetryCancelButtonType
Type: SystemBoolean
True if it is retry cancel messagebox. False otherwise.
isAbortRetryCancelButtonType
Type: SystemBoolean
True if it is abort retry cancel messagebox. False otherwise.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageBoxService.Show Method (Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean, Boolean)

IMessageBoxServiceShow Method (Window, String, String, MessageBoxButton, MessageBoxImage, MessageBoxResult, String, String, String, Boolean, Boolean)

Displays a message box in front of the specified object and with specified text, caption, buttons, icon, defult message box result, yes button content, no button content, cancel button content and option to set message box on top.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult Show(
    Window owner,
    string messageBoxText,
    string caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult,
    string yesButtonContent,
    string noButtonContent,
    string cancelButtonContent,
    bool closeCaptionButtonVisibility,
    bool topmost
)
MessageBoxResult Show(
    Window^ owner,
    String^ messageBoxText,
    String^ caption,
    MessageBoxButton button,
    MessageBoxImage icon,
    MessageBoxResult defaultMessageBoxResult,
    String^ yesButtonContent,
    String^ noButtonContent,
    String^ cancelButtonContent,
    bool closeCaptionButtonVisibility,
    bool topmost
)

Parameters

owner
Type: System.WindowsWindow
An implementation of IWin32Window that will own the modal dialog box.
messageBoxText
Type: SystemString
The text to display in the message box.
caption
Type: SystemString
The text to display in the title bar of the message box.
button
Type: System.WindowsMessageBoxButton
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
icon
Type: System.WindowsMessageBoxImage
One of the MessageBoxIcon values that specifies which icon to display in the message box.
defaultMessageBoxResult
Type: System.WindowsMessageBoxResult
yesButtonContent
Type: SystemString
The text to display in message box yes button.
noButtonContent
Type: SystemString
The text to display in message box no button.
cancelButtonContent
Type: SystemString
The text to display in message box cancel button.
closeCaptionButtonVisibility
Type: SystemBoolean
True if Close caption button is visible. False otherwise.
topmost
Type: SystemBoolean
True to make this MessageBox the topmost. False otherwise.

Return Value

Type: MessageBoxResult
One of the DialogResult values.
See Also

Reference

IMessageBoxService Interface
Show Overload
VisualComponents.Create3D Namespace


IMessageService Interface

Application messaging service interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IMessageService
public interface class IMessageService

The IMessageService type exposes the following members.

Properties
 | Name | Description
Public property | Messages | Read-only list of currently stored messages.
Top
Methods
 | Name | Description
Public method | AppendMessage(String, MessageLevel) | Adds a new message to the message list.
Public method | AppendMessage(String, MessageLevel, Boolean) | Adds a new message to the message list.
Public method | ClearMessages | Clears the message history.
Top
Events
 | Name | Description
Public event | MessageAdded | Event that occurs when a new message has been added.
Public event | MessagesCleared | Occurs when ClearMessages() is called.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IMessageService Properties

The IMessageService type exposes the following members.

Properties
 | Name | Description
Public property | Messages | Read-only list of currently stored messages.
Top
See Also

Reference

IMessageService Interface
VisualComponents.Create3D Namespace


IMessageService.Messages Property

IMessageServiceMessages Property

Read-only list of currently stored messages.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<string> Messages { get; }
property IList<String^>^ Messages {
    IList<String^>^ get ();
}

Property Value

Type: IListString
See Also

Reference

IMessageService Interface
VisualComponents.Create3D Namespace


IMessageService Methods

The IMessageService type exposes the following members.

Methods
 | Name | Description
Public method | AppendMessage(String, MessageLevel) | Adds a new message to the message list.
Public method | AppendMessage(String, MessageLevel, Boolean) | Adds a new message to the message list.
Public method | ClearMessages | Clears the message history.
Top
See Also

Reference

IMessageService Interface
VisualComponents.Create3D Namespace


IMessageService.AppendMessage Method

IMessageServiceAppendMessage Method

Overload List
 | Name | Description
Public method | AppendMessage(String, MessageLevel) | Adds a new message to the message list.
Public method | AppendMessage(String, MessageLevel, Boolean) | Adds a new message to the message list.
Top
See Also

Reference

IMessageService Interface
VisualComponents.Create3D Namespace


IMessageService.AppendMessage Method (String, MessageLevel)

IMessageServiceAppendMessage Method (String, MessageLevel)

Adds a new message to the message list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AppendMessage(
    string message,
    MessageLevel messageLevel
)
void AppendMessage(
    String^ message,
    MessageLevel messageLevel
)

Parameters

message
Type: SystemString
Message to be added.
messageLevel
Type: VisualComponents.Create3DMessageLevel
Message level.
See Also

Reference

IMessageService Interface
AppendMessage Overload
VisualComponents.Create3D Namespace


IMessageService.AppendMessage Method (String, MessageLevel, Boolean)

IMessageServiceAppendMessage Method (String, MessageLevel, Boolean)

Adds a new message to the message list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AppendMessage(
    string message,
    MessageLevel messageLevel,
    bool writeToLog
)
void AppendMessage(
    String^ message,
    MessageLevel messageLevel,
    bool writeToLog
)

Parameters

message
Type: SystemString
Message to be added.
messageLevel
Type: VisualComponents.Create3DMessageLevel
Message level.
writeToLog
Type: SystemBoolean
Message should written to log file.
See Also

Reference

IMessageService Interface
AppendMessage Overload
VisualComponents.Create3D Namespace


IMessageService.ClearMessages Method

IMessageServiceClearMessages Method

Clears the message history.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ClearMessages()
void ClearMessages()
See Also

Reference

IMessageService Interface
VisualComponents.Create3D Namespace


IMessageService Events

The IMessageService type exposes the following members.

Events
 | Name | Description
Public event | MessageAdded | Event that occurs when a new message has been added.
Public event | MessagesCleared | Occurs when ClearMessages() is called.
Top
See Also

Reference

IMessageService Interface
VisualComponents.Create3D Namespace


IMessageService.MessageAdded Event

IMessageServiceMessageAdded Event

Event that occurs when a new message has been added.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<MessageAddedEventArgs> MessageAdded
 event EventHandler<MessageAddedEventArgs^>^ MessageAdded {
    void add (EventHandler<MessageAddedEventArgs^>^ value);
    void remove (EventHandler<MessageAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerMessageAddedEventArgs
See Also

Reference

IMessageService Interface
VisualComponents.Create3D Namespace


IMessageService.MessagesCleared Event

IMessageServiceMessagesCleared Event

Occurs when ClearMessages() is called.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler MessagesCleared
 event EventHandler^ MessagesCleared {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IMessageService Interface
VisualComponents.Create3D Namespace


IMirrorFeature Interface

Represents a mirror feature object

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IMirrorFeature : IFeature,
    IVisualObject, INamed, IWrapper, IDisposable, IVisitable,
    IPropertyContainer, IBatchModeObject, ISharedCloneable
public interface class IMirrorFeature : IFeature,
    IVisualObject, INamed, IWrapper, IDisposable, IVisitable,
    IPropertyContainer, IBatchModeObject, ISharedCloneable

The IMirrorFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
The Mirror operation feature generates a mirror image of all sub features through the YZ plane.
See Also

Reference

VisualComponents.Create3D Namespace


IMirrorFeature Properties

The IMirrorFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
See Also

Reference

IMirrorFeature Interface
VisualComponents.Create3D Namespace


IMirrorFeature Methods

The IMirrorFeature type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IMirrorFeature Interface
VisualComponents.Create3D Namespace


IMirrorFeature Events

The IMirrorFeature type exposes the following members.

Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

IMirrorFeature Interface
VisualComponents.Create3D Namespace


IModelMetadata Interface

Component metadata

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IModelMetadata
public interface class IModelMetadata

The IModelMetadata type exposes the following members.

Properties
 | Name | Description
Public property | Author | Component Author
Public property | BatchVersion | Batch version number
Public property | Description | Component description
Public property | Email | Component author e-mail
Public property | IconBitmap | Icon bitmap, shown in the eCatalog
Public property | IsComponentMetadata | Indicates whether metadata belongs to a component or layout.
Public property | IsDeprecated | Deprecated component type
Public property | LogoBitmap | Logo bitmap
Public property | MajorVersion | Major version number
Public property | Manufacturer | Component Manufacturer
Public property | MaxPayload | Component Max Payload
Public property | MinorVersion | Minor version number
Public property | Name | Component name
Public property | Path | Path where the component/layout is located.
Public property | PreviewBitmap | Preview bitmap; larger than the icon bitmap.
Public property | Reach | Component Reach
Public property | Revision | Revision number; incremented when the model is saved.
Public property | Tags | Component tags
Public property | Type | Component type
Public property | Vcid | Component VCID. For layout metadata, this is an empty string.
Public property | Website | Component author web-site
Top
Methods
 | Name | Description
Public method | AddKeywords | Add a new range of keywords
Public method | IncrementRevision | Increment current revision and updates major, minor and batch version.
Public method | IsEmpty | Status of the instance
Public method | RefreshIcons | refresh previously loaded icons
Public method | SetNewVcid | Change the VCID to a new unique VCID.
Public method | UpdateDetailedRevision | Updates detailed revision, major, minor and batch version.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IModelMetadata Properties

The IModelMetadata type exposes the following members.

Properties
 | Name | Description
Public property | Author | Component Author
Public property | BatchVersion | Batch version number
Public property | Description | Component description
Public property | Email | Component author e-mail
Public property | IconBitmap | Icon bitmap, shown in the eCatalog
Public property | IsComponentMetadata | Indicates whether metadata belongs to a component or layout.
Public property | IsDeprecated | Deprecated component type
Public property | LogoBitmap | Logo bitmap
Public property | MajorVersion | Major version number
Public property | Manufacturer | Component Manufacturer
Public property | MaxPayload | Component Max Payload
Public property | MinorVersion | Minor version number
Public property | Name | Component name
Public property | Path | Path where the component/layout is located.
Public property | PreviewBitmap | Preview bitmap; larger than the icon bitmap.
Public property | Reach | Component Reach
Public property | Revision | Revision number; incremented when the model is saved.
Public property | Tags | Component tags
Public property | Type | Component type
Public property | Vcid | Component VCID. For layout metadata, this is an empty string.
Public property | Website | Component author web-site
Top
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IModelMetadata.Author Property

IModelMetadataAuthor Property

Component Author

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Author { get; set; }
property String^ Author {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IModelMetadata.BatchVersion Property

IModelMetadataBatchVersion Property

Batch version number

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int BatchVersion { get; set; }
property int BatchVersion {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IModelMetadata.Description Property

IModelMetadataDescription Property

Component description

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Description { get; set; }
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IModelMetadata.Email Property

IModelMetadataEmail Property

Component author e-mail

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Email { get; set; }
property String^ Email {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IModelMetadata.IconBitmap Property

IModelMetadataIconBitmap Property

Icon bitmap, shown in the eCatalog

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Bitmap IconBitmap { get; }
property Bitmap^ IconBitmap {
    Bitmap^ get ();
}

Property Value

Type: Bitmap
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IModelMetadata.IsComponentMetadata Property

IModelMetadataIsComponentMetadata Property

Indicates whether metadata belongs to a component or layout.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsComponentMetadata { get; }
property bool IsComponentMetadata {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IModelMetadata.IsDeprecated Property

IModelMetadataIsDeprecated Property

Deprecated component type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsDeprecated { get; set; }
property bool IsDeprecated {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IModelMetadata.LogoBitmap Property

IModelMetadataLogoBitmap Property

Logo bitmap

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Bitmap LogoBitmap { get; set; }
property Bitmap^ LogoBitmap {
    Bitmap^ get ();
    void set (Bitmap^ value);
}

Property Value

Type: Bitmap
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IModelMetadata.MajorVersion Property

IModelMetadataMajorVersion Property

Major version number

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int MajorVersion { get; set; }
property int MajorVersion {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IModelMetadata.Manufacturer Property

IModelMetadataManufacturer Property

Component Manufacturer

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Manufacturer { get; set; }
property String^ Manufacturer {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IModelMetadata.MaxPayload Property

IModelMetadataMaxPayload Property

Component Max Payload

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int MaxPayload { get; set; }
property int MaxPayload {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IModelMetadata.MinorVersion Property

IModelMetadataMinorVersion Property

Minor version number

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int MinorVersion { get; set; }
property int MinorVersion {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IModelMetadata.Name Property

IModelMetadataName Property

Component name

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Name { get; set; }
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IModelMetadata.Path Property

IModelMetadataPath Property

Path where the component/layout is located.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Path { get; }
property String^ Path {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IModelMetadata.PreviewBitmap Property

IModelMetadataPreviewBitmap Property

Preview bitmap; larger than the icon bitmap.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Bitmap PreviewBitmap { get; }
property Bitmap^ PreviewBitmap {
    Bitmap^ get ();
}

Property Value

Type: Bitmap
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IModelMetadata.Reach Property

IModelMetadataReach Property

Component Reach

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int Reach { get; set; }
property int Reach {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IModelMetadata.Revision Property

IModelMetadataRevision Property

Revision number; incremented when the model is saved.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int Revision { get; }
property int Revision {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IModelMetadata.Tags Property

IModelMetadataTags Property

Component tags

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<string> Tags { get; set; }
property IEnumerable<String^>^ Tags {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}

Property Value

Type: IEnumerableString
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IModelMetadata.Type Property

IModelMetadataType Property

Component type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Type { get; set; }
property String^ Type {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IModelMetadata.Vcid Property

IModelMetadataVcid Property

Component VCID. For layout metadata, this is an empty string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Vcid { get; }
property String^ Vcid {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IModelMetadata.Website Property

IModelMetadataWebsite Property

Component author web-site

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Website { get; set; }
property String^ Website {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IModelMetadata Methods

The IModelMetadata type exposes the following members.

Methods
 | Name | Description
Public method | AddKeywords | Add a new range of keywords
Public method | IncrementRevision | Increment current revision and updates major, minor and batch version.
Public method | IsEmpty | Status of the instance
Public method | RefreshIcons | refresh previously loaded icons
Public method | SetNewVcid | Change the VCID to a new unique VCID.
Public method | UpdateDetailedRevision | Updates detailed revision, major, minor and batch version.
Top
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IModelMetadata.AddKeywords Method

IModelMetadataAddKeywords Method

Add a new range of keywords

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddKeywords(
    IDictionary<string, string> keywords
)
void AddKeywords(
    IDictionary<String^, String^>^ keywords
)

Parameters

keywords
Type: System.Collections.GenericIDictionaryString, String
key/value pair of keyword
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IModelMetadata.IncrementRevision Method

IModelMetadataIncrementRevision Method

Increment current revision and updates major, minor and batch version.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void IncrementRevision()
void IncrementRevision()
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IModelMetadata.IsEmpty Method

IModelMetadataIsEmpty Method

Status of the instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsEmpty()
bool IsEmpty()

Return Value

Type: Boolean
true if the instance doesn't have any values
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IModelMetadata.RefreshIcons Method

IModelMetadataRefreshIcons Method

refresh previously loaded icons

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RefreshIcons()
void RefreshIcons()
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IModelMetadata.SetNewVcid Method

IModelMetadataSetNewVcid Method

Change the VCID to a new unique VCID.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetNewVcid()
void SetNewVcid()
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IModelMetadata.UpdateDetailedRevision Method

IModelMetadataUpdateDetailedRevision Method

Updates detailed revision, major, minor and batch version.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateDetailedRevision()
void UpdateDetailedRevision()
See Also

Reference

IModelMetadata Interface
VisualComponents.Create3D Namespace


IMotionInterpolator Interface

An interface for interpolating motion target paths. The motion interpolator's life time is managed by its user, see remarks.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IMotionInterpolator : IDisposable
public interface class IMotionInterpolator : IDisposable

The IMotionInterpolator type exposes the following members.

Properties
 | Name | Description
Public property | IsValid | Checks if the instance has been disposed.
Public property | Targets | Motion targets added with AddTarget(IMotionTarget).
Top
Methods
 | Name | Description
Public method | AddTarget | Adds a position to the interpolation path.
Public method | ClearTargets | Clears the interpolation path.
Public method | DeleteTargetAt | Removes a position from the path.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetCycleTimeAt | Calculates the time necessary to interpolate a particular segment.
Public method | Interpolate | Calculates the robot's state at a specified time.
Public method | SetTargetAt | Replaces a position in the path.
Top
Remarks
The Life time of motion interpolator instances is managed externally. Therefore, it is important that the instance is properly released by its user by calling Dispose.
See Also

Reference

VisualComponents.Create3D Namespace


IMotionInterpolator Properties

The IMotionInterpolator type exposes the following members.

Properties
 | Name | Description
Public property | IsValid | Checks if the instance has been disposed.
Public property | Targets | Motion targets added with AddTarget(IMotionTarget).
Top
See Also

Reference

IMotionInterpolator Interface
VisualComponents.Create3D Namespace


IMotionInterpolator.IsValid Property

IMotionInterpolatorIsValid Property

Checks if the instance has been disposed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsValid { get; }
property bool IsValid {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IMotionInterpolator Interface
VisualComponents.Create3D Namespace


IMotionInterpolator.Targets Property

IMotionInterpolatorTargets Property

Motion targets added with AddTarget(IMotionTarget).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IMotionTarget> Targets { get; }
property IList<IMotionTarget^>^ Targets {
    IList<IMotionTarget^>^ get ();
}

Property Value

Type: IListIMotionTarget
See Also

Reference

IMotionInterpolator Interface
VisualComponents.Create3D Namespace


IMotionInterpolator Methods

The IMotionInterpolator type exposes the following members.

Methods
 | Name | Description
Public method | AddTarget | Adds a position to the interpolation path.
Public method | ClearTargets | Clears the interpolation path.
Public method | DeleteTargetAt | Removes a position from the path.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetCycleTimeAt | Calculates the time necessary to interpolate a particular segment.
Public method | Interpolate | Calculates the robot's state at a specified time.
Public method | SetTargetAt | Replaces a position in the path.
Top
See Also

Reference

IMotionInterpolator Interface
VisualComponents.Create3D Namespace


IMotionInterpolator.AddTarget Method

IMotionInterpolatorAddTarget Method

Adds a position to the interpolation path.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddTarget(
    IMotionTarget target
)
void AddTarget(
    IMotionTarget^ target
)

Parameters

target
Type: VisualComponents.Create3DIMotionTarget
Robot's position/state, defined with IMotionTarget
See Also

Reference

IMotionInterpolator Interface
VisualComponents.Create3D Namespace


IMotionInterpolator.ClearTargets Method

IMotionInterpolatorClearTargets Method

Clears the interpolation path.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ClearTargets()
void ClearTargets()
See Also

Reference

IMotionInterpolator Interface
VisualComponents.Create3D Namespace


IMotionInterpolator.DeleteTargetAt Method

IMotionInterpolatorDeleteTargetAt Method

Removes a position from the path.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteTargetAt(
    int index
)
void DeleteTargetAt(
    int index
)

Parameters

index
Type: SystemInt32
See Also

Reference

IMotionInterpolator Interface
VisualComponents.Create3D Namespace


IMotionInterpolator.GetCycleTimeAt Method

IMotionInterpolatorGetCycleTimeAt Method

Calculates the time necessary to interpolate a particular segment.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double GetCycleTimeAt(
    int index
)
double GetCycleTimeAt(
    int index
)

Parameters

index
Type: SystemInt32
Path segment index

Return Value

Type: Double
Path segment simulation time
See Also

Reference

IMotionInterpolator Interface
VisualComponents.Create3D Namespace


IMotionInterpolator.Interpolate Method

IMotionInterpolatorInterpolate Method

Calculates the robot's state at a specified time.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool Interpolate(
    double cycleTime,
    ref IMotionTarget target
)
bool Interpolate(
    double cycleTime,
    IMotionTarget^% target
)

Parameters

cycleTime
Type: SystemDouble
Time for which to calculate the position
target
Type: VisualComponents.Create3DIMotionTarget
Resulting position/state

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IMotionInterpolator.Interpolate(System.Double,VisualComponents.Create3D.IMotionTarget@)"]

See Also

Reference

IMotionInterpolator Interface
VisualComponents.Create3D Namespace


IMotionInterpolator.SetTargetAt Method

IMotionInterpolatorSetTargetAt Method

Replaces a position in the path.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetTargetAt(
    int index,
    IMotionTarget target
)
void SetTargetAt(
    int index,
    IMotionTarget^ target
)

Parameters

index
Type: SystemInt32
Index of item to replace
target
Type: VisualComponents.Create3DIMotionTarget
New position, defined with IMotionTarget
See Also

Reference

IMotionInterpolator Interface
VisualComponents.Create3D Namespace


IMotionModeStatement Interface

Interface for motion mode statement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IMotionModeStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IMotionModeStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IMotionModeStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Mode | The mode specifier.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IMotionModeStatement Properties

The IMotionModeStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Mode | The mode specifier.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
See Also

Reference

IMotionModeStatement Interface
VisualComponents.Create3D Namespace


IMotionModeStatement.Mode Property

IMotionModeStatementMode Property

The mode specifier.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MotionMode Mode { get; set; }
property MotionMode Mode {
    MotionMode get ();
    void set (MotionMode value);
}

Property Value

Type: MotionMode
See Also

Reference

IMotionModeStatement Interface
VisualComponents.Create3D Namespace


IMotionModeStatement Methods

The IMotionModeStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IMotionModeStatement Interface
VisualComponents.Create3D Namespace


IMotionModeStatement Events

The IMotionModeStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IMotionModeStatement Interface
VisualComponents.Create3D Namespace


IMotionPath Interface

Base interface for motion path behaviors.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IMotionPath : ISimContainer,
    IFlowBehavior, IBehavior, IPropertyContainer, IBatchModeObject, IVisitable,
    IWrapper, IDisposable, INamed
public interface class IMotionPath : ISimContainer,
    IFlowBehavior, IBehavior, IPropertyContainer, IBatchModeObject, IVisitable,
    IWrapper, IDisposable, INamed

The IMotionPath type exposes the following members.

Properties
 | Name | Description
Public property | Acceleration | Gets or sets acceleration rate of components on the path, in millimeters per second squared. If this is zero, acceleration is not calculated.
Public property | Accumulate | Determines whether components on the path accumulate when one or more components are blocked at the end of the path. If true, components behind a blocked component keep moving until they hit the blocked component. If false, all components in the path stop when the end is blocked.
Public property | Capacity | Maximum logical capacity of the container. This determines the maximum number of components that can be contained in the container at any one time. (Inherited from ISimContainer.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Components | list of components currently contained in the container (Inherited from ISimContainer.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Deceleration | Gets or sets deceleration rate of components on the path, in millimeters per second squared. If this is zero, deceleration is not calculated.
Public property | DetailCurveMotion | Determines if parts use at curved areas bound box information to avoid box shaped parts to intersect at corners. In some cases like when parts are cylindrical shapes this can cause extra spacing between parts in the curves and in these cases option could be disabled. Part starting movement at curve area after linear section will slow down slightly part immediately behind (at linear section) when part bound box starts rotating. If slight intersection temporarily in the transition from linear section to curved section is not a problem or is part shapes are cylindrical or similar then this option could be disabled.
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | HeadComponent | Returns component in the head of container (Inherited from ISimContainer.)
Public property | Interpolation | Gets or sets interpolation mode to use with the path frames.
Public property | IsContentVisible | Defines whether components held by the container are displayed or not (Inherited from ISimContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Path | Gets the ordered list of frames that define the path. The actual path is then calculated by interpolating using the method defined by InterpolationMode property.
Public property | PathLength | Gets the total length of the path.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | RetainOffset | Determines how components are positioned on the path when they enter the path. If true, the component offset is retained, otherwise the component is placed with its origin at the nearest point on the path.
Public property | SegmentSize | Gets or sets conveyor segment size. If this is greater to zero, the conveyor is divided into segments of the given size, each of which may contain at most one component at any one time. The total number of segments will then determine the maximum capacity of the conveyor in addition to the Capacity property and any associated capacity controllers.
Public property | Sensors | Gets the list of sensors that are used in this path.
Public property | SpaceUtilization | Determines if components are kept apart from each other in accumulating mode, or when new components are added to the path. If set to false, components may overlap. This may be useful when RetainOffset is true and the components are spread out along the width of a conveyor. In this case two components are allowed to be side by side on the conveyor.
Public property | Speed | Gets or sets the speed of the conveyor, in millimeters per second.
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | TailComponent | Returns component in the tail of container (Inherited from ISimContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetContainerProximity | Calculate the orthogonal distance from position to this container (Inherited from ISimContainer.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetPathDistanceAtPosition | Gets the path distance at the path position. If the position is outside the path then the distance at closest path position is returned.
Public method | GetPathPositionAtDistance | Gets the path position at given distance
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Grab | Grab the component into this container (Inherited from ISimContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ComponentArriving | Triggered when a component is arriving to the container (Inherited from ISimContainer.)
Public event | ComponentLeaving | Triggered when a component is leaving from the container (Inherited from ISimContainer.)
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IMotionPath Properties

The IMotionPath type exposes the following members.

Properties
 | Name | Description
Public property | Acceleration | Gets or sets acceleration rate of components on the path, in millimeters per second squared. If this is zero, acceleration is not calculated.
Public property | Accumulate | Determines whether components on the path accumulate when one or more components are blocked at the end of the path. If true, components behind a blocked component keep moving until they hit the blocked component. If false, all components in the path stop when the end is blocked.
Public property | Capacity | Maximum logical capacity of the container. This determines the maximum number of components that can be contained in the container at any one time. (Inherited from ISimContainer.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Components | list of components currently contained in the container (Inherited from ISimContainer.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Deceleration | Gets or sets deceleration rate of components on the path, in millimeters per second squared. If this is zero, deceleration is not calculated.
Public property | DetailCurveMotion | Determines if parts use at curved areas bound box information to avoid box shaped parts to intersect at corners. In some cases like when parts are cylindrical shapes this can cause extra spacing between parts in the curves and in these cases option could be disabled. Part starting movement at curve area after linear section will slow down slightly part immediately behind (at linear section) when part bound box starts rotating. If slight intersection temporarily in the transition from linear section to curved section is not a problem or is part shapes are cylindrical or similar then this option could be disabled.
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | HeadComponent | Returns component in the head of container (Inherited from ISimContainer.)
Public property | Interpolation | Gets or sets interpolation mode to use with the path frames.
Public property | IsContentVisible | Defines whether components held by the container are displayed or not (Inherited from ISimContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Path | Gets the ordered list of frames that define the path. The actual path is then calculated by interpolating using the method defined by InterpolationMode property.
Public property | PathLength | Gets the total length of the path.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | RetainOffset | Determines how components are positioned on the path when they enter the path. If true, the component offset is retained, otherwise the component is placed with its origin at the nearest point on the path.
Public property | SegmentSize | Gets or sets conveyor segment size. If this is greater to zero, the conveyor is divided into segments of the given size, each of which may contain at most one component at any one time. The total number of segments will then determine the maximum capacity of the conveyor in addition to the Capacity property and any associated capacity controllers.
Public property | Sensors | Gets the list of sensors that are used in this path.
Public property | SpaceUtilization | Determines if components are kept apart from each other in accumulating mode, or when new components are added to the path. If set to false, components may overlap. This may be useful when RetainOffset is true and the components are spread out along the width of a conveyor. In this case two components are allowed to be side by side on the conveyor.
Public property | Speed | Gets or sets the speed of the conveyor, in millimeters per second.
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | TailComponent | Returns component in the tail of container (Inherited from ISimContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IMotionPath Interface
VisualComponents.Create3D Namespace


IMotionPath.Acceleration Property

IMotionPathAcceleration Property

Gets or sets acceleration rate of components on the path, in millimeters per second squared. If this is zero, acceleration is not calculated.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Acceleration { get; set; }
property double Acceleration {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IMotionPath Interface
VisualComponents.Create3D Namespace


IMotionPath.Accumulate Property

IMotionPathAccumulate Property

Determines whether components on the path accumulate when one or more components are blocked at the end of the path. If true, components behind a blocked component keep moving until they hit the blocked component. If false, all components in the path stop when the end is blocked.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool Accumulate { get; set; }
property bool Accumulate {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IMotionPath Interface
VisualComponents.Create3D Namespace


IMotionPath.Deceleration Property

IMotionPathDeceleration Property

Gets or sets deceleration rate of components on the path, in millimeters per second squared. If this is zero, deceleration is not calculated.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Deceleration { get; set; }
property double Deceleration {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IMotionPath Interface
VisualComponents.Create3D Namespace


IMotionPath.DetailCurveMotion Property

IMotionPathDetailCurveMotion Property

Determines if parts use at curved areas bound box information to avoid box shaped parts to intersect at corners. In some cases like when parts are cylindrical shapes this can cause extra spacing between parts in the curves and in these cases option could be disabled. Part starting movement at curve area after linear section will slow down slightly part immediately behind (at linear section) when part bound box starts rotating. If slight intersection temporarily in the transition from linear section to curved section is not a problem or is part shapes are cylindrical or similar then this option could be disabled.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool DetailCurveMotion { get; set; }
property bool DetailCurveMotion {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IMotionPath Interface
VisualComponents.Create3D Namespace


IMotionPath.Interpolation Property

IMotionPathInterpolation Property

Gets or sets interpolation mode to use with the path frames.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MotionPathInterpolation Interpolation { get; set; }
property MotionPathInterpolation Interpolation {
    MotionPathInterpolation get ();
    void set (MotionPathInterpolation value);
}

Property Value

Type: MotionPathInterpolation
See Also

Reference

IMotionPath Interface
VisualComponents.Create3D Namespace


IMotionPath.Path Property

IMotionPathPath Property

Gets the ordered list of frames that define the path. The actual path is then calculated by interpolating using the method defined by InterpolationMode property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IFrameFeature> Path { get; }
property IList<IFrameFeature^>^ Path {
    IList<IFrameFeature^>^ get ();
}

Property Value

Type: IListIFrameFeature
See Also

Reference

IMotionPath Interface
VisualComponents.Create3D Namespace


IMotionPath.PathLength Property

IMotionPathPathLength Property

Gets the total length of the path.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double PathLength { get; }
property double PathLength {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IMotionPath Interface
VisualComponents.Create3D Namespace


IMotionPath.RetainOffset Property

IMotionPathRetainOffset Property

Determines how components are positioned on the path when they enter the path. If true, the component offset is retained, otherwise the component is placed with its origin at the nearest point on the path.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool RetainOffset { get; set; }
property bool RetainOffset {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IMotionPath Interface
VisualComponents.Create3D Namespace


IMotionPath.SegmentSize Property

IMotionPathSegmentSize Property

Gets or sets conveyor segment size. If this is greater to zero, the conveyor is divided into segments of the given size, each of which may contain at most one component at any one time. The total number of segments will then determine the maximum capacity of the conveyor in addition to the Capacity property and any associated capacity controllers.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double SegmentSize { get; set; }
property double SegmentSize {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Remarks
When this value is greater to zero, a contained component will not move into the next segment until the previous component has left it completely.
See Also

Reference

IMotionPath Interface
VisualComponents.Create3D Namespace


IMotionPath.Sensors Property

IMotionPathSensors Property

Gets the list of sensors that are used in this path.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IBehavior> Sensors { get; }
property IList<IBehavior^>^ Sensors {
    IList<IBehavior^>^ get ();
}

Property Value

Type: IListIBehavior
See Also

Reference

IMotionPath Interface
VisualComponents.Create3D Namespace


IMotionPath.SpaceUtilization Property

IMotionPathSpaceUtilization Property

Determines if components are kept apart from each other in accumulating mode, or when new components are added to the path. If set to false, components may overlap. This may be useful when RetainOffset is true and the components are spread out along the width of a conveyor. In this case two components are allowed to be side by side on the conveyor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SpaceUtilization { get; set; }
property bool SpaceUtilization {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IMotionPath Interface
VisualComponents.Create3D Namespace


IMotionPath.Speed Property

IMotionPathSpeed Property

Gets or sets the speed of the conveyor, in millimeters per second.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Speed { get; set; }
property double Speed {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IMotionPath Interface
VisualComponents.Create3D Namespace


IMotionPath Methods

The IMotionPath type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetContainerProximity | Calculate the orthogonal distance from position to this container (Inherited from ISimContainer.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetPathDistanceAtPosition | Gets the path distance at the path position. If the position is outside the path then the distance at closest path position is returned.
Public method | GetPathPositionAtDistance | Gets the path position at given distance
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Grab | Grab the component into this container (Inherited from ISimContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IMotionPath Interface
VisualComponents.Create3D Namespace


IMotionPath.GetPathDistanceAtPosition Method

IMotionPathGetPathDistanceAtPosition Method

Gets the path distance at the path position. If the position is outside the path then the distance at closest path position is returned.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double GetPathDistanceAtPosition(
    Matrix position
)
double GetPathDistanceAtPosition(
    Matrix position
)

Parameters

position
Type: VisualComponents.Create3DMatrix
Position in node's coordinate system

Return Value

Type: Double
Path distance at the given position
See Also

Reference

IMotionPath Interface
VisualComponents.Create3D Namespace


IMotionPath.GetPathPositionAtDistance Method

IMotionPathGetPathPositionAtDistance Method

Gets the path position at given distance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix GetPathPositionAtDistance(
    double distance
)
Matrix GetPathPositionAtDistance(
    double distance
)

Parameters

distance
Type: SystemDouble
Path distance

Return Value

Type: Matrix
Path position in node's coordinate system
See Also

Reference

IMotionPath Interface
VisualComponents.Create3D Namespace


IMotionPath Events

The IMotionPath type exposes the following members.

Events
 | Name | Description
Public event | ComponentArriving | Triggered when a component is arriving to the container (Inherited from ISimContainer.)
Public event | ComponentLeaving | Triggered when a component is leaving from the container (Inherited from ISimContainer.)
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IMotionPath Interface
VisualComponents.Create3D Namespace


IMotionTarget Interface

Motion target for a robot, which may include joint and tool behavior as well as speed and configuration settings for orientation solutions.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IMotionTarget : IWrapper,
    IDisposable
public interface class IMotionTarget : IWrapper,
    IDisposable

The IMotionTarget type exposes the following members.

Properties
 | Name | Description
Public property | AccuracyMethod | Defines the zone of accuracy type to use for the target, for example distance, time or velocity.
Public property | AccuracyValue | Defines the limit used in AccuracyMethod.
Public property | AngularSpeed | Defines the rate of target rotation (degrees/s), which is only used for non-joint motions.
Public property | BaseMatrix | Position of robot's base, relative to the node it's attached to.
Public property | BaseName | Name of the selected base frame.
Public property | CartesianAcceleration | Gets or sets maximum cartesian acceleration for linear movements.
Public property | CartesianDeceleration | Gets or sets maximum cartesian deceleration for linear movements.
Public property | CartesianSpeed | Defines the rate of target translation (units/s), which is only used for non-joint motions.
Public property | ConfigurationCount | Number of joint configurations.
Public property | ConfigurationMode | Defines the robot's joint configuration during linear interpolation.
Public property | CurrentConfiguration | Current joint configuration type.
Public property | CycleTime | Cycle time. If this is greater than zero, it overrides any other speed parameters.
Public property | ExternalJointCount | Amount of joints defined in the track controller and workpiece controller.
Public property | ExternalTcp | Robot's external tcp mode.
Public property | InternalJointCount | Amount of joints defined in the robot controller.
Public property | IsContinuous | Indicates that robot should move through this point without decelerating. Note: this flag is usable only in rare cases. There are few demands for it to work nicely: - external joints must not move. - both previous and next movement targets must be linear. - distance of the previous and next movements should be similar. - orientation of previous/this/next movement targets should be similar.
Public property | IsReachable | Obsolete. Indicates that Status contains Reachable.
Public property | IsStatusValid | Indicates that Status contains Reachable and WithinJointLimits. NoSingularity-flag is ignored.
Public property | IsValid | (Inherited from IWrapper.)
Public property | JointCount | Amount of joints defined in the robot controller, track controller, and workpiece controller.
Public property | JointSpeed | Defines the joint speed at the target, as a factor of maximum speed determined in robot controller. Value from 0 to 100.
Public property | JointTurnMode | Defines joint turn changes during linear interpolation.
Public property | MotionType | Interpolation type: point-to-point or linear.
Public property | NamedBases | Names of all base frames.
Public property | NamedTools | Names of all tool frames.
Public property | NearestConfiguration | Nearest joint configuration type.
Public property | OrientationInterpolationMode | Interpolation method used for orientation.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | RobotController | Robot's controller behavior.
Public property | RobotPositioner | Controller of the robot's track component.
Public property | RobotPositionerJointCount | Amount of joints defined in the track controller.
Public property | RobotRootToRobotFlangeMatrix | Flange position relative to robot's root.
Public property | RootNodeToRobotRootMatrix | Robot's root position relative to robot's node.
Public property | Status | Final position status, calculated from ConfigurationWarnings.
Public property | TargetMatrix | Target position for inverse kinematics. Note: This matrix is not always compatible with IRobotController.ToolCenterPoint. When TargetMode == World this matrix is defined in world coordinates, while 'IRobotController.ToolCenterPoint' is relative to 'IRobotController.RobotWorldNode.TransformationInWorld'.
Public property | TargetMode | Target matrix relationship with a robot.
Public property | ToolMatrix | Position of robot's tool, relative to the node it's attached to.
Public property | ToolName | Name of the selected tool frame.
Public property | UseJointValues | Indicates that inverse kinematics calculation is not needed.
Public property | WorkpiecePositionerJointCount | Amount of joints defined in the workpiece controller.
Public property | WorkpiecePositioners | Controllers of the robot's workpiece components.
Public property | WorldBaseMatrix | Absolute position of robot's base.
Public property | WorldBaseMatrix2 | Absolute position of robot's base, when taking into account all joint values stored in this motion target.
Public property | WorldTargetMatrix | Target position for inverse kinematics. Defined in absolute coordinates.
Public property | WorldToRootNodeMatrix | Robot's root position. Defined in absolute coordinates.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetAllJointStarts | Returns joint start values.
Public method | GetAllJointTurns | Returns turn counts of individual joints.
Public method | GetAllJointValues | Returns joint values of a robot.
Public method | GetConfigurationWarnings | Returns state of inverse kinematics calculation for a specific configuration.
Public method | GetExternalJointTurns | Return turn counts of external joints.
Public method | GetExternalJointValues | Returns external joint values (track, workpiece servo, etc).
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetRobotPositionerJointTurns | Returns turn counts of the track's joints.
Public method | GetRobotPositionerJointValues | Returns joint values of a track.
Public method | GetWorkpiecePositionerJointTurns | Returns turn counts of the workpiece joints.
Public method | GetWorkpiecePositionerJointValues | Returns joint values of a workpiece.
Public method | SetAllJointTurns | Sets turn counts of individual joints.
Public method | SetAllJointValues | Sets motion target's all joint values.
Public method | SetExternalJointTurns | Sets turn counts of external joints.
Public method | SetExternalJointValues | Sets motion target's external joints values.
Public method | SetRobotPositionerJointTurns | Sets turn counts of the track joints.
Public method | SetRobotPositionerJointValues | Sets track's joint values.
Public method | SetWorkpiecePositionerJointTurns | Sets turn counts of the workpiece joints.
Public method | SetWorkpiecePositionerJointValues | Sets workpieces joint values.
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IMotionTarget Properties

The IMotionTarget type exposes the following members.

Properties
 | Name | Description
Public property | AccuracyMethod | Defines the zone of accuracy type to use for the target, for example distance, time or velocity.
Public property | AccuracyValue | Defines the limit used in AccuracyMethod.
Public property | AngularSpeed | Defines the rate of target rotation (degrees/s), which is only used for non-joint motions.
Public property | BaseMatrix | Position of robot's base, relative to the node it's attached to.
Public property | BaseName | Name of the selected base frame.
Public property | CartesianAcceleration | Gets or sets maximum cartesian acceleration for linear movements.
Public property | CartesianDeceleration | Gets or sets maximum cartesian deceleration for linear movements.
Public property | CartesianSpeed | Defines the rate of target translation (units/s), which is only used for non-joint motions.
Public property | ConfigurationCount | Number of joint configurations.
Public property | ConfigurationMode | Defines the robot's joint configuration during linear interpolation.
Public property | CurrentConfiguration | Current joint configuration type.
Public property | CycleTime | Cycle time. If this is greater than zero, it overrides any other speed parameters.
Public property | ExternalJointCount | Amount of joints defined in the track controller and workpiece controller.
Public property | ExternalTcp | Robot's external tcp mode.
Public property | InternalJointCount | Amount of joints defined in the robot controller.
Public property | IsContinuous | Indicates that robot should move through this point without decelerating. Note: this flag is usable only in rare cases. There are few demands for it to work nicely: - external joints must not move. - both previous and next movement targets must be linear. - distance of the previous and next movements should be similar. - orientation of previous/this/next movement targets should be similar.
Public property | IsReachable | Obsolete. Indicates that Status contains Reachable.
Public property | IsStatusValid | Indicates that Status contains Reachable and WithinJointLimits. NoSingularity-flag is ignored.
Public property | IsValid | (Inherited from IWrapper.)
Public property | JointCount | Amount of joints defined in the robot controller, track controller, and workpiece controller.
Public property | JointSpeed | Defines the joint speed at the target, as a factor of maximum speed determined in robot controller. Value from 0 to 100.
Public property | JointTurnMode | Defines joint turn changes during linear interpolation.
Public property | MotionType | Interpolation type: point-to-point or linear.
Public property | NamedBases | Names of all base frames.
Public property | NamedTools | Names of all tool frames.
Public property | NearestConfiguration | Nearest joint configuration type.
Public property | OrientationInterpolationMode | Interpolation method used for orientation.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | RobotController | Robot's controller behavior.
Public property | RobotPositioner | Controller of the robot's track component.
Public property | RobotPositionerJointCount | Amount of joints defined in the track controller.
Public property | RobotRootToRobotFlangeMatrix | Flange position relative to robot's root.
Public property | RootNodeToRobotRootMatrix | Robot's root position relative to robot's node.
Public property | Status | Final position status, calculated from ConfigurationWarnings.
Public property | TargetMatrix | Target position for inverse kinematics. Note: This matrix is not always compatible with IRobotController.ToolCenterPoint. When TargetMode == World this matrix is defined in world coordinates, while 'IRobotController.ToolCenterPoint' is relative to 'IRobotController.RobotWorldNode.TransformationInWorld'.
Public property | TargetMode | Target matrix relationship with a robot.
Public property | ToolMatrix | Position of robot's tool, relative to the node it's attached to.
Public property | ToolName | Name of the selected tool frame.
Public property | UseJointValues | Indicates that inverse kinematics calculation is not needed.
Public property | WorkpiecePositionerJointCount | Amount of joints defined in the workpiece controller.
Public property | WorkpiecePositioners | Controllers of the robot's workpiece components.
Public property | WorldBaseMatrix | Absolute position of robot's base.
Public property | WorldBaseMatrix2 | Absolute position of robot's base, when taking into account all joint values stored in this motion target.
Public property | WorldTargetMatrix | Target position for inverse kinematics. Defined in absolute coordinates.
Public property | WorldToRootNodeMatrix | Robot's root position. Defined in absolute coordinates.
Top
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.AccuracyMethod Property

IMotionTargetAccuracyMethod Property

Defines the zone of accuracy type to use for the target, for example distance, time or velocity.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
AccuracyMethod AccuracyMethod { get; set; }
property AccuracyMethod AccuracyMethod {
    AccuracyMethod get ();
    void set (AccuracyMethod value);
}

Property Value

Type: AccuracyMethod
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.AccuracyValue Property

IMotionTargetAccuracyValue Property

Defines the limit used in AccuracyMethod.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double AccuracyValue { get; set; }
property double AccuracyValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.AngularSpeed Property

IMotionTargetAngularSpeed Property

Defines the rate of target rotation (degrees/s), which is only used for non-joint motions.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double AngularSpeed { get; set; }
property double AngularSpeed {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.BaseMatrix Property

IMotionTargetBaseMatrix Property

Position of robot's base, relative to the node it's attached to.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix BaseMatrix { get; set; }
property Matrix BaseMatrix {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.BaseName Property

IMotionTargetBaseName Property

Name of the selected base frame.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string BaseName { get; set; }
property String^ BaseName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.CartesianAcceleration Property

IMotionTargetCartesianAcceleration Property

Gets or sets maximum cartesian acceleration for linear movements.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double CartesianAcceleration { get; set; }
property double CartesianAcceleration {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.CartesianDeceleration Property

IMotionTargetCartesianDeceleration Property

Gets or sets maximum cartesian deceleration for linear movements.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double CartesianDeceleration { get; set; }
property double CartesianDeceleration {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.CartesianSpeed Property

IMotionTargetCartesianSpeed Property

Defines the rate of target translation (units/s), which is only used for non-joint motions.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double CartesianSpeed { get; set; }
property double CartesianSpeed {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.ConfigurationCount Property

IMotionTargetConfigurationCount Property

Number of joint configurations.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int ConfigurationCount { get; }
property int ConfigurationCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.ConfigurationMode Property

IMotionTargetConfigurationMode Property

Defines the robot's joint configuration during linear interpolation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ConfigurationMode ConfigurationMode { get; set; }
property ConfigurationMode ConfigurationMode {
    ConfigurationMode get ();
    void set (ConfigurationMode value);
}

Property Value

Type: ConfigurationMode
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.CurrentConfiguration Property

IMotionTargetCurrentConfiguration Property

Current joint configuration type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int CurrentConfiguration { get; set; }
property int CurrentConfiguration {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.CycleTime Property

IMotionTargetCycleTime Property

Cycle time. If this is greater than zero, it overrides any other speed parameters.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double CycleTime { get; set; }
property double CycleTime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.ExternalJointCount Property

IMotionTargetExternalJointCount Property

Amount of joints defined in the track controller and workpiece controller.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int ExternalJointCount { get; }
property int ExternalJointCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.ExternalTcp Property

IMotionTargetExternalTcp Property

Robot's external tcp mode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ExternalTcp { get; set; }
property bool ExternalTcp {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.InternalJointCount Property

IMotionTargetInternalJointCount Property

Amount of joints defined in the robot controller.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int InternalJointCount { get; }
property int InternalJointCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.IsContinuous Property

IMotionTargetIsContinuous Property

Indicates that robot should move through this point without decelerating. Note: this flag is usable only in rare cases. There are few demands for it to work nicely: - external joints must not move. - both previous and next movement targets must be linear. - distance of the previous and next movements should be similar. - orientation of previous/this/next movement targets should be similar.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsContinuous { get; set; }
property bool IsContinuous {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.IsReachable Property

IMotionTargetIsReachable Property

Note: This API is now obsolete.

Indicates that Status contains Reachable.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Use 'Status & PositionStatus.Reachable' instead.")]
bool IsReachable { get; }
[ObsoleteAttribute(L"Use 'Status & PositionStatus.Reachable' instead.")]
property bool IsReachable {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.IsStatusValid Property

IMotionTargetIsStatusValid Property

Indicates that Status contains Reachable and WithinJointLimits. NoSingularity-flag is ignored.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsStatusValid { get; }
property bool IsStatusValid {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.JointCount Property

IMotionTargetJointCount Property

Amount of joints defined in the robot controller, track controller, and workpiece controller.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int JointCount { get; }
property int JointCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.JointSpeed Property

IMotionTargetJointSpeed Property

Defines the joint speed at the target, as a factor of maximum speed determined in robot controller. Value from 0 to 100.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double JointSpeed { get; set; }
property double JointSpeed {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.JointTurnMode Property

IMotionTargetJointTurnMode Property

Defines joint turn changes during linear interpolation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
JointTurnMode JointTurnMode { get; set; }
property JointTurnMode JointTurnMode {
    JointTurnMode get ();
    void set (JointTurnMode value);
}

Property Value

Type: JointTurnMode
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.MotionType Property

IMotionTargetMotionType Property

Interpolation type: point-to-point or linear.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MotionType MotionType { get; set; }
property MotionType MotionType {
    MotionType get ();
    void set (MotionType value);
}

Property Value

Type: MotionType
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.NamedBases Property

IMotionTargetNamedBases Property

Names of all base frames.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<string> NamedBases { get; }
property IEnumerable<String^>^ NamedBases {
    IEnumerable<String^>^ get ();
}

Property Value

Type: IEnumerableString
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.NamedTools Property

IMotionTargetNamedTools Property

Names of all tool frames.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<string> NamedTools { get; }
property IEnumerable<String^>^ NamedTools {
    IEnumerable<String^>^ get ();
}

Property Value

Type: IEnumerableString
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.NearestConfiguration Property

IMotionTargetNearestConfiguration Property

Nearest joint configuration type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int NearestConfiguration { get; }
property int NearestConfiguration {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.OrientationInterpolationMode Property

IMotionTargetOrientationInterpolationMode Property

Interpolation method used for orientation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
OrientationInterpolationMode OrientationInterpolationMode { get; set; }
property OrientationInterpolationMode OrientationInterpolationMode {
    OrientationInterpolationMode get ();
    void set (OrientationInterpolationMode value);
}

Property Value

Type: OrientationInterpolationMode
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.RobotController Property

IMotionTargetRobotController Property

Robot's controller behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotController RobotController { get; }
property IRobotController^ RobotController {
    IRobotController^ get ();
}

Property Value

Type: IRobotController
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.RobotPositioner Property

IMotionTargetRobotPositioner Property

Controller of the robot's track component.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IServoController RobotPositioner { get; }
property IServoController^ RobotPositioner {
    IServoController^ get ();
}

Property Value

Type: IServoController
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.RobotPositionerJointCount Property

IMotionTargetRobotPositionerJointCount Property

Amount of joints defined in the track controller.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int RobotPositionerJointCount { get; }
property int RobotPositionerJointCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.RobotRootToRobotFlangeMatrix Property

IMotionTargetRobotRootToRobotFlangeMatrix Property

Flange position relative to robot's root.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix RobotRootToRobotFlangeMatrix { get; }
property Matrix RobotRootToRobotFlangeMatrix {
    Matrix get ();
}

Property Value

Type: Matrix
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.RootNodeToRobotRootMatrix Property

IMotionTargetRootNodeToRobotRootMatrix Property

Robot's root position relative to robot's node.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix RootNodeToRobotRootMatrix { get; }
property Matrix RootNodeToRobotRootMatrix {
    Matrix get ();
}

Property Value

Type: Matrix
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.Status Property

IMotionTargetStatus Property

Final position status, calculated from ConfigurationWarnings.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
PositionStatus Status { get; }
property PositionStatus Status {
    PositionStatus get ();
}

Property Value

Type: PositionStatus
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.TargetMatrix Property

IMotionTargetTargetMatrix Property

Target position for inverse kinematics. Note: This matrix is not always compatible with IRobotController.ToolCenterPoint. When TargetMode == World this matrix is defined in world coordinates, while 'IRobotController.ToolCenterPoint' is relative to 'IRobotController.RobotWorldNode.TransformationInWorld'.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix TargetMatrix { get; set; }
property Matrix TargetMatrix {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.TargetMode Property

IMotionTargetTargetMode Property

Target matrix relationship with a robot.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
TargetMode TargetMode { get; set; }
property TargetMode TargetMode {
    TargetMode get ();
    void set (TargetMode value);
}

Property Value

Type: TargetMode
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.ToolMatrix Property

IMotionTargetToolMatrix Property

Position of robot's tool, relative to the node it's attached to.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix ToolMatrix { get; set; }
property Matrix ToolMatrix {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.ToolName Property

IMotionTargetToolName Property

Name of the selected tool frame.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ToolName { get; set; }
property String^ ToolName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.UseJointValues Property

IMotionTargetUseJointValues Property

Indicates that inverse kinematics calculation is not needed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool UseJointValues { get; set; }
property bool UseJointValues {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.WorkpiecePositionerJointCount Property

IMotionTargetWorkpiecePositionerJointCount Property

Amount of joints defined in the workpiece controller.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int WorkpiecePositionerJointCount { get; }
property int WorkpiecePositionerJointCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.WorkpiecePositioners Property

IMotionTargetWorkpiecePositioners Property

Controllers of the robot's workpiece components.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<IServoController> WorkpiecePositioners { get; }
property IEnumerable<IServoController^>^ WorkpiecePositioners {
    IEnumerable<IServoController^>^ get ();
}

Property Value

Type: IEnumerableIServoController
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.WorldBaseMatrix Property

IMotionTargetWorldBaseMatrix Property

Absolute position of robot's base.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix WorldBaseMatrix { get; }
property Matrix WorldBaseMatrix {
    Matrix get ();
}

Property Value

Type: Matrix
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.WorldBaseMatrix2 Property

IMotionTargetWorldBaseMatrix2 Property

Absolute position of robot's base, when taking into account all joint values stored in this motion target.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix WorldBaseMatrix2 { get; }
property Matrix WorldBaseMatrix2 {
    Matrix get ();
}

Property Value

Type: Matrix
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.WorldTargetMatrix Property

IMotionTargetWorldTargetMatrix Property

Target position for inverse kinematics. Defined in absolute coordinates.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix WorldTargetMatrix { get; }
property Matrix WorldTargetMatrix {
    Matrix get ();
}

Property Value

Type: Matrix
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.WorldToRootNodeMatrix Property

IMotionTargetWorldToRootNodeMatrix Property

Robot's root position. Defined in absolute coordinates.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix WorldToRootNodeMatrix { get; }
property Matrix WorldToRootNodeMatrix {
    Matrix get ();
}

Property Value

Type: Matrix
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget Methods

The IMotionTarget type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetAllJointStarts | Returns joint start values.
Public method | GetAllJointTurns | Returns turn counts of individual joints.
Public method | GetAllJointValues | Returns joint values of a robot.
Public method | GetConfigurationWarnings | Returns state of inverse kinematics calculation for a specific configuration.
Public method | GetExternalJointTurns | Return turn counts of external joints.
Public method | GetExternalJointValues | Returns external joint values (track, workpiece servo, etc).
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetRobotPositionerJointTurns | Returns turn counts of the track's joints.
Public method | GetRobotPositionerJointValues | Returns joint values of a track.
Public method | GetWorkpiecePositionerJointTurns | Returns turn counts of the workpiece joints.
Public method | GetWorkpiecePositionerJointValues | Returns joint values of a workpiece.
Public method | SetAllJointTurns | Sets turn counts of individual joints.
Public method | SetAllJointValues | Sets motion target's all joint values.
Public method | SetExternalJointTurns | Sets turn counts of external joints.
Public method | SetExternalJointValues | Sets motion target's external joints values.
Public method | SetRobotPositionerJointTurns | Sets turn counts of the track joints.
Public method | SetRobotPositionerJointValues | Sets track's joint values.
Public method | SetWorkpiecePositionerJointTurns | Sets turn counts of the workpiece joints.
Public method | SetWorkpiecePositionerJointValues | Sets workpieces joint values.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.GetAllJointStarts Method

IMotionTargetGetAllJointStarts Method

Returns joint start values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double[] GetAllJointStarts()
array<double>^ GetAllJointStarts()

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.Create3D.IMotionTarget.GetAllJointStarts"]

See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.GetAllJointTurns Method

IMotionTargetGetAllJointTurns Method

Returns turn counts of individual joints.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int[] GetAllJointTurns()
array<int>^ GetAllJointTurns()

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.IMotionTarget.GetAllJointTurns"]

See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.GetAllJointValues Method

IMotionTargetGetAllJointValues Method

Returns joint values of a robot.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double[] GetAllJointValues()
array<double>^ GetAllJointValues()

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.Create3D.IMotionTarget.GetAllJointValues"]

See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.GetConfigurationWarnings Method

IMotionTargetGetConfigurationWarnings Method

Returns state of inverse kinematics calculation for a specific configuration.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ConfigurationWarnings GetConfigurationWarnings(
    int index
)
ConfigurationWarnings GetConfigurationWarnings(
    int index
)

Parameters

index
Type: SystemInt32
Configuration index

Return Value

Type: ConfigurationWarnings

[Missing <returns> documentation for "M:VisualComponents.Create3D.IMotionTarget.GetConfigurationWarnings(System.Int32)"]

See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.GetExternalJointTurns Method

IMotionTargetGetExternalJointTurns Method

Return turn counts of external joints.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int[] GetExternalJointTurns()
array<int>^ GetExternalJointTurns()

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.IMotionTarget.GetExternalJointTurns"]

See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.GetExternalJointValues Method

IMotionTargetGetExternalJointValues Method

Returns external joint values (track, workpiece servo, etc).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double[] GetExternalJointValues()
array<double>^ GetExternalJointValues()

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.Create3D.IMotionTarget.GetExternalJointValues"]

See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.GetRobotPositionerJointTurns Method

IMotionTargetGetRobotPositionerJointTurns Method

Returns turn counts of the track's joints.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int[] GetRobotPositionerJointTurns()
array<int>^ GetRobotPositionerJointTurns()

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.IMotionTarget.GetRobotPositionerJointTurns"]

See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.GetRobotPositionerJointValues Method

IMotionTargetGetRobotPositionerJointValues Method

Returns joint values of a track.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double[] GetRobotPositionerJointValues()
array<double>^ GetRobotPositionerJointValues()

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.Create3D.IMotionTarget.GetRobotPositionerJointValues"]

See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.GetWorkpiecePositionerJointTurns Method

IMotionTargetGetWorkpiecePositionerJointTurns Method

Returns turn counts of the workpiece joints.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int[] GetWorkpiecePositionerJointTurns()
array<int>^ GetWorkpiecePositionerJointTurns()

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.IMotionTarget.GetWorkpiecePositionerJointTurns"]

See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.GetWorkpiecePositionerJointValues Method

IMotionTargetGetWorkpiecePositionerJointValues Method

Returns joint values of a workpiece.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double[] GetWorkpiecePositionerJointValues()
array<double>^ GetWorkpiecePositionerJointValues()

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.Create3D.IMotionTarget.GetWorkpiecePositionerJointValues"]

See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.SetAllJointTurns Method

IMotionTargetSetAllJointTurns Method

Sets turn counts of individual joints.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetAllJointTurns(
    IEnumerable<int> turns
)
void SetAllJointTurns(
    IEnumerable<int>^ turns
)

Parameters

turns
Type: System.Collections.GenericIEnumerableInt32
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.SetAllJointValues Method

IMotionTargetSetAllJointValues Method

Sets motion target's all joint values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetAllJointValues(
    IEnumerable<double> values
)
void SetAllJointValues(
    IEnumerable<double>^ values
)

Parameters

values
Type: System.Collections.GenericIEnumerableDouble
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.SetExternalJointTurns Method

IMotionTargetSetExternalJointTurns Method

Sets turn counts of external joints.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetExternalJointTurns(
    IEnumerable<int> turns
)
void SetExternalJointTurns(
    IEnumerable<int>^ turns
)

Parameters

turns
Type: System.Collections.GenericIEnumerableInt32
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.SetExternalJointValues Method

IMotionTargetSetExternalJointValues Method

Sets motion target's external joints values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetExternalJointValues(
    IEnumerable<double> values
)
void SetExternalJointValues(
    IEnumerable<double>^ values
)

Parameters

values
Type: System.Collections.GenericIEnumerableDouble
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.SetRobotPositionerJointTurns Method

IMotionTargetSetRobotPositionerJointTurns Method

Sets turn counts of the track joints.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetRobotPositionerJointTurns(
    IEnumerable<int> turns
)
void SetRobotPositionerJointTurns(
    IEnumerable<int>^ turns
)

Parameters

turns
Type: System.Collections.GenericIEnumerableInt32
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.SetRobotPositionerJointValues Method

IMotionTargetSetRobotPositionerJointValues Method

Sets track's joint values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetRobotPositionerJointValues(
    IEnumerable<double> values
)
void SetRobotPositionerJointValues(
    IEnumerable<double>^ values
)

Parameters

values
Type: System.Collections.GenericIEnumerableDouble
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.SetWorkpiecePositionerJointTurns Method

IMotionTargetSetWorkpiecePositionerJointTurns Method

Sets turn counts of the workpiece joints.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetWorkpiecePositionerJointTurns(
    IEnumerable<int> turns
)
void SetWorkpiecePositionerJointTurns(
    IEnumerable<int>^ turns
)

Parameters

turns
Type: System.Collections.GenericIEnumerableInt32
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget.SetWorkpiecePositionerJointValues Method

IMotionTargetSetWorkpiecePositionerJointValues Method

Sets workpieces joint values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetWorkpiecePositionerJointValues(
    IEnumerable<double> values
)
void SetWorkpiecePositionerJointValues(
    IEnumerable<double>^ values
)

Parameters

values
Type: System.Collections.GenericIEnumerableDouble
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTarget Events

The IMotionTarget type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
See Also

Reference

IMotionTarget Interface
VisualComponents.Create3D Namespace


IMotionTester Interface

Interface for changing robot's state with IMotionTarget.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IMotionTester : IWrapper,
    IDisposable
public interface class IMotionTester : IWrapper,
    IDisposable

The IMotionTester type exposes the following members.

Properties
 | Name | Description
Public property | CurrentTarget | Robot's current state, defined with IMotionTarget.
Public property | HasTestRun | When enabled overrides robot's default interpolation logic.
Public property | IsCurrentTargetContinuous | Helper property for getting CurrentTarget.IsContinuous without creating motion target.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IMotionTester Properties

The IMotionTester type exposes the following members.

Properties
 | Name | Description
Public property | CurrentTarget | Robot's current state, defined with IMotionTarget.
Public property | HasTestRun | When enabled overrides robot's default interpolation logic.
Public property | IsCurrentTargetContinuous | Helper property for getting CurrentTarget.IsContinuous without creating motion target.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Top
See Also

Reference

IMotionTester Interface
VisualComponents.Create3D Namespace


IMotionTester.CurrentTarget Property

IMotionTesterCurrentTarget Property

Robot's current state, defined with IMotionTarget.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMotionTarget CurrentTarget { get; set; }
property IMotionTarget^ CurrentTarget {
    IMotionTarget^ get ();
    void set (IMotionTarget^ value);
}

Property Value

Type: IMotionTarget
See Also

Reference

IMotionTester Interface
VisualComponents.Create3D Namespace


IMotionTester.HasTestRun Property

IMotionTesterHasTestRun Property

When enabled overrides robot's default interpolation logic.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool HasTestRun { get; set; }
property bool HasTestRun {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IMotionTester Interface
VisualComponents.Create3D Namespace


IMotionTester.IsCurrentTargetContinuous Property

IMotionTesterIsCurrentTargetContinuous Property

Helper property for getting CurrentTarget.IsContinuous without creating motion target.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsCurrentTargetContinuous { get; set; }
property bool IsCurrentTargetContinuous {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IMotionTester Interface
VisualComponents.Create3D Namespace


IMotionTester Methods

The IMotionTester type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IMotionTester Interface
VisualComponents.Create3D Namespace


IMotionTester Events

The IMotionTester type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
See Also

Reference

IMotionTester Interface
VisualComponents.Create3D Namespace


IMoveJointStatement Interface

Moves Joint to TargetValue over [!:MotionTime].

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IMoveJointStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IMoveJointStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IMoveJointStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | Controller | Gets owner IServoController of the Joint.
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Joint | Gets or sets IJoint to move.
Public property | MotionTimeExpression | Gets or sets Joint movement time. Setting this to an empty string will let the IServoController plan the motion time.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | TargetValue | Gets the target value where to move the joint.
Public property | TargetValueExpression | Gets or sets the expression defining TargetValue where to move the joint.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IMoveJointStatement Properties

The IMoveJointStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | Controller | Gets owner IServoController of the Joint.
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Joint | Gets or sets IJoint to move.
Public property | MotionTimeExpression | Gets or sets Joint movement time. Setting this to an empty string will let the IServoController plan the motion time.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | TargetValue | Gets the target value where to move the joint.
Public property | TargetValueExpression | Gets or sets the expression defining TargetValue where to move the joint.
Top
See Also

Reference

IMoveJointStatement Interface
VisualComponents.Create3D Namespace


IMoveJointStatement.Controller Property

IMoveJointStatementController Property

Gets owner IServoController of the Joint.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IServoController Controller { get; }
property IServoController^ Controller {
    IServoController^ get ();
}

Property Value

Type: IServoController
See Also

Reference

IMoveJointStatement Interface
VisualComponents.Create3D Namespace


IMoveJointStatement.Joint Property

IMoveJointStatementJoint Property

Gets or sets IJoint to move.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IJoint Joint { get; set; }
property IJoint^ Joint {
    IJoint^ get ();
    void set (IJoint^ value);
}

Property Value

Type: IJoint
Exceptions
Exception | Condition
ArgumentException | Thrown by setter when supplied value is not a native object wrapper.
See Also

Reference

IMoveJointStatement Interface
VisualComponents.Create3D Namespace


IMoveJointStatement.MotionTimeExpression Property

IMoveJointStatementMotionTimeExpression Property

Gets or sets Joint movement time. Setting this to an empty string will let the IServoController plan the motion time.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string MotionTimeExpression { get; set; }
property String^ MotionTimeExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown by setter when supplied value is null.
See Also

Reference

IMoveJointStatement Interface
VisualComponents.Create3D Namespace


IMoveJointStatement.TargetValue Property

IMoveJointStatementTargetValue Property

Gets the target value where to move the joint.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Nullable<double> TargetValue { get; }
property Nullable<double> TargetValue {
    Nullable<double> get ();
}

Property Value

Type: NullableDouble
Remarks
Tries to evaluate the TargetValueExpression and cast the result to double.
See Also

Reference

IMoveJointStatement Interface
VisualComponents.Create3D Namespace


IMoveJointStatement.TargetValueExpression Property

IMoveJointStatementTargetValueExpression Property

Gets or sets the expression defining TargetValue where to move the joint.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string TargetValueExpression { get; set; }
property String^ TargetValueExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown by setter when supplied value is null.
See Also

Reference

IMoveJointStatement Interface
VisualComponents.Create3D Namespace


IMoveJointStatement Methods

The IMoveJointStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IMoveJointStatement Interface
VisualComponents.Create3D Namespace


IMoveJointStatement Events

The IMoveJointStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IMoveJointStatement Interface
VisualComponents.Create3D Namespace


ImportConfigElement Class

Configuration file element for import options.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.Create3DImportConfigElement

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ImportConfigElement : ConfigurationElement
public ref class ImportConfigElement : public ConfigurationElement

The ImportConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | ImportConfigElement | Constructor.
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | DefaultUnit | Units. Default value: DefaultUnit.Default.
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | FeatureTreeStructure | CAD import feature tree reading structure.
Public property | GeometryFace | Face handling method.
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is . (Inherited from ConfigurationElement.)
Public property | Healing | Healing threshold. Default value 0.0.
Public property | HoleRemovalArea | Hole removal
Public property | ImportMarkups | Whether to import CAD markups.
Public property | ImportMaterials | Whether to import CAD materials.
Public property | ImportMaterialsThreshold | Whether to import CAD materials if there is no material in our library with lower or same given threshold.
Public property | ImportTextures | Whether to import textures.
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | MinimumBoundBoxVolume | Hole removal
Public property | NodeTreeStructure | CAD import into 1 node, many nodes or components
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | ReadBrep | Whether to import CAD breps.
Public property | ReadPoints | Whether to import CAD PointSets.
Public property | ShowInvisibleParts | Whether to show invisible geometry.
Public property | TessellationDetail | CAD import tessellation detail quality
Public property | UpAxis | Up axis index. Default value is 2 (Z).
Top
Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ImportConfigElement Constructor

Constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ImportConfigElement()
public:
ImportConfigElement()
See Also

Reference

ImportConfigElement Class
VisualComponents.Create3D Namespace


ImportConfigElement Properties

The ImportConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | DefaultUnit | Units. Default value: DefaultUnit.Default.
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | FeatureTreeStructure | CAD import feature tree reading structure.
Public property | GeometryFace | Face handling method.
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is . (Inherited from ConfigurationElement.)
Public property | Healing | Healing threshold. Default value 0.0.
Public property | HoleRemovalArea | Hole removal
Public property | ImportMarkups | Whether to import CAD markups.
Public property | ImportMaterials | Whether to import CAD materials.
Public property | ImportMaterialsThreshold | Whether to import CAD materials if there is no material in our library with lower or same given threshold.
Public property | ImportTextures | Whether to import textures.
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | MinimumBoundBoxVolume | Hole removal
Public property | NodeTreeStructure | CAD import into 1 node, many nodes or components
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | ReadBrep | Whether to import CAD breps.
Public property | ReadPoints | Whether to import CAD PointSets.
Public property | ShowInvisibleParts | Whether to show invisible geometry.
Public property | TessellationDetail | CAD import tessellation detail quality
Public property | UpAxis | Up axis index. Default value is 2 (Z).
Top
See Also

Reference

ImportConfigElement Class
VisualComponents.Create3D Namespace


ImportConfigElement.DefaultUnit Property

ImportConfigElementDefaultUnit Property

Units. Default value: DefaultUnit.Default.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int DefaultUnit { get; set; }
public:
property int DefaultUnit {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ImportConfigElement Class
VisualComponents.Create3D Namespace
ImportConfigElementDefaultUnit


ImportConfigElement.FeatureTreeStructure Property

ImportConfigElementFeatureTreeStructure Property

CAD import feature tree reading structure.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int FeatureTreeStructure { get; set; }
public:
property int FeatureTreeStructure {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ImportConfigElement Class
VisualComponents.Create3D Namespace
ImportConfigElementFeatureTreeStructure


ImportConfigElement.GeometryFace Property

ImportConfigElementGeometryFace Property

Face handling method.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int GeometryFace { get; set; }
public:
property int GeometryFace {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ImportConfigElement Class
VisualComponents.Create3D Namespace
ImportConfigElementGeometryFace


ImportConfigElement.Healing Property

ImportConfigElementHealing Property

Healing threshold. Default value 0.0.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Healing { get; set; }
public:
property double Healing {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ImportConfigElement Class
VisualComponents.Create3D Namespace


ImportConfigElement.HoleRemovalArea Property

ImportConfigElementHoleRemovalArea Property

Hole removal

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double HoleRemovalArea { get; set; }
public:
property double HoleRemovalArea {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ImportConfigElement Class
VisualComponents.Create3D Namespace


ImportConfigElement.ImportMarkups Property

ImportConfigElementImportMarkups Property

Whether to import CAD markups.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ImportMarkups { get; set; }
public:
property bool ImportMarkups {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ImportConfigElement Class
VisualComponents.Create3D Namespace


ImportConfigElement.ImportMaterials Property

ImportConfigElementImportMaterials Property

Whether to import CAD materials.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ImportMaterials { get; set; }
public:
property bool ImportMaterials {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ImportConfigElement Class
VisualComponents.Create3D Namespace


ImportConfigElement.ImportMaterialsThreshold Property

ImportConfigElementImportMaterialsThreshold Property

Whether to import CAD materials if there is no material in our library with lower or same given threshold.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ImportMaterialsThreshold { get; set; }
public:
property int ImportMaterialsThreshold {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ImportConfigElement Class
VisualComponents.Create3D Namespace


ImportConfigElement.ImportTextures Property

ImportConfigElementImportTextures Property

Whether to import textures.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ImportTextures { get; set; }
public:
property bool ImportTextures {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ImportConfigElement Class
VisualComponents.Create3D Namespace


ImportConfigElement.MinimumBoundBoxVolume Property

ImportConfigElementMinimumBoundBoxVolume Property

Hole removal

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double MinimumBoundBoxVolume { get; set; }
public:
property double MinimumBoundBoxVolume {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ImportConfigElement Class
VisualComponents.Create3D Namespace


ImportConfigElement.NodeTreeStructure Property

ImportConfigElementNodeTreeStructure Property

CAD import into 1 node, many nodes or components

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int NodeTreeStructure { get; set; }
public:
property int NodeTreeStructure {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ImportConfigElement Class
VisualComponents.Create3D Namespace
ImportConfigElementNodeTreeStructure


ImportConfigElement.ReadBrep Property

ImportConfigElementReadBrep Property

Whether to import CAD breps.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ReadBrep { get; set; }
public:
property bool ReadBrep {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ImportConfigElement Class
VisualComponents.Create3D Namespace


ImportConfigElement.ReadPoints Property

ImportConfigElementReadPoints Property

Whether to import CAD PointSets.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ReadPoints { get; set; }
public:
property bool ReadPoints {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ImportConfigElement Class
VisualComponents.Create3D Namespace


ImportConfigElement.ShowInvisibleParts Property

ImportConfigElementShowInvisibleParts Property

Whether to show invisible geometry.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowInvisibleParts { get; set; }
public:
property bool ShowInvisibleParts {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ImportConfigElement Class
VisualComponents.Create3D Namespace


ImportConfigElement.TessellationDetail Property

ImportConfigElementTessellationDetail Property

CAD import tessellation detail quality

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int TessellationDetail { get; set; }
public:
property int TessellationDetail {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ImportConfigElement Class
VisualComponents.Create3D Namespace
ImportConfigElementTessellationDetail


ImportConfigElement.UpAxis Property

ImportConfigElementUpAxis Property

Up axis index. Default value is 2 (Z).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int UpAxis { get; set; }
public:
property int UpAxis {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ImportConfigElement Class
VisualComponents.Create3D Namespace


ImportConfigElement Methods

The ImportConfigElement type exposes the following members.

Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ImportConfigElement Class
VisualComponents.Create3D Namespace


ImportSection Class

Configuration file section for import options.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationSection
VisualComponents.Create3DImportSection

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ImportSection : ConfigurationSection,
    IImportSection, ISection
public ref class ImportSection sealed : public ConfigurationSection,
    IImportSection, ISection

The ImportSection type exposes the following members.

Constructors
 | Name | Description
Public method | ImportSection | Constructor.
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | ImportElement | Configuration file element for import options.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName | Section's name in configuration file.
Public property | SectionType | Interface type.
Public property | SectionVersion | Section's version number.
Top
Methods
 | Name | Description
Public method | CheckVersion | Upgrade configuration to the latest version.
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection | Finds typed section by name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ImportSection Constructor

Constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ImportSection()
public:
ImportSection()
See Also

Reference

ImportSection Class
VisualComponents.Create3D Namespace


ImportSection Properties

The ImportSection type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | ImportElement | Configuration file element for import options.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName | Section's name in configuration file.
Public property | SectionType | Interface type.
Public property | SectionVersion | Section's version number.
Top
See Also

Reference

ImportSection Class
VisualComponents.Create3D Namespace


ImportSection.ImportElement Property

ImportSectionImportElement Property

Configuration file element for import options.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ImportConfigElement ImportElement { get; set; }
public:
virtual property ImportConfigElement^ ImportElement {
    ImportConfigElement^ get () sealed;
    void set (ImportConfigElement^ value) sealed;
}

Property Value

Type: ImportConfigElement

Implements

IImportSectionImportElement
See Also

Reference

ImportSection Class
VisualComponents.Create3D Namespace


ImportSection.SectionName Property

ImportSectionSectionName Property

Section's name in configuration file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SectionName { get; }
public:
virtual property String^ SectionName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ISectionSectionName
See Also

Reference

ImportSection Class
VisualComponents.Create3D Namespace


ImportSection.SectionType Property

ImportSectionSectionType Property

Interface type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type SectionType { get; }
public:
virtual property Type^ SectionType {
    Type^ get () sealed;
}

Property Value

Type: Type

Implements

ISectionSectionType
See Also

Reference

ImportSection Class
VisualComponents.Create3D Namespace


ImportSection.SectionVersion Property

ImportSectionSectionVersion Property

Section's version number.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int SectionVersion { get; }
public:
virtual property int SectionVersion {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISectionSectionVersion
See Also

Reference

ImportSection Class
VisualComponents.Create3D Namespace


ImportSection Methods

The ImportSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion | Upgrade configuration to the latest version.
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection | Finds typed section by name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ImportSection Class
VisualComponents.Create3D Namespace


ImportSection.CheckVersion Method

ImportSectionCheckVersion Method

Upgrade configuration to the latest version.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CheckVersion()
public:
virtual void CheckVersion() sealed

Implements

ISectionCheckVersion
See Also

Reference

ImportSection Class
VisualComponents.Create3D Namespace


ImportSection.GetSection Method

ImportSectionGetSection Method

Finds typed section by name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISection GetSection(
    Configuration userSettingConfiguration
)
public:
virtual ISection^ GetSection(
    Configuration^ userSettingConfiguration
) sealed

Parameters

userSettingConfiguration
Type: System.ConfigurationConfiguration

Return Value

Type: ISection

[Missing <returns> documentation for "M:VisualComponents.Create3D.ImportSection.GetSection(System.Configuration.Configuration)"]

Implements

ISectionGetSection(Configuration)
See Also

Reference

ImportSection Class
VisualComponents.Create3D Namespace


ImportSection.ToString Method

ImportSectionToString Method

Converts this instance to string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String
String representation of this instance
See Also

Reference

ImportSection Class
VisualComponents.Create3D Namespace


ImportSummaryMessage Class

Represents a summary of a CAD file
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DImportSummaryMessage

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ImportSummaryMessage
public ref class ImportSummaryMessage

The ImportSummaryMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ImportSummaryMessage | Constructor
Top
Properties
 | Name | Description
Public property | ComponentsCount | Estimated number of components
Public property | DwgEntities | Estimated number of Entities in case of DWG file
Public property | FilePath | path of the CAD file
Public property | GeometryFeaturesCount | Estimated number of geometry features
Public property | GeometrySetsCountMax | Estimated maximun number of geometry sets
Public property | GeometrySetsCountMin | Estimated minimun number of geometry sets
Public property | Is3D | Determines if it is a 3D model
Public property | IsCAD | False for DWG/DXF files
Public property | MaterialCount | Estimated number of materials found in the CAD file
Public property | NodesCount | Estimated number of nodes
Public property | PointApproxCount | Estimated numbet of points
Public property | TransformFeaturesCountMax | Estimated maximun number of transform features
Public property | TriangleApproxCount | Estimated number of triangles
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks
Message is sent during CAD reading process if CADSummary option is enabled
See Also

Reference

VisualComponents.Create3D Namespace


ImportSummaryMessage Constructor

Constructor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ImportSummaryMessage()
public:
ImportSummaryMessage()
See Also

Reference

ImportSummaryMessage Class
VisualComponents.Create3D Namespace


ImportSummaryMessage Properties

The ImportSummaryMessage type exposes the following members.

Properties
 | Name | Description
Public property | ComponentsCount | Estimated number of components
Public property | DwgEntities | Estimated number of Entities in case of DWG file
Public property | FilePath | path of the CAD file
Public property | GeometryFeaturesCount | Estimated number of geometry features
Public property | GeometrySetsCountMax | Estimated maximun number of geometry sets
Public property | GeometrySetsCountMin | Estimated minimun number of geometry sets
Public property | Is3D | Determines if it is a 3D model
Public property | IsCAD | False for DWG/DXF files
Public property | MaterialCount | Estimated number of materials found in the CAD file
Public property | NodesCount | Estimated number of nodes
Public property | PointApproxCount | Estimated numbet of points
Public property | TransformFeaturesCountMax | Estimated maximun number of transform features
Public property | TriangleApproxCount | Estimated number of triangles
Top
See Also

Reference

ImportSummaryMessage Class
VisualComponents.Create3D Namespace


ImportSummaryMessage.ComponentsCount Property

ImportSummaryMessageComponentsCount Property

Estimated number of components

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint ComponentsCount { get; set; }
public:
property unsigned int ComponentsCount {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ImportSummaryMessage Class
VisualComponents.Create3D Namespace


ImportSummaryMessage.DwgEntities Property

ImportSummaryMessageDwgEntities Property

Estimated number of Entities in case of DWG file

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int DwgEntities { get; set; }
public:
property int DwgEntities {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ImportSummaryMessage Class
VisualComponents.Create3D Namespace


ImportSummaryMessage.FilePath Property

ImportSummaryMessageFilePath Property

path of the CAD file

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string FilePath { get; set; }
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ImportSummaryMessage Class
VisualComponents.Create3D Namespace


ImportSummaryMessage.GeometryFeaturesCount Property

ImportSummaryMessageGeometryFeaturesCount Property

Estimated number of geometry features

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint GeometryFeaturesCount { get; set; }
public:
property unsigned int GeometryFeaturesCount {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ImportSummaryMessage Class
VisualComponents.Create3D Namespace


ImportSummaryMessage.GeometrySetsCountMax Property

ImportSummaryMessageGeometrySetsCountMax Property

Estimated maximun number of geometry sets

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint GeometrySetsCountMax { get; set; }
public:
property unsigned int GeometrySetsCountMax {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ImportSummaryMessage Class
VisualComponents.Create3D Namespace


ImportSummaryMessage.GeometrySetsCountMin Property

ImportSummaryMessageGeometrySetsCountMin Property

Estimated minimun number of geometry sets

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint GeometrySetsCountMin { get; set; }
public:
property unsigned int GeometrySetsCountMin {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ImportSummaryMessage Class
VisualComponents.Create3D Namespace


ImportSummaryMessage.Is3D Property

ImportSummaryMessageIs3D Property

Determines if it is a 3D model

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Is3D { get; set; }
public:
property bool Is3D {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ImportSummaryMessage Class
VisualComponents.Create3D Namespace


ImportSummaryMessage.IsCAD Property

ImportSummaryMessageIsCAD Property

False for DWG/DXF files

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsCAD { get; set; }
public:
property bool IsCAD {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ImportSummaryMessage Class
VisualComponents.Create3D Namespace


ImportSummaryMessage.MaterialCount Property

ImportSummaryMessageMaterialCount Property

Estimated number of materials found in the CAD file

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int MaterialCount { get; set; }
public:
property int MaterialCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ImportSummaryMessage Class
VisualComponents.Create3D Namespace


ImportSummaryMessage.NodesCount Property

ImportSummaryMessageNodesCount Property

Estimated number of nodes

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint NodesCount { get; set; }
public:
property unsigned int NodesCount {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ImportSummaryMessage Class
VisualComponents.Create3D Namespace


ImportSummaryMessage.PointApproxCount Property

ImportSummaryMessagePointApproxCount Property

Estimated numbet of points

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint PointApproxCount { get; set; }
public:
property unsigned int PointApproxCount {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ImportSummaryMessage Class
VisualComponents.Create3D Namespace


ImportSummaryMessage.TransformFeaturesCountMax Property

ImportSummaryMessageTransformFeaturesCountMax Property

Estimated maximun number of transform features

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint TransformFeaturesCountMax { get; set; }
public:
property unsigned int TransformFeaturesCountMax {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ImportSummaryMessage Class
VisualComponents.Create3D Namespace


ImportSummaryMessage.TriangleApproxCount Property

ImportSummaryMessageTriangleApproxCount Property

Estimated number of triangles

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint TriangleApproxCount { get; set; }
public:
property unsigned int TriangleApproxCount {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ImportSummaryMessage Class
VisualComponents.Create3D Namespace


ImportSummaryMessage Methods

The ImportSummaryMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ImportSummaryMessage Class
VisualComponents.Create3D Namespace


INamed Interface

Interface for named objects

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface INamed
public interface class INamed

The INamed type exposes the following members.

Properties
 | Name | Description
Public property | Name | Retrieves or sets the name of the object
Top
See Also

Reference

VisualComponents.Create3D Namespace


INamed Properties

The INamed type exposes the following members.

Properties
 | Name | Description
Public property | Name | Retrieves or sets the name of the object
Top
See Also

Reference

INamed Interface
VisualComponents.Create3D Namespace


INamed.Name Property

INamedName Property

Retrieves or sets the name of the object

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Name { get; set; }
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown by the setter if value is null
ArgumentException | Thrown by the setter if the value is not acceptable
See Also

Reference

INamed Interface
VisualComponents.Create3D Namespace


INativeSection Interface

Configuration file section for native options.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface INativeSection : ISection
public interface class INativeSection : ISection

The INativeSection type exposes the following members.

Properties
 | Name | Description
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | Contains | Determines whether an element is in the NativeConfigElement.
Public method | GetSection | Gets the section (Inherited from ISection.)
Public method | GetUserValue | Gets configuration file element for native option.
Top
See Also

Reference

VisualComponents.Create3D Namespace


INativeSection Properties

The INativeSection type exposes the following members.

Properties
 | Name | Description
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
See Also

Reference

INativeSection Interface
VisualComponents.Create3D Namespace


INativeSection Methods

The INativeSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | Contains | Determines whether an element is in the NativeConfigElement.
Public method | GetSection | Gets the section (Inherited from ISection.)
Public method | GetUserValue | Gets configuration file element for native option.
Top
See Also

Reference

INativeSection Interface
VisualComponents.Create3D Namespace


INativeSection.Contains Method

INativeSectionContains Method

Determines whether an element is in the NativeConfigElement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool Contains(
    string key
)
bool Contains(
    String^ key
)

Parameters

key
Type: SystemString
Native option key

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.INativeSection.Contains(System.String)"]

See Also

Reference

INativeSection Interface
VisualComponents.Create3D Namespace


INativeSection.GetUserValue Method

INativeSectionGetUserValue Method

Gets configuration file element for native option.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
NativeConfigElement GetUserValue(
    string key
)
NativeConfigElement^ GetUserValue(
    String^ key
)

Parameters

key
Type: SystemString
Native option key

Return Value

Type: NativeConfigElement
Native option element
See Also

Reference

INativeSection Interface
VisualComponents.Create3D Namespace


IndexedLoadingPoint Structure

Specifies loading parameters, e.g. on a robot's tool or additional load on one of its links.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct IndexedLoadingPoint
public value class IndexedLoadingPoint

The IndexedLoadingPoint type exposes the following members.

Constructors
 | Name | Description
Public method | IndexedLoadingPoint | Specifies loading parameters, e.g. on a robot's tool or additional load on one of its links.
Top
Properties
 | Name | Description
Public property | IndexNumber | Index in the related container, e.g. tool list or joint list.
Public property | Load | Loading information.
Top
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides ValueTypeEquals(Object).)
Public method | Equals(IndexedLoadingPoint) |
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Equality |
Inequality |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IndexedLoadingPoint Constructor

Specifies loading parameters, e.g. on a robot's tool or additional load on one of its links.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IndexedLoadingPoint(
    uint axisNumber,
    double mass,
    Matrix centerOfMass,
    Vector3 inertia
)
public:
IndexedLoadingPoint(
    unsigned int axisNumber,
    double mass,
    Matrix centerOfMass,
    Vector3 inertia
)

Parameters

axisNumber
Type: SystemUInt32
mass
Type: SystemDouble
centerOfMass
Type: VisualComponents.Create3DMatrix
inertia
Type: VisualComponents.Create3DVector3
See Also

Reference

IndexedLoadingPoint Structure
VisualComponents.Create3D Namespace


IndexedLoadingPoint Properties

The IndexedLoadingPoint type exposes the following members.

Properties
 | Name | Description
Public property | IndexNumber | Index in the related container, e.g. tool list or joint list.
Public property | Load | Loading information.
Top
See Also

Reference

IndexedLoadingPoint Structure
VisualComponents.Create3D Namespace


IndexedLoadingPoint.IndexNumber Property

IndexedLoadingPointIndexNumber Property

Index in the related container, e.g. tool list or joint list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint IndexNumber { get; }
public:
property unsigned int IndexNumber {
    unsigned int get ();
}

Property Value

Type: UInt32
See Also

Reference

IndexedLoadingPoint Structure
VisualComponents.Create3D Namespace


IndexedLoadingPoint.Load Property

IndexedLoadingPointLoad Property

Loading information.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LoadingPoint Load { get; }
public:
property LoadingPoint Load {
    LoadingPoint get ();
}

Property Value

Type: LoadingPoint
See Also

Reference

IndexedLoadingPoint Structure
VisualComponents.Create3D Namespace


IndexedLoadingPoint Methods

The IndexedLoadingPoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | (Overrides ValueTypeEquals(Object).)
Public method | Equals(IndexedLoadingPoint) |
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

IndexedLoadingPoint Structure
VisualComponents.Create3D Namespace


IndexedLoadingPoint.Equals Method

IndexedLoadingPointEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ValueTypeEquals(Object).)
Public method | Equals(IndexedLoadingPoint) |
Top
See Also

Reference

IndexedLoadingPoint Structure
VisualComponents.Create3D Namespace


IndexedLoadingPoint.Equals Method (Object)

IndexedLoadingPointEquals Method (Object)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IndexedLoadingPoint.Equals(System.Object)"]

See Also

Reference

IndexedLoadingPoint Structure
Equals Overload
VisualComponents.Create3D Namespace


IndexedLoadingPoint.Equals Method (IndexedLoadingPoint)

IndexedLoadingPointEquals Method (IndexedLoadingPoint)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    IndexedLoadingPoint other
)
public:
bool Equals(
    IndexedLoadingPoint other
)

Parameters

other
Type: VisualComponents.Create3DIndexedLoadingPoint

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IndexedLoadingPoint.Equals(VisualComponents.Create3D.IndexedLoadingPoint)"]

See Also

Reference

IndexedLoadingPoint Structure
Equals Overload
VisualComponents.Create3D Namespace


IndexedLoadingPoint.GetHashCode Method

IndexedLoadingPointGetHashCode Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.IndexedLoadingPoint.GetHashCode"]

See Also

Reference

IndexedLoadingPoint Structure
VisualComponents.Create3D Namespace


IndexedLoadingPoint Operators

The IndexedLoadingPoint type exposes the following members.

Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

IndexedLoadingPoint Structure
VisualComponents.Create3D Namespace


IndexedLoadingPoint.Equality Operator

IndexedLoadingPointEquality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    IndexedLoadingPoint lhs,
    IndexedLoadingPoint other
)
public:
static bool operator ==(
    IndexedLoadingPoint lhs,
    IndexedLoadingPoint other
)

Parameters

lhs
Type: VisualComponents.Create3DIndexedLoadingPoint
other
Type: VisualComponents.Create3DIndexedLoadingPoint

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IndexedLoadingPoint.op_Equality(VisualComponents.Create3D.IndexedLoadingPoint,VisualComponents.Create3D.IndexedLoadingPoint)"]

See Also

Reference

IndexedLoadingPoint Structure
VisualComponents.Create3D Namespace


IndexedLoadingPoint.Inequality Operator

IndexedLoadingPointInequality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    IndexedLoadingPoint lhs,
    IndexedLoadingPoint other
)
public:
static bool operator !=(
    IndexedLoadingPoint lhs,
    IndexedLoadingPoint other
)

Parameters

lhs
Type: VisualComponents.Create3DIndexedLoadingPoint
other
Type: VisualComponents.Create3DIndexedLoadingPoint

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IndexedLoadingPoint.op_Inequality(VisualComponents.Create3D.IndexedLoadingPoint,VisualComponents.Create3D.IndexedLoadingPoint)"]

See Also

Reference

IndexedLoadingPoint Structure
VisualComponents.Create3D Namespace


IndicationStyle Enumeration

Annotation attachment point indication style enumeration.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum IndicationStyle
public enum class IndicationStyle
Members
Member name | Value | Description
None | 0 | No indication is drawn.
Point | 1 | A line connecting the attachment point to the annotation text is drawn. A point is drawn at the attachment point.
Arrow | 2 | A line connecting the attachment point to the annotation text is drawn. An arrow is drawn at the attachment point.
Line | 3 | A line connecting the attachment point to the annotation text is drawn. No indication drawn at the attachment point.
See Also

Reference

VisualComponents.Create3D Namespace


INodeEntryListHelper Interface

Helper utility interface for working with instances of NodeListEntry.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface INodeEntryListHelper
public interface class INodeEntryListHelper

The INodeEntryListHelper type exposes the following members.

Methods
 | Name | Description
Public method | FilterNodes | Get included instances of ISimNode from the collection of NodeListEntry instances.
Top
Examples
Get a list of nodes belonging to specific components, using Component scope.
Copy
var app = IoC.Get<IApplication>();
ISimNode node1 = app.World.FindComponent("node1").RootNode;
ISimNode node2 = app.World.FindComponent("node2").RootNode;

List<NodeListEntry> entries = new List<NodeListEntry>
{
    new NodeListEntry(node1, NodeEntryScope.Component, NodeEntryType.Include),
    new NodeListEntry(node2, NodeEntryScope.Component, NodeEntryType.Include),
};

var resultNodes = IoC.Get<INodeEntryListHelper>().FilterNodes(entries);
Examples
Get a list of all nodes in the world using Tree scope. From that list, exclude whole component and a specific node from another component.
Copy
var app = IoC.Get<IApplication>();
ISimNode worldnode = app.World.WorldRoot;
ISimNode comp1 = app.World.FindComponent("comp1").RootNode;
ISimNode child1 = app.World.FindComponent("node2").FindNode("child1");

List<NodeListEntry> entries = new List<NodeListEntry>
{
    new NodeListEntry(worldnode, NodeEntryScope.Tree, NodeEntryType.Include),
    new NodeListEntry(comp1, NodeEntryScope.Component, NodeEntryType.Exclude),
    new NodeListEntry(child1, NodeEntryScope.Node, NodeEntryType.Exclude)
};

var resultNodes = IoC.Get<INodeEntryListHelper>().FilterNodes(entries);
Examples

Get a list of all nodes belonging to a component, excluding specific subnodes with type Node and node subtrees with Tree scope.

Note: to include all nodes from a given component, it is not required to define a NodeListEntry with the component's root node and Component scope. Any node of a specific component included with Component scope will include all subnodes of that component (including parents of the specified node, if any).

Copy
var app = IoC.Get<IApplication>();
ISimComponent comp1 = app.World.FindComponent("comp1");
ISimNode rootnode = comp1.RootNode;
ISimNode subnode1 = comp1.FindNode("subnode1");
ISimNode subnode2 = comp1.FindNode("subnode2");

List<NodeListEntry> entries = new List<NodeListEntry>
{
    new NodeListEntry(rootnode, NodeEntryScope.Component, NodeEntryType.Include),
    new NodeListEntry(subnode1, NodeEntryScope.Node, NodeEntryType.Exclude)
    new NodeListEntry(subnode2, NodeEntryScope.Tree, NodeEntryType.Exclude)
};

var resultNodes = IoC.Get<INodeEntryListHelper>().FilterNodes(entries);
See Also

Reference

VisualComponents.Create3D Namespace


INodeEntryListHelper Methods

The INodeEntryListHelper type exposes the following members.

Methods
 | Name | Description
Public method | FilterNodes | Get included instances of ISimNode from the collection of NodeListEntry instances.
Top
See Also

Reference

INodeEntryListHelper Interface
VisualComponents.Create3D Namespace


INodeEntryListHelper.FilterNodes Method

INodeEntryListHelperFilterNodes Method

Get included instances of ISimNode from the collection of NodeListEntry instances.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<ISimNode> FilterNodes(
    IEnumerable<NodeListEntry> nodeEntries
)
IEnumerable<ISimNode^>^ FilterNodes(
    IEnumerable<NodeListEntry^>^ nodeEntries
)

Parameters

nodeEntries
Type: System.Collections.GenericIEnumerableNodeListEntry
Node entry list.

Return Value

Type: IEnumerableISimNode
List of included nodes.
See Also

Reference

INodeEntryListHelper Interface
VisualComponents.Create3D Namespace


INonvisualManipulationTarget Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface INonvisualManipulationTarget : IManipulationTarget,
    ILockableObject, IDisposable
public interface class INonvisualManipulationTarget : IManipulationTarget,
    ILockableObject, IDisposable

The INonvisualManipulationTarget type exposes the following members.

Properties
 | Name | Description
Public property | HandleInObjectCoordinates | Deprecated. Same as TransformationInObject. (Inherited from IManipulationTarget.)
Public property | HandleInReference | Deprecated. Same as TransformationInReference. (Inherited from IManipulationTarget.)
Public property | HandleInWorld | Deprecated. Same as TransformationInWorld. (Inherited from IManipulationTarget.)
Public property | HandleReferenceInWorld | Deprecated. Same as ParentTransformationInWorld. (Inherited from IManipulationTarget.)
Public property | IsHandleFixed | Deprecated. Same as IRobotTcpManipulationTarget.IsTcpExternal. (Inherited from IManipulationTarget.)
Public property | IsLocked | (Inherited from IManipulationTarget.)
Public property | IsTargetEnabled | This is similar to IsLocked, but for manual disabling. (Inherited from IManipulationTarget.)
Public property | IsValid | (Inherited from IManipulationTarget.)
Public property | IsVisible | (Inherited from IManipulationTarget.)
Public property | ParentTransformationInWorld | Position of pivot visual object parent. (Inherited from IManipulationTarget.)
Public property | PivotObject | (Inherited from IManipulationTarget.)
Public property | TargetObjects | Target objects. May exlude child objects. (Inherited from IManipulationTarget.)
Public property | TransformationInObject | Sets the transformation in reference to its own space (Inherited from IManipulationTarget.)
Public property | TransformationInReference | Gets or sets the transformation in reference to its parent (Inherited from IManipulationTarget.)
Public property | TransformationInWorld | Gets or sets the transformation in world (Inherited from IManipulationTarget.)
Top
Methods
 | Name | Description
Public method | ApplyChanges | This is implemented by manipulators that do actual changes on action end or mouse relase. If finalChange==false, then it's only an intermediate change (on mouse release). (Inherited from IManipulationTarget.)
Public method | CollectUndoChanges | Collect all changes since the last call to StoreUndoState(). (Inherited from IManipulationTarget.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | StoreUndoState | Store information away to be used when creating an undo change set later. (Inherited from IManipulationTarget.)
Top
Events
 | Name | Description
Public event | IsLockedChanged | (Inherited from IManipulationTarget.)
Public event | IsVisibleChanged | (Inherited from IManipulationTarget.)
Public event | ObjectInvalidated | (Inherited from IManipulationTarget.)
Public event | TransformationChanged | (Inherited from IManipulationTarget.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


INonvisualManipulationTarget Properties

The INonvisualManipulationTarget type exposes the following members.

Properties
 | Name | Description
Public property | HandleInObjectCoordinates | Deprecated. Same as TransformationInObject. (Inherited from IManipulationTarget.)
Public property | HandleInReference | Deprecated. Same as TransformationInReference. (Inherited from IManipulationTarget.)
Public property | HandleInWorld | Deprecated. Same as TransformationInWorld. (Inherited from IManipulationTarget.)
Public property | HandleReferenceInWorld | Deprecated. Same as ParentTransformationInWorld. (Inherited from IManipulationTarget.)
Public property | IsHandleFixed | Deprecated. Same as IRobotTcpManipulationTarget.IsTcpExternal. (Inherited from IManipulationTarget.)
Public property | IsLocked | (Inherited from IManipulationTarget.)
Public property | IsTargetEnabled | This is similar to IsLocked, but for manual disabling. (Inherited from IManipulationTarget.)
Public property | IsValid | (Inherited from IManipulationTarget.)
Public property | IsVisible | (Inherited from IManipulationTarget.)
Public property | ParentTransformationInWorld | Position of pivot visual object parent. (Inherited from IManipulationTarget.)
Public property | PivotObject | (Inherited from IManipulationTarget.)
Public property | TargetObjects | Target objects. May exlude child objects. (Inherited from IManipulationTarget.)
Public property | TransformationInObject | Sets the transformation in reference to its own space (Inherited from IManipulationTarget.)
Public property | TransformationInReference | Gets or sets the transformation in reference to its parent (Inherited from IManipulationTarget.)
Public property | TransformationInWorld | Gets or sets the transformation in world (Inherited from IManipulationTarget.)
Top
See Also

Reference

INonvisualManipulationTarget Interface
VisualComponents.Create3D Namespace


INonvisualManipulationTarget Methods

The INonvisualManipulationTarget type exposes the following members.

Methods
 | Name | Description
Public method | ApplyChanges | This is implemented by manipulators that do actual changes on action end or mouse relase. If finalChange==false, then it's only an intermediate change (on mouse release). (Inherited from IManipulationTarget.)
Public method | CollectUndoChanges | Collect all changes since the last call to StoreUndoState(). (Inherited from IManipulationTarget.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | StoreUndoState | Store information away to be used when creating an undo change set later. (Inherited from IManipulationTarget.)
Top
See Also

Reference

INonvisualManipulationTarget Interface
VisualComponents.Create3D Namespace


INonvisualManipulationTarget Events

The INonvisualManipulationTarget type exposes the following members.

Events
 | Name | Description
Public event | IsLockedChanged | (Inherited from IManipulationTarget.)
Public event | IsVisibleChanged | (Inherited from IManipulationTarget.)
Public event | ObjectInvalidated | (Inherited from IManipulationTarget.)
Public event | TransformationChanged | (Inherited from IManipulationTarget.)
Top
See Also

Reference

INonvisualManipulationTarget Interface
VisualComponents.Create3D Namespace


INote Interface

An interface for note behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface INote : IBehavior, IPropertyContainer,
    IBatchModeObject, IVisitable, IWrapper, IDisposable, INamed
public interface class INote : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The INote type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Note | Gets or sets the text displayed in the note.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


INote Properties

The INote type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Note | Gets or sets the text displayed in the note.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

INote Interface
VisualComponents.Create3D Namespace


INote.Note Property

INoteNote Property

Gets or sets the text displayed in the note.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Note { get; set; }
property String^ Note {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

INote Interface
VisualComponents.Create3D Namespace


INote Methods

The INote type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

INote Interface
VisualComponents.Create3D Namespace


INote Events

The INote type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

INote Interface
VisualComponents.Create3D Namespace


InteractInfoMessage Class

Broad casted when navigation starts and ends.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DInteractInfoMessage

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class InteractInfoMessage
public ref class InteractInfoMessage sealed

The InteractInfoMessage type exposes the following members.

Constructors
 | Name | Description
Public method | InteractInfoMessage | Initializes a new instance of the InteractInfoMessage class
Top
Properties
 | Name | Description
Public property | Mode |
Public property | Start | True if navigation starts. Otherwise false.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


InteractInfoMessage Constructor

Initializes a new instance of the InteractInfoMessage class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InteractInfoMessage()
public:
InteractInfoMessage()
See Also

Reference

InteractInfoMessage Class
VisualComponents.Create3D Namespace


InteractInfoMessage Properties

The InteractInfoMessage type exposes the following members.

Properties
 | Name | Description
Public property | Mode |
Public property | Start | True if navigation starts. Otherwise false.
Top
See Also

Reference

InteractInfoMessage Class
VisualComponents.Create3D Namespace


InteractInfoMessage.Mode Property

InteractInfoMessageMode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InteractMode Mode { get; set; }
public:
property InteractMode Mode {
    InteractMode get ();
    void set (InteractMode value);
}

Property Value

Type: InteractMode
See Also

Reference

InteractInfoMessage Class
VisualComponents.Create3D Namespace


InteractInfoMessage.Start Property

InteractInfoMessageStart Property

True if navigation starts. Otherwise false.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Start { get; set; }
public:
property bool Start {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

InteractInfoMessage Class
VisualComponents.Create3D Namespace


InteractInfoMessage Methods

The InteractInfoMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

InteractInfoMessage Class
VisualComponents.Create3D Namespace


InteractMode Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum InteractMode
public enum class InteractMode
Members
Member name | Value | Description
Free | 0 |
Pan | 1 |
Rotate | 2 |
Zoom | 3 |
Interact | 4 |
Translate | 5 |
RotateObject | 6 |
Measure | 7 |
SnapPrimitive | 8 |
JointSliderDrag | 9 |
See Also

Reference

VisualComponents.Create3D Namespace


InterfaceConnections Class

Class returned when calling GetConnectionsComponents of IPlugAndPlayLogicalHelper
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DInterfaceConnections

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class InterfaceConnections
public ref class InterfaceConnections sealed

The InterfaceConnections type exposes the following members.

Constructors
 | Name | Description
Public method | InterfaceConnections | Initializes a new instance of the InterfaceConnections class
Top
Properties
 | Name | Description
Public property | AbstractInterface |
Public property | AbstractInterfaceTo |
Public property | Component |
Public property | Connected |
Public property | PositionTo |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


InterfaceConnections Constructor

Initializes a new instance of the InterfaceConnections class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InterfaceConnections()
public:
InterfaceConnections()
See Also

Reference

InterfaceConnections Class
VisualComponents.Create3D Namespace


InterfaceConnections Properties

The InterfaceConnections type exposes the following members.

Properties
 | Name | Description
Public property | AbstractInterface |
Public property | AbstractInterfaceTo |
Public property | Component |
Public property | Connected |
Public property | PositionTo |
Top
See Also

Reference

InterfaceConnections Class
VisualComponents.Create3D Namespace


InterfaceConnections.AbstractInterface Property

InterfaceConnectionsAbstractInterface Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimInterface AbstractInterface { get; set; }
public:
property ISimInterface^ AbstractInterface {
    ISimInterface^ get ();
    void set (ISimInterface^ value);
}

Property Value

Type: ISimInterface
See Also

Reference

InterfaceConnections Class
VisualComponents.Create3D Namespace


InterfaceConnections.AbstractInterfaceTo Property

InterfaceConnectionsAbstractInterfaceTo Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimInterface AbstractInterfaceTo { get; set; }
public:
property ISimInterface^ AbstractInterfaceTo {
    ISimInterface^ get ();
    void set (ISimInterface^ value);
}

Property Value

Type: ISimInterface
See Also

Reference

InterfaceConnections Class
VisualComponents.Create3D Namespace


InterfaceConnections.Component Property

InterfaceConnectionsComponent Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimNode Component { get; set; }
public:
property ISimNode^ Component {
    ISimNode^ get ();
    void set (ISimNode^ value);
}

Property Value

Type: ISimNode
See Also

Reference

InterfaceConnections Class
VisualComponents.Create3D Namespace


InterfaceConnections.Connected Property

InterfaceConnectionsConnected Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Connected { get; set; }
public:
property bool Connected {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

InterfaceConnections Class
VisualComponents.Create3D Namespace


InterfaceConnections.PositionTo Property

InterfaceConnectionsPositionTo Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Matrix PositionTo { get; set; }
public:
property Matrix PositionTo {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

InterfaceConnections Class
VisualComponents.Create3D Namespace


InterfaceConnections Methods

The InterfaceConnections type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

InterfaceConnections Class
VisualComponents.Create3D Namespace


InterfaceConnectPostEventArgs Class

Provides data for Connected and Disconnected events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DInterfaceConnectPostEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class InterfaceConnectPostEventArgs : EventArgs
public ref class InterfaceConnectPostEventArgs : public EventArgs

The InterfaceConnectPostEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | InterfaceConnectPostEventArgs | Initializes a new instance of the InterfaceConnectPostEventArgs class.
Top
Properties
 | Name | Description
Public property | OtherInterface | Other interface.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


InterfaceConnectPostEventArgs Constructor

Initializes a new instance of the InterfaceConnectPostEventArgs class.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InterfaceConnectPostEventArgs(
    ISimInterface simInterface
)
public:
InterfaceConnectPostEventArgs(
    ISimInterface^ simInterface
)

Parameters

simInterface
Type: VisualComponents.Create3DISimInterface
Other interface
See Also

Reference

InterfaceConnectPostEventArgs Class
VisualComponents.Create3D Namespace


InterfaceConnectPostEventArgs Properties

The InterfaceConnectPostEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | OtherInterface | Other interface.
Top
See Also

Reference

InterfaceConnectPostEventArgs Class
VisualComponents.Create3D Namespace


InterfaceConnectPostEventArgs.OtherInterface Property

InterfaceConnectPostEventArgsOtherInterface Property

Other interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimInterface OtherInterface { get; }
public:
property ISimInterface^ OtherInterface {
    ISimInterface^ get ();
}

Property Value

Type: ISimInterface
See Also

Reference

InterfaceConnectPostEventArgs Class
VisualComponents.Create3D Namespace


InterfaceConnectPostEventArgs Methods

The InterfaceConnectPostEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

InterfaceConnectPostEventArgs Class
VisualComponents.Create3D Namespace


InterfaceConnectPreEventArgs Class

Provides data for Connecting and Disconnecting events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DInterfaceConnectPreEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class InterfaceConnectPreEventArgs : EventArgs
public ref class InterfaceConnectPreEventArgs : public EventArgs

The InterfaceConnectPreEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | InterfaceConnectPreEventArgs | Initializes a new instance of the InterfaceConnectPreEventArgs class.
Top
Properties
 | Name | Description
Public property | Handled | Defines if the event is considered as handled and should not be processed.
Public property | OtherInterface | Other interface.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


InterfaceConnectPreEventArgs Constructor

Initializes a new instance of the InterfaceConnectPreEventArgs class.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InterfaceConnectPreEventArgs(
    ISimInterface simInterface
)
public:
InterfaceConnectPreEventArgs(
    ISimInterface^ simInterface
)

Parameters

simInterface
Type: VisualComponents.Create3DISimInterface
Other interface.
See Also

Reference

InterfaceConnectPreEventArgs Class
VisualComponents.Create3D Namespace


InterfaceConnectPreEventArgs Properties

The InterfaceConnectPreEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Handled | Defines if the event is considered as handled and should not be processed.
Public property | OtherInterface | Other interface.
Top
See Also

Reference

InterfaceConnectPreEventArgs Class
VisualComponents.Create3D Namespace


InterfaceConnectPreEventArgs.Handled Property

InterfaceConnectPreEventArgsHandled Property

Defines if the event is considered as handled and should not be processed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Handled { get; set; }
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

InterfaceConnectPreEventArgs Class
VisualComponents.Create3D Namespace


InterfaceConnectPreEventArgs.OtherInterface Property

InterfaceConnectPreEventArgsOtherInterface Property

Other interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimInterface OtherInterface { get; }
public:
property ISimInterface^ OtherInterface {
    ISimInterface^ get ();
}

Property Value

Type: ISimInterface
See Also

Reference

InterfaceConnectPreEventArgs Class
VisualComponents.Create3D Namespace


InterfaceConnectPreEventArgs Methods

The InterfaceConnectPreEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

InterfaceConnectPreEventArgs Class
VisualComponents.Create3D Namespace


InterfaceMatchEventArgs Class

Provides data for Match event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DInterfaceMatchEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class InterfaceMatchEventArgs : EventArgs
public ref class InterfaceMatchEventArgs : public EventArgs

The InterfaceMatchEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | InterfaceMatchEventArgs | Initializes a new instance of the InterfaceMatchEventArgs class.
Top
Properties
 | Name | Description
Public property | Handled | Defines if the event is considered as handled and should not be processed.
Public property | OtherInterface | Other interface.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


InterfaceMatchEventArgs Constructor

Initializes a new instance of the InterfaceMatchEventArgs class.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InterfaceMatchEventArgs(
    ISimInterface simInterface
)
public:
InterfaceMatchEventArgs(
    ISimInterface^ simInterface
)

Parameters

simInterface
Type: VisualComponents.Create3DISimInterface
Other interface.
See Also

Reference

InterfaceMatchEventArgs Class
VisualComponents.Create3D Namespace


InterfaceMatchEventArgs Properties

The InterfaceMatchEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Handled | Defines if the event is considered as handled and should not be processed.
Public property | OtherInterface | Other interface.
Top
See Also

Reference

InterfaceMatchEventArgs Class
VisualComponents.Create3D Namespace


InterfaceMatchEventArgs.Handled Property

InterfaceMatchEventArgsHandled Property

Defines if the event is considered as handled and should not be processed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Handled { get; set; }
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

InterfaceMatchEventArgs Class
VisualComponents.Create3D Namespace


InterfaceMatchEventArgs.OtherInterface Property

InterfaceMatchEventArgsOtherInterface Property

Other interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimInterface OtherInterface { get; }
public:
property ISimInterface^ OtherInterface {
    ISimInterface^ get ();
}

Property Value

Type: ISimInterface
See Also

Reference

InterfaceMatchEventArgs Class
VisualComponents.Create3D Namespace


InterfaceMatchEventArgs Methods

The InterfaceMatchEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

InterfaceMatchEventArgs Class
VisualComponents.Create3D Namespace


InterfacePosition Class

Class returned when calling GetNodeInterfaces of IPlugAndPlayLogicalHelper
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DInterfacePosition

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class InterfacePosition
public ref class InterfacePosition sealed

The InterfacePosition type exposes the following members.

Constructors
 | Name | Description
Public method | InterfacePosition | Initializes a new instance of the InterfacePosition class
Top
Properties
 | Name | Description
Public property | AbstractInterface |
Public property | TransformationInWorld |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


InterfacePosition Constructor

Initializes a new instance of the InterfacePosition class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InterfacePosition()
public:
InterfacePosition()
See Also

Reference

InterfacePosition Class
VisualComponents.Create3D Namespace


InterfacePosition Properties

The InterfacePosition type exposes the following members.

Properties
 | Name | Description
Public property | AbstractInterface |
Public property | TransformationInWorld |
Top
See Also

Reference

InterfacePosition Class
VisualComponents.Create3D Namespace


InterfacePosition.AbstractInterface Property

InterfacePositionAbstractInterface Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimInterface AbstractInterface { get; set; }
public:
property ISimInterface^ AbstractInterface {
    ISimInterface^ get ();
    void set (ISimInterface^ value);
}

Property Value

Type: ISimInterface
See Also

Reference

InterfacePosition Class
VisualComponents.Create3D Namespace


InterfacePosition.TransformationInWorld Property

InterfacePositionTransformationInWorld Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Matrix TransformationInWorld { get; set; }
public:
property Matrix TransformationInWorld {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

InterfacePosition Class
VisualComponents.Create3D Namespace


InterfacePosition Methods

The InterfacePosition type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

InterfacePosition Class
VisualComponents.Create3D Namespace


IntersectingGeometry Structure

Represents the intersection or minimum distance between 2 triangles from 2 triangle sets

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct IntersectingGeometry
public value class IntersectingGeometry

The IntersectingGeometry type exposes the following members.

Constructors
 | Name | Description
Public method | IntersectingGeometry | Initializes a new instance of the IntersectingGeometry class
Top
Properties
 | Name | Description
Public property | IntersectingLine |
Public property | IntersectingTriangles |
Public property | Set1 |
Public property | Set2 |
Top
Methods
 | Name | Description
Public method | Equals | Compares triangle index from two IntersectingGeometry (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Gets a hash code for this structure (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Equality | Compares two IntersectingGeometry instances for equality
Inequality | Compares two IntersectingGeometry instances for inequality
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IntersectingGeometry Constructor

Initializes a new instance of the IntersectingGeometry class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IntersectingGeometry(
    ITriangleSet set1,
    ITriangleSet set2,
    Tuple<int, int>[] intersectingTriangles,
    Tuple<Vector3, Vector3>[] intersectingLine
)
public:
IntersectingGeometry(
    ITriangleSet^ set1,
    ITriangleSet^ set2,
    array<Tuple<int, int>^>^ intersectingTriangles,
    array<Tuple<Vector3, Vector3>^>^ intersectingLine
)

Parameters

set1
Type: VisualComponents.Create3DITriangleSet
set2
Type: VisualComponents.Create3DITriangleSet
intersectingTriangles
Type: SystemTupleInt32, Int32
intersectingLine
Type: SystemTupleVector3, Vector3
See Also

Reference

IntersectingGeometry Structure
VisualComponents.Create3D Namespace


IntersectingGeometry Properties

The IntersectingGeometry type exposes the following members.

Properties
 | Name | Description
Public property | IntersectingLine |
Public property | IntersectingTriangles |
Public property | Set1 |
Public property | Set2 |
Top
See Also

Reference

IntersectingGeometry Structure
VisualComponents.Create3D Namespace


IntersectingGeometry.IntersectingLine Property

IntersectingGeometryIntersectingLine Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<Tuple<Vector3, Vector3>> IntersectingLine { get; }
public:
property ReadOnlyCollection<Tuple<Vector3, Vector3>^>^ IntersectingLine {
    ReadOnlyCollection<Tuple<Vector3, Vector3>^>^ get ();
}

Property Value

Type: ReadOnlyCollectionTupleVector3, Vector3
See Also

Reference

IntersectingGeometry Structure
VisualComponents.Create3D Namespace


IntersectingGeometry.IntersectingTriangles Property

IntersectingGeometryIntersectingTriangles Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<Tuple<int, int>> IntersectingTriangles { get; }
public:
property ReadOnlyCollection<Tuple<int, int>^>^ IntersectingTriangles {
    ReadOnlyCollection<Tuple<int, int>^>^ get ();
}

Property Value

Type: ReadOnlyCollectionTupleInt32, Int32
See Also

Reference

IntersectingGeometry Structure
VisualComponents.Create3D Namespace


IntersectingGeometry.Set1 Property

IntersectingGeometrySet1 Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ITriangleSet Set1 { get; }
public:
property ITriangleSet^ Set1 {
    ITriangleSet^ get ();
}

Property Value

Type: ITriangleSet
See Also

Reference

IntersectingGeometry Structure
VisualComponents.Create3D Namespace


IntersectingGeometry.Set2 Property

IntersectingGeometrySet2 Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ITriangleSet Set2 { get; }
public:
property ITriangleSet^ Set2 {
    ITriangleSet^ get ();
}

Property Value

Type: ITriangleSet
See Also

Reference

IntersectingGeometry Structure
VisualComponents.Create3D Namespace


IntersectingGeometry Methods

The IntersectingGeometry type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares triangle index from two IntersectingGeometry (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Gets a hash code for this structure (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

IntersectingGeometry Structure
VisualComponents.Create3D Namespace


IntersectingGeometry.Equals Method

IntersectingGeometryEquals Method

Compares triangle index from two IntersectingGeometry

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
The IntersectingGeometry to compare

Return Value

Type: Boolean
True if obj is identical with this IntersectingGeometry; false otherwise.
See Also

Reference

IntersectingGeometry Structure
VisualComponents.Create3D Namespace


IntersectingGeometry.GetHashCode Method

IntersectingGeometryGetHashCode Method

Gets a hash code for this structure

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32
Hash code
See Also

Reference

IntersectingGeometry Structure
VisualComponents.Create3D Namespace


IntersectingGeometry Operators

The IntersectingGeometry type exposes the following members.

Operators
Name | Description
Equality | Compares two IntersectingGeometry instances for equality
Inequality | Compares two IntersectingGeometry instances for inequality
Top
See Also

Reference

IntersectingGeometry Structure
VisualComponents.Create3D Namespace


IntersectingGeometry.Equality Operator

IntersectingGeometryEquality Operator

Compares two IntersectingGeometry instances for equality

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    IntersectingGeometry intersect1,
    IntersectingGeometry intersect2
)
public:
static bool operator ==(
    IntersectingGeometry intersect1,
    IntersectingGeometry intersect2
)

Parameters

intersect1
Type: VisualComponents.Create3DIntersectingGeometry
The first IntersectingGeometry to compare
intersect2
Type: VisualComponents.Create3DIntersectingGeometry
The second IntersectingGeometry to compare against

Return Value

Type: Boolean
True if the IntersectingGeometry are identical; false otherwise.
See Also

Reference

IntersectingGeometry Structure
VisualComponents.Create3D Namespace


IntersectingGeometry.Inequality Operator

IntersectingGeometryInequality Operator

Compares two IntersectingGeometry instances for inequality

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    IntersectingGeometry intersect1,
    IntersectingGeometry intersect2
)
public:
static bool operator !=(
    IntersectingGeometry intersect1,
    IntersectingGeometry intersect2
)

Parameters

intersect1
Type: VisualComponents.Create3DIntersectingGeometry
The first IntersectingGeometry to compare
intersect2
Type: VisualComponents.Create3DIntersectingGeometry
The second IntersectingGeometry to compare against

Return Value

Type: Boolean
True if the vectors are inequal, false otherwise
See Also

Reference

IntersectingGeometry Structure
VisualComponents.Create3D Namespace


InvalidWrapperException Class

Exception is thrown is an attempt to use an invalidated wrapper object is detected.
Inheritance Hierarchy
SystemObject
SystemException
VisualComponents.Create3DInvalidWrapperException

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[SerializableAttribute]
public class InvalidWrapperException : Exception
[SerializableAttribute]
public ref class InvalidWrapperException : public Exception

The InvalidWrapperException type exposes the following members.

Constructors
 | Name | Description
Public method | InvalidWrapperException | Initializes a new instance of the InvalidWrapperException class.
Public method | InvalidWrapperException(String) | Initializes a new instance of the InvalidWrapperException class.
Protected method | InvalidWrapperException(SerializationInfo, StreamingContext) | Initializes a new instance of the System.Exception class with serialized data.
Public method | InvalidWrapperException(String, Exception) | Initializes a new instance of the InvalidWrapperException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks
When working with wrappers you should always handle ObjectInvalidated event.
See Also

Reference

VisualComponents.Create3D Namespace


InvalidWrapperException Constructor

Overload List
 | Name | Description
Public method | InvalidWrapperException | Initializes a new instance of the InvalidWrapperException class.
Public method | InvalidWrapperException(String) | Initializes a new instance of the InvalidWrapperException class.
Protected method | InvalidWrapperException(SerializationInfo, StreamingContext) | Initializes a new instance of the System.Exception class with serialized data.
Public method | InvalidWrapperException(String, Exception) | Initializes a new instance of the InvalidWrapperException class.
Top
See Also

Reference

InvalidWrapperException Class
VisualComponents.Create3D Namespace


InvalidWrapperException Constructor

Initializes a new instance of the InvalidWrapperException class.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InvalidWrapperException()
public:
InvalidWrapperException()
See Also

Reference

InvalidWrapperException Class
InvalidWrapperException Overload
VisualComponents.Create3D Namespace


InvalidWrapperException Constructor (String)

Initializes a new instance of the InvalidWrapperException class.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InvalidWrapperException(
    string message
)
public:
InvalidWrapperException(
    String^ message
)

Parameters

message
Type: SystemString
The message that describes the error.
See Also

Reference

InvalidWrapperException Class
InvalidWrapperException Overload
VisualComponents.Create3D Namespace


InvalidWrapperException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the System.Exception class with serialized data.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected InvalidWrapperException(
    SerializationInfo info,
    StreamingContext context
)
protected:
InvalidWrapperException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.
See Also

Reference

InvalidWrapperException Class
InvalidWrapperException Overload
VisualComponents.Create3D Namespace


InvalidWrapperException Constructor (String, Exception)

Initializes a new instance of the InvalidWrapperException class.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InvalidWrapperException(
    string message,
    Exception innerException
)
public:
InvalidWrapperException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: SystemString
The message that describes the error.
innerException
Type: SystemException
Exception that is the cause of current exception or a null reference.
See Also

Reference

InvalidWrapperException Class
InvalidWrapperException Overload
VisualComponents.Create3D Namespace


InvalidWrapperException Properties

The InvalidWrapperException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

InvalidWrapperException Class
VisualComponents.Create3D Namespace


InvalidWrapperException Methods

The InvalidWrapperException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

InvalidWrapperException Class
VisualComponents.Create3D Namespace


InvalidWrapperException Events

The InvalidWrapperException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

InvalidWrapperException Class
VisualComponents.Create3D Namespace


IOneDirectionalPath Interface

One-directional path behavior used to move components along a path.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IOneDirectionalPath : ISimContainer,
    IFlowBehavior, IBehavior, IPropertyContainer, IBatchModeObject, IVisitable,
    IWrapper, IDisposable, INamed
public interface class IOneDirectionalPath : ISimContainer,
    IFlowBehavior, IBehavior, IPropertyContainer, IBatchModeObject, IVisitable,
    IWrapper, IDisposable, INamed

The IOneDirectionalPath type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Maximum logical capacity of the container. This determines the maximum number of components that can be contained in the container at any one time. (Inherited from ISimContainer.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Components | list of components currently contained in the container (Inherited from ISimContainer.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | HeadComponent | Returns component in the head of container (Inherited from ISimContainer.)
Public property | IsContentVisible | Defines whether components held by the container are displayed or not (Inherited from ISimContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | TailComponent | Returns component in the tail of container (Inherited from ISimContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetContainerProximity | Calculate the orthogonal distance from position to this container (Inherited from ISimContainer.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Grab | Grab the component into this container (Inherited from ISimContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ComponentArriving | Triggered when a component is arriving to the container (Inherited from ISimContainer.)
Public event | ComponentLeaving | Triggered when a component is leaving from the container (Inherited from ISimContainer.)
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IOneDirectionalPath Properties

The IOneDirectionalPath type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Maximum logical capacity of the container. This determines the maximum number of components that can be contained in the container at any one time. (Inherited from ISimContainer.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Components | list of components currently contained in the container (Inherited from ISimContainer.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | HeadComponent | Returns component in the head of container (Inherited from ISimContainer.)
Public property | IsContentVisible | Defines whether components held by the container are displayed or not (Inherited from ISimContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | TailComponent | Returns component in the tail of container (Inherited from ISimContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IOneDirectionalPath Interface
VisualComponents.Create3D Namespace


IOneDirectionalPath Methods

The IOneDirectionalPath type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetContainerProximity | Calculate the orthogonal distance from position to this container (Inherited from ISimContainer.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Grab | Grab the component into this container (Inherited from ISimContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IOneDirectionalPath Interface
VisualComponents.Create3D Namespace


IOneDirectionalPath Events

The IOneDirectionalPath type exposes the following members.

Events
 | Name | Description
Public event | ComponentArriving | Triggered when a component is arriving to the container (Inherited from ISimContainer.)
Public event | ComponentLeaving | Triggered when a component is leaving from the container (Inherited from ISimContainer.)
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IOneDirectionalPath Interface
VisualComponents.Create3D Namespace


IOneToManyInterface Interface

An interface for one to many interface behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IOneToManyInterface : ISimInterface,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed, IPropertyChangeFilter
public interface class IOneToManyInterface : ISimInterface,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed, IPropertyChangeFilter

The IOneToManyInterface type exposes the following members.

Properties
 | Name | Description
Public property | AngleTolerance | Gets or sets the angle tolerance of this ISimInterface. (Inherited from ISimInterface.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConnectedComponents | Retrieves the collection of ISimComponent that are connected to this ISimInterface. (Inherited from ISimInterface.)
Public property | ConnectedInterfaces | Retrieves the collection of ISimInterface that are connected to this ISimInterface. (Inherited from ISimInterface.)
Public property | ConnectedSections | Retrieves the collection of ISimInterfaceSection that are connected to this ISimInterface. (Inherited from ISimInterface.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Description | Gets or sets an user description of this ISimInterface. (Inherited from ISimInterface.)
Public property | EventFilter | Comma separated list of allowed client type names. (Inherited from IPropertyChangeFilter.)
Public property | IndicateDistance | Gets or sets the indicate distance of this ISimInterface. (Inherited from ISimInterface.)
Public property | IsApplication | Determines if this ISimInterface was created by the main application. (Inherited from ISimInterface.)
Public property | IsConnected | Retrieves the connection status of this ISimInterface. (Inherited from ISimInterface.)
Public property | IsLogical | Determines if this ISimInterface is logical (i.e. not connectable by plug and play). (Inherited from ISimInterface.)
Public property | IsOneToMany | Determines if this ISimInterface is one to many interface. (Inherited from ISimInterface.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | MagnetDistance | Gets or sets the magnet distance of this ISimInterface. (Inherited from ISimInterface.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Sections | Retrieves the collection of sections in this interface. (Inherited from ISimInterface.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect(ISimInterface) | Connects the given ISimInterface to this interface without updating position of the owner component. (Inherited from ISimInterface.)
Public method | Connect(ISimInterface, Boolean) | Connects the given ISimInterface to this interface. (Inherited from ISimInterface.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | CreateSection | Creates and adds a new ISimInterfaceSection to this interface. (Inherited from ISimInterface.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteSection | Deletes the given ISimInterfaceSection and removes it from this interface. (Inherited from ISimInterface.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects all the interfaces connected to this ISimInterface. (Inherited from ISimInterface.)
Public method | Disconnect(ISimInterface) | Disconnects the given interface from this ISimInterface. (Inherited from ISimInterface.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | FindMatchingSections | Finds the first ISimInterfaceSection that matches the given section. (Inherited from ISimInterface.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | IsCompatibleWith | Checks if the given ISimInterface is compatible with this interface. (Inherited from ISimInterface.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SwapSections | Swaps the order of the given sections. (Inherited from ISimInterface.)
Top
Events
 | Name | Description
Public event | Connected | Event that is raised after this ISimInterface has been connected. (Inherited from ISimInterface.)
Public event | Connecting | Event that is raised when this ISimInterface is being connected. (Inherited from ISimInterface.)
Public event | Disconnected | Event that is raised after this ISimInterface has been disconnected. (Inherited from ISimInterface.)
Public event | Disconnecting | Event that is raised when this ISimInterface is being disconnected. (Inherited from ISimInterface.)
Public event | Match | Event that is raised when this ISimInterface checks if it matches with other interface. (Inherited from ISimInterface.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IOneToManyInterface Properties

The IOneToManyInterface type exposes the following members.

Properties
 | Name | Description
Public property | AngleTolerance | Gets or sets the angle tolerance of this ISimInterface. (Inherited from ISimInterface.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConnectedComponents | Retrieves the collection of ISimComponent that are connected to this ISimInterface. (Inherited from ISimInterface.)
Public property | ConnectedInterfaces | Retrieves the collection of ISimInterface that are connected to this ISimInterface. (Inherited from ISimInterface.)
Public property | ConnectedSections | Retrieves the collection of ISimInterfaceSection that are connected to this ISimInterface. (Inherited from ISimInterface.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Description | Gets or sets an user description of this ISimInterface. (Inherited from ISimInterface.)
Public property | EventFilter | Comma separated list of allowed client type names. (Inherited from IPropertyChangeFilter.)
Public property | IndicateDistance | Gets or sets the indicate distance of this ISimInterface. (Inherited from ISimInterface.)
Public property | IsApplication | Determines if this ISimInterface was created by the main application. (Inherited from ISimInterface.)
Public property | IsConnected | Retrieves the connection status of this ISimInterface. (Inherited from ISimInterface.)
Public property | IsLogical | Determines if this ISimInterface is logical (i.e. not connectable by plug and play). (Inherited from ISimInterface.)
Public property | IsOneToMany | Determines if this ISimInterface is one to many interface. (Inherited from ISimInterface.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | MagnetDistance | Gets or sets the magnet distance of this ISimInterface. (Inherited from ISimInterface.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Sections | Retrieves the collection of sections in this interface. (Inherited from ISimInterface.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IOneToManyInterface Interface
VisualComponents.Create3D Namespace


IOneToManyInterface Methods

The IOneToManyInterface type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect(ISimInterface) | Connects the given ISimInterface to this interface without updating position of the owner component. (Inherited from ISimInterface.)
Public method | Connect(ISimInterface, Boolean) | Connects the given ISimInterface to this interface. (Inherited from ISimInterface.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | CreateSection | Creates and adds a new ISimInterfaceSection to this interface. (Inherited from ISimInterface.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteSection | Deletes the given ISimInterfaceSection and removes it from this interface. (Inherited from ISimInterface.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects all the interfaces connected to this ISimInterface. (Inherited from ISimInterface.)
Public method | Disconnect(ISimInterface) | Disconnects the given interface from this ISimInterface. (Inherited from ISimInterface.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | FindMatchingSections | Finds the first ISimInterfaceSection that matches the given section. (Inherited from ISimInterface.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | IsCompatibleWith | Checks if the given ISimInterface is compatible with this interface. (Inherited from ISimInterface.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SwapSections | Swaps the order of the given sections. (Inherited from ISimInterface.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IOneToManyInterface Interface
VisualComponents.Create3D Namespace


IOneToManyInterface Events

The IOneToManyInterface type exposes the following members.

Events
 | Name | Description
Public event | Connected | Event that is raised after this ISimInterface has been connected. (Inherited from ISimInterface.)
Public event | Connecting | Event that is raised when this ISimInterface is being connected. (Inherited from ISimInterface.)
Public event | Disconnected | Event that is raised after this ISimInterface has been disconnected. (Inherited from ISimInterface.)
Public event | Disconnecting | Event that is raised when this ISimInterface is being disconnected. (Inherited from ISimInterface.)
Public event | Match | Event that is raised when this ISimInterface checks if it matches with other interface. (Inherited from ISimInterface.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IOneToManyInterface Interface
VisualComponents.Create3D Namespace


IOneToOneInterface Interface

An interface for one to one interface behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IOneToOneInterface : ISimInterface,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed, IPropertyChangeFilter
public interface class IOneToOneInterface : ISimInterface,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed, IPropertyChangeFilter

The IOneToOneInterface type exposes the following members.

Properties
 | Name | Description
Public property | AngleTolerance | Gets or sets the angle tolerance of this ISimInterface. (Inherited from ISimInterface.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConnectedComponents | Retrieves the collection of ISimComponent that are connected to this ISimInterface. (Inherited from ISimInterface.)
Public property | ConnectedInterfaces | Retrieves the collection of ISimInterface that are connected to this ISimInterface. (Inherited from ISimInterface.)
Public property | ConnectedSections | Retrieves the collection of ISimInterfaceSection that are connected to this ISimInterface. (Inherited from ISimInterface.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Description | Gets or sets an user description of this ISimInterface. (Inherited from ISimInterface.)
Public property | EventFilter | Comma separated list of allowed client type names. (Inherited from IPropertyChangeFilter.)
Public property | IndicateDistance | Gets or sets the indicate distance of this ISimInterface. (Inherited from ISimInterface.)
Public property | IsApplication | Determines if this ISimInterface was created by the main application. (Inherited from ISimInterface.)
Public property | IsConnected | Retrieves the connection status of this ISimInterface. (Inherited from ISimInterface.)
Public property | IsLogical | Determines if this ISimInterface is logical (i.e. not connectable by plug and play). (Inherited from ISimInterface.)
Public property | IsOneToMany | Determines if this ISimInterface is one to many interface. (Inherited from ISimInterface.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | MagnetDistance | Gets or sets the magnet distance of this ISimInterface. (Inherited from ISimInterface.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Sections | Retrieves the collection of sections in this interface. (Inherited from ISimInterface.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect(ISimInterface) | Connects the given ISimInterface to this interface without updating position of the owner component. (Inherited from ISimInterface.)
Public method | Connect(ISimInterface, Boolean) | Connects the given ISimInterface to this interface. (Inherited from ISimInterface.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | CreateSection | Creates and adds a new ISimInterfaceSection to this interface. (Inherited from ISimInterface.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteSection | Deletes the given ISimInterfaceSection and removes it from this interface. (Inherited from ISimInterface.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects all the interfaces connected to this ISimInterface. (Inherited from ISimInterface.)
Public method | Disconnect(ISimInterface) | Disconnects the given interface from this ISimInterface. (Inherited from ISimInterface.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | FindMatchingSections | Finds the first ISimInterfaceSection that matches the given section. (Inherited from ISimInterface.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | IsCompatibleWith | Checks if the given ISimInterface is compatible with this interface. (Inherited from ISimInterface.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SwapSections | Swaps the order of the given sections. (Inherited from ISimInterface.)
Top
Events
 | Name | Description
Public event | Connected | Event that is raised after this ISimInterface has been connected. (Inherited from ISimInterface.)
Public event | Connecting | Event that is raised when this ISimInterface is being connected. (Inherited from ISimInterface.)
Public event | Disconnected | Event that is raised after this ISimInterface has been disconnected. (Inherited from ISimInterface.)
Public event | Disconnecting | Event that is raised when this ISimInterface is being disconnected. (Inherited from ISimInterface.)
Public event | Match | Event that is raised when this ISimInterface checks if it matches with other interface. (Inherited from ISimInterface.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IOneToOneInterface Properties

The IOneToOneInterface type exposes the following members.

Properties
 | Name | Description
Public property | AngleTolerance | Gets or sets the angle tolerance of this ISimInterface. (Inherited from ISimInterface.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConnectedComponents | Retrieves the collection of ISimComponent that are connected to this ISimInterface. (Inherited from ISimInterface.)
Public property | ConnectedInterfaces | Retrieves the collection of ISimInterface that are connected to this ISimInterface. (Inherited from ISimInterface.)
Public property | ConnectedSections | Retrieves the collection of ISimInterfaceSection that are connected to this ISimInterface. (Inherited from ISimInterface.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Description | Gets or sets an user description of this ISimInterface. (Inherited from ISimInterface.)
Public property | EventFilter | Comma separated list of allowed client type names. (Inherited from IPropertyChangeFilter.)
Public property | IndicateDistance | Gets or sets the indicate distance of this ISimInterface. (Inherited from ISimInterface.)
Public property | IsApplication | Determines if this ISimInterface was created by the main application. (Inherited from ISimInterface.)
Public property | IsConnected | Retrieves the connection status of this ISimInterface. (Inherited from ISimInterface.)
Public property | IsLogical | Determines if this ISimInterface is logical (i.e. not connectable by plug and play). (Inherited from ISimInterface.)
Public property | IsOneToMany | Determines if this ISimInterface is one to many interface. (Inherited from ISimInterface.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | MagnetDistance | Gets or sets the magnet distance of this ISimInterface. (Inherited from ISimInterface.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Sections | Retrieves the collection of sections in this interface. (Inherited from ISimInterface.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IOneToOneInterface Interface
VisualComponents.Create3D Namespace


IOneToOneInterface Methods

The IOneToOneInterface type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect(ISimInterface) | Connects the given ISimInterface to this interface without updating position of the owner component. (Inherited from ISimInterface.)
Public method | Connect(ISimInterface, Boolean) | Connects the given ISimInterface to this interface. (Inherited from ISimInterface.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | CreateSection | Creates and adds a new ISimInterfaceSection to this interface. (Inherited from ISimInterface.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteSection | Deletes the given ISimInterfaceSection and removes it from this interface. (Inherited from ISimInterface.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects all the interfaces connected to this ISimInterface. (Inherited from ISimInterface.)
Public method | Disconnect(ISimInterface) | Disconnects the given interface from this ISimInterface. (Inherited from ISimInterface.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | FindMatchingSections | Finds the first ISimInterfaceSection that matches the given section. (Inherited from ISimInterface.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | IsCompatibleWith | Checks if the given ISimInterface is compatible with this interface. (Inherited from ISimInterface.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SwapSections | Swaps the order of the given sections. (Inherited from ISimInterface.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IOneToOneInterface Interface
VisualComponents.Create3D Namespace


IOneToOneInterface Events

The IOneToOneInterface type exposes the following members.

Events
 | Name | Description
Public event | Connected | Event that is raised after this ISimInterface has been connected. (Inherited from ISimInterface.)
Public event | Connecting | Event that is raised when this ISimInterface is being connected. (Inherited from ISimInterface.)
Public event | Disconnected | Event that is raised after this ISimInterface has been disconnected. (Inherited from ISimInterface.)
Public event | Disconnecting | Event that is raised when this ISimInterface is being disconnected. (Inherited from ISimInterface.)
Public event | Match | Event that is raised when this ISimInterface checks if it matches with other interface. (Inherited from ISimInterface.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IOneToOneInterface Interface
VisualComponents.Create3D Namespace


IOneWayPath Interface

An interface for one-way path behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IOneWayPath : IMotionPath,
    ISimContainer, IFlowBehavior, IBehavior, IPropertyContainer, IBatchModeObject,
    IVisitable, IWrapper, IDisposable, INamed
public interface class IOneWayPath : IMotionPath,
    ISimContainer, IFlowBehavior, IBehavior, IPropertyContainer, IBatchModeObject,
    IVisitable, IWrapper, IDisposable, INamed

The IOneWayPath type exposes the following members.

Properties
 | Name | Description
Public property | Acceleration | Gets or sets acceleration rate of components on the path, in millimeters per second squared. If this is zero, acceleration is not calculated. (Inherited from IMotionPath.)
Public property | Accumulate | Determines whether components on the path accumulate when one or more components are blocked at the end of the path. If true, components behind a blocked component keep moving until they hit the blocked component. If false, all components in the path stop when the end is blocked. (Inherited from IMotionPath.)
Public property | Capacity | Maximum logical capacity of the container. This determines the maximum number of components that can be contained in the container at any one time. (Inherited from ISimContainer.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Components | list of components currently contained in the container (Inherited from ISimContainer.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Deceleration | Gets or sets deceleration rate of components on the path, in millimeters per second squared. If this is zero, deceleration is not calculated. (Inherited from IMotionPath.)
Public property | DetailCurveMotion | Determines if parts use at curved areas bound box information to avoid box shaped parts to intersect at corners. In some cases like when parts are cylindrical shapes this can cause extra spacing between parts in the curves and in these cases option could be disabled. Part starting movement at curve area after linear section will slow down slightly part immediately behind (at linear section) when part bound box starts rotating. If slight intersection temporarily in the transition from linear section to curved section is not a problem or is part shapes are cylindrical or similar then this option could be disabled. (Inherited from IMotionPath.)
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | HeadComponent | Returns component in the head of container (Inherited from ISimContainer.)
Public property | Interpolation | Gets or sets interpolation mode to use with the path frames. (Inherited from IMotionPath.)
Public property | IsContentVisible | Defines whether components held by the container are displayed or not (Inherited from ISimContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Path | Gets the ordered list of frames that define the path. The actual path is then calculated by interpolating using the method defined by InterpolationMode property. (Inherited from IMotionPath.)
Public property | PathLength | Gets the total length of the path. (Inherited from IMotionPath.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | RetainOffset | Determines how components are positioned on the path when they enter the path. If true, the component offset is retained, otherwise the component is placed with its origin at the nearest point on the path. (Inherited from IMotionPath.)
Public property | SegmentSize | Gets or sets conveyor segment size. If this is greater to zero, the conveyor is divided into segments of the given size, each of which may contain at most one component at any one time. The total number of segments will then determine the maximum capacity of the conveyor in addition to the Capacity property and any associated capacity controllers. (Inherited from IMotionPath.)
Public property | Sensors | Gets the list of sensors that are used in this path. (Inherited from IMotionPath.)
Public property | SpaceUtilization | Determines if components are kept apart from each other in accumulating mode, or when new components are added to the path. If set to false, components may overlap. This may be useful when RetainOffset is true and the components are spread out along the width of a conveyor. In this case two components are allowed to be side by side on the conveyor. (Inherited from IMotionPath.)
Public property | Speed | Gets or sets the speed of the conveyor, in millimeters per second. (Inherited from IMotionPath.)
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | TailComponent | Returns component in the tail of container (Inherited from ISimContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetContainerProximity | Calculate the orthogonal distance from position to this container (Inherited from ISimContainer.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetPathDistanceAtPosition | Gets the path distance at the path position. If the position is outside the path then the distance at closest path position is returned. (Inherited from IMotionPath.)
Public method | GetPathPositionAtDistance | Gets the path position at given distance (Inherited from IMotionPath.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Grab | Grab the component into this container (Inherited from ISimContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ComponentArriving | Triggered when a component is arriving to the container (Inherited from ISimContainer.)
Public event | ComponentLeaving | Triggered when a component is leaving from the container (Inherited from ISimContainer.)
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IOneWayPath Properties

The IOneWayPath type exposes the following members.

Properties
 | Name | Description
Public property | Acceleration | Gets or sets acceleration rate of components on the path, in millimeters per second squared. If this is zero, acceleration is not calculated. (Inherited from IMotionPath.)
Public property | Accumulate | Determines whether components on the path accumulate when one or more components are blocked at the end of the path. If true, components behind a blocked component keep moving until they hit the blocked component. If false, all components in the path stop when the end is blocked. (Inherited from IMotionPath.)
Public property | Capacity | Maximum logical capacity of the container. This determines the maximum number of components that can be contained in the container at any one time. (Inherited from ISimContainer.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Components | list of components currently contained in the container (Inherited from ISimContainer.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Deceleration | Gets or sets deceleration rate of components on the path, in millimeters per second squared. If this is zero, deceleration is not calculated. (Inherited from IMotionPath.)
Public property | DetailCurveMotion | Determines if parts use at curved areas bound box information to avoid box shaped parts to intersect at corners. In some cases like when parts are cylindrical shapes this can cause extra spacing between parts in the curves and in these cases option could be disabled. Part starting movement at curve area after linear section will slow down slightly part immediately behind (at linear section) when part bound box starts rotating. If slight intersection temporarily in the transition from linear section to curved section is not a problem or is part shapes are cylindrical or similar then this option could be disabled. (Inherited from IMotionPath.)
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | HeadComponent | Returns component in the head of container (Inherited from ISimContainer.)
Public property | Interpolation | Gets or sets interpolation mode to use with the path frames. (Inherited from IMotionPath.)
Public property | IsContentVisible | Defines whether components held by the container are displayed or not (Inherited from ISimContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Path | Gets the ordered list of frames that define the path. The actual path is then calculated by interpolating using the method defined by InterpolationMode property. (Inherited from IMotionPath.)
Public property | PathLength | Gets the total length of the path. (Inherited from IMotionPath.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | RetainOffset | Determines how components are positioned on the path when they enter the path. If true, the component offset is retained, otherwise the component is placed with its origin at the nearest point on the path. (Inherited from IMotionPath.)
Public property | SegmentSize | Gets or sets conveyor segment size. If this is greater to zero, the conveyor is divided into segments of the given size, each of which may contain at most one component at any one time. The total number of segments will then determine the maximum capacity of the conveyor in addition to the Capacity property and any associated capacity controllers. (Inherited from IMotionPath.)
Public property | Sensors | Gets the list of sensors that are used in this path. (Inherited from IMotionPath.)
Public property | SpaceUtilization | Determines if components are kept apart from each other in accumulating mode, or when new components are added to the path. If set to false, components may overlap. This may be useful when RetainOffset is true and the components are spread out along the width of a conveyor. In this case two components are allowed to be side by side on the conveyor. (Inherited from IMotionPath.)
Public property | Speed | Gets or sets the speed of the conveyor, in millimeters per second. (Inherited from IMotionPath.)
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | TailComponent | Returns component in the tail of container (Inherited from ISimContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IOneWayPath Interface
VisualComponents.Create3D Namespace


IOneWayPath Methods

The IOneWayPath type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetContainerProximity | Calculate the orthogonal distance from position to this container (Inherited from ISimContainer.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetPathDistanceAtPosition | Gets the path distance at the path position. If the position is outside the path then the distance at closest path position is returned. (Inherited from IMotionPath.)
Public method | GetPathPositionAtDistance | Gets the path position at given distance (Inherited from IMotionPath.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Grab | Grab the component into this container (Inherited from ISimContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IOneWayPath Interface
VisualComponents.Create3D Namespace


IOneWayPath Events

The IOneWayPath type exposes the following members.

Events
 | Name | Description
Public event | ComponentArriving | Triggered when a component is arriving to the container (Inherited from ISimContainer.)
Public event | ComponentLeaving | Triggered when a component is leaving from the container (Inherited from ISimContainer.)
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IOneWayPath Interface
VisualComponents.Create3D Namespace


IOriginManipulationTarget Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IOriginManipulationTarget : IManipulationTarget,
    ILockableObject, IDisposable
public interface class IOriginManipulationTarget : IManipulationTarget,
    ILockableObject, IDisposable

The IOriginManipulationTarget type exposes the following members.

Properties
 | Name | Description
Public property | HandleInObjectCoordinates | Deprecated. Same as TransformationInObject. (Inherited from IManipulationTarget.)
Public property | HandleInReference | Deprecated. Same as TransformationInReference. (Inherited from IManipulationTarget.)
Public property | HandleInWorld | Deprecated. Same as TransformationInWorld. (Inherited from IManipulationTarget.)
Public property | HandleReferenceInWorld | Deprecated. Same as ParentTransformationInWorld. (Inherited from IManipulationTarget.)
Public property | IsHandleFixed | Deprecated. Same as IRobotTcpManipulationTarget.IsTcpExternal. (Inherited from IManipulationTarget.)
Public property | IsLocked | (Inherited from IManipulationTarget.)
Public property | IsTargetEnabled | This is similar to IsLocked, but for manual disabling. (Inherited from IManipulationTarget.)
Public property | IsValid | (Inherited from IManipulationTarget.)
Public property | IsVisible | (Inherited from IManipulationTarget.)
Public property | ParentTransformationInWorld | Position of pivot visual object parent. (Inherited from IManipulationTarget.)
Public property | PivotObject | (Inherited from IManipulationTarget.)
Public property | TargetObjects | Target objects. May exlude child objects. (Inherited from IManipulationTarget.)
Public property | TransformationInObject | Sets the transformation in reference to its own space (Inherited from IManipulationTarget.)
Public property | TransformationInReference | Gets or sets the transformation in reference to its parent (Inherited from IManipulationTarget.)
Public property | TransformationInWorld | Gets or sets the transformation in world (Inherited from IManipulationTarget.)
Top
Methods
 | Name | Description
Public method | ApplyChanges | Apply changes on action end.
Public method | CollectUndoChanges | Collect all changes since the last call to StoreUndoState(). (Inherited from IManipulationTarget.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | StoreUndoState | Store information away to be used when creating an undo change set later. (Inherited from IManipulationTarget.)
Top
Events
 | Name | Description
Public event | IsLockedChanged | (Inherited from IManipulationTarget.)
Public event | IsVisibleChanged | (Inherited from IManipulationTarget.)
Public event | ObjectInvalidated | (Inherited from IManipulationTarget.)
Public event | TransformationChanged | (Inherited from IManipulationTarget.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IOriginManipulationTarget Properties

The IOriginManipulationTarget type exposes the following members.

Properties
 | Name | Description
Public property | HandleInObjectCoordinates | Deprecated. Same as TransformationInObject. (Inherited from IManipulationTarget.)
Public property | HandleInReference | Deprecated. Same as TransformationInReference. (Inherited from IManipulationTarget.)
Public property | HandleInWorld | Deprecated. Same as TransformationInWorld. (Inherited from IManipulationTarget.)
Public property | HandleReferenceInWorld | Deprecated. Same as ParentTransformationInWorld. (Inherited from IManipulationTarget.)
Public property | IsHandleFixed | Deprecated. Same as IRobotTcpManipulationTarget.IsTcpExternal. (Inherited from IManipulationTarget.)
Public property | IsLocked | (Inherited from IManipulationTarget.)
Public property | IsTargetEnabled | This is similar to IsLocked, but for manual disabling. (Inherited from IManipulationTarget.)
Public property | IsValid | (Inherited from IManipulationTarget.)
Public property | IsVisible | (Inherited from IManipulationTarget.)
Public property | ParentTransformationInWorld | Position of pivot visual object parent. (Inherited from IManipulationTarget.)
Public property | PivotObject | (Inherited from IManipulationTarget.)
Public property | TargetObjects | Target objects. May exlude child objects. (Inherited from IManipulationTarget.)
Public property | TransformationInObject | Sets the transformation in reference to its own space (Inherited from IManipulationTarget.)
Public property | TransformationInReference | Gets or sets the transformation in reference to its parent (Inherited from IManipulationTarget.)
Public property | TransformationInWorld | Gets or sets the transformation in world (Inherited from IManipulationTarget.)
Top
See Also

Reference

IOriginManipulationTarget Interface
VisualComponents.Create3D Namespace


IOriginManipulationTarget Methods

The IOriginManipulationTarget type exposes the following members.

Methods
 | Name | Description
Public method | ApplyChanges | Apply changes on action end.
Public method | CollectUndoChanges | Collect all changes since the last call to StoreUndoState(). (Inherited from IManipulationTarget.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | StoreUndoState | Store information away to be used when creating an undo change set later. (Inherited from IManipulationTarget.)
Top
See Also

Reference

IOriginManipulationTarget Interface
VisualComponents.Create3D Namespace


IOriginManipulationTarget.ApplyChanges Method

IOriginManipulationTargetApplyChanges Method

Apply changes on action end.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ApplyChanges(
    bool finalChange
)
void ApplyChanges(
    bool finalChange
)

Parameters

finalChange
Type: SystemBoolean

Implements

IManipulationTargetApplyChanges(Boolean)
See Also

Reference

IOriginManipulationTarget Interface
VisualComponents.Create3D Namespace


IOriginManipulationTarget Events

The IOriginManipulationTarget type exposes the following members.

Events
 | Name | Description
Public event | IsLockedChanged | (Inherited from IManipulationTarget.)
Public event | IsVisibleChanged | (Inherited from IManipulationTarget.)
Public event | ObjectInvalidated | (Inherited from IManipulationTarget.)
Public event | TransformationChanged | (Inherited from IManipulationTarget.)
Top
See Also

Reference

IOriginManipulationTarget Interface
VisualComponents.Create3D Namespace


IPackFolder Interface

Pack folder interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPackFolder
public interface class IPackFolder

The IPackFolder type exposes the following members.

Properties
 | Name | Description
Public property | PackFolderLocalPath | Local path where pack folder files can be found.
Public property | State | Current pack folder state.
Top
Methods
 | Name | Description
Public method | MapFolder | Unpack the files in the pack folder to a local folder.
Public method | RemapFolder | Change pack folder mapping without extracting or copying files.
Public method | Reset | Sets back the state to NotDefined and cleans the PackFolderLocalPath.
Public method | RollbackFolder | Remove local folder mapping without saving any changes.
Top
Remarks
A pack folder is a set of files included in a component or layout file. When the folder is mapped, a folder is created in temporary storage, and all these files are extracted there. When the component or layout is saved, any files or folders in this area are stored as well.
See Also

Reference

VisualComponents.Create3D Namespace


IPackFolder Properties

The IPackFolder type exposes the following members.

Properties
 | Name | Description
Public property | PackFolderLocalPath | Local path where pack folder files can be found.
Public property | State | Current pack folder state.
Top
See Also

Reference

IPackFolder Interface
VisualComponents.Create3D Namespace


IPackFolder.PackFolderLocalPath Property

IPackFolderPackFolderLocalPath Property

Local path where pack folder files can be found.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string PackFolderLocalPath { get; }
property String^ PackFolderLocalPath {
    String^ get ();
}

Property Value

Type: String
Remarks
This is empty if the pack folder is not mapped.
See Also

Reference

IPackFolder Interface
VisualComponents.Create3D Namespace


IPackFolder.State Property

IPackFolderState Property

Current pack folder state.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
PackFolderState State { get; }
property PackFolderState State {
    PackFolderState get ();
}

Property Value

Type: PackFolderState
See Also

Reference

IPackFolder Interface
VisualComponents.Create3D Namespace


IPackFolder Methods

The IPackFolder type exposes the following members.

Methods
 | Name | Description
Public method | MapFolder | Unpack the files in the pack folder to a local folder.
Public method | RemapFolder | Change pack folder mapping without extracting or copying files.
Public method | Reset | Sets back the state to NotDefined and cleans the PackFolderLocalPath.
Public method | RollbackFolder | Remove local folder mapping without saving any changes.
Top
See Also

Reference

IPackFolder Interface
VisualComponents.Create3D Namespace


IPackFolder.MapFolder Method

IPackFolderMapFolder Method

Unpack the files in the pack folder to a local folder.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void MapFolder(
    string localPath
)
void MapFolder(
    String^ localPath
)

Parameters

localPath
Type: SystemString
Optional local path.
Remarks

The localPath argument is optional; if it is null or empty, the pack folder will be mapped to a location in the system temporary folder. In any case, the local folder location can be read in PackFolderLocalPath after calling this method.

Note that the given local path must exist when this method is called. Note also that this method will delete all files in the given folder before unpacking the packed files.

See Also

Reference

IPackFolder Interface
VisualComponents.Create3D Namespace


IPackFolder.RemapFolder Method

IPackFolderRemapFolder Method

Change pack folder mapping without extracting or copying files.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RemapFolder(
    string localPath
)
void RemapFolder(
    String^ localPath
)

Parameters

localPath
Type: SystemString
Remarks

This method maps the pack folder to a local path without replacing the files at the target local path.

Note that the given local path must exist when this method is called.

See Also

Reference

IPackFolder Interface
VisualComponents.Create3D Namespace


IPackFolder.Reset Method

IPackFolderReset Method

Sets back the state to NotDefined and cleans the PackFolderLocalPath.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Reset()
void Reset()
See Also

Reference

IPackFolder Interface
VisualComponents.Create3D Namespace


IPackFolder.RollbackFolder Method

IPackFolderRollbackFolder Method

Remove local folder mapping without saving any changes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RollbackFolder()
void RollbackFolder()
Remarks
The component pack folder will revert to the state before MapFolder was called.
See Also

Reference

IPackFolder Interface
VisualComponents.Create3D Namespace


IParallelogramKinematics Interface

An interface for parallelogram kinematics behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IParallelogramKinematics : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IParallelogramKinematics : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IParallelogramKinematics type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IParallelogramKinematics Properties

The IParallelogramKinematics type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IParallelogramKinematics Interface
VisualComponents.Create3D Namespace


IParallelogramKinematics Methods

The IParallelogramKinematics type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IParallelogramKinematics Interface
VisualComponents.Create3D Namespace


IParallelogramKinematics Events

The IParallelogramKinematics type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IParallelogramKinematics Interface
VisualComponents.Create3D Namespace


IPathObject Interface

Path object layout item interface. Path object is an object consisting of motion nodes, action nodes, parameter nodes and reference nodes. It also contains segments that consists of trajectory nodes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPathObject : IWrapper,
    IDisposable, ILayoutItem, INamed, IPropertyContainer, IBatchModeObject
public interface class IPathObject : IWrapper,
    IDisposable, ILayoutItem, INamed, IPropertyContainer, IBatchModeObject

The IPathObject type exposes the following members.

Properties
 | Name | Description
Public property | ActionNodes | Gets the action nodes in the path object.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsPersistent | Defines if the ILayoutItem is stored with the layout. (Inherited from ILayoutItem.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | MotionNodes | Gets the motion nodes in the path object.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParameterNodes | Gets the parameter nodes in the path object.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferenceNodes | Gets the reference nodes in the path object.
Public property | Segments | Gets the segments in the path object.
Public property | TrajectoryNodes | Gets all the trajectory nodes in the path object.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
Path object has been deprecated in 4.0. This interface should be only used to retrieve the data from layouts saved in the previous versions.
See Also

Reference

VisualComponents.Create3D Namespace


IPathObject Properties

The IPathObject type exposes the following members.

Properties
 | Name | Description
Public property | ActionNodes | Gets the action nodes in the path object.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsPersistent | Defines if the ILayoutItem is stored with the layout. (Inherited from ILayoutItem.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | MotionNodes | Gets the motion nodes in the path object.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParameterNodes | Gets the parameter nodes in the path object.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferenceNodes | Gets the reference nodes in the path object.
Public property | Segments | Gets the segments in the path object.
Public property | TrajectoryNodes | Gets all the trajectory nodes in the path object.
Top
See Also

Reference

IPathObject Interface
VisualComponents.Create3D Namespace


IPathObject.ActionNodes Property

IPathObjectActionNodes Property

Gets the action nodes in the path object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IPathObjectActionNode> ActionNodes { get; }
property ReadOnlyCollection<IPathObjectActionNode^>^ ActionNodes {
    ReadOnlyCollection<IPathObjectActionNode^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIPathObjectActionNode
See Also

Reference

IPathObject Interface
VisualComponents.Create3D Namespace


IPathObject.MotionNodes Property

IPathObjectMotionNodes Property

Gets the motion nodes in the path object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IPathObjectMotionNode> MotionNodes { get; }
property ReadOnlyCollection<IPathObjectMotionNode^>^ MotionNodes {
    ReadOnlyCollection<IPathObjectMotionNode^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIPathObjectMotionNode
See Also

Reference

IPathObject Interface
VisualComponents.Create3D Namespace


IPathObject.ParameterNodes Property

IPathObjectParameterNodes Property

Gets the parameter nodes in the path object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IPathObjectParameterNode> ParameterNodes { get; }
property ReadOnlyCollection<IPathObjectParameterNode^>^ ParameterNodes {
    ReadOnlyCollection<IPathObjectParameterNode^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIPathObjectParameterNode
See Also

Reference

IPathObject Interface
VisualComponents.Create3D Namespace


IPathObject.ReferenceNodes Property

IPathObjectReferenceNodes Property

Gets the reference nodes in the path object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IPathObjectReferenceNode> ReferenceNodes { get; }
property ReadOnlyCollection<IPathObjectReferenceNode^>^ ReferenceNodes {
    ReadOnlyCollection<IPathObjectReferenceNode^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIPathObjectReferenceNode
See Also

Reference

IPathObject Interface
VisualComponents.Create3D Namespace


IPathObject.Segments Property

IPathObjectSegments Property

Gets the segments in the path object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IPathObjectSegment> Segments { get; }
property ReadOnlyCollection<IPathObjectSegment^>^ Segments {
    ReadOnlyCollection<IPathObjectSegment^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIPathObjectSegment
See Also

Reference

IPathObject Interface
VisualComponents.Create3D Namespace


IPathObject.TrajectoryNodes Property

IPathObjectTrajectoryNodes Property

Gets all the trajectory nodes in the path object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<TrajectoryNode> TrajectoryNodes { get; }
property ReadOnlyCollection<TrajectoryNode>^ TrajectoryNodes {
    ReadOnlyCollection<TrajectoryNode>^ get ();
}

Property Value

Type: ReadOnlyCollectionTrajectoryNode
See Also

Reference

IPathObject Interface
VisualComponents.Create3D Namespace


IPathObject Methods

The IPathObject type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IPathObject Interface
VisualComponents.Create3D Namespace


IPathObject Events

The IPathObject type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IPathObject Interface
VisualComponents.Create3D Namespace


IPathObjectActionNode Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPathObjectActionNode : IPathObjectNode,
    IWrapper, IDisposable, IPropertyContainer, IBatchModeObject, INamed
public interface class IPathObjectActionNode : IPathObjectNode,
    IWrapper, IDisposable, IPropertyContainer, IBatchModeObject, INamed

The IPathObjectActionNode type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | LogicalPosition |
Public property | MotionNode |
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Offset |
Public property | PathObject | Gets the path object that owns this node. (Inherited from IPathObjectNode.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPathObjectActionNode Properties

The IPathObjectActionNode type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | LogicalPosition |
Public property | MotionNode |
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Offset |
Public property | PathObject | Gets the path object that owns this node. (Inherited from IPathObjectNode.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IPathObjectActionNode Interface
VisualComponents.Create3D Namespace


IPathObjectActionNode.LogicalPosition Property

IPathObjectActionNodeLogicalPosition Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double LogicalPosition { get; }
property double LogicalPosition {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IPathObjectActionNode Interface
VisualComponents.Create3D Namespace


IPathObjectActionNode.MotionNode Property

IPathObjectActionNodeMotionNode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPathObjectMotionNode MotionNode { get; }
property IPathObjectMotionNode^ MotionNode {
    IPathObjectMotionNode^ get ();
}

Property Value

Type: IPathObjectMotionNode
See Also

Reference

IPathObjectActionNode Interface
VisualComponents.Create3D Namespace


IPathObjectActionNode.Offset Property

IPathObjectActionNodeOffset Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Offset { get; }
property double Offset {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IPathObjectActionNode Interface
VisualComponents.Create3D Namespace


IPathObjectActionNode Methods

The IPathObjectActionNode type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IPathObjectActionNode Interface
VisualComponents.Create3D Namespace


IPathObjectActionNode Events

The IPathObjectActionNode type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IPathObjectActionNode Interface
VisualComponents.Create3D Namespace


IPathObjectMotionNode Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPathObjectMotionNode : IPathObjectNode,
    IWrapper, IDisposable, IPropertyContainer, IBatchModeObject, INamed
public interface class IPathObjectMotionNode : IPathObjectNode,
    IWrapper, IDisposable, IPropertyContainer, IBatchModeObject, INamed

The IPathObjectMotionNode type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | LogicalPosition |
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodePositionMatrix |
Public property | PathObject | Gets the path object that owns this node. (Inherited from IPathObjectNode.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | PositionMatrix |
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferenceNode |
Public property | WorldPositionMatrix |
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPathObjectMotionNode Properties

The IPathObjectMotionNode type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | LogicalPosition |
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodePositionMatrix |
Public property | PathObject | Gets the path object that owns this node. (Inherited from IPathObjectNode.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | PositionMatrix |
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferenceNode |
Public property | WorldPositionMatrix |
Top
See Also

Reference

IPathObjectMotionNode Interface
VisualComponents.Create3D Namespace


IPathObjectMotionNode.LogicalPosition Property

IPathObjectMotionNodeLogicalPosition Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double LogicalPosition { get; }
property double LogicalPosition {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IPathObjectMotionNode Interface
VisualComponents.Create3D Namespace


IPathObjectMotionNode.NodePositionMatrix Property

IPathObjectMotionNodeNodePositionMatrix Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix NodePositionMatrix { get; }
property Matrix NodePositionMatrix {
    Matrix get ();
}

Property Value

Type: Matrix
See Also

Reference

IPathObjectMotionNode Interface
VisualComponents.Create3D Namespace


IPathObjectMotionNode.PositionMatrix Property

IPathObjectMotionNodePositionMatrix Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix PositionMatrix { get; }
property Matrix PositionMatrix {
    Matrix get ();
}

Property Value

Type: Matrix
See Also

Reference

IPathObjectMotionNode Interface
VisualComponents.Create3D Namespace


IPathObjectMotionNode.ReferenceNode Property

IPathObjectMotionNodeReferenceNode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPathObjectReferenceNode ReferenceNode { get; }
property IPathObjectReferenceNode^ ReferenceNode {
    IPathObjectReferenceNode^ get ();
}

Property Value

Type: IPathObjectReferenceNode
See Also

Reference

IPathObjectMotionNode Interface
VisualComponents.Create3D Namespace


IPathObjectMotionNode.WorldPositionMatrix Property

IPathObjectMotionNodeWorldPositionMatrix Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix WorldPositionMatrix { get; }
property Matrix WorldPositionMatrix {
    Matrix get ();
}

Property Value

Type: Matrix
See Also

Reference

IPathObjectMotionNode Interface
VisualComponents.Create3D Namespace


IPathObjectMotionNode Methods

The IPathObjectMotionNode type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IPathObjectMotionNode Interface
VisualComponents.Create3D Namespace


IPathObjectMotionNode Events

The IPathObjectMotionNode type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IPathObjectMotionNode Interface
VisualComponents.Create3D Namespace


IPathObjectNode Interface

Path object node interface.There are four different types of nodes in the IvcPathObject. These include action nodes, motion nodes, parameter nodes and reference nodes. A reference node is comparable with a base frame in robotics. It may be relative to a simulation node. It may also be relative to the world origin. If it is relative to a simulation node, it follows the simulation node if it moves. Motion nodes and parameter nodes may be relative to reference node. If so, then they move when reference node moves. Action nodes are relative to motion nodes but their physical location in 3D space is defined by the trajectory segment. So its location depends on LogicalDistance property, that in turn is calculated from the LogicalDistance of the motion node it is relative to and Offset value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPathObjectNode : IWrapper,
    IDisposable, IPropertyContainer, IBatchModeObject, INamed
public interface class IPathObjectNode : IWrapper,
    IDisposable, IPropertyContainer, IBatchModeObject, INamed

The IPathObjectNode type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | PathObject | Gets the path object that owns this node.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
Path object has been deprecated in 4.0. This interface should be only used to retrieve the data from layouts saved in the previous versions.
See Also

Reference

VisualComponents.Create3D Namespace


IPathObjectNode Properties

The IPathObjectNode type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | PathObject | Gets the path object that owns this node.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IPathObjectNode Interface
VisualComponents.Create3D Namespace


IPathObjectNode.PathObject Property

IPathObjectNodePathObject Property

Gets the path object that owns this node.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPathObject PathObject { get; }
property IPathObject^ PathObject {
    IPathObject^ get ();
}

Property Value

Type: IPathObject
See Also

Reference

IPathObjectNode Interface
VisualComponents.Create3D Namespace


IPathObjectNode Methods

The IPathObjectNode type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IPathObjectNode Interface
VisualComponents.Create3D Namespace


IPathObjectNode Events

The IPathObjectNode type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IPathObjectNode Interface
VisualComponents.Create3D Namespace


IPathObjectParameterNode Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPathObjectParameterNode : IPathObjectNode,
    IWrapper, IDisposable, IPropertyContainer, IBatchModeObject, INamed
public interface class IPathObjectParameterNode : IPathObjectNode,
    IWrapper, IDisposable, IPropertyContainer, IBatchModeObject, INamed

The IPathObjectParameterNode type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | PathObject | Gets the path object that owns this node. (Inherited from IPathObjectNode.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | PositionMatrix |
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferenceNode |
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPathObjectParameterNode Properties

The IPathObjectParameterNode type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | PathObject | Gets the path object that owns this node. (Inherited from IPathObjectNode.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | PositionMatrix |
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferenceNode |
Top
See Also

Reference

IPathObjectParameterNode Interface
VisualComponents.Create3D Namespace


IPathObjectParameterNode.PositionMatrix Property

IPathObjectParameterNodePositionMatrix Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix PositionMatrix { get; }
property Matrix PositionMatrix {
    Matrix get ();
}

Property Value

Type: Matrix
See Also

Reference

IPathObjectParameterNode Interface
VisualComponents.Create3D Namespace


IPathObjectParameterNode.ReferenceNode Property

IPathObjectParameterNodeReferenceNode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPathObjectReferenceNode ReferenceNode { get; }
property IPathObjectReferenceNode^ ReferenceNode {
    IPathObjectReferenceNode^ get ();
}

Property Value

Type: IPathObjectReferenceNode
See Also

Reference

IPathObjectParameterNode Interface
VisualComponents.Create3D Namespace


IPathObjectParameterNode Methods

The IPathObjectParameterNode type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IPathObjectParameterNode Interface
VisualComponents.Create3D Namespace


IPathObjectParameterNode Events

The IPathObjectParameterNode type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IPathObjectParameterNode Interface
VisualComponents.Create3D Namespace


IPathObjectReferenceNode Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPathObjectReferenceNode : IPathObjectNode,
    IWrapper, IDisposable, IPropertyContainer, IBatchModeObject, INamed
public interface class IPathObjectReferenceNode : IPathObjectNode,
    IWrapper, IDisposable, IPropertyContainer, IBatchModeObject, INamed

The IPathObjectReferenceNode type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node |
Public property | PathObject | Gets the path object that owns this node. (Inherited from IPathObjectNode.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | PositionMatrix |
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPathObjectReferenceNode Properties

The IPathObjectReferenceNode type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node |
Public property | PathObject | Gets the path object that owns this node. (Inherited from IPathObjectNode.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | PositionMatrix |
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IPathObjectReferenceNode Interface
VisualComponents.Create3D Namespace


IPathObjectReferenceNode.Node Property

IPathObjectReferenceNodeNode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode Node { get; }
property ISimNode^ Node {
    ISimNode^ get ();
}

Property Value

Type: ISimNode
See Also

Reference

IPathObjectReferenceNode Interface
VisualComponents.Create3D Namespace


IPathObjectReferenceNode.PositionMatrix Property

IPathObjectReferenceNodePositionMatrix Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix PositionMatrix { get; }
property Matrix PositionMatrix {
    Matrix get ();
}

Property Value

Type: Matrix
See Also

Reference

IPathObjectReferenceNode Interface
VisualComponents.Create3D Namespace


IPathObjectReferenceNode Methods

The IPathObjectReferenceNode type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IPathObjectReferenceNode Interface
VisualComponents.Create3D Namespace


IPathObjectReferenceNode Events

The IPathObjectReferenceNode type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IPathObjectReferenceNode Interface
VisualComponents.Create3D Namespace


IPathObjectSegment Interface

Path object segment interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPathObjectSegment : IWrapper,
    IDisposable, IPropertyContainer, IBatchModeObject
public interface class IPathObjectSegment : IWrapper,
    IDisposable, IPropertyContainer, IBatchModeObject

The IPathObjectSegment type exposes the following members.

Properties
 | Name | Description
Public property | BeginLogicalPosition | Gets the starting location of the trajectory segment.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | EndLogicalPosition | Gets the ending location of the trajectory segment.
Public property | IsValid | (Inherited from IWrapper.)
Public property | PathObject | Gets the path object that owns this segment.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
Path object has been deprecated in 4.0. This interface should be only used to retrieve the data from layouts saved in the previous versions.
See Also

Reference

VisualComponents.Create3D Namespace


IPathObjectSegment Properties

The IPathObjectSegment type exposes the following members.

Properties
 | Name | Description
Public property | BeginLogicalPosition | Gets the starting location of the trajectory segment.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | EndLogicalPosition | Gets the ending location of the trajectory segment.
Public property | IsValid | (Inherited from IWrapper.)
Public property | PathObject | Gets the path object that owns this segment.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IPathObjectSegment Interface
VisualComponents.Create3D Namespace


IPathObjectSegment.BeginLogicalPosition Property

IPathObjectSegmentBeginLogicalPosition Property

Gets the starting location of the trajectory segment.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double BeginLogicalPosition { get; }
property double BeginLogicalPosition {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IPathObjectSegment Interface
VisualComponents.Create3D Namespace


IPathObjectSegment.EndLogicalPosition Property

IPathObjectSegmentEndLogicalPosition Property

Gets the ending location of the trajectory segment.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double EndLogicalPosition { get; }
property double EndLogicalPosition {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IPathObjectSegment Interface
VisualComponents.Create3D Namespace


IPathObjectSegment.PathObject Property

IPathObjectSegmentPathObject Property

Gets the path object that owns this segment.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPathObject PathObject { get; }
property IPathObject^ PathObject {
    IPathObject^ get ();
}

Property Value

Type: IPathObject
See Also

Reference

IPathObjectSegment Interface
VisualComponents.Create3D Namespace


IPathObjectSegment Methods

The IPathObjectSegment type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IPathObjectSegment Interface
VisualComponents.Create3D Namespace


IPathObjectSegment Events

The IPathObjectSegment type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IPathObjectSegment Interface
VisualComponents.Create3D Namespace


IPathStatement Interface

Statement for moving a robot along a path. Similar to ILayoutSchemaPropertyList class, but requires a robot. Note that internally position frames are stored differently from [!:IPositionStatement.Positions]. Use SchemaPositions instead of [!:IPathStatement.Positions].

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPathStatement : IPositionStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement>, ICloneable,
    IInterpolatable, IPositionFrameContainer
public interface class IPathStatement : IPositionStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement^>, ICloneable,
    IInterpolatable, IPositionFrameContainer

The IPathStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | Base | Gets or sets the robot base for which the positions in this IPositionStatement are attached to. (Inherited from IPositionStatement.)
Public property | BoundBox |
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | Description |
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | ExternalJointCount |
Public property | ExternalTcp | Gets or sets external TCP mode. (Inherited from IPositionStatement.)
Public property | FirstFrame | First position frame.
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible |
Public property | LastFrame | Last position frame.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Positions | Gets all the positions in this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferenceFrames |
Public property | ReferenceFramesCount |
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | SchemaDatabase | Reference to rSchemaDatabase.
Public property | SchemaItemCount |
Public property | SchemaPositions | Positions frames of this statement. This list should be used instead of [!:IPathStatement.Positions]. All items are of type ISchemaPositionFrame.
Public property | SchemaProperties | Definition of schema.
Public property | ShowLabels |
Public property | ShowLine |
Public property | ShowReferenceFrames |
Public property | Tool | Gets or sets the robot tool (Inherited from IPositionStatement.)
Public property | UseNativeExecution |
Top
Methods
 | Name | Description
Public method | AddPositionFromProgram | Adds an existing IPositionFrame from IProgram to this IPositionStatement. (Inherited from IPositionStatement.)
Public method | AddSchemaProperties | Setups the schema and it's properties.
Public method | BeginBatchUpdate |
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ClearPositions |
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | ClonePositions |
Public method | CreatePosition | Creates a new IPositionFrame instance and adds it to this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeletePosition | Deletes the given IPositionFrame from this IPositionFrameContainer and deletes it (see remarks). (Inherited from IPositionFrameContainer.)
Public method | DeletePositions |
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatchUpdate |
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | ExecuteImmediatePosition | Moves the robot to the given position. See also: IStatement.ExecuteImmediate(). (Inherited from IPositionStatement.)
Public method | ExtendSelection |
Public method | GetFrame | Creates an ISchemaPositionFrame instance for a specific position index.
Public method | GetFrames | Creates an ISchemaPositionFrame instance that combines multiple positions. See ICombinableT.
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetNextFrame | Internal helper method for iterating ISchemaPositionFrame frames.
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetSchemaValue(Int32, Int32) | See also GetSchemaValue(String).
Public method | GetSchemaValue(Int32, String) | See also GetSchemaValue(String).
Public method | GetSchemaValue(IEnumerableIPositionFrame, Int32) | See also GetSchemaValue(String).
Public method | GetSchemaValue(IEnumerableIPositionFrame, String) | See also GetSchemaValue(String).
Public method | HighlightAll | Highlights all the positions in this IPositionStatement. (Inherited from IPositionStatement.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | NotifyDatabaseChange |
Public method | ReadIn(IPositionFrame) | Reads in the current state of from the associated instance of IServoController. (Inherited from IPositionStatement.)
Public method | ReadIn(ISchemaPositionFrame) | Updates joint and position values in frame.
Public method | RemoveSchemaProperties(IEnumerableString) | Remove properties from SchemaProperties, if found
Public method | RemoveSchemaProperties(IEnumerableIProperty) | Remove properties from SchemaProperties, if found
Public method | SetExternalTcp | Gets or sets external TCP mode by keeping relative frame positions. (Inherited from IPositionStatement.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetSchemaValue(Int32, Int32, Object) | See also SetSchemaValue(String, Object).
Public method | SetSchemaValue(Int32, String, Object) | See also SetSchemaValue(String, Object).
Public method | SetSchemaValues(Int32, IEnumerableInt32, IEnumerableObject) | See also SetSchemaValue(String, Object).
Public method | SetSchemaValues(IEnumerableIPositionFrame, IEnumerableInt32, IEnumerableObject) | See also SetSchemaValue(String, Object).
Public method | SetSchemaValues(IEnumerableIPositionFrame, String, Object) | See also SetSchemaValue(String, Object).
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | DatabaseChanged |
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PositionAdded | Occurs when a new instance of IPositionFrame has been added to this instance of IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public event | PositionRemoving | Occurs when an instance of IPositionFrame is being removed from this instance of IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public event | PositionTransformationChanged | Occurs when transformation of an instance of IPositionFrame in this instance of IPositionStatement changes. (Inherited from IPositionStatement.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Examples
Creating a path statement:
Copy
var robot = IoC.Get<ITeachContext>().ActiveRobot;
var console = IoC.Get<IConsoleViewModel>();
var path = robot.Executor.Program.MainRoutine.AddStatement<SchemaPathStatement>();
var indices = path.AddSchemaProperties
(
    new Tuple<string, Type, object>[]
    {
        new Tuple<string, Type, object>("Position", typeof(Matrix), new Matrix()),
        new Tuple<string, Type, object>("FrameVisibility", typeof(bool), false),
        new Tuple<string, Type, object>("LineVisibility", typeof(bool), true),
        new Tuple<string, Type, object>("LineColor", typeof(Vector3), new Vector3()),
        new Tuple<string, Type, object>("Name", typeof(string), "")
    }
);

path.SchemaProperties.GetProperty("FrameVisibility").IsVisible = true;
path.SchemaProperties.GetProperty("LineVisibility").IsVisible = true;
path.SchemaProperties.GetProperty("LineColor").IsVisible = true;
path.SchemaProperties.GetProperty("Name").IsVisible = true;
path.GetProperty("PositionField").Value = prop_indices[0];
path.GetProperty("FrameVisibleField").Value = prop_indices[1];
path.GetProperty("LineVisibleField").Value = prop_indices[2];
path.GetProperty("LineColorField").Value = prop_indices[3];

path.BeginBatchUpdate(10);

var allFrames = path.SchemaPositions.Cast<ISchemaPositionFrame>();
foreach (var frame in allFrames)
{
    var matrix = new Matrix();
    matrix.SetP(new Vector3(frame.Index * 50, 0, 0));
    var values = new object[]{ matrix, true, true, new Vector3(0,1,1), "Frame_" + ((ISchemaPositionFrame)frame).Index };
    path.SetSchemaValues(frame.Index, indices, values);
}

path.EndBatchUpdate(frame_count);
console.AppendMessage("Created path statement: " + path.Name);
IoC.Get<ISelectionManager>().SetSelection(path, false);
IoC.Get<IRenderService>().RequestRender();
Examples
Offsetting path's positions:
Copy
var allFrames = path.SchemaPositions.Cast<ISchemaPositionFrame>();
foreach (var frame in allFrames)
{
    var matrix = frame.TransformationInWorld;
    var pos = matrix.GetP();
    pos.Z += 20;
    matrix.SetP(pos);
    frame.TransformationInWorld = matrix;
}
Examples
Offsetting selected positions:
Copy
var selectedFrames = IoC.Get<ISelectionManager>().GetSelection<IPositionFrame>().OfType<ISchemaPositionFrame>();
var allFrames = selectedFrames.SelectMany(item => item.CombinedItems).Cast<ISchemaPositionFrame>();
foreach (var frame in allFrames)
{
    var matrix = frame.TransformationInWorld;
    var pos = matrix.GetP();
    pos.Z += 20;
    matrix.SetP(pos);
    frame.TransformationInWorld = matrix;
}
Examples
Listing position properties:
Copy
var path = IoC.Get<ISelectionManager>().GetSelection<IStatement>().OfType<IPathStatement>().FirstOrDefault();
var console = IoC.Get<IConsoleViewModel>();
var props = "";
foreach (var prop in path.SchemaProperties.Properties)
{
    props += prop.Name + ", ";
}
console.AppendMessage("Schema properties: " + props);
Examples
Reading/writing position properties:
Copy
var path = IoC.Get<ISelectionManager>().GetSelection<IStatement>().OfType<IPathStatement>().FirstOrDefault();
var allFrames = path.SchemaPositions.Cast<ISchemaPositionFrame>();
foreach (var frame in allFrames)
{
    var framePath = (IPathStatement)frame.Statement;
    var frameIndex = frame.Index;
    var positionFieldIndex = (int)path.GetProperty("PositionField").Value;
    var position1 = (Matrix)frame.GetSchemaValue("Position");
    var position2 = (Matrix)frame.GetSchemaValue(positionFieldIndex);
    frame.SetSchemaValue("Position", position1);
    frame.SetSchemaValue(positionFieldIndex, position2);
}
See Also

Reference

VisualComponents.Create3D Namespace


IPathStatement Properties

The IPathStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | Base | Gets or sets the robot base for which the positions in this IPositionStatement are attached to. (Inherited from IPositionStatement.)
Public property | BoundBox |
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | Description |
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | ExternalJointCount |
Public property | ExternalTcp | Gets or sets external TCP mode. (Inherited from IPositionStatement.)
Public property | FirstFrame | First position frame.
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible |
Public property | LastFrame | Last position frame.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Positions | Gets all the positions in this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferenceFrames |
Public property | ReferenceFramesCount |
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | SchemaDatabase | Reference to rSchemaDatabase.
Public property | SchemaItemCount |
Public property | SchemaPositions | Positions frames of this statement. This list should be used instead of [!:IPathStatement.Positions]. All items are of type ISchemaPositionFrame.
Public property | SchemaProperties | Definition of schema.
Public property | ShowLabels |
Public property | ShowLine |
Public property | ShowReferenceFrames |
Public property | Tool | Gets or sets the robot tool (Inherited from IPositionStatement.)
Public property | UseNativeExecution |
Top
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.BoundBox Property

IPathStatementBoundBox Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IBoundBox BoundBox { get; }
property IBoundBox^ BoundBox {
    IBoundBox^ get ();
}

Property Value

Type: IBoundBox
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.Description Property

IPathStatementDescription Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Description { get; set; }
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.ExternalJointCount Property

IPathStatementExternalJointCount Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int ExternalJointCount { get; }
property int ExternalJointCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.FirstFrame Property

IPathStatementFirstFrame Property

First position frame.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPositionFrame FirstFrame { get; }
property IPositionFrame^ FirstFrame {
    IPositionFrame^ get ();
}

Property Value

Type: IPositionFrame
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.IsVisible Property

IPathStatementIsVisible Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsVisible { get; set; }
property bool IsVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.LastFrame Property

IPathStatementLastFrame Property

Last position frame.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPositionFrame LastFrame { get; }
property IPositionFrame^ LastFrame {
    IPositionFrame^ get ();
}

Property Value

Type: IPositionFrame
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.ReferenceFrames Property

IPathStatementReferenceFrames Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IPositionFrame> ReferenceFrames { get; }
property ReadOnlyCollection<IPositionFrame^>^ ReferenceFrames {
    ReadOnlyCollection<IPositionFrame^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIPositionFrame
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.ReferenceFramesCount Property

IPathStatementReferenceFramesCount Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int ReferenceFramesCount { get; }
property int ReferenceFramesCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.SchemaDatabase Property

IPathStatementSchemaDatabase Property

Reference to rSchemaDatabase.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IntPtr SchemaDatabase { get; }
property IntPtr SchemaDatabase {
    IntPtr get ();
}

Property Value

Type: IntPtr
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.SchemaItemCount Property

IPathStatementSchemaItemCount Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int SchemaItemCount { get; }
property int SchemaItemCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.SchemaPositions Property

IPathStatementSchemaPositions Property

Positions frames of this statement. This list should be used instead of [!:IPathStatement.Positions]. All items are of type ISchemaPositionFrame.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<IPositionFrame> SchemaPositions { get; }
property IEnumerable<IPositionFrame^>^ SchemaPositions {
    IEnumerable<IPositionFrame^>^ get ();
}

Property Value

Type: IEnumerableIPositionFrame
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.SchemaProperties Property

IPathStatementSchemaProperties Property

Definition of schema.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPropertyContainer SchemaProperties { get; }
property IPropertyContainer^ SchemaProperties {
    IPropertyContainer^ get ();
}

Property Value

Type: IPropertyContainer
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.ShowLabels Property

IPathStatementShowLabels Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ShowLabels { get; set; }
property bool ShowLabels {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.ShowLine Property

IPathStatementShowLine Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ShowLine { get; set; }
property bool ShowLine {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.ShowReferenceFrames Property

IPathStatementShowReferenceFrames Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ShowReferenceFrames { get; set; }
property bool ShowReferenceFrames {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.UseNativeExecution Property

IPathStatementUseNativeExecution Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool UseNativeExecution { get; set; }
property bool UseNativeExecution {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement Methods

The IPathStatement type exposes the following members.

Methods
 | Name | Description
Public method | AddPositionFromProgram | Adds an existing IPositionFrame from IProgram to this IPositionStatement. (Inherited from IPositionStatement.)
Public method | AddSchemaProperties | Setups the schema and it's properties.
Public method | BeginBatchUpdate |
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ClearPositions |
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | ClonePositions |
Public method | CreatePosition | Creates a new IPositionFrame instance and adds it to this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeletePosition | Deletes the given IPositionFrame from this IPositionFrameContainer and deletes it (see remarks). (Inherited from IPositionFrameContainer.)
Public method | DeletePositions |
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatchUpdate |
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | ExecuteImmediatePosition | Moves the robot to the given position. See also: IStatement.ExecuteImmediate(). (Inherited from IPositionStatement.)
Public method | ExtendSelection |
Public method | GetFrame | Creates an ISchemaPositionFrame instance for a specific position index.
Public method | GetFrames | Creates an ISchemaPositionFrame instance that combines multiple positions. See ICombinableT.
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetNextFrame | Internal helper method for iterating ISchemaPositionFrame frames.
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetSchemaValue(Int32, Int32) | See also GetSchemaValue(String).
Public method | GetSchemaValue(Int32, String) | See also GetSchemaValue(String).
Public method | GetSchemaValue(IEnumerableIPositionFrame, Int32) | See also GetSchemaValue(String).
Public method | GetSchemaValue(IEnumerableIPositionFrame, String) | See also GetSchemaValue(String).
Public method | HighlightAll | Highlights all the positions in this IPositionStatement. (Inherited from IPositionStatement.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | NotifyDatabaseChange |
Public method | ReadIn(IPositionFrame) | Reads in the current state of from the associated instance of IServoController. (Inherited from IPositionStatement.)
Public method | ReadIn(ISchemaPositionFrame) | Updates joint and position values in frame.
Public method | RemoveSchemaProperties(IEnumerableString) | Remove properties from SchemaProperties, if found
Public method | RemoveSchemaProperties(IEnumerableIProperty) | Remove properties from SchemaProperties, if found
Public method | SetExternalTcp | Gets or sets external TCP mode by keeping relative frame positions. (Inherited from IPositionStatement.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetSchemaValue(Int32, Int32, Object) | See also SetSchemaValue(String, Object).
Public method | SetSchemaValue(Int32, String, Object) | See also SetSchemaValue(String, Object).
Public method | SetSchemaValues(Int32, IEnumerableInt32, IEnumerableObject) | See also SetSchemaValue(String, Object).
Public method | SetSchemaValues(IEnumerableIPositionFrame, IEnumerableInt32, IEnumerableObject) | See also SetSchemaValue(String, Object).
Public method | SetSchemaValues(IEnumerableIPositionFrame, String, Object) | See also SetSchemaValue(String, Object).
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.AddSchemaProperties Method

IPathStatementAddSchemaProperties Method

Setups the schema and it's properties.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int[] AddSchemaProperties(
    IEnumerable<Tuple<string, Type, Object>> infos
)
array<int>^ AddSchemaProperties(
    IEnumerable<Tuple<String^, Type^, Object^>^>^ infos
)

Parameters

infos
Type: System.Collections.GenericIEnumerableTupleString, Type, Object
enumerable of tuples with values for each property: name (string), type (Type), value (object)

Return Value

Type: Int32
array of indices in the SchemaProperties container for added properties
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.BeginBatchUpdate Method

IPathStatementBeginBatchUpdate Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void BeginBatchUpdate(
    int size
)
void BeginBatchUpdate(
    int size
)

Parameters

size
Type: SystemInt32
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.ClearPositions Method

IPathStatementClearPositions Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ClearPositions()
void ClearPositions()

Implements

IPositionFrameContainerClearPositions
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.ClonePositions Method

IPathStatementClonePositions Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ClonePositions(
    int from,
    int count,
    int to
)
void ClonePositions(
    int from,
    int count,
    int to
)

Parameters

from
Type: SystemInt32
count
Type: SystemInt32
to
Type: SystemInt32
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.DeletePositions Method

IPathStatementDeletePositions Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeletePositions(
    int from,
    int count
)
void DeletePositions(
    int from,
    int count
)

Parameters

from
Type: SystemInt32
count
Type: SystemInt32
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.EndBatchUpdate Method

IPathStatementEndBatchUpdate Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void EndBatchUpdate(
    int size
)
void EndBatchUpdate(
    int size
)

Parameters

size
Type: SystemInt32
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.ExtendSelection Method

IPathStatementExtendSelection Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IPositionFrame> ExtendSelection(
    IPositionFrame pickedFrame,
    IPositionFrame[] previousSelection,
    bool appendOrRemove,
    bool appendOrRemoveRange
)
ReadOnlyCollection<IPositionFrame^>^ ExtendSelection(
    IPositionFrame^ pickedFrame,
    array<IPositionFrame^>^ previousSelection,
    bool appendOrRemove,
    bool appendOrRemoveRange
)

Parameters

pickedFrame
Type: VisualComponents.Create3DIPositionFrame
previousSelection
Type: VisualComponents.Create3DIPositionFrame
appendOrRemove
Type: SystemBoolean
appendOrRemoveRange
Type: SystemBoolean

Return Value

Type: ReadOnlyCollectionIPositionFrame

[Missing <returns> documentation for "M:VisualComponents.Create3D.IPathStatement.ExtendSelection(VisualComponents.Create3D.IPositionFrame,VisualComponents.Create3D.IPositionFrame[],System.Boolean,System.Boolean)"]

See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.GetFrame Method

IPathStatementGetFrame Method

Creates an ISchemaPositionFrame instance for a specific position index.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void GetFrame(
    int index,
    ref IPositionFrame frame
)
void GetFrame(
    int index,
    IPositionFrame^% frame
)

Parameters

index
Type: SystemInt32
frame
Type: VisualComponents.Create3DIPositionFrame
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.GetFrames Method

IPathStatementGetFrames Method

Creates an ISchemaPositionFrame instance that combines multiple positions. See ICombinableT.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPositionFrame GetFrames(
    int[] indexes
)
IPositionFrame^ GetFrames(
    array<int>^ indexes
)

Parameters

indexes
Type: SystemInt32

Return Value

Type: IPositionFrame

[Missing <returns> documentation for "M:VisualComponents.Create3D.IPathStatement.GetFrames(System.Int32[])"]

See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.GetNextFrame Method

IPathStatementGetNextFrame Method

Internal helper method for iterating ISchemaPositionFrame frames.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool GetNextFrame(
    IPositionFrame frameSet,
    bool onlyReferences,
    ref IPositionFrame frame
)
bool GetNextFrame(
    IPositionFrame^ frameSet,
    bool onlyReferences,
    IPositionFrame^% frame
)

Parameters

frameSet
Type: VisualComponents.Create3DIPositionFrame
onlyReferences
Type: SystemBoolean
frame
Type: VisualComponents.Create3DIPositionFrame

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IPathStatement.GetNextFrame(VisualComponents.Create3D.IPositionFrame,System.Boolean,VisualComponents.Create3D.IPositionFrame@)"]

See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.GetSchemaValue Method

IPathStatementGetSchemaValue Method

Overload List
 | Name | Description
Public method | GetSchemaValue(Int32, Int32) | See also GetSchemaValue(String).
Public method | GetSchemaValue(Int32, String) | See also GetSchemaValue(String).
Public method | GetSchemaValue(IEnumerableIPositionFrame, Int32) | See also GetSchemaValue(String).
Public method | GetSchemaValue(IEnumerableIPositionFrame, String) | See also GetSchemaValue(String).
Top
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.GetSchemaValue Method (Int32, Int32)

IPathStatementGetSchemaValue Method (Int32, Int32)

See also GetSchemaValue(String).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object GetSchemaValue(
    int positionIndex,
    int fieldIndex
)
Object^ GetSchemaValue(
    int positionIndex,
    int fieldIndex
)

Parameters

positionIndex
Type: SystemInt32
fieldIndex
Type: SystemInt32

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.Create3D.IPathStatement.GetSchemaValue(System.Int32,System.Int32)"]

See Also

Reference

IPathStatement Interface
GetSchemaValue Overload
VisualComponents.Create3D Namespace


IPathStatement.GetSchemaValue Method (Int32, String)

IPathStatementGetSchemaValue Method (Int32, String)

See also GetSchemaValue(String).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object GetSchemaValue(
    int positionIndex,
    string fieldName
)
Object^ GetSchemaValue(
    int positionIndex,
    String^ fieldName
)

Parameters

positionIndex
Type: SystemInt32
fieldName
Type: SystemString

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.Create3D.IPathStatement.GetSchemaValue(System.Int32,System.String)"]

See Also

Reference

IPathStatement Interface
GetSchemaValue Overload
VisualComponents.Create3D Namespace


IPathStatement.GetSchemaValue Method (IEnumerable(IPositionFrame), Int32)

IPathStatementGetSchemaValue Method (IEnumerableIPositionFrame, Int32)

See also GetSchemaValue(String).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object GetSchemaValue(
    IEnumerable<IPositionFrame> frames,
    int fieldIndex
)
Object^ GetSchemaValue(
    IEnumerable<IPositionFrame^>^ frames,
    int fieldIndex
)

Parameters

frames
Type: System.Collections.GenericIEnumerableIPositionFrame
fieldIndex
Type: SystemInt32

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.Create3D.IPathStatement.GetSchemaValue(System.Collections.Generic.IEnumerable{VisualComponents.Create3D.IPositionFrame},System.Int32)"]

See Also

Reference

IPathStatement Interface
GetSchemaValue Overload
VisualComponents.Create3D Namespace


IPathStatement.GetSchemaValue Method (IEnumerable(IPositionFrame), String)

IPathStatementGetSchemaValue Method (IEnumerableIPositionFrame, String)

See also GetSchemaValue(String).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object GetSchemaValue(
    IEnumerable<IPositionFrame> frames,
    string fieldName
)
Object^ GetSchemaValue(
    IEnumerable<IPositionFrame^>^ frames,
    String^ fieldName
)

Parameters

frames
Type: System.Collections.GenericIEnumerableIPositionFrame
fieldName
Type: SystemString

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.Create3D.IPathStatement.GetSchemaValue(System.Collections.Generic.IEnumerable{VisualComponents.Create3D.IPositionFrame},System.String)"]

See Also

Reference

IPathStatement Interface
GetSchemaValue Overload
VisualComponents.Create3D Namespace


IPathStatement.NotifyDatabaseChange Method

IPathStatementNotifyDatabaseChange Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void NotifyDatabaseChange(
    int dirtyIndex
)
void NotifyDatabaseChange(
    int dirtyIndex
)

Parameters

dirtyIndex
Type: SystemInt32
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.ReadIn Method

IPathStatementReadIn Method

Overload List
 | Name | Description
Public method | ReadIn(IPositionFrame) | Reads in the current state of from the associated instance of IServoController. (Inherited from IPositionStatement.)
Public method | ReadIn(ISchemaPositionFrame) | Updates joint and position values in frame.
Top
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.ReadIn Method (ISchemaPositionFrame)

IPathStatementReadIn Method (ISchemaPositionFrame)

Updates joint and position values in frame.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ReadIn(
    ISchemaPositionFrame targetFrame
)
void ReadIn(
    ISchemaPositionFrame^ targetFrame
)

Parameters

targetFrame
Type: VisualComponents.Create3DISchemaPositionFrame
See Also

Reference

IPathStatement Interface
ReadIn Overload
VisualComponents.Create3D Namespace


IPathStatement.RemoveSchemaProperties Method

IPathStatementRemoveSchemaProperties Method

Overload List
 | Name | Description
Public method | RemoveSchemaProperties(IEnumerableString) | Remove properties from SchemaProperties, if found
Public method | RemoveSchemaProperties(IEnumerableIProperty) | Remove properties from SchemaProperties, if found
Top
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.RemoveSchemaProperties Method (IEnumerable(String))

IPathStatementRemoveSchemaProperties Method (IEnumerableString)

Remove properties from SchemaProperties, if found

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RemoveSchemaProperties(
    IEnumerable<string> names
)
void RemoveSchemaProperties(
    IEnumerable<String^>^ names
)

Parameters

names
Type: System.Collections.GenericIEnumerableString
enumerable of property names for properties to remove
See Also

Reference

IPathStatement Interface
RemoveSchemaProperties Overload
VisualComponents.Create3D Namespace


IPathStatement.RemoveSchemaProperties Method (IEnumerable(IProperty))

IPathStatementRemoveSchemaProperties Method (IEnumerableIProperty)

Remove properties from SchemaProperties, if found

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RemoveSchemaProperties(
    IEnumerable<IProperty> properties
)
void RemoveSchemaProperties(
    IEnumerable<IProperty^>^ properties
)

Parameters

properties
Type: System.Collections.GenericIEnumerableIProperty
enumerable of properties to remove
See Also

Reference

IPathStatement Interface
RemoveSchemaProperties Overload
VisualComponents.Create3D Namespace


IPathStatement.SetSchemaValue Method

IPathStatementSetSchemaValue Method

Overload List
 | Name | Description
Public method | SetSchemaValue(Int32, Int32, Object) | See also SetSchemaValue(String, Object).
Public method | SetSchemaValue(Int32, String, Object) | See also SetSchemaValue(String, Object).
Top
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.SetSchemaValue Method (Int32, Int32, Object)

IPathStatementSetSchemaValue Method (Int32, Int32, Object)

See also SetSchemaValue(String, Object).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetSchemaValue(
    int positionIndex,
    int fieldIndex,
    Object value
)
void SetSchemaValue(
    int positionIndex,
    int fieldIndex,
    Object^ value
)

Parameters

positionIndex
Type: SystemInt32
fieldIndex
Type: SystemInt32
value
Type: SystemObject
See Also

Reference

IPathStatement Interface
SetSchemaValue Overload
VisualComponents.Create3D Namespace


IPathStatement.SetSchemaValue Method (Int32, String, Object)

IPathStatementSetSchemaValue Method (Int32, String, Object)

See also SetSchemaValue(String, Object).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetSchemaValue(
    int positionIndex,
    string fieldName,
    Object value
)
void SetSchemaValue(
    int positionIndex,
    String^ fieldName,
    Object^ value
)

Parameters

positionIndex
Type: SystemInt32
fieldName
Type: SystemString
value
Type: SystemObject
See Also

Reference

IPathStatement Interface
SetSchemaValue Overload
VisualComponents.Create3D Namespace


IPathStatement.SetSchemaValues Method

IPathStatementSetSchemaValues Method

Overload List
 | Name | Description
Public method | SetSchemaValues(Int32, IEnumerableInt32, IEnumerableObject) | See also SetSchemaValue(String, Object).
Public method | SetSchemaValues(IEnumerableIPositionFrame, IEnumerableInt32, IEnumerableObject) | See also SetSchemaValue(String, Object).
Public method | SetSchemaValues(IEnumerableIPositionFrame, String, Object) | See also SetSchemaValue(String, Object).
Top
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.SetSchemaValues Method (Int32, IEnumerable(Int32), IEnumerable(Object))

IPathStatementSetSchemaValues Method (Int32, IEnumerableInt32, IEnumerableObject)

See also SetSchemaValue(String, Object).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetSchemaValues(
    int positionIndex,
    IEnumerable<int> fieldIndexes,
    IEnumerable<Object> values
)
void SetSchemaValues(
    int positionIndex,
    IEnumerable<int>^ fieldIndexes,
    IEnumerable<Object^>^ values
)

Parameters

positionIndex
Type: SystemInt32
fieldIndexes
Type: System.Collections.GenericIEnumerableInt32
values
Type: System.Collections.GenericIEnumerableObject
See Also

Reference

IPathStatement Interface
SetSchemaValues Overload
VisualComponents.Create3D Namespace


IPathStatement.SetSchemaValues Method (IEnumerable(IPositionFrame), IEnumerable(Int32), IEnumerable(Object))

IPathStatementSetSchemaValues Method (IEnumerableIPositionFrame, IEnumerableInt32, IEnumerableObject)

See also SetSchemaValue(String, Object).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetSchemaValues(
    IEnumerable<IPositionFrame> frames,
    IEnumerable<int> fieldIndexes,
    IEnumerable<Object> values
)
void SetSchemaValues(
    IEnumerable<IPositionFrame^>^ frames,
    IEnumerable<int>^ fieldIndexes,
    IEnumerable<Object^>^ values
)

Parameters

frames
Type: System.Collections.GenericIEnumerableIPositionFrame
fieldIndexes
Type: System.Collections.GenericIEnumerableInt32
values
Type: System.Collections.GenericIEnumerableObject
See Also

Reference

IPathStatement Interface
SetSchemaValues Overload
VisualComponents.Create3D Namespace


IPathStatement.SetSchemaValues Method (IEnumerable(IPositionFrame), String, Object)

IPathStatementSetSchemaValues Method (IEnumerableIPositionFrame, String, Object)

See also SetSchemaValue(String, Object).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetSchemaValues(
    IEnumerable<IPositionFrame> frames,
    string fieldName,
    Object value
)
void SetSchemaValues(
    IEnumerable<IPositionFrame^>^ frames,
    String^ fieldName,
    Object^ value
)

Parameters

frames
Type: System.Collections.GenericIEnumerableIPositionFrame
fieldName
Type: SystemString
value
Type: SystemObject
See Also

Reference

IPathStatement Interface
SetSchemaValues Overload
VisualComponents.Create3D Namespace


IPathStatement Events

The IPathStatement type exposes the following members.

Events
 | Name | Description
Public event | DatabaseChanged |
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PositionAdded | Occurs when a new instance of IPositionFrame has been added to this instance of IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public event | PositionRemoving | Occurs when an instance of IPositionFrame is being removed from this instance of IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public event | PositionTransformationChanged | Occurs when transformation of an instance of IPositionFrame in this instance of IPositionStatement changes. (Inherited from IPositionStatement.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPathStatement.DatabaseChanged Event

IPathStatementDatabaseChanged Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<DatabaseChangedEventArgs> DatabaseChanged
 event EventHandler<DatabaseChangedEventArgs^>^ DatabaseChanged {
    void add (EventHandler<DatabaseChangedEventArgs^>^ value);
    void remove (EventHandler<DatabaseChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerDatabaseChangedEventArgs
See Also

Reference

IPathStatement Interface
VisualComponents.Create3D Namespace


IPdfRecorder Interface

Service to create pdf from simulation recording

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPdfRecorder
public interface class IPdfRecorder

The IPdfRecorder type exposes the following members.

Properties
 | Name | Description
Public property | ShowPdf | Show or not Pdf after creation
Top
Methods
 | Name | Description
Public method | StartRecording | Starts the simulation recording to Pdf.
Public method | StopRecording | Stops pdf creation
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPdfRecorder Properties

The IPdfRecorder type exposes the following members.

Properties
 | Name | Description
Public property | ShowPdf | Show or not Pdf after creation
Top
See Also

Reference

IPdfRecorder Interface
VisualComponents.Create3D Namespace


IPdfRecorder.ShowPdf Property

IPdfRecorderShowPdf Property

Show or not Pdf after creation

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ShowPdf { get; set; }
property bool ShowPdf {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPdfRecorder Interface
VisualComponents.Create3D Namespace


IPdfRecorder Methods

The IPdfRecorder type exposes the following members.

Methods
 | Name | Description
Public method | StartRecording | Starts the simulation recording to Pdf.
Public method | StopRecording | Stops pdf creation
Top
See Also

Reference

IPdfRecorder Interface
VisualComponents.Create3D Namespace


IPdfRecorder.StartRecording Method

IPdfRecorderStartRecording Method

Starts the simulation recording to Pdf.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool StartRecording(
    string file,
    int frameRate,
    Uri templatePath
)
bool StartRecording(
    String^ file,
    int frameRate,
    Uri^ templatePath
)

Parameters

file
Type: SystemString
path to save the pdf
frameRate
Type: SystemInt32
recording frame rate
templatePath
Type: SystemUri
path of the pdf template

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IPdfRecorder.StartRecording(System.String,System.Int32,System.Uri)"]

See Also

Reference

IPdfRecorder Interface
VisualComponents.Create3D Namespace


IPdfRecorder.StopRecording Method

IPdfRecorderStopRecording Method

Stops pdf creation

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StopRecording(
    bool save
)
void StopRecording(
    bool save
)

Parameters

save
Type: SystemBoolean
save the recording
See Also

Reference

IPdfRecorder Interface
VisualComponents.Create3D Namespace


IPdfRecordExporter Interface

Represents a UI entry for the IPDFReportBuilder which is coupled with a specific PDF template file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPdfRecordExporter : IRecordExporter
public interface class IPdfRecordExporter : IRecordExporter

The IPdfRecordExporter type exposes the following members.

Properties
 | Name | Description
Public property | CustomProperties | Custom properties of the template
Public property | GetOutputPathFromUser |
Public property | Header | Header information (Inherited from IRecordExporter.)
Public property | OutputPath | PDF output path
Public property | RecordingType | Type information (Inherited from IRecordExporter.)
Public property | TemplatePath | PDF template path
Top
Methods
 | Name | Description
Public method | Export | Constructor
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPdfRecordExporter Properties

The IPdfRecordExporter type exposes the following members.

Properties
 | Name | Description
Public property | CustomProperties | Custom properties of the template
Public property | GetOutputPathFromUser |
Public property | Header | Header information (Inherited from IRecordExporter.)
Public property | OutputPath | PDF output path
Public property | RecordingType | Type information (Inherited from IRecordExporter.)
Public property | TemplatePath | PDF template path
Top
See Also

Reference

IPdfRecordExporter Interface
VisualComponents.Create3D Namespace


IPdfRecordExporter.CustomProperties Property

IPdfRecordExporterCustomProperties Property

Custom properties of the template

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ObservableCollection<IProperty> CustomProperties { get; }
property ObservableCollection<IProperty^>^ CustomProperties {
    ObservableCollection<IProperty^>^ get ();
}

Property Value

Type: ObservableCollectionIProperty
See Also

Reference

IPdfRecordExporter Interface
VisualComponents.Create3D Namespace


IPdfRecordExporter.GetOutputPathFromUser Property

IPdfRecordExporterGetOutputPathFromUser Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool GetOutputPathFromUser { get; }
property bool GetOutputPathFromUser {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IPdfRecordExporter Interface
VisualComponents.Create3D Namespace


IPdfRecordExporter.OutputPath Property

IPdfRecordExporterOutputPath Property

PDF output path

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Uri OutputPath { get; set; }
property Uri^ OutputPath {
    Uri^ get ();
    void set (Uri^ value);
}

Property Value

Type: Uri
See Also

Reference

IPdfRecordExporter Interface
VisualComponents.Create3D Namespace


IPdfRecordExporter.TemplatePath Property

IPdfRecordExporterTemplatePath Property

PDF template path

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Uri TemplatePath { get; }
property Uri^ TemplatePath {
    Uri^ get ();
}

Property Value

Type: Uri
See Also

Reference

IPdfRecordExporter Interface
VisualComponents.Create3D Namespace


IPdfRecordExporter Methods

The IPdfRecordExporter type exposes the following members.

Methods
 | Name | Description
Public method | Export | Constructor
Top
See Also

Reference

IPdfRecordExporter Interface
VisualComponents.Create3D Namespace


IPdfRecordExporter.Export Method

IPdfRecordExporterExport Method

Constructor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool Export(
    Uri recordPath,
    string layoutName,
    Point3D layoutCenter,
    double layoutFillDistance,
    IEnumerable<IComponentPdfInfo> componentInfo
)
bool Export(
    Uri^ recordPath,
    String^ layoutName,
    Point3D layoutCenter,
    double layoutFillDistance,
    IEnumerable<IComponentPdfInfo^>^ componentInfo
)

Parameters

recordPath
Type: SystemUri
layoutName
Type: SystemString
layoutCenter
Type: System.Windows.Media.Media3DPoint3D
layoutFillDistance
Type: SystemDouble
componentInfo
Type: System.Collections.GenericIEnumerableIComponentPdfInfo

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IPdfRecordExporter.Export(System.Uri,System.String,System.Windows.Media.Media3D.Point3D,System.Double,System.Collections.Generic.IEnumerable{VisualComponents.Create3D.IComponentPdfInfo})"]

See Also

Reference

IPdfRecordExporter Interface
VisualComponents.Create3D Namespace


IPdfReportBuilder Interface

A component which can create a PDF report from a U3D model.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPdfReportBuilder
public interface class IPdfReportBuilder

The IPdfReportBuilder type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor | PDF background Color
Public property | CustomProperties | Custom properties
Public property | GetOutputPathFromUser | Specifies if output should come from user
Public property | HeaderIconPath | PDF header icon path
Public property | Id | PDF Prefix ID
Public property | OutputPath | Output path
Top
Methods
 | Name | Description
Public method | CreateReport | Constructor
Public method | GetDisplayName | Gets the displayed name (header name) of specified pdf template
Public method | SetBackgroundColor | Set background color of the PDF file.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPdfReportBuilder Properties

The IPdfReportBuilder type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor | PDF background Color
Public property | CustomProperties | Custom properties
Public property | GetOutputPathFromUser | Specifies if output should come from user
Public property | HeaderIconPath | PDF header icon path
Public property | Id | PDF Prefix ID
Public property | OutputPath | Output path
Top
See Also

Reference

IPdfReportBuilder Interface
VisualComponents.Create3D Namespace


IPdfReportBuilder.BackgroundColor Property

IPdfReportBuilderBackgroundColor Property

PDF background Color

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Color BackgroundColor { get; }
property Color BackgroundColor {
    Color get ();
}

Property Value

Type: Color
See Also

Reference

IPdfReportBuilder Interface
VisualComponents.Create3D Namespace


IPdfReportBuilder.CustomProperties Property

IPdfReportBuilderCustomProperties Property

Custom properties

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ObservableCollection<IProperty> CustomProperties { get; }
property ObservableCollection<IProperty^>^ CustomProperties {
    ObservableCollection<IProperty^>^ get ();
}

Property Value

Type: ObservableCollectionIProperty
See Also

Reference

IPdfReportBuilder Interface
VisualComponents.Create3D Namespace


IPdfReportBuilder.GetOutputPathFromUser Property

IPdfReportBuilderGetOutputPathFromUser Property

Specifies if output should come from user

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool GetOutputPathFromUser { get; }
property bool GetOutputPathFromUser {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IPdfReportBuilder Interface
VisualComponents.Create3D Namespace


IPdfReportBuilder.HeaderIconPath Property

IPdfReportBuilderHeaderIconPath Property

PDF header icon path

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string HeaderIconPath { get; }
property String^ HeaderIconPath {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IPdfReportBuilder Interface
VisualComponents.Create3D Namespace


IPdfReportBuilder.Id Property

IPdfReportBuilderId Property

PDF Prefix ID

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Id { get; }
property String^ Id {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IPdfReportBuilder Interface
VisualComponents.Create3D Namespace


IPdfReportBuilder.OutputPath Property

IPdfReportBuilderOutputPath Property

Output path

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Uri OutputPath { get; set; }
property Uri^ OutputPath {
    Uri^ get ();
    void set (Uri^ value);
}

Property Value

Type: Uri
See Also

Reference

IPdfReportBuilder Interface
VisualComponents.Create3D Namespace


IPdfReportBuilder Methods

The IPdfReportBuilder type exposes the following members.

Methods
 | Name | Description
Public method | CreateReport | Constructor
Public method | GetDisplayName | Gets the displayed name (header name) of specified pdf template
Public method | SetBackgroundColor | Set background color of the PDF file.
Top
See Also

Reference

IPdfReportBuilder Interface
VisualComponents.Create3D Namespace


IPdfReportBuilder.CreateReport Method

IPdfReportBuilderCreateReport Method

Constructor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CreateReport(
    Uri templatePath,
    Uri recordPath,
    string layoutName,
    Point3D layoutCenter,
    double layoutFillDistance,
    IEnumerable<IComponentPdfInfo> componentInfo
)
bool CreateReport(
    Uri^ templatePath,
    Uri^ recordPath,
    String^ layoutName,
    Point3D layoutCenter,
    double layoutFillDistance,
    IEnumerable<IComponentPdfInfo^>^ componentInfo
)

Parameters

templatePath
Type: SystemUri
recordPath
Type: SystemUri
layoutName
Type: SystemString
layoutCenter
Type: System.Windows.Media.Media3DPoint3D
layoutFillDistance
Type: SystemDouble
componentInfo
Type: System.Collections.GenericIEnumerableIComponentPdfInfo

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IPdfReportBuilder.CreateReport(System.Uri,System.Uri,System.String,System.Windows.Media.Media3D.Point3D,System.Double,System.Collections.Generic.IEnumerable{VisualComponents.Create3D.IComponentPdfInfo})"]

See Also

Reference

IPdfReportBuilder Interface
VisualComponents.Create3D Namespace


IPdfReportBuilder.GetDisplayName Method

IPdfReportBuilderGetDisplayName Method

Gets the displayed name (header name) of specified pdf template

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string GetDisplayName(
    string templateName
)
String^ GetDisplayName(
    String^ templateName
)

Parameters

templateName
Type: SystemString

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.IPdfReportBuilder.GetDisplayName(System.String)"]

See Also

Reference

IPdfReportBuilder Interface
VisualComponents.Create3D Namespace


IPdfReportBuilder.SetBackgroundColor Method

IPdfReportBuilderSetBackgroundColor Method

Set background color of the PDF file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetBackgroundColor(
    Color color
)
void SetBackgroundColor(
    Color color
)

Parameters

color
Type: System.Windows.MediaColor
See Also

Reference

IPdfReportBuilder Interface
VisualComponents.Create3D Namespace


IPhysicsCable Interface

An interface for physical cable behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPhysicsCable : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IPhysicsCable : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IPhysicsCable type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPhysicsCable Properties

The IPhysicsCable type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IPhysicsCable Interface
VisualComponents.Create3D Namespace


IPhysicsCable Methods

The IPhysicsCable type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IPhysicsCable Interface
VisualComponents.Create3D Namespace


IPhysicsCable Events

The IPhysicsCable type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IPhysicsCable Interface
VisualComponents.Create3D Namespace


IPhysicsContactModifier Interface

An interface for physics contact modifier behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPhysicsContactModifier : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IPhysicsContactModifier : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IPhysicsContactModifier type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPhysicsContactModifier Properties

The IPhysicsContactModifier type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IPhysicsContactModifier Interface
VisualComponents.Create3D Namespace


IPhysicsContactModifier Methods

The IPhysicsContactModifier type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IPhysicsContactModifier Interface
VisualComponents.Create3D Namespace


IPhysicsContactModifier Events

The IPhysicsContactModifier type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IPhysicsContactModifier Interface
VisualComponents.Create3D Namespace


IPhysicsContainer Interface

An interface for physics container behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPhysicsContainer : ISimContainer,
    IFlowBehavior, IBehavior, IPropertyContainer, IBatchModeObject, IVisitable,
    IWrapper, IDisposable, INamed
public interface class IPhysicsContainer : ISimContainer,
    IFlowBehavior, IBehavior, IPropertyContainer, IBatchModeObject, IVisitable,
    IWrapper, IDisposable, INamed

The IPhysicsContainer type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Maximum logical capacity of the container. This determines the maximum number of components that can be contained in the container at any one time. (Inherited from ISimContainer.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Components | list of components currently contained in the container (Inherited from ISimContainer.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | HeadComponent | Returns component in the head of container (Inherited from ISimContainer.)
Public property | IsContentVisible | Defines whether components held by the container are displayed or not (Inherited from ISimContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | TailComponent | Returns component in the tail of container (Inherited from ISimContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetContainerProximity | Calculate the orthogonal distance from position to this container (Inherited from ISimContainer.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Grab | Grab the component into this container (Inherited from ISimContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ComponentArriving | Triggered when a component is arriving to the container (Inherited from ISimContainer.)
Public event | ComponentLeaving | Triggered when a component is leaving from the container (Inherited from ISimContainer.)
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPhysicsContainer Properties

The IPhysicsContainer type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Maximum logical capacity of the container. This determines the maximum number of components that can be contained in the container at any one time. (Inherited from ISimContainer.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Components | list of components currently contained in the container (Inherited from ISimContainer.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | HeadComponent | Returns component in the head of container (Inherited from ISimContainer.)
Public property | IsContentVisible | Defines whether components held by the container are displayed or not (Inherited from ISimContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | TailComponent | Returns component in the tail of container (Inherited from ISimContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IPhysicsContainer Interface
VisualComponents.Create3D Namespace


IPhysicsContainer Methods

The IPhysicsContainer type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetContainerProximity | Calculate the orthogonal distance from position to this container (Inherited from ISimContainer.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Grab | Grab the component into this container (Inherited from ISimContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IPhysicsContainer Interface
VisualComponents.Create3D Namespace


IPhysicsContainer Events

The IPhysicsContainer type exposes the following members.

Events
 | Name | Description
Public event | ComponentArriving | Triggered when a component is arriving to the container (Inherited from ISimContainer.)
Public event | ComponentLeaving | Triggered when a component is leaving from the container (Inherited from ISimContainer.)
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IPhysicsContainer Interface
VisualComponents.Create3D Namespace


IPhysicsEntity Interface

An interface for physics entity behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPhysicsEntity : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IPhysicsEntity : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IPhysicsEntity type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Serialize | Converts `rPxRigidDynamicSerialization` (cpp struct) to `PxRigidDynamicSerialization` (managed cpp struct).
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPhysicsEntity Properties

The IPhysicsEntity type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IPhysicsEntity Interface
VisualComponents.Create3D Namespace


IPhysicsEntity Methods

The IPhysicsEntity type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Serialize | Converts `rPxRigidDynamicSerialization` (cpp struct) to `PxRigidDynamicSerialization` (managed cpp struct).
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IPhysicsEntity Interface
VisualComponents.Create3D Namespace


IPhysicsEntity.Serialize Method

IPhysicsEntitySerialize Method

Converts `rPxRigidDynamicSerialization` (cpp struct) to `PxRigidDynamicSerialization` (managed cpp struct).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
PxRigidDynamicSerialization Serialize()
PxRigidDynamicSerialization Serialize()

Return Value

Type: PxRigidDynamicSerialization
PxRigidDynamicSerialization, struct containing full information about the physical node
See Also

Reference

IPhysicsEntity Interface
VisualComponents.Create3D Namespace


IPhysicsEntity Events

The IPhysicsEntity type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IPhysicsEntity Interface
VisualComponents.Create3D Namespace


IPhysicsJointD6 Interface

An interface for physics joing d6 behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPhysicsJointD6 : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IPhysicsJointD6 : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IPhysicsJointD6 type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPhysicsJointD6 Properties

The IPhysicsJointD6 type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IPhysicsJointD6 Interface
VisualComponents.Create3D Namespace


IPhysicsJointD6 Methods

The IPhysicsJointD6 type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IPhysicsJointD6 Interface
VisualComponents.Create3D Namespace


IPhysicsJointD6 Events

The IPhysicsJointD6 type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IPhysicsJointD6 Interface
VisualComponents.Create3D Namespace


IPhysicsJointD6ManipulationTarget Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPhysicsJointD6ManipulationTarget : IManipulationTarget,
    ILockableObject, IDisposable
public interface class IPhysicsJointD6ManipulationTarget : IManipulationTarget,
    ILockableObject, IDisposable

The IPhysicsJointD6ManipulationTarget type exposes the following members.

Properties
 | Name | Description
Public property | HandleInObjectCoordinates | Deprecated. Same as TransformationInObject. (Inherited from IManipulationTarget.)
Public property | HandleInReference | Deprecated. Same as TransformationInReference. (Inherited from IManipulationTarget.)
Public property | HandleInWorld | Deprecated. Same as TransformationInWorld. (Inherited from IManipulationTarget.)
Public property | HandleReferenceInWorld | Deprecated. Same as ParentTransformationInWorld. (Inherited from IManipulationTarget.)
Public property | IsHandleFixed | Deprecated. Same as IRobotTcpManipulationTarget.IsTcpExternal. (Inherited from IManipulationTarget.)
Public property | IsLocked | (Inherited from IManipulationTarget.)
Public property | IsTargetEnabled | This is similar to IsLocked, but for manual disabling. (Inherited from IManipulationTarget.)
Public property | IsValid | (Inherited from IManipulationTarget.)
Public property | IsVisible | (Inherited from IManipulationTarget.)
Public property | ParentTransformationInWorld | Position of pivot visual object parent. (Inherited from IManipulationTarget.)
Public property | PivotObject | (Inherited from IManipulationTarget.)
Public property | TargetObjects | Target objects. May exlude child objects. (Inherited from IManipulationTarget.)
Public property | TransformationInObject | Sets the transformation in reference to its own space (Inherited from IManipulationTarget.)
Public property | TransformationInReference | Gets or sets the transformation in reference to its parent (Inherited from IManipulationTarget.)
Public property | TransformationInWorld | Gets or sets the transformation in world (Inherited from IManipulationTarget.)
Top
Methods
 | Name | Description
Public method | ApplyChanges | This is implemented by manipulators that do actual changes on action end or mouse relase. If finalChange==false, then it's only an intermediate change (on mouse release). (Inherited from IManipulationTarget.)
Public method | CollectUndoChanges | Collect all changes since the last call to StoreUndoState(). (Inherited from IManipulationTarget.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | StoreUndoState | Store information away to be used when creating an undo change set later. (Inherited from IManipulationTarget.)
Top
Events
 | Name | Description
Public event | IsLockedChanged | (Inherited from IManipulationTarget.)
Public event | IsVisibleChanged | (Inherited from IManipulationTarget.)
Public event | ObjectInvalidated | (Inherited from IManipulationTarget.)
Public event | TransformationChanged | (Inherited from IManipulationTarget.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPhysicsJointD6ManipulationTarget Properties

The IPhysicsJointD6ManipulationTarget type exposes the following members.

Properties
 | Name | Description
Public property | HandleInObjectCoordinates | Deprecated. Same as TransformationInObject. (Inherited from IManipulationTarget.)
Public property | HandleInReference | Deprecated. Same as TransformationInReference. (Inherited from IManipulationTarget.)
Public property | HandleInWorld | Deprecated. Same as TransformationInWorld. (Inherited from IManipulationTarget.)
Public property | HandleReferenceInWorld | Deprecated. Same as ParentTransformationInWorld. (Inherited from IManipulationTarget.)
Public property | IsHandleFixed | Deprecated. Same as IRobotTcpManipulationTarget.IsTcpExternal. (Inherited from IManipulationTarget.)
Public property | IsLocked | (Inherited from IManipulationTarget.)
Public property | IsTargetEnabled | This is similar to IsLocked, but for manual disabling. (Inherited from IManipulationTarget.)
Public property | IsValid | (Inherited from IManipulationTarget.)
Public property | IsVisible | (Inherited from IManipulationTarget.)
Public property | ParentTransformationInWorld | Position of pivot visual object parent. (Inherited from IManipulationTarget.)
Public property | PivotObject | (Inherited from IManipulationTarget.)
Public property | TargetObjects | Target objects. May exlude child objects. (Inherited from IManipulationTarget.)
Public property | TransformationInObject | Sets the transformation in reference to its own space (Inherited from IManipulationTarget.)
Public property | TransformationInReference | Gets or sets the transformation in reference to its parent (Inherited from IManipulationTarget.)
Public property | TransformationInWorld | Gets or sets the transformation in world (Inherited from IManipulationTarget.)
Top
See Also

Reference

IPhysicsJointD6ManipulationTarget Interface
VisualComponents.Create3D Namespace


IPhysicsJointD6ManipulationTarget Methods

The IPhysicsJointD6ManipulationTarget type exposes the following members.

Methods
 | Name | Description
Public method | ApplyChanges | This is implemented by manipulators that do actual changes on action end or mouse relase. If finalChange==false, then it's only an intermediate change (on mouse release). (Inherited from IManipulationTarget.)
Public method | CollectUndoChanges | Collect all changes since the last call to StoreUndoState(). (Inherited from IManipulationTarget.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | StoreUndoState | Store information away to be used when creating an undo change set later. (Inherited from IManipulationTarget.)
Top
See Also

Reference

IPhysicsJointD6ManipulationTarget Interface
VisualComponents.Create3D Namespace


IPhysicsJointD6ManipulationTarget Events

The IPhysicsJointD6ManipulationTarget type exposes the following members.

Events
 | Name | Description
Public event | IsLockedChanged | (Inherited from IManipulationTarget.)
Public event | IsVisibleChanged | (Inherited from IManipulationTarget.)
Public event | ObjectInvalidated | (Inherited from IManipulationTarget.)
Public event | TransformationChanged | (Inherited from IManipulationTarget.)
Top
See Also

Reference

IPhysicsJointD6ManipulationTarget Interface
VisualComponents.Create3D Namespace


IPhysicsPath Interface

An interface for physics path behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPhysicsPath : ISimContainer,
    IFlowBehavior, IBehavior, IPropertyContainer, IBatchModeObject, IVisitable,
    IWrapper, IDisposable, INamed
public interface class IPhysicsPath : ISimContainer,
    IFlowBehavior, IBehavior, IPropertyContainer, IBatchModeObject, IVisitable,
    IWrapper, IDisposable, INamed

The IPhysicsPath type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Maximum logical capacity of the container. This determines the maximum number of components that can be contained in the container at any one time. (Inherited from ISimContainer.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Components | list of components currently contained in the container (Inherited from ISimContainer.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | HeadComponent | Returns component in the head of container (Inherited from ISimContainer.)
Public property | IsContentVisible | Defines whether components held by the container are displayed or not (Inherited from ISimContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | TailComponent | Returns component in the tail of container (Inherited from ISimContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetContainerProximity | Calculate the orthogonal distance from position to this container (Inherited from ISimContainer.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Grab | Grab the component into this container (Inherited from ISimContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ComponentArriving | Triggered when a component is arriving to the container (Inherited from ISimContainer.)
Public event | ComponentLeaving | Triggered when a component is leaving from the container (Inherited from ISimContainer.)
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPhysicsPath Properties

The IPhysicsPath type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Maximum logical capacity of the container. This determines the maximum number of components that can be contained in the container at any one time. (Inherited from ISimContainer.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Components | list of components currently contained in the container (Inherited from ISimContainer.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | HeadComponent | Returns component in the head of container (Inherited from ISimContainer.)
Public property | IsContentVisible | Defines whether components held by the container are displayed or not (Inherited from ISimContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | TailComponent | Returns component in the tail of container (Inherited from ISimContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IPhysicsPath Interface
VisualComponents.Create3D Namespace


IPhysicsPath Methods

The IPhysicsPath type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetContainerProximity | Calculate the orthogonal distance from position to this container (Inherited from ISimContainer.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Grab | Grab the component into this container (Inherited from ISimContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IPhysicsPath Interface
VisualComponents.Create3D Namespace


IPhysicsPath Events

The IPhysicsPath type exposes the following members.

Events
 | Name | Description
Public event | ComponentArriving | Triggered when a component is arriving to the container (Inherited from ISimContainer.)
Public event | ComponentLeaving | Triggered when a component is leaving from the container (Inherited from ISimContainer.)
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IPhysicsPath Interface
VisualComponents.Create3D Namespace


IPlaneFeature Interface

Plane feature interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPlaneFeature : IFeature,
    IVisualObject, INamed, IWrapper, IDisposable, IVisitable,
    IPropertyContainer, IBatchModeObject, ISharedCloneable
public interface class IPlaneFeature : IFeature,
    IVisualObject, INamed, IWrapper, IDisposable, IVisitable,
    IPropertyContainer, IBatchModeObject, ISharedCloneable

The IPlaneFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks

The plane feature generates a planar geometry.

Plane is typically used as a reference geometry for other operations such as sketching lines.

It is also used as a parameter to the Slice operation

See Also

Reference

VisualComponents.Create3D Namespace


IPlaneFeature Properties

The IPlaneFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
See Also

Reference

IPlaneFeature Interface
VisualComponents.Create3D Namespace


IPlaneFeature Methods

The IPlaneFeature type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IPlaneFeature Interface
VisualComponents.Create3D Namespace


IPlaneFeature Events

The IPlaneFeature type exposes the following members.

Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

IPlaneFeature Interface
VisualComponents.Create3D Namespace


IPlugAndPlayHelper Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPlugAndPlayHelper
public interface class IPlugAndPlayHelper

The IPlugAndPlayHelper type exposes the following members.

Properties
 | Name | Description
Public property | AutoSelect |
Public property | Indications |
Public property | PlugStatus |
Public property | ScreenSpace |
Top
Methods
 | Name | Description
Public method | BeginPlugPlay |
Public method | ConnectSignals |
Public method | DisconnectExternalInterfaces |
Public method | DisconnectSignals |
Public method | EndPlugPlay |
Public method | GetSignalConnectionInterface |
Public method | HidePlugPlayInterfaceIndicators |
Public method | Init |
Public method | IsConnected |
Public method | IsInPath |
Public method | IsSignalConnected |
Public method | SetIsSimulationRunning |
Public method | SetScreenSpaceMagnetDistance |
Public method | ShowPlugPlayInterfaceIndicators |
Public method | VerifyPathPosition |
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPlugAndPlayHelper Properties

The IPlugAndPlayHelper type exposes the following members.

Properties
 | Name | Description
Public property | AutoSelect |
Public property | Indications |
Public property | PlugStatus |
Public property | ScreenSpace |
Top
See Also

Reference

IPlugAndPlayHelper Interface
VisualComponents.Create3D Namespace


IPlugAndPlayHelper.AutoSelect Property

IPlugAndPlayHelperAutoSelect Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool AutoSelect { get; set; }
property bool AutoSelect {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPlugAndPlayHelper Interface
VisualComponents.Create3D Namespace


IPlugAndPlayHelper.Indications Property

IPlugAndPlayHelperIndications Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<PlugIndication> Indications { get; }
property ReadOnlyCollection<PlugIndication^>^ Indications {
    ReadOnlyCollection<PlugIndication^>^ get ();
}

Property Value

Type: ReadOnlyCollectionPlugIndication
See Also

Reference

IPlugAndPlayHelper Interface
VisualComponents.Create3D Namespace


IPlugAndPlayHelper.PlugStatus Property

IPlugAndPlayHelperPlugStatus Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
PlugStatus PlugStatus { get; }
property PlugStatus PlugStatus {
    PlugStatus get ();
}

Property Value

Type: PlugStatus
See Also

Reference

IPlugAndPlayHelper Interface
VisualComponents.Create3D Namespace


IPlugAndPlayHelper.ScreenSpace Property

IPlugAndPlayHelperScreenSpace Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ScreenSpace { get; set; }
property bool ScreenSpace {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPlugAndPlayHelper Interface
VisualComponents.Create3D Namespace


IPlugAndPlayHelper Methods

The IPlugAndPlayHelper type exposes the following members.

Methods
 | Name | Description
Public method | BeginPlugPlay |
Public method | ConnectSignals |
Public method | DisconnectExternalInterfaces |
Public method | DisconnectSignals |
Public method | EndPlugPlay |
Public method | GetSignalConnectionInterface |
Public method | HidePlugPlayInterfaceIndicators |
Public method | Init |
Public method | IsConnected |
Public method | IsInPath |
Public method | IsSignalConnected |
Public method | SetIsSimulationRunning |
Public method | SetScreenSpaceMagnetDistance |
Public method | ShowPlugPlayInterfaceIndicators |
Public method | VerifyPathPosition |
Top
See Also

Reference

IPlugAndPlayHelper Interface
VisualComponents.Create3D Namespace


IPlugAndPlayHelper.BeginPlugPlay Method

IPlugAndPlayHelperBeginPlugPlay Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Nullable<Vector3> BeginPlugPlay(
    ISimComponent[] selection,
    Vector3 nextOffset
)
Nullable<Vector3> BeginPlugPlay(
    array<ISimComponent^>^ selection,
    Vector3 nextOffset
)

Parameters

selection
Type: VisualComponents.Create3DISimComponent
nextOffset
Type: VisualComponents.Create3DVector3

Return Value

Type: NullableVector3

[Missing <returns> documentation for "M:VisualComponents.Create3D.IPlugAndPlayHelper.BeginPlugPlay(VisualComponents.Create3D.ISimComponent[],VisualComponents.Create3D.Vector3)"]

See Also

Reference

IPlugAndPlayHelper Interface
VisualComponents.Create3D Namespace


IPlugAndPlayHelper.ConnectSignals Method

IPlugAndPlayHelperConnectSignals Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ConnectSignals(
    ISignal signal1,
    ISignal signal2
)
bool ConnectSignals(
    ISignal^ signal1,
    ISignal^ signal2
)

Parameters

signal1
Type: VisualComponents.Create3DISignal
signal2
Type: VisualComponents.Create3DISignal

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IPlugAndPlayHelper.ConnectSignals(VisualComponents.Create3D.ISignal,VisualComponents.Create3D.ISignal)"]

See Also

Reference

IPlugAndPlayHelper Interface
VisualComponents.Create3D Namespace


IPlugAndPlayHelper.DisconnectExternalInterfaces Method

IPlugAndPlayHelperDisconnectExternalInterfaces Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DisconnectExternalInterfaces(
    ISimComponent[] components
)
void DisconnectExternalInterfaces(
    array<ISimComponent^>^ components
)

Parameters

components
Type: VisualComponents.Create3DISimComponent
See Also

Reference

IPlugAndPlayHelper Interface
VisualComponents.Create3D Namespace


IPlugAndPlayHelper.DisconnectSignals Method

IPlugAndPlayHelperDisconnectSignals Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool DisconnectSignals(
    ISignal signal1,
    ISignal signal2
)
bool DisconnectSignals(
    ISignal^ signal1,
    ISignal^ signal2
)

Parameters

signal1
Type: VisualComponents.Create3DISignal
signal2
Type: VisualComponents.Create3DISignal

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IPlugAndPlayHelper.DisconnectSignals(VisualComponents.Create3D.ISignal,VisualComponents.Create3D.ISignal)"]

See Also

Reference

IPlugAndPlayHelper Interface
VisualComponents.Create3D Namespace


IPlugAndPlayHelper.EndPlugPlay Method

IPlugAndPlayHelperEndPlugPlay Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void EndPlugPlay(
    ISimComponent[] selection,
    bool attachment
)
void EndPlugPlay(
    array<ISimComponent^>^ selection,
    bool attachment
)

Parameters

selection
Type: VisualComponents.Create3DISimComponent
attachment
Type: SystemBoolean
See Also

Reference

IPlugAndPlayHelper Interface
VisualComponents.Create3D Namespace


IPlugAndPlayHelper.GetSignalConnectionInterface Method

IPlugAndPlayHelperGetSignalConnectionInterface Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool GetSignalConnectionInterface(
    ISignal signalA,
    IList<ISimInterface> interfacesA,
    IList<ISignal> signalB,
    IList<ISimInterface> interfacesB
)
bool GetSignalConnectionInterface(
    ISignal^ signalA,
    IList<ISimInterface^>^ interfacesA,
    IList<ISignal^>^ signalB,
    IList<ISimInterface^>^ interfacesB
)

Parameters

signalA
Type: VisualComponents.Create3DISignal
interfacesA
Type: System.Collections.GenericIListISimInterface
signalB
Type: System.Collections.GenericIListISignal
interfacesB
Type: System.Collections.GenericIListISimInterface

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IPlugAndPlayHelper.GetSignalConnectionInterface(VisualComponents.Create3D.ISignal,System.Collections.Generic.IList{VisualComponents.Create3D.ISimInterface},System.Collections.Generic.IList{VisualComponents.Create3D.ISignal},System.Collections.Generic.IList{VisualComponents.Create3D.ISimInterface})"]

See Also

Reference

IPlugAndPlayHelper Interface
VisualComponents.Create3D Namespace


IPlugAndPlayHelper.HidePlugPlayInterfaceIndicators Method

IPlugAndPlayHelperHidePlugPlayInterfaceIndicators Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void HidePlugPlayInterfaceIndicators()
void HidePlugPlayInterfaceIndicators()
See Also

Reference

IPlugAndPlayHelper Interface
VisualComponents.Create3D Namespace


IPlugAndPlayHelper.Init Method

IPlugAndPlayHelperInit Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Init(
    ISimWorld simWorld
)
void Init(
    ISimWorld^ simWorld
)

Parameters

simWorld
Type: VisualComponents.Create3DISimWorld
See Also

Reference

IPlugAndPlayHelper Interface
VisualComponents.Create3D Namespace


IPlugAndPlayHelper.IsConnected Method

IPlugAndPlayHelperIsConnected Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsConnected()
bool IsConnected()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IPlugAndPlayHelper.IsConnected"]

See Also

Reference

IPlugAndPlayHelper Interface
VisualComponents.Create3D Namespace


IPlugAndPlayHelper.IsInPath Method

IPlugAndPlayHelperIsInPath Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsInPath(
    ISimComponent[] selection
)
bool IsInPath(
    array<ISimComponent^>^ selection
)

Parameters

selection
Type: VisualComponents.Create3DISimComponent

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IPlugAndPlayHelper.IsInPath(VisualComponents.Create3D.ISimComponent[])"]

See Also

Reference

IPlugAndPlayHelper Interface
VisualComponents.Create3D Namespace


IPlugAndPlayHelper.IsSignalConnected Method

IPlugAndPlayHelperIsSignalConnected Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsSignalConnected(
    ISignal signal
)
bool IsSignalConnected(
    ISignal^ signal
)

Parameters

signal
Type: VisualComponents.Create3DISignal

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IPlugAndPlayHelper.IsSignalConnected(VisualComponents.Create3D.ISignal)"]

See Also

Reference

IPlugAndPlayHelper Interface
VisualComponents.Create3D Namespace


IPlugAndPlayHelper.SetIsSimulationRunning Method

IPlugAndPlayHelperSetIsSimulationRunning Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetIsSimulationRunning(
    bool running
)
void SetIsSimulationRunning(
    bool running
)

Parameters

running
Type: SystemBoolean
See Also

Reference

IPlugAndPlayHelper Interface
VisualComponents.Create3D Namespace


IPlugAndPlayHelper.SetScreenSpaceMagnetDistance Method

IPlugAndPlayHelperSetScreenSpaceMagnetDistance Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetScreenSpaceMagnetDistance(
    int distance
)
void SetScreenSpaceMagnetDistance(
    int distance
)

Parameters

distance
Type: SystemInt32
See Also

Reference

IPlugAndPlayHelper Interface
VisualComponents.Create3D Namespace


IPlugAndPlayHelper.ShowPlugPlayInterfaceIndicators Method

IPlugAndPlayHelperShowPlugPlayInterfaceIndicators Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ShowPlugPlayInterfaceIndicators(
    ISimComponent[] selection
)
void ShowPlugPlayInterfaceIndicators(
    array<ISimComponent^>^ selection
)

Parameters

selection
Type: VisualComponents.Create3DISimComponent
See Also

Reference

IPlugAndPlayHelper Interface
VisualComponents.Create3D Namespace


IPlugAndPlayHelper.VerifyPathPosition Method

IPlugAndPlayHelperVerifyPathPosition Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 VerifyPathPosition(
    ISimComponent[] selection,
    Vector3 nextOffset
)
Vector3 VerifyPathPosition(
    array<ISimComponent^>^ selection,
    Vector3 nextOffset
)

Parameters

selection
Type: VisualComponents.Create3DISimComponent
nextOffset
Type: VisualComponents.Create3DVector3

Return Value

Type: Vector3

[Missing <returns> documentation for "M:VisualComponents.Create3D.IPlugAndPlayHelper.VerifyPathPosition(VisualComponents.Create3D.ISimComponent[],VisualComponents.Create3D.Vector3)"]

See Also

Reference

IPlugAndPlayHelper Interface
VisualComponents.Create3D Namespace


IPlugAndPlayLogicalHelper Interface

Helper interface that provides methods relating to abstract interfaces behaviors

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPlugAndPlayLogicalHelper
public interface class IPlugAndPlayLogicalHelper

The IPlugAndPlayLogicalHelper type exposes the following members.

Methods
 | Name | Description
Public method | CheckInNode | Returns a possible match interface of the given node with the given interface
Public method | CheckProximity | Check proximity of interfaces. Returns an interface if connection can be done, null otherwise
Public method | GetConnectionsComponents | Get a list of all nodes that can be or are connected to the given interface
Public method | GetNodeInterfaces | Get all abstract interfaces of a component and its world position
Public method | Init | Method called when initializing this interface
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPlugAndPlayLogicalHelper Methods

The IPlugAndPlayLogicalHelper type exposes the following members.

Methods
 | Name | Description
Public method | CheckInNode | Returns a possible match interface of the given node with the given interface
Public method | CheckProximity | Check proximity of interfaces. Returns an interface if connection can be done, null otherwise
Public method | GetConnectionsComponents | Get a list of all nodes that can be or are connected to the given interface
Public method | GetNodeInterfaces | Get all abstract interfaces of a component and its world position
Public method | Init | Method called when initializing this interface
Top
See Also

Reference

IPlugAndPlayLogicalHelper Interface
VisualComponents.Create3D Namespace


IPlugAndPlayLogicalHelper.CheckInNode Method

IPlugAndPlayLogicalHelperCheckInNode Method

Returns a possible match interface of the given node with the given interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
PossibleConnection CheckInNode(
    ISimInterface simInterface,
    ISimNode simNode
)
PossibleConnection^ CheckInNode(
    ISimInterface^ simInterface,
    ISimNode^ simNode
)

Parameters

simInterface
Type: VisualComponents.Create3DISimInterface
Interface to match
simNode
Type: VisualComponents.Create3DISimNode
Node to look up

Return Value

Type: PossibleConnection
Match description
See Also

Reference

IPlugAndPlayLogicalHelper Interface
VisualComponents.Create3D Namespace


IPlugAndPlayLogicalHelper.CheckProximity Method

IPlugAndPlayLogicalHelperCheckProximity Method

Check proximity of interfaces. Returns an interface if connection can be done, null otherwise

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
PossibleConnection CheckProximity(
    ISimInterface abstractInterface,
    Vector3 position
)
PossibleConnection^ CheckProximity(
    ISimInterface^ abstractInterface,
    Vector3 position
)

Parameters

abstractInterface
Type: VisualComponents.Create3DISimInterface
interface to test
position
Type: VisualComponents.Create3DVector3
interface position

Return Value

Type: PossibleConnection
possible connection
See Also

Reference

IPlugAndPlayLogicalHelper Interface
VisualComponents.Create3D Namespace


IPlugAndPlayLogicalHelper.GetConnectionsComponents Method

IPlugAndPlayLogicalHelperGetConnectionsComponents Method

Get a list of all nodes that can be or are connected to the given interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<InterfaceConnections> GetConnectionsComponents(
    ISimInterface interfaceFrom
)
IEnumerable<InterfaceConnections^>^ GetConnectionsComponents(
    ISimInterface^ interfaceFrom
)

Parameters

interfaceFrom
Type: VisualComponents.Create3DISimInterface
interface to test

Return Value

Type: IEnumerableInterfaceConnections
interface connections list
See Also

Reference

IPlugAndPlayLogicalHelper Interface
VisualComponents.Create3D Namespace


IPlugAndPlayLogicalHelper.GetNodeInterfaces Method

IPlugAndPlayLogicalHelperGetNodeInterfaces Method

Get all abstract interfaces of a component and its world position

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<InterfacePosition> GetNodeInterfaces(
    IVisualObject visualObject
)
IEnumerable<InterfacePosition^>^ GetNodeInterfaces(
    IVisualObject^ visualObject
)

Parameters

visualObject
Type: VisualComponents.Create3DIVisualObject
Must be a component

Return Value

Type: IEnumerableInterfacePosition
List of interfaces and its world position
See Also

Reference

IPlugAndPlayLogicalHelper Interface
VisualComponents.Create3D Namespace


IPlugAndPlayLogicalHelper.Init Method

IPlugAndPlayLogicalHelperInit Method

Method called when initializing this interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Init(
    IWindow3D window3D
)
void Init(
    IWindow3D^ window3D
)

Parameters

window3D
Type: VisualComponents.Create3DIWindow3D
See Also

Reference

IPlugAndPlayLogicalHelper Interface
VisualComponents.Create3D Namespace


IPointSet Interface

Interface for point sets.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPointSet : IGeometrySet,
    IPrimitive, IWrapper, IDisposable
public interface class IPointSet : IGeometrySet,
    IPrimitive, IWrapper, IDisposable

The IPointSet type exposes the following members.

Properties
 | Name | Description
Public property | BoundBox | Returns the bound box of the geometryset. (Inherited from IGeometrySet.)
Public property | ColorConfiguration | Defines point set color configuration
Public property | Container | Geometry container object (Inherited from IGeometrySet.)
Public property | Feature | IGeometryFeature owning the geoset (Inherited from IGeometrySet.)
Public property | HasMaterialInheritance | Determines if it has material inheritance (Inherited from IGeometrySet.)
Public property | HasNoHits | For internal purpose only (Inherited from IGeometrySet.)
Public property | IncrementalBoundUpdate | Defines if on every added point the bound box should be updated or not.
Public property | IsHighlighted | Determines if set is highlighted (Inherited from IGeometrySet.)
Public property | IsLayerVisible | Determine if the layer where the geometry set is located is visible (Inherited from IGeometrySet.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Determines if set is visible (Inherited from IGeometrySet.)
Public property | Material | Material of the set (Inherited from IGeometrySet.)
Public property | Name | Name of the set (Inherited from IGeometrySet.)
Public property | ObjectPrimitiveType | (Inherited from IPrimitive.)
Public property | Original | Retrieves the original geometry set (Inherited from IGeometrySet.)
Public property | PointCount | Total amount of points in the set
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | PointSize | Defines the size (in pixels) of points in set.
Public property | Scale | Defines a factor for scaling rendered points in set.
Public property | TopologyCurves | Set topological information (Inherited from IGeometrySet.)
Top
Methods
 | Name | Description
Public method | AddPoint(Vector3) | Adds a new point into the set
Public method | AddPoint(Vector3, Color) | Adds a new point into the set with given color
Public method | Clear | Clears all geometry information from the set (Inherited from IGeometrySet.)
Public method | Delete | Deletes the set. Instance gets invalidated (Inherited from IGeometrySet.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetClosestPoint | Raycast geometry set. (Inherited from IGeometrySet.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetPointColor | Get a color of a point defined by the index
Public method | GetPointPosition | Get a position of a point defined by the index
Public method | HighlightEdges | highlights only the edges (does not override normal highlighting) (Inherited from IGeometrySet.)
Public method | Update | Updates set information (Inherited from IGeometrySet.)
Public method | UpdatePointColor | Updates a color of a point defined by the index and given color
Public method | UpdatePointPosition | Updates a position of a point defined by the index and given vector
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPointSet Properties

The IPointSet type exposes the following members.

Properties
 | Name | Description
Public property | BoundBox | Returns the bound box of the geometryset. (Inherited from IGeometrySet.)
Public property | ColorConfiguration | Defines point set color configuration
Public property | Container | Geometry container object (Inherited from IGeometrySet.)
Public property | Feature | IGeometryFeature owning the geoset (Inherited from IGeometrySet.)
Public property | HasMaterialInheritance | Determines if it has material inheritance (Inherited from IGeometrySet.)
Public property | HasNoHits | For internal purpose only (Inherited from IGeometrySet.)
Public property | IncrementalBoundUpdate | Defines if on every added point the bound box should be updated or not.
Public property | IsHighlighted | Determines if set is highlighted (Inherited from IGeometrySet.)
Public property | IsLayerVisible | Determine if the layer where the geometry set is located is visible (Inherited from IGeometrySet.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Determines if set is visible (Inherited from IGeometrySet.)
Public property | Material | Material of the set (Inherited from IGeometrySet.)
Public property | Name | Name of the set (Inherited from IGeometrySet.)
Public property | ObjectPrimitiveType | (Inherited from IPrimitive.)
Public property | Original | Retrieves the original geometry set (Inherited from IGeometrySet.)
Public property | PointCount | Total amount of points in the set
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | PointSize | Defines the size (in pixels) of points in set.
Public property | Scale | Defines a factor for scaling rendered points in set.
Public property | TopologyCurves | Set topological information (Inherited from IGeometrySet.)
Top
See Also

Reference

IPointSet Interface
VisualComponents.Create3D Namespace


IPointSet.ColorConfiguration Property

IPointSetColorConfiguration Property

Defines point set color configuration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ColorConfiguration ColorConfiguration { get; set; }
property ColorConfiguration ColorConfiguration {
    ColorConfiguration get ();
    void set (ColorConfiguration value);
}

Property Value

Type: ColorConfiguration
See Also

Reference

IPointSet Interface
VisualComponents.Create3D Namespace


IPointSet.IncrementalBoundUpdate Property

IPointSetIncrementalBoundUpdate Property

Defines if on every added point the bound box should be updated or not.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IncrementalBoundUpdate { get; set; }
property bool IncrementalBoundUpdate {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPointSet Interface
VisualComponents.Create3D Namespace


IPointSet.PointCount Property

IPointSetPointCount Property

Total amount of points in the set

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int PointCount { get; }
property int PointCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IPointSet Interface
VisualComponents.Create3D Namespace


IPointSet.PointSize Property

IPointSetPointSize Property

Defines the size (in pixels) of points in set.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double PointSize { get; set; }
property double PointSize {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IPointSet Interface
VisualComponents.Create3D Namespace


IPointSet.Scale Property

IPointSetScale Property

Defines a factor for scaling rendered points in set.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Scale { get; set; }
property double Scale {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IPointSet Interface
VisualComponents.Create3D Namespace


IPointSet Methods

The IPointSet type exposes the following members.

Methods
 | Name | Description
Public method | AddPoint(Vector3) | Adds a new point into the set
Public method | AddPoint(Vector3, Color) | Adds a new point into the set with given color
Public method | Clear | Clears all geometry information from the set (Inherited from IGeometrySet.)
Public method | Delete | Deletes the set. Instance gets invalidated (Inherited from IGeometrySet.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetClosestPoint | Raycast geometry set. (Inherited from IGeometrySet.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetPointColor | Get a color of a point defined by the index
Public method | GetPointPosition | Get a position of a point defined by the index
Public method | HighlightEdges | highlights only the edges (does not override normal highlighting) (Inherited from IGeometrySet.)
Public method | Update | Updates set information (Inherited from IGeometrySet.)
Public method | UpdatePointColor | Updates a color of a point defined by the index and given color
Public method | UpdatePointPosition | Updates a position of a point defined by the index and given vector
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IPointSet Interface
VisualComponents.Create3D Namespace


IPointSet.AddPoint Method

IPointSetAddPoint Method

Overload List
 | Name | Description
Public method | AddPoint(Vector3) | Adds a new point into the set
Public method | AddPoint(Vector3, Color) | Adds a new point into the set with given color
Top
See Also

Reference

IPointSet Interface
VisualComponents.Create3D Namespace


IPointSet.AddPoint Method (Vector3)

IPointSetAddPoint Method (Vector3)

Adds a new point into the set

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddPoint(
    Vector3 position
)
void AddPoint(
    Vector3 position
)

Parameters

position
Type: VisualComponents.Create3DVector3
See Also

Reference

IPointSet Interface
AddPoint Overload
VisualComponents.Create3D Namespace


IPointSet.AddPoint Method (Vector3, Color)

IPointSetAddPoint Method (Vector3, Color)

Adds a new point into the set with given color

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddPoint(
    Vector3 position,
    Color color
)
void AddPoint(
    Vector3 position,
    Color color
)

Parameters

position
Type: VisualComponents.Create3DVector3
color
Type: VisualComponents.Create3DColor
See Also

Reference

IPointSet Interface
AddPoint Overload
VisualComponents.Create3D Namespace


IPointSet.GetPointColor Method

IPointSetGetPointColor Method

Get a color of a point defined by the index

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Color GetPointColor(
    int index
)
Color GetPointColor(
    int index
)

Parameters

index
Type: SystemInt32

Return Value

Type: Color

[Missing <returns> documentation for "M:VisualComponents.Create3D.IPointSet.GetPointColor(System.Int32)"]

See Also

Reference

IPointSet Interface
VisualComponents.Create3D Namespace


IPointSet.GetPointPosition Method

IPointSetGetPointPosition Method

Get a position of a point defined by the index

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 GetPointPosition(
    int index
)
Vector3 GetPointPosition(
    int index
)

Parameters

index
Type: SystemInt32

Return Value

Type: Vector3

[Missing <returns> documentation for "M:VisualComponents.Create3D.IPointSet.GetPointPosition(System.Int32)"]

See Also

Reference

IPointSet Interface
VisualComponents.Create3D Namespace


IPointSet.UpdatePointColor Method

IPointSetUpdatePointColor Method

Updates a color of a point defined by the index and given color

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdatePointColor(
    int index,
    Color color
)
void UpdatePointColor(
    int index,
    Color color
)

Parameters

index
Type: SystemInt32
color
Type: VisualComponents.Create3DColor
See Also

Reference

IPointSet Interface
VisualComponents.Create3D Namespace


IPointSet.UpdatePointPosition Method

IPointSetUpdatePointPosition Method

Updates a position of a point defined by the index and given vector

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdatePointPosition(
    int index,
    Vector3 position
)
void UpdatePointPosition(
    int index,
    Vector3 position
)

Parameters

index
Type: SystemInt32
position
Type: VisualComponents.Create3DVector3
See Also

Reference

IPointSet Interface
VisualComponents.Create3D Namespace


IPointSet Events

The IPointSet type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
See Also

Reference

IPointSet Interface
VisualComponents.Create3D Namespace


IPosition Interface

Interface for object that have position.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPosition
public interface class IPosition

The IPosition type exposes the following members.

Properties
 | Name | Description
Public property | Position | Gets or sets the position. It depends on the implementing object in which coordinate system the position is represented.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPosition Properties

The IPosition type exposes the following members.

Properties
 | Name | Description
Public property | Position | Gets or sets the position. It depends on the implementing object in which coordinate system the position is represented.
Top
See Also

Reference

IPosition Interface
VisualComponents.Create3D Namespace


IPosition.Position Property

IPositionPosition Property

Gets or sets the position. It depends on the implementing object in which coordinate system the position is represented.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix Position { get; set; }
property Matrix Position {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

IPosition Interface
VisualComponents.Create3D Namespace


IPositionFrame Interface

Defines 3D position and joint values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPositionFrame : IFrame,
    IPrimitive, IWrapper, IDisposable, INamed, IVisualObject,
    IPropertyContainer, IBatchModeObject
public interface class IPositionFrame : IFrame,
    IPrimitive, IWrapper, IDisposable, INamed, IVisualObject,
    IPropertyContainer, IBatchModeObject

The IPositionFrame type exposes the following members.

Properties
 | Name | Description
Public property | Base | Base to which this position is attached to. Note: this can point to a Tool frame if external tcp is used.
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Configuration | Robot's configuration for JointValues.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Controller | Gets the robot controller.
Public property | ExternalJointValues | Gets external joint values.
Public property | Feature | (Inherited from IFrame.)
Public property | InternalJointValues | Gets internal joint values.
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsLocal | Returns true if this IPositionFrame is a local position stored in IPositionStatement, false if the position is stored in IProgram.
Public property | IsReference | Marks frame as a reference frame, which is later used for path smoothing.
Public property | IsStatusValid | Returns true only if Status == Valid.
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | JointValues | Gets all joint values.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ObjectPrimitiveType | (Inherited from IPrimitive.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Position | (Inherited from IFrame.)
Public property | Program | Gets the IProgram containing this instance of IPositionFrame. This will return null if the position is owned by the instance of IPositionStatement.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | SelectedPositionFramesVisibility | Deprecated flag. Similar to SelectedRobotPositionFramesLayerVisibility, but for a single Base.
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | Statement | Deprecated. Use Statements.
Public property | Statements | Gets all the IPositionStatements that refer to this IPositionFrame
Public property | Status | State of inverse kinematics calculation.
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IVisualObject.)
Public property | TransformationInWorld | Gets or sets the world transformation matrix (Inherited from IVisualObject.)
Public property | UseAsGuide | (Inherited from IFrame.)
Public property | VisualizationInfo | Information about the way this frame is rendered. List items contain point size and color values.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetExternalJoints | Sets external joint values.
Public method | SetJoints | Sets all joint values.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | UpdateStatus | Internal method for updating the status.
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Public Extension Method | ToCollection | (Defined by CombinableItemCollectionExtensions.)
Top
Remarks
Usually referefenced by Positions. Also includes Configuration and Status.
See Also

Reference

VisualComponents.Create3D Namespace


IPositionFrame Properties

The IPositionFrame type exposes the following members.

Properties
 | Name | Description
Public property | Base | Base to which this position is attached to. Note: this can point to a Tool frame if external tcp is used.
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Configuration | Robot's configuration for JointValues.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Controller | Gets the robot controller.
Public property | ExternalJointValues | Gets external joint values.
Public property | Feature | (Inherited from IFrame.)
Public property | InternalJointValues | Gets internal joint values.
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsLocal | Returns true if this IPositionFrame is a local position stored in IPositionStatement, false if the position is stored in IProgram.
Public property | IsReference | Marks frame as a reference frame, which is later used for path smoothing.
Public property | IsStatusValid | Returns true only if Status == Valid.
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | JointValues | Gets all joint values.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ObjectPrimitiveType | (Inherited from IPrimitive.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Position | (Inherited from IFrame.)
Public property | Program | Gets the IProgram containing this instance of IPositionFrame. This will return null if the position is owned by the instance of IPositionStatement.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | SelectedPositionFramesVisibility | Deprecated flag. Similar to SelectedRobotPositionFramesLayerVisibility, but for a single Base.
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | Statement | Deprecated. Use Statements.
Public property | Statements | Gets all the IPositionStatements that refer to this IPositionFrame
Public property | Status | State of inverse kinematics calculation.
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IVisualObject.)
Public property | TransformationInWorld | Gets or sets the world transformation matrix (Inherited from IVisualObject.)
Public property | UseAsGuide | (Inherited from IFrame.)
Public property | VisualizationInfo | Information about the way this frame is rendered. List items contain point size and color values.
Top
See Also

Reference

IPositionFrame Interface
VisualComponents.Create3D Namespace


IPositionFrame.Base Property

IPositionFrameBase Property

Base to which this position is attached to. Note: this can point to a Tool frame if external tcp is used.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotFrame Base { get; }
property IRobotFrame^ Base {
    IRobotFrame^ get ();
}

Property Value

Type: IRobotFrame
See Also

Reference

IPositionFrame Interface
VisualComponents.Create3D Namespace


IPositionFrame.Configuration Property

IPositionFrameConfiguration Property

Robot's configuration for JointValues.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int Configuration { get; set; }
property int Configuration {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IPositionFrame Interface
VisualComponents.Create3D Namespace


IPositionFrame.Controller Property

IPositionFrameController Property

Gets the robot controller.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotController Controller { get; }
property IRobotController^ Controller {
    IRobotController^ get ();
}

Property Value

Type: IRobotController
See Also

Reference

IPositionFrame Interface
VisualComponents.Create3D Namespace


IPositionFrame.ExternalJointValues Property

IPositionFrameExternalJointValues Property

Gets external joint values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<double> ExternalJointValues { get; }
property ReadOnlyCollection<double>^ ExternalJointValues {
    ReadOnlyCollection<double>^ get ();
}

Property Value

Type: ReadOnlyCollectionDouble
See Also

Reference

IPositionFrame Interface
VisualComponents.Create3D Namespace


IPositionFrame.InternalJointValues Property

IPositionFrameInternalJointValues Property

Gets internal joint values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<double> InternalJointValues { get; }
property ReadOnlyCollection<double>^ InternalJointValues {
    ReadOnlyCollection<double>^ get ();
}

Property Value

Type: ReadOnlyCollectionDouble
See Also

Reference

IPositionFrame Interface
VisualComponents.Create3D Namespace


IPositionFrame.IsLocal Property

IPositionFrameIsLocal Property

Returns true if this IPositionFrame is a local position stored in IPositionStatement, false if the position is stored in IProgram.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsLocal { get; }
property bool IsLocal {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IPositionFrame Interface
VisualComponents.Create3D Namespace


IPositionFrame.IsReference Property

IPositionFrameIsReference Property

Marks frame as a reference frame, which is later used for path smoothing.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsReference { get; set; }
property bool IsReference {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPositionFrame Interface
VisualComponents.Create3D Namespace


IPositionFrame.IsStatusValid Property

IPositionFrameIsStatusValid Property

Returns true only if Status == Valid.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsStatusValid { get; }
property bool IsStatusValid {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IPositionFrame Interface
VisualComponents.Create3D Namespace


IPositionFrame.JointValues Property

IPositionFrameJointValues Property

Gets all joint values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<double> JointValues { get; }
property ReadOnlyCollection<double>^ JointValues {
    ReadOnlyCollection<double>^ get ();
}

Property Value

Type: ReadOnlyCollectionDouble
See Also

Reference

IPositionFrame Interface
VisualComponents.Create3D Namespace


IPositionFrame.Program Property

IPositionFrameProgram Property

Gets the IProgram containing this instance of IPositionFrame. This will return null if the position is owned by the instance of IPositionStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProgram Program { get; }
property IProgram^ Program {
    IProgram^ get ();
}

Property Value

Type: IProgram
See Also

Reference

IPositionFrame Interface
VisualComponents.Create3D Namespace


IPositionFrame.SelectedPositionFramesVisibility Property

IPositionFrameSelectedPositionFramesVisibility Property

Deprecated flag. Similar to SelectedRobotPositionFramesLayerVisibility, but for a single Base.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SelectedPositionFramesVisibility { get; set; }
property bool SelectedPositionFramesVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPositionFrame Interface
VisualComponents.Create3D Namespace


IPositionFrame.Statement Property

IPositionFrameStatement Property

Deprecated. Use Statements.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPositionStatement Statement { get; }
property IPositionStatement^ Statement {
    IPositionStatement^ get ();
}

Property Value

Type: IPositionStatement
See Also

Reference

IPositionFrame Interface
VisualComponents.Create3D Namespace


IPositionFrame.Statements Property

IPositionFrameStatements Property

Gets all the IPositionStatements that refer to this IPositionFrame

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IPositionStatement> Statements { get; }
property ReadOnlyCollection<IPositionStatement^>^ Statements {
    ReadOnlyCollection<IPositionStatement^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIPositionStatement
See Also

Reference

IPositionFrame Interface
VisualComponents.Create3D Namespace


IPositionFrame.Status Property

IPositionFrameStatus Property

State of inverse kinematics calculation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
PositionStatus Status { get; set; }
property PositionStatus Status {
    PositionStatus get ();
    void set (PositionStatus value);
}

Property Value

Type: PositionStatus
See Also

Reference

IPositionFrame Interface
VisualComponents.Create3D Namespace


IPositionFrame.VisualizationInfo Property

IPositionFrameVisualizationInfo Property

Information about the way this frame is rendered. List items contain point size and color values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<int> VisualizationInfo { get; }
property IList<int>^ VisualizationInfo {
    IList<int>^ get ();
}

Property Value

Type: IListInt32
See Also

Reference

IPositionFrame Interface
VisualComponents.Create3D Namespace


IPositionFrame Methods

The IPositionFrame type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetExternalJoints | Sets external joint values.
Public method | SetJoints | Sets all joint values.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | UpdateStatus | Internal method for updating the status.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Public Extension Method | ToCollection | (Defined by CombinableItemCollectionExtensions.)
Top
See Also

Reference

IPositionFrame Interface
VisualComponents.Create3D Namespace


IPositionFrame.SetExternalJoints Method

IPositionFrameSetExternalJoints Method

Sets external joint values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetExternalJoints(
    IEnumerable<double> jointValues
)
void SetExternalJoints(
    IEnumerable<double>^ jointValues
)

Parameters

jointValues
Type: System.Collections.GenericIEnumerableDouble
See Also

Reference

IPositionFrame Interface
VisualComponents.Create3D Namespace


IPositionFrame.SetJoints Method

IPositionFrameSetJoints Method

Sets all joint values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetJoints(
    IEnumerable<double> jointValues
)
void SetJoints(
    IEnumerable<double>^ jointValues
)

Parameters

jointValues
Type: System.Collections.GenericIEnumerableDouble
Joint values.
See Also

Reference

IPositionFrame Interface
VisualComponents.Create3D Namespace


IPositionFrame.UpdateStatus Method

IPositionFrameUpdateStatus Method

Internal method for updating the status.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateStatus(
    bool useFrameJoints
)
void UpdateStatus(
    bool useFrameJoints
)

Parameters

useFrameJoints
Type: SystemBoolean
See Also

Reference

IPositionFrame Interface
VisualComponents.Create3D Namespace


IPositionFrame Events

The IPositionFrame type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

IPositionFrame Interface
VisualComponents.Create3D Namespace


IPositionFrameContainer Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPositionFrameContainer
public interface class IPositionFrameContainer

The IPositionFrameContainer type exposes the following members.

Properties
 | Name | Description
Public property | Positions | Gets all the positions in this IPositionFrameContainer.
Top
Methods
 | Name | Description
Public method | ClearPositions | Clears all IPositionFrame instances from this IPositionFrameContainer.
Public method | CreatePosition | Creates a new IPositionFrame instance and adds it to this IPositionFrameContainer.
Public method | DeletePosition | Deletes the given IPositionFrame from this IPositionFrameContainer and deletes it (see remarks).
Top
Events
 | Name | Description
Public event | PositionAdded | Occurs when a new instance of IPositionFrame has been added to this instance of IPositionFrameContainer.
Public event | PositionRemoving | Occurs when an instance of IPositionFrame is being removed from this instance of IPositionFrameContainer.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPositionFrameContainer Properties

The IPositionFrameContainer type exposes the following members.

Properties
 | Name | Description
Public property | Positions | Gets all the positions in this IPositionFrameContainer.
Top
See Also

Reference

IPositionFrameContainer Interface
VisualComponents.Create3D Namespace


IPositionFrameContainer.Positions Property

IPositionFrameContainerPositions Property

Gets all the positions in this IPositionFrameContainer.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IPositionFrame> Positions { get; }
property ReadOnlyCollection<IPositionFrame^>^ Positions {
    ReadOnlyCollection<IPositionFrame^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIPositionFrame
See Also

Reference

IPositionFrameContainer Interface
VisualComponents.Create3D Namespace


IPositionFrameContainer Methods

The IPositionFrameContainer type exposes the following members.

Methods
 | Name | Description
Public method | ClearPositions | Clears all IPositionFrame instances from this IPositionFrameContainer.
Public method | CreatePosition | Creates a new IPositionFrame instance and adds it to this IPositionFrameContainer.
Public method | DeletePosition | Deletes the given IPositionFrame from this IPositionFrameContainer and deletes it (see remarks).
Top
See Also

Reference

IPositionFrameContainer Interface
VisualComponents.Create3D Namespace


IPositionFrameContainer.ClearPositions Method

IPositionFrameContainerClearPositions Method

Clears all IPositionFrame instances from this IPositionFrameContainer.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ClearPositions()
void ClearPositions()
See Also

Reference

IPositionFrameContainer Interface
VisualComponents.Create3D Namespace


IPositionFrameContainer.CreatePosition Method

IPositionFrameContainerCreatePosition Method

Creates a new IPositionFrame instance and adds it to this IPositionFrameContainer.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPositionFrame CreatePosition(
    string name
)
IPositionFrame^ CreatePosition(
    String^ name
)

Parameters

name
Type: SystemString
Name of the position to be created.

Return Value

Type: IPositionFrame
Created position.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when name parameter is null.
See Also

Reference

IPositionFrameContainer Interface
VisualComponents.Create3D Namespace


IPositionFrameContainer.DeletePosition Method

IPositionFrameContainerDeletePosition Method

Deletes the given IPositionFrame from this IPositionFrameContainer and deletes it (see remarks).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeletePosition(
    IPositionFrame position
)
void DeletePosition(
    IPositionFrame^ position
)

Parameters

position
Type: VisualComponents.Create3DIPositionFrame
Position to be deleted.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when position parameter is null.
ArgumentNullException | Thrown when position parameter is null.
InvalidOperationException | Thrown when trying to delete a position that does not exist in this statement.
Remarks
If the position to be deleted has been created in the program, it is only removed from the statement. In order for the position to be deleted, it must be deleted from the program.
See Also

Reference

IPositionFrameContainer Interface
VisualComponents.Create3D Namespace


IPositionFrameContainer Events

The IPositionFrameContainer type exposes the following members.

Events
 | Name | Description
Public event | PositionAdded | Occurs when a new instance of IPositionFrame has been added to this instance of IPositionFrameContainer.
Public event | PositionRemoving | Occurs when an instance of IPositionFrame is being removed from this instance of IPositionFrameContainer.
Top
See Also

Reference

IPositionFrameContainer Interface
VisualComponents.Create3D Namespace


IPositionFrameContainer.PositionAdded Event

IPositionFrameContainerPositionAdded Event

Occurs when a new instance of IPositionFrame has been added to this instance of IPositionFrameContainer.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<PositionFrameAddedEventArgs> PositionAdded
 event EventHandler<PositionFrameAddedEventArgs^>^ PositionAdded {
    void add (EventHandler<PositionFrameAddedEventArgs^>^ value);
    void remove (EventHandler<PositionFrameAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerPositionFrameAddedEventArgs
See Also

Reference

IPositionFrameContainer Interface
VisualComponents.Create3D Namespace


IPositionFrameContainer.PositionRemoving Event

IPositionFrameContainerPositionRemoving Event

Occurs when an instance of IPositionFrame is being removed from this instance of IPositionFrameContainer.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<PositionFrameRemovingEventArgs> PositionRemoving
 event EventHandler<PositionFrameRemovingEventArgs^>^ PositionRemoving {
    void add (EventHandler<PositionFrameRemovingEventArgs^>^ value);
    void remove (EventHandler<PositionFrameRemovingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerPositionFrameRemovingEventArgs
See Also

Reference

IPositionFrameContainer Interface
VisualComponents.Create3D Namespace


IPositionStatement Interface

Interface for robot statements that include positions

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPositionStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable, IInterpolatable,
    IPositionFrameContainer
public interface class IPositionStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable, IInterpolatable,
    IPositionFrameContainer

The IPositionStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | Base | Gets or sets the robot base for which the positions in this IPositionStatement are attached to.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | ExternalTcp | Gets or sets external TCP mode.
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Positions | Gets all the positions in this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | Tool | Gets or sets the robot tool
Top
Methods
 | Name | Description
Public method | AddPositionFromProgram | Adds an existing IPositionFrame from IProgram to this IPositionStatement.
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ClearPositions | Clears all IPositionFrame instances from this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreatePosition | Creates a new IPositionFrame instance and adds it to this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeletePosition | Deletes the given IPositionFrame from this IPositionFrameContainer and deletes it (see remarks). (Inherited from IPositionFrameContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | ExecuteImmediatePosition | Moves the robot to the given position. See also: IStatement.ExecuteImmediate().
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | HighlightAll | Highlights all the positions in this IPositionStatement.
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | ReadIn | Reads in the current state of from the associated instance of IServoController.
Public method | SetExternalTcp | Gets or sets external TCP mode by keeping relative frame positions.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PositionAdded | Occurs when a new instance of IPositionFrame has been added to this instance of IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public event | PositionRemoving | Occurs when an instance of IPositionFrame is being removed from this instance of IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public event | PositionTransformationChanged | Occurs when transformation of an instance of IPositionFrame in this instance of IPositionStatement changes.
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPositionStatement Properties

The IPositionStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | Base | Gets or sets the robot base for which the positions in this IPositionStatement are attached to.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | ExternalTcp | Gets or sets external TCP mode.
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Positions | Gets all the positions in this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | Tool | Gets or sets the robot tool
Top
See Also

Reference

IPositionStatement Interface
VisualComponents.Create3D Namespace


IPositionStatement.Base Property

IPositionStatementBase Property

Gets or sets the robot base for which the positions in this IPositionStatement are attached to.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotFrame Base { get; set; }
property IRobotFrame^ Base {
    IRobotFrame^ get ();
    void set (IRobotFrame^ value);
}

Property Value

Type: IRobotFrame
See Also

Reference

IPositionStatement Interface
VisualComponents.Create3D Namespace


IPositionStatement.ExternalTcp Property

IPositionStatementExternalTcp Property

Gets or sets external TCP mode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ExternalTcp { get; set; }
property bool ExternalTcp {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPositionStatement Interface
VisualComponents.Create3D Namespace


IPositionStatement.Tool Property

IPositionStatementTool Property

Gets or sets the robot tool

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotFrame Tool { get; set; }
property IRobotFrame^ Tool {
    IRobotFrame^ get ();
    void set (IRobotFrame^ value);
}

Property Value

Type: IRobotFrame
See Also

Reference

IPositionStatement Interface
VisualComponents.Create3D Namespace


IPositionStatement Methods

The IPositionStatement type exposes the following members.

Methods
 | Name | Description
Public method | AddPositionFromProgram | Adds an existing IPositionFrame from IProgram to this IPositionStatement.
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ClearPositions | Clears all IPositionFrame instances from this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreatePosition | Creates a new IPositionFrame instance and adds it to this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeletePosition | Deletes the given IPositionFrame from this IPositionFrameContainer and deletes it (see remarks). (Inherited from IPositionFrameContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | ExecuteImmediatePosition | Moves the robot to the given position. See also: IStatement.ExecuteImmediate().
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | HighlightAll | Highlights all the positions in this IPositionStatement.
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | ReadIn | Reads in the current state of from the associated instance of IServoController.
Public method | SetExternalTcp | Gets or sets external TCP mode by keeping relative frame positions.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IPositionStatement Interface
VisualComponents.Create3D Namespace


IPositionStatement.AddPositionFromProgram Method

IPositionStatementAddPositionFromProgram Method

Adds an existing IPositionFrame from IProgram to this IPositionStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddPositionFromProgram(
    IPositionFrame position
)
void AddPositionFromProgram(
    IPositionFrame^ position
)

Parameters

position
Type: VisualComponents.Create3DIPositionFrame
Position to be added.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when position parameter is null.
InvalidOperationException | Thrown when trying to add a position from another program or a local position from another statement.
See Also

Reference

IPositionStatement Interface
VisualComponents.Create3D Namespace


IPositionStatement.ExecuteImmediatePosition Method

IPositionStatementExecuteImmediatePosition Method

Moves the robot to the given position. See also: IStatement.ExecuteImmediate().

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ExecuteImmediatePosition(
    IPositionFrame frame
)
void ExecuteImmediatePosition(
    IPositionFrame^ frame
)

Parameters

frame
Type: VisualComponents.Create3DIPositionFrame
See Also

Reference

IPositionStatement Interface
VisualComponents.Create3D Namespace


IPositionStatement.HighlightAll Method

IPositionStatementHighlightAll Method

Highlights all the positions in this IPositionStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void HighlightAll(
    bool value
)
void HighlightAll(
    bool value
)

Parameters

value
Type: SystemBoolean
True/false, when applying/removing highlight.
See Also

Reference

IPositionStatement Interface
VisualComponents.Create3D Namespace


IPositionStatement.ReadIn Method

IPositionStatementReadIn Method

Reads in the current state of from the associated instance of IServoController.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ReadIn(
    IPositionFrame frame
)
void ReadIn(
    IPositionFrame^ frame
)

Parameters

frame
Type: VisualComponents.Create3DIPositionFrame
Target frame.
See Also

Reference

IPositionStatement Interface
VisualComponents.Create3D Namespace


IPositionStatement.SetExternalTcp Method

IPositionStatementSetExternalTcp Method

Gets or sets external TCP mode by keeping relative frame positions.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetExternalTcp(
    bool value,
    bool keepWorldPosition
)
void SetExternalTcp(
    bool value,
    bool keepWorldPosition
)

Parameters

value
Type: SystemBoolean
keepWorldPosition
Type: SystemBoolean
See Also

Reference

IPositionStatement Interface
VisualComponents.Create3D Namespace


IPositionStatement Events

The IPositionStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PositionAdded | Occurs when a new instance of IPositionFrame has been added to this instance of IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public event | PositionRemoving | Occurs when an instance of IPositionFrame is being removed from this instance of IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public event | PositionTransformationChanged | Occurs when transformation of an instance of IPositionFrame in this instance of IPositionStatement changes.
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IPositionStatement Interface
VisualComponents.Create3D Namespace


IPositionStatement.PositionTransformationChanged Event

IPositionStatementPositionTransformationChanged Event

Occurs when transformation of an instance of IPositionFrame in this instance of IPositionStatement changes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<PositionFrameTransformationChangedEventArgs> PositionTransformationChanged
 event EventHandler<PositionFrameTransformationChangedEventArgs^>^ PositionTransformationChanged {
    void add (EventHandler<PositionFrameTransformationChangedEventArgs^>^ value);
    void remove (EventHandler<PositionFrameTransformationChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerPositionFrameTransformationChangedEventArgs
See Also

Reference

IPositionStatement Interface
VisualComponents.Create3D Namespace


IPositionValidator Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPositionValidator
public interface class IPositionValidator

The IPositionValidator type exposes the following members.

Methods
 | Name | Description
Public method | CorrectPosition |
Public method | IsValidPosition |
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPositionValidator Methods

The IPositionValidator type exposes the following members.

Methods
 | Name | Description
Public method | CorrectPosition |
Public method | IsValidPosition |
Top
See Also

Reference

IPositionValidator Interface
VisualComponents.Create3D Namespace


IPositionValidator.CorrectPosition Method

IPositionValidatorCorrectPosition Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix CorrectPosition(
    Matrix current,
    Matrix next
)
Matrix CorrectPosition(
    Matrix current,
    Matrix next
)

Parameters

current
Type: VisualComponents.Create3DMatrix
next
Type: VisualComponents.Create3DMatrix

Return Value

Type: Matrix

[Missing <returns> documentation for "M:VisualComponents.Create3D.IPositionValidator.CorrectPosition(VisualComponents.Create3D.Matrix,VisualComponents.Create3D.Matrix)"]

See Also

Reference

IPositionValidator Interface
VisualComponents.Create3D Namespace


IPositionValidator.IsValidPosition Method

IPositionValidatorIsValidPosition Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsValidPosition(
    Matrix current,
    Matrix next
)
bool IsValidPosition(
    Matrix current,
    Matrix next
)

Parameters

current
Type: VisualComponents.Create3DMatrix
next
Type: VisualComponents.Create3DMatrix

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IPositionValidator.IsValidPosition(VisualComponents.Create3D.Matrix,VisualComponents.Create3D.Matrix)"]

See Also

Reference

IPositionValidator Interface
VisualComponents.Create3D Namespace


IPrimitive Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPrimitive : IWrapper,
    IDisposable
public interface class IPrimitive : IWrapper,
    IDisposable

The IPrimitive type exposes the following members.

Properties
 | Name | Description
Public property | IsValid | (Inherited from IWrapper.)
Public property | ObjectPrimitiveType |
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPrimitive Properties

The IPrimitive type exposes the following members.

Properties
 | Name | Description
Public property | IsValid | (Inherited from IWrapper.)
Public property | ObjectPrimitiveType |
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Top
See Also

Reference

IPrimitive Interface
VisualComponents.Create3D Namespace


IPrimitive.ObjectPrimitiveType Property

IPrimitiveObjectPrimitiveType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
PrimitiveType ObjectPrimitiveType { get; }
property PrimitiveType ObjectPrimitiveType {
    PrimitiveType get ();
}

Property Value

Type: PrimitiveType
See Also

Reference

IPrimitive Interface
VisualComponents.Create3D Namespace


IPrimitive Methods

The IPrimitive type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IPrimitive Interface
VisualComponents.Create3D Namespace


IPrimitive Events

The IPrimitive type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
See Also

Reference

IPrimitive Interface
VisualComponents.Create3D Namespace


IPrimitiveFeature Interface

Primitive feature interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPrimitiveFeature : IFeature,
    IVisualObject, INamed, IWrapper, IDisposable, IVisitable,
    IPropertyContainer, IBatchModeObject, ISharedCloneable
public interface class IPrimitiveFeature : IFeature,
    IVisualObject, INamed, IWrapper, IDisposable, IVisitable,
    IPropertyContainer, IBatchModeObject, ISharedCloneable

The IPrimitiveFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPrimitiveFeature Properties

The IPrimitiveFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
See Also

Reference

IPrimitiveFeature Interface
VisualComponents.Create3D Namespace


IPrimitiveFeature Methods

The IPrimitiveFeature type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IPrimitiveFeature Interface
VisualComponents.Create3D Namespace


IPrimitiveFeature Events

The IPrimitiveFeature type exposes the following members.

Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

IPrimitiveFeature Interface
VisualComponents.Create3D Namespace


IPrintStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPrintStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IPrintStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IPrintStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Message |
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPrintStatement Properties

The IPrintStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Message |
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
See Also

Reference

IPrintStatement Interface
VisualComponents.Create3D Namespace


IPrintStatement.Message Property

IPrintStatementMessage Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Message { get; set; }
property String^ Message {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IPrintStatement Interface
VisualComponents.Create3D Namespace


IPrintStatement Methods

The IPrintStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IPrintStatement Interface
VisualComponents.Create3D Namespace


IPrintStatement Events

The IPrintStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IPrintStatement Interface
VisualComponents.Create3D Namespace


IProcessBooleanTableStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessBooleanTableStatement : IProcessTableStatement,
    IProcessRuleStatement, IStatement, INamed, IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, IApiType, ICloneable<IStatement>,
    ICloneable, IStatementScope, IInterpolatable
public interface class IProcessBooleanTableStatement : IProcessTableStatement,
    IProcessRuleStatement, IStatement, INamed, IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, IApiType, ICloneable<IStatement^>,
    ICloneable, IStatementScope, IInterpolatable

The IProcessBooleanTableStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProcessBooleanTableStatement Properties

The IProcessBooleanTableStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
See Also

Reference

IProcessBooleanTableStatement Interface
VisualComponents.Create3D Namespace


IProcessBooleanTableStatement Methods

The IProcessBooleanTableStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProcessBooleanTableStatement Interface
VisualComponents.Create3D Namespace


IProcessBooleanTableStatement Events

The IProcessBooleanTableStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IProcessBooleanTableStatement Interface
VisualComponents.Create3D Namespace


IProcessController Interface

The process controller is a central object that ties in different aspects of a Process Modeling system.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessController : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IProcessController : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IProcessController type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | FlowGroupManager | Gets the instance of IProcessFlowGroupManager that contains the process groups for this IProcessController.
Public property | FlowTable | Gets the instance of IProcessFlowTable that contains the process sequences for this IProcessController.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProcessManager | Gets the instance of IProcessManager that manages process groups for this IProcessController.
Public property | ProductTypeManager | Gets the instance of IProductTypeManager that contains the product types for this IProcessController.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | TransportSystem | Gets the instance of ITransportSystem that manages product transportation for this IProcessController.
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProcessController Properties

The IProcessController type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | FlowGroupManager | Gets the instance of IProcessFlowGroupManager that contains the process groups for this IProcessController.
Public property | FlowTable | Gets the instance of IProcessFlowTable that contains the process sequences for this IProcessController.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProcessManager | Gets the instance of IProcessManager that manages process groups for this IProcessController.
Public property | ProductTypeManager | Gets the instance of IProductTypeManager that contains the product types for this IProcessController.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | TransportSystem | Gets the instance of ITransportSystem that manages product transportation for this IProcessController.
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IProcessController Interface
VisualComponents.Create3D Namespace


IProcessController.FlowGroupManager Property

IProcessControllerFlowGroupManager Property

Gets the instance of IProcessFlowGroupManager that contains the process groups for this IProcessController.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessFlowGroupManager FlowGroupManager { get; }
property IProcessFlowGroupManager^ FlowGroupManager {
    IProcessFlowGroupManager^ get ();
}

Property Value

Type: IProcessFlowGroupManager
See Also

Reference

IProcessController Interface
VisualComponents.Create3D Namespace


IProcessController.FlowTable Property

IProcessControllerFlowTable Property

Gets the instance of IProcessFlowTable that contains the process sequences for this IProcessController.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessFlowTable FlowTable { get; }
property IProcessFlowTable^ FlowTable {
    IProcessFlowTable^ get ();
}

Property Value

Type: IProcessFlowTable
See Also

Reference

IProcessController Interface
VisualComponents.Create3D Namespace


IProcessController.ProcessManager Property

IProcessControllerProcessManager Property

Gets the instance of IProcessManager that manages process groups for this IProcessController.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessManager ProcessManager { get; }
property IProcessManager^ ProcessManager {
    IProcessManager^ get ();
}

Property Value

Type: IProcessManager
See Also

Reference

IProcessController Interface
VisualComponents.Create3D Namespace


IProcessController.ProductTypeManager Property

IProcessControllerProductTypeManager Property

Gets the instance of IProductTypeManager that contains the product types for this IProcessController.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProductTypeManager ProductTypeManager { get; }
property IProductTypeManager^ ProductTypeManager {
    IProductTypeManager^ get ();
}

Property Value

Type: IProductTypeManager
See Also

Reference

IProcessController Interface
VisualComponents.Create3D Namespace


IProcessController.TransportSystem Property

IProcessControllerTransportSystem Property

Gets the instance of ITransportSystem that manages product transportation for this IProcessController.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ITransportSystem TransportSystem { get; }
property ITransportSystem^ TransportSystem {
    ITransportSystem^ get ();
}

Property Value

Type: ITransportSystem
See Also

Reference

IProcessController Interface
VisualComponents.Create3D Namespace


IProcessController Methods

The IProcessController type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProcessController Interface
VisualComponents.Create3D Namespace


IProcessController Events

The IProcessController type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IProcessController Interface
VisualComponents.Create3D Namespace


IProcessDelayStatement Interface

Delays process execution for a variable amount of simulation time.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessDelayStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IProcessDelayStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IProcessDelayStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | Distribution | Gets pseudo-random real number generated by DistributionExpression.
Public property | DistributionExpression | Gets or sets distribution expression defining the delay time.
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | Expression | Gets or sets an expression defining the delay time.
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | TimeSource | Gets or sets the delay time value source to use.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProcessDelayStatement Properties

The IProcessDelayStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | Distribution | Gets pseudo-random real number generated by DistributionExpression.
Public property | DistributionExpression | Gets or sets distribution expression defining the delay time.
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | Expression | Gets or sets an expression defining the delay time.
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | TimeSource | Gets or sets the delay time value source to use.
Top
See Also

Reference

IProcessDelayStatement Interface
VisualComponents.Create3D Namespace


IProcessDelayStatement.Distribution Property

IProcessDelayStatementDistribution Property

Gets pseudo-random real number generated by DistributionExpression.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Distribution { get; }
property double Distribution {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IProcessDelayStatement Interface
VisualComponents.Create3D Namespace


IProcessDelayStatement.DistributionExpression Property

IProcessDelayStatementDistributionExpression Property

Gets or sets distribution expression defining the delay time.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string DistributionExpression { get; set; }
property String^ DistributionExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IProcessDelayStatement Interface
VisualComponents.Create3D Namespace


IProcessDelayStatement.Expression Property

IProcessDelayStatementExpression Property

Gets or sets an expression defining the delay time.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Expression { get; set; }
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown by setter when supplied value is null.
See Also

Reference

IProcessDelayStatement Interface
VisualComponents.Create3D Namespace


IProcessDelayStatement.TimeSource Property

IProcessDelayStatementTimeSource Property

Gets or sets the delay time value source to use.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ProcessDelayTimeSource TimeSource { get; set; }
property ProcessDelayTimeSource TimeSource {
    ProcessDelayTimeSource get ();
    void set (ProcessDelayTimeSource value);
}

Property Value

Type: ProcessDelayTimeSource
See Also

Reference

IProcessDelayStatement Interface
VisualComponents.Create3D Namespace


IProcessDelayStatement Methods

The IProcessDelayStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProcessDelayStatement Interface
VisualComponents.Create3D Namespace


IProcessDelayStatement Events

The IProcessDelayStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IProcessDelayStatement Interface
VisualComponents.Create3D Namespace


IProcessExecutor Interface

IProcessExecutor is a IBehavior that holds and runs IProcessRoutines. Each IProcessRoutine is an implementation of a process. The execution order of the IProcessRoutines is controlled by the parent IProcessController.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessExecutor : IExecutor,
    IStatementExecutor, IBehavior, IPropertyContainer, IBatchModeObject, IVisitable,
    IWrapper, IDisposable, INamed
public interface class IProcessExecutor : IExecutor,
    IStatementExecutor, IBehavior, IPropertyContainer, IBatchModeObject, IVisitable,
    IWrapper, IDisposable, INamed

The IProcessExecutor type exposes the following members.

Properties
 | Name | Description
Public property | ActiveProgram | Gets or sets the currently active program. (Inherited from IStatementExecutor.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CurrentScope | Get the scope that is currently being executed. (Inherited from IStatementExecutor.)
Public property | CurrentStatement | Gets the current position of the program pointer. Returns null if in the beginning of scope. (Inherited from IStatementExecutor.)
Public property | DigitalInputSignals | Gets or sets the input ISignalMap associated to this IExecutor. (Inherited from IExecutor.)
Public property | DigitalOutputSignals | Gets or sets the output ISignalMap associated to this IExecutor. (Inherited from IExecutor.)
Public property | IsEnabled | Defines if the executor will execute its program. (Inherited from IStatementExecutor.)
Public property | IsIdle | Returns true if, and only if, the executor is currently not executing any IStatements or IStatementScopes. (Inherited from IExecutor.)
Public property | IsLooping | Defines if the executor will restart the program automatically when finished. (Inherited from IStatementExecutor.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProcessController | Gets the associated IProcessController.
Public property | Processes | Gets all the instances of IProcessRoutine in this executor's IProgram.
Public property | Program | Gets the first program contained by this IStatementExecutor instance. (Inherited from IStatementExecutor.)
Public property | Programs | Gets all the instances of IProgram in this executor. (Inherited from IStatementExecutor.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | StatementHandler | Gets or sets the instance of IProcessHandler that can be used for overriding or customizing the execution of IStatement instances. (Inherited from IExecutor.)
Public property | TransportNode | The associated ITransportNode that this IProcessExecutor’s IProcessRoutines use to receive and send ISimProduct instances.
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddProcess | Creates a new IProcessRoutine and adds it to this IProcessExecutor’s program. Returns the created process routine, or null if this rom this IProcessExecutor doesn’t have an IProgram.
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | ClearProcesses | Deletes all instance of IProcessRoutine from this IProcessExecutor.
Public method | ClearPrograms | (Inherited from IStatementExecutor.)
Public method | Continue | Continues execution. (Inherited from IStatementExecutor.)
Public method | Continue(Double) | Continues the execution after a given time. (Inherited from IStatementExecutor.)
Public method | CreateProgram | Creates a new instance of IProgram. (Inherited from IStatementExecutor.)
Public method | CreateProgram(String) | Creates a new instance of IProgram. (Inherited from IStatementExecutor.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProcess | Removes the given instance of IProcessRoutine from this IProcessExecutor, and then deletes the removed IProcessRoutine.
Public method | DeleteProgram | Deletes the given instance of IProgram (Inherited from IStatementExecutor.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | ExecuteStep | Execute the next IStatement. (Inherited from IStatementExecutor.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | JumpToScope | Adds the current program position to the stack and jumps program execution to the given scope. When the scope is finished, the progam will continue from the current position. (Inherited from IStatementExecutor.)
Public method | NotifyStatementExecutedEx | Signals ExecutedEx event for this statement. This should only be used together with custom statements that have set the value of ControlExecutedExEvent to true. (Inherited from IStatementExecutor.)
Public method | Reset | Reset the execution to the beginning of the program. (Inherited from IStatementExecutor.)
Public method | SetProgramPointer | Sets the program pointer to the given position. When executed, the program will start from this position. (Inherited from IStatementExecutor.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ActiveProgramChanged | Occurs when the value of ActiveProgram has changed. (Inherited from IStatementExecutor.)
Public event | CurrentStatementChanged | Obsolete. An event that is raised when the executor begins to execute a IStatement. (Inherited from IExecutor.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | ProgramAdded | Occurs when a new instance of IProgram has been added to this instance of IStatementExecutor. (Inherited from IStatementExecutor.)
Public event | ProgramFinished | An event that is raised when the executor has executed its program. (Inherited from IExecutor.)
Public event | ProgramRemoving | Occurs when an instance of IProgram is being removed from this instance of IStatementExecutor. (Inherited from IStatementExecutor.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | StatementExecuted | An event that is raised when the executor has executed a IStatement. (Inherited from IExecutor.)
Public event | StatementExecuting | An event that is raised when the executor begins to execute a IStatement. (Inherited from IExecutor.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProcessExecutor Properties

The IProcessExecutor type exposes the following members.

Properties
 | Name | Description
Public property | ActiveProgram | Gets or sets the currently active program. (Inherited from IStatementExecutor.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CurrentScope | Get the scope that is currently being executed. (Inherited from IStatementExecutor.)
Public property | CurrentStatement | Gets the current position of the program pointer. Returns null if in the beginning of scope. (Inherited from IStatementExecutor.)
Public property | DigitalInputSignals | Gets or sets the input ISignalMap associated to this IExecutor. (Inherited from IExecutor.)
Public property | DigitalOutputSignals | Gets or sets the output ISignalMap associated to this IExecutor. (Inherited from IExecutor.)
Public property | IsEnabled | Defines if the executor will execute its program. (Inherited from IStatementExecutor.)
Public property | IsIdle | Returns true if, and only if, the executor is currently not executing any IStatements or IStatementScopes. (Inherited from IExecutor.)
Public property | IsLooping | Defines if the executor will restart the program automatically when finished. (Inherited from IStatementExecutor.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProcessController | Gets the associated IProcessController.
Public property | Processes | Gets all the instances of IProcessRoutine in this executor's IProgram.
Public property | Program | Gets the first program contained by this IStatementExecutor instance. (Inherited from IStatementExecutor.)
Public property | Programs | Gets all the instances of IProgram in this executor. (Inherited from IStatementExecutor.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | StatementHandler | Gets or sets the instance of IProcessHandler that can be used for overriding or customizing the execution of IStatement instances. (Inherited from IExecutor.)
Public property | TransportNode | The associated ITransportNode that this IProcessExecutor’s IProcessRoutines use to receive and send ISimProduct instances.
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IProcessExecutor Interface
VisualComponents.Create3D Namespace


IProcessExecutor.ProcessController Property

IProcessExecutorProcessController Property

Gets the associated IProcessController.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessController ProcessController { get; }
property IProcessController^ ProcessController {
    IProcessController^ get ();
}

Property Value

Type: IProcessController
See Also

Reference

IProcessExecutor Interface
VisualComponents.Create3D Namespace


IProcessExecutor.Processes Property

IProcessExecutorProcesses Property

Gets all the instances of IProcessRoutine in this executor's IProgram.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<IProcessRoutine> Processes { get; }
property IReadOnlyList<IProcessRoutine^>^ Processes {
    IReadOnlyList<IProcessRoutine^>^ get ();
}

Property Value

Type: IReadOnlyListIProcessRoutine
Remarks
Returns null if this rom this IProcessExecutor doesn’t have an IProgram.
See Also

Reference

IProcessExecutor Interface
VisualComponents.Create3D Namespace


IProcessExecutor.TransportNode Property

IProcessExecutorTransportNode Property

The associated ITransportNode that this IProcessExecutor’s IProcessRoutines use to receive and send ISimProduct instances.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ITransportNode TransportNode { get; set; }
property ITransportNode^ TransportNode {
    ITransportNode^ get ();
    void set (ITransportNode^ value);
}

Property Value

Type: ITransportNode
Remarks
Setting this property also sets the ProcessExecutor property on the new ITransportNode, and clears the same property from the old ITransportNode, if there was one.
See Also

Reference

IProcessExecutor Interface
VisualComponents.Create3D Namespace


IProcessExecutor Methods

The IProcessExecutor type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddProcess | Creates a new IProcessRoutine and adds it to this IProcessExecutor’s program. Returns the created process routine, or null if this rom this IProcessExecutor doesn’t have an IProgram.
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | ClearProcesses | Deletes all instance of IProcessRoutine from this IProcessExecutor.
Public method | ClearPrograms | (Inherited from IStatementExecutor.)
Public method | Continue | Continues execution. (Inherited from IStatementExecutor.)
Public method | Continue(Double) | Continues the execution after a given time. (Inherited from IStatementExecutor.)
Public method | CreateProgram | Creates a new instance of IProgram. (Inherited from IStatementExecutor.)
Public method | CreateProgram(String) | Creates a new instance of IProgram. (Inherited from IStatementExecutor.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProcess | Removes the given instance of IProcessRoutine from this IProcessExecutor, and then deletes the removed IProcessRoutine.
Public method | DeleteProgram | Deletes the given instance of IProgram (Inherited from IStatementExecutor.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | ExecuteStep | Execute the next IStatement. (Inherited from IStatementExecutor.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | JumpToScope | Adds the current program position to the stack and jumps program execution to the given scope. When the scope is finished, the progam will continue from the current position. (Inherited from IStatementExecutor.)
Public method | NotifyStatementExecutedEx | Signals ExecutedEx event for this statement. This should only be used together with custom statements that have set the value of ControlExecutedExEvent to true. (Inherited from IStatementExecutor.)
Public method | Reset | Reset the execution to the beginning of the program. (Inherited from IStatementExecutor.)
Public method | SetProgramPointer | Sets the program pointer to the given position. When executed, the program will start from this position. (Inherited from IStatementExecutor.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProcessExecutor Interface
VisualComponents.Create3D Namespace


IProcessExecutor.AddProcess Method

IProcessExecutorAddProcess Method

Creates a new IProcessRoutine and adds it to this IProcessExecutor’s program.

Returns the created process routine, or null if this rom this IProcessExecutor doesn’t have an IProgram.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessRoutine AddProcess(
    string processId
)
IProcessRoutine^ AddProcess(
    String^ processId
)

Parameters

processId
Type: SystemString
Process id. This has to be unique within this IProcessExecutor’s program.

Return Value

Type: IProcessRoutine

[Missing <returns> documentation for "M:VisualComponents.Create3D.IProcessExecutor.AddProcess(System.String)"]

Exceptions
Exception | Condition
InvalidOperationException |
See Also

Reference

IProcessExecutor Interface
VisualComponents.Create3D Namespace


IProcessExecutor.ClearProcesses Method

IProcessExecutorClearProcesses Method

Deletes all instance of IProcessRoutine from this IProcessExecutor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ClearProcesses()
void ClearProcesses()
See Also

Reference

IProcessExecutor Interface
VisualComponents.Create3D Namespace


IProcessExecutor.DeleteProcess Method

IProcessExecutorDeleteProcess Method

Removes the given instance of IProcessRoutine from this IProcessExecutor, and then deletes the removed IProcessRoutine.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteProcess(
    IProcessRoutine process
)
void DeleteProcess(
    IProcessRoutine^ process
)

Parameters

process
Type: VisualComponents.Create3DIProcessRoutine
Process to be deleted.
See Also

Reference

IProcessExecutor Interface
VisualComponents.Create3D Namespace


IProcessExecutor Events

The IProcessExecutor type exposes the following members.

Events
 | Name | Description
Public event | ActiveProgramChanged | Occurs when the value of ActiveProgram has changed. (Inherited from IStatementExecutor.)
Public event | CurrentStatementChanged | Obsolete. An event that is raised when the executor begins to execute a IStatement. (Inherited from IExecutor.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | ProgramAdded | Occurs when a new instance of IProgram has been added to this instance of IStatementExecutor. (Inherited from IStatementExecutor.)
Public event | ProgramFinished | An event that is raised when the executor has executed its program. (Inherited from IExecutor.)
Public event | ProgramRemoving | Occurs when an instance of IProgram is being removed from this instance of IStatementExecutor. (Inherited from IStatementExecutor.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | StatementExecuted | An event that is raised when the executor has executed a IStatement. (Inherited from IExecutor.)
Public event | StatementExecuting | An event that is raised when the executor begins to execute a IStatement. (Inherited from IExecutor.)
Top
See Also

Reference

IProcessExecutor Interface
VisualComponents.Create3D Namespace


IProcessFlowGroup Interface

A IProcessFlowGroup is a grouping of IProductTypes that share same IProcessSequence and can navigate through the same ITransportLinks.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessFlowGroup : INamed,
    IWrapper, IDisposable, IPropertyContainer, IBatchModeObject
public interface class IProcessFlowGroup : INamed,
    IWrapper, IDisposable, IPropertyContainer, IBatchModeObject

The IProcessFlowGroup type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | FlowGroupManager | Gets the instance of IProcessFlowGroupManager that owns this IProcessFlowGroup.
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Defines if this IProcessFlowGroup is visible in certain areas of the user interface.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductTypes | Gets all the instances of IProductType that belong to this IProcessFlowGroup.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | ProductTypeAdded | Occurs when an instance of IProductType has been added to this IProcessFlowGroup.
Public event | ProductTypeRemoving | Occurs when an instance of IProductType is being removed from this IProcessFlowGroup.
Public event | ProductTypeReplaced | Occurs when an instance of IProductType has been replaced by another IProductType, e.g. when a newer version of that IProductType is loaded.
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
Every IProductType belongs to exactly one IProcessFlowGroup, with the only exception being the system “Any” IProductType doesn’t belong to a IProcessFlowGroup.
See Also

Reference

VisualComponents.Create3D Namespace


IProcessFlowGroup Properties

The IProcessFlowGroup type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | FlowGroupManager | Gets the instance of IProcessFlowGroupManager that owns this IProcessFlowGroup.
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Defines if this IProcessFlowGroup is visible in certain areas of the user interface.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductTypes | Gets all the instances of IProductType that belong to this IProcessFlowGroup.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IProcessFlowGroup Interface
VisualComponents.Create3D Namespace


IProcessFlowGroup.FlowGroupManager Property

IProcessFlowGroupFlowGroupManager Property

Gets the instance of IProcessFlowGroupManager that owns this IProcessFlowGroup.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessFlowGroupManager FlowGroupManager { get; }
property IProcessFlowGroupManager^ FlowGroupManager {
    IProcessFlowGroupManager^ get ();
}

Property Value

Type: IProcessFlowGroupManager
See Also

Reference

IProcessFlowGroup Interface
VisualComponents.Create3D Namespace


IProcessFlowGroup.IsVisible Property

IProcessFlowGroupIsVisible Property

Defines if this IProcessFlowGroup is visible in certain areas of the user interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsVisible { get; set; }
property bool IsVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IProcessFlowGroup Interface
VisualComponents.Create3D Namespace


IProcessFlowGroup.ProductTypes Property

IProcessFlowGroupProductTypes Property

Gets all the instances of IProductType that belong to this IProcessFlowGroup.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<IProductType> ProductTypes { get; }
property IEnumerable<IProductType^>^ ProductTypes {
    IEnumerable<IProductType^>^ get ();
}

Property Value

Type: IEnumerableIProductType
See Also

Reference

IProcessFlowGroup Interface
VisualComponents.Create3D Namespace


IProcessFlowGroup Methods

The IProcessFlowGroup type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProcessFlowGroup Interface
VisualComponents.Create3D Namespace


IProcessFlowGroup Events

The IProcessFlowGroup type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | ProductTypeAdded | Occurs when an instance of IProductType has been added to this IProcessFlowGroup.
Public event | ProductTypeRemoving | Occurs when an instance of IProductType is being removed from this IProcessFlowGroup.
Public event | ProductTypeReplaced | Occurs when an instance of IProductType has been replaced by another IProductType, e.g. when a newer version of that IProductType is loaded.
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IProcessFlowGroup Interface
VisualComponents.Create3D Namespace


IProcessFlowGroup.ProductTypeAdded Event

IProcessFlowGroupProductTypeAdded Event

Occurs when an instance of IProductType has been added to this IProcessFlowGroup.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ProductTypeAddedEventArgs> ProductTypeAdded
 event EventHandler<ProductTypeAddedEventArgs^>^ ProductTypeAdded {
    void add (EventHandler<ProductTypeAddedEventArgs^>^ value);
    void remove (EventHandler<ProductTypeAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerProductTypeAddedEventArgs
See Also

Reference

IProcessFlowGroup Interface
VisualComponents.Create3D Namespace


IProcessFlowGroup.ProductTypeRemoving Event

IProcessFlowGroupProductTypeRemoving Event

Occurs when an instance of IProductType is being removed from this IProcessFlowGroup.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ProductTypeRemovingEventArgs> ProductTypeRemoving
 event EventHandler<ProductTypeRemovingEventArgs^>^ ProductTypeRemoving {
    void add (EventHandler<ProductTypeRemovingEventArgs^>^ value);
    void remove (EventHandler<ProductTypeRemovingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerProductTypeRemovingEventArgs
See Also

Reference

IProcessFlowGroup Interface
VisualComponents.Create3D Namespace


IProcessFlowGroup.ProductTypeReplaced Event

IProcessFlowGroupProductTypeReplaced Event

Occurs when an instance of IProductType has been replaced by another IProductType, e.g. when a newer version of that IProductType is loaded.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ProductTypeReplacedEventArgs> ProductTypeReplaced
 event EventHandler<ProductTypeReplacedEventArgs^>^ ProductTypeReplaced {
    void add (EventHandler<ProductTypeReplacedEventArgs^>^ value);
    void remove (EventHandler<ProductTypeReplacedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerProductTypeReplacedEventArgs
See Also

Reference

IProcessFlowGroup Interface
VisualComponents.Create3D Namespace


IProcessFlowGroupManager Interface

The IProcessFlowGroupManager is used to manage the IProcessFlowGroup objects within its owner IProcessController.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessFlowGroupManager : IWrapper,
    IDisposable
public interface class IProcessFlowGroupManager : IWrapper,
    IDisposable

The IProcessFlowGroupManager type exposes the following members.

Properties
 | Name | Description
Public property | Controller | Gets the instance of IProcessController that owns this IProcessFlowGroupManager.
Public property | Groups | Gets all instances of IProcessFlowGroups owned by this IProcessFlowGroupManager.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Top
Methods
 | Name | Description
Public method | ClearGroups | Deletes all the instance of IProcessFlowGroup in this IProcessFlowGroupManager.
Public method | CreateGroup | Creates a new instance of IProcessFlowGroup.
Public method | DeleteGroup | Deletes the given instance of IProcessFlowGroup. Also deletes the related IProductTypes, ITransportLinks, and IProcessSequences.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | MoveProductType | Moves the given instance of IProductType to the given instance IProcessFlowGroup.
Top
Events
 | Name | Description
Public event | GroupAdded | Occurs when an instance of IProcessFlowGroup has been added to this IProcessFlowGroupManager.
Public event | GroupRemoving | Occurs when an instance of IProcessFlowGroup is being removed from this IProcessFlowGroupManager.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProcessFlowGroupManager Properties

The IProcessFlowGroupManager type exposes the following members.

Properties
 | Name | Description
Public property | Controller | Gets the instance of IProcessController that owns this IProcessFlowGroupManager.
Public property | Groups | Gets all instances of IProcessFlowGroups owned by this IProcessFlowGroupManager.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Top
See Also

Reference

IProcessFlowGroupManager Interface
VisualComponents.Create3D Namespace


IProcessFlowGroupManager.Controller Property

IProcessFlowGroupManagerController Property

Gets the instance of IProcessController that owns this IProcessFlowGroupManager.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessController Controller { get; }
property IProcessController^ Controller {
    IProcessController^ get ();
}

Property Value

Type: IProcessController
See Also

Reference

IProcessFlowGroupManager Interface
VisualComponents.Create3D Namespace


IProcessFlowGroupManager.Groups Property

IProcessFlowGroupManagerGroups Property

Gets all instances of IProcessFlowGroups owned by this IProcessFlowGroupManager.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<IProcessFlowGroup> Groups { get; }
property IReadOnlyList<IProcessFlowGroup^>^ Groups {
    IReadOnlyList<IProcessFlowGroup^>^ get ();
}

Property Value

Type: IReadOnlyListIProcessFlowGroup
See Also

Reference

IProcessFlowGroupManager Interface
VisualComponents.Create3D Namespace


IProcessFlowGroupManager Methods

The IProcessFlowGroupManager type exposes the following members.

Methods
 | Name | Description
Public method | ClearGroups | Deletes all the instance of IProcessFlowGroup in this IProcessFlowGroupManager.
Public method | CreateGroup | Creates a new instance of IProcessFlowGroup.
Public method | DeleteGroup | Deletes the given instance of IProcessFlowGroup. Also deletes the related IProductTypes, ITransportLinks, and IProcessSequences.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | MoveProductType | Moves the given instance of IProductType to the given instance IProcessFlowGroup.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProcessFlowGroupManager Interface
VisualComponents.Create3D Namespace


IProcessFlowGroupManager.ClearGroups Method

IProcessFlowGroupManagerClearGroups Method

Deletes all the instance of IProcessFlowGroup in this IProcessFlowGroupManager.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ClearGroups()
void ClearGroups()
See Also

Reference

IProcessFlowGroupManager Interface
VisualComponents.Create3D Namespace


IProcessFlowGroupManager.CreateGroup Method

IProcessFlowGroupManagerCreateGroup Method

Creates a new instance of IProcessFlowGroup.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessFlowGroup CreateGroup(
    string name
)
IProcessFlowGroup^ CreateGroup(
    String^ name
)

Parameters

name
Type: SystemString
Flow group name.

Return Value

Type: IProcessFlowGroup
Created flow group.
Exceptions
Exception | Condition
ArgumentNullException | Occurs when the given name is empty or null string.
ArgumentException | Occurs when a group with the given name exists.
See Also

Reference

IProcessFlowGroupManager Interface
VisualComponents.Create3D Namespace


IProcessFlowGroupManager.DeleteGroup Method

IProcessFlowGroupManagerDeleteGroup Method

Deletes the given instance of IProcessFlowGroup. Also deletes the related IProductTypes, ITransportLinks, and IProcessSequences.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteGroup(
    IProcessFlowGroup group
)
void DeleteGroup(
    IProcessFlowGroup^ group
)

Parameters

group
Type: VisualComponents.Create3DIProcessFlowGroup
Group to delete.
Exceptions
Exception | Condition
ArgumentNullException | Occurs when the given groups is null.
See Also

Reference

IProcessFlowGroupManager Interface
VisualComponents.Create3D Namespace


IProcessFlowGroupManager.MoveProductType Method

IProcessFlowGroupManagerMoveProductType Method

Moves the given instance of IProductType to the given instance IProcessFlowGroup.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void MoveProductType(
    IProductType productType,
    IProcessFlowGroup newGroup
)
void MoveProductType(
    IProductType^ productType,
    IProcessFlowGroup^ newGroup
)

Parameters

productType
Type: VisualComponents.Create3DIProductType
Product type to move.
newGroup
Type: VisualComponents.Create3DIProcessFlowGroup
Target group.
Exceptions
Exception | Condition
ArgumentNullException | Occurs when the given productType or newGroup is null.
InvalidOperationException | Occurs when attempting to add 'Any' system type to a group or when the given product type is not associated to the process controller that owns this group.
See Also

Reference

IProcessFlowGroupManager Interface
VisualComponents.Create3D Namespace


IProcessFlowGroupManager Events

The IProcessFlowGroupManager type exposes the following members.

Events
 | Name | Description
Public event | GroupAdded | Occurs when an instance of IProcessFlowGroup has been added to this IProcessFlowGroupManager.
Public event | GroupRemoving | Occurs when an instance of IProcessFlowGroup is being removed from this IProcessFlowGroupManager.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
See Also

Reference

IProcessFlowGroupManager Interface
VisualComponents.Create3D Namespace


IProcessFlowGroupManager.GroupAdded Event

IProcessFlowGroupManagerGroupAdded Event

Occurs when an instance of IProcessFlowGroup has been added to this IProcessFlowGroupManager.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ProcessFlowGroupAddedEventArgs> GroupAdded
 event EventHandler<ProcessFlowGroupAddedEventArgs^>^ GroupAdded {
    void add (EventHandler<ProcessFlowGroupAddedEventArgs^>^ value);
    void remove (EventHandler<ProcessFlowGroupAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerProcessFlowGroupAddedEventArgs
See Also

Reference

IProcessFlowGroupManager Interface
VisualComponents.Create3D Namespace


IProcessFlowGroupManager.GroupRemoving Event

IProcessFlowGroupManagerGroupRemoving Event

Occurs when an instance of IProcessFlowGroup is being removed from this IProcessFlowGroupManager.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ProcessFlowGroupRemovingEventArgs> GroupRemoving
 event EventHandler<ProcessFlowGroupRemovingEventArgs^>^ GroupRemoving {
    void add (EventHandler<ProcessFlowGroupRemovingEventArgs^>^ value);
    void remove (EventHandler<ProcessFlowGroupRemovingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerProcessFlowGroupRemovingEventArgs
See Also

Reference

IProcessFlowGroupManager Interface
VisualComponents.Create3D Namespace


IProcessFlowTable Interface

The IProcessFlowTable holds the IProcessSequences that each ISimProduct belonging to a certain IProcessFlowGroups shall follow as it travels through the simulation under this IProcessController.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessFlowTable : IWrapper,
    IDisposable
public interface class IProcessFlowTable : IWrapper,
    IDisposable

The IProcessFlowTable type exposes the following members.

Properties
 | Name | Description
Public property | Controller | Gets the instance of IProcessController that owns this IProcessFlowTable.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Sequences | Gets the collection of all IProcessSequence instances.
Top
Methods
 | Name | Description
Public method | CopySequenceFrom | Copies the sequence defined for the given source IProcessFlowGroup and adds it to this IProcessFlowTable, for the target IProcessFlowGroup.
Public method | CreateSequence | Creates a new IProcessSequence for the given IProcessFlowGroup.
Public method | DeleteSequence | Deletes the IProcessSequence of the given IProcessFlowGroup.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetSequence | Returns the IProcessSequence instance associated with the given IProcessFlowGroup, without getting the whole Sequences collection, or null if no such sequence is found.
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | SequenceAdded | Event that occurs when a new instance of IProcessSequence has been added to this IProcessFlowTable.
Public event | SequenceRemoving | Event that occurs when the instance of IProcessSequence is being deleted from this IProcessFlowTable.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProcessFlowTable Properties

The IProcessFlowTable type exposes the following members.

Properties
 | Name | Description
Public property | Controller | Gets the instance of IProcessController that owns this IProcessFlowTable.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Sequences | Gets the collection of all IProcessSequence instances.
Top
See Also

Reference

IProcessFlowTable Interface
VisualComponents.Create3D Namespace


IProcessFlowTable.Controller Property

IProcessFlowTableController Property

Gets the instance of IProcessController that owns this IProcessFlowTable.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessController Controller { get; }
property IProcessController^ Controller {
    IProcessController^ get ();
}

Property Value

Type: IProcessController
See Also

Reference

IProcessFlowTable Interface
VisualComponents.Create3D Namespace


IProcessFlowTable.Sequences Property

IProcessFlowTableSequences Property

Gets the collection of all IProcessSequence instances.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<IProcessSequence> Sequences { get; }
property IReadOnlyList<IProcessSequence^>^ Sequences {
    IReadOnlyList<IProcessSequence^>^ get ();
}

Property Value

Type: IReadOnlyListIProcessSequence
See Also

Reference

IProcessFlowTable Interface
VisualComponents.Create3D Namespace


IProcessFlowTable Methods

The IProcessFlowTable type exposes the following members.

Methods
 | Name | Description
Public method | CopySequenceFrom | Copies the sequence defined for the given source IProcessFlowGroup and adds it to this IProcessFlowTable, for the target IProcessFlowGroup.
Public method | CreateSequence | Creates a new IProcessSequence for the given IProcessFlowGroup.
Public method | DeleteSequence | Deletes the IProcessSequence of the given IProcessFlowGroup.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetSequence | Returns the IProcessSequence instance associated with the given IProcessFlowGroup, without getting the whole Sequences collection, or null if no such sequence is found.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProcessFlowTable Interface
VisualComponents.Create3D Namespace


IProcessFlowTable.CopySequenceFrom Method

IProcessFlowTableCopySequenceFrom Method

Copies the sequence defined for the given source IProcessFlowGroup and adds it to this IProcessFlowTable, for the target IProcessFlowGroup.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessSequence CopySequenceFrom(
    IProcessFlowGroup source,
    IProcessFlowGroup target
)
IProcessSequence^ CopySequenceFrom(
    IProcessFlowGroup^ source,
    IProcessFlowGroup^ target
)

Parameters

source
Type: VisualComponents.Create3DIProcessFlowGroup
Flow group whose sequence is to be copied.
target
Type: VisualComponents.Create3DIProcessFlowGroup
Flow group to which the newly-copied sequence will be associated.

Return Value

Type: IProcessSequence
Copied sequence.
Exceptions
Exception | Condition
ArgumentNullException | Occurs when source or target parameter is null.
InvalidOperationException | Occurs when a sequence for the given target exists already.
See Also

Reference

IProcessFlowTable Interface
VisualComponents.Create3D Namespace


IProcessFlowTable.CreateSequence Method

IProcessFlowTableCreateSequence Method

Creates a new IProcessSequence for the given IProcessFlowGroup.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessSequence CreateSequence(
    IProcessFlowGroup group
)
IProcessSequence^ CreateSequence(
    IProcessFlowGroup^ group
)

Parameters

group
Type: VisualComponents.Create3DIProcessFlowGroup
Flow group for which the sequence is to be created.

Return Value

Type: IProcessSequence
Created sequence.
Exceptions
Exception | Condition
ArgumentNullException | Occurs when product type is null.
ArgumentException | Occurs if the group does not belong to the same process controller than this sequence
InvalidOperationException | Occurs when sequence for the given group exists already.
See Also

Reference

IProcessFlowTable Interface
VisualComponents.Create3D Namespace


IProcessFlowTable.DeleteSequence Method

IProcessFlowTableDeleteSequence Method

Deletes the IProcessSequence of the given IProcessFlowGroup.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteSequence(
    IProcessFlowGroup group
)
void DeleteSequence(
    IProcessFlowGroup^ group
)

Parameters

group
Type: VisualComponents.Create3DIProcessFlowGroup
Flow group whose sequence is to be deleted.
Exceptions
Exception | Condition
ArgumentNullException | Occurs when the given group is null.
ArgumentException | Occurs if the group does not belong to the same process controller than this sequence
See Also

Reference

IProcessFlowTable Interface
VisualComponents.Create3D Namespace


IProcessFlowTable.GetSequence Method

IProcessFlowTableGetSequence Method

Returns the IProcessSequence instance associated with the given IProcessFlowGroup, without getting the whole Sequences collection, or null if no such sequence is found.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessSequence GetSequence(
    IProcessFlowGroup group
)
IProcessSequence^ GetSequence(
    IProcessFlowGroup^ group
)

Parameters

group
Type: VisualComponents.Create3DIProcessFlowGroup
Flow group to use for finding the sequence.

Return Value

Type: IProcessSequence

[Missing <returns> documentation for "M:VisualComponents.Create3D.IProcessFlowTable.GetSequence(VisualComponents.Create3D.IProcessFlowGroup)"]

Exceptions
Exception | Condition
ArgumentNullException | Occurs if the given group is null.
See Also

Reference

IProcessFlowTable Interface
VisualComponents.Create3D Namespace


IProcessFlowTable Events

The IProcessFlowTable type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | SequenceAdded | Event that occurs when a new instance of IProcessSequence has been added to this IProcessFlowTable.
Public event | SequenceRemoving | Event that occurs when the instance of IProcessSequence is being deleted from this IProcessFlowTable.
Top
See Also

Reference

IProcessFlowTable Interface
VisualComponents.Create3D Namespace


IProcessFlowTable.SequenceAdded Event

IProcessFlowTableSequenceAdded Event

Event that occurs when a new instance of IProcessSequence has been added to this IProcessFlowTable.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<SequenceAddedEventArgs> SequenceAdded
 event EventHandler<SequenceAddedEventArgs^>^ SequenceAdded {
    void add (EventHandler<SequenceAddedEventArgs^>^ value);
    void remove (EventHandler<SequenceAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerSequenceAddedEventArgs
See Also

Reference

IProcessFlowTable Interface
VisualComponents.Create3D Namespace


IProcessFlowTable.SequenceRemoving Event

IProcessFlowTableSequenceRemoving Event

Event that occurs when the instance of IProcessSequence is being deleted from this IProcessFlowTable.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<SequenceRemovingEventArgs> SequenceRemoving
 event EventHandler<SequenceRemovingEventArgs^>^ SequenceRemoving {
    void add (EventHandler<SequenceRemovingEventArgs^>^ value);
    void remove (EventHandler<SequenceRemovingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerSequenceRemovingEventArgs
See Also

Reference

IProcessFlowTable Interface
VisualComponents.Create3D Namespace


IProcessGroup Interface

IProcessGroup is an automatic grouping of all IProcessRoutine implementations that have the same identifier (ProcessId).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessGroup : IWrapper,
    IDisposable
public interface class IProcessGroup : IWrapper,
    IDisposable

The IProcessGroup type exposes the following members.

Properties
 | Name | Description
Public property | Implementations | Gets the current implementations of this IProcessRoutine.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Manager | Gets the IProcessManager that owns this group object.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProcessId | Gets the common id / name of the IProcessRoutine implementations.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks

The IProcessRoutine implementations are not owned but only referenced by this object.

The parent IProcessManager provides events for tracking changes.

Note that an IProcessGroup is automatically deleted when it becomes empty.

See Also

Reference

VisualComponents.Create3D Namespace


IProcessGroup Properties

The IProcessGroup type exposes the following members.

Properties
 | Name | Description
Public property | Implementations | Gets the current implementations of this IProcessRoutine.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Manager | Gets the IProcessManager that owns this group object.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProcessId | Gets the common id / name of the IProcessRoutine implementations.
Top
See Also

Reference

IProcessGroup Interface
VisualComponents.Create3D Namespace


IProcessGroup.Implementations Property

IProcessGroupImplementations Property

Gets the current implementations of this IProcessRoutine.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<IProcessRoutine> Implementations { get; }
property IReadOnlyList<IProcessRoutine^>^ Implementations {
    IReadOnlyList<IProcessRoutine^>^ get ();
}

Property Value

Type: IReadOnlyListIProcessRoutine
See Also

Reference

IProcessGroup Interface
VisualComponents.Create3D Namespace


IProcessGroup.Manager Property

IProcessGroupManager Property

Gets the IProcessManager that owns this group object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessManager Manager { get; }
property IProcessManager^ Manager {
    IProcessManager^ get ();
}

Property Value

Type: IProcessManager
See Also

Reference

IProcessGroup Interface
VisualComponents.Create3D Namespace


IProcessGroup.ProcessId Property

IProcessGroupProcessId Property

Gets the common id / name of the IProcessRoutine implementations.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ProcessId { get; }
property String^ ProcessId {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IProcessGroup Interface
VisualComponents.Create3D Namespace


IProcessGroup Methods

The IProcessGroup type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProcessGroup Interface
VisualComponents.Create3D Namespace


IProcessGroup Events

The IProcessGroup type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
See Also

Reference

IProcessGroup Interface
VisualComponents.Create3D Namespace


IProcessHandler Interface

An interface for process handlers.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessHandler : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IProcessHandler : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IProcessHandler type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Icon | Process icon.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Process | The name of the process.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | NotifyStatementModified | Invokes OnStatementModified in python script.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProcessHandler Properties

The IProcessHandler type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Icon | Process icon.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Process | The name of the process.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IProcessHandler Interface
VisualComponents.Create3D Namespace


IProcessHandler.Icon Property

IProcessHandlerIcon Property

Process icon.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Bitmap Icon { get; set; }
property Bitmap^ Icon {
    Bitmap^ get ();
    void set (Bitmap^ value);
}

Property Value

Type: Bitmap
See Also

Reference

IProcessHandler Interface
VisualComponents.Create3D Namespace


IProcessHandler.Process Property

IProcessHandlerProcess Property

The name of the process.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Process { get; set; }
property String^ Process {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IProcessHandler Interface
VisualComponents.Create3D Namespace


IProcessHandler Methods

The IProcessHandler type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | NotifyStatementModified | Invokes OnStatementModified in python script.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProcessHandler Interface
VisualComponents.Create3D Namespace


IProcessHandler.NotifyStatementModified Method

IProcessHandlerNotifyStatementModified Method

Invokes OnStatementModified in python script.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void NotifyStatementModified(
    IPositionStatement statement
)
void NotifyStatementModified(
    IPositionStatement^ statement
)

Parameters

statement
Type: VisualComponents.Create3DIPositionStatement
See Also

Reference

IProcessHandler Interface
VisualComponents.Create3D Namespace


IProcessHandler Events

The IProcessHandler type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IProcessHandler Interface
VisualComponents.Create3D Namespace


IProcessIfStatement Interface

Executes ThenScope when ConditionExpression evaluates to True or ElseScope when it evaluates to False.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessIfStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IProcessIfStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IProcessIfStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConditionExpression | Gets or sets condition expression to evaluate when the statement is executed.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ElseScope | Gets IStatementScope to execute when ConditionExpression evaluates to False.
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | ThenScope | Gets IStatementScope to execute when ConditionExpression evaluates to True.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
If ConditionExpression is invalid neither ThenScope nor ElseScope are executed.
See Also

Reference

VisualComponents.Create3D Namespace


IProcessIfStatement Properties

The IProcessIfStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConditionExpression | Gets or sets condition expression to evaluate when the statement is executed.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ElseScope | Gets IStatementScope to execute when ConditionExpression evaluates to False.
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | ThenScope | Gets IStatementScope to execute when ConditionExpression evaluates to True.
Top
See Also

Reference

IProcessIfStatement Interface
VisualComponents.Create3D Namespace


IProcessIfStatement.ConditionExpression Property

IProcessIfStatementConditionExpression Property

Gets or sets condition expression to evaluate when the statement is executed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ConditionExpression { get; set; }
property String^ ConditionExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
This expression has access to UPM variables stored in IProcessRoutine.
See Also

Reference

IProcessIfStatement Interface
VisualComponents.Create3D Namespace


IProcessIfStatement.ElseScope Property

IProcessIfStatementElseScope Property

Gets IStatementScope to execute when ConditionExpression evaluates to False.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatementScope ElseScope { get; }
property IStatementScope^ ElseScope {
    IStatementScope^ get ();
}

Property Value

Type: IStatementScope
See Also

Reference

IProcessIfStatement Interface
VisualComponents.Create3D Namespace


IProcessIfStatement.ThenScope Property

IProcessIfStatementThenScope Property

Gets IStatementScope to execute when ConditionExpression evaluates to True.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatementScope ThenScope { get; }
property IStatementScope^ ThenScope {
    IStatementScope^ get ();
}

Property Value

Type: IStatementScope
See Also

Reference

IProcessIfStatement Interface
VisualComponents.Create3D Namespace


IProcessIfStatement Methods

The IProcessIfStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProcessIfStatement Interface
VisualComponents.Create3D Namespace


IProcessIfStatement Events

The IProcessIfStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IProcessIfStatement Interface
VisualComponents.Create3D Namespace


IProcessIntegerTableStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessIntegerTableStatement : IProcessTableStatement,
    IProcessRuleStatement, IStatement, INamed, IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, IApiType, ICloneable<IStatement>,
    ICloneable, IStatementScope, IInterpolatable
public interface class IProcessIntegerTableStatement : IProcessTableStatement,
    IProcessRuleStatement, IStatement, INamed, IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, IApiType, ICloneable<IStatement^>,
    ICloneable, IStatementScope, IInterpolatable

The IProcessIntegerTableStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProcessIntegerTableStatement Properties

The IProcessIntegerTableStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
See Also

Reference

IProcessIntegerTableStatement Interface
VisualComponents.Create3D Namespace


IProcessIntegerTableStatement Methods

The IProcessIntegerTableStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProcessIntegerTableStatement Interface
VisualComponents.Create3D Namespace


IProcessIntegerTableStatement Events

The IProcessIntegerTableStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IProcessIntegerTableStatement Interface
VisualComponents.Create3D Namespace


IProcessManager Interface

The IProcessManager service automatically creates, updates and removes IProcessGroups when IProcessRoutines are added, renamed or removed within its parent IProcessController.

The IProcessGroups can be used to easily find all implementations of a IProcessRoutine.

IProcessRoutine implementations are owned by IProcessExecutor instances.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessManager : IWrapper,
    IDisposable
public interface class IProcessManager : IWrapper,
    IDisposable

The IProcessManager type exposes the following members.

Properties
 | Name | Description
Public property | IsValid | (Inherited from IWrapper.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProcessGroups | Gets the collection of IProcessGroup instances that belong to this IProcessManager.
Top
Methods
 | Name | Description
Public method | ChangeProcessGroupId | Renames all the processes with the given currentId to newId.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindProcessGroup | Tries to find the instance of IProcessGroup with the given processId. Return the found group, or null if not found.
Public method | GetHashCode | (Inherited from IWrapper.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | ProcessAdded | Event that occurs when a new process implementation has been added to this IProcessManager.
Public event | ProcessGroupIdChanged | Event that occurs when all implementations of processes in a IProcessGroup were renamed./>.
Public event | ProcessRemoved | Event that occurs when a process implementation has been removed from this IProcessManager.
Public event | ProcessRemoving | Event that occurs when a process implementation is being removed from this IProcessManager.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProcessManager Properties

The IProcessManager type exposes the following members.

Properties
 | Name | Description
Public property | IsValid | (Inherited from IWrapper.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProcessGroups | Gets the collection of IProcessGroup instances that belong to this IProcessManager.
Top
See Also

Reference

IProcessManager Interface
VisualComponents.Create3D Namespace


IProcessManager.ProcessGroups Property

IProcessManagerProcessGroups Property

Gets the collection of IProcessGroup instances that belong to this IProcessManager.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<IProcessGroup> ProcessGroups { get; }
property IReadOnlyList<IProcessGroup^>^ ProcessGroups {
    IReadOnlyList<IProcessGroup^>^ get ();
}

Property Value

Type: IReadOnlyListIProcessGroup
See Also

Reference

IProcessManager Interface
VisualComponents.Create3D Namespace


IProcessManager Methods

The IProcessManager type exposes the following members.

Methods
 | Name | Description
Public method | ChangeProcessGroupId | Renames all the processes with the given currentId to newId.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindProcessGroup | Tries to find the instance of IProcessGroup with the given processId. Return the found group, or null if not found.
Public method | GetHashCode | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProcessManager Interface
VisualComponents.Create3D Namespace


IProcessManager.ChangeProcessGroupId Method

IProcessManagerChangeProcessGroupId Method

Renames all the processes with the given currentId to newId.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ChangeProcessGroupId(
    string currentId,
    string newId
)
void ChangeProcessGroupId(
    String^ currentId,
    String^ newId
)

Parameters

currentId
Type: SystemString
Id of the processes that are to be renamed.
newId
Type: SystemString
New id.
Exceptions
Exception | Condition
ArgumentNullException | Occurs when currentId is null.
ArgumentException | Occurs when newId is null, empty or whitespace.
InvalidOperationException | Occurs when any of the executors of the Process implementations already also have a Process with the new id. No implementations get renamed if this happens.
See Also

Reference

IProcessManager Interface
VisualComponents.Create3D Namespace


IProcessManager.FindProcessGroup Method

IProcessManagerFindProcessGroup Method

Tries to find the instance of IProcessGroup with the given processId. Return the found group, or null if not found.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessGroup FindProcessGroup(
    string processGroupId
)
IProcessGroup^ FindProcessGroup(
    String^ processGroupId
)

Parameters

processGroupId
Type: SystemString
Process ID.

Return Value

Type: IProcessGroup

[Missing <returns> documentation for "M:VisualComponents.Create3D.IProcessManager.FindProcessGroup(System.String)"]

Exceptions
Exception | Condition
ArgumentNullException | Occurs when given processId is null.
See Also

Reference

IProcessManager Interface
VisualComponents.Create3D Namespace


IProcessManager Events

The IProcessManager type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | ProcessAdded | Event that occurs when a new process implementation has been added to this IProcessManager.
Public event | ProcessGroupIdChanged | Event that occurs when all implementations of processes in a IProcessGroup were renamed./>.
Public event | ProcessRemoved | Event that occurs when a process implementation has been removed from this IProcessManager.
Public event | ProcessRemoving | Event that occurs when a process implementation is being removed from this IProcessManager.
Top
See Also

Reference

IProcessManager Interface
VisualComponents.Create3D Namespace


IProcessManager.ProcessAdded Event

IProcessManagerProcessAdded Event

Event that occurs when a new process implementation has been added to this IProcessManager.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ProcessAddedEventArgs> ProcessAdded
 event EventHandler<ProcessAddedEventArgs^>^ ProcessAdded {
    void add (EventHandler<ProcessAddedEventArgs^>^ value);
    void remove (EventHandler<ProcessAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerProcessAddedEventArgs
See Also

Reference

IProcessManager Interface
VisualComponents.Create3D Namespace


IProcessManager.ProcessGroupIdChanged Event

IProcessManagerProcessGroupIdChanged Event

Event that occurs when all implementations of processes in a IProcessGroup were renamed./>.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ProcessGroupIdChangedEventArgs> ProcessGroupIdChanged
 event EventHandler<ProcessGroupIdChangedEventArgs^>^ ProcessGroupIdChanged {
    void add (EventHandler<ProcessGroupIdChangedEventArgs^>^ value);
    void remove (EventHandler<ProcessGroupIdChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerProcessGroupIdChangedEventArgs
See Also

Reference

IProcessManager Interface
VisualComponents.Create3D Namespace


IProcessManager.ProcessRemoved Event

IProcessManagerProcessRemoved Event

Event that occurs when a process implementation has been removed from this IProcessManager.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ProcessRemovedEventArgs> ProcessRemoved
 event EventHandler<ProcessRemovedEventArgs^>^ ProcessRemoved {
    void add (EventHandler<ProcessRemovedEventArgs^>^ value);
    void remove (EventHandler<ProcessRemovedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerProcessRemovedEventArgs
See Also

Reference

IProcessManager Interface
VisualComponents.Create3D Namespace


IProcessManager.ProcessRemoving Event

IProcessManagerProcessRemoving Event

Event that occurs when a process implementation is being removed from this IProcessManager.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ProcessRemovingEventArgs> ProcessRemoving
 event EventHandler<ProcessRemovingEventArgs^>^ ProcessRemoving {
    void add (EventHandler<ProcessRemovingEventArgs^>^ value);
    void remove (EventHandler<ProcessRemovingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerProcessRemovingEventArgs
See Also

Reference

IProcessManager Interface
VisualComponents.Create3D Namespace


IProcessNormalStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessNormalStatement : IProcessRuleStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement>, ICloneable,
    IStatementScope, IInterpolatable
public interface class IProcessNormalStatement : IProcessRuleStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement^>, ICloneable,
    IStatementScope, IInterpolatable

The IProcessNormalStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | Average |
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | Deviation |
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | RandomSeed |
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProcessNormalStatement Properties

The IProcessNormalStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | Average |
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | Deviation |
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | RandomSeed |
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
See Also

Reference

IProcessNormalStatement Interface
VisualComponents.Create3D Namespace


IProcessNormalStatement.Average Property

IProcessNormalStatementAverage Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Average { get; set; }
property double Average {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IProcessNormalStatement Interface
VisualComponents.Create3D Namespace


IProcessNormalStatement.Deviation Property

IProcessNormalStatementDeviation Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Deviation { get; set; }
property double Deviation {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IProcessNormalStatement Interface
VisualComponents.Create3D Namespace


IProcessNormalStatement.RandomSeed Property

IProcessNormalStatementRandomSeed Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int RandomSeed { get; set; }
property int RandomSeed {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IProcessNormalStatement Interface
VisualComponents.Create3D Namespace


IProcessNormalStatement Methods

The IProcessNormalStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProcessNormalStatement Interface
VisualComponents.Create3D Namespace


IProcessNormalStatement Events

The IProcessNormalStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IProcessNormalStatement Interface
VisualComponents.Create3D Namespace


IProcessPointSensor Interface

An interface for process point sensor behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessPointSensor : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IProcessPointSensor : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IProcessPointSensor type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Rules | Returns the IRoutine instance containing the rules.
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | ConvertOldRuleToNewRule | Converts and rules created prior to 4.0 version to new rule mechanism.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProcessPointSensor Properties

The IProcessPointSensor type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Rules | Returns the IRoutine instance containing the rules.
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IProcessPointSensor Interface
VisualComponents.Create3D Namespace


IProcessPointSensor.Rules Property

IProcessPointSensorRules Property

Returns the IRoutine instance containing the rules.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRoutine Rules { get; }
property IRoutine^ Rules {
    IRoutine^ get ();
}

Property Value

Type: IRoutine
See Also

Reference

IProcessPointSensor Interface
VisualComponents.Create3D Namespace


IProcessPointSensor Methods

The IProcessPointSensor type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | ConvertOldRuleToNewRule | Converts and rules created prior to 4.0 version to new rule mechanism.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProcessPointSensor Interface
VisualComponents.Create3D Namespace


IProcessPointSensor.ConvertOldRuleToNewRule Method

IProcessPointSensorConvertOldRuleToNewRule Method

Converts and rules created prior to 4.0 version to new rule mechanism.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ConvertOldRuleToNewRule()
void ConvertOldRuleToNewRule()
See Also

Reference

IProcessPointSensor Interface
VisualComponents.Create3D Namespace


IProcessPointSensor Events

The IProcessPointSensor type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IProcessPointSensor Interface
VisualComponents.Create3D Namespace


IProcessPrintStatement Interface

Prints result of MessageExpression to the Output panel.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessPrintStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IProcessPrintStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IProcessPrintStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | MessageExpression | Gets or sets the expression defining the message to be printed when the statement is executed.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | PrependHeader | Defines whether default header should be prepended to the message.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProcessPrintStatement Properties

The IProcessPrintStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | MessageExpression | Gets or sets the expression defining the message to be printed when the statement is executed.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | PrependHeader | Defines whether default header should be prepended to the message.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
See Also

Reference

IProcessPrintStatement Interface
VisualComponents.Create3D Namespace


IProcessPrintStatement.MessageExpression Property

IProcessPrintStatementMessageExpression Property

Gets or sets the expression defining the message to be printed when the statement is executed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string MessageExpression { get; set; }
property String^ MessageExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
This expression has access to UPM variables stored in IProcessRoutine.
See Also

Reference

IProcessPrintStatement Interface
VisualComponents.Create3D Namespace


IProcessPrintStatement.PrependHeader Property

IProcessPrintStatementPrependHeader Property

Defines whether default header should be prepended to the message.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool PrependHeader { get; set; }
property bool PrependHeader {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
Format of the header to be prepended is "ComponentName::ProcessExecutorName::ProcessRoutineName:".
See Also

Reference

IProcessPrintStatement Interface
VisualComponents.Create3D Namespace


IProcessPrintStatement Methods

The IProcessPrintStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProcessPrintStatement Interface
VisualComponents.Create3D Namespace


IProcessPrintStatement Events

The IProcessPrintStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IProcessPrintStatement Interface
VisualComponents.Create3D Namespace


IProcessRealTableStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessRealTableStatement : IProcessTableStatement,
    IProcessRuleStatement, IStatement, INamed, IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, IApiType, ICloneable<IStatement>,
    ICloneable, IStatementScope, IInterpolatable
public interface class IProcessRealTableStatement : IProcessTableStatement,
    IProcessRuleStatement, IStatement, INamed, IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, IApiType, ICloneable<IStatement^>,
    ICloneable, IStatementScope, IInterpolatable

The IProcessRealTableStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProcessRealTableStatement Properties

The IProcessRealTableStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
See Also

Reference

IProcessRealTableStatement Interface
VisualComponents.Create3D Namespace


IProcessRealTableStatement Methods

The IProcessRealTableStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProcessRealTableStatement Interface
VisualComponents.Create3D Namespace


IProcessRealTableStatement Events

The IProcessRealTableStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IProcessRealTableStatement Interface
VisualComponents.Create3D Namespace


IProcessRequirementsRoutine Interface

A IProcessRequirementsRoutine holds the IRequirementStatements that need to pass before the IProcessRoutine can be started.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessRequirementsRoutine : IRoutine,
    IPropertyContainer, IBatchModeObject, IStatementScope, IInterpolatable, IApiType,
    INamed, ICloneable<IRoutine>, ICloneable, IWrapper,
    IDisposable
public interface class IProcessRequirementsRoutine : IRoutine,
    IPropertyContainer, IBatchModeObject, IStatementScope, IInterpolatable, IApiType,
    INamed, ICloneable<IRoutine^>, ICloneable, IWrapper,
    IDisposable

The IProcessRequirementsRoutine type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsPersistent | Gets or sets the persistency flag for this routine. (Inherited from IRoutine.)
Public property | IsSystem | Defines if the routine is managed by the application. System routines cannot be deleted or created by the user. (Inherited from IRoutine.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Program | Gets the owner program. (Inherited from IRoutine.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProcessRequirementsRoutine Properties

The IProcessRequirementsRoutine type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsPersistent | Gets or sets the persistency flag for this routine. (Inherited from IRoutine.)
Public property | IsSystem | Defines if the routine is managed by the application. System routines cannot be deleted or created by the user. (Inherited from IRoutine.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Program | Gets the owner program. (Inherited from IRoutine.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
See Also

Reference

IProcessRequirementsRoutine Interface
VisualComponents.Create3D Namespace


IProcessRequirementsRoutine Methods

The IProcessRequirementsRoutine type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProcessRequirementsRoutine Interface
VisualComponents.Create3D Namespace


IProcessRequirementsRoutine Events

The IProcessRequirementsRoutine type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IProcessRequirementsRoutine Interface
VisualComponents.Create3D Namespace


IProcessRoutine Interface

IProcessRoutine is a routine in the IProcessExecutor’s program that implements a Process Modeling process.

It has an additional internal IRoutine for the special IRequirementStatements that control when this process’ execution starts.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessRoutine : IRoutine,
    IPropertyContainer, IBatchModeObject, IStatementScope, IInterpolatable, IApiType,
    INamed, ICloneable<IRoutine>, ICloneable, IWrapper,
    IDisposable
public interface class IProcessRoutine : IRoutine,
    IPropertyContainer, IBatchModeObject, IStatementScope, IInterpolatable, IApiType,
    INamed, ICloneable<IRoutine^>, ICloneable, IWrapper,
    IDisposable

The IProcessRoutine type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsPersistent | Gets or sets the persistency flag for this routine. (Inherited from IRoutine.)
Public property | IsSystem | Defines if the routine is managed by the application. System routines cannot be deleted or created by the user. (Inherited from IRoutine.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Program | Gets the owner program. (Inherited from IRoutine.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Requirements | Gets the instance of IProcessRequirementsRoutine containing all the requirements that need to be met before this IProcessRoutine can be started.
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProcessRoutine Properties

The IProcessRoutine type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsPersistent | Gets or sets the persistency flag for this routine. (Inherited from IRoutine.)
Public property | IsSystem | Defines if the routine is managed by the application. System routines cannot be deleted or created by the user. (Inherited from IRoutine.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Program | Gets the owner program. (Inherited from IRoutine.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Requirements | Gets the instance of IProcessRequirementsRoutine containing all the requirements that need to be met before this IProcessRoutine can be started.
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
See Also

Reference

IProcessRoutine Interface
VisualComponents.Create3D Namespace


IProcessRoutine.Requirements Property

IProcessRoutineRequirements Property

Gets the instance of IProcessRequirementsRoutine containing all the requirements that need to be met before this IProcessRoutine can be started.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessRequirementsRoutine Requirements { get; }
property IProcessRequirementsRoutine^ Requirements {
    IProcessRequirementsRoutine^ get ();
}

Property Value

Type: IProcessRequirementsRoutine
See Also

Reference

IProcessRoutine Interface
VisualComponents.Create3D Namespace


IProcessRoutine Methods

The IProcessRoutine type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProcessRoutine Interface
VisualComponents.Create3D Namespace


IProcessRoutine Events

The IProcessRoutine type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IProcessRoutine Interface
VisualComponents.Create3D Namespace


IProcessRuleLineStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessRuleLineStatement : IProcessRuleStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement>, ICloneable,
    IStatementScope, IInterpolatable
public interface class IProcessRuleLineStatement : IProcessRuleStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement^>, ICloneable,
    IStatementScope, IInterpolatable

The IProcessRuleLineStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProcessTime |
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | UsesProcessTime |
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProcessRuleLineStatement Properties

The IProcessRuleLineStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProcessTime |
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | UsesProcessTime |
Top
See Also

Reference

IProcessRuleLineStatement Interface
VisualComponents.Create3D Namespace


IProcessRuleLineStatement.ProcessTime Property

IProcessRuleLineStatementProcessTime Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double ProcessTime { get; set; }
property double ProcessTime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IProcessRuleLineStatement Interface
VisualComponents.Create3D Namespace


IProcessRuleLineStatement.UsesProcessTime Property

IProcessRuleLineStatementUsesProcessTime Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool UsesProcessTime { get; }
property bool UsesProcessTime {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IProcessRuleLineStatement Interface
VisualComponents.Create3D Namespace


IProcessRuleLineStatement Methods

The IProcessRuleLineStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProcessRuleLineStatement Interface
VisualComponents.Create3D Namespace


IProcessRuleLineStatement Events

The IProcessRuleLineStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IProcessRuleLineStatement Interface
VisualComponents.Create3D Namespace


IProcessRuleStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessRuleStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable, IStatementScope,
    IInterpolatable
public interface class IProcessRuleStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable, IStatementScope,
    IInterpolatable

The IProcessRuleStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProcessRuleStatement Properties

The IProcessRuleStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
See Also

Reference

IProcessRuleStatement Interface
VisualComponents.Create3D Namespace


IProcessRuleStatement Methods

The IProcessRuleStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProcessRuleStatement Interface
VisualComponents.Create3D Namespace


IProcessRuleStatement Events

The IProcessRuleStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IProcessRuleStatement Interface
VisualComponents.Create3D Namespace


IProcessSequence Interface

Defines the sequence of process steps (see IProcessGroup) that any IProductType belonging to a particular IProcessFlowGroup shall follow in the Process Modeling system.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessSequence : IList<IProcessGroup>,
    ICollection<IProcessGroup>, IEnumerable<IProcessGroup>, IEnumerable,
    INotifyCollectionChanged, IWrapper, IDisposable
public interface class IProcessSequence : IList<IProcessGroup^>,
    ICollection<IProcessGroup^>, IEnumerable<IProcessGroup^>, IEnumerable,
    INotifyCollectionChanged, IWrapper, IDisposable

The IProcessSequence type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionIProcessGroup .)
Public property | FlowTable | Gets the IProcessFlowTable that owns this IProcessSequence.
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionIProcessGroup .)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListIProcessGroup .)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | TargetGroup | Gets the IProcessFlowGroup for which this IProcessFlowGroup is defined for.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionIProcessGroup .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionIProcessGroup .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionIProcessGroup .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionIProcessGroup .)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableIProcessGroup .)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListIProcessGroup .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListIProcessGroup .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionIProcessGroup .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListIProcessGroup .)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when the collection changes. (Inherited from INotifyCollectionChanged.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachIProcessGroup | Enumerate a cached collection performing the specified action on each item. (Defined by ForEachHelper.)
Public Extension Method | HasMoreThanIProcessGroup | (Defined by EnumerableHelper.)
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Public Extension Method | ToObservableCollectionIProcessGroup | (Defined by Extensions.)
Public Extension Method | ToObservableCollectionExIProcessGroup | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProcessSequence Properties

The IProcessSequence type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollectionIProcessGroup .)
Public property | FlowTable | Gets the IProcessFlowTable that owns this IProcessSequence.
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollectionIProcessGroup .)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IListIProcessGroup .)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | TargetGroup | Gets the IProcessFlowGroup for which this IProcessFlowGroup is defined for.
Top
See Also

Reference

IProcessSequence Interface
VisualComponents.Create3D Namespace


IProcessSequence.FlowTable Property

IProcessSequenceFlowTable Property

Gets the IProcessFlowTable that owns this IProcessSequence.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessFlowTable FlowTable { get; }
property IProcessFlowTable^ FlowTable {
    IProcessFlowTable^ get ();
}

Property Value

Type: IProcessFlowTable
See Also

Reference

IProcessSequence Interface
VisualComponents.Create3D Namespace


IProcessSequence.TargetGroup Property

IProcessSequenceTargetGroup Property

Gets the IProcessFlowGroup for which this IProcessFlowGroup is defined for.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessFlowGroup TargetGroup { get; }
property IProcessFlowGroup^ TargetGroup {
    IProcessFlowGroup^ get ();
}

Property Value

Type: IProcessFlowGroup
See Also

Reference

IProcessSequence Interface
VisualComponents.Create3D Namespace


IProcessSequence Methods

The IProcessSequence type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollectionIProcessGroup .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollectionIProcessGroup .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollectionIProcessGroup .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollectionIProcessGroup .)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerableIProcessGroup .)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IListIProcessGroup .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IListIProcessGroup .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollectionIProcessGroup .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IListIProcessGroup .)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachIProcessGroup | Enumerate a cached collection performing the specified action on each item. (Defined by ForEachHelper.)
Public Extension Method | HasMoreThanIProcessGroup | (Defined by EnumerableHelper.)
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Public Extension Method | ToObservableCollectionIProcessGroup | (Defined by Extensions.)
Public Extension Method | ToObservableCollectionExIProcessGroup | (Defined by Extensions.)
Top
See Also

Reference

IProcessSequence Interface
VisualComponents.Create3D Namespace


IProcessSequence Events

The IProcessSequence type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when the collection changes. (Inherited from INotifyCollectionChanged.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
See Also

Reference

IProcessSequence Interface
VisualComponents.Create3D Namespace


IProcessStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessStatement : IPositionStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement>, ICloneable,
    IInterpolatable, IPositionFrameContainer
public interface class IProcessStatement : IPositionStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement^>, ICloneable,
    IInterpolatable, IPositionFrameContainer

The IProcessStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | Base | Gets or sets the robot base for which the positions in this IPositionStatement are attached to. (Inherited from IPositionStatement.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | Description |
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | ExternalTcp | Gets or sets external TCP mode. (Inherited from IPositionStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Positions | Gets all the positions in this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public property | Process |
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | Tool | Gets or sets the robot tool (Inherited from IPositionStatement.)
Top
Methods
 | Name | Description
Public method | AddPositionFromProgram | Adds an existing IPositionFrame from IProgram to this IPositionStatement. (Inherited from IPositionStatement.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ClearPositions | Clears all IPositionFrame instances from this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreatePosition | Creates a new IPositionFrame instance and adds it to this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeletePosition | Deletes the given IPositionFrame from this IPositionFrameContainer and deletes it (see remarks). (Inherited from IPositionFrameContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | ExecuteImmediatePosition | Moves the robot to the given position. See also: IStatement.ExecuteImmediate(). (Inherited from IPositionStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | HighlightAll | Highlights all the positions in this IPositionStatement. (Inherited from IPositionStatement.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | ReadIn | Reads in the current state of from the associated instance of IServoController. (Inherited from IPositionStatement.)
Public method | SetExternalTcp | Gets or sets external TCP mode by keeping relative frame positions. (Inherited from IPositionStatement.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PositionAdded | Occurs when a new instance of IPositionFrame has been added to this instance of IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public event | PositionRemoving | Occurs when an instance of IPositionFrame is being removed from this instance of IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public event | PositionTransformationChanged | Occurs when transformation of an instance of IPositionFrame in this instance of IPositionStatement changes. (Inherited from IPositionStatement.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProcessStatement Properties

The IProcessStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | Base | Gets or sets the robot base for which the positions in this IPositionStatement are attached to. (Inherited from IPositionStatement.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | Description |
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | ExternalTcp | Gets or sets external TCP mode. (Inherited from IPositionStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Positions | Gets all the positions in this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public property | Process |
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | Tool | Gets or sets the robot tool (Inherited from IPositionStatement.)
Top
See Also

Reference

IProcessStatement Interface
VisualComponents.Create3D Namespace


IProcessStatement.Description Property

IProcessStatementDescription Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Description { get; set; }
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IProcessStatement Interface
VisualComponents.Create3D Namespace


IProcessStatement.Process Property

IProcessStatementProcess Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessHandler Process { get; set; }
property IProcessHandler^ Process {
    IProcessHandler^ get ();
    void set (IProcessHandler^ value);
}

Property Value

Type: IProcessHandler
See Also

Reference

IProcessStatement Interface
VisualComponents.Create3D Namespace


IProcessStatement Methods

The IProcessStatement type exposes the following members.

Methods
 | Name | Description
Public method | AddPositionFromProgram | Adds an existing IPositionFrame from IProgram to this IPositionStatement. (Inherited from IPositionStatement.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ClearPositions | Clears all IPositionFrame instances from this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreatePosition | Creates a new IPositionFrame instance and adds it to this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeletePosition | Deletes the given IPositionFrame from this IPositionFrameContainer and deletes it (see remarks). (Inherited from IPositionFrameContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | ExecuteImmediatePosition | Moves the robot to the given position. See also: IStatement.ExecuteImmediate(). (Inherited from IPositionStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | HighlightAll | Highlights all the positions in this IPositionStatement. (Inherited from IPositionStatement.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | ReadIn | Reads in the current state of from the associated instance of IServoController. (Inherited from IPositionStatement.)
Public method | SetExternalTcp | Gets or sets external TCP mode by keeping relative frame positions. (Inherited from IPositionStatement.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProcessStatement Interface
VisualComponents.Create3D Namespace


IProcessStatement Events

The IProcessStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PositionAdded | Occurs when a new instance of IPositionFrame has been added to this instance of IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public event | PositionRemoving | Occurs when an instance of IPositionFrame is being removed from this instance of IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public event | PositionTransformationChanged | Occurs when transformation of an instance of IPositionFrame in this instance of IPositionStatement changes. (Inherited from IPositionStatement.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IProcessStatement Interface
VisualComponents.Create3D Namespace


IProcessStringTableStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessStringTableStatement : IProcessTableStatement,
    IProcessRuleStatement, IStatement, INamed, IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, IApiType, ICloneable<IStatement>,
    ICloneable, IStatementScope, IInterpolatable
public interface class IProcessStringTableStatement : IProcessTableStatement,
    IProcessRuleStatement, IStatement, INamed, IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, IApiType, ICloneable<IStatement^>,
    ICloneable, IStatementScope, IInterpolatable

The IProcessStringTableStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProcessStringTableStatement Properties

The IProcessStringTableStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
See Also

Reference

IProcessStringTableStatement Interface
VisualComponents.Create3D Namespace


IProcessStringTableStatement Methods

The IProcessStringTableStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProcessStringTableStatement Interface
VisualComponents.Create3D Namespace


IProcessStringTableStatement Events

The IProcessStringTableStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IProcessStringTableStatement Interface
VisualComponents.Create3D Namespace


IProcessTableLineStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessTableLineStatement : IProcessRuleLineStatement,
    IProcessRuleStatement, IStatement, INamed, IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, IApiType, ICloneable<IStatement>,
    ICloneable, IStatementScope, IInterpolatable
public interface class IProcessTableLineStatement : IProcessRuleLineStatement,
    IProcessRuleStatement, IStatement, INamed, IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, IApiType, ICloneable<IStatement^>,
    ICloneable, IStatementScope, IInterpolatable

The IProcessTableLineStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsDefault |
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProcessTime | (Inherited from IProcessRuleLineStatement.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | UsesProcessTime | (Inherited from IProcessRuleLineStatement.)
Public property | Value |
Public property | ValueType |
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProcessTableLineStatement Properties

The IProcessTableLineStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsDefault |
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProcessTime | (Inherited from IProcessRuleLineStatement.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | UsesProcessTime | (Inherited from IProcessRuleLineStatement.)
Public property | Value |
Public property | ValueType |
Top
See Also

Reference

IProcessTableLineStatement Interface
VisualComponents.Create3D Namespace


IProcessTableLineStatement.IsDefault Property

IProcessTableLineStatementIsDefault Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsDefault { get; set; }
property bool IsDefault {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IProcessTableLineStatement Interface
VisualComponents.Create3D Namespace


IProcessTableLineStatement.Value Property

IProcessTableLineStatementValue Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object Value { get; set; }
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

IProcessTableLineStatement Interface
VisualComponents.Create3D Namespace


IProcessTableLineStatement.ValueType Property

IProcessTableLineStatementValueType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Type ValueType { get; }
property Type^ ValueType {
    Type^ get ();
}

Property Value

Type: Type
See Also

Reference

IProcessTableLineStatement Interface
VisualComponents.Create3D Namespace


IProcessTableLineStatement Methods

The IProcessTableLineStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProcessTableLineStatement Interface
VisualComponents.Create3D Namespace


IProcessTableLineStatement Events

The IProcessTableLineStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IProcessTableLineStatement Interface
VisualComponents.Create3D Namespace


IProcessTableStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessTableStatement : IProcessRuleStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement>, ICloneable,
    IStatementScope, IInterpolatable
public interface class IProcessTableStatement : IProcessRuleStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement^>, ICloneable,
    IStatementScope, IInterpolatable

The IProcessTableStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProcessTableStatement Properties

The IProcessTableStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
See Also

Reference

IProcessTableStatement Interface
VisualComponents.Create3D Namespace


IProcessTableStatement Methods

The IProcessTableStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProcessTableStatement Interface
VisualComponents.Create3D Namespace


IProcessTableStatement Events

The IProcessTableStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IProcessTableStatement Interface
VisualComponents.Create3D Namespace


IProcessUniformStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessUniformStatement : IProcessRuleStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement>, ICloneable,
    IStatementScope, IInterpolatable
public interface class IProcessUniformStatement : IProcessRuleStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement^>, ICloneable,
    IStatementScope, IInterpolatable

The IProcessUniformStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Max |
Public property | Min |
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | RandomSeed |
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProcessUniformStatement Properties

The IProcessUniformStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Max |
Public property | Min |
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | RandomSeed |
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
See Also

Reference

IProcessUniformStatement Interface
VisualComponents.Create3D Namespace


IProcessUniformStatement.Max Property

IProcessUniformStatementMax Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Max { get; set; }
property double Max {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IProcessUniformStatement Interface
VisualComponents.Create3D Namespace


IProcessUniformStatement.Min Property

IProcessUniformStatementMin Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Min { get; set; }
property double Min {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IProcessUniformStatement Interface
VisualComponents.Create3D Namespace


IProcessUniformStatement.RandomSeed Property

IProcessUniformStatementRandomSeed Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int RandomSeed { get; set; }
property int RandomSeed {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IProcessUniformStatement Interface
VisualComponents.Create3D Namespace


IProcessUniformStatement Methods

The IProcessUniformStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProcessUniformStatement Interface
VisualComponents.Create3D Namespace


IProcessUniformStatement Events

The IProcessUniformStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IProcessUniformStatement Interface
VisualComponents.Create3D Namespace


IProcessWhileStatement Interface

Executes Scope in a loop as long as ConditionExpression evaluates to True.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessWhileStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IProcessWhileStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IProcessWhileStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConditionExpression | Gets or sets condition expression to evaluate on each loop iteration. Statement execution stops when this expression evaluates to False.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | Scope | Gets IStatementScope to keep executing while ConditionExpression evaluates to True.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProcessWhileStatement Properties

The IProcessWhileStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConditionExpression | Gets or sets condition expression to evaluate on each loop iteration. Statement execution stops when this expression evaluates to False.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | Scope | Gets IStatementScope to keep executing while ConditionExpression evaluates to True.
Top
See Also

Reference

IProcessWhileStatement Interface
VisualComponents.Create3D Namespace


IProcessWhileStatement.ConditionExpression Property

IProcessWhileStatementConditionExpression Property

Gets or sets condition expression to evaluate on each loop iteration. Statement execution stops when this expression evaluates to False.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ConditionExpression { get; set; }
property String^ ConditionExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
This expression has access to UPM variables stored in IProcessRoutine.
See Also

Reference

IProcessWhileStatement Interface
VisualComponents.Create3D Namespace


IProcessWhileStatement.Scope Property

IProcessWhileStatementScope Property

Gets IStatementScope to keep executing while ConditionExpression evaluates to True.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatementScope Scope { get; }
property IStatementScope^ Scope {
    IStatementScope^ get ();
}

Property Value

Type: IStatementScope
See Also

Reference

IProcessWhileStatement Interface
VisualComponents.Create3D Namespace


IProcessWhileStatement Methods

The IProcessWhileStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProcessWhileStatement Interface
VisualComponents.Create3D Namespace


IProcessWhileStatement Events

The IProcessWhileStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IProcessWhileStatement Interface
VisualComponents.Create3D Namespace


IProductConfiguration Interface

Product license configuration interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProductConfiguration
public interface class IProductConfiguration

The IProductConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | AddOnProducts | Known add-ons to this product.
Public property | LicenseSpecificationPath | License specification file.
Public property | MainProduct | Main product information.
Top
Remarks

This is available from the application object after initialization, and describes the main licensed product as well as any add-on modules.

See Also

Reference

VisualComponents.Create3D Namespace


IProductConfiguration Properties

The IProductConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | AddOnProducts | Known add-ons to this product.
Public property | LicenseSpecificationPath | License specification file.
Public property | MainProduct | Main product information.
Top
See Also

Reference

IProductConfiguration Interface
VisualComponents.Create3D Namespace


IProductConfiguration.AddOnProducts Property

IProductConfigurationAddOnProducts Property

Known add-ons to this product.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<IProductItem> AddOnProducts { get; }
property IEnumerable<IProductItem^>^ AddOnProducts {
    IEnumerable<IProductItem^>^ get ();
}

Property Value

Type: IEnumerableIProductItem
See Also

Reference

IProductConfiguration Interface
VisualComponents.Create3D Namespace


IProductConfiguration.LicenseSpecificationPath Property

IProductConfigurationLicenseSpecificationPath Property

License specification file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Uri LicenseSpecificationPath { get; }
property Uri^ LicenseSpecificationPath {
    Uri^ get ();
}

Property Value

Type: Uri
See Also

Reference

IProductConfiguration Interface
VisualComponents.Create3D Namespace


IProductConfiguration.MainProduct Property

IProductConfigurationMainProduct Property

Main product information.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProductItem MainProduct { get; }
property IProductItem^ MainProduct {
    IProductItem^ get ();
}

Property Value

Type: IProductItem
See Also

Reference

IProductConfiguration Interface
VisualComponents.Create3D Namespace


IProductCreator Interface

Product creator is a IBehavior that creates ISimProduct instances during simulation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProductCreator : IFlowBehavior,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed
public interface class IProductCreator : IFlowBehavior,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed

The IProductCreator type exposes the following members.

Properties
 | Name | Description
Public property | ApplyProductTypeOrigin | Gets or sets whether to position the created ISimProduct instances taking the OriginFrame into account.
Public property | BatchFeed | Gets the Batch configuration in this IProductCreator.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | DistributionFeed | Gets the Distribution configuration in this IProductCreator.
Public property | FeedMode | Gets or sets the which feed mode to use during simulation.
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProcessController | Gets IProcessController that defines the available IProductType objects.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SingleFeed | Gets the Single configuration in this IProductCreator.
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | TableFeed | Gets the Table configuration in this IProductCreator.
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Public property | UsePartPooling | Gets or sets whether to reuse of components made by the creator, thereby improving simulation performance.
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
Different rules of what and when to create can be configured independently using the feed modes, but only one of them can be active at a time. The feed mode to use is defined by FeedMode
See Also

Reference

VisualComponents.Create3D Namespace


IProductCreator Properties

The IProductCreator type exposes the following members.

Properties
 | Name | Description
Public property | ApplyProductTypeOrigin | Gets or sets whether to position the created ISimProduct instances taking the OriginFrame into account.
Public property | BatchFeed | Gets the Batch configuration in this IProductCreator.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | DistributionFeed | Gets the Distribution configuration in this IProductCreator.
Public property | FeedMode | Gets or sets the which feed mode to use during simulation.
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProcessController | Gets IProcessController that defines the available IProductType objects.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SingleFeed | Gets the Single configuration in this IProductCreator.
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | TableFeed | Gets the Table configuration in this IProductCreator.
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Public property | UsePartPooling | Gets or sets whether to reuse of components made by the creator, thereby improving simulation performance.
Top
See Also

Reference

IProductCreator Interface
VisualComponents.Create3D Namespace


IProductCreator.ApplyProductTypeOrigin Property

IProductCreatorApplyProductTypeOrigin Property

Gets or sets whether to position the created ISimProduct instances taking the OriginFrame into account.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ApplyProductTypeOrigin { get; set; }
property bool ApplyProductTypeOrigin {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IProductCreator Interface
VisualComponents.Create3D Namespace


IProductCreator.BatchFeed Property

IProductCreatorBatchFeed Property

Gets the Batch configuration in this IProductCreator.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProductCreatorBatchMode BatchFeed { get; }
property IProductCreatorBatchMode^ BatchFeed {
    IProductCreatorBatchMode^ get ();
}

Property Value

Type: IProductCreatorBatchMode
See Also

Reference

IProductCreator Interface
VisualComponents.Create3D Namespace


IProductCreator.DistributionFeed Property

IProductCreatorDistributionFeed Property

Gets the Distribution configuration in this IProductCreator.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProductCreatorDistributionMode DistributionFeed { get; }
property IProductCreatorDistributionMode^ DistributionFeed {
    IProductCreatorDistributionMode^ get ();
}

Property Value

Type: IProductCreatorDistributionMode
See Also

Reference

IProductCreator Interface
VisualComponents.Create3D Namespace


IProductCreator.FeedMode Property

IProductCreatorFeedMode Property

Gets or sets the which feed mode to use during simulation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ProductCreatorFeedMode FeedMode { get; set; }
property ProductCreatorFeedMode FeedMode {
    ProductCreatorFeedMode get ();
    void set (ProductCreatorFeedMode value);
}

Property Value

Type: ProductCreatorFeedMode
See Also

Reference

IProductCreator Interface
VisualComponents.Create3D Namespace


IProductCreator.ProcessController Property

IProductCreatorProcessController Property

Gets IProcessController that defines the available IProductType objects.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessController ProcessController { get; }
property IProcessController^ ProcessController {
    IProcessController^ get ();
}

Property Value

Type: IProcessController
See Also

Reference

IProductCreator Interface
VisualComponents.Create3D Namespace


IProductCreator.SingleFeed Property

IProductCreatorSingleFeed Property

Gets the Single configuration in this IProductCreator.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProductCreatorSingleMode SingleFeed { get; }
property IProductCreatorSingleMode^ SingleFeed {
    IProductCreatorSingleMode^ get ();
}

Property Value

Type: IProductCreatorSingleMode
See Also

Reference

IProductCreator Interface
VisualComponents.Create3D Namespace


IProductCreator.TableFeed Property

IProductCreatorTableFeed Property

Gets the Table configuration in this IProductCreator.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProductCreatorTableMode TableFeed { get; }
property IProductCreatorTableMode^ TableFeed {
    IProductCreatorTableMode^ get ();
}

Property Value

Type: IProductCreatorTableMode
See Also

Reference

IProductCreator Interface
VisualComponents.Create3D Namespace


IProductCreator.UsePartPooling Property

IProductCreatorUsePartPooling Property

Gets or sets whether to reuse of components made by the creator, thereby improving simulation performance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool UsePartPooling { get; set; }
property bool UsePartPooling {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IProductCreator Interface
VisualComponents.Create3D Namespace


IProductCreator Methods

The IProductCreator type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProductCreator Interface
VisualComponents.Create3D Namespace


IProductCreator Events

The IProductCreator type exposes the following members.

Events
 | Name | Description
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IProductCreator Interface
VisualComponents.Create3D Namespace


IProductCreatorBatchMode Interface

Configuration for creating batches of products from IProductCreator Multiple batches can be defined and they are executed in sequence.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProductCreatorBatchMode : IPropertyContainer,
    IBatchModeObject, IWrapper, IDisposable
public interface class IProductCreatorBatchMode : IPropertyContainer,
    IBatchModeObject, IWrapper, IDisposable

The IProductCreatorBatchMode type exposes the following members.

Properties
 | Name | Description
Public property | BatchInterval | Delay after last product in each batch before starting the next batch.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsLooping | Whether to restart from first batch after the last batch is complete.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductBatches | Gets all configured batches.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateBatch | Creates and adds a new product batch.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteBatch | Removes the given feed line from the batch mode.
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | MoveBatch | Moves the given batch to the given position in the sequence.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | BatchesChanged | Raised when ProductBatches content or ordering has changed.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProductCreatorBatchMode Properties

The IProductCreatorBatchMode type exposes the following members.

Properties
 | Name | Description
Public property | BatchInterval | Delay after last product in each batch before starting the next batch.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsLooping | Whether to restart from first batch after the last batch is complete.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductBatches | Gets all configured batches.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IProductCreatorBatchMode Interface
VisualComponents.Create3D Namespace


IProductCreatorBatchMode.BatchInterval Property

IProductCreatorBatchModeBatchInterval Property

Delay after last product in each batch before starting the next batch.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
TimeSpan BatchInterval { get; set; }
property TimeSpan BatchInterval {
    TimeSpan get ();
    void set (TimeSpan value);
}

Property Value

Type: TimeSpan
See Also

Reference

IProductCreatorBatchMode Interface
VisualComponents.Create3D Namespace


IProductCreatorBatchMode.IsLooping Property

IProductCreatorBatchModeIsLooping Property

Whether to restart from first batch after the last batch is complete.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsLooping { get; set; }
property bool IsLooping {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IProductCreatorBatchMode Interface
VisualComponents.Create3D Namespace


IProductCreatorBatchMode.ProductBatches Property

IProductCreatorBatchModeProductBatches Property

Gets all configured batches.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<IProductCreatorFeedBatch> ProductBatches { get; }
property IReadOnlyList<IProductCreatorFeedBatch^>^ ProductBatches {
    IReadOnlyList<IProductCreatorFeedBatch^>^ get ();
}

Return Value

Type: IReadOnlyListIProductCreatorFeedBatch
A collection that holds all the items present when this getter was called.
See Also

Reference

IProductCreatorBatchMode Interface
VisualComponents.Create3D Namespace


IProductCreatorBatchMode Methods

The IProductCreatorBatchMode type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateBatch | Creates and adds a new product batch.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteBatch | Removes the given feed line from the batch mode.
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | MoveBatch | Moves the given batch to the given position in the sequence.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProductCreatorBatchMode Interface
VisualComponents.Create3D Namespace


IProductCreatorBatchMode.CreateBatch Method

IProductCreatorBatchModeCreateBatch Method

Creates and adds a new product batch.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProductCreatorFeedBatch CreateBatch()
IProductCreatorFeedBatch^ CreateBatch()

Return Value

Type: IProductCreatorFeedBatch
The created batch object.
Remarks
The batch is created using default values and added to the end of the sequence.
See Also

Reference

IProductCreatorBatchMode Interface
VisualComponents.Create3D Namespace


IProductCreatorBatchMode.DeleteBatch Method

IProductCreatorBatchModeDeleteBatch Method

Removes the given feed line from the batch mode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteBatch(
    IProductCreatorFeedBatch batch
)
void DeleteBatch(
    IProductCreatorFeedBatch^ batch
)

Parameters

batch
Type: VisualComponents.Create3DIProductCreatorFeedBatch
Feed line to be remove.
Exceptions
Exception | Condition
ArgumentNullException |
InvalidOperationException | Occurs when the batch is not from of this IProductCreatorBatchMode
See Also

Reference

IProductCreatorBatchMode Interface
VisualComponents.Create3D Namespace


IProductCreatorBatchMode.MoveBatch Method

IProductCreatorBatchModeMoveBatch Method

Moves the given batch to the given position in the sequence.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void MoveBatch(
    IProductCreatorFeedBatch batch,
    int newIndex
)
void MoveBatch(
    IProductCreatorFeedBatch^ batch,
    int newIndex
)

Parameters

batch
Type: VisualComponents.Create3DIProductCreatorFeedBatch
The batch to move.
newIndex
Type: SystemInt32
New zero-based position of the batch.
Exceptions
Exception | Condition
ArgumentOutOfRangeException |
ArgumentNullException |
InvalidOperationException | Occurs when the batch is not from of this IProductCreatorBatchMode
See Also

Reference

IProductCreatorBatchMode Interface
VisualComponents.Create3D Namespace


IProductCreatorBatchMode Events

The IProductCreatorBatchMode type exposes the following members.

Events
 | Name | Description
Public event | BatchesChanged | Raised when ProductBatches content or ordering has changed.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IProductCreatorBatchMode Interface
VisualComponents.Create3D Namespace


IProductCreatorBatchMode.BatchesChanged Event

IProductCreatorBatchModeBatchesChanged Event

Raised when ProductBatches content or ordering has changed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<BatchesChangedEventArgs> BatchesChanged
 event EventHandler<BatchesChangedEventArgs^>^ BatchesChanged {
    void add (EventHandler<BatchesChangedEventArgs^>^ value);
    void remove (EventHandler<BatchesChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerBatchesChangedEventArgs
See Also

Reference

IProductCreatorBatchMode Interface
VisualComponents.Create3D Namespace


IProductCreatorDistributionMode Interface

Configuration for creating products of different types in randomized order from IProductCreator.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProductCreatorDistributionMode : IPropertyContainer,
    IBatchModeObject, IWrapper, IDisposable
public interface class IProductCreatorDistributionMode : IPropertyContainer,
    IBatchModeObject, IWrapper, IDisposable

The IProductCreatorDistributionMode type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Interval | Gets the property that defines the product creation interval.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Limit | Gets or sets how many ISimProduct instances to create.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductEntries | Gets the currently configured IProductType options to create.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | RandomStreamIndex | Defines the pseudo random number generator to use for picking the next IProductType to instantiate.
Top
Methods
 | Name | Description
Public method | AddProductEntry | Creates a new IDistributionModeProductLineEntry and adds it to ProductEntries.
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | RemoveProductEntry | Removes the given IDistributionModeProductLineEntry from ProductEntries.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | ProductEntriesChanged | Raised whenever the ProductEntries collection has changed.
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
Holds a set of IProductType and probability pairs that define which products are created. On each interval tick the creator picks a IProductType to create based on a pseudo-random uniform value and the probability weights.
See Also

Reference

VisualComponents.Create3D Namespace


IProductCreatorDistributionMode Properties

The IProductCreatorDistributionMode type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Interval | Gets the property that defines the product creation interval.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Limit | Gets or sets how many ISimProduct instances to create.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductEntries | Gets the currently configured IProductType options to create.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | RandomStreamIndex | Defines the pseudo random number generator to use for picking the next IProductType to instantiate.
Top
See Also

Reference

IProductCreatorDistributionMode Interface
VisualComponents.Create3D Namespace


IProductCreatorDistributionMode.Interval Property

IProductCreatorDistributionModeInterval Property

Gets the property that defines the product creation interval.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IDistributionProperty Interval { get; }
property IDistributionProperty^ Interval {
    IDistributionProperty^ get ();
}

Property Value

Type: IDistributionProperty
See Also

Reference

IProductCreatorDistributionMode Interface
VisualComponents.Create3D Namespace


IProductCreatorDistributionMode.Limit Property

IProductCreatorDistributionModeLimit Property

Gets or sets how many ISimProduct instances to create.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int Limit { get; set; }
property int Limit {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Occurs when setting value less than 0.
See Also

Reference

IProductCreatorDistributionMode Interface
VisualComponents.Create3D Namespace


IProductCreatorDistributionMode.ProductEntries Property

IProductCreatorDistributionModeProductEntries Property

Gets the currently configured IProductType options to create.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<IDistributionModeProductLineEntry> ProductEntries { get; }
property IReadOnlyList<IDistributionModeProductLineEntry^>^ ProductEntries {
    IReadOnlyList<IDistributionModeProductLineEntry^>^ get ();
}

Property Value

Type: IReadOnlyListIDistributionModeProductLineEntry
See Also

Reference

IProductCreatorDistributionMode Interface
VisualComponents.Create3D Namespace


IProductCreatorDistributionMode.RandomStreamIndex Property

IProductCreatorDistributionModeRandomStreamIndex Property

Defines the pseudo random number generator to use for picking the next IProductType to instantiate.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int RandomStreamIndex { get; set; }
property int RandomStreamIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Occurs when trying to set a value less than 0 or greater than 63.
Remarks
Valid value range is 0-63 (inclusive).
See Also

Reference

IProductCreatorDistributionMode Interface
VisualComponents.Create3D Namespace


IProductCreatorDistributionMode Methods

The IProductCreatorDistributionMode type exposes the following members.

Methods
 | Name | Description
Public method | AddProductEntry | Creates a new IDistributionModeProductLineEntry and adds it to ProductEntries.
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | RemoveProductEntry | Removes the given IDistributionModeProductLineEntry from ProductEntries.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProductCreatorDistributionMode Interface
VisualComponents.Create3D Namespace


IProductCreatorDistributionMode.AddProductEntry Method

IProductCreatorDistributionModeAddProductEntry Method

Creates a new IDistributionModeProductLineEntry and adds it to ProductEntries.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IDistributionModeProductLineEntry AddProductEntry(
    IProductType productType,
    double probability
)
IDistributionModeProductLineEntry^ AddProductEntry(
    IProductType^ productType,
    double probability
)

Parameters

productType
Type: VisualComponents.Create3DIProductType
The IProductType to create.
probability
Type: SystemDouble
Creation probability of this IProductType. Should be a positive value. The probabilities are evaluated relative to each other and thus don't need to have any particular sum.

Return Value

Type: IDistributionModeProductLineEntry

[Missing <returns> documentation for "M:VisualComponents.Create3D.IProductCreatorDistributionMode.AddProductEntry(VisualComponents.Create3D.IProductType,System.Double)"]

Exceptions
Exception | Condition
ArgumentNullException |
ArgumentOutOfRangeException | Occurs when probability < 0
See Also

Reference

IProductCreatorDistributionMode Interface
VisualComponents.Create3D Namespace


IProductCreatorDistributionMode.RemoveProductEntry Method

IProductCreatorDistributionModeRemoveProductEntry Method

Removes the given IDistributionModeProductLineEntry from ProductEntries.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RemoveProductEntry(
    IDistributionModeProductLineEntry productEntry
)
void RemoveProductEntry(
    IDistributionModeProductLineEntry^ productEntry
)

Parameters

productEntry
Type: VisualComponents.Create3DIDistributionModeProductLineEntry
The entry to remove.
Exceptions
Exception | Condition
ArgumentException | Occurs when the productEntry is not in this distribution mode.
ArgumentNullException |
See Also

Reference

IProductCreatorDistributionMode Interface
VisualComponents.Create3D Namespace


IProductCreatorDistributionMode Events

The IProductCreatorDistributionMode type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | ProductEntriesChanged | Raised whenever the ProductEntries collection has changed.
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IProductCreatorDistributionMode Interface
VisualComponents.Create3D Namespace


IProductCreatorDistributionMode.ProductEntriesChanged Event

IProductCreatorDistributionModeProductEntriesChanged Event

Raised whenever the ProductEntries collection has changed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ProductEntriesChangedEventArgs> ProductEntriesChanged
 event EventHandler<ProductEntriesChangedEventArgs^>^ ProductEntriesChanged {
    void add (EventHandler<ProductEntriesChangedEventArgs^>^ value);
    void remove (EventHandler<ProductEntriesChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerProductEntriesChangedEventArgs
See Also

Reference

IProductCreatorDistributionMode Interface
VisualComponents.Create3D Namespace


IProductCreatorFeedBatch Interface

Configuration for creating a single batch of products from IProductCreator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProductCreatorFeedBatch : IPropertyContainer,
    IBatchModeObject, IWrapper, IDisposable
public interface class IProductCreatorFeedBatch : IPropertyContainer,
    IBatchModeObject, IWrapper, IDisposable

The IProductCreatorFeedBatch type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Interval | Gets the property that defines the product creation interval.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Limit | Gets or sets how many ISimProduct instances to create.
Public property | Part | Gets or sets the type of product to create.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProductCreatorFeedBatch Properties

The IProductCreatorFeedBatch type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Interval | Gets the property that defines the product creation interval.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Limit | Gets or sets how many ISimProduct instances to create.
Public property | Part | Gets or sets the type of product to create.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IProductCreatorFeedBatch Interface
VisualComponents.Create3D Namespace


IProductCreatorFeedBatch.Interval Property

IProductCreatorFeedBatchInterval Property

Gets the property that defines the product creation interval.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IDistributionProperty Interval { get; }
property IDistributionProperty^ Interval {
    IDistributionProperty^ get ();
}

Property Value

Type: IDistributionProperty
See Also

Reference

IProductCreatorFeedBatch Interface
VisualComponents.Create3D Namespace


IProductCreatorFeedBatch.Limit Property

IProductCreatorFeedBatchLimit Property

Gets or sets how many ISimProduct instances to create.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int Limit { get; set; }
property int Limit {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentException |
See Also

Reference

IProductCreatorFeedBatch Interface
VisualComponents.Create3D Namespace


IProductCreatorFeedBatch.Part Property

IProductCreatorFeedBatchPart Property

Gets or sets the type of product to create.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProductType Part { get; set; }
property IProductType^ Part {
    IProductType^ get ();
    void set (IProductType^ value);
}

Property Value

Type: IProductType
Exceptions
Exception | Condition
ArgumentNullException |
InvalidCastException |
See Also

Reference

IProductCreatorFeedBatch Interface
VisualComponents.Create3D Namespace


IProductCreatorFeedBatch Methods

The IProductCreatorFeedBatch type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProductCreatorFeedBatch Interface
VisualComponents.Create3D Namespace


IProductCreatorFeedBatch Events

The IProductCreatorFeedBatch type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IProductCreatorFeedBatch Interface
VisualComponents.Create3D Namespace


IProductCreatorSingleMode Interface

Configuration for Single mode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProductCreatorSingleMode : IPropertyContainer,
    IBatchModeObject, IWrapper, IDisposable
public interface class IProductCreatorSingleMode : IPropertyContainer,
    IBatchModeObject, IWrapper, IDisposable

The IProductCreatorSingleMode type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Interval | Gets the property that defines the product creation interval.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Limit | Gets or sets how many ISimProduct instances to create.
Public property | Part | Gets or sets the type of product to create.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProductCreatorSingleMode Properties

The IProductCreatorSingleMode type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Interval | Gets the property that defines the product creation interval.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Limit | Gets or sets how many ISimProduct instances to create.
Public property | Part | Gets or sets the type of product to create.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IProductCreatorSingleMode Interface
VisualComponents.Create3D Namespace


IProductCreatorSingleMode.Interval Property

IProductCreatorSingleModeInterval Property

Gets the property that defines the product creation interval.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IDistributionProperty Interval { get; }
property IDistributionProperty^ Interval {
    IDistributionProperty^ get ();
}

Property Value

Type: IDistributionProperty
See Also

Reference

IProductCreatorSingleMode Interface
VisualComponents.Create3D Namespace


IProductCreatorSingleMode.Limit Property

IProductCreatorSingleModeLimit Property

Gets or sets how many ISimProduct instances to create.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int Limit { get; set; }
property int Limit {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentException |
See Also

Reference

IProductCreatorSingleMode Interface
VisualComponents.Create3D Namespace


IProductCreatorSingleMode.Part Property

IProductCreatorSingleModePart Property

Gets or sets the type of product to create.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProductType Part { get; set; }
property IProductType^ Part {
    IProductType^ get ();
    void set (IProductType^ value);
}

Property Value

Type: IProductType
Exceptions
Exception | Condition
ArgumentNullException |
InvalidCastException |
See Also

Reference

IProductCreatorSingleMode Interface
VisualComponents.Create3D Namespace


IProductCreatorSingleMode Methods

The IProductCreatorSingleMode type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProductCreatorSingleMode Interface
VisualComponents.Create3D Namespace


IProductCreatorSingleMode Events

The IProductCreatorSingleMode type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IProductCreatorSingleMode Interface
VisualComponents.Create3D Namespace


IProductCreatorTableMode Interface

Configuration for creating products at specific sequence and time from IProductCreator.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProductCreatorTableMode : IPropertyContainer,
    IBatchModeObject, IWrapper, IDisposable
public interface class IProductCreatorTableMode : IPropertyContainer,
    IBatchModeObject, IWrapper, IDisposable

The IProductCreatorTableMode type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | FilePath | Obsolete. Gets or sets file system path where to load table rows.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductRows | Gets a copy of all currently defined rows.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | RowCount | Gets the current row count.
Top
Methods
 | Name | Description
Public method | AddRow | Adds a new row definition as a copy. The row gets inserted immediately after all existing rows with the same or smaller CreationTime.
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ClearRows | Clears all ProductRows.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteRow | Removes a row from ProductRows at given index.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetRow | Gets a row definition at given index in ProductRows as a copy.
Public method | ReadRowsFromFile | Attempts to load ProductCreatorTableRows from a file. Doesn't modify ProductRows content.
Public method | ReplaceAllRows | Replaces all rows in ProductRows by copying the newRows.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | RowsChanged | Raised when the ProductRows collection content has changed.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
Holds a list of rows, each defining which IProductType to instantiate and at what simulation time. The rows are automatically sorted in ascending order by the creation time.
See Also

Reference

VisualComponents.Create3D Namespace


IProductCreatorTableMode Properties

The IProductCreatorTableMode type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | FilePath | Obsolete. Gets or sets file system path where to load table rows.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductRows | Gets a copy of all currently defined rows.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | RowCount | Gets the current row count.
Top
See Also

Reference

IProductCreatorTableMode Interface
VisualComponents.Create3D Namespace


IProductCreatorTableMode.FilePath Property

IProductCreatorTableModeFilePath Property

Note: This API is now obsolete.

Gets or sets file system path where to load table rows.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Use ReadRowsFromFile and ReplaceAllRows to load rows from a file.",
    false)]
Uri FilePath { get; set; }
[ObsoleteAttribute(L"Use ReadRowsFromFile and ReplaceAllRows to load rows from a file.",
    false)]
property Uri^ FilePath {
    Uri^ get ();
    void set (Uri^ value);
}

Property Value

Type: Uri
Remarks
Changing the FilePath will cause an immediate attempt to read the file and replace all ProductRows if successful.
See Also

Reference

IProductCreatorTableMode Interface
VisualComponents.Create3D Namespace


IProductCreatorTableMode.ProductRows Property

IProductCreatorTableModeProductRows Property

Gets a copy of all currently defined rows.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<ProductCreatorTableRow> ProductRows { get; }
property IReadOnlyList<ProductCreatorTableRow>^ ProductRows {
    IReadOnlyList<ProductCreatorTableRow>^ get ();
}

Property Value

Type: IReadOnlyListProductCreatorTableRow
See Also

Reference

IProductCreatorTableMode Interface
VisualComponents.Create3D Namespace


IProductCreatorTableMode.RowCount Property

IProductCreatorTableModeRowCount Property

Gets the current row count.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int RowCount { get; }
property int RowCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IProductCreatorTableMode Interface
VisualComponents.Create3D Namespace


IProductCreatorTableMode Methods

The IProductCreatorTableMode type exposes the following members.

Methods
 | Name | Description
Public method | AddRow | Adds a new row definition as a copy. The row gets inserted immediately after all existing rows with the same or smaller CreationTime.
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ClearRows | Clears all ProductRows.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteRow | Removes a row from ProductRows at given index.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetRow | Gets a row definition at given index in ProductRows as a copy.
Public method | ReadRowsFromFile | Attempts to load ProductCreatorTableRows from a file. Doesn't modify ProductRows content.
Public method | ReplaceAllRows | Replaces all rows in ProductRows by copying the newRows.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProductCreatorTableMode Interface
VisualComponents.Create3D Namespace


IProductCreatorTableMode.AddRow Method

IProductCreatorTableModeAddRow Method

Adds a new row definition as a copy. The row gets inserted immediately after all existing rows with the same or smaller CreationTime.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int AddRow(
    ProductCreatorTableRow newRow
)
int AddRow(
    ProductCreatorTableRow newRow
)

Parameters

newRow
Type: VisualComponents.Create3DProductCreatorTableRow
The product instantiation configuration to add.

Return Value

Type: Int32
Index of the added row.
Exceptions
Exception | Condition
ArgumentException | Occurs when newRow contains invalid values.
See Also

Reference

IProductCreatorTableMode Interface
VisualComponents.Create3D Namespace


IProductCreatorTableMode.ClearRows Method

IProductCreatorTableModeClearRows Method

Clears all ProductRows.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ClearRows()
void ClearRows()
See Also

Reference

IProductCreatorTableMode Interface
VisualComponents.Create3D Namespace


IProductCreatorTableMode.DeleteRow Method

IProductCreatorTableModeDeleteRow Method

Removes a row from ProductRows at given index.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteRow(
    int index
)
void DeleteRow(
    int index
)

Parameters

index
Type: SystemInt32
Zero based index of row to remove.
Exceptions
Exception | Condition
ArgumentOutOfRangeException |
See Also

Reference

IProductCreatorTableMode Interface
VisualComponents.Create3D Namespace


IProductCreatorTableMode.GetRow Method

IProductCreatorTableModeGetRow Method

Gets a row definition at given index in ProductRows as a copy.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ProductCreatorTableRow GetRow(
    int index
)
ProductCreatorTableRow GetRow(
    int index
)

Parameters

index
Type: SystemInt32
Zero-based row index.

Return Value

Type: ProductCreatorTableRow
The table row as a copy.
Exceptions
Exception | Condition
ArgumentOutOfRangeException |
See Also

Reference

IProductCreatorTableMode Interface
VisualComponents.Create3D Namespace


IProductCreatorTableMode.ReadRowsFromFile Method

IProductCreatorTableModeReadRowsFromFile Method

Attempts to load ProductCreatorTableRows from a file. Doesn't modify ProductRows content.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<ProductCreatorTableRow> ReadRowsFromFile(
    Uri filePath,
    bool showErrorMessages
)
IList<ProductCreatorTableRow>^ ReadRowsFromFile(
    Uri^ filePath,
    bool showErrorMessages
)

Parameters

filePath
Type: SystemUri
Uri describing full path to the file to load.
showErrorMessages
Type: SystemBoolean
When true, any errors are written to the output panel.

Return Value

Type: IListProductCreatorTableRow
Null if loading the file failed. The rows are in the file order and the collection may also be empty.
See Also

Reference

IProductCreatorTableMode Interface
VisualComponents.Create3D Namespace


IProductCreatorTableMode.ReplaceAllRows Method

IProductCreatorTableModeReplaceAllRows Method

Replaces all rows in ProductRows by copying the newRows.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ReplaceAllRows(
    IEnumerable<ProductCreatorTableRow> newRows
)
void ReplaceAllRows(
    IEnumerable<ProductCreatorTableRow>^ newRows
)

Parameters

newRows
Type: System.Collections.GenericIEnumerableProductCreatorTableRow
The new row definitions to apply.
Exceptions
Exception | Condition
InvalidOperationException | Occurs when any of the rows in newRows have invalid values.
Remarks
Either succeeds fully or doesn't change anything. The rows get automatically sorted in ascending order by CreationTime using a stable sort algorithm.
See Also

Reference

IProductCreatorTableMode Interface
VisualComponents.Create3D Namespace


IProductCreatorTableMode Events

The IProductCreatorTableMode type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | RowsChanged | Raised when the ProductRows collection content has changed.
Top
See Also

Reference

IProductCreatorTableMode Interface
VisualComponents.Create3D Namespace


IProductCreatorTableMode.RowsChanged Event

IProductCreatorTableModeRowsChanged Event

Raised when the ProductRows collection content has changed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler RowsChanged
 event EventHandler^ RowsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IProductCreatorTableMode Interface
VisualComponents.Create3D Namespace


IProductItem Interface

Product add-on information interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProductItem
public interface class IProductItem

The IProductItem type exposes the following members.

Properties
 | Name | Description
Public property | AcceptedKeyPattern | Optional regex pattern that must match the filtered product key.
Public property | Description | Product description string.
Public property | Features | Collection of required licensing features.
Public property | IsEnabled | Whether this item is enabled in this session.
Public property | IsKeyManaged | Whether the license key is externally managed.
Public property | Name | Product name.
Public property | Version | Product version string.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProductItem Properties

The IProductItem type exposes the following members.

Properties
 | Name | Description
Public property | AcceptedKeyPattern | Optional regex pattern that must match the filtered product key.
Public property | Description | Product description string.
Public property | Features | Collection of required licensing features.
Public property | IsEnabled | Whether this item is enabled in this session.
Public property | IsKeyManaged | Whether the license key is externally managed.
Public property | Name | Product name.
Public property | Version | Product version string.
Top
See Also

Reference

IProductItem Interface
VisualComponents.Create3D Namespace


IProductItem.AcceptedKeyPattern Property

IProductItemAcceptedKeyPattern Property

Optional regex pattern that must match the filtered product key.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string AcceptedKeyPattern { get; }
property String^ AcceptedKeyPattern {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IProductItem Interface
VisualComponents.Create3D Namespace


IProductItem.Description Property

IProductItemDescription Property

Product description string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Description { get; }
property String^ Description {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IProductItem Interface
VisualComponents.Create3D Namespace


IProductItem.Features Property

IProductItemFeatures Property

Collection of required licensing features.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISet<ProductFeature> Features { get; }
property ISet<ProductFeature>^ Features {
    ISet<ProductFeature>^ get ();
}

Property Value

Type: ISetProductFeature
See Also

Reference

IProductItem Interface
VisualComponents.Create3D Namespace


IProductItem.IsEnabled Property

IProductItemIsEnabled Property

Whether this item is enabled in this session.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsEnabled { get; set; }
property bool IsEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks

Note: This property is only settable on add-on products.

See Also

Reference

IProductItem Interface
VisualComponents.Create3D Namespace


IProductItem.IsKeyManaged Property

IProductItemIsKeyManaged Property

Whether the license key is externally managed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsKeyManaged { get; }
property bool IsKeyManaged {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IProductItem Interface
VisualComponents.Create3D Namespace


IProductItem.Name Property

IProductItemName Property

Product name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Name { get; }
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IProductItem Interface
VisualComponents.Create3D Namespace


IProductItem.Version Property

IProductItemVersion Property

Product version string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Version { get; }
property String^ Version {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IProductItem Interface
VisualComponents.Create3D Namespace


IProductType Interface

A product definition that is used to create ISimProduct instances.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProductType : INamed,
    IPropertyContainer, IBatchModeObject, IWrapper, IDisposable
public interface class IProductType : INamed,
    IPropertyContainer, IBatchModeObject, IWrapper, IDisposable

The IProductType type exposes the following members.

Properties
 | Name | Description
Public property | AssignedComponentTemplate | Restricted access to the ISimComponent template that is used when creating ISimProduct instances of this IProductType.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ComponentProperties | Properties that are applied to components of ISimProduct instances created from this IProductType.
Public property | ComponentUri | Simulation component type (VCID) used to visualize ISimProduct instances created from this type.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Group | Gets the instance of IProcessFlowGroup that contains this product type.
Public property | IsSystem | True if this IProductType is a special internal type.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | OriginFrame | Offset from Component origin to ISimProduct origin.
Public property | ParentProduct | Gets or sets the parent product type of this IProductType.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductProperties | Properties that are applied to ISimProduct instances created from this type.
Public property | ProductTypeManager | Gets the instance of IProductTypeManager that holds and manages this IProductType.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | UniqueId | Unique identifier for this IProductType definition used internally to e.g. identify whether two IProductTypes are the same or not.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | ResetUniqueId | Generates and assigns a new UniqueId for this IProductType.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProductType Properties

The IProductType type exposes the following members.

Properties
 | Name | Description
Public property | AssignedComponentTemplate | Restricted access to the ISimComponent template that is used when creating ISimProduct instances of this IProductType.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ComponentProperties | Properties that are applied to components of ISimProduct instances created from this IProductType.
Public property | ComponentUri | Simulation component type (VCID) used to visualize ISimProduct instances created from this type.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Group | Gets the instance of IProcessFlowGroup that contains this product type.
Public property | IsSystem | True if this IProductType is a special internal type.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | OriginFrame | Offset from Component origin to ISimProduct origin.
Public property | ParentProduct | Gets or sets the parent product type of this IProductType.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductProperties | Properties that are applied to ISimProduct instances created from this type.
Public property | ProductTypeManager | Gets the instance of IProductTypeManager that holds and manages this IProductType.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | UniqueId | Unique identifier for this IProductType definition used internally to e.g. identify whether two IProductTypes are the same or not.
Top
See Also

Reference

IProductType Interface
VisualComponents.Create3D Namespace


IProductType.AssignedComponentTemplate Property

IProductTypeAssignedComponentTemplate Property

Restricted access to the ISimComponent template that is used when creating ISimProduct instances of this IProductType.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProductTypeComponentTemplate AssignedComponentTemplate { get; }
property IProductTypeComponentTemplate^ AssignedComponentTemplate {
    IProductTypeComponentTemplate^ get ();
}

Property Value

Type: IProductTypeComponentTemplate
Remarks
Changing the template should be done by setting ComponentUri.
See Also

Reference

IProductType Interface
VisualComponents.Create3D Namespace


IProductType.ComponentProperties Property

IProductTypeComponentProperties Property

Properties that are applied to components of ISimProduct instances created from this IProductType.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPropertyContainer ComponentProperties { get; }
property IPropertyContainer^ ComponentProperties {
    IPropertyContainer^ get ();
}

Property Value

Type: IPropertyContainer
See Also

Reference

IProductType Interface
VisualComponents.Create3D Namespace


IProductType.ComponentUri Property

IProductTypeComponentUri Property

Simulation component type (VCID) used to visualize ISimProduct instances created from this type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Uri ComponentUri { get; set; }
property Uri^ ComponentUri {
    Uri^ get ();
    void set (Uri^ value);
}

Property Value

Type: Uri
Exceptions
Exception | Condition
InvalidOperationException | If attempting to modify system types
Remarks
Setting this Uri causes the IProductType to immediately attempt to load and make an internal copy of the ISimComponent. Special “component” Uri scheme (component:componentName) can be used to point to an existing static component in the simulation layout.
See Also

Reference

IProductType Interface
VisualComponents.Create3D Namespace


IProductType.Group Property

IProductTypeGroup Property

Gets the instance of IProcessFlowGroup that contains this product type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessFlowGroup Group { get; }
property IProcessFlowGroup^ Group {
    IProcessFlowGroup^ get ();
}

Property Value

Type: IProcessFlowGroup
Remarks
Use methods in IProcessFlowGroup to associate the type to another flow group.
See Also

Reference

IProductType Interface
VisualComponents.Create3D Namespace


IProductType.IsSystem Property

IProductTypeIsSystem Property

True if this IProductType is a special internal type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsSystem { get; }
property bool IsSystem {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IProductType Interface
VisualComponents.Create3D Namespace


IProductType.OriginFrame Property

IProductTypeOriginFrame Property

Offset from Component origin to ISimProduct origin.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix OriginFrame { get; set; }
property Matrix OriginFrame {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
Exceptions
Exception | Condition
InvalidOperationException | If attempting to modify system types
See Also

Reference

IProductType Interface
VisualComponents.Create3D Namespace


IProductType.ParentProduct Property

IProductTypeParentProduct Property

Gets or sets the parent product type of this IProductType.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProductType ParentProduct { get; set; }
property IProductType^ ParentProduct {
    IProductType^ get ();
    void set (IProductType^ value);
}

Property Value

Type: IProductType
Exceptions
Exception | Condition
ArgumentNullException |
InvalidOperationException | If attempting to modify system types
Remarks
All user defined ProductTypes must derive directly or indirectly from the "Any" ProductType. The ProductType inheritance hierarchy must always form an acyclic connected graph.
See Also

Reference

IProductType Interface
VisualComponents.Create3D Namespace


IProductType.ProductProperties Property

IProductTypeProductProperties Property

Properties that are applied to ISimProduct instances created from this type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPropertyContainer ProductProperties { get; }
property IPropertyContainer^ ProductProperties {
    IPropertyContainer^ get ();
}

Property Value

Type: IPropertyContainer
See Also

Reference

IProductType Interface
VisualComponents.Create3D Namespace


IProductType.ProductTypeManager Property

IProductTypeProductTypeManager Property

Gets the instance of IProductTypeManager that holds and manages this IProductType.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProductTypeManager ProductTypeManager { get; }
property IProductTypeManager^ ProductTypeManager {
    IProductTypeManager^ get ();
}

Property Value

Type: IProductTypeManager
See Also

Reference

IProductType Interface
VisualComponents.Create3D Namespace


IProductType.UniqueId Property

IProductTypeUniqueId Property

Unique identifier for this IProductType definition used internally to e.g. identify whether two IProductTypes are the same or not.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string UniqueId { get; }
property String^ UniqueId {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IProductType Interface
VisualComponents.Create3D Namespace


IProductType Methods

The IProductType type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | ResetUniqueId | Generates and assigns a new UniqueId for this IProductType.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProductType Interface
VisualComponents.Create3D Namespace


IProductType.ResetUniqueId Method

IProductTypeResetUniqueId Method

Generates and assigns a new UniqueId for this IProductType.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ResetUniqueId()
void ResetUniqueId()
See Also

Reference

IProductType Interface
VisualComponents.Create3D Namespace


IProductType Events

The IProductType type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IProductType Interface
VisualComponents.Create3D Namespace


IProductTypeComponentTemplate Interface

An interface to provide restricted access to the template ISimComponent that is used when creating ISimProduct objects of a certain IProductType.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProductTypeComponentTemplate : IWrapper,
    IDisposable, INamed
public interface class IProductTypeComponentTemplate : IWrapper,
    IDisposable, INamed

The IProductTypeComponentTemplate type exposes the following members.

Properties
 | Name | Description
Public property | ComponentProperties | Gets a collection of the properties currently present in the ISimComponent.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | VCID | Gets the unique component type identifier.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProductTypeComponentTemplate Properties

The IProductTypeComponentTemplate type exposes the following members.

Properties
 | Name | Description
Public property | ComponentProperties | Gets a collection of the properties currently present in the ISimComponent.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | VCID | Gets the unique component type identifier.
Top
See Also

Reference

IProductTypeComponentTemplate Interface
VisualComponents.Create3D Namespace


IProductTypeComponentTemplate.ComponentProperties Property

IProductTypeComponentTemplateComponentProperties Property

Gets a collection of the properties currently present in the ISimComponent.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<IProperty> ComponentProperties { get; }
property IReadOnlyList<IProperty^>^ ComponentProperties {
    IReadOnlyList<IProperty^>^ get ();
}

Property Value

Type: IReadOnlyListIProperty
See Also

Reference

IProductTypeComponentTemplate Interface
VisualComponents.Create3D Namespace


IProductTypeComponentTemplate.VCID Property

IProductTypeComponentTemplateVCID Property

Gets the unique component type identifier.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string VCID { get; }
property String^ VCID {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IProductTypeComponentTemplate Interface
VisualComponents.Create3D Namespace


IProductTypeComponentTemplate Methods

The IProductTypeComponentTemplate type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProductTypeComponentTemplate Interface
VisualComponents.Create3D Namespace


IProductTypeComponentTemplate Events

The IProductTypeComponentTemplate type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
See Also

Reference

IProductTypeComponentTemplate Interface
VisualComponents.Create3D Namespace


IProductTypeManager Interface

The product type manager is used to create, modify and delete IProductType objects. It is owned by an IProcessController.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProductTypeManager : IWrapper,
    IDisposable
public interface class IProductTypeManager : IWrapper,
    IDisposable

The IProductTypeManager type exposes the following members.

Properties
 | Name | Description
Public property | Controller | Gets the instance of IProcessController that owns this IProductTypeManager.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductTypes | Gets all the instances of IProductType managed by this IProductTypeManager.
Top
Methods
 | Name | Description
Public method | CloneProductType | Creates a cloned instance of given IProductType.
Public method | CreateProductType | Creates a new instance of IProductType.
Public method | DeleteProductType | Tries to delete the given IProductType. Can’t delete system product types or product types from a different IProcessController.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | ProductTypeAdded | Occurs when a new instance of IProductType is added to this instance of IProductTypeManager.
Public event | ProductTypeRemoved | Occurs when an instance of IProductType has been removed from this instance of IProductTypeManager.
Public event | ProductTypeRemoving | Occurs when an instance of IProductType is being removed from this instance of IProductTypeManager.
Public event | ProductTypeReplaced | Occurs when an instance of IProductType has been replaced by another type, e.g. when a newer version of that type is loaded.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProductTypeManager Properties

The IProductTypeManager type exposes the following members.

Properties
 | Name | Description
Public property | Controller | Gets the instance of IProcessController that owns this IProductTypeManager.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductTypes | Gets all the instances of IProductType managed by this IProductTypeManager.
Top
See Also

Reference

IProductTypeManager Interface
VisualComponents.Create3D Namespace


IProductTypeManager.Controller Property

IProductTypeManagerController Property

Gets the instance of IProcessController that owns this IProductTypeManager.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessController Controller { get; }
property IProcessController^ Controller {
    IProcessController^ get ();
}

Property Value

Type: IProcessController
See Also

Reference

IProductTypeManager Interface
VisualComponents.Create3D Namespace


IProductTypeManager.ProductTypes Property

IProductTypeManagerProductTypes Property

Gets all the instances of IProductType managed by this IProductTypeManager.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<IProductType> ProductTypes { get; }
property IReadOnlyList<IProductType^>^ ProductTypes {
    IReadOnlyList<IProductType^>^ get ();
}

Return Value

Type: IReadOnlyListIProductType
A collection that holds all the items present when this getter was called.
Remarks
Returns a collection that holds all the items present when this getter was called.
See Also

Reference

IProductTypeManager Interface
VisualComponents.Create3D Namespace


IProductTypeManager Methods

The IProductTypeManager type exposes the following members.

Methods
 | Name | Description
Public method | CloneProductType | Creates a cloned instance of given IProductType.
Public method | CreateProductType | Creates a new instance of IProductType.
Public method | DeleteProductType | Tries to delete the given IProductType. Can’t delete system product types or product types from a different IProcessController.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProductTypeManager Interface
VisualComponents.Create3D Namespace


IProductTypeManager.CloneProductType Method

IProductTypeManagerCloneProductType Method

Creates a cloned instance of given IProductType.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProductType CloneProductType(
    string name,
    IProductType type,
    IProcessFlowGroup groupToPlaceObject
)
IProductType^ CloneProductType(
    String^ name,
    IProductType^ type,
    IProcessFlowGroup^ groupToPlaceObject
)

Parameters

name
Type: SystemString
The name of the product type to be created. Must be unique.
type
Type: VisualComponents.Create3DIProductType
The (assembly) product type to clone
groupToPlaceObject
Type: VisualComponents.Create3DIProcessFlowGroup
The group that the name product type will be placed into.

Return Value

Type: IProductType
Cloned (assembly) product type
Exceptions
Exception | Condition
ArgumentNullException |
ArgumentException | Raised when name is not unique.
See Also

Reference

IProductTypeManager Interface
VisualComponents.Create3D Namespace


IProductTypeManager.CreateProductType Method

IProductTypeManagerCreateProductType Method

Creates a new instance of IProductType.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProductType CreateProductType(
    string name,
    IProcessFlowGroup groupToPlaceObject
)
IProductType^ CreateProductType(
    String^ name,
    IProcessFlowGroup^ groupToPlaceObject
)

Parameters

name
Type: SystemString
The name of the product type to be created. Must be unique.
groupToPlaceObject
Type: VisualComponents.Create3DIProcessFlowGroup
The group that the name product type will be placed into.

Return Value

Type: IProductType
Created product type.
Exceptions
Exception | Condition
ArgumentNullException |
ArgumentException | Raised when name is not unique.
See Also

Reference

IProductTypeManager Interface
VisualComponents.Create3D Namespace


IProductTypeManager.DeleteProductType Method

IProductTypeManagerDeleteProductType Method

Tries to delete the given IProductType. Can’t delete system product types or product types from a different IProcessController.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteProductType(
    IProductType type
)
void DeleteProductType(
    IProductType^ type
)

Parameters

type
Type: VisualComponents.Create3DIProductType
The product type to be deleted.
Exceptions
Exception | Condition
ArgumentNullException |
InvalidOperationException |
See Also

Reference

IProductTypeManager Interface
VisualComponents.Create3D Namespace


IProductTypeManager Events

The IProductTypeManager type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | ProductTypeAdded | Occurs when a new instance of IProductType is added to this instance of IProductTypeManager.
Public event | ProductTypeRemoved | Occurs when an instance of IProductType has been removed from this instance of IProductTypeManager.
Public event | ProductTypeRemoving | Occurs when an instance of IProductType is being removed from this instance of IProductTypeManager.
Public event | ProductTypeReplaced | Occurs when an instance of IProductType has been replaced by another type, e.g. when a newer version of that type is loaded.
Top
See Also

Reference

IProductTypeManager Interface
VisualComponents.Create3D Namespace


IProductTypeManager.ProductTypeAdded Event

IProductTypeManagerProductTypeAdded Event

Occurs when a new instance of IProductType is added to this instance of IProductTypeManager.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ProductTypeAddedEventArgs> ProductTypeAdded
 event EventHandler<ProductTypeAddedEventArgs^>^ ProductTypeAdded {
    void add (EventHandler<ProductTypeAddedEventArgs^>^ value);
    void remove (EventHandler<ProductTypeAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerProductTypeAddedEventArgs
See Also

Reference

IProductTypeManager Interface
VisualComponents.Create3D Namespace


IProductTypeManager.ProductTypeRemoved Event

IProductTypeManagerProductTypeRemoved Event

Occurs when an instance of IProductType has been removed from this instance of IProductTypeManager.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ProductTypeRemovedEventArgs> ProductTypeRemoved
 event EventHandler<ProductTypeRemovedEventArgs^>^ ProductTypeRemoved {
    void add (EventHandler<ProductTypeRemovedEventArgs^>^ value);
    void remove (EventHandler<ProductTypeRemovedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerProductTypeRemovedEventArgs
See Also

Reference

IProductTypeManager Interface
VisualComponents.Create3D Namespace


IProductTypeManager.ProductTypeRemoving Event

IProductTypeManagerProductTypeRemoving Event

Occurs when an instance of IProductType is being removed from this instance of IProductTypeManager.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ProductTypeRemovingEventArgs> ProductTypeRemoving
 event EventHandler<ProductTypeRemovingEventArgs^>^ ProductTypeRemoving {
    void add (EventHandler<ProductTypeRemovingEventArgs^>^ value);
    void remove (EventHandler<ProductTypeRemovingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerProductTypeRemovingEventArgs
See Also

Reference

IProductTypeManager Interface
VisualComponents.Create3D Namespace


IProductTypeManager.ProductTypeReplaced Event

IProductTypeManagerProductTypeReplaced Event

Occurs when an instance of IProductType has been replaced by another type, e.g. when a newer version of that type is loaded.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ProductTypeReplacedEventArgs> ProductTypeReplaced
 event EventHandler<ProductTypeReplacedEventArgs^>^ ProductTypeReplaced {
    void add (EventHandler<ProductTypeReplacedEventArgs^>^ value);
    void remove (EventHandler<ProductTypeReplacedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerProductTypeReplacedEventArgs
See Also

Reference

IProductTypeManager Interface
VisualComponents.Create3D Namespace


IProgram Interface

Robot program interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProgram : INamed,
    IPropertyContainer, IBatchModeObject, IPositionFrameContainer, IWrapper, IDisposable
public interface class IProgram : INamed,
    IPropertyContainer, IBatchModeObject, IPositionFrameContainer, IWrapper, IDisposable

The IProgram type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Executor | Gets the IExecutor who owns this IProgram
Public property | IsPositionsLockedToWorld | Defines if all the IPositionStatement instances in this IProgram are locked to world.
Public property | IsPublic | Gets or sets the public visibility of this instance of IProgram. Positions of a public program can be made public used in all instances of IPositionStatement belonging to the same instance of IRobotExecutor.
Public property | IsSystem | Defines if this instance of IProgram is created by the application (i.e. the default program of the executor).
Public property | IsValid | (Inherited from IWrapper.)
Public property | MainRoutine | Gets the main IRoutine of this IProgram.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Positions | Gets all the positions in this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routines | Gets the all the IRoutine instances of this IProgram.
Top
Methods
 | Name | Description
Public method | AddRoutine(String) | Creates a new IRoutine instance and adds it to this IProgram.
Public method | AddRoutine(IRoutine) | Adds an existing IRoutine instance and adds it to this IProgram.
Public method | AddRoutine(String, Boolean) | Creates a new IRoutine instance and adds it to this IProgram.
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ClearPositions | Clears all IPositionFrame instances from this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public method | CreatePosition | Creates a new IPositionFrame instance and adds it to this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeletePosition | Deletes the given IPositionFrame from this IPositionFrameContainer and deletes it (see remarks). (Inherited from IPositionFrameContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetUniquePositionName | Gets a unique position name by appending the given prefix with an index.
Public method | GetUniqueStatementName | Gets a unique statement name by appending the given prefix with an index.
Public method | InsertRoutine | Inserts the given Routine to the given position.
Public method | MoveRoutine | Moves the given routine to the new position inside this instance of IProgram.
Public method | RemoveRoutine | Removes the given IRoutine from this IProgram.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PositionAdded | Occurs when a new instance of IPositionFrame has been added to this instance of IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public event | PositionRemoving | Occurs when an instance of IPositionFrame is being removed from this instance of IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | RoutineAdded | Occurs when a new IRoutine is added to this IProgram.
Public event | RoutineRemoving | Occurs when an instance of IRoutine is being removed from this IProgram.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProgram Properties

The IProgram type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Executor | Gets the IExecutor who owns this IProgram
Public property | IsPositionsLockedToWorld | Defines if all the IPositionStatement instances in this IProgram are locked to world.
Public property | IsPublic | Gets or sets the public visibility of this instance of IProgram. Positions of a public program can be made public used in all instances of IPositionStatement belonging to the same instance of IRobotExecutor.
Public property | IsSystem | Defines if this instance of IProgram is created by the application (i.e. the default program of the executor).
Public property | IsValid | (Inherited from IWrapper.)
Public property | MainRoutine | Gets the main IRoutine of this IProgram.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Positions | Gets all the positions in this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routines | Gets the all the IRoutine instances of this IProgram.
Top
See Also

Reference

IProgram Interface
VisualComponents.Create3D Namespace


IProgram.Executor Property

IProgramExecutor Property

Gets the IExecutor who owns this IProgram

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IExecutor Executor { get; }
property IExecutor^ Executor {
    IExecutor^ get ();
}

Property Value

Type: IExecutor
See Also

Reference

IProgram Interface
VisualComponents.Create3D Namespace


IProgram.IsPositionsLockedToWorld Property

IProgramIsPositionsLockedToWorld Property

Defines if all the IPositionStatement instances in this IProgram are locked to world.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsPositionsLockedToWorld { get; set; }
property bool IsPositionsLockedToWorld {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IProgram Interface
VisualComponents.Create3D Namespace


IProgram.IsPublic Property

IProgramIsPublic Property

Gets or sets the public visibility of this instance of IProgram. Positions of a public program can be made public used in all instances of IPositionStatement belonging to the same instance of IRobotExecutor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsPublic { get; set; }
property bool IsPublic {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IProgram Interface
VisualComponents.Create3D Namespace


IProgram.IsSystem Property

IProgramIsSystem Property

Defines if this instance of IProgram is created by the application (i.e. the default program of the executor).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsSystem { get; }
property bool IsSystem {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IProgram Interface
VisualComponents.Create3D Namespace


IProgram.MainRoutine Property

IProgramMainRoutine Property

Gets the main IRoutine of this IProgram.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRoutine MainRoutine { get; }
property IRoutine^ MainRoutine {
    IRoutine^ get ();
}

Property Value

Type: IRoutine
See Also

Reference

IProgram Interface
VisualComponents.Create3D Namespace


IProgram.Routines Property

IProgramRoutines Property

Gets the all the IRoutine instances of this IProgram.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IRoutine> Routines { get; }
property ReadOnlyCollection<IRoutine^>^ Routines {
    ReadOnlyCollection<IRoutine^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIRoutine
See Also

Reference

IProgram Interface
VisualComponents.Create3D Namespace


IProgram Methods

The IProgram type exposes the following members.

Methods
 | Name | Description
Public method | AddRoutine(String) | Creates a new IRoutine instance and adds it to this IProgram.
Public method | AddRoutine(IRoutine) | Adds an existing IRoutine instance and adds it to this IProgram.
Public method | AddRoutine(String, Boolean) | Creates a new IRoutine instance and adds it to this IProgram.
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ClearPositions | Clears all IPositionFrame instances from this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public method | CreatePosition | Creates a new IPositionFrame instance and adds it to this IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeletePosition | Deletes the given IPositionFrame from this IPositionFrameContainer and deletes it (see remarks). (Inherited from IPositionFrameContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetUniquePositionName | Gets a unique position name by appending the given prefix with an index.
Public method | GetUniqueStatementName | Gets a unique statement name by appending the given prefix with an index.
Public method | InsertRoutine | Inserts the given Routine to the given position.
Public method | MoveRoutine | Moves the given routine to the new position inside this instance of IProgram.
Public method | RemoveRoutine | Removes the given IRoutine from this IProgram.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProgram Interface
VisualComponents.Create3D Namespace


IProgram.AddRoutine Method

IProgramAddRoutine Method

Overload List
 | Name | Description
Public method | AddRoutine(String) | Creates a new IRoutine instance and adds it to this IProgram.
Public method | AddRoutine(IRoutine) | Adds an existing IRoutine instance and adds it to this IProgram.
Public method | AddRoutine(String, Boolean) | Creates a new IRoutine instance and adds it to this IProgram.
Top
See Also

Reference

IProgram Interface
VisualComponents.Create3D Namespace


IProgram.AddRoutine Method (String)

IProgramAddRoutine Method (String)

Creates a new IRoutine instance and adds it to this IProgram.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRoutine AddRoutine(
    string name
)
IRoutine^ AddRoutine(
    String^ name
)

Parameters

name
Type: SystemString
Name of the routine to be created.

Return Value

Type: IRoutine
Created routine.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when name parameter is null.
See Also

Reference

IProgram Interface
AddRoutine Overload
VisualComponents.Create3D Namespace


IProgram.AddRoutine Method (IRoutine)

IProgramAddRoutine Method (IRoutine)

Adds an existing IRoutine instance and adds it to this IProgram.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddRoutine(
    IRoutine routine
)
void AddRoutine(
    IRoutine^ routine
)

Parameters

routine
Type: VisualComponents.Create3DIRoutine
Routine to add.
See Also

Reference

IProgram Interface
AddRoutine Overload
VisualComponents.Create3D Namespace


IProgram.AddRoutine Method (String, Boolean)

IProgramAddRoutine Method (String, Boolean)

Creates a new IRoutine instance and adds it to this IProgram.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRoutine AddRoutine(
    string name,
    bool validateName
)
IRoutine^ AddRoutine(
    String^ name,
    bool validateName
)

Parameters

name
Type: SystemString
Name of the routine to be created.
validateName
Type: SystemBoolean
Last integer in the name will be automatically incremented to the next available index.

Return Value

Type: IRoutine
Created routine.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when name parameter is null.
See Also

Reference

IProgram Interface
AddRoutine Overload
VisualComponents.Create3D Namespace


IProgram.GetUniquePositionName Method

IProgramGetUniquePositionName Method

Gets a unique position name by appending the given prefix with an index.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string GetUniquePositionName(
    string prefix
)
String^ GetUniquePositionName(
    String^ prefix
)

Parameters

prefix
Type: SystemString
Prefix that is going to be appended with an index.

Return Value

Type: String
Unique position name in the scope of this program.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when prefix is null or empty.
See Also

Reference

IProgram Interface
VisualComponents.Create3D Namespace


IProgram.GetUniqueStatementName Method

IProgramGetUniqueStatementName Method

Gets a unique statement name by appending the given prefix with an index.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string GetUniqueStatementName(
    string prefix
)
String^ GetUniqueStatementName(
    String^ prefix
)

Parameters

prefix
Type: SystemString
Prefix that is going to be appended with an index.

Return Value

Type: String
Unique statement name in the scope of this program.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when prefix is null or empty.
See Also

Reference

IProgram Interface
VisualComponents.Create3D Namespace


IProgram.InsertRoutine Method

IProgramInsertRoutine Method

Inserts the given Routine to the given position.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void InsertRoutine(
    IRoutine routine,
    int index
)
void InsertRoutine(
    IRoutine^ routine,
    int index
)

Parameters

routine
Type: VisualComponents.Create3DIRoutine
Routine to be inserted.
index
Type: SystemInt32
Position for the routine.
Remarks
MainRoutine cannot be moved, it will always occupy the first index
See Also

Reference

IProgram Interface
VisualComponents.Create3D Namespace


IProgram.MoveRoutine Method

IProgramMoveRoutine Method

Moves the given routine to the new position inside this instance of IProgram.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void MoveRoutine(
    IRoutine routine,
    int index
)
void MoveRoutine(
    IRoutine^ routine,
    int index
)

Parameters

routine
Type: VisualComponents.Create3DIRoutine
Routine to be moved.
index
Type: SystemInt32
New position for the routine.
Remarks
MainRoutine cannot be moved, it will always occupy the first index
See Also

Reference

IProgram Interface
VisualComponents.Create3D Namespace


IProgram.RemoveRoutine Method

IProgramRemoveRoutine Method

Removes the given IRoutine from this IProgram.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RemoveRoutine(
    IRoutine routine
)
void RemoveRoutine(
    IRoutine^ routine
)

Parameters

routine
Type: VisualComponents.Create3DIRoutine
Routine to be removed.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when routine parameter is null.
InvalidOperationException | Occurs when: -Trying to delete routine that does not belong to this program -Trying to delete the main routine -Trying to delete the system routine
See Also

Reference

IProgram Interface
VisualComponents.Create3D Namespace


IProgram Events

The IProgram type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PositionAdded | Occurs when a new instance of IPositionFrame has been added to this instance of IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public event | PositionRemoving | Occurs when an instance of IPositionFrame is being removed from this instance of IPositionFrameContainer. (Inherited from IPositionFrameContainer.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | RoutineAdded | Occurs when a new IRoutine is added to this IProgram.
Public event | RoutineRemoving | Occurs when an instance of IRoutine is being removed from this IProgram.
Top
See Also

Reference

IProgram Interface
VisualComponents.Create3D Namespace


IProgram.RoutineAdded Event

IProgramRoutineAdded Event

Occurs when a new IRoutine is added to this IProgram.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<RoutineAddedEventArgs> RoutineAdded
 event EventHandler<RoutineAddedEventArgs^>^ RoutineAdded {
    void add (EventHandler<RoutineAddedEventArgs^>^ value);
    void remove (EventHandler<RoutineAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerRoutineAddedEventArgs
See Also

Reference

IProgram Interface
VisualComponents.Create3D Namespace


IProgram.RoutineRemoving Event

IProgramRoutineRemoving Event

Occurs when an instance of IRoutine is being removed from this IProgram.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<RoutineRemovingEventArgs> RoutineRemoving
 event EventHandler<RoutineRemovingEventArgs^>^ RoutineRemoving {
    void add (EventHandler<RoutineRemovingEventArgs^>^ value);
    void remove (EventHandler<RoutineRemovingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerRoutineRemovingEventArgs
See Also

Reference

IProgram Interface
VisualComponents.Create3D Namespace


IProgramSerializer Interface

Utility to serialize and deserialize IProgram instances.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProgramSerializer
public interface class IProgramSerializer
Methods
 | Name | Description
Public method | Deserialize(IProgram, String, Boolean) | Deserializes the given xml string to the given IProgram.
Public method | Deserialize(IRoutine, String, Boolean) | Deserializes the given xml string to the given IRoutine.
Public method | Deserialize(IStatementExecutor, String, Boolean) | Deserializes the given xml string to the given IStatementExecutor.
Public method | Deserialize(IProgram, String, Boolean, IProgressContext) | Deserializes the given xml string to the given IProgram.
Public method | Serialize(IProgram, Boolean) | Serializes the given IProgram and returns the result in xml.
Public method | Serialize(IRoutine, Boolean) | Serializes the given IRoutine and returns the result in xml.
Public method | Serialize(IStatementExecutor, Boolean) | Serializes the given IStatementExecutor and returns the result in xml.
Public method | Serialize(IProgram, Boolean, Boolean) | Serializes the given IProgram and returns the result in xml.
Public method | Serialize(IProgram, Boolean, IProgressContext) | Serializes the given IProgram and returns the result in xml.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProgramSerializer Methods

Methods
 | Name | Description
Public method | Deserialize(IProgram, String, Boolean) | Deserializes the given xml string to the given IProgram.
Public method | Deserialize(IRoutine, String, Boolean) | Deserializes the given xml string to the given IRoutine.
Public method | Deserialize(IStatementExecutor, String, Boolean) | Deserializes the given xml string to the given IStatementExecutor.
Public method | Deserialize(IProgram, String, Boolean, IProgressContext) | Deserializes the given xml string to the given IProgram.
Public method | Serialize(IProgram, Boolean) | Serializes the given IProgram and returns the result in xml.
Public method | Serialize(IRoutine, Boolean) | Serializes the given IRoutine and returns the result in xml.
Public method | Serialize(IStatementExecutor, Boolean) | Serializes the given IStatementExecutor and returns the result in xml.
Public method | Serialize(IProgram, Boolean, Boolean) | Serializes the given IProgram and returns the result in xml.
Public method | Serialize(IProgram, Boolean, IProgressContext) | Serializes the given IProgram and returns the result in xml.
Top
See Also

Reference

IProgramSerializer Interface
VisualComponents.Create3D Namespace


IProgramSerializer.Deserialize Method

IProgramSerializerDeserialize Method

Overload List
 | Name | Description
Public method | Deserialize(IProgram, String, Boolean) | Deserializes the given xml string to the given IProgram.
Public method | Deserialize(IRoutine, String, Boolean) | Deserializes the given xml string to the given IRoutine.
Public method | Deserialize(IStatementExecutor, String, Boolean) | Deserializes the given xml string to the given IStatementExecutor.
Public method | Deserialize(IProgram, String, Boolean, IProgressContext) | Deserializes the given xml string to the given IProgram.
Top
See Also

Reference

IProgramSerializer Interface
VisualComponents.Create3D Namespace


IProgramSerializer.Deserialize Method (IProgram, String, Boolean)

IProgramSerializerDeserialize Method (IProgram, String, Boolean)

Deserializes the given xml string to the given IProgram.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Deserialize(
    IProgram programToDeserialize,
    string programData,
    bool fromLayout
)
void Deserialize(
    IProgram^ programToDeserialize,
    String^ programData,
    bool fromLayout
)

Parameters

programToDeserialize
Type: VisualComponents.Create3DIProgram
Program where the data is to be deserialized.
programData
Type: SystemString
Progam data to be deserialized in xml.
fromLayout
Type: SystemBoolean
See Also

Reference

IProgramSerializer Interface
Deserialize Overload
VisualComponents.Create3D Namespace


IProgramSerializer.Deserialize Method (IRoutine, String, Boolean)

IProgramSerializerDeserialize Method (IRoutine, String, Boolean)

Deserializes the given xml string to the given IRoutine.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Deserialize(
    IRoutine routineToDeserialize,
    string routineData,
    bool fromLayout
)
void Deserialize(
    IRoutine^ routineToDeserialize,
    String^ routineData,
    bool fromLayout
)

Parameters

routineToDeserialize
Type: VisualComponents.Create3DIRoutine
Routine where the data is to be deserialized.
routineData
Type: SystemString
Routine data to be deserialized in xml.
fromLayout
Type: SystemBoolean
See Also

Reference

IProgramSerializer Interface
Deserialize Overload
VisualComponents.Create3D Namespace


IProgramSerializer.Deserialize Method (IStatementExecutor, String, Boolean)

IProgramSerializerDeserialize Method (IStatementExecutor, String, Boolean)

Deserializes the given xml string to the given IStatementExecutor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Deserialize(
    IStatementExecutor executor,
    string programData,
    bool fromLayout
)
void Deserialize(
    IStatementExecutor^ executor,
    String^ programData,
    bool fromLayout
)

Parameters

executor
Type: VisualComponents.Create3DIStatementExecutor
programData
Type: SystemString
fromLayout
Type: SystemBoolean
See Also

Reference

IProgramSerializer Interface
Deserialize Overload
VisualComponents.Create3D Namespace


IProgramSerializer.Deserialize Method (IProgram, String, Boolean, IProgressContext)

IProgramSerializerDeserialize Method (IProgram, String, Boolean, IProgressContext)

Deserializes the given xml string to the given IProgram.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Deserialize(
    IProgram programToDeserialize,
    string programData,
    bool fromLayout,
    IProgressContext progressContext
)
void Deserialize(
    IProgram^ programToDeserialize,
    String^ programData,
    bool fromLayout,
    IProgressContext^ progressContext
)

Parameters

programToDeserialize
Type: VisualComponents.Create3DIProgram
Program where the data is to be deserialized.
programData
Type: SystemString
Progam data to be deserialized in xml.
fromLayout
Type: SystemBoolean
progressContext
Type: VisualComponents.Create3DIProgressContext
Progress context to report deserialization progress.
See Also

Reference

IProgramSerializer Interface
Deserialize Overload
VisualComponents.Create3D Namespace


IProgramSerializer.Serialize Method

IProgramSerializerSerialize Method

Overload List
 | Name | Description
Public method | Serialize(IProgram, Boolean) | Serializes the given IProgram and returns the result in xml.
Public method | Serialize(IRoutine, Boolean) | Serializes the given IRoutine and returns the result in xml.
Public method | Serialize(IStatementExecutor, Boolean) | Serializes the given IStatementExecutor and returns the result in xml.
Public method | Serialize(IProgram, Boolean, Boolean) | Serializes the given IProgram and returns the result in xml.
Public method | Serialize(IProgram, Boolean, IProgressContext) | Serializes the given IProgram and returns the result in xml.
Top
See Also

Reference

IProgramSerializer Interface
VisualComponents.Create3D Namespace


IProgramSerializer.Serialize Method (IProgram, Boolean)

IProgramSerializerSerialize Method (IProgram, Boolean)

Serializes the given IProgram and returns the result in xml.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Serialize(
    IProgram programToSerialize,
    bool toLayout
)
String^ Serialize(
    IProgram^ programToSerialize,
    bool toLayout
)

Parameters

programToSerialize
Type: VisualComponents.Create3DIProgram
Program to be serialized.
toLayout
Type: SystemBoolean

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.IProgramSerializer.Serialize(VisualComponents.Create3D.IProgram,System.Boolean)"]

See Also

Reference

IProgramSerializer Interface
Serialize Overload
VisualComponents.Create3D Namespace


IProgramSerializer.Serialize Method (IRoutine, Boolean)

IProgramSerializerSerialize Method (IRoutine, Boolean)

Serializes the given IRoutine and returns the result in xml.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Serialize(
    IRoutine routineToSerialize,
    bool toLayout
)
String^ Serialize(
    IRoutine^ routineToSerialize,
    bool toLayout
)

Parameters

routineToSerialize
Type: VisualComponents.Create3DIRoutine
Routine to be serialized.
toLayout
Type: SystemBoolean

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.IProgramSerializer.Serialize(VisualComponents.Create3D.IRoutine,System.Boolean)"]

See Also

Reference

IProgramSerializer Interface
Serialize Overload
VisualComponents.Create3D Namespace


IProgramSerializer.Serialize Method (IStatementExecutor, Boolean)

IProgramSerializerSerialize Method (IStatementExecutor, Boolean)

Serializes the given IStatementExecutor and returns the result in xml.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Serialize(
    IStatementExecutor executor,
    bool toLayout
)
String^ Serialize(
    IStatementExecutor^ executor,
    bool toLayout
)

Parameters

executor
Type: VisualComponents.Create3DIStatementExecutor
Executor to be serialized.
toLayout
Type: SystemBoolean

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.IProgramSerializer.Serialize(VisualComponents.Create3D.IStatementExecutor,System.Boolean)"]

Remarks
Serialization contains all executor's programs.
See Also

Reference

IProgramSerializer Interface
Serialize Overload
VisualComponents.Create3D Namespace


IProgramSerializer.Serialize Method (IProgram, Boolean, Boolean)

IProgramSerializerSerialize Method (IProgram, Boolean, Boolean)

Serializes the given IProgram and returns the result in xml.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Serialize(
    IProgram programToSerialize,
    bool toLayout,
    bool includeIds
)
String^ Serialize(
    IProgram^ programToSerialize,
    bool toLayout,
    bool includeIds
)

Parameters

programToSerialize
Type: VisualComponents.Create3DIProgram
Program to be serialized.
toLayout
Type: SystemBoolean
includeIds
Type: SystemBoolean
includes Pointer information for IWrapper type of objects

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.IProgramSerializer.Serialize(VisualComponents.Create3D.IProgram,System.Boolean,System.Boolean)"]

See Also

Reference

IProgramSerializer Interface
Serialize Overload
VisualComponents.Create3D Namespace


IProgramSerializer.Serialize Method (IProgram, Boolean, IProgressContext)

IProgramSerializerSerialize Method (IProgram, Boolean, IProgressContext)

Serializes the given IProgram and returns the result in xml.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Serialize(
    IProgram programToSerialize,
    bool toLayout,
    IProgressContext progressContext
)
String^ Serialize(
    IProgram^ programToSerialize,
    bool toLayout,
    IProgressContext^ progressContext
)

Parameters

programToSerialize
Type: VisualComponents.Create3DIProgram
Program to be serialized.
toLayout
Type: SystemBoolean
progressContext
Type: VisualComponents.Create3DIProgressContext
Progress context to report serialization progress.

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.IProgramSerializer.Serialize(VisualComponents.Create3D.IProgram,System.Boolean,VisualComponents.Create3D.IProgressContext)"]

See Also

Reference

IProgramSerializer Interface
Serialize Overload
VisualComponents.Create3D Namespace


IProgramSyncStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProgramSyncStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IProgramSyncStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IProgramSyncStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | SyncComponents |
Public property | SyncMessage |
Public property | WaitSync |
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetSyncComponents |
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProgramSyncStatement Properties

The IProgramSyncStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | SyncComponents |
Public property | SyncMessage |
Public property | WaitSync |
Top
See Also

Reference

IProgramSyncStatement Interface
VisualComponents.Create3D Namespace


IProgramSyncStatement.SyncComponents Property

IProgramSyncStatementSyncComponents Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ISimComponent> SyncComponents { get; }
property ReadOnlyCollection<ISimComponent^>^ SyncComponents {
    ReadOnlyCollection<ISimComponent^>^ get ();
}

Property Value

Type: ReadOnlyCollectionISimComponent
See Also

Reference

IProgramSyncStatement Interface
VisualComponents.Create3D Namespace


IProgramSyncStatement.SyncMessage Property

IProgramSyncStatementSyncMessage Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string SyncMessage { get; set; }
property String^ SyncMessage {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IProgramSyncStatement Interface
VisualComponents.Create3D Namespace


IProgramSyncStatement.WaitSync Property

IProgramSyncStatementWaitSync Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool WaitSync { get; set; }
property bool WaitSync {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IProgramSyncStatement Interface
VisualComponents.Create3D Namespace


IProgramSyncStatement Methods

The IProgramSyncStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetSyncComponents |
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IProgramSyncStatement Interface
VisualComponents.Create3D Namespace


IProgramSyncStatement.SetSyncComponents Method

IProgramSyncStatementSetSyncComponents Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetSyncComponents(
    IEnumerable<ISimComponent> components
)
void SetSyncComponents(
    IEnumerable<ISimComponent^>^ components
)

Parameters

components
Type: System.Collections.GenericIEnumerableISimComponent
See Also

Reference

IProgramSyncStatement Interface
VisualComponents.Create3D Namespace


IProgramSyncStatement Events

The IProgramSyncStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IProgramSyncStatement Interface
VisualComponents.Create3D Namespace


IProgressContext Interface

Progress context manages progress bar data.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProgressContext
public interface class IProgressContext

The IProgressContext type exposes the following members.

Properties
 | Name | Description
Public property | CanCancel | Returns true or false whether the current task supports cancelation.
Public property | IsEnabled | Enables or disables progress bar updates.
Public property | IsIndeterminate | Gets or sets whether the progress context has actual values or generic, continuous progress feedback.
Public property | Status | Progress bar status
Public property | Value | Step value of the progress bar. Between 0 and 1
Top
Methods
 | Name | Description
Public method | Cancel | Cancel current task.
Top
Events
 | Name | Description
Public event | OnProgress |
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProgressContext Properties

The IProgressContext type exposes the following members.

Properties
 | Name | Description
Public property | CanCancel | Returns true or false whether the current task supports cancelation.
Public property | IsEnabled | Enables or disables progress bar updates.
Public property | IsIndeterminate | Gets or sets whether the progress context has actual values or generic, continuous progress feedback.
Public property | Status | Progress bar status
Public property | Value | Step value of the progress bar. Between 0 and 1
Top
See Also

Reference

IProgressContext Interface
VisualComponents.Create3D Namespace


IProgressContext.CanCancel Property

IProgressContextCanCancel Property

Returns true or false whether the current task supports cancelation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanCancel { get; }
property bool CanCancel {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IProgressContext Interface
VisualComponents.Create3D Namespace


IProgressContext.IsEnabled Property

IProgressContextIsEnabled Property

Enables or disables progress bar updates.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsEnabled { get; set; }
property bool IsEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IProgressContext Interface
VisualComponents.Create3D Namespace


IProgressContext.IsIndeterminate Property

IProgressContextIsIndeterminate Property

Gets or sets whether the progress context has actual values or generic, continuous progress feedback.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsIndeterminate { get; set; }
property bool IsIndeterminate {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IProgressContext Interface
VisualComponents.Create3D Namespace


IProgressContext.Status Property

IProgressContextStatus Property

Progress bar status

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Status { get; set; }
property String^ Status {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IProgressContext Interface
VisualComponents.Create3D Namespace


IProgressContext.Value Property

IProgressContextValue Property

Step value of the progress bar. Between 0 and 1

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Value { get; set; }
property double Value {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IProgressContext Interface
VisualComponents.Create3D Namespace


IProgressContext Methods

The IProgressContext type exposes the following members.

Methods
 | Name | Description
Public method | Cancel | Cancel current task.
Top
See Also

Reference

IProgressContext Interface
VisualComponents.Create3D Namespace


IProgressContext.Cancel Method

IProgressContextCancel Method

Cancel current task.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Cancel()
void Cancel()
See Also

Reference

IProgressContext Interface
VisualComponents.Create3D Namespace


IProgressContext Events

The IProgressContext type exposes the following members.

Events
 | Name | Description
Public event | OnProgress |
Top
See Also

Reference

IProgressContext Interface
VisualComponents.Create3D Namespace


IProgressContext.OnProgress Event

IProgressContextOnProgress Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ProgressEventArgs> OnProgress
 event EventHandler<ProgressEventArgs^>^ OnProgress {
    void add (EventHandler<ProgressEventArgs^>^ value);
    void remove (EventHandler<ProgressEventArgs^>^ value);
}

Value

Type: SystemEventHandlerProgressEventArgs
See Also

Reference

IProgressContext Interface
VisualComponents.Create3D Namespace


IProgressStatusSource Interface

Progress status source interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProgressStatusSource
public interface class IProgressStatusSource

The IProgressStatusSource type exposes the following members.

Properties
 | Name | Description
Public property | IsUpdatingProgress | Indicates whether the progress of a long running operation is being updated.
Top
Remarks
This interface is implemented by the application object.
See Also

Reference

VisualComponents.Create3D Namespace


IProgressStatusSource Properties

The IProgressStatusSource type exposes the following members.

Properties
 | Name | Description
Public property | IsUpdatingProgress | Indicates whether the progress of a long running operation is being updated.
Top
See Also

Reference

IProgressStatusSource Interface
VisualComponents.Create3D Namespace


IProgressStatusSource.IsUpdatingProgress Property

IProgressStatusSourceIsUpdatingProgress Property

Indicates whether the progress of a long running operation is being updated.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsUpdatingProgress { get; }
property bool IsUpdatingProgress {
    bool get ();
}

Property Value

Type: Boolean
Remarks
This is true if a progress context is being updated. In the process, the application will process the event loop to check if the process needs to be canceled. During this time, no other simulation events are processed, to prevent corrupting the simulation state.
See Also

Reference

IProgressStatusSource Interface
VisualComponents.Create3D Namespace


IProperty Interface

Non-generic property interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProperty : INotifyPropertyChanged,
    IDisposable, INamed
public interface class IProperty : INotifyPropertyChanged,
    IDisposable, INamed

The IProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Allowed maximum value for the property.
Public property | AllowedMinimum | Allowed minimum value for the property.
Public property | AllowedValues | Collection of allowed values for constrained properties.
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property.
Public property | Category | Property grouping category name.
Public property | ConstraintType | Property constraint type.
Public property | Container | Property container object that contains this property.
Public property | CreationTypes | Read-only list of available creation types.
Public property | Description | Localized property description string.
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled.
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties.
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function.
Public property | History | Obsolete.
Public property | IsDesignTime | Whether the property is intended for component design time use only.
Public property | IsInternal | Whether the property is internally defined.
Public property | IsLocked | Whether the containing object is currently locked, or not.
Public property | IsPersistent | Whether the property is saved with the component or layout.
Public property | IsQuantityValue |
Public property | IsReadOnly | When true, the Value can't be set through the API.
Public property | IsVisible | Whether the property should be displayed in the UI.
Public property | IsVisibleDesignTime |
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number.
Public property | PropertyType | Property value type.
Public property | Quantity |
Public property | TabHeader | Property page tab header.
Public property | Unit | Effective unit of property.
Public property | Value | Property value as an object.
Top
Methods
 | Name | Description
Public method | Clone |
Public method | CreateAndSetNewValue | Set this property to a newly-created value.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching.
Public method | SetQuantity |
Public method | SetUnitMagnitude | Select an appropriate unit.
Public method | StartBatch | Start property batch updating.
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IProperty Properties

The IProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Allowed maximum value for the property.
Public property | AllowedMinimum | Allowed minimum value for the property.
Public property | AllowedValues | Collection of allowed values for constrained properties.
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property.
Public property | Category | Property grouping category name.
Public property | ConstraintType | Property constraint type.
Public property | Container | Property container object that contains this property.
Public property | CreationTypes | Read-only list of available creation types.
Public property | Description | Localized property description string.
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled.
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties.
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function.
Public property | History | Obsolete.
Public property | IsDesignTime | Whether the property is intended for component design time use only.
Public property | IsInternal | Whether the property is internally defined.
Public property | IsLocked | Whether the containing object is currently locked, or not.
Public property | IsPersistent | Whether the property is saved with the component or layout.
Public property | IsQuantityValue |
Public property | IsReadOnly | When true, the Value can't be set through the API.
Public property | IsVisible | Whether the property should be displayed in the UI.
Public property | IsVisibleDesignTime |
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number.
Public property | PropertyType | Property value type.
Public property | Quantity |
Public property | TabHeader | Property page tab header.
Public property | Unit | Effective unit of property.
Public property | Value | Property value as an object.
Top
See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.AllowedMaximum Property

IPropertyAllowedMaximum Property

Allowed maximum value for the property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IComparable AllowedMaximum { get; set; }
property IComparable^ AllowedMaximum {
    IComparable^ get ();
    void set (IComparable^ value);
}

Property Value

Type: IComparable
Remarks

This may only be accessed when ConstraintType is set to PropertyConstraintType.AllowedRangeOnly.

For custom properties, this value can be set.

For internal properties, this value is usually read-only.

See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.AllowedMinimum Property

IPropertyAllowedMinimum Property

Allowed minimum value for the property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IComparable AllowedMinimum { get; set; }
property IComparable^ AllowedMinimum {
    IComparable^ get ();
    void set (IComparable^ value);
}

Property Value

Type: IComparable
Remarks

This may only be accessed when ConstraintType is set to PropertyConstraintType.AllowedRangeOnly.

For custom properties, this value can be set.

For internal properties, this value is usually read-only.

See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.AllowedValues Property

IPropertyAllowedValues Property

Collection of allowed values for constrained properties.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ICollection<PropertyAllowedValue> AllowedValues { get; }
property ICollection<PropertyAllowedValue>^ AllowedValues {
    ICollection<PropertyAllowedValue>^ get ();
}

Property Value

Type: ICollectionPropertyAllowedValue
Remarks

This may only be read when ConstraintType is set to PropertyConstraintType.AllowedValueSetOnly.

For custom simple properties, the returned collection can be manipulated to change the available values.

For object reference properties, the collection is typically read-only.

See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.CanCreateNewValue Property

IPropertyCanCreateNewValue Property

Enable/disable collecting statistics for this property.
True if this property can be set to a newly created value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanCreateNewValue { get; }
property bool CanCreateNewValue {
    bool get ();
}

Property Value

Type: Boolean
Remarks
This is true for object reference properties with a well- defined default object value. Clients that render this property should include a "Create New" option among the other choices.
See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.Category Property

IPropertyCategory Property

Property grouping category name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Category { get; set; }
property String^ Category {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks

This value is session specific, and not persisted anywhere.

See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.ConstraintType Property

IPropertyConstraintType Property

Property constraint type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
PropertyConstraintType ConstraintType { get; }
property PropertyConstraintType ConstraintType {
    PropertyConstraintType get ();
}

Property Value

Type: PropertyConstraintType
See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.Container Property

IPropertyContainer Property

Property container object that contains this property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPropertyContainer Container { get; }
property IPropertyContainer^ Container {
    IPropertyContainer^ get ();
}

Property Value

Type: IPropertyContainer
See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.CreationTypes Property

IPropertyCreationTypes Property

Read-only list of available creation types.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<string> CreationTypes { get; }
property IList<String^>^ CreationTypes {
    IList<String^>^ get ();
}

Property Value

Type: IListString
Remarks
The creation types may be in the format "XXXX=YYYY" where XXXX is the actual type, and YYYY is a localized description string. If the number of supported types is exactly one, the string may be empty. If CanCreateNewValue is false, this property is an empty list.
See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.Description Property

IPropertyDescription Property

Localized property description string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Description { get; set; }
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks

This value is not implemented.

See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.DisabledStateToolTip Property

IPropertyDisabledStateToolTip Property

Localized property tooltip string shown when property is disabled.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string DisabledStateToolTip { get; set; }
property String^ DisabledStateToolTip {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks

Property value can be disabled so that editing is prohabited.This property contain message why editing is disabled.

See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.DistributionExpression Property

IPropertyDistributionExpression Property

The distribution expression for pseudo-random distribution. properties.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string DistributionExpression { get; set; }
property String^ DistributionExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks

A pseudo-random distribution property returns a pseudo- random value every time it is read. The value is computed according to the given distribution expression.

See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.HasDistribution Property

IPropertyHasDistribution Property

Whether this is a pseudo-random property with a defined distribution function.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool HasDistribution { get; }
property bool HasDistribution {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.History Property

IPropertyHistory Property

Note: This API is now obsolete.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("This property is obsolete. It always return null.",
    true)]
ReadOnlyCollection<HistoryItem> History { get; }
[ObsoleteAttribute(L"This property is obsolete. It always return null.",
    true)]
property ReadOnlyCollection<HistoryItem>^ History {
    ReadOnlyCollection<HistoryItem>^ get ();
}

Property Value

Type: ReadOnlyCollectionHistoryItem
See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.IsDesignTime Property

IPropertyIsDesignTime Property

Whether the property is intended for component design time use only.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsDesignTime { get; }
property bool IsDesignTime {
    bool get ();
}

Property Value

Type: Boolean
Remarks

Design time properties are used during component authoring and not shown during simulation.

Setting this property in internal property objects is not allowed.

See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.IsInternal Property

IPropertyIsInternal Property

Whether the property is internally defined.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsInternal { get; }
property bool IsInternal {
    bool get ();
}

Property Value

Type: Boolean
Remarks

Unlike custom properties, internally defined properties are typically protected from deletion and/or manipulation.

See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.IsLocked Property

IPropertyIsLocked Property

Whether the containing object is currently locked, or not.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsLocked { get; }
property bool IsLocked {
    bool get ();
}

Property Value

Type: Boolean
Remarks

This is true for e.g. properties of locked components.

See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.IsPersistent Property

IPropertyIsPersistent Property

Whether the property is saved with the component or layout.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsPersistent { get; set; }
property bool IsPersistent {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks

Persisted properties are written to the component or layout file when the file is saved.

In the case of custom properties, if IsPersistent is false, the property is not written at all, and will not be present once the component or layout is reloaded from file.

For internal properties, a non-persistent property may or may not be present after reloading. In case it is present, the value is typically reset to a default value.

Setting this property on internal property objects is not allowed.

See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.IsQuantityValue Property

IPropertyIsQuantityValue Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsQuantityValue { get; }
property bool IsQuantityValue {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.IsReadOnly Property

IPropertyIsReadOnly Property

When true, the Value can't be set through the API.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsReadOnly { get; set; }
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
The read-only state of of Properties can't be changed through the API either i.e. the setter does nothing.
See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.IsVisible Property

IPropertyIsVisible Property

Whether the property should be displayed in the UI.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsVisible { get; set; }
property bool IsVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.IsVisibleDesignTime Property

IPropertyIsVisibleDesignTime Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsVisibleDesignTime { get; }
property bool IsVisibleDesignTime {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.Order Property

IPropertyOrder Property

Property display order number.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int Order { get; set; }
property int Order {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks

In the property panel, properties are ordered by ascending order number first, then alphabetically by name.

See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.PropertyType Property

IPropertyPropertyType Property

Property value type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Type PropertyType { get; }
property Type^ PropertyType {
    Type^ get ();
}

Property Value

Type: Type
Remarks

The value of Value when read is guaranteed to be convertible to this type.

See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.Quantity Property

IPropertyQuantity Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IScalarQuantity Quantity { get; }
property IScalarQuantity^ Quantity {
    IScalarQuantity^ get ();
}

Property Value

Type: IScalarQuantity
See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.TabHeader Property

IPropertyTabHeader Property

Property page tab header.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string TabHeader { get; set; }
property String^ TabHeader {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks

Properties with the same tab header are displayed on the same page in the property panel.

This value is session specific and not persisted in any way.

See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.Unit Property

IPropertyUnit Property

Effective unit of property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IUnit Unit { get; }
property IUnit^ Unit {
    IUnit^ get ();
}

Property Value

Type: IUnit
Remarks

This is only applicable to the property types with real-type numeric based values, i.e. real, vector and matrix properties, and only if these have been associated a quantity. For these properties, this contains a unit object of the currently selected family that corresponds to the specified quantity and unit magnitude.

For all other properties, this value is null.

See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.Value Property

IPropertyValue Property

Property value as an object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object Value { get; set; }
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
Exceptions
Exception | Condition
InvalidCastException | Occurs when the new value can't be cast to the data type of the property.
PropertyException | Occurs when trying to set value of a read-only property.
See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty Methods

The IProperty type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | CreateAndSetNewValue | Set this property to a newly-created value.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching.
Public method | SetQuantity |
Public method | SetUnitMagnitude | Select an appropriate unit.
Public method | StartBatch | Start property batch updating.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.Clone Method

IPropertyClone Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProperty Clone()
IProperty^ Clone()

Return Value

Type: IProperty

[Missing <returns> documentation for "M:VisualComponents.Create3D.IProperty.Clone"]

See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.CreateAndSetNewValue Method

IPropertyCreateAndSetNewValue Method

Set this property to a newly-created value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object CreateAndSetNewValue(
    string creationType,
    bool setImmediately
)
Object^ CreateAndSetNewValue(
    String^ creationType,
    bool setImmediately
)

Parameters

creationType
Type: SystemString
Type of value to create.
setImmediately
Type: SystemBoolean

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.Create3D.IProperty.CreateAndSetNewValue(System.String,System.Boolean)"]

Exceptions
Exception | Condition
InvalidOperationException | Thrown if creationType is not valid.
NotSupportedException | Thrown if the property does not support new value creation.
Remarks

This method creates a new value, and sets the property to that value.

The value type specified must be one of the types in the CreationTypes property. If the creation type is in the format "XXXX=YYYY", both "XXXX" and "XXXX=YYYY" are valid forms.

See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.EndBatch Method

IPropertyEndBatch Method

End property value batching.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void EndBatch(
    bool cancel
)
void EndBatch(
    bool cancel
)

Parameters

cancel
Type: SystemBoolean
Cancel event changes if set
Remarks

This method ends property value batching and send´s only one value event change if property value was changed once or multiple times.

If method cancel parameter is called with true value then events is not triggered.

See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.SetQuantity Method

IPropertySetQuantity Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IUnitGroup SetQuantity(
    string value
)
IUnitGroup^ SetQuantity(
    String^ value
)

Parameters

value
Type: SystemString
Quantity name

Return Value

Type: IUnitGroup

[Missing <returns> documentation for "M:VisualComponents.Create3D.IProperty.SetQuantity(System.String)"]

See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.SetUnitMagnitude Method

IPropertySetUnitMagnitude Method

Select an appropriate unit.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetUnitMagnitude(
    double value
)
void SetUnitMagnitude(
    double value
)

Parameters

value
Type: SystemDouble
Unit magnitude, in canonical units for the quantity.
See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty.StartBatch Method

IPropertyStartBatch Method

Start property batch updating.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StartBatch()
void StartBatch()
Remarks

This method starts property value batch updating which will consolidate all value event changes for this property until EndBatch method is called.

See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty Events

The IProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IProperty Interface
VisualComponents.Create3D Namespace


IProperty(T) Interface

IPropertyT Interface

Generic property object interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProperty<T> : IProperty,
    INotifyPropertyChanged, IDisposable, INamed

generic<typename T>
public interface class IProperty : IProperty,
    INotifyPropertyChanged, IDisposable, INamed

Type Parameters

T
Property value type.

The IPropertyT type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Strongly typed allowed maximum value.
Public property | AllowedMinimum | Strongly typed allowed minimum value.
Public property | AllowedValues | Strongly typed container of allowed values.
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Strongly typed property value.
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
Remarks

This interface extends IProperty and replaces Value with a strongly typed version.

Most property objects support IProperty<T> in addition to the IProperty interface. Exceptions are expression properties, button properties, distribution properties and record list properties.

See Also

Reference

VisualComponents.Create3D Namespace


IProperty(T) Properties

IPropertyT Properties

The IPropertyT generic type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Strongly typed allowed maximum value.
Public property | AllowedMinimum | Strongly typed allowed minimum value.
Public property | AllowedValues | Strongly typed container of allowed values.
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Strongly typed property value.
Top
See Also

Reference

IPropertyT Interface
VisualComponents.Create3D Namespace


IProperty(T).AllowedMaximum Property

IPropertyTAllowedMaximum Property

Strongly typed allowed maximum value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
T AllowedMaximum { get; set; }
property T AllowedMaximum {
    T get ();
    void set (T value);
}

Property Value

Type: T
See Also

Reference

IPropertyT Interface
VisualComponents.Create3D Namespace


IProperty(T).AllowedMinimum Property

IPropertyTAllowedMinimum Property

Strongly typed allowed minimum value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
T AllowedMinimum { get; set; }
property T AllowedMinimum {
    T get ();
    void set (T value);
}

Property Value

Type: T
See Also

Reference

IPropertyT Interface
VisualComponents.Create3D Namespace


IProperty(T).AllowedValues Property

IPropertyTAllowedValues Property

Strongly typed container of allowed values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ICollection<PropertyAllowedValue<T>> AllowedValues { get; }
property ICollection<PropertyAllowedValue<T>>^ AllowedValues {
    ICollection<PropertyAllowedValue<T>>^ get ();
}

Property Value

Type: ICollectionPropertyAllowedValue T
See Also

Reference

IPropertyT Interface
VisualComponents.Create3D Namespace


IProperty(T).Value Property

IPropertyTValue Property

Strongly typed property value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
T Value { get; set; }
property T Value {
    T get ();
    void set (T value);
}

Property Value

Type: T
See Also

Reference

IPropertyT Interface
VisualComponents.Create3D Namespace


IProperty(T) Methods

IPropertyT Methods

The IPropertyT generic type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

IPropertyT Interface
VisualComponents.Create3D Namespace


IProperty(T) Events

IPropertyT Events

The IPropertyT generic type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IPropertyT Interface
VisualComponents.Create3D Namespace


IPropertyChangedScriptEventHandler Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPropertyChangedScriptEventHandler
public interface class IPropertyChangedScriptEventHandler

The IPropertyChangedScriptEventHandler type exposes the following members.

Methods
 | Name | Description
Public method | OnPropertyChanged |
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPropertyChangedScriptEventHandler Methods

The IPropertyChangedScriptEventHandler type exposes the following members.

Methods
 | Name | Description
Public method | OnPropertyChanged |
Top
See Also

Reference

IPropertyChangedScriptEventHandler Interface
VisualComponents.Create3D Namespace


IPropertyChangedScriptEventHandler.OnPropertyChanged Method

IPropertyChangedScriptEventHandlerOnPropertyChanged Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void OnPropertyChanged(
    Object sender,
    PropertyChangedEventArgs e
)
void OnPropertyChanged(
    Object^ sender,
    PropertyChangedEventArgs^ e
)

Parameters

sender
Type: SystemObject
e
Type: System.ComponentModelPropertyChangedEventArgs
See Also

Reference

IPropertyChangedScriptEventHandler Interface
VisualComponents.Create3D Namespace


IPropertyChangeFilter Interface

Property change notification filtering interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPropertyChangeFilter
public interface class IPropertyChangeFilter

The IPropertyChangeFilter type exposes the following members.

Properties
 | Name | Description
Public property | EventFilter | Comma separated list of allowed client type names.
Top
Remarks

This interface is implemented by objects that support limiting event notification delivery only to clients of a predefined set of actual types.

See Also

Reference

VisualComponents.Create3D Namespace


IPropertyChangeFilter Properties

The IPropertyChangeFilter type exposes the following members.

Properties
 | Name | Description
Public property | EventFilter | Comma separated list of allowed client type names.
Top
See Also

Reference

IPropertyChangeFilter Interface
VisualComponents.Create3D Namespace


IPropertyChangeFilter.EventFilter Property

IPropertyChangeFilterEventFilter Property

Comma separated list of allowed client type names.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string EventFilter { get; set; }
property String^ EventFilter {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks

When this property is empty, all clients receive event notifications. When the property is nonempty, only clients whose type is on the list receive change notifications.

See Also

Reference

IPropertyChangeFilter Interface
VisualComponents.Create3D Namespace


IPropertyConditionStatement Interface

A process requirement statement for evaluating if a given property's value matches the given condition. Triggers re-evaluation of the requirements section if the property's value changes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPropertyConditionStatement : IRequirementStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement>, ICloneable
public interface class IPropertyConditionStatement : IRequirementStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement^>, ICloneable

The IPropertyConditionStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConditionExpression | The condition to evaluate against the SelectedProperty.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | SelectedBehavior | The IBehavior to get the IProperty from. A null value means that the IProperty is selected from SelectedComponent.
Public property | SelectedComponent | The static ISimComponent to get the IProperty from. A null value means that SelectedBehavior is selected from the component owned by the IProcessExecutor that is running this IGetPropertyStatement.
Public property | SelectedProperty | The IProperty to get and then store into a process variable.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetSelectedProperty | Set the selected property and it's owning objects.
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPropertyConditionStatement Properties

The IPropertyConditionStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConditionExpression | The condition to evaluate against the SelectedProperty.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | SelectedBehavior | The IBehavior to get the IProperty from. A null value means that the IProperty is selected from SelectedComponent.
Public property | SelectedComponent | The static ISimComponent to get the IProperty from. A null value means that SelectedBehavior is selected from the component owned by the IProcessExecutor that is running this IGetPropertyStatement.
Public property | SelectedProperty | The IProperty to get and then store into a process variable.
Top
See Also

Reference

IPropertyConditionStatement Interface
VisualComponents.Create3D Namespace


IPropertyConditionStatement.ConditionExpression Property

IPropertyConditionStatementConditionExpression Property

The condition to evaluate against the SelectedProperty.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ConditionExpression { get; set; }
property String^ ConditionExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
This expression has access to UPM variables stored in IProcessRoutine.
See Also

Reference

IPropertyConditionStatement Interface
VisualComponents.Create3D Namespace


IPropertyConditionStatement.SelectedBehavior Property

IPropertyConditionStatementSelectedBehavior Property

The IBehavior to get the IProperty from.

A null value means that the IProperty is selected from SelectedComponent.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IBehavior SelectedBehavior { get; }
property IBehavior^ SelectedBehavior {
    IBehavior^ get ();
}

Property Value

Type: IBehavior
See Also

Reference

IPropertyConditionStatement Interface
VisualComponents.Create3D Namespace


IPropertyConditionStatement.SelectedComponent Property

IPropertyConditionStatementSelectedComponent Property

The static ISimComponent to get the IProperty from.

A null value means that SelectedBehavior is selected from the component owned by the IProcessExecutor that is running this IGetPropertyStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent SelectedComponent { get; }
property ISimComponent^ SelectedComponent {
    ISimComponent^ get ();
}

Property Value

Type: ISimComponent
See Also

Reference

IPropertyConditionStatement Interface
VisualComponents.Create3D Namespace


IPropertyConditionStatement.SelectedProperty Property

IPropertyConditionStatementSelectedProperty Property

The IProperty to get and then store into a process variable.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProperty SelectedProperty { get; }
property IProperty^ SelectedProperty {
    IProperty^ get ();
}

Property Value

Type: IProperty
See Also

Reference

IPropertyConditionStatement Interface
VisualComponents.Create3D Namespace


IPropertyConditionStatement Methods

The IPropertyConditionStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetSelectedProperty | Set the selected property and it's owning objects.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IPropertyConditionStatement Interface
VisualComponents.Create3D Namespace


IPropertyConditionStatement.SetSelectedProperty Method

IPropertyConditionStatementSetSelectedProperty Method

Set the selected property and it's owning objects.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetSelectedProperty(
    ISimComponent selectedComponent,
    IBehavior selectedBehavior,
    IProperty selectedProperty
)
void SetSelectedProperty(
    ISimComponent^ selectedComponent,
    IBehavior^ selectedBehavior,
    IProperty^ selectedProperty
)

Parameters

selectedComponent
Type: VisualComponents.Create3DISimComponent
See SelectedComponent.
selectedBehavior
Type: VisualComponents.Create3DIBehavior
See SelectedBehavior.
selectedProperty
Type: VisualComponents.Create3DIProperty
See SelectedProperty.
Exceptions
Exception | Condition
ArgumentException | If all the given arguments do not match.
ArgumentNullException | If selectedProperty is null
See Also

Reference

IPropertyConditionStatement Interface
VisualComponents.Create3D Namespace


IPropertyConditionStatement Events

The IPropertyConditionStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IPropertyConditionStatement Interface
VisualComponents.Create3D Namespace


IPropertyContainer Interface

Property container interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPropertyContainer : IBatchModeObject
public interface class IPropertyContainer : IBatchModeObject

The IPropertyContainer type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context.
Public property | Properties | List of property objects.
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties.
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties
Public property | PropertyValues | List of all property values. This list has the same order as Properties.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container.
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container.
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) |
Public method | DeleteProperty | Delete and invalidate the given property object.
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | GetProperty | Get an individual named property object.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning.
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name.
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name.
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index.
Top
Events
 | Name | Description
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container.
Top
Remarks

This is implemented by object that have a list of dynamic properties that may or may not be extended.

See Also

Reference

VisualComponents.Create3D Namespace


IPropertyContainer Properties

The IPropertyContainer type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context.
Public property | Properties | List of property objects.
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties.
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties
Public property | PropertyValues | List of all property values. This list has the same order as Properties.
Top
See Also

Reference

IPropertyContainer Interface
VisualComponents.Create3D Namespace


IPropertyContainer.ContainerExpressionContext Property

IPropertyContainerContainerExpressionContext Property

Property expression context.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IExpressionContext ContainerExpressionContext { get; }
property IExpressionContext^ ContainerExpressionContext {
    IExpressionContext^ get ();
}

Property Value

Type: IExpressionContext
Remarks

This is the expression context from the property container, which is used to evaluate any expression properties.

See Also

Reference

IPropertyContainer Interface
VisualComponents.Create3D Namespace


IPropertyContainer.Properties Property

IPropertyContainerProperties Property

List of property objects.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IProperty> Properties { get; }
property IList<IProperty^>^ Properties {
    IList<IProperty^>^ get ();
}

Property Value

Type: IListIProperty
Remarks

This list is editable if the underlying object allows properties to be edited, otherwise it is read-only.

See Also

Reference

IPropertyContainer Interface
VisualComponents.Create3D Namespace


IPropertyContainer.PropertyNames Property

IPropertyContainerPropertyNames Property

Get a list of all property names. This list has the same order as Properties.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<string> PropertyNames { get; }
property IEnumerable<String^>^ PropertyNames {
    IEnumerable<String^>^ get ();
}

Property Value

Type: IEnumerableString
See Also

Reference

IPropertyContainer Interface
VisualComponents.Create3D Namespace


IPropertyContainer.PropertyNamesAndValues Property

IPropertyContainerPropertyNamesAndValues Property

List of all name-value pairs. This list has the same order as Properties

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<Tuple<string, Object>> PropertyNamesAndValues { get; }
property IEnumerable<Tuple<String^, Object^>^>^ PropertyNamesAndValues {
    IEnumerable<Tuple<String^, Object^>^>^ get ();
}

Property Value

Type: IEnumerableTupleString, Object
See Also

Reference

IPropertyContainer Interface
VisualComponents.Create3D Namespace


IPropertyContainer.PropertyValues Property

IPropertyContainerPropertyValues Property

List of all property values. This list has the same order as Properties.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<Object> PropertyValues { get; }
property IEnumerable<Object^>^ PropertyValues {
    IEnumerable<Object^>^ get ();
}

Property Value

Type: IEnumerableObject
See Also

Reference

IPropertyContainer Interface
VisualComponents.Create3D Namespace


IPropertyContainer Methods

The IPropertyContainer type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container.
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container.
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) |
Public method | DeleteProperty | Delete and invalidate the given property object.
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | GetProperty | Get an individual named property object.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning.
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name.
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name.
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index.
Top
See Also

Reference

IPropertyContainer Interface
VisualComponents.Create3D Namespace


IPropertyContainer.CreateProperty Method

IPropertyContainerCreateProperty Method

Overload List
 | Name | Description
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container.
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container.
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) |
Top
See Also

Reference

IPropertyContainer Interface
VisualComponents.Create3D Namespace


IPropertyContainer.CreateProperty Method (Type, PropertyConstraintType)

IPropertyContainerCreateProperty Method (Type, PropertyConstraintType)

Create a property object that can be used with the property container.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProperty CreateProperty(
    Type valueType,
    PropertyConstraintType constraintType
)
IProperty^ CreateProperty(
    Type^ valueType,
    PropertyConstraintType constraintType
)

Parameters

valueType
Type: SystemType
Property value type
constraintType
Type: VisualComponents.Create3DPropertyConstraintType
Property constraint type

Return Value

Type: IProperty
The newly created property
Exceptions
Exception | Condition
NotSupportedException | Thrown if the given value type, constraint type, and/or combination of these is not supported by the property container.
InvalidOperationException | Thrown if the property container cannot be modified.
Remarks
The property is not automatically added to the container, so that has to be done separately, by adding it to the Properties list.
See Also

Reference

IPropertyContainer Interface
CreateProperty Overload
VisualComponents.Create3D Namespace


IPropertyContainer.CreateProperty Method (Type, PropertyConstraintType, String)

IPropertyContainerCreateProperty Method (Type, PropertyConstraintType, String)

Create a property object that can be used with the property container.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProperty CreateProperty(
    Type valueType,
    PropertyConstraintType constraintType,
    string name
)
IProperty^ CreateProperty(
    Type^ valueType,
    PropertyConstraintType constraintType,
    String^ name
)

Parameters

valueType
Type: SystemType
Property value type
constraintType
Type: VisualComponents.Create3DPropertyConstraintType
Property constraint type
name
Type: SystemString
Name of the property

Return Value

Type: IProperty
The newly created property
Exceptions
Exception | Condition
NotSupportedException | Thrown if the given value type, constraint type, and/or combination of these is not supported by the property container.
InvalidOperationException | Thrown if the property container cannot be modified.
Remarks
The property is not automatically added to the container, so that has to be done separately, by adding it to the Properties list.
See Also

Reference

IPropertyContainer Interface
CreateProperty Overload
VisualComponents.Create3D Namespace


IPropertyContainer.CreateProperty Method (Type, PropertyConstraintType, String, IProperty)

IPropertyContainerCreateProperty Method (Type, PropertyConstraintType, String, IProperty)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProperty CreateProperty(
    Type valueType,
    PropertyConstraintType constraintType,
    string name,
    IProperty toBeReplaced
)
IProperty^ CreateProperty(
    Type^ valueType,
    PropertyConstraintType constraintType,
    String^ name,
    IProperty^ toBeReplaced
)

Parameters

valueType
Type: SystemType
constraintType
Type: VisualComponents.Create3DPropertyConstraintType
name
Type: SystemString
toBeReplaced
Type: VisualComponents.Create3DIProperty

Return Value

Type: IProperty

[Missing <returns> documentation for "M:VisualComponents.Create3D.IPropertyContainer.CreateProperty(System.Type,VisualComponents.Create3D.PropertyConstraintType,System.String,VisualComponents.Create3D.IProperty)"]

See Also

Reference

IPropertyContainer Interface
CreateProperty Overload
VisualComponents.Create3D Namespace


IPropertyContainer.DeleteProperty Method

IPropertyContainerDeleteProperty Method

Delete and invalidate the given property object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteProperty(
    IProperty prop
)
void DeleteProperty(
    IProperty^ prop
)

Parameters

prop
Type: VisualComponents.Create3DIProperty
See Also

Reference

IPropertyContainer Interface
VisualComponents.Create3D Namespace


IPropertyContainer.GetProperty Method

IPropertyContainerGetProperty Method

Get an individual named property object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProperty GetProperty(
    string name
)
IProperty^ GetProperty(
    String^ name
)

Parameters

name
Type: SystemString
Property name

Return Value

Type: IProperty
Property object
See Also

Reference

IPropertyContainer Interface
VisualComponents.Create3D Namespace


IPropertyContainer.SetPropertyValues Method

IPropertyContainerSetPropertyValues Method

Overload List
 | Name | Description
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning.
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name.
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name.
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index.
Top
See Also

Reference

IPropertyContainer Interface
VisualComponents.Create3D Namespace


IPropertyContainer.SetPropertyValues Method (IEnumerable(Object))

IPropertyContainerSetPropertyValues Method (IEnumerableObject)

Set property values sequentially from the beginning.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetPropertyValues(
    IEnumerable<Object> values
)
void SetPropertyValues(
    IEnumerable<Object^>^ values
)

Parameters

values
Type: System.Collections.GenericIEnumerableObject
List of values
Remarks

If there are fewer values than properties, the properties at the end remain unchanged. If there are more values than properties, the values at the end are ignored.

See Also

Reference

IPropertyContainer Interface
SetPropertyValues Overload
VisualComponents.Create3D Namespace


IPropertyContainer.SetPropertyValues Method (IEnumerable(Tuple(String, Object)))

IPropertyContainerSetPropertyValues Method (IEnumerableTupleString, Object)

Set the property values by name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetPropertyValues(
    IEnumerable<Tuple<string, Object>> namesAndValues
)
void SetPropertyValues(
    IEnumerable<Tuple<String^, Object^>^>^ namesAndValues
)

Parameters

namesAndValues
Type: System.Collections.GenericIEnumerableTupleString, Object
List of name-value pairs
Remarks
If a name in a name-value pair does not correspond to an existing property, the pair is ignored.
See Also

Reference

IPropertyContainer Interface
SetPropertyValues Overload
VisualComponents.Create3D Namespace


IPropertyContainer.SetPropertyValues Method (IEnumerable(String), IEnumerable(Object))

IPropertyContainerSetPropertyValues Method (IEnumerableString, IEnumerableObject)

Set the property values by name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetPropertyValues(
    IEnumerable<string> names,
    IEnumerable<Object> values
)
void SetPropertyValues(
    IEnumerable<String^>^ names,
    IEnumerable<Object^>^ values
)

Parameters

names
Type: System.Collections.GenericIEnumerableString
List of names
values
Type: System.Collections.GenericIEnumerableObject
List of values
Remarks

If names and values are of different length, the last elements of the longer list are ignored. If a name does not correspond to an existing property, it and its corresponding value are ignored.

See Also

Reference

IPropertyContainer Interface
SetPropertyValues Overload
VisualComponents.Create3D Namespace


IPropertyContainer.SetPropertyValues Method (Int32, IEnumerable(Object))

IPropertyContainerSetPropertyValues Method (Int32, IEnumerableObject)

Set property values sequentially starting from the given index.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetPropertyValues(
    int startIndex,
    IEnumerable<Object> values
)
void SetPropertyValues(
    int startIndex,
    IEnumerable<Object^>^ values
)

Parameters

startIndex
Type: SystemInt32
Starting index
values
Type: System.Collections.GenericIEnumerableObject
List of values
Remarks

Properties before the given index remain unchanged. If there are fewer values than properties, the properties at the end remain unchanged. If there are more values than properties, the values at the end are ignored.

See Also

Reference

IPropertyContainer Interface
SetPropertyValues Overload
VisualComponents.Create3D Namespace


IPropertyContainer Events

The IPropertyContainer type exposes the following members.

Events
 | Name | Description
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container.
Top
See Also

Reference

IPropertyContainer Interface
VisualComponents.Create3D Namespace


IPropertyContainer.PropertyContainerChanged Event

IPropertyContainerPropertyContainerChanged Event

Raised when a property has been created, moved or removed within the property container.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<PropertyContainerChangedEventArgs> PropertyContainerChanged
 event EventHandler<PropertyContainerChangedEventArgs^>^ PropertyContainerChanged {
    void add (EventHandler<PropertyContainerChangedEventArgs^>^ value);
    void remove (EventHandler<PropertyContainerChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerPropertyContainerChangedEventArgs
Remarks
Important! Do not throw exceptions from your event handler code.
See Also

Reference

IPropertyContainer Interface
VisualComponents.Create3D Namespace


IPropertyContainerProperty Interface

Property container property interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPropertyContainerProperty : IProperty<Tuple<string, Object>[]>,
    IProperty, INotifyPropertyChanged, IDisposable, INamed
public interface class IPropertyContainerProperty : IProperty<array<Tuple<String^, Object^>^>^>,
    IProperty, INotifyPropertyChanged, IDisposable, INamed

The IPropertyContainerProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Strongly typed allowed maximum value. (Inherited from IPropertyT.)
Public property | AllowedMinimum | Strongly typed allowed minimum value. (Inherited from IPropertyT.)
Public property | AllowedValues | Strongly typed container of allowed values. (Inherited from IPropertyT.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | Properties | List of sub-properties that make up the property value.
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Strongly typed property value. (Inherited from IPropertyT.)
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPropertyContainerProperty Properties

The IPropertyContainerProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Strongly typed allowed maximum value. (Inherited from IPropertyT.)
Public property | AllowedMinimum | Strongly typed allowed minimum value. (Inherited from IPropertyT.)
Public property | AllowedValues | Strongly typed container of allowed values. (Inherited from IPropertyT.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | Properties | List of sub-properties that make up the property value.
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Strongly typed property value. (Inherited from IPropertyT.)
Top
See Also

Reference

IPropertyContainerProperty Interface
VisualComponents.Create3D Namespace


IPropertyContainerProperty.Properties Property

IPropertyContainerPropertyProperties Property

List of sub-properties that make up the property value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPropertyContainer Properties { get; }
property IPropertyContainer^ Properties {
    IPropertyContainer^ get ();
}

Property Value

Type: IPropertyContainer
Remarks

This property container object allows access to the individual properties that make up the value.

See Also

Reference

IPropertyContainerProperty Interface
VisualComponents.Create3D Namespace


IPropertyContainerProperty Methods

The IPropertyContainerProperty type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

IPropertyContainerProperty Interface
VisualComponents.Create3D Namespace


IPropertyContainerProperty Events

The IPropertyContainerProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IPropertyContainerProperty Interface
VisualComponents.Create3D Namespace


IPropertyEditorDisplayName Interface

Interface for objects that want to customize the property editor header to be different from Name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPropertyEditorDisplayName
public interface class IPropertyEditorDisplayName

The IPropertyEditorDisplayName type exposes the following members.

Properties
 | Name | Description
Public property | PropertyEditorDisplayName | Gets the name displayed in the property editor header.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPropertyEditorDisplayName Properties

The IPropertyEditorDisplayName type exposes the following members.

Properties
 | Name | Description
Public property | PropertyEditorDisplayName | Gets the name displayed in the property editor header.
Top
See Also

Reference

IPropertyEditorDisplayName Interface
VisualComponents.Create3D Namespace


IPropertyEditorDisplayName.PropertyEditorDisplayName Property

IPropertyEditorDisplayNamePropertyEditorDisplayName Property

Gets the name displayed in the property editor header.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string PropertyEditorDisplayName { get; }
property String^ PropertyEditorDisplayName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IPropertyEditorDisplayName Interface
VisualComponents.Create3D Namespace


IPySnapCommand Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPySnapCommand
public interface class IPySnapCommand

The IPySnapCommand type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | AutoExpansion |
Public property | CenterSnapOnControl |
Public property | CenterSnapOnShift |
Public property | ContinuousMode |
Public property | CurveAngleTolerance |
Public property | CurveDistanceTolerance |
Public property | SnapFilters |
Public property | SnapOnBoundType |
Public property | SnapOnCurveLoop |
Public property | SnapOnFaceLevel |
Public property | SnapOnFreePoint |
Public property | SnapOnFullTopology |
Public property | SnapOnMouseUp |
Public property | SnapOnSinglePart |
Public property | SnapResult |
Public property | TargetCurvesCount |
Public property | TopologySnap |
Top
Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | ClearAction |
Public method | DeleteLast |
Public method | GetSetFilters |
Public method | GetTargetCurvesCurve |
Public method | GetTargetCurvesPositions |
Public method | StartAction |
Top
Events
 | Name | Description
Public event | StopNativeAction |
Public event | TargetAvailable |
Public event | TargetSet |
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPySnapCommand Properties

The IPySnapCommand type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | AutoExpansion |
Public property | CenterSnapOnControl |
Public property | CenterSnapOnShift |
Public property | ContinuousMode |
Public property | CurveAngleTolerance |
Public property | CurveDistanceTolerance |
Public property | SnapFilters |
Public property | SnapOnBoundType |
Public property | SnapOnCurveLoop |
Public property | SnapOnFaceLevel |
Public property | SnapOnFreePoint |
Public property | SnapOnFullTopology |
Public property | SnapOnMouseUp |
Public property | SnapOnSinglePart |
Public property | SnapResult |
Public property | TargetCurvesCount |
Public property | TopologySnap |
Top
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.ActionFinished Property

IPySnapCommandActionFinished Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ActionFinished { get; }
property bool ActionFinished {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.AutoExpansion Property

IPySnapCommandAutoExpansion Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool AutoExpansion { get; set; }
property bool AutoExpansion {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.CenterSnapOnControl Property

IPySnapCommandCenterSnapOnControl Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CenterSnapOnControl { get; set; }
property bool CenterSnapOnControl {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.CenterSnapOnShift Property

IPySnapCommandCenterSnapOnShift Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CenterSnapOnShift { get; set; }
property bool CenterSnapOnShift {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.ContinuousMode Property

IPySnapCommandContinuousMode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ContinuousMode { get; set; }
property bool ContinuousMode {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.CurveAngleTolerance Property

IPySnapCommandCurveAngleTolerance Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double CurveAngleTolerance { get; set; }
property double CurveAngleTolerance {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.CurveDistanceTolerance Property

IPySnapCommandCurveDistanceTolerance Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double CurveDistanceTolerance { get; set; }
property double CurveDistanceTolerance {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.SnapFilters Property

IPySnapCommandSnapFilters Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<SnapType> SnapFilters { get; set; }
property IList<SnapType>^ SnapFilters {
    IList<SnapType>^ get ();
    void set (IList<SnapType>^ value);
}

Property Value

Type: IListSnapType
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.SnapOnBoundType Property

IPySnapCommandSnapOnBoundType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
SelectionTypes SnapOnBoundType { get; set; }
property SelectionTypes SnapOnBoundType {
    SelectionTypes get ();
    void set (SelectionTypes value);
}

Property Value

Type: SelectionTypes
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.SnapOnCurveLoop Property

IPySnapCommandSnapOnCurveLoop Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SnapOnCurveLoop { get; set; }
property bool SnapOnCurveLoop {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.SnapOnFaceLevel Property

IPySnapCommandSnapOnFaceLevel Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int SnapOnFaceLevel { get; set; }
property int SnapOnFaceLevel {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.SnapOnFreePoint Property

IPySnapCommandSnapOnFreePoint Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SnapOnFreePoint { get; set; }
property bool SnapOnFreePoint {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.SnapOnFullTopology Property

IPySnapCommandSnapOnFullTopology Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SnapOnFullTopology { get; set; }
property bool SnapOnFullTopology {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.SnapOnMouseUp Property

IPySnapCommandSnapOnMouseUp Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SnapOnMouseUp { get; set; }
property bool SnapOnMouseUp {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.SnapOnSinglePart Property

IPySnapCommandSnapOnSinglePart Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SnapOnSinglePart { get; set; }
property bool SnapOnSinglePart {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.SnapResult Property

IPySnapCommandSnapResult Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
SnapResult SnapResult { get; }
property SnapResult SnapResult {
    SnapResult get ();
}

Property Value

Type: SnapResult
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.TargetCurvesCount Property

IPySnapCommandTargetCurvesCount Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int TargetCurvesCount { get; }
property int TargetCurvesCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.TopologySnap Property

IPySnapCommandTopologySnap Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool TopologySnap { get; set; }
property bool TopologySnap {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand Methods

The IPySnapCommand type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | ClearAction |
Public method | DeleteLast |
Public method | GetSetFilters |
Public method | GetTargetCurvesCurve |
Public method | GetTargetCurvesPositions |
Public method | StartAction |
Top
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.ApplyAction Method

IPySnapCommandApplyAction Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ApplyAction()
void ApplyAction()
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.CancelAction Method

IPySnapCommandCancelAction Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void CancelAction()
void CancelAction()
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.ClearAction Method

IPySnapCommandClearAction Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ClearAction()
void ClearAction()
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.DeleteLast Method

IPySnapCommandDeleteLast Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteLast()
void DeleteLast()
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.GetSetFilters Method

IPySnapCommandGetSetFilters Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void GetSetFilters(
    bool doSet,
    SnapType type,
    IntPtr result
)
void GetSetFilters(
    bool doSet,
    SnapType type,
    IntPtr result
)

Parameters

doSet
Type: SystemBoolean
type
Type: VisualComponents.Create3DSnapType
result
Type: SystemIntPtr
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.GetTargetCurvesCurve Method

IPySnapCommandGetTargetCurvesCurve Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Tuple<ISimNode, IGeometrySet, int, bool> GetTargetCurvesCurve(
    int index
)
Tuple<ISimNode^, IGeometrySet^, int, bool>^ GetTargetCurvesCurve(
    int index
)

Parameters

index
Type: SystemInt32

Return Value

Type: TupleISimNode, IGeometrySet, Int32, Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IPySnapCommand.GetTargetCurvesCurve(System.Int32)"]

See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.GetTargetCurvesPositions Method

IPySnapCommandGetTargetCurvesPositions Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<Matrix> GetTargetCurvesPositions(
    int index
)
IList<Matrix>^ GetTargetCurvesPositions(
    int index
)

Parameters

index
Type: SystemInt32

Return Value

Type: IListMatrix

[Missing <returns> documentation for "M:VisualComponents.Create3D.IPySnapCommand.GetTargetCurvesPositions(System.Int32)"]

See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.StartAction Method

IPySnapCommandStartAction Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StartAction()
void StartAction()
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand Events

The IPySnapCommand type exposes the following members.

Events
 | Name | Description
Public event | StopNativeAction |
Public event | TargetAvailable |
Public event | TargetSet |
Top
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.StopNativeAction Event

IPySnapCommandStopNativeAction Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler StopNativeAction
 event EventHandler^ StopNativeAction {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.TargetAvailable Event

IPySnapCommandTargetAvailable Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler TargetAvailable
 event EventHandler^ TargetAvailable {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPySnapCommand.TargetSet Event

IPySnapCommandTargetSet Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler TargetSet
 event EventHandler^ TargetSet {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IPySnapCommand Interface
VisualComponents.Create3D Namespace


IPythonActionPanelCommand Interface

Provides access to the python action panel.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPythonActionPanelCommand
public interface class IPythonActionPanelCommand

The IPythonActionPanelCommand type exposes the following members.

Events
 | Name | Description
Public event | OnClosed | Event trigger when Python Action panel is closed
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPythonActionPanelCommand Events

The IPythonActionPanelCommand type exposes the following members.

Events
 | Name | Description
Public event | OnClosed | Event trigger when Python Action panel is closed
Top
See Also

Reference

IPythonActionPanelCommand Interface
VisualComponents.Create3D Namespace


IPythonActionPanelCommand.OnClosed Event

IPythonActionPanelCommandOnClosed Event

Event trigger when Python Action panel is closed

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler OnClosed
 event EventHandler^ OnClosed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IPythonActionPanelCommand Interface
VisualComponents.Create3D Namespace


IPythonCommand Interface

An interface for Python commands.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPythonCommand : IPythonInstance,
    IPropertyContainer, IBatchModeObject
public interface class IPythonCommand : IPythonInstance,
    IPropertyContainer, IBatchModeObject

The IPythonCommand type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | CommandFileName | Location of this Python command.
Public property | CommandName | Gets the name of this Python command.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsTracingEnabled | Whether tracing is enabled. (Inherited from IPythonInstance.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Script | Python code text.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Compile | Recompiles the script in this Python command.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Execute | Executes this Python command instance.
Public method | FindObjectType | Find the type of the given Python object name (Inherited from IPythonInstance.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | OnTrace | Trace event (Inherited from IPythonInstance.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPythonCommand Properties

The IPythonCommand type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | CommandFileName | Location of this Python command.
Public property | CommandName | Gets the name of this Python command.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsTracingEnabled | Whether tracing is enabled. (Inherited from IPythonInstance.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Script | Python code text.
Top
See Also

Reference

IPythonCommand Interface
VisualComponents.Create3D Namespace


IPythonCommand.CommandFileName Property

IPythonCommandCommandFileName Property

Location of this Python command.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string CommandFileName { get; }
property String^ CommandFileName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IPythonCommand Interface
VisualComponents.Create3D Namespace


IPythonCommand.CommandName Property

IPythonCommandCommandName Property

Gets the name of this Python command.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string CommandName { get; }
property String^ CommandName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IPythonCommand Interface
VisualComponents.Create3D Namespace


IPythonCommand.Script Property

IPythonCommandScript Property

Python code text.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Script { get; set; }
property String^ Script {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Implements

IPythonInstanceScript
See Also

Reference

IPythonCommand Interface
VisualComponents.Create3D Namespace


IPythonCommand Methods

The IPythonCommand type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Compile | Recompiles the script in this Python command.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Execute | Executes this Python command instance.
Public method | FindObjectType | Find the type of the given Python object name (Inherited from IPythonInstance.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IPythonCommand Interface
VisualComponents.Create3D Namespace


IPythonCommand.Compile Method

IPythonCommandCompile Method

Recompiles the script in this Python command.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Compile()
void Compile()

Implements

IPythonInstanceCompile
See Also

Reference

IPythonCommand Interface
VisualComponents.Create3D Namespace


IPythonCommand.Execute Method

IPythonCommandExecute Method

Executes this Python command instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ExecuteCommandResult Execute()
ExecuteCommandResult Execute()

Return Value

Type: ExecuteCommandResult

[Missing <returns> documentation for "M:VisualComponents.Create3D.IPythonCommand.Execute"]

See Also

Reference

IPythonCommand Interface
VisualComponents.Create3D Namespace


IPythonCommand Events

The IPythonCommand type exposes the following members.

Events
 | Name | Description
Public event | OnTrace | Trace event (Inherited from IPythonInstance.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IPythonCommand Interface
VisualComponents.Create3D Namespace


IPythonFeature Interface

Represents a python feature object

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPythonFeature : IFeature,
    IVisualObject, INamed, IWrapper, IDisposable, IVisitable,
    IPropertyContainer, IBatchModeObject, ISharedCloneable, IPythonInstance
public interface class IPythonFeature : IFeature,
    IVisualObject, INamed, IWrapper, IDisposable, IVisitable,
    IPropertyContainer, IBatchModeObject, ISharedCloneable, IPythonInstance

The IPythonFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsTracingEnabled | Whether tracing is enabled. (Inherited from IPythonInstance.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | Script | Python code text. (Inherited from IPythonInstance.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | Compile | Compile Python script. (Inherited from IPythonInstance.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | FindObjectType | Find the type of the given Python object name (Inherited from IPythonInstance.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | OnTrace | Trace event (Inherited from IPythonInstance.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
The Python script feature uses a custom Python script to generate the geometry. The geometry is generated by calling the OnEvaluate function in the script, if it is defined.
See Also

Reference

VisualComponents.Create3D Namespace


IPythonFeature Properties

The IPythonFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsTracingEnabled | Whether tracing is enabled. (Inherited from IPythonInstance.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | Script | Python code text. (Inherited from IPythonInstance.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
See Also

Reference

IPythonFeature Interface
VisualComponents.Create3D Namespace


IPythonFeature Methods

The IPythonFeature type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | Compile | Compile Python script. (Inherited from IPythonInstance.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | FindObjectType | Find the type of the given Python object name (Inherited from IPythonInstance.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IPythonFeature Interface
VisualComponents.Create3D Namespace


IPythonFeature Events

The IPythonFeature type exposes the following members.

Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | OnTrace | Trace event (Inherited from IPythonInstance.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

IPythonFeature Interface
VisualComponents.Create3D Namespace


IPythonInstance Interface

Python script instance interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPythonInstance
public interface class IPythonInstance

The IPythonInstance type exposes the following members.

Properties
 | Name | Description
Public property | IsTracingEnabled | Whether tracing is enabled.
Public property | Script | Python code text.
Top
Methods
 | Name | Description
Public method | Compile | Compile Python script.
Public method | FindObjectType | Find the type of the given Python object name
Top
Events
 | Name | Description
Public event | OnTrace | Trace event
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPythonInstance Properties

The IPythonInstance type exposes the following members.

Properties
 | Name | Description
Public property | IsTracingEnabled | Whether tracing is enabled.
Public property | Script | Python code text.
Top
See Also

Reference

IPythonInstance Interface
VisualComponents.Create3D Namespace


IPythonInstance.IsTracingEnabled Property

IPythonInstanceIsTracingEnabled Property

Whether tracing is enabled.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsTracingEnabled { get; set; }
property bool IsTracingEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPythonInstance Interface
VisualComponents.Create3D Namespace


IPythonInstance.Script Property

IPythonInstanceScript Property

Python code text.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Script { get; set; }
property String^ Script {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IPythonInstance Interface
VisualComponents.Create3D Namespace


IPythonInstance Methods

The IPythonInstance type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Compile Python script.
Public method | FindObjectType | Find the type of the given Python object name
Top
See Also

Reference

IPythonInstance Interface
VisualComponents.Create3D Namespace


IPythonInstance.Compile Method

IPythonInstanceCompile Method

Compile Python script.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Compile()
void Compile()
See Also

Reference

IPythonInstance Interface
VisualComponents.Create3D Namespace


IPythonInstance.FindObjectType Method

IPythonInstanceFindObjectType Method

Find the type of the given Python object name

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string FindObjectType(
    string objectName
)
String^ FindObjectType(
    String^ objectName
)

Parameters

objectName
Type: SystemString
name of the object

Return Value

Type: String
Object type as an string
See Also

Reference

IPythonInstance Interface
VisualComponents.Create3D Namespace


IPythonInstance Events

The IPythonInstance type exposes the following members.

Events
 | Name | Description
Public event | OnTrace | Trace event
Top
See Also

Reference

IPythonInstance Interface
VisualComponents.Create3D Namespace


IPythonInstance.OnTrace Event

IPythonInstanceOnTrace Event

Trace event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<PythonScriptTriggerEventArgs> OnTrace
 event EventHandler<PythonScriptTriggerEventArgs^>^ OnTrace {
    void add (EventHandler<PythonScriptTriggerEventArgs^>^ value);
    void remove (EventHandler<PythonScriptTriggerEventArgs^>^ value);
}

Value

Type: SystemEventHandlerPythonScriptTriggerEventArgs
See Also

Reference

IPythonInstance Interface
VisualComponents.Create3D Namespace


IPythonProcessHandler Interface

An interface for python process handler behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPythonProcessHandler : IProcessHandler,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed, IPythonSimInstance, IPythonInstance
public interface class IPythonProcessHandler : IProcessHandler,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed, IPythonSimInstance, IPythonInstance

The IPythonProcessHandler type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Icon | Process icon. (Inherited from IProcessHandler.)
Public property | IsTracingEnabled | Whether tracing is enabled. (Inherited from IPythonInstance.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Process | The name of the process. (Inherited from IProcessHandler.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Script | Python code text. (Inherited from IPythonInstance.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | BreakTaskletExecution | Stop tasklet execution if it is currently being executed. (Inherited from IPythonSimInstance.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Compile | Compile Python script. (Inherited from IPythonInstance.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | FindObjectType | Find the type of the given Python object name (Inherited from IPythonInstance.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | NotifyStatementModified | Invokes OnStatementModified in python script. (Inherited from IProcessHandler.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | OnTrace | Trace event (Inherited from IPythonInstance.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPythonProcessHandler Properties

The IPythonProcessHandler type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Icon | Process icon. (Inherited from IProcessHandler.)
Public property | IsTracingEnabled | Whether tracing is enabled. (Inherited from IPythonInstance.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Process | The name of the process. (Inherited from IProcessHandler.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Script | Python code text. (Inherited from IPythonInstance.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IPythonProcessHandler Interface
VisualComponents.Create3D Namespace


IPythonProcessHandler Methods

The IPythonProcessHandler type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | BreakTaskletExecution | Stop tasklet execution if it is currently being executed. (Inherited from IPythonSimInstance.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Compile | Compile Python script. (Inherited from IPythonInstance.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | FindObjectType | Find the type of the given Python object name (Inherited from IPythonInstance.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | NotifyStatementModified | Invokes OnStatementModified in python script. (Inherited from IProcessHandler.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IPythonProcessHandler Interface
VisualComponents.Create3D Namespace


IPythonProcessHandler Events

The IPythonProcessHandler type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | OnTrace | Trace event (Inherited from IPythonInstance.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IPythonProcessHandler Interface
VisualComponents.Create3D Namespace


IPythonScript Interface

An interface for Python Script behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPythonScript : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed, IPythonSimInstance, IPythonInstance
public interface class IPythonScript : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed, IPythonSimInstance, IPythonInstance

The IPythonScript type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsTracingEnabled | Whether tracing is enabled. (Inherited from IPythonInstance.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Script | Python code text. (Inherited from IPythonInstance.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | BreakTaskletExecution | Stop tasklet execution if it is currently being executed. (Inherited from IPythonSimInstance.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Compile | Compile Python script. (Inherited from IPythonInstance.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | FindObjectType | Find the type of the given Python object name (Inherited from IPythonInstance.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | OnTrace | Trace event (Inherited from IPythonInstance.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPythonScript Properties

The IPythonScript type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsTracingEnabled | Whether tracing is enabled. (Inherited from IPythonInstance.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Script | Python code text. (Inherited from IPythonInstance.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IPythonScript Interface
VisualComponents.Create3D Namespace


IPythonScript Methods

The IPythonScript type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | BreakTaskletExecution | Stop tasklet execution if it is currently being executed. (Inherited from IPythonSimInstance.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Compile | Compile Python script. (Inherited from IPythonInstance.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | FindObjectType | Find the type of the given Python object name (Inherited from IPythonInstance.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IPythonScript Interface
VisualComponents.Create3D Namespace


IPythonScript Events

The IPythonScript type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | OnTrace | Trace event (Inherited from IPythonInstance.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IPythonScript Interface
VisualComponents.Create3D Namespace


IPythonSimInstance Interface

Python simulation script instance interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPythonSimInstance : IPythonInstance
public interface class IPythonSimInstance : IPythonInstance

The IPythonSimInstance type exposes the following members.

Properties
 | Name | Description
Public property | IsTracingEnabled | Whether tracing is enabled. (Inherited from IPythonInstance.)
Public property | Script | Python code text. (Inherited from IPythonInstance.)
Top
Methods
 | Name | Description
Public method | BreakTaskletExecution | Stop tasklet execution if it is currently being executed.
Public method | Compile | Compile Python script. (Inherited from IPythonInstance.)
Public method | FindObjectType | Find the type of the given Python object name (Inherited from IPythonInstance.)
Top
Events
 | Name | Description
Public event | OnTrace | Trace event (Inherited from IPythonInstance.)
Top
Remarks

This interface extends IPythonInstance to include a method to break tasklet execution.

It is used in the wrappers for Python script based behaviors.

See Also

Reference

VisualComponents.Create3D Namespace


IPythonSimInstance Properties

The IPythonSimInstance type exposes the following members.

Properties
 | Name | Description
Public property | IsTracingEnabled | Whether tracing is enabled. (Inherited from IPythonInstance.)
Public property | Script | Python code text. (Inherited from IPythonInstance.)
Top
See Also

Reference

IPythonSimInstance Interface
VisualComponents.Create3D Namespace


IPythonSimInstance Methods

The IPythonSimInstance type exposes the following members.

Methods
 | Name | Description
Public method | BreakTaskletExecution | Stop tasklet execution if it is currently being executed.
Public method | Compile | Compile Python script. (Inherited from IPythonInstance.)
Public method | FindObjectType | Find the type of the given Python object name (Inherited from IPythonInstance.)
Top
See Also

Reference

IPythonSimInstance Interface
VisualComponents.Create3D Namespace


IPythonSimInstance.BreakTaskletExecution Method

IPythonSimInstanceBreakTaskletExecution Method

Stop tasklet execution if it is currently being executed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void BreakTaskletExecution()
void BreakTaskletExecution()
Remarks
This should be called only from the OnTrace event handler.
See Also

Reference

IPythonSimInstance Interface
VisualComponents.Create3D Namespace


IPythonSimInstance Events

The IPythonSimInstance type exposes the following members.

Events
 | Name | Description
Public event | OnTrace | Trace event (Inherited from IPythonInstance.)
Top
See Also

Reference

IPythonSimInstance Interface
VisualComponents.Create3D Namespace


IPythonTransportController Interface

Delegates implementation of the transport of ISimProduct instances over ITransportLinks to user-made Python script(s). Custom controllers can be created with CreateBehaviorByType(BehaviorType) using PythonTransportController.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPythonTransportController : ITransportController,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed
public interface class IPythonTransportController : ITransportController,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed

The IPythonTransportController type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Icon | Defines either filesystem path to the SVG image file or an SVG path data. Both relative and absolute paths with/without .svg extension are allowed. Defaults to an empty icon if path to the image or data itself is invalid.
Public property | IconColor | Defines SVG path fill for the Icon. Accepts values in ARGB, RGB or unqualified-color-name formats (i.e. #FFFF0000 or #FF0000 or Red). Defaults to black if the value can't be parsed into a valid Color.
Public property | IsSystem | Defines whether this controller is part of the application or user-defined. (Inherited from ITransportController.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IPythonTransportController Properties

The IPythonTransportController type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Icon | Defines either filesystem path to the SVG image file or an SVG path data. Both relative and absolute paths with/without .svg extension are allowed. Defaults to an empty icon if path to the image or data itself is invalid.
Public property | IconColor | Defines SVG path fill for the Icon. Accepts values in ARGB, RGB or unqualified-color-name formats (i.e. #FFFF0000 or #FF0000 or Red). Defaults to black if the value can't be parsed into a valid Color.
Public property | IsSystem | Defines whether this controller is part of the application or user-defined. (Inherited from ITransportController.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IPythonTransportController Interface
VisualComponents.Create3D Namespace


IPythonTransportController.Icon Property

IPythonTransportControllerIcon Property

Defines either filesystem path to the SVG image file or an SVG path data. Both relative and absolute paths with/without .svg extension are allowed. Defaults to an empty icon if path to the image or data itself is invalid.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Icon { get; set; }
property String^ Icon {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IPythonTransportController Interface
VisualComponents.Create3D Namespace


IPythonTransportController.IconColor Property

IPythonTransportControllerIconColor Property

Defines SVG path fill for the Icon. Accepts values in ARGB, RGB or unqualified-color-name formats (i.e. #FFFF0000 or #FF0000 or Red). Defaults to black if the value can't be parsed into a valid Color.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string IconColor { get; set; }
property String^ IconColor {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IPythonTransportController Interface
VisualComponents.Create3D Namespace


IPythonTransportController Methods

The IPythonTransportController type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IPythonTransportController Interface
VisualComponents.Create3D Namespace


IPythonTransportController Events

The IPythonTransportController type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IPythonTransportController Interface
VisualComponents.Create3D Namespace


IRay Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRay
public interface class IRay

The IRay type exposes the following members.

Properties
 | Name | Description
Public property | Position1 |
Public property | Position2 |
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRay Properties

The IRay type exposes the following members.

Properties
 | Name | Description
Public property | Position1 |
Public property | Position2 |
Top
See Also

Reference

IRay Interface
VisualComponents.Create3D Namespace


IRay.Position1 Property

IRayPosition1 Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 Position1 { get; set; }
property Vector3 Position1 {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

IRay Interface
VisualComponents.Create3D Namespace


IRay.Position2 Property

IRayPosition2 Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 Position2 { get; set; }
property Vector3 Position2 {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

IRay Interface
VisualComponents.Create3D Namespace


IRaycastCurveHelper Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRaycastCurveHelper
public interface class IRaycastCurveHelper

The IRaycastCurveHelper type exposes the following members.

Properties
 | Name | Description
Public property | AllowInnerEdge |
Public property | AllowOuterEdge |
Public property | InnerEdgeDetectionTolerance |
Public property | OuterEdgeDetectionTolerance |
Public property | PositionTolerance |
Public property | SearchDistance |
Public property | StepSize |
Top
Methods
 | Name | Description
Public method | ConstructPath |
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRaycastCurveHelper Properties

The IRaycastCurveHelper type exposes the following members.

Properties
 | Name | Description
Public property | AllowInnerEdge |
Public property | AllowOuterEdge |
Public property | InnerEdgeDetectionTolerance |
Public property | OuterEdgeDetectionTolerance |
Public property | PositionTolerance |
Public property | SearchDistance |
Public property | StepSize |
Top
See Also

Reference

IRaycastCurveHelper Interface
VisualComponents.Create3D Namespace


IRaycastCurveHelper.AllowInnerEdge Property

IRaycastCurveHelperAllowInnerEdge Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool AllowInnerEdge { get; set; }
property bool AllowInnerEdge {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRaycastCurveHelper Interface
VisualComponents.Create3D Namespace


IRaycastCurveHelper.AllowOuterEdge Property

IRaycastCurveHelperAllowOuterEdge Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool AllowOuterEdge { get; set; }
property bool AllowOuterEdge {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRaycastCurveHelper Interface
VisualComponents.Create3D Namespace


IRaycastCurveHelper.InnerEdgeDetectionTolerance Property

IRaycastCurveHelperInnerEdgeDetectionTolerance Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double InnerEdgeDetectionTolerance { get; set; }
property double InnerEdgeDetectionTolerance {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IRaycastCurveHelper Interface
VisualComponents.Create3D Namespace


IRaycastCurveHelper.OuterEdgeDetectionTolerance Property

IRaycastCurveHelperOuterEdgeDetectionTolerance Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double OuterEdgeDetectionTolerance { get; set; }
property double OuterEdgeDetectionTolerance {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IRaycastCurveHelper Interface
VisualComponents.Create3D Namespace


IRaycastCurveHelper.PositionTolerance Property

IRaycastCurveHelperPositionTolerance Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double PositionTolerance { get; set; }
property double PositionTolerance {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IRaycastCurveHelper Interface
VisualComponents.Create3D Namespace


IRaycastCurveHelper.SearchDistance Property

IRaycastCurveHelperSearchDistance Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double SearchDistance { get; set; }
property double SearchDistance {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IRaycastCurveHelper Interface
VisualComponents.Create3D Namespace


IRaycastCurveHelper.StepSize Property

IRaycastCurveHelperStepSize Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double StepSize { get; set; }
property double StepSize {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IRaycastCurveHelper Interface
VisualComponents.Create3D Namespace


IRaycastCurveHelper Methods

The IRaycastCurveHelper type exposes the following members.

Methods
 | Name | Description
Public method | ConstructPath |
Top
See Also

Reference

IRaycastCurveHelper Interface
VisualComponents.Create3D Namespace


IRaycastCurveHelper.ConstructPath Method

IRaycastCurveHelperConstructPath Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<RaycastPoint> ConstructPath(
    Matrix referencePosition,
    PathSnapperCornerStyle cornerStyle
)
IList<RaycastPoint^>^ ConstructPath(
    Matrix referencePosition,
    PathSnapperCornerStyle cornerStyle
)

Parameters

referencePosition
Type: VisualComponents.Create3DMatrix
cornerStyle
Type: VisualComponents.Create3DPathSnapperCornerStyle

Return Value

Type: IListRaycastPoint

[Missing <returns> documentation for "M:VisualComponents.Create3D.IRaycastCurveHelper.ConstructPath(VisualComponents.Create3D.Matrix,VisualComponents.Create3D.PathSnapperCornerStyle)"]

See Also

Reference

IRaycastCurveHelper Interface
VisualComponents.Create3D Namespace


IRaycastSensor Interface

An interface for ray cast behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRaycastSensor : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IRaycastSensor : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IRaycastSensor type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRaycastSensor Properties

The IRaycastSensor type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IRaycastSensor Interface
VisualComponents.Create3D Namespace


IRaycastSensor Methods

The IRaycastSensor type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRaycastSensor Interface
VisualComponents.Create3D Namespace


IRaycastSensor Events

The IRaycastSensor type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IRaycastSensor Interface
VisualComponents.Create3D Namespace


IRealPropertyCreator Interface

An interface for real property creator behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRealPropertyCreator : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IRealPropertyCreator : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IRealPropertyCreator type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace
VisualComponents.Create3DIStringPropertyCreator
VisualComponents.Create3DIIntegerPropertyCreator
VisualComponents.Create3DIBooleanPropertyCreator


IRealPropertyCreator Properties

The IRealPropertyCreator type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IRealPropertyCreator Interface
VisualComponents.Create3D Namespace


IRealPropertyCreator Methods

The IRealPropertyCreator type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRealPropertyCreator Interface
VisualComponents.Create3D Namespace


IRealPropertyCreator Events

The IRealPropertyCreator type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IRealPropertyCreator Interface
VisualComponents.Create3D Namespace


IRealSignal Interface

An interface for real signal behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRealSignal : ISignal,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed
public interface class IRealSignal : ISignal,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed

The IRealSignal type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsApplication | Defines if this ISignal instance has been created by the application for its internal use. (Inherited from ISignal.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Public property | Value | Gets or sets the value of this ISignal instance. (Inherited from ISignal.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanConnectTo | Defines if this ISignal instance can be connected to the given signal. (Inherited from ISignal.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect | Connects the given ISignal instance to the given signal. (Inherited from ISignal.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects this ISignal instance from the given signal. (Inherited from ISignal.)
Public method | DisconnectAll | Disconnects all ISignal instances connected to this signal. (Inherited from ISignal.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | SignalTrigger | Event that is raised when the value of this ISignal instance is changing. (Inherited from ISignal.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRealSignal Properties

The IRealSignal type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsApplication | Defines if this ISignal instance has been created by the application for its internal use. (Inherited from ISignal.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Public property | Value | Gets or sets the value of this ISignal instance. (Inherited from ISignal.)
Top
See Also

Reference

IRealSignal Interface
VisualComponents.Create3D Namespace


IRealSignal Methods

The IRealSignal type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanConnectTo | Defines if this ISignal instance can be connected to the given signal. (Inherited from ISignal.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect | Connects the given ISignal instance to the given signal. (Inherited from ISignal.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects this ISignal instance from the given signal. (Inherited from ISignal.)
Public method | DisconnectAll | Disconnects all ISignal instances connected to this signal. (Inherited from ISignal.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRealSignal Interface
VisualComponents.Create3D Namespace


IRealSignal Events

The IRealSignal type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | SignalTrigger | Event that is raised when the value of this ISignal instance is changing. (Inherited from ISignal.)
Top
See Also

Reference

IRealSignal Interface
VisualComponents.Create3D Namespace


IRealSignalMap Interface

An interface for real signal map behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRealSignalMap : ISignalMap,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed
public interface class IRealSignalMap : ISignalMap,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed

The IRealSignalMap type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConnectedExternalPorts | Returns all the connected external ports. The return value is a collection of tuples where the first item is the internal port number number and the second item is a port number in connected external map. (Inherited from ISignalMap.)
Public property | ConnectedExternalSignals | Returns all the connected signals in external components. The return value is a collection of tuples where the first item is the internal port number number and the second item is an external signal connected to the port. (Inherited from ISignalMap.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | MapCount | Gets the number of ports connected to ISignal instances. This matches SignalCount. (Inherited from ISignalMap.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | PortCount | Gets the total number of ports in this signal map. (Inherited from ISignalMap.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SignalCount | Gets the number of ISignal instances behind this signal map. (Inherited from ISignalMap.)
Public property | StartIndex | Gets the ports starting index. (Inherited from ISignalMap.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect(Int32, ISignal) | Connects the signal behind the given port to the given ISignal instance. (Inherited from ISignalMap.)
Public method | Connect(Int32, ISignalMap, Int32) | Connects the ISignal instance behind the given port to the signal behind the port behind the given map. (Inherited from ISignalMap.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | CreateSignal | Creates a ISignal instance at the given port. (Inherited from ISignalMap.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteSignalConnection(Int32) | Deletes all ISignal instances connected to the signal at the given port. Also deletes disconnected application signals. (Inherited from ISignalMap.)
Public method | DeleteSignalConnection(Int32, Boolean) | Deletes all ISignal instances connected to the signal at the given port. (Inherited from ISignalMap.)
Public method | DeleteSignalConnection(Int32, Boolean, ISignal) | Disconnects the ISignal instance at the given port from the given signal. The signal will maintain its other connections (if any). (Inherited from ISignalMap.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects the ISignal instance behind the given port. (Inherited from ISignalMap.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | FindSignalIndexesLocation | Gets the map indexes associated to the given ISignal instance. (Inherited from ISignalMap.)
Public method | FindSignalIndexLocation | Obsolete. This method is obsolete. Use FindSignalIndexesLocation(ISignal) instead. (Inherited from ISignalMap.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetPort | Returns the port number at the given map index. Works in opposite way than GetPortIndex(Int32). (Inherited from ISignalMap.)
Public method | GetPortIndex | Returns the map index of the port defined by port number. Works in opposite way than GetPort(Int32). (Inherited from ISignalMap.)
Public method | GetPortName | Returns the name of the port at the given map index. (Inherited from ISignalMap.)
Public method | GetPortValue | Reads the value from a port defined by the map index if there is a signal in that port. (Inherited from ISignalMap.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetSignal | Gets a ISignal instance behind the map at the given map index. (Inherited from ISignalMap.)
Public method | MapGetPortSignal | Gets the ISignal instance behind the given port number. (Inherited from ISignalMap.)
Public method | SetPortName | Sets a port name given map index Remarks There should be a signal in this port in order to associate a name (Inherited from ISignalMap.)
Public method | SetPortValue | Sends a signal to a port defined by map index. (Inherited from ISignalMap.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetSignal | Associates a component signal into the given port (Inherited from ISignalMap.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | SignalValueChanged | Triggered when the value of the signal associated to the port changes. (Inherited from ISignalMap.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRealSignalMap Properties

The IRealSignalMap type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConnectedExternalPorts | Returns all the connected external ports. The return value is a collection of tuples where the first item is the internal port number number and the second item is a port number in connected external map. (Inherited from ISignalMap.)
Public property | ConnectedExternalSignals | Returns all the connected signals in external components. The return value is a collection of tuples where the first item is the internal port number number and the second item is an external signal connected to the port. (Inherited from ISignalMap.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | MapCount | Gets the number of ports connected to ISignal instances. This matches SignalCount. (Inherited from ISignalMap.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | PortCount | Gets the total number of ports in this signal map. (Inherited from ISignalMap.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SignalCount | Gets the number of ISignal instances behind this signal map. (Inherited from ISignalMap.)
Public property | StartIndex | Gets the ports starting index. (Inherited from ISignalMap.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IRealSignalMap Interface
VisualComponents.Create3D Namespace


IRealSignalMap Methods

The IRealSignalMap type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect(Int32, ISignal) | Connects the signal behind the given port to the given ISignal instance. (Inherited from ISignalMap.)
Public method | Connect(Int32, ISignalMap, Int32) | Connects the ISignal instance behind the given port to the signal behind the port behind the given map. (Inherited from ISignalMap.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | CreateSignal | Creates a ISignal instance at the given port. (Inherited from ISignalMap.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteSignalConnection(Int32) | Deletes all ISignal instances connected to the signal at the given port. Also deletes disconnected application signals. (Inherited from ISignalMap.)
Public method | DeleteSignalConnection(Int32, Boolean) | Deletes all ISignal instances connected to the signal at the given port. (Inherited from ISignalMap.)
Public method | DeleteSignalConnection(Int32, Boolean, ISignal) | Disconnects the ISignal instance at the given port from the given signal. The signal will maintain its other connections (if any). (Inherited from ISignalMap.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects the ISignal instance behind the given port. (Inherited from ISignalMap.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | FindSignalIndexesLocation | Gets the map indexes associated to the given ISignal instance. (Inherited from ISignalMap.)
Public method | FindSignalIndexLocation | Obsolete. This method is obsolete. Use FindSignalIndexesLocation(ISignal) instead. (Inherited from ISignalMap.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetPort | Returns the port number at the given map index. Works in opposite way than GetPortIndex(Int32). (Inherited from ISignalMap.)
Public method | GetPortIndex | Returns the map index of the port defined by port number. Works in opposite way than GetPort(Int32). (Inherited from ISignalMap.)
Public method | GetPortName | Returns the name of the port at the given map index. (Inherited from ISignalMap.)
Public method | GetPortValue | Reads the value from a port defined by the map index if there is a signal in that port. (Inherited from ISignalMap.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetSignal | Gets a ISignal instance behind the map at the given map index. (Inherited from ISignalMap.)
Public method | MapGetPortSignal | Gets the ISignal instance behind the given port number. (Inherited from ISignalMap.)
Public method | SetPortName | Sets a port name given map index Remarks There should be a signal in this port in order to associate a name (Inherited from ISignalMap.)
Public method | SetPortValue | Sends a signal to a port defined by map index. (Inherited from ISignalMap.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetSignal | Associates a component signal into the given port (Inherited from ISignalMap.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRealSignalMap Interface
VisualComponents.Create3D Namespace


IRealSignalMap Events

The IRealSignalMap type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | SignalValueChanged | Triggered when the value of the signal associated to the port changes. (Inherited from ISignalMap.)
Top
See Also

Reference

IRealSignalMap Interface
VisualComponents.Create3D Namespace


IRecord Interface

Record list property value element object interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRecord : IPropertyContainer,
    IBatchModeObject
public interface class IRecord : IPropertyContainer,
    IBatchModeObject

The IRecord type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Template | Template used when creating the record.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Remarks

This interface wraps an individual element in a record list property value. It extends the property container interface to add a reference to the template used to create the record.

See Also

Reference

VisualComponents.Create3D Namespace


IRecord Properties

The IRecord type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Template | Template used when creating the record.
Top
See Also

Reference

IRecord Interface
VisualComponents.Create3D Namespace


IRecord.Template Property

IRecordTemplate Property

Template used when creating the record.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRecordTemplate Template { get; }
property IRecordTemplate^ Template {
    IRecordTemplate^ get ();
}

Property Value

Type: IRecordTemplate
Remarks

For template based records, this value is the template on which the record is based. For free-form records (where these are supported) this value is null.

See Also

Reference

IRecord Interface
VisualComponents.Create3D Namespace


IRecord Methods

The IRecord type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IRecord Interface
VisualComponents.Create3D Namespace


IRecord Events

The IRecord type exposes the following members.

Events
 | Name | Description
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IRecord Interface
VisualComponents.Create3D Namespace


IRecorder Interface

Simulation recorder interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRecorder : IDisposable
public interface class IRecorder : IDisposable

The IRecorder type exposes the following members.

Properties
 | Name | Description
Public property | FrameRate | Defines the frame rate (fps) of the recorder.
Public property | IsRecording | Defines if the recorder has been started.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Start | Starts and initializes the recorder.
Public method | Stop | Stops the recorder and saves the result to the given file.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRecorder Properties

The IRecorder type exposes the following members.

Properties
 | Name | Description
Public property | FrameRate | Defines the frame rate (fps) of the recorder.
Public property | IsRecording | Defines if the recorder has been started.
Top
See Also

Reference

IRecorder Interface
VisualComponents.Create3D Namespace


IRecorder.FrameRate Property

IRecorderFrameRate Property

Defines the frame rate (fps) of the recorder.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int FrameRate { get; set; }
property int FrameRate {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IRecorder Interface
VisualComponents.Create3D Namespace


IRecorder.IsRecording Property

IRecorderIsRecording Property

Defines if the recorder has been started.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsRecording { get; }
property bool IsRecording {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IRecorder Interface
VisualComponents.Create3D Namespace


IRecorder Methods

The IRecorder type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Start | Starts and initializes the recorder.
Public method | Stop | Stops the recorder and saves the result to the given file.
Top
See Also

Reference

IRecorder Interface
VisualComponents.Create3D Namespace


IRecorder.Start Method

IRecorderStart Method

Starts and initializes the recorder.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Start()
void Start()
See Also

Reference

IRecorder Interface
VisualComponents.Create3D Namespace


IRecorder.Stop Method

IRecorderStop Method

Stops the recorder and saves the result to the given file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Stop(
    Uri file
)
void Stop(
    Uri^ file
)

Parameters

file
Type: SystemUri
File where the result is saved to, if the file is null the result is discarded.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when recording has not been started.
See Also

Reference

IRecorder Interface
VisualComponents.Create3D Namespace


IRecordExporter Interface

Recorder base interfaec

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRecordExporter
public interface class IRecordExporter

The IRecordExporter type exposes the following members.

Properties
 | Name | Description
Public property | Header | Header information
Public property | RecordingType | Type information
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRecordExporter Properties

The IRecordExporter type exposes the following members.

Properties
 | Name | Description
Public property | Header | Header information
Public property | RecordingType | Type information
Top
See Also

Reference

IRecordExporter Interface
VisualComponents.Create3D Namespace


IRecordExporter.Header Property

IRecordExporterHeader Property

Header information

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IHeaderModel Header { get; }
property IHeaderModel^ Header {
    IHeaderModel^ get ();
}

Property Value

Type: IHeaderModel
See Also

Reference

IRecordExporter Interface
VisualComponents.Create3D Namespace


IRecordExporter.RecordingType Property

IRecordExporterRecordingType Property

Type information

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
RecordingType RecordingType { get; }
property RecordingType RecordingType {
    RecordingType get ();
}

Property Value

Type: RecordingType
See Also

Reference

IRecordExporter Interface
VisualComponents.Create3D Namespace


IRecordListProperty Interface

Record list property interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRecordListProperty : IListProperty<IRecord>,
    IProperty<IRecord[]>, IProperty, INotifyPropertyChanged, IDisposable,
    INamed, IListProperty
public interface class IRecordListProperty : IListProperty<IRecord^>,
    IProperty<array<IRecord^>^>, IProperty, INotifyPropertyChanged,
    IDisposable, INamed, IListProperty

The IRecordListProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Strongly typed allowed maximum value. (Inherited from IPropertyT.)
Public property | AllowedMinimum | Strongly typed allowed minimum value. (Inherited from IPropertyT.)
Public property | AllowedValues | Strongly typed container of allowed values. (Inherited from IPropertyT.)
Public property | AreCustomTemplatesSupported | Whether custom templates can be created and added.
Public property | AreFreeformRecordsSupported | Whether free-form records (i.e. not based on any template) are supported.
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | List | Property value as an editable list. (Inherited from IListPropertyT.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Templates | Read-only collection of templates.
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Strongly typed property value. (Inherited from IPropertyT.)
Top
Methods
 | Name | Description
Public method | AddNewTemplate | Create a new template.
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | CreateRecord | Create a new record.
Public method | DeleteTemplate | Delete the named template.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | FindTemplate | Find a template by name.
Public method | MoveItem | Moves item from source index position to destination index position. (Inherited from IListProperty.)
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
Remarks

A record list property contains a list of records, which are collections of name-value pairs. The record list property interface extends the list property interface where the element value type is a tuple containing a string (name) and an object (value.)

An individual record is usually based on a pre-defined template, which is a set of pre-defined properties that must exist in the record.

Depending on the record list property, it may also support free-form records. A free-form record is not based on a template, but can contain any properties, as determined by creating them when the record is created.

Some record templates also allow custom properties to be added in addition to those defined by the template.

See Also

Reference

VisualComponents.Create3D Namespace


IRecordListProperty Properties

The IRecordListProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Strongly typed allowed maximum value. (Inherited from IPropertyT.)
Public property | AllowedMinimum | Strongly typed allowed minimum value. (Inherited from IPropertyT.)
Public property | AllowedValues | Strongly typed container of allowed values. (Inherited from IPropertyT.)
Public property | AreCustomTemplatesSupported | Whether custom templates can be created and added.
Public property | AreFreeformRecordsSupported | Whether free-form records (i.e. not based on any template) are supported.
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | List | Property value as an editable list. (Inherited from IListPropertyT.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Templates | Read-only collection of templates.
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Strongly typed property value. (Inherited from IPropertyT.)
Top
See Also

Reference

IRecordListProperty Interface
VisualComponents.Create3D Namespace


IRecordListProperty.AreCustomTemplatesSupported Property

IRecordListPropertyAreCustomTemplatesSupported Property

Whether custom templates can be created and added.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool AreCustomTemplatesSupported { get; }
property bool AreCustomTemplatesSupported {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IRecordListProperty Interface
VisualComponents.Create3D Namespace


IRecordListProperty.AreFreeformRecordsSupported Property

IRecordListPropertyAreFreeformRecordsSupported Property

Whether free-form records (i.e. not based on any template) are supported.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool AreFreeformRecordsSupported { get; }
property bool AreFreeformRecordsSupported {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IRecordListProperty Interface
VisualComponents.Create3D Namespace


IRecordListProperty.Templates Property

IRecordListPropertyTemplates Property

Read-only collection of templates.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ICollection<IRecordTemplate> Templates { get; }
property ICollection<IRecordTemplate^>^ Templates {
    ICollection<IRecordTemplate^>^ get ();
}

Property Value

Type: ICollectionIRecordTemplate
See Also

Reference

IRecordListProperty Interface
VisualComponents.Create3D Namespace


IRecordListProperty Methods

The IRecordListProperty type exposes the following members.

Methods
 | Name | Description
Public method | AddNewTemplate | Create a new template.
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | CreateRecord | Create a new record.
Public method | DeleteTemplate | Delete the named template.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | FindTemplate | Find a template by name.
Public method | MoveItem | Moves item from source index position to destination index position. (Inherited from IListProperty.)
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

IRecordListProperty Interface
VisualComponents.Create3D Namespace


IRecordListProperty.AddNewTemplate Method

IRecordListPropertyAddNewTemplate Method

Create a new template.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRecordTemplate AddNewTemplate(
    string name
)
IRecordTemplate^ AddNewTemplate(
    String^ name
)

Parameters

name
Type: SystemString

Return Value

Type: IRecordTemplate

[Missing <returns> documentation for "M:VisualComponents.Create3D.IRecordListProperty.AddNewTemplate(System.String)"]

Remarks
The created template is automatically added to the template collection.
See Also

Reference

IRecordListProperty Interface
VisualComponents.Create3D Namespace


IRecordListProperty.CreateRecord Method

IRecordListPropertyCreateRecord Method

Create a new record.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRecord CreateRecord(
    IRecordTemplate baseTemplate
)
IRecord^ CreateRecord(
    IRecordTemplate^ baseTemplate
)

Parameters

baseTemplate
Type: VisualComponents.Create3DIRecordTemplate
Template to use, or null for a free-form record.

Return Value

Type: IRecord

[Missing <returns> documentation for "M:VisualComponents.Create3D.IRecordListProperty.CreateRecord(VisualComponents.Create3D.IRecordTemplate)"]

Remarks
The created record must be manually inserted into the RecordList list.
See Also

Reference

IRecordListProperty Interface
VisualComponents.Create3D Namespace


IRecordListProperty.DeleteTemplate Method

IRecordListPropertyDeleteTemplate Method

Delete the named template.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteTemplate(
    IRecordTemplate templateToDelete
)
void DeleteTemplate(
    IRecordTemplate^ templateToDelete
)

Parameters

templateToDelete
Type: VisualComponents.Create3DIRecordTemplate
Template to delete.
See Also

Reference

IRecordListProperty Interface
VisualComponents.Create3D Namespace


IRecordListProperty.FindTemplate Method

IRecordListPropertyFindTemplate Method

Find a template by name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRecordTemplate FindTemplate(
    string name
)
IRecordTemplate^ FindTemplate(
    String^ name
)

Parameters

name
Type: SystemString

Return Value

Type: IRecordTemplate
The template, or null if no such template exists.
See Also

Reference

IRecordListProperty Interface
VisualComponents.Create3D Namespace


IRecordListProperty Events

The IRecordListProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IRecordListProperty Interface
VisualComponents.Create3D Namespace


IRecordTemplate Interface

Record template interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRecordTemplate : IPropertyContainer,
    IBatchModeObject
public interface class IRecordTemplate : IPropertyContainer,
    IBatchModeObject

The IRecordTemplate type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsEditable | Whether the template can be edited.
Public property | IsRecordEditable | Whether records based on this template can have properties added and/or removed.
Public property | Name | Template name.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Remarks
A record template is a collection of properties and default values for a record.
See Also

Reference

VisualComponents.Create3D Namespace


IRecordTemplate Properties

The IRecordTemplate type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsEditable | Whether the template can be edited.
Public property | IsRecordEditable | Whether records based on this template can have properties added and/or removed.
Public property | Name | Template name.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IRecordTemplate Interface
VisualComponents.Create3D Namespace


IRecordTemplate.IsEditable Property

IRecordTemplateIsEditable Property

Whether the template can be edited.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsEditable { get; }
property bool IsEditable {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IRecordTemplate Interface
VisualComponents.Create3D Namespace


IRecordTemplate.IsRecordEditable Property

IRecordTemplateIsRecordEditable Property

Whether records based on this template can have properties added and/or removed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsRecordEditable { get; set; }
property bool IsRecordEditable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRecordTemplate Interface
VisualComponents.Create3D Namespace


IRecordTemplate.Name Property

IRecordTemplateName Property

Template name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Name { get; }
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IRecordTemplate Interface
VisualComponents.Create3D Namespace


IRecordTemplate Methods

The IRecordTemplate type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IRecordTemplate Interface
VisualComponents.Create3D Namespace


IRecordTemplate Events

The IRecordTemplate type exposes the following members.

Events
 | Name | Description
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IRecordTemplate Interface
VisualComponents.Create3D Namespace


IReferenceListProperty Interface

A property that holds a reference to an object instead of a value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IReferenceListProperty : IListProperty,
    IProperty, INotifyPropertyChanged, IDisposable, INamed
public interface class IReferenceListProperty : IListProperty,
    IProperty, INotifyPropertyChanged, IDisposable, INamed

The IReferenceListProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Allowed maximum value for the property. (Inherited from IProperty.)
Public property | AllowedMinimum | Allowed minimum value for the property. (Inherited from IProperty.)
Public property | AllowedValues | Collection of allowed values for constrained properties. (Inherited from IProperty.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | List | Property value as an editable list. (Inherited from IListProperty.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Property value as an object. (Inherited from IProperty.)
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | GetUniqueNameForValue | Gets an unique name (within the property's context) for the object at the given index that can be used for serialization.
Public method | MoveItem | Moves item from source index position to destination index position. (Inherited from IListProperty.)
Public method | ResolveValueFromUniqueName | Tries to resolve the given name to an object.
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IReferenceListProperty Properties

The IReferenceListProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Allowed maximum value for the property. (Inherited from IProperty.)
Public property | AllowedMinimum | Allowed minimum value for the property. (Inherited from IProperty.)
Public property | AllowedValues | Collection of allowed values for constrained properties. (Inherited from IProperty.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | List | Property value as an editable list. (Inherited from IListProperty.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Property value as an object. (Inherited from IProperty.)
Top
See Also

Reference

IReferenceListProperty Interface
VisualComponents.Create3D Namespace


IReferenceListProperty Methods

The IReferenceListProperty type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | GetUniqueNameForValue | Gets an unique name (within the property's context) for the object at the given index that can be used for serialization.
Public method | MoveItem | Moves item from source index position to destination index position. (Inherited from IListProperty.)
Public method | ResolveValueFromUniqueName | Tries to resolve the given name to an object.
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

IReferenceListProperty Interface
VisualComponents.Create3D Namespace


IReferenceListProperty.GetUniqueNameForValue Method

IReferenceListPropertyGetUniqueNameForValue Method

Gets an unique name (within the property's context) for the object at the given index that can be used for serialization.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string GetUniqueNameForValue(
    int index
)
String^ GetUniqueNameForValue(
    int index
)

Parameters

index
Type: SystemInt32
Index of element to get a name for.

Return Value

Type: String
Null if an unique name can't be created.
See Also

Reference

IReferenceListProperty Interface
VisualComponents.Create3D Namespace


IReferenceListProperty.ResolveValueFromUniqueName Method

IReferenceListPropertyResolveValueFromUniqueName Method

Tries to resolve the given name to an object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object ResolveValueFromUniqueName(
    string name
)
Object^ ResolveValueFromUniqueName(
    String^ name
)

Parameters

name
Type: SystemString
Unique name of the pointed object within this property's context.

Return Value

Type: Object
Null if a matching object wasn't found.
See Also

Reference

IReferenceListProperty Interface
VisualComponents.Create3D Namespace


IReferenceListProperty Events

The IReferenceListProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IReferenceListProperty Interface
VisualComponents.Create3D Namespace


IReferenceProperty Interface

A property that holds a reference to an object instead of a value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IReferenceProperty : IProperty,
    INotifyPropertyChanged, IDisposable, INamed
public interface class IReferenceProperty : IProperty,
    INotifyPropertyChanged, IDisposable, INamed

The IReferenceProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Allowed maximum value for the property. (Inherited from IProperty.)
Public property | AllowedMinimum | Allowed minimum value for the property. (Inherited from IProperty.)
Public property | AllowedValues | Collection of allowed values for constrained properties. (Inherited from IProperty.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Property value as an object. (Inherited from IProperty.)
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | GetUniqueNameForValue | Gets an unique name (within the property's context) for the currently pointed object that can be used for serialization.
Public method | ResolveValueFromUniqueName | Tries to resolve the given name to an object.
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IReferenceProperty Properties

The IReferenceProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Allowed maximum value for the property. (Inherited from IProperty.)
Public property | AllowedMinimum | Allowed minimum value for the property. (Inherited from IProperty.)
Public property | AllowedValues | Collection of allowed values for constrained properties. (Inherited from IProperty.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Property value as an object. (Inherited from IProperty.)
Top
See Also

Reference

IReferenceProperty Interface
VisualComponents.Create3D Namespace


IReferenceProperty Methods

The IReferenceProperty type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | GetUniqueNameForValue | Gets an unique name (within the property's context) for the currently pointed object that can be used for serialization.
Public method | ResolveValueFromUniqueName | Tries to resolve the given name to an object.
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

IReferenceProperty Interface
VisualComponents.Create3D Namespace


IReferenceProperty.GetUniqueNameForValue Method

IReferencePropertyGetUniqueNameForValue Method

Gets an unique name (within the property's context) for the currently pointed object that can be used for serialization.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string GetUniqueNameForValue()
String^ GetUniqueNameForValue()

Return Value

Type: String
Null if Value is null or an unique name can't be created.
See Also

Reference

IReferenceProperty Interface
VisualComponents.Create3D Namespace


IReferenceProperty.ResolveValueFromUniqueName Method

IReferencePropertyResolveValueFromUniqueName Method

Tries to resolve the given name to an object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object ResolveValueFromUniqueName(
    string name
)
Object^ ResolveValueFromUniqueName(
    String^ name
)

Parameters

name
Type: SystemString
Unique name of the pointed object within this property's context.

Return Value

Type: Object
Null if a matching object wasn't found.
See Also

Reference

IReferenceProperty Interface
VisualComponents.Create3D Namespace


IReferenceProperty Events

The IReferenceProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IReferenceProperty Interface
VisualComponents.Create3D Namespace


IReleaseProductReservationStatement Interface

A process statement for releasing a pre-reserved product instance, e.g. so that it can be offered to another process.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IReleaseProductReservationStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IReleaseProductReservationStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IReleaseProductReservationStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductVariableName | Name of the Process variable where this statement will retrieve a reference to the pre-reserved ISimProduct instance from.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IReleaseProductReservationStatement Properties

The IReleaseProductReservationStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductVariableName | Name of the Process variable where this statement will retrieve a reference to the pre-reserved ISimProduct instance from.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
See Also

Reference

IReleaseProductReservationStatement Interface
VisualComponents.Create3D Namespace


IReleaseProductReservationStatement.ProductVariableName Property

IReleaseProductReservationStatementProductVariableName Property

Name of the Process variable where this statement will retrieve a reference to the pre-reserved ISimProduct instance from.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ProductVariableName { get; set; }
property String^ ProductVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown if trying to set a null value
Remarks
This statement should be used to release ISimProducts that we're pre-reserved in the Requirements section, but that were not used when the process executed.
See Also

Reference

IReleaseProductReservationStatement Interface
VisualComponents.Create3D Namespace


IReleaseProductReservationStatement Methods

The IReleaseProductReservationStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IReleaseProductReservationStatement Interface
VisualComponents.Create3D Namespace


IReleaseProductReservationStatement Events

The IReleaseProductReservationStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IReleaseProductReservationStatement Interface
VisualComponents.Create3D Namespace


IRemoveProductStatement Interface

A statement for deleting a ISimProduct instance. Also deletes Component.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRemoveProductStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IRemoveProductStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IRemoveProductStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | AssemblyOrderVariableName | Name of the optional assembly order variable that determines which parts of an assembly to remove.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductVariableName | Name of the process variable that holds the ISimProduct instance to delete.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRemoveProductStatement Properties

The IRemoveProductStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | AssemblyOrderVariableName | Name of the optional assembly order variable that determines which parts of an assembly to remove.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductVariableName | Name of the process variable that holds the ISimProduct instance to delete.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
See Also

Reference

IRemoveProductStatement Interface
VisualComponents.Create3D Namespace


IRemoveProductStatement.AssemblyOrderVariableName Property

IRemoveProductStatementAssemblyOrderVariableName Property

Name of the optional assembly order variable that determines which parts of an assembly to remove.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string AssemblyOrderVariableName { get; set; }
property String^ AssemblyOrderVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IRemoveProductStatement Interface
VisualComponents.Create3D Namespace


IRemoveProductStatement.ProductVariableName Property

IRemoveProductStatementProductVariableName Property

Name of the process variable that holds the ISimProduct instance to delete.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ProductVariableName { get; set; }
property String^ ProductVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown if trying to set a null value
See Also

Reference

IRemoveProductStatement Interface
VisualComponents.Create3D Namespace


IRemoveProductStatement Methods

The IRemoveProductStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRemoveProductStatement Interface
VisualComponents.Create3D Namespace


IRemoveProductStatement Events

The IRemoveProductStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IRemoveProductStatement Interface
VisualComponents.Create3D Namespace


IRenderService Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRenderService
public interface class IRenderService

The IRenderService type exposes the following members.

Properties
 | Name | Description
Public property | AmbientOcclusionQuality |
Public property | IsAmbientOcclusionEnabled |
Public property | IsAntialiasingEnabled |
Public property | IsEffectShaderEnabled |
Public property | IsInitialized |
Public property | IsMaterialShaderEnabled |
Public property | IsNavigating |
Public property | IsRenderingEnabled |
Public property | IsShadowsEnabled |
Public property | MultisamplingMode |
Public property | RenderingMode |
Public property | RenderingPresetMode |
Public property | RenderRequested |
Public property | SelectionFillColor |
Public property | SelectionSilhouetteColor |
Public property | ShadingMode |
Public property | ShadowSoftness |
Public property | SoftwareFallbackMode |
Top
Methods
 | Name | Description
Public method | AllowSingleRender |
Public method | DecreaseTargetCount |
Public method | IncreaseTargetCount |
Public method | RefreshRenderSettings |
Public method | RemoveViewportInvalidatedMethod |
Public method | RequestRender |
Public method | RestoreSelectionColor |
Public method | SetRenderingPresetMode |
Public method | SetRenderMode |
Public method | SetRenderQuality | Obsolete.
Public method | SetSelectionColor |
Public method | SetViewportInvalidatedMethod |
Public method | TakeSingleRender |
Top
Events
 | Name | Description
Public event | OnRequestRender |
Public event | RenderPresetModeChanged |
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRenderService Properties

The IRenderService type exposes the following members.

Properties
 | Name | Description
Public property | AmbientOcclusionQuality |
Public property | IsAmbientOcclusionEnabled |
Public property | IsAntialiasingEnabled |
Public property | IsEffectShaderEnabled |
Public property | IsInitialized |
Public property | IsMaterialShaderEnabled |
Public property | IsNavigating |
Public property | IsRenderingEnabled |
Public property | IsShadowsEnabled |
Public property | MultisamplingMode |
Public property | RenderingMode |
Public property | RenderingPresetMode |
Public property | RenderRequested |
Public property | SelectionFillColor |
Public property | SelectionSilhouetteColor |
Public property | ShadingMode |
Public property | ShadowSoftness |
Public property | SoftwareFallbackMode |
Top
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.AmbientOcclusionQuality Property

IRenderServiceAmbientOcclusionQuality Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string AmbientOcclusionQuality { get; set; }
property String^ AmbientOcclusionQuality {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.IsAmbientOcclusionEnabled Property

IRenderServiceIsAmbientOcclusionEnabled Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsAmbientOcclusionEnabled { get; set; }
property bool IsAmbientOcclusionEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.IsAntialiasingEnabled Property

IRenderServiceIsAntialiasingEnabled Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsAntialiasingEnabled { get; set; }
property bool IsAntialiasingEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.IsEffectShaderEnabled Property

IRenderServiceIsEffectShaderEnabled Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsEffectShaderEnabled { get; set; }
property bool IsEffectShaderEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.IsInitialized Property

IRenderServiceIsInitialized Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsInitialized { get; }
property bool IsInitialized {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.IsMaterialShaderEnabled Property

IRenderServiceIsMaterialShaderEnabled Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsMaterialShaderEnabled { get; set; }
property bool IsMaterialShaderEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.IsNavigating Property

IRenderServiceIsNavigating Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsNavigating { get; }
property bool IsNavigating {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.IsRenderingEnabled Property

IRenderServiceIsRenderingEnabled Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsRenderingEnabled { get; set; }
property bool IsRenderingEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.IsShadowsEnabled Property

IRenderServiceIsShadowsEnabled Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsShadowsEnabled { get; set; }
property bool IsShadowsEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.MultisamplingMode Property

IRenderServiceMultisamplingMode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int MultisamplingMode { get; set; }
property int MultisamplingMode {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.RenderingMode Property

IRenderServiceRenderingMode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string RenderingMode { get; set; }
property String^ RenderingMode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.RenderingPresetMode Property

IRenderServiceRenderingPresetMode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
PresetMode RenderingPresetMode { get; set; }
property PresetMode RenderingPresetMode {
    PresetMode get ();
    void set (PresetMode value);
}

Property Value

Type: PresetMode
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.RenderRequested Property

IRenderServiceRenderRequested Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool RenderRequested { get; set; }
property bool RenderRequested {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.SelectionFillColor Property

IRenderServiceSelectionFillColor Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Color SelectionFillColor { get; set; }
property Color SelectionFillColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.SelectionSilhouetteColor Property

IRenderServiceSelectionSilhouetteColor Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Color SelectionSilhouetteColor { get; set; }
property Color SelectionSilhouetteColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.ShadingMode Property

IRenderServiceShadingMode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ShadingMode { get; set; }
property String^ ShadingMode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.ShadowSoftness Property

IRenderServiceShadowSoftness Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double ShadowSoftness { get; set; }
property double ShadowSoftness {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.SoftwareFallbackMode Property

IRenderServiceSoftwareFallbackMode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SoftwareFallbackMode { get; set; }
property bool SoftwareFallbackMode {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService Methods

The IRenderService type exposes the following members.

Methods
 | Name | Description
Public method | AllowSingleRender |
Public method | DecreaseTargetCount |
Public method | IncreaseTargetCount |
Public method | RefreshRenderSettings |
Public method | RemoveViewportInvalidatedMethod |
Public method | RequestRender |
Public method | RestoreSelectionColor |
Public method | SetRenderingPresetMode |
Public method | SetRenderMode |
Public method | SetRenderQuality | Obsolete.
Public method | SetSelectionColor |
Public method | SetViewportInvalidatedMethod |
Public method | TakeSingleRender |
Top
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.AllowSingleRender Method

IRenderServiceAllowSingleRender Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AllowSingleRender()
void AllowSingleRender()
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.DecreaseTargetCount Method

IRenderServiceDecreaseTargetCount Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DecreaseTargetCount()
void DecreaseTargetCount()
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.IncreaseTargetCount Method

IRenderServiceIncreaseTargetCount Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void IncreaseTargetCount()
void IncreaseTargetCount()
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.RefreshRenderSettings Method

IRenderServiceRefreshRenderSettings Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RefreshRenderSettings()
void RefreshRenderSettings()
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.RemoveViewportInvalidatedMethod Method

IRenderServiceRemoveViewportInvalidatedMethod Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RemoveViewportInvalidatedMethod(
    Action invalidateMethod
)
void RemoveViewportInvalidatedMethod(
    Action^ invalidateMethod
)

Parameters

invalidateMethod
Type: SystemAction
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.RequestRender Method

IRenderServiceRequestRender Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RequestRender()
void RequestRender()
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.RestoreSelectionColor Method

IRenderServiceRestoreSelectionColor Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RestoreSelectionColor(
    bool updateConfig
)
void RestoreSelectionColor(
    bool updateConfig
)

Parameters

updateConfig
Type: SystemBoolean
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.SetRenderingPresetMode Method

IRenderServiceSetRenderingPresetMode Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetRenderingPresetMode(
    IWindow3D window,
    PresetMode presetMode
)
void SetRenderingPresetMode(
    IWindow3D^ window,
    PresetMode presetMode
)

Parameters

window
Type: VisualComponents.Create3DIWindow3D
presetMode
Type: VisualComponents.Create3DPresetMode
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.SetRenderMode Method

IRenderServiceSetRenderMode Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetRenderMode(
    RenderEffectMode renderEffectMode
)
void SetRenderMode(
    RenderEffectMode renderEffectMode
)

Parameters

renderEffectMode
Type: VisualComponents.Create3DRenderEffectMode
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.SetRenderQuality Method

IRenderServiceSetRenderQuality Method

Note: This API is now obsolete.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Please use RenderingPresetMode and AmbientOcclusionQuality instead.")]
void SetRenderQuality(
    RenderingQuality quality
)
[ObsoleteAttribute(L"Please use RenderingPresetMode and AmbientOcclusionQuality instead.")]
void SetRenderQuality(
    RenderingQuality quality
)

Parameters

quality
Type: VisualComponents.Create3DRenderingQuality
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.SetSelectionColor Method

IRenderServiceSetSelectionColor Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetSelectionColor(
    Nullable<Color> fillColor,
    Nullable<Color> silhouetteColor,
    bool updateConfig
)
void SetSelectionColor(
    Nullable<Color> fillColor,
    Nullable<Color> silhouetteColor,
    bool updateConfig
)

Parameters

fillColor
Type: SystemNullableColor
silhouetteColor
Type: SystemNullableColor
updateConfig
Type: SystemBoolean
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.SetViewportInvalidatedMethod Method

IRenderServiceSetViewportInvalidatedMethod Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetViewportInvalidatedMethod(
    Action invalidateMethod
)
void SetViewportInvalidatedMethod(
    Action^ invalidateMethod
)

Parameters

invalidateMethod
Type: SystemAction
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.TakeSingleRender Method

IRenderServiceTakeSingleRender Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool TakeSingleRender()
bool TakeSingleRender()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IRenderService.TakeSingleRender"]

See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService Events

The IRenderService type exposes the following members.

Events
 | Name | Description
Public event | OnRequestRender |
Public event | RenderPresetModeChanged |
Top
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.OnRequestRender Event

IRenderServiceOnRequestRender Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler OnRequestRender
 event EventHandler^ OnRequestRender {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderService.RenderPresetModeChanged Event

IRenderServiceRenderPresetModeChanged Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<RenderPresetModeChangedEventArgs> RenderPresetModeChanged
 event EventHandler<RenderPresetModeChangedEventArgs^>^ RenderPresetModeChanged {
    void add (EventHandler<RenderPresetModeChangedEventArgs^>^ value);
    void remove (EventHandler<RenderPresetModeChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerRenderPresetModeChangedEventArgs
See Also

Reference

IRenderService Interface
VisualComponents.Create3D Namespace


IRenderStage Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRenderStage : IPropertyContainer,
    IBatchModeObject, IWrapper, IDisposable, IDurable
public interface class IRenderStage : IPropertyContainer,
    IBatchModeObject, IWrapper, IDisposable, IDurable

The IRenderStage type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Description |
Public property | IsEnabled |
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name |
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetEnabled |
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRenderStage Properties

The IRenderStage type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Description |
Public property | IsEnabled |
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name |
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IRenderStage Interface
VisualComponents.Create3D Namespace


IRenderStage.Description Property

IRenderStageDescription Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Description { get; }
property String^ Description {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IRenderStage Interface
VisualComponents.Create3D Namespace


IRenderStage.IsEnabled Property

IRenderStageIsEnabled Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsEnabled { get; }
property bool IsEnabled {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IRenderStage Interface
VisualComponents.Create3D Namespace


IRenderStage.Name Property

IRenderStageName Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Name { get; }
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IRenderStage Interface
VisualComponents.Create3D Namespace


IRenderStage Methods

The IRenderStage type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetEnabled |
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRenderStage Interface
VisualComponents.Create3D Namespace


IRenderStage.SetEnabled Method

IRenderStageSetEnabled Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SetEnabled(
    Object controller,
    bool enabled
)
bool SetEnabled(
    Object^ controller,
    bool enabled
)

Parameters

controller
Type: SystemObject
enabled
Type: SystemBoolean

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IRenderStage.SetEnabled(System.Object,System.Boolean)"]

See Also

Reference

IRenderStage Interface
VisualComponents.Create3D Namespace


IRenderStage Events

The IRenderStage type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IRenderStage Interface
VisualComponents.Create3D Namespace


IRequirementStatement Interface

Represents a process requirement statement. For a process to start, all of it's requirements must pass.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRequirementStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IRequirementStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IRequirementStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRequirementStatement Properties

The IRequirementStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
See Also

Reference

IRequirementStatement Interface
VisualComponents.Create3D Namespace


IRequirementStatement Methods

The IRequirementStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRequirementStatement Interface
VisualComponents.Create3D Namespace


IRequirementStatement Events

The IRequirementStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IRequirementStatement Interface
VisualComponents.Create3D Namespace


IReserveProductStatement Interface

Represents a process requirement to reserve a single ISimProduct instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IReserveProductStatement : IRequirementStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement>, ICloneable
public interface class IReserveProductStatement : IRequirementStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement^>, ICloneable

The IReserveProductStatement type exposes the following members.

Properties
 | Name | Description
Public property | AcceptAllProductTypes | Whether to accept ISimProducts of any IProductType regardless of the other settings.
Public property | AcceptedFlowGroups | An editable list of explicitly accepted IProcessFlowGroups.
Public property | AcceptedProductTypes | An editable list of explicitly accepted IProductTypes.
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductVariableName | Name of the Process variable where a reference to the received ISimProduct instance will be stored by this statement.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IReserveProductStatement Properties

The IReserveProductStatement type exposes the following members.

Properties
 | Name | Description
Public property | AcceptAllProductTypes | Whether to accept ISimProducts of any IProductType regardless of the other settings.
Public property | AcceptedFlowGroups | An editable list of explicitly accepted IProcessFlowGroups.
Public property | AcceptedProductTypes | An editable list of explicitly accepted IProductTypes.
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductVariableName | Name of the Process variable where a reference to the received ISimProduct instance will be stored by this statement.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
See Also

Reference

IReserveProductStatement Interface
VisualComponents.Create3D Namespace


IReserveProductStatement.AcceptAllProductTypes Property

IReserveProductStatementAcceptAllProductTypes Property

Whether to accept ISimProducts of any IProductType regardless of the other settings.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool AcceptAllProductTypes { get; set; }
property bool AcceptAllProductTypes {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IReserveProductStatement Interface
VisualComponents.Create3D Namespace


IReserveProductStatement.AcceptedFlowGroups Property

IReserveProductStatementAcceptedFlowGroups Property

An editable list of explicitly accepted IProcessFlowGroups.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IProcessFlowGroup> AcceptedFlowGroups { get; }
property IList<IProcessFlowGroup^>^ AcceptedFlowGroups {
    IList<IProcessFlowGroup^>^ get ();
}

Property Value

Type: IListIProcessFlowGroup
See Also

Reference

IReserveProductStatement Interface
VisualComponents.Create3D Namespace


IReserveProductStatement.AcceptedProductTypes Property

IReserveProductStatementAcceptedProductTypes Property

An editable list of explicitly accepted IProductTypes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IProductType> AcceptedProductTypes { get; }
property IList<IProductType^>^ AcceptedProductTypes {
    IList<IProductType^>^ get ();
}

Property Value

Type: IListIProductType
See Also

Reference

IReserveProductStatement Interface
VisualComponents.Create3D Namespace


IReserveProductStatement.ProductVariableName Property

IReserveProductStatementProductVariableName Property

Name of the Process variable where a reference to the received ISimProduct instance will be stored by this statement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ProductVariableName { get; set; }
property String^ ProductVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown if trying to set a null value
Remarks
The variable will be created if needed when this statement executes.
See Also

Reference

IReserveProductStatement Interface
VisualComponents.Create3D Namespace


IReserveProductStatement Methods

The IReserveProductStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IReserveProductStatement Interface
VisualComponents.Create3D Namespace


IReserveProductStatement Events

The IReserveProductStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IReserveProductStatement Interface
VisualComponents.Create3D Namespace


IReturnStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IReturnStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IReturnStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IReturnStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IReturnStatement Properties

The IReturnStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
See Also

Reference

IReturnStatement Interface
VisualComponents.Create3D Namespace


IReturnStatement Methods

The IReturnStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IReturnStatement Interface
VisualComponents.Create3D Namespace


IReturnStatement Events

The IReturnStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IReturnStatement Interface
VisualComponents.Create3D Namespace


IRevolveFeature Interface

Represents a revolve feature object

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRevolveFeature : IFeature,
    IVisualObject, INamed, IWrapper, IDisposable, IVisitable,
    IPropertyContainer, IBatchModeObject, ISharedCloneable
public interface class IRevolveFeature : IFeature,
    IVisualObject, INamed, IWrapper, IDisposable, IVisitable,
    IPropertyContainer, IBatchModeObject, ISharedCloneable

The IRevolveFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
The Revolve operation feature revolves all polylines in its sub features around the Z axis. If a polyline is not a loop all the face normals are made to point outwards. If polyline is a loop, the loop should normally point to the clockwise direction of the revolve angle.
See Also

Reference

VisualComponents.Create3D Namespace


IRevolveFeature Properties

The IRevolveFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
See Also

Reference

IRevolveFeature Interface
VisualComponents.Create3D Namespace


IRevolveFeature Methods

The IRevolveFeature type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRevolveFeature Interface
VisualComponents.Create3D Namespace


IRevolveFeature Events

The IRevolveFeature type exposes the following members.

Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

IRevolveFeature Interface
VisualComponents.Create3D Namespace


IRibbonProgramSection Interface

Configuration section for Program ribbon tab.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRibbonProgramSection : ISection
public interface class IRibbonProgramSection : ISection

The IRibbonProgramSection type exposes the following members.

Properties
 | Name | Description
Public property | ProgramElement | Configuration element for Program ribbon tab.
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | GetSection | Gets the section (Inherited from ISection.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRibbonProgramSection Properties

The IRibbonProgramSection type exposes the following members.

Properties
 | Name | Description
Public property | ProgramElement | Configuration element for Program ribbon tab.
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
See Also

Reference

IRibbonProgramSection Interface
VisualComponents.Create3D Namespace


IRibbonProgramSection.ProgramElement Property

IRibbonProgramSectionProgramElement Property

Configuration element for Program ribbon tab.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
RibbonProgramConfigElement ProgramElement { get; }
property RibbonProgramConfigElement^ ProgramElement {
    RibbonProgramConfigElement^ get ();
}

Property Value

Type: RibbonProgramConfigElement
See Also

Reference

IRibbonProgramSection Interface
VisualComponents.Create3D Namespace


IRibbonProgramSection Methods

The IRibbonProgramSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | GetSection | Gets the section (Inherited from ISection.)
Top
See Also

Reference

IRibbonProgramSection Interface
VisualComponents.Create3D Namespace


IRibbonService Interface

Application Ribboon Service

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRibbonService
public interface class IRibbonService

The IRibbonService type exposes the following members.

Methods
 | Name | Description
Public method | SetContextualRibbonTab | Hide or show contextual ribbon tab.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRibbonService Methods

The IRibbonService type exposes the following members.

Methods
 | Name | Description
Public method | SetContextualRibbonTab | Hide or show contextual ribbon tab.
Top
See Also

Reference

IRibbonService Interface
VisualComponents.Create3D Namespace


IRibbonService.SetContextualRibbonTab Method

IRibbonServiceSetContextualRibbonTab Method

Hide or show contextual ribbon tab.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetContextualRibbonTab(
    string id,
    bool isVisible
)
void SetContextualRibbonTab(
    String^ id,
    bool isVisible
)

Parameters

id
Type: SystemString
Context Id
isVisible
Type: SystemBoolean
True to show or False to hide.
See Also

Reference

IRibbonService Interface
VisualComponents.Create3D Namespace


IRobot Interface

Robot or servo interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRobot : IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, INamed
public interface class IRobot : IPropertyContainer,
    IBatchModeObject, IWrapper, IDisposable, INamed

The IRobot type exposes the following members.

Properties
 | Name | Description
Public property | AllControllers | Gets all the controllers associated to the robot.
Public property | AllExecutors | Gets all the executors associated to the robot.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Component | Gets the component instance
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Controller | Gets the controller associated to the robot.
Public property | CurrentState | Gets the current robot controller state
Public property | Executor | Gets the executor associated to the robot.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | RobotController | Gets the robot controller associated to the robot, null if no robot controller exists.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
Contains references to IServoController, IRobotController, IRobotExecutor, and ISimComponent.
See Also

Reference

VisualComponents.Create3D Namespace


IRobot Properties

The IRobot type exposes the following members.

Properties
 | Name | Description
Public property | AllControllers | Gets all the controllers associated to the robot.
Public property | AllExecutors | Gets all the executors associated to the robot.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Component | Gets the component instance
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Controller | Gets the controller associated to the robot.
Public property | CurrentState | Gets the current robot controller state
Public property | Executor | Gets the executor associated to the robot.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | RobotController | Gets the robot controller associated to the robot, null if no robot controller exists.
Top
See Also

Reference

IRobot Interface
VisualComponents.Create3D Namespace


IRobot.AllControllers Property

IRobotAllControllers Property

Gets all the controllers associated to the robot.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IServoController> AllControllers { get; }
property ReadOnlyCollection<IServoController^>^ AllControllers {
    ReadOnlyCollection<IServoController^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIServoController
See Also

Reference

IRobot Interface
VisualComponents.Create3D Namespace


IRobot.AllExecutors Property

IRobotAllExecutors Property

Gets all the executors associated to the robot.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IRobotExecutor> AllExecutors { get; }
property ReadOnlyCollection<IRobotExecutor^>^ AllExecutors {
    ReadOnlyCollection<IRobotExecutor^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIRobotExecutor
See Also

Reference

IRobot Interface
VisualComponents.Create3D Namespace


IRobot.Component Property

IRobotComponent Property

Gets the component instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent Component { get; }
property ISimComponent^ Component {
    ISimComponent^ get ();
}

Property Value

Type: ISimComponent
See Also

Reference

IRobot Interface
VisualComponents.Create3D Namespace


IRobot.Controller Property

IRobotController Property

Gets the controller associated to the robot.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IServoController Controller { get; }
property IServoController^ Controller {
    IServoController^ get ();
}

Property Value

Type: IServoController
See Also

Reference

IRobot Interface
VisualComponents.Create3D Namespace


IRobot.CurrentState Property

IRobotCurrentState Property

Gets the current robot controller state

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPropertyContainer CurrentState { get; }
property IPropertyContainer^ CurrentState {
    IPropertyContainer^ get ();
}

Property Value

Type: IPropertyContainer
See Also

Reference

IRobot Interface
VisualComponents.Create3D Namespace


IRobot.Executor Property

IRobotExecutor Property

Gets the executor associated to the robot.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotExecutor Executor { get; }
property IRobotExecutor^ Executor {
    IRobotExecutor^ get ();
}

Property Value

Type: IRobotExecutor
See Also

Reference

IRobot Interface
VisualComponents.Create3D Namespace


IRobot.RobotController Property

IRobotRobotController Property

Gets the robot controller associated to the robot, null if no robot controller exists.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotController RobotController { get; }
property IRobotController^ RobotController {
    IRobotController^ get ();
}

Property Value

Type: IRobotController
See Also

Reference

IRobot Interface
VisualComponents.Create3D Namespace


IRobot Methods

The IRobot type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRobot Interface
VisualComponents.Create3D Namespace


IRobot Events

The IRobot type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IRobot Interface
VisualComponents.Create3D Namespace


IRobotController Interface

Defines robot's joints, bases, and tools.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRobotController : IServoController,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed
public interface class IRobotController : IServoController,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed

The IRobotController type exposes the following members.

Properties
 | Name | Description
Public property | AreBaseAndToolReversed | Indicates that base frame is attached to the flange node (also tool frame is not attached to the flange node).
Public property | AuxWorldSet | Obsolete. Deprecated frame-set reference.
Public property | BaseListDefaultFrameSet | IFrameSet instance that is used to display position frames without base.
Public property | Bases | Available base frames.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Configurations | Available configurations.
Public property | ConfigurationWarnings | Returns state of inverse kinematics calculation for all configurations.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CurrentBase | Selected base.
Public property | CurrentBaseInWorld | Coordinate system of ToolCenterPoint. Equals to RobotWorldNode.TransformationInWorld.
Public property | CurrentConfiguration | Configuration index describing current Joints.
Public property | CurrentState | Current kinematic chain state. (Inherited from IServoController.)
Public property | CurrentTool | Selected tool.
Public property | CustomSimulationUpdateTime | Last time value passed to ScheduleCustomSimulationUpdate(). (Inherited from IServoController.)
Public property | Dofs | List of DOFs used by the controller. (Inherited from IServoController.)
Public property | ExternalJoints | List of imported external joints. (Inherited from IServoController.)
Public property | ExternalTcp | Indicates whether statements are added to the base or tool frame.
Public property | FlangeNode | Gets or sets the flange node (Inherited from IServoController.)
Public property | FlangeOffset | Flange offset.
Public property | HeartbeatTime | Gets or sets heartbeat interval (Inherited from IServoController.)
Public property | InitialBase | Base frame used on simulation reset.
Public property | InitialTool | Tool frame used on simulation reset.
Public property | IsBaseToolSetupValid | Indicates that nodes selected in tool and base frames are valid (kinematic chain is valid).
Public property | IsBeingMoved | Indicates that robot's state is being updated. Moving robot again might result in unpredictable results.
Public property | IsConnected | Indicates whether the servo is connected to another servo (Inherited from IServoController.)
Public property | IsReachable | Obsolete. Indicates that Status contains Reachable.
Public property | IsStatusValid | Returns true only if Status is Valid.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Joints | List of joints implemented in the controller. (Inherited from IServoController.)
Public property | Kinematics | Kinematics behavior associated with this controller behavior.
Public property | LastConfigurationWarnings |
Public property | MaxAngularAcceleration | Maximum angular acceleration for Cartesian motions [deg/s^^2].
Public property | MaxAngularDeceleration | Maximum angular deceleration for Cartesian motions [deg/s^^2].
Public property | MaxAngularSpeed | Maximum angular speed for Cartesian motions [deg/s].
Public property | MaxCartesianAcceleration | Maximum Cartesian acceleration [mm/s^2].
Public property | MaxCartesianDeceleration | Maximum Cartesian deceleration [mm/s^2].
Public property | MaxCartesianSpeed | Maximum Cartesian speed [mm/s].
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NearestConfiguration |
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | RobotWorldNode | Root node attached to robot's base or servo track.
Public property | RootNode | Gets or sets the root node (Inherited from IServoController.)
Public property | RootOffset | Root offset.
Public property | SelectedRobotBaseFramesLayerVisibility | Indicates that robot's base frames should be shown when robot is selected.
Public property | SelectedRobotPositionFramesLayerVisibility | Indicates that robot's position statements should be shown when robot is selected.
Public property | SelectedRobotToolFramesLayerVisibility | Indicates that robot's tool frames should be shown when robot is selected.
Public property | SelectedRobotWorldFramesLayerVisibility | Indicates that robot's world frame should be shown when robot is selected.
Public property | Status | Inverse kinematics status.
Public property | ToolCenterPoint | Tool frame's position. Coordinates are relative to 'CurrentBase.TransformationInWorld' or to 'CurrentBaseInWorld' (which equals to 'RobotWorldNode.TransformationInWorld').
Public property | ToolListDefaultFrameSet | IFrameSet instance that is used to display external TCP positions, whose Tool reference is null.
Public property | Tools | Available tool frames.
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Public property | UsesCustomSimulationUpdate | Indicates that ScheduleCustomSimulationUpdate() was called. (Inherited from IServoController.)
Public property | UsesHeartbeat | Defines if controller updates movements on a heartbeat rate. Normally updating is done when required. (Inherited from IServoController.)
Public property | WorldTransformMatrix | Defines robot world frame of a robot.
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CalculateJointTurn | A helper method that can be used to calculate the current turn from an absolute angle value.
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateBase(String) | Creates a base frame and adds it to the Bases list.
Public method | CreateBase(String, Boolean) | Creates a base frame and adds it to the Bases list.
Public method | CreateJoint | Create a new joint, and add it to the end of the joint list. (Inherited from IServoController.)
Public method | CreateMotionInterpolator | Creates a motion interpolator instance, that can be used for interpolating robot's movement along a path.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | CreateTarget | Create motion target from robot's current state.
Public method | CreateTool(String) | Creates a tool frame and adds it to the Tools list.
Public method | CreateTool(String, Boolean) | Creates a tool frame and adds it to the Tools list.
Public method | DeleteBase | Removes base from Bases.
Public method | DeleteBaseAt | Removes base from Bases.
Public method | DeleteJoint | Delete the specified joint. (Inherited from IServoController.)
Public method | DeleteJointAt | Delete the joint at the specified index. (Inherited from IServoController.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteTool | Removes tool from Bases.
Public method | DeleteToolAt | Removes tool from Tools.
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetConfigurationWarnings | Returns state of inverse kinematics calculation for a specific configuration.
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetMotionTester | Gets IMotionTester interface for changing robot's state with IMotionTarget.
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateKinChains | Delete all rKinChain instances from controller and executors. (Inherited from IServoController.)
Public method | ScheduleCustomSimulationUpdate | Request a CustomSimulationUpdate event to be triggered when the robot's component is updated during simulation, or at the specified time. (Inherited from IServoController.)
Public method | SetJointValues | Sets the robot joint values. (Inherited from IServoController.)
Public method | SetJointValuesInRadians | Sets the robot joint values. (Inherited from IServoController.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetToolCenterPoint(Matrix, IRobotTcpSettings) | Advanced setter for ToolCenterPoint.
Public method | SetToolCenterPoint(Matrix, Boolean, Boolean, Boolean) | Advanced setter for ToolCenterPoint. If allowUnreachable and target is not reachable returns the best possible result.
Public method | SetToolCenterPoint(Matrix, Boolean, Boolean, Boolean, NullableBoolean, NullableInt32) | Advanced setter for ToolCenterPoint. If allowConfigChange is set, configuration is either maintained as originalConfig or not.
Public method | StartHeartbeat | Start receiving heartbeat events (Inherited from IServoController.)
Public method | StopHeartbeat | Stop receiving heartbeat events (Inherited from IServoController.)
Public method | UpdateCurrentStateJointStarts | Sets joint starts to current joint values.
Public method | UpdateJointLimitHighlights | Updates highlighting of joint nodes if values exceed their limits. (Inherited from IServoController.)
Public method | UpdateRobot | Internal helper.
Public method | UpdateRobotKinematics | Internal helper.
Public method | UpdateToolCenterPoint | Internal helper.
Top
Events
 | Name | Description
Public event | BaseAdded | Occurs when a base frame is added.
Public event | BaseRemoving | Occurs when a base frame is being removed.
Public event | CurrentStateChange | Event triggered at each state change. (Inherited from IServoController.)
Public event | CurrentStateInvalidated | Event triggered when CurrentState gets invalidated. (Inherited from IServoController.)
Public event | CustomSimulationUpdate | Event triggered on simulation update. (Inherited from IServoController.)
Public event | DofValueChanged | Event triggered when the value any associated instance of IDof changes. (Inherited from IServoController.)
Public event | Heartbeat | Event triggered at each heartbeat of servo. (Inherited from IServoController.)
Public event | JointAdded | Event triggered when a joint was added to this controller. (Inherited from IServoController.)
Public event | JointRemoved | Event triggered when a joint was removed from this controller. (Inherited from IServoController.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | RobotWorldNodeChanged | Occurs when robot world node is changed.
Public event | ToolAdded | Occurs when a tool frame is added.
Public event | ToolRemoving | Occurs when a tool frame is being removed.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRobotController Properties

The IRobotController type exposes the following members.

Properties
 | Name | Description
Public property | AreBaseAndToolReversed | Indicates that base frame is attached to the flange node (also tool frame is not attached to the flange node).
Public property | AuxWorldSet | Obsolete. Deprecated frame-set reference.
Public property | BaseListDefaultFrameSet | IFrameSet instance that is used to display position frames without base.
Public property | Bases | Available base frames.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Configurations | Available configurations.
Public property | ConfigurationWarnings | Returns state of inverse kinematics calculation for all configurations.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CurrentBase | Selected base.
Public property | CurrentBaseInWorld | Coordinate system of ToolCenterPoint. Equals to RobotWorldNode.TransformationInWorld.
Public property | CurrentConfiguration | Configuration index describing current Joints.
Public property | CurrentState | Current kinematic chain state. (Inherited from IServoController.)
Public property | CurrentTool | Selected tool.
Public property | CustomSimulationUpdateTime | Last time value passed to ScheduleCustomSimulationUpdate(). (Inherited from IServoController.)
Public property | Dofs | List of DOFs used by the controller. (Inherited from IServoController.)
Public property | ExternalJoints | List of imported external joints. (Inherited from IServoController.)
Public property | ExternalTcp | Indicates whether statements are added to the base or tool frame.
Public property | FlangeNode | Gets or sets the flange node (Inherited from IServoController.)
Public property | FlangeOffset | Flange offset.
Public property | HeartbeatTime | Gets or sets heartbeat interval (Inherited from IServoController.)
Public property | InitialBase | Base frame used on simulation reset.
Public property | InitialTool | Tool frame used on simulation reset.
Public property | IsBaseToolSetupValid | Indicates that nodes selected in tool and base frames are valid (kinematic chain is valid).
Public property | IsBeingMoved | Indicates that robot's state is being updated. Moving robot again might result in unpredictable results.
Public property | IsConnected | Indicates whether the servo is connected to another servo (Inherited from IServoController.)
Public property | IsReachable | Obsolete. Indicates that Status contains Reachable.
Public property | IsStatusValid | Returns true only if Status is Valid.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Joints | List of joints implemented in the controller. (Inherited from IServoController.)
Public property | Kinematics | Kinematics behavior associated with this controller behavior.
Public property | LastConfigurationWarnings |
Public property | MaxAngularAcceleration | Maximum angular acceleration for Cartesian motions [deg/s^^2].
Public property | MaxAngularDeceleration | Maximum angular deceleration for Cartesian motions [deg/s^^2].
Public property | MaxAngularSpeed | Maximum angular speed for Cartesian motions [deg/s].
Public property | MaxCartesianAcceleration | Maximum Cartesian acceleration [mm/s^2].
Public property | MaxCartesianDeceleration | Maximum Cartesian deceleration [mm/s^2].
Public property | MaxCartesianSpeed | Maximum Cartesian speed [mm/s].
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NearestConfiguration |
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | RobotWorldNode | Root node attached to robot's base or servo track.
Public property | RootNode | Gets or sets the root node (Inherited from IServoController.)
Public property | RootOffset | Root offset.
Public property | SelectedRobotBaseFramesLayerVisibility | Indicates that robot's base frames should be shown when robot is selected.
Public property | SelectedRobotPositionFramesLayerVisibility | Indicates that robot's position statements should be shown when robot is selected.
Public property | SelectedRobotToolFramesLayerVisibility | Indicates that robot's tool frames should be shown when robot is selected.
Public property | SelectedRobotWorldFramesLayerVisibility | Indicates that robot's world frame should be shown when robot is selected.
Public property | Status | Inverse kinematics status.
Public property | ToolCenterPoint | Tool frame's position. Coordinates are relative to 'CurrentBase.TransformationInWorld' or to 'CurrentBaseInWorld' (which equals to 'RobotWorldNode.TransformationInWorld').
Public property | ToolListDefaultFrameSet | IFrameSet instance that is used to display external TCP positions, whose Tool reference is null.
Public property | Tools | Available tool frames.
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Public property | UsesCustomSimulationUpdate | Indicates that ScheduleCustomSimulationUpdate() was called. (Inherited from IServoController.)
Public property | UsesHeartbeat | Defines if controller updates movements on a heartbeat rate. Normally updating is done when required. (Inherited from IServoController.)
Public property | WorldTransformMatrix | Defines robot world frame of a robot.
Top
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.AreBaseAndToolReversed Property

IRobotControllerAreBaseAndToolReversed Property

Indicates that base frame is attached to the flange node (also tool frame is not attached to the flange node).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool AreBaseAndToolReversed { get; }
property bool AreBaseAndToolReversed {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.AuxWorldSet Property

IRobotControllerAuxWorldSet Property

Note: This API is now obsolete.

Deprecated frame-set reference.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Use BaseListDefaultFrameSet")]
IFrameSet AuxWorldSet { get; }
[ObsoleteAttribute(L"Use BaseListDefaultFrameSet")]
property IFrameSet^ AuxWorldSet {
    IFrameSet^ get ();
}

Property Value

Type: IFrameSet
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.BaseListDefaultFrameSet Property

IRobotControllerBaseListDefaultFrameSet Property

IFrameSet instance that is used to display position frames without base.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFrameSet BaseListDefaultFrameSet { get; }
property IFrameSet^ BaseListDefaultFrameSet {
    IFrameSet^ get ();
}

Property Value

Type: IFrameSet
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.Bases Property

IRobotControllerBases Property

Available base frames.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IRobotFrame> Bases { get; }
property IList<IRobotFrame^>^ Bases {
    IList<IRobotFrame^>^ get ();
}

Property Value

Type: IListIRobotFrame
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.Configurations Property

IRobotControllerConfigurations Property

Available configurations.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<string> Configurations { get; }
property IEnumerable<String^>^ Configurations {
    IEnumerable<String^>^ get ();
}

Property Value

Type: IEnumerableString
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.ConfigurationWarnings Property

IRobotControllerConfigurationWarnings Property

Returns state of inverse kinematics calculation for all configurations.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<ConfigurationWarnings> ConfigurationWarnings { get; }
property IReadOnlyList<ConfigurationWarnings>^ ConfigurationWarnings {
    IReadOnlyList<ConfigurationWarnings>^ get ();
}

Property Value

Type: IReadOnlyListConfigurationWarnings
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.CurrentBase Property

IRobotControllerCurrentBase Property

Selected base.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotFrame CurrentBase { get; set; }
property IRobotFrame^ CurrentBase {
    IRobotFrame^ get ();
    void set (IRobotFrame^ value);
}

Property Value

Type: IRobotFrame
Remarks
Also visible in Jog panel.
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.CurrentBaseInWorld Property

IRobotControllerCurrentBaseInWorld Property

Coordinate system of ToolCenterPoint. Equals to RobotWorldNode.TransformationInWorld.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix CurrentBaseInWorld { get; }
property Matrix CurrentBaseInWorld {
    Matrix get ();
}

Property Value

Type: Matrix
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.CurrentConfiguration Property

IRobotControllerCurrentConfiguration Property

Configuration index describing current Joints.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int CurrentConfiguration { get; set; }
property int CurrentConfiguration {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
Also visible in Jog panel.
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.CurrentTool Property

IRobotControllerCurrentTool Property

Selected tool.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotFrame CurrentTool { get; set; }
property IRobotFrame^ CurrentTool {
    IRobotFrame^ get ();
    void set (IRobotFrame^ value);
}

Property Value

Type: IRobotFrame
Remarks
Also visible in Jog panel.
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.ExternalTcp Property

IRobotControllerExternalTcp Property

Indicates whether statements are added to the base or tool frame.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ExternalTcp { get; set; }
property bool ExternalTcp {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.FlangeOffset Property

IRobotControllerFlangeOffset Property

Flange offset.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix FlangeOffset { get; }
property Matrix FlangeOffset {
    Matrix get ();
}

Property Value

Type: Matrix
Remarks
Also visible in behavior properties.
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.InitialBase Property

IRobotControllerInitialBase Property

Base frame used on simulation reset.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotFrame InitialBase { get; set; }
property IRobotFrame^ InitialBase {
    IRobotFrame^ get ();
    void set (IRobotFrame^ value);
}

Property Value

Type: IRobotFrame
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.InitialTool Property

IRobotControllerInitialTool Property

Tool frame used on simulation reset.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotFrame InitialTool { get; set; }
property IRobotFrame^ InitialTool {
    IRobotFrame^ get ();
    void set (IRobotFrame^ value);
}

Property Value

Type: IRobotFrame
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.IsBaseToolSetupValid Property

IRobotControllerIsBaseToolSetupValid Property

Indicates that nodes selected in tool and base frames are valid (kinematic chain is valid).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsBaseToolSetupValid { get; }
property bool IsBaseToolSetupValid {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.IsBeingMoved Property

IRobotControllerIsBeingMoved Property

Indicates that robot's state is being updated. Moving robot again might result in unpredictable results.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsBeingMoved { get; }
property bool IsBeingMoved {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.IsReachable Property

IRobotControllerIsReachable Property

Note: This API is now obsolete.

Indicates that Status contains Reachable.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Use 'Status & PositionStatus.Reachable' instead.")]
bool IsReachable { get; }
[ObsoleteAttribute(L"Use 'Status & PositionStatus.Reachable' instead.")]
property bool IsReachable {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.IsStatusValid Property

IRobotControllerIsStatusValid Property

Returns true only if Status is Valid.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsStatusValid { get; }
property bool IsStatusValid {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.Kinematics Property

IRobotControllerKinematics Property

Kinematics behavior associated with this controller behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IBehavior Kinematics { get; }
property IBehavior^ Kinematics {
    IBehavior^ get ();
}

Property Value

Type: IBehavior
Remarks
Also visible in controller behavior properties.
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.LastConfigurationWarnings Property

IRobotControllerLastConfigurationWarnings Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<ConfigurationWarnings> LastConfigurationWarnings { get; }
property IReadOnlyList<ConfigurationWarnings>^ LastConfigurationWarnings {
    IReadOnlyList<ConfigurationWarnings>^ get ();
}

Property Value

Type: IReadOnlyListConfigurationWarnings
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.MaxAngularAcceleration Property

IRobotControllerMaxAngularAcceleration Property

Maximum angular acceleration for Cartesian motions [deg/s^^2].

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double MaxAngularAcceleration { get; set; }
property double MaxAngularAcceleration {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.MaxAngularDeceleration Property

IRobotControllerMaxAngularDeceleration Property

Maximum angular deceleration for Cartesian motions [deg/s^^2].

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double MaxAngularDeceleration { get; set; }
property double MaxAngularDeceleration {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.MaxAngularSpeed Property

IRobotControllerMaxAngularSpeed Property

Maximum angular speed for Cartesian motions [deg/s].

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double MaxAngularSpeed { get; set; }
property double MaxAngularSpeed {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.MaxCartesianAcceleration Property

IRobotControllerMaxCartesianAcceleration Property

Maximum Cartesian acceleration [mm/s^2].

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double MaxCartesianAcceleration { get; set; }
property double MaxCartesianAcceleration {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.MaxCartesianDeceleration Property

IRobotControllerMaxCartesianDeceleration Property

Maximum Cartesian deceleration [mm/s^2].

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double MaxCartesianDeceleration { get; set; }
property double MaxCartesianDeceleration {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.MaxCartesianSpeed Property

IRobotControllerMaxCartesianSpeed Property

Maximum Cartesian speed [mm/s].

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double MaxCartesianSpeed { get; set; }
property double MaxCartesianSpeed {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.NearestConfiguration Property

IRobotControllerNearestConfiguration Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int NearestConfiguration { get; }
property int NearestConfiguration {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.RobotWorldNode Property

IRobotControllerRobotWorldNode Property

Root node attached to robot's base or servo track.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode RobotWorldNode { get; }
property ISimNode^ RobotWorldNode {
    ISimNode^ get ();
}

Property Value

Type: ISimNode
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.RootOffset Property

IRobotControllerRootOffset Property

Root offset.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix RootOffset { get; }
property Matrix RootOffset {
    Matrix get ();
}

Property Value

Type: Matrix
Remarks
Also visible in behavior properties.
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.SelectedRobotBaseFramesLayerVisibility Property

IRobotControllerSelectedRobotBaseFramesLayerVisibility Property

Indicates that robot's base frames should be shown when robot is selected.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SelectedRobotBaseFramesLayerVisibility { get; set; }
property bool SelectedRobotBaseFramesLayerVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.SelectedRobotPositionFramesLayerVisibility Property

IRobotControllerSelectedRobotPositionFramesLayerVisibility Property

Indicates that robot's position statements should be shown when robot is selected.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SelectedRobotPositionFramesLayerVisibility { get; set; }
property bool SelectedRobotPositionFramesLayerVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.SelectedRobotToolFramesLayerVisibility Property

IRobotControllerSelectedRobotToolFramesLayerVisibility Property

Indicates that robot's tool frames should be shown when robot is selected.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SelectedRobotToolFramesLayerVisibility { get; set; }
property bool SelectedRobotToolFramesLayerVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.SelectedRobotWorldFramesLayerVisibility Property

IRobotControllerSelectedRobotWorldFramesLayerVisibility Property

Indicates that robot's world frame should be shown when robot is selected.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SelectedRobotWorldFramesLayerVisibility { get; set; }
property bool SelectedRobotWorldFramesLayerVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.Status Property

IRobotControllerStatus Property

Inverse kinematics status.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
PositionStatus Status { get; }
property PositionStatus Status {
    PositionStatus get ();
}

Property Value

Type: PositionStatus
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.ToolCenterPoint Property

IRobotControllerToolCenterPoint Property

Tool frame's position. Coordinates are relative to 'CurrentBase.TransformationInWorld' or to 'CurrentBaseInWorld' (which equals to 'RobotWorldNode.TransformationInWorld').

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix ToolCenterPoint { get; set; }
property Matrix ToolCenterPoint {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.ToolListDefaultFrameSet Property

IRobotControllerToolListDefaultFrameSet Property

IFrameSet instance that is used to display external TCP positions, whose Tool reference is null.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFrameSet ToolListDefaultFrameSet { get; }
property IFrameSet^ ToolListDefaultFrameSet {
    IFrameSet^ get ();
}

Property Value

Type: IFrameSet
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.Tools Property

IRobotControllerTools Property

Available tool frames.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IRobotFrame> Tools { get; }
property IList<IRobotFrame^>^ Tools {
    IList<IRobotFrame^>^ get ();
}

Property Value

Type: IListIRobotFrame
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.WorldTransformMatrix Property

IRobotControllerWorldTransformMatrix Property

Defines robot world frame of a robot.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix WorldTransformMatrix { get; set; }
property Matrix WorldTransformMatrix {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController Methods

The IRobotController type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CalculateJointTurn | A helper method that can be used to calculate the current turn from an absolute angle value.
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateBase(String) | Creates a base frame and adds it to the Bases list.
Public method | CreateBase(String, Boolean) | Creates a base frame and adds it to the Bases list.
Public method | CreateJoint | Create a new joint, and add it to the end of the joint list. (Inherited from IServoController.)
Public method | CreateMotionInterpolator | Creates a motion interpolator instance, that can be used for interpolating robot's movement along a path.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | CreateTarget | Create motion target from robot's current state.
Public method | CreateTool(String) | Creates a tool frame and adds it to the Tools list.
Public method | CreateTool(String, Boolean) | Creates a tool frame and adds it to the Tools list.
Public method | DeleteBase | Removes base from Bases.
Public method | DeleteBaseAt | Removes base from Bases.
Public method | DeleteJoint | Delete the specified joint. (Inherited from IServoController.)
Public method | DeleteJointAt | Delete the joint at the specified index. (Inherited from IServoController.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteTool | Removes tool from Bases.
Public method | DeleteToolAt | Removes tool from Tools.
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetConfigurationWarnings | Returns state of inverse kinematics calculation for a specific configuration.
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetMotionTester | Gets IMotionTester interface for changing robot's state with IMotionTarget.
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateKinChains | Delete all rKinChain instances from controller and executors. (Inherited from IServoController.)
Public method | ScheduleCustomSimulationUpdate | Request a CustomSimulationUpdate event to be triggered when the robot's component is updated during simulation, or at the specified time. (Inherited from IServoController.)
Public method | SetJointValues | Sets the robot joint values. (Inherited from IServoController.)
Public method | SetJointValuesInRadians | Sets the robot joint values. (Inherited from IServoController.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetToolCenterPoint(Matrix, IRobotTcpSettings) | Advanced setter for ToolCenterPoint.
Public method | SetToolCenterPoint(Matrix, Boolean, Boolean, Boolean) | Advanced setter for ToolCenterPoint. If allowUnreachable and target is not reachable returns the best possible result.
Public method | SetToolCenterPoint(Matrix, Boolean, Boolean, Boolean, NullableBoolean, NullableInt32) | Advanced setter for ToolCenterPoint. If allowConfigChange is set, configuration is either maintained as originalConfig or not.
Public method | StartHeartbeat | Start receiving heartbeat events (Inherited from IServoController.)
Public method | StopHeartbeat | Stop receiving heartbeat events (Inherited from IServoController.)
Public method | UpdateCurrentStateJointStarts | Sets joint starts to current joint values.
Public method | UpdateJointLimitHighlights | Updates highlighting of joint nodes if values exceed their limits. (Inherited from IServoController.)
Public method | UpdateRobot | Internal helper.
Public method | UpdateRobotKinematics | Internal helper.
Public method | UpdateToolCenterPoint | Internal helper.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.CalculateJointTurn Method

IRobotControllerCalculateJointTurn Method

A helper method that can be used to calculate the current turn from an absolute angle value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int CalculateJointTurn(
    double jointAngle
)
int CalculateJointTurn(
    double jointAngle
)

Parameters

jointAngle
Type: SystemDouble
Angle of a rotational joint.

Return Value

Type: Int32
Calculated turn
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.CreateBase Method

IRobotControllerCreateBase Method

Overload List
 | Name | Description
Public method | CreateBase(String) | Creates a base frame and adds it to the Bases list.
Public method | CreateBase(String, Boolean) | Creates a base frame and adds it to the Bases list.
Top
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.CreateBase Method (String)

IRobotControllerCreateBase Method (String)

Creates a base frame and adds it to the Bases list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotFrame CreateBase(
    string name
)
IRobotFrame^ CreateBase(
    String^ name
)

Parameters

name
Type: SystemString
New name

Return Value

Type: IRobotFrame
Newly created base frame
See Also

Reference

IRobotController Interface
CreateBase Overload
VisualComponents.Create3D Namespace


IRobotController.CreateBase Method (String, Boolean)

IRobotControllerCreateBase Method (String, Boolean)

Creates a base frame and adds it to the Bases list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotFrame CreateBase(
    string name,
    bool suggestedName
)
IRobotFrame^ CreateBase(
    String^ name,
    bool suggestedName
)

Parameters

name
Type: SystemString
New name
suggestedName
Type: SystemBoolean
Find a unique name if name already used.

Return Value

Type: IRobotFrame

[Missing <returns> documentation for "M:VisualComponents.Create3D.IRobotController.CreateBase(System.String,System.Boolean)"]

See Also

Reference

IRobotController Interface
CreateBase Overload
VisualComponents.Create3D Namespace


IRobotController.CreateMotionInterpolator Method

IRobotControllerCreateMotionInterpolator Method

Creates a motion interpolator instance, that can be used for interpolating robot's movement along a path.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMotionInterpolator CreateMotionInterpolator()
IMotionInterpolator^ CreateMotionInterpolator()

Return Value

Type: IMotionInterpolator
Newly created motion interpolator
Remarks
Motion interpolator object will remain in memory until it is disposed. Therefore it is on the caller's responsibility to dispose the motion interpolator.
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.CreateTarget Method

IRobotControllerCreateTarget Method

Create motion target from robot's current state.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMotionTarget CreateTarget()
IMotionTarget^ CreateTarget()

Return Value

Type: IMotionTarget
Newly created motion target instance
Remarks
Motion target object will remain in memory until it is disposed. Therefore it is on the caller's responsibility to dispose the motion target.
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.CreateTool Method

IRobotControllerCreateTool Method

Overload List
 | Name | Description
Public method | CreateTool(String) | Creates a tool frame and adds it to the Tools list.
Public method | CreateTool(String, Boolean) | Creates a tool frame and adds it to the Tools list.
Top
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.CreateTool Method (String)

IRobotControllerCreateTool Method (String)

Creates a tool frame and adds it to the Tools list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotFrame CreateTool(
    string name
)
IRobotFrame^ CreateTool(
    String^ name
)

Parameters

name
Type: SystemString
New name

Return Value

Type: IRobotFrame
Newly created base frame
See Also

Reference

IRobotController Interface
CreateTool Overload
VisualComponents.Create3D Namespace


IRobotController.CreateTool Method (String, Boolean)

IRobotControllerCreateTool Method (String, Boolean)

Creates a tool frame and adds it to the Tools list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotFrame CreateTool(
    string name,
    bool suggestedName
)
IRobotFrame^ CreateTool(
    String^ name,
    bool suggestedName
)

Parameters

name
Type: SystemString
New name
suggestedName
Type: SystemBoolean
Find a unique name if name already used.

Return Value

Type: IRobotFrame
Newly created tool frame
See Also

Reference

IRobotController Interface
CreateTool Overload
VisualComponents.Create3D Namespace


IRobotController.DeleteBase Method

IRobotControllerDeleteBase Method

Removes base from Bases.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteBase(
    IRobotFrame baseFrame
)
void DeleteBase(
    IRobotFrame^ baseFrame
)

Parameters

baseFrame
Type: VisualComponents.Create3DIRobotFrame
Base frame to remove
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.DeleteBaseAt Method

IRobotControllerDeleteBaseAt Method

Removes base from Bases.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteBaseAt(
    int index
)
void DeleteBaseAt(
    int index
)

Parameters

index
Type: SystemInt32
Index of the item to remove
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.DeleteTool Method

IRobotControllerDeleteTool Method

Removes tool from Bases.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteTool(
    IRobotFrame toolFrame
)
void DeleteTool(
    IRobotFrame^ toolFrame
)

Parameters

toolFrame
Type: VisualComponents.Create3DIRobotFrame
Tool frame to remove
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.DeleteToolAt Method

IRobotControllerDeleteToolAt Method

Removes tool from Tools.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteToolAt(
    int index
)
void DeleteToolAt(
    int index
)

Parameters

index
Type: SystemInt32
Index of the item to remove
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.GetConfigurationWarnings Method

IRobotControllerGetConfigurationWarnings Method

Returns state of inverse kinematics calculation for a specific configuration.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ConfigurationWarnings GetConfigurationWarnings(
    int index
)
ConfigurationWarnings GetConfigurationWarnings(
    int index
)

Parameters

index
Type: SystemInt32
Configuration index

Return Value

Type: ConfigurationWarnings

[Missing <returns> documentation for "M:VisualComponents.Create3D.IRobotController.GetConfigurationWarnings(System.Int32)"]

See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.GetMotionTester Method

IRobotControllerGetMotionTester Method

Gets IMotionTester interface for changing robot's state with IMotionTarget.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMotionTester GetMotionTester()
IMotionTester^ GetMotionTester()

Return Value

Type: IMotionTester
Newly created motion tester instance
Remarks
Motion tester object will remain in memory until it is disposed. Therefore it is on the caller's responsibility to dispose the motion tester.
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.SetToolCenterPoint Method

IRobotControllerSetToolCenterPoint Method

Overload List
 | Name | Description
Public method | SetToolCenterPoint(Matrix, IRobotTcpSettings) | Advanced setter for ToolCenterPoint.
Public method | SetToolCenterPoint(Matrix, Boolean, Boolean, Boolean) | Advanced setter for ToolCenterPoint. If allowUnreachable and target is not reachable returns the best possible result.
Public method | SetToolCenterPoint(Matrix, Boolean, Boolean, Boolean, NullableBoolean, NullableInt32) | Advanced setter for ToolCenterPoint. If allowConfigChange is set, configuration is either maintained as originalConfig or not.
Top
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.SetToolCenterPoint Method (Matrix, IRobotTcpSettings)

IRobotControllerSetToolCenterPoint Method (Matrix, IRobotTcpSettings)

Advanced setter for ToolCenterPoint.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetToolCenterPoint(
    Matrix position,
    IRobotTcpSettings settings
)
void SetToolCenterPoint(
    Matrix position,
    IRobotTcpSettings^ settings
)

Parameters

position
Type: VisualComponents.Create3DMatrix
settings
Type: VisualComponents.Create3DIRobotTcpSettings
See Also

Reference

IRobotController Interface
SetToolCenterPoint Overload
VisualComponents.Create3D Namespace


IRobotController.SetToolCenterPoint Method (Matrix, Boolean, Boolean, Boolean)

IRobotControllerSetToolCenterPoint Method (Matrix, Boolean, Boolean, Boolean)

Advanced setter for ToolCenterPoint. If allowUnreachable and target is not reachable returns the best possible result.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetToolCenterPoint(
    Matrix position,
    bool allowUnreachable,
    bool maintainUnreachable,
    bool allowOutsideJointLimits
)
void SetToolCenterPoint(
    Matrix position,
    bool allowUnreachable,
    bool maintainUnreachable,
    bool allowOutsideJointLimits
)

Parameters

position
Type: VisualComponents.Create3DMatrix
allowUnreachable
Type: SystemBoolean
maintainUnreachable
Type: SystemBoolean
allowOutsideJointLimits
Type: SystemBoolean
See Also

Reference

IRobotController Interface
SetToolCenterPoint Overload
VisualComponents.Create3D Namespace


IRobotController.SetToolCenterPoint Method (Matrix, Boolean, Boolean, Boolean, Nullable(Boolean), Nullable(Int32))

IRobotControllerSetToolCenterPoint Method (Matrix, Boolean, Boolean, Boolean, NullableBoolean, NullableInt32)

Advanced setter for ToolCenterPoint. If allowConfigChange is set, configuration is either maintained as originalConfig or not.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetToolCenterPoint(
    Matrix position,
    bool allowUnreachable,
    bool maintainUnreachable,
    bool allowOutsideJointLimits,
    Nullable<bool> allowConfigChange,
    Nullable<int> originalConfig
)
void SetToolCenterPoint(
    Matrix position,
    bool allowUnreachable,
    bool maintainUnreachable,
    bool allowOutsideJointLimits,
    Nullable<bool> allowConfigChange,
    Nullable<int> originalConfig
)

Parameters

position
Type: VisualComponents.Create3DMatrix
allowUnreachable
Type: SystemBoolean
maintainUnreachable
Type: SystemBoolean
allowOutsideJointLimits
Type: SystemBoolean
allowConfigChange
Type: SystemNullableBoolean
originalConfig
Type: SystemNullableInt32
See Also

Reference

IRobotController Interface
SetToolCenterPoint Overload
VisualComponents.Create3D Namespace


IRobotController.UpdateCurrentStateJointStarts Method

IRobotControllerUpdateCurrentStateJointStarts Method

Sets joint starts to current joint values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateCurrentStateJointStarts()
void UpdateCurrentStateJointStarts()
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.UpdateRobot Method

IRobotControllerUpdateRobot Method

Internal helper.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateRobot()
void UpdateRobot()
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.UpdateRobotKinematics Method

IRobotControllerUpdateRobotKinematics Method

Internal helper.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateRobotKinematics()
void UpdateRobotKinematics()
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.UpdateToolCenterPoint Method

IRobotControllerUpdateToolCenterPoint Method

Internal helper.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateToolCenterPoint()
void UpdateToolCenterPoint()
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController Events

The IRobotController type exposes the following members.

Events
 | Name | Description
Public event | BaseAdded | Occurs when a base frame is added.
Public event | BaseRemoving | Occurs when a base frame is being removed.
Public event | CurrentStateChange | Event triggered at each state change. (Inherited from IServoController.)
Public event | CurrentStateInvalidated | Event triggered when CurrentState gets invalidated. (Inherited from IServoController.)
Public event | CustomSimulationUpdate | Event triggered on simulation update. (Inherited from IServoController.)
Public event | DofValueChanged | Event triggered when the value any associated instance of IDof changes. (Inherited from IServoController.)
Public event | Heartbeat | Event triggered at each heartbeat of servo. (Inherited from IServoController.)
Public event | JointAdded | Event triggered when a joint was added to this controller. (Inherited from IServoController.)
Public event | JointRemoved | Event triggered when a joint was removed from this controller. (Inherited from IServoController.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | RobotWorldNodeChanged | Occurs when robot world node is changed.
Public event | ToolAdded | Occurs when a tool frame is added.
Public event | ToolRemoving | Occurs when a tool frame is being removed.
Top
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.BaseAdded Event

IRobotControllerBaseAdded Event

Occurs when a base frame is added.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<RobotFrameAddedEventArgs> BaseAdded
 event EventHandler<RobotFrameAddedEventArgs^>^ BaseAdded {
    void add (EventHandler<RobotFrameAddedEventArgs^>^ value);
    void remove (EventHandler<RobotFrameAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerRobotFrameAddedEventArgs
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.BaseRemoving Event

IRobotControllerBaseRemoving Event

Occurs when a base frame is being removed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<RobotFrameRemovingEventArgs> BaseRemoving
 event EventHandler<RobotFrameRemovingEventArgs^>^ BaseRemoving {
    void add (EventHandler<RobotFrameRemovingEventArgs^>^ value);
    void remove (EventHandler<RobotFrameRemovingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerRobotFrameRemovingEventArgs
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.RobotWorldNodeChanged Event

IRobotControllerRobotWorldNodeChanged Event

Occurs when robot world node is changed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler RobotWorldNodeChanged
 event EventHandler^ RobotWorldNodeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.ToolAdded Event

IRobotControllerToolAdded Event

Occurs when a tool frame is added.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<RobotFrameAddedEventArgs> ToolAdded
 event EventHandler<RobotFrameAddedEventArgs^>^ ToolAdded {
    void add (EventHandler<RobotFrameAddedEventArgs^>^ value);
    void remove (EventHandler<RobotFrameAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerRobotFrameAddedEventArgs
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotController.ToolRemoving Event

IRobotControllerToolRemoving Event

Occurs when a tool frame is being removed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<RobotFrameRemovingEventArgs> ToolRemoving
 event EventHandler<RobotFrameRemovingEventArgs^>^ ToolRemoving {
    void add (EventHandler<RobotFrameRemovingEventArgs^>^ value);
    void remove (EventHandler<RobotFrameRemovingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerRobotFrameRemovingEventArgs
See Also

Reference

IRobotController Interface
VisualComponents.Create3D Namespace


IRobotConverter Interface

Helper class for converting old RSL programs to the new IRobotExecutor format.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRobotConverter
public interface class IRobotConverter

The IRobotConverter type exposes the following members.

Methods
 | Name | Description
Public method | ConvertExecutor | Creates an instance of IRobotExecutor and converts the program in given legacy executor.
Public method | ConvertRobot | Creates a new instance of IRobotExecutor and converts the program in the legace executor. Legacy executor is automatically deleted.
Public method | HasLegacyProgram | Checks if the legacy executor has a program.
Public method | NeedsConversion | Checks if the given robot has a legacy executor which needs to be converted.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRobotConverter Methods

The IRobotConverter type exposes the following members.

Methods
 | Name | Description
Public method | ConvertExecutor | Creates an instance of IRobotExecutor and converts the program in given legacy executor.
Public method | ConvertRobot | Creates a new instance of IRobotExecutor and converts the program in the legace executor. Legacy executor is automatically deleted.
Public method | HasLegacyProgram | Checks if the legacy executor has a program.
Public method | NeedsConversion | Checks if the given robot has a legacy executor which needs to be converted.
Top
See Also

Reference

IRobotConverter Interface
VisualComponents.Create3D Namespace


IRobotConverter.ConvertExecutor Method

IRobotConverterConvertExecutor Method

Creates an instance of IRobotExecutor and converts the program in given legacy executor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotExecutor ConvertExecutor(
    IRslExecutor legacyExecutor
)
IRobotExecutor^ ConvertExecutor(
    IRslExecutor^ legacyExecutor
)

Parameters

legacyExecutor
Type: VisualComponents.Create3DIRslExecutor
Legacy executor to convert.

Return Value

Type: IRobotExecutor

[Missing <returns> documentation for "M:VisualComponents.Create3D.IRobotConverter.ConvertExecutor(VisualComponents.Create3D.IRslExecutor)"]

Remarks
This method does not delete the legacy executor.
See Also

Reference

IRobotConverter Interface
VisualComponents.Create3D Namespace


IRobotConverter.ConvertRobot Method

IRobotConverterConvertRobot Method

Creates a new instance of IRobotExecutor and converts the program in the legace executor. Legacy executor is automatically deleted.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ConvertRobot(
    IRobot robot
)
void ConvertRobot(
    IRobot^ robot
)

Parameters

robot
Type: VisualComponents.Create3DIRobot
Robot to convert.
Remarks
This only converts the first executor in the component. For multiexecutor components use ConvertExecutor method
See Also

Reference

IRobotConverter Interface
VisualComponents.Create3D Namespace


IRobotConverter.HasLegacyProgram Method

IRobotConverterHasLegacyProgram Method

Checks if the legacy executor has a program.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool HasLegacyProgram(
    IRslExecutor legacyExecutor
)
bool HasLegacyProgram(
    IRslExecutor^ legacyExecutor
)

Parameters

legacyExecutor
Type: VisualComponents.Create3DIRslExecutor
Legacy executor.

Return Value

Type: Boolean
True if the legacy executor has a program.
See Also

Reference

IRobotConverter Interface
VisualComponents.Create3D Namespace


IRobotConverter.NeedsConversion Method

IRobotConverterNeedsConversion Method

Checks if the given robot has a legacy executor which needs to be converted.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
RobotConversionStatus NeedsConversion(
    IRobot robot
)
RobotConversionStatus NeedsConversion(
    IRobot^ robot
)

Parameters

robot
Type: VisualComponents.Create3DIRobot
Robot to check.

Return Value

Type: RobotConversionStatus
Result indicating if the conversion is needed
See Also

Reference

IRobotConverter Interface
VisualComponents.Create3D Namespace


IRobotExecutor Interface

Robot executor behavior interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRobotExecutor : IExecutor,
    IStatementExecutor, IBehavior, IPropertyContainer, IBatchModeObject, IVisitable,
    IWrapper, IDisposable, INamed
public interface class IRobotExecutor : IExecutor,
    IStatementExecutor, IBehavior, IPropertyContainer, IBatchModeObject, IVisitable,
    IWrapper, IDisposable, INamed

The IRobotExecutor type exposes the following members.

Properties
 | Name | Description
Public property | ActiveProgram | Gets or sets the currently active program. (Inherited from IStatementExecutor.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Controller | Gets or sets the associated robot controller behavior.
Public property | CurrentScope | Get the scope that is currently being executed. (Inherited from IStatementExecutor.)
Public property | CurrentStatement | Gets the current position of the program pointer. Returns null if in the beginning of scope. (Inherited from IStatementExecutor.)
Public property | CycleTimeMarker1 | Gets or sets the instance of IStatement that defines the start/end point for cycle time calculation.
Public property | CycleTimeMarker2 | Gets or sets the instance of IStatement that defines the start/end point for cycle time calculation.
Public property | DigitalInputSignals | Gets or sets the input ISignalMap associated to this IExecutor. (Inherited from IExecutor.)
Public property | DigitalOutputSignals | Gets or sets the output ISignalMap associated to this IExecutor. (Inherited from IExecutor.)
Public property | ExternalMode | Determines whether to call an external executor to drive the robot.
Public property | IsEnabled | Defines if the executor will execute its program. (Inherited from IStatementExecutor.)
Public property | IsIdle | Returns true if, and only if, the executor is currently not executing any IStatements or IStatementScopes. (Inherited from IExecutor.)
Public property | IsLooping | Defines if the executor will restart the program automatically when finished. (Inherited from IStatementExecutor.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Program | Gets the first program contained by this IStatementExecutor instance. (Inherited from IStatementExecutor.)
Public property | Programs | Gets all the instances of IProgram in this executor. (Inherited from IStatementExecutor.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | StatementHandler | Gets or sets the instance of IProcessHandler that can be used for overriding or customizing the execution of IStatement instances. (Inherited from IExecutor.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | ClearPrograms | (Inherited from IStatementExecutor.)
Public method | Continue | Continues execution. (Inherited from IStatementExecutor.)
Public method | Continue(Double) | Continues the execution after a given time. (Inherited from IStatementExecutor.)
Public method | CreateProgram | Creates a new instance of IProgram. (Inherited from IStatementExecutor.)
Public method | CreateProgram(String) | Creates a new instance of IProgram. (Inherited from IStatementExecutor.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProgram | Deletes the given instance of IProgram (Inherited from IStatementExecutor.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndProgram |
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | ExecuteStep | Execute the next IStatement. (Inherited from IStatementExecutor.)
Public method | Freeze |
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | JumpToScope | Adds the current program position to the stack and jumps program execution to the given scope. When the scope is finished, the progam will continue from the current position. (Inherited from IStatementExecutor.)
Public method | NotifyStatementExecutedEx | Signals ExecutedEx event for this statement. This should only be used together with custom statements that have set the value of ControlExecutedExEvent to true. (Inherited from IStatementExecutor.)
Public method | Reset | Reset the execution to the beginning of the program. (Inherited from IStatementExecutor.)
Public method | SetProgramPointer | Sets the program pointer to the given position. When executed, the program will start from this position. (Inherited from IStatementExecutor.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ActiveProgramChanged | Occurs when the value of ActiveProgram has changed. (Inherited from IStatementExecutor.)
Public event | BinaryInputValueChanged |
Public event | CurrentStatementChanged | Obsolete. An event that is raised when the executor begins to execute a IStatement. (Inherited from IExecutor.)
Public event | CycleTimeMarkersChanged | Occurs when the value of CycleTimeMarker1 or CycleTimeMarker2 property is changed.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | ProgramAdded | Occurs when a new instance of IProgram has been added to this instance of IStatementExecutor. (Inherited from IStatementExecutor.)
Public event | ProgramFinished | An event that is raised when the executor has executed its program. (Inherited from IExecutor.)
Public event | ProgramRemoving | Occurs when an instance of IProgram is being removed from this instance of IStatementExecutor. (Inherited from IStatementExecutor.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | RunNotified |
Public event | SimulationReset |
Public event | SimulationStarted |
Public event | SimulationStopped |
Public event | StatementExecuted | An event that is raised when the executor has executed a IStatement. (Inherited from IExecutor.)
Public event | StatementExecuting | An event that is raised when the executor begins to execute a IStatement. (Inherited from IExecutor.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRobotExecutor Properties

The IRobotExecutor type exposes the following members.

Properties
 | Name | Description
Public property | ActiveProgram | Gets or sets the currently active program. (Inherited from IStatementExecutor.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Controller | Gets or sets the associated robot controller behavior.
Public property | CurrentScope | Get the scope that is currently being executed. (Inherited from IStatementExecutor.)
Public property | CurrentStatement | Gets the current position of the program pointer. Returns null if in the beginning of scope. (Inherited from IStatementExecutor.)
Public property | CycleTimeMarker1 | Gets or sets the instance of IStatement that defines the start/end point for cycle time calculation.
Public property | CycleTimeMarker2 | Gets or sets the instance of IStatement that defines the start/end point for cycle time calculation.
Public property | DigitalInputSignals | Gets or sets the input ISignalMap associated to this IExecutor. (Inherited from IExecutor.)
Public property | DigitalOutputSignals | Gets or sets the output ISignalMap associated to this IExecutor. (Inherited from IExecutor.)
Public property | ExternalMode | Determines whether to call an external executor to drive the robot.
Public property | IsEnabled | Defines if the executor will execute its program. (Inherited from IStatementExecutor.)
Public property | IsIdle | Returns true if, and only if, the executor is currently not executing any IStatements or IStatementScopes. (Inherited from IExecutor.)
Public property | IsLooping | Defines if the executor will restart the program automatically when finished. (Inherited from IStatementExecutor.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Program | Gets the first program contained by this IStatementExecutor instance. (Inherited from IStatementExecutor.)
Public property | Programs | Gets all the instances of IProgram in this executor. (Inherited from IStatementExecutor.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | StatementHandler | Gets or sets the instance of IProcessHandler that can be used for overriding or customizing the execution of IStatement instances. (Inherited from IExecutor.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IRobotExecutor Interface
VisualComponents.Create3D Namespace


IRobotExecutor.Controller Property

IRobotExecutorController Property

Gets or sets the associated robot controller behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IBehavior Controller { get; set; }
property IBehavior^ Controller {
    IBehavior^ get ();
    void set (IBehavior^ value);
}

Property Value

Type: IBehavior
See Also

Reference

IRobotExecutor Interface
VisualComponents.Create3D Namespace


IRobotExecutor.CycleTimeMarker1 Property

IRobotExecutorCycleTimeMarker1 Property

Gets or sets the instance of IStatement that defines the start/end point for cycle time calculation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatement CycleTimeMarker1 { get; set; }
property IStatement^ CycleTimeMarker1 {
    IStatement^ get ();
    void set (IStatement^ value);
}

Property Value

Type: IStatement
See Also

Reference

IRobotExecutor Interface
VisualComponents.Create3D Namespace


IRobotExecutor.CycleTimeMarker2 Property

IRobotExecutorCycleTimeMarker2 Property

Gets or sets the instance of IStatement that defines the start/end point for cycle time calculation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatement CycleTimeMarker2 { get; set; }
property IStatement^ CycleTimeMarker2 {
    IStatement^ get ();
    void set (IStatement^ value);
}

Property Value

Type: IStatement
See Also

Reference

IRobotExecutor Interface
VisualComponents.Create3D Namespace


IRobotExecutor.ExternalMode Property

IRobotExecutorExternalMode Property

Determines whether to call an external executor to drive the robot.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ExternalMode { get; set; }
property bool ExternalMode {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRobotExecutor Interface
VisualComponents.Create3D Namespace


IRobotExecutor Methods

The IRobotExecutor type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | ClearPrograms | (Inherited from IStatementExecutor.)
Public method | Continue | Continues execution. (Inherited from IStatementExecutor.)
Public method | Continue(Double) | Continues the execution after a given time. (Inherited from IStatementExecutor.)
Public method | CreateProgram | Creates a new instance of IProgram. (Inherited from IStatementExecutor.)
Public method | CreateProgram(String) | Creates a new instance of IProgram. (Inherited from IStatementExecutor.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProgram | Deletes the given instance of IProgram (Inherited from IStatementExecutor.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndProgram |
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | ExecuteStep | Execute the next IStatement. (Inherited from IStatementExecutor.)
Public method | Freeze |
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | JumpToScope | Adds the current program position to the stack and jumps program execution to the given scope. When the scope is finished, the progam will continue from the current position. (Inherited from IStatementExecutor.)
Public method | NotifyStatementExecutedEx | Signals ExecutedEx event for this statement. This should only be used together with custom statements that have set the value of ControlExecutedExEvent to true. (Inherited from IStatementExecutor.)
Public method | Reset | Reset the execution to the beginning of the program. (Inherited from IStatementExecutor.)
Public method | SetProgramPointer | Sets the program pointer to the given position. When executed, the program will start from this position. (Inherited from IStatementExecutor.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRobotExecutor Interface
VisualComponents.Create3D Namespace


IRobotExecutor.EndProgram Method

IRobotExecutorEndProgram Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void EndProgram()
void EndProgram()
See Also

Reference

IRobotExecutor Interface
VisualComponents.Create3D Namespace


IRobotExecutor.Freeze Method

IRobotExecutorFreeze Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Freeze()
void Freeze()
See Also

Reference

IRobotExecutor Interface
VisualComponents.Create3D Namespace


IRobotExecutor Events

The IRobotExecutor type exposes the following members.

Events
 | Name | Description
Public event | ActiveProgramChanged | Occurs when the value of ActiveProgram has changed. (Inherited from IStatementExecutor.)
Public event | BinaryInputValueChanged |
Public event | CurrentStatementChanged | Obsolete. An event that is raised when the executor begins to execute a IStatement. (Inherited from IExecutor.)
Public event | CycleTimeMarkersChanged | Occurs when the value of CycleTimeMarker1 or CycleTimeMarker2 property is changed.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | ProgramAdded | Occurs when a new instance of IProgram has been added to this instance of IStatementExecutor. (Inherited from IStatementExecutor.)
Public event | ProgramFinished | An event that is raised when the executor has executed its program. (Inherited from IExecutor.)
Public event | ProgramRemoving | Occurs when an instance of IProgram is being removed from this instance of IStatementExecutor. (Inherited from IStatementExecutor.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | RunNotified |
Public event | SimulationReset |
Public event | SimulationStarted |
Public event | SimulationStopped |
Public event | StatementExecuted | An event that is raised when the executor has executed a IStatement. (Inherited from IExecutor.)
Public event | StatementExecuting | An event that is raised when the executor begins to execute a IStatement. (Inherited from IExecutor.)
Top
See Also

Reference

IRobotExecutor Interface
VisualComponents.Create3D Namespace


IRobotExecutor.BinaryInputValueChanged Event

IRobotExecutorBinaryInputValueChanged Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<BinaryInputValueChangedEventArgs> BinaryInputValueChanged
 event EventHandler<BinaryInputValueChangedEventArgs^>^ BinaryInputValueChanged {
    void add (EventHandler<BinaryInputValueChangedEventArgs^>^ value);
    void remove (EventHandler<BinaryInputValueChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerBinaryInputValueChangedEventArgs
See Also

Reference

IRobotExecutor Interface
VisualComponents.Create3D Namespace


IRobotExecutor.CycleTimeMarkersChanged Event

IRobotExecutorCycleTimeMarkersChanged Event

Occurs when the value of CycleTimeMarker1 or CycleTimeMarker2 property is changed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler CycleTimeMarkersChanged
 event EventHandler^ CycleTimeMarkersChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IRobotExecutor Interface
VisualComponents.Create3D Namespace


IRobotExecutor.RunNotified Event

IRobotExecutorRunNotified Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<RunNotifiedEventArgs> RunNotified
 event EventHandler<RunNotifiedEventArgs^>^ RunNotified {
    void add (EventHandler<RunNotifiedEventArgs^>^ value);
    void remove (EventHandler<RunNotifiedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerRunNotifiedEventArgs
See Also

Reference

IRobotExecutor Interface
VisualComponents.Create3D Namespace


IRobotExecutor.SimulationReset Event

IRobotExecutorSimulationReset Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> SimulationReset
 event EventHandler<EventArgs^>^ SimulationReset {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

IRobotExecutor Interface
VisualComponents.Create3D Namespace


IRobotExecutor.SimulationStarted Event

IRobotExecutorSimulationStarted Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> SimulationStarted
 event EventHandler<EventArgs^>^ SimulationStarted {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

IRobotExecutor Interface
VisualComponents.Create3D Namespace


IRobotExecutor.SimulationStopped Event

IRobotExecutorSimulationStopped Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> SimulationStopped
 event EventHandler<EventArgs^>^ SimulationStopped {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

IRobotExecutor Interface
VisualComponents.Create3D Namespace


IRobotFrame Interface

Base/tool frame interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRobotFrame : IVisualObject,
    INamed, IWrapper, IDisposable, IPropertyContainer, IBatchModeObject
public interface class IRobotFrame : IVisualObject,
    INamed, IWrapper, IDisposable, IPropertyContainer, IBatchModeObject

The IRobotFrame type exposes the following members.

Properties
 | Name | Description
Public property | Behavior | Containing behavior.
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | FrameSet | Frame set containing this robot frame.
Public property | IpoMode | Frame IPO mode.
Public property | IsBaseFrame | Whether this frame is a base frame or a tool frame.
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsImported | Whether the frame was imported from another behavior through plug and play.
Public property | IsParametric | Obsolete. Whether the position expression uses component parameters.
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Node where the tool or base is attached.
Public property | Parent | Parent visual object.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | PositionExpression | Expression string that defines frame position within its node.
Public property | PositionFrameSet | Frame set to use for rendering positions that use this frame as a base, or a tool in external TCP mode.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IVisualObject.)
Public property | TransformationInWorld | Gets or sets the world transformation matrix (Inherited from IVisualObject.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Public event | UpdatedPositions | This event happens after doing the position statements update in case of transformation in the base
Public event | UpdatingPositions | This event happens before doing the position statement update in case of transformation in the base
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRobotFrame Properties

The IRobotFrame type exposes the following members.

Properties
 | Name | Description
Public property | Behavior | Containing behavior.
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | FrameSet | Frame set containing this robot frame.
Public property | IpoMode | Frame IPO mode.
Public property | IsBaseFrame | Whether this frame is a base frame or a tool frame.
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsImported | Whether the frame was imported from another behavior through plug and play.
Public property | IsParametric | Obsolete. Whether the position expression uses component parameters.
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Node where the tool or base is attached.
Public property | Parent | Parent visual object.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | PositionExpression | Expression string that defines frame position within its node.
Public property | PositionFrameSet | Frame set to use for rendering positions that use this frame as a base, or a tool in external TCP mode.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IVisualObject.)
Public property | TransformationInWorld | Gets or sets the world transformation matrix (Inherited from IVisualObject.)
Top
See Also

Reference

IRobotFrame Interface
VisualComponents.Create3D Namespace


IRobotFrame.Behavior Property

IRobotFrameBehavior Property

Containing behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IBehavior Behavior { get; }
property IBehavior^ Behavior {
    IBehavior^ get ();
}

Property Value

Type: IBehavior
See Also

Reference

IRobotFrame Interface
VisualComponents.Create3D Namespace


IRobotFrame.FrameSet Property

IRobotFrameFrameSet Property

Frame set containing this robot frame.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFrameSet FrameSet { get; }
property IFrameSet^ FrameSet {
    IFrameSet^ get ();
}

Property Value

Type: IFrameSet
See Also

Reference

IRobotFrame Interface
VisualComponents.Create3D Namespace


IRobotFrame.IpoMode Property

IRobotFrameIpoMode Property

Frame IPO mode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
RobotFrameIpoMode IpoMode { get; set; }
property RobotFrameIpoMode IpoMode {
    RobotFrameIpoMode get ();
    void set (RobotFrameIpoMode value);
}

Property Value

Type: RobotFrameIpoMode
Remarks
This determines the default TCP mode when the base or tool is selected.
See Also

Reference

IRobotFrame Interface
VisualComponents.Create3D Namespace


IRobotFrame.IsBaseFrame Property

IRobotFrameIsBaseFrame Property

Whether this frame is a base frame or a tool frame.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsBaseFrame { get; }
property bool IsBaseFrame {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IRobotFrame Interface
VisualComponents.Create3D Namespace


IRobotFrame.IsImported Property

IRobotFrameIsImported Property

Whether the frame was imported from another behavior through plug and play.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsImported { get; }
property bool IsImported {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IRobotFrame Interface
VisualComponents.Create3D Namespace


IRobotFrame.IsParametric Property

IRobotFrameIsParametric Property

Note: This API is now obsolete.

Whether the position expression uses component parameters.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("IsParametric is obsolete")]
bool IsParametric { get; set; }
[ObsoleteAttribute(L"IsParametric is obsolete")]
property bool IsParametric {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRobotFrame Interface
VisualComponents.Create3D Namespace


IRobotFrame.Node Property

IRobotFrameNode Property

Node where the tool or base is attached.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode Node { get; set; }
property ISimNode^ Node {
    ISimNode^ get ();
    void set (ISimNode^ value);
}

Property Value

Type: ISimNode
See Also

Reference

IRobotFrame Interface
VisualComponents.Create3D Namespace


IRobotFrame.Parent Property

IRobotFrameParent Property

Parent visual object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IVisualObject Parent { get; }
property IVisualObject^ Parent {
    IVisualObject^ get ();
}

Property Value

Type: IVisualObject
See Also

Reference

IRobotFrame Interface
VisualComponents.Create3D Namespace


IRobotFrame.PositionExpression Property

IRobotFramePositionExpression Property

Expression string that defines frame position within its node.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string PositionExpression { get; set; }
property String^ PositionExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IRobotFrame Interface
VisualComponents.Create3D Namespace


IRobotFrame.PositionFrameSet Property

IRobotFramePositionFrameSet Property

Frame set to use for rendering positions that use this frame as a base, or a tool in external TCP mode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFrameSet PositionFrameSet { get; }
property IFrameSet^ PositionFrameSet {
    IFrameSet^ get ();
}

Property Value

Type: IFrameSet
See Also

Reference

IRobotFrame Interface
VisualComponents.Create3D Namespace


IRobotFrame Methods

The IRobotFrame type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRobotFrame Interface
VisualComponents.Create3D Namespace


IRobotFrame Events

The IRobotFrame type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Public event | UpdatedPositions | This event happens after doing the position statements update in case of transformation in the base
Public event | UpdatingPositions | This event happens before doing the position statement update in case of transformation in the base
Top
See Also

Reference

IRobotFrame Interface
VisualComponents.Create3D Namespace


IRobotFrame.UpdatedPositions Event

IRobotFrameUpdatedPositions Event

This event happens after doing the position statements update in case of transformation in the base

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> UpdatedPositions
 event EventHandler<EventArgs^>^ UpdatedPositions {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

IRobotFrame Interface
VisualComponents.Create3D Namespace


IRobotFrame.UpdatingPositions Event

IRobotFrameUpdatingPositions Event

This event happens before doing the position statement update in case of transformation in the base

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> UpdatingPositions
 event EventHandler<EventArgs^>^ UpdatingPositions {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

IRobotFrame Interface
VisualComponents.Create3D Namespace


IRobotPositionManipulationTarget Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRobotPositionManipulationTarget : IManipulationTarget,
    ILockableObject, IDisposable
public interface class IRobotPositionManipulationTarget : IManipulationTarget,
    ILockableObject, IDisposable

The IRobotPositionManipulationTarget type exposes the following members.

Properties
 | Name | Description
Public property | HandleInObjectCoordinates | Deprecated. Same as TransformationInObject. (Inherited from IManipulationTarget.)
Public property | HandleInReference | Deprecated. Same as TransformationInReference. (Inherited from IManipulationTarget.)
Public property | HandleInWorld | Deprecated. Same as TransformationInWorld. (Inherited from IManipulationTarget.)
Public property | HandleReferenceInWorld | Deprecated. Same as ParentTransformationInWorld. (Inherited from IManipulationTarget.)
Public property | IsHandleFixed | Deprecated. Same as IRobotTcpManipulationTarget.IsTcpExternal. (Inherited from IManipulationTarget.)
Public property | IsLocked | (Inherited from IManipulationTarget.)
Public property | IsStatusValid |
Public property | IsTargetEnabled | This is similar to IsLocked, but for manual disabling. (Inherited from IManipulationTarget.)
Public property | IsValid | (Inherited from IManipulationTarget.)
Public property | IsVisible | (Inherited from IManipulationTarget.)
Public property | ParentTransformationInWorld | Position of pivot visual object parent. (Inherited from IManipulationTarget.)
Public property | PivotObject | (Inherited from IManipulationTarget.)
Public property | PositionFrames |
Public property | PositionStatements |
Public property | TargetObjects | Target objects. May exlude child objects. (Inherited from IManipulationTarget.)
Public property | TransformationInObject | Sets the transformation in reference to its own space (Inherited from IManipulationTarget.)
Public property | TransformationInReference | Gets or sets the transformation in reference to its parent (Inherited from IManipulationTarget.)
Public property | TransformationInWorld | Gets or sets the transformation in world (Inherited from IManipulationTarget.)
Top
Methods
 | Name | Description
Public method | ApplyChanges | This is implemented by manipulators that do actual changes on action end or mouse relase. If finalChange==false, then it's only an intermediate change (on mouse release). (Inherited from IManipulationTarget.)
Public method | CollectUndoChanges | Collect all changes since the last call to StoreUndoState(). (Inherited from IManipulationTarget.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | StoreUndoState | Store information away to be used when creating an undo change set later. (Inherited from IManipulationTarget.)
Top
Events
 | Name | Description
Public event | IsLockedChanged | (Inherited from IManipulationTarget.)
Public event | IsVisibleChanged | (Inherited from IManipulationTarget.)
Public event | ObjectInvalidated | (Inherited from IManipulationTarget.)
Public event | TransformationChanged | (Inherited from IManipulationTarget.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRobotPositionManipulationTarget Properties

The IRobotPositionManipulationTarget type exposes the following members.

Properties
 | Name | Description
Public property | HandleInObjectCoordinates | Deprecated. Same as TransformationInObject. (Inherited from IManipulationTarget.)
Public property | HandleInReference | Deprecated. Same as TransformationInReference. (Inherited from IManipulationTarget.)
Public property | HandleInWorld | Deprecated. Same as TransformationInWorld. (Inherited from IManipulationTarget.)
Public property | HandleReferenceInWorld | Deprecated. Same as ParentTransformationInWorld. (Inherited from IManipulationTarget.)
Public property | IsHandleFixed | Deprecated. Same as IRobotTcpManipulationTarget.IsTcpExternal. (Inherited from IManipulationTarget.)
Public property | IsLocked | (Inherited from IManipulationTarget.)
Public property | IsStatusValid |
Public property | IsTargetEnabled | This is similar to IsLocked, but for manual disabling. (Inherited from IManipulationTarget.)
Public property | IsValid | (Inherited from IManipulationTarget.)
Public property | IsVisible | (Inherited from IManipulationTarget.)
Public property | ParentTransformationInWorld | Position of pivot visual object parent. (Inherited from IManipulationTarget.)
Public property | PivotObject | (Inherited from IManipulationTarget.)
Public property | PositionFrames |
Public property | PositionStatements |
Public property | TargetObjects | Target objects. May exlude child objects. (Inherited from IManipulationTarget.)
Public property | TransformationInObject | Sets the transformation in reference to its own space (Inherited from IManipulationTarget.)
Public property | TransformationInReference | Gets or sets the transformation in reference to its parent (Inherited from IManipulationTarget.)
Public property | TransformationInWorld | Gets or sets the transformation in world (Inherited from IManipulationTarget.)
Top
See Also

Reference

IRobotPositionManipulationTarget Interface
VisualComponents.Create3D Namespace


IRobotPositionManipulationTarget.IsStatusValid Property

IRobotPositionManipulationTargetIsStatusValid Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsStatusValid { get; }
property bool IsStatusValid {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IRobotPositionManipulationTarget Interface
VisualComponents.Create3D Namespace


IRobotPositionManipulationTarget.PositionFrames Property

IRobotPositionManipulationTargetPositionFrames Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IPositionFrame> PositionFrames { get; }
property IList<IPositionFrame^>^ PositionFrames {
    IList<IPositionFrame^>^ get ();
}

Property Value

Type: IListIPositionFrame
See Also

Reference

IRobotPositionManipulationTarget Interface
VisualComponents.Create3D Namespace


IRobotPositionManipulationTarget.PositionStatements Property

IRobotPositionManipulationTargetPositionStatements Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IPositionStatement> PositionStatements { get; }
property IList<IPositionStatement^>^ PositionStatements {
    IList<IPositionStatement^>^ get ();
}

Property Value

Type: IListIPositionStatement
See Also

Reference

IRobotPositionManipulationTarget Interface
VisualComponents.Create3D Namespace


IRobotPositionManipulationTarget Methods

The IRobotPositionManipulationTarget type exposes the following members.

Methods
 | Name | Description
Public method | ApplyChanges | This is implemented by manipulators that do actual changes on action end or mouse relase. If finalChange==false, then it's only an intermediate change (on mouse release). (Inherited from IManipulationTarget.)
Public method | CollectUndoChanges | Collect all changes since the last call to StoreUndoState(). (Inherited from IManipulationTarget.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | StoreUndoState | Store information away to be used when creating an undo change set later. (Inherited from IManipulationTarget.)
Top
See Also

Reference

IRobotPositionManipulationTarget Interface
VisualComponents.Create3D Namespace


IRobotPositionManipulationTarget Events

The IRobotPositionManipulationTarget type exposes the following members.

Events
 | Name | Description
Public event | IsLockedChanged | (Inherited from IManipulationTarget.)
Public event | IsVisibleChanged | (Inherited from IManipulationTarget.)
Public event | ObjectInvalidated | (Inherited from IManipulationTarget.)
Public event | TransformationChanged | (Inherited from IManipulationTarget.)
Top
See Also

Reference

IRobotPositionManipulationTarget Interface
VisualComponents.Create3D Namespace


IRobotTcpManipulationTarget Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRobotTcpManipulationTarget : IManipulationTarget,
    ILockableObject, IDisposable
public interface class IRobotTcpManipulationTarget : IManipulationTarget,
    ILockableObject, IDisposable

The IRobotTcpManipulationTarget type exposes the following members.

Properties
 | Name | Description
Public property | AllowConfigChange |
Public property | AllowJointTurnChange |
Public property | AllowUnreachable | If allowUnreachable and target is not reachable sets the best possible result.
Public property | Controller |
Public property | HandleInObjectCoordinates | Deprecated. Same as TransformationInObject. (Inherited from IManipulationTarget.)
Public property | HandleInReference | Deprecated. Same as TransformationInReference. (Inherited from IManipulationTarget.)
Public property | HandleInWorld | Deprecated. Same as TransformationInWorld. (Inherited from IManipulationTarget.)
Public property | HandleReferenceInWorld | Deprecated. Same as ParentTransformationInWorld. (Inherited from IManipulationTarget.)
Public property | IsHandleFixed | Deprecated. Same as IRobotTcpManipulationTarget.IsTcpExternal. (Inherited from IManipulationTarget.)
Public property | IsLocked | (Inherited from IManipulationTarget.)
Public property | IsTargetEnabled | This is similar to IsLocked, but for manual disabling. (Inherited from IManipulationTarget.)
Public property | IsTcpExternal |
Public property | IsValid | (Inherited from IManipulationTarget.)
Public property | IsVisible | (Inherited from IManipulationTarget.)
Public property | OriginalConfig |
Public property | OriginalJointTurns |
Public property | ParentTransformationInWorld | Position of pivot visual object parent. (Inherited from IManipulationTarget.)
Public property | PivotObject | (Inherited from IManipulationTarget.)
Public property | Robot |
Public property | RobotController |
Public property | TargetObjects | Target objects. May exlude child objects. (Inherited from IManipulationTarget.)
Public property | TransformationInObject | Sets the transformation in reference to its own space (Inherited from IManipulationTarget.)
Public property | TransformationInReference | Gets or sets the transformation in reference to its parent (Inherited from IManipulationTarget.)
Public property | TransformationInWorld | Gets or sets the transformation in world (Inherited from IManipulationTarget.)
Top
Methods
 | Name | Description
Public method | ApplyChanges | This is implemented by manipulators that do actual changes on action end or mouse relase. If finalChange==false, then it's only an intermediate change (on mouse release). (Inherited from IManipulationTarget.)
Public method | CollectUndoChanges | Collect all changes since the last call to StoreUndoState(). (Inherited from IManipulationTarget.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EnsureReachable |
Public method | MoveToFrame |
Public method | MoveToItem | Move robot, where "item" can be IPositionFrame or IPositionStatement.
Public method | SetToPositionFrame |
Public method | StoreUndoState | Store information away to be used when creating an undo change set later. (Inherited from IManipulationTarget.)
Top
Events
 | Name | Description
Public event | IsLockedChanged | (Inherited from IManipulationTarget.)
Public event | IsVisibleChanged | (Inherited from IManipulationTarget.)
Public event | ObjectInvalidated | (Inherited from IManipulationTarget.)
Public event | TransformationChanged | (Inherited from IManipulationTarget.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRobotTcpManipulationTarget Properties

The IRobotTcpManipulationTarget type exposes the following members.

Properties
 | Name | Description
Public property | AllowConfigChange |
Public property | AllowJointTurnChange |
Public property | AllowUnreachable | If allowUnreachable and target is not reachable sets the best possible result.
Public property | Controller |
Public property | HandleInObjectCoordinates | Deprecated. Same as TransformationInObject. (Inherited from IManipulationTarget.)
Public property | HandleInReference | Deprecated. Same as TransformationInReference. (Inherited from IManipulationTarget.)
Public property | HandleInWorld | Deprecated. Same as TransformationInWorld. (Inherited from IManipulationTarget.)
Public property | HandleReferenceInWorld | Deprecated. Same as ParentTransformationInWorld. (Inherited from IManipulationTarget.)
Public property | IsHandleFixed | Deprecated. Same as IRobotTcpManipulationTarget.IsTcpExternal. (Inherited from IManipulationTarget.)
Public property | IsLocked | (Inherited from IManipulationTarget.)
Public property | IsTargetEnabled | This is similar to IsLocked, but for manual disabling. (Inherited from IManipulationTarget.)
Public property | IsTcpExternal |
Public property | IsValid | (Inherited from IManipulationTarget.)
Public property | IsVisible | (Inherited from IManipulationTarget.)
Public property | OriginalConfig |
Public property | OriginalJointTurns |
Public property | ParentTransformationInWorld | Position of pivot visual object parent. (Inherited from IManipulationTarget.)
Public property | PivotObject | (Inherited from IManipulationTarget.)
Public property | Robot |
Public property | RobotController |
Public property | TargetObjects | Target objects. May exlude child objects. (Inherited from IManipulationTarget.)
Public property | TransformationInObject | Sets the transformation in reference to its own space (Inherited from IManipulationTarget.)
Public property | TransformationInReference | Gets or sets the transformation in reference to its parent (Inherited from IManipulationTarget.)
Public property | TransformationInWorld | Gets or sets the transformation in world (Inherited from IManipulationTarget.)
Top
See Also

Reference

IRobotTcpManipulationTarget Interface
VisualComponents.Create3D Namespace


IRobotTcpManipulationTarget.AllowConfigChange Property

IRobotTcpManipulationTargetAllowConfigChange Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Nullable<bool> AllowConfigChange { get; set; }
property Nullable<bool> AllowConfigChange {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: NullableBoolean
See Also

Reference

IRobotTcpManipulationTarget Interface
VisualComponents.Create3D Namespace


IRobotTcpManipulationTarget.AllowJointTurnChange Property

IRobotTcpManipulationTargetAllowJointTurnChange Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool AllowJointTurnChange { get; set; }
property bool AllowJointTurnChange {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRobotTcpManipulationTarget Interface
VisualComponents.Create3D Namespace


IRobotTcpManipulationTarget.AllowUnreachable Property

IRobotTcpManipulationTargetAllowUnreachable Property

If allowUnreachable and target is not reachable sets the best possible result.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool AllowUnreachable { get; set; }
property bool AllowUnreachable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRobotTcpManipulationTarget Interface
VisualComponents.Create3D Namespace


IRobotTcpManipulationTarget.Controller Property

IRobotTcpManipulationTargetController Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IServoController Controller { get; }
property IServoController^ Controller {
    IServoController^ get ();
}

Property Value

Type: IServoController
See Also

Reference

IRobotTcpManipulationTarget Interface
VisualComponents.Create3D Namespace


IRobotTcpManipulationTarget.IsTcpExternal Property

IRobotTcpManipulationTargetIsTcpExternal Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsTcpExternal { get; }
property bool IsTcpExternal {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IRobotTcpManipulationTarget Interface
VisualComponents.Create3D Namespace


IRobotTcpManipulationTarget.OriginalConfig Property

IRobotTcpManipulationTargetOriginalConfig Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Nullable<int> OriginalConfig { get; set; }
property Nullable<int> OriginalConfig {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Property Value

Type: NullableInt32
See Also

Reference

IRobotTcpManipulationTarget Interface
VisualComponents.Create3D Namespace


IRobotTcpManipulationTarget.OriginalJointTurns Property

IRobotTcpManipulationTargetOriginalJointTurns Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<int> OriginalJointTurns { get; }
property IList<int>^ OriginalJointTurns {
    IList<int>^ get ();
}

Property Value

Type: IListInt32
See Also

Reference

IRobotTcpManipulationTarget Interface
VisualComponents.Create3D Namespace


IRobotTcpManipulationTarget.Robot Property

IRobotTcpManipulationTargetRobot Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobot Robot { get; }
property IRobot^ Robot {
    IRobot^ get ();
}

Property Value

Type: IRobot
See Also

Reference

IRobotTcpManipulationTarget Interface
VisualComponents.Create3D Namespace


IRobotTcpManipulationTarget.RobotController Property

IRobotTcpManipulationTargetRobotController Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotController RobotController { get; }
property IRobotController^ RobotController {
    IRobotController^ get ();
}

Property Value

Type: IRobotController
See Also

Reference

IRobotTcpManipulationTarget Interface
VisualComponents.Create3D Namespace


IRobotTcpManipulationTarget Methods

The IRobotTcpManipulationTarget type exposes the following members.

Methods
 | Name | Description
Public method | ApplyChanges | This is implemented by manipulators that do actual changes on action end or mouse relase. If finalChange==false, then it's only an intermediate change (on mouse release). (Inherited from IManipulationTarget.)
Public method | CollectUndoChanges | Collect all changes since the last call to StoreUndoState(). (Inherited from IManipulationTarget.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EnsureReachable |
Public method | MoveToFrame |
Public method | MoveToItem | Move robot, where "item" can be IPositionFrame or IPositionStatement.
Public method | SetToPositionFrame |
Public method | StoreUndoState | Store information away to be used when creating an undo change set later. (Inherited from IManipulationTarget.)
Top
See Also

Reference

IRobotTcpManipulationTarget Interface
VisualComponents.Create3D Namespace


IRobotTcpManipulationTarget.EnsureReachable Method

IRobotTcpManipulationTargetEnsureReachable Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void EnsureReachable()
void EnsureReachable()
See Also

Reference

IRobotTcpManipulationTarget Interface
VisualComponents.Create3D Namespace


IRobotTcpManipulationTarget.MoveToFrame Method

IRobotTcpManipulationTargetMoveToFrame Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void MoveToFrame(
    IPositionFrame frame
)
void MoveToFrame(
    IPositionFrame^ frame
)

Parameters

frame
Type: VisualComponents.Create3DIPositionFrame
See Also

Reference

IRobotTcpManipulationTarget Interface
VisualComponents.Create3D Namespace


IRobotTcpManipulationTarget.MoveToItem Method

IRobotTcpManipulationTargetMoveToItem Method

Move robot, where "item" can be IPositionFrame or IPositionStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void MoveToItem(
    Object item
)
void MoveToItem(
    Object^ item
)

Parameters

item
Type: SystemObject
See Also

Reference

IRobotTcpManipulationTarget Interface
VisualComponents.Create3D Namespace


IRobotTcpManipulationTarget.SetToPositionFrame Method

IRobotTcpManipulationTargetSetToPositionFrame Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetToPositionFrame(
    IPositionFrame frame
)
void SetToPositionFrame(
    IPositionFrame^ frame
)

Parameters

frame
Type: VisualComponents.Create3DIPositionFrame
See Also

Reference

IRobotTcpManipulationTarget Interface
VisualComponents.Create3D Namespace


IRobotTcpManipulationTarget Events

The IRobotTcpManipulationTarget type exposes the following members.

Events
 | Name | Description
Public event | IsLockedChanged | (Inherited from IManipulationTarget.)
Public event | IsVisibleChanged | (Inherited from IManipulationTarget.)
Public event | ObjectInvalidated | (Inherited from IManipulationTarget.)
Public event | TransformationChanged | (Inherited from IManipulationTarget.)
Top
See Also

Reference

IRobotTcpManipulationTarget Interface
VisualComponents.Create3D Namespace


IRobotTcpSettings Interface

Robot TCP manipulation settings interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRobotTcpSettings
public interface class IRobotTcpSettings

The IRobotTcpSettings type exposes the following members.

Properties
 | Name | Description
Public property | IsConfigurationChangeAllowed | Whether to allow the configuration to change.
Public property | IsJointTurnChangeAllowed | Whether to allow the joint turn number to change.
Public property | IsOutsideJointLimitsAllowed | Whether to allow a TCP that exceeds joint limits.
Public property | IsUnreachableAllowed | Whether to allow the TCP to be set to an unreachable point.
Public property | OriginalConfiguration | Original configuration index.
Public property | OriginalJointTurns | Original joint turn numbers.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRobotTcpSettings Properties

The IRobotTcpSettings type exposes the following members.

Properties
 | Name | Description
Public property | IsConfigurationChangeAllowed | Whether to allow the configuration to change.
Public property | IsJointTurnChangeAllowed | Whether to allow the joint turn number to change.
Public property | IsOutsideJointLimitsAllowed | Whether to allow a TCP that exceeds joint limits.
Public property | IsUnreachableAllowed | Whether to allow the TCP to be set to an unreachable point.
Public property | OriginalConfiguration | Original configuration index.
Public property | OriginalJointTurns | Original joint turn numbers.
Top
See Also

Reference

IRobotTcpSettings Interface
VisualComponents.Create3D Namespace


IRobotTcpSettings.IsConfigurationChangeAllowed Property

IRobotTcpSettingsIsConfigurationChangeAllowed Property

Whether to allow the configuration to change.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Nullable<bool> IsConfigurationChangeAllowed { get; }
property Nullable<bool> IsConfigurationChangeAllowed {
    Nullable<bool> get ();
}

Property Value

Type: NullableBoolean
Remarks
If this is null, the value is determined from the robot configuration mode.
See Also

Reference

IRobotTcpSettings Interface
VisualComponents.Create3D Namespace


IRobotTcpSettings.IsJointTurnChangeAllowed Property

IRobotTcpSettingsIsJointTurnChangeAllowed Property

Whether to allow the joint turn number to change.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsJointTurnChangeAllowed { get; }
property bool IsJointTurnChangeAllowed {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IRobotTcpSettings Interface
VisualComponents.Create3D Namespace


IRobotTcpSettings.IsOutsideJointLimitsAllowed Property

IRobotTcpSettingsIsOutsideJointLimitsAllowed Property

Whether to allow a TCP that exceeds joint limits.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsOutsideJointLimitsAllowed { get; }
property bool IsOutsideJointLimitsAllowed {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IRobotTcpSettings Interface
VisualComponents.Create3D Namespace


IRobotTcpSettings.IsUnreachableAllowed Property

IRobotTcpSettingsIsUnreachableAllowed Property

Whether to allow the TCP to be set to an unreachable point.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsUnreachableAllowed { get; }
property bool IsUnreachableAllowed {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IRobotTcpSettings Interface
VisualComponents.Create3D Namespace


IRobotTcpSettings.OriginalConfiguration Property

IRobotTcpSettingsOriginalConfiguration Property

Original configuration index.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Nullable<int> OriginalConfiguration { get; }
property Nullable<int> OriginalConfiguration {
    Nullable<int> get ();
}

Property Value

Type: NullableInt32
Remarks
This configuration is preferred as long as it is reachable and within joint limits. If this is null, the robot current configuration is used.
See Also

Reference

IRobotTcpSettings Interface
VisualComponents.Create3D Namespace


IRobotTcpSettings.OriginalJointTurns Property

IRobotTcpSettingsOriginalJointTurns Property

Original joint turn numbers.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<int> OriginalJointTurns { get; }
property IList<int>^ OriginalJointTurns {
    IList<int>^ get ();
}

Property Value

Type: IListInt32
See Also

Reference

IRobotTcpSettings Interface
VisualComponents.Create3D Namespace


IRobotTraceDataService Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRobotTraceDataService : IDisposable
public interface class IRobotTraceDataService : IDisposable

The IRobotTraceDataService type exposes the following members.

Properties
 | Name | Description
Public property | CsvFileLocation | Get or set the data storage csv location
Public property | CurrentTraceData | Get the newest trace data check after RecordAppended, check the traceConfig.xml for requested data
Public property | Robot | Get or Set the robot component selected for Trace data.
Public property | SaveToBinary | Get or set if the collected data should be saved with the layout as a binary file of type ILayoutPropertyList
Public property | SaveToCsv | Get or set if the collected data should be exported to csv
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Top
Events
 | Name | Description
Public event | RecordAppended | Occurs when a record (row) has been appended to a schema.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRobotTraceDataService Properties

The IRobotTraceDataService type exposes the following members.

Properties
 | Name | Description
Public property | CsvFileLocation | Get or set the data storage csv location
Public property | CurrentTraceData | Get the newest trace data check after RecordAppended, check the traceConfig.xml for requested data
Public property | Robot | Get or Set the robot component selected for Trace data.
Public property | SaveToBinary | Get or set if the collected data should be saved with the layout as a binary file of type ILayoutPropertyList
Public property | SaveToCsv | Get or set if the collected data should be exported to csv
Top
See Also

Reference

IRobotTraceDataService Interface
VisualComponents.Create3D Namespace


IRobotTraceDataService.CsvFileLocation Property

IRobotTraceDataServiceCsvFileLocation Property

Get or set the data storage csv location

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string CsvFileLocation { get; set; }
property String^ CsvFileLocation {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IRobotTraceDataService Interface
VisualComponents.Create3D Namespace


IRobotTraceDataService.CurrentTraceData Property

IRobotTraceDataServiceCurrentTraceData Property

Get the newest trace data check after RecordAppended, check the traceConfig.xml for requested data

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
CurrentTraceData CurrentTraceData { get; }
property CurrentTraceData CurrentTraceData {
    CurrentTraceData get ();
}

Property Value

Type: CurrentTraceData
See Also

Reference

IRobotTraceDataService Interface
VisualComponents.Create3D Namespace


IRobotTraceDataService.Robot Property

IRobotTraceDataServiceRobot Property

Get or Set the robot component selected for Trace data.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent Robot { get; set; }
property ISimComponent^ Robot {
    ISimComponent^ get ();
    void set (ISimComponent^ value);
}

Property Value

Type: ISimComponent
See Also

Reference

IRobotTraceDataService Interface
VisualComponents.Create3D Namespace


IRobotTraceDataService.SaveToBinary Property

IRobotTraceDataServiceSaveToBinary Property

Get or set if the collected data should be saved with the layout as a binary file of type ILayoutPropertyList

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SaveToBinary { get; set; }
property bool SaveToBinary {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRobotTraceDataService Interface
VisualComponents.Create3D Namespace


IRobotTraceDataService.SaveToCsv Property

IRobotTraceDataServiceSaveToCsv Property

Get or set if the collected data should be exported to csv

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SaveToCsv { get; set; }
property bool SaveToCsv {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRobotTraceDataService Interface
VisualComponents.Create3D Namespace


IRobotTraceDataService Methods

The IRobotTraceDataService type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Top
See Also

Reference

IRobotTraceDataService Interface
VisualComponents.Create3D Namespace


IRobotTraceDataService Events

The IRobotTraceDataService type exposes the following members.

Events
 | Name | Description
Public event | RecordAppended | Occurs when a record (row) has been appended to a schema.
Top
See Also

Reference

IRobotTraceDataService Interface
VisualComponents.Create3D Namespace


IRobotTraceDataService.RecordAppended Event

IRobotTraceDataServiceRecordAppended Event

Occurs when a record (row) has been appended to a schema.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<SchemaRecordChangedEventArgs> RecordAppended
 event EventHandler<SchemaRecordChangedEventArgs^>^ RecordAppended {
    void add (EventHandler<SchemaRecordChangedEventArgs^>^ value);
    void remove (EventHandler<SchemaRecordChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerSchemaRecordChangedEventArgs
Remarks
Append is defined by the inserted records being located at the end of a schema, allowing the freedom not to consider following records (rows), if the data is sequential in nature (e.g. a sequence of positions). Hence, to comply with this notion, the first record inserted to an empty schema is considered as being "appended".
See Also

Reference

IRobotTraceDataService Interface
VisualComponents.Create3D Namespace


IRouteBooleanTableStatement Interface

Uses component boolean variable value to define where routing is done It is compused by one or multiple IRouteTableLineStatement statements

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRouteBooleanTableStatement : IRouteTableStatement,
    IRouteRuleStatement, IStatement, INamed, IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, IApiType, ICloneable<IStatement>,
    ICloneable, IStatementScope, IInterpolatable
public interface class IRouteBooleanTableStatement : IRouteTableStatement,
    IRouteRuleStatement, IStatement, INamed, IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, IApiType, ICloneable<IStatement^>,
    ICloneable, IStatementScope, IInterpolatable

The IRouteBooleanTableStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRouteBooleanTableStatement Properties

The IRouteBooleanTableStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRouteBooleanTableStatement Interface
VisualComponents.Create3D Namespace


IRouteBooleanTableStatement Methods

The IRouteBooleanTableStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRouteBooleanTableStatement Interface
VisualComponents.Create3D Namespace


IRouteBooleanTableStatement Events

The IRouteBooleanTableStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRouteBooleanTableStatement Interface
VisualComponents.Create3D Namespace


IRouteCapacityStatement Interface

Routing is done to the first connection where is capacity for the connected component

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRouteCapacityStatement : IRouteRuleStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement>, ICloneable,
    IStatementScope, IInterpolatable
public interface class IRouteCapacityStatement : IRouteRuleStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement^>, ICloneable,
    IStatementScope, IInterpolatable

The IRouteCapacityStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRouteCapacityStatement Properties

The IRouteCapacityStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRouteCapacityStatement Interface
VisualComponents.Create3D Namespace


IRouteCapacityStatement Methods

The IRouteCapacityStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRouteCapacityStatement Interface
VisualComponents.Create3D Namespace


IRouteCapacityStatement Events

The IRouteCapacityStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRouteCapacityStatement Interface
VisualComponents.Create3D Namespace


IRouteCyclicStatement Interface

Routing is cycled between user defined connections

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRouteCyclicStatement : IRouteRuleStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement>, ICloneable,
    IStatementScope, IInterpolatable
public interface class IRouteCyclicStatement : IRouteRuleStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement^>, ICloneable,
    IStatementScope, IInterpolatable

The IRouteCyclicStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRouteCyclicStatement Properties

The IRouteCyclicStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRouteCyclicStatement Interface
VisualComponents.Create3D Namespace


IRouteCyclicStatement Methods

The IRouteCyclicStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRouteCyclicStatement Interface
VisualComponents.Create3D Namespace


IRouteCyclicStatement Events

The IRouteCyclicStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRouteCyclicStatement Interface
VisualComponents.Create3D Namespace


IRouteFixedLineStatement Interface

Defines a fixed rule for a IRouteFixedStatement statements

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRouteFixedLineStatement : IRouteRuleLineStatement,
    IRouteRuleStatement, IStatement, INamed, IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, IApiType, ICloneable<IStatement>,
    ICloneable, IStatementScope, IInterpolatable
public interface class IRouteFixedLineStatement : IRouteRuleLineStatement,
    IRouteRuleStatement, IStatement, INamed, IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, IApiType, ICloneable<IStatement^>,
    ICloneable, IStatementScope, IInterpolatable

The IRouteFixedLineStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | From | input
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Target | Connector target index (Inherited from IRouteRuleLineStatement.)
Public property | UseTarget | Specifies if uses connector target (Inherited from IRouteRuleLineStatement.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRouteFixedLineStatement Properties

The IRouteFixedLineStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | From | input
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Target | Connector target index (Inherited from IRouteRuleLineStatement.)
Public property | UseTarget | Specifies if uses connector target (Inherited from IRouteRuleLineStatement.)
Top
See Also

Reference

IRouteFixedLineStatement Interface
VisualComponents.Create3D Namespace


IRouteFixedLineStatement.From Property

IRouteFixedLineStatementFrom Property

input

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int From { get; set; }
property int From {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IRouteFixedLineStatement Interface
VisualComponents.Create3D Namespace


IRouteFixedLineStatement Methods

The IRouteFixedLineStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRouteFixedLineStatement Interface
VisualComponents.Create3D Namespace


IRouteFixedLineStatement Events

The IRouteFixedLineStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRouteFixedLineStatement Interface
VisualComponents.Create3D Namespace


IRouteFixedStatement Interface

Routing in each input can have a equivalent output where a component is routed. It is compused by one or multiple IRouteFixedLineStatement statements

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRouteFixedStatement : IRouteRuleStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement>, ICloneable,
    IStatementScope, IInterpolatable
public interface class IRouteFixedStatement : IRouteRuleStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement^>, ICloneable,
    IStatementScope, IInterpolatable

The IRouteFixedStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRouteFixedStatement Properties

The IRouteFixedStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRouteFixedStatement Interface
VisualComponents.Create3D Namespace


IRouteFixedStatement Methods

The IRouteFixedStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRouteFixedStatement Interface
VisualComponents.Create3D Namespace


IRouteFixedStatement Events

The IRouteFixedStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRouteFixedStatement Interface
VisualComponents.Create3D Namespace


IRouteIntegerTableStatement Interface

Uses component integer variable value to define where routing is done It is compused by one or multiple IRouteTableLineStatement statements

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRouteIntegerTableStatement : IRouteTableStatement,
    IRouteRuleStatement, IStatement, INamed, IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, IApiType, ICloneable<IStatement>,
    ICloneable, IStatementScope, IInterpolatable
public interface class IRouteIntegerTableStatement : IRouteTableStatement,
    IRouteRuleStatement, IStatement, INamed, IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, IApiType, ICloneable<IStatement^>,
    ICloneable, IStatementScope, IInterpolatable

The IRouteIntegerTableStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRouteIntegerTableStatement Properties

The IRouteIntegerTableStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRouteIntegerTableStatement Interface
VisualComponents.Create3D Namespace


IRouteIntegerTableStatement Methods

The IRouteIntegerTableStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRouteIntegerTableStatement Interface
VisualComponents.Create3D Namespace


IRouteIntegerTableStatement Events

The IRouteIntegerTableStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRouteIntegerTableStatement Interface
VisualComponents.Create3D Namespace


IRoutePercentageLineStatement Interface

Defines a percentage rule for a IRoutePercentageStatement statements

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRoutePercentageLineStatement : IRouteRuleLineStatement,
    IRouteRuleStatement, IStatement, INamed, IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, IApiType, ICloneable<IStatement>,
    ICloneable, IStatementScope, IInterpolatable
public interface class IRoutePercentageLineStatement : IRouteRuleLineStatement,
    IRouteRuleStatement, IStatement, INamed, IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, IApiType, ICloneable<IStatement^>,
    ICloneable, IStatementScope, IInterpolatable

The IRoutePercentageLineStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Percentage | Percentage to evaluate
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Target | Connector target index (Inherited from IRouteRuleLineStatement.)
Public property | UseTarget | Specifies if uses connector target (Inherited from IRouteRuleLineStatement.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRoutePercentageLineStatement Properties

The IRoutePercentageLineStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Percentage | Percentage to evaluate
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Target | Connector target index (Inherited from IRouteRuleLineStatement.)
Public property | UseTarget | Specifies if uses connector target (Inherited from IRouteRuleLineStatement.)
Top
See Also

Reference

IRoutePercentageLineStatement Interface
VisualComponents.Create3D Namespace


IRoutePercentageLineStatement.Percentage Property

IRoutePercentageLineStatementPercentage Property

Percentage to evaluate

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Percentage { get; set; }
property double Percentage {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IRoutePercentageLineStatement Interface
VisualComponents.Create3D Namespace


IRoutePercentageLineStatement Methods

The IRoutePercentageLineStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRoutePercentageLineStatement Interface
VisualComponents.Create3D Namespace


IRoutePercentageLineStatement Events

The IRoutePercentageLineStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRoutePercentageLineStatement Interface
VisualComponents.Create3D Namespace


IRoutePercentageStatement Interface

routing is done dividing material flow between connections using connection specific percentage It is compused by one or multiple IRoutePercentageLineStatement statements

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRoutePercentageStatement : IRouteRuleStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement>, ICloneable,
    IStatementScope, IInterpolatable
public interface class IRoutePercentageStatement : IRouteRuleStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement^>, ICloneable,
    IStatementScope, IInterpolatable

The IRoutePercentageStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRoutePercentageStatement Properties

The IRoutePercentageStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRoutePercentageStatement Interface
VisualComponents.Create3D Namespace


IRoutePercentageStatement Methods

The IRoutePercentageStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRoutePercentageStatement Interface
VisualComponents.Create3D Namespace


IRoutePercentageStatement Events

The IRoutePercentageStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRoutePercentageStatement Interface
VisualComponents.Create3D Namespace


IRouteRealTableStatement Interface

Uses component real variable value to define where routing is done It is compused by one or multiple IRouteTableLineStatement statements

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRouteRealTableStatement : IRouteTableStatement,
    IRouteRuleStatement, IStatement, INamed, IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, IApiType, ICloneable<IStatement>,
    ICloneable, IStatementScope, IInterpolatable
public interface class IRouteRealTableStatement : IRouteTableStatement,
    IRouteRuleStatement, IStatement, INamed, IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, IApiType, ICloneable<IStatement^>,
    ICloneable, IStatementScope, IInterpolatable

The IRouteRealTableStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRouteRealTableStatement Properties

The IRouteRealTableStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRouteRealTableStatement Interface
VisualComponents.Create3D Namespace


IRouteRealTableStatement Methods

The IRouteRealTableStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRouteRealTableStatement Interface
VisualComponents.Create3D Namespace


IRouteRealTableStatement Events

The IRouteRealTableStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRouteRealTableStatement Interface
VisualComponents.Create3D Namespace


IRouteRuleLineStatement Interface

Base interface for all line statements

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRouteRuleLineStatement : IRouteRuleStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement>, ICloneable,
    IStatementScope, IInterpolatable
public interface class IRouteRuleLineStatement : IRouteRuleStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement^>, ICloneable,
    IStatementScope, IInterpolatable

The IRouteRuleLineStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Target | Connector target index
Public property | UseTarget | Specifies if uses connector target
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRouteRuleLineStatement Properties

The IRouteRuleLineStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Target | Connector target index
Public property | UseTarget | Specifies if uses connector target
Top
See Also

Reference

IRouteRuleLineStatement Interface
VisualComponents.Create3D Namespace


IRouteRuleLineStatement.Target Property

IRouteRuleLineStatementTarget Property

Connector target index

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int Target { get; set; }
property int Target {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IRouteRuleLineStatement Interface
VisualComponents.Create3D Namespace


IRouteRuleLineStatement.UseTarget Property

IRouteRuleLineStatementUseTarget Property

Specifies if uses connector target

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool UseTarget { get; }
property bool UseTarget {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IRouteRuleLineStatement Interface
VisualComponents.Create3D Namespace


IRouteRuleLineStatement Methods

The IRouteRuleLineStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRouteRuleLineStatement Interface
VisualComponents.Create3D Namespace


IRouteRuleLineStatement Events

The IRouteRuleLineStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRouteRuleLineStatement Interface
VisualComponents.Create3D Namespace


IRouteRuleStatement Interface

Routing Rule can be used to divide and merge a material flow by connecting it into existing paths or to moving containers. Routing Rule makes routing decision either using a fixed value or by applying rules. Some rules support hierarchical decisions.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRouteRuleStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable, IStatementScope,
    IInterpolatable
public interface class IRouteRuleStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable, IStatementScope,
    IInterpolatable

The IRouteRuleStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRouteRuleStatement Properties

The IRouteRuleStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRouteRuleStatement Interface
VisualComponents.Create3D Namespace


IRouteRuleStatement Methods

The IRouteRuleStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRouteRuleStatement Interface
VisualComponents.Create3D Namespace


IRouteRuleStatement Events

The IRouteRuleStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRouteRuleStatement Interface
VisualComponents.Create3D Namespace


IRouteStringTableStatement Interface

Uses component string variable value to define where routing is done It is compused by one or multiple IRouteTableLineStatement statements

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRouteStringTableStatement : IRouteTableStatement,
    IRouteRuleStatement, IStatement, INamed, IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, IApiType, ICloneable<IStatement>,
    ICloneable, IStatementScope, IInterpolatable
public interface class IRouteStringTableStatement : IRouteTableStatement,
    IRouteRuleStatement, IStatement, INamed, IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, IApiType, ICloneable<IStatement^>,
    ICloneable, IStatementScope, IInterpolatable

The IRouteStringTableStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRouteStringTableStatement Properties

The IRouteStringTableStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRouteStringTableStatement Interface
VisualComponents.Create3D Namespace


IRouteStringTableStatement Methods

The IRouteStringTableStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRouteStringTableStatement Interface
VisualComponents.Create3D Namespace


IRouteStringTableStatement Events

The IRouteStringTableStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRouteStringTableStatement Interface
VisualComponents.Create3D Namespace


IRouteTableLineStatement Interface

Defines a fixed rule for a IRouteTableStatement statements

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRouteTableLineStatement : IRouteRuleLineStatement,
    IRouteRuleStatement, IStatement, INamed, IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, IApiType, ICloneable<IStatement>,
    ICloneable, IStatementScope, IInterpolatable
public interface class IRouteTableLineStatement : IRouteRuleLineStatement,
    IRouteRuleStatement, IStatement, INamed, IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, IApiType, ICloneable<IStatement^>,
    ICloneable, IStatementScope, IInterpolatable

The IRouteTableLineStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsDefault | In case of not having the specified property, setting this to True will route this way.
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Target | Connector target index (Inherited from IRouteRuleLineStatement.)
Public property | UseTarget | Specifies if uses connector target (Inherited from IRouteRuleLineStatement.)
Public property | Value | Value to check
Public property | ValueType | Value type (boolean, integer, real or string)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRouteTableLineStatement Properties

The IRouteTableLineStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsDefault | In case of not having the specified property, setting this to True will route this way.
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Target | Connector target index (Inherited from IRouteRuleLineStatement.)
Public property | UseTarget | Specifies if uses connector target (Inherited from IRouteRuleLineStatement.)
Public property | Value | Value to check
Public property | ValueType | Value type (boolean, integer, real or string)
Top
See Also

Reference

IRouteTableLineStatement Interface
VisualComponents.Create3D Namespace


IRouteTableLineStatement.IsDefault Property

IRouteTableLineStatementIsDefault Property

In case of not having the specified property, setting this to True will route this way.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsDefault { get; set; }
property bool IsDefault {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRouteTableLineStatement Interface
VisualComponents.Create3D Namespace


IRouteTableLineStatement.Value Property

IRouteTableLineStatementValue Property

Value to check

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object Value { get; set; }
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

IRouteTableLineStatement Interface
VisualComponents.Create3D Namespace


IRouteTableLineStatement.ValueType Property

IRouteTableLineStatementValueType Property

Value type (boolean, integer, real or string)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Type ValueType { get; }
property Type^ ValueType {
    Type^ get ();
}

Property Value

Type: Type
See Also

Reference

IRouteTableLineStatement Interface
VisualComponents.Create3D Namespace


IRouteTableLineStatement Methods

The IRouteTableLineStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRouteTableLineStatement Interface
VisualComponents.Create3D Namespace


IRouteTableLineStatement Events

The IRouteTableLineStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRouteTableLineStatement Interface
VisualComponents.Create3D Namespace


IRouteTableStatement Interface

Base interface for all rule table statements

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRouteTableStatement : IRouteRuleStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement>, ICloneable,
    IStatementScope, IInterpolatable
public interface class IRouteTableStatement : IRouteRuleStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement^>, ICloneable,
    IStatementScope, IInterpolatable

The IRouteTableStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRouteTableStatement Properties

The IRouteTableStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRouteTableStatement Interface
VisualComponents.Create3D Namespace


IRouteTableStatement Methods

The IRouteTableStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRouteTableStatement Interface
VisualComponents.Create3D Namespace


IRouteTableStatement Events

The IRouteTableStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRouteTableStatement Interface
VisualComponents.Create3D Namespace


IRouteTransportSolutionLineStatement Interface

Defines a single rule for a IRouteTransportSolutionStatement routing rule statement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRouteTransportSolutionLineStatement : IRouteRuleLineStatement,
    IRouteRuleStatement, IStatement, INamed, IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, IApiType, ICloneable<IStatement>,
    ICloneable, IStatementScope, IInterpolatable
public interface class IRouteTransportSolutionLineStatement : IRouteRuleLineStatement,
    IRouteRuleStatement, IStatement, INamed, IPropertyContainer, IBatchModeObject,
    IWrapper, IDisposable, IApiType, ICloneable<IStatement^>,
    ICloneable, IStatementScope, IInterpolatable

The IRouteTransportSolutionLineStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsDefault | Defines if this is the default statement in the IRouteTransportSolutionStatement.
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Target | Connector target index (Inherited from IRouteRuleLineStatement.)
Public property | TransportNode | The selected ITransportNode.
Public property | TransportNodeProperty | The IProperty that holds the value of the selected ITransportNode.
Public property | UseTarget | Specifies if uses connector target (Inherited from IRouteRuleLineStatement.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRouteTransportSolutionLineStatement Properties

The IRouteTransportSolutionLineStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsDefault | Defines if this is the default statement in the IRouteTransportSolutionStatement.
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Target | Connector target index (Inherited from IRouteRuleLineStatement.)
Public property | TransportNode | The selected ITransportNode.
Public property | TransportNodeProperty | The IProperty that holds the value of the selected ITransportNode.
Public property | UseTarget | Specifies if uses connector target (Inherited from IRouteRuleLineStatement.)
Top
See Also

Reference

IRouteTransportSolutionLineStatement Interface
VisualComponents.Create3D Namespace


IRouteTransportSolutionLineStatement.IsDefault Property

IRouteTransportSolutionLineStatementIsDefault Property

Defines if this is the default statement in the IRouteTransportSolutionStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsDefault { get; set; }
property bool IsDefault {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRouteTransportSolutionLineStatement Interface
VisualComponents.Create3D Namespace


IRouteTransportSolutionLineStatement.TransportNode Property

IRouteTransportSolutionLineStatementTransportNode Property

The selected ITransportNode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ITransportNode TransportNode { get; set; }
property ITransportNode^ TransportNode {
    ITransportNode^ get ();
    void set (ITransportNode^ value);
}

Property Value

Type: ITransportNode
See Also

Reference

IRouteTransportSolutionLineStatement Interface
VisualComponents.Create3D Namespace


IRouteTransportSolutionLineStatement.TransportNodeProperty Property

IRouteTransportSolutionLineStatementTransportNodeProperty Property

The IProperty that holds the value of the selected ITransportNode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProperty TransportNodeProperty { get; }
property IProperty^ TransportNodeProperty {
    IProperty^ get ();
}

Property Value

Type: IProperty
See Also

Reference

IRouteTransportSolutionLineStatement Interface
VisualComponents.Create3D Namespace


IRouteTransportSolutionLineStatement Methods

The IRouteTransportSolutionLineStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRouteTransportSolutionLineStatement Interface
VisualComponents.Create3D Namespace


IRouteTransportSolutionLineStatement Events

The IRouteTransportSolutionLineStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRouteTransportSolutionLineStatement Interface
VisualComponents.Create3D Namespace


IRouteTransportSolutionStatement Interface

A routing rule, where the routing is based on the transport solution of the ISimProduct object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRouteTransportSolutionStatement : IRouteRuleStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement>, ICloneable,
    IStatementScope, IInterpolatable
public interface class IRouteTransportSolutionStatement : IRouteRuleStatement,
    IStatement, INamed, IPropertyContainer, IBatchModeObject, IWrapper,
    IDisposable, IApiType, ICloneable<IStatement^>, ICloneable,
    IStatementScope, IInterpolatable

The IRouteTransportSolutionStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | RuleType | Determines what ITransportNode from the transport solution will be used in the comparison of the child IRouteTransportSolutionLineStatements.
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRouteTransportSolutionStatement Properties

The IRouteTransportSolutionStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | RuleType | Determines what ITransportNode from the transport solution will be used in the comparison of the child IRouteTransportSolutionLineStatements.
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRouteTransportSolutionStatement Interface
VisualComponents.Create3D Namespace


IRouteTransportSolutionStatement.RuleType Property

IRouteTransportSolutionStatementRuleType Property

Determines what ITransportNode from the transport solution will be used in the comparison of the child IRouteTransportSolutionLineStatements.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
RouteTransportSolutionStatementRuleType RuleType { get; set; }
property RouteTransportSolutionStatementRuleType RuleType {
    RouteTransportSolutionStatementRuleType get ();
    void set (RouteTransportSolutionStatementRuleType value);
}

Property Value

Type: RouteTransportSolutionStatementRuleType
See Also

Reference

IRouteTransportSolutionStatement Interface
VisualComponents.Create3D Namespace


IRouteTransportSolutionStatement Methods

The IRouteTransportSolutionStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRouteTransportSolutionStatement Interface
VisualComponents.Create3D Namespace


IRouteTransportSolutionStatement Events

The IRouteTransportSolutionStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRouteTransportSolutionStatement Interface
VisualComponents.Create3D Namespace


IRoutine Interface

Interface for program routines. These routines are contained and managed by an instance of IProgram.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRoutine : IPropertyContainer,
    IBatchModeObject, IStatementScope, IInterpolatable, IApiType, INamed,
    ICloneable<IRoutine>, ICloneable, IWrapper, IDisposable
public interface class IRoutine : IPropertyContainer,
    IBatchModeObject, IStatementScope, IInterpolatable, IApiType, INamed,
    ICloneable<IRoutine^>, ICloneable, IWrapper, IDisposable

The IRoutine type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsPersistent | Gets or sets the persistency flag for this routine.
Public property | IsSystem | Defines if the routine is managed by the application. System routines cannot be deleted or created by the user.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Program | Gets the owner program.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRoutine Properties

The IRoutine type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsPersistent | Gets or sets the persistency flag for this routine.
Public property | IsSystem | Defines if the routine is managed by the application. System routines cannot be deleted or created by the user.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Program | Gets the owner program.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRoutine Interface
VisualComponents.Create3D Namespace


IRoutine.IsPersistent Property

IRoutineIsPersistent Property

Gets or sets the persistency flag for this routine.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsPersistent { get; set; }
property bool IsPersistent {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRoutine Interface
VisualComponents.Create3D Namespace


IRoutine.IsSystem Property

IRoutineIsSystem Property

Defines if the routine is managed by the application. System routines cannot be deleted or created by the user.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsSystem { get; }
property bool IsSystem {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IRoutine Interface
VisualComponents.Create3D Namespace


IRoutine.Program Property

IRoutineProgram Property

Gets the owner program.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProgram Program { get; }
property IProgram^ Program {
    IProgram^ get ();
}

Property Value

Type: IProgram
See Also

Reference

IRoutine Interface
VisualComponents.Create3D Namespace


IRoutine Methods

The IRoutine type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRoutine Interface
VisualComponents.Create3D Namespace


IRoutine Events

The IRoutine type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IRoutine Interface
VisualComponents.Create3D Namespace


IRoutingRule Interface

Interface for routing rule behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRoutingRule : ISimContainer,
    IFlowBehavior, IBehavior, IPropertyContainer, IBatchModeObject, IVisitable,
    IWrapper, IDisposable, INamed
public interface class IRoutingRule : ISimContainer,
    IFlowBehavior, IBehavior, IPropertyContainer, IBatchModeObject, IVisitable,
    IWrapper, IDisposable, INamed

The IRoutingRule type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Maximum logical capacity of the container. This determines the maximum number of components that can be contained in the container at any one time. (Inherited from ISimContainer.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Components | list of components currently contained in the container (Inherited from ISimContainer.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | HeadComponent | Returns component in the head of container (Inherited from ISimContainer.)
Public property | IsContentVisible | Defines whether components held by the container are displayed or not (Inherited from ISimContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Proxy | Flow Proxy definition allows for routing capacity test based decisions apart at specified material flow connection point
Public property | Rules | Returns the IRoutine instance containing the rules.
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | TailComponent | Returns component in the tail of container (Inherited from ISimContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | ConvertOldRuleToNewRule | Convert old RSL rules to new rules mechanism
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetContainerProximity | Calculate the orthogonal distance from position to this container (Inherited from ISimContainer.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Grab | Grab the component into this container (Inherited from ISimContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ComponentArriving | Triggered when a component is arriving to the container (Inherited from ISimContainer.)
Public event | ComponentLeaving | Triggered when a component is leaving from the container (Inherited from ISimContainer.)
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRoutingRule Properties

The IRoutingRule type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Maximum logical capacity of the container. This determines the maximum number of components that can be contained in the container at any one time. (Inherited from ISimContainer.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Components | list of components currently contained in the container (Inherited from ISimContainer.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | HeadComponent | Returns component in the head of container (Inherited from ISimContainer.)
Public property | IsContentVisible | Defines whether components held by the container are displayed or not (Inherited from ISimContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Proxy | Flow Proxy definition allows for routing capacity test based decisions apart at specified material flow connection point
Public property | Rules | Returns the IRoutine instance containing the rules.
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | TailComponent | Returns component in the tail of container (Inherited from ISimContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IRoutingRule Interface
VisualComponents.Create3D Namespace


IRoutingRule.Proxy Property

IRoutingRuleProxy Property

Flow Proxy definition allows for routing capacity test based decisions apart at specified material flow connection point

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFlowBehavior Proxy { get; }
property IFlowBehavior^ Proxy {
    IFlowBehavior^ get ();
}

Property Value

Type: IFlowBehavior
See Also

Reference

IRoutingRule Interface
VisualComponents.Create3D Namespace


IRoutingRule.Rules Property

IRoutingRuleRules Property

Returns the IRoutine instance containing the rules.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRoutine Rules { get; }
property IRoutine^ Rules {
    IRoutine^ get ();
}

Property Value

Type: IRoutine
See Also

Reference

IRoutingRule Interface
VisualComponents.Create3D Namespace


IRoutingRule Methods

The IRoutingRule type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | ConvertOldRuleToNewRule | Convert old RSL rules to new rules mechanism
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetContainerProximity | Calculate the orthogonal distance from position to this container (Inherited from ISimContainer.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Grab | Grab the component into this container (Inherited from ISimContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRoutingRule Interface
VisualComponents.Create3D Namespace


IRoutingRule.ConvertOldRuleToNewRule Method

IRoutingRuleConvertOldRuleToNewRule Method

Convert old RSL rules to new rules mechanism

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ConvertOldRuleToNewRule()
void ConvertOldRuleToNewRule()
See Also

Reference

IRoutingRule Interface
VisualComponents.Create3D Namespace


IRoutingRule Events

The IRoutingRule type exposes the following members.

Events
 | Name | Description
Public event | ComponentArriving | Triggered when a component is arriving to the container (Inherited from ISimContainer.)
Public event | ComponentLeaving | Triggered when a component is leaving from the container (Inherited from ISimContainer.)
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IRoutingRule Interface
VisualComponents.Create3D Namespace


IRslExecutor Interface

An interface for RSL Executor behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRslExecutor : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IRslExecutor : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IRslExecutor type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Controller | Gets the associated controller.
Public property | DigitalMapIn | Gets digital input ISignalMap instance associated to this IRslExecutor behavior.
Public property | DigitalMapOut | Gets digital output ISignalMap instance associated to this IRslExecutor behavior.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
Rsl Executor behavior is obsolete and replaced by IRobotExecutor behavior.
See Also

Reference

VisualComponents.Create3D Namespace


IRslExecutor Properties

The IRslExecutor type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Controller | Gets the associated controller.
Public property | DigitalMapIn | Gets digital input ISignalMap instance associated to this IRslExecutor behavior.
Public property | DigitalMapOut | Gets digital output ISignalMap instance associated to this IRslExecutor behavior.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IRslExecutor Interface
VisualComponents.Create3D Namespace


IRslExecutor.Controller Property

IRslExecutorController Property

Gets the associated controller.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IServoController Controller { get; }
property IServoController^ Controller {
    IServoController^ get ();
}

Property Value

Type: IServoController
See Also

Reference

IRslExecutor Interface
VisualComponents.Create3D Namespace


IRslExecutor.DigitalMapIn Property

IRslExecutorDigitalMapIn Property

Gets digital input ISignalMap instance associated to this IRslExecutor behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISignalMap DigitalMapIn { get; }
property ISignalMap^ DigitalMapIn {
    ISignalMap^ get ();
}

Property Value

Type: ISignalMap
See Also

Reference

IRslExecutor Interface
VisualComponents.Create3D Namespace


IRslExecutor.DigitalMapOut Property

IRslExecutorDigitalMapOut Property

Gets digital output ISignalMap instance associated to this IRslExecutor behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISignalMap DigitalMapOut { get; }
property ISignalMap^ DigitalMapOut {
    ISignalMap^ get ();
}

Property Value

Type: ISignalMap
See Also

Reference

IRslExecutor Interface
VisualComponents.Create3D Namespace


IRslExecutor Methods

The IRslExecutor type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRslExecutor Interface
VisualComponents.Create3D Namespace


IRslExecutor Events

The IRslExecutor type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IRslExecutor Interface
VisualComponents.Create3D Namespace


IRunRobotRoutineStatement Interface

A process statement that waits until the selected IRobotExecutor is idle, and then runs the selected IRoutine synchronously.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRunRobotRoutineStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IRunRobotRoutineStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IRunRobotRoutineStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | RobotComponent | The ISimComponent to get the IRobotExecutor from. If the ISimComponent has multiple IRobotExecutors, the first one is selected.
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | RoutineNameProperty | This expression should evaluate to the name of an IRoutine in one of the selected IRobotExecutor's IPrograms. The expression will be evaluated at run-time, and the chosen IRoutine will be started.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IRunRobotRoutineStatement Properties

The IRunRobotRoutineStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | RobotComponent | The ISimComponent to get the IRobotExecutor from. If the ISimComponent has multiple IRobotExecutors, the first one is selected.
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | RoutineNameProperty | This expression should evaluate to the name of an IRoutine in one of the selected IRobotExecutor's IPrograms. The expression will be evaluated at run-time, and the chosen IRoutine will be started.
Top
See Also

Reference

IRunRobotRoutineStatement Interface
VisualComponents.Create3D Namespace


IRunRobotRoutineStatement.RobotComponent Property

IRunRobotRoutineStatementRobotComponent Property

The ISimComponent to get the IRobotExecutor from.

If the ISimComponent has multiple IRobotExecutors, the first one is selected.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent RobotComponent { get; set; }
property ISimComponent^ RobotComponent {
    ISimComponent^ get ();
    void set (ISimComponent^ value);
}

Property Value

Type: ISimComponent
Exceptions
Exception | Condition
ArgumentNullException |
See Also

Reference

IRunRobotRoutineStatement Interface
VisualComponents.Create3D Namespace


IRunRobotRoutineStatement.RoutineNameProperty Property

IRunRobotRoutineStatementRoutineNameProperty Property

This expression should evaluate to the name of an IRoutine in one of the selected IRobotExecutor's IPrograms.

The expression will be evaluated at run-time, and the chosen IRoutine will be started.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IExpressionProperty RoutineNameProperty { get; }
property IExpressionProperty^ RoutineNameProperty {
    IExpressionProperty^ get ();
}

Property Value

Type: IExpressionProperty
See Also

Reference

IRunRobotRoutineStatement Interface
VisualComponents.Create3D Namespace


IRunRobotRoutineStatement Methods

The IRunRobotRoutineStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IRunRobotRoutineStatement Interface
VisualComponents.Create3D Namespace


IRunRobotRoutineStatement Events

The IRunRobotRoutineStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IRunRobotRoutineStatement Interface
VisualComponents.Create3D Namespace


ISamplingTimer Interface

Simulation timer.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISamplingTimer
public interface class ISamplingTimer

The ISamplingTimer type exposes the following members.

Properties
 | Name | Description
Public property | IsStatisticsTimer | Indicates that timer belongs to statistics behaviour, and uses global statistics interval.
Public property | SamplingInterval | Timer interval.
Top
Methods
 | Name | Description
Public method | StartStopTimer | Enables and disables the timer.
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISamplingTimer Properties

The ISamplingTimer type exposes the following members.

Properties
 | Name | Description
Public property | IsStatisticsTimer | Indicates that timer belongs to statistics behaviour, and uses global statistics interval.
Public property | SamplingInterval | Timer interval.
Top
See Also

Reference

ISamplingTimer Interface
VisualComponents.Create3D Namespace


ISamplingTimer.IsStatisticsTimer Property

ISamplingTimerIsStatisticsTimer Property

Indicates that timer belongs to statistics behaviour, and uses global statistics interval.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsStatisticsTimer { get; }
property bool IsStatisticsTimer {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISamplingTimer Interface
VisualComponents.Create3D Namespace


ISamplingTimer.SamplingInterval Property

ISamplingTimerSamplingInterval Property

Timer interval.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double SamplingInterval { get; set; }
property double SamplingInterval {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ISamplingTimer Interface
VisualComponents.Create3D Namespace


ISamplingTimer Methods

The ISamplingTimer type exposes the following members.

Methods
 | Name | Description
Public method | StartStopTimer | Enables and disables the timer.
Top
See Also

Reference

ISamplingTimer Interface
VisualComponents.Create3D Namespace


ISamplingTimer.StartStopTimer Method

ISamplingTimerStartStopTimer Method

Enables and disables the timer.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StartStopTimer(
    bool start
)
void StartStopTimer(
    bool start
)

Parameters

start
Type: SystemBoolean
Target state
See Also

Reference

ISamplingTimer Interface
VisualComponents.Create3D Namespace


IScalarQuantity Interface

Interface representing a type of value that parameter contains.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IScalarQuantity
public interface class IScalarQuantity

The IScalarQuantity type exposes the following members.

Properties
 | Name | Description
Public property | Name | Name of the Quantity
Top
See Also

Reference

VisualComponents.Create3D Namespace


IScalarQuantity Properties

The IScalarQuantity type exposes the following members.

Properties
 | Name | Description
Public property | Name | Name of the Quantity
Top
See Also

Reference

IScalarQuantity Interface
VisualComponents.Create3D Namespace


IScalarQuantity.Name Property

IScalarQuantityName Property

Name of the Quantity

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Name { get; }
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IScalarQuantity Interface
VisualComponents.Create3D Namespace


IScaraKinematics Interface

An interface for scara kinematics behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IScaraKinematics : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IScaraKinematics : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IScaraKinematics type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IScaraKinematics Properties

The IScaraKinematics type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IScaraKinematics Interface
VisualComponents.Create3D Namespace


IScaraKinematics Methods

The IScaraKinematics type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IScaraKinematics Interface
VisualComponents.Create3D Namespace


IScaraKinematics Events

The IScaraKinematics type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IScaraKinematics Interface
VisualComponents.Create3D Namespace


IScaraKinematics2 Interface

An interface for scara kinematics 2 behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IScaraKinematics2 : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IScaraKinematics2 : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IScaraKinematics2 type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConfigName1 | Gets or sets the value of ConfigName1 property.
Public property | ConfigName2 | Gets or sets the value of ConfigName2 property.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | JointSign1 | Gets or sets the value of JointSign1 property.
Public property | JointSign2 | Gets or sets the value of JointSign2 property.
Public property | JointSign3 | Gets or sets the value of JointSign3 property.
Public property | JointSign4 | Gets or sets the value of JointSign4 property.
Public property | JointZeroOffset1 | Gets or sets the value of JointZeroOffset1 property.
Public property | JointZeroOffset2 | Gets or sets the value of JointZeroOffset2 property.
Public property | JointZeroOffset3 | Gets or sets the value of JointZeroOffset3 property.
Public property | JointZeroOffset4 | Gets or sets the value of JointZeroOffset4 property.
Public property | L04Z | Gets or sets the value of L04Z property.
Public property | L12X | Gets or sets the value of L12X property.
Public property | L23X | Gets or sets the value of L23X property.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IScaraKinematics2 Properties

The IScaraKinematics2 type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConfigName1 | Gets or sets the value of ConfigName1 property.
Public property | ConfigName2 | Gets or sets the value of ConfigName2 property.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | JointSign1 | Gets or sets the value of JointSign1 property.
Public property | JointSign2 | Gets or sets the value of JointSign2 property.
Public property | JointSign3 | Gets or sets the value of JointSign3 property.
Public property | JointSign4 | Gets or sets the value of JointSign4 property.
Public property | JointZeroOffset1 | Gets or sets the value of JointZeroOffset1 property.
Public property | JointZeroOffset2 | Gets or sets the value of JointZeroOffset2 property.
Public property | JointZeroOffset3 | Gets or sets the value of JointZeroOffset3 property.
Public property | JointZeroOffset4 | Gets or sets the value of JointZeroOffset4 property.
Public property | L04Z | Gets or sets the value of L04Z property.
Public property | L12X | Gets or sets the value of L12X property.
Public property | L23X | Gets or sets the value of L23X property.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IScaraKinematics2 Interface
VisualComponents.Create3D Namespace


IScaraKinematics2.ConfigName1 Property

IScaraKinematics2ConfigName1 Property

Gets or sets the value of ConfigName1 property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ConfigName1 { get; set; }
property String^ ConfigName1 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IScaraKinematics2 Interface
VisualComponents.Create3D Namespace


IScaraKinematics2.ConfigName2 Property

IScaraKinematics2ConfigName2 Property

Gets or sets the value of ConfigName2 property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ConfigName2 { get; set; }
property String^ ConfigName2 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IScaraKinematics2 Interface
VisualComponents.Create3D Namespace


IScaraKinematics2.JointSign1 Property

IScaraKinematics2JointSign1 Property

Gets or sets the value of JointSign1 property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int JointSign1 { get; set; }
property int JointSign1 {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IScaraKinematics2 Interface
VisualComponents.Create3D Namespace


IScaraKinematics2.JointSign2 Property

IScaraKinematics2JointSign2 Property

Gets or sets the value of JointSign2 property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int JointSign2 { get; set; }
property int JointSign2 {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IScaraKinematics2 Interface
VisualComponents.Create3D Namespace


IScaraKinematics2.JointSign3 Property

IScaraKinematics2JointSign3 Property

Gets or sets the value of JointSign3 property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int JointSign3 { get; set; }
property int JointSign3 {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IScaraKinematics2 Interface
VisualComponents.Create3D Namespace


IScaraKinematics2.JointSign4 Property

IScaraKinematics2JointSign4 Property

Gets or sets the value of JointSign4 property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int JointSign4 { get; set; }
property int JointSign4 {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IScaraKinematics2 Interface
VisualComponents.Create3D Namespace


IScaraKinematics2.JointZeroOffset1 Property

IScaraKinematics2JointZeroOffset1 Property

Gets or sets the value of JointZeroOffset1 property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double JointZeroOffset1 { get; set; }
property double JointZeroOffset1 {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IScaraKinematics2 Interface
VisualComponents.Create3D Namespace


IScaraKinematics2.JointZeroOffset2 Property

IScaraKinematics2JointZeroOffset2 Property

Gets or sets the value of JointZeroOffset2 property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double JointZeroOffset2 { get; set; }
property double JointZeroOffset2 {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IScaraKinematics2 Interface
VisualComponents.Create3D Namespace


IScaraKinematics2.JointZeroOffset3 Property

IScaraKinematics2JointZeroOffset3 Property

Gets or sets the value of JointZeroOffset3 property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double JointZeroOffset3 { get; set; }
property double JointZeroOffset3 {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IScaraKinematics2 Interface
VisualComponents.Create3D Namespace


IScaraKinematics2.JointZeroOffset4 Property

IScaraKinematics2JointZeroOffset4 Property

Gets or sets the value of JointZeroOffset4 property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double JointZeroOffset4 { get; set; }
property double JointZeroOffset4 {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IScaraKinematics2 Interface
VisualComponents.Create3D Namespace


IScaraKinematics2.L04Z Property

IScaraKinematics2L04Z Property

Gets or sets the value of L04Z property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double L04Z { get; set; }
property double L04Z {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IScaraKinematics2 Interface
VisualComponents.Create3D Namespace


IScaraKinematics2.L12X Property

IScaraKinematics2L12X Property

Gets or sets the value of L12X property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double L12X { get; set; }
property double L12X {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IScaraKinematics2 Interface
VisualComponents.Create3D Namespace


IScaraKinematics2.L23X Property

IScaraKinematics2L23X Property

Gets or sets the value of L23X property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double L23X { get; set; }
property double L23X {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IScaraKinematics2 Interface
VisualComponents.Create3D Namespace


IScaraKinematics2 Methods

The IScaraKinematics2 type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IScaraKinematics2 Interface
VisualComponents.Create3D Namespace


IScaraKinematics2 Events

The IScaraKinematics2 type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IScaraKinematics2 Interface
VisualComponents.Create3D Namespace


ISchemaFrame Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISchemaFrame : IVisualObject,
    INamed, IWrapper, IDisposable, IPropertyContainer, IBatchModeObject,
    IPrimitive, ICombinable<ISchemaFrame>, IFrame
public interface class ISchemaFrame : IVisualObject,
    INamed, IWrapper, IDisposable, IPropertyContainer, IBatchModeObject,
    IPrimitive, ICombinable<ISchemaFrame^>, IFrame

The ISchemaFrame type exposes the following members.

Properties
 | Name | Description
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | CombinedCount | How many instances are combined. (Inherited from ICombinableT.)
Public property | CombinedIndexes | Indexes that indicate which instances were combined. (Inherited from ICombinableT.)
Public property | CombinedItems | (Inherited from ICombinableT.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Feature | (Inherited from IFrame.)
Public property | Index | Item's index. (Inherited from ICombinableT.)
Public property | IsCombined | Whether or not this instances encapsulates another instances. (Inherited from ICombinableT.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | LayoutSchemaPropertyList | Gets the instance of ILayoutSchemaPropertyList that owns this ISchemaFrame .
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ObjectPrimitiveType | (Inherited from IPrimitive.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Position | (Inherited from IFrame.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IVisualObject.)
Public property | TransformationInWorld | Gets or sets the world transformation matrix (Inherited from IVisualObject.)
Public property | UseAsGuide | (Inherited from IFrame.)
Public property | VisualizationInfo | Information about the way this frame is rendered. List items contain point size and color values.
Top
Methods
 | Name | Description
Public method | AddTransformationInObject | Helper function that takes into account multiple positions combined in one ISchemaFrame.
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Public Extension Method | ToCollection | (Defined by CombinableItemCollectionExtensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISchemaFrame Properties

The ISchemaFrame type exposes the following members.

Properties
 | Name | Description
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | CombinedCount | How many instances are combined. (Inherited from ICombinableT.)
Public property | CombinedIndexes | Indexes that indicate which instances were combined. (Inherited from ICombinableT.)
Public property | CombinedItems | (Inherited from ICombinableT.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Feature | (Inherited from IFrame.)
Public property | Index | Item's index. (Inherited from ICombinableT.)
Public property | IsCombined | Whether or not this instances encapsulates another instances. (Inherited from ICombinableT.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | LayoutSchemaPropertyList | Gets the instance of ILayoutSchemaPropertyList that owns this ISchemaFrame .
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ObjectPrimitiveType | (Inherited from IPrimitive.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Position | (Inherited from IFrame.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IVisualObject.)
Public property | TransformationInWorld | Gets or sets the world transformation matrix (Inherited from IVisualObject.)
Public property | UseAsGuide | (Inherited from IFrame.)
Public property | VisualizationInfo | Information about the way this frame is rendered. List items contain point size and color values.
Top
See Also

Reference

ISchemaFrame Interface
VisualComponents.Create3D Namespace


ISchemaFrame.LayoutSchemaPropertyList Property

ISchemaFrameLayoutSchemaPropertyList Property

Gets the instance of ILayoutSchemaPropertyList that owns this ISchemaFrame .

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ILayoutSchemaPropertyList LayoutSchemaPropertyList { get; }
property ILayoutSchemaPropertyList^ LayoutSchemaPropertyList {
    ILayoutSchemaPropertyList^ get ();
}

Property Value

Type: ILayoutSchemaPropertyList
See Also

Reference

ISchemaFrame Interface
VisualComponents.Create3D Namespace


ISchemaFrame.VisualizationInfo Property

ISchemaFrameVisualizationInfo Property

Information about the way this frame is rendered. List items contain point size and color values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<int> VisualizationInfo { get; }
property IList<int>^ VisualizationInfo {
    IList<int>^ get ();
}

Property Value

Type: IListInt32
See Also

Reference

ISchemaFrame Interface
VisualComponents.Create3D Namespace


ISchemaFrame Methods

The ISchemaFrame type exposes the following members.

Methods
 | Name | Description
Public method | AddTransformationInObject | Helper function that takes into account multiple positions combined in one ISchemaFrame.
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Public Extension Method | ToCollection | (Defined by CombinableItemCollectionExtensions.)
Top
See Also

Reference

ISchemaFrame Interface
VisualComponents.Create3D Namespace


ISchemaFrame.AddTransformationInObject Method

ISchemaFrameAddTransformationInObject Method

Helper function that takes into account multiple positions combined in one ISchemaFrame.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddTransformationInObject(
    Matrix offset
)
void AddTransformationInObject(
    Matrix offset
)

Parameters

offset
Type: VisualComponents.Create3DMatrix
See Also

Reference

ISchemaFrame Interface
VisualComponents.Create3D Namespace


ISchemaFrame Events

The ISchemaFrame type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

ISchemaFrame Interface
VisualComponents.Create3D Namespace


ISchemaPositionFrame Interface

Position frame belonging to IPathStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISchemaPositionFrame : IPositionFrame,
    IFrame, IPrimitive, IWrapper, IDisposable, INamed,
    IVisualObject, IPropertyContainer, IBatchModeObject, ICombinable<IPositionFrame>
public interface class ISchemaPositionFrame : IPositionFrame,
    IFrame, IPrimitive, IWrapper, IDisposable, INamed,
    IVisualObject, IPropertyContainer, IBatchModeObject, ICombinable<IPositionFrame^>

The ISchemaPositionFrame type exposes the following members.

Properties
 | Name | Description
Public property | Base | Base to which this position is attached to. Note: this can point to a Tool frame if external tcp is used.
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | CombinedCount | How many instances are combined. (Inherited from ICombinableT.)
Public property | CombinedIndexes | Indexes that indicate which instances were combined. (Inherited from ICombinableT.)
Public property | CombinedItems | (Inherited from ICombinableT.)
Public property | CombinedPositionCount | Normally this is 1, except when selecting lots of potisions.
Public property | Configuration | Robot's configuration for JointValues. (Inherited from IPositionFrame.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Controller | Gets the robot controller. (Inherited from IPositionFrame.)
Public property | ExternalJointValues | Gets external joint values.
Public property | Feature | (Inherited from IFrame.)
Public property | Index | Item's index. (Inherited from ICombinableT.)
Public property | InternalJointValues | Gets internal joint values. (Inherited from IPositionFrame.)
Public property | IsCombined | Whether or not this instances encapsulates another instances. (Inherited from ICombinableT.)
Public property | IsHighlighted | Highlights frame in rendering.
Public property | IsLocal | Returns true if this IPositionFrame is a local position stored in IPositionStatement, false if the position is stored in IProgram. (Inherited from IPositionFrame.)
Public property | IsReference | Marks frame as a reference frame, which is later used for path smoothing.
Public property | IsStatusValid | Returns true only if Status == Valid. (Inherited from IPositionFrame.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | JointValues | Gets all joint values.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ObjectPrimitiveType | (Inherited from IPrimitive.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Position | (Inherited from IFrame.)
Public property | Program | Gets the IProgram containing this instance of IPositionFrame. This will return null if the position is owned by the instance of IPositionStatement. (Inherited from IPositionFrame.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | SelectedPositionFramesVisibility | Deprecated flag. Similar to SelectedRobotPositionFramesLayerVisibility, but for a single Base. (Inherited from IPositionFrame.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | Statement | Deprecated. Use Statements. (Inherited from IPositionFrame.)
Public property | Statements | Gets all the IPositionStatements that refer to this IPositionFrame (Inherited from IPositionFrame.)
Public property | Status | State of inverse kinematics calculation.
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IVisualObject.)
Public property | TransformationInWorld | Gets or sets the world transformation matrix (Inherited from IVisualObject.)
Public property | UseAsGuide | (Inherited from IFrame.)
Public property | VisualizationInfo | Information about the way this frame is rendered. List items contain point size and color values.
Top
Methods
 | Name | Description
Public method | AddTransformationInObject | Helper function that takes into account multiple positions combined in one ISchemaPositionFrame.
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ContainsFrame | Checks if a given position is part of this position.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EnsureExternalJoints | Ensure path statement has enough external joints.
Public method | Equals | (Inherited from IWrapper.)
Public method | GetCombinedPositions | Indices of multi-selected positions.
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetSchemaValue(Int32) | Gets property value.
Public method | GetSchemaValue(String) | Gets property value.
Public method | SetExternalJoints | Sets external joint values.
Public method | SetJoints | Sets all joint values.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetSchemaValue(Int32, Object) | Sets property value.
Public method | SetSchemaValue(String, Object) | Sets property value.
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | UpdateStatus | Internal method for updating the status. (Inherited from IPositionFrame.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Public Extension Method | ToCollection | (Defined by CombinableItemCollectionExtensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISchemaPositionFrame Properties

The ISchemaPositionFrame type exposes the following members.

Properties
 | Name | Description
Public property | Base | Base to which this position is attached to. Note: this can point to a Tool frame if external tcp is used.
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | CombinedCount | How many instances are combined. (Inherited from ICombinableT.)
Public property | CombinedIndexes | Indexes that indicate which instances were combined. (Inherited from ICombinableT.)
Public property | CombinedItems | (Inherited from ICombinableT.)
Public property | CombinedPositionCount | Normally this is 1, except when selecting lots of potisions.
Public property | Configuration | Robot's configuration for JointValues. (Inherited from IPositionFrame.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Controller | Gets the robot controller. (Inherited from IPositionFrame.)
Public property | ExternalJointValues | Gets external joint values.
Public property | Feature | (Inherited from IFrame.)
Public property | Index | Item's index. (Inherited from ICombinableT.)
Public property | InternalJointValues | Gets internal joint values. (Inherited from IPositionFrame.)
Public property | IsCombined | Whether or not this instances encapsulates another instances. (Inherited from ICombinableT.)
Public property | IsHighlighted | Highlights frame in rendering.
Public property | IsLocal | Returns true if this IPositionFrame is a local position stored in IPositionStatement, false if the position is stored in IProgram. (Inherited from IPositionFrame.)
Public property | IsReference | Marks frame as a reference frame, which is later used for path smoothing.
Public property | IsStatusValid | Returns true only if Status == Valid. (Inherited from IPositionFrame.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | JointValues | Gets all joint values.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ObjectPrimitiveType | (Inherited from IPrimitive.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Position | (Inherited from IFrame.)
Public property | Program | Gets the IProgram containing this instance of IPositionFrame. This will return null if the position is owned by the instance of IPositionStatement. (Inherited from IPositionFrame.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | SelectedPositionFramesVisibility | Deprecated flag. Similar to SelectedRobotPositionFramesLayerVisibility, but for a single Base. (Inherited from IPositionFrame.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | Statement | Deprecated. Use Statements. (Inherited from IPositionFrame.)
Public property | Statements | Gets all the IPositionStatements that refer to this IPositionFrame (Inherited from IPositionFrame.)
Public property | Status | State of inverse kinematics calculation.
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IVisualObject.)
Public property | TransformationInWorld | Gets or sets the world transformation matrix (Inherited from IVisualObject.)
Public property | UseAsGuide | (Inherited from IFrame.)
Public property | VisualizationInfo | Information about the way this frame is rendered. List items contain point size and color values.
Top
See Also

Reference

ISchemaPositionFrame Interface
VisualComponents.Create3D Namespace


ISchemaPositionFrame.Base Property

ISchemaPositionFrameBase Property

Base to which this position is attached to. Note: this can point to a Tool frame if external tcp is used.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotFrame Base { get; }
property IRobotFrame^ Base {
    IRobotFrame^ get ();
}

Property Value

Type: IRobotFrame

Implements

IPositionFrameBase
See Also

Reference

ISchemaPositionFrame Interface
VisualComponents.Create3D Namespace


ISchemaPositionFrame.CombinedPositionCount Property

ISchemaPositionFrameCombinedPositionCount Property

Normally this is 1, except when selecting lots of potisions.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int CombinedPositionCount { get; }
property int CombinedPositionCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ISchemaPositionFrame Interface
VisualComponents.Create3D Namespace


ISchemaPositionFrame.ExternalJointValues Property

ISchemaPositionFrameExternalJointValues Property

Gets external joint values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<double> ExternalJointValues { get; }
property ReadOnlyCollection<double>^ ExternalJointValues {
    ReadOnlyCollection<double>^ get ();
}

Property Value

Type: ReadOnlyCollectionDouble

Implements

IPositionFrameExternalJointValues
See Also

Reference

ISchemaPositionFrame Interface
VisualComponents.Create3D Namespace


ISchemaPositionFrame.IsHighlighted Property

ISchemaPositionFrameIsHighlighted Property

Highlights frame in rendering.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsHighlighted { get; set; }
property bool IsHighlighted {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IVisualObjectIsHighlighted
See Also

Reference

ISchemaPositionFrame Interface
VisualComponents.Create3D Namespace


ISchemaPositionFrame.IsReference Property

ISchemaPositionFrameIsReference Property

Marks frame as a reference frame, which is later used for path smoothing.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsReference { get; set; }
property bool IsReference {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IPositionFrameIsReference
See Also

Reference

ISchemaPositionFrame Interface
VisualComponents.Create3D Namespace


ISchemaPositionFrame.JointValues Property

ISchemaPositionFrameJointValues Property

Gets all joint values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<double> JointValues { get; }
property ReadOnlyCollection<double>^ JointValues {
    ReadOnlyCollection<double>^ get ();
}

Property Value

Type: ReadOnlyCollectionDouble

Implements

IPositionFrameJointValues
See Also

Reference

ISchemaPositionFrame Interface
VisualComponents.Create3D Namespace


ISchemaPositionFrame.Status Property

ISchemaPositionFrameStatus Property

State of inverse kinematics calculation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
PositionStatus Status { get; set; }
property PositionStatus Status {
    PositionStatus get ();
    void set (PositionStatus value);
}

Property Value

Type: PositionStatus

Implements

IPositionFrameStatus
See Also

Reference

ISchemaPositionFrame Interface
VisualComponents.Create3D Namespace


ISchemaPositionFrame.VisualizationInfo Property

ISchemaPositionFrameVisualizationInfo Property

Information about the way this frame is rendered. List items contain point size and color values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<int> VisualizationInfo { get; }
property IList<int>^ VisualizationInfo {
    IList<int>^ get ();
}

Property Value

Type: IListInt32

Implements

IPositionFrameVisualizationInfo
See Also

Reference

ISchemaPositionFrame Interface
VisualComponents.Create3D Namespace


ISchemaPositionFrame Methods

The ISchemaPositionFrame type exposes the following members.

Methods
 | Name | Description
Public method | AddTransformationInObject | Helper function that takes into account multiple positions combined in one ISchemaPositionFrame.
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ContainsFrame | Checks if a given position is part of this position.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EnsureExternalJoints | Ensure path statement has enough external joints.
Public method | Equals | (Inherited from IWrapper.)
Public method | GetCombinedPositions | Indices of multi-selected positions.
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetSchemaValue(Int32) | Gets property value.
Public method | GetSchemaValue(String) | Gets property value.
Public method | SetExternalJoints | Sets external joint values.
Public method | SetJoints | Sets all joint values.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetSchemaValue(Int32, Object) | Sets property value.
Public method | SetSchemaValue(String, Object) | Sets property value.
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | UpdateStatus | Internal method for updating the status. (Inherited from IPositionFrame.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Public Extension Method | ToCollection | (Defined by CombinableItemCollectionExtensions.)
Top
See Also

Reference

ISchemaPositionFrame Interface
VisualComponents.Create3D Namespace


ISchemaPositionFrame.AddTransformationInObject Method

ISchemaPositionFrameAddTransformationInObject Method

Helper function that takes into account multiple positions combined in one ISchemaPositionFrame.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddTransformationInObject(
    Matrix offset
)
void AddTransformationInObject(
    Matrix offset
)

Parameters

offset
Type: VisualComponents.Create3DMatrix
Transformation offset defined in object space
See Also

Reference

ISchemaPositionFrame Interface
VisualComponents.Create3D Namespace


ISchemaPositionFrame.ContainsFrame Method

ISchemaPositionFrameContainsFrame Method

Checks if a given position is part of this position.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ContainsFrame(
    ISchemaPositionFrame frame
)
bool ContainsFrame(
    ISchemaPositionFrame^ frame
)

Parameters

frame
Type: VisualComponents.Create3DISchemaPositionFrame

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISchemaPositionFrame.ContainsFrame(VisualComponents.Create3D.ISchemaPositionFrame)"]

See Also

Reference

ISchemaPositionFrame Interface
VisualComponents.Create3D Namespace


ISchemaPositionFrame.EnsureExternalJoints Method

ISchemaPositionFrameEnsureExternalJoints Method

Ensure path statement has enough external joints.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void EnsureExternalJoints(
    IEnumerable<double> defaultJointValues
)
void EnsureExternalJoints(
    IEnumerable<double>^ defaultJointValues
)

Parameters

defaultJointValues
Type: System.Collections.GenericIEnumerableDouble
See Also

Reference

ISchemaPositionFrame Interface
VisualComponents.Create3D Namespace


ISchemaPositionFrame.GetCombinedPositions Method

ISchemaPositionFrameGetCombinedPositions Method

Indices of multi-selected positions.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int[] GetCombinedPositions()
array<int>^ GetCombinedPositions()

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISchemaPositionFrame.GetCombinedPositions"]

See Also

Reference

ISchemaPositionFrame Interface
VisualComponents.Create3D Namespace


ISchemaPositionFrame.GetSchemaValue Method

ISchemaPositionFrameGetSchemaValue Method

Overload List
 | Name | Description
Public method | GetSchemaValue(Int32) | Gets property value.
Public method | GetSchemaValue(String) | Gets property value.
Top
See Also

Reference

ISchemaPositionFrame Interface
VisualComponents.Create3D Namespace


ISchemaPositionFrame.GetSchemaValue Method (Int32)

ISchemaPositionFrameGetSchemaValue Method (Int32)

Gets property value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object GetSchemaValue(
    int fieldIndex
)
Object^ GetSchemaValue(
    int fieldIndex
)

Parameters

fieldIndex
Type: SystemInt32

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISchemaPositionFrame.GetSchemaValue(System.Int32)"]

See Also

Reference

ISchemaPositionFrame Interface
GetSchemaValue Overload
VisualComponents.Create3D Namespace


ISchemaPositionFrame.GetSchemaValue Method (String)

ISchemaPositionFrameGetSchemaValue Method (String)

Gets property value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object GetSchemaValue(
    string fieldName
)
Object^ GetSchemaValue(
    String^ fieldName
)

Parameters

fieldName
Type: SystemString

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISchemaPositionFrame.GetSchemaValue(System.String)"]

See Also

Reference

ISchemaPositionFrame Interface
GetSchemaValue Overload
VisualComponents.Create3D Namespace


ISchemaPositionFrame.SetExternalJoints Method

ISchemaPositionFrameSetExternalJoints Method

Sets external joint values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetExternalJoints(
    IEnumerable<double> jointValues
)
void SetExternalJoints(
    IEnumerable<double>^ jointValues
)

Parameters

jointValues
Type: System.Collections.GenericIEnumerableDouble

Implements

IPositionFrameSetExternalJoints(IEnumerableDouble)
See Also

Reference

ISchemaPositionFrame Interface
VisualComponents.Create3D Namespace


ISchemaPositionFrame.SetJoints Method

ISchemaPositionFrameSetJoints Method

Sets all joint values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetJoints(
    IEnumerable<double> jointValues
)
void SetJoints(
    IEnumerable<double>^ jointValues
)

Parameters

jointValues
Type: System.Collections.GenericIEnumerableDouble

Implements

IPositionFrameSetJoints(IEnumerableDouble)
See Also

Reference

ISchemaPositionFrame Interface
VisualComponents.Create3D Namespace


ISchemaPositionFrame.SetSchemaValue Method

ISchemaPositionFrameSetSchemaValue Method

Overload List
 | Name | Description
Public method | SetSchemaValue(Int32, Object) | Sets property value.
Public method | SetSchemaValue(String, Object) | Sets property value.
Top
See Also

Reference

ISchemaPositionFrame Interface
VisualComponents.Create3D Namespace


ISchemaPositionFrame.SetSchemaValue Method (Int32, Object)

ISchemaPositionFrameSetSchemaValue Method (Int32, Object)

Sets property value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetSchemaValue(
    int fieldIndex,
    Object value
)
void SetSchemaValue(
    int fieldIndex,
    Object^ value
)

Parameters

fieldIndex
Type: SystemInt32
value
Type: SystemObject
See Also

Reference

ISchemaPositionFrame Interface
SetSchemaValue Overload
VisualComponents.Create3D Namespace


ISchemaPositionFrame.SetSchemaValue Method (String, Object)

ISchemaPositionFrameSetSchemaValue Method (String, Object)

Sets property value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetSchemaValue(
    string fieldName,
    Object value
)
void SetSchemaValue(
    String^ fieldName,
    Object^ value
)

Parameters

fieldName
Type: SystemString
value
Type: SystemObject
See Also

Reference

ISchemaPositionFrame Interface
SetSchemaValue Overload
VisualComponents.Create3D Namespace


ISchemaPositionFrame Events

The ISchemaPositionFrame type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

ISchemaPositionFrame Interface
VisualComponents.Create3D Namespace


IScreenRecorder Interface

Simulation recorder interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IScreenRecorder
public interface class IScreenRecorder

The IScreenRecorder type exposes the following members.

Methods
 | Name | Description
Public method | StartScreenRecording | Starts the screen recording
Public method | StopScreenRecording | Stops and saves the recording
Top
See Also

Reference

VisualComponents.Create3D Namespace


IScreenRecorder Methods

The IScreenRecorder type exposes the following members.

Methods
 | Name | Description
Public method | StartScreenRecording | Starts the screen recording
Public method | StopScreenRecording | Stops and saves the recording
Top
See Also

Reference

IScreenRecorder Interface
VisualComponents.Create3D Namespace


IScreenRecorder.StartScreenRecording Method

IScreenRecorderStartScreenRecording Method

Starts the screen recording

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StartScreenRecording(
    bool desktop,
    Uri url,
    bool mouse
)
void StartScreenRecording(
    bool desktop,
    Uri^ url,
    bool mouse
)

Parameters

desktop
Type: SystemBoolean
recording whole screen or current windows
url
Type: SystemUri
location to save the file
mouse
Type: SystemBoolean
show mouse in recording or not
See Also

Reference

IScreenRecorder Interface
VisualComponents.Create3D Namespace


IScreenRecorder.StopScreenRecording Method

IScreenRecorderStopScreenRecording Method

Stops and saves the recording

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StopScreenRecording()
void StopScreenRecording()
See Also

Reference

IScreenRecorder Interface
VisualComponents.Create3D Namespace


IScriptProperty Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IScriptProperty : IProperty,
    INotifyPropertyChanged, IDisposable, INamed
public interface class IScriptProperty : IProperty,
    INotifyPropertyChanged, IDisposable, INamed

The IScriptProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Allowed maximum value for the property. (Inherited from IProperty.)
Public property | AllowedMinimum | Allowed minimum value for the property. (Inherited from IProperty.)
Public property | AllowedValues | Collection of allowed values for constrained properties. (Inherited from IProperty.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Property value as an object. (Inherited from IProperty.)
Top
Methods
 | Name | Description
Public method | Click |
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Events
 | Name | Description
Public event | OnClick |
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IScriptProperty Properties

The IScriptProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Allowed maximum value for the property. (Inherited from IProperty.)
Public property | AllowedMinimum | Allowed minimum value for the property. (Inherited from IProperty.)
Public property | AllowedValues | Collection of allowed values for constrained properties. (Inherited from IProperty.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Property value as an object. (Inherited from IProperty.)
Top
See Also

Reference

IScriptProperty Interface
VisualComponents.Create3D Namespace


IScriptProperty Methods

The IScriptProperty type exposes the following members.

Methods
 | Name | Description
Public method | Click |
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

IScriptProperty Interface
VisualComponents.Create3D Namespace


IScriptProperty.Click Method

IScriptPropertyClick Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Click()
void Click()
See Also

Reference

IScriptProperty Interface
VisualComponents.Create3D Namespace


IScriptProperty Events

The IScriptProperty type exposes the following members.

Events
 | Name | Description
Public event | OnClick |
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IScriptProperty Interface
VisualComponents.Create3D Namespace


IScriptProperty.OnClick Event

IScriptPropertyOnClick Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ButtonPropertyClickedEventArgs> OnClick
 event EventHandler<ButtonPropertyClickedEventArgs^>^ OnClick {
    void add (EventHandler<ButtonPropertyClickedEventArgs^>^ value);
    void remove (EventHandler<ButtonPropertyClickedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerButtonPropertyClickedEventArgs
See Also

Reference

IScriptProperty Interface
VisualComponents.Create3D Namespace


ISection Interface

User configuration section.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISection
public interface class ISection

The ISection type exposes the following members.

Properties
 | Name | Description
Public property | SectionName | Section name
Public property | SectionType | Section type
Public property | SectionVersion | Section version
Top
Methods
 | Name | Description
Public method | CheckVersion | Checks section version
Public method | GetSection | Gets the section
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISection Properties

The ISection type exposes the following members.

Properties
 | Name | Description
Public property | SectionName | Section name
Public property | SectionType | Section type
Public property | SectionVersion | Section version
Top
See Also

Reference

ISection Interface
VisualComponents.Create3D Namespace


ISection.SectionName Property

ISectionSectionName Property

Section name

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string SectionName { get; }
property String^ SectionName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ISection Interface
VisualComponents.Create3D Namespace


ISection.SectionType Property

ISectionSectionType Property

Section type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Type SectionType { get; }
property Type^ SectionType {
    Type^ get ();
}

Property Value

Type: Type
See Also

Reference

ISection Interface
VisualComponents.Create3D Namespace


ISection.SectionVersion Property

ISectionSectionVersion Property

Section version

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int SectionVersion { get; }
property int SectionVersion {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ISection Interface
VisualComponents.Create3D Namespace


ISection Methods

The ISection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion | Checks section version
Public method | GetSection | Gets the section
Top
See Also

Reference

ISection Interface
VisualComponents.Create3D Namespace


ISection.CheckVersion Method

ISectionCheckVersion Method

Checks section version

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void CheckVersion()
void CheckVersion()
See Also

Reference

ISection Interface
VisualComponents.Create3D Namespace


ISection.GetSection Method

ISectionGetSection Method

Gets the section

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISection GetSection(
    Configuration userSettingConfiguration
)
ISection^ GetSection(
    Configuration^ userSettingConfiguration
)

Parameters

userSettingConfiguration
Type: System.ConfigurationConfiguration
configuration instance

Return Value

Type: ISection
new or existing version of the section
See Also

Reference

ISection Interface
VisualComponents.Create3D Namespace


ISelectionHandler Interface

SelectionHandler implementations are responsible to implemenet logic what should happen when the object is being added or removed from selection. However, these are not used directly, but are invoked through SelectionManager, which is responsible for maintaining bookkeeping of selections.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISelectionHandler
public interface class ISelectionHandler

The ISelectionHandler type exposes the following members.

Properties
 | Name | Description
Public property | HandledType |
Public property | IsActive |
Top
Methods
 | Name | Description
Public method | AddToSelection |
Public method | CanHandle(Object) |
Public method | CanHandleT |
Public method | RemovedFromSelection |
Public method | RemovingFromSelection |
Top
Events
 | Name | Description
Public event | Deselected |
Public event | Deselecting |
Public event | Selected |
Public event | Selecting |
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISelectionHandler Properties

The ISelectionHandler type exposes the following members.

Properties
 | Name | Description
Public property | HandledType |
Public property | IsActive |
Top
See Also

Reference

ISelectionHandler Interface
VisualComponents.Create3D Namespace


ISelectionHandler.HandledType Property

ISelectionHandlerHandledType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Type HandledType { get; }
property Type^ HandledType {
    Type^ get ();
}

Property Value

Type: Type
See Also

Reference

ISelectionHandler Interface
VisualComponents.Create3D Namespace


ISelectionHandler.IsActive Property

ISelectionHandlerIsActive Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsActive { get; set; }
property bool IsActive {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISelectionHandler Interface
VisualComponents.Create3D Namespace


ISelectionHandler Methods

The ISelectionHandler type exposes the following members.

Methods
 | Name | Description
Public method | AddToSelection |
Public method | CanHandle(Object) |
Public method | CanHandleT |
Public method | RemovedFromSelection |
Public method | RemovingFromSelection |
Top
See Also

Reference

ISelectionHandler Interface
VisualComponents.Create3D Namespace


ISelectionHandler.AddToSelection Method

ISelectionHandlerAddToSelection Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddToSelection(
    Object[] itemsToAdd,
    bool appendToSelection,
    ISelectionManager selectionManager,
    Action<Object[]> methodToAddToSelection,
    Action<Object[]> methodToRemoveFromSelection
)
void AddToSelection(
    array<Object^>^ itemsToAdd,
    bool appendToSelection,
    ISelectionManager^ selectionManager,
    Action<array<Object^>^>^ methodToAddToSelection,
    Action<array<Object^>^>^ methodToRemoveFromSelection
)

Parameters

itemsToAdd
Type: SystemObject
appendToSelection
Type: SystemBoolean
selectionManager
Type: VisualComponents.Create3DISelectionManager
methodToAddToSelection
Type: SystemActionObject
methodToRemoveFromSelection
Type: SystemActionObject
See Also

Reference

ISelectionHandler Interface
VisualComponents.Create3D Namespace


ISelectionHandler.CanHandle Method

ISelectionHandlerCanHandle Method

Overload List
 | Name | Description
Public method | CanHandleT |
Public method | CanHandle(Object) |
Top
See Also

Reference

ISelectionHandler Interface
VisualComponents.Create3D Namespace


ISelectionHandler.CanHandle(T) Method

ISelectionHandlerCanHandleT Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanHandle<T>()

generic<typename T>
bool CanHandle()

Type Parameters

T

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISelectionHandler.CanHandle``1"]

See Also

Reference

ISelectionHandler Interface
CanHandle Overload
VisualComponents.Create3D Namespace


ISelectionHandler.CanHandle Method (Object)

ISelectionHandlerCanHandle Method (Object)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanHandle(
    Object item
)
bool CanHandle(
    Object^ item
)

Parameters

item
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISelectionHandler.CanHandle(System.Object)"]

See Also

Reference

ISelectionHandler Interface
CanHandle Overload
VisualComponents.Create3D Namespace


ISelectionHandler.RemovedFromSelection Method

ISelectionHandlerRemovedFromSelection Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RemovedFromSelection(
    Object[] itemsToRemove,
    ISelectionManager selectionManager
)
void RemovedFromSelection(
    array<Object^>^ itemsToRemove,
    ISelectionManager^ selectionManager
)

Parameters

itemsToRemove
Type: SystemObject
selectionManager
Type: VisualComponents.Create3DISelectionManager
See Also

Reference

ISelectionHandler Interface
VisualComponents.Create3D Namespace


ISelectionHandler.RemovingFromSelection Method

ISelectionHandlerRemovingFromSelection Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RemovingFromSelection(
    Object[] itemsToRemove,
    ISelectionManager selectionManager
)
void RemovingFromSelection(
    array<Object^>^ itemsToRemove,
    ISelectionManager^ selectionManager
)

Parameters

itemsToRemove
Type: SystemObject
selectionManager
Type: VisualComponents.Create3DISelectionManager
See Also

Reference

ISelectionHandler Interface
VisualComponents.Create3D Namespace


ISelectionHandler Events

The ISelectionHandler type exposes the following members.

Events
 | Name | Description
Public event | Deselected |
Public event | Deselecting |
Public event | Selected |
Public event | Selecting |
Top
See Also

Reference

ISelectionHandler Interface
VisualComponents.Create3D Namespace


ISelectionHandler.Deselected Event

ISelectionHandlerDeselected Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ItemsDeselectedEventArgs> Deselected
 event EventHandler<ItemsDeselectedEventArgs^>^ Deselected {
    void add (EventHandler<ItemsDeselectedEventArgs^>^ value);
    void remove (EventHandler<ItemsDeselectedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerItemsDeselectedEventArgs
See Also

Reference

ISelectionHandler Interface
VisualComponents.Create3D Namespace


ISelectionHandler.Deselecting Event

ISelectionHandlerDeselecting Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ItemsDeselectingEventArgs> Deselecting
 event EventHandler<ItemsDeselectingEventArgs^>^ Deselecting {
    void add (EventHandler<ItemsDeselectingEventArgs^>^ value);
    void remove (EventHandler<ItemsDeselectingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerItemsDeselectingEventArgs
See Also

Reference

ISelectionHandler Interface
VisualComponents.Create3D Namespace


ISelectionHandler.Selected Event

ISelectionHandlerSelected Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ItemsSelectedEventArgs> Selected
 event EventHandler<ItemsSelectedEventArgs^>^ Selected {
    void add (EventHandler<ItemsSelectedEventArgs^>^ value);
    void remove (EventHandler<ItemsSelectedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerItemsSelectedEventArgs
See Also

Reference

ISelectionHandler Interface
VisualComponents.Create3D Namespace


ISelectionHandler.Selecting Event

ISelectionHandlerSelecting Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ItemsSelectingEventArgs> Selecting
 event EventHandler<ItemsSelectingEventArgs^>^ Selecting {
    void add (EventHandler<ItemsSelectingEventArgs^>^ value);
    void remove (EventHandler<ItemsSelectingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerItemsSelectingEventArgs
See Also

Reference

ISelectionHandler Interface
VisualComponents.Create3D Namespace


ISelectionManager Interface

SelectionManager tracks selected objects in scene and delegates selection and deselection to associated selection handlers.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISelectionManager : INotifyPropertyChangedEx,
    INotifyPropertyChanged
public interface class ISelectionManager : INotifyPropertyChangedEx,
    INotifyPropertyChanged

The ISelectionManager type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationSelectionHandler | Returns the selection handler that can handle IAnnotation type
Public property | AssemblyPatternSlotVisualizationHandler | Returns the selection handler that can handle IPatternSlotVisualization type
Public property | AssemblyStepSelectionHandler | Returns the selection handler that can handle IAssemblyStep type
Public property | ComponentSelectionHandler | Returns the selection handler that can handle ISimComponent type
Public property | DimensionSelectionHandler | Returns the selection handler that can handle IDimension type
Public property | FaceSelectionHandler | Returns the selection handler that can handle IFace type
Public property | FeatureSelectionHandler | Returns the selection handler that can handle IFeaure type
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | NodeSelectionHandler | Returns the selection handler that can handle ISimNode type
Public property | ProductTypeSelectionHandler | Returns the selection handler that can handle IProductType type
Public property | SelectedPhysicsRope |
Public property | SelectedPhysicsRopeBehavior |
Public property | SelectedPhysicsRopePin |
Public property | StatementSelectionHandler | Returns the selection handler that can handle IStatement type
Public property | StatisticChartSelectionHandler | Returns the selection handler that can handle IStatisticsChartBase type
Public property | TransportLinkSelectionHandler | Returns the selection handler that can handle ITransportLink type
Top
Methods
 | Name | Description
Public method | Clear | Deselects all the objects
Public method | Clear(Boolean, Boolean) | Deselects all the objects
Public method | ClearT | Deselects all the objects of given type
Public method | ClearT(Boolean) | Deselects all the objects of given type
Public method | GetAllSelected | Returns all the selected objects
Public method | GetSelectedT | Returns the selected object of given type. If multiple objects are selected, returns the first one.
Public method | GetSelectionT | Returns all the selected objects of given type
Public method | GetSelectionCollectionT | Obsolete. Returns an enumerable collection, that takes into account internally combined items. See ICombinable interface.
Public method | GetSelectionHandlers | Returns an array of all ISelectionHandler instances
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | SetSelection(Object) | Selects the given object. Selection list is cleared before adding object as selected.
Public method | SetSelection(IEnumerableObject, Boolean) | Selects a collection of objects
Public method | SetSelection(Object, Boolean) | Selects the given object
Public method | SetSelection(IEnumerableObject, Boolean, Boolean) | Selects a collection of objects
Public method | SetSelection(IEnumerableObject, Boolean, Boolean, Boolean) | Selects a collection of objects
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Public event | SelectionChanged | When this event is called ManipulateViewModel.Target is already updated.
Public event | SelectionChanging | Internal event
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISelectionManager Properties

The ISelectionManager type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationSelectionHandler | Returns the selection handler that can handle IAnnotation type
Public property | AssemblyPatternSlotVisualizationHandler | Returns the selection handler that can handle IPatternSlotVisualization type
Public property | AssemblyStepSelectionHandler | Returns the selection handler that can handle IAssemblyStep type
Public property | ComponentSelectionHandler | Returns the selection handler that can handle ISimComponent type
Public property | DimensionSelectionHandler | Returns the selection handler that can handle IDimension type
Public property | FaceSelectionHandler | Returns the selection handler that can handle IFace type
Public property | FeatureSelectionHandler | Returns the selection handler that can handle IFeaure type
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | NodeSelectionHandler | Returns the selection handler that can handle ISimNode type
Public property | ProductTypeSelectionHandler | Returns the selection handler that can handle IProductType type
Public property | SelectedPhysicsRope |
Public property | SelectedPhysicsRopeBehavior |
Public property | SelectedPhysicsRopePin |
Public property | StatementSelectionHandler | Returns the selection handler that can handle IStatement type
Public property | StatisticChartSelectionHandler | Returns the selection handler that can handle IStatisticsChartBase type
Public property | TransportLinkSelectionHandler | Returns the selection handler that can handle ITransportLink type
Top
See Also

Reference

ISelectionManager Interface
VisualComponents.Create3D Namespace


ISelectionManager.AnnotationSelectionHandler Property

ISelectionManagerAnnotationSelectionHandler Property

Returns the selection handler that can handle IAnnotation type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISelectionHandler AnnotationSelectionHandler { get; }
property ISelectionHandler^ AnnotationSelectionHandler {
    ISelectionHandler^ get ();
}

Property Value

Type: ISelectionHandler
See Also

Reference

ISelectionManager Interface
VisualComponents.Create3D Namespace


ISelectionManager.AssemblyPatternSlotVisualizationHandler Property

ISelectionManagerAssemblyPatternSlotVisualizationHandler Property

Returns the selection handler that can handle IPatternSlotVisualization type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISelectionHandler AssemblyPatternSlotVisualizationHandler { get; }
property ISelectionHandler^ AssemblyPatternSlotVisualizationHandler {
    ISelectionHandler^ get ();
}

Property Value

Type: ISelectionHandler
See Also

Reference

ISelectionManager Interface
VisualComponents.Create3D Namespace


ISelectionManager.AssemblyStepSelectionHandler Property

ISelectionManagerAssemblyStepSelectionHandler Property

Returns the selection handler that can handle IAssemblyStep type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISelectionHandler AssemblyStepSelectionHandler { get; }
property ISelectionHandler^ AssemblyStepSelectionHandler {
    ISelectionHandler^ get ();
}

Property Value

Type: ISelectionHandler
See Also

Reference

ISelectionManager Interface
VisualComponents.Create3D Namespace


ISelectionManager.ComponentSelectionHandler Property

ISelectionManagerComponentSelectionHandler Property

Returns the selection handler that can handle ISimComponent type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISelectionHandler ComponentSelectionHandler { get; }
property ISelectionHandler^ ComponentSelectionHandler {
    ISelectionHandler^ get ();
}

Property Value

Type: ISelectionHandler
See Also

Reference

ISelectionManager Interface
VisualComponents.Create3D Namespace


ISelectionManager.DimensionSelectionHandler Property

ISelectionManagerDimensionSelectionHandler Property

Returns the selection handler that can handle IDimension type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISelectionHandler DimensionSelectionHandler { get; }
property ISelectionHandler^ DimensionSelectionHandler {
    ISelectionHandler^ get ();
}

Property Value

Type: ISelectionHandler
See Also

Reference

ISelectionManager Interface
VisualComponents.Create3D Namespace


ISelectionManager.FaceSelectionHandler Property

ISelectionManagerFaceSelectionHandler Property

Returns the selection handler that can handle IFace type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISelectionHandler FaceSelectionHandler { get; }
property ISelectionHandler^ FaceSelectionHandler {
    ISelectionHandler^ get ();
}

Property Value

Type: ISelectionHandler
See Also

Reference

ISelectionManager Interface
VisualComponents.Create3D Namespace


ISelectionManager.FeatureSelectionHandler Property

ISelectionManagerFeatureSelectionHandler Property

Returns the selection handler that can handle IFeaure type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISelectionHandler FeatureSelectionHandler { get; }
property ISelectionHandler^ FeatureSelectionHandler {
    ISelectionHandler^ get ();
}

Property Value

Type: ISelectionHandler
See Also

Reference

ISelectionManager Interface
VisualComponents.Create3D Namespace


ISelectionManager.NodeSelectionHandler Property

ISelectionManagerNodeSelectionHandler Property

Returns the selection handler that can handle ISimNode type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISelectionHandler NodeSelectionHandler { get; }
property ISelectionHandler^ NodeSelectionHandler {
    ISelectionHandler^ get ();
}

Property Value

Type: ISelectionHandler
See Also

Reference

ISelectionManager Interface
VisualComponents.Create3D Namespace


ISelectionManager.ProductTypeSelectionHandler Property

ISelectionManagerProductTypeSelectionHandler Property

Returns the selection handler that can handle IProductType type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISelectionHandler ProductTypeSelectionHandler { get; }
property ISelectionHandler^ ProductTypeSelectionHandler {
    ISelectionHandler^ get ();
}

Property Value

Type: ISelectionHandler
See Also

Reference

ISelectionManager Interface
VisualComponents.Create3D Namespace


ISelectionManager.SelectedPhysicsRope Property

ISelectionManagerSelectedPhysicsRope Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent SelectedPhysicsRope { get; }
property ISimComponent^ SelectedPhysicsRope {
    ISimComponent^ get ();
}

Property Value

Type: ISimComponent
See Also

Reference

ISelectionManager Interface
VisualComponents.Create3D Namespace


ISelectionManager.SelectedPhysicsRopeBehavior Property

ISelectionManagerSelectedPhysicsRopeBehavior Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IBehavior SelectedPhysicsRopeBehavior { get; }
property IBehavior^ SelectedPhysicsRopeBehavior {
    IBehavior^ get ();
}

Property Value

Type: IBehavior
See Also

Reference

ISelectionManager Interface
VisualComponents.Create3D Namespace


ISelectionManager.SelectedPhysicsRopePin Property

ISelectionManagerSelectedPhysicsRopePin Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode SelectedPhysicsRopePin { get; }
property ISimNode^ SelectedPhysicsRopePin {
    ISimNode^ get ();
}

Property Value

Type: ISimNode
See Also

Reference

ISelectionManager Interface
VisualComponents.Create3D Namespace


ISelectionManager.StatementSelectionHandler Property

ISelectionManagerStatementSelectionHandler Property

Returns the selection handler that can handle IStatement type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISelectionHandler StatementSelectionHandler { get; }
property ISelectionHandler^ StatementSelectionHandler {
    ISelectionHandler^ get ();
}

Property Value

Type: ISelectionHandler
See Also

Reference

ISelectionManager Interface
VisualComponents.Create3D Namespace


ISelectionManager.StatisticChartSelectionHandler Property

ISelectionManagerStatisticChartSelectionHandler Property

Returns the selection handler that can handle IStatisticsChartBase type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISelectionHandler StatisticChartSelectionHandler { get; }
property ISelectionHandler^ StatisticChartSelectionHandler {
    ISelectionHandler^ get ();
}

Property Value

Type: ISelectionHandler
See Also

Reference

ISelectionManager Interface
VisualComponents.Create3D Namespace


ISelectionManager.TransportLinkSelectionHandler Property

ISelectionManagerTransportLinkSelectionHandler Property

Returns the selection handler that can handle ITransportLink type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISelectionHandler TransportLinkSelectionHandler { get; }
property ISelectionHandler^ TransportLinkSelectionHandler {
    ISelectionHandler^ get ();
}

Property Value

Type: ISelectionHandler
See Also

Reference

ISelectionManager Interface
VisualComponents.Create3D Namespace


ISelectionManager Methods

The ISelectionManager type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Deselects all the objects
Public method | Clear(Boolean, Boolean) | Deselects all the objects
Public method | ClearT | Deselects all the objects of given type
Public method | ClearT(Boolean) | Deselects all the objects of given type
Public method | GetAllSelected | Returns all the selected objects
Public method | GetSelectedT | Returns the selected object of given type. If multiple objects are selected, returns the first one.
Public method | GetSelectionT | Returns all the selected objects of given type
Public method | GetSelectionCollectionT | Obsolete. Returns an enumerable collection, that takes into account internally combined items. See ICombinable interface.
Public method | GetSelectionHandlers | Returns an array of all ISelectionHandler instances
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | SetSelection(Object) | Selects the given object. Selection list is cleared before adding object as selected.
Public method | SetSelection(IEnumerableObject, Boolean) | Selects a collection of objects
Public method | SetSelection(Object, Boolean) | Selects the given object
Public method | SetSelection(IEnumerableObject, Boolean, Boolean) | Selects a collection of objects
Public method | SetSelection(IEnumerableObject, Boolean, Boolean, Boolean) | Selects a collection of objects
Top
See Also

Reference

ISelectionManager Interface
VisualComponents.Create3D Namespace


ISelectionManager.Clear Method

ISelectionManagerClear Method

Overload List
 | Name | Description
Public method | Clear | Deselects all the objects
Public method | ClearT | Deselects all the objects of given type
Public method | ClearT(Boolean) | Deselects all the objects of given type
Public method | Clear(Boolean, Boolean) | Deselects all the objects
Top
See Also

Reference

ISelectionManager Interface
VisualComponents.Create3D Namespace


ISelectionManager.Clear Method

ISelectionManagerClear Method

Deselects all the objects

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Clear()
void Clear()
See Also

Reference

ISelectionManager Interface
Clear Overload
VisualComponents.Create3D Namespace


ISelectionManager.Clear(T) Method

ISelectionManagerClearT Method

Deselects all the objects of given type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Clear<T>()
where T : class

generic<typename T>
where T : ref class
void Clear()

Type Parameters

T
Type of objects to be deselected
See Also

Reference

ISelectionManager Interface
Clear Overload
VisualComponents.Create3D Namespace


ISelectionManager.Clear(T) Method (Boolean)

ISelectionManagerClearT Method (Boolean)

Deselects all the objects of given type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Clear<T>(
    bool notify
)
where T : class

generic<typename T>
where T : ref class
void Clear(
    bool notify
)

Parameters

notify
Type: SystemBoolean

Type Parameters

T
Type of objects to be deselected
See Also

Reference

ISelectionManager Interface
Clear Overload
VisualComponents.Create3D Namespace


ISelectionManager.Clear Method (Boolean, Boolean)

ISelectionManagerClear Method (Boolean, Boolean)

Deselects all the objects

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Clear(
    bool notify,
    bool complete
)
void Clear(
    bool notify,
    bool complete
)

Parameters

notify
Type: SystemBoolean
complete
Type: SystemBoolean
See Also

Reference

ISelectionManager Interface
Clear Overload
VisualComponents.Create3D Namespace


ISelectionManager.GetAllSelected Method

ISelectionManagerGetAllSelected Method

Returns all the selected objects

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object[] GetAllSelected()
array<Object^>^ GetAllSelected()

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISelectionManager.GetAllSelected"]

See Also

Reference

ISelectionManager Interface
VisualComponents.Create3D Namespace


ISelectionManager.GetSelected(T) Method

ISelectionManagerGetSelectedT Method

Returns the selected object of given type. If multiple objects are selected, returns the first one.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
T GetSelected<T>()
where T : class

generic<typename T>
where T : ref class
T GetSelected()

Type Parameters

T

Return Value

Type: T

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISelectionManager.GetSelected``1"]

See Also

Reference

ISelectionManager Interface
VisualComponents.Create3D Namespace


ISelectionManager.GetSelection(T) Method

ISelectionManagerGetSelectionT Method

Returns all the selected objects of given type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
T[] GetSelection<T>()
where T : class

generic<typename T>
where T : ref class
array<T>^ GetSelection()

Type Parameters

T
Type of objects

Return Value

Type: T

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISelectionManager.GetSelection``1"]

See Also

Reference

ISelectionManager Interface
VisualComponents.Create3D Namespace


ISelectionManager.GetSelectionCollection(T) Method

ISelectionManagerGetSelectionCollectionT Method

Note: This API is now obsolete.

Returns an enumerable collection, that takes into account internally combined items. See ICombinable interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Replaced with ICombinable<T>.CombinedItems")]
IEnumerable<T> GetSelectionCollection<T>()
where T : class

[ObsoleteAttribute(L"Replaced with ICombinable<T>.CombinedItems")]
generic<typename T>
where T : ref class
IEnumerable<T>^ GetSelectionCollection()

Type Parameters

T

Return Value

Type: IEnumerableT

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISelectionManager.GetSelectionCollection``1"]

See Also

Reference

ISelectionManager Interface
VisualComponents.Create3D Namespace


ISelectionManager.GetSelectionHandlers Method

ISelectionManagerGetSelectionHandlers Method

Returns an array of all ISelectionHandler instances

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISelectionHandler[] GetSelectionHandlers()
array<ISelectionHandler^>^ GetSelectionHandlers()

Return Value

Type: ISelectionHandler
Array of selection handlers
See Also

Reference

ISelectionManager Interface
VisualComponents.Create3D Namespace


ISelectionManager.SetSelection Method

ISelectionManagerSetSelection Method

Overload List
 | Name | Description
Public method | SetSelection(Object) | Selects the given object. Selection list is cleared before adding object as selected.
Public method | SetSelection(IEnumerableObject, Boolean) | Selects a collection of objects
Public method | SetSelection(Object, Boolean) | Selects the given object
Public method | SetSelection(IEnumerableObject, Boolean, Boolean) | Selects a collection of objects
Public method | SetSelection(IEnumerableObject, Boolean, Boolean, Boolean) | Selects a collection of objects
Top
See Also

Reference

ISelectionManager Interface
VisualComponents.Create3D Namespace


ISelectionManager.SetSelection Method (Object)

ISelectionManagerSetSelection Method (Object)

Selects the given object. Selection list is cleared before adding object as selected.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetSelection(
    Object item
)
void SetSelection(
    Object^ item
)

Parameters

item
Type: SystemObject
Item to be selected
See Also

Reference

ISelectionManager Interface
SetSelection Overload
VisualComponents.Create3D Namespace


ISelectionManager.SetSelection Method (IEnumerable(Object), Boolean)

ISelectionManagerSetSelection Method (IEnumerableObject, Boolean)

Selects a collection of objects

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetSelection(
    IEnumerable<Object> items,
    bool multiselect
)
void SetSelection(
    IEnumerable<Object^>^ items,
    bool multiselect
)

Parameters

items
Type: System.Collections.GenericIEnumerableObject
Items to be selected
multiselect
Type: SystemBoolean
If true, items will be appended to the current selection, otherwise selection is cleared first
See Also

Reference

ISelectionManager Interface
SetSelection Overload
VisualComponents.Create3D Namespace


ISelectionManager.SetSelection Method (Object, Boolean)

ISelectionManagerSetSelection Method (Object, Boolean)

Selects the given object

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetSelection(
    Object item,
    bool multiselect
)
void SetSelection(
    Object^ item,
    bool multiselect
)

Parameters

item
Type: SystemObject
Item to be selected
multiselect
Type: SystemBoolean
If true, item will be appended to the current selection, selection is cleared first
See Also

Reference

ISelectionManager Interface
SetSelection Overload
VisualComponents.Create3D Namespace


ISelectionManager.SetSelection Method (IEnumerable(Object), Boolean, Boolean)

ISelectionManagerSetSelection Method (IEnumerableObject, Boolean, Boolean)

Selects a collection of objects

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetSelection(
    IEnumerable<Object> items,
    bool multiselect,
    bool notify
)
void SetSelection(
    IEnumerable<Object^>^ items,
    bool multiselect,
    bool notify
)

Parameters

items
Type: System.Collections.GenericIEnumerableObject
Items to be selected
multiselect
Type: SystemBoolean
If true, items will be appended to the current selection, otherwise selection is cleared first
notify
Type: SystemBoolean
If true, notifies about selection changes
See Also

Reference

ISelectionManager Interface
SetSelection Overload
VisualComponents.Create3D Namespace


ISelectionManager.SetSelection Method (IEnumerable(Object), Boolean, Boolean, Boolean)

ISelectionManagerSetSelection Method (IEnumerableObject, Boolean, Boolean, Boolean)

Selects a collection of objects

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetSelection(
    IEnumerable<Object> items,
    bool multiselect,
    bool notify,
    bool toggleSelected
)
void SetSelection(
    IEnumerable<Object^>^ items,
    bool multiselect,
    bool notify,
    bool toggleSelected
)

Parameters

items
Type: System.Collections.GenericIEnumerableObject
Items to be selected
multiselect
Type: SystemBoolean
If true, items will be appended to the current selection, otherwise selection is cleared first
notify
Type: SystemBoolean
If true, notifies about selection changes
toggleSelected
Type: SystemBoolean
If true, and multiselect also true, duplicated items will be deselected
See Also

Reference

ISelectionManager Interface
SetSelection Overload
VisualComponents.Create3D Namespace


ISelectionManager Events

The ISelectionManager type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Public event | SelectionChanged | When this event is called ManipulateViewModel.Target is already updated.
Public event | SelectionChanging | Internal event
Top
See Also

Reference

ISelectionManager Interface
VisualComponents.Create3D Namespace


ISelectionManager.SelectionChanged Event

ISelectionManagerSelectionChanged Event

When this event is called ManipulateViewModel.Target is already updated.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler SelectionChanged
 event EventHandler^ SelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ISelectionManager Interface
VisualComponents.Create3D Namespace


ISelectionManager.SelectionChanging Event

ISelectionManagerSelectionChanging Event

Internal event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler SelectionChanging
 event EventHandler^ SelectionChanging {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ISelectionManager Interface
VisualComponents.Create3D Namespace


ISelectProductsStatement Interface

A process statement for filtering IProductTypes from a given list variable to a new list variable.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISelectProductsStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class ISelectProductsStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The ISelectProductsStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | MaxCountExpression | An expression that defines the maximum number of accepted products.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductVariableName | The name of the input list variable to filter from.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | SplitVariableName | The name of the output list variable to filter to. This variable will be created if it does not already exist.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISelectProductsStatement Properties

The ISelectProductsStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | MaxCountExpression | An expression that defines the maximum number of accepted products.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductVariableName | The name of the input list variable to filter from.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | SplitVariableName | The name of the output list variable to filter to. This variable will be created if it does not already exist.
Top
See Also

Reference

ISelectProductsStatement Interface
VisualComponents.Create3D Namespace


ISelectProductsStatement.MaxCountExpression Property

ISelectProductsStatementMaxCountExpression Property

An expression that defines the maximum number of accepted products.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string MaxCountExpression { get; set; }
property String^ MaxCountExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ISelectProductsStatement Interface
VisualComponents.Create3D Namespace


ISelectProductsStatement.ProductVariableName Property

ISelectProductsStatementProductVariableName Property

The name of the input list variable to filter from.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ProductVariableName { get; set; }
property String^ ProductVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown when trying to set a null value
See Also

Reference

ISelectProductsStatement Interface
VisualComponents.Create3D Namespace


ISelectProductsStatement.SplitVariableName Property

ISelectProductsStatementSplitVariableName Property

The name of the output list variable to filter to. This variable will be created if it does not already exist.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string SplitVariableName { get; set; }
property String^ SplitVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown when trying to set a null value
See Also

Reference

ISelectProductsStatement Interface
VisualComponents.Create3D Namespace


ISelectProductsStatement Methods

The ISelectProductsStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISelectProductsStatement Interface
VisualComponents.Create3D Namespace


ISelectProductsStatement Events

The ISelectProductsStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

ISelectProductsStatement Interface
VisualComponents.Create3D Namespace


ISendSignalStatement Interface

Process statement that sends the selected ISignal with the provided value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISendSignalStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class ISendSignalStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The ISendSignalStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | SelectedComponent | A static ISimComponent of which the ISignal will be sent from. Null value means to get from the same ISimComponent this IStatement is executing in.
Public property | SelectedSignal | The ISignal to send. Setting this will also set SelectedComponent.
Public property | ValueExpression | The value to send.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISendSignalStatement Properties

The ISendSignalStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | SelectedComponent | A static ISimComponent of which the ISignal will be sent from. Null value means to get from the same ISimComponent this IStatement is executing in.
Public property | SelectedSignal | The ISignal to send. Setting this will also set SelectedComponent.
Public property | ValueExpression | The value to send.
Top
See Also

Reference

ISendSignalStatement Interface
VisualComponents.Create3D Namespace


ISendSignalStatement.SelectedComponent Property

ISendSignalStatementSelectedComponent Property

A static ISimComponent of which the ISignal will be sent from.

Null value means to get from the same ISimComponent this IStatement is executing in.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent SelectedComponent { get; }
property ISimComponent^ SelectedComponent {
    ISimComponent^ get ();
}

Property Value

Type: ISimComponent
See Also

Reference

ISendSignalStatement Interface
VisualComponents.Create3D Namespace


ISendSignalStatement.SelectedSignal Property

ISendSignalStatementSelectedSignal Property

The ISignal to send. Setting this will also set SelectedComponent.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISignal SelectedSignal { get; set; }
property ISignal^ SelectedSignal {
    ISignal^ get ();
    void set (ISignal^ value);
}

Property Value

Type: ISignal
Exceptions
Exception | Condition
ArgumentNullException | Thrown if trying to set a null value
ArgumentException | Thrown if there is an error while processing the argument
See Also

Reference

ISendSignalStatement Interface
VisualComponents.Create3D Namespace


ISendSignalStatement.ValueExpression Property

ISendSignalStatementValueExpression Property

The value to send.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ValueExpression { get; set; }
property String^ ValueExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
This expression has access to variables stored in IProcessRoutine.
See Also

Reference

ISendSignalStatement Interface
VisualComponents.Create3D Namespace


ISendSignalStatement Methods

The ISendSignalStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISendSignalStatement Interface
VisualComponents.Create3D Namespace


ISendSignalStatement Events

The ISendSignalStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

ISendSignalStatement Interface
VisualComponents.Create3D Namespace


IServoController Interface

Servo controller behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IServoController : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IServoController : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IServoController type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CurrentState | Current kinematic chain state.
Public property | CustomSimulationUpdateTime | Last time value passed to ScheduleCustomSimulationUpdate().
Public property | Dofs | List of DOFs used by the controller.
Public property | ExternalJoints | List of imported external joints.
Public property | FlangeNode | Gets or sets the flange node
Public property | HeartbeatTime | Gets or sets heartbeat interval
Public property | IsConnected | Indicates whether the servo is connected to another servo
Public property | IsValid | (Inherited from IWrapper.)
Public property | Joints | List of joints implemented in the controller.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | RootNode | Gets or sets the root node
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Public property | UsesCustomSimulationUpdate | Indicates that ScheduleCustomSimulationUpdate() was called.
Public property | UsesHeartbeat | Defines if controller updates movements on a heartbeat rate. Normally updating is done when required.
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateJoint | Create a new joint, and add it to the end of the joint list.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteJoint | Delete the specified joint.
Public method | DeleteJointAt | Delete the joint at the specified index.
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateKinChains | Delete all rKinChain instances from controller and executors.
Public method | ScheduleCustomSimulationUpdate | Request a CustomSimulationUpdate event to be triggered when the robot's component is updated during simulation, or at the specified time.
Public method | SetJointValues | Sets the robot joint values.
Public method | SetJointValuesInRadians | Sets the robot joint values.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartHeartbeat | Start receiving heartbeat events
Public method | StopHeartbeat | Stop receiving heartbeat events
Public method | UpdateJointLimitHighlights | Updates highlighting of joint nodes if values exceed their limits.
Top
Events
 | Name | Description
Public event | CurrentStateChange | Event triggered at each state change.
Public event | CurrentStateInvalidated | Event triggered when CurrentState gets invalidated.
Public event | CustomSimulationUpdate | Event triggered on simulation update.
Public event | DofValueChanged | Event triggered when the value any associated instance of IDof changes.
Public event | Heartbeat | Event triggered at each heartbeat of servo.
Public event | JointAdded | Event triggered when a joint was added to this controller.
Public event | JointRemoved | Event triggered when a joint was removed from this controller.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IServoController Properties

The IServoController type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CurrentState | Current kinematic chain state.
Public property | CustomSimulationUpdateTime | Last time value passed to ScheduleCustomSimulationUpdate().
Public property | Dofs | List of DOFs used by the controller.
Public property | ExternalJoints | List of imported external joints.
Public property | FlangeNode | Gets or sets the flange node
Public property | HeartbeatTime | Gets or sets heartbeat interval
Public property | IsConnected | Indicates whether the servo is connected to another servo
Public property | IsValid | (Inherited from IWrapper.)
Public property | Joints | List of joints implemented in the controller.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | RootNode | Gets or sets the root node
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Public property | UsesCustomSimulationUpdate | Indicates that ScheduleCustomSimulationUpdate() was called.
Public property | UsesHeartbeat | Defines if controller updates movements on a heartbeat rate. Normally updating is done when required.
Top
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController.CurrentState Property

IServoControllerCurrentState Property

Current kinematic chain state.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPropertyContainer CurrentState { get; }
property IPropertyContainer^ CurrentState {
    IPropertyContainer^ get ();
}

Property Value

Type: IPropertyContainer
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController.CustomSimulationUpdateTime Property

IServoControllerCustomSimulationUpdateTime Property

Last time value passed to ScheduleCustomSimulationUpdate().

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double CustomSimulationUpdateTime { get; }
property double CustomSimulationUpdateTime {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController.Dofs Property

IServoControllerDofs Property

List of DOFs used by the controller.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IDof> Dofs { get; }
property IList<IDof^>^ Dofs {
    IList<IDof^>^ get ();
}

Property Value

Type: IListIDof
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController.ExternalJoints Property

IServoControllerExternalJoints Property

List of imported external joints.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IJoint> ExternalJoints { get; }
property IList<IJoint^>^ ExternalJoints {
    IList<IJoint^>^ get ();
}

Property Value

Type: IListIJoint
Remarks

Joints can be imported into a servo or robot controller through joint export fields in a sim interface object.

See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController.FlangeNode Property

IServoControllerFlangeNode Property

Gets or sets the flange node

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode FlangeNode { get; set; }
property ISimNode^ FlangeNode {
    ISimNode^ get ();
    void set (ISimNode^ value);
}

Property Value

Type: ISimNode
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController.HeartbeatTime Property

IServoControllerHeartbeatTime Property

Gets or sets heartbeat interval

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double HeartbeatTime { get; set; }
property double HeartbeatTime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController.IsConnected Property

IServoControllerIsConnected Property

Indicates whether the servo is connected to another servo

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsConnected { get; }
property bool IsConnected {
    bool get ();
}

Property Value

Type: Boolean
Remarks

A servo or robot controller can be connected to another controller by the simulation interface joint export field.

Joints may not be modified in a servo controller while it is connected to another controller

See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController.Joints Property

IServoControllerJoints Property

List of joints implemented in the controller.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IJoint> Joints { get; }
property IList<IJoint^>^ Joints {
    IList<IJoint^>^ get ();
}

Property Value

Type: IListIJoint
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController.RootNode Property

IServoControllerRootNode Property

Gets or sets the root node

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode RootNode { get; set; }
property ISimNode^ RootNode {
    ISimNode^ get ();
    void set (ISimNode^ value);
}

Property Value

Type: ISimNode
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController.UsesCustomSimulationUpdate Property

IServoControllerUsesCustomSimulationUpdate Property

Indicates that ScheduleCustomSimulationUpdate() was called.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool UsesCustomSimulationUpdate { get; set; }
property bool UsesCustomSimulationUpdate {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController.UsesHeartbeat Property

IServoControllerUsesHeartbeat Property

Defines if controller updates movements on a heartbeat rate. Normally updating is done when required.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool UsesHeartbeat { get; set; }
property bool UsesHeartbeat {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController Methods

The IServoController type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateJoint | Create a new joint, and add it to the end of the joint list.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteJoint | Delete the specified joint.
Public method | DeleteJointAt | Delete the joint at the specified index.
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateKinChains | Delete all rKinChain instances from controller and executors.
Public method | ScheduleCustomSimulationUpdate | Request a CustomSimulationUpdate event to be triggered when the robot's component is updated during simulation, or at the specified time.
Public method | SetJointValues | Sets the robot joint values.
Public method | SetJointValuesInRadians | Sets the robot joint values.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartHeartbeat | Start receiving heartbeat events
Public method | StopHeartbeat | Stop receiving heartbeat events
Public method | UpdateJointLimitHighlights | Updates highlighting of joint nodes if values exceed their limits.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController.CreateJoint Method

IServoControllerCreateJoint Method

Create a new joint, and add it to the end of the joint list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IJoint CreateJoint(
    IDof dof
)
IJoint^ CreateJoint(
    IDof^ dof
)

Parameters

dof
Type: VisualComponents.Create3DIDof
DOF object to use. If null, a dummy DOF is created.

Return Value

Type: IJoint
The newly created joint.
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController.DeleteJoint Method

IServoControllerDeleteJoint Method

Delete the specified joint.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteJoint(
    IJoint joint
)
void DeleteJoint(
    IJoint^ joint
)

Parameters

joint
Type: VisualComponents.Create3DIJoint
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController.DeleteJointAt Method

IServoControllerDeleteJointAt Method

Delete the joint at the specified index.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteJointAt(
    int index
)
void DeleteJointAt(
    int index
)

Parameters

index
Type: SystemInt32
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController.InvalidateKinChains Method

IServoControllerInvalidateKinChains Method

Delete all rKinChain instances from controller and executors.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void InvalidateKinChains()
void InvalidateKinChains()
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController.ScheduleCustomSimulationUpdate Method

IServoControllerScheduleCustomSimulationUpdate Method

Request a CustomSimulationUpdate event to be triggered when the robot's component is updated during simulation, or at the specified time.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ScheduleCustomSimulationUpdate(
    CustomSimulationUpdateType condition,
    double time
)
void ScheduleCustomSimulationUpdate(
    CustomSimulationUpdateType condition,
    double time
)

Parameters

condition
Type: VisualComponents.Create3DCustomSimulationUpdateType
time
Type: SystemDouble
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController.SetJointValues Method

IServoControllerSetJointValues Method

Sets the robot joint values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetJointValues(
    IEnumerable<double> jointValues
)
void SetJointValues(
    IEnumerable<double>^ jointValues
)

Parameters

jointValues
Type: System.Collections.GenericIEnumerableDouble
Joint values
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController.SetJointValuesInRadians Method

IServoControllerSetJointValuesInRadians Method

Sets the robot joint values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetJointValuesInRadians(
    IEnumerable<double> jointValues
)
void SetJointValuesInRadians(
    IEnumerable<double>^ jointValues
)

Parameters

jointValues
Type: System.Collections.GenericIEnumerableDouble
Joint values where rotational values are exressed in radians.
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController.StartHeartbeat Method

IServoControllerStartHeartbeat Method

Start receiving heartbeat events

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StartHeartbeat()
void StartHeartbeat()
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController.StopHeartbeat Method

IServoControllerStopHeartbeat Method

Stop receiving heartbeat events

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StopHeartbeat()
void StopHeartbeat()
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController.UpdateJointLimitHighlights Method

IServoControllerUpdateJointLimitHighlights Method

Updates highlighting of joint nodes if values exceed their limits.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateJointLimitHighlights()
void UpdateJointLimitHighlights()
Remarks
This has no effect if joint limit check highlighting is not enabled.>
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController Events

The IServoController type exposes the following members.

Events
 | Name | Description
Public event | CurrentStateChange | Event triggered at each state change.
Public event | CurrentStateInvalidated | Event triggered when CurrentState gets invalidated.
Public event | CustomSimulationUpdate | Event triggered on simulation update.
Public event | DofValueChanged | Event triggered when the value any associated instance of IDof changes.
Public event | Heartbeat | Event triggered at each heartbeat of servo.
Public event | JointAdded | Event triggered when a joint was added to this controller.
Public event | JointRemoved | Event triggered when a joint was removed from this controller.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController.CurrentStateChange Event

IServoControllerCurrentStateChange Event

Event triggered at each state change.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> CurrentStateChange
 event EventHandler<EventArgs^>^ CurrentStateChange {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController.CurrentStateInvalidated Event

IServoControllerCurrentStateInvalidated Event

Event triggered when CurrentState gets invalidated.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler CurrentStateInvalidated
 event EventHandler^ CurrentStateInvalidated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController.CustomSimulationUpdate Event

IServoControllerCustomSimulationUpdate Event

Event triggered on simulation update.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<CustomSimulationUpdateEventArgs> CustomSimulationUpdate
 event EventHandler<CustomSimulationUpdateEventArgs^>^ CustomSimulationUpdate {
    void add (EventHandler<CustomSimulationUpdateEventArgs^>^ value);
    void remove (EventHandler<CustomSimulationUpdateEventArgs^>^ value);
}

Value

Type: SystemEventHandlerCustomSimulationUpdateEventArgs
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController.DofValueChanged Event

IServoControllerDofValueChanged Event

Event triggered when the value any associated instance of IDof changes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> DofValueChanged
 event EventHandler<EventArgs^>^ DofValueChanged {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController.Heartbeat Event

IServoControllerHeartbeat Event

Event triggered at each heartbeat of servo.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<HeartbeatEventArgs> Heartbeat
 event EventHandler<HeartbeatEventArgs^>^ Heartbeat {
    void add (EventHandler<HeartbeatEventArgs^>^ value);
    void remove (EventHandler<HeartbeatEventArgs^>^ value);
}

Value

Type: SystemEventHandlerHeartbeatEventArgs
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController.JointAdded Event

IServoControllerJointAdded Event

Event triggered when a joint was added to this controller.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<JointAddedEventArgs> JointAdded
 event EventHandler<JointAddedEventArgs^>^ JointAdded {
    void add (EventHandler<JointAddedEventArgs^>^ value);
    void remove (EventHandler<JointAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerJointAddedEventArgs
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


IServoController.JointRemoved Event

IServoControllerJointRemoved Event

Event triggered when a joint was removed from this controller.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<JointRemovedEventArgs> JointRemoved
 event EventHandler<JointRemovedEventArgs^>^ JointRemoved {
    void add (EventHandler<JointRemovedEventArgs^>^ value);
    void remove (EventHandler<JointRemovedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerJointRemovedEventArgs
See Also

Reference

IServoController Interface
VisualComponents.Create3D Namespace


ISetBaseStatement Interface

Interface for set base statement

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISetBaseStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class ISetBaseStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The ISetBaseStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | Base | IRobotFrame to be defined by the statement.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | InitToDefaultsOnBaseChange | If true, Position, Node, and InterpolationMode properties are read from the base frame when the Base value changes.
Public property | InterpolationMode | Defines the interpolation mode for a base.
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsRelative | Specifies if the base position change is relative to its current position. If this flag is checked, the Position property is added to the current position of the base, and the Node property is ignored.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | ISimNode to attach the base frame to. If null the base is attached to the robot world frame.
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Position | Base frame position relative to the node it is attached to.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISetBaseStatement Properties

The ISetBaseStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | Base | IRobotFrame to be defined by the statement.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | InitToDefaultsOnBaseChange | If true, Position, Node, and InterpolationMode properties are read from the base frame when the Base value changes.
Public property | InterpolationMode | Defines the interpolation mode for a base.
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsRelative | Specifies if the base position change is relative to its current position. If this flag is checked, the Position property is added to the current position of the base, and the Node property is ignored.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | ISimNode to attach the base frame to. If null the base is attached to the robot world frame.
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Position | Base frame position relative to the node it is attached to.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
See Also

Reference

ISetBaseStatement Interface
VisualComponents.Create3D Namespace


ISetBaseStatement.Base Property

ISetBaseStatementBase Property

IRobotFrame to be defined by the statement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotFrame Base { get; set; }
property IRobotFrame^ Base {
    IRobotFrame^ get ();
    void set (IRobotFrame^ value);
}

Property Value

Type: IRobotFrame
See Also

Reference

ISetBaseStatement Interface
VisualComponents.Create3D Namespace


ISetBaseStatement.InitToDefaultsOnBaseChange Property

ISetBaseStatementInitToDefaultsOnBaseChange Property

If true, Position, Node, and InterpolationMode properties are read from the base frame when the Base value changes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool InitToDefaultsOnBaseChange { get; set; }
property bool InitToDefaultsOnBaseChange {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISetBaseStatement Interface
VisualComponents.Create3D Namespace


ISetBaseStatement.InterpolationMode Property

ISetBaseStatementInterpolationMode Property

Defines the interpolation mode for a base.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
RobotFrameIpoMode InterpolationMode { get; set; }
property RobotFrameIpoMode InterpolationMode {
    RobotFrameIpoMode get ();
    void set (RobotFrameIpoMode value);
}

Property Value

Type: RobotFrameIpoMode
See Also

Reference

ISetBaseStatement Interface
VisualComponents.Create3D Namespace


ISetBaseStatement.IsRelative Property

ISetBaseStatementIsRelative Property

Specifies if the base position change is relative to its current position. If this flag is checked, the Position property is added to the current position of the base, and the Node property is ignored.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsRelative { get; set; }
property bool IsRelative {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISetBaseStatement Interface
VisualComponents.Create3D Namespace


ISetBaseStatement.Node Property

ISetBaseStatementNode Property

ISimNode to attach the base frame to. If null the base is attached to the robot world frame.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode Node { get; set; }
property ISimNode^ Node {
    ISimNode^ get ();
    void set (ISimNode^ value);
}

Property Value

Type: ISimNode
See Also

Reference

ISetBaseStatement Interface
VisualComponents.Create3D Namespace


ISetBaseStatement.Position Property

ISetBaseStatementPosition Property

Base frame position relative to the node it is attached to.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix Position { get; set; }
property Matrix Position {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

ISetBaseStatement Interface
VisualComponents.Create3D Namespace


ISetBaseStatement Methods

The ISetBaseStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISetBaseStatement Interface
VisualComponents.Create3D Namespace


ISetBaseStatement Events

The ISetBaseStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

ISetBaseStatement Interface
VisualComponents.Create3D Namespace


ISetDigitalOutputStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISetDigitalOutputStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class ISetDigitalOutputStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The ISetDigitalOutputStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | OutputPort |
Public property | OutputValue |
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISetDigitalOutputStatement Properties

The ISetDigitalOutputStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | OutputPort |
Public property | OutputValue |
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
See Also

Reference

ISetDigitalOutputStatement Interface
VisualComponents.Create3D Namespace


ISetDigitalOutputStatement.OutputPort Property

ISetDigitalOutputStatementOutputPort Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int OutputPort { get; set; }
property int OutputPort {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ISetDigitalOutputStatement Interface
VisualComponents.Create3D Namespace


ISetDigitalOutputStatement.OutputValue Property

ISetDigitalOutputStatementOutputValue Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool OutputValue { get; set; }
property bool OutputValue {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISetDigitalOutputStatement Interface
VisualComponents.Create3D Namespace


ISetDigitalOutputStatement Methods

The ISetDigitalOutputStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISetDigitalOutputStatement Interface
VisualComponents.Create3D Namespace


ISetDigitalOutputStatement Events

The ISetDigitalOutputStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

ISetDigitalOutputStatement Interface
VisualComponents.Create3D Namespace


ISetNodeMaterialStatement Interface

Process statement for changing IMaterial of an ISimNode in an ISimProduct instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISetNodeMaterialStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class ISetNodeMaterialStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The ISetNodeMaterialStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | Force | Gets or sets whether to force IMaterial inheritance in the ISimNode.
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Material | Gets or sets the IMaterial to assign to the ISimNode.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeName | Name of the ISimNode in Component to assign the IMaterial to.
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductVariableName | Gets or sets the name of the Process variable that contains one or more references to ISimProduct objects. This statement will set the IMaterial of these objects, also considering the other parameters.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISetNodeMaterialStatement Properties

The ISetNodeMaterialStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | Force | Gets or sets whether to force IMaterial inheritance in the ISimNode.
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Material | Gets or sets the IMaterial to assign to the ISimNode.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeName | Name of the ISimNode in Component to assign the IMaterial to.
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductVariableName | Gets or sets the name of the Process variable that contains one or more references to ISimProduct objects. This statement will set the IMaterial of these objects, also considering the other parameters.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
See Also

Reference

ISetNodeMaterialStatement Interface
VisualComponents.Create3D Namespace


ISetNodeMaterialStatement.Force Property

ISetNodeMaterialStatementForce Property

Gets or sets whether to force IMaterial inheritance in the ISimNode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool Force { get; set; }
property bool Force {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISetNodeMaterialStatement Interface
VisualComponents.Create3D Namespace


ISetNodeMaterialStatement.Material Property

ISetNodeMaterialStatementMaterial Property

Gets or sets the IMaterial to assign to the ISimNode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMaterial Material { get; set; }
property IMaterial^ Material {
    IMaterial^ get ();
    void set (IMaterial^ value);
}

Property Value

Type: IMaterial
See Also

Reference

ISetNodeMaterialStatement Interface
VisualComponents.Create3D Namespace


ISetNodeMaterialStatement.NodeName Property

ISetNodeMaterialStatementNodeName Property

Name of the ISimNode in Component to assign the IMaterial to.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string NodeName { get; set; }
property String^ NodeName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown if trying to set a null value
Remarks
An empty string means to set the IMaterial of the ISimComponent's root node.
See Also

Reference

ISetNodeMaterialStatement Interface
VisualComponents.Create3D Namespace


ISetNodeMaterialStatement.ProductVariableName Property

ISetNodeMaterialStatementProductVariableName Property

Gets or sets the name of the Process variable that contains one or more references to ISimProduct objects.

This statement will set the IMaterial of these objects, also considering the other parameters.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ProductVariableName { get; set; }
property String^ ProductVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown if trying to set a null value
See Also

Reference

ISetNodeMaterialStatement Interface
VisualComponents.Create3D Namespace


ISetNodeMaterialStatement Methods

The ISetNodeMaterialStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISetNodeMaterialStatement Interface
VisualComponents.Create3D Namespace


ISetNodeMaterialStatement Events

The ISetNodeMaterialStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

ISetNodeMaterialStatement Interface
VisualComponents.Create3D Namespace


ISetNodeVisibilityStatement Interface

A process statement for changing the visibility of an ISimNode in one or more ISimProducts.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISetNodeVisibilityStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class ISetNodeVisibilityStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The ISetNodeVisibilityStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeName | Name of the ISimNode in Component to assign the material to.
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductVariableName | Gets or sets the name of the Process variable containing one or more references to ISimProduct objects where the material should be set.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | Visibility | How to change the affected ISimNodes' visibility.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISetNodeVisibilityStatement Properties

The ISetNodeVisibilityStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeName | Name of the ISimNode in Component to assign the material to.
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductVariableName | Gets or sets the name of the Process variable containing one or more references to ISimProduct objects where the material should be set.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | Visibility | How to change the affected ISimNodes' visibility.
Top
See Also

Reference

ISetNodeVisibilityStatement Interface
VisualComponents.Create3D Namespace


ISetNodeVisibilityStatement.NodeName Property

ISetNodeVisibilityStatementNodeName Property

Name of the ISimNode in Component to assign the material to.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string NodeName { get; set; }
property String^ NodeName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown if trying to set a null value
Remarks
An empty string means to set material of the ISimComponent's root node.
See Also

Reference

ISetNodeVisibilityStatement Interface
VisualComponents.Create3D Namespace


ISetNodeVisibilityStatement.ProductVariableName Property

ISetNodeVisibilityStatementProductVariableName Property

Gets or sets the name of the Process variable containing one or more references to ISimProduct objects where the material should be set.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ProductVariableName { get; set; }
property String^ ProductVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown if trying to set a null value
See Also

Reference

ISetNodeVisibilityStatement Interface
VisualComponents.Create3D Namespace


ISetNodeVisibilityStatement.Visibility Property

ISetNodeVisibilityStatementVisibility Property

How to change the affected ISimNodes' visibility.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
NodeVisibilityStateChange Visibility { get; set; }
property NodeVisibilityStateChange Visibility {
    NodeVisibilityStateChange get ();
    void set (NodeVisibilityStateChange value);
}

Property Value

Type: NodeVisibilityStateChange
See Also

Reference

ISetNodeVisibilityStatement Interface
VisualComponents.Create3D Namespace


ISetNodeVisibilityStatement Methods

The ISetNodeVisibilityStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISetNodeVisibilityStatement Interface
VisualComponents.Create3D Namespace


ISetNodeVisibilityStatement Events

The ISetNodeVisibilityStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

ISetNodeVisibilityStatement Interface
VisualComponents.Create3D Namespace


ISetPropertyStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISetPropertyStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class ISetPropertyStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The ISetPropertyStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | TargetPropertyName |
Public property | TargetValueExpression |
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISetPropertyStatement Properties

The ISetPropertyStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | TargetPropertyName |
Public property | TargetValueExpression |
Top
See Also

Reference

ISetPropertyStatement Interface
VisualComponents.Create3D Namespace


ISetPropertyStatement.TargetPropertyName Property

ISetPropertyStatementTargetPropertyName Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string TargetPropertyName { get; set; }
property String^ TargetPropertyName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ISetPropertyStatement Interface
VisualComponents.Create3D Namespace


ISetPropertyStatement.TargetValueExpression Property

ISetPropertyStatementTargetValueExpression Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string TargetValueExpression { get; set; }
property String^ TargetValueExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ISetPropertyStatement Interface
VisualComponents.Create3D Namespace


ISetPropertyStatement Methods

The ISetPropertyStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISetPropertyStatement Interface
VisualComponents.Create3D Namespace


ISetPropertyStatement Events

The ISetPropertyStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

ISetPropertyStatement Interface
VisualComponents.Create3D Namespace


ISetStatisticsFlowStatement Interface

Controls flow-type statistics for individual ISimProducts in the machine.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISetStatisticsFlowStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class ISetStatisticsFlowStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The ISetStatisticsFlowStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | FlowDirection | Gets or sets statistics flow to be set. Defines the direction of product's transfer (in/out) which should be recorded by Statistics behavior.
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductVariableName | Gets or sets the name of the process variable that holds the ISimProduct instance to flow.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | Statistics | Gets or sets IStatistics behavior to record the flow.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISetStatisticsFlowStatement Properties

The ISetStatisticsFlowStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | FlowDirection | Gets or sets statistics flow to be set. Defines the direction of product's transfer (in/out) which should be recorded by Statistics behavior.
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductVariableName | Gets or sets the name of the process variable that holds the ISimProduct instance to flow.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | Statistics | Gets or sets IStatistics behavior to record the flow.
Top
See Also

Reference

ISetStatisticsFlowStatement Interface
VisualComponents.Create3D Namespace


ISetStatisticsFlowStatement.FlowDirection Property

ISetStatisticsFlowStatementFlowDirection Property

Gets or sets statistics flow to be set. Defines the direction of product's transfer (in/out) which should be recorded by Statistics behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
StatisticsFlowDirection FlowDirection { get; set; }
property StatisticsFlowDirection FlowDirection {
    StatisticsFlowDirection get ();
    void set (StatisticsFlowDirection value);
}

Property Value

Type: StatisticsFlowDirection
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown by setter when an invalid value is supplied.
See Also

Reference

ISetStatisticsFlowStatement Interface
VisualComponents.Create3D Namespace


ISetStatisticsFlowStatement.ProductVariableName Property

ISetStatisticsFlowStatementProductVariableName Property

Gets or sets the name of the process variable that holds the ISimProduct instance to flow.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ProductVariableName { get; set; }
property String^ ProductVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown by setter when supplied value is null.
See Also

Reference

ISetStatisticsFlowStatement Interface
VisualComponents.Create3D Namespace


ISetStatisticsFlowStatement.Statistics Property

ISetStatisticsFlowStatementStatistics Property

Gets or sets IStatistics behavior to record the flow.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatistics Statistics { get; set; }
property IStatistics^ Statistics {
    IStatistics^ get ();
    void set (IStatistics^ value);
}

Property Value

Type: IStatistics
See Also

Reference

ISetStatisticsFlowStatement Interface
VisualComponents.Create3D Namespace


ISetStatisticsFlowStatement Methods

The ISetStatisticsFlowStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISetStatisticsFlowStatement Interface
VisualComponents.Create3D Namespace


ISetStatisticsFlowStatement Events

The ISetStatisticsFlowStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

ISetStatisticsFlowStatement Interface
VisualComponents.Create3D Namespace


ISetStatisticsStateStatement Interface

Sets statistical state of the machine.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISetStatisticsStateStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class ISetStatisticsStateStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The ISetStatisticsStateStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | State | Gets custom statistics state to be set. This state is guaranteed to exist in Statistics behavior. Returns null otherwise.
Public property | StateName | Gets or sets the name of the custom statistics state to be set.
Public property | Statistics | Gets or sets IStatistics behavior to set the state of.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISetStatisticsStateStatement Properties

The ISetStatisticsStateStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | State | Gets custom statistics state to be set. This state is guaranteed to exist in Statistics behavior. Returns null otherwise.
Public property | StateName | Gets or sets the name of the custom statistics state to be set.
Public property | Statistics | Gets or sets IStatistics behavior to set the state of.
Top
See Also

Reference

ISetStatisticsStateStatement Interface
VisualComponents.Create3D Namespace


ISetStatisticsStateStatement.State Property

ISetStatisticsStateStatementState Property

Gets custom statistics state to be set. This state is guaranteed to exist in Statistics behavior. Returns null otherwise.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatisticsState State { get; }
property IStatisticsState^ State {
    IStatisticsState^ get ();
}

Property Value

Type: IStatisticsState
See Also

Reference

ISetStatisticsStateStatement Interface
VisualComponents.Create3D Namespace


ISetStatisticsStateStatement.StateName Property

ISetStatisticsStateStatementStateName Property

Gets or sets the name of the custom statistics state to be set.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string StateName { get; set; }
property String^ StateName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ISetStatisticsStateStatement Interface
VisualComponents.Create3D Namespace


ISetStatisticsStateStatement.Statistics Property

ISetStatisticsStateStatementStatistics Property

Gets or sets IStatistics behavior to set the state of.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatistics Statistics { get; set; }
property IStatistics^ Statistics {
    IStatistics^ get ();
    void set (IStatistics^ value);
}

Property Value

Type: IStatistics
See Also

Reference

ISetStatisticsStateStatement Interface
VisualComponents.Create3D Namespace


ISetStatisticsStateStatement Methods

The ISetStatisticsStateStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISetStatisticsStateStatement Interface
VisualComponents.Create3D Namespace


ISetStatisticsStateStatement Events

The ISetStatisticsStateStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

ISetStatisticsStateStatement Interface
VisualComponents.Create3D Namespace


ISetToolStatement Interface

Interface for set tool statement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISetToolStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class ISetToolStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The ISetToolStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | InitToDefaultsOnToolChange | If true, Position, Node, and InterpolationMode properties are read from the tool frame when the Tool value changes.
Public property | InterpolationMode | Defines the interpolation mode for a base.
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsRelative | Specifies if the base position change is relative to its current position. If this flag is checked, the Position property is added to the current position of the base, and the Node property is ignored.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | ISimNode to attach the base frame to. If null the base is attached to the robot world frame.
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Position | Base frame position relative to the node it is attached to.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | Tool | IRobotFrame to be defined by the statement.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISetToolStatement Properties

The ISetToolStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | InitToDefaultsOnToolChange | If true, Position, Node, and InterpolationMode properties are read from the tool frame when the Tool value changes.
Public property | InterpolationMode | Defines the interpolation mode for a base.
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsRelative | Specifies if the base position change is relative to its current position. If this flag is checked, the Position property is added to the current position of the base, and the Node property is ignored.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | ISimNode to attach the base frame to. If null the base is attached to the robot world frame.
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Position | Base frame position relative to the node it is attached to.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | Tool | IRobotFrame to be defined by the statement.
Top
See Also

Reference

ISetToolStatement Interface
VisualComponents.Create3D Namespace


ISetToolStatement.InitToDefaultsOnToolChange Property

ISetToolStatementInitToDefaultsOnToolChange Property

If true, Position, Node, and InterpolationMode properties are read from the tool frame when the Tool value changes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool InitToDefaultsOnToolChange { get; set; }
property bool InitToDefaultsOnToolChange {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISetToolStatement Interface
VisualComponents.Create3D Namespace


ISetToolStatement.InterpolationMode Property

ISetToolStatementInterpolationMode Property

Defines the interpolation mode for a base.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
RobotFrameIpoMode InterpolationMode { get; set; }
property RobotFrameIpoMode InterpolationMode {
    RobotFrameIpoMode get ();
    void set (RobotFrameIpoMode value);
}

Property Value

Type: RobotFrameIpoMode
See Also

Reference

ISetToolStatement Interface
VisualComponents.Create3D Namespace


ISetToolStatement.IsRelative Property

ISetToolStatementIsRelative Property

Specifies if the base position change is relative to its current position. If this flag is checked, the Position property is added to the current position of the base, and the Node property is ignored.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsRelative { get; set; }
property bool IsRelative {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISetToolStatement Interface
VisualComponents.Create3D Namespace


ISetToolStatement.Node Property

ISetToolStatementNode Property

ISimNode to attach the base frame to. If null the base is attached to the robot world frame.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode Node { get; set; }
property ISimNode^ Node {
    ISimNode^ get ();
    void set (ISimNode^ value);
}

Property Value

Type: ISimNode
See Also

Reference

ISetToolStatement Interface
VisualComponents.Create3D Namespace


ISetToolStatement.Position Property

ISetToolStatementPosition Property

Base frame position relative to the node it is attached to.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix Position { get; set; }
property Matrix Position {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

ISetToolStatement Interface
VisualComponents.Create3D Namespace


ISetToolStatement.Tool Property

ISetToolStatementTool Property

IRobotFrame to be defined by the statement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotFrame Tool { get; set; }
property IRobotFrame^ Tool {
    IRobotFrame^ get ();
    void set (IRobotFrame^ value);
}

Property Value

Type: IRobotFrame
See Also

Reference

ISetToolStatement Interface
VisualComponents.Create3D Namespace


ISetToolStatement Methods

The ISetToolStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISetToolStatement Interface
VisualComponents.Create3D Namespace


ISetToolStatement Events

The ISetToolStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

ISetToolStatement Interface
VisualComponents.Create3D Namespace


ISharedCloneable Interface

Interface for objects that can share data when being cloned.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISharedCloneable
public interface class ISharedCloneable

The ISharedCloneable type exposes the following members.

Properties
 | Name | Description
Public property | IsSharedClone | Indicates if this object shares data with another object.
Public property | SharingId | Sharing ID of the shared data.
Top
Methods
 | Name | Description
Public method | Clone(CloningMode) | Create a clone of the object.
Public method | Clone(CloningMode, Boolean) | Create a clone of the object.
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent.
Public method | MakeUnique | Ensure that this object shares no data with other objects.
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISharedCloneable Properties

The ISharedCloneable type exposes the following members.

Properties
 | Name | Description
Public property | IsSharedClone | Indicates if this object shares data with another object.
Public property | SharingId | Sharing ID of the shared data.
Top
See Also

Reference

ISharedCloneable Interface
VisualComponents.Create3D Namespace


ISharedCloneable.IsSharedClone Property

ISharedCloneableIsSharedClone Property

Indicates if this object shares data with another object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsSharedClone { get; }
property bool IsSharedClone {
    bool get ();
}

Property Value

Type: Boolean
Remarks

A shared clone uses less memory than a clone with its own copy of the data, but is also limited in that some settings are shared as well.

A component that is a shared clone shares the feature tree and node structures. In practice, this means that a component must be made unique before changing any features, or changing any parameters that cause a component rebuild, otherwise all components that have the same sharing ID (i.e. share the same data) are affected.

See Also

Reference

ISharedCloneable Interface
VisualComponents.Create3D Namespace


ISharedCloneable.SharingId Property

ISharedCloneableSharingId Property

Sharing ID of the shared data.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
long SharingId { get; }
property long long SharingId {
    long long get ();
}

Property Value

Type: Int64
Remarks
Objects with the same sharing ID share the same data. The sharing ID is unique to the shared data during the lifetime of the object in the session.
See Also

Reference

ISharedCloneable Interface
VisualComponents.Create3D Namespace


ISharedCloneable Methods

The ISharedCloneable type exposes the following members.

Methods
 | Name | Description
Public method | Clone(CloningMode) | Create a clone of the object.
Public method | Clone(CloningMode, Boolean) | Create a clone of the object.
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent.
Public method | MakeUnique | Ensure that this object shares no data with other objects.
Top
See Also

Reference

ISharedCloneable Interface
VisualComponents.Create3D Namespace


ISharedCloneable.Clone Method

ISharedCloneableClone Method

Overload List
 | Name | Description
Public method | Clone(CloningMode) | Create a clone of the object.
Public method | Clone(CloningMode, Boolean) | Create a clone of the object.
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent.
Top
See Also

Reference

ISharedCloneable Interface
VisualComponents.Create3D Namespace


ISharedCloneable.Clone Method (CloningMode)

ISharedCloneableClone Method (CloningMode)

Create a clone of the object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISharedCloneable Clone(
    CloningMode mode
)
ISharedCloneable^ Clone(
    CloningMode mode
)

Parameters

mode
Type: VisualComponents.Create3DCloningMode
Cloning mode to use.

Return Value

Type: ISharedCloneable
The newly created clone.
Remarks
In the case of components, the cloned component is attached to the world root node.
See Also

Reference

ISharedCloneable Interface
Clone Overload
VisualComponents.Create3D Namespace


ISharedCloneable.Clone Method (CloningMode, Boolean)

ISharedCloneableClone Method (CloningMode, Boolean)

Create a clone of the object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISharedCloneable Clone(
    CloningMode mode,
    bool cloneChildren
)
ISharedCloneable^ Clone(
    CloningMode mode,
    bool cloneChildren
)

Parameters

mode
Type: VisualComponents.Create3DCloningMode
Cloning mode to use.
cloneChildren
Type: SystemBoolean
Defines if the object's children (if any) are cloned as well.

Return Value

Type: ISharedCloneable
The newly created clone.
Remarks
In the case of components, the cloned component is attached to the world root node, and the parameter cloneChildren referns only to children components
See Also

Reference

ISharedCloneable Interface
Clone Overload
VisualComponents.Create3D Namespace


ISharedCloneable.Clone Method (CloningMode, Boolean, ISharedCloneable)

ISharedCloneableClone Method (CloningMode, Boolean, ISharedCloneable)

Create a clone of the object and add it to a new parent.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISharedCloneable Clone(
    CloningMode mode,
    bool cloneChildren,
    ISharedCloneable targetParent
)
ISharedCloneable^ Clone(
    CloningMode mode,
    bool cloneChildren,
    ISharedCloneable^ targetParent
)

Parameters

mode
Type: VisualComponents.Create3DCloningMode
Cloning mode to use.
cloneChildren
Type: SystemBoolean
Defines if the object's children (if any) are cloned as well.
targetParent
Type: VisualComponents.Create3DISharedCloneable

Return Value

Type: ISharedCloneable
The newly created clone.
See Also

Reference

ISharedCloneable Interface
Clone Overload
VisualComponents.Create3D Namespace


ISharedCloneable.MakeUnique Method

ISharedCloneableMakeUnique Method

Ensure that this object shares no data with other objects.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool MakeUnique()
bool MakeUnique()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISharedCloneable.MakeUnique"]

See Also

Reference

ISharedCloneable Interface
VisualComponents.Create3D Namespace


IShutdownNotifier Interface

Notifies when shutting down.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IShutdownNotifier
public interface class IShutdownNotifier

The IShutdownNotifier type exposes the following members.

Events
 | Name | Description
Public event | IsAboutToShutdown | Raised when the the shutdown sequence has been initiated.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IShutdownNotifier Events

The IShutdownNotifier type exposes the following members.

Events
 | Name | Description
Public event | IsAboutToShutdown | Raised when the the shutdown sequence has been initiated.
Top
See Also

Reference

IShutdownNotifier Interface
VisualComponents.Create3D Namespace


IShutdownNotifier.IsAboutToShutdown Event

IShutdownNotifierIsAboutToShutdown Event

Raised when the the shutdown sequence has been initiated.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler IsAboutToShutdown
 event EventHandler^ IsAboutToShutdown {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IShutdownNotifier Interface
VisualComponents.Create3D Namespace


ISignal Interface

An interface for signal behavior. A signal is used to transmit information received from a sensor in a component or relay information between two or more components.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISignal : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class ISignal : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The ISignal type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsApplication | Defines if this ISignal instance has been created by the application for its internal use.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Public property | Value | Gets or sets the value of this ISignal instance.
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanConnectTo | Defines if this ISignal instance can be connected to the given signal.
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect | Connects the given ISignal instance to the given signal.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects this ISignal instance from the given signal.
Public method | DisconnectAll | Disconnects all ISignal instances connected to this signal.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | SignalTrigger | Event that is raised when the value of this ISignal instance is changing.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISignal Properties

The ISignal type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsApplication | Defines if this ISignal instance has been created by the application for its internal use.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Public property | Value | Gets or sets the value of this ISignal instance.
Top
See Also

Reference

ISignal Interface
VisualComponents.Create3D Namespace


ISignal.IsApplication Property

ISignalIsApplication Property

Defines if this ISignal instance has been created by the application for its internal use.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsApplication { get; }
property bool IsApplication {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISignal Interface
VisualComponents.Create3D Namespace


ISignal.Value Property

ISignalValue Property

Gets or sets the value of this ISignal instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object Value { get; set; }
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
Exceptions
Exception | Condition
ArgumentException | Thrown when given value is of invalid type.
See Also

Reference

ISignal Interface
VisualComponents.Create3D Namespace


ISignal Methods

The ISignal type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanConnectTo | Defines if this ISignal instance can be connected to the given signal.
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect | Connects the given ISignal instance to the given signal.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects this ISignal instance from the given signal.
Public method | DisconnectAll | Disconnects all ISignal instances connected to this signal.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISignal Interface
VisualComponents.Create3D Namespace


ISignal.CanConnectTo Method

ISignalCanConnectTo Method

Defines if this ISignal instance can be connected to the given signal.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanConnectTo(
    ISignal signal
)
bool CanConnectTo(
    ISignal^ signal
)

Parameters

signal
Type: VisualComponents.Create3DISignal
Signal to test.

Return Value

Type: Boolean
True if the given signal can be connected.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when signal parameter is null.
See Also

Reference

ISignal Interface
VisualComponents.Create3D Namespace


ISignal.Connect Method

ISignalConnect Method

Connects the given ISignal instance to the given signal.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool Connect(
    ISignal signal
)
bool Connect(
    ISignal^ signal
)

Parameters

signal
Type: VisualComponents.Create3DISignal
Signal to be connected.

Return Value

Type: Boolean
True if the signal could be connected.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when signal parameter is null.
See Also

Reference

ISignal Interface
VisualComponents.Create3D Namespace


ISignal.Disconnect Method

ISignalDisconnect Method

Disconnects this ISignal instance from the given signal.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool Disconnect(
    ISignal signal
)
bool Disconnect(
    ISignal^ signal
)

Parameters

signal
Type: VisualComponents.Create3DISignal
Signal to be disconnected.

Return Value

Type: Boolean
True if the signal could be disconnected.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when signal parameter is null.
See Also

Reference

ISignal Interface
VisualComponents.Create3D Namespace


ISignal.DisconnectAll Method

ISignalDisconnectAll Method

Disconnects all ISignal instances connected to this signal.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool DisconnectAll()
bool DisconnectAll()

Return Value

Type: Boolean
True if one or more signals were disconnected.
See Also

Reference

ISignal Interface
VisualComponents.Create3D Namespace


ISignal Events

The ISignal type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | SignalTrigger | Event that is raised when the value of this ISignal instance is changing.
Top
See Also

Reference

ISignal Interface
VisualComponents.Create3D Namespace


ISignal.SignalTrigger Event

ISignalSignalTrigger Event

Event that is raised when the value of this ISignal instance is changing.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<SignalTriggerEventArgs> SignalTrigger
 event EventHandler<SignalTriggerEventArgs^>^ SignalTrigger {
    void add (EventHandler<SignalTriggerEventArgs^>^ value);
    void remove (EventHandler<SignalTriggerEventArgs^>^ value);
}

Value

Type: SystemEventHandlerSignalTriggerEventArgs
See Also

Reference

ISignal Interface
VisualComponents.Create3D Namespace


ISignalMap Interface

Signal map behavior interface. Signal maps are used to signals to I/O space of IExecutor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISignalMap : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class ISignalMap : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The ISignalMap type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConnectedExternalPorts | Returns all the connected external ports. The return value is a collection of tuples where the first item is the internal port number number and the second item is a port number in connected external map.
Public property | ConnectedExternalSignals | Returns all the connected signals in external components. The return value is a collection of tuples where the first item is the internal port number number and the second item is an external signal connected to the port.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | MapCount | Gets the number of ports connected to ISignal instances. This matches SignalCount.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | PortCount | Gets the total number of ports in this signal map.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SignalCount | Gets the number of ISignal instances behind this signal map.
Public property | StartIndex | Gets the ports starting index.
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect(Int32, ISignal) | Connects the signal behind the given port to the given ISignal instance.
Public method | Connect(Int32, ISignalMap, Int32) | Connects the ISignal instance behind the given port to the signal behind the port behind the given map.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | CreateSignal | Creates a ISignal instance at the given port.
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteSignalConnection(Int32) | Deletes all ISignal instances connected to the signal at the given port. Also deletes disconnected application signals.
Public method | DeleteSignalConnection(Int32, Boolean) | Deletes all ISignal instances connected to the signal at the given port.
Public method | DeleteSignalConnection(Int32, Boolean, ISignal) | Disconnects the ISignal instance at the given port from the given signal. The signal will maintain its other connections (if any).
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects the ISignal instance behind the given port.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | FindSignalIndexesLocation | Gets the map indexes associated to the given ISignal instance.
Public method | FindSignalIndexLocation | Obsolete. This method is obsolete. Use FindSignalIndexesLocation(ISignal) instead.
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetPort | Returns the port number at the given map index. Works in opposite way than GetPortIndex(Int32).
Public method | GetPortIndex | Returns the map index of the port defined by port number. Works in opposite way than GetPort(Int32).
Public method | GetPortName | Returns the name of the port at the given map index.
Public method | GetPortValue | Reads the value from a port defined by the map index if there is a signal in that port.
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetSignal | Gets a ISignal instance behind the map at the given map index.
Public method | MapGetPortSignal | Gets the ISignal instance behind the given port number.
Public method | SetPortName | Sets a port name given map index Remarks There should be a signal in this port in order to associate a name
Public method | SetPortValue | Sends a signal to a port defined by map index.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetSignal | Associates a component signal into the given port
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | SignalValueChanged | Triggered when the value of the signal associated to the port changes.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISignalMap Properties

The ISignalMap type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConnectedExternalPorts | Returns all the connected external ports. The return value is a collection of tuples where the first item is the internal port number number and the second item is a port number in connected external map.
Public property | ConnectedExternalSignals | Returns all the connected signals in external components. The return value is a collection of tuples where the first item is the internal port number number and the second item is an external signal connected to the port.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | MapCount | Gets the number of ports connected to ISignal instances. This matches SignalCount.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | PortCount | Gets the total number of ports in this signal map.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SignalCount | Gets the number of ISignal instances behind this signal map.
Public property | StartIndex | Gets the ports starting index.
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

ISignalMap Interface
VisualComponents.Create3D Namespace


ISignalMap.ConnectedExternalPorts Property

ISignalMapConnectedExternalPorts Property

Returns all the connected external ports. The return value is a collection of tuples where the first item is the internal port number number and the second item is a port number in connected external map.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<Tuple<int, ISignalMap, int>> ConnectedExternalPorts { get; }
property ReadOnlyCollection<Tuple<int, ISignalMap^, int>^>^ ConnectedExternalPorts {
    ReadOnlyCollection<Tuple<int, ISignalMap^, int>^>^ get ();
}

Property Value

Type: ReadOnlyCollectionTupleInt32, ISignalMap, Int32
See Also

Reference

ISignalMap Interface
VisualComponents.Create3D Namespace


ISignalMap.ConnectedExternalSignals Property

ISignalMapConnectedExternalSignals Property

Returns all the connected signals in external components. The return value is a collection of tuples where the first item is the internal port number number and the second item is an external signal connected to the port.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<Tuple<int, ISignal>> ConnectedExternalSignals { get; }
property ReadOnlyCollection<Tuple<int, ISignal^>^>^ ConnectedExternalSignals {
    ReadOnlyCollection<Tuple<int, ISignal^>^>^ get ();
}

Property Value

Type: ReadOnlyCollectionTupleInt32, ISignal
See Also

Reference

ISignalMap Interface
VisualComponents.Create3D Namespace


ISignalMap.MapCount Property

ISignalMapMapCount Property

Gets the number of ports connected to ISignal instances. This matches SignalCount.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int MapCount { get; }
property int MapCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ISignalMap Interface
VisualComponents.Create3D Namespace


ISignalMap.PortCount Property

ISignalMapPortCount Property

Gets the total number of ports in this signal map.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int PortCount { get; }
property int PortCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ISignalMap Interface
VisualComponents.Create3D Namespace


ISignalMap.SignalCount Property

ISignalMapSignalCount Property

Gets the number of ISignal instances behind this signal map.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int SignalCount { get; }
property int SignalCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ISignalMap Interface
VisualComponents.Create3D Namespace


ISignalMap.StartIndex Property

ISignalMapStartIndex Property

Gets the ports starting index.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int StartIndex { get; }
property int StartIndex {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ISignalMap Interface
VisualComponents.Create3D Namespace


ISignalMap Methods

The ISignalMap type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect(Int32, ISignal) | Connects the signal behind the given port to the given ISignal instance.
Public method | Connect(Int32, ISignalMap, Int32) | Connects the ISignal instance behind the given port to the signal behind the port behind the given map.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | CreateSignal | Creates a ISignal instance at the given port.
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteSignalConnection(Int32) | Deletes all ISignal instances connected to the signal at the given port. Also deletes disconnected application signals.
Public method | DeleteSignalConnection(Int32, Boolean) | Deletes all ISignal instances connected to the signal at the given port.
Public method | DeleteSignalConnection(Int32, Boolean, ISignal) | Disconnects the ISignal instance at the given port from the given signal. The signal will maintain its other connections (if any).
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects the ISignal instance behind the given port.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | FindSignalIndexesLocation | Gets the map indexes associated to the given ISignal instance.
Public method | FindSignalIndexLocation | Obsolete. This method is obsolete. Use FindSignalIndexesLocation(ISignal) instead.
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetPort | Returns the port number at the given map index. Works in opposite way than GetPortIndex(Int32).
Public method | GetPortIndex | Returns the map index of the port defined by port number. Works in opposite way than GetPort(Int32).
Public method | GetPortName | Returns the name of the port at the given map index.
Public method | GetPortValue | Reads the value from a port defined by the map index if there is a signal in that port.
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetSignal | Gets a ISignal instance behind the map at the given map index.
Public method | MapGetPortSignal | Gets the ISignal instance behind the given port number.
Public method | SetPortName | Sets a port name given map index Remarks There should be a signal in this port in order to associate a name
Public method | SetPortValue | Sends a signal to a port defined by map index.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetSignal | Associates a component signal into the given port
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISignalMap Interface
VisualComponents.Create3D Namespace


ISignalMap.Connect Method

ISignalMapConnect Method

Overload List
 | Name | Description
Public method | Connect(Int32, ISignal) | Connects the signal behind the given port to the given ISignal instance.
Public method | Connect(Int32, ISignalMap, Int32) | Connects the ISignal instance behind the given port to the signal behind the port behind the given map.
Top
See Also

Reference

ISignalMap Interface
VisualComponents.Create3D Namespace


ISignalMap.Connect Method (Int32, ISignal)

ISignalMapConnect Method (Int32, ISignal)

Connects the signal behind the given port to the given ISignal instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Connect(
    int port,
    ISignal signalToConnect
)
void Connect(
    int port,
    ISignal^ signalToConnect
)

Parameters

port
Type: SystemInt32
Port number
signalToConnect
Type: VisualComponents.Create3DISignal
Signal to connect.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when signalToConnect parameter is null.
ArgumentOutOfRangeException | Thrown when port is out of bounds.
See Also

Reference

ISignalMap Interface
Connect Overload
VisualComponents.Create3D Namespace


ISignalMap.Connect Method (Int32, ISignalMap, Int32)

ISignalMapConnect Method (Int32, ISignalMap, Int32)

Connects the ISignal instance behind the given port to the signal behind the port behind the given map.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Connect(
    int port,
    ISignalMap mapToConnect,
    int portToConnect
)
void Connect(
    int port,
    ISignalMap^ mapToConnect,
    int portToConnect
)

Parameters

port
Type: SystemInt32
Port number in this signal map.
mapToConnect
Type: VisualComponents.Create3DISignalMap
Map to connect to.
portToConnect
Type: SystemInt32
Port to connect to.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when mapToConnect parameter is null.
ArgumentOutOfRangeException | Thrown when port or portToConnect is out of bounds.
See Also

Reference

ISignalMap Interface
Connect Overload
VisualComponents.Create3D Namespace


ISignalMap.CreateSignal Method

ISignalMapCreateSignal Method

Creates a ISignal instance at the given port.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISignal CreateSignal(
    int port
)
ISignal^ CreateSignal(
    int port
)

Parameters

port
Type: SystemInt32
Port number.

Return Value

Type: ISignal
Created signal.
See Also

Reference

ISignalMap Interface
VisualComponents.Create3D Namespace


ISignalMap.DeleteSignalConnection Method

ISignalMapDeleteSignalConnection Method

Overload List
 | Name | Description
Public method | DeleteSignalConnection(Int32) | Deletes all ISignal instances connected to the signal at the given port. Also deletes disconnected application signals.
Public method | DeleteSignalConnection(Int32, Boolean) | Deletes all ISignal instances connected to the signal at the given port.
Public method | DeleteSignalConnection(Int32, Boolean, ISignal) | Disconnects the ISignal instance at the given port from the given signal. The signal will maintain its other connections (if any).
Top
See Also

Reference

ISignalMap Interface
VisualComponents.Create3D Namespace


ISignalMap.DeleteSignalConnection Method (Int32)

ISignalMapDeleteSignalConnection Method (Int32)

Deletes all ISignal instances connected to the signal at the given port. Also deletes disconnected application signals.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteSignalConnection(
    int port
)
void DeleteSignalConnection(
    int port
)

Parameters

port
Type: SystemInt32
Port number.
See Also

Reference

ISignalMap Interface
DeleteSignalConnection Overload
VisualComponents.Create3D Namespace


ISignalMap.DeleteSignalConnection Method (Int32, Boolean)

ISignalMapDeleteSignalConnection Method (Int32, Boolean)

Deletes all ISignal instances connected to the signal at the given port.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteSignalConnection(
    int port,
    bool deleteConnectedApplicationSignals
)
void DeleteSignalConnection(
    int port,
    bool deleteConnectedApplicationSignals
)

Parameters

port
Type: SystemInt32
Port number.
deleteConnectedApplicationSignals
Type: SystemBoolean
Defines if disconnected application signals are deleted.
See Also

Reference

ISignalMap Interface
DeleteSignalConnection Overload
VisualComponents.Create3D Namespace


ISignalMap.DeleteSignalConnection Method (Int32, Boolean, ISignal)

ISignalMapDeleteSignalConnection Method (Int32, Boolean, ISignal)

Disconnects the ISignal instance at the given port from the given signal. The signal will maintain its other connections (if any).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteSignalConnection(
    int port,
    bool deleteConnectedApplicationSignals,
    ISignal signalToDisconnect
)
void DeleteSignalConnection(
    int port,
    bool deleteConnectedApplicationSignals,
    ISignal^ signalToDisconnect
)

Parameters

port
Type: SystemInt32
Port number.
deleteConnectedApplicationSignals
Type: SystemBoolean
Defines if disconnected application signals are deleted.
signalToDisconnect
Type: VisualComponents.Create3DISignal
Signal to disconnect.
See Also

Reference

ISignalMap Interface
DeleteSignalConnection Overload
VisualComponents.Create3D Namespace


ISignalMap.Disconnect Method

ISignalMapDisconnect Method

Disconnects the ISignal instance behind the given port.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Disconnect(
    int port
)
void Disconnect(
    int port
)

Parameters

port
Type: SystemInt32
Port number
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when port is out of bounds.
See Also

Reference

ISignalMap Interface
VisualComponents.Create3D Namespace


ISignalMap.FindSignalIndexesLocation Method

ISignalMapFindSignalIndexesLocation Method

Gets the map indexes associated to the given ISignal instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<int> FindSignalIndexesLocation(
    ISignal signal
)
ReadOnlyCollection<int>^ FindSignalIndexesLocation(
    ISignal^ signal
)

Parameters

signal
Type: VisualComponents.Create3DISignal
Signal.

Return Value

Type: ReadOnlyCollectionInt32
Map indexes associated to the signal.
See Also

Reference

ISignalMap Interface
VisualComponents.Create3D Namespace


ISignalMap.FindSignalIndexLocation Method

ISignalMapFindSignalIndexLocation Method

Note: This API is now obsolete.

This method is obsolete. Use FindSignalIndexesLocation(ISignal) instead.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Use FindSignalIndexesLocation instead.")]
int FindSignalIndexLocation(
    ISignal signal
)
[ObsoleteAttribute(L"Use FindSignalIndexesLocation instead.")]
int FindSignalIndexLocation(
    ISignal^ signal
)

Parameters

signal
Type: VisualComponents.Create3DISignal
Obsolete.

Return Value

Type: Int32
Obsolete.
See Also

Reference

ISignalMap Interface
VisualComponents.Create3D Namespace


ISignalMap.GetPort Method

ISignalMapGetPort Method

Returns the port number at the given map index. Works in opposite way than GetPortIndex(Int32).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int GetPort(
    int mapIndex
)
int GetPort(
    int mapIndex
)

Parameters

mapIndex
Type: SystemInt32
Map index.

Return Value

Type: Int32
Port number at the given map index.
See Also

Reference

ISignalMap Interface
VisualComponents.Create3D Namespace


ISignalMap.GetPortIndex Method

ISignalMapGetPortIndex Method

Returns the map index of the port defined by port number. Works in opposite way than GetPort(Int32).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int GetPortIndex(
    int port
)
int GetPortIndex(
    int port
)

Parameters

port
Type: SystemInt32
Port number.

Return Value

Type: Int32
Map index of the given port number.
See Also

Reference

ISignalMap Interface
VisualComponents.Create3D Namespace


ISignalMap.GetPortName Method

ISignalMapGetPortName Method

Returns the name of the port at the given map index.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string GetPortName(
    int index
)
String^ GetPortName(
    int index
)

Parameters

index
Type: SystemInt32
Map index.

Return Value

Type: String
Port name.
See Also

Reference

ISignalMap Interface
VisualComponents.Create3D Namespace


ISignalMap.GetPortValue Method

ISignalMapGetPortValue Method

Reads the value from a port defined by the map index if there is a signal in that port.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object GetPortValue(
    int mapIndex
)
Object^ GetPortValue(
    int mapIndex
)

Parameters

mapIndex
Type: SystemInt32
Map index.

Return Value

Type: Object
Returns the signal value behind the given map index.
Exceptions
Exception | Condition
ArgumentException | Thrown when map index is out of bounds.
See Also

Reference

ISignalMap Interface
VisualComponents.Create3D Namespace


ISignalMap.GetSignal Method

ISignalMapGetSignal Method

Gets a ISignal instance behind the map at the given map index.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISignal GetSignal(
    int mapIndex
)
ISignal^ GetSignal(
    int mapIndex
)

Parameters

mapIndex
Type: SystemInt32
Map index.

Return Value

Type: ISignal
Signal at the given map index.
Remarks
This is not to be confused with signal in other component. This is an internal component signals which is typically connected to external signal(s).
See Also

Reference

ISignalMap Interface
VisualComponents.Create3D Namespace


ISignalMap.MapGetPortSignal Method

ISignalMapMapGetPortSignal Method

Gets the ISignal instance behind the given port number.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISignal MapGetPortSignal(
    int port
)
ISignal^ MapGetPortSignal(
    int port
)

Parameters

port
Type: SystemInt32
Port number.

Return Value

Type: ISignal
Signal at the given port.
See Also

Reference

ISignalMap Interface
VisualComponents.Create3D Namespace


ISignalMap.SetPortName Method

ISignalMapSetPortName Method

Sets a port name given map index
Remarks
There should be a signal in this port in order to associate a name

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetPortName(
    int index,
    string name
)
void SetPortName(
    int index,
    String^ name
)

Parameters

index
Type: SystemInt32
Map index
name
Type: SystemString
name
See Also

Reference

ISignalMap Interface
VisualComponents.Create3D Namespace


ISignalMap.SetPortValue Method

ISignalMapSetPortValue Method

Sends a signal to a port defined by map index.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetPortValue(
    int mapIndex,
    Object value
)
void SetPortValue(
    int mapIndex,
    Object^ value
)

Parameters

mapIndex
Type: SystemInt32
Map index.
value
Type: SystemObject
Signal value.
Exceptions
Exception | Condition
ArgumentException | Thrown when map index is out of bounds.
See Also

Reference

ISignalMap Interface
VisualComponents.Create3D Namespace


ISignalMap.SetSignal Method

ISignalMapSetSignal Method

Associates a component signal into the given port

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetSignal(
    int port,
    ISignal signal
)
void SetSignal(
    int port,
    ISignal^ signal
)

Parameters

port
Type: SystemInt32
Port number
signal
Type: VisualComponents.Create3DISignal
See Also

Reference

ISignalMap Interface
VisualComponents.Create3D Namespace


ISignalMap Events

The ISignalMap type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | SignalValueChanged | Triggered when the value of the signal associated to the port changes.
Top
See Also

Reference

ISignalMap Interface
VisualComponents.Create3D Namespace


ISignalMap.SignalValueChanged Event

ISignalMapSignalValueChanged Event

Triggered when the value of the signal associated to the port changes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<SignalMapSignalValueChangedEventArgs> SignalValueChanged
 event EventHandler<SignalMapSignalValueChangedEventArgs^>^ SignalValueChanged {
    void add (EventHandler<SignalMapSignalValueChangedEventArgs^>^ value);
    void remove (EventHandler<SignalMapSignalValueChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerSignalMapSignalValueChangedEventArgs
See Also

Reference

ISignalMap Interface
VisualComponents.Create3D Namespace


ISimAction Interface

Property container storing information about actions such as grab, release, toggle trace, etc.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimAction : IPropertyContainer,
    IBatchModeObject, INamed, IWrapper, IDisposable
public interface class ISimAction : IPropertyContainer,
    IBatchModeObject, INamed, IWrapper, IDisposable

The ISimAction type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Message | Defines the status information about action execution
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Time | Returns action creation time.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Execute | Executes associated action
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Invalidate | It should be previosly removed from its container.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
Actions are typically defined in IActionContainer. Actions are activated with plug&play functionality and ISimInterfaceActionField field.
See Also

Reference

VisualComponents.Create3D Namespace
VisualComponents.Create3DISimInterfaceActionField


ISimAction Properties

The ISimAction type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Message | Defines the status information about action execution
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Time | Returns action creation time.
Top
See Also

Reference

ISimAction Interface
VisualComponents.Create3D Namespace


ISimAction.Message Property

ISimActionMessage Property

Defines the status information about action execution

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Message { get; set; }
property String^ Message {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ISimAction Interface
VisualComponents.Create3D Namespace


ISimAction.Time Property

ISimActionTime Property

Returns action creation time.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Time { get; set; }
property double Time {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ISimAction Interface
VisualComponents.Create3D Namespace


ISimAction Methods

The ISimAction type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Execute | Executes associated action
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Invalidate | It should be previosly removed from its container.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISimAction Interface
VisualComponents.Create3D Namespace


ISimAction.Execute Method

ISimActionExecute Method

Executes associated action

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool Execute()
bool Execute()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISimAction.Execute"]

See Also

Reference

ISimAction Interface
VisualComponents.Create3D Namespace


ISimAction.Invalidate Method

ISimActionInvalidate Method

It should be previosly removed from its container.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Invalidate()
void Invalidate()
See Also

Reference

ISimAction Interface
VisualComponents.Create3D Namespace


ISimAction Events

The ISimAction type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ISimAction Interface
VisualComponents.Create3D Namespace


ISimComponent Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimComponent : IVisualObject,
    INamed, IWrapper, IDisposable, IPropertyContainer, IBatchModeObject,
    IVisitable, ISharedCloneable, ILockableObject
public interface class ISimComponent : IVisualObject,
    INamed, IWrapper, IDisposable, IPropertyContainer, IBatchModeObject,
    IVisitable, ISharedCloneable, ILockableObject

The ISimComponent type exposes the following members.

Properties
 | Name | Description
Public property | BackfaceMode | Defines the mode for rendering geometry backfaces of a component. That is, geometry not facing the active camera.
Public property | Behaviors | Gets all the instances of IBehavior in this instance of ISimComponent.
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ComponentMetadata | Component metadata object.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Features | Gets all the instance if IFeature in this instance of ISimComponent.
Public property | Group | Get the component group of the component or null if component does not belong to a group.
Public property | IsConnected | Returns true if any of the component's interface behaviors is connected.
Public property | IsDynamic | Defines if this instance of ISimComponent has been created during simulation.
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsLocked | (Inherited from ILockableObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Material | Gets or sets the material of this instance of ISimComponent.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Nodes | Gets all the instances of ISimNode in this instance of ISimComponent.
Public property | OverwriteFramesVisibility | Gets or sets a Boolean value that indicates the frames visibility for this component are independent of the IApplication.FrameVisibility value. Value of True indicates that frames of this component are always visible even if IApplication.FrameVisibility is False. Value of False indicatse that the frames of this component has the visibility specified in IApplication.FrameVisibility
Public property | PackFolder | Component pack folder.
Public property | PdfExportLevel |
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Product | Gets the ISimProduct associated with this component if any.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootNode | Returns component as a ISimNode.
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | SimulationLevel | Note: this value cannot be SimulationLevel.Default See also ISimWorld.SimulationLevel.
Public property | Statistics |
Public property | Tag | Gets or sets the object that contains data about this ISimComponent.
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IVisualObject.)
Public property | TransformationInWorld | Gets or sets the world transformation matrix (Inherited from IVisualObject.)
Public property | VCID | Gets the unique component type identifier.
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanConnect |
Public method | CanPlugAndPlay |
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindBehavior | Finds the instance of IBehavior by its name.
Public method | FindFeature | Finds the instance of IFeature by its name.
Public method | FindNode | Finds the instance of ISimNode in this instance of ISimComponent by its name.
Public method | GetBehavior |
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetRobot | Returns the robot object instance representing this component
Public method | MakeMetadataUnique | If metadata object is shared between multiple components, this method will make it unique for this one
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | MakeUnique(Boolean, Boolean) | Extension to ISharedCloneable interface. Allows disabling of auto sharing.
Public method | Rebuild |
Public method | Rebuild(Boolean) |
Public method | Rebuild(Boolean, Boolean) | Note: The second argument 'autoSharing' is typically unusable, becase FeatureTreeAutoSharing-option is disabled. Use IAppliation.AutoShareFeatureTrees() instead.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | Update |
Public method | UpdateAttributes |
Top
Events
 | Name | Description
Public event | BehaviorAdded | Occurs when a behavior has been added to this ISimComponent.
Public event | BehaviorRemoved | Occurs when a behavior was removed from this ISimComponent
Public event | BehaviorRemoving | Occurs when a behavior is being removed from this ISimComponent
Public event | CategoryChanged | Occurs when ISimComponent category name has been changed .
Public event | FeatureTreeChanged | Occurs when ISimNode RootFeature has been changed.
Public event | IsLockedChanged | Event that is raised when Lock property of the component is changed (Inherited from ILockableObject.)
Public event | LinkAdded | Occurs when a link has been added to this ISimComponent.
Public event | LinkRemoving | Occurs when a link is being removed.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | ParentChanged | Event that is raised when component parent is changed
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISimComponent Properties

The ISimComponent type exposes the following members.

Properties
 | Name | Description
Public property | BackfaceMode | Defines the mode for rendering geometry backfaces of a component. That is, geometry not facing the active camera.
Public property | Behaviors | Gets all the instances of IBehavior in this instance of ISimComponent.
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ComponentMetadata | Component metadata object.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Features | Gets all the instance if IFeature in this instance of ISimComponent.
Public property | Group | Get the component group of the component or null if component does not belong to a group.
Public property | IsConnected | Returns true if any of the component's interface behaviors is connected.
Public property | IsDynamic | Defines if this instance of ISimComponent has been created during simulation.
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsLocked | (Inherited from ILockableObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Material | Gets or sets the material of this instance of ISimComponent.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Nodes | Gets all the instances of ISimNode in this instance of ISimComponent.
Public property | OverwriteFramesVisibility | Gets or sets a Boolean value that indicates the frames visibility for this component are independent of the IApplication.FrameVisibility value. Value of True indicates that frames of this component are always visible even if IApplication.FrameVisibility is False. Value of False indicatse that the frames of this component has the visibility specified in IApplication.FrameVisibility
Public property | PackFolder | Component pack folder.
Public property | PdfExportLevel |
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Product | Gets the ISimProduct associated with this component if any.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootNode | Returns component as a ISimNode.
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | SimulationLevel | Note: this value cannot be SimulationLevel.Default See also ISimWorld.SimulationLevel.
Public property | Statistics |
Public property | Tag | Gets or sets the object that contains data about this ISimComponent.
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IVisualObject.)
Public property | TransformationInWorld | Gets or sets the world transformation matrix (Inherited from IVisualObject.)
Public property | VCID | Gets the unique component type identifier.
Top
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.BackfaceMode Property

ISimComponentBackfaceMode Property

Defines the mode for rendering geometry backfaces of a component. That is, geometry not facing the active camera.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
BackfaceMode BackfaceMode { get; set; }
property BackfaceMode BackfaceMode {
    BackfaceMode get ();
    void set (BackfaceMode value);
}

Property Value

Type: BackfaceMode
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.Behaviors Property

ISimComponentBehaviors Property

Gets all the instances of IBehavior in this instance of ISimComponent.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IBehavior> Behaviors { get; }
property ReadOnlyCollection<IBehavior^>^ Behaviors {
    ReadOnlyCollection<IBehavior^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIBehavior
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.ComponentMetadata Property

ISimComponentComponentMetadata Property

Component metadata object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IModelMetadata ComponentMetadata { get; }
property IModelMetadata^ ComponentMetadata {
    IModelMetadata^ get ();
}

Property Value

Type: IModelMetadata
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.Features Property

ISimComponentFeatures Property

Gets all the instance if IFeature in this instance of ISimComponent.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IFeature> Features { get; }
property ReadOnlyCollection<IFeature^>^ Features {
    ReadOnlyCollection<IFeature^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIFeature
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.Group Property

ISimComponentGroup Property

Get the component group of the component or null if component does not belong to a group.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IGroup Group { get; set; }
property IGroup^ Group {
    IGroup^ get ();
    void set (IGroup^ value);
}

Property Value

Type: IGroup
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.IsConnected Property

ISimComponentIsConnected Property

Returns true if any of the component's interface behaviors is connected.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsConnected { get; }
property bool IsConnected {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.IsDynamic Property

ISimComponentIsDynamic Property

Defines if this instance of ISimComponent has been created during simulation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsDynamic { get; }
property bool IsDynamic {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.Material Property

ISimComponentMaterial Property

Gets or sets the material of this instance of ISimComponent.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMaterial Material { get; set; }
property IMaterial^ Material {
    IMaterial^ get ();
    void set (IMaterial^ value);
}

Property Value

Type: IMaterial
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.Nodes Property

ISimComponentNodes Property

Gets all the instances of ISimNode in this instance of ISimComponent.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ISimNode> Nodes { get; }
property ReadOnlyCollection<ISimNode^>^ Nodes {
    ReadOnlyCollection<ISimNode^>^ get ();
}

Property Value

Type: ReadOnlyCollectionISimNode
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.OverwriteFramesVisibility Property

ISimComponentOverwriteFramesVisibility Property

Gets or sets a Boolean value that indicates the frames visibility for this component are independent of the IApplication.FrameVisibility value. Value of True indicates that frames of this component are always visible even if IApplication.FrameVisibility is False. Value of False indicatse that the frames of this component has the visibility specified in IApplication.FrameVisibility

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool OverwriteFramesVisibility { get; set; }
property bool OverwriteFramesVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.PackFolder Property

ISimComponentPackFolder Property

Component pack folder.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPackFolder PackFolder { get; }
property IPackFolder^ PackFolder {
    IPackFolder^ get ();
}

Property Value

Type: IPackFolder
Remarks

This is the interface to the pack folder, which is a folder with files and subfolders that can be optionally included with a component in a layout or component file.

The pack folder is only available for static components; dynamic components will have this property set to null. The pack folder is not copied when a component is cloned or copied.

See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.PdfExportLevel Property

ISimComponentPdfExportLevel Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
PdfExportLevel PdfExportLevel { get; set; }
property PdfExportLevel PdfExportLevel {
    PdfExportLevel get ();
    void set (PdfExportLevel value);
}

Property Value

Type: PdfExportLevel
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.Product Property

ISimComponentProduct Property

Gets the ISimProduct associated with this component if any.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimProduct Product { get; }
property ISimProduct^ Product {
    ISimProduct^ get ();
}

Property Value

Type: ISimProduct
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.RootNode Property

ISimComponentRootNode Property

Returns component as a ISimNode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode RootNode { get; }
property ISimNode^ RootNode {
    ISimNode^ get ();
}

Property Value

Type: ISimNode
Remarks
RootNode property does not refer to the world or node hierarchy. It returns the components own ISimNode instance.
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.SimulationLevel Property

ISimComponentSimulationLevel Property

Note: this value cannot be SimulationLevel.Default See also ISimWorld.SimulationLevel.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
SimulationLevel SimulationLevel { get; set; }
property SimulationLevel SimulationLevel {
    SimulationLevel get ();
    void set (SimulationLevel value);
}

Property Value

Type: SimulationLevel
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.Statistics Property

ISimComponentStatistics Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatistics Statistics { get; }
property IStatistics^ Statistics {
    IStatistics^ get ();
}

Property Value

Type: IStatistics
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.Tag Property

ISimComponentTag Property

Gets or sets the object that contains data about this ISimComponent.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object Tag { get; set; }
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.VCID Property

ISimComponentVCID Property

Gets the unique component type identifier.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string VCID { get; }
property String^ VCID {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent Methods

The ISimComponent type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanConnect |
Public method | CanPlugAndPlay |
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindBehavior | Finds the instance of IBehavior by its name.
Public method | FindFeature | Finds the instance of IFeature by its name.
Public method | FindNode | Finds the instance of ISimNode in this instance of ISimComponent by its name.
Public method | GetBehavior |
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetRobot | Returns the robot object instance representing this component
Public method | MakeMetadataUnique | If metadata object is shared between multiple components, this method will make it unique for this one
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | MakeUnique(Boolean, Boolean) | Extension to ISharedCloneable interface. Allows disabling of auto sharing.
Public method | Rebuild |
Public method | Rebuild(Boolean) |
Public method | Rebuild(Boolean, Boolean) | Note: The second argument 'autoSharing' is typically unusable, becase FeatureTreeAutoSharing-option is disabled. Use IAppliation.AutoShareFeatureTrees() instead.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | Update |
Public method | UpdateAttributes |
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.CanConnect Method

ISimComponentCanConnect Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanConnect()
bool CanConnect()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISimComponent.CanConnect"]

See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.CanPlugAndPlay Method

ISimComponentCanPlugAndPlay Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanPlugAndPlay()
bool CanPlugAndPlay()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISimComponent.CanPlugAndPlay"]

See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.FindBehavior Method

ISimComponentFindBehavior Method

Finds the instance of IBehavior by its name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IBehavior FindBehavior(
    string name
)
IBehavior^ FindBehavior(
    String^ name
)

Parameters

name
Type: SystemString
Behavior name.

Return Value

Type: IBehavior
Behavior, null if no behavior with the given name was found.
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.FindFeature Method

ISimComponentFindFeature Method

Finds the instance of IFeature by its name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFeature FindFeature(
    string name
)
IFeature^ FindFeature(
    String^ name
)

Parameters

name
Type: SystemString
Feature name.

Return Value

Type: IFeature
Feature, null if no feature with the given name was found.
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.FindNode Method

ISimComponentFindNode Method

Finds the instance of ISimNode in this instance of ISimComponent by its name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode FindNode(
    string name
)
ISimNode^ FindNode(
    String^ name
)

Parameters

name
Type: SystemString
Node name.

Return Value

Type: ISimNode
Node, null if no node with the given name was found.
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.GetBehavior Method

ISimComponentGetBehavior Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IBehavior GetBehavior(
    BehaviorType type
)
IBehavior^ GetBehavior(
    BehaviorType type
)

Parameters

type
Type: VisualComponents.Create3DBehaviorType

Return Value

Type: IBehavior

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISimComponent.GetBehavior(VisualComponents.Create3D.BehaviorType)"]

See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.GetRobot Method

ISimComponentGetRobot Method

Returns the robot object instance representing this component

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobot GetRobot()
IRobot^ GetRobot()

Return Value

Type: IRobot
Robot object, if the component is not a robot null is returned
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.MakeMetadataUnique Method

ISimComponentMakeMetadataUnique Method

If metadata object is shared between multiple components, this method will make it unique for this one

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void MakeMetadataUnique()
void MakeMetadataUnique()
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.MakeUnique Method

ISimComponentMakeUnique Method

Overload List
 | Name | Description
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | MakeUnique(Boolean, Boolean) | Extension to ISharedCloneable interface. Allows disabling of auto sharing.
Top
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.MakeUnique Method (Boolean, Boolean)

ISimComponentMakeUnique Method (Boolean, Boolean)

Extension to ISharedCloneable interface. Allows disabling of auto sharing.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool MakeUnique(
    bool rebuild,
    bool scheduleAutoSharing
)
bool MakeUnique(
    bool rebuild,
    bool scheduleAutoSharing
)

Parameters

rebuild
Type: SystemBoolean
scheduleAutoSharing
Type: SystemBoolean

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISimComponent.MakeUnique(System.Boolean,System.Boolean)"]

See Also

Reference

ISimComponent Interface
MakeUnique Overload
VisualComponents.Create3D Namespace


ISimComponent.Rebuild Method

ISimComponentRebuild Method

Overload List
 | Name | Description
Public method | Rebuild |
Public method | Rebuild(Boolean) |
Public method | Rebuild(Boolean, Boolean) | Note: The second argument 'autoSharing' is typically unusable, becase FeatureTreeAutoSharing-option is disabled. Use IAppliation.AutoShareFeatureTrees() instead.
Top
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.Rebuild Method

ISimComponentRebuild Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Rebuild()
void Rebuild()
See Also

Reference

ISimComponent Interface
Rebuild Overload
VisualComponents.Create3D Namespace


ISimComponent.Rebuild Method (Boolean)

ISimComponentRebuild Method (Boolean)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Rebuild(
    bool makeResourceUnique
)
void Rebuild(
    bool makeResourceUnique
)

Parameters

makeResourceUnique
Type: SystemBoolean
See Also

Reference

ISimComponent Interface
Rebuild Overload
VisualComponents.Create3D Namespace


ISimComponent.Rebuild Method (Boolean, Boolean)

ISimComponentRebuild Method (Boolean, Boolean)

Note: The second argument 'autoSharing' is typically unusable, becase FeatureTreeAutoSharing-option is disabled. Use IAppliation.AutoShareFeatureTrees() instead.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Rebuild(
    bool makeResourceUnique,
    bool autoSharing
)
void Rebuild(
    bool makeResourceUnique,
    bool autoSharing
)

Parameters

makeResourceUnique
Type: SystemBoolean
autoSharing
Type: SystemBoolean
See Also

Reference

ISimComponent Interface
Rebuild Overload
VisualComponents.Create3D Namespace


ISimComponent.Update Method

ISimComponentUpdate Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Update()
void Update()
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.UpdateAttributes Method

ISimComponentUpdateAttributes Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateAttributes()
void UpdateAttributes()
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent Events

The ISimComponent type exposes the following members.

Events
 | Name | Description
Public event | BehaviorAdded | Occurs when a behavior has been added to this ISimComponent.
Public event | BehaviorRemoved | Occurs when a behavior was removed from this ISimComponent
Public event | BehaviorRemoving | Occurs when a behavior is being removed from this ISimComponent
Public event | CategoryChanged | Occurs when ISimComponent category name has been changed .
Public event | FeatureTreeChanged | Occurs when ISimNode RootFeature has been changed.
Public event | IsLockedChanged | Event that is raised when Lock property of the component is changed (Inherited from ILockableObject.)
Public event | LinkAdded | Occurs when a link has been added to this ISimComponent.
Public event | LinkRemoving | Occurs when a link is being removed.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | ParentChanged | Event that is raised when component parent is changed
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.BehaviorAdded Event

ISimComponentBehaviorAdded Event

Occurs when a behavior has been added to this ISimComponent.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<BehaviorAddedEventArgs> BehaviorAdded
 event EventHandler<BehaviorAddedEventArgs^>^ BehaviorAdded {
    void add (EventHandler<BehaviorAddedEventArgs^>^ value);
    void remove (EventHandler<BehaviorAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerBehaviorAddedEventArgs
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.BehaviorRemoved Event

ISimComponentBehaviorRemoved Event

Occurs when a behavior was removed from this ISimComponent

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<BehaviorRemovedEventArgs> BehaviorRemoved
 event EventHandler<BehaviorRemovedEventArgs^>^ BehaviorRemoved {
    void add (EventHandler<BehaviorRemovedEventArgs^>^ value);
    void remove (EventHandler<BehaviorRemovedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerBehaviorRemovedEventArgs
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.BehaviorRemoving Event

ISimComponentBehaviorRemoving Event

Occurs when a behavior is being removed from this ISimComponent

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<BehaviorRemovingEventArgs> BehaviorRemoving
 event EventHandler<BehaviorRemovingEventArgs^>^ BehaviorRemoving {
    void add (EventHandler<BehaviorRemovingEventArgs^>^ value);
    void remove (EventHandler<BehaviorRemovingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerBehaviorRemovingEventArgs
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.CategoryChanged Event

ISimComponentCategoryChanged Event

Occurs when ISimComponent category name has been changed .

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<CategoryChangedEventArgs> CategoryChanged
 event EventHandler<CategoryChangedEventArgs^>^ CategoryChanged {
    void add (EventHandler<CategoryChangedEventArgs^>^ value);
    void remove (EventHandler<CategoryChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerCategoryChangedEventArgs
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.FeatureTreeChanged Event

ISimComponentFeatureTreeChanged Event

Occurs when ISimNode RootFeature has been changed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<FeatureTreeChangedEventArgs> FeatureTreeChanged
 event EventHandler<FeatureTreeChangedEventArgs^>^ FeatureTreeChanged {
    void add (EventHandler<FeatureTreeChangedEventArgs^>^ value);
    void remove (EventHandler<FeatureTreeChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerFeatureTreeChangedEventArgs
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.LinkAdded Event

ISimComponentLinkAdded Event

Occurs when a link has been added to this ISimComponent.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<LinkAddedEventArgs> LinkAdded
 event EventHandler<LinkAddedEventArgs^>^ LinkAdded {
    void add (EventHandler<LinkAddedEventArgs^>^ value);
    void remove (EventHandler<LinkAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerLinkAddedEventArgs
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.LinkRemoving Event

ISimComponentLinkRemoving Event

Occurs when a link is being removed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<LinkRemovingEventArgs> LinkRemoving
 event EventHandler<LinkRemovingEventArgs^>^ LinkRemoving {
    void add (EventHandler<LinkRemovingEventArgs^>^ value);
    void remove (EventHandler<LinkRemovingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerLinkRemovingEventArgs
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimComponent.ParentChanged Event

ISimComponentParentChanged Event

Event that is raised when component parent is changed

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler ParentChanged
 event EventHandler^ ParentChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ISimComponent Interface
VisualComponents.Create3D Namespace


ISimConnector Interface

Interface defining a connection port. Used to implement material flow between containers.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimConnector : IPropertyContainer,
    IBatchModeObject, IWrapper, IDisposable, INamed
public interface class ISimConnector : IPropertyContainer,
    IBatchModeObject, IWrapper, IDisposable, INamed

The ISimConnector type exposes the following members.

Properties
 | Name | Description
Public property | CapacityTest | Condition for capacity test.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Connection | Connector to which this instance is currently connected to.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Owner | Behaviour defining this connector.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Connector type.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CheckCapacity | Tests if the owner behavior has capacity for a component.
Public method | CheckConnectedCapacity | Tests if connected connector's owner has capacity for a component.
Public method | Connect | Connects two connectors together.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
Typically referenced by Connectors, ISimContainer.Connectors, and other classes inheriting from ISimContainer interface.
See Also

Reference

VisualComponents.Create3D Namespace
VisualComponents.Create3DIFlowBehavior
VisualComponents.Create3DISimContainer


ISimConnector Properties

The ISimConnector type exposes the following members.

Properties
 | Name | Description
Public property | CapacityTest | Condition for capacity test.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Connection | Connector to which this instance is currently connected to.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Owner | Behaviour defining this connector.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Connector type.
Top
See Also

Reference

ISimConnector Interface
VisualComponents.Create3D Namespace


ISimConnector.CapacityTest Property

ISimConnectorCapacityTest Property

Condition for capacity test.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ConnectorTestLocation CapacityTest { get; set; }
property ConnectorTestLocation CapacityTest {
    ConnectorTestLocation get ();
    void set (ConnectorTestLocation value);
}

Property Value

Type: ConnectorTestLocation
See Also

Reference

ISimConnector Interface
VisualComponents.Create3D Namespace


ISimConnector.Connection Property

ISimConnectorConnection Property

Connector to which this instance is currently connected to.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimConnector Connection { get; }
property ISimConnector^ Connection {
    ISimConnector^ get ();
}

Property Value

Type: ISimConnector
See Also

Reference

ISimConnector Interface
VisualComponents.Create3D Namespace


ISimConnector.Owner Property

ISimConnectorOwner Property

Behaviour defining this connector.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IBehavior Owner { get; }
property IBehavior^ Owner {
    IBehavior^ get ();
}

Property Value

Type: IBehavior
See Also

Reference

ISimConnector Interface
VisualComponents.Create3D Namespace


ISimConnector.Type Property

ISimConnectorType Property

Connector type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ConnectorType Type { get; set; }
property ConnectorType Type {
    ConnectorType get ();
    void set (ConnectorType value);
}

Property Value

Type: ConnectorType
See Also

Reference

ISimConnector Interface
VisualComponents.Create3D Namespace


ISimConnector Methods

The ISimConnector type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CheckCapacity | Tests if the owner behavior has capacity for a component.
Public method | CheckConnectedCapacity | Tests if connected connector's owner has capacity for a component.
Public method | Connect | Connects two connectors together.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISimConnector Interface
VisualComponents.Create3D Namespace


ISimConnector.CheckCapacity Method

ISimConnectorCheckCapacity Method

Tests if the owner behavior has capacity for a component.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CheckCapacity(
    ISimComponent component
)
bool CheckCapacity(
    ISimComponent^ component
)

Parameters

component
Type: VisualComponents.Create3DISimComponent
Component entering this port

Return Value

Type: Boolean
True if component can enter this port
Exceptions
Exception | Condition
ArgumentNullException | Thrown when component parameter is null.
See Also

Reference

ISimConnector Interface
VisualComponents.Create3D Namespace


ISimConnector.CheckConnectedCapacity Method

ISimConnectorCheckConnectedCapacity Method

Tests if connected connector's owner has capacity for a component.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CheckConnectedCapacity(
    ISimComponent component
)
bool CheckConnectedCapacity(
    ISimComponent^ component
)

Parameters

component
Type: VisualComponents.Create3DISimComponent
Component coming through the connected connector

Return Value

Type: Boolean
True if component can enter Connection connector
Exceptions
Exception | Condition
ArgumentNullException | Thrown when component parameter is null.
See Also

Reference

ISimConnector Interface
VisualComponents.Create3D Namespace


ISimConnector.Connect Method

ISimConnectorConnect Method

Connects two connectors together.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Connect(
    ISimConnector connector
)
void Connect(
    ISimConnector^ connector
)

Parameters

connector
Type: VisualComponents.Create3DISimConnector
Target connector
Exceptions
Exception | Condition
InvalidOperationException | Thrown when connector is not in this component.
See Also

Reference

ISimConnector Interface
VisualComponents.Create3D Namespace


ISimConnector Events

The ISimConnector type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ISimConnector Interface
VisualComponents.Create3D Namespace


ISimContainer Interface

Container behavior used for placing components into a logical container.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimContainer : IFlowBehavior,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed
public interface class ISimContainer : IFlowBehavior,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed

The ISimContainer type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Maximum logical capacity of the container. This determines the maximum number of components that can be contained in the container at any one time.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Components | list of components currently contained in the container
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | HeadComponent | Returns component in the head of container
Public property | IsContentVisible | Defines whether components held by the container are displayed or not
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | TailComponent | Returns component in the tail of container
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetContainerProximity | Calculate the orthogonal distance from position to this container
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Grab | Grab the component into this container
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ComponentArriving | Triggered when a component is arriving to the container
Public event | ComponentLeaving | Triggered when a component is leaving from the container
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISimContainer Properties

The ISimContainer type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Maximum logical capacity of the container. This determines the maximum number of components that can be contained in the container at any one time.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Components | list of components currently contained in the container
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | HeadComponent | Returns component in the head of container
Public property | IsContentVisible | Defines whether components held by the container are displayed or not
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | TailComponent | Returns component in the tail of container
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

ISimContainer Interface
VisualComponents.Create3D Namespace


ISimContainer.Capacity Property

ISimContainerCapacity Property

Maximum logical capacity of the container. This determines the maximum number of components that can be contained in the container at any one time.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int Capacity { get; set; }
property int Capacity {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ISimContainer Interface
VisualComponents.Create3D Namespace


ISimContainer.Components Property

ISimContainerComponents Property

list of components currently contained in the container

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ISimComponent> Components { get; }
property ReadOnlyCollection<ISimComponent^>^ Components {
    ReadOnlyCollection<ISimComponent^>^ get ();
}

Property Value

Type: ReadOnlyCollectionISimComponent
See Also

Reference

ISimContainer Interface
VisualComponents.Create3D Namespace


ISimContainer.HeadComponent Property

ISimContainerHeadComponent Property

Returns component in the head of container

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent HeadComponent { get; }
property ISimComponent^ HeadComponent {
    ISimComponent^ get ();
}

Property Value

Type: ISimComponent
See Also

Reference

ISimContainer Interface
VisualComponents.Create3D Namespace


ISimContainer.IsContentVisible Property

ISimContainerIsContentVisible Property

Defines whether components held by the container are displayed or not

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsContentVisible { get; set; }
property bool IsContentVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISimContainer Interface
VisualComponents.Create3D Namespace


ISimContainer.TailComponent Property

ISimContainerTailComponent Property

Returns component in the tail of container

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent TailComponent { get; }
property ISimComponent^ TailComponent {
    ISimComponent^ get ();
}

Property Value

Type: ISimComponent
See Also

Reference

ISimContainer Interface
VisualComponents.Create3D Namespace


ISimContainer Methods

The ISimContainer type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetContainerProximity | Calculate the orthogonal distance from position to this container
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Grab | Grab the component into this container
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISimContainer Interface
VisualComponents.Create3D Namespace


ISimContainer.GetContainerProximity Method

ISimContainerGetContainerProximity Method

Calculate the orthogonal distance from position to this container

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double GetContainerProximity(
    Vector3 position
)
double GetContainerProximity(
    Vector3 position
)

Parameters

position
Type: VisualComponents.Create3DVector3

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISimContainer.GetContainerProximity(VisualComponents.Create3D.Vector3)"]

See Also

Reference

ISimContainer Interface
VisualComponents.Create3D Namespace


ISimContainer.Grab Method

ISimContainerGrab Method

Grab the component into this container

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Grab(
    ISimComponent component
)
void Grab(
    ISimComponent^ component
)

Parameters

component
Type: VisualComponents.Create3DISimComponent
Exceptions
Exception | Condition
ArgumentNullException | Thrown when component parameter is null.
InvalidOperationException | Thrown when trying to grab component to itself.
See Also

Reference

ISimContainer Interface
VisualComponents.Create3D Namespace


ISimContainer Events

The ISimContainer type exposes the following members.

Events
 | Name | Description
Public event | ComponentArriving | Triggered when a component is arriving to the container
Public event | ComponentLeaving | Triggered when a component is leaving from the container
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ISimContainer Interface
VisualComponents.Create3D Namespace


ISimContainer.ComponentArriving Event

ISimContainerComponentArriving Event

Triggered when a component is arriving to the container

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ContainerTransitionEventArgs> ComponentArriving
 event EventHandler<ContainerTransitionEventArgs^>^ ComponentArriving {
    void add (EventHandler<ContainerTransitionEventArgs^>^ value);
    void remove (EventHandler<ContainerTransitionEventArgs^>^ value);
}

Value

Type: SystemEventHandlerContainerTransitionEventArgs
See Also

Reference

ISimContainer Interface
VisualComponents.Create3D Namespace


ISimContainer.ComponentLeaving Event

ISimContainerComponentLeaving Event

Triggered when a component is leaving from the container

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ContainerTransitionEventArgs> ComponentLeaving
 event EventHandler<ContainerTransitionEventArgs^>^ ComponentLeaving {
    void add (EventHandler<ContainerTransitionEventArgs^>^ value);
    void remove (EventHandler<ContainerTransitionEventArgs^>^ value);
}

Value

Type: SystemEventHandlerContainerTransitionEventArgs
See Also

Reference

ISimContainer Interface
VisualComponents.Create3D Namespace


ISimDoubleVariableCreator Interface

Note: This API is now obsolete.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Use IRealPropertyCreator instead.")]
public interface ISimDoubleVariableCreator : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
[ObsoleteAttribute(L"Use IRealPropertyCreator instead.")]
public interface class ISimDoubleVariableCreator : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The ISimDoubleVariableCreator type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISimDoubleVariableCreator Properties

The ISimDoubleVariableCreator type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

ISimDoubleVariableCreator Interface
VisualComponents.Create3D Namespace


ISimDoubleVariableCreator Methods

The ISimDoubleVariableCreator type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISimDoubleVariableCreator Interface
VisualComponents.Create3D Namespace


ISimDoubleVariableCreator Events

The ISimDoubleVariableCreator type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ISimDoubleVariableCreator Interface
VisualComponents.Create3D Namespace


ISimInterface Interface

An simulation interface behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimInterface : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed, IPropertyChangeFilter
public interface class ISimInterface : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed, IPropertyChangeFilter

The ISimInterface type exposes the following members.

Properties
 | Name | Description
Public property | AngleTolerance | Gets or sets the angle tolerance of this ISimInterface.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConnectedComponents | Retrieves the collection of ISimComponent that are connected to this ISimInterface.
Public property | ConnectedInterfaces | Retrieves the collection of ISimInterface that are connected to this ISimInterface.
Public property | ConnectedSections | Retrieves the collection of ISimInterfaceSection that are connected to this ISimInterface.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Description | Gets or sets an user description of this ISimInterface.
Public property | EventFilter | Comma separated list of allowed client type names. (Inherited from IPropertyChangeFilter.)
Public property | IndicateDistance | Gets or sets the indicate distance of this ISimInterface.
Public property | IsApplication | Determines if this ISimInterface was created by the main application.
Public property | IsConnected | Retrieves the connection status of this ISimInterface.
Public property | IsLogical | Determines if this ISimInterface is logical (i.e. not connectable by plug and play).
Public property | IsOneToMany | Determines if this ISimInterface is one to many interface.
Public property | IsValid | (Inherited from IWrapper.)
Public property | MagnetDistance | Gets or sets the magnet distance of this ISimInterface.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Sections | Retrieves the collection of sections in this interface.
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect(ISimInterface) | Connects the given ISimInterface to this interface without updating position of the owner component.
Public method | Connect(ISimInterface, Boolean) | Connects the given ISimInterface to this interface.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | CreateSection | Creates and adds a new ISimInterfaceSection to this interface.
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteSection | Deletes the given ISimInterfaceSection and removes it from this interface.
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects all the interfaces connected to this ISimInterface.
Public method | Disconnect(ISimInterface) | Disconnects the given interface from this ISimInterface.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | FindMatchingSections | Finds the first ISimInterfaceSection that matches the given section.
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | IsCompatibleWith | Checks if the given ISimInterface is compatible with this interface.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SwapSections | Swaps the order of the given sections.
Top
Events
 | Name | Description
Public event | Connected | Event that is raised after this ISimInterface has been connected.
Public event | Connecting | Event that is raised when this ISimInterface is being connected.
Public event | Disconnected | Event that is raised after this ISimInterface has been disconnected.
Public event | Disconnecting | Event that is raised when this ISimInterface is being disconnected.
Public event | Match | Event that is raised when this ISimInterface checks if it matches with other interface.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISimInterface Properties

The ISimInterface type exposes the following members.

Properties
 | Name | Description
Public property | AngleTolerance | Gets or sets the angle tolerance of this ISimInterface.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConnectedComponents | Retrieves the collection of ISimComponent that are connected to this ISimInterface.
Public property | ConnectedInterfaces | Retrieves the collection of ISimInterface that are connected to this ISimInterface.
Public property | ConnectedSections | Retrieves the collection of ISimInterfaceSection that are connected to this ISimInterface.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Description | Gets or sets an user description of this ISimInterface.
Public property | EventFilter | Comma separated list of allowed client type names. (Inherited from IPropertyChangeFilter.)
Public property | IndicateDistance | Gets or sets the indicate distance of this ISimInterface.
Public property | IsApplication | Determines if this ISimInterface was created by the main application.
Public property | IsConnected | Retrieves the connection status of this ISimInterface.
Public property | IsLogical | Determines if this ISimInterface is logical (i.e. not connectable by plug and play).
Public property | IsOneToMany | Determines if this ISimInterface is one to many interface.
Public property | IsValid | (Inherited from IWrapper.)
Public property | MagnetDistance | Gets or sets the magnet distance of this ISimInterface.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Sections | Retrieves the collection of sections in this interface.
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

ISimInterface Interface
VisualComponents.Create3D Namespace


ISimInterface.AngleTolerance Property

ISimInterfaceAngleTolerance Property

Gets or sets the angle tolerance of this ISimInterface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double AngleTolerance { get; set; }
property double AngleTolerance {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ISimInterface Interface
VisualComponents.Create3D Namespace


ISimInterface.ConnectedComponents Property

ISimInterfaceConnectedComponents Property

Retrieves the collection of ISimComponent that are connected to this ISimInterface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ISimComponent> ConnectedComponents { get; }
property ReadOnlyCollection<ISimComponent^>^ ConnectedComponents {
    ReadOnlyCollection<ISimComponent^>^ get ();
}

Property Value

Type: ReadOnlyCollectionISimComponent
See Also

Reference

ISimInterface Interface
VisualComponents.Create3D Namespace


ISimInterface.ConnectedInterfaces Property

ISimInterfaceConnectedInterfaces Property

Retrieves the collection of ISimInterface that are connected to this ISimInterface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ISimInterface> ConnectedInterfaces { get; }
property ReadOnlyCollection<ISimInterface^>^ ConnectedInterfaces {
    ReadOnlyCollection<ISimInterface^>^ get ();
}

Property Value

Type: ReadOnlyCollectionISimInterface
See Also

Reference

ISimInterface Interface
VisualComponents.Create3D Namespace


ISimInterface.ConnectedSections Property

ISimInterfaceConnectedSections Property

Retrieves the collection of ISimInterfaceSection that are connected to this ISimInterface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ISimInterfaceSection> ConnectedSections { get; }
property ReadOnlyCollection<ISimInterfaceSection^>^ ConnectedSections {
    ReadOnlyCollection<ISimInterfaceSection^>^ get ();
}

Property Value

Type: ReadOnlyCollectionISimInterfaceSection
See Also

Reference

ISimInterface Interface
VisualComponents.Create3D Namespace


ISimInterface.Description Property

ISimInterfaceDescription Property

Gets or sets an user description of this ISimInterface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Description { get; set; }
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ISimInterface Interface
VisualComponents.Create3D Namespace


ISimInterface.IndicateDistance Property

ISimInterfaceIndicateDistance Property

Gets or sets the indicate distance of this ISimInterface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double IndicateDistance { get; set; }
property double IndicateDistance {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ISimInterface Interface
VisualComponents.Create3D Namespace


ISimInterface.IsApplication Property

ISimInterfaceIsApplication Property

Determines if this ISimInterface was created by the main application.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsApplication { get; }
property bool IsApplication {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimInterface Interface
VisualComponents.Create3D Namespace


ISimInterface.IsConnected Property

ISimInterfaceIsConnected Property

Retrieves the connection status of this ISimInterface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsConnected { get; }
property bool IsConnected {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimInterface Interface
VisualComponents.Create3D Namespace


ISimInterface.IsLogical Property

ISimInterfaceIsLogical Property

Determines if this ISimInterface is logical (i.e. not connectable by plug and play).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsLogical { get; set; }
property bool IsLogical {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Exceptions
Exception | Condition
InvalidOperationException | Thrown when interface is connected.
See Also

Reference

ISimInterface Interface
VisualComponents.Create3D Namespace


ISimInterface.IsOneToMany Property

ISimInterfaceIsOneToMany Property

Determines if this ISimInterface is one to many interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsOneToMany { get; }
property bool IsOneToMany {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimInterface Interface
VisualComponents.Create3D Namespace


ISimInterface.MagnetDistance Property

ISimInterfaceMagnetDistance Property

Gets or sets the magnet distance of this ISimInterface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double MagnetDistance { get; set; }
property double MagnetDistance {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ISimInterface Interface
VisualComponents.Create3D Namespace


ISimInterface.Sections Property

ISimInterfaceSections Property

Retrieves the collection of sections in this interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ISimInterfaceSection> Sections { get; }
property ReadOnlyCollection<ISimInterfaceSection^>^ Sections {
    ReadOnlyCollection<ISimInterfaceSection^>^ get ();
}

Property Value

Type: ReadOnlyCollectionISimInterfaceSection
See Also

Reference

ISimInterface Interface
VisualComponents.Create3D Namespace


ISimInterface Methods

The ISimInterface type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect(ISimInterface) | Connects the given ISimInterface to this interface without updating position of the owner component.
Public method | Connect(ISimInterface, Boolean) | Connects the given ISimInterface to this interface.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | CreateSection | Creates and adds a new ISimInterfaceSection to this interface.
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteSection | Deletes the given ISimInterfaceSection and removes it from this interface.
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects all the interfaces connected to this ISimInterface.
Public method | Disconnect(ISimInterface) | Disconnects the given interface from this ISimInterface.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | FindMatchingSections | Finds the first ISimInterfaceSection that matches the given section.
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | IsCompatibleWith | Checks if the given ISimInterface is compatible with this interface.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SwapSections | Swaps the order of the given sections.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISimInterface Interface
VisualComponents.Create3D Namespace


ISimInterface.Connect Method

ISimInterfaceConnect Method

Overload List
 | Name | Description
Public method | Connect(ISimInterface) | Connects the given ISimInterface to this interface without updating position of the owner component.
Public method | Connect(ISimInterface, Boolean) | Connects the given ISimInterface to this interface.
Top
See Also

Reference

ISimInterface Interface
VisualComponents.Create3D Namespace


ISimInterface.Connect Method (ISimInterface)

ISimInterfaceConnect Method (ISimInterface)

Connects the given ISimInterface to this interface without updating position of the owner component.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Connect(
    ISimInterface simInterface
)
void Connect(
    ISimInterface^ simInterface
)

Parameters

simInterface
Type: VisualComponents.Create3DISimInterface
The interface to connect to.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when simInterface parameter is null.
InvalidOperationException | Thrown when interface cannot be connected (it is one to one interface and already connected or interfaces do not match).
See Also

Reference

ISimInterface Interface
Connect Overload
VisualComponents.Create3D Namespace


ISimInterface.Connect Method (ISimInterface, Boolean)

ISimInterfaceConnect Method (ISimInterface, Boolean)

Connects the given ISimInterface to this interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Connect(
    ISimInterface simInterface,
    bool updatePosition
)
void Connect(
    ISimInterface^ simInterface,
    bool updatePosition
)

Parameters

simInterface
Type: VisualComponents.Create3DISimInterface
The interface to connect to.
updatePosition
Type: SystemBoolean
If true, updates the position of the component that owns this interface.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when simInterface parameter is null.
InvalidOperationException | Thrown when interface cannot be connected (it is one to one interface and already connected or interfaces do not match).
See Also

Reference

ISimInterface Interface
Connect Overload
VisualComponents.Create3D Namespace


ISimInterface.CreateSection Method

ISimInterfaceCreateSection Method

Creates and adds a new ISimInterfaceSection to this interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimInterfaceSection CreateSection(
    string name
)
ISimInterfaceSection^ CreateSection(
    String^ name
)

Parameters

name
Type: SystemString
Name of the interface section to be created.

Return Value

Type: ISimInterfaceSection
The created interface section.
Exceptions
Exception | Condition
ArgumentException | Thrown when name is null or empty.
InvalidOperationException | Thrown if the interface is one to many interface or the interface is connected.
See Also

Reference

ISimInterface Interface
VisualComponents.Create3D Namespace


ISimInterface.DeleteSection Method

ISimInterfaceDeleteSection Method

Deletes the given ISimInterfaceSection and removes it from this interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteSection(
    ISimInterfaceSection section
)
void DeleteSection(
    ISimInterfaceSection^ section
)

Parameters

section
Type: VisualComponents.Create3DISimInterfaceSection
The interface section to delete.
Exceptions
Exception | Condition
ArgumentException | Thrown when section is null.
InvalidOperationException | Thrown if the interface is connected.
See Also

Reference

ISimInterface Interface
VisualComponents.Create3D Namespace


ISimInterface.Disconnect Method

ISimInterfaceDisconnect Method

Overload List
 | Name | Description
Public method | Disconnect | Disconnects all the interfaces connected to this ISimInterface.
Public method | Disconnect(ISimInterface) | Disconnects the given interface from this ISimInterface.
Top
See Also

Reference

ISimInterface Interface
VisualComponents.Create3D Namespace


ISimInterface.Disconnect Method

ISimInterfaceDisconnect Method

Disconnects all the interfaces connected to this ISimInterface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Disconnect()
void Disconnect()
Exceptions
Exception | Condition
InvalidOperationException | Thrown when interface cannot be disconnected.
See Also

Reference

ISimInterface Interface
Disconnect Overload
VisualComponents.Create3D Namespace


ISimInterface.Disconnect Method (ISimInterface)

ISimInterfaceDisconnect Method (ISimInterface)

Disconnects the given interface from this ISimInterface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Disconnect(
    ISimInterface simInterface
)
void Disconnect(
    ISimInterface^ simInterface
)

Parameters

simInterface
Type: VisualComponents.Create3DISimInterface
The interface to disconnect from.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when interface cannot be disconnected.
See Also

Reference

ISimInterface Interface
Disconnect Overload
VisualComponents.Create3D Namespace


ISimInterface.FindMatchingSections Method

ISimInterfaceFindMatchingSections Method

Finds the first ISimInterfaceSection that matches the given section.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Tuple<ISimInterfaceSection, ISimInterfaceSection> FindMatchingSections(
    ISimInterface otherInterface
)
Tuple<ISimInterfaceSection^, ISimInterfaceSection^>^ FindMatchingSections(
    ISimInterface^ otherInterface
)

Parameters

otherInterface
Type: VisualComponents.Create3DISimInterface
The instance of ISimInterface to match against.

Return Value

Type: TupleISimInterfaceSection, ISimInterfaceSection
Tuple containing the matching sections. Returns null if no matching sections are found.
Exceptions
Exception | Condition
ArgumentException | Thrown when otherInterface is null.
See Also

Reference

ISimInterface Interface
VisualComponents.Create3D Namespace


ISimInterface.IsCompatibleWith Method

ISimInterfaceIsCompatibleWith Method

Checks if the given ISimInterface is compatible with this interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsCompatibleWith(
    ISimInterface simInterface
)
bool IsCompatibleWith(
    ISimInterface^ simInterface
)

Parameters

simInterface
Type: VisualComponents.Create3DISimInterface
Interface to check against.

Return Value

Type: Boolean
True if the interface is compatible.
Exceptions
Exception | Condition
ArgumentException | Thrown when simInterface is null.
See Also

Reference

ISimInterface Interface
VisualComponents.Create3D Namespace


ISimInterface.SwapSections Method

ISimInterfaceSwapSections Method

Swaps the order of the given sections.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SwapSections(
    int sectionIndex1,
    int sectionIndex2
)
void SwapSections(
    int sectionIndex1,
    int sectionIndex2
)

Parameters

sectionIndex1
Type: SystemInt32
The index of section 1
sectionIndex2
Type: SystemInt32
The index of section 2
Exceptions
Exception | Condition
InvalidOperationException | Thrown section1 or section2 is out of bounds.
See Also

Reference

ISimInterface Interface
VisualComponents.Create3D Namespace


ISimInterface Events

The ISimInterface type exposes the following members.

Events
 | Name | Description
Public event | Connected | Event that is raised after this ISimInterface has been connected.
Public event | Connecting | Event that is raised when this ISimInterface is being connected.
Public event | Disconnected | Event that is raised after this ISimInterface has been disconnected.
Public event | Disconnecting | Event that is raised when this ISimInterface is being disconnected.
Public event | Match | Event that is raised when this ISimInterface checks if it matches with other interface.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ISimInterface Interface
VisualComponents.Create3D Namespace


ISimInterface.Connected Event

ISimInterfaceConnected Event

Event that is raised after this ISimInterface has been connected.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<InterfaceConnectPostEventArgs> Connected
 event EventHandler<InterfaceConnectPostEventArgs^>^ Connected {
    void add (EventHandler<InterfaceConnectPostEventArgs^>^ value);
    void remove (EventHandler<InterfaceConnectPostEventArgs^>^ value);
}

Value

Type: SystemEventHandlerInterfaceConnectPostEventArgs
See Also

Reference

ISimInterface Interface
VisualComponents.Create3D Namespace


ISimInterface.Connecting Event

ISimInterfaceConnecting Event

Event that is raised when this ISimInterface is being connected.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<InterfaceConnectPreEventArgs> Connecting
 event EventHandler<InterfaceConnectPreEventArgs^>^ Connecting {
    void add (EventHandler<InterfaceConnectPreEventArgs^>^ value);
    void remove (EventHandler<InterfaceConnectPreEventArgs^>^ value);
}

Value

Type: SystemEventHandlerInterfaceConnectPreEventArgs
See Also

Reference

ISimInterface Interface
VisualComponents.Create3D Namespace


ISimInterface.Disconnected Event

ISimInterfaceDisconnected Event

Event that is raised after this ISimInterface has been disconnected.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<InterfaceConnectPostEventArgs> Disconnected
 event EventHandler<InterfaceConnectPostEventArgs^>^ Disconnected {
    void add (EventHandler<InterfaceConnectPostEventArgs^>^ value);
    void remove (EventHandler<InterfaceConnectPostEventArgs^>^ value);
}

Value

Type: SystemEventHandlerInterfaceConnectPostEventArgs
See Also

Reference

ISimInterface Interface
VisualComponents.Create3D Namespace


ISimInterface.Disconnecting Event

ISimInterfaceDisconnecting Event

Event that is raised when this ISimInterface is being disconnected.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<InterfaceConnectPreEventArgs> Disconnecting
 event EventHandler<InterfaceConnectPreEventArgs^>^ Disconnecting {
    void add (EventHandler<InterfaceConnectPreEventArgs^>^ value);
    void remove (EventHandler<InterfaceConnectPreEventArgs^>^ value);
}

Value

Type: SystemEventHandlerInterfaceConnectPreEventArgs
See Also

Reference

ISimInterface Interface
VisualComponents.Create3D Namespace


ISimInterface.Match Event

ISimInterfaceMatch Event

Event that is raised when this ISimInterface checks if it matches with other interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<InterfaceMatchEventArgs> Match
 event EventHandler<InterfaceMatchEventArgs^>^ Match {
    void add (EventHandler<InterfaceMatchEventArgs^>^ value);
    void remove (EventHandler<InterfaceMatchEventArgs^>^ value);
}

Value

Type: SystemEventHandlerInterfaceMatchEventArgs
See Also

Reference

ISimInterface Interface
VisualComponents.Create3D Namespace


ISimInterfaceActionField Interface

Field for connecting IActionContainer containers and plug&playing components.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimInterfaceActionField : ISimInterfaceField,
    IPropertyContainer, IBatchModeObject, IWrapper, IDisposable
public interface class ISimInterfaceActionField : ISimInterfaceField,
    IPropertyContainer, IBatchModeObject, IWrapper, IDisposable

The ISimInterfaceActionField type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets or sets the name of this interface field. (Inherited from ISimInterfaceField.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Section | Gets the section where this interface fields belongs to. (Inherited from ISimInterfaceField.)
Public property | Type | Gets the type of this interface field. (Inherited from ISimInterfaceField.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace
VisualComponents.Create3DISimAction
VisualComponents.Create3DIActionContainer
VisualComponents.Create3DISimInterface
VisualComponents.Create3DISimInterfaceSection
VisualComponents.Create3DISimInterfaceField


ISimInterfaceActionField Properties

The ISimInterfaceActionField type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets or sets the name of this interface field. (Inherited from ISimInterfaceField.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Section | Gets the section where this interface fields belongs to. (Inherited from ISimInterfaceField.)
Public property | Type | Gets the type of this interface field. (Inherited from ISimInterfaceField.)
Top
See Also

Reference

ISimInterfaceActionField Interface
VisualComponents.Create3D Namespace


ISimInterfaceActionField Methods

The ISimInterfaceActionField type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISimInterfaceActionField Interface
VisualComponents.Create3D Namespace


ISimInterfaceActionField Events

The ISimInterfaceActionField type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ISimInterfaceActionField Interface
VisualComponents.Create3D Namespace


ISimInterfaceAttachmentField Interface

Field for hierarchically attaching physical objects.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimInterfaceAttachmentField : ISimInterfaceField,
    IPropertyContainer, IBatchModeObject, IWrapper, IDisposable
public interface class ISimInterfaceAttachmentField : ISimInterfaceField,
    IPropertyContainer, IBatchModeObject, IWrapper, IDisposable

The ISimInterfaceAttachmentField type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Frame | Frame attached to the physical cable or attachement.
Public property | IsParent | Indicates that Node will be the parent.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets or sets the name of this interface field. (Inherited from ISimInterfaceField.)
Public property | Node | Node that is attached to another node on plug&play.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Section | Gets the section where this interface fields belongs to. (Inherited from ISimInterfaceField.)
Public property | Type | Gets the type of this interface field. (Inherited from ISimInterfaceField.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
Attaching is made without changing the parent of the component. This field is used mostly for physical cable attachments.
See Also

Reference

VisualComponents.Create3D Namespace
VisualComponents.Create3DISimInterface
VisualComponents.Create3DISimInterfaceSection
VisualComponents.Create3DISimInterfaceField


ISimInterfaceAttachmentField Properties

The ISimInterfaceAttachmentField type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Frame | Frame attached to the physical cable or attachement.
Public property | IsParent | Indicates that Node will be the parent.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets or sets the name of this interface field. (Inherited from ISimInterfaceField.)
Public property | Node | Node that is attached to another node on plug&play.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Section | Gets the section where this interface fields belongs to. (Inherited from ISimInterfaceField.)
Public property | Type | Gets the type of this interface field. (Inherited from ISimInterfaceField.)
Top
See Also

Reference

ISimInterfaceAttachmentField Interface
VisualComponents.Create3D Namespace


ISimInterfaceAttachmentField.Frame Property

ISimInterfaceAttachmentFieldFrame Property

Frame attached to the physical cable or attachement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFrameFeature Frame { get; }
property IFrameFeature^ Frame {
    IFrameFeature^ get ();
}

Property Value

Type: IFrameFeature
See Also

Reference

ISimInterfaceAttachmentField Interface
VisualComponents.Create3D Namespace


ISimInterfaceAttachmentField.IsParent Property

ISimInterfaceAttachmentFieldIsParent Property

Indicates that Node will be the parent.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsParent { get; }
property bool IsParent {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimInterfaceAttachmentField Interface
VisualComponents.Create3D Namespace


ISimInterfaceAttachmentField.Node Property

ISimInterfaceAttachmentFieldNode Property

Node that is attached to another node on plug&play.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode Node { get; }
property ISimNode^ Node {
    ISimNode^ get ();
}

Property Value

Type: ISimNode
See Also

Reference

ISimInterfaceAttachmentField Interface
VisualComponents.Create3D Namespace


ISimInterfaceAttachmentField Methods

The ISimInterfaceAttachmentField type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISimInterfaceAttachmentField Interface
VisualComponents.Create3D Namespace


ISimInterfaceAttachmentField Events

The ISimInterfaceAttachmentField type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ISimInterfaceAttachmentField Interface
VisualComponents.Create3D Namespace


ISimInterfaceBaseExportField Interface

Field for adding additional base frames to a robot controller.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimInterfaceBaseExportField : ISimInterfaceField,
    IPropertyContainer, IBatchModeObject, IWrapper, IDisposable
public interface class ISimInterfaceBaseExportField : ISimInterfaceField,
    IPropertyContainer, IBatchModeObject, IWrapper, IDisposable

The ISimInterfaceBaseExportField type exposes the following members.

Properties
 | Name | Description
Public property | BaseList | Defines the IBaseContainer or IRobotController behavior whose bases will be exporter/imported.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Export | Defines if the bases in BaseList are exported or imported to the connected interface.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets or sets the name of this interface field. (Inherited from ISimInterfaceField.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Section | Gets the section where this interface fields belongs to. (Inherited from ISimInterfaceField.)
Public property | Type | Gets the type of this interface field. (Inherited from ISimInterfaceField.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace
VisualComponents.Create3DISimInterface
VisualComponents.Create3DISimInterfaceSection
VisualComponents.Create3DISimInterfaceField


ISimInterfaceBaseExportField Properties

The ISimInterfaceBaseExportField type exposes the following members.

Properties
 | Name | Description
Public property | BaseList | Defines the IBaseContainer or IRobotController behavior whose bases will be exporter/imported.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Export | Defines if the bases in BaseList are exported or imported to the connected interface.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets or sets the name of this interface field. (Inherited from ISimInterfaceField.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Section | Gets the section where this interface fields belongs to. (Inherited from ISimInterfaceField.)
Public property | Type | Gets the type of this interface field. (Inherited from ISimInterfaceField.)
Top
See Also

Reference

ISimInterfaceBaseExportField Interface
VisualComponents.Create3D Namespace


ISimInterfaceBaseExportField.BaseList Property

ISimInterfaceBaseExportFieldBaseList Property

Defines the IBaseContainer or IRobotController behavior whose bases will be exporter/imported.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IBehavior BaseList { get; set; }
property IBehavior^ BaseList {
    IBehavior^ get ();
    void set (IBehavior^ value);
}

Property Value

Type: IBehavior
See Also

Reference

ISimInterfaceBaseExportField Interface
VisualComponents.Create3D Namespace


ISimInterfaceBaseExportField.Export Property

ISimInterfaceBaseExportFieldExport Property

Defines if the bases in BaseList are exported or imported to the connected interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool Export { get; set; }
property bool Export {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISimInterfaceBaseExportField Interface
VisualComponents.Create3D Namespace


ISimInterfaceBaseExportField Methods

The ISimInterfaceBaseExportField type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISimInterfaceBaseExportField Interface
VisualComponents.Create3D Namespace


ISimInterfaceBaseExportField Events

The ISimInterfaceBaseExportField type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ISimInterfaceBaseExportField Interface
VisualComponents.Create3D Namespace


ISimInterfaceField Interface

Plug&play interface field.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimInterfaceField : IPropertyContainer,
    IBatchModeObject, IWrapper, IDisposable
public interface class ISimInterfaceField : IPropertyContainer,
    IBatchModeObject, IWrapper, IDisposable

The ISimInterfaceField type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets or sets the name of this interface field.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Section | Gets the section where this interface fields belongs to.
Public property | Type | Gets the type of this interface field.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
Typically each ISimInterfaceSection defines one or more fields.
See Also

Reference

VisualComponents.Create3D Namespace
VisualComponents.Create3DISimInterface
VisualComponents.Create3DISimInterfaceSection


ISimInterfaceField Properties

The ISimInterfaceField type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets or sets the name of this interface field.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Section | Gets the section where this interface fields belongs to.
Public property | Type | Gets the type of this interface field.
Top
See Also

Reference

ISimInterfaceField Interface
VisualComponents.Create3D Namespace


ISimInterfaceField.Name Property

ISimInterfaceFieldName Property

Gets or sets the name of this interface field.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Name { get; set; }
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ISimInterfaceField Interface
VisualComponents.Create3D Namespace


ISimInterfaceField.Section Property

ISimInterfaceFieldSection Property

Gets the section where this interface fields belongs to.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimInterfaceSection Section { get; }
property ISimInterfaceSection^ Section {
    ISimInterfaceSection^ get ();
}

Property Value

Type: ISimInterfaceSection
See Also

Reference

ISimInterfaceField Interface
VisualComponents.Create3D Namespace


ISimInterfaceField.Type Property

ISimInterfaceFieldType Property

Gets the type of this interface field.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
SimInterfaceFieldType Type { get; }
property SimInterfaceFieldType Type {
    SimInterfaceFieldType get ();
}

Property Value

Type: SimInterfaceFieldType
See Also

Reference

ISimInterfaceField Interface
VisualComponents.Create3D Namespace


ISimInterfaceField Methods

The ISimInterfaceField type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISimInterfaceField Interface
VisualComponents.Create3D Namespace


ISimInterfaceField Events

The ISimInterfaceField type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ISimInterfaceField Interface
VisualComponents.Create3D Namespace


ISimInterfaceFlowField Interface

Field for connecting two ISimConnector connectors and facilitating a material flow between component containers.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimInterfaceFlowField : ISimInterfaceField,
    IPropertyContainer, IBatchModeObject, IWrapper, IDisposable
public interface class ISimInterfaceFlowField : ISimInterfaceField,
    IPropertyContainer, IBatchModeObject, IWrapper, IDisposable

The ISimInterfaceFlowField type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets or sets the name of this interface field. (Inherited from ISimInterfaceField.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Port | Gets or sets the instance of ISimConnector that will be connected when the interface will be connected.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Section | Gets the section where this interface fields belongs to. (Inherited from ISimInterfaceField.)
Public property | Type | Gets the type of this interface field. (Inherited from ISimInterfaceField.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace
VisualComponents.Create3DISimConnector
VisualComponents.Create3DISimInterface
VisualComponents.Create3DISimInterfaceSection


ISimInterfaceFlowField Properties

The ISimInterfaceFlowField type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets or sets the name of this interface field. (Inherited from ISimInterfaceField.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Port | Gets or sets the instance of ISimConnector that will be connected when the interface will be connected.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Section | Gets the section where this interface fields belongs to. (Inherited from ISimInterfaceField.)
Public property | Type | Gets the type of this interface field. (Inherited from ISimInterfaceField.)
Top
See Also

Reference

ISimInterfaceFlowField Interface
VisualComponents.Create3D Namespace


ISimInterfaceFlowField.Port Property

ISimInterfaceFlowFieldPort Property

Gets or sets the instance of ISimConnector that will be connected when the interface will be connected.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimConnector Port { get; set; }
property ISimConnector^ Port {
    ISimConnector^ get ();
    void set (ISimConnector^ value);
}

Property Value

Type: ISimConnector
See Also

Reference

ISimInterfaceFlowField Interface
VisualComponents.Create3D Namespace


ISimInterfaceFlowField Methods

The ISimInterfaceFlowField type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISimInterfaceFlowField Interface
VisualComponents.Create3D Namespace


ISimInterfaceFlowField Events

The ISimInterfaceFlowField type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ISimInterfaceFlowField Interface
VisualComponents.Create3D Namespace


ISimInterfaceHierarchyField Interface

Field for connecting components hierarchically.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimInterfaceHierarchyField : ISimInterfaceField,
    IPropertyContainer, IBatchModeObject, IWrapper, IDisposable
public interface class ISimInterfaceHierarchyField : ISimInterfaceField,
    IPropertyContainer, IBatchModeObject, IWrapper, IDisposable

The ISimInterfaceHierarchyField type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Frame | Gets or sets the IFrameFeature that defines the attachment position.
Public property | IsParent | Defines if this component will be a parent or a child. If this field is the parent, the opposite side needs to be the child and vice versa.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets or sets the name of this interface field. (Inherited from ISimInterfaceField.)
Public property | Node | Gets or sets the ISimNode for which the child component will be attached to. This is valid only for parent fields, child component is always attached from its root node.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Section | Gets the section where this interface fields belongs to. (Inherited from ISimInterfaceField.)
Public property | Type | Gets the type of this interface field. (Inherited from ISimInterfaceField.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace
VisualComponents.Create3DISimInterface
VisualComponents.Create3DISimInterfaceSection
VisualComponents.Create3DISimInterfaceField


ISimInterfaceHierarchyField Properties

The ISimInterfaceHierarchyField type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Frame | Gets or sets the IFrameFeature that defines the attachment position.
Public property | IsParent | Defines if this component will be a parent or a child. If this field is the parent, the opposite side needs to be the child and vice versa.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets or sets the name of this interface field. (Inherited from ISimInterfaceField.)
Public property | Node | Gets or sets the ISimNode for which the child component will be attached to. This is valid only for parent fields, child component is always attached from its root node.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Section | Gets the section where this interface fields belongs to. (Inherited from ISimInterfaceField.)
Public property | Type | Gets the type of this interface field. (Inherited from ISimInterfaceField.)
Top
See Also

Reference

ISimInterfaceHierarchyField Interface
VisualComponents.Create3D Namespace


ISimInterfaceHierarchyField.Frame Property

ISimInterfaceHierarchyFieldFrame Property

Gets or sets the IFrameFeature that defines the attachment position.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFrameFeature Frame { get; set; }
property IFrameFeature^ Frame {
    IFrameFeature^ get ();
    void set (IFrameFeature^ value);
}

Property Value

Type: IFrameFeature
See Also

Reference

ISimInterfaceHierarchyField Interface
VisualComponents.Create3D Namespace


ISimInterfaceHierarchyField.IsParent Property

ISimInterfaceHierarchyFieldIsParent Property

Defines if this component will be a parent or a child. If this field is the parent, the opposite side needs to be the child and vice versa.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsParent { get; set; }
property bool IsParent {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISimInterfaceHierarchyField Interface
VisualComponents.Create3D Namespace


ISimInterfaceHierarchyField.Node Property

ISimInterfaceHierarchyFieldNode Property

Gets or sets the ISimNode for which the child component will be attached to. This is valid only for parent fields, child component is always attached from its root node.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode Node { get; set; }
property ISimNode^ Node {
    ISimNode^ get ();
    void set (ISimNode^ value);
}

Property Value

Type: ISimNode
See Also

Reference

ISimInterfaceHierarchyField Interface
VisualComponents.Create3D Namespace


ISimInterfaceHierarchyField Methods

The ISimInterfaceHierarchyField type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISimInterfaceHierarchyField Interface
VisualComponents.Create3D Namespace


ISimInterfaceHierarchyField Events

The ISimInterfaceHierarchyField type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ISimInterfaceHierarchyField Interface
VisualComponents.Create3D Namespace


ISimInterfaceIntegerCompatibilityField Interface

Field defining comparison mechanism for interfaces, which have the same amount of fields, but different restrictions.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimInterfaceIntegerCompatibilityField : ISimInterfaceField,
    IPropertyContainer, IBatchModeObject, IWrapper, IDisposable
public interface class ISimInterfaceIntegerCompatibilityField : ISimInterfaceField,
    IPropertyContainer, IBatchModeObject, IWrapper, IDisposable

The ISimInterfaceIntegerCompatibilityField type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets or sets the name of this interface field. (Inherited from ISimInterfaceField.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Section | Gets the section where this interface fields belongs to. (Inherited from ISimInterfaceField.)
Public property | Type | Gets the type of this interface field. (Inherited from ISimInterfaceField.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace
VisualComponents.Create3DISimInterface
VisualComponents.Create3DISimInterfaceSection
VisualComponents.Create3DISimInterfaceField


ISimInterfaceIntegerCompatibilityField Properties

The ISimInterfaceIntegerCompatibilityField type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets or sets the name of this interface field. (Inherited from ISimInterfaceField.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Section | Gets the section where this interface fields belongs to. (Inherited from ISimInterfaceField.)
Public property | Type | Gets the type of this interface field. (Inherited from ISimInterfaceField.)
Top
See Also

Reference

ISimInterfaceIntegerCompatibilityField Interface
VisualComponents.Create3D Namespace


ISimInterfaceIntegerCompatibilityField Methods

The ISimInterfaceIntegerCompatibilityField type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISimInterfaceIntegerCompatibilityField Interface
VisualComponents.Create3D Namespace


ISimInterfaceIntegerCompatibilityField Events

The ISimInterfaceIntegerCompatibilityField type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ISimInterfaceIntegerCompatibilityField Interface
VisualComponents.Create3D Namespace


ISimInterfaceJointExportField Interface

Field for adding servo's joints to a servo controller.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimInterfaceJointExportField : ISimInterfaceField,
    IPropertyContainer, IBatchModeObject, IWrapper, IDisposable
public interface class ISimInterfaceJointExportField : ISimInterfaceField,
    IPropertyContainer, IBatchModeObject, IWrapper, IDisposable

The ISimInterfaceJointExportField type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Controller | Gets or sets the IServoController whose joints are exported or who receives the imported joints.
Public property | ExportJoints | Defines if the joints are exported or imported.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets or sets the name of this interface field. (Inherited from ISimInterfaceField.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Section | Gets the section where this interface fields belongs to. (Inherited from ISimInterfaceField.)
Public property | Type | Gets the type of this interface field. (Inherited from ISimInterfaceField.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace
VisualComponents.Create3DISimInterface
VisualComponents.Create3DISimInterfaceSection
VisualComponents.Create3DISimInterfaceField


ISimInterfaceJointExportField Properties

The ISimInterfaceJointExportField type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Controller | Gets or sets the IServoController whose joints are exported or who receives the imported joints.
Public property | ExportJoints | Defines if the joints are exported or imported.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets or sets the name of this interface field. (Inherited from ISimInterfaceField.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Section | Gets the section where this interface fields belongs to. (Inherited from ISimInterfaceField.)
Public property | Type | Gets the type of this interface field. (Inherited from ISimInterfaceField.)
Top
See Also

Reference

ISimInterfaceJointExportField Interface
VisualComponents.Create3D Namespace


ISimInterfaceJointExportField.Controller Property

ISimInterfaceJointExportFieldController Property

Gets or sets the IServoController whose joints are exported or who receives the imported joints.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IServoController Controller { get; set; }
property IServoController^ Controller {
    IServoController^ get ();
    void set (IServoController^ value);
}

Property Value

Type: IServoController
See Also

Reference

ISimInterfaceJointExportField Interface
VisualComponents.Create3D Namespace


ISimInterfaceJointExportField.ExportJoints Property

ISimInterfaceJointExportFieldExportJoints Property

Defines if the joints are exported or imported.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ExportJoints { get; set; }
property bool ExportJoints {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISimInterfaceJointExportField Interface
VisualComponents.Create3D Namespace


ISimInterfaceJointExportField Methods

The ISimInterfaceJointExportField type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISimInterfaceJointExportField Interface
VisualComponents.Create3D Namespace


ISimInterfaceJointExportField Events

The ISimInterfaceJointExportField type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ISimInterfaceJointExportField Interface
VisualComponents.Create3D Namespace


ISimInterfaceProcessorField Interface

Field for connecting process points to motion paths.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimInterfaceProcessorField : ISimInterfaceField,
    IPropertyContainer, IBatchModeObject, IWrapper, IDisposable
public interface class ISimInterfaceProcessorField : ISimInterfaceField,
    IPropertyContainer, IBatchModeObject, IWrapper, IDisposable

The ISimInterfaceProcessorField type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsParent | Defines if the field is a parent or child field. A parent field utilizes a path behavior. A child field utilizes a sensor behavior.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets or sets the name of this interface field. (Inherited from ISimInterfaceField.)
Public property | Path | Gets or sets the motion path behavior. This is valid for for parent fields only.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Section | Gets the section where this interface fields belongs to. (Inherited from ISimInterfaceField.)
Public property | Sensor | Gets or sets the sensor behavior. This is valid for child fields only.
Public property | Type | Gets the type of this interface field. (Inherited from ISimInterfaceField.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace
VisualComponents.Create3DISimInterface
VisualComponents.Create3DISimInterfaceSection
VisualComponents.Create3DISimInterfaceField


ISimInterfaceProcessorField Properties

The ISimInterfaceProcessorField type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsParent | Defines if the field is a parent or child field. A parent field utilizes a path behavior. A child field utilizes a sensor behavior.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets or sets the name of this interface field. (Inherited from ISimInterfaceField.)
Public property | Path | Gets or sets the motion path behavior. This is valid for for parent fields only.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Section | Gets the section where this interface fields belongs to. (Inherited from ISimInterfaceField.)
Public property | Sensor | Gets or sets the sensor behavior. This is valid for child fields only.
Public property | Type | Gets the type of this interface field. (Inherited from ISimInterfaceField.)
Top
See Also

Reference

ISimInterfaceProcessorField Interface
VisualComponents.Create3D Namespace


ISimInterfaceProcessorField.IsParent Property

ISimInterfaceProcessorFieldIsParent Property

Defines if the field is a parent or child field. A parent field utilizes a path behavior. A child field utilizes a sensor behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsParent { get; set; }
property bool IsParent {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISimInterfaceProcessorField Interface
VisualComponents.Create3D Namespace


ISimInterfaceProcessorField.Path Property

ISimInterfaceProcessorFieldPath Property

Gets or sets the motion path behavior. This is valid for for parent fields only.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMotionPath Path { get; set; }
property IMotionPath^ Path {
    IMotionPath^ get ();
    void set (IMotionPath^ value);
}

Property Value

Type: IMotionPath
See Also

Reference

ISimInterfaceProcessorField Interface
VisualComponents.Create3D Namespace


ISimInterfaceProcessorField.Sensor Property

ISimInterfaceProcessorFieldSensor Property

Gets or sets the sensor behavior. This is valid for child fields only.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IBehavior Sensor { get; set; }
property IBehavior^ Sensor {
    IBehavior^ get ();
    void set (IBehavior^ value);
}

Property Value

Type: IBehavior
See Also

Reference

ISimInterfaceProcessorField Interface
VisualComponents.Create3D Namespace


ISimInterfaceProcessorField Methods

The ISimInterfaceProcessorField type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISimInterfaceProcessorField Interface
VisualComponents.Create3D Namespace


ISimInterfaceProcessorField Events

The ISimInterfaceProcessorField type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ISimInterfaceProcessorField Interface
VisualComponents.Create3D Namespace


ISimInterfaceRSLField Interface

Field connecting RSL publishers.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimInterfaceRSLField : ISimInterfaceField,
    IPropertyContainer, IBatchModeObject, IWrapper, IDisposable
public interface class ISimInterfaceRSLField : ISimInterfaceField,
    IPropertyContainer, IBatchModeObject, IWrapper, IDisposable

The ISimInterfaceRSLField type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets or sets the name of this interface field. (Inherited from ISimInterfaceField.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Section | Gets the section where this interface fields belongs to. (Inherited from ISimInterfaceField.)
Public property | Type | Gets the type of this interface field. (Inherited from ISimInterfaceField.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace
VisualComponents.Create3DISimInterface
VisualComponents.Create3DISimInterfaceSection
VisualComponents.Create3DISimInterfaceField


ISimInterfaceRSLField Properties

The ISimInterfaceRSLField type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets or sets the name of this interface field. (Inherited from ISimInterfaceField.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Section | Gets the section where this interface fields belongs to. (Inherited from ISimInterfaceField.)
Public property | Type | Gets the type of this interface field. (Inherited from ISimInterfaceField.)
Top
See Also

Reference

ISimInterfaceRSLField Interface
VisualComponents.Create3D Namespace


ISimInterfaceRSLField Methods

The ISimInterfaceRSLField type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISimInterfaceRSLField Interface
VisualComponents.Create3D Namespace


ISimInterfaceRSLField Events

The ISimInterfaceRSLField type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ISimInterfaceRSLField Interface
VisualComponents.Create3D Namespace


ISimInterfaceSection Interface

Simulation interface section.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimInterfaceSection : IWrapper,
    IDisposable
public interface class ISimInterfaceSection : IWrapper,
    IDisposable

The ISimInterfaceSection type exposes the following members.

Properties
 | Name | Description
Public property | ConnectedSection | Gets the interface section connected to this interface section.
Public property | Fields | Gets the collection of ISimInterfaceField contained by this inteface section.
Public property | Frame | Gets or sets the frame feature associated with this section.
Public property | FramePrimitive | Gets the IFrame instance belonging to the Frame feature.
Public property | Interface | Gets the ISimInterface for which this interface section belongs to.
Public property | IsConnected | Gets the boolean value indicating if this interface section is connected or not.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets or sets the name of this inteface section.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Top
Methods
 | Name | Description
Public method | CreateFieldT(String) | Creates and adds a new instance of ISimInterfaceField to this interface section.
Public method | CreateFieldT(String, Int32) | Creates and adds a new instance of ISimInterfaceField to this interface section.
Public method | DeleteField | Removes and deletes the given ISimInterfaceField.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | IsCompatibleWith | Tests if the given interface section is compatible with this interface section.
Public method | SwapFields | Swaps the order of ISimInterfaceField instances at given indexes.
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
Typically each ISimInterface behavior defines one or more sections.
See Also

Reference

VisualComponents.Create3D Namespace


ISimInterfaceSection Properties

The ISimInterfaceSection type exposes the following members.

Properties
 | Name | Description
Public property | ConnectedSection | Gets the interface section connected to this interface section.
Public property | Fields | Gets the collection of ISimInterfaceField contained by this inteface section.
Public property | Frame | Gets or sets the frame feature associated with this section.
Public property | FramePrimitive | Gets the IFrame instance belonging to the Frame feature.
Public property | Interface | Gets the ISimInterface for which this interface section belongs to.
Public property | IsConnected | Gets the boolean value indicating if this interface section is connected or not.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets or sets the name of this inteface section.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Top
See Also

Reference

ISimInterfaceSection Interface
VisualComponents.Create3D Namespace


ISimInterfaceSection.ConnectedSection Property

ISimInterfaceSectionConnectedSection Property

Gets the interface section connected to this interface section.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimInterfaceSection ConnectedSection { get; }
property ISimInterfaceSection^ ConnectedSection {
    ISimInterfaceSection^ get ();
}

Property Value

Type: ISimInterfaceSection
See Also

Reference

ISimInterfaceSection Interface
VisualComponents.Create3D Namespace


ISimInterfaceSection.Fields Property

ISimInterfaceSectionFields Property

Gets the collection of ISimInterfaceField contained by this inteface section.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ISimInterfaceField> Fields { get; }
property ReadOnlyCollection<ISimInterfaceField^>^ Fields {
    ReadOnlyCollection<ISimInterfaceField^>^ get ();
}

Property Value

Type: ReadOnlyCollectionISimInterfaceField
See Also

Reference

ISimInterfaceSection Interface
VisualComponents.Create3D Namespace


ISimInterfaceSection.Frame Property

ISimInterfaceSectionFrame Property

Gets or sets the frame feature associated with this section.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFeature Frame { get; set; }
property IFeature^ Frame {
    IFeature^ get ();
    void set (IFeature^ value);
}

Property Value

Type: IFeature
Exceptions
Exception | Condition
ArgumentException | Thrown when feature is not of type IFrameFeature.
See Also

Reference

ISimInterfaceSection Interface
VisualComponents.Create3D Namespace


ISimInterfaceSection.FramePrimitive Property

ISimInterfaceSectionFramePrimitive Property

Gets the IFrame instance belonging to the Frame feature.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFrame FramePrimitive { get; }
property IFrame^ FramePrimitive {
    IFrame^ get ();
}

Property Value

Type: IFrame
See Also

Reference

ISimInterfaceSection Interface
VisualComponents.Create3D Namespace


ISimInterfaceSection.Interface Property

ISimInterfaceSectionInterface Property

Gets the ISimInterface for which this interface section belongs to.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimInterface Interface { get; }
property ISimInterface^ Interface {
    ISimInterface^ get ();
}

Property Value

Type: ISimInterface
See Also

Reference

ISimInterfaceSection Interface
VisualComponents.Create3D Namespace


ISimInterfaceSection.IsConnected Property

ISimInterfaceSectionIsConnected Property

Gets the boolean value indicating if this interface section is connected or not.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsConnected { get; }
property bool IsConnected {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimInterfaceSection Interface
VisualComponents.Create3D Namespace


ISimInterfaceSection.Name Property

ISimInterfaceSectionName Property

Gets or sets the name of this inteface section.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Name { get; set; }
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ISimInterfaceSection Interface
VisualComponents.Create3D Namespace


ISimInterfaceSection Methods

The ISimInterfaceSection type exposes the following members.

Methods
 | Name | Description
Public method | CreateFieldT(String) | Creates and adds a new instance of ISimInterfaceField to this interface section.
Public method | CreateFieldT(String, Int32) | Creates and adds a new instance of ISimInterfaceField to this interface section.
Public method | DeleteField | Removes and deletes the given ISimInterfaceField.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | IsCompatibleWith | Tests if the given interface section is compatible with this interface section.
Public method | SwapFields | Swaps the order of ISimInterfaceField instances at given indexes.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISimInterfaceSection Interface
VisualComponents.Create3D Namespace


ISimInterfaceSection.CreateField Method

ISimInterfaceSectionCreateField Method

Overload List
 | Name | Description
Public method | CreateFieldT(String) | Creates and adds a new instance of ISimInterfaceField to this interface section.
Public method | CreateFieldT(String, Int32) | Creates and adds a new instance of ISimInterfaceField to this interface section.
Top
See Also

Reference

ISimInterfaceSection Interface
VisualComponents.Create3D Namespace


ISimInterfaceSection.CreateField(T) Method (String)

ISimInterfaceSectionCreateFieldT Method (String)

Creates and adds a new instance of ISimInterfaceField to this interface section.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
T CreateField<T>(
    string name
)
where T : ISimInterfaceField

generic<typename T>
where T : ISimInterfaceField
T CreateField(
    String^ name
)

Parameters

name
Type: SystemString
Name of the field to be created.

Type Parameters

T
Type of the field to be created.

Return Value

Type: T
Created field instance.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when name is null.
InvalidOperationException | Thrown when the interface is connected or given type is not supported.
See Also

Reference

ISimInterfaceSection Interface
CreateField Overload
VisualComponents.Create3D Namespace


ISimInterfaceSection.CreateField(T) Method (String, Int32)

ISimInterfaceSectionCreateFieldT Method (String, Int32)

Creates and adds a new instance of ISimInterfaceField to this interface section.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
T CreateField<T>(
    string name,
    int position
)
where T : ISimInterfaceField

generic<typename T>
where T : ISimInterfaceField
T CreateField(
    String^ name,
    int position
)

Parameters

name
Type: SystemString
Name of the field to be created.
position
Type: SystemInt32
Insertion index.

Type Parameters

T
Type of the field to be created.

Return Value

Type: T
Created field instance.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when name is null.
InvalidOperationException | Thrown when the interface is connected or given type is not supported.
See Also

Reference

ISimInterfaceSection Interface
CreateField Overload
VisualComponents.Create3D Namespace


ISimInterfaceSection.DeleteField Method

ISimInterfaceSectionDeleteField Method

Removes and deletes the given ISimInterfaceField.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteField(
    ISimInterfaceField field
)
void DeleteField(
    ISimInterfaceField^ field
)

Parameters

field
Type: VisualComponents.Create3DISimInterfaceField
Field to be deleted.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when field is null.
InvalidOperationException | Thrown when the interface is connected.
See Also

Reference

ISimInterfaceSection Interface
VisualComponents.Create3D Namespace


ISimInterfaceSection.IsCompatibleWith Method

ISimInterfaceSectionIsCompatibleWith Method

Tests if the given interface section is compatible with this interface section.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsCompatibleWith(
    ISimInterfaceSection section
)
bool IsCompatibleWith(
    ISimInterfaceSection^ section
)

Parameters

section
Type: VisualComponents.Create3DISimInterfaceSection
Section to test against.

Return Value

Type: Boolean
True if connection between these sections is possible.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when section is null.
Remarks
This does not check if the sections are already connected or not.
See Also

Reference

ISimInterfaceSection Interface
VisualComponents.Create3D Namespace


ISimInterfaceSection.SwapFields Method

ISimInterfaceSectionSwapFields Method

Swaps the order of ISimInterfaceField instances at given indexes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SwapFields(
    int fieldIndex1,
    int fieldIndex2
)
void SwapFields(
    int fieldIndex1,
    int fieldIndex2
)

Parameters

fieldIndex1
Type: SystemInt32
First field index.
fieldIndex2
Type: SystemInt32
Second field index.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when fieldIndex1 or fieldIndex2 is out of bounds.
See Also

Reference

ISimInterfaceSection Interface
VisualComponents.Create3D Namespace


ISimInterfaceSection Events

The ISimInterfaceSection type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
See Also

Reference

ISimInterfaceSection Interface
VisualComponents.Create3D Namespace


ISimInterfaceSignalField Interface

Field for connecting signal behaviors.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimInterfaceSignalField : ISimInterfaceField,
    IPropertyContainer, IBatchModeObject, IWrapper, IDisposable
public interface class ISimInterfaceSignalField : ISimInterfaceField,
    IPropertyContainer, IBatchModeObject, IWrapper, IDisposable

The ISimInterfaceSignalField type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets or sets the name of this interface field. (Inherited from ISimInterfaceField.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Section | Gets the section where this interface fields belongs to. (Inherited from ISimInterfaceField.)
Public property | Signal | Gets or sets ISignal that is connected when the owning ISimInterface is connected.
Public property | Type | Gets the type of this interface field. (Inherited from ISimInterfaceField.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
ISignal is used to transmit information received from a sensor in a component or relay information between two or more components.
See Also

Reference

VisualComponents.Create3D Namespace
VisualComponents.Create3DISimInterface
VisualComponents.Create3DISimInterfaceSection
VisualComponents.Create3DISimInterfaceField


ISimInterfaceSignalField Properties

The ISimInterfaceSignalField type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets or sets the name of this interface field. (Inherited from ISimInterfaceField.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Section | Gets the section where this interface fields belongs to. (Inherited from ISimInterfaceField.)
Public property | Signal | Gets or sets ISignal that is connected when the owning ISimInterface is connected.
Public property | Type | Gets the type of this interface field. (Inherited from ISimInterfaceField.)
Top
See Also

Reference

ISimInterfaceSignalField Interface
VisualComponents.Create3D Namespace


ISimInterfaceSignalField.Signal Property

ISimInterfaceSignalFieldSignal Property

Gets or sets ISignal that is connected when the owning ISimInterface is connected.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISignal Signal { get; set; }
property ISignal^ Signal {
    ISignal^ get ();
    void set (ISignal^ value);
}

Property Value

Type: ISignal
See Also

Reference

ISimInterfaceSignalField Interface
VisualComponents.Create3D Namespace


ISimInterfaceSignalField Methods

The ISimInterfaceSignalField type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISimInterfaceSignalField Interface
VisualComponents.Create3D Namespace


ISimInterfaceSignalField Events

The ISimInterfaceSignalField type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ISimInterfaceSignalField Interface
VisualComponents.Create3D Namespace


ISimInterfaceToolExportField Interface

Field for adding additional tool frames to a IRobotController.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimInterfaceToolExportField : ISimInterfaceField,
    IPropertyContainer, IBatchModeObject, IWrapper, IDisposable
public interface class ISimInterfaceToolExportField : ISimInterfaceField,
    IPropertyContainer, IBatchModeObject, IWrapper, IDisposable

The ISimInterfaceToolExportField type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Export | Defines if the tools in ToolList are exported or imported to the connected interface.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets or sets the name of this interface field. (Inherited from ISimInterfaceField.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Section | Gets the section where this interface fields belongs to. (Inherited from ISimInterfaceField.)
Public property | ToolList | Defines the IToolContainer or IRobotController behavior whose tools will be exporter/imported.
Public property | Type | Gets the type of this interface field. (Inherited from ISimInterfaceField.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace
VisualComponents.Create3DISimInterface
VisualComponents.Create3DISimInterfaceSection
VisualComponents.Create3DISimInterfaceField


ISimInterfaceToolExportField Properties

The ISimInterfaceToolExportField type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Export | Defines if the tools in ToolList are exported or imported to the connected interface.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets or sets the name of this interface field. (Inherited from ISimInterfaceField.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Section | Gets the section where this interface fields belongs to. (Inherited from ISimInterfaceField.)
Public property | ToolList | Defines the IToolContainer or IRobotController behavior whose tools will be exporter/imported.
Public property | Type | Gets the type of this interface field. (Inherited from ISimInterfaceField.)
Top
See Also

Reference

ISimInterfaceToolExportField Interface
VisualComponents.Create3D Namespace


ISimInterfaceToolExportField.Export Property

ISimInterfaceToolExportFieldExport Property

Defines if the tools in ToolList are exported or imported to the connected interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool Export { get; set; }
property bool Export {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISimInterfaceToolExportField Interface
VisualComponents.Create3D Namespace


ISimInterfaceToolExportField.ToolList Property

ISimInterfaceToolExportFieldToolList Property

Defines the IToolContainer or IRobotController behavior whose tools will be exporter/imported.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IBehavior ToolList { get; set; }
property IBehavior^ ToolList {
    IBehavior^ get ();
    void set (IBehavior^ value);
}

Property Value

Type: IBehavior
See Also

Reference

ISimInterfaceToolExportField Interface
VisualComponents.Create3D Namespace


ISimInterfaceToolExportField Methods

The ISimInterfaceToolExportField type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISimInterfaceToolExportField Interface
VisualComponents.Create3D Namespace


ISimInterfaceToolExportField Events

The ISimInterfaceToolExportField type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ISimInterfaceToolExportField Interface
VisualComponents.Create3D Namespace


ISimInterfaceTransportField Interface

Field for connecting ITransportProtocol containers/behaviors.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimInterfaceTransportField : ISimInterfaceField,
    IPropertyContainer, IBatchModeObject, IWrapper, IDisposable
public interface class ISimInterfaceTransportField : ISimInterfaceField,
    IPropertyContainer, IBatchModeObject, IWrapper, IDisposable

The ISimInterfaceTransportField type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets or sets the name of this interface field. (Inherited from ISimInterfaceField.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Section | Gets the section where this interface fields belongs to. (Inherited from ISimInterfaceField.)
Public property | Type | Gets the type of this interface field. (Inherited from ISimInterfaceField.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace
VisualComponents.Create3DITransportProtocol


ISimInterfaceTransportField Properties

The ISimInterfaceTransportField type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Gets or sets the name of this interface field. (Inherited from ISimInterfaceField.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Section | Gets the section where this interface fields belongs to. (Inherited from ISimInterfaceField.)
Public property | Type | Gets the type of this interface field. (Inherited from ISimInterfaceField.)
Top
See Also

Reference

ISimInterfaceTransportField Interface
VisualComponents.Create3D Namespace


ISimInterfaceTransportField Methods

The ISimInterfaceTransportField type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISimInterfaceTransportField Interface
VisualComponents.Create3D Namespace


ISimInterfaceTransportField Events

The ISimInterfaceTransportField type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ISimInterfaceTransportField Interface
VisualComponents.Create3D Namespace


ISimNode Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimNode : IWrapper,
    IDisposable, IVisualObject, INamed, IVisitable, IPropertyContainer,
    IBatchModeObject, ISharedCloneable
public interface class ISimNode : IWrapper,
    IDisposable, IVisualObject, INamed, IVisitable, IPropertyContainer,
    IBatchModeObject, ISharedCloneable

The ISimNode type exposes the following members.

Properties
 | Name | Description
Public property | Behaviors |
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Children |
Public property | ClassId |
Public property | Component |
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Dof | Degree of freedom description for the node.
Public property | DofType | Type of DOF for the node. Setting this resets Dof to a new value.
Public property | Features |
Public property | Geometry |
Public property | HighlightMaterial | Alternative way of highlighting, using custom material. Note: IsHighlighted should be disabled when this is used.
Public property | IsBaseNode | True for robot world nodes.
Public property | IsComponentRoot | True for component root nodes.
Public property | IsHighlighted |
Public property | IsManipulationLocked | This is similar to ILockable.IsLocked. Used to indicate that child SimNode is attached to external node (with rSimAttachmentField interface)
Public property | IsNodeValid | Extension to IWrapper.IsValid logic. This flag is disabled earlier than IWrapper.IsValid. It is disabled for whole group of components with ISimWorld.InvalidateComponents().
Public property | IsOffsetParametric | Query whether the offset matrix is dependent on any component parameters.
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | IsVisibleInUI | This is false only for special visualization nodes in PhysicsCable component.
Public property | IsWorldRootNode | True for world root node.
Public property | Material |
Public property | MaterialInheritance |
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeVisible | Getter and setter for node visibility.
Public property | Parent |
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature |
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IVisualObject.)
Public property | TransformationInWorld | Gets or sets the world transformation matrix (Inherited from IVisualObject.)
Public property | UserGeometry |
Public property | VisualizationNode |
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(String) | Creates a child node using the given node. If another node in the same component has the same name this method will throw an argument exception.
Public method | AddChild(ISimNode) | Change the parent of the given node to this node. Given node cannot be root node of a component.
Public method | AddChild(String, Boolean) | Creates a child node using the given node. If another node in the same component has the same name this method will modify the name to a valid name.
Public method | AddNext | Creates a sibling node using the given node. If another node in the same component has the same name this method will modify the name to a valid name.
Public method | AttachTo |
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanInteract |
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | CreateBehaviorT |
Public method | CreateBehaviorByType |
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the node.
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Detach | Detaches the node from its parent.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetFeatureTransformationInWorld | Feature's final position in world.
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | IsOffsetDependentOnProperty | Check if offset value depends on given property.
Public method | LogicalParents |
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | MeasureDistance | Measure closest distance to other node(s).
Public method | MoveBehaviorAfter | Moves the behavior after the specified one in the list.
Public method | MoveBehaviorBefore | Moves the behavior before the specified one in the list.
Public method | Rebuild |
Public method | RemoveBehavior | Removes the behavior from the node. See remarks.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | TransformContent(Matrix) | Transform all the content by the given matrix.
Public method | TransformContent(Matrix, Boolean, Boolean) | Transform all the content by the given matrix.
Public method | UpdateScene | Updates scene graph transformation and bound information.
Public method | UpdateScene(Boolean) |
Top
Events
 | Name | Description
Public event | ChildAdded | Occurs when new ISimNode has been added to this node.
Public event | NameChanged | Occurs when ISimNode name has been changed.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | ParentChanged | Occurs when the parent node of this node changes.
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISimNode Properties

The ISimNode type exposes the following members.

Properties
 | Name | Description
Public property | Behaviors |
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Children |
Public property | ClassId |
Public property | Component |
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Dof | Degree of freedom description for the node.
Public property | DofType | Type of DOF for the node. Setting this resets Dof to a new value.
Public property | Features |
Public property | Geometry |
Public property | HighlightMaterial | Alternative way of highlighting, using custom material. Note: IsHighlighted should be disabled when this is used.
Public property | IsBaseNode | True for robot world nodes.
Public property | IsComponentRoot | True for component root nodes.
Public property | IsHighlighted |
Public property | IsManipulationLocked | This is similar to ILockable.IsLocked. Used to indicate that child SimNode is attached to external node (with rSimAttachmentField interface)
Public property | IsNodeValid | Extension to IWrapper.IsValid logic. This flag is disabled earlier than IWrapper.IsValid. It is disabled for whole group of components with ISimWorld.InvalidateComponents().
Public property | IsOffsetParametric | Query whether the offset matrix is dependent on any component parameters.
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | IsVisibleInUI | This is false only for special visualization nodes in PhysicsCable component.
Public property | IsWorldRootNode | True for world root node.
Public property | Material |
Public property | MaterialInheritance |
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeVisible | Getter and setter for node visibility.
Public property | Parent |
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature |
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IVisualObject.)
Public property | TransformationInWorld | Gets or sets the world transformation matrix (Inherited from IVisualObject.)
Public property | UserGeometry |
Public property | VisualizationNode |
Top
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.Behaviors Property

ISimNodeBehaviors Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IBehavior> Behaviors { get; }
property ReadOnlyCollection<IBehavior^>^ Behaviors {
    ReadOnlyCollection<IBehavior^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIBehavior
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.Children Property

ISimNodeChildren Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ISimNode> Children { get; }
property ReadOnlyCollection<ISimNode^>^ Children {
    ReadOnlyCollection<ISimNode^>^ get ();
}

Property Value

Type: ReadOnlyCollectionISimNode
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.ClassId Property

ISimNodeClassId Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IntPtr ClassId { get; }
property IntPtr ClassId {
    IntPtr get ();
}

Property Value

Type: IntPtr
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.Component Property

ISimNodeComponent Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent Component { get; }
property ISimComponent^ Component {
    ISimComponent^ get ();
}

Property Value

Type: ISimComponent
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.Dof Property

ISimNodeDof Property

Degree of freedom description for the node.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IDof Dof { get; }
property IDof^ Dof {
    IDof^ get ();
}

Property Value

Type: IDof
Remarks
This is null for component node. For Fixed dof returning special kind of "NullDof" instance, for stability reasons.
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.DofType Property

ISimNodeDofType Property

Type of DOF for the node. Setting this resets Dof to a new value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
JointType DofType { get; set; }
property JointType DofType {
    JointType get ();
    void set (JointType value);
}

Property Value

Type: JointType
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.Features Property

ISimNodeFeatures Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IFeature> Features { get; }
property ReadOnlyCollection<IFeature^>^ Features {
    ReadOnlyCollection<IFeature^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIFeature
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.Geometry Property

ISimNodeGeometry Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IGeometryContainer Geometry { get; }
property IGeometryContainer^ Geometry {
    IGeometryContainer^ get ();
}

Property Value

Type: IGeometryContainer
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.HighlightMaterial Property

ISimNodeHighlightMaterial Property

Alternative way of highlighting, using custom material. Note: IsHighlighted should be disabled when this is used.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMaterial HighlightMaterial { get; set; }
property IMaterial^ HighlightMaterial {
    IMaterial^ get ();
    void set (IMaterial^ value);
}

Property Value

Type: IMaterial
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.IsBaseNode Property

ISimNodeIsBaseNode Property

True for robot world nodes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsBaseNode { get; }
property bool IsBaseNode {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.IsComponentRoot Property

ISimNodeIsComponentRoot Property

True for component root nodes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsComponentRoot { get; }
property bool IsComponentRoot {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.IsHighlighted Property

ISimNodeIsHighlighted Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsHighlighted { get; set; }
property bool IsHighlighted {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IVisualObjectIsHighlighted
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.IsManipulationLocked Property

ISimNodeIsManipulationLocked Property

This is similar to ILockable.IsLocked. Used to indicate that child SimNode is attached to external node (with rSimAttachmentField interface)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsManipulationLocked { get; }
property bool IsManipulationLocked {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.IsNodeValid Property

ISimNodeIsNodeValid Property

Extension to IWrapper.IsValid logic. This flag is disabled earlier than IWrapper.IsValid. It is disabled for whole group of components with ISimWorld.InvalidateComponents().

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsNodeValid { get; }
property bool IsNodeValid {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.IsOffsetParametric Property

ISimNodeIsOffsetParametric Property

Query whether the offset matrix is dependent on any component parameters.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsOffsetParametric { get; }
property bool IsOffsetParametric {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.IsVisibleInUI Property

ISimNodeIsVisibleInUI Property

This is false only for special visualization nodes in PhysicsCable component.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsVisibleInUI { get; }
property bool IsVisibleInUI {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.IsWorldRootNode Property

ISimNodeIsWorldRootNode Property

True for world root node.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsWorldRootNode { get; }
property bool IsWorldRootNode {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.Material Property

ISimNodeMaterial Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMaterial Material { get; set; }
property IMaterial^ Material {
    IMaterial^ get ();
    void set (IMaterial^ value);
}

Property Value

Type: IMaterial
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.MaterialInheritance Property

ISimNodeMaterialInheritance Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MaterialInheritance MaterialInheritance { get; set; }
property MaterialInheritance MaterialInheritance {
    MaterialInheritance get ();
    void set (MaterialInheritance value);
}

Property Value

Type: MaterialInheritance
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.NodeVisible Property

ISimNodeNodeVisible Property

Getter and setter for node visibility.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool NodeVisible { get; set; }
property bool NodeVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.Parent Property

ISimNodeParent Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode Parent { get; }
property ISimNode^ Parent {
    ISimNode^ get ();
}

Property Value

Type: ISimNode
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.RootFeature Property

ISimNodeRootFeature Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFeature RootFeature { get; }
property IFeature^ RootFeature {
    IFeature^ get ();
}

Property Value

Type: IFeature
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.UserGeometry Property

ISimNodeUserGeometry Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IGeometryContainer UserGeometry { get; }
property IGeometryContainer^ UserGeometry {
    IGeometryContainer^ get ();
}

Property Value

Type: IGeometryContainer
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.VisualizationNode Property

ISimNodeVisualizationNode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IntPtr VisualizationNode { get; }
property IntPtr VisualizationNode {
    IntPtr get ();
}

Property Value

Type: IntPtr
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode Methods

The ISimNode type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(String) | Creates a child node using the given node. If another node in the same component has the same name this method will throw an argument exception.
Public method | AddChild(ISimNode) | Change the parent of the given node to this node. Given node cannot be root node of a component.
Public method | AddChild(String, Boolean) | Creates a child node using the given node. If another node in the same component has the same name this method will modify the name to a valid name.
Public method | AddNext | Creates a sibling node using the given node. If another node in the same component has the same name this method will modify the name to a valid name.
Public method | AttachTo |
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanInteract |
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | CreateBehaviorT |
Public method | CreateBehaviorByType |
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the node.
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Detach | Detaches the node from its parent.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetFeatureTransformationInWorld | Feature's final position in world.
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | IsOffsetDependentOnProperty | Check if offset value depends on given property.
Public method | LogicalParents |
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | MeasureDistance | Measure closest distance to other node(s).
Public method | MoveBehaviorAfter | Moves the behavior after the specified one in the list.
Public method | MoveBehaviorBefore | Moves the behavior before the specified one in the list.
Public method | Rebuild |
Public method | RemoveBehavior | Removes the behavior from the node. See remarks.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | TransformContent(Matrix) | Transform all the content by the given matrix.
Public method | TransformContent(Matrix, Boolean, Boolean) | Transform all the content by the given matrix.
Public method | UpdateScene | Updates scene graph transformation and bound information.
Public method | UpdateScene(Boolean) |
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.AddChild Method

ISimNodeAddChild Method

Overload List
 | Name | Description
Public method | AddChild(String) | Creates a child node using the given node. If another node in the same component has the same name this method will throw an argument exception.
Public method | AddChild(ISimNode) | Change the parent of the given node to this node. Given node cannot be root node of a component.
Public method | AddChild(String, Boolean) | Creates a child node using the given node. If another node in the same component has the same name this method will modify the name to a valid name.
Top
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.AddChild Method (String)

ISimNodeAddChild Method (String)

Creates a child node using the given node. If another node in the same component has the same name this method will throw an argument exception.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode AddChild(
    string name
)
ISimNode^ AddChild(
    String^ name
)

Parameters

name
Type: SystemString
node's name

Return Value

Type: ISimNode

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISimNode.AddChild(System.String)"]

See Also

Reference

ISimNode Interface
AddChild Overload
VisualComponents.Create3D Namespace


ISimNode.AddChild Method (ISimNode)

ISimNodeAddChild Method (ISimNode)

Change the parent of the given node to this node. Given node cannot be root node of a component.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddChild(
    ISimNode node
)
void AddChild(
    ISimNode^ node
)

Parameters

node
Type: VisualComponents.Create3DISimNode
See Also

Reference

ISimNode Interface
AddChild Overload
VisualComponents.Create3D Namespace


ISimNode.AddChild Method (String, Boolean)

ISimNodeAddChild Method (String, Boolean)

Creates a child node using the given node. If another node in the same component has the same name this method will modify the name to a valid name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode AddChild(
    string name,
    bool suggestName
)
ISimNode^ AddChild(
    String^ name,
    bool suggestName
)

Parameters

name
Type: SystemString
suggestName
Type: SystemBoolean

Return Value

Type: ISimNode

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISimNode.AddChild(System.String,System.Boolean)"]

See Also

Reference

ISimNode Interface
AddChild Overload
VisualComponents.Create3D Namespace


ISimNode.AddNext Method

ISimNodeAddNext Method

Creates a sibling node using the given node. If another node in the same component has the same name this method will modify the name to a valid name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode AddNext(
    string name,
    bool suggestName
)
ISimNode^ AddNext(
    String^ name,
    bool suggestName
)

Parameters

name
Type: SystemString
suggestName
Type: SystemBoolean

Return Value

Type: ISimNode

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISimNode.AddNext(System.String,System.Boolean)"]

See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.AttachTo Method

ISimNodeAttachTo Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AttachTo(
    ISimNode parent
)
void AttachTo(
    ISimNode^ parent
)

Parameters

parent
Type: VisualComponents.Create3DISimNode
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.CanInteract Method

ISimNodeCanInteract Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanInteract()
bool CanInteract()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISimNode.CanInteract"]

See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.CreateBehavior(T) Method

ISimNodeCreateBehaviorT Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
T CreateBehavior<T>(
    string name
)
where T : IBehavior

generic<typename T>
where T : IBehavior
T CreateBehavior(
    String^ name
)

Parameters

name
Type: SystemString

Type Parameters

T

Return Value

Type: T

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISimNode.CreateBehavior``1(System.String)"]

See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.CreateBehaviorByType Method

ISimNodeCreateBehaviorByType Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IBehavior CreateBehaviorByType(
    BehaviorType behaviorType
)
IBehavior^ CreateBehaviorByType(
    BehaviorType behaviorType
)

Parameters

behaviorType
Type: VisualComponents.Create3DBehaviorType

Return Value

Type: IBehavior

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISimNode.CreateBehaviorByType(VisualComponents.Create3D.BehaviorType)"]

See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.Delete Method

ISimNodeDelete Method

Deletes the node.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Delete()
void Delete()
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.Detach Method

ISimNodeDetach Method

Detaches the node from its parent.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Detach()
void Detach()
Remarks
If a node is detached its lifetime is no longer managed by the simulation world, therefore it must either be reattached or deleted manually.
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.GetFeatureTransformationInWorld Method

ISimNodeGetFeatureTransformationInWorld Method

Feature's final position in world.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix GetFeatureTransformationInWorld(
    IFeature feature
)
Matrix GetFeatureTransformationInWorld(
    IFeature^ feature
)

Parameters

feature
Type: VisualComponents.Create3DIFeature

Return Value

Type: Matrix

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISimNode.GetFeatureTransformationInWorld(VisualComponents.Create3D.IFeature)"]

See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.IsOffsetDependentOnProperty Method

ISimNodeIsOffsetDependentOnProperty Method

Check if offset value depends on given property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsOffsetDependentOnProperty(
    IProperty propertyObject
)
bool IsOffsetDependentOnProperty(
    IProperty^ propertyObject
)

Parameters

propertyObject
Type: VisualComponents.Create3DIProperty

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISimNode.IsOffsetDependentOnProperty(VisualComponents.Create3D.IProperty)"]

See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.LogicalParents Method

ISimNodeLogicalParents Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ISimNode> LogicalParents()
ReadOnlyCollection<ISimNode^>^ LogicalParents()

Return Value

Type: ReadOnlyCollectionISimNode

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISimNode.LogicalParents"]

See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.MeasureDistance Method

ISimNodeMeasureDistance Method

Measure closest distance to other node(s).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
DistanceResult MeasureDistance(
    params ISimNode[] otherNodes
)
DistanceResult^ MeasureDistance(
    ... array<ISimNode^>^ otherNodes
)

Parameters

otherNodes
Type: VisualComponents.Create3DISimNode
Target nodes to measure distance.

Return Value

Type: DistanceResult
Minimum distance to other nodes, or null if not found.
Remarks

This method measures the distance from this node to one or more other nodes. The distance is based on the closest points between geometry in the nodes.

If the distance cannot be obtained (for example if there is no geometry to measure in the node or nodes) the result is null.

Otherwise, a result object is returned, with coordinates set relative to this node.

See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.MoveBehaviorAfter Method

ISimNodeMoveBehaviorAfter Method

Moves the behavior after the specified one in the list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void MoveBehaviorAfter(
    IBehavior behavior,
    IBehavior after
)
void MoveBehaviorAfter(
    IBehavior^ behavior,
    IBehavior^ after
)

Parameters

behavior
Type: VisualComponents.Create3DIBehavior
after
Type: VisualComponents.Create3DIBehavior
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.MoveBehaviorBefore Method

ISimNodeMoveBehaviorBefore Method

Moves the behavior before the specified one in the list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void MoveBehaviorBefore(
    IBehavior behavior,
    IBehavior before
)
void MoveBehaviorBefore(
    IBehavior^ behavior,
    IBehavior^ before
)

Parameters

behavior
Type: VisualComponents.Create3DIBehavior
before
Type: VisualComponents.Create3DIBehavior
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.Rebuild Method

ISimNodeRebuild Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Rebuild()
void Rebuild()
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.RemoveBehavior Method

ISimNodeRemoveBehavior Method

Removes the behavior from the node. See remarks.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RemoveBehavior(
    IBehavior behavior
)
void RemoveBehavior(
    IBehavior^ behavior
)

Parameters

behavior
Type: VisualComponents.Create3DIBehavior
Remarks
This call implies that the caller should either attach the behavior again to another ISimNode or to manually call Destroy to avoid memory leaks.
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.TransformContent Method

ISimNodeTransformContent Method

Overload List
 | Name | Description
Public method | TransformContent(Matrix) | Transform all the content by the given matrix.
Public method | TransformContent(Matrix, Boolean, Boolean) | Transform all the content by the given matrix.
Top
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.TransformContent Method (Matrix)

ISimNodeTransformContent Method (Matrix)

Transform all the content by the given matrix.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void TransformContent(
    Matrix transform
)
void TransformContent(
    Matrix transform
)

Parameters

transform
Type: VisualComponents.Create3DMatrix

Implements

IVisualObjectTransformContent(Matrix)
See Also

Reference

ISimNode Interface
TransformContent Overload
VisualComponents.Create3D Namespace


ISimNode.TransformContent Method (Matrix, Boolean, Boolean)

ISimNodeTransformContent Method (Matrix, Boolean, Boolean)

Transform all the content by the given matrix.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void TransformContent(
    Matrix transform,
    bool rebuild,
    bool lockGeometryToNode
)
void TransformContent(
    Matrix transform,
    bool rebuild,
    bool lockGeometryToNode
)

Parameters

transform
Type: VisualComponents.Create3DMatrix
rebuild
Type: SystemBoolean
lockGeometryToNode
Type: SystemBoolean
See Also

Reference

ISimNode Interface
TransformContent Overload
VisualComponents.Create3D Namespace


ISimNode.UpdateScene Method

ISimNodeUpdateScene Method

Overload List
 | Name | Description
Public method | UpdateScene | Updates scene graph transformation and bound information.
Public method | UpdateScene(Boolean) |
Top
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.UpdateScene Method

ISimNodeUpdateScene Method

Updates scene graph transformation and bound information.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateScene()
void UpdateScene()
See Also

Reference

ISimNode Interface
UpdateScene Overload
VisualComponents.Create3D Namespace


ISimNode.UpdateScene Method (Boolean)

ISimNodeUpdateScene Method (Boolean)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateScene(
    bool updateBehaviors
)
void UpdateScene(
    bool updateBehaviors
)

Parameters

updateBehaviors
Type: SystemBoolean
See Also

Reference

ISimNode Interface
UpdateScene Overload
VisualComponents.Create3D Namespace


ISimNode Events

The ISimNode type exposes the following members.

Events
 | Name | Description
Public event | ChildAdded | Occurs when new ISimNode has been added to this node.
Public event | NameChanged | Occurs when ISimNode name has been changed.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | ParentChanged | Occurs when the parent node of this node changes.
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.ChildAdded Event

ISimNodeChildAdded Event

Occurs when new ISimNode has been added to this node.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ChildAddedEventArgs> ChildAdded
 event EventHandler<ChildAddedEventArgs^>^ ChildAdded {
    void add (EventHandler<ChildAddedEventArgs^>^ value);
    void remove (EventHandler<ChildAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerChildAddedEventArgs
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.NameChanged Event

ISimNodeNameChanged Event

Occurs when ISimNode name has been changed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<NameChangedEventArgs> NameChanged
 event EventHandler<NameChangedEventArgs^>^ NameChanged {
    void add (EventHandler<NameChangedEventArgs^>^ value);
    void remove (EventHandler<NameChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerNameChangedEventArgs
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimNode.ParentChanged Event

ISimNodeParentChanged Event

Occurs when the parent node of this node changes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler ParentChanged
 event EventHandler^ ParentChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ISimNode Interface
VisualComponents.Create3D Namespace


ISimProduct Interface

Instance of a IProductType, a single Product.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimProduct : IWrapper,
    IDisposable
public interface class ISimProduct : IWrapper,
    IDisposable

The ISimProduct type exposes the following members.

Properties
 | Name | Description
Public property | Component | Gets the ISimComponent currently used as a visualization of this product instance.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductType | Gets the IProductType this is an instance of.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISimProduct Properties

The ISimProduct type exposes the following members.

Properties
 | Name | Description
Public property | Component | Gets the ISimComponent currently used as a visualization of this product instance.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductType | Gets the IProductType this is an instance of.
Top
See Also

Reference

ISimProduct Interface
VisualComponents.Create3D Namespace


ISimProduct.Component Property

ISimProductComponent Property

Gets the ISimComponent currently used as a visualization of this product instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent Component { get; }
property ISimComponent^ Component {
    ISimComponent^ get ();
}

Property Value

Type: ISimComponent
See Also

Reference

ISimProduct Interface
VisualComponents.Create3D Namespace


ISimProduct.ProductType Property

ISimProductProductType Property

Gets the IProductType this is an instance of.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProductType ProductType { get; }
property IProductType^ ProductType {
    IProductType^ get ();
}

Property Value

Type: IProductType
See Also

Reference

ISimProduct Interface
VisualComponents.Create3D Namespace


ISimProduct Methods

The ISimProduct type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISimProduct Interface
VisualComponents.Create3D Namespace


ISimProduct Events

The ISimProduct type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
See Also

Reference

ISimProduct Interface
VisualComponents.Create3D Namespace


ISimulation Interface

Simulation object interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimulation : IWrapper,
    IDisposable
public interface class ISimulation : IWrapper,
    IDisposable

The ISimulation type exposes the following members.

Properties
 | Name | Description
Public property | AnimationRecorder | Gets an instance of IAnimationRecorder that can be used for recording vcax animation files.
Public property | AutoSaveState | Invoke SaveState on Play. Initial value is loaded from application config.
Public property | DrawingMode | Defines if the application is in drawing context.
Public property | Elapsed | Simulation time.
Public property | IsActive | IsRunning, or paused, or starting.
Public property | IsAnimating | Defines if the 3D scene is rendered during simulation.
Public property | IsLooping | Defines if the simulation gets automatically restarted when finished.
Public property | IsPausing | Simulation is still running, but Halt event was scheduled.
Public property | IsPhysicalGrabberActive | Indicates if physical grabber joint has been configured with SetupPhysicalGrabber.
Public property | IsPrecisePhysicsEnabled | Obsolete. Indicates that all components and all behaviours will be updated on each physics substep. True by default.
Public property | IsRecordingEnabled | Is recording a video, animation, or pdf.
Public property | IsRunning | Note: This can return false when simulation in technically running, but is about to halt, and simulation time won't grow anymore.
Public property | IsStreamingEnabled | Is streaming an animation.
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVideoRecordingEnabled | Is recording a video.
Public property | JointLimitTestInterval | Gets or sets the interval (seconds) at which the joint limits are tested during simulation.
Public property | JointLimitTests | Gets or sets the enabled joint limit tests.
Public property | JointLimitTestSettings | Gets or sets the enabled joint limit test settings.
Public property | PhysicsSlowdownFactor | Gets or sets the scale value for the physical substep.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProcessController | Gets the global process controller.
Public property | RunTime | Gets or sets the simulation run Time.
Public property | SpeedFactor | Gets or sets the simulation speed factor.
Public property | State |
Public property | TimeMode |
Public property | U3DRecorder | Gets an instance of IU3DRecorder that can be used for recording u3d files.
Public property | WarmupTime | Simulation warm-up time
Top
Methods
 | Name | Description
Public method | ClearPhysicalGrabber | Removes grabbing joint.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | Init | Initializes simulation with the given speed factor.
Public method | MovePhysicalGrabber | Move grabbing joint to world target position.
Public method | Pause | Pauses simulation at the current time.
Public method | PreRender | For internal use only. Do not use.
Public method | Repeat |
Public method | Reset | Resets simulation.
Public method | RestoreState |
Public method | Run | Initializes and sets simulation to run mode.
Public method | SaveState | Saves the initial simulation state that is restored when simulation is reset.
Public method | ScheduleCallback | Schedules request to get a callback from simulation after a given time has elapsed.
Public method | SetFastScheduling | Modifies fast scheduling property for all conveyor path behaviors.
Public method | SetupPhysicalGrabber | Create's a joint that moves the specified physical body to target position.
Public method | Simulate | Synchronously tries to advance the simulation forward by the given amount.
Public method | Update |
Top
Events
 | Name | Description
Public event | CollisionDetected | Event that is raised when any collision detector detects a collision.
Public event | JointLimitExceeded | Event that is raised when a joint limit is exceeded during simulation.
Public event | JointLimitSettingChanged | Event that is raised when joint limit setting is changed.
Public event | Looping | Event that is raised when main loop execution starts again if IsLooping is set to True.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | RunTimeChanged | Event that is raised when simulation runtime is changed.
Public event | SimulationInitializing | Event that is raised before simulation initialized.
Public event | SimulationRender | For internal use only. Do not use.
Public event | SimulationReset | Event that is raised after simulation has been reset.
Public event | SimulationRun | Event that is raised when after the simulation has started and "OnRun()" method has been called for all script behaviors. This is raised after SimulationStarted event.
Public event | SimulationStarted | Event that is raised after simulation has been started.
Public event | SimulationStopped | Event that is raised after simulation has been stopped.
Public event | SpeedFactorChanged | Event that is raised when simulation speed factor is changed.
Public event | TimeModeChanged | Event that is raised when simulation real time mode is changed.
Public event | WarmupTimeChanged | Event that is raised when the simulation WarmupTime property is changed.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISimulation Properties

The ISimulation type exposes the following members.

Properties
 | Name | Description
Public property | AnimationRecorder | Gets an instance of IAnimationRecorder that can be used for recording vcax animation files.
Public property | AutoSaveState | Invoke SaveState on Play. Initial value is loaded from application config.
Public property | DrawingMode | Defines if the application is in drawing context.
Public property | Elapsed | Simulation time.
Public property | IsActive | IsRunning, or paused, or starting.
Public property | IsAnimating | Defines if the 3D scene is rendered during simulation.
Public property | IsLooping | Defines if the simulation gets automatically restarted when finished.
Public property | IsPausing | Simulation is still running, but Halt event was scheduled.
Public property | IsPhysicalGrabberActive | Indicates if physical grabber joint has been configured with SetupPhysicalGrabber.
Public property | IsPrecisePhysicsEnabled | Obsolete. Indicates that all components and all behaviours will be updated on each physics substep. True by default.
Public property | IsRecordingEnabled | Is recording a video, animation, or pdf.
Public property | IsRunning | Note: This can return false when simulation in technically running, but is about to halt, and simulation time won't grow anymore.
Public property | IsStreamingEnabled | Is streaming an animation.
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVideoRecordingEnabled | Is recording a video.
Public property | JointLimitTestInterval | Gets or sets the interval (seconds) at which the joint limits are tested during simulation.
Public property | JointLimitTests | Gets or sets the enabled joint limit tests.
Public property | JointLimitTestSettings | Gets or sets the enabled joint limit test settings.
Public property | PhysicsSlowdownFactor | Gets or sets the scale value for the physical substep.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProcessController | Gets the global process controller.
Public property | RunTime | Gets or sets the simulation run Time.
Public property | SpeedFactor | Gets or sets the simulation speed factor.
Public property | State |
Public property | TimeMode |
Public property | U3DRecorder | Gets an instance of IU3DRecorder that can be used for recording u3d files.
Public property | WarmupTime | Simulation warm-up time
Top
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.AnimationRecorder Property

ISimulationAnimationRecorder Property

Gets an instance of IAnimationRecorder that can be used for recording vcax animation files.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IAnimationRecorder AnimationRecorder { get; }
property IAnimationRecorder^ AnimationRecorder {
    IAnimationRecorder^ get ();
}

Property Value

Type: IAnimationRecorder
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.AutoSaveState Property

ISimulationAutoSaveState Property

Invoke SaveState on Play. Initial value is loaded from application config.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool AutoSaveState { get; set; }
property bool AutoSaveState {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.DrawingMode Property

ISimulationDrawingMode Property

Defines if the application is in drawing context.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool DrawingMode { get; set; }
property bool DrawingMode {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.Elapsed Property

ISimulationElapsed Property

Simulation time.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Elapsed { get; }
property double Elapsed {
    double get ();
}

Property Value

Type: Double
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.IsActive Property

ISimulationIsActive Property

IsRunning, or paused, or starting.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsActive { get; }
property bool IsActive {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.IsAnimating Property

ISimulationIsAnimating Property

Defines if the 3D scene is rendered during simulation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsAnimating { get; set; }
property bool IsAnimating {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.IsLooping Property

ISimulationIsLooping Property

Defines if the simulation gets automatically restarted when finished.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsLooping { get; set; }
property bool IsLooping {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.IsPausing Property

ISimulationIsPausing Property

Simulation is still running, but Halt event was scheduled.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsPausing { get; }
property bool IsPausing {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.IsPhysicalGrabberActive Property

ISimulationIsPhysicalGrabberActive Property

Indicates if physical grabber joint has been configured with SetupPhysicalGrabber.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsPhysicalGrabberActive { get; }
property bool IsPhysicalGrabberActive {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.IsPrecisePhysicsEnabled Property

ISimulationIsPrecisePhysicsEnabled Property

Note: This API is now obsolete.

Indicates that all components and all behaviours will be updated on each physics substep. True by default.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("IsPrecisePhysicsEnabled is deprecated")]
bool IsPrecisePhysicsEnabled { get; set; }
[ObsoleteAttribute(L"IsPrecisePhysicsEnabled is deprecated")]
property bool IsPrecisePhysicsEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.IsRecordingEnabled Property

ISimulationIsRecordingEnabled Property

Is recording a video, animation, or pdf.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsRecordingEnabled { get; }
property bool IsRecordingEnabled {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.IsRunning Property

ISimulationIsRunning Property

Note: This can return false when simulation in technically running, but is about to halt, and simulation time won't grow anymore.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsRunning { get; }
property bool IsRunning {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.IsStreamingEnabled Property

ISimulationIsStreamingEnabled Property

Is streaming an animation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsStreamingEnabled { get; }
property bool IsStreamingEnabled {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.IsVideoRecordingEnabled Property

ISimulationIsVideoRecordingEnabled Property

Is recording a video.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsVideoRecordingEnabled { get; }
property bool IsVideoRecordingEnabled {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.JointLimitTestInterval Property

ISimulationJointLimitTestInterval Property

Gets or sets the interval (seconds) at which the joint limits are tested during simulation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double JointLimitTestInterval { get; set; }
property double JointLimitTestInterval {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.JointLimitTests Property

ISimulationJointLimitTests Property

Gets or sets the enabled joint limit tests.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
JointLimitTests JointLimitTests { get; set; }
property JointLimitTests JointLimitTests {
    JointLimitTests get ();
    void set (JointLimitTests value);
}

Property Value

Type: JointLimitTests
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.JointLimitTestSettings Property

ISimulationJointLimitTestSettings Property

Gets or sets the enabled joint limit test settings.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
JointLimitTestSettings JointLimitTestSettings { get; set; }
property JointLimitTestSettings JointLimitTestSettings {
    JointLimitTestSettings get ();
    void set (JointLimitTestSettings value);
}

Property Value

Type: JointLimitTestSettings
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.PhysicsSlowdownFactor Property

ISimulationPhysicsSlowdownFactor Property

Gets or sets the scale value for the physical substep.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double PhysicsSlowdownFactor { get; set; }
property double PhysicsSlowdownFactor {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.ProcessController Property

ISimulationProcessController Property

Gets the global process controller.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessController ProcessController { get; }
property IProcessController^ ProcessController {
    IProcessController^ get ();
}

Property Value

Type: IProcessController
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.RunTime Property

ISimulationRunTime Property

Gets or sets the simulation run Time.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double RunTime { get; set; }
property double RunTime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.SpeedFactor Property

ISimulationSpeedFactor Property

Gets or sets the simulation speed factor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double SpeedFactor { get; set; }
property double SpeedFactor {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.State Property

ISimulationState Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
SimulationState State { get; }
property SimulationState State {
    SimulationState get ();
}

Property Value

Type: SimulationState
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.TimeMode Property

ISimulationTimeMode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
SimulationTimeMode TimeMode { get; set; }
property SimulationTimeMode TimeMode {
    SimulationTimeMode get ();
    void set (SimulationTimeMode value);
}

Property Value

Type: SimulationTimeMode
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.U3DRecorder Property

ISimulationU3DRecorder Property

Gets an instance of IU3DRecorder that can be used for recording u3d files.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IU3DRecorder U3DRecorder { get; }
property IU3DRecorder^ U3DRecorder {
    IU3DRecorder^ get ();
}

Property Value

Type: IU3DRecorder
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.WarmupTime Property

ISimulationWarmupTime Property

Simulation warm-up time

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double WarmupTime { get; set; }
property double WarmupTime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation Methods

The ISimulation type exposes the following members.

Methods
 | Name | Description
Public method | ClearPhysicalGrabber | Removes grabbing joint.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | Init | Initializes simulation with the given speed factor.
Public method | MovePhysicalGrabber | Move grabbing joint to world target position.
Public method | Pause | Pauses simulation at the current time.
Public method | PreRender | For internal use only. Do not use.
Public method | Repeat |
Public method | Reset | Resets simulation.
Public method | RestoreState |
Public method | Run | Initializes and sets simulation to run mode.
Public method | SaveState | Saves the initial simulation state that is restored when simulation is reset.
Public method | ScheduleCallback | Schedules request to get a callback from simulation after a given time has elapsed.
Public method | SetFastScheduling | Modifies fast scheduling property for all conveyor path behaviors.
Public method | SetupPhysicalGrabber | Create's a joint that moves the specified physical body to target position.
Public method | Simulate | Synchronously tries to advance the simulation forward by the given amount.
Public method | Update |
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.ClearPhysicalGrabber Method

ISimulationClearPhysicalGrabber Method

Removes grabbing joint.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ClearPhysicalGrabber()
void ClearPhysicalGrabber()
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.Init Method

ISimulationInit Method

Initializes simulation with the given speed factor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Init(
    double speedFactor
)
void Init(
    double speedFactor
)

Parameters

speedFactor
Type: SystemDouble
Speed factor.
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.MovePhysicalGrabber Method

ISimulationMovePhysicalGrabber Method

Move grabbing joint to world target position.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void MovePhysicalGrabber(
    Vector3 worldTargetPosition
)
void MovePhysicalGrabber(
    Vector3 worldTargetPosition
)

Parameters

worldTargetPosition
Type: VisualComponents.Create3DVector3
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.Pause Method

ISimulationPause Method

Pauses simulation at the current time.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Pause()
void Pause()
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.PreRender Method

ISimulationPreRender Method

For internal use only. Do not use.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void PreRender()
void PreRender()
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.Repeat Method

ISimulationRepeat Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Repeat()
void Repeat()
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.Reset Method

ISimulationReset Method

Resets simulation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Reset()
void Reset()
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.RestoreState Method

ISimulationRestoreState Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RestoreState()
void RestoreState()
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.Run Method

ISimulationRun Method

Initializes and sets simulation to run mode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Run(
    double time
)
void Run(
    double time
)

Parameters

time
Type: SystemDouble
Simulation time where to schedule an automatic stop.
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.SaveState Method

ISimulationSaveState Method

Saves the initial simulation state that is restored when simulation is reset.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SaveState()
void SaveState()
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.ScheduleCallback Method

ISimulationScheduleCallback Method

Schedules request to get a callback from simulation after a given time has elapsed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ScheduleCallback(
    double timeSlice,
    SimEventSchedulingOrder eventOrder,
    SimulationTimeCallback timeSliceCompletedCallback
)
void ScheduleCallback(
    double timeSlice,
    SimEventSchedulingOrder eventOrder,
    SimulationTimeCallback^ timeSliceCompletedCallback
)

Parameters

timeSlice
Type: SystemDouble
Time forward from current simulation time in seconds when to execute the callback.
eventOrder
Type: VisualComponents.Create3DSimEventSchedulingOrder
Ordering of the callback event in the simulation event queue.
timeSliceCompletedCallback
Type: VisualComponents.Create3DSimulationTimeCallback
Delegate to call from the simulation thread.
Remarks
Callback events are discarded on simulation reset and thus may never get executed.
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.SetFastScheduling Method

ISimulationSetFastScheduling Method

Modifies fast scheduling property for all conveyor path behaviors.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetFastScheduling(
    bool enabled
)
void SetFastScheduling(
    bool enabled
)

Parameters

enabled
Type: SystemBoolean
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.SetupPhysicalGrabber Method

ISimulationSetupPhysicalGrabber Method

Create's a joint that moves the specified physical body to target position.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SetupPhysicalGrabber(
    ISimNode grabbedNode,
    Vector3 grabbedPosition,
    Vector3 worldTargetPosition
)
bool SetupPhysicalGrabber(
    ISimNode^ grabbedNode,
    Vector3 grabbedPosition,
    Vector3 worldTargetPosition
)

Parameters

grabbedNode
Type: VisualComponents.Create3DISimNode
grabbedPosition
Type: VisualComponents.Create3DVector3
worldTargetPosition
Type: VisualComponents.Create3DVector3

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISimulation.SetupPhysicalGrabber(VisualComponents.Create3D.ISimNode,VisualComponents.Create3D.Vector3,VisualComponents.Create3D.Vector3)"]

See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.Simulate Method

ISimulationSimulate Method

Synchronously tries to advance the simulation forward by the given amount.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Simulate(
    double timeSlice
)
void Simulate(
    double timeSlice
)

Parameters

timeSlice
Type: SystemDouble
Time in seconds to simulate forward from current simulation time.
Remarks
The reached simulation time may be lower than requested if system events such as simulation stop, animation step, recording step etc. are scheduled before the requested end time. Execution may also stop prematurely due to a real-time timeout. Client code should check the end time from Elapsed property and whether the simulation was stopped or reset.
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.Update Method

ISimulationUpdate Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Update()
void Update()
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation Events

The ISimulation type exposes the following members.

Events
 | Name | Description
Public event | CollisionDetected | Event that is raised when any collision detector detects a collision.
Public event | JointLimitExceeded | Event that is raised when a joint limit is exceeded during simulation.
Public event | JointLimitSettingChanged | Event that is raised when joint limit setting is changed.
Public event | Looping | Event that is raised when main loop execution starts again if IsLooping is set to True.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | RunTimeChanged | Event that is raised when simulation runtime is changed.
Public event | SimulationInitializing | Event that is raised before simulation initialized.
Public event | SimulationRender | For internal use only. Do not use.
Public event | SimulationReset | Event that is raised after simulation has been reset.
Public event | SimulationRun | Event that is raised when after the simulation has started and "OnRun()" method has been called for all script behaviors. This is raised after SimulationStarted event.
Public event | SimulationStarted | Event that is raised after simulation has been started.
Public event | SimulationStopped | Event that is raised after simulation has been stopped.
Public event | SpeedFactorChanged | Event that is raised when simulation speed factor is changed.
Public event | TimeModeChanged | Event that is raised when simulation real time mode is changed.
Public event | WarmupTimeChanged | Event that is raised when the simulation WarmupTime property is changed.
Top
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.CollisionDetected Event

ISimulationCollisionDetected Event

Event that is raised when any collision detector detects a collision.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<CollisionDetectedEventArgs> CollisionDetected
 event EventHandler<CollisionDetectedEventArgs^>^ CollisionDetected {
    void add (EventHandler<CollisionDetectedEventArgs^>^ value);
    void remove (EventHandler<CollisionDetectedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerCollisionDetectedEventArgs
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.JointLimitExceeded Event

ISimulationJointLimitExceeded Event

Event that is raised when a joint limit is exceeded during simulation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<JointLimitExceededEventArgs> JointLimitExceeded
 event EventHandler<JointLimitExceededEventArgs^>^ JointLimitExceeded {
    void add (EventHandler<JointLimitExceededEventArgs^>^ value);
    void remove (EventHandler<JointLimitExceededEventArgs^>^ value);
}

Value

Type: SystemEventHandlerJointLimitExceededEventArgs
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.JointLimitSettingChanged Event

ISimulationJointLimitSettingChanged Event

Event that is raised when joint limit setting is changed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<JointLimitSettingChangedEventArgs> JointLimitSettingChanged
 event EventHandler<JointLimitSettingChangedEventArgs^>^ JointLimitSettingChanged {
    void add (EventHandler<JointLimitSettingChangedEventArgs^>^ value);
    void remove (EventHandler<JointLimitSettingChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerJointLimitSettingChangedEventArgs
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.Looping Event

ISimulationLooping Event

Event that is raised when main loop execution starts again if IsLooping is set to True.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> Looping
 event EventHandler<EventArgs^>^ Looping {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.RunTimeChanged Event

ISimulationRunTimeChanged Event

Event that is raised when simulation runtime is changed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<SimulationRunTimeChangedEventArgs> RunTimeChanged
 event EventHandler<SimulationRunTimeChangedEventArgs^>^ RunTimeChanged {
    void add (EventHandler<SimulationRunTimeChangedEventArgs^>^ value);
    void remove (EventHandler<SimulationRunTimeChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerSimulationRunTimeChangedEventArgs
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.SimulationInitializing Event

ISimulationSimulationInitializing Event

Event that is raised before simulation initialized.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> SimulationInitializing
 event EventHandler<EventArgs^>^ SimulationInitializing {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.SimulationRender Event

ISimulationSimulationRender Event

For internal use only. Do not use.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> SimulationRender
 event EventHandler<EventArgs^>^ SimulationRender {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.SimulationReset Event

ISimulationSimulationReset Event

Event that is raised after simulation has been reset.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> SimulationReset
 event EventHandler<EventArgs^>^ SimulationReset {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.SimulationRun Event

ISimulationSimulationRun Event

Event that is raised when after the simulation has started and "OnRun()" method has been called for all script behaviors. This is raised after SimulationStarted event.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> SimulationRun
 event EventHandler<EventArgs^>^ SimulationRun {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.SimulationStarted Event

ISimulationSimulationStarted Event

Event that is raised after simulation has been started.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> SimulationStarted
 event EventHandler<EventArgs^>^ SimulationStarted {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.SimulationStopped Event

ISimulationSimulationStopped Event

Event that is raised after simulation has been stopped.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> SimulationStopped
 event EventHandler<EventArgs^>^ SimulationStopped {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.SpeedFactorChanged Event

ISimulationSpeedFactorChanged Event

Event that is raised when simulation speed factor is changed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<SimulationSpeedFactorChangedEventArgs> SpeedFactorChanged
 event EventHandler<SimulationSpeedFactorChangedEventArgs^>^ SpeedFactorChanged {
    void add (EventHandler<SimulationSpeedFactorChangedEventArgs^>^ value);
    void remove (EventHandler<SimulationSpeedFactorChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerSimulationSpeedFactorChangedEventArgs
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.TimeModeChanged Event

ISimulationTimeModeChanged Event

Event that is raised when simulation real time mode is changed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<SimulationTimeModeChangedEventArgs> TimeModeChanged
 event EventHandler<SimulationTimeModeChangedEventArgs^>^ TimeModeChanged {
    void add (EventHandler<SimulationTimeModeChangedEventArgs^>^ value);
    void remove (EventHandler<SimulationTimeModeChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerSimulationTimeModeChangedEventArgs
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulation.WarmupTimeChanged Event

ISimulationWarmupTimeChanged Event

Event that is raised when the simulation WarmupTime property is changed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> WarmupTimeChanged
 event EventHandler<EventArgs^>^ WarmupTimeChanged {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

ISimulation Interface
VisualComponents.Create3D Namespace


ISimulationService Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimulationService : INotifyPropertyChangedEx,
    INotifyPropertyChanged
public interface class ISimulationService : INotifyPropertyChangedEx,
    INotifyPropertyChanged

The ISimulationService type exposes the following members.

Properties
Name | Description
Public property Elapsed
Note: this is similar to ISimulation.Elapsed, but expressed in TimeSpan not seconds.
Public property | IsLooping
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsRecordingOn
Public property | IsSimulationAtStart
Public property | IsSimulationPaused
Public property | IsSimulationRecordingOn
Public property IsSimulationRunning
Note: this can return false when simulation is technically running, but halt-event was already scheduled.
Public property | IsStreamingOn
Public property | SimulationMode
Public property | SpeedFactor
Public property | SpeedFactorInputValue
Public property UseExternalClock
Defines if simulation is controlled by external clock. If this property is
Copy
true
simulation must be executed manually using Simulate(Double).
Top
Methods
 | Name | Description
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | PauseSimulation |
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | RepeatSimulation |
Public method | ResetSimulation |
Public method | ResetSimulation(Boolean) |
Public method | ResetSpeedFactor |
Public method | RunSimulation |
Public method | SaveSimulationState |
Public method | SetSimulationMode |
Public method | SwitchRunState(Double) |
Public method | SwitchRunState(Double, Double) |
Public method | UpdateSimulationRecordingState |
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISimulationService Properties

The ISimulationService type exposes the following members.

Properties
Name | Description
Public property Elapsed
Note: this is similar to ISimulation.Elapsed, but expressed in TimeSpan not seconds.
Public property | IsLooping
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsRecordingOn
Public property | IsSimulationAtStart
Public property | IsSimulationPaused
Public property | IsSimulationRecordingOn
Public property IsSimulationRunning
Note: this can return false when simulation is technically running, but halt-event was already scheduled.
Public property | IsStreamingOn
Public property | SimulationMode
Public property | SpeedFactor
Public property | SpeedFactorInputValue
Public property UseExternalClock
Defines if simulation is controlled by external clock. If this property is
Copy
true
simulation must be executed manually using Simulate(Double).
Top
See Also

Reference

ISimulationService Interface
VisualComponents.Create3D Namespace


ISimulationService.Elapsed Property

ISimulationServiceElapsed Property

Note: this is similar to ISimulation.Elapsed, but expressed in TimeSpan not seconds.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
TimeSpan Elapsed { get; }
property TimeSpan Elapsed {
    TimeSpan get ();
}

Property Value

Type: TimeSpan
See Also

Reference

ISimulationService Interface
VisualComponents.Create3D Namespace


ISimulationService.IsLooping Property

ISimulationServiceIsLooping Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsLooping { get; set; }
property bool IsLooping {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISimulationService Interface
VisualComponents.Create3D Namespace


ISimulationService.IsRecordingOn Property

ISimulationServiceIsRecordingOn Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsRecordingOn { get; }
property bool IsRecordingOn {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimulationService Interface
VisualComponents.Create3D Namespace


ISimulationService.IsSimulationAtStart Property

ISimulationServiceIsSimulationAtStart Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsSimulationAtStart { get; }
property bool IsSimulationAtStart {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimulationService Interface
VisualComponents.Create3D Namespace


ISimulationService.IsSimulationPaused Property

ISimulationServiceIsSimulationPaused Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsSimulationPaused { get; }
property bool IsSimulationPaused {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimulationService Interface
VisualComponents.Create3D Namespace


ISimulationService.IsSimulationRecordingOn Property

ISimulationServiceIsSimulationRecordingOn Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsSimulationRecordingOn { get; }
property bool IsSimulationRecordingOn {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimulationService Interface
VisualComponents.Create3D Namespace


ISimulationService.IsSimulationRunning Property

ISimulationServiceIsSimulationRunning Property

Note: this can return false when simulation is technically running, but halt-event was already scheduled.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsSimulationRunning { get; }
property bool IsSimulationRunning {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimulationService Interface
VisualComponents.Create3D Namespace


ISimulationService.IsStreamingOn Property

ISimulationServiceIsStreamingOn Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsStreamingOn { get; }
property bool IsStreamingOn {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimulationService Interface
VisualComponents.Create3D Namespace


ISimulationService.SimulationMode Property

ISimulationServiceSimulationMode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
SimulationTimeMode SimulationMode { get; }
property SimulationTimeMode SimulationMode {
    SimulationTimeMode get ();
}

Property Value

Type: SimulationTimeMode
See Also

Reference

ISimulationService Interface
VisualComponents.Create3D Namespace


ISimulationService.SpeedFactor Property

ISimulationServiceSpeedFactor Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double SpeedFactor { get; set; }
property double SpeedFactor {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ISimulationService Interface
VisualComponents.Create3D Namespace


ISimulationService.SpeedFactorInputValue Property

ISimulationServiceSpeedFactorInputValue Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double SpeedFactorInputValue { get; set; }
property double SpeedFactorInputValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ISimulationService Interface
VisualComponents.Create3D Namespace


ISimulationService.UseExternalClock Property

ISimulationServiceUseExternalClock Property

Defines if simulation is controlled by external clock. If this property is
Copy
true
simulation must be executed manually using Simulate(Double).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool UseExternalClock { get; set; }
property bool UseExternalClock {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISimulationService Interface
VisualComponents.Create3D Namespace


ISimulationService Methods

The ISimulationService type exposes the following members.

Methods
 | Name | Description
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | PauseSimulation |
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | RepeatSimulation |
Public method | ResetSimulation |
Public method | ResetSimulation(Boolean) |
Public method | ResetSpeedFactor |
Public method | RunSimulation |
Public method | SaveSimulationState |
Public method | SetSimulationMode |
Public method | SwitchRunState(Double) |
Public method | SwitchRunState(Double, Double) |
Public method | UpdateSimulationRecordingState |
Top
See Also

Reference

ISimulationService Interface
VisualComponents.Create3D Namespace


ISimulationService.PauseSimulation Method

ISimulationServicePauseSimulation Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void PauseSimulation()
void PauseSimulation()
See Also

Reference

ISimulationService Interface
VisualComponents.Create3D Namespace


ISimulationService.RepeatSimulation Method

ISimulationServiceRepeatSimulation Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RepeatSimulation()
void RepeatSimulation()
See Also

Reference

ISimulationService Interface
VisualComponents.Create3D Namespace


ISimulationService.ResetSimulation Method

ISimulationServiceResetSimulation Method

Overload List
 | Name | Description
Public method | ResetSimulation |
Public method | ResetSimulation(Boolean) |
Top
See Also

Reference

ISimulationService Interface
VisualComponents.Create3D Namespace


ISimulationService.ResetSimulation Method

ISimulationServiceResetSimulation Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ResetSimulation()
void ResetSimulation()
See Also

Reference

ISimulationService Interface
ResetSimulation Overload
VisualComponents.Create3D Namespace


ISimulationService.ResetSimulation Method (Boolean)

ISimulationServiceResetSimulation Method (Boolean)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ResetSimulation(
    bool onlyIfRunning
)
void ResetSimulation(
    bool onlyIfRunning
)

Parameters

onlyIfRunning
Type: SystemBoolean
See Also

Reference

ISimulationService Interface
ResetSimulation Overload
VisualComponents.Create3D Namespace


ISimulationService.ResetSpeedFactor Method

ISimulationServiceResetSpeedFactor Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ResetSpeedFactor()
void ResetSpeedFactor()
See Also

Reference

ISimulationService Interface
VisualComponents.Create3D Namespace


ISimulationService.RunSimulation Method

ISimulationServiceRunSimulation Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RunSimulation()
void RunSimulation()
See Also

Reference

ISimulationService Interface
VisualComponents.Create3D Namespace


ISimulationService.SaveSimulationState Method

ISimulationServiceSaveSimulationState Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SaveSimulationState()
void SaveSimulationState()
See Also

Reference

ISimulationService Interface
VisualComponents.Create3D Namespace


ISimulationService.SetSimulationMode Method

ISimulationServiceSetSimulationMode Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetSimulationMode(
    SimulationTimeMode mode,
    bool forceChange
)
void SetSimulationMode(
    SimulationTimeMode mode,
    bool forceChange
)

Parameters

mode
Type: VisualComponents.Create3DSimulationTimeMode
forceChange
Type: SystemBoolean
See Also

Reference

ISimulationService Interface
VisualComponents.Create3D Namespace


ISimulationService.SwitchRunState Method

ISimulationServiceSwitchRunState Method

Overload List
 | Name | Description
Public method | SwitchRunState(Double) |
Public method | SwitchRunState(Double, Double) |
Top
See Also

Reference

ISimulationService Interface
VisualComponents.Create3D Namespace


ISimulationService.SwitchRunState Method (Double)

ISimulationServiceSwitchRunState Method (Double)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SwitchRunState(
    double runtime
)
void SwitchRunState(
    double runtime
)

Parameters

runtime
Type: SystemDouble
See Also

Reference

ISimulationService Interface
SwitchRunState Overload
VisualComponents.Create3D Namespace


ISimulationService.SwitchRunState Method (Double, Double)

ISimulationServiceSwitchRunState Method (Double, Double)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SwitchRunState(
    double runtime,
    double warmupTime
)
void SwitchRunState(
    double runtime,
    double warmupTime
)

Parameters

runtime
Type: SystemDouble
warmupTime
Type: SystemDouble
See Also

Reference

ISimulationService Interface
SwitchRunState Overload
VisualComponents.Create3D Namespace


ISimulationService.UpdateSimulationRecordingState Method

ISimulationServiceUpdateSimulationRecordingState Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateSimulationRecordingState()
void UpdateSimulationRecordingState()
See Also

Reference

ISimulationService Interface
VisualComponents.Create3D Namespace


ISimulationService Events

The ISimulationService type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

ISimulationService Interface
VisualComponents.Create3D Namespace


ISimWorld Interface

SimWorld is the root node of the simulation. It provides access to the layout items, components, groups and views.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimWorld : IWrapper,
    IDisposable
public interface class ISimWorld : IWrapper,
    IDisposable

The ISimWorld type exposes the following members.

Properties
 | Name | Description
Public property | BoundBox | World's bound box
Public property | Components | Retrieves the collection of ISimComponent instances in the simulation world
Public property | Floor | Gets the instance of IFloor in this instance of ISimWorld.
Public property | Groups | Gets the collection of logical ISimComponent groups
Public property | HasSimulationLevelControl | Indicates that layout has components/scripts that listen to SimulationLevel-changes.
Public property | IsSystem | Defines if this instance of ISimWorld is managed by the application.
Public property | IsValid | (Inherited from IWrapper.)
Public property | LayoutItemGroups | Gets the collection of ILayoutItemGroup groups that contain at least 1 item
Public property | LayoutItems | Retrieves the collection of ILayoutItem instances in the simulation world
Public property | LayoutMetadata | Layout metadata object.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | RandomGeneratorsCount | Number of random generators
Public property | SimulationLevel | Global simulation level. Setting this value will invoke OnSimulationLevelChanged in all python scripts See also ISimComponent.SimulationLevel.
Public property | Views | Returns the collection IView3D instances
Public property | WorldRoot | Returns the simulation world root node
Top
Methods
 | Name | Description
Public method | Clear | Clears the simulation world
Public method | CreateComponent(String) | Creates a new component
Public method | CreateComponent(String, IDictionaryString, String) | Creates a new component with given metadata properties. If Keywords is null, component will be created without metadata
Public method | CreateGroup | Creates a new empty logical group for ISimComponent
Public method | CreateGroup(String) | Creates a new empty logical group for ISimComponent with the given name
Public method | CreateLayoutItemT | Creates a new ILayoutItem instance
Public method | CreateLayoutItemGroup | Creates a new empty logical group for ILayoutItem Remarks Empty groups are not persistant
Public method | CreateLayoutItemGroup(String) | Creates a new empty logical group for ILayoutItem with the given name. Remarks Empty groups are not persistant
Public method | CreateView | Creates a new IView3D instance
Public method | DeleteComponent | Deletes the component
Public method | DeleteLayoutItem | Deletes the given ILayoutItem instance
Public method | DeleteView | Deletes the existing IView3D instance
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindComponent | Returns the component by name
Public method | FindLayoutItem | Finds the ILayoutItem by name
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetRandomSeed | Gets seed value for the generator defined by index
Public method | GetSimulationWorldRoot | Create light weight hierarchical representation of simulation world and return the Parent Node
Public method | Import | Import a geometry from CAD file
Public method | InvalidateComponents | Mark components for deletion.
Public method | Raycast | Obsolete. Do raycast in the scene
Public method | SetRandomSeed | Sets the value of the generator defined by index
Public method | UpdateView | Update a IView3D instance
Public method | ValidateComponents | Restore component state for those component that failed to be deleted.
Top
Events
 | Name | Description
Public event | ComponentAdded | Event that is raised when a component is added to the simulation world
Public event | ComponentRemoving | Event that is raised when a component is being removed from the world
Public event | DynamicComponentAdded | Event that is raised when a dynamic component is added to the simulation world
Public event | DynamicComponentRemoving | Event that is raised when a dynamic component is being removed from the world
Public event | LayoutItemAdded | Event that is raised when a layout item is added to the world.
Public event | LayoutItemRemoving | Event that is raised when a layout item is being removed from the world.
Public event | NodeTreeFinalized | Raised when one or more simulation nodes are to be added to the world. This event is not raised for dynamic components.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | ViewCollectionChanged | Event that is raised when a view is added to the simulation world
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISimWorld Properties

The ISimWorld type exposes the following members.

Properties
 | Name | Description
Public property | BoundBox | World's bound box
Public property | Components | Retrieves the collection of ISimComponent instances in the simulation world
Public property | Floor | Gets the instance of IFloor in this instance of ISimWorld.
Public property | Groups | Gets the collection of logical ISimComponent groups
Public property | HasSimulationLevelControl | Indicates that layout has components/scripts that listen to SimulationLevel-changes.
Public property | IsSystem | Defines if this instance of ISimWorld is managed by the application.
Public property | IsValid | (Inherited from IWrapper.)
Public property | LayoutItemGroups | Gets the collection of ILayoutItemGroup groups that contain at least 1 item
Public property | LayoutItems | Retrieves the collection of ILayoutItem instances in the simulation world
Public property | LayoutMetadata | Layout metadata object.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | RandomGeneratorsCount | Number of random generators
Public property | SimulationLevel | Global simulation level. Setting this value will invoke OnSimulationLevelChanged in all python scripts See also ISimComponent.SimulationLevel.
Public property | Views | Returns the collection IView3D instances
Public property | WorldRoot | Returns the simulation world root node
Top
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.BoundBox Property

ISimWorldBoundBox Property

World's bound box

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IBoundBox BoundBox { get; }
property IBoundBox^ BoundBox {
    IBoundBox^ get ();
}

Property Value

Type: IBoundBox
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.Components Property

ISimWorldComponents Property

Retrieves the collection of ISimComponent instances in the simulation world

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ISimComponent> Components { get; }
property ReadOnlyCollection<ISimComponent^>^ Components {
    ReadOnlyCollection<ISimComponent^>^ get ();
}

Property Value

Type: ReadOnlyCollectionISimComponent
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.Floor Property

ISimWorldFloor Property

Gets the instance of IFloor in this instance of ISimWorld.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFloor Floor { get; }
property IFloor^ Floor {
    IFloor^ get ();
}

Property Value

Type: IFloor
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.Groups Property

ISimWorldGroups Property

Gets the collection of logical ISimComponent groups

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IGroup> Groups { get; }
property ReadOnlyCollection<IGroup^>^ Groups {
    ReadOnlyCollection<IGroup^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIGroup
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.HasSimulationLevelControl Property

ISimWorldHasSimulationLevelControl Property

Indicates that layout has components/scripts that listen to SimulationLevel-changes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool HasSimulationLevelControl { get; set; }
property bool HasSimulationLevelControl {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.IsSystem Property

ISimWorldIsSystem Property

Defines if this instance of ISimWorld is managed by the application.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsSystem { get; }
property bool IsSystem {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.LayoutItemGroups Property

ISimWorldLayoutItemGroups Property

Gets the collection of ILayoutItemGroup groups that contain at least 1 item

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ILayoutItemGroup> LayoutItemGroups { get; }
property ReadOnlyCollection<ILayoutItemGroup^>^ LayoutItemGroups {
    ReadOnlyCollection<ILayoutItemGroup^>^ get ();
}

Property Value

Type: ReadOnlyCollectionILayoutItemGroup
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.LayoutItems Property

ISimWorldLayoutItems Property

Retrieves the collection of ILayoutItem instances in the simulation world

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ILayoutItem> LayoutItems { get; }
property ReadOnlyCollection<ILayoutItem^>^ LayoutItems {
    ReadOnlyCollection<ILayoutItem^>^ get ();
}

Property Value

Type: ReadOnlyCollectionILayoutItem
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.LayoutMetadata Property

ISimWorldLayoutMetadata Property

Layout metadata object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IModelMetadata LayoutMetadata { get; }
property IModelMetadata^ LayoutMetadata {
    IModelMetadata^ get ();
}

Property Value

Type: IModelMetadata
Remarks

Any changes made to this metadata object is persisted when the layout is saved.

Note that the VCID is always an empty string for layouts.

See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.RandomGeneratorsCount Property

ISimWorldRandomGeneratorsCount Property

Number of random generators

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int RandomGeneratorsCount { get; set; }
property int RandomGeneratorsCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.SimulationLevel Property

ISimWorldSimulationLevel Property

Global simulation level. Setting this value will invoke OnSimulationLevelChanged in all python scripts See also ISimComponent.SimulationLevel.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
SimulationLevel SimulationLevel { get; set; }
property SimulationLevel SimulationLevel {
    SimulationLevel get ();
    void set (SimulationLevel value);
}

Property Value

Type: SimulationLevel
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.Views Property

ISimWorldViews Property

Returns the collection IView3D instances

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IView3D> Views { get; }
property ReadOnlyCollection<IView3D^>^ Views {
    ReadOnlyCollection<IView3D^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIView3D
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.WorldRoot Property

ISimWorldWorldRoot Property

Returns the simulation world root node

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode WorldRoot { get; }
property ISimNode^ WorldRoot {
    ISimNode^ get ();
}

Property Value

Type: ISimNode
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld Methods

The ISimWorld type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clears the simulation world
Public method | CreateComponent(String) | Creates a new component
Public method | CreateComponent(String, IDictionaryString, String) | Creates a new component with given metadata properties. If Keywords is null, component will be created without metadata
Public method | CreateGroup | Creates a new empty logical group for ISimComponent
Public method | CreateGroup(String) | Creates a new empty logical group for ISimComponent with the given name
Public method | CreateLayoutItemT | Creates a new ILayoutItem instance
Public method | CreateLayoutItemGroup | Creates a new empty logical group for ILayoutItem Remarks Empty groups are not persistant
Public method | CreateLayoutItemGroup(String) | Creates a new empty logical group for ILayoutItem with the given name. Remarks Empty groups are not persistant
Public method | CreateView | Creates a new IView3D instance
Public method | DeleteComponent | Deletes the component
Public method | DeleteLayoutItem | Deletes the given ILayoutItem instance
Public method | DeleteView | Deletes the existing IView3D instance
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindComponent | Returns the component by name
Public method | FindLayoutItem | Finds the ILayoutItem by name
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetRandomSeed | Gets seed value for the generator defined by index
Public method | GetSimulationWorldRoot | Create light weight hierarchical representation of simulation world and return the Parent Node
Public method | Import | Import a geometry from CAD file
Public method | InvalidateComponents | Mark components for deletion.
Public method | Raycast | Obsolete. Do raycast in the scene
Public method | SetRandomSeed | Sets the value of the generator defined by index
Public method | UpdateView | Update a IView3D instance
Public method | ValidateComponents | Restore component state for those component that failed to be deleted.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.Clear Method

ISimWorldClear Method

Clears the simulation world

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Clear()
void Clear()
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.CreateComponent Method

ISimWorldCreateComponent Method

Overload List
 | Name | Description
Public method | CreateComponent(String) | Creates a new component
Public method | CreateComponent(String, IDictionaryString, String) | Creates a new component with given metadata properties. If Keywords is null, component will be created without metadata
Top
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.CreateComponent Method (String)

ISimWorldCreateComponent Method (String)

Creates a new component

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent CreateComponent(
    string name
)
ISimComponent^ CreateComponent(
    String^ name
)

Parameters

name
Type: SystemString
Name of the component to be created

Return Value

Type: ISimComponent
Created component
See Also

Reference

ISimWorld Interface
CreateComponent Overload
VisualComponents.Create3D Namespace


ISimWorld.CreateComponent Method (String, IDictionary(String, String))

ISimWorldCreateComponent Method (String, IDictionaryString, String)

Creates a new component with given metadata properties. If Keywords is null, component will be created without metadata

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent CreateComponent(
    string name,
    IDictionary<string, string> keywords
)
ISimComponent^ CreateComponent(
    String^ name,
    IDictionary<String^, String^>^ keywords
)

Parameters

name
Type: SystemString
Name of the component to be created
keywords
Type: System.Collections.GenericIDictionaryString, String
Metadata properties

Return Value

Type: ISimComponent
Created component
See Also

Reference

ISimWorld Interface
CreateComponent Overload
VisualComponents.Create3D Namespace


ISimWorld.CreateGroup Method

ISimWorldCreateGroup Method

Overload List
 | Name | Description
Public method | CreateGroup | Creates a new empty logical group for ISimComponent
Public method | CreateGroup(String) | Creates a new empty logical group for ISimComponent with the given name
Top
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.CreateGroup Method

ISimWorldCreateGroup Method

Creates a new empty logical group for ISimComponent

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IGroup CreateGroup()
IGroup^ CreateGroup()

Return Value

Type: IGroup
New empty logical group object.
See Also

Reference

ISimWorld Interface
CreateGroup Overload
VisualComponents.Create3D Namespace


ISimWorld.CreateGroup Method (String)

ISimWorldCreateGroup Method (String)

Creates a new empty logical group for ISimComponent with the given name

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IGroup CreateGroup(
    string name
)
IGroup^ CreateGroup(
    String^ name
)

Parameters

name
Type: SystemString
Name of the group to be created

Return Value

Type: IGroup
New empty logical group object.
See Also

Reference

ISimWorld Interface
CreateGroup Overload
VisualComponents.Create3D Namespace


ISimWorld.CreateLayoutItem(T) Method

ISimWorldCreateLayoutItemT Method

Creates a new ILayoutItem instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
T CreateLayoutItem<T>(
    string name
)
where T : ILayoutItem

generic<typename T>
where T : ILayoutItem
T CreateLayoutItem(
    String^ name
)

Parameters

name
Type: SystemString
Name of the layout item

Type Parameters

T
Type of layout item to be created

Return Value

Type: T
Created layout item
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.CreateLayoutItemGroup Method

ISimWorldCreateLayoutItemGroup Method

Overload List
 | Name | Description
Public method | CreateLayoutItemGroup | Creates a new empty logical group for ILayoutItem Remarks Empty groups are not persistant
Public method | CreateLayoutItemGroup(String) | Creates a new empty logical group for ILayoutItem with the given name. Remarks Empty groups are not persistant
Top
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.CreateLayoutItemGroup Method

ISimWorldCreateLayoutItemGroup Method

Creates a new empty logical group for ILayoutItem
Remarks
Empty groups are not persistant

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ILayoutItemGroup CreateLayoutItemGroup()
ILayoutItemGroup^ CreateLayoutItemGroup()

Return Value

Type: ILayoutItemGroup
New empty logical group object.
See Also

Reference

ISimWorld Interface
CreateLayoutItemGroup Overload
VisualComponents.Create3D Namespace


ISimWorld.CreateLayoutItemGroup Method (String)

ISimWorldCreateLayoutItemGroup Method (String)

Creates a new empty logical group for ILayoutItem with the given name.
Remarks
Empty groups are not persistant

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ILayoutItemGroup CreateLayoutItemGroup(
    string name
)
ILayoutItemGroup^ CreateLayoutItemGroup(
    String^ name
)

Parameters

name
Type: SystemString
Name of the group to be created

Return Value

Type: ILayoutItemGroup
New empty logical group object.
See Also

Reference

ISimWorld Interface
CreateLayoutItemGroup Overload
VisualComponents.Create3D Namespace


ISimWorld.CreateView Method

ISimWorldCreateView Method

Creates a new IView3D instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IView3D CreateView(
    string name
)
IView3D^ CreateView(
    String^ name
)

Parameters

name
Type: SystemString
Name of the view to be created

Return Value

Type: IView3D
New view instance
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.DeleteComponent Method

ISimWorldDeleteComponent Method

Deletes the component

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteComponent(
    ISimComponent component
)
void DeleteComponent(
    ISimComponent^ component
)

Parameters

component
Type: VisualComponents.Create3DISimComponent
Component to be deleted
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.DeleteLayoutItem Method

ISimWorldDeleteLayoutItem Method

Deletes the given ILayoutItem instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteLayoutItem(
    ILayoutItem item
)
void DeleteLayoutItem(
    ILayoutItem^ item
)

Parameters

item
Type: VisualComponents.Create3DILayoutItem
Layout item to be deleted
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.DeleteView Method

ISimWorldDeleteView Method

Deletes the existing IView3D instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteView(
    IView3D view
)
void DeleteView(
    IView3D^ view
)

Parameters

view
Type: VisualComponents.Create3DIView3D
View to be deleted
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.FindComponent Method

ISimWorldFindComponent Method

Returns the component by name

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent FindComponent(
    string name
)
ISimComponent^ FindComponent(
    String^ name
)

Parameters

name
Type: SystemString
Name of the component

Return Value

Type: ISimComponent
Component if found, otherwise null
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.FindLayoutItem Method

ISimWorldFindLayoutItem Method

Finds the ILayoutItem by name

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ILayoutItem FindLayoutItem(
    string name
)
ILayoutItem^ FindLayoutItem(
    String^ name
)

Parameters

name
Type: SystemString
Name of the layout item

Return Value

Type: ILayoutItem
Layout item if found with given name, otherwise null
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.GetRandomSeed Method

ISimWorldGetRandomSeed Method

Gets seed value for the generator defined by index

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int GetRandomSeed(
    int index
)
int GetRandomSeed(
    int index
)

Parameters

index
Type: SystemInt32
index of the generator

Return Value

Type: Int32
seed value
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.GetSimulationWorldRoot Method

ISimWorldGetSimulationWorldRoot Method

Create light weight hierarchical representation of simulation world and return the Parent Node

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ILightSimNode GetSimulationWorldRoot()
ILightSimNode^ GetSimulationWorldRoot()

Return Value

Type: ILightSimNode
Node that represent the simulation world
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.Import Method

ISimWorldImport Method

Import a geometry from CAD file

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent Import(
    Uri path,
    TessellationDetail tessellationDetail,
    FeatureTreeStructure treeStructure,
    ISimNode node
)
ISimComponent^ Import(
    Uri^ path,
    TessellationDetail tessellationDetail,
    FeatureTreeStructure treeStructure,
    ISimNode^ node
)

Parameters

path
Type: SystemUri
Location of the file to be imported
tessellationDetail
Type: VisualComponents.Create3DTessellationDetail
Tesselation quality (between 0 and 100, the higher the value the coarser the tesselation)
treeStructure
Type: VisualComponents.Create3DFeatureTreeStructure
Feature tree structure
node
Type: VisualComponents.Create3DISimNode
Node where geometry will be stored, or null if new component should be created

Return Value

Type: ISimComponent
Created component, null if no component was created.
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.InvalidateComponents Method

ISimWorldInvalidateComponents Method

Mark components for deletion.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void InvalidateComponents(
    IEnumerable<ISimComponent> components,
    ref Object previousState
)
void InvalidateComponents(
    IEnumerable<ISimComponent^>^ components,
    Object^% previousState
)

Parameters

components
Type: System.Collections.GenericIEnumerableISimComponent
previousState
Type: SystemObject
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.Raycast Method

ISimWorldRaycast Method

Note: This API is now obsolete.

Do raycast in the scene

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("This method is deprecated. Use IWindow3D.RaycastScene instead",
    false)]
Tuple<Matrix, ISimNode, IGeometrySet, int> Raycast(
    Matrix start,
    double length,
    ISimNode exclude,
    Nullable<bool> detectBackface
)
[ObsoleteAttribute(L"This method is deprecated. Use IWindow3D.RaycastScene instead",
    false)]
Tuple<Matrix, ISimNode^, IGeometrySet^, int>^ Raycast(
    Matrix start,
    double length,
    ISimNode^ exclude,
    Nullable<bool> detectBackface
)

Parameters

start
Type: VisualComponents.Create3DMatrix
length
Type: SystemDouble
exclude
Type: VisualComponents.Create3DISimNode
detectBackface
Type: SystemNullableBoolean

Return Value

Type: TupleMatrix, ISimNode, IGeometrySet, Int32
tuple containing hitposition matrix, node, set and possibly index if found, otherwise null.
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.SetRandomSeed Method

ISimWorldSetRandomSeed Method

Sets the value of the generator defined by index

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetRandomSeed(
    int index,
    int seed
)
void SetRandomSeed(
    int index,
    int seed
)

Parameters

index
Type: SystemInt32
index of the generator
seed
Type: SystemInt32
seed value
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.UpdateView Method

ISimWorldUpdateView Method

Update a IView3D instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateView(
    IView3D view
)
void UpdateView(
    IView3D^ view
)

Parameters

view
Type: VisualComponents.Create3DIView3D
View to be updated
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.ValidateComponents Method

ISimWorldValidateComponents Method

Restore component state for those component that failed to be deleted.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ValidateComponents(
    IEnumerable<ISimComponent> components,
    Object previousState
)
void ValidateComponents(
    IEnumerable<ISimComponent^>^ components,
    Object^ previousState
)

Parameters

components
Type: System.Collections.GenericIEnumerableISimComponent
previousState
Type: SystemObject
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld Events

The ISimWorld type exposes the following members.

Events
 | Name | Description
Public event | ComponentAdded | Event that is raised when a component is added to the simulation world
Public event | ComponentRemoving | Event that is raised when a component is being removed from the world
Public event | DynamicComponentAdded | Event that is raised when a dynamic component is added to the simulation world
Public event | DynamicComponentRemoving | Event that is raised when a dynamic component is being removed from the world
Public event | LayoutItemAdded | Event that is raised when a layout item is added to the world.
Public event | LayoutItemRemoving | Event that is raised when a layout item is being removed from the world.
Public event | NodeTreeFinalized | Raised when one or more simulation nodes are to be added to the world. This event is not raised for dynamic components.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | ViewCollectionChanged | Event that is raised when a view is added to the simulation world
Top
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.ComponentAdded Event

ISimWorldComponentAdded Event

Event that is raised when a component is added to the simulation world

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ComponentAddedEventArgs> ComponentAdded
 event EventHandler<ComponentAddedEventArgs^>^ ComponentAdded {
    void add (EventHandler<ComponentAddedEventArgs^>^ value);
    void remove (EventHandler<ComponentAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerComponentAddedEventArgs
Remarks
Important! Do not throw exceptions from your event handler code.
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.ComponentRemoving Event

ISimWorldComponentRemoving Event

Event that is raised when a component is being removed from the world

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ComponentRemovingEventArgs> ComponentRemoving
 event EventHandler<ComponentRemovingEventArgs^>^ ComponentRemoving {
    void add (EventHandler<ComponentRemovingEventArgs^>^ value);
    void remove (EventHandler<ComponentRemovingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerComponentRemovingEventArgs
Remarks
Important! Do not throw exceptions from your event handler code.
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.DynamicComponentAdded Event

ISimWorldDynamicComponentAdded Event

Event that is raised when a dynamic component is added to the simulation world

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ComponentAddedEventArgs> DynamicComponentAdded
 event EventHandler<ComponentAddedEventArgs^>^ DynamicComponentAdded {
    void add (EventHandler<ComponentAddedEventArgs^>^ value);
    void remove (EventHandler<ComponentAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerComponentAddedEventArgs
Remarks
Important! Do not throw exceptions from your event handler code.
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.DynamicComponentRemoving Event

ISimWorldDynamicComponentRemoving Event

Event that is raised when a dynamic component is being removed from the world

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ComponentRemovingEventArgs> DynamicComponentRemoving
 event EventHandler<ComponentRemovingEventArgs^>^ DynamicComponentRemoving {
    void add (EventHandler<ComponentRemovingEventArgs^>^ value);
    void remove (EventHandler<ComponentRemovingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerComponentRemovingEventArgs
Remarks
Important! Do not throw exceptions from your event handler code.
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.LayoutItemAdded Event

ISimWorldLayoutItemAdded Event

Event that is raised when a layout item is added to the world.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<LayoutItemAddedEventArgs> LayoutItemAdded
 event EventHandler<LayoutItemAddedEventArgs^>^ LayoutItemAdded {
    void add (EventHandler<LayoutItemAddedEventArgs^>^ value);
    void remove (EventHandler<LayoutItemAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerLayoutItemAddedEventArgs
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.LayoutItemRemoving Event

ISimWorldLayoutItemRemoving Event

Event that is raised when a layout item is being removed from the world.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<LayoutItemRemovingEventArgs> LayoutItemRemoving
 event EventHandler<LayoutItemRemovingEventArgs^>^ LayoutItemRemoving {
    void add (EventHandler<LayoutItemRemovingEventArgs^>^ value);
    void remove (EventHandler<LayoutItemRemovingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerLayoutItemRemovingEventArgs
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.NodeTreeFinalized Event

ISimWorldNodeTreeFinalized Event

Raised when one or more simulation nodes are to be added to the world. This event is not raised for dynamic components.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<NodeTreeFinalizedEventArgs> NodeTreeFinalized
 event EventHandler<NodeTreeFinalizedEventArgs^>^ NodeTreeFinalized {
    void add (EventHandler<NodeTreeFinalizedEventArgs^>^ value);
    void remove (EventHandler<NodeTreeFinalizedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerNodeTreeFinalizedEventArgs
Remarks

This event is raised in the following situations:

When a model is loaded, this event is raised once for all loaded components.When a component is created, either through the API or by cloning or during simulation, this event is raised once for the newly created component.When a node is created through the API, this event is raised once for the node.When a legacy node is upgraded as a result of changing its JointExpression or PivotExpression properties through the API, this event is raised once for the node.

When this event is raised during component creation or loading, it is raised before any component names are changed to avoid naming conflicts.

See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorld.ViewCollectionChanged Event

ISimWorldViewCollectionChanged Event

Event that is raised when a view is added to the simulation world

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ViewCollectionChangedEventArgs> ViewCollectionChanged
 event EventHandler<ViewCollectionChangedEventArgs^>^ ViewCollectionChanged {
    void add (EventHandler<ViewCollectionChangedEventArgs^>^ value);
    void remove (EventHandler<ViewCollectionChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerViewCollectionChangedEventArgs
See Also

Reference

ISimWorld Interface
VisualComponents.Create3D Namespace


ISimWorldObject Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimWorldObject
public interface class ISimWorldObject

The ISimWorldObject type exposes the following members.

Properties
 | Name | Description
Public property | World | Gets the instance of ISimWorld where this instance of ISimWorldObject belongs to.
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISimWorldObject Properties

The ISimWorldObject type exposes the following members.

Properties
 | Name | Description
Public property | World | Gets the instance of ISimWorld where this instance of ISimWorldObject belongs to.
Top
See Also

Reference

ISimWorldObject Interface
VisualComponents.Create3D Namespace


ISimWorldObject.World Property

ISimWorldObjectWorld Property

Gets the instance of ISimWorld where this instance of ISimWorldObject belongs to.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimWorld World { get; }
property ISimWorld^ World {
    ISimWorld^ get ();
}

Property Value

Type: ISimWorld
See Also

Reference

ISimWorldObject Interface
VisualComponents.Create3D Namespace


ISnapOptionsViewModel Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISnapOptionsViewModel
public interface class ISnapOptionsViewModel

The ISnapOptionsViewModel type exposes the following members.

Properties
 | Name | Description
Public property | RenderGhostWhenSnapping |
Top
Methods
 | Name | Description
Public method | GetCustomSnapperGeometry |
Public method | GetCustomSnapperState |
Public method | GetSnapOption |
Public method | GetSnapOptions |
Public method | HasSnapOptions |
Public method | IsSnapOptionUsable |
Public method | NotifyOptionsChanged |
Public method | OptionsOpened |
Public method | SetSnapOption |
Public method | SetSnapOptions(String, SnapType) |
Public method | SetSnapOptions(String, SnapType, ICustomSnapper) |
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISnapOptionsViewModel Properties

The ISnapOptionsViewModel type exposes the following members.

Properties
 | Name | Description
Public property | RenderGhostWhenSnapping |
Top
See Also

Reference

ISnapOptionsViewModel Interface
VisualComponents.Create3D Namespace


ISnapOptionsViewModel.RenderGhostWhenSnapping Property

ISnapOptionsViewModelRenderGhostWhenSnapping Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool RenderGhostWhenSnapping { get; set; }
property bool RenderGhostWhenSnapping {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISnapOptionsViewModel Interface
VisualComponents.Create3D Namespace


ISnapOptionsViewModel Methods

The ISnapOptionsViewModel type exposes the following members.

Methods
 | Name | Description
Public method | GetCustomSnapperGeometry |
Public method | GetCustomSnapperState |
Public method | GetSnapOption |
Public method | GetSnapOptions |
Public method | HasSnapOptions |
Public method | IsSnapOptionUsable |
Public method | NotifyOptionsChanged |
Public method | OptionsOpened |
Public method | SetSnapOption |
Public method | SetSnapOptions(String, SnapType) |
Public method | SetSnapOptions(String, SnapType, ICustomSnapper) |
Top
See Also

Reference

ISnapOptionsViewModel Interface
VisualComponents.Create3D Namespace


ISnapOptionsViewModel.GetCustomSnapperGeometry Method

ISnapOptionsViewModelGetCustomSnapperGeometry Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Model3DGroup GetCustomSnapperGeometry(
    ICustomSnapper snapper,
    int index
)
Model3DGroup^ GetCustomSnapperGeometry(
    ICustomSnapper^ snapper,
    int index
)

Parameters

snapper
Type: VisualComponents.Create3DICustomSnapper
index
Type: SystemInt32

Return Value

Type: Model3DGroup

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISnapOptionsViewModel.GetCustomSnapperGeometry(VisualComponents.Create3D.ICustomSnapper,System.Int32)"]

See Also

Reference

ISnapOptionsViewModel Interface
VisualComponents.Create3D Namespace


ISnapOptionsViewModel.GetCustomSnapperState Method

ISnapOptionsViewModelGetCustomSnapperState Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool GetCustomSnapperState(
    string snapOptionsContext,
    ICustomSnapper snapper
)
bool GetCustomSnapperState(
    String^ snapOptionsContext,
    ICustomSnapper^ snapper
)

Parameters

snapOptionsContext
Type: SystemString
snapper
Type: VisualComponents.Create3DICustomSnapper

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISnapOptionsViewModel.GetCustomSnapperState(System.String,VisualComponents.Create3D.ICustomSnapper)"]

See Also

Reference

ISnapOptionsViewModel Interface
VisualComponents.Create3D Namespace


ISnapOptionsViewModel.GetSnapOption Method

ISnapOptionsViewModelGetSnapOption Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool GetSnapOption(
    string snapOptionsContext,
    SnapType type
)
bool GetSnapOption(
    String^ snapOptionsContext,
    SnapType type
)

Parameters

snapOptionsContext
Type: SystemString
type
Type: VisualComponents.Create3DSnapType

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISnapOptionsViewModel.GetSnapOption(System.String,VisualComponents.Create3D.SnapType)"]

See Also

Reference

ISnapOptionsViewModel Interface
VisualComponents.Create3D Namespace


ISnapOptionsViewModel.GetSnapOptions Method

ISnapOptionsViewModelGetSnapOptions Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
SnapType[] GetSnapOptions(
    string snapOptionsContext
)
array<SnapType>^ GetSnapOptions(
    String^ snapOptionsContext
)

Parameters

snapOptionsContext
Type: SystemString

Return Value

Type: SnapType

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISnapOptionsViewModel.GetSnapOptions(System.String)"]

See Also

Reference

ISnapOptionsViewModel Interface
VisualComponents.Create3D Namespace


ISnapOptionsViewModel.HasSnapOptions Method

ISnapOptionsViewModelHasSnapOptions Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool HasSnapOptions(
    string snapOptionsContext,
    SnapType[] types,
    ICustomSnapper snapper
)
bool HasSnapOptions(
    String^ snapOptionsContext,
    array<SnapType>^ types,
    ICustomSnapper^ snapper
)

Parameters

snapOptionsContext
Type: SystemString
types
Type: VisualComponents.Create3DSnapType
snapper
Type: VisualComponents.Create3DICustomSnapper

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISnapOptionsViewModel.HasSnapOptions(System.String,VisualComponents.Create3D.SnapType[],VisualComponents.Create3D.ICustomSnapper)"]

See Also

Reference

ISnapOptionsViewModel Interface
VisualComponents.Create3D Namespace


ISnapOptionsViewModel.IsSnapOptionUsable Method

ISnapOptionsViewModelIsSnapOptionUsable Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsSnapOptionUsable(
    string snapOptionsContext,
    SnapType type
)
bool IsSnapOptionUsable(
    String^ snapOptionsContext,
    SnapType type
)

Parameters

snapOptionsContext
Type: SystemString
type
Type: VisualComponents.Create3DSnapType

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISnapOptionsViewModel.IsSnapOptionUsable(System.String,VisualComponents.Create3D.SnapType)"]

See Also

Reference

ISnapOptionsViewModel Interface
VisualComponents.Create3D Namespace


ISnapOptionsViewModel.NotifyOptionsChanged Method

ISnapOptionsViewModelNotifyOptionsChanged Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void NotifyOptionsChanged()
void NotifyOptionsChanged()
See Also

Reference

ISnapOptionsViewModel Interface
VisualComponents.Create3D Namespace


ISnapOptionsViewModel.OptionsOpened Method

ISnapOptionsViewModelOptionsOpened Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void OptionsOpened(
    bool opened
)
void OptionsOpened(
    bool opened
)

Parameters

opened
Type: SystemBoolean
See Also

Reference

ISnapOptionsViewModel Interface
VisualComponents.Create3D Namespace


ISnapOptionsViewModel.SetSnapOption Method

ISnapOptionsViewModelSetSnapOption Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetSnapOption(
    string snapOptionsContext,
    SnapType type,
    bool value
)
void SetSnapOption(
    String^ snapOptionsContext,
    SnapType type,
    bool value
)

Parameters

snapOptionsContext
Type: SystemString
type
Type: VisualComponents.Create3DSnapType
value
Type: SystemBoolean
See Also

Reference

ISnapOptionsViewModel Interface
VisualComponents.Create3D Namespace


ISnapOptionsViewModel.SetSnapOptions Method

ISnapOptionsViewModelSetSnapOptions Method

Overload List
 | Name | Description
Public method | SetSnapOptions(String, SnapType) |
Public method | SetSnapOptions(String, SnapType, ICustomSnapper) |
Top
See Also

Reference

ISnapOptionsViewModel Interface
VisualComponents.Create3D Namespace


ISnapOptionsViewModel.SetSnapOptions Method (String, SnapType[])

ISnapOptionsViewModelSetSnapOptions Method (String, SnapType)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetSnapOptions(
    string snapOptionsContext,
    SnapType[] types
)
void SetSnapOptions(
    String^ snapOptionsContext,
    array<SnapType>^ types
)

Parameters

snapOptionsContext
Type: SystemString
types
Type: VisualComponents.Create3DSnapType
See Also

Reference

ISnapOptionsViewModel Interface
SetSnapOptions Overload
VisualComponents.Create3D Namespace


ISnapOptionsViewModel.SetSnapOptions Method (String, SnapType[], ICustomSnapper)

ISnapOptionsViewModelSetSnapOptions Method (String, SnapType, ICustomSnapper)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetSnapOptions(
    string snapOptionsContext,
    SnapType[] types,
    ICustomSnapper snapper
)
void SetSnapOptions(
    String^ snapOptionsContext,
    array<SnapType>^ types,
    ICustomSnapper^ snapper
)

Parameters

snapOptionsContext
Type: SystemString
types
Type: VisualComponents.Create3DSnapType
snapper
Type: VisualComponents.Create3DICustomSnapper
See Also

Reference

ISnapOptionsViewModel Interface
SetSnapOptions Overload
VisualComponents.Create3D Namespace


ISnapperPosition Interface

Interface for positions produced by path snappers.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISnapperPosition : IPosition,
    ICloneable<ISnapperPosition>, ICloneable, ISnapperPropertyContainer
public interface class ISnapperPosition : IPosition,
    ICloneable<ISnapperPosition^>, ICloneable, ISnapperPropertyContainer

The ISnapperPosition type exposes the following members.

Properties
 | Name | Description
Public property | Node | Gets the instance of ISimNode in this instance of ISnapperPosition.
Public property | Position | Gets or sets the position. It depends on the implementing object in which coordinate system the position is represented. (Inherited from IPosition.)
Public property | Properties | Gets the list containing all the instanceof ISnapperProperty in this instance of ISnapperPropertyContainer. (Inherited from ISnapperPropertyContainer.)
Public property | SurfaceNormals | A list of all found surface normals adjacent to the Position (optional). Wheather the surface normals are available depends if the type of path snapper used to create the path is able to provide this information.
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from ICloneableT.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISnapperPosition Properties

The ISnapperPosition type exposes the following members.

Properties
 | Name | Description
Public property | Node | Gets the instance of ISimNode in this instance of ISnapperPosition.
Public property | Position | Gets or sets the position. It depends on the implementing object in which coordinate system the position is represented. (Inherited from IPosition.)
Public property | Properties | Gets the list containing all the instanceof ISnapperProperty in this instance of ISnapperPropertyContainer. (Inherited from ISnapperPropertyContainer.)
Public property | SurfaceNormals | A list of all found surface normals adjacent to the Position (optional). Wheather the surface normals are available depends if the type of path snapper used to create the path is able to provide this information.
Top
See Also

Reference

ISnapperPosition Interface
VisualComponents.Create3D Namespace


ISnapperPosition.Node Property

ISnapperPositionNode Property

Gets the instance of ISimNode in this instance of ISnapperPosition.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode Node { get; }
property ISimNode^ Node {
    ISimNode^ get ();
}

Property Value

Type: ISimNode
See Also

Reference

ISnapperPosition Interface
VisualComponents.Create3D Namespace


ISnapperPosition.SurfaceNormals Property

ISnapperPositionSurfaceNormals Property

A list of all found surface normals adjacent to the Position (optional). Wheather the surface normals are available depends if the type of path snapper used to create the path is able to provide this information.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<Vector3> SurfaceNormals { get; }
property IList<Vector3>^ SurfaceNormals {
    IList<Vector3>^ get ();
}

Property Value

Type: IListVector3
See Also

Reference

ISnapperPosition Interface
VisualComponents.Create3D Namespace


ISnapperPosition Methods

The ISnapperPosition type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from ICloneableT.)
Top
See Also

Reference

ISnapperPosition Interface
VisualComponents.Create3D Namespace


ISnapperProperty Interface

Interface for properties in path snapper objects.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISnapperProperty : ICloneable<ISnapperProperty>,
    ICloneable
public interface class ISnapperProperty : ICloneable<ISnapperProperty^>,
    ICloneable

The ISnapperProperty type exposes the following members.

Properties
 | Name | Description
Public property | IsTemporary | A Property, which is marked as "temporary" (IsTemporary == true), is only available in the data. When the data gets converted to statements and positions, temporary properties will be ignored and be lost, only non-temporary properties will be converted and be kept.
Public property | IsVisible | A Property, which is marked as "visible" (IsVisible == true), will be marked as visible when exporting to the final IPathStatement, so it can be seen by the user in the IPathStatements properties pane.
Public property | Name | Name of the Property. Must be unique among properties in the same container.
Public property | Value | Value of the Property.
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from ICloneableT.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISnapperProperty Properties

The ISnapperProperty type exposes the following members.

Properties
 | Name | Description
Public property | IsTemporary | A Property, which is marked as "temporary" (IsTemporary == true), is only available in the data. When the data gets converted to statements and positions, temporary properties will be ignored and be lost, only non-temporary properties will be converted and be kept.
Public property | IsVisible | A Property, which is marked as "visible" (IsVisible == true), will be marked as visible when exporting to the final IPathStatement, so it can be seen by the user in the IPathStatements properties pane.
Public property | Name | Name of the Property. Must be unique among properties in the same container.
Public property | Value | Value of the Property.
Top
See Also

Reference

ISnapperProperty Interface
VisualComponents.Create3D Namespace


ISnapperProperty.IsTemporary Property

ISnapperPropertyIsTemporary Property

A Property, which is marked as "temporary" (IsTemporary == true), is only available in the data. When the data gets converted to statements and positions, temporary properties will be ignored and be lost, only non-temporary properties will be converted and be kept.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsTemporary { get; set; }
property bool IsTemporary {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISnapperProperty Interface
VisualComponents.Create3D Namespace


ISnapperProperty.IsVisible Property

ISnapperPropertyIsVisible Property

A Property, which is marked as "visible" (IsVisible == true), will be marked as visible when exporting to the final IPathStatement, so it can be seen by the user in the IPathStatements properties pane.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsVisible { get; set; }
property bool IsVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISnapperProperty Interface
VisualComponents.Create3D Namespace


ISnapperProperty.Name Property

ISnapperPropertyName Property

Name of the Property. Must be unique among properties in the same container.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Name { get; set; }
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ISnapperProperty Interface
VisualComponents.Create3D Namespace


ISnapperProperty.Value Property

ISnapperPropertyValue Property

Value of the Property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object Value { get; set; }
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

ISnapperProperty Interface
VisualComponents.Create3D Namespace


ISnapperProperty Methods

The ISnapperProperty type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from ICloneableT.)
Top
See Also

Reference

ISnapperProperty Interface
VisualComponents.Create3D Namespace


ISnapperPropertyContainer Interface

Interface for snapper related objects with properties.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISnapperPropertyContainer
public interface class ISnapperPropertyContainer

The ISnapperPropertyContainer type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets the list containing all the instanceof ISnapperProperty in this instance of ISnapperPropertyContainer.
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISnapperPropertyContainer Properties

The ISnapperPropertyContainer type exposes the following members.

Properties
 | Name | Description
Public property | Properties | Gets the list containing all the instanceof ISnapperProperty in this instance of ISnapperPropertyContainer.
Top
See Also

Reference

ISnapperPropertyContainer Interface
VisualComponents.Create3D Namespace


ISnapperPropertyContainer.Properties Property

ISnapperPropertyContainerProperties Property

Gets the list containing all the instanceof ISnapperProperty in this instance of ISnapperPropertyContainer.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<ISnapperProperty> Properties { get; }
property IList<ISnapperProperty^>^ Properties {
    IList<ISnapperProperty^>^ get ();
}

Property Value

Type: IListISnapperProperty
See Also

Reference

ISnapperPropertyContainer Interface
VisualComponents.Create3D Namespace


ISolidTopology Interface

Curve topology interface for ITriangleSet

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISolidTopology
public interface class ISolidTopology

The ISolidTopology type exposes the following members.

Properties
 | Name | Description
Public property | CurveCount | Total number of curves in all the curve loops in the geometry
Public property | CurveLoopCount | Total number of curve loops in all faces in the geometry
Public property | CurveLoops | List of ITopologyCurveLoop present in the solid
Public property | Curves | List of ITopologyCurve present in the solid
Public property | FaceCount | Number of faces in the geometry
Public property | Faces | List of ITopologyFace present in the solid
Public property | NurbsEditMode | In case of having nurbs, True means that the nurb object is loaded into memory. Remarks Any nurb operation will turn this mode on, so it is not necessary to turn it on. However, If no operation are going to be done using nurbs, it is recommendable to set it off
Top
Methods
 | Name | Description
Public method | AddNurbFace | Adds a nurb face. Remarks All tessellated faces in this geometry set will be delated after this.
Public method | AddOffsetFace | Creates an offset face based on another face.
Public method | DeleteMathematicalFace | Deletes a mathematical face
Public method | UnloadNurbs | In case of having nurbs, this method will delete them and keep the tessellated data
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISolidTopology Properties

The ISolidTopology type exposes the following members.

Properties
 | Name | Description
Public property | CurveCount | Total number of curves in all the curve loops in the geometry
Public property | CurveLoopCount | Total number of curve loops in all faces in the geometry
Public property | CurveLoops | List of ITopologyCurveLoop present in the solid
Public property | Curves | List of ITopologyCurve present in the solid
Public property | FaceCount | Number of faces in the geometry
Public property | Faces | List of ITopologyFace present in the solid
Public property | NurbsEditMode | In case of having nurbs, True means that the nurb object is loaded into memory. Remarks Any nurb operation will turn this mode on, so it is not necessary to turn it on. However, If no operation are going to be done using nurbs, it is recommendable to set it off
Top
See Also

Reference

ISolidTopology Interface
VisualComponents.Create3D Namespace


ISolidTopology.CurveCount Property

ISolidTopologyCurveCount Property

Total number of curves in all the curve loops in the geometry

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int CurveCount { get; }
property int CurveCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ISolidTopology Interface
VisualComponents.Create3D Namespace


ISolidTopology.CurveLoopCount Property

ISolidTopologyCurveLoopCount Property

Total number of curve loops in all faces in the geometry

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int CurveLoopCount { get; }
property int CurveLoopCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ISolidTopology Interface
VisualComponents.Create3D Namespace


ISolidTopology.CurveLoops Property

ISolidTopologyCurveLoops Property

List of ITopologyCurveLoop present in the solid

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ITopologyCurveLoop> CurveLoops { get; }
property ReadOnlyCollection<ITopologyCurveLoop^>^ CurveLoops {
    ReadOnlyCollection<ITopologyCurveLoop^>^ get ();
}

Property Value

Type: ReadOnlyCollectionITopologyCurveLoop
See Also

Reference

ISolidTopology Interface
VisualComponents.Create3D Namespace


ISolidTopology.Curves Property

ISolidTopologyCurves Property

List of ITopologyCurve present in the solid

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ITopologyCurve> Curves { get; }
property ReadOnlyCollection<ITopologyCurve^>^ Curves {
    ReadOnlyCollection<ITopologyCurve^>^ get ();
}

Property Value

Type: ReadOnlyCollectionITopologyCurve
See Also

Reference

ISolidTopology Interface
VisualComponents.Create3D Namespace


ISolidTopology.FaceCount Property

ISolidTopologyFaceCount Property

Number of faces in the geometry

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int FaceCount { get; }
property int FaceCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ISolidTopology Interface
VisualComponents.Create3D Namespace


ISolidTopology.Faces Property

ISolidTopologyFaces Property

List of ITopologyFace present in the solid

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ITopologyFace> Faces { get; }
property ReadOnlyCollection<ITopologyFace^>^ Faces {
    ReadOnlyCollection<ITopologyFace^>^ get ();
}

Property Value

Type: ReadOnlyCollectionITopologyFace
See Also

Reference

ISolidTopology Interface
VisualComponents.Create3D Namespace


ISolidTopology.NurbsEditMode Property

ISolidTopologyNurbsEditMode Property

In case of having nurbs, True means that the nurb object is loaded into memory.
Remarks
Any nurb operation will turn this mode on, so it is not necessary to turn it on. However, If no operation are going to be done using nurbs, it is recommendable to set it off

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool NurbsEditMode { get; set; }
property bool NurbsEditMode {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISolidTopology Interface
VisualComponents.Create3D Namespace


ISolidTopology Methods

The ISolidTopology type exposes the following members.

Methods
 | Name | Description
Public method | AddNurbFace | Adds a nurb face. Remarks All tessellated faces in this geometry set will be delated after this.
Public method | AddOffsetFace | Creates an offset face based on another face.
Public method | DeleteMathematicalFace | Deletes a mathematical face
Public method | UnloadNurbs | In case of having nurbs, this method will delete them and keep the tessellated data
Top
See Also

Reference

ISolidTopology Interface
VisualComponents.Create3D Namespace


ISolidTopology.AddNurbFace Method

ISolidTopologyAddNurbFace Method

Adds a nurb face.
Remarks
All tessellated faces in this geometry set will be delated after this.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool AddNurbFace(
    Surface surface,
    ICollection<CurveLoop> loops
)
bool AddNurbFace(
    Surface^ surface,
    ICollection<CurveLoop^>^ loops
)

Parameters

surface
Type: VisualComponents.Create3DSurface
Surface information
loops
Type: System.Collections.GenericICollectionCurveLoop
Should have at least 1 loop. First loop is always the outter loop

Return Value

Type: Boolean
True if succeed
See Also

Reference

ISolidTopology Interface
VisualComponents.Create3D Namespace


ISolidTopology.AddOffsetFace Method

ISolidTopologyAddOffsetFace Method

Creates an offset face based on another face.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool AddOffsetFace(
    int faceIndex,
    double offsetDistance
)
bool AddOffsetFace(
    int faceIndex,
    double offsetDistance
)

Parameters

faceIndex
Type: SystemInt32
original face
offsetDistance
Type: SystemDouble
offset distance

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISolidTopology.AddOffsetFace(System.Int32,System.Double)"]

See Also

Reference

ISolidTopology Interface
VisualComponents.Create3D Namespace


ISolidTopology.DeleteMathematicalFace Method

ISolidTopologyDeleteMathematicalFace Method

Deletes a mathematical face

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteMathematicalFace(
    int faceIndex
)
void DeleteMathematicalFace(
    int faceIndex
)

Parameters

faceIndex
Type: SystemInt32
face to be deleted
See Also

Reference

ISolidTopology Interface
VisualComponents.Create3D Namespace


ISolidTopology.UnloadNurbs Method

ISolidTopologyUnloadNurbs Method

In case of having nurbs, this method will delete them and keep the tessellated data

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UnloadNurbs()
void UnloadNurbs()
See Also

Reference

ISolidTopology Interface
VisualComponents.Create3D Namespace


ISphereFeature Interface

Sphere feature interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISphereFeature : IPrimitiveFeature,
    IFeature, IVisualObject, INamed, IWrapper, IDisposable,
    IVisitable, IPropertyContainer, IBatchModeObject, ISharedCloneable
public interface class ISphereFeature : IPrimitiveFeature,
    IFeature, IVisualObject, INamed, IWrapper, IDisposable,
    IVisitable, IPropertyContainer, IBatchModeObject, ISharedCloneable

The ISphereFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
The Sphere geometry primitive generates a sphere of the specified radius.
See Also

Reference

VisualComponents.Create3D Namespace


ISphereFeature Properties

The ISphereFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
See Also

Reference

ISphereFeature Interface
VisualComponents.Create3D Namespace


ISphereFeature Methods

The ISphereFeature type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISphereFeature Interface
VisualComponents.Create3D Namespace


ISphereFeature Events

The ISphereFeature type exposes the following members.

Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

ISphereFeature Interface
VisualComponents.Create3D Namespace


IStartTransportInStatement Interface

Transports ISimProducts in asynchronously.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IStartTransportInStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IStartTransportInStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IStartTransportInStatement type exposes the following members.

Properties
 | Name | Description
Public property | AcceptAllProductTypes | Defines whether ISimProducts of any IProductType should be accepted regardless of the other settings.
Public property | AcceptedFlowGroups | Gets an editable list of explicitly accepted IProcessFlowGroups.
Public property | AcceptedProductTypes | Gets an editable list of explicitly accepted IProductTypes.
Public property | ApiType | (Inherited from IApiType.)
Public property | AssemblyOrderVariableName | Gets or sets the name of the variable containing an object returned from the IGetAssemblyStatement. Used only if Mode is set to ProcessAssembly.
Public property | AssemblyVariableName | Gets or sets the name of the variable containing an ISimProduct that has a non-null ISimAssembly. Used only if Mode is set to ProcessAssembly.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Mode | Gets or sets the mode defining what this statement will be doing.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductPositionFrame | Gets or sets frame location where products should be placed.
Public property | ProductVariableName | Gets or sets the name of the variable where reference to the received ISimProduct instance will be stored.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReservedProductVariableName | Gets or sets the name of the variable containing products already reserved using IReserveProductStatement.
Public property | ResourcePositionFrame | Gets or sets frame location where resource will move while placing the product.
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IStartTransportInStatement Properties

The IStartTransportInStatement type exposes the following members.

Properties
 | Name | Description
Public property | AcceptAllProductTypes | Defines whether ISimProducts of any IProductType should be accepted regardless of the other settings.
Public property | AcceptedFlowGroups | Gets an editable list of explicitly accepted IProcessFlowGroups.
Public property | AcceptedProductTypes | Gets an editable list of explicitly accepted IProductTypes.
Public property | ApiType | (Inherited from IApiType.)
Public property | AssemblyOrderVariableName | Gets or sets the name of the variable containing an object returned from the IGetAssemblyStatement. Used only if Mode is set to ProcessAssembly.
Public property | AssemblyVariableName | Gets or sets the name of the variable containing an ISimProduct that has a non-null ISimAssembly. Used only if Mode is set to ProcessAssembly.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Mode | Gets or sets the mode defining what this statement will be doing.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductPositionFrame | Gets or sets frame location where products should be placed.
Public property | ProductVariableName | Gets or sets the name of the variable where reference to the received ISimProduct instance will be stored.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReservedProductVariableName | Gets or sets the name of the variable containing products already reserved using IReserveProductStatement.
Public property | ResourcePositionFrame | Gets or sets frame location where resource will move while placing the product.
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
See Also

Reference

IStartTransportInStatement Interface
VisualComponents.Create3D Namespace


IStartTransportInStatement.AcceptAllProductTypes Property

IStartTransportInStatementAcceptAllProductTypes Property

Defines whether ISimProducts of any IProductType should be accepted regardless of the other settings.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool AcceptAllProductTypes { get; set; }
property bool AcceptAllProductTypes {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IStartTransportInStatement Interface
VisualComponents.Create3D Namespace


IStartTransportInStatement.AcceptedFlowGroups Property

IStartTransportInStatementAcceptedFlowGroups Property

Gets an editable list of explicitly accepted IProcessFlowGroups.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IProcessFlowGroup> AcceptedFlowGroups { get; }
property IList<IProcessFlowGroup^>^ AcceptedFlowGroups {
    IList<IProcessFlowGroup^>^ get ();
}

Property Value

Type: IListIProcessFlowGroup
See Also

Reference

IStartTransportInStatement Interface
VisualComponents.Create3D Namespace


IStartTransportInStatement.AcceptedProductTypes Property

IStartTransportInStatementAcceptedProductTypes Property

Gets an editable list of explicitly accepted IProductTypes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IProductType> AcceptedProductTypes { get; }
property IList<IProductType^>^ AcceptedProductTypes {
    IList<IProductType^>^ get ();
}

Property Value

Type: IListIProductType
See Also

Reference

IStartTransportInStatement Interface
VisualComponents.Create3D Namespace


IStartTransportInStatement.AssemblyOrderVariableName Property

IStartTransportInStatementAssemblyOrderVariableName Property

Gets or sets the name of the variable containing an object returned from the IGetAssemblyStatement.

Used only if Mode is set to ProcessAssembly.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string AssemblyOrderVariableName { get; set; }
property String^ AssemblyOrderVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown by setter when supplied value is null.
See Also

Reference

IStartTransportInStatement Interface
VisualComponents.Create3D Namespace


IStartTransportInStatement.AssemblyVariableName Property

IStartTransportInStatementAssemblyVariableName Property

Gets or sets the name of the variable containing an ISimProduct that has a non-null ISimAssembly.

Used only if Mode is set to ProcessAssembly.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string AssemblyVariableName { get; set; }
property String^ AssemblyVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown by setter when supplied value is null.
See Also

Reference

IStartTransportInStatement Interface
VisualComponents.Create3D Namespace


IStartTransportInStatement.Mode Property

IStartTransportInStatementMode Property

Gets or sets the mode defining what this statement will be doing.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
TransportStatementMode Mode { get; set; }
property TransportStatementMode Mode {
    TransportStatementMode get ();
    void set (TransportStatementMode value);
}

Property Value

Type: TransportStatementMode
See Also

Reference

IStartTransportInStatement Interface
VisualComponents.Create3D Namespace


IStartTransportInStatement.ProductPositionFrame Property

IStartTransportInStatementProductPositionFrame Property

Gets or sets frame location where products should be placed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFrameFeature ProductPositionFrame { get; set; }
property IFrameFeature^ ProductPositionFrame {
    IFrameFeature^ get ();
    void set (IFrameFeature^ value);
}

Property Value

Type: IFrameFeature
See Also

Reference

IStartTransportInStatement Interface
VisualComponents.Create3D Namespace


IStartTransportInStatement.ProductVariableName Property

IStartTransportInStatementProductVariableName Property

Gets or sets the name of the variable where reference to the received ISimProduct instance will be stored.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ProductVariableName { get; set; }
property String^ ProductVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
The variable will be created if needed when this statement executes.
See Also

Reference

IStartTransportInStatement Interface
VisualComponents.Create3D Namespace


IStartTransportInStatement.ReservedProductVariableName Property

IStartTransportInStatementReservedProductVariableName Property

Gets or sets the name of the variable containing products already reserved using IReserveProductStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ReservedProductVariableName { get; set; }
property String^ ReservedProductVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown by setter when supplied value is null.
Remarks
Can be left as an empty string, meaning that Product reservation is not used.
See Also

Reference

IStartTransportInStatement Interface
VisualComponents.Create3D Namespace


IStartTransportInStatement.ResourcePositionFrame Property

IStartTransportInStatementResourcePositionFrame Property

Gets or sets frame location where resource will move while placing the product.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFrameFeature ResourcePositionFrame { get; set; }
property IFrameFeature^ ResourcePositionFrame {
    IFrameFeature^ get ();
    void set (IFrameFeature^ value);
}

Property Value

Type: IFrameFeature
See Also

Reference

IStartTransportInStatement Interface
VisualComponents.Create3D Namespace


IStartTransportInStatement Methods

The IStartTransportInStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IStartTransportInStatement Interface
VisualComponents.Create3D Namespace


IStartTransportInStatement Events

The IStartTransportInStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IStartTransportInStatement Interface
VisualComponents.Create3D Namespace


IStartTransportOutStatement Interface

Transports ISimProducts out asynchronously.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IStartTransportOutStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IStartTransportOutStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IStartTransportOutStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | AssemblyOrderVariableName | Gets or sets the name of the variable containing an object returned from the IGetAssemblyStatement. Used only if Mode is set to ProcessAssembly.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Container | Gets or sets IComponentContainer where outgoing products will be placed.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | Destination | Gets or sets the destination where products are transported out.
Public property | DestinationNode | Gets or sets ITransportNode products will be sent to.
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Mode | Gets or sets the mode defining what this statement will be doing.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductVariableName | Gets or sets the name of the variable which stores a reference to ISimProduct instances to be transported out. If Mode is set to ProcessAssembly, then the given ISimProduct must have a non-null ISimAssembly.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ResourcePositionFrame | Gets or sets frame location where resource will move while picking the product.
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | SendAsProductBundles | If Mode is set to ProcessAssembly, determines whether leaving products retain their child products from the assembly. Within any selected step, the first slot of a product bundle hierarchy will always leave as a separate product, or product bundle. Thus, use AssemblyOrderVariableName to control bundle grouping.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IStartTransportOutStatement Properties

The IStartTransportOutStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | AssemblyOrderVariableName | Gets or sets the name of the variable containing an object returned from the IGetAssemblyStatement. Used only if Mode is set to ProcessAssembly.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Container | Gets or sets IComponentContainer where outgoing products will be placed.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | Destination | Gets or sets the destination where products are transported out.
Public property | DestinationNode | Gets or sets ITransportNode products will be sent to.
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Mode | Gets or sets the mode defining what this statement will be doing.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductVariableName | Gets or sets the name of the variable which stores a reference to ISimProduct instances to be transported out. If Mode is set to ProcessAssembly, then the given ISimProduct must have a non-null ISimAssembly.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ResourcePositionFrame | Gets or sets frame location where resource will move while picking the product.
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | SendAsProductBundles | If Mode is set to ProcessAssembly, determines whether leaving products retain their child products from the assembly. Within any selected step, the first slot of a product bundle hierarchy will always leave as a separate product, or product bundle. Thus, use AssemblyOrderVariableName to control bundle grouping.
Top
See Also

Reference

IStartTransportOutStatement Interface
VisualComponents.Create3D Namespace


IStartTransportOutStatement.AssemblyOrderVariableName Property

IStartTransportOutStatementAssemblyOrderVariableName Property

Gets or sets the name of the variable containing an object returned from the IGetAssemblyStatement.

Used only if Mode is set to ProcessAssembly.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string AssemblyOrderVariableName { get; set; }
property String^ AssemblyOrderVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown by setter when supplied value is null.
See Also

Reference

IStartTransportOutStatement Interface
VisualComponents.Create3D Namespace


IStartTransportOutStatement.Container Property

IStartTransportOutStatementContainer Property

Gets or sets IComponentContainer where outgoing products will be placed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IComponentContainer Container { get; set; }
property IComponentContainer^ Container {
    IComponentContainer^ get ();
    void set (IComponentContainer^ value);
}

Property Value

Type: IComponentContainer
See Also

Reference

IStartTransportOutStatement Interface
VisualComponents.Create3D Namespace


IStartTransportOutStatement.Destination Property

IStartTransportOutStatementDestination Property

Gets or sets the destination where products are transported out.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
TransportOutType Destination { get; set; }
property TransportOutType Destination {
    TransportOutType get ();
    void set (TransportOutType value);
}

Property Value

Type: TransportOutType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown by getter when native Destination property has an invalid value or by setter when an invalid value is supplied.
See Also

Reference

IStartTransportOutStatement Interface
VisualComponents.Create3D Namespace


IStartTransportOutStatement.DestinationNode Property

IStartTransportOutStatementDestinationNode Property

Gets or sets ITransportNode products will be sent to.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ITransportNode DestinationNode { get; set; }
property ITransportNode^ DestinationNode {
    ITransportNode^ get ();
    void set (ITransportNode^ value);
}

Property Value

Type: ITransportNode
See Also

Reference

IStartTransportOutStatement Interface
VisualComponents.Create3D Namespace


IStartTransportOutStatement.Mode Property

IStartTransportOutStatementMode Property

Gets or sets the mode defining what this statement will be doing.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
TransportStatementMode Mode { get; set; }
property TransportStatementMode Mode {
    TransportStatementMode get ();
    void set (TransportStatementMode value);
}

Property Value

Type: TransportStatementMode
See Also

Reference

IStartTransportOutStatement Interface
VisualComponents.Create3D Namespace


IStartTransportOutStatement.ProductVariableName Property

IStartTransportOutStatementProductVariableName Property

Gets or sets the name of the variable which stores a reference to ISimProduct instances to be transported out.

If Mode is set to ProcessAssembly, then the given ISimProduct must have a non-null ISimAssembly.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ProductVariableName { get; set; }
property String^ ProductVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown by setter when supplied value is null.
Remarks
The variable reference is resolved when the statement executes.
See Also

Reference

IStartTransportOutStatement Interface
VisualComponents.Create3D Namespace


IStartTransportOutStatement.ResourcePositionFrame Property

IStartTransportOutStatementResourcePositionFrame Property

Gets or sets frame location where resource will move while picking the product.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFrameFeature ResourcePositionFrame { get; set; }
property IFrameFeature^ ResourcePositionFrame {
    IFrameFeature^ get ();
    void set (IFrameFeature^ value);
}

Property Value

Type: IFrameFeature
See Also

Reference

IStartTransportOutStatement Interface
VisualComponents.Create3D Namespace


IStartTransportOutStatement.SendAsProductBundles Property

IStartTransportOutStatementSendAsProductBundles Property

If Mode is set to ProcessAssembly, determines whether leaving products retain their child products from the assembly.

Within any selected step, the first slot of a product bundle hierarchy will always leave as a separate product, or product bundle. Thus, use AssemblyOrderVariableName to control bundle grouping.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SendAsProductBundles { get; set; }
property bool SendAsProductBundles {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IStartTransportOutStatement Interface
VisualComponents.Create3D Namespace


IStartTransportOutStatement Methods

The IStartTransportOutStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IStartTransportOutStatement Interface
VisualComponents.Create3D Namespace


IStartTransportOutStatement Events

The IStartTransportOutStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IStartTransportOutStatement Interface
VisualComponents.Create3D Namespace


IStatement Interface

Statement interface. Statement defines a functionality that can be executed by the instance of IStatementExecutor. Statement is always owned by an instance of IStatementScope.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IStatement : INamed,
    IPropertyContainer, IBatchModeObject, IWrapper, IDisposable, IApiType,
    ICloneable<IStatement>, ICloneable
public interface class IStatement : INamed,
    IPropertyContainer, IBatchModeObject, IWrapper, IDisposable, IApiType,
    ICloneable<IStatement^>, ICloneable

The IStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet).
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic.
Public property | ExecutedCycleTime | Gets the cached execution time of the statement.
Public property | IsExecuting | Defines if this instance of IStatement is being executed.
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time.
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed.
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx).
Public event | Executing | Event that occurs when the statement execution starts.
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset).
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IStatement Properties

The IStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet).
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic.
Public property | ExecutedCycleTime | Gets the cached execution time of the statement.
Public property | IsExecuting | Defines if this instance of IStatement is being executed.
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement.
Top
See Also

Reference

IStatement Interface
VisualComponents.Create3D Namespace


IStatement.ControlExecutedExEvent Property

IStatementControlExecutedExEvent Property

Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ControlExecutedExEvent { get; set; }
property bool ControlExecutedExEvent {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IStatement Interface
VisualComponents.Create3D Namespace
IStatementExecutingEx
IStatementExecutedEx


IStatement.CustomStatement Property

IStatementCustomStatement Property

Associated custom statement that is listening to this statement events, and implements main execution logic.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ICustomStatement CustomStatement { get; }
property ICustomStatement^ CustomStatement {
    ICustomStatement^ get ();
}

Property Value

Type: ICustomStatement
See Also

Reference

IStatement Interface
VisualComponents.Create3D Namespace


IStatement.ExecutedCycleTime Property

IStatementExecutedCycleTime Property

Gets the cached execution time of the statement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double ExecutedCycleTime { get; }
property double ExecutedCycleTime {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IStatement Interface
VisualComponents.Create3D Namespace


IStatement.IsExecuting Property

IStatementIsExecuting Property

Defines if this instance of IStatement is being executed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsExecuting { get; }
property bool IsExecuting {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IStatement Interface
VisualComponents.Create3D Namespace


IStatement.IsLoop Property

IStatementIsLoop Property

Defines if this instance of IStatement will be executed again after it finishes executing.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsLoop { get; }
property bool IsLoop {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IStatement Interface
VisualComponents.Create3D Namespace


IStatement.ParentScope Property

IStatementParentScope Property

Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatementScope ParentScope { get; }
property IStatementScope^ ParentScope {
    IStatementScope^ get ();
}

Property Value

Type: IStatementScope
See Also

Reference

IStatement Interface
VisualComponents.Create3D Namespace


IStatement.Routine Property

IStatementRoutine Property

Gets the instance of IRoutine that owns this instance of IStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRoutine Routine { get; }
property IRoutine^ Routine {
    IRoutine^ get ();
}

Property Value

Type: IRoutine
See Also

Reference

IStatement Interface
VisualComponents.Create3D Namespace


IStatement Methods

The IStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time.
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IStatement Interface
VisualComponents.Create3D Namespace


IStatement.Clone Method

IStatementClone Method

Overload List
 | Name | Description
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning.
Top
See Also

Reference

IStatement Interface
VisualComponents.Create3D Namespace


IStatement.Clone Method (Boolean)

IStatementClone Method (Boolean)

Extended cloning.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatement Clone(
    bool cloneContents
)
IStatement^ Clone(
    bool cloneContents
)

Parameters

cloneContents
Type: SystemBoolean

Return Value

Type: IStatement

[Missing <returns> documentation for "M:VisualComponents.Create3D.IStatement.Clone(System.Boolean)"]

See Also

Reference

IStatement Interface
Clone Overload
VisualComponents.Create3D Namespace


IStatement.ExecuteImmediate Method

IStatementExecuteImmediate Method

Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ExecuteImmediate()
void ExecuteImmediate()
See Also

Reference

IStatement Interface
VisualComponents.Create3D Namespace


IStatement Events

The IStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed.
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx).
Public event | Executing | Event that occurs when the statement execution starts.
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset).
Top
See Also

Reference

IStatement Interface
VisualComponents.Create3D Namespace


IStatement.Executed Event

IStatementExecuted Event

Event that occurs when the statement has been executed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<StatementExecutedEventArgs> Executed
 event EventHandler<StatementExecutedEventArgs^>^ Executed {
    void add (EventHandler<StatementExecutedEventArgs^>^ value);
    void remove (EventHandler<StatementExecutedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerStatementExecutedEventArgs
See Also

Reference

IStatement Interface
VisualComponents.Create3D Namespace


IStatement.ExecutedEx Event

IStatementExecutedEx Event

Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<StatementExecutedEventArgs> ExecutedEx
 event EventHandler<StatementExecutedEventArgs^>^ ExecutedEx {
    void add (EventHandler<StatementExecutedEventArgs^>^ value);
    void remove (EventHandler<StatementExecutedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerStatementExecutedEventArgs
See Also

Reference

IStatement Interface
VisualComponents.Create3D Namespace


IStatement.Executing Event

IStatementExecuting Event

Event that occurs when the statement execution starts.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<StatementExecutingEventArgs> Executing
 event EventHandler<StatementExecutingEventArgs^>^ Executing {
    void add (EventHandler<StatementExecutingEventArgs^>^ value);
    void remove (EventHandler<StatementExecutingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerStatementExecutingEventArgs
See Also

Reference

IStatement Interface
VisualComponents.Create3D Namespace


IStatement.ExecutingEx Event

IStatementExecutingEx Event

Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<StatementExecutingEventArgs> ExecutingEx
 event EventHandler<StatementExecutingEventArgs^>^ ExecutingEx {
    void add (EventHandler<StatementExecutingEventArgs^>^ value);
    void remove (EventHandler<StatementExecutingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerStatementExecutingEventArgs
See Also

Reference

IStatement Interface
VisualComponents.Create3D Namespace


IStatement.Reset Event

IStatementReset Event

Event that occurs when the statement (i.e. simulation is reset).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> Reset
 event EventHandler<EventArgs^>^ Reset {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

IStatement Interface
VisualComponents.Create3D Namespace


IStatementExecutor Interface

Base class of any executor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IStatementExecutor
public interface class IStatementExecutor

The IStatementExecutor type exposes the following members.

Properties
 | Name | Description
Public property | ActiveProgram | Gets or sets the currently active program.
Public property | CurrentScope | Get the scope that is currently being executed.
Public property | CurrentStatement | Gets the current position of the program pointer. Returns null if in the beginning of scope.
Public property | IsEnabled | Defines if the executor will execute its program.
Public property | IsLooping | Defines if the executor will restart the program automatically when finished.
Public property | Program | Gets the first program contained by this IStatementExecutor instance.
Public property | Programs | Gets all the instances of IProgram in this executor.
Top
Methods
 | Name | Description
Public method | ClearPrograms |
Public method | Continue | Continues execution.
Public method | Continue(Double) | Continues the execution after a given time.
Public method | CreateProgram | Creates a new instance of IProgram.
Public method | CreateProgram(String) | Creates a new instance of IProgram.
Public method | DeleteProgram | Deletes the given instance of IProgram
Public method | ExecuteStep | Execute the next IStatement.
Public method | JumpToScope | Adds the current program position to the stack and jumps program execution to the given scope. When the scope is finished, the progam will continue from the current position.
Public method | NotifyStatementExecutedEx | Signals ExecutedEx event for this statement. This should only be used together with custom statements that have set the value of ControlExecutedExEvent to true.
Public method | Reset | Reset the execution to the beginning of the program.
Public method | SetProgramPointer | Sets the program pointer to the given position. When executed, the program will start from this position.
Top
Events
 | Name | Description
Public event | ActiveProgramChanged | Occurs when the value of ActiveProgram has changed.
Public event | ProgramAdded | Occurs when a new instance of IProgram has been added to this instance of IStatementExecutor.
Public event | ProgramRemoving | Occurs when an instance of IProgram is being removed from this instance of IStatementExecutor.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IStatementExecutor Properties

The IStatementExecutor type exposes the following members.

Properties
 | Name | Description
Public property | ActiveProgram | Gets or sets the currently active program.
Public property | CurrentScope | Get the scope that is currently being executed.
Public property | CurrentStatement | Gets the current position of the program pointer. Returns null if in the beginning of scope.
Public property | IsEnabled | Defines if the executor will execute its program.
Public property | IsLooping | Defines if the executor will restart the program automatically when finished.
Public property | Program | Gets the first program contained by this IStatementExecutor instance.
Public property | Programs | Gets all the instances of IProgram in this executor.
Top
See Also

Reference

IStatementExecutor Interface
VisualComponents.Create3D Namespace


IStatementExecutor.ActiveProgram Property

IStatementExecutorActiveProgram Property

Gets or sets the currently active program.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProgram ActiveProgram { get; set; }
property IProgram^ ActiveProgram {
    IProgram^ get ();
    void set (IProgram^ value);
}

Property Value

Type: IProgram
See Also

Reference

IStatementExecutor Interface
VisualComponents.Create3D Namespace


IStatementExecutor.CurrentScope Property

IStatementExecutorCurrentScope Property

Get the scope that is currently being executed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatementScope CurrentScope { get; }
property IStatementScope^ CurrentScope {
    IStatementScope^ get ();
}

Property Value

Type: IStatementScope
See Also

Reference

IStatementExecutor Interface
VisualComponents.Create3D Namespace


IStatementExecutor.CurrentStatement Property

IStatementExecutorCurrentStatement Property

Gets the current position of the program pointer. Returns null if in the beginning of scope.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatement CurrentStatement { get; }
property IStatement^ CurrentStatement {
    IStatement^ get ();
}

Property Value

Type: IStatement
See Also

Reference

IStatementExecutor Interface
VisualComponents.Create3D Namespace


IStatementExecutor.IsEnabled Property

IStatementExecutorIsEnabled Property

Defines if the executor will execute its program.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsEnabled { get; set; }
property bool IsEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IStatementExecutor Interface
VisualComponents.Create3D Namespace


IStatementExecutor.IsLooping Property

IStatementExecutorIsLooping Property

Defines if the executor will restart the program automatically when finished.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsLooping { get; set; }
property bool IsLooping {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IStatementExecutor Interface
VisualComponents.Create3D Namespace


IStatementExecutor.Program Property

IStatementExecutorProgram Property

Gets the first program contained by this IStatementExecutor instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProgram Program { get; }
property IProgram^ Program {
    IProgram^ get ();
}

Property Value

Type: IProgram
See Also

Reference

IStatementExecutor Interface
VisualComponents.Create3D Namespace


IStatementExecutor.Programs Property

IStatementExecutorPrograms Property

Gets all the instances of IProgram in this executor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<IProgram> Programs { get; }
property IEnumerable<IProgram^>^ Programs {
    IEnumerable<IProgram^>^ get ();
}

Property Value

Type: IEnumerableIProgram
See Also

Reference

IStatementExecutor Interface
VisualComponents.Create3D Namespace


IStatementExecutor Methods

The IStatementExecutor type exposes the following members.

Methods
 | Name | Description
Public method | ClearPrograms |
Public method | Continue | Continues execution.
Public method | Continue(Double) | Continues the execution after a given time.
Public method | CreateProgram | Creates a new instance of IProgram.
Public method | CreateProgram(String) | Creates a new instance of IProgram.
Public method | DeleteProgram | Deletes the given instance of IProgram
Public method | ExecuteStep | Execute the next IStatement.
Public method | JumpToScope | Adds the current program position to the stack and jumps program execution to the given scope. When the scope is finished, the progam will continue from the current position.
Public method | NotifyStatementExecutedEx | Signals ExecutedEx event for this statement. This should only be used together with custom statements that have set the value of ControlExecutedExEvent to true.
Public method | Reset | Reset the execution to the beginning of the program.
Public method | SetProgramPointer | Sets the program pointer to the given position. When executed, the program will start from this position.
Top
See Also

Reference

IStatementExecutor Interface
VisualComponents.Create3D Namespace


IStatementExecutor.ClearPrograms Method

IStatementExecutorClearPrograms Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ClearPrograms()
void ClearPrograms()
See Also

Reference

IStatementExecutor Interface
VisualComponents.Create3D Namespace


IStatementExecutor.Continue Method

IStatementExecutorContinue Method

Overload List
 | Name | Description
Public method | Continue | Continues execution.
Public method | Continue(Double) | Continues the execution after a given time.
Top
See Also

Reference

IStatementExecutor Interface
VisualComponents.Create3D Namespace


IStatementExecutor.Continue Method

IStatementExecutorContinue Method

Continues execution.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Continue()
void Continue()
See Also

Reference

IStatementExecutor Interface
Continue Overload
VisualComponents.Create3D Namespace


IStatementExecutor.Continue Method (Double)

IStatementExecutorContinue Method (Double)

Continues the execution after a given time.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Continue(
    double time
)
void Continue(
    double time
)

Parameters

time
Type: SystemDouble
Time in seconds
See Also

Reference

IStatementExecutor Interface
Continue Overload
VisualComponents.Create3D Namespace


IStatementExecutor.CreateProgram Method

IStatementExecutorCreateProgram Method

Overload List
 | Name | Description
Public method | CreateProgram | Creates a new instance of IProgram.
Public method | CreateProgram(String) | Creates a new instance of IProgram.
Top
See Also

Reference

IStatementExecutor Interface
VisualComponents.Create3D Namespace


IStatementExecutor.CreateProgram Method

IStatementExecutorCreateProgram Method

Creates a new instance of IProgram.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProgram CreateProgram()
IProgram^ CreateProgram()

Return Value

Type: IProgram
New program.
See Also

Reference

IStatementExecutor Interface
CreateProgram Overload
VisualComponents.Create3D Namespace


IStatementExecutor.CreateProgram Method (String)

IStatementExecutorCreateProgram Method (String)

Creates a new instance of IProgram.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProgram CreateProgram(
    string name
)
IProgram^ CreateProgram(
    String^ name
)

Parameters

name
Type: SystemString
Program name.

Return Value

Type: IProgram
New program.
Exceptions
Exception | Condition
ArgumentNullException | Occurs when name is null.
See Also

Reference

IStatementExecutor Interface
CreateProgram Overload
VisualComponents.Create3D Namespace


IStatementExecutor.DeleteProgram Method

IStatementExecutorDeleteProgram Method

Deletes the given instance of IProgram

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteProgram(
    IProgram program
)
void DeleteProgram(
    IProgram^ program
)

Parameters

program
Type: VisualComponents.Create3DIProgram
Program to be deleted.
Exceptions
Exception | Condition
ArgumentNullException | Occurs when program is null.
InvalidOperationException | Occurs when attempting to delete the system program.
See Also

Reference

IStatementExecutor Interface
VisualComponents.Create3D Namespace


IStatementExecutor.ExecuteStep Method

IStatementExecutorExecuteStep Method

Execute the next IStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ExecuteStep(
    bool immediate
)
bool ExecuteStep(
    bool immediate
)

Parameters

immediate
Type: SystemBoolean
Defines if the next IStatement should be executed in immediate mode

Return Value

Type: Boolean
False if the program has finished after executing the statement, true if there are still statements remaining.
See Also

Reference

IStatementExecutor Interface
VisualComponents.Create3D Namespace


IStatementExecutor.JumpToScope Method

IStatementExecutorJumpToScope Method

Adds the current program position to the stack and jumps program execution to the given scope. When the scope is finished, the progam will continue from the current position.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void JumpToScope(
    IStatementScope scope
)
void JumpToScope(
    IStatementScope^ scope
)

Parameters

scope
Type: VisualComponents.Create3DIStatementScope
Scope to jump to.
See Also

Reference

IStatementExecutor Interface
VisualComponents.Create3D Namespace


IStatementExecutor.NotifyStatementExecutedEx Method

IStatementExecutorNotifyStatementExecutedEx Method

Signals ExecutedEx event for this statement. This should only be used together with custom statements that have set the value of ControlExecutedExEvent to true.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void NotifyStatementExecutedEx(
    IStatement statement
)
void NotifyStatementExecutedEx(
    IStatement^ statement
)

Parameters

statement
Type: VisualComponents.Create3DIStatement
Exceptions
Exception | Condition
NullReferenceException | Occurs when the given statement is null.
InvalidOperationException | Occurs when the given statement belons to a different executor.
See Also

Reference

IStatementExecutor Interface
VisualComponents.Create3D Namespace


IStatementExecutor.Reset Method

IStatementExecutorReset Method

Reset the execution to the beginning of the program.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Reset()
void Reset()
See Also

Reference

IStatementExecutor Interface
VisualComponents.Create3D Namespace


IStatementExecutor.SetProgramPointer Method

IStatementExecutorSetProgramPointer Method

Sets the program pointer to the given position. When executed, the program will start from this position.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetProgramPointer(
    int statementIndex,
    IStatementScope scope
)
void SetProgramPointer(
    int statementIndex,
    IStatementScope^ scope
)

Parameters

statementIndex
Type: SystemInt32
Index of the statement.
scope
Type: VisualComponents.Create3DIStatementScope
Scope in which the statement resides.
See Also

Reference

IStatementExecutor Interface
VisualComponents.Create3D Namespace


IStatementExecutor Events

The IStatementExecutor type exposes the following members.

Events
 | Name | Description
Public event | ActiveProgramChanged | Occurs when the value of ActiveProgram has changed.
Public event | ProgramAdded | Occurs when a new instance of IProgram has been added to this instance of IStatementExecutor.
Public event | ProgramRemoving | Occurs when an instance of IProgram is being removed from this instance of IStatementExecutor.
Top
See Also

Reference

IStatementExecutor Interface
VisualComponents.Create3D Namespace


IStatementExecutor.ActiveProgramChanged Event

IStatementExecutorActiveProgramChanged Event

Occurs when the value of ActiveProgram has changed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> ActiveProgramChanged
 event EventHandler<EventArgs^>^ ActiveProgramChanged {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

IStatementExecutor Interface
VisualComponents.Create3D Namespace


IStatementExecutor.ProgramAdded Event

IStatementExecutorProgramAdded Event

Occurs when a new instance of IProgram has been added to this instance of IStatementExecutor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ProgramAddedEventArgs> ProgramAdded
 event EventHandler<ProgramAddedEventArgs^>^ ProgramAdded {
    void add (EventHandler<ProgramAddedEventArgs^>^ value);
    void remove (EventHandler<ProgramAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerProgramAddedEventArgs
See Also

Reference

IStatementExecutor Interface
VisualComponents.Create3D Namespace


IStatementExecutor.ProgramRemoving Event

IStatementExecutorProgramRemoving Event

Occurs when an instance of IProgram is being removed from this instance of IStatementExecutor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ProgramRemovingEventArgs> ProgramRemoving
 event EventHandler<ProgramRemovingEventArgs^>^ ProgramRemoving {
    void add (EventHandler<ProgramRemovingEventArgs^>^ value);
    void remove (EventHandler<ProgramRemovingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerProgramRemovingEventArgs
See Also

Reference

IStatementExecutor Interface
VisualComponents.Create3D Namespace


IStatementScope Interface

Statement scope is a set of statements. Statement scope can be either a routine, a statement (e.g. while statement) or a child scope inside a statement (e.g if then/else).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IStatementScope : IInterpolatable,
    IApiType
public interface class IStatementScope : IInterpolatable,
    IApiType

The IStatementScope type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine.
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope.
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope.
Top
Methods
 | Name | Description
Public method | Clear | Deletes all the statements in this instance of IStatementScope.
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope.
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | GetStatement | Gets a statement at the given position.
Public method | InsertStatement | Inserts the goven statement to the given position.
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope.
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | ScopeExecuted | Occurs when statement has been executed.
Public event | StatementAdded | Occurs when a statement has been added to this scope.
Public event | StatementMoved | Occurs when statement has been moved in this scope.
Public event | StatementRemoved | Occurs when a statement has been removed from this scope.
Public event | StatementRemoving | Occurs when a statement is being removed from this scope.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IStatementScope Properties

The IStatementScope type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine.
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope.
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope.
Top
See Also

Reference

IStatementScope Interface
VisualComponents.Create3D Namespace


IStatementScope.ParentStatement Property

IStatementScopeParentStatement Property

Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatement ParentStatement { get; }
property IStatement^ ParentStatement {
    IStatement^ get ();
}

Property Value

Type: IStatement
See Also

Reference

IStatementScope Interface
VisualComponents.Create3D Namespace


IStatementScope.StatementCount Property

IStatementScopeStatementCount Property

Gets the number of direct child statements belonging to this instance of IStatementScope.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int StatementCount { get; }
property int StatementCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IStatementScope Interface
VisualComponents.Create3D Namespace


IStatementScope.Statements Property

IStatementScopeStatements Property

Gets all the direct child statements belonging to this instance of IStatementScope.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IStatement> Statements { get; }
property ReadOnlyCollection<IStatement^>^ Statements {
    ReadOnlyCollection<IStatement^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIStatement
See Also

Reference

IStatementScope Interface
VisualComponents.Create3D Namespace


IStatementScope Methods

The IStatementScope type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Deletes all the statements in this instance of IStatementScope.
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope.
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | GetStatement | Gets a statement at the given position.
Public method | InsertStatement | Inserts the goven statement to the given position.
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope.
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
See Also

Reference

IStatementScope Interface
VisualComponents.Create3D Namespace


IStatementScope.Clear Method

IStatementScopeClear Method

Deletes all the statements in this instance of IStatementScope.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Clear()
void Clear()
See Also

Reference

IStatementScope Interface
VisualComponents.Create3D Namespace


IStatementScope.DeleteStatement Method

IStatementScopeDeleteStatement Method

Deletes the given statement from this instance of IStatementScope.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteStatement(
    IStatement statement
)
void DeleteStatement(
    IStatement^ statement
)

Parameters

statement
Type: VisualComponents.Create3DIStatement
Statement to be deleted.
See Also

Reference

IStatementScope Interface
VisualComponents.Create3D Namespace


IStatementScope.GetStatement Method

IStatementScopeGetStatement Method

Gets a statement at the given position.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatement GetStatement(
    int index
)
IStatement^ GetStatement(
    int index
)

Parameters

index
Type: SystemInt32
Position.

Return Value

Type: IStatement
Statement.
See Also

Reference

IStatementScope Interface
VisualComponents.Create3D Namespace


IStatementScope.InsertStatement Method

IStatementScopeInsertStatement Method

Inserts the goven statement to the given position.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void InsertStatement(
    IStatement statement,
    int index
)
void InsertStatement(
    IStatement^ statement,
    int index
)

Parameters

statement
Type: VisualComponents.Create3DIStatement
Statement to be inserted.
index
Type: SystemInt32
Position for the statwement.
See Also

Reference

IStatementScope Interface
VisualComponents.Create3D Namespace


IStatementScope.MoveStatement Method

IStatementScopeMoveStatement Method

Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void MoveStatement(
    IStatement statement,
    int index
)
void MoveStatement(
    IStatement^ statement,
    int index
)

Parameters

statement
Type: VisualComponents.Create3DIStatement
Statement to be moved.
index
Type: SystemInt32
New position for the statement.
See Also

Reference

IStatementScope Interface
VisualComponents.Create3D Namespace


IStatementScope Events

The IStatementScope type exposes the following members.

Events
 | Name | Description
Public event | ScopeExecuted | Occurs when statement has been executed.
Public event | StatementAdded | Occurs when a statement has been added to this scope.
Public event | StatementMoved | Occurs when statement has been moved in this scope.
Public event | StatementRemoved | Occurs when a statement has been removed from this scope.
Public event | StatementRemoving | Occurs when a statement is being removed from this scope.
Top
See Also

Reference

IStatementScope Interface
VisualComponents.Create3D Namespace


IStatementScope.ScopeExecuted Event

IStatementScopeScopeExecuted Event

Occurs when statement has been executed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ScopeExecutedEventArgs> ScopeExecuted
 event EventHandler<ScopeExecutedEventArgs^>^ ScopeExecuted {
    void add (EventHandler<ScopeExecutedEventArgs^>^ value);
    void remove (EventHandler<ScopeExecutedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerScopeExecutedEventArgs
See Also

Reference

IStatementScope Interface
VisualComponents.Create3D Namespace


IStatementScope.StatementAdded Event

IStatementScopeStatementAdded Event

Occurs when a statement has been added to this scope.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<StatementAddedEventArgs> StatementAdded
 event EventHandler<StatementAddedEventArgs^>^ StatementAdded {
    void add (EventHandler<StatementAddedEventArgs^>^ value);
    void remove (EventHandler<StatementAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerStatementAddedEventArgs
See Also

Reference

IStatementScope Interface
VisualComponents.Create3D Namespace


IStatementScope.StatementMoved Event

IStatementScopeStatementMoved Event

Occurs when statement has been moved in this scope.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<StatementMovedEventArgs> StatementMoved
 event EventHandler<StatementMovedEventArgs^>^ StatementMoved {
    void add (EventHandler<StatementMovedEventArgs^>^ value);
    void remove (EventHandler<StatementMovedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerStatementMovedEventArgs
See Also

Reference

IStatementScope Interface
VisualComponents.Create3D Namespace


IStatementScope.StatementRemoved Event

IStatementScopeStatementRemoved Event

Occurs when a statement has been removed from this scope.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<StatementRemovedEventArgs> StatementRemoved
 event EventHandler<StatementRemovedEventArgs^>^ StatementRemoved {
    void add (EventHandler<StatementRemovedEventArgs^>^ value);
    void remove (EventHandler<StatementRemovedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerStatementRemovedEventArgs
See Also

Reference

IStatementScope Interface
VisualComponents.Create3D Namespace


IStatementScope.StatementRemoving Event

IStatementScopeStatementRemoving Event

Occurs when a statement is being removed from this scope.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<StatementRemovingEventArgs> StatementRemoving
 event EventHandler<StatementRemovingEventArgs^>^ StatementRemoving {
    void add (EventHandler<StatementRemovingEventArgs^>^ value);
    void remove (EventHandler<StatementRemovingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerStatementRemovingEventArgs
See Also

Reference

IStatementScope Interface
VisualComponents.Create3D Namespace


IStatistics Interface

An interface for collecting statistics of material flow.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IStatistics : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IStatistics : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IStatistics type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | GetStatisticsStates | Gest all the custom statistics states.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | PartsAverageCount | Gets the average amount of components in the container.
Public property | PartsAverageTime | Gets the average time a component spends in the container.
Public property | PartsCurrent | Gets the amount of components currently in the container.
Public property | PartsEntered | Gets the amount of components that entered the container.
Public property | PartsExited | Gets the amount of components that exited the container.
Public property | PartsMaxCount | Gets the maximum amount of components in the container.
Public property | PartsMaxTime | Gets the longest time a component spent in the container.
Public property | PartsMinCount | Gets the minimum amount of components in the container.
Public property | PartsMinTime | Gets the shortest time a component spent in the container.
Public property | PartsTotalTime | Gets the total time parts were on/in a component, i.e. the sum of each part's duration in the container.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SystemStates | Gets the names of container states for which statistics are collected.
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateDefaultStates | Removes all the states and adds the default states.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | CreateStatisticsStates | Creates a new state.
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatisticsStates | Deletes given state.
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStateTotalTime | Gets the total time the container was in the given State.
Public method | GetSystemPercentage | Gets the percentage of time spent in the given State.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
Usually referenced by IFlowBehavior.
See Also

Reference

VisualComponents.Create3D Namespace


IStatistics Properties

The IStatistics type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | GetStatisticsStates | Gest all the custom statistics states.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | PartsAverageCount | Gets the average amount of components in the container.
Public property | PartsAverageTime | Gets the average time a component spends in the container.
Public property | PartsCurrent | Gets the amount of components currently in the container.
Public property | PartsEntered | Gets the amount of components that entered the container.
Public property | PartsExited | Gets the amount of components that exited the container.
Public property | PartsMaxCount | Gets the maximum amount of components in the container.
Public property | PartsMaxTime | Gets the longest time a component spent in the container.
Public property | PartsMinCount | Gets the minimum amount of components in the container.
Public property | PartsMinTime | Gets the shortest time a component spent in the container.
Public property | PartsTotalTime | Gets the total time parts were on/in a component, i.e. the sum of each part's duration in the container.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SystemStates | Gets the names of container states for which statistics are collected.
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IStatistics Interface
VisualComponents.Create3D Namespace


IStatistics.GetStatisticsStates Property

IStatisticsGetStatisticsStates Property

Gest all the custom statistics states.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IStatisticsState> GetStatisticsStates { get; }
property ReadOnlyCollection<IStatisticsState^>^ GetStatisticsStates {
    ReadOnlyCollection<IStatisticsState^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIStatisticsState
See Also

Reference

IStatistics Interface
VisualComponents.Create3D Namespace


IStatistics.PartsAverageCount Property

IStatisticsPartsAverageCount Property

Gets the average amount of components in the container.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double PartsAverageCount { get; }
property double PartsAverageCount {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IStatistics Interface
VisualComponents.Create3D Namespace


IStatistics.PartsAverageTime Property

IStatisticsPartsAverageTime Property

Gets the average time a component spends in the container.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double PartsAverageTime { get; }
property double PartsAverageTime {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IStatistics Interface
VisualComponents.Create3D Namespace


IStatistics.PartsCurrent Property

IStatisticsPartsCurrent Property

Gets the amount of components currently in the container.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int PartsCurrent { get; }
property int PartsCurrent {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IStatistics Interface
VisualComponents.Create3D Namespace


IStatistics.PartsEntered Property

IStatisticsPartsEntered Property

Gets the amount of components that entered the container.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int PartsEntered { get; }
property int PartsEntered {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IStatistics Interface
VisualComponents.Create3D Namespace


IStatistics.PartsExited Property

IStatisticsPartsExited Property

Gets the amount of components that exited the container.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int PartsExited { get; }
property int PartsExited {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IStatistics Interface
VisualComponents.Create3D Namespace


IStatistics.PartsMaxCount Property

IStatisticsPartsMaxCount Property

Gets the maximum amount of components in the container.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int PartsMaxCount { get; }
property int PartsMaxCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IStatistics Interface
VisualComponents.Create3D Namespace


IStatistics.PartsMaxTime Property

IStatisticsPartsMaxTime Property

Gets the longest time a component spent in the container.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double PartsMaxTime { get; }
property double PartsMaxTime {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IStatistics Interface
VisualComponents.Create3D Namespace


IStatistics.PartsMinCount Property

IStatisticsPartsMinCount Property

Gets the minimum amount of components in the container.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int PartsMinCount { get; }
property int PartsMinCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IStatistics Interface
VisualComponents.Create3D Namespace


IStatistics.PartsMinTime Property

IStatisticsPartsMinTime Property

Gets the shortest time a component spent in the container.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double PartsMinTime { get; }
property double PartsMinTime {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IStatistics Interface
VisualComponents.Create3D Namespace


IStatistics.PartsTotalTime Property

IStatisticsPartsTotalTime Property

Gets the total time parts were on/in a component, i.e. the sum of each part's duration in the container.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double PartsTotalTime { get; }
property double PartsTotalTime {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IStatistics Interface
VisualComponents.Create3D Namespace


IStatistics.SystemStates Property

IStatisticsSystemStates Property

Gets the names of container states for which statistics are collected.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<string> SystemStates { get; }
property ReadOnlyCollection<String^>^ SystemStates {
    ReadOnlyCollection<String^>^ get ();
}

Property Value

Type: ReadOnlyCollectionString
See Also

Reference

IStatistics Interface
VisualComponents.Create3D Namespace


IStatistics Methods

The IStatistics type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateDefaultStates | Removes all the states and adds the default states.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | CreateStatisticsStates | Creates a new state.
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatisticsStates | Deletes given state.
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStateTotalTime | Gets the total time the container was in the given State.
Public method | GetSystemPercentage | Gets the percentage of time spent in the given State.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IStatistics Interface
VisualComponents.Create3D Namespace


IStatistics.CreateDefaultStates Method

IStatisticsCreateDefaultStates Method

Removes all the states and adds the default states.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void CreateDefaultStates()
void CreateDefaultStates()
See Also

Reference

IStatistics Interface
VisualComponents.Create3D Namespace


IStatistics.CreateStatisticsStates Method

IStatisticsCreateStatisticsStates Method

Creates a new state.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatisticsState CreateStatisticsStates(
    string name
)
IStatisticsState^ CreateStatisticsStates(
    String^ name
)

Parameters

name
Type: SystemString

Return Value

Type: IStatisticsState
Created state.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when name is null or empty.
See Also

Reference

IStatistics Interface
VisualComponents.Create3D Namespace


IStatistics.DeleteStatisticsStates Method

IStatisticsDeleteStatisticsStates Method

Deletes given state.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteStatisticsStates(
    IStatisticsState state
)
void DeleteStatisticsStates(
    IStatisticsState^ state
)

Parameters

state
Type: VisualComponents.Create3DIStatisticsState
Exceptions
Exception | Condition
ArgumentNullException | Thrown when state is null.
See Also

Reference

IStatistics Interface
VisualComponents.Create3D Namespace


IStatistics.GetStateTotalTime Method

IStatisticsGetStateTotalTime Method

Gets the total time the container was in the given State.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double GetStateTotalTime(
    State state
)
double GetStateTotalTime(
    State state
)

Parameters

state
Type: VisualComponents.Create3DState
The state of the container.

Return Value

Type: Double
Time in seconds.
See Also

Reference

IStatistics Interface
VisualComponents.Create3D Namespace


IStatistics.GetSystemPercentage Method

IStatisticsGetSystemPercentage Method

Gets the percentage of time spent in the given State.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double GetSystemPercentage(
    State state
)
double GetSystemPercentage(
    State state
)

Parameters

state
Type: VisualComponents.Create3DState
The state of the container.

Return Value

Type: Double
Percentage value.
See Also

Reference

IStatistics Interface
VisualComponents.Create3D Namespace


IStatistics Events

The IStatistics type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IStatistics Interface
VisualComponents.Create3D Namespace


IStatisticsChart Interface

Base interface for selectable chart item (StatisticsChartBase), chart's UI (StatisticsChartViewModel), and placeholder chart UI (StatisticsChartViewModel).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IStatisticsChart : IStatisticsChartBase,
    INamed, INotifyPropertyChanged, IDisposable
public interface class IStatisticsChart : IStatisticsChartBase,
    INamed, INotifyPropertyChanged, IDisposable

The IStatisticsChart type exposes the following members.

Properties
 | Name | Description
Public property | AccumulatedValues | Values accumulated during sampling interval: 0: Latest time delta since last sampling time 1: Latest value 2: Minimum value 3: Maximum value 4: Average value 5: Sum of time deltas recording during sampling period (Inherited from IStatisticsChartBase.)
Public property | AllSourceInfos | Additional information about current sources, used in populating a pie chart. (Inherited from IStatisticsChartBase.)
Public property | AllSourceInfosEx | Additional information about current sources, used in populating a pie chart. (Inherited from IStatisticsChartBase.)
Public property | AllSources | List of sources decuded from Series, their Property- and Components-references. Each IStatisticsSeries can have one or more sources/properties. (Inherited from IStatisticsChartBase.)
Public property | BaseChart | Internal reference. Not needed normally.
Public property | ChartType | Chart's type (line, bar, area, or pie) (Inherited from IStatisticsChartBase.)
Public property | DataRows | Graph data for all series/sources. (Inherited from IStatisticsChartBase.)
Public property | DataType | Type of information stored in IStatisticsChartBase.DataRow. (Inherited from IStatisticsChartBase.)
Public property | DisplayName | Same as Name.
Public property | FieldCountPerProperty | How many double values are recorded per source/property. See StatisticsDataRow.RowFields. (Inherited from IStatisticsChartBase.)
Public property | IsCreated | Indicates that placeholder slot was filled with actual chart.
Public property | IsStarted | State of simulation timer. (Inherited from IStatisticsChartBase.)
Public property | LegendVisibility | Visibility of chart's legend panel. (Inherited from IStatisticsChartBase.)
Public property | MustUseStatisticsInterval | Indicates that one of the selected properties belong to statistics behavior, and global sampling interval must be used. This means that SamplingInterval will be automatically forced to -1. (Inherited from IStatisticsChartBase.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentTab | Reference to tab.
Public property | Position | Todo: setter, which will either change position-values in dashboard layout, or move graph from one position to another.
Public property | RecordAccumulatedValues | Indicates that property values should be integrated over time. (Inherited from IStatisticsChartBase.)
Public property | SamplingInterval | Custom sampling interval. Currently can be defined for all properties, except for statistics behavior properties. -1 means that global sampling interval is used. (Inherited from IStatisticsChartBase.)
Public property | SamplingTimer | Simulation timer used to update this chart. (Inherited from IStatisticsChartBase.)
Public property | Series | List of chart series. Note: each series can monitor multiple properties. (Inherited from IStatisticsChartBase.)
Public property | TileState | Maximized or normal state.
Public property | TileType | Note: IsCreated==true means that TileType == ActualTile.
Public property | TitleVisibility | Visibility of chart's title. (Inherited from IStatisticsChartBase.)
Top
Methods
 | Name | Description
Public method | AddSeries | Adds a blank series. (Inherited from IStatisticsChartBase.)
Public method | ClearData | Clears the DataRows list. (Inherited from IStatisticsChartBase.)
Public method | ClearSeries | Removes all series. (Inherited from IStatisticsChartBase.)
Public method | ConvertToDouble | Helper method for converting IProperty.Value to double. (Inherited from IStatisticsChartBase.)
Public method | DeleteSeries | Removes series configuration. (Inherited from IStatisticsChartBase.)
Public method | Dispose | Disposes a chart. (Inherited from IStatisticsChartBase.)
Public method | NotifyPropertyChanged | INotifyPropertyChanged interface implementation. (Inherited from IStatisticsChartBase.)
Public method | StartStopTimer | Enabled/disabled the simulation timer. (Inherited from IStatisticsChartBase.)
Public method | UpdateChart | Updates visual representation of chart. (Inherited from IStatisticsChartBase.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | Indicates that one of the monitored components or properties was deleted. (Inherited from IStatisticsChartBase.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IStatisticsChart Properties

The IStatisticsChart type exposes the following members.

Properties
 | Name | Description
Public property | AccumulatedValues | Values accumulated during sampling interval: 0: Latest time delta since last sampling time 1: Latest value 2: Minimum value 3: Maximum value 4: Average value 5: Sum of time deltas recording during sampling period (Inherited from IStatisticsChartBase.)
Public property | AllSourceInfos | Additional information about current sources, used in populating a pie chart. (Inherited from IStatisticsChartBase.)
Public property | AllSourceInfosEx | Additional information about current sources, used in populating a pie chart. (Inherited from IStatisticsChartBase.)
Public property | AllSources | List of sources decuded from Series, their Property- and Components-references. Each IStatisticsSeries can have one or more sources/properties. (Inherited from IStatisticsChartBase.)
Public property | BaseChart | Internal reference. Not needed normally.
Public property | ChartType | Chart's type (line, bar, area, or pie) (Inherited from IStatisticsChartBase.)
Public property | DataRows | Graph data for all series/sources. (Inherited from IStatisticsChartBase.)
Public property | DataType | Type of information stored in IStatisticsChartBase.DataRow. (Inherited from IStatisticsChartBase.)
Public property | DisplayName | Same as Name.
Public property | FieldCountPerProperty | How many double values are recorded per source/property. See StatisticsDataRow.RowFields. (Inherited from IStatisticsChartBase.)
Public property | IsCreated | Indicates that placeholder slot was filled with actual chart.
Public property | IsStarted | State of simulation timer. (Inherited from IStatisticsChartBase.)
Public property | LegendVisibility | Visibility of chart's legend panel. (Inherited from IStatisticsChartBase.)
Public property | MustUseStatisticsInterval | Indicates that one of the selected properties belong to statistics behavior, and global sampling interval must be used. This means that SamplingInterval will be automatically forced to -1. (Inherited from IStatisticsChartBase.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentTab | Reference to tab.
Public property | Position | Todo: setter, which will either change position-values in dashboard layout, or move graph from one position to another.
Public property | RecordAccumulatedValues | Indicates that property values should be integrated over time. (Inherited from IStatisticsChartBase.)
Public property | SamplingInterval | Custom sampling interval. Currently can be defined for all properties, except for statistics behavior properties. -1 means that global sampling interval is used. (Inherited from IStatisticsChartBase.)
Public property | SamplingTimer | Simulation timer used to update this chart. (Inherited from IStatisticsChartBase.)
Public property | Series | List of chart series. Note: each series can monitor multiple properties. (Inherited from IStatisticsChartBase.)
Public property | TileState | Maximized or normal state.
Public property | TileType | Note: IsCreated==true means that TileType == ActualTile.
Public property | TitleVisibility | Visibility of chart's title. (Inherited from IStatisticsChartBase.)
Top
See Also

Reference

IStatisticsChart Interface
VisualComponents.Create3D Namespace


IStatisticsChart.BaseChart Property

IStatisticsChartBaseChart Property

Internal reference. Not needed normally.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatisticsChartBase BaseChart { get; }
property IStatisticsChartBase^ BaseChart {
    IStatisticsChartBase^ get ();
}

Property Value

Type: IStatisticsChartBase
See Also

Reference

IStatisticsChart Interface
VisualComponents.Create3D Namespace


IStatisticsChart.DisplayName Property

IStatisticsChartDisplayName Property

Same as Name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string DisplayName { get; set; }
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IStatisticsChart Interface
VisualComponents.Create3D Namespace


IStatisticsChart.IsCreated Property

IStatisticsChartIsCreated Property

Indicates that placeholder slot was filled with actual chart.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsCreated { get; }
property bool IsCreated {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IStatisticsChart Interface
VisualComponents.Create3D Namespace


IStatisticsChart.ParentTab Property

IStatisticsChartParentTab Property

Reference to tab.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatisticsTab ParentTab { get; }
property IStatisticsTab^ ParentTab {
    IStatisticsTab^ get ();
}

Property Value

Type: IStatisticsTab
See Also

Reference

IStatisticsChart Interface
VisualComponents.Create3D Namespace


IStatisticsChart.Position Property

IStatisticsChartPosition Property

Todo: setter, which will either change position-values in dashboard layout, or move graph from one position to another.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ChartPosition Position { get; }
property ChartPosition^ Position {
    ChartPosition^ get ();
}

Property Value

Type: ChartPosition
See Also

Reference

IStatisticsChart Interface
VisualComponents.Create3D Namespace


IStatisticsChart.TileState Property

IStatisticsChartTileState Property

Maximized or normal state.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ChartTileState TileState { get; set; }
property ChartTileState TileState {
    ChartTileState get ();
    void set (ChartTileState value);
}

Property Value

Type: ChartTileState
See Also

Reference

IStatisticsChart Interface
VisualComponents.Create3D Namespace


IStatisticsChart.TileType Property

IStatisticsChartTileType Property

Note: IsCreated==true means that TileType == ActualTile.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ChartTileType TileType { get; }
property ChartTileType TileType {
    ChartTileType get ();
}

Property Value

Type: ChartTileType
See Also

Reference

IStatisticsChart Interface
VisualComponents.Create3D Namespace


IStatisticsChart Methods

The IStatisticsChart type exposes the following members.

Methods
 | Name | Description
Public method | AddSeries | Adds a blank series. (Inherited from IStatisticsChartBase.)
Public method | ClearData | Clears the DataRows list. (Inherited from IStatisticsChartBase.)
Public method | ClearSeries | Removes all series. (Inherited from IStatisticsChartBase.)
Public method | ConvertToDouble | Helper method for converting IProperty.Value to double. (Inherited from IStatisticsChartBase.)
Public method | DeleteSeries | Removes series configuration. (Inherited from IStatisticsChartBase.)
Public method | Dispose | Disposes a chart. (Inherited from IStatisticsChartBase.)
Public method | NotifyPropertyChanged | INotifyPropertyChanged interface implementation. (Inherited from IStatisticsChartBase.)
Public method | StartStopTimer | Enabled/disabled the simulation timer. (Inherited from IStatisticsChartBase.)
Public method | UpdateChart | Updates visual representation of chart. (Inherited from IStatisticsChartBase.)
Top
See Also

Reference

IStatisticsChart Interface
VisualComponents.Create3D Namespace


IStatisticsChart Events

The IStatisticsChart type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | Indicates that one of the monitored components or properties was deleted. (Inherited from IStatisticsChartBase.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IStatisticsChart Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase Interface

Base interface for selectable chart item (StatisticsChartBase), chart's UI (StatisticsChartViewModel), and placeholder chart UI (StatisticsChartViewModel).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IStatisticsChartBase : INamed,
    INotifyPropertyChanged, IDisposable
public interface class IStatisticsChartBase : INamed,
    INotifyPropertyChanged, IDisposable

The IStatisticsChartBase type exposes the following members.

Properties
 | Name | Description
Public property | AccumulatedValues | Values accumulated during sampling interval: 0: Latest time delta since last sampling time 1: Latest value 2: Minimum value 3: Maximum value 4: Average value 5: Sum of time deltas recording during sampling period
Public property | AllSourceInfos | Additional information about current sources, used in populating a pie chart.
Public property | AllSourceInfosEx | Additional information about current sources, used in populating a pie chart.
Public property | AllSources | List of sources decuded from Series, their Property- and Components-references. Each IStatisticsSeries can have one or more sources/properties.
Public property | ChartType | Chart's type (line, bar, area, or pie)
Public property | DataRows | Graph data for all series/sources.
Public property | DataType | Type of information stored in IStatisticsChartBase.DataRow.
Public property | FieldCountPerProperty | How many double values are recorded per source/property. See StatisticsDataRow.RowFields.
Public property | IsStarted | State of simulation timer.
Public property | LegendVisibility | Visibility of chart's legend panel.
Public property | MustUseStatisticsInterval | Indicates that one of the selected properties belong to statistics behavior, and global sampling interval must be used. This means that SamplingInterval will be automatically forced to -1.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | RecordAccumulatedValues | Indicates that property values should be integrated over time.
Public property | SamplingInterval | Custom sampling interval. Currently can be defined for all properties, except for statistics behavior properties. -1 means that global sampling interval is used.
Public property | SamplingTimer | Simulation timer used to update this chart.
Public property | Series | List of chart series. Note: each series can monitor multiple properties.
Public property | TitleVisibility | Visibility of chart's title.
Top
Methods
 | Name | Description
Public method | AddSeries | Adds a blank series.
Public method | ClearData | Clears the DataRows list.
Public method | ClearSeries | Removes all series.
Public method | ConvertToDouble | Helper method for converting IProperty.Value to double.
Public method | DeleteSeries | Removes series configuration.
Public method | Dispose | Disposes a chart.
Public method | NotifyPropertyChanged | INotifyPropertyChanged interface implementation.
Public method | StartStopTimer | Enabled/disabled the simulation timer.
Public method | UpdateChart | Updates visual representation of chart.
Top
Events
 | Name | Description
Public event | ObjectInvalidated | Indicates that one of the monitored components or properties was deleted.
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IStatisticsChartBase Properties

The IStatisticsChartBase type exposes the following members.

Properties
 | Name | Description
Public property | AccumulatedValues | Values accumulated during sampling interval: 0: Latest time delta since last sampling time 1: Latest value 2: Minimum value 3: Maximum value 4: Average value 5: Sum of time deltas recording during sampling period
Public property | AllSourceInfos | Additional information about current sources, used in populating a pie chart.
Public property | AllSourceInfosEx | Additional information about current sources, used in populating a pie chart.
Public property | AllSources | List of sources decuded from Series, their Property- and Components-references. Each IStatisticsSeries can have one or more sources/properties.
Public property | ChartType | Chart's type (line, bar, area, or pie)
Public property | DataRows | Graph data for all series/sources.
Public property | DataType | Type of information stored in IStatisticsChartBase.DataRow.
Public property | FieldCountPerProperty | How many double values are recorded per source/property. See StatisticsDataRow.RowFields.
Public property | IsStarted | State of simulation timer.
Public property | LegendVisibility | Visibility of chart's legend panel.
Public property | MustUseStatisticsInterval | Indicates that one of the selected properties belong to statistics behavior, and global sampling interval must be used. This means that SamplingInterval will be automatically forced to -1.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | RecordAccumulatedValues | Indicates that property values should be integrated over time.
Public property | SamplingInterval | Custom sampling interval. Currently can be defined for all properties, except for statistics behavior properties. -1 means that global sampling interval is used.
Public property | SamplingTimer | Simulation timer used to update this chart.
Public property | Series | List of chart series. Note: each series can monitor multiple properties.
Public property | TitleVisibility | Visibility of chart's title.
Top
See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase.AccumulatedValues Property

IStatisticsChartBaseAccumulatedValues Property

Values accumulated during sampling interval: 0: Latest time delta since last sampling time 1: Latest value 2: Minimum value 3: Maximum value 4: Average value 5: Sum of time deltas recording during sampling period

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
List<double[]> AccumulatedValues { get; }
property List<array<double>^>^ AccumulatedValues {
    List<array<double>^>^ get ();
}

Property Value

Type: ListDouble
See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase.AllSourceInfos Property

IStatisticsChartBaseAllSourceInfos Property

Additional information about current sources, used in populating a pie chart.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<StatisticsSourceInfo> AllSourceInfos { get; }
property IReadOnlyList<StatisticsSourceInfo^>^ AllSourceInfos {
    IReadOnlyList<StatisticsSourceInfo^>^ get ();
}

Property Value

Type: IReadOnlyListStatisticsSourceInfo
See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase.AllSourceInfosEx Property

IStatisticsChartBaseAllSourceInfosEx Property

Additional information about current sources, used in populating a pie chart.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<StatisticsDataRow> AllSourceInfosEx { get; }
property IReadOnlyList<StatisticsDataRow^>^ AllSourceInfosEx {
    IReadOnlyList<StatisticsDataRow^>^ get ();
}

Property Value

Type: IReadOnlyListStatisticsDataRow
See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase.AllSources Property

IStatisticsChartBaseAllSources Property

List of sources decuded from Series, their Property- and Components-references. Each IStatisticsSeries can have one or more sources/properties.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<IStatisticsSource> AllSources { get; }
property IReadOnlyList<IStatisticsSource^>^ AllSources {
    IReadOnlyList<IStatisticsSource^>^ get ();
}

Property Value

Type: IReadOnlyListIStatisticsSource
See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase.ChartType Property

IStatisticsChartBaseChartType Property

Chart's type (line, bar, area, or pie)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ChartType ChartType { get; set; }
property ChartType ChartType {
    ChartType get ();
    void set (ChartType value);
}

Property Value

Type: ChartType
See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase.DataRows Property

IStatisticsChartBaseDataRows Property

Graph data for all series/sources.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<StatisticsDataRow> DataRows { get; }
property IReadOnlyList<StatisticsDataRow^>^ DataRows {
    IReadOnlyList<StatisticsDataRow^>^ get ();
}

Property Value

Type: IReadOnlyListStatisticsDataRow
See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase.DataType Property

IStatisticsChartBaseDataType Property

Type of information stored in IStatisticsChartBase.DataRow.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ChartDataType DataType { get; set; }
property ChartDataType DataType {
    ChartDataType get ();
    void set (ChartDataType value);
}

Property Value

Type: ChartDataType
See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase.FieldCountPerProperty Property

IStatisticsChartBaseFieldCountPerProperty Property

How many double values are recorded per source/property. See StatisticsDataRow.RowFields.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int FieldCountPerProperty { get; }
property int FieldCountPerProperty {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase.IsStarted Property

IStatisticsChartBaseIsStarted Property

State of simulation timer.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsStarted { get; }
property bool IsStarted {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase.LegendVisibility Property

IStatisticsChartBaseLegendVisibility Property

Visibility of chart's legend panel.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool LegendVisibility { get; set; }
property bool LegendVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase.MustUseStatisticsInterval Property

IStatisticsChartBaseMustUseStatisticsInterval Property

Indicates that one of the selected properties belong to statistics behavior, and global sampling interval must be used. This means that SamplingInterval will be automatically forced to -1.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool MustUseStatisticsInterval { get; }
property bool MustUseStatisticsInterval {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase.RecordAccumulatedValues Property

IStatisticsChartBaseRecordAccumulatedValues Property

Indicates that property values should be integrated over time.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool RecordAccumulatedValues { get; set; }
property bool RecordAccumulatedValues {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase.SamplingInterval Property

IStatisticsChartBaseSamplingInterval Property

Custom sampling interval. Currently can be defined for all properties, except for statistics behavior properties. -1 means that global sampling interval is used.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double SamplingInterval { get; set; }
property double SamplingInterval {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase.SamplingTimer Property

IStatisticsChartBaseSamplingTimer Property

Simulation timer used to update this chart.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISamplingTimer SamplingTimer { get; }
property ISamplingTimer^ SamplingTimer {
    ISamplingTimer^ get ();
}

Property Value

Type: ISamplingTimer
See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase.Series Property

IStatisticsChartBaseSeries Property

List of chart series. Note: each series can monitor multiple properties.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IStatisticsSeries> Series { get; }
property IList<IStatisticsSeries^>^ Series {
    IList<IStatisticsSeries^>^ get ();
}

Property Value

Type: IListIStatisticsSeries
See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase.TitleVisibility Property

IStatisticsChartBaseTitleVisibility Property

Visibility of chart's title.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool TitleVisibility { get; set; }
property bool TitleVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase Methods

The IStatisticsChartBase type exposes the following members.

Methods
 | Name | Description
Public method | AddSeries | Adds a blank series.
Public method | ClearData | Clears the DataRows list.
Public method | ClearSeries | Removes all series.
Public method | ConvertToDouble | Helper method for converting IProperty.Value to double.
Public method | DeleteSeries | Removes series configuration.
Public method | Dispose | Disposes a chart.
Public method | NotifyPropertyChanged | INotifyPropertyChanged interface implementation.
Public method | StartStopTimer | Enabled/disabled the simulation timer.
Public method | UpdateChart | Updates visual representation of chart.
Top
See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase.AddSeries Method

IStatisticsChartBaseAddSeries Method

Adds a blank series.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatisticsSeries AddSeries()
IStatisticsSeries^ AddSeries()

Return Value

Type: IStatisticsSeries
Series instance
See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase.ClearData Method

IStatisticsChartBaseClearData Method

Clears the DataRows list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ClearData()
void ClearData()
See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase.ClearSeries Method

IStatisticsChartBaseClearSeries Method

Removes all series.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ClearSeries()
void ClearSeries()
See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase.ConvertToDouble Method

IStatisticsChartBaseConvertToDouble Method

Helper method for converting IProperty.Value to double.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double ConvertToDouble(
    Object value
)
double ConvertToDouble(
    Object^ value
)

Parameters

value
Type: SystemObject

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.Create3D.IStatisticsChartBase.ConvertToDouble(System.Object)"]

See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase.DeleteSeries Method

IStatisticsChartBaseDeleteSeries Method

Removes series configuration.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteSeries(
    IStatisticsSeries series
)
void DeleteSeries(
    IStatisticsSeries^ series
)

Parameters

series
Type: VisualComponents.Create3DIStatisticsSeries
Series instance
See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase.Dispose Method

IStatisticsChartBaseDispose Method

Disposes a chart.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Dispose()
void Dispose()

Implements

IDisposableDispose
See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase.NotifyPropertyChanged Method

IStatisticsChartBaseNotifyPropertyChanged Method

INotifyPropertyChanged interface implementation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void NotifyPropertyChanged(
    string name
)
void NotifyPropertyChanged(
    String^ name
)

Parameters

name
Type: SystemString
See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase.StartStopTimer Method

IStatisticsChartBaseStartStopTimer Method

Enabled/disabled the simulation timer.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StartStopTimer(
    bool start
)
void StartStopTimer(
    bool start
)

Parameters

start
Type: SystemBoolean
Target state
See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase.UpdateChart Method

IStatisticsChartBaseUpdateChart Method

Updates visual representation of chart.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateChart()
void UpdateChart()
See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase Events

The IStatisticsChartBase type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | Indicates that one of the monitored components or properties was deleted.
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsChartBase.ObjectInvalidated Event

IStatisticsChartBaseObjectInvalidated Event

Indicates that one of the monitored components or properties was deleted.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler ObjectInvalidated
 event EventHandler^ ObjectInvalidated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IStatisticsChartBase Interface
VisualComponents.Create3D Namespace


IStatisticsDashboard Interface

Statistics dashboard, which consists of tabs, layouts, and charts.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IStatisticsDashboard : IScreen,
    IHaveDisplayName, IActivate, IDeactivate, IGuardClose, IClose,
    INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IStatisticsDashboard : IScreen,
    IHaveDisplayName, IActivate, IDeactivate, IGuardClose, IClose,
    INotifyPropertyChangedEx, INotifyPropertyChanged

The IStatisticsDashboard type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | SelectedTab | Currently opened tab.
Public property | StatisticsInterval | Same value as in StatisticsManager.
Public property | Tabs | All tabs in current layout.
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | CreateTab | Create new statistics Tab.
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | DeleteTab | Delete tab.
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IStatisticsDashboard Properties

The IStatisticsDashboard type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | SelectedTab | Currently opened tab.
Public property | StatisticsInterval | Same value as in StatisticsManager.
Public property | Tabs | All tabs in current layout.
Top
See Also

Reference

IStatisticsDashboard Interface
VisualComponents.Create3D Namespace


IStatisticsDashboard.SelectedTab Property

IStatisticsDashboardSelectedTab Property

Currently opened tab.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatisticsTab SelectedTab { get; set; }
property IStatisticsTab^ SelectedTab {
    IStatisticsTab^ get ();
    void set (IStatisticsTab^ value);
}

Property Value

Type: IStatisticsTab
See Also

Reference

IStatisticsDashboard Interface
VisualComponents.Create3D Namespace


IStatisticsDashboard.StatisticsInterval Property

IStatisticsDashboardStatisticsInterval Property

Same value as in StatisticsManager.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double StatisticsInterval { get; set; }
property double StatisticsInterval {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IStatisticsDashboard Interface
VisualComponents.Create3D Namespace


IStatisticsDashboard.Tabs Property

IStatisticsDashboardTabs Property

All tabs in current layout.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<IStatisticsTab> Tabs { get; }
property IReadOnlyList<IStatisticsTab^>^ Tabs {
    IReadOnlyList<IStatisticsTab^>^ get ();
}

Property Value

Type: IReadOnlyListIStatisticsTab
See Also

Reference

IStatisticsDashboard Interface
VisualComponents.Create3D Namespace


IStatisticsDashboard Methods

The IStatisticsDashboard type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | CreateTab | Create new statistics Tab.
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | DeleteTab | Delete tab.
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IStatisticsDashboard Interface
VisualComponents.Create3D Namespace


IStatisticsDashboard.CreateTab Method

IStatisticsDashboardCreateTab Method

Create new statistics Tab.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatisticsTab CreateTab(
    string name,
    bool activate
)
IStatisticsTab^ CreateTab(
    String^ name,
    bool activate
)

Parameters

name
Type: SystemString
activate
Type: SystemBoolean

Return Value

Type: IStatisticsTab

[Missing <returns> documentation for "M:VisualComponents.Create3D.IStatisticsDashboard.CreateTab(System.String,System.Boolean)"]

See Also

Reference

IStatisticsDashboard Interface
VisualComponents.Create3D Namespace


IStatisticsDashboard.DeleteTab Method

IStatisticsDashboardDeleteTab Method

Delete tab.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteTab(
    IStatisticsTab tab
)
void DeleteTab(
    IStatisticsTab^ tab
)

Parameters

tab
Type: VisualComponents.Create3DIStatisticsTab
See Also

Reference

IStatisticsDashboard Interface
VisualComponents.Create3D Namespace


IStatisticsDashboard Events

The IStatisticsDashboard type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IStatisticsDashboard Interface
VisualComponents.Create3D Namespace


IStatisticsManager Interface

Global statistics manager.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IStatisticsManager
public interface class IStatisticsManager

The IStatisticsManager type exposes the following members.

Properties
 | Name | Description
Public property | IsEnabled | Enabling this will initialize statistics manager every time simulation starts.
Public property | StatisticsInterval | Global sampling interval used for all statistics behaviours.
Top
Methods
 | Name | Description
Public method | CreateTimer(EventHandler) | Timer shared for all statistics behaviours.
Public method | CreateTimer(EventHandler, Double) | Custom interval timer, with a specified interval. Note: these timers stop working on "reset". Must be re-created always on OnSimulationStarted() event.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IStatisticsManager Properties

The IStatisticsManager type exposes the following members.

Properties
 | Name | Description
Public property | IsEnabled | Enabling this will initialize statistics manager every time simulation starts.
Public property | StatisticsInterval | Global sampling interval used for all statistics behaviours.
Top
See Also

Reference

IStatisticsManager Interface
VisualComponents.Create3D Namespace


IStatisticsManager.IsEnabled Property

IStatisticsManagerIsEnabled Property

Enabling this will initialize statistics manager every time simulation starts.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsEnabled { get; set; }
property bool IsEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IStatisticsManager Interface
VisualComponents.Create3D Namespace


IStatisticsManager.StatisticsInterval Property

IStatisticsManagerStatisticsInterval Property

Global sampling interval used for all statistics behaviours.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double StatisticsInterval { get; set; }
property double StatisticsInterval {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IStatisticsManager Interface
VisualComponents.Create3D Namespace


IStatisticsManager Methods

Methods
 | Name | Description
Public method | CreateTimer(EventHandler) | Timer shared for all statistics behaviours.
Public method | CreateTimer(EventHandler, Double) | Custom interval timer, with a specified interval. Note: these timers stop working on "reset". Must be re-created always on OnSimulationStarted() event.
Top
See Also

Reference

IStatisticsManager Interface
VisualComponents.Create3D Namespace


IStatisticsManager.CreateTimer Method

IStatisticsManagerCreateTimer Method

Overload List
 | Name | Description
Public method | CreateTimer(EventHandler) | Timer shared for all statistics behaviours.
Public method | CreateTimer(EventHandler, Double) | Custom interval timer, with a specified interval. Note: these timers stop working on "reset". Must be re-created always on OnSimulationStarted() event.
Top
See Also

Reference

IStatisticsManager Interface
VisualComponents.Create3D Namespace


IStatisticsManager.CreateTimer Method (EventHandler)

IStatisticsManagerCreateTimer Method (EventHandler)

Timer shared for all statistics behaviours.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISamplingTimer CreateTimer(
    EventHandler handler
)
ISamplingTimer^ CreateTimer(
    EventHandler^ handler
)

Parameters

handler
Type: SystemEventHandler

Return Value

Type: ISamplingTimer

[Missing <returns> documentation for "M:VisualComponents.Create3D.IStatisticsManager.CreateTimer(System.EventHandler)"]

See Also

Reference

IStatisticsManager Interface
CreateTimer Overload
VisualComponents.Create3D Namespace


IStatisticsManager.CreateTimer Method (EventHandler, Double)

IStatisticsManagerCreateTimer Method (EventHandler, Double)

Custom interval timer, with a specified interval. Note: these timers stop working on "reset". Must be re-created always on OnSimulationStarted() event.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISamplingTimer CreateTimer(
    EventHandler handler,
    double interval
)
ISamplingTimer^ CreateTimer(
    EventHandler^ handler,
    double interval
)

Parameters

handler
Type: SystemEventHandler
interval
Type: SystemDouble

Return Value

Type: ISamplingTimer

[Missing <returns> documentation for "M:VisualComponents.Create3D.IStatisticsManager.CreateTimer(System.EventHandler,System.Double)"]

See Also

Reference

IStatisticsManager Interface
CreateTimer Overload
VisualComponents.Create3D Namespace


IStatisticsManager2 Interface

Encapsulates a dashboard collection, that is stored as a layout item.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IStatisticsManager2
public interface class IStatisticsManager2

The IStatisticsManager2 type exposes the following members.

Properties
 | Name | Description
Public property | Dashboards |
Top
Methods
 | Name | Description
Public method | CreateDashboard |
Public method | DeleteDashboard |
Public method | HideDashboard |
Public method | ShowDashboard |
Top
See Also

Reference

VisualComponents.Create3D Namespace


IStatisticsManager2 Properties

The IStatisticsManager2 type exposes the following members.

Properties
 | Name | Description
Public property | Dashboards |
Top
See Also

Reference

IStatisticsManager2 Interface
VisualComponents.Create3D Namespace


IStatisticsManager2.Dashboards Property

IStatisticsManager2Dashboards Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<IStatisticsDashboard> Dashboards { get; }
property IReadOnlyList<IStatisticsDashboard^>^ Dashboards {
    IReadOnlyList<IStatisticsDashboard^>^ get ();
}

Property Value

Type: IReadOnlyListIStatisticsDashboard
See Also

Reference

IStatisticsManager2 Interface
VisualComponents.Create3D Namespace


IStatisticsManager2 Methods

The IStatisticsManager2 type exposes the following members.

Methods
 | Name | Description
Public method | CreateDashboard |
Public method | DeleteDashboard |
Public method | HideDashboard |
Public method | ShowDashboard |
Top
See Also

Reference

IStatisticsManager2 Interface
VisualComponents.Create3D Namespace


IStatisticsManager2.CreateDashboard Method

IStatisticsManager2CreateDashboard Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatisticsDashboard CreateDashboard(
    string name,
    bool activate
)
IStatisticsDashboard^ CreateDashboard(
    String^ name,
    bool activate
)

Parameters

name
Type: SystemString
activate
Type: SystemBoolean

Return Value

Type: IStatisticsDashboard

[Missing <returns> documentation for "M:VisualComponents.Create3D.IStatisticsManager2.CreateDashboard(System.String,System.Boolean)"]

See Also

Reference

IStatisticsManager2 Interface
VisualComponents.Create3D Namespace


IStatisticsManager2.DeleteDashboard Method

IStatisticsManager2DeleteDashboard Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteDashboard(
    IStatisticsDashboard dashboard
)
void DeleteDashboard(
    IStatisticsDashboard^ dashboard
)

Parameters

dashboard
Type: VisualComponents.Create3DIStatisticsDashboard
See Also

Reference

IStatisticsManager2 Interface
VisualComponents.Create3D Namespace


IStatisticsManager2.HideDashboard Method

IStatisticsManager2HideDashboard Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void HideDashboard(
    IStatisticsDashboard dashboard
)
void HideDashboard(
    IStatisticsDashboard^ dashboard
)

Parameters

dashboard
Type: VisualComponents.Create3DIStatisticsDashboard
See Also

Reference

IStatisticsManager2 Interface
VisualComponents.Create3D Namespace


IStatisticsManager2.ShowDashboard Method

IStatisticsManager2ShowDashboard Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ShowDashboard(
    IStatisticsDashboard dashboard
)
bool ShowDashboard(
    IStatisticsDashboard^ dashboard
)

Parameters

dashboard
Type: VisualComponents.Create3DIStatisticsDashboard

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IStatisticsManager2.ShowDashboard(VisualComponents.Create3D.IStatisticsDashboard)"]

See Also

Reference

IStatisticsManager2 Interface
VisualComponents.Create3D Namespace


IStatisticsSection Interface

Configuration file section for Statistics Dashboard Settings.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IStatisticsSection : ISection
public interface class IStatisticsSection : ISection

The IStatisticsSection type exposes the following members.

Properties
 | Name | Description
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Public property | StatisticsElement | Configuration file element for Statistics Dashboard Settings.
Top
Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | GetSection | Gets the section (Inherited from ISection.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IStatisticsSection Properties

The IStatisticsSection type exposes the following members.

Properties
 | Name | Description
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Public property | StatisticsElement | Configuration file element for Statistics Dashboard Settings.
Top
See Also

Reference

IStatisticsSection Interface
VisualComponents.Create3D Namespace


IStatisticsSection.StatisticsElement Property

IStatisticsSectionStatisticsElement Property

Configuration file element for Statistics Dashboard Settings.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
StatisticsConfigElement StatisticsElement { get; }
property StatisticsConfigElement^ StatisticsElement {
    StatisticsConfigElement^ get ();
}

Property Value

Type: StatisticsConfigElement
See Also

Reference

IStatisticsSection Interface
VisualComponents.Create3D Namespace


IStatisticsSection Methods

The IStatisticsSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | GetSection | Gets the section (Inherited from ISection.)
Top
See Also

Reference

IStatisticsSection Interface
VisualComponents.Create3D Namespace


IStatisticsSeries Interface

Defines graph sources, settings, and sampled values. Note: one instance can have multiple sources, so "Series" can also mean "Multiple Series".

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IStatisticsSeries : INotifyPropertyChanged
public interface class IStatisticsSeries : INotifyPropertyChanged

The IStatisticsSeries type exposes the following members.

Properties
 | Name | Description
Public property | Colors | Line colors for all sources. Note: item count must remains the same when assigning this property.
Public property | Components | Components whose properties are monitored and displayed in the chart. Note: changing this can also change Property-property.
Public property | Expression | Not implemented yet.
Public property | ParentChart | Chart that owns this series.
Public property | Property | Property whose value will be monitored and displayed in the chart. Note: when using multiple Components this must point to the property of first component. Note: changing this property can change Components-list.
Public property | SeriesName | Series title.
Public property | Sources | Helper list of sources deduced from Property and Components. This list is calculated automatically.
Public property | Thickness | Line thickness for all sources. Note: item count must remains the same when assigning this property.
Public property | Titles | Custom titles for all sources. Used for constructing a chart legend, or a pie chart.
Top
Methods
 | Name | Description
Public method | NotifyPropertyChanged | INotifyPropertyChanged interface implementation.
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IStatisticsSeries Properties

The IStatisticsSeries type exposes the following members.

Properties
 | Name | Description
Public property | Colors | Line colors for all sources. Note: item count must remains the same when assigning this property.
Public property | Components | Components whose properties are monitored and displayed in the chart. Note: changing this can also change Property-property.
Public property | Expression | Not implemented yet.
Public property | ParentChart | Chart that owns this series.
Public property | Property | Property whose value will be monitored and displayed in the chart. Note: when using multiple Components this must point to the property of first component. Note: changing this property can change Components-list.
Public property | SeriesName | Series title.
Public property | Sources | Helper list of sources deduced from Property and Components. This list is calculated automatically.
Public property | Thickness | Line thickness for all sources. Note: item count must remains the same when assigning this property.
Public property | Titles | Custom titles for all sources. Used for constructing a chart legend, or a pie chart.
Top
See Also

Reference

IStatisticsSeries Interface
VisualComponents.Create3D Namespace


IStatisticsSeries.Colors Property

IStatisticsSeriesColors Property

Line colors for all sources. Note: item count must remains the same when assigning this property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<Nullable<Color>> Colors { get; set; }
property IReadOnlyList<Nullable<Color>>^ Colors {
    IReadOnlyList<Nullable<Color>>^ get ();
    void set (IReadOnlyList<Nullable<Color>>^ value);
}

Property Value

Type: IReadOnlyListNullableColor
See Also

Reference

IStatisticsSeries Interface
VisualComponents.Create3D Namespace


IStatisticsSeries.Components Property

IStatisticsSeriesComponents Property

Components whose properties are monitored and displayed in the chart. Note: changing this can also change Property-property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<ISimComponent> Components { get; set; }
property IReadOnlyList<ISimComponent^>^ Components {
    IReadOnlyList<ISimComponent^>^ get ();
    void set (IReadOnlyList<ISimComponent^>^ value);
}

Property Value

Type: IReadOnlyListISimComponent
See Also

Reference

IStatisticsSeries Interface
VisualComponents.Create3D Namespace


IStatisticsSeries.Expression Property

IStatisticsSeriesExpression Property

Not implemented yet.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Expression { get; set; }
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IStatisticsSeries Interface
VisualComponents.Create3D Namespace


IStatisticsSeries.ParentChart Property

IStatisticsSeriesParentChart Property

Chart that owns this series.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatisticsChartBase ParentChart { get; }
property IStatisticsChartBase^ ParentChart {
    IStatisticsChartBase^ get ();
}

Property Value

Type: IStatisticsChartBase
See Also

Reference

IStatisticsSeries Interface
VisualComponents.Create3D Namespace


IStatisticsSeries.Property Property

IStatisticsSeriesProperty Property

Property whose value will be monitored and displayed in the chart. Note: when using multiple Components this must point to the property of first component. Note: changing this property can change Components-list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProperty Property { get; set; }
property IProperty^ Property {
    IProperty^ get ();
    void set (IProperty^ value);
}

Property Value

Type: IProperty
See Also

Reference

IStatisticsSeries Interface
VisualComponents.Create3D Namespace


IStatisticsSeries.SeriesName Property

IStatisticsSeriesSeriesName Property

Series title.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string SeriesName { get; set; }
property String^ SeriesName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IStatisticsSeries Interface
VisualComponents.Create3D Namespace


IStatisticsSeries.Sources Property

IStatisticsSeriesSources Property

Helper list of sources deduced from Property and Components. This list is calculated automatically.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<IStatisticsSource> Sources { get; }
property IReadOnlyList<IStatisticsSource^>^ Sources {
    IReadOnlyList<IStatisticsSource^>^ get ();
}

Property Value

Type: IReadOnlyListIStatisticsSource
See Also

Reference

IStatisticsSeries Interface
VisualComponents.Create3D Namespace


IStatisticsSeries.Thickness Property

IStatisticsSeriesThickness Property

Line thickness for all sources. Note: item count must remains the same when assigning this property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<Nullable<double>> Thickness { get; set; }
property IReadOnlyList<Nullable<double>>^ Thickness {
    IReadOnlyList<Nullable<double>>^ get ();
    void set (IReadOnlyList<Nullable<double>>^ value);
}

Property Value

Type: IReadOnlyListNullableDouble
See Also

Reference

IStatisticsSeries Interface
VisualComponents.Create3D Namespace


IStatisticsSeries.Titles Property

IStatisticsSeriesTitles Property

Custom titles for all sources. Used for constructing a chart legend, or a pie chart.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<string> Titles { get; set; }
property IReadOnlyList<String^>^ Titles {
    IReadOnlyList<String^>^ get ();
    void set (IReadOnlyList<String^>^ value);
}

Property Value

Type: IReadOnlyListString
See Also

Reference

IStatisticsSeries Interface
VisualComponents.Create3D Namespace


IStatisticsSeries Methods

The IStatisticsSeries type exposes the following members.

Methods
 | Name | Description
Public method | NotifyPropertyChanged | INotifyPropertyChanged interface implementation.
Top
See Also

Reference

IStatisticsSeries Interface
VisualComponents.Create3D Namespace


IStatisticsSeries.NotifyPropertyChanged Method

IStatisticsSeriesNotifyPropertyChanged Method

INotifyPropertyChanged interface implementation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void NotifyPropertyChanged(
    string name
)
void NotifyPropertyChanged(
    String^ name
)

Parameters

name
Type: SystemString
See Also

Reference

IStatisticsSeries Interface
VisualComponents.Create3D Namespace


IStatisticsSeries Events

The IStatisticsSeries type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IStatisticsSeries Interface
VisualComponents.Create3D Namespace


IStatisticsSource Interface

Helper interface, used only for reading final properties and components, which are deduced from IStatisticsSeries.Property and IStatisticsSeries.Components. These values are calculated automatically, and cannot be modified.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IStatisticsSource
public interface class IStatisticsSource

The IStatisticsSource type exposes the following members.

Properties
 | Name | Description
Public property | Color | Line color.
Public property | Component | Owner component.
Public property | Expression | Either Property or Expression is defined.
Public property | ParentSeries | Owner.
Public property | Property | Either Property or Expression is defined.
Public property | Thickness | Line color. By default equals to IStatisticsSeries.Thickness.
Public property | Title | Title string, typically used in chart legend, and the pie chart.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IStatisticsSource Properties

The IStatisticsSource type exposes the following members.

Properties
 | Name | Description
Public property | Color | Line color.
Public property | Component | Owner component.
Public property | Expression | Either Property or Expression is defined.
Public property | ParentSeries | Owner.
Public property | Property | Either Property or Expression is defined.
Public property | Thickness | Line color. By default equals to IStatisticsSeries.Thickness.
Public property | Title | Title string, typically used in chart legend, and the pie chart.
Top
See Also

Reference

IStatisticsSource Interface
VisualComponents.Create3D Namespace


IStatisticsSource.Color Property

IStatisticsSourceColor Property

Line color.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Nullable<Color> Color { get; }
property Nullable<Color> Color {
    Nullable<Color> get ();
}

Property Value

Type: NullableColor
See Also

Reference

IStatisticsSource Interface
VisualComponents.Create3D Namespace


IStatisticsSource.Component Property

IStatisticsSourceComponent Property

Owner component.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent Component { get; }
property ISimComponent^ Component {
    ISimComponent^ get ();
}

Property Value

Type: ISimComponent
See Also

Reference

IStatisticsSource Interface
VisualComponents.Create3D Namespace


IStatisticsSource.Expression Property

IStatisticsSourceExpression Property

Either Property or Expression is defined.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Expression { get; }
property String^ Expression {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IStatisticsSource Interface
VisualComponents.Create3D Namespace


IStatisticsSource.ParentSeries Property

IStatisticsSourceParentSeries Property

Owner.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatisticsSeries ParentSeries { get; set; }
property IStatisticsSeries^ ParentSeries {
    IStatisticsSeries^ get ();
    void set (IStatisticsSeries^ value);
}

Property Value

Type: IStatisticsSeries
See Also

Reference

IStatisticsSource Interface
VisualComponents.Create3D Namespace


IStatisticsSource.Property Property

IStatisticsSourceProperty Property

Either Property or Expression is defined.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProperty Property { get; }
property IProperty^ Property {
    IProperty^ get ();
}

Property Value

Type: IProperty
See Also

Reference

IStatisticsSource Interface
VisualComponents.Create3D Namespace


IStatisticsSource.Thickness Property

IStatisticsSourceThickness Property

Line color. By default equals to IStatisticsSeries.Thickness.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Nullable<double> Thickness { get; }
property Nullable<double> Thickness {
    Nullable<double> get ();
}

Property Value

Type: NullableDouble
See Also

Reference

IStatisticsSource Interface
VisualComponents.Create3D Namespace


IStatisticsSource.Title Property

IStatisticsSourceTitle Property

Title string, typically used in chart legend, and the pie chart.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Title { get; }
property String^ Title {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IStatisticsSource Interface
VisualComponents.Create3D Namespace


IStatisticsState Interface

States for which statistics are collected.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IStatisticsState
public interface class IStatisticsState

The IStatisticsState type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the position in the array of states.
Public property | Name | Gets or sets the name of the state.
Public property | StateMapping | Gets or sets the state mapping.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IStatisticsState Properties

The IStatisticsState type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the position in the array of states.
Public property | Name | Gets or sets the name of the state.
Public property | StateMapping | Gets or sets the state mapping.
Top
See Also

Reference

IStatisticsState Interface
VisualComponents.Create3D Namespace


IStatisticsState.Id Property

IStatisticsStateId Property

Gets the position in the array of states.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int Id { get; }
property int Id {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IStatisticsState Interface
VisualComponents.Create3D Namespace


IStatisticsState.Name Property

IStatisticsStateName Property

Gets or sets the name of the state.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Name { get; set; }
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IStatisticsState Interface
VisualComponents.Create3D Namespace


IStatisticsState.StateMapping Property

IStatisticsStateStateMapping Property

Gets or sets the state mapping.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
State StateMapping { get; set; }
property State StateMapping {
    State get ();
    void set (State value);
}

Property Value

Type: State
See Also

Reference

IStatisticsState Interface
VisualComponents.Create3D Namespace


IStatisticsTab Interface

Defines a single tab in statistics dashboard.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IStatisticsTab
public interface class IStatisticsTab

The IStatisticsTab type exposes the following members.

Properties
 | Name | Description
Public property | Charts | Charts defined in current tab.
Public property | Layouts | Available layouts.
Public property | Name | Tab's title.
Public property | SelectedChart | Focused chart or layout position.
Public property | SelectedLayout | Current layout.
Top
Methods
 | Name | Description
Public method | ClearLayout | Removes all charts. Note: all charts are replaced with placeholder tiles.
Public method | CreateChart | Creates a chart at a given position.
Public method | CreateLayout | Creates an instance of SelectedLayout
Public method | DeleteChart | Removes a chart from the dashboard's tab. Note: chart is replaced with a placeholder tile.
Public method | SelectChart | Focuses a chart or position.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IStatisticsTab Properties

The IStatisticsTab type exposes the following members.

Properties
 | Name | Description
Public property | Charts | Charts defined in current tab.
Public property | Layouts | Available layouts.
Public property | Name | Tab's title.
Public property | SelectedChart | Focused chart or layout position.
Public property | SelectedLayout | Current layout.
Top
See Also

Reference

IStatisticsTab Interface
VisualComponents.Create3D Namespace


IStatisticsTab.Charts Property

IStatisticsTabCharts Property

Charts defined in current tab.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<IStatisticsChart> Charts { get; }
property IEnumerable<IStatisticsChart^>^ Charts {
    IEnumerable<IStatisticsChart^>^ get ();
}

Property Value

Type: IEnumerableIStatisticsChart
See Also

Reference

IStatisticsTab Interface
VisualComponents.Create3D Namespace


IStatisticsTab.Layouts Property

IStatisticsTabLayouts Property

Available layouts.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<ChartLayout> Layouts { get; set; }
property IList<ChartLayout^>^ Layouts {
    IList<ChartLayout^>^ get ();
    void set (IList<ChartLayout^>^ value);
}

Property Value

Type: IListChartLayout
See Also

Reference

IStatisticsTab Interface
VisualComponents.Create3D Namespace


IStatisticsTab.Name Property

IStatisticsTabName Property

Tab's title.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Name { get; set; }
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IStatisticsTab Interface
VisualComponents.Create3D Namespace


IStatisticsTab.SelectedChart Property

IStatisticsTabSelectedChart Property

Focused chart or layout position.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatisticsChart SelectedChart { get; set; }
property IStatisticsChart^ SelectedChart {
    IStatisticsChart^ get ();
    void set (IStatisticsChart^ value);
}

Property Value

Type: IStatisticsChart
See Also

Reference

IStatisticsTab Interface
VisualComponents.Create3D Namespace


IStatisticsTab.SelectedLayout Property

IStatisticsTabSelectedLayout Property

Current layout.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ChartLayout SelectedLayout { get; set; }
property ChartLayout^ SelectedLayout {
    ChartLayout^ get ();
    void set (ChartLayout^ value);
}

Property Value

Type: ChartLayout
See Also

Reference

IStatisticsTab Interface
VisualComponents.Create3D Namespace


IStatisticsTab Methods

The IStatisticsTab type exposes the following members.

Methods
 | Name | Description
Public method | ClearLayout | Removes all charts. Note: all charts are replaced with placeholder tiles.
Public method | CreateChart | Creates a chart at a given position.
Public method | CreateLayout | Creates an instance of SelectedLayout
Public method | DeleteChart | Removes a chart from the dashboard's tab. Note: chart is replaced with a placeholder tile.
Public method | SelectChart | Focuses a chart or position.
Top
See Also

Reference

IStatisticsTab Interface
VisualComponents.Create3D Namespace


IStatisticsTab.ClearLayout Method

IStatisticsTabClearLayout Method

Removes all charts. Note: all charts are replaced with placeholder tiles.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ClearLayout()
void ClearLayout()
See Also

Reference

IStatisticsTab Interface
VisualComponents.Create3D Namespace


IStatisticsTab.CreateChart Method

IStatisticsTabCreateChart Method

Creates a chart at a given position.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void CreateChart(
    IStatisticsChart item,
    ChartType type,
    bool activate
)
void CreateChart(
    IStatisticsChart^ item,
    ChartType type,
    bool activate
)

Parameters

item
Type: VisualComponents.Create3DIStatisticsChart
Position
type
Type: VisualComponents.Create3DChartType
Chart type
activate
Type: SystemBoolean
Indicates that chart should be selected immediately
See Also

Reference

IStatisticsTab Interface
VisualComponents.Create3D Namespace


IStatisticsTab.CreateLayout Method

IStatisticsTabCreateLayout Method

Creates an instance of SelectedLayout

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void CreateLayout()
void CreateLayout()
See Also

Reference

IStatisticsTab Interface
VisualComponents.Create3D Namespace


IStatisticsTab.DeleteChart Method

IStatisticsTabDeleteChart Method

Removes a chart from the dashboard's tab. Note: chart is replaced with a placeholder tile.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteChart(
    IStatisticsChart item
)
void DeleteChart(
    IStatisticsChart^ item
)

Parameters

item
Type: VisualComponents.Create3DIStatisticsChart
See Also

Reference

IStatisticsTab Interface
VisualComponents.Create3D Namespace


IStatisticsTab.SelectChart Method

IStatisticsTabSelectChart Method

Focuses a chart or position.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SelectChart(
    IStatisticsChart item
)
void SelectChart(
    IStatisticsChart^ item
)

Parameters

item
Type: VisualComponents.Create3DIStatisticsChart
Chart to focus
See Also

Reference

IStatisticsTab Interface
VisualComponents.Create3D Namespace


IStringProperty Interface

Interface for string properties. Provides more information about this type of property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IStringProperty : IProperty<string>,
    IProperty, INotifyPropertyChanged, IDisposable, INamed
public interface class IStringProperty : IProperty<String^>,
    IProperty, INotifyPropertyChanged, IDisposable, INamed

The IStringProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Strongly typed allowed maximum value. (Inherited from IPropertyT.)
Public property | AllowedMinimum | Strongly typed allowed minimum value. (Inherited from IPropertyT.)
Public property | AllowedValues | Strongly typed container of allowed values. (Inherited from IPropertyT.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsMultiline | Specifies if string property offers multiline capabilities.
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Strongly typed property value. (Inherited from IPropertyT.)
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IStringProperty Properties

The IStringProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Strongly typed allowed maximum value. (Inherited from IPropertyT.)
Public property | AllowedMinimum | Strongly typed allowed minimum value. (Inherited from IPropertyT.)
Public property | AllowedValues | Strongly typed container of allowed values. (Inherited from IPropertyT.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsMultiline | Specifies if string property offers multiline capabilities.
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Strongly typed property value. (Inherited from IPropertyT.)
Top
See Also

Reference

IStringProperty Interface
VisualComponents.Create3D Namespace


IStringProperty.IsMultiline Property

IStringPropertyIsMultiline Property

Specifies if string property offers multiline capabilities.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsMultiline { get; set; }
property bool IsMultiline {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IStringProperty Interface
VisualComponents.Create3D Namespace


IStringProperty Methods

The IStringProperty type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

IStringProperty Interface
VisualComponents.Create3D Namespace


IStringProperty Events

The IStringProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IStringProperty Interface
VisualComponents.Create3D Namespace


IStringPropertyCreator Interface

Property creation behavior used to create and modify string property values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IStringPropertyCreator : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IStringPropertyCreator : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IStringPropertyCreator type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace
VisualComponents.Create3DIIntegerPropertyCreator
VisualComponents.Create3DISimDoubleVariableCreator
VisualComponents.Create3DIBooleanPropertyCreator


IStringPropertyCreator Properties

The IStringPropertyCreator type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IStringPropertyCreator Interface
VisualComponents.Create3D Namespace


IStringPropertyCreator Methods

The IStringPropertyCreator type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IStringPropertyCreator Interface
VisualComponents.Create3D Namespace


IStringPropertyCreator Events

The IStringPropertyCreator type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IStringPropertyCreator Interface
VisualComponents.Create3D Namespace


IStringSignal Interface

Simulation signal behaviour.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IStringSignal : ISignal,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed
public interface class IStringSignal : ISignal,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed

The IStringSignal type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsApplication | Defines if this ISignal instance has been created by the application for its internal use. (Inherited from ISignal.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Public property | Value | Gets or sets the value of this ISignal instance. (Inherited from ISignal.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanConnectTo | Defines if this ISignal instance can be connected to the given signal. (Inherited from ISignal.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect | Connects the given ISignal instance to the given signal. (Inherited from ISignal.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects this ISignal instance from the given signal. (Inherited from ISignal.)
Public method | DisconnectAll | Disconnects all ISignal instances connected to this signal. (Inherited from ISignal.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | SignalTrigger | Event that is raised when the value of this ISignal instance is changing. (Inherited from ISignal.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IStringSignal Properties

The IStringSignal type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsApplication | Defines if this ISignal instance has been created by the application for its internal use. (Inherited from ISignal.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Public property | Value | Gets or sets the value of this ISignal instance. (Inherited from ISignal.)
Top
See Also

Reference

IStringSignal Interface
VisualComponents.Create3D Namespace


IStringSignal Methods

The IStringSignal type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanConnectTo | Defines if this ISignal instance can be connected to the given signal. (Inherited from ISignal.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect | Connects the given ISignal instance to the given signal. (Inherited from ISignal.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects this ISignal instance from the given signal. (Inherited from ISignal.)
Public method | DisconnectAll | Disconnects all ISignal instances connected to this signal. (Inherited from ISignal.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IStringSignal Interface
VisualComponents.Create3D Namespace


IStringSignal Events

The IStringSignal type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | SignalTrigger | Event that is raised when the value of this ISignal instance is changing. (Inherited from ISignal.)
Top
See Also

Reference

IStringSignal Interface
VisualComponents.Create3D Namespace


IStringSignalMap Interface

String signal map behavior.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IStringSignalMap : ISignalMap,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed
public interface class IStringSignalMap : ISignalMap,
    IBehavior, IPropertyContainer, IBatchModeObject, IVisitable, IWrapper,
    IDisposable, INamed

The IStringSignalMap type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConnectedExternalPorts | Returns all the connected external ports. The return value is a collection of tuples where the first item is the internal port number number and the second item is a port number in connected external map. (Inherited from ISignalMap.)
Public property | ConnectedExternalSignals | Returns all the connected signals in external components. The return value is a collection of tuples where the first item is the internal port number number and the second item is an external signal connected to the port. (Inherited from ISignalMap.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | MapCount | Gets the number of ports connected to ISignal instances. This matches SignalCount. (Inherited from ISignalMap.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | PortCount | Gets the total number of ports in this signal map. (Inherited from ISignalMap.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SignalCount | Gets the number of ISignal instances behind this signal map. (Inherited from ISignalMap.)
Public property | StartIndex | Gets the ports starting index. (Inherited from ISignalMap.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect(Int32, ISignal) | Connects the signal behind the given port to the given ISignal instance. (Inherited from ISignalMap.)
Public method | Connect(Int32, ISignalMap, Int32) | Connects the ISignal instance behind the given port to the signal behind the port behind the given map. (Inherited from ISignalMap.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | CreateSignal | Creates a ISignal instance at the given port. (Inherited from ISignalMap.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteSignalConnection(Int32) | Deletes all ISignal instances connected to the signal at the given port. Also deletes disconnected application signals. (Inherited from ISignalMap.)
Public method | DeleteSignalConnection(Int32, Boolean) | Deletes all ISignal instances connected to the signal at the given port. (Inherited from ISignalMap.)
Public method | DeleteSignalConnection(Int32, Boolean, ISignal) | Disconnects the ISignal instance at the given port from the given signal. The signal will maintain its other connections (if any). (Inherited from ISignalMap.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects the ISignal instance behind the given port. (Inherited from ISignalMap.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | FindSignalIndexesLocation | Gets the map indexes associated to the given ISignal instance. (Inherited from ISignalMap.)
Public method | FindSignalIndexLocation | Obsolete. This method is obsolete. Use FindSignalIndexesLocation(ISignal) instead. (Inherited from ISignalMap.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetPort | Returns the port number at the given map index. Works in opposite way than GetPortIndex(Int32). (Inherited from ISignalMap.)
Public method | GetPortIndex | Returns the map index of the port defined by port number. Works in opposite way than GetPort(Int32). (Inherited from ISignalMap.)
Public method | GetPortName | Returns the name of the port at the given map index. (Inherited from ISignalMap.)
Public method | GetPortValue | Reads the value from a port defined by the map index if there is a signal in that port. (Inherited from ISignalMap.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetSignal | Gets a ISignal instance behind the map at the given map index. (Inherited from ISignalMap.)
Public method | MapGetPortSignal | Gets the ISignal instance behind the given port number. (Inherited from ISignalMap.)
Public method | SetPortName | Sets a port name given map index Remarks There should be a signal in this port in order to associate a name (Inherited from ISignalMap.)
Public method | SetPortValue | Sends a signal to a port defined by map index. (Inherited from ISignalMap.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetSignal | Associates a component signal into the given port (Inherited from ISignalMap.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | SignalValueChanged | Triggered when the value of the signal associated to the port changes. (Inherited from ISignalMap.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IStringSignalMap Properties

The IStringSignalMap type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConnectedExternalPorts | Returns all the connected external ports. The return value is a collection of tuples where the first item is the internal port number number and the second item is a port number in connected external map. (Inherited from ISignalMap.)
Public property | ConnectedExternalSignals | Returns all the connected signals in external components. The return value is a collection of tuples where the first item is the internal port number number and the second item is an external signal connected to the port. (Inherited from ISignalMap.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | MapCount | Gets the number of ports connected to ISignal instances. This matches SignalCount. (Inherited from ISignalMap.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | PortCount | Gets the total number of ports in this signal map. (Inherited from ISignalMap.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SignalCount | Gets the number of ISignal instances behind this signal map. (Inherited from ISignalMap.)
Public property | StartIndex | Gets the ports starting index. (Inherited from ISignalMap.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IStringSignalMap Interface
VisualComponents.Create3D Namespace


IStringSignalMap Methods

The IStringSignalMap type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | Connect(Int32, ISignal) | Connects the signal behind the given port to the given ISignal instance. (Inherited from ISignalMap.)
Public method | Connect(Int32, ISignalMap, Int32) | Connects the ISignal instance behind the given port to the signal behind the port behind the given map. (Inherited from ISignalMap.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | CreateSignal | Creates a ISignal instance at the given port. (Inherited from ISignalMap.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteSignalConnection(Int32) | Deletes all ISignal instances connected to the signal at the given port. Also deletes disconnected application signals. (Inherited from ISignalMap.)
Public method | DeleteSignalConnection(Int32, Boolean) | Deletes all ISignal instances connected to the signal at the given port. (Inherited from ISignalMap.)
Public method | DeleteSignalConnection(Int32, Boolean, ISignal) | Disconnects the ISignal instance at the given port from the given signal. The signal will maintain its other connections (if any). (Inherited from ISignalMap.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Disconnect | Disconnects the ISignal instance behind the given port. (Inherited from ISignalMap.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | FindSignalIndexesLocation | Gets the map indexes associated to the given ISignal instance. (Inherited from ISignalMap.)
Public method | FindSignalIndexLocation | Obsolete. This method is obsolete. Use FindSignalIndexesLocation(ISignal) instead. (Inherited from ISignalMap.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetPort | Returns the port number at the given map index. Works in opposite way than GetPortIndex(Int32). (Inherited from ISignalMap.)
Public method | GetPortIndex | Returns the map index of the port defined by port number. Works in opposite way than GetPort(Int32). (Inherited from ISignalMap.)
Public method | GetPortName | Returns the name of the port at the given map index. (Inherited from ISignalMap.)
Public method | GetPortValue | Reads the value from a port defined by the map index if there is a signal in that port. (Inherited from ISignalMap.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetSignal | Gets a ISignal instance behind the map at the given map index. (Inherited from ISignalMap.)
Public method | MapGetPortSignal | Gets the ISignal instance behind the given port number. (Inherited from ISignalMap.)
Public method | SetPortName | Sets a port name given map index Remarks There should be a signal in this port in order to associate a name (Inherited from ISignalMap.)
Public method | SetPortValue | Sends a signal to a port defined by map index. (Inherited from ISignalMap.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetSignal | Associates a component signal into the given port (Inherited from ISignalMap.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IStringSignalMap Interface
VisualComponents.Create3D Namespace


IStringSignalMap Events

The IStringSignalMap type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | SignalValueChanged | Triggered when the value of the signal associated to the port changes. (Inherited from ISignalMap.)
Top
See Also

Reference

IStringSignalMap Interface
VisualComponents.Create3D Namespace


ISweptVolume Interface

Swept volume layout item interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISweptVolume : ILayoutItem,
    IWrapper, IDisposable, INamed, IPropertyContainer, IBatchModeObject
public interface class ISweptVolume : ILayoutItem,
    IWrapper, IDisposable, INamed, IPropertyContainer, IBatchModeObject

The ISweptVolume type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | DecompositionDecimationTarget | If the Structure property is set equal to Decomposition, a decimation target can be set to expedite/speed up the process. Decimation target refers to the number of triangle sets remaining after the decimation process. This process only applies to nodes with fewer triangle sets than the decimation target. Set to 0 for no effect.
Public property | DecompositionQuality | If the Structure property is set equal to Decomposition, the quality of that decomposition can be set from a range of 0 to 100.
Public property | IsPersistent | Defines if the ILayoutItem is stored with the layout. (Inherited from ILayoutItem.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Material | Material of the created swept volume. If set to null, the swept volume will try to get the material from the swept geometry
Public property | Method | Indicates the method to be used when doing the swept volume.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeList | Node list.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Representation | Indicates how the list node will be represented when doing the swept volume.
Public property | TargetNode | Defines the node where the geometry generated by the swept volume is stored. The target node position should remain static during the simulation.
Top
Methods
 | Name | Description
Public method | Begin | Start point of the swept volume process. The Structure is initiated during this call. The center of each node's boundary is used.
Public method | Begin(Vector3) | Start point of the swept volume process. The Structure is initiated during this call.
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Clears the geometry generated by the swept volume, which can be done during a simulation.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | End | Finishes the swept volume. Capping of the swept volume can be done at this stage if needed.
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Next | Iterative process that creates the visual swept volume based on positions. the center of each node's boundary is used.
Public method | Next(Vector3) | Iterative process that creates the visual swept volume based on positions.
Public method | SetNodeList | Set the node list.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | Store | Stores geometry generated by swept volume in TargetNode after the end of a swept volume process. If no geometry is generated during a swept volume process, no feature is created and the method returns null. You should call this method after executing the end() method as well as before executing the clear() method.
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISweptVolume Properties

The ISweptVolume type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | DecompositionDecimationTarget | If the Structure property is set equal to Decomposition, a decimation target can be set to expedite/speed up the process. Decimation target refers to the number of triangle sets remaining after the decimation process. This process only applies to nodes with fewer triangle sets than the decimation target. Set to 0 for no effect.
Public property | DecompositionQuality | If the Structure property is set equal to Decomposition, the quality of that decomposition can be set from a range of 0 to 100.
Public property | IsPersistent | Defines if the ILayoutItem is stored with the layout. (Inherited from ILayoutItem.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Material | Material of the created swept volume. If set to null, the swept volume will try to get the material from the swept geometry
Public property | Method | Indicates the method to be used when doing the swept volume.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeList | Node list.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Representation | Indicates how the list node will be represented when doing the swept volume.
Public property | TargetNode | Defines the node where the geometry generated by the swept volume is stored. The target node position should remain static during the simulation.
Top
See Also

Reference

ISweptVolume Interface
VisualComponents.Create3D Namespace


ISweptVolume.DecompositionDecimationTarget Property

ISweptVolumeDecompositionDecimationTarget Property

If the Structure property is set equal to Decomposition, a decimation target can be set to expedite/speed up the process. Decimation target refers to the number of triangle sets remaining after the decimation process. This process only applies to nodes with fewer triangle sets than the decimation target. Set to 0 for no effect.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double DecompositionDecimationTarget { get; set; }
property double DecompositionDecimationTarget {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ISweptVolume Interface
VisualComponents.Create3D Namespace


ISweptVolume.DecompositionQuality Property

ISweptVolumeDecompositionQuality Property

If the Structure property is set equal to Decomposition, the quality of that decomposition can be set from a range of 0 to 100.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double DecompositionQuality { get; set; }
property double DecompositionQuality {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ISweptVolume Interface
VisualComponents.Create3D Namespace


ISweptVolume.Material Property

ISweptVolumeMaterial Property

Material of the created swept volume. If set to null, the swept volume will try to get the material from the swept geometry

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMaterial Material { get; set; }
property IMaterial^ Material {
    IMaterial^ get ();
    void set (IMaterial^ value);
}

Property Value

Type: IMaterial
See Also

Reference

ISweptVolume Interface
VisualComponents.Create3D Namespace


ISweptVolume.Method Property

ISweptVolumeMethod Property

Indicates the method to be used when doing the swept volume.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
SweptVolumeMethod Method { get; set; }
property SweptVolumeMethod Method {
    SweptVolumeMethod get ();
    void set (SweptVolumeMethod value);
}

Property Value

Type: SweptVolumeMethod
See Also

Reference

ISweptVolume Interface
VisualComponents.Create3D Namespace


ISweptVolume.NodeList Property

ISweptVolumeNodeList Property

Node list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<NodeListEntry> NodeList { get; }
property ReadOnlyCollection<NodeListEntry^>^ NodeList {
    ReadOnlyCollection<NodeListEntry^>^ get ();
}

Property Value

Type: ReadOnlyCollectionNodeListEntry
See Also

Reference

ISweptVolume Interface
VisualComponents.Create3D Namespace


ISweptVolume.Representation Property

ISweptVolumeRepresentation Property

Indicates how the list node will be represented when doing the swept volume.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
SweptVolumeRepresentation Representation { get; set; }
property SweptVolumeRepresentation Representation {
    SweptVolumeRepresentation get ();
    void set (SweptVolumeRepresentation value);
}

Property Value

Type: SweptVolumeRepresentation
See Also

Reference

ISweptVolume Interface
VisualComponents.Create3D Namespace


ISweptVolume.TargetNode Property

ISweptVolumeTargetNode Property

Defines the node where the geometry generated by the swept volume is stored. The target node position should remain static during the simulation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode TargetNode { get; set; }
property ISimNode^ TargetNode {
    ISimNode^ get ();
    void set (ISimNode^ value);
}

Property Value

Type: ISimNode
See Also

Reference

ISweptVolume Interface
VisualComponents.Create3D Namespace


ISweptVolume Methods

The ISweptVolume type exposes the following members.

Methods
 | Name | Description
Public method | Begin | Start point of the swept volume process. The Structure is initiated during this call. The center of each node's boundary is used.
Public method | Begin(Vector3) | Start point of the swept volume process. The Structure is initiated during this call.
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Clears the geometry generated by the swept volume, which can be done during a simulation.
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | End | Finishes the swept volume. Capping of the swept volume can be done at this stage if needed.
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Next | Iterative process that creates the visual swept volume based on positions. the center of each node's boundary is used.
Public method | Next(Vector3) | Iterative process that creates the visual swept volume based on positions.
Public method | SetNodeList | Set the node list.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | Store | Stores geometry generated by swept volume in TargetNode after the end of a swept volume process. If no geometry is generated during a swept volume process, no feature is created and the method returns null. You should call this method after executing the end() method as well as before executing the clear() method.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISweptVolume Interface
VisualComponents.Create3D Namespace


ISweptVolume.Begin Method

ISweptVolumeBegin Method

Overload List
 | Name | Description
Public method | Begin | Start point of the swept volume process. The Structure is initiated during this call. The center of each node's boundary is used.
Public method | Begin(Vector3) | Start point of the swept volume process. The Structure is initiated during this call.
Top
See Also

Reference

ISweptVolume Interface
VisualComponents.Create3D Namespace


ISweptVolume.Begin Method

ISweptVolumeBegin Method

Start point of the swept volume process. The Structure is initiated during this call. The center of each node's boundary is used.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Begin()
void Begin()
See Also

Reference

ISweptVolume Interface
Begin Overload
VisualComponents.Create3D Namespace


ISweptVolume.Begin Method (Vector3)

ISweptVolumeBegin Method (Vector3)

Start point of the swept volume process. The Structure is initiated during this call.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Begin(
    Vector3 position
)
void Begin(
    Vector3 position
)

Parameters

position
Type: VisualComponents.Create3DVector3
See Also

Reference

ISweptVolume Interface
Begin Overload
VisualComponents.Create3D Namespace


ISweptVolume.Clear Method

ISweptVolumeClear Method

Clears the geometry generated by the swept volume, which can be done during a simulation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Clear()
void Clear()
See Also

Reference

ISweptVolume Interface
VisualComponents.Create3D Namespace


ISweptVolume.End Method

ISweptVolumeEnd Method

Finishes the swept volume. Capping of the swept volume can be done at this stage if needed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void End()
void End()
See Also

Reference

ISweptVolume Interface
VisualComponents.Create3D Namespace


ISweptVolume.Next Method

ISweptVolumeNext Method

Overload List
 | Name | Description
Public method | Next | Iterative process that creates the visual swept volume based on positions. the center of each node's boundary is used.
Public method | Next(Vector3) | Iterative process that creates the visual swept volume based on positions.
Top
See Also

Reference

ISweptVolume Interface
VisualComponents.Create3D Namespace


ISweptVolume.Next Method

ISweptVolumeNext Method

Iterative process that creates the visual swept volume based on positions. the center of each node's boundary is used.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Next()
void Next()
See Also

Reference

ISweptVolume Interface
Next Overload
VisualComponents.Create3D Namespace


ISweptVolume.Next Method (Vector3)

ISweptVolumeNext Method (Vector3)

Iterative process that creates the visual swept volume based on positions.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Next(
    Vector3 position
)
void Next(
    Vector3 position
)

Parameters

position
Type: VisualComponents.Create3DVector3
If null, the center of each node's boundary is used.
See Also

Reference

ISweptVolume Interface
Next Overload
VisualComponents.Create3D Namespace


ISweptVolume.SetNodeList Method

ISweptVolumeSetNodeList Method

Set the node list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetNodeList(
    IEnumerable<NodeListEntry> nodeList
)
void SetNodeList(
    IEnumerable<NodeListEntry^>^ nodeList
)

Parameters

nodeList
Type: System.Collections.GenericIEnumerableNodeListEntry
Entries to
Remarks

This clears the current node list and populates it with the given node entries.

See Also

Reference

ISweptVolume Interface
VisualComponents.Create3D Namespace


ISweptVolume.Store Method

ISweptVolumeStore Method

Stores geometry generated by swept volume in TargetNode after the end of a swept volume process. If no geometry is generated during a swept volume process, no feature is created and the method returns null. You should call this method after executing the end() method as well as before executing the clear() method.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFeature Store()
IFeature^ Store()

Return Value

Type: IFeature
feature that contains the stored swept volume.
See Also

Reference

ISweptVolume Interface
VisualComponents.Create3D Namespace


ISweptVolume Events

The ISweptVolume type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ISweptVolume Interface
VisualComponents.Create3D Namespace


ISwitchCaseStatement Interface

A switch statement that executes the first ICaseScope who's ConditionExpression matches ConditionExpression.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISwitchCaseStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class ISwitchCaseStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The ISwitchCaseStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | Cases | Get all cases.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConditionExpression | The condition to evaluate when the statement is executed.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
Methods
 | Name | Description
Public method | AddCase | Adds a new case.
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteCase | Deletes an existing case. This will invalidate the ICaseScope wrapper.
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetCase | Get an existing case.
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InsertCase(Int32) | Inserts a new case to the given index. If the given index is less than zero or greater than the current case count, the case will be inserted at the end of the list.
Public method | InsertCase(Int32, ICaseScope) | Inserts an existing case to the given index and takes ownership of the ICaseScope. If the given index is less than zero or greater than the current case count, the case will be inserted at the end of the list.
Public method | MoveCase | Moves the given case to the new position inside this instance of ISwitchCaseStatement. If the given index is less than zero or greater than the current case count, the case will be moved to the end of the list.
Public method | ReleaseCase | Removes an existing case from this IStatement. The caller claims ownership of the ICaseScope.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | CaseAdded | Occurs when a case has been added or inserted (in)to this switch statement.
Public event | CaseMoved | Occurs when a case has been added or inserted (in)to this switch statement.
Public event | CaseRemoved | Occurs when a case has been removed from this switch statement.
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ISwitchCaseStatement Properties

The ISwitchCaseStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | Cases | Get all cases.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConditionExpression | The condition to evaluate when the statement is executed.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
See Also

Reference

ISwitchCaseStatement Interface
VisualComponents.Create3D Namespace


ISwitchCaseStatement.Cases Property

ISwitchCaseStatementCases Property

Get all cases.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<ICaseScope> Cases { get; }
property IReadOnlyList<ICaseScope^>^ Cases {
    IReadOnlyList<ICaseScope^>^ get ();
}

Property Value

Type: IReadOnlyListICaseScope
See Also

Reference

ISwitchCaseStatement Interface
VisualComponents.Create3D Namespace


ISwitchCaseStatement.ConditionExpression Property

ISwitchCaseStatementConditionExpression Property

The condition to evaluate when the statement is executed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ConditionExpression { get; set; }
property String^ ConditionExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
This expression has access to UPM variables stored in IProcessRoutine.
See Also

Reference

ISwitchCaseStatement Interface
VisualComponents.Create3D Namespace


ISwitchCaseStatement Methods

The ISwitchCaseStatement type exposes the following members.

Methods
 | Name | Description
Public method | AddCase | Adds a new case.
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteCase | Deletes an existing case. This will invalidate the ICaseScope wrapper.
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetCase | Get an existing case.
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InsertCase(Int32) | Inserts a new case to the given index. If the given index is less than zero or greater than the current case count, the case will be inserted at the end of the list.
Public method | InsertCase(Int32, ICaseScope) | Inserts an existing case to the given index and takes ownership of the ICaseScope. If the given index is less than zero or greater than the current case count, the case will be inserted at the end of the list.
Public method | MoveCase | Moves the given case to the new position inside this instance of ISwitchCaseStatement. If the given index is less than zero or greater than the current case count, the case will be moved to the end of the list.
Public method | ReleaseCase | Removes an existing case from this IStatement. The caller claims ownership of the ICaseScope.
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISwitchCaseStatement Interface
VisualComponents.Create3D Namespace


ISwitchCaseStatement.AddCase Method

ISwitchCaseStatementAddCase Method

Adds a new case.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ICaseScope AddCase()
ICaseScope^ AddCase()

Return Value

Type: ICaseScope

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISwitchCaseStatement.AddCase"]

See Also

Reference

ISwitchCaseStatement Interface
VisualComponents.Create3D Namespace


ISwitchCaseStatement.DeleteCase Method

ISwitchCaseStatementDeleteCase Method

Deletes an existing case. This will invalidate the ICaseScope wrapper.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteCase(
    ICaseScope scope
)
void DeleteCase(
    ICaseScope^ scope
)

Parameters

scope
Type: VisualComponents.Create3DICaseScope
Case to remove
See Also

Reference

ISwitchCaseStatement Interface
VisualComponents.Create3D Namespace


ISwitchCaseStatement.GetCase Method

ISwitchCaseStatementGetCase Method

Get an existing case.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ICaseScope GetCase(
    uint index
)
ICaseScope^ GetCase(
    unsigned int index
)

Parameters

index
Type: SystemUInt32
Index of case to get

Return Value

Type: ICaseScope

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISwitchCaseStatement.GetCase(System.UInt32)"]

See Also

Reference

ISwitchCaseStatement Interface
VisualComponents.Create3D Namespace


ISwitchCaseStatement.InsertCase Method

ISwitchCaseStatementInsertCase Method

Overload List
 | Name | Description
Public method | InsertCase(Int32) | Inserts a new case to the given index. If the given index is less than zero or greater than the current case count, the case will be inserted at the end of the list.
Public method | InsertCase(Int32, ICaseScope) | Inserts an existing case to the given index and takes ownership of the ICaseScope. If the given index is less than zero or greater than the current case count, the case will be inserted at the end of the list.
Top
See Also

Reference

ISwitchCaseStatement Interface
VisualComponents.Create3D Namespace


ISwitchCaseStatement.InsertCase Method (Int32)

ISwitchCaseStatementInsertCase Method (Int32)

Inserts a new case to the given index. If the given index is less than zero or greater than the current case count, the case will be inserted at the end of the list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ICaseScope InsertCase(
    int index
)
ICaseScope^ InsertCase(
    int index
)

Parameters

index
Type: SystemInt32
Index of the new statement

Return Value

Type: ICaseScope

[Missing <returns> documentation for "M:VisualComponents.Create3D.ISwitchCaseStatement.InsertCase(System.Int32)"]

See Also

Reference

ISwitchCaseStatement Interface
InsertCase Overload
VisualComponents.Create3D Namespace


ISwitchCaseStatement.InsertCase Method (Int32, ICaseScope)

ISwitchCaseStatementInsertCase Method (Int32, ICaseScope)

Inserts an existing case to the given index and takes ownership of the ICaseScope. If the given index is less than zero or greater than the current case count, the case will be inserted at the end of the list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void InsertCase(
    int index,
    ICaseScope scope
)
void InsertCase(
    int index,
    ICaseScope^ scope
)

Parameters

index
Type: SystemInt32
Index at which the case will be inserted
scope
Type: VisualComponents.Create3DICaseScope
scope to insert
See Also

Reference

ISwitchCaseStatement Interface
InsertCase Overload
VisualComponents.Create3D Namespace


ISwitchCaseStatement.MoveCase Method

ISwitchCaseStatementMoveCase Method

Moves the given case to the new position inside this instance of ISwitchCaseStatement. If the given index is less than zero or greater than the current case count, the case will be moved to the end of the list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void MoveCase(
    ICaseScope scope,
    int index
)
void MoveCase(
    ICaseScope^ scope,
    int index
)

Parameters

scope
Type: VisualComponents.Create3DICaseScope
Case to be moved.
index
Type: SystemInt32
New position for the case.
See Also

Reference

ISwitchCaseStatement Interface
VisualComponents.Create3D Namespace


ISwitchCaseStatement.ReleaseCase Method

ISwitchCaseStatementReleaseCase Method

Removes an existing case from this IStatement. The caller claims ownership of the ICaseScope.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ReleaseCase(
    ICaseScope scope
)
void ReleaseCase(
    ICaseScope^ scope
)

Parameters

scope
Type: VisualComponents.Create3DICaseScope
Case to remove
See Also

Reference

ISwitchCaseStatement Interface
VisualComponents.Create3D Namespace


ISwitchCaseStatement Events

The ISwitchCaseStatement type exposes the following members.

Events
 | Name | Description
Public event | CaseAdded | Occurs when a case has been added or inserted (in)to this switch statement.
Public event | CaseMoved | Occurs when a case has been added or inserted (in)to this switch statement.
Public event | CaseRemoved | Occurs when a case has been removed from this switch statement.
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

ISwitchCaseStatement Interface
VisualComponents.Create3D Namespace


ISwitchCaseStatement.CaseAdded Event

ISwitchCaseStatementCaseAdded Event

Occurs when a case has been added or inserted (in)to this switch statement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<CaseAddedEventArgs> CaseAdded
 event EventHandler<CaseAddedEventArgs^>^ CaseAdded {
    void add (EventHandler<CaseAddedEventArgs^>^ value);
    void remove (EventHandler<CaseAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerCaseAddedEventArgs
See Also

Reference

ISwitchCaseStatement Interface
VisualComponents.Create3D Namespace


ISwitchCaseStatement.CaseMoved Event

ISwitchCaseStatementCaseMoved Event

Occurs when a case has been added or inserted (in)to this switch statement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<CaseMovedEventArgs> CaseMoved
 event EventHandler<CaseMovedEventArgs^>^ CaseMoved {
    void add (EventHandler<CaseMovedEventArgs^>^ value);
    void remove (EventHandler<CaseMovedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerCaseMovedEventArgs
See Also

Reference

ISwitchCaseStatement Interface
VisualComponents.Create3D Namespace


ISwitchCaseStatement.CaseRemoved Event

ISwitchCaseStatementCaseRemoved Event

Occurs when a case has been removed from this switch statement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<CaseRemovedEventArgs> CaseRemoved
 event EventHandler<CaseRemovedEventArgs^>^ CaseRemoved {
    void add (EventHandler<CaseRemovedEventArgs^>^ value);
    void remove (EventHandler<CaseRemovedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerCaseRemovedEventArgs
See Also

Reference

ISwitchCaseStatement Interface
VisualComponents.Create3D Namespace


ISwitchFeature Interface

Represents a switch feature object

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISwitchFeature : IFeature,
    IVisualObject, INamed, IWrapper, IDisposable, IVisitable,
    IPropertyContainer, IBatchModeObject, ISharedCloneable
public interface class ISwitchFeature : IFeature,
    IVisualObject, INamed, IWrapper, IDisposable, IVisitable,
    IPropertyContainer, IBatchModeObject, ISharedCloneable

The ISwitchFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
The Switch operation feature selects one sub tree for further evaluation and ignores the rest. Which sub tree is selected, if any, depends on the choosen expression
See Also

Reference

VisualComponents.Create3D Namespace


ISwitchFeature Properties

The ISwitchFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
See Also

Reference

ISwitchFeature Interface
VisualComponents.Create3D Namespace


ISwitchFeature Methods

The ISwitchFeature type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ISwitchFeature Interface
VisualComponents.Create3D Namespace


ISwitchFeature Events

The ISwitchFeature type exposes the following members.

Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

ISwitchFeature Interface
VisualComponents.Create3D Namespace


ITeachContext Interface

This interface represents the Teach context of the application

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ITeachContext : IContext
public interface class ITeachContext : IContext

The ITeachContext type exposes the following members.

Properties
 | Name | Description
Public property | ActiveController |
Public property | ActiveRobot | This is not null only when ITeachContext.IsActive.
Public property | ActiveRobotTarget |
Public property | ActiveScope |
Public property | ActiveStatementIndex |
Public property | HidePropertyEditorPane | Use this proprty to custom control and override the visibility of property editor pane. Set True to hide property pane when selecting statement and false otherwise.
Public property | Id | Context ID. Possible values can be found in Contexts static class. (Inherited from IContext.)
Public property | IsActive | Determine if the context is active, hence, the current application context. (Inherited from IContext.)
Public property | SimplifiedStatementNodeTemplate | This template is used during simulation runtime to improve the tracing performance in program editor. All interactions are disabled during simulation so the template would better not have TreeNodeViewEx.
Public property | StatementNodeTemplate | Allows to supply a custom statement template for the program editor. Template must contain TreeNodeViewEx.
Public property | SupportedManipulationModes | Gets the list of manipulation modes that are allowed in this context. (Inherited from IContext.)
Top
Methods
 | Name | Description
Public method | Activate | Activates the context making it this application context. (Inherited from IContext.)
Public method | ClearContext | This is called internally on world clearing.
Public method | Deactivate | Deactivates this context. (Inherited from IContext.)
Public method | SetActiveRobot |
Public method | SetActiveStatement | Sets current active statement scope and statement index. Triggers ActiveStatementChanged event
Public method | TriggerStatementDoubleClick | Internal helper for invoking StatementDoubleClick.
Top
Events
 | Name | Description
Public event | ActiveRobotChanged |
Public event | ActiveRobotChanging | These events are fired on active robot change, or when teach context is activated (when we have some robot to activate in TeachContext.OnActivate). These events are Not triggered outside of teach context.
Public event | ActiveStatementChanged | Triggered when calling ITeachContext.SetActiveStatement method
Public event | StatementDoubleClick | Triggered when statement is double clicked in the program editor.
Public event | StatementNodeTemplateChanged | Triggered when new node template gets assigned to either StatementNodeTemplate or SimplifiedStatementNodeTemplate.
Top
See Also

Reference

VisualComponents.Create3D Namespace


ITeachContext Properties

The ITeachContext type exposes the following members.

Properties
 | Name | Description
Public property | ActiveController |
Public property | ActiveRobot | This is not null only when ITeachContext.IsActive.
Public property | ActiveRobotTarget |
Public property | ActiveScope |
Public property | ActiveStatementIndex |
Public property | HidePropertyEditorPane | Use this proprty to custom control and override the visibility of property editor pane. Set True to hide property pane when selecting statement and false otherwise.
Public property | Id | Context ID. Possible values can be found in Contexts static class. (Inherited from IContext.)
Public property | IsActive | Determine if the context is active, hence, the current application context. (Inherited from IContext.)
Public property | SimplifiedStatementNodeTemplate | This template is used during simulation runtime to improve the tracing performance in program editor. All interactions are disabled during simulation so the template would better not have TreeNodeViewEx.
Public property | StatementNodeTemplate | Allows to supply a custom statement template for the program editor. Template must contain TreeNodeViewEx.
Public property | SupportedManipulationModes | Gets the list of manipulation modes that are allowed in this context. (Inherited from IContext.)
Top
See Also

Reference

ITeachContext Interface
VisualComponents.Create3D Namespace


ITeachContext.ActiveController Property

ITeachContextActiveController Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IServoController ActiveController { get; }
property IServoController^ ActiveController {
    IServoController^ get ();
}

Property Value

Type: IServoController
See Also

Reference

ITeachContext Interface
VisualComponents.Create3D Namespace


ITeachContext.ActiveRobot Property

ITeachContextActiveRobot Property

This is not null only when ITeachContext.IsActive.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobot ActiveRobot { get; set; }
property IRobot^ ActiveRobot {
    IRobot^ get ();
    void set (IRobot^ value);
}

Property Value

Type: IRobot
See Also

Reference

ITeachContext Interface
VisualComponents.Create3D Namespace


ITeachContext.ActiveRobotTarget Property

ITeachContextActiveRobotTarget Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotTcpManipulationTarget ActiveRobotTarget { get; }
property IRobotTcpManipulationTarget^ ActiveRobotTarget {
    IRobotTcpManipulationTarget^ get ();
}

Property Value

Type: IRobotTcpManipulationTarget
See Also

Reference

ITeachContext Interface
VisualComponents.Create3D Namespace


ITeachContext.ActiveScope Property

ITeachContextActiveScope Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatementScope ActiveScope { get; }
property IStatementScope^ ActiveScope {
    IStatementScope^ get ();
}

Property Value

Type: IStatementScope
See Also

Reference

ITeachContext Interface
VisualComponents.Create3D Namespace


ITeachContext.ActiveStatementIndex Property

ITeachContextActiveStatementIndex Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int ActiveStatementIndex { get; }
property int ActiveStatementIndex {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ITeachContext Interface
VisualComponents.Create3D Namespace


ITeachContext.HidePropertyEditorPane Property

ITeachContextHidePropertyEditorPane Property

Use this proprty to custom control and override the visibility of property editor pane. Set True to hide property pane when selecting statement and false otherwise.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool HidePropertyEditorPane { get; set; }
property bool HidePropertyEditorPane {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ITeachContext Interface
VisualComponents.Create3D Namespace


ITeachContext.SimplifiedStatementNodeTemplate Property

ITeachContextSimplifiedStatementNodeTemplate Property

This template is used during simulation runtime to improve the tracing performance in program editor. All interactions are disabled during simulation so the template would better not have TreeNodeViewEx.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
DataTemplate SimplifiedStatementNodeTemplate { get; set; }
property DataTemplate^ SimplifiedStatementNodeTemplate {
    DataTemplate^ get ();
    void set (DataTemplate^ value);
}

Property Value

Type: DataTemplate
See Also

Reference

ITeachContext Interface
VisualComponents.Create3D Namespace


ITeachContext.StatementNodeTemplate Property

ITeachContextStatementNodeTemplate Property

Allows to supply a custom statement template for the program editor. Template must contain TreeNodeViewEx.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
DataTemplate StatementNodeTemplate { get; set; }
property DataTemplate^ StatementNodeTemplate {
    DataTemplate^ get ();
    void set (DataTemplate^ value);
}

Property Value

Type: DataTemplate
See Also

Reference

ITeachContext Interface
VisualComponents.Create3D Namespace


ITeachContext Methods

The ITeachContext type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the context making it this application context. (Inherited from IContext.)
Public method | ClearContext | This is called internally on world clearing.
Public method | Deactivate | Deactivates this context. (Inherited from IContext.)
Public method | SetActiveRobot |
Public method | SetActiveStatement | Sets current active statement scope and statement index. Triggers ActiveStatementChanged event
Public method | TriggerStatementDoubleClick | Internal helper for invoking StatementDoubleClick.
Top
See Also

Reference

ITeachContext Interface
VisualComponents.Create3D Namespace


ITeachContext.ClearContext Method

ITeachContextClearContext Method

This is called internally on world clearing.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ClearContext()
void ClearContext()
See Also

Reference

ITeachContext Interface
VisualComponents.Create3D Namespace


ITeachContext.SetActiveRobot Method

ITeachContextSetActiveRobot Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetActiveRobot(
    IRobot robot,
    IServoController currentController
)
void SetActiveRobot(
    IRobot^ robot,
    IServoController^ currentController
)

Parameters

robot
Type: VisualComponents.Create3DIRobot
currentController
Type: VisualComponents.Create3DIServoController
See Also

Reference

ITeachContext Interface
VisualComponents.Create3D Namespace


ITeachContext.SetActiveStatement Method

ITeachContextSetActiveStatement Method

Sets current active statement scope and statement index. Triggers ActiveStatementChanged event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetActiveStatement(
    IStatementScope scope,
    int statementIndex
)
void SetActiveStatement(
    IStatementScope^ scope,
    int statementIndex
)

Parameters

scope
Type: VisualComponents.Create3DIStatementScope
statementIndex
Type: SystemInt32
See Also

Reference

ITeachContext Interface
VisualComponents.Create3D Namespace


ITeachContext.TriggerStatementDoubleClick Method

ITeachContextTriggerStatementDoubleClick Method

Internal helper for invoking StatementDoubleClick.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void TriggerStatementDoubleClick(
    Object sender,
    StatementDoubleClickEventArgs e
)
void TriggerStatementDoubleClick(
    Object^ sender,
    StatementDoubleClickEventArgs^ e
)

Parameters

sender
Type: SystemObject
e
Type: VisualComponents.Create3DStatementDoubleClickEventArgs
See Also

Reference

ITeachContext Interface
VisualComponents.Create3D Namespace


ITeachContext Events

The ITeachContext type exposes the following members.

Events
 | Name | Description
Public event | ActiveRobotChanged |
Public event | ActiveRobotChanging | These events are fired on active robot change, or when teach context is activated (when we have some robot to activate in TeachContext.OnActivate). These events are Not triggered outside of teach context.
Public event | ActiveStatementChanged | Triggered when calling ITeachContext.SetActiveStatement method
Public event | StatementDoubleClick | Triggered when statement is double clicked in the program editor.
Public event | StatementNodeTemplateChanged | Triggered when new node template gets assigned to either StatementNodeTemplate or SimplifiedStatementNodeTemplate.
Top
See Also

Reference

ITeachContext Interface
VisualComponents.Create3D Namespace


ITeachContext.ActiveRobotChanged Event

ITeachContextActiveRobotChanged Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ActiveRobotChangeEventArgs> ActiveRobotChanged
 event EventHandler<ActiveRobotChangeEventArgs^>^ ActiveRobotChanged {
    void add (EventHandler<ActiveRobotChangeEventArgs^>^ value);
    void remove (EventHandler<ActiveRobotChangeEventArgs^>^ value);
}

Value

Type: SystemEventHandlerActiveRobotChangeEventArgs
See Also

Reference

ITeachContext Interface
VisualComponents.Create3D Namespace


ITeachContext.ActiveRobotChanging Event

ITeachContextActiveRobotChanging Event

These events are fired on active robot change, or when teach context is activated (when we have some robot to activate in TeachContext.OnActivate). These events are Not triggered outside of teach context.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ActiveRobotChangeEventArgs> ActiveRobotChanging
 event EventHandler<ActiveRobotChangeEventArgs^>^ ActiveRobotChanging {
    void add (EventHandler<ActiveRobotChangeEventArgs^>^ value);
    void remove (EventHandler<ActiveRobotChangeEventArgs^>^ value);
}

Value

Type: SystemEventHandlerActiveRobotChangeEventArgs
See Also

Reference

ITeachContext Interface
VisualComponents.Create3D Namespace


ITeachContext.ActiveStatementChanged Event

ITeachContextActiveStatementChanged Event

Triggered when calling ITeachContext.SetActiveStatement method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> ActiveStatementChanged
 event EventHandler<EventArgs^>^ ActiveStatementChanged {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

ITeachContext Interface
VisualComponents.Create3D Namespace


ITeachContext.StatementDoubleClick Event

ITeachContextStatementDoubleClick Event

Triggered when statement is double clicked in the program editor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<StatementDoubleClickEventArgs> StatementDoubleClick
 event EventHandler<StatementDoubleClickEventArgs^>^ StatementDoubleClick {
    void add (EventHandler<StatementDoubleClickEventArgs^>^ value);
    void remove (EventHandler<StatementDoubleClickEventArgs^>^ value);
}

Value

Type: SystemEventHandlerStatementDoubleClickEventArgs
See Also

Reference

ITeachContext Interface
VisualComponents.Create3D Namespace


ITeachContext.StatementNodeTemplateChanged Event

ITeachContextStatementNodeTemplateChanged Event

Triggered when new node template gets assigned to either StatementNodeTemplate or SimplifiedStatementNodeTemplate.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<NodeTemplateChangedEventArgs> StatementNodeTemplateChanged
 event EventHandler<NodeTemplateChangedEventArgs^>^ StatementNodeTemplateChanged {
    void add (EventHandler<NodeTemplateChangedEventArgs^>^ value);
    void remove (EventHandler<NodeTemplateChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerNodeTemplateChangedEventArgs
See Also

Reference

ITeachContext Interface
VisualComponents.Create3D Namespace


ItemCollectionChangedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DItemCollectionChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ItemCollectionChangedEventArgs : EventArgs
public ref class ItemCollectionChangedEventArgs : public EventArgs

The ItemCollectionChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ItemCollectionChangedEventArgs | Initializes a new instance of the ItemCollectionChangedEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ItemCollectionChangedEventArgs Constructor

Initializes a new instance of the ItemCollectionChangedEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ItemCollectionChangedEventArgs()
public:
ItemCollectionChangedEventArgs()
See Also

Reference

ItemCollectionChangedEventArgs Class
VisualComponents.Create3D Namespace


ItemCollectionChangedEventArgs Methods

The ItemCollectionChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ItemCollectionChangedEventArgs Class
VisualComponents.Create3D Namespace


ItemsDeselectedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DItemsDeselectedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ItemsDeselectedEventArgs : EventArgs
public ref class ItemsDeselectedEventArgs : public EventArgs

The ItemsDeselectedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ItemsDeselectedEventArgs | Initializes a new instance of the ItemsDeselectedEventArgs class
Top
Properties
 | Name | Description
Public property | Items |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ItemsDeselectedEventArgs Constructor

Initializes a new instance of the ItemsDeselectedEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ItemsDeselectedEventArgs(
    Object[] items
)
public:
ItemsDeselectedEventArgs(
    array<Object^>^ items
)

Parameters

items
Type: SystemObject
See Also

Reference

ItemsDeselectedEventArgs Class
VisualComponents.Create3D Namespace


ItemsDeselectedEventArgs Properties

The ItemsDeselectedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Items |
Top
See Also

Reference

ItemsDeselectedEventArgs Class
VisualComponents.Create3D Namespace


ItemsDeselectedEventArgs.Items Property

ItemsDeselectedEventArgsItems Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<Object> Items { get; }
public:
property ReadOnlyCollection<Object^>^ Items {
    ReadOnlyCollection<Object^>^ get ();
}

Property Value

Type: ReadOnlyCollectionObject
See Also

Reference

ItemsDeselectedEventArgs Class
VisualComponents.Create3D Namespace


ItemsDeselectedEventArgs Methods

The ItemsDeselectedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ItemsDeselectedEventArgs Class
VisualComponents.Create3D Namespace


ItemsDeselectingEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DItemsDeselectingEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ItemsDeselectingEventArgs : EventArgs
public ref class ItemsDeselectingEventArgs : public EventArgs

The ItemsDeselectingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ItemsDeselectingEventArgs | Initializes a new instance of the ItemsDeselectingEventArgs class
Top
Properties
 | Name | Description
Public property | Items |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ItemsDeselectingEventArgs Constructor

Initializes a new instance of the ItemsDeselectingEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ItemsDeselectingEventArgs(
    Object[] items
)
public:
ItemsDeselectingEventArgs(
    array<Object^>^ items
)

Parameters

items
Type: SystemObject
See Also

Reference

ItemsDeselectingEventArgs Class
VisualComponents.Create3D Namespace


ItemsDeselectingEventArgs Properties

The ItemsDeselectingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Items |
Top
See Also

Reference

ItemsDeselectingEventArgs Class
VisualComponents.Create3D Namespace


ItemsDeselectingEventArgs.Items Property

ItemsDeselectingEventArgsItems Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<Object> Items { get; }
public:
property ReadOnlyCollection<Object^>^ Items {
    ReadOnlyCollection<Object^>^ get ();
}

Property Value

Type: ReadOnlyCollectionObject
See Also

Reference

ItemsDeselectingEventArgs Class
VisualComponents.Create3D Namespace


ItemsDeselectingEventArgs Methods

The ItemsDeselectingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ItemsDeselectingEventArgs Class
VisualComponents.Create3D Namespace


ItemSelectedMessage(T) Class

ItemSelectedMessageT Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DItemSelectedMessageT

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ItemSelectedMessage<T>

generic<typename T>
public ref class ItemSelectedMessage

Type Parameters

T

The ItemSelectedMessageT type exposes the following members.

Constructors
 | Name | Description
Public method | ItemSelectedMessageT | Initializes a new instance of the ItemSelectedMessageT class
Public method | ItemSelectedMessageT(T) | Initializes a new instance of the ItemSelectedMessageT class
Top
Properties
 | Name | Description
Public property | SelectedObject |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ItemSelectedMessage(T) Constructor

ItemSelectedMessageT Constructor

Overload List
 | Name | Description
Public method | ItemSelectedMessageT | Initializes a new instance of the ItemSelectedMessageT class
Public method | ItemSelectedMessageT(T) | Initializes a new instance of the ItemSelectedMessageT class
Top
See Also

Reference

ItemSelectedMessageT Class
VisualComponents.Create3D Namespace


ItemSelectedMessage(T) Constructor

ItemSelectedMessageT Constructor

Initializes a new instance of the ItemSelectedMessageT class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ItemSelectedMessage()
public:
ItemSelectedMessage()
See Also

Reference

ItemSelectedMessageT Class
ItemSelectedMessageT Overload
VisualComponents.Create3D Namespace


ItemSelectedMessage(T) Constructor (T)

ItemSelectedMessageT Constructor (T)

Initializes a new instance of the ItemSelectedMessageT class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ItemSelectedMessage(
    T selectedObject
)
public:
ItemSelectedMessage(
    T selectedObject
)

Parameters

selectedObject
Type: T
See Also

Reference

ItemSelectedMessageT Class
ItemSelectedMessageT Overload
VisualComponents.Create3D Namespace


ItemSelectedMessage(T) Properties

ItemSelectedMessageT Properties

The ItemSelectedMessageT generic type exposes the following members.

Properties
 | Name | Description
Public property | SelectedObject |
Top
See Also

Reference

ItemSelectedMessageT Class
VisualComponents.Create3D Namespace


ItemSelectedMessage(T).SelectedObject Property

ItemSelectedMessageTSelectedObject Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public T SelectedObject { get; set; }
public:
property T SelectedObject {
    T get ();
    void set (T value);
}

Property Value

Type: T
See Also

Reference

ItemSelectedMessageT Class
VisualComponents.Create3D Namespace


ItemSelectedMessage(T) Methods

ItemSelectedMessageT Methods

The ItemSelectedMessageT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ItemSelectedMessageT Class
VisualComponents.Create3D Namespace


ItemsSelectedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DItemsSelectedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ItemsSelectedEventArgs : EventArgs
public ref class ItemsSelectedEventArgs : public EventArgs

The ItemsSelectedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ItemsSelectedEventArgs | Initializes a new instance of the ItemsSelectedEventArgs class
Top
Properties
 | Name | Description
Public property | Items |
Public property | Multiselect |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ItemsSelectedEventArgs Constructor

Initializes a new instance of the ItemsSelectedEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ItemsSelectedEventArgs(
    Object[] items,
    bool multiselect
)
public:
ItemsSelectedEventArgs(
    array<Object^>^ items,
    bool multiselect
)

Parameters

items
Type: SystemObject
multiselect
Type: SystemBoolean
See Also

Reference

ItemsSelectedEventArgs Class
VisualComponents.Create3D Namespace


ItemsSelectedEventArgs Properties

The ItemsSelectedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Items |
Public property | Multiselect |
Top
See Also

Reference

ItemsSelectedEventArgs Class
VisualComponents.Create3D Namespace


ItemsSelectedEventArgs.Items Property

ItemsSelectedEventArgsItems Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<Object> Items { get; }
public:
property ReadOnlyCollection<Object^>^ Items {
    ReadOnlyCollection<Object^>^ get ();
}

Property Value

Type: ReadOnlyCollectionObject
See Also

Reference

ItemsSelectedEventArgs Class
VisualComponents.Create3D Namespace


ItemsSelectedEventArgs.Multiselect Property

ItemsSelectedEventArgsMultiselect Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Multiselect { get; }
public:
property bool Multiselect {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ItemsSelectedEventArgs Class
VisualComponents.Create3D Namespace


ItemsSelectedEventArgs Methods

The ItemsSelectedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ItemsSelectedEventArgs Class
VisualComponents.Create3D Namespace


ItemsSelectingEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DItemsSelectingEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ItemsSelectingEventArgs : EventArgs
public ref class ItemsSelectingEventArgs : public EventArgs

The ItemsSelectingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ItemsSelectingEventArgs | Initializes a new instance of the ItemsSelectingEventArgs class
Top
Properties
 | Name | Description
Public property | Handled |
Public property | Items |
Public property | Multiselect |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ItemsSelectingEventArgs Constructor

Initializes a new instance of the ItemsSelectingEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ItemsSelectingEventArgs(
    Object[] items,
    bool multiselect
)
public:
ItemsSelectingEventArgs(
    array<Object^>^ items,
    bool multiselect
)

Parameters

items
Type: SystemObject
multiselect
Type: SystemBoolean
See Also

Reference

ItemsSelectingEventArgs Class
VisualComponents.Create3D Namespace


ItemsSelectingEventArgs Properties

The ItemsSelectingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Handled |
Public property | Items |
Public property | Multiselect |
Top
See Also

Reference

ItemsSelectingEventArgs Class
VisualComponents.Create3D Namespace


ItemsSelectingEventArgs.Handled Property

ItemsSelectingEventArgsHandled Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Handled { get; set; }
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ItemsSelectingEventArgs Class
VisualComponents.Create3D Namespace


ItemsSelectingEventArgs.Items Property

ItemsSelectingEventArgsItems Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<Object> Items { get; }
public:
property ReadOnlyCollection<Object^>^ Items {
    ReadOnlyCollection<Object^>^ get ();
}

Property Value

Type: ReadOnlyCollectionObject
See Also

Reference

ItemsSelectingEventArgs Class
VisualComponents.Create3D Namespace


ItemsSelectingEventArgs.Multiselect Property

ItemsSelectingEventArgsMultiselect Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Multiselect { get; }
public:
property bool Multiselect {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ItemsSelectingEventArgs Class
VisualComponents.Create3D Namespace


ItemsSelectingEventArgs Methods

The ItemsSelectingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ItemsSelectingEventArgs Class
VisualComponents.Create3D Namespace


IText2DSet Interface

Interface for 2d text sets. Implements a geometry set that renders bill boarded text in the world.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IText2DSet : IGeometrySet,
    IPrimitive, IWrapper, IDisposable
public interface class IText2DSet : IGeometrySet,
    IPrimitive, IWrapper, IDisposable

The IText2DSet type exposes the following members.

Properties
 | Name | Description
Public property | BoundBox | Returns the bound box of the geometryset. (Inherited from IGeometrySet.)
Public property | Container | Geometry container object (Inherited from IGeometrySet.)
Public property | Feature | IGeometryFeature owning the geoset (Inherited from IGeometrySet.)
Public property | HasMaterialInheritance | Determines if it has material inheritance (Inherited from IGeometrySet.)
Public property | HasNoHits | For internal purpose only (Inherited from IGeometrySet.)
Public property | IsHighlighted | Determines if set is highlighted (Inherited from IGeometrySet.)
Public property | IsLayerVisible | Determine if the layer where the geometry set is located is visible (Inherited from IGeometrySet.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Determines if set is visible (Inherited from IGeometrySet.)
Public property | Material | Material of the set (Inherited from IGeometrySet.)
Public property | Name | Name of the set (Inherited from IGeometrySet.)
Public property | ObjectPrimitiveType | (Inherited from IPrimitive.)
Public property | Original | Retrieves the original geometry set (Inherited from IGeometrySet.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Position | 3D position of the text object
Public property | Text | The text to display. This string is displayed as one line
Public property | TopologyCurves | Set topological information (Inherited from IGeometrySet.)
Top
Methods
 | Name | Description
Public method | Clear | Clears all geometry information from the set (Inherited from IGeometrySet.)
Public method | Delete | Deletes the set. Instance gets invalidated (Inherited from IGeometrySet.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetClosestPoint | Raycast geometry set. (Inherited from IGeometrySet.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | HighlightEdges | highlights only the edges (does not override normal highlighting) (Inherited from IGeometrySet.)
Public method | Update | Updates set information (Inherited from IGeometrySet.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IText2DSet Properties

The IText2DSet type exposes the following members.

Properties
 | Name | Description
Public property | BoundBox | Returns the bound box of the geometryset. (Inherited from IGeometrySet.)
Public property | Container | Geometry container object (Inherited from IGeometrySet.)
Public property | Feature | IGeometryFeature owning the geoset (Inherited from IGeometrySet.)
Public property | HasMaterialInheritance | Determines if it has material inheritance (Inherited from IGeometrySet.)
Public property | HasNoHits | For internal purpose only (Inherited from IGeometrySet.)
Public property | IsHighlighted | Determines if set is highlighted (Inherited from IGeometrySet.)
Public property | IsLayerVisible | Determine if the layer where the geometry set is located is visible (Inherited from IGeometrySet.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Determines if set is visible (Inherited from IGeometrySet.)
Public property | Material | Material of the set (Inherited from IGeometrySet.)
Public property | Name | Name of the set (Inherited from IGeometrySet.)
Public property | ObjectPrimitiveType | (Inherited from IPrimitive.)
Public property | Original | Retrieves the original geometry set (Inherited from IGeometrySet.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Position | 3D position of the text object
Public property | Text | The text to display. This string is displayed as one line
Public property | TopologyCurves | Set topological information (Inherited from IGeometrySet.)
Top
See Also

Reference

IText2DSet Interface
VisualComponents.Create3D Namespace


IText2DSet.Position Property

IText2DSetPosition Property

3D position of the text object

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 Position { get; set; }
property Vector3 Position {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

IText2DSet Interface
VisualComponents.Create3D Namespace


IText2DSet.Text Property

IText2DSetText Property

The text to display. This string is displayed as one line

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Text { get; set; }
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IText2DSet Interface
VisualComponents.Create3D Namespace


IText2DSet Methods

The IText2DSet type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clears all geometry information from the set (Inherited from IGeometrySet.)
Public method | Delete | Deletes the set. Instance gets invalidated (Inherited from IGeometrySet.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetClosestPoint | Raycast geometry set. (Inherited from IGeometrySet.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | HighlightEdges | highlights only the edges (does not override normal highlighting) (Inherited from IGeometrySet.)
Public method | Update | Updates set information (Inherited from IGeometrySet.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IText2DSet Interface
VisualComponents.Create3D Namespace


IText2DSet Events

The IText2DSet type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
See Also

Reference

IText2DSet Interface
VisualComponents.Create3D Namespace


IText3DSet Interface

Interface for 3d text sets. Implements a geometry set that renders 3d text in the world.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IText3DSet : IGeometrySet,
    IPrimitive, IWrapper, IDisposable
public interface class IText3DSet : IGeometrySet,
    IPrimitive, IWrapper, IDisposable

The IText3DSet type exposes the following members.

Properties
 | Name | Description
Public property | BoundBox | Returns the bound box of the geometryset. (Inherited from IGeometrySet.)
Public property | Container | Geometry container object (Inherited from IGeometrySet.)
Public property | Feature | IGeometryFeature owning the geoset (Inherited from IGeometrySet.)
Public property | HasMaterialInheritance | Determines if it has material inheritance (Inherited from IGeometrySet.)
Public property | HasNoHits | For internal purpose only (Inherited from IGeometrySet.)
Public property | Height | Text's height
Public property | IsHighlighted | Determines if set is highlighted (Inherited from IGeometrySet.)
Public property | IsLayerVisible | Determine if the layer where the geometry set is located is visible (Inherited from IGeometrySet.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Determines if set is visible (Inherited from IGeometrySet.)
Public property | Material | Material of the set (Inherited from IGeometrySet.)
Public property | Name | Name of the set (Inherited from IGeometrySet.)
Public property | ObjectPrimitiveType | (Inherited from IPrimitive.)
Public property | Original | Retrieves the original geometry set (Inherited from IGeometrySet.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Position | 3D position of the text object
Public property | Text | The text to display. This string is displayed as one line
Public property | TopologyCurves | Set topological information (Inherited from IGeometrySet.)
Top
Methods
 | Name | Description
Public method | Clear | Clears all geometry information from the set (Inherited from IGeometrySet.)
Public method | Delete | Deletes the set. Instance gets invalidated (Inherited from IGeometrySet.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetClosestPoint | Raycast geometry set. (Inherited from IGeometrySet.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | HighlightEdges | highlights only the edges (does not override normal highlighting) (Inherited from IGeometrySet.)
Public method | Update | Updates set information (Inherited from IGeometrySet.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IText3DSet Properties

The IText3DSet type exposes the following members.

Properties
 | Name | Description
Public property | BoundBox | Returns the bound box of the geometryset. (Inherited from IGeometrySet.)
Public property | Container | Geometry container object (Inherited from IGeometrySet.)
Public property | Feature | IGeometryFeature owning the geoset (Inherited from IGeometrySet.)
Public property | HasMaterialInheritance | Determines if it has material inheritance (Inherited from IGeometrySet.)
Public property | HasNoHits | For internal purpose only (Inherited from IGeometrySet.)
Public property | Height | Text's height
Public property | IsHighlighted | Determines if set is highlighted (Inherited from IGeometrySet.)
Public property | IsLayerVisible | Determine if the layer where the geometry set is located is visible (Inherited from IGeometrySet.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Determines if set is visible (Inherited from IGeometrySet.)
Public property | Material | Material of the set (Inherited from IGeometrySet.)
Public property | Name | Name of the set (Inherited from IGeometrySet.)
Public property | ObjectPrimitiveType | (Inherited from IPrimitive.)
Public property | Original | Retrieves the original geometry set (Inherited from IGeometrySet.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Position | 3D position of the text object
Public property | Text | The text to display. This string is displayed as one line
Public property | TopologyCurves | Set topological information (Inherited from IGeometrySet.)
Top
See Also

Reference

IText3DSet Interface
VisualComponents.Create3D Namespace


IText3DSet.Height Property

IText3DSetHeight Property

Text's height

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Height { get; set; }
property double Height {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IText3DSet Interface
VisualComponents.Create3D Namespace


IText3DSet.Position Property

IText3DSetPosition Property

3D position of the text object

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix Position { get; set; }
property Matrix Position {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

IText3DSet Interface
VisualComponents.Create3D Namespace


IText3DSet.Text Property

IText3DSetText Property

The text to display. This string is displayed as one line

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Text { get; set; }
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IText3DSet Interface
VisualComponents.Create3D Namespace


IText3DSet Methods

The IText3DSet type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clears all geometry information from the set (Inherited from IGeometrySet.)
Public method | Delete | Deletes the set. Instance gets invalidated (Inherited from IGeometrySet.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetClosestPoint | Raycast geometry set. (Inherited from IGeometrySet.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | HighlightEdges | highlights only the edges (does not override normal highlighting) (Inherited from IGeometrySet.)
Public method | Update | Updates set information (Inherited from IGeometrySet.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IText3DSet Interface
VisualComponents.Create3D Namespace


IText3DSet Events

The IText3DSet type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
See Also

Reference

IText3DSet Interface
VisualComponents.Create3D Namespace


ITextFeature Interface

Text type of feature

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ITextFeature : IFeature,
    IVisualObject, INamed, IWrapper, IDisposable, IVisitable,
    IPropertyContainer, IBatchModeObject, ISharedCloneable
public interface class ITextFeature : IFeature,
    IVisualObject, INamed, IWrapper, IDisposable, IVisitable,
    IPropertyContainer, IBatchModeObject, ISharedCloneable

The ITextFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsFloating | If True, text will be shown as a 2D text (billboard)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsReadOnly | If True, TextExpression cannot be change
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Material | Text material IMaterial
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | Size | Font size
Public property | TextExpression | Text or expression
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ITextFeature Properties

The ITextFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsFloating | If True, text will be shown as a 2D text (billboard)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsReadOnly | If True, TextExpression cannot be change
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Material | Text material IMaterial
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | Size | Font size
Public property | TextExpression | Text or expression
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
See Also

Reference

ITextFeature Interface
VisualComponents.Create3D Namespace


ITextFeature.IsFloating Property

ITextFeatureIsFloating Property

If True, text will be shown as a 2D text (billboard)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsFloating { get; set; }
property bool IsFloating {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ITextFeature Interface
VisualComponents.Create3D Namespace


ITextFeature.IsReadOnly Property

ITextFeatureIsReadOnly Property

If True, TextExpression cannot be change

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsReadOnly { get; set; }
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ITextFeature Interface
VisualComponents.Create3D Namespace


ITextFeature.Material Property

ITextFeatureMaterial Property

Text material IMaterial

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMaterial Material { get; set; }
property IMaterial^ Material {
    IMaterial^ get ();
    void set (IMaterial^ value);
}

Property Value

Type: IMaterial
See Also

Reference

ITextFeature Interface
VisualComponents.Create3D Namespace


ITextFeature.Size Property

ITextFeatureSize Property

Font size

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Size { get; set; }
property double Size {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ITextFeature Interface
VisualComponents.Create3D Namespace


ITextFeature.TextExpression Property

ITextFeatureTextExpression Property

Text or expression

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string TextExpression { get; set; }
property String^ TextExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ITextFeature Interface
VisualComponents.Create3D Namespace


ITextFeature Methods

The ITextFeature type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ITextFeature Interface
VisualComponents.Create3D Namespace


ITextFeature Events

The ITextFeature type exposes the following members.

Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

ITextFeature Interface
VisualComponents.Create3D Namespace


ITimerStatement Interface

Interface for timer statement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ITimerStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class ITimerStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The ITimerStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | LatestResult | Returns the latest result. Results are calculated when a stop mode statement is executed.
Public property | Mode | The mode specifier.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | TimerNumber | A number that identifies which timer will be used. The value range is [1, 64].
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ResultUpdated | Occurs when the timer result has been updated. This is usually when a statement with Mode Stop is executed.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ITimerStatement Properties

The ITimerStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | LatestResult | Returns the latest result. Results are calculated when a stop mode statement is executed.
Public property | Mode | The mode specifier.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | TimerNumber | A number that identifies which timer will be used. The value range is [1, 64].
Top
See Also

Reference

ITimerStatement Interface
VisualComponents.Create3D Namespace


ITimerStatement.LatestResult Property

ITimerStatementLatestResult Property

Returns the latest result. Results are calculated when a stop mode statement is executed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
(double lapTime, double totalTime) LatestResult { get; }
property ValueTuple<double, double> LatestResult {
    ValueTuple<double, double> get ();
}

Property Value

Type: ValueTupleDouble, Double
See Also

Reference

ITimerStatement Interface
VisualComponents.Create3D Namespace


ITimerStatement.Mode Property

ITimerStatementMode Property

The mode specifier.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
TimerStatementMode Mode { get; set; }
property TimerStatementMode Mode {
    TimerStatementMode get ();
    void set (TimerStatementMode value);
}

Property Value

Type: TimerStatementMode
See Also

Reference

ITimerStatement Interface
VisualComponents.Create3D Namespace


ITimerStatement.TimerNumber Property

ITimerStatementTimerNumber Property

A number that identifies which timer will be used. The value range is [1, 64].

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
uint TimerNumber { get; set; }
property unsigned int TimerNumber {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ITimerStatement Interface
VisualComponents.Create3D Namespace


ITimerStatement Methods

The ITimerStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ITimerStatement Interface
VisualComponents.Create3D Namespace


ITimerStatement Events

The ITimerStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ResultUpdated | Occurs when the timer result has been updated. This is usually when a statement with Mode Stop is executed.
Top
See Also

Reference

ITimerStatement Interface
VisualComponents.Create3D Namespace


ITimerStatement.ResultUpdated Event

ITimerStatementResultUpdated Event

Occurs when the timer result has been updated. This is usually when a statement with Mode Stop is executed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<TimerResultUpdatedEventArgs> ResultUpdated
 event EventHandler<TimerResultUpdatedEventArgs^>^ ResultUpdated {
    void add (EventHandler<TimerResultUpdatedEventArgs^>^ value);
    void remove (EventHandler<TimerResultUpdatedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerTimerResultUpdatedEventArgs
See Also

Reference

ITimerStatement Interface
VisualComponents.Create3D Namespace


IToolContainer Interface

Data container for tool IRobotFrame instances.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IToolContainer : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IToolContainer : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IToolContainer type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Tools | Gets the tools as a list of IRobotFrame instances.
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | CreateTool(String) | Creates and returns a new tool IRobotFrame instance.
Public method | CreateTool(String, Boolean) | Creates and returns a new tool IRobotFrame instance.
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteTool | Removes the given tool from the container.
Public method | DeleteToolAt | Removes the tool located at the given index from the container.
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ItemCollectionChanged | Event that is raised when tool frame collection is changed.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IToolContainer Properties

The IToolContainer type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Tools | Gets the tools as a list of IRobotFrame instances.
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IToolContainer Interface
VisualComponents.Create3D Namespace


IToolContainer.Tools Property

IToolContainerTools Property

Gets the tools as a list of IRobotFrame instances.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IRobotFrame> Tools { get; }
property IList<IRobotFrame^>^ Tools {
    IList<IRobotFrame^>^ get ();
}

Property Value

Type: IListIRobotFrame
See Also

Reference

IToolContainer Interface
VisualComponents.Create3D Namespace


IToolContainer Methods

The IToolContainer type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | CreateTool(String) | Creates and returns a new tool IRobotFrame instance.
Public method | CreateTool(String, Boolean) | Creates and returns a new tool IRobotFrame instance.
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteTool | Removes the given tool from the container.
Public method | DeleteToolAt | Removes the tool located at the given index from the container.
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IToolContainer Interface
VisualComponents.Create3D Namespace


IToolContainer.CreateTool Method

IToolContainerCreateTool Method

Overload List
 | Name | Description
Public method | CreateTool(String) | Creates and returns a new tool IRobotFrame instance.
Public method | CreateTool(String, Boolean) | Creates and returns a new tool IRobotFrame instance.
Top
See Also

Reference

IToolContainer Interface
VisualComponents.Create3D Namespace


IToolContainer.CreateTool Method (String)

IToolContainerCreateTool Method (String)

Creates and returns a new tool IRobotFrame instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotFrame CreateTool(
    string name
)
IRobotFrame^ CreateTool(
    String^ name
)

Parameters

name
Type: SystemString
Name of the tool to be created.

Return Value

Type: IRobotFrame
Created tool frame.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the name parameter is null.
ArgumentException | Thrown when a base with the given name exists already.
See Also

Reference

IToolContainer Interface
CreateTool Overload
VisualComponents.Create3D Namespace


IToolContainer.CreateTool Method (String, Boolean)

IToolContainerCreateTool Method (String, Boolean)

Creates and returns a new tool IRobotFrame instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotFrame CreateTool(
    string name,
    bool renameIfExists
)
IRobotFrame^ CreateTool(
    String^ name,
    bool renameIfExists
)

Parameters

name
Type: SystemString
Name of the tool to be created.
renameIfExists
Type: SystemBoolean
Defines if the tool be created is automatically renamed if a base with the given name exists already.

Return Value

Type: IRobotFrame
Created tool frame.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the name parameter is null.
See Also

Reference

IToolContainer Interface
CreateTool Overload
VisualComponents.Create3D Namespace


IToolContainer.DeleteTool Method

IToolContainerDeleteTool Method

Removes the given tool from the container.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteTool(
    IRobotFrame toolFrame
)
void DeleteTool(
    IRobotFrame^ toolFrame
)

Parameters

toolFrame
Type: VisualComponents.Create3DIRobotFrame
Tool to delete.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when tool is null.
See Also

Reference

IToolContainer Interface
VisualComponents.Create3D Namespace


IToolContainer.DeleteToolAt Method

IToolContainerDeleteToolAt Method

Removes the tool located at the given index from the container.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteToolAt(
    int index
)
void DeleteToolAt(
    int index
)

Parameters

index
Type: SystemInt32
The index of the tool to be deleted.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Throw when index is out of bounds.
See Also

Reference

IToolContainer Interface
VisualComponents.Create3D Namespace


IToolContainer Events

The IToolContainer type exposes the following members.

Events
 | Name | Description
Public event | ItemCollectionChanged | Event that is raised when tool frame collection is changed.
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IToolContainer Interface
VisualComponents.Create3D Namespace


IToolContainer.ItemCollectionChanged Event

IToolContainerItemCollectionChanged Event

Event that is raised when tool frame collection is changed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ItemCollectionChangedEventArgs> ItemCollectionChanged
 event EventHandler<ItemCollectionChangedEventArgs^>^ ItemCollectionChanged {
    void add (EventHandler<ItemCollectionChangedEventArgs^>^ value);
    void remove (EventHandler<ItemCollectionChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerItemCollectionChangedEventArgs
See Also

Reference

IToolContainer Interface
VisualComponents.Create3D Namespace


ITopologyBaseCurve Interface

Curves topology base interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ITopologyBaseCurve
public interface class ITopologyBaseCurve

The ITopologyBaseCurve type exposes the following members.

Properties
 | Name | Description
Public property | Edge | Convert this curve reference to IEdge reference.
Public property | Endpoints | Endpoints of a curve, contents of collection: [pos1, dir1, pos2, dir2]
Public property | GetCurveParameters | In case of non-tessellated curves, it will return all its parameters
Public property | Length | Retrieves Curver Length
Public property | Type | Retrieves Curver type
Top
Methods
 | Name | Description
Public method | EvaluateCurvature | In case of non-tessellated curves, computes the curvature of a curve at a given parameter
Public method | GetClosestPosition | Closest position distance, path distance for the given point
Public method | GetDirection | Returns direction along the curve as a Vector3 at the given distance
Public method | GetPosition | Returns position along the curve as a Vector3 at the given distance
Public method | GetPositions | Create curve points by using tessellation criterias. Remarks This method returns positions only if the curve is of type Polyline or Spline.
Public method | GetPositions(Double, Double, Double) | Create curve points by using tessellation criterias. Remarks This method returns positions only if the curve is of type Polyline or Spline.
Top
See Also

Reference

VisualComponents.Create3D Namespace


ITopologyBaseCurve Properties

The ITopologyBaseCurve type exposes the following members.

Properties
 | Name | Description
Public property | Edge | Convert this curve reference to IEdge reference.
Public property | Endpoints | Endpoints of a curve, contents of collection: [pos1, dir1, pos2, dir2]
Public property | GetCurveParameters | In case of non-tessellated curves, it will return all its parameters
Public property | Length | Retrieves Curver Length
Public property | Type | Retrieves Curver type
Top
See Also

Reference

ITopologyBaseCurve Interface
VisualComponents.Create3D Namespace


ITopologyBaseCurve.Edge Property

ITopologyBaseCurveEdge Property

Convert this curve reference to IEdge reference.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEdge Edge { get; }
property IEdge^ Edge {
    IEdge^ get ();
}

Property Value

Type: IEdge
See Also

Reference

ITopologyBaseCurve Interface
VisualComponents.Create3D Namespace


ITopologyBaseCurve.Endpoints Property

ITopologyBaseCurveEndpoints Property

Endpoints of a curve, contents of collection: [pos1, dir1, pos2, dir2]

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<Vector3> Endpoints { get; }
property ReadOnlyCollection<Vector3>^ Endpoints {
    ReadOnlyCollection<Vector3>^ get ();
}

Property Value

Type: ReadOnlyCollectionVector3
See Also

Reference

ITopologyBaseCurve Interface
VisualComponents.Create3D Namespace


ITopologyBaseCurve.GetCurveParameters Property

ITopologyBaseCurveGetCurveParameters Property

In case of non-tessellated curves, it will return all its parameters

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
CurveBase GetCurveParameters { get; }
property CurveBase^ GetCurveParameters {
    CurveBase^ get ();
}

Return Value

Type: CurveBase
Null if tessellated curve
See Also

Reference

ITopologyBaseCurve Interface
VisualComponents.Create3D Namespace


ITopologyBaseCurve.Length Property

ITopologyBaseCurveLength Property

Retrieves Curver Length

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Length { get; }
property double Length {
    double get ();
}

Property Value

Type: Double
See Also

Reference

ITopologyBaseCurve Interface
VisualComponents.Create3D Namespace


ITopologyBaseCurve.Type Property

ITopologyBaseCurveType Property

Retrieves Curver type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
CurveType Type { get; }
property CurveType Type {
    CurveType get ();
}

Property Value

Type: CurveType
See Also

Reference

ITopologyBaseCurve Interface
VisualComponents.Create3D Namespace


ITopologyBaseCurve Methods

The ITopologyBaseCurve type exposes the following members.

Methods
 | Name | Description
Public method | EvaluateCurvature | In case of non-tessellated curves, computes the curvature of a curve at a given parameter
Public method | GetClosestPosition | Closest position distance, path distance for the given point
Public method | GetDirection | Returns direction along the curve as a Vector3 at the given distance
Public method | GetPosition | Returns position along the curve as a Vector3 at the given distance
Public method | GetPositions | Create curve points by using tessellation criterias. Remarks This method returns positions only if the curve is of type Polyline or Spline.
Public method | GetPositions(Double, Double, Double) | Create curve points by using tessellation criterias. Remarks This method returns positions only if the curve is of type Polyline or Spline.
Top
See Also

Reference

ITopologyBaseCurve Interface
VisualComponents.Create3D Namespace


ITopologyBaseCurve.EvaluateCurvature Method

ITopologyBaseCurveEvaluateCurvature Method

In case of non-tessellated curves, computes the curvature of a curve at a given parameter

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double EvaluateCurvature(
    double parameter
)
double EvaluateCurvature(
    double parameter
)

Parameters

parameter
Type: SystemDouble

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.Create3D.ITopologyBaseCurve.EvaluateCurvature(System.Double)"]

See Also

Reference

ITopologyBaseCurve Interface
VisualComponents.Create3D Namespace


ITopologyBaseCurve.GetClosestPosition Method

ITopologyBaseCurveGetClosestPosition Method

Closest position distance, path distance for the given point

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double GetClosestPosition(
    Vector3 referencePosition
)
double GetClosestPosition(
    Vector3 referencePosition
)

Parameters

referencePosition
Type: VisualComponents.Create3DVector3

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.Create3D.ITopologyBaseCurve.GetClosestPosition(VisualComponents.Create3D.Vector3)"]

See Also

Reference

ITopologyBaseCurve Interface
VisualComponents.Create3D Namespace


ITopologyBaseCurve.GetDirection Method

ITopologyBaseCurveGetDirection Method

Returns direction along the curve as a Vector3 at the given distance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 GetDirection(
    double distance
)
Vector3 GetDirection(
    double distance
)

Parameters

distance
Type: SystemDouble
desired distance

Return Value

Type: Vector3

[Missing <returns> documentation for "M:VisualComponents.Create3D.ITopologyBaseCurve.GetDirection(System.Double)"]

See Also

Reference

ITopologyBaseCurve Interface
VisualComponents.Create3D Namespace


ITopologyBaseCurve.GetPosition Method

ITopologyBaseCurveGetPosition Method

Returns position along the curve as a Vector3 at the given distance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 GetPosition(
    double distance
)
Vector3 GetPosition(
    double distance
)

Parameters

distance
Type: SystemDouble
desired distance

Return Value

Type: Vector3

[Missing <returns> documentation for "M:VisualComponents.Create3D.ITopologyBaseCurve.GetPosition(System.Double)"]

See Also

Reference

ITopologyBaseCurve Interface
VisualComponents.Create3D Namespace


ITopologyBaseCurve.GetPositions Method

ITopologyBaseCurveGetPositions Method

Overload List
 | Name | Description
Public method | GetPositions | Create curve points by using tessellation criterias. Remarks This method returns positions only if the curve is of type Polyline or Spline.
Public method | GetPositions(Double, Double, Double) | Create curve points by using tessellation criterias. Remarks This method returns positions only if the curve is of type Polyline or Spline.
Top
See Also

Reference

ITopologyBaseCurve Interface
VisualComponents.Create3D Namespace


ITopologyBaseCurve.GetPositions Method

ITopologyBaseCurveGetPositions Method

Create curve points by using tessellation criterias.
Remarks
This method returns positions only if the curve is of type Polyline or Spline.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<Matrix> GetPositions()
ReadOnlyCollection<Matrix>^ GetPositions()

Return Value

Type: ReadOnlyCollectionMatrix

[Missing <returns> documentation for "M:VisualComponents.Create3D.ITopologyBaseCurve.GetPositions"]

See Also

Reference

ITopologyBaseCurve Interface
GetPositions Overload
VisualComponents.Create3D Namespace


ITopologyBaseCurve.GetPositions Method (Double, Double, Double)

ITopologyBaseCurveGetPositions Method (Double, Double, Double)

Create curve points by using tessellation criterias.
Remarks
This method returns positions only if the curve is of type Polyline or Spline.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<Matrix> GetPositions(
    double chordHeightTolerance,
    double angleToleranceDegree,
    double maximum3DDistance
)
ReadOnlyCollection<Matrix>^ GetPositions(
    double chordHeightTolerance,
    double angleToleranceDegree,
    double maximum3DDistance
)

Parameters

chordHeightTolerance
Type: SystemDouble
max height/length ratio between tess pts, 0=ignore
angleToleranceDegree
Type: SystemDouble
max angle between tess tangents, 0=ignore
maximum3DDistance
Type: SystemDouble
max distance between tess pts, 0=ignore

Return Value

Type: ReadOnlyCollectionMatrix

[Missing <returns> documentation for "M:VisualComponents.Create3D.ITopologyBaseCurve.GetPositions(System.Double,System.Double,System.Double)"]

See Also

Reference

ITopologyBaseCurve Interface
GetPositions Overload
VisualComponents.Create3D Namespace


ITopologyCurve Interface

Curve topological information

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ITopologyCurve : ITopologyBaseCurve
public interface class ITopologyCurve : ITopologyBaseCurve

The ITopologyCurve type exposes the following members.

Properties
 | Name | Description
Public property | CurveLoop | Returns the loop a curve belongs to
Public property | Edge | Convert this curve reference to IEdge reference. (Inherited from ITopologyBaseCurve.)
Public property | Endpoints | Endpoints of a curve, contents of collection: [pos1, dir1, pos2, dir2] (Inherited from ITopologyBaseCurve.)
Public property | Face | Returns the face a curve belongs to.
Public property | GetCurveParameters | In case of non-tessellated curves, it will return all its parameters (Inherited from ITopologyBaseCurve.)
Public property | Length | Retrieves Curver Length (Inherited from ITopologyBaseCurve.)
Public property | Neighbors | Retrieves curves neighbor to this ITopologyCurve
Public property | Type | Retrieves Curver type (Inherited from ITopologyBaseCurve.)
Top
Methods
 | Name | Description
Public method | EvaluateCurvature | In case of non-tessellated curves, computes the curvature of a curve at a given parameter (Inherited from ITopologyBaseCurve.)
Public method | GetClosestPosition | Closest position distance, path distance for the given point (Inherited from ITopologyBaseCurve.)
Public method | GetDirection | Returns direction along the curve as a Vector3 at the given distance (Inherited from ITopologyBaseCurve.)
Public method | GetPosition | Returns position along the curve as a Vector3 at the given distance (Inherited from ITopologyBaseCurve.)
Public method | GetPositions | Create curve points by using tessellation criterias. Remarks This method returns positions only if the curve is of type Polyline or Spline. (Inherited from ITopologyBaseCurve.)
Public method | GetPositions(Double, Double, Double) | Create curve points by using tessellation criterias. Remarks This method returns positions only if the curve is of type Polyline or Spline. (Inherited from ITopologyBaseCurve.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ITopologyCurve Properties

The ITopologyCurve type exposes the following members.

Properties
 | Name | Description
Public property | CurveLoop | Returns the loop a curve belongs to
Public property | Edge | Convert this curve reference to IEdge reference. (Inherited from ITopologyBaseCurve.)
Public property | Endpoints | Endpoints of a curve, contents of collection: [pos1, dir1, pos2, dir2] (Inherited from ITopologyBaseCurve.)
Public property | Face | Returns the face a curve belongs to.
Public property | GetCurveParameters | In case of non-tessellated curves, it will return all its parameters (Inherited from ITopologyBaseCurve.)
Public property | Length | Retrieves Curver Length (Inherited from ITopologyBaseCurve.)
Public property | Neighbors | Retrieves curves neighbor to this ITopologyCurve
Public property | Type | Retrieves Curver type (Inherited from ITopologyBaseCurve.)
Top
See Also

Reference

ITopologyCurve Interface
VisualComponents.Create3D Namespace


ITopologyCurve.CurveLoop Property

ITopologyCurveCurveLoop Property

Returns the loop a curve belongs to

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ITopologyCurveLoop CurveLoop { get; }
property ITopologyCurveLoop^ CurveLoop {
    ITopologyCurveLoop^ get ();
}

Property Value

Type: ITopologyCurveLoop
See Also

Reference

ITopologyCurve Interface
VisualComponents.Create3D Namespace


ITopologyCurve.Face Property

ITopologyCurveFace Property

Returns the face a curve belongs to.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ITopologyFace Face { get; }
property ITopologyFace^ Face {
    ITopologyFace^ get ();
}

Property Value

Type: ITopologyFace
See Also

Reference

ITopologyCurve Interface
VisualComponents.Create3D Namespace


ITopologyCurve.Neighbors Property

ITopologyCurveNeighbors Property

Retrieves curves neighbor to this ITopologyCurve

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ITopologyCurve> Neighbors { get; }
property ReadOnlyCollection<ITopologyCurve^>^ Neighbors {
    ReadOnlyCollection<ITopologyCurve^>^ get ();
}

Property Value

Type: ReadOnlyCollectionITopologyCurve
See Also

Reference

ITopologyCurve Interface
VisualComponents.Create3D Namespace


ITopologyCurve Methods

The ITopologyCurve type exposes the following members.

Methods
 | Name | Description
Public method | EvaluateCurvature | In case of non-tessellated curves, computes the curvature of a curve at a given parameter (Inherited from ITopologyBaseCurve.)
Public method | GetClosestPosition | Closest position distance, path distance for the given point (Inherited from ITopologyBaseCurve.)
Public method | GetDirection | Returns direction along the curve as a Vector3 at the given distance (Inherited from ITopologyBaseCurve.)
Public method | GetPosition | Returns position along the curve as a Vector3 at the given distance (Inherited from ITopologyBaseCurve.)
Public method | GetPositions | Create curve points by using tessellation criterias. Remarks This method returns positions only if the curve is of type Polyline or Spline. (Inherited from ITopologyBaseCurve.)
Public method | GetPositions(Double, Double, Double) | Create curve points by using tessellation criterias. Remarks This method returns positions only if the curve is of type Polyline or Spline. (Inherited from ITopologyBaseCurve.)
Top
See Also

Reference

ITopologyCurve Interface
VisualComponents.Create3D Namespace


ITopologyCurveLoop Interface

Curve loop topological information

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ITopologyCurveLoop
public interface class ITopologyCurveLoop

The ITopologyCurveLoop type exposes the following members.

Properties
 | Name | Description
Public property | Curves | Retrieves curves inside this ITopologyCurve
Public property | Face | Face owner of this ITopologyFace
Public property | Length | For tesselated curve it represents the number of points.
Public property | LoopIndex | Loop index.
Public property | Outer | Specifies if this is an outer or inner ITopologyCurveLoop
Top
See Also

Reference

VisualComponents.Create3D Namespace


ITopologyCurveLoop Properties

The ITopologyCurveLoop type exposes the following members.

Properties
 | Name | Description
Public property | Curves | Retrieves curves inside this ITopologyCurve
Public property | Face | Face owner of this ITopologyFace
Public property | Length | For tesselated curve it represents the number of points.
Public property | LoopIndex | Loop index.
Public property | Outer | Specifies if this is an outer or inner ITopologyCurveLoop
Top
See Also

Reference

ITopologyCurveLoop Interface
VisualComponents.Create3D Namespace


ITopologyCurveLoop.Curves Property

ITopologyCurveLoopCurves Property

Retrieves curves inside this ITopologyCurve

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ITopologyCurve> Curves { get; }
property ReadOnlyCollection<ITopologyCurve^>^ Curves {
    ReadOnlyCollection<ITopologyCurve^>^ get ();
}

Property Value

Type: ReadOnlyCollectionITopologyCurve
See Also

Reference

ITopologyCurveLoop Interface
VisualComponents.Create3D Namespace


ITopologyCurveLoop.Face Property

ITopologyCurveLoopFace Property

Face owner of this ITopologyFace

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ITopologyFace Face { get; }
property ITopologyFace^ Face {
    ITopologyFace^ get ();
}

Property Value

Type: ITopologyFace
See Also

Reference

ITopologyCurveLoop Interface
VisualComponents.Create3D Namespace


ITopologyCurveLoop.Length Property

ITopologyCurveLoopLength Property

For tesselated curve it represents the number of points.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Length { get; }
property double Length {
    double get ();
}

Property Value

Type: Double
See Also

Reference

ITopologyCurveLoop Interface
VisualComponents.Create3D Namespace


ITopologyCurveLoop.LoopIndex Property

ITopologyCurveLoopLoopIndex Property

Loop index.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int LoopIndex { get; }
property int LoopIndex {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ITopologyCurveLoop Interface
VisualComponents.Create3D Namespace


ITopologyCurveLoop.Outer Property

ITopologyCurveLoopOuter Property

Specifies if this is an outer or inner ITopologyCurveLoop

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool Outer { get; }
property bool Outer {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ITopologyCurveLoop Interface
VisualComponents.Create3D Namespace


ITopologyFace Interface

Face topological information

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ITopologyFace
public interface class ITopologyFace

The ITopologyFace type exposes the following members.

Properties
 | Name | Description
Public property | Bound | Bound of the ITopoFace
Public property | CurveLoops | Retrieves curve loops from this ITopoFace
Public property | Face | Convert this topology face reference to IFace reference.
Public property | Index | Face Index
Public property | IsPlanar | Defines if the face is planar
Top
See Also

Reference

VisualComponents.Create3D Namespace


ITopologyFace Properties

The ITopologyFace type exposes the following members.

Properties
 | Name | Description
Public property | Bound | Bound of the ITopoFace
Public property | CurveLoops | Retrieves curve loops from this ITopoFace
Public property | Face | Convert this topology face reference to IFace reference.
Public property | Index | Face Index
Public property | IsPlanar | Defines if the face is planar
Top
See Also

Reference

ITopologyFace Interface
VisualComponents.Create3D Namespace


ITopologyFace.Bound Property

ITopologyFaceBound Property

Bound of the ITopoFace

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IBoundBox Bound { get; }
property IBoundBox^ Bound {
    IBoundBox^ get ();
}

Property Value

Type: IBoundBox
See Also

Reference

ITopologyFace Interface
VisualComponents.Create3D Namespace


ITopologyFace.CurveLoops Property

ITopologyFaceCurveLoops Property

Retrieves curve loops from this ITopoFace

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ITopologyCurveLoop> CurveLoops { get; }
property ReadOnlyCollection<ITopologyCurveLoop^>^ CurveLoops {
    ReadOnlyCollection<ITopologyCurveLoop^>^ get ();
}

Property Value

Type: ReadOnlyCollectionITopologyCurveLoop
See Also

Reference

ITopologyFace Interface
VisualComponents.Create3D Namespace


ITopologyFace.Face Property

ITopologyFaceFace Property

Convert this topology face reference to IFace reference.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFace Face { get; }
property IFace^ Face {
    IFace^ get ();
}

Property Value

Type: IFace
See Also

Reference

ITopologyFace Interface
VisualComponents.Create3D Namespace


ITopologyFace.Index Property

ITopologyFaceIndex Property

Face Index

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int Index { get; }
property int Index {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ITopologyFace Interface
VisualComponents.Create3D Namespace


ITopologyFace.IsPlanar Property

ITopologyFaceIsPlanar Property

Defines if the face is planar

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsPlanar { get; }
property bool IsPlanar {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ITopologyFace Interface
VisualComponents.Create3D Namespace


ITransformFeature Interface

Represents a transform feature object

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ITransformFeature : IFeature,
    IVisualObject, INamed, IWrapper, IDisposable, IVisitable,
    IPropertyContainer, IBatchModeObject, ISharedCloneable
public interface class ITransformFeature : IFeature,
    IVisualObject, INamed, IWrapper, IDisposable, IVisitable,
    IPropertyContainer, IBatchModeObject, ISharedCloneable

The ITransformFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | Expression | Expression that defines the transformation to apply
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
Applies a user defined transformation to all sub trees of a feature. This operation feature is essential when creating parametric components
See Also

Reference

VisualComponents.Create3D Namespace


ITransformFeature Properties

The ITransformFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | Expression | Expression that defines the transformation to apply
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
See Also

Reference

ITransformFeature Interface
VisualComponents.Create3D Namespace


ITransformFeature.Expression Property

ITransformFeatureExpression Property

Expression that defines the transformation to apply

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Expression { get; set; }
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
This must be a matrix expression, and it can contain user defined parameters.
See Also

Reference

ITransformFeature Interface
VisualComponents.Create3D Namespace


ITransformFeature Methods

The ITransformFeature type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ITransformFeature Interface
VisualComponents.Create3D Namespace


ITransformFeature Events

The ITransformFeature type exposes the following members.

Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

ITransformFeature Interface
VisualComponents.Create3D Namespace


ITranslationRotationService Interface

ITranslationRotationService privides methods to rotate and translate an IPosition target. It provides a method to get the position in which the manipulation handler for this target should be located in the 3d World. Additionaly, a handle can be set so the service will update its position automatically after each transformation in the target

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ITranslationRotationService : INotifyPropertyChanged
public interface class ITranslationRotationService : INotifyPropertyChanged

The ITranslationRotationService type exposes the following members.

Properties
 | Name | Description
Public property | ApplyGridRotation | To notify about changes when using grid for rotation
Public property | ApplyGridTranslation | To notify about changes when using grid for translation
Public property | CoordinateSystem | Returns the current coordinate system
Public property | GridRotationValue | To notify about changes about grid rotation value changes
Public property | GridTranslationValue | To notify about changes about grid translation value changes
Public property | Position | Gets or sets the position of the target in current coordinate system
Public property | Target | Gets or sets the target in which the service operations will be apply. Inside ItemSelectedMessage messages this reference can be trusted to point to the right target. Note that this reference changes on translation and rotation actions. More persistent reference can be found in IManipulateViewModel.Target and IComponentEditorExViewModel.SelectedObject.
Public property | TranslateDelta | Accomulated delta value use in future translation
Top
Methods
 | Name | Description
Public method | CorrectPositionToGrid | Corrects the nextPosition if grid value is in use
Public method | CreateDofManipulationTarget |
Public method | CreateLocalManipulationTarget |
Public method | CreateManipulationTarget(IEnumerableIVisualObject) | Creates a new manipulation target and sets it as the target of the service
Public method | CreateManipulationTarget(IVisualObject) |
Public method | CreateNonvisualManipulationTarget |
Public method | CreateOriginManipulationTarget |
Public method | CreatePhysicsJointD6ManipulationTarget |
Public method | CreateRobotManipulationTarget(IRobot) |
Public method | CreateRobotManipulationTarget(IRobot, IServoController) |
Public method | CreateRobotPositionManipulationTarget |
Public method | GetGridOriginInWorld | Gets the origin position and orientation of the translation snapping grid in world coordinates.
Public method | GetHandleIn | Get the handle position of the target in the given coodinate system.
Public method | GetPositionIn(CoordinateSystem) |
Public method | GetPositionIn(IManipulationTarget, CoordinateSystem) | Gets the position of the target in given coordinate system
Public method | ResetTranslateDelta | Resets accomulated delta value used in future translations
Public method | RotateQuaternion | Quaternion Rotation ADDS the angle of the given axis
Public method | RotateWPR(IManipulationTarget, Double, Double, Double, OperationType) | Euler rotation a,b,c degree about the X, Y, Z axes using XYZ order. Rotation pivot is the center of the target.
Public method | RotateWPR(IManipulationTarget, Double, Double, Double, OperationType, EulerRotationOrder) | Euler rotation a,b,c degree about the X, Y, Z axes and Using pivot as the center of the rotation.
Public method | RotateWPRIn | Rotate in coordinate system defined by coordinateSystemMatrix matrix.
Public method | SetHandleIn | Set the handle position of the target in the given coodinate system.
Public method | SetPositionIn | Sets the position of the target in given coordinate system
Public method | SetPositionValidator | Optional. Validator will be call after each transformation
Public method | SetWPR | Sets the yaw, pitch and roll of the selected object in the currently used coordinate system.
Public method | SnapToRotationGrid | Snaps the argument vector direction to the currently applied rotation grid.
Public method | Translate(IManipulationTarget, Vector3, OperationType) | Translate according to offset values of the given vector
Public method | Translate(IManipulationTarget, Vector3, OperationType, CoordinateSystem) | Translate according to offset values of the given vector
Public method | Translate(IManipulationTarget, Vector3, OperationType, CoordinateSystem, Boolean) | Translate according to offset values of the given vector
Public method | TranslateIn | Translate in coordinate system defined in coordinateSystemMatrix matrix.
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ITranslationRotationService Properties

The ITranslationRotationService type exposes the following members.

Properties
 | Name | Description
Public property | ApplyGridRotation | To notify about changes when using grid for rotation
Public property | ApplyGridTranslation | To notify about changes when using grid for translation
Public property | CoordinateSystem | Returns the current coordinate system
Public property | GridRotationValue | To notify about changes about grid rotation value changes
Public property | GridTranslationValue | To notify about changes about grid translation value changes
Public property | Position | Gets or sets the position of the target in current coordinate system
Public property | Target | Gets or sets the target in which the service operations will be apply. Inside ItemSelectedMessage messages this reference can be trusted to point to the right target. Note that this reference changes on translation and rotation actions. More persistent reference can be found in IManipulateViewModel.Target and IComponentEditorExViewModel.SelectedObject.
Public property | TranslateDelta | Accomulated delta value use in future translation
Top
See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.ApplyGridRotation Property

ITranslationRotationServiceApplyGridRotation Property

To notify about changes when using grid for rotation

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ApplyGridRotation { get; set; }
property bool ApplyGridRotation {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.ApplyGridTranslation Property

ITranslationRotationServiceApplyGridTranslation Property

To notify about changes when using grid for translation

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ApplyGridTranslation { get; set; }
property bool ApplyGridTranslation {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.CoordinateSystem Property

ITranslationRotationServiceCoordinateSystem Property

Returns the current coordinate system

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
CoordinateSystem CoordinateSystem { get; set; }
property CoordinateSystem CoordinateSystem {
    CoordinateSystem get ();
    void set (CoordinateSystem value);
}

Property Value

Type: CoordinateSystem
See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.GridRotationValue Property

ITranslationRotationServiceGridRotationValue Property

To notify about changes about grid rotation value changes

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double GridRotationValue { get; set; }
property double GridRotationValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.GridTranslationValue Property

ITranslationRotationServiceGridTranslationValue Property

To notify about changes about grid translation value changes

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double GridTranslationValue { get; set; }
property double GridTranslationValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.Position Property

ITranslationRotationServicePosition Property

Gets or sets the position of the target in current coordinate system

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix Position { get; set; }
property Matrix Position {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.Target Property

ITranslationRotationServiceTarget Property

Gets or sets the target in which the service operations will be apply. Inside ItemSelectedMessage messages this reference can be trusted to point to the right target. Note that this reference changes on translation and rotation actions. More persistent reference can be found in IManipulateViewModel.Target and IComponentEditorExViewModel.SelectedObject.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IManipulationTarget Target { get; set; }
property IManipulationTarget^ Target {
    IManipulationTarget^ get ();
    void set (IManipulationTarget^ value);
}

Property Value

Type: IManipulationTarget
See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.TranslateDelta Property

ITranslationRotationServiceTranslateDelta Property

Accomulated delta value use in future translation

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Nullable<Vector3> TranslateDelta { get; }
property Nullable<Vector3> TranslateDelta {
    Nullable<Vector3> get ();
}

Property Value

Type: NullableVector3
See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService Methods

The ITranslationRotationService type exposes the following members.

Methods
 | Name | Description
Public method | CorrectPositionToGrid | Corrects the nextPosition if grid value is in use
Public method | CreateDofManipulationTarget |
Public method | CreateLocalManipulationTarget |
Public method | CreateManipulationTarget(IEnumerableIVisualObject) | Creates a new manipulation target and sets it as the target of the service
Public method | CreateManipulationTarget(IVisualObject) |
Public method | CreateNonvisualManipulationTarget |
Public method | CreateOriginManipulationTarget |
Public method | CreatePhysicsJointD6ManipulationTarget |
Public method | CreateRobotManipulationTarget(IRobot) |
Public method | CreateRobotManipulationTarget(IRobot, IServoController) |
Public method | CreateRobotPositionManipulationTarget |
Public method | GetGridOriginInWorld | Gets the origin position and orientation of the translation snapping grid in world coordinates.
Public method | GetHandleIn | Get the handle position of the target in the given coodinate system.
Public method | GetPositionIn(CoordinateSystem) |
Public method | GetPositionIn(IManipulationTarget, CoordinateSystem) | Gets the position of the target in given coordinate system
Public method | ResetTranslateDelta | Resets accomulated delta value used in future translations
Public method | RotateQuaternion | Quaternion Rotation ADDS the angle of the given axis
Public method | RotateWPR(IManipulationTarget, Double, Double, Double, OperationType) | Euler rotation a,b,c degree about the X, Y, Z axes using XYZ order. Rotation pivot is the center of the target.
Public method | RotateWPR(IManipulationTarget, Double, Double, Double, OperationType, EulerRotationOrder) | Euler rotation a,b,c degree about the X, Y, Z axes and Using pivot as the center of the rotation.
Public method | RotateWPRIn | Rotate in coordinate system defined by coordinateSystemMatrix matrix.
Public method | SetHandleIn | Set the handle position of the target in the given coodinate system.
Public method | SetPositionIn | Sets the position of the target in given coordinate system
Public method | SetPositionValidator | Optional. Validator will be call after each transformation
Public method | SetWPR | Sets the yaw, pitch and roll of the selected object in the currently used coordinate system.
Public method | SnapToRotationGrid | Snaps the argument vector direction to the currently applied rotation grid.
Public method | Translate(IManipulationTarget, Vector3, OperationType) | Translate according to offset values of the given vector
Public method | Translate(IManipulationTarget, Vector3, OperationType, CoordinateSystem) | Translate according to offset values of the given vector
Public method | Translate(IManipulationTarget, Vector3, OperationType, CoordinateSystem, Boolean) | Translate according to offset values of the given vector
Public method | TranslateIn | Translate in coordinate system defined in coordinateSystemMatrix matrix.
Top
See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.CorrectPositionToGrid Method

ITranslationRotationServiceCorrectPositionToGrid Method

Corrects the nextPosition if grid value is in use

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix CorrectPositionToGrid(
    Matrix currentPosition,
    Matrix nextPosition
)
Matrix CorrectPositionToGrid(
    Matrix currentPosition,
    Matrix nextPosition
)

Parameters

currentPosition
Type: VisualComponents.Create3DMatrix
nextPosition
Type: VisualComponents.Create3DMatrix

Return Value

Type: Matrix
corrected matrix
See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.CreateDofManipulationTarget Method

ITranslationRotationServiceCreateDofManipulationTarget Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IManipulationTarget CreateDofManipulationTarget(
    IDof dofItem
)
IManipulationTarget^ CreateDofManipulationTarget(
    IDof^ dofItem
)

Parameters

dofItem
Type: VisualComponents.Create3DIDof

Return Value

Type: IManipulationTarget

[Missing <returns> documentation for "M:VisualComponents.Create3D.ITranslationRotationService.CreateDofManipulationTarget(VisualComponents.Create3D.IDof)"]

See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.CreateLocalManipulationTarget Method

ITranslationRotationServiceCreateLocalManipulationTarget Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IManipulationTarget CreateLocalManipulationTarget(
    IEnumerable<IVisualObject> targetItems,
    IVisualObject referenceObject,
    Nullable<bool> moveOnRelease
)
IManipulationTarget^ CreateLocalManipulationTarget(
    IEnumerable<IVisualObject^>^ targetItems,
    IVisualObject^ referenceObject,
    Nullable<bool> moveOnRelease
)

Parameters

targetItems
Type: System.Collections.GenericIEnumerableIVisualObject
referenceObject
Type: VisualComponents.Create3DIVisualObject
moveOnRelease
Type: SystemNullableBoolean

Return Value

Type: IManipulationTarget

[Missing <returns> documentation for "M:VisualComponents.Create3D.ITranslationRotationService.CreateLocalManipulationTarget(System.Collections.Generic.IEnumerable{VisualComponents.Create3D.IVisualObject},VisualComponents.Create3D.IVisualObject,System.Nullable{System.Boolean})"]

See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.CreateManipulationTarget Method

ITranslationRotationServiceCreateManipulationTarget Method

Overload List
 | Name | Description
Public method | CreateManipulationTarget(IEnumerableIVisualObject) | Creates a new manipulation target and sets it as the target of the service
Public method | CreateManipulationTarget(IVisualObject) |
Top
See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.CreateManipulationTarget Method (IEnumerable(IVisualObject))

ITranslationRotationServiceCreateManipulationTarget Method (IEnumerableIVisualObject)

Creates a new manipulation target and sets it as the target of the service

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IManipulationTarget CreateManipulationTarget(
    IEnumerable<IVisualObject> targetItems
)
IManipulationTarget^ CreateManipulationTarget(
    IEnumerable<IVisualObject^>^ targetItems
)

Parameters

targetItems
Type: System.Collections.GenericIEnumerableIVisualObject

Return Value

Type: IManipulationTarget

[Missing <returns> documentation for "M:VisualComponents.Create3D.ITranslationRotationService.CreateManipulationTarget(System.Collections.Generic.IEnumerable{VisualComponents.Create3D.IVisualObject})"]

See Also

Reference

ITranslationRotationService Interface
CreateManipulationTarget Overload
VisualComponents.Create3D Namespace


ITranslationRotationService.CreateManipulationTarget Method (IVisualObject)

ITranslationRotationServiceCreateManipulationTarget Method (IVisualObject)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IManipulationTarget CreateManipulationTarget(
    IVisualObject targetItem
)
IManipulationTarget^ CreateManipulationTarget(
    IVisualObject^ targetItem
)

Parameters

targetItem
Type: VisualComponents.Create3DIVisualObject

Return Value

Type: IManipulationTarget

[Missing <returns> documentation for "M:VisualComponents.Create3D.ITranslationRotationService.CreateManipulationTarget(VisualComponents.Create3D.IVisualObject)"]

See Also

Reference

ITranslationRotationService Interface
CreateManipulationTarget Overload
VisualComponents.Create3D Namespace


ITranslationRotationService.CreateNonvisualManipulationTarget Method

ITranslationRotationServiceCreateNonvisualManipulationTarget Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
INonvisualManipulationTarget CreateNonvisualManipulationTarget()
INonvisualManipulationTarget^ CreateNonvisualManipulationTarget()

Return Value

Type: INonvisualManipulationTarget

[Missing <returns> documentation for "M:VisualComponents.Create3D.ITranslationRotationService.CreateNonvisualManipulationTarget"]

See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.CreateOriginManipulationTarget Method

ITranslationRotationServiceCreateOriginManipulationTarget Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IOriginManipulationTarget CreateOriginManipulationTarget(
    IVisualObject robot,
    IVisualObject referenceObject
)
IOriginManipulationTarget^ CreateOriginManipulationTarget(
    IVisualObject^ robot,
    IVisualObject^ referenceObject
)

Parameters

robot
Type: VisualComponents.Create3DIVisualObject
referenceObject
Type: VisualComponents.Create3DIVisualObject

Return Value

Type: IOriginManipulationTarget

[Missing <returns> documentation for "M:VisualComponents.Create3D.ITranslationRotationService.CreateOriginManipulationTarget(VisualComponents.Create3D.IVisualObject,VisualComponents.Create3D.IVisualObject)"]

See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.CreatePhysicsJointD6ManipulationTarget Method

ITranslationRotationServiceCreatePhysicsJointD6ManipulationTarget Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IManipulationTarget CreatePhysicsJointD6ManipulationTarget(
    IEnumerable<IBehavior> targetItems
)
IManipulationTarget^ CreatePhysicsJointD6ManipulationTarget(
    IEnumerable<IBehavior^>^ targetItems
)

Parameters

targetItems
Type: System.Collections.GenericIEnumerableIBehavior

Return Value

Type: IManipulationTarget

[Missing <returns> documentation for "M:VisualComponents.Create3D.ITranslationRotationService.CreatePhysicsJointD6ManipulationTarget(System.Collections.Generic.IEnumerable{VisualComponents.Create3D.IBehavior})"]

See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.CreateRobotManipulationTarget Method

ITranslationRotationServiceCreateRobotManipulationTarget Method

Overload List
 | Name | Description
Public method | CreateRobotManipulationTarget(IRobot) |
Public method | CreateRobotManipulationTarget(IRobot, IServoController) |
Top
See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.CreateRobotManipulationTarget Method (IRobot)

ITranslationRotationServiceCreateRobotManipulationTarget Method (IRobot)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IManipulationTarget CreateRobotManipulationTarget(
    IRobot robot
)
IManipulationTarget^ CreateRobotManipulationTarget(
    IRobot^ robot
)

Parameters

robot
Type: VisualComponents.Create3DIRobot

Return Value

Type: IManipulationTarget

[Missing <returns> documentation for "M:VisualComponents.Create3D.ITranslationRotationService.CreateRobotManipulationTarget(VisualComponents.Create3D.IRobot)"]

See Also

Reference

ITranslationRotationService Interface
CreateRobotManipulationTarget Overload
VisualComponents.Create3D Namespace


ITranslationRotationService.CreateRobotManipulationTarget Method (IRobot, IServoController)

ITranslationRotationServiceCreateRobotManipulationTarget Method (IRobot, IServoController)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IManipulationTarget CreateRobotManipulationTarget(
    IRobot robot,
    IServoController activeController
)
IManipulationTarget^ CreateRobotManipulationTarget(
    IRobot^ robot,
    IServoController^ activeController
)

Parameters

robot
Type: VisualComponents.Create3DIRobot
activeController
Type: VisualComponents.Create3DIServoController

Return Value

Type: IManipulationTarget

[Missing <returns> documentation for "M:VisualComponents.Create3D.ITranslationRotationService.CreateRobotManipulationTarget(VisualComponents.Create3D.IRobot,VisualComponents.Create3D.IServoController)"]

See Also

Reference

ITranslationRotationService Interface
CreateRobotManipulationTarget Overload
VisualComponents.Create3D Namespace


ITranslationRotationService.CreateRobotPositionManipulationTarget Method

ITranslationRotationServiceCreateRobotPositionManipulationTarget Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IManipulationTarget CreateRobotPositionManipulationTarget(
    IRobot robot,
    IEnumerable<IPositionStatement> statements,
    IEnumerable<IPositionFrame> position
)
IManipulationTarget^ CreateRobotPositionManipulationTarget(
    IRobot^ robot,
    IEnumerable<IPositionStatement^>^ statements,
    IEnumerable<IPositionFrame^>^ position
)

Parameters

robot
Type: VisualComponents.Create3DIRobot
statements
Type: System.Collections.GenericIEnumerableIPositionStatement
position
Type: System.Collections.GenericIEnumerableIPositionFrame

Return Value

Type: IManipulationTarget

[Missing <returns> documentation for "M:VisualComponents.Create3D.ITranslationRotationService.CreateRobotPositionManipulationTarget(VisualComponents.Create3D.IRobot,System.Collections.Generic.IEnumerable{VisualComponents.Create3D.IPositionStatement},System.Collections.Generic.IEnumerable{VisualComponents.Create3D.IPositionFrame})"]

See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.GetGridOriginInWorld Method

ITranslationRotationServiceGetGridOriginInWorld Method

Gets the origin position and orientation of the translation snapping grid in world coordinates.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix GetGridOriginInWorld()
Matrix GetGridOriginInWorld()

Return Value

Type: Matrix

[Missing <returns> documentation for "M:VisualComponents.Create3D.ITranslationRotationService.GetGridOriginInWorld"]

See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.GetHandleIn Method

ITranslationRotationServiceGetHandleIn Method

Get the handle position of the target in the given coodinate system.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix GetHandleIn(
    IManipulationTarget target,
    CoordinateSystem coordinateSystem
)
Matrix GetHandleIn(
    IManipulationTarget^ target,
    CoordinateSystem coordinateSystem
)

Parameters

target
Type: VisualComponents.Create3DIManipulationTarget
coordinateSystem
Type: VisualComponents.Create3DCoordinateSystem

Return Value

Type: Matrix

[Missing <returns> documentation for "M:VisualComponents.Create3D.ITranslationRotationService.GetHandleIn(VisualComponents.Create3D.IManipulationTarget,VisualComponents.Create3D.CoordinateSystem)"]

See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.GetPositionIn Method

ITranslationRotationServiceGetPositionIn Method

Overload List
 | Name | Description
Public method | GetPositionIn(CoordinateSystem) |
Public method | GetPositionIn(IManipulationTarget, CoordinateSystem) | Gets the position of the target in given coordinate system
Top
See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.GetPositionIn Method (CoordinateSystem)

ITranslationRotationServiceGetPositionIn Method (CoordinateSystem)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix GetPositionIn(
    CoordinateSystem coordinateSystem
)
Matrix GetPositionIn(
    CoordinateSystem coordinateSystem
)

Parameters

coordinateSystem
Type: VisualComponents.Create3DCoordinateSystem

Return Value

Type: Matrix

[Missing <returns> documentation for "M:VisualComponents.Create3D.ITranslationRotationService.GetPositionIn(VisualComponents.Create3D.CoordinateSystem)"]

See Also

Reference

ITranslationRotationService Interface
GetPositionIn Overload
VisualComponents.Create3D Namespace


ITranslationRotationService.GetPositionIn Method (IManipulationTarget, CoordinateSystem)

ITranslationRotationServiceGetPositionIn Method (IManipulationTarget, CoordinateSystem)

Gets the position of the target in given coordinate system

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix GetPositionIn(
    IManipulationTarget target,
    CoordinateSystem coordinateSystem
)
Matrix GetPositionIn(
    IManipulationTarget^ target,
    CoordinateSystem coordinateSystem
)

Parameters

target
Type: VisualComponents.Create3DIManipulationTarget
coordinateSystem
Type: VisualComponents.Create3DCoordinateSystem

Return Value

Type: Matrix
Position matrix
See Also

Reference

ITranslationRotationService Interface
GetPositionIn Overload
VisualComponents.Create3D Namespace


ITranslationRotationService.ResetTranslateDelta Method

ITranslationRotationServiceResetTranslateDelta Method

Resets accomulated delta value used in future translations

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ResetTranslateDelta()
void ResetTranslateDelta()
See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.RotateQuaternion Method

ITranslationRotationServiceRotateQuaternion Method

Quaternion Rotation ADDS the angle of the given axis

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool RotateQuaternion(
    Vector3 axis,
    double angle
)
bool RotateQuaternion(
    Vector3 axis,
    double angle
)

Parameters

axis
Type: VisualComponents.Create3DVector3
angle
Type: SystemDouble

Return Value

Type: Boolean
true if the current position of the target changes after the call
See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.RotateWPR Method

ITranslationRotationServiceRotateWPR Method

Overload List
 | Name | Description
Public method | RotateWPR(IManipulationTarget, Double, Double, Double, OperationType) | Euler rotation a,b,c degree about the X, Y, Z axes using XYZ order. Rotation pivot is the center of the target.
Public method | RotateWPR(IManipulationTarget, Double, Double, Double, OperationType, EulerRotationOrder) | Euler rotation a,b,c degree about the X, Y, Z axes and Using pivot as the center of the rotation.
Top
See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.RotateWPR Method (IManipulationTarget, Double, Double, Double, OperationType)

ITranslationRotationServiceRotateWPR Method (IManipulationTarget, Double, Double, Double, OperationType)

Euler rotation a,b,c degree about the X, Y, Z axes using XYZ order. Rotation pivot is the center of the target.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool RotateWPR(
    IManipulationTarget target,
    double degreeA,
    double degreeB,
    double degreeC,
    OperationType type
)
bool RotateWPR(
    IManipulationTarget^ target,
    double degreeA,
    double degreeB,
    double degreeC,
    OperationType type
)

Parameters

target
Type: VisualComponents.Create3DIManipulationTarget
degreeA
Type: SystemDouble
degreeB
Type: SystemDouble
degreeC
Type: SystemDouble
type
Type: VisualComponents.Create3DOperationType

Return Value

Type: Boolean
true the if current position of the target changes after the call
See Also

Reference

ITranslationRotationService Interface
RotateWPR Overload
VisualComponents.Create3D Namespace


ITranslationRotationService.RotateWPR Method (IManipulationTarget, Double, Double, Double, OperationType, EulerRotationOrder)

ITranslationRotationServiceRotateWPR Method (IManipulationTarget, Double, Double, Double, OperationType, EulerRotationOrder)

Euler rotation a,b,c degree about the X, Y, Z axes and Using pivot as the center of the rotation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool RotateWPR(
    IManipulationTarget target,
    double degreeA,
    double degreeB,
    double degreeC,
    OperationType type,
    EulerRotationOrder order
)
bool RotateWPR(
    IManipulationTarget^ target,
    double degreeA,
    double degreeB,
    double degreeC,
    OperationType type,
    EulerRotationOrder order
)

Parameters

target
Type: VisualComponents.Create3DIManipulationTarget
degreeA
Type: SystemDouble
degreeB
Type: SystemDouble
degreeC
Type: SystemDouble
type
Type: VisualComponents.Create3DOperationType
order
Type: VisualComponents.Create3DEulerRotationOrder

Return Value

Type: Boolean
true the if current position of the target changes after the call
See Also

Reference

ITranslationRotationService Interface
RotateWPR Overload
VisualComponents.Create3D Namespace


ITranslationRotationService.RotateWPRIn Method

ITranslationRotationServiceRotateWPRIn Method

Rotate in coordinate system defined by coordinateSystemMatrix matrix.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool RotateWPRIn(
    IManipulationTarget target,
    Matrix coordinateSystemMatrix,
    CoordinateSystem coordinatesToUse,
    Vector3 angles,
    EulerRotationOrder order
)
bool RotateWPRIn(
    IManipulationTarget^ target,
    Matrix coordinateSystemMatrix,
    CoordinateSystem coordinatesToUse,
    Vector3 angles,
    EulerRotationOrder order
)

Parameters

target
Type: VisualComponents.Create3DIManipulationTarget
coordinateSystemMatrix
Type: VisualComponents.Create3DMatrix
coordinatesToUse
Type: VisualComponents.Create3DCoordinateSystem
angles
Type: VisualComponents.Create3DVector3
order
Type: VisualComponents.Create3DEulerRotationOrder

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ITranslationRotationService.RotateWPRIn(VisualComponents.Create3D.IManipulationTarget,VisualComponents.Create3D.Matrix,VisualComponents.Create3D.CoordinateSystem,VisualComponents.Create3D.Vector3,VisualComponents.Create3D.EulerRotationOrder)"]

See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.SetHandleIn Method

ITranslationRotationServiceSetHandleIn Method

Set the handle position of the target in the given coodinate system.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetHandleIn(
    IManipulationTarget target,
    CoordinateSystem coordinateSystem,
    Matrix value
)
void SetHandleIn(
    IManipulationTarget^ target,
    CoordinateSystem coordinateSystem,
    Matrix value
)

Parameters

target
Type: VisualComponents.Create3DIManipulationTarget
coordinateSystem
Type: VisualComponents.Create3DCoordinateSystem
value
Type: VisualComponents.Create3DMatrix
See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.SetPositionIn Method

ITranslationRotationServiceSetPositionIn Method

Sets the position of the target in given coordinate system

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetPositionIn(
    IManipulationTarget target,
    CoordinateSystem coordinateSystem,
    Matrix value
)
void SetPositionIn(
    IManipulationTarget^ target,
    CoordinateSystem coordinateSystem,
    Matrix value
)

Parameters

target
Type: VisualComponents.Create3DIManipulationTarget
coordinateSystem
Type: VisualComponents.Create3DCoordinateSystem
value
Type: VisualComponents.Create3DMatrix
See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.SetPositionValidator Method

ITranslationRotationServiceSetPositionValidator Method

Optional. Validator will be call after each transformation

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetPositionValidator(
    IPositionValidator validator
)
void SetPositionValidator(
    IPositionValidator^ validator
)

Parameters

validator
Type: VisualComponents.Create3DIPositionValidator
See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.SetWPR Method

ITranslationRotationServiceSetWPR Method

Sets the yaw, pitch and roll of the selected object in the currently used coordinate system.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetWPR(
    Vector3 wpr
)
void SetWPR(
    Vector3 wpr
)

Parameters

wpr
Type: VisualComponents.Create3DVector3
Yaw, pitch and roll vector.
See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.SnapToRotationGrid Method

ITranslationRotationServiceSnapToRotationGrid Method

Snaps the argument vector direction to the currently applied rotation grid.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 SnapToRotationGrid(
    Vector3 vectorToRotate
)
Vector3 SnapToRotationGrid(
    Vector3 vectorToRotate
)

Parameters

vectorToRotate
Type: VisualComponents.Create3DVector3
Vector to snap.

Return Value

Type: Vector3
Vector of unchanged length which is oriented in the current rotation snap grid direction closest to the original vector.
See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.Translate Method

ITranslationRotationServiceTranslate Method

Overload List
 | Name | Description
Public method | Translate(IManipulationTarget, Vector3, OperationType) | Translate according to offset values of the given vector
Public method | Translate(IManipulationTarget, Vector3, OperationType, CoordinateSystem) | Translate according to offset values of the given vector
Public method | Translate(IManipulationTarget, Vector3, OperationType, CoordinateSystem, Boolean) | Translate according to offset values of the given vector
Top
See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService.Translate Method (IManipulationTarget, Vector3, OperationType)

ITranslationRotationServiceTranslate Method (IManipulationTarget, Vector3, OperationType)

Translate according to offset values of the given vector

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool Translate(
    IManipulationTarget target,
    Vector3 vector,
    OperationType type
)
bool Translate(
    IManipulationTarget^ target,
    Vector3 vector,
    OperationType type
)

Parameters

target
Type: VisualComponents.Create3DIManipulationTarget
vector
Type: VisualComponents.Create3DVector3
type
Type: VisualComponents.Create3DOperationType

Return Value

Type: Boolean
true if the current position of the target changes after the call
See Also

Reference

ITranslationRotationService Interface
Translate Overload
VisualComponents.Create3D Namespace


ITranslationRotationService.Translate Method (IManipulationTarget, Vector3, OperationType, CoordinateSystem)

ITranslationRotationServiceTranslate Method (IManipulationTarget, Vector3, OperationType, CoordinateSystem)

Translate according to offset values of the given vector

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool Translate(
    IManipulationTarget target,
    Vector3 vector,
    OperationType type,
    CoordinateSystem coordinatesToUse
)
bool Translate(
    IManipulationTarget^ target,
    Vector3 vector,
    OperationType type,
    CoordinateSystem coordinatesToUse
)

Parameters

target
Type: VisualComponents.Create3DIManipulationTarget
vector
Type: VisualComponents.Create3DVector3
type
Type: VisualComponents.Create3DOperationType
coordinatesToUse
Type: VisualComponents.Create3DCoordinateSystem

Return Value

Type: Boolean
true if the current position of the target changes after the call
See Also

Reference

ITranslationRotationService Interface
Translate Overload
VisualComponents.Create3D Namespace


ITranslationRotationService.Translate Method (IManipulationTarget, Vector3, OperationType, CoordinateSystem, Boolean)

ITranslationRotationServiceTranslate Method (IManipulationTarget, Vector3, OperationType, CoordinateSystem, Boolean)

Translate according to offset values of the given vector

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool Translate(
    IManipulationTarget target,
    Vector3 vector,
    OperationType type,
    CoordinateSystem coordinatesToUse,
    bool rememberDeltaWhenGridEnabled
)
bool Translate(
    IManipulationTarget^ target,
    Vector3 vector,
    OperationType type,
    CoordinateSystem coordinatesToUse,
    bool rememberDeltaWhenGridEnabled
)

Parameters

target
Type: VisualComponents.Create3DIManipulationTarget
vector
Type: VisualComponents.Create3DVector3
type
Type: VisualComponents.Create3DOperationType
coordinatesToUse
Type: VisualComponents.Create3DCoordinateSystem
rememberDeltaWhenGridEnabled
Type: SystemBoolean

Return Value

Type: Boolean
true if the current position of the target changes after the call
See Also

Reference

ITranslationRotationService Interface
Translate Overload
VisualComponents.Create3D Namespace


ITranslationRotationService.TranslateIn Method

ITranslationRotationServiceTranslateIn Method

Translate in coordinate system defined in coordinateSystemMatrix matrix.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool TranslateIn(
    IManipulationTarget target,
    Matrix coordinateSystemMatrix,
    CoordinateSystem coordinatesToUse,
    Vector3 vector,
    bool rememberDeltaWhenGridEnabled
)
bool TranslateIn(
    IManipulationTarget^ target,
    Matrix coordinateSystemMatrix,
    CoordinateSystem coordinatesToUse,
    Vector3 vector,
    bool rememberDeltaWhenGridEnabled
)

Parameters

target
Type: VisualComponents.Create3DIManipulationTarget
coordinateSystemMatrix
Type: VisualComponents.Create3DMatrix
coordinatesToUse
Type: VisualComponents.Create3DCoordinateSystem
vector
Type: VisualComponents.Create3DVector3
rememberDeltaWhenGridEnabled
Type: SystemBoolean

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ITranslationRotationService.TranslateIn(VisualComponents.Create3D.IManipulationTarget,VisualComponents.Create3D.Matrix,VisualComponents.Create3D.CoordinateSystem,VisualComponents.Create3D.Vector3,System.Boolean)"]

See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITranslationRotationService Events

The ITranslationRotationService type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

ITranslationRotationService Interface
VisualComponents.Create3D Namespace


ITransportController Interface

Implements transport of ISimProduct instances over ITransportLinks.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ITransportController : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class ITransportController : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The ITransportController type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsSystem | Defines whether this controller is part of the application or user-defined.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
New controllers can be created with CreateBehaviorByType(BehaviorType) using PythonTransportController. All controllers associated with the ITransportSystem instance can be accessed through Controllers getter.
See Also

Reference

VisualComponents.Create3D Namespace


ITransportController Properties

The ITransportController type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsSystem | Defines whether this controller is part of the application or user-defined.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

ITransportController Interface
VisualComponents.Create3D Namespace


ITransportController.IsSystem Property

ITransportControllerIsSystem Property

Defines whether this controller is part of the application or user-defined.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsSystem { get; }
property bool IsSystem {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ITransportController Interface
VisualComponents.Create3D Namespace


ITransportController Methods

The ITransportController type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ITransportController Interface
VisualComponents.Create3D Namespace


ITransportController Events

The ITransportController type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ITransportController Interface
VisualComponents.Create3D Namespace


ITransportInStatement Interface

Transports ISimProducts in.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ITransportInStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class ITransportInStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The ITransportInStatement type exposes the following members.

Properties
 | Name | Description
Public property | AcceptAllProductTypes | Defines whether ISimProducts of any IProductType should be accepted regardless of the other settings.
Public property | AcceptedFlowGroups | Gets an editable list of explicitly accepted IProcessFlowGroups.
Public property | AcceptedProductTypes | Gets an editable list of explicitly accepted IProductTypes.
Public property | ApiType | (Inherited from IApiType.)
Public property | AssemblyOrderVariableName | Gets or sets the name of the variable containing an object returned from the IGetAssemblyStatement. Used only if Mode is set to ProcessAssembly.
Public property | AssemblyVariableName | Gets or sets the name of the variable containing an ISimProduct that has a non-null ISimAssembly. Used only if Mode is set to ProcessAssembly.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Mode | Gets or sets the mode defining what this statement will be doing.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductPositionFrame | Gets or sets frame location where products should be placed.
Public property | ProductVariableName | Gets or sets the name of the variable where reference to the received ISimProduct instance will be stored.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReservedProductVariableName | Gets or sets the name of the variable containing products already reserved using IReserveProductStatement.
Public property | ResourcePositionFrame | Gets or sets frame location where resource will move while placing the product.
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | Source | Gets or sets the source used to transport products in.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ITransportInStatement Properties

The ITransportInStatement type exposes the following members.

Properties
 | Name | Description
Public property | AcceptAllProductTypes | Defines whether ISimProducts of any IProductType should be accepted regardless of the other settings.
Public property | AcceptedFlowGroups | Gets an editable list of explicitly accepted IProcessFlowGroups.
Public property | AcceptedProductTypes | Gets an editable list of explicitly accepted IProductTypes.
Public property | ApiType | (Inherited from IApiType.)
Public property | AssemblyOrderVariableName | Gets or sets the name of the variable containing an object returned from the IGetAssemblyStatement. Used only if Mode is set to ProcessAssembly.
Public property | AssemblyVariableName | Gets or sets the name of the variable containing an ISimProduct that has a non-null ISimAssembly. Used only if Mode is set to ProcessAssembly.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Mode | Gets or sets the mode defining what this statement will be doing.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductPositionFrame | Gets or sets frame location where products should be placed.
Public property | ProductVariableName | Gets or sets the name of the variable where reference to the received ISimProduct instance will be stored.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReservedProductVariableName | Gets or sets the name of the variable containing products already reserved using IReserveProductStatement.
Public property | ResourcePositionFrame | Gets or sets frame location where resource will move while placing the product.
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | Source | Gets or sets the source used to transport products in.
Top
See Also

Reference

ITransportInStatement Interface
VisualComponents.Create3D Namespace


ITransportInStatement.AcceptAllProductTypes Property

ITransportInStatementAcceptAllProductTypes Property

Defines whether ISimProducts of any IProductType should be accepted regardless of the other settings.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool AcceptAllProductTypes { get; set; }
property bool AcceptAllProductTypes {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ITransportInStatement Interface
VisualComponents.Create3D Namespace


ITransportInStatement.AcceptedFlowGroups Property

ITransportInStatementAcceptedFlowGroups Property

Gets an editable list of explicitly accepted IProcessFlowGroups.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IProcessFlowGroup> AcceptedFlowGroups { get; }
property IList<IProcessFlowGroup^>^ AcceptedFlowGroups {
    IList<IProcessFlowGroup^>^ get ();
}

Property Value

Type: IListIProcessFlowGroup
See Also

Reference

ITransportInStatement Interface
VisualComponents.Create3D Namespace


ITransportInStatement.AcceptedProductTypes Property

ITransportInStatementAcceptedProductTypes Property

Gets an editable list of explicitly accepted IProductTypes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IProductType> AcceptedProductTypes { get; }
property IList<IProductType^>^ AcceptedProductTypes {
    IList<IProductType^>^ get ();
}

Property Value

Type: IListIProductType
See Also

Reference

ITransportInStatement Interface
VisualComponents.Create3D Namespace


ITransportInStatement.AssemblyOrderVariableName Property

ITransportInStatementAssemblyOrderVariableName Property

Gets or sets the name of the variable containing an object returned from the IGetAssemblyStatement.

Used only if Mode is set to ProcessAssembly.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string AssemblyOrderVariableName { get; set; }
property String^ AssemblyOrderVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown by setter when supplied value is null.
See Also

Reference

ITransportInStatement Interface
VisualComponents.Create3D Namespace


ITransportInStatement.AssemblyVariableName Property

ITransportInStatementAssemblyVariableName Property

Gets or sets the name of the variable containing an ISimProduct that has a non-null ISimAssembly.

Used only if Mode is set to ProcessAssembly.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string AssemblyVariableName { get; set; }
property String^ AssemblyVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown by setter when supplied value is null.
See Also

Reference

ITransportInStatement Interface
VisualComponents.Create3D Namespace


ITransportInStatement.Mode Property

ITransportInStatementMode Property

Gets or sets the mode defining what this statement will be doing.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
TransportStatementMode Mode { get; set; }
property TransportStatementMode Mode {
    TransportStatementMode get ();
    void set (TransportStatementMode value);
}

Property Value

Type: TransportStatementMode
See Also

Reference

ITransportInStatement Interface
VisualComponents.Create3D Namespace


ITransportInStatement.ProductPositionFrame Property

ITransportInStatementProductPositionFrame Property

Gets or sets frame location where products should be placed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFrameFeature ProductPositionFrame { get; set; }
property IFrameFeature^ ProductPositionFrame {
    IFrameFeature^ get ();
    void set (IFrameFeature^ value);
}

Property Value

Type: IFrameFeature
See Also

Reference

ITransportInStatement Interface
VisualComponents.Create3D Namespace


ITransportInStatement.ProductVariableName Property

ITransportInStatementProductVariableName Property

Gets or sets the name of the variable where reference to the received ISimProduct instance will be stored.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ProductVariableName { get; set; }
property String^ ProductVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
The variable will be created if needed when this statement executes.
See Also

Reference

ITransportInStatement Interface
VisualComponents.Create3D Namespace


ITransportInStatement.ReservedProductVariableName Property

ITransportInStatementReservedProductVariableName Property

Gets or sets the name of the variable containing products already reserved using IReserveProductStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ReservedProductVariableName { get; set; }
property String^ ReservedProductVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown by setter when supplied value is null.
Remarks
Can be left as an empty string, meaning that Product reservation is not used.
See Also

Reference

ITransportInStatement Interface
VisualComponents.Create3D Namespace


ITransportInStatement.ResourcePositionFrame Property

ITransportInStatementResourcePositionFrame Property

Gets or sets frame location where resource will move while placing the product.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFrameFeature ResourcePositionFrame { get; set; }
property IFrameFeature^ ResourcePositionFrame {
    IFrameFeature^ get ();
    void set (IFrameFeature^ value);
}

Property Value

Type: IFrameFeature
See Also

Reference

ITransportInStatement Interface
VisualComponents.Create3D Namespace


ITransportInStatement.Source Property

ITransportInStatementSource Property

Gets or sets the source used to transport products in.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
TransportInType Source { get; set; }
property TransportInType Source {
    TransportInType get ();
    void set (TransportInType value);
}

Property Value

Type: TransportInType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown by getter when native Source property has an invalid value or by setter when an invalid value is supplied.
See Also

Reference

ITransportInStatement Interface
VisualComponents.Create3D Namespace


ITransportInStatement Methods

The ITransportInStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ITransportInStatement Interface
VisualComponents.Create3D Namespace


ITransportInStatement Events

The ITransportInStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

ITransportInStatement Interface
VisualComponents.Create3D Namespace


ITransportLink Interface

A logical single-directional link between two ITransportNode objects. All links are managed by ITransportSystem, so only the Implementer can be changed after the link has been created.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ITransportLink : IWrapper,
    IDisposable, IPropertyContainer, IBatchModeObject
public interface class ITransportLink : IWrapper,
    IDisposable, IPropertyContainer, IBatchModeObject

The ITransportLink type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Destination | The ITransportNode an ISimProduct should arrive to.
Public property | Implementer | Gets or sets the ITransportController that implements this link. Every link must be associated with a ITransportController.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Source | The ITransportNode an ISimProduct can start moving from.
Public property | SupportedGroup | The IProcessFlowGroup whose product types can be transported through this link.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
Links can be created or deleted through ITransportSystem.
See Also

Reference

VisualComponents.Create3D Namespace


ITransportLink Properties

The ITransportLink type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Destination | The ITransportNode an ISimProduct should arrive to.
Public property | Implementer | Gets or sets the ITransportController that implements this link. Every link must be associated with a ITransportController.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Source | The ITransportNode an ISimProduct can start moving from.
Public property | SupportedGroup | The IProcessFlowGroup whose product types can be transported through this link.
Top
See Also

Reference

ITransportLink Interface
VisualComponents.Create3D Namespace


ITransportLink.Destination Property

ITransportLinkDestination Property

The ITransportNode an ISimProduct should arrive to.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ITransportNode Destination { get; }
property ITransportNode^ Destination {
    ITransportNode^ get ();
}

Property Value

Type: ITransportNode
See Also

Reference

ITransportLink Interface
VisualComponents.Create3D Namespace


ITransportLink.Implementer Property

ITransportLinkImplementer Property

Gets or sets the ITransportController that implements this link. Every link must be associated with a ITransportController.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ITransportController Implementer { get; set; }
property ITransportController^ Implementer {
    ITransportController^ get ();
    void set (ITransportController^ value);
}

Property Value

Type: ITransportController
Exceptions
Exception | Condition
ArgumentNullException | Thrown by setter if the value is null.
See Also

Reference

ITransportLink Interface
VisualComponents.Create3D Namespace


ITransportLink.Source Property

ITransportLinkSource Property

The ITransportNode an ISimProduct can start moving from.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ITransportNode Source { get; }
property ITransportNode^ Source {
    ITransportNode^ get ();
}

Property Value

Type: ITransportNode
See Also

Reference

ITransportLink Interface
VisualComponents.Create3D Namespace


ITransportLink.SupportedGroup Property

ITransportLinkSupportedGroup Property

The IProcessFlowGroup whose product types can be transported through this link.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessFlowGroup SupportedGroup { get; }
property IProcessFlowGroup^ SupportedGroup {
    IProcessFlowGroup^ get ();
}

Property Value

Type: IProcessFlowGroup
See Also

Reference

ITransportLink Interface
VisualComponents.Create3D Namespace


ITransportLink Methods

The ITransportLink type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ITransportLink Interface
VisualComponents.Create3D Namespace


ITransportLink Events

The ITransportLink type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ITransportLink Interface
VisualComponents.Create3D Namespace


ITransportNode Interface

Defines a logical place where ISimProducts can be transported to/from.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ITransportNode : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class ITransportNode : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The ITransportNode type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ComponentContainer | Gets or sets ISimContainer this node monitors for arriving products.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | DefaultProductPositionFrame | Gets or sets default position for ISimProducts.
Public property | DefaultResourcePositionFrame | Gets or sets default position for resources.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProcessExecutor | Obsolete. Associated IProcessExecutor behavior. To set this value, set TransportNode.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | TransportLinks | Enumerates all ITransportLinks coming into or going out of this node.
Public property | TransportSystem | Gets the associated ITransportSystem.
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Public property | VisualPosition | Gets visualization position of the node in world coordinates.
Public property | VisualPositionFrame | Gets or sets visualization position of the node.
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ITransportNode Properties

The ITransportNode type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ComponentContainer | Gets or sets ISimContainer this node monitors for arriving products.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | DefaultProductPositionFrame | Gets or sets default position for ISimProducts.
Public property | DefaultResourcePositionFrame | Gets or sets default position for resources.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProcessExecutor | Obsolete. Associated IProcessExecutor behavior. To set this value, set TransportNode.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | TransportLinks | Enumerates all ITransportLinks coming into or going out of this node.
Public property | TransportSystem | Gets the associated ITransportSystem.
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Public property | VisualPosition | Gets visualization position of the node in world coordinates.
Public property | VisualPositionFrame | Gets or sets visualization position of the node.
Top
See Also

Reference

ITransportNode Interface
VisualComponents.Create3D Namespace


ITransportNode.ComponentContainer Property

ITransportNodeComponentContainer Property

Gets or sets ISimContainer this node monitors for arriving products.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimContainer ComponentContainer { get; set; }
property ISimContainer^ ComponentContainer {
    ISimContainer^ get ();
    void set (ISimContainer^ value);
}

Property Value

Type: ISimContainer
See Also

Reference

ITransportNode Interface
VisualComponents.Create3D Namespace


ITransportNode.DefaultProductPositionFrame Property

ITransportNodeDefaultProductPositionFrame Property

Gets or sets default position for ISimProducts.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFrameFeature DefaultProductPositionFrame { get; set; }
property IFrameFeature^ DefaultProductPositionFrame {
    IFrameFeature^ get ();
    void set (IFrameFeature^ value);
}

Property Value

Type: IFrameFeature
Exceptions
Exception | Condition
InvalidOperationException | Thrown by setter if frame feature does not belong to the same component.
Remarks
Must belong to the same ISimComponent as this behavior.
See Also

Reference

ITransportNode Interface
VisualComponents.Create3D Namespace


ITransportNode.DefaultResourcePositionFrame Property

ITransportNodeDefaultResourcePositionFrame Property

Gets or sets default position for resources.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFrameFeature DefaultResourcePositionFrame { get; set; }
property IFrameFeature^ DefaultResourcePositionFrame {
    IFrameFeature^ get ();
    void set (IFrameFeature^ value);
}

Property Value

Type: IFrameFeature
Exceptions
Exception | Condition
InvalidOperationException | Thrown by setter if frame feature does not belong to the same component.
Remarks
Must belong to the same ISimComponent as this behavior.
See Also

Reference

ITransportNode Interface
VisualComponents.Create3D Namespace


ITransportNode.ProcessExecutor Property

ITransportNodeProcessExecutor Property

Note: This API is now obsolete.

Associated IProcessExecutor behavior. To set this value, set TransportNode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Multiple process executors will be able to use the same transport node.")]
IProcessExecutor ProcessExecutor { get; }
[ObsoleteAttribute(L"Multiple process executors will be able to use the same transport node.")]
property IProcessExecutor^ ProcessExecutor {
    IProcessExecutor^ get ();
}

Property Value

Type: IProcessExecutor
See Also

Reference

ITransportNode Interface
VisualComponents.Create3D Namespace


ITransportNode.TransportLinks Property

ITransportNodeTransportLinks Property

Enumerates all ITransportLinks coming into or going out of this node.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<ITransportLink> TransportLinks { get; }
property IEnumerable<ITransportLink^>^ TransportLinks {
    IEnumerable<ITransportLink^>^ get ();
}

Property Value

Type: IEnumerableITransportLink
See Also

Reference

ITransportNode Interface
VisualComponents.Create3D Namespace


ITransportNode.TransportSystem Property

ITransportNodeTransportSystem Property

Gets the associated ITransportSystem.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ITransportSystem TransportSystem { get; }
property ITransportSystem^ TransportSystem {
    ITransportSystem^ get ();
}

Property Value

Type: ITransportSystem
See Also

Reference

ITransportNode Interface
VisualComponents.Create3D Namespace


ITransportNode.VisualPosition Property

ITransportNodeVisualPosition Property

Gets visualization position of the node in world coordinates.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix VisualPosition { get; }
property Matrix VisualPosition {
    Matrix get ();
}

Property Value

Type: Matrix
See Also

Reference

ITransportNode Interface
VisualComponents.Create3D Namespace


ITransportNode.VisualPositionFrame Property

ITransportNodeVisualPositionFrame Property

Gets or sets visualization position of the node.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFrameFeature VisualPositionFrame { get; set; }
property IFrameFeature^ VisualPositionFrame {
    IFrameFeature^ get ();
    void set (IFrameFeature^ value);
}

Property Value

Type: IFrameFeature
Exceptions
Exception | Condition
InvalidOperationException | Thrown by setter if frame feature does not belong to the same component.
Remarks
Must belong to the same ISimComponent as this behavior.
See Also

Reference

ITransportNode Interface
VisualComponents.Create3D Namespace


ITransportNode Methods

The ITransportNode type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ITransportNode Interface
VisualComponents.Create3D Namespace


ITransportNode Events

The ITransportNode type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ITransportNode Interface
VisualComponents.Create3D Namespace


ITransportOutStatement Interface

Transports ISimProducts out.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ITransportOutStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class ITransportOutStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The ITransportOutStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | AssemblyOrderVariableName | Gets or sets the name of the variable containing an object returned from the IGetAssemblyStatement. Used only if Mode is set to ProcessAssembly.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Container | Gets or sets IComponentContainer where outgoing products will be placed.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | Destination | Gets or sets the destination where products are transported out.
Public property | DestinationNode | Gets or sets ITransportNode products will be sent to.
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Mode | Gets or sets the mode defining what this statement will be doing.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductVariableName | Gets or sets the name of the variable which stores a reference to ISimProduct instances to be transported out. If Mode is set to ProcessAssembly, then the given ISimProduct must have a non-null ISimAssembly.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ResourcePositionFrame | Gets or sets frame location where resource will move while picking the product.
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | SendAsProductBundles | If Mode is set to ProcessAssembly, determines whether leaving products retain their child products from the assembly. Within any selected step, the first slot of a product bundle hierarchy will always leave as a separate product, or product bundle. Thus, use AssemblyOrderVariableName to control bundle grouping.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ITransportOutStatement Properties

The ITransportOutStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | AssemblyOrderVariableName | Gets or sets the name of the variable containing an object returned from the IGetAssemblyStatement. Used only if Mode is set to ProcessAssembly.
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Container | Gets or sets IComponentContainer where outgoing products will be placed.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | Destination | Gets or sets the destination where products are transported out.
Public property | DestinationNode | Gets or sets ITransportNode products will be sent to.
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Mode | Gets or sets the mode defining what this statement will be doing.
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductVariableName | Gets or sets the name of the variable which stores a reference to ISimProduct instances to be transported out. If Mode is set to ProcessAssembly, then the given ISimProduct must have a non-null ISimAssembly.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ResourcePositionFrame | Gets or sets frame location where resource will move while picking the product.
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | SendAsProductBundles | If Mode is set to ProcessAssembly, determines whether leaving products retain their child products from the assembly. Within any selected step, the first slot of a product bundle hierarchy will always leave as a separate product, or product bundle. Thus, use AssemblyOrderVariableName to control bundle grouping.
Top
See Also

Reference

ITransportOutStatement Interface
VisualComponents.Create3D Namespace


ITransportOutStatement.AssemblyOrderVariableName Property

ITransportOutStatementAssemblyOrderVariableName Property

Gets or sets the name of the variable containing an object returned from the IGetAssemblyStatement.

Used only if Mode is set to ProcessAssembly.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string AssemblyOrderVariableName { get; set; }
property String^ AssemblyOrderVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown by setter when supplied value is null.
See Also

Reference

ITransportOutStatement Interface
VisualComponents.Create3D Namespace


ITransportOutStatement.Container Property

ITransportOutStatementContainer Property

Gets or sets IComponentContainer where outgoing products will be placed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IComponentContainer Container { get; set; }
property IComponentContainer^ Container {
    IComponentContainer^ get ();
    void set (IComponentContainer^ value);
}

Property Value

Type: IComponentContainer
See Also

Reference

ITransportOutStatement Interface
VisualComponents.Create3D Namespace


ITransportOutStatement.Destination Property

ITransportOutStatementDestination Property

Gets or sets the destination where products are transported out.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
TransportOutType Destination { get; set; }
property TransportOutType Destination {
    TransportOutType get ();
    void set (TransportOutType value);
}

Property Value

Type: TransportOutType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown by getter when native Destination property has an invalid value or by setter when an invalid value is supplied.
See Also

Reference

ITransportOutStatement Interface
VisualComponents.Create3D Namespace


ITransportOutStatement.DestinationNode Property

ITransportOutStatementDestinationNode Property

Gets or sets ITransportNode products will be sent to.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ITransportNode DestinationNode { get; set; }
property ITransportNode^ DestinationNode {
    ITransportNode^ get ();
    void set (ITransportNode^ value);
}

Property Value

Type: ITransportNode
See Also

Reference

ITransportOutStatement Interface
VisualComponents.Create3D Namespace


ITransportOutStatement.Mode Property

ITransportOutStatementMode Property

Gets or sets the mode defining what this statement will be doing.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
TransportStatementMode Mode { get; set; }
property TransportStatementMode Mode {
    TransportStatementMode get ();
    void set (TransportStatementMode value);
}

Property Value

Type: TransportStatementMode
See Also

Reference

ITransportOutStatement Interface
VisualComponents.Create3D Namespace


ITransportOutStatement.ProductVariableName Property

ITransportOutStatementProductVariableName Property

Gets or sets the name of the variable which stores a reference to ISimProduct instances to be transported out.

If Mode is set to ProcessAssembly, then the given ISimProduct must have a non-null ISimAssembly.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ProductVariableName { get; set; }
property String^ ProductVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown by setter when supplied value is null.
Remarks
The variable reference is resolved when the statement executes.
See Also

Reference

ITransportOutStatement Interface
VisualComponents.Create3D Namespace


ITransportOutStatement.ResourcePositionFrame Property

ITransportOutStatementResourcePositionFrame Property

Gets or sets frame location where resource will move while picking the product.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFrameFeature ResourcePositionFrame { get; set; }
property IFrameFeature^ ResourcePositionFrame {
    IFrameFeature^ get ();
    void set (IFrameFeature^ value);
}

Property Value

Type: IFrameFeature
See Also

Reference

ITransportOutStatement Interface
VisualComponents.Create3D Namespace


ITransportOutStatement.SendAsProductBundles Property

ITransportOutStatementSendAsProductBundles Property

If Mode is set to ProcessAssembly, determines whether leaving products retain their child products from the assembly.

Within any selected step, the first slot of a product bundle hierarchy will always leave as a separate product, or product bundle. Thus, use AssemblyOrderVariableName to control bundle grouping.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SendAsProductBundles { get; set; }
property bool SendAsProductBundles {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ITransportOutStatement Interface
VisualComponents.Create3D Namespace


ITransportOutStatement Methods

The ITransportOutStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ITransportOutStatement Interface
VisualComponents.Create3D Namespace


ITransportOutStatement Events

The ITransportOutStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

ITransportOutStatement Interface
VisualComponents.Create3D Namespace


ITransportPatternInStatement Interface

Process statement for transporting in multiple products to a pattern.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ITransportPatternInStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class ITransportPatternInStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The ITransportPatternInStatement type exposes the following members.

Properties
 | Name | Description
Public property | AcceptAllProductTypes | Defines whether ISimProducts of any IProductType should be accepted regardless of the other settings.
Public property | AcceptedFlowGroups | Gets an editable list of explicitly accepted IProcessFlowGroups.
Public property | AcceptedProductTypes | Gets an editable list of explicitly accepted IProductTypes.
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Offset | Gets or sets offset of the first product from ProductPositionFrame.
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | PatternCount | Gets or sets the number of product per X,Y,Z axis.
Public property | PatternStep | Gets or sets the step between products in pattern per X,Y,Z axis.
Public property | PatternTotalCount | Gets the total number of products defined in the pattern.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductPositionFrame | Gets or sets the frame defining position and orientation of the pattern before applying the offset.
Public property | ProductVariableName | Gets or sets the name of the variable where reference to the received ISimProduct instance will be stored.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReservedProductVariableName | Gets or sets the name of the variable containing products already reserved using IReserveProductStatement.
Public property | ResourcePositionFrame | Gets or sets frame location where resource will move while placing the product.
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ITransportPatternInStatement Properties

The ITransportPatternInStatement type exposes the following members.

Properties
 | Name | Description
Public property | AcceptAllProductTypes | Defines whether ISimProducts of any IProductType should be accepted regardless of the other settings.
Public property | AcceptedFlowGroups | Gets an editable list of explicitly accepted IProcessFlowGroups.
Public property | AcceptedProductTypes | Gets an editable list of explicitly accepted IProductTypes.
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Offset | Gets or sets offset of the first product from ProductPositionFrame.
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | PatternCount | Gets or sets the number of product per X,Y,Z axis.
Public property | PatternStep | Gets or sets the step between products in pattern per X,Y,Z axis.
Public property | PatternTotalCount | Gets the total number of products defined in the pattern.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductPositionFrame | Gets or sets the frame defining position and orientation of the pattern before applying the offset.
Public property | ProductVariableName | Gets or sets the name of the variable where reference to the received ISimProduct instance will be stored.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReservedProductVariableName | Gets or sets the name of the variable containing products already reserved using IReserveProductStatement.
Public property | ResourcePositionFrame | Gets or sets frame location where resource will move while placing the product.
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
See Also

Reference

ITransportPatternInStatement Interface
VisualComponents.Create3D Namespace


ITransportPatternInStatement.AcceptAllProductTypes Property

ITransportPatternInStatementAcceptAllProductTypes Property

Defines whether ISimProducts of any IProductType should be accepted regardless of the other settings.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool AcceptAllProductTypes { get; set; }
property bool AcceptAllProductTypes {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ITransportPatternInStatement Interface
VisualComponents.Create3D Namespace


ITransportPatternInStatement.AcceptedFlowGroups Property

ITransportPatternInStatementAcceptedFlowGroups Property

Gets an editable list of explicitly accepted IProcessFlowGroups.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IProcessFlowGroup> AcceptedFlowGroups { get; }
property IList<IProcessFlowGroup^>^ AcceptedFlowGroups {
    IList<IProcessFlowGroup^>^ get ();
}

Property Value

Type: IListIProcessFlowGroup
See Also

Reference

ITransportPatternInStatement Interface
VisualComponents.Create3D Namespace


ITransportPatternInStatement.AcceptedProductTypes Property

ITransportPatternInStatementAcceptedProductTypes Property

Gets an editable list of explicitly accepted IProductTypes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IProductType> AcceptedProductTypes { get; }
property IList<IProductType^>^ AcceptedProductTypes {
    IList<IProductType^>^ get ();
}

Property Value

Type: IListIProductType
See Also

Reference

ITransportPatternInStatement Interface
VisualComponents.Create3D Namespace


ITransportPatternInStatement.Offset Property

ITransportPatternInStatementOffset Property

Gets or sets offset of the first product from ProductPositionFrame.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix Offset { get; set; }
property Matrix Offset {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

ITransportPatternInStatement Interface
VisualComponents.Create3D Namespace


ITransportPatternInStatement.PatternCount Property

ITransportPatternInStatementPatternCount Property

Gets or sets the number of product per X,Y,Z axis.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 PatternCount { get; set; }
property Vector3 PatternCount {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

ITransportPatternInStatement Interface
VisualComponents.Create3D Namespace


ITransportPatternInStatement.PatternStep Property

ITransportPatternInStatementPatternStep Property

Gets or sets the step between products in pattern per X,Y,Z axis.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 PatternStep { get; set; }
property Vector3 PatternStep {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

ITransportPatternInStatement Interface
VisualComponents.Create3D Namespace


ITransportPatternInStatement.PatternTotalCount Property

ITransportPatternInStatementPatternTotalCount Property

Gets the total number of products defined in the pattern.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int PatternTotalCount { get; }
property int PatternTotalCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ITransportPatternInStatement Interface
VisualComponents.Create3D Namespace


ITransportPatternInStatement.ProductPositionFrame Property

ITransportPatternInStatementProductPositionFrame Property

Gets or sets the frame defining position and orientation of the pattern before applying the offset.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFrameFeature ProductPositionFrame { get; set; }
property IFrameFeature^ ProductPositionFrame {
    IFrameFeature^ get ();
    void set (IFrameFeature^ value);
}

Property Value

Type: IFrameFeature
See Also

Reference

ITransportPatternInStatement Interface
VisualComponents.Create3D Namespace


ITransportPatternInStatement.ProductVariableName Property

ITransportPatternInStatementProductVariableName Property

Gets or sets the name of the variable where reference to the received ISimProduct instance will be stored.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ProductVariableName { get; set; }
property String^ ProductVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
The variable will be created if needed when this statement executes.
See Also

Reference

ITransportPatternInStatement Interface
VisualComponents.Create3D Namespace


ITransportPatternInStatement.ReservedProductVariableName Property

ITransportPatternInStatementReservedProductVariableName Property

Gets or sets the name of the variable containing products already reserved using IReserveProductStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ReservedProductVariableName { get; set; }
property String^ ReservedProductVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown by setter when supplied value is null.
Remarks
Can be left as an empty string, meaning that Product reservation is not used.
See Also

Reference

ITransportPatternInStatement Interface
VisualComponents.Create3D Namespace


ITransportPatternInStatement.ResourcePositionFrame Property

ITransportPatternInStatementResourcePositionFrame Property

Gets or sets frame location where resource will move while placing the product.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFrameFeature ResourcePositionFrame { get; set; }
property IFrameFeature^ ResourcePositionFrame {
    IFrameFeature^ get ();
    void set (IFrameFeature^ value);
}

Property Value

Type: IFrameFeature
See Also

Reference

ITransportPatternInStatement Interface
VisualComponents.Create3D Namespace


ITransportPatternInStatement Methods

The ITransportPatternInStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ITransportPatternInStatement Interface
VisualComponents.Create3D Namespace


ITransportPatternInStatement Events

The ITransportPatternInStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

ITransportPatternInStatement Interface
VisualComponents.Create3D Namespace


ITransportProtocol Interface

A transportation sender and target behaviour used to customize and standardize transportation process.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ITransportProtocol : ISimContainer,
    IFlowBehavior, IBehavior, IPropertyContainer, IBatchModeObject, IVisitable,
    IWrapper, IDisposable, INamed
public interface class ITransportProtocol : ISimContainer,
    IFlowBehavior, IBehavior, IPropertyContainer, IBatchModeObject, IVisitable,
    IWrapper, IDisposable, INamed

The ITransportProtocol type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Maximum logical capacity of the container. This determines the maximum number of components that can be contained in the container at any one time. (Inherited from ISimContainer.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Components | list of components currently contained in the container (Inherited from ISimContainer.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | HeadComponent | Returns component in the head of container (Inherited from ISimContainer.)
Public property | IsContentVisible | Defines whether components held by the container are displayed or not (Inherited from ISimContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | TailComponent | Returns component in the tail of container (Inherited from ISimContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetContainerProximity | Calculate the orthogonal distance from position to this container (Inherited from ISimContainer.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Grab | Grab the component into this container (Inherited from ISimContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ComponentArriving | Triggered when a component is arriving to the container (Inherited from ISimContainer.)
Public event | ComponentLeaving | Triggered when a component is leaving from the container (Inherited from ISimContainer.)
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ITransportProtocol Properties

The ITransportProtocol type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Maximum logical capacity of the container. This determines the maximum number of components that can be contained in the container at any one time. (Inherited from ISimContainer.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Components | list of components currently contained in the container (Inherited from ISimContainer.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | HeadComponent | Returns component in the head of container (Inherited from ISimContainer.)
Public property | IsContentVisible | Defines whether components held by the container are displayed or not (Inherited from ISimContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | TailComponent | Returns component in the tail of container (Inherited from ISimContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

ITransportProtocol Interface
VisualComponents.Create3D Namespace


ITransportProtocol Methods

The ITransportProtocol type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetContainerProximity | Calculate the orthogonal distance from position to this container (Inherited from ISimContainer.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Grab | Grab the component into this container (Inherited from ISimContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ITransportProtocol Interface
VisualComponents.Create3D Namespace


ITransportProtocol Events

The ITransportProtocol type exposes the following members.

Events
 | Name | Description
Public event | ComponentArriving | Triggered when a component is arriving to the container (Inherited from ISimContainer.)
Public event | ComponentLeaving | Triggered when a component is leaving from the container (Inherited from ISimContainer.)
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ITransportProtocol Interface
VisualComponents.Create3D Namespace


ITransportSystem Interface

Manager service for ITransportNode and ITransportLink objects that form a transportation graph.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ITransportSystem : IWrapper,
    IDisposable
public interface class ITransportSystem : IWrapper,
    IDisposable

The ITransportSystem type exposes the following members.

Properties
 | Name | Description
Public property | Controllers | Gets all available ITransportControllers (both system and user-created).
Public property | IsValid | (Inherited from IWrapper.)
Public property | Links | Gets all ITransportLinks owned by this system.
Public property | Nodes | Gets all ITransportNodes associated with this system.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProcessController | Gets IProcessController that owns this system.
Top
Methods
 | Name | Description
Public method | CopyLinks | Copies links and assignes copies to the given targetGroup.
Public method | CreateTransportLink | Creates a new transport link between source and destination nodes and registers it to the system.
Public method | DeleteTransportLink | Removes link from this system and deletes it.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindAllLinksBetweenNodeSets | Finds a set containing all ITransportLinks that are part of any valid path from any node in the sourceNodes set to any node in the sourceNodes set.
Public method | GetHashCode | (Inherited from IWrapper.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | TransportControllerAdded | Event that occurs when new ITransportController has become available.
Public event | TransportControllerRemoving | Event that occurs when ITransportController is being removed.
Public event | TransportLinkAdded | Event that occurs when new ITransportLink has been created.
Public event | TransportLinkRemoved | Event that occurs when ITransportLink is deleted.
Public event | TransportLinkRemoving | Event that occurs when ITransportLink is being deleted.
Public event | TransportNodeAdded | Event that occurs when new ITransportNode has been added.
Public event | TransportNodeRemoving | Event that occurs when ITransportNode is being removed.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ITransportSystem Properties

The ITransportSystem type exposes the following members.

Properties
 | Name | Description
Public property | Controllers | Gets all available ITransportControllers (both system and user-created).
Public property | IsValid | (Inherited from IWrapper.)
Public property | Links | Gets all ITransportLinks owned by this system.
Public property | Nodes | Gets all ITransportNodes associated with this system.
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProcessController | Gets IProcessController that owns this system.
Top
See Also

Reference

ITransportSystem Interface
VisualComponents.Create3D Namespace


ITransportSystem.Controllers Property

ITransportSystemControllers Property

Gets all available ITransportControllers (both system and user-created).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<ITransportController> Controllers { get; }
property IReadOnlyList<ITransportController^>^ Controllers {
    IReadOnlyList<ITransportController^>^ get ();
}

Property Value

Type: IReadOnlyListITransportController
See Also

Reference

ITransportSystem Interface
VisualComponents.Create3D Namespace


ITransportSystem.Links Property

ITransportSystemLinks Property

Gets all ITransportLinks owned by this system.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<ITransportLink> Links { get; }
property IReadOnlyList<ITransportLink^>^ Links {
    IReadOnlyList<ITransportLink^>^ get ();
}

Property Value

Type: IReadOnlyListITransportLink
See Also

Reference

ITransportSystem Interface
VisualComponents.Create3D Namespace


ITransportSystem.Nodes Property

ITransportSystemNodes Property

Gets all ITransportNodes associated with this system.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<ITransportNode> Nodes { get; }
property IReadOnlyList<ITransportNode^>^ Nodes {
    IReadOnlyList<ITransportNode^>^ get ();
}

Property Value

Type: IReadOnlyListITransportNode
See Also

Reference

ITransportSystem Interface
VisualComponents.Create3D Namespace


ITransportSystem.ProcessController Property

ITransportSystemProcessController Property

Gets IProcessController that owns this system.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessController ProcessController { get; }
property IProcessController^ ProcessController {
    IProcessController^ get ();
}

Property Value

Type: IProcessController
See Also

Reference

ITransportSystem Interface
VisualComponents.Create3D Namespace


ITransportSystem Methods

The ITransportSystem type exposes the following members.

Methods
 | Name | Description
Public method | CopyLinks | Copies links and assignes copies to the given targetGroup.
Public method | CreateTransportLink | Creates a new transport link between source and destination nodes and registers it to the system.
Public method | DeleteTransportLink | Removes link from this system and deletes it.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindAllLinksBetweenNodeSets | Finds a set containing all ITransportLinks that are part of any valid path from any node in the sourceNodes set to any node in the sourceNodes set.
Public method | GetHashCode | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ITransportSystem Interface
VisualComponents.Create3D Namespace


ITransportSystem.CopyLinks Method

ITransportSystemCopyLinks Method

Copies links and assignes copies to the given targetGroup.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<ITransportLink> CopyLinks(
    IEnumerable<ITransportLink> links,
    IProcessFlowGroup targetGroup
)
IReadOnlyList<ITransportLink^>^ CopyLinks(
    IEnumerable<ITransportLink^>^ links,
    IProcessFlowGroup^ targetGroup
)

Parameters

links
Type: System.Collections.GenericIEnumerableITransportLink
ITransportLinks to be copied.
targetGroup
Type: VisualComponents.Create3DIProcessFlowGroup
IProcessFlowGroup to which the copied links are assigned.

Return Value

Type: IReadOnlyListITransportLink
Copied links.
Exceptions
Exception | Condition
ArgumentNullException | Occurs when any of the arguments is null.
InvalidOperationException | Occurs when targetGroup does not belong to the owning IProcessController behavior.
See Also

Reference

ITransportSystem Interface
VisualComponents.Create3D Namespace


ITransportSystem.CreateTransportLink Method

ITransportSystemCreateTransportLink Method

Creates a new transport link between source and destination nodes and registers it to the system.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ITransportLink CreateTransportLink(
    ITransportNode source,
    ITransportNode destination,
    ITransportController implementer,
    IProcessFlowGroup group
)
ITransportLink^ CreateTransportLink(
    ITransportNode^ source,
    ITransportNode^ destination,
    ITransportController^ implementer,
    IProcessFlowGroup^ group
)

Parameters

source
Type: VisualComponents.Create3DITransportNode
Source ITransportNode of the link. Must be associated with this system.
destination
Type: VisualComponents.Create3DITransportNode
Destination ITransportNode of the link. Must be associated with this system.
implementer
Type: VisualComponents.Create3DITransportController
ITransportController that implements the link.
group
Type: VisualComponents.Create3DIProcessFlowGroup
IProcessFlowGroup the link should support.

Return Value

Type: ITransportLink
The created transport link.
Exceptions
Exception | Condition
ArgumentNullException | Occurs when any of the arguments is null.
InvalidOperationException | Occurs when source and destination are the same node, or any of them is not part of this system.
See Also

Reference

ITransportSystem Interface
VisualComponents.Create3D Namespace


ITransportSystem.DeleteTransportLink Method

ITransportSystemDeleteTransportLink Method

Removes link from this system and deletes it.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteTransportLink(
    ITransportLink link
)
void DeleteTransportLink(
    ITransportLink^ link
)

Parameters

link
Type: VisualComponents.Create3DITransportLink
The link to remove. Must be owned by this system.
Exceptions
Exception | Condition
NullReferenceException | Occurs when link is null.
InvalidOperationException | Occurs when link is not part of this system.
See Also

Reference

ITransportSystem Interface
VisualComponents.Create3D Namespace


ITransportSystem.FindAllLinksBetweenNodeSets Method

ITransportSystemFindAllLinksBetweenNodeSets Method

Finds a set containing all ITransportLinks that are part of any valid path from any node in the sourceNodes set to any node in the sourceNodes set.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<ITransportLink> FindAllLinksBetweenNodeSets(
    IEnumerable<ITransportNode> sourceNodes,
    IEnumerable<ITransportNode> destinationNodes,
    IProcessFlowGroup group
)
IReadOnlyList<ITransportLink^>^ FindAllLinksBetweenNodeSets(
    IEnumerable<ITransportNode^>^ sourceNodes,
    IEnumerable<ITransportNode^>^ destinationNodes,
    IProcessFlowGroup^ group
)

Parameters

sourceNodes
Type: System.Collections.GenericIEnumerableITransportNode
The source ITransportNode set.
destinationNodes
Type: System.Collections.GenericIEnumerableITransportNode
The destination ITransportNode set.
group
Type: VisualComponents.Create3DIProcessFlowGroup
IProcessFlowGroup all links must support.

Return Value

Type: IReadOnlyListITransportLink
Found links or an empty enumerable if no valid paths exist.
Exceptions
Exception | Condition
ArgumentNullException | Occurs when any of the arguments is null.
ArgumentException | Occurs when sourceNodes or destinationNodes set is empty.
Remarks
The sourceNodes and destinationNodes sets can overlap.
See Also

Reference

ITransportSystem Interface
VisualComponents.Create3D Namespace


ITransportSystem Events

The ITransportSystem type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | TransportControllerAdded | Event that occurs when new ITransportController has become available.
Public event | TransportControllerRemoving | Event that occurs when ITransportController is being removed.
Public event | TransportLinkAdded | Event that occurs when new ITransportLink has been created.
Public event | TransportLinkRemoved | Event that occurs when ITransportLink is deleted.
Public event | TransportLinkRemoving | Event that occurs when ITransportLink is being deleted.
Public event | TransportNodeAdded | Event that occurs when new ITransportNode has been added.
Public event | TransportNodeRemoving | Event that occurs when ITransportNode is being removed.
Top
See Also

Reference

ITransportSystem Interface
VisualComponents.Create3D Namespace


ITransportSystem.TransportControllerAdded Event

ITransportSystemTransportControllerAdded Event

Event that occurs when new ITransportController has become available.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<TransportControllerAddedEventArgs> TransportControllerAdded
 event EventHandler<TransportControllerAddedEventArgs^>^ TransportControllerAdded {
    void add (EventHandler<TransportControllerAddedEventArgs^>^ value);
    void remove (EventHandler<TransportControllerAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerTransportControllerAddedEventArgs
See Also

Reference

ITransportSystem Interface
VisualComponents.Create3D Namespace


ITransportSystem.TransportControllerRemoving Event

ITransportSystemTransportControllerRemoving Event

Event that occurs when ITransportController is being removed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<TransportControllerRemovingEventArgs> TransportControllerRemoving
 event EventHandler<TransportControllerRemovingEventArgs^>^ TransportControllerRemoving {
    void add (EventHandler<TransportControllerRemovingEventArgs^>^ value);
    void remove (EventHandler<TransportControllerRemovingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerTransportControllerRemovingEventArgs
See Also

Reference

ITransportSystem Interface
VisualComponents.Create3D Namespace


ITransportSystem.TransportLinkAdded Event

ITransportSystemTransportLinkAdded Event

Event that occurs when new ITransportLink has been created.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<TransportLinkAddedEventArgs> TransportLinkAdded
 event EventHandler<TransportLinkAddedEventArgs^>^ TransportLinkAdded {
    void add (EventHandler<TransportLinkAddedEventArgs^>^ value);
    void remove (EventHandler<TransportLinkAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerTransportLinkAddedEventArgs
See Also

Reference

ITransportSystem Interface
VisualComponents.Create3D Namespace


ITransportSystem.TransportLinkRemoved Event

ITransportSystemTransportLinkRemoved Event

Event that occurs when ITransportLink is deleted.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<TransportLinkRemovedEventArgs> TransportLinkRemoved
 event EventHandler<TransportLinkRemovedEventArgs^>^ TransportLinkRemoved {
    void add (EventHandler<TransportLinkRemovedEventArgs^>^ value);
    void remove (EventHandler<TransportLinkRemovedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerTransportLinkRemovedEventArgs
See Also

Reference

ITransportSystem Interface
VisualComponents.Create3D Namespace


ITransportSystem.TransportLinkRemoving Event

ITransportSystemTransportLinkRemoving Event

Event that occurs when ITransportLink is being deleted.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<TransportLinkRemovingEventArgs> TransportLinkRemoving
 event EventHandler<TransportLinkRemovingEventArgs^>^ TransportLinkRemoving {
    void add (EventHandler<TransportLinkRemovingEventArgs^>^ value);
    void remove (EventHandler<TransportLinkRemovingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerTransportLinkRemovingEventArgs
See Also

Reference

ITransportSystem Interface
VisualComponents.Create3D Namespace


ITransportSystem.TransportNodeAdded Event

ITransportSystemTransportNodeAdded Event

Event that occurs when new ITransportNode has been added.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<TransportNodeAddedEventArgs> TransportNodeAdded
 event EventHandler<TransportNodeAddedEventArgs^>^ TransportNodeAdded {
    void add (EventHandler<TransportNodeAddedEventArgs^>^ value);
    void remove (EventHandler<TransportNodeAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerTransportNodeAddedEventArgs
See Also

Reference

ITransportSystem Interface
VisualComponents.Create3D Namespace


ITransportSystem.TransportNodeRemoving Event

ITransportSystemTransportNodeRemoving Event

Event that occurs when ITransportNode is being removed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<TransportNodeRemovingEventArgs> TransportNodeRemoving
 event EventHandler<TransportNodeRemovingEventArgs^>^ TransportNodeRemoving {
    void add (EventHandler<TransportNodeRemovingEventArgs^>^ value);
    void remove (EventHandler<TransportNodeRemovingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerTransportNodeRemovingEventArgs
See Also

Reference

ITransportSystem Interface
VisualComponents.Create3D Namespace


ITriangleSet Interface

Interface for triangle sets.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ITriangleSet : IGeometrySet,
    IPrimitive, IWrapper, IDisposable
public interface class ITriangleSet : IGeometrySet,
    IPrimitive, IWrapper, IDisposable

The ITriangleSet type exposes the following members.

Properties
 | Name | Description
Public property | BoundBox | Returns the bound box of the geometryset. (Inherited from IGeometrySet.)
Public property | BrepAvailable | Determines if this triangle set is created from a boundary representation
Public property | Container | Geometry container object (Inherited from IGeometrySet.)
Public property | CreaseAngle | Gets or sets angle tolerance for triangle edge shading in which edge angles less than tolerance are rendered as smooth surfaces during light calculations.
Public property | Feature | IGeometryFeature owning the geoset (Inherited from IGeometrySet.)
Public property | HasMaterialInheritance | Determines if it has material inheritance (Inherited from IGeometrySet.)
Public property | HasNoHits | For internal purpose only (Inherited from IGeometrySet.)
Public property | HasTextureCoordinates | Determines if the triangle set uses texture coordinates
Public property | IsHighlighted | Determines if set is highlighted (Inherited from IGeometrySet.)
Public property | IsLayerVisible | Determine if the layer where the geometry set is located is visible (Inherited from IGeometrySet.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Determines if set is visible (Inherited from IGeometrySet.)
Public property | Material | Material of the set (Inherited from IGeometrySet.)
Public property | Name | Name of the set (Inherited from IGeometrySet.)
Public property | Normals | Returns a list of normals of each triangle
Public property | ObjectPrimitiveType | (Inherited from IPrimitive.)
Public property | Original | Retrieves the original geometry set (Inherited from IGeometrySet.)
Public property | PointCount | Number of points in TriangleSet
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Points | Returns a list of all points
Public property | Topology | Returns the topological information
Public property | TopologyCurves | Set topological information (Inherited from IGeometrySet.)
Public property | TriangleCount | Number of triangles in the TriangleSet
Public property | Triangles | Returns a list of all triangles indices. Every 3 indices compose a single triangle.
Top
Methods
 | Name | Description
Public method | AddPoint | Adds a point to the triangle set
Public method | AddPoints | Adds an array of points to the triangle set
Public method | AddTextureCoordinate | Adds texture coordinate to a vertex
Public method | AddTriangle(Int32, Int32, Int32) | Adds a triangle to the triangle st
Public method | AddTriangle(UInt32, UInt32, UInt32) | Adds a triangle to the triangle st
Public method | AddTriangles | Adds several triangles defined in an array of vertices.
Public method | AssignBrepPtr | For internal use only
Public method | Clear | Clears all geometry information from the set (Inherited from IGeometrySet.)
Public method | CompactData | Remove non-referenced points and rearrange triangles indices
Public method | CreateDecal | Creates a new mesh of a decal and it place it into a new feature located in the same parent where this set feature is. viewPoint should be pointing directly to a position in the triangleset.
Public method | Decimate(Double, Double) | Decimates the triangle set
Public method | Decimate(Double, Double, Double, Double, Double, Double, Double) | Decimates the triangle set
Public method | Delete | Deletes the set. Instance gets invalidated (Inherited from IGeometrySet.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindIntersection | Find intersection curves given a plan defined by a position and a normal
Public method | GetClosestPoint | Raycast geometry set. (Inherited from IGeometrySet.)
Public method | GetClosestTriangleEdge | Find closest triangle.
Public method | GetClosestTriangleSetPoint | Find closest point.
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetInterpolatedTextureCoordinate | Returns interpolated texture "U" and "V" coordinates in the defined 3D position for the given triangle. Coordinates are interpolated based on triangle corner "U" and "V" values.
Public method | GetTextureCoordinate | Gets the texture coordinate of a vertex
Public method | GetTriangleNormal | Gets triangle normal
Public method | GetTriangleVertex | Gets triangle 3 vertex
Public method | GetVertexNear | Find closest vertices.
Public method | HighlightEdges | highlights only the edges (does not override normal highlighting) (Inherited from IGeometrySet.)
Public method | InvertGeometry | Inverts all its geometry
Public method | MergePoints(Double, Boolean) | Merge points which are close to each other using certain tolerance value
Public method | MergePoints(IListVector3, Vector3, Double, Double) | Collapse vertices by tolerance and sanitize mesh.
Public method | MergeSet | Merges all points and triangles from given set into this one. Remarks Given set will be invalidated after this call
Public method | MergeSetBase | Merges all points and triangles from given set into this one.
Public method | NormalizeMesh | Simplify and sanitize mesh.
Public method | ResetTextureCoordinateValues | Resets the u,v values of all texture coordinates. If there are no texture coordinates, this call will create them.
Public method | SubdivideMesh | Subdivide mesh to desired resolution
Public method | ToMeshGeometry3D | Creates and returns a MeshGeometry3D object. Usefull for wpf 3d rendering.
Public method | Update | Updates set information (Inherited from IGeometrySet.)
Public method | UpdateTriangle | Updates the triangle at given index with new point indexes
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ITriangleSet Properties

The ITriangleSet type exposes the following members.

Properties
 | Name | Description
Public property | BoundBox | Returns the bound box of the geometryset. (Inherited from IGeometrySet.)
Public property | BrepAvailable | Determines if this triangle set is created from a boundary representation
Public property | Container | Geometry container object (Inherited from IGeometrySet.)
Public property | CreaseAngle | Gets or sets angle tolerance for triangle edge shading in which edge angles less than tolerance are rendered as smooth surfaces during light calculations.
Public property | Feature | IGeometryFeature owning the geoset (Inherited from IGeometrySet.)
Public property | HasMaterialInheritance | Determines if it has material inheritance (Inherited from IGeometrySet.)
Public property | HasNoHits | For internal purpose only (Inherited from IGeometrySet.)
Public property | HasTextureCoordinates | Determines if the triangle set uses texture coordinates
Public property | IsHighlighted | Determines if set is highlighted (Inherited from IGeometrySet.)
Public property | IsLayerVisible | Determine if the layer where the geometry set is located is visible (Inherited from IGeometrySet.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Determines if set is visible (Inherited from IGeometrySet.)
Public property | Material | Material of the set (Inherited from IGeometrySet.)
Public property | Name | Name of the set (Inherited from IGeometrySet.)
Public property | Normals | Returns a list of normals of each triangle
Public property | ObjectPrimitiveType | (Inherited from IPrimitive.)
Public property | Original | Retrieves the original geometry set (Inherited from IGeometrySet.)
Public property | PointCount | Number of points in TriangleSet
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Points | Returns a list of all points
Public property | Topology | Returns the topological information
Public property | TopologyCurves | Set topological information (Inherited from IGeometrySet.)
Public property | TriangleCount | Number of triangles in the TriangleSet
Public property | Triangles | Returns a list of all triangles indices. Every 3 indices compose a single triangle.
Top
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.BrepAvailable Property

ITriangleSetBrepAvailable Property

Determines if this triangle set is created from a boundary representation

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool BrepAvailable { get; }
property bool BrepAvailable {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.CreaseAngle Property

ITriangleSetCreaseAngle Property

Gets or sets angle tolerance for triangle edge shading in which edge angles less than tolerance are rendered as smooth surfaces during light calculations.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double CreaseAngle { get; set; }
property double CreaseAngle {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.HasTextureCoordinates Property

ITriangleSetHasTextureCoordinates Property

Determines if the triangle set uses texture coordinates

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool HasTextureCoordinates { get; set; }
property bool HasTextureCoordinates {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.Normals Property

ITriangleSetNormals Property

Returns a list of normals of each triangle

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<Vector3> Normals { get; }
property ReadOnlyCollection<Vector3>^ Normals {
    ReadOnlyCollection<Vector3>^ get ();
}

Property Value

Type: ReadOnlyCollectionVector3
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.PointCount Property

ITriangleSetPointCount Property

Number of points in TriangleSet

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int PointCount { get; }
property int PointCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.Points Property

ITriangleSetPoints Property

Returns a list of all points

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<Vector3> Points { get; }
property ReadOnlyCollection<Vector3>^ Points {
    ReadOnlyCollection<Vector3>^ get ();
}

Property Value

Type: ReadOnlyCollectionVector3
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.Topology Property

ITriangleSetTopology Property

Returns the topological information

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISolidTopology Topology { get; }
property ISolidTopology^ Topology {
    ISolidTopology^ get ();
}

Property Value

Type: ISolidTopology
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.TriangleCount Property

ITriangleSetTriangleCount Property

Number of triangles in the TriangleSet

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int TriangleCount { get; }
property int TriangleCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.Triangles Property

ITriangleSetTriangles Property

Returns a list of all triangles indices. Every 3 indices compose a single triangle.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<int> Triangles { get; }
property ReadOnlyCollection<int>^ Triangles {
    ReadOnlyCollection<int>^ get ();
}

Property Value

Type: ReadOnlyCollectionInt32
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet Methods

The ITriangleSet type exposes the following members.

Methods
 | Name | Description
Public method | AddPoint | Adds a point to the triangle set
Public method | AddPoints | Adds an array of points to the triangle set
Public method | AddTextureCoordinate | Adds texture coordinate to a vertex
Public method | AddTriangle(Int32, Int32, Int32) | Adds a triangle to the triangle st
Public method | AddTriangle(UInt32, UInt32, UInt32) | Adds a triangle to the triangle st
Public method | AddTriangles | Adds several triangles defined in an array of vertices.
Public method | AssignBrepPtr | For internal use only
Public method | Clear | Clears all geometry information from the set (Inherited from IGeometrySet.)
Public method | CompactData | Remove non-referenced points and rearrange triangles indices
Public method | CreateDecal | Creates a new mesh of a decal and it place it into a new feature located in the same parent where this set feature is. viewPoint should be pointing directly to a position in the triangleset.
Public method | Decimate(Double, Double) | Decimates the triangle set
Public method | Decimate(Double, Double, Double, Double, Double, Double, Double) | Decimates the triangle set
Public method | Delete | Deletes the set. Instance gets invalidated (Inherited from IGeometrySet.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindIntersection | Find intersection curves given a plan defined by a position and a normal
Public method | GetClosestPoint | Raycast geometry set. (Inherited from IGeometrySet.)
Public method | GetClosestTriangleEdge | Find closest triangle.
Public method | GetClosestTriangleSetPoint | Find closest point.
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetInterpolatedTextureCoordinate | Returns interpolated texture "U" and "V" coordinates in the defined 3D position for the given triangle. Coordinates are interpolated based on triangle corner "U" and "V" values.
Public method | GetTextureCoordinate | Gets the texture coordinate of a vertex
Public method | GetTriangleNormal | Gets triangle normal
Public method | GetTriangleVertex | Gets triangle 3 vertex
Public method | GetVertexNear | Find closest vertices.
Public method | HighlightEdges | highlights only the edges (does not override normal highlighting) (Inherited from IGeometrySet.)
Public method | InvertGeometry | Inverts all its geometry
Public method | MergePoints(Double, Boolean) | Merge points which are close to each other using certain tolerance value
Public method | MergePoints(IListVector3, Vector3, Double, Double) | Collapse vertices by tolerance and sanitize mesh.
Public method | MergeSet | Merges all points and triangles from given set into this one. Remarks Given set will be invalidated after this call
Public method | MergeSetBase | Merges all points and triangles from given set into this one.
Public method | NormalizeMesh | Simplify and sanitize mesh.
Public method | ResetTextureCoordinateValues | Resets the u,v values of all texture coordinates. If there are no texture coordinates, this call will create them.
Public method | SubdivideMesh | Subdivide mesh to desired resolution
Public method | ToMeshGeometry3D | Creates and returns a MeshGeometry3D object. Usefull for wpf 3d rendering.
Public method | Update | Updates set information (Inherited from IGeometrySet.)
Public method | UpdateTriangle | Updates the triangle at given index with new point indexes
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.AddPoint Method

ITriangleSetAddPoint Method

Adds a point to the triangle set

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
uint AddPoint(
    Vector3 point
)
unsigned int AddPoint(
    Vector3 point
)

Parameters

point
Type: VisualComponents.Create3DVector3

Return Value

Type: UInt32

[Missing <returns> documentation for "M:VisualComponents.Create3D.ITriangleSet.AddPoint(VisualComponents.Create3D.Vector3)"]

See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.AddPoints Method

ITriangleSetAddPoints Method

Adds an array of points to the triangle set

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddPoints(
    Vector3[] points
)
void AddPoints(
    array<Vector3>^ points
)

Parameters

points
Type: VisualComponents.Create3DVector3
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.AddTextureCoordinate Method

ITriangleSetAddTextureCoordinate Method

Adds texture coordinate to a vertex

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddTextureCoordinate(
    int vertex,
    double coordinateU,
    double coordinateV
)
void AddTextureCoordinate(
    int vertex,
    double coordinateU,
    double coordinateV
)

Parameters

vertex
Type: SystemInt32
vertext index
coordinateU
Type: SystemDouble
u coordinate
coordinateV
Type: SystemDouble
v coordinate
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.AddTriangle Method

ITriangleSetAddTriangle Method

Overload List
 | Name | Description
Public method | AddTriangle(Int32, Int32, Int32) | Adds a triangle to the triangle st
Public method | AddTriangle(UInt32, UInt32, UInt32) | Adds a triangle to the triangle st
Top
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.AddTriangle Method (Int32, Int32, Int32)

ITriangleSetAddTriangle Method (Int32, Int32, Int32)

Adds a triangle to the triangle st

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
uint AddTriangle(
    int vertex1,
    int vertex2,
    int vertex3
)
unsigned int AddTriangle(
    int vertex1,
    int vertex2,
    int vertex3
)

Parameters

vertex1
Type: SystemInt32
Point index 1
vertex2
Type: SystemInt32
Point index 2
vertex3
Type: SystemInt32
Point index 3

Return Value

Type: UInt32
Returns the new triangle index
See Also

Reference

ITriangleSet Interface
AddTriangle Overload
VisualComponents.Create3D Namespace


ITriangleSet.AddTriangle Method (UInt32, UInt32, UInt32)

ITriangleSetAddTriangle Method (UInt32, UInt32, UInt32)

Adds a triangle to the triangle st

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
uint AddTriangle(
    uint vertex1,
    uint vertex2,
    uint vertex3
)
unsigned int AddTriangle(
    unsigned int vertex1,
    unsigned int vertex2,
    unsigned int vertex3
)

Parameters

vertex1
Type: SystemUInt32
Point index 1
vertex2
Type: SystemUInt32
Point index 2
vertex3
Type: SystemUInt32
Point index 3

Return Value

Type: UInt32
Returns the new triangle index
See Also

Reference

ITriangleSet Interface
AddTriangle Overload
VisualComponents.Create3D Namespace


ITriangleSet.AddTriangles Method

ITriangleSetAddTriangles Method

Adds several triangles defined in an array of vertices.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddTriangles(
    int[] vertices
)
void AddTriangles(
    array<int>^ vertices
)

Parameters

vertices
Type: SystemInt32
each element represents a point index
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.AssignBrepPtr Method

ITriangleSetAssignBrepPtr Method

For internal use only

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AssignBrepPtr(
    IntPtr ptr,
    double units,
    TessellationDetail tessellation
)
void AssignBrepPtr(
    IntPtr ptr,
    double units,
    TessellationDetail tessellation
)

Parameters

ptr
Type: SystemIntPtr
units
Type: SystemDouble
tessellation
Type: VisualComponents.Create3DTessellationDetail
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.CompactData Method

ITriangleSetCompactData Method

Remove non-referenced points and rearrange triangles indices

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void CompactData()
void CompactData()
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.CreateDecal Method

ITriangleSetCreateDecal Method

Creates a new mesh of a decal and it place it into a new feature located in the same parent where this set feature is. viewPoint should be pointing directly to a position in the triangleset.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void CreateDecal(
    Matrix viewPoint,
    double width,
    double height,
    double uTiling,
    double vTiling,
    double offset
)
void CreateDecal(
    Matrix viewPoint,
    double width,
    double height,
    double uTiling,
    double vTiling,
    double offset
)

Parameters

viewPoint
Type: VisualComponents.Create3DMatrix
width
Type: SystemDouble
height
Type: SystemDouble
uTiling
Type: SystemDouble
vTiling
Type: SystemDouble
offset
Type: SystemDouble
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.Decimate Method

ITriangleSetDecimate Method

Overload List
 | Name | Description
Public method | Decimate(Double, Double) | Decimates the triangle set
Public method | Decimate(Double, Double, Double, Double, Double, Double, Double) | Decimates the triangle set
Top
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.Decimate Method (Double, Double)

ITriangleSetDecimate Method (Double, Double)

Decimates the triangle set

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Decimate(
    double maxError,
    double quality
)
double Decimate(
    double maxError,
    double quality
)

Parameters

maxError
Type: SystemDouble
Max error
quality
Type: SystemDouble
Decimation quiality

Return Value

Type: Double
Reduction factor. Number of triangles removed.
See Also

Reference

ITriangleSet Interface
Decimate Overload
VisualComponents.Create3D Namespace


ITriangleSet.Decimate Method (Double, Double, Double, Double, Double, Double, Double)

ITriangleSetDecimate Method (Double, Double, Double, Double, Double, Double, Double)

Decimates the triangle set

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Decimate(
    double boundaryVertexWeight,
    double edgeVertexWeight,
    double cornerVertexWeight,
    double surfaceErrorScale,
    double maxSurfaceError,
    double maxPositionError,
    double quality
)
double Decimate(
    double boundaryVertexWeight,
    double edgeVertexWeight,
    double cornerVertexWeight,
    double surfaceErrorScale,
    double maxSurfaceError,
    double maxPositionError,
    double quality
)

Parameters

boundaryVertexWeight
Type: SystemDouble
Boundary vertext weight
edgeVertexWeight
Type: SystemDouble
Edge vertext weight
cornerVertexWeight
Type: SystemDouble
Corner vertex weight
surfaceErrorScale
Type: SystemDouble
Surface error scale
maxSurfaceError
Type: SystemDouble
Max surface error
maxPositionError
Type: SystemDouble
Max position error
quality
Type: SystemDouble

Return Value

Type: Double
Reduction factor. Number of triangles removed.
See Also

Reference

ITriangleSet Interface
Decimate Overload
VisualComponents.Create3D Namespace


ITriangleSet.FindIntersection Method

ITriangleSetFindIntersection Method

Find intersection curves given a plan defined by a position and a normal

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool FindIntersection(
    Vector3 planePosition,
    Vector3 planeNormal,
    bool includeCoplanar,
    IList<Vector3> intersectionCurves,
    IList<int> intersectionCurveLengths
)
bool FindIntersection(
    Vector3 planePosition,
    Vector3 planeNormal,
    bool includeCoplanar,
    IList<Vector3>^ intersectionCurves,
    IList<int>^ intersectionCurveLengths
)

Parameters

planePosition
Type: VisualComponents.Create3DVector3
position of plane
planeNormal
Type: VisualComponents.Create3DVector3
normal of plane
includeCoplanar
Type: SystemBoolean
include coplanar faces
intersectionCurves
Type: System.Collections.GenericIListVector3
intersected curves
intersectionCurveLengths
Type: System.Collections.GenericIListInt32
intersected curves lenght

Return Value

Type: Boolean
True if intersection found
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.GetClosestTriangleEdge Method

ITriangleSetGetClosestTriangleEdge Method

Find closest triangle.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool GetClosestTriangleEdge(
    Vector3 edgeStart,
    Vector3 edgeEnd,
    ref int[] pointsIndexes,
    ref Vector3 resultEdgeStart,
    ref Vector3 resultEdgeEnd,
    ref int resultTriangle,
    ref int resultEdgeIndex,
    double tolerance,
    double tolerance2
)
bool GetClosestTriangleEdge(
    Vector3 edgeStart,
    Vector3 edgeEnd,
    array<int>^% pointsIndexes,
    Vector3% resultEdgeStart,
    Vector3% resultEdgeEnd,
    int% resultTriangle,
    int% resultEdgeIndex,
    double tolerance,
    double tolerance2
)

Parameters

edgeStart
Type: VisualComponents.Create3DVector3
edgeEnd
Type: VisualComponents.Create3DVector3
pointsIndexes
Type: SystemInt32
resultEdgeStart
Type: VisualComponents.Create3DVector3
resultEdgeEnd
Type: VisualComponents.Create3DVector3
resultTriangle
Type: SystemInt32
resultEdgeIndex
Type: SystemInt32
tolerance
Type: SystemDouble
tolerance2
Type: SystemDouble

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ITriangleSet.GetClosestTriangleEdge(VisualComponents.Create3D.Vector3,VisualComponents.Create3D.Vector3,System.Int32[]@,VisualComponents.Create3D.Vector3@,VisualComponents.Create3D.Vector3@,System.Int32@,System.Int32@,System.Double,System.Double)"]

See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.GetClosestTriangleSetPoint Method

ITriangleSetGetClosestTriangleSetPoint Method

Find closest point.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool GetClosestTriangleSetPoint(
    Vector3 referencePoint,
    ref Vector3 result,
    ref double distanceToTriangle,
    ref int triangleIndex,
    ref int resultFaceIndex
)
bool GetClosestTriangleSetPoint(
    Vector3 referencePoint,
    Vector3% result,
    double% distanceToTriangle,
    int% triangleIndex,
    int% resultFaceIndex
)

Parameters

referencePoint
Type: VisualComponents.Create3DVector3
result
Type: VisualComponents.Create3DVector3
distanceToTriangle
Type: SystemDouble
triangleIndex
Type: SystemInt32
resultFaceIndex
Type: SystemInt32

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ITriangleSet.GetClosestTriangleSetPoint(VisualComponents.Create3D.Vector3,VisualComponents.Create3D.Vector3@,System.Double@,System.Int32@,System.Int32@)"]

See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.GetInterpolatedTextureCoordinate Method

ITriangleSetGetInterpolatedTextureCoordinate Method

Returns interpolated texture "U" and "V" coordinates in the defined 3D position for the given triangle. Coordinates are interpolated based on triangle corner "U" and "V" values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Tuple<bool, TexturePoint> GetInterpolatedTextureCoordinate(
    int triangleIndex,
    Vector3 position
)
Tuple<bool, TexturePoint>^ GetInterpolatedTextureCoordinate(
    int triangleIndex,
    Vector3 position
)

Parameters

triangleIndex
Type: SystemInt32
Index of the triangle
position
Type: VisualComponents.Create3DVector3
Intersection position

Return Value

Type: TupleBoolean, TexturePoint
Tuple where the first item defines if the call succeeded and the second item contains the resulting texture coordinates.
Remarks
Position needs to be in triangle area and surface to get a correct result. Typically this method is used in conjunction with snapping tools which return the index of the triangle and 3D position.
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.GetTextureCoordinate Method

ITriangleSetGetTextureCoordinate Method

Gets the texture coordinate of a vertex

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
TexturePoint GetTextureCoordinate(
    int vertex
)
TexturePoint GetTextureCoordinate(
    int vertex
)

Parameters

vertex
Type: SystemInt32
vertext index

Return Value

Type: TexturePoint
TexturePoint structure
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.GetTriangleNormal Method

ITriangleSetGetTriangleNormal Method

Gets triangle normal

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 GetTriangleNormal(
    int triangleIndex
)
Vector3 GetTriangleNormal(
    int triangleIndex
)

Parameters

triangleIndex
Type: SystemInt32
Triangle index

Return Value

Type: Vector3
Triangle normal
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.GetTriangleVertex Method

ITriangleSetGetTriangleVertex Method

Gets triangle 3 vertex

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Tuple<int, int, int> GetTriangleVertex(
    int triangleIndex
)
Tuple<int, int, int>^ GetTriangleVertex(
    int triangleIndex
)

Parameters

triangleIndex
Type: SystemInt32
Triangle index

Return Value

Type: TupleInt32, Int32, Int32
3 vertex
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.GetVertexNear Method

ITriangleSetGetVertexNear Method

Find closest vertices.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void GetVertexNear(
    Vector3 referencePosition,
    double tolerance,
    ref List<Vector3> positions,
    ref List<int> indexes
)
void GetVertexNear(
    Vector3 referencePosition,
    double tolerance,
    List<Vector3>^% positions,
    List<int>^% indexes
)

Parameters

referencePosition
Type: VisualComponents.Create3DVector3
tolerance
Type: SystemDouble
positions
Type: System.Collections.GenericListVector3
indexes
Type: System.Collections.GenericListInt32
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.InvertGeometry Method

ITriangleSetInvertGeometry Method

Inverts all its geometry

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void InvertGeometry()
void InvertGeometry()

Return Value

Type:
True if operation is sucessfull
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.MergePoints Method

ITriangleSetMergePoints Method

Overload List
 | Name | Description
Public method | MergePoints(Double, Boolean) | Merge points which are close to each other using certain tolerance value
Public method | MergePoints(IListVector3, Vector3, Double, Double) | Collapse vertices by tolerance and sanitize mesh.
Top
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.MergePoints Method (Double, Boolean)

ITriangleSetMergePoints Method (Double, Boolean)

Merge points which are close to each other using certain tolerance value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool MergePoints(
    double tolerance,
    bool onlyBoundaryPoints
)
bool MergePoints(
    double tolerance,
    bool onlyBoundaryPoints
)

Parameters

tolerance
Type: SystemDouble
tolerance value in mm
onlyBoundaryPoints
Type: SystemBoolean
determines if only boundary points should be merged

Return Value

Type: Boolean
True if operation was successful
See Also

Reference

ITriangleSet Interface
MergePoints Overload
VisualComponents.Create3D Namespace


ITriangleSet.MergePoints Method (IList(Vector3), Vector3, Double, Double)

ITriangleSetMergePoints Method (IListVector3, Vector3, Double, Double)

Collapse vertices by tolerance and sanitize mesh.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void MergePoints(
    IList<Vector3> points,
    Vector3 targetPosition,
    double tolerance,
    double tolerance2
)
void MergePoints(
    IList<Vector3>^ points,
    Vector3 targetPosition,
    double tolerance,
    double tolerance2
)

Parameters

points
Type: System.Collections.GenericIListVector3
targetPosition
Type: VisualComponents.Create3DVector3
tolerance
Type: SystemDouble
tolerance2
Type: SystemDouble
See Also

Reference

ITriangleSet Interface
MergePoints Overload
VisualComponents.Create3D Namespace


ITriangleSet.MergeSet Method

ITriangleSetMergeSet Method

Merges all points and triangles from given set into this one.
Remarks
Given set will be invalidated after this call

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool MergeSet(
    ITriangleSet otherSet
)
bool MergeSet(
    ITriangleSet^ otherSet
)

Parameters

otherSet
Type: VisualComponents.Create3DITriangleSet

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ITriangleSet.MergeSet(VisualComponents.Create3D.ITriangleSet)"]

See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.MergeSetBase Method

ITriangleSetMergeSetBase Method

Merges all points and triangles from given set into this one.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool MergeSetBase(
    ITriangleSet otherSet
)
bool MergeSetBase(
    ITriangleSet^ otherSet
)

Parameters

otherSet
Type: VisualComponents.Create3DITriangleSet

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ITriangleSet.MergeSetBase(VisualComponents.Create3D.ITriangleSet)"]

See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.NormalizeMesh Method

ITriangleSetNormalizeMesh Method

Simplify and sanitize mesh.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void NormalizeMesh(
    bool removeDuplicatePoints,
    bool sanitize,
    bool compact,
    double tolerance
)
void NormalizeMesh(
    bool removeDuplicatePoints,
    bool sanitize,
    bool compact,
    double tolerance
)

Parameters

removeDuplicatePoints
Type: SystemBoolean
sanitize
Type: SystemBoolean
compact
Type: SystemBoolean
tolerance
Type: SystemDouble
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.ResetTextureCoordinateValues Method

ITriangleSetResetTextureCoordinateValues Method

Resets the u,v values of all texture coordinates. If there are no texture coordinates, this call will create them.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ResetTextureCoordinateValues()
void ResetTextureCoordinateValues()
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.SubdivideMesh Method

ITriangleSetSubdivideMesh Method

Subdivide mesh to desired resolution

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int SubdivideMesh(
    double maxEdge,
    int maxTriangles
)
int SubdivideMesh(
    double maxEdge,
    int maxTriangles
)

Parameters

maxEdge
Type: SystemDouble
Maximum edge length
maxTriangles
Type: SystemInt32
Maximum number of triangles

Return Value

Type: Int32
Number of additional number of triangles created
Remarks
For painting and similar application requiring dense mesh
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.ToMeshGeometry3D Method

ITriangleSetToMeshGeometry3D Method

Creates and returns a MeshGeometry3D object. Usefull for wpf 3d rendering.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MeshGeometry3D ToMeshGeometry3D()
MeshGeometry3D^ ToMeshGeometry3D()

Return Value

Type: MeshGeometry3D

[Missing <returns> documentation for "M:VisualComponents.Create3D.ITriangleSet.ToMeshGeometry3D"]

See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet.UpdateTriangle Method

ITriangleSetUpdateTriangle Method

Updates the triangle at given index with new point indexes

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateTriangle(
    uint triangleIndex,
    uint vertex1,
    uint vertex2,
    uint vertex3
)
void UpdateTriangle(
    unsigned int triangleIndex,
    unsigned int vertex1,
    unsigned int vertex2,
    unsigned int vertex3
)

Parameters

triangleIndex
Type: SystemUInt32
triangle index
vertex1
Type: SystemUInt32
Point index 1
vertex2
Type: SystemUInt32
Point index 2
vertex3
Type: SystemUInt32
Point index 3
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITriangleSet Events

The ITriangleSet type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
See Also

Reference

ITriangleSet Interface
VisualComponents.Create3D Namespace


ITwoDirectionalPath Interface

Two-directional path behavior used to move components along a path.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ITwoDirectionalPath : ISimContainer,
    IFlowBehavior, IBehavior, IPropertyContainer, IBatchModeObject, IVisitable,
    IWrapper, IDisposable, INamed
public interface class ITwoDirectionalPath : ISimContainer,
    IFlowBehavior, IBehavior, IPropertyContainer, IBatchModeObject, IVisitable,
    IWrapper, IDisposable, INamed

The ITwoDirectionalPath type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Maximum logical capacity of the container. This determines the maximum number of components that can be contained in the container at any one time. (Inherited from ISimContainer.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Components | list of components currently contained in the container (Inherited from ISimContainer.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | HeadComponent | Returns component in the head of container (Inherited from ISimContainer.)
Public property | IsContentVisible | Defines whether components held by the container are displayed or not (Inherited from ISimContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | TailComponent | Returns component in the tail of container (Inherited from ISimContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetContainerProximity | Calculate the orthogonal distance from position to this container (Inherited from ISimContainer.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Grab | Grab the component into this container (Inherited from ISimContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ComponentArriving | Triggered when a component is arriving to the container (Inherited from ISimContainer.)
Public event | ComponentLeaving | Triggered when a component is leaving from the container (Inherited from ISimContainer.)
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ITwoDirectionalPath Properties

The ITwoDirectionalPath type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Maximum logical capacity of the container. This determines the maximum number of components that can be contained in the container at any one time. (Inherited from ISimContainer.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Components | list of components currently contained in the container (Inherited from ISimContainer.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | HeadComponent | Returns component in the head of container (Inherited from ISimContainer.)
Public property | IsContentVisible | Defines whether components held by the container are displayed or not (Inherited from ISimContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | TailComponent | Returns component in the tail of container (Inherited from ISimContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

ITwoDirectionalPath Interface
VisualComponents.Create3D Namespace


ITwoDirectionalPath Methods

The ITwoDirectionalPath type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetContainerProximity | Calculate the orthogonal distance from position to this container (Inherited from ISimContainer.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Grab | Grab the component into this container (Inherited from ISimContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ITwoDirectionalPath Interface
VisualComponents.Create3D Namespace


ITwoDirectionalPath Events

The ITwoDirectionalPath type exposes the following members.

Events
 | Name | Description
Public event | ComponentArriving | Triggered when a component is arriving to the container (Inherited from ISimContainer.)
Public event | ComponentLeaving | Triggered when a component is leaving from the container (Inherited from ISimContainer.)
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ITwoDirectionalPath Interface
VisualComponents.Create3D Namespace


ITwoWayPath Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ITwoWayPath : IMotionPath,
    ISimContainer, IFlowBehavior, IBehavior, IPropertyContainer, IBatchModeObject,
    IVisitable, IWrapper, IDisposable, INamed
public interface class ITwoWayPath : IMotionPath,
    ISimContainer, IFlowBehavior, IBehavior, IPropertyContainer, IBatchModeObject,
    IVisitable, IWrapper, IDisposable, INamed

The ITwoWayPath type exposes the following members.

Properties
 | Name | Description
Public property | Acceleration | Gets or sets acceleration rate of components on the path, in millimeters per second squared. If this is zero, acceleration is not calculated. (Inherited from IMotionPath.)
Public property | Accumulate | Determines whether components on the path accumulate when one or more components are blocked at the end of the path. If true, components behind a blocked component keep moving until they hit the blocked component. If false, all components in the path stop when the end is blocked. (Inherited from IMotionPath.)
Public property | Capacity | Maximum logical capacity of the container. This determines the maximum number of components that can be contained in the container at any one time. (Inherited from ISimContainer.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Components | list of components currently contained in the container (Inherited from ISimContainer.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Deceleration | Gets or sets deceleration rate of components on the path, in millimeters per second squared. If this is zero, deceleration is not calculated. (Inherited from IMotionPath.)
Public property | DetailCurveMotion | Determines if parts use at curved areas bound box information to avoid box shaped parts to intersect at corners. In some cases like when parts are cylindrical shapes this can cause extra spacing between parts in the curves and in these cases option could be disabled. Part starting movement at curve area after linear section will slow down slightly part immediately behind (at linear section) when part bound box starts rotating. If slight intersection temporarily in the transition from linear section to curved section is not a problem or is part shapes are cylindrical or similar then this option could be disabled. (Inherited from IMotionPath.)
Public property | Direction |
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | HeadComponent | Returns component in the head of container (Inherited from ISimContainer.)
Public property | Interpolation | Gets or sets interpolation mode to use with the path frames. (Inherited from IMotionPath.)
Public property | IsContentVisible | Defines whether components held by the container are displayed or not (Inherited from ISimContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Path | Gets the ordered list of frames that define the path. The actual path is then calculated by interpolating using the method defined by InterpolationMode property. (Inherited from IMotionPath.)
Public property | PathLength | Gets the total length of the path. (Inherited from IMotionPath.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | RetainOffset | Determines how components are positioned on the path when they enter the path. If true, the component offset is retained, otherwise the component is placed with its origin at the nearest point on the path. (Inherited from IMotionPath.)
Public property | SegmentSize | Gets or sets conveyor segment size. If this is greater to zero, the conveyor is divided into segments of the given size, each of which may contain at most one component at any one time. The total number of segments will then determine the maximum capacity of the conveyor in addition to the Capacity property and any associated capacity controllers. (Inherited from IMotionPath.)
Public property | Sensors | Gets the list of sensors that are used in this path. (Inherited from IMotionPath.)
Public property | SpaceUtilization | Determines if components are kept apart from each other in accumulating mode, or when new components are added to the path. If set to false, components may overlap. This may be useful when RetainOffset is true and the components are spread out along the width of a conveyor. In this case two components are allowed to be side by side on the conveyor. (Inherited from IMotionPath.)
Public property | Speed | Gets or sets the speed of the conveyor, in millimeters per second. (Inherited from IMotionPath.)
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | TailComponent | Returns component in the tail of container (Inherited from ISimContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetContainerProximity | Calculate the orthogonal distance from position to this container (Inherited from ISimContainer.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetPathDistanceAtPosition | Gets the path distance at the path position. If the position is outside the path then the distance at closest path position is returned. (Inherited from IMotionPath.)
Public method | GetPathPositionAtDistance | Gets the path position at given distance (Inherited from IMotionPath.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Grab | Grab the component into this container (Inherited from ISimContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ComponentArriving | Triggered when a component is arriving to the container (Inherited from ISimContainer.)
Public event | ComponentLeaving | Triggered when a component is leaving from the container (Inherited from ISimContainer.)
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ITwoWayPath Properties

The ITwoWayPath type exposes the following members.

Properties
 | Name | Description
Public property | Acceleration | Gets or sets acceleration rate of components on the path, in millimeters per second squared. If this is zero, acceleration is not calculated. (Inherited from IMotionPath.)
Public property | Accumulate | Determines whether components on the path accumulate when one or more components are blocked at the end of the path. If true, components behind a blocked component keep moving until they hit the blocked component. If false, all components in the path stop when the end is blocked. (Inherited from IMotionPath.)
Public property | Capacity | Maximum logical capacity of the container. This determines the maximum number of components that can be contained in the container at any one time. (Inherited from ISimContainer.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Components | list of components currently contained in the container (Inherited from ISimContainer.)
Public property | Connectors | Retrieves the collection of ISimConnector instances owned by this behavior. (Inherited from IFlowBehavior.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Deceleration | Gets or sets deceleration rate of components on the path, in millimeters per second squared. If this is zero, deceleration is not calculated. (Inherited from IMotionPath.)
Public property | DetailCurveMotion | Determines if parts use at curved areas bound box information to avoid box shaped parts to intersect at corners. In some cases like when parts are cylindrical shapes this can cause extra spacing between parts in the curves and in these cases option could be disabled. Part starting movement at curve area after linear section will slow down slightly part immediately behind (at linear section) when part bound box starts rotating. If slight intersection temporarily in the transition from linear section to curved section is not a problem or is part shapes are cylindrical or similar then this option could be disabled. (Inherited from IMotionPath.)
Public property | Direction |
Public property | HasCapacity | Defines if this flow behavior accepts incoming components. This is different from logical capacity count that is used for restricting the amount of components that can enter the behavior. (Inherited from IFlowBehavior.)
Public property | HeadComponent | Returns component in the head of container (Inherited from ISimContainer.)
Public property | Interpolation | Gets or sets interpolation mode to use with the path frames. (Inherited from IMotionPath.)
Public property | IsContentVisible | Defines whether components held by the container are displayed or not (Inherited from ISimContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Path | Gets the ordered list of frames that define the path. The actual path is then calculated by interpolating using the method defined by InterpolationMode property. (Inherited from IMotionPath.)
Public property | PathLength | Gets the total length of the path. (Inherited from IMotionPath.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | RetainOffset | Determines how components are positioned on the path when they enter the path. If true, the component offset is retained, otherwise the component is placed with its origin at the nearest point on the path. (Inherited from IMotionPath.)
Public property | SegmentSize | Gets or sets conveyor segment size. If this is greater to zero, the conveyor is divided into segments of the given size, each of which may contain at most one component at any one time. The total number of segments will then determine the maximum capacity of the conveyor in addition to the Capacity property and any associated capacity controllers. (Inherited from IMotionPath.)
Public property | Sensors | Gets the list of sensors that are used in this path. (Inherited from IMotionPath.)
Public property | SpaceUtilization | Determines if components are kept apart from each other in accumulating mode, or when new components are added to the path. If set to false, components may overlap. This may be useful when RetainOffset is true and the components are spread out along the width of a conveyor. In this case two components are allowed to be side by side on the conveyor. (Inherited from IMotionPath.)
Public property | Speed | Gets or sets the speed of the conveyor, in millimeters per second. (Inherited from IMotionPath.)
Public property | SupportsDynamicConnectors | Defines if connectors can be added or removed from this flow behavior. (Inherited from IFlowBehavior.)
Public property | TailComponent | Returns component in the tail of container (Inherited from ISimContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

ITwoWayPath Interface
VisualComponents.Create3D Namespace


ITwoWayPath.Direction Property

ITwoWayPathDirection Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MotionPathDirection Direction { get; set; }
property MotionPathDirection Direction {
    MotionPathDirection get ();
    void set (MotionPathDirection value);
}

Property Value

Type: MotionPathDirection
See Also

Reference

ITwoWayPath Interface
VisualComponents.Create3D Namespace


ITwoWayPath Methods

The ITwoWayPath type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CheckCapacity | Tests if the behavior has capacity for a component coming in through the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | CreateConnector | Creates a new ISimConnector instance to this behavior. (Inherited from IFlowBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteConnector | Deletes the given ISimConnector. (Inherited from IFlowBehavior.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetContainerProximity | Calculate the orthogonal distance from position to this container (Inherited from ISimContainer.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetPathDistanceAtPosition | Gets the path distance at the path position. If the position is outside the path then the distance at closest path position is returned. (Inherited from IMotionPath.)
Public method | GetPathPositionAtDistance | Gets the path position at given distance (Inherited from IMotionPath.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | Grab | Grab the component into this container (Inherited from ISimContainer.)
Public method | SetConnection | Connects the given ISimConnector instances. (Inherited from IFlowBehavior.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

ITwoWayPath Interface
VisualComponents.Create3D Namespace


ITwoWayPath Events

The ITwoWayPath type exposes the following members.

Events
 | Name | Description
Public event | ComponentArriving | Triggered when a component is arriving to the container (Inherited from ISimContainer.)
Public event | ComponentLeaving | Triggered when a component is leaving from the container (Inherited from ISimContainer.)
Public event | ConnectorAdded | Event that is raised when a new ISimConnector has been added to this behavior. (Inherited from IFlowBehavior.)
Public event | ConnectorRemoving | Event that is raised when an ISimConnector has been removed from this behavior. (Inherited from IFlowBehavior.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

ITwoWayPath Interface
VisualComponents.Create3D Namespace


IU3DRecorder Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IU3DRecorder : IRecorder,
    IDisposable
public interface class IU3DRecorder : IRecorder,
    IDisposable

The IU3DRecorder type exposes the following members.

Properties
 | Name | Description
Public property | FrameRate | Defines the frame rate (fps) of the recorder. (Inherited from IRecorder.)
Public property | IsRecording | Defines if the recorder has been started. (Inherited from IRecorder.)
Top
Methods
 | Name | Description
Public method | Cancel | Stops current generation.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Export(Uri) | Creates a static u3d model
Public method | Export(Uri, IEnumerableISimComponent) | Exports a static u3d model from the given components
Public method | Start | Starts and initializes the recorder. (Inherited from IRecorder.)
Public method | Stop | Stops the recorder and saves the result to the given file. (Inherited from IRecorder.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IU3DRecorder Properties

The IU3DRecorder type exposes the following members.

Properties
 | Name | Description
Public property | FrameRate | Defines the frame rate (fps) of the recorder. (Inherited from IRecorder.)
Public property | IsRecording | Defines if the recorder has been started. (Inherited from IRecorder.)
Top
See Also

Reference

IU3DRecorder Interface
VisualComponents.Create3D Namespace


IU3DRecorder Methods

The IU3DRecorder type exposes the following members.

Methods
 | Name | Description
Public method | Cancel | Stops current generation.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Export(Uri) | Creates a static u3d model
Public method | Export(Uri, IEnumerableISimComponent) | Exports a static u3d model from the given components
Public method | Start | Starts and initializes the recorder. (Inherited from IRecorder.)
Public method | Stop | Stops the recorder and saves the result to the given file. (Inherited from IRecorder.)
Top
See Also

Reference

IU3DRecorder Interface
VisualComponents.Create3D Namespace


IU3DRecorder.Cancel Method

IU3DRecorderCancel Method

Stops current generation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Cancel()
void Cancel()
See Also

Reference

IU3DRecorder Interface
VisualComponents.Create3D Namespace


IU3DRecorder.Export Method

IU3DRecorderExport Method

Overload List
 | Name | Description
Public method | Export(Uri) | Creates a static u3d model
Public method | Export(Uri, IEnumerableISimComponent) | Exports a static u3d model from the given components
Top
See Also

Reference

IU3DRecorder Interface
VisualComponents.Create3D Namespace


IU3DRecorder.Export Method (Uri)

IU3DRecorderExport Method (Uri)

Creates a static u3d model

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Export(
    Uri uri
)
void Export(
    Uri^ uri
)

Parameters

uri
Type: SystemUri
See Also

Reference

IU3DRecorder Interface
Export Overload
VisualComponents.Create3D Namespace


IU3DRecorder.Export Method (Uri, IEnumerable(ISimComponent))

IU3DRecorderExport Method (Uri, IEnumerableISimComponent)

Exports a static u3d model from the given components

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Export(
    Uri uri,
    IEnumerable<ISimComponent> components
)
void Export(
    Uri^ uri,
    IEnumerable<ISimComponent^>^ components
)

Parameters

uri
Type: SystemUri
The destination uri
components
Type: System.Collections.GenericIEnumerableISimComponent
List of components included in the exported file.
See Also

Reference

IU3DRecorder Interface
Export Overload
VisualComponents.Create3D Namespace


IUndoHelper Interface

Undo helper utility interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IUndoHelper
public interface class IUndoHelper

The IUndoHelper type exposes the following members.

Methods
 | Name | Description
Public method | CreateComponentMemento | Creates a new instance of IComponentMemento.
Public method | CreateProcessFlowGroupMemento |
Top
See Also

Reference

VisualComponents.Create3D Namespace


IUndoHelper Methods

The IUndoHelper type exposes the following members.

Methods
 | Name | Description
Public method | CreateComponentMemento | Creates a new instance of IComponentMemento.
Public method | CreateProcessFlowGroupMemento |
Top
See Also

Reference

IUndoHelper Interface
VisualComponents.Create3D Namespace


IUndoHelper.CreateComponentMemento Method

IUndoHelperCreateComponentMemento Method

Creates a new instance of IComponentMemento.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IComponentMemento CreateComponentMemento()
IComponentMemento^ CreateComponentMemento()

Return Value

Type: IComponentMemento
Component memento instance.
See Also

Reference

IUndoHelper Interface
VisualComponents.Create3D Namespace


IUndoHelper.CreateProcessFlowGroupMemento Method

IUndoHelperCreateProcessFlowGroupMemento Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMemento<IProcessFlowGroup> CreateProcessFlowGroupMemento()
IMemento<IProcessFlowGroup^>^ CreateProcessFlowGroupMemento()

Return Value

Type: IMemento IProcessFlowGroup

[Missing <returns> documentation for "M:VisualComponents.Create3D.IUndoHelper.CreateProcessFlowGroupMemento"]

See Also

Reference

IUndoHelper Interface
VisualComponents.Create3D Namespace


IUndoService Interface

UndoService implements a linear model undo that tracks changesets and allows reverting objects back to their previous state as well as redoing undone operations.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IUndoService
public interface class IUndoService

The IUndoService type exposes the following members.

Properties
 | Name | Description
Public property | CurrentUndoState | Current UndoState of the service.
Public property | IsActive | Returns true if UndoService has an active, non-isolated undo scope.
Public property | RedoStack | Collection of redoable changesets in the redo stack.
Public property | UndoStack | Collection of undoable changesets in the undo stack.
Top
Methods
 | Name | Description
Public method | AddChange | Add a single change to current undo scope.
Public method | AddChangeset | Adds a new changeset to undo stack. Change set addition clears previous redo operations.
Public method | AddChangeToPreviousSet | Add a single change to the previous already-stored changeset.
Public method | Clear | Removes changesets from undo and redo stacks.
Public method | Clear(Boolean, Boolean) | Removes changesets from undo and redo stacks and performs garbage collection.
Public method | Redo | Redoes changeset on the top of the redo stack and moves that changeset to the undo stack.
Public method | Undo | Undoes changeset on the top of the undo stack and moves that changeset to the redo stack.
Top
Events
 | Name | Description
Public event | Cleared |
Public event | NewChangeset |
Public event | RedoDone |
Public event | Redoing |
Public event | UndoDone |
Public event | Undoing |
Top
Remarks
UndoService is NOT threadsafe and you should be used from main thread only.
See Also

Reference

VisualComponents.Create3D Namespace


IUndoService Properties

The IUndoService type exposes the following members.

Properties
 | Name | Description
Public property | CurrentUndoState | Current UndoState of the service.
Public property | IsActive | Returns true if UndoService has an active, non-isolated undo scope.
Public property | RedoStack | Collection of redoable changesets in the redo stack.
Public property | UndoStack | Collection of undoable changesets in the undo stack.
Top
See Also

Reference

IUndoService Interface
VisualComponents.Create3D Namespace


IUndoService.CurrentUndoState Property

IUndoServiceCurrentUndoState Property

Current UndoState of the service.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
UndoState CurrentUndoState { get; }
property UndoState CurrentUndoState {
    UndoState get ();
}

Property Value

Type: UndoState
See Also

Reference

IUndoService Interface
VisualComponents.Create3D Namespace


IUndoService.IsActive Property

IUndoServiceIsActive Property

Returns true if UndoService has an active, non-isolated undo scope.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsActive { get; }
property bool IsActive {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IUndoService Interface
VisualComponents.Create3D Namespace


IUndoService.RedoStack Property

IUndoServiceRedoStack Property

Collection of redoable changesets in the redo stack.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<Changeset> RedoStack { get; }
property IEnumerable<Changeset^>^ RedoStack {
    IEnumerable<Changeset^>^ get ();
}

Property Value

Type: IEnumerableChangeset
See Also

Reference

IUndoService Interface
VisualComponents.Create3D Namespace


IUndoService.UndoStack Property

IUndoServiceUndoStack Property

Collection of undoable changesets in the undo stack.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<Changeset> UndoStack { get; }
property IEnumerable<Changeset^>^ UndoStack {
    IEnumerable<Changeset^>^ get ();
}

Property Value

Type: IEnumerableChangeset
See Also

Reference

IUndoService Interface
VisualComponents.Create3D Namespace


IUndoService Methods

The IUndoService type exposes the following members.

Methods
 | Name | Description
Public method | AddChange | Add a single change to current undo scope.
Public method | AddChangeset | Adds a new changeset to undo stack. Change set addition clears previous redo operations.
Public method | AddChangeToPreviousSet | Add a single change to the previous already-stored changeset.
Public method | Clear | Removes changesets from undo and redo stacks.
Public method | Clear(Boolean, Boolean) | Removes changesets from undo and redo stacks and performs garbage collection.
Public method | Redo | Redoes changeset on the top of the redo stack and moves that changeset to the undo stack.
Public method | Undo | Undoes changeset on the top of the undo stack and moves that changeset to the redo stack.
Top
See Also

Reference

IUndoService Interface
VisualComponents.Create3D Namespace


IUndoService.AddChange Method

IUndoServiceAddChange Method

Add a single change to current undo scope.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddChange(
    Change change
)
void AddChange(
    Change^ change
)

Parameters

change
Type: VisualComponents.Create3DChange
Change to add.
Exceptions
Exception | Condition
InvalidOperationException | If there is no undoscope available.
See Also

Reference

IUndoService Interface
VisualComponents.Create3D Namespace


IUndoService.AddChangeset Method

IUndoServiceAddChangeset Method

Adds a new changeset to undo stack. Change set addition clears previous redo operations.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddChangeset(
    Changeset changeset
)
void AddChangeset(
    Changeset^ changeset
)

Parameters

changeset
Type: VisualComponents.Create3DChangeset
Changeset to add to the undo stack.
See Also

Reference

IUndoService Interface
VisualComponents.Create3D Namespace


IUndoService.AddChangeToPreviousSet Method

IUndoServiceAddChangeToPreviousSet Method

Add a single change to the previous already-stored changeset.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddChangeToPreviousSet(
    Change change
)
void AddChangeToPreviousSet(
    Change^ change
)

Parameters

change
Type: VisualComponents.Create3DChange
Change to add.
Exceptions
Exception | Condition
InvalidOperationException | If there is no previous changeset, or if the redo stack is not clear.
See Also

Reference

IUndoService Interface
VisualComponents.Create3D Namespace


IUndoService.Clear Method

IUndoServiceClear Method

Overload List
 | Name | Description
Public method | Clear | Removes changesets from undo and redo stacks.
Public method | Clear(Boolean, Boolean) | Removes changesets from undo and redo stacks and performs garbage collection.
Top
See Also

Reference

IUndoService Interface
VisualComponents.Create3D Namespace


IUndoService.Clear Method

IUndoServiceClear Method

Removes changesets from undo and redo stacks.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Clear()
void Clear()
See Also

Reference

IUndoService Interface
Clear Overload
VisualComponents.Create3D Namespace


IUndoService.Clear Method (Boolean, Boolean)

IUndoServiceClear Method (Boolean, Boolean)

Removes changesets from undo and redo stacks and performs garbage collection.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Clear(
    bool clearOutput,
    bool doGC
)
void Clear(
    bool clearOutput,
    bool doGC
)

Parameters

clearOutput
Type: SystemBoolean
doGC
Type: SystemBoolean
See Also

Reference

IUndoService Interface
Clear Overload
VisualComponents.Create3D Namespace


IUndoService.Redo Method

IUndoServiceRedo Method

Redoes changeset on the top of the redo stack and moves that changeset to the undo stack.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Redo()
void Redo()
See Also

Reference

IUndoService Interface
VisualComponents.Create3D Namespace


IUndoService.Undo Method

IUndoServiceUndo Method

Undoes changeset on the top of the undo stack and moves that changeset to the redo stack.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Undo()
void Undo()
See Also

Reference

IUndoService Interface
VisualComponents.Create3D Namespace


IUndoService Events

The IUndoService type exposes the following members.

Events
 | Name | Description
Public event | Cleared |
Public event | NewChangeset |
Public event | RedoDone |
Public event | Redoing |
Public event | UndoDone |
Public event | Undoing |
Top
See Also

Reference

IUndoService Interface
VisualComponents.Create3D Namespace


IUndoService.Cleared Event

IUndoServiceCleared Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler Cleared
 event EventHandler^ Cleared {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IUndoService Interface
VisualComponents.Create3D Namespace


IUndoService.NewChangeset Event

IUndoServiceNewChangeset Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<UndoEventArgs> NewChangeset
 event EventHandler<UndoEventArgs^>^ NewChangeset {
    void add (EventHandler<UndoEventArgs^>^ value);
    void remove (EventHandler<UndoEventArgs^>^ value);
}

Value

Type: SystemEventHandlerUndoEventArgs
See Also

Reference

IUndoService Interface
VisualComponents.Create3D Namespace


IUndoService.RedoDone Event

IUndoServiceRedoDone Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<UndoEventArgs> RedoDone
 event EventHandler<UndoEventArgs^>^ RedoDone {
    void add (EventHandler<UndoEventArgs^>^ value);
    void remove (EventHandler<UndoEventArgs^>^ value);
}

Value

Type: SystemEventHandlerUndoEventArgs
See Also

Reference

IUndoService Interface
VisualComponents.Create3D Namespace


IUndoService.Redoing Event

IUndoServiceRedoing Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<UndoEventArgs> Redoing
 event EventHandler<UndoEventArgs^>^ Redoing {
    void add (EventHandler<UndoEventArgs^>^ value);
    void remove (EventHandler<UndoEventArgs^>^ value);
}

Value

Type: SystemEventHandlerUndoEventArgs
See Also

Reference

IUndoService Interface
VisualComponents.Create3D Namespace


IUndoService.UndoDone Event

IUndoServiceUndoDone Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<UndoEventArgs> UndoDone
 event EventHandler<UndoEventArgs^>^ UndoDone {
    void add (EventHandler<UndoEventArgs^>^ value);
    void remove (EventHandler<UndoEventArgs^>^ value);
}

Value

Type: SystemEventHandlerUndoEventArgs
See Also

Reference

IUndoService Interface
VisualComponents.Create3D Namespace


IUndoService.Undoing Event

IUndoServiceUndoing Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<UndoEventArgs> Undoing
 event EventHandler<UndoEventArgs^>^ Undoing {
    void add (EventHandler<UndoEventArgs^>^ value);
    void remove (EventHandler<UndoEventArgs^>^ value);
}

Value

Type: SystemEventHandlerUndoEventArgs
See Also

Reference

IUndoService Interface
VisualComponents.Create3D Namespace


IUnionProperty Interface

Union property interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IUnionProperty : IProperty,
    INotifyPropertyChanged, IDisposable, INamed
public interface class IUnionProperty : IProperty,
    INotifyPropertyChanged, IDisposable, INamed

The IUnionProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Allowed maximum value for the property. (Inherited from IProperty.)
Public property | AllowedMinimum | Allowed minimum value for the property. (Inherited from IProperty.)
Public property | AllowedValues | Collection of allowed values for constrained properties. (Inherited from IProperty.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsEditable | Whether the union property is currently editable.
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsValid | Whether all the source property objects are valid.
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | Properties | Properties that compose this union property.
Public property | PropertyDistinctionLevel | Degree of distinction between the individual properties in this union.
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Property value as an object. (Inherited from IProperty.)
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Public method | StopListening | Disconnect all change event handlers from source properties.
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IUnionProperty Properties

The IUnionProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Allowed maximum value for the property. (Inherited from IProperty.)
Public property | AllowedMinimum | Allowed minimum value for the property. (Inherited from IProperty.)
Public property | AllowedValues | Collection of allowed values for constrained properties. (Inherited from IProperty.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsEditable | Whether the union property is currently editable.
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsValid | Whether all the source property objects are valid.
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | Properties | Properties that compose this union property.
Public property | PropertyDistinctionLevel | Degree of distinction between the individual properties in this union.
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Property value as an object. (Inherited from IProperty.)
Top
See Also

Reference

IUnionProperty Interface
VisualComponents.Create3D Namespace


IUnionProperty.IsEditable Property

IUnionPropertyIsEditable Property

Whether the union property is currently editable.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsEditable { get; }
property bool IsEditable {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IUnionProperty Interface
VisualComponents.Create3D Namespace


IUnionProperty.IsValid Property

IUnionPropertyIsValid Property

Whether all the source property objects are valid.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsValid { get; }
property bool IsValid {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IUnionProperty Interface
VisualComponents.Create3D Namespace


IUnionProperty.Properties Property

IUnionPropertyProperties Property

Properties that compose this union property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
PropertyCollection Properties { get; }
property PropertyCollection^ Properties {
    PropertyCollection^ get ();
}

Property Value

Type: PropertyCollection
See Also

Reference

IUnionProperty Interface
VisualComponents.Create3D Namespace


IUnionProperty.PropertyDistinctionLevel Property

IUnionPropertyPropertyDistinctionLevel Property

Degree of distinction between the individual properties in this union.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
DistinctionLevel PropertyDistinctionLevel { get; }
property DistinctionLevel PropertyDistinctionLevel {
    DistinctionLevel get ();
}

Property Value

Type: DistinctionLevel
See Also

Reference

IUnionProperty Interface
VisualComponents.Create3D Namespace


IUnionProperty Methods

The IUnionProperty type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Public method | StopListening | Disconnect all change event handlers from source properties.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

IUnionProperty Interface
VisualComponents.Create3D Namespace


IUnionProperty.StopListening Method

IUnionPropertyStopListening Method

Disconnect all change event handlers from source properties.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StopListening()
void StopListening()
See Also

Reference

IUnionProperty Interface
VisualComponents.Create3D Namespace


IUnionProperty Events

The IUnionProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IUnionProperty Interface
VisualComponents.Create3D Namespace


IUnit Interface

Unit of measure object interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IUnit : IWrapper, IDisposable
public interface class IUnit : IWrapper,
    IDisposable

The IUnit type exposes the following members.

Properties
 | Name | Description
Public property | ContainedIn | Unit group containing the unit. This is determined when the unit is created.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Magnitude | Unit magnitude.
Public property | Name | Full name of the unit
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Suffix | Unit suffix string. This string is displayed in the GUI when the user edits properties that are displayed using this unit. This value is not set if the unit is a built-in unit.
Top
Methods
 | Name | Description
Public method | ConvertFromCanonical | Convert the given canonical value to its representation in this unit.
Public method | ConvertToCanonical | Convert the given value expressed in terms of this unit to its canonical representation.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | Compare equality of instances.
Public method | GetHashCode | (Inherited from IWrapper.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks

An object implementing this interface represents a single unit of measure. It has a name, a suffix, and properties for describing a linear mapping between the canonical value and the unit value. This mapping is then available through a number of conversion methods.

See Also

Reference

VisualComponents.Create3D Namespace


IUnit Properties

The IUnit type exposes the following members.

Properties
 | Name | Description
Public property | ContainedIn | Unit group containing the unit. This is determined when the unit is created.
Public property | IsValid | (Inherited from IWrapper.)
Public property | Magnitude | Unit magnitude.
Public property | Name | Full name of the unit
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Suffix | Unit suffix string. This string is displayed in the GUI when the user edits properties that are displayed using this unit. This value is not set if the unit is a built-in unit.
Top
See Also

Reference

IUnit Interface
VisualComponents.Create3D Namespace


IUnit.ContainedIn Property

IUnitContainedIn Property

Unit group containing the unit. This is determined when the unit is created.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IUnitGroup ContainedIn { get; }
property IUnitGroup^ ContainedIn {
    IUnitGroup^ get ();
}

Property Value

Type: IUnitGroup
See Also

Reference

IUnit Interface
VisualComponents.Create3D Namespace


IUnit.Magnitude Property

IUnitMagnitude Property

Unit magnitude.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Magnitude { get; }
property double Magnitude {
    double get ();
}

Property Value

Type: Double
Remarks
This is the size of the unit, measured in canonical units for the quantity.
See Also

Reference

IUnit Interface
VisualComponents.Create3D Namespace


IUnit.Name Property

IUnitName Property

Full name of the unit

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Name { get; }
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IUnit Interface
VisualComponents.Create3D Namespace


IUnit.Suffix Property

IUnitSuffix Property

Unit suffix string. This string is displayed in the GUI when the user edits properties that are displayed using this unit. This value is not set if the unit is a built-in unit.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Suffix { get; }
property String^ Suffix {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IUnit Interface
VisualComponents.Create3D Namespace


IUnit Methods

The IUnit type exposes the following members.

Methods
 | Name | Description
Public method | ConvertFromCanonical | Convert the given canonical value to its representation in this unit.
Public method | ConvertToCanonical | Convert the given value expressed in terms of this unit to its canonical representation.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | Compare equality of instances.
Public method | GetHashCode | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IUnit Interface
VisualComponents.Create3D Namespace


IUnit.ConvertFromCanonical Method

IUnitConvertFromCanonical Method

Convert the given canonical value to its representation in this unit.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double ConvertFromCanonical(
    double canonicalValue
)
double ConvertFromCanonical(
    double canonicalValue
)

Parameters

canonicalValue
Type: SystemDouble

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.Create3D.IUnit.ConvertFromCanonical(System.Double)"]

See Also

Reference

IUnit Interface
VisualComponents.Create3D Namespace


IUnit.ConvertToCanonical Method

IUnitConvertToCanonical Method

Convert the given value expressed in terms of this unit to its canonical representation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double ConvertToCanonical(
    double unitValue
)
double ConvertToCanonical(
    double unitValue
)

Parameters

unitValue
Type: SystemDouble

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.Create3D.IUnit.ConvertToCanonical(System.Double)"]

See Also

Reference

IUnit Interface
VisualComponents.Create3D Namespace


IUnit.Equals Method

IUnitEquals Method

Compare equality of instances.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool Equals(
    Object value
)
bool Equals(
    Object^ value
)

Parameters

value
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IUnit.Equals(System.Object)"]

Implements

IWrapperEquals(Object)
See Also

Reference

IUnit Interface
VisualComponents.Create3D Namespace


IUnit Events

The IUnit type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
See Also

Reference

IUnit Interface
VisualComponents.Create3D Namespace


IUnitFamily Interface

Interface representing a group of units of the same measuring system.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IUnitFamily
public interface class IUnitFamily

The IUnitFamily type exposes the following members.

Properties
 | Name | Description
Public property | Name | Full name of the unit family
Public property | Pointer |
Public property | UnitGroups | Read-only list of unit groups in the family.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IUnitFamily Properties

The IUnitFamily type exposes the following members.

Properties
 | Name | Description
Public property | Name | Full name of the unit family
Public property | Pointer |
Public property | UnitGroups | Read-only list of unit groups in the family.
Top
See Also

Reference

IUnitFamily Interface
VisualComponents.Create3D Namespace


IUnitFamily.Name Property

IUnitFamilyName Property

Full name of the unit family

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Name { get; }
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IUnitFamily Interface
VisualComponents.Create3D Namespace


IUnitFamily.Pointer Property

IUnitFamilyPointer Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IntPtr Pointer { get; }
property IntPtr Pointer {
    IntPtr get ();
}

Property Value

Type: IntPtr
See Also

Reference

IUnitFamily Interface
VisualComponents.Create3D Namespace


IUnitFamily.UnitGroups Property

IUnitFamilyUnitGroups Property

Read-only list of unit groups in the family.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IUnitGroup> UnitGroups { get; }
property IList<IUnitGroup^>^ UnitGroups {
    IList<IUnitGroup^>^ get ();
}

Property Value

Type: IListIUnitGroup
See Also

Reference

IUnitFamily Interface
VisualComponents.Create3D Namespace


IUnitGroup Interface

Interface representing a group of units of the same quantity and unit family.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IUnitGroup
public interface class IUnitGroup

The IUnitGroup type exposes the following members.

Properties
 | Name | Description
Public property | Name | Full name of the unit group
Public property | Quantity |
Public property | Units | Read-only list of units in the group.
Top
Methods
 | Name | Description
Public method | GetUnitWithMagnitude | This method returns the unit that is logarithmically closest to the given magnitude.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IUnitGroup Properties

The IUnitGroup type exposes the following members.

Properties
 | Name | Description
Public property | Name | Full name of the unit group
Public property | Quantity |
Public property | Units | Read-only list of units in the group.
Top
See Also

Reference

IUnitGroup Interface
VisualComponents.Create3D Namespace


IUnitGroup.Name Property

IUnitGroupName Property

Full name of the unit group

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Name { get; }
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IUnitGroup Interface
VisualComponents.Create3D Namespace


IUnitGroup.Quantity Property

IUnitGroupQuantity Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Quantity { get; }
property String^ Quantity {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IUnitGroup Interface
VisualComponents.Create3D Namespace


IUnitGroup.Units Property

IUnitGroupUnits Property

Read-only list of units in the group.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IUnit> Units { get; }
property IList<IUnit^>^ Units {
    IList<IUnit^>^ get ();
}

Property Value

Type: IListIUnit
See Also

Reference

IUnitGroup Interface
VisualComponents.Create3D Namespace


IUnitGroup Methods

The IUnitGroup type exposes the following members.

Methods
 | Name | Description
Public method | GetUnitWithMagnitude | This method returns the unit that is logarithmically closest to the given magnitude.
Top
See Also

Reference

IUnitGroup Interface
VisualComponents.Create3D Namespace


IUnitGroup.GetUnitWithMagnitude Method

IUnitGroupGetUnitWithMagnitude Method

This method returns the unit that is logarithmically closest to the given magnitude.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IUnit GetUnitWithMagnitude(
    double magnitude
)
IUnit^ GetUnitWithMagnitude(
    double magnitude
)

Parameters

magnitude
Type: SystemDouble
Unit magnitude

Return Value

Type: IUnit

[Missing <returns> documentation for "M:VisualComponents.Create3D.IUnitGroup.GetUnitWithMagnitude(System.Double)"]

See Also

Reference

IUnitGroup Interface
VisualComponents.Create3D Namespace


IUnitManager Interface

Unit manager interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IUnitManager
public interface class IUnitManager

The IUnitManager type exposes the following members.

Properties
 | Name | Description
Public property | AllUnitFamilies |
Public property | AllUnitGroups |
Public property | SelectedUnitFamily |
Public property | UnitQuantities |
Top
Methods
 | Name | Description
Public method | FindUnit | Find unit by name or suffix.
Public method | FindUnitGroup | Find unit group by name.
Public method | GetValueAndUnit |
Top
Events
 | Name | Description
Public event | UnitFamilyChanged |
Top
Remarks

This interface enables units to be searched by name. An instance of this interface is exported through MEF.

See Also

Reference

VisualComponents.Create3D Namespace


IUnitManager Properties

The IUnitManager type exposes the following members.

Properties
 | Name | Description
Public property | AllUnitFamilies |
Public property | AllUnitGroups |
Public property | SelectedUnitFamily |
Public property | UnitQuantities |
Top
See Also

Reference

IUnitManager Interface
VisualComponents.Create3D Namespace


IUnitManager.AllUnitFamilies Property

IUnitManagerAllUnitFamilies Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IUnitFamily> AllUnitFamilies { get; }
property IList<IUnitFamily^>^ AllUnitFamilies {
    IList<IUnitFamily^>^ get ();
}

Property Value

Type: IListIUnitFamily
See Also

Reference

IUnitManager Interface
VisualComponents.Create3D Namespace


IUnitManager.AllUnitGroups Property

IUnitManagerAllUnitGroups Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IUnitGroup> AllUnitGroups { get; }
property IList<IUnitGroup^>^ AllUnitGroups {
    IList<IUnitGroup^>^ get ();
}

Property Value

Type: IListIUnitGroup
See Also

Reference

IUnitManager Interface
VisualComponents.Create3D Namespace


IUnitManager.SelectedUnitFamily Property

IUnitManagerSelectedUnitFamily Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IUnitFamily SelectedUnitFamily { get; set; }
property IUnitFamily^ SelectedUnitFamily {
    IUnitFamily^ get ();
    void set (IUnitFamily^ value);
}

Property Value

Type: IUnitFamily
See Also

Reference

IUnitManager Interface
VisualComponents.Create3D Namespace


IUnitManager.UnitQuantities Property

IUnitManagerUnitQuantities Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<IScalarQuantity> UnitQuantities { get; }
property IList<IScalarQuantity^>^ UnitQuantities {
    IList<IScalarQuantity^>^ get ();
}

Property Value

Type: IListIScalarQuantity
See Also

Reference

IUnitManager Interface
VisualComponents.Create3D Namespace


IUnitManager Methods

The IUnitManager type exposes the following members.

Methods
 | Name | Description
Public method | FindUnit | Find unit by name or suffix.
Public method | FindUnitGroup | Find unit group by name.
Public method | GetValueAndUnit |
Top
See Also

Reference

IUnitManager Interface
VisualComponents.Create3D Namespace


IUnitManager.FindUnit Method

IUnitManagerFindUnit Method

Find unit by name or suffix.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IUnit FindUnit(
    string nameOrSuffix
)
IUnit^ FindUnit(
    String^ nameOrSuffix
)

Parameters

nameOrSuffix
Type: SystemString
Unit name or suffix.

Return Value

Type: IUnit
The named unit, or null if not found.
See Also

Reference

IUnitManager Interface
VisualComponents.Create3D Namespace


IUnitManager.FindUnitGroup Method

IUnitManagerFindUnitGroup Method

Find unit group by name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IUnitGroup FindUnitGroup(
    string name
)
IUnitGroup^ FindUnitGroup(
    String^ name
)

Parameters

name
Type: SystemString
Unit group name.

Return Value

Type: IUnitGroup
The named group, or null if not found.
See Also

Reference

IUnitManager Interface
VisualComponents.Create3D Namespace


IUnitManager.GetValueAndUnit Method

IUnitManagerGetValueAndUnit Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Tuple<double, string> GetValueAndUnit(
    double value,
    string unit
)
Tuple<double, String^>^ GetValueAndUnit(
    double value,
    String^ unit
)

Parameters

value
Type: SystemDouble
unit
Type: SystemString

Return Value

Type: TupleDouble, String

[Missing <returns> documentation for "M:VisualComponents.Create3D.IUnitManager.GetValueAndUnit(System.Double,System.String)"]

See Also

Reference

IUnitManager Interface
VisualComponents.Create3D Namespace


IUnitManager Events

The IUnitManager type exposes the following members.

Events
 | Name | Description
Public event | UnitFamilyChanged |
Top
See Also

Reference

IUnitManager Interface
VisualComponents.Create3D Namespace


IUnitManager.UnitFamilyChanged Event

IUnitManagerUnitFamilyChanged Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<UnitFamilyChangedEventArgs> UnitFamilyChanged
 event EventHandler<UnitFamilyChangedEventArgs^>^ UnitFamilyChanged {
    void add (EventHandler<UnitFamilyChangedEventArgs^>^ value);
    void remove (EventHandler<UnitFamilyChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerUnitFamilyChangedEventArgs
See Also

Reference

IUnitManager Interface
VisualComponents.Create3D Namespace


IUnknownStatement Interface

Interface for statements that could not be deserialized by IProgramSerializer.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IUnknownStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IUnknownStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IUnknownStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | Data | Gets or sets the original serialized data.
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | TypeString | Gets or sets the type of the original statement.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks
For internal use only.
See Also

Reference

VisualComponents.Create3D Namespace


IUnknownStatement Properties

The IUnknownStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | Data | Gets or sets the original serialized data.
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | TypeString | Gets or sets the type of the original statement.
Top
See Also

Reference

IUnknownStatement Interface
VisualComponents.Create3D Namespace


IUnknownStatement.Data Property

IUnknownStatementData Property

Gets or sets the original serialized data.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Data { get; set; }
property String^ Data {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IUnknownStatement Interface
VisualComponents.Create3D Namespace


IUnknownStatement.TypeString Property

IUnknownStatementTypeString Property

Gets or sets the type of the original statement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string TypeString { get; set; }
property String^ TypeString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IUnknownStatement Interface
VisualComponents.Create3D Namespace


IUnknownStatement Methods

The IUnknownStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IUnknownStatement Interface
VisualComponents.Create3D Namespace


IUnknownStatement Events

The IUnknownStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IUnknownStatement Interface
VisualComponents.Create3D Namespace


IUriProperty Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IUriProperty : IProperty<Uri>,
    IProperty, INotifyPropertyChanged, IDisposable, INamed
public interface class IUriProperty : IProperty<Uri^>,
    IProperty, INotifyPropertyChanged, IDisposable, INamed

The IUriProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Strongly typed allowed maximum value. (Inherited from IPropertyT.)
Public property | AllowedMinimum | Strongly typed allowed minimum value. (Inherited from IPropertyT.)
Public property | AllowedValues | Strongly typed container of allowed values. (Inherited from IPropertyT.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | FolderSelection |
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Strongly typed property value. (Inherited from IPropertyT.)
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IUriProperty Properties

The IUriProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Strongly typed allowed maximum value. (Inherited from IPropertyT.)
Public property | AllowedMinimum | Strongly typed allowed minimum value. (Inherited from IPropertyT.)
Public property | AllowedValues | Strongly typed container of allowed values. (Inherited from IPropertyT.)
Public property | CanCreateNewValue | Enable/disable collecting statistics for this property. (Inherited from IProperty.)
Public property | Category | Property grouping category name. (Inherited from IProperty.)
Public property | ConstraintType | Property constraint type. (Inherited from IProperty.)
Public property | Container | Property container object that contains this property. (Inherited from IProperty.)
Public property | CreationTypes | Read-only list of available creation types. (Inherited from IProperty.)
Public property | Description | Localized property description string. (Inherited from IProperty.)
Public property | DisabledStateToolTip | Localized property tooltip string shown when property is disabled. (Inherited from IProperty.)
Public property | DistributionExpression | The distribution expression for pseudo-random distribution. properties. (Inherited from IProperty.)
Public property | FolderSelection |
Public property | HasDistribution | Whether this is a pseudo-random property with a defined distribution function. (Inherited from IProperty.)
Public property | History | Obsolete. (Inherited from IProperty.)
Public property | IsDesignTime | Whether the property is intended for component design time use only. (Inherited from IProperty.)
Public property | IsInternal | Whether the property is internally defined. (Inherited from IProperty.)
Public property | IsLocked | Whether the containing object is currently locked, or not. (Inherited from IProperty.)
Public property | IsPersistent | Whether the property is saved with the component or layout. (Inherited from IProperty.)
Public property | IsQuantityValue | (Inherited from IProperty.)
Public property | IsReadOnly | When true, the Value can't be set through the API. (Inherited from IProperty.)
Public property | IsVisible | Whether the property should be displayed in the UI. (Inherited from IProperty.)
Public property | IsVisibleDesignTime | (Inherited from IProperty.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Order | Property display order number. (Inherited from IProperty.)
Public property | PropertyType | Property value type. (Inherited from IProperty.)
Public property | Quantity | (Inherited from IProperty.)
Public property | TabHeader | Property page tab header. (Inherited from IProperty.)
Public property | Unit | Effective unit of property. (Inherited from IProperty.)
Public property | Value | Strongly typed property value. (Inherited from IPropertyT.)
Top
See Also

Reference

IUriProperty Interface
VisualComponents.Create3D Namespace


IUriProperty.FolderSelection Property

IUriPropertyFolderSelection Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool FolderSelection { get; }
property bool FolderSelection {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IUriProperty Interface
VisualComponents.Create3D Namespace


IUriProperty Methods

The IUriProperty type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from IProperty.)
Public method | CreateAndSetNewValue | Set this property to a newly-created value. (Inherited from IProperty.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndBatch | End property value batching. (Inherited from IProperty.)
Public method | SetQuantity | (Inherited from IProperty.)
Public method | SetUnitMagnitude | Select an appropriate unit. (Inherited from IProperty.)
Public method | StartBatch | Start property batch updating. (Inherited from IProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Top
See Also

Reference

IUriProperty Interface
VisualComponents.Create3D Namespace


IUriProperty Events

The IUriProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IUriProperty Interface
VisualComponents.Create3D Namespace


IUrlHelper Interface

URL helper interface, because the .NET Uri class is broken.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IUrlHelper
public interface class IUrlHelper
Methods
 | Name | Description
Public method | ChangeUrlScheme(String, String) | Change scheme of URL by looking up in eCatalog.
Public method | ChangeUrlScheme(Uri, String) | Change scheme of URL by looking up in eCatalog.
Public method | ChangeUrlScheme(String, String, Boolean) | Change scheme of URL by looking up in eCatalog.
Public method | ChangeUrlScheme(Uri, String, Boolean) | Change scheme of URL by looking up in eCatalog.
Public method | CheckIsUrlRemoteEcat(String) | Check if an URL is a remote eCat url
Public method | CheckIsUrlRemoteEcat(Uri) | Check if an URL is a remote eCat url
Public method | GetLocalPathWithFragment(String) | Get local path with a fragment from URL string. Vcid-based paths are returned as is.
Public method | GetLocalPathWithFragment(String, Boolean) | Get local path with a fragment from URL string.
Public method | GetVcidFromUrl(String) | Look up VCID for url.
Public method | GetVcidFromUrl(Uri) | Look up VCID for url.
Public method | LocalPathToUrl(String) | Convert local path to URL. Note: '#' characters are converted to '%23'.
Public method | LocalPathToUrl(String, Boolean) | Convert local path to URL.
Public method | UrlToLocalPath(String) | Extract local path from URL string.
Public method | UrlToLocalPath(Uri) | Extract local path from URL object.
Top
Remarks

An implementation of interface is exported via MEF, but it should not be used until after the application is initialized.

See Also

Reference

VisualComponents.Create3D Namespace


IUrlHelper Methods

Methods
 | Name | Description
Public method | ChangeUrlScheme(String, String) | Change scheme of URL by looking up in eCatalog.
Public method | ChangeUrlScheme(Uri, String) | Change scheme of URL by looking up in eCatalog.
Public method | ChangeUrlScheme(String, String, Boolean) | Change scheme of URL by looking up in eCatalog.
Public method | ChangeUrlScheme(Uri, String, Boolean) | Change scheme of URL by looking up in eCatalog.
Public method | CheckIsUrlRemoteEcat(String) | Check if an URL is a remote eCat url
Public method | CheckIsUrlRemoteEcat(Uri) | Check if an URL is a remote eCat url
Public method | GetLocalPathWithFragment(String) | Get local path with a fragment from URL string. Vcid-based paths are returned as is.
Public method | GetLocalPathWithFragment(String, Boolean) | Get local path with a fragment from URL string.
Public method | GetVcidFromUrl(String) | Look up VCID for url.
Public method | GetVcidFromUrl(Uri) | Look up VCID for url.
Public method | LocalPathToUrl(String) | Convert local path to URL. Note: '#' characters are converted to '%23'.
Public method | LocalPathToUrl(String, Boolean) | Convert local path to URL.
Public method | UrlToLocalPath(String) | Extract local path from URL string.
Public method | UrlToLocalPath(Uri) | Extract local path from URL object.
Top
See Also

Reference

IUrlHelper Interface
VisualComponents.Create3D Namespace


IUrlHelper.ChangeUrlScheme Method

IUrlHelperChangeUrlScheme Method

Overload List
 | Name | Description
Public method | ChangeUrlScheme(String, String) | Change scheme of URL by looking up in eCatalog.
Public method | ChangeUrlScheme(Uri, String) | Change scheme of URL by looking up in eCatalog.
Public method | ChangeUrlScheme(String, String, Boolean) | Change scheme of URL by looking up in eCatalog.
Public method | ChangeUrlScheme(Uri, String, Boolean) | Change scheme of URL by looking up in eCatalog.
Top
See Also

Reference

IUrlHelper Interface
VisualComponents.Create3D Namespace


IUrlHelper.ChangeUrlScheme Method (String, String)

IUrlHelperChangeUrlScheme Method (String, String)

Change scheme of URL by looking up in eCatalog.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Uri ChangeUrlScheme(
    string url,
    string scheme
)
Uri^ ChangeUrlScheme(
    String^ url,
    String^ scheme
)

Parameters

url
Type: SystemString
Original URL
scheme
Type: SystemString
New scheme

Return Value

Type: Uri
Changed URL, or original URL if scheme could not be changed.
See Also

Reference

IUrlHelper Interface
ChangeUrlScheme Overload
VisualComponents.Create3D Namespace


IUrlHelper.ChangeUrlScheme Method (Uri, String)

IUrlHelperChangeUrlScheme Method (Uri, String)

Change scheme of URL by looking up in eCatalog.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Uri ChangeUrlScheme(
    Uri url,
    string scheme
)
Uri^ ChangeUrlScheme(
    Uri^ url,
    String^ scheme
)

Parameters

url
Type: SystemUri
Original URL
scheme
Type: SystemString
New scheme

Return Value

Type: Uri
Changed URL, or original URL if scheme could not be changed.
See Also

Reference

IUrlHelper Interface
ChangeUrlScheme Overload
VisualComponents.Create3D Namespace


IUrlHelper.ChangeUrlScheme Method (String, String, Boolean)

IUrlHelperChangeUrlScheme Method (String, String, Boolean)

Change scheme of URL by looking up in eCatalog.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Uri ChangeUrlScheme(
    string url,
    string scheme,
    bool canHaveFragment
)
Uri^ ChangeUrlScheme(
    String^ url,
    String^ scheme,
    bool canHaveFragment
)

Parameters

url
Type: SystemString
Original URL
scheme
Type: SystemString
New scheme
canHaveFragment
Type: SystemBoolean
Should support urls with fragment: 'layout.vcmx#part'.

Return Value

Type: Uri
Changed URL, or original URL if scheme could not be changed.
See Also

Reference

IUrlHelper Interface
ChangeUrlScheme Overload
VisualComponents.Create3D Namespace


IUrlHelper.ChangeUrlScheme Method (Uri, String, Boolean)

IUrlHelperChangeUrlScheme Method (Uri, String, Boolean)

Change scheme of URL by looking up in eCatalog.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Uri ChangeUrlScheme(
    Uri url,
    string scheme,
    bool canHaveFragment
)
Uri^ ChangeUrlScheme(
    Uri^ url,
    String^ scheme,
    bool canHaveFragment
)

Parameters

url
Type: SystemUri
Original URL
scheme
Type: SystemString
New scheme
canHaveFragment
Type: SystemBoolean
Should support urls with fragment: 'layout.vcmx#part'.

Return Value

Type: Uri
Changed URL, or original URL if scheme could not be changed.
See Also

Reference

IUrlHelper Interface
ChangeUrlScheme Overload
VisualComponents.Create3D Namespace


IUrlHelper.CheckIsUrlRemoteEcat Method

IUrlHelperCheckIsUrlRemoteEcat Method

Overload List
 | Name | Description
Public method | CheckIsUrlRemoteEcat(String) | Check if an URL is a remote eCat url
Public method | CheckIsUrlRemoteEcat(Uri) | Check if an URL is a remote eCat url
Top
See Also

Reference

IUrlHelper Interface
VisualComponents.Create3D Namespace


IUrlHelper.CheckIsUrlRemoteEcat Method (String)

IUrlHelperCheckIsUrlRemoteEcat Method (String)

Check if an URL is a remote eCat url

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CheckIsUrlRemoteEcat(
    string url
)
bool CheckIsUrlRemoteEcat(
    String^ url
)

Parameters

url
Type: SystemString

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IUrlHelper.CheckIsUrlRemoteEcat(System.String)"]

See Also

Reference

IUrlHelper Interface
CheckIsUrlRemoteEcat Overload
VisualComponents.Create3D Namespace


IUrlHelper.CheckIsUrlRemoteEcat Method (Uri)

IUrlHelperCheckIsUrlRemoteEcat Method (Uri)

Check if an URL is a remote eCat url

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CheckIsUrlRemoteEcat(
    Uri url
)
bool CheckIsUrlRemoteEcat(
    Uri^ url
)

Parameters

url
Type: SystemUri

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IUrlHelper.CheckIsUrlRemoteEcat(System.Uri)"]

See Also

Reference

IUrlHelper Interface
CheckIsUrlRemoteEcat Overload
VisualComponents.Create3D Namespace


IUrlHelper.GetLocalPathWithFragment Method

IUrlHelperGetLocalPathWithFragment Method

Overload List
 | Name | Description
Public method | GetLocalPathWithFragment(String) | Get local path with a fragment from URL string. Vcid-based paths are returned as is.
Public method | GetLocalPathWithFragment(String, Boolean) | Get local path with a fragment from URL string.
Top
See Also

Reference

IUrlHelper Interface
VisualComponents.Create3D Namespace


IUrlHelper.GetLocalPathWithFragment Method (String)

IUrlHelperGetLocalPathWithFragment Method (String)

Get local path with a fragment from URL string. Vcid-based paths are returned as is.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string GetLocalPathWithFragment(
    string path
)
String^ GetLocalPathWithFragment(
    String^ path
)

Parameters

path
Type: SystemString
url

Return Value

Type: String
local path with fragment
See Also

Reference

IUrlHelper Interface
GetLocalPathWithFragment Overload
VisualComponents.Create3D Namespace


IUrlHelper.GetLocalPathWithFragment Method (String, Boolean)

IUrlHelperGetLocalPathWithFragment Method (String, Boolean)

Get local path with a fragment from URL string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string GetLocalPathWithFragment(
    string path,
    bool autoConvert
)
String^ GetLocalPathWithFragment(
    String^ path,
    bool autoConvert
)

Parameters

path
Type: SystemString
url
autoConvert
Type: SystemBoolean
try to convert vcid url to file path

Return Value

Type: String
local path with fragment
See Also

Reference

IUrlHelper Interface
GetLocalPathWithFragment Overload
VisualComponents.Create3D Namespace


IUrlHelper.GetVcidFromUrl Method

IUrlHelperGetVcidFromUrl Method

Overload List
 | Name | Description
Public method | GetVcidFromUrl(String) | Look up VCID for url.
Public method | GetVcidFromUrl(Uri) | Look up VCID for url.
Top
See Also

Reference

IUrlHelper Interface
VisualComponents.Create3D Namespace


IUrlHelper.GetVcidFromUrl Method (String)

IUrlHelperGetVcidFromUrl Method (String)

Look up VCID for url.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string GetVcidFromUrl(
    string url
)
String^ GetVcidFromUrl(
    String^ url
)

Parameters

url
Type: SystemString

Return Value

Type: String
VCID string, or empty string if not found.
See Also

Reference

IUrlHelper Interface
GetVcidFromUrl Overload
VisualComponents.Create3D Namespace


IUrlHelper.GetVcidFromUrl Method (Uri)

IUrlHelperGetVcidFromUrl Method (Uri)

Look up VCID for url.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string GetVcidFromUrl(
    Uri url
)
String^ GetVcidFromUrl(
    Uri^ url
)

Parameters

url
Type: SystemUri

Return Value

Type: String
VCID string, or empty string if not found.
See Also

Reference

IUrlHelper Interface
GetVcidFromUrl Overload
VisualComponents.Create3D Namespace


IUrlHelper.LocalPathToUrl Method

IUrlHelperLocalPathToUrl Method

Overload List
 | Name | Description
Public method | LocalPathToUrl(String) | Convert local path to URL. Note: '#' characters are converted to '%23'.
Public method | LocalPathToUrl(String, Boolean) | Convert local path to URL.
Top
See Also

Reference

IUrlHelper Interface
VisualComponents.Create3D Namespace


IUrlHelper.LocalPathToUrl Method (String)

IUrlHelperLocalPathToUrl Method (String)

Convert local path to URL. Note: '#' characters are converted to '%23'.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Uri LocalPathToUrl(
    string localPath
)
Uri^ LocalPathToUrl(
    String^ localPath
)

Parameters

localPath
Type: SystemString

Return Value

Type: Uri

[Missing <returns> documentation for "M:VisualComponents.Create3D.IUrlHelper.LocalPathToUrl(System.String)"]

See Also

Reference

IUrlHelper Interface
LocalPathToUrl Overload
VisualComponents.Create3D Namespace


IUrlHelper.LocalPathToUrl Method (String, Boolean)

IUrlHelperLocalPathToUrl Method (String, Boolean)

Convert local path to URL.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Uri LocalPathToUrl(
    string localPath,
    bool canHaveFragment
)
Uri^ LocalPathToUrl(
    String^ localPath,
    bool canHaveFragment
)

Parameters

localPath
Type: SystemString
canHaveFragment
Type: SystemBoolean
Should support urls with fragment: 'layout.vcmx#part'.

Return Value

Type: Uri

[Missing <returns> documentation for "M:VisualComponents.Create3D.IUrlHelper.LocalPathToUrl(System.String,System.Boolean)"]

See Also

Reference

IUrlHelper Interface
LocalPathToUrl Overload
VisualComponents.Create3D Namespace


IUrlHelper.UrlToLocalPath Method

IUrlHelperUrlToLocalPath Method

Overload List
 | Name | Description
Public method | UrlToLocalPath(String) | Extract local path from URL string.
Public method | UrlToLocalPath(Uri) | Extract local path from URL object.
Top
See Also

Reference

IUrlHelper Interface
VisualComponents.Create3D Namespace


IUrlHelper.UrlToLocalPath Method (String)

IUrlHelperUrlToLocalPath Method (String)

Extract local path from URL string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string UrlToLocalPath(
    string url
)
String^ UrlToLocalPath(
    String^ url
)

Parameters

url
Type: SystemString

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.IUrlHelper.UrlToLocalPath(System.String)"]

See Also

Reference

IUrlHelper Interface
UrlToLocalPath Overload
VisualComponents.Create3D Namespace


IUrlHelper.UrlToLocalPath Method (Uri)

IUrlHelperUrlToLocalPath Method (Uri)

Extract local path from URL object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string UrlToLocalPath(
    Uri url
)
String^ UrlToLocalPath(
    Uri^ url
)

Parameters

url
Type: SystemUri

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.IUrlHelper.UrlToLocalPath(System.Uri)"]

See Also

Reference

IUrlHelper Interface
UrlToLocalPath Overload
VisualComponents.Create3D Namespace


IUserMaterialLibraryService Interface

Service that provides methods to load, save or update user materials

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IUserMaterialLibraryService
public interface class IUserMaterialLibraryService

The IUserMaterialLibraryService type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBitmap | Generates a bitmap from given image path.
Public method | LoadMaterials | Loads all user library materials defined under "My Materials"
Public method | SaveOrUpdate | Saves or updates all IMaterial that has IsUserDefined property set to true.
Public method | ShaderToMaterialConversion | Give Material, tries to set diffusion, specular and ambient values based on the material shader properties
Top
See Also

Reference

VisualComponents.Create3D Namespace


IUserMaterialLibraryService Methods

The IUserMaterialLibraryService type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBitmap | Generates a bitmap from given image path.
Public method | LoadMaterials | Loads all user library materials defined under "My Materials"
Public method | SaveOrUpdate | Saves or updates all IMaterial that has IsUserDefined property set to true.
Public method | ShaderToMaterialConversion | Give Material, tries to set diffusion, specular and ambient values based on the material shader properties
Top
See Also

Reference

IUserMaterialLibraryService Interface
VisualComponents.Create3D Namespace


IUserMaterialLibraryService.GenerateBitmap Method

IUserMaterialLibraryServiceGenerateBitmap Method

Generates a bitmap from given image path.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Bitmap GenerateBitmap(
    string path
)
Bitmap^ GenerateBitmap(
    String^ path
)

Parameters

path
Type: SystemString

Return Value

Type: Bitmap

[Missing <returns> documentation for "M:VisualComponents.Create3D.IUserMaterialLibraryService.GenerateBitmap(System.String)"]

Remarks
This method is useful to assign textures to materials as it tries to convert the given image into a "Format24bppRgb" pixel format bitmap.
See Also

Reference

IUserMaterialLibraryService Interface
VisualComponents.Create3D Namespace


IUserMaterialLibraryService.LoadMaterials Method

IUserMaterialLibraryServiceLoadMaterials Method

Loads all user library materials defined under "My Materials"

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void LoadMaterials()
void LoadMaterials()
See Also

Reference

IUserMaterialLibraryService Interface
VisualComponents.Create3D Namespace


IUserMaterialLibraryService.SaveOrUpdate Method

IUserMaterialLibraryServiceSaveOrUpdate Method

Saves or updates all IMaterial that has IsUserDefined property set to true.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SaveOrUpdate()
void SaveOrUpdate()
See Also

Reference

IUserMaterialLibraryService Interface
VisualComponents.Create3D Namespace


IUserMaterialLibraryService.ShaderToMaterialConversion Method

IUserMaterialLibraryServiceShaderToMaterialConversion Method

Give Material, tries to set diffusion, specular and ambient values based on the material shader properties

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ShaderToMaterialConversion(
    IMaterial material
)
void ShaderToMaterialConversion(
    IMaterial^ material
)

Parameters

material
Type: VisualComponents.Create3DIMaterial
See Also

Reference

IUserMaterialLibraryService Interface
VisualComponents.Create3D Namespace


IUserSettingService Interface

User setting interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IUserSettingService
public interface class IUserSettingService

The IUserSettingService type exposes the following members.

Properties
 | Name | Description
Public property | DecimalPrecision | Decimal precision property
Public property | DimensionAccuracy | Dimension accuracy property
Public property | TrailingZeroVisible | Trailing zero visible property
Public property | UnitFamily | Unit family property
Top
Methods
 | Name | Description
Public method | Refresh | refreshes previously loaded values
Top
See Also

Reference

VisualComponents.Create3D Namespace


IUserSettingService Properties

The IUserSettingService type exposes the following members.

Properties
 | Name | Description
Public property | DecimalPrecision | Decimal precision property
Public property | DimensionAccuracy | Dimension accuracy property
Public property | TrailingZeroVisible | Trailing zero visible property
Public property | UnitFamily | Unit family property
Top
See Also

Reference

IUserSettingService Interface
VisualComponents.Create3D Namespace


IUserSettingService.DecimalPrecision Property

IUserSettingServiceDecimalPrecision Property

Decimal precision property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
uint DecimalPrecision { get; }
property unsigned int DecimalPrecision {
    unsigned int get ();
}

Property Value

Type: UInt32
See Also

Reference

IUserSettingService Interface
VisualComponents.Create3D Namespace


IUserSettingService.DimensionAccuracy Property

IUserSettingServiceDimensionAccuracy Property

Dimension accuracy property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
uint DimensionAccuracy { get; }
property unsigned int DimensionAccuracy {
    unsigned int get ();
}

Property Value

Type: UInt32
See Also

Reference

IUserSettingService Interface
VisualComponents.Create3D Namespace


IUserSettingService.TrailingZeroVisible Property

IUserSettingServiceTrailingZeroVisible Property

Trailing zero visible property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool TrailingZeroVisible { get; }
property bool TrailingZeroVisible {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IUserSettingService Interface
VisualComponents.Create3D Namespace


IUserSettingService.UnitFamily Property

IUserSettingServiceUnitFamily Property

Unit family property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string UnitFamily { get; }
property String^ UnitFamily {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IUserSettingService Interface
VisualComponents.Create3D Namespace


IUserSettingService Methods

The IUserSettingService type exposes the following members.

Methods
 | Name | Description
Public method | Refresh | refreshes previously loaded values
Top
See Also

Reference

IUserSettingService Interface
VisualComponents.Create3D Namespace


IUserSettingService.Refresh Method

IUserSettingServiceRefresh Method

refreshes previously loaded values

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Refresh()
void Refresh()
See Also

Reference

IUserSettingService Interface
VisualComponents.Create3D Namespace


IWaitDigitalInputStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IWaitDigitalInputStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IWaitDigitalInputStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IWaitDigitalInputStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | InputPort |
Public property | InputValue |
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | WaitTrigger |
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IWaitDigitalInputStatement Properties

The IWaitDigitalInputStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | InputPort |
Public property | InputValue |
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | WaitTrigger |
Top
See Also

Reference

IWaitDigitalInputStatement Interface
VisualComponents.Create3D Namespace


IWaitDigitalInputStatement.InputPort Property

IWaitDigitalInputStatementInputPort Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int InputPort { get; set; }
property int InputPort {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IWaitDigitalInputStatement Interface
VisualComponents.Create3D Namespace


IWaitDigitalInputStatement.InputValue Property

IWaitDigitalInputStatementInputValue Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool InputValue { get; set; }
property bool InputValue {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IWaitDigitalInputStatement Interface
VisualComponents.Create3D Namespace


IWaitDigitalInputStatement.WaitTrigger Property

IWaitDigitalInputStatementWaitTrigger Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool WaitTrigger { get; set; }
property bool WaitTrigger {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IWaitDigitalInputStatement Interface
VisualComponents.Create3D Namespace


IWaitDigitalInputStatement Methods

The IWaitDigitalInputStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IWaitDigitalInputStatement Interface
VisualComponents.Create3D Namespace


IWaitDigitalInputStatement Events

The IWaitDigitalInputStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IWaitDigitalInputStatement Interface
VisualComponents.Create3D Namespace


IWaitPropertyConditionStatement Interface

Waits until a property with VariableName fulfills the condition of ConditionExpression.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IWaitPropertyConditionStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IWaitPropertyConditionStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IWaitPropertyConditionStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConditionExpression | Gets or sets the condition expression to evaluate on the VariableName IProperty.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | VariableName | Gets or sets the name of the process IProperty to watch.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IWaitPropertyConditionStatement Properties

The IWaitPropertyConditionStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConditionExpression | Gets or sets the condition expression to evaluate on the VariableName IProperty.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | VariableName | Gets or sets the name of the process IProperty to watch.
Top
See Also

Reference

IWaitPropertyConditionStatement Interface
VisualComponents.Create3D Namespace


IWaitPropertyConditionStatement.ConditionExpression Property

IWaitPropertyConditionStatementConditionExpression Property

Gets or sets the condition expression to evaluate on the VariableName IProperty.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ConditionExpression { get; set; }
property String^ ConditionExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown by setter when supplied value is null.
Remarks
This expression has access to UPM variables stored in IProcessRoutine.
See Also

Reference

IWaitPropertyConditionStatement Interface
VisualComponents.Create3D Namespace


IWaitPropertyConditionStatement.VariableName Property

IWaitPropertyConditionStatementVariableName Property

Gets or sets the name of the process IProperty to watch.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string VariableName { get; set; }
property String^ VariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown by setter when supplied value is null.
See Also

Reference

IWaitPropertyConditionStatement Interface
VisualComponents.Create3D Namespace


IWaitPropertyConditionStatement Methods

The IWaitPropertyConditionStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IWaitPropertyConditionStatement Interface
VisualComponents.Create3D Namespace


IWaitPropertyConditionStatement Events

The IWaitPropertyConditionStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IWaitPropertyConditionStatement Interface
VisualComponents.Create3D Namespace


IWaitSignalStatement Interface

Process statement for waiting until a signal is triggered with value matching a condition.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IWaitSignalStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IWaitSignalStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IWaitSignalStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConditionExpression | The condition to evaluate on each received signal value.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | SelectedComponent | A static ISimComponent of which the ISignal will be sent from. Null value means to get from the same ISimComponent this IStatement is executing in.
Public property | SelectedSignal | The ISignal to monitor. Setting this will also set SelectedComponent.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IWaitSignalStatement Properties

The IWaitSignalStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ConditionExpression | The condition to evaluate on each received signal value.
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | SelectedComponent | A static ISimComponent of which the ISignal will be sent from. Null value means to get from the same ISimComponent this IStatement is executing in.
Public property | SelectedSignal | The ISignal to monitor. Setting this will also set SelectedComponent.
Top
See Also

Reference

IWaitSignalStatement Interface
VisualComponents.Create3D Namespace


IWaitSignalStatement.ConditionExpression Property

IWaitSignalStatementConditionExpression Property

The condition to evaluate on each received signal value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ConditionExpression { get; set; }
property String^ ConditionExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
This expression has access to variables stored in IProcessRoutine.
See Also

Reference

IWaitSignalStatement Interface
VisualComponents.Create3D Namespace


IWaitSignalStatement.SelectedComponent Property

IWaitSignalStatementSelectedComponent Property

A static ISimComponent of which the ISignal will be sent from.

Null value means to get from the same ISimComponent this IStatement is executing in.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent SelectedComponent { get; }
property ISimComponent^ SelectedComponent {
    ISimComponent^ get ();
}

Property Value

Type: ISimComponent
See Also

Reference

IWaitSignalStatement Interface
VisualComponents.Create3D Namespace


IWaitSignalStatement.SelectedSignal Property

IWaitSignalStatementSelectedSignal Property

The ISignal to monitor. Setting this will also set SelectedComponent.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISignal SelectedSignal { get; set; }
property ISignal^ SelectedSignal {
    ISignal^ get ();
    void set (ISignal^ value);
}

Property Value

Type: ISignal
Exceptions
Exception | Condition
ArgumentNullException | Thrown if trying to set a null value
ArgumentException | Thrown if there is an error while processing the argument
See Also

Reference

IWaitSignalStatement Interface
VisualComponents.Create3D Namespace


IWaitSignalStatement Methods

The IWaitSignalStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IWaitSignalStatement Interface
VisualComponents.Create3D Namespace


IWaitSignalStatement Events

The IWaitSignalStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IWaitSignalStatement Interface
VisualComponents.Create3D Namespace


IWaitTransportStatement Interface

Blocks and waits for one or more transport operations started by IStartTransportInStatement or IStartTransportOutStatement to complete. Transport operations are identified by ProductVariableName used in those statements.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IWaitTransportStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IWaitTransportStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IWaitTransportStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductVariableName | Gets or sets the name of the variable used in the matching IStartTransportInStatement or IStartTransportOutStatement.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IWaitTransportStatement Properties

The IWaitTransportStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProductVariableName | Gets or sets the name of the variable used in the matching IStartTransportInStatement or IStartTransportOutStatement.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Top
See Also

Reference

IWaitTransportStatement Interface
VisualComponents.Create3D Namespace


IWaitTransportStatement.ProductVariableName Property

IWaitTransportStatementProductVariableName Property

Gets or sets the name of the variable used in the matching IStartTransportInStatement or IStartTransportOutStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ProductVariableName { get; set; }
property String^ ProductVariableName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown by setter when supplied value is null.
See Also

Reference

IWaitTransportStatement Interface
VisualComponents.Create3D Namespace


IWaitTransportStatement Methods

The IWaitTransportStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IWaitTransportStatement Interface
VisualComponents.Create3D Namespace


IWaitTransportStatement Events

The IWaitTransportStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IWaitTransportStatement Interface
VisualComponents.Create3D Namespace


IWedgeFeature Interface

Wedge feature interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IWedgeFeature : IPrimitiveFeature,
    IFeature, IVisualObject, INamed, IWrapper, IDisposable,
    IVisitable, IPropertyContainer, IBatchModeObject, ISharedCloneable
public interface class IWedgeFeature : IPrimitiveFeature,
    IFeature, IVisualObject, INamed, IWrapper, IDisposable,
    IVisitable, IPropertyContainer, IBatchModeObject, ISharedCloneable

The IWedgeFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
Remarks

The Wedge geometry primitive generates a wedge-like shape with the specified dimensions.

The basic shape is a cuboid that is truncated with a plane parallel to the Y axis that intersects the far X-Y (top) and Y-Z (front) faces, at specified distances along the X and Z axes, respectively.

This shape may then be reflected through the X-Y (bottom) plane, the Y-Z (back) plane, or both.

See Also

Reference

VisualComponents.Create3D Namespace


IWedgeFeature Properties

The IWedgeFeature type exposes the following members.

Properties
 | Name | Description
Public property | AlignedBoundBox | Retrieves the bounding box of this feature aligned to local coordinates. (Inherited from IFeature.)
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates. (Inherited from IVisualObject.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ChildCount | Number of child features. (Inherited from IFeature.)
Public property | Children | Retrieves all children feature (Inherited from IFeature.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | CreatesOriginalGeoSet | Indicates if the featue is a geometry feature or primitive feature (Inherited from IFeature.)
Public property | FeatureComplexity | Estimated complexity. If >1.0 manipulation is done on mouse release. (Inherited from IFeature.)
Public property | IsHighlighted | (Inherited from IVisualObject.)
Public property | IsSharedClone | Indicates if this object shares data with another object. (Inherited from ISharedCloneable.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object (Inherited from IVisualObject.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeInstances | Retrieves all ISimNode instances where this feature is referenced (Inherited from IFeature.)
Public property | Parent | Feature's parent in the feature tree (Inherited from IFeature.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center. (Inherited from IVisualObject.)
Public property | RootFeature | Retrieves the root node of the feature tree where this feature is located (Inherited from IFeature.)
Public property | SelectionType | (Inherited from IVisualObject.)
Public property | SharingId | Sharing ID of the shared data. (Inherited from ISharedCloneable.)
Public property | TotalBoundBox | Retrieves the bounding box of this feature and it's children. (Inherited from IFeature.)
Public property | TransformationInNode | Gets or sets the transformation matrix in simulation node's space. (Inherited from IFeature.)
Public property | TransformationInNodeReal | Gets transformation in simulation node's space, without temporary origin. Note: TransformationInNode temporarely changes when moving feature's origin, but is restored on model load. (Inherited from IFeature.)
Public property | TransformationInReference | Gets or sets the transformation matrix. (Inherited from IFeature.)
Public property | TransformationInWorld | Obsolete. This is Not a world position. Use ISimNode.GetFeatureTransformationInWorld(feature) instead. (Inherited from IFeature.)
Public property | Type | Feature type (Inherited from IFeature.)
Top
See Also

Reference

IWedgeFeature Interface
VisualComponents.Create3D Namespace


IWedgeFeature Methods

The IWedgeFeature type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | AddChild(IFeature, Int32) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | AddChild(IFeature, Int32, Boolean, Boolean) | Adds a child feature in the given index position (Inherited from IFeature.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CanCollapse | Determines if an IFeature can be collapsed (Inherited from IFeature.)
Public method | Clone(CloningMode) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean) | Create a clone of the object. (Inherited from ISharedCloneable.)
Public method | Clone(CloningMode, Boolean, ISharedCloneable) | Create a clone of the object and add it to a new parent. (Inherited from ISharedCloneable.)
Public method | Collapse | Collapses the feature and all of its child features into a new Geometry feature. All geometries in the sub features are placed into the new geometry feature and original features are invalidated. Thus, the original feature structure is permanently deleted. (Inherited from IFeature.)
Public method | CreateFeatureT | Creates a feature and it gives to it a valid name. It also perform a local update (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean) | Creates a feature and it gives to it a valid name (Inherited from IFeature.)
Public method | CreateFeatureT(Boolean, Boolean) | Creates a features (Inherited from IFeature.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | Delete | Deletes the feature and all its child features. (Inherited from IFeature.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | FindNode | From the given IVisualObject it will try to locate any node where this feature is present. (Inherited from IFeature.)
Public method | GetCombinedBoundBox | Get bound box including specified features. Bounds are define in SimNode space. (Inherited from IFeature.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | InvalidateBounds | Finalize changes after finished moving with IFeature.TransformationInWorld. (Inherited from IFeature.)
Public method | MakeUnique | Ensure that this object shares no data with other objects. (Inherited from ISharedCloneable.)
Public method | Rebuild | Update geosets affected by this feature. This method is called automatically on each move. (Inherited from IFeature.)
Public method | RebuildNodes | re evaluate the feature tree (Inherited from IFeature.)
Public method | SetDynamicProperty | This is used for variables, that are created on demand. (Inherited from IFeature.)
Public method | SetName(String) | This method sets the name of the feature without checking if it is valid name (Inherited from IFeature.)
Public method | SetName(String, Boolean) | This method sets the name of the feature. (Inherited from IFeature.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | SetTransformationsOptimized | Batch update feature positions. This feature should be the first feature in the "features" list. (Inherited from IFeature.)
Public method | TransformContent | Transform all the content by the given matrix. (Inherited from IVisualObject.)
Public method | ValidateName | Change name to the next valid one. (Inherited from IFeature.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IWedgeFeature Interface
VisualComponents.Create3D Namespace


IWedgeFeature Events

The IWedgeFeature type exposes the following members.

Events
 | Name | Description
Public event | FeatureHierarchyChanged | Occurs when a feature hierarchy is modified. This event is only signaled from the root feature. (Inherited from IFeature.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | TransformationChanged | Transformation changed event (Inherited from IVisualObject.)
Top
See Also

Reference

IWedgeFeature Interface
VisualComponents.Create3D Namespace


IVehicle Interface

Vehicle behavior that provides automnoumous movement scheduling for components.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IVehicle : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IVehicle : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IVehicle type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IVehicle Properties

The IVehicle type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IVehicle Interface
VisualComponents.Create3D Namespace


IVehicle Methods

The IVehicle type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IVehicle Interface
VisualComponents.Create3D Namespace


IVehicle Events

The IVehicle type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IVehicle Interface
VisualComponents.Create3D Namespace


IWhileStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IWhileStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable, IStatementScope,
    IInterpolatable
public interface class IWhileStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable, IStatementScope,
    IInterpolatable

The IWhileStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Condition |
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IWhileStatement Properties

The IWhileStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | Condition |
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | ParentStatement | Gets the instance of IStatement that owns this statement. This is null if the parent is an instance of IRoutine. (Inherited from IStatementScope.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | StatementCount | Gets the number of direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Public property | Statements | Gets all the direct child statements belonging to this instance of IStatementScope. (Inherited from IStatementScope.)
Top
See Also

Reference

IWhileStatement Interface
VisualComponents.Create3D Namespace


IWhileStatement.Condition Property

IWhileStatementCondition Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Condition { get; set; }
property String^ Condition {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IWhileStatement Interface
VisualComponents.Create3D Namespace


IWhileStatement Methods

The IWhileStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clear | Deletes all the statements in this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | DeleteStatement | Deletes the given statement from this instance of IStatementScope. (Inherited from IStatementScope.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | EndInterpolation | Notifies that that the interpolation has been finished and all the interpolation related data can be released (Inherited from IInterpolatable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | GetStatement | Gets a statement at the given position. (Inherited from IStatementScope.)
Public method | InsertStatement | Inserts the goven statement to the given position. (Inherited from IStatementScope.)
Public method | Interpolate | Gets the interpolated target at the given length and assigns the result to the given target, creating it if null is given. (Inherited from IInterpolatable.)
Public method | MoveStatement | Moves the given statement to the new position inside this instance of IStatementScope. If the given index is less than zero or greater than the current statement count, the statement will be moved to the end of the scope. (Inherited from IStatementScope.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | StartInterpolation | Calculates the cycle length and initializes the interpolator. (Inherited from IInterpolatable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IWhileStatement Interface
VisualComponents.Create3D Namespace


IWhileStatement Events

The IWhileStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Public event | ScopeExecuted | Occurs when statement has been executed. (Inherited from IStatementScope.)
Public event | StatementAdded | Occurs when a statement has been added to this scope. (Inherited from IStatementScope.)
Public event | StatementMoved | Occurs when statement has been moved in this scope. (Inherited from IStatementScope.)
Public event | StatementRemoved | Occurs when a statement has been removed from this scope. (Inherited from IStatementScope.)
Public event | StatementRemoving | Occurs when a statement is being removed from this scope. (Inherited from IStatementScope.)
Top
See Also

Reference

IWhileStatement Interface
VisualComponents.Create3D Namespace


IVideoRecorder Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IVideoRecorder : IRecorder,
    IDisposable
public interface class IVideoRecorder : IRecorder,
    IDisposable

The IVideoRecorder type exposes the following members.

Properties
 | Name | Description
Public property | Bitrate | Quality bitrate
Public property | Codec | Video codec
Public property | EndTime | Recording end time
Public property | Format | Video file format
Public property | FrameRate | Defines the frame rate (fps) of the recorder. (Inherited from IRecorder.)
Public property | Height | Resolution height or 0 for window height.
Public property | IsPaused | Pause/Unpause current record
Public property | IsRecording | Defines if the recorder has been started. (Inherited from IRecorder.)
Public property | RecordingHeight | Resolution height
Public property | RecordingWidth | Resolution width
Public property | ShowVideo | Show or not video after create it
Public property | Speed | Recording speed compare to simulation time
Public property | StartTime | Recording start time
Public property | Width | Resolution width or 0 for window width.
Top
Methods
 | Name | Description
Public method | Cancel | Cancels current recording
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Start | Starts and initializes the recorder. (Inherited from IRecorder.)
Public method | Start(Boolean) | Starts the recording of the simulation in paused mode
Public method | Stop | Stops the recorder and saves the result to the given file. (Inherited from IRecorder.)
Top
Events
 | Name | Description
Public event | VideoCreationProgress | Raised during video creation.
Public event | VideoRecordingFrame | Raised for every recorded frame
Public event | VideoRecordingNotification | Raised if an exception occurs during video creation
Top
See Also

Reference

VisualComponents.Create3D Namespace


IVideoRecorder Properties

The IVideoRecorder type exposes the following members.

Properties
 | Name | Description
Public property | Bitrate | Quality bitrate
Public property | Codec | Video codec
Public property | EndTime | Recording end time
Public property | Format | Video file format
Public property | FrameRate | Defines the frame rate (fps) of the recorder. (Inherited from IRecorder.)
Public property | Height | Resolution height or 0 for window height.
Public property | IsPaused | Pause/Unpause current record
Public property | IsRecording | Defines if the recorder has been started. (Inherited from IRecorder.)
Public property | RecordingHeight | Resolution height
Public property | RecordingWidth | Resolution width
Public property | ShowVideo | Show or not video after create it
Public property | Speed | Recording speed compare to simulation time
Public property | StartTime | Recording start time
Public property | Width | Resolution width or 0 for window width.
Top
See Also

Reference

IVideoRecorder Interface
VisualComponents.Create3D Namespace


IVideoRecorder.Bitrate Property

IVideoRecorderBitrate Property

Quality bitrate

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Bitrate { get; set; }
property double Bitrate {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IVideoRecorder Interface
VisualComponents.Create3D Namespace


IVideoRecorder.Codec Property

IVideoRecorderCodec Property

Video codec

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
VideoCodec Codec { get; set; }
property VideoCodec Codec {
    VideoCodec get ();
    void set (VideoCodec value);
}

Property Value

Type: VideoCodec
See Also

Reference

IVideoRecorder Interface
VisualComponents.Create3D Namespace


IVideoRecorder.EndTime Property

IVideoRecorderEndTime Property

Recording end time

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int EndTime { get; set; }
property int EndTime {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IVideoRecorder Interface
VisualComponents.Create3D Namespace


IVideoRecorder.Format Property

IVideoRecorderFormat Property

Video file format

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
VideoFormat Format { get; set; }
property VideoFormat Format {
    VideoFormat get ();
    void set (VideoFormat value);
}

Property Value

Type: VideoFormat
See Also

Reference

IVideoRecorder Interface
VisualComponents.Create3D Namespace


IVideoRecorder.Height Property

IVideoRecorderHeight Property

Resolution height or 0 for window height.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int Height { get; set; }
property int Height {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IVideoRecorder Interface
VisualComponents.Create3D Namespace


IVideoRecorder.IsPaused Property

IVideoRecorderIsPaused Property

Pause/Unpause current record

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsPaused { get; set; }
property bool IsPaused {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IVideoRecorder Interface
VisualComponents.Create3D Namespace


IVideoRecorder.RecordingHeight Property

IVideoRecorderRecordingHeight Property

Resolution height

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int RecordingHeight { get; }
property int RecordingHeight {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IVideoRecorder Interface
VisualComponents.Create3D Namespace


IVideoRecorder.RecordingWidth Property

IVideoRecorderRecordingWidth Property

Resolution width

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int RecordingWidth { get; }
property int RecordingWidth {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IVideoRecorder Interface
VisualComponents.Create3D Namespace


IVideoRecorder.ShowVideo Property

IVideoRecorderShowVideo Property

Show or not video after create it

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ShowVideo { get; set; }
property bool ShowVideo {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IVideoRecorder Interface
VisualComponents.Create3D Namespace


IVideoRecorder.Speed Property

IVideoRecorderSpeed Property

Recording speed compare to simulation time

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Speed { get; set; }
property double Speed {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IVideoRecorder Interface
VisualComponents.Create3D Namespace


IVideoRecorder.StartTime Property

IVideoRecorderStartTime Property

Recording start time

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int StartTime { get; set; }
property int StartTime {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IVideoRecorder Interface
VisualComponents.Create3D Namespace


IVideoRecorder.Width Property

IVideoRecorderWidth Property

Resolution width or 0 for window width.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int Width { get; set; }
property int Width {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IVideoRecorder Interface
VisualComponents.Create3D Namespace


IVideoRecorder Methods

The IVideoRecorder type exposes the following members.

Methods
 | Name | Description
Public method | Cancel | Cancels current recording
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Start | Starts and initializes the recorder. (Inherited from IRecorder.)
Public method | Start(Boolean) | Starts the recording of the simulation in paused mode
Public method | Stop | Stops the recorder and saves the result to the given file. (Inherited from IRecorder.)
Top
See Also

Reference

IVideoRecorder Interface
VisualComponents.Create3D Namespace


IVideoRecorder.Cancel Method

IVideoRecorderCancel Method

Cancels current recording

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Cancel()
void Cancel()
See Also

Reference

IVideoRecorder Interface
VisualComponents.Create3D Namespace


IVideoRecorder.Start Method

IVideoRecorderStart Method

Overload List
 | Name | Description
Public method | Start | Starts and initializes the recorder. (Inherited from IRecorder.)
Public method | Start(Boolean) | Starts the recording of the simulation in paused mode
Top
See Also

Reference

IVideoRecorder Interface
VisualComponents.Create3D Namespace


IVideoRecorder.Start Method (Boolean)

IVideoRecorderStart Method (Boolean)

Starts the recording of the simulation in paused mode

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Start(
    bool paused
)
void Start(
    bool paused
)

Parameters

paused
Type: SystemBoolean
See Also

Reference

IVideoRecorder Interface
Start Overload
VisualComponents.Create3D Namespace


IVideoRecorder Events

The IVideoRecorder type exposes the following members.

Events
 | Name | Description
Public event | VideoCreationProgress | Raised during video creation.
Public event | VideoRecordingFrame | Raised for every recorded frame
Public event | VideoRecordingNotification | Raised if an exception occurs during video creation
Top
See Also

Reference

IVideoRecorder Interface
VisualComponents.Create3D Namespace


IVideoRecorder.VideoCreationProgress Event

IVideoRecorderVideoCreationProgress Event

Raised during video creation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<VideoCreationProgressEventArgs> VideoCreationProgress
 event EventHandler<VideoCreationProgressEventArgs^>^ VideoCreationProgress {
    void add (EventHandler<VideoCreationProgressEventArgs^>^ value);
    void remove (EventHandler<VideoCreationProgressEventArgs^>^ value);
}

Value

Type: SystemEventHandlerVideoCreationProgressEventArgs
See Also

Reference

IVideoRecorder Interface
VisualComponents.Create3D Namespace


IVideoRecorder.VideoRecordingFrame Event

IVideoRecorderVideoRecordingFrame Event

Raised for every recorded frame

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<VideoCreationFrameEventArgs> VideoRecordingFrame
 event EventHandler<VideoCreationFrameEventArgs^>^ VideoRecordingFrame {
    void add (EventHandler<VideoCreationFrameEventArgs^>^ value);
    void remove (EventHandler<VideoCreationFrameEventArgs^>^ value);
}

Value

Type: SystemEventHandlerVideoCreationFrameEventArgs
See Also

Reference

IVideoRecorder Interface
VisualComponents.Create3D Namespace


IVideoRecorder.VideoRecordingNotification Event

IVideoRecorderVideoRecordingNotification Event

Raised if an exception occurs during video creation

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<VideoCreationNotificationEventArgs> VideoRecordingNotification
 event EventHandler<VideoCreationNotificationEventArgs^>^ VideoRecordingNotification {
    void add (EventHandler<VideoCreationNotificationEventArgs^>^ value);
    void remove (EventHandler<VideoCreationNotificationEventArgs^>^ value);
}

Value

Type: SystemEventHandlerVideoCreationNotificationEventArgs
See Also

Reference

IVideoRecorder Interface
VisualComponents.Create3D Namespace


IVideoRecordExporter Interface

Video recording exporter

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IVideoRecordExporter : IRecordExporter,
    IScreenRecorder, IVideoRecorder, IRecorder, IDisposable
public interface class IVideoRecordExporter : IRecordExporter,
    IScreenRecorder, IVideoRecorder, IRecorder, IDisposable

The IVideoRecordExporter type exposes the following members.

Properties
 | Name | Description
Public property | Bitrate | Quality bitrate (Inherited from IVideoRecorder.)
Public property | Codec | Video codec (Inherited from IVideoRecorder.)
Public property | EndTime | Recording end time (Inherited from IVideoRecorder.)
Public property | Format | Video file format (Inherited from IVideoRecorder.)
Public property | FrameRate | Defines the frame rate (fps) of the recorder. (Inherited from IRecorder.)
Public property | Header | Header information (Inherited from IRecordExporter.)
Public property | Height | Resolution height or 0 for window height. (Inherited from IVideoRecorder.)
Public property | IsPaused | Pause/Unpause current record (Inherited from IVideoRecorder.)
Public property | IsRecording | Defines if the recorder has been started. (Inherited from IRecorder.)
Public property | RecordingHeight | Resolution height (Inherited from IVideoRecorder.)
Public property | RecordingType | Type information (Inherited from IRecordExporter.)
Public property | RecordingWidth | Resolution width (Inherited from IVideoRecorder.)
Public property | ShowVideo | Show or not video after create it (Inherited from IVideoRecorder.)
Public property | Speed | Recording speed compare to simulation time (Inherited from IVideoRecorder.)
Public property | StartTime | Recording start time (Inherited from IVideoRecorder.)
Public property | Width | Resolution width or 0 for window width. (Inherited from IVideoRecorder.)
Top
Methods
 | Name | Description
Public method | Cancel | Cancels current recording (Inherited from IVideoRecorder.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Start | Starts and initializes the recorder. (Inherited from IRecorder.)
Public method | Start(Boolean) | Starts the recording of the simulation in paused mode (Inherited from IVideoRecorder.)
Public method | StartScreenRecording | Starts the screen recording (Inherited from IScreenRecorder.)
Public method | Stop | Stops the recorder and saves the result to the given file. (Inherited from IRecorder.)
Public method | StopScreenRecording | Stops and saves the recording (Inherited from IScreenRecorder.)
Top
Events
 | Name | Description
Public event | VideoCreationProgress | Raised during video creation. (Inherited from IVideoRecorder.)
Public event | VideoRecordingFrame | Raised for every recorded frame (Inherited from IVideoRecorder.)
Public event | VideoRecordingNotification | Raised if an exception occurs during video creation (Inherited from IVideoRecorder.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IVideoRecordExporter Properties

The IVideoRecordExporter type exposes the following members.

Properties
 | Name | Description
Public property | Bitrate | Quality bitrate (Inherited from IVideoRecorder.)
Public property | Codec | Video codec (Inherited from IVideoRecorder.)
Public property | EndTime | Recording end time (Inherited from IVideoRecorder.)
Public property | Format | Video file format (Inherited from IVideoRecorder.)
Public property | FrameRate | Defines the frame rate (fps) of the recorder. (Inherited from IRecorder.)
Public property | Header | Header information (Inherited from IRecordExporter.)
Public property | Height | Resolution height or 0 for window height. (Inherited from IVideoRecorder.)
Public property | IsPaused | Pause/Unpause current record (Inherited from IVideoRecorder.)
Public property | IsRecording | Defines if the recorder has been started. (Inherited from IRecorder.)
Public property | RecordingHeight | Resolution height (Inherited from IVideoRecorder.)
Public property | RecordingType | Type information (Inherited from IRecordExporter.)
Public property | RecordingWidth | Resolution width (Inherited from IVideoRecorder.)
Public property | ShowVideo | Show or not video after create it (Inherited from IVideoRecorder.)
Public property | Speed | Recording speed compare to simulation time (Inherited from IVideoRecorder.)
Public property | StartTime | Recording start time (Inherited from IVideoRecorder.)
Public property | Width | Resolution width or 0 for window width. (Inherited from IVideoRecorder.)
Top
See Also

Reference

IVideoRecordExporter Interface
VisualComponents.Create3D Namespace


IVideoRecordExporter Methods

The IVideoRecordExporter type exposes the following members.

Methods
 | Name | Description
Public method | Cancel | Cancels current recording (Inherited from IVideoRecorder.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Start | Starts and initializes the recorder. (Inherited from IRecorder.)
Public method | Start(Boolean) | Starts the recording of the simulation in paused mode (Inherited from IVideoRecorder.)
Public method | StartScreenRecording | Starts the screen recording (Inherited from IScreenRecorder.)
Public method | Stop | Stops the recorder and saves the result to the given file. (Inherited from IRecorder.)
Public method | StopScreenRecording | Stops and saves the recording (Inherited from IScreenRecorder.)
Top
See Also

Reference

IVideoRecordExporter Interface
VisualComponents.Create3D Namespace


IVideoRecordExporter Events

The IVideoRecordExporter type exposes the following members.

Events
 | Name | Description
Public event | VideoCreationProgress | Raised during video creation. (Inherited from IVideoRecorder.)
Public event | VideoRecordingFrame | Raised for every recorded frame (Inherited from IVideoRecorder.)
Public event | VideoRecordingNotification | Raised if an exception occurs during video creation (Inherited from IVideoRecorder.)
Top
See Also

Reference

IVideoRecordExporter Interface
VisualComponents.Create3D Namespace


IView3D Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IView3D : IPropertyContainer,
    IBatchModeObject, IWrapper, IDisposable
public interface class IView3D : IPropertyContainer,
    IBatchModeObject, IWrapper, IDisposable

The IView3D type exposes the following members.

Properties
 | Name | Description
Public property | ApplyOptions |
Public property | CameraFarPlane |
Public property | CameraFieldOfViewY |
Public property | CameraNearPlane |
Public property | CameraPosition |
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | EdgeColorMode |
Public property | EdgeShadingMode |
Public property | IsOrthographic |
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name |
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | PreviewImage | Gets the image that contains the preview snapshot of this IView3D.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | RenderOpacity |
Public property | RenderShadingMode |
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | UpdatePreviewImage | Generates a preview image using this IView3D. The image can be retrieved from PreviewImage property.
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IView3D Properties

The IView3D type exposes the following members.

Properties
 | Name | Description
Public property | ApplyOptions |
Public property | CameraFarPlane |
Public property | CameraFieldOfViewY |
Public property | CameraNearPlane |
Public property | CameraPosition |
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | EdgeColorMode |
Public property | EdgeShadingMode |
Public property | IsOrthographic |
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name |
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | PreviewImage | Gets the image that contains the preview snapshot of this IView3D.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | RenderOpacity |
Public property | RenderShadingMode |
Top
See Also

Reference

IView3D Interface
VisualComponents.Create3D Namespace


IView3D.ApplyOptions Property

IView3DApplyOptions Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ViewApplyOptions ApplyOptions { get; set; }
property ViewApplyOptions ApplyOptions {
    ViewApplyOptions get ();
    void set (ViewApplyOptions value);
}

Property Value

Type: ViewApplyOptions
See Also

Reference

IView3D Interface
VisualComponents.Create3D Namespace


IView3D.CameraFarPlane Property

IView3DCameraFarPlane Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double CameraFarPlane { get; set; }
property double CameraFarPlane {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IView3D Interface
VisualComponents.Create3D Namespace


IView3D.CameraFieldOfViewY Property

IView3DCameraFieldOfViewY Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double CameraFieldOfViewY { get; set; }
property double CameraFieldOfViewY {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IView3D Interface
VisualComponents.Create3D Namespace


IView3D.CameraNearPlane Property

IView3DCameraNearPlane Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double CameraNearPlane { get; set; }
property double CameraNearPlane {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IView3D Interface
VisualComponents.Create3D Namespace


IView3D.CameraPosition Property

IView3DCameraPosition Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix CameraPosition { get; set; }
property Matrix CameraPosition {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

IView3D Interface
VisualComponents.Create3D Namespace


IView3D.EdgeColorMode Property

IView3DEdgeColorMode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
EdgeColor EdgeColorMode { get; set; }
property EdgeColor EdgeColorMode {
    EdgeColor get ();
    void set (EdgeColor value);
}

Property Value

Type: EdgeColor
See Also

Reference

IView3D Interface
VisualComponents.Create3D Namespace


IView3D.EdgeShadingMode Property

IView3DEdgeShadingMode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
EdgeShading EdgeShadingMode { get; set; }
property EdgeShading EdgeShadingMode {
    EdgeShading get ();
    void set (EdgeShading value);
}

Property Value

Type: EdgeShading
See Also

Reference

IView3D Interface
VisualComponents.Create3D Namespace


IView3D.IsOrthographic Property

IView3DIsOrthographic Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsOrthographic { get; set; }
property bool IsOrthographic {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IView3D Interface
VisualComponents.Create3D Namespace


IView3D.Name Property

IView3DName Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Name { get; set; }
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IView3D Interface
VisualComponents.Create3D Namespace


IView3D.PreviewImage Property

IView3DPreviewImage Property

Gets the image that contains the preview snapshot of this IView3D.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Bitmap PreviewImage { get; }
property Bitmap^ PreviewImage {
    Bitmap^ get ();
}

Property Value

Type: Bitmap
Remarks
The preview image can be generated using UpdatePreviewImage method.
See Also

Reference

IView3D Interface
VisualComponents.Create3D Namespace


IView3D.RenderOpacity Property

IView3DRenderOpacity Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
float RenderOpacity { get; set; }
property float RenderOpacity {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

IView3D Interface
VisualComponents.Create3D Namespace


IView3D.RenderShadingMode Property

IView3DRenderShadingMode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
RenderShading RenderShadingMode { get; set; }
property RenderShading RenderShadingMode {
    RenderShading get ();
    void set (RenderShading value);
}

Property Value

Type: RenderShading
See Also

Reference

IView3D Interface
VisualComponents.Create3D Namespace


IView3D Methods

The IView3D type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Public method | UpdatePreviewImage | Generates a preview image using this IView3D. The image can be retrieved from PreviewImage property.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IView3D Interface
VisualComponents.Create3D Namespace


IView3D.UpdatePreviewImage Method

IView3DUpdatePreviewImage Method

Generates a preview image using this IView3D. The image can be retrieved from PreviewImage property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdatePreviewImage()
void UpdatePreviewImage()
See Also

Reference

IView3D Interface
VisualComponents.Create3D Namespace


IView3D Events

The IView3D type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IView3D Interface
VisualComponents.Create3D Namespace


IViewport Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IViewport : IScreen,
    IHaveDisplayName, IActivate, IDeactivate, IGuardClose, IClose,
    INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IViewport : IScreen,
    IHaveDisplayName, IActivate, IDeactivate, IGuardClose, IClose,
    INotifyPropertyChangedEx, INotifyPropertyChanged

The IViewport type exposes the following members.

Properties
 | Name | Description
Public property | AreUseSettingsApplied | Defines if the user settings are applied to this instance of IViewport.
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsCubeVisible | Cube can be also force-hidden with app setting "IsDefaultViewCubeVisible".
Public property | IsDXReady |
Public property | IsMainViewport | Definese if this instance of IViewport is the main view port.
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsSimulationControlVisible | Simulation control can be also force-hidden with app setting "IsSimulationControlVisible".
Public property | IsToolBarShown | Gets the actual 3D toolbar visibility. This is based on the value of IsToolBarVisible property, active viewport and full screen mode.
Public property | IsToolBarVisible | Gets or sets 3D toolbar visibility.
Public property | OnViewportInvalidate | Gets the method that should be called when the viewport should be invalidated.
Public property | RootElement |
Public property | SurfaceSize |
Public property | Window |
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | ApplyUserSettings | Read and apply user settings from the configuration file.
Public method | CanClose | (Inherited from IGuardClose.)
Public method | CreateViewport | Creates a new 3D viewport view model displaying the main 3d/drawing worlds. This will automatically create a new instance of IWindow3D with the contents of built in 3D/drawing world instances.
Public method | CreateViewport(IWindow3D) | Creates a new 3D viewport view model displaying the given instance of IWindow3D.
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | InvalidateHelperViewport | Refresh HelperViewport.
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | ReadZoomSettings | Reads in locally-cached settings for zooming the view, e.g. sensitivity and zoom mode, from the settings file.
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | RequestRender |
Public method | SetAsActiveViewport | Sets the viewport and its window active.
Public method | SetRecordingMode |
Public method | SetWindow |
Public method | ShowRecordedImage |
Public method | TryClose | (Inherited from IClose.)
Public method | UpdateGeometryScale | Used internally for updating manipulator sizes.
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | CameraChanged | Occurs when 3D camera has been updated,
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | Initialized | Occurs after viewport has been initialized.
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IViewport Properties

The IViewport type exposes the following members.

Properties
 | Name | Description
Public property | AreUseSettingsApplied | Defines if the user settings are applied to this instance of IViewport.
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsCubeVisible | Cube can be also force-hidden with app setting "IsDefaultViewCubeVisible".
Public property | IsDXReady |
Public property | IsMainViewport | Definese if this instance of IViewport is the main view port.
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsSimulationControlVisible | Simulation control can be also force-hidden with app setting "IsSimulationControlVisible".
Public property | IsToolBarShown | Gets the actual 3D toolbar visibility. This is based on the value of IsToolBarVisible property, active viewport and full screen mode.
Public property | IsToolBarVisible | Gets or sets 3D toolbar visibility.
Public property | OnViewportInvalidate | Gets the method that should be called when the viewport should be invalidated.
Public property | RootElement |
Public property | SurfaceSize |
Public property | Window |
Top
See Also

Reference

IViewport Interface
VisualComponents.Create3D Namespace


IViewport.AreUseSettingsApplied Property

IViewportAreUseSettingsApplied Property

Defines if the user settings are applied to this instance of IViewport.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool AreUseSettingsApplied { get; }
property bool AreUseSettingsApplied {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IViewport Interface
VisualComponents.Create3D Namespace


IViewport.IsCubeVisible Property

IViewportIsCubeVisible Property

Cube can be also force-hidden with app setting "IsDefaultViewCubeVisible".

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsCubeVisible { get; set; }
property bool IsCubeVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IViewport Interface
VisualComponents.Create3D Namespace


IViewport.IsDXReady Property

IViewportIsDXReady Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsDXReady { get; }
property bool IsDXReady {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IViewport Interface
VisualComponents.Create3D Namespace


IViewport.IsMainViewport Property

IViewportIsMainViewport Property

Definese if this instance of IViewport is the main view port.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsMainViewport { get; }
property bool IsMainViewport {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IViewport Interface
VisualComponents.Create3D Namespace


IViewport.IsSimulationControlVisible Property

IViewportIsSimulationControlVisible Property

Simulation control can be also force-hidden with app setting "IsSimulationControlVisible".

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsSimulationControlVisible { get; set; }
property bool IsSimulationControlVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IViewport Interface
VisualComponents.Create3D Namespace


IViewport.IsToolBarShown Property

IViewportIsToolBarShown Property

Gets the actual 3D toolbar visibility. This is based on the value of IsToolBarVisible property, active viewport and full screen mode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsToolBarShown { get; }
property bool IsToolBarShown {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IViewport Interface
VisualComponents.Create3D Namespace


IViewport.IsToolBarVisible Property

IViewportIsToolBarVisible Property

Gets or sets 3D toolbar visibility.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsToolBarVisible { get; set; }
property bool IsToolBarVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IViewport Interface
VisualComponents.Create3D Namespace


IViewport.OnViewportInvalidate Property

IViewportOnViewportInvalidate Property

Gets the method that should be called when the viewport should be invalidated.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Action OnViewportInvalidate { get; }
property Action OnViewportInvalidate {
    Action get ();
}

Property Value

Type: Action
Remarks
For internal use only.
See Also

Reference

IViewport Interface
VisualComponents.Create3D Namespace


IViewport.RootElement Property

IViewportRootElement Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
UIElement RootElement { get; }
property UIElement^ RootElement {
    UIElement^ get ();
}

Property Value

Type: UIElement
See Also

Reference

IViewport Interface
VisualComponents.Create3D Namespace


IViewport.SurfaceSize Property

IViewportSurfaceSize Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Size SurfaceSize { get; }
property Size SurfaceSize {
    Size get ();
}

Property Value

Type: Size
See Also

Reference

IViewport Interface
VisualComponents.Create3D Namespace


IViewport.Window Property

IViewportWindow Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IWindow3D Window { get; }
property IWindow3D^ Window {
    IWindow3D^ get ();
}

Property Value

Type: IWindow3D
See Also

Reference

IViewport Interface
VisualComponents.Create3D Namespace


IViewport Methods

The IViewport type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | ApplyUserSettings | Read and apply user settings from the configuration file.
Public method | CanClose | (Inherited from IGuardClose.)
Public method | CreateViewport | Creates a new 3D viewport view model displaying the main 3d/drawing worlds. This will automatically create a new instance of IWindow3D with the contents of built in 3D/drawing world instances.
Public method | CreateViewport(IWindow3D) | Creates a new 3D viewport view model displaying the given instance of IWindow3D.
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | InvalidateHelperViewport | Refresh HelperViewport.
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | ReadZoomSettings | Reads in locally-cached settings for zooming the view, e.g. sensitivity and zoom mode, from the settings file.
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | RequestRender |
Public method | SetAsActiveViewport | Sets the viewport and its window active.
Public method | SetRecordingMode |
Public method | SetWindow |
Public method | ShowRecordedImage |
Public method | TryClose | (Inherited from IClose.)
Public method | UpdateGeometryScale | Used internally for updating manipulator sizes.
Top
See Also

Reference

IViewport Interface
VisualComponents.Create3D Namespace


IViewport.ApplyUserSettings Method

IViewportApplyUserSettings Method

Read and apply user settings from the configuration file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ApplyUserSettings()
void ApplyUserSettings()
See Also

Reference

IViewport Interface
VisualComponents.Create3D Namespace


IViewport.CreateViewport Method

IViewportCreateViewport Method

Overload List
 | Name | Description
Public method | CreateViewport | Creates a new 3D viewport view model displaying the main 3d/drawing worlds. This will automatically create a new instance of IWindow3D with the contents of built in 3D/drawing world instances.
Public method | CreateViewport(IWindow3D) | Creates a new 3D viewport view model displaying the given instance of IWindow3D.
Top
See Also

Reference

IViewport Interface
VisualComponents.Create3D Namespace


IViewport.CreateViewport Method

IViewportCreateViewport Method

Creates a new 3D viewport view model displaying the main 3d/drawing worlds. This will automatically create a new instance of IWindow3D with the contents of built in 3D/drawing world instances.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IViewport CreateViewport()
IViewport^ CreateViewport()

Return Value

Type: IViewport
Created view port.
See Also

Reference

IViewport Interface
CreateViewport Overload
VisualComponents.Create3D Namespace


IViewport.CreateViewport Method (IWindow3D)

IViewportCreateViewport Method (IWindow3D)

Creates a new 3D viewport view model displaying the given instance of IWindow3D.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IViewport CreateViewport(
    IWindow3D window
)
IViewport^ CreateViewport(
    IWindow3D^ window
)

Parameters

window
Type: VisualComponents.Create3DIWindow3D

Return Value

Type: IViewport
Created view port.
See Also

Reference

IViewport Interface
CreateViewport Overload
VisualComponents.Create3D Namespace


IViewport.InvalidateHelperViewport Method

IViewportInvalidateHelperViewport Method

Refresh HelperViewport.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void InvalidateHelperViewport()
void InvalidateHelperViewport()
See Also

Reference

IViewport Interface
VisualComponents.Create3D Namespace


IViewport.ReadZoomSettings Method

IViewportReadZoomSettings Method

Reads in locally-cached settings for zooming the view, e.g. sensitivity and zoom mode, from the settings file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ReadZoomSettings()
void ReadZoomSettings()
See Also

Reference

IViewport Interface
VisualComponents.Create3D Namespace


IViewport.RequestRender Method

IViewportRequestRender Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RequestRender()
void RequestRender()
See Also

Reference

IViewport Interface
VisualComponents.Create3D Namespace


IViewport.SetAsActiveViewport Method

IViewportSetAsActiveViewport Method

Sets the viewport and its window active.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetAsActiveViewport()
void SetAsActiveViewport()
See Also

Reference

IViewport Interface
VisualComponents.Create3D Namespace


IViewport.SetRecordingMode Method

IViewportSetRecordingMode Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetRecordingMode(
    bool enable
)
void SetRecordingMode(
    bool enable
)

Parameters

enable
Type: SystemBoolean
See Also

Reference

IViewport Interface
VisualComponents.Create3D Namespace


IViewport.SetWindow Method

IViewportSetWindow Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetWindow(
    IWindow3D window
)
void SetWindow(
    IWindow3D^ window
)

Parameters

window
Type: VisualComponents.Create3DIWindow3D
See Also

Reference

IViewport Interface
VisualComponents.Create3D Namespace


IViewport.ShowRecordedImage Method

IViewportShowRecordedImage Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ShowRecordedImage(
    ImageSource image
)
void ShowRecordedImage(
    ImageSource^ image
)

Parameters

image
Type: System.Windows.MediaImageSource
See Also

Reference

IViewport Interface
VisualComponents.Create3D Namespace


IViewport.UpdateGeometryScale Method

IViewportUpdateGeometryScale Method

Used internally for updating manipulator sizes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateGeometryScale()
void UpdateGeometryScale()
See Also

Reference

IViewport Interface
VisualComponents.Create3D Namespace


IViewport Events

The IViewport type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | CameraChanged | Occurs when 3D camera has been updated,
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | Initialized | Occurs after viewport has been initialized.
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IViewport Interface
VisualComponents.Create3D Namespace


IViewport.CameraChanged Event

IViewportCameraChanged Event

Occurs when 3D camera has been updated,

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler CameraChanged
 event EventHandler^ CameraChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IViewport Interface
VisualComponents.Create3D Namespace


IViewport.Initialized Event

IViewportInitialized Event

Occurs after viewport has been initialized.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> Initialized
 event EventHandler<EventArgs^>^ Initialized {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

IViewport Interface
VisualComponents.Create3D Namespace


IViewStatement Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IViewStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IViewStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IViewStatement type exposes the following members.

Properties
 | Name | Description
Public property | AnimationMode |
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | Delay |
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | View |
Public property | View3D |
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IViewStatement Properties

The IViewStatement type exposes the following members.

Properties
 | Name | Description
Public property | AnimationMode |
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | Delay |
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | View |
Public property | View3D |
Top
See Also

Reference

IViewStatement Interface
VisualComponents.Create3D Namespace


IViewStatement.AnimationMode Property

IViewStatementAnimationMode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ViewAnimationMode AnimationMode { get; set; }
property ViewAnimationMode AnimationMode {
    ViewAnimationMode get ();
    void set (ViewAnimationMode value);
}

Property Value

Type: ViewAnimationMode
See Also

Reference

IViewStatement Interface
VisualComponents.Create3D Namespace


IViewStatement.Delay Property

IViewStatementDelay Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Delay { get; set; }
property double Delay {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IViewStatement Interface
VisualComponents.Create3D Namespace


IViewStatement.View Property

IViewStatementView Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string View { get; set; }
property String^ View {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IViewStatement Interface
VisualComponents.Create3D Namespace


IViewStatement.View3D Property

IViewStatementView3D Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IView3D View3D { get; set; }
property IView3D^ View3D {
    IView3D^ get ();
    void set (IView3D^ value);
}

Property Value

Type: IView3D
See Also

Reference

IViewStatement Interface
VisualComponents.Create3D Namespace


IViewStatement Methods

The IViewStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IViewStatement Interface
VisualComponents.Create3D Namespace


IViewStatement Events

The IViewStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IViewStatement Interface
VisualComponents.Create3D Namespace


IWindow3D Interface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IWindow3D : IWrapper,
    IDisposable
public interface class IWindow3D : IWrapper,
    IDisposable

The IWindow3D type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor | Gets or sets the 3D window background color.
Public property | Camera |
Public property | EdgeColorMode |
Public property | EdgeShadingMode |
Public property | FontSize3D |
Public property | Height |
Public property | IsActive |
Public property | IsInvisibleContentShown | Defines if insivisible objects are rendered in this IWindow3D.
Public property | IsMainWindow |
Public property | IsValid | (Inherited from IWrapper.)
Public property | MouseWheel |
Public property | Name |
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | RenderOpacity |
Public property | RenderShadingMode |
Public property | RenderStages |
Public property | SnapThreshold |
Public property | TransparencyQuality |
Public property | TuningValue |
Public property | UseHeadlight |
Public property | UseManipulationAcceleration |
Public property | UseMaterialShaders |
Public property | Width |
Public property | World | Gets the instance of 3D world displayed by this instance of IWindow3D.
Top
Methods
 | Name | Description
Public method | AbortCurrentPick |
Public method | ApplyView(IView3D) |
Public method | ApplyView(IView3D, Boolean) |
Public method | CalculateReferencePlane |
Public method | ClearTransparency |
Public method | DisableFeatureCollisions |
Public method | DisableGeometrySetCollisions(ISimComponent, IListIGeometrySet, IListIFeature) |
Public method | DisableGeometrySetCollisions(ISimComponent, Boolean, IListISimNode, IListIGeometrySet, ISimNode, IFeature) |
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EnableFeatureCollisions |
Public method | Equals | (Inherited from IWrapper.)
Public method | GetFramesIntersectingWithPolygon(ILayoutSchemaPropertyList, IListPoint) |
Public method | GetFramesIntersectingWithPolygon(IPathStatement, IListPoint) |
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetPickRay |
Public method | GetProjectedPointPixelSize | Calculates pixel size for world position.
Public method | GetScreenColor |
Public method | IsGeometryProjectedInsideLimits |
Public method | MapCursorToPlane |
Public method | MapXYCoordinatesToFloor | Map screen coordinates to 3D world floor.
Public method | MapXYCoordinatesToPlane(Int32, Int32, Vector3, Vector3) | Map screen coordinates to given plane in 3D world.
Public method | MapXYCoordinatesToPlane(Int32, Int32, Vector3, Vector3, Boolean) | Obsolete.
Public method | PickGeoPrimitive(Int32, Int32, PickPrimitives) |
Public method | PickGeoPrimitive(Int32, Int32, Int32, IntPtr) | Obsolete.
Public method | PickGeoPrimitive(Int32, Int32, PickPrimitives, IEnumerableISimNode) |
Public method | PickGeoPrimitive(Int32, Int32, PickPrimitives, IntPtr) |
Public method | PickScene(Int32, Int32) |
Public method | PickScene(Int32, Int32, Boolean) |
Public method | PointToImagePlane |
Public method | ProjectBoundsFromLocalToScreenSpace |
Public method | ProjectPointFromLocalToScreenSpace |
Public method | ProjectWorldPointToScreenSpace | Projects world position defined by a matrix to screen space coordinates.
Public method | RaycastScene(Int32, Int32) | Shoots ray using the given screen coordinates and results the first hit.
Public method | RaycastScene(Int32, Int32, Boolean) | Shoots ray using the given screen coordinates and results the first hit.
Public method | RaycastScene(Int32, Int32, IEnumerableNodeListEntry) | Shoots ray using the given screen coordinates and results the first hit.
Public method | RaycastScene(Matrix, Double, Boolean) | Shoots ray using the given word position and results the first hit.
Public method | RaycastScene(Int32, Int32, Boolean, PickPrimitives, Boolean) | Shoots ray using the given screen coordinates and results the first hit.
Public method | RaycastScene(Matrix, Double, Boolean, PickPrimitives, Boolean) | Shoots ray using the given word position and results the first hit.
Public method | RaycastScene(Int32, Int32, Boolean, PickPrimitives, Boolean, Double) | Shoots ray using the given screen coordinates and results the first hit.
Public method | RaycastScene(Matrix, Double, Boolean, PickPrimitives, Boolean, IEnumerableNodeListEntry) | Shoots ray using the given word position and results the first hit.
Public method | RaycastScene(Int32, Int32, Boolean, PickPrimitives, Boolean, Double, IEnumerableNodeListEntry) | Shoots ray using the given screen coordinates and results the first hit.
Public method | RemoveGhostVisuals |
Public method | Render |
Public method | SetTransparency |
Public method | SetXY |
Public method | UpdateGhostVisuals | Update ghost visuals e.g. for snap result preview.
Public method | WorldToScreenPosition | World position to screen position
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Public Extension Method | MapXYCoordinatesToPlaneEx | (Defined by Window3DExtensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IWindow3D Properties

The IWindow3D type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor | Gets or sets the 3D window background color.
Public property | Camera |
Public property | EdgeColorMode |
Public property | EdgeShadingMode |
Public property | FontSize3D |
Public property | Height |
Public property | IsActive |
Public property | IsInvisibleContentShown | Defines if insivisible objects are rendered in this IWindow3D.
Public property | IsMainWindow |
Public property | IsValid | (Inherited from IWrapper.)
Public property | MouseWheel |
Public property | Name |
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | RenderOpacity |
Public property | RenderShadingMode |
Public property | RenderStages |
Public property | SnapThreshold |
Public property | TransparencyQuality |
Public property | TuningValue |
Public property | UseHeadlight |
Public property | UseManipulationAcceleration |
Public property | UseMaterialShaders |
Public property | Width |
Public property | World | Gets the instance of 3D world displayed by this instance of IWindow3D.
Top
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.BackgroundColor Property

IWindow3DBackgroundColor Property

Gets or sets the 3D window background color.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Color BackgroundColor { get; set; }
property Color BackgroundColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.Camera Property

IWindow3DCamera Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ICamera Camera { get; }
property ICamera^ Camera {
    ICamera^ get ();
}

Property Value

Type: ICamera
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.EdgeColorMode Property

IWindow3DEdgeColorMode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
EdgeColor EdgeColorMode { get; set; }
property EdgeColor EdgeColorMode {
    EdgeColor get ();
    void set (EdgeColor value);
}

Property Value

Type: EdgeColor
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.EdgeShadingMode Property

IWindow3DEdgeShadingMode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
EdgeShading EdgeShadingMode { get; set; }
property EdgeShading EdgeShadingMode {
    EdgeShading get ();
    void set (EdgeShading value);
}

Property Value

Type: EdgeShading
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.FontSize3D Property

IWindow3DFontSize3D Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double FontSize3D { get; set; }
property double FontSize3D {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.Height Property

IWindow3DHeight Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int Height { get; }
property int Height {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.IsActive Property

IWindow3DIsActive Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsActive { get; }
property bool IsActive {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.IsInvisibleContentShown Property

IWindow3DIsInvisibleContentShown Property

Defines if insivisible objects are rendered in this IWindow3D.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsInvisibleContentShown { get; set; }
property bool IsInvisibleContentShown {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.IsMainWindow Property

IWindow3DIsMainWindow Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsMainWindow { get; }
property bool IsMainWindow {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.MouseWheel Property

IWindow3DMouseWheel Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int MouseWheel { get; }
property int MouseWheel {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.Name Property

IWindow3DName Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Name { get; set; }
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.RenderOpacity Property

IWindow3DRenderOpacity Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
float RenderOpacity { get; set; }
property float RenderOpacity {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.RenderShadingMode Property

IWindow3DRenderShadingMode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
RenderShading RenderShadingMode { get; set; }
property RenderShading RenderShadingMode {
    RenderShading get ();
    void set (RenderShading value);
}

Property Value

Type: RenderShading
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.RenderStages Property

IWindow3DRenderStages Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<IRenderStage> RenderStages { get; }
property ReadOnlyCollection<IRenderStage^>^ RenderStages {
    ReadOnlyCollection<IRenderStage^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIRenderStage
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.SnapThreshold Property

IWindow3DSnapThreshold Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int SnapThreshold { get; set; }
property int SnapThreshold {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.TransparencyQuality Property

IWindow3DTransparencyQuality Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
TransparencyQuality TransparencyQuality { get; set; }
property TransparencyQuality TransparencyQuality {
    TransparencyQuality get ();
    void set (TransparencyQuality value);
}

Property Value

Type: TransparencyQuality
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.TuningValue Property

IWindow3DTuningValue Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double TuningValue { get; set; }
property double TuningValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.UseHeadlight Property

IWindow3DUseHeadlight Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool UseHeadlight { get; set; }
property bool UseHeadlight {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.UseManipulationAcceleration Property

IWindow3DUseManipulationAcceleration Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool UseManipulationAcceleration { get; set; }
property bool UseManipulationAcceleration {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.UseMaterialShaders Property

IWindow3DUseMaterialShaders Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool UseMaterialShaders { get; set; }
property bool UseMaterialShaders {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.Width Property

IWindow3DWidth Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int Width { get; }
property int Width {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.World Property

IWindow3DWorld Property

Gets the instance of 3D world displayed by this instance of IWindow3D.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimWorld World { get; }
property ISimWorld^ World {
    ISimWorld^ get ();
}

Property Value

Type: ISimWorld
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D Methods

The IWindow3D type exposes the following members.

Methods
 | Name | Description
Public method | AbortCurrentPick |
Public method | ApplyView(IView3D) |
Public method | ApplyView(IView3D, Boolean) |
Public method | CalculateReferencePlane |
Public method | ClearTransparency |
Public method | DisableFeatureCollisions |
Public method | DisableGeometrySetCollisions(ISimComponent, IListIGeometrySet, IListIFeature) |
Public method | DisableGeometrySetCollisions(ISimComponent, Boolean, IListISimNode, IListIGeometrySet, ISimNode, IFeature) |
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EnableFeatureCollisions |
Public method | Equals | (Inherited from IWrapper.)
Public method | GetFramesIntersectingWithPolygon(ILayoutSchemaPropertyList, IListPoint) |
Public method | GetFramesIntersectingWithPolygon(IPathStatement, IListPoint) |
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetPickRay |
Public method | GetProjectedPointPixelSize | Calculates pixel size for world position.
Public method | GetScreenColor |
Public method | IsGeometryProjectedInsideLimits |
Public method | MapCursorToPlane |
Public method | MapXYCoordinatesToFloor | Map screen coordinates to 3D world floor.
Public method | MapXYCoordinatesToPlane(Int32, Int32, Vector3, Vector3) | Map screen coordinates to given plane in 3D world.
Public method | MapXYCoordinatesToPlane(Int32, Int32, Vector3, Vector3, Boolean) | Obsolete.
Public method | PickGeoPrimitive(Int32, Int32, PickPrimitives) |
Public method | PickGeoPrimitive(Int32, Int32, Int32, IntPtr) | Obsolete.
Public method | PickGeoPrimitive(Int32, Int32, PickPrimitives, IEnumerableISimNode) |
Public method | PickGeoPrimitive(Int32, Int32, PickPrimitives, IntPtr) |
Public method | PickScene(Int32, Int32) |
Public method | PickScene(Int32, Int32, Boolean) |
Public method | PointToImagePlane |
Public method | ProjectBoundsFromLocalToScreenSpace |
Public method | ProjectPointFromLocalToScreenSpace |
Public method | ProjectWorldPointToScreenSpace | Projects world position defined by a matrix to screen space coordinates.
Public method | RaycastScene(Int32, Int32) | Shoots ray using the given screen coordinates and results the first hit.
Public method | RaycastScene(Int32, Int32, Boolean) | Shoots ray using the given screen coordinates and results the first hit.
Public method | RaycastScene(Int32, Int32, IEnumerableNodeListEntry) | Shoots ray using the given screen coordinates and results the first hit.
Public method | RaycastScene(Matrix, Double, Boolean) | Shoots ray using the given word position and results the first hit.
Public method | RaycastScene(Int32, Int32, Boolean, PickPrimitives, Boolean) | Shoots ray using the given screen coordinates and results the first hit.
Public method | RaycastScene(Matrix, Double, Boolean, PickPrimitives, Boolean) | Shoots ray using the given word position and results the first hit.
Public method | RaycastScene(Int32, Int32, Boolean, PickPrimitives, Boolean, Double) | Shoots ray using the given screen coordinates and results the first hit.
Public method | RaycastScene(Matrix, Double, Boolean, PickPrimitives, Boolean, IEnumerableNodeListEntry) | Shoots ray using the given word position and results the first hit.
Public method | RaycastScene(Int32, Int32, Boolean, PickPrimitives, Boolean, Double, IEnumerableNodeListEntry) | Shoots ray using the given screen coordinates and results the first hit.
Public method | RemoveGhostVisuals |
Public method | Render |
Public method | SetTransparency |
Public method | SetXY |
Public method | UpdateGhostVisuals | Update ghost visuals e.g. for snap result preview.
Public method | WorldToScreenPosition | World position to screen position
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Public Extension Method | MapXYCoordinatesToPlaneEx | (Defined by Window3DExtensions.)
Top
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.AbortCurrentPick Method

IWindow3DAbortCurrentPick Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AbortCurrentPick()
void AbortCurrentPick()
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.ApplyView Method

IWindow3DApplyView Method

Overload List
 | Name | Description
Public method | ApplyView(IView3D) |
Public method | ApplyView(IView3D, Boolean) |
Top
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.ApplyView Method (IView3D)

IWindow3DApplyView Method (IView3D)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ApplyView(
    IView3D view
)
void ApplyView(
    IView3D^ view
)

Parameters

view
Type: VisualComponents.Create3DIView3D
See Also

Reference

IWindow3D Interface
ApplyView Overload
VisualComponents.Create3D Namespace


IWindow3D.ApplyView Method (IView3D, Boolean)

IWindow3DApplyView Method (IView3D, Boolean)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ApplyView(
    IView3D view,
    bool animate
)
void ApplyView(
    IView3D^ view,
    bool animate
)

Parameters

view
Type: VisualComponents.Create3DIView3D
animate
Type: SystemBoolean
See Also

Reference

IWindow3D Interface
ApplyView Overload
VisualComponents.Create3D Namespace


IWindow3D.CalculateReferencePlane Method

IWindow3DCalculateReferencePlane Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 CalculateReferencePlane(
    Vector3 planeDirection,
    Vector3 referenceDirection
)
Vector3 CalculateReferencePlane(
    Vector3 planeDirection,
    Vector3 referenceDirection
)

Parameters

planeDirection
Type: VisualComponents.Create3DVector3
referenceDirection
Type: VisualComponents.Create3DVector3

Return Value

Type: Vector3

[Missing <returns> documentation for "M:VisualComponents.Create3D.IWindow3D.CalculateReferencePlane(VisualComponents.Create3D.Vector3,VisualComponents.Create3D.Vector3)"]

See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.ClearTransparency Method

IWindow3DClearTransparency Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ClearTransparency()
void ClearTransparency()
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.DisableFeatureCollisions Method

IWindow3DDisableFeatureCollisions Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DisableFeatureCollisions(
    IFeature feature,
    ISimComponent component
)
void DisableFeatureCollisions(
    IFeature^ feature,
    ISimComponent^ component
)

Parameters

feature
Type: VisualComponents.Create3DIFeature
component
Type: VisualComponents.Create3DISimComponent
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.DisableGeometrySetCollisions Method

IWindow3DDisableGeometrySetCollisions Method

Overload List
 | Name | Description
Public method | DisableGeometrySetCollisions(ISimComponent, IListIGeometrySet, IListIFeature) |
Public method | DisableGeometrySetCollisions(ISimComponent, Boolean, IListISimNode, IListIGeometrySet, ISimNode, IFeature) |
Top
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.DisableGeometrySetCollisions Method (ISimComponent, IList(IGeometrySet), IList(IFeature))

IWindow3DDisableGeometrySetCollisions Method (ISimComponent, IListIGeometrySet, IListIFeature)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DisableGeometrySetCollisions(
    ISimComponent component,
    IList<IGeometrySet> disabled,
    IList<IFeature> disabledFeatures
)
void DisableGeometrySetCollisions(
    ISimComponent^ component,
    IList<IGeometrySet^>^ disabled,
    IList<IFeature^>^ disabledFeatures
)

Parameters

component
Type: VisualComponents.Create3DISimComponent
disabled
Type: System.Collections.GenericIListIGeometrySet
disabledFeatures
Type: System.Collections.GenericIListIFeature
See Also

Reference

IWindow3D Interface
DisableGeometrySetCollisions Overload
VisualComponents.Create3D Namespace


IWindow3D.DisableGeometrySetCollisions Method (ISimComponent, Boolean, IList(ISimNode), IList(IGeometrySet), ISimNode, IFeature)

IWindow3DDisableGeometrySetCollisions Method (ISimComponent, Boolean, IListISimNode, IListIGeometrySet, ISimNode, IFeature)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DisableGeometrySetCollisions(
    ISimComponent component,
    bool alsoAttachedComponents,
    IList<ISimNode> nodesToShow,
    IList<IGeometrySet> hiddenGeometrySets,
    ISimNode exceptNode,
    IFeature exceptFeature
)
void DisableGeometrySetCollisions(
    ISimComponent^ component,
    bool alsoAttachedComponents,
    IList<ISimNode^>^ nodesToShow,
    IList<IGeometrySet^>^ hiddenGeometrySets,
    ISimNode^ exceptNode,
    IFeature^ exceptFeature
)

Parameters

component
Type: VisualComponents.Create3DISimComponent
alsoAttachedComponents
Type: SystemBoolean
nodesToShow
Type: System.Collections.GenericIListISimNode
hiddenGeometrySets
Type: System.Collections.GenericIListIGeometrySet
exceptNode
Type: VisualComponents.Create3DISimNode
exceptFeature
Type: VisualComponents.Create3DIFeature
See Also

Reference

IWindow3D Interface
DisableGeometrySetCollisions Overload
VisualComponents.Create3D Namespace


IWindow3D.EnableFeatureCollisions Method

IWindow3DEnableFeatureCollisions Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void EnableFeatureCollisions(
    ISimComponent component
)
void EnableFeatureCollisions(
    ISimComponent^ component
)

Parameters

component
Type: VisualComponents.Create3DISimComponent
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.GetFramesIntersectingWithPolygon Method

IWindow3DGetFramesIntersectingWithPolygon Method

Overload List
 | Name | Description
Public method | GetFramesIntersectingWithPolygon(ILayoutSchemaPropertyList, IListPoint) |
Public method | GetFramesIntersectingWithPolygon(IPathStatement, IListPoint) |
Top
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.GetFramesIntersectingWithPolygon Method (ILayoutSchemaPropertyList, IList(Point))

IWindow3DGetFramesIntersectingWithPolygon Method (ILayoutSchemaPropertyList, IListPoint)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<ISchemaFrame> GetFramesIntersectingWithPolygon(
    ILayoutSchemaPropertyList schemaPropertyList,
    IList<Point> polygon
)
IEnumerable<ISchemaFrame^>^ GetFramesIntersectingWithPolygon(
    ILayoutSchemaPropertyList^ schemaPropertyList,
    IList<Point>^ polygon
)

Parameters

schemaPropertyList
Type: VisualComponents.Create3DILayoutSchemaPropertyList
polygon
Type: System.Collections.GenericIListPoint

Return Value

Type: IEnumerableISchemaFrame

[Missing <returns> documentation for "M:VisualComponents.Create3D.IWindow3D.GetFramesIntersectingWithPolygon(VisualComponents.Create3D.ILayoutSchemaPropertyList,System.Collections.Generic.IList{System.Windows.Point})"]

See Also

Reference

IWindow3D Interface
GetFramesIntersectingWithPolygon Overload
VisualComponents.Create3D Namespace


IWindow3D.GetFramesIntersectingWithPolygon Method (IPathStatement, IList(Point))

IWindow3DGetFramesIntersectingWithPolygon Method (IPathStatement, IListPoint)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IEnumerable<ISchemaPositionFrame> GetFramesIntersectingWithPolygon(
    IPathStatement path,
    IList<Point> polygon
)
IEnumerable<ISchemaPositionFrame^>^ GetFramesIntersectingWithPolygon(
    IPathStatement^ path,
    IList<Point>^ polygon
)

Parameters

path
Type: VisualComponents.Create3DIPathStatement
polygon
Type: System.Collections.GenericIListPoint

Return Value

Type: IEnumerableISchemaPositionFrame

[Missing <returns> documentation for "M:VisualComponents.Create3D.IWindow3D.GetFramesIntersectingWithPolygon(VisualComponents.Create3D.IPathStatement,System.Collections.Generic.IList{System.Windows.Point})"]

See Also

Reference

IWindow3D Interface
GetFramesIntersectingWithPolygon Overload
VisualComponents.Create3D Namespace


IWindow3D.GetPickRay Method

IWindow3DGetPickRay Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Tuple<Vector3, Vector3> GetPickRay(
    int x,
    int y,
    Matrix transformation
)
Tuple<Vector3, Vector3>^ GetPickRay(
    int x,
    int y,
    Matrix transformation
)

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
transformation
Type: VisualComponents.Create3DMatrix

Return Value

Type: TupleVector3, Vector3

[Missing <returns> documentation for "M:VisualComponents.Create3D.IWindow3D.GetPickRay(System.Int32,System.Int32,VisualComponents.Create3D.Matrix)"]

See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.GetProjectedPointPixelSize Method

IWindow3DGetProjectedPointPixelSize Method

Calculates pixel size for world position.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double GetProjectedPointPixelSize(
    Vector3 pointInWorldCoordinates
)
double GetProjectedPointPixelSize(
    Vector3 pointInWorldCoordinates
)

Parameters

pointInWorldCoordinates
Type: VisualComponents.Create3DVector3

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.Create3D.IWindow3D.GetProjectedPointPixelSize(VisualComponents.Create3D.Vector3)"]

See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.GetScreenColor Method

IWindow3DGetScreenColor Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int GetScreenColor(
    int[] rects
)
int GetScreenColor(
    array<int>^ rects
)

Parameters

rects
Type: SystemInt32

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.IWindow3D.GetScreenColor(System.Int32[])"]

See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.IsGeometryProjectedInsideLimits Method

IWindow3DIsGeometryProjectedInsideLimits Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsGeometryProjectedInsideLimits(
    Matrix positionInWorld,
    IGeometrySet geometry,
    IList<Point> limits
)
bool IsGeometryProjectedInsideLimits(
    Matrix positionInWorld,
    IGeometrySet^ geometry,
    IList<Point>^ limits
)

Parameters

positionInWorld
Type: VisualComponents.Create3DMatrix
geometry
Type: VisualComponents.Create3DIGeometrySet
limits
Type: System.Collections.GenericIListPoint

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IWindow3D.IsGeometryProjectedInsideLimits(VisualComponents.Create3D.Matrix,VisualComponents.Create3D.IGeometrySet,System.Collections.Generic.IList{System.Windows.Point})"]

See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.MapCursorToPlane Method

IWindow3DMapCursorToPlane Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double MapCursorToPlane(
    ref Vector3 cursorPosition,
    Vector3 planePosition,
    Vector3 planeDirection
)
double MapCursorToPlane(
    Vector3% cursorPosition,
    Vector3 planePosition,
    Vector3 planeDirection
)

Parameters

cursorPosition
Type: VisualComponents.Create3DVector3
planePosition
Type: VisualComponents.Create3DVector3
planeDirection
Type: VisualComponents.Create3DVector3

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.Create3D.IWindow3D.MapCursorToPlane(VisualComponents.Create3D.Vector3@,VisualComponents.Create3D.Vector3,VisualComponents.Create3D.Vector3)"]

See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.MapXYCoordinatesToFloor Method

IWindow3DMapXYCoordinatesToFloor Method

Map screen coordinates to 3D world floor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 MapXYCoordinatesToFloor(
    int x,
    int y
)
Vector3 MapXYCoordinatesToFloor(
    int x,
    int y
)

Parameters

x
Type: SystemInt32
X coordinate
y
Type: SystemInt32
Y coordinate

Return Value

Type: Vector3
3D world position of point on floor.
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.MapXYCoordinatesToPlane Method

IWindow3DMapXYCoordinatesToPlane Method

Overload List
 | Name | Description
Public method | MapXYCoordinatesToPlane(Int32, Int32, Vector3, Vector3) | Map screen coordinates to given plane in 3D world.
Public method | MapXYCoordinatesToPlane(Int32, Int32, Vector3, Vector3, Boolean) | Obsolete.
Top
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.MapXYCoordinatesToPlane Method (Int32, Int32, Vector3, Vector3)

IWindow3DMapXYCoordinatesToPlane Method (Int32, Int32, Vector3, Vector3)

Map screen coordinates to given plane in 3D world.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 MapXYCoordinatesToPlane(
    int x,
    int y,
    Vector3 planePosition,
    Vector3 planeDirection
)
Vector3 MapXYCoordinatesToPlane(
    int x,
    int y,
    Vector3 planePosition,
    Vector3 planeDirection
)

Parameters

x
Type: SystemInt32
X coordinate
y
Type: SystemInt32
Y coordinate
planePosition
Type: VisualComponents.Create3DVector3
Point on plane, in 3D world coordinates.
planeDirection
Type: VisualComponents.Create3DVector3
Plane normal direction. This must be a vector with length 1.

Return Value

Type: Vector3
3D world position of mapped point.
See Also

Reference

IWindow3D Interface
MapXYCoordinatesToPlane Overload
VisualComponents.Create3D Namespace


IWindow3D.MapXYCoordinatesToPlane Method (Int32, Int32, Vector3, Vector3, Boolean)

IWindow3DMapXYCoordinatesToPlane Method (Int32, Int32, Vector3, Vector3, Boolean)

Note: This API is now obsolete.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Identical to the other overload; considerCameraGazeLength parameter is ignored.")]
Vector3 MapXYCoordinatesToPlane(
    int x,
    int y,
    Vector3 planePosition,
    Vector3 planeDirection,
    bool considerCameraGazeLength
)
[ObsoleteAttribute(L"Identical to the other overload; considerCameraGazeLength parameter is ignored.")]
Vector3 MapXYCoordinatesToPlane(
    int x,
    int y,
    Vector3 planePosition,
    Vector3 planeDirection,
    bool considerCameraGazeLength
)

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
planePosition
Type: VisualComponents.Create3DVector3
planeDirection
Type: VisualComponents.Create3DVector3
considerCameraGazeLength
Type: SystemBoolean

Return Value

Type: Vector3

[Missing <returns> documentation for "M:VisualComponents.Create3D.IWindow3D.MapXYCoordinatesToPlane(System.Int32,System.Int32,VisualComponents.Create3D.Vector3,VisualComponents.Create3D.Vector3,System.Boolean)"]

See Also

Reference

IWindow3D Interface
MapXYCoordinatesToPlane Overload
VisualComponents.Create3D Namespace


IWindow3D.PickGeoPrimitive Method

IWindow3DPickGeoPrimitive Method

Overload List
 | Name | Description
Public method | PickGeoPrimitive(Int32, Int32, PickPrimitives) |
Public method | PickGeoPrimitive(Int32, Int32, Int32, IntPtr) | Obsolete.
Public method | PickGeoPrimitive(Int32, Int32, PickPrimitives, IEnumerableISimNode) |
Public method | PickGeoPrimitive(Int32, Int32, PickPrimitives, IntPtr) |
Top
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.PickGeoPrimitive Method (Int32, Int32, PickPrimitives)

IWindow3DPickGeoPrimitive Method (Int32, Int32, PickPrimitives)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
GeoPrimitivePickResult PickGeoPrimitive(
    int x,
    int y,
    PickPrimitives filter
)
GeoPrimitivePickResult PickGeoPrimitive(
    int x,
    int y,
    PickPrimitives filter
)

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
filter
Type: VisualComponents.Create3DPickPrimitives

Return Value

Type: GeoPrimitivePickResult

[Missing <returns> documentation for "M:VisualComponents.Create3D.IWindow3D.PickGeoPrimitive(System.Int32,System.Int32,VisualComponents.Create3D.PickPrimitives)"]

See Also

Reference

IWindow3D Interface
PickGeoPrimitive Overload
VisualComponents.Create3D Namespace


IWindow3D.PickGeoPrimitive Method (Int32, Int32, Int32, IntPtr)

IWindow3DPickGeoPrimitive Method (Int32, Int32, Int32, IntPtr)

Note: This API is now obsolete.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Use PickGeoPrimitive(int x, int y, PickPrimitives filter) instead.")]
GeoPrimitivePickResult PickGeoPrimitive(
    int x,
    int y,
    int filter,
    IntPtr nodeFilter
)
[ObsoleteAttribute(L"Use PickGeoPrimitive(int x, int y, PickPrimitives filter) instead.")]
GeoPrimitivePickResult PickGeoPrimitive(
    int x,
    int y,
    int filter,
    IntPtr nodeFilter
)

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
filter
Type: SystemInt32
nodeFilter
Type: SystemIntPtr

Return Value

Type: GeoPrimitivePickResult

[Missing <returns> documentation for "M:VisualComponents.Create3D.IWindow3D.PickGeoPrimitive(System.Int32,System.Int32,System.Int32,System.IntPtr)"]

See Also

Reference

IWindow3D Interface
PickGeoPrimitive Overload
VisualComponents.Create3D Namespace


IWindow3D.PickGeoPrimitive Method (Int32, Int32, PickPrimitives, IEnumerable(ISimNode))

IWindow3DPickGeoPrimitive Method (Int32, Int32, PickPrimitives, IEnumerableISimNode)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
GeoPrimitivePickResult PickGeoPrimitive(
    int x,
    int y,
    PickPrimitives pickFilter,
    IEnumerable<ISimNode> nodes
)
GeoPrimitivePickResult PickGeoPrimitive(
    int x,
    int y,
    PickPrimitives pickFilter,
    IEnumerable<ISimNode^>^ nodes
)

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
pickFilter
Type: VisualComponents.Create3DPickPrimitives
nodes
Type: System.Collections.GenericIEnumerableISimNode

Return Value

Type: GeoPrimitivePickResult

[Missing <returns> documentation for "M:VisualComponents.Create3D.IWindow3D.PickGeoPrimitive(System.Int32,System.Int32,VisualComponents.Create3D.PickPrimitives,System.Collections.Generic.IEnumerable{VisualComponents.Create3D.ISimNode})"]

See Also

Reference

IWindow3D Interface
PickGeoPrimitive Overload
VisualComponents.Create3D Namespace


IWindow3D.PickGeoPrimitive Method (Int32, Int32, PickPrimitives, IntPtr)

IWindow3DPickGeoPrimitive Method (Int32, Int32, PickPrimitives, IntPtr)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
GeoPrimitivePickResult PickGeoPrimitive(
    int x,
    int y,
    PickPrimitives filter,
    IntPtr nodeFilter
)
GeoPrimitivePickResult PickGeoPrimitive(
    int x,
    int y,
    PickPrimitives filter,
    IntPtr nodeFilter
)

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
filter
Type: VisualComponents.Create3DPickPrimitives
nodeFilter
Type: SystemIntPtr

Return Value

Type: GeoPrimitivePickResult

[Missing <returns> documentation for "M:VisualComponents.Create3D.IWindow3D.PickGeoPrimitive(System.Int32,System.Int32,VisualComponents.Create3D.PickPrimitives,System.IntPtr)"]

See Also

Reference

IWindow3D Interface
PickGeoPrimitive Overload
VisualComponents.Create3D Namespace


IWindow3D.PickScene Method

IWindow3DPickScene Method

Overload List
 | Name | Description
Public method | PickScene(Int32, Int32) |
Public method | PickScene(Int32, Int32, Boolean) |
Top
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.PickScene Method (Int32, Int32)

IWindow3DPickScene Method (Int32, Int32)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
PickResult PickScene(
    int x,
    int y
)
PickResult PickScene(
    int x,
    int y
)

Parameters

x
Type: SystemInt32
y
Type: SystemInt32

Return Value

Type: PickResult

[Missing <returns> documentation for "M:VisualComponents.Create3D.IWindow3D.PickScene(System.Int32,System.Int32)"]

See Also

Reference

IWindow3D Interface
PickScene Overload
VisualComponents.Create3D Namespace


IWindow3D.PickScene Method (Int32, Int32, Boolean)

IWindow3DPickScene Method (Int32, Int32, Boolean)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
PickResult PickScene(
    int x,
    int y,
    bool noHitTest
)
PickResult PickScene(
    int x,
    int y,
    bool noHitTest
)

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
noHitTest
Type: SystemBoolean

Return Value

Type: PickResult

[Missing <returns> documentation for "M:VisualComponents.Create3D.IWindow3D.PickScene(System.Int32,System.Int32,System.Boolean)"]

See Also

Reference

IWindow3D Interface
PickScene Overload
VisualComponents.Create3D Namespace


IWindow3D.PointToImagePlane Method

IWindow3DPointToImagePlane Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Point PointToImagePlane(
    int x,
    int y
)
Point PointToImagePlane(
    int x,
    int y
)

Parameters

x
Type: SystemInt32
y
Type: SystemInt32

Return Value

Type: Point

[Missing <returns> documentation for "M:VisualComponents.Create3D.IWindow3D.PointToImagePlane(System.Int32,System.Int32)"]

See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.ProjectBoundsFromLocalToScreenSpace Method

IWindow3DProjectBoundsFromLocalToScreenSpace Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3[] ProjectBoundsFromLocalToScreenSpace(
    Matrix positionInWorld,
    Object item,
    double[] limits
)
array<Vector3>^ ProjectBoundsFromLocalToScreenSpace(
    Matrix positionInWorld,
    Object^ item,
    array<double>^ limits
)

Parameters

positionInWorld
Type: VisualComponents.Create3DMatrix
item
Type: SystemObject
limits
Type: SystemDouble

Return Value

Type: Vector3

[Missing <returns> documentation for "M:VisualComponents.Create3D.IWindow3D.ProjectBoundsFromLocalToScreenSpace(VisualComponents.Create3D.Matrix,System.Object,System.Double[])"]

See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.ProjectPointFromLocalToScreenSpace Method

IWindow3DProjectPointFromLocalToScreenSpace Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 ProjectPointFromLocalToScreenSpace(
    Matrix positionInWorld,
    Vector3 pointInScreenSpace
)
Vector3 ProjectPointFromLocalToScreenSpace(
    Matrix positionInWorld,
    Vector3 pointInScreenSpace
)

Parameters

positionInWorld
Type: VisualComponents.Create3DMatrix
pointInScreenSpace
Type: VisualComponents.Create3DVector3

Return Value

Type: Vector3

[Missing <returns> documentation for "M:VisualComponents.Create3D.IWindow3D.ProjectPointFromLocalToScreenSpace(VisualComponents.Create3D.Matrix,VisualComponents.Create3D.Vector3)"]

See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.ProjectWorldPointToScreenSpace Method

IWindow3DProjectWorldPointToScreenSpace Method

Projects world position defined by a matrix to screen space coordinates.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ProjectWorldPointToScreenSpace(
    ref Matrix positionInWorld,
    out Vector3 screenPosition
)
bool ProjectWorldPointToScreenSpace(
    Matrix% positionInWorld,
    [OutAttribute] Vector3% screenPosition
)

Parameters

positionInWorld
Type: VisualComponents.Create3DMatrix
The world position matrix.
screenPosition
Type: VisualComponents.Create3DVector3
Output screen position. Negative Z values mean that the point is in front of the camera.

Return Value

Type: Boolean
Whether the world point is within the camera view frustrum.
Remarks
Ref parameter is used to avoid copying the matrix struct. It is not modified by the function.
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.RaycastScene Method

IWindow3DRaycastScene Method

Overload List
 | Name | Description
Public method | RaycastScene(Int32, Int32) | Shoots ray using the given screen coordinates and results the first hit.
Public method | RaycastScene(Int32, Int32, Boolean) | Shoots ray using the given screen coordinates and results the first hit.
Public method | RaycastScene(Int32, Int32, IEnumerableNodeListEntry) | Shoots ray using the given screen coordinates and results the first hit.
Public method | RaycastScene(Matrix, Double, Boolean) | Shoots ray using the given word position and results the first hit.
Public method | RaycastScene(Int32, Int32, Boolean, PickPrimitives, Boolean) | Shoots ray using the given screen coordinates and results the first hit.
Public method | RaycastScene(Matrix, Double, Boolean, PickPrimitives, Boolean) | Shoots ray using the given word position and results the first hit.
Public method | RaycastScene(Int32, Int32, Boolean, PickPrimitives, Boolean, Double) | Shoots ray using the given screen coordinates and results the first hit.
Public method | RaycastScene(Matrix, Double, Boolean, PickPrimitives, Boolean, IEnumerableNodeListEntry) | Shoots ray using the given word position and results the first hit.
Public method | RaycastScene(Int32, Int32, Boolean, PickPrimitives, Boolean, Double, IEnumerableNodeListEntry) | Shoots ray using the given screen coordinates and results the first hit.
Top
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.RaycastScene Method (Int32, Int32)

IWindow3DRaycastScene Method (Int32, Int32)

Shoots ray using the given screen coordinates and results the first hit.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
RaycastResult RaycastScene(
    int x,
    int y
)
RaycastResult RaycastScene(
    int x,
    int y
)

Parameters

x
Type: SystemInt32
Screen X coordinate.
y
Type: SystemInt32
Screen Y coordinate.

Return Value

Type: RaycastResult
Raycast result.
See Also

Reference

IWindow3D Interface
RaycastScene Overload
VisualComponents.Create3D Namespace


IWindow3D.RaycastScene Method (Int32, Int32, Boolean)

IWindow3DRaycastScene Method (Int32, Int32, Boolean)

Shoots ray using the given screen coordinates and results the first hit.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
RaycastResult RaycastScene(
    int x,
    int y,
    bool pickBackface
)
RaycastResult RaycastScene(
    int x,
    int y,
    bool pickBackface
)

Parameters

x
Type: SystemInt32
Screen X coordinate.
y
Type: SystemInt32
Screen Y coordinate.
pickBackface
Type: SystemBoolean
Defines if the triangle backfaces are included in raycast hit test.

Return Value

Type: RaycastResult
Raycast result.
See Also

Reference

IWindow3D Interface
RaycastScene Overload
VisualComponents.Create3D Namespace


IWindow3D.RaycastScene Method (Int32, Int32, IEnumerable(NodeListEntry))

IWindow3DRaycastScene Method (Int32, Int32, IEnumerableNodeListEntry)

Shoots ray using the given screen coordinates and results the first hit.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
RaycastResult RaycastScene(
    int x,
    int y,
    IEnumerable<NodeListEntry> nodeEntries
)
RaycastResult RaycastScene(
    int x,
    int y,
    IEnumerable<NodeListEntry^>^ nodeEntries
)

Parameters

x
Type: SystemInt32
Screen X coordinate.
y
Type: SystemInt32
Screen Y coordinate.
nodeEntries
Type: System.Collections.GenericIEnumerableNodeListEntry
Nodes to include in the raycast hit test.

Return Value

Type: RaycastResult
Raycast result.
See Also

Reference

IWindow3D Interface
RaycastScene Overload
VisualComponents.Create3D Namespace


IWindow3D.RaycastScene Method (Matrix, Double, Boolean)

IWindow3DRaycastScene Method (Matrix, Double, Boolean)

Shoots ray using the given word position and results the first hit.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
RaycastResult RaycastScene(
    Matrix position,
    double rayLength,
    bool pickBackface
)
RaycastResult RaycastScene(
    Matrix position,
    double rayLength,
    bool pickBackface
)

Parameters

position
Type: VisualComponents.Create3DMatrix
Ray transformation matrix (position and direction).
rayLength
Type: SystemDouble
Ray length.
pickBackface
Type: SystemBoolean
Defines if the triangle backfaces are included in raycast hit test.

Return Value

Type: RaycastResult
Raycast result.
See Also

Reference

IWindow3D Interface
RaycastScene Overload
VisualComponents.Create3D Namespace


IWindow3D.RaycastScene Method (Int32, Int32, Boolean, PickPrimitives, Boolean)

IWindow3DRaycastScene Method (Int32, Int32, Boolean, PickPrimitives, Boolean)

Shoots ray using the given screen coordinates and results the first hit.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
RaycastResult RaycastScene(
    int x,
    int y,
    bool pickBackface,
    PickPrimitives filters,
    bool pickSysGeometry
)
RaycastResult RaycastScene(
    int x,
    int y,
    bool pickBackface,
    PickPrimitives filters,
    bool pickSysGeometry
)

Parameters

x
Type: SystemInt32
Screen X coordinate.
y
Type: SystemInt32
Screen Y coordinate.
pickBackface
Type: SystemBoolean
Defines if the triangle backfaces are included in raycast hit test.
filters
Type: VisualComponents.Create3DPickPrimitives
Defines the geometry primitive types that are included in raycast hit test.
pickSysGeometry
Type: SystemBoolean
Defines if the system geometries are included in raycast hit test.

Return Value

Type: RaycastResult
Raycast result.
See Also

Reference

IWindow3D Interface
RaycastScene Overload
VisualComponents.Create3D Namespace


IWindow3D.RaycastScene Method (Matrix, Double, Boolean, PickPrimitives, Boolean)

IWindow3DRaycastScene Method (Matrix, Double, Boolean, PickPrimitives, Boolean)

Shoots ray using the given word position and results the first hit.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
RaycastResult RaycastScene(
    Matrix position,
    double rayLength,
    bool pickBackface,
    PickPrimitives filters,
    bool pickSysGeometry
)
RaycastResult RaycastScene(
    Matrix position,
    double rayLength,
    bool pickBackface,
    PickPrimitives filters,
    bool pickSysGeometry
)

Parameters

position
Type: VisualComponents.Create3DMatrix
Ray transformation matrix (position and direction).
rayLength
Type: SystemDouble
Ray length.
pickBackface
Type: SystemBoolean
Defines if the triangle backfaces are included in raycast hit test.
filters
Type: VisualComponents.Create3DPickPrimitives
Defines the geometry primitive types that are included in raycast hit test.
pickSysGeometry
Type: SystemBoolean
Defines if the system geometries are included in raycast hit test.

Return Value

Type: RaycastResult
Raycast result.
See Also

Reference

IWindow3D Interface
RaycastScene Overload
VisualComponents.Create3D Namespace


IWindow3D.RaycastScene Method (Int32, Int32, Boolean, PickPrimitives, Boolean, Double)

IWindow3DRaycastScene Method (Int32, Int32, Boolean, PickPrimitives, Boolean, Double)

Shoots ray using the given screen coordinates and results the first hit.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
RaycastResult RaycastScene(
    int x,
    int y,
    bool pickBackface,
    PickPrimitives filters,
    bool pickSysGeometry,
    double snapThreshold
)
RaycastResult RaycastScene(
    int x,
    int y,
    bool pickBackface,
    PickPrimitives filters,
    bool pickSysGeometry,
    double snapThreshold
)

Parameters

x
Type: SystemInt32
Screen X coordinate.
y
Type: SystemInt32
Screen Y coordinate.
pickBackface
Type: SystemBoolean
Defines if the triangle backfaces are included in raycast hit test.
filters
Type: VisualComponents.Create3DPickPrimitives
Defines the geometry primitive types that are included in raycast hit test.
pickSysGeometry
Type: SystemBoolean
Defines if the system geometries are included in raycast hit test.
snapThreshold
Type: SystemDouble
Defines the tolerance (i.e. sensitivity) of raycast hit test.

Return Value

Type: RaycastResult
Raycast result.
See Also

Reference

IWindow3D Interface
RaycastScene Overload
VisualComponents.Create3D Namespace


IWindow3D.RaycastScene Method (Matrix, Double, Boolean, PickPrimitives, Boolean, IEnumerable(NodeListEntry))

IWindow3DRaycastScene Method (Matrix, Double, Boolean, PickPrimitives, Boolean, IEnumerableNodeListEntry)

Shoots ray using the given word position and results the first hit.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
RaycastResult RaycastScene(
    Matrix position,
    double rayLength,
    bool pickBackface,
    PickPrimitives filters,
    bool pickSysGeometry,
    IEnumerable<NodeListEntry> nodeEntries
)
RaycastResult RaycastScene(
    Matrix position,
    double rayLength,
    bool pickBackface,
    PickPrimitives filters,
    bool pickSysGeometry,
    IEnumerable<NodeListEntry^>^ nodeEntries
)

Parameters

position
Type: VisualComponents.Create3DMatrix
Ray transformation matrix (position and direction).
rayLength
Type: SystemDouble
Ray length.
pickBackface
Type: SystemBoolean
Defines if the triangle backfaces are included in raycast hit test.
filters
Type: VisualComponents.Create3DPickPrimitives
Defines the geometry primitive types that are included in raycast hit test.
pickSysGeometry
Type: SystemBoolean
Defines if the system geometries are included in raycast hit test.
nodeEntries
Type: System.Collections.GenericIEnumerableNodeListEntry
Nodes to include in the raycast hit test.

Return Value

Type: RaycastResult
Raycast result.
See Also

Reference

IWindow3D Interface
RaycastScene Overload
VisualComponents.Create3D Namespace


IWindow3D.RaycastScene Method (Int32, Int32, Boolean, PickPrimitives, Boolean, Double, IEnumerable(NodeListEntry))

IWindow3DRaycastScene Method (Int32, Int32, Boolean, PickPrimitives, Boolean, Double, IEnumerableNodeListEntry)

Shoots ray using the given screen coordinates and results the first hit.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
RaycastResult RaycastScene(
    int x,
    int y,
    bool pickBackface,
    PickPrimitives filters,
    bool pickSysGeometry,
    double snapThreshold,
    IEnumerable<NodeListEntry> nodeEntries
)
RaycastResult RaycastScene(
    int x,
    int y,
    bool pickBackface,
    PickPrimitives filters,
    bool pickSysGeometry,
    double snapThreshold,
    IEnumerable<NodeListEntry^>^ nodeEntries
)

Parameters

x
Type: SystemInt32
Screen X coordinate.
y
Type: SystemInt32
Screen Y coordinate.
pickBackface
Type: SystemBoolean
Defines if the triangle backfaces are included in raycast hit test.
filters
Type: VisualComponents.Create3DPickPrimitives
Defines the geometry primitive types that are included in raycast hit test.
pickSysGeometry
Type: SystemBoolean
Defines if the system geometries are included in raycast hit test.
snapThreshold
Type: SystemDouble
Defines the tolerance (i.e. sensitivity) of raycast hit test.
nodeEntries
Type: System.Collections.GenericIEnumerableNodeListEntry
Nodes to include in the raycast hit test.

Return Value

Type: RaycastResult
Raycast result.
See Also

Reference

IWindow3D Interface
RaycastScene Overload
VisualComponents.Create3D Namespace


IWindow3D.RemoveGhostVisuals Method

IWindow3DRemoveGhostVisuals Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RemoveGhostVisuals()
void RemoveGhostVisuals()
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.Render Method

IWindow3DRender Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Render()
void Render()
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.SetTransparency Method

IWindow3DSetTransparency Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetTransparency(
    IEnumerable<IVisualObject> visuals,
    double opacity
)
void SetTransparency(
    IEnumerable<IVisualObject^>^ visuals,
    double opacity
)

Parameters

visuals
Type: System.Collections.GenericIEnumerableIVisualObject
opacity
Type: SystemDouble
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.SetXY Method

IWindow3DSetXY Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetXY(
    int x,
    int y
)
void SetXY(
    int x,
    int y
)

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.UpdateGhostVisuals Method

IWindow3DUpdateGhostVisuals Method

Update ghost visuals e.g. for snap result preview.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool UpdateGhostVisuals(
    bool show,
    bool showOriginal,
    IManipulationTarget manipulationTarget,
    IEnumerable<IVisualObject> visuals,
    Nullable<Matrix> referencePosition,
    Nullable<Matrix> newPosition
)
bool UpdateGhostVisuals(
    bool show,
    bool showOriginal,
    IManipulationTarget^ manipulationTarget,
    IEnumerable<IVisualObject^>^ visuals,
    Nullable<Matrix> referencePosition,
    Nullable<Matrix> newPosition
)

Parameters

show
Type: SystemBoolean
showOriginal
Type: SystemBoolean
manipulationTarget
Type: VisualComponents.Create3DIManipulationTarget
visuals
Type: System.Collections.GenericIEnumerableIVisualObject
referencePosition
Type: SystemNullableMatrix
newPosition
Type: SystemNullableMatrix

Return Value

Type: Boolean
True if no errors detected.
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D.WorldToScreenPosition Method

IWindow3DWorldToScreenPosition Method

World position to screen position

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Point WorldToScreenPosition(
    Vector3 position
)
Point WorldToScreenPosition(
    Vector3 position
)

Parameters

position
Type: VisualComponents.Create3DVector3
Position in 3D world coordiantes

Return Value

Type: Point

[Missing <returns> documentation for "M:VisualComponents.Create3D.IWindow3D.WorldToScreenPosition(VisualComponents.Create3D.Vector3)"]

See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindow3D Events

The IWindow3D type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Top
See Also

Reference

IWindow3D Interface
VisualComponents.Create3D Namespace


IWindowSection Interface

Configuration file section for window options.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IWindowSection : ISection
public interface class IWindowSection : ISection

The IWindowSection type exposes the following members.

Properties
 | Name | Description
Public property | Placement | Configuration file element for window options.
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | GetSection | Gets the section (Inherited from ISection.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IWindowSection Properties

The IWindowSection type exposes the following members.

Properties
 | Name | Description
Public property | Placement | Configuration file element for window options.
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
See Also

Reference

IWindowSection Interface
VisualComponents.Create3D Namespace


IWindowSection.Placement Property

IWindowSectionPlacement Property

Configuration file element for window options.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
WindowConfigElement Placement { get; }
property WindowConfigElement^ Placement {
    WindowConfigElement^ get ();
}

Property Value

Type: WindowConfigElement
See Also

Reference

IWindowSection Interface
VisualComponents.Create3D Namespace


IWindowSection Methods

The IWindowSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | GetSection | Gets the section (Inherited from ISection.)
Top
See Also

Reference

IWindowSection Interface
VisualComponents.Create3D Namespace


IVisitable Interface

Nodes that allow visitors should implement this interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IVisitable
public interface class IVisitable

The IVisitable type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor.
Top
See Also

Reference

VisualComponents.Create3D Namespace


IVisitable Methods

The IVisitable type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor.
Top
See Also

Reference

IVisitable Interface
VisualComponents.Create3D Namespace


IVisitable.Accept Method

IVisitableAccept Method

Calls Visit method of visitor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Accept(
    VisitorBase visitor
)
void Accept(
    VisitorBase^ visitor
)

Parameters

visitor
Type: VisualComponents.Create3DVisitorBase
See Also

Reference

IVisitable Interface
VisualComponents.Create3D Namespace


IVisualObject Interface

IVisualObjects are objects that can be manipulated using its position matrix.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IVisualObject : INamed,
    IWrapper, IDisposable
public interface class IVisualObject : INamed,
    IWrapper, IDisposable

The IVisualObject type exposes the following members.

Properties
 | Name | Description
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates.
Public property | IsHighlighted |
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center.
Public property | SelectionType |
Public property | TransformationInReference | Gets or sets the transformation matrix.
Public property | TransformationInWorld | Gets or sets the world transformation matrix
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | TransformContent | Transform all the content by the given matrix.
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | TransformationChanged | Transformation changed event
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IVisualObject Properties

The IVisualObject type exposes the following members.

Properties
 | Name | Description
Public property | BoundBox | Retrieves the bounding box of the object in nodes local coordinates.
Public property | IsHighlighted |
Public property | IsValid | (Inherited from IWrapper.)
Public property | IsVisible | Gets or sets visibility of the object
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ReferencePoints | Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center.
Public property | SelectionType |
Public property | TransformationInReference | Gets or sets the transformation matrix.
Public property | TransformationInWorld | Gets or sets the world transformation matrix
Top
See Also

Reference

IVisualObject Interface
VisualComponents.Create3D Namespace


IVisualObject.BoundBox Property

IVisualObjectBoundBox Property

Retrieves the bounding box of the object in nodes local coordinates.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IBoundBox BoundBox { get; }
property IBoundBox^ BoundBox {
    IBoundBox^ get ();
}

Property Value

Type: IBoundBox
See Also

Reference

IVisualObject Interface
VisualComponents.Create3D Namespace


IVisualObject.IsHighlighted Property

IVisualObjectIsHighlighted Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsHighlighted { get; set; }
property bool IsHighlighted {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IVisualObject Interface
VisualComponents.Create3D Namespace


IVisualObject.IsVisible Property

IVisualObjectIsVisible Property

Gets or sets visibility of the object

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsVisible { get; set; }
property bool IsVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IVisualObject Interface
VisualComponents.Create3D Namespace


IVisualObject.ReferencePoints Property

IVisualObjectReferencePoints Property

Gets the reference points of the object, which are used in area selection test. This list contains: - for ISimComponent contains ReferencePoints of each child node and RootNode. - for ISimNode contains GeometrySet bounds for all geometries (corners and centers). - for other visual objects contains bound center.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<Vector3> ReferencePoints { get; }
property ReadOnlyCollection<Vector3>^ ReferencePoints {
    ReadOnlyCollection<Vector3>^ get ();
}

Property Value

Type: ReadOnlyCollectionVector3
See Also

Reference

IVisualObject Interface
VisualComponents.Create3D Namespace


IVisualObject.SelectionType Property

IVisualObjectSelectionType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
SelectionTypes SelectionType { get; }
property SelectionTypes SelectionType {
    SelectionTypes get ();
}

Property Value

Type: SelectionTypes
See Also

Reference

IVisualObject Interface
VisualComponents.Create3D Namespace


IVisualObject.TransformationInReference Property

IVisualObjectTransformationInReference Property

Gets or sets the transformation matrix.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix TransformationInReference { get; set; }
property Matrix TransformationInReference {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

IVisualObject Interface
VisualComponents.Create3D Namespace


IVisualObject.TransformationInWorld Property

IVisualObjectTransformationInWorld Property

Gets or sets the world transformation matrix

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Matrix TransformationInWorld { get; set; }
property Matrix TransformationInWorld {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

IVisualObject Interface
VisualComponents.Create3D Namespace


IVisualObject Methods

The IVisualObject type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals | (Inherited from IWrapper.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | TransformContent | Transform all the content by the given matrix.
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IVisualObject Interface
VisualComponents.Create3D Namespace


IVisualObject.TransformContent Method

IVisualObjectTransformContent Method

Transform all the content by the given matrix.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void TransformContent(
    Matrix transform
)
void TransformContent(
    Matrix transform
)

Parameters

transform
Type: VisualComponents.Create3DMatrix
Transformation to apply.
Remarks

The transformation will reposition all the content by the specified amount. The transform is interpreted as an absolute transformation in the local reference coordinate system.

If the visual object is part of a visual tree, all its child nodes will be affected as well.

If the content of the visual object is hierarchical, the transformation will only be applied at the topmost level needed to fulfill the change.

See Also

Reference

IVisualObject Interface
VisualComponents.Create3D Namespace


IVisualObject Events

The IVisualObject type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | TransformationChanged | Transformation changed event
Top
See Also

Reference

IVisualObject Interface
VisualComponents.Create3D Namespace


IVisualObject.TransformationChanged Event

IVisualObjectTransformationChanged Event

Transformation changed event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> TransformationChanged
 event EventHandler<EventArgs^>^ TransformationChanged {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

IVisualObject Interface
VisualComponents.Create3D Namespace


IVolumeSensor Interface

Sensor behavior that uses bounding box to detect geometry.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IVolumeSensor : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed
public interface class IVolumeSensor : IBehavior,
    IPropertyContainer, IBatchModeObject, IVisitable, IWrapper, IDisposable,
    INamed

The IVolumeSensor type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IVolumeSensor Properties

The IVolumeSensor type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | Node | Get the ISimNode instance that owns this IBehavior instance. (Inherited from IBehavior.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | Type | Gets the type of this IBehavior instance. (Inherited from IBehavior.)
Top
See Also

Reference

IVolumeSensor Interface
VisualComponents.Create3D Namespace


IVolumeSensor Methods

The IVolumeSensor type exposes the following members.

Methods
 | Name | Description
Public method | Accept | Calls Visit method of visitor. (Inherited from IVisitable.)
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | ChangeNode | Changes the ISimNode container of this IBehavior instance. (Inherited from IBehavior.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Destroy | Deletes this IBehavior instance. This method should be called after removing the behavior from the containing ISimNode and if is not going to be added into another ISimNode. (Inherited from IBehavior.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | Evaluate | Evaluates this IBehavior instance. This is useful if the behavior has references to the geometry and the referenced geometry is changed. For instance, if the frames of the path behavior change the path needs to be re-evaluated. (Inherited from IBehavior.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IVolumeSensor Interface
VisualComponents.Create3D Namespace


IVolumeSensor Events

The IVolumeSensor type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IVolumeSensor Interface
VisualComponents.Create3D Namespace


IWorkStatement Interface

Reserves one resource from an IPythonTransportController to work in the process for the duration.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IWorkStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement>, ICloneable
public interface class IWorkStatement : IStatement,
    INamed, IPropertyContainer, IBatchModeObject, IWrapper, IDisposable,
    IApiType, ICloneable<IStatement^>, ICloneable

The IWorkStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | Controller | The IPythonTransportController that will delegate the work to a resource.
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProcessTimeDistributionExpression | An expression that defines the duration of the work, see TimeSource.
Public property | ProcessTimeExpression | An expression that defines the duration of the work, see TimeSource.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ResourcePositionFrame | A frame that defines the position where the resource should be when doing its work.
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | TimeSource | Gets or sets the process time value source to use, see ProcessTimeDistributionExpression and ProcessTimeExpression.
Public property | WorkPositionFrame | A frame that defines the position where the actual work happens.
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IWorkStatement Properties

The IWorkStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from IApiType.)
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | ControlExecutedExEvent | Defines if the statement automatically signals ExecutingEx event. This is false by default but can be set to true by custom statements that for some reason want to delay and manually signal the event using NotifyStatementExecutedEx(IStatement) method. This may be useful when implementing custom robot motion statement that supports rcs advanced run execution (not supported yet). (Inherited from IStatement.)
Public property | Controller | The IPythonTransportController that will delegate the work to a resource.
Public property | CustomStatement | Associated custom statement that is listening to this statement events, and implements main execution logic. (Inherited from IStatement.)
Public property | ExecutedCycleTime | Gets the cached execution time of the statement. (Inherited from IStatement.)
Public property | IsExecuting | Defines if this instance of IStatement is being executed. (Inherited from IStatement.)
Public property | IsLoop | Defines if this instance of IStatement will be executed again after it finishes executing. (Inherited from IStatement.)
Public property | IsValid | (Inherited from IWrapper.)
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | ParentScope | Gets the instance of IStatementScope that owns this instance of IStatement. This can either be a routine, statement or a scope in another statement. (Inherited from IStatement.)
Public property | Pointer | Pointer to the native object. (Inherited from IWrapper.)
Public property | ProcessTimeDistributionExpression | An expression that defines the duration of the work, see TimeSource.
Public property | ProcessTimeExpression | An expression that defines the duration of the work, see TimeSource.
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | ResourcePositionFrame | A frame that defines the position where the resource should be when doing its work.
Public property | Routine | Gets the instance of IRoutine that owns this instance of IStatement. (Inherited from IStatement.)
Public property | TimeSource | Gets or sets the process time value source to use, see ProcessTimeDistributionExpression and ProcessTimeExpression.
Public property | WorkPositionFrame | A frame that defines the position where the actual work happens.
Top
See Also

Reference

IWorkStatement Interface
VisualComponents.Create3D Namespace


IWorkStatement.Controller Property

IWorkStatementController Property

The IPythonTransportController that will delegate the work to a resource.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPythonTransportController Controller { get; set; }
property IPythonTransportController^ Controller {
    IPythonTransportController^ get ();
    void set (IPythonTransportController^ value);
}

Property Value

Type: IPythonTransportController
See Also

Reference

IWorkStatement Interface
VisualComponents.Create3D Namespace


IWorkStatement.ProcessTimeDistributionExpression Property

IWorkStatementProcessTimeDistributionExpression Property

An expression that defines the duration of the work, see TimeSource.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ProcessTimeDistributionExpression { get; set; }
property String^ ProcessTimeDistributionExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown if trying to set a null value
See Also

Reference

IWorkStatement Interface
VisualComponents.Create3D Namespace


IWorkStatement.ProcessTimeExpression Property

IWorkStatementProcessTimeExpression Property

An expression that defines the duration of the work, see TimeSource.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ProcessTimeExpression { get; set; }
property String^ ProcessTimeExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Thrown if trying to set a null value
See Also

Reference

IWorkStatement Interface
VisualComponents.Create3D Namespace


IWorkStatement.ResourcePositionFrame Property

IWorkStatementResourcePositionFrame Property

A frame that defines the position where the resource should be when doing its work.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFrameFeature ResourcePositionFrame { get; set; }
property IFrameFeature^ ResourcePositionFrame {
    IFrameFeature^ get ();
    void set (IFrameFeature^ value);
}

Property Value

Type: IFrameFeature
See Also

Reference

IWorkStatement Interface
VisualComponents.Create3D Namespace


IWorkStatement.TimeSource Property

IWorkStatementTimeSource Property

Gets or sets the process time value source to use, see ProcessTimeDistributionExpression and ProcessTimeExpression.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ProcessWorkStatementTimeSource TimeSource { get; set; }
property ProcessWorkStatementTimeSource TimeSource {
    ProcessWorkStatementTimeSource get ();
    void set (ProcessWorkStatementTimeSource value);
}

Property Value

Type: ProcessWorkStatementTimeSource
See Also

Reference

IWorkStatement Interface
VisualComponents.Create3D Namespace


IWorkStatement.WorkPositionFrame Property

IWorkStatementWorkPositionFrame Property

A frame that defines the position where the actual work happens.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFrameFeature WorkPositionFrame { get; set; }
property IFrameFeature^ WorkPositionFrame {
    IFrameFeature^ get ();
    void set (IFrameFeature^ value);
}

Property Value

Type: IFrameFeature
See Also

Reference

IWorkStatement Interface
VisualComponents.Create3D Namespace


IWorkStatement Methods

The IWorkStatement type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | Clone | (Inherited from ICloneableT.)
Public method | Clone(Boolean) | Extended cloning. (Inherited from IStatement.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Equals | (Inherited from IWrapper.)
Public method | ExecuteImmediate | Executes the statement in 'immediate' mode. If the statement supports immediate execution, it is executed immediately and thus not allowed to consume any simulation time. (Inherited from IStatement.)
Public method | GetHashCode | (Inherited from IWrapper.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IWorkStatement Interface
VisualComponents.Create3D Namespace


IWorkStatement Events

The IWorkStatement type exposes the following members.

Events
 | Name | Description
Public event | Executed | Event that occurs when the statement has been executed. (Inherited from IStatement.)
Public event | ExecutedEx | Event that occurs when the statement has been executed. In contrast to Executing this is triggered after advanced run (see ExecutingEx). (Inherited from IStatement.)
Public event | Executing | Event that occurs when the statement execution starts. (Inherited from IStatement.)
Public event | ExecutingEx | Event that occurs when the statement execution starts. In contrast to Executing this is triggered after advanced run and could differ from CurrentStatement. Advanced run can occur when executing robot flyby motion statements with RCS module (not supported yet). In this case the statement is executed in advance in order to feed the robot controller with requested targets. Use this event if you are interested in 'logical' execution order of the statements. (Inherited from IStatement.)
Public event | ObjectInvalidated | (Inherited from IWrapper.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Public event | Reset | Event that occurs when the statement (i.e. simulation is reset). (Inherited from IStatement.)
Top
See Also

Reference

IWorkStatement Interface
VisualComponents.Create3D Namespace


IWrapper Interface

Defines an interface for accessing a wrapped native object through a pointer.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IWrapper : IDisposable
public interface class IWrapper : IDisposable

The IWrapper type exposes the following members.

Properties
 | Name | Description
Public property | IsValid |
Public property | Pointer | Pointer to the native object.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals |
Public method | GetHashCode |
Top
Events
 | Name | Description
Public event | ObjectInvalidated |
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


IWrapper Properties

The IWrapper type exposes the following members.

Properties
 | Name | Description
Public property | IsValid |
Public property | Pointer | Pointer to the native object.
Top
See Also

Reference

IWrapper Interface
VisualComponents.Create3D Namespace


IWrapper.IsValid Property

IWrapperIsValid Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsValid { get; }
property bool IsValid {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IWrapper Interface
VisualComponents.Create3D Namespace


IWrapper.Pointer Property

IWrapperPointer Property

Pointer to the native object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IntPtr Pointer { get; }
property IntPtr Pointer {
    IntPtr get ();
}

Property Value

Type: IntPtr
See Also

Reference

IWrapper Interface
VisualComponents.Create3D Namespace


IWrapper Methods

The IWrapper type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Equals |
Public method | GetHashCode |
Top
Extension Methods
 | Name | Description
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Top
See Also

Reference

IWrapper Interface
VisualComponents.Create3D Namespace


IWrapper.Equals Method

IWrapperEquals Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool Equals(
    Object value
)
bool Equals(
    Object^ value
)

Parameters

value
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.IWrapper.Equals(System.Object)"]

See Also

Reference

IWrapper Interface
VisualComponents.Create3D Namespace


IWrapper.GetHashCode Method

IWrapperGetHashCode Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int GetHashCode()
int GetHashCode()

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.IWrapper.GetHashCode"]

See Also

Reference

IWrapper Interface
VisualComponents.Create3D Namespace


IWrapper Events

The IWrapper type exposes the following members.

Events
 | Name | Description
Public event | ObjectInvalidated |
Top
See Also

Reference

IWrapper Interface
VisualComponents.Create3D Namespace


IWrapper.ObjectInvalidated Event

IWrapperObjectInvalidated Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler ObjectInvalidated
 event EventHandler^ ObjectInvalidated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IWrapper Interface
VisualComponents.Create3D Namespace


JointAddedEventArgs Class

Joint added event args JointAdded
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DJointAddedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class JointAddedEventArgs : EventArgs
public ref class JointAddedEventArgs : public EventArgs

The JointAddedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | JointAddedEventArgs | Constructor
Top
Properties
 | Name | Description
Public property | Joint | Added joint
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


JointAddedEventArgs Constructor

Constructor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public JointAddedEventArgs(
    IJoint joint
)
public:
JointAddedEventArgs(
    IJoint^ joint
)

Parameters

joint
Type: VisualComponents.Create3DIJoint
Joint added to controller
See Also

Reference

JointAddedEventArgs Class
VisualComponents.Create3D Namespace


JointAddedEventArgs Properties

The JointAddedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Joint | Added joint
Top
See Also

Reference

JointAddedEventArgs Class
VisualComponents.Create3D Namespace


JointAddedEventArgs.Joint Property

JointAddedEventArgsJoint Property

Added joint

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IJoint Joint { get; }
public:
property IJoint^ Joint {
    IJoint^ get ();
}

Property Value

Type: IJoint
See Also

Reference

JointAddedEventArgs Class
VisualComponents.Create3D Namespace


JointAddedEventArgs Methods

The JointAddedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

JointAddedEventArgs Class
VisualComponents.Create3D Namespace


JointAxis Enumeration

Joint axis enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum JointAxis
public enum class JointAxis
Members
Member name | Value | Description
Other | -1 | Other axis
PositiveX | 0 | X axis
PositiveY | 1 | Y axis
PositiveZ | 2 | Z axis
NegativeX | 4 | -x axis
NegativeY | 5 | -y axis
NegativeZ | 6 | -z axis
See Also

Reference

VisualComponents.Create3D Namespace


JointControlType Enumeration

Joint control type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum JointControlType
public enum class JointControlType
Members
Member name | Value | Description
Fixed | 0 | Fixed link of any type.
Passive | 1 | Joggable link with neither physics nor servo/robot controller attached.
Physical | 2 | Physics engine controlled link.
ServoAxis | 3 | Servo controlled link.
ExternalRobotAxis | 4 | Robot controlled link mapped as an external axis.
KinematicRobotAxis | 5 | Robot controlled link mapped as a kinematic axis.
InterpolatedRobotAxis | 6 | Robot controlled link mapped as an interpolated axis.
See Also

Reference

VisualComponents.Create3D Namespace


JointLimitExceededEventArgs Class

Contains event data for JointLimitExceeded event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DJointLimitExceededEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class JointLimitExceededEventArgs : EventArgs
public ref class JointLimitExceededEventArgs : public EventArgs

The JointLimitExceededEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | JointLimitExceededEventArgs | Initializes a new instance of JointLimitExceededEventArgs.
Top
Properties
 | Name | Description
Public property | FailedTest | Gets the failed test.
Public property | Joint | Gets the joint that exceeded the limit.
Public property | LimitValue | Gets the limit value of the failed test.
Public property | Value | Gets the value of the failed test.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


JointLimitExceededEventArgs Constructor

Initializes a new instance of JointLimitExceededEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public JointLimitExceededEventArgs(
    IJoint joint,
    JointLimitTests failedTest,
    double value,
    double limit
)
public:
JointLimitExceededEventArgs(
    IJoint^ joint,
    JointLimitTests failedTest,
    double value,
    double limit
)

Parameters

joint
Type: VisualComponents.Create3DIJoint
Joint that failed to pass the tests.
failedTest
Type: VisualComponents.Create3DJointLimitTests
Test that failed.
value
Type: SystemDouble
Value
limit
Type: SystemDouble
Limit value
See Also

Reference

JointLimitExceededEventArgs Class
VisualComponents.Create3D Namespace


JointLimitExceededEventArgs Properties

The JointLimitExceededEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | FailedTest | Gets the failed test.
Public property | Joint | Gets the joint that exceeded the limit.
Public property | LimitValue | Gets the limit value of the failed test.
Public property | Value | Gets the value of the failed test.
Top
See Also

Reference

JointLimitExceededEventArgs Class
VisualComponents.Create3D Namespace


JointLimitExceededEventArgs.FailedTest Property

JointLimitExceededEventArgsFailedTest Property

Gets the failed test.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public JointLimitTests FailedTest { get; }
public:
property JointLimitTests FailedTest {
    JointLimitTests get ();
}

Property Value

Type: JointLimitTests
See Also

Reference

JointLimitExceededEventArgs Class
VisualComponents.Create3D Namespace


JointLimitExceededEventArgs.Joint Property

JointLimitExceededEventArgsJoint Property

Gets the joint that exceeded the limit.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IJoint Joint { get; }
public:
property IJoint^ Joint {
    IJoint^ get ();
}

Property Value

Type: IJoint
See Also

Reference

JointLimitExceededEventArgs Class
VisualComponents.Create3D Namespace


JointLimitExceededEventArgs.LimitValue Property

JointLimitExceededEventArgsLimitValue Property

Gets the limit value of the failed test.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double LimitValue { get; }
public:
property double LimitValue {
    double get ();
}

Property Value

Type: Double
See Also

Reference

JointLimitExceededEventArgs Class
VisualComponents.Create3D Namespace


JointLimitExceededEventArgs.Value Property

JointLimitExceededEventArgsValue Property

Gets the value of the failed test.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Value { get; }
public:
property double Value {
    double get ();
}

Property Value

Type: Double
See Also

Reference

JointLimitExceededEventArgs Class
VisualComponents.Create3D Namespace


JointLimitExceededEventArgs Methods

The JointLimitExceededEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

JointLimitExceededEventArgs Class
VisualComponents.Create3D Namespace


JointLimitSettingChangedEventArgs Class

Contains event data for JointLimitSettingChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DJointLimitSettingChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class JointLimitSettingChangedEventArgs : EventArgs
public ref class JointLimitSettingChangedEventArgs : public EventArgs

The JointLimitSettingChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | JointLimitSettingChangedEventArgs | Initializes a new instance of JointLimitExceededEventArgs.
Public method | JointLimitSettingChangedEventArgs(Boolean, String) | Initializes a new instance of JointLimitExceededEventArgs.
Top
Properties
 | Name | Description
Public property | SettingName | Gets the name of the changed setting.
Public property | Value | Gets the new value of the changed setting.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


JointLimitSettingChangedEventArgs Constructor

Overload List
 | Name | Description
Public method | JointLimitSettingChangedEventArgs | Initializes a new instance of JointLimitExceededEventArgs.
Public method | JointLimitSettingChangedEventArgs(Boolean, String) | Initializes a new instance of JointLimitExceededEventArgs.
Top
See Also

Reference

JointLimitSettingChangedEventArgs Class
VisualComponents.Create3D Namespace


JointLimitSettingChangedEventArgs Constructor

Initializes a new instance of JointLimitExceededEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public JointLimitSettingChangedEventArgs()
public:
JointLimitSettingChangedEventArgs()
See Also

Reference

JointLimitSettingChangedEventArgs Class
JointLimitSettingChangedEventArgs Overload
VisualComponents.Create3D Namespace


JointLimitSettingChangedEventArgs Constructor (Boolean, String)

Initializes a new instance of JointLimitExceededEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public JointLimitSettingChangedEventArgs(
    bool value,
    string settingName
)
public:
JointLimitSettingChangedEventArgs(
    bool value,
    String^ settingName
)

Parameters

value
Type: SystemBoolean
settingName
Type: SystemString
See Also

Reference

JointLimitSettingChangedEventArgs Class
JointLimitSettingChangedEventArgs Overload
VisualComponents.Create3D Namespace


JointLimitSettingChangedEventArgs Properties

The JointLimitSettingChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | SettingName | Gets the name of the changed setting.
Public property | Value | Gets the new value of the changed setting.
Top
See Also

Reference

JointLimitSettingChangedEventArgs Class
VisualComponents.Create3D Namespace


JointLimitSettingChangedEventArgs.SettingName Property

JointLimitSettingChangedEventArgsSettingName Property

Gets the name of the changed setting.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SettingName { get; }
public:
property String^ SettingName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

JointLimitSettingChangedEventArgs Class
VisualComponents.Create3D Namespace


JointLimitSettingChangedEventArgs.Value Property

JointLimitSettingChangedEventArgsValue Property

Gets the new value of the changed setting.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Value { get; }
public:
property bool Value {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

JointLimitSettingChangedEventArgs Class
VisualComponents.Create3D Namespace


JointLimitSettingChangedEventArgs Methods

The JointLimitSettingChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

JointLimitSettingChangedEventArgs Class
VisualComponents.Create3D Namespace


JointLimitTests Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[FlagsAttribute]
public enum JointLimitTests
[FlagsAttribute]
public enum class JointLimitTests
Members
Member name | Value | Description
None | 0 |
Value | 1 |
Speed | 2 |
Acceleration | 4 |
Singularity | 8 |
See Also

Reference

VisualComponents.Create3D Namespace


JointLimitTestSettings Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[FlagsAttribute]
public enum JointLimitTestSettings
[FlagsAttribute]
public enum class JointLimitTestSettings
Members
Member name | Value | Description
None | 0 |
NodeHighlight | 1 |
StopAtLimit | 2 |
MessagePanelOutput | 4 |
See Also

Reference

VisualComponents.Create3D Namespace


JointRemovedEventArgs Class

Joint removed event args JointRemoved
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DJointRemovedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class JointRemovedEventArgs : EventArgs
public ref class JointRemovedEventArgs : public EventArgs

The JointRemovedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | JointRemovedEventArgs | Constructor
Top
Properties
 | Name | Description
Public property | Joint | Removed joint
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


JointRemovedEventArgs Constructor

Constructor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public JointRemovedEventArgs(
    IJoint joint
)
public:
JointRemovedEventArgs(
    IJoint^ joint
)

Parameters

joint
Type: VisualComponents.Create3DIJoint
Joint removed from controller
See Also

Reference

JointRemovedEventArgs Class
VisualComponents.Create3D Namespace


JointRemovedEventArgs Properties

The JointRemovedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Joint | Removed joint
Top
See Also

Reference

JointRemovedEventArgs Class
VisualComponents.Create3D Namespace


JointRemovedEventArgs.Joint Property

JointRemovedEventArgsJoint Property

Removed joint

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IJoint Joint { get; }
public:
property IJoint^ Joint {
    IJoint^ get ();
}

Property Value

Type: IJoint
See Also

Reference

JointRemovedEventArgs Class
VisualComponents.Create3D Namespace


JointRemovedEventArgs Methods

The JointRemovedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

JointRemovedEventArgs Class
VisualComponents.Create3D Namespace


JointTurnMode Enumeration

Defines joint turn changes during linear interpolation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum JointTurnMode
public enum class JointTurnMode
Members
Member name | Value | Description
NearestWithinLimits | 0 | Finds turn count that matched the joint limits.
Nearest | 1 | Finds turn count that is closest to the previous turn count.
Zero | 2 | Keeps turn count at zero.
Fixed | 3 | Tries to maintain turn counts.
See Also

Reference

VisualComponents.Create3D Namespace


JointType Enumeration

Joint type enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum JointType
public enum class JointType
Members
Member name | Value | Description
Fixed | 0 | Joint does not move.
Rotational | 1 | Joint rotates around an axis.
Translational | 2 | Joint slides along an axis.
RotationalFollower | 3 | Joint rotates around an axis following another joint.
TranslationalFollower | 4 | Joint slides along an axis following another joint.
Custom | 5 | Joint implements custom transform.
Dummy | 6 | Joint has no simulation representation.
See Also

Reference

VisualComponents.Create3D Namespace


JT Enumeration

JT -> Up to v10.0

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum JT
public enum class JT
Members
Member name | Value | Description
JT | 0 |
See Also

Reference

VisualComponents.Create3D Namespace


LanguageChangedEventArgs Class

Language changed event arguments
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DLanguageChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LanguageChangedEventArgs : EventArgs
public ref class LanguageChangedEventArgs : public EventArgs

The LanguageChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | LanguageChangedEventArgs | Initializes a new instance of the LanguageChangedEventArgs class
Top
Properties
 | Name | Description
Public property | Language |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


LanguageChangedEventArgs Constructor

Initializes a new instance of the LanguageChangedEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LanguageChangedEventArgs(
    string language
)
public:
LanguageChangedEventArgs(
    String^ language
)

Parameters

language
Type: SystemString
See Also

Reference

LanguageChangedEventArgs Class
VisualComponents.Create3D Namespace


LanguageChangedEventArgs Properties

The LanguageChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Language |
Top
See Also

Reference

LanguageChangedEventArgs Class
VisualComponents.Create3D Namespace


LanguageChangedEventArgs.Language Property

LanguageChangedEventArgsLanguage Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Language { get; }
public:
property String^ Language {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

LanguageChangedEventArgs Class
VisualComponents.Create3D Namespace


LanguageChangedEventArgs Methods

The LanguageChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LanguageChangedEventArgs Class
VisualComponents.Create3D Namespace


LayerPropertyChangedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DLayerPropertyChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LayerPropertyChangedEventArgs : EventArgs
public ref class LayerPropertyChangedEventArgs : public EventArgs

The LayerPropertyChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | LayerPropertyChangedEventArgs | Initializes a new instance of the LayerPropertyChangedEventArgs class.
Top
Properties
 | Name | Description
Public property | NewValue | Gets the new value.
Public property | PropertyName | Gets property Name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


LayerPropertyChangedEventArgs Constructor

Initializes a new instance of the LayerPropertyChangedEventArgs class.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LayerPropertyChangedEventArgs(
    string propertyName,
    bool newValue
)
public:
LayerPropertyChangedEventArgs(
    String^ propertyName,
    bool newValue
)

Parameters

propertyName
Type: SystemString
Property Name.
newValue
Type: SystemBoolean
New Value.
See Also

Reference

LayerPropertyChangedEventArgs Class
VisualComponents.Create3D Namespace


LayerPropertyChangedEventArgs Properties

The LayerPropertyChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets the new value.
Public property | PropertyName | Gets property Name.
Top
See Also

Reference

LayerPropertyChangedEventArgs Class
VisualComponents.Create3D Namespace


LayerPropertyChangedEventArgs.NewValue Property

LayerPropertyChangedEventArgsNewValue Property

Gets the new value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool NewValue { get; }
public:
property bool NewValue {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

LayerPropertyChangedEventArgs Class
VisualComponents.Create3D Namespace


LayerPropertyChangedEventArgs.PropertyName Property

LayerPropertyChangedEventArgsPropertyName Property

Gets property Name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string PropertyName { get; }
public:
property String^ PropertyName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

LayerPropertyChangedEventArgs Class
VisualComponents.Create3D Namespace


LayerPropertyChangedEventArgs Methods

The LayerPropertyChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LayerPropertyChangedEventArgs Class
VisualComponents.Create3D Namespace


LayoutClosedEventArgs Class

Represents a layout closed event arguments. It derives from the EventArgs class EventArgs.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DLayoutClosedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LayoutClosedEventArgs : EventArgs
public ref class LayoutClosedEventArgs : public EventArgs

The LayoutClosedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | LayoutClosedEventArgs | Initializes a new instance of the LayoutClosedEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


LayoutClosedEventArgs Constructor

Initializes a new instance of the LayoutClosedEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LayoutClosedEventArgs()
public:
LayoutClosedEventArgs()
See Also

Reference

LayoutClosedEventArgs Class
VisualComponents.Create3D Namespace


LayoutClosedEventArgs Methods

The LayoutClosedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LayoutClosedEventArgs Class
VisualComponents.Create3D Namespace


LayoutClosingEventArgs Class

Represents a layout closing event arguments. It derives from the EventArgs class EventArgs.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DLayoutClosingEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LayoutClosingEventArgs : EventArgs
public ref class LayoutClosingEventArgs : public EventArgs

The LayoutClosingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | LayoutClosingEventArgs | Initializes a new instance of the LayoutClosingEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


LayoutClosingEventArgs Constructor

Initializes a new instance of the LayoutClosingEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LayoutClosingEventArgs()
public:
LayoutClosingEventArgs()
See Also

Reference

LayoutClosingEventArgs Class
VisualComponents.Create3D Namespace


LayoutClosingEventArgs Methods

The LayoutClosingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LayoutClosingEventArgs Class
VisualComponents.Create3D Namespace


LayoutItemAddedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DLayoutItemAddedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LayoutItemAddedEventArgs : EventArgs
public ref class LayoutItemAddedEventArgs : public EventArgs

The LayoutItemAddedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | LayoutItemAddedEventArgs | Initializes a new instance of the LayoutItemAddedEventArgs class
Top
Properties
 | Name | Description
Public property | LayoutItem |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


LayoutItemAddedEventArgs Constructor

Initializes a new instance of the LayoutItemAddedEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LayoutItemAddedEventArgs(
    ILayoutItem layoutItem
)
public:
LayoutItemAddedEventArgs(
    ILayoutItem^ layoutItem
)

Parameters

layoutItem
Type: VisualComponents.Create3DILayoutItem
See Also

Reference

LayoutItemAddedEventArgs Class
VisualComponents.Create3D Namespace


LayoutItemAddedEventArgs Properties

The LayoutItemAddedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | LayoutItem |
Top
See Also

Reference

LayoutItemAddedEventArgs Class
VisualComponents.Create3D Namespace


LayoutItemAddedEventArgs.LayoutItem Property

LayoutItemAddedEventArgsLayoutItem Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ILayoutItem LayoutItem { get; }
public:
property ILayoutItem^ LayoutItem {
    ILayoutItem^ get ();
}

Property Value

Type: ILayoutItem
See Also

Reference

LayoutItemAddedEventArgs Class
VisualComponents.Create3D Namespace


LayoutItemAddedEventArgs Methods

The LayoutItemAddedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LayoutItemAddedEventArgs Class
VisualComponents.Create3D Namespace


LayoutItemRemovingEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DLayoutItemRemovingEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LayoutItemRemovingEventArgs : EventArgs
public ref class LayoutItemRemovingEventArgs : public EventArgs

The LayoutItemRemovingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | LayoutItemRemovingEventArgs | Initializes a new instance of the LayoutItemRemovingEventArgs class
Top
Properties
 | Name | Description
Public property | LayoutItem |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


LayoutItemRemovingEventArgs Constructor

Initializes a new instance of the LayoutItemRemovingEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LayoutItemRemovingEventArgs(
    ILayoutItem layoutItem
)
public:
LayoutItemRemovingEventArgs(
    ILayoutItem^ layoutItem
)

Parameters

layoutItem
Type: VisualComponents.Create3DILayoutItem
See Also

Reference

LayoutItemRemovingEventArgs Class
VisualComponents.Create3D Namespace


LayoutItemRemovingEventArgs Properties

The LayoutItemRemovingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | LayoutItem |
Top
See Also

Reference

LayoutItemRemovingEventArgs Class
VisualComponents.Create3D Namespace


LayoutItemRemovingEventArgs.LayoutItem Property

LayoutItemRemovingEventArgsLayoutItem Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ILayoutItem LayoutItem { get; }
public:
property ILayoutItem^ LayoutItem {
    ILayoutItem^ get ();
}

Property Value

Type: ILayoutItem
See Also

Reference

LayoutItemRemovingEventArgs Class
VisualComponents.Create3D Namespace


LayoutItemRemovingEventArgs Methods

The LayoutItemRemovingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LayoutItemRemovingEventArgs Class
VisualComponents.Create3D Namespace


LayoutLoadedEventArgs Class

Represents layout loading event arguments. It derives from the EventArgs class EventArgs
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DLayoutLoadedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LayoutLoadedEventArgs : EventArgs
public ref class LayoutLoadedEventArgs : public EventArgs

The LayoutLoadedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | LayoutLoadedEventArgs | Initializes a new instance of the layout loading EventArgs with a given Uri and an array of ISimComponent parameters.
Top
Properties
 | Name | Description
Public property | Components | Gets the list of loaded components ISimComponent.
Public property | Uri | Gets the Uri of the loaded layout.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


LayoutLoadedEventArgs Constructor

Initializes a new instance of the layout loading EventArgs with a given Uri and an array of ISimComponent parameters.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LayoutLoadedEventArgs(
    Uri uri,
    ISimComponent[] components
)
public:
LayoutLoadedEventArgs(
    Uri^ uri,
    array<ISimComponent^>^ components
)

Parameters

uri
Type: SystemUri
Indicates Uri
components
Type: VisualComponents.Create3DISimComponent
Indicates an array of ISimComponent
See Also

Reference

LayoutLoadedEventArgs Class
VisualComponents.Create3D Namespace


LayoutLoadedEventArgs Properties

The LayoutLoadedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Components | Gets the list of loaded components ISimComponent.
Public property | Uri | Gets the Uri of the loaded layout.
Top
See Also

Reference

LayoutLoadedEventArgs Class
VisualComponents.Create3D Namespace


LayoutLoadedEventArgs.Components Property

LayoutLoadedEventArgsComponents Property

Gets the list of loaded components ISimComponent.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<ISimComponent> Components { get; }
public:
property ReadOnlyCollection<ISimComponent^>^ Components {
    ReadOnlyCollection<ISimComponent^>^ get ();
}

Property Value

Type: ReadOnlyCollectionISimComponent
See Also

Reference

LayoutLoadedEventArgs Class
VisualComponents.Create3D Namespace


LayoutLoadedEventArgs.Uri Property

LayoutLoadedEventArgsUri Property

Gets the Uri of the loaded layout.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Uri Uri { get; }
public:
property Uri^ Uri {
    Uri^ get ();
}

Property Value

Type: Uri
See Also

Reference

LayoutLoadedEventArgs Class
VisualComponents.Create3D Namespace


LayoutLoadedEventArgs Methods

The LayoutLoadedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LayoutLoadedEventArgs Class
VisualComponents.Create3D Namespace


LayoutLoadingEventArgs Class

Represents layout loading event arguments. It derives from the EventArgs class EventArgs
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DLayoutLoadingEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LayoutLoadingEventArgs : EventArgs
public ref class LayoutLoadingEventArgs : public EventArgs

The LayoutLoadingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | LayoutLoadingEventArgs | Initializes a new instance of the layout loading EventArgs with a given uri
Top
Properties
 | Name | Description
Public property | Uri | Gets the Uri where the layout was loaded from
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


LayoutLoadingEventArgs Constructor

Initializes a new instance of the layout loading EventArgs with a given uri

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LayoutLoadingEventArgs(
    Uri uri
)
public:
LayoutLoadingEventArgs(
    Uri^ uri
)

Parameters

uri
Type: SystemUri
Indicates the Uri
See Also

Reference

LayoutLoadingEventArgs Class
VisualComponents.Create3D Namespace


LayoutLoadingEventArgs Properties

The LayoutLoadingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Uri | Gets the Uri where the layout was loaded from
Top
See Also

Reference

LayoutLoadingEventArgs Class
VisualComponents.Create3D Namespace


LayoutLoadingEventArgs.Uri Property

LayoutLoadingEventArgsUri Property

Gets the Uri where the layout was loaded from

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Uri Uri { get; }
public:
property Uri^ Uri {
    Uri^ get ();
}

Property Value

Type: Uri
See Also

Reference

LayoutLoadingEventArgs Class
VisualComponents.Create3D Namespace


LayoutLoadingEventArgs Methods

The LayoutLoadingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LayoutLoadingEventArgs Class
VisualComponents.Create3D Namespace


LayoutModifiedChangedEventArgs Class

Represents LayoutModified value changed event arguments. It derives from the EventArgs class EventArgs.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DLayoutModifiedChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LayoutModifiedChangedEventArgs : EventArgs
public ref class LayoutModifiedChangedEventArgs : public EventArgs

The LayoutModifiedChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | LayoutModifiedChangedEventArgs | Initializes a new instance of the LayoutModified value changed EventArgs with a Boolean parameters.
Top
Properties
 | Name | Description
Public property | NewValue | Gets a Boolean value, true or false, which indicates the new value of LayoutModified.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


LayoutModifiedChangedEventArgs Constructor

Initializes a new instance of the LayoutModified value changed EventArgs with a Boolean parameters.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LayoutModifiedChangedEventArgs(
    bool newValue
)
public:
LayoutModifiedChangedEventArgs(
    bool newValue
)

Parameters

newValue
Type: SystemBoolean
See Also

Reference

LayoutModifiedChangedEventArgs Class
VisualComponents.Create3D Namespace


LayoutModifiedChangedEventArgs Properties

The LayoutModifiedChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets a Boolean value, true or false, which indicates the new value of LayoutModified.
Top
See Also

Reference

LayoutModifiedChangedEventArgs Class
VisualComponents.Create3D Namespace


LayoutModifiedChangedEventArgs.NewValue Property

LayoutModifiedChangedEventArgsNewValue Property

Gets a Boolean value, true or false, which indicates the new value of LayoutModified.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool NewValue { get; protected set; }
public:
property bool NewValue {
    bool get ();
    protected: void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LayoutModifiedChangedEventArgs Class
VisualComponents.Create3D Namespace


LayoutModifiedChangedEventArgs Methods

The LayoutModifiedChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LayoutModifiedChangedEventArgs Class
VisualComponents.Create3D Namespace


LayoutSavedEventArgs Class

Represents a saved layout event arguments. It derives from the EventArgs class EventArgs.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DLayoutSavedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LayoutSavedEventArgs : EventArgs
public ref class LayoutSavedEventArgs : public EventArgs

The LayoutSavedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | LayoutSavedEventArgs | Initializes a new instance of the saved layout EventArgs with a given Uri and Boolean parameters.
Top
Properties
 | Name | Description
Public property | Succeeded | Gets a Boolean value, true or false, which indicates if the layout was succesfully saved.
Public property | Uri | Gets the Uri where the layout was saved.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


LayoutSavedEventArgs Constructor

Initializes a new instance of the saved layout EventArgs with a given Uri and Boolean parameters.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LayoutSavedEventArgs(
    Uri uri,
    bool succeeded
)
public:
LayoutSavedEventArgs(
    Uri^ uri,
    bool succeeded
)

Parameters

uri
Type: SystemUri
Uri
succeeded
Type: SystemBoolean
See Also

Reference

LayoutSavedEventArgs Class
VisualComponents.Create3D Namespace


LayoutSavedEventArgs Properties

The LayoutSavedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Succeeded | Gets a Boolean value, true or false, which indicates if the layout was succesfully saved.
Public property | Uri | Gets the Uri where the layout was saved.
Top
See Also

Reference

LayoutSavedEventArgs Class
VisualComponents.Create3D Namespace


LayoutSavedEventArgs.Succeeded Property

LayoutSavedEventArgsSucceeded Property

Gets a Boolean value, true or false, which indicates if the layout was succesfully saved.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Succeeded { get; protected set; }
public:
property bool Succeeded {
    bool get ();
    protected: void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LayoutSavedEventArgs Class
VisualComponents.Create3D Namespace


LayoutSavedEventArgs.Uri Property

LayoutSavedEventArgsUri Property

Gets the Uri where the layout was saved.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Uri Uri { get; protected set; }
public:
property Uri^ Uri {
    Uri^ get ();
    protected: void set (Uri^ value);
}

Property Value

Type: Uri
See Also

Reference

LayoutSavedEventArgs Class
VisualComponents.Create3D Namespace


LayoutSavedEventArgs Methods

The LayoutSavedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LayoutSavedEventArgs Class
VisualComponents.Create3D Namespace


LayoutSavingEventArgs Class

Represents a layout saving event arguments. It derives from the EventArgs class EventArgs.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DLayoutSavingEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LayoutSavingEventArgs : EventArgs
public ref class LayoutSavingEventArgs : public EventArgs

The LayoutSavingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | LayoutSavingEventArgs | Initializes a new instance of the saving layout EventArgs with a given Uri
Top
Properties
 | Name | Description
Public property | Uri | Gets the Uri where the layout is being saved
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


LayoutSavingEventArgs Constructor

Initializes a new instance of the saving layout EventArgs with a given Uri

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LayoutSavingEventArgs(
    Uri uri
)
public:
LayoutSavingEventArgs(
    Uri^ uri
)

Parameters

uri
Type: SystemUri
Indicates the Uri
See Also

Reference

LayoutSavingEventArgs Class
VisualComponents.Create3D Namespace


LayoutSavingEventArgs Properties

The LayoutSavingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Uri | Gets the Uri where the layout is being saved
Top
See Also

Reference

LayoutSavingEventArgs Class
VisualComponents.Create3D Namespace


LayoutSavingEventArgs.Uri Property

LayoutSavingEventArgsUri Property

Gets the Uri where the layout is being saved

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Uri Uri { get; }
public:
property Uri^ Uri {
    Uri^ get ();
}

Property Value

Type: Uri
See Also

Reference

LayoutSavingEventArgs Class
VisualComponents.Create3D Namespace


LayoutSavingEventArgs Methods

The LayoutSavingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LayoutSavingEventArgs Class
VisualComponents.Create3D Namespace


LayoutSize Structure

Row and column counts of the layout.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct LayoutSize : IEquatable<LayoutSize>
public value class LayoutSize : IEquatable<LayoutSize>

The LayoutSize type exposes the following members.

Constructors
 | Name | Description
Public method | LayoutSize | Constructor
Top
Properties
 | Name | Description
Public property | Column | Column count.
Public property | Row | Row count.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Equality comparison. (Overrides ValueTypeEquals(Object).)
Public method | Equals(LayoutSize) | Equality comparison.
Public method | GetHashCode | Hash code calculation. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Equality | Equality comparison operator.
Inequality | Equality comparison operator.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


LayoutSize Constructor

Constructor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LayoutSize(
    int col,
    int row
)
public:
LayoutSize(
    int col,
    int row
)

Parameters

col
Type: SystemInt32
row
Type: SystemInt32
See Also

Reference

LayoutSize Structure
VisualComponents.Create3D Namespace


LayoutSize Properties

The LayoutSize type exposes the following members.

Properties
 | Name | Description
Public property | Column | Column count.
Public property | Row | Row count.
Top
See Also

Reference

LayoutSize Structure
VisualComponents.Create3D Namespace


LayoutSize.Column Property

LayoutSizeColumn Property

Column count.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Column { get; set; }
public:
property int Column {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

LayoutSize Structure
VisualComponents.Create3D Namespace


LayoutSize.Row Property

LayoutSizeRow Property

Row count.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Row { get; set; }
public:
property int Row {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

LayoutSize Structure
VisualComponents.Create3D Namespace


LayoutSize Methods

The LayoutSize type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Equality comparison. (Overrides ValueTypeEquals(Object).)
Public method | Equals(LayoutSize) | Equality comparison.
Public method | GetHashCode | Hash code calculation. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LayoutSize Structure
VisualComponents.Create3D Namespace


LayoutSize.Equals Method

LayoutSizeEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Equality comparison. (Overrides ValueTypeEquals(Object).)
Public method | Equals(LayoutSize) | Equality comparison.
Top
See Also

Reference

LayoutSize Structure
VisualComponents.Create3D Namespace


LayoutSize.Equals Method (Object)

LayoutSizeEquals Method (Object)

Equality comparison.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.LayoutSize.Equals(System.Object)"]

See Also

Reference

LayoutSize Structure
Equals Overload
VisualComponents.Create3D Namespace


LayoutSize.Equals Method (LayoutSize)

LayoutSizeEquals Method (LayoutSize)

Equality comparison.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    LayoutSize other
)
public:
virtual bool Equals(
    LayoutSize other
) sealed

Parameters

other
Type: VisualComponents.Create3DLayoutSize

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.LayoutSize.Equals(VisualComponents.Create3D.LayoutSize)"]

Implements

IEquatableTEquals(T)
See Also

Reference

LayoutSize Structure
Equals Overload
VisualComponents.Create3D Namespace


LayoutSize.GetHashCode Method

LayoutSizeGetHashCode Method

Hash code calculation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.LayoutSize.GetHashCode"]

See Also

Reference

LayoutSize Structure
VisualComponents.Create3D Namespace


LayoutSize Operators

The LayoutSize type exposes the following members.

Operators
Name | Description
Equality | Equality comparison operator.
Inequality | Equality comparison operator.
Top
See Also

Reference

LayoutSize Structure
VisualComponents.Create3D Namespace


LayoutSize.Equality Operator

LayoutSizeEquality Operator

Equality comparison operator.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    LayoutSize layoutSize1,
    LayoutSize layoutSize2
)
public:
static bool operator ==(
    LayoutSize layoutSize1,
    LayoutSize layoutSize2
)

Parameters

layoutSize1
Type: VisualComponents.Create3DLayoutSize
layoutSize2
Type: VisualComponents.Create3DLayoutSize

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.LayoutSize.op_Equality(VisualComponents.Create3D.LayoutSize,VisualComponents.Create3D.LayoutSize)"]

See Also

Reference

LayoutSize Structure
VisualComponents.Create3D Namespace


LayoutSize.Inequality Operator

LayoutSizeInequality Operator

Equality comparison operator.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    LayoutSize layoutSize1,
    LayoutSize layoutSize2
)
public:
static bool operator !=(
    LayoutSize layoutSize1,
    LayoutSize layoutSize2
)

Parameters

layoutSize1
Type: VisualComponents.Create3DLayoutSize
layoutSize2
Type: VisualComponents.Create3DLayoutSize

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.LayoutSize.op_Inequality(VisualComponents.Create3D.LayoutSize,VisualComponents.Create3D.LayoutSize)"]

See Also

Reference

LayoutSize Structure
VisualComponents.Create3D Namespace


LicenseCheckFailedEventArgs Class

License check failure event argument class.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DLicenseCheckFailedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LicenseCheckFailedEventArgs : EventArgs
public ref class LicenseCheckFailedEventArgs : public EventArgs

The LicenseCheckFailedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | LicenseCheckFailedEventArgs | Initializing constructor.
Top
Properties
 | Name | Description
Public property | DelinquentFeatures | List of features where the license check is failing.
Public property | GraceTimeSecondsLeft | How many seconds are left of the license check failure grace time.
Public property | IsCountdownAbortRequested | Set this in the handler to cancel any further countdown notices or reconnection attempts.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


LicenseCheckFailedEventArgs Constructor

Initializing constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LicenseCheckFailedEventArgs(
    int graceTimeSecondsLeft,
    IList<LicensingServiceFeature> delinquentFeatures
)
public:
LicenseCheckFailedEventArgs(
    int graceTimeSecondsLeft,
    IList<LicensingServiceFeature>^ delinquentFeatures
)

Parameters

graceTimeSecondsLeft
Type: SystemInt32
Grace time left.
delinquentFeatures
Type: System.Collections.GenericIListLicensingServiceFeature
Features where the check is failing.
See Also

Reference

LicenseCheckFailedEventArgs Class
VisualComponents.Create3D Namespace


LicenseCheckFailedEventArgs Properties

The LicenseCheckFailedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | DelinquentFeatures | List of features where the license check is failing.
Public property | GraceTimeSecondsLeft | How many seconds are left of the license check failure grace time.
Public property | IsCountdownAbortRequested | Set this in the handler to cancel any further countdown notices or reconnection attempts.
Top
See Also

Reference

LicenseCheckFailedEventArgs Class
VisualComponents.Create3D Namespace


LicenseCheckFailedEventArgs.DelinquentFeatures Property

LicenseCheckFailedEventArgsDelinquentFeatures Property

List of features where the license check is failing.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList<LicensingServiceFeature> DelinquentFeatures { get; }
public:
property IList<LicensingServiceFeature>^ DelinquentFeatures {
    IList<LicensingServiceFeature>^ get ();
}

Property Value

Type: IListLicensingServiceFeature
See Also

Reference

LicenseCheckFailedEventArgs Class
VisualComponents.Create3D Namespace


LicenseCheckFailedEventArgs.GraceTimeSecondsLeft Property

LicenseCheckFailedEventArgsGraceTimeSecondsLeft Property

How many seconds are left of the license check failure grace time.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int GraceTimeSecondsLeft { get; }
public:
property int GraceTimeSecondsLeft {
    int get ();
}

Property Value

Type: Int32
Remarks

When this number reaches zero, the application will exit.

See Also

Reference

LicenseCheckFailedEventArgs Class
VisualComponents.Create3D Namespace


LicenseCheckFailedEventArgs.IsCountdownAbortRequested Property

LicenseCheckFailedEventArgsIsCountdownAbortRequested Property

Set this in the handler to cancel any further countdown notices or reconnection attempts.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsCountdownAbortRequested { get; set; }
public:
property bool IsCountdownAbortRequested {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LicenseCheckFailedEventArgs Class
VisualComponents.Create3D Namespace


LicenseCheckFailedEventArgs Methods

The LicenseCheckFailedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LicenseCheckFailedEventArgs Class
VisualComponents.Create3D Namespace


LicenseCheckingCatalog Class

Composition catalog that only allows parts with correct license.
Inheritance Hierarchy
SystemObject
System.ComponentModel.Composition.PrimitivesComposablePartCatalog
VisualComponents.Create3DLicenseCheckingCatalog

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class LicenseCheckingCatalog : ComposablePartCatalog,
    ICompositionElement
public ref class LicenseCheckingCatalog sealed : public ComposablePartCatalog,
    ICompositionElement

The LicenseCheckingCatalog type exposes the following members.

Constructors
 | Name | Description
Public method | LicenseCheckingCatalog | Initializing constructor.
Top
Properties
 | Name | Description
Public property | Parts | Exported parts, filtered by licensing status. (Overrides ComposablePartCatalog.Parts.)
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ComposablePartCatalog. (Inherited from ComposablePartCatalog.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Get an enumerator to all licensed parts. (Overrides ComposablePartCatalogGetEnumerator.)
Public method | GetExports | Get all matching exports that are licensed. (Overrides ComposablePartCatalogGetExports(ImportDefinition).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks
This class prevents non-licensed parts from being created and crashing the software because of the missing license.
See Also

Reference

VisualComponents.Create3D Namespace


LicenseCheckingCatalog Constructor

Initializing constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LicenseCheckingCatalog(
    ComposablePartCatalog source,
    Func<ILicensingService> getLicensingService
)
public:
LicenseCheckingCatalog(
    ComposablePartCatalog^ source,
    Func<ILicensingService^>^ getLicensingService
)

Parameters

source
Type: System.ComponentModel.Composition.PrimitivesComposablePartCatalog
Source catalog to filter.
getLicensingService
Type: SystemFuncILicensingService
Licensing service instance getter. If you implement this using MEF, remember to add recursion detection to avoid overflowing the stack. In that case, the method should return null. Also, don't add any licensing restriction metadata to the licensing service implementation.
See Also

Reference

LicenseCheckingCatalog Class
VisualComponents.Create3D Namespace


LicenseCheckingCatalog Properties

The LicenseCheckingCatalog type exposes the following members.

Properties
 | Name | Description
Public property | Parts | Exported parts, filtered by licensing status. (Overrides ComposablePartCatalog.Parts.)
Top
See Also

Reference

LicenseCheckingCatalog Class
VisualComponents.Create3D Namespace


LicenseCheckingCatalog.Parts Property

LicenseCheckingCatalogParts Property

Exported parts, filtered by licensing status.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override IQueryable<ComposablePartDefinition> Parts { get; }
public:
virtual property IQueryable<ComposablePartDefinition^>^ Parts {
    IQueryable<ComposablePartDefinition^>^ get () override;
}

Property Value

Type: IQueryableComposablePartDefinition
See Also

Reference

LicenseCheckingCatalog Class
VisualComponents.Create3D Namespace


LicenseCheckingCatalog Methods

The LicenseCheckingCatalog type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ComposablePartCatalog. (Inherited from ComposablePartCatalog.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Get an enumerator to all licensed parts. (Overrides ComposablePartCatalogGetEnumerator.)
Public method | GetExports | Get all matching exports that are licensed. (Overrides ComposablePartCatalogGetExports(ImportDefinition).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LicenseCheckingCatalog Class
VisualComponents.Create3D Namespace


LicenseCheckingCatalog.GetEnumerator Method

LicenseCheckingCatalogGetEnumerator Method

Get an enumerator to all licensed parts.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override IEnumerator<ComposablePartDefinition> GetEnumerator()
public:
virtual IEnumerator<ComposablePartDefinition^>^ GetEnumerator() override

Return Value

Type: IEnumeratorComposablePartDefinition

[Missing <returns> documentation for "M:VisualComponents.Create3D.LicenseCheckingCatalog.GetEnumerator"]

Implements

IEnumerableTGetEnumerator
See Also

Reference

LicenseCheckingCatalog Class
VisualComponents.Create3D Namespace


LicenseCheckingCatalog.GetExports Method

LicenseCheckingCatalogGetExports Method

Get all matching exports that are licensed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override IEnumerable<Tuple<ComposablePartDefinition, ExportDefinition>> GetExports(
    ImportDefinition definition
)
public:
virtual IEnumerable<Tuple<ComposablePartDefinition^, ExportDefinition^>^>^ GetExports(
    ImportDefinition^ definition
) override

Parameters

definition
Type: System.ComponentModel.Composition.PrimitivesImportDefinition

Return Value

Type: IEnumerableTupleComposablePartDefinition, ExportDefinition

[Missing <returns> documentation for "M:VisualComponents.Create3D.LicenseCheckingCatalog.GetExports(System.ComponentModel.Composition.Primitives.ImportDefinition)"]

See Also

Reference

LicenseCheckingCatalog Class
VisualComponents.Create3D Namespace


LicenseFeatures Class

License features utility class.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DLicenseFeatures

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LicenseFeatures
public ref class LicenseFeatures

The LicenseFeatures type exposes the following members.

Constructors
 | Name | Description
Public method | LicenseFeatures | Initializes a new instance of the LicenseFeatures class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetConfiguredFeatures | This method used to get list of features the application is configured.
 | GetEnabledFeatures | Get enabled features
 | GetFeatureName | Get feature name for given feature flag.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetProductFeature | Get product feature for flag.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsLicenseMetadataRestrictive(Object) | Test whether license metadata imposes license restrictions.
 | IsLicenseMetadataRestrictive(ILicenseMetadata) | Test whether license metadata imposes license restrictions.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TestLicenseMetadata(Object, IProductConfiguration) | Test if required features is compatible with license configuration.
 | TestLicenseMetadata(ILicenseMetadata, IProductConfiguration) | Test if license metadata is compatible with license configuration.
 | TestProductFeature | Test if specified features are all defined in license configuration.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
CurrentVersion | Current feature version string.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks

This class defines constants for use when defining RequireLicense export metadata for product features.

See Also

Reference

VisualComponents.Create3D Namespace


LicenseFeatures Constructor

Initializes a new instance of the LicenseFeatures class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LicenseFeatures()
public:
LicenseFeatures()
See Also

Reference

LicenseFeatures Class
VisualComponents.Create3D Namespace


LicenseFeatures Methods

The LicenseFeatures type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetConfiguredFeatures | This method used to get list of features the application is configured.
 | GetEnabledFeatures | Get enabled features
 | GetFeatureName | Get feature name for given feature flag.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetProductFeature | Get product feature for flag.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsLicenseMetadataRestrictive(Object) | Test whether license metadata imposes license restrictions.
 | IsLicenseMetadataRestrictive(ILicenseMetadata) | Test whether license metadata imposes license restrictions.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TestLicenseMetadata(Object, IProductConfiguration) | Test if required features is compatible with license configuration.
 | TestLicenseMetadata(ILicenseMetadata, IProductConfiguration) | Test if license metadata is compatible with license configuration.
 | TestProductFeature | Test if specified features are all defined in license configuration.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LicenseFeatures Class
VisualComponents.Create3D Namespace


LicenseFeatures.GetConfiguredFeatures Method

LicenseFeaturesGetConfiguredFeatures Method

This method used to get list of features the application is configured.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ISet<ProductFeature> GetConfiguredFeatures(
    IProductConfiguration productConfiguration
)
public:
static ISet<ProductFeature>^ GetConfiguredFeatures(
    IProductConfiguration^ productConfiguration
)

Parameters

productConfiguration
Type: VisualComponents.Create3DIProductConfiguration
Product configuration object

Return Value

Type: ISetProductFeature
Returns a list of main and addon features that are defined in configuration file.
See Also

Reference

LicenseFeatures Class
VisualComponents.Create3D Namespace


LicenseFeatures.GetEnabledFeatures Method

LicenseFeaturesGetEnabledFeatures Method

Get enabled features

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ISet<ProductFeature> GetEnabledFeatures(
    IProductConfiguration productConfiguration
)
public:
static ISet<ProductFeature>^ GetEnabledFeatures(
    IProductConfiguration^ productConfiguration
)

Parameters

productConfiguration
Type: VisualComponents.Create3DIProductConfiguration

Return Value

Type: ISetProductFeature

[Missing <returns> documentation for "M:VisualComponents.Create3D.LicenseFeatures.GetEnabledFeatures(VisualComponents.Create3D.IProductConfiguration)"]

See Also

Reference

LicenseFeatures Class
VisualComponents.Create3D Namespace


LicenseFeatures.GetFeatureName Method

LicenseFeaturesGetFeatureName Method

Get feature name for given feature flag.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetFeatureName(
    LicenseFeaturesFeatures feature
)
public:
static String^ GetFeatureName(
    LicenseFeaturesFeatures feature
)

Parameters

feature
Type: VisualComponents.Create3DLicenseFeaturesFeatures
Single feature flag

Return Value

Type: String
Feature name
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if featureFlag contains an unknown flag, or more than one flag.
See Also

Reference

LicenseFeatures Class
VisualComponents.Create3D Namespace


LicenseFeatures.GetProductFeature Method

LicenseFeaturesGetProductFeature Method

Get product feature for flag.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ProductFeature GetProductFeature(
    LicenseFeaturesFeatures feature
)
public:
static ProductFeature GetProductFeature(
    LicenseFeaturesFeatures feature
)

Parameters

feature
Type: VisualComponents.Create3DLicenseFeaturesFeatures
Single feature flag.

Return Value

Type: ProductFeature
Product feature object set to the specified feature and the current version string.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if featureFlag contains an unknown flag, or more than one flag.
See Also

Reference

LicenseFeatures Class
VisualComponents.Create3D Namespace


LicenseFeatures.IsLicenseMetadataRestrictive Method

LicenseFeaturesIsLicenseMetadataRestrictive Method

Overload List
Name | Description
IsLicenseMetadataRestrictive(Object) | Test whether license metadata imposes license restrictions.
IsLicenseMetadataRestrictive(ILicenseMetadata) | Test whether license metadata imposes license restrictions.
Top
See Also

Reference

LicenseFeatures Class
VisualComponents.Create3D Namespace


LicenseFeatures.IsLicenseMetadataRestrictive Method (Object)

LicenseFeaturesIsLicenseMetadataRestrictive Method (Object)

Test whether license metadata imposes license restrictions.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsLicenseMetadataRestrictive(
    Object requiredFeatures
)
public:
static bool IsLicenseMetadataRestrictive(
    Object^ requiredFeatures
)

Parameters

requiredFeatures
Type: SystemObject
Required features object to test

Return Value

Type: Boolean
True if metadata is not null, and has license restrictions.
See Also

Reference

LicenseFeatures Class
IsLicenseMetadataRestrictive Overload
VisualComponents.Create3D Namespace


LicenseFeatures.IsLicenseMetadataRestrictive Method (ILicenseMetadata)

LicenseFeaturesIsLicenseMetadataRestrictive Method (ILicenseMetadata)

Test whether license metadata imposes license restrictions.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsLicenseMetadataRestrictive(
    ILicenseMetadata metadata
)
public:
static bool IsLicenseMetadataRestrictive(
    ILicenseMetadata^ metadata
)

Parameters

metadata
Type: VisualComponents.Create3DILicenseMetadata
Metadata object to test

Return Value

Type: Boolean
True if metadata is not null, and has license restrictions.
See Also

Reference

LicenseFeatures Class
IsLicenseMetadataRestrictive Overload
VisualComponents.Create3D Namespace


LicenseFeatures.TestLicenseMetadata Method

LicenseFeaturesTestLicenseMetadata Method

Overload List
Name | Description
TestLicenseMetadata(Object, IProductConfiguration) | Test if required features is compatible with license configuration.
TestLicenseMetadata(ILicenseMetadata, IProductConfiguration) | Test if license metadata is compatible with license configuration.
Top
See Also

Reference

LicenseFeatures Class
VisualComponents.Create3D Namespace


LicenseFeatures.TestLicenseMetadata Method (Object, IProductConfiguration)

LicenseFeaturesTestLicenseMetadata Method (Object, IProductConfiguration)

Test if required features is compatible with license configuration.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool TestLicenseMetadata(
    Object requiredFeatures,
    IProductConfiguration licenseConfiguration
)
public:
static bool TestLicenseMetadata(
    Object^ requiredFeatures,
    IProductConfiguration^ licenseConfiguration
)

Parameters

requiredFeatures
Type: SystemObject
Required features specification.
licenseConfiguration
Type: VisualComponents.Create3DIProductConfiguration
Configuration to test against.

Return Value

Type: Boolean
True if the configuration supports the given metadata.
Remarks
The requiredFeatures parameter may be specified in the manner described in ILicenseMetadata.
See Also

Reference

LicenseFeatures Class
TestLicenseMetadata Overload
VisualComponents.Create3D Namespace


LicenseFeatures.TestLicenseMetadata Method (ILicenseMetadata, IProductConfiguration)

LicenseFeaturesTestLicenseMetadata Method (ILicenseMetadata, IProductConfiguration)

Test if license metadata is compatible with license configuration.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool TestLicenseMetadata(
    ILicenseMetadata metadata,
    IProductConfiguration licenseConfiguration
)
public:
static bool TestLicenseMetadata(
    ILicenseMetadata^ metadata,
    IProductConfiguration^ licenseConfiguration
)

Parameters

metadata
Type: VisualComponents.Create3DILicenseMetadata
License metadata to test
licenseConfiguration
Type: VisualComponents.Create3DIProductConfiguration
Configuration to test against.

Return Value

Type: Boolean
True if the configuration supports the given metadata.
See Also

Reference

LicenseFeatures Class
TestLicenseMetadata Overload
VisualComponents.Create3D Namespace


LicenseFeatures.TestProductFeature Method

LicenseFeaturesTestProductFeature Method

Test if specified features are all defined in license configuration.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool TestProductFeature(
    LicenseFeaturesFeatures features,
    IProductConfiguration licenseConfiguration
)
public:
static bool TestProductFeature(
    LicenseFeaturesFeatures features,
    IProductConfiguration^ licenseConfiguration
)

Parameters

features
Type: VisualComponents.Create3DLicenseFeaturesFeatures
Feature flag mask.
licenseConfiguration
Type: VisualComponents.Create3DIProductConfiguration
Product license configuration to test.c

Return Value

Type: Boolean
True if all specified features are defined in license configuration.
See Also

Reference

LicenseFeatures Class
VisualComponents.Create3D Namespace


LicenseFeatures Fields

The LicenseFeatures type exposes the following members.

Fields
Name | Description
CurrentVersion | Current feature version string.
Top
See Also

Reference

LicenseFeatures Class
VisualComponents.Create3D Namespace


LicenseFeatures.CurrentVersion Field

LicenseFeaturesCurrentVersion Field

Current feature version string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly string CurrentVersion
public:
static initonly String^ CurrentVersion

Field Value

Type: String
See Also

Reference

LicenseFeatures Class
VisualComponents.Create3D Namespace


LicenseFeatures.Features Enumeration

LicenseFeaturesFeatures Enumeration

License Features

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[FlagsAttribute]
public enum Features
[FlagsAttribute]
public enum class Features
Members
Member name | Value | Description
None | 0 | No features.
Configurator | 1 | Configurator base feature flag.
Robotics | 2 | Robotics execution base feature flag.
Statistics | 4 | Statistics collection base feature flag.
Communication | 8 | Controller communication base feature flag.
VideoExport | 16 | Video export base feature flag.
PdfTemplate | 32 | PDF template support base feature flag.
ModelingPack | 64 | Component modeling pack feature flag.
RoboticsPack | 128 | Robot programming pack feature flag.
HoopsImportAll | 256 | Hoops Import All pack feature flag.
HoopsImportStep | 512 | Hoops Import Step pack feature flag.
PythonCommandPack | 1024 | Python commands pack feature flag.
DotNetPluginPack | 2048 | .NET plugins pack feature flag.
AnimationStreaming | 4096 | Animation streaming feature flag.
ProcessModeling | 8192 | Process modeling UI feature flag.
PaintingPack | 16384 | Painting add-on feature flag.
AddOnKukaArcWeld | 32768 | KUKA arcwelding add-on feature flag.
BeckhoffAds | 65536 | BechoffAds add-on feature flag.
OpcUa | 131072 | OpcUa add-on feature flag.
SiemensS7 | 262144 | SiemensS7 add-on feature flag.
UniversalRobotsRtde | 524288 | UniversalRobotsRtde add-on feature flag.
WinModNet | 1048576 | WinMOD Net connection plugin feature flag.
ConnectivityVC | 2097152 | Visual Components Connectivity feature flag.
ConnectivityKuka | 4194304 | KUKA Connectivity add-on feature flag.
ModelingActionItemPack | 8388608 | Modeling ActionItems add-on feature flag.
SimitConnection | 16777216 | Simit connection plugin feature flag.
VideoExportMP4 | 33554432 | Video export to MP4 feature flag.
See Also

Reference

VisualComponents.Create3D Namespace


LicenseInfo Class

Basic license information object.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DLicenseInfo

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LicenseInfo : ILicenseInfo
public ref class LicenseInfo : ILicenseInfo

The LicenseInfo type exposes the following members.

Constructors
 | Name | Description
Public method | LicenseInfo | Initializes a new instance of the LicenseInfo class
Top
Properties
 | Name | Description
Public property | Clients | Clients currently using the license.
Public property | CommuterCodeIssuingServer | Issuing server name if this is a commuter code license.
Public property | CommuterCount | Number of commuted licenses.
Public property | Expiration | License expiration type.
Public property | ExpirationDate | License expiration date, or null for perpetual or evaluation license.
Public property | ExpirationTimeLeft | Evaluation time left, or null for non-evaluation licenses.
Public property | FeatureName | Name of licensed feature.
Public property | FeatureVersion | Version of licensed feature.
Public property | HasRenewalPeriod | Whether the license has a renewal period.
Public property | IsAvailable | Whether the license is available.
Public property | IsCommuterCode | Whether the license is a commuted license.
Public property | IsNetworkLicense | Whether the license is a floating (network) license.
Public property | IsRenewable | Whether the license can be renewed.
Public property | LicenseCount | Number of seats in a network license.
Public property | LicenseHash | Hash string for the license code.
Public property | MaintenanceEndDate | Known maintenance end date, or null if not known.
Public property | MaximumCheckOutTimeDays | Maximum limit of days to commute license at a time.
Public property | ProductKey | License product key. Only valid for standalone licenses.
Public property | ProductKeyExpiration | Product key expiration type.
Public property | ProductKeyExpirationDate | Product key expiration date, or null for no expiration.
Public property | ProductKeyLicenseType | Product key license type string.
Public property | ProductName | Product name string.
Public property | RenewalPeriodDays | Length of renewal period, or null if there is none.
Public property | StartDate | License start date.
Public property | Type | License type.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetClients | Set the contents of the client list.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


LicenseInfo Constructor

Initializes a new instance of the LicenseInfo class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LicenseInfo()
public:
LicenseInfo()
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseInfo Properties

The LicenseInfo type exposes the following members.

Properties
 | Name | Description
Public property | Clients | Clients currently using the license.
Public property | CommuterCodeIssuingServer | Issuing server name if this is a commuter code license.
Public property | CommuterCount | Number of commuted licenses.
Public property | Expiration | License expiration type.
Public property | ExpirationDate | License expiration date, or null for perpetual or evaluation license.
Public property | ExpirationTimeLeft | Evaluation time left, or null for non-evaluation licenses.
Public property | FeatureName | Name of licensed feature.
Public property | FeatureVersion | Version of licensed feature.
Public property | HasRenewalPeriod | Whether the license has a renewal period.
Public property | IsAvailable | Whether the license is available.
Public property | IsCommuterCode | Whether the license is a commuted license.
Public property | IsNetworkLicense | Whether the license is a floating (network) license.
Public property | IsRenewable | Whether the license can be renewed.
Public property | LicenseCount | Number of seats in a network license.
Public property | LicenseHash | Hash string for the license code.
Public property | MaintenanceEndDate | Known maintenance end date, or null if not known.
Public property | MaximumCheckOutTimeDays | Maximum limit of days to commute license at a time.
Public property | ProductKey | License product key. Only valid for standalone licenses.
Public property | ProductKeyExpiration | Product key expiration type.
Public property | ProductKeyExpirationDate | Product key expiration date, or null for no expiration.
Public property | ProductKeyLicenseType | Product key license type string.
Public property | ProductName | Product name string.
Public property | RenewalPeriodDays | Length of renewal period, or null if there is none.
Public property | StartDate | License start date.
Public property | Type | License type.
Top
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseInfo.Clients Property

LicenseInfoClients Property

Clients currently using the license.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList<IClientInfo> Clients { get; }
public:
virtual property IList<IClientInfo^>^ Clients {
    IList<IClientInfo^>^ get () sealed;
}

Property Value

Type: IListIClientInfo

Implements

ILicenseInfo.Clients
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseInfo.CommuterCodeIssuingServer Property

LicenseInfoCommuterCodeIssuingServer Property

Issuing server name if this is a commuter code license.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CommuterCodeIssuingServer { get; set; }
public:
virtual property String^ CommuterCodeIssuingServer {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ILicenseInfo.CommuterCodeIssuingServer
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseInfo.CommuterCount Property

LicenseInfoCommuterCount Property

Number of commuted licenses.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CommuterCount { get; set; }
public:
virtual property int CommuterCount {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

ILicenseInfo.CommuterCount
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseInfo.Expiration Property

LicenseInfoExpiration Property

License expiration type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ExpirationType Expiration { get; set; }
public:
virtual property ExpirationType Expiration {
    ExpirationType get () sealed;
    void set (ExpirationType value) sealed;
}

Property Value

Type: ExpirationType

Implements

ILicenseInfo.Expiration
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseInfo.ExpirationDate Property

LicenseInfoExpirationDate Property

License expiration date, or null for perpetual or evaluation license.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<DateTime> ExpirationDate { get; set; }
public:
virtual property Nullable<DateTime> ExpirationDate {
    Nullable<DateTime> get () sealed;
    void set (Nullable<DateTime> value) sealed;
}

Property Value

Type: NullableDateTime

Implements

ILicenseInfo.ExpirationDate
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseInfo.ExpirationTimeLeft Property

LicenseInfoExpirationTimeLeft Property

Evaluation time left, or null for non-evaluation licenses.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<TimeSpan> ExpirationTimeLeft { get; set; }
public:
virtual property Nullable<TimeSpan> ExpirationTimeLeft {
    Nullable<TimeSpan> get () sealed;
    void set (Nullable<TimeSpan> value) sealed;
}

Property Value

Type: NullableTimeSpan

Implements

ILicenseInfo.ExpirationTimeLeft
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseInfo.FeatureName Property

LicenseInfoFeatureName Property

Name of licensed feature.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string FeatureName { get; set; }
public:
virtual property String^ FeatureName {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ILicenseInfo.FeatureName
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseInfo.FeatureVersion Property

LicenseInfoFeatureVersion Property

Version of licensed feature.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string FeatureVersion { get; set; }
public:
virtual property String^ FeatureVersion {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ILicenseInfo.FeatureVersion
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseInfo.HasRenewalPeriod Property

LicenseInfoHasRenewalPeriod Property

Whether the license has a renewal period.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HasRenewalPeriod { get; set; }
public:
virtual property bool HasRenewalPeriod {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ILicenseInfo.HasRenewalPeriod
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseInfo.IsAvailable Property

LicenseInfoIsAvailable Property

Whether the license is available.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsAvailable { get; set; }
public:
virtual property bool IsAvailable {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ILicenseInfo.IsAvailable
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseInfo.IsCommuterCode Property

LicenseInfoIsCommuterCode Property

Whether the license is a commuted license.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsCommuterCode { get; set; }
public:
virtual property bool IsCommuterCode {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ILicenseInfo.IsCommuterCode
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseInfo.IsNetworkLicense Property

LicenseInfoIsNetworkLicense Property

Whether the license is a floating (network) license.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsNetworkLicense { get; set; }
public:
virtual property bool IsNetworkLicense {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ILicenseInfo.IsNetworkLicense
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseInfo.IsRenewable Property

LicenseInfoIsRenewable Property

Whether the license can be renewed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsRenewable { get; set; }
public:
virtual property bool IsRenewable {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ILicenseInfo.IsRenewable
Remarks
This is only true for licenses that have a renewal period; however, it will be false if the license is on its last renewal period.
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseInfo.LicenseCount Property

LicenseInfoLicenseCount Property

Number of seats in a network license.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int LicenseCount { get; set; }
public:
virtual property int LicenseCount {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

ILicenseInfo.LicenseCount
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseInfo.LicenseHash Property

LicenseInfoLicenseHash Property

Hash string for the license code.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string LicenseHash { get; set; }
public:
virtual property String^ LicenseHash {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ILicenseInfo.LicenseHash
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseInfo.MaintenanceEndDate Property

LicenseInfoMaintenanceEndDate Property

Known maintenance end date, or null if not known.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<DateTime> MaintenanceEndDate { get; set; }
public:
virtual property Nullable<DateTime> MaintenanceEndDate {
    Nullable<DateTime> get () sealed;
    void set (Nullable<DateTime> value) sealed;
}

Property Value

Type: NullableDateTime

Implements

ILicenseInfo.MaintenanceEndDate
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseInfo.MaximumCheckOutTimeDays Property

LicenseInfoMaximumCheckOutTimeDays Property

Maximum limit of days to commute license at a time.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int MaximumCheckOutTimeDays { get; set; }
public:
virtual property int MaximumCheckOutTimeDays {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

ILicenseInfo.MaximumCheckOutTimeDays
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseInfo.ProductKey Property

LicenseInfoProductKey Property

License product key. Only valid for standalone licenses.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ProductKey { get; set; }
public:
virtual property String^ ProductKey {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ILicenseInfo.ProductKey
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseInfo.ProductKeyExpiration Property

LicenseInfoProductKeyExpiration Property

Product key expiration type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ExpirationType ProductKeyExpiration { get; set; }
public:
virtual property ExpirationType ProductKeyExpiration {
    ExpirationType get () sealed;
    void set (ExpirationType value) sealed;
}

Property Value

Type: ExpirationType

Implements

ILicenseInfo.ProductKeyExpiration
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseInfo.ProductKeyExpirationDate Property

LicenseInfoProductKeyExpirationDate Property

Product key expiration date, or null for no expiration.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<DateTime> ProductKeyExpirationDate { get; set; }
public:
virtual property Nullable<DateTime> ProductKeyExpirationDate {
    Nullable<DateTime> get () sealed;
    void set (Nullable<DateTime> value) sealed;
}

Property Value

Type: NullableDateTime

Implements

ILicenseInfo.ProductKeyExpirationDate
Remarks
This is the last day on which the license will work.
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseInfo.ProductKeyLicenseType Property

LicenseInfoProductKeyLicenseType Property

Product key license type string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ProductKeyLicenseType { get; set; }
public:
virtual property String^ ProductKeyLicenseType {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ILicenseInfo.ProductKeyLicenseType
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseInfo.ProductName Property

LicenseInfoProductName Property

Product name string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ProductName { get; set; }
public:
virtual property String^ ProductName {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ILicenseInfo.ProductName
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseInfo.RenewalPeriodDays Property

LicenseInfoRenewalPeriodDays Property

Length of renewal period, or null if there is none.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<int> RenewalPeriodDays { get; set; }
public:
virtual property Nullable<int> RenewalPeriodDays {
    Nullable<int> get () sealed;
    void set (Nullable<int> value) sealed;
}

Property Value

Type: NullableInt32

Implements

ILicenseInfo.RenewalPeriodDays
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseInfo.StartDate Property

LicenseInfoStartDate Property

License start date.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DateTime StartDate { get; set; }
public:
virtual property DateTime StartDate {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}

Property Value

Type: DateTime

Implements

ILicenseInfo.StartDate
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseInfo.Type Property

LicenseInfoType Property

License type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LicenseType Type { get; set; }
public:
virtual property LicenseType Type {
    LicenseType get () sealed;
    void set (LicenseType value) sealed;
}

Property Value

Type: LicenseType

Implements

ILicenseInfo.Type
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseInfo Methods

The LicenseInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetClients | Set the contents of the client list.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseInfo.SetClients Method

LicenseInfoSetClients Method

Set the contents of the client list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetClients(
    IEnumerable<IClientInfo> clients
)
public:
void SetClients(
    IEnumerable<IClientInfo^>^ clients
)

Parameters

clients
Type: System.Collections.GenericIEnumerableIClientInfo
See Also

Reference

LicenseInfo Class
VisualComponents.Create3D Namespace


LicenseMetadata Class

License metadata class.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DLicenseMetadata

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LicenseMetadata : ILicenseMetadata
public ref class LicenseMetadata : ILicenseMetadata

The LicenseMetadata type exposes the following members.

Constructors
 | Name | Description
Public method | LicenseMetadata | Initializing constructor.
Public method | LicenseMetadata(LicenseFeaturesFeatures) | Initializing constructor.
Top
Properties
 | Name | Description
Public property | RequiredFeatures | Required feature
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


LicenseMetadata Constructor

Overload List
 | Name | Description
Public method | LicenseMetadata | Initializing constructor.
Public method | LicenseMetadata(LicenseFeaturesFeatures) | Initializing constructor.
Top
See Also

Reference

LicenseMetadata Class
VisualComponents.Create3D Namespace


LicenseMetadata Constructor

Initializing constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LicenseMetadata()
public:
LicenseMetadata()
See Also

Reference

LicenseMetadata Class
LicenseMetadata Overload
VisualComponents.Create3D Namespace


LicenseMetadata Constructor (LicenseFeatures.Features)

LicenseMetadata Constructor (LicenseFeaturesFeatures)

Initializing constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LicenseMetadata(
    LicenseFeaturesFeatures feature
)
public:
LicenseMetadata(
    LicenseFeaturesFeatures feature
)

Parameters

feature
Type: VisualComponents.Create3DLicenseFeaturesFeatures
License feature
See Also

Reference

LicenseMetadata Class
LicenseMetadata Overload
VisualComponents.Create3D Namespace


LicenseMetadata Properties

The LicenseMetadata type exposes the following members.

Properties
 | Name | Description
Public property | RequiredFeatures | Required feature
Top
See Also

Reference

LicenseMetadata Class
VisualComponents.Create3D Namespace


LicenseMetadata.RequiredFeatures Property

LicenseMetadataRequiredFeatures Property

Required feature

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object RequiredFeatures { get; }
public:
virtual property Object^ RequiredFeatures {
    Object^ get () sealed;
}

Property Value

Type: Object

Implements

ILicenseMetadataRequiredFeatures
See Also

Reference

LicenseMetadata Class
VisualComponents.Create3D Namespace


LicenseMetadata Methods

The LicenseMetadata type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LicenseMetadata Class
VisualComponents.Create3D Namespace


LicenseState Enumeration

State of licensing.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum LicenseState
public enum class LicenseState
Members
Member name | Value | Description
NotPresent | 0 | License is not present on the server.
PresentButNotAvailable | 1 | License is present but not available due to maximum amount of concurrent users.
PresentAndAvailable | 2 | License is present and available for use.
See Also

Reference

VisualComponents.Create3D Namespace


LicensingHelper Class

Licensing Helper for working with the main application license.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DLicensingHelper

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class LicensingHelper
public ref class LicensingHelper abstract sealed

The LicensingHelper type exposes the following members.

Properties
Name | Description
ActivatedLicenseType | Represents the activated license type
ActivationMethod | Tells how the current instance of the application is activated
ActiveProductKeyString | Return the active product key string for the product that best matches the current license configuration.
ApplicationLicenseConfiguration | Represents the main licensed product as well as any add-on modules
ConnectionStatus | Result of last connection check.
ProductKeyFromLauncherConfig | Get product key which activate the application.This key is stored in Launcher config file.
ProductKeySavedInLauncher | Get product key which activate the application.This key is stored in Launcher config file.
Top
Methods
Name | Description
CheckAndRequestLicense | Compare existing active license with requested features
CheckConnection | Check if connection to licensor is available.
CheckProductLicense | Compare existing active license with requested features
CheckSoftwareUpdate |
CompareProductKeyFeature(String, ISetProductFeature) | Compares the product key feature
CompareProductKeyFeature(String, IProductConfiguration) | Check product key features against current product configuration.
DeactivateStandaloneLicenseKey | Deactivate a given product key.
EvaluationPeriodLeft(IProductKey) | Calculate evaluation time left for product key.
EvaluationPeriodLeft(NullableDateTime, NullableTimeSpan) | Calculate evaluation period left given expiration date and evaluation time left.
GetActiveProductKey | Collects list of active standalone product keys.
GetActiveStandaloneProductKey | Return the first active standalone product key which have the same feature defined in license setting.
GetActiveStandaloneProductKey(String) | Return active standalone product key that have a particular key string.
GetConfiguredFeatures | This method used to get list of features the application is configured.
GetLicense | Get current active license
GetLicenseInfoClassList | This method is used for debugging purpose to get list of LicenseInfo that can be examined.
IsCommuterCodeInUse | Checks if commuted license is used.
IsProductKeyFeatureMatch | checks product key feature matching
IsStandaloneLicenseInUse |
LicenseRenewalNeeded | Determine if license renew due day is less than 7 day. if it is, it will return the number of day left. Else return -1(i.e still not in renewal period).
LicenseUpgradingNeeded | Determine if evaluation license expiration due day is less than 7 day. if it is, it will return the number of day left. Else return -1(i.e still not in upgrading period).
LoadLicensor | Load Licensor assemblies
RenewProductKeys | Auto renew license
SetActivationMethod | Set the product activation method detected.
Top
Events
Name | Description
ConnectionCheckCompleted | Connection check has completed.
Top
See Also

Reference

VisualComponents.Create3D Namespace


LicensingHelper Properties

The LicensingHelper type exposes the following members.

Properties
Name | Description
ActivatedLicenseType | Represents the activated license type
ActivationMethod | Tells how the current instance of the application is activated
ActiveProductKeyString | Return the active product key string for the product that best matches the current license configuration.
ApplicationLicenseConfiguration | Represents the main licensed product as well as any add-on modules
ConnectionStatus | Result of last connection check.
ProductKeyFromLauncherConfig | Get product key which activate the application.This key is stored in Launcher config file.
ProductKeySavedInLauncher | Get product key which activate the application.This key is stored in Launcher config file.
Top
See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.ActivatedLicenseType Property

LicensingHelperActivatedLicenseType Property

Represents the activated license type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static LicensingHelperActivationLicenseType ActivatedLicenseType { get; }
public:
static property LicensingHelperActivationLicenseType ActivatedLicenseType {
    LicensingHelperActivationLicenseType get ();
}

Property Value

Type: LicensingHelperActivationLicenseType
See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.ActivationMethod Property

LicensingHelperActivationMethod Property

Tells how the current instance of the application is activated

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ProductLicenseType ActivationMethod { get; }
public:
static property ProductLicenseType ActivationMethod {
    ProductLicenseType get ();
}

Property Value

Type: ProductLicenseType
See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.ActiveProductKeyString Property

LicensingHelperActiveProductKeyString Property

Return the active product key string for the product that best matches the current license configuration.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string ActiveProductKeyString { get; }
public:
static property String^ ActiveProductKeyString {
    String^ get ();
}

Property Value

Type: String
Remarks
This is called from the native side to implement the corresponding Python API properties.
See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.ApplicationLicenseConfiguration Property

LicensingHelperApplicationLicenseConfiguration Property

Represents the main licensed product as well as any add-on modules

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IProductConfiguration ApplicationLicenseConfiguration { get; }
public:
static property IProductConfiguration^ ApplicationLicenseConfiguration {
    IProductConfiguration^ get ();
}

Property Value

Type: IProductConfiguration
See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.ConnectionStatus Property

LicensingHelperConnectionStatus Property

Result of last connection check.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Nullable<bool> ConnectionStatus { get; }
public:
static property Nullable<bool> ConnectionStatus {
    Nullable<bool> get ();
}

Property Value

Type: NullableBoolean
See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.ProductKeyFromLauncherConfig Property

LicensingHelperProductKeyFromLauncherConfig Property

Get product key which activate the application.This key is stored in Launcher config file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string ProductKeyFromLauncherConfig { get; }
public:
static property String^ ProductKeyFromLauncherConfig {
    String^ get ();
}

Return Value

Type: String
product key
See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.ProductKeySavedInLauncher Property

LicensingHelperProductKeySavedInLauncher Property

Get product key which activate the application.This key is stored in Launcher config file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string ProductKeySavedInLauncher { get; }
public:
static property String^ ProductKeySavedInLauncher {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper Methods

The LicensingHelper type exposes the following members.

Methods
Name | Description
CheckAndRequestLicense | Compare existing active license with requested features
CheckConnection | Check if connection to licensor is available.
CheckProductLicense | Compare existing active license with requested features
CheckSoftwareUpdate |
CompareProductKeyFeature(String, ISetProductFeature) | Compares the product key feature
CompareProductKeyFeature(String, IProductConfiguration) | Check product key features against current product configuration.
DeactivateStandaloneLicenseKey | Deactivate a given product key.
EvaluationPeriodLeft(IProductKey) | Calculate evaluation time left for product key.
EvaluationPeriodLeft(NullableDateTime, NullableTimeSpan) | Calculate evaluation period left given expiration date and evaluation time left.
GetActiveProductKey | Collects list of active standalone product keys.
GetActiveStandaloneProductKey | Return the first active standalone product key which have the same feature defined in license setting.
GetActiveStandaloneProductKey(String) | Return active standalone product key that have a particular key string.
GetConfiguredFeatures | This method used to get list of features the application is configured.
GetLicense | Get current active license
GetLicenseInfoClassList | This method is used for debugging purpose to get list of LicenseInfo that can be examined.
IsCommuterCodeInUse | Checks if commuted license is used.
IsProductKeyFeatureMatch | checks product key feature matching
IsStandaloneLicenseInUse |
LicenseRenewalNeeded | Determine if license renew due day is less than 7 day. if it is, it will return the number of day left. Else return -1(i.e still not in renewal period).
LicenseUpgradingNeeded | Determine if evaluation license expiration due day is less than 7 day. if it is, it will return the number of day left. Else return -1(i.e still not in upgrading period).
LoadLicensor | Load Licensor assemblies
RenewProductKeys | Auto renew license
SetActivationMethod | Set the product activation method detected.
Top
See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.CheckAndRequestLicense Method

LicensingHelperCheckAndRequestLicense Method

Compare existing active license with requested features

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool CheckAndRequestLicense()
public:
static bool CheckAndRequestLicense()

Return Value

Type: Boolean
True if the license is valid
See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.CheckConnection Method

LicensingHelperCheckConnection Method

Check if connection to licensor is available.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Nullable<bool> CheckConnection()
public:
static Nullable<bool> CheckConnection()

Return Value

Type: NullableBoolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.LicensingHelper.CheckConnection"]

Remarks

If the connection status is unknown, this method starts the connection check in the background and returns without waiting for it to complete. If the return value is null, the ConnectionCheckCompleted event will be raised when the connection check has completed. The status can then be read from ConnectionStatus.

It is recommended to add a handler to ConnectionCheckCompleted before this method is called in order to avoid missing the event if the check completes quickly.

See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.CheckProductLicense Method

LicensingHelperCheckProductLicense Method

Compare existing active license with requested features

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ProductLicenseType CheckProductLicense(
    Action<string> setStatus
)
public:
static ProductLicenseType CheckProductLicense(
    Action<String^>^ setStatus
)

Parameters

setStatus
Type: SystemActionString

Return Value

Type: ProductLicenseType
type of the license
Remarks
This function is called from Shell, Launcher and Integration test also
See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.CheckSoftwareUpdate Method

LicensingHelperCheckSoftwareUpdate Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool CheckSoftwareUpdate()
public:
static bool CheckSoftwareUpdate()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.LicensingHelper.CheckSoftwareUpdate"]

See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.CompareProductKeyFeature Method

LicensingHelperCompareProductKeyFeature Method

Overload List
Name | Description
CompareProductKeyFeature(String, ISetProductFeature) | Compares the product key feature
CompareProductKeyFeature(String, IProductConfiguration) | Check product key features against current product configuration.
Top
See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.CompareProductKeyFeature Method (String, ISet(ProductFeature))

LicensingHelperCompareProductKeyFeature Method (String, ISetProductFeature)

Compares the product key feature

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static FeatureMatch CompareProductKeyFeature(
    string productFeatures,
    ISet<ProductFeature> referenceFeatures
)
public:
static FeatureMatch CompareProductKeyFeature(
    String^ productFeatures,
    ISet<ProductFeature>^ referenceFeatures
)

Parameters

productFeatures
Type: SystemString
referenceFeatures
Type: System.Collections.GenericISetProductFeature

Return Value

Type: FeatureMatch

[Missing <returns> documentation for "M:VisualComponents.Create3D.LicensingHelper.CompareProductKeyFeature(System.String,System.Collections.Generic.ISet{VisualComponents.Create3D.ProductFeature})"]

See Also

Reference

LicensingHelper Class
CompareProductKeyFeature Overload
VisualComponents.Create3D Namespace


LicensingHelper.CompareProductKeyFeature Method (String, IProductConfiguration)

LicensingHelperCompareProductKeyFeature Method (String, IProductConfiguration)

Check product key features against current product configuration.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static FeatureMatch CompareProductKeyFeature(
    string productFeatures,
    IProductConfiguration productConfiguration
)
public:
static FeatureMatch CompareProductKeyFeature(
    String^ productFeatures,
    IProductConfiguration^ productConfiguration
)

Parameters

productFeatures
Type: SystemString
productConfiguration
Type: VisualComponents.Create3DIProductConfiguration

Return Value

Type: FeatureMatch

[Missing <returns> documentation for "M:VisualComponents.Create3D.LicensingHelper.CompareProductKeyFeature(System.String,VisualComponents.Create3D.IProductConfiguration)"]

See Also

Reference

LicensingHelper Class
CompareProductKeyFeature Overload
VisualComponents.Create3D Namespace


LicensingHelper.DeactivateStandaloneLicenseKey Method

LicensingHelperDeactivateStandaloneLicenseKey Method

Deactivate a given product key.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void DeactivateStandaloneLicenseKey(
    IProductKey productKey
)
public:
static void DeactivateStandaloneLicenseKey(
    IProductKey^ productKey
)

Parameters

productKey
Type: IProductKey
See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.EvaluationPeriodLeft Method

LicensingHelperEvaluationPeriodLeft Method

Overload List
Name | Description
EvaluationPeriodLeft(IProductKey) | Calculate evaluation time left for product key.
EvaluationPeriodLeft(NullableDateTime, NullableTimeSpan) | Calculate evaluation period left given expiration date and evaluation time left.
Top
See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.EvaluationPeriodLeft Method (IProductKey)

LicensingHelperEvaluationPeriodLeft Method (IProductKey)

Calculate evaluation time left for product key.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static TimeSpan EvaluationPeriodLeft(
    IProductKey productKey
)
public:
static TimeSpan EvaluationPeriodLeft(
    IProductKey^ productKey
)

Parameters

productKey
Type: IProductKey

Return Value

Type: TimeSpan
Returns the time left. If it is not evaluation key it will return zero TimeSpan
See Also

Reference

LicensingHelper Class
EvaluationPeriodLeft Overload
VisualComponents.Create3D Namespace


LicensingHelper.EvaluationPeriodLeft Method (Nullable(DateTime), Nullable(TimeSpan))

LicensingHelperEvaluationPeriodLeft Method (NullableDateTime, NullableTimeSpan)

Calculate evaluation period left given expiration date and evaluation time left.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static TimeSpan EvaluationPeriodLeft(
    Nullable<DateTime> expirationDate,
    Nullable<TimeSpan> evaluationTimeLeft
)
public:
static TimeSpan EvaluationPeriodLeft(
    Nullable<DateTime> expirationDate,
    Nullable<TimeSpan> evaluationTimeLeft
)

Parameters

expirationDate
Type: SystemNullableDateTime
evaluationTimeLeft
Type: SystemNullableTimeSpan

Return Value

Type: TimeSpan

[Missing <returns> documentation for "M:VisualComponents.Create3D.LicensingHelper.EvaluationPeriodLeft(System.Nullable{System.DateTime},System.Nullable{System.TimeSpan})"]

See Also

Reference

LicensingHelper Class
EvaluationPeriodLeft Overload
VisualComponents.Create3D Namespace


LicensingHelper.GetActiveProductKey Method

LicensingHelperGetActiveProductKey Method

Collects list of active standalone product keys.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IList<IProductKey> GetActiveProductKey(
    bool getAllActiveKeys
)
public:
static IList<IProductKey^>^ GetActiveProductKey(
    bool getAllActiveKeys
)

Parameters

getAllActiveKeys
Type: SystemBoolean

Return Value

Type: IListIProductKey
List of Active product key
See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.GetActiveStandaloneProductKey Method

LicensingHelperGetActiveStandaloneProductKey Method

Overload List
Name | Description
GetActiveStandaloneProductKey | Return the first active standalone product key which have the same feature defined in license setting.
GetActiveStandaloneProductKey(String) | Return active standalone product key that have a particular key string.
Top
See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.GetActiveStandaloneProductKey Method

LicensingHelperGetActiveStandaloneProductKey Method

Return the first active standalone product key which have the same feature defined in license setting.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IProductKey GetActiveStandaloneProductKey()
public:
static IProductKey^ GetActiveStandaloneProductKey()

Return Value

Type: IProductKey
active standalone product key
See Also

Reference

LicensingHelper Class
GetActiveStandaloneProductKey Overload
VisualComponents.Create3D Namespace


LicensingHelper.GetActiveStandaloneProductKey Method (String)

LicensingHelperGetActiveStandaloneProductKey Method (String)

Return active standalone product key that have a particular key string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IProductKey GetActiveStandaloneProductKey(
    string productKey
)
public:
static IProductKey^ GetActiveStandaloneProductKey(
    String^ productKey
)

Parameters

productKey
Type: SystemString

Return Value

Type: IProductKey

[Missing <returns> documentation for "M:VisualComponents.Create3D.LicensingHelper.GetActiveStandaloneProductKey(System.String)"]

See Also

Reference

LicensingHelper Class
GetActiveStandaloneProductKey Overload
VisualComponents.Create3D Namespace


LicensingHelper.GetConfiguredFeatures Method

LicensingHelperGetConfiguredFeatures Method

This method used to get list of features the application is configured.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ISet<ProductFeature> GetConfiguredFeatures(
    IProductConfiguration productConfiguration
)
public:
static ISet<ProductFeature>^ GetConfiguredFeatures(
    IProductConfiguration^ productConfiguration
)

Parameters

productConfiguration
Type: VisualComponents.Create3DIProductConfiguration
Product configuration object

Return Value

Type: ISetProductFeature
Returns a list of main and addon features that are defined in configuration file.
See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.GetLicense Method

LicensingHelperGetLicense Method

Get current active license

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ILicense GetLicense(
    ILicensor licensor,
    NetworkServerMode serverMode,
    string feature,
    string version,
    string challenge,
    byte[] correctResponse
)
public:
static ILicense^ GetLicense(
    ILicensor^ licensor,
    NetworkServerMode serverMode,
    String^ feature,
    String^ version,
    String^ challenge,
    array<unsigned char>^ correctResponse
)

Parameters

licensor
Type: ILicensor
serverMode
Type: NetworkServerMode
feature
Type: SystemString
version
Type: SystemString
challenge
Type: SystemString
correctResponse
Type: SystemByte

Return Value

Type: ILicense

[Missing <returns> documentation for "M:VisualComponents.Create3D.LicensingHelper.GetLicense(VisualComponents.Licensor.ILicensor,VisualComponents.Licensor.NetworkServerMode,System.String,System.String,System.String,System.Byte[])"]

See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.GetLicenseInfoClassList Method

LicensingHelperGetLicenseInfoClassList Method

This method is used for debugging purpose to get list of LicenseInfo that can be examined.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IList<LicenseInfo> GetLicenseInfoClassList(
    IEnumerable<ILicenseInfo> licenseInfoList
)
public:
static IList<LicenseInfo^>^ GetLicenseInfoClassList(
    IEnumerable<ILicenseInfo^>^ licenseInfoList
)

Parameters

licenseInfoList
Type: System.Collections.GenericIEnumerableILicenseInfo

Return Value

Type: IListLicenseInfo

[Missing <returns> documentation for "M:VisualComponents.Create3D.LicensingHelper.GetLicenseInfoClassList(System.Collections.Generic.IEnumerable{VisualComponents.Licensor.ILicenseInfo})"]

See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.IsCommuterCodeInUse Method

LicensingHelperIsCommuterCodeInUse Method

Checks if commuted license is used.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsCommuterCodeInUse(
    IProductConfiguration productLicense
)
public:
static bool IsCommuterCodeInUse(
    IProductConfiguration^ productLicense
)

Parameters

productLicense
Type: VisualComponents.Create3DIProductConfiguration
instance of product features

Return Value

Type: Boolean
True if commuter license is used for the feature.
Exceptions
Exception | Condition
ArgumentNullException |
See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.IsProductKeyFeatureMatch Method

LicensingHelperIsProductKeyFeatureMatch Method

checks product key feature matching

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsProductKeyFeatureMatch(
    string productFeatures,
    ISet<ProductFeature> referenceFeatures
)
public:
static bool IsProductKeyFeatureMatch(
    String^ productFeatures,
    ISet<ProductFeature>^ referenceFeatures
)

Parameters

productFeatures
Type: SystemString
referenceFeatures
Type: System.Collections.GenericISetProductFeature

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.LicensingHelper.IsProductKeyFeatureMatch(System.String,System.Collections.Generic.ISet{VisualComponents.Create3D.ProductFeature})"]

See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.IsStandaloneLicenseInUse Method

LicensingHelperIsStandaloneLicenseInUse Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsStandaloneLicenseInUse(
    string key
)
public:
static bool IsStandaloneLicenseInUse(
    String^ key
)

Parameters

key
Type: SystemString

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.LicensingHelper.IsStandaloneLicenseInUse(System.String)"]

See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.LicenseRenewalNeeded Method

LicensingHelperLicenseRenewalNeeded Method

Determine if license renew due day is less than 7 day. if it is, it will return the number of day left. Else return -1(i.e still not in renewal period).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int LicenseRenewalNeeded(
    int days
)
public:
static int LicenseRenewalNeeded(
    int days
)

Parameters

days
Type: SystemInt32

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.LicensingHelper.LicenseRenewalNeeded(System.Int32)"]

See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.LicenseUpgradingNeeded Method

LicensingHelperLicenseUpgradingNeeded Method

Determine if evaluation license expiration due day is less than 7 day. if it is, it will return the number of day left. Else return -1(i.e still not in upgrading period).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int LicenseUpgradingNeeded(
    int days
)
public:
static int LicenseUpgradingNeeded(
    int days
)

Parameters

days
Type: SystemInt32

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.LicensingHelper.LicenseUpgradingNeeded(System.Int32)"]

See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.LoadLicensor Method

LicensingHelperLoadLicensor Method

Load Licensor assemblies

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IList<string> LoadLicensor()
public:
static IList<String^>^ LoadLicensor()

Return Value

Type: IListString
list of assembles for loading
See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.RenewProductKeys Method

LicensingHelperRenewProductKeys Method

Auto renew license

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Nullable<DateTime> RenewProductKeys()
public:
static Nullable<DateTime> RenewProductKeys()

Return Value

Type: NullableDateTime
Last renewed date.
See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.SetActivationMethod Method

LicensingHelperSetActivationMethod Method

Set the product activation method detected.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetActivationMethod(
    ProductLicenseType licenseType
)
public:
static void SetActivationMethod(
    ProductLicenseType licenseType
)

Parameters

licenseType
Type: VisualComponents.Create3DProductLicenseType
See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper Events

The LicensingHelper type exposes the following members.

Events
Name | Description
ConnectionCheckCompleted | Connection check has completed.
Top
See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.ConnectionCheckCompleted Event

LicensingHelperConnectionCheckCompleted Event

Connection check has completed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static event EventHandler ConnectionCheckCompleted
public:
static  event EventHandler^ ConnectionCheckCompleted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

LicensingHelper Class
VisualComponents.Create3D Namespace


LicensingHelper.ActivationLicenseType Enumeration

LicensingHelperActivationLicenseType Enumeration

The product license source type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ActivationLicenseType
public enum class ActivationLicenseType
Members
Member name | Value | Description
Unidentified | 0 | Not identified.
Evaluation | 1 | Evaluation license
FloatingEducational | 2 | Server based license for educational users.
FloatingCommercial | 3 | Server based license for commercial users.
FloatingCommercialCommuterCode | 4 | Commuted server based license for commercial users.
Commercial | 5 | Standalone license for commercial users.
Production | 6 | Standalone license for production environment.
Project | 7 | Standalone license for project users.
Educational | 8 | Standalone license for educational users.
See Also

Reference

VisualComponents.Create3D Namespace


LicensingHelper.LicenseWarning Enumeration

LicensingHelperLicenseWarning Enumeration

License warning status.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum LicenseWarning
public enum class LicenseWarning
Members
Member name | Value | Description
MaintenanceEndingSoon | 0 | Maintenance is ending soon.
ExpiringSoon | 1 | Product key expires soon.
RenewingNeed | 2 | License needs to be renewed soon.
See Also

Reference

VisualComponents.Create3D Namespace


LicensingServiceFeature Structure

A versioned feature.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct LicensingServiceFeature
public value class LicensingServiceFeature

The LicensingServiceFeature type exposes the following members.

Constructors
 | Name | Description
Public method | LicensingServiceFeature | Initializes a new instance of the LicensingServiceFeature class
Top
Properties
 | Name | Description
Public property | HasValues | Returns if Name and Version are not null or empty.
Public property | Name | The name of the feature.
Public property | Version | The version of the feature.
Top
Methods
 | Name | Description
Public method | Equals | (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Equality |
Inequality |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


LicensingServiceFeature Constructor

Initializes a new instance of the LicensingServiceFeature class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LicensingServiceFeature(
    string name,
    string version
)
public:
LicensingServiceFeature(
    String^ name,
    String^ version
)

Parameters

name
Type: SystemString
version
Type: SystemString
See Also

Reference

LicensingServiceFeature Structure
VisualComponents.Create3D Namespace


LicensingServiceFeature Properties

The LicensingServiceFeature type exposes the following members.

Properties
 | Name | Description
Public property | HasValues | Returns if Name and Version are not null or empty.
Public property | Name | The name of the feature.
Public property | Version | The version of the feature.
Top
See Also

Reference

LicensingServiceFeature Structure
VisualComponents.Create3D Namespace


LicensingServiceFeature.HasValues Property

LicensingServiceFeatureHasValues Property

Returns if Name and Version are not null or empty.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HasValues { get; }
public:
property bool HasValues {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

LicensingServiceFeature Structure
VisualComponents.Create3D Namespace


LicensingServiceFeature.Name Property

LicensingServiceFeatureName Property

The name of the feature.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; }
public:
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

LicensingServiceFeature Structure
VisualComponents.Create3D Namespace


LicensingServiceFeature.Version Property

LicensingServiceFeatureVersion Property

The version of the feature.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Version { get; }
public:
property String^ Version {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

LicensingServiceFeature Structure
VisualComponents.Create3D Namespace


LicensingServiceFeature Methods

The LicensingServiceFeature type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LicensingServiceFeature Structure
VisualComponents.Create3D Namespace


LicensingServiceFeature.Equals Method

LicensingServiceFeatureEquals Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.LicensingServiceFeature.Equals(System.Object)"]

See Also

Reference

LicensingServiceFeature Structure
VisualComponents.Create3D Namespace


LicensingServiceFeature.GetHashCode Method

LicensingServiceFeatureGetHashCode Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.LicensingServiceFeature.GetHashCode"]

See Also

Reference

LicensingServiceFeature Structure
VisualComponents.Create3D Namespace


LicensingServiceFeature Operators

The LicensingServiceFeature type exposes the following members.

Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

LicensingServiceFeature Structure
VisualComponents.Create3D Namespace


LicensingServiceFeature.Equality Operator

LicensingServiceFeatureEquality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    LicensingServiceFeature obj1,
    LicensingServiceFeature obj2
)
public:
static bool operator ==(
    LicensingServiceFeature obj1,
    LicensingServiceFeature obj2
)

Parameters

obj1
Type: VisualComponents.Create3DLicensingServiceFeature
obj2
Type: VisualComponents.Create3DLicensingServiceFeature

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.LicensingServiceFeature.op_Equality(VisualComponents.Create3D.LicensingServiceFeature,VisualComponents.Create3D.LicensingServiceFeature)"]

See Also

Reference

LicensingServiceFeature Structure
VisualComponents.Create3D Namespace


LicensingServiceFeature.Inequality Operator

LicensingServiceFeatureInequality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    LicensingServiceFeature obj1,
    LicensingServiceFeature obj2
)
public:
static bool operator !=(
    LicensingServiceFeature obj1,
    LicensingServiceFeature obj2
)

Parameters

obj1
Type: VisualComponents.Create3DLicensingServiceFeature
obj2
Type: VisualComponents.Create3DLicensingServiceFeature

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.LicensingServiceFeature.op_Inequality(VisualComponents.Create3D.LicensingServiceFeature,VisualComponents.Create3D.LicensingServiceFeature)"]

See Also

Reference

LicensingServiceFeature Structure
VisualComponents.Create3D Namespace


LightSimNode Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DLightSimNode

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LightSimNode : ILightSimNode,
    INotifyPropertyChanged
public ref class LightSimNode : ILightSimNode,
    INotifyPropertyChanged

The LightSimNode type exposes the following members.

Constructors
 | Name | Description
Public method | LightSimNode | Initializes a new instance of the LightSimNode class
Top
Properties
 | Name | Description
Public property | Children |
Public property | ComponentName |
Public property | Name |
Public property | NodeType |
Public property | Parent |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnPropertyChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


LightSimNode Constructor

Initializes a new instance of the LightSimNode class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LightSimNode()
public:
LightSimNode()
See Also

Reference

LightSimNode Class
VisualComponents.Create3D Namespace


LightSimNode Properties

The LightSimNode type exposes the following members.

Properties
 | Name | Description
Public property | Children |
Public property | ComponentName |
Public property | Name |
Public property | NodeType |
Public property | Parent |
Top
See Also

Reference

LightSimNode Class
VisualComponents.Create3D Namespace


LightSimNode.Children Property

LightSimNodeChildren Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObservableCollection<ILightSimNode> Children { get; }
public:
virtual property ObservableCollection<ILightSimNode^>^ Children {
    ObservableCollection<ILightSimNode^>^ get () sealed;
}

Property Value

Type: ObservableCollectionILightSimNode

Implements

ILightSimNodeChildren
See Also

Reference

LightSimNode Class
VisualComponents.Create3D Namespace


LightSimNode.ComponentName Property

LightSimNodeComponentName Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ComponentName { get; set; }
public:
virtual property String^ ComponentName {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ILightSimNodeComponentName
See Also

Reference

LightSimNode Class
VisualComponents.Create3D Namespace


LightSimNode.Name Property

LightSimNodeName Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; set; }
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ILightSimNodeName
See Also

Reference

LightSimNode Class
VisualComponents.Create3D Namespace


LightSimNode.NodeType Property

LightSimNodeNodeType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TypeOfNode NodeType { get; set; }
public:
virtual property TypeOfNode NodeType {
    TypeOfNode get () sealed;
    void set (TypeOfNode value) sealed;
}

Property Value

Type: TypeOfNode

Implements

ILightSimNodeNodeType
See Also

Reference

LightSimNode Class
VisualComponents.Create3D Namespace


LightSimNode.Parent Property

LightSimNodeParent Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ILightSimNode Parent { get; set; }
public:
virtual property ILightSimNode^ Parent {
    ILightSimNode^ get () sealed;
    void set (ILightSimNode^ value) sealed;
}

Property Value

Type: ILightSimNode

Implements

ILightSimNodeParent
See Also

Reference

LightSimNode Class
VisualComponents.Create3D Namespace


LightSimNode Methods

The LightSimNode type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnPropertyChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LightSimNode Class
VisualComponents.Create3D Namespace


LightSimNode.OnPropertyChanged Method

LightSimNodeOnPropertyChanged Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void OnPropertyChanged(
    string propertyName
)
public:
void OnPropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: SystemString
See Also

Reference

LightSimNode Class
VisualComponents.Create3D Namespace


LightSimNode Events

The LightSimNode type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

LightSimNode Class
VisualComponents.Create3D Namespace


LightSimNode.PropertyChanged Event

LightSimNodePropertyChanged Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event PropertyChangedEventHandler PropertyChanged
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

LightSimNode Class
VisualComponents.Create3D Namespace


LinkAddedEventArgs Class

Event data for LinkAdded event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DLinkAddedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LinkAddedEventArgs : EventArgs
public ref class LinkAddedEventArgs : public EventArgs

The LinkAddedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | LinkAddedEventArgs | Initializes a new instance of the LinkAddedEventArgs class.
Top
Properties
 | Name | Description
Public property | Node | Gets the added link node.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


LinkAddedEventArgs Constructor

Initializes a new instance of the LinkAddedEventArgs class.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LinkAddedEventArgs(
    ISimNode node
)
public:
LinkAddedEventArgs(
    ISimNode^ node
)

Parameters

node
Type: VisualComponents.Create3DISimNode
Node that was added.
See Also

Reference

LinkAddedEventArgs Class
VisualComponents.Create3D Namespace


LinkAddedEventArgs Properties

The LinkAddedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Node | Gets the added link node.
Top
See Also

Reference

LinkAddedEventArgs Class
VisualComponents.Create3D Namespace


LinkAddedEventArgs.Node Property

LinkAddedEventArgsNode Property

Gets the added link node.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimNode Node { get; }
public:
property ISimNode^ Node {
    ISimNode^ get ();
}

Property Value

Type: ISimNode
See Also

Reference

LinkAddedEventArgs Class
VisualComponents.Create3D Namespace


LinkAddedEventArgs Methods

The LinkAddedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LinkAddedEventArgs Class
VisualComponents.Create3D Namespace


LinkRemovingEventArgs Class

Event data for LinkRemoving event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DLinkRemovingEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LinkRemovingEventArgs : EventArgs
public ref class LinkRemovingEventArgs : public EventArgs

The LinkRemovingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | LinkRemovingEventArgs | Initializes a new instance of the BehaviorAddedEventArgs class.
Top
Properties
 | Name | Description
Public property | Node1 | Gets the link node that is being removed.
Public property | Node2 | Gets the link node to which Node1 will be added next. Defined only when moving from one parent to another.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


LinkRemovingEventArgs Constructor

Initializes a new instance of the BehaviorAddedEventArgs class.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LinkRemovingEventArgs(
    ISimNode node1,
    ISimNode node2
)
public:
LinkRemovingEventArgs(
    ISimNode^ node1,
    ISimNode^ node2
)

Parameters

node1
Type: VisualComponents.Create3DISimNode
node2
Type: VisualComponents.Create3DISimNode
See Also

Reference

LinkRemovingEventArgs Class
VisualComponents.Create3D Namespace


LinkRemovingEventArgs Properties

The LinkRemovingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Node1 | Gets the link node that is being removed.
Public property | Node2 | Gets the link node to which Node1 will be added next. Defined only when moving from one parent to another.
Top
See Also

Reference

LinkRemovingEventArgs Class
VisualComponents.Create3D Namespace


LinkRemovingEventArgs.Node1 Property

LinkRemovingEventArgsNode1 Property

Gets the link node that is being removed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimNode Node1 { get; }
public:
property ISimNode^ Node1 {
    ISimNode^ get ();
}

Property Value

Type: ISimNode
See Also

Reference

LinkRemovingEventArgs Class
VisualComponents.Create3D Namespace


LinkRemovingEventArgs.Node2 Property

LinkRemovingEventArgsNode2 Property

Gets the link node to which Node1 will be added next. Defined only when moving from one parent to another.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimNode Node2 { get; }
public:
property ISimNode^ Node2 {
    ISimNode^ get ();
}

Property Value

Type: ISimNode
See Also

Reference

LinkRemovingEventArgs Class
VisualComponents.Create3D Namespace


LinkRemovingEventArgs Methods

The LinkRemovingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LinkRemovingEventArgs Class
VisualComponents.Create3D Namespace


LoadComponentChange Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DChange
VisualComponents.Create3DLoadComponentChange

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LoadComponentChange : Change
public ref class LoadComponentChange : public Change

The LoadComponentChange type exposes the following members.

Constructors
 | Name | Description
Public method | LoadComponentChange | Initializes a new instance of the LoadComponentChange class
Top
Properties
 | Name | Description
Protected property | Changeset | (Inherited from Change.)
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Protected property | TargetsList | Access to easier manipulation of targets in derived classes. (Inherited from Change.)
Top
Methods
 | Name | Description
Protected method | AddTarget | (Inherited from Change.)
Public method | Dispose | (Inherited from Change.)
Protected method | Dispose(Boolean) | (Inherited from Change.)
Protected method | DoRedo | (Overrides ChangeDoRedo.)
Protected method | DoUndo | (Overrides ChangeDoUndo.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasValueChanged | (Inherited from Change.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


LoadComponentChange Constructor

Initializes a new instance of the LoadComponentChange class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LoadComponentChange(
    string filePath,
    Nullable<Vector3> initialPosition,
    ISimComponent component
)
public:
LoadComponentChange(
    String^ filePath,
    Nullable<Vector3> initialPosition,
    ISimComponent^ component
)

Parameters

filePath
Type: SystemString
initialPosition
Type: SystemNullableVector3
component
Type: VisualComponents.Create3DISimComponent
See Also

Reference

LoadComponentChange Class
VisualComponents.Create3D Namespace


LoadComponentChange Properties

The LoadComponentChange type exposes the following members.

Properties
 | Name | Description
Protected property | Changeset | (Inherited from Change.)
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Protected property | TargetsList | Access to easier manipulation of targets in derived classes. (Inherited from Change.)
Top
See Also

Reference

LoadComponentChange Class
VisualComponents.Create3D Namespace


LoadComponentChange Methods

The LoadComponentChange type exposes the following members.

Methods
 | Name | Description
Protected method | AddTarget | (Inherited from Change.)
Public method | Dispose | (Inherited from Change.)
Protected method | Dispose(Boolean) | (Inherited from Change.)
Protected method | DoRedo | (Overrides ChangeDoRedo.)
Protected method | DoUndo | (Overrides ChangeDoUndo.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasValueChanged | (Inherited from Change.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LoadComponentChange Class
VisualComponents.Create3D Namespace


LoadComponentChange.DoRedo Method

LoadComponentChangeDoRedo Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void DoRedo()
protected:
virtual void DoRedo() override
See Also

Reference

LoadComponentChange Class
VisualComponents.Create3D Namespace


LoadComponentChange.DoUndo Method

LoadComponentChangeDoUndo Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void DoUndo()
protected:
virtual void DoUndo() override
See Also

Reference

LoadComponentChange Class
VisualComponents.Create3D Namespace


LoadingPoint Structure

Specifies loading parameters, e.g. on a robot's tool or additional load on one of its links.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct LoadingPoint
public value class LoadingPoint

The LoadingPoint type exposes the following members.

Constructors
 | Name | Description
Public method | LoadingPoint | Specifies loading parameters, e.g. on a robot's tool or additional load on one of its links.
Top
Properties
 | Name | Description
Public property | CenterOfMass | The offset of centre of mass from its parent.
Public property | Inertia | The vector of inertia.
Public property | Mass | The weight of the load.
Top
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides ValueTypeEquals(Object).)
Public method | Equals(LoadingPoint) |
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Equality |
Inequality |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


LoadingPoint Constructor

Specifies loading parameters, e.g. on a robot's tool or additional load on one of its links.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LoadingPoint(
    double mass,
    Matrix centerOfMass,
    Vector3 inertia
)
public:
LoadingPoint(
    double mass,
    Matrix centerOfMass,
    Vector3 inertia
)

Parameters

mass
Type: SystemDouble
centerOfMass
Type: VisualComponents.Create3DMatrix
inertia
Type: VisualComponents.Create3DVector3
See Also

Reference

LoadingPoint Structure
VisualComponents.Create3D Namespace


LoadingPoint Properties

The LoadingPoint type exposes the following members.

Properties
 | Name | Description
Public property | CenterOfMass | The offset of centre of mass from its parent.
Public property | Inertia | The vector of inertia.
Public property | Mass | The weight of the load.
Top
See Also

Reference

LoadingPoint Structure
VisualComponents.Create3D Namespace


LoadingPoint.CenterOfMass Property

LoadingPointCenterOfMass Property

The offset of centre of mass from its parent.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Matrix CenterOfMass { get; }
public:
property Matrix CenterOfMass {
    Matrix get ();
}

Property Value

Type: Matrix
See Also

Reference

LoadingPoint Structure
VisualComponents.Create3D Namespace


LoadingPoint.Inertia Property

LoadingPointInertia Property

The vector of inertia.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 Inertia { get; }
public:
property Vector3 Inertia {
    Vector3 get ();
}

Property Value

Type: Vector3
See Also

Reference

LoadingPoint Structure
VisualComponents.Create3D Namespace


LoadingPoint.Mass Property

LoadingPointMass Property

The weight of the load.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Mass { get; }
public:
property double Mass {
    double get ();
}

Property Value

Type: Double
See Also

Reference

LoadingPoint Structure
VisualComponents.Create3D Namespace


LoadingPoint Methods

The LoadingPoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | (Overrides ValueTypeEquals(Object).)
Public method | Equals(LoadingPoint) |
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LoadingPoint Structure
VisualComponents.Create3D Namespace


LoadingPoint.Equals Method

LoadingPointEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ValueTypeEquals(Object).)
Public method | Equals(LoadingPoint) |
Top
See Also

Reference

LoadingPoint Structure
VisualComponents.Create3D Namespace


LoadingPoint.Equals Method (Object)

LoadingPointEquals Method (Object)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.LoadingPoint.Equals(System.Object)"]

See Also

Reference

LoadingPoint Structure
Equals Overload
VisualComponents.Create3D Namespace


LoadingPoint.Equals Method (LoadingPoint)

LoadingPointEquals Method (LoadingPoint)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    LoadingPoint other
)
public:
bool Equals(
    LoadingPoint other
)

Parameters

other
Type: VisualComponents.Create3DLoadingPoint

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.LoadingPoint.Equals(VisualComponents.Create3D.LoadingPoint)"]

See Also

Reference

LoadingPoint Structure
Equals Overload
VisualComponents.Create3D Namespace


LoadingPoint.GetHashCode Method

LoadingPointGetHashCode Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.LoadingPoint.GetHashCode"]

See Also

Reference

LoadingPoint Structure
VisualComponents.Create3D Namespace


LoadingPoint Operators

The LoadingPoint type exposes the following members.

Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

LoadingPoint Structure
VisualComponents.Create3D Namespace


LoadingPoint.Equality Operator

LoadingPointEquality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    LoadingPoint lhs,
    LoadingPoint other
)
public:
static bool operator ==(
    LoadingPoint lhs,
    LoadingPoint other
)

Parameters

lhs
Type: VisualComponents.Create3DLoadingPoint
other
Type: VisualComponents.Create3DLoadingPoint

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.LoadingPoint.op_Equality(VisualComponents.Create3D.LoadingPoint,VisualComponents.Create3D.LoadingPoint)"]

See Also

Reference

LoadingPoint Structure
VisualComponents.Create3D Namespace


LoadingPoint.Inequality Operator

LoadingPointInequality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    LoadingPoint lhs,
    LoadingPoint other
)
public:
static bool operator !=(
    LoadingPoint lhs,
    LoadingPoint other
)

Parameters

lhs
Type: VisualComponents.Create3DLoadingPoint
other
Type: VisualComponents.Create3DLoadingPoint

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.LoadingPoint.op_Inequality(VisualComponents.Create3D.LoadingPoint,VisualComponents.Create3D.LoadingPoint)"]

See Also

Reference

LoadingPoint Structure
VisualComponents.Create3D Namespace


Log4NetHelper Class

Log4Net Helper class.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DLog4NetHelper

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class Log4NetHelper
[ExtensionAttribute]
public ref class Log4NetHelper abstract sealed
Methods
Name | Description
Debug(ILog, FuncString) | Log a message object with the log4net.Core.Level.Debug level.
Debug(ILog, String) | Log a message with the log4net.Core.Level.Debug level.
Debug(ILog, FuncString, Exception) | Log a message object with the log4net.Core.Level.Debug level.
Error(ILog, FuncString) | Logs a message object with the log4net.Core.Level.Error level.
Error(ILog, FuncString, Exception) | Log a message object with the log4net.Core.Level.Error level including the stack trace of the System.Exception passed as a parameter.
Fatal(ILog, FuncString) | Log a message object with the log4net.Core.Level.Fatal level.
Fatal(ILog, FuncString, Exception) | Log a message object with the log4net.Core.Level.Fatal level including the stack trace of the System.Exception passed as a parameter.
Info(ILog, FuncString) | Logs a message object with the INFO level.
Info(ILog, FuncString, Exception) | Logs a message object with the INFO level including the stack trace of the System.Exception passed as a parameter.
Warn(ILog, FuncString) | Log a message object with the log4net.Core.Level.Warn level.
Warn(ILog, FuncString, Exception) | Log a message object with the log4net.Core.Level.Warn level including the stack trace of the System.Exception passed as a parameter.
Top
See Also

Reference

VisualComponents.Create3D Namespace


Log4NetHelper Methods

Methods
Name | Description
Debug(ILog, FuncString) | Log a message object with the log4net.Core.Level.Debug level.
Debug(ILog, String) | Log a message with the log4net.Core.Level.Debug level.
Debug(ILog, FuncString, Exception) | Log a message object with the log4net.Core.Level.Debug level.
Error(ILog, FuncString) | Logs a message object with the log4net.Core.Level.Error level.
Error(ILog, FuncString, Exception) | Log a message object with the log4net.Core.Level.Error level including the stack trace of the System.Exception passed as a parameter.
Fatal(ILog, FuncString) | Log a message object with the log4net.Core.Level.Fatal level.
Fatal(ILog, FuncString, Exception) | Log a message object with the log4net.Core.Level.Fatal level including the stack trace of the System.Exception passed as a parameter.
Info(ILog, FuncString) | Logs a message object with the INFO level.
Info(ILog, FuncString, Exception) | Logs a message object with the INFO level including the stack trace of the System.Exception passed as a parameter.
Warn(ILog, FuncString) | Log a message object with the log4net.Core.Level.Warn level.
Warn(ILog, FuncString, Exception) | Log a message object with the log4net.Core.Level.Warn level including the stack trace of the System.Exception passed as a parameter.
Top
See Also

Reference

Log4NetHelper Class
VisualComponents.Create3D Namespace


Log4NetHelper.Debug Method

Log4NetHelperDebug Method

Overload List
Name | Description
Debug(ILog, FuncString) | Log a message object with the log4net.Core.Level.Debug level.
Debug(ILog, String) | Log a message with the log4net.Core.Level.Debug level.
Debug(ILog, FuncString, Exception) | Log a message object with the log4net.Core.Level.Debug level.
Top
See Also

Reference

Log4NetHelper Class
VisualComponents.Create3D Namespace


Log4NetHelper.Debug Method (ILog, Func(String))

Log4NetHelperDebug Method (ILog, FuncString)

Log a message object with the log4net.Core.Level.Debug level.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void Debug(
    this ILog log,
    Func<string> formattingCallback
)
public:
[ExtensionAttribute]
static void Debug(
    ILog^ log,
    Func<String^>^ formattingCallback
)

Parameters

log
Type: ILog
The logger instance.
formattingCallback
Type: SystemFuncString
the function which returns the message object to log.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Log4NetHelper Class
Debug Overload
VisualComponents.Create3D Namespace


Log4NetHelper.Debug Method (ILog, String)

Log4NetHelperDebug Method (ILog, String)

Log a message with the log4net.Core.Level.Debug level.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void Debug(
    this ILog log,
    string message
)
public:
[ExtensionAttribute]
static void Debug(
    ILog^ log,
    String^ message
)

Parameters

log
Type: ILog
The logger instance.
message
Type: SystemString
the message to the log.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Log4NetHelper Class
Debug Overload
VisualComponents.Create3D Namespace


Log4NetHelper.Debug Method (ILog, Func(String), Exception)

Log4NetHelperDebug Method (ILog, FuncString, Exception)

Log a message object with the log4net.Core.Level.Debug level.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void Debug(
    this ILog log,
    Func<string> formattingCallback,
    Exception exception
)
public:
[ExtensionAttribute]
static void Debug(
    ILog^ log,
    Func<String^>^ formattingCallback,
    Exception^ exception
)

Parameters

log
Type: ILog
The logger instance.
formattingCallback
Type: SystemFuncString
the function which returns the message object to log.
exception
Type: SystemException
The exception to log, including its stack trace.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Log4NetHelper Class
Debug Overload
VisualComponents.Create3D Namespace


Log4NetHelper.Error Method

Log4NetHelperError Method

Overload List
Name | Description
Error(ILog, FuncString) | Logs a message object with the log4net.Core.Level.Error level.
Error(ILog, FuncString, Exception) | Log a message object with the log4net.Core.Level.Error level including the stack trace of the System.Exception passed as a parameter.
Top
See Also

Reference

Log4NetHelper Class
VisualComponents.Create3D Namespace


Log4NetHelper.Error Method (ILog, Func(String))

Log4NetHelperError Method (ILog, FuncString)

Logs a message object with the log4net.Core.Level.Error level.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void Error(
    this ILog log,
    Func<string> formattingCallback
)
public:
[ExtensionAttribute]
static void Error(
    ILog^ log,
    Func<String^>^ formattingCallback
)

Parameters

log
Type: ILog
The logger instance.
formattingCallback
Type: SystemFuncString
the function which returns the message object to log.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Log4NetHelper Class
Error Overload
VisualComponents.Create3D Namespace


Log4NetHelper.Error Method (ILog, Func(String), Exception)

Log4NetHelperError Method (ILog, FuncString, Exception)

Log a message object with the log4net.Core.Level.Error level including the stack trace of the System.Exception passed as a parameter.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void Error(
    this ILog log,
    Func<string> formattingCallback,
    Exception exception
)
public:
[ExtensionAttribute]
static void Error(
    ILog^ log,
    Func<String^>^ formattingCallback,
    Exception^ exception
)

Parameters

log
Type: ILog
The logger instance.
formattingCallback
Type: SystemFuncString
the function which returns the message object to log.
exception
Type: SystemException
The exception to log, including its stack trace.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Log4NetHelper Class
Error Overload
VisualComponents.Create3D Namespace


Log4NetHelper.Fatal Method

Log4NetHelperFatal Method

Overload List
Name | Description
Fatal(ILog, FuncString) | Log a message object with the log4net.Core.Level.Fatal level.
Fatal(ILog, FuncString, Exception) | Log a message object with the log4net.Core.Level.Fatal level including the stack trace of the System.Exception passed as a parameter.
Top
See Also

Reference

Log4NetHelper Class
VisualComponents.Create3D Namespace


Log4NetHelper.Fatal Method (ILog, Func(String))

Log4NetHelperFatal Method (ILog, FuncString)

Log a message object with the log4net.Core.Level.Fatal level.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void Fatal(
    this ILog log,
    Func<string> formattingCallback
)
public:
[ExtensionAttribute]
static void Fatal(
    ILog^ log,
    Func<String^>^ formattingCallback
)

Parameters

log
Type: ILog
The logger instance.
formattingCallback
Type: SystemFuncString
the function which returns the message object to log.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Log4NetHelper Class
Fatal Overload
VisualComponents.Create3D Namespace


Log4NetHelper.Fatal Method (ILog, Func(String), Exception)

Log4NetHelperFatal Method (ILog, FuncString, Exception)

Log a message object with the log4net.Core.Level.Fatal level including the stack trace of the System.Exception passed as a parameter.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void Fatal(
    this ILog log,
    Func<string> formattingCallback,
    Exception exception
)
public:
[ExtensionAttribute]
static void Fatal(
    ILog^ log,
    Func<String^>^ formattingCallback,
    Exception^ exception
)

Parameters

log
Type: ILog
The logger instance.
formattingCallback
Type: SystemFuncString
the function which returns the message object to log.
exception
Type: SystemException
The exception to log, including its stack trace.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Log4NetHelper Class
Fatal Overload
VisualComponents.Create3D Namespace


Log4NetHelper.Info Method

Log4NetHelperInfo Method

Overload List
Name | Description
Info(ILog, FuncString) | Logs a message object with the INFO level.
Info(ILog, FuncString, Exception) | Logs a message object with the INFO level including the stack trace of the System.Exception passed as a parameter.
Top
See Also

Reference

Log4NetHelper Class
VisualComponents.Create3D Namespace


Log4NetHelper.Info Method (ILog, Func(String))

Log4NetHelperInfo Method (ILog, FuncString)

Logs a message object with the INFO level.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void Info(
    this ILog log,
    Func<string> formattingCallback
)
public:
[ExtensionAttribute]
static void Info(
    ILog^ log,
    Func<String^>^ formattingCallback
)

Parameters

log
Type: ILog
The logger instance.
formattingCallback
Type: SystemFuncString
the function which returns the message object to log.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Log4NetHelper Class
Info Overload
VisualComponents.Create3D Namespace


Log4NetHelper.Info Method (ILog, Func(String), Exception)

Log4NetHelperInfo Method (ILog, FuncString, Exception)

Logs a message object with the INFO level including the stack trace of the System.Exception passed as a parameter.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void Info(
    this ILog log,
    Func<string> formattingCallback,
    Exception exception
)
public:
[ExtensionAttribute]
static void Info(
    ILog^ log,
    Func<String^>^ formattingCallback,
    Exception^ exception
)

Parameters

log
Type: ILog
The logger instance.
formattingCallback
Type: SystemFuncString
the function which returns the message object to log.
exception
Type: SystemException
The exception to log, including its stack trace.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Log4NetHelper Class
Info Overload
VisualComponents.Create3D Namespace


Log4NetHelper.Warn Method

Log4NetHelperWarn Method

Overload List
Name | Description
Warn(ILog, FuncString) | Log a message object with the log4net.Core.Level.Warn level.
Warn(ILog, FuncString, Exception) | Log a message object with the log4net.Core.Level.Warn level including the stack trace of the System.Exception passed as a parameter.
Top
See Also

Reference

Log4NetHelper Class
VisualComponents.Create3D Namespace


Log4NetHelper.Warn Method (ILog, Func(String))

Log4NetHelperWarn Method (ILog, FuncString)

Log a message object with the log4net.Core.Level.Warn level.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void Warn(
    this ILog log,
    Func<string> formattingCallback
)
public:
[ExtensionAttribute]
static void Warn(
    ILog^ log,
    Func<String^>^ formattingCallback
)

Parameters

log
Type: ILog
The logger instance.
formattingCallback
Type: SystemFuncString
the function which returns the message object to log.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Log4NetHelper Class
Warn Overload
VisualComponents.Create3D Namespace


Log4NetHelper.Warn Method (ILog, Func(String), Exception)

Log4NetHelperWarn Method (ILog, FuncString, Exception)

Log a message object with the log4net.Core.Level.Warn level including the stack trace of the System.Exception passed as a parameter.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void Warn(
    this ILog log,
    Func<string> formattingCallback,
    Exception exception
)
public:
[ExtensionAttribute]
static void Warn(
    ILog^ log,
    Func<String^>^ formattingCallback,
    Exception^ exception
)

Parameters

log
Type: ILog
The logger instance.
formattingCallback
Type: SystemFuncString
the function which returns the message object to log.
exception
Type: SystemException
The exception to log, including its stack trace.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ILog. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Log4NetHelper Class
Warn Overload
VisualComponents.Create3D Namespace


Logger Class

Extended logger.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DLogger

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class Logger : ILogExt
public ref class Logger : ILogExt

The Logger type exposes the following members.

Constructors
 | Name | Description
Public method | Logger | Initializes a new instance of the Logger class
Public method | Logger(ILog) | Initializes a new instance of the Logger class
Public method | Logger(Boolean) | Initializes a new instance of the Logger class
Public method | Logger(ILog, TextWriter) | Initializes a new instance of the Logger class
Top
Methods
 | Name | Description
Public method | DecreaseIndent |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Error |
Public method | ErrorFormat(String, Object) |
Public method | ErrorFormat(String, Exception, Object) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IncreaseIndent |
Public method | Info |
Public method | InfoFormat |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


Logger Constructor

Overload List
 | Name | Description
Public method | Logger | Initializes a new instance of the Logger class
Public method | Logger(ILog) | Initializes a new instance of the Logger class
Public method | Logger(Boolean) | Initializes a new instance of the Logger class
Public method | Logger(ILog, TextWriter) | Initializes a new instance of the Logger class
Top
See Also

Reference

Logger Class
VisualComponents.Create3D Namespace


Logger Constructor

Initializes a new instance of the Logger class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Logger()
public:
Logger()
See Also

Reference

Logger Class
Logger Overload
VisualComponents.Create3D Namespace


Logger Constructor (ILog)

Initializes a new instance of the Logger class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Logger(
    ILog log
)
public:
Logger(
    ILog^ log
)

Parameters

log
Type: ILog
See Also

Reference

Logger Class
Logger Overload
VisualComponents.Create3D Namespace


Logger Constructor (Boolean)

Initializes a new instance of the Logger class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Logger(
    bool toConsole
)
public:
Logger(
    bool toConsole
)

Parameters

toConsole
Type: SystemBoolean
See Also

Reference

Logger Class
Logger Overload
VisualComponents.Create3D Namespace


Logger Constructor (ILog, TextWriter)

Initializes a new instance of the Logger class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Logger(
    ILog log,
    TextWriter outWriter
)
public:
Logger(
    ILog^ log,
    TextWriter^ outWriter
)

Parameters

log
Type: ILog
outWriter
Type: System.IOTextWriter
See Also

Reference

Logger Class
Logger Overload
VisualComponents.Create3D Namespace


Logger Methods

The Logger type exposes the following members.

Methods
 | Name | Description
Public method | DecreaseIndent |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Error |
Public method | ErrorFormat(String, Object) |
Public method | ErrorFormat(String, Exception, Object) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IncreaseIndent |
Public method | Info |
Public method | InfoFormat |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

Logger Class
VisualComponents.Create3D Namespace


Logger.DecreaseIndent Method

LoggerDecreaseIndent Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int DecreaseIndent()
public:
virtual int DecreaseIndent() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.Logger.DecreaseIndent"]

Implements

ILogExtDecreaseIndent
See Also

Reference

Logger Class
VisualComponents.Create3D Namespace


Logger.Error Method

LoggerError Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Error(
    string message
)
public:
virtual void Error(
    String^ message
) sealed

Parameters

message
Type: SystemString

Implements

ILogExtError(String)
See Also

Reference

Logger Class
VisualComponents.Create3D Namespace


Logger.ErrorFormat Method

LoggerErrorFormat Method

Overload List
 | Name | Description
Public method | ErrorFormat(String, Object) |
Public method | ErrorFormat(String, Exception, Object) |
Top
See Also

Reference

Logger Class
VisualComponents.Create3D Namespace


Logger.ErrorFormat Method (String, Object[])

LoggerErrorFormat Method (String, Object)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ErrorFormat(
    string format,
    params Object[] args
)
public:
virtual void ErrorFormat(
    String^ format,
    ... array<Object^>^ args
) sealed

Parameters

format
Type: SystemString
args
Type: SystemObject

Implements

ILogExtErrorFormat(String, Object)
See Also

Reference

Logger Class
ErrorFormat Overload
VisualComponents.Create3D Namespace


Logger.ErrorFormat Method (String, Exception, Object[])

LoggerErrorFormat Method (String, Exception, Object)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ErrorFormat(
    string format,
    Exception ex,
    params Object[] args
)
public:
virtual void ErrorFormat(
    String^ format,
    Exception^ ex,
    ... array<Object^>^ args
) sealed

Parameters

format
Type: SystemString
ex
Type: SystemException
args
Type: SystemObject

Implements

ILogExtErrorFormat(String, Exception, Object)
See Also

Reference

Logger Class
ErrorFormat Overload
VisualComponents.Create3D Namespace


Logger.IncreaseIndent Method

LoggerIncreaseIndent Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int IncreaseIndent()
public:
virtual int IncreaseIndent() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.Logger.IncreaseIndent"]

Implements

ILogExtIncreaseIndent
See Also

Reference

Logger Class
VisualComponents.Create3D Namespace


Logger.Info Method

LoggerInfo Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Info(
    string message
)
public:
virtual void Info(
    String^ message
) sealed

Parameters

message
Type: SystemString

Implements

ILogExtInfo(String)
See Also

Reference

Logger Class
VisualComponents.Create3D Namespace


Logger.InfoFormat Method

LoggerInfoFormat Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InfoFormat(
    string format,
    params Object[] args
)
public:
virtual void InfoFormat(
    String^ format,
    ... array<Object^>^ args
) sealed

Parameters

format
Type: SystemString
args
Type: SystemObject

Implements

ILogExtInfoFormat(String, Object)
See Also

Reference

Logger Class
VisualComponents.Create3D Namespace


LogNormalDistributionParameters Class

Log Normal distribution parameters
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DLogNormalDistributionParameters

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LogNormalDistributionParameters : IDistributionParameters
public ref class LogNormalDistributionParameters : IDistributionParameters

The LogNormalDistributionParameters type exposes the following members.

Constructors
 | Name | Description
Public method | LogNormalDistributionParameters | Initializes a new instance of the LogNormalDistributionParameters class
Public method | LogNormalDistributionParameters(IProperty) | Initializes a new instance of the LogNormalDistributionParameters class
Top
Properties
 | Name | Description
Public property | Deviation | standard deviation σ value
Public property | DistributionType |
Public property | Expression |
Public property | Mean | mean μ value
Public property | Property |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


LogNormalDistributionParameters Constructor

Overload List
 | Name | Description
Public method | LogNormalDistributionParameters | Initializes a new instance of the LogNormalDistributionParameters class
Public method | LogNormalDistributionParameters(IProperty) | Initializes a new instance of the LogNormalDistributionParameters class
Top
See Also

Reference

LogNormalDistributionParameters Class
VisualComponents.Create3D Namespace


LogNormalDistributionParameters Constructor

Initializes a new instance of the LogNormalDistributionParameters class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LogNormalDistributionParameters()
public:
LogNormalDistributionParameters()
See Also

Reference

LogNormalDistributionParameters Class
LogNormalDistributionParameters Overload
VisualComponents.Create3D Namespace


LogNormalDistributionParameters Constructor (IProperty)

Initializes a new instance of the LogNormalDistributionParameters class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LogNormalDistributionParameters(
    IProperty property
)
public:
LogNormalDistributionParameters(
    IProperty^ property
)

Parameters

property
Type: VisualComponents.Create3DIProperty
See Also

Reference

LogNormalDistributionParameters Class
LogNormalDistributionParameters Overload
VisualComponents.Create3D Namespace


LogNormalDistributionParameters Properties

The LogNormalDistributionParameters type exposes the following members.

Properties
 | Name | Description
Public property | Deviation | standard deviation σ value
Public property | DistributionType |
Public property | Expression |
Public property | Mean | mean μ value
Public property | Property |
Top
See Also

Reference

LogNormalDistributionParameters Class
VisualComponents.Create3D Namespace


LogNormalDistributionParameters.Deviation Property

LogNormalDistributionParametersDeviation Property

standard deviation σ value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Deviation { get; set; }
public:
property double Deviation {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

LogNormalDistributionParameters Class
VisualComponents.Create3D Namespace


LogNormalDistributionParameters.DistributionType Property

LogNormalDistributionParametersDistributionType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DistributionType DistributionType { get; }
public:
virtual property DistributionType DistributionType {
    DistributionType get () sealed;
}

Property Value

Type: DistributionType

Implements

IDistributionParametersDistributionType
See Also

Reference

LogNormalDistributionParameters Class
VisualComponents.Create3D Namespace


LogNormalDistributionParameters.Expression Property

LogNormalDistributionParametersExpression Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Expression { get; }
public:
virtual property String^ Expression {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IDistributionParametersExpression
See Also

Reference

LogNormalDistributionParameters Class
VisualComponents.Create3D Namespace


LogNormalDistributionParameters.Mean Property

LogNormalDistributionParametersMean Property

mean μ value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Mean { get; set; }
public:
property double Mean {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

LogNormalDistributionParameters Class
VisualComponents.Create3D Namespace


LogNormalDistributionParameters.Property Property

LogNormalDistributionParametersProperty Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty Property { get; }
public:
property IProperty^ Property {
    IProperty^ get ();
}

Property Value

Type: IProperty
See Also

Reference

LogNormalDistributionParameters Class
VisualComponents.Create3D Namespace


LogNormalDistributionParameters Methods

The LogNormalDistributionParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LogNormalDistributionParameters Class
VisualComponents.Create3D Namespace


ManipulationMode Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ManipulationMode
public enum class ManipulationMode
Members
Member name | Value | Description
Disabled | 0 |
Select | 1 |
Move | 2 |
Pnp | 3 |
Interact | 4 |
Jog | 5 |
StatementSelected | 6 |
RoutineSelected | 7 |
See Also

Reference

VisualComponents.Create3D Namespace


ManipulationTargetHelper Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DManipulationTargetHelper

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class ManipulationTargetHelper
public ref class ManipulationTargetHelper abstract sealed

The ManipulationTargetHelper type exposes the following members.

Fields
Name | Description
TotalCount |
Top
See Also

Reference

VisualComponents.Create3D Namespace


ManipulationTargetHelper Fields

The ManipulationTargetHelper type exposes the following members.

Fields
Name | Description
TotalCount |
Top
See Also

Reference

ManipulationTargetHelper Class
VisualComponents.Create3D Namespace


ManipulationTargetHelper.TotalCount Field

ManipulationTargetHelperTotalCount Field

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int TotalCount
public:
static int TotalCount

Field Value

Type: Int32
See Also

Reference

ManipulationTargetHelper Class
VisualComponents.Create3D Namespace


ManipulationTargetPreviewMessage Class

Message broadcasted on [!:ILocalManipulationTarget.TransformationInWorld] changes.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DManipulationTargetPreviewMessage

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ManipulationTargetPreviewMessage
public ref class ManipulationTargetPreviewMessage

The ManipulationTargetPreviewMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ManipulationTargetPreviewMessage | Initializes a new instance of the ManipulationTargetPreviewMessage class
Top
Properties
 | Name | Description
Public property | PreviewTarget | Reference to ILocalManipulationTarget whose transformation has changed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks
Broadcasted only when MoveOnRelease is True.
See Also

Reference

VisualComponents.Create3D Namespace


ManipulationTargetPreviewMessage Constructor

Initializes a new instance of the ManipulationTargetPreviewMessage class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ManipulationTargetPreviewMessage()
public:
ManipulationTargetPreviewMessage()
See Also

Reference

ManipulationTargetPreviewMessage Class
VisualComponents.Create3D Namespace


ManipulationTargetPreviewMessage Properties

The ManipulationTargetPreviewMessage type exposes the following members.

Properties
 | Name | Description
Public property | PreviewTarget | Reference to ILocalManipulationTarget whose transformation has changed.
Top
See Also

Reference

ManipulationTargetPreviewMessage Class
VisualComponents.Create3D Namespace


ManipulationTargetPreviewMessage.PreviewTarget Property

ManipulationTargetPreviewMessagePreviewTarget Property

Reference to ILocalManipulationTarget whose transformation has changed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IManipulationTarget PreviewTarget { get; set; }
public:
property IManipulationTarget^ PreviewTarget {
    IManipulationTarget^ get ();
    void set (IManipulationTarget^ value);
}

Property Value

Type: IManipulationTarget
See Also

Reference

ManipulationTargetPreviewMessage Class
VisualComponents.Create3D Namespace


ManipulationTargetPreviewMessage Methods

The ManipulationTargetPreviewMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ManipulationTargetPreviewMessage Class
VisualComponents.Create3D Namespace


ManipulatorToolType Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ManipulatorToolType
public enum class ManipulatorToolType
Members
Member name | Value | Description
None | 0 |
Combined | 1 | Used in ManipulationMode.Jog mode.
Configuration | 2 | Used in ManipulationMode.Move mode.
PlugAndPlay | 3 | Used in ManipulationMode.PnP mode.
See Also

Reference

VisualComponents.Create3D Namespace


MaterialInheritance Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum MaterialInheritance
public enum class MaterialInheritance
Members
Member name | Value | Description
Disabled | 0 | Node's material is not used.
Inherit | 1 | Node's material is inherited to geometries in the node and its child nodes that do not force their own materials
ForceInherit | 2 | Node's material is inherited to geometries in the node and all its child nodes.
InheritNode | 3 | Node's material is inherited to all geometries in the node that do not do not force their own materials
ForceInheritNode | 4 | Node's material is inherited to all geometries in this node.
InheritLevel | 5 | Node's material is inherited to all geometries on the same level that do not force their own materials. If node is world root then all the nodes in the world will be affected. If node is a component then all the nodes inside the component will be affected. Otherwise, only the node itself will be affected.
ForceInheritLevel | 6 | Node's material is inherited to all geometries on the same level. If node is world root then all the nodes in the world will be affected. If node is a component then all the nodes inside the component will be affected. Otherwise, only the node itself will be affected.
See Also

Reference

VisualComponents.Create3D Namespace


MathHelper Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DMathHelper

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class MathHelper
[ExtensionAttribute]
public ref class MathHelper abstract sealed

The MathHelper type exposes the following members.

Methods
Name | Description
Ceiling |
Clamp(Double, Double, Double) | Clamps value to minimum and maximum.
Clamp(Int32, Int32, Int32) | Clamps value to minimum and maximum.
Clamp(Single, Single, Single) |
Floor |
GetPointEdgeDistance |
GetPointLineDistance |
GetPointPlaneSignedDistance |
IsValidMatrix(Matrix) | This test can be used for sanity checking matrix.
IsValidMatrix(Matrix) | This test can be used for sanity checking matrix.
IsValidMatrix(Matrix, Boolean) |
IsValidMatrix(Matrix, Boolean, Boolean) | This test can be used for sanity checking matrix.
MinIndexT | Finds index of minimum value.
PointToLineDistance2D |
SanitizeMatrix |
ToDegrees | Converts radians to degrees.
ToRadians | Converters degrees to radians.
ToStringRounded(Point3D, Int32) |
ToStringRounded(Vector3D, Int32) |
ToStringRounded(NullableVector3, Int32) |
ToStringRounded(Vector3, Int32) |
ToStringRounded(Point3D, Int32, String) |
ToStringRounded(Vector3D, Int32, String) |
ToStringRounded(NullableVector3, Int32, String) |
ToStringRounded(Vector3, Int32, String) |
VectorLength |
VectorNormalize |
Top
See Also

Reference

VisualComponents.Create3D Namespace


MathHelper Methods

The MathHelper type exposes the following members.

Methods
Name | Description
Ceiling |
Clamp(Double, Double, Double) | Clamps value to minimum and maximum.
Clamp(Int32, Int32, Int32) | Clamps value to minimum and maximum.
Clamp(Single, Single, Single) |
Floor |
GetPointEdgeDistance |
GetPointLineDistance |
GetPointPlaneSignedDistance |
IsValidMatrix(Matrix) | This test can be used for sanity checking matrix.
IsValidMatrix(Matrix) | This test can be used for sanity checking matrix.
IsValidMatrix(Matrix, Boolean) |
IsValidMatrix(Matrix, Boolean, Boolean) | This test can be used for sanity checking matrix.
MinIndexT | Finds index of minimum value.
PointToLineDistance2D |
SanitizeMatrix |
ToDegrees | Converts radians to degrees.
ToRadians | Converters degrees to radians.
ToStringRounded(Point3D, Int32) |
ToStringRounded(Vector3D, Int32) |
ToStringRounded(NullableVector3, Int32) |
ToStringRounded(Vector3, Int32) |
ToStringRounded(Point3D, Int32, String) |
ToStringRounded(Vector3D, Int32, String) |
ToStringRounded(NullableVector3, Int32, String) |
ToStringRounded(Vector3, Int32, String) |
VectorLength |
VectorNormalize |
Top
See Also

Reference

MathHelper Class
VisualComponents.Create3D Namespace


MathHelper.Ceiling Method

MathHelperCeiling Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static double Ceiling(
    this double d,
    int decimals
)
public:
[ExtensionAttribute]
static double Ceiling(
    double d,
    int decimals
)

Parameters

d
Type: SystemDouble
decimals
Type: SystemInt32

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.Create3D.MathHelper.Ceiling(System.Double,System.Int32)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Double. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

MathHelper Class
VisualComponents.Create3D Namespace


MathHelper.Clamp Method

MathHelperClamp Method

Overload List
Name | Description
Clamp(Double, Double, Double) | Clamps value to minimum and maximum.
Clamp(Int32, Int32, Int32) | Clamps value to minimum and maximum.
Clamp(Single, Single, Single) |
Top
See Also

Reference

MathHelper Class
VisualComponents.Create3D Namespace


MathHelper.Clamp Method (Double, Double, Double)

MathHelperClamp Method (Double, Double, Double)

Clamps value to minimum and maximum.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static double Clamp(
    double value,
    double minValue,
    double maxValue
)
public:
static double Clamp(
    double value,
    double minValue,
    double maxValue
)

Parameters

value
Type: SystemDouble
minValue
Type: SystemDouble
maxValue
Type: SystemDouble

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.Create3D.MathHelper.Clamp(System.Double,System.Double,System.Double)"]

See Also

Reference

MathHelper Class
Clamp Overload
VisualComponents.Create3D Namespace


MathHelper.Clamp Method (Int32, Int32, Int32)

MathHelperClamp Method (Int32, Int32, Int32)

Clamps value to minimum and maximum.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int Clamp(
    int value,
    int minValue,
    int maxValue
)
public:
static int Clamp(
    int value,
    int minValue,
    int maxValue
)

Parameters

value
Type: SystemInt32
minValue
Type: SystemInt32
maxValue
Type: SystemInt32

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.MathHelper.Clamp(System.Int32,System.Int32,System.Int32)"]

See Also

Reference

MathHelper Class
Clamp Overload
VisualComponents.Create3D Namespace


MathHelper.Clamp Method (Single, Single, Single)

MathHelperClamp Method (Single, Single, Single)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static float Clamp(
    float value,
    float minValue,
    float maxValue
)
public:
static float Clamp(
    float value,
    float minValue,
    float maxValue
)

Parameters

value
Type: SystemSingle
minValue
Type: SystemSingle
maxValue
Type: SystemSingle

Return Value

Type: Single

[Missing <returns> documentation for "M:VisualComponents.Create3D.MathHelper.Clamp(System.Single,System.Single,System.Single)"]

See Also

Reference

MathHelper Class
Clamp Overload
VisualComponents.Create3D Namespace


MathHelper.Floor Method

MathHelperFloor Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static double Floor(
    this double d,
    int decimals
)
public:
[ExtensionAttribute]
static double Floor(
    double d,
    int decimals
)

Parameters

d
Type: SystemDouble
decimals
Type: SystemInt32

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.Create3D.MathHelper.Floor(System.Double,System.Int32)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Double. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

MathHelper Class
VisualComponents.Create3D Namespace


MathHelper.GetPointEdgeDistance Method

MathHelperGetPointEdgeDistance Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static double GetPointEdgeDistance(
    Vector3 referencePoint,
    Vector3 edgePoint1,
    Vector3 edgePoint2
)
public:
static double GetPointEdgeDistance(
    Vector3 referencePoint,
    Vector3 edgePoint1,
    Vector3 edgePoint2
)

Parameters

referencePoint
Type: VisualComponents.Create3DVector3
edgePoint1
Type: VisualComponents.Create3DVector3
edgePoint2
Type: VisualComponents.Create3DVector3

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.Create3D.MathHelper.GetPointEdgeDistance(VisualComponents.Create3D.Vector3,VisualComponents.Create3D.Vector3,VisualComponents.Create3D.Vector3)"]

See Also

Reference

MathHelper Class
VisualComponents.Create3D Namespace


MathHelper.GetPointLineDistance Method

MathHelperGetPointLineDistance Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static double GetPointLineDistance(
    Vector3 p,
    Vector3 p1,
    Vector3 a1
)
public:
static double GetPointLineDistance(
    Vector3 p,
    Vector3 p1,
    Vector3 a1
)

Parameters

p
Type: VisualComponents.Create3DVector3
p1
Type: VisualComponents.Create3DVector3
a1
Type: VisualComponents.Create3DVector3

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.Create3D.MathHelper.GetPointLineDistance(VisualComponents.Create3D.Vector3,VisualComponents.Create3D.Vector3,VisualComponents.Create3D.Vector3)"]

See Also

Reference

MathHelper Class
VisualComponents.Create3D Namespace


MathHelper.GetPointPlaneSignedDistance Method

MathHelperGetPointPlaneSignedDistance Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static double GetPointPlaneSignedDistance(
    Vector3 point,
    Matrix plane
)
public:
static double GetPointPlaneSignedDistance(
    Vector3 point,
    Matrix plane
)

Parameters

point
Type: VisualComponents.Create3DVector3
plane
Type: VisualComponents.Create3DMatrix

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.Create3D.MathHelper.GetPointPlaneSignedDistance(VisualComponents.Create3D.Vector3,VisualComponents.Create3D.Matrix)"]

See Also

Reference

MathHelper Class
VisualComponents.Create3D Namespace


MathHelper.IsValidMatrix Method

MathHelperIsValidMatrix Method

Overload List
Name | Description
IsValidMatrix(Matrix) | This test can be used for sanity checking matrix.
IsValidMatrix(Matrix) | This test can be used for sanity checking matrix.
IsValidMatrix(Matrix, Boolean) |
IsValidMatrix(Matrix, Boolean, Boolean) | This test can be used for sanity checking matrix.
Top
See Also

Reference

MathHelper Class
VisualComponents.Create3D Namespace


MathHelper.IsValidMatrix Method (Matrix)

MathHelperIsValidMatrix Method (Matrix)

This test can be used for sanity checking matrix.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsValidMatrix(
    Matrix matrix
)
public:
static bool IsValidMatrix(
    Matrix matrix
)

Parameters

matrix
Type: VisualComponents.Create3DMatrix

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.MathHelper.IsValidMatrix(VisualComponents.Create3D.Matrix)"]

See Also

Reference

MathHelper Class
IsValidMatrix Overload
VisualComponents.Create3D Namespace


MathHelper.IsValidMatrix Method (Matrix)

MathHelperIsValidMatrix Method (Matrix)

This test can be used for sanity checking matrix.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsValidMatrix(
    ref Matrix matrix
)
public:
static bool IsValidMatrix(
    Matrix% matrix
)

Parameters

matrix
Type: VisualComponents.Create3DMatrix

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.MathHelper.IsValidMatrix(VisualComponents.Create3D.Matrix@)"]

See Also

Reference

MathHelper Class
IsValidMatrix Overload
VisualComponents.Create3D Namespace


MathHelper.IsValidMatrix Method (Matrix, Boolean)

MathHelperIsValidMatrix Method (Matrix, Boolean)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsValidMatrix(
    ref Matrix matrix,
    bool quickTest
)
public:
static bool IsValidMatrix(
    Matrix% matrix,
    bool quickTest
)

Parameters

matrix
Type: VisualComponents.Create3DMatrix
quickTest
Type: SystemBoolean

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.MathHelper.IsValidMatrix(VisualComponents.Create3D.Matrix@,System.Boolean)"]

See Also

Reference

MathHelper Class
IsValidMatrix Overload
VisualComponents.Create3D Namespace


MathHelper.IsValidMatrix Method (Matrix, Boolean, Boolean)

MathHelperIsValidMatrix Method (Matrix, Boolean, Boolean)

This test can be used for sanity checking matrix.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsValidMatrix(
    ref Matrix matrix,
    bool quickTest,
    bool checkScale
)
public:
static bool IsValidMatrix(
    Matrix% matrix,
    bool quickTest,
    bool checkScale
)

Parameters

matrix
Type: VisualComponents.Create3DMatrix
quickTest
Type: SystemBoolean
checkScale
Type: SystemBoolean

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.MathHelper.IsValidMatrix(VisualComponents.Create3D.Matrix@,System.Boolean,System.Boolean)"]

See Also

Reference

MathHelper Class
IsValidMatrix Overload
VisualComponents.Create3D Namespace


MathHelper.MinIndex(T) Method

MathHelperMinIndexT Method

Finds index of minimum value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int MinIndex<T>(
    T[] list
)
where T : IComparable

public:
generic<typename T>
where T : IComparable
static int MinIndex(
    array<T>^ list
)

Parameters

list
Type: T

Type Parameters

T

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.MathHelper.MinIndex``1(``0[])"]

See Also

Reference

MathHelper Class
VisualComponents.Create3D Namespace


MathHelper.PointToLineDistance2D Method

MathHelperPointToLineDistance2D Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static double PointToLineDistance2D(
    Point a,
    Point b,
    Point c
)
public:
static double PointToLineDistance2D(
    Point a,
    Point b,
    Point c
)

Parameters

a
Type: System.WindowsPoint
b
Type: System.WindowsPoint
c
Type: System.WindowsPoint

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.Create3D.MathHelper.PointToLineDistance2D(System.Windows.Point,System.Windows.Point,System.Windows.Point)"]

See Also

Reference

MathHelper Class
VisualComponents.Create3D Namespace


MathHelper.SanitizeMatrix Method

MathHelperSanitizeMatrix Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool SanitizeMatrix(
    ref Matrix matrix
)
public:
static bool SanitizeMatrix(
    Matrix% matrix
)

Parameters

matrix
Type: VisualComponents.Create3DMatrix

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.MathHelper.SanitizeMatrix(VisualComponents.Create3D.Matrix@)"]

See Also

Reference

MathHelper Class
VisualComponents.Create3D Namespace


MathHelper.ToDegrees Method

MathHelperToDegrees Method

Converts radians to degrees.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static double ToDegrees(
    double radians
)
public:
static double ToDegrees(
    double radians
)

Parameters

radians
Type: SystemDouble

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.Create3D.MathHelper.ToDegrees(System.Double)"]

See Also

Reference

MathHelper Class
VisualComponents.Create3D Namespace


MathHelper.ToRadians Method

MathHelperToRadians Method

Converters degrees to radians.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static double ToRadians(
    double degrees
)
public:
static double ToRadians(
    double degrees
)

Parameters

degrees
Type: SystemDouble

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.Create3D.MathHelper.ToRadians(System.Double)"]

See Also

Reference

MathHelper Class
VisualComponents.Create3D Namespace


MathHelper.ToStringRounded Method

MathHelperToStringRounded Method

Overload List
Name | Description
ToStringRounded(Point3D, Int32) |
ToStringRounded(Vector3D, Int32) |
ToStringRounded(NullableVector3, Int32) |
ToStringRounded(Vector3, Int32) |
ToStringRounded(Point3D, Int32, String) |
ToStringRounded(Vector3D, Int32, String) |
ToStringRounded(NullableVector3, Int32, String) |
ToStringRounded(Vector3, Int32, String) |
Top
See Also

Reference

MathHelper Class
VisualComponents.Create3D Namespace


MathHelper.ToStringRounded Method (Point3D, Int32)

MathHelperToStringRounded Method (Point3D, Int32)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string ToStringRounded(
    this Point3D vector,
    int decimals
)
public:
[ExtensionAttribute]
static String^ ToStringRounded(
    Point3D vector,
    int decimals
)

Parameters

vector
Type: System.Windows.Media.Media3DPoint3D
decimals
Type: SystemInt32

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.MathHelper.ToStringRounded(System.Windows.Media.Media3D.Point3D,System.Int32)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Point3D. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

MathHelper Class
ToStringRounded Overload
VisualComponents.Create3D Namespace


MathHelper.ToStringRounded Method (Vector3D, Int32)

MathHelperToStringRounded Method (Vector3D, Int32)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string ToStringRounded(
    this Vector3D vector,
    int decimals
)
public:
[ExtensionAttribute]
static String^ ToStringRounded(
    Vector3D vector,
    int decimals
)

Parameters

vector
Type: System.Windows.Media.Media3DVector3D
decimals
Type: SystemInt32

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.MathHelper.ToStringRounded(System.Windows.Media.Media3D.Vector3D,System.Int32)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Vector3D. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

MathHelper Class
ToStringRounded Overload
VisualComponents.Create3D Namespace


MathHelper.ToStringRounded Method (Nullable(Vector3), Int32)

MathHelperToStringRounded Method (NullableVector3, Int32)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string ToStringRounded(
    this Nullable<Vector3> vector,
    int decimals
)
public:
[ExtensionAttribute]
static String^ ToStringRounded(
    Nullable<Vector3> vector,
    int decimals
)

Parameters

vector
Type: SystemNullableVector3
decimals
Type: SystemInt32

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.MathHelper.ToStringRounded(System.Nullable{VisualComponents.Create3D.Vector3},System.Int32)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type NullableVector3 . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

MathHelper Class
ToStringRounded Overload
VisualComponents.Create3D Namespace


MathHelper.ToStringRounded Method (Vector3, Int32)

MathHelperToStringRounded Method (Vector3, Int32)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string ToStringRounded(
    this Vector3 vector,
    int decimals
)
public:
[ExtensionAttribute]
static String^ ToStringRounded(
    Vector3 vector,
    int decimals
)

Parameters

vector
Type: VisualComponents.Create3DVector3
decimals
Type: SystemInt32

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.MathHelper.ToStringRounded(VisualComponents.Create3D.Vector3,System.Int32)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Vector3. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

MathHelper Class
ToStringRounded Overload
VisualComponents.Create3D Namespace


MathHelper.ToStringRounded Method (Point3D, Int32, String)

MathHelperToStringRounded Method (Point3D, Int32, String)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string ToStringRounded(
    this Point3D vector,
    int decimals,
    string separator
)
public:
[ExtensionAttribute]
static String^ ToStringRounded(
    Point3D vector,
    int decimals,
    String^ separator
)

Parameters

vector
Type: System.Windows.Media.Media3DPoint3D
decimals
Type: SystemInt32
separator
Type: SystemString

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.MathHelper.ToStringRounded(System.Windows.Media.Media3D.Point3D,System.Int32,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Point3D. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

MathHelper Class
ToStringRounded Overload
VisualComponents.Create3D Namespace


MathHelper.ToStringRounded Method (Vector3D, Int32, String)

MathHelperToStringRounded Method (Vector3D, Int32, String)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string ToStringRounded(
    this Vector3D vector,
    int decimals,
    string separator
)
public:
[ExtensionAttribute]
static String^ ToStringRounded(
    Vector3D vector,
    int decimals,
    String^ separator
)

Parameters

vector
Type: System.Windows.Media.Media3DVector3D
decimals
Type: SystemInt32
separator
Type: SystemString

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.MathHelper.ToStringRounded(System.Windows.Media.Media3D.Vector3D,System.Int32,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Vector3D. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

MathHelper Class
ToStringRounded Overload
VisualComponents.Create3D Namespace


MathHelper.ToStringRounded Method (Nullable(Vector3), Int32, String)

MathHelperToStringRounded Method (NullableVector3, Int32, String)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string ToStringRounded(
    this Nullable<Vector3> vector,
    int decimals,
    string separator
)
public:
[ExtensionAttribute]
static String^ ToStringRounded(
    Nullable<Vector3> vector,
    int decimals,
    String^ separator
)

Parameters

vector
Type: SystemNullableVector3
decimals
Type: SystemInt32
separator
Type: SystemString

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.MathHelper.ToStringRounded(System.Nullable{VisualComponents.Create3D.Vector3},System.Int32,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type NullableVector3 . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

MathHelper Class
ToStringRounded Overload
VisualComponents.Create3D Namespace


MathHelper.ToStringRounded Method (Vector3, Int32, String)

MathHelperToStringRounded Method (Vector3, Int32, String)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string ToStringRounded(
    this Vector3 vector,
    int decimals,
    string separator
)
public:
[ExtensionAttribute]
static String^ ToStringRounded(
    Vector3 vector,
    int decimals,
    String^ separator
)

Parameters

vector
Type: VisualComponents.Create3DVector3
decimals
Type: SystemInt32
separator
Type: SystemString

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.MathHelper.ToStringRounded(VisualComponents.Create3D.Vector3,System.Int32,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Vector3. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

MathHelper Class
ToStringRounded Overload
VisualComponents.Create3D Namespace


MathHelper.VectorLength Method

MathHelperVectorLength Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static double VectorLength(
    double x,
    double y,
    double z
)
public:
static double VectorLength(
    double x,
    double y,
    double z
)

Parameters

x
Type: SystemDouble
y
Type: SystemDouble
z
Type: SystemDouble

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.Create3D.MathHelper.VectorLength(System.Double,System.Double,System.Double)"]

See Also

Reference

MathHelper Class
VisualComponents.Create3D Namespace


MathHelper.VectorNormalize Method

MathHelperVectorNormalize Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void VectorNormalize(
    ref double x,
    ref double y,
    ref double z
)
public:
static void VectorNormalize(
    double% x,
    double% y,
    double% z
)

Parameters

x
Type: SystemDouble
y
Type: SystemDouble
z
Type: SystemDouble
See Also

Reference

MathHelper Class
VisualComponents.Create3D Namespace


Matrix Structure

Represents a 4x4 matrix in column major format.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct Matrix
public value class Matrix

The Matrix type exposes the following members.

Constructors
 | Name | Description
Public method | Matrix(Matrix3D) | Constructor that sets matrix's initial values using Matrix3D structure
Public method | Matrix(Vector3, Vector3, Vector3, Vector3) | Constructor that sets matrix's initial values using Vector3 structures
Public method | Matrix(Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double) | Constructor that sets matrix's initial values
Top
Properties
 | Name | Description
Public property | Aw | Gets or sets Aw value of this Matrix
Public property | Ax | Gets or sets Ax value of this Matrix
Public property | Ay | Gets or sets Ay value of this Matrix
Public property | Az | Gets or sets Az value of this Matrix
Public property | Determinant | Retrieves the determinant of ths Matrix
 | Identity | Returns an Matrix that is an identity matrix
Public property | IsIdentity | Determines whether this Matrix is an identity matrix.
Public property | IsOrthogonal | Determines if this Matrix is orthogonal
Public property | Item | Access Nx, Ny, Nz, Ox... values of this Matrix using indices
Public property | Nw | Gets or sets Nw value of this Matrix
Public property | Nx | Gets or sets Nx value of this Matrix
Public property | Ny | Gets or sets Ny value of this Matrix
Public property | Nz | Gets or sets Nz value of this Matrix
Public property | Ow | Gets or sets Ow value of this Matrix
Public property | Ox | Gets or sets Ox value of this Matrix
Public property | Oy | Gets or sets Oy value of this Matrix
Public property | Oz | Gets or sets Oz value of this Matrix
Public property | Pw | Gets or sets Pw value of this Matrix
Public property | Px | Gets or sets Px value of this Matrix
Public property | Py | Gets or sets Py value of this Matrix
Public property | Pz | Gets or sets Pz value of this Matrix
 | Zero | Returns an Matrix with all values set to zero
Top
Methods
 | Name | Description
Public method | Equals(Object) | Compares two Matrix structures for equality (Overrides ValueTypeEquals(Object).)
 | Equals(Matrix, Matrix) | Compares two Matrix structures for equality
Public method | EqualsThreshold(Matrix) |
Public method | EqualsThreshold(Matrix, Double) |
Public method | GetA | Gets Ax, Ay and Az values of this Matrix as a new Vector3 instance
Public method | GetAxisAngle | Returns the orientation of this Matrix as a rotation of the identity matrix about the axis defined by the (XYZ) values of the returned Vector3. The W value holds the rotation angle, in degrees.
Public method | GetEuler | Returns the orientation of this Matrix as a set of absolute rotations (around fixed coordinate system) about the Z axis followed by the Y axis and then the Z axis again, using angles stored in (XYZ) values of the returned Vector3, in degrees.
Public method | GetHashCode | Gets a hash code for this structure (Overrides ValueTypeGetHashCode.)
 | GetMeanMatrix |
Public method | GetN | Gets Nx, Ny and Nz values of this as a new Vector3 instance
Public method | GetO | Gets Ox, Oy and Oz values of this Matrix as a new Vector3 instance
Public method | GetP | Gets Px, Py and Pz values of this Matrix as new Vector3 instance
Public method | GetQuaternion | Returns the orientation of this Matrix as an orientation quaternion, stored in (XYZW) values of the returned Vector3.
Public method | GetScale | Gets the scaling factors of this Matrix as a new Vector3 instance
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWPR | Get or sets the orientation of this Matrix as a set of relative rotations about the Z axis followed by the Y axis and X axis using the angles stored in (XYZ) values of the returned Vector3, in degrees.
Public method | GetWPR(Int32) | Get or sets the orientation of this Matrix as a set of relative rotations about the Z axis followed by the Y axis and X axis using the angles stored in (XYZ) values of the returned Vector3, in degrees.
Public method | Inverse | Returns a new inverted matrix.
Public method | Invert | Inverts this Matrix
 | Multiply | Multiplies the specified two Matrix structures
 | Parse | Converts string representation of a matrix to equivalent Matrix instance
Public method | RotateAbsX | Rotates this Matrix around the X-axis based in the absolute coordinate system.
Public method | RotateAbsY | Rotates this Matrix around the Y-axis based in the absolute coordinate system
Public method | RotateAbsZ | Rotates this Matrix around the Z-axis based in the absolute coordinate system
Public method | RotateAroundX | Rotates this Matrix around the X-axis based in the coordinate system relative to the matrix position
Public method | RotateAroundY | Rotates this Matrix around the Y-axis based in the coordinate system relative to the matrix position.
Public method | RotateAroundZ | Rotates this Matrix around the Z-axis based in the coordinate system relative to the matrix position.
Public method | RotateAt | Rotate matrix by quaternion and at specified position.
Public method | ScaleAbs | Scales this Matrix about the world origin
Public method | ScaleRelative | Scales this Matrix about the matrix position
Public method | SetA | Sets Ax, Ay and Az values of this Matrix using the given Vector3
Public method | SetAxisAngle | Sets the axis and angle rotation of this Matrix. This representation uses two values: a unit vector (x,y,z) indicating the direction of a direct axis and an angle (w) describing the magnitude of the rotation about the axis.
Public method | SetEuler | Sets the orientation of this Matrix as a set of absolute rotations (around fixed coordinate system) about the Z axis followed by the Y axis and then the Z axis again. All angles are given in degrees.
Public method | SetIdentity | Converts this Matrix to identity matrix
Public method | SetIJK(Vector3) | Sets the orientation of this Matrix so that the approach vector (Z-axis) is pointing to the given (I,J,K) vector direction, i.e. Z-axis aligned with vector
Public method | SetIJK(Double, Double, Double) | Sets the orientation of this Matrix so that the approach vector (Z-axis) is pointing to the given (I,J,K) vector direction, i.e. Z-axis aligned with vector
Public method | SetN | Sets the Nx, Ny and Nz values of this Matrix using the given Vector3
Public method | SetO | Sets Ox, Oy and Oz values of this Matrix using the given Vector3
Public method | SetP | Sets Px, Py and Pz values of this Matrix using the given Vector3
Public method | SetQuaternion | Set the orientation of this Matrix using an orientation quaternion. Note: X-component of Vector3 is W-component of quaternion.
Public method | SetWPR | Set the orientation of this Matrix using the specified yaw, pitch, and roll values.
 | ToMedia3D | Returns the specified Matrix as a new Matrix3D structure
Public method | ToString | Creates a string representation of this Matrix (Overrides ValueTypeToString.)
 | Transform |
Public method | TranslateAbs | Translates the position of this Matrix by the given offset in the world coordinate system
Public method | TranslateRelative(Vector3) | Translates the position of this Matrix by the given offset in the matrix coordinate system
Public method | TranslateRelative(Double, Double, Double) | Translates the position of this Matrix by the given offset in the matrix coordinate system
Public method | Uniform | To make sure this Matrix is orthogonal and contains no scaling
Public method | UniformZ | Uniforms matrix m so that Z axis (A) retains its direction. Thes second most important axis is X (N).
Top
Operators
Name | Description
Equality | Compares two Matrix structures for equality
(Matrix3D to Matrix) | Converts the Matrix3D structure to a new Matrix
(Matrix to Matrix3D) | Converts the Matrix to a new Matrix3D structure
Inequality | Compares two Matrix structures for inequality
Multiply | Multiplies two Matrix structures
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks
NOAP refers to normal, orientation, approach and position vectors.
See Also

Reference

VisualComponents.Create3D Namespace


Matrix Constructor

Overload List
 | Name | Description
Public method | Matrix(Matrix3D) | Constructor that sets matrix's initial values using Matrix3D structure
Public method | Matrix(Vector3, Vector3, Vector3, Vector3) | Constructor that sets matrix's initial values using Vector3 structures
Public method | Matrix(Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double) | Constructor that sets matrix's initial values
Top
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix Constructor (Matrix3D)

Constructor that sets matrix's initial values using Matrix3D structure

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Matrix(
    Matrix3D matrix3D
)
public:
Matrix(
    Matrix3D matrix3D
)

Parameters

matrix3D
Type: System.Windows.Media.Media3DMatrix3D
Matrix3D to be initialized from
See Also

Reference

Matrix Structure
Matrix Overload
VisualComponents.Create3D Namespace


Matrix Constructor (Vector3, Vector3, Vector3, Vector3)

Constructor that sets matrix's initial values using Vector3 structures

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Matrix(
    Vector3 n,
    Vector3 o,
    Vector3 a,
    Vector3 p
)
public:
Matrix(
    Vector3 n,
    Vector3 o,
    Vector3 a,
    Vector3 p
)

Parameters

n
Type: VisualComponents.Create3DVector3
Vector defining Nx, Ny, Nz values
o
Type: VisualComponents.Create3DVector3
Vector defining Ox, Oy, Oz values
a
Type: VisualComponents.Create3DVector3
Vector defining Ax, Ay, Az values
p
Type: VisualComponents.Create3DVector3
Vector defining Px, Pw, Pz
See Also

Reference

Matrix Structure
Matrix Overload
VisualComponents.Create3D Namespace


Matrix Constructor (Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double)

Constructor that sets matrix's initial values

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Matrix(
    double nx,
    double ny,
    double nz,
    double nw,
    double ox,
    double oy,
    double oz,
    double ow,
    double ax,
    double ay,
    double az,
    double aw,
    double px,
    double py,
    double pz,
    double pw
)
public:
Matrix(
    double nx,
    double ny,
    double nz,
    double nw,
    double ox,
    double oy,
    double oz,
    double ow,
    double ax,
    double ay,
    double az,
    double aw,
    double px,
    double py,
    double pz,
    double pw
)

Parameters

nx
Type: SystemDouble
Nx value
ny
Type: SystemDouble
Ny value
nz
Type: SystemDouble
Nz value
nw
Type: SystemDouble
Nw value
ox
Type: SystemDouble
Ox value
oy
Type: SystemDouble
Oy value
oz
Type: SystemDouble
Oz value
ow
Type: SystemDouble
Ow value
ax
Type: SystemDouble
Ax value
ay
Type: SystemDouble
Ay value
az
Type: SystemDouble
Az value
aw
Type: SystemDouble
Aw value
px
Type: SystemDouble
Px value
py
Type: SystemDouble
Py value
pz
Type: SystemDouble
Pz value
pw
Type: SystemDouble
Pw value
See Also

Reference

Matrix Structure
Matrix Overload
VisualComponents.Create3D Namespace


Matrix Properties

The Matrix type exposes the following members.

Properties
 | Name | Description
Public property | Aw | Gets or sets Aw value of this Matrix
Public property | Ax | Gets or sets Ax value of this Matrix
Public property | Ay | Gets or sets Ay value of this Matrix
Public property | Az | Gets or sets Az value of this Matrix
Public property | Determinant | Retrieves the determinant of ths Matrix
 | Identity | Returns an Matrix that is an identity matrix
Public property | IsIdentity | Determines whether this Matrix is an identity matrix.
Public property | IsOrthogonal | Determines if this Matrix is orthogonal
Public property | Item | Access Nx, Ny, Nz, Ox... values of this Matrix using indices
Public property | Nw | Gets or sets Nw value of this Matrix
Public property | Nx | Gets or sets Nx value of this Matrix
Public property | Ny | Gets or sets Ny value of this Matrix
Public property | Nz | Gets or sets Nz value of this Matrix
Public property | Ow | Gets or sets Ow value of this Matrix
Public property | Ox | Gets or sets Ox value of this Matrix
Public property | Oy | Gets or sets Oy value of this Matrix
Public property | Oz | Gets or sets Oz value of this Matrix
Public property | Pw | Gets or sets Pw value of this Matrix
Public property | Px | Gets or sets Px value of this Matrix
Public property | Py | Gets or sets Py value of this Matrix
Public property | Pz | Gets or sets Pz value of this Matrix
 | Zero | Returns an Matrix with all values set to zero
Top
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.Aw Property

MatrixAw Property

Gets or sets Aw value of this Matrix

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Aw { get; set; }
public:
property double Aw {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.Ax Property

MatrixAx Property

Gets or sets Ax value of this Matrix

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Ax { get; set; }
public:
property double Ax {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.Ay Property

MatrixAy Property

Gets or sets Ay value of this Matrix

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Ay { get; set; }
public:
property double Ay {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.Az Property

MatrixAz Property

Gets or sets Az value of this Matrix

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Az { get; set; }
public:
property double Az {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.Determinant Property

MatrixDeterminant Property

Retrieves the determinant of ths Matrix

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Determinant { get; }
public:
property double Determinant {
    double get ();
}

Property Value

Type: Double
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.Identity Property

MatrixIdentity Property

Returns an Matrix that is an identity matrix

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Matrix Identity { get; }
public:
static property Matrix Identity {
    Matrix get ();
}

Property Value

Type: Matrix
Examples
This sample shows how to use Identity property.
Copy
class TestClass
{
    static int Main()
    {
        Matrix identity = Matrix.Identity;
    }
}
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.IsIdentity Property

MatrixIsIdentity Property

Determines whether this Matrix is an identity matrix.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsIdentity { get; }
public:
property bool IsIdentity {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.IsOrthogonal Property

MatrixIsOrthogonal Property

Determines if this Matrix is orthogonal

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsOrthogonal { get; }
public:
property bool IsOrthogonal {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.Item Property

MatrixItem Property

Access Nx, Ny, Nz, Ox... values of this Matrix using indices

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double this[
    int index
] { get; set; }
public:
property double default[int index] {
    double get (int index);
    void set (int index, double value);
}

Parameters

index
Type: SystemInt32
Index

Return Value

Type: Double
Value
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.Nw Property

MatrixNw Property

Gets or sets Nw value of this Matrix

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Nw { get; set; }
public:
property double Nw {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.Nx Property

MatrixNx Property

Gets or sets Nx value of this Matrix

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Nx { get; set; }
public:
property double Nx {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.Ny Property

MatrixNy Property

Gets or sets Ny value of this Matrix

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Ny { get; set; }
public:
property double Ny {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.Nz Property

MatrixNz Property

Gets or sets Nz value of this Matrix

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Nz { get; set; }
public:
property double Nz {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.Ow Property

MatrixOw Property

Gets or sets Ow value of this Matrix

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Ow { get; set; }
public:
property double Ow {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.Ox Property

MatrixOx Property

Gets or sets Ox value of this Matrix

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Ox { get; set; }
public:
property double Ox {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.Oy Property

MatrixOy Property

Gets or sets Oy value of this Matrix

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Oy { get; set; }
public:
property double Oy {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.Oz Property

MatrixOz Property

Gets or sets Oz value of this Matrix

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Oz { get; set; }
public:
property double Oz {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.Pw Property

MatrixPw Property

Gets or sets Pw value of this Matrix

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Pw { get; set; }
public:
property double Pw {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.Px Property

MatrixPx Property

Gets or sets Px value of this Matrix

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Px { get; set; }
public:
property double Px {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.Py Property

MatrixPy Property

Gets or sets Py value of this Matrix

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Py { get; set; }
public:
property double Py {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.Pz Property

MatrixPz Property

Gets or sets Pz value of this Matrix

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Pz { get; set; }
public:
property double Pz {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.Zero Property

MatrixZero Property

Returns an Matrix with all values set to zero

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Matrix Zero { get; }
public:
static property Matrix Zero {
    Matrix get ();
}

Property Value

Type: Matrix
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix Methods

The Matrix type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Compares two Matrix structures for equality (Overrides ValueTypeEquals(Object).)
 | Equals(Matrix, Matrix) | Compares two Matrix structures for equality
Public method | EqualsThreshold(Matrix) |
Public method | EqualsThreshold(Matrix, Double) |
Public method | GetA | Gets Ax, Ay and Az values of this Matrix as a new Vector3 instance
Public method | GetAxisAngle | Returns the orientation of this Matrix as a rotation of the identity matrix about the axis defined by the (XYZ) values of the returned Vector3. The W value holds the rotation angle, in degrees.
Public method | GetEuler | Returns the orientation of this Matrix as a set of absolute rotations (around fixed coordinate system) about the Z axis followed by the Y axis and then the Z axis again, using angles stored in (XYZ) values of the returned Vector3, in degrees.
Public method | GetHashCode | Gets a hash code for this structure (Overrides ValueTypeGetHashCode.)
 | GetMeanMatrix |
Public method | GetN | Gets Nx, Ny and Nz values of this as a new Vector3 instance
Public method | GetO | Gets Ox, Oy and Oz values of this Matrix as a new Vector3 instance
Public method | GetP | Gets Px, Py and Pz values of this Matrix as new Vector3 instance
Public method | GetQuaternion | Returns the orientation of this Matrix as an orientation quaternion, stored in (XYZW) values of the returned Vector3.
Public method | GetScale | Gets the scaling factors of this Matrix as a new Vector3 instance
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWPR | Get or sets the orientation of this Matrix as a set of relative rotations about the Z axis followed by the Y axis and X axis using the angles stored in (XYZ) values of the returned Vector3, in degrees.
Public method | GetWPR(Int32) | Get or sets the orientation of this Matrix as a set of relative rotations about the Z axis followed by the Y axis and X axis using the angles stored in (XYZ) values of the returned Vector3, in degrees.
Public method | Inverse | Returns a new inverted matrix.
Public method | Invert | Inverts this Matrix
 | Multiply | Multiplies the specified two Matrix structures
 | Parse | Converts string representation of a matrix to equivalent Matrix instance
Public method | RotateAbsX | Rotates this Matrix around the X-axis based in the absolute coordinate system.
Public method | RotateAbsY | Rotates this Matrix around the Y-axis based in the absolute coordinate system
Public method | RotateAbsZ | Rotates this Matrix around the Z-axis based in the absolute coordinate system
Public method | RotateAroundX | Rotates this Matrix around the X-axis based in the coordinate system relative to the matrix position
Public method | RotateAroundY | Rotates this Matrix around the Y-axis based in the coordinate system relative to the matrix position.
Public method | RotateAroundZ | Rotates this Matrix around the Z-axis based in the coordinate system relative to the matrix position.
Public method | RotateAt | Rotate matrix by quaternion and at specified position.
Public method | ScaleAbs | Scales this Matrix about the world origin
Public method | ScaleRelative | Scales this Matrix about the matrix position
Public method | SetA | Sets Ax, Ay and Az values of this Matrix using the given Vector3
Public method | SetAxisAngle | Sets the axis and angle rotation of this Matrix. This representation uses two values: a unit vector (x,y,z) indicating the direction of a direct axis and an angle (w) describing the magnitude of the rotation about the axis.
Public method | SetEuler | Sets the orientation of this Matrix as a set of absolute rotations (around fixed coordinate system) about the Z axis followed by the Y axis and then the Z axis again. All angles are given in degrees.
Public method | SetIdentity | Converts this Matrix to identity matrix
Public method | SetIJK(Vector3) | Sets the orientation of this Matrix so that the approach vector (Z-axis) is pointing to the given (I,J,K) vector direction, i.e. Z-axis aligned with vector
Public method | SetIJK(Double, Double, Double) | Sets the orientation of this Matrix so that the approach vector (Z-axis) is pointing to the given (I,J,K) vector direction, i.e. Z-axis aligned with vector
Public method | SetN | Sets the Nx, Ny and Nz values of this Matrix using the given Vector3
Public method | SetO | Sets Ox, Oy and Oz values of this Matrix using the given Vector3
Public method | SetP | Sets Px, Py and Pz values of this Matrix using the given Vector3
Public method | SetQuaternion | Set the orientation of this Matrix using an orientation quaternion. Note: X-component of Vector3 is W-component of quaternion.
Public method | SetWPR | Set the orientation of this Matrix using the specified yaw, pitch, and roll values.
 | ToMedia3D | Returns the specified Matrix as a new Matrix3D structure
Public method | ToString | Creates a string representation of this Matrix (Overrides ValueTypeToString.)
 | Transform |
Public method | TranslateAbs | Translates the position of this Matrix by the given offset in the world coordinate system
Public method | TranslateRelative(Vector3) | Translates the position of this Matrix by the given offset in the matrix coordinate system
Public method | TranslateRelative(Double, Double, Double) | Translates the position of this Matrix by the given offset in the matrix coordinate system
Public method | Uniform | To make sure this Matrix is orthogonal and contains no scaling
Public method | UniformZ | Uniforms matrix m so that Z axis (A) retains its direction. Thes second most important axis is X (N).
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.Equals Method

MatrixEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Compares two Matrix structures for equality (Overrides ValueTypeEquals(Object).)
 | Equals(Matrix, Matrix) | Compares two Matrix structures for equality
Top
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.Equals Method (Object)

MatrixEquals Method (Object)

Compares two Matrix structures for equality

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
The matrix to compare

Return Value

Type: Boolean
True if the matrices are identical; false otherwise.
See Also

Reference

Matrix Structure
Equals Overload
VisualComponents.Create3D Namespace


Matrix.Equals Method (Matrix, Matrix)

MatrixEquals Method (Matrix, Matrix)

Compares two Matrix structures for equality

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool Equals(
    Matrix matrix1,
    Matrix matrix2
)
public:
static bool Equals(
    Matrix matrix1,
    Matrix matrix2
)

Parameters

matrix1
Type: VisualComponents.Create3DMatrix
The first matrix
matrix2
Type: VisualComponents.Create3DMatrix
The second matrix

Return Value

Type: Boolean
True if the matrices are identical; false otherwise
See Also

Reference

Matrix Structure
Equals Overload
VisualComponents.Create3D Namespace


Matrix.EqualsThreshold Method

MatrixEqualsThreshold Method

Overload List
 | Name | Description
Public method | EqualsThreshold(Matrix) |
Public method | EqualsThreshold(Matrix, Double) |
Top
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.EqualsThreshold Method (Matrix)

MatrixEqualsThreshold Method (Matrix)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool EqualsThreshold(
    Matrix matrix2
)
public:
bool EqualsThreshold(
    Matrix matrix2
)

Parameters

matrix2
Type: VisualComponents.Create3DMatrix

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.Matrix.EqualsThreshold(VisualComponents.Create3D.Matrix)"]

See Also

Reference

Matrix Structure
EqualsThreshold Overload
VisualComponents.Create3D Namespace


Matrix.EqualsThreshold Method (Matrix, Double)

MatrixEqualsThreshold Method (Matrix, Double)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool EqualsThreshold(
    Matrix matrix2,
    double threshold
)
public:
bool EqualsThreshold(
    Matrix matrix2,
    double threshold
)

Parameters

matrix2
Type: VisualComponents.Create3DMatrix
threshold
Type: SystemDouble

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.Matrix.EqualsThreshold(VisualComponents.Create3D.Matrix,System.Double)"]

See Also

Reference

Matrix Structure
EqualsThreshold Overload
VisualComponents.Create3D Namespace


Matrix.GetA Method

MatrixGetA Method

Gets Ax, Ay and Az values of this Matrix as a new Vector3 instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 GetA()
public:
Vector3 GetA()

Return Value

Type: Vector3
Ax, Ay and Az as a Vector
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.GetAxisAngle Method

MatrixGetAxisAngle Method

Returns the orientation of this Matrix as a rotation of the identity matrix about the axis defined by the (XYZ) values of the returned Vector3. The W value holds the rotation angle, in degrees.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 GetAxisAngle()
public:
Vector3 GetAxisAngle()

Return Value

Type: Vector3
Axis angle
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.GetEuler Method

MatrixGetEuler Method

Returns the orientation of this Matrix as a set of absolute rotations (around fixed coordinate system) about the Z axis followed by the Y axis and then the Z axis again, using angles stored in (XYZ) values of the returned Vector3, in degrees.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 GetEuler()
public:
Vector3 GetEuler()

Return Value

Type: Vector3
Euler orientation as a new Vector instance
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.GetHashCode Method

MatrixGetHashCode Method

Gets a hash code for this structure

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32
Hash code
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.GetMeanMatrix Method

MatrixGetMeanMatrix Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Matrix GetMeanMatrix(
    Matrix matrix1,
    Matrix matrix2
)
public:
static Matrix GetMeanMatrix(
    Matrix matrix1,
    Matrix matrix2
)

Parameters

matrix1
Type: VisualComponents.Create3DMatrix
matrix2
Type: VisualComponents.Create3DMatrix

Return Value

Type: Matrix

[Missing <returns> documentation for "M:VisualComponents.Create3D.Matrix.GetMeanMatrix(VisualComponents.Create3D.Matrix,VisualComponents.Create3D.Matrix)"]

See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.GetN Method

MatrixGetN Method

Gets Nx, Ny and Nz values of this as a new Vector3 instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 GetN()
public:
Vector3 GetN()

Return Value

Type: Vector3
Nx, Ny and Nz as a Vector
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.GetO Method

MatrixGetO Method

Gets Ox, Oy and Oz values of this Matrix as a new Vector3 instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 GetO()
public:
Vector3 GetO()

Return Value

Type: Vector3
Ox, Oy and Oz as a Vector
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.GetP Method

MatrixGetP Method

Gets Px, Py and Pz values of this Matrix as new Vector3 instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 GetP()
public:
Vector3 GetP()

Return Value

Type: Vector3
Px, Py, Pz as a Vector
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.GetQuaternion Method

MatrixGetQuaternion Method

Returns the orientation of this Matrix as an orientation quaternion, stored in (XYZW) values of the returned Vector3.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 GetQuaternion()
public:
Vector3 GetQuaternion()

Return Value

Type: Vector3
Quaternion as a new Vector3 instance
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.GetScale Method

MatrixGetScale Method

Gets the scaling factors of this Matrix as a new Vector3 instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 GetScale()
public:
Vector3 GetScale()

Return Value

Type: Vector3
Scaling factors as a new Vector3 instance
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.GetWPR Method

MatrixGetWPR Method

Overload List
 | Name | Description
Public method | GetWPR | Get or sets the orientation of this Matrix as a set of relative rotations about the Z axis followed by the Y axis and X axis using the angles stored in (XYZ) values of the returned Vector3, in degrees.
Public method | GetWPR(Int32) | Get or sets the orientation of this Matrix as a set of relative rotations about the Z axis followed by the Y axis and X axis using the angles stored in (XYZ) values of the returned Vector3, in degrees.
Top
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.GetWPR Method

MatrixGetWPR Method

Get or sets the orientation of this Matrix as a set of relative rotations about the Z axis followed by the Y axis and X axis using the angles stored in (XYZ) values of the returned Vector3, in degrees.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 GetWPR()
public:
Vector3 GetWPR()

Return Value

Type: Vector3
Orientation as WPR (yaw, pitch, roll) as a new Vector instance
See Also

Reference

Matrix Structure
GetWPR Overload
VisualComponents.Create3D Namespace


Matrix.GetWPR Method (Int32)

MatrixGetWPR Method (Int32)

Get or sets the orientation of this Matrix as a set of relative rotations about the Z axis followed by the Y axis and X axis using the angles stored in (XYZ) values of the returned Vector3, in degrees.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 GetWPR(
    int solution
)
public:
Vector3 GetWPR(
    int solution
)

Parameters

solution
Type: SystemInt32
WPR interpretation

Return Value

Type: Vector3
Orientation as WPR (yaw, pitch, roll) as a new Vector instance
See Also

Reference

Matrix Structure
GetWPR Overload
VisualComponents.Create3D Namespace


Matrix.Inverse Method

MatrixInverse Method

Returns a new inverted matrix.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Matrix Inverse()
public:
Matrix Inverse()

Return Value

Type: Matrix

[Missing <returns> documentation for "M:VisualComponents.Create3D.Matrix.Inverse"]

See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.Invert Method

MatrixInvert Method

Inverts this Matrix

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Invert()
public:
void Invert()
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.Multiply Method

MatrixMultiply Method

Multiplies the specified two Matrix structures

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Matrix Multiply(
    Matrix matrix1,
    Matrix matrix2
)
public:
static Matrix Multiply(
    Matrix matrix1,
    Matrix matrix2
)

Parameters

matrix1
Type: VisualComponents.Create3DMatrix
Matrix to multiply
matrix2
Type: VisualComponents.Create3DMatrix
Matrix by which the first matrix is multiplied

Return Value

Type: Matrix
Matrix that is the result of multiplication
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.Parse Method

MatrixParse Method

Converts string representation of a matrix to equivalent Matrix instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Matrix Parse(
    string source
)
public:
static Matrix Parse(
    String^ source
)

Parameters

source
Type: SystemString
String representation of the matrix

Return Value

Type: Matrix
Result matrix
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.RotateAbsX Method

MatrixRotateAbsX Method

Rotates this Matrix around the X-axis based in the absolute coordinate system.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RotateAbsX(
    double angle
)
public:
void RotateAbsX(
    double angle
)

Parameters

angle
Type: SystemDouble
Rotation
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.RotateAbsY Method

MatrixRotateAbsY Method

Rotates this Matrix around the Y-axis based in the absolute coordinate system

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RotateAbsY(
    double angle
)
public:
void RotateAbsY(
    double angle
)

Parameters

angle
Type: SystemDouble
Rotation
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.RotateAbsZ Method

MatrixRotateAbsZ Method

Rotates this Matrix around the Z-axis based in the absolute coordinate system

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RotateAbsZ(
    double angle
)
public:
void RotateAbsZ(
    double angle
)

Parameters

angle
Type: SystemDouble
Rotation
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.RotateAroundX Method

MatrixRotateAroundX Method

Rotates this Matrix around the X-axis based in the coordinate system relative to the matrix position

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RotateAroundX(
    double angle
)
public:
void RotateAroundX(
    double angle
)

Parameters

angle
Type: SystemDouble
Rotation
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.RotateAroundY Method

MatrixRotateAroundY Method

Rotates this Matrix around the Y-axis based in the coordinate system relative to the matrix position.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RotateAroundY(
    double angle
)
public:
void RotateAroundY(
    double angle
)

Parameters

angle
Type: SystemDouble
Rotation
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.RotateAroundZ Method

MatrixRotateAroundZ Method

Rotates this Matrix around the Z-axis based in the coordinate system relative to the matrix position.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RotateAroundZ(
    double angle
)
public:
void RotateAroundZ(
    double angle
)

Parameters

angle
Type: SystemDouble
Rotation
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.RotateAt Method

MatrixRotateAt Method

Rotate matrix by quaternion and at specified position.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RotateAt(
    Vector3 quaternion,
    Vector3 position
)
public:
void RotateAt(
    Vector3 quaternion,
    Vector3 position
)

Parameters

quaternion
Type: VisualComponents.Create3DVector3
position
Type: VisualComponents.Create3DVector3
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.ScaleAbs Method

MatrixScaleAbs Method

Scales this Matrix about the world origin

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ScaleAbs(
    Vector3 vector
)
public:
void ScaleAbs(
    Vector3 vector
)

Parameters

vector
Type: VisualComponents.Create3DVector3
Scaling factors as a Vector
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.ScaleRelative Method

MatrixScaleRelative Method

Scales this Matrix about the matrix position

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ScaleRelative(
    Vector3 vector
)
public:
void ScaleRelative(
    Vector3 vector
)

Parameters

vector
Type: VisualComponents.Create3DVector3
Scaling factors as a Vector
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.SetA Method

MatrixSetA Method

Sets Ax, Ay and Az values of this Matrix using the given Vector3

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetA(
    Vector3 a
)
public:
void SetA(
    Vector3 a
)

Parameters

a
Type: VisualComponents.Create3DVector3
Vector defining new Ax, Ay and Az values
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.SetAxisAngle Method

MatrixSetAxisAngle Method

Sets the axis and angle rotation of this Matrix. This representation uses two values: a unit vector (x,y,z) indicating the direction of a direct axis and an angle (w) describing the magnitude of the rotation about the axis.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetAxisAngle(
    Vector3 angle
)
public:
void SetAxisAngle(
    Vector3 angle
)

Parameters

angle
Type: VisualComponents.Create3DVector3
Axis angle to bet set
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.SetEuler Method

MatrixSetEuler Method

Sets the orientation of this Matrix as a set of absolute rotations (around fixed coordinate system) about the Z axis followed by the Y axis and then the Z axis again. All angles are given in degrees.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetEuler(
    Vector3 value
)
public:
void SetEuler(
    Vector3 value
)

Parameters

value
Type: VisualComponents.Create3DVector3
Orientation to be set
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.SetIdentity Method

MatrixSetIdentity Method

Converts this Matrix to identity matrix

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetIdentity()
public:
void SetIdentity()
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.SetIJK Method

MatrixSetIJK Method

Overload List
 | Name | Description
Public method | SetIJK(Vector3) | Sets the orientation of this Matrix so that the approach vector (Z-axis) is pointing to the given (I,J,K) vector direction, i.e. Z-axis aligned with vector
Public method | SetIJK(Double, Double, Double) | Sets the orientation of this Matrix so that the approach vector (Z-axis) is pointing to the given (I,J,K) vector direction, i.e. Z-axis aligned with vector
Top
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.SetIJK Method (Vector3)

MatrixSetIJK Method (Vector3)

Sets the orientation of this Matrix so that the approach vector (Z-axis) is pointing to the given (I,J,K) vector direction, i.e. Z-axis aligned with vector

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetIJK(
    Vector3 ijk
)
public:
void SetIJK(
    Vector3 ijk
)

Parameters

ijk
Type: VisualComponents.Create3DVector3
IJK values as a new Vector instance
See Also

Reference

Matrix Structure
SetIJK Overload
VisualComponents.Create3D Namespace


Matrix.SetIJK Method (Double, Double, Double)

MatrixSetIJK Method (Double, Double, Double)

Sets the orientation of this Matrix so that the approach vector (Z-axis) is pointing to the given (I,J,K) vector direction, i.e. Z-axis aligned with vector

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetIJK(
    double i,
    double j,
    double k
)
public:
void SetIJK(
    double i,
    double j,
    double k
)

Parameters

i
Type: SystemDouble
j
Type: SystemDouble
k
Type: SystemDouble
See Also

Reference

Matrix Structure
SetIJK Overload
VisualComponents.Create3D Namespace


Matrix.SetN Method

MatrixSetN Method

Sets the Nx, Ny and Nz values of this Matrix using the given Vector3

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetN(
    Vector3 n
)
public:
void SetN(
    Vector3 n
)

Parameters

n
Type: VisualComponents.Create3DVector3
Vector defining new Nx, Ny and Nz values
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.SetO Method

MatrixSetO Method

Sets Ox, Oy and Oz values of this Matrix using the given Vector3

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetO(
    Vector3 o
)
public:
void SetO(
    Vector3 o
)

Parameters

o
Type: VisualComponents.Create3DVector3
Vector defining new Ox, Oy and Oz values
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.SetP Method

MatrixSetP Method

Sets Px, Py and Pz values of this Matrix using the given Vector3

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetP(
    Vector3 p
)
public:
void SetP(
    Vector3 p
)

Parameters

p
Type: VisualComponents.Create3DVector3
Vector defining new Px, Py and Pz values
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.SetQuaternion Method

MatrixSetQuaternion Method

Set the orientation of this Matrix using an orientation quaternion. Note: X-component of Vector3 is W-component of quaternion.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetQuaternion(
    Vector3 value
)
public:
void SetQuaternion(
    Vector3 value
)

Parameters

value
Type: VisualComponents.Create3DVector3
Orientation to be set
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.SetWPR Method

MatrixSetWPR Method

Set the orientation of this Matrix using the specified yaw, pitch, and roll values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetWPR(
    Vector3 value
)
public:
void SetWPR(
    Vector3 value
)

Parameters

value
Type: VisualComponents.Create3DVector3
Orientation to be set
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.ToMedia3D Method

MatrixToMedia3D Method

Returns the specified Matrix as a new Matrix3D structure

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Matrix3D ToMedia3D(
    Matrix matrix
)
public:
static Matrix3D ToMedia3D(
    Matrix matrix
)

Parameters

matrix
Type: VisualComponents.Create3DMatrix
Matrix to be converted

Return Value

Type: Matrix3D
Matrix as a new System.Windows.Media.Media3D.Matrix3D structure
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.ToString Method

MatrixToString Method

Creates a string representation of this Matrix

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String
String representation of the matrix
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.Transform Method

MatrixTransform Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Vector3 Transform(
    Matrix matrix,
    Vector3 vector
)
public:
static Vector3 Transform(
    Matrix matrix,
    Vector3 vector
)

Parameters

matrix
Type: VisualComponents.Create3DMatrix
vector
Type: VisualComponents.Create3DVector3

Return Value

Type: Vector3

[Missing <returns> documentation for "M:VisualComponents.Create3D.Matrix.Transform(VisualComponents.Create3D.Matrix,VisualComponents.Create3D.Vector3)"]

See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.TranslateAbs Method

MatrixTranslateAbs Method

Translates the position of this Matrix by the given offset in the world coordinate system

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void TranslateAbs(
    Vector3 vector
)
public:
void TranslateAbs(
    Vector3 vector
)

Parameters

vector
Type: VisualComponents.Create3DVector3
Translation as a Vector
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.TranslateRelative Method

MatrixTranslateRelative Method

Overload List
 | Name | Description
Public method | TranslateRelative(Vector3) | Translates the position of this Matrix by the given offset in the matrix coordinate system
Public method | TranslateRelative(Double, Double, Double) | Translates the position of this Matrix by the given offset in the matrix coordinate system
Top
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.TranslateRelative Method (Vector3)

MatrixTranslateRelative Method (Vector3)

Translates the position of this Matrix by the given offset in the matrix coordinate system

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void TranslateRelative(
    Vector3 vector
)
public:
void TranslateRelative(
    Vector3 vector
)

Parameters

vector
Type: VisualComponents.Create3DVector3
Translation as a Vector
See Also

Reference

Matrix Structure
TranslateRelative Overload
VisualComponents.Create3D Namespace


Matrix.TranslateRelative Method (Double, Double, Double)

MatrixTranslateRelative Method (Double, Double, Double)

Translates the position of this Matrix by the given offset in the matrix coordinate system

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void TranslateRelative(
    double offsetX,
    double offsetY,
    double offsetZ
)
public:
void TranslateRelative(
    double offsetX,
    double offsetY,
    double offsetZ
)

Parameters

offsetX
Type: SystemDouble
offsetY
Type: SystemDouble
offsetZ
Type: SystemDouble
See Also

Reference

Matrix Structure
TranslateRelative Overload
VisualComponents.Create3D Namespace


Matrix.Uniform Method

MatrixUniform Method

To make sure this Matrix is orthogonal and contains no scaling

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Uniform()
public:
void Uniform()
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.UniformZ Method

MatrixUniformZ Method

Uniforms matrix m so that Z axis (A) retains its direction. Thes second most important axis is X (N).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void UniformZ()
public:
void UniformZ()
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix Operators and Type Conversions

The Matrix type exposes the following members.

Operators
Name | Description
Equality | Compares two Matrix structures for equality
(Matrix3D to Matrix) | Converts the Matrix3D structure to a new Matrix
(Matrix to Matrix3D) | Converts the Matrix to a new Matrix3D structure
Inequality | Compares two Matrix structures for inequality
Multiply | Multiplies two Matrix structures
Top
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.Equality Operator

MatrixEquality Operator

Compares two Matrix structures for equality

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    Matrix matrix1,
    Matrix matrix2
)
public:
static bool operator ==(
    Matrix matrix1,
    Matrix matrix2
)

Parameters

matrix1
Type: VisualComponents.Create3DMatrix
The first matrix
matrix2
Type: VisualComponents.Create3DMatrix
The second matrix

Return Value

Type: Boolean
True if the matrices are identical; false otherwise
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix Explicit Conversion Operators

Matrix Conversion Operators

Overload List
Name | Description
(Matrix3D to Matrix) | Converts the Matrix3D structure to a new Matrix
(Matrix to Matrix3D) | Converts the Matrix to a new Matrix3D structure
Top
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix Explicit Conversion (Matrix3D to Matrix)

Matrix Conversion (Matrix3D to Matrix)

Converts the Matrix3D structure to a new Matrix

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static explicit operator Matrix (
    Matrix3D matrix3D
)
static explicit operator Matrix (
    Matrix3D matrix3D
)

Parameters

matrix3D
Type: System.Windows.Media.Media3DMatrix3D
Matrix3D to convert

Return Value

Type: Matrix
Result of the conversion as a Matrix
See Also

Reference

Matrix Structure
Overload
VisualComponents.Create3D Namespace


Matrix Explicit Conversion (Matrix to Matrix3D)

Matrix Conversion (Matrix to Matrix3D)

Converts the Matrix to a new Matrix3D structure

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static explicit operator Matrix3D (
    Matrix matrix
)
static explicit operator Matrix3D (
    Matrix matrix
)

Parameters

matrix
Type: VisualComponents.Create3DMatrix
Matrix to convert

Return Value

Type: Matrix3D
Result of the conversion as a System.Windows.Media.Media3D.Matrix3D
See Also

Reference

Matrix Structure
Overload
VisualComponents.Create3D Namespace


Matrix.Inequality Operator

MatrixInequality Operator

Compares two Matrix structures for inequality

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    Matrix matrix1,
    Matrix matrix2
)
public:
static bool operator !=(
    Matrix matrix1,
    Matrix matrix2
)

Parameters

matrix1
Type: VisualComponents.Create3DMatrix
The first matrix
matrix2
Type: VisualComponents.Create3DMatrix
The second matrix

Return Value

Type: Boolean
True if the matrices are inequal, false otherwise
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix.Multiply Operator

MatrixMultiply Operator

Multiplies two Matrix structures

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Matrix operator *(
    Matrix matrix1,
    Matrix matrix2
)
public:
static Matrix operator *(
    Matrix matrix1,
    Matrix matrix2
)

Parameters

matrix1
Type: VisualComponents.Create3DMatrix
Matrix to multiply
matrix2
Type: VisualComponents.Create3DMatrix
Matrix by which the first one is multiplied

Return Value

Type: Matrix
Matrix that is the result of multiplication
See Also

Reference

Matrix Structure
VisualComponents.Create3D Namespace


Matrix3DExtension Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DMatrix3DExtension

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class Matrix3DExtension
[ExtensionAttribute]
public ref class Matrix3DExtension abstract sealed

The Matrix3DExtension type exposes the following members.

Methods
Name | Description
FromYawPitchRollVector |
ToYawPitchRollVector | Get Yaw-Pitch-Roll vector.
Top
See Also

Reference

VisualComponents.Create3D Namespace


Matrix3DExtension Methods

The Matrix3DExtension type exposes the following members.

Methods
Name | Description
FromYawPitchRollVector |
ToYawPitchRollVector | Get Yaw-Pitch-Roll vector.
Top
See Also

Reference

Matrix3DExtension Class
VisualComponents.Create3D Namespace


Matrix3DExtension.FromYawPitchRollVector Method

Matrix3DExtensionFromYawPitchRollVector Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Matrix3D FromYawPitchRollVector(
    this Matrix3D matrix,
    Vector3D yprVector
)
public:
[ExtensionAttribute]
static Matrix3D FromYawPitchRollVector(
    Matrix3D matrix,
    Vector3D yprVector
)

Parameters

matrix
Type: System.Windows.Media.Media3DMatrix3D
yprVector
Type: System.Windows.Media.Media3DVector3D

Return Value

Type: Matrix3D

[Missing <returns> documentation for "M:VisualComponents.Create3D.Matrix3DExtension.FromYawPitchRollVector(System.Windows.Media.Media3D.Matrix3D,System.Windows.Media.Media3D.Vector3D)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Matrix3D. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Matrix3DExtension Class
VisualComponents.Create3D Namespace


Matrix3DExtension.ToYawPitchRollVector Method

Matrix3DExtensionToYawPitchRollVector Method

Get Yaw-Pitch-Roll vector.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Vector3D ToYawPitchRollVector(
    this Matrix3D matrix
)
public:
[ExtensionAttribute]
static Vector3D ToYawPitchRollVector(
    Matrix3D matrix
)

Parameters

matrix
Type: System.Windows.Media.Media3DMatrix3D

Return Value

Type: Vector3D

[Missing <returns> documentation for "M:VisualComponents.Create3D.Matrix3DExtension.ToYawPitchRollVector(System.Windows.Media.Media3D.Matrix3D)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Matrix3D. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Matrix3DExtension Class
VisualComponents.Create3D Namespace


MessageAddedEventArgs Class

Event data for MessageAdded event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DMessageAddedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class MessageAddedEventArgs : EventArgs
public ref class MessageAddedEventArgs : public EventArgs

The MessageAddedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | MessageAddedEventArgs | Initializes a new instance of the MessageAddedEventArgs class.
Top
Properties
 | Name | Description
Public property | Message | Gets the message that has been added.
Public property | MessageLevel | Gets the message level.
Public property | WriteToLog | Write message to the log file. Enabled by default.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


MessageAddedEventArgs Constructor

Initializes a new instance of the MessageAddedEventArgs class.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MessageAddedEventArgs(
    string message,
    MessageLevel messageLevel,
    bool writeToLog
)
public:
MessageAddedEventArgs(
    String^ message,
    MessageLevel messageLevel,
    bool writeToLog
)

Parameters

message
Type: SystemString
Message.
messageLevel
Type: VisualComponents.Create3DMessageLevel
Message level.
writeToLog
Type: SystemBoolean
See Also

Reference

MessageAddedEventArgs Class
VisualComponents.Create3D Namespace


MessageAddedEventArgs Properties

The MessageAddedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Message | Gets the message that has been added.
Public property | MessageLevel | Gets the message level.
Public property | WriteToLog | Write message to the log file. Enabled by default.
Top
See Also

Reference

MessageAddedEventArgs Class
VisualComponents.Create3D Namespace


MessageAddedEventArgs.Message Property

MessageAddedEventArgsMessage Property

Gets the message that has been added.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Message { get; }
public:
property String^ Message {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

MessageAddedEventArgs Class
VisualComponents.Create3D Namespace


MessageAddedEventArgs.MessageLevel Property

MessageAddedEventArgsMessageLevel Property

Gets the message level.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MessageLevel MessageLevel { get; }
public:
property MessageLevel MessageLevel {
    MessageLevel get ();
}

Property Value

Type: MessageLevel
See Also

Reference

MessageAddedEventArgs Class
VisualComponents.Create3D Namespace


MessageAddedEventArgs.WriteToLog Property

MessageAddedEventArgsWriteToLog Property

Write message to the log file. Enabled by default.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool WriteToLog { get; }
public:
property bool WriteToLog {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

MessageAddedEventArgs Class
VisualComponents.Create3D Namespace


MessageAddedEventArgs Methods

The MessageAddedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MessageAddedEventArgs Class
VisualComponents.Create3D Namespace


MessageLevel Enumeration

Message level.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum MessageLevel
public enum class MessageLevel
Members
Member name | Value | Description
Debug | 0 |
Info | 1 |
Error | 2 |
Warning | 3 |
See Also

Reference

VisualComponents.Create3D Namespace


MethodChange(TTarget) Class

MethodChangeTTarget Class

MethodChange contains information about a change that requires a method call.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DChange
VisualComponents.Create3DMethodChangeTTarget

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class MethodChange<TTarget> : Change

generic<typename TTarget>
public ref class MethodChange sealed : public Change

Type Parameters

TTarget

The MethodChangeTTarget type exposes the following members.

Constructors
 | Name | Description
Public method | MethodChangeTTarget | Initializes a new instance of a method change object.
Top
Properties
 | Name | Description
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from Change.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


MethodChange(TTarget) Constructor

MethodChangeTTarget Constructor

Initializes a new instance of a method change object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MethodChange(
    TTarget target,
    Action<TTarget> redoMethod,
    Action<TTarget> undoMethod
)
public:
MethodChange(
    TTarget target,
    Action<TTarget>^ redoMethod,
    Action<TTarget>^ undoMethod
)

Parameters

target
Type: TTarget
Target object for this change.
redoMethod
Type: SystemActionTTarget
undoMethod
Type: SystemActionTTarget
See Also

Reference

MethodChangeTTarget Class
VisualComponents.Create3D Namespace


MethodChange(TTarget) Properties

MethodChangeTTarget Properties

The MethodChangeTTarget generic type exposes the following members.

Properties
 | Name | Description
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Top
See Also

Reference

MethodChangeTTarget Class
VisualComponents.Create3D Namespace


MethodChange(TTarget) Methods

MethodChangeTTarget Methods

The MethodChangeTTarget generic type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from Change.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MethodChangeTTarget Class
VisualComponents.Create3D Namespace


MotionPathDirection Enumeration

Motion path directions.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum MotionPathDirection
public enum class MotionPathDirection
Members
Member name | Value | Description
Forward | 0 | Conveyor contents are moved forwards from the first frame to the last frame.
Backward | 1 | Conveyor contents are moved backwards from the last frame to the first frame.
ForwardAuto | 2 | Similar to Forward. However, the conveyor automatically changes direction to BackwardAuto if a component is transferred in from the conveyor's second connector (InOut2).
BackwardAuto | 3 | Similar to Backward. However, the conveyor automatically changes direction to ForwardAuto if a component is transferred in from the conveyor's first connector (InOut1).
See Also

Reference

VisualComponents.Create3D Namespace


MotionPathInterpolation Enumeration

Motion path interpolation

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum MotionPathInterpolation
public enum class MotionPathInterpolation
Members
Member name | Value | Description
None | 0 | Undefined.
Step | 1 | No interpolation is performed between frames, so a component's position changes from one frame to the next without any movement in between frames.
Linear | 2 | The path is interpolated as straight lines between the frames.
Cubic | 3 | A cubic spline is used to interpolate the path from one frame to the next.
See Also

Reference

VisualComponents.Create3D Namespace


MotionType Enumeration

Interpolation type: point-to-point or linear.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum MotionType
public enum class MotionType
Members
Member name | Value | Description
Joint | 0 | Interpolating joints.
Linear | 1 | Interpolating 3D position.
See Also

Reference

VisualComponents.Create3D Namespace


MouseInteractionType Enumeration

Defines the type of interaction on an interactive node.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum MouseInteractionType
public enum class MouseInteractionType
Members
Member name | Value | Description
None | 0 | None.
Pressed | 1 | Mouse pressed.
Released | 2 | Mouse released.
HoverIn | 3 | Mouse hover in.
HoverOut | 4 | Mouse hover out.
See Also

Reference

VisualComponents.Create3D Namespace


NameChangedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DNameChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NameChangedEventArgs : EventArgs
public ref class NameChangedEventArgs : public EventArgs

The NameChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | NameChangedEventArgs | Initializes a new instance of the NameChangedEventArgs class.
Top
Properties
 | Name | Description
Public property | NewValue | Gets the new name.
Public property | OldValue | Gets the old name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


NameChangedEventArgs Constructor

Initializes a new instance of the NameChangedEventArgs class.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NameChangedEventArgs(
    string oldValue,
    string newValue
)
public:
NameChangedEventArgs(
    String^ oldValue,
    String^ newValue
)

Parameters

oldValue
Type: SystemString
Old Value.
newValue
Type: SystemString
New Value.
See Also

Reference

NameChangedEventArgs Class
VisualComponents.Create3D Namespace


NameChangedEventArgs Properties

The NameChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets the new name.
Public property | OldValue | Gets the old name.
Top
See Also

Reference

NameChangedEventArgs Class
VisualComponents.Create3D Namespace


NameChangedEventArgs.NewValue Property

NameChangedEventArgsNewValue Property

Gets the new name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string NewValue { get; }
public:
property String^ NewValue {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

NameChangedEventArgs Class
VisualComponents.Create3D Namespace


NameChangedEventArgs.OldValue Property

NameChangedEventArgsOldValue Property

Gets the old name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string OldValue { get; }
public:
property String^ OldValue {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

NameChangedEventArgs Class
VisualComponents.Create3D Namespace


NameChangedEventArgs Methods

The NameChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NameChangedEventArgs Class
VisualComponents.Create3D Namespace


NativeConfigCollection Class

Configuration file element collection for native options.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationElementCollection
VisualComponents.Create3DNativeConfigCollection

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NativeConfigCollection : ConfigurationElementCollection
public ref class NativeConfigCollection : public ConfigurationElementCollection

The NativeConfigCollection type exposes the following members.

Constructors
 | Name | Description
Public method | NativeConfigCollection | Initializes a new instance of the NativeConfigCollection class
Top
Properties
 | Name | Description
Protected property | AddElementName | Gets or sets the name of the ConfigurationElement to associate with the add operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected property | ClearElementName | Gets or sets the name for the ConfigurationElement to associate with the clear operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementName | Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is . (Inherited from ConfigurationElement.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Public property | ItemInt32 | Gets item by index.
Public property | ItemString | Gets item by key.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Protected property | RemoveElementName | Gets or sets the name of the ConfigurationElement to associate with the remove operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected property | ThrowOnDuplicate | Gets a value indicating whether an attempt to add a duplicate ConfigurationElement to the ConfigurationElementCollection will cause an exception to be thrown. (Inherited from ConfigurationElementCollection.)
Top
Methods
 | Name | Description
Public method | Add | Adds item to this collection.
Protected method | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseClear | Removes all configuration element objects from the collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGet(Object) | Returns the configuration element with the specified key. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGet(Int32) | Gets the configuration element at the specified index location. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGetAllKeys | Returns an array of the keys for all of the configuration elements contained in the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGetKey | Gets the key for the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
Protected method | BaseIndexOf | Indicates the index of the specified ConfigurationElement. (Inherited from ConfigurationElementCollection.)
Protected method | BaseIsRemoved | Indicates whether the ConfigurationElement with the specified key has been removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseRemove | Removes a ConfigurationElement from the collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseRemoveAt | Removes the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
Public method | Clear | Clears collection.
Public method | Contains | Returns a value indicating whether the container contains a specified key.
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Protected method | CreateNewElement | Creates new configuration element. (Overrides ConfigurationElementCollectionCreateNewElement.)
Protected method | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetElementKey | Returns the key of specified configuration element. (Overrides ConfigurationElementCollectionGetElementKey(ConfigurationElement).)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsElementName | Indicates whether the specified ConfigurationElement exists in the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | IsElementRemovable | Indicates whether the specified ConfigurationElement can be removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | IsModified | Indicates whether this ConfigurationElementCollection has been modified since it was last saved or loaded when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Causes the configuration system to throw an exception. (Inherited from ConfigurationElementCollection.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Public method | Remove | Removes item from this collection.
Protected method | Reset | Resets the ConfigurationElementCollection to its unmodified state when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | ResetModified | Resets the value of the IsModified property to when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | SerializeElement | Writes the configuration data to an XML element in the configuration file when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElementCollection object and for all sub-elements. (Inherited from ConfigurationElementCollection.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Reverses the effect of merging configuration information from different levels of the configuration hierarchy (Inherited from ConfigurationElementCollection.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


NativeConfigCollection Constructor

Initializes a new instance of the NativeConfigCollection class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NativeConfigCollection()
public:
NativeConfigCollection()
See Also

Reference

NativeConfigCollection Class
VisualComponents.Create3D Namespace


NativeConfigCollection Properties

The NativeConfigCollection type exposes the following members.

Properties
 | Name | Description
Protected property | AddElementName | Gets or sets the name of the ConfigurationElement to associate with the add operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected property | ClearElementName | Gets or sets the name for the ConfigurationElement to associate with the clear operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementName | Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is . (Inherited from ConfigurationElement.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Public property | ItemInt32 | Gets item by index.
Public property | ItemString | Gets item by key.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Protected property | RemoveElementName | Gets or sets the name of the ConfigurationElement to associate with the remove operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected property | ThrowOnDuplicate | Gets a value indicating whether an attempt to add a duplicate ConfigurationElement to the ConfigurationElementCollection will cause an exception to be thrown. (Inherited from ConfigurationElementCollection.)
Top
See Also

Reference

NativeConfigCollection Class
VisualComponents.Create3D Namespace


NativeConfigCollection.Item Property

NativeConfigCollectionItem Property

Overload List
 | Name | Description
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Public property | ItemInt32 | Gets item by index.
Public property | ItemString | Gets item by key.
Top
See Also

Reference

NativeConfigCollection Class
VisualComponents.Create3D Namespace


NativeConfigCollection.Item Property (Int32)

NativeConfigCollectionItem Property (Int32)

Gets item by index.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NativeConfigElement this[
    int index
] { get; }
public:
property NativeConfigElement^ default[int index] {
    NativeConfigElement^ get (int index);
}

Parameters

index
Type: SystemInt32

Property Value

Type: NativeConfigElement
See Also

Reference

NativeConfigCollection Class
Item Overload
VisualComponents.Create3D Namespace


NativeConfigCollection.Item Property (String)

NativeConfigCollectionItem Property (String)

Gets item by key.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NativeConfigElement this[
    string key
] { get; set; }
public:
property NativeConfigElement^ default[String^ key] {
    NativeConfigElement^ get (String^ key);
    void set (String^ key, NativeConfigElement^ value);
}

Parameters

key
Type: SystemString

Property Value

Type: NativeConfigElement
See Also

Reference

NativeConfigCollection Class
Item Overload
VisualComponents.Create3D Namespace


NativeConfigCollection Methods

The NativeConfigCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds item to this collection.
Protected method | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseClear | Removes all configuration element objects from the collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGet(Object) | Returns the configuration element with the specified key. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGet(Int32) | Gets the configuration element at the specified index location. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGetAllKeys | Returns an array of the keys for all of the configuration elements contained in the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGetKey | Gets the key for the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
Protected method | BaseIndexOf | Indicates the index of the specified ConfigurationElement. (Inherited from ConfigurationElementCollection.)
Protected method | BaseIsRemoved | Indicates whether the ConfigurationElement with the specified key has been removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseRemove | Removes a ConfigurationElement from the collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseRemoveAt | Removes the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
Public method | Clear | Clears collection.
Public method | Contains | Returns a value indicating whether the container contains a specified key.
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Protected method | CreateNewElement | Creates new configuration element. (Overrides ConfigurationElementCollectionCreateNewElement.)
Protected method | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetElementKey | Returns the key of specified configuration element. (Overrides ConfigurationElementCollectionGetElementKey(ConfigurationElement).)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsElementName | Indicates whether the specified ConfigurationElement exists in the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | IsElementRemovable | Indicates whether the specified ConfigurationElement can be removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | IsModified | Indicates whether this ConfigurationElementCollection has been modified since it was last saved or loaded when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Causes the configuration system to throw an exception. (Inherited from ConfigurationElementCollection.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Public method | Remove | Removes item from this collection.
Protected method | Reset | Resets the ConfigurationElementCollection to its unmodified state when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | ResetModified | Resets the value of the IsModified property to when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | SerializeElement | Writes the configuration data to an XML element in the configuration file when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElementCollection object and for all sub-elements. (Inherited from ConfigurationElementCollection.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Reverses the effect of merging configuration information from different levels of the configuration hierarchy (Inherited from ConfigurationElementCollection.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NativeConfigCollection Class
VisualComponents.Create3D Namespace


NativeConfigCollection.Add Method

NativeConfigCollectionAdd Method

Adds item to this collection.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Add(
    NativeConfigElement configItem
)
public:
void Add(
    NativeConfigElement^ configItem
)

Parameters

configItem
Type: VisualComponents.Create3DNativeConfigElement
See Also

Reference

NativeConfigCollection Class
VisualComponents.Create3D Namespace


NativeConfigCollection.Clear Method

NativeConfigCollectionClear Method

Clears collection.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Clear()
public:
void Clear()
See Also

Reference

NativeConfigCollection Class
VisualComponents.Create3D Namespace


NativeConfigCollection.Contains Method

NativeConfigCollectionContains Method

Returns a value indicating whether the container contains a specified key.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Contains(
    string key
)
public:
bool Contains(
    String^ key
)

Parameters

key
Type: SystemString

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.NativeConfigCollection.Contains(System.String)"]

See Also

Reference

NativeConfigCollection Class
VisualComponents.Create3D Namespace


NativeConfigCollection.CreateNewElement Method

NativeConfigCollectionCreateNewElement Method

Overload List
 | Name | Description
Protected method | CreateNewElement | Creates new configuration element. (Overrides ConfigurationElementCollectionCreateNewElement.)
Protected method | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Top
See Also

Reference

NativeConfigCollection Class
VisualComponents.Create3D Namespace


NativeConfigCollection.CreateNewElement Method

NativeConfigCollectionCreateNewElement Method

Creates new configuration element.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override ConfigurationElement CreateNewElement()
protected:
virtual ConfigurationElement^ CreateNewElement() override

Return Value

Type: ConfigurationElement

[Missing <returns> documentation for "M:VisualComponents.Create3D.NativeConfigCollection.CreateNewElement"]

See Also

Reference

NativeConfigCollection Class
CreateNewElement Overload
VisualComponents.Create3D Namespace


NativeConfigCollection.GetElementKey Method

NativeConfigCollectionGetElementKey Method

Returns the key of specified configuration element.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Object GetElementKey(
    ConfigurationElement element
)
protected:
virtual Object^ GetElementKey(
    ConfigurationElement^ element
) override

Parameters

element
Type: System.ConfigurationConfigurationElement
Specified configuration element

Return Value

Type: Object
Key of specified configuration element
See Also

Reference

NativeConfigCollection Class
VisualComponents.Create3D Namespace


NativeConfigCollection.Remove Method

NativeConfigCollectionRemove Method

Removes item from this collection.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Remove(
    string name
)
public:
void Remove(
    String^ name
)

Parameters

name
Type: SystemString
See Also

Reference

NativeConfigCollection Class
VisualComponents.Create3D Namespace


NativeConfigElement Class

Configuration file element for native options.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.Create3DNativeConfigElement

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NativeConfigElement : ConfigurationElement
public ref class NativeConfigElement : public ConfigurationElement

The NativeConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | NativeConfigElement | Constructor.
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is . (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | Key | Native option id.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | Value | Native option value.
Top
Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


NativeConfigElement Constructor

Constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NativeConfigElement()
public:
NativeConfigElement()
See Also

Reference

NativeConfigElement Class
VisualComponents.Create3D Namespace


NativeConfigElement Properties

The NativeConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is . (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | Key | Native option id.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | Value | Native option value.
Top
See Also

Reference

NativeConfigElement Class
VisualComponents.Create3D Namespace


NativeConfigElement.Key Property

NativeConfigElementKey Property

Native option id.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Key { get; set; }
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

NativeConfigElement Class
VisualComponents.Create3D Namespace


NativeConfigElement.Value Property

NativeConfigElementValue Property

Native option value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Value { get; set; }
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

NativeConfigElement Class
VisualComponents.Create3D Namespace


NativeConfigElement Methods

The NativeConfigElement type exposes the following members.

Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NativeConfigElement Class
VisualComponents.Create3D Namespace


NativeSection Class

Configuration file section for native options.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationSection
VisualComponents.Create3DNativeSection

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NativeSection : ConfigurationSection,
    INativeSection, ISection
public ref class NativeSection : public ConfigurationSection,
    INativeSection, ISection

The NativeSection type exposes the following members.

Constructors
 | Name | Description
Public method | NativeSection | Constructor.
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is . (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName | Section's name in configuration file.
Public property | SectionType | Interface type.
Public property | SectionVersion | Section's version number.
Top
Methods
 | Name | Description
Public method | CheckVersion | Upgrade configuration to the latest version.
Public method | Contains | Determines whether an element is in the NativeConfigElement.
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Protected method | DeserializeSection | Reads XML from the configuration file. (Inherited from ConfigurationSection.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetRuntimeObject | Returns a custom object when overridden in a derived class. (Inherited from ConfigurationSection.)
Public method | GetSection | Finds typed section by name.
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserValue | Gets configuration file element for native option.
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded when implemented in a derived class. (Inherited from ConfigurationSection.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to when implemented in a derived class. (Inherited from ConfigurationSection.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeSection | Creates an XML string containing an unmerged view of the ConfigurationSection object as a single section to write to a file. (Inherited from ConfigurationSection.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Protected method | ShouldSerializeElementInTargetVersion | Indicates whether the specified element should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Inherited from ConfigurationSection.)
Protected method | ShouldSerializePropertyInTargetVersion | Indicates whether the specified property should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Inherited from ConfigurationSection.)
Protected method | ShouldSerializeSectionInTargetVersion | Indicates whether the current ConfigurationSection instance should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Inherited from ConfigurationSection.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


NativeSection Constructor

Constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NativeSection()
public:
NativeSection()
See Also

Reference

NativeSection Class
VisualComponents.Create3D Namespace


NativeSection Properties

The NativeSection type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is . (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName | Section's name in configuration file.
Public property | SectionType | Interface type.
Public property | SectionVersion | Section's version number.
Top
See Also

Reference

NativeSection Class
VisualComponents.Create3D Namespace


NativeSection.SectionName Property

NativeSectionSectionName Property

Section's name in configuration file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SectionName { get; }
public:
virtual property String^ SectionName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ISectionSectionName
See Also

Reference

NativeSection Class
VisualComponents.Create3D Namespace


NativeSection.SectionType Property

NativeSectionSectionType Property

Interface type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type SectionType { get; }
public:
virtual property Type^ SectionType {
    Type^ get () sealed;
}

Property Value

Type: Type

Implements

ISectionSectionType
See Also

Reference

NativeSection Class
VisualComponents.Create3D Namespace


NativeSection.SectionVersion Property

NativeSectionSectionVersion Property

Section's version number.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int SectionVersion { get; protected set; }
public:
virtual property int SectionVersion {
    int get () sealed;
    protected: void set (int value) sealed;
}

Property Value

Type: Int32

Implements

ISectionSectionVersion
See Also

Reference

NativeSection Class
VisualComponents.Create3D Namespace


NativeSection Methods

The NativeSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion | Upgrade configuration to the latest version.
Public method | Contains | Determines whether an element is in the NativeConfigElement.
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Protected method | DeserializeSection | Reads XML from the configuration file. (Inherited from ConfigurationSection.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetRuntimeObject | Returns a custom object when overridden in a derived class. (Inherited from ConfigurationSection.)
Public method | GetSection | Finds typed section by name.
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserValue | Gets configuration file element for native option.
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded when implemented in a derived class. (Inherited from ConfigurationSection.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to when implemented in a derived class. (Inherited from ConfigurationSection.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeSection | Creates an XML string containing an unmerged view of the ConfigurationSection object as a single section to write to a file. (Inherited from ConfigurationSection.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Protected method | ShouldSerializeElementInTargetVersion | Indicates whether the specified element should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Inherited from ConfigurationSection.)
Protected method | ShouldSerializePropertyInTargetVersion | Indicates whether the specified property should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Inherited from ConfigurationSection.)
Protected method | ShouldSerializeSectionInTargetVersion | Indicates whether the current ConfigurationSection instance should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Inherited from ConfigurationSection.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NativeSection Class
VisualComponents.Create3D Namespace


NativeSection.CheckVersion Method

NativeSectionCheckVersion Method

Upgrade configuration to the latest version.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CheckVersion()
public:
virtual void CheckVersion() sealed

Implements

ISectionCheckVersion
See Also

Reference

NativeSection Class
VisualComponents.Create3D Namespace


NativeSection.Contains Method

NativeSectionContains Method

Determines whether an element is in the NativeConfigElement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Contains(
    string key
)
public:
virtual bool Contains(
    String^ key
) sealed

Parameters

key
Type: SystemString
Native option key

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.NativeSection.Contains(System.String)"]

Implements

INativeSectionContains(String)
See Also

Reference

NativeSection Class
VisualComponents.Create3D Namespace


NativeSection.GetSection Method

NativeSectionGetSection Method

Finds typed section by name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISection GetSection(
    Configuration userSettingConfiguration
)
public:
virtual ISection^ GetSection(
    Configuration^ userSettingConfiguration
) sealed

Parameters

userSettingConfiguration
Type: System.ConfigurationConfiguration

Return Value

Type: ISection

[Missing <returns> documentation for "M:VisualComponents.Create3D.NativeSection.GetSection(System.Configuration.Configuration)"]

Implements

ISectionGetSection(Configuration)
See Also

Reference

NativeSection Class
VisualComponents.Create3D Namespace


NativeSection.GetUserValue Method

NativeSectionGetUserValue Method

Gets configuration file element for native option.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NativeConfigElement GetUserValue(
    string key
)
public:
virtual NativeConfigElement^ GetUserValue(
    String^ key
) sealed

Parameters

key
Type: SystemString

Return Value

Type: NativeConfigElement

[Missing <returns> documentation for "M:VisualComponents.Create3D.NativeSection.GetUserValue(System.String)"]

Implements

INativeSectionGetUserValue(String)
See Also

Reference

NativeSection Class
VisualComponents.Create3D Namespace


NativeSection.ToString Method

NativeSectionToString Method

Converts this instance to string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String
String representation of this instance
See Also

Reference

NativeSection Class
VisualComponents.Create3D Namespace


NodeEntryScope Enumeration

Defines the scope of NodeListEntry.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum NodeEntryScope
public enum class NodeEntryScope
Members
Member name | Value | Description
Node | 0 | Only the value of SimNode is included in the node list.
Component | 1 | Value of SimNode and any subnodes within the same component are included in the node list.
Tree | 2 | Value of SimNode and any subnodes regardless of component boundaries are included in the node list.
See Also

Reference

VisualComponents.Create3D Namespace


NodeEntryType Enumeration

Defines the type of NodeListEntry.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum NodeEntryType
public enum class NodeEntryType
Members
Member name | Value | Description
Include | 0 | Nodes included in the entry are included in the node list.
Exclude | 1 | Nodes included in the entry are excluded from the node list.
See Also

Reference

VisualComponents.Create3D Namespace


NodeFeatureList Class

Class that associates a node to the list of features.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DNodeFeatureList

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NodeFeatureList
public ref class NodeFeatureList

The NodeFeatureList type exposes the following members.

Constructors
 | Name | Description
Public method | NodeFeatureList(ISimNode) | Constructor.
Public method | NodeFeatureList(ISimNode, IEnumerableIFeature) | Constructor
Top
Properties
 | Name | Description
Public property | Features | Gets the features.
Public property | Node | Gets the node for which the features are associated to.
Top
Methods
 | Name | Description
Public method | AddFeature | Adds a new feature to this NodeFeatureList.
Public method | ContainsFeature | Checks if feature is contained in the list.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindFeature | Finds first feature that matches the custom check.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveFeature | Removes the feature from this NodeFeatureList.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


NodeFeatureList Constructor

Overload List
 | Name | Description
Public method | NodeFeatureList(ISimNode) | Constructor.
Public method | NodeFeatureList(ISimNode, IEnumerableIFeature) | Constructor
Top
See Also

Reference

NodeFeatureList Class
VisualComponents.Create3D Namespace


NodeFeatureList Constructor (ISimNode)

Constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NodeFeatureList(
    ISimNode node
)
public:
NodeFeatureList(
    ISimNode^ node
)

Parameters

node
Type: VisualComponents.Create3DISimNode
Node for which the features in this NodeFetureList will be associated to.
See Also

Reference

NodeFeatureList Class
NodeFeatureList Overload
VisualComponents.Create3D Namespace


NodeFeatureList Constructor (ISimNode, IEnumerable(IFeature))

NodeFeatureList Constructor (ISimNode, IEnumerableIFeature)

Constructor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NodeFeatureList(
    ISimNode node,
    IEnumerable<IFeature> features
)
public:
NodeFeatureList(
    ISimNode^ node,
    IEnumerable<IFeature^>^ features
)

Parameters

node
Type: VisualComponents.Create3DISimNode
Node for which the features in this NodeFetureList are associated to.
features
Type: System.Collections.GenericIEnumerableIFeature
Features.
See Also

Reference

NodeFeatureList Class
NodeFeatureList Overload
VisualComponents.Create3D Namespace


NodeFeatureList Properties

The NodeFeatureList type exposes the following members.

Properties
 | Name | Description
Public property | Features | Gets the features.
Public property | Node | Gets the node for which the features are associated to.
Top
See Also

Reference

NodeFeatureList Class
VisualComponents.Create3D Namespace


NodeFeatureList.Features Property

NodeFeatureListFeatures Property

Gets the features.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<IFeature> Features { get; }
public:
property ReadOnlyCollection<IFeature^>^ Features {
    ReadOnlyCollection<IFeature^>^ get ();
}

Property Value

Type: ReadOnlyCollectionIFeature
See Also

Reference

NodeFeatureList Class
VisualComponents.Create3D Namespace


NodeFeatureList.Node Property

NodeFeatureListNode Property

Gets the node for which the features are associated to.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimNode Node { get; }
public:
property ISimNode^ Node {
    ISimNode^ get ();
}

Property Value

Type: ISimNode
See Also

Reference

NodeFeatureList Class
VisualComponents.Create3D Namespace


NodeFeatureList Methods

The NodeFeatureList type exposes the following members.

Methods
 | Name | Description
Public method | AddFeature | Adds a new feature to this NodeFeatureList.
Public method | ContainsFeature | Checks if feature is contained in the list.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindFeature | Finds first feature that matches the custom check.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveFeature | Removes the feature from this NodeFeatureList.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NodeFeatureList Class
VisualComponents.Create3D Namespace


NodeFeatureList.AddFeature Method

NodeFeatureListAddFeature Method

Adds a new feature to this NodeFeatureList.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void AddFeature(
    IFeature feature
)
public:
void AddFeature(
    IFeature^ feature
)

Parameters

feature
Type: VisualComponents.Create3DIFeature
Feature to be added.
See Also

Reference

NodeFeatureList Class
VisualComponents.Create3D Namespace


NodeFeatureList.ContainsFeature Method

NodeFeatureListContainsFeature Method

Checks if feature is contained in the list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ContainsFeature(
    IFeature feature
)
public:
bool ContainsFeature(
    IFeature^ feature
)

Parameters

feature
Type: VisualComponents.Create3DIFeature
Feature

Return Value

Type: Boolean
True if feature is contained
See Also

Reference

NodeFeatureList Class
VisualComponents.Create3D Namespace


NodeFeatureList.FindFeature Method

NodeFeatureListFindFeature Method

Finds first feature that matches the custom check.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IFeature FindFeature(
    Func<IFeature, bool> check
)
public:
IFeature^ FindFeature(
    Func<IFeature^, bool>^ check
)

Parameters

check
Type: SystemFuncIFeature, Boolean
Custom check

Return Value

Type: IFeature
Feature
See Also

Reference

NodeFeatureList Class
VisualComponents.Create3D Namespace


NodeFeatureList.RemoveFeature Method

NodeFeatureListRemoveFeature Method

Removes the feature from this NodeFeatureList.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RemoveFeature(
    IFeature feature
)
public:
void RemoveFeature(
    IFeature^ feature
)

Parameters

feature
Type: VisualComponents.Create3DIFeature
Feature to be removed.
See Also

Reference

NodeFeatureList Class
VisualComponents.Create3D Namespace


NodeListEntry Class

NodeListEntry instances can be used to form a list of instances of ISimNode.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DNodeListEntry

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NodeListEntry
public ref class NodeListEntry

The NodeListEntry type exposes the following members.

Constructors
 | Name | Description
Public method | NodeListEntry | Initializes a new instance of NodeListEntry.
Top
Properties
 | Name | Description
Public property | EntryScope | Gets the NodeEntryScope of this instance of NodeListEntry-
Public property | EntryType | Gets the NodeEntryType of this instance of NodeListEntry.
Public property | SimNode | Gets the instance of ISimNode of this instance of NodeListEntry.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks
Node list can be used in different operations, such as setting up collision detectors or raycasting. See helper methods and examples in INodeEntryListHelper interface.
See Also

Reference

VisualComponents.Create3D Namespace


NodeListEntry Constructor

Initializes a new instance of NodeListEntry.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NodeListEntry(
    ISimNode node,
    NodeEntryScope scope,
    NodeEntryType type
)
public:
NodeListEntry(
    ISimNode^ node,
    NodeEntryScope scope,
    NodeEntryType type
)

Parameters

node
Type: VisualComponents.Create3DISimNode
Node.
scope
Type: VisualComponents.Create3DNodeEntryScope
Scope.
type
Type: VisualComponents.Create3DNodeEntryType
Type.
See Also

Reference

NodeListEntry Class
VisualComponents.Create3D Namespace


NodeListEntry Properties

The NodeListEntry type exposes the following members.

Properties
 | Name | Description
Public property | EntryScope | Gets the NodeEntryScope of this instance of NodeListEntry-
Public property | EntryType | Gets the NodeEntryType of this instance of NodeListEntry.
Public property | SimNode | Gets the instance of ISimNode of this instance of NodeListEntry.
Top
See Also

Reference

NodeListEntry Class
VisualComponents.Create3D Namespace


NodeListEntry.EntryScope Property

NodeListEntryEntryScope Property

Gets the NodeEntryScope of this instance of NodeListEntry-

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NodeEntryScope EntryScope { get; }
public:
property NodeEntryScope EntryScope {
    NodeEntryScope get ();
}

Property Value

Type: NodeEntryScope
See Also

Reference

NodeListEntry Class
VisualComponents.Create3D Namespace


NodeListEntry.EntryType Property

NodeListEntryEntryType Property

Gets the NodeEntryType of this instance of NodeListEntry.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NodeEntryType EntryType { get; }
public:
property NodeEntryType EntryType {
    NodeEntryType get ();
}

Property Value

Type: NodeEntryType
See Also

Reference

NodeListEntry Class
VisualComponents.Create3D Namespace


NodeListEntry.SimNode Property

NodeListEntrySimNode Property

Gets the instance of ISimNode of this instance of NodeListEntry.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimNode SimNode { get; }
public:
property ISimNode^ SimNode {
    ISimNode^ get ();
}

Property Value

Type: ISimNode
See Also

Reference

NodeListEntry Class
VisualComponents.Create3D Namespace


NodeListEntry Methods

The NodeListEntry type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NodeListEntry Class
VisualComponents.Create3D Namespace


NodeTemplateChangedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DNodeTemplateChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NodeTemplateChangedEventArgs : EventArgs
public ref class NodeTemplateChangedEventArgs : public EventArgs

The NodeTemplateChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | NodeTemplateChangedEventArgs | Initializes a new instance of the NodeTemplateChangedEventArgs class
Top
Properties
 | Name | Description
Public property | IsSimplified |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


NodeTemplateChangedEventArgs Constructor

Initializes a new instance of the NodeTemplateChangedEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NodeTemplateChangedEventArgs(
    bool isSimplified
)
public:
NodeTemplateChangedEventArgs(
    bool isSimplified
)

Parameters

isSimplified
Type: SystemBoolean
See Also

Reference

NodeTemplateChangedEventArgs Class
VisualComponents.Create3D Namespace


NodeTemplateChangedEventArgs Properties

The NodeTemplateChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | IsSimplified |
Top
See Also

Reference

NodeTemplateChangedEventArgs Class
VisualComponents.Create3D Namespace


NodeTemplateChangedEventArgs.IsSimplified Property

NodeTemplateChangedEventArgsIsSimplified Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsSimplified { get; }
public:
property bool IsSimplified {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

NodeTemplateChangedEventArgs Class
VisualComponents.Create3D Namespace


NodeTemplateChangedEventArgs Methods

The NodeTemplateChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NodeTemplateChangedEventArgs Class
VisualComponents.Create3D Namespace


NodeTreeFinalizedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DNodeTreeFinalizedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NodeTreeFinalizedEventArgs : EventArgs
public ref class NodeTreeFinalizedEventArgs : public EventArgs

The NodeTreeFinalizedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | NodeTreeFinalizedEventArgs | Initializes a new instance of the NodeTreeFinalizedEventArgs class
Top
Properties
 | Name | Description
Public property | Components |
Public property | RootNode |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


NodeTreeFinalizedEventArgs Constructor

Initializes a new instance of the NodeTreeFinalizedEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NodeTreeFinalizedEventArgs(
    ISimNode rootNode,
    IEnumerable<ISimComponent> components
)
public:
NodeTreeFinalizedEventArgs(
    ISimNode^ rootNode,
    IEnumerable<ISimComponent^>^ components
)

Parameters

rootNode
Type: VisualComponents.Create3DISimNode
components
Type: System.Collections.GenericIEnumerableISimComponent
See Also

Reference

NodeTreeFinalizedEventArgs Class
VisualComponents.Create3D Namespace


NodeTreeFinalizedEventArgs Properties

The NodeTreeFinalizedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Components |
Public property | RootNode |
Top
See Also

Reference

NodeTreeFinalizedEventArgs Class
VisualComponents.Create3D Namespace


NodeTreeFinalizedEventArgs.Components Property

NodeTreeFinalizedEventArgsComponents Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<ISimComponent> Components { get; }
public:
property IEnumerable<ISimComponent^>^ Components {
    IEnumerable<ISimComponent^>^ get ();
}

Property Value

Type: IEnumerableISimComponent
See Also

Reference

NodeTreeFinalizedEventArgs Class
VisualComponents.Create3D Namespace


NodeTreeFinalizedEventArgs.RootNode Property

NodeTreeFinalizedEventArgsRootNode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimNode RootNode { get; }
public:
property ISimNode^ RootNode {
    ISimNode^ get ();
}

Property Value

Type: ISimNode
See Also

Reference

NodeTreeFinalizedEventArgs Class
VisualComponents.Create3D Namespace


NodeTreeFinalizedEventArgs Methods

The NodeTreeFinalizedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NodeTreeFinalizedEventArgs Class
VisualComponents.Create3D Namespace


NodeTreeStructure Enumeration

CAD import into 1 node, many nodes or components

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum NodeTreeStructure
public enum class NodeTreeStructure
Members
Member name | Value | Description
Node | 0 | 1 Node, 1 Component
Component | 1 | Multiple Nodes in 1 component
Layout | 2 | Multiple nodes, multiple components
See Also

Reference

VisualComponents.Create3D Namespace


NodeVisibilityStateChange Enumeration

Defines how to change the ISimNode visibility with ISetNodeMaterialStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum NodeVisibilityStateChange
public enum class NodeVisibilityStateChange
Members
Member name | Value | Description
Toggle | 0 | Toggle the visibility of each node independently.
Visible | 1 | Set the node visible.
Invisible | 2 | Set the node invisible.
See Also

Reference

VisualComponents.Create3D Namespace


NormalDistributionParameters Class

Normal distribution parameters
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DNormalDistributionParameters

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NormalDistributionParameters : IDistributionParameters
public ref class NormalDistributionParameters : IDistributionParameters

The NormalDistributionParameters type exposes the following members.

Constructors
 | Name | Description
Public method | NormalDistributionParameters | Initializes a new instance of the NormalDistributionParameters class
Public method | NormalDistributionParameters(IProperty) | Initializes a new instance of the NormalDistributionParameters class
Top
Properties
 | Name | Description
Public property | Deviation | standard deviation σ value
Public property | DistributionType |
Public property | Expression |
Public property | Mean | mean μ value
Public property | Property |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


NormalDistributionParameters Constructor

Overload List
 | Name | Description
Public method | NormalDistributionParameters | Initializes a new instance of the NormalDistributionParameters class
Public method | NormalDistributionParameters(IProperty) | Initializes a new instance of the NormalDistributionParameters class
Top
See Also

Reference

NormalDistributionParameters Class
VisualComponents.Create3D Namespace


NormalDistributionParameters Constructor

Initializes a new instance of the NormalDistributionParameters class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NormalDistributionParameters()
public:
NormalDistributionParameters()
See Also

Reference

NormalDistributionParameters Class
NormalDistributionParameters Overload
VisualComponents.Create3D Namespace


NormalDistributionParameters Constructor (IProperty)

Initializes a new instance of the NormalDistributionParameters class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NormalDistributionParameters(
    IProperty property
)
public:
NormalDistributionParameters(
    IProperty^ property
)

Parameters

property
Type: VisualComponents.Create3DIProperty
See Also

Reference

NormalDistributionParameters Class
NormalDistributionParameters Overload
VisualComponents.Create3D Namespace


NormalDistributionParameters Properties

The NormalDistributionParameters type exposes the following members.

Properties
 | Name | Description
Public property | Deviation | standard deviation σ value
Public property | DistributionType |
Public property | Expression |
Public property | Mean | mean μ value
Public property | Property |
Top
See Also

Reference

NormalDistributionParameters Class
VisualComponents.Create3D Namespace


NormalDistributionParameters.Deviation Property

NormalDistributionParametersDeviation Property

standard deviation σ value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Deviation { get; set; }
public:
property double Deviation {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

NormalDistributionParameters Class
VisualComponents.Create3D Namespace


NormalDistributionParameters.DistributionType Property

NormalDistributionParametersDistributionType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DistributionType DistributionType { get; }
public:
virtual property DistributionType DistributionType {
    DistributionType get () sealed;
}

Property Value

Type: DistributionType

Implements

IDistributionParametersDistributionType
See Also

Reference

NormalDistributionParameters Class
VisualComponents.Create3D Namespace


NormalDistributionParameters.Expression Property

NormalDistributionParametersExpression Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Expression { get; }
public:
virtual property String^ Expression {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IDistributionParametersExpression
See Also

Reference

NormalDistributionParameters Class
VisualComponents.Create3D Namespace


NormalDistributionParameters.Mean Property

NormalDistributionParametersMean Property

mean μ value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Mean { get; set; }
public:
property double Mean {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

NormalDistributionParameters Class
VisualComponents.Create3D Namespace


NormalDistributionParameters.Property Property

NormalDistributionParametersProperty Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty Property { get; }
public:
property IProperty^ Property {
    IProperty^ get ();
}

Property Value

Type: IProperty
See Also

Reference

NormalDistributionParameters Class
VisualComponents.Create3D Namespace


NormalDistributionParameters Methods

The NormalDistributionParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NormalDistributionParameters Class
VisualComponents.Create3D Namespace


ObjectSelectionMode Enumeration

Contains a list of available selection modes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ObjectSelectionMode
public enum class ObjectSelectionMode
Members
Member name | Value | Description
None | 0 |
Area | 1 | Rectangular area selection.
Lasso | 2 | Lasso area selection.
See Also

Reference

VisualComponents.Create3D Namespace


OperationType Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum OperationType
public enum class OperationType
Members
Member name | Value | Description
Add | 0 |
Set | 1 |
See Also

Reference

VisualComponents.Create3D Namespace


OrientationInterpolationMode Enumeration

Interpolation method used for orientation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum OrientationInterpolationMode
public enum class OrientationInterpolationMode
Members
Member name | Value | Description
OneAxis | 1 | Rotates around a single fixed axis.
TwoAxisX | 2 | Rotates X axis towards the target, while turning around itself.
TwoAxisY | 3 | Rotates Y axis towards the target, while turning around itself.
TwoAxisZ | 4 | Rotates Z axis towards the target, while turning around itself.
ThreeAxisYawPitchRoll | 5 | Interpolates yaw/pitch/rool values separately.
ThreeAxisEuler | 6 | Interpolates euler angles separately.
Wrist | 7 | Interpolates robot wrist joint values directly.
See Also

Reference

VisualComponents.Create3D Namespace


OutlineStyle Enumeration

Annotation text outline style enumeration.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum OutlineStyle
public enum class OutlineStyle
Members
Member name | Value | Description
None | 0 | No outline.
Outline | 1 | An empty box is drawn around the annotation text.
Circle | 2 | A circle is drawn around the annotation text.
Underline | 3 | The annotation text is underlined.
See Also

Reference

VisualComponents.Create3D Namespace


PackFolderState Enumeration

Pack folder state.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum PackFolderState
public enum class PackFolderState
Members
Member name | Value | Description
NotDefined | 0 | Pack folder is not defined in component.
Defined | 1 | Pack folder is defined in component, but not currently mapped.
Mapped | 2 | Pack folder is loaded and unpacked to local file system.
See Also

Reference

VisualComponents.Create3D Namespace


Parasolid Enumeration

Parasolid

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum Parasolid
public enum class Parasolid
Members
Member name | Value | Description
X_B | 0 |
X_T | 1 |
XMT | 2 |
XMT_TXT | 3 |
See Also

Reference

VisualComponents.Create3D Namespace


PathSnapperCornerStyle Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum PathSnapperCornerStyle
public enum class PathSnapperCornerStyle
Members
Member name | Value | Description
None | 0 |
Duplicate | 1 |
Single | 2 |
See Also

Reference

VisualComponents.Create3D Namespace


PathUtility Class

Path utility
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DPathUtility

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class PathUtility
public ref class PathUtility sealed

The PathUtility type exposes the following members.

Properties
Name | Description
BaseDirectory | The app base directory, returns the app local path
UserTempFile | Returns the unique full path of a temporary file that will be located in the user's temp folder.
UserTempFileName | Returns the name of a unique temporary file
UserTempPath | Returns the path to a temporary folder.
Top
Methods
 | Name | Description
 | Contains | Returns a value indicating whether a specified substring occurs within this string
 | CopyAndDeleteFile | Copies an existing file to a new file.
 | CreateDirectory | Creates all directories and subdirectories in the specified path unless they already exist.
 | CreateRelativeOrAbsoluteUri | Initializes a new instance of the System.Uri class with the specified URI. This constructor allows you to specify if the URI string is a relative URI, absolute URI, or is indeterminate.
 | DeleteDirectory | Deletes the specified directory and, if indicated, any subdirectories and files in the directory.
 | DeleteFile | Deletes the specified file.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | ExpandPathVariables | Returns full path
 | ExpandPathVariablesWithSuffix | Returns full path
 | ExpandTextExpression(String, ILocalizationService) | Expands keys in the text. Form should be e.g. "The build year is %YEAR%.".
 | ExpandTextExpression(String, ILocalizationService, FuncString, String) | Expands keys in the text. Form should be e.g. "The build year is %BUILD_YEAR%.".
 | FileExists | Determines whether the specified file exists.
 | FileWriteAccess | Check file permissions to write to a directory or file.
 | GetAppSettingPath | Return full path from the application config file
 | GetExtension | Returns the extension of the specified path string.
 | GetFileExtension | Get the file extension.
 | GetFolderPath(EnvironmentSpecialFolder) | Gets the path to the system special folder that is identified by the specified enumeration.
 | GetFolderPath(String) | Checks the path and if it's not exist it will be created.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetTextReplacementValue |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | HasWritePermissionOnFilePath | Check write access for a specified directory and the file.
 | HasWritePermissionOnFolder |
 | IsReadOnlyFileAttributeSet | Checks Read Only file attribute
 | RemoveReadOnlyFileAttribute | Remove the Read-Only file attribute if it's set
 | SetFilePermissions | Adds access for the specified file to the existing state of the permission.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


PathUtility Properties

The PathUtility type exposes the following members.

Properties
Name | Description
BaseDirectory | The app base directory, returns the app local path
UserTempFile | Returns the unique full path of a temporary file that will be located in the user's temp folder.
UserTempFileName | Returns the name of a unique temporary file
UserTempPath | Returns the path to a temporary folder.
Top
See Also

Reference

PathUtility Class
VisualComponents.Create3D Namespace


PathUtility.BaseDirectory Property

PathUtilityBaseDirectory Property

The app base directory, returns the app local path

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string BaseDirectory { get; }
public:
static property String^ BaseDirectory {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

PathUtility Class
VisualComponents.Create3D Namespace


PathUtility.UserTempFile Property

PathUtilityUserTempFile Property

Returns the unique full path of a temporary file that will be located in the user's temp folder.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string UserTempFile { get; }
public:
static property String^ UserTempFile {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

PathUtility Class
VisualComponents.Create3D Namespace


PathUtility.UserTempFileName Property

PathUtilityUserTempFileName Property

Returns the name of a unique temporary file

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string UserTempFileName { get; }
public:
static property String^ UserTempFileName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

PathUtility Class
VisualComponents.Create3D Namespace


PathUtility.UserTempPath Property

PathUtilityUserTempPath Property

Returns the path to a temporary folder.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string UserTempPath { get; }
public:
static property String^ UserTempPath {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

PathUtility Class
VisualComponents.Create3D Namespace


PathUtility Methods

The PathUtility type exposes the following members.

Methods
 | Name | Description
 | Contains | Returns a value indicating whether a specified substring occurs within this string
 | CopyAndDeleteFile | Copies an existing file to a new file.
 | CreateDirectory | Creates all directories and subdirectories in the specified path unless they already exist.
 | CreateRelativeOrAbsoluteUri | Initializes a new instance of the System.Uri class with the specified URI. This constructor allows you to specify if the URI string is a relative URI, absolute URI, or is indeterminate.
 | DeleteDirectory | Deletes the specified directory and, if indicated, any subdirectories and files in the directory.
 | DeleteFile | Deletes the specified file.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | ExpandPathVariables | Returns full path
 | ExpandPathVariablesWithSuffix | Returns full path
 | ExpandTextExpression(String, ILocalizationService) | Expands keys in the text. Form should be e.g. "The build year is %YEAR%.".
 | ExpandTextExpression(String, ILocalizationService, FuncString, String) | Expands keys in the text. Form should be e.g. "The build year is %BUILD_YEAR%.".
 | FileExists | Determines whether the specified file exists.
 | FileWriteAccess | Check file permissions to write to a directory or file.
 | GetAppSettingPath | Return full path from the application config file
 | GetExtension | Returns the extension of the specified path string.
 | GetFileExtension | Get the file extension.
 | GetFolderPath(EnvironmentSpecialFolder) | Gets the path to the system special folder that is identified by the specified enumeration.
 | GetFolderPath(String) | Checks the path and if it's not exist it will be created.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetTextReplacementValue |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | HasWritePermissionOnFilePath | Check write access for a specified directory and the file.
 | HasWritePermissionOnFolder |
 | IsReadOnlyFileAttributeSet | Checks Read Only file attribute
 | RemoveReadOnlyFileAttribute | Remove the Read-Only file attribute if it's set
 | SetFilePermissions | Adds access for the specified file to the existing state of the permission.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PathUtility Class
VisualComponents.Create3D Namespace


PathUtility.Contains Method

PathUtilityContains Method

Returns a value indicating whether a specified substring occurs within this string

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool Contains(
    string source,
    string toCheck,
    StringComparison comparison
)
public:
static bool Contains(
    String^ source,
    String^ toCheck,
    StringComparison comparison
)

Parameters

source
Type: SystemString
source string
toCheck
Type: SystemString
The string to seek
comparison
Type: SystemStringComparison
Specifies the sort rules

Return Value

Type: Boolean
true if the value parameter occurs within this string; otherwise, false
See Also

Reference

PathUtility Class
VisualComponents.Create3D Namespace


PathUtility.CopyAndDeleteFile Method

PathUtilityCopyAndDeleteFile Method

Copies an existing file to a new file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool CopyAndDeleteFile(
    Uri uriSourceFileName,
    Uri uriDestinationFileName
)
public:
static bool CopyAndDeleteFile(
    Uri^ uriSourceFileName,
    Uri^ uriDestinationFileName
)

Parameters

uriSourceFileName
Type: SystemUri
The file to copy.
uriDestinationFileName
Type: SystemUri
The name of the destination file. This cannot be a directory.

Return Value

Type: Boolean
true if the file was copyed and original file was deleted.
See Also

Reference

PathUtility Class
VisualComponents.Create3D Namespace


PathUtility.CreateDirectory Method

PathUtilityCreateDirectory Method

Creates all directories and subdirectories in the specified path unless they already exist.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void CreateDirectory(
    string path
)
public:
static void CreateDirectory(
    String^ path
)

Parameters

path
Type: SystemString
The directory to create.
See Also

Reference

PathUtility Class
VisualComponents.Create3D Namespace


PathUtility.CreateRelativeOrAbsoluteUri Method

PathUtilityCreateRelativeOrAbsoluteUri Method

Initializes a new instance of the System.Uri class with the specified URI. This constructor allows you to specify if the URI string is a relative URI, absolute URI, or is indeterminate.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Uri CreateRelativeOrAbsoluteUri(
    string path
)
public:
static Uri^ CreateRelativeOrAbsoluteUri(
    String^ path
)

Parameters

path
Type: SystemString
A string that identifies the resource to be represented by the System.Uri instance.

Return Value

Type: Uri
new Uri
See Also

Reference

PathUtility Class
VisualComponents.Create3D Namespace


PathUtility.DeleteDirectory Method

PathUtilityDeleteDirectory Method

Deletes the specified directory and, if indicated, any subdirectories and files in the directory.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void DeleteDirectory(
    string path,
    bool recursive
)
public:
static void DeleteDirectory(
    String^ path,
    bool recursive
)

Parameters

path
Type: SystemString
The name of the directory to remove.
recursive
Type: SystemBoolean
true to remove directories, subdirectories, and files in path; otherwise, false.
See Also

Reference

PathUtility Class
VisualComponents.Create3D Namespace


PathUtility.DeleteFile Method

PathUtilityDeleteFile Method

Deletes the specified file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool DeleteFile(
    string sourceFileName
)
public:
static bool DeleteFile(
    String^ sourceFileName
)

Parameters

sourceFileName
Type: SystemString
The name of the file to be deleted. Wildcard characters are not supported.

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.PathUtility.DeleteFile(System.String)"]

See Also

Reference

PathUtility Class
VisualComponents.Create3D Namespace


PathUtility.ExpandPathVariables Method

PathUtilityExpandPathVariables Method

Returns full path

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string ExpandPathVariables(
    string path,
    bool createMissingFolder = true,
    bool appendStartPath = true
)
public:
static String^ ExpandPathVariables(
    String^ path,
    bool createMissingFolder = true,
    bool appendStartPath = true
)

Parameters

path
Type: SystemString
the path with variables
createMissingFolder (Optional)
Type: SystemBoolean
appendStartPath (Optional)
Type: SystemBoolean

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.PathUtility.ExpandPathVariables(System.String,System.Boolean,System.Boolean)"]

See Also

Reference

PathUtility Class
VisualComponents.Create3D Namespace


PathUtility.ExpandPathVariablesWithSuffix Method

PathUtilityExpandPathVariablesWithSuffix Method

Returns full path

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string ExpandPathVariablesWithSuffix(
    string path,
    string suffix,
    bool createMissingFolder = true,
    bool appendStartPath = true
)
public:
static String^ ExpandPathVariablesWithSuffix(
    String^ path,
    String^ suffix,
    bool createMissingFolder = true,
    bool appendStartPath = true
)

Parameters

path
Type: SystemString
the path with variables
suffix
Type: SystemString
suffix to append after environment variable expansion
createMissingFolder (Optional)
Type: SystemBoolean
appendStartPath (Optional)
Type: SystemBoolean

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.PathUtility.ExpandPathVariablesWithSuffix(System.String,System.String,System.Boolean,System.Boolean)"]

See Also

Reference

PathUtility Class
VisualComponents.Create3D Namespace


PathUtility.ExpandTextExpression Method

PathUtilityExpandTextExpression Method

Overload List
Name | Description
ExpandTextExpression(String, ILocalizationService) | Expands keys in the text. Form should be e.g. "The build year is %YEAR%.".
ExpandTextExpression(String, ILocalizationService, FuncString, String) | Expands keys in the text. Form should be e.g. "The build year is %BUILD_YEAR%.".
Top
See Also

Reference

PathUtility Class
VisualComponents.Create3D Namespace


PathUtility.ExpandTextExpression Method (String, ILocalizationService)

PathUtilityExpandTextExpression Method (String, ILocalizationService)

Expands keys in the text. Form should be e.g. "The build year is %YEAR%.".

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string ExpandTextExpression(
    string expression,
    ILocalizationService localization
)
public:
static String^ ExpandTextExpression(
    String^ expression,
    ILocalizationService^ localization
)

Parameters

expression
Type: SystemString
localization
Type: VisualComponents.Create3DILocalizationService
Can be used as a fallback, if a predefined key is not found.

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.PathUtility.ExpandTextExpression(System.String,VisualComponents.Create3D.ILocalizationService)"]

See Also

Reference

PathUtility Class
ExpandTextExpression Overload
VisualComponents.Create3D Namespace


PathUtility.ExpandTextExpression Method (String, ILocalizationService, Func(String, String))

PathUtilityExpandTextExpression Method (String, ILocalizationService, FuncString, String)

Expands keys in the text. Form should be e.g. "The build year is %BUILD_YEAR%.".

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string ExpandTextExpression(
    string expression,
    ILocalizationService localization,
    Func<string, string> valueGetter
)
public:
static String^ ExpandTextExpression(
    String^ expression,
    ILocalizationService^ localization,
    Func<String^, String^>^ valueGetter
)

Parameters

expression
Type: SystemString
localization
Type: VisualComponents.Create3DILocalizationService
Can be used as a fallback, if valueGetter does not return a value.
valueGetter
Type: SystemFuncString, String
Will be used to get the values (input is "YEAR").

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.PathUtility.ExpandTextExpression(System.String,VisualComponents.Create3D.ILocalizationService,System.Func{System.String,System.String})"]

See Also

Reference

PathUtility Class
ExpandTextExpression Overload
VisualComponents.Create3D Namespace


PathUtility.FileExists Method

PathUtilityFileExists Method

Determines whether the specified file exists.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool FileExists(
    string path
)
public:
static bool FileExists(
    String^ path
)

Parameters

path
Type: SystemString
The file to check.

Return Value

Type: Boolean
true if the caller has the required permissions and path contains the name of an existing file; otherwise, false. This method also returns false if path is null, an invalid path, or a zero-length string. If the caller does not have sufficient permissions to read the specified file, no exception is thrown and the method returns false regardless of the existence of path.
See Also

Reference

PathUtility Class
VisualComponents.Create3D Namespace


PathUtility.FileWriteAccess Method

PathUtilityFileWriteAccess Method

Check file permissions to write to a directory or file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool FileWriteAccess(
    string filePath
)
public:
static bool FileWriteAccess(
    String^ filePath
)

Parameters

filePath
Type: SystemString
a file name

Return Value

Type: Boolean
true if write access is granded
See Also

Reference

PathUtility Class
VisualComponents.Create3D Namespace


PathUtility.GetAppSettingPath Method

PathUtilityGetAppSettingPath Method

Return full path from the application config file

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetAppSettingPath(
    string appConfigKeyPathName
)
public:
static String^ GetAppSettingPath(
    String^ appConfigKeyPathName
)

Parameters

appConfigKeyPathName
Type: SystemString
the application config key

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.PathUtility.GetAppSettingPath(System.String)"]

See Also

Reference

PathUtility Class
VisualComponents.Create3D Namespace


PathUtility.GetExtension Method

PathUtilityGetExtension Method

Returns the extension of the specified path string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetExtension(
    string path
)
public:
static String^ GetExtension(
    String^ path
)

Parameters

path
Type: SystemString
The path string from which to get the extension.

Return Value

Type: String
The extension of the specified path (including the period "."), or null, or System.String.Empty. If path is null, System.IO.Path.GetExtension(System.String) returns System.String.Empty. If path does not have extension information, System.IO.Path.GetExtension(System.String) returns System.String.Empty.
See Also

Reference

PathUtility Class
VisualComponents.Create3D Namespace


PathUtility.GetFileExtension Method

PathUtilityGetFileExtension Method

Get the file extension.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetFileExtension(
    string filePath
)
public:
static String^ GetFileExtension(
    String^ filePath
)

Parameters

filePath
Type: SystemString
Full file path.

Return Value

Type: String
File extension in lowercase and without the dot, or System.String.Empty.
See Also

Reference

PathUtility Class
VisualComponents.Create3D Namespace


PathUtility.GetFolderPath Method

PathUtilityGetFolderPath Method

Overload List
Name | Description
GetFolderPath(EnvironmentSpecialFolder) | Gets the path to the system special folder that is identified by the specified enumeration.
GetFolderPath(String) | Checks the path and if it's not exist it will be created.
Top
See Also

Reference

PathUtility Class
VisualComponents.Create3D Namespace


PathUtility.GetFolderPath Method (Environment.SpecialFolder)

PathUtilityGetFolderPath Method (EnvironmentSpecialFolder)

Gets the path to the system special folder that is identified by the specified enumeration.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetFolderPath(
    EnvironmentSpecialFolder folder
)
public:
static String^ GetFolderPath(
    EnvironmentSpecialFolder folder
)

Parameters

folder
Type: SystemEnvironmentSpecialFolder
An enumerated constant that identifies a system special folder.

Return Value

Type: String
The path to the specified system special folder, if that folder is not physically exist on your computer it will be created.
See Also

Reference

PathUtility Class
GetFolderPath Overload
VisualComponents.Create3D Namespace


PathUtility.GetFolderPath Method (String)

PathUtilityGetFolderPath Method (String)

Checks the path and if it's not exist it will be created.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetFolderPath(
    string path
)
public:
static String^ GetFolderPath(
    String^ path
)

Parameters

path
Type: SystemString
path name.

Return Value

Type: String
The path to the folder, if that folder is not physically exist on your computer it will be created.
See Also

Reference

PathUtility Class
GetFolderPath Overload
VisualComponents.Create3D Namespace


PathUtility.GetTextReplacementValue Method

PathUtilityGetTextReplacementValue Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetTextReplacementValue(
    string key
)
public:
static String^ GetTextReplacementValue(
    String^ key
)

Parameters

key
Type: SystemString

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.PathUtility.GetTextReplacementValue(System.String)"]

See Also

Reference

PathUtility Class
VisualComponents.Create3D Namespace


PathUtility.HasWritePermissionOnFilePath Method

PathUtilityHasWritePermissionOnFilePath Method

Check write access for a specified directory and the file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool HasWritePermissionOnFilePath(
    string filePath
)
public:
static bool HasWritePermissionOnFilePath(
    String^ filePath
)

Parameters

filePath
Type: SystemString
The full file path to check.

Return Value

Type: Boolean
true if the caller has the required permissions.
See Also

Reference

PathUtility Class
VisualComponents.Create3D Namespace


PathUtility.HasWritePermissionOnFolder Method

PathUtilityHasWritePermissionOnFolder Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool HasWritePermissionOnFolder(
    string directory
)
public:
static bool HasWritePermissionOnFolder(
    String^ directory
)

Parameters

directory
Type: SystemString

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.PathUtility.HasWritePermissionOnFolder(System.String)"]

See Also

Reference

PathUtility Class
VisualComponents.Create3D Namespace


PathUtility.IsReadOnlyFileAttributeSet Method

PathUtilityIsReadOnlyFileAttributeSet Method

Checks Read Only file attribute

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsReadOnlyFileAttributeSet(
    string sourceFileName
)
public:
static bool IsReadOnlyFileAttributeSet(
    String^ sourceFileName
)

Parameters

sourceFileName
Type: SystemString
The absolute path of a file

Return Value

Type: Boolean
true if the Read-Only file attribute is set
See Also

Reference

PathUtility Class
VisualComponents.Create3D Namespace


PathUtility.RemoveReadOnlyFileAttribute Method

PathUtilityRemoveReadOnlyFileAttribute Method

Remove the Read-Only file attribute if it's set

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void RemoveReadOnlyFileAttribute(
    string sourceFileName
)
public:
static void RemoveReadOnlyFileAttribute(
    String^ sourceFileName
)

Parameters

sourceFileName
Type: SystemString
The absolute path of a file
See Also

Reference

PathUtility Class
VisualComponents.Create3D Namespace


PathUtility.SetFilePermissions Method

PathUtilitySetFilePermissions Method

Adds access for the specified file to the existing state of the permission.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool SetFilePermissions(
    FileIOPermissionAccess access,
    string path
)
public:
static bool SetFilePermissions(
    FileIOPermissionAccess access,
    String^ path
)

Parameters

access
Type: System.Security.PermissionsFileIOPermissionAccess
A bitwise combination of the System.Security.Permissions.FileIOPermissionAccess values.
path
Type: SystemString
The absolute path of a file or directory.

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.PathUtility.SetFilePermissions(System.Security.Permissions.FileIOPermissionAccess,System.String)"]

See Also

Reference

PathUtility Class
VisualComponents.Create3D Namespace


PdbPlugin Enumeration

Igrip/Quest/VNC geometry

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum PdbPlugin
public enum class PdbPlugin
Members
Member name | Value | Description
PDB | 0 |
ALL_ | 1 |
See Also

Reference

VisualComponents.Create3D Namespace


PdfExporter Class

Utility class to export elements into PDF file
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DPdfExporter

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class PdfExporter
public ref class PdfExporter abstract sealed
Methods
Name | Description
VisualsToPdf(IEnumerableVisual, String, Int32, Int32, Int32) | Creates a pdf out of each visual element
VisualsToPdf(IEnumerableVisual, String, Int32, Int32, Int32, Boolean, PaperSize) | Creates a pdf out of each visual element
Top
See Also

Reference

VisualComponents.Create3D Namespace


PdfExporter Methods

Methods
Name | Description
VisualsToPdf(IEnumerableVisual, String, Int32, Int32, Int32) | Creates a pdf out of each visual element
VisualsToPdf(IEnumerableVisual, String, Int32, Int32, Int32, Boolean, PaperSize) | Creates a pdf out of each visual element
Top
See Also

Reference

PdfExporter Class
VisualComponents.Create3D Namespace


PdfExporter.VisualsToPdf Method

PdfExporterVisualsToPdf Method

Overload List
Name | Description
VisualsToPdf(IEnumerableVisual, String, Int32, Int32, Int32) | Creates a pdf out of each visual element
VisualsToPdf(IEnumerableVisual, String, Int32, Int32, Int32, Boolean, PaperSize) | Creates a pdf out of each visual element
Top
See Also

Reference

PdfExporter Class
VisualComponents.Create3D Namespace


PdfExporter.VisualsToPdf Method (IEnumerable(Visual), String, Int32, Int32, Int32)

PdfExporterVisualsToPdf Method (IEnumerableVisual, String, Int32, Int32, Int32)

Creates a pdf out of each visual element

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void VisualsToPdf(
    IEnumerable<Visual> visuals,
    string pdfPath,
    int width,
    int height,
    int margin
)
public:
static void VisualsToPdf(
    IEnumerable<Visual^>^ visuals,
    String^ pdfPath,
    int width,
    int height,
    int margin
)

Parameters

visuals
Type: System.Collections.GenericIEnumerableVisual
List of visuals to be included in pdf file. Each visual will be placed in one page
pdfPath
Type: SystemString
Absolute path where pdf file will be saved
width
Type: SystemInt32
Width of visuals in pixels
height
Type: SystemInt32
Height of visuals in pixels
margin
Type: SystemInt32
Page margin
See Also

Reference

PdfExporter Class
VisualsToPdf Overload
VisualComponents.Create3D Namespace


PdfExporter.VisualsToPdf Method (IEnumerable(Visual), String, Int32, Int32, Int32, Boolean, PaperSize)

PdfExporterVisualsToPdf Method (IEnumerableVisual, String, Int32, Int32, Int32, Boolean, PaperSize)

Creates a pdf out of each visual element

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void VisualsToPdf(
    IEnumerable<Visual> visuals,
    string pdfPath,
    int width,
    int height,
    int margin,
    bool rotate,
    PaperSize paperKind
)
public:
static void VisualsToPdf(
    IEnumerable<Visual^>^ visuals,
    String^ pdfPath,
    int width,
    int height,
    int margin,
    bool rotate,
    PaperSize^ paperKind
)

Parameters

visuals
Type: System.Collections.GenericIEnumerableVisual
List of visuals to be included in pdf file. Each visual will be placed in one page
pdfPath
Type: SystemString
Absolute path where pdf file will be saved
width
Type: SystemInt32
Width of visuals in pixels
height
Type: SystemInt32
Height of visuals in pixels
margin
Type: SystemInt32
Page margin
rotate
Type: SystemBoolean
Rotate each visual 90 degrees
paperKind
Type: System.Drawing.PrintingPaperSize
Page kind (only a4, a3, a2, a1 and a0 are accepted
See Also

Reference

PdfExporter Class
VisualsToPdf Overload
VisualComponents.Create3D Namespace


PdfExportLevel Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum PdfExportLevel
public enum class PdfExportLevel
Members
Member name | Value | Description
NoExport | 0 |
Complete | 1 |
GeometryBound | 2 |
NodeBound | 3 |
ComponentBound | 4 |
See Also

Reference

VisualComponents.Create3D Namespace


PerformanceMeasurement Class

performance measurement helper
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DPerformanceMeasurement

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PerformanceMeasurement
public ref class PerformanceMeasurement

The PerformanceMeasurement type exposes the following members.

Constructors
 | Name | Description
Public method | PerformanceMeasurement | default constructor
Top
Properties
 | Name | Description
Public property | ElapsedStopwatchTime | Gets the elapsed stopwatch time.
Public property | ElapsedTotalProcessorTime | Gets the elapsed total processor time.
Top
Methods
 | Name | Description
 | Create |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Start | Start performance measurement.
Public method | Start(String) | Start measure
Public method | Stop | Stop performance measurement.
Public method | Stop(String, Boolean) | stop to measure
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


PerformanceMeasurement Constructor

default constructor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PerformanceMeasurement()
public:
PerformanceMeasurement()
See Also

Reference

PerformanceMeasurement Class
VisualComponents.Create3D Namespace


PerformanceMeasurement Properties

The PerformanceMeasurement type exposes the following members.

Properties
 | Name | Description
Public property | ElapsedStopwatchTime | Gets the elapsed stopwatch time.
Public property | ElapsedTotalProcessorTime | Gets the elapsed total processor time.
Top
See Also

Reference

PerformanceMeasurement Class
VisualComponents.Create3D Namespace


PerformanceMeasurement.ElapsedStopwatchTime Property

PerformanceMeasurementElapsedStopwatchTime Property

Gets the elapsed stopwatch time.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TimeSpan ElapsedStopwatchTime { get; }
public:
property TimeSpan ElapsedStopwatchTime {
    TimeSpan get ();
}

Property Value

Type: TimeSpan
See Also

Reference

PerformanceMeasurement Class
VisualComponents.Create3D Namespace


PerformanceMeasurement.ElapsedTotalProcessorTime Property

PerformanceMeasurementElapsedTotalProcessorTime Property

Gets the elapsed total processor time.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TimeSpan ElapsedTotalProcessorTime { get; }
public:
property TimeSpan ElapsedTotalProcessorTime {
    TimeSpan get ();
}

Property Value

Type: TimeSpan
See Also

Reference

PerformanceMeasurement Class
VisualComponents.Create3D Namespace


PerformanceMeasurement Methods

The PerformanceMeasurement type exposes the following members.

Methods
 | Name | Description
 | Create |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Start | Start performance measurement.
Public method | Start(String) | Start measure
Public method | Stop | Stop performance measurement.
Public method | Stop(String, Boolean) | stop to measure
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PerformanceMeasurement Class
VisualComponents.Create3D Namespace


PerformanceMeasurement.Create Method

PerformanceMeasurementCreate Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static PerformanceMeasurement Create()
public:
static PerformanceMeasurement^ Create()

Return Value

Type: PerformanceMeasurement

[Missing <returns> documentation for "M:VisualComponents.Create3D.PerformanceMeasurement.Create"]

See Also

Reference

PerformanceMeasurement Class
VisualComponents.Create3D Namespace


PerformanceMeasurement.Start Method

PerformanceMeasurementStart Method

Overload List
 | Name | Description
Public method | Start | Start performance measurement.
Public method | Start(String) | Start measure
Top
See Also

Reference

PerformanceMeasurement Class
VisualComponents.Create3D Namespace


PerformanceMeasurement.Start Method

PerformanceMeasurementStart Method

Start performance measurement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Start()
public:
void Start()
See Also

Reference

PerformanceMeasurement Class
Start Overload
VisualComponents.Create3D Namespace


PerformanceMeasurement.Start Method (String)

PerformanceMeasurementStart Method (String)

Start measure

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Start(
    string logMessage
)
public:
void Start(
    String^ logMessage
)

Parameters

logMessage
Type: SystemString
logging message
See Also

Reference

PerformanceMeasurement Class
Start Overload
VisualComponents.Create3D Namespace


PerformanceMeasurement.Stop Method

PerformanceMeasurementStop Method

Overload List
 | Name | Description
Public method | Stop | Stop performance measurement.
Public method | Stop(String, Boolean) | stop to measure
Top
See Also

Reference

PerformanceMeasurement Class
VisualComponents.Create3D Namespace


PerformanceMeasurement.Stop Method

PerformanceMeasurementStop Method

Stop performance measurement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Stop()
public:
String^ Stop()

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.PerformanceMeasurement.Stop"]

See Also

Reference

PerformanceMeasurement Class
Stop Overload
VisualComponents.Create3D Namespace


PerformanceMeasurement.Stop Method (String, Boolean)

PerformanceMeasurementStop Method (String, Boolean)

stop to measure

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Stop(
    string logMessage,
    bool shortReport
)
public:
String^ Stop(
    String^ logMessage,
    bool shortReport
)

Parameters

logMessage
Type: SystemString
additional text
shortReport
Type: SystemBoolean
type of generated message. Default value can be false.

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.PerformanceMeasurement.Stop(System.String,System.Boolean)"]

See Also

Reference

PerformanceMeasurement Class
Stop Overload
VisualComponents.Create3D Namespace


PickFilter Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum PickFilter
public enum class PickFilter
Members
Member name | Value | Description
None | 0 |
Component | 1 | Picking returns ISimComponent
Node | 2 | Picking will return ISimNode
Feature | 3 | Not supported yet.
GeoSet | 4 | Not supported yet.
See Also

Reference

VisualComponents.Create3D Namespace


PickPrimitives Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[FlagsAttribute]
public enum PickPrimitives
[FlagsAttribute]
public enum class PickPrimitives
Members
Member name | Value | Description
Point | 2 |
Line | 4 |
Edge | 8 |
Polygon | 16 |
Surface | 32 |
Frame | 64 |
Particle | 128 |
Text2D | 256 |
Text3D | 512 |
Floor | 1024 |
Curve | 2048 |
CurveLoop | 4096 |
FaceCurve | 8192 |
PointCloud | 16384 |
Indexed | 32768 |
TessellationPoint | 65536 |
All | 57342 |
See Also

Reference

VisualComponents.Create3D Namespace


PickResult Structure

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct PickResult
public value class PickResult

The PickResult type exposes the following members.

Constructors
 | Name | Description
Public method | PickResult(SelectionTypes, IVisualObject, IPrimitive) | Initializes a new instance of the PickResult class
Public method | PickResult(SelectionTypes, IVisualObject, IPrimitive, IPropertyContainer) | Initializes a new instance of the PickResult class
Top
Properties
 | Name | Description
Public property | CustomType |
 | Empty |
Public property | ObjectType |
Public property | PickedObject |
Public property | Primitive |
Public property | PropertyContainer |
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object instances are considered equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(PickResult) | Determines whether the specified object instances are considered equal.
Public method | GetHashCode | Returns a hashcode for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Equality | Determines whether the specified object instances are considered equal.
Inequality | Determines whether the specified object instances are not considered equal.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


PickResult Constructor

Overload List
 | Name | Description
Public method | PickResult(SelectionTypes, IVisualObject, IPrimitive) | Initializes a new instance of the PickResult class
Public method | PickResult(SelectionTypes, IVisualObject, IPrimitive, IPropertyContainer) | Initializes a new instance of the PickResult class
Top
See Also

Reference

PickResult Structure
VisualComponents.Create3D Namespace


PickResult Constructor (SelectionTypes, IVisualObject, IPrimitive)

Initializes a new instance of the PickResult class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PickResult(
    SelectionTypes typeOfPickedObject,
    IVisualObject pickedObject,
    IPrimitive pickedPrimitive
)
public:
PickResult(
    SelectionTypes typeOfPickedObject,
    IVisualObject^ pickedObject,
    IPrimitive^ pickedPrimitive
)

Parameters

typeOfPickedObject
Type: VisualComponents.Create3DSelectionTypes
pickedObject
Type: VisualComponents.Create3DIVisualObject
pickedPrimitive
Type: VisualComponents.Create3DIPrimitive
See Also

Reference

PickResult Structure
PickResult Overload
VisualComponents.Create3D Namespace


PickResult Constructor (SelectionTypes, IVisualObject, IPrimitive, IPropertyContainer)

Initializes a new instance of the PickResult class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PickResult(
    SelectionTypes typeOfPickedObject,
    IVisualObject pickedObject,
    IPrimitive pickedPrimitive,
    IPropertyContainer pickedContainer
)
public:
PickResult(
    SelectionTypes typeOfPickedObject,
    IVisualObject^ pickedObject,
    IPrimitive^ pickedPrimitive,
    IPropertyContainer^ pickedContainer
)

Parameters

typeOfPickedObject
Type: VisualComponents.Create3DSelectionTypes
pickedObject
Type: VisualComponents.Create3DIVisualObject
pickedPrimitive
Type: VisualComponents.Create3DIPrimitive
pickedContainer
Type: VisualComponents.Create3DIPropertyContainer
See Also

Reference

PickResult Structure
PickResult Overload
VisualComponents.Create3D Namespace


PickResult Properties

The PickResult type exposes the following members.

Properties
 | Name | Description
Public property | CustomType |
 | Empty |
Public property | ObjectType |
Public property | PickedObject |
Public property | Primitive |
Public property | PropertyContainer |
Top
See Also

Reference

PickResult Structure
VisualComponents.Create3D Namespace


PickResult.CustomType Property

PickResultCustomType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CustomType { get; }
public:
property String^ CustomType {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

PickResult Structure
VisualComponents.Create3D Namespace


PickResult.Empty Property

PickResultEmpty Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static PickResult Empty { get; }
public:
static property PickResult Empty {
    PickResult get ();
}

Property Value

Type: PickResult
See Also

Reference

PickResult Structure
VisualComponents.Create3D Namespace


PickResult.ObjectType Property

PickResultObjectType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SelectionTypes ObjectType { get; }
public:
property SelectionTypes ObjectType {
    SelectionTypes get ();
}

Property Value

Type: SelectionTypes
See Also

Reference

PickResult Structure
VisualComponents.Create3D Namespace


PickResult.PickedObject Property

PickResultPickedObject Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IVisualObject PickedObject { get; }
public:
property IVisualObject^ PickedObject {
    IVisualObject^ get ();
}

Property Value

Type: IVisualObject
See Also

Reference

PickResult Structure
VisualComponents.Create3D Namespace


PickResult.Primitive Property

PickResultPrimitive Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IPrimitive Primitive { get; }
public:
property IPrimitive^ Primitive {
    IPrimitive^ get ();
}

Property Value

Type: IPrimitive
See Also

Reference

PickResult Structure
VisualComponents.Create3D Namespace


PickResult.PropertyContainer Property

PickResultPropertyContainer Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IPropertyContainer PropertyContainer { get; }
public:
property IPropertyContainer^ PropertyContainer {
    IPropertyContainer^ get ();
}

Property Value

Type: IPropertyContainer
See Also

Reference

PickResult Structure
VisualComponents.Create3D Namespace


PickResult Methods

The PickResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object instances are considered equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(PickResult) | Determines whether the specified object instances are considered equal.
Public method | GetHashCode | Returns a hashcode for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PickResult Structure
VisualComponents.Create3D Namespace


PickResult.Equals Method

PickResultEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object instances are considered equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(PickResult) | Determines whether the specified object instances are considered equal.
Top
See Also

Reference

PickResult Structure
VisualComponents.Create3D Namespace


PickResult.Equals Method (Object)

PickResultEquals Method (Object)

Determines whether the specified object instances are considered equal.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
The object to compare with the current object.

Return Value

Type: Boolean
true if the objects are considered equal; otherwise, false.
See Also

Reference

PickResult Structure
Equals Overload
VisualComponents.Create3D Namespace


PickResult.Equals Method (PickResult)

PickResultEquals Method (PickResult)

Determines whether the specified object instances are considered equal.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    PickResult other
)
public:
bool Equals(
    PickResult other
)

Parameters

other
Type: VisualComponents.Create3DPickResult
The object to compare with the current object.

Return Value

Type: Boolean
true if the objects are considered equal; otherwise, false.
See Also

Reference

PickResult Structure
Equals Overload
VisualComponents.Create3D Namespace


PickResult.GetHashCode Method

PickResultGetHashCode Method

Returns a hashcode for this object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32
the hahscode.
See Also

Reference

PickResult Structure
VisualComponents.Create3D Namespace


PickResult Operators

The PickResult type exposes the following members.

Operators
Name | Description
Equality | Determines whether the specified object instances are considered equal.
Inequality | Determines whether the specified object instances are not considered equal.
Top
See Also

Reference

PickResult Structure
VisualComponents.Create3D Namespace


PickResult.Equality Operator

PickResultEquality Operator

Determines whether the specified object instances are considered equal.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    PickResult result1,
    PickResult result2
)
public:
static bool operator ==(
    PickResult result1,
    PickResult result2
)

Parameters

result1
Type: VisualComponents.Create3DPickResult
The first object to compare.
result2
Type: VisualComponents.Create3DPickResult
The second object to compare.

Return Value

Type: Boolean
true if the objects are considered equal; otherwise, false.
See Also

Reference

PickResult Structure
VisualComponents.Create3D Namespace


PickResult.Inequality Operator

PickResultInequality Operator

Determines whether the specified object instances are not considered equal.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    PickResult result1,
    PickResult result2
)
public:
static bool operator !=(
    PickResult result1,
    PickResult result2
)

Parameters

result1
Type: VisualComponents.Create3DPickResult
The first object to compare.
result2
Type: VisualComponents.Create3DPickResult
The second object to compare.

Return Value

Type: Boolean
true if the objects are not considered equal; otherwise, true.
See Also

Reference

PickResult Structure
VisualComponents.Create3D Namespace


PlugIndication Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DPlugIndication

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class PlugIndication
public ref class PlugIndication sealed

The PlugIndication type exposes the following members.

Constructors
 | Name | Description
Public method | PlugIndication | Initializes a new instance of the PlugIndication class
Top
Properties
 | Name | Description
Public property | Closest |
Public property | Point1 |
Public property | Point2 |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


PlugIndication Constructor

Initializes a new instance of the PlugIndication class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PlugIndication()
public:
PlugIndication()
See Also

Reference

PlugIndication Class
VisualComponents.Create3D Namespace


PlugIndication Properties

The PlugIndication type exposes the following members.

Properties
 | Name | Description
Public property | Closest |
Public property | Point1 |
Public property | Point2 |
Top
See Also

Reference

PlugIndication Class
VisualComponents.Create3D Namespace


PlugIndication.Closest Property

PlugIndicationClosest Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Closest { get; set; }
public:
property bool Closest {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PlugIndication Class
VisualComponents.Create3D Namespace


PlugIndication.Point1 Property

PlugIndicationPoint1 Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 Point1 { get; set; }
public:
property Vector3 Point1 {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

PlugIndication Class
VisualComponents.Create3D Namespace


PlugIndication.Point2 Property

PlugIndicationPoint2 Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 Point2 { get; set; }
public:
property Vector3 Point2 {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

PlugIndication Class
VisualComponents.Create3D Namespace


PlugIndication Methods

The PlugIndication type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PlugIndication Class
VisualComponents.Create3D Namespace


PlugStatus Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum PlugStatus
public enum class PlugStatus
Members
Member name | Value | Description
None | 0 |
NoDocking | 1 |
DockingPossible | 2 |
Docked | 3 |
DockingImpossible | 4 |
See Also

Reference

VisualComponents.Create3D Namespace


PolylineCurve Class

This class contains information to create a polyline
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DCurveBase
VisualComponents.Create3DPolylineCurve

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PolylineCurve : CurveBase
public ref class PolylineCurve : public CurveBase

The PolylineCurve type exposes the following members.

Constructors
 | Name | Description
Public method | PolylineCurve | Initializes a new instance of the PolylineCurve class
Top
Properties
 | Name | Description
Public property | ControlPoints | (Overrides CurveBaseControlPoints.)
Public property | CurveType | (Overrides CurveBaseCurveType.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


PolylineCurve Constructor

Initializes a new instance of the PolylineCurve class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PolylineCurve(
    ICollection<Vector3> controlPoints
)
public:
PolylineCurve(
    ICollection<Vector3>^ controlPoints
)

Parameters

controlPoints
Type: System.Collections.GenericICollectionVector3
See Also

Reference

PolylineCurve Class
VisualComponents.Create3D Namespace


PolylineCurve Properties

The PolylineCurve type exposes the following members.

Properties
 | Name | Description
Public property | ControlPoints | (Overrides CurveBaseControlPoints.)
Public property | CurveType | (Overrides CurveBaseCurveType.)
Top
See Also

Reference

PolylineCurve Class
VisualComponents.Create3D Namespace


PolylineCurve.ControlPoints Property

PolylineCurveControlPoints Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override ReadOnlyCollection<Vector3> ControlPoints { get; }
public:
virtual property ReadOnlyCollection<Vector3>^ ControlPoints {
    ReadOnlyCollection<Vector3>^ get () override;
}

Property Value

Type: ReadOnlyCollectionVector3
See Also

Reference

PolylineCurve Class
VisualComponents.Create3D Namespace


PolylineCurve.CurveType Property

PolylineCurveCurveType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override CurveType CurveType { get; }
public:
virtual property CurveType CurveType {
    CurveType get () override;
}

Property Value

Type: CurveType
See Also

Reference

PolylineCurve Class
VisualComponents.Create3D Namespace


PolylineCurve Methods

The PolylineCurve type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PolylineCurve Class
VisualComponents.Create3D Namespace


PositionFrameAddedEventArgs Class

Provides data for PositionAdded event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DPositionFrameAddedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PositionFrameAddedEventArgs : EventArgs
public ref class PositionFrameAddedEventArgs : public EventArgs

The PositionFrameAddedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PositionFrameAddedEventArgs | Initializes a new instance of PositionFrameAddedEventArgs.
Top
Properties
 | Name | Description
Public property | Position | Gets the instance of IPositionFrame added to the container.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


PositionFrameAddedEventArgs Constructor

Initializes a new instance of PositionFrameAddedEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PositionFrameAddedEventArgs(
    IPositionFrame position
)
public:
PositionFrameAddedEventArgs(
    IPositionFrame^ position
)

Parameters

position
Type: VisualComponents.Create3DIPositionFrame
Added position.
See Also

Reference

PositionFrameAddedEventArgs Class
VisualComponents.Create3D Namespace


PositionFrameAddedEventArgs Properties

The PositionFrameAddedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Position | Gets the instance of IPositionFrame added to the container.
Top
See Also

Reference

PositionFrameAddedEventArgs Class
VisualComponents.Create3D Namespace


PositionFrameAddedEventArgs.Position Property

PositionFrameAddedEventArgsPosition Property

Gets the instance of IPositionFrame added to the container.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IPositionFrame Position { get; }
public:
property IPositionFrame^ Position {
    IPositionFrame^ get ();
}

Property Value

Type: IPositionFrame
See Also

Reference

PositionFrameAddedEventArgs Class
VisualComponents.Create3D Namespace


PositionFrameAddedEventArgs Methods

The PositionFrameAddedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PositionFrameAddedEventArgs Class
VisualComponents.Create3D Namespace


PositionFrameCollection Class

Collection of position statements and frames. Used for easier iteration of all position frames.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DPositionFrameCollection

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PositionFrameCollection : IEnumerable<PositionStatementFrame>,
    IEnumerable, IEnumerable<IPositionFrame>
public ref class PositionFrameCollection : IEnumerable<PositionStatementFrame^>,
    IEnumerable, IEnumerable<IPositionFrame^>

The PositionFrameCollection type exposes the following members.

Constructors
 | Name | Description
Public method | PositionFrameCollection(Boolean) | Creates a custom position frame collection, populated with AddIndexed().
Public method | PositionFrameCollection(IPathStatement, Int32) | Creates a collection of position frames from a path statement.
Public method | PositionFrameCollection(ListIPositionStatement, Int32) | Creates a collection of position frames from a list of statements.
Public method | PositionFrameCollection(IPositionStatement, Int32) | Creates a collection of position frames from a position statement.
Public method | PositionFrameCollection(IPathStatement, ISchemaPositionFrame, Boolean, Int32) | Creates a collection of position frames from a path statement and a subset of position frames.
Top
Properties
 | Name | Description
Public property | IndexedCount | Count of custom positions.
Top
Methods
 | Name | Description
Public method | AddIndexed | Populates custom position collection, created with PositionFrameCollection(true) constructor.
Public method | Dispose | Disposes this collection.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns enumerator of this collection.
Public method | GetFirst | Returns the first position frame.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLast | Returns the last position frame.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachIPositionFrame(ActionIPositionFrame) | Overloaded. Enumerate a cached collection performing the specified action on each item. (Defined by ForEachHelper.)
Public Extension Method | ForEachPositionStatementFrame(ActionPositionStatementFrame) | Overloaded. (Defined by ForEachHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | HasMoreThanPositionStatementFrame(Int32) | Overloaded. (Defined by EnumerableHelper.)
Public Extension Method | HasMoreThanIPositionFrame(Int32) | Overloaded. (Defined by EnumerableHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToObservableCollectionPositionStatementFrame | Overloaded. (Defined by Extensions.)
Public Extension Method | ToObservableCollectionIPositionFrame | Overloaded. (Defined by Extensions.)
Public Extension Method | ToObservableCollectionExPositionStatementFrame | Overloaded. (Defined by Extensions.)
Public Extension Method | ToObservableCollectionExIPositionFrame | Overloaded. (Defined by Extensions.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


PositionFrameCollection Constructor

Overload List
 | Name | Description
Public method | PositionFrameCollection(Boolean) | Creates a custom position frame collection, populated with AddIndexed().
Public method | PositionFrameCollection(IPathStatement, Int32) | Creates a collection of position frames from a path statement.
Public method | PositionFrameCollection(ListIPositionStatement, Int32) | Creates a collection of position frames from a list of statements.
Public method | PositionFrameCollection(IPositionStatement, Int32) | Creates a collection of position frames from a position statement.
Public method | PositionFrameCollection(IPathStatement, ISchemaPositionFrame, Boolean, Int32) | Creates a collection of position frames from a path statement and a subset of position frames.
Top
See Also

Reference

PositionFrameCollection Class
VisualComponents.Create3D Namespace


PositionFrameCollection Constructor (Boolean)

Creates a custom position frame collection, populated with AddIndexed().

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PositionFrameCollection(
    bool indexed
)
public:
PositionFrameCollection(
    bool indexed
)

Parameters

indexed
Type: SystemBoolean
See Also

Reference

PositionFrameCollection Class
PositionFrameCollection Overload
VisualComponents.Create3D Namespace


PositionFrameCollection Constructor (IPathStatement, Int32)

Creates a collection of position frames from a path statement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PositionFrameCollection(
    IPathStatement path,
    int myFirstIndex
)
public:
PositionFrameCollection(
    IPathStatement^ path,
    int myFirstIndex
)

Parameters

path
Type: VisualComponents.Create3DIPathStatement
myFirstIndex
Type: SystemInt32
Index of the first position frame
See Also

Reference

PositionFrameCollection Class
PositionFrameCollection Overload
VisualComponents.Create3D Namespace


PositionFrameCollection Constructor (List(IPositionStatement), Int32)

PositionFrameCollection Constructor (ListIPositionStatement, Int32)

Creates a collection of position frames from a list of statements.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PositionFrameCollection(
    List<IPositionStatement> statements,
    int myFirstIndex
)
public:
PositionFrameCollection(
    List<IPositionStatement^>^ statements,
    int myFirstIndex
)

Parameters

statements
Type: System.Collections.GenericListIPositionStatement
Position statements
myFirstIndex
Type: SystemInt32
Index of the first position frame
See Also

Reference

PositionFrameCollection Class
PositionFrameCollection Overload
VisualComponents.Create3D Namespace


PositionFrameCollection Constructor (IPositionStatement, Int32)

Creates a collection of position frames from a position statement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PositionFrameCollection(
    IPositionStatement statement,
    int myFirstIndex
)
public:
PositionFrameCollection(
    IPositionStatement^ statement,
    int myFirstIndex
)

Parameters

statement
Type: VisualComponents.Create3DIPositionStatement
Position statement
myFirstIndex
Type: SystemInt32
Index of the first position frame
See Also

Reference

PositionFrameCollection Class
PositionFrameCollection Overload
VisualComponents.Create3D Namespace


PositionFrameCollection Constructor (IPathStatement, ISchemaPositionFrame, Boolean, Int32)

Creates a collection of position frames from a path statement and a subset of position frames.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PositionFrameCollection(
    IPathStatement path,
    ISchemaPositionFrame pathFrameSet,
    bool onlyReferences,
    int myFirstIndex
)
public:
PositionFrameCollection(
    IPathStatement^ path,
    ISchemaPositionFrame^ pathFrameSet,
    bool onlyReferences,
    int myFirstIndex
)

Parameters

path
Type: VisualComponents.Create3DIPathStatement
Path statement
pathFrameSet
Type: VisualComponents.Create3DISchemaPositionFrame
Subset of position frames
onlyReferences
Type: SystemBoolean
Indicates that only reference frames should be included
myFirstIndex
Type: SystemInt32
Index of the first position frame
See Also

Reference

PositionFrameCollection Class
PositionFrameCollection Overload
VisualComponents.Create3D Namespace


PositionFrameCollection Properties

The PositionFrameCollection type exposes the following members.

Properties
 | Name | Description
Public property | IndexedCount | Count of custom positions.
Top
See Also

Reference

PositionFrameCollection Class
VisualComponents.Create3D Namespace


PositionFrameCollection.IndexedCount Property

PositionFrameCollectionIndexedCount Property

Count of custom positions.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int IndexedCount { get; }
public:
property int IndexedCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

PositionFrameCollection Class
VisualComponents.Create3D Namespace


PositionFrameCollection Methods

The PositionFrameCollection type exposes the following members.

Methods
 | Name | Description
Public method | AddIndexed | Populates custom position collection, created with PositionFrameCollection(true) constructor.
Public method | Dispose | Disposes this collection.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns enumerator of this collection.
Public method | GetFirst | Returns the first position frame.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLast | Returns the last position frame.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachIPositionFrame(ActionIPositionFrame) | Overloaded. Enumerate a cached collection performing the specified action on each item. (Defined by ForEachHelper.)
Public Extension Method | ForEachPositionStatementFrame(ActionPositionStatementFrame) | Overloaded. (Defined by ForEachHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | HasMoreThanPositionStatementFrame(Int32) | Overloaded. (Defined by EnumerableHelper.)
Public Extension Method | HasMoreThanIPositionFrame(Int32) | Overloaded. (Defined by EnumerableHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToObservableCollectionPositionStatementFrame | Overloaded. (Defined by Extensions.)
Public Extension Method | ToObservableCollectionIPositionFrame | Overloaded. (Defined by Extensions.)
Public Extension Method | ToObservableCollectionExPositionStatementFrame | Overloaded. (Defined by Extensions.)
Public Extension Method | ToObservableCollectionExIPositionFrame | Overloaded. (Defined by Extensions.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PositionFrameCollection Class
VisualComponents.Create3D Namespace


PositionFrameCollection.AddIndexed Method

PositionFrameCollectionAddIndexed Method

Populates custom position collection, created with PositionFrameCollection(true) constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void AddIndexed(
    IPositionStatement stat,
    int index
)
public:
void AddIndexed(
    IPositionStatement^ stat,
    int index
)

Parameters

stat
Type: VisualComponents.Create3DIPositionStatement
index
Type: SystemInt32
See Also

Reference

PositionFrameCollection Class
VisualComponents.Create3D Namespace


PositionFrameCollection.Dispose Method

PositionFrameCollectionDispose Method

Disposes this collection.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Dispose()
public:
void Dispose()
See Also

Reference

PositionFrameCollection Class
VisualComponents.Create3D Namespace


PositionFrameCollection.GetEnumerator Method

PositionFrameCollectionGetEnumerator Method

Returns enumerator of this collection.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerator<PositionStatementFrame> GetEnumerator()
public:
virtual IEnumerator<PositionStatementFrame^>^ GetEnumerator() sealed

Return Value

Type: IEnumeratorPositionStatementFrame

[Missing <returns> documentation for "M:VisualComponents.Create3D.PositionFrameCollection.GetEnumerator"]

Implements

IEnumerableTGetEnumerator
See Also

Reference

PositionFrameCollection Class
VisualComponents.Create3D Namespace


PositionFrameCollection.GetFirst Method

PositionFrameCollectionGetFirst Method

Returns the first position frame.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PositionStatementFrame GetFirst()
public:
PositionStatementFrame^ GetFirst()

Return Value

Type: PositionStatementFrame

[Missing <returns> documentation for "M:VisualComponents.Create3D.PositionFrameCollection.GetFirst"]

See Also

Reference

PositionFrameCollection Class
VisualComponents.Create3D Namespace


PositionFrameCollection.GetLast Method

PositionFrameCollectionGetLast Method

Returns the last position frame.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PositionStatementFrame GetLast()
public:
PositionStatementFrame^ GetLast()

Return Value

Type: PositionStatementFrame

[Missing <returns> documentation for "M:VisualComponents.Create3D.PositionFrameCollection.GetLast"]

See Also

Reference

PositionFrameCollection Class
VisualComponents.Create3D Namespace


PositionFrameHelper Class

Helper class for converting IMotionTarget to IPositionStatement and back.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DPositionFrameHelper

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class PositionFrameHelper
public ref class PositionFrameHelper abstract sealed

The PositionFrameHelper type exposes the following members.

Methods
Name | Description
FillPositionFromTarget(IMotionTarget, IPositionStatement, IPositionFrame, Boolean) | Update position statement's and position frame's values based on motion target.
FillPositionFromTarget(IMotionTarget, IPositionStatement, IPositionFrame, Boolean, Boolean) | Update position statement's and position frame's values based on motion target.
FillTargetFromPosition | Fill motion target with position statement/frame values.
GetFramesToUpdateIK | Helper method that creates PositionFrameCollection instance, that is used to iterate the position frames.
Top
See Also

Reference

VisualComponents.Create3D Namespace


PositionFrameHelper Methods

The PositionFrameHelper type exposes the following members.

Methods
Name | Description
FillPositionFromTarget(IMotionTarget, IPositionStatement, IPositionFrame, Boolean) | Update position statement's and position frame's values based on motion target.
FillPositionFromTarget(IMotionTarget, IPositionStatement, IPositionFrame, Boolean, Boolean) | Update position statement's and position frame's values based on motion target.
FillTargetFromPosition | Fill motion target with position statement/frame values.
GetFramesToUpdateIK | Helper method that creates PositionFrameCollection instance, that is used to iterate the position frames.
Top
See Also

Reference

PositionFrameHelper Class
VisualComponents.Create3D Namespace


PositionFrameHelper.FillPositionFromTarget Method

PositionFrameHelperFillPositionFromTarget Method

Overload List
Name | Description
FillPositionFromTarget(IMotionTarget, IPositionStatement, IPositionFrame, Boolean) | Update position statement's and position frame's values based on motion target.
FillPositionFromTarget(IMotionTarget, IPositionStatement, IPositionFrame, Boolean, Boolean) | Update position statement's and position frame's values based on motion target.
Top
See Also

Reference

PositionFrameHelper Class
VisualComponents.Create3D Namespace


PositionFrameHelper.FillPositionFromTarget Method (IMotionTarget, IPositionStatement, IPositionFrame, Boolean)

PositionFrameHelperFillPositionFromTarget Method (IMotionTarget, IPositionStatement, IPositionFrame, Boolean)

Update position statement's and position frame's values based on motion target.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void FillPositionFromTarget(
    IMotionTarget motionTarget,
    IPositionStatement posStatement,
    IPositionFrame posFrame,
    bool updateMatrix = true
)
public:
static void FillPositionFromTarget(
    IMotionTarget^ motionTarget,
    IPositionStatement^ posStatement,
    IPositionFrame^ posFrame,
    bool updateMatrix = true
)

Parameters

motionTarget
Type: VisualComponents.Create3DIMotionTarget
Source motion target
posStatement
Type: VisualComponents.Create3DIPositionStatement
Target position statement
posFrame
Type: VisualComponents.Create3DIPositionFrame
Target position frame
updateMatrix (Optional)
Type: SystemBoolean
See Also

Reference

PositionFrameHelper Class
FillPositionFromTarget Overload
VisualComponents.Create3D Namespace


PositionFrameHelper.FillPositionFromTarget Method (IMotionTarget, IPositionStatement, IPositionFrame, Boolean, Boolean)

PositionFrameHelperFillPositionFromTarget Method (IMotionTarget, IPositionStatement, IPositionFrame, Boolean, Boolean)

Update position statement's and position frame's values based on motion target.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void FillPositionFromTarget(
    IMotionTarget motionTarget,
    IPositionStatement posStatement,
    IPositionFrame posFrame,
    bool updateMatrix,
    bool updateExternalJoints
)
public:
static void FillPositionFromTarget(
    IMotionTarget^ motionTarget,
    IPositionStatement^ posStatement,
    IPositionFrame^ posFrame,
    bool updateMatrix,
    bool updateExternalJoints
)

Parameters

motionTarget
Type: VisualComponents.Create3DIMotionTarget
Source motion target
posStatement
Type: VisualComponents.Create3DIPositionStatement
Target position statement
posFrame
Type: VisualComponents.Create3DIPositionFrame
Target position frame
updateMatrix
Type: SystemBoolean
updateExternalJoints
Type: SystemBoolean
See Also

Reference

PositionFrameHelper Class
FillPositionFromTarget Overload
VisualComponents.Create3D Namespace


PositionFrameHelper.FillTargetFromPosition Method

PositionFrameHelperFillTargetFromPosition Method

Fill motion target with position statement/frame values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void FillTargetFromPosition(
    IMotionTarget motionTarget,
    IPositionStatement posStatement,
    IPositionFrame posFrame,
    Nullable<Matrix> frameLocalPos = null,
    Nullable<bool> useInternalJoints = null,
    Nullable<bool> findBestConfiguration = null
)
public:
static void FillTargetFromPosition(
    IMotionTarget^ motionTarget,
    IPositionStatement^ posStatement,
    IPositionFrame^ posFrame,
    Nullable<Matrix> frameLocalPos = nullptr,
    Nullable<bool> useInternalJoints = nullptr,
    Nullable<bool> findBestConfiguration = nullptr
)

Parameters

motionTarget
Type: VisualComponents.Create3DIMotionTarget
Target motion target
posStatement
Type: VisualComponents.Create3DIPositionStatement
Source position statement
posFrame
Type: VisualComponents.Create3DIPositionFrame
Source position frame
frameLocalPos (Optional)
Type: SystemNullableMatrix
Optional 3D position, defined in local coordinates
useInternalJoints (Optional)
Type: SystemNullableBoolean
findBestConfiguration (Optional)
Type: SystemNullableBoolean
See Also

Reference

PositionFrameHelper Class
VisualComponents.Create3D Namespace


PositionFrameHelper.GetFramesToUpdateIK Method

PositionFrameHelperGetFramesToUpdateIK Method

Helper method that creates PositionFrameCollection instance, that is used to iterate the position frames.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IEnumerable<IPositionFrame> GetFramesToUpdateIK(
    IPositionFrame frame
)
public:
static IEnumerable<IPositionFrame^>^ GetFramesToUpdateIK(
    IPositionFrame^ frame
)

Parameters

frame
Type: VisualComponents.Create3DIPositionFrame

Return Value

Type: IEnumerableIPositionFrame

[Missing <returns> documentation for "M:VisualComponents.Create3D.PositionFrameHelper.GetFramesToUpdateIK(VisualComponents.Create3D.IPositionFrame)"]

See Also

Reference

PositionFrameHelper Class
VisualComponents.Create3D Namespace


PositionFrameIterator Class

Position frame iterator. Use internally by PositionFrameCollection.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DPositionFrameIterator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PositionFrameIterator : IEnumerator<PositionStatementFrame>,
    IDisposable, IEnumerator, IEnumerator<IPositionFrame>
public ref class PositionFrameIterator : IEnumerator<PositionStatementFrame^>,
    IDisposable, IEnumerator, IEnumerator<IPositionFrame^>

The PositionFrameIterator type exposes the following members.

Constructors
 | Name | Description
Public method | PositionFrameIterator | Iterator constructor. Use internally by PositionFrameCollection.
Top
Properties
 | Name | Description
Public property | Current | Returns current item.
Top
Methods
 | Name | Description
Public method | Dispose | Disposes this iterator.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCount | Returns the total count of position frames.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Moves to the next position frame.
Public method | MoveTo | Moves to a specified position frame.
Public method | Reset | Restores iterator to original state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


PositionFrameIterator Constructor

Iterator constructor. Use internally by PositionFrameCollection.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PositionFrameIterator(
    PositionFrameCollection owner,
    int iteratorType,
    List<IPositionStatement> statements,
    IPositionStatement statement,
    IList<IPositionFrame> positions,
    IPathStatement path,
    ISchemaPositionFrame pathFrameSet,
    bool onlyReferences,
    List<Tuple<IPositionStatement, int>> indexedReferences,
    int myFirstIndex
)
public:
PositionFrameIterator(
    PositionFrameCollection^ owner,
    int iteratorType,
    List<IPositionStatement^>^ statements,
    IPositionStatement^ statement,
    IList<IPositionFrame^>^ positions,
    IPathStatement^ path,
    ISchemaPositionFrame^ pathFrameSet,
    bool onlyReferences,
    List<Tuple<IPositionStatement^, int>^>^ indexedReferences,
    int myFirstIndex
)

Parameters

owner
Type: VisualComponents.Create3DPositionFrameCollection
iteratorType
Type: SystemInt32
statements
Type: System.Collections.GenericListIPositionStatement
statement
Type: VisualComponents.Create3DIPositionStatement
positions
Type: System.Collections.GenericIListIPositionFrame
path
Type: VisualComponents.Create3DIPathStatement
pathFrameSet
Type: VisualComponents.Create3DISchemaPositionFrame
onlyReferences
Type: SystemBoolean
indexedReferences
Type: System.Collections.GenericListTupleIPositionStatement, Int32
myFirstIndex
Type: SystemInt32
See Also

Reference

PositionFrameIterator Class
VisualComponents.Create3D Namespace


PositionFrameIterator Properties

The PositionFrameIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Returns current item.
Top
See Also

Reference

PositionFrameIterator Class
VisualComponents.Create3D Namespace


PositionFrameIterator.Current Property

PositionFrameIteratorCurrent Property

Returns current item.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PositionStatementFrame Current { get; }
public:
virtual property PositionStatementFrame^ Current {
    PositionStatementFrame^ get () sealed;
}

Property Value

Type: PositionStatementFrame

Implements

IEnumeratorTCurrent
See Also

Reference

PositionFrameIterator Class
VisualComponents.Create3D Namespace


PositionFrameIterator Methods

The PositionFrameIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes this iterator.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCount | Returns the total count of position frames.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Moves to the next position frame.
Public method | MoveTo | Moves to a specified position frame.
Public method | Reset | Restores iterator to original state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PositionFrameIterator Class
VisualComponents.Create3D Namespace


PositionFrameIterator.Dispose Method

PositionFrameIteratorDispose Method

Disposes this iterator.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Dispose()
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

PositionFrameIterator Class
VisualComponents.Create3D Namespace


PositionFrameIterator.GetCount Method

PositionFrameIteratorGetCount Method

Returns the total count of position frames.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int GetCount()
public:
int GetCount()

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.PositionFrameIterator.GetCount"]

See Also

Reference

PositionFrameIterator Class
VisualComponents.Create3D Namespace


PositionFrameIterator.MoveNext Method

PositionFrameIteratorMoveNext Method

Moves to the next position frame.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool MoveNext()
public:
virtual bool MoveNext() sealed

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.PositionFrameIterator.MoveNext"]

Implements

IEnumeratorMoveNext
See Also

Reference

PositionFrameIterator Class
VisualComponents.Create3D Namespace


PositionFrameIterator.MoveTo Method

PositionFrameIteratorMoveTo Method

Moves to a specified position frame.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool MoveTo(
    int j
)
public:
bool MoveTo(
    int j
)

Parameters

j
Type: SystemInt32

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.PositionFrameIterator.MoveTo(System.Int32)"]

See Also

Reference

PositionFrameIterator Class
VisualComponents.Create3D Namespace


PositionFrameIterator.Reset Method

PositionFrameIteratorReset Method

Restores iterator to original state.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Reset()
public:
virtual void Reset() sealed

Implements

IEnumeratorReset
See Also

Reference

PositionFrameIterator Class
VisualComponents.Create3D Namespace


PositionFrameRemovingEventArgs Class

Provides data for PositionRemoving event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DPositionFrameRemovingEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PositionFrameRemovingEventArgs : EventArgs
public ref class PositionFrameRemovingEventArgs : public EventArgs

The PositionFrameRemovingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PositionFrameRemovingEventArgs | Initializes a new instance of PositionFrameRemovingEventArgs.
Top
Properties
 | Name | Description
Public property | Position | Gets the instance of IPositionFrame being removed from the container.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


PositionFrameRemovingEventArgs Constructor

Initializes a new instance of PositionFrameRemovingEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PositionFrameRemovingEventArgs(
    IPositionFrame position
)
public:
PositionFrameRemovingEventArgs(
    IPositionFrame^ position
)

Parameters

position
Type: VisualComponents.Create3DIPositionFrame
See Also

Reference

PositionFrameRemovingEventArgs Class
VisualComponents.Create3D Namespace


PositionFrameRemovingEventArgs Properties

The PositionFrameRemovingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Position | Gets the instance of IPositionFrame being removed from the container.
Top
See Also

Reference

PositionFrameRemovingEventArgs Class
VisualComponents.Create3D Namespace


PositionFrameRemovingEventArgs.Position Property

PositionFrameRemovingEventArgsPosition Property

Gets the instance of IPositionFrame being removed from the container.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IPositionFrame Position { get; }
public:
property IPositionFrame^ Position {
    IPositionFrame^ get ();
}

Property Value

Type: IPositionFrame
See Also

Reference

PositionFrameRemovingEventArgs Class
VisualComponents.Create3D Namespace


PositionFrameRemovingEventArgs Methods

The PositionFrameRemovingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PositionFrameRemovingEventArgs Class
VisualComponents.Create3D Namespace


PositionFrameTransformationChangedEventArgs Class

Provides data for PositionTransformationChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DPositionFrameTransformationChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PositionFrameTransformationChangedEventArgs : EventArgs
public ref class PositionFrameTransformationChangedEventArgs : public EventArgs

The PositionFrameTransformationChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PositionFrameTransformationChangedEventArgs | Initializes a new instance of PositionFrameTransformationChangedEventArgs.
Top
Properties
 | Name | Description
Public property | Position | Gets the position.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


PositionFrameTransformationChangedEventArgs Constructor

Initializes a new instance of PositionFrameTransformationChangedEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PositionFrameTransformationChangedEventArgs(
    IPositionFrame position
)
public:
PositionFrameTransformationChangedEventArgs(
    IPositionFrame^ position
)

Parameters

position
Type: VisualComponents.Create3DIPositionFrame
See Also

Reference

PositionFrameTransformationChangedEventArgs Class
VisualComponents.Create3D Namespace


PositionFrameTransformationChangedEventArgs Properties

The PositionFrameTransformationChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Position | Gets the position.
Top
See Also

Reference

PositionFrameTransformationChangedEventArgs Class
VisualComponents.Create3D Namespace


PositionFrameTransformationChangedEventArgs.Position Property

PositionFrameTransformationChangedEventArgsPosition Property

Gets the position.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IPositionFrame Position { get; }
public:
property IPositionFrame^ Position {
    IPositionFrame^ get ();
}

Property Value

Type: IPositionFrame
See Also

Reference

PositionFrameTransformationChangedEventArgs Class
VisualComponents.Create3D Namespace


PositionFrameTransformationChangedEventArgs Methods

The PositionFrameTransformationChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PositionFrameTransformationChangedEventArgs Class
VisualComponents.Create3D Namespace


PositionStatementFrame Class

Encapsultes together a position frame and a position statement. Used for easier iteration of all position frames.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DPositionStatementFrame

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PositionStatementFrame
public ref class PositionStatementFrame

The PositionStatementFrame type exposes the following members.

Constructors
 | Name | Description
Public method | PositionStatementFrame | Initializes a new instance of the PositionStatementFrame class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Frame | Position frame.
Public field | FrameIndex | Position frame's index.
Public field | Index | Statement's index.
Public field | Statement | Position statement.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


PositionStatementFrame Constructor

Initializes a new instance of the PositionStatementFrame class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PositionStatementFrame()
public:
PositionStatementFrame()
See Also

Reference

PositionStatementFrame Class
VisualComponents.Create3D Namespace


PositionStatementFrame Methods

The PositionStatementFrame type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PositionStatementFrame Class
VisualComponents.Create3D Namespace


PositionStatementFrame Fields

The PositionStatementFrame type exposes the following members.

Fields
 | Name | Description
Public field | Frame | Position frame.
Public field | FrameIndex | Position frame's index.
Public field | Index | Statement's index.
Public field | Statement | Position statement.
Top
See Also

Reference

PositionStatementFrame Class
VisualComponents.Create3D Namespace


PositionStatementFrame.Frame Field

PositionStatementFrameFrame Field

Position frame.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IPositionFrame Frame
public:
IPositionFrame^ Frame

Field Value

Type: IPositionFrame
See Also

Reference

PositionStatementFrame Class
VisualComponents.Create3D Namespace


PositionStatementFrame.FrameIndex Field

PositionStatementFrameFrameIndex Field

Position frame's index.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int FrameIndex
public:
int FrameIndex

Field Value

Type: Int32
See Also

Reference

PositionStatementFrame Class
VisualComponents.Create3D Namespace


PositionStatementFrame.Index Field

PositionStatementFrameIndex Field

Statement's index.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Index
public:
int Index

Field Value

Type: Int32
See Also

Reference

PositionStatementFrame Class
VisualComponents.Create3D Namespace


PositionStatementFrame.Statement Field

PositionStatementFrameStatement Field

Position statement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IPositionStatement Statement
public:
IPositionStatement^ Statement

Field Value

Type: IPositionStatement
See Also

Reference

PositionStatementFrame Class
VisualComponents.Create3D Namespace


PositionStatus Enumeration

State of motion target inverse kinematics. Note: Currently the NoSingularity flag is not checked in IsStatusValid.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[FlagsAttribute]
public enum PositionStatus
[FlagsAttribute]
public enum class PositionStatus
Members
Member name | Value | Description
Reachable | 1 | Motion target can be reached.
WithinJointLimits | 2 | Robot joints are within limits.
NoSingularity | 4 | There's no singularity at target position.
Valid | 7 | Target is completely valid. Note: similar to IMotionTarget.IsStatusValid.
See Also

Reference

VisualComponents.Create3D Namespace


PossibleConnection Class

Class returned when calling CheckInNode or CheckProximity of IPlugAndPlayLogicalHelper
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DPossibleConnection

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class PossibleConnection
public ref class PossibleConnection sealed

The PossibleConnection type exposes the following members.

Constructors
 | Name | Description
Public method | PossibleConnection | Initializes a new instance of the PossibleConnection class
Top
Properties
 | Name | Description
Public property | AbstractInterface |
Public property | Component |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


PossibleConnection Constructor

Initializes a new instance of the PossibleConnection class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PossibleConnection()
public:
PossibleConnection()
See Also

Reference

PossibleConnection Class
VisualComponents.Create3D Namespace


PossibleConnection Properties

The PossibleConnection type exposes the following members.

Properties
 | Name | Description
Public property | AbstractInterface |
Public property | Component |
Top
See Also

Reference

PossibleConnection Class
VisualComponents.Create3D Namespace


PossibleConnection.AbstractInterface Property

PossibleConnectionAbstractInterface Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimInterface AbstractInterface { get; set; }
public:
property ISimInterface^ AbstractInterface {
    ISimInterface^ get ();
    void set (ISimInterface^ value);
}

Property Value

Type: ISimInterface
See Also

Reference

PossibleConnection Class
VisualComponents.Create3D Namespace


PossibleConnection.Component Property

PossibleConnectionComponent Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimNode Component { get; set; }
public:
property ISimNode^ Component {
    ISimNode^ get ();
    void set (ISimNode^ value);
}

Property Value

Type: ISimNode
See Also

Reference

PossibleConnection Class
VisualComponents.Create3D Namespace


PossibleConnection Methods

The PossibleConnection type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PossibleConnection Class
VisualComponents.Create3D Namespace


PRC Enumeration

PRC -> All Versions

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum PRC
public enum class PRC
Members
Member name | Value | Description
PRC | 0 |
See Also

Reference

VisualComponents.Create3D Namespace


PresetMode Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum PresetMode
public enum class PresetMode
Members
Member name | Value | Description
Wireframe | 0 |
AllEdgesShaded | 1 |
SilhouetteEdgesShaded | 2 |
XRayShaded | 3 |
Shaded | 4 |
MaterialShaded | 5 |
RealisticShaded | 6 |
SilhouetteEdgesRealisticShaded | 7 |
See Also

Reference

VisualComponents.Create3D Namespace


PrimitiveType Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum PrimitiveType
public enum class PrimitiveType
Members
Member name | Value | Description
GeometrySet | 0 |
Frame | 1 |
PositionFrame | 2 |
See Also

Reference

VisualComponents.Create3D Namespace


ProcessAddedEventArgs Class

Provides data for ProcessAdded event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DProcessAddedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ProcessAddedEventArgs : EventArgs
public ref class ProcessAddedEventArgs : public EventArgs

The ProcessAddedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ProcessAddedEventArgs | Initializes a new instance of ProcessAddedEventArgs.
Top
Properties
 | Name | Description
Public property | Process | Process that has been added.
Public property | ProcessGroup | Group where the process has been added.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ProcessAddedEventArgs Constructor

Initializes a new instance of ProcessAddedEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProcessAddedEventArgs(
    IProcessRoutine process,
    IProcessGroup processGroup
)
public:
ProcessAddedEventArgs(
    IProcessRoutine^ process,
    IProcessGroup^ processGroup
)

Parameters

process
Type: VisualComponents.Create3DIProcessRoutine
Added process.
processGroup
Type: VisualComponents.Create3DIProcessGroup
Group containing the process.
See Also

Reference

ProcessAddedEventArgs Class
VisualComponents.Create3D Namespace


ProcessAddedEventArgs Properties

The ProcessAddedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Process | Process that has been added.
Public property | ProcessGroup | Group where the process has been added.
Top
See Also

Reference

ProcessAddedEventArgs Class
VisualComponents.Create3D Namespace


ProcessAddedEventArgs.Process Property

ProcessAddedEventArgsProcess Property

Process that has been added.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProcessRoutine Process { get; }
public:
property IProcessRoutine^ Process {
    IProcessRoutine^ get ();
}

Property Value

Type: IProcessRoutine
See Also

Reference

ProcessAddedEventArgs Class
VisualComponents.Create3D Namespace


ProcessAddedEventArgs.ProcessGroup Property

ProcessAddedEventArgsProcessGroup Property

Group where the process has been added.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProcessGroup ProcessGroup { get; }
public:
property IProcessGroup^ ProcessGroup {
    IProcessGroup^ get ();
}

Property Value

Type: IProcessGroup
See Also

Reference

ProcessAddedEventArgs Class
VisualComponents.Create3D Namespace


ProcessAddedEventArgs Methods

The ProcessAddedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProcessAddedEventArgs Class
VisualComponents.Create3D Namespace


ProcessDelayTimeSource Enumeration

Options for delay time source in IProcessDelayStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ProcessDelayTimeSource
public enum class ProcessDelayTimeSource
Members
Member name | Value | Description
Distribution | 0 | Take a sample from the Distribution property.
Expression | 1 | Evaluate the Expression property and use the result value.
See Also

Reference

VisualComponents.Create3D Namespace


ProcessFlowGroupAddedEventArgs Class

Data for GroupAdded event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DProcessFlowGroupAddedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ProcessFlowGroupAddedEventArgs : EventArgs
public ref class ProcessFlowGroupAddedEventArgs : public EventArgs

The ProcessFlowGroupAddedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ProcessFlowGroupAddedEventArgs | Initializes a new instance of ProcessFlowGroupAddedEventArgs.
Top
Properties
 | Name | Description
Public property | Group | Gets the group that has been added.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ProcessFlowGroupAddedEventArgs Constructor

Initializes a new instance of ProcessFlowGroupAddedEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProcessFlowGroupAddedEventArgs(
    IProcessFlowGroup group
)
public:
ProcessFlowGroupAddedEventArgs(
    IProcessFlowGroup^ group
)

Parameters

group
Type: VisualComponents.Create3DIProcessFlowGroup
Group that has been added.
See Also

Reference

ProcessFlowGroupAddedEventArgs Class
VisualComponents.Create3D Namespace


ProcessFlowGroupAddedEventArgs Properties

The ProcessFlowGroupAddedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Group | Gets the group that has been added.
Top
See Also

Reference

ProcessFlowGroupAddedEventArgs Class
VisualComponents.Create3D Namespace


ProcessFlowGroupAddedEventArgs.Group Property

ProcessFlowGroupAddedEventArgsGroup Property

Gets the group that has been added.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProcessFlowGroup Group { get; }
public:
property IProcessFlowGroup^ Group {
    IProcessFlowGroup^ get ();
}

Property Value

Type: IProcessFlowGroup
See Also

Reference

ProcessFlowGroupAddedEventArgs Class
VisualComponents.Create3D Namespace


ProcessFlowGroupAddedEventArgs Methods

The ProcessFlowGroupAddedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProcessFlowGroupAddedEventArgs Class
VisualComponents.Create3D Namespace


ProcessFlowGroupDeleteChange Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DChange
VisualComponents.Create3DProcessFlowGroupDeleteChange

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ProcessFlowGroupDeleteChange : Change
public ref class ProcessFlowGroupDeleteChange : public Change

The ProcessFlowGroupDeleteChange type exposes the following members.

Constructors
 | Name | Description
Public method | ProcessFlowGroupDeleteChange | Initializes a new instance of the ProcessFlowGroupDeleteChange class
Top
Properties
 | Name | Description
Protected property | Changeset | (Inherited from Change.)
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Protected property | TargetsList | Access to easier manipulation of targets in derived classes. (Inherited from Change.)
Top
Methods
 | Name | Description
Protected method | AddTarget | (Inherited from Change.)
Public method | Dispose | (Inherited from Change.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ProcessFlowGroupDeleteChange and optionally releases the managed resources (Overrides ChangeDispose(Boolean).)
Protected method | DoRedo | (Overrides ChangeDoRedo.)
Protected method | DoUndo | (Overrides ChangeDoUndo.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasValueChanged | (Inherited from Change.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ProcessFlowGroupDeleteChange Constructor

Initializes a new instance of the ProcessFlowGroupDeleteChange class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProcessFlowGroupDeleteChange(
    IMemento<IProcessFlowGroup> memento
)
public:
ProcessFlowGroupDeleteChange(
    IMemento<IProcessFlowGroup^>^ memento
)

Parameters

memento
Type: VisualComponents.Create3DIMemento IProcessFlowGroup
See Also

Reference

ProcessFlowGroupDeleteChange Class
VisualComponents.Create3D Namespace


ProcessFlowGroupDeleteChange Properties

The ProcessFlowGroupDeleteChange type exposes the following members.

Properties
 | Name | Description
Protected property | Changeset | (Inherited from Change.)
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Protected property | TargetsList | Access to easier manipulation of targets in derived classes. (Inherited from Change.)
Top
See Also

Reference

ProcessFlowGroupDeleteChange Class
VisualComponents.Create3D Namespace


ProcessFlowGroupDeleteChange Methods

The ProcessFlowGroupDeleteChange type exposes the following members.

Methods
 | Name | Description
Protected method | AddTarget | (Inherited from Change.)
Public method | Dispose | (Inherited from Change.)
Protected method | Dispose(Boolean) | (Overrides ChangeDispose(Boolean).)
Protected method | DoRedo | (Overrides ChangeDoRedo.)
Protected method | DoUndo | (Overrides ChangeDoUndo.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasValueChanged | (Inherited from Change.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProcessFlowGroupDeleteChange Class
VisualComponents.Create3D Namespace


ProcessFlowGroupDeleteChange.Dispose Method

ProcessFlowGroupDeleteChangeDispose Method

Overload List
 | Name | Description
Public method | Dispose | (Inherited from Change.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ProcessFlowGroupDeleteChange and optionally releases the managed resources (Overrides ChangeDispose(Boolean).)
Top
See Also

Reference

ProcessFlowGroupDeleteChange Class
VisualComponents.Create3D Namespace


ProcessFlowGroupDeleteChange.Dispose Method (Boolean)

ProcessFlowGroupDeleteChangeDispose Method (Boolean)

Releases the unmanaged resources used by the ProcessFlowGroupDeleteChange and optionally releases the managed resources

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void Dispose(
    bool disposing
)
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

ProcessFlowGroupDeleteChange Class
Dispose Overload
VisualComponents.Create3D Namespace


ProcessFlowGroupDeleteChange.DoRedo Method

ProcessFlowGroupDeleteChangeDoRedo Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void DoRedo()
protected:
virtual void DoRedo() override
See Also

Reference

ProcessFlowGroupDeleteChange Class
VisualComponents.Create3D Namespace


ProcessFlowGroupDeleteChange.DoUndo Method

ProcessFlowGroupDeleteChangeDoUndo Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void DoUndo()
protected:
virtual void DoUndo() override
See Also

Reference

ProcessFlowGroupDeleteChange Class
VisualComponents.Create3D Namespace


ProcessFlowGroupRemovingEventArgs Class

Data for GroupRemoving event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DProcessFlowGroupRemovingEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ProcessFlowGroupRemovingEventArgs : EventArgs
public ref class ProcessFlowGroupRemovingEventArgs : public EventArgs

The ProcessFlowGroupRemovingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ProcessFlowGroupRemovingEventArgs | Initializes a new instance of ProcessFlowGroupRemovingEventArgs.
Top
Properties
 | Name | Description
Public property | Group | Gets the group that is being removed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ProcessFlowGroupRemovingEventArgs Constructor

Initializes a new instance of ProcessFlowGroupRemovingEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProcessFlowGroupRemovingEventArgs(
    IProcessFlowGroup group
)
public:
ProcessFlowGroupRemovingEventArgs(
    IProcessFlowGroup^ group
)

Parameters

group
Type: VisualComponents.Create3DIProcessFlowGroup
Group that is being removed.
See Also

Reference

ProcessFlowGroupRemovingEventArgs Class
VisualComponents.Create3D Namespace


ProcessFlowGroupRemovingEventArgs Properties

The ProcessFlowGroupRemovingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Group | Gets the group that is being removed.
Top
See Also

Reference

ProcessFlowGroupRemovingEventArgs Class
VisualComponents.Create3D Namespace


ProcessFlowGroupRemovingEventArgs.Group Property

ProcessFlowGroupRemovingEventArgsGroup Property

Gets the group that is being removed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProcessFlowGroup Group { get; }
public:
property IProcessFlowGroup^ Group {
    IProcessFlowGroup^ get ();
}

Property Value

Type: IProcessFlowGroup
See Also

Reference

ProcessFlowGroupRemovingEventArgs Class
VisualComponents.Create3D Namespace


ProcessFlowGroupRemovingEventArgs Methods

The ProcessFlowGroupRemovingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProcessFlowGroupRemovingEventArgs Class
VisualComponents.Create3D Namespace


ProcessGroupIdChangedEventArgs Class

Provides data for ProcessGroupIdChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DProcessGroupIdChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ProcessGroupIdChangedEventArgs : EventArgs
public ref class ProcessGroupIdChangedEventArgs : public EventArgs

The ProcessGroupIdChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ProcessGroupIdChangedEventArgs | Initializes a new instance of ProcessRemovedEventArgs.
Top
Properties
 | Name | Description
Public property | PreviousId | Previous id of the process group.
Public property | ProcessGroup | The renamed process group.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ProcessGroupIdChangedEventArgs Constructor

Initializes a new instance of ProcessRemovedEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProcessGroupIdChangedEventArgs(
    IProcessGroup processGroup,
    string oldId
)
public:
ProcessGroupIdChangedEventArgs(
    IProcessGroup^ processGroup,
    String^ oldId
)

Parameters

processGroup
Type: VisualComponents.Create3DIProcessGroup
The group that had its id changed.
oldId
Type: SystemString
Group id before the change.
See Also

Reference

ProcessGroupIdChangedEventArgs Class
VisualComponents.Create3D Namespace


ProcessGroupIdChangedEventArgs Properties

The ProcessGroupIdChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | PreviousId | Previous id of the process group.
Public property | ProcessGroup | The renamed process group.
Top
See Also

Reference

ProcessGroupIdChangedEventArgs Class
VisualComponents.Create3D Namespace


ProcessGroupIdChangedEventArgs.PreviousId Property

ProcessGroupIdChangedEventArgsPreviousId Property

Previous id of the process group.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string PreviousId { get; }
public:
property String^ PreviousId {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ProcessGroupIdChangedEventArgs Class
VisualComponents.Create3D Namespace


ProcessGroupIdChangedEventArgs.ProcessGroup Property

ProcessGroupIdChangedEventArgsProcessGroup Property

The renamed process group.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProcessGroup ProcessGroup { get; }
public:
property IProcessGroup^ ProcessGroup {
    IProcessGroup^ get ();
}

Property Value

Type: IProcessGroup
See Also

Reference

ProcessGroupIdChangedEventArgs Class
VisualComponents.Create3D Namespace


ProcessGroupIdChangedEventArgs Methods

The ProcessGroupIdChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProcessGroupIdChangedEventArgs Class
VisualComponents.Create3D Namespace


ProcessRemovedEventArgs Class

Provides data for ProcessRemoved event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DProcessRemovedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ProcessRemovedEventArgs : EventArgs
public ref class ProcessRemovedEventArgs : public EventArgs

The ProcessRemovedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ProcessRemovedEventArgs | Initializes a new instance of ProcessRemovedEventArgs.
Top
Properties
 | Name | Description
Public property | Process | Process that was removed.
Public property | ProcessGroup | Group that contained removed process.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ProcessRemovedEventArgs Constructor

Initializes a new instance of ProcessRemovedEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProcessRemovedEventArgs(
    IProcessRoutine process,
    IProcessGroup processGroup
)
public:
ProcessRemovedEventArgs(
    IProcessRoutine^ process,
    IProcessGroup^ processGroup
)

Parameters

process
Type: VisualComponents.Create3DIProcessRoutine
Removed process.
processGroup
Type: VisualComponents.Create3DIProcessGroup
Group that contained the process.
See Also

Reference

ProcessRemovedEventArgs Class
VisualComponents.Create3D Namespace


ProcessRemovedEventArgs Properties

The ProcessRemovedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Process | Process that was removed.
Public property | ProcessGroup | Group that contained removed process.
Top
See Also

Reference

ProcessRemovedEventArgs Class
VisualComponents.Create3D Namespace


ProcessRemovedEventArgs.Process Property

ProcessRemovedEventArgsProcess Property

Process that was removed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProcessRoutine Process { get; }
public:
property IProcessRoutine^ Process {
    IProcessRoutine^ get ();
}

Property Value

Type: IProcessRoutine
See Also

Reference

ProcessRemovedEventArgs Class
VisualComponents.Create3D Namespace


ProcessRemovedEventArgs.ProcessGroup Property

ProcessRemovedEventArgsProcessGroup Property

Group that contained removed process.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProcessGroup ProcessGroup { get; }
public:
property IProcessGroup^ ProcessGroup {
    IProcessGroup^ get ();
}

Property Value

Type: IProcessGroup
See Also

Reference

ProcessRemovedEventArgs Class
VisualComponents.Create3D Namespace


ProcessRemovedEventArgs Methods

The ProcessRemovedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProcessRemovedEventArgs Class
VisualComponents.Create3D Namespace


ProcessRemovingEventArgs Class

Provides data for ProcessRemoving event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DProcessRemovingEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ProcessRemovingEventArgs : EventArgs
public ref class ProcessRemovingEventArgs : public EventArgs

The ProcessRemovingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ProcessRemovingEventArgs | Initializes a new instance of ProcessRemovingEventArgs.
Top
Properties
 | Name | Description
Public property | Process | Process that is being removed.
Public property | ProcessGroup | Group containing the process.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ProcessRemovingEventArgs Constructor

Initializes a new instance of ProcessRemovingEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProcessRemovingEventArgs(
    IProcessRoutine process,
    IProcessGroup processGroup
)
public:
ProcessRemovingEventArgs(
    IProcessRoutine^ process,
    IProcessGroup^ processGroup
)

Parameters

process
Type: VisualComponents.Create3DIProcessRoutine
Removing process.
processGroup
Type: VisualComponents.Create3DIProcessGroup
Group containing the process.
See Also

Reference

ProcessRemovingEventArgs Class
VisualComponents.Create3D Namespace


ProcessRemovingEventArgs Properties

The ProcessRemovingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Process | Process that is being removed.
Public property | ProcessGroup | Group containing the process.
Top
See Also

Reference

ProcessRemovingEventArgs Class
VisualComponents.Create3D Namespace


ProcessRemovingEventArgs.Process Property

ProcessRemovingEventArgsProcess Property

Process that is being removed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProcessRoutine Process { get; }
public:
property IProcessRoutine^ Process {
    IProcessRoutine^ get ();
}

Property Value

Type: IProcessRoutine
See Also

Reference

ProcessRemovingEventArgs Class
VisualComponents.Create3D Namespace


ProcessRemovingEventArgs.ProcessGroup Property

ProcessRemovingEventArgsProcessGroup Property

Group containing the process.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProcessGroup ProcessGroup { get; }
public:
property IProcessGroup^ ProcessGroup {
    IProcessGroup^ get ();
}

Property Value

Type: IProcessGroup
See Also

Reference

ProcessRemovingEventArgs Class
VisualComponents.Create3D Namespace


ProcessRemovingEventArgs Methods

The ProcessRemovingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProcessRemovingEventArgs Class
VisualComponents.Create3D Namespace


ProcessWorkStatementTimeSource Enumeration

Options for process time source in IWorkStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ProcessWorkStatementTimeSource
public enum class ProcessWorkStatementTimeSource
Members
Member name | Value | Description
Distribution | 0 | Take a sample from the Distribution property.
Expression | 1 | Evaluate the Expression property and use the result value.
See Also

Reference

VisualComponents.Create3D Namespace


ProductCreatorFeedMode Enumeration

Feed mode options for FeedMode selection.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ProductCreatorFeedMode
public enum class ProductCreatorFeedMode
Members
Member name | Value | Description
Single | 0 | Creates instances of a single IProductType at a given time interval until the limit is reached.
Batch | 1 | Creates batches of IProductType instances in a sequence. Each batch defines the type of ISimProduct to create, interval between instances and the maximum number of products to be created.
Table | 2 | Creates products in a sequence based on individually defined IProductType and creation time.
Distribution | 3 | Creates products with the IProductType selected in random but according to a distribution of possible choices.
See Also

Reference

VisualComponents.Create3D Namespace


ProductCreatorTableRow Structure

Defines a single ISimProduct to be created at simulation time CreationTime. Used in IProductCreatorTableMode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct ProductCreatorTableRow : IEquatable<ProductCreatorTableRow>
public value class ProductCreatorTableRow : IEquatable<ProductCreatorTableRow>

The ProductCreatorTableRow type exposes the following members.

Constructors
 | Name | Description
Public method | ProductCreatorTableRow | Constructs a new ProductCreatorTableRow instance.
Top
Properties
 | Name | Description
Public property | CreationTime | Gets or sets the simulation time when to create the product instance.
Public property | ProductType | Gets or sets the type of product to instantiate.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Shallow untyped equality comparison. (Overrides ValueTypeEquals(Object).)
Public method | Equals(ProductCreatorTableRow) | Shallow typed equality comparison.
Public method | GetHashCode | Hash code generation. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Equality | Equality comparison using Equals(ProductCreatorTableRow)
Inequality | Inequality comparison using Equals(ProductCreatorTableRow)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks
Note that this is a managed value type, so editing it will only edit a copy.
See Also

Reference

VisualComponents.Create3D Namespace


ProductCreatorTableRow Constructor

Constructs a new ProductCreatorTableRow instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProductCreatorTableRow(
    double creationTime,
    IProductType productType
)
public:
ProductCreatorTableRow(
    double creationTime,
    IProductType^ productType
)

Parameters

creationTime
Type: SystemDouble
Value for CreationTime
productType
Type: VisualComponents.Create3DIProductType
Value for ProductType
Exceptions
Exception | Condition
ArgumentOutOfRangeException |
NullReferenceException |
InvalidWrapperException |
See Also

Reference

ProductCreatorTableRow Structure
VisualComponents.Create3D Namespace


ProductCreatorTableRow Properties

The ProductCreatorTableRow type exposes the following members.

Properties
 | Name | Description
Public property | CreationTime | Gets or sets the simulation time when to create the product instance.
Public property | ProductType | Gets or sets the type of product to instantiate.
Top
See Also

Reference

ProductCreatorTableRow Structure
VisualComponents.Create3D Namespace


ProductCreatorTableRow.CreationTime Property

ProductCreatorTableRowCreationTime Property

Gets or sets the simulation time when to create the product instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double CreationTime { get; set; }
public:
property double CreationTime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Occurs when value is not 0 or a finite positive number.
See Also

Reference

ProductCreatorTableRow Structure
VisualComponents.Create3D Namespace


ProductCreatorTableRow.ProductType Property

ProductCreatorTableRowProductType Property

Gets or sets the type of product to instantiate.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProductType ProductType { get; set; }
public:
property IProductType^ ProductType {
    IProductType^ get ();
    void set (IProductType^ value);
}

Property Value

Type: IProductType
Exceptions
Exception | Condition
ArgumentNullException |
See Also

Reference

ProductCreatorTableRow Structure
VisualComponents.Create3D Namespace


ProductCreatorTableRow Methods

The ProductCreatorTableRow type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Shallow untyped equality comparison. (Overrides ValueTypeEquals(Object).)
Public method | Equals(ProductCreatorTableRow) | Shallow typed equality comparison.
Public method | GetHashCode | Hash code generation. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProductCreatorTableRow Structure
VisualComponents.Create3D Namespace


ProductCreatorTableRow.Equals Method

ProductCreatorTableRowEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Shallow untyped equality comparison. (Overrides ValueTypeEquals(Object).)
Public method | Equals(ProductCreatorTableRow) | Shallow typed equality comparison.
Top
See Also

Reference

ProductCreatorTableRow Structure
VisualComponents.Create3D Namespace


ProductCreatorTableRow.Equals Method (Object)

ProductCreatorTableRowEquals Method (Object)

Shallow untyped equality comparison.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ProductCreatorTableRow.Equals(System.Object)"]

See Also

Reference

ProductCreatorTableRow Structure
Equals Overload
VisualComponents.Create3D Namespace


ProductCreatorTableRow.Equals Method (ProductCreatorTableRow)

ProductCreatorTableRowEquals Method (ProductCreatorTableRow)

Shallow typed equality comparison.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    ProductCreatorTableRow other
)
public:
virtual bool Equals(
    ProductCreatorTableRow other
) sealed

Parameters

other
Type: VisualComponents.Create3DProductCreatorTableRow

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ProductCreatorTableRow.Equals(VisualComponents.Create3D.ProductCreatorTableRow)"]

Implements

IEquatableTEquals(T)
See Also

Reference

ProductCreatorTableRow Structure
Equals Overload
VisualComponents.Create3D Namespace


ProductCreatorTableRow.GetHashCode Method

ProductCreatorTableRowGetHashCode Method

Hash code generation.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.ProductCreatorTableRow.GetHashCode"]

See Also

Reference

ProductCreatorTableRow Structure
VisualComponents.Create3D Namespace


ProductCreatorTableRow Operators

The ProductCreatorTableRow type exposes the following members.

Operators
Name | Description
Equality | Equality comparison using Equals(ProductCreatorTableRow)
Inequality | Inequality comparison using Equals(ProductCreatorTableRow)
Top
See Also

Reference

ProductCreatorTableRow Structure
VisualComponents.Create3D Namespace


ProductCreatorTableRow.Equality Operator

ProductCreatorTableRowEquality Operator

Equality comparison using Equals(ProductCreatorTableRow)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    ProductCreatorTableRow row1,
    ProductCreatorTableRow row2
)
public:
static bool operator ==(
    ProductCreatorTableRow row1,
    ProductCreatorTableRow row2
)

Parameters

row1
Type: VisualComponents.Create3DProductCreatorTableRow
row2
Type: VisualComponents.Create3DProductCreatorTableRow

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ProductCreatorTableRow.op_Equality(VisualComponents.Create3D.ProductCreatorTableRow,VisualComponents.Create3D.ProductCreatorTableRow)"]

See Also

Reference

ProductCreatorTableRow Structure
VisualComponents.Create3D Namespace


ProductCreatorTableRow.Inequality Operator

ProductCreatorTableRowInequality Operator

Inequality comparison using Equals(ProductCreatorTableRow)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    ProductCreatorTableRow row1,
    ProductCreatorTableRow row2
)
public:
static bool operator !=(
    ProductCreatorTableRow row1,
    ProductCreatorTableRow row2
)

Parameters

row1
Type: VisualComponents.Create3DProductCreatorTableRow
row2
Type: VisualComponents.Create3DProductCreatorTableRow

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ProductCreatorTableRow.op_Inequality(VisualComponents.Create3D.ProductCreatorTableRow,VisualComponents.Create3D.ProductCreatorTableRow)"]

See Also

Reference

ProductCreatorTableRow Structure
VisualComponents.Create3D Namespace


ProductEntriesChangedEventArgs Class

Event arguments for ProductEntriesChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DProductEntriesChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ProductEntriesChangedEventArgs : EventArgs
public ref class ProductEntriesChangedEventArgs : public EventArgs

The ProductEntriesChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ProductEntriesChangedEventArgs | Initializes a new instance of the ProductEntriesChangedEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ProductEntriesChangedEventArgs Constructor

Initializes a new instance of the ProductEntriesChangedEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProductEntriesChangedEventArgs()
public:
ProductEntriesChangedEventArgs()
See Also

Reference

ProductEntriesChangedEventArgs Class
VisualComponents.Create3D Namespace


ProductEntriesChangedEventArgs Methods

The ProductEntriesChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProductEntriesChangedEventArgs Class
VisualComponents.Create3D Namespace


ProductFeature Structure

Product licensing feature identifier value class.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct ProductFeature : IComparable<ProductFeature>
public value class ProductFeature : IComparable<ProductFeature>

The ProductFeature type exposes the following members.

Constructors
 | Name | Description
Public method | ProductFeature(LicensingServiceFeature) | Initializing constructor.
Public method | ProductFeature(String, String) | Initializing constructor.
Top
Properties
 | Name | Description
Public property | Name | Product feature name.
Public property | Version | Product feature version string.
Top
Methods
 | Name | Description
Public method | CompareTo | Compare to other product feature.
Public method | Equals(Object) | Test for equality with object (Overrides ValueTypeEquals(Object).)
Public method | Equals(ProductFeature) | Test for equality with other product feature
Public method | GetHashCode | Get the hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | MakeFeatureSpec | Make feature specification string from product features.
 | ParseFeatureSpec | Parse feature specification string to set of product features.
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Equality | Equality operator
GreaterThan | Greater than operator
GreaterThanOrEqual | Greater than or equal operator
Inequality | Inequality operator
LessThan | Less than operator
LessThanOrEqual | Less than or equal operator
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks

A product feature instance describes a licensed feature that is enabled in the current licensing configuration of the product.

Note that the licensing module imposes additional constraints on the length and characters of the name and version strings, and that these constraints are not enforced by this value class.

See Also

Reference

VisualComponents.Create3D Namespace


ProductFeature Constructor

Overload List
 | Name | Description
Public method | ProductFeature(LicensingServiceFeature) | Initializing constructor.
Public method | ProductFeature(String, String) | Initializing constructor.
Top
See Also

Reference

ProductFeature Structure
VisualComponents.Create3D Namespace


ProductFeature Constructor (LicensingServiceFeature)

Initializing constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProductFeature(
    LicensingServiceFeature feature
)
public:
ProductFeature(
    LicensingServiceFeature feature
)

Parameters

feature
Type: VisualComponents.Create3DLicensingServiceFeature
An object returned from ILicensingService
See Also

Reference

ProductFeature Structure
ProductFeature Overload
VisualComponents.Create3D Namespace


ProductFeature Constructor (String, String)

Initializing constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProductFeature(
    string name,
    string version
)
public:
ProductFeature(
    String^ name,
    String^ version
)

Parameters

name
Type: SystemString
Product feature name
version
Type: SystemString
Product feature version
See Also

Reference

ProductFeature Structure
ProductFeature Overload
VisualComponents.Create3D Namespace


ProductFeature Properties

The ProductFeature type exposes the following members.

Properties
 | Name | Description
Public property | Name | Product feature name.
Public property | Version | Product feature version string.
Top
See Also

Reference

ProductFeature Structure
VisualComponents.Create3D Namespace


ProductFeature.Name Property

ProductFeatureName Property

Product feature name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; set; }
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ProductFeature Structure
VisualComponents.Create3D Namespace


ProductFeature.Version Property

ProductFeatureVersion Property

Product feature version string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Version { get; set; }
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ProductFeature Structure
VisualComponents.Create3D Namespace


ProductFeature Methods

The ProductFeature type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compare to other product feature.
Public method | Equals(Object) | Test for equality with object (Overrides ValueTypeEquals(Object).)
Public method | Equals(ProductFeature) | Test for equality with other product feature
Public method | GetHashCode | Get the hash code for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | MakeFeatureSpec | Make feature specification string from product features.
 | ParseFeatureSpec | Parse feature specification string to set of product features.
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProductFeature Structure
VisualComponents.Create3D Namespace


ProductFeature.CompareTo Method

ProductFeatureCompareTo Method

Compare to other product feature.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CompareTo(
    ProductFeature other
)
public:
virtual int CompareTo(
    ProductFeature other
) sealed

Parameters

other
Type: VisualComponents.Create3DProductFeature

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.ProductFeature.CompareTo(VisualComponents.Create3D.ProductFeature)"]

Implements

IComparableTCompareTo(T)
Remarks

Features are ordered first by version using ordinal sort, then by name using ordinal sort.

See Also

Reference

ProductFeature Structure
VisualComponents.Create3D Namespace


ProductFeature.Equals Method

ProductFeatureEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Test for equality with object (Overrides ValueTypeEquals(Object).)
Public method | Equals(ProductFeature) | Test for equality with other product feature
Top
See Also

Reference

ProductFeature Structure
VisualComponents.Create3D Namespace


ProductFeature.Equals Method (Object)

ProductFeatureEquals Method (Object)

Test for equality with object

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ProductFeature.Equals(System.Object)"]

See Also

Reference

ProductFeature Structure
Equals Overload
VisualComponents.Create3D Namespace


ProductFeature.Equals Method (ProductFeature)

ProductFeatureEquals Method (ProductFeature)

Test for equality with other product feature

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    ProductFeature other
)
public:
bool Equals(
    ProductFeature other
)

Parameters

other
Type: VisualComponents.Create3DProductFeature

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ProductFeature.Equals(VisualComponents.Create3D.ProductFeature)"]

See Also

Reference

ProductFeature Structure
Equals Overload
VisualComponents.Create3D Namespace


ProductFeature.GetHashCode Method

ProductFeatureGetHashCode Method

Get the hash code for this object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.ProductFeature.GetHashCode"]

See Also

Reference

ProductFeature Structure
VisualComponents.Create3D Namespace


ProductFeature.MakeFeatureSpec Method

ProductFeatureMakeFeatureSpec Method

Make feature specification string from product features.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string MakeFeatureSpec(
    IEnumerable<ProductFeature> features
)
public:
static String^ MakeFeatureSpec(
    IEnumerable<ProductFeature>^ features
)

Parameters

features
Type: System.Collections.GenericIEnumerableProductFeature
Product feature set to format

Return Value

Type: String
Feature specification string.
See Also

Reference

ProductFeature Structure
VisualComponents.Create3D Namespace


ProductFeature.ParseFeatureSpec Method

ProductFeatureParseFeatureSpec Method

Parse feature specification string to set of product features.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ISet<ProductFeature> ParseFeatureSpec(
    string featureSpec
)
public:
static ISet<ProductFeature>^ ParseFeatureSpec(
    String^ featureSpec
)

Parameters

featureSpec
Type: SystemString
Feature specification string.

Return Value

Type: ISetProductFeature
The parsed product-feature set.
Remarks

A feature specification string consists of feature-version pairs separated by pound ('#') signs.

Each feature-version pair consists of the feature and version, separated by a dollar ('$') sign.

See Also

Reference

ProductFeature Structure
VisualComponents.Create3D Namespace


ProductFeature Operators

The ProductFeature type exposes the following members.

Operators
Name | Description
Equality | Equality operator
GreaterThan | Greater than operator
GreaterThanOrEqual | Greater than or equal operator
Inequality | Inequality operator
LessThan | Less than operator
LessThanOrEqual | Less than or equal operator
Top
See Also

Reference

ProductFeature Structure
VisualComponents.Create3D Namespace


ProductFeature.Equality Operator

ProductFeatureEquality Operator

Equality operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    ProductFeature left,
    ProductFeature right
)
public:
static bool operator ==(
    ProductFeature left,
    ProductFeature right
)

Parameters

left
Type: VisualComponents.Create3DProductFeature
Left operand
right
Type: VisualComponents.Create3DProductFeature
Right operand

Return Value

Type: Boolean
True if both the name and version are equal.
See Also

Reference

ProductFeature Structure
VisualComponents.Create3D Namespace


ProductFeature.GreaterThan Operator

ProductFeatureGreaterThan Operator

Greater than operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator >(
    ProductFeature left,
    ProductFeature right
)
public:
static bool operator >(
    ProductFeature left,
    ProductFeature right
)

Parameters

left
Type: VisualComponents.Create3DProductFeature
right
Type: VisualComponents.Create3DProductFeature

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ProductFeature.op_GreaterThan(VisualComponents.Create3D.ProductFeature,VisualComponents.Create3D.ProductFeature)"]

See Also

Reference

ProductFeature Structure
VisualComponents.Create3D Namespace


ProductFeature.GreaterThanOrEqual Operator

ProductFeatureGreaterThanOrEqual Operator

Greater than or equal operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator >=(
    ProductFeature left,
    ProductFeature right
)
public:
static bool operator >=(
    ProductFeature left,
    ProductFeature right
)

Parameters

left
Type: VisualComponents.Create3DProductFeature
right
Type: VisualComponents.Create3DProductFeature

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ProductFeature.op_GreaterThanOrEqual(VisualComponents.Create3D.ProductFeature,VisualComponents.Create3D.ProductFeature)"]

See Also

Reference

ProductFeature Structure
VisualComponents.Create3D Namespace


ProductFeature.Inequality Operator

ProductFeatureInequality Operator

Inequality operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    ProductFeature left,
    ProductFeature right
)
public:
static bool operator !=(
    ProductFeature left,
    ProductFeature right
)

Parameters

left
Type: VisualComponents.Create3DProductFeature
Left operand
right
Type: VisualComponents.Create3DProductFeature
Right operand

Return Value

Type: Boolean
True if either the name or version strings are different.
See Also

Reference

ProductFeature Structure
VisualComponents.Create3D Namespace


ProductFeature.LessThan Operator

ProductFeatureLessThan Operator

Less than operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator <(
    ProductFeature left,
    ProductFeature right
)
public:
static bool operator <(
    ProductFeature left,
    ProductFeature right
)

Parameters

left
Type: VisualComponents.Create3DProductFeature
right
Type: VisualComponents.Create3DProductFeature

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ProductFeature.op_LessThan(VisualComponents.Create3D.ProductFeature,VisualComponents.Create3D.ProductFeature)"]

See Also

Reference

ProductFeature Structure
VisualComponents.Create3D Namespace


ProductFeature.LessThanOrEqual Operator

ProductFeatureLessThanOrEqual Operator

Less than or equal operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator <=(
    ProductFeature left,
    ProductFeature right
)
public:
static bool operator <=(
    ProductFeature left,
    ProductFeature right
)

Parameters

left
Type: VisualComponents.Create3DProductFeature
right
Type: VisualComponents.Create3DProductFeature

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.ProductFeature.op_LessThanOrEqual(VisualComponents.Create3D.ProductFeature,VisualComponents.Create3D.ProductFeature)"]

See Also

Reference

ProductFeature Structure
VisualComponents.Create3D Namespace


ProductLicenseConfiguration Class

Product license configuration settings persistency class.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DProductLicenseConfiguration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ProductLicenseConfiguration
public ref class ProductLicenseConfiguration

The ProductLicenseConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | ProductLicenseConfiguration | Construct an empty product license configuration.
Top
Properties
 | Name | Description
Public property | AcceptedKeyPattern | Pattern that must match entered key, as a regular expression.
Public property | IsKeyManaged | Whether or not the product key is externally managed.
Public property | LicenseSpecificationFileName | License specification file name.
Public property | ProductDescription | Product description string.
Public property | ProductFeature | Product feature specification string.
Public property | ProductFeatureVersion | Product version string, as displayed.
Public property | ProductName | Product name, as it should be displayed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks

This class is used when reading the product configuration settings from the license settings file.

See Also

Reference

VisualComponents.Create3D Namespace


ProductLicenseConfiguration Constructor

Construct an empty product license configuration.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProductLicenseConfiguration()
public:
ProductLicenseConfiguration()
See Also

Reference

ProductLicenseConfiguration Class
VisualComponents.Create3D Namespace


ProductLicenseConfiguration Properties

The ProductLicenseConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | AcceptedKeyPattern | Pattern that must match entered key, as a regular expression.
Public property | IsKeyManaged | Whether or not the product key is externally managed.
Public property | LicenseSpecificationFileName | License specification file name.
Public property | ProductDescription | Product description string.
Public property | ProductFeature | Product feature specification string.
Public property | ProductFeatureVersion | Product version string, as displayed.
Public property | ProductName | Product name, as it should be displayed.
Top
See Also

Reference

ProductLicenseConfiguration Class
VisualComponents.Create3D Namespace


ProductLicenseConfiguration.AcceptedKeyPattern Property

ProductLicenseConfigurationAcceptedKeyPattern Property

Pattern that must match entered key, as a regular expression.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AcceptedKeyPattern { get; set; }
public:
property String^ AcceptedKeyPattern {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
The pattern is tested against the filtered product key string, which does not include any hyphens.
See Also

Reference

ProductLicenseConfiguration Class
VisualComponents.Create3D Namespace


ProductLicenseConfiguration.IsKeyManaged Property

ProductLicenseConfigurationIsKeyManaged Property

Whether or not the product key is externally managed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsKeyManaged { get; set; }
public:
property bool IsKeyManaged {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ProductLicenseConfiguration Class
VisualComponents.Create3D Namespace


ProductLicenseConfiguration.LicenseSpecificationFileName Property

ProductLicenseConfigurationLicenseSpecificationFileName Property

License specification file name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string LicenseSpecificationFileName { get; set; }
public:
property String^ LicenseSpecificationFileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ProductLicenseConfiguration Class
VisualComponents.Create3D Namespace


ProductLicenseConfiguration.ProductDescription Property

ProductLicenseConfigurationProductDescription Property

Product description string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ProductDescription { get; set; }
public:
property String^ ProductDescription {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ProductLicenseConfiguration Class
VisualComponents.Create3D Namespace


ProductLicenseConfiguration.ProductFeature Property

ProductLicenseConfigurationProductFeature Property

Product feature specification string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ProductFeature { get; set; }
public:
property String^ ProductFeature {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ProductLicenseConfiguration Class
VisualComponents.Create3D Namespace


ProductLicenseConfiguration.ProductFeatureVersion Property

ProductLicenseConfigurationProductFeatureVersion Property

Product version string, as displayed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ProductFeatureVersion { get; set; }
public:
property String^ ProductFeatureVersion {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ProductLicenseConfiguration Class
VisualComponents.Create3D Namespace


ProductLicenseConfiguration.ProductName Property

ProductLicenseConfigurationProductName Property

Product name, as it should be displayed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ProductName { get; set; }
public:
property String^ ProductName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ProductLicenseConfiguration Class
VisualComponents.Create3D Namespace


ProductLicenseConfiguration Methods

The ProductLicenseConfiguration type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProductLicenseConfiguration Class
VisualComponents.Create3D Namespace


ProductLicenseType Enumeration

The product license source type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ProductLicenseType
public enum class ProductLicenseType
Members
Member name | Value | Description
NotFound | 0 | License not found at all.
RenewalNeeded | 1 | License found, but needs to be renewed.
Local | 2 | Local license found.
Server | 3 | Server license found.
ServerNotAvailable | 4 | License server configured, but not available.
CommuterCode | 5 | Commuted server license found.
See Also

Reference

VisualComponents.Create3D Namespace


ProductTypeAddedEventArgs Class

Provides data for ProductTypeAdded and ProductTypeRemoving events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DProductTypeAddedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ProductTypeAddedEventArgs : EventArgs
public ref class ProductTypeAddedEventArgs : public EventArgs

The ProductTypeAddedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ProductTypeAddedEventArgs | Initializes a new instance of ProductTypeAddedEventArgs.
Top
Properties
 | Name | Description
Public property | ProductType | Gets the product type.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ProductTypeAddedEventArgs Constructor

Initializes a new instance of ProductTypeAddedEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProductTypeAddedEventArgs(
    IProductType productType
)
public:
ProductTypeAddedEventArgs(
    IProductType^ productType
)

Parameters

productType
Type: VisualComponents.Create3DIProductType
Product type.
See Also

Reference

ProductTypeAddedEventArgs Class
VisualComponents.Create3D Namespace


ProductTypeAddedEventArgs Properties

The ProductTypeAddedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ProductType | Gets the product type.
Top
See Also

Reference

ProductTypeAddedEventArgs Class
VisualComponents.Create3D Namespace


ProductTypeAddedEventArgs.ProductType Property

ProductTypeAddedEventArgsProductType Property

Gets the product type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProductType ProductType { get; }
public:
property IProductType^ ProductType {
    IProductType^ get ();
}

Property Value

Type: IProductType
See Also

Reference

ProductTypeAddedEventArgs Class
VisualComponents.Create3D Namespace


ProductTypeAddedEventArgs Methods

The ProductTypeAddedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProductTypeAddedEventArgs Class
VisualComponents.Create3D Namespace


ProductTypeRemovedEventArgs Class

Provides data for ProductTypeRemoved event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DProductTypeRemovedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ProductTypeRemovedEventArgs : EventArgs
public ref class ProductTypeRemovedEventArgs : public EventArgs

The ProductTypeRemovedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ProductTypeRemovedEventArgs | Initializes a new instance of ProductTypeRemovingEventArgs.
Top
Properties
 | Name | Description
Public property | ProductType | Gets the product type.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ProductTypeRemovedEventArgs Constructor

Initializes a new instance of ProductTypeRemovingEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProductTypeRemovedEventArgs(
    IProductType productType
)
public:
ProductTypeRemovedEventArgs(
    IProductType^ productType
)

Parameters

productType
Type: VisualComponents.Create3DIProductType
Product type.
See Also

Reference

ProductTypeRemovedEventArgs Class
VisualComponents.Create3D Namespace


ProductTypeRemovedEventArgs Properties

The ProductTypeRemovedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ProductType | Gets the product type.
Top
See Also

Reference

ProductTypeRemovedEventArgs Class
VisualComponents.Create3D Namespace


ProductTypeRemovedEventArgs.ProductType Property

ProductTypeRemovedEventArgsProductType Property

Gets the product type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProductType ProductType { get; }
public:
property IProductType^ ProductType {
    IProductType^ get ();
}

Property Value

Type: IProductType
See Also

Reference

ProductTypeRemovedEventArgs Class
VisualComponents.Create3D Namespace


ProductTypeRemovedEventArgs Methods

The ProductTypeRemovedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProductTypeRemovedEventArgs Class
VisualComponents.Create3D Namespace


ProductTypeRemovingEventArgs Class

Provides data for ProductTypeRemoving and ProductTypeRemoving events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DProductTypeRemovingEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ProductTypeRemovingEventArgs : EventArgs
public ref class ProductTypeRemovingEventArgs : public EventArgs

The ProductTypeRemovingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ProductTypeRemovingEventArgs | Initializes a new instance of ProductTypeRemovingEventArgs.
Top
Properties
 | Name | Description
Public property | ProductType | Gets the product type.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ProductTypeRemovingEventArgs Constructor

Initializes a new instance of ProductTypeRemovingEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProductTypeRemovingEventArgs(
    IProductType productType
)
public:
ProductTypeRemovingEventArgs(
    IProductType^ productType
)

Parameters

productType
Type: VisualComponents.Create3DIProductType
Product type.
See Also

Reference

ProductTypeRemovingEventArgs Class
VisualComponents.Create3D Namespace


ProductTypeRemovingEventArgs Properties

The ProductTypeRemovingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ProductType | Gets the product type.
Top
See Also

Reference

ProductTypeRemovingEventArgs Class
VisualComponents.Create3D Namespace


ProductTypeRemovingEventArgs.ProductType Property

ProductTypeRemovingEventArgsProductType Property

Gets the product type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProductType ProductType { get; }
public:
property IProductType^ ProductType {
    IProductType^ get ();
}

Property Value

Type: IProductType
See Also

Reference

ProductTypeRemovingEventArgs Class
VisualComponents.Create3D Namespace


ProductTypeRemovingEventArgs Methods

The ProductTypeRemovingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProductTypeRemovingEventArgs Class
VisualComponents.Create3D Namespace


ProductTypeReplacedEventArgs Class

Provides data for ProductTypeReplaced and ProductTypeReplaced events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DProductTypeReplacedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ProductTypeReplacedEventArgs : EventArgs
public ref class ProductTypeReplacedEventArgs : public EventArgs

The ProductTypeReplacedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ProductTypeReplacedEventArgs | Initializes a new instance of ProductTypeRemovingEventArgs.
Top
Properties
 | Name | Description
Public property | NewProductType | Gets the new product type.
Public property | OldProductType | Gets the old product type.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ProductTypeReplacedEventArgs Constructor

Initializes a new instance of ProductTypeRemovingEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProductTypeReplacedEventArgs(
    IProductType oldProductType,
    IProductType newProductType
)
public:
ProductTypeReplacedEventArgs(
    IProductType^ oldProductType,
    IProductType^ newProductType
)

Parameters

oldProductType
Type: VisualComponents.Create3DIProductType
The product type that was replaced by the new type. The underlying object will be deleted soon after this event.
newProductType
Type: VisualComponents.Create3DIProductType
The product type that replaced the old type.
See Also

Reference

ProductTypeReplacedEventArgs Class
VisualComponents.Create3D Namespace


ProductTypeReplacedEventArgs Properties

The ProductTypeReplacedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewProductType | Gets the new product type.
Public property | OldProductType | Gets the old product type.
Top
See Also

Reference

ProductTypeReplacedEventArgs Class
VisualComponents.Create3D Namespace


ProductTypeReplacedEventArgs.NewProductType Property

ProductTypeReplacedEventArgsNewProductType Property

Gets the new product type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProductType NewProductType { get; }
public:
property IProductType^ NewProductType {
    IProductType^ get ();
}

Property Value

Type: IProductType
See Also

Reference

ProductTypeReplacedEventArgs Class
VisualComponents.Create3D Namespace


ProductTypeReplacedEventArgs.OldProductType Property

ProductTypeReplacedEventArgsOldProductType Property

Gets the old product type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProductType OldProductType { get; }
public:
property IProductType^ OldProductType {
    IProductType^ get ();
}

Property Value

Type: IProductType
See Also

Reference

ProductTypeReplacedEventArgs Class
VisualComponents.Create3D Namespace


ProductTypeReplacedEventArgs Methods

The ProductTypeReplacedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProductTypeReplacedEventArgs Class
VisualComponents.Create3D Namespace


ProgramAddedEventArgs Class

Provides data for ProgramAdded event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DProgramAddedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ProgramAddedEventArgs : EventArgs
public ref class ProgramAddedEventArgs : public EventArgs

The ProgramAddedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ProgramAddedEventArgs | Initializes a new instance of ProgramAddedEventArgs.
Top
Properties
 | Name | Description
Public property | Program | Gets the instance of IProgram that was added.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ProgramAddedEventArgs Constructor

Initializes a new instance of ProgramAddedEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProgramAddedEventArgs(
    IProgram program
)
public:
ProgramAddedEventArgs(
    IProgram^ program
)

Parameters

program
Type: VisualComponents.Create3DIProgram
See Also

Reference

ProgramAddedEventArgs Class
VisualComponents.Create3D Namespace


ProgramAddedEventArgs Properties

The ProgramAddedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Program | Gets the instance of IProgram that was added.
Top
See Also

Reference

ProgramAddedEventArgs Class
VisualComponents.Create3D Namespace


ProgramAddedEventArgs.Program Property

ProgramAddedEventArgsProgram Property

Gets the instance of IProgram that was added.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProgram Program { get; }
public:
property IProgram^ Program {
    IProgram^ get ();
}

Property Value

Type: IProgram
See Also

Reference

ProgramAddedEventArgs Class
VisualComponents.Create3D Namespace


ProgramAddedEventArgs Methods

The ProgramAddedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProgramAddedEventArgs Class
VisualComponents.Create3D Namespace


ProgramRemovingEventArgs Class

Provides data for ProgramRemoving event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DProgramRemovingEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ProgramRemovingEventArgs : EventArgs
public ref class ProgramRemovingEventArgs : public EventArgs

The ProgramRemovingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ProgramRemovingEventArgs | Initializes a new instance of ProgramRemovingEventArgs.
Top
Properties
 | Name | Description
Public property | Program | Gets the instance of IProgram that is being removed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ProgramRemovingEventArgs Constructor

Initializes a new instance of ProgramRemovingEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProgramRemovingEventArgs(
    IProgram program
)
public:
ProgramRemovingEventArgs(
    IProgram^ program
)

Parameters

program
Type: VisualComponents.Create3DIProgram
See Also

Reference

ProgramRemovingEventArgs Class
VisualComponents.Create3D Namespace


ProgramRemovingEventArgs Properties

The ProgramRemovingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Program | Gets the instance of IProgram that is being removed.
Top
See Also

Reference

ProgramRemovingEventArgs Class
VisualComponents.Create3D Namespace


ProgramRemovingEventArgs.Program Property

ProgramRemovingEventArgsProgram Property

Gets the instance of IProgram that is being removed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProgram Program { get; }
public:
property IProgram^ Program {
    IProgram^ get ();
}

Property Value

Type: IProgram
See Also

Reference

ProgramRemovingEventArgs Class
VisualComponents.Create3D Namespace


ProgramRemovingEventArgs Methods

The ProgramRemovingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProgramRemovingEventArgs Class
VisualComponents.Create3D Namespace


ProgressEventArgs Class

Component added event arguments
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DProgressEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ProgressEventArgs : EventArgs
public ref class ProgressEventArgs : public EventArgs

The ProgressEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ProgressEventArgs | Initializes a new instance of the ProgressEventArgs class
Top
Properties
 | Name | Description
Public property | Status |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ProgressEventArgs Constructor

Initializes a new instance of the ProgressEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProgressEventArgs(
    double value,
    string status
)
public:
ProgressEventArgs(
    double value,
    String^ status
)

Parameters

value
Type: SystemDouble
status
Type: SystemString
See Also

Reference

ProgressEventArgs Class
VisualComponents.Create3D Namespace


ProgressEventArgs Properties

The ProgressEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Status |
Public property | Value |
Top
See Also

Reference

ProgressEventArgs Class
VisualComponents.Create3D Namespace


ProgressEventArgs.Status Property

ProgressEventArgsStatus Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Status { get; set; }
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ProgressEventArgs Class
VisualComponents.Create3D Namespace


ProgressEventArgs.Value Property

ProgressEventArgsValue Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Value { get; set; }
public:
property double Value {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ProgressEventArgs Class
VisualComponents.Create3D Namespace


ProgressEventArgs Methods

The ProgressEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProgressEventArgs Class
VisualComponents.Create3D Namespace


PropertyAllowedValue Structure

Information about a single allowed value used in properties with allowed value set constraint.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct PropertyAllowedValue
public value class PropertyAllowedValue

The PropertyAllowedValue type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyAllowedValue | Initializes a new instance of the PropertyAllowedValue class
Top
Properties
 | Name | Description
Public property | LocalizedName |
Public property | Name |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Equality |
Inequality |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


PropertyAllowedValue Constructor

Initializes a new instance of the PropertyAllowedValue class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyAllowedValue(
    Object value,
    string name,
    string localizedName
)
public:
PropertyAllowedValue(
    Object^ value,
    String^ name,
    String^ localizedName
)

Parameters

value
Type: SystemObject
name
Type: SystemString
localizedName
Type: SystemString
See Also

Reference

PropertyAllowedValue Structure
VisualComponents.Create3D Namespace


PropertyAllowedValue Properties

The PropertyAllowedValue type exposes the following members.

Properties
 | Name | Description
Public property | LocalizedName |
Public property | Name |
Public property | Value |
Top
See Also

Reference

PropertyAllowedValue Structure
VisualComponents.Create3D Namespace


PropertyAllowedValue.LocalizedName Property

PropertyAllowedValueLocalizedName Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string LocalizedName { get; set; }
public:
property String^ LocalizedName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PropertyAllowedValue Structure
VisualComponents.Create3D Namespace


PropertyAllowedValue.Name Property

PropertyAllowedValueName Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; set; }
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PropertyAllowedValue Structure
VisualComponents.Create3D Namespace


PropertyAllowedValue.Value Property

PropertyAllowedValueValue Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Value { get; set; }
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

PropertyAllowedValue Structure
VisualComponents.Create3D Namespace


PropertyAllowedValue Methods

The PropertyAllowedValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PropertyAllowedValue Structure
VisualComponents.Create3D Namespace


PropertyAllowedValue.Equals Method

PropertyAllowedValueEquals Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.PropertyAllowedValue.Equals(System.Object)"]

See Also

Reference

PropertyAllowedValue Structure
VisualComponents.Create3D Namespace


PropertyAllowedValue.GetHashCode Method

PropertyAllowedValueGetHashCode Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.PropertyAllowedValue.GetHashCode"]

See Also

Reference

PropertyAllowedValue Structure
VisualComponents.Create3D Namespace


PropertyAllowedValue Operators

The PropertyAllowedValue type exposes the following members.

Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

PropertyAllowedValue Structure
VisualComponents.Create3D Namespace


PropertyAllowedValue.Equality Operator

PropertyAllowedValueEquality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    PropertyAllowedValue first,
    PropertyAllowedValue second
)
public:
static bool operator ==(
    PropertyAllowedValue first,
    PropertyAllowedValue second
)

Parameters

first
Type: VisualComponents.Create3DPropertyAllowedValue
second
Type: VisualComponents.Create3DPropertyAllowedValue

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.PropertyAllowedValue.op_Equality(VisualComponents.Create3D.PropertyAllowedValue,VisualComponents.Create3D.PropertyAllowedValue)"]

See Also

Reference

PropertyAllowedValue Structure
VisualComponents.Create3D Namespace


PropertyAllowedValue.Inequality Operator

PropertyAllowedValueInequality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    PropertyAllowedValue first,
    PropertyAllowedValue second
)
public:
static bool operator !=(
    PropertyAllowedValue first,
    PropertyAllowedValue second
)

Parameters

first
Type: VisualComponents.Create3DPropertyAllowedValue
second
Type: VisualComponents.Create3DPropertyAllowedValue

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.PropertyAllowedValue.op_Inequality(VisualComponents.Create3D.PropertyAllowedValue,VisualComponents.Create3D.PropertyAllowedValue)"]

See Also

Reference

PropertyAllowedValue Structure
VisualComponents.Create3D Namespace


PropertyAllowedValue(T) Structure

PropertyAllowedValueT Structure

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct PropertyAllowedValue<T>

generic<typename T>
public value class PropertyAllowedValue

Type Parameters

T

The PropertyAllowedValueT type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyAllowedValueT | Initializes a new instance of the PropertyAllowedValueT class
Top
Properties
 | Name | Description
Public property | LocalizedName |
Public property | Name |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Equality |
Inequality |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


PropertyAllowedValue(T) Constructor

PropertyAllowedValueT Constructor

Initializes a new instance of the PropertyAllowedValueT class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyAllowedValue(
    T value,
    string name,
    string localizedName
)
public:
PropertyAllowedValue(
    T value,
    String^ name,
    String^ localizedName
)

Parameters

value
Type: T
name
Type: SystemString
localizedName
Type: SystemString
See Also

Reference

PropertyAllowedValueT Structure
VisualComponents.Create3D Namespace


PropertyAllowedValue(T) Properties

PropertyAllowedValueT Properties

The PropertyAllowedValueT generic type exposes the following members.

Properties
 | Name | Description
Public property | LocalizedName |
Public property | Name |
Public property | Value |
Top
See Also

Reference

PropertyAllowedValueT Structure
VisualComponents.Create3D Namespace


PropertyAllowedValue(T).LocalizedName Property

PropertyAllowedValueTLocalizedName Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string LocalizedName { get; set; }
public:
property String^ LocalizedName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PropertyAllowedValueT Structure
VisualComponents.Create3D Namespace


PropertyAllowedValue(T).Name Property

PropertyAllowedValueTName Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; set; }
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PropertyAllowedValueT Structure
VisualComponents.Create3D Namespace


PropertyAllowedValue(T).Value Property

PropertyAllowedValueTValue Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public T Value { get; set; }
public:
property T Value {
    T get ();
    void set (T value);
}

Property Value

Type: T
See Also

Reference

PropertyAllowedValueT Structure
VisualComponents.Create3D Namespace


PropertyAllowedValue(T) Methods

PropertyAllowedValueT Methods

The PropertyAllowedValueT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PropertyAllowedValueT Structure
VisualComponents.Create3D Namespace


PropertyAllowedValue(T).Equals Method

PropertyAllowedValueTEquals Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.PropertyAllowedValue`1.Equals(System.Object)"]

See Also

Reference

PropertyAllowedValueT Structure
VisualComponents.Create3D Namespace


PropertyAllowedValue(T).GetHashCode Method

PropertyAllowedValueTGetHashCode Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.PropertyAllowedValue`1.GetHashCode"]

See Also

Reference

PropertyAllowedValueT Structure
VisualComponents.Create3D Namespace


PropertyAllowedValue(T) Operators

PropertyAllowedValueT Operators

The PropertyAllowedValueT generic type exposes the following members.

Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

PropertyAllowedValueT Structure
VisualComponents.Create3D Namespace


PropertyAllowedValue(T).Equality Operator

PropertyAllowedValueTEquality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    PropertyAllowedValue<T> first,
    PropertyAllowedValue<T> second
)
public:
static bool operator ==(
    PropertyAllowedValue<T> first,
    PropertyAllowedValue<T> second
)

Parameters

first
Type: VisualComponents.Create3DPropertyAllowedValue T
second
Type: VisualComponents.Create3DPropertyAllowedValue T

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.PropertyAllowedValue`1.op_Equality(VisualComponents.Create3D.PropertyAllowedValue{`0},VisualComponents.Create3D.PropertyAllowedValue{`0})"]

See Also

Reference

PropertyAllowedValueT Structure
VisualComponents.Create3D Namespace


PropertyAllowedValue(T).Inequality Operator

PropertyAllowedValueTInequality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    PropertyAllowedValue<T> first,
    PropertyAllowedValue<T> second
)
public:
static bool operator !=(
    PropertyAllowedValue<T> first,
    PropertyAllowedValue<T> second
)

Parameters

first
Type: VisualComponents.Create3DPropertyAllowedValue T
second
Type: VisualComponents.Create3DPropertyAllowedValue T

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.PropertyAllowedValue`1.op_Inequality(VisualComponents.Create3D.PropertyAllowedValue{`0},VisualComponents.Create3D.PropertyAllowedValue{`0})"]

See Also

Reference

PropertyAllowedValueT Structure
VisualComponents.Create3D Namespace


PropertyChange Class

PropertyChange contains information about a change of a individual property value.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DChange
VisualComponents.Create3DPropertyChange

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class PropertyChange : Change
public ref class PropertyChange sealed : public Change

The PropertyChange type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyChange | Initializes a new instance of a property change object.
Top
Properties
 | Name | Description
Public property | NewValue | New value of the property.
Public property | OldValue | Previous value of the property.
Public property | PropertyName | Name of the changed property.
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from Change.)
Public method | Equals | Compares if two propety changesets are equal (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Gets a hash code for this class (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


PropertyChange Constructor

Initializes a new instance of a property change object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyChange(
    Object target,
    string propertyName,
    Object newValue,
    Object oldValue
)
public:
PropertyChange(
    Object^ target,
    String^ propertyName,
    Object^ newValue,
    Object^ oldValue
)

Parameters

target
Type: SystemObject
Target object for this change.
propertyName
Type: SystemString
Name of the changed property.
newValue
Type: SystemObject
New value of the property.
oldValue
Type: SystemObject
Previous value of the property.
See Also

Reference

PropertyChange Class
VisualComponents.Create3D Namespace


PropertyChange Properties

The PropertyChange type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | New value of the property.
Public property | OldValue | Previous value of the property.
Public property | PropertyName | Name of the changed property.
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Top
See Also

Reference

PropertyChange Class
VisualComponents.Create3D Namespace


PropertyChange.NewValue Property

PropertyChangeNewValue Property

New value of the property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object NewValue { get; set; }
public:
property Object^ NewValue {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

PropertyChange Class
VisualComponents.Create3D Namespace


PropertyChange.OldValue Property

PropertyChangeOldValue Property

Previous value of the property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object OldValue { get; set; }
public:
property Object^ OldValue {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

PropertyChange Class
VisualComponents.Create3D Namespace


PropertyChange.PropertyName Property

PropertyChangePropertyName Property

Name of the changed property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string PropertyName { get; set; }
public:
property String^ PropertyName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PropertyChange Class
VisualComponents.Create3D Namespace


PropertyChange Methods

The PropertyChange type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from Change.)
Public method | Equals | Compares if two propety changesets are equal (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Gets a hash code for this class (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PropertyChange Class
VisualComponents.Create3D Namespace


PropertyChange.Equals Method

PropertyChangeEquals Method

Compares if two propety changesets are equal

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
property changeset to compare

Return Value

Type: Boolean
True if the property changesets have the same values; false otherwise.
See Also

Reference

PropertyChange Class
VisualComponents.Create3D Namespace


PropertyChange.GetHashCode Method

PropertyChangeGetHashCode Method

Gets a hash code for this class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32
Hash code
See Also

Reference

PropertyChange Class
VisualComponents.Create3D Namespace


PropertyCollection Class

PropertyList tracks the lifetime of contained properties, removing invalidated objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollectionIProperty
System.Collections.ObjectModelObservableCollectionIProperty
VisualComponents.Create3DPropertyCollection
VisualComponents.UX.SharedPropertyCategory

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PropertyCollection : ObservableCollection<IProperty>,
    IDisposable
public ref class PropertyCollection : public ObservableCollection<IProperty^>,
    IDisposable

The PropertyCollection type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyCollection | Construct an empty property collection.
Public method | PropertyCollection(IEnumerableIProperty) | Construct a property collection containing the given properties.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from CollectionIProperty .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from CollectionIProperty .)
Public property | ItemString | Access properties by name.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from CollectionIProperty .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from CollectionIProperty .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollectionIProperty .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollectionIProperty .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from CollectionIProperty .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollectionIProperty .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from CollectionIProperty .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from CollectionIProperty .)
Public method | Dispose | Releases all resources used by the PropertyCollection
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PropertyCollection and optionally releases the managed resources
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetByIndex | Access properties by index.
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from CollectionIProperty .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from CollectionIProperty .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from CollectionIProperty .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollectionIProperty .)
 | MakeUnionProperty |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeProperties(IEnumerableIListIProperty, Boolean) | Constructs a list of UnionProperties by grouping properties of the property containers based on the property name and type.
 | MergeProperties(IEnumerableIPropertyContainer, Boolean) |
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollectionIProperty .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollectionIProperty .)
Protected method | OnCollectionChanged | (Overrides ObservableCollectionTOnCollectionChanged(NotifyCollectionChangedEventArgs).)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollectionIProperty .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from CollectionIProperty .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from CollectionIProperty .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollectionIProperty .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollectionIProperty .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollectionIProperty .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollectionIProperty .)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


PropertyCollection Constructor

Overload List
 | Name | Description
Public method | PropertyCollection | Construct an empty property collection.
Public method | PropertyCollection(IEnumerableIProperty) | Construct a property collection containing the given properties.
Top
See Also

Reference

PropertyCollection Class
VisualComponents.Create3D Namespace


PropertyCollection Constructor

Construct an empty property collection.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyCollection()
public:
PropertyCollection()
See Also

Reference

PropertyCollection Class
PropertyCollection Overload
VisualComponents.Create3D Namespace


PropertyCollection Constructor (IEnumerable(IProperty))

PropertyCollection Constructor (IEnumerableIProperty)

Construct a property collection containing the given properties.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyCollection(
    IEnumerable<IProperty> properties
)
public:
PropertyCollection(
    IEnumerable<IProperty^>^ properties
)

Parameters

properties
Type: System.Collections.GenericIEnumerableIProperty
See Also

Reference

PropertyCollection Class
PropertyCollection Overload
VisualComponents.Create3D Namespace


PropertyCollection Properties

The PropertyCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from CollectionIProperty .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from CollectionIProperty .)
Public property | ItemString | Access properties by name.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from CollectionIProperty .)
Top
See Also

Reference

PropertyCollection Class
VisualComponents.Create3D Namespace


PropertyCollection.Item Property

PropertyCollectionItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from CollectionIProperty .)
Public property | ItemString | Access properties by name.
Top
See Also

Reference

PropertyCollection Class
VisualComponents.Create3D Namespace


PropertyCollection.Item Property (String)

PropertyCollectionItem Property (String)

Access properties by name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty this[
    string name
] { get; }
public:
property IProperty^ default[String^ name] {
    IProperty^ get (String^ name);
}

Parameters

name
Type: SystemString
Property name.

Return Value

Type: IProperty
The named property, or null if not present.
See Also

Reference

PropertyCollection Class
Item Overload
VisualComponents.Create3D Namespace


PropertyCollection Methods

The PropertyCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from CollectionIProperty .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollectionIProperty .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollectionIProperty .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from CollectionIProperty .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollectionIProperty .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from CollectionIProperty .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from CollectionIProperty .)
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetByIndex | Access properties by index.
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from CollectionIProperty .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from CollectionIProperty .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from CollectionIProperty .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollectionIProperty .)
 | MakeUnionProperty |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeProperties(IEnumerableIListIProperty, Boolean) | Constructs a list of UnionProperties by grouping properties of the property containers based on the property name and type.
 | MergeProperties(IEnumerableIPropertyContainer, Boolean) |
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollectionIProperty .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollectionIProperty .)
Protected method | OnCollectionChanged | (Overrides ObservableCollectionTOnCollectionChanged(NotifyCollectionChangedEventArgs).)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollectionIProperty .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from CollectionIProperty .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from CollectionIProperty .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollectionIProperty .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollectionIProperty .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PropertyCollection Class
VisualComponents.Create3D Namespace


PropertyCollection.Dispose Method

PropertyCollectionDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the PropertyCollection
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PropertyCollection and optionally releases the managed resources
Top
See Also

Reference

PropertyCollection Class
VisualComponents.Create3D Namespace


PropertyCollection.Dispose Method

PropertyCollectionDispose Method

Releases all resources used by the PropertyCollection

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Dispose()
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

PropertyCollection Class
Dispose Overload
VisualComponents.Create3D Namespace


PropertyCollection.Dispose Method (Boolean)

PropertyCollectionDispose Method (Boolean)

Releases the unmanaged resources used by the PropertyCollection and optionally releases the managed resources

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void Dispose(
    bool disposing
)
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

PropertyCollection Class
Dispose Overload
VisualComponents.Create3D Namespace


PropertyCollection.Finalize Method

PropertyCollectionFinalize Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void Finalize()
protected:
virtual void Finalize() override

Implements

ObjectFinalize
See Also

Reference

PropertyCollection Class
VisualComponents.Create3D Namespace


PropertyCollection.GetByIndex Method

PropertyCollectionGetByIndex Method

Access properties by index.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty GetByIndex(
    int index
)
public:
IProperty^ GetByIndex(
    int index
)

Parameters

index
Type: SystemInt32
Property index.

Return Value

Type: IProperty

[Missing <returns> documentation for "M:VisualComponents.Create3D.PropertyCollection.GetByIndex(System.Int32)"]

See Also

Reference

PropertyCollection Class
VisualComponents.Create3D Namespace


PropertyCollection.MakeUnionProperty Method

PropertyCollectionMakeUnionProperty Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IUnionProperty MakeUnionProperty(
    IEnumerable<IProperty> group
)
public:
static IUnionProperty^ MakeUnionProperty(
    IEnumerable<IProperty^>^ group
)

Parameters

group
Type: System.Collections.GenericIEnumerableIProperty

Return Value

Type: IUnionProperty

[Missing <returns> documentation for "M:VisualComponents.Create3D.PropertyCollection.MakeUnionProperty(System.Collections.Generic.IEnumerable{VisualComponents.Create3D.IProperty})"]

See Also

Reference

PropertyCollection Class
VisualComponents.Create3D Namespace


PropertyCollection.MergeProperties Method

PropertyCollectionMergeProperties Method

Overload List
Name | Description
MergeProperties(IEnumerableIListIProperty, Boolean) | Constructs a list of UnionProperties by grouping properties of the property containers based on the property name and type.
MergeProperties(IEnumerableIPropertyContainer, Boolean) |
Top
See Also

Reference

PropertyCollection Class
VisualComponents.Create3D Namespace


PropertyCollection.MergeProperties Method (IEnumerable(IList(IProperty)), Boolean)

PropertyCollectionMergeProperties Method (IEnumerableIListIProperty, Boolean)

Constructs a list of UnionProperties by grouping properties of the property containers based on the property name and type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IList<IProperty> MergeProperties(
    IEnumerable<IList<IProperty>> propertyLists,
    bool intersect
)
public:
static IList<IProperty^>^ MergeProperties(
    IEnumerable<IList<IProperty^>^>^ propertyLists,
    bool intersect
)

Parameters

propertyLists
Type: System.Collections.GenericIEnumerableIListIProperty
Propertycontainers containing the properties to be merged.
intersect
Type: SystemBoolean
If true only properties that exist in all property containers are returned. If false a union of properties is returned.

Return Value

Type: IListIProperty

[Missing <returns> documentation for "M:VisualComponents.Create3D.PropertyCollection.MergeProperties(System.Collections.Generic.IEnumerable{System.Collections.Generic.IList{VisualComponents.Create3D.IProperty}},System.Boolean)"]

See Also

Reference

PropertyCollection Class
MergeProperties Overload
VisualComponents.Create3D Namespace


PropertyCollection.MergeProperties Method (IEnumerable(IPropertyContainer), Boolean)

PropertyCollectionMergeProperties Method (IEnumerableIPropertyContainer, Boolean)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IList<IProperty> MergeProperties(
    IEnumerable<IPropertyContainer> containers,
    bool intersect
)
public:
static IList<IProperty^>^ MergeProperties(
    IEnumerable<IPropertyContainer^>^ containers,
    bool intersect
)

Parameters

containers
Type: System.Collections.GenericIEnumerableIPropertyContainer
intersect
Type: SystemBoolean

Return Value

Type: IListIProperty

[Missing <returns> documentation for "M:VisualComponents.Create3D.PropertyCollection.MergeProperties(System.Collections.Generic.IEnumerable{VisualComponents.Create3D.IPropertyContainer},System.Boolean)"]

See Also

Reference

PropertyCollection Class
MergeProperties Overload
VisualComponents.Create3D Namespace


PropertyCollection.OnCollectionChanged Method

PropertyCollectionOnCollectionChanged Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnCollectionChanged(
    NotifyCollectionChangedEventArgs e
)
protected:
virtual void OnCollectionChanged(
    NotifyCollectionChangedEventArgs^ e
) override

Parameters

e
Type: System.Collections.SpecializedNotifyCollectionChangedEventArgs
See Also

Reference

PropertyCollection Class
VisualComponents.Create3D Namespace


PropertyCollection Events

The PropertyCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollectionIProperty .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollectionIProperty .)
Top
See Also

Reference

PropertyCollection Class
VisualComponents.Create3D Namespace


PropertyComparer Class

Compares two properties and returns true if the values strings are equal.
Inheritance Hierarchy
SystemObject
System.Collections.GenericEqualityComparerIProperty
VisualComponents.Create3DPropertyComparer

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PropertyComparer : EqualityComparer<IProperty>
public ref class PropertyComparer : public EqualityComparer<IProperty^>

The PropertyComparer type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyComparer | Initializes a new instance of the PropertyComparer class
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(IProperty, IProperty) | Determines whether the specified object instances are considered equal. (Overrides EqualityComparerTEquals(T, T).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetHashCode(IProperty) | Returns hashcode for given property. (Overrides EqualityComparerTGetHashCode(T).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


PropertyComparer Constructor

Initializes a new instance of the PropertyComparer class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyComparer()
public:
PropertyComparer()
See Also

Reference

PropertyComparer Class
VisualComponents.Create3D Namespace


PropertyComparer Methods

The PropertyComparer type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(IProperty, IProperty) | Determines whether the specified object instances are considered equal. (Overrides EqualityComparerTEquals(T, T).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetHashCode(IProperty) | Returns hashcode for given property. (Overrides EqualityComparerTGetHashCode(T).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PropertyComparer Class
VisualComponents.Create3D Namespace


PropertyComparer.Equals Method

PropertyComparerEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(IProperty, IProperty) | Determines whether the specified object instances are considered equal. (Overrides EqualityComparerTEquals(T, T).)
Top
See Also

Reference

PropertyComparer Class
VisualComponents.Create3D Namespace


PropertyComparer.Equals Method (IProperty, IProperty)

PropertyComparerEquals Method (IProperty, IProperty)

Determines whether the specified object instances are considered equal.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    IProperty x,
    IProperty y
)
public:
virtual bool Equals(
    IProperty^ x,
    IProperty^ y
) override

Parameters

x
Type: VisualComponents.Create3DIProperty
First property to compare.
y
Type: VisualComponents.Create3DIProperty
Second property to compare.

Return Value

Type: Boolean
True if instances are to be considered equal.

Implements

IEqualityComparerTEquals(T, T)
See Also

Reference

PropertyComparer Class
Equals Overload
VisualComponents.Create3D Namespace


PropertyComparer.GetHashCode Method

PropertyComparerGetHashCode Method

Overload List
 | Name | Description
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetHashCode(IProperty) | Returns hashcode for given property. (Overrides EqualityComparerTGetHashCode(T).)
Top
See Also

Reference

PropertyComparer Class
VisualComponents.Create3D Namespace


PropertyComparer.GetHashCode Method (IProperty)

PropertyComparerGetHashCode Method (IProperty)

Returns hashcode for given property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode(
    IProperty obj
)
public:
virtual int GetHashCode(
    IProperty^ obj
) override

Parameters

obj
Type: VisualComponents.Create3DIProperty
The object for which to get a hash code.

Return Value

Type: Int32
A hash code for the specified object.

Implements

IEqualityComparerTGetHashCode(T)
See Also

Reference

PropertyComparer Class
GetHashCode Overload
VisualComponents.Create3D Namespace


PropertyConstraintType Enumeration

Property constraint type enumeration.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum PropertyConstraintType
public enum class PropertyConstraintType
Members
Member name | Value | Description
NotSpecified | 0 | Constraint type not specified. Default constraint type is used.
AllValuesAllowed | 1 | Property value can be any value.
AllowedRangeOnly | 2 | Property value must be in the allowed minimum-maximum range.
AllowedValueSetOnly | 3 | Property value must belong to a predefined set of allowed values.
Remarks

Property constraints determine if there are restrictions to the values that can be used when setting the property value. Apart from no restrictions, this enumeration allows the client to specify the restrictions as a range or as a predefined set of allowed values.

See Also

Reference

VisualComponents.Create3D Namespace


PropertyContainerChangedEventArgs Class

Property modified event arguments class.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DPropertyContainerChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PropertyContainerChangedEventArgs : EventArgs
public ref class PropertyContainerChangedEventArgs : public EventArgs

The PropertyContainerChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyContainerChangedEventArgs | Initializing constructor.
Top
Properties
 | Name | Description
Public property | ChangeType | Type of change that occurred.
Public property | Property | Affected property.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


PropertyContainerChangedEventArgs Constructor

Initializing constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyContainerChangedEventArgs(
    IProperty property,
    PropertyContainerChangeType changeType
)
public:
PropertyContainerChangedEventArgs(
    IProperty^ property,
    PropertyContainerChangeType changeType
)

Parameters

property
Type: VisualComponents.Create3DIProperty
Affected property.
changeType
Type: VisualComponents.Create3DPropertyContainerChangeType
Type of change that occurred.
See Also

Reference

PropertyContainerChangedEventArgs Class
VisualComponents.Create3D Namespace


PropertyContainerChangedEventArgs Properties

The PropertyContainerChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ChangeType | Type of change that occurred.
Public property | Property | Affected property.
Top
See Also

Reference

PropertyContainerChangedEventArgs Class
VisualComponents.Create3D Namespace


PropertyContainerChangedEventArgs.ChangeType Property

PropertyContainerChangedEventArgsChangeType Property

Type of change that occurred.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyContainerChangeType ChangeType { get; }
public:
property PropertyContainerChangeType ChangeType {
    PropertyContainerChangeType get ();
}

Property Value

Type: PropertyContainerChangeType
See Also

Reference

PropertyContainerChangedEventArgs Class
VisualComponents.Create3D Namespace


PropertyContainerChangedEventArgs.Property Property

PropertyContainerChangedEventArgsProperty Property

Affected property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty Property { get; }
public:
property IProperty^ Property {
    IProperty^ get ();
}

Property Value

Type: IProperty
See Also

Reference

PropertyContainerChangedEventArgs Class
VisualComponents.Create3D Namespace


PropertyContainerChangedEventArgs Methods

The PropertyContainerChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PropertyContainerChangedEventArgs Class
VisualComponents.Create3D Namespace


PropertyContainerChangeType Enumeration

Property change type enumeration.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum PropertyContainerChangeType
public enum class PropertyContainerChangeType
Members
Member name | Value | Description
Added | 0 | Property was added to container.
Removed | 1 | Property was removed from container.
Renamed | 2 | Property was renamed in the container.
See Also

Reference

VisualComponents.Create3D Namespace


PropertyException Class

For errors related to IProperty.
Inheritance Hierarchy
SystemObject
SystemException
VisualComponents.Create3DPropertyException

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[SerializableAttribute]
public class PropertyException : Exception
[SerializableAttribute]
public ref class PropertyException : public Exception

The PropertyException type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyException | Initializes a new property exception.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Overrides ExceptionMessage.)
Public property | Property | The affected property.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | TypeOfError | The type of error that occured.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


PropertyException Constructor

Initializes a new property exception.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyException(
    IProperty property,
    PropertyExceptionErrorType errorType
)
public:
PropertyException(
    IProperty^ property,
    PropertyExceptionErrorType errorType
)

Parameters

property
Type: VisualComponents.Create3DIProperty
The affected property.
errorType
Type: VisualComponents.Create3DPropertyExceptionErrorType
Type of the error that occured.
See Also

Reference

PropertyException Class
VisualComponents.Create3D Namespace


PropertyException Properties

The PropertyException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Overrides ExceptionMessage.)
Public property | Property | The affected property.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | TypeOfError | The type of error that occured.
Top
See Also

Reference

PropertyException Class
VisualComponents.Create3D Namespace


PropertyException.Message Property

PropertyExceptionMessage Property

Gets a message that describes the current exception.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string Message { get; }
public:
virtual property String^ Message {
    String^ get () override;
}

Property Value

Type: String

Implements

_ExceptionMessage
See Also

Reference

PropertyException Class
VisualComponents.Create3D Namespace


PropertyException.Property Property

PropertyExceptionProperty Property

The affected property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty Property { get; }
public:
property IProperty^ Property {
    IProperty^ get ();
}

Property Value

Type: IProperty
See Also

Reference

PropertyException Class
VisualComponents.Create3D Namespace


PropertyException.TypeOfError Property

PropertyExceptionTypeOfError Property

The type of error that occured.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyExceptionErrorType TypeOfError { get; }
public:
property PropertyExceptionErrorType TypeOfError {
    PropertyExceptionErrorType get ();
}

Property Value

Type: PropertyExceptionErrorType
See Also

Reference

PropertyException Class
VisualComponents.Create3D Namespace


PropertyException Methods

The PropertyException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PropertyException Class
VisualComponents.Create3D Namespace


PropertyException.GetObjectData Method

PropertyExceptionGetObjectData Method

sets the System.Runtime.Serialization.SerializationInfo with information about the exception.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

PropertyException Class
VisualComponents.Create3D Namespace


PropertyException Events

The PropertyException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

PropertyException Class
VisualComponents.Create3D Namespace


PropertyException.ErrorType Enumeration

PropertyExceptionErrorType Enumeration

Type of error that occured.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ErrorType
public enum class ErrorType
Members
Member name | Value | Description
SetValueOfReadOnlyVariable | 0 | Tried to set value of a read-only variable through API.
See Also

Reference

VisualComponents.Create3D Namespace


PropertyProxyCollection Class

Collection class to refer by proxy to properties in other containers. This class can be used to collect properties from various property containers so that they can be manipulated as a group.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DPropertyProxyCollection

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PropertyProxyCollection : IPropertyContainer,
    IBatchModeObject
public ref class PropertyProxyCollection : IPropertyContainer,
    IBatchModeObject

The PropertyProxyCollection type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyProxyCollection | Initializes a new instance of the PropertyProxyCollection class
Top
Properties
 | Name | Description
Public property | ChangeBatchLevel |
Public property | ContainerExpressionContext |
Public property | Properties |
Public property | PropertyNames |
Public property | PropertyNamesAndValues |
Public property | PropertyValues |
Top
Methods
 | Name | Description
Public method | BeginChangeBatch |
Public method | CreateProperty(Type, PropertyConstraintType) |
Public method | CreateProperty(Type, PropertyConstraintType, String) |
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) |
Public method | DeleteProperty |
Public method | EndChangeBatch |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperty |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadPropertyValues |
Public method | SetPropertyValues(IEnumerableObject) |
Public method | SetPropertyValues(IEnumerableTupleString, Object) |
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) |
Public method | SetPropertyValues(Int32, IEnumerableObject) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WritePropertyValues |
Top
Events
 | Name | Description
Public event | PropertyContainerChanged |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


PropertyProxyCollection Constructor

Initializes a new instance of the PropertyProxyCollection class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyProxyCollection()
public:
PropertyProxyCollection()
See Also

Reference

PropertyProxyCollection Class
VisualComponents.Create3D Namespace


PropertyProxyCollection Properties

The PropertyProxyCollection type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel |
Public property | ContainerExpressionContext |
Public property | Properties |
Public property | PropertyNames |
Public property | PropertyNamesAndValues |
Public property | PropertyValues |
Top
See Also

Reference

PropertyProxyCollection Class
VisualComponents.Create3D Namespace


PropertyProxyCollection.ChangeBatchLevel Property

PropertyProxyCollectionChangeBatchLevel Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ChangeBatchLevel { get; }
public:
virtual property int ChangeBatchLevel {
    int get () sealed;
}

Property Value

Type: Int32

Implements

IBatchModeObjectChangeBatchLevel
See Also

Reference

PropertyProxyCollection Class
VisualComponents.Create3D Namespace


PropertyProxyCollection.ContainerExpressionContext Property

PropertyProxyCollectionContainerExpressionContext Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IExpressionContext ContainerExpressionContext { get; }
public:
virtual property IExpressionContext^ ContainerExpressionContext {
    IExpressionContext^ get () sealed;
}

Property Value

Type: IExpressionContext

Implements

IPropertyContainerContainerExpressionContext
See Also

Reference

PropertyProxyCollection Class
VisualComponents.Create3D Namespace


PropertyProxyCollection.Properties Property

PropertyProxyCollectionProperties Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList<IProperty> Properties { get; }
public:
virtual property IList<IProperty^>^ Properties {
    IList<IProperty^>^ get () sealed;
}

Property Value

Type: IListIProperty

Implements

IPropertyContainerProperties
See Also

Reference

PropertyProxyCollection Class
VisualComponents.Create3D Namespace


PropertyProxyCollection.PropertyNames Property

PropertyProxyCollectionPropertyNames Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<string> PropertyNames { get; }
public:
virtual property IEnumerable<String^>^ PropertyNames {
    IEnumerable<String^>^ get () sealed;
}

Property Value

Type: IEnumerableString

Implements

IPropertyContainerPropertyNames
See Also

Reference

PropertyProxyCollection Class
VisualComponents.Create3D Namespace


PropertyProxyCollection.PropertyNamesAndValues Property

PropertyProxyCollectionPropertyNamesAndValues Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<Tuple<string, Object>> PropertyNamesAndValues { get; }
public:
virtual property IEnumerable<Tuple<String^, Object^>^>^ PropertyNamesAndValues {
    IEnumerable<Tuple<String^, Object^>^>^ get () sealed;
}

Property Value

Type: IEnumerableTupleString, Object

Implements

IPropertyContainerPropertyNamesAndValues
See Also

Reference

PropertyProxyCollection Class
VisualComponents.Create3D Namespace


PropertyProxyCollection.PropertyValues Property

PropertyProxyCollectionPropertyValues Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<Object> PropertyValues { get; }
public:
virtual property IEnumerable<Object^>^ PropertyValues {
    IEnumerable<Object^>^ get () sealed;
}

Property Value

Type: IEnumerableObject

Implements

IPropertyContainerPropertyValues
See Also

Reference

PropertyProxyCollection Class
VisualComponents.Create3D Namespace


PropertyProxyCollection Methods

The PropertyProxyCollection type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch |
Public method | CreateProperty(Type, PropertyConstraintType) |
Public method | CreateProperty(Type, PropertyConstraintType, String) |
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) |
Public method | DeleteProperty |
Public method | EndChangeBatch |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperty |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadPropertyValues |
Public method | SetPropertyValues(IEnumerableObject) |
Public method | SetPropertyValues(IEnumerableTupleString, Object) |
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) |
Public method | SetPropertyValues(Int32, IEnumerableObject) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WritePropertyValues |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PropertyProxyCollection Class
VisualComponents.Create3D Namespace


PropertyProxyCollection.BeginChangeBatch Method

PropertyProxyCollectionBeginChangeBatch Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void BeginChangeBatch()
public:
virtual void BeginChangeBatch() sealed

Implements

IBatchModeObjectBeginChangeBatch
See Also

Reference

PropertyProxyCollection Class
VisualComponents.Create3D Namespace


PropertyProxyCollection.CreateProperty Method

PropertyProxyCollectionCreateProperty Method

Overload List
 | Name | Description
Public method | CreateProperty(Type, PropertyConstraintType) |
Public method | CreateProperty(Type, PropertyConstraintType, String) |
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) |
Top
See Also

Reference

PropertyProxyCollection Class
VisualComponents.Create3D Namespace


PropertyProxyCollection.CreateProperty Method (Type, PropertyConstraintType)

PropertyProxyCollectionCreateProperty Method (Type, PropertyConstraintType)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty CreateProperty(
    Type valueType,
    PropertyConstraintType constraintType
)
public:
virtual IProperty^ CreateProperty(
    Type^ valueType,
    PropertyConstraintType constraintType
) sealed

Parameters

valueType
Type: SystemType
constraintType
Type: VisualComponents.Create3DPropertyConstraintType

Return Value

Type: IProperty

[Missing <returns> documentation for "M:VisualComponents.Create3D.PropertyProxyCollection.CreateProperty(System.Type,VisualComponents.Create3D.PropertyConstraintType)"]

Implements

IPropertyContainerCreateProperty(Type, PropertyConstraintType)
See Also

Reference

PropertyProxyCollection Class
CreateProperty Overload
VisualComponents.Create3D Namespace


PropertyProxyCollection.CreateProperty Method (Type, PropertyConstraintType, String)

PropertyProxyCollectionCreateProperty Method (Type, PropertyConstraintType, String)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty CreateProperty(
    Type valueType,
    PropertyConstraintType constraintType,
    string name
)
public:
virtual IProperty^ CreateProperty(
    Type^ valueType,
    PropertyConstraintType constraintType,
    String^ name
) sealed

Parameters

valueType
Type: SystemType
constraintType
Type: VisualComponents.Create3DPropertyConstraintType
name
Type: SystemString

Return Value

Type: IProperty

[Missing <returns> documentation for "M:VisualComponents.Create3D.PropertyProxyCollection.CreateProperty(System.Type,VisualComponents.Create3D.PropertyConstraintType,System.String)"]

Implements

IPropertyContainerCreateProperty(Type, PropertyConstraintType, String)
See Also

Reference

PropertyProxyCollection Class
CreateProperty Overload
VisualComponents.Create3D Namespace


PropertyProxyCollection.CreateProperty Method (Type, PropertyConstraintType, String, IProperty)

PropertyProxyCollectionCreateProperty Method (Type, PropertyConstraintType, String, IProperty)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty CreateProperty(
    Type valueType,
    PropertyConstraintType constraintType,
    string name,
    IProperty toBeReplaced
)
public:
virtual IProperty^ CreateProperty(
    Type^ valueType,
    PropertyConstraintType constraintType,
    String^ name,
    IProperty^ toBeReplaced
) sealed

Parameters

valueType
Type: SystemType
constraintType
Type: VisualComponents.Create3DPropertyConstraintType
name
Type: SystemString
toBeReplaced
Type: VisualComponents.Create3DIProperty

Return Value

Type: IProperty

[Missing <returns> documentation for "M:VisualComponents.Create3D.PropertyProxyCollection.CreateProperty(System.Type,VisualComponents.Create3D.PropertyConstraintType,System.String,VisualComponents.Create3D.IProperty)"]

Implements

IPropertyContainerCreateProperty(Type, PropertyConstraintType, String, IProperty)
See Also

Reference

PropertyProxyCollection Class
CreateProperty Overload
VisualComponents.Create3D Namespace


PropertyProxyCollection.DeleteProperty Method

PropertyProxyCollectionDeleteProperty Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void DeleteProperty(
    IProperty prop
)
public:
virtual void DeleteProperty(
    IProperty^ prop
) sealed

Parameters

prop
Type: VisualComponents.Create3DIProperty

Implements

IPropertyContainerDeleteProperty(IProperty)
See Also

Reference

PropertyProxyCollection Class
VisualComponents.Create3D Namespace


PropertyProxyCollection.EndChangeBatch Method

PropertyProxyCollectionEndChangeBatch Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void EndChangeBatch()
public:
virtual void EndChangeBatch() sealed

Implements

IBatchModeObjectEndChangeBatch
See Also

Reference

PropertyProxyCollection Class
VisualComponents.Create3D Namespace


PropertyProxyCollection.GetProperty Method

PropertyProxyCollectionGetProperty Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty GetProperty(
    string name
)
public:
virtual IProperty^ GetProperty(
    String^ name
) sealed

Parameters

name
Type: SystemString

Return Value

Type: IProperty

[Missing <returns> documentation for "M:VisualComponents.Create3D.PropertyProxyCollection.GetProperty(System.String)"]

Implements

IPropertyContainerGetProperty(String)
See Also

Reference

PropertyProxyCollection Class
VisualComponents.Create3D Namespace


PropertyProxyCollection.ReadPropertyValues Method

PropertyProxyCollectionReadPropertyValues Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ReadPropertyValues(
    int propertyIndex,
    int count,
    Object[] outputBuffer,
    int outputIndex
)
public:
void ReadPropertyValues(
    int propertyIndex,
    int count,
    array<Object^>^ outputBuffer,
    int outputIndex
)

Parameters

propertyIndex
Type: SystemInt32
count
Type: SystemInt32
outputBuffer
Type: SystemObject
outputIndex
Type: SystemInt32
See Also

Reference

PropertyProxyCollection Class
VisualComponents.Create3D Namespace


PropertyProxyCollection.SetPropertyValues Method

PropertyProxyCollectionSetPropertyValues Method

Overload List
 | Name | Description
Public method | SetPropertyValues(IEnumerableObject) |
Public method | SetPropertyValues(IEnumerableTupleString, Object) |
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) |
Public method | SetPropertyValues(Int32, IEnumerableObject) |
Top
See Also

Reference

PropertyProxyCollection Class
VisualComponents.Create3D Namespace


PropertyProxyCollection.SetPropertyValues Method (IEnumerable(Object))

PropertyProxyCollectionSetPropertyValues Method (IEnumerableObject)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetPropertyValues(
    IEnumerable<Object> values
)
public:
virtual void SetPropertyValues(
    IEnumerable<Object^>^ values
) sealed

Parameters

values
Type: System.Collections.GenericIEnumerableObject

Implements

IPropertyContainerSetPropertyValues(IEnumerableObject)
See Also

Reference

PropertyProxyCollection Class
SetPropertyValues Overload
VisualComponents.Create3D Namespace


PropertyProxyCollection.SetPropertyValues Method (IEnumerable(Tuple(String, Object)))

PropertyProxyCollectionSetPropertyValues Method (IEnumerableTupleString, Object)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetPropertyValues(
    IEnumerable<Tuple<string, Object>> namesAndValues
)
public:
virtual void SetPropertyValues(
    IEnumerable<Tuple<String^, Object^>^>^ namesAndValues
) sealed

Parameters

namesAndValues
Type: System.Collections.GenericIEnumerableTupleString, Object

Implements

IPropertyContainerSetPropertyValues(IEnumerableTupleString, Object)
See Also

Reference

PropertyProxyCollection Class
SetPropertyValues Overload
VisualComponents.Create3D Namespace


PropertyProxyCollection.SetPropertyValues Method (IEnumerable(String), IEnumerable(Object))

PropertyProxyCollectionSetPropertyValues Method (IEnumerableString, IEnumerableObject)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetPropertyValues(
    IEnumerable<string> names,
    IEnumerable<Object> values
)
public:
virtual void SetPropertyValues(
    IEnumerable<String^>^ names,
    IEnumerable<Object^>^ values
) sealed

Parameters

names
Type: System.Collections.GenericIEnumerableString
values
Type: System.Collections.GenericIEnumerableObject

Implements

IPropertyContainerSetPropertyValues(IEnumerableString, IEnumerableObject)
See Also

Reference

PropertyProxyCollection Class
SetPropertyValues Overload
VisualComponents.Create3D Namespace


PropertyProxyCollection.SetPropertyValues Method (Int32, IEnumerable(Object))

PropertyProxyCollectionSetPropertyValues Method (Int32, IEnumerableObject)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetPropertyValues(
    int startIndex,
    IEnumerable<Object> values
)
public:
virtual void SetPropertyValues(
    int startIndex,
    IEnumerable<Object^>^ values
) sealed

Parameters

startIndex
Type: SystemInt32
values
Type: System.Collections.GenericIEnumerableObject

Implements

IPropertyContainerSetPropertyValues(Int32, IEnumerableObject)
See Also

Reference

PropertyProxyCollection Class
SetPropertyValues Overload
VisualComponents.Create3D Namespace


PropertyProxyCollection.WritePropertyValues Method

PropertyProxyCollectionWritePropertyValues Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WritePropertyValues(
    int propertyIndex,
    Object[] inputValues,
    int inputIndex,
    int count
)
public:
void WritePropertyValues(
    int propertyIndex,
    array<Object^>^ inputValues,
    int inputIndex,
    int count
)

Parameters

propertyIndex
Type: SystemInt32
inputValues
Type: SystemObject
inputIndex
Type: SystemInt32
count
Type: SystemInt32
See Also

Reference

PropertyProxyCollection Class
VisualComponents.Create3D Namespace


PropertyProxyCollection Events

The PropertyProxyCollection type exposes the following members.

Events
 | Name | Description
Public event | PropertyContainerChanged |
Top
See Also

Reference

PropertyProxyCollection Class
VisualComponents.Create3D Namespace


PropertyProxyCollection.PropertyContainerChanged Event

PropertyProxyCollectionPropertyContainerChanged Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<PropertyContainerChangedEventArgs> PropertyContainerChanged
public:
virtual  event EventHandler<PropertyContainerChangedEventArgs^>^ PropertyContainerChanged {
    void add (EventHandler<PropertyContainerChangedEventArgs^>^ value);
    void remove (EventHandler<PropertyContainerChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerPropertyContainerChangedEventArgs

Implements

IPropertyContainerPropertyContainerChanged
See Also

Reference

PropertyProxyCollection Class
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization Structure

Replicates `rPxRigidDynamicSerialization` struct from Revolution in VisualComponents.Create3D.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct PxRigidDynamicSerialization
public value class PxRigidDynamicSerialization

The PxRigidDynamicSerialization type exposes the following members.

Properties
 | Name | Description
Public property | ActorFlags |
Public property | AngularDamping |
Public property | AngularVelocity |
Public property | BaseFlags |
Public property | ConstraintCount |
Public property | ContactReportThreshold |
Public property | GlobalPosition |
Public property | GlobalQuaternion |
Public property | InertiaTensor |
Public property | InertiaTensorInverse |
Public property | IsReleasable |
Public property | IsSleeping |
Public property | KinematicTargetPosition |
Public property | KinematicTargetQuaternion |
Public property | LinearDamping |
Public property | LinearVelocity |
Public property | Mass |
Public property | MassCOGPosition |
Public property | MassCOGQuaternion |
Public property | MassInverse |
Public property | MaxAngularVelocity |
Public property | MaxContactImpulse |
Public property | MaxDepenetrationVelocity |
Public property | MinCCDAdvanceCoefficient |
Public property | RigidBodyFlags |
Public property | RigidDynamicLockFlags |
Public property | Shapes |
Public property | ShapesCount |
Public property | SleepThreshold |
Public property | SolverPositionIterationCount |
Public property | SolverVelocityIterationCount |
Public property | StabilizationThreshold |
Public property | Type |
Public property | WakeCounter |
Top
Methods
 | Name | Description
Public method | Equals | (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Equality |
Inequality |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks
The property names MUST match the ones in `PhysicsEntityDescription` in the `Snapshot.proto`, as they are processed automatically in `PhysicsEntityComparison.cs`.
See Also

Reference

VisualComponents.Create3D Namespace


PxRigidDynamicSerialization Properties

The PxRigidDynamicSerialization type exposes the following members.

Properties
 | Name | Description
Public property | ActorFlags |
Public property | AngularDamping |
Public property | AngularVelocity |
Public property | BaseFlags |
Public property | ConstraintCount |
Public property | ContactReportThreshold |
Public property | GlobalPosition |
Public property | GlobalQuaternion |
Public property | InertiaTensor |
Public property | InertiaTensorInverse |
Public property | IsReleasable |
Public property | IsSleeping |
Public property | KinematicTargetPosition |
Public property | KinematicTargetQuaternion |
Public property | LinearDamping |
Public property | LinearVelocity |
Public property | Mass |
Public property | MassCOGPosition |
Public property | MassCOGQuaternion |
Public property | MassInverse |
Public property | MaxAngularVelocity |
Public property | MaxContactImpulse |
Public property | MaxDepenetrationVelocity |
Public property | MinCCDAdvanceCoefficient |
Public property | RigidBodyFlags |
Public property | RigidDynamicLockFlags |
Public property | Shapes |
Public property | ShapesCount |
Public property | SleepThreshold |
Public property | SolverPositionIterationCount |
Public property | SolverVelocityIterationCount |
Public property | StabilizationThreshold |
Public property | Type |
Public property | WakeCounter |
Top
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.ActorFlags Property

PxRigidDynamicSerializationActorFlags Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint ActorFlags { get; set; }
public:
property unsigned int ActorFlags {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.AngularDamping Property

PxRigidDynamicSerializationAngularDamping Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float AngularDamping { get; set; }
public:
property float AngularDamping {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.AngularVelocity Property

PxRigidDynamicSerializationAngularVelocity Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 AngularVelocity { get; set; }
public:
property Vector3 AngularVelocity {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.BaseFlags Property

PxRigidDynamicSerializationBaseFlags Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint BaseFlags { get; set; }
public:
property unsigned int BaseFlags {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.ConstraintCount Property

PxRigidDynamicSerializationConstraintCount Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint ConstraintCount { get; set; }
public:
property unsigned int ConstraintCount {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.ContactReportThreshold Property

PxRigidDynamicSerializationContactReportThreshold Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float ContactReportThreshold { get; set; }
public:
property float ContactReportThreshold {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.GlobalPosition Property

PxRigidDynamicSerializationGlobalPosition Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 GlobalPosition { get; set; }
public:
property Vector3 GlobalPosition {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.GlobalQuaternion Property

PxRigidDynamicSerializationGlobalQuaternion Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Quaternion GlobalQuaternion { get; set; }
public:
property Quaternion GlobalQuaternion {
    Quaternion get ();
    void set (Quaternion value);
}

Property Value

Type: Quaternion
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.InertiaTensor Property

PxRigidDynamicSerializationInertiaTensor Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 InertiaTensor { get; set; }
public:
property Vector3 InertiaTensor {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.InertiaTensorInverse Property

PxRigidDynamicSerializationInertiaTensorInverse Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 InertiaTensorInverse { get; set; }
public:
property Vector3 InertiaTensorInverse {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.IsReleasable Property

PxRigidDynamicSerializationIsReleasable Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsReleasable { get; set; }
public:
property bool IsReleasable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.IsSleeping Property

PxRigidDynamicSerializationIsSleeping Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsSleeping { get; set; }
public:
property bool IsSleeping {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.KinematicTargetPosition Property

PxRigidDynamicSerializationKinematicTargetPosition Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 KinematicTargetPosition { get; set; }
public:
property Vector3 KinematicTargetPosition {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.KinematicTargetQuaternion Property

PxRigidDynamicSerializationKinematicTargetQuaternion Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Quaternion KinematicTargetQuaternion { get; set; }
public:
property Quaternion KinematicTargetQuaternion {
    Quaternion get ();
    void set (Quaternion value);
}

Property Value

Type: Quaternion
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.LinearDamping Property

PxRigidDynamicSerializationLinearDamping Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float LinearDamping { get; set; }
public:
property float LinearDamping {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.LinearVelocity Property

PxRigidDynamicSerializationLinearVelocity Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 LinearVelocity { get; set; }
public:
property Vector3 LinearVelocity {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.Mass Property

PxRigidDynamicSerializationMass Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float Mass { get; set; }
public:
property float Mass {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.MassCOGPosition Property

PxRigidDynamicSerializationMassCOGPosition Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 MassCOGPosition { get; set; }
public:
property Vector3 MassCOGPosition {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.MassCOGQuaternion Property

PxRigidDynamicSerializationMassCOGQuaternion Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Quaternion MassCOGQuaternion { get; set; }
public:
property Quaternion MassCOGQuaternion {
    Quaternion get ();
    void set (Quaternion value);
}

Property Value

Type: Quaternion
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.MassInverse Property

PxRigidDynamicSerializationMassInverse Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float MassInverse { get; set; }
public:
property float MassInverse {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.MaxAngularVelocity Property

PxRigidDynamicSerializationMaxAngularVelocity Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float MaxAngularVelocity { get; set; }
public:
property float MaxAngularVelocity {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.MaxContactImpulse Property

PxRigidDynamicSerializationMaxContactImpulse Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float MaxContactImpulse { get; set; }
public:
property float MaxContactImpulse {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.MaxDepenetrationVelocity Property

PxRigidDynamicSerializationMaxDepenetrationVelocity Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float MaxDepenetrationVelocity { get; set; }
public:
property float MaxDepenetrationVelocity {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.MinCCDAdvanceCoefficient Property

PxRigidDynamicSerializationMinCCDAdvanceCoefficient Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float MinCCDAdvanceCoefficient { get; set; }
public:
property float MinCCDAdvanceCoefficient {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.RigidBodyFlags Property

PxRigidDynamicSerializationRigidBodyFlags Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint RigidBodyFlags { get; set; }
public:
property unsigned int RigidBodyFlags {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.RigidDynamicLockFlags Property

PxRigidDynamicSerializationRigidDynamicLockFlags Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint RigidDynamicLockFlags { get; set; }
public:
property unsigned int RigidDynamicLockFlags {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.Shapes Property

PxRigidDynamicSerializationShapes Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<PxShapeSerialization> Shapes { get; set; }
public:
property List<PxShapeSerialization>^ Shapes {
    List<PxShapeSerialization>^ get ();
    void set (List<PxShapeSerialization>^ value);
}

Property Value

Type: ListPxShapeSerialization
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.ShapesCount Property

PxRigidDynamicSerializationShapesCount Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint ShapesCount { get; set; }
public:
property unsigned int ShapesCount {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.SleepThreshold Property

PxRigidDynamicSerializationSleepThreshold Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float SleepThreshold { get; set; }
public:
property float SleepThreshold {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.SolverPositionIterationCount Property

PxRigidDynamicSerializationSolverPositionIterationCount Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint SolverPositionIterationCount { get; set; }
public:
property unsigned int SolverPositionIterationCount {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.SolverVelocityIterationCount Property

PxRigidDynamicSerializationSolverVelocityIterationCount Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint SolverVelocityIterationCount { get; set; }
public:
property unsigned int SolverVelocityIterationCount {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.StabilizationThreshold Property

PxRigidDynamicSerializationStabilizationThreshold Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float StabilizationThreshold { get; set; }
public:
property float StabilizationThreshold {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.Type Property

PxRigidDynamicSerializationType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint Type { get; set; }
public:
property unsigned int Type {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.WakeCounter Property

PxRigidDynamicSerializationWakeCounter Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float WakeCounter { get; set; }
public:
property float WakeCounter {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization Methods

The PxRigidDynamicSerialization type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.Equals Method

PxRigidDynamicSerializationEquals Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.PxRigidDynamicSerialization.Equals(System.Object)"]

See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.GetHashCode Method

PxRigidDynamicSerializationGetHashCode Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.PxRigidDynamicSerialization.GetHashCode"]

See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization Operators

The PxRigidDynamicSerialization type exposes the following members.

Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.Equality Operator

PxRigidDynamicSerializationEquality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    PxRigidDynamicSerialization serialization1,
    PxRigidDynamicSerialization serialization2
)
public:
static bool operator ==(
    PxRigidDynamicSerialization serialization1,
    PxRigidDynamicSerialization serialization2
)

Parameters

serialization1
Type: VisualComponents.Create3DPxRigidDynamicSerialization
serialization2
Type: VisualComponents.Create3DPxRigidDynamicSerialization

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.PxRigidDynamicSerialization.op_Equality(VisualComponents.Create3D.PxRigidDynamicSerialization,VisualComponents.Create3D.PxRigidDynamicSerialization)"]

See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxRigidDynamicSerialization.Inequality Operator

PxRigidDynamicSerializationInequality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    PxRigidDynamicSerialization serialization1,
    PxRigidDynamicSerialization serialization2
)
public:
static bool operator !=(
    PxRigidDynamicSerialization serialization1,
    PxRigidDynamicSerialization serialization2
)

Parameters

serialization1
Type: VisualComponents.Create3DPxRigidDynamicSerialization
serialization2
Type: VisualComponents.Create3DPxRigidDynamicSerialization

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.PxRigidDynamicSerialization.op_Inequality(VisualComponents.Create3D.PxRigidDynamicSerialization,VisualComponents.Create3D.PxRigidDynamicSerialization)"]

See Also

Reference

PxRigidDynamicSerialization Structure
VisualComponents.Create3D Namespace


PxShapeSerialization Structure

Replicates `rPxShapeSerialization` struct from Revolution in VisualComponents.Create3D.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct PxShapeSerialization
public value class PxShapeSerialization

The PxShapeSerialization type exposes the following members.

Properties
 | Name | Description
Public property | ContactOffset |
Public property | Flags |
Public property | GeometryType |
Public property | LocalPosition |
Public property | LocalQuaternion |
Public property | MaterialCount |
Public property | QueryFilterData |
Public property | RestOffset |
Public property | SimulationFilterData |
Top
Methods
 | Name | Description
Public method | Equals | (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Equality |
Inequality |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks
The property names MUST match the ones in `PhysicsShapeDescription` in the `Snapshot.proto`, as they are processed automatically in `PhysicsEntityComparison.cs`.
See Also

Reference

VisualComponents.Create3D Namespace


PxShapeSerialization Properties

The PxShapeSerialization type exposes the following members.

Properties
 | Name | Description
Public property | ContactOffset |
Public property | Flags |
Public property | GeometryType |
Public property | LocalPosition |
Public property | LocalQuaternion |
Public property | MaterialCount |
Public property | QueryFilterData |
Public property | RestOffset |
Public property | SimulationFilterData |
Top
See Also

Reference

PxShapeSerialization Structure
VisualComponents.Create3D Namespace


PxShapeSerialization.ContactOffset Property

PxShapeSerializationContactOffset Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float ContactOffset { get; set; }
public:
property float ContactOffset {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

PxShapeSerialization Structure
VisualComponents.Create3D Namespace


PxShapeSerialization.Flags Property

PxShapeSerializationFlags Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint Flags { get; set; }
public:
property unsigned int Flags {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

PxShapeSerialization Structure
VisualComponents.Create3D Namespace


PxShapeSerialization.GeometryType Property

PxShapeSerializationGeometryType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint GeometryType { get; set; }
public:
property unsigned int GeometryType {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

PxShapeSerialization Structure
VisualComponents.Create3D Namespace


PxShapeSerialization.LocalPosition Property

PxShapeSerializationLocalPosition Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 LocalPosition { get; set; }
public:
property Vector3 LocalPosition {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

PxShapeSerialization Structure
VisualComponents.Create3D Namespace


PxShapeSerialization.LocalQuaternion Property

PxShapeSerializationLocalQuaternion Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Quaternion LocalQuaternion { get; set; }
public:
property Quaternion LocalQuaternion {
    Quaternion get ();
    void set (Quaternion value);
}

Property Value

Type: Quaternion
See Also

Reference

PxShapeSerialization Structure
VisualComponents.Create3D Namespace


PxShapeSerialization.MaterialCount Property

PxShapeSerializationMaterialCount Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint MaterialCount { get; set; }
public:
property unsigned int MaterialCount {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

PxShapeSerialization Structure
VisualComponents.Create3D Namespace


PxShapeSerialization.QueryFilterData Property

PxShapeSerializationQueryFilterData Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<uint> QueryFilterData { get; set; }
public:
property List<unsigned int>^ QueryFilterData {
    List<unsigned int>^ get ();
    void set (List<unsigned int>^ value);
}

Property Value

Type: ListUInt32
See Also

Reference

PxShapeSerialization Structure
VisualComponents.Create3D Namespace


PxShapeSerialization.RestOffset Property

PxShapeSerializationRestOffset Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float RestOffset { get; set; }
public:
property float RestOffset {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

PxShapeSerialization Structure
VisualComponents.Create3D Namespace


PxShapeSerialization.SimulationFilterData Property

PxShapeSerializationSimulationFilterData Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<uint> SimulationFilterData { get; set; }
public:
property List<unsigned int>^ SimulationFilterData {
    List<unsigned int>^ get ();
    void set (List<unsigned int>^ value);
}

Property Value

Type: ListUInt32
See Also

Reference

PxShapeSerialization Structure
VisualComponents.Create3D Namespace


PxShapeSerialization Methods

The PxShapeSerialization type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PxShapeSerialization Structure
VisualComponents.Create3D Namespace


PxShapeSerialization.Equals Method

PxShapeSerializationEquals Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.PxShapeSerialization.Equals(System.Object)"]

See Also

Reference

PxShapeSerialization Structure
VisualComponents.Create3D Namespace


PxShapeSerialization.GetHashCode Method

PxShapeSerializationGetHashCode Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.PxShapeSerialization.GetHashCode"]

See Also

Reference

PxShapeSerialization Structure
VisualComponents.Create3D Namespace


PxShapeSerialization Operators

The PxShapeSerialization type exposes the following members.

Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

PxShapeSerialization Structure
VisualComponents.Create3D Namespace


PxShapeSerialization.Equality Operator

PxShapeSerializationEquality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    PxShapeSerialization serialization1,
    PxShapeSerialization serialization2
)
public:
static bool operator ==(
    PxShapeSerialization serialization1,
    PxShapeSerialization serialization2
)

Parameters

serialization1
Type: VisualComponents.Create3DPxShapeSerialization
serialization2
Type: VisualComponents.Create3DPxShapeSerialization

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.PxShapeSerialization.op_Equality(VisualComponents.Create3D.PxShapeSerialization,VisualComponents.Create3D.PxShapeSerialization)"]

See Also

Reference

PxShapeSerialization Structure
VisualComponents.Create3D Namespace


PxShapeSerialization.Inequality Operator

PxShapeSerializationInequality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    PxShapeSerialization serialization1,
    PxShapeSerialization serialization2
)
public:
static bool operator !=(
    PxShapeSerialization serialization1,
    PxShapeSerialization serialization2
)

Parameters

serialization1
Type: VisualComponents.Create3DPxShapeSerialization
serialization2
Type: VisualComponents.Create3DPxShapeSerialization

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.PxShapeSerialization.op_Inequality(VisualComponents.Create3D.PxShapeSerialization,VisualComponents.Create3D.PxShapeSerialization)"]

See Also

Reference

PxShapeSerialization Structure
VisualComponents.Create3D Namespace


PythonActionCommandType Enumeration

CommandType defines what type of command python action invokes when executed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum PythonActionCommandType
public enum class PythonActionCommandType
Members
Member name | Value | Description
Invalid | 0 | Invalid.
Python | 1 | UxItem bound to PythonActionItem that invokes Python command
NET | 2 | UxItem bound to PythonActionItem that that invokes Managed command.
DirectNET | 3 | Invoke .NET commmand directly
PythonActionPanel | 4 | Display action pane for setting parameters for the python command.
Internal | 5 | Internal command
See Also

Reference

VisualComponents.Create3D Namespace


PythonCommandIsCheckedChangedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DPythonCommandIsCheckedChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PythonCommandIsCheckedChangedEventArgs : EventArgs
public ref class PythonCommandIsCheckedChangedEventArgs : public EventArgs

The PythonCommandIsCheckedChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PythonCommandIsCheckedChangedEventArgs | Initializes a new instance of the PythonCommandIsCheckedChangedEventArgs class
Top
Properties
 | Name | Description
Public property | CommandName |
Public property | IsChecked |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


PythonCommandIsCheckedChangedEventArgs Constructor

Initializes a new instance of the PythonCommandIsCheckedChangedEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PythonCommandIsCheckedChangedEventArgs(
    string commandName,
    bool isChecked
)
public:
PythonCommandIsCheckedChangedEventArgs(
    String^ commandName,
    bool isChecked
)

Parameters

commandName
Type: SystemString
isChecked
Type: SystemBoolean
See Also

Reference

PythonCommandIsCheckedChangedEventArgs Class
VisualComponents.Create3D Namespace


PythonCommandIsCheckedChangedEventArgs Properties

The PythonCommandIsCheckedChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | CommandName |
Public property | IsChecked |
Top
See Also

Reference

PythonCommandIsCheckedChangedEventArgs Class
VisualComponents.Create3D Namespace


PythonCommandIsCheckedChangedEventArgs.CommandName Property

PythonCommandIsCheckedChangedEventArgsCommandName Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CommandName { get; }
public:
property String^ CommandName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

PythonCommandIsCheckedChangedEventArgs Class
VisualComponents.Create3D Namespace


PythonCommandIsCheckedChangedEventArgs.IsChecked Property

PythonCommandIsCheckedChangedEventArgsIsChecked Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsChecked { get; }
public:
property bool IsChecked {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

PythonCommandIsCheckedChangedEventArgs Class
VisualComponents.Create3D Namespace


PythonCommandIsCheckedChangedEventArgs Methods

The PythonCommandIsCheckedChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PythonCommandIsCheckedChangedEventArgs Class
VisualComponents.Create3D Namespace


PythonCommandIsEnabledChangedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DPythonCommandIsEnabledChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PythonCommandIsEnabledChangedEventArgs : EventArgs
public ref class PythonCommandIsEnabledChangedEventArgs : public EventArgs

The PythonCommandIsEnabledChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PythonCommandIsEnabledChangedEventArgs | Initializes a new instance of the PythonCommandIsEnabledChangedEventArgs class
Top
Properties
 | Name | Description
Public property | CommandName |
Public property | IsEnabled |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


PythonCommandIsEnabledChangedEventArgs Constructor

Initializes a new instance of the PythonCommandIsEnabledChangedEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PythonCommandIsEnabledChangedEventArgs(
    string commandName,
    bool isEnabled
)
public:
PythonCommandIsEnabledChangedEventArgs(
    String^ commandName,
    bool isEnabled
)

Parameters

commandName
Type: SystemString
isEnabled
Type: SystemBoolean
See Also

Reference

PythonCommandIsEnabledChangedEventArgs Class
VisualComponents.Create3D Namespace


PythonCommandIsEnabledChangedEventArgs Properties

The PythonCommandIsEnabledChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | CommandName |
Public property | IsEnabled |
Top
See Also

Reference

PythonCommandIsEnabledChangedEventArgs Class
VisualComponents.Create3D Namespace


PythonCommandIsEnabledChangedEventArgs.CommandName Property

PythonCommandIsEnabledChangedEventArgsCommandName Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CommandName { get; }
public:
property String^ CommandName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

PythonCommandIsEnabledChangedEventArgs Class
VisualComponents.Create3D Namespace


PythonCommandIsEnabledChangedEventArgs.IsEnabled Property

PythonCommandIsEnabledChangedEventArgsIsEnabled Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsEnabled { get; }
public:
property bool IsEnabled {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

PythonCommandIsEnabledChangedEventArgs Class
VisualComponents.Create3D Namespace


PythonCommandIsEnabledChangedEventArgs Methods

The PythonCommandIsEnabledChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PythonCommandIsEnabledChangedEventArgs Class
VisualComponents.Create3D Namespace


PythonScriptTriggerEventArgs Class

Python trace event argument class.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DPythonScriptTriggerEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PythonScriptTriggerEventArgs : EventArgs
public ref class PythonScriptTriggerEventArgs : public EventArgs

The PythonScriptTriggerEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PythonScriptTriggerEventArgs | Initializing constructor.
Top
Properties
 | Name | Description
Public property | Frame | Topmost Python trace frame.
Public property | Instance | Python instance that sent the trace.
Public property | Step | Type of trace event.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


PythonScriptTriggerEventArgs Constructor

Initializing constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PythonScriptTriggerEventArgs(
    IPythonInstance instance,
    TraceStep step,
    TraceFrame frame
)
public:
PythonScriptTriggerEventArgs(
    IPythonInstance^ instance,
    TraceStep step,
    TraceFrame frame
)

Parameters

instance
Type: VisualComponents.Create3DIPythonInstance
step
Type: VisualComponents.Create3DTraceStep
frame
Type: VisualComponents.Create3DTraceFrame
See Also

Reference

PythonScriptTriggerEventArgs Class
VisualComponents.Create3D Namespace


PythonScriptTriggerEventArgs Properties

The PythonScriptTriggerEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Frame | Topmost Python trace frame.
Public property | Instance | Python instance that sent the trace.
Public property | Step | Type of trace event.
Top
See Also

Reference

PythonScriptTriggerEventArgs Class
VisualComponents.Create3D Namespace


PythonScriptTriggerEventArgs.Frame Property

PythonScriptTriggerEventArgsFrame Property

Topmost Python trace frame.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TraceFrame Frame { get; set; }
public:
property TraceFrame Frame {
    TraceFrame get ();
    void set (TraceFrame value);
}

Property Value

Type: TraceFrame
See Also

Reference

PythonScriptTriggerEventArgs Class
VisualComponents.Create3D Namespace


PythonScriptTriggerEventArgs.Instance Property

PythonScriptTriggerEventArgsInstance Property

Python instance that sent the trace.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IPythonInstance Instance { get; set; }
public:
property IPythonInstance^ Instance {
    IPythonInstance^ get ();
    void set (IPythonInstance^ value);
}

Property Value

Type: IPythonInstance
See Also

Reference

PythonScriptTriggerEventArgs Class
VisualComponents.Create3D Namespace


PythonScriptTriggerEventArgs.Step Property

PythonScriptTriggerEventArgsStep Property

Type of trace event.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TraceStep Step { get; set; }
public:
property TraceStep Step {
    TraceStep get ();
    void set (TraceStep value);
}

Property Value

Type: TraceStep
See Also

Reference

PythonScriptTriggerEventArgs Class
VisualComponents.Create3D Namespace


PythonScriptTriggerEventArgs Methods

The PythonScriptTriggerEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PythonScriptTriggerEventArgs Class
VisualComponents.Create3D Namespace


RaycastPoint Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DRaycastPoint

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RaycastPoint : ISnapperPosition,
    IPosition, ICloneable<ISnapperPosition>, ICloneable, ISnapperPropertyContainer
public ref class RaycastPoint : ISnapperPosition,
    IPosition, ICloneable<ISnapperPosition^>, ICloneable, ISnapperPropertyContainer

The RaycastPoint type exposes the following members.

Constructors
 | Name | Description
Public method | RaycastPoint | Initializes a new instance of the RaycastPoint class
Top
Properties
 | Name | Description
Public property | IsCorner |
Public property | IsInnerEdge |
Public property | IsInnerEdge23 |
Public property | Node |
Public property | Position |
Public property | Properties |
Public property | Surface1 |
Public property | Surface2 |
Public property | Surface3 |
Public property | SurfaceNormals |
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


RaycastPoint Constructor

Initializes a new instance of the RaycastPoint class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RaycastPoint()
public:
RaycastPoint()
See Also

Reference

RaycastPoint Class
VisualComponents.Create3D Namespace


RaycastPoint Properties

The RaycastPoint type exposes the following members.

Properties
 | Name | Description
Public property | IsCorner |
Public property | IsInnerEdge |
Public property | IsInnerEdge23 |
Public property | Node |
Public property | Position |
Public property | Properties |
Public property | Surface1 |
Public property | Surface2 |
Public property | Surface3 |
Public property | SurfaceNormals |
Top
See Also

Reference

RaycastPoint Class
VisualComponents.Create3D Namespace


RaycastPoint.IsCorner Property

RaycastPointIsCorner Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsCorner { get; set; }
public:
property bool IsCorner {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

RaycastPoint Class
VisualComponents.Create3D Namespace


RaycastPoint.IsInnerEdge Property

RaycastPointIsInnerEdge Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsInnerEdge { get; }
public:
property bool IsInnerEdge {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

RaycastPoint Class
VisualComponents.Create3D Namespace


RaycastPoint.IsInnerEdge23 Property

RaycastPointIsInnerEdge23 Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsInnerEdge23 { get; }
public:
property bool IsInnerEdge23 {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

RaycastPoint Class
VisualComponents.Create3D Namespace


RaycastPoint.Node Property

RaycastPointNode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimNode Node { get; set; }
public:
virtual property ISimNode^ Node {
    ISimNode^ get () sealed;
    void set (ISimNode^ value) sealed;
}

Property Value

Type: ISimNode

Implements

ISnapperPositionNode
See Also

Reference

RaycastPoint Class
VisualComponents.Create3D Namespace


RaycastPoint.Position Property

RaycastPointPosition Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Matrix Position { get; set; }
public:
virtual property Matrix Position {
    Matrix get () sealed;
    void set (Matrix value) sealed;
}

Property Value

Type: Matrix

Implements

IPositionPosition
See Also

Reference

RaycastPoint Class
VisualComponents.Create3D Namespace


RaycastPoint.Properties Property

RaycastPointProperties Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList<ISnapperProperty> Properties { get; }
public:
virtual property IList<ISnapperProperty^>^ Properties {
    IList<ISnapperProperty^>^ get () sealed;
}

Property Value

Type: IListISnapperProperty

Implements

ISnapperPropertyContainerProperties
See Also

Reference

RaycastPoint Class
VisualComponents.Create3D Namespace


RaycastPoint.Surface1 Property

RaycastPointSurface1 Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Matrix Surface1 { get; set; }
public:
property Matrix Surface1 {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

RaycastPoint Class
VisualComponents.Create3D Namespace


RaycastPoint.Surface2 Property

RaycastPointSurface2 Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Matrix Surface2 { get; set; }
public:
property Matrix Surface2 {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

RaycastPoint Class
VisualComponents.Create3D Namespace


RaycastPoint.Surface3 Property

RaycastPointSurface3 Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<Matrix> Surface3 { get; set; }
public:
property Nullable<Matrix> Surface3 {
    Nullable<Matrix> get ();
    void set (Nullable<Matrix> value);
}

Property Value

Type: NullableMatrix
See Also

Reference

RaycastPoint Class
VisualComponents.Create3D Namespace


RaycastPoint.SurfaceNormals Property

RaycastPointSurfaceNormals Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList<Vector3> SurfaceNormals { get; }
public:
virtual property IList<Vector3>^ SurfaceNormals {
    IList<Vector3>^ get () sealed;
}

Property Value

Type: IListVector3

Implements

ISnapperPositionSurfaceNormals
See Also

Reference

RaycastPoint Class
VisualComponents.Create3D Namespace


RaycastPoint Methods

The RaycastPoint type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RaycastPoint Class
VisualComponents.Create3D Namespace


RaycastPoint.Clone Method

RaycastPointClone Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISnapperPosition Clone()
public:
virtual ISnapperPosition^ Clone() sealed

Return Value

Type: ISnapperPosition

[Missing <returns> documentation for "M:VisualComponents.Create3D.RaycastPoint.Clone"]

Implements

ICloneableTClone
See Also

Reference

RaycastPoint Class
VisualComponents.Create3D Namespace


RaycastResult Structure

Contains a result scene raycast, see IWindow3D

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct RaycastResult
public value class RaycastResult

The RaycastResult type exposes the following members.

Constructors
 | Name | Description
Public method | RaycastResult(IPositionFrame) | Initializes a new instance of RaycastResult.
Public method | RaycastResult(ISchemaFrame) | Initializes a new instance of RaycastResult.
Public method | RaycastResult(ISimNode, IGeometrySet, Int32, Vector3, Vector3) | Initializes a new instance of RaycastResult.
Top
Properties
 | Name | Description
Public property | Hit | True when the ray intersects a node, otherwise false.
Public property | Index | In case of having a Triangle set, this is the triangle index.
Public property | Node | First node intersecting the ray.
Public property | Normal | Hit angle.
Public property | Position | Hit position.
Public property | PositionFrame | Position frame intersecting the ray.
Public property | SchemaFrame | Schema frame intersecting the ray.
Public property | Set | First geometry set intersecting the ray.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object instances are considered equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(RaycastResult) | Determines whether the specified object instances are considered equal.
Public method | GetHashCode | Returns a hashcode for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Equality | Determines whether the specified object instances are considered equal.
Inequality | Determines whether the specified object instances are not considered equal.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


RaycastResult Constructor

Overload List
 | Name | Description
Public method | RaycastResult(IPositionFrame) | Initializes a new instance of RaycastResult.
Public method | RaycastResult(ISchemaFrame) | Initializes a new instance of RaycastResult.
Public method | RaycastResult(ISimNode, IGeometrySet, Int32, Vector3, Vector3) | Initializes a new instance of RaycastResult.
Top
See Also

Reference

RaycastResult Structure
VisualComponents.Create3D Namespace


RaycastResult Constructor (IPositionFrame)

Initializes a new instance of RaycastResult.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RaycastResult(
    IPositionFrame positionFrame
)
public:
RaycastResult(
    IPositionFrame^ positionFrame
)

Parameters

positionFrame
Type: VisualComponents.Create3DIPositionFrame
Position frame.
See Also

Reference

RaycastResult Structure
RaycastResult Overload
VisualComponents.Create3D Namespace


RaycastResult Constructor (ISchemaFrame)

Initializes a new instance of RaycastResult.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RaycastResult(
    ISchemaFrame schemaFrame
)
public:
RaycastResult(
    ISchemaFrame^ schemaFrame
)

Parameters

schemaFrame
Type: VisualComponents.Create3DISchemaFrame
Schema frame.
See Also

Reference

RaycastResult Structure
RaycastResult Overload
VisualComponents.Create3D Namespace


RaycastResult Constructor (ISimNode, IGeometrySet, Int32, Vector3, Vector3)

Initializes a new instance of RaycastResult.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RaycastResult(
    ISimNode node,
    IGeometrySet set,
    int triangleIndex,
    Vector3 position,
    Vector3 normal
)
public:
RaycastResult(
    ISimNode^ node,
    IGeometrySet^ set,
    int triangleIndex,
    Vector3 position,
    Vector3 normal
)

Parameters

node
Type: VisualComponents.Create3DISimNode
Node intersecting the ray.
set
Type: VisualComponents.Create3DIGeometrySet
Geometry set intersecting the ray.
triangleIndex
Type: SystemInt32
Triangle index intersecting the ray.
position
Type: VisualComponents.Create3DVector3
Hit position.
normal
Type: VisualComponents.Create3DVector3
Hit angle.
See Also

Reference

RaycastResult Structure
RaycastResult Overload
VisualComponents.Create3D Namespace


RaycastResult Properties

The RaycastResult type exposes the following members.

Properties
 | Name | Description
Public property | Hit | True when the ray intersects a node, otherwise false.
Public property | Index | In case of having a Triangle set, this is the triangle index.
Public property | Node | First node intersecting the ray.
Public property | Normal | Hit angle.
Public property | Position | Hit position.
Public property | PositionFrame | Position frame intersecting the ray.
Public property | SchemaFrame | Schema frame intersecting the ray.
Public property | Set | First geometry set intersecting the ray.
Top
See Also

Reference

RaycastResult Structure
VisualComponents.Create3D Namespace


RaycastResult.Hit Property

RaycastResultHit Property

True when the ray intersects a node, otherwise false.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Hit { get; }
public:
property bool Hit {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

RaycastResult Structure
VisualComponents.Create3D Namespace


RaycastResult.Index Property

RaycastResultIndex Property

In case of having a Triangle set, this is the triangle index.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Index { get; }
public:
property int Index {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

RaycastResult Structure
VisualComponents.Create3D Namespace


RaycastResult.Node Property

RaycastResultNode Property

First node intersecting the ray.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimNode Node { get; }
public:
property ISimNode^ Node {
    ISimNode^ get ();
}

Property Value

Type: ISimNode
See Also

Reference

RaycastResult Structure
VisualComponents.Create3D Namespace


RaycastResult.Normal Property

RaycastResultNormal Property

Hit angle.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 Normal { get; }
public:
property Vector3 Normal {
    Vector3 get ();
}

Property Value

Type: Vector3
See Also

Reference

RaycastResult Structure
VisualComponents.Create3D Namespace


RaycastResult.Position Property

RaycastResultPosition Property

Hit position.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 Position { get; }
public:
property Vector3 Position {
    Vector3 get ();
}

Property Value

Type: Vector3
See Also

Reference

RaycastResult Structure
VisualComponents.Create3D Namespace


RaycastResult.PositionFrame Property

RaycastResultPositionFrame Property

Position frame intersecting the ray.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IPositionFrame PositionFrame { get; }
public:
property IPositionFrame^ PositionFrame {
    IPositionFrame^ get ();
}

Property Value

Type: IPositionFrame
See Also

Reference

RaycastResult Structure
VisualComponents.Create3D Namespace


RaycastResult.SchemaFrame Property

RaycastResultSchemaFrame Property

Schema frame intersecting the ray.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISchemaFrame SchemaFrame { get; }
public:
property ISchemaFrame^ SchemaFrame {
    ISchemaFrame^ get ();
}

Property Value

Type: ISchemaFrame
See Also

Reference

RaycastResult Structure
VisualComponents.Create3D Namespace


RaycastResult.Set Property

RaycastResultSet Property

First geometry set intersecting the ray.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IGeometrySet Set { get; }
public:
property IGeometrySet^ Set {
    IGeometrySet^ get ();
}

Property Value

Type: IGeometrySet
See Also

Reference

RaycastResult Structure
VisualComponents.Create3D Namespace


RaycastResult Methods

The RaycastResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object instances are considered equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(RaycastResult) | Determines whether the specified object instances are considered equal.
Public method | GetHashCode | Returns a hashcode for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RaycastResult Structure
VisualComponents.Create3D Namespace


RaycastResult.Equals Method

RaycastResultEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object instances are considered equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(RaycastResult) | Determines whether the specified object instances are considered equal.
Top
See Also

Reference

RaycastResult Structure
VisualComponents.Create3D Namespace


RaycastResult.Equals Method (Object)

RaycastResultEquals Method (Object)

Determines whether the specified object instances are considered equal.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
The object to compare with the current object.

Return Value

Type: Boolean
true if the objects are considered equal; otherwise, false.
See Also

Reference

RaycastResult Structure
Equals Overload
VisualComponents.Create3D Namespace


RaycastResult.Equals Method (RaycastResult)

RaycastResultEquals Method (RaycastResult)

Determines whether the specified object instances are considered equal.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    RaycastResult other
)
public:
bool Equals(
    RaycastResult other
)

Parameters

other
Type: VisualComponents.Create3DRaycastResult
The object to compare with the current object.

Return Value

Type: Boolean
true if the objects are considered equal; otherwise, false.
See Also

Reference

RaycastResult Structure
Equals Overload
VisualComponents.Create3D Namespace


RaycastResult.GetHashCode Method

RaycastResultGetHashCode Method

Returns a hashcode for this object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32
the hahscode.
See Also

Reference

RaycastResult Structure
VisualComponents.Create3D Namespace


RaycastResult Operators

The RaycastResult type exposes the following members.

Operators
Name | Description
Equality | Determines whether the specified object instances are considered equal.
Inequality | Determines whether the specified object instances are not considered equal.
Top
See Also

Reference

RaycastResult Structure
VisualComponents.Create3D Namespace


RaycastResult.Equality Operator

RaycastResultEquality Operator

Determines whether the specified object instances are considered equal.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    RaycastResult result1,
    RaycastResult result2
)
public:
static bool operator ==(
    RaycastResult result1,
    RaycastResult result2
)

Parameters

result1
Type: VisualComponents.Create3DRaycastResult
The first object to compare.
result2
Type: VisualComponents.Create3DRaycastResult
The second object to compare.

Return Value

Type: Boolean
true if the objects are considered equal; otherwise, false.
See Also

Reference

RaycastResult Structure
VisualComponents.Create3D Namespace


RaycastResult.Inequality Operator

RaycastResultInequality Operator

Determines whether the specified object instances are not considered equal.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    RaycastResult result1,
    RaycastResult result2
)
public:
static bool operator !=(
    RaycastResult result1,
    RaycastResult result2
)

Parameters

result1
Type: VisualComponents.Create3DRaycastResult
The first object to compare.
result2
Type: VisualComponents.Create3DRaycastResult
The second object to compare.

Return Value

Type: Boolean
true if the objects are not considered equal; otherwise, true.
See Also

Reference

RaycastResult Structure
VisualComponents.Create3D Namespace


ReaderType Enumeration

Application readers type

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ReaderType
public enum class ReaderType
Members
Member name | Value | Description
HOOPS_READER | 0 |
HOOPS_READER_STEP | 1 |
DWG_READER | 2 |
OBJ_READER | 3 |
NATIVE_READER | 4 |
See Also

Reference

VisualComponents.Create3D Namespace


RecordingStartStopEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DRecordingStartStopEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RecordingStartStopEventArgs : EventArgs
public ref class RecordingStartStopEventArgs : public EventArgs

The RecordingStartStopEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | RecordingStartStopEventArgs | Initializes a new instance of the RecordingStartStopEventArgs class
Top
Properties
 | Name | Description
Public property | Started |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


RecordingStartStopEventArgs Constructor

Initializes a new instance of the RecordingStartStopEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RecordingStartStopEventArgs(
    bool started
)
public:
RecordingStartStopEventArgs(
    bool started
)

Parameters

started
Type: SystemBoolean
See Also

Reference

RecordingStartStopEventArgs Class
VisualComponents.Create3D Namespace


RecordingStartStopEventArgs Properties

The RecordingStartStopEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Started |
Top
See Also

Reference

RecordingStartStopEventArgs Class
VisualComponents.Create3D Namespace


RecordingStartStopEventArgs.Started Property

RecordingStartStopEventArgsStarted Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Started { get; }
public:
property bool Started {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

RecordingStartStopEventArgs Class
VisualComponents.Create3D Namespace


RecordingStartStopEventArgs Methods

The RecordingStartStopEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RecordingStartStopEventArgs Class
VisualComponents.Create3D Namespace


RecordingType Enumeration

Recording typess

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum RecordingType
public enum class RecordingType
Members
Member name | Value | Description
Video | 0 | video recording
Pdf | 1 | PDF recording
See Also

Reference

VisualComponents.Create3D Namespace


RenderEffectMode Enumeration

List of available rendering effects.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum RenderEffectMode
public enum class RenderEffectMode
Members
Member name | Value | Description
NoShader | 0 |
Shader | 1 |
SilhouetteSSAO | 2 |
ShadowSilhouette | 3 |
ShadowSSAOSilhouette | 4 |
FullRenderingSilhouette | 5 |
See Also

Reference

VisualComponents.Create3D Namespace


RenderingMode Structure

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct RenderingMode
public value class RenderingMode

The RenderingMode type exposes the following members.

Properties
 | Name | Description
Public property | Content |
Public property | Description |
Public property | IconPath |
Public property | Id |
Public property | IsIconSourceFromFile |
Public property | Quality |
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


RenderingMode Properties

The RenderingMode type exposes the following members.

Properties
 | Name | Description
Public property | Content |
Public property | Description |
Public property | IconPath |
Public property | Id |
Public property | IsIconSourceFromFile |
Public property | Quality |
Top
See Also

Reference

RenderingMode Structure
VisualComponents.Create3D Namespace


RenderingMode.Content Property

RenderingModeContent Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Content { get; set; }
public:
property String^ Content {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

RenderingMode Structure
VisualComponents.Create3D Namespace


RenderingMode.Description Property

RenderingModeDescription Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; set; }
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

RenderingMode Structure
VisualComponents.Create3D Namespace


RenderingMode.IconPath Property

RenderingModeIconPath Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string IconPath { get; set; }
public:
property String^ IconPath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

RenderingMode Structure
VisualComponents.Create3D Namespace


RenderingMode.Id Property

RenderingModeId Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Id { get; set; }
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

RenderingMode Structure
VisualComponents.Create3D Namespace


RenderingMode.IsIconSourceFromFile Property

RenderingModeIsIconSourceFromFile Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsIconSourceFromFile { get; set; }
public:
property bool IsIconSourceFromFile {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

RenderingMode Structure
VisualComponents.Create3D Namespace


RenderingMode.Quality Property

RenderingModeQuality Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RenderingQuality Quality { get; set; }
public:
property RenderingQuality Quality {
    RenderingQuality get ();
    void set (RenderingQuality value);
}

Property Value

Type: RenderingQuality
See Also

Reference

RenderingMode Structure
VisualComponents.Create3D Namespace


RenderingMode Methods

The RenderingMode type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RenderingMode Structure
VisualComponents.Create3D Namespace


RenderingPreset Structure

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct RenderingPreset
public value class RenderingPreset

The RenderingPreset type exposes the following members.

Properties
 | Name | Description
Public property | Content |
Public property | Description |
Public property | IconPath |
Public property | Id |
Public property | IsIconSourceFromFile |
Public property | PresetMode |
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


RenderingPreset Properties

The RenderingPreset type exposes the following members.

Properties
 | Name | Description
Public property | Content |
Public property | Description |
Public property | IconPath |
Public property | Id |
Public property | IsIconSourceFromFile |
Public property | PresetMode |
Top
See Also

Reference

RenderingPreset Structure
VisualComponents.Create3D Namespace


RenderingPreset.Content Property

RenderingPresetContent Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Content { get; set; }
public:
property String^ Content {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

RenderingPreset Structure
VisualComponents.Create3D Namespace


RenderingPreset.Description Property

RenderingPresetDescription Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; set; }
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

RenderingPreset Structure
VisualComponents.Create3D Namespace


RenderingPreset.IconPath Property

RenderingPresetIconPath Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string IconPath { get; set; }
public:
property String^ IconPath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

RenderingPreset Structure
VisualComponents.Create3D Namespace


RenderingPreset.Id Property

RenderingPresetId Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Id { get; set; }
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

RenderingPreset Structure
VisualComponents.Create3D Namespace


RenderingPreset.IsIconSourceFromFile Property

RenderingPresetIsIconSourceFromFile Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsIconSourceFromFile { get; set; }
public:
property bool IsIconSourceFromFile {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

RenderingPreset Structure
VisualComponents.Create3D Namespace


RenderingPreset.PresetMode Property

RenderingPresetPresetMode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PresetMode PresetMode { get; set; }
public:
property PresetMode PresetMode {
    PresetMode get ();
    void set (PresetMode value);
}

Property Value

Type: PresetMode
See Also

Reference

RenderingPreset Structure
VisualComponents.Create3D Namespace


RenderingPreset Methods

The RenderingPreset type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RenderingPreset Structure
VisualComponents.Create3D Namespace


RenderingQuality Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum RenderingQuality
public enum class RenderingQuality
Members
Member name | Value | Description
Preset | 0 |
Fast | 1 |
Medium | 2 |
High | 3 |
Ultra | 4 |
See Also

Reference

VisualComponents.Create3D Namespace


RenderPresetModeChangedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DRenderPresetModeChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RenderPresetModeChangedEventArgs : EventArgs
public ref class RenderPresetModeChangedEventArgs : public EventArgs

The RenderPresetModeChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | RenderPresetModeChangedEventArgs | Initializes a new instance of the RenderPresetModeChangedEventArgs class
Top
Properties
 | Name | Description
Public property | Mode |
Public property | Window |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


RenderPresetModeChangedEventArgs Constructor

Initializes a new instance of the RenderPresetModeChangedEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RenderPresetModeChangedEventArgs(
    IWindow3D window,
    PresetMode mode
)
public:
RenderPresetModeChangedEventArgs(
    IWindow3D^ window,
    PresetMode mode
)

Parameters

window
Type: VisualComponents.Create3DIWindow3D
mode
Type: VisualComponents.Create3DPresetMode
See Also

Reference

RenderPresetModeChangedEventArgs Class
VisualComponents.Create3D Namespace


RenderPresetModeChangedEventArgs Properties

The RenderPresetModeChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Mode |
Public property | Window |
Top
See Also

Reference

RenderPresetModeChangedEventArgs Class
VisualComponents.Create3D Namespace


RenderPresetModeChangedEventArgs.Mode Property

RenderPresetModeChangedEventArgsMode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PresetMode Mode { get; }
public:
property PresetMode Mode {
    PresetMode get ();
}

Property Value

Type: PresetMode
See Also

Reference

RenderPresetModeChangedEventArgs Class
VisualComponents.Create3D Namespace


RenderPresetModeChangedEventArgs.Window Property

RenderPresetModeChangedEventArgsWindow Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IWindow3D Window { get; }
public:
property IWindow3D^ Window {
    IWindow3D^ get ();
}

Property Value

Type: IWindow3D
See Also

Reference

RenderPresetModeChangedEventArgs Class
VisualComponents.Create3D Namespace


RenderPresetModeChangedEventArgs Methods

The RenderPresetModeChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RenderPresetModeChangedEventArgs Class
VisualComponents.Create3D Namespace


RenderShading Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum RenderShading
public enum class RenderShading
Members
Member name | Value | Description
None | 0 |
NoFill | 1 |
ConstantFill | 2 |
FlatShaded | 3 |
SmoothShaded | 4 |
See Also

Reference

VisualComponents.Create3D Namespace


Revit Enumeration

Revit

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum Revit
public enum class Revit
Members
Member name | Value | Description
RVT | 0 |
RFA | 1 |
See Also

Reference

VisualComponents.Create3D Namespace


Rhino Enumeration

Rhino -> 4, 5

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum Rhino
public enum class Rhino
Members
Member name | Value | Description
FORMAT_3DM | 0 |
See Also

Reference

VisualComponents.Create3D Namespace


RibbonProgramConfigElement Class

Configuration element for Program ribbon tab.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.Create3DRibbonProgramConfigElement

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class RibbonProgramConfigElement : ConfigurationElement
public ref class RibbonProgramConfigElement sealed : public ConfigurationElement

The RibbonProgramConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | RibbonProgramConfigElement | Constructor.
Top
Properties
 | Name | Description
Public property | AccelerationLimit | Acceleration limit property.
Public property | ColorHighlightLimit | Color Highlight limit property.
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | MessagePanelOutputLimit | Message Panel Output limit property.
Public property | SingularityLimit | Singularity limit property.
Public property | SpeedLimit | Speed limit property.
Public property | StopAtLimitsLimit | Stop At Limits limit property.
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InitDefaults |
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks
These options are visibile in Program ribbon tab, and stored to user-specific configuration file.
See Also

Reference

VisualComponents.Create3D Namespace


RibbonProgramConfigElement Constructor

Constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RibbonProgramConfigElement()
public:
RibbonProgramConfigElement()
See Also

Reference

RibbonProgramConfigElement Class
VisualComponents.Create3D Namespace


RibbonProgramConfigElement Properties

The RibbonProgramConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | AccelerationLimit | Acceleration limit property.
Public property | ColorHighlightLimit | Color Highlight limit property.
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | MessagePanelOutputLimit | Message Panel Output limit property.
Public property | SingularityLimit | Singularity limit property.
Public property | SpeedLimit | Speed limit property.
Public property | StopAtLimitsLimit | Stop At Limits limit property.
Top
See Also

Reference

RibbonProgramConfigElement Class
VisualComponents.Create3D Namespace


RibbonProgramConfigElement.AccelerationLimit Property

RibbonProgramConfigElementAccelerationLimit Property

Acceleration limit property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<bool> AccelerationLimit { get; set; }
public:
property Nullable<bool> AccelerationLimit {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: NullableBoolean
See Also

Reference

RibbonProgramConfigElement Class
VisualComponents.Create3D Namespace


RibbonProgramConfigElement.ColorHighlightLimit Property

RibbonProgramConfigElementColorHighlightLimit Property

Color Highlight limit property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<bool> ColorHighlightLimit { get; set; }
public:
property Nullable<bool> ColorHighlightLimit {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: NullableBoolean
See Also

Reference

RibbonProgramConfigElement Class
VisualComponents.Create3D Namespace


RibbonProgramConfigElement.MessagePanelOutputLimit Property

RibbonProgramConfigElementMessagePanelOutputLimit Property

Message Panel Output limit property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<bool> MessagePanelOutputLimit { get; set; }
public:
property Nullable<bool> MessagePanelOutputLimit {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: NullableBoolean
See Also

Reference

RibbonProgramConfigElement Class
VisualComponents.Create3D Namespace


RibbonProgramConfigElement.SingularityLimit Property

RibbonProgramConfigElementSingularityLimit Property

Singularity limit property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<bool> SingularityLimit { get; set; }
public:
property Nullable<bool> SingularityLimit {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: NullableBoolean
See Also

Reference

RibbonProgramConfigElement Class
VisualComponents.Create3D Namespace


RibbonProgramConfigElement.SpeedLimit Property

RibbonProgramConfigElementSpeedLimit Property

Speed limit property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<bool> SpeedLimit { get; set; }
public:
property Nullable<bool> SpeedLimit {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: NullableBoolean
See Also

Reference

RibbonProgramConfigElement Class
VisualComponents.Create3D Namespace


RibbonProgramConfigElement.StopAtLimitsLimit Property

RibbonProgramConfigElementStopAtLimitsLimit Property

Stop At Limits limit property.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<bool> StopAtLimitsLimit { get; set; }
public:
property Nullable<bool> StopAtLimitsLimit {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: NullableBoolean
See Also

Reference

RibbonProgramConfigElement Class
VisualComponents.Create3D Namespace


RibbonProgramConfigElement Methods

The RibbonProgramConfigElement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InitDefaults |
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RibbonProgramConfigElement Class
VisualComponents.Create3D Namespace


RibbonProgramConfigElement.InitDefaults Method

RibbonProgramConfigElementInitDefaults Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void InitDefaults(
    IAppConfigSettings appConfigSettings
)
public:
static void InitDefaults(
    IAppConfigSettings^ appConfigSettings
)

Parameters

appConfigSettings
Type: VisualComponents.Create3DIAppConfigSettings
See Also

Reference

RibbonProgramConfigElement Class
VisualComponents.Create3D Namespace


RobFace Enumeration

RobFace r4

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum RobFace
public enum class RobFace
Members
Member name | Value | Description
FORMAT_RF | 0 |
See Also

Reference

VisualComponents.Create3D Namespace


RobotConversionStatus Enumeration

Robot conversion statuses.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum RobotConversionStatus
public enum class RobotConversionStatus
Members
Member name | Value | Description
NoNeed | 0 | Robot has no legacy executor requiring conversion.
Need | 1 | Robot has a legacy executor requiring conversion, but no program in it.
NeedAndAsk | 2 | Robot has a legacy executor requiring conversion and program in it.
See Also

Reference

VisualComponents.Create3D Namespace


RobotFrameAddedEventArgs Class

Event data for ToolAdded and BaseAdded events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DRobotFrameAddedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RobotFrameAddedEventArgs : EventArgs
public ref class RobotFrameAddedEventArgs : public EventArgs

The RobotFrameAddedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | RobotFrameAddedEventArgs | Initializes a new instance of RobotFrameAddedEventArgs class.
Top
Properties
 | Name | Description
Public property | RobotFrame | Gets the added IRobotFrame.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


RobotFrameAddedEventArgs Constructor

Initializes a new instance of RobotFrameAddedEventArgs class.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RobotFrameAddedEventArgs(
    IRobotFrame robotFrame
)
public:
RobotFrameAddedEventArgs(
    IRobotFrame^ robotFrame
)

Parameters

robotFrame
Type: VisualComponents.Create3DIRobotFrame
Added robot frame.
See Also

Reference

RobotFrameAddedEventArgs Class
VisualComponents.Create3D Namespace


RobotFrameAddedEventArgs Properties

The RobotFrameAddedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | RobotFrame | Gets the added IRobotFrame.
Top
See Also

Reference

RobotFrameAddedEventArgs Class
VisualComponents.Create3D Namespace


RobotFrameAddedEventArgs.RobotFrame Property

RobotFrameAddedEventArgsRobotFrame Property

Gets the added IRobotFrame.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IRobotFrame RobotFrame { get; }
public:
property IRobotFrame^ RobotFrame {
    IRobotFrame^ get ();
}

Property Value

Type: IRobotFrame
See Also

Reference

RobotFrameAddedEventArgs Class
VisualComponents.Create3D Namespace


RobotFrameAddedEventArgs Methods

The RobotFrameAddedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RobotFrameAddedEventArgs Class
VisualComponents.Create3D Namespace


RobotFrameIpoMode Enumeration

Robot frame IPO mode enumeration.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum RobotFrameIpoMode
public enum class RobotFrameIpoMode
Members
Member name | Value | Description
None | 0 | Frame can be used both with and without external TCP.
Base | 1 | Frame default is external TCP disabled.
Tcp | 2 | Frame default is external TCP enabled.
See Also

Reference

VisualComponents.Create3D Namespace


RobotFrameRemovingEventArgs Class

Event data for BaseRemoving and ToolRemoving events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DRobotFrameRemovingEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RobotFrameRemovingEventArgs : EventArgs
public ref class RobotFrameRemovingEventArgs : public EventArgs

The RobotFrameRemovingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | RobotFrameRemovingEventArgs | Initializes a new instance of RobotFrameRemovingEventArgs class.
Top
Properties
 | Name | Description
Public property | RobotFrame | Gets the IRobotFrame that is being removed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


RobotFrameRemovingEventArgs Constructor

Initializes a new instance of RobotFrameRemovingEventArgs class.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RobotFrameRemovingEventArgs(
    IRobotFrame robotFrame
)
public:
RobotFrameRemovingEventArgs(
    IRobotFrame^ robotFrame
)

Parameters

robotFrame
Type: VisualComponents.Create3DIRobotFrame
Robot frame that is being removed.
See Also

Reference

RobotFrameRemovingEventArgs Class
VisualComponents.Create3D Namespace


RobotFrameRemovingEventArgs Properties

The RobotFrameRemovingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | RobotFrame | Gets the IRobotFrame that is being removed.
Top
See Also

Reference

RobotFrameRemovingEventArgs Class
VisualComponents.Create3D Namespace


RobotFrameRemovingEventArgs.RobotFrame Property

RobotFrameRemovingEventArgsRobotFrame Property

Gets the IRobotFrame that is being removed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IRobotFrame RobotFrame { get; }
public:
property IRobotFrame^ RobotFrame {
    IRobotFrame^ get ();
}

Property Value

Type: IRobotFrame
See Also

Reference

RobotFrameRemovingEventArgs Class
VisualComponents.Create3D Namespace


RobotFrameRemovingEventArgs Methods

The RobotFrameRemovingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RobotFrameRemovingEventArgs Class
VisualComponents.Create3D Namespace


RotationCoordinateSystem Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum RotationCoordinateSystem
public enum class RotationCoordinateSystem
Members
Member name | Value | Description
ABC | 0 |
XYZ | 1 |
See Also

Reference

VisualComponents.Create3D Namespace


RouteTransportSolutionStatementRuleType Enumeration

Used in IRouteTransportSolutionStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum RouteTransportSolutionStatementRuleType
public enum class RouteTransportSolutionStatementRuleType
Members
Member name | Value | Description
NextTransportNode | 0 | The ITransportNode to compare will be the next one that the ISimProduct object is going to.
SourceNode | 1 | The ITransportNode to compare will be the next one where the ISimProduct object started from.
DestinationNode | 2 | The ITransportNode to compare will be the final destination ISimProduct of the object.
See Also

Reference

VisualComponents.Create3D Namespace


RoutineAddedEventArgs Class

Provides data for RoutineAddedEvent event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DRoutineAddedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RoutineAddedEventArgs : EventArgs
public ref class RoutineAddedEventArgs : public EventArgs

The RoutineAddedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | RoutineAddedEventArgs | Constructor.
Top
Properties
 | Name | Description
Public property | Routine | Gets the IRoutine that has been added.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


RoutineAddedEventArgs Constructor

Constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RoutineAddedEventArgs(
    IRoutine routine
)
public:
RoutineAddedEventArgs(
    IRoutine^ routine
)

Parameters

routine
Type: VisualComponents.Create3DIRoutine
routine.
See Also

Reference

RoutineAddedEventArgs Class
VisualComponents.Create3D Namespace


RoutineAddedEventArgs Properties

The RoutineAddedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Routine | Gets the IRoutine that has been added.
Top
See Also

Reference

RoutineAddedEventArgs Class
VisualComponents.Create3D Namespace


RoutineAddedEventArgs.Routine Property

RoutineAddedEventArgsRoutine Property

Gets the IRoutine that has been added.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IRoutine Routine { get; }
public:
property IRoutine^ Routine {
    IRoutine^ get ();
}

Property Value

Type: IRoutine
See Also

Reference

RoutineAddedEventArgs Class
VisualComponents.Create3D Namespace


RoutineAddedEventArgs Methods

The RoutineAddedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RoutineAddedEventArgs Class
VisualComponents.Create3D Namespace


RoutineRemovingEventArgs Class

Provides data for RoutineRemoving event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DRoutineRemovingEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RoutineRemovingEventArgs : EventArgs
public ref class RoutineRemovingEventArgs : public EventArgs

The RoutineRemovingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | RoutineRemovingEventArgs | Constructor.
Top
Properties
 | Name | Description
Public property | Routine | Gets the IRoutine that is being removed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


RoutineRemovingEventArgs Constructor

Constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RoutineRemovingEventArgs(
    IRoutine routine
)
public:
RoutineRemovingEventArgs(
    IRoutine^ routine
)

Parameters

routine
Type: VisualComponents.Create3DIRoutine
routine.
See Also

Reference

RoutineRemovingEventArgs Class
VisualComponents.Create3D Namespace


RoutineRemovingEventArgs Properties

The RoutineRemovingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Routine | Gets the IRoutine that is being removed.
Top
See Also

Reference

RoutineRemovingEventArgs Class
VisualComponents.Create3D Namespace


RoutineRemovingEventArgs.Routine Property

RoutineRemovingEventArgsRoutine Property

Gets the IRoutine that is being removed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IRoutine Routine { get; }
public:
property IRoutine^ Routine {
    IRoutine^ get ();
}

Property Value

Type: IRoutine
See Also

Reference

RoutineRemovingEventArgs Class
VisualComponents.Create3D Namespace


RoutineRemovingEventArgs Methods

The RoutineRemovingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RoutineRemovingEventArgs Class
VisualComponents.Create3D Namespace


RunNotifiedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DRunNotifiedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RunNotifiedEventArgs : EventArgs
public ref class RunNotifiedEventArgs : public EventArgs

The RunNotifiedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | RunNotifiedEventArgs | Initializes a new instance of the RunNotifiedEventArgs class
Top
Properties
 | Name | Description
Public property | TimeSlice |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


RunNotifiedEventArgs Constructor

Initializes a new instance of the RunNotifiedEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RunNotifiedEventArgs(
    int timeSlice
)
public:
RunNotifiedEventArgs(
    int timeSlice
)

Parameters

timeSlice
Type: SystemInt32
See Also

Reference

RunNotifiedEventArgs Class
VisualComponents.Create3D Namespace


RunNotifiedEventArgs Properties

The RunNotifiedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | TimeSlice |
Top
See Also

Reference

RunNotifiedEventArgs Class
VisualComponents.Create3D Namespace


RunNotifiedEventArgs.TimeSlice Property

RunNotifiedEventArgsTimeSlice Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int TimeSlice { get; }
public:
property int TimeSlice {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

RunNotifiedEventArgs Class
VisualComponents.Create3D Namespace


RunNotifiedEventArgs Methods

The RunNotifiedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RunNotifiedEventArgs Class
VisualComponents.Create3D Namespace


SchemaFrameCollection Class

Helper class that converts ISchemaFrame[] to IEnumerableT. See ICombinable interface. Note: This is needed because ISchemaFrame inherits from ICombinable interface.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DCombinableItemCollection ISchemaFrame
VisualComponents.Create3DSchemaFrameCollection

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SchemaFrameCollection : CombinableItemCollection<ISchemaFrame>,
    IEnumerable<ISchemaFrame>, IEnumerable, IGenericEnumeratorOwner<ISchemaFrame>
public ref class SchemaFrameCollection : public CombinableItemCollection<ISchemaFrame^>,
    IEnumerable<ISchemaFrame^>, IEnumerable, IGenericEnumeratorOwner<ISchemaFrame^>

The SchemaFrameCollection type exposes the following members.

Constructors
 | Name | Description
Public method | SchemaFrameCollection(IEnumerableISchemaFrame) | Initializes a new instance of the SchemaFrameCollection class
Public method | SchemaFrameCollection(ISchemaFrame) | Initializes a new instance of the SchemaFrameCollection class
Top
Properties
 | Name | Description
Public property | OriginalFrames | (Overrides CombinableItemCollectionTOriginalFrames.)
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the SchemaFrameCollection
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachISchemaFrame | Enumerate a cached collection performing the specified action on each item. (Defined by ForEachHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | HasMoreThanISchemaFrame | (Defined by EnumerableHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToObservableCollectionISchemaFrame | (Defined by Extensions.)
Public Extension Method | ToObservableCollectionExISchemaFrame | (Defined by Extensions.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


SchemaFrameCollection Constructor

Overload List
 | Name | Description
Public method | SchemaFrameCollection(IEnumerableISchemaFrame) | Initializes a new instance of the SchemaFrameCollection class
Public method | SchemaFrameCollection(ISchemaFrame) | Initializes a new instance of the SchemaFrameCollection class
Top
See Also

Reference

SchemaFrameCollection Class
VisualComponents.Create3D Namespace


SchemaFrameCollection Constructor (IEnumerable(ISchemaFrame))

SchemaFrameCollection Constructor (IEnumerableISchemaFrame)

Initializes a new instance of the SchemaFrameCollection class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SchemaFrameCollection(
    IEnumerable<ISchemaFrame> currentlySelected
)
public:
SchemaFrameCollection(
    IEnumerable<ISchemaFrame^>^ currentlySelected
)

Parameters

currentlySelected
Type: System.Collections.GenericIEnumerableISchemaFrame
See Also

Reference

SchemaFrameCollection Class
SchemaFrameCollection Overload
VisualComponents.Create3D Namespace


SchemaFrameCollection Constructor (ISchemaFrame)

Initializes a new instance of the SchemaFrameCollection class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SchemaFrameCollection(
    ISchemaFrame currentlySelected
)
public:
SchemaFrameCollection(
    ISchemaFrame^ currentlySelected
)

Parameters

currentlySelected
Type: VisualComponents.Create3DISchemaFrame
See Also

Reference

SchemaFrameCollection Class
SchemaFrameCollection Overload
VisualComponents.Create3D Namespace


SchemaFrameCollection Properties

The SchemaFrameCollection type exposes the following members.

Properties
 | Name | Description
Public property | OriginalFrames | (Overrides CombinableItemCollectionTOriginalFrames.)
Top
See Also

Reference

SchemaFrameCollection Class
VisualComponents.Create3D Namespace


SchemaFrameCollection.OriginalFrames Property

SchemaFrameCollectionOriginalFrames Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override IEnumerable<ISchemaFrame> OriginalFrames { get; }
public:
virtual property IEnumerable<ISchemaFrame^>^ OriginalFrames {
    IEnumerable<ISchemaFrame^>^ get () override;
}

Property Value

Type: IEnumerableISchemaFrame
See Also

Reference

SchemaFrameCollection Class
VisualComponents.Create3D Namespace


SchemaFrameCollection Methods

The SchemaFrameCollection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachISchemaFrame | Enumerate a cached collection performing the specified action on each item. (Defined by ForEachHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | HasMoreThanISchemaFrame | (Defined by EnumerableHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToObservableCollectionISchemaFrame | (Defined by Extensions.)
Public Extension Method | ToObservableCollectionExISchemaFrame | (Defined by Extensions.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SchemaFrameCollection Class
VisualComponents.Create3D Namespace


SchemaFrameCollection.Dispose Method

SchemaFrameCollectionDispose Method

Releases all resources used by the SchemaFrameCollection

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Dispose()
public:
void Dispose()
See Also

Reference

SchemaFrameCollection Class
VisualComponents.Create3D Namespace


SchemaFrameCollection.GetEnumerator Method

SchemaFrameCollectionGetEnumerator Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerator<ISchemaFrame> GetEnumerator()
public:
virtual IEnumerator<ISchemaFrame^>^ GetEnumerator() sealed

Return Value

Type: IEnumeratorISchemaFrame

[Missing <returns> documentation for "M:VisualComponents.Create3D.SchemaFrameCollection.GetEnumerator"]

Implements

IEnumerableTGetEnumerator
See Also

Reference

SchemaFrameCollection Class
VisualComponents.Create3D Namespace


SchemaFrameCollection.MoveNext Method

SchemaFrameCollectionMoveNext Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool MoveNext(
    GenericEnumerator<ISchemaFrame> state
)
public:
virtual bool MoveNext(
    GenericEnumerator<ISchemaFrame^>^ state
) sealed

Parameters

state
Type: VisualComponents.Create3DGenericEnumerator ISchemaFrame

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.SchemaFrameCollection.MoveNext(VisualComponents.Create3D.GenericEnumerator{VisualComponents.Create3D.ISchemaFrame})"]

Implements

IGenericEnumeratorOwnerTMoveNext(GenericEnumeratorT)
See Also

Reference

SchemaFrameCollection Class
VisualComponents.Create3D Namespace


SchemaPositionFrameCollection Class

Helper class that converts IPositionFrame[] to IEnumerableT. See ICombinable interface. Note: This is needed because ISchemaPositionFrame inherits from ICombinable interface.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DCombinableItemCollection IPositionFrame
VisualComponents.Create3DSchemaPositionFrameCollection

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SchemaPositionFrameCollection : CombinableItemCollection<IPositionFrame>,
    IEnumerable<IPositionFrame>, IEnumerable, IGenericEnumeratorOwner<IPositionFrame>
public ref class SchemaPositionFrameCollection : public CombinableItemCollection<IPositionFrame^>,
    IEnumerable<IPositionFrame^>, IEnumerable, IGenericEnumeratorOwner<IPositionFrame^>

The SchemaPositionFrameCollection type exposes the following members.

Constructors
 | Name | Description
Public method | SchemaPositionFrameCollection(IEnumerableIPositionFrame) | Initializes a new instance of the SchemaPositionFrameCollection class
Public method | SchemaPositionFrameCollection(IPositionFrame) | Initializes a new instance of the SchemaPositionFrameCollection class
Top
Properties
 | Name | Description
Public property | OriginalFrames | (Overrides CombinableItemCollectionTOriginalFrames.)
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the SchemaPositionFrameCollection
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachIPositionFrame | Enumerate a cached collection performing the specified action on each item. (Defined by ForEachHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | HasMoreThanIPositionFrame | (Defined by EnumerableHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToObservableCollectionIPositionFrame | (Defined by Extensions.)
Public Extension Method | ToObservableCollectionExIPositionFrame | (Defined by Extensions.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


SchemaPositionFrameCollection Constructor

Overload List
 | Name | Description
Public method | SchemaPositionFrameCollection(IEnumerableIPositionFrame) | Initializes a new instance of the SchemaPositionFrameCollection class
Public method | SchemaPositionFrameCollection(IPositionFrame) | Initializes a new instance of the SchemaPositionFrameCollection class
Top
See Also

Reference

SchemaPositionFrameCollection Class
VisualComponents.Create3D Namespace


SchemaPositionFrameCollection Constructor (IEnumerable(IPositionFrame))

SchemaPositionFrameCollection Constructor (IEnumerableIPositionFrame)

Initializes a new instance of the SchemaPositionFrameCollection class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SchemaPositionFrameCollection(
    IEnumerable<IPositionFrame> currentlySelected
)
public:
SchemaPositionFrameCollection(
    IEnumerable<IPositionFrame^>^ currentlySelected
)

Parameters

currentlySelected
Type: System.Collections.GenericIEnumerableIPositionFrame
See Also

Reference

SchemaPositionFrameCollection Class
SchemaPositionFrameCollection Overload
VisualComponents.Create3D Namespace


SchemaPositionFrameCollection Constructor (IPositionFrame)

Initializes a new instance of the SchemaPositionFrameCollection class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SchemaPositionFrameCollection(
    IPositionFrame currentlySelected
)
public:
SchemaPositionFrameCollection(
    IPositionFrame^ currentlySelected
)

Parameters

currentlySelected
Type: VisualComponents.Create3DIPositionFrame
See Also

Reference

SchemaPositionFrameCollection Class
SchemaPositionFrameCollection Overload
VisualComponents.Create3D Namespace


SchemaPositionFrameCollection Properties

The SchemaPositionFrameCollection type exposes the following members.

Properties
 | Name | Description
Public property | OriginalFrames | (Overrides CombinableItemCollectionTOriginalFrames.)
Top
See Also

Reference

SchemaPositionFrameCollection Class
VisualComponents.Create3D Namespace


SchemaPositionFrameCollection.OriginalFrames Property

SchemaPositionFrameCollectionOriginalFrames Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override IEnumerable<IPositionFrame> OriginalFrames { get; }
public:
virtual property IEnumerable<IPositionFrame^>^ OriginalFrames {
    IEnumerable<IPositionFrame^>^ get () override;
}

Property Value

Type: IEnumerableIPositionFrame
See Also

Reference

SchemaPositionFrameCollection Class
VisualComponents.Create3D Namespace


SchemaPositionFrameCollection Methods

The SchemaPositionFrameCollection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachIPositionFrame | Enumerate a cached collection performing the specified action on each item. (Defined by ForEachHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | HasMoreThanIPositionFrame | (Defined by EnumerableHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToObservableCollectionIPositionFrame | (Defined by Extensions.)
Public Extension Method | ToObservableCollectionExIPositionFrame | (Defined by Extensions.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SchemaPositionFrameCollection Class
VisualComponents.Create3D Namespace


SchemaPositionFrameCollection.Dispose Method

SchemaPositionFrameCollectionDispose Method

Releases all resources used by the SchemaPositionFrameCollection

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Dispose()
public:
void Dispose()
See Also

Reference

SchemaPositionFrameCollection Class
VisualComponents.Create3D Namespace


SchemaPositionFrameCollection.GetEnumerator Method

SchemaPositionFrameCollectionGetEnumerator Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerator<IPositionFrame> GetEnumerator()
public:
virtual IEnumerator<IPositionFrame^>^ GetEnumerator() sealed

Return Value

Type: IEnumeratorIPositionFrame

[Missing <returns> documentation for "M:VisualComponents.Create3D.SchemaPositionFrameCollection.GetEnumerator"]

Implements

IEnumerableTGetEnumerator
See Also

Reference

SchemaPositionFrameCollection Class
VisualComponents.Create3D Namespace


SchemaPositionFrameCollection.MoveNext Method

SchemaPositionFrameCollectionMoveNext Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool MoveNext(
    GenericEnumerator<IPositionFrame> state
)
public:
virtual bool MoveNext(
    GenericEnumerator<IPositionFrame^>^ state
) sealed

Parameters

state
Type: VisualComponents.Create3DGenericEnumerator IPositionFrame

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.SchemaPositionFrameCollection.MoveNext(VisualComponents.Create3D.GenericEnumerator{VisualComponents.Create3D.IPositionFrame})"]

Implements

IGenericEnumeratorOwnerTMoveNext(GenericEnumeratorT)
See Also

Reference

SchemaPositionFrameCollection Class
VisualComponents.Create3D Namespace


SchemaRecordChangedEventArgs Class

Provides data for: - RecordAppended - RecordInserted - RecordRemoved
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DSchemaRecordChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SchemaRecordChangedEventArgs : EventArgs
public ref class SchemaRecordChangedEventArgs : public EventArgs

The SchemaRecordChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SchemaRecordChangedEventArgs | Initializes a new instance of SchemaRecordChangedEventArgs.
Top
Properties
 | Name | Description
Public property | Count | Number of rows that changed (starting from DataIndex).
Public property | DataIndex | Data index that has changed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


SchemaRecordChangedEventArgs Constructor

Initializes a new instance of SchemaRecordChangedEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SchemaRecordChangedEventArgs(
    int dataIndex,
    int count
)
public:
SchemaRecordChangedEventArgs(
    int dataIndex,
    int count
)

Parameters

dataIndex
Type: SystemInt32
Data index.
count
Type: SystemInt32
Number of changed records.
See Also

Reference

SchemaRecordChangedEventArgs Class
VisualComponents.Create3D Namespace


SchemaRecordChangedEventArgs Properties

The SchemaRecordChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Count | Number of rows that changed (starting from DataIndex).
Public property | DataIndex | Data index that has changed.
Top
See Also

Reference

SchemaRecordChangedEventArgs Class
VisualComponents.Create3D Namespace


SchemaRecordChangedEventArgs.Count Property

SchemaRecordChangedEventArgsCount Property

Number of rows that changed (starting from DataIndex).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Count { get; }
public:
property int Count {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

SchemaRecordChangedEventArgs Class
VisualComponents.Create3D Namespace


SchemaRecordChangedEventArgs.DataIndex Property

SchemaRecordChangedEventArgsDataIndex Property

Data index that has changed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int DataIndex { get; }
public:
property int DataIndex {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

SchemaRecordChangedEventArgs Class
VisualComponents.Create3D Namespace


SchemaRecordChangedEventArgs Methods

The SchemaRecordChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SchemaRecordChangedEventArgs Class
VisualComponents.Create3D Namespace


SchemaValueChangedEventArgs Class

Provides data for SchemaValueChanged.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DSchemaValueChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SchemaValueChangedEventArgs : EventArgs
public ref class SchemaValueChangedEventArgs : public EventArgs

The SchemaValueChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SchemaValueChangedEventArgs | Initializes a new instance of SchemaValueChangedEventArgs.
Top
Properties
 | Name | Description
Public property | DataIndex | Data index that has changed.
Public property | NewValue | The value of the cell after the change.
Public property | OldValue | The value of the cell before the change.
Public property | SchemaPropertyIndex | Property index.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


SchemaValueChangedEventArgs Constructor

Initializes a new instance of SchemaValueChangedEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SchemaValueChangedEventArgs(
    int dataIndex,
    int schemaIndex,
    Object oldValue,
    Object newValue
)
public:
SchemaValueChangedEventArgs(
    int dataIndex,
    int schemaIndex,
    Object^ oldValue,
    Object^ newValue
)

Parameters

dataIndex
Type: SystemInt32
Data index.
schemaIndex
Type: SystemInt32
Schema index.
oldValue
Type: SystemObject
Old value (before change).
newValue
Type: SystemObject
New value (after change).
See Also

Reference

SchemaValueChangedEventArgs Class
VisualComponents.Create3D Namespace


SchemaValueChangedEventArgs Properties

The SchemaValueChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | DataIndex | Data index that has changed.
Public property | NewValue | The value of the cell after the change.
Public property | OldValue | The value of the cell before the change.
Public property | SchemaPropertyIndex | Property index.
Top
See Also

Reference

SchemaValueChangedEventArgs Class
VisualComponents.Create3D Namespace


SchemaValueChangedEventArgs.DataIndex Property

SchemaValueChangedEventArgsDataIndex Property

Data index that has changed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int DataIndex { get; }
public:
property int DataIndex {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

SchemaValueChangedEventArgs Class
VisualComponents.Create3D Namespace


SchemaValueChangedEventArgs.NewValue Property

SchemaValueChangedEventArgsNewValue Property

The value of the cell after the change.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object NewValue { get; }
public:
property Object^ NewValue {
    Object^ get ();
}

Property Value

Type: Object
See Also

Reference

SchemaValueChangedEventArgs Class
VisualComponents.Create3D Namespace


SchemaValueChangedEventArgs.OldValue Property

SchemaValueChangedEventArgsOldValue Property

The value of the cell before the change.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object OldValue { get; }
public:
property Object^ OldValue {
    Object^ get ();
}

Property Value

Type: Object
See Also

Reference

SchemaValueChangedEventArgs Class
VisualComponents.Create3D Namespace


SchemaValueChangedEventArgs.SchemaPropertyIndex Property

SchemaValueChangedEventArgsSchemaPropertyIndex Property

Property index.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int SchemaPropertyIndex { get; }
public:
property int SchemaPropertyIndex {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

SchemaValueChangedEventArgs Class
VisualComponents.Create3D Namespace


SchemaValueChangedEventArgs Methods

The SchemaValueChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SchemaValueChangedEventArgs Class
VisualComponents.Create3D Namespace


ScopeExecutedEventArgs Class

Provides data for ScopeExecuted event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DScopeExecutedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ScopeExecutedEventArgs : EventArgs
public ref class ScopeExecutedEventArgs : public EventArgs

The ScopeExecutedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ScopeExecutedEventArgs | Initializes a new instance of ScopeExecutedEventArgs.
Top
Properties
 | Name | Description
Public property | Executor | Gets the instance of IExecutor that executed this scope.
Public property | IsImmediate | Defines if the scope was executed in immediate mode.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ScopeExecutedEventArgs Constructor

Initializes a new instance of ScopeExecutedEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ScopeExecutedEventArgs(
    IExecutor executor,
    bool isImmediate
)
public:
ScopeExecutedEventArgs(
    IExecutor^ executor,
    bool isImmediate
)

Parameters

executor
Type: VisualComponents.Create3DIExecutor
Executor.
isImmediate
Type: SystemBoolean
True if executed in immediate mode.
See Also

Reference

ScopeExecutedEventArgs Class
VisualComponents.Create3D Namespace


ScopeExecutedEventArgs Properties

The ScopeExecutedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Executor | Gets the instance of IExecutor that executed this scope.
Public property | IsImmediate | Defines if the scope was executed in immediate mode.
Top
See Also

Reference

ScopeExecutedEventArgs Class
VisualComponents.Create3D Namespace


ScopeExecutedEventArgs.Executor Property

ScopeExecutedEventArgsExecutor Property

Gets the instance of IExecutor that executed this scope.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IExecutor Executor { get; set; }
public:
property IExecutor^ Executor {
    IExecutor^ get ();
    void set (IExecutor^ value);
}

Property Value

Type: IExecutor
See Also

Reference

ScopeExecutedEventArgs Class
VisualComponents.Create3D Namespace


ScopeExecutedEventArgs.IsImmediate Property

ScopeExecutedEventArgsIsImmediate Property

Defines if the scope was executed in immediate mode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsImmediate { get; set; }
public:
property bool IsImmediate {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ScopeExecutedEventArgs Class
VisualComponents.Create3D Namespace


ScopeExecutedEventArgs Methods

The ScopeExecutedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ScopeExecutedEventArgs Class
VisualComponents.Create3D Namespace


SecondarySnapResult Class

Class used to save secondary snap results, such as arc centers and bound box corners.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DSecondarySnapResult

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SecondarySnapResult
public ref class SecondarySnapResult

The SecondarySnapResult type exposes the following members.

Constructors
 | Name | Description
Public method | SecondarySnapResult | Initializes a new instance of the SecondarySnapResult class
Top
Properties
 | Name | Description
Public property | CancelDistanceThreshold |
Public property | LastMinDistance | Used to save last distance to this result.
Public property | ScreenPosition | Used to save screen position of this result.
Public property | SecondarySnap |
Public property | SecondarySnapType |
Public property | Timestamp |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


SecondarySnapResult Constructor

Initializes a new instance of the SecondarySnapResult class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SecondarySnapResult()
public:
SecondarySnapResult()
See Also

Reference

SecondarySnapResult Class
VisualComponents.Create3D Namespace


SecondarySnapResult Properties

The SecondarySnapResult type exposes the following members.

Properties
 | Name | Description
Public property | CancelDistanceThreshold |
Public property | LastMinDistance | Used to save last distance to this result.
Public property | ScreenPosition | Used to save screen position of this result.
Public property | SecondarySnap |
Public property | SecondarySnapType |
Public property | Timestamp |
Top
See Also

Reference

SecondarySnapResult Class
VisualComponents.Create3D Namespace


SecondarySnapResult.CancelDistanceThreshold Property

SecondarySnapResultCancelDistanceThreshold Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double CancelDistanceThreshold { get; set; }
public:
property double CancelDistanceThreshold {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

SecondarySnapResult Class
VisualComponents.Create3D Namespace


SecondarySnapResult.LastMinDistance Property

SecondarySnapResultLastMinDistance Property

Used to save last distance to this result.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double LastMinDistance { get; set; }
public:
property double LastMinDistance {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

SecondarySnapResult Class
VisualComponents.Create3D Namespace


SecondarySnapResult.ScreenPosition Property

SecondarySnapResultScreenPosition Property

Used to save screen position of this result.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 ScreenPosition { get; set; }
public:
property Vector3 ScreenPosition {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

SecondarySnapResult Class
VisualComponents.Create3D Namespace


SecondarySnapResult.SecondarySnap Property

SecondarySnapResultSecondarySnap Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SnapResult SecondarySnap { get; set; }
public:
property SnapResult SecondarySnap {
    SnapResult get ();
    void set (SnapResult value);
}

Property Value

Type: SnapResult
See Also

Reference

SecondarySnapResult Class
VisualComponents.Create3D Namespace


SecondarySnapResult.SecondarySnapType Property

SecondarySnapResultSecondarySnapType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SnapType SecondarySnapType { get; set; }
public:
property SnapType SecondarySnapType {
    SnapType get ();
    void set (SnapType value);
}

Property Value

Type: SnapType
See Also

Reference

SecondarySnapResult Class
VisualComponents.Create3D Namespace


SecondarySnapResult.Timestamp Property

SecondarySnapResultTimestamp Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Timestamp { get; set; }
public:
property int Timestamp {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SecondarySnapResult Class
VisualComponents.Create3D Namespace


SecondarySnapResult Methods

The SecondarySnapResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SecondarySnapResult Class
VisualComponents.Create3D Namespace


SelectedRibbonTabChangedMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DSelectedRibbonTabChangedMessage

Namespace: VisualComponents.Create3D
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SelectedRibbonTabChangedMessage
public ref class SelectedRibbonTabChangedMessage

The SelectedRibbonTabChangedMessage type exposes the following members.

Constructors
 | Name | Description
Public method | SelectedRibbonTabChangedMessage | Initializes a new instance of the SelectedRibbonTabChangedMessage class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | TabName |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


SelectedRibbonTabChangedMessage Constructor

Initializes a new instance of the SelectedRibbonTabChangedMessage class

Namespace: VisualComponents.Create3D
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SelectedRibbonTabChangedMessage(
    string tabName
)
public:
SelectedRibbonTabChangedMessage(
    String^ tabName
)

Parameters

tabName
Type: SystemString
See Also

Reference

SelectedRibbonTabChangedMessage Class
VisualComponents.Create3D Namespace


SelectedRibbonTabChangedMessage Methods

The SelectedRibbonTabChangedMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SelectedRibbonTabChangedMessage Class
VisualComponents.Create3D Namespace


SelectedRibbonTabChangedMessage Fields

The SelectedRibbonTabChangedMessage type exposes the following members.

Fields
 | Name | Description
Public field | TabName |
Top
See Also

Reference

SelectedRibbonTabChangedMessage Class
VisualComponents.Create3D Namespace


SelectedRibbonTabChangedMessage.TabName Field

SelectedRibbonTabChangedMessageTabName Field

Namespace: VisualComponents.Create3D
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public readonly string TabName
public:
initonly String^ TabName

Field Value

Type: String
See Also

Reference

SelectedRibbonTabChangedMessage Class
VisualComponents.Create3D Namespace


SelectionChange Class

Represents a change of selection in ISelectionManager using complete "Before" and "After" selection sets.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DChange
VisualComponents.Create3DSelectionChange

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SelectionChange : Change
public ref class SelectionChange : public Change

The SelectionChange type exposes the following members.

Constructors
 | Name | Description
Public method | SelectionChange | Creates a new instance that uses the given selection manager.
Top
Properties
 | Name | Description
Protected property | Changeset | (Inherited from Change.)
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Protected property | TargetsList | Access to easier manipulation of targets in derived classes. (Inherited from Change.)
Top
Methods
 | Name | Description
Protected method | AddTarget | (Inherited from Change.)
Public method | Dispose | (Inherited from Change.)
Protected method | Dispose(Boolean) | Clears internal memory. This object is not usable after disposal. (Overrides ChangeDispose(Boolean).)
Protected method | DoRedo | Performs the redo action by setting the stored "After" state to the selection manager. (Overrides ChangeDoRedo.)
Protected method | DoUndo | Performs the undo action by setting the stored "Before" state to the selection manager. (Overrides ChangeDoUndo.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasValueChanged | Compares equality of the stored "Before" and "After" states. (Overrides ChangeHasValueChanged.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StoreAfterState | Saves the current selection as the "After" state that is used on redo.
Public method | StoreBeforeState | Saves the current selection as the "Before" state that is used on undo.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks
This approach doesn't work with selected object deletion.
See Also

Reference

VisualComponents.Create3D Namespace


SelectionChange Constructor

Creates a new instance that uses the given selection manager.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SelectionChange(
    ISelectionManager selectionManager
)
public:
SelectionChange(
    ISelectionManager^ selectionManager
)

Parameters

selectionManager
Type: VisualComponents.Create3DISelectionManager
See Also

Reference

SelectionChange Class
VisualComponents.Create3D Namespace


SelectionChange Properties

The SelectionChange type exposes the following members.

Properties
 | Name | Description
Protected property | Changeset | (Inherited from Change.)
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Protected property | TargetsList | Access to easier manipulation of targets in derived classes. (Inherited from Change.)
Top
See Also

Reference

SelectionChange Class
VisualComponents.Create3D Namespace


SelectionChange Methods

The SelectionChange type exposes the following members.

Methods
 | Name | Description
Protected method | AddTarget | (Inherited from Change.)
Public method | Dispose | (Inherited from Change.)
Protected method | Dispose(Boolean) | Clears internal memory. This object is not usable after disposal. (Overrides ChangeDispose(Boolean).)
Protected method | DoRedo | Performs the redo action by setting the stored "After" state to the selection manager. (Overrides ChangeDoRedo.)
Protected method | DoUndo | Performs the undo action by setting the stored "Before" state to the selection manager. (Overrides ChangeDoUndo.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasValueChanged | Compares equality of the stored "Before" and "After" states. (Overrides ChangeHasValueChanged.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StoreAfterState | Saves the current selection as the "After" state that is used on redo.
Public method | StoreBeforeState | Saves the current selection as the "Before" state that is used on undo.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SelectionChange Class
VisualComponents.Create3D Namespace


SelectionChange.Dispose Method

SelectionChangeDispose Method

Overload List
 | Name | Description
Public method | Dispose | (Inherited from Change.)
Protected method | Dispose(Boolean) | Clears internal memory. This object is not usable after disposal. (Overrides ChangeDispose(Boolean).)
Top
See Also

Reference

SelectionChange Class
VisualComponents.Create3D Namespace


SelectionChange.Dispose Method (Boolean)

SelectionChangeDispose Method (Boolean)

Clears internal memory. This object is not usable after disposal.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void Dispose(
    bool disposing
)
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

SelectionChange Class
Dispose Overload
VisualComponents.Create3D Namespace


SelectionChange.DoRedo Method

SelectionChangeDoRedo Method

Performs the redo action by setting the stored "After" state to the selection manager.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void DoRedo()
protected:
virtual void DoRedo() override
See Also

Reference

SelectionChange Class
VisualComponents.Create3D Namespace


SelectionChange.DoUndo Method

SelectionChangeDoUndo Method

Performs the undo action by setting the stored "Before" state to the selection manager.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void DoUndo()
protected:
virtual void DoUndo() override
See Also

Reference

SelectionChange Class
VisualComponents.Create3D Namespace


SelectionChange.HasValueChanged Method

SelectionChangeHasValueChanged Method

Compares equality of the stored "Before" and "After" states.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override bool HasValueChanged()
protected:
virtual bool HasValueChanged() override

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.SelectionChange.HasValueChanged"]

See Also

Reference

SelectionChange Class
VisualComponents.Create3D Namespace


SelectionChange.StoreAfterState Method

SelectionChangeStoreAfterState Method

Saves the current selection as the "After" state that is used on redo.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StoreAfterState()
public:
void StoreAfterState()
See Also

Reference

SelectionChange Class
VisualComponents.Create3D Namespace


SelectionChange.StoreBeforeState Method

SelectionChangeStoreBeforeState Method

Saves the current selection as the "Before" state that is used on undo.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StoreBeforeState()
public:
void StoreBeforeState()
See Also

Reference

SelectionChange Class
VisualComponents.Create3D Namespace


SelectionHighlightRequestMessage Class

Message that temporarely disables highlighting of features and nodes.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DSelectionHighlightRequestMessage

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SelectionHighlightRequestMessage
public ref class SelectionHighlightRequestMessage

The SelectionHighlightRequestMessage type exposes the following members.

Constructors
 | Name | Description
Public method | SelectionHighlightRequestMessage | Constructor.
Top
Properties
 | Name | Description
Public property | Highlight | Wheter to disable or restore highlighting.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks
Broadcasted by Material Assign action to override default highlighting.
See Also

Reference

VisualComponents.Create3D Namespace


SelectionHighlightRequestMessage Constructor

Constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SelectionHighlightRequestMessage(
    bool highlight
)
public:
SelectionHighlightRequestMessage(
    bool highlight
)

Parameters

highlight
Type: SystemBoolean
Wheter to disable or restore highlighting
See Also

Reference

SelectionHighlightRequestMessage Class
VisualComponents.Create3D Namespace


SelectionHighlightRequestMessage Properties

The SelectionHighlightRequestMessage type exposes the following members.

Properties
 | Name | Description
Public property | Highlight | Wheter to disable or restore highlighting.
Top
See Also

Reference

SelectionHighlightRequestMessage Class
VisualComponents.Create3D Namespace


SelectionHighlightRequestMessage.Highlight Property

SelectionHighlightRequestMessageHighlight Property

Wheter to disable or restore highlighting.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Highlight { get; set; }
public:
property bool Highlight {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SelectionHighlightRequestMessage Class
VisualComponents.Create3D Namespace


SelectionHighlightRequestMessage Methods

The SelectionHighlightRequestMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SelectionHighlightRequestMessage Class
VisualComponents.Create3D Namespace


SelectionTypes Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[FlagsAttribute]
public enum SelectionTypes
[FlagsAttribute]
public enum class SelectionTypes
Members
Member name | Value | Description
None | 0 |
Component | 1 |
Annotation | 2 |
Dimension | 4 |
DrawingView | 8 |
Statement | 16 |
PositionFrame | 32 |
RobotFrame | 64 |
Feature | 128 |
GeoSet | 256 |
Node | 512 |
SchemaPropertyList | 1024 |
AssemblyPatternSlotVisualization | 2048 |
AssemblyStepVisualization | 4096 |
See Also

Reference

VisualComponents.Create3D Namespace


SequenceAddedEventArgs Class

Provides data for SequenceAdded event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DSequenceAddedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SequenceAddedEventArgs : EventArgs
public ref class SequenceAddedEventArgs : public EventArgs

The SequenceAddedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SequenceAddedEventArgs | Creates a new instance of SequenceAddedEventArgs.
Top
Properties
 | Name | Description
Public property | Sequence | Sequence that has been added.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


SequenceAddedEventArgs Constructor

Creates a new instance of SequenceAddedEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SequenceAddedEventArgs(
    IProcessSequence sequence
)
public:
SequenceAddedEventArgs(
    IProcessSequence^ sequence
)

Parameters

sequence
Type: VisualComponents.Create3DIProcessSequence
Added sequence.
See Also

Reference

SequenceAddedEventArgs Class
VisualComponents.Create3D Namespace


SequenceAddedEventArgs Properties

The SequenceAddedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Sequence | Sequence that has been added.
Top
See Also

Reference

SequenceAddedEventArgs Class
VisualComponents.Create3D Namespace


SequenceAddedEventArgs.Sequence Property

SequenceAddedEventArgsSequence Property

Sequence that has been added.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProcessSequence Sequence { get; }
public:
property IProcessSequence^ Sequence {
    IProcessSequence^ get ();
}

Property Value

Type: IProcessSequence
See Also

Reference

SequenceAddedEventArgs Class
VisualComponents.Create3D Namespace


SequenceAddedEventArgs Methods

The SequenceAddedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SequenceAddedEventArgs Class
VisualComponents.Create3D Namespace


SequenceRemovingEventArgs Class

Provides data for SequenceRemoving event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DSequenceRemovingEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SequenceRemovingEventArgs : EventArgs
public ref class SequenceRemovingEventArgs : public EventArgs

The SequenceRemovingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SequenceRemovingEventArgs | Creates a new instance of SequenceRemovingEventArgs.
Top
Properties
 | Name | Description
Public property | Sequence | Sequence that is about to be removed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


SequenceRemovingEventArgs Constructor

Creates a new instance of SequenceRemovingEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SequenceRemovingEventArgs(
    IProcessSequence sequence
)
public:
SequenceRemovingEventArgs(
    IProcessSequence^ sequence
)

Parameters

sequence
Type: VisualComponents.Create3DIProcessSequence
Removing sequence.
See Also

Reference

SequenceRemovingEventArgs Class
VisualComponents.Create3D Namespace


SequenceRemovingEventArgs Properties

The SequenceRemovingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Sequence | Sequence that is about to be removed.
Top
See Also

Reference

SequenceRemovingEventArgs Class
VisualComponents.Create3D Namespace


SequenceRemovingEventArgs.Sequence Property

SequenceRemovingEventArgsSequence Property

Sequence that is about to be removed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProcessSequence Sequence { get; }
public:
property IProcessSequence^ Sequence {
    IProcessSequence^ get ();
}

Property Value

Type: IProcessSequence
See Also

Reference

SequenceRemovingEventArgs Class
VisualComponents.Create3D Namespace


SequenceRemovingEventArgs Methods

The SequenceRemovingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SequenceRemovingEventArgs Class
VisualComponents.Create3D Namespace


Serializer Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DSerializer

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class Serializer
public ref class Serializer abstract sealed

The Serializer type exposes the following members.

Methods
Name | Description
DeserializeT |
SerializeT |
Top
See Also

Reference

VisualComponents.Create3D Namespace


Serializer Methods

The Serializer type exposes the following members.

Methods
Name | Description
DeserializeT |
SerializeT |
Top
See Also

Reference

Serializer Class
VisualComponents.Create3D Namespace


Serializer.Deserialize(T) Method

SerializerDeserializeT Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static T Deserialize<T>(
    string input
)
where T : class

public:
generic<typename T>
where T : ref class
static T Deserialize(
    String^ input
)

Parameters

input
Type: SystemString

Type Parameters

T

Return Value

Type: T

[Missing <returns> documentation for "M:VisualComponents.Create3D.Serializer.Deserialize``1(System.String)"]

See Also

Reference

Serializer Class
VisualComponents.Create3D Namespace


Serializer.Serialize(T) Method

SerializerSerializeT Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string Serialize<T>(
    T objectToSerialize
)

public:
generic<typename T>
static String^ Serialize(
    T objectToSerialize
)

Parameters

objectToSerialize
Type: T

Type Parameters

T

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.Serializer.Serialize``1(``0)"]

See Also

Reference

Serializer Class
VisualComponents.Create3D Namespace


SetupPythonActionMessage Class

Signals a request to setup a managed command for executing a python/native command.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DSetupPythonActionMessage

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SetupPythonActionMessage : IDisposable
public ref class SetupPythonActionMessage : IDisposable

The SetupPythonActionMessage type exposes the following members.

Constructors
 | Name | Description
Public method | SetupPythonActionMessage | Initializes a new instance of the SetupPythonActionMessage class
Top
Properties
 | Name | Description
Public property | BaseBackColor | Background color. Used in ContextualTabGroup
Public property | CallingCommandName |
Public property | CommandName | Command name launched when this action is executed.
Public property | CommandType | This action can be used to execute either .NET commands or internal (python or native) commands.
Public property | ControlType | Control type.
Public property | IconPath |
Public property | PositionIndex |
Public property | Props |
Public property | ReferenceId |
Public property | ToolSizingMode |
Public property | ToolTipImage |
Public property | ToolTipText |
Public property | UXName | String used in the user interface.
Public property | UXSite | Identifies UXSite where where action is added.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the SetupPythonActionMessage
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the SetupPythonActionMessage and optionally releases the managed resources
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UxSiteType |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


SetupPythonActionMessage Constructor

Initializes a new instance of the SetupPythonActionMessage class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetupPythonActionMessage()
public:
SetupPythonActionMessage()
See Also

Reference

SetupPythonActionMessage Class
VisualComponents.Create3D Namespace


SetupPythonActionMessage Properties

The SetupPythonActionMessage type exposes the following members.

Properties
 | Name | Description
Public property | BaseBackColor | Background color. Used in ContextualTabGroup
Public property | CallingCommandName |
Public property | CommandName | Command name launched when this action is executed.
Public property | CommandType | This action can be used to execute either .NET commands or internal (python or native) commands.
Public property | ControlType | Control type.
Public property | IconPath |
Public property | PositionIndex |
Public property | Props |
Public property | ReferenceId |
Public property | ToolSizingMode |
Public property | ToolTipImage |
Public property | ToolTipText |
Public property | UXName | String used in the user interface.
Public property | UXSite | Identifies UXSite where where action is added.
Top
See Also

Reference

SetupPythonActionMessage Class
VisualComponents.Create3D Namespace


SetupPythonActionMessage.BaseBackColor Property

SetupPythonActionMessageBaseBackColor Property

Background color. Used in ContextualTabGroup

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string BaseBackColor { get; set; }
public:
property String^ BaseBackColor {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SetupPythonActionMessage Class
VisualComponents.Create3D Namespace


SetupPythonActionMessage.CallingCommandName Property

SetupPythonActionMessageCallingCommandName Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CallingCommandName { get; set; }
public:
property String^ CallingCommandName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SetupPythonActionMessage Class
VisualComponents.Create3D Namespace


SetupPythonActionMessage.CommandName Property

SetupPythonActionMessageCommandName Property

Command name launched when this action is executed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CommandName { get; set; }
public:
property String^ CommandName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SetupPythonActionMessage Class
VisualComponents.Create3D Namespace


SetupPythonActionMessage.CommandType Property

SetupPythonActionMessageCommandType Property

This action can be used to execute either .NET commands or internal (python or native) commands.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PythonActionCommandType CommandType { get; set; }
public:
property PythonActionCommandType CommandType {
    PythonActionCommandType get ();
    void set (PythonActionCommandType value);
}

Property Value

Type: PythonActionCommandType
See Also

Reference

SetupPythonActionMessage Class
VisualComponents.Create3D Namespace


SetupPythonActionMessage.ControlType Property

SetupPythonActionMessageControlType Property

Control type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ControlType { get; set; }
public:
property String^ ControlType {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SetupPythonActionMessage Class
VisualComponents.Create3D Namespace


SetupPythonActionMessage.IconPath Property

SetupPythonActionMessageIconPath Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string IconPath { get; set; }
public:
property String^ IconPath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SetupPythonActionMessage Class
VisualComponents.Create3D Namespace


SetupPythonActionMessage.PositionIndex Property

SetupPythonActionMessagePositionIndex Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int PositionIndex { get; set; }
public:
property int PositionIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SetupPythonActionMessage Class
VisualComponents.Create3D Namespace


SetupPythonActionMessage.Props Property

SetupPythonActionMessageProps Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyCollection Props { get; }
public:
property PropertyCollection^ Props {
    PropertyCollection^ get ();
}

Property Value

Type: PropertyCollection
See Also

Reference

SetupPythonActionMessage Class
VisualComponents.Create3D Namespace


SetupPythonActionMessage.ReferenceId Property

SetupPythonActionMessageReferenceId Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ReferenceId { get; set; }
public:
property String^ ReferenceId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SetupPythonActionMessage Class
VisualComponents.Create3D Namespace


SetupPythonActionMessage.ToolSizingMode Property

SetupPythonActionMessageToolSizingMode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ToolSizingMode { get; set; }
public:
property String^ ToolSizingMode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SetupPythonActionMessage Class
VisualComponents.Create3D Namespace


SetupPythonActionMessage.ToolTipImage Property

SetupPythonActionMessageToolTipImage Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ToolTipImage { get; set; }
public:
property String^ ToolTipImage {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SetupPythonActionMessage Class
VisualComponents.Create3D Namespace


SetupPythonActionMessage.ToolTipText Property

SetupPythonActionMessageToolTipText Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ToolTipText { get; set; }
public:
property String^ ToolTipText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SetupPythonActionMessage Class
VisualComponents.Create3D Namespace


SetupPythonActionMessage.UXName Property

SetupPythonActionMessageUXName Property

String used in the user interface.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string UXName { get; set; }
public:
property String^ UXName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SetupPythonActionMessage Class
VisualComponents.Create3D Namespace


SetupPythonActionMessage.UXSite Property

SetupPythonActionMessageUXSite Property

Identifies UXSite where where action is added.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string UXSite { get; set; }
public:
property String^ UXSite {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SetupPythonActionMessage Class
VisualComponents.Create3D Namespace


SetupPythonActionMessage Methods

The SetupPythonActionMessage type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UxSiteType |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SetupPythonActionMessage Class
VisualComponents.Create3D Namespace


SetupPythonActionMessage.Dispose Method

SetupPythonActionMessageDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the SetupPythonActionMessage
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the SetupPythonActionMessage and optionally releases the managed resources
Top
See Also

Reference

SetupPythonActionMessage Class
VisualComponents.Create3D Namespace


SetupPythonActionMessage.Dispose Method

SetupPythonActionMessageDispose Method

Releases all resources used by the SetupPythonActionMessage

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Dispose()
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

SetupPythonActionMessage Class
Dispose Overload
VisualComponents.Create3D Namespace


SetupPythonActionMessage.Dispose Method (Boolean)

SetupPythonActionMessageDispose Method (Boolean)

Releases the unmanaged resources used by the SetupPythonActionMessage and optionally releases the managed resources

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void Dispose(
    bool disposing
)
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

SetupPythonActionMessage Class
Dispose Overload
VisualComponents.Create3D Namespace


SetupPythonActionMessage.UxSiteType Method

SetupPythonActionMessageUxSiteType Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string UxSiteType()
public:
String^ UxSiteType()

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.SetupPythonActionMessage.UxSiteType"]

See Also

Reference

SetupPythonActionMessage Class
VisualComponents.Create3D Namespace


SignalMapSignalValueChangedEventArgs Class

Contains data for SignalValueChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DSignalMapSignalValueChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SignalMapSignalValueChangedEventArgs : EventArgs
public ref class SignalMapSignalValueChangedEventArgs : public EventArgs

The SignalMapSignalValueChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SignalMapSignalValueChangedEventArgs | Initializes a new instance of SignalMapSignalValueChangedEventArgs.
Top
Properties
 | Name | Description
Public property | Port | Gets the index of the signal map port whose value changed.
Public property | SignalValue | Gets the current value of the signal map port.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


SignalMapSignalValueChangedEventArgs Constructor

Initializes a new instance of SignalMapSignalValueChangedEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SignalMapSignalValueChangedEventArgs(
    int port,
    Object signalValue
)
public:
SignalMapSignalValueChangedEventArgs(
    int port,
    Object^ signalValue
)

Parameters

port
Type: SystemInt32
Signal map port index.
signalValue
Type: SystemObject
Signal map port current value.
See Also

Reference

SignalMapSignalValueChangedEventArgs Class
VisualComponents.Create3D Namespace


SignalMapSignalValueChangedEventArgs Properties

The SignalMapSignalValueChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Port | Gets the index of the signal map port whose value changed.
Public property | SignalValue | Gets the current value of the signal map port.
Top
See Also

Reference

SignalMapSignalValueChangedEventArgs Class
VisualComponents.Create3D Namespace


SignalMapSignalValueChangedEventArgs.Port Property

SignalMapSignalValueChangedEventArgsPort Property

Gets the index of the signal map port whose value changed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Port { get; }
public:
property int Port {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

SignalMapSignalValueChangedEventArgs Class
VisualComponents.Create3D Namespace


SignalMapSignalValueChangedEventArgs.SignalValue Property

SignalMapSignalValueChangedEventArgsSignalValue Property

Gets the current value of the signal map port.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object SignalValue { get; }
public:
property Object^ SignalValue {
    Object^ get ();
}

Property Value

Type: Object
See Also

Reference

SignalMapSignalValueChangedEventArgs Class
VisualComponents.Create3D Namespace


SignalMapSignalValueChangedEventArgs Methods

The SignalMapSignalValueChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SignalMapSignalValueChangedEventArgs Class
VisualComponents.Create3D Namespace


SignalTriggerEventArgs Class

Provides the data for SignalTrigger event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DSignalTriggerEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SignalTriggerEventArgs : EventArgs
public ref class SignalTriggerEventArgs : public EventArgs

The SignalTriggerEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SignalTriggerEventArgs | Initializes a new instance of the SignalTriggerEventArgs class.
Top
Properties
 | Name | Description
Public property | Signal | Gets the signal whose value is changing.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


SignalTriggerEventArgs Constructor

Initializes a new instance of the SignalTriggerEventArgs class.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SignalTriggerEventArgs(
    ISignal signal
)
public:
SignalTriggerEventArgs(
    ISignal^ signal
)

Parameters

signal
Type: VisualComponents.Create3DISignal
Signal whose value is changing.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when signal parameter is null.
See Also

Reference

SignalTriggerEventArgs Class
VisualComponents.Create3D Namespace


SignalTriggerEventArgs Properties

The SignalTriggerEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Signal | Gets the signal whose value is changing.
Top
See Also

Reference

SignalTriggerEventArgs Class
VisualComponents.Create3D Namespace


SignalTriggerEventArgs.Signal Property

SignalTriggerEventArgsSignal Property

Gets the signal whose value is changing.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISignal Signal { get; }
public:
property ISignal^ Signal {
    ISignal^ get ();
}

Property Value

Type: ISignal
See Also

Reference

SignalTriggerEventArgs Class
VisualComponents.Create3D Namespace


SignalTriggerEventArgs Methods

The SignalTriggerEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SignalTriggerEventArgs Class
VisualComponents.Create3D Namespace


SimEventSchedulingOrder Enumeration

Options for user event execution order in simulation scheduler relative to other events scheduled at the same simulation time.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum SimEventSchedulingOrder
public enum class SimEventSchedulingOrder
Members
Member name | Value | Description
InSchedulingOrder | 0 | Default ordering. Executed after all immediate events and in order of scheduling.
See Also

Reference

VisualComponents.Create3D Namespace


SimInterfaceConnectionChange Class

Stores SimInterface state changes.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DChange
VisualComponents.Create3DSimInterfaceConnectionChange

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class SimInterfaceConnectionChange : Change
public ref class SimInterfaceConnectionChange sealed : public Change

The SimInterfaceConnectionChange type exposes the following members.

Constructors
 | Name | Description
Public method | SimInterfaceConnectionChange(IEnumerableISimComponent) | Initializes a new instance of SimInterfaceConnectionChange.
Public method | SimInterfaceConnectionChange(IEnumerableISimComponent, PlugStatus) | Obsolete. Obsolete. Use SimInterfaceConnectionChange(IEnumerableISimComponent) instead.
Top
Properties
 | Name | Description
Public property | BeginStatus | Obsolete. Obsolete.
Public property | EndStatus | Obsolete. Obsolete.
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from Change.)
Public method | DoDisconnectConnect |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ListenForDisconnectConnect | In some cases, components connected to a path will disconnect-connect their interfaces when changing it's position along the path. This method will make this changeset to record those actions.
Public method | StopListenForDisconnectConnect | Method should be call if ListenForDisconnectConnect() is previously called. UndoService will call this method when added to the stack
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


SimInterfaceConnectionChange Constructor

Overload List
 | Name | Description
Public method | SimInterfaceConnectionChange(IEnumerableISimComponent) | Initializes a new instance of SimInterfaceConnectionChange.
Public method | SimInterfaceConnectionChange(IEnumerableISimComponent, PlugStatus) | Obsolete. Obsolete. Use SimInterfaceConnectionChange(IEnumerableISimComponent) instead.
Top
See Also

Reference

SimInterfaceConnectionChange Class
VisualComponents.Create3D Namespace


SimInterfaceConnectionChange Constructor (IEnumerable(ISimComponent))

SimInterfaceConnectionChange Constructor (IEnumerableISimComponent)

Initializes a new instance of SimInterfaceConnectionChange.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SimInterfaceConnectionChange(
    IEnumerable<ISimComponent> targets
)
public:
SimInterfaceConnectionChange(
    IEnumerable<ISimComponent^>^ targets
)

Parameters

targets
Type: System.Collections.GenericIEnumerableISimComponent
Target objects for this change.
See Also

Reference

SimInterfaceConnectionChange Class
SimInterfaceConnectionChange Overload
VisualComponents.Create3D Namespace


SimInterfaceConnectionChange Constructor (IEnumerable(ISimComponent), PlugStatus)

SimInterfaceConnectionChange Constructor (IEnumerableISimComponent, PlugStatus)

Note: This API is now obsolete.

Obsolete. Use SimInterfaceConnectionChange(IEnumerableISimComponent) instead.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("beginStatus is obsolete. Use constructor SimInterfaceConnectionChange(IEnumerable<ISimComponent> targets) instead. ")]
public SimInterfaceConnectionChange(
    IEnumerable<ISimComponent> targets,
    PlugStatus beginStatus
)
public:
[ObsoleteAttribute(L"beginStatus is obsolete. Use constructor SimInterfaceConnectionChange(IEnumerable<ISimComponent> targets) instead. ")]
SimInterfaceConnectionChange(
    IEnumerable<ISimComponent^>^ targets,
    PlugStatus beginStatus
)

Parameters

targets
Type: System.Collections.GenericIEnumerableISimComponent
Obsolete.
beginStatus
Type: VisualComponents.Create3DPlugStatus
Obsolete.
See Also

Reference

SimInterfaceConnectionChange Class
SimInterfaceConnectionChange Overload
VisualComponents.Create3D Namespace


SimInterfaceConnectionChange Properties

The SimInterfaceConnectionChange type exposes the following members.

Properties
 | Name | Description
Public property | BeginStatus | Obsolete. Obsolete.
Public property | EndStatus | Obsolete. Obsolete.
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Top
See Also

Reference

SimInterfaceConnectionChange Class
VisualComponents.Create3D Namespace


SimInterfaceConnectionChange.BeginStatus Property

SimInterfaceConnectionChangeBeginStatus Property

Note: This API is now obsolete.

Obsolete.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Not used anymore.")]
public PlugStatus BeginStatus { get; set; }
public:
[ObsoleteAttribute(L"Not used anymore.")]
property PlugStatus BeginStatus {
    PlugStatus get ();
    void set (PlugStatus value);
}

Property Value

Type: PlugStatus
See Also

Reference

SimInterfaceConnectionChange Class
VisualComponents.Create3D Namespace


SimInterfaceConnectionChange.EndStatus Property

SimInterfaceConnectionChangeEndStatus Property

Note: This API is now obsolete.

Obsolete.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Not used anymore.")]
public PlugStatus EndStatus { get; set; }
public:
[ObsoleteAttribute(L"Not used anymore.")]
property PlugStatus EndStatus {
    PlugStatus get ();
    void set (PlugStatus value);
}

Property Value

Type: PlugStatus
See Also

Reference

SimInterfaceConnectionChange Class
VisualComponents.Create3D Namespace


SimInterfaceConnectionChange Methods

The SimInterfaceConnectionChange type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from Change.)
Public method | DoDisconnectConnect |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ListenForDisconnectConnect | In some cases, components connected to a path will disconnect-connect their interfaces when changing it's position along the path. This method will make this changeset to record those actions.
Public method | StopListenForDisconnectConnect | Method should be call if ListenForDisconnectConnect() is previously called. UndoService will call this method when added to the stack
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SimInterfaceConnectionChange Class
VisualComponents.Create3D Namespace


SimInterfaceConnectionChange.DoDisconnectConnect Method

SimInterfaceConnectionChangeDoDisconnectConnect Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void DoDisconnectConnect()
public:
void DoDisconnectConnect()
See Also

Reference

SimInterfaceConnectionChange Class
VisualComponents.Create3D Namespace


SimInterfaceConnectionChange.ListenForDisconnectConnect Method

SimInterfaceConnectionChangeListenForDisconnectConnect Method

In some cases, components connected to a path will disconnect-connect their interfaces when changing it's position along the path. This method will make this changeset to record those actions.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ListenForDisconnectConnect()
public:
void ListenForDisconnectConnect()
See Also

Reference

SimInterfaceConnectionChange Class
VisualComponents.Create3D Namespace


SimInterfaceConnectionChange.StopListenForDisconnectConnect Method

SimInterfaceConnectionChangeStopListenForDisconnectConnect Method

Method should be call if ListenForDisconnectConnect() is previously called. UndoService will call this method when added to the stack

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StopListenForDisconnectConnect()
public:
void StopListenForDisconnectConnect()
See Also

Reference

SimInterfaceConnectionChange Class
VisualComponents.Create3D Namespace


SimInterfaceFieldType Enumeration

Interface field types.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum SimInterfaceFieldType
public enum class SimInterfaceFieldType
Members
Member name | Value | Description
Unknown | 0 | Unknown type
Action | 1 | ISimInterfaceActionField field.
BaseExport | 2 | ISimInterfaceBaseExportField field.
Flow | 3 | ISimInterfaceFlowField field.
Hierarchy | 4 | ISimInterfaceHierarchyField field.
IntegerCompatibility | 5 | ISimInterfaceIntegerCompatibilityField field.
JointExport | 6 | ISimInterfaceJointExportField field.
Processor | 7 | ISimInterfaceProcessorField field.
Rsl | 8 | ISimInterfaceRSLField field.
Signal | 9 | ISimInterfaceSignalField field.
ToolExport | 10 | ISimInterfaceToolExportField field.
Transport | 11 | ISimInterfaceTransportField field.
Attachment | 12 | ISimInterfaceAttachmentField field.
Remarks
These correspond to classes inheriting from ISimInterfaceField interface.
See Also

Reference

VisualComponents.Create3D Namespace


SimplifiedGeometryType Enumeration

Type of simplification.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum SimplifiedGeometryType
public enum class SimplifiedGeometryType
Members
Member name | Value | Description
SimplifiedCylinder | 0 | Simplify to a cylinder.
SimplifiedBlock | 1 | Simplify to a cube.
See Also

Reference

VisualComponents.Create3D Namespace


SimSignalConnectionChange Class

Stores Undo/Redo information for signal connections done in the signal connection editor.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DChange
VisualComponents.Create3DSimSignalConnectionChange

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class SimSignalConnectionChange : Change
public ref class SimSignalConnectionChange sealed : public Change

The SimSignalConnectionChange type exposes the following members.

Constructors
 | Name | Description
Public method | SimSignalConnectionChange | Any kind of change can be supplied as parameter, but now we only Undo and Redo connections between the signals.
Top
Properties
 | Name | Description
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from Change.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
RedoRequest |
UndoRequest |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


SimSignalConnectionChange Constructor

Any kind of change can be supplied as parameter, but now we only Undo and Redo connections between the signals.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SimSignalConnectionChange(
    Object change,
    IApplication application
)
public:
SimSignalConnectionChange(
    Object^ change,
    IApplication^ application
)

Parameters

change
Type: SystemObject
application
Type: VisualComponents.Create3DIApplication
See Also

Reference

SimSignalConnectionChange Class
VisualComponents.Create3D Namespace


SimSignalConnectionChange Properties

The SimSignalConnectionChange type exposes the following members.

Properties
 | Name | Description
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Top
See Also

Reference

SimSignalConnectionChange Class
VisualComponents.Create3D Namespace


SimSignalConnectionChange Methods

The SimSignalConnectionChange type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from Change.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SimSignalConnectionChange Class
VisualComponents.Create3D Namespace


SimSignalConnectionChange Fields

The SimSignalConnectionChange type exposes the following members.

Fields
Name | Description
RedoRequest |
UndoRequest |
Top
See Also

Reference

SimSignalConnectionChange Class
VisualComponents.Create3D Namespace


SimSignalConnectionChange.RedoRequest Field

SimSignalConnectionChangeRedoRequest Field

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static EventHandler<Object> RedoRequest
public:
static EventHandler<Object^>^ RedoRequest

Field Value

Type: EventHandlerObject
See Also

Reference

SimSignalConnectionChange Class
VisualComponents.Create3D Namespace


SimSignalConnectionChange.UndoRequest Field

SimSignalConnectionChangeUndoRequest Field

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static EventHandler<Object> UndoRequest
public:
static EventHandler<Object^>^ UndoRequest

Field Value

Type: EventHandlerObject
See Also

Reference

SimSignalConnectionChange Class
VisualComponents.Create3D Namespace


SimulationLevel Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum SimulationLevel
public enum class SimulationLevel
Members
Member name | Value | Description
Default | -1 |
Detailed | 0 |
Balanced | 1 |
Fast | 2 |
See Also

Reference

VisualComponents.Create3D Namespace


SimulationRunTimeChangedEventArgs Class

Contains event data for RunTimeChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DSimulationRunTimeChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SimulationRunTimeChangedEventArgs : EventArgs
public ref class SimulationRunTimeChangedEventArgs : public EventArgs

The SimulationRunTimeChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SimulationRunTimeChangedEventArgs | Initializes a new instance of RunTimeChanged event.
Public method | SimulationRunTimeChangedEventArgs(Double) | Initializes a new instance of RunTimeChanged event.
Top
Properties
 | Name | Description
Public property | Value | Gets the new simulation run time.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


SimulationRunTimeChangedEventArgs Constructor

Overload List
 | Name | Description
Public method | SimulationRunTimeChangedEventArgs | Initializes a new instance of RunTimeChanged event.
Public method | SimulationRunTimeChangedEventArgs(Double) | Initializes a new instance of RunTimeChanged event.
Top
See Also

Reference

SimulationRunTimeChangedEventArgs Class
VisualComponents.Create3D Namespace


SimulationRunTimeChangedEventArgs Constructor

Initializes a new instance of RunTimeChanged event.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SimulationRunTimeChangedEventArgs()
public:
SimulationRunTimeChangedEventArgs()
See Also

Reference

SimulationRunTimeChangedEventArgs Class
SimulationRunTimeChangedEventArgs Overload
VisualComponents.Create3D Namespace


SimulationRunTimeChangedEventArgs Constructor (Double)

Initializes a new instance of RunTimeChanged event.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SimulationRunTimeChangedEventArgs(
    double time
)
public:
SimulationRunTimeChangedEventArgs(
    double time
)

Parameters

time
Type: SystemDouble
See Also

Reference

SimulationRunTimeChangedEventArgs Class
SimulationRunTimeChangedEventArgs Overload
VisualComponents.Create3D Namespace


SimulationRunTimeChangedEventArgs Properties

The SimulationRunTimeChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets the new simulation run time.
Top
See Also

Reference

SimulationRunTimeChangedEventArgs Class
VisualComponents.Create3D Namespace


SimulationRunTimeChangedEventArgs.Value Property

SimulationRunTimeChangedEventArgsValue Property

Gets the new simulation run time.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Value { get; }
public:
property double Value {
    double get ();
}

Property Value

Type: Double
See Also

Reference

SimulationRunTimeChangedEventArgs Class
VisualComponents.Create3D Namespace


SimulationRunTimeChangedEventArgs Methods

The SimulationRunTimeChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SimulationRunTimeChangedEventArgs Class
VisualComponents.Create3D Namespace


SimulationSpeedFactorChangedEventArgs Class

Contains event data for SpeedFactorChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DSimulationSpeedFactorChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SimulationSpeedFactorChangedEventArgs : EventArgs
public ref class SimulationSpeedFactorChangedEventArgs : public EventArgs

The SimulationSpeedFactorChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SimulationSpeedFactorChangedEventArgs | Initializes a new instance of SpeedFactorChanged event.
Public method | SimulationSpeedFactorChangedEventArgs(Double) | Initializes a new instance of SpeedFactorChanged event.
Top
Properties
 | Name | Description
Public property | Value | Gets the new simulation speed factor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


SimulationSpeedFactorChangedEventArgs Constructor

Overload List
 | Name | Description
Public method | SimulationSpeedFactorChangedEventArgs | Initializes a new instance of SpeedFactorChanged event.
Public method | SimulationSpeedFactorChangedEventArgs(Double) | Initializes a new instance of SpeedFactorChanged event.
Top
See Also

Reference

SimulationSpeedFactorChangedEventArgs Class
VisualComponents.Create3D Namespace


SimulationSpeedFactorChangedEventArgs Constructor

Initializes a new instance of SpeedFactorChanged event.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SimulationSpeedFactorChangedEventArgs()
public:
SimulationSpeedFactorChangedEventArgs()
See Also

Reference

SimulationSpeedFactorChangedEventArgs Class
SimulationSpeedFactorChangedEventArgs Overload
VisualComponents.Create3D Namespace


SimulationSpeedFactorChangedEventArgs Constructor (Double)

Initializes a new instance of SpeedFactorChanged event.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SimulationSpeedFactorChangedEventArgs(
    double factor
)
public:
SimulationSpeedFactorChangedEventArgs(
    double factor
)

Parameters

factor
Type: SystemDouble
See Also

Reference

SimulationSpeedFactorChangedEventArgs Class
SimulationSpeedFactorChangedEventArgs Overload
VisualComponents.Create3D Namespace


SimulationSpeedFactorChangedEventArgs Properties

The SimulationSpeedFactorChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets the new simulation speed factor.
Top
See Also

Reference

SimulationSpeedFactorChangedEventArgs Class
VisualComponents.Create3D Namespace


SimulationSpeedFactorChangedEventArgs.Value Property

SimulationSpeedFactorChangedEventArgsValue Property

Gets the new simulation speed factor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Value { get; }
public:
property double Value {
    double get ();
}

Property Value

Type: Double
See Also

Reference

SimulationSpeedFactorChangedEventArgs Class
VisualComponents.Create3D Namespace


SimulationSpeedFactorChangedEventArgs Methods

The SimulationSpeedFactorChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SimulationSpeedFactorChangedEventArgs Class
VisualComponents.Create3D Namespace


SimulationState Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum SimulationState
public enum class SimulationState
Members
Member name | Value | Description
Unknown | 0 |
Stop | 1 |
Halt | 2 |
Clock | 3 |
Sync | 4 |
Animation | 5 |
ResetScheduled | 6 |
WaitExternal | 7 |
See Also

Reference

VisualComponents.Create3D Namespace


SimulationTimeCallback Delegate

Delegate type for scheduled simulation callbacks.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public delegate void SimulationTimeCallback(
    double simulationTime
)
public delegate void SimulationTimeCallback(
    double simulationTime
)

Parameters

simulationTime
Type: SystemDouble
See Also

Reference

VisualComponents.Create3D Namespace


SimulationTimeMode Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum SimulationTimeMode
public enum class SimulationTimeMode
Members
Member name | Value | Description
RealTime | 0 |
VirtualTime | 1 |
See Also

Reference

VisualComponents.Create3D Namespace


SimulationTimeModeChangedEventArgs Class

Contains event data for VisualComponents.Create3D.ISimulation.SpeedFactorChanged event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DSimulationTimeModeChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SimulationTimeModeChangedEventArgs : EventArgs
public ref class SimulationTimeModeChangedEventArgs : public EventArgs

The SimulationTimeModeChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SimulationTimeModeChangedEventArgs | Initializes a new instance of the SimulationTimeModeChangedEventArgs class
Public method | SimulationTimeModeChangedEventArgs(SimulationTimeMode) | Initializes a new instance of the SimulationTimeModeChangedEventArgs class
Top
Properties
 | Name | Description
Public property | Value | New speed factor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


SimulationTimeModeChangedEventArgs Constructor

Overload List
 | Name | Description
Public method | SimulationTimeModeChangedEventArgs | Initializes a new instance of the SimulationTimeModeChangedEventArgs class
Public method | SimulationTimeModeChangedEventArgs(SimulationTimeMode) | Initializes a new instance of the SimulationTimeModeChangedEventArgs class
Top
See Also

Reference

SimulationTimeModeChangedEventArgs Class
VisualComponents.Create3D Namespace


SimulationTimeModeChangedEventArgs Constructor

Initializes a new instance of the SimulationTimeModeChangedEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SimulationTimeModeChangedEventArgs()
public:
SimulationTimeModeChangedEventArgs()
See Also

Reference

SimulationTimeModeChangedEventArgs Class
SimulationTimeModeChangedEventArgs Overload
VisualComponents.Create3D Namespace


SimulationTimeModeChangedEventArgs Constructor (SimulationTimeMode)

Initializes a new instance of the SimulationTimeModeChangedEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SimulationTimeModeChangedEventArgs(
    SimulationTimeMode isRealTime
)
public:
SimulationTimeModeChangedEventArgs(
    SimulationTimeMode isRealTime
)

Parameters

isRealTime
Type: VisualComponents.Create3DSimulationTimeMode
See Also

Reference

SimulationTimeModeChangedEventArgs Class
SimulationTimeModeChangedEventArgs Overload
VisualComponents.Create3D Namespace


SimulationTimeModeChangedEventArgs Properties

The SimulationTimeModeChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Value | New speed factor
Top
See Also

Reference

SimulationTimeModeChangedEventArgs Class
VisualComponents.Create3D Namespace


SimulationTimeModeChangedEventArgs.Value Property

SimulationTimeModeChangedEventArgsValue Property

New speed factor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SimulationTimeMode Value { get; }
public:
property SimulationTimeMode Value {
    SimulationTimeMode get ();
}

Property Value

Type: SimulationTimeMode
See Also

Reference

SimulationTimeModeChangedEventArgs Class
VisualComponents.Create3D Namespace


SimulationTimeModeChangedEventArgs Methods

The SimulationTimeModeChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SimulationTimeModeChangedEventArgs Class
VisualComponents.Create3D Namespace


SnapOptionsContext Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DSnapOptionsContext

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class SnapOptionsContext
public ref class SnapOptionsContext abstract sealed

The SnapOptionsContext type exposes the following members.

Fields
Name | Description
CombinationSnap |
JogSnap |
NormalSnap |
PrimitiveSnap |
SliceSnap |
Top
See Also

Reference

VisualComponents.Create3D Namespace


SnapOptionsContext Fields

The SnapOptionsContext type exposes the following members.

Fields
Name | Description
CombinationSnap |
JogSnap |
NormalSnap |
PrimitiveSnap |
SliceSnap |
Top
See Also

Reference

SnapOptionsContext Class
VisualComponents.Create3D Namespace


SnapOptionsContext.CombinationSnap Field

SnapOptionsContextCombinationSnap Field

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string CombinationSnap = "CombinationSnap"
public:
literal String^ CombinationSnap = "CombinationSnap"

Field Value

Type: String
See Also

Reference

SnapOptionsContext Class
VisualComponents.Create3D Namespace


SnapOptionsContext.JogSnap Field

SnapOptionsContextJogSnap Field

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string JogSnap = "JogSnap"
public:
literal String^ JogSnap = "JogSnap"

Field Value

Type: String
See Also

Reference

SnapOptionsContext Class
VisualComponents.Create3D Namespace


SnapOptionsContext.NormalSnap Field

SnapOptionsContextNormalSnap Field

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string NormalSnap = "NormalSnap"
public:
literal String^ NormalSnap = "NormalSnap"

Field Value

Type: String
See Also

Reference

SnapOptionsContext Class
VisualComponents.Create3D Namespace


SnapOptionsContext.PrimitiveSnap Field

SnapOptionsContextPrimitiveSnap Field

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string PrimitiveSnap = "PrimitiveSnap"
public:
literal String^ PrimitiveSnap = "PrimitiveSnap"

Field Value

Type: String
See Also

Reference

SnapOptionsContext Class
VisualComponents.Create3D Namespace


SnapOptionsContext.SliceSnap Field

SnapOptionsContextSliceSnap Field

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string SliceSnap = "SliceSnap"
public:
literal String^ SliceSnap = "SliceSnap"

Field Value

Type: String
See Also

Reference

SnapOptionsContext Class
VisualComponents.Create3D Namespace


SnapperPropertyList Class

Class the implements IListT and accepts only instance of ISnapperProperty which are unique within the list.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DConditionalList ISnapperProperty
VisualComponents.Create3DSnapperPropertyList

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SnapperPropertyList : ConditionalList<ISnapperProperty>
public ref class SnapperPropertyList : public ConditionalList<ISnapperProperty^>

The SnapperPropertyList type exposes the following members.

Constructors
 | Name | Description
Public method | SnapperPropertyList | Initializes a new instance of SnapperPropertyList.
Top
Properties
 | Name | Description
Public property | Condition | Gets or sets the instance of ActionT that is used for evaluating the items to be added in the list. The condition should throw an instance of Exception if the item is not allowed in the list. (Inherited from ConditionalListT.)
Public property | Count | (Inherited from ConditionalListT.)
Public property | IsReadOnly | (Inherited from ConditionalListT.)
Public property | Item | (Inherited from ConditionalListT.)
Top
Methods
 | Name | Description
Public method | Add | (Inherited from ConditionalListT.)
Public method | Clear | (Inherited from ConditionalListT.)
Public method | Contains | (Inherited from ConditionalListT.)
Public method | CopyTo | (Inherited from ConditionalListT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | (Inherited from ConditionalListT.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | (Inherited from ConditionalListT.)
Public method | Insert | (Inherited from ConditionalListT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | (Inherited from ConditionalListT.)
Public method | RemoveAt | (Inherited from ConditionalListT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


SnapperPropertyList Constructor

Initializes a new instance of SnapperPropertyList.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SnapperPropertyList()
public:
SnapperPropertyList()
See Also

Reference

SnapperPropertyList Class
VisualComponents.Create3D Namespace


SnapperPropertyList Properties

The SnapperPropertyList type exposes the following members.

Properties
 | Name | Description
Public property | Condition | Gets or sets the instance of ActionT that is used for evaluating the items to be added in the list. The condition should throw an instance of Exception if the item is not allowed in the list. (Inherited from ConditionalListT.)
Public property | Count | (Inherited from ConditionalListT.)
Public property | IsReadOnly | (Inherited from ConditionalListT.)
Public property | Item | (Inherited from ConditionalListT.)
Top
See Also

Reference

SnapperPropertyList Class
VisualComponents.Create3D Namespace


SnapperPropertyList Methods

The SnapperPropertyList type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Inherited from ConditionalListT.)
Public method | Clear | (Inherited from ConditionalListT.)
Public method | Contains | (Inherited from ConditionalListT.)
Public method | CopyTo | (Inherited from ConditionalListT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | (Inherited from ConditionalListT.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | (Inherited from ConditionalListT.)
Public method | Insert | (Inherited from ConditionalListT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | (Inherited from ConditionalListT.)
Public method | RemoveAt | (Inherited from ConditionalListT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SnapperPropertyList Class
VisualComponents.Create3D Namespace


SnapPrimitiveMethod Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum SnapPrimitiveMethod
public enum class SnapPrimitiveMethod
Members
Member name | Value | Description
OnePointSnap | 0 |
TwoPointSnap | 1 |
ThreePointSnap | 2 |
FromToAlign | 3 |
See Also

Reference

VisualComponents.Create3D Namespace


SnapResult Structure

SnapResult is used to indicate 3D position in space and visual object touching it in some way. SnapResult can be a position on edge, end-point of edge, center-point of a face, center-point of an edge, etc. Also it's possible to get extra info from SnapResult.GeoPickResult.GeoPrimitive instance (for example with GetTopologyPolyline).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct SnapResult
public value class SnapResult

The SnapResult type exposes the following members.

Constructors
 | Name | Description
Public method | SnapResult | Constructor
Top
Properties
 | Name | Description
Public property | CenterPosition | Used to define edge's midpoint. This is similary to SnapAction.SnapResultSecondary, but is used only for visualization.
Public property | CustomSnapInfo |
Public property | Direction | Gets the target direction vector. Either edge direction or GuidFrame's X-axis.
 | Empty | Gets an empty result
Public property | FreePointSelection | This makes sense only for Face and Edge results.
Public property | GeoPickResult |
Public property | GeoPrimitive |
Public property | HasResult |
Public property | Normal | Gets the target normal vector. Either surface normal or GuidFrame's Z-axis.
Public property | ObjectTypeMask |
Public property | Position | Gets the target position vector
Public property | PrimitiveType | Gets the target object primitive type (point, edge, face, frame...)
Public property | RefNode |
Public property | ResultText |
Public property | SnapType |
Public property | SurfaceNormal | Gets more precise surface normal, which we get by raycasting. (even when result is an edge)
Public property | SurfacePosition | Gets more precise surface normal, which we get by raycasting. (even when result is an edge)
Public property | VisualObject | Gets the target visual object
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object instances are considered equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(SnapResult) | Determines whether the specified object instances are considered equal. Note: currently there's no way to compare to IGeometrySet instancers (inside _geoPickResult), so comparison of _geoPickResult's is buggy. Aare
Public method | GetHashCode | Returns a hashcode for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Equality | Determines whether the specified object instances are considered equal.
Inequality | Determines whether the specified object instances are not considered equal.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


SnapResult Constructor

Constructor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SnapResult(
    SnapType snapType,
    Vector3 position,
    Nullable<Vector3> centerPosition,
    Nullable<Vector3> normal,
    Nullable<Vector3> direction,
    Nullable<GeoPrimitivePickResult> geoPickResult,
    CustomSnapInfo customSnapInfo,
    bool freePointMode,
    ISimNode refNode,
    SelectionTypes objectTypeMask
)
public:
SnapResult(
    SnapType snapType,
    Vector3 position,
    Nullable<Vector3> centerPosition,
    Nullable<Vector3> normal,
    Nullable<Vector3> direction,
    Nullable<GeoPrimitivePickResult> geoPickResult,
    CustomSnapInfo^ customSnapInfo,
    bool freePointMode,
    ISimNode^ refNode,
    SelectionTypes objectTypeMask
)

Parameters

snapType
Type: VisualComponents.Create3DSnapType
position
Type: VisualComponents.Create3DVector3
Position vector
centerPosition
Type: SystemNullableVector3
normal
Type: SystemNullableVector3
Normal vector
direction
Type: SystemNullableVector3
Direction vector
geoPickResult
Type: SystemNullableGeoPrimitivePickResult
customSnapInfo
Type: VisualComponents.Create3DCustomSnapInfo
freePointMode
Type: SystemBoolean
refNode
Type: VisualComponents.Create3DISimNode
objectTypeMask
Type: VisualComponents.Create3DSelectionTypes
See Also

Reference

SnapResult Structure
VisualComponents.Create3D Namespace


SnapResult Properties

The SnapResult type exposes the following members.

Properties
 | Name | Description
Public property | CenterPosition | Used to define edge's midpoint. This is similary to SnapAction.SnapResultSecondary, but is used only for visualization.
Public property | CustomSnapInfo |
Public property | Direction | Gets the target direction vector. Either edge direction or GuidFrame's X-axis.
 | Empty | Gets an empty result
Public property | FreePointSelection | This makes sense only for Face and Edge results.
Public property | GeoPickResult |
Public property | GeoPrimitive |
Public property | HasResult |
Public property | Normal | Gets the target normal vector. Either surface normal or GuidFrame's Z-axis.
Public property | ObjectTypeMask |
Public property | Position | Gets the target position vector
Public property | PrimitiveType | Gets the target object primitive type (point, edge, face, frame...)
Public property | RefNode |
Public property | ResultText |
Public property | SnapType |
Public property | SurfaceNormal | Gets more precise surface normal, which we get by raycasting. (even when result is an edge)
Public property | SurfacePosition | Gets more precise surface normal, which we get by raycasting. (even when result is an edge)
Public property | VisualObject | Gets the target visual object
Top
See Also

Reference

SnapResult Structure
VisualComponents.Create3D Namespace


SnapResult.CenterPosition Property

SnapResultCenterPosition Property

Used to define edge's midpoint. This is similary to SnapAction.SnapResultSecondary, but is used only for visualization.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<Vector3> CenterPosition { get; set; }
public:
property Nullable<Vector3> CenterPosition {
    Nullable<Vector3> get ();
    void set (Nullable<Vector3> value);
}

Property Value

Type: NullableVector3
See Also

Reference

SnapResult Structure
VisualComponents.Create3D Namespace


SnapResult.CustomSnapInfo Property

SnapResultCustomSnapInfo Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CustomSnapInfo CustomSnapInfo { get; set; }
public:
property CustomSnapInfo^ CustomSnapInfo {
    CustomSnapInfo^ get ();
    void set (CustomSnapInfo^ value);
}

Property Value

Type: CustomSnapInfo
See Also

Reference

SnapResult Structure
VisualComponents.Create3D Namespace


SnapResult.Direction Property

SnapResultDirection Property

Gets the target direction vector. Either edge direction or GuidFrame's X-axis.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<Vector3> Direction { get; }
public:
property Nullable<Vector3> Direction {
    Nullable<Vector3> get ();
}

Property Value

Type: NullableVector3
See Also

Reference

SnapResult Structure
VisualComponents.Create3D Namespace


SnapResult.Empty Property

SnapResultEmpty Property

Gets an empty result

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static SnapResult Empty { get; }
public:
static property SnapResult Empty {
    SnapResult get ();
}

Property Value

Type: SnapResult
See Also

Reference

SnapResult Structure
VisualComponents.Create3D Namespace


SnapResult.FreePointSelection Property

SnapResultFreePointSelection Property

This makes sense only for Face and Edge results.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool FreePointSelection { get; }
public:
property bool FreePointSelection {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

SnapResult Structure
VisualComponents.Create3D Namespace


SnapResult.GeoPickResult Property

SnapResultGeoPickResult Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<GeoPrimitivePickResult> GeoPickResult { get; }
public:
property Nullable<GeoPrimitivePickResult> GeoPickResult {
    Nullable<GeoPrimitivePickResult> get ();
}

Property Value

Type: NullableGeoPrimitivePickResult
See Also

Reference

SnapResult Structure
VisualComponents.Create3D Namespace


SnapResult.GeoPrimitive Property

SnapResultGeoPrimitive Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object GeoPrimitive { get; }
public:
property Object^ GeoPrimitive {
    Object^ get ();
}

Property Value

Type: Object
See Also

Reference

SnapResult Structure
VisualComponents.Create3D Namespace


SnapResult.HasResult Property

SnapResultHasResult Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HasResult { get; }
public:
property bool HasResult {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

SnapResult Structure
VisualComponents.Create3D Namespace


SnapResult.Normal Property

SnapResultNormal Property

Gets the target normal vector. Either surface normal or GuidFrame's Z-axis.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<Vector3> Normal { get; set; }
public:
property Nullable<Vector3> Normal {
    Nullable<Vector3> get ();
    void set (Nullable<Vector3> value);
}

Property Value

Type: NullableVector3
See Also

Reference

SnapResult Structure
VisualComponents.Create3D Namespace


SnapResult.ObjectTypeMask Property

SnapResultObjectTypeMask Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SelectionTypes ObjectTypeMask { get; set; }
public:
property SelectionTypes ObjectTypeMask {
    SelectionTypes get ();
    void set (SelectionTypes value);
}

Property Value

Type: SelectionTypes
See Also

Reference

SnapResult Structure
VisualComponents.Create3D Namespace


SnapResult.Position Property

SnapResultPosition Property

Gets the target position vector

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 Position { get; set; }
public:
property Vector3 Position {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

SnapResult Structure
VisualComponents.Create3D Namespace


SnapResult.PrimitiveType Property

SnapResultPrimitiveType Property

Gets the target object primitive type (point, edge, face, frame...)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GeoPrimitiveType PrimitiveType { get; }
public:
property GeoPrimitiveType PrimitiveType {
    GeoPrimitiveType get ();
}

Property Value

Type: GeoPrimitiveType
See Also

Reference

SnapResult Structure
VisualComponents.Create3D Namespace


SnapResult.RefNode Property

SnapResultRefNode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimNode RefNode { get; set; }
public:
property ISimNode^ RefNode {
    ISimNode^ get ();
    void set (ISimNode^ value);
}

Property Value

Type: ISimNode
See Also

Reference

SnapResult Structure
VisualComponents.Create3D Namespace


SnapResult.ResultText Property

SnapResultResultText Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ResultText { get; }
public:
property String^ ResultText {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

SnapResult Structure
VisualComponents.Create3D Namespace


SnapResult.SnapType Property

SnapResultSnapType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SnapType SnapType { get; set; }
public:
property SnapType SnapType {
    SnapType get ();
    void set (SnapType value);
}

Property Value

Type: SnapType
See Also

Reference

SnapResult Structure
VisualComponents.Create3D Namespace


SnapResult.SurfaceNormal Property

SnapResultSurfaceNormal Property

Gets more precise surface normal, which we get by raycasting. (even when result is an edge)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<Vector3> SurfaceNormal { get; set; }
public:
property Nullable<Vector3> SurfaceNormal {
    Nullable<Vector3> get ();
    void set (Nullable<Vector3> value);
}

Property Value

Type: NullableVector3
See Also

Reference

SnapResult Structure
VisualComponents.Create3D Namespace


SnapResult.SurfacePosition Property

SnapResultSurfacePosition Property

Gets more precise surface normal, which we get by raycasting. (even when result is an edge)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<Vector3> SurfacePosition { get; set; }
public:
property Nullable<Vector3> SurfacePosition {
    Nullable<Vector3> get ();
    void set (Nullable<Vector3> value);
}

Property Value

Type: NullableVector3
See Also

Reference

SnapResult Structure
VisualComponents.Create3D Namespace


SnapResult.VisualObject Property

SnapResultVisualObject Property

Gets the target visual object

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IVisualObject VisualObject { get; }
public:
property IVisualObject^ VisualObject {
    IVisualObject^ get ();
}

Property Value

Type: IVisualObject
See Also

Reference

SnapResult Structure
VisualComponents.Create3D Namespace


SnapResult Methods

The SnapResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object instances are considered equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(SnapResult) | Determines whether the specified object instances are considered equal. Note: currently there's no way to compare to IGeometrySet instancers (inside _geoPickResult), so comparison of _geoPickResult's is buggy. Aare
Public method | GetHashCode | Returns a hashcode for this object. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SnapResult Structure
VisualComponents.Create3D Namespace


SnapResult.Equals Method

SnapResultEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object instances are considered equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(SnapResult) | Determines whether the specified object instances are considered equal. Note: currently there's no way to compare to IGeometrySet instancers (inside _geoPickResult), so comparison of _geoPickResult's is buggy. Aare
Top
See Also

Reference

SnapResult Structure
VisualComponents.Create3D Namespace


SnapResult.Equals Method (Object)

SnapResultEquals Method (Object)

Determines whether the specified object instances are considered equal.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
The object to compare with the current object.

Return Value

Type: Boolean
true if the objects are considered equal; otherwise, false.
See Also

Reference

SnapResult Structure
Equals Overload
VisualComponents.Create3D Namespace


SnapResult.Equals Method (SnapResult)

SnapResultEquals Method (SnapResult)

Determines whether the specified object instances are considered equal. Note: currently there's no way to compare to IGeometrySet instancers (inside _geoPickResult), so comparison of _geoPickResult's is buggy. Aare

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    SnapResult other
)
public:
bool Equals(
    SnapResult other
)

Parameters

other
Type: VisualComponents.Create3DSnapResult
The object to compare with the current object.

Return Value

Type: Boolean
true if the objects are considered equal; otherwise, false.
See Also

Reference

SnapResult Structure
Equals Overload
VisualComponents.Create3D Namespace


SnapResult.GetHashCode Method

SnapResultGetHashCode Method

Returns a hashcode for this object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32
the hahscode.
See Also

Reference

SnapResult Structure
VisualComponents.Create3D Namespace


SnapResult Operators

The SnapResult type exposes the following members.

Operators
Name | Description
Equality | Determines whether the specified object instances are considered equal.
Inequality | Determines whether the specified object instances are not considered equal.
Top
See Also

Reference

SnapResult Structure
VisualComponents.Create3D Namespace


SnapResult.Equality Operator

SnapResultEquality Operator

Determines whether the specified object instances are considered equal.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    SnapResult result1,
    SnapResult result2
)
public:
static bool operator ==(
    SnapResult result1,
    SnapResult result2
)

Parameters

result1
Type: VisualComponents.Create3DSnapResult
The first object to compare.
result2
Type: VisualComponents.Create3DSnapResult
The second object to compare.

Return Value

Type: Boolean
true if the objects are considered equal; otherwise, false.
See Also

Reference

SnapResult Structure
VisualComponents.Create3D Namespace


SnapResult.Inequality Operator

SnapResultInequality Operator

Determines whether the specified object instances are not considered equal.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    SnapResult result1,
    SnapResult result2
)
public:
static bool operator !=(
    SnapResult result1,
    SnapResult result2
)

Parameters

result1
Type: VisualComponents.Create3DSnapResult
The first object to compare.
result2
Type: VisualComponents.Create3DSnapResult
The second object to compare.

Return Value

Type: Boolean
true if the objects are not considered equal; otherwise, true.
See Also

Reference

SnapResult Structure
VisualComponents.Create3D Namespace


SnapType Enumeration

Snap filters and results.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum SnapType
public enum class SnapType
Members
Member name | Value | Description
None | 0 |
All | 1 |
FreePoint | 2 |
MousePoint | 3 |
Face | 4 |
FaceCenter | 5 |
FacePoint | 6 |
Edge | 7 |
EdgeCenter | 8 |
EdgePoint | 9 |
EdgeLine | 10 |
EdgeCurve | 11 |
ArcCenter | 12 |
GuideFrame | 13 |
ObjectOrigin | 14 |
ObjectBounds | 15 |
ObjectBoundsCenter | 16 |
ObjectBoundsCorner | 17 |
BoundsCorners | 18 |
Bounds | 19 |
COIPoint | 20 |
SnapTypeCount | 21 |
See Also

Reference

VisualComponents.Create3D Namespace


SoftwareReleaseInfo Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DSoftwareReleaseInfo

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SoftwareReleaseInfo
public ref class SoftwareReleaseInfo

The SoftwareReleaseInfo type exposes the following members.

Constructors
 | Name | Description
Public method | SoftwareReleaseInfo | Initializes a new instance of the SoftwareReleaseInfo class
Top
Properties
 | Name | Description
Public property | BuildNumber |
Public property | FileSize |
Public property | NewFeatures |
Public property | Notes |
Public property | Source |
Public property | Version |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


SoftwareReleaseInfo Constructor

Initializes a new instance of the SoftwareReleaseInfo class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SoftwareReleaseInfo()
public:
SoftwareReleaseInfo()
See Also

Reference

SoftwareReleaseInfo Class
VisualComponents.Create3D Namespace


SoftwareReleaseInfo Properties

The SoftwareReleaseInfo type exposes the following members.

Properties
 | Name | Description
Public property | BuildNumber |
Public property | FileSize |
Public property | NewFeatures |
Public property | Notes |
Public property | Source |
Public property | Version |
Top
See Also

Reference

SoftwareReleaseInfo Class
VisualComponents.Create3D Namespace


SoftwareReleaseInfo.BuildNumber Property

SoftwareReleaseInfoBuildNumber Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string BuildNumber { get; set; }
public:
property String^ BuildNumber {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SoftwareReleaseInfo Class
VisualComponents.Create3D Namespace


SoftwareReleaseInfo.FileSize Property

SoftwareReleaseInfoFileSize Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string FileSize { get; set; }
public:
property String^ FileSize {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SoftwareReleaseInfo Class
VisualComponents.Create3D Namespace


SoftwareReleaseInfo.NewFeatures Property

SoftwareReleaseInfoNewFeatures Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObservableCollection<string> NewFeatures { get; set; }
public:
property ObservableCollection<String^>^ NewFeatures {
    ObservableCollection<String^>^ get ();
    void set (ObservableCollection<String^>^ value);
}

Property Value

Type: ObservableCollectionString
See Also

Reference

SoftwareReleaseInfo Class
VisualComponents.Create3D Namespace


SoftwareReleaseInfo.Notes Property

SoftwareReleaseInfoNotes Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Notes { get; set; }
public:
property String^ Notes {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SoftwareReleaseInfo Class
VisualComponents.Create3D Namespace


SoftwareReleaseInfo.Source Property

SoftwareReleaseInfoSource Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Source { get; set; }
public:
property String^ Source {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SoftwareReleaseInfo Class
VisualComponents.Create3D Namespace


SoftwareReleaseInfo.Version Property

SoftwareReleaseInfoVersion Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Version { get; set; }
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SoftwareReleaseInfo Class
VisualComponents.Create3D Namespace


SoftwareReleaseInfo Methods

The SoftwareReleaseInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SoftwareReleaseInfo Class
VisualComponents.Create3D Namespace


SoftwareUpdateHelper Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DSoftwareUpdateHelper

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class SoftwareUpdateHelper
public ref class SoftwareUpdateHelper sealed

The SoftwareUpdateHelper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FindLatestSoftwareRelease |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


SoftwareUpdateHelper Methods

The SoftwareUpdateHelper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | FindLatestSoftwareRelease |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SoftwareUpdateHelper Class
VisualComponents.Create3D Namespace


SoftwareUpdateHelper.FindLatestSoftwareRelease Method

SoftwareUpdateHelperFindLatestSoftwareRelease Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static SoftwareReleaseInfo FindLatestSoftwareRelease()
public:
static SoftwareReleaseInfo^ FindLatestSoftwareRelease()

Return Value

Type: SoftwareReleaseInfo

[Missing <returns> documentation for "M:VisualComponents.Create3D.SoftwareUpdateHelper.FindLatestSoftwareRelease"]

See Also

Reference

SoftwareUpdateHelper Class
VisualComponents.Create3D Namespace


SolidEdge Enumeration

SolidEdge -> V19 - 20, ST - ST7

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum SolidEdge
public enum class SolidEdge
Members
Member name | Value | Description
ASM | 0 |
PAR | 1 |
PWD | 2 |
PSM | 3 |
See Also

Reference

VisualComponents.Create3D Namespace


SolidWorks Enumeration

SolidWorks -> From 97 up to 2017

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum SolidWorks
public enum class SolidWorks
Members
Member name | Value | Description
SLDASM | 0 |
SLDPRT | 1 |
See Also

Reference

VisualComponents.Create3D Namespace


SourceVariableType Enumeration

Can be used when it is to select from what type of property to get some real value, e.g. time, from, if there is just one of each type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum SourceVariableType
public enum class SourceVariableType
Members
Member name | Value | Description
Distribution | 0 | Take a sample from the Distribution property.
Expression | 1 | Evaluate the Expression property and use the result value.
See Also

Reference

VisualComponents.Create3D Namespace


SplineCurve Class

This class contains information to create a spline
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DCurveBase
VisualComponents.Create3DSplineCurve

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SplineCurve : CurveBase
public ref class SplineCurve : public CurveBase

The SplineCurve type exposes the following members.

Constructors
 | Name | Description
Public method | SplineCurve | Initializes a new instance of the SplineCurve class
Top
Properties
 | Name | Description
Public property | ControlPoints | (Overrides CurveBaseControlPoints.)
Public property | CurveType | (Overrides CurveBaseCurveType.)
Public property | Degree |
Public property | Knots | Face U knots
Public property | Weights | Face control weights
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


SplineCurve Constructor

Initializes a new instance of the SplineCurve class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SplineCurve(
    int degree,
    ICollection<Vector3> controlPoints,
    ICollection<double> weights,
    ICollection<Tuple<double, int>> knots
)
public:
SplineCurve(
    int degree,
    ICollection<Vector3>^ controlPoints,
    ICollection<double>^ weights,
    ICollection<Tuple<double, int>^>^ knots
)

Parameters

degree
Type: SystemInt32
controlPoints
Type: System.Collections.GenericICollectionVector3
weights
Type: System.Collections.GenericICollectionDouble
knots
Type: System.Collections.GenericICollectionTupleDouble, Int32
See Also

Reference

SplineCurve Class
VisualComponents.Create3D Namespace


SplineCurve Properties

The SplineCurve type exposes the following members.

Properties
 | Name | Description
Public property | ControlPoints | (Overrides CurveBaseControlPoints.)
Public property | CurveType | (Overrides CurveBaseCurveType.)
Public property | Degree |
Public property | Knots | Face U knots
Public property | Weights | Face control weights
Top
See Also

Reference

SplineCurve Class
VisualComponents.Create3D Namespace


SplineCurve.ControlPoints Property

SplineCurveControlPoints Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override ReadOnlyCollection<Vector3> ControlPoints { get; }
public:
virtual property ReadOnlyCollection<Vector3>^ ControlPoints {
    ReadOnlyCollection<Vector3>^ get () override;
}

Property Value

Type: ReadOnlyCollectionVector3
See Also

Reference

SplineCurve Class
VisualComponents.Create3D Namespace


SplineCurve.CurveType Property

SplineCurveCurveType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override CurveType CurveType { get; }
public:
virtual property CurveType CurveType {
    CurveType get () override;
}

Property Value

Type: CurveType
See Also

Reference

SplineCurve Class
VisualComponents.Create3D Namespace


SplineCurve.Degree Property

SplineCurveDegree Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Degree { get; }
public:
property int Degree {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

SplineCurve Class
VisualComponents.Create3D Namespace


SplineCurve.Knots Property

SplineCurveKnots Property

Face U knots

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<Tuple<double, int>> Knots { get; }
public:
property ReadOnlyCollection<Tuple<double, int>^>^ Knots {
    ReadOnlyCollection<Tuple<double, int>^>^ get ();
}

Property Value

Type: ReadOnlyCollectionTupleDouble, Int32
See Also

Reference

SplineCurve Class
VisualComponents.Create3D Namespace


SplineCurve.Weights Property

SplineCurveWeights Property

Face control weights

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<double> Weights { get; }
public:
property ReadOnlyCollection<double>^ Weights {
    ReadOnlyCollection<double>^ get ();
}

Property Value

Type: ReadOnlyCollectionDouble
See Also

Reference

SplineCurve Class
VisualComponents.Create3D Namespace


SplineCurve Methods

The SplineCurve type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SplineCurve Class
VisualComponents.Create3D Namespace


State Enumeration

Container states used in collecting statistics.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum State
public enum class State
Members
Member name | Value | Description
Invalid | 0 | Invalid state.
WarmUp | 1 | Warm up.
Break | 2 | Break.
Idle | 3 | Idle.
Busy | 4 | Busy.
Blocked | 5 | Blocked.
Fail | 6 | Fail.
Repair | 7 | Repair.
Setup | 8 | Setup.
See Also

Reference

VisualComponents.Create3D Namespace


StatementAddedEventArgs Class

Provides data for StatementAdded event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DStatementAddedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class StatementAddedEventArgs : EventArgs
public ref class StatementAddedEventArgs : public EventArgs

The StatementAddedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | StatementAddedEventArgs | Initializes a new instance of StatementAddedEventArgs.
Top
Properties
 | Name | Description
Public property | Statement | Gets the statement that was added.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


StatementAddedEventArgs Constructor

Initializes a new instance of StatementAddedEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StatementAddedEventArgs(
    IStatement statement
)
public:
StatementAddedEventArgs(
    IStatement^ statement
)

Parameters

statement
Type: VisualComponents.Create3DIStatement
See Also

Reference

StatementAddedEventArgs Class
VisualComponents.Create3D Namespace


StatementAddedEventArgs Properties

The StatementAddedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Statement | Gets the statement that was added.
Top
See Also

Reference

StatementAddedEventArgs Class
VisualComponents.Create3D Namespace


StatementAddedEventArgs.Statement Property

StatementAddedEventArgsStatement Property

Gets the statement that was added.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IStatement Statement { get; }
public:
property IStatement^ Statement {
    IStatement^ get ();
}

Property Value

Type: IStatement
See Also

Reference

StatementAddedEventArgs Class
VisualComponents.Create3D Namespace


StatementAddedEventArgs Methods

The StatementAddedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

StatementAddedEventArgs Class
VisualComponents.Create3D Namespace


StatementDoubleClickEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DStatementDoubleClickEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class StatementDoubleClickEventArgs : EventArgs
public ref class StatementDoubleClickEventArgs : public EventArgs

The StatementDoubleClickEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | StatementDoubleClickEventArgs | Initializes a new instance of the StatementDoubleClickEventArgs class
Top
Properties
 | Name | Description
Public property | Source |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


StatementDoubleClickEventArgs Constructor

Initializes a new instance of the StatementDoubleClickEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StatementDoubleClickEventArgs()
public:
StatementDoubleClickEventArgs()
See Also

Reference

StatementDoubleClickEventArgs Class
VisualComponents.Create3D Namespace


StatementDoubleClickEventArgs Properties

The StatementDoubleClickEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Source |
Top
See Also

Reference

StatementDoubleClickEventArgs Class
VisualComponents.Create3D Namespace


StatementDoubleClickEventArgs.Source Property

StatementDoubleClickEventArgsSource Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Source { get; set; }
public:
property Object^ Source {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

StatementDoubleClickEventArgs Class
VisualComponents.Create3D Namespace


StatementDoubleClickEventArgs Methods

The StatementDoubleClickEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

StatementDoubleClickEventArgs Class
VisualComponents.Create3D Namespace


StatementExecutedEventArgs Class

Provides data for statement post execution events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DStatementExecutedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class StatementExecutedEventArgs : EventArgs
public ref class StatementExecutedEventArgs : public EventArgs

The StatementExecutedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | StatementExecutedEventArgs(IExecutor) | Initializes a new instance of StatementExecutedEventArgs.
Public method | StatementExecutedEventArgs(IExecutor, IStatement) | Initializes a new instance of StatementExecutedEventArgs.
Public method | StatementExecutedEventArgs(IExecutor, Boolean, IStatement) | Initializes a new instance of StatementExecutedEventArgs.
Top
Properties
 | Name | Description
Public property | Executor | Gets the IExecutor that executed the instance of IStatement.
Public property | IsImmediate | Defines if the instance of IStatement was executed in immediate (non time-consuming) mode.
Public property | Statement | Gets the instance of IStatement that was executed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


StatementExecutedEventArgs Constructor

Overload List
 | Name | Description
Public method | StatementExecutedEventArgs(IExecutor) | Initializes a new instance of StatementExecutedEventArgs.
Public method | StatementExecutedEventArgs(IExecutor, IStatement) | Initializes a new instance of StatementExecutedEventArgs.
Public method | StatementExecutedEventArgs(IExecutor, Boolean, IStatement) | Initializes a new instance of StatementExecutedEventArgs.
Top
See Also

Reference

StatementExecutedEventArgs Class
VisualComponents.Create3D Namespace


StatementExecutedEventArgs Constructor (IExecutor)

Initializes a new instance of StatementExecutedEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StatementExecutedEventArgs(
    IExecutor executor
)
public:
StatementExecutedEventArgs(
    IExecutor^ executor
)

Parameters

executor
Type: VisualComponents.Create3DIExecutor
Executor that executed the statement.
See Also

Reference

StatementExecutedEventArgs Class
StatementExecutedEventArgs Overload
VisualComponents.Create3D Namespace


StatementExecutedEventArgs Constructor (IExecutor, IStatement)

Initializes a new instance of StatementExecutedEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StatementExecutedEventArgs(
    IExecutor executor,
    IStatement statement
)
public:
StatementExecutedEventArgs(
    IExecutor^ executor,
    IStatement^ statement
)

Parameters

executor
Type: VisualComponents.Create3DIExecutor
Executor that executed the statement.
statement
Type: VisualComponents.Create3DIStatement
Statement that was executed.
See Also

Reference

StatementExecutedEventArgs Class
StatementExecutedEventArgs Overload
VisualComponents.Create3D Namespace


StatementExecutedEventArgs Constructor (IExecutor, Boolean, IStatement)

Initializes a new instance of StatementExecutedEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StatementExecutedEventArgs(
    IExecutor executor,
    bool isImmediate,
    IStatement statement
)
public:
StatementExecutedEventArgs(
    IExecutor^ executor,
    bool isImmediate,
    IStatement^ statement
)

Parameters

executor
Type: VisualComponents.Create3DIExecutor
Executor that executed the statement.
isImmediate
Type: SystemBoolean
Defins if statement was executed in immediate mode.
statement
Type: VisualComponents.Create3DIStatement
Statement that was executed.
See Also

Reference

StatementExecutedEventArgs Class
StatementExecutedEventArgs Overload
VisualComponents.Create3D Namespace


StatementExecutedEventArgs Properties

The StatementExecutedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Executor | Gets the IExecutor that executed the instance of IStatement.
Public property | IsImmediate | Defines if the instance of IStatement was executed in immediate (non time-consuming) mode.
Public property | Statement | Gets the instance of IStatement that was executed.
Top
See Also

Reference

StatementExecutedEventArgs Class
VisualComponents.Create3D Namespace


StatementExecutedEventArgs.Executor Property

StatementExecutedEventArgsExecutor Property

Gets the IExecutor that executed the instance of IStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IExecutor Executor { get; }
public:
property IExecutor^ Executor {
    IExecutor^ get ();
}

Property Value

Type: IExecutor
See Also

Reference

StatementExecutedEventArgs Class
VisualComponents.Create3D Namespace


StatementExecutedEventArgs.IsImmediate Property

StatementExecutedEventArgsIsImmediate Property

Defines if the instance of IStatement was executed in immediate (non time-consuming) mode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsImmediate { get; }
public:
property bool IsImmediate {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

StatementExecutedEventArgs Class
VisualComponents.Create3D Namespace


StatementExecutedEventArgs.Statement Property

StatementExecutedEventArgsStatement Property

Gets the instance of IStatement that was executed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IStatement Statement { get; }
public:
property IStatement^ Statement {
    IStatement^ get ();
}

Property Value

Type: IStatement
See Also

Reference

StatementExecutedEventArgs Class
VisualComponents.Create3D Namespace


StatementExecutedEventArgs Methods

The StatementExecutedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

StatementExecutedEventArgs Class
VisualComponents.Create3D Namespace


StatementExecutingEventArgs Class

Provides data for statement pre execution events.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DStatementExecutingEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class StatementExecutingEventArgs : EventArgs
public ref class StatementExecutingEventArgs : public EventArgs

The StatementExecutingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | StatementExecutingEventArgs(IExecutor, Boolean) | Initializes a new instace of StatementExecutingEventArgs.
Public method | StatementExecutingEventArgs(IExecutor, Boolean, IStatement) | Initializes a new instace of StatementExecutingEventArgs.
Top
Properties
 | Name | Description
Public property | Executor | Gets the IExecutor that is executing the instance of IStatement.
Public property | IsImmediate | Defines if the instance of IStatement is executed in immediate (non time-consuming) mode.
Public property | Statement | Gets the the instance of IStatement that is being executed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


StatementExecutingEventArgs Constructor

Overload List
 | Name | Description
Public method | StatementExecutingEventArgs(IExecutor, Boolean) | Initializes a new instace of StatementExecutingEventArgs.
Public method | StatementExecutingEventArgs(IExecutor, Boolean, IStatement) | Initializes a new instace of StatementExecutingEventArgs.
Top
See Also

Reference

StatementExecutingEventArgs Class
VisualComponents.Create3D Namespace


StatementExecutingEventArgs Constructor (IExecutor, Boolean)

Initializes a new instace of StatementExecutingEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StatementExecutingEventArgs(
    IExecutor executor,
    bool immediate
)
public:
StatementExecutingEventArgs(
    IExecutor^ executor,
    bool immediate
)

Parameters

executor
Type: VisualComponents.Create3DIExecutor
Executor that is executing the statement.
immediate
Type: SystemBoolean
If the statement is executed in immediate mode.
See Also

Reference

StatementExecutingEventArgs Class
StatementExecutingEventArgs Overload
VisualComponents.Create3D Namespace


StatementExecutingEventArgs Constructor (IExecutor, Boolean, IStatement)

Initializes a new instace of StatementExecutingEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StatementExecutingEventArgs(
    IExecutor executor,
    bool immediate,
    IStatement statement
)
public:
StatementExecutingEventArgs(
    IExecutor^ executor,
    bool immediate,
    IStatement^ statement
)

Parameters

executor
Type: VisualComponents.Create3DIExecutor
Executor that is executing the statement.
immediate
Type: SystemBoolean
If the statement is executed in immediate mode.
statement
Type: VisualComponents.Create3DIStatement
Statement that is being executed.
See Also

Reference

StatementExecutingEventArgs Class
StatementExecutingEventArgs Overload
VisualComponents.Create3D Namespace


StatementExecutingEventArgs Properties

The StatementExecutingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Executor | Gets the IExecutor that is executing the instance of IStatement.
Public property | IsImmediate | Defines if the instance of IStatement is executed in immediate (non time-consuming) mode.
Public property | Statement | Gets the the instance of IStatement that is being executed.
Top
See Also

Reference

StatementExecutingEventArgs Class
VisualComponents.Create3D Namespace


StatementExecutingEventArgs.Executor Property

StatementExecutingEventArgsExecutor Property

Gets the IExecutor that is executing the instance of IStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IExecutor Executor { get; }
public:
property IExecutor^ Executor {
    IExecutor^ get ();
}

Property Value

Type: IExecutor
See Also

Reference

StatementExecutingEventArgs Class
VisualComponents.Create3D Namespace


StatementExecutingEventArgs.IsImmediate Property

StatementExecutingEventArgsIsImmediate Property

Defines if the instance of IStatement is executed in immediate (non time-consuming) mode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsImmediate { get; }
public:
property bool IsImmediate {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

StatementExecutingEventArgs Class
VisualComponents.Create3D Namespace


StatementExecutingEventArgs.Statement Property

StatementExecutingEventArgsStatement Property

Gets the the instance of IStatement that is being executed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IStatement Statement { get; }
public:
property IStatement^ Statement {
    IStatement^ get ();
}

Property Value

Type: IStatement
See Also

Reference

StatementExecutingEventArgs Class
VisualComponents.Create3D Namespace


StatementExecutingEventArgs Methods

The StatementExecutingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

StatementExecutingEventArgs Class
VisualComponents.Create3D Namespace


StatementMovedEventArgs Class

Provides data for StatementMoved.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DStatementMovedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class StatementMovedEventArgs : EventArgs
public ref class StatementMovedEventArgs : public EventArgs

The StatementMovedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | StatementMovedEventArgs | Initializes a new instance of StatementMovedEventArgs.
Top
Properties
 | Name | Description
Public property | NewIndex | Gets the position of the statement in the new scope.
Public property | OldIndex | Gets the position of the statement in original scope.
Public property | OldScope | Gets the original scope of the statement.
Public property | Statement | Gets the statement that was moved.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


StatementMovedEventArgs Constructor

Initializes a new instance of StatementMovedEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StatementMovedEventArgs(
    IStatement statement,
    int newIndex,
    IStatementScope oldScope,
    int oldIndex
)
public:
StatementMovedEventArgs(
    IStatement^ statement,
    int newIndex,
    IStatementScope^ oldScope,
    int oldIndex
)

Parameters

statement
Type: VisualComponents.Create3DIStatement
Statement that was moved.
newIndex
Type: SystemInt32
New index.
oldScope
Type: VisualComponents.Create3DIStatementScope
Old scope.
oldIndex
Type: SystemInt32
Old index.
See Also

Reference

StatementMovedEventArgs Class
VisualComponents.Create3D Namespace


StatementMovedEventArgs Properties

The StatementMovedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewIndex | Gets the position of the statement in the new scope.
Public property | OldIndex | Gets the position of the statement in original scope.
Public property | OldScope | Gets the original scope of the statement.
Public property | Statement | Gets the statement that was moved.
Top
See Also

Reference

StatementMovedEventArgs Class
VisualComponents.Create3D Namespace


StatementMovedEventArgs.NewIndex Property

StatementMovedEventArgsNewIndex Property

Gets the position of the statement in the new scope.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int NewIndex { get; }
public:
property int NewIndex {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

StatementMovedEventArgs Class
VisualComponents.Create3D Namespace


StatementMovedEventArgs.OldIndex Property

StatementMovedEventArgsOldIndex Property

Gets the position of the statement in original scope.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int OldIndex { get; }
public:
property int OldIndex {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

StatementMovedEventArgs Class
VisualComponents.Create3D Namespace


StatementMovedEventArgs.OldScope Property

StatementMovedEventArgsOldScope Property

Gets the original scope of the statement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IStatementScope OldScope { get; }
public:
property IStatementScope^ OldScope {
    IStatementScope^ get ();
}

Property Value

Type: IStatementScope
See Also

Reference

StatementMovedEventArgs Class
VisualComponents.Create3D Namespace


StatementMovedEventArgs.Statement Property

StatementMovedEventArgsStatement Property

Gets the statement that was moved.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IStatement Statement { get; }
public:
property IStatement^ Statement {
    IStatement^ get ();
}

Property Value

Type: IStatement
See Also

Reference

StatementMovedEventArgs Class
VisualComponents.Create3D Namespace


StatementMovedEventArgs Methods

The StatementMovedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

StatementMovedEventArgs Class
VisualComponents.Create3D Namespace


StatementRemovedEventArgs Class

Provides data for StatementRemoved event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DStatementRemovedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class StatementRemovedEventArgs : EventArgs
public ref class StatementRemovedEventArgs : public EventArgs

The StatementRemovedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | StatementRemovedEventArgs | Initializes a new instance of StatementRemovedEventArgs.
Top
Properties
 | Name | Description
Public property | Statement | Gets the statement that was removed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


StatementRemovedEventArgs Constructor

Initializes a new instance of StatementRemovedEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StatementRemovedEventArgs(
    IStatement statement
)
public:
StatementRemovedEventArgs(
    IStatement^ statement
)

Parameters

statement
Type: VisualComponents.Create3DIStatement
See Also

Reference

StatementRemovedEventArgs Class
VisualComponents.Create3D Namespace


StatementRemovedEventArgs Properties

The StatementRemovedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Statement | Gets the statement that was removed.
Top
See Also

Reference

StatementRemovedEventArgs Class
VisualComponents.Create3D Namespace


StatementRemovedEventArgs.Statement Property

StatementRemovedEventArgsStatement Property

Gets the statement that was removed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IStatement Statement { get; }
public:
property IStatement^ Statement {
    IStatement^ get ();
}

Property Value

Type: IStatement
See Also

Reference

StatementRemovedEventArgs Class
VisualComponents.Create3D Namespace


StatementRemovedEventArgs Methods

The StatementRemovedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

StatementRemovedEventArgs Class
VisualComponents.Create3D Namespace


StatementRemovingEventArgs Class

Provides data for StatementRemoving event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DStatementRemovingEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class StatementRemovingEventArgs : EventArgs
public ref class StatementRemovingEventArgs : public EventArgs

The StatementRemovingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | StatementRemovingEventArgs | Initializes a new instance of StatementRemovingEventArgs.
Top
Properties
 | Name | Description
Public property | Statement | Gets the statement that is being removed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


StatementRemovingEventArgs Constructor

Initializes a new instance of StatementRemovingEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StatementRemovingEventArgs(
    IStatement statement
)
public:
StatementRemovingEventArgs(
    IStatement^ statement
)

Parameters

statement
Type: VisualComponents.Create3DIStatement
See Also

Reference

StatementRemovingEventArgs Class
VisualComponents.Create3D Namespace


StatementRemovingEventArgs Properties

The StatementRemovingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Statement | Gets the statement that is being removed.
Top
See Also

Reference

StatementRemovingEventArgs Class
VisualComponents.Create3D Namespace


StatementRemovingEventArgs.Statement Property

StatementRemovingEventArgsStatement Property

Gets the statement that is being removed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IStatement Statement { get; }
public:
property IStatement^ Statement {
    IStatement^ get ();
}

Property Value

Type: IStatement
See Also

Reference

StatementRemovingEventArgs Class
VisualComponents.Create3D Namespace


StatementRemovingEventArgs Methods

The StatementRemovingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

StatementRemovingEventArgs Class
VisualComponents.Create3D Namespace


StaticPdf Enumeration

Static PDF

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum StaticPdf
public enum class StaticPdf
Members
Member name | Value | Description
PDF | 0 |
See Also

Reference

VisualComponents.Create3D Namespace


StatisticsConfigElement Class

Configuration file element for Statistics Dashboard Settings.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.Create3DStatisticsConfigElement

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class StatisticsConfigElement : ConfigurationElement
public ref class StatisticsConfigElement sealed : public ConfigurationElement

The StatisticsConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | StatisticsConfigElement | Constructor.
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | TemplatesPopupThreshold | Threshold for alternative presentation of Statistics Templates.
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks
These options are visibile in application backstage, and stored to user-specific configuration file.
See Also

Reference

VisualComponents.Create3D Namespace


StatisticsConfigElement Constructor

Constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StatisticsConfigElement()
public:
StatisticsConfigElement()
See Also

Reference

StatisticsConfigElement Class
VisualComponents.Create3D Namespace


StatisticsConfigElement Properties

The StatisticsConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | TemplatesPopupThreshold | Threshold for alternative presentation of Statistics Templates.
Top
See Also

Reference

StatisticsConfigElement Class
VisualComponents.Create3D Namespace


StatisticsConfigElement.TemplatesPopupThreshold Property

StatisticsConfigElementTemplatesPopupThreshold Property

Threshold for alternative presentation of Statistics Templates.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int TemplatesPopupThreshold { get; set; }
public:
property int TemplatesPopupThreshold {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

StatisticsConfigElement Class
VisualComponents.Create3D Namespace


StatisticsConfigElement Methods

The StatisticsConfigElement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

StatisticsConfigElement Class
VisualComponents.Create3D Namespace


StatisticsDataRow Class

Defines a set of values recorded at a particular moment of simulation time.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DStatisticsDataRow

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class StatisticsDataRow
public ref class StatisticsDataRow

The StatisticsDataRow type exposes the following members.

Constructors
 | Name | Description
Public method | StatisticsDataRow | Initializes a new instance of the StatisticsDataRow class
Top
Properties
 | Name | Description
Public property | RowFields | Either 1 or 5 double values per series/component/property. See IStatisticsChartBase.DataType.
Public property | SimulationTime | The moment these values were recorded. Measured in simulation time seconds.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


StatisticsDataRow Constructor

Initializes a new instance of the StatisticsDataRow class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StatisticsDataRow()
public:
StatisticsDataRow()
See Also

Reference

StatisticsDataRow Class
VisualComponents.Create3D Namespace


StatisticsDataRow Properties

The StatisticsDataRow type exposes the following members.

Properties
 | Name | Description
Public property | RowFields | Either 1 or 5 double values per series/component/property. See IStatisticsChartBase.DataType.
Public property | SimulationTime | The moment these values were recorded. Measured in simulation time seconds.
Top
See Also

Reference

StatisticsDataRow Class
VisualComponents.Create3D Namespace


StatisticsDataRow.RowFields Property

StatisticsDataRowRowFields Property

Either 1 or 5 double values per series/component/property. See IStatisticsChartBase.DataType.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object[] RowFields { get; set; }
public:
property array<Object^>^ RowFields {
    array<Object^>^ get ();
    void set (array<Object^>^ value);
}

Property Value

Type: Object
See Also

Reference

StatisticsDataRow Class
VisualComponents.Create3D Namespace


StatisticsDataRow.SimulationTime Property

StatisticsDataRowSimulationTime Property

The moment these values were recorded. Measured in simulation time seconds.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double SimulationTime { get; set; }
public:
property double SimulationTime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

StatisticsDataRow Class
VisualComponents.Create3D Namespace


StatisticsDataRow Methods

The StatisticsDataRow type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

StatisticsDataRow Class
VisualComponents.Create3D Namespace


StatisticsFlowDirection Enumeration

Direction of component's transfer used in the flow-type statistics.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum StatisticsFlowDirection
public enum class StatisticsFlowDirection
Members
Member name | Value | Description
Enter | 0 | Indicates that the product is transferred into the process.
Leave | 1 | Indicates that the product is transferred out from the process.
See Also

Reference

VisualComponents.Create3D Namespace


StatisticsSection Class

Configuration file section for Statistics Dashboard Settings.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationSection
VisualComponents.Create3DStatisticsSection

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class StatisticsSection : ConfigurationSection,
    IStatisticsSection, ISection
public ref class StatisticsSection sealed : public ConfigurationSection,
    IStatisticsSection, ISection

The StatisticsSection type exposes the following members.

Constructors
 | Name | Description
Public method | StatisticsSection | Contructor.
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName | Section's name in configuration file.
Public property | SectionType | Interface type.
Public property | SectionVersion | Section's version number.
Public property | StatisticsElement | Configuration file element for Statistics Dashboard Settings.
Top
Methods
 | Name | Description
Public method | CheckVersion | Upgrade configuration to the latest version.
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection | Finds typed section by name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


StatisticsSection Constructor

Contructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StatisticsSection()
public:
StatisticsSection()
See Also

Reference

StatisticsSection Class
VisualComponents.Create3D Namespace


StatisticsSection Properties

The StatisticsSection type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName | Section's name in configuration file.
Public property | SectionType | Interface type.
Public property | SectionVersion | Section's version number.
Public property | StatisticsElement | Configuration file element for Statistics Dashboard Settings.
Top
See Also

Reference

StatisticsSection Class
VisualComponents.Create3D Namespace


StatisticsSection.SectionName Property

StatisticsSectionSectionName Property

Section's name in configuration file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SectionName { get; }
public:
virtual property String^ SectionName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ISectionSectionName
See Also

Reference

StatisticsSection Class
VisualComponents.Create3D Namespace


StatisticsSection.SectionType Property

StatisticsSectionSectionType Property

Interface type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type SectionType { get; }
public:
virtual property Type^ SectionType {
    Type^ get () sealed;
}

Property Value

Type: Type

Implements

ISectionSectionType
See Also

Reference

StatisticsSection Class
VisualComponents.Create3D Namespace


StatisticsSection.SectionVersion Property

StatisticsSectionSectionVersion Property

Section's version number.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int SectionVersion { get; }
public:
virtual property int SectionVersion {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISectionSectionVersion
See Also

Reference

StatisticsSection Class
VisualComponents.Create3D Namespace


StatisticsSection.StatisticsElement Property

StatisticsSectionStatisticsElement Property

Configuration file element for Statistics Dashboard Settings.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StatisticsConfigElement StatisticsElement { get; set; }
public:
virtual property StatisticsConfigElement^ StatisticsElement {
    StatisticsConfigElement^ get () sealed;
    void set (StatisticsConfigElement^ value) sealed;
}

Property Value

Type: StatisticsConfigElement

Implements

IStatisticsSectionStatisticsElement
See Also

Reference

StatisticsSection Class
VisualComponents.Create3D Namespace


StatisticsSection Methods

The StatisticsSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion | Upgrade configuration to the latest version.
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection | Finds typed section by name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

StatisticsSection Class
VisualComponents.Create3D Namespace


StatisticsSection.CheckVersion Method

StatisticsSectionCheckVersion Method

Upgrade configuration to the latest version.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CheckVersion()
public:
virtual void CheckVersion() sealed

Implements

ISectionCheckVersion
See Also

Reference

StatisticsSection Class
VisualComponents.Create3D Namespace


StatisticsSection.GetSection Method

StatisticsSectionGetSection Method

Finds typed section by name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISection GetSection(
    Configuration userSettingConfiguration
)
public:
virtual ISection^ GetSection(
    Configuration^ userSettingConfiguration
) sealed

Parameters

userSettingConfiguration
Type: System.ConfigurationConfiguration
Configuration containing this section

Return Value

Type: ISection
Instance of StatisticsSection

Implements

ISectionGetSection(Configuration)
See Also

Reference

StatisticsSection Class
VisualComponents.Create3D Namespace


StatisticsSection.ToString Method

StatisticsSectionToString Method

Converts this instance to string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String
String representation of this instance
See Also

Reference

StatisticsSection Class
VisualComponents.Create3D Namespace


StatisticsSourceInfo Class

Additional information about a source, listed in IStatisticsChart.AllSourceInfos, and used for populating a pie chart.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DStatisticsSourceInfo

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class StatisticsSourceInfo
public ref class StatisticsSourceInfo

The StatisticsSourceInfo type exposes the following members.

Constructors
 | Name | Description
Public method | StatisticsSourceInfo | Initializes a new instance of the StatisticsSourceInfo class
Top
Properties
 | Name | Description
Public property | CurrentPositiveNonzeroValue | Latest Math.Abs(value).
Public property | CurrentPositiveValue | Latest Math.Abs(value).
Public property | CurrentValue | Latest value.
Public property | Source | Associated source.
Public property | TitleAndValue | Label text.
Public property | ToolTip | ToolTip for pie chart.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


StatisticsSourceInfo Constructor

Initializes a new instance of the StatisticsSourceInfo class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StatisticsSourceInfo()
public:
StatisticsSourceInfo()
See Also

Reference

StatisticsSourceInfo Class
VisualComponents.Create3D Namespace


StatisticsSourceInfo Properties

The StatisticsSourceInfo type exposes the following members.

Properties
 | Name | Description
Public property | CurrentPositiveNonzeroValue | Latest Math.Abs(value).
Public property | CurrentPositiveValue | Latest Math.Abs(value).
Public property | CurrentValue | Latest value.
Public property | Source | Associated source.
Public property | TitleAndValue | Label text.
Public property | ToolTip | ToolTip for pie chart.
Top
See Also

Reference

StatisticsSourceInfo Class
VisualComponents.Create3D Namespace


StatisticsSourceInfo.CurrentPositiveNonzeroValue Property

StatisticsSourceInfoCurrentPositiveNonzeroValue Property

Latest Math.Abs(value).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double CurrentPositiveNonzeroValue { get; set; }
public:
property double CurrentPositiveNonzeroValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

StatisticsSourceInfo Class
VisualComponents.Create3D Namespace


StatisticsSourceInfo.CurrentPositiveValue Property

StatisticsSourceInfoCurrentPositiveValue Property

Latest Math.Abs(value).

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double CurrentPositiveValue { get; set; }
public:
property double CurrentPositiveValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

StatisticsSourceInfo Class
VisualComponents.Create3D Namespace


StatisticsSourceInfo.CurrentValue Property

StatisticsSourceInfoCurrentValue Property

Latest value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double CurrentValue { get; set; }
public:
property double CurrentValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

StatisticsSourceInfo Class
VisualComponents.Create3D Namespace


StatisticsSourceInfo.Source Property

StatisticsSourceInfoSource Property

Associated source.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IStatisticsSource Source { get; set; }
public:
property IStatisticsSource^ Source {
    IStatisticsSource^ get ();
    void set (IStatisticsSource^ value);
}

Property Value

Type: IStatisticsSource
See Also

Reference

StatisticsSourceInfo Class
VisualComponents.Create3D Namespace


StatisticsSourceInfo.TitleAndValue Property

StatisticsSourceInfoTitleAndValue Property

Label text.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string TitleAndValue { get; set; }
public:
property String^ TitleAndValue {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

StatisticsSourceInfo Class
VisualComponents.Create3D Namespace


StatisticsSourceInfo.ToolTip Property

StatisticsSourceInfoToolTip Property

ToolTip for pie chart.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ToolTip { get; set; }
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

StatisticsSourceInfo Class
VisualComponents.Create3D Namespace


StatisticsSourceInfo Methods

The StatisticsSourceInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

StatisticsSourceInfo Class
VisualComponents.Create3D Namespace


StatusAddedEventArgs Class

Status message event arguments class.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DStatusAddedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class StatusAddedEventArgs : EventArgs
public ref class StatusAddedEventArgs : public EventArgs

The StatusAddedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | StatusAddedEventArgs | Initializing constructor
Top
Properties
 | Name | Description
Public property | StatusMessage | Localized status message string.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


StatusAddedEventArgs Constructor

Initializing constructor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StatusAddedEventArgs(
    string statusMessage
)
public:
StatusAddedEventArgs(
    String^ statusMessage
)

Parameters

statusMessage
Type: SystemString
Status message string
See Also

Reference

StatusAddedEventArgs Class
VisualComponents.Create3D Namespace


StatusAddedEventArgs Properties

The StatusAddedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | StatusMessage | Localized status message string.
Top
See Also

Reference

StatusAddedEventArgs Class
VisualComponents.Create3D Namespace


StatusAddedEventArgs.StatusMessage Property

StatusAddedEventArgsStatusMessage Property

Localized status message string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string StatusMessage { get; }
public:
property String^ StatusMessage {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

StatusAddedEventArgs Class
VisualComponents.Create3D Namespace


StatusAddedEventArgs Methods

The StatusAddedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

StatusAddedEventArgs Class
VisualComponents.Create3D Namespace


STEP Enumeration

STEP -> AP 203 E1/E2, AP 214, AP 242

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum STEP
public enum class STEP
Members
Member name | Value | Description
STP | 0 |
STEP | 1 |
STPZ | 2 |
See Also

Reference

VisualComponents.Create3D Namespace


STL Enumeration

STL (Stereo lithography file)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum STL
public enum class STL
Members
Member name | Value | Description
STL | 0 |
See Also

Reference

VisualComponents.Create3D Namespace


StringCipher Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DStringCipher

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class StringCipher
public ref class StringCipher abstract sealed

The StringCipher type exposes the following members.

Methods
Name | Description
Decrypt |
Encrypt |
Top
See Also

Reference

VisualComponents.Create3D Namespace


StringCipher Methods

The StringCipher type exposes the following members.

Methods
Name | Description
Decrypt |
Encrypt |
Top
See Also

Reference

StringCipher Class
VisualComponents.Create3D Namespace


StringCipher.Decrypt Method

StringCipherDecrypt Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string Decrypt(
    string cipherText,
    string passphrase
)
public:
static String^ Decrypt(
    String^ cipherText,
    String^ passphrase
)

Parameters

cipherText
Type: SystemString
passphrase
Type: SystemString

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.StringCipher.Decrypt(System.String,System.String)"]

See Also

Reference

StringCipher Class
VisualComponents.Create3D Namespace


StringCipher.Encrypt Method

StringCipherEncrypt Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string Encrypt(
    string plaintext,
    string passphrase
)
public:
static String^ Encrypt(
    String^ plaintext,
    String^ passphrase
)

Parameters

plaintext
Type: SystemString
passphrase
Type: SystemString

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.StringCipher.Encrypt(System.String,System.String)"]

See Also

Reference

StringCipher Class
VisualComponents.Create3D Namespace


SubInstallation Class

Information on sub installation
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DSubInstallation

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class SubInstallation
public ref class SubInstallation abstract sealed

The SubInstallation type exposes the following members.

Methods
Name | Description
GetInstallDirectory(String) | Queries installation directory
GetInstallDirectory(SubInstallationESubInstallationType) | Queries installation directory
GetPackageMainPluginAssembly | Gets package main assembly.
IsModuleInstalled(String, String) | Queries if module is installed.
IsModuleInstalled(SubInstallationESubInstallationType, String) | Queries if module is installed.
MainPluginLoadFile | Loads plugin specific file format. Return IntPtr of imported node.
Top
See Also

Reference

VisualComponents.Create3D Namespace


SubInstallation Methods

The SubInstallation type exposes the following members.

Methods
Name | Description
GetInstallDirectory(String) | Queries installation directory
GetInstallDirectory(SubInstallationESubInstallationType) | Queries installation directory
GetPackageMainPluginAssembly | Gets package main assembly.
IsModuleInstalled(String, String) | Queries if module is installed.
IsModuleInstalled(SubInstallationESubInstallationType, String) | Queries if module is installed.
MainPluginLoadFile | Loads plugin specific file format. Return IntPtr of imported node.
Top
See Also

Reference

SubInstallation Class
VisualComponents.Create3D Namespace


SubInstallation.GetInstallDirectory Method

SubInstallationGetInstallDirectory Method

Overload List
Name | Description
GetInstallDirectory(String) | Queries installation directory
GetInstallDirectory(SubInstallationESubInstallationType) | Queries installation directory
Top
See Also

Reference

SubInstallation Class
VisualComponents.Create3D Namespace


SubInstallation.GetInstallDirectory Method (String)

SubInstallationGetInstallDirectory Method (String)

Queries installation directory

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetInstallDirectory(
    string module
)
public:
static String^ GetInstallDirectory(
    String^ module
)

Parameters

module
Type: SystemString
Module to query

Return Value

Type: String
Installation directory
See Also

Reference

SubInstallation Class
GetInstallDirectory Overload
VisualComponents.Create3D Namespace


SubInstallation.GetInstallDirectory Method (SubInstallation.ESubInstallationType)

SubInstallationGetInstallDirectory Method (SubInstallationESubInstallationType)

Queries installation directory

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetInstallDirectory(
    SubInstallationESubInstallationType type
)
public:
static String^ GetInstallDirectory(
    SubInstallationESubInstallationType type
)

Parameters

type
Type: VisualComponents.Create3DSubInstallationESubInstallationType
Sub installation path to query

Return Value

Type: String
Installation directory
See Also

Reference

SubInstallation Class
GetInstallDirectory Overload
VisualComponents.Create3D Namespace


SubInstallation.GetPackageMainPluginAssembly Method

SubInstallationGetPackageMainPluginAssembly Method

Gets package main assembly.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Assembly GetPackageMainPluginAssembly(
    SubInstallationESubInstallationType type
)
public:
static Assembly^ GetPackageMainPluginAssembly(
    SubInstallationESubInstallationType type
)

Parameters

type
Type: VisualComponents.Create3DSubInstallationESubInstallationType

Return Value

Type: Assembly

[Missing <returns> documentation for "M:VisualComponents.Create3D.SubInstallation.GetPackageMainPluginAssembly(VisualComponents.Create3D.SubInstallation.ESubInstallationType)"]

See Also

Reference

SubInstallation Class
VisualComponents.Create3D Namespace


SubInstallation.IsModuleInstalled Method

SubInstallationIsModuleInstalled Method

Overload List
Name | Description
IsModuleInstalled(String, String) | Queries if module is installed.
IsModuleInstalled(SubInstallationESubInstallationType, String) | Queries if module is installed.
Top
See Also

Reference

SubInstallation Class
VisualComponents.Create3D Namespace


SubInstallation.IsModuleInstalled Method (String, String)

SubInstallationIsModuleInstalled Method (String, String)

Queries if module is installed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsModuleInstalled(
    string module,
    out string directory
)
public:
static bool IsModuleInstalled(
    String^ module,
    [OutAttribute] String^% directory
)

Parameters

module
Type: SystemString
Module name
directory
Type: SystemString
where installed

Return Value

Type: Boolean
true if installed, false if not
See Also

Reference

SubInstallation Class
IsModuleInstalled Overload
VisualComponents.Create3D Namespace


SubInstallation.IsModuleInstalled Method (SubInstallation.ESubInstallationType, String)

SubInstallationIsModuleInstalled Method (SubInstallationESubInstallationType, String)

Queries if module is installed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsModuleInstalled(
    SubInstallationESubInstallationType type,
    out string directory
)
public:
static bool IsModuleInstalled(
    SubInstallationESubInstallationType type,
    [OutAttribute] String^% directory
)

Parameters

type
Type: VisualComponents.Create3DSubInstallationESubInstallationType
Module
directory
Type: SystemString
where installed

Return Value

Type: Boolean
true if installed, false if not
See Also

Reference

SubInstallation Class
IsModuleInstalled Overload
VisualComponents.Create3D Namespace


SubInstallation.MainPluginLoadFile Method

SubInstallationMainPluginLoadFile Method

Loads plugin specific file format. Return IntPtr of imported node.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IntPtr MainPluginLoadFile(
    SubInstallationESubInstallationType type,
    string file
)
public:
static IntPtr MainPluginLoadFile(
    SubInstallationESubInstallationType type,
    String^ file
)

Parameters

type
Type: VisualComponents.Create3DSubInstallationESubInstallationType
Package/plugin
file
Type: SystemString
Model to load

Return Value

Type: IntPtr
Read node
See Also

Reference

SubInstallation Class
VisualComponents.Create3D Namespace


SubInstallation.ESubInstallationType Enumeration

SubInstallationESubInstallationType Enumeration

Available sub installations

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ESubInstallationType
public enum class ESubInstallationType
Members
Member name | Value | Description
RealDWG | 0 | Real dwg
HoopsExchangePublish | 1 | Hoops exchange publish
See Also

Reference

VisualComponents.Create3D Namespace


Surface Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DSurface

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class Surface
public ref class Surface

The Surface type exposes the following members.

Constructors
 | Name | Description
Public method | Surface | Initializes a new instance of the Surface class
Top
Properties
 | Name | Description
Public property | ControlPoints | Face control points
Public property | UDegree | Face U degree
Public property | UKnots | Face U knots
Public property | VDegree | Face V degree
Public property | Weights | Face control weights
Public property | VKnots | Face V knots
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


Surface Constructor

Initializes a new instance of the Surface class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Surface(
    int uDegree,
    int vDegree,
    ICollection<Vector3> controlPoints,
    ICollection<Tuple<double, int>> uKnots,
    ICollection<Tuple<double, int>> vKnots,
    ICollection<double> weights
)
public:
Surface(
    int uDegree,
    int vDegree,
    ICollection<Vector3>^ controlPoints,
    ICollection<Tuple<double, int>^>^ uKnots,
    ICollection<Tuple<double, int>^>^ vKnots,
    ICollection<double>^ weights
)

Parameters

uDegree
Type: SystemInt32
vDegree
Type: SystemInt32
controlPoints
Type: System.Collections.GenericICollectionVector3
uKnots
Type: System.Collections.GenericICollectionTupleDouble, Int32
vKnots
Type: System.Collections.GenericICollectionTupleDouble, Int32
weights
Type: System.Collections.GenericICollectionDouble
See Also

Reference

Surface Class
VisualComponents.Create3D Namespace


Surface Properties

The Surface type exposes the following members.

Properties
 | Name | Description
Public property | ControlPoints | Face control points
Public property | UDegree | Face U degree
Public property | UKnots | Face U knots
Public property | VDegree | Face V degree
Public property | Weights | Face control weights
Public property | VKnots | Face V knots
Top
See Also

Reference

Surface Class
VisualComponents.Create3D Namespace


Surface.ControlPoints Property

SurfaceControlPoints Property

Face control points

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<Vector3> ControlPoints { get; }
public:
property ReadOnlyCollection<Vector3>^ ControlPoints {
    ReadOnlyCollection<Vector3>^ get ();
}

Property Value

Type: ReadOnlyCollectionVector3
See Also

Reference

Surface Class
VisualComponents.Create3D Namespace


Surface.UDegree Property

SurfaceUDegree Property

Face U degree

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int UDegree { get; }
public:
property int UDegree {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

Surface Class
VisualComponents.Create3D Namespace


Surface.UKnots Property

SurfaceUKnots Property

Face U knots

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<Tuple<double, int>> UKnots { get; }
public:
property ReadOnlyCollection<Tuple<double, int>^>^ UKnots {
    ReadOnlyCollection<Tuple<double, int>^>^ get ();
}

Property Value

Type: ReadOnlyCollectionTupleDouble, Int32
See Also

Reference

Surface Class
VisualComponents.Create3D Namespace


Surface.VDegree Property

SurfaceVDegree Property

Face V degree

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int VDegree { get; }
public:
property int VDegree {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

Surface Class
VisualComponents.Create3D Namespace


Surface.Weights Property

SurfaceWeights Property

Face control weights

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<double> Weights { get; }
public:
property ReadOnlyCollection<double>^ Weights {
    ReadOnlyCollection<double>^ get ();
}

Property Value

Type: ReadOnlyCollectionDouble
See Also

Reference

Surface Class
VisualComponents.Create3D Namespace


Surface.VKnots Property

SurfaceVKnots Property

Face V knots

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<Tuple<double, int>> VKnots { get; }
public:
property ReadOnlyCollection<Tuple<double, int>^>^ VKnots {
    ReadOnlyCollection<Tuple<double, int>^>^ get ();
}

Property Value

Type: ReadOnlyCollectionTupleDouble, Int32
See Also

Reference

Surface Class
VisualComponents.Create3D Namespace


Surface Methods

The Surface type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

Surface Class
VisualComponents.Create3D Namespace


SurfaceGeometric Structure

various geometric surface properties

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct SurfaceGeometric
public value class SurfaceGeometric

The SurfaceGeometric type exposes the following members.

Constructors
 | Name | Description
Public method | SurfaceGeometric | Initializes a new instance of the SurfaceGeometric class
Top
Properties
 | Name | Description
Public property | FirstFundamental |
Public property | FirstPrincipalCurvature |
Public property | GaussianCurvature |
Public property | MeanCurvature |
Public property | SecondFundamental |
Public property | SecondPrincipalCurvature |
Public property | TangentAlongFirstPrincipal |
Public property | TangentAlongSecondPrincipal |
Top
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides ValueTypeEquals(Object).)
 | Equals(SurfaceGeometric, SurfaceGeometric) |
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Equality |
Inequality |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


SurfaceGeometric Constructor

Initializes a new instance of the SurfaceGeometric class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SurfaceGeometric(
    double gaussianCurvature,
    double meanCurvature,
    double firstPrincipalCurvature,
    double secondPrincipalCurvature,
    Vector3 firstFundamental,
    Vector3 secondFundamental,
    Vector3 tangentAlongFirstPrincipal,
    Vector3 tangentAlongSecondPrincipal
)
public:
SurfaceGeometric(
    double gaussianCurvature,
    double meanCurvature,
    double firstPrincipalCurvature,
    double secondPrincipalCurvature,
    Vector3 firstFundamental,
    Vector3 secondFundamental,
    Vector3 tangentAlongFirstPrincipal,
    Vector3 tangentAlongSecondPrincipal
)

Parameters

gaussianCurvature
Type: SystemDouble
meanCurvature
Type: SystemDouble
firstPrincipalCurvature
Type: SystemDouble
secondPrincipalCurvature
Type: SystemDouble
firstFundamental
Type: VisualComponents.Create3DVector3
secondFundamental
Type: VisualComponents.Create3DVector3
tangentAlongFirstPrincipal
Type: VisualComponents.Create3DVector3
tangentAlongSecondPrincipal
Type: VisualComponents.Create3DVector3
See Also

Reference

SurfaceGeometric Structure
VisualComponents.Create3D Namespace


SurfaceGeometric Properties

The SurfaceGeometric type exposes the following members.

Properties
 | Name | Description
Public property | FirstFundamental |
Public property | FirstPrincipalCurvature |
Public property | GaussianCurvature |
Public property | MeanCurvature |
Public property | SecondFundamental |
Public property | SecondPrincipalCurvature |
Public property | TangentAlongFirstPrincipal |
Public property | TangentAlongSecondPrincipal |
Top
See Also

Reference

SurfaceGeometric Structure
VisualComponents.Create3D Namespace


SurfaceGeometric.FirstFundamental Property

SurfaceGeometricFirstFundamental Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 FirstFundamental { get; set; }
public:
property Vector3 FirstFundamental {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

SurfaceGeometric Structure
VisualComponents.Create3D Namespace


SurfaceGeometric.FirstPrincipalCurvature Property

SurfaceGeometricFirstPrincipalCurvature Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double FirstPrincipalCurvature { get; set; }
public:
property double FirstPrincipalCurvature {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

SurfaceGeometric Structure
VisualComponents.Create3D Namespace


SurfaceGeometric.GaussianCurvature Property

SurfaceGeometricGaussianCurvature Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double GaussianCurvature { get; set; }
public:
property double GaussianCurvature {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

SurfaceGeometric Structure
VisualComponents.Create3D Namespace


SurfaceGeometric.MeanCurvature Property

SurfaceGeometricMeanCurvature Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double MeanCurvature { get; set; }
public:
property double MeanCurvature {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

SurfaceGeometric Structure
VisualComponents.Create3D Namespace


SurfaceGeometric.SecondFundamental Property

SurfaceGeometricSecondFundamental Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 SecondFundamental { get; set; }
public:
property Vector3 SecondFundamental {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

SurfaceGeometric Structure
VisualComponents.Create3D Namespace


SurfaceGeometric.SecondPrincipalCurvature Property

SurfaceGeometricSecondPrincipalCurvature Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double SecondPrincipalCurvature { get; set; }
public:
property double SecondPrincipalCurvature {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

SurfaceGeometric Structure
VisualComponents.Create3D Namespace


SurfaceGeometric.TangentAlongFirstPrincipal Property

SurfaceGeometricTangentAlongFirstPrincipal Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 TangentAlongFirstPrincipal { get; set; }
public:
property Vector3 TangentAlongFirstPrincipal {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

SurfaceGeometric Structure
VisualComponents.Create3D Namespace


SurfaceGeometric.TangentAlongSecondPrincipal Property

SurfaceGeometricTangentAlongSecondPrincipal Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 TangentAlongSecondPrincipal { get; set; }
public:
property Vector3 TangentAlongSecondPrincipal {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

SurfaceGeometric Structure
VisualComponents.Create3D Namespace


SurfaceGeometric Methods

The SurfaceGeometric type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | (Overrides ValueTypeEquals(Object).)
 | Equals(SurfaceGeometric, SurfaceGeometric) |
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SurfaceGeometric Structure
VisualComponents.Create3D Namespace


SurfaceGeometric.Equals Method

SurfaceGeometricEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ValueTypeEquals(Object).)
 | Equals(SurfaceGeometric, SurfaceGeometric) |
Top
See Also

Reference

SurfaceGeometric Structure
VisualComponents.Create3D Namespace


SurfaceGeometric.Equals Method (Object)

SurfaceGeometricEquals Method (Object)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.SurfaceGeometric.Equals(System.Object)"]

See Also

Reference

SurfaceGeometric Structure
Equals Overload
VisualComponents.Create3D Namespace


SurfaceGeometric.Equals Method (SurfaceGeometric, SurfaceGeometric)

SurfaceGeometricEquals Method (SurfaceGeometric, SurfaceGeometric)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool Equals(
    SurfaceGeometric value1,
    SurfaceGeometric value2
)
public:
static bool Equals(
    SurfaceGeometric value1,
    SurfaceGeometric value2
)

Parameters

value1
Type: VisualComponents.Create3DSurfaceGeometric
value2
Type: VisualComponents.Create3DSurfaceGeometric

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.SurfaceGeometric.Equals(VisualComponents.Create3D.SurfaceGeometric,VisualComponents.Create3D.SurfaceGeometric)"]

See Also

Reference

SurfaceGeometric Structure
Equals Overload
VisualComponents.Create3D Namespace


SurfaceGeometric.GetHashCode Method

SurfaceGeometricGetHashCode Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.SurfaceGeometric.GetHashCode"]

See Also

Reference

SurfaceGeometric Structure
VisualComponents.Create3D Namespace


SurfaceGeometric Operators

The SurfaceGeometric type exposes the following members.

Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

SurfaceGeometric Structure
VisualComponents.Create3D Namespace


SurfaceGeometric.Equality Operator

SurfaceGeometricEquality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    SurfaceGeometric value1,
    SurfaceGeometric value2
)
public:
static bool operator ==(
    SurfaceGeometric value1,
    SurfaceGeometric value2
)

Parameters

value1
Type: VisualComponents.Create3DSurfaceGeometric
value2
Type: VisualComponents.Create3DSurfaceGeometric

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.SurfaceGeometric.op_Equality(VisualComponents.Create3D.SurfaceGeometric,VisualComponents.Create3D.SurfaceGeometric)"]

See Also

Reference

SurfaceGeometric Structure
VisualComponents.Create3D Namespace


SurfaceGeometric.Inequality Operator

SurfaceGeometricInequality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    SurfaceGeometric value1,
    SurfaceGeometric value2
)
public:
static bool operator !=(
    SurfaceGeometric value1,
    SurfaceGeometric value2
)

Parameters

value1
Type: VisualComponents.Create3DSurfaceGeometric
value2
Type: VisualComponents.Create3DSurfaceGeometric

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.SurfaceGeometric.op_Inequality(VisualComponents.Create3D.SurfaceGeometric,VisualComponents.Create3D.SurfaceGeometric)"]

See Also

Reference

SurfaceGeometric Structure
VisualComponents.Create3D Namespace


SweptVolumeMethod Enumeration

Enumeration for the method to be used when doing the swept volume.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum SweptVolumeMethod
public enum class SweptVolumeMethod
Members
Member name | Value | Description
Lofting | 0 | Works for movements requiring small changes (small rotational and directional changes like linear motions).
HullFromHulls | 1 | Creates internal faces and produces more points.
HullFromSilhouettes | 2 | Intermediate method between small and complex movements.
See Also

Reference

VisualComponents.Create3D Namespace


SweptVolumeRepresentation Enumeration

Enumeration for how the list node will be represented when doing the swept volume.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum SweptVolumeRepresentation
public enum class SweptVolumeRepresentation
Members
Member name | Value | Description
ConvexHull | 0 | One convex hull. Sacrificing accuracy in the swept volume if a selected node is of non-convex shape.
Decomposition | 1 | Convex decomposition (one or more convex hulls) Slower depending on size and complexity of node(s), and additional convex hull can slow processing, yet accuracy is improved.
ConvexHullPerMesh | 2 | Convex hull of each triangle mesh for each node in list; used when a pre-decomposition has been made. Speed rate and accuracy in between values ConvexHull and Decomposition, in terms of performance.
See Also

Reference

VisualComponents.Create3D Namespace


TargetMode Enumeration

Target matrix relationship with a robot.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum TargetMode
public enum class TargetMode
Members
Member name | Value | Description
Normal | 0 | The target matrix uses a default or normal type of relationship with a robot. To convert world coordinates to TargetMatrix use: var relative_coordinates_matrix = MotionTarget.WorldBaseMatrix2.Inverse() * world_coordinates_matrix; MotionTarget.TargetMatrix = relative_coordinates_matrix;
RobotRoot | 1 | The target matrix relates to a robot's root node.
StaticTool | 2 | The target matrix relates to a robot's static tool.
ExternalBase | 3 | The target matrix relates to an external base in relation to a robot.
World | 4 | The target matrix is defined in world coordinates. Note: Activating this mode also clears the Base-selection in Jog panel. Note: Position frames can't use this mode. Their coordinates can only be relative robot's world, not whole world.
See Also

Reference

VisualComponents.Create3D Namespace


TessellationDetail Enumeration

CAD import tessellation detail quality

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum TessellationDetail
public enum class TessellationDetail
Members
Member name | Value | Description
ExtraLow | 0 | Lowest tessellation level
Low | 1 | Low tessellation level
Medium | 2 | Medium tessellation level
High | 3 | High tessellation level
ExtraHigh | 4 | Extra High tessellation level
Remarks
Please add localization strings if you happen to modify this enum. String keys should have format: "TessellationQuality" + enum_member Examples: "TesselationQualityExtraLow", "TessellationQualityMedium"
See Also

Reference

VisualComponents.Create3D Namespace


TexturePoint Structure

Represents a u,v texture coordinate point

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct TexturePoint
public value class TexturePoint

The TexturePoint type exposes the following members.

Constructors
 | Name | Description
Public method | TexturePoint | Creates a new instance of texture point struct.
Top
Properties
 | Name | Description
Public property | U | Gets or sets the U coordinate value
Public property | V | Gets or sets the V coordinate value
Top
Methods
 | Name | Description
Public method | Equals | Compares two TexturePoint instances for equality (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Gets a hash code for this structure (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Equality | Compares two TexturePoint instances for equality
Inequality | Compares two TexturePoint instances for inequality
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


TexturePoint Constructor

Creates a new instance of texture point struct.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TexturePoint(
    double u,
    double v
)
public:
TexturePoint(
    double u,
    double v
)

Parameters

u
Type: SystemDouble
U coordinate value
v
Type: SystemDouble
V coorindate value
See Also

Reference

TexturePoint Structure
VisualComponents.Create3D Namespace


TexturePoint Properties

The TexturePoint type exposes the following members.

Properties
 | Name | Description
Public property | U | Gets or sets the U coordinate value
Public property | V | Gets or sets the V coordinate value
Top
See Also

Reference

TexturePoint Structure
VisualComponents.Create3D Namespace


TexturePoint.U Property

TexturePointU Property

Gets or sets the U coordinate value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double U { get; set; }
public:
property double U {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

TexturePoint Structure
VisualComponents.Create3D Namespace


TexturePoint.V Property

TexturePointV Property

Gets or sets the V coordinate value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double V { get; set; }
public:
property double V {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

TexturePoint Structure
VisualComponents.Create3D Namespace


TexturePoint Methods

The TexturePoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares two TexturePoint instances for equality (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Gets a hash code for this structure (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TexturePoint Structure
VisualComponents.Create3D Namespace


TexturePoint.Equals Method

TexturePointEquals Method

Compares two TexturePoint instances for equality

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
The vector to compare

Return Value

Type: Boolean
True if obj is identical with this vector; false otherwise.
See Also

Reference

TexturePoint Structure
VisualComponents.Create3D Namespace


TexturePoint.GetHashCode Method

TexturePointGetHashCode Method

Gets a hash code for this structure

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32
Hash code
See Also

Reference

TexturePoint Structure
VisualComponents.Create3D Namespace


TexturePoint Operators

The TexturePoint type exposes the following members.

Operators
Name | Description
Equality | Compares two TexturePoint instances for equality
Inequality | Compares two TexturePoint instances for inequality
Top
See Also

Reference

TexturePoint Structure
VisualComponents.Create3D Namespace


TexturePoint.Equality Operator

TexturePointEquality Operator

Compares two TexturePoint instances for equality

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    TexturePoint vector1,
    TexturePoint vector2
)
public:
static bool operator ==(
    TexturePoint vector1,
    TexturePoint vector2
)

Parameters

vector1
Type: VisualComponents.Create3DTexturePoint
The first vector to compare
vector2
Type: VisualComponents.Create3DTexturePoint
The second vector to compare against

Return Value

Type: Boolean
True if the vectors are identical; false otherwise.
See Also

Reference

TexturePoint Structure
VisualComponents.Create3D Namespace


TexturePoint.Inequality Operator

TexturePointInequality Operator

Compares two TexturePoint instances for inequality

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    TexturePoint vector1,
    TexturePoint vector2
)
public:
static bool operator !=(
    TexturePoint vector1,
    TexturePoint vector2
)

Parameters

vector1
Type: VisualComponents.Create3DTexturePoint
The first vector to compare
vector2
Type: VisualComponents.Create3DTexturePoint
The second vector to compare against

Return Value

Type: Boolean
True if the vectors are inequal, false otherwise
See Also

Reference

TexturePoint Structure
VisualComponents.Create3D Namespace


ThemeChangedEventArgs Class

Theme changed event arguments.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DThemeChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ThemeChangedEventArgs : EventArgs
public ref class ThemeChangedEventArgs : public EventArgs

The ThemeChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ThemeChangedEventArgs | constructor.
Top
Properties
 | Name | Description
Public property | MainForeground | The main theme foreground.
Public property | Theme | The theme name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ThemeChangedEventArgs Constructor

constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ThemeChangedEventArgs(
    string theme,
    SolidColorBrush mainForeground
)
public:
ThemeChangedEventArgs(
    String^ theme,
    SolidColorBrush^ mainForeground
)

Parameters

theme
Type: SystemString
the theme name
mainForeground
Type: System.Windows.MediaSolidColorBrush
main foreground color brush.
See Also

Reference

ThemeChangedEventArgs Class
VisualComponents.Create3D Namespace


ThemeChangedEventArgs Properties

The ThemeChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | MainForeground | The main theme foreground.
Public property | Theme | The theme name.
Top
See Also

Reference

ThemeChangedEventArgs Class
VisualComponents.Create3D Namespace


ThemeChangedEventArgs.MainForeground Property

ThemeChangedEventArgsMainForeground Property

The main theme foreground.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SolidColorBrush MainForeground { get; protected set; }
public:
property SolidColorBrush^ MainForeground {
    SolidColorBrush^ get ();
    protected: void set (SolidColorBrush^ value);
}

Property Value

Type: SolidColorBrush
See Also

Reference

ThemeChangedEventArgs Class
VisualComponents.Create3D Namespace


ThemeChangedEventArgs.Theme Property

ThemeChangedEventArgsTheme Property

The theme name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Theme { get; protected set; }
public:
property String^ Theme {
    String^ get ();
    protected: void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ThemeChangedEventArgs Class
VisualComponents.Create3D Namespace


ThemeChangedEventArgs Methods

The ThemeChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ThemeChangedEventArgs Class
VisualComponents.Create3D Namespace


ThreadSafeGC Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DThreadSafeGC

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class ThreadSafeGC
public ref class ThreadSafeGC abstract sealed

The ThreadSafeGC type exposes the following members.

Methods
Name | Description
FlushPendingGC |
FlushPendingGC(Int32) |
InitSafeGC |
SafeDispose(IDisposable) |
SafeDispose(IDisposable, Boolean) |
Top
See Also

Reference

VisualComponents.Create3D Namespace


ThreadSafeGC Methods

The ThreadSafeGC type exposes the following members.

Methods
Name | Description
FlushPendingGC |
FlushPendingGC(Int32) |
InitSafeGC |
SafeDispose(IDisposable) |
SafeDispose(IDisposable, Boolean) |
Top
See Also

Reference

ThreadSafeGC Class
VisualComponents.Create3D Namespace


ThreadSafeGC.FlushPendingGC Method

ThreadSafeGCFlushPendingGC Method

Overload List
Name | Description
FlushPendingGC |
FlushPendingGC(Int32) |
Top
See Also

Reference

ThreadSafeGC Class
VisualComponents.Create3D Namespace


ThreadSafeGC.FlushPendingGC Method

ThreadSafeGCFlushPendingGC Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void FlushPendingGC()
public:
static void FlushPendingGC()
See Also

Reference

ThreadSafeGC Class
FlushPendingGC Overload
VisualComponents.Create3D Namespace


ThreadSafeGC.FlushPendingGC Method (Int32)

ThreadSafeGCFlushPendingGC Method (Int32)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void FlushPendingGC(
    int maxCount
)
public:
static void FlushPendingGC(
    int maxCount
)

Parameters

maxCount
Type: SystemInt32
See Also

Reference

ThreadSafeGC Class
FlushPendingGC Overload
VisualComponents.Create3D Namespace


ThreadSafeGC.InitSafeGC Method

ThreadSafeGCInitSafeGC Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void InitSafeGC()
public:
static void InitSafeGC()
See Also

Reference

ThreadSafeGC Class
VisualComponents.Create3D Namespace


ThreadSafeGC.SafeDispose Method

ThreadSafeGCSafeDispose Method

Overload List
Name | Description
SafeDispose(IDisposable) |
SafeDispose(IDisposable, Boolean) |
Top
See Also

Reference

ThreadSafeGC Class
VisualComponents.Create3D Namespace


ThreadSafeGC.SafeDispose Method (IDisposable)

ThreadSafeGCSafeDispose Method (IDisposable)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SafeDispose(
    IDisposable item
)
public:
static void SafeDispose(
    IDisposable^ item
)

Parameters

item
Type: SystemIDisposable
See Also

Reference

ThreadSafeGC Class
SafeDispose Overload
VisualComponents.Create3D Namespace


ThreadSafeGC.SafeDispose Method (IDisposable, Boolean)

ThreadSafeGCSafeDispose Method (IDisposable, Boolean)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SafeDispose(
    IDisposable item,
    bool immediateIfInMain
)
public:
static void SafeDispose(
    IDisposable^ item,
    bool immediateIfInMain
)

Parameters

item
Type: SystemIDisposable
immediateIfInMain
Type: SystemBoolean
See Also

Reference

ThreadSafeGC Class
SafeDispose Overload
VisualComponents.Create3D Namespace


TimerResultUpdatedEventArgs Class

Provides data for TargetReached event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DTimerResultUpdatedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TimerResultUpdatedEventArgs : EventArgs
public ref class TimerResultUpdatedEventArgs : public EventArgs

The TimerResultUpdatedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TimerResultUpdatedEventArgs | Initializes a new instance of TimerResultUpdatedEventArgs.
Top
Properties
 | Name | Description
Public property | Statement | Gets the statement.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


TimerResultUpdatedEventArgs Constructor

Initializes a new instance of TimerResultUpdatedEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TimerResultUpdatedEventArgs(
    ITimerStatement statement
)
public:
TimerResultUpdatedEventArgs(
    ITimerStatement^ statement
)

Parameters

statement
Type: VisualComponents.Create3DITimerStatement
See Also

Reference

TimerResultUpdatedEventArgs Class
VisualComponents.Create3D Namespace


TimerResultUpdatedEventArgs Properties

The TimerResultUpdatedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Statement | Gets the statement.
Top
See Also

Reference

TimerResultUpdatedEventArgs Class
VisualComponents.Create3D Namespace


TimerResultUpdatedEventArgs.Statement Property

TimerResultUpdatedEventArgsStatement Property

Gets the statement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ITimerStatement Statement { get; }
public:
property ITimerStatement^ Statement {
    ITimerStatement^ get ();
}

Property Value

Type: ITimerStatement
See Also

Reference

TimerResultUpdatedEventArgs Class
VisualComponents.Create3D Namespace


TimerResultUpdatedEventArgs Methods

The TimerResultUpdatedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TimerResultUpdatedEventArgs Class
VisualComponents.Create3D Namespace


TimerStatementMode Enumeration

The mode a ITimerStatement will be used in.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum TimerStatementMode
public enum class TimerStatementMode
Members
Member name | Value | Description
Reset | 0 | Indicates that this statement will reset the timer.
Start | 1 | Indicates that this statement will start the timer.
Stop | 2 | Indicates that this statement will stop the timer.
See Also

Reference

VisualComponents.Create3D Namespace


ToggleEcatIndexingMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DToggleEcatIndexingMessage

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ToggleEcatIndexingMessage
public ref class ToggleEcatIndexingMessage sealed

The ToggleEcatIndexingMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ToggleEcatIndexingMessage | Initializes a new instance of the ToggleEcatIndexingMessage class
Top
Properties
 | Name | Description
Public property | Enable |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ToggleEcatIndexingMessage Constructor

Initializes a new instance of the ToggleEcatIndexingMessage class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ToggleEcatIndexingMessage()
public:
ToggleEcatIndexingMessage()
See Also

Reference

ToggleEcatIndexingMessage Class
VisualComponents.Create3D Namespace


ToggleEcatIndexingMessage Properties

The ToggleEcatIndexingMessage type exposes the following members.

Properties
 | Name | Description
Public property | Enable |
Top
See Also

Reference

ToggleEcatIndexingMessage Class
VisualComponents.Create3D Namespace


ToggleEcatIndexingMessage.Enable Property

ToggleEcatIndexingMessageEnable Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Enable { get; set; }
public:
property bool Enable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ToggleEcatIndexingMessage Class
VisualComponents.Create3D Namespace


ToggleEcatIndexingMessage Methods

The ToggleEcatIndexingMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ToggleEcatIndexingMessage Class
VisualComponents.Create3D Namespace


Topic Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DTopic

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class Topic
public ref class Topic

The Topic type exposes the following members.

Constructors
 | Name | Description
Public method | Topic | Initializes a new instance of the Topic class
Top
Properties
 | Name | Description
Public property | Content |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


Topic Constructor

Initializes a new instance of the Topic class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Topic()
public:
Topic()
See Also

Reference

Topic Class
VisualComponents.Create3D Namespace


Topic Properties

The Topic type exposes the following members.

Properties
 | Name | Description
Public property | Content |
Top
See Also

Reference

Topic Class
VisualComponents.Create3D Namespace


Topic.Content Property

TopicContent Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Content { get; set; }
public:
property String^ Content {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Topic Class
VisualComponents.Create3D Namespace


Topic Methods

The Topic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

Topic Class
VisualComponents.Create3D Namespace


TraceFrame Structure

Python trace frame struct.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct TraceFrame
public value class TraceFrame

The TraceFrame type exposes the following members.

Properties
 | Name | Description
Public property | BlockIndex | Loop/try-except block depth in current function.
Public property | CurrentLineNumber | Line number in current function.
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


TraceFrame Properties

The TraceFrame type exposes the following members.

Properties
 | Name | Description
Public property | BlockIndex | Loop/try-except block depth in current function.
Public property | CurrentLineNumber | Line number in current function.
Top
See Also

Reference

TraceFrame Structure
VisualComponents.Create3D Namespace


TraceFrame.BlockIndex Property

TraceFrameBlockIndex Property

Loop/try-except block depth in current function.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int BlockIndex { get; set; }
public:
property int BlockIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

TraceFrame Structure
VisualComponents.Create3D Namespace


TraceFrame.CurrentLineNumber Property

TraceFrameCurrentLineNumber Property

Line number in current function.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CurrentLineNumber { get; set; }
public:
property int CurrentLineNumber {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

TraceFrame Structure
VisualComponents.Create3D Namespace


TraceFrame Methods

The TraceFrame type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TraceFrame Structure
VisualComponents.Create3D Namespace


TraceStep Enumeration

Python trace event type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum TraceStep
public enum class TraceStep
Members
Member name | Value | Description
Call | 0 | Python function call started, or Python main block entered.
Exception | 1 | Python exception occurred.
Line | 2 | Line number changed.
Return | 3 | Python function call ended with no error.
CCall | 4 | C function call started.
CException | 5 | C function call raised exception.
CReturn | 6 | C function call ended with no error.
Unknown | -1 | Unknown type.
Remarks

This is mapped directly from the PyTrace_XXX constants.

See Also

Reference

VisualComponents.Create3D Namespace


TrajectoryNode Structure

Trajectory node structure.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct TrajectoryNode
public value class TrajectoryNode

The TrajectoryNode type exposes the following members.

Properties
 | Name | Description
Public property | LogicalPosition | Gets or setts the logical position of the trajectory node.
Public property | Position | Gets or sets the position matrix of the trajectory node.
Public property | SegmentIndex | Gets or sets the index of the segment owning the trajectory node.
Top
Methods
 | Name | Description
Public method | Equals | Checks for object equality. (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Gets the hash code of this trajectory node. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Equality | Compares the objects for equality.
Inequality | Compares the objects for inequality.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


TrajectoryNode Properties

The TrajectoryNode type exposes the following members.

Properties
 | Name | Description
Public property | LogicalPosition | Gets or setts the logical position of the trajectory node.
Public property | Position | Gets or sets the position matrix of the trajectory node.
Public property | SegmentIndex | Gets or sets the index of the segment owning the trajectory node.
Top
See Also

Reference

TrajectoryNode Structure
VisualComponents.Create3D Namespace


TrajectoryNode.LogicalPosition Property

TrajectoryNodeLogicalPosition Property

Gets or setts the logical position of the trajectory node.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double LogicalPosition { get; set; }
public:
property double LogicalPosition {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

TrajectoryNode Structure
VisualComponents.Create3D Namespace


TrajectoryNode.Position Property

TrajectoryNodePosition Property

Gets or sets the position matrix of the trajectory node.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Matrix Position { get; set; }
public:
property Matrix Position {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

TrajectoryNode Structure
VisualComponents.Create3D Namespace


TrajectoryNode.SegmentIndex Property

TrajectoryNodeSegmentIndex Property

Gets or sets the index of the segment owning the trajectory node.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int SegmentIndex { get; set; }
public:
property int SegmentIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

TrajectoryNode Structure
VisualComponents.Create3D Namespace


TrajectoryNode Methods

The TrajectoryNode type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Checks for object equality. (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Gets the hash code of this trajectory node. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TrajectoryNode Structure
VisualComponents.Create3D Namespace


TrajectoryNode.Equals Method

TrajectoryNodeEquals Method

Checks for object equality.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
Object to check.

Return Value

Type: Boolean
True if the object is equal.
See Also

Reference

TrajectoryNode Structure
VisualComponents.Create3D Namespace


TrajectoryNode.GetHashCode Method

TrajectoryNodeGetHashCode Method

Gets the hash code of this trajectory node.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.TrajectoryNode.GetHashCode"]

See Also

Reference

TrajectoryNode Structure
VisualComponents.Create3D Namespace


TrajectoryNode Operators

The TrajectoryNode type exposes the following members.

Operators
Name | Description
Equality | Compares the objects for equality.
Inequality | Compares the objects for inequality.
Top
See Also

Reference

TrajectoryNode Structure
VisualComponents.Create3D Namespace


TrajectoryNode.Equality Operator

TrajectoryNodeEquality Operator

Compares the objects for equality.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    TrajectoryNode nodeA,
    TrajectoryNode nodeB
)
public:
static bool operator ==(
    TrajectoryNode nodeA,
    TrajectoryNode nodeB
)

Parameters

nodeA
Type: VisualComponents.Create3DTrajectoryNode
Node A
nodeB
Type: VisualComponents.Create3DTrajectoryNode
Node B

Return Value

Type: Boolean
True if the objects are equal.
See Also

Reference

TrajectoryNode Structure
VisualComponents.Create3D Namespace


TrajectoryNode.Inequality Operator

TrajectoryNodeInequality Operator

Compares the objects for inequality.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    TrajectoryNode nodeA,
    TrajectoryNode nodeB
)
public:
static bool operator !=(
    TrajectoryNode nodeA,
    TrajectoryNode nodeB
)

Parameters

nodeA
Type: VisualComponents.Create3DTrajectoryNode
Node A
nodeB
Type: VisualComponents.Create3DTrajectoryNode
Node B

Return Value

Type: Boolean
True if the objects are inequal.
See Also

Reference

TrajectoryNode Structure
VisualComponents.Create3D Namespace


TransparencyQuality Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum TransparencyQuality
public enum class TransparencyQuality
Members
Member name | Value | Description
None | 0 |
OnePeel | 1 |
TwoPeels | 2 |
FourPeels | 3 |
See Also

Reference

VisualComponents.Create3D Namespace


TransportControllerAddedEventArgs Class

Provides data for TransportControllerAdded event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DTransportControllerAddedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TransportControllerAddedEventArgs : EventArgs
public ref class TransportControllerAddedEventArgs : public EventArgs

The TransportControllerAddedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TransportControllerAddedEventArgs | Initializes a new instance of TransportControllerAddedEventArgs.
Top
Properties
 | Name | Description
Public property | TransportController | ITransportController that has been added.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


TransportControllerAddedEventArgs Constructor

Initializes a new instance of TransportControllerAddedEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TransportControllerAddedEventArgs(
    ITransportController controller
)
public:
TransportControllerAddedEventArgs(
    ITransportController^ controller
)

Parameters

controller
Type: VisualComponents.Create3DITransportController
ITransportController that has been added.
See Also

Reference

TransportControllerAddedEventArgs Class
VisualComponents.Create3D Namespace


TransportControllerAddedEventArgs Properties

The TransportControllerAddedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | TransportController | ITransportController that has been added.
Top
See Also

Reference

TransportControllerAddedEventArgs Class
VisualComponents.Create3D Namespace


TransportControllerAddedEventArgs.TransportController Property

TransportControllerAddedEventArgsTransportController Property

ITransportController that has been added.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ITransportController TransportController { get; }
public:
property ITransportController^ TransportController {
    ITransportController^ get ();
}

Property Value

Type: ITransportController
See Also

Reference

TransportControllerAddedEventArgs Class
VisualComponents.Create3D Namespace


TransportControllerAddedEventArgs Methods

The TransportControllerAddedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TransportControllerAddedEventArgs Class
VisualComponents.Create3D Namespace


TransportControllerRemovingEventArgs Class

Provides data for TransportControllerRemoving event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DTransportControllerRemovingEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TransportControllerRemovingEventArgs : EventArgs
public ref class TransportControllerRemovingEventArgs : public EventArgs

The TransportControllerRemovingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TransportControllerRemovingEventArgs | Initializes a new instance of TransportControllerRemovingEventArgs.
Top
Properties
 | Name | Description
Public property | TransportController | Transport controller that is being removed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


TransportControllerRemovingEventArgs Constructor

Initializes a new instance of TransportControllerRemovingEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TransportControllerRemovingEventArgs(
    ITransportController controller
)
public:
TransportControllerRemovingEventArgs(
    ITransportController^ controller
)

Parameters

controller
Type: VisualComponents.Create3DITransportController
Transport controller that is being removed.
See Also

Reference

TransportControllerRemovingEventArgs Class
VisualComponents.Create3D Namespace


TransportControllerRemovingEventArgs Properties

The TransportControllerRemovingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | TransportController | Transport controller that is being removed.
Top
See Also

Reference

TransportControllerRemovingEventArgs Class
VisualComponents.Create3D Namespace


TransportControllerRemovingEventArgs.TransportController Property

TransportControllerRemovingEventArgsTransportController Property

Transport controller that is being removed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ITransportController TransportController { get; }
public:
property ITransportController^ TransportController {
    ITransportController^ get ();
}

Property Value

Type: ITransportController
See Also

Reference

TransportControllerRemovingEventArgs Class
VisualComponents.Create3D Namespace


TransportControllerRemovingEventArgs Methods

The TransportControllerRemovingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TransportControllerRemovingEventArgs Class
VisualComponents.Create3D Namespace


TransportInType Enumeration

Options for product arrival for ITransportInStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum TransportInType
public enum class TransportInType
Members
Member name | Value | Description
FromPreviousProcess | 0 | Perform the operation using the transport system.
FromContainer | 1 | Perform the operation when a product arrives to a container.
See Also

Reference

VisualComponents.Create3D Namespace


TransportLinkAddedEventArgs Class

Provides data for TransportLinkAdded event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DTransportLinkAddedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TransportLinkAddedEventArgs : EventArgs
public ref class TransportLinkAddedEventArgs : public EventArgs

The TransportLinkAddedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TransportLinkAddedEventArgs | Initializes a new instance of TransportLinkAddedEventArgs.
Top
Properties
 | Name | Description
Public property | TransportLink | ITransportLink that has been added.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


TransportLinkAddedEventArgs Constructor

Initializes a new instance of TransportLinkAddedEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TransportLinkAddedEventArgs(
    ITransportLink link
)
public:
TransportLinkAddedEventArgs(
    ITransportLink^ link
)

Parameters

link
Type: VisualComponents.Create3DITransportLink
ITransportLink that has been added.
See Also

Reference

TransportLinkAddedEventArgs Class
VisualComponents.Create3D Namespace


TransportLinkAddedEventArgs Properties

The TransportLinkAddedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | TransportLink | ITransportLink that has been added.
Top
See Also

Reference

TransportLinkAddedEventArgs Class
VisualComponents.Create3D Namespace


TransportLinkAddedEventArgs.TransportLink Property

TransportLinkAddedEventArgsTransportLink Property

ITransportLink that has been added.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ITransportLink TransportLink { get; }
public:
property ITransportLink^ TransportLink {
    ITransportLink^ get ();
}

Property Value

Type: ITransportLink
See Also

Reference

TransportLinkAddedEventArgs Class
VisualComponents.Create3D Namespace


TransportLinkAddedEventArgs Methods

The TransportLinkAddedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TransportLinkAddedEventArgs Class
VisualComponents.Create3D Namespace


TransportLinkDeleteChange Class

Transport link deletion change memento class.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DChange
VisualComponents.Create3DTransportLinkDeleteChange

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TransportLinkDeleteChange : Change
public ref class TransportLinkDeleteChange : public Change

The TransportLinkDeleteChange type exposes the following members.

Constructors
 | Name | Description
Public method | TransportLinkDeleteChange | Initializing constructor.
Top
Properties
 | Name | Description
Protected property | Changeset | (Inherited from Change.)
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Protected property | TargetsList | Access to easier manipulation of targets in derived classes. (Inherited from Change.)
Top
Methods
 | Name | Description
Protected method | AddTarget | (Inherited from Change.)
Public method | Dispose | (Inherited from Change.)
Protected method | Dispose(Boolean) | (Inherited from Change.)
Protected method | DoRedo | Delete the link again. (Overrides ChangeDoRedo.)
Protected method | DoUndo | Recreate the deleted link. (Overrides ChangeDoUndo.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasValueChanged | (Inherited from Change.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


TransportLinkDeleteChange Constructor

Initializing constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TransportLinkDeleteChange(
    ITransportLink link
)
public:
TransportLinkDeleteChange(
    ITransportLink^ link
)

Parameters

link
Type: VisualComponents.Create3DITransportLink
Link that is about to be deleted.
See Also

Reference

TransportLinkDeleteChange Class
VisualComponents.Create3D Namespace


TransportLinkDeleteChange Properties

The TransportLinkDeleteChange type exposes the following members.

Properties
 | Name | Description
Protected property | Changeset | (Inherited from Change.)
Public property | Targets | Target object(s) for this change. (Inherited from Change.)
Protected property | TargetsList | Access to easier manipulation of targets in derived classes. (Inherited from Change.)
Top
See Also

Reference

TransportLinkDeleteChange Class
VisualComponents.Create3D Namespace


TransportLinkDeleteChange Methods

The TransportLinkDeleteChange type exposes the following members.

Methods
 | Name | Description
Protected method | AddTarget | (Inherited from Change.)
Public method | Dispose | (Inherited from Change.)
Protected method | Dispose(Boolean) | (Inherited from Change.)
Protected method | DoRedo | Delete the link again. (Overrides ChangeDoRedo.)
Protected method | DoUndo | Recreate the deleted link. (Overrides ChangeDoUndo.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasValueChanged | (Inherited from Change.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TransportLinkDeleteChange Class
VisualComponents.Create3D Namespace


TransportLinkDeleteChange.DoRedo Method

TransportLinkDeleteChangeDoRedo Method

Delete the link again.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void DoRedo()
protected:
virtual void DoRedo() override
See Also

Reference

TransportLinkDeleteChange Class
VisualComponents.Create3D Namespace


TransportLinkDeleteChange.DoUndo Method

TransportLinkDeleteChangeDoUndo Method

Recreate the deleted link.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void DoUndo()
protected:
virtual void DoUndo() override
See Also

Reference

TransportLinkDeleteChange Class
VisualComponents.Create3D Namespace


TransportLinkRemovedEventArgs Class

Provides data for TransportLinkRemoved event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DTransportLinkRemovedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TransportLinkRemovedEventArgs : EventArgs
public ref class TransportLinkRemovedEventArgs : public EventArgs

The TransportLinkRemovedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TransportLinkRemovedEventArgs | Initializes a new instance of TransportLinkRemovedEventArgs.
Top
Properties
 | Name | Description
Public property | Destination | Removed ITransportLink's destination ITransportNode.
Public property | Group | Removed ITransportLink's associated IProcessFlowGroup.
Public property | Source | Removed ITransportLink's source ITransportNode.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


TransportLinkRemovedEventArgs Constructor

Initializes a new instance of TransportLinkRemovedEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TransportLinkRemovedEventArgs(
    IProcessFlowGroup group,
    ITransportNode source,
    ITransportNode destination
)
public:
TransportLinkRemovedEventArgs(
    IProcessFlowGroup^ group,
    ITransportNode^ source,
    ITransportNode^ destination
)

Parameters

group
Type: VisualComponents.Create3DIProcessFlowGroup
IProcessFlowGroup associated to the ITransportLink that was removed.
source
Type: VisualComponents.Create3DITransportNode
Source ITransportNode of the ITransportLink that was removed.
destination
Type: VisualComponents.Create3DITransportNode
Destination ITransportNode of the ITransportLink that was removed.
See Also

Reference

TransportLinkRemovedEventArgs Class
VisualComponents.Create3D Namespace


TransportLinkRemovedEventArgs Properties

The TransportLinkRemovedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Destination | Removed ITransportLink's destination ITransportNode.
Public property | Group | Removed ITransportLink's associated IProcessFlowGroup.
Public property | Source | Removed ITransportLink's source ITransportNode.
Top
See Also

Reference

TransportLinkRemovedEventArgs Class
VisualComponents.Create3D Namespace


TransportLinkRemovedEventArgs.Destination Property

TransportLinkRemovedEventArgsDestination Property

Removed ITransportLink's destination ITransportNode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ITransportNode Destination { get; }
public:
property ITransportNode^ Destination {
    ITransportNode^ get ();
}

Property Value

Type: ITransportNode
See Also

Reference

TransportLinkRemovedEventArgs Class
VisualComponents.Create3D Namespace


TransportLinkRemovedEventArgs.Group Property

TransportLinkRemovedEventArgsGroup Property

Removed ITransportLink's associated IProcessFlowGroup.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProcessFlowGroup Group { get; }
public:
property IProcessFlowGroup^ Group {
    IProcessFlowGroup^ get ();
}

Property Value

Type: IProcessFlowGroup
See Also

Reference

TransportLinkRemovedEventArgs Class
VisualComponents.Create3D Namespace


TransportLinkRemovedEventArgs.Source Property

TransportLinkRemovedEventArgsSource Property

Removed ITransportLink's source ITransportNode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ITransportNode Source { get; }
public:
property ITransportNode^ Source {
    ITransportNode^ get ();
}

Property Value

Type: ITransportNode
See Also

Reference

TransportLinkRemovedEventArgs Class
VisualComponents.Create3D Namespace


TransportLinkRemovedEventArgs Methods

The TransportLinkRemovedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TransportLinkRemovedEventArgs Class
VisualComponents.Create3D Namespace


TransportLinkRemovingEventArgs Class

Provides data for TransportLinkRemoving event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DTransportLinkRemovingEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TransportLinkRemovingEventArgs : EventArgs
public ref class TransportLinkRemovingEventArgs : public EventArgs

The TransportLinkRemovingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TransportLinkRemovingEventArgs | Initializes a new instance of TransportLinkRemovingEventArgs.
Top
Properties
 | Name | Description
Public property | TransportLink | ITransportLink that is being removed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


TransportLinkRemovingEventArgs Constructor

Initializes a new instance of TransportLinkRemovingEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TransportLinkRemovingEventArgs(
    ITransportLink link
)
public:
TransportLinkRemovingEventArgs(
    ITransportLink^ link
)

Parameters

link
Type: VisualComponents.Create3DITransportLink
ITransportLink being removed.
See Also

Reference

TransportLinkRemovingEventArgs Class
VisualComponents.Create3D Namespace


TransportLinkRemovingEventArgs Properties

The TransportLinkRemovingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | TransportLink | ITransportLink that is being removed.
Top
See Also

Reference

TransportLinkRemovingEventArgs Class
VisualComponents.Create3D Namespace


TransportLinkRemovingEventArgs.TransportLink Property

TransportLinkRemovingEventArgsTransportLink Property

ITransportLink that is being removed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ITransportLink TransportLink { get; }
public:
property ITransportLink^ TransportLink {
    ITransportLink^ get ();
}

Property Value

Type: ITransportLink
See Also

Reference

TransportLinkRemovingEventArgs Class
VisualComponents.Create3D Namespace


TransportLinkRemovingEventArgs Methods

The TransportLinkRemovingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TransportLinkRemovingEventArgs Class
VisualComponents.Create3D Namespace


TransportNodeAddedEventArgs Class

Provides data for TransportNodeAdded event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DTransportNodeAddedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TransportNodeAddedEventArgs : EventArgs
public ref class TransportNodeAddedEventArgs : public EventArgs

The TransportNodeAddedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TransportNodeAddedEventArgs | Initializes a new instance of TransportNodeAddedEventArgs.
Top
Properties
 | Name | Description
Public property | TransportNode | ITransportNode that has been added.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


TransportNodeAddedEventArgs Constructor

Initializes a new instance of TransportNodeAddedEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TransportNodeAddedEventArgs(
    ITransportNode node
)
public:
TransportNodeAddedEventArgs(
    ITransportNode^ node
)

Parameters

node
Type: VisualComponents.Create3DITransportNode
ITransportNode that has been added.
See Also

Reference

TransportNodeAddedEventArgs Class
VisualComponents.Create3D Namespace


TransportNodeAddedEventArgs Properties

The TransportNodeAddedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | TransportNode | ITransportNode that has been added.
Top
See Also

Reference

TransportNodeAddedEventArgs Class
VisualComponents.Create3D Namespace


TransportNodeAddedEventArgs.TransportNode Property

TransportNodeAddedEventArgsTransportNode Property

ITransportNode that has been added.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ITransportNode TransportNode { get; }
public:
property ITransportNode^ TransportNode {
    ITransportNode^ get ();
}

Property Value

Type: ITransportNode
See Also

Reference

TransportNodeAddedEventArgs Class
VisualComponents.Create3D Namespace


TransportNodeAddedEventArgs Methods

The TransportNodeAddedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TransportNodeAddedEventArgs Class
VisualComponents.Create3D Namespace


TransportNodeRemovingEventArgs Class

Provides data for TransportNodeRemoving event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DTransportNodeRemovingEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TransportNodeRemovingEventArgs : EventArgs
public ref class TransportNodeRemovingEventArgs : public EventArgs

The TransportNodeRemovingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TransportNodeRemovingEventArgs | Initializes a new instance of TransportNodeRemovingEventArgs.
Top
Properties
 | Name | Description
Public property | TransportNode | ITransportNode that is being removed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


TransportNodeRemovingEventArgs Constructor

Initializes a new instance of TransportNodeRemovingEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TransportNodeRemovingEventArgs(
    ITransportNode node
)
public:
TransportNodeRemovingEventArgs(
    ITransportNode^ node
)

Parameters

node
Type: VisualComponents.Create3DITransportNode
ITransportNode being removed.
See Also

Reference

TransportNodeRemovingEventArgs Class
VisualComponents.Create3D Namespace


TransportNodeRemovingEventArgs Properties

The TransportNodeRemovingEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | TransportNode | ITransportNode that is being removed.
Top
See Also

Reference

TransportNodeRemovingEventArgs Class
VisualComponents.Create3D Namespace


TransportNodeRemovingEventArgs.TransportNode Property

TransportNodeRemovingEventArgsTransportNode Property

ITransportNode that is being removed.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ITransportNode TransportNode { get; }
public:
property ITransportNode^ TransportNode {
    ITransportNode^ get ();
}

Property Value

Type: ITransportNode
See Also

Reference

TransportNodeRemovingEventArgs Class
VisualComponents.Create3D Namespace


TransportNodeRemovingEventArgs Methods

The TransportNodeRemovingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TransportNodeRemovingEventArgs Class
VisualComponents.Create3D Namespace


TransportOutType Enumeration

Options for product leaving for ITransportOutStatement.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum TransportOutType
public enum class TransportOutType
Members
Member name | Value | Description
ToNextProcess | 0 | Send the product to the next process by using the transport system.
ToContainer | 1 | Send the product to the specified IComponentContainer.
ToTransportNode | 2 | Send the product to the specified ITransportNode.
See Also

Reference

VisualComponents.Create3D Namespace


TransportStatementMode Enumeration

Operation options in PM transport statements.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum TransportStatementMode
public enum class TransportStatementMode
Members
Member name | Value | Description
TransportProducts | 0 | Transport ISimProducts between processes.
ProcessAssembly | 1 | Fill or empty ISimAssembly by transporting ISimProducts in or out.
See Also

Reference

VisualComponents.Create3D Namespace


TriangularDistributionParameters Class

Triangular distribution parameters
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DTriangularDistributionParameters

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TriangularDistributionParameters : IDistributionParameters
public ref class TriangularDistributionParameters : IDistributionParameters

The TriangularDistributionParameters type exposes the following members.

Constructors
 | Name | Description
Public method | TriangularDistributionParameters | Initializes a new instance of the TriangularDistributionParameters class
Public method | TriangularDistributionParameters(IProperty) | Initializes a new instance of the TriangularDistributionParameters class
Top
Properties
 | Name | Description
Public property | DistributionType |
Public property | Expression |
Public property | Max | Maximum value
Public property | Mid | Medium value
Public property | Min | Minimum value
Public property | Property |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


TriangularDistributionParameters Constructor

Overload List
 | Name | Description
Public method | TriangularDistributionParameters | Initializes a new instance of the TriangularDistributionParameters class
Public method | TriangularDistributionParameters(IProperty) | Initializes a new instance of the TriangularDistributionParameters class
Top
See Also

Reference

TriangularDistributionParameters Class
VisualComponents.Create3D Namespace


TriangularDistributionParameters Constructor

Initializes a new instance of the TriangularDistributionParameters class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TriangularDistributionParameters()
public:
TriangularDistributionParameters()
See Also

Reference

TriangularDistributionParameters Class
TriangularDistributionParameters Overload
VisualComponents.Create3D Namespace


TriangularDistributionParameters Constructor (IProperty)

Initializes a new instance of the TriangularDistributionParameters class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TriangularDistributionParameters(
    IProperty property
)
public:
TriangularDistributionParameters(
    IProperty^ property
)

Parameters

property
Type: VisualComponents.Create3DIProperty
See Also

Reference

TriangularDistributionParameters Class
TriangularDistributionParameters Overload
VisualComponents.Create3D Namespace


TriangularDistributionParameters Properties

The TriangularDistributionParameters type exposes the following members.

Properties
 | Name | Description
Public property | DistributionType |
Public property | Expression |
Public property | Max | Maximum value
Public property | Mid | Medium value
Public property | Min | Minimum value
Public property | Property |
Top
See Also

Reference

TriangularDistributionParameters Class
VisualComponents.Create3D Namespace


TriangularDistributionParameters.DistributionType Property

TriangularDistributionParametersDistributionType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DistributionType DistributionType { get; }
public:
virtual property DistributionType DistributionType {
    DistributionType get () sealed;
}

Property Value

Type: DistributionType

Implements

IDistributionParametersDistributionType
See Also

Reference

TriangularDistributionParameters Class
VisualComponents.Create3D Namespace


TriangularDistributionParameters.Expression Property

TriangularDistributionParametersExpression Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Expression { get; }
public:
virtual property String^ Expression {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IDistributionParametersExpression
See Also

Reference

TriangularDistributionParameters Class
VisualComponents.Create3D Namespace


TriangularDistributionParameters.Max Property

TriangularDistributionParametersMax Property

Maximum value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Max { get; set; }
public:
property double Max {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

TriangularDistributionParameters Class
VisualComponents.Create3D Namespace


TriangularDistributionParameters.Mid Property

TriangularDistributionParametersMid Property

Medium value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Mid { get; set; }
public:
property double Mid {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

TriangularDistributionParameters Class
VisualComponents.Create3D Namespace


TriangularDistributionParameters.Min Property

TriangularDistributionParametersMin Property

Minimum value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Min { get; set; }
public:
property double Min {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

TriangularDistributionParameters Class
VisualComponents.Create3D Namespace


TriangularDistributionParameters.Property Property

TriangularDistributionParametersProperty Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty Property { get; }
public:
property IProperty^ Property {
    IProperty^ get ();
}

Property Value

Type: IProperty
See Also

Reference

TriangularDistributionParameters Class
VisualComponents.Create3D Namespace


TriangularDistributionParameters Methods

The TriangularDistributionParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TriangularDistributionParameters Class
VisualComponents.Create3D Namespace


TypeOfNode Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum TypeOfNode
public enum class TypeOfNode
Members
Member name | Value | Description
WorldNode | 0 |
RootSimNode | 1 |
SimNode | 2 |
RootFeature | 3 |
Feature | 4 |
See Also

Reference

VisualComponents.Create3D Namespace


U3D Enumeration

U3D -> ECMA-363 (1st, 2nd and 3rd editions)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum U3D
public enum class U3D
Members
Member name | Value | Description
U3D | 0 |
See Also

Reference

VisualComponents.Create3D Namespace


UndoEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DUndoEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class UndoEventArgs : EventArgs
public ref class UndoEventArgs : public EventArgs

The UndoEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | UndoEventArgs | Initializes a new instance of the UndoEventArgs class
Top
Properties
 | Name | Description
Public property | Changeset |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


UndoEventArgs Constructor

Initializes a new instance of the UndoEventArgs class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UndoEventArgs(
    Changeset changeset
)
public:
UndoEventArgs(
    Changeset^ changeset
)

Parameters

changeset
Type: VisualComponents.Create3DChangeset
See Also

Reference

UndoEventArgs Class
VisualComponents.Create3D Namespace


UndoEventArgs Properties

The UndoEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Changeset |
Top
See Also

Reference

UndoEventArgs Class
VisualComponents.Create3D Namespace


UndoEventArgs.Changeset Property

UndoEventArgsChangeset Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Changeset Changeset { get; }
public:
property Changeset^ Changeset {
    Changeset^ get ();
}

Property Value

Type: Changeset
See Also

Reference

UndoEventArgs Class
VisualComponents.Create3D Namespace


UndoEventArgs Methods

The UndoEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UndoEventArgs Class
VisualComponents.Create3D Namespace


UndoScope Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DUndoScope

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class UndoScope : IDisposable
public ref class UndoScope sealed : IDisposable

The UndoScope type exposes the following members.

Properties
 | Name | Description
Public property | Changes | Gets the collection of Change instances in this undo scope.
 | Current |
 | LegacyMode | Obsolete.
 | Scopes | Gets the collection of active UndoScope instances.
Top
Methods
 | Name | Description
Public method | AddChange |
 | CreateNew | Initializes a new UndoScope.
 | CreateNew(UndoScopeOption) | Initializes a new UndoScope.
 | CreateNew(UndoScopeOption, IUndoService) | Initializes a new UndoScope.
Public method | Dispose | Disposing this instance will end the associated Undo batch.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertChange |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


UndoScope Properties

The UndoScope type exposes the following members.

Properties
 | Name | Description
Public property | Changes | Gets the collection of Change instances in this undo scope.
 | Current |
 | LegacyMode | Obsolete.
 | Scopes | Gets the collection of active UndoScope instances.
Top
See Also

Reference

UndoScope Class
VisualComponents.Create3D Namespace


UndoScope.Changes Property

UndoScopeChanges Property

Gets the collection of Change instances in this undo scope.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<Change> Changes { get; }
public:
property ReadOnlyCollection<Change^>^ Changes {
    ReadOnlyCollection<Change^>^ get ();
}

Property Value

Type: ReadOnlyCollectionChange
See Also

Reference

UndoScope Class
VisualComponents.Create3D Namespace


UndoScope.Current Property

UndoScopeCurrent Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static UndoScope Current { get; }
public:
static property UndoScope^ Current {
    UndoScope^ get ();
}

Property Value

Type: UndoScope
See Also

Reference

UndoScope Class
VisualComponents.Create3D Namespace


UndoScope.LegacyMode Property

UndoScopeLegacyMode Property

Note: This API is now obsolete.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("For debugging purposes only.")]
public static bool LegacyMode { get; set; }
public:
[ObsoleteAttribute(L"For debugging purposes only.")]
static property bool LegacyMode {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

UndoScope Class
VisualComponents.Create3D Namespace


UndoScope.Scopes Property

UndoScopeScopes Property

Gets the collection of active UndoScope instances.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ReadOnlyCollection<UndoScope> Scopes { get; }
public:
static property ReadOnlyCollection<UndoScope^>^ Scopes {
    ReadOnlyCollection<UndoScope^>^ get ();
}

Property Value

Type: ReadOnlyCollectionUndoScope
See Also

Reference

UndoScope Class
VisualComponents.Create3D Namespace


UndoScope Methods

The UndoScope type exposes the following members.

Methods
 | Name | Description
Public method | AddChange |
 | CreateNew | Initializes a new UndoScope.
 | CreateNew(UndoScopeOption) | Initializes a new UndoScope.
 | CreateNew(UndoScopeOption, IUndoService) | Initializes a new UndoScope.
Public method | Dispose | Disposing this instance will end the associated Undo batch.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertChange |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UndoScope Class
VisualComponents.Create3D Namespace


UndoScope.AddChange Method

UndoScopeAddChange Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void AddChange(
    Change change
)
public:
void AddChange(
    Change^ change
)

Parameters

change
Type: VisualComponents.Create3DChange
See Also

Reference

UndoScope Class
VisualComponents.Create3D Namespace


UndoScope.CreateNew Method

UndoScopeCreateNew Method

Overload List
Name | Description
CreateNew | Initializes a new UndoScope.
CreateNew(UndoScopeOption) | Initializes a new UndoScope.
CreateNew(UndoScopeOption, IUndoService) | Initializes a new UndoScope.
Top
See Also

Reference

UndoScope Class
VisualComponents.Create3D Namespace


UndoScope.CreateNew Method

UndoScopeCreateNew Method

Initializes a new UndoScope.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static UndoScope CreateNew()
public:
static UndoScope^ CreateNew()

Return Value

Type: UndoScope
New UndoScope instance.
See Also

Reference

UndoScope Class
CreateNew Overload
VisualComponents.Create3D Namespace


UndoScope.CreateNew Method (UndoScopeOption)

UndoScopeCreateNew Method (UndoScopeOption)

Initializes a new UndoScope.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static UndoScope CreateNew(
    UndoScopeOption option
)
public:
static UndoScope^ CreateNew(
    UndoScopeOption option
)

Parameters

option
Type: VisualComponents.Create3DUndoScopeOption
Allows merging the new scope with existing scope.

Return Value

Type: UndoScope
New UndoScope instance.
See Also

Reference

UndoScope Class
CreateNew Overload
VisualComponents.Create3D Namespace


UndoScope.CreateNew Method (UndoScopeOption, IUndoService)

UndoScopeCreateNew Method (UndoScopeOption, IUndoService)

Initializes a new UndoScope.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static UndoScope CreateNew(
    UndoScopeOption option,
    IUndoService undoService
)
public:
static UndoScope^ CreateNew(
    UndoScopeOption option,
    IUndoService^ undoService
)

Parameters

option
Type: VisualComponents.Create3DUndoScopeOption
Allows merging the new scope with existing scope.
undoService
Type: VisualComponents.Create3DIUndoService
The UndoService object to use.

Return Value

Type: UndoScope
New UndoScope instance.
See Also

Reference

UndoScope Class
CreateNew Overload
VisualComponents.Create3D Namespace


UndoScope.Dispose Method

UndoScopeDispose Method

Disposing this instance will end the associated Undo batch.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Dispose()
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

UndoScope Class
VisualComponents.Create3D Namespace


UndoScope.InsertChange Method

UndoScopeInsertChange Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InsertChange(
    int index,
    Change change
)
public:
void InsertChange(
    int index,
    Change^ change
)

Parameters

index
Type: SystemInt32
change
Type: VisualComponents.Create3DChange
See Also

Reference

UndoScope Class
VisualComponents.Create3D Namespace


UndoScopeOption Enumeration

UndoScopeOption defines behavior of nested undo scopes.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum UndoScopeOption
public enum class UndoScopeOption
Members
Member name | Value | Description
Invalid | 0 | Invalid.
Default | 1 | Creates a new undo scope, new scopes are allowed to be merged to the created scope.
Isolated | 2 | Creates a new isolated undo scope. Adding change sets is accepting only by direct calls to this scope. No merging to or from isolated scope is allowed.
Merge | 3 | Merges the scope with previous non-isolated scope.
ReverseMerge | 4 | Merges the scope with previous non-isolated scope. Changes are processed in reverse order when processing undo and redo.
See Also

Reference

VisualComponents.Create3D Namespace


UndoState Enumeration

Declares available states for UndoService.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum UndoState
public enum class UndoState
Members
Member name | Value | Description
None | 0 |
ProcessingUndo | 1 | Service is processing undo request.
ProcessingRedo | 2 | Service is processing redo request.
Idle | 3 | Service is ready to process change sets.
Blocked | 4 | Current application state does not allow adding new change sets or processing undo or redo requests.
See Also

Reference

VisualComponents.Create3D Namespace


UniformDistributionParameters Class

Uniform distribution parameters
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DUniformDistributionParameters

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class UniformDistributionParameters : IDistributionParameters
public ref class UniformDistributionParameters : IDistributionParameters

The UniformDistributionParameters type exposes the following members.

Constructors
 | Name | Description
Public method | UniformDistributionParameters | Initializes a new instance of the UniformDistributionParameters class
Public method | UniformDistributionParameters(IProperty) | Initializes a new instance of the UniformDistributionParameters class
Top
Properties
 | Name | Description
Public property | DistributionType |
Public property | Expression |
Public property | Max | Maximum value
Public property | Min | Minimum value
Public property | Property |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


UniformDistributionParameters Constructor

Overload List
 | Name | Description
Public method | UniformDistributionParameters | Initializes a new instance of the UniformDistributionParameters class
Public method | UniformDistributionParameters(IProperty) | Initializes a new instance of the UniformDistributionParameters class
Top
See Also

Reference

UniformDistributionParameters Class
VisualComponents.Create3D Namespace


UniformDistributionParameters Constructor

Initializes a new instance of the UniformDistributionParameters class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UniformDistributionParameters()
public:
UniformDistributionParameters()
See Also

Reference

UniformDistributionParameters Class
UniformDistributionParameters Overload
VisualComponents.Create3D Namespace


UniformDistributionParameters Constructor (IProperty)

Initializes a new instance of the UniformDistributionParameters class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UniformDistributionParameters(
    IProperty property
)
public:
UniformDistributionParameters(
    IProperty^ property
)

Parameters

property
Type: VisualComponents.Create3DIProperty
See Also

Reference

UniformDistributionParameters Class
UniformDistributionParameters Overload
VisualComponents.Create3D Namespace


UniformDistributionParameters Properties

The UniformDistributionParameters type exposes the following members.

Properties
 | Name | Description
Public property | DistributionType |
Public property | Expression |
Public property | Max | Maximum value
Public property | Min | Minimum value
Public property | Property |
Top
See Also

Reference

UniformDistributionParameters Class
VisualComponents.Create3D Namespace


UniformDistributionParameters.DistributionType Property

UniformDistributionParametersDistributionType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DistributionType DistributionType { get; }
public:
virtual property DistributionType DistributionType {
    DistributionType get () sealed;
}

Property Value

Type: DistributionType

Implements

IDistributionParametersDistributionType
See Also

Reference

UniformDistributionParameters Class
VisualComponents.Create3D Namespace


UniformDistributionParameters.Expression Property

UniformDistributionParametersExpression Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Expression { get; }
public:
virtual property String^ Expression {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IDistributionParametersExpression
See Also

Reference

UniformDistributionParameters Class
VisualComponents.Create3D Namespace


UniformDistributionParameters.Max Property

UniformDistributionParametersMax Property

Maximum value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Max { get; set; }
public:
property double Max {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

UniformDistributionParameters Class
VisualComponents.Create3D Namespace


UniformDistributionParameters.Min Property

UniformDistributionParametersMin Property

Minimum value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Min { get; set; }
public:
property double Min {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

UniformDistributionParameters Class
VisualComponents.Create3D Namespace


UniformDistributionParameters.Property Property

UniformDistributionParametersProperty Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty Property { get; }
public:
property IProperty^ Property {
    IProperty^ get ();
}

Property Value

Type: IProperty
See Also

Reference

UniformDistributionParameters Class
VisualComponents.Create3D Namespace


UniformDistributionParameters Methods

The UniformDistributionParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UniformDistributionParameters Class
VisualComponents.Create3D Namespace


Unigraphics Enumeration

(Siemens PLM Software NX) Unigraphics -> V11.0 to NX 9.0

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum Unigraphics
public enum class Unigraphics
Members
Member name | Value | Description
PRT | 0 |
See Also

Reference

VisualComponents.Create3D Namespace


UnionListProperty Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DUnionPropertyBase
VisualComponents.Create3DUnionListProperty

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class UnionListProperty : UnionPropertyBase,
    IListProperty, IProperty, INotifyPropertyChanged, IDisposable, INamed
public ref class UnionListProperty : public UnionPropertyBase,
    IListProperty, IProperty, INotifyPropertyChanged, IDisposable, INamed

The UnionListProperty type exposes the following members.

Constructors
 | Name | Description
Public method | UnionListProperty | Initializes a new instance of the UnionListProperty class
Top
Properties
 | Name | Description
Public property | AllowedMaximum | Aggregate maximum allowed value. Only valid if the aggregate constraints result in an allowed range. (Inherited from UnionPropertyBase.)
Public property | AllowedMinimum | Aggregate minimum allowed value. Only valid if the aggregate constraints result in an allowed range. (Inherited from UnionPropertyBase.)
Public property | AllowedValues | Aggregate allowed values. Only valid if the aggregate constraints result in a closed set of values. (Inherited from UnionPropertyBase.)
Public property | CanCreateNewValue | (Inherited from UnionPropertyBase.)
Public property | Category | Category, if it is the same for all properties, otherwise an empty string. (Inherited from UnionPropertyBase.)
Public property | ConstraintType | Aggregate constraint type. Only valid if constraints of all properties overlap. (Inherited from UnionPropertyBase.)
Public property | Container | Property container object. Always null for union properties. (Inherited from UnionPropertyBase.)
Public property | CreationTypes | (Inherited from UnionPropertyBase.)
Public property | Description | The description string, if it is the same for all properties, otherwise an empty string. (Inherited from UnionPropertyBase.)
Public property | DisabledStateToolTip | (Inherited from UnionPropertyBase.)
Public property | DistributionExpression | Not implemented for union properties. (Inherited from UnionPropertyBase.)
Public property | HasDistribution | Not implemented for union properties. (Inherited from UnionPropertyBase.)
Public property | History | Not supported in union properties. (Inherited from UnionPropertyBase.)
Public property | IsDesignTime | Whether all properties are design time properties. (Inherited from UnionPropertyBase.)
Public property | IsEditable | True if all properties are currently editable, as determined by the application and simulation state. (Inherited from UnionPropertyBase.)
Public property | IsInternal | True if any property in union is internal. (Inherited from UnionPropertyBase.)
Public property | IsLocked | True if any of the union properties is locked. (Inherited from UnionPropertyBase.)
Public property | IsPersistent | Whether all properties are persistent. (Inherited from UnionPropertyBase.)
Public property | IsQuantityValue | (Inherited from UnionPropertyBase.)
Public property | IsReadOnly | True if any of the properties is read-only. (Inherited from UnionPropertyBase.)
Public property | IsValid | (Inherited from UnionPropertyBase.)
Public property | IsVisible | True if all properties in union are visible. (Inherited from UnionPropertyBase.)
Public property | IsVisibleDesignTime | (Inherited from UnionPropertyBase.)
Public property | List |
Public property | Name | Property name if all properties have the same name, otherwise an empty string. (Inherited from UnionPropertyBase.)
Public property | Order | Smallest order number of all properties in union. (Inherited from UnionPropertyBase.)
Public property | Properties | Properties contained by the union property (Inherited from UnionPropertyBase.)
Public property | PropertyDistinctionLevel | Level of difference between properties. (Inherited from UnionPropertyBase.)
Public property | PropertyType | Property value type, if same for all properties, otherwise null. (Inherited from UnionPropertyBase.)
Public property | Quantity | (Inherited from UnionPropertyBase.)
Public property | TabHeader | Tab header, if it is the same for all properties, otherwise an empty string. (Inherited from UnionPropertyBase.)
Public property | Unit | Common unit for properties, or null if there are different units. (Inherited from UnionPropertyBase.)
Public property | Value | (Inherited from UnionPropertyBase.)
Public property | ValueString | Value description string. (Inherited from UnionPropertyBase.)
Top
Methods
 | Name | Description
Protected method | AddAggregateProperty(ExpressionFuncBoolean, Boolean, Boolean) | (Inherited from UnionPropertyBase.)
Protected method | AddAggregateProperty(PropertyInfo, Boolean, Boolean) | (Inherited from UnionPropertyBase.)
Public method | Clone | (Inherited from UnionPropertyBase.)
Protected method | CompareValuesEqual | (Overrides UnionPropertyBaseCompareValuesEqual(Object, Object).)
Public method | CreateAndSetNewValue | (Inherited from UnionPropertyBase.)
Public method | Dispose | Dispose all properties in the list. (Inherited from UnionPropertyBase.)
Protected method | Dispose(Boolean) | (Inherited from UnionPropertyBase.)
Public method | EndBatch | (Inherited from UnionPropertyBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetAggregateValue(ExpressionFuncBoolean) | (Inherited from UnionPropertyBase.)
Protected method | GetAggregateValue(String) | (Inherited from UnionPropertyBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokePropertyChanged | (Inherited from UnionPropertyBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveItem |
Protected method | ResetDistinctionLevel | (Inherited from UnionPropertyBase.)
Protected method | SetAggregateValue(Boolean, String) | (Inherited from UnionPropertyBase.)
Protected method | SetAggregateValue(ExpressionFuncBoolean, Boolean) | (Inherited from UnionPropertyBase.)
Protected method | SetAggregateValue(String, Boolean) | (Inherited from UnionPropertyBase.)
Public method | SetQuantity | (Inherited from UnionPropertyBase.)
Public method | SetUnitMagnitude | Set the unit magnitude for all properties. (Inherited from UnionPropertyBase.)
Public method | StartBatch | (Inherited from UnionPropertyBase.)
Public method | StopListening | (Inherited from UnionPropertyBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from UnionPropertyBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


UnionListProperty Constructor

Initializes a new instance of the UnionListProperty class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UnionListProperty(
    IEnumerable<IListProperty> properties
)
public:
UnionListProperty(
    IEnumerable<IListProperty^>^ properties
)

Parameters

properties
Type: System.Collections.GenericIEnumerableIListProperty
See Also

Reference

UnionListProperty Class
VisualComponents.Create3D Namespace


UnionListProperty Properties

The UnionListProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Aggregate maximum allowed value. Only valid if the aggregate constraints result in an allowed range. (Inherited from UnionPropertyBase.)
Public property | AllowedMinimum | Aggregate minimum allowed value. Only valid if the aggregate constraints result in an allowed range. (Inherited from UnionPropertyBase.)
Public property | AllowedValues | Aggregate allowed values. Only valid if the aggregate constraints result in a closed set of values. (Inherited from UnionPropertyBase.)
Public property | CanCreateNewValue | (Inherited from UnionPropertyBase.)
Public property | Category | Category, if it is the same for all properties, otherwise an empty string. (Inherited from UnionPropertyBase.)
Public property | ConstraintType | Aggregate constraint type. Only valid if constraints of all properties overlap. (Inherited from UnionPropertyBase.)
Public property | Container | Property container object. Always null for union properties. (Inherited from UnionPropertyBase.)
Public property | CreationTypes | (Inherited from UnionPropertyBase.)
Public property | Description | The description string, if it is the same for all properties, otherwise an empty string. (Inherited from UnionPropertyBase.)
Public property | DisabledStateToolTip | (Inherited from UnionPropertyBase.)
Public property | DistributionExpression | Not implemented for union properties. (Inherited from UnionPropertyBase.)
Public property | HasDistribution | Not implemented for union properties. (Inherited from UnionPropertyBase.)
Public property | History | Not supported in union properties. (Inherited from UnionPropertyBase.)
Public property | IsDesignTime | Whether all properties are design time properties. (Inherited from UnionPropertyBase.)
Public property | IsEditable | True if all properties are currently editable, as determined by the application and simulation state. (Inherited from UnionPropertyBase.)
Public property | IsInternal | True if any property in union is internal. (Inherited from UnionPropertyBase.)
Public property | IsLocked | True if any of the union properties is locked. (Inherited from UnionPropertyBase.)
Public property | IsPersistent | Whether all properties are persistent. (Inherited from UnionPropertyBase.)
Public property | IsQuantityValue | (Inherited from UnionPropertyBase.)
Public property | IsReadOnly | True if any of the properties is read-only. (Inherited from UnionPropertyBase.)
Public property | IsValid | (Inherited from UnionPropertyBase.)
Public property | IsVisible | True if all properties in union are visible. (Inherited from UnionPropertyBase.)
Public property | IsVisibleDesignTime | (Inherited from UnionPropertyBase.)
Public property | List |
Public property | Name | Property name if all properties have the same name, otherwise an empty string. (Inherited from UnionPropertyBase.)
Public property | Order | Smallest order number of all properties in union. (Inherited from UnionPropertyBase.)
Public property | Properties | Properties contained by the union property (Inherited from UnionPropertyBase.)
Public property | PropertyDistinctionLevel | Level of difference between properties. (Inherited from UnionPropertyBase.)
Public property | PropertyType | Property value type, if same for all properties, otherwise null. (Inherited from UnionPropertyBase.)
Public property | Quantity | (Inherited from UnionPropertyBase.)
Public property | TabHeader | Tab header, if it is the same for all properties, otherwise an empty string. (Inherited from UnionPropertyBase.)
Public property | Unit | Common unit for properties, or null if there are different units. (Inherited from UnionPropertyBase.)
Public property | Value | (Inherited from UnionPropertyBase.)
Public property | ValueString | Value description string. (Inherited from UnionPropertyBase.)
Top
See Also

Reference

UnionListProperty Class
VisualComponents.Create3D Namespace


UnionListProperty.List Property

UnionListPropertyList Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList List { get; }
public:
virtual property IList^ List {
    IList^ get () sealed;
}

Property Value

Type: IList

Implements

IListPropertyList
See Also

Reference

UnionListProperty Class
VisualComponents.Create3D Namespace


UnionListProperty Methods

The UnionListProperty type exposes the following members.

Methods
 | Name | Description
Protected method | AddAggregateProperty(ExpressionFuncBoolean, Boolean, Boolean) | (Inherited from UnionPropertyBase.)
Protected method | AddAggregateProperty(PropertyInfo, Boolean, Boolean) | (Inherited from UnionPropertyBase.)
Public method | Clone | (Inherited from UnionPropertyBase.)
Protected method | CompareValuesEqual | (Overrides UnionPropertyBaseCompareValuesEqual(Object, Object).)
Public method | CreateAndSetNewValue | (Inherited from UnionPropertyBase.)
Public method | Dispose | Dispose all properties in the list. (Inherited from UnionPropertyBase.)
Protected method | Dispose(Boolean) | (Inherited from UnionPropertyBase.)
Public method | EndBatch | (Inherited from UnionPropertyBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetAggregateValue(ExpressionFuncBoolean) | (Inherited from UnionPropertyBase.)
Protected method | GetAggregateValue(String) | (Inherited from UnionPropertyBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokePropertyChanged | (Inherited from UnionPropertyBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveItem |
Protected method | ResetDistinctionLevel | (Inherited from UnionPropertyBase.)
Protected method | SetAggregateValue(Boolean, String) | (Inherited from UnionPropertyBase.)
Protected method | SetAggregateValue(ExpressionFuncBoolean, Boolean) | (Inherited from UnionPropertyBase.)
Protected method | SetAggregateValue(String, Boolean) | (Inherited from UnionPropertyBase.)
Public method | SetQuantity | (Inherited from UnionPropertyBase.)
Public method | SetUnitMagnitude | Set the unit magnitude for all properties. (Inherited from UnionPropertyBase.)
Public method | StartBatch | (Inherited from UnionPropertyBase.)
Public method | StopListening | (Inherited from UnionPropertyBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UnionListProperty Class
VisualComponents.Create3D Namespace


UnionListProperty.CompareValuesEqual Method

UnionListPropertyCompareValuesEqual Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override bool CompareValuesEqual(
    Object left,
    Object right
)
protected:
virtual bool CompareValuesEqual(
    Object^ left,
    Object^ right
) override

Parameters

left
Type: SystemObject
right
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.UnionListProperty.CompareValuesEqual(System.Object,System.Object)"]

See Also

Reference

UnionListProperty Class
VisualComponents.Create3D Namespace


UnionListProperty.MoveItem Method

UnionListPropertyMoveItem Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool MoveItem(
    int source,
    int destination
)
public:
virtual bool MoveItem(
    int source,
    int destination
) sealed

Parameters

source
Type: SystemInt32
destination
Type: SystemInt32

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.UnionListProperty.MoveItem(System.Int32,System.Int32)"]

Implements

IListPropertyMoveItem(Int32, Int32)
See Also

Reference

UnionListProperty Class
VisualComponents.Create3D Namespace


UnionListProperty Events

The UnionListProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from UnionPropertyBase.)
Top
See Also

Reference

UnionListProperty Class
VisualComponents.Create3D Namespace


UnionProperty Class

Property that aggregates multiple properties.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DUnionPropertyBase
VisualComponents.Create3DUnionProperty

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class UnionProperty : UnionPropertyBase,
    IExpressionProperty, IProperty, INotifyPropertyChanged, IDisposable, INamed
public ref class UnionProperty : public UnionPropertyBase,
    IExpressionProperty, IProperty, INotifyPropertyChanged, IDisposable, INamed

The UnionProperty type exposes the following members.

Constructors
 | Name | Description
Public method | UnionProperty | Construct a union property based on a set of properties.
Top
Properties
 | Name | Description
Public property | AllowedMaximum | Aggregate maximum allowed value. Only valid if the aggregate constraints result in an allowed range. (Inherited from UnionPropertyBase.)
Public property | AllowedMinimum | Aggregate minimum allowed value. Only valid if the aggregate constraints result in an allowed range. (Inherited from UnionPropertyBase.)
Public property | AllowedValues | Aggregate allowed values. Only valid if the aggregate constraints result in a closed set of values. (Inherited from UnionPropertyBase.)
Public property | CanCreateNewValue | (Inherited from UnionPropertyBase.)
Public property | Category | Category, if it is the same for all properties, otherwise an empty string. (Inherited from UnionPropertyBase.)
Public property | ConstraintType | Aggregate constraint type. Only valid if constraints of all properties overlap. (Inherited from UnionPropertyBase.)
Public property | Container | Property container object. Always null for union properties. (Inherited from UnionPropertyBase.)
Public property | CreationTypes | (Inherited from UnionPropertyBase.)
Public property | Description | The description string, if it is the same for all properties, otherwise an empty string. (Inherited from UnionPropertyBase.)
Public property | DisabledStateToolTip | (Inherited from UnionPropertyBase.)
Public property | DistributionExpression | Not implemented for union properties. (Inherited from UnionPropertyBase.)
Public property | ErrorMessage | Expression error message string.
Public property | Expression | Common expression, or a string indicating the level of difference.
Public property | ExpressionContext | Expression context.
Public property | HasDistribution | Not implemented for union properties. (Inherited from UnionPropertyBase.)
Public property | History | Not supported in union properties. (Inherited from UnionPropertyBase.)
Public property | IsConstant |
Public property | IsDesignTime | Whether all properties are design time properties. (Inherited from UnionPropertyBase.)
Public property | IsDeterministic |
Public property | IsEditable | True if all properties are currently editable, as determined by the application and simulation state. (Inherited from UnionPropertyBase.)
Public property | IsInternal | True if any property in union is internal. (Inherited from UnionPropertyBase.)
Public property | IsLocked | True if any of the union properties is locked. (Inherited from UnionPropertyBase.)
Public property | IsPersistent | Whether all properties are persistent. (Inherited from UnionPropertyBase.)
Public property | IsQuantityValue | (Inherited from UnionPropertyBase.)
Public property | IsReadOnly | True if any of the properties is read-only. (Inherited from UnionPropertyBase.)
Public property | IsValid | (Inherited from UnionPropertyBase.)
Public property | IsVisible | True if all properties in union are visible. (Inherited from UnionPropertyBase.)
Public property | IsVisibleDesignTime | (Inherited from UnionPropertyBase.)
Public property | Name | Property name if all properties have the same name, otherwise an empty string. (Inherited from UnionPropertyBase.)
Public property | Order | Smallest order number of all properties in union. (Inherited from UnionPropertyBase.)
Public property | Properties | Properties contained by the union property (Inherited from UnionPropertyBase.)
Public property | PropertyDistinctionLevel | Level of difference between properties. (Inherited from UnionPropertyBase.)
Public property | PropertyType | Property value type, if same for all properties, otherwise null. (Inherited from UnionPropertyBase.)
Public property | Quantity | (Inherited from UnionPropertyBase.)
Public property | RequiredExpressionType |
Public property | ResultString |
Public property | TabHeader | Tab header, if it is the same for all properties, otherwise an empty string. (Inherited from UnionPropertyBase.)
Public property | Unit | Common unit for properties, or null if there are different units. (Inherited from UnionPropertyBase.)
Public property | Value | (Inherited from UnionPropertyBase.)
Public property | ValueString | Value description string. (Inherited from UnionPropertyBase.)
Top
Methods
 | Name | Description
Protected method | AddAggregateProperty(ExpressionFuncBoolean, Boolean, Boolean) | (Inherited from UnionPropertyBase.)
Protected method | AddAggregateProperty(PropertyInfo, Boolean, Boolean) | (Inherited from UnionPropertyBase.)
Public method | Clone | (Inherited from UnionPropertyBase.)
Protected method | CompareValuesEqual | (Overrides UnionPropertyBaseCompareValuesEqual(Object, Object).)
Public method | CreateAndSetNewValue | (Inherited from UnionPropertyBase.)
Public method | Dispose | Dispose all properties in the list. (Inherited from UnionPropertyBase.)
Protected method | Dispose(Boolean) | (Inherited from UnionPropertyBase.)
Public method | EndBatch | (Inherited from UnionPropertyBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetAggregateValue(ExpressionFuncBoolean) | (Inherited from UnionPropertyBase.)
Protected method | GetAggregateValue(String) | (Inherited from UnionPropertyBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokePropertyChanged | (Inherited from UnionPropertyBase.)
Public method | IsDependentOn |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ResetDistinctionLevel | (Inherited from UnionPropertyBase.)
Protected method | SetAggregateValue(Boolean, String) | (Inherited from UnionPropertyBase.)
Protected method | SetAggregateValue(ExpressionFuncBoolean, Boolean) | (Inherited from UnionPropertyBase.)
Protected method | SetAggregateValue(String, Boolean) | (Inherited from UnionPropertyBase.)
Public method | SetQuantity | (Inherited from UnionPropertyBase.)
Public method | SetUnitMagnitude | Set the unit magnitude for all properties. (Inherited from UnionPropertyBase.)
Public method | StartBatch | (Inherited from UnionPropertyBase.)
Public method | StopListening | (Inherited from UnionPropertyBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from UnionPropertyBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks

This class determines the common traits in a group of property objects, such as when manipulating the properties of multiple components selected at once.

See Also

Reference

VisualComponents.Create3D Namespace


UnionProperty Constructor

Construct a union property based on a set of properties.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UnionProperty(
    IEnumerable<IProperty> properties
)
public:
UnionProperty(
    IEnumerable<IProperty^>^ properties
)

Parameters

properties
Type: System.Collections.GenericIEnumerableIProperty
See Also

Reference

UnionProperty Class
VisualComponents.Create3D Namespace


UnionProperty Properties

The UnionProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Aggregate maximum allowed value. Only valid if the aggregate constraints result in an allowed range. (Inherited from UnionPropertyBase.)
Public property | AllowedMinimum | Aggregate minimum allowed value. Only valid if the aggregate constraints result in an allowed range. (Inherited from UnionPropertyBase.)
Public property | AllowedValues | Aggregate allowed values. Only valid if the aggregate constraints result in a closed set of values. (Inherited from UnionPropertyBase.)
Public property | CanCreateNewValue | (Inherited from UnionPropertyBase.)
Public property | Category | Category, if it is the same for all properties, otherwise an empty string. (Inherited from UnionPropertyBase.)
Public property | ConstraintType | Aggregate constraint type. Only valid if constraints of all properties overlap. (Inherited from UnionPropertyBase.)
Public property | Container | Property container object. Always null for union properties. (Inherited from UnionPropertyBase.)
Public property | CreationTypes | (Inherited from UnionPropertyBase.)
Public property | Description | The description string, if it is the same for all properties, otherwise an empty string. (Inherited from UnionPropertyBase.)
Public property | DisabledStateToolTip | (Inherited from UnionPropertyBase.)
Public property | DistributionExpression | Not implemented for union properties. (Inherited from UnionPropertyBase.)
Public property | ErrorMessage | Expression error message string.
Public property | Expression | Common expression, or a string indicating the level of difference.
Public property | ExpressionContext | Expression context.
Public property | HasDistribution | Not implemented for union properties. (Inherited from UnionPropertyBase.)
Public property | History | Not supported in union properties. (Inherited from UnionPropertyBase.)
Public property | IsConstant |
Public property | IsDesignTime | Whether all properties are design time properties. (Inherited from UnionPropertyBase.)
Public property | IsDeterministic |
Public property | IsEditable | True if all properties are currently editable, as determined by the application and simulation state. (Inherited from UnionPropertyBase.)
Public property | IsInternal | True if any property in union is internal. (Inherited from UnionPropertyBase.)
Public property | IsLocked | True if any of the union properties is locked. (Inherited from UnionPropertyBase.)
Public property | IsPersistent | Whether all properties are persistent. (Inherited from UnionPropertyBase.)
Public property | IsQuantityValue | (Inherited from UnionPropertyBase.)
Public property | IsReadOnly | True if any of the properties is read-only. (Inherited from UnionPropertyBase.)
Public property | IsValid | (Inherited from UnionPropertyBase.)
Public property | IsVisible | True if all properties in union are visible. (Inherited from UnionPropertyBase.)
Public property | IsVisibleDesignTime | (Inherited from UnionPropertyBase.)
Public property | Name | Property name if all properties have the same name, otherwise an empty string. (Inherited from UnionPropertyBase.)
Public property | Order | Smallest order number of all properties in union. (Inherited from UnionPropertyBase.)
Public property | Properties | Properties contained by the union property (Inherited from UnionPropertyBase.)
Public property | PropertyDistinctionLevel | Level of difference between properties. (Inherited from UnionPropertyBase.)
Public property | PropertyType | Property value type, if same for all properties, otherwise null. (Inherited from UnionPropertyBase.)
Public property | Quantity | (Inherited from UnionPropertyBase.)
Public property | RequiredExpressionType |
Public property | ResultString |
Public property | TabHeader | Tab header, if it is the same for all properties, otherwise an empty string. (Inherited from UnionPropertyBase.)
Public property | Unit | Common unit for properties, or null if there are different units. (Inherited from UnionPropertyBase.)
Public property | Value | (Inherited from UnionPropertyBase.)
Public property | ValueString | Value description string. (Inherited from UnionPropertyBase.)
Top
See Also

Reference

UnionProperty Class
VisualComponents.Create3D Namespace


UnionProperty.ErrorMessage Property

UnionPropertyErrorMessage Property

Expression error message string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ErrorMessage { get; }
public:
virtual property String^ ErrorMessage {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IExpressionPropertyErrorMessage
See Also

Reference

UnionProperty Class
VisualComponents.Create3D Namespace


UnionProperty.Expression Property

UnionPropertyExpression Property

Common expression, or a string indicating the level of difference.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Expression { get; set; }
public:
virtual property String^ Expression {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IExpressionPropertyExpression
Remarks

Setting this property will set the expression of all union properties.

See Also

Reference

UnionProperty Class
VisualComponents.Create3D Namespace


UnionProperty.ExpressionContext Property

UnionPropertyExpressionContext Property

Expression context.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IExpressionContext ExpressionContext { get; }
public:
virtual property IExpressionContext^ ExpressionContext {
    IExpressionContext^ get () sealed;
}

Property Value

Type: IExpressionContext

Implements

IExpressionPropertyExpressionContext
See Also

Reference

UnionProperty Class
VisualComponents.Create3D Namespace


UnionProperty.IsConstant Property

UnionPropertyIsConstant Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsConstant { get; }
public:
virtual property bool IsConstant {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IExpressionPropertyIsConstant
See Also

Reference

UnionProperty Class
VisualComponents.Create3D Namespace


UnionProperty.IsDeterministic Property

UnionPropertyIsDeterministic Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsDeterministic { get; }
public:
virtual property bool IsDeterministic {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IExpressionPropertyIsDeterministic
See Also

Reference

UnionProperty Class
VisualComponents.Create3D Namespace


UnionProperty.RequiredExpressionType Property

UnionPropertyRequiredExpressionType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type RequiredExpressionType { get; }
public:
virtual property Type^ RequiredExpressionType {
    Type^ get () sealed;
}

Property Value

Type: Type

Implements

IExpressionPropertyRequiredExpressionType
See Also

Reference

UnionProperty Class
VisualComponents.Create3D Namespace


UnionProperty.ResultString Property

UnionPropertyResultString Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ResultString { get; }
public:
virtual property String^ ResultString {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IExpressionPropertyResultString
See Also

Reference

UnionProperty Class
VisualComponents.Create3D Namespace


UnionProperty Methods

The UnionProperty type exposes the following members.

Methods
 | Name | Description
Protected method | AddAggregateProperty(ExpressionFuncBoolean, Boolean, Boolean) | (Inherited from UnionPropertyBase.)
Protected method | AddAggregateProperty(PropertyInfo, Boolean, Boolean) | (Inherited from UnionPropertyBase.)
Public method | Clone | (Inherited from UnionPropertyBase.)
Protected method | CompareValuesEqual | (Overrides UnionPropertyBaseCompareValuesEqual(Object, Object).)
Public method | CreateAndSetNewValue | (Inherited from UnionPropertyBase.)
Public method | Dispose | Dispose all properties in the list. (Inherited from UnionPropertyBase.)
Protected method | Dispose(Boolean) | (Inherited from UnionPropertyBase.)
Public method | EndBatch | (Inherited from UnionPropertyBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetAggregateValue(ExpressionFuncBoolean) | (Inherited from UnionPropertyBase.)
Protected method | GetAggregateValue(String) | (Inherited from UnionPropertyBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokePropertyChanged | (Inherited from UnionPropertyBase.)
Public method | IsDependentOn |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ResetDistinctionLevel | (Inherited from UnionPropertyBase.)
Protected method | SetAggregateValue(Boolean, String) | (Inherited from UnionPropertyBase.)
Protected method | SetAggregateValue(ExpressionFuncBoolean, Boolean) | (Inherited from UnionPropertyBase.)
Protected method | SetAggregateValue(String, Boolean) | (Inherited from UnionPropertyBase.)
Public method | SetQuantity | (Inherited from UnionPropertyBase.)
Public method | SetUnitMagnitude | Set the unit magnitude for all properties. (Inherited from UnionPropertyBase.)
Public method | StartBatch | (Inherited from UnionPropertyBase.)
Public method | StopListening | (Inherited from UnionPropertyBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UnionProperty Class
VisualComponents.Create3D Namespace


UnionProperty.CompareValuesEqual Method

UnionPropertyCompareValuesEqual Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override bool CompareValuesEqual(
    Object left,
    Object right
)
protected:
virtual bool CompareValuesEqual(
    Object^ left,
    Object^ right
) override

Parameters

left
Type: SystemObject
right
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.UnionProperty.CompareValuesEqual(System.Object,System.Object)"]

See Also

Reference

UnionProperty Class
VisualComponents.Create3D Namespace


UnionProperty.IsDependentOn Method

UnionPropertyIsDependentOn Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsDependentOn(
    IProperty propertyObject
)
public:
virtual bool IsDependentOn(
    IProperty^ propertyObject
) sealed

Parameters

propertyObject
Type: VisualComponents.Create3DIProperty

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.UnionProperty.IsDependentOn(VisualComponents.Create3D.IProperty)"]

Implements

IExpressionPropertyIsDependentOn(IProperty)
See Also

Reference

UnionProperty Class
VisualComponents.Create3D Namespace


UnionProperty Events

The UnionProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from UnionPropertyBase.)
Top
See Also

Reference

UnionProperty Class
VisualComponents.Create3D Namespace


UnionPropertyBase Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DUnionPropertyBase
VisualComponents.Create3DUnionListProperty
VisualComponents.Create3DUnionProperty

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract class UnionPropertyBase : IUnionProperty,
    IProperty, INotifyPropertyChanged, IDisposable, INamed
public ref class UnionPropertyBase abstract : IUnionProperty,
    IProperty, INotifyPropertyChanged, IDisposable, INamed

The UnionPropertyBase type exposes the following members.

Constructors
 | Name | Description
Protected method | UnionPropertyBase | Construct a union property based on a set of properties.
Top
Properties
 | Name | Description
Public property | AllowedMaximum | Aggregate maximum allowed value. Only valid if the aggregate constraints result in an allowed range.
Public property | AllowedMinimum | Aggregate minimum allowed value. Only valid if the aggregate constraints result in an allowed range.
Public property | AllowedValues | Aggregate allowed values. Only valid if the aggregate constraints result in a closed set of values.
Public property | CanCreateNewValue |
Public property | Category | Category, if it is the same for all properties, otherwise an empty string.
Public property | ConstraintType | Aggregate constraint type. Only valid if constraints of all properties overlap.
Public property | Container | Property container object. Always null for union properties.
Public property | CreationTypes |
Public property | Description | The description string, if it is the same for all properties, otherwise an empty string.
Public property | DisabledStateToolTip |
Public property | DistributionExpression | Not implemented for union properties.
Public property | HasDistribution | Not implemented for union properties.
Public property | History | Not supported in union properties.
Public property | IsDesignTime | Whether all properties are design time properties.
Public property | IsEditable | True if all properties are currently editable, as determined by the application and simulation state.
Public property | IsInternal | True if any property in union is internal.
Public property | IsLocked | True if any of the union properties is locked.
Public property | IsPersistent | Whether all properties are persistent.
Public property | IsQuantityValue |
Public property | IsReadOnly | True if any of the properties is read-only.
Public property | IsValid |
Public property | IsVisible | True if all properties in union are visible.
Public property | IsVisibleDesignTime |
Public property | Name | Property name if all properties have the same name, otherwise an empty string.
Public property | Order | Smallest order number of all properties in union.
Public property | Properties | Properties contained by the union property
Public property | PropertyDistinctionLevel | Level of difference between properties.
Public property | PropertyType | Property value type, if same for all properties, otherwise null.
Public property | Quantity |
Public property | TabHeader | Tab header, if it is the same for all properties, otherwise an empty string.
Public property | Unit | Common unit for properties, or null if there are different units.
Public property | Value |
Public property | ValueString | Value description string.
Top
Methods
 | Name | Description
Protected method | AddAggregateProperty(ExpressionFuncBoolean, Boolean, Boolean) |
Protected method | AddAggregateProperty(PropertyInfo, Boolean, Boolean) |
Public method | Clone |
Protected method | CompareValuesEqual |
Public method | CreateAndSetNewValue |
Public method | Dispose | Dispose all properties in the list.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the UnionPropertyBase and optionally releases the managed resources
Public method | EndBatch |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetAggregateValue(ExpressionFuncBoolean) |
Protected method | GetAggregateValue(String) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokePropertyChanged |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ResetDistinctionLevel |
Protected method | SetAggregateValue(Boolean, String) |
Protected method | SetAggregateValue(ExpressionFuncBoolean, Boolean) |
Protected method | SetAggregateValue(String, Boolean) |
Public method | SetQuantity |
Public method | SetUnitMagnitude | Set the unit magnitude for all properties.
Public method | StartBatch |
Public method | StopListening |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
Fields
Name | Description
MultipleValues |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


UnionPropertyBase Constructor

Construct a union property based on a set of properties.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected UnionPropertyBase(
    IEnumerable<IProperty> properties
)
protected:
UnionPropertyBase(
    IEnumerable<IProperty^>^ properties
)

Parameters

properties
Type: System.Collections.GenericIEnumerableIProperty
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase Properties

The UnionPropertyBase type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | Aggregate maximum allowed value. Only valid if the aggregate constraints result in an allowed range.
Public property | AllowedMinimum | Aggregate minimum allowed value. Only valid if the aggregate constraints result in an allowed range.
Public property | AllowedValues | Aggregate allowed values. Only valid if the aggregate constraints result in a closed set of values.
Public property | CanCreateNewValue |
Public property | Category | Category, if it is the same for all properties, otherwise an empty string.
Public property | ConstraintType | Aggregate constraint type. Only valid if constraints of all properties overlap.
Public property | Container | Property container object. Always null for union properties.
Public property | CreationTypes |
Public property | Description | The description string, if it is the same for all properties, otherwise an empty string.
Public property | DisabledStateToolTip |
Public property | DistributionExpression | Not implemented for union properties.
Public property | HasDistribution | Not implemented for union properties.
Public property | History | Not supported in union properties.
Public property | IsDesignTime | Whether all properties are design time properties.
Public property | IsEditable | True if all properties are currently editable, as determined by the application and simulation state.
Public property | IsInternal | True if any property in union is internal.
Public property | IsLocked | True if any of the union properties is locked.
Public property | IsPersistent | Whether all properties are persistent.
Public property | IsQuantityValue |
Public property | IsReadOnly | True if any of the properties is read-only.
Public property | IsValid |
Public property | IsVisible | True if all properties in union are visible.
Public property | IsVisibleDesignTime |
Public property | Name | Property name if all properties have the same name, otherwise an empty string.
Public property | Order | Smallest order number of all properties in union.
Public property | Properties | Properties contained by the union property
Public property | PropertyDistinctionLevel | Level of difference between properties.
Public property | PropertyType | Property value type, if same for all properties, otherwise null.
Public property | Quantity |
Public property | TabHeader | Tab header, if it is the same for all properties, otherwise an empty string.
Public property | Unit | Common unit for properties, or null if there are different units.
Public property | Value |
Public property | ValueString | Value description string.
Top
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.AllowedMaximum Property

UnionPropertyBaseAllowedMaximum Property

Aggregate maximum allowed value. Only valid if the aggregate constraints result in an allowed range.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IComparable AllowedMaximum { get; set; }
public:
virtual property IComparable^ AllowedMaximum {
    IComparable^ get () sealed;
    void set (IComparable^ value) sealed;
}

Property Value

Type: IComparable

Implements

IPropertyAllowedMaximum
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.AllowedMinimum Property

UnionPropertyBaseAllowedMinimum Property

Aggregate minimum allowed value. Only valid if the aggregate constraints result in an allowed range.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IComparable AllowedMinimum { get; set; }
public:
virtual property IComparable^ AllowedMinimum {
    IComparable^ get () sealed;
    void set (IComparable^ value) sealed;
}

Property Value

Type: IComparable

Implements

IPropertyAllowedMinimum
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.AllowedValues Property

UnionPropertyBaseAllowedValues Property

Aggregate allowed values. Only valid if the aggregate constraints result in a closed set of values.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ICollection<PropertyAllowedValue> AllowedValues { get; }
public:
virtual property ICollection<PropertyAllowedValue>^ AllowedValues {
    ICollection<PropertyAllowedValue>^ get () sealed;
}

Property Value

Type: ICollectionPropertyAllowedValue

Implements

IPropertyAllowedValues
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.CanCreateNewValue Property

UnionPropertyBaseCanCreateNewValue Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanCreateNewValue { get; }
public:
virtual property bool CanCreateNewValue {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IPropertyCanCreateNewValue
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.Category Property

UnionPropertyBaseCategory Property

Category, if it is the same for all properties, otherwise an empty string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Category { get; set; }
public:
virtual property String^ Category {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPropertyCategory
Remarks

Setting this value is not supported in union properties.

See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.ConstraintType Property

UnionPropertyBaseConstraintType Property

Aggregate constraint type. Only valid if constraints of all properties overlap.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyConstraintType ConstraintType { get; }
public:
virtual property PropertyConstraintType ConstraintType {
    PropertyConstraintType get () sealed;
}

Property Value

Type: PropertyConstraintType

Implements

IPropertyConstraintType
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.Container Property

UnionPropertyBaseContainer Property

Property container object. Always null for union properties.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IPropertyContainer Container { get; }
public:
virtual property IPropertyContainer^ Container {
    IPropertyContainer^ get () sealed;
}

Property Value

Type: IPropertyContainer

Implements

IPropertyContainer
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.CreationTypes Property

UnionPropertyBaseCreationTypes Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList<string> CreationTypes { get; }
public:
virtual property IList<String^>^ CreationTypes {
    IList<String^>^ get () sealed;
}

Property Value

Type: IListString

Implements

IPropertyCreationTypes
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.Description Property

UnionPropertyBaseDescription Property

The description string, if it is the same for all properties, otherwise an empty string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; set; }
public:
virtual property String^ Description {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPropertyDescription
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.DisabledStateToolTip Property

UnionPropertyBaseDisabledStateToolTip Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string DisabledStateToolTip { get; set; }
public:
virtual property String^ DisabledStateToolTip {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPropertyDisabledStateToolTip
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.DistributionExpression Property

UnionPropertyBaseDistributionExpression Property

Not implemented for union properties.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string DistributionExpression { get; set; }
public:
virtual property String^ DistributionExpression {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPropertyDistributionExpression
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.HasDistribution Property

UnionPropertyBaseHasDistribution Property

Not implemented for union properties.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HasDistribution { get; }
public:
virtual property bool HasDistribution {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IPropertyHasDistribution
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.History Property

UnionPropertyBaseHistory Property

Not supported in union properties.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<HistoryItem> History { get; }
public:
virtual property ReadOnlyCollection<HistoryItem>^ History {
    ReadOnlyCollection<HistoryItem>^ get () sealed;
}

Property Value

Type: ReadOnlyCollectionHistoryItem

Implements

IPropertyHistory
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.IsDesignTime Property

UnionPropertyBaseIsDesignTime Property

Whether all properties are design time properties.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsDesignTime { get; }
public:
virtual property bool IsDesignTime {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IPropertyIsDesignTime
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.IsEditable Property

UnionPropertyBaseIsEditable Property

True if all properties are currently editable, as determined by the application and simulation state.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsEditable { get; }
public:
virtual property bool IsEditable {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IUnionPropertyIsEditable
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.IsInternal Property

UnionPropertyBaseIsInternal Property

True if any property in union is internal.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsInternal { get; }
public:
virtual property bool IsInternal {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IPropertyIsInternal
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.IsLocked Property

UnionPropertyBaseIsLocked Property

True if any of the union properties is locked.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsLocked { get; }
public:
virtual property bool IsLocked {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IPropertyIsLocked
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.IsPersistent Property

UnionPropertyBaseIsPersistent Property

Whether all properties are persistent.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsPersistent { get; set; }
public:
virtual property bool IsPersistent {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPropertyIsPersistent
Remarks

Setting this value sets the value for all properties.

See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.IsQuantityValue Property

UnionPropertyBaseIsQuantityValue Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsQuantityValue { get; }
public:
virtual property bool IsQuantityValue {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IPropertyIsQuantityValue
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.IsReadOnly Property

UnionPropertyBaseIsReadOnly Property

True if any of the properties is read-only.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsReadOnly { get; set; }
public:
virtual property bool IsReadOnly {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPropertyIsReadOnly
Remarks

Setting this value is not supported in union properties.

See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.IsValid Property

UnionPropertyBaseIsValid Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsValid { get; }
public:
virtual property bool IsValid {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IUnionPropertyIsValid
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.IsVisible Property

UnionPropertyBaseIsVisible Property

True if all properties in union are visible.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsVisible { get; set; }
public:
virtual property bool IsVisible {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPropertyIsVisible
Remarks

Setting this value is not supported in union properties.

See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.IsVisibleDesignTime Property

UnionPropertyBaseIsVisibleDesignTime Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsVisibleDesignTime { get; }
public:
virtual property bool IsVisibleDesignTime {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IPropertyIsVisibleDesignTime
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.Name Property

UnionPropertyBaseName Property

Property name if all properties have the same name, otherwise an empty string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; set; }
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INamedName
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.Order Property

UnionPropertyBaseOrder Property

Smallest order number of all properties in union.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Order { get; set; }
public:
virtual property int Order {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

IPropertyOrder
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.Properties Property

UnionPropertyBaseProperties Property

Properties contained by the union property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyCollection Properties { get; }
public:
virtual property PropertyCollection^ Properties {
    PropertyCollection^ get () sealed;
}

Property Value

Type: PropertyCollection

Implements

IUnionPropertyProperties
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.PropertyDistinctionLevel Property

UnionPropertyBasePropertyDistinctionLevel Property

Level of difference between properties.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DistinctionLevel PropertyDistinctionLevel { get; }
public:
virtual property DistinctionLevel PropertyDistinctionLevel {
    DistinctionLevel get () sealed;
}

Property Value

Type: DistinctionLevel

Implements

IUnionPropertyPropertyDistinctionLevel
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.PropertyType Property

UnionPropertyBasePropertyType Property

Property value type, if same for all properties, otherwise null.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type PropertyType { get; }
public:
virtual property Type^ PropertyType {
    Type^ get () sealed;
}

Property Value

Type: Type

Implements

IPropertyPropertyType
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.Quantity Property

UnionPropertyBaseQuantity Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IScalarQuantity Quantity { get; }
public:
virtual property IScalarQuantity^ Quantity {
    IScalarQuantity^ get () sealed;
}

Property Value

Type: IScalarQuantity

Implements

IPropertyQuantity
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.TabHeader Property

UnionPropertyBaseTabHeader Property

Tab header, if it is the same for all properties, otherwise an empty string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string TabHeader { get; set; }
public:
virtual property String^ TabHeader {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPropertyTabHeader
Remarks

Setting this value will change the tab header of all properties.

See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.Unit Property

UnionPropertyBaseUnit Property

Common unit for properties, or null if there are different units.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IUnit Unit { get; }
public:
virtual property IUnit^ Unit {
    IUnit^ get () sealed;
}

Property Value

Type: IUnit

Implements

IPropertyUnit
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.Value Property

UnionPropertyBaseValue Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Value { get; set; }
public:
virtual property Object^ Value {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}

Property Value

Type: Object

Implements

IPropertyValue
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.ValueString Property

UnionPropertyBaseValueString Property

Value description string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ValueString { get; }
public:
property String^ ValueString {
    String^ get ();
}

Property Value

Type: String
Remarks

If all properties have the same value, this is a string representation of that value, otherwise this string indicates whether the properties are of different types, have non-overlapping constraints, or are set to multiple values.

See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase Methods

The UnionPropertyBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddAggregateProperty(ExpressionFuncBoolean, Boolean, Boolean) |
Protected method | AddAggregateProperty(PropertyInfo, Boolean, Boolean) |
Public method | Clone |
Protected method | CompareValuesEqual |
Public method | CreateAndSetNewValue |
Public method | Dispose | Dispose all properties in the list.
Protected method | Dispose(Boolean) |
Public method | EndBatch |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetAggregateValue(ExpressionFuncBoolean) |
Protected method | GetAggregateValue(String) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokePropertyChanged |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ResetDistinctionLevel |
Protected method | SetAggregateValue(Boolean, String) |
Protected method | SetAggregateValue(ExpressionFuncBoolean, Boolean) |
Protected method | SetAggregateValue(String, Boolean) |
Public method | SetQuantity |
Public method | SetUnitMagnitude | Set the unit magnitude for all properties.
Public method | StartBatch |
Public method | StopListening |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.AddAggregateProperty Method

UnionPropertyBaseAddAggregateProperty Method

Overload List
 | Name | Description
Protected method | AddAggregateProperty(ExpressionFuncBoolean, Boolean, Boolean) |
Protected method | AddAggregateProperty(PropertyInfo, Boolean, Boolean) |
Top
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.AddAggregateProperty Method (Expression(Func(Boolean)), Boolean, Boolean)

UnionPropertyBaseAddAggregateProperty Method (ExpressionFuncBoolean, Boolean, Boolean)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected void AddAggregateProperty(
    Expression<Func<bool>> property,
    bool isIntersection,
    bool valueWhenEmpty
)
protected:
void AddAggregateProperty(
    Expression<Func<bool>^>^ property,
    bool isIntersection,
    bool valueWhenEmpty
)

Parameters

property
Type: System.Linq.ExpressionsExpressionFuncBoolean
isIntersection
Type: SystemBoolean
valueWhenEmpty
Type: SystemBoolean
See Also

Reference

UnionPropertyBase Class
AddAggregateProperty Overload
VisualComponents.Create3D Namespace


UnionPropertyBase.AddAggregateProperty Method (PropertyInfo, Boolean, Boolean)

UnionPropertyBaseAddAggregateProperty Method (PropertyInfo, Boolean, Boolean)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected void AddAggregateProperty(
    PropertyInfo property,
    bool isIntersection,
    bool valueWhenEmpty
)
protected:
void AddAggregateProperty(
    PropertyInfo^ property,
    bool isIntersection,
    bool valueWhenEmpty
)

Parameters

property
Type: System.ReflectionPropertyInfo
isIntersection
Type: SystemBoolean
valueWhenEmpty
Type: SystemBoolean
See Also

Reference

UnionPropertyBase Class
AddAggregateProperty Overload
VisualComponents.Create3D Namespace


UnionPropertyBase.Clone Method

UnionPropertyBaseClone Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty Clone()
public:
virtual IProperty^ Clone() sealed

Return Value

Type: IProperty

[Missing <returns> documentation for "M:VisualComponents.Create3D.UnionPropertyBase.Clone"]

Implements

IPropertyClone
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.CompareValuesEqual Method

UnionPropertyBaseCompareValuesEqual Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected abstract bool CompareValuesEqual(
    Object left,
    Object right
)
protected:
virtual bool CompareValuesEqual(
    Object^ left,
    Object^ right
) abstract

Parameters

left
Type: SystemObject
right
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.UnionPropertyBase.CompareValuesEqual(System.Object,System.Object)"]

See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.CreateAndSetNewValue Method

UnionPropertyBaseCreateAndSetNewValue Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object CreateAndSetNewValue(
    string creationType,
    bool setImmediately
)
public:
virtual Object^ CreateAndSetNewValue(
    String^ creationType,
    bool setImmediately
) sealed

Parameters

creationType
Type: SystemString
setImmediately
Type: SystemBoolean

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.Create3D.UnionPropertyBase.CreateAndSetNewValue(System.String,System.Boolean)"]

Implements

IPropertyCreateAndSetNewValue(String, Boolean)
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.Dispose Method

UnionPropertyBaseDispose Method

Overload List
 | Name | Description
Public method | Dispose | Dispose all properties in the list.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the UnionPropertyBase and optionally releases the managed resources
Top
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.Dispose Method

UnionPropertyBaseDispose Method

Dispose all properties in the list.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Dispose()
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

UnionPropertyBase Class
Dispose Overload
VisualComponents.Create3D Namespace


UnionPropertyBase.Dispose Method (Boolean)

UnionPropertyBaseDispose Method (Boolean)

Releases the unmanaged resources used by the UnionPropertyBase and optionally releases the managed resources

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void Dispose(
    bool disposing
)
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

UnionPropertyBase Class
Dispose Overload
VisualComponents.Create3D Namespace


UnionPropertyBase.EndBatch Method

UnionPropertyBaseEndBatch Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void EndBatch(
    bool cancel
)
public:
virtual void EndBatch(
    bool cancel
) sealed

Parameters

cancel
Type: SystemBoolean

Implements

IPropertyEndBatch(Boolean)
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.GetAggregateValue Method

UnionPropertyBaseGetAggregateValue Method

Overload List
 | Name | Description
Protected method | GetAggregateValue(ExpressionFuncBoolean) |
Protected method | GetAggregateValue(String) |
Top
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.GetAggregateValue Method (Expression(Func(Boolean)))

UnionPropertyBaseGetAggregateValue Method (ExpressionFuncBoolean)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected bool GetAggregateValue(
    Expression<Func<bool>> property
)
protected:
bool GetAggregateValue(
    Expression<Func<bool>^>^ property
)

Parameters

property
Type: System.Linq.ExpressionsExpressionFuncBoolean

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.UnionPropertyBase.GetAggregateValue(System.Linq.Expressions.Expression{System.Func{System.Boolean}})"]

See Also

Reference

UnionPropertyBase Class
GetAggregateValue Overload
VisualComponents.Create3D Namespace


UnionPropertyBase.GetAggregateValue Method (String)

UnionPropertyBaseGetAggregateValue Method (String)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected bool GetAggregateValue(
    string name = null
)
protected:
bool GetAggregateValue(
    String^ name = nullptr
)

Parameters

name (Optional)
Type: SystemString

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.UnionPropertyBase.GetAggregateValue(System.String)"]

See Also

Reference

UnionPropertyBase Class
GetAggregateValue Overload
VisualComponents.Create3D Namespace


UnionPropertyBase.InvokePropertyChanged Method

UnionPropertyBaseInvokePropertyChanged Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected void InvokePropertyChanged(
    string name
)
protected:
void InvokePropertyChanged(
    String^ name
)

Parameters

name
Type: SystemString
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.ResetDistinctionLevel Method

UnionPropertyBaseResetDistinctionLevel Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected void ResetDistinctionLevel()
protected:
void ResetDistinctionLevel()
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.SetAggregateValue Method

UnionPropertyBaseSetAggregateValue Method

Overload List
 | Name | Description
Protected method | SetAggregateValue(Boolean, String) |
Protected method | SetAggregateValue(ExpressionFuncBoolean, Boolean) |
Protected method | SetAggregateValue(String, Boolean) |
Top
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.SetAggregateValue Method (Boolean, String)

UnionPropertyBaseSetAggregateValue Method (Boolean, String)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected void SetAggregateValue(
    bool value,
    string property = null
)
protected:
void SetAggregateValue(
    bool value,
    String^ property = nullptr
)

Parameters

value
Type: SystemBoolean
property (Optional)
Type: SystemString
See Also

Reference

UnionPropertyBase Class
SetAggregateValue Overload
VisualComponents.Create3D Namespace


UnionPropertyBase.SetAggregateValue Method (Expression(Func(Boolean)), Boolean)

UnionPropertyBaseSetAggregateValue Method (ExpressionFuncBoolean, Boolean)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected void SetAggregateValue(
    Expression<Func<bool>> property,
    bool value
)
protected:
void SetAggregateValue(
    Expression<Func<bool>^>^ property,
    bool value
)

Parameters

property
Type: System.Linq.ExpressionsExpressionFuncBoolean
value
Type: SystemBoolean
See Also

Reference

UnionPropertyBase Class
SetAggregateValue Overload
VisualComponents.Create3D Namespace


UnionPropertyBase.SetAggregateValue Method (String, Boolean)

UnionPropertyBaseSetAggregateValue Method (String, Boolean)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected void SetAggregateValue(
    string name,
    bool value
)
protected:
void SetAggregateValue(
    String^ name,
    bool value
)

Parameters

name
Type: SystemString
value
Type: SystemBoolean
See Also

Reference

UnionPropertyBase Class
SetAggregateValue Overload
VisualComponents.Create3D Namespace


UnionPropertyBase.SetQuantity Method

UnionPropertyBaseSetQuantity Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IUnitGroup SetQuantity(
    string value
)
public:
virtual IUnitGroup^ SetQuantity(
    String^ value
) sealed

Parameters

value
Type: SystemString

Return Value

Type: IUnitGroup

[Missing <returns> documentation for "M:VisualComponents.Create3D.UnionPropertyBase.SetQuantity(System.String)"]

Implements

IPropertySetQuantity(String)
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.SetUnitMagnitude Method

UnionPropertyBaseSetUnitMagnitude Method

Set the unit magnitude for all properties.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetUnitMagnitude(
    double value
)
public:
virtual void SetUnitMagnitude(
    double value
) sealed

Parameters

value
Type: SystemDouble

Implements

IPropertySetUnitMagnitude(Double)
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.StartBatch Method

UnionPropertyBaseStartBatch Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartBatch()
public:
virtual void StartBatch() sealed

Implements

IPropertyStartBatch
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.StopListening Method

UnionPropertyBaseStopListening Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StopListening()
public:
virtual void StopListening() sealed

Implements

IUnionPropertyStopListening
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase Events

The UnionPropertyBase type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.PropertyChanged Event

UnionPropertyBasePropertyChanged Event

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event PropertyChangedEventHandler PropertyChanged
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase Fields

The UnionPropertyBase type exposes the following members.

Fields
Name | Description
MultipleValues |
Top
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnionPropertyBase.MultipleValues Field

UnionPropertyBaseMultipleValues Field

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected const string MultipleValues = "<multiple values>"
protected:
literal String^ MultipleValues = "<multiple values>"

Field Value

Type: String
See Also

Reference

UnionPropertyBase Class
VisualComponents.Create3D Namespace


UnitFamilyChangedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DUnitFamilyChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class UnitFamilyChangedEventArgs : EventArgs
public ref class UnitFamilyChangedEventArgs : public EventArgs

The UnitFamilyChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | UnitFamilyChangedEventArgs | Initializes a new instance of VisualComponents.Create3D.UnitFamilyChangedEventArgs.
Top
Properties
 | Name | Description
Public property | NewValue | New value
Public property | OldValue | Old Value
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


UnitFamilyChangedEventArgs Constructor

Initializes a new instance of VisualComponents.Create3D.UnitFamilyChangedEventArgs.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UnitFamilyChangedEventArgs(
    string oldValue,
    string newValue
)
public:
UnitFamilyChangedEventArgs(
    String^ oldValue,
    String^ newValue
)

Parameters

oldValue
Type: SystemString
Old value
newValue
Type: SystemString
New value
See Also

Reference

UnitFamilyChangedEventArgs Class
VisualComponents.Create3D Namespace


UnitFamilyChangedEventArgs Properties

The UnitFamilyChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | New value
Public property | OldValue | Old Value
Top
See Also

Reference

UnitFamilyChangedEventArgs Class
VisualComponents.Create3D Namespace


UnitFamilyChangedEventArgs.NewValue Property

UnitFamilyChangedEventArgsNewValue Property

New value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string NewValue { get; }
public:
property String^ NewValue {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

UnitFamilyChangedEventArgs Class
VisualComponents.Create3D Namespace


UnitFamilyChangedEventArgs.OldValue Property

UnitFamilyChangedEventArgsOldValue Property

Old Value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string OldValue { get; }
public:
property String^ OldValue {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

UnitFamilyChangedEventArgs Class
VisualComponents.Create3D Namespace


UnitFamilyChangedEventArgs Methods

The UnitFamilyChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UnitFamilyChangedEventArgs Class
VisualComponents.Create3D Namespace


UnSetupPythonActionMessage Class

Defines which action should be removed from UI.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DUnSetupPythonActionMessage

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class UnSetupPythonActionMessage
public ref class UnSetupPythonActionMessage

The UnSetupPythonActionMessage type exposes the following members.

Constructors
 | Name | Description
Public method | UnSetupPythonActionMessage | Initializes a new instance of the UnSetupPythonActionMessage class
Top
Properties
 | Name | Description
Public property | ActionId |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


UnSetupPythonActionMessage Constructor

Initializes a new instance of the UnSetupPythonActionMessage class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UnSetupPythonActionMessage()
public:
UnSetupPythonActionMessage()
See Also

Reference

UnSetupPythonActionMessage Class
VisualComponents.Create3D Namespace


UnSetupPythonActionMessage Properties

The UnSetupPythonActionMessage type exposes the following members.

Properties
 | Name | Description
Public property | ActionId |
Top
See Also

Reference

UnSetupPythonActionMessage Class
VisualComponents.Create3D Namespace


UnSetupPythonActionMessage.ActionId Property

UnSetupPythonActionMessageActionId Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ActionId { get; set; }
public:
property String^ ActionId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UnSetupPythonActionMessage Class
VisualComponents.Create3D Namespace


UnSetupPythonActionMessage Methods

The UnSetupPythonActionMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

UnSetupPythonActionMessage Class
VisualComponents.Create3D Namespace


UpAxis Enumeration

Axis from the CAD file that points up

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum UpAxis
public enum class UpAxis
Members
Member name | Value | Description
X | 0 | x Axis
Y | 1 | y Axis
Z | 2 | z Axis
NegativeX | 3 | -x Axis
NegativeY | 4 | -y Axis
NegativeZ | 5 | -z Axis
See Also

Reference

VisualComponents.Create3D Namespace


Wavefront Enumeration

OBJ format

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum Wavefront
public enum class Wavefront
Members
Member name | Value | Description
OBJ | 0 |
See Also

Reference

VisualComponents.Create3D Namespace


VCFlybyParameters Structure

Rounding information for the VC robot controller

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct VCFlybyParameters
public value class VCFlybyParameters

The VCFlybyParameters type exposes the following members.

Constructors
 | Name | Description
Public method | VCFlybyParameters | Initializes a new instance of the VCFlybyParameters class
Top
Properties
 | Name | Description
Public property | Method |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Equality |
Inequality |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


VCFlybyParameters Constructor

Initializes a new instance of the VCFlybyParameters class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VCFlybyParameters(
    AccuracyMethod method,
    double value
)
public:
VCFlybyParameters(
    AccuracyMethod method,
    double value
)

Parameters

method
Type: VisualComponents.Create3DAccuracyMethod
value
Type: SystemDouble
See Also

Reference

VCFlybyParameters Structure
VisualComponents.Create3D Namespace


VCFlybyParameters Properties

The VCFlybyParameters type exposes the following members.

Properties
 | Name | Description
Public property | Method |
Public property | Value |
Top
See Also

Reference

VCFlybyParameters Structure
VisualComponents.Create3D Namespace


VCFlybyParameters.Method Property

VCFlybyParametersMethod Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AccuracyMethod Method { get; }
public:
property AccuracyMethod Method {
    AccuracyMethod get ();
}

Property Value

Type: AccuracyMethod
See Also

Reference

VCFlybyParameters Structure
VisualComponents.Create3D Namespace


VCFlybyParameters.Value Property

VCFlybyParametersValue Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Value { get; }
public:
property double Value {
    double get ();
}

Property Value

Type: Double
See Also

Reference

VCFlybyParameters Structure
VisualComponents.Create3D Namespace


VCFlybyParameters Methods

The VCFlybyParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VCFlybyParameters Structure
VisualComponents.Create3D Namespace


VCFlybyParameters.Equals Method

VCFlybyParametersEquals Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.VCFlybyParameters.Equals(System.Object)"]

See Also

Reference

VCFlybyParameters Structure
VisualComponents.Create3D Namespace


VCFlybyParameters.GetHashCode Method

VCFlybyParametersGetHashCode Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Create3D.VCFlybyParameters.GetHashCode"]

See Also

Reference

VCFlybyParameters Structure
VisualComponents.Create3D Namespace


VCFlybyParameters Operators

The VCFlybyParameters type exposes the following members.

Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

VCFlybyParameters Structure
VisualComponents.Create3D Namespace


VCFlybyParameters.Equality Operator

VCFlybyParametersEquality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    VCFlybyParameters obj1,
    VCFlybyParameters obj2
)
public:
static bool operator ==(
    VCFlybyParameters obj1,
    VCFlybyParameters obj2
)

Parameters

obj1
Type: VisualComponents.Create3DVCFlybyParameters
obj2
Type: VisualComponents.Create3DVCFlybyParameters

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.VCFlybyParameters.op_Equality(VisualComponents.Create3D.VCFlybyParameters,VisualComponents.Create3D.VCFlybyParameters)"]

See Also

Reference

VCFlybyParameters Structure
VisualComponents.Create3D Namespace


VCFlybyParameters.Inequality Operator

VCFlybyParametersInequality Operator

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    VCFlybyParameters obj1,
    VCFlybyParameters obj2
)
public:
static bool operator !=(
    VCFlybyParameters obj1,
    VCFlybyParameters obj2
)

Parameters

obj1
Type: VisualComponents.Create3DVCFlybyParameters
obj2
Type: VisualComponents.Create3DVCFlybyParameters

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.VCFlybyParameters.op_Inequality(VisualComponents.Create3D.VCFlybyParameters,VisualComponents.Create3D.VCFlybyParameters)"]

See Also

Reference

VCFlybyParameters Structure
VisualComponents.Create3D Namespace


VCPath Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DVCPath

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class VCPath
public ref class VCPath

The VCPath type exposes the following members.

Constructors
 | Name | Description
Public method | VCPath | Initializes a new instance of the VCPath class
Top
Properties
 | Name | Description
Public property | Data |
Public property | FillColor |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


VCPath Constructor

Initializes a new instance of the VCPath class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VCPath()
public:
VCPath()
See Also

Reference

VCPath Class
VisualComponents.Create3D Namespace


VCPath Properties

The VCPath type exposes the following members.

Properties
 | Name | Description
Public property | Data |
Public property | FillColor |
Top
See Also

Reference

VCPath Class
VisualComponents.Create3D Namespace


VCPath.Data Property

VCPathData Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Data { get; set; }
public:
property String^ Data {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

VCPath Class
VisualComponents.Create3D Namespace


VCPath.FillColor Property

VCPathFillColor Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SolidColorBrush FillColor { get; set; }
public:
property SolidColorBrush^ FillColor {
    SolidColorBrush^ get ();
    void set (SolidColorBrush^ value);
}

Property Value

Type: SolidColorBrush
See Also

Reference

VCPath Class
VisualComponents.Create3D Namespace


VCPath Methods

The VCPath type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VCPath Class
VisualComponents.Create3D Namespace


VCPathObject Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DVCPathObject

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class VCPathObject
public ref class VCPathObject

The VCPathObject type exposes the following members.

Constructors
 | Name | Description
Public method | VCPathObject | Initializes a new instance of the VCPathObject class
Top
Properties
 | Name | Description
Public property | Data0 |
Public property | Data1 |
Public property | Data2 |
Public property | Data3 |
Public property | Data4 |
Public property | FillColor0 |
Public property | FillColor1 |
Public property | FillColor2 |
Public property | FillColor3 |
Public property | FillColor4 |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


VCPathObject Constructor

Initializes a new instance of the VCPathObject class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VCPathObject()
public:
VCPathObject()
See Also

Reference

VCPathObject Class
VisualComponents.Create3D Namespace


VCPathObject Properties

The VCPathObject type exposes the following members.

Properties
 | Name | Description
Public property | Data0 |
Public property | Data1 |
Public property | Data2 |
Public property | Data3 |
Public property | Data4 |
Public property | FillColor0 |
Public property | FillColor1 |
Public property | FillColor2 |
Public property | FillColor3 |
Public property | FillColor4 |
Top
See Also

Reference

VCPathObject Class
VisualComponents.Create3D Namespace


VCPathObject.Data0 Property

VCPathObjectData0 Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Data0 { get; set; }
public:
property String^ Data0 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

VCPathObject Class
VisualComponents.Create3D Namespace


VCPathObject.Data1 Property

VCPathObjectData1 Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Data1 { get; set; }
public:
property String^ Data1 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

VCPathObject Class
VisualComponents.Create3D Namespace


VCPathObject.Data2 Property

VCPathObjectData2 Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Data2 { get; set; }
public:
property String^ Data2 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

VCPathObject Class
VisualComponents.Create3D Namespace


VCPathObject.Data3 Property

VCPathObjectData3 Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Data3 { get; set; }
public:
property String^ Data3 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

VCPathObject Class
VisualComponents.Create3D Namespace


VCPathObject.Data4 Property

VCPathObjectData4 Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Data4 { get; set; }
public:
property String^ Data4 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

VCPathObject Class
VisualComponents.Create3D Namespace


VCPathObject.FillColor0 Property

VCPathObjectFillColor0 Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SolidColorBrush FillColor0 { get; set; }
public:
property SolidColorBrush^ FillColor0 {
    SolidColorBrush^ get ();
    void set (SolidColorBrush^ value);
}

Property Value

Type: SolidColorBrush
See Also

Reference

VCPathObject Class
VisualComponents.Create3D Namespace


VCPathObject.FillColor1 Property

VCPathObjectFillColor1 Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SolidColorBrush FillColor1 { get; set; }
public:
property SolidColorBrush^ FillColor1 {
    SolidColorBrush^ get ();
    void set (SolidColorBrush^ value);
}

Property Value

Type: SolidColorBrush
See Also

Reference

VCPathObject Class
VisualComponents.Create3D Namespace


VCPathObject.FillColor2 Property

VCPathObjectFillColor2 Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SolidColorBrush FillColor2 { get; set; }
public:
property SolidColorBrush^ FillColor2 {
    SolidColorBrush^ get ();
    void set (SolidColorBrush^ value);
}

Property Value

Type: SolidColorBrush
See Also

Reference

VCPathObject Class
VisualComponents.Create3D Namespace


VCPathObject.FillColor3 Property

VCPathObjectFillColor3 Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SolidColorBrush FillColor3 { get; set; }
public:
property SolidColorBrush^ FillColor3 {
    SolidColorBrush^ get ();
    void set (SolidColorBrush^ value);
}

Property Value

Type: SolidColorBrush
See Also

Reference

VCPathObject Class
VisualComponents.Create3D Namespace


VCPathObject.FillColor4 Property

VCPathObjectFillColor4 Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SolidColorBrush FillColor4 { get; set; }
public:
property SolidColorBrush^ FillColor4 {
    SolidColorBrush^ get ();
    void set (SolidColorBrush^ value);
}

Property Value

Type: SolidColorBrush
See Also

Reference

VCPathObject Class
VisualComponents.Create3D Namespace


VCPathObject Methods

The VCPathObject type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VCPathObject Class
VisualComponents.Create3D Namespace


VDA Enumeration

VDA -> Version 1.0 and 2.0

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum VDA
public enum class VDA
Members
Member name | Value | Description
VDA | 0 |
See Also

Reference

VisualComponents.Create3D Namespace


WeakEventManager Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DWeakEventManager

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class WeakEventManager
public ref class WeakEventManager

The WeakEventManager type exposes the following members.

Constructors
 | Name | Description
Public method | WeakEventManager | Initializes a new instance of the WeakEventManager class
Top
Properties
 | Name | Description
Public property | HandlerCount |
 | TotalCount |
Top
Methods
 | Name | Description
Public method | Add |
Public method | Clear |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove |
Public method | SafeInvoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


WeakEventManager Constructor

Initializes a new instance of the WeakEventManager class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public WeakEventManager()
public:
WeakEventManager()
See Also

Reference

WeakEventManager Class
VisualComponents.Create3D Namespace


WeakEventManager Properties

The WeakEventManager type exposes the following members.

Properties
 | Name | Description
Public property | HandlerCount |
 | TotalCount |
Top
See Also

Reference

WeakEventManager Class
VisualComponents.Create3D Namespace


WeakEventManager.HandlerCount Property

WeakEventManagerHandlerCount Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int HandlerCount { get; }
public:
property int HandlerCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

WeakEventManager Class
VisualComponents.Create3D Namespace


WeakEventManager.TotalCount Property

WeakEventManagerTotalCount Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int TotalCount { get; set; }
public:
static property int TotalCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

WeakEventManager Class
VisualComponents.Create3D Namespace


WeakEventManager Methods

The WeakEventManager type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Public method | Clear |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove |
Public method | SafeInvoke |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

WeakEventManager Class
VisualComponents.Create3D Namespace


WeakEventManager.Add Method

WeakEventManagerAdd Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Add(
    Delegate handler
)
public:
void Add(
    Delegate^ handler
)

Parameters

handler
Type: SystemDelegate
See Also

Reference

WeakEventManager Class
VisualComponents.Create3D Namespace


WeakEventManager.Clear Method

WeakEventManagerClear Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Clear()
public:
void Clear()
See Also

Reference

WeakEventManager Class
VisualComponents.Create3D Namespace


WeakEventManager.Remove Method

WeakEventManagerRemove Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Remove(
    Delegate handler
)
public:
bool Remove(
    Delegate^ handler
)

Parameters

handler
Type: SystemDelegate

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.WeakEventManager.Remove(System.Delegate)"]

See Also

Reference

WeakEventManager Class
VisualComponents.Create3D Namespace


WeakEventManager.SafeInvoke Method

WeakEventManagerSafeInvoke Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SafeInvoke(
    string eventId,
    params Object[] args
)
public:
void SafeInvoke(
    String^ eventId,
    ... array<Object^>^ args
)

Parameters

eventId
Type: SystemString
args
Type: SystemObject
See Also

Reference

WeakEventManager Class
VisualComponents.Create3D Namespace


Vector3 Structure

Represents a vector in 3D space

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct Vector3
public value class Vector3

The Vector3 type exposes the following members.

Constructors
 | Name | Description
Public method | Vector3(Vector3D) | Initializes a new Vector3 from Vector3D structure
Public method | Vector3(Double, Double, Double) | Initializes a new Vector3 instance
Public method | Vector3(Double, Double, Double, Double) | Initializes a new Vector3 instance
Top
Properties
 | Name | Description
Public property | Item | Access X, Y, Z values using indexes [0], [1], [2] respectively.
Public property | Length | Gets the length of this Vector3
Public property | LengthSquared | Gets the square of the length of this Vector3
Public property | W | Gets or sets the Vector3 W value
Public property | X | Gets or sets the Vector3 X-axis value
Public property | Y | Gets or sets the Vector3 Y-axis value
Public property | Z | Gets or sets the Vector3 Z-axis value
Top
Methods
 | Name | Description
 | Add | Adds two vectors and returns a new Vector3 instance
 | AngleBetween | Calculates the angle between two Vector3 instances
 | Cross | Calculated the cross product of two vectors and returns a new Vector3 instance
 | Divide | Divides the vector with a number and returns a new Vector3 instance
 | Dot | Calculates the dot (scalar) product of two Vector3 instances
Public method | Equals(Object) | Compares two Vector3 instances for equality (Overrides ValueTypeEquals(Object).)
 | Equals(Vector3, Vector3) | Compares two Vector3 instances for equality
Public method | EqualsThreshold(Vector3) | Compares two Vector3 instances for equality using threshold/tolerance
Public method | EqualsThreshold(Vector3, Double) | Compares two Vector3 instances for equality using threshold/tolerance
Public method | GetHashCode | Gets a hash code for this structure (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Multiply(Vector3, Double) | Multiplies the vector with a number and returns a new Vector3 instance
 | Multiply(Vector3, Matrix) | Multiplies the specified Vector3 by Matrix
Public method | Normalize | The normalized vector is a vector in the same direction but with the length of 1.
 | Parse | Converts string representation of a vector to equivalent Vector3 instance
 | Reflect | Calculates a vector of equal length to the given Vector3 but with its direction reflected
Public method | Set | Initializes a Vector3
 | Subtract | Subtracts vector2 from vector1 and returns a new Vector3 instance ///
 | ToMedia3D | Transforms Vector3 to a new Vector3D structure
Public method | ToString | Creates a string representation of the Vector3 (Overrides ValueTypeToString.)
Public method | TransformDirection(Matrix) | Transforms the specified direction into Matrix coordinate system.
 | TransformDirection(Vector3, Matrix) | Transforms the specified direction into Matrix coordinate system.
Top
Operators
Name | Description
Addition | Adds two vectors and returns the result as a new Vector3 instance
Division | Divides a vector with a number and returns a new Vector3 instance
Equality | Compares two Vector3 instances for equality
(Point3D to Vector3) | Transforms Point3D structure to a new Vector3 instance
(Quaternion to Vector3) | Transforms Quaternion structure to a new Vector3 instance
(Vector3D to Vector3) | Transforms Vector3D structure to a new Vector3 instance
(Point to Vector3) |
(Vector3 to Vector3D) | Transforms Vector3 to a new Vector3D structure
(Vector3 to Point3D) | Transforms Vector3 to a new Point3D structure
(Vector3 to Quaternion) | Transforms Vector3 to a new Quaternion structure
Inequality | Compares two Vector3 instances for inequality
Modulus | Calculates the cross product of two vectors and returns a new Vector3 instance
Multiply(Double, Vector3) | Multiplies the vector with a number and returns a new Vector3 instance
Multiply(Vector3, Double) | Multiplies the vector with a number and returns a new Vector3 instance
Multiply(Vector3, Matrix) | Multiplies the specified vector by Vector3
Multiply(Vector3, Vector3) | Calculates the dot (scalar) product of two Vector3 instances
Subtraction | Subtracts a vector from a vector and returns a new Vector3 instance
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToStringRounded(Int32) | Overloaded. (Defined by MathHelper.)
Public Extension Method | ToStringRounded(Int32, String) | Overloaded. (Defined by MathHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


Vector3 Constructor

Overload List
 | Name | Description
Public method | Vector3(Vector3D) | Initializes a new Vector3 from Vector3D structure
Public method | Vector3(Double, Double, Double) | Initializes a new Vector3 instance
Public method | Vector3(Double, Double, Double, Double) | Initializes a new Vector3 instance
Top
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3 Constructor (Vector3D)

Initializes a new Vector3 from Vector3D structure

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3(
    Vector3D vector3D
)
public:
Vector3(
    Vector3D vector3D
)

Parameters

vector3D
Type: System.Windows.Media.Media3DVector3D
Vector to be initialized from
See Also

Reference

Vector3 Structure
Vector3 Overload
VisualComponents.Create3D Namespace


Vector3 Constructor (Double, Double, Double)

Initializes a new Vector3 instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3(
    double x,
    double y,
    double z
)
public:
Vector3(
    double x,
    double y,
    double z
)

Parameters

x
Type: SystemDouble
X-axis value
y
Type: SystemDouble
Y-axis value
z
Type: SystemDouble
Z-axis value
See Also

Reference

Vector3 Structure
Vector3 Overload
VisualComponents.Create3D Namespace


Vector3 Constructor (Double, Double, Double, Double)

Initializes a new Vector3 instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3(
    double x,
    double y,
    double z,
    double w
)
public:
Vector3(
    double x,
    double y,
    double z,
    double w
)

Parameters

x
Type: SystemDouble
X-axis value
y
Type: SystemDouble
Y-axis value
z
Type: SystemDouble
Z-axis value
w
Type: SystemDouble
W value
See Also

Reference

Vector3 Structure
Vector3 Overload
VisualComponents.Create3D Namespace


Vector3 Properties

The Vector3 type exposes the following members.

Properties
 | Name | Description
Public property | Item | Access X, Y, Z values using indexes [0], [1], [2] respectively.
Public property | Length | Gets the length of this Vector3
Public property | LengthSquared | Gets the square of the length of this Vector3
Public property | W | Gets or sets the Vector3 W value
Public property | X | Gets or sets the Vector3 X-axis value
Public property | Y | Gets or sets the Vector3 Y-axis value
Public property | Z | Gets or sets the Vector3 Z-axis value
Top
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.Item Property

Vector3Item Property

Access X, Y, Z values using indexes [0], [1], [2] respectively.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double this[
    int index
] { get; set; }
public:
property double default[int index] {
    double get (int index);
    void set (int index, double value);
}

Parameters

index
Type: SystemInt32
Index

Return Value

Type: Double
Value
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.Length Property

Vector3Length Property

Gets the length of this Vector3

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Length { get; }
public:
property double Length {
    double get ();
}

Property Value

Type: Double
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.LengthSquared Property

Vector3LengthSquared Property

Gets the square of the length of this Vector3

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double LengthSquared { get; }
public:
property double LengthSquared {
    double get ();
}

Property Value

Type: Double
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.W Property

Vector3W Property

Gets or sets the Vector3 W value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double W { get; set; }
public:
property double W {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.X Property

Vector3X Property

Gets or sets the Vector3 X-axis value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double X { get; set; }
public:
property double X {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.Y Property

Vector3Y Property

Gets or sets the Vector3 Y-axis value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Y { get; set; }
public:
property double Y {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.Z Property

Vector3Z Property

Gets or sets the Vector3 Z-axis value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Z { get; set; }
public:
property double Z {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3 Methods

The Vector3 type exposes the following members.

Methods
 | Name | Description
 | Add | Adds two vectors and returns a new Vector3 instance
 | AngleBetween | Calculates the angle between two Vector3 instances
 | Cross | Calculated the cross product of two vectors and returns a new Vector3 instance
 | Divide | Divides the vector with a number and returns a new Vector3 instance
 | Dot | Calculates the dot (scalar) product of two Vector3 instances
Public method | Equals(Object) | Compares two Vector3 instances for equality (Overrides ValueTypeEquals(Object).)
 | Equals(Vector3, Vector3) | Compares two Vector3 instances for equality
Public method | EqualsThreshold(Vector3) | Compares two Vector3 instances for equality using threshold/tolerance
Public method | EqualsThreshold(Vector3, Double) | Compares two Vector3 instances for equality using threshold/tolerance
Public method | GetHashCode | Gets a hash code for this structure (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Multiply(Vector3, Double) | Multiplies the vector with a number and returns a new Vector3 instance
 | Multiply(Vector3, Matrix) | Multiplies the specified Vector3 by Matrix
Public method | Normalize | The normalized vector is a vector in the same direction but with the length of 1.
 | Parse | Converts string representation of a vector to equivalent Vector3 instance
 | Reflect | Calculates a vector of equal length to the given Vector3 but with its direction reflected
Public method | Set | Initializes a Vector3
 | Subtract | Subtracts vector2 from vector1 and returns a new Vector3 instance ///
 | ToMedia3D | Transforms Vector3 to a new Vector3D structure
Public method | ToString | Creates a string representation of the Vector3 (Overrides ValueTypeToString.)
Public method | TransformDirection(Matrix) | Transforms the specified direction into Matrix coordinate system.
 | TransformDirection(Vector3, Matrix) | Transforms the specified direction into Matrix coordinate system.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToStringRounded(Int32) | Overloaded. (Defined by MathHelper.)
Public Extension Method | ToStringRounded(Int32, String) | Overloaded. (Defined by MathHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.Add Method

Vector3Add Method

Adds two vectors and returns a new Vector3 instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Vector3 Add(
    Vector3 vector1,
    Vector3 vector2
)
public:
static Vector3 Add(
    Vector3 vector1,
    Vector3 vector2
)

Parameters

vector1
Type: VisualComponents.Create3DVector3
First vector
vector2
Type: VisualComponents.Create3DVector3
Second vector

Return Value

Type: Vector3
Result vector
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.AngleBetween Method

Vector3AngleBetween Method

Calculates the angle between two Vector3 instances

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static double AngleBetween(
    Vector3 vector1,
    Vector3 vector2
)
public:
static double AngleBetween(
    Vector3 vector1,
    Vector3 vector2
)

Parameters

vector1
Type: VisualComponents.Create3DVector3
The first vector to evaluate
vector2
Type: VisualComponents.Create3DVector3
The second vector to evaluate

Return Value

Type: Double
Angle between vector1 and vector2 in radians
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.Cross Method

Vector3Cross Method

Calculated the cross product of two vectors and returns a new Vector3 instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Vector3 Cross(
    Vector3 vector1,
    Vector3 vector2
)
public:
static Vector3 Cross(
    Vector3 vector1,
    Vector3 vector2
)

Parameters

vector1
Type: VisualComponents.Create3DVector3
The first vector to evaluate
vector2
Type: VisualComponents.Create3DVector3
The second vector to evaluate

Return Value

Type: Vector3
Cross product of vector1 and vector2
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.Divide Method

Vector3Divide Method

Divides the vector with a number and returns a new Vector3 instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Vector3 Divide(
    Vector3 vector,
    double number
)
public:
static Vector3 Divide(
    Vector3 vector,
    double number
)

Parameters

vector
Type: VisualComponents.Create3DVector3
The vector to be divided
number
Type: SystemDouble
Denominator

Return Value

Type: Vector3
Result vector
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.Dot Method

Vector3Dot Method

Calculates the dot (scalar) product of two Vector3 instances

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static double Dot(
    Vector3 vector1,
    Vector3 vector2
)
public:
static double Dot(
    Vector3 vector1,
    Vector3 vector2
)

Parameters

vector1
Type: VisualComponents.Create3DVector3
The first vector to evaluate
vector2
Type: VisualComponents.Create3DVector3
The second vector to evaluate

Return Value

Type: Double
Dot product of vector1 and vector2
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.Equals Method

Vector3Equals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Compares two Vector3 instances for equality (Overrides ValueTypeEquals(Object).)
 | Equals(Vector3, Vector3) | Compares two Vector3 instances for equality
Top
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.Equals Method (Object)

Vector3Equals Method (Object)

Compares two Vector3 instances for equality

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
The vector to compare

Return Value

Type: Boolean
True if obj is identical with this vector; false otherwise.
See Also

Reference

Vector3 Structure
Equals Overload
VisualComponents.Create3D Namespace


Vector3.Equals Method (Vector3, Vector3)

Vector3Equals Method (Vector3, Vector3)

Compares two Vector3 instances for equality

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool Equals(
    Vector3 vector1,
    Vector3 vector2
)
public:
static bool Equals(
    Vector3 vector1,
    Vector3 vector2
)

Parameters

vector1
Type: VisualComponents.Create3DVector3
The first vector
vector2
Type: VisualComponents.Create3DVector3
The second vector

Return Value

Type: Boolean
True if the vectors are identical; false otherwise.
See Also

Reference

Vector3 Structure
Equals Overload
VisualComponents.Create3D Namespace


Vector3.EqualsThreshold Method

Vector3EqualsThreshold Method

Overload List
 | Name | Description
Public method | EqualsThreshold(Vector3) | Compares two Vector3 instances for equality using threshold/tolerance
Public method | EqualsThreshold(Vector3, Double) | Compares two Vector3 instances for equality using threshold/tolerance
Top
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.EqualsThreshold Method (Vector3)

Vector3EqualsThreshold Method (Vector3)

Compares two Vector3 instances for equality using threshold/tolerance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool EqualsThreshold(
    Vector3 vector2
)
public:
bool EqualsThreshold(
    Vector3 vector2
)

Parameters

vector2
Type: VisualComponents.Create3DVector3
The second vector

Return Value

Type: Boolean
True if the vectors are identical; false otherwise.
See Also

Reference

Vector3 Structure
EqualsThreshold Overload
VisualComponents.Create3D Namespace


Vector3.EqualsThreshold Method (Vector3, Double)

Vector3EqualsThreshold Method (Vector3, Double)

Compares two Vector3 instances for equality using threshold/tolerance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool EqualsThreshold(
    Vector3 vector2,
    double threshold
)
public:
bool EqualsThreshold(
    Vector3 vector2,
    double threshold
)

Parameters

vector2
Type: VisualComponents.Create3DVector3
The second vector
threshold
Type: SystemDouble
The threshold value

Return Value

Type: Boolean
True if the vectors are identical; false otherwise.
See Also

Reference

Vector3 Structure
EqualsThreshold Overload
VisualComponents.Create3D Namespace


Vector3.GetHashCode Method

Vector3GetHashCode Method

Gets a hash code for this structure

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32
Hash code
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.Multiply Method

Vector3Multiply Method

Overload List
Name | Description
Multiply(Vector3, Double) | Multiplies the vector with a number and returns a new Vector3 instance
Multiply(Vector3, Matrix) | Multiplies the specified Vector3 by Matrix
Top
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.Multiply Method (Vector3, Double)

Vector3Multiply Method (Vector3, Double)

Multiplies the vector with a number and returns a new Vector3 instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Vector3 Multiply(
    Vector3 vector,
    double number
)
public:
static Vector3 Multiply(
    Vector3 vector,
    double number
)

Parameters

vector
Type: VisualComponents.Create3DVector3
Vector to be multiplied
number
Type: SystemDouble
Multiplier

Return Value

Type: Vector3
Result vector
See Also

Reference

Vector3 Structure
Multiply Overload
VisualComponents.Create3D Namespace


Vector3.Multiply Method (Vector3, Matrix)

Vector3Multiply Method (Vector3, Matrix)

Multiplies the specified Vector3 by Matrix

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Vector3 Multiply(
    Vector3 vector,
    Matrix matrix
)
public:
static Vector3 Multiply(
    Vector3 vector,
    Matrix matrix
)

Parameters

vector
Type: VisualComponents.Create3DVector3
Vector to multiply
matrix
Type: VisualComponents.Create3DMatrix
Matrix by which the vector is multiplied

Return Value

Type: Vector3
Vector that is the result of multiplication
See Also

Reference

Vector3 Structure
Multiply Overload
VisualComponents.Create3D Namespace


Vector3.Normalize Method

Vector3Normalize Method

The normalized vector is a vector in the same direction but with the length of 1.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Normalize()
public:
void Normalize()
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.Parse Method

Vector3Parse Method

Converts string representation of a vector to equivalent Vector3 instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Vector3 Parse(
    string source
)
public:
static Vector3 Parse(
    String^ source
)

Parameters

source
Type: SystemString
String representation of the vector

Return Value

Type: Vector3
Result vector
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.Reflect Method

Vector3Reflect Method

Calculates a vector of equal length to the given Vector3 but with its direction reflected

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Vector3 Reflect(
    Vector3 vector,
    Vector3 normal
)
public:
static Vector3 Reflect(
    Vector3 vector,
    Vector3 normal
)

Parameters

vector
Type: VisualComponents.Create3DVector3
Input vector
normal
Type: VisualComponents.Create3DVector3
Normal vector representing the reflection plane

Return Value

Type: Vector3
Reflected vector
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.Set Method

Vector3Set Method

Initializes a Vector3

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Set(
    double x,
    double y,
    double z,
    double w
)
public:
void Set(
    double x,
    double y,
    double z,
    double w
)

Parameters

x
Type: SystemDouble
X-axis value
y
Type: SystemDouble
Y-axis value
z
Type: SystemDouble
Z-axis value
w
Type: SystemDouble
W value
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.Subtract Method

Vector3Subtract Method

Subtracts vector2 from vector1 and returns a new Vector3 instance ///

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Vector3 Subtract(
    Vector3 vector1,
    Vector3 vector2
)
public:
static Vector3 Subtract(
    Vector3 vector1,
    Vector3 vector2
)

Parameters

vector1
Type: VisualComponents.Create3DVector3
The vector to be subtracted from
vector2
Type: VisualComponents.Create3DVector3
The vector to subtract from vector1

Return Value

Type: Vector3
Result vector
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.ToMedia3D Method

Vector3ToMedia3D Method

Transforms Vector3 to a new Vector3D structure

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Vector3D ToMedia3D(
    Vector3 vector
)
public:
static Vector3D ToMedia3D(
    Vector3 vector
)

Parameters

vector
Type: VisualComponents.Create3DVector3
Source vector

Return Value

Type: Vector3D
System.Windows.Media.Media3D.Vector3D structure
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.ToString Method

Vector3ToString Method

Creates a string representation of the Vector3

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String
String representation of the vector
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.TransformDirection Method

Vector3TransformDirection Method

Overload List
 | Name | Description
Public method | TransformDirection(Matrix) | Transforms the specified direction into Matrix coordinate system.
 | TransformDirection(Vector3, Matrix) | Transforms the specified direction into Matrix coordinate system.
Top
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.TransformDirection Method (Matrix)

Vector3TransformDirection Method (Matrix)

Transforms the specified direction into Matrix coordinate system.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 TransformDirection(
    Matrix matrix
)
public:
Vector3 TransformDirection(
    Matrix matrix
)

Parameters

matrix
Type: VisualComponents.Create3DMatrix
Matrix by which the vector is multiplied

Return Value

Type: Vector3
Vector that is the result of multiplication
See Also

Reference

Vector3 Structure
TransformDirection Overload
VisualComponents.Create3D Namespace


Vector3.TransformDirection Method (Vector3, Matrix)

Vector3TransformDirection Method (Vector3, Matrix)

Transforms the specified direction into Matrix coordinate system.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Vector3 TransformDirection(
    Vector3 vector,
    Matrix matrix
)
public:
static Vector3 TransformDirection(
    Vector3 vector,
    Matrix matrix
)

Parameters

vector
Type: VisualComponents.Create3DVector3
Vector to multiply
matrix
Type: VisualComponents.Create3DMatrix
Matrix by which the vector is multiplied

Return Value

Type: Vector3
Vector that is the result of multiplication
See Also

Reference

Vector3 Structure
TransformDirection Overload
VisualComponents.Create3D Namespace


Vector3 Operators and Type Conversions

The Vector3 type exposes the following members.

Operators
Name | Description
Addition | Adds two vectors and returns the result as a new Vector3 instance
Division | Divides a vector with a number and returns a new Vector3 instance
Equality | Compares two Vector3 instances for equality
(Point3D to Vector3) | Transforms Point3D structure to a new Vector3 instance
(Quaternion to Vector3) | Transforms Quaternion structure to a new Vector3 instance
(Vector3D to Vector3) | Transforms Vector3D structure to a new Vector3 instance
(Point to Vector3) |
(Vector3 to Vector3D) | Transforms Vector3 to a new Vector3D structure
(Vector3 to Point3D) | Transforms Vector3 to a new Point3D structure
(Vector3 to Quaternion) | Transforms Vector3 to a new Quaternion structure
Inequality | Compares two Vector3 instances for inequality
Modulus | Calculates the cross product of two vectors and returns a new Vector3 instance
Multiply(Double, Vector3) | Multiplies the vector with a number and returns a new Vector3 instance
Multiply(Vector3, Double) | Multiplies the vector with a number and returns a new Vector3 instance
Multiply(Vector3, Matrix) | Multiplies the specified vector by Vector3
Multiply(Vector3, Vector3) | Calculates the dot (scalar) product of two Vector3 instances
Subtraction | Subtracts a vector from a vector and returns a new Vector3 instance
Top
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.Addition Operator

Vector3Addition Operator

Adds two vectors and returns the result as a new Vector3 instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Vector3 operator +(
    Vector3 vector1,
    Vector3 vector2
)
public:
static Vector3 operator +(
    Vector3 vector1,
    Vector3 vector2
)

Parameters

vector1
Type: VisualComponents.Create3DVector3
The first vector
vector2
Type: VisualComponents.Create3DVector3
The second vector

Return Value

Type: Vector3
Result vector
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.Division Operator

Vector3Division Operator

Divides a vector with a number and returns a new Vector3 instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Vector3 operator /(
    Vector3 vector,
    double number
)
public:
static Vector3 operator /(
    Vector3 vector,
    double number
)

Parameters

vector
Type: VisualComponents.Create3DVector3
Vector to be divided
number
Type: SystemDouble
Denominator

Return Value

Type: Vector3
Result vector
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.Equality Operator

Vector3Equality Operator

Compares two Vector3 instances for equality

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    Vector3 vector1,
    Vector3 vector2
)
public:
static bool operator ==(
    Vector3 vector1,
    Vector3 vector2
)

Parameters

vector1
Type: VisualComponents.Create3DVector3
The first vector to compare
vector2
Type: VisualComponents.Create3DVector3
The second vector to compare against

Return Value

Type: Boolean
True if the vectors are identical; false otherwise.
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3 Explicit Conversion Operators

Vector3 Conversion Operators

Overload List
Name | Description
(Point3D to Vector3) | Transforms Point3D structure to a new Vector3 instance
(Quaternion to Vector3) | Transforms Quaternion structure to a new Vector3 instance
(Vector3D to Vector3) | Transforms Vector3D structure to a new Vector3 instance
(Point to Vector3) |
(Vector3 to Vector3D) | Transforms Vector3 to a new Vector3D structure
(Vector3 to Point3D) | Transforms Vector3 to a new Point3D structure
(Vector3 to Quaternion) | Transforms Vector3 to a new Quaternion structure
Top
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3 Explicit Conversion (Point3D to Vector3)

Vector3 Conversion (Point3D to Vector3)

Transforms Point3D structure to a new Vector3 instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static explicit operator Vector3 (
    Point3D vector
)
static explicit operator Vector3 (
    Point3D vector
)

Parameters

vector
Type: System.Windows.Media.Media3DPoint3D
Vector to be type casted

Return Value

Type: Vector3
Result vector as new Vector structure
See Also

Reference

Vector3 Structure
Overload
VisualComponents.Create3D Namespace


Vector3 Explicit Conversion (Quaternion to Vector3)

Vector3 Conversion (Quaternion to Vector3)

Transforms Quaternion structure to a new Vector3 instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static explicit operator Vector3 (
    Quaternion quaternion
)
static explicit operator Vector3 (
    Quaternion quaternion
)

Parameters

quaternion
Type: System.Windows.Media.Media3DQuaternion

Return Value

Type: Vector3
Result vector as new Vector structure
See Also

Reference

Vector3 Structure
Overload
VisualComponents.Create3D Namespace


Vector3 Explicit Conversion (Vector3D to Vector3)

Vector3 Conversion (Vector3D to Vector3)

Transforms Vector3D structure to a new Vector3 instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static explicit operator Vector3 (
    Vector3D vector
)
static explicit operator Vector3 (
    Vector3D vector
)

Parameters

vector
Type: System.Windows.Media.Media3DVector3D
Vector to be type casted

Return Value

Type: Vector3
Result vector as new Vector structure
See Also

Reference

Vector3 Structure
Overload
VisualComponents.Create3D Namespace


Vector3 Explicit Conversion (Point to Vector3)

Vector3 Conversion (Point to Vector3)

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static explicit operator Vector3 (
    Point vector
)
static explicit operator Vector3 (
    Point vector
)

Parameters

vector
Type: System.WindowsPoint

Return Value

Type: Vector3

[Missing <returns> documentation for "M:VisualComponents.Create3D.Vector3.op_Explicit(System.Windows.Point)~VisualComponents.Create3D.Vector3"]

See Also

Reference

Vector3 Structure
Overload
VisualComponents.Create3D Namespace


Vector3 Explicit Conversion (Vector3 to Vector3D)

Vector3 Conversion (Vector3 to Vector3D)

Transforms Vector3 to a new Vector3D structure

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static explicit operator Vector3D (
    Vector3 vector
)
static explicit operator Vector3D (
    Vector3 vector
)

Parameters

vector
Type: VisualComponents.Create3DVector3
Vector to be type casted

Return Value

Type: Vector3D
Result vector as new System.Windows.Media.Media3D.Vector3D structure
See Also

Reference

Vector3 Structure
Overload
VisualComponents.Create3D Namespace


Vector3 Explicit Conversion (Vector3 to Point3D)

Vector3 Conversion (Vector3 to Point3D)

Transforms Vector3 to a new Point3D structure

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static explicit operator Point3D (
    Vector3 vector
)
static explicit operator Point3D (
    Vector3 vector
)

Parameters

vector
Type: VisualComponents.Create3DVector3
Vector to be type casted

Return Value

Type: Point3D
Result vector as new System.Windows.Media.Media3D.Vector3D structure
See Also

Reference

Vector3 Structure
Overload
VisualComponents.Create3D Namespace


Vector3 Explicit Conversion (Vector3 to Quaternion)

Vector3 Conversion (Vector3 to Quaternion)

Transforms Vector3 to a new Quaternion structure

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static explicit operator Quaternion (
    Vector3 vector
)
static explicit operator Quaternion (
    Vector3 vector
)

Parameters

vector
Type: VisualComponents.Create3DVector3
Vector to be type casted

Return Value

Type: Quaternion
Result vector as new System.Windows.Media.Media3D.Vector3D structure
See Also

Reference

Vector3 Structure
Overload
VisualComponents.Create3D Namespace


Vector3.Inequality Operator

Vector3Inequality Operator

Compares two Vector3 instances for inequality

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    Vector3 vector1,
    Vector3 vector2
)
public:
static bool operator !=(
    Vector3 vector1,
    Vector3 vector2
)

Parameters

vector1
Type: VisualComponents.Create3DVector3
The first vector to compare
vector2
Type: VisualComponents.Create3DVector3
The second vector to compare against

Return Value

Type: Boolean
True if the vectors are inequal, false otherwise
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.Modulus Operator

Vector3Modulus Operator

Calculates the cross product of two vectors and returns a new Vector3 instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Vector3 operator %(
    Vector3 vector1,
    Vector3 vector2
)
public:
static Vector3 operator %(
    Vector3 vector1,
    Vector3 vector2
)

Parameters

vector1
Type: VisualComponents.Create3DVector3
The first vector to evalute
vector2
Type: VisualComponents.Create3DVector3
The second vector to evaluate

Return Value

Type: Vector3
Result vector
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.Multiply Operator

Vector3Multiply Operator

Overload List
Name | Description
Multiply(Double, Vector3) | Multiplies the vector with a number and returns a new Vector3 instance
Multiply(Vector3, Double) | Multiplies the vector with a number and returns a new Vector3 instance
Multiply(Vector3, Matrix) | Multiplies the specified vector by Vector3
Multiply(Vector3, Vector3) | Calculates the dot (scalar) product of two Vector3 instances
Top
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


Vector3.Multiply Operator (Double, Vector3)

Vector3Multiply Operator (Double, Vector3)

Multiplies the vector with a number and returns a new Vector3 instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Vector3 operator *(
    double number,
    Vector3 vector
)
public:
static Vector3 operator *(
    double number,
    Vector3 vector
)

Parameters

number
Type: SystemDouble
Multiplier
vector
Type: VisualComponents.Create3DVector3
Vector to be multiplied

Return Value

Type: Vector3
Result vector
See Also

Reference

Vector3 Structure
Multiply Overload
VisualComponents.Create3D Namespace


Vector3.Multiply Operator (Vector3, Double)

Vector3Multiply Operator (Vector3, Double)

Multiplies the vector with a number and returns a new Vector3 instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Vector3 operator *(
    Vector3 vector,
    double number
)
public:
static Vector3 operator *(
    Vector3 vector,
    double number
)

Parameters

vector
Type: VisualComponents.Create3DVector3
Vector to be multiplied
number
Type: SystemDouble
Multiplier

Return Value

Type: Vector3
Result vector
See Also

Reference

Vector3 Structure
Multiply Overload
VisualComponents.Create3D Namespace


Vector3.Multiply Operator (Vector3, Matrix)

Vector3Multiply Operator (Vector3, Matrix)

Multiplies the specified vector by Vector3

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Vector3 operator *(
    Vector3 vector,
    Matrix matrix
)
public:
static Vector3 operator *(
    Vector3 vector,
    Matrix matrix
)

Parameters

vector
Type: VisualComponents.Create3DVector3
Vector to multiply
matrix
Type: VisualComponents.Create3DMatrix
Matrix by which the vector is multiplied

Return Value

Type: Vector3
Vector that is the result of multiplication
See Also

Reference

Vector3 Structure
Multiply Overload
VisualComponents.Create3D Namespace


Vector3.Multiply Operator (Vector3, Vector3)

Vector3Multiply Operator (Vector3, Vector3)

Calculates the dot (scalar) product of two Vector3 instances

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static double operator *(
    Vector3 vector1,
    Vector3 vector2
)
public:
static double operator *(
    Vector3 vector1,
    Vector3 vector2
)

Parameters

vector1
Type: VisualComponents.Create3DVector3
The first vector to evaluate
vector2
Type: VisualComponents.Create3DVector3
The second vector to evaluate

Return Value

Type: Double
Dot product of vector1 and vector2
See Also

Reference

Vector3 Structure
Multiply Overload
VisualComponents.Create3D Namespace


Vector3.Subtraction Operator

Vector3Subtraction Operator

Subtracts a vector from a vector and returns a new Vector3 instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Vector3 operator -(
    Vector3 vector1,
    Vector3 vector2
)
public:
static Vector3 operator -(
    Vector3 vector1,
    Vector3 vector2
)

Parameters

vector1
Type: VisualComponents.Create3DVector3
Vector to be subtracted from
vector2
Type: VisualComponents.Create3DVector3
Vector to subtract

Return Value

Type: Vector3
Result vector
See Also

Reference

Vector3 Structure
VisualComponents.Create3D Namespace


VectorDrawingFormat Enumeration

List of Auto desk RealDWG formats.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum VectorDrawingFormat
public enum class VectorDrawingFormat
Members
Member name | Value | Description
DWG | 0 |
DXB | 1 |
DXF | 2 |
See Also

Reference

VisualComponents.Create3D Namespace


WeibullDistributionParameters Class

Triangular distribution parameters
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DWeibullDistributionParameters

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class WeibullDistributionParameters : IDistributionParameters
public ref class WeibullDistributionParameters : IDistributionParameters

The WeibullDistributionParameters type exposes the following members.

Constructors
 | Name | Description
Public method | WeibullDistributionParameters | Initializes a new instance of the WeibullDistributionParameters class
Public method | WeibullDistributionParameters(IProperty) | Initializes a new instance of the WeibullDistributionParameters class
Top
Properties
 | Name | Description
Public property | DistributionType |
Public property | Expression |
Public property | Property |
Public property | Scale | Scale (λ) value
Public property | Shape | Shape (k) value
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


WeibullDistributionParameters Constructor

Overload List
 | Name | Description
Public method | WeibullDistributionParameters | Initializes a new instance of the WeibullDistributionParameters class
Public method | WeibullDistributionParameters(IProperty) | Initializes a new instance of the WeibullDistributionParameters class
Top
See Also

Reference

WeibullDistributionParameters Class
VisualComponents.Create3D Namespace


WeibullDistributionParameters Constructor

Initializes a new instance of the WeibullDistributionParameters class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public WeibullDistributionParameters()
public:
WeibullDistributionParameters()
See Also

Reference

WeibullDistributionParameters Class
WeibullDistributionParameters Overload
VisualComponents.Create3D Namespace


WeibullDistributionParameters Constructor (IProperty)

Initializes a new instance of the WeibullDistributionParameters class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public WeibullDistributionParameters(
    IProperty property
)
public:
WeibullDistributionParameters(
    IProperty^ property
)

Parameters

property
Type: VisualComponents.Create3DIProperty
See Also

Reference

WeibullDistributionParameters Class
WeibullDistributionParameters Overload
VisualComponents.Create3D Namespace


WeibullDistributionParameters Properties

The WeibullDistributionParameters type exposes the following members.

Properties
 | Name | Description
Public property | DistributionType |
Public property | Expression |
Public property | Property |
Public property | Scale | Scale (λ) value
Public property | Shape | Shape (k) value
Top
See Also

Reference

WeibullDistributionParameters Class
VisualComponents.Create3D Namespace


WeibullDistributionParameters.DistributionType Property

WeibullDistributionParametersDistributionType Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DistributionType DistributionType { get; }
public:
virtual property DistributionType DistributionType {
    DistributionType get () sealed;
}

Property Value

Type: DistributionType

Implements

IDistributionParametersDistributionType
See Also

Reference

WeibullDistributionParameters Class
VisualComponents.Create3D Namespace


WeibullDistributionParameters.Expression Property

WeibullDistributionParametersExpression Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Expression { get; }
public:
virtual property String^ Expression {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IDistributionParametersExpression
See Also

Reference

WeibullDistributionParameters Class
VisualComponents.Create3D Namespace


WeibullDistributionParameters.Property Property

WeibullDistributionParametersProperty Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty Property { get; }
public:
property IProperty^ Property {
    IProperty^ get ();
}

Property Value

Type: IProperty
See Also

Reference

WeibullDistributionParameters Class
VisualComponents.Create3D Namespace


WeibullDistributionParameters.Scale Property

WeibullDistributionParametersScale Property

Scale (λ) value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Scale { get; set; }
public:
property double Scale {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

WeibullDistributionParameters Class
VisualComponents.Create3D Namespace


WeibullDistributionParameters.Shape Property

WeibullDistributionParametersShape Property

Shape (k) value

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Shape { get; set; }
public:
property double Shape {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

WeibullDistributionParameters Class
VisualComponents.Create3D Namespace


WeibullDistributionParameters Methods

The WeibullDistributionParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

WeibullDistributionParameters Class
VisualComponents.Create3D Namespace


VerboseException Class

Helper class for logging "inner" exceptions to log4net. Note: normal InnerException:s are working without this class.
Inheritance Hierarchy
SystemObject
SystemException
VisualComponents.Create3DVerboseException

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[SerializableAttribute]
public class VerboseException : Exception
[SerializableAttribute]
public ref class VerboseException : public Exception

The VerboseException type exposes the following members.

Constructors
 | Name | Description
Public method | VerboseException | Constructor
Top
Properties
 | Name | Description
Public property | Data | Returns a IDictionary that represents current data. (Overrides ExceptionData.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string that represents the message. (Overrides ExceptionMessage.)
Public property | Source | Returns a string that represents the exception source. (Overrides ExceptionSource.)
Public property | StackTrace | Returns a string that represents the stack. (Overrides ExceptionStackTrace.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | Returns an instance of base exception. (Overrides ExceptionGetBaseException.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
 | Make | Decide whether to use VerboseException or return normal exception.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the exception object. (Overrides ExceptionToString.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


VerboseException Constructor

Constructor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VerboseException(
    Exception ex
)
public:
VerboseException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
current exception
See Also

Reference

VerboseException Class
VisualComponents.Create3D Namespace


VerboseException Properties

The VerboseException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Returns a IDictionary that represents current data. (Overrides ExceptionData.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns a string that represents the message. (Overrides ExceptionMessage.)
Public property | Source | Returns a string that represents the exception source. (Overrides ExceptionSource.)
Public property | StackTrace | Returns a string that represents the stack. (Overrides ExceptionStackTrace.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

VerboseException Class
VisualComponents.Create3D Namespace


VerboseException.Data Property

VerboseExceptionData Property

Returns a IDictionary that represents current data.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override IDictionary Data { get; }
public:
virtual property IDictionary^ Data {
    IDictionary^ get () override;
}

Property Value

Type: IDictionary
See Also

Reference

VerboseException Class
VisualComponents.Create3D Namespace


VerboseException.Message Property

VerboseExceptionMessage Property

Returns a string that represents the message.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string Message { get; }
public:
virtual property String^ Message {
    String^ get () override;
}

Property Value

Type: String

Implements

_ExceptionMessage
See Also

Reference

VerboseException Class
VisualComponents.Create3D Namespace


VerboseException.Source Property

VerboseExceptionSource Property

Returns a string that represents the exception source.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string Source { get; set; }
public:
virtual property String^ Source {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String

Implements

_ExceptionSource
See Also

Reference

VerboseException Class
VisualComponents.Create3D Namespace


VerboseException.StackTrace Property

VerboseExceptionStackTrace Property

Returns a string that represents the stack.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string StackTrace { get; }
public:
virtual property String^ StackTrace {
    String^ get () override;
}

Property Value

Type: String

Implements

_ExceptionStackTrace
See Also

Reference

VerboseException Class
VisualComponents.Create3D Namespace


VerboseException Methods

The VerboseException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | Returns an instance of base exception. (Overrides ExceptionGetBaseException.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
 | Make | Decide whether to use VerboseException or return normal exception.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the exception object. (Overrides ExceptionToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VerboseException Class
VisualComponents.Create3D Namespace


VerboseException.GetBaseException Method

VerboseExceptionGetBaseException Method

Returns an instance of base exception.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override Exception GetBaseException()
public:
virtual Exception^ GetBaseException() override

Return Value

Type: Exception

[Missing <returns> documentation for "M:VisualComponents.Create3D.VerboseException.GetBaseException"]

Implements

_ExceptionGetBaseException
See Also

Reference

VerboseException Class
VisualComponents.Create3D Namespace


VerboseException.GetObjectData Method

VerboseExceptionGetObjectData Method

Sets the SerializationInfo with information about the exception.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

VerboseException Class
VisualComponents.Create3D Namespace


VerboseException.Make Method

VerboseExceptionMake Method

Decide whether to use VerboseException or return normal exception.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Exception Make(
    Exception ex
)
public:
static Exception^ Make(
    Exception^ ex
)

Parameters

ex
Type: SystemException
current exception

Return Value

Type: Exception
new verbose exception
See Also

Reference

VerboseException Class
VisualComponents.Create3D Namespace


VerboseException.ToString Method

VerboseExceptionToString Method

Returns a string that represents the exception object.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String
A string that represents the exception.

Implements

_ExceptionToString
See Also

Reference

VerboseException Class
VisualComponents.Create3D Namespace


VerboseException Events

The VerboseException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

VerboseException Class
VisualComponents.Create3D Namespace


VideoCodec Enumeration

Video recording available codecs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum VideoCodec
public enum class VideoCodec
Members
Member name | Value | Description
Raw | 0 | raw frames
H264 | 1 | H.264 codec
QuickTimeAnimationRle | 2 | QuickTime Animation (RLE) codec
See Also

Reference

VisualComponents.Create3D Namespace


VideoCreationFrameEventArgs Class

Represents video recording frame event arguments. It derives from the EventArgs class EventArgs
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DVideoCreationFrameEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class VideoCreationFrameEventArgs : EventArgs
public ref class VideoCreationFrameEventArgs : public EventArgs

The VideoCreationFrameEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | VideoCreationFrameEventArgs | Constructor
Top
Properties
 | Name | Description
Public property | Buffer | Frame represented as a buffer
Public property | Image | Frame represented as an image source
Public property | Time | recorded frame time
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


VideoCreationFrameEventArgs Constructor

Constructor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VideoCreationFrameEventArgs(
    double time,
    byte[] buffer,
    BitmapSource image
)
public:
VideoCreationFrameEventArgs(
    double time,
    array<unsigned char>^ buffer,
    BitmapSource^ image
)

Parameters

time
Type: SystemDouble
buffer
Type: SystemByte
image
Type: System.Windows.Media.ImagingBitmapSource
See Also

Reference

VideoCreationFrameEventArgs Class
VisualComponents.Create3D Namespace


VideoCreationFrameEventArgs Properties

The VideoCreationFrameEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Buffer | Frame represented as a buffer
Public property | Image | Frame represented as an image source
Public property | Time | recorded frame time
Top
See Also

Reference

VideoCreationFrameEventArgs Class
VisualComponents.Create3D Namespace


VideoCreationFrameEventArgs.Buffer Property

VideoCreationFrameEventArgsBuffer Property

Frame represented as a buffer

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList<byte> Buffer { get; }
public:
property IList<unsigned char>^ Buffer {
    IList<unsigned char>^ get ();
}

Property Value

Type: IListByte
See Also

Reference

VideoCreationFrameEventArgs Class
VisualComponents.Create3D Namespace


VideoCreationFrameEventArgs.Image Property

VideoCreationFrameEventArgsImage Property

Frame represented as an image source

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BitmapSource Image { get; }
public:
property BitmapSource^ Image {
    BitmapSource^ get ();
}

Property Value

Type: BitmapSource
See Also

Reference

VideoCreationFrameEventArgs Class
VisualComponents.Create3D Namespace


VideoCreationFrameEventArgs.Time Property

VideoCreationFrameEventArgsTime Property

recorded frame time

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Time { get; }
public:
property double Time {
    double get ();
}

Property Value

Type: Double
See Also

Reference

VideoCreationFrameEventArgs Class
VisualComponents.Create3D Namespace


VideoCreationFrameEventArgs Methods

The VideoCreationFrameEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VideoCreationFrameEventArgs Class
VisualComponents.Create3D Namespace


VideoCreationNotificationEventArgs Class

Represents video recording notification event arguments. It derives from the EventArgs class EventArgs
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DVideoCreationNotificationEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class VideoCreationNotificationEventArgs : EventArgs
public ref class VideoCreationNotificationEventArgs : public EventArgs

The VideoCreationNotificationEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | VideoCreationNotificationEventArgs | Constructor
Top
Properties
 | Name | Description
Public property | Message | Message associated with the notification
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


VideoCreationNotificationEventArgs Constructor

Constructor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VideoCreationNotificationEventArgs(
    string message
)
public:
VideoCreationNotificationEventArgs(
    String^ message
)

Parameters

message
Type: SystemString
See Also

Reference

VideoCreationNotificationEventArgs Class
VisualComponents.Create3D Namespace


VideoCreationNotificationEventArgs Properties

The VideoCreationNotificationEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Message | Message associated with the notification
Top
See Also

Reference

VideoCreationNotificationEventArgs Class
VisualComponents.Create3D Namespace


VideoCreationNotificationEventArgs.Message Property

VideoCreationNotificationEventArgsMessage Property

Message associated with the notification

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Message { get; set; }
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

VideoCreationNotificationEventArgs Class
VisualComponents.Create3D Namespace


VideoCreationNotificationEventArgs Methods

The VideoCreationNotificationEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VideoCreationNotificationEventArgs Class
VisualComponents.Create3D Namespace


VideoCreationProgressEventArgs Class

Represents video recording progress status event arguments. It derives from the EventArgs class EventArgs
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DVideoCreationProgressEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class VideoCreationProgressEventArgs : EventArgs
public ref class VideoCreationProgressEventArgs : public EventArgs

The VideoCreationProgressEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | VideoCreationProgressEventArgs | Constructor
Top
Properties
 | Name | Description
Public property | CurrentStep | Current progress step
Public property | MaxStep | Maximun number of progress steps
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


VideoCreationProgressEventArgs Constructor

Constructor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VideoCreationProgressEventArgs(
    double maxStep,
    double currentStep
)
public:
VideoCreationProgressEventArgs(
    double maxStep,
    double currentStep
)

Parameters

maxStep
Type: SystemDouble
currentStep
Type: SystemDouble
See Also

Reference

VideoCreationProgressEventArgs Class
VisualComponents.Create3D Namespace


VideoCreationProgressEventArgs Properties

The VideoCreationProgressEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | CurrentStep | Current progress step
Public property | MaxStep | Maximun number of progress steps
Top
See Also

Reference

VideoCreationProgressEventArgs Class
VisualComponents.Create3D Namespace


VideoCreationProgressEventArgs.CurrentStep Property

VideoCreationProgressEventArgsCurrentStep Property

Current progress step

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double CurrentStep { get; set; }
public:
property double CurrentStep {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

VideoCreationProgressEventArgs Class
VisualComponents.Create3D Namespace


VideoCreationProgressEventArgs.MaxStep Property

VideoCreationProgressEventArgsMaxStep Property

Maximun number of progress steps

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double MaxStep { get; set; }
public:
property double MaxStep {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

VideoCreationProgressEventArgs Class
VisualComponents.Create3D Namespace


VideoCreationProgressEventArgs Methods

The VideoCreationProgressEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VideoCreationProgressEventArgs Class
VisualComponents.Create3D Namespace


VideoFormat Enumeration

Video recording available formats

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum VideoFormat
public enum class VideoFormat
Members
Member name | Value | Description
AVI | 0 | Audio Video Interleaved
MP4 | 1 | MPEG-4 Part 14
MOV | 2 | MOV format
See Also

Reference

VisualComponents.Create3D Namespace


ViewAnimationMode Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ViewAnimationMode
public enum class ViewAnimationMode
Members
Member name | Value | Description
Step | 0 |
Linear | 1 |
Arc | 2 |
See Also

Reference

VisualComponents.Create3D Namespace


ViewApplyOptions Enumeration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[FlagsAttribute]
public enum ViewApplyOptions
[FlagsAttribute]
public enum class ViewApplyOptions
Members
Member name | Value | Description
Camera | 1 |
Shading | 2 |
See Also

Reference

VisualComponents.Create3D Namespace


ViewCollectionChangedEventArgs Class

View added event arguments
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.Create3DViewCollectionChangedEventArgs

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ViewCollectionChangedEventArgs : EventArgs
public ref class ViewCollectionChangedEventArgs : public EventArgs

The ViewCollectionChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ViewCollectionChangedEventArgs | Constructor
Top
Properties
 | Name | Description
Public property | Added |
Public property | View | View that has been added to the simulation world
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


ViewCollectionChangedEventArgs Constructor

Constructor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ViewCollectionChangedEventArgs(
    IView3D view,
    bool added
)
public:
ViewCollectionChangedEventArgs(
    IView3D^ view,
    bool added
)

Parameters

view
Type: VisualComponents.Create3DIView3D
View
added
Type: SystemBoolean
See Also

Reference

ViewCollectionChangedEventArgs Class
VisualComponents.Create3D Namespace


ViewCollectionChangedEventArgs Properties

The ViewCollectionChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Added |
Public property | View | View that has been added to the simulation world
Top
See Also

Reference

ViewCollectionChangedEventArgs Class
VisualComponents.Create3D Namespace


ViewCollectionChangedEventArgs.Added Property

ViewCollectionChangedEventArgsAdded Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Added { get; }
public:
property bool Added {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ViewCollectionChangedEventArgs Class
VisualComponents.Create3D Namespace


ViewCollectionChangedEventArgs.View Property

ViewCollectionChangedEventArgsView Property

View that has been added to the simulation world

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IView3D View { get; }
public:
property IView3D^ View {
    IView3D^ get ();
}

Property Value

Type: IView3D
See Also

Reference

ViewCollectionChangedEventArgs Class
VisualComponents.Create3D Namespace


ViewCollectionChangedEventArgs Methods

The ViewCollectionChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ViewCollectionChangedEventArgs Class
VisualComponents.Create3D Namespace


WindowConfigElement Class

Configuration file element for window options.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.Create3DWindowConfigElement

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class WindowConfigElement : ConfigurationElement
public ref class WindowConfigElement : public ConfigurationElement

The WindowConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | WindowConfigElement | Constructor.
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is . (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | NormalPosition | Normal position rectangle.
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | WindowState | Width.
Top
Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public method | IsDefault | Tests if options are set to default.
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


WindowConfigElement Constructor

Constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public WindowConfigElement()
public:
WindowConfigElement()
See Also

Reference

WindowConfigElement Class
VisualComponents.Create3D Namespace


WindowConfigElement Properties

The WindowConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is . (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | NormalPosition | Normal position rectangle.
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | WindowState | Width.
Top
See Also

Reference

WindowConfigElement Class
VisualComponents.Create3D Namespace


WindowConfigElement.NormalPosition Property

WindowConfigElementNormalPosition Property

Normal position rectangle.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public WindowRectangle NormalPosition { get; set; }
public:
property WindowRectangle^ NormalPosition {
    WindowRectangle^ get ();
    void set (WindowRectangle^ value);
}

Property Value

Type: WindowRectangle
See Also

Reference

WindowConfigElement Class
VisualComponents.Create3D Namespace


WindowConfigElement.WindowState Property

WindowConfigElementWindowState Property

Width.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public WindowState WindowState { get; set; }
public:
property WindowState WindowState {
    WindowState get ();
    void set (WindowState value);
}

Property Value

Type: WindowState
See Also

Reference

WindowConfigElement Class
VisualComponents.Create3D Namespace


WindowConfigElement Methods

The WindowConfigElement type exposes the following members.

Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public method | IsDefault | Tests if options are set to default.
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

WindowConfigElement Class
VisualComponents.Create3D Namespace


WindowConfigElement.IsDefault Method

WindowConfigElementIsDefault Method

Tests if options are set to default.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsDefault()
public:
bool IsDefault()

Return Value

Type: Boolean
True if default options used
See Also

Reference

WindowConfigElement Class
VisualComponents.Create3D Namespace


WindowPoint Class

Window 2D position.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.Create3DWindowPoint

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class WindowPoint : ConfigurationElement
public ref class WindowPoint : public ConfigurationElement

The WindowPoint type exposes the following members.

Constructors
 | Name | Description
Public method | WindowPoint | Initializes a new instance of the WindowPoint class
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is . (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | X | X value.
Public property | Y | Y value.
Top
Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


WindowPoint Constructor

Initializes a new instance of the WindowPoint class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public WindowPoint()
public:
WindowPoint()
See Also

Reference

WindowPoint Class
VisualComponents.Create3D Namespace


WindowPoint Properties

The WindowPoint type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is . (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | X | X value.
Public property | Y | Y value.
Top
See Also

Reference

WindowPoint Class
VisualComponents.Create3D Namespace


WindowPoint.X Property

WindowPointX Property

X value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int X { get; set; }
public:
property int X {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

WindowPoint Class
VisualComponents.Create3D Namespace


WindowPoint.Y Property

WindowPointY Property

Y value.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Y { get; set; }
public:
property int Y {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

WindowPoint Class
VisualComponents.Create3D Namespace


WindowPoint Methods

The WindowPoint type exposes the following members.

Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

WindowPoint Class
VisualComponents.Create3D Namespace


WindowRectangle Class

Window rectangular position.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.Create3DWindowRectangle

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class WindowRectangle : ConfigurationElement
public ref class WindowRectangle : public ConfigurationElement

The WindowRectangle type exposes the following members.

Constructors
 | Name | Description
Public method | WindowRectangle | Initializes a new instance of the WindowRectangle class
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is . (Inherited from ConfigurationElement.)
Public property | Height | Height.
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | Left | Left coordinate.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | Top | Top coordinate.
Public property | Width | Width.
Top
Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


WindowRectangle Constructor

Initializes a new instance of the WindowRectangle class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public WindowRectangle()
public:
WindowRectangle()
See Also

Reference

WindowRectangle Class
VisualComponents.Create3D Namespace


WindowRectangle Properties

The WindowRectangle type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is . (Inherited from ConfigurationElement.)
Public property | Height | Height.
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | Left | Left coordinate.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | Top | Top coordinate.
Public property | Width | Width.
Top
See Also

Reference

WindowRectangle Class
VisualComponents.Create3D Namespace


WindowRectangle.Height Property

WindowRectangleHeight Property

Height.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Height { get; set; }
public:
property double Height {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

WindowRectangle Class
VisualComponents.Create3D Namespace


WindowRectangle.Left Property

WindowRectangleLeft Property

Left coordinate.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Left { get; set; }
public:
property double Left {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

WindowRectangle Class
VisualComponents.Create3D Namespace


WindowRectangle.Top Property

WindowRectangleTop Property

Top coordinate.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Top { get; set; }
public:
property double Top {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

WindowRectangle Class
VisualComponents.Create3D Namespace


WindowRectangle.Width Property

WindowRectangleWidth Property

Width.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Width { get; set; }
public:
property double Width {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

WindowRectangle Class
VisualComponents.Create3D Namespace


WindowRectangle Methods

The WindowRectangle type exposes the following members.

Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

WindowRectangle Class
VisualComponents.Create3D Namespace


WindowSection Class

Configuration file section for window options.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationSection
VisualComponents.Create3DWindowSection

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class WindowSection : ConfigurationSection,
    IWindowSection, ISection
public ref class WindowSection sealed : public ConfigurationSection,
    IWindowSection, ISection

The WindowSection type exposes the following members.

Constructors
 | Name | Description
Public method | WindowSection | Constructor.
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | Placement | Configuration file element for window options.
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName | Section's name in configuration file.
Public property | SectionType | Interface type.
Public property | SectionVersion | Section's version number.
Top
Methods
 | Name | Description
Public method | CheckVersion | Upgrade configuration to the latest version.
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection | Finds typed section by name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


WindowSection Constructor

Constructor.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public WindowSection()
public:
WindowSection()
See Also

Reference

WindowSection Class
VisualComponents.Create3D Namespace


WindowSection Properties

The WindowSection type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | Placement | Configuration file element for window options.
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName | Section's name in configuration file.
Public property | SectionType | Interface type.
Public property | SectionVersion | Section's version number.
Top
See Also

Reference

WindowSection Class
VisualComponents.Create3D Namespace


WindowSection.Placement Property

WindowSectionPlacement Property

Configuration file element for window options.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public WindowConfigElement Placement { get; set; }
public:
virtual property WindowConfigElement^ Placement {
    WindowConfigElement^ get () sealed;
    void set (WindowConfigElement^ value) sealed;
}

Property Value

Type: WindowConfigElement

Implements

IWindowSectionPlacement
See Also

Reference

WindowSection Class
VisualComponents.Create3D Namespace


WindowSection.SectionName Property

WindowSectionSectionName Property

Section's name in configuration file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SectionName { get; }
public:
virtual property String^ SectionName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ISectionSectionName
See Also

Reference

WindowSection Class
VisualComponents.Create3D Namespace


WindowSection.SectionType Property

WindowSectionSectionType Property

Interface type.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type SectionType { get; }
public:
virtual property Type^ SectionType {
    Type^ get () sealed;
}

Property Value

Type: Type

Implements

ISectionSectionType
See Also

Reference

WindowSection Class
VisualComponents.Create3D Namespace


WindowSection.SectionVersion Property

WindowSectionSectionVersion Property

Section's version number.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int SectionVersion { get; }
public:
virtual property int SectionVersion {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISectionSectionVersion
See Also

Reference

WindowSection Class
VisualComponents.Create3D Namespace


WindowSection Methods

The WindowSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion | Upgrade configuration to the latest version.
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection | Finds typed section by name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

WindowSection Class
VisualComponents.Create3D Namespace


WindowSection.CheckVersion Method

WindowSectionCheckVersion Method

Upgrade configuration to the latest version.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CheckVersion()
public:
virtual void CheckVersion() sealed

Implements

ISectionCheckVersion
See Also

Reference

WindowSection Class
VisualComponents.Create3D Namespace


WindowSection.GetSection Method

WindowSectionGetSection Method

Finds typed section by name.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISection GetSection(
    Configuration userSettingConfiguration
)
public:
virtual ISection^ GetSection(
    Configuration^ userSettingConfiguration
) sealed

Parameters

userSettingConfiguration
Type: System.ConfigurationConfiguration

Return Value

Type: ISection

[Missing <returns> documentation for "M:VisualComponents.Create3D.WindowSection.GetSection(System.Configuration.Configuration)"]

Implements

ISectionGetSection(Configuration)
See Also

Reference

WindowSection Class
VisualComponents.Create3D Namespace


WindowSection.ToString Method

WindowSectionToString Method

Converts this instance to string.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String
String representation of this instance
See Also

Reference

WindowSection Class
VisualComponents.Create3D Namespace


VisitorBase Class

Base class for node visitors
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DVisitorBase

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract class VisitorBase
public ref class VisitorBase abstract

The VisitorBase type exposes the following members.

Constructors
 | Name | Description
Protected method | VisitorBase | Initializes a new instance of the VisitorBase class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Visit(IBehavior) | Called by IVisitable.
Public method | Visit(IFeature) | Called by IVisitable.
Public method | Visit(ISimComponent) | Called by IVisitable.
Public method | Visit(ISimNode) | Called by IVisitable.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


VisitorBase Constructor

Initializes a new instance of the VisitorBase class

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected VisitorBase()
protected:
VisitorBase()
See Also

Reference

VisitorBase Class
VisualComponents.Create3D Namespace


VisitorBase Methods

The VisitorBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Visit(IBehavior) | Called by IVisitable.
Public method | Visit(IFeature) | Called by IVisitable.
Public method | Visit(ISimComponent) | Called by IVisitable.
Public method | Visit(ISimNode) | Called by IVisitable.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisitorBase Class
VisualComponents.Create3D Namespace


VisitorBase.Visit Method

VisitorBaseVisit Method

Overload List
 | Name | Description
Public method | Visit(IBehavior) | Called by IVisitable.
Public method | Visit(IFeature) | Called by IVisitable.
Public method | Visit(ISimComponent) | Called by IVisitable.
Public method | Visit(ISimNode) | Called by IVisitable.
Top
See Also

Reference

VisitorBase Class
VisualComponents.Create3D Namespace


VisitorBase.Visit Method (IBehavior)

VisitorBaseVisit Method (IBehavior)

Called by IVisitable.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract void Visit(
    IBehavior behavior
)
public:
virtual void Visit(
    IBehavior^ behavior
) abstract

Parameters

behavior
Type: VisualComponents.Create3DIBehavior
See Also

Reference

VisitorBase Class
Visit Overload
VisualComponents.Create3D Namespace


VisitorBase.Visit Method (IFeature)

VisitorBaseVisit Method (IFeature)

Called by IVisitable.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract void Visit(
    IFeature node
)
public:
virtual void Visit(
    IFeature^ node
) abstract

Parameters

node
Type: VisualComponents.Create3DIFeature
See Also

Reference

VisitorBase Class
Visit Overload
VisualComponents.Create3D Namespace


VisitorBase.Visit Method (ISimComponent)

VisitorBaseVisit Method (ISimComponent)

Called by IVisitable.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract void Visit(
    ISimComponent node
)
public:
virtual void Visit(
    ISimComponent^ node
) abstract

Parameters

node
Type: VisualComponents.Create3DISimComponent
See Also

Reference

VisitorBase Class
Visit Overload
VisualComponents.Create3D Namespace


VisitorBase.Visit Method (ISimNode)

VisitorBaseVisit Method (ISimNode)

Called by IVisitable.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract void Visit(
    ISimNode node
)
public:
virtual void Visit(
    ISimNode^ node
) abstract

Parameters

node
Type: VisualComponents.Create3DISimNode
See Also

Reference

VisitorBase Class
Visit Overload
VisualComponents.Create3D Namespace


VisualHost Class

DrawingVisual container helper class. Used in ImageSourceExporter
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
VisualComponents.Create3DVisualHost

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class VisualHost : FrameworkElement
public ref class VisualHost : public FrameworkElement

The VisualHost type exposes the following members.

Constructors
 | Name | Description
Public method | VisualHost(DrawingVisual) | Constructor
Public method | VisualHost(DrawingVisual, Double, Double) | Constructor
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height |
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Width |
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Number of hosted visual elements (Overrides FrameworkElementVisualChildrenCount.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the hosted object instance (Overrides FrameworkElementGetVisualChild(Int32).)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ResetDrawing | Clear reference to DrawingVisual instance.
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D Namespace


VisualHost Constructor

Overload List
 | Name | Description
Public method | VisualHost(DrawingVisual) | Constructor
Public method | VisualHost(DrawingVisual, Double, Double) | Constructor
Top
See Also

Reference

VisualHost Class
VisualComponents.Create3D Namespace


VisualHost Constructor (DrawingVisual)

Constructor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VisualHost(
    DrawingVisual drawing
)
public:
VisualHost(
    DrawingVisual^ drawing
)

Parameters

drawing
Type: System.Windows.MediaDrawingVisual
hosted visual object
See Also

Reference

VisualHost Class
VisualHost Overload
VisualComponents.Create3D Namespace


VisualHost Constructor (DrawingVisual, Double, Double)

Constructor

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VisualHost(
    DrawingVisual drawing,
    double width,
    double height
)
public:
VisualHost(
    DrawingVisual^ drawing,
    double width,
    double height
)

Parameters

drawing
Type: System.Windows.MediaDrawingVisual
hosted visual object
width
Type: SystemDouble
width of drawing
height
Type: SystemDouble
height of drawing
See Also

Reference

VisualHost Class
VisualHost Overload
VisualComponents.Create3D Namespace


VisualHost Properties

The VisualHost type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height |
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Width |
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Number of hosted visual elements (Overrides FrameworkElementVisualChildrenCount.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

VisualHost Class
VisualComponents.Create3D Namespace


VisualHost.Height Property

VisualHostHeight Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Height { get; set; }
public:
property double Height {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

VisualHost Class
VisualComponents.Create3D Namespace


VisualHost.Width Property

VisualHostWidth Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Width { get; set; }
public:
property double Width {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

VisualHost Class
VisualComponents.Create3D Namespace


VisualHost.VisualChildrenCount Property

VisualHostVisualChildrenCount Property

Number of hosted visual elements

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override int VisualChildrenCount { get; }
protected:
virtual property int VisualChildrenCount {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

VisualHost Class
VisualComponents.Create3D Namespace


VisualHost Methods

The VisualHost type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Returns the hosted object instance (Overrides FrameworkElementGetVisualChild(Int32).)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ResetDrawing | Clear reference to DrawingVisual instance.
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualHost Class
VisualComponents.Create3D Namespace


VisualHost.GetVisualChild Method

VisualHostGetVisualChild Method

Returns the hosted object instance

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Visual GetVisualChild(
    int index
)
protected:
virtual Visual^ GetVisualChild(
    int index
) override

Parameters

index
Type: SystemInt32
Index of visual object

Return Value

Type: Visual
Hosted visual object
See Also

Reference

VisualHost Class
VisualComponents.Create3D Namespace


VisualHost.ResetDrawing Method

VisualHostResetDrawing Method

Clear reference to DrawingVisual instance.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ResetDrawing()
public:
void ResetDrawing()
See Also

Reference

VisualHost Class
VisualComponents.Create3D Namespace


VisualHost Events

The VisualHost type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

VisualHost Class
VisualComponents.Create3D Namespace


WpfApplication Class

A helper class to encapsulate the WPF Application instance.
Inheritance Hierarchy
SystemObject
VisualComponents.Create3DWpfApplication

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class WpfApplication
public ref class WpfApplication abstract sealed

The WpfApplication type exposes the following members.

Properties
Name | Description
HasMainWindow | Returns true if MainWindow is null.
IsInHeadlessMode |
IsInOperationDebug | Same as IApplication.IsInOperationDebug
IsInSafeMode | Same as IApplication.IsInSafeMode
MainApplication | Gets the instance of main application.
MainWindow | Gets the instance of main window.
Top
Methods
Name | Description
Assert | Asserts are typically only logged. Use safemode to see them in the Output window, and print the callstack in the log file.
DxViewError | Similar to log.Error() but also printed to Output window in safemode.
DxViewWarn | Similar to log.Warn() but also printed to Output window in safemode.
EcatDebug(FuncString) | Ecat debug messages are typically hidden. Use safemode to see them in log.
EcatDebug(String) | Ecat debug messages are typically hidden. Use safemode to see them in log.
EcatDebug(String, Exception) | Ecat debug messages are typically hidden. Use safemode to see them in log.
EcatError(String, Boolean) | Ecat errors are typically only logged. Use safemode or 'isImportant' to see them in the Output window.
EcatError(String, Boolean, Exception) | Ecat errors are typically only logged. Use safemode or 'isImportant' to see them in the Output window.
EcatError(String, Boolean, Exception, Boolean) | Ecat errors are typically only logged. Use safemode or 'isImportant' to see them in the Output window.
EcatError(String, Boolean, Exception, Int32, Boolean) | Ecat errors are typically only logged. Use safemode or 'isImportant' to see them in the Output window.
EcatWait | This is used when waiting for database lock to be released.
GetCallingMethodName(IEnumerableType) | Get the name of the caller.
GetCallingMethodName(Int32) | Get the name of the caller.
InitSafeMode |
SetHeadlessMode |
Top
See Also

Reference

VisualComponents.Create3D Namespace


WpfApplication Properties

The WpfApplication type exposes the following members.

Properties
Name | Description
HasMainWindow | Returns true if MainWindow is null.
IsInHeadlessMode |
IsInOperationDebug | Same as IApplication.IsInOperationDebug
IsInSafeMode | Same as IApplication.IsInSafeMode
MainApplication | Gets the instance of main application.
MainWindow | Gets the instance of main window.
Top
See Also

Reference

WpfApplication Class
VisualComponents.Create3D Namespace


WpfApplication.HasMainWindow Property

WpfApplicationHasMainWindow Property

Returns true if MainWindow is null.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool HasMainWindow { get; }
public:
static property bool HasMainWindow {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

WpfApplication Class
VisualComponents.Create3D Namespace


WpfApplication.IsInHeadlessMode Property

WpfApplicationIsInHeadlessMode Property

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsInHeadlessMode { get; }
public:
static property bool IsInHeadlessMode {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

WpfApplication Class
VisualComponents.Create3D Namespace


WpfApplication.IsInOperationDebug Property

WpfApplicationIsInOperationDebug Property

Same as IApplication.IsInOperationDebug

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsInOperationDebug { get; }
public:
static property bool IsInOperationDebug {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

WpfApplication Class
VisualComponents.Create3D Namespace


WpfApplication.IsInSafeMode Property

WpfApplicationIsInSafeMode Property

Same as IApplication.IsInSafeMode

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsInSafeMode { get; }
public:
static property bool IsInSafeMode {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

WpfApplication Class
VisualComponents.Create3D Namespace


WpfApplication.MainApplication Property

WpfApplicationMainApplication Property

Gets the instance of main application.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Application MainApplication { get; }
public:
static property Application^ MainApplication {
    Application^ get ();
}

Property Value

Type: Application
See Also

Reference

WpfApplication Class
VisualComponents.Create3D Namespace


WpfApplication.MainWindow Property

WpfApplicationMainWindow Property

Gets the instance of main window.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Window MainWindow { get; }
public:
static property Window^ MainWindow {
    Window^ get ();
}

Property Value

Type: Window
See Also

Reference

WpfApplication Class
VisualComponents.Create3D Namespace


WpfApplication Methods

The WpfApplication type exposes the following members.

Methods
Name | Description
Assert | Asserts are typically only logged. Use safemode to see them in the Output window, and print the callstack in the log file.
DxViewError | Similar to log.Error() but also printed to Output window in safemode.
DxViewWarn | Similar to log.Warn() but also printed to Output window in safemode.
EcatDebug(FuncString) | Ecat debug messages are typically hidden. Use safemode to see them in log.
EcatDebug(String) | Ecat debug messages are typically hidden. Use safemode to see them in log.
EcatDebug(String, Exception) | Ecat debug messages are typically hidden. Use safemode to see them in log.
EcatError(String, Boolean) | Ecat errors are typically only logged. Use safemode or 'isImportant' to see them in the Output window.
EcatError(String, Boolean, Exception) | Ecat errors are typically only logged. Use safemode or 'isImportant' to see them in the Output window.
EcatError(String, Boolean, Exception, Boolean) | Ecat errors are typically only logged. Use safemode or 'isImportant' to see them in the Output window.
EcatError(String, Boolean, Exception, Int32, Boolean) | Ecat errors are typically only logged. Use safemode or 'isImportant' to see them in the Output window.
EcatWait | This is used when waiting for database lock to be released.
GetCallingMethodName(IEnumerableType) | Get the name of the caller.
GetCallingMethodName(Int32) | Get the name of the caller.
InitSafeMode |
SetHeadlessMode |
Top
See Also

Reference

WpfApplication Class
VisualComponents.Create3D Namespace


WpfApplication.Assert Method

WpfApplicationAssert Method

Asserts are typically only logged. Use safemode to see them in the Output window, and print the callstack in the log file.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void Assert(
    bool condition,
    string statement,
    string callerName = null,
    string callerFile = null,
    int callerLine = -1
)
public:
static void Assert(
    bool condition,
    String^ statement,
    String^ callerName = nullptr,
    String^ callerFile = nullptr,
    int callerLine = -1
)

Parameters

condition
Type: SystemBoolean
statement
Type: SystemString
callerName (Optional)
Type: SystemString
callerFile (Optional)
Type: SystemString
callerLine (Optional)
Type: SystemInt32
See Also

Reference

WpfApplication Class
VisualComponents.Create3D Namespace


WpfApplication.DxViewError Method

WpfApplicationDxViewError Method

Similar to log.Error() but also printed to Output window in safemode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void DxViewError(
    string message,
    params Object[] other
)
public:
static void DxViewError(
    String^ message,
    ... array<Object^>^ other
)

Parameters

message
Type: SystemString
other
Type: SystemObject
See Also

Reference

WpfApplication Class
VisualComponents.Create3D Namespace


WpfApplication.DxViewWarn Method

WpfApplicationDxViewWarn Method

Similar to log.Warn() but also printed to Output window in safemode.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void DxViewWarn(
    string message,
    params Object[] other
)
public:
static void DxViewWarn(
    String^ message,
    ... array<Object^>^ other
)

Parameters

message
Type: SystemString
other
Type: SystemObject
See Also

Reference

WpfApplication Class
VisualComponents.Create3D Namespace


WpfApplication.EcatDebug Method

WpfApplicationEcatDebug Method

Overload List
Name | Description
EcatDebug(FuncString) | Ecat debug messages are typically hidden. Use safemode to see them in log.
EcatDebug(String) | Ecat debug messages are typically hidden. Use safemode to see them in log.
EcatDebug(String, Exception) | Ecat debug messages are typically hidden. Use safemode to see them in log.
Top
See Also

Reference

WpfApplication Class
VisualComponents.Create3D Namespace


WpfApplication.EcatDebug Method (Func(String))

WpfApplicationEcatDebug Method (FuncString)

Ecat debug messages are typically hidden. Use safemode to see them in log.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void EcatDebug(
    Func<string> messageGetter
)
public:
static void EcatDebug(
    Func<String^>^ messageGetter
)

Parameters

messageGetter
Type: SystemFuncString
See Also

Reference

WpfApplication Class
EcatDebug Overload
VisualComponents.Create3D Namespace


WpfApplication.EcatDebug Method (String)

WpfApplicationEcatDebug Method (String)

Ecat debug messages are typically hidden. Use safemode to see them in log.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void EcatDebug(
    string message
)
public:
static void EcatDebug(
    String^ message
)

Parameters

message
Type: SystemString
See Also

Reference

WpfApplication Class
EcatDebug Overload
VisualComponents.Create3D Namespace


WpfApplication.EcatDebug Method (String, Exception)

WpfApplicationEcatDebug Method (String, Exception)

Ecat debug messages are typically hidden. Use safemode to see them in log.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void EcatDebug(
    string message,
    Exception exception
)
public:
static void EcatDebug(
    String^ message,
    Exception^ exception
)

Parameters

message
Type: SystemString
exception
Type: SystemException
See Also

Reference

WpfApplication Class
EcatDebug Overload
VisualComponents.Create3D Namespace


WpfApplication.EcatError Method

WpfApplicationEcatError Method

Overload List
Name | Description
EcatError(String, Boolean) | Ecat errors are typically only logged. Use safemode or 'isImportant' to see them in the Output window.
EcatError(String, Boolean, Exception) | Ecat errors are typically only logged. Use safemode or 'isImportant' to see them in the Output window.
EcatError(String, Boolean, Exception, Boolean) | Ecat errors are typically only logged. Use safemode or 'isImportant' to see them in the Output window.
EcatError(String, Boolean, Exception, Int32, Boolean) | Ecat errors are typically only logged. Use safemode or 'isImportant' to see them in the Output window.
Top
See Also

Reference

WpfApplication Class
VisualComponents.Create3D Namespace


WpfApplication.EcatError Method (String, Boolean)

WpfApplicationEcatError Method (String, Boolean)

Ecat errors are typically only logged. Use safemode or 'isImportant' to see them in the Output window.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void EcatError(
    string message,
    bool isImportant
)
public:
static void EcatError(
    String^ message,
    bool isImportant
)

Parameters

message
Type: SystemString
isImportant
Type: SystemBoolean
See Also

Reference

WpfApplication Class
EcatError Overload
VisualComponents.Create3D Namespace


WpfApplication.EcatError Method (String, Boolean, Exception)

WpfApplicationEcatError Method (String, Boolean, Exception)

Ecat errors are typically only logged. Use safemode or 'isImportant' to see them in the Output window.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void EcatError(
    string message,
    bool isImportant,
    Exception exception
)
public:
static void EcatError(
    String^ message,
    bool isImportant,
    Exception^ exception
)

Parameters

message
Type: SystemString
isImportant
Type: SystemBoolean
exception
Type: SystemException
See Also

Reference

WpfApplication Class
EcatError Overload
VisualComponents.Create3D Namespace


WpfApplication.EcatError Method (String, Boolean, Exception, Boolean)

WpfApplicationEcatError Method (String, Boolean, Exception, Boolean)

Ecat errors are typically only logged. Use safemode or 'isImportant' to see them in the Output window.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void EcatError(
    string message,
    bool isImportant,
    Exception exception,
    bool ownedByWrapper
)
public:
static void EcatError(
    String^ message,
    bool isImportant,
    Exception^ exception,
    bool ownedByWrapper
)

Parameters

message
Type: SystemString
isImportant
Type: SystemBoolean
exception
Type: SystemException
ownedByWrapper
Type: SystemBoolean
See Also

Reference

WpfApplication Class
EcatError Overload
VisualComponents.Create3D Namespace


WpfApplication.EcatError Method (String, Boolean, Exception, Int32, Boolean)

WpfApplicationEcatError Method (String, Boolean, Exception, Int32, Boolean)

Ecat errors are typically only logged. Use safemode or 'isImportant' to see them in the Output window.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void EcatError(
    string message,
    bool isImportant,
    Exception exception,
    ref int errorCount,
    bool ownedByWrapper
)
public:
static void EcatError(
    String^ message,
    bool isImportant,
    Exception^ exception,
    int% errorCount,
    bool ownedByWrapper
)

Parameters

message
Type: SystemString
isImportant
Type: SystemBoolean
exception
Type: SystemException
errorCount
Type: SystemInt32
ownedByWrapper
Type: SystemBoolean
See Also

Reference

WpfApplication Class
EcatError Overload
VisualComponents.Create3D Namespace


WpfApplication.EcatWait Method

WpfApplicationEcatWait Method

This is used when waiting for database lock to be released.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void EcatWait(
    int delay
)
public:
static void EcatWait(
    int delay
)

Parameters

delay
Type: SystemInt32
See Also

Reference

WpfApplication Class
VisualComponents.Create3D Namespace


WpfApplication.GetCallingMethodName Method

WpfApplicationGetCallingMethodName Method

Overload List
Name | Description
GetCallingMethodName(IEnumerableType) | Get the name of the caller.
GetCallingMethodName(Int32) | Get the name of the caller.
Top
See Also

Reference

WpfApplication Class
VisualComponents.Create3D Namespace


WpfApplication.GetCallingMethodName Method (IEnumerable(Type))

WpfApplicationGetCallingMethodName Method (IEnumerableType)

Get the name of the caller.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetCallingMethodName(
    IEnumerable<Type> typesToSkip
)
public:
static String^ GetCallingMethodName(
    IEnumerable<Type^>^ typesToSkip
)

Parameters

typesToSkip
Type: System.Collections.GenericIEnumerableType

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.WpfApplication.GetCallingMethodName(System.Collections.Generic.IEnumerable{System.Type})"]

See Also

Reference

WpfApplication Class
GetCallingMethodName Overload
VisualComponents.Create3D Namespace


WpfApplication.GetCallingMethodName Method (Int32)

WpfApplicationGetCallingMethodName Method (Int32)

Get the name of the caller.

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetCallingMethodName(
    int frameIndex
)
public:
static String^ GetCallingMethodName(
    int frameIndex
)

Parameters

frameIndex
Type: SystemInt32

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Create3D.WpfApplication.GetCallingMethodName(System.Int32)"]

See Also

Reference

WpfApplication Class
GetCallingMethodName Overload
VisualComponents.Create3D Namespace


WpfApplication.InitSafeMode Method

WpfApplicationInitSafeMode Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void InitSafeMode()
public:
static void InitSafeMode()
See Also

Reference

WpfApplication Class
VisualComponents.Create3D Namespace


WpfApplication.SetHeadlessMode Method

WpfApplicationSetHeadlessMode Method

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetHeadlessMode()
public:
static void SetHeadlessMode()
See Also

Reference

WpfApplication Class
VisualComponents.Create3D Namespace


VRML Enumeration

VRML -> V1.0 and V2.0

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum VRML
public enum class VRML
Members
Member name | Value | Description
WRL | 0 |
VRML | 1 |
See Also

Reference

VisualComponents.Create3D Namespace


ZoomMode Enumeration

Zoom mode enumaration

Namespace: VisualComponents.Create3D
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ZoomMode
public enum class ZoomMode
Members
Member name | Value | Description
AdjustCoi | 0 | Adjust Center of interest
AdjustGazeLength | 1 | Adjust Gaze Length (Distance from camera lense (eye) to Center of View)
See Also

Reference

VisualComponents.Create3D Namespace


VisualComponents.Create3D.Remote Namespace

Classes
 | Class | Description
Public class | CloudServerGetter |
Public class | ExperienceExportAttribute |
Interfaces
 | Interface | Description
Public interface | IBaseServer | Basic interface which allows the viewer to control the nextgen.
Public interface | ICloudServer | External implemention of a tcpip server that listens to a specific protobuf messages, and uses the c# api. Note: Instead of IoC.Get<CloudServer>() we call CloudServerGetter.Get().
Public interface | IHandshakeServer |
Public interface | IRemoteIoC | Socket communication helper, that allows making method calls across tcp/ip.
Public interface | IServer |
Public interface | IStreamServer |
Public interface | IVREventsServer | Basic interface which allows the viewer to send VR events to the nextgen.


CloudServerGetter Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3D.RemoteCloudServerGetter

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class CloudServerGetter
public ref class CloudServerGetter abstract sealed

The CloudServerGetter type exposes the following members.

Methods
Name | Description
Get | Simulates the IoC.Get<T>() call.
Top
See Also

Reference

VisualComponents.Create3D.Remote Namespace


CloudServerGetter Methods

The CloudServerGetter type exposes the following members.

Methods
Name | Description
Get | Simulates the IoC.Get<T>() call.
Top
See Also

Reference

CloudServerGetter Class
VisualComponents.Create3D.Remote Namespace


CloudServerGetter.Get Method

CloudServerGetterGet Method

Simulates the IoC.Get<T>() call.

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ICloudServer Get()
public:
static ICloudServer^ Get()

Return Value

Type: ICloudServer

[Missing <returns> documentation for "M:VisualComponents.Create3D.Remote.CloudServerGetter.Get"]

See Also

Reference

CloudServerGetter Class
VisualComponents.Create3D.Remote Namespace


ExperienceExportAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
VisualComponents.Create3D.RemoteExperienceExportAttribute

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ExperienceExportAttribute : Attribute
public ref class ExperienceExportAttribute sealed : public Attribute

The ExperienceExportAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | ExperienceExportAttribute(Type) | Initializes a new instance of the ExperienceExportAttribute class
Public method | ExperienceExportAttribute(Type, String) | Initializes a new instance of the ExperienceExportAttribute class
Top
Properties
 | Name | Description
Public property | Id |
Public property | Type |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Create3D.Remote Namespace


ExperienceExportAttribute Constructor

Overload List
 | Name | Description
Public method | ExperienceExportAttribute(Type) | Initializes a new instance of the ExperienceExportAttribute class
Public method | ExperienceExportAttribute(Type, String) | Initializes a new instance of the ExperienceExportAttribute class
Top
See Also

Reference

ExperienceExportAttribute Class
VisualComponents.Create3D.Remote Namespace


ExperienceExportAttribute Constructor (Type)

Initializes a new instance of the ExperienceExportAttribute class

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ExperienceExportAttribute(
    Type type
)
public:
ExperienceExportAttribute(
    Type^ type
)

Parameters

type
Type: SystemType
See Also

Reference

ExperienceExportAttribute Class
ExperienceExportAttribute Overload
VisualComponents.Create3D.Remote Namespace


ExperienceExportAttribute Constructor (Type, String)

Initializes a new instance of the ExperienceExportAttribute class

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ExperienceExportAttribute(
    Type type,
    string id
)
public:
ExperienceExportAttribute(
    Type^ type,
    String^ id
)

Parameters

type
Type: SystemType
id
Type: SystemString
See Also

Reference

ExperienceExportAttribute Class
ExperienceExportAttribute Overload
VisualComponents.Create3D.Remote Namespace


ExperienceExportAttribute Properties

The ExperienceExportAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Public property | Type |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ExperienceExportAttribute Class
VisualComponents.Create3D.Remote Namespace


ExperienceExportAttribute.Id Property

ExperienceExportAttributeId Property

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Id { get; set; }
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ExperienceExportAttribute Class
VisualComponents.Create3D.Remote Namespace


ExperienceExportAttribute.Type Property

ExperienceExportAttributeType Property

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type Type { get; set; }
public:
property Type^ Type {
    Type^ get ();
    void set (Type^ value);
}

Property Value

Type: Type
See Also

Reference

ExperienceExportAttribute Class
VisualComponents.Create3D.Remote Namespace


ExperienceExportAttribute Methods

The ExperienceExportAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ExperienceExportAttribute Class
VisualComponents.Create3D.Remote Namespace


IBaseServer Interface

Basic interface which allows the viewer to control the nextgen.

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IBaseServer : IServer
public interface class IBaseServer : IServer

The IBaseServer type exposes the following members.

Properties
 | Name | Description
Public property | HasResetAndRun |
Public property | IsSimRunning |
Public property | PropertiesResult |
Public property | SpeedFactor |
Top
Methods
 | Name | Description
Public method | GetSimProperties |
Public method | LoadLayoutEcat |
Public method | ResetSim |
Public method | RunPauseSim |
Top
See Also

Reference

VisualComponents.Create3D.Remote Namespace


IBaseServer Properties

The IBaseServer type exposes the following members.

Properties
 | Name | Description
Public property | HasResetAndRun |
Public property | IsSimRunning |
Public property | PropertiesResult |
Public property | SpeedFactor |
Top
See Also

Reference

IBaseServer Interface
VisualComponents.Create3D.Remote Namespace


IBaseServer.HasResetAndRun Property

IBaseServerHasResetAndRun Property

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool HasResetAndRun { get; }
property bool HasResetAndRun {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IBaseServer Interface
VisualComponents.Create3D.Remote Namespace


IBaseServer.IsSimRunning Property

IBaseServerIsSimRunning Property

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsSimRunning { get; }
property bool IsSimRunning {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IBaseServer Interface
VisualComponents.Create3D.Remote Namespace


IBaseServer.PropertiesResult Property

IBaseServerPropertiesResult Property

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object[] PropertiesResult { get; set; }
property array<Object^>^ PropertiesResult {
    array<Object^>^ get ();
    void set (array<Object^>^ value);
}

Property Value

Type: Object
See Also

Reference

IBaseServer Interface
VisualComponents.Create3D.Remote Namespace


IBaseServer.SpeedFactor Property

IBaseServerSpeedFactor Property

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double SpeedFactor { get; set; }
property double SpeedFactor {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IBaseServer Interface
VisualComponents.Create3D.Remote Namespace


IBaseServer Methods

The IBaseServer type exposes the following members.

Methods
 | Name | Description
Public method | GetSimProperties |
Public method | LoadLayoutEcat |
Public method | ResetSim |
Public method | RunPauseSim |
Top
See Also

Reference

IBaseServer Interface
VisualComponents.Create3D.Remote Namespace


IBaseServer.GetSimProperties Method

IBaseServerGetSimProperties Method

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void GetSimProperties(
    ISimNode node
)
void GetSimProperties(
    ISimNode^ node
)

Parameters

node
Type: VisualComponents.Create3DISimNode
See Also

Reference

IBaseServer Interface
VisualComponents.Create3D.Remote Namespace


IBaseServer.LoadLayoutEcat Method

IBaseServerLoadLayoutEcat Method

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void LoadLayoutEcat(
    string name,
    bool clear
)
void LoadLayoutEcat(
    String^ name,
    bool clear
)

Parameters

name
Type: SystemString
clear
Type: SystemBoolean
See Also

Reference

IBaseServer Interface
VisualComponents.Create3D.Remote Namespace


IBaseServer.ResetSim Method

IBaseServerResetSim Method

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ResetSim()
void ResetSim()
See Also

Reference

IBaseServer Interface
VisualComponents.Create3D.Remote Namespace


IBaseServer.RunPauseSim Method

IBaseServerRunPauseSim Method

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RunPauseSim(
    bool doRun
)
void RunPauseSim(
    bool doRun
)

Parameters

doRun
Type: SystemBoolean
See Also

Reference

IBaseServer Interface
VisualComponents.Create3D.Remote Namespace


ICloudServer Interface

External implemention of a tcpip server that listens to a specific protobuf messages, and uses the c# api. Note: Instead of IoC.Get<CloudServer>() we call CloudServerGetter.Get().

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICloudServer
public interface class ICloudServer

The ICloudServer type exposes the following members.

Properties
 | Name | Description
Public property | IsPapertrailEnabled |
Public property | PapertrailHost |
Public property | PapertrailPort |
Public property | ServerIndex |
Public property | ServerPort |
Top
Methods
 | Name | Description
Public method | InitServer |
Public method | SendProgressMessage |
Public method | SetServerReady |
Top
See Also

Reference

VisualComponents.Create3D.Remote Namespace


ICloudServer Properties

The ICloudServer type exposes the following members.

Properties
 | Name | Description
Public property | IsPapertrailEnabled |
Public property | PapertrailHost |
Public property | PapertrailPort |
Public property | ServerIndex |
Public property | ServerPort |
Top
See Also

Reference

ICloudServer Interface
VisualComponents.Create3D.Remote Namespace


ICloudServer.IsPapertrailEnabled Property

ICloudServerIsPapertrailEnabled Property

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsPapertrailEnabled { get; }
property bool IsPapertrailEnabled {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ICloudServer Interface
VisualComponents.Create3D.Remote Namespace


ICloudServer.PapertrailHost Property

ICloudServerPapertrailHost Property

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string PapertrailHost { get; }
property String^ PapertrailHost {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ICloudServer Interface
VisualComponents.Create3D.Remote Namespace


ICloudServer.PapertrailPort Property

ICloudServerPapertrailPort Property

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int PapertrailPort { get; }
property int PapertrailPort {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ICloudServer Interface
VisualComponents.Create3D.Remote Namespace


ICloudServer.ServerIndex Property

ICloudServerServerIndex Property

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int ServerIndex { get; set; }
property int ServerIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ICloudServer Interface
VisualComponents.Create3D.Remote Namespace


ICloudServer.ServerPort Property

ICloudServerServerPort Property

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int ServerPort { get; }
property int ServerPort {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ICloudServer Interface
VisualComponents.Create3D.Remote Namespace


ICloudServer Methods

The ICloudServer type exposes the following members.

Methods
 | Name | Description
Public method | InitServer |
Public method | SendProgressMessage |
Public method | SetServerReady |
Top
See Also

Reference

ICloudServer Interface
VisualComponents.Create3D.Remote Namespace


ICloudServer.InitServer Method

ICloudServerInitServer Method

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool InitServer()
bool InitServer()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.Remote.ICloudServer.InitServer"]

See Also

Reference

ICloudServer Interface
VisualComponents.Create3D.Remote Namespace


ICloudServer.SendProgressMessage Method

ICloudServerSendProgressMessage Method

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SendProgressMessage(
    string info
)
void SendProgressMessage(
    String^ info
)

Parameters

info
Type: SystemString
See Also

Reference

ICloudServer Interface
VisualComponents.Create3D.Remote Namespace


ICloudServer.SetServerReady Method

ICloudServerSetServerReady Method

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetServerReady(
    bool streamServiceReady
)
void SetServerReady(
    bool streamServiceReady
)

Parameters

streamServiceReady
Type: SystemBoolean
See Also

Reference

ICloudServer Interface
VisualComponents.Create3D.Remote Namespace


IHandshakeServer Interface

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IHandshakeServer : IServer
public interface class IHandshakeServer : IServer
See Also

Reference

VisualComponents.Create3D.Remote Namespace


IRemoteIoC Interface

Socket communication helper, that allows making method calls across tcp/ip.

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRemoteIoC
public interface class IRemoteIoC

The IRemoteIoC type exposes the following members.

Properties
 | Name | Description
Public property | IsStreamingOn |
Public property | ProtobufMode |
Top
Methods
 | Name | Description
Public method | DeserializeArgument |
Public method | GetT |
Public method | ProcessGetProperty |
Public method | ProcessInvokeMethod |
Public method | SendPropertyChanged |
Public method | SendProtobufMessage(Int32, IMessage) |
Public method | SendProtobufMessage(Int32, Int32, IMessage) |
Public method | SerializeArgument |
Public method | SyncProperties |
Top
See Also

Reference

VisualComponents.Create3D.Remote Namespace


IRemoteIoC Properties

The IRemoteIoC type exposes the following members.

Properties
 | Name | Description
Public property | IsStreamingOn |
Public property | ProtobufMode |
Top
See Also

Reference

IRemoteIoC Interface
VisualComponents.Create3D.Remote Namespace


IRemoteIoC.IsStreamingOn Property

IRemoteIoCIsStreamingOn Property

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsStreamingOn { get; }
property bool IsStreamingOn {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IRemoteIoC Interface
VisualComponents.Create3D.Remote Namespace


IRemoteIoC.ProtobufMode Property

IRemoteIoCProtobufMode Property

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ProtobufMode { get; }
property bool ProtobufMode {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IRemoteIoC Interface
VisualComponents.Create3D.Remote Namespace


IRemoteIoC Methods

The IRemoteIoC type exposes the following members.

Methods
 | Name | Description
Public method | DeserializeArgument |
Public method | GetT |
Public method | ProcessGetProperty |
Public method | ProcessInvokeMethod |
Public method | SendPropertyChanged |
Public method | SendProtobufMessage(Int32, IMessage) |
Public method | SendProtobufMessage(Int32, Int32, IMessage) |
Public method | SerializeArgument |
Public method | SyncProperties |
Top
See Also

Reference

IRemoteIoC Interface
VisualComponents.Create3D.Remote Namespace


IRemoteIoC.DeserializeArgument Method

IRemoteIoCDeserializeArgument Method

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool DeserializeArgument(
    byte[] message,
    ref int offset,
    List<Object> parsedArgs,
    List<Type> parsedTypes,
    ref string parsedDescription
)
bool DeserializeArgument(
    array<unsigned char>^ message,
    int% offset,
    List<Object^>^ parsedArgs,
    List<Type^>^ parsedTypes,
    String^% parsedDescription
)

Parameters

message
Type: SystemByte
offset
Type: SystemInt32
parsedArgs
Type: System.Collections.GenericListObject
parsedTypes
Type: System.Collections.GenericListType
parsedDescription
Type: SystemString

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.Remote.IRemoteIoC.DeserializeArgument(System.Byte[],System.Int32@,System.Collections.Generic.List{System.Object},System.Collections.Generic.List{System.Type},System.String@)"]

See Also

Reference

IRemoteIoC Interface
VisualComponents.Create3D.Remote Namespace


IRemoteIoC.Get(T) Method

IRemoteIoCGetT Method

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
T Get<T>()
where T : IServer

generic<typename T>
where T : IServer
T Get()

Type Parameters

T

Return Value

Type: T

[Missing <returns> documentation for "M:VisualComponents.Create3D.Remote.IRemoteIoC.Get``1"]

See Also

Reference

IRemoteIoC Interface
VisualComponents.Create3D.Remote Namespace


IRemoteIoC.ProcessGetProperty Method

IRemoteIoCProcessGetProperty Method

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ProcessGetProperty(
    byte[] message
)
bool ProcessGetProperty(
    array<unsigned char>^ message
)

Parameters

message
Type: SystemByte

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.Remote.IRemoteIoC.ProcessGetProperty(System.Byte[])"]

See Also

Reference

IRemoteIoC Interface
VisualComponents.Create3D.Remote Namespace


IRemoteIoC.ProcessInvokeMethod Method

IRemoteIoCProcessInvokeMethod Method

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ProcessInvokeMethod(
    byte[] message
)
bool ProcessInvokeMethod(
    array<unsigned char>^ message
)

Parameters

message
Type: SystemByte

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Create3D.Remote.IRemoteIoC.ProcessInvokeMethod(System.Byte[])"]

See Also

Reference

IRemoteIoC Interface
VisualComponents.Create3D.Remote Namespace


IRemoteIoC.SendPropertyChanged Method

IRemoteIoCSendPropertyChanged Method

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SendPropertyChanged(
    string className,
    string propertyName,
    Object value
)
void SendPropertyChanged(
    String^ className,
    String^ propertyName,
    Object^ value
)

Parameters

className
Type: SystemString
propertyName
Type: SystemString
value
Type: SystemObject
See Also

Reference

IRemoteIoC Interface
VisualComponents.Create3D.Remote Namespace


IRemoteIoC.SendProtobufMessage Method

IRemoteIoCSendProtobufMessage Method

Overload List
 | Name | Description
Public method | SendProtobufMessage(Int32, IMessage) |
Public method | SendProtobufMessage(Int32, Int32, IMessage) |
Top
See Also

Reference

IRemoteIoC Interface
VisualComponents.Create3D.Remote Namespace


IRemoteIoC.SendProtobufMessage Method (Int32, IMessage)

IRemoteIoCSendProtobufMessage Method (Int32, IMessage)

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SendProtobufMessage(
    int streamId,
    IMessage message
)
void SendProtobufMessage(
    int streamId,
    IMessage^ message
)

Parameters

streamId
Type: SystemInt32
message
Type: IMessage
See Also

Reference

IRemoteIoC Interface
SendProtobufMessage Overload
VisualComponents.Create3D.Remote Namespace


IRemoteIoC.SendProtobufMessage Method (Int32, Int32, IMessage)

IRemoteIoCSendProtobufMessage Method (Int32, Int32, IMessage)

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SendProtobufMessage(
    int clientId,
    int streamId,
    IMessage message
)
void SendProtobufMessage(
    int clientId,
    int streamId,
    IMessage^ message
)

Parameters

clientId
Type: SystemInt32
streamId
Type: SystemInt32
message
Type: IMessage
See Also

Reference

IRemoteIoC Interface
SendProtobufMessage Overload
VisualComponents.Create3D.Remote Namespace


IRemoteIoC.SerializeArgument Method

IRemoteIoCSerializeArgument Method

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SerializeArgument(
    List<byte> result,
    Object value
)
void SerializeArgument(
    List<unsigned char>^ result,
    Object^ value
)

Parameters

result
Type: System.Collections.GenericListByte
value
Type: SystemObject
See Also

Reference

IRemoteIoC Interface
VisualComponents.Create3D.Remote Namespace


IRemoteIoC.SyncProperties Method

IRemoteIoCSyncProperties Method

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SyncProperties(
    bool connected
)
void SyncProperties(
    bool connected
)

Parameters

connected
Type: SystemBoolean
See Also

Reference

IRemoteIoC Interface
VisualComponents.Create3D.Remote Namespace


IServer Interface

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IServer
public interface class IServer
See Also

Reference

VisualComponents.Create3D.Remote Namespace


IStreamServer Interface

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IStreamServer : IServer
public interface class IStreamServer : IServer
See Also

Reference

VisualComponents.Create3D.Remote Namespace


IVREventsServer Interface

Basic interface which allows the viewer to send VR events to the nextgen.

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IVREventsServer : IServer
public interface class IVREventsServer : IServer

The IVREventsServer type exposes the following members.

Properties
 | Name | Description
Public property | Buttons |
Public property | ClientId |
Public property | DeviceInputs |
Public property | DeviceModel |
Public property | Directions |
Public property | EventCounter |
Public property | EventsEnabled |
Public property | MaxUpdateRate |
Public property | OneMeterLength |
Public property | Positions |
Public property | RealEventCounter |
Public property | RoomCenter |
Public property | Times |
Public property | Touches |
Top
Methods
 | Name | Description
Public method | NotifyPython |
Public method | ToggleAction |
Top
See Also

Reference

VisualComponents.Create3D.Remote Namespace


IVREventsServer Properties

The IVREventsServer type exposes the following members.

Properties
 | Name | Description
Public property | Buttons |
Public property | ClientId |
Public property | DeviceInputs |
Public property | DeviceModel |
Public property | Directions |
Public property | EventCounter |
Public property | EventsEnabled |
Public property | MaxUpdateRate |
Public property | OneMeterLength |
Public property | Positions |
Public property | RealEventCounter |
Public property | RoomCenter |
Public property | Times |
Public property | Touches |
Top
See Also

Reference

IVREventsServer Interface
VisualComponents.Create3D.Remote Namespace


IVREventsServer.Buttons Property

IVREventsServerButtons Property

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
uint[] Buttons { get; set; }
property array<unsigned int>^ Buttons {
    array<unsigned int>^ get ();
    void set (array<unsigned int>^ value);
}

Property Value

Type: UInt32
See Also

Reference

IVREventsServer Interface
VisualComponents.Create3D.Remote Namespace


IVREventsServer.ClientId Property

IVREventsServerClientId Property

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int ClientId { get; set; }
property int ClientId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IVREventsServer Interface
VisualComponents.Create3D.Remote Namespace


IVREventsServer.DeviceInputs Property

IVREventsServerDeviceInputs Property

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Collection<DeviceInputs> DeviceInputs { get; }
property Collection<DeviceInputs^>^ DeviceInputs {
    Collection<DeviceInputs^>^ get ();
}

Property Value

Type: CollectionDeviceInputs
See Also

Reference

IVREventsServer Interface
VisualComponents.Create3D.Remote Namespace


IVREventsServer.DeviceModel Property

IVREventsServerDeviceModel Property

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string DeviceModel { get; set; }
property String^ DeviceModel {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IVREventsServer Interface
VisualComponents.Create3D.Remote Namespace


IVREventsServer.Directions Property

IVREventsServerDirections Property

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3[] Directions { get; set; }
property array<Vector3>^ Directions {
    array<Vector3>^ get ();
    void set (array<Vector3>^ value);
}

Property Value

Type: Vector3
See Also

Reference

IVREventsServer Interface
VisualComponents.Create3D.Remote Namespace


IVREventsServer.EventCounter Property

IVREventsServerEventCounter Property

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int EventCounter { get; set; }
property int EventCounter {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IVREventsServer Interface
VisualComponents.Create3D.Remote Namespace


IVREventsServer.EventsEnabled Property

IVREventsServerEventsEnabled Property

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool EventsEnabled { get; set; }
property bool EventsEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IVREventsServer Interface
VisualComponents.Create3D.Remote Namespace


IVREventsServer.MaxUpdateRate Property

IVREventsServerMaxUpdateRate Property

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int MaxUpdateRate { get; set; }
property int MaxUpdateRate {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IVREventsServer Interface
VisualComponents.Create3D.Remote Namespace


IVREventsServer.OneMeterLength Property

IVREventsServerOneMeterLength Property

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
float OneMeterLength { get; set; }
property float OneMeterLength {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

IVREventsServer Interface
VisualComponents.Create3D.Remote Namespace


IVREventsServer.Positions Property

IVREventsServerPositions Property

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3[] Positions { get; set; }
property array<Vector3>^ Positions {
    array<Vector3>^ get ();
    void set (array<Vector3>^ value);
}

Property Value

Type: Vector3
See Also

Reference

IVREventsServer Interface
VisualComponents.Create3D.Remote Namespace


IVREventsServer.RealEventCounter Property

IVREventsServerRealEventCounter Property

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int RealEventCounter { get; set; }
property int RealEventCounter {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IVREventsServer Interface
VisualComponents.Create3D.Remote Namespace


IVREventsServer.RoomCenter Property

IVREventsServerRoomCenter Property

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3 RoomCenter { get; set; }
property Vector3 RoomCenter {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

IVREventsServer Interface
VisualComponents.Create3D.Remote Namespace


IVREventsServer.Times Property

IVREventsServerTimes Property

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
float[] Times { get; set; }
property array<float>^ Times {
    array<float>^ get ();
    void set (array<float>^ value);
}

Property Value

Type: Single
See Also

Reference

IVREventsServer Interface
VisualComponents.Create3D.Remote Namespace


IVREventsServer.Touches Property

IVREventsServerTouches Property

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Vector3[] Touches { get; set; }
property array<Vector3>^ Touches {
    array<Vector3>^ get ();
    void set (array<Vector3>^ value);
}

Property Value

Type: Vector3
See Also

Reference

IVREventsServer Interface
VisualComponents.Create3D.Remote Namespace


IVREventsServer Methods

The IVREventsServer type exposes the following members.

Methods
 | Name | Description
Public method | NotifyPython |
Public method | ToggleAction |
Top
See Also

Reference

IVREventsServer Interface
VisualComponents.Create3D.Remote Namespace


IVREventsServer.NotifyPython Method

IVREventsServerNotifyPython Method

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void NotifyPython()
void NotifyPython()
See Also

Reference

IVREventsServer Interface
VisualComponents.Create3D.Remote Namespace


IVREventsServer.ToggleAction Method

IVREventsServerToggleAction Method

Namespace: VisualComponents.Create3D.Remote
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ToggleAction(
    int clientId,
    string action,
    bool value
)
void ToggleAction(
    int clientId,
    String^ action,
    bool value
)

Parameters

clientId
Type: SystemInt32
action
Type: SystemString
value
Type: SystemBoolean
See Also

Reference

IVREventsServer Interface
VisualComponents.Create3D.Remote Namespace


VisualComponents.Messages Namespace

Classes
 | Class | Description
Public class | AbsoluteKey |
Public class | Action |
Public class | ActionTypes | Container for nested types declared in the Action message type.
Public class | ActionTypesToggleAction |
Public class | AddCamera |
Public class | AddComponent | ----------------------------------------------------------------------------- Stream
Public class | AddMaterial |
Public class | AddMesh |
Public class | AddNode |
Public class | AddShaderMaterial |
Public class | AddSubLine |
Public class | AddSubMesh |
Public class | AddSubMeshTopology |
Public class | AddSubMeshTopologyCurve |
Public class | AddSync |
Public class | AddTexture |
Public class | AddTimeStep |
Public class | AddView |
Public class | ChangeMeshKey |
Public class | CloseStream |
Public class | ConnectStream | ----------------------------------------------------------------------------- HandShake
Public class | DeleteComponent |
Public class | DeviceInfo |
Public class | DeviceInput |
Public class | EventCounter |
Public class | EventsEnabled | ----------------------------------------------------------------------------- VREvents
Public class | FinishMessage |
Public class | GetDefaults | ----------------------------------------------------------------------------- Base
Public class | InitDefaults |
Public class | InputValue |
Public class | InputValueTypes | Container for nested types declared in the InputValue message type.
Public class | InputValueTypesAxis |
Public class | InputValueTypesAxis2D |
Public class | InputValueTypesButton |
Public class | LoadLayoutEcat | Note: this message requires CACHED_VR_ECAT_SUPPORT
Public class | LoadLayoutSimple |
Public class | MaxUpdateRate |
Public class | MoveComponent |
Public class | MoveResult |
Public class | NotifyPython |
Public class | PreviewImages |
Public class | PythonRequest |
Public class | RemoveComponentKey |
Public class | ResetSim |
Public class | RunPauseSim |
Public class | Services | Services/messages and their managers/servers: - handshake - HandshakeServer.cs/cpp (todo) - establishing the connection. - stream - StreamServer.cs/cpp (todo) - serializing the whole layout. Keeping it in sync in the viewer side. - processed by Experience or ThreeJs viewer. - base - BaseServer.cs - vr_events - VREventsServer.cs - sending/receiving VR events and tracking data. Ports: - 6688 - VC.Engine.exe - 7000 - VC.Headless.exe / VC.Engine.exe - 700x - VC.Headless.exe Also see: - C:\bb1\visualcomponents-plugin\Plugin\Proto\Plugin.Cloud.Server.Messages.proto
Public class | ServicesTypes | Container for nested types declared in the Services message type.
Public class | ServicesTypesBase |
Public class | ServicesTypesHandShake |
Public class | ServicesTypesStream |
Public class | ServicesTypesVREvents |
Public class | SetBackground |
Public class | SetFloor |
Public class | SetNodeMaterials |
Public class | SetNodeMatrix |
Public class | SetParentKey |
Public class | SetUVKey |
Public class | SpeedFactor |
Public class | StartSocket |
Public class | StartStream |
Public class | VisualComponentsMessagesReflection | Holder for reflection information generated from VisualComponents_Messages.proto
Enumerations
 | Enumeration | Description
Public enumeration | ActionTypesActionType |
Public enumeration | InputValueInputOneofCase | Enum of possible cases for the "input" oneof.


AbsoluteKey Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesAbsoluteKey

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class AbsoluteKey : IMessage<AbsoluteKey>,
    IMessage, IEquatable<AbsoluteKey>, IDeepCloneable<AbsoluteKey>
public ref class AbsoluteKey sealed : IMessage<AbsoluteKey^>,
    IMessage, IEquatable<AbsoluteKey^>, IDeepCloneable<AbsoluteKey^>

The AbsoluteKey type exposes the following members.

Constructors
 | Name | Description
Public method | AbsoluteKey | Initializes a new instance of the AbsoluteKey class
Public method | AbsoluteKey(AbsoluteKey) | Initializes a new instance of the AbsoluteKey class
Top
Properties
 | Name | Description
Public property | ComponentId |
 | Descriptor |
Public property | NodeId |
 | Parser |
Public property | Position |
Public property | Rotation |
Public property | Rotation2 |
Public property | Scale |
Public property | Scale2 |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AbsoluteKey) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AbsoluteKey) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
ComponentIdFieldNumber | Field number for the "component_id" field.
NodeIdFieldNumber | Field number for the "node_id" field.
PositionFieldNumber | Field number for the "position" field.
Rotation2FieldNumber | Field number for the "rotation_2" field.
RotationFieldNumber | Field number for the "rotation" field.
Scale2FieldNumber | Field number for the "scale_2" field.
ScaleFieldNumber | Field number for the "scale" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


AbsoluteKey Constructor

Overload List
 | Name | Description
Public method | AbsoluteKey | Initializes a new instance of the AbsoluteKey class
Public method | AbsoluteKey(AbsoluteKey) | Initializes a new instance of the AbsoluteKey class
Top
See Also

Reference

AbsoluteKey Class
VisualComponents.Messages Namespace


AbsoluteKey Constructor

Initializes a new instance of the AbsoluteKey class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AbsoluteKey()
public:
AbsoluteKey()
See Also

Reference

AbsoluteKey Class
AbsoluteKey Overload
VisualComponents.Messages Namespace


AbsoluteKey Constructor (AbsoluteKey)

Initializes a new instance of the AbsoluteKey class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AbsoluteKey(
    AbsoluteKey other
)
public:
AbsoluteKey(
    AbsoluteKey^ other
)

Parameters

other
Type: VisualComponents.MessagesAbsoluteKey
See Also

Reference

AbsoluteKey Class
AbsoluteKey Overload
VisualComponents.Messages Namespace


AbsoluteKey Properties

The AbsoluteKey type exposes the following members.

Properties
 | Name | Description
Public property | ComponentId |
 | Descriptor |
Public property | NodeId |
 | Parser |
Public property | Position |
Public property | Rotation |
Public property | Rotation2 |
Public property | Scale |
Public property | Scale2 |
Top
See Also

Reference

AbsoluteKey Class
VisualComponents.Messages Namespace


AbsoluteKey.ComponentId Property

AbsoluteKeyComponentId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ComponentId { get; set; }
public:
property int ComponentId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AbsoluteKey Class
VisualComponents.Messages Namespace


AbsoluteKey.Descriptor Property

AbsoluteKeyDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

AbsoluteKey Class
VisualComponents.Messages Namespace


AbsoluteKey.NodeId Property

AbsoluteKeyNodeId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int NodeId { get; set; }
public:
property int NodeId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AbsoluteKey Class
VisualComponents.Messages Namespace


AbsoluteKey.Parser Property

AbsoluteKeyParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<AbsoluteKey> Parser { get; }
public:
static property MessageParser<AbsoluteKey^>^ Parser {
    MessageParser<AbsoluteKey^>^ get ();
}

Property Value

Type: MessageParserAbsoluteKey
See Also

Reference

AbsoluteKey Class
VisualComponents.Messages Namespace


AbsoluteKey.Position Property

AbsoluteKeyPosition Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Position { get; }
public:
property RepeatedField<float>^ Position {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

AbsoluteKey Class
VisualComponents.Messages Namespace


AbsoluteKey.Rotation Property

AbsoluteKeyRotation Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Rotation { get; }
public:
property RepeatedField<float>^ Rotation {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

AbsoluteKey Class
VisualComponents.Messages Namespace


AbsoluteKey.Rotation2 Property

AbsoluteKeyRotation2 Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Rotation2 { get; }
public:
property RepeatedField<float>^ Rotation2 {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

AbsoluteKey Class
VisualComponents.Messages Namespace


AbsoluteKey.Scale Property

AbsoluteKeyScale Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Scale { get; }
public:
property RepeatedField<float>^ Scale {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

AbsoluteKey Class
VisualComponents.Messages Namespace


AbsoluteKey.Scale2 Property

AbsoluteKeyScale2 Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Scale2 { get; }
public:
property RepeatedField<float>^ Scale2 {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

AbsoluteKey Class
VisualComponents.Messages Namespace


AbsoluteKey Methods

The AbsoluteKey type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AbsoluteKey) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AbsoluteKey) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AbsoluteKey Class
VisualComponents.Messages Namespace


AbsoluteKey.CalculateSize Method

AbsoluteKeyCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AbsoluteKey.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

AbsoluteKey Class
VisualComponents.Messages Namespace


AbsoluteKey.Clone Method

AbsoluteKeyClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AbsoluteKey Clone()
public:
virtual AbsoluteKey^ Clone() sealed

Return Value

Type: AbsoluteKey

[Missing <returns> documentation for "M:VisualComponents.Messages.AbsoluteKey.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

AbsoluteKey Class
VisualComponents.Messages Namespace


AbsoluteKey.Equals Method

AbsoluteKeyEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AbsoluteKey) |
Top
See Also

Reference

AbsoluteKey Class
VisualComponents.Messages Namespace


AbsoluteKey.Equals Method (Object)

AbsoluteKeyEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AbsoluteKey.Equals(System.Object)"]

See Also

Reference

AbsoluteKey Class
Equals Overload
VisualComponents.Messages Namespace


AbsoluteKey.Equals Method (AbsoluteKey)

AbsoluteKeyEquals Method (AbsoluteKey)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    AbsoluteKey other
)
public:
virtual bool Equals(
    AbsoluteKey^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAbsoluteKey

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AbsoluteKey.Equals(VisualComponents.Messages.AbsoluteKey)"]

Implements

IEquatableTEquals(T)
See Also

Reference

AbsoluteKey Class
Equals Overload
VisualComponents.Messages Namespace


AbsoluteKey.GetHashCode Method

AbsoluteKeyGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AbsoluteKey.GetHashCode"]

See Also

Reference

AbsoluteKey Class
VisualComponents.Messages Namespace


AbsoluteKey.MergeFrom Method

AbsoluteKeyMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AbsoluteKey) |
Top
See Also

Reference

AbsoluteKey Class
VisualComponents.Messages Namespace


AbsoluteKey.MergeFrom Method (CodedInputStream)

AbsoluteKeyMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

AbsoluteKey Class
MergeFrom Overload
VisualComponents.Messages Namespace


AbsoluteKey.MergeFrom Method (AbsoluteKey)

AbsoluteKeyMergeFrom Method (AbsoluteKey)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    AbsoluteKey other
)
public:
virtual void MergeFrom(
    AbsoluteKey^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAbsoluteKey

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

AbsoluteKey Class
MergeFrom Overload
VisualComponents.Messages Namespace


AbsoluteKey.ToString Method

AbsoluteKeyToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.AbsoluteKey.ToString"]

See Also

Reference

AbsoluteKey Class
VisualComponents.Messages Namespace


AbsoluteKey.WriteTo Method

AbsoluteKeyWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

AbsoluteKey Class
VisualComponents.Messages Namespace


AbsoluteKey Fields

The AbsoluteKey type exposes the following members.

Fields
Name | Description
ComponentIdFieldNumber | Field number for the "component_id" field.
NodeIdFieldNumber | Field number for the "node_id" field.
PositionFieldNumber | Field number for the "position" field.
Rotation2FieldNumber | Field number for the "rotation_2" field.
RotationFieldNumber | Field number for the "rotation" field.
Scale2FieldNumber | Field number for the "scale_2" field.
ScaleFieldNumber | Field number for the "scale" field.
Top
See Also

Reference

AbsoluteKey Class
VisualComponents.Messages Namespace


AbsoluteKey.ComponentIdFieldNumber Field

AbsoluteKeyComponentIdFieldNumber Field

Field number for the "component_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ComponentIdFieldNumber = 2
public:
literal int ComponentIdFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

AbsoluteKey Class
VisualComponents.Messages Namespace


AbsoluteKey.NodeIdFieldNumber Field

AbsoluteKeyNodeIdFieldNumber Field

Field number for the "node_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int NodeIdFieldNumber = 1
public:
literal int NodeIdFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

AbsoluteKey Class
VisualComponents.Messages Namespace


AbsoluteKey.PositionFieldNumber Field

AbsoluteKeyPositionFieldNumber Field

Field number for the "position" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int PositionFieldNumber = 3
public:
literal int PositionFieldNumber = 3

Field Value

Type: Int32
See Also

Reference

AbsoluteKey Class
VisualComponents.Messages Namespace


AbsoluteKey.Rotation2FieldNumber Field

AbsoluteKeyRotation2FieldNumber Field

Field number for the "rotation_2" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int Rotation2FieldNumber = 6
public:
literal int Rotation2FieldNumber = 6

Field Value

Type: Int32
See Also

Reference

AbsoluteKey Class
VisualComponents.Messages Namespace


AbsoluteKey.RotationFieldNumber Field

AbsoluteKeyRotationFieldNumber Field

Field number for the "rotation" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int RotationFieldNumber = 4
public:
literal int RotationFieldNumber = 4

Field Value

Type: Int32
See Also

Reference

AbsoluteKey Class
VisualComponents.Messages Namespace


AbsoluteKey.Scale2FieldNumber Field

AbsoluteKeyScale2FieldNumber Field

Field number for the "scale_2" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int Scale2FieldNumber = 7
public:
literal int Scale2FieldNumber = 7

Field Value

Type: Int32
See Also

Reference

AbsoluteKey Class
VisualComponents.Messages Namespace


AbsoluteKey.ScaleFieldNumber Field

AbsoluteKeyScaleFieldNumber Field

Field number for the "scale" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ScaleFieldNumber = 5
public:
literal int ScaleFieldNumber = 5

Field Value

Type: Int32
See Also

Reference

AbsoluteKey Class
VisualComponents.Messages Namespace


Action Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesAction

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class Action : IMessage<Action>,
    IMessage, IEquatable<Action>, IDeepCloneable<Action>
public ref class Action sealed : IMessage<Action^>,
    IMessage, IEquatable<Action^>, IDeepCloneable<Action^>

The Action type exposes the following members.

Constructors
 | Name | Description
Public method | Action | Initializes a new instance of the Action class
Public method | Action(Action) | Initializes a new instance of the Action class
Top
Properties
Name | Description
Descriptor |
Parser |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(Action) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(Action) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


Action Constructor

Overload List
 | Name | Description
Public method | Action | Initializes a new instance of the Action class
Public method | Action(Action) | Initializes a new instance of the Action class
Top
See Also

Reference

Action Class
VisualComponents.Messages Namespace


Action Constructor

Initializes a new instance of the Action class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Action()
public:
Action()
See Also

Reference

Action Class
Action Overload
VisualComponents.Messages Namespace


Action Constructor (Action)

Initializes a new instance of the Action class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Action(
    Action other
)
public:
Action(
    Action^ other
)

Parameters

other
Type: VisualComponents.MessagesAction
See Also

Reference

Action Class
Action Overload
VisualComponents.Messages Namespace


Action Properties

The Action type exposes the following members.

Properties
Name | Description
Descriptor |
Parser |
Top
See Also

Reference

Action Class
VisualComponents.Messages Namespace


Action.Descriptor Property

ActionDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

Action Class
VisualComponents.Messages Namespace


Action.Parser Property

ActionParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<Action> Parser { get; }
public:
static property MessageParser<Action^>^ Parser {
    MessageParser<Action^>^ get ();
}

Property Value

Type: MessageParserAction
See Also

Reference

Action Class
VisualComponents.Messages Namespace


Action Methods

The Action type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(Action) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(Action) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

Action Class
VisualComponents.Messages Namespace


Action.CalculateSize Method

ActionCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.Action.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

Action Class
VisualComponents.Messages Namespace


Action.Clone Method

ActionClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Action Clone()
public:
virtual Action^ Clone() sealed

Return Value

Type: Action

[Missing <returns> documentation for "M:VisualComponents.Messages.Action.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

Action Class
VisualComponents.Messages Namespace


Action.Equals Method

ActionEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(Action) |
Top
See Also

Reference

Action Class
VisualComponents.Messages Namespace


Action.Equals Method (Object)

ActionEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.Action.Equals(System.Object)"]

See Also

Reference

Action Class
Equals Overload
VisualComponents.Messages Namespace


Action.Equals Method (Action)

ActionEquals Method (Action)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    Action other
)
public:
virtual bool Equals(
    Action^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAction

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.Action.Equals(VisualComponents.Messages.Action)"]

Implements

IEquatableTEquals(T)
See Also

Reference

Action Class
Equals Overload
VisualComponents.Messages Namespace


Action.GetHashCode Method

ActionGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.Action.GetHashCode"]

See Also

Reference

Action Class
VisualComponents.Messages Namespace


Action.MergeFrom Method

ActionMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(Action) |
Top
See Also

Reference

Action Class
VisualComponents.Messages Namespace


Action.MergeFrom Method (CodedInputStream)

ActionMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

Action Class
MergeFrom Overload
VisualComponents.Messages Namespace


Action.MergeFrom Method (Action)

ActionMergeFrom Method (Action)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    Action other
)
public:
virtual void MergeFrom(
    Action^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAction

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

Action Class
MergeFrom Overload
VisualComponents.Messages Namespace


Action.ToString Method

ActionToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.Action.ToString"]

See Also

Reference

Action Class
VisualComponents.Messages Namespace


Action.WriteTo Method

ActionWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

Action Class
VisualComponents.Messages Namespace


Action.Types Class

ActionTypes Class

Container for nested types declared in the Action message type.
Inheritance Hierarchy
SystemObject
VisualComponents.MessagesActionTypes

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class Types
public ref class Types abstract sealed
See Also

Reference

VisualComponents.Messages Namespace


Action.Types.ActionType Enumeration

ActionTypesActionType Enumeration

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ActionType
public enum class ActionType
Members
Member name | Value | Description
Unknown | 0 |
Teleport | 1 |
Elevator | 2 |
Pause | 3 |
See Also

Reference

VisualComponents.Messages Namespace


Action.Types.ToggleAction Class

ActionTypesToggleAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesActionTypesToggleAction

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ToggleAction : IMessage<ActionTypesToggleAction>,
    IMessage, IEquatable<ActionTypesToggleAction>, IDeepCloneable<ActionTypesToggleAction>
public ref class ToggleAction sealed : IMessage<ActionTypesToggleAction^>,
    IMessage, IEquatable<ActionTypesToggleAction^>, IDeepCloneable<ActionTypesToggleAction^>

The ActionTypesToggleAction type exposes the following members.

Constructors
 | Name | Description
Public method | ActionTypesToggleAction | Initializes a new instance of the ActionTypesToggleAction class
Public method | ActionTypesToggleAction(ActionTypesToggleAction) | Initializes a new instance of the ActionTypesToggleAction class
Top
Properties
 | Name | Description
 | Descriptor |
 | Parser |
Public property | Type |
Public property | Value |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ActionTypesToggleAction) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(ActionTypesToggleAction) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
TypeFieldNumber | Field number for the "type" field.
ValueFieldNumber | Field number for the "value" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


ToggleAction Constructor

Overload List
 | Name | Description
Public method | ActionTypesToggleAction | Initializes a new instance of the ActionTypesToggleAction class
Public method | ActionTypesToggleAction(ActionTypesToggleAction) | Initializes a new instance of the ActionTypesToggleAction class
Top
See Also

Reference

ActionTypesToggleAction Class
VisualComponents.Messages Namespace


Action.Types.ToggleAction Constructor

ActionTypesToggleAction Constructor

Initializes a new instance of the ActionTypesToggleAction class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ToggleAction()
public:
ToggleAction()
See Also

Reference

ActionTypesToggleAction Class
ActionTypesToggleAction Overload
VisualComponents.Messages Namespace


Action.Types.ToggleAction Constructor (Action.Types.ToggleAction)

ActionTypesToggleAction Constructor (ActionTypesToggleAction)

Initializes a new instance of the ActionTypesToggleAction class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ToggleAction(
    ActionTypesToggleAction other
)
public:
ToggleAction(
    ActionTypesToggleAction^ other
)

Parameters

other
Type: VisualComponents.MessagesActionTypesToggleAction
See Also

Reference

ActionTypesToggleAction Class
ActionTypesToggleAction Overload
VisualComponents.Messages Namespace


ToggleAction Properties

The ActionTypesToggleAction type exposes the following members.

Properties
 | Name | Description
 | Descriptor |
 | Parser |
Public property | Type |
Public property | Value |
Top
See Also

Reference

ActionTypesToggleAction Class
VisualComponents.Messages Namespace


Action.Types.ToggleAction.Descriptor Property

ActionTypesToggleActionDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

ActionTypesToggleAction Class
VisualComponents.Messages Namespace


Action.Types.ToggleAction.Parser Property

ActionTypesToggleActionParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<ActionTypesToggleAction> Parser { get; }
public:
static property MessageParser<ActionTypesToggleAction^>^ Parser {
    MessageParser<ActionTypesToggleAction^>^ get ();
}

Property Value

Type: MessageParserActionTypesToggleAction
See Also

Reference

ActionTypesToggleAction Class
VisualComponents.Messages Namespace


Action.Types.ToggleAction.Type Property

ActionTypesToggleActionType Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionTypesActionType Type { get; set; }
public:
property ActionTypesActionType Type {
    ActionTypesActionType get ();
    void set (ActionTypesActionType value);
}

Property Value

Type: ActionTypesActionType
See Also

Reference

ActionTypesToggleAction Class
VisualComponents.Messages Namespace


Action.Types.ToggleAction.Value Property

ActionTypesToggleActionValue Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Value { get; set; }
public:
property bool Value {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ActionTypesToggleAction Class
VisualComponents.Messages Namespace


ToggleAction Methods

The ActionTypesToggleAction type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ActionTypesToggleAction) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(ActionTypesToggleAction) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ActionTypesToggleAction Class
VisualComponents.Messages Namespace


Action.Types.ToggleAction.CalculateSize Method

ActionTypesToggleActionCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.Action.Types.ToggleAction.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

ActionTypesToggleAction Class
VisualComponents.Messages Namespace


Action.Types.ToggleAction.Clone Method

ActionTypesToggleActionClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionTypesToggleAction Clone()
public:
virtual ActionTypesToggleAction^ Clone() sealed

Return Value

Type: ActionTypesToggleAction

[Missing <returns> documentation for "M:VisualComponents.Messages.Action.Types.ToggleAction.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

ActionTypesToggleAction Class
VisualComponents.Messages Namespace


ToggleAction.Equals Method

ToggleActionEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ActionTypesToggleAction) |
Top
See Also

Reference

ActionTypesToggleAction Class
VisualComponents.Messages Namespace


Action.Types.ToggleAction.Equals Method (Object)

ActionTypesToggleActionEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.Action.Types.ToggleAction.Equals(System.Object)"]

See Also

Reference

ActionTypesToggleAction Class
Equals Overload
VisualComponents.Messages Namespace


Action.Types.ToggleAction.Equals Method (Action.Types.ToggleAction)

ActionTypesToggleActionEquals Method (ActionTypesToggleAction)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    ActionTypesToggleAction other
)
public:
virtual bool Equals(
    ActionTypesToggleAction^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesActionTypesToggleAction

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.Action.Types.ToggleAction.Equals(VisualComponents.Messages.Action.Types.ToggleAction)"]

Implements

IEquatableTEquals(T)
See Also

Reference

ActionTypesToggleAction Class
Equals Overload
VisualComponents.Messages Namespace


Action.Types.ToggleAction.GetHashCode Method

ActionTypesToggleActionGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.Action.Types.ToggleAction.GetHashCode"]

See Also

Reference

ActionTypesToggleAction Class
VisualComponents.Messages Namespace


ToggleAction.MergeFrom Method

ToggleActionMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(ActionTypesToggleAction) |
Top
See Also

Reference

ActionTypesToggleAction Class
VisualComponents.Messages Namespace


Action.Types.ToggleAction.MergeFrom Method (CodedInputStream)

ActionTypesToggleActionMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

ActionTypesToggleAction Class
MergeFrom Overload
VisualComponents.Messages Namespace


Action.Types.ToggleAction.MergeFrom Method (Action.Types.ToggleAction)

ActionTypesToggleActionMergeFrom Method (ActionTypesToggleAction)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    ActionTypesToggleAction other
)
public:
virtual void MergeFrom(
    ActionTypesToggleAction^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesActionTypesToggleAction

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

ActionTypesToggleAction Class
MergeFrom Overload
VisualComponents.Messages Namespace


Action.Types.ToggleAction.ToString Method

ActionTypesToggleActionToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.Action.Types.ToggleAction.ToString"]

See Also

Reference

ActionTypesToggleAction Class
VisualComponents.Messages Namespace


Action.Types.ToggleAction.WriteTo Method

ActionTypesToggleActionWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

ActionTypesToggleAction Class
VisualComponents.Messages Namespace


ToggleAction Fields

The ActionTypesToggleAction type exposes the following members.

Fields
Name | Description
TypeFieldNumber | Field number for the "type" field.
ValueFieldNumber | Field number for the "value" field.
Top
See Also

Reference

ActionTypesToggleAction Class
VisualComponents.Messages Namespace


Action.Types.ToggleAction.TypeFieldNumber Field

ActionTypesToggleActionTypeFieldNumber Field

Field number for the "type" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int TypeFieldNumber = 1
public:
literal int TypeFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

ActionTypesToggleAction Class
VisualComponents.Messages Namespace


Action.Types.ToggleAction.ValueFieldNumber Field

ActionTypesToggleActionValueFieldNumber Field

Field number for the "value" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ValueFieldNumber = 2
public:
literal int ValueFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

ActionTypesToggleAction Class
VisualComponents.Messages Namespace


AddCamera Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesAddCamera

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class AddCamera : IMessage<AddCamera>,
    IMessage, IEquatable<AddCamera>, IDeepCloneable<AddCamera>
public ref class AddCamera sealed : IMessage<AddCamera^>,
    IMessage, IEquatable<AddCamera^>, IDeepCloneable<AddCamera^>

The AddCamera type exposes the following members.

Constructors
 | Name | Description
Public method | AddCamera | Initializes a new instance of the AddCamera class
Public method | AddCamera(AddCamera) | Initializes a new instance of the AddCamera class
Top
Properties
 | Name | Description
 | Descriptor |
Public property | Fov |
 | Parser |
Public property | Position |
Public property | Rotation |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddCamera) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddCamera) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
FovFieldNumber | Field number for the "fov" field.
PositionFieldNumber | Field number for the "position" field.
RotationFieldNumber | Field number for the "rotation" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


AddCamera Constructor

Overload List
 | Name | Description
Public method | AddCamera | Initializes a new instance of the AddCamera class
Public method | AddCamera(AddCamera) | Initializes a new instance of the AddCamera class
Top
See Also

Reference

AddCamera Class
VisualComponents.Messages Namespace


AddCamera Constructor

Initializes a new instance of the AddCamera class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddCamera()
public:
AddCamera()
See Also

Reference

AddCamera Class
AddCamera Overload
VisualComponents.Messages Namespace


AddCamera Constructor (AddCamera)

Initializes a new instance of the AddCamera class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddCamera(
    AddCamera other
)
public:
AddCamera(
    AddCamera^ other
)

Parameters

other
Type: VisualComponents.MessagesAddCamera
See Also

Reference

AddCamera Class
AddCamera Overload
VisualComponents.Messages Namespace


AddCamera Properties

The AddCamera type exposes the following members.

Properties
 | Name | Description
 | Descriptor |
Public property | Fov |
 | Parser |
Public property | Position |
Public property | Rotation |
Top
See Also

Reference

AddCamera Class
VisualComponents.Messages Namespace


AddCamera.Descriptor Property

AddCameraDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

AddCamera Class
VisualComponents.Messages Namespace


AddCamera.Fov Property

AddCameraFov Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float Fov { get; set; }
public:
property float Fov {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

AddCamera Class
VisualComponents.Messages Namespace


AddCamera.Parser Property

AddCameraParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<AddCamera> Parser { get; }
public:
static property MessageParser<AddCamera^>^ Parser {
    MessageParser<AddCamera^>^ get ();
}

Property Value

Type: MessageParserAddCamera
See Also

Reference

AddCamera Class
VisualComponents.Messages Namespace


AddCamera.Position Property

AddCameraPosition Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Position { get; }
public:
property RepeatedField<float>^ Position {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

AddCamera Class
VisualComponents.Messages Namespace


AddCamera.Rotation Property

AddCameraRotation Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Rotation { get; }
public:
property RepeatedField<float>^ Rotation {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

AddCamera Class
VisualComponents.Messages Namespace


AddCamera Methods

The AddCamera type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddCamera) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddCamera) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AddCamera Class
VisualComponents.Messages Namespace


AddCamera.CalculateSize Method

AddCameraCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AddCamera.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

AddCamera Class
VisualComponents.Messages Namespace


AddCamera.Clone Method

AddCameraClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddCamera Clone()
public:
virtual AddCamera^ Clone() sealed

Return Value

Type: AddCamera

[Missing <returns> documentation for "M:VisualComponents.Messages.AddCamera.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

AddCamera Class
VisualComponents.Messages Namespace


AddCamera.Equals Method

AddCameraEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddCamera) |
Top
See Also

Reference

AddCamera Class
VisualComponents.Messages Namespace


AddCamera.Equals Method (Object)

AddCameraEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AddCamera.Equals(System.Object)"]

See Also

Reference

AddCamera Class
Equals Overload
VisualComponents.Messages Namespace


AddCamera.Equals Method (AddCamera)

AddCameraEquals Method (AddCamera)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    AddCamera other
)
public:
virtual bool Equals(
    AddCamera^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAddCamera

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AddCamera.Equals(VisualComponents.Messages.AddCamera)"]

Implements

IEquatableTEquals(T)
See Also

Reference

AddCamera Class
Equals Overload
VisualComponents.Messages Namespace


AddCamera.GetHashCode Method

AddCameraGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AddCamera.GetHashCode"]

See Also

Reference

AddCamera Class
VisualComponents.Messages Namespace


AddCamera.MergeFrom Method

AddCameraMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddCamera) |
Top
See Also

Reference

AddCamera Class
VisualComponents.Messages Namespace


AddCamera.MergeFrom Method (CodedInputStream)

AddCameraMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

AddCamera Class
MergeFrom Overload
VisualComponents.Messages Namespace


AddCamera.MergeFrom Method (AddCamera)

AddCameraMergeFrom Method (AddCamera)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    AddCamera other
)
public:
virtual void MergeFrom(
    AddCamera^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAddCamera

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

AddCamera Class
MergeFrom Overload
VisualComponents.Messages Namespace


AddCamera.ToString Method

AddCameraToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.AddCamera.ToString"]

See Also

Reference

AddCamera Class
VisualComponents.Messages Namespace


AddCamera.WriteTo Method

AddCameraWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

AddCamera Class
VisualComponents.Messages Namespace


AddCamera Fields

The AddCamera type exposes the following members.

Fields
Name | Description
FovFieldNumber | Field number for the "fov" field.
PositionFieldNumber | Field number for the "position" field.
RotationFieldNumber | Field number for the "rotation" field.
Top
See Also

Reference

AddCamera Class
VisualComponents.Messages Namespace


AddCamera.FovFieldNumber Field

AddCameraFovFieldNumber Field

Field number for the "fov" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int FovFieldNumber = 4
public:
literal int FovFieldNumber = 4

Field Value

Type: Int32
See Also

Reference

AddCamera Class
VisualComponents.Messages Namespace


AddCamera.PositionFieldNumber Field

AddCameraPositionFieldNumber Field

Field number for the "position" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int PositionFieldNumber = 2
public:
literal int PositionFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

AddCamera Class
VisualComponents.Messages Namespace


AddCamera.RotationFieldNumber Field

AddCameraRotationFieldNumber Field

Field number for the "rotation" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int RotationFieldNumber = 3
public:
literal int RotationFieldNumber = 3

Field Value

Type: Int32
See Also

Reference

AddCamera Class
VisualComponents.Messages Namespace


AddComponent Class

----------------------------------------------------------------------------- Stream
Inheritance Hierarchy
SystemObject
VisualComponents.MessagesAddComponent

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class AddComponent : IMessage<AddComponent>,
    IMessage, IEquatable<AddComponent>, IDeepCloneable<AddComponent>
public ref class AddComponent sealed : IMessage<AddComponent^>,
    IMessage, IEquatable<AddComponent^>, IDeepCloneable<AddComponent^>

The AddComponent type exposes the following members.

Constructors
 | Name | Description
Public method | AddComponent | Initializes a new instance of the AddComponent class
Public method | AddComponent(AddComponent) | Initializes a new instance of the AddComponent class
Top
Properties
 | Name | Description
Public property | BackfaceMode |
Public property | ComponentBound |
Public property | ComponentId |
Public property | ComponentName |
 | Descriptor |
Public property | EcatIndex |
 | Parser |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddComponent) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddComponent) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
BackfaceModeFieldNumber | Field number for the "backface_mode" field.
ComponentBoundFieldNumber | Field number for the "component_bound" field.
ComponentIdFieldNumber | Field number for the "component_id" field.
ComponentNameFieldNumber | Field number for the "component_name" field.
EcatIndexFieldNumber | Field number for the "ecat_index" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


AddComponent Constructor

Overload List
 | Name | Description
Public method | AddComponent | Initializes a new instance of the AddComponent class
Public method | AddComponent(AddComponent) | Initializes a new instance of the AddComponent class
Top
See Also

Reference

AddComponent Class
VisualComponents.Messages Namespace


AddComponent Constructor

Initializes a new instance of the AddComponent class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddComponent()
public:
AddComponent()
See Also

Reference

AddComponent Class
AddComponent Overload
VisualComponents.Messages Namespace


AddComponent Constructor (AddComponent)

Initializes a new instance of the AddComponent class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddComponent(
    AddComponent other
)
public:
AddComponent(
    AddComponent^ other
)

Parameters

other
Type: VisualComponents.MessagesAddComponent
See Also

Reference

AddComponent Class
AddComponent Overload
VisualComponents.Messages Namespace


AddComponent Properties

The AddComponent type exposes the following members.

Properties
 | Name | Description
Public property | BackfaceMode |
Public property | ComponentBound |
Public property | ComponentId |
Public property | ComponentName |
 | Descriptor |
Public property | EcatIndex |
 | Parser |
Top
See Also

Reference

AddComponent Class
VisualComponents.Messages Namespace


AddComponent.BackfaceMode Property

AddComponentBackfaceMode Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int BackfaceMode { get; set; }
public:
property int BackfaceMode {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AddComponent Class
VisualComponents.Messages Namespace


AddComponent.ComponentBound Property

AddComponentComponentBound Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> ComponentBound { get; }
public:
property RepeatedField<float>^ ComponentBound {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

AddComponent Class
VisualComponents.Messages Namespace


AddComponent.ComponentId Property

AddComponentComponentId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ComponentId { get; set; }
public:
property int ComponentId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AddComponent Class
VisualComponents.Messages Namespace


AddComponent.ComponentName Property

AddComponentComponentName Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ComponentName { get; set; }
public:
property String^ ComponentName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

AddComponent Class
VisualComponents.Messages Namespace


AddComponent.Descriptor Property

AddComponentDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

AddComponent Class
VisualComponents.Messages Namespace


AddComponent.EcatIndex Property

AddComponentEcatIndex Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int EcatIndex { get; set; }
public:
property int EcatIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AddComponent Class
VisualComponents.Messages Namespace


AddComponent.Parser Property

AddComponentParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<AddComponent> Parser { get; }
public:
static property MessageParser<AddComponent^>^ Parser {
    MessageParser<AddComponent^>^ get ();
}

Property Value

Type: MessageParserAddComponent
See Also

Reference

AddComponent Class
VisualComponents.Messages Namespace


AddComponent Methods

The AddComponent type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddComponent) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddComponent) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AddComponent Class
VisualComponents.Messages Namespace


AddComponent.CalculateSize Method

AddComponentCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AddComponent.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

AddComponent Class
VisualComponents.Messages Namespace


AddComponent.Clone Method

AddComponentClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddComponent Clone()
public:
virtual AddComponent^ Clone() sealed

Return Value

Type: AddComponent

[Missing <returns> documentation for "M:VisualComponents.Messages.AddComponent.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

AddComponent Class
VisualComponents.Messages Namespace


AddComponent.Equals Method

AddComponentEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddComponent) |
Top
See Also

Reference

AddComponent Class
VisualComponents.Messages Namespace


AddComponent.Equals Method (Object)

AddComponentEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AddComponent.Equals(System.Object)"]

See Also

Reference

AddComponent Class
Equals Overload
VisualComponents.Messages Namespace


AddComponent.Equals Method (AddComponent)

AddComponentEquals Method (AddComponent)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    AddComponent other
)
public:
virtual bool Equals(
    AddComponent^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAddComponent

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AddComponent.Equals(VisualComponents.Messages.AddComponent)"]

Implements

IEquatableTEquals(T)
See Also

Reference

AddComponent Class
Equals Overload
VisualComponents.Messages Namespace


AddComponent.GetHashCode Method

AddComponentGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AddComponent.GetHashCode"]

See Also

Reference

AddComponent Class
VisualComponents.Messages Namespace


AddComponent.MergeFrom Method

AddComponentMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddComponent) |
Top
See Also

Reference

AddComponent Class
VisualComponents.Messages Namespace


AddComponent.MergeFrom Method (CodedInputStream)

AddComponentMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

AddComponent Class
MergeFrom Overload
VisualComponents.Messages Namespace


AddComponent.MergeFrom Method (AddComponent)

AddComponentMergeFrom Method (AddComponent)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    AddComponent other
)
public:
virtual void MergeFrom(
    AddComponent^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAddComponent

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

AddComponent Class
MergeFrom Overload
VisualComponents.Messages Namespace


AddComponent.ToString Method

AddComponentToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.AddComponent.ToString"]

See Also

Reference

AddComponent Class
VisualComponents.Messages Namespace


AddComponent.WriteTo Method

AddComponentWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

AddComponent Class
VisualComponents.Messages Namespace


AddComponent Fields

The AddComponent type exposes the following members.

Fields
Name | Description
BackfaceModeFieldNumber | Field number for the "backface_mode" field.
ComponentBoundFieldNumber | Field number for the "component_bound" field.
ComponentIdFieldNumber | Field number for the "component_id" field.
ComponentNameFieldNumber | Field number for the "component_name" field.
EcatIndexFieldNumber | Field number for the "ecat_index" field.
Top
See Also

Reference

AddComponent Class
VisualComponents.Messages Namespace


AddComponent.BackfaceModeFieldNumber Field

AddComponentBackfaceModeFieldNumber Field

Field number for the "backface_mode" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int BackfaceModeFieldNumber = 3
public:
literal int BackfaceModeFieldNumber = 3

Field Value

Type: Int32
See Also

Reference

AddComponent Class
VisualComponents.Messages Namespace


AddComponent.ComponentBoundFieldNumber Field

AddComponentComponentBoundFieldNumber Field

Field number for the "component_bound" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ComponentBoundFieldNumber = 4
public:
literal int ComponentBoundFieldNumber = 4

Field Value

Type: Int32
See Also

Reference

AddComponent Class
VisualComponents.Messages Namespace


AddComponent.ComponentIdFieldNumber Field

AddComponentComponentIdFieldNumber Field

Field number for the "component_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ComponentIdFieldNumber = 1
public:
literal int ComponentIdFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

AddComponent Class
VisualComponents.Messages Namespace


AddComponent.ComponentNameFieldNumber Field

AddComponentComponentNameFieldNumber Field

Field number for the "component_name" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ComponentNameFieldNumber = 2
public:
literal int ComponentNameFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

AddComponent Class
VisualComponents.Messages Namespace


AddComponent.EcatIndexFieldNumber Field

AddComponentEcatIndexFieldNumber Field

Field number for the "ecat_index" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int EcatIndexFieldNumber = 5
public:
literal int EcatIndexFieldNumber = 5

Field Value

Type: Int32
See Also

Reference

AddComponent Class
VisualComponents.Messages Namespace


AddMaterial Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesAddMaterial

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class AddMaterial : IMessage<AddMaterial>,
    IMessage, IEquatable<AddMaterial>, IDeepCloneable<AddMaterial>
public ref class AddMaterial sealed : IMessage<AddMaterial^>,
    IMessage, IEquatable<AddMaterial^>, IDeepCloneable<AddMaterial^>

The AddMaterial type exposes the following members.

Constructors
 | Name | Description
Public method | AddMaterial | Initializes a new instance of the AddMaterial class
Public method | AddMaterial(AddMaterial) | Initializes a new instance of the AddMaterial class
Top
Properties
 | Name | Description
Public property | Ambient |
 | Descriptor |
Public property | Diffuse |
Public property | MaterialId |
Public property | MaterialName |
Public property | Opacity |
 | Parser |
Public property | Shininess |
Public property | Specular |
Public property | TextureId |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddMaterial) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddMaterial) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
AmbientFieldNumber | Field number for the "ambient" field.
DiffuseFieldNumber | Field number for the "diffuse" field.
MaterialIdFieldNumber | Field number for the "material_id" field.
MaterialNameFieldNumber | Field number for the "material_name" field.
OpacityFieldNumber | Field number for the "opacity" field.
ShininessFieldNumber | Field number for the "shininess" field.
SpecularFieldNumber | Field number for the "specular" field.
TextureIdFieldNumber | Field number for the "texture_id" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


AddMaterial Constructor

Overload List
 | Name | Description
Public method | AddMaterial | Initializes a new instance of the AddMaterial class
Public method | AddMaterial(AddMaterial) | Initializes a new instance of the AddMaterial class
Top
See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMaterial Constructor

Initializes a new instance of the AddMaterial class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddMaterial()
public:
AddMaterial()
See Also

Reference

AddMaterial Class
AddMaterial Overload
VisualComponents.Messages Namespace


AddMaterial Constructor (AddMaterial)

Initializes a new instance of the AddMaterial class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddMaterial(
    AddMaterial other
)
public:
AddMaterial(
    AddMaterial^ other
)

Parameters

other
Type: VisualComponents.MessagesAddMaterial
See Also

Reference

AddMaterial Class
AddMaterial Overload
VisualComponents.Messages Namespace


AddMaterial Properties

The AddMaterial type exposes the following members.

Properties
 | Name | Description
Public property | Ambient |
 | Descriptor |
Public property | Diffuse |
Public property | MaterialId |
Public property | MaterialName |
Public property | Opacity |
 | Parser |
Public property | Shininess |
Public property | Specular |
Public property | TextureId |
Top
See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMaterial.Ambient Property

AddMaterialAmbient Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Ambient { get; }
public:
property RepeatedField<float>^ Ambient {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMaterial.Descriptor Property

AddMaterialDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMaterial.Diffuse Property

AddMaterialDiffuse Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Diffuse { get; }
public:
property RepeatedField<float>^ Diffuse {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMaterial.MaterialId Property

AddMaterialMaterialId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int MaterialId { get; set; }
public:
property int MaterialId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMaterial.MaterialName Property

AddMaterialMaterialName Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string MaterialName { get; set; }
public:
property String^ MaterialName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMaterial.Opacity Property

AddMaterialOpacity Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float Opacity { get; set; }
public:
property float Opacity {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMaterial.Parser Property

AddMaterialParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<AddMaterial> Parser { get; }
public:
static property MessageParser<AddMaterial^>^ Parser {
    MessageParser<AddMaterial^>^ get ();
}

Property Value

Type: MessageParserAddMaterial
See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMaterial.Shininess Property

AddMaterialShininess Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float Shininess { get; set; }
public:
property float Shininess {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMaterial.Specular Property

AddMaterialSpecular Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Specular { get; }
public:
property RepeatedField<float>^ Specular {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMaterial.TextureId Property

AddMaterialTextureId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int TextureId { get; set; }
public:
property int TextureId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMaterial Methods

The AddMaterial type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddMaterial) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddMaterial) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMaterial.CalculateSize Method

AddMaterialCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AddMaterial.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMaterial.Clone Method

AddMaterialClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddMaterial Clone()
public:
virtual AddMaterial^ Clone() sealed

Return Value

Type: AddMaterial

[Missing <returns> documentation for "M:VisualComponents.Messages.AddMaterial.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMaterial.Equals Method

AddMaterialEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddMaterial) |
Top
See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMaterial.Equals Method (Object)

AddMaterialEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AddMaterial.Equals(System.Object)"]

See Also

Reference

AddMaterial Class
Equals Overload
VisualComponents.Messages Namespace


AddMaterial.Equals Method (AddMaterial)

AddMaterialEquals Method (AddMaterial)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    AddMaterial other
)
public:
virtual bool Equals(
    AddMaterial^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAddMaterial

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AddMaterial.Equals(VisualComponents.Messages.AddMaterial)"]

Implements

IEquatableTEquals(T)
See Also

Reference

AddMaterial Class
Equals Overload
VisualComponents.Messages Namespace


AddMaterial.GetHashCode Method

AddMaterialGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AddMaterial.GetHashCode"]

See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMaterial.MergeFrom Method

AddMaterialMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddMaterial) |
Top
See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMaterial.MergeFrom Method (CodedInputStream)

AddMaterialMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

AddMaterial Class
MergeFrom Overload
VisualComponents.Messages Namespace


AddMaterial.MergeFrom Method (AddMaterial)

AddMaterialMergeFrom Method (AddMaterial)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    AddMaterial other
)
public:
virtual void MergeFrom(
    AddMaterial^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAddMaterial

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

AddMaterial Class
MergeFrom Overload
VisualComponents.Messages Namespace


AddMaterial.ToString Method

AddMaterialToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.AddMaterial.ToString"]

See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMaterial.WriteTo Method

AddMaterialWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMaterial Fields

The AddMaterial type exposes the following members.

Fields
Name | Description
AmbientFieldNumber | Field number for the "ambient" field.
DiffuseFieldNumber | Field number for the "diffuse" field.
MaterialIdFieldNumber | Field number for the "material_id" field.
MaterialNameFieldNumber | Field number for the "material_name" field.
OpacityFieldNumber | Field number for the "opacity" field.
ShininessFieldNumber | Field number for the "shininess" field.
SpecularFieldNumber | Field number for the "specular" field.
TextureIdFieldNumber | Field number for the "texture_id" field.
Top
See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMaterial.AmbientFieldNumber Field

AddMaterialAmbientFieldNumber Field

Field number for the "ambient" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int AmbientFieldNumber = 5
public:
literal int AmbientFieldNumber = 5

Field Value

Type: Int32
See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMaterial.DiffuseFieldNumber Field

AddMaterialDiffuseFieldNumber Field

Field number for the "diffuse" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int DiffuseFieldNumber = 3
public:
literal int DiffuseFieldNumber = 3

Field Value

Type: Int32
See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMaterial.MaterialIdFieldNumber Field

AddMaterialMaterialIdFieldNumber Field

Field number for the "material_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int MaterialIdFieldNumber = 1
public:
literal int MaterialIdFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMaterial.MaterialNameFieldNumber Field

AddMaterialMaterialNameFieldNumber Field

Field number for the "material_name" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int MaterialNameFieldNumber = 2
public:
literal int MaterialNameFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMaterial.OpacityFieldNumber Field

AddMaterialOpacityFieldNumber Field

Field number for the "opacity" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int OpacityFieldNumber = 7
public:
literal int OpacityFieldNumber = 7

Field Value

Type: Int32
See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMaterial.ShininessFieldNumber Field

AddMaterialShininessFieldNumber Field

Field number for the "shininess" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ShininessFieldNumber = 6
public:
literal int ShininessFieldNumber = 6

Field Value

Type: Int32
See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMaterial.SpecularFieldNumber Field

AddMaterialSpecularFieldNumber Field

Field number for the "specular" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int SpecularFieldNumber = 4
public:
literal int SpecularFieldNumber = 4

Field Value

Type: Int32
See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMaterial.TextureIdFieldNumber Field

AddMaterialTextureIdFieldNumber Field

Field number for the "texture_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int TextureIdFieldNumber = 8
public:
literal int TextureIdFieldNumber = 8

Field Value

Type: Int32
See Also

Reference

AddMaterial Class
VisualComponents.Messages Namespace


AddMesh Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesAddMesh

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class AddMesh : IMessage<AddMesh>,
    IMessage, IEquatable<AddMesh>, IDeepCloneable<AddMesh>
public ref class AddMesh sealed : IMessage<AddMesh^>,
    IMessage, IEquatable<AddMesh^>, IDeepCloneable<AddMesh^>

The AddMesh type exposes the following members.

Constructors
 | Name | Description
Public method | AddMesh | Initializes a new instance of the AddMesh class
Public method | AddMesh(AddMesh) | Initializes a new instance of the AddMesh class
Top
Properties
 | Name | Description
 | Descriptor |
Public property | MeshId |
Public property | MeshName |
 | Parser |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddMesh) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddMesh) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
MeshIdFieldNumber | Field number for the "mesh_id" field.
MeshNameFieldNumber | Field number for the "mesh_name" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


AddMesh Constructor

Overload List
 | Name | Description
Public method | AddMesh | Initializes a new instance of the AddMesh class
Public method | AddMesh(AddMesh) | Initializes a new instance of the AddMesh class
Top
See Also

Reference

AddMesh Class
VisualComponents.Messages Namespace


AddMesh Constructor

Initializes a new instance of the AddMesh class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddMesh()
public:
AddMesh()
See Also

Reference

AddMesh Class
AddMesh Overload
VisualComponents.Messages Namespace


AddMesh Constructor (AddMesh)

Initializes a new instance of the AddMesh class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddMesh(
    AddMesh other
)
public:
AddMesh(
    AddMesh^ other
)

Parameters

other
Type: VisualComponents.MessagesAddMesh
See Also

Reference

AddMesh Class
AddMesh Overload
VisualComponents.Messages Namespace


AddMesh Properties

The AddMesh type exposes the following members.

Properties
 | Name | Description
 | Descriptor |
Public property | MeshId |
Public property | MeshName |
 | Parser |
Top
See Also

Reference

AddMesh Class
VisualComponents.Messages Namespace


AddMesh.Descriptor Property

AddMeshDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

AddMesh Class
VisualComponents.Messages Namespace


AddMesh.MeshId Property

AddMeshMeshId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int MeshId { get; set; }
public:
property int MeshId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AddMesh Class
VisualComponents.Messages Namespace


AddMesh.MeshName Property

AddMeshMeshName Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string MeshName { get; set; }
public:
property String^ MeshName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

AddMesh Class
VisualComponents.Messages Namespace


AddMesh.Parser Property

AddMeshParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<AddMesh> Parser { get; }
public:
static property MessageParser<AddMesh^>^ Parser {
    MessageParser<AddMesh^>^ get ();
}

Property Value

Type: MessageParserAddMesh
See Also

Reference

AddMesh Class
VisualComponents.Messages Namespace


AddMesh Methods

The AddMesh type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddMesh) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddMesh) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AddMesh Class
VisualComponents.Messages Namespace


AddMesh.CalculateSize Method

AddMeshCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AddMesh.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

AddMesh Class
VisualComponents.Messages Namespace


AddMesh.Clone Method

AddMeshClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddMesh Clone()
public:
virtual AddMesh^ Clone() sealed

Return Value

Type: AddMesh

[Missing <returns> documentation for "M:VisualComponents.Messages.AddMesh.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

AddMesh Class
VisualComponents.Messages Namespace


AddMesh.Equals Method

AddMeshEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddMesh) |
Top
See Also

Reference

AddMesh Class
VisualComponents.Messages Namespace


AddMesh.Equals Method (Object)

AddMeshEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AddMesh.Equals(System.Object)"]

See Also

Reference

AddMesh Class
Equals Overload
VisualComponents.Messages Namespace


AddMesh.Equals Method (AddMesh)

AddMeshEquals Method (AddMesh)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    AddMesh other
)
public:
virtual bool Equals(
    AddMesh^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAddMesh

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AddMesh.Equals(VisualComponents.Messages.AddMesh)"]

Implements

IEquatableTEquals(T)
See Also

Reference

AddMesh Class
Equals Overload
VisualComponents.Messages Namespace


AddMesh.GetHashCode Method

AddMeshGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AddMesh.GetHashCode"]

See Also

Reference

AddMesh Class
VisualComponents.Messages Namespace


AddMesh.MergeFrom Method

AddMeshMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddMesh) |
Top
See Also

Reference

AddMesh Class
VisualComponents.Messages Namespace


AddMesh.MergeFrom Method (CodedInputStream)

AddMeshMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

AddMesh Class
MergeFrom Overload
VisualComponents.Messages Namespace


AddMesh.MergeFrom Method (AddMesh)

AddMeshMergeFrom Method (AddMesh)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    AddMesh other
)
public:
virtual void MergeFrom(
    AddMesh^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAddMesh

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

AddMesh Class
MergeFrom Overload
VisualComponents.Messages Namespace


AddMesh.ToString Method

AddMeshToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.AddMesh.ToString"]

See Also

Reference

AddMesh Class
VisualComponents.Messages Namespace


AddMesh.WriteTo Method

AddMeshWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

AddMesh Class
VisualComponents.Messages Namespace


AddMesh Fields

The AddMesh type exposes the following members.

Fields
Name | Description
MeshIdFieldNumber | Field number for the "mesh_id" field.
MeshNameFieldNumber | Field number for the "mesh_name" field.
Top
See Also

Reference

AddMesh Class
VisualComponents.Messages Namespace


AddMesh.MeshIdFieldNumber Field

AddMeshMeshIdFieldNumber Field

Field number for the "mesh_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int MeshIdFieldNumber = 1
public:
literal int MeshIdFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

AddMesh Class
VisualComponents.Messages Namespace


AddMesh.MeshNameFieldNumber Field

AddMeshMeshNameFieldNumber Field

Field number for the "mesh_name" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int MeshNameFieldNumber = 2
public:
literal int MeshNameFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

AddMesh Class
VisualComponents.Messages Namespace


AddNode Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesAddNode

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class AddNode : IMessage<AddNode>,
    IMessage, IEquatable<AddNode>, IDeepCloneable<AddNode>
public ref class AddNode sealed : IMessage<AddNode^>,
    IMessage, IEquatable<AddNode^>, IDeepCloneable<AddNode^>

The AddNode type exposes the following members.

Constructors
 | Name | Description
Public method | AddNode | Initializes a new instance of the AddNode class
Public method | AddNode(AddNode) | Initializes a new instance of the AddNode class
Top
Properties
 | Name | Description
Public property | BoundVersion |
Public property | ComponentId |
Public property | DefaultColor |
 | Descriptor |
Public property | MeshId |
Public property | NodeBound |
Public property | NodeId |
Public property | NodeName |
Public property | ParentComponentId |
Public property | ParentNodeId |
 | Parser |
Public property | Position |
Public property | Rotation |
Public property | Rotation2 |
Public property | Scale |
Public property | Scale2 |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddNode) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddNode) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
BoundVersionFieldNumber | Field number for the "bound_version" field.
ComponentIdFieldNumber | Field number for the "component_id" field.
DefaultColorFieldNumber | Field number for the "default_color" field.
MeshIdFieldNumber | Field number for the "mesh_id" field.
NodeBoundFieldNumber | Field number for the "node_bound" field.
NodeIdFieldNumber | Field number for the "node_id" field.
NodeNameFieldNumber | Field number for the "node_name" field.
ParentComponentIdFieldNumber | Field number for the "parent_component_id" field.
ParentNodeIdFieldNumber | Field number for the "parent_node_id" field.
PositionFieldNumber | Field number for the "position" field.
Rotation2FieldNumber | Field number for the "rotation_2" field.
RotationFieldNumber | Field number for the "rotation" field.
Scale2FieldNumber | Field number for the "scale_2" field.
ScaleFieldNumber | Field number for the "scale" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


AddNode Constructor

Overload List
 | Name | Description
Public method | AddNode | Initializes a new instance of the AddNode class
Public method | AddNode(AddNode) | Initializes a new instance of the AddNode class
Top
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode Constructor

Initializes a new instance of the AddNode class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddNode()
public:
AddNode()
See Also

Reference

AddNode Class
AddNode Overload
VisualComponents.Messages Namespace


AddNode Constructor (AddNode)

Initializes a new instance of the AddNode class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddNode(
    AddNode other
)
public:
AddNode(
    AddNode^ other
)

Parameters

other
Type: VisualComponents.MessagesAddNode
See Also

Reference

AddNode Class
AddNode Overload
VisualComponents.Messages Namespace


AddNode Properties

The AddNode type exposes the following members.

Properties
 | Name | Description
Public property | BoundVersion |
Public property | ComponentId |
Public property | DefaultColor |
 | Descriptor |
Public property | MeshId |
Public property | NodeBound |
Public property | NodeId |
Public property | NodeName |
Public property | ParentComponentId |
Public property | ParentNodeId |
 | Parser |
Public property | Position |
Public property | Rotation |
Public property | Rotation2 |
Public property | Scale |
Public property | Scale2 |
Top
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.BoundVersion Property

AddNodeBoundVersion Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int BoundVersion { get; set; }
public:
property int BoundVersion {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.ComponentId Property

AddNodeComponentId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ComponentId { get; set; }
public:
property int ComponentId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.DefaultColor Property

AddNodeDefaultColor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> DefaultColor { get; }
public:
property RepeatedField<float>^ DefaultColor {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.Descriptor Property

AddNodeDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.MeshId Property

AddNodeMeshId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int MeshId { get; set; }
public:
property int MeshId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.NodeBound Property

AddNodeNodeBound Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> NodeBound { get; }
public:
property RepeatedField<float>^ NodeBound {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.NodeId Property

AddNodeNodeId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int NodeId { get; set; }
public:
property int NodeId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.NodeName Property

AddNodeNodeName Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string NodeName { get; set; }
public:
property String^ NodeName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.ParentComponentId Property

AddNodeParentComponentId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ParentComponentId { get; set; }
public:
property int ParentComponentId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.ParentNodeId Property

AddNodeParentNodeId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ParentNodeId { get; set; }
public:
property int ParentNodeId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.Parser Property

AddNodeParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<AddNode> Parser { get; }
public:
static property MessageParser<AddNode^>^ Parser {
    MessageParser<AddNode^>^ get ();
}

Property Value

Type: MessageParserAddNode
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.Position Property

AddNodePosition Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Position { get; }
public:
property RepeatedField<float>^ Position {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.Rotation Property

AddNodeRotation Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Rotation { get; }
public:
property RepeatedField<float>^ Rotation {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.Rotation2 Property

AddNodeRotation2 Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Rotation2 { get; }
public:
property RepeatedField<float>^ Rotation2 {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.Scale Property

AddNodeScale Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Scale { get; }
public:
property RepeatedField<float>^ Scale {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.Scale2 Property

AddNodeScale2 Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Scale2 { get; }
public:
property RepeatedField<float>^ Scale2 {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode Methods

The AddNode type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddNode) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddNode) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.CalculateSize Method

AddNodeCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AddNode.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.Clone Method

AddNodeClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddNode Clone()
public:
virtual AddNode^ Clone() sealed

Return Value

Type: AddNode

[Missing <returns> documentation for "M:VisualComponents.Messages.AddNode.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.Equals Method

AddNodeEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddNode) |
Top
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.Equals Method (Object)

AddNodeEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AddNode.Equals(System.Object)"]

See Also

Reference

AddNode Class
Equals Overload
VisualComponents.Messages Namespace


AddNode.Equals Method (AddNode)

AddNodeEquals Method (AddNode)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    AddNode other
)
public:
virtual bool Equals(
    AddNode^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAddNode

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AddNode.Equals(VisualComponents.Messages.AddNode)"]

Implements

IEquatableTEquals(T)
See Also

Reference

AddNode Class
Equals Overload
VisualComponents.Messages Namespace


AddNode.GetHashCode Method

AddNodeGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AddNode.GetHashCode"]

See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.MergeFrom Method

AddNodeMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddNode) |
Top
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.MergeFrom Method (CodedInputStream)

AddNodeMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

AddNode Class
MergeFrom Overload
VisualComponents.Messages Namespace


AddNode.MergeFrom Method (AddNode)

AddNodeMergeFrom Method (AddNode)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    AddNode other
)
public:
virtual void MergeFrom(
    AddNode^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAddNode

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

AddNode Class
MergeFrom Overload
VisualComponents.Messages Namespace


AddNode.ToString Method

AddNodeToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.AddNode.ToString"]

See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.WriteTo Method

AddNodeWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode Fields

The AddNode type exposes the following members.

Fields
Name | Description
BoundVersionFieldNumber | Field number for the "bound_version" field.
ComponentIdFieldNumber | Field number for the "component_id" field.
DefaultColorFieldNumber | Field number for the "default_color" field.
MeshIdFieldNumber | Field number for the "mesh_id" field.
NodeBoundFieldNumber | Field number for the "node_bound" field.
NodeIdFieldNumber | Field number for the "node_id" field.
NodeNameFieldNumber | Field number for the "node_name" field.
ParentComponentIdFieldNumber | Field number for the "parent_component_id" field.
ParentNodeIdFieldNumber | Field number for the "parent_node_id" field.
PositionFieldNumber | Field number for the "position" field.
Rotation2FieldNumber | Field number for the "rotation_2" field.
RotationFieldNumber | Field number for the "rotation" field.
Scale2FieldNumber | Field number for the "scale_2" field.
ScaleFieldNumber | Field number for the "scale" field.
Top
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.BoundVersionFieldNumber Field

AddNodeBoundVersionFieldNumber Field

Field number for the "bound_version" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int BoundVersionFieldNumber = 14
public:
literal int BoundVersionFieldNumber = 14

Field Value

Type: Int32
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.ComponentIdFieldNumber Field

AddNodeComponentIdFieldNumber Field

Field number for the "component_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ComponentIdFieldNumber = 3
public:
literal int ComponentIdFieldNumber = 3

Field Value

Type: Int32
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.DefaultColorFieldNumber Field

AddNodeDefaultColorFieldNumber Field

Field number for the "default_color" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int DefaultColorFieldNumber = 8
public:
literal int DefaultColorFieldNumber = 8

Field Value

Type: Int32
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.MeshIdFieldNumber Field

AddNodeMeshIdFieldNumber Field

Field number for the "mesh_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int MeshIdFieldNumber = 6
public:
literal int MeshIdFieldNumber = 6

Field Value

Type: Int32
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.NodeBoundFieldNumber Field

AddNodeNodeBoundFieldNumber Field

Field number for the "node_bound" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int NodeBoundFieldNumber = 7
public:
literal int NodeBoundFieldNumber = 7

Field Value

Type: Int32
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.NodeIdFieldNumber Field

AddNodeNodeIdFieldNumber Field

Field number for the "node_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int NodeIdFieldNumber = 2
public:
literal int NodeIdFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.NodeNameFieldNumber Field

AddNodeNodeNameFieldNumber Field

Field number for the "node_name" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int NodeNameFieldNumber = 1
public:
literal int NodeNameFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.ParentComponentIdFieldNumber Field

AddNodeParentComponentIdFieldNumber Field

Field number for the "parent_component_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ParentComponentIdFieldNumber = 5
public:
literal int ParentComponentIdFieldNumber = 5

Field Value

Type: Int32
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.ParentNodeIdFieldNumber Field

AddNodeParentNodeIdFieldNumber Field

Field number for the "parent_node_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ParentNodeIdFieldNumber = 4
public:
literal int ParentNodeIdFieldNumber = 4

Field Value

Type: Int32
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.PositionFieldNumber Field

AddNodePositionFieldNumber Field

Field number for the "position" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int PositionFieldNumber = 9
public:
literal int PositionFieldNumber = 9

Field Value

Type: Int32
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.Rotation2FieldNumber Field

AddNodeRotation2FieldNumber Field

Field number for the "rotation_2" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int Rotation2FieldNumber = 12
public:
literal int Rotation2FieldNumber = 12

Field Value

Type: Int32
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.RotationFieldNumber Field

AddNodeRotationFieldNumber Field

Field number for the "rotation" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int RotationFieldNumber = 10
public:
literal int RotationFieldNumber = 10

Field Value

Type: Int32
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.Scale2FieldNumber Field

AddNodeScale2FieldNumber Field

Field number for the "scale_2" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int Scale2FieldNumber = 13
public:
literal int Scale2FieldNumber = 13

Field Value

Type: Int32
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddNode.ScaleFieldNumber Field

AddNodeScaleFieldNumber Field

Field number for the "scale" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ScaleFieldNumber = 11
public:
literal int ScaleFieldNumber = 11

Field Value

Type: Int32
See Also

Reference

AddNode Class
VisualComponents.Messages Namespace


AddShaderMaterial Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesAddShaderMaterial

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class AddShaderMaterial : IMessage<AddShaderMaterial>,
    IMessage, IEquatable<AddShaderMaterial>, IDeepCloneable<AddShaderMaterial>
public ref class AddShaderMaterial sealed : IMessage<AddShaderMaterial^>,
    IMessage, IEquatable<AddShaderMaterial^>, IDeepCloneable<AddShaderMaterial^>

The AddShaderMaterial type exposes the following members.

Constructors
 | Name | Description
Public method | AddShaderMaterial | Initializes a new instance of the AddShaderMaterial class
Public method | AddShaderMaterial(AddShaderMaterial) | Initializes a new instance of the AddShaderMaterial class
Top
Properties
 | Name | Description
Public property | Color |
 | Descriptor |
Public property | MaterialId |
Public property | MaterialName |
Public property | Metallic |
Public property | Opacity |
 | Parser |
Public property | Roughness |
Public property | TextureId |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddShaderMaterial) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddShaderMaterial) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
ColorFieldNumber | Field number for the "color" field.
MaterialIdFieldNumber | Field number for the "material_id" field.
MaterialNameFieldNumber | Field number for the "material_name" field.
MetallicFieldNumber | Field number for the "metallic" field.
OpacityFieldNumber | Field number for the "opacity" field.
RoughnessFieldNumber | Field number for the "roughness" field.
TextureIdFieldNumber | Field number for the "texture_id" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


AddShaderMaterial Constructor

Overload List
 | Name | Description
Public method | AddShaderMaterial | Initializes a new instance of the AddShaderMaterial class
Public method | AddShaderMaterial(AddShaderMaterial) | Initializes a new instance of the AddShaderMaterial class
Top
See Also

Reference

AddShaderMaterial Class
VisualComponents.Messages Namespace


AddShaderMaterial Constructor

Initializes a new instance of the AddShaderMaterial class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddShaderMaterial()
public:
AddShaderMaterial()
See Also

Reference

AddShaderMaterial Class
AddShaderMaterial Overload
VisualComponents.Messages Namespace


AddShaderMaterial Constructor (AddShaderMaterial)

Initializes a new instance of the AddShaderMaterial class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddShaderMaterial(
    AddShaderMaterial other
)
public:
AddShaderMaterial(
    AddShaderMaterial^ other
)

Parameters

other
Type: VisualComponents.MessagesAddShaderMaterial
See Also

Reference

AddShaderMaterial Class
AddShaderMaterial Overload
VisualComponents.Messages Namespace


AddShaderMaterial Properties

The AddShaderMaterial type exposes the following members.

Properties
 | Name | Description
Public property | Color |
 | Descriptor |
Public property | MaterialId |
Public property | MaterialName |
Public property | Metallic |
Public property | Opacity |
 | Parser |
Public property | Roughness |
Public property | TextureId |
Top
See Also

Reference

AddShaderMaterial Class
VisualComponents.Messages Namespace


AddShaderMaterial.Color Property

AddShaderMaterialColor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Color { get; }
public:
property RepeatedField<float>^ Color {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

AddShaderMaterial Class
VisualComponents.Messages Namespace


AddShaderMaterial.Descriptor Property

AddShaderMaterialDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

AddShaderMaterial Class
VisualComponents.Messages Namespace


AddShaderMaterial.MaterialId Property

AddShaderMaterialMaterialId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int MaterialId { get; set; }
public:
property int MaterialId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AddShaderMaterial Class
VisualComponents.Messages Namespace


AddShaderMaterial.MaterialName Property

AddShaderMaterialMaterialName Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string MaterialName { get; set; }
public:
property String^ MaterialName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

AddShaderMaterial Class
VisualComponents.Messages Namespace


AddShaderMaterial.Metallic Property

AddShaderMaterialMetallic Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float Metallic { get; set; }
public:
property float Metallic {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

AddShaderMaterial Class
VisualComponents.Messages Namespace


AddShaderMaterial.Opacity Property

AddShaderMaterialOpacity Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float Opacity { get; set; }
public:
property float Opacity {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

AddShaderMaterial Class
VisualComponents.Messages Namespace


AddShaderMaterial.Parser Property

AddShaderMaterialParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<AddShaderMaterial> Parser { get; }
public:
static property MessageParser<AddShaderMaterial^>^ Parser {
    MessageParser<AddShaderMaterial^>^ get ();
}

Property Value

Type: MessageParserAddShaderMaterial
See Also

Reference

AddShaderMaterial Class
VisualComponents.Messages Namespace


AddShaderMaterial.Roughness Property

AddShaderMaterialRoughness Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float Roughness { get; set; }
public:
property float Roughness {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

AddShaderMaterial Class
VisualComponents.Messages Namespace


AddShaderMaterial.TextureId Property

AddShaderMaterialTextureId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int TextureId { get; set; }
public:
property int TextureId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AddShaderMaterial Class
VisualComponents.Messages Namespace


AddShaderMaterial Methods

The AddShaderMaterial type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddShaderMaterial) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddShaderMaterial) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AddShaderMaterial Class
VisualComponents.Messages Namespace


AddShaderMaterial.CalculateSize Method

AddShaderMaterialCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AddShaderMaterial.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

AddShaderMaterial Class
VisualComponents.Messages Namespace


AddShaderMaterial.Clone Method

AddShaderMaterialClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddShaderMaterial Clone()
public:
virtual AddShaderMaterial^ Clone() sealed

Return Value

Type: AddShaderMaterial

[Missing <returns> documentation for "M:VisualComponents.Messages.AddShaderMaterial.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

AddShaderMaterial Class
VisualComponents.Messages Namespace


AddShaderMaterial.Equals Method

AddShaderMaterialEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddShaderMaterial) |
Top
See Also

Reference

AddShaderMaterial Class
VisualComponents.Messages Namespace


AddShaderMaterial.Equals Method (Object)

AddShaderMaterialEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AddShaderMaterial.Equals(System.Object)"]

See Also

Reference

AddShaderMaterial Class
Equals Overload
VisualComponents.Messages Namespace


AddShaderMaterial.Equals Method (AddShaderMaterial)

AddShaderMaterialEquals Method (AddShaderMaterial)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    AddShaderMaterial other
)
public:
virtual bool Equals(
    AddShaderMaterial^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAddShaderMaterial

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AddShaderMaterial.Equals(VisualComponents.Messages.AddShaderMaterial)"]

Implements

IEquatableTEquals(T)
See Also

Reference

AddShaderMaterial Class
Equals Overload
VisualComponents.Messages Namespace


AddShaderMaterial.GetHashCode Method

AddShaderMaterialGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AddShaderMaterial.GetHashCode"]

See Also

Reference

AddShaderMaterial Class
VisualComponents.Messages Namespace


AddShaderMaterial.MergeFrom Method

AddShaderMaterialMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddShaderMaterial) |
Top
See Also

Reference

AddShaderMaterial Class
VisualComponents.Messages Namespace


AddShaderMaterial.MergeFrom Method (CodedInputStream)

AddShaderMaterialMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

AddShaderMaterial Class
MergeFrom Overload
VisualComponents.Messages Namespace


AddShaderMaterial.MergeFrom Method (AddShaderMaterial)

AddShaderMaterialMergeFrom Method (AddShaderMaterial)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    AddShaderMaterial other
)
public:
virtual void MergeFrom(
    AddShaderMaterial^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAddShaderMaterial

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

AddShaderMaterial Class
MergeFrom Overload
VisualComponents.Messages Namespace


AddShaderMaterial.ToString Method

AddShaderMaterialToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.AddShaderMaterial.ToString"]

See Also

Reference

AddShaderMaterial Class
VisualComponents.Messages Namespace


AddShaderMaterial.WriteTo Method

AddShaderMaterialWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

AddShaderMaterial Class
VisualComponents.Messages Namespace


AddShaderMaterial Fields

The AddShaderMaterial type exposes the following members.

Fields
Name | Description
ColorFieldNumber | Field number for the "color" field.
MaterialIdFieldNumber | Field number for the "material_id" field.
MaterialNameFieldNumber | Field number for the "material_name" field.
MetallicFieldNumber | Field number for the "metallic" field.
OpacityFieldNumber | Field number for the "opacity" field.
RoughnessFieldNumber | Field number for the "roughness" field.
TextureIdFieldNumber | Field number for the "texture_id" field.
Top
See Also

Reference

AddShaderMaterial Class
VisualComponents.Messages Namespace


AddShaderMaterial.ColorFieldNumber Field

AddShaderMaterialColorFieldNumber Field

Field number for the "color" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ColorFieldNumber = 4
public:
literal int ColorFieldNumber = 4

Field Value

Type: Int32
See Also

Reference

AddShaderMaterial Class
VisualComponents.Messages Namespace


AddShaderMaterial.MaterialIdFieldNumber Field

AddShaderMaterialMaterialIdFieldNumber Field

Field number for the "material_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int MaterialIdFieldNumber = 1
public:
literal int MaterialIdFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

AddShaderMaterial Class
VisualComponents.Messages Namespace


AddShaderMaterial.MaterialNameFieldNumber Field

AddShaderMaterialMaterialNameFieldNumber Field

Field number for the "material_name" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int MaterialNameFieldNumber = 2
public:
literal int MaterialNameFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

AddShaderMaterial Class
VisualComponents.Messages Namespace


AddShaderMaterial.MetallicFieldNumber Field

AddShaderMaterialMetallicFieldNumber Field

Field number for the "metallic" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int MetallicFieldNumber = 6
public:
literal int MetallicFieldNumber = 6

Field Value

Type: Int32
See Also

Reference

AddShaderMaterial Class
VisualComponents.Messages Namespace


AddShaderMaterial.OpacityFieldNumber Field

AddShaderMaterialOpacityFieldNumber Field

Field number for the "opacity" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int OpacityFieldNumber = 7
public:
literal int OpacityFieldNumber = 7

Field Value

Type: Int32
See Also

Reference

AddShaderMaterial Class
VisualComponents.Messages Namespace


AddShaderMaterial.RoughnessFieldNumber Field

AddShaderMaterialRoughnessFieldNumber Field

Field number for the "roughness" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int RoughnessFieldNumber = 5
public:
literal int RoughnessFieldNumber = 5

Field Value

Type: Int32
See Also

Reference

AddShaderMaterial Class
VisualComponents.Messages Namespace


AddShaderMaterial.TextureIdFieldNumber Field

AddShaderMaterialTextureIdFieldNumber Field

Field number for the "texture_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int TextureIdFieldNumber = 3
public:
literal int TextureIdFieldNumber = 3

Field Value

Type: Int32
See Also

Reference

AddShaderMaterial Class
VisualComponents.Messages Namespace


AddSubLine Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesAddSubLine

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class AddSubLine : IMessage<AddSubLine>,
    IMessage, IEquatable<AddSubLine>, IDeepCloneable<AddSubLine>
public ref class AddSubLine sealed : IMessage<AddSubLine^>,
    IMessage, IEquatable<AddSubLine^>, IDeepCloneable<AddSubLine^>

The AddSubLine type exposes the following members.

Constructors
 | Name | Description
Public method | AddSubLine | Initializes a new instance of the AddSubLine class
Public method | AddSubLine(AddSubLine) | Initializes a new instance of the AddSubLine class
Top
Properties
 | Name | Description
 | Descriptor |
Public property | LineColor |
Public property | MaterialId |
 | Parser |
Public property | Vertices |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddSubLine) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddSubLine) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
LineColorFieldNumber | Field number for the "line_color" field.
MaterialIdFieldNumber | Field number for the "material_id" field.
VerticesFieldNumber | Field number for the "vertices" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


AddSubLine Constructor

Overload List
 | Name | Description
Public method | AddSubLine | Initializes a new instance of the AddSubLine class
Public method | AddSubLine(AddSubLine) | Initializes a new instance of the AddSubLine class
Top
See Also

Reference

AddSubLine Class
VisualComponents.Messages Namespace


AddSubLine Constructor

Initializes a new instance of the AddSubLine class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddSubLine()
public:
AddSubLine()
See Also

Reference

AddSubLine Class
AddSubLine Overload
VisualComponents.Messages Namespace


AddSubLine Constructor (AddSubLine)

Initializes a new instance of the AddSubLine class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddSubLine(
    AddSubLine other
)
public:
AddSubLine(
    AddSubLine^ other
)

Parameters

other
Type: VisualComponents.MessagesAddSubLine
See Also

Reference

AddSubLine Class
AddSubLine Overload
VisualComponents.Messages Namespace


AddSubLine Properties

The AddSubLine type exposes the following members.

Properties
 | Name | Description
 | Descriptor |
Public property | LineColor |
Public property | MaterialId |
 | Parser |
Public property | Vertices |
Top
See Also

Reference

AddSubLine Class
VisualComponents.Messages Namespace


AddSubLine.Descriptor Property

AddSubLineDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

AddSubLine Class
VisualComponents.Messages Namespace


AddSubLine.LineColor Property

AddSubLineLineColor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> LineColor { get; }
public:
property RepeatedField<float>^ LineColor {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

AddSubLine Class
VisualComponents.Messages Namespace


AddSubLine.MaterialId Property

AddSubLineMaterialId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int MaterialId { get; set; }
public:
property int MaterialId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AddSubLine Class
VisualComponents.Messages Namespace


AddSubLine.Parser Property

AddSubLineParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<AddSubLine> Parser { get; }
public:
static property MessageParser<AddSubLine^>^ Parser {
    MessageParser<AddSubLine^>^ get ();
}

Property Value

Type: MessageParserAddSubLine
See Also

Reference

AddSubLine Class
VisualComponents.Messages Namespace


AddSubLine.Vertices Property

AddSubLineVertices Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Vertices { get; }
public:
property RepeatedField<float>^ Vertices {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

AddSubLine Class
VisualComponents.Messages Namespace


AddSubLine Methods

The AddSubLine type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddSubLine) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddSubLine) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AddSubLine Class
VisualComponents.Messages Namespace


AddSubLine.CalculateSize Method

AddSubLineCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSubLine.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

AddSubLine Class
VisualComponents.Messages Namespace


AddSubLine.Clone Method

AddSubLineClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddSubLine Clone()
public:
virtual AddSubLine^ Clone() sealed

Return Value

Type: AddSubLine

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSubLine.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

AddSubLine Class
VisualComponents.Messages Namespace


AddSubLine.Equals Method

AddSubLineEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddSubLine) |
Top
See Also

Reference

AddSubLine Class
VisualComponents.Messages Namespace


AddSubLine.Equals Method (Object)

AddSubLineEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSubLine.Equals(System.Object)"]

See Also

Reference

AddSubLine Class
Equals Overload
VisualComponents.Messages Namespace


AddSubLine.Equals Method (AddSubLine)

AddSubLineEquals Method (AddSubLine)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    AddSubLine other
)
public:
virtual bool Equals(
    AddSubLine^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAddSubLine

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSubLine.Equals(VisualComponents.Messages.AddSubLine)"]

Implements

IEquatableTEquals(T)
See Also

Reference

AddSubLine Class
Equals Overload
VisualComponents.Messages Namespace


AddSubLine.GetHashCode Method

AddSubLineGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSubLine.GetHashCode"]

See Also

Reference

AddSubLine Class
VisualComponents.Messages Namespace


AddSubLine.MergeFrom Method

AddSubLineMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddSubLine) |
Top
See Also

Reference

AddSubLine Class
VisualComponents.Messages Namespace


AddSubLine.MergeFrom Method (CodedInputStream)

AddSubLineMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

AddSubLine Class
MergeFrom Overload
VisualComponents.Messages Namespace


AddSubLine.MergeFrom Method (AddSubLine)

AddSubLineMergeFrom Method (AddSubLine)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    AddSubLine other
)
public:
virtual void MergeFrom(
    AddSubLine^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAddSubLine

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

AddSubLine Class
MergeFrom Overload
VisualComponents.Messages Namespace


AddSubLine.ToString Method

AddSubLineToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSubLine.ToString"]

See Also

Reference

AddSubLine Class
VisualComponents.Messages Namespace


AddSubLine.WriteTo Method

AddSubLineWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

AddSubLine Class
VisualComponents.Messages Namespace


AddSubLine Fields

The AddSubLine type exposes the following members.

Fields
Name | Description
LineColorFieldNumber | Field number for the "line_color" field.
MaterialIdFieldNumber | Field number for the "material_id" field.
VerticesFieldNumber | Field number for the "vertices" field.
Top
See Also

Reference

AddSubLine Class
VisualComponents.Messages Namespace


AddSubLine.LineColorFieldNumber Field

AddSubLineLineColorFieldNumber Field

Field number for the "line_color" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int LineColorFieldNumber = 3
public:
literal int LineColorFieldNumber = 3

Field Value

Type: Int32
See Also

Reference

AddSubLine Class
VisualComponents.Messages Namespace


AddSubLine.MaterialIdFieldNumber Field

AddSubLineMaterialIdFieldNumber Field

Field number for the "material_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int MaterialIdFieldNumber = 2
public:
literal int MaterialIdFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

AddSubLine Class
VisualComponents.Messages Namespace


AddSubLine.VerticesFieldNumber Field

AddSubLineVerticesFieldNumber Field

Field number for the "vertices" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int VerticesFieldNumber = 1
public:
literal int VerticesFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

AddSubLine Class
VisualComponents.Messages Namespace


AddSubMesh Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesAddSubMesh

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class AddSubMesh : IMessage<AddSubMesh>,
    IMessage, IEquatable<AddSubMesh>, IDeepCloneable<AddSubMesh>
public ref class AddSubMesh sealed : IMessage<AddSubMesh^>,
    IMessage, IEquatable<AddSubMesh^>, IDeepCloneable<AddSubMesh^>

The AddSubMesh type exposes the following members.

Constructors
 | Name | Description
Public method | AddSubMesh | Initializes a new instance of the AddSubMesh class
Public method | AddSubMesh(AddSubMesh) | Initializes a new instance of the AddSubMesh class
Top
Properties
 | Name | Description
Public property | DefaultColor |
 | Descriptor |
Public property | MaterialId |
 | Parser |
Public property | Triangles |
Public property | UCoordinates |
Public property | UseBackface |
Public property | VCoordinates |
Public property | Vertices |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddSubMesh) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddSubMesh) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
DefaultColorFieldNumber | Field number for the "default_color" field.
MaterialIdFieldNumber | Field number for the "material_id" field.
TrianglesFieldNumber | Field number for the "triangles" field.
UCoordinatesFieldNumber | Field number for the "u_coordinates" field.
UseBackfaceFieldNumber | Field number for the "use_backface" field.
VCoordinatesFieldNumber | Field number for the "v_coordinates" field.
VerticesFieldNumber | Field number for the "vertices" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


AddSubMesh Constructor

Overload List
 | Name | Description
Public method | AddSubMesh | Initializes a new instance of the AddSubMesh class
Public method | AddSubMesh(AddSubMesh) | Initializes a new instance of the AddSubMesh class
Top
See Also

Reference

AddSubMesh Class
VisualComponents.Messages Namespace


AddSubMesh Constructor

Initializes a new instance of the AddSubMesh class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddSubMesh()
public:
AddSubMesh()
See Also

Reference

AddSubMesh Class
AddSubMesh Overload
VisualComponents.Messages Namespace


AddSubMesh Constructor (AddSubMesh)

Initializes a new instance of the AddSubMesh class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddSubMesh(
    AddSubMesh other
)
public:
AddSubMesh(
    AddSubMesh^ other
)

Parameters

other
Type: VisualComponents.MessagesAddSubMesh
See Also

Reference

AddSubMesh Class
AddSubMesh Overload
VisualComponents.Messages Namespace


AddSubMesh Properties

The AddSubMesh type exposes the following members.

Properties
 | Name | Description
Public property | DefaultColor |
 | Descriptor |
Public property | MaterialId |
 | Parser |
Public property | Triangles |
Public property | UCoordinates |
Public property | UseBackface |
Public property | VCoordinates |
Public property | Vertices |
Top
See Also

Reference

AddSubMesh Class
VisualComponents.Messages Namespace


AddSubMesh.DefaultColor Property

AddSubMeshDefaultColor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> DefaultColor { get; }
public:
property RepeatedField<float>^ DefaultColor {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

AddSubMesh Class
VisualComponents.Messages Namespace


AddSubMesh.Descriptor Property

AddSubMeshDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

AddSubMesh Class
VisualComponents.Messages Namespace


AddSubMesh.MaterialId Property

AddSubMeshMaterialId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int MaterialId { get; set; }
public:
property int MaterialId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AddSubMesh Class
VisualComponents.Messages Namespace


AddSubMesh.Parser Property

AddSubMeshParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<AddSubMesh> Parser { get; }
public:
static property MessageParser<AddSubMesh^>^ Parser {
    MessageParser<AddSubMesh^>^ get ();
}

Property Value

Type: MessageParserAddSubMesh
See Also

Reference

AddSubMesh Class
VisualComponents.Messages Namespace


AddSubMesh.Triangles Property

AddSubMeshTriangles Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<int> Triangles { get; }
public:
property RepeatedField<int>^ Triangles {
    RepeatedField<int>^ get ();
}

Property Value

Type: RepeatedFieldInt32
See Also

Reference

AddSubMesh Class
VisualComponents.Messages Namespace


AddSubMesh.UCoordinates Property

AddSubMeshUCoordinates Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> UCoordinates { get; }
public:
property RepeatedField<float>^ UCoordinates {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

AddSubMesh Class
VisualComponents.Messages Namespace


AddSubMesh.UseBackface Property

AddSubMeshUseBackface Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool UseBackface { get; set; }
public:
property bool UseBackface {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AddSubMesh Class
VisualComponents.Messages Namespace


AddSubMesh.VCoordinates Property

AddSubMeshVCoordinates Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> VCoordinates { get; }
public:
property RepeatedField<float>^ VCoordinates {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

AddSubMesh Class
VisualComponents.Messages Namespace


AddSubMesh.Vertices Property

AddSubMeshVertices Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Vertices { get; }
public:
property RepeatedField<float>^ Vertices {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

AddSubMesh Class
VisualComponents.Messages Namespace


AddSubMesh Methods

The AddSubMesh type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddSubMesh) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddSubMesh) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AddSubMesh Class
VisualComponents.Messages Namespace


AddSubMesh.CalculateSize Method

AddSubMeshCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSubMesh.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

AddSubMesh Class
VisualComponents.Messages Namespace


AddSubMesh.Clone Method

AddSubMeshClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddSubMesh Clone()
public:
virtual AddSubMesh^ Clone() sealed

Return Value

Type: AddSubMesh

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSubMesh.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

AddSubMesh Class
VisualComponents.Messages Namespace


AddSubMesh.Equals Method

AddSubMeshEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddSubMesh) |
Top
See Also

Reference

AddSubMesh Class
VisualComponents.Messages Namespace


AddSubMesh.Equals Method (Object)

AddSubMeshEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSubMesh.Equals(System.Object)"]

See Also

Reference

AddSubMesh Class
Equals Overload
VisualComponents.Messages Namespace


AddSubMesh.Equals Method (AddSubMesh)

AddSubMeshEquals Method (AddSubMesh)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    AddSubMesh other
)
public:
virtual bool Equals(
    AddSubMesh^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAddSubMesh

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSubMesh.Equals(VisualComponents.Messages.AddSubMesh)"]

Implements

IEquatableTEquals(T)
See Also

Reference

AddSubMesh Class
Equals Overload
VisualComponents.Messages Namespace


AddSubMesh.GetHashCode Method

AddSubMeshGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSubMesh.GetHashCode"]

See Also

Reference

AddSubMesh Class
VisualComponents.Messages Namespace


AddSubMesh.MergeFrom Method

AddSubMeshMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddSubMesh) |
Top
See Also

Reference

AddSubMesh Class
VisualComponents.Messages Namespace


AddSubMesh.MergeFrom Method (CodedInputStream)

AddSubMeshMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

AddSubMesh Class
MergeFrom Overload
VisualComponents.Messages Namespace


AddSubMesh.MergeFrom Method (AddSubMesh)

AddSubMeshMergeFrom Method (AddSubMesh)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    AddSubMesh other
)
public:
virtual void MergeFrom(
    AddSubMesh^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAddSubMesh

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

AddSubMesh Class
MergeFrom Overload
VisualComponents.Messages Namespace


AddSubMesh.ToString Method

AddSubMeshToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSubMesh.ToString"]

See Also

Reference

AddSubMesh Class
VisualComponents.Messages Namespace


AddSubMesh.WriteTo Method

AddSubMeshWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

AddSubMesh Class
VisualComponents.Messages Namespace


AddSubMesh Fields

The AddSubMesh type exposes the following members.

Fields
Name | Description
DefaultColorFieldNumber | Field number for the "default_color" field.
MaterialIdFieldNumber | Field number for the "material_id" field.
TrianglesFieldNumber | Field number for the "triangles" field.
UCoordinatesFieldNumber | Field number for the "u_coordinates" field.
UseBackfaceFieldNumber | Field number for the "use_backface" field.
VCoordinatesFieldNumber | Field number for the "v_coordinates" field.
VerticesFieldNumber | Field number for the "vertices" field.
Top
See Also

Reference

AddSubMesh Class
VisualComponents.Messages Namespace


AddSubMesh.DefaultColorFieldNumber Field

AddSubMeshDefaultColorFieldNumber Field

Field number for the "default_color" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int DefaultColorFieldNumber = 2
public:
literal int DefaultColorFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

AddSubMesh Class
VisualComponents.Messages Namespace


AddSubMesh.MaterialIdFieldNumber Field

AddSubMeshMaterialIdFieldNumber Field

Field number for the "material_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int MaterialIdFieldNumber = 1
public:
literal int MaterialIdFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

AddSubMesh Class
VisualComponents.Messages Namespace


AddSubMesh.TrianglesFieldNumber Field

AddSubMeshTrianglesFieldNumber Field

Field number for the "triangles" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int TrianglesFieldNumber = 4
public:
literal int TrianglesFieldNumber = 4

Field Value

Type: Int32
See Also

Reference

AddSubMesh Class
VisualComponents.Messages Namespace


AddSubMesh.UCoordinatesFieldNumber Field

AddSubMeshUCoordinatesFieldNumber Field

Field number for the "u_coordinates" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int UCoordinatesFieldNumber = 5
public:
literal int UCoordinatesFieldNumber = 5

Field Value

Type: Int32
See Also

Reference

AddSubMesh Class
VisualComponents.Messages Namespace


AddSubMesh.UseBackfaceFieldNumber Field

AddSubMeshUseBackfaceFieldNumber Field

Field number for the "use_backface" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int UseBackfaceFieldNumber = 7
public:
literal int UseBackfaceFieldNumber = 7

Field Value

Type: Int32
See Also

Reference

AddSubMesh Class
VisualComponents.Messages Namespace


AddSubMesh.VCoordinatesFieldNumber Field

AddSubMeshVCoordinatesFieldNumber Field

Field number for the "v_coordinates" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int VCoordinatesFieldNumber = 6
public:
literal int VCoordinatesFieldNumber = 6

Field Value

Type: Int32
See Also

Reference

AddSubMesh Class
VisualComponents.Messages Namespace


AddSubMesh.VerticesFieldNumber Field

AddSubMeshVerticesFieldNumber Field

Field number for the "vertices" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int VerticesFieldNumber = 3
public:
literal int VerticesFieldNumber = 3

Field Value

Type: Int32
See Also

Reference

AddSubMesh Class
VisualComponents.Messages Namespace


AddSubMeshTopology Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesAddSubMeshTopology

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class AddSubMeshTopology : IMessage<AddSubMeshTopology>,
    IMessage, IEquatable<AddSubMeshTopology>, IDeepCloneable<AddSubMeshTopology>
public ref class AddSubMeshTopology sealed : IMessage<AddSubMeshTopology^>,
    IMessage, IEquatable<AddSubMeshTopology^>, IDeepCloneable<AddSubMeshTopology^>

The AddSubMeshTopology type exposes the following members.

Constructors
 | Name | Description
Public method | AddSubMeshTopology | Initializes a new instance of the AddSubMeshTopology class
Public method | AddSubMeshTopology(AddSubMeshTopology) | Initializes a new instance of the AddSubMeshTopology class
Top
Properties
 | Name | Description
 | Descriptor |
Public property | FaceCount |
Public property | FaceCurveloopCounts |
Public property | FaceCurveloopCurveCounts |
Public property | FaceTriangleCounts |
 | Parser |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddSubMeshTopology) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddSubMeshTopology) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
FaceCountFieldNumber | Field number for the "face_count" field.
FaceCurveloopCountsFieldNumber | Field number for the "face_curveloop_counts" field.
FaceCurveloopCurveCountsFieldNumber | Field number for the "face_curveloop_curve_counts" field.
FaceTriangleCountsFieldNumber | Field number for the "face_triangle_counts" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


AddSubMeshTopology Constructor

Overload List
 | Name | Description
Public method | AddSubMeshTopology | Initializes a new instance of the AddSubMeshTopology class
Public method | AddSubMeshTopology(AddSubMeshTopology) | Initializes a new instance of the AddSubMeshTopology class
Top
See Also

Reference

AddSubMeshTopology Class
VisualComponents.Messages Namespace


AddSubMeshTopology Constructor

Initializes a new instance of the AddSubMeshTopology class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddSubMeshTopology()
public:
AddSubMeshTopology()
See Also

Reference

AddSubMeshTopology Class
AddSubMeshTopology Overload
VisualComponents.Messages Namespace


AddSubMeshTopology Constructor (AddSubMeshTopology)

Initializes a new instance of the AddSubMeshTopology class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddSubMeshTopology(
    AddSubMeshTopology other
)
public:
AddSubMeshTopology(
    AddSubMeshTopology^ other
)

Parameters

other
Type: VisualComponents.MessagesAddSubMeshTopology
See Also

Reference

AddSubMeshTopology Class
AddSubMeshTopology Overload
VisualComponents.Messages Namespace


AddSubMeshTopology Properties

The AddSubMeshTopology type exposes the following members.

Properties
 | Name | Description
 | Descriptor |
Public property | FaceCount |
Public property | FaceCurveloopCounts |
Public property | FaceCurveloopCurveCounts |
Public property | FaceTriangleCounts |
 | Parser |
Top
See Also

Reference

AddSubMeshTopology Class
VisualComponents.Messages Namespace


AddSubMeshTopology.Descriptor Property

AddSubMeshTopologyDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

AddSubMeshTopology Class
VisualComponents.Messages Namespace


AddSubMeshTopology.FaceCount Property

AddSubMeshTopologyFaceCount Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int FaceCount { get; set; }
public:
property int FaceCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AddSubMeshTopology Class
VisualComponents.Messages Namespace


AddSubMeshTopology.FaceCurveloopCounts Property

AddSubMeshTopologyFaceCurveloopCounts Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<int> FaceCurveloopCounts { get; }
public:
property RepeatedField<int>^ FaceCurveloopCounts {
    RepeatedField<int>^ get ();
}

Property Value

Type: RepeatedFieldInt32
See Also

Reference

AddSubMeshTopology Class
VisualComponents.Messages Namespace


AddSubMeshTopology.FaceCurveloopCurveCounts Property

AddSubMeshTopologyFaceCurveloopCurveCounts Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<int> FaceCurveloopCurveCounts { get; }
public:
property RepeatedField<int>^ FaceCurveloopCurveCounts {
    RepeatedField<int>^ get ();
}

Property Value

Type: RepeatedFieldInt32
See Also

Reference

AddSubMeshTopology Class
VisualComponents.Messages Namespace


AddSubMeshTopology.FaceTriangleCounts Property

AddSubMeshTopologyFaceTriangleCounts Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<int> FaceTriangleCounts { get; }
public:
property RepeatedField<int>^ FaceTriangleCounts {
    RepeatedField<int>^ get ();
}

Property Value

Type: RepeatedFieldInt32
See Also

Reference

AddSubMeshTopology Class
VisualComponents.Messages Namespace


AddSubMeshTopology.Parser Property

AddSubMeshTopologyParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<AddSubMeshTopology> Parser { get; }
public:
static property MessageParser<AddSubMeshTopology^>^ Parser {
    MessageParser<AddSubMeshTopology^>^ get ();
}

Property Value

Type: MessageParserAddSubMeshTopology
See Also

Reference

AddSubMeshTopology Class
VisualComponents.Messages Namespace


AddSubMeshTopology Methods

The AddSubMeshTopology type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddSubMeshTopology) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddSubMeshTopology) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AddSubMeshTopology Class
VisualComponents.Messages Namespace


AddSubMeshTopology.CalculateSize Method

AddSubMeshTopologyCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSubMeshTopology.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

AddSubMeshTopology Class
VisualComponents.Messages Namespace


AddSubMeshTopology.Clone Method

AddSubMeshTopologyClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddSubMeshTopology Clone()
public:
virtual AddSubMeshTopology^ Clone() sealed

Return Value

Type: AddSubMeshTopology

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSubMeshTopology.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

AddSubMeshTopology Class
VisualComponents.Messages Namespace


AddSubMeshTopology.Equals Method

AddSubMeshTopologyEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddSubMeshTopology) |
Top
See Also

Reference

AddSubMeshTopology Class
VisualComponents.Messages Namespace


AddSubMeshTopology.Equals Method (Object)

AddSubMeshTopologyEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSubMeshTopology.Equals(System.Object)"]

See Also

Reference

AddSubMeshTopology Class
Equals Overload
VisualComponents.Messages Namespace


AddSubMeshTopology.Equals Method (AddSubMeshTopology)

AddSubMeshTopologyEquals Method (AddSubMeshTopology)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    AddSubMeshTopology other
)
public:
virtual bool Equals(
    AddSubMeshTopology^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAddSubMeshTopology

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSubMeshTopology.Equals(VisualComponents.Messages.AddSubMeshTopology)"]

Implements

IEquatableTEquals(T)
See Also

Reference

AddSubMeshTopology Class
Equals Overload
VisualComponents.Messages Namespace


AddSubMeshTopology.GetHashCode Method

AddSubMeshTopologyGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSubMeshTopology.GetHashCode"]

See Also

Reference

AddSubMeshTopology Class
VisualComponents.Messages Namespace


AddSubMeshTopology.MergeFrom Method

AddSubMeshTopologyMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddSubMeshTopology) |
Top
See Also

Reference

AddSubMeshTopology Class
VisualComponents.Messages Namespace


AddSubMeshTopology.MergeFrom Method (CodedInputStream)

AddSubMeshTopologyMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

AddSubMeshTopology Class
MergeFrom Overload
VisualComponents.Messages Namespace


AddSubMeshTopology.MergeFrom Method (AddSubMeshTopology)

AddSubMeshTopologyMergeFrom Method (AddSubMeshTopology)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    AddSubMeshTopology other
)
public:
virtual void MergeFrom(
    AddSubMeshTopology^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAddSubMeshTopology

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

AddSubMeshTopology Class
MergeFrom Overload
VisualComponents.Messages Namespace


AddSubMeshTopology.ToString Method

AddSubMeshTopologyToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSubMeshTopology.ToString"]

See Also

Reference

AddSubMeshTopology Class
VisualComponents.Messages Namespace


AddSubMeshTopology.WriteTo Method

AddSubMeshTopologyWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

AddSubMeshTopology Class
VisualComponents.Messages Namespace


AddSubMeshTopology Fields

The AddSubMeshTopology type exposes the following members.

Fields
Name | Description
FaceCountFieldNumber | Field number for the "face_count" field.
FaceCurveloopCountsFieldNumber | Field number for the "face_curveloop_counts" field.
FaceCurveloopCurveCountsFieldNumber | Field number for the "face_curveloop_curve_counts" field.
FaceTriangleCountsFieldNumber | Field number for the "face_triangle_counts" field.
Top
See Also

Reference

AddSubMeshTopology Class
VisualComponents.Messages Namespace


AddSubMeshTopology.FaceCountFieldNumber Field

AddSubMeshTopologyFaceCountFieldNumber Field

Field number for the "face_count" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int FaceCountFieldNumber = 3
public:
literal int FaceCountFieldNumber = 3

Field Value

Type: Int32
See Also

Reference

AddSubMeshTopology Class
VisualComponents.Messages Namespace


AddSubMeshTopology.FaceCurveloopCountsFieldNumber Field

AddSubMeshTopologyFaceCurveloopCountsFieldNumber Field

Field number for the "face_curveloop_counts" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int FaceCurveloopCountsFieldNumber = 5
public:
literal int FaceCurveloopCountsFieldNumber = 5

Field Value

Type: Int32
See Also

Reference

AddSubMeshTopology Class
VisualComponents.Messages Namespace


AddSubMeshTopology.FaceCurveloopCurveCountsFieldNumber Field

AddSubMeshTopologyFaceCurveloopCurveCountsFieldNumber Field

Field number for the "face_curveloop_curve_counts" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int FaceCurveloopCurveCountsFieldNumber = 6
public:
literal int FaceCurveloopCurveCountsFieldNumber = 6

Field Value

Type: Int32
See Also

Reference

AddSubMeshTopology Class
VisualComponents.Messages Namespace


AddSubMeshTopology.FaceTriangleCountsFieldNumber Field

AddSubMeshTopologyFaceTriangleCountsFieldNumber Field

Field number for the "face_triangle_counts" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int FaceTriangleCountsFieldNumber = 4
public:
literal int FaceTriangleCountsFieldNumber = 4

Field Value

Type: Int32
See Also

Reference

AddSubMeshTopology Class
VisualComponents.Messages Namespace


AddSubMeshTopologyCurve Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesAddSubMeshTopologyCurve

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class AddSubMeshTopologyCurve : IMessage<AddSubMeshTopologyCurve>,
    IMessage, IEquatable<AddSubMeshTopologyCurve>, IDeepCloneable<AddSubMeshTopologyCurve>
public ref class AddSubMeshTopologyCurve sealed : IMessage<AddSubMeshTopologyCurve^>,
    IMessage, IEquatable<AddSubMeshTopologyCurve^>, IDeepCloneable<AddSubMeshTopologyCurve^>

The AddSubMeshTopologyCurve type exposes the following members.

Constructors
 | Name | Description
Public method | AddSubMeshTopologyCurve | Initializes a new instance of the AddSubMeshTopologyCurve class
Public method | AddSubMeshTopologyCurve(AddSubMeshTopologyCurve) | Initializes a new instance of the AddSubMeshTopologyCurve class
Top
Properties
 | Name | Description
Public property | CurveIndex |
Public property | CurveloopIndex |
Public property | CurvePointIndices |
 | Descriptor |
 | Parser |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddSubMeshTopologyCurve) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddSubMeshTopologyCurve) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
CurveIndexFieldNumber | Field number for the "curve_index" field.
CurveloopIndexFieldNumber | Field number for the "curveloop_index" field.
CurvePointIndicesFieldNumber | Field number for the "curve_point_indices" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


AddSubMeshTopologyCurve Constructor

Overload List
 | Name | Description
Public method | AddSubMeshTopologyCurve | Initializes a new instance of the AddSubMeshTopologyCurve class
Public method | AddSubMeshTopologyCurve(AddSubMeshTopologyCurve) | Initializes a new instance of the AddSubMeshTopologyCurve class
Top
See Also

Reference

AddSubMeshTopologyCurve Class
VisualComponents.Messages Namespace


AddSubMeshTopologyCurve Constructor

Initializes a new instance of the AddSubMeshTopologyCurve class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddSubMeshTopologyCurve()
public:
AddSubMeshTopologyCurve()
See Also

Reference

AddSubMeshTopologyCurve Class
AddSubMeshTopologyCurve Overload
VisualComponents.Messages Namespace


AddSubMeshTopologyCurve Constructor (AddSubMeshTopologyCurve)

Initializes a new instance of the AddSubMeshTopologyCurve class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddSubMeshTopologyCurve(
    AddSubMeshTopologyCurve other
)
public:
AddSubMeshTopologyCurve(
    AddSubMeshTopologyCurve^ other
)

Parameters

other
Type: VisualComponents.MessagesAddSubMeshTopologyCurve
See Also

Reference

AddSubMeshTopologyCurve Class
AddSubMeshTopologyCurve Overload
VisualComponents.Messages Namespace


AddSubMeshTopologyCurve Properties

The AddSubMeshTopologyCurve type exposes the following members.

Properties
 | Name | Description
Public property | CurveIndex |
Public property | CurveloopIndex |
Public property | CurvePointIndices |
 | Descriptor |
 | Parser |
Top
See Also

Reference

AddSubMeshTopologyCurve Class
VisualComponents.Messages Namespace


AddSubMeshTopologyCurve.CurveIndex Property

AddSubMeshTopologyCurveCurveIndex Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CurveIndex { get; set; }
public:
property int CurveIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AddSubMeshTopologyCurve Class
VisualComponents.Messages Namespace


AddSubMeshTopologyCurve.CurveloopIndex Property

AddSubMeshTopologyCurveCurveloopIndex Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CurveloopIndex { get; set; }
public:
property int CurveloopIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AddSubMeshTopologyCurve Class
VisualComponents.Messages Namespace


AddSubMeshTopologyCurve.CurvePointIndices Property

AddSubMeshTopologyCurveCurvePointIndices Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<int> CurvePointIndices { get; }
public:
property RepeatedField<int>^ CurvePointIndices {
    RepeatedField<int>^ get ();
}

Property Value

Type: RepeatedFieldInt32
See Also

Reference

AddSubMeshTopologyCurve Class
VisualComponents.Messages Namespace


AddSubMeshTopologyCurve.Descriptor Property

AddSubMeshTopologyCurveDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

AddSubMeshTopologyCurve Class
VisualComponents.Messages Namespace


AddSubMeshTopologyCurve.Parser Property

AddSubMeshTopologyCurveParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<AddSubMeshTopologyCurve> Parser { get; }
public:
static property MessageParser<AddSubMeshTopologyCurve^>^ Parser {
    MessageParser<AddSubMeshTopologyCurve^>^ get ();
}

Property Value

Type: MessageParserAddSubMeshTopologyCurve
See Also

Reference

AddSubMeshTopologyCurve Class
VisualComponents.Messages Namespace


AddSubMeshTopologyCurve Methods

The AddSubMeshTopologyCurve type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddSubMeshTopologyCurve) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddSubMeshTopologyCurve) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AddSubMeshTopologyCurve Class
VisualComponents.Messages Namespace


AddSubMeshTopologyCurve.CalculateSize Method

AddSubMeshTopologyCurveCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSubMeshTopologyCurve.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

AddSubMeshTopologyCurve Class
VisualComponents.Messages Namespace


AddSubMeshTopologyCurve.Clone Method

AddSubMeshTopologyCurveClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddSubMeshTopologyCurve Clone()
public:
virtual AddSubMeshTopologyCurve^ Clone() sealed

Return Value

Type: AddSubMeshTopologyCurve

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSubMeshTopologyCurve.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

AddSubMeshTopologyCurve Class
VisualComponents.Messages Namespace


AddSubMeshTopologyCurve.Equals Method

AddSubMeshTopologyCurveEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddSubMeshTopologyCurve) |
Top
See Also

Reference

AddSubMeshTopologyCurve Class
VisualComponents.Messages Namespace


AddSubMeshTopologyCurve.Equals Method (Object)

AddSubMeshTopologyCurveEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSubMeshTopologyCurve.Equals(System.Object)"]

See Also

Reference

AddSubMeshTopologyCurve Class
Equals Overload
VisualComponents.Messages Namespace


AddSubMeshTopologyCurve.Equals Method (AddSubMeshTopologyCurve)

AddSubMeshTopologyCurveEquals Method (AddSubMeshTopologyCurve)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    AddSubMeshTopologyCurve other
)
public:
virtual bool Equals(
    AddSubMeshTopologyCurve^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAddSubMeshTopologyCurve

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSubMeshTopologyCurve.Equals(VisualComponents.Messages.AddSubMeshTopologyCurve)"]

Implements

IEquatableTEquals(T)
See Also

Reference

AddSubMeshTopologyCurve Class
Equals Overload
VisualComponents.Messages Namespace


AddSubMeshTopologyCurve.GetHashCode Method

AddSubMeshTopologyCurveGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSubMeshTopologyCurve.GetHashCode"]

See Also

Reference

AddSubMeshTopologyCurve Class
VisualComponents.Messages Namespace


AddSubMeshTopologyCurve.MergeFrom Method

AddSubMeshTopologyCurveMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddSubMeshTopologyCurve) |
Top
See Also

Reference

AddSubMeshTopologyCurve Class
VisualComponents.Messages Namespace


AddSubMeshTopologyCurve.MergeFrom Method (CodedInputStream)

AddSubMeshTopologyCurveMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

AddSubMeshTopologyCurve Class
MergeFrom Overload
VisualComponents.Messages Namespace


AddSubMeshTopologyCurve.MergeFrom Method (AddSubMeshTopologyCurve)

AddSubMeshTopologyCurveMergeFrom Method (AddSubMeshTopologyCurve)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    AddSubMeshTopologyCurve other
)
public:
virtual void MergeFrom(
    AddSubMeshTopologyCurve^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAddSubMeshTopologyCurve

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

AddSubMeshTopologyCurve Class
MergeFrom Overload
VisualComponents.Messages Namespace


AddSubMeshTopologyCurve.ToString Method

AddSubMeshTopologyCurveToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSubMeshTopologyCurve.ToString"]

See Also

Reference

AddSubMeshTopologyCurve Class
VisualComponents.Messages Namespace


AddSubMeshTopologyCurve.WriteTo Method

AddSubMeshTopologyCurveWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

AddSubMeshTopologyCurve Class
VisualComponents.Messages Namespace


AddSubMeshTopologyCurve Fields

The AddSubMeshTopologyCurve type exposes the following members.

Fields
Name | Description
CurveIndexFieldNumber | Field number for the "curve_index" field.
CurveloopIndexFieldNumber | Field number for the "curveloop_index" field.
CurvePointIndicesFieldNumber | Field number for the "curve_point_indices" field.
Top
See Also

Reference

AddSubMeshTopologyCurve Class
VisualComponents.Messages Namespace


AddSubMeshTopologyCurve.CurveIndexFieldNumber Field

AddSubMeshTopologyCurveCurveIndexFieldNumber Field

Field number for the "curve_index" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int CurveIndexFieldNumber = 2
public:
literal int CurveIndexFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

AddSubMeshTopologyCurve Class
VisualComponents.Messages Namespace


AddSubMeshTopologyCurve.CurveloopIndexFieldNumber Field

AddSubMeshTopologyCurveCurveloopIndexFieldNumber Field

Field number for the "curveloop_index" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int CurveloopIndexFieldNumber = 1
public:
literal int CurveloopIndexFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

AddSubMeshTopologyCurve Class
VisualComponents.Messages Namespace


AddSubMeshTopologyCurve.CurvePointIndicesFieldNumber Field

AddSubMeshTopologyCurveCurvePointIndicesFieldNumber Field

Field number for the "curve_point_indices" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int CurvePointIndicesFieldNumber = 3
public:
literal int CurvePointIndicesFieldNumber = 3

Field Value

Type: Int32
See Also

Reference

AddSubMeshTopologyCurve Class
VisualComponents.Messages Namespace


AddSync Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesAddSync

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class AddSync : IMessage<AddSync>,
    IMessage, IEquatable<AddSync>, IDeepCloneable<AddSync>
public ref class AddSync sealed : IMessage<AddSync^>,
    IMessage, IEquatable<AddSync^>, IDeepCloneable<AddSync^>

The AddSync type exposes the following members.

Constructors
 | Name | Description
Public method | AddSync | Initializes a new instance of the AddSync class
Public method | AddSync(AddSync) | Initializes a new instance of the AddSync class
Top
Properties
 | Name | Description
 | Descriptor |
 | Parser |
Public property | RealTime |
Public property | SimTime |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddSync) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddSync) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
RealTimeFieldNumber | Field number for the "real_time" field.
SimTimeFieldNumber | Field number for the "sim_time" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


AddSync Constructor

Overload List
 | Name | Description
Public method | AddSync | Initializes a new instance of the AddSync class
Public method | AddSync(AddSync) | Initializes a new instance of the AddSync class
Top
See Also

Reference

AddSync Class
VisualComponents.Messages Namespace


AddSync Constructor

Initializes a new instance of the AddSync class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddSync()
public:
AddSync()
See Also

Reference

AddSync Class
AddSync Overload
VisualComponents.Messages Namespace


AddSync Constructor (AddSync)

Initializes a new instance of the AddSync class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddSync(
    AddSync other
)
public:
AddSync(
    AddSync^ other
)

Parameters

other
Type: VisualComponents.MessagesAddSync
See Also

Reference

AddSync Class
AddSync Overload
VisualComponents.Messages Namespace


AddSync Properties

The AddSync type exposes the following members.

Properties
 | Name | Description
 | Descriptor |
 | Parser |
Public property | RealTime |
Public property | SimTime |
Top
See Also

Reference

AddSync Class
VisualComponents.Messages Namespace


AddSync.Descriptor Property

AddSyncDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

AddSync Class
VisualComponents.Messages Namespace


AddSync.Parser Property

AddSyncParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<AddSync> Parser { get; }
public:
static property MessageParser<AddSync^>^ Parser {
    MessageParser<AddSync^>^ get ();
}

Property Value

Type: MessageParserAddSync
See Also

Reference

AddSync Class
VisualComponents.Messages Namespace


AddSync.RealTime Property

AddSyncRealTime Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float RealTime { get; set; }
public:
property float RealTime {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

AddSync Class
VisualComponents.Messages Namespace


AddSync.SimTime Property

AddSyncSimTime Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float SimTime { get; set; }
public:
property float SimTime {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

AddSync Class
VisualComponents.Messages Namespace


AddSync Methods

The AddSync type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddSync) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddSync) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AddSync Class
VisualComponents.Messages Namespace


AddSync.CalculateSize Method

AddSyncCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSync.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

AddSync Class
VisualComponents.Messages Namespace


AddSync.Clone Method

AddSyncClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddSync Clone()
public:
virtual AddSync^ Clone() sealed

Return Value

Type: AddSync

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSync.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

AddSync Class
VisualComponents.Messages Namespace


AddSync.Equals Method

AddSyncEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddSync) |
Top
See Also

Reference

AddSync Class
VisualComponents.Messages Namespace


AddSync.Equals Method (Object)

AddSyncEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSync.Equals(System.Object)"]

See Also

Reference

AddSync Class
Equals Overload
VisualComponents.Messages Namespace


AddSync.Equals Method (AddSync)

AddSyncEquals Method (AddSync)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    AddSync other
)
public:
virtual bool Equals(
    AddSync^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAddSync

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSync.Equals(VisualComponents.Messages.AddSync)"]

Implements

IEquatableTEquals(T)
See Also

Reference

AddSync Class
Equals Overload
VisualComponents.Messages Namespace


AddSync.GetHashCode Method

AddSyncGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSync.GetHashCode"]

See Also

Reference

AddSync Class
VisualComponents.Messages Namespace


AddSync.MergeFrom Method

AddSyncMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddSync) |
Top
See Also

Reference

AddSync Class
VisualComponents.Messages Namespace


AddSync.MergeFrom Method (CodedInputStream)

AddSyncMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

AddSync Class
MergeFrom Overload
VisualComponents.Messages Namespace


AddSync.MergeFrom Method (AddSync)

AddSyncMergeFrom Method (AddSync)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    AddSync other
)
public:
virtual void MergeFrom(
    AddSync^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAddSync

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

AddSync Class
MergeFrom Overload
VisualComponents.Messages Namespace


AddSync.ToString Method

AddSyncToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.AddSync.ToString"]

See Also

Reference

AddSync Class
VisualComponents.Messages Namespace


AddSync.WriteTo Method

AddSyncWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

AddSync Class
VisualComponents.Messages Namespace


AddSync Fields

The AddSync type exposes the following members.

Fields
Name | Description
RealTimeFieldNumber | Field number for the "real_time" field.
SimTimeFieldNumber | Field number for the "sim_time" field.
Top
See Also

Reference

AddSync Class
VisualComponents.Messages Namespace


AddSync.RealTimeFieldNumber Field

AddSyncRealTimeFieldNumber Field

Field number for the "real_time" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int RealTimeFieldNumber = 2
public:
literal int RealTimeFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

AddSync Class
VisualComponents.Messages Namespace


AddSync.SimTimeFieldNumber Field

AddSyncSimTimeFieldNumber Field

Field number for the "sim_time" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int SimTimeFieldNumber = 1
public:
literal int SimTimeFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

AddSync Class
VisualComponents.Messages Namespace


AddTexture Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesAddTexture

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class AddTexture : IMessage<AddTexture>,
    IMessage, IEquatable<AddTexture>, IDeepCloneable<AddTexture>
public ref class AddTexture sealed : IMessage<AddTexture^>,
    IMessage, IEquatable<AddTexture^>, IDeepCloneable<AddTexture^>

The AddTexture type exposes the following members.

Constructors
 | Name | Description
Public method | AddTexture | Initializes a new instance of the AddTexture class
Public method | AddTexture(AddTexture) | Initializes a new instance of the AddTexture class
Top
Properties
 | Name | Description
 | Descriptor |
 | Parser |
Public property | TextureData |
Public property | TextureId |
Public property | TextureName |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddTexture) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddTexture) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
TextureDataFieldNumber | Field number for the "texture_data" field.
TextureIdFieldNumber | Field number for the "texture_id" field.
TextureNameFieldNumber | Field number for the "texture_name" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


AddTexture Constructor

Overload List
 | Name | Description
Public method | AddTexture | Initializes a new instance of the AddTexture class
Public method | AddTexture(AddTexture) | Initializes a new instance of the AddTexture class
Top
See Also

Reference

AddTexture Class
VisualComponents.Messages Namespace


AddTexture Constructor

Initializes a new instance of the AddTexture class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddTexture()
public:
AddTexture()
See Also

Reference

AddTexture Class
AddTexture Overload
VisualComponents.Messages Namespace


AddTexture Constructor (AddTexture)

Initializes a new instance of the AddTexture class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddTexture(
    AddTexture other
)
public:
AddTexture(
    AddTexture^ other
)

Parameters

other
Type: VisualComponents.MessagesAddTexture
See Also

Reference

AddTexture Class
AddTexture Overload
VisualComponents.Messages Namespace


AddTexture Properties

The AddTexture type exposes the following members.

Properties
 | Name | Description
 | Descriptor |
 | Parser |
Public property | TextureData |
Public property | TextureId |
Public property | TextureName |
Top
See Also

Reference

AddTexture Class
VisualComponents.Messages Namespace


AddTexture.Descriptor Property

AddTextureDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

AddTexture Class
VisualComponents.Messages Namespace


AddTexture.Parser Property

AddTextureParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<AddTexture> Parser { get; }
public:
static property MessageParser<AddTexture^>^ Parser {
    MessageParser<AddTexture^>^ get ();
}

Property Value

Type: MessageParserAddTexture
See Also

Reference

AddTexture Class
VisualComponents.Messages Namespace


AddTexture.TextureData Property

AddTextureTextureData Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ByteString TextureData { get; set; }
public:
property ByteString^ TextureData {
    ByteString^ get ();
    void set (ByteString^ value);
}

Property Value

Type: ByteString
See Also

Reference

AddTexture Class
VisualComponents.Messages Namespace


AddTexture.TextureId Property

AddTextureTextureId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int TextureId { get; set; }
public:
property int TextureId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AddTexture Class
VisualComponents.Messages Namespace


AddTexture.TextureName Property

AddTextureTextureName Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string TextureName { get; set; }
public:
property String^ TextureName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

AddTexture Class
VisualComponents.Messages Namespace


AddTexture Methods

The AddTexture type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddTexture) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddTexture) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AddTexture Class
VisualComponents.Messages Namespace


AddTexture.CalculateSize Method

AddTextureCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AddTexture.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

AddTexture Class
VisualComponents.Messages Namespace


AddTexture.Clone Method

AddTextureClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddTexture Clone()
public:
virtual AddTexture^ Clone() sealed

Return Value

Type: AddTexture

[Missing <returns> documentation for "M:VisualComponents.Messages.AddTexture.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

AddTexture Class
VisualComponents.Messages Namespace


AddTexture.Equals Method

AddTextureEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddTexture) |
Top
See Also

Reference

AddTexture Class
VisualComponents.Messages Namespace


AddTexture.Equals Method (Object)

AddTextureEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AddTexture.Equals(System.Object)"]

See Also

Reference

AddTexture Class
Equals Overload
VisualComponents.Messages Namespace


AddTexture.Equals Method (AddTexture)

AddTextureEquals Method (AddTexture)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    AddTexture other
)
public:
virtual bool Equals(
    AddTexture^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAddTexture

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AddTexture.Equals(VisualComponents.Messages.AddTexture)"]

Implements

IEquatableTEquals(T)
See Also

Reference

AddTexture Class
Equals Overload
VisualComponents.Messages Namespace


AddTexture.GetHashCode Method

AddTextureGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AddTexture.GetHashCode"]

See Also

Reference

AddTexture Class
VisualComponents.Messages Namespace


AddTexture.MergeFrom Method

AddTextureMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddTexture) |
Top
See Also

Reference

AddTexture Class
VisualComponents.Messages Namespace


AddTexture.MergeFrom Method (CodedInputStream)

AddTextureMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

AddTexture Class
MergeFrom Overload
VisualComponents.Messages Namespace


AddTexture.MergeFrom Method (AddTexture)

AddTextureMergeFrom Method (AddTexture)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    AddTexture other
)
public:
virtual void MergeFrom(
    AddTexture^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAddTexture

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

AddTexture Class
MergeFrom Overload
VisualComponents.Messages Namespace


AddTexture.ToString Method

AddTextureToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.AddTexture.ToString"]

See Also

Reference

AddTexture Class
VisualComponents.Messages Namespace


AddTexture.WriteTo Method

AddTextureWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

AddTexture Class
VisualComponents.Messages Namespace


AddTexture Fields

The AddTexture type exposes the following members.

Fields
Name | Description
TextureDataFieldNumber | Field number for the "texture_data" field.
TextureIdFieldNumber | Field number for the "texture_id" field.
TextureNameFieldNumber | Field number for the "texture_name" field.
Top
See Also

Reference

AddTexture Class
VisualComponents.Messages Namespace


AddTexture.TextureDataFieldNumber Field

AddTextureTextureDataFieldNumber Field

Field number for the "texture_data" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int TextureDataFieldNumber = 3
public:
literal int TextureDataFieldNumber = 3

Field Value

Type: Int32
See Also

Reference

AddTexture Class
VisualComponents.Messages Namespace


AddTexture.TextureIdFieldNumber Field

AddTextureTextureIdFieldNumber Field

Field number for the "texture_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int TextureIdFieldNumber = 1
public:
literal int TextureIdFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

AddTexture Class
VisualComponents.Messages Namespace


AddTexture.TextureNameFieldNumber Field

AddTextureTextureNameFieldNumber Field

Field number for the "texture_name" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int TextureNameFieldNumber = 2
public:
literal int TextureNameFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

AddTexture Class
VisualComponents.Messages Namespace


AddTimeStep Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesAddTimeStep

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class AddTimeStep : IMessage<AddTimeStep>,
    IMessage, IEquatable<AddTimeStep>, IDeepCloneable<AddTimeStep>
public ref class AddTimeStep sealed : IMessage<AddTimeStep^>,
    IMessage, IEquatable<AddTimeStep^>, IDeepCloneable<AddTimeStep^>

The AddTimeStep type exposes the following members.

Constructors
 | Name | Description
Public method | AddTimeStep | Initializes a new instance of the AddTimeStep class
Public method | AddTimeStep(AddTimeStep) | Initializes a new instance of the AddTimeStep class
Top
Properties
 | Name | Description
 | Descriptor |
Public property | IsSimStep |
 | Parser |
Public property | RealTime |
Public property | RealTimeInt |
Public property | Time |
Public property | TimeStep |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddTimeStep) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddTimeStep) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
IsSimStepFieldNumber | Field number for the "is_sim_step" field.
RealTimeFieldNumber | Field number for the "real_time" field.
RealTimeIntFieldNumber | Field number for the "real_time_int" field.
TimeFieldNumber | Field number for the "time" field.
TimeStepFieldNumber | Field number for the "time_step" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


AddTimeStep Constructor

Overload List
 | Name | Description
Public method | AddTimeStep | Initializes a new instance of the AddTimeStep class
Public method | AddTimeStep(AddTimeStep) | Initializes a new instance of the AddTimeStep class
Top
See Also

Reference

AddTimeStep Class
VisualComponents.Messages Namespace


AddTimeStep Constructor

Initializes a new instance of the AddTimeStep class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddTimeStep()
public:
AddTimeStep()
See Also

Reference

AddTimeStep Class
AddTimeStep Overload
VisualComponents.Messages Namespace


AddTimeStep Constructor (AddTimeStep)

Initializes a new instance of the AddTimeStep class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddTimeStep(
    AddTimeStep other
)
public:
AddTimeStep(
    AddTimeStep^ other
)

Parameters

other
Type: VisualComponents.MessagesAddTimeStep
See Also

Reference

AddTimeStep Class
AddTimeStep Overload
VisualComponents.Messages Namespace


AddTimeStep Properties

The AddTimeStep type exposes the following members.

Properties
 | Name | Description
 | Descriptor |
Public property | IsSimStep |
 | Parser |
Public property | RealTime |
Public property | RealTimeInt |
Public property | Time |
Public property | TimeStep |
Top
See Also

Reference

AddTimeStep Class
VisualComponents.Messages Namespace


AddTimeStep.Descriptor Property

AddTimeStepDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

AddTimeStep Class
VisualComponents.Messages Namespace


AddTimeStep.IsSimStep Property

AddTimeStepIsSimStep Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsSimStep { get; set; }
public:
property bool IsSimStep {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AddTimeStep Class
VisualComponents.Messages Namespace


AddTimeStep.Parser Property

AddTimeStepParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<AddTimeStep> Parser { get; }
public:
static property MessageParser<AddTimeStep^>^ Parser {
    MessageParser<AddTimeStep^>^ get ();
}

Property Value

Type: MessageParserAddTimeStep
See Also

Reference

AddTimeStep Class
VisualComponents.Messages Namespace


AddTimeStep.RealTime Property

AddTimeStepRealTime Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float RealTime { get; set; }
public:
property float RealTime {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

AddTimeStep Class
VisualComponents.Messages Namespace


AddTimeStep.RealTimeInt Property

AddTimeStepRealTimeInt Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int RealTimeInt { get; set; }
public:
property int RealTimeInt {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AddTimeStep Class
VisualComponents.Messages Namespace


AddTimeStep.Time Property

AddTimeStepTime Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float Time { get; set; }
public:
property float Time {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

AddTimeStep Class
VisualComponents.Messages Namespace


AddTimeStep.TimeStep Property

AddTimeStepTimeStep Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float TimeStep { get; set; }
public:
property float TimeStep {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

AddTimeStep Class
VisualComponents.Messages Namespace


AddTimeStep Methods

The AddTimeStep type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddTimeStep) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddTimeStep) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AddTimeStep Class
VisualComponents.Messages Namespace


AddTimeStep.CalculateSize Method

AddTimeStepCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AddTimeStep.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

AddTimeStep Class
VisualComponents.Messages Namespace


AddTimeStep.Clone Method

AddTimeStepClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddTimeStep Clone()
public:
virtual AddTimeStep^ Clone() sealed

Return Value

Type: AddTimeStep

[Missing <returns> documentation for "M:VisualComponents.Messages.AddTimeStep.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

AddTimeStep Class
VisualComponents.Messages Namespace


AddTimeStep.Equals Method

AddTimeStepEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddTimeStep) |
Top
See Also

Reference

AddTimeStep Class
VisualComponents.Messages Namespace


AddTimeStep.Equals Method (Object)

AddTimeStepEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AddTimeStep.Equals(System.Object)"]

See Also

Reference

AddTimeStep Class
Equals Overload
VisualComponents.Messages Namespace


AddTimeStep.Equals Method (AddTimeStep)

AddTimeStepEquals Method (AddTimeStep)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    AddTimeStep other
)
public:
virtual bool Equals(
    AddTimeStep^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAddTimeStep

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AddTimeStep.Equals(VisualComponents.Messages.AddTimeStep)"]

Implements

IEquatableTEquals(T)
See Also

Reference

AddTimeStep Class
Equals Overload
VisualComponents.Messages Namespace


AddTimeStep.GetHashCode Method

AddTimeStepGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AddTimeStep.GetHashCode"]

See Also

Reference

AddTimeStep Class
VisualComponents.Messages Namespace


AddTimeStep.MergeFrom Method

AddTimeStepMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddTimeStep) |
Top
See Also

Reference

AddTimeStep Class
VisualComponents.Messages Namespace


AddTimeStep.MergeFrom Method (CodedInputStream)

AddTimeStepMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

AddTimeStep Class
MergeFrom Overload
VisualComponents.Messages Namespace


AddTimeStep.MergeFrom Method (AddTimeStep)

AddTimeStepMergeFrom Method (AddTimeStep)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    AddTimeStep other
)
public:
virtual void MergeFrom(
    AddTimeStep^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAddTimeStep

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

AddTimeStep Class
MergeFrom Overload
VisualComponents.Messages Namespace


AddTimeStep.ToString Method

AddTimeStepToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.AddTimeStep.ToString"]

See Also

Reference

AddTimeStep Class
VisualComponents.Messages Namespace


AddTimeStep.WriteTo Method

AddTimeStepWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

AddTimeStep Class
VisualComponents.Messages Namespace


AddTimeStep Fields

The AddTimeStep type exposes the following members.

Fields
Name | Description
IsSimStepFieldNumber | Field number for the "is_sim_step" field.
RealTimeFieldNumber | Field number for the "real_time" field.
RealTimeIntFieldNumber | Field number for the "real_time_int" field.
TimeFieldNumber | Field number for the "time" field.
TimeStepFieldNumber | Field number for the "time_step" field.
Top
See Also

Reference

AddTimeStep Class
VisualComponents.Messages Namespace


AddTimeStep.IsSimStepFieldNumber Field

AddTimeStepIsSimStepFieldNumber Field

Field number for the "is_sim_step" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int IsSimStepFieldNumber = 5
public:
literal int IsSimStepFieldNumber = 5

Field Value

Type: Int32
See Also

Reference

AddTimeStep Class
VisualComponents.Messages Namespace


AddTimeStep.RealTimeFieldNumber Field

AddTimeStepRealTimeFieldNumber Field

Field number for the "real_time" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int RealTimeFieldNumber = 3
public:
literal int RealTimeFieldNumber = 3

Field Value

Type: Int32
See Also

Reference

AddTimeStep Class
VisualComponents.Messages Namespace


AddTimeStep.RealTimeIntFieldNumber Field

AddTimeStepRealTimeIntFieldNumber Field

Field number for the "real_time_int" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int RealTimeIntFieldNumber = 4
public:
literal int RealTimeIntFieldNumber = 4

Field Value

Type: Int32
See Also

Reference

AddTimeStep Class
VisualComponents.Messages Namespace


AddTimeStep.TimeFieldNumber Field

AddTimeStepTimeFieldNumber Field

Field number for the "time" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int TimeFieldNumber = 1
public:
literal int TimeFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

AddTimeStep Class
VisualComponents.Messages Namespace


AddTimeStep.TimeStepFieldNumber Field

AddTimeStepTimeStepFieldNumber Field

Field number for the "time_step" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int TimeStepFieldNumber = 2
public:
literal int TimeStepFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

AddTimeStep Class
VisualComponents.Messages Namespace


AddView Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesAddView

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class AddView : IMessage<AddView>,
    IMessage, IEquatable<AddView>, IDeepCloneable<AddView>
public ref class AddView sealed : IMessage<AddView^>,
    IMessage, IEquatable<AddView^>, IDeepCloneable<AddView^>

The AddView type exposes the following members.

Constructors
 | Name | Description
Public method | AddView | Initializes a new instance of the AddView class
Public method | AddView(AddView) | Initializes a new instance of the AddView class
Top
Properties
 | Name | Description
 | Descriptor |
Public property | Fov |
 | Parser |
Public property | Position |
Public property | Rotation |
Public property | ViewName |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddView) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddView) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
FovFieldNumber | Field number for the "fov" field.
PositionFieldNumber | Field number for the "position" field.
RotationFieldNumber | Field number for the "rotation" field.
ViewNameFieldNumber | Field number for the "view_name" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


AddView Constructor

Overload List
 | Name | Description
Public method | AddView | Initializes a new instance of the AddView class
Public method | AddView(AddView) | Initializes a new instance of the AddView class
Top
See Also

Reference

AddView Class
VisualComponents.Messages Namespace


AddView Constructor

Initializes a new instance of the AddView class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddView()
public:
AddView()
See Also

Reference

AddView Class
AddView Overload
VisualComponents.Messages Namespace


AddView Constructor (AddView)

Initializes a new instance of the AddView class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddView(
    AddView other
)
public:
AddView(
    AddView^ other
)

Parameters

other
Type: VisualComponents.MessagesAddView
See Also

Reference

AddView Class
AddView Overload
VisualComponents.Messages Namespace


AddView Properties

The AddView type exposes the following members.

Properties
 | Name | Description
 | Descriptor |
Public property | Fov |
 | Parser |
Public property | Position |
Public property | Rotation |
Public property | ViewName |
Top
See Also

Reference

AddView Class
VisualComponents.Messages Namespace


AddView.Descriptor Property

AddViewDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

AddView Class
VisualComponents.Messages Namespace


AddView.Fov Property

AddViewFov Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float Fov { get; set; }
public:
property float Fov {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

AddView Class
VisualComponents.Messages Namespace


AddView.Parser Property

AddViewParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<AddView> Parser { get; }
public:
static property MessageParser<AddView^>^ Parser {
    MessageParser<AddView^>^ get ();
}

Property Value

Type: MessageParserAddView
See Also

Reference

AddView Class
VisualComponents.Messages Namespace


AddView.Position Property

AddViewPosition Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Position { get; }
public:
property RepeatedField<float>^ Position {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

AddView Class
VisualComponents.Messages Namespace


AddView.Rotation Property

AddViewRotation Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Rotation { get; }
public:
property RepeatedField<float>^ Rotation {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

AddView Class
VisualComponents.Messages Namespace


AddView.ViewName Property

AddViewViewName Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ViewName { get; set; }
public:
property String^ ViewName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

AddView Class
VisualComponents.Messages Namespace


AddView Methods

The AddView type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddView) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddView) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AddView Class
VisualComponents.Messages Namespace


AddView.CalculateSize Method

AddViewCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AddView.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

AddView Class
VisualComponents.Messages Namespace


AddView.Clone Method

AddViewClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddView Clone()
public:
virtual AddView^ Clone() sealed

Return Value

Type: AddView

[Missing <returns> documentation for "M:VisualComponents.Messages.AddView.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

AddView Class
VisualComponents.Messages Namespace


AddView.Equals Method

AddViewEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(AddView) |
Top
See Also

Reference

AddView Class
VisualComponents.Messages Namespace


AddView.Equals Method (Object)

AddViewEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AddView.Equals(System.Object)"]

See Also

Reference

AddView Class
Equals Overload
VisualComponents.Messages Namespace


AddView.Equals Method (AddView)

AddViewEquals Method (AddView)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    AddView other
)
public:
virtual bool Equals(
    AddView^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAddView

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.AddView.Equals(VisualComponents.Messages.AddView)"]

Implements

IEquatableTEquals(T)
See Also

Reference

AddView Class
Equals Overload
VisualComponents.Messages Namespace


AddView.GetHashCode Method

AddViewGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.AddView.GetHashCode"]

See Also

Reference

AddView Class
VisualComponents.Messages Namespace


AddView.MergeFrom Method

AddViewMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(AddView) |
Top
See Also

Reference

AddView Class
VisualComponents.Messages Namespace


AddView.MergeFrom Method (CodedInputStream)

AddViewMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

AddView Class
MergeFrom Overload
VisualComponents.Messages Namespace


AddView.MergeFrom Method (AddView)

AddViewMergeFrom Method (AddView)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    AddView other
)
public:
virtual void MergeFrom(
    AddView^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesAddView

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

AddView Class
MergeFrom Overload
VisualComponents.Messages Namespace


AddView.ToString Method

AddViewToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.AddView.ToString"]

See Also

Reference

AddView Class
VisualComponents.Messages Namespace


AddView.WriteTo Method

AddViewWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

AddView Class
VisualComponents.Messages Namespace


AddView Fields

The AddView type exposes the following members.

Fields
Name | Description
FovFieldNumber | Field number for the "fov" field.
PositionFieldNumber | Field number for the "position" field.
RotationFieldNumber | Field number for the "rotation" field.
ViewNameFieldNumber | Field number for the "view_name" field.
Top
See Also

Reference

AddView Class
VisualComponents.Messages Namespace


AddView.FovFieldNumber Field

AddViewFovFieldNumber Field

Field number for the "fov" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int FovFieldNumber = 4
public:
literal int FovFieldNumber = 4

Field Value

Type: Int32
See Also

Reference

AddView Class
VisualComponents.Messages Namespace


AddView.PositionFieldNumber Field

AddViewPositionFieldNumber Field

Field number for the "position" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int PositionFieldNumber = 2
public:
literal int PositionFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

AddView Class
VisualComponents.Messages Namespace


AddView.RotationFieldNumber Field

AddViewRotationFieldNumber Field

Field number for the "rotation" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int RotationFieldNumber = 3
public:
literal int RotationFieldNumber = 3

Field Value

Type: Int32
See Also

Reference

AddView Class
VisualComponents.Messages Namespace


AddView.ViewNameFieldNumber Field

AddViewViewNameFieldNumber Field

Field number for the "view_name" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ViewNameFieldNumber = 1
public:
literal int ViewNameFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

AddView Class
VisualComponents.Messages Namespace


ChangeMeshKey Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesChangeMeshKey

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ChangeMeshKey : IMessage<ChangeMeshKey>,
    IMessage, IEquatable<ChangeMeshKey>, IDeepCloneable<ChangeMeshKey>
public ref class ChangeMeshKey sealed : IMessage<ChangeMeshKey^>,
    IMessage, IEquatable<ChangeMeshKey^>, IDeepCloneable<ChangeMeshKey^>

The ChangeMeshKey type exposes the following members.

Constructors
 | Name | Description
Public method | ChangeMeshKey | Initializes a new instance of the ChangeMeshKey class
Public method | ChangeMeshKey(ChangeMeshKey) | Initializes a new instance of the ChangeMeshKey class
Top
Properties
 | Name | Description
Public property | ComponentId |
 | Descriptor |
Public property | MeshId |
Public property | NodeId |
 | Parser |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ChangeMeshKey) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(ChangeMeshKey) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
ComponentIdFieldNumber | Field number for the "component_id" field.
MeshIdFieldNumber | Field number for the "mesh_id" field.
NodeIdFieldNumber | Field number for the "node_id" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


ChangeMeshKey Constructor

Overload List
 | Name | Description
Public method | ChangeMeshKey | Initializes a new instance of the ChangeMeshKey class
Public method | ChangeMeshKey(ChangeMeshKey) | Initializes a new instance of the ChangeMeshKey class
Top
See Also

Reference

ChangeMeshKey Class
VisualComponents.Messages Namespace


ChangeMeshKey Constructor

Initializes a new instance of the ChangeMeshKey class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ChangeMeshKey()
public:
ChangeMeshKey()
See Also

Reference

ChangeMeshKey Class
ChangeMeshKey Overload
VisualComponents.Messages Namespace


ChangeMeshKey Constructor (ChangeMeshKey)

Initializes a new instance of the ChangeMeshKey class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ChangeMeshKey(
    ChangeMeshKey other
)
public:
ChangeMeshKey(
    ChangeMeshKey^ other
)

Parameters

other
Type: VisualComponents.MessagesChangeMeshKey
See Also

Reference

ChangeMeshKey Class
ChangeMeshKey Overload
VisualComponents.Messages Namespace


ChangeMeshKey Properties

The ChangeMeshKey type exposes the following members.

Properties
 | Name | Description
Public property | ComponentId |
 | Descriptor |
Public property | MeshId |
Public property | NodeId |
 | Parser |
Top
See Also

Reference

ChangeMeshKey Class
VisualComponents.Messages Namespace


ChangeMeshKey.ComponentId Property

ChangeMeshKeyComponentId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ComponentId { get; set; }
public:
property int ComponentId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ChangeMeshKey Class
VisualComponents.Messages Namespace


ChangeMeshKey.Descriptor Property

ChangeMeshKeyDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

ChangeMeshKey Class
VisualComponents.Messages Namespace


ChangeMeshKey.MeshId Property

ChangeMeshKeyMeshId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int MeshId { get; set; }
public:
property int MeshId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ChangeMeshKey Class
VisualComponents.Messages Namespace


ChangeMeshKey.NodeId Property

ChangeMeshKeyNodeId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int NodeId { get; set; }
public:
property int NodeId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ChangeMeshKey Class
VisualComponents.Messages Namespace


ChangeMeshKey.Parser Property

ChangeMeshKeyParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<ChangeMeshKey> Parser { get; }
public:
static property MessageParser<ChangeMeshKey^>^ Parser {
    MessageParser<ChangeMeshKey^>^ get ();
}

Property Value

Type: MessageParserChangeMeshKey
See Also

Reference

ChangeMeshKey Class
VisualComponents.Messages Namespace


ChangeMeshKey Methods

The ChangeMeshKey type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ChangeMeshKey) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(ChangeMeshKey) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ChangeMeshKey Class
VisualComponents.Messages Namespace


ChangeMeshKey.CalculateSize Method

ChangeMeshKeyCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.ChangeMeshKey.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

ChangeMeshKey Class
VisualComponents.Messages Namespace


ChangeMeshKey.Clone Method

ChangeMeshKeyClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ChangeMeshKey Clone()
public:
virtual ChangeMeshKey^ Clone() sealed

Return Value

Type: ChangeMeshKey

[Missing <returns> documentation for "M:VisualComponents.Messages.ChangeMeshKey.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

ChangeMeshKey Class
VisualComponents.Messages Namespace


ChangeMeshKey.Equals Method

ChangeMeshKeyEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ChangeMeshKey) |
Top
See Also

Reference

ChangeMeshKey Class
VisualComponents.Messages Namespace


ChangeMeshKey.Equals Method (Object)

ChangeMeshKeyEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.ChangeMeshKey.Equals(System.Object)"]

See Also

Reference

ChangeMeshKey Class
Equals Overload
VisualComponents.Messages Namespace


ChangeMeshKey.Equals Method (ChangeMeshKey)

ChangeMeshKeyEquals Method (ChangeMeshKey)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    ChangeMeshKey other
)
public:
virtual bool Equals(
    ChangeMeshKey^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesChangeMeshKey

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.ChangeMeshKey.Equals(VisualComponents.Messages.ChangeMeshKey)"]

Implements

IEquatableTEquals(T)
See Also

Reference

ChangeMeshKey Class
Equals Overload
VisualComponents.Messages Namespace


ChangeMeshKey.GetHashCode Method

ChangeMeshKeyGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.ChangeMeshKey.GetHashCode"]

See Also

Reference

ChangeMeshKey Class
VisualComponents.Messages Namespace


ChangeMeshKey.MergeFrom Method

ChangeMeshKeyMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(ChangeMeshKey) |
Top
See Also

Reference

ChangeMeshKey Class
VisualComponents.Messages Namespace


ChangeMeshKey.MergeFrom Method (CodedInputStream)

ChangeMeshKeyMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

ChangeMeshKey Class
MergeFrom Overload
VisualComponents.Messages Namespace


ChangeMeshKey.MergeFrom Method (ChangeMeshKey)

ChangeMeshKeyMergeFrom Method (ChangeMeshKey)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    ChangeMeshKey other
)
public:
virtual void MergeFrom(
    ChangeMeshKey^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesChangeMeshKey

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

ChangeMeshKey Class
MergeFrom Overload
VisualComponents.Messages Namespace


ChangeMeshKey.ToString Method

ChangeMeshKeyToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.ChangeMeshKey.ToString"]

See Also

Reference

ChangeMeshKey Class
VisualComponents.Messages Namespace


ChangeMeshKey.WriteTo Method

ChangeMeshKeyWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

ChangeMeshKey Class
VisualComponents.Messages Namespace


ChangeMeshKey Fields

The ChangeMeshKey type exposes the following members.

Fields
Name | Description
ComponentIdFieldNumber | Field number for the "component_id" field.
MeshIdFieldNumber | Field number for the "mesh_id" field.
NodeIdFieldNumber | Field number for the "node_id" field.
Top
See Also

Reference

ChangeMeshKey Class
VisualComponents.Messages Namespace


ChangeMeshKey.ComponentIdFieldNumber Field

ChangeMeshKeyComponentIdFieldNumber Field

Field number for the "component_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ComponentIdFieldNumber = 1
public:
literal int ComponentIdFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

ChangeMeshKey Class
VisualComponents.Messages Namespace


ChangeMeshKey.MeshIdFieldNumber Field

ChangeMeshKeyMeshIdFieldNumber Field

Field number for the "mesh_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int MeshIdFieldNumber = 3
public:
literal int MeshIdFieldNumber = 3

Field Value

Type: Int32
See Also

Reference

ChangeMeshKey Class
VisualComponents.Messages Namespace


ChangeMeshKey.NodeIdFieldNumber Field

ChangeMeshKeyNodeIdFieldNumber Field

Field number for the "node_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int NodeIdFieldNumber = 2
public:
literal int NodeIdFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

ChangeMeshKey Class
VisualComponents.Messages Namespace


CloseStream Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesCloseStream

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class CloseStream : IMessage<CloseStream>,
    IMessage, IEquatable<CloseStream>, IDeepCloneable<CloseStream>
public ref class CloseStream sealed : IMessage<CloseStream^>,
    IMessage, IEquatable<CloseStream^>, IDeepCloneable<CloseStream^>

The CloseStream type exposes the following members.

Constructors
 | Name | Description
Public method | CloseStream | Initializes a new instance of the CloseStream class
Public method | CloseStream(CloseStream) | Initializes a new instance of the CloseStream class
Top
Properties
 | Name | Description
Public property | Condition |
 | Descriptor |
 | Parser |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(CloseStream) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(CloseStream) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
ConditionFieldNumber | Field number for the "condition" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


CloseStream Constructor

Overload List
 | Name | Description
Public method | CloseStream | Initializes a new instance of the CloseStream class
Public method | CloseStream(CloseStream) | Initializes a new instance of the CloseStream class
Top
See Also

Reference

CloseStream Class
VisualComponents.Messages Namespace


CloseStream Constructor

Initializes a new instance of the CloseStream class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CloseStream()
public:
CloseStream()
See Also

Reference

CloseStream Class
CloseStream Overload
VisualComponents.Messages Namespace


CloseStream Constructor (CloseStream)

Initializes a new instance of the CloseStream class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CloseStream(
    CloseStream other
)
public:
CloseStream(
    CloseStream^ other
)

Parameters

other
Type: VisualComponents.MessagesCloseStream
See Also

Reference

CloseStream Class
CloseStream Overload
VisualComponents.Messages Namespace


CloseStream Properties

The CloseStream type exposes the following members.

Properties
 | Name | Description
Public property | Condition |
 | Descriptor |
 | Parser |
Top
See Also

Reference

CloseStream Class
VisualComponents.Messages Namespace


CloseStream.Condition Property

CloseStreamCondition Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Condition { get; set; }
public:
property int Condition {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

CloseStream Class
VisualComponents.Messages Namespace


CloseStream.Descriptor Property

CloseStreamDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

CloseStream Class
VisualComponents.Messages Namespace


CloseStream.Parser Property

CloseStreamParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<CloseStream> Parser { get; }
public:
static property MessageParser<CloseStream^>^ Parser {
    MessageParser<CloseStream^>^ get ();
}

Property Value

Type: MessageParserCloseStream
See Also

Reference

CloseStream Class
VisualComponents.Messages Namespace


CloseStream Methods

The CloseStream type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(CloseStream) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(CloseStream) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CloseStream Class
VisualComponents.Messages Namespace


CloseStream.CalculateSize Method

CloseStreamCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.CloseStream.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

CloseStream Class
VisualComponents.Messages Namespace


CloseStream.Clone Method

CloseStreamClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CloseStream Clone()
public:
virtual CloseStream^ Clone() sealed

Return Value

Type: CloseStream

[Missing <returns> documentation for "M:VisualComponents.Messages.CloseStream.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

CloseStream Class
VisualComponents.Messages Namespace


CloseStream.Equals Method

CloseStreamEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(CloseStream) |
Top
See Also

Reference

CloseStream Class
VisualComponents.Messages Namespace


CloseStream.Equals Method (Object)

CloseStreamEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.CloseStream.Equals(System.Object)"]

See Also

Reference

CloseStream Class
Equals Overload
VisualComponents.Messages Namespace


CloseStream.Equals Method (CloseStream)

CloseStreamEquals Method (CloseStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    CloseStream other
)
public:
virtual bool Equals(
    CloseStream^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesCloseStream

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.CloseStream.Equals(VisualComponents.Messages.CloseStream)"]

Implements

IEquatableTEquals(T)
See Also

Reference

CloseStream Class
Equals Overload
VisualComponents.Messages Namespace


CloseStream.GetHashCode Method

CloseStreamGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.CloseStream.GetHashCode"]

See Also

Reference

CloseStream Class
VisualComponents.Messages Namespace


CloseStream.MergeFrom Method

CloseStreamMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(CloseStream) |
Top
See Also

Reference

CloseStream Class
VisualComponents.Messages Namespace


CloseStream.MergeFrom Method (CodedInputStream)

CloseStreamMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

CloseStream Class
MergeFrom Overload
VisualComponents.Messages Namespace


CloseStream.MergeFrom Method (CloseStream)

CloseStreamMergeFrom Method (CloseStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CloseStream other
)
public:
virtual void MergeFrom(
    CloseStream^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesCloseStream

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

CloseStream Class
MergeFrom Overload
VisualComponents.Messages Namespace


CloseStream.ToString Method

CloseStreamToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.CloseStream.ToString"]

See Also

Reference

CloseStream Class
VisualComponents.Messages Namespace


CloseStream.WriteTo Method

CloseStreamWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

CloseStream Class
VisualComponents.Messages Namespace


CloseStream Fields

The CloseStream type exposes the following members.

Fields
Name | Description
ConditionFieldNumber | Field number for the "condition" field.
Top
See Also

Reference

CloseStream Class
VisualComponents.Messages Namespace


CloseStream.ConditionFieldNumber Field

CloseStreamConditionFieldNumber Field

Field number for the "condition" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ConditionFieldNumber = 1
public:
literal int ConditionFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

CloseStream Class
VisualComponents.Messages Namespace


ConnectStream Class

----------------------------------------------------------------------------- HandShake
Inheritance Hierarchy
SystemObject
VisualComponents.MessagesConnectStream

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ConnectStream : IMessage<ConnectStream>,
    IMessage, IEquatable<ConnectStream>, IDeepCloneable<ConnectStream>
public ref class ConnectStream sealed : IMessage<ConnectStream^>,
    IMessage, IEquatable<ConnectStream^>, IDeepCloneable<ConnectStream^>

The ConnectStream type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectStream | Initializes a new instance of the ConnectStream class
Public method | ConnectStream(ConnectStream) | Initializes a new instance of the ConnectStream class
Top
Properties
 | Name | Description
Public property | ClientId |
Public property | ClientMode |
 | Descriptor |
Public property | Header1 |
Public property | Header2 |
Public property | Header3 |
 | Parser |
Public property | StreamId |
Public property | Version1 |
Public property | Version2 |
Public property | Version3 |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ConnectStream) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(ConnectStream) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
ClientIdFieldNumber | Field number for the "client_id" field.
ClientModeFieldNumber | Field number for the "client_mode" field.
Header1FieldNumber | Field number for the "header1" field.
Header2FieldNumber | Field number for the "header2" field.
Header3FieldNumber | Field number for the "header3" field.
StreamIdFieldNumber | Field number for the "stream_id" field.
Version1FieldNumber | Field number for the "version1" field.
Version2FieldNumber | Field number for the "version2" field.
Version3FieldNumber | Field number for the "version3" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


ConnectStream Constructor

Overload List
 | Name | Description
Public method | ConnectStream | Initializes a new instance of the ConnectStream class
Public method | ConnectStream(ConnectStream) | Initializes a new instance of the ConnectStream class
Top
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream Constructor

Initializes a new instance of the ConnectStream class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectStream()
public:
ConnectStream()
See Also

Reference

ConnectStream Class
ConnectStream Overload
VisualComponents.Messages Namespace


ConnectStream Constructor (ConnectStream)

Initializes a new instance of the ConnectStream class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectStream(
    ConnectStream other
)
public:
ConnectStream(
    ConnectStream^ other
)

Parameters

other
Type: VisualComponents.MessagesConnectStream
See Also

Reference

ConnectStream Class
ConnectStream Overload
VisualComponents.Messages Namespace


ConnectStream Properties

The ConnectStream type exposes the following members.

Properties
 | Name | Description
Public property | ClientId |
Public property | ClientMode |
 | Descriptor |
Public property | Header1 |
Public property | Header2 |
Public property | Header3 |
 | Parser |
Public property | StreamId |
Public property | Version1 |
Public property | Version2 |
Public property | Version3 |
Top
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream.ClientId Property

ConnectStreamClientId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint ClientId { get; set; }
public:
property unsigned int ClientId {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream.ClientMode Property

ConnectStreamClientMode Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint ClientMode { get; set; }
public:
property unsigned int ClientMode {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream.Descriptor Property

ConnectStreamDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream.Header1 Property

ConnectStreamHeader1 Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint Header1 { get; set; }
public:
property unsigned int Header1 {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream.Header2 Property

ConnectStreamHeader2 Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint Header2 { get; set; }
public:
property unsigned int Header2 {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream.Header3 Property

ConnectStreamHeader3 Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint Header3 { get; set; }
public:
property unsigned int Header3 {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream.Parser Property

ConnectStreamParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<ConnectStream> Parser { get; }
public:
static property MessageParser<ConnectStream^>^ Parser {
    MessageParser<ConnectStream^>^ get ();
}

Property Value

Type: MessageParserConnectStream
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream.StreamId Property

ConnectStreamStreamId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint StreamId { get; set; }
public:
property unsigned int StreamId {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream.Version1 Property

ConnectStreamVersion1 Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint Version1 { get; set; }
public:
property unsigned int Version1 {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream.Version2 Property

ConnectStreamVersion2 Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint Version2 { get; set; }
public:
property unsigned int Version2 {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream.Version3 Property

ConnectStreamVersion3 Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint Version3 { get; set; }
public:
property unsigned int Version3 {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream Methods

The ConnectStream type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ConnectStream) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(ConnectStream) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream.CalculateSize Method

ConnectStreamCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.ConnectStream.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream.Clone Method

ConnectStreamClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectStream Clone()
public:
virtual ConnectStream^ Clone() sealed

Return Value

Type: ConnectStream

[Missing <returns> documentation for "M:VisualComponents.Messages.ConnectStream.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream.Equals Method

ConnectStreamEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ConnectStream) |
Top
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream.Equals Method (Object)

ConnectStreamEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.ConnectStream.Equals(System.Object)"]

See Also

Reference

ConnectStream Class
Equals Overload
VisualComponents.Messages Namespace


ConnectStream.Equals Method (ConnectStream)

ConnectStreamEquals Method (ConnectStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    ConnectStream other
)
public:
virtual bool Equals(
    ConnectStream^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesConnectStream

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.ConnectStream.Equals(VisualComponents.Messages.ConnectStream)"]

Implements

IEquatableTEquals(T)
See Also

Reference

ConnectStream Class
Equals Overload
VisualComponents.Messages Namespace


ConnectStream.GetHashCode Method

ConnectStreamGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.ConnectStream.GetHashCode"]

See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream.MergeFrom Method

ConnectStreamMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(ConnectStream) |
Top
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream.MergeFrom Method (CodedInputStream)

ConnectStreamMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

ConnectStream Class
MergeFrom Overload
VisualComponents.Messages Namespace


ConnectStream.MergeFrom Method (ConnectStream)

ConnectStreamMergeFrom Method (ConnectStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    ConnectStream other
)
public:
virtual void MergeFrom(
    ConnectStream^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesConnectStream

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

ConnectStream Class
MergeFrom Overload
VisualComponents.Messages Namespace


ConnectStream.ToString Method

ConnectStreamToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.ConnectStream.ToString"]

See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream.WriteTo Method

ConnectStreamWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream Fields

The ConnectStream type exposes the following members.

Fields
Name | Description
ClientIdFieldNumber | Field number for the "client_id" field.
ClientModeFieldNumber | Field number for the "client_mode" field.
Header1FieldNumber | Field number for the "header1" field.
Header2FieldNumber | Field number for the "header2" field.
Header3FieldNumber | Field number for the "header3" field.
StreamIdFieldNumber | Field number for the "stream_id" field.
Version1FieldNumber | Field number for the "version1" field.
Version2FieldNumber | Field number for the "version2" field.
Version3FieldNumber | Field number for the "version3" field.
Top
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream.ClientIdFieldNumber Field

ConnectStreamClientIdFieldNumber Field

Field number for the "client_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ClientIdFieldNumber = 7
public:
literal int ClientIdFieldNumber = 7

Field Value

Type: Int32
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream.ClientModeFieldNumber Field

ConnectStreamClientModeFieldNumber Field

Field number for the "client_mode" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ClientModeFieldNumber = 9
public:
literal int ClientModeFieldNumber = 9

Field Value

Type: Int32
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream.Header1FieldNumber Field

ConnectStreamHeader1FieldNumber Field

Field number for the "header1" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int Header1FieldNumber = 1
public:
literal int Header1FieldNumber = 1

Field Value

Type: Int32
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream.Header2FieldNumber Field

ConnectStreamHeader2FieldNumber Field

Field number for the "header2" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int Header2FieldNumber = 2
public:
literal int Header2FieldNumber = 2

Field Value

Type: Int32
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream.Header3FieldNumber Field

ConnectStreamHeader3FieldNumber Field

Field number for the "header3" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int Header3FieldNumber = 3
public:
literal int Header3FieldNumber = 3

Field Value

Type: Int32
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream.StreamIdFieldNumber Field

ConnectStreamStreamIdFieldNumber Field

Field number for the "stream_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int StreamIdFieldNumber = 8
public:
literal int StreamIdFieldNumber = 8

Field Value

Type: Int32
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream.Version1FieldNumber Field

ConnectStreamVersion1FieldNumber Field

Field number for the "version1" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int Version1FieldNumber = 4
public:
literal int Version1FieldNumber = 4

Field Value

Type: Int32
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream.Version2FieldNumber Field

ConnectStreamVersion2FieldNumber Field

Field number for the "version2" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int Version2FieldNumber = 5
public:
literal int Version2FieldNumber = 5

Field Value

Type: Int32
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


ConnectStream.Version3FieldNumber Field

ConnectStreamVersion3FieldNumber Field

Field number for the "version3" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int Version3FieldNumber = 6
public:
literal int Version3FieldNumber = 6

Field Value

Type: Int32
See Also

Reference

ConnectStream Class
VisualComponents.Messages Namespace


DeleteComponent Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesDeleteComponent

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class DeleteComponent : IMessage<DeleteComponent>,
    IMessage, IEquatable<DeleteComponent>, IDeepCloneable<DeleteComponent>
public ref class DeleteComponent sealed : IMessage<DeleteComponent^>,
    IMessage, IEquatable<DeleteComponent^>, IDeepCloneable<DeleteComponent^>

The DeleteComponent type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteComponent | Initializes a new instance of the DeleteComponent class
Public method | DeleteComponent(DeleteComponent) | Initializes a new instance of the DeleteComponent class
Top
Properties
 | Name | Description
Public property | ComponentId |
Public property | Deleted |
 | Descriptor |
 | Parser |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(DeleteComponent) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(DeleteComponent) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
ComponentIdFieldNumber | Field number for the "component_id" field.
DeletedFieldNumber | Field number for the "deleted" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


DeleteComponent Constructor

Overload List
 | Name | Description
Public method | DeleteComponent | Initializes a new instance of the DeleteComponent class
Public method | DeleteComponent(DeleteComponent) | Initializes a new instance of the DeleteComponent class
Top
See Also

Reference

DeleteComponent Class
VisualComponents.Messages Namespace


DeleteComponent Constructor

Initializes a new instance of the DeleteComponent class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DeleteComponent()
public:
DeleteComponent()
See Also

Reference

DeleteComponent Class
DeleteComponent Overload
VisualComponents.Messages Namespace


DeleteComponent Constructor (DeleteComponent)

Initializes a new instance of the DeleteComponent class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DeleteComponent(
    DeleteComponent other
)
public:
DeleteComponent(
    DeleteComponent^ other
)

Parameters

other
Type: VisualComponents.MessagesDeleteComponent
See Also

Reference

DeleteComponent Class
DeleteComponent Overload
VisualComponents.Messages Namespace


DeleteComponent Properties

The DeleteComponent type exposes the following members.

Properties
 | Name | Description
Public property | ComponentId |
Public property | Deleted |
 | Descriptor |
 | Parser |
Top
See Also

Reference

DeleteComponent Class
VisualComponents.Messages Namespace


DeleteComponent.ComponentId Property

DeleteComponentComponentId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ComponentId { get; set; }
public:
property int ComponentId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

DeleteComponent Class
VisualComponents.Messages Namespace


DeleteComponent.Deleted Property

DeleteComponentDeleted Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Deleted { get; set; }
public:
property bool Deleted {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DeleteComponent Class
VisualComponents.Messages Namespace


DeleteComponent.Descriptor Property

DeleteComponentDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

DeleteComponent Class
VisualComponents.Messages Namespace


DeleteComponent.Parser Property

DeleteComponentParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<DeleteComponent> Parser { get; }
public:
static property MessageParser<DeleteComponent^>^ Parser {
    MessageParser<DeleteComponent^>^ get ();
}

Property Value

Type: MessageParserDeleteComponent
See Also

Reference

DeleteComponent Class
VisualComponents.Messages Namespace


DeleteComponent Methods

The DeleteComponent type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(DeleteComponent) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(DeleteComponent) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DeleteComponent Class
VisualComponents.Messages Namespace


DeleteComponent.CalculateSize Method

DeleteComponentCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.DeleteComponent.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

DeleteComponent Class
VisualComponents.Messages Namespace


DeleteComponent.Clone Method

DeleteComponentClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DeleteComponent Clone()
public:
virtual DeleteComponent^ Clone() sealed

Return Value

Type: DeleteComponent

[Missing <returns> documentation for "M:VisualComponents.Messages.DeleteComponent.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

DeleteComponent Class
VisualComponents.Messages Namespace


DeleteComponent.Equals Method

DeleteComponentEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(DeleteComponent) |
Top
See Also

Reference

DeleteComponent Class
VisualComponents.Messages Namespace


DeleteComponent.Equals Method (Object)

DeleteComponentEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.DeleteComponent.Equals(System.Object)"]

See Also

Reference

DeleteComponent Class
Equals Overload
VisualComponents.Messages Namespace


DeleteComponent.Equals Method (DeleteComponent)

DeleteComponentEquals Method (DeleteComponent)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    DeleteComponent other
)
public:
virtual bool Equals(
    DeleteComponent^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesDeleteComponent

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.DeleteComponent.Equals(VisualComponents.Messages.DeleteComponent)"]

Implements

IEquatableTEquals(T)
See Also

Reference

DeleteComponent Class
Equals Overload
VisualComponents.Messages Namespace


DeleteComponent.GetHashCode Method

DeleteComponentGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.DeleteComponent.GetHashCode"]

See Also

Reference

DeleteComponent Class
VisualComponents.Messages Namespace


DeleteComponent.MergeFrom Method

DeleteComponentMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(DeleteComponent) |
Top
See Also

Reference

DeleteComponent Class
VisualComponents.Messages Namespace


DeleteComponent.MergeFrom Method (CodedInputStream)

DeleteComponentMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

DeleteComponent Class
MergeFrom Overload
VisualComponents.Messages Namespace


DeleteComponent.MergeFrom Method (DeleteComponent)

DeleteComponentMergeFrom Method (DeleteComponent)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    DeleteComponent other
)
public:
virtual void MergeFrom(
    DeleteComponent^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesDeleteComponent

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

DeleteComponent Class
MergeFrom Overload
VisualComponents.Messages Namespace


DeleteComponent.ToString Method

DeleteComponentToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.DeleteComponent.ToString"]

See Also

Reference

DeleteComponent Class
VisualComponents.Messages Namespace


DeleteComponent.WriteTo Method

DeleteComponentWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

DeleteComponent Class
VisualComponents.Messages Namespace


DeleteComponent Fields

The DeleteComponent type exposes the following members.

Fields
Name | Description
ComponentIdFieldNumber | Field number for the "component_id" field.
DeletedFieldNumber | Field number for the "deleted" field.
Top
See Also

Reference

DeleteComponent Class
VisualComponents.Messages Namespace


DeleteComponent.ComponentIdFieldNumber Field

DeleteComponentComponentIdFieldNumber Field

Field number for the "component_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ComponentIdFieldNumber = 1
public:
literal int ComponentIdFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

DeleteComponent Class
VisualComponents.Messages Namespace


DeleteComponent.DeletedFieldNumber Field

DeleteComponentDeletedFieldNumber Field

Field number for the "deleted" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int DeletedFieldNumber = 2
public:
literal int DeletedFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

DeleteComponent Class
VisualComponents.Messages Namespace


DeviceInfo Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesDeviceInfo

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class DeviceInfo : IMessage<DeviceInfo>,
    IMessage, IEquatable<DeviceInfo>, IDeepCloneable<DeviceInfo>
public ref class DeviceInfo sealed : IMessage<DeviceInfo^>,
    IMessage, IEquatable<DeviceInfo^>, IDeepCloneable<DeviceInfo^>

The DeviceInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DeviceInfo | Initializes a new instance of the DeviceInfo class
Public method | DeviceInfo(DeviceInfo) | Initializes a new instance of the DeviceInfo class
Top
Properties
 | Name | Description
 | Descriptor |
Public property | Model |
 | Parser |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(DeviceInfo) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(DeviceInfo) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
ModelFieldNumber | Field number for the "model" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


DeviceInfo Constructor

Overload List
 | Name | Description
Public method | DeviceInfo | Initializes a new instance of the DeviceInfo class
Public method | DeviceInfo(DeviceInfo) | Initializes a new instance of the DeviceInfo class
Top
See Also

Reference

DeviceInfo Class
VisualComponents.Messages Namespace


DeviceInfo Constructor

Initializes a new instance of the DeviceInfo class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DeviceInfo()
public:
DeviceInfo()
See Also

Reference

DeviceInfo Class
DeviceInfo Overload
VisualComponents.Messages Namespace


DeviceInfo Constructor (DeviceInfo)

Initializes a new instance of the DeviceInfo class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DeviceInfo(
    DeviceInfo other
)
public:
DeviceInfo(
    DeviceInfo^ other
)

Parameters

other
Type: VisualComponents.MessagesDeviceInfo
See Also

Reference

DeviceInfo Class
DeviceInfo Overload
VisualComponents.Messages Namespace


DeviceInfo Properties

The DeviceInfo type exposes the following members.

Properties
 | Name | Description
 | Descriptor |
Public property | Model |
 | Parser |
Top
See Also

Reference

DeviceInfo Class
VisualComponents.Messages Namespace


DeviceInfo.Descriptor Property

DeviceInfoDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

DeviceInfo Class
VisualComponents.Messages Namespace


DeviceInfo.Model Property

DeviceInfoModel Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Model { get; set; }
public:
property String^ Model {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DeviceInfo Class
VisualComponents.Messages Namespace


DeviceInfo.Parser Property

DeviceInfoParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<DeviceInfo> Parser { get; }
public:
static property MessageParser<DeviceInfo^>^ Parser {
    MessageParser<DeviceInfo^>^ get ();
}

Property Value

Type: MessageParserDeviceInfo
See Also

Reference

DeviceInfo Class
VisualComponents.Messages Namespace


DeviceInfo Methods

The DeviceInfo type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(DeviceInfo) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(DeviceInfo) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DeviceInfo Class
VisualComponents.Messages Namespace


DeviceInfo.CalculateSize Method

DeviceInfoCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.DeviceInfo.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

DeviceInfo Class
VisualComponents.Messages Namespace


DeviceInfo.Clone Method

DeviceInfoClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DeviceInfo Clone()
public:
virtual DeviceInfo^ Clone() sealed

Return Value

Type: DeviceInfo

[Missing <returns> documentation for "M:VisualComponents.Messages.DeviceInfo.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

DeviceInfo Class
VisualComponents.Messages Namespace


DeviceInfo.Equals Method

DeviceInfoEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(DeviceInfo) |
Top
See Also

Reference

DeviceInfo Class
VisualComponents.Messages Namespace


DeviceInfo.Equals Method (Object)

DeviceInfoEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.DeviceInfo.Equals(System.Object)"]

See Also

Reference

DeviceInfo Class
Equals Overload
VisualComponents.Messages Namespace


DeviceInfo.Equals Method (DeviceInfo)

DeviceInfoEquals Method (DeviceInfo)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    DeviceInfo other
)
public:
virtual bool Equals(
    DeviceInfo^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesDeviceInfo

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.DeviceInfo.Equals(VisualComponents.Messages.DeviceInfo)"]

Implements

IEquatableTEquals(T)
See Also

Reference

DeviceInfo Class
Equals Overload
VisualComponents.Messages Namespace


DeviceInfo.GetHashCode Method

DeviceInfoGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.DeviceInfo.GetHashCode"]

See Also

Reference

DeviceInfo Class
VisualComponents.Messages Namespace


DeviceInfo.MergeFrom Method

DeviceInfoMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(DeviceInfo) |
Top
See Also

Reference

DeviceInfo Class
VisualComponents.Messages Namespace


DeviceInfo.MergeFrom Method (CodedInputStream)

DeviceInfoMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

DeviceInfo Class
MergeFrom Overload
VisualComponents.Messages Namespace


DeviceInfo.MergeFrom Method (DeviceInfo)

DeviceInfoMergeFrom Method (DeviceInfo)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    DeviceInfo other
)
public:
virtual void MergeFrom(
    DeviceInfo^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesDeviceInfo

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

DeviceInfo Class
MergeFrom Overload
VisualComponents.Messages Namespace


DeviceInfo.ToString Method

DeviceInfoToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.DeviceInfo.ToString"]

See Also

Reference

DeviceInfo Class
VisualComponents.Messages Namespace


DeviceInfo.WriteTo Method

DeviceInfoWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

DeviceInfo Class
VisualComponents.Messages Namespace


DeviceInfo Fields

The DeviceInfo type exposes the following members.

Fields
Name | Description
ModelFieldNumber | Field number for the "model" field.
Top
See Also

Reference

DeviceInfo Class
VisualComponents.Messages Namespace


DeviceInfo.ModelFieldNumber Field

DeviceInfoModelFieldNumber Field

Field number for the "model" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ModelFieldNumber = 1
public:
literal int ModelFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

DeviceInfo Class
VisualComponents.Messages Namespace


DeviceInput Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesDeviceInput

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class DeviceInput : IMessage<DeviceInput>,
    IMessage, IEquatable<DeviceInput>, IDeepCloneable<DeviceInput>
public ref class DeviceInput sealed : IMessage<DeviceInput^>,
    IMessage, IEquatable<DeviceInput^>, IDeepCloneable<DeviceInput^>

The DeviceInput type exposes the following members.

Constructors
 | Name | Description
Public method | DeviceInput | Initializes a new instance of the DeviceInput class
Public method | DeviceInput(DeviceInput) | Initializes a new instance of the DeviceInput class
Top
Properties
 | Name | Description
 | Descriptor |
Public property | DeviceRole |
Public property | Inputs |
 | Parser |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(DeviceInput) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(DeviceInput) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
DeviceRoleFieldNumber | Field number for the "device_role" field.
InputsFieldNumber | Field number for the "inputs" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


DeviceInput Constructor

Overload List
 | Name | Description
Public method | DeviceInput | Initializes a new instance of the DeviceInput class
Public method | DeviceInput(DeviceInput) | Initializes a new instance of the DeviceInput class
Top
See Also

Reference

DeviceInput Class
VisualComponents.Messages Namespace


DeviceInput Constructor

Initializes a new instance of the DeviceInput class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DeviceInput()
public:
DeviceInput()
See Also

Reference

DeviceInput Class
DeviceInput Overload
VisualComponents.Messages Namespace


DeviceInput Constructor (DeviceInput)

Initializes a new instance of the DeviceInput class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DeviceInput(
    DeviceInput other
)
public:
DeviceInput(
    DeviceInput^ other
)

Parameters

other
Type: VisualComponents.MessagesDeviceInput
See Also

Reference

DeviceInput Class
DeviceInput Overload
VisualComponents.Messages Namespace


DeviceInput Properties

The DeviceInput type exposes the following members.

Properties
 | Name | Description
 | Descriptor |
Public property | DeviceRole |
Public property | Inputs |
 | Parser |
Top
See Also

Reference

DeviceInput Class
VisualComponents.Messages Namespace


DeviceInput.Descriptor Property

DeviceInputDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

DeviceInput Class
VisualComponents.Messages Namespace


DeviceInput.DeviceRole Property

DeviceInputDeviceRole Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string DeviceRole { get; set; }
public:
property String^ DeviceRole {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DeviceInput Class
VisualComponents.Messages Namespace


DeviceInput.Inputs Property

DeviceInputInputs Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<InputValue> Inputs { get; }
public:
property RepeatedField<InputValue^>^ Inputs {
    RepeatedField<InputValue^>^ get ();
}

Property Value

Type: RepeatedFieldInputValue
See Also

Reference

DeviceInput Class
VisualComponents.Messages Namespace


DeviceInput.Parser Property

DeviceInputParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<DeviceInput> Parser { get; }
public:
static property MessageParser<DeviceInput^>^ Parser {
    MessageParser<DeviceInput^>^ get ();
}

Property Value

Type: MessageParserDeviceInput
See Also

Reference

DeviceInput Class
VisualComponents.Messages Namespace


DeviceInput Methods

The DeviceInput type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(DeviceInput) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(DeviceInput) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DeviceInput Class
VisualComponents.Messages Namespace


DeviceInput.CalculateSize Method

DeviceInputCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.DeviceInput.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

DeviceInput Class
VisualComponents.Messages Namespace


DeviceInput.Clone Method

DeviceInputClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DeviceInput Clone()
public:
virtual DeviceInput^ Clone() sealed

Return Value

Type: DeviceInput

[Missing <returns> documentation for "M:VisualComponents.Messages.DeviceInput.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

DeviceInput Class
VisualComponents.Messages Namespace


DeviceInput.Equals Method

DeviceInputEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(DeviceInput) |
Top
See Also

Reference

DeviceInput Class
VisualComponents.Messages Namespace


DeviceInput.Equals Method (Object)

DeviceInputEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.DeviceInput.Equals(System.Object)"]

See Also

Reference

DeviceInput Class
Equals Overload
VisualComponents.Messages Namespace


DeviceInput.Equals Method (DeviceInput)

DeviceInputEquals Method (DeviceInput)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    DeviceInput other
)
public:
virtual bool Equals(
    DeviceInput^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesDeviceInput

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.DeviceInput.Equals(VisualComponents.Messages.DeviceInput)"]

Implements

IEquatableTEquals(T)
See Also

Reference

DeviceInput Class
Equals Overload
VisualComponents.Messages Namespace


DeviceInput.GetHashCode Method

DeviceInputGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.DeviceInput.GetHashCode"]

See Also

Reference

DeviceInput Class
VisualComponents.Messages Namespace


DeviceInput.MergeFrom Method

DeviceInputMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(DeviceInput) |
Top
See Also

Reference

DeviceInput Class
VisualComponents.Messages Namespace


DeviceInput.MergeFrom Method (CodedInputStream)

DeviceInputMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

DeviceInput Class
MergeFrom Overload
VisualComponents.Messages Namespace


DeviceInput.MergeFrom Method (DeviceInput)

DeviceInputMergeFrom Method (DeviceInput)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    DeviceInput other
)
public:
virtual void MergeFrom(
    DeviceInput^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesDeviceInput

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

DeviceInput Class
MergeFrom Overload
VisualComponents.Messages Namespace


DeviceInput.ToString Method

DeviceInputToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.DeviceInput.ToString"]

See Also

Reference

DeviceInput Class
VisualComponents.Messages Namespace


DeviceInput.WriteTo Method

DeviceInputWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

DeviceInput Class
VisualComponents.Messages Namespace


DeviceInput Fields

The DeviceInput type exposes the following members.

Fields
Name | Description
DeviceRoleFieldNumber | Field number for the "device_role" field.
InputsFieldNumber | Field number for the "inputs" field.
Top
See Also

Reference

DeviceInput Class
VisualComponents.Messages Namespace


DeviceInput.DeviceRoleFieldNumber Field

DeviceInputDeviceRoleFieldNumber Field

Field number for the "device_role" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int DeviceRoleFieldNumber = 1
public:
literal int DeviceRoleFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

DeviceInput Class
VisualComponents.Messages Namespace


DeviceInput.InputsFieldNumber Field

DeviceInputInputsFieldNumber Field

Field number for the "inputs" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int InputsFieldNumber = 2
public:
literal int InputsFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

DeviceInput Class
VisualComponents.Messages Namespace


EventCounter Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesEventCounter

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class EventCounter : IMessage<EventCounter>,
    IMessage, IEquatable<EventCounter>, IDeepCloneable<EventCounter>
public ref class EventCounter sealed : IMessage<EventCounter^>,
    IMessage, IEquatable<EventCounter^>, IDeepCloneable<EventCounter^>

The EventCounter type exposes the following members.

Constructors
 | Name | Description
Public method | EventCounter | Initializes a new instance of the EventCounter class
Public method | EventCounter(EventCounter) | Initializes a new instance of the EventCounter class
Top
Properties
 | Name | Description
 | Descriptor |
 | Parser |
Public property | Value |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(EventCounter) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(EventCounter) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
ValueFieldNumber | Field number for the "value" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


EventCounter Constructor

Overload List
 | Name | Description
Public method | EventCounter | Initializes a new instance of the EventCounter class
Public method | EventCounter(EventCounter) | Initializes a new instance of the EventCounter class
Top
See Also

Reference

EventCounter Class
VisualComponents.Messages Namespace


EventCounter Constructor

Initializes a new instance of the EventCounter class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EventCounter()
public:
EventCounter()
See Also

Reference

EventCounter Class
EventCounter Overload
VisualComponents.Messages Namespace


EventCounter Constructor (EventCounter)

Initializes a new instance of the EventCounter class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EventCounter(
    EventCounter other
)
public:
EventCounter(
    EventCounter^ other
)

Parameters

other
Type: VisualComponents.MessagesEventCounter
See Also

Reference

EventCounter Class
EventCounter Overload
VisualComponents.Messages Namespace


EventCounter Properties

The EventCounter type exposes the following members.

Properties
 | Name | Description
 | Descriptor |
 | Parser |
Public property | Value |
Top
See Also

Reference

EventCounter Class
VisualComponents.Messages Namespace


EventCounter.Descriptor Property

EventCounterDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

EventCounter Class
VisualComponents.Messages Namespace


EventCounter.Parser Property

EventCounterParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<EventCounter> Parser { get; }
public:
static property MessageParser<EventCounter^>^ Parser {
    MessageParser<EventCounter^>^ get ();
}

Property Value

Type: MessageParserEventCounter
See Also

Reference

EventCounter Class
VisualComponents.Messages Namespace


EventCounter.Value Property

EventCounterValue Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Value { get; set; }
public:
property int Value {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

EventCounter Class
VisualComponents.Messages Namespace


EventCounter Methods

The EventCounter type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(EventCounter) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(EventCounter) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

EventCounter Class
VisualComponents.Messages Namespace


EventCounter.CalculateSize Method

EventCounterCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.EventCounter.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

EventCounter Class
VisualComponents.Messages Namespace


EventCounter.Clone Method

EventCounterClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EventCounter Clone()
public:
virtual EventCounter^ Clone() sealed

Return Value

Type: EventCounter

[Missing <returns> documentation for "M:VisualComponents.Messages.EventCounter.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

EventCounter Class
VisualComponents.Messages Namespace


EventCounter.Equals Method

EventCounterEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(EventCounter) |
Top
See Also

Reference

EventCounter Class
VisualComponents.Messages Namespace


EventCounter.Equals Method (Object)

EventCounterEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.EventCounter.Equals(System.Object)"]

See Also

Reference

EventCounter Class
Equals Overload
VisualComponents.Messages Namespace


EventCounter.Equals Method (EventCounter)

EventCounterEquals Method (EventCounter)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    EventCounter other
)
public:
virtual bool Equals(
    EventCounter^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesEventCounter

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.EventCounter.Equals(VisualComponents.Messages.EventCounter)"]

Implements

IEquatableTEquals(T)
See Also

Reference

EventCounter Class
Equals Overload
VisualComponents.Messages Namespace


EventCounter.GetHashCode Method

EventCounterGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.EventCounter.GetHashCode"]

See Also

Reference

EventCounter Class
VisualComponents.Messages Namespace


EventCounter.MergeFrom Method

EventCounterMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(EventCounter) |
Top
See Also

Reference

EventCounter Class
VisualComponents.Messages Namespace


EventCounter.MergeFrom Method (CodedInputStream)

EventCounterMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

EventCounter Class
MergeFrom Overload
VisualComponents.Messages Namespace


EventCounter.MergeFrom Method (EventCounter)

EventCounterMergeFrom Method (EventCounter)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    EventCounter other
)
public:
virtual void MergeFrom(
    EventCounter^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesEventCounter

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

EventCounter Class
MergeFrom Overload
VisualComponents.Messages Namespace


EventCounter.ToString Method

EventCounterToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.EventCounter.ToString"]

See Also

Reference

EventCounter Class
VisualComponents.Messages Namespace


EventCounter.WriteTo Method

EventCounterWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

EventCounter Class
VisualComponents.Messages Namespace


EventCounter Fields

The EventCounter type exposes the following members.

Fields
Name | Description
ValueFieldNumber | Field number for the "value" field.
Top
See Also

Reference

EventCounter Class
VisualComponents.Messages Namespace


EventCounter.ValueFieldNumber Field

EventCounterValueFieldNumber Field

Field number for the "value" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ValueFieldNumber = 1
public:
literal int ValueFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

EventCounter Class
VisualComponents.Messages Namespace


EventsEnabled Class

----------------------------------------------------------------------------- VREvents
Inheritance Hierarchy
SystemObject
VisualComponents.MessagesEventsEnabled

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class EventsEnabled : IMessage<EventsEnabled>,
    IMessage, IEquatable<EventsEnabled>, IDeepCloneable<EventsEnabled>
public ref class EventsEnabled sealed : IMessage<EventsEnabled^>,
    IMessage, IEquatable<EventsEnabled^>, IDeepCloneable<EventsEnabled^>

The EventsEnabled type exposes the following members.

Constructors
 | Name | Description
Public method | EventsEnabled | Initializes a new instance of the EventsEnabled class
Public method | EventsEnabled(EventsEnabled) | Initializes a new instance of the EventsEnabled class
Top
Properties
 | Name | Description
 | Descriptor |
 | Parser |
Public property | Value |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(EventsEnabled) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(EventsEnabled) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
ValueFieldNumber | Field number for the "value" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


EventsEnabled Constructor

Overload List
 | Name | Description
Public method | EventsEnabled | Initializes a new instance of the EventsEnabled class
Public method | EventsEnabled(EventsEnabled) | Initializes a new instance of the EventsEnabled class
Top
See Also

Reference

EventsEnabled Class
VisualComponents.Messages Namespace


EventsEnabled Constructor

Initializes a new instance of the EventsEnabled class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EventsEnabled()
public:
EventsEnabled()
See Also

Reference

EventsEnabled Class
EventsEnabled Overload
VisualComponents.Messages Namespace


EventsEnabled Constructor (EventsEnabled)

Initializes a new instance of the EventsEnabled class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EventsEnabled(
    EventsEnabled other
)
public:
EventsEnabled(
    EventsEnabled^ other
)

Parameters

other
Type: VisualComponents.MessagesEventsEnabled
See Also

Reference

EventsEnabled Class
EventsEnabled Overload
VisualComponents.Messages Namespace


EventsEnabled Properties

The EventsEnabled type exposes the following members.

Properties
 | Name | Description
 | Descriptor |
 | Parser |
Public property | Value |
Top
See Also

Reference

EventsEnabled Class
VisualComponents.Messages Namespace


EventsEnabled.Descriptor Property

EventsEnabledDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

EventsEnabled Class
VisualComponents.Messages Namespace


EventsEnabled.Parser Property

EventsEnabledParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<EventsEnabled> Parser { get; }
public:
static property MessageParser<EventsEnabled^>^ Parser {
    MessageParser<EventsEnabled^>^ get ();
}

Property Value

Type: MessageParserEventsEnabled
See Also

Reference

EventsEnabled Class
VisualComponents.Messages Namespace


EventsEnabled.Value Property

EventsEnabledValue Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Value { get; set; }
public:
property bool Value {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

EventsEnabled Class
VisualComponents.Messages Namespace


EventsEnabled Methods

The EventsEnabled type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(EventsEnabled) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(EventsEnabled) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

EventsEnabled Class
VisualComponents.Messages Namespace


EventsEnabled.CalculateSize Method

EventsEnabledCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.EventsEnabled.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

EventsEnabled Class
VisualComponents.Messages Namespace


EventsEnabled.Clone Method

EventsEnabledClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EventsEnabled Clone()
public:
virtual EventsEnabled^ Clone() sealed

Return Value

Type: EventsEnabled

[Missing <returns> documentation for "M:VisualComponents.Messages.EventsEnabled.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

EventsEnabled Class
VisualComponents.Messages Namespace


EventsEnabled.Equals Method

EventsEnabledEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(EventsEnabled) |
Top
See Also

Reference

EventsEnabled Class
VisualComponents.Messages Namespace


EventsEnabled.Equals Method (Object)

EventsEnabledEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.EventsEnabled.Equals(System.Object)"]

See Also

Reference

EventsEnabled Class
Equals Overload
VisualComponents.Messages Namespace


EventsEnabled.Equals Method (EventsEnabled)

EventsEnabledEquals Method (EventsEnabled)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    EventsEnabled other
)
public:
virtual bool Equals(
    EventsEnabled^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesEventsEnabled

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.EventsEnabled.Equals(VisualComponents.Messages.EventsEnabled)"]

Implements

IEquatableTEquals(T)
See Also

Reference

EventsEnabled Class
Equals Overload
VisualComponents.Messages Namespace


EventsEnabled.GetHashCode Method

EventsEnabledGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.EventsEnabled.GetHashCode"]

See Also

Reference

EventsEnabled Class
VisualComponents.Messages Namespace


EventsEnabled.MergeFrom Method

EventsEnabledMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(EventsEnabled) |
Top
See Also

Reference

EventsEnabled Class
VisualComponents.Messages Namespace


EventsEnabled.MergeFrom Method (CodedInputStream)

EventsEnabledMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

EventsEnabled Class
MergeFrom Overload
VisualComponents.Messages Namespace


EventsEnabled.MergeFrom Method (EventsEnabled)

EventsEnabledMergeFrom Method (EventsEnabled)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    EventsEnabled other
)
public:
virtual void MergeFrom(
    EventsEnabled^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesEventsEnabled

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

EventsEnabled Class
MergeFrom Overload
VisualComponents.Messages Namespace


EventsEnabled.ToString Method

EventsEnabledToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.EventsEnabled.ToString"]

See Also

Reference

EventsEnabled Class
VisualComponents.Messages Namespace


EventsEnabled.WriteTo Method

EventsEnabledWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

EventsEnabled Class
VisualComponents.Messages Namespace


EventsEnabled Fields

The EventsEnabled type exposes the following members.

Fields
Name | Description
ValueFieldNumber | Field number for the "value" field.
Top
See Also

Reference

EventsEnabled Class
VisualComponents.Messages Namespace


EventsEnabled.ValueFieldNumber Field

EventsEnabledValueFieldNumber Field

Field number for the "value" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ValueFieldNumber = 1
public:
literal int ValueFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

EventsEnabled Class
VisualComponents.Messages Namespace


FinishMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesFinishMessage

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class FinishMessage : IMessage<FinishMessage>,
    IMessage, IEquatable<FinishMessage>, IDeepCloneable<FinishMessage>
public ref class FinishMessage sealed : IMessage<FinishMessage^>,
    IMessage, IEquatable<FinishMessage^>, IDeepCloneable<FinishMessage^>

The FinishMessage type exposes the following members.

Constructors
 | Name | Description
Public method | FinishMessage | Initializes a new instance of the FinishMessage class
Public method | FinishMessage(FinishMessage) | Initializes a new instance of the FinishMessage class
Top
Properties
 | Name | Description
 | Descriptor |
Public property | FinishType |
 | Parser |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(FinishMessage) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(FinishMessage) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
FinishTypeFieldNumber | Field number for the "finish_type" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


FinishMessage Constructor

Overload List
 | Name | Description
Public method | FinishMessage | Initializes a new instance of the FinishMessage class
Public method | FinishMessage(FinishMessage) | Initializes a new instance of the FinishMessage class
Top
See Also

Reference

FinishMessage Class
VisualComponents.Messages Namespace


FinishMessage Constructor

Initializes a new instance of the FinishMessage class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FinishMessage()
public:
FinishMessage()
See Also

Reference

FinishMessage Class
FinishMessage Overload
VisualComponents.Messages Namespace


FinishMessage Constructor (FinishMessage)

Initializes a new instance of the FinishMessage class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FinishMessage(
    FinishMessage other
)
public:
FinishMessage(
    FinishMessage^ other
)

Parameters

other
Type: VisualComponents.MessagesFinishMessage
See Also

Reference

FinishMessage Class
FinishMessage Overload
VisualComponents.Messages Namespace


FinishMessage Properties

The FinishMessage type exposes the following members.

Properties
 | Name | Description
 | Descriptor |
Public property | FinishType |
 | Parser |
Top
See Also

Reference

FinishMessage Class
VisualComponents.Messages Namespace


FinishMessage.Descriptor Property

FinishMessageDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

FinishMessage Class
VisualComponents.Messages Namespace


FinishMessage.FinishType Property

FinishMessageFinishType Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int FinishType { get; set; }
public:
property int FinishType {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

FinishMessage Class
VisualComponents.Messages Namespace


FinishMessage.Parser Property

FinishMessageParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<FinishMessage> Parser { get; }
public:
static property MessageParser<FinishMessage^>^ Parser {
    MessageParser<FinishMessage^>^ get ();
}

Property Value

Type: MessageParserFinishMessage
See Also

Reference

FinishMessage Class
VisualComponents.Messages Namespace


FinishMessage Methods

The FinishMessage type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(FinishMessage) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(FinishMessage) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

FinishMessage Class
VisualComponents.Messages Namespace


FinishMessage.CalculateSize Method

FinishMessageCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.FinishMessage.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

FinishMessage Class
VisualComponents.Messages Namespace


FinishMessage.Clone Method

FinishMessageClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FinishMessage Clone()
public:
virtual FinishMessage^ Clone() sealed

Return Value

Type: FinishMessage

[Missing <returns> documentation for "M:VisualComponents.Messages.FinishMessage.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

FinishMessage Class
VisualComponents.Messages Namespace


FinishMessage.Equals Method

FinishMessageEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(FinishMessage) |
Top
See Also

Reference

FinishMessage Class
VisualComponents.Messages Namespace


FinishMessage.Equals Method (Object)

FinishMessageEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.FinishMessage.Equals(System.Object)"]

See Also

Reference

FinishMessage Class
Equals Overload
VisualComponents.Messages Namespace


FinishMessage.Equals Method (FinishMessage)

FinishMessageEquals Method (FinishMessage)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    FinishMessage other
)
public:
virtual bool Equals(
    FinishMessage^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesFinishMessage

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.FinishMessage.Equals(VisualComponents.Messages.FinishMessage)"]

Implements

IEquatableTEquals(T)
See Also

Reference

FinishMessage Class
Equals Overload
VisualComponents.Messages Namespace


FinishMessage.GetHashCode Method

FinishMessageGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.FinishMessage.GetHashCode"]

See Also

Reference

FinishMessage Class
VisualComponents.Messages Namespace


FinishMessage.MergeFrom Method

FinishMessageMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(FinishMessage) |
Top
See Also

Reference

FinishMessage Class
VisualComponents.Messages Namespace


FinishMessage.MergeFrom Method (CodedInputStream)

FinishMessageMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

FinishMessage Class
MergeFrom Overload
VisualComponents.Messages Namespace


FinishMessage.MergeFrom Method (FinishMessage)

FinishMessageMergeFrom Method (FinishMessage)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    FinishMessage other
)
public:
virtual void MergeFrom(
    FinishMessage^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesFinishMessage

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

FinishMessage Class
MergeFrom Overload
VisualComponents.Messages Namespace


FinishMessage.ToString Method

FinishMessageToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.FinishMessage.ToString"]

See Also

Reference

FinishMessage Class
VisualComponents.Messages Namespace


FinishMessage.WriteTo Method

FinishMessageWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

FinishMessage Class
VisualComponents.Messages Namespace


FinishMessage Fields

The FinishMessage type exposes the following members.

Fields
Name | Description
FinishTypeFieldNumber | Field number for the "finish_type" field.
Top
See Also

Reference

FinishMessage Class
VisualComponents.Messages Namespace


FinishMessage.FinishTypeFieldNumber Field

FinishMessageFinishTypeFieldNumber Field

Field number for the "finish_type" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int FinishTypeFieldNumber = 1
public:
literal int FinishTypeFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

FinishMessage Class
VisualComponents.Messages Namespace


GetDefaults Class

----------------------------------------------------------------------------- Base
Inheritance Hierarchy
SystemObject
VisualComponents.MessagesGetDefaults

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class GetDefaults : IMessage<GetDefaults>,
    IMessage, IEquatable<GetDefaults>, IDeepCloneable<GetDefaults>
public ref class GetDefaults sealed : IMessage<GetDefaults^>,
    IMessage, IEquatable<GetDefaults^>, IDeepCloneable<GetDefaults^>

The GetDefaults type exposes the following members.

Constructors
 | Name | Description
Public method | GetDefaults | Initializes a new instance of the GetDefaults class
Public method | GetDefaults(GetDefaults) | Initializes a new instance of the GetDefaults class
Top
Properties
 | Name | Description
Public property | Condition |
 | Descriptor |
 | Parser |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(GetDefaults) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(GetDefaults) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
ConditionFieldNumber | Field number for the "condition" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


GetDefaults Constructor

Overload List
 | Name | Description
Public method | GetDefaults | Initializes a new instance of the GetDefaults class
Public method | GetDefaults(GetDefaults) | Initializes a new instance of the GetDefaults class
Top
See Also

Reference

GetDefaults Class
VisualComponents.Messages Namespace


GetDefaults Constructor

Initializes a new instance of the GetDefaults class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GetDefaults()
public:
GetDefaults()
See Also

Reference

GetDefaults Class
GetDefaults Overload
VisualComponents.Messages Namespace


GetDefaults Constructor (GetDefaults)

Initializes a new instance of the GetDefaults class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GetDefaults(
    GetDefaults other
)
public:
GetDefaults(
    GetDefaults^ other
)

Parameters

other
Type: VisualComponents.MessagesGetDefaults
See Also

Reference

GetDefaults Class
GetDefaults Overload
VisualComponents.Messages Namespace


GetDefaults Properties

The GetDefaults type exposes the following members.

Properties
 | Name | Description
Public property | Condition |
 | Descriptor |
 | Parser |
Top
See Also

Reference

GetDefaults Class
VisualComponents.Messages Namespace


GetDefaults.Condition Property

GetDefaultsCondition Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Condition { get; set; }
public:
property int Condition {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

GetDefaults Class
VisualComponents.Messages Namespace


GetDefaults.Descriptor Property

GetDefaultsDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

GetDefaults Class
VisualComponents.Messages Namespace


GetDefaults.Parser Property

GetDefaultsParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<GetDefaults> Parser { get; }
public:
static property MessageParser<GetDefaults^>^ Parser {
    MessageParser<GetDefaults^>^ get ();
}

Property Value

Type: MessageParserGetDefaults
See Also

Reference

GetDefaults Class
VisualComponents.Messages Namespace


GetDefaults Methods

The GetDefaults type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(GetDefaults) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(GetDefaults) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

GetDefaults Class
VisualComponents.Messages Namespace


GetDefaults.CalculateSize Method

GetDefaultsCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.GetDefaults.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

GetDefaults Class
VisualComponents.Messages Namespace


GetDefaults.Clone Method

GetDefaultsClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GetDefaults Clone()
public:
virtual GetDefaults^ Clone() sealed

Return Value

Type: GetDefaults

[Missing <returns> documentation for "M:VisualComponents.Messages.GetDefaults.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

GetDefaults Class
VisualComponents.Messages Namespace


GetDefaults.Equals Method

GetDefaultsEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(GetDefaults) |
Top
See Also

Reference

GetDefaults Class
VisualComponents.Messages Namespace


GetDefaults.Equals Method (Object)

GetDefaultsEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.GetDefaults.Equals(System.Object)"]

See Also

Reference

GetDefaults Class
Equals Overload
VisualComponents.Messages Namespace


GetDefaults.Equals Method (GetDefaults)

GetDefaultsEquals Method (GetDefaults)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    GetDefaults other
)
public:
virtual bool Equals(
    GetDefaults^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesGetDefaults

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.GetDefaults.Equals(VisualComponents.Messages.GetDefaults)"]

Implements

IEquatableTEquals(T)
See Also

Reference

GetDefaults Class
Equals Overload
VisualComponents.Messages Namespace


GetDefaults.GetHashCode Method

GetDefaultsGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.GetDefaults.GetHashCode"]

See Also

Reference

GetDefaults Class
VisualComponents.Messages Namespace


GetDefaults.MergeFrom Method

GetDefaultsMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(GetDefaults) |
Top
See Also

Reference

GetDefaults Class
VisualComponents.Messages Namespace


GetDefaults.MergeFrom Method (CodedInputStream)

GetDefaultsMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

GetDefaults Class
MergeFrom Overload
VisualComponents.Messages Namespace


GetDefaults.MergeFrom Method (GetDefaults)

GetDefaultsMergeFrom Method (GetDefaults)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    GetDefaults other
)
public:
virtual void MergeFrom(
    GetDefaults^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesGetDefaults

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

GetDefaults Class
MergeFrom Overload
VisualComponents.Messages Namespace


GetDefaults.ToString Method

GetDefaultsToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.GetDefaults.ToString"]

See Also

Reference

GetDefaults Class
VisualComponents.Messages Namespace


GetDefaults.WriteTo Method

GetDefaultsWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

GetDefaults Class
VisualComponents.Messages Namespace


GetDefaults Fields

The GetDefaults type exposes the following members.

Fields
Name | Description
ConditionFieldNumber | Field number for the "condition" field.
Top
See Also

Reference

GetDefaults Class
VisualComponents.Messages Namespace


GetDefaults.ConditionFieldNumber Field

GetDefaultsConditionFieldNumber Field

Field number for the "condition" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ConditionFieldNumber = 1
public:
literal int ConditionFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

GetDefaults Class
VisualComponents.Messages Namespace


InitDefaults Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesInitDefaults

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class InitDefaults : IMessage<InitDefaults>,
    IMessage, IEquatable<InitDefaults>, IDeepCloneable<InitDefaults>
public ref class InitDefaults sealed : IMessage<InitDefaults^>,
    IMessage, IEquatable<InitDefaults^>, IDeepCloneable<InitDefaults^>

The InitDefaults type exposes the following members.

Constructors
 | Name | Description
Public method | InitDefaults | Initializes a new instance of the InitDefaults class
Public method | InitDefaults(InitDefaults) | Initializes a new instance of the InitDefaults class
Top
Properties
 | Name | Description
 | Descriptor |
Public property | HasResetAndRun |
Public property | IsSimRunning |
 | Parser |
Public property | SpeedFactor |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(InitDefaults) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(InitDefaults) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
HasResetAndRunFieldNumber | Field number for the "has_reset_and_run" field.
IsSimRunningFieldNumber | Field number for the "is_sim_running" field.
SpeedFactorFieldNumber | Field number for the "speed_factor" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


InitDefaults Constructor

Overload List
 | Name | Description
Public method | InitDefaults | Initializes a new instance of the InitDefaults class
Public method | InitDefaults(InitDefaults) | Initializes a new instance of the InitDefaults class
Top
See Also

Reference

InitDefaults Class
VisualComponents.Messages Namespace


InitDefaults Constructor

Initializes a new instance of the InitDefaults class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InitDefaults()
public:
InitDefaults()
See Also

Reference

InitDefaults Class
InitDefaults Overload
VisualComponents.Messages Namespace


InitDefaults Constructor (InitDefaults)

Initializes a new instance of the InitDefaults class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InitDefaults(
    InitDefaults other
)
public:
InitDefaults(
    InitDefaults^ other
)

Parameters

other
Type: VisualComponents.MessagesInitDefaults
See Also

Reference

InitDefaults Class
InitDefaults Overload
VisualComponents.Messages Namespace


InitDefaults Properties

The InitDefaults type exposes the following members.

Properties
 | Name | Description
 | Descriptor |
Public property | HasResetAndRun |
Public property | IsSimRunning |
 | Parser |
Public property | SpeedFactor |
Top
See Also

Reference

InitDefaults Class
VisualComponents.Messages Namespace


InitDefaults.Descriptor Property

InitDefaultsDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

InitDefaults Class
VisualComponents.Messages Namespace


InitDefaults.HasResetAndRun Property

InitDefaultsHasResetAndRun Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HasResetAndRun { get; set; }
public:
property bool HasResetAndRun {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

InitDefaults Class
VisualComponents.Messages Namespace


InitDefaults.IsSimRunning Property

InitDefaultsIsSimRunning Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsSimRunning { get; set; }
public:
property bool IsSimRunning {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

InitDefaults Class
VisualComponents.Messages Namespace


InitDefaults.Parser Property

InitDefaultsParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<InitDefaults> Parser { get; }
public:
static property MessageParser<InitDefaults^>^ Parser {
    MessageParser<InitDefaults^>^ get ();
}

Property Value

Type: MessageParserInitDefaults
See Also

Reference

InitDefaults Class
VisualComponents.Messages Namespace


InitDefaults.SpeedFactor Property

InitDefaultsSpeedFactor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float SpeedFactor { get; set; }
public:
property float SpeedFactor {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

InitDefaults Class
VisualComponents.Messages Namespace


InitDefaults Methods

The InitDefaults type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(InitDefaults) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(InitDefaults) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

InitDefaults Class
VisualComponents.Messages Namespace


InitDefaults.CalculateSize Method

InitDefaultsCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.InitDefaults.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

InitDefaults Class
VisualComponents.Messages Namespace


InitDefaults.Clone Method

InitDefaultsClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InitDefaults Clone()
public:
virtual InitDefaults^ Clone() sealed

Return Value

Type: InitDefaults

[Missing <returns> documentation for "M:VisualComponents.Messages.InitDefaults.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

InitDefaults Class
VisualComponents.Messages Namespace


InitDefaults.Equals Method

InitDefaultsEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(InitDefaults) |
Top
See Also

Reference

InitDefaults Class
VisualComponents.Messages Namespace


InitDefaults.Equals Method (Object)

InitDefaultsEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.InitDefaults.Equals(System.Object)"]

See Also

Reference

InitDefaults Class
Equals Overload
VisualComponents.Messages Namespace


InitDefaults.Equals Method (InitDefaults)

InitDefaultsEquals Method (InitDefaults)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    InitDefaults other
)
public:
virtual bool Equals(
    InitDefaults^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesInitDefaults

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.InitDefaults.Equals(VisualComponents.Messages.InitDefaults)"]

Implements

IEquatableTEquals(T)
See Also

Reference

InitDefaults Class
Equals Overload
VisualComponents.Messages Namespace


InitDefaults.GetHashCode Method

InitDefaultsGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.InitDefaults.GetHashCode"]

See Also

Reference

InitDefaults Class
VisualComponents.Messages Namespace


InitDefaults.MergeFrom Method

InitDefaultsMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(InitDefaults) |
Top
See Also

Reference

InitDefaults Class
VisualComponents.Messages Namespace


InitDefaults.MergeFrom Method (CodedInputStream)

InitDefaultsMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

InitDefaults Class
MergeFrom Overload
VisualComponents.Messages Namespace


InitDefaults.MergeFrom Method (InitDefaults)

InitDefaultsMergeFrom Method (InitDefaults)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    InitDefaults other
)
public:
virtual void MergeFrom(
    InitDefaults^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesInitDefaults

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

InitDefaults Class
MergeFrom Overload
VisualComponents.Messages Namespace


InitDefaults.ToString Method

InitDefaultsToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.InitDefaults.ToString"]

See Also

Reference

InitDefaults Class
VisualComponents.Messages Namespace


InitDefaults.WriteTo Method

InitDefaultsWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

InitDefaults Class
VisualComponents.Messages Namespace


InitDefaults Fields

The InitDefaults type exposes the following members.

Fields
Name | Description
HasResetAndRunFieldNumber | Field number for the "has_reset_and_run" field.
IsSimRunningFieldNumber | Field number for the "is_sim_running" field.
SpeedFactorFieldNumber | Field number for the "speed_factor" field.
Top
See Also

Reference

InitDefaults Class
VisualComponents.Messages Namespace


InitDefaults.HasResetAndRunFieldNumber Field

InitDefaultsHasResetAndRunFieldNumber Field

Field number for the "has_reset_and_run" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int HasResetAndRunFieldNumber = 1
public:
literal int HasResetAndRunFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

InitDefaults Class
VisualComponents.Messages Namespace


InitDefaults.IsSimRunningFieldNumber Field

InitDefaultsIsSimRunningFieldNumber Field

Field number for the "is_sim_running" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int IsSimRunningFieldNumber = 2
public:
literal int IsSimRunningFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

InitDefaults Class
VisualComponents.Messages Namespace


InitDefaults.SpeedFactorFieldNumber Field

InitDefaultsSpeedFactorFieldNumber Field

Field number for the "speed_factor" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int SpeedFactorFieldNumber = 3
public:
literal int SpeedFactorFieldNumber = 3

Field Value

Type: Int32
See Also

Reference

InitDefaults Class
VisualComponents.Messages Namespace


InputValue Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesInputValue

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class InputValue : IMessage<InputValue>,
    IMessage, IEquatable<InputValue>, IDeepCloneable<InputValue>
public ref class InputValue sealed : IMessage<InputValue^>,
    IMessage, IEquatable<InputValue^>, IDeepCloneable<InputValue^>

The InputValue type exposes the following members.

Constructors
 | Name | Description
Public method | InputValue | Initializes a new instance of the InputValue class
Public method | InputValue(InputValue) | Initializes a new instance of the InputValue class
Top
Properties
 | Name | Description
Public property | Axis |
Public property | Axis2D |
Public property | Button |
 | Descriptor |
Public property | InputCase |
Public property | Name |
 | Parser |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | ClearInput |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(InputValue) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(InputValue) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
Axis2DFieldNumber | Field number for the "axis_2d" field.
AxisFieldNumber | Field number for the "axis" field.
ButtonFieldNumber | Field number for the "button" field.
NameFieldNumber | Field number for the "name" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


InputValue Constructor

Overload List
 | Name | Description
Public method | InputValue | Initializes a new instance of the InputValue class
Public method | InputValue(InputValue) | Initializes a new instance of the InputValue class
Top
See Also

Reference

InputValue Class
VisualComponents.Messages Namespace


InputValue Constructor

Initializes a new instance of the InputValue class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InputValue()
public:
InputValue()
See Also

Reference

InputValue Class
InputValue Overload
VisualComponents.Messages Namespace


InputValue Constructor (InputValue)

Initializes a new instance of the InputValue class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InputValue(
    InputValue other
)
public:
InputValue(
    InputValue^ other
)

Parameters

other
Type: VisualComponents.MessagesInputValue
See Also

Reference

InputValue Class
InputValue Overload
VisualComponents.Messages Namespace


InputValue Properties

The InputValue type exposes the following members.

Properties
 | Name | Description
Public property | Axis |
Public property | Axis2D |
Public property | Button |
 | Descriptor |
Public property | InputCase |
Public property | Name |
 | Parser |
Top
See Also

Reference

InputValue Class
VisualComponents.Messages Namespace


InputValue.Axis Property

InputValueAxis Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InputValueTypesAxis Axis { get; set; }
public:
property InputValueTypesAxis^ Axis {
    InputValueTypesAxis^ get ();
    void set (InputValueTypesAxis^ value);
}

Property Value

Type: InputValueTypesAxis
See Also

Reference

InputValue Class
VisualComponents.Messages Namespace


InputValue.Axis2D Property

InputValueAxis2D Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InputValueTypesAxis2D Axis2D { get; set; }
public:
property InputValueTypesAxis2D^ Axis2D {
    InputValueTypesAxis2D^ get ();
    void set (InputValueTypesAxis2D^ value);
}

Property Value

Type: InputValueTypesAxis2D
See Also

Reference

InputValue Class
VisualComponents.Messages Namespace


InputValue.Button Property

InputValueButton Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InputValueTypesButton Button { get; set; }
public:
property InputValueTypesButton^ Button {
    InputValueTypesButton^ get ();
    void set (InputValueTypesButton^ value);
}

Property Value

Type: InputValueTypesButton
See Also

Reference

InputValue Class
VisualComponents.Messages Namespace


InputValue.Descriptor Property

InputValueDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

InputValue Class
VisualComponents.Messages Namespace


InputValue.InputCase Property

InputValueInputCase Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InputValueInputOneofCase InputCase { get; }
public:
property InputValueInputOneofCase InputCase {
    InputValueInputOneofCase get ();
}

Property Value

Type: InputValueInputOneofCase
See Also

Reference

InputValue Class
VisualComponents.Messages Namespace


InputValue.Name Property

InputValueName Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; set; }
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

InputValue Class
VisualComponents.Messages Namespace


InputValue.Parser Property

InputValueParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<InputValue> Parser { get; }
public:
static property MessageParser<InputValue^>^ Parser {
    MessageParser<InputValue^>^ get ();
}

Property Value

Type: MessageParserInputValue
See Also

Reference

InputValue Class
VisualComponents.Messages Namespace


InputValue Methods

The InputValue type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | ClearInput |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(InputValue) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(InputValue) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

InputValue Class
VisualComponents.Messages Namespace


InputValue.CalculateSize Method

InputValueCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.InputValue.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

InputValue Class
VisualComponents.Messages Namespace


InputValue.ClearInput Method

InputValueClearInput Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ClearInput()
public:
void ClearInput()
See Also

Reference

InputValue Class
VisualComponents.Messages Namespace


InputValue.Clone Method

InputValueClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InputValue Clone()
public:
virtual InputValue^ Clone() sealed

Return Value

Type: InputValue

[Missing <returns> documentation for "M:VisualComponents.Messages.InputValue.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

InputValue Class
VisualComponents.Messages Namespace


InputValue.Equals Method

InputValueEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(InputValue) |
Top
See Also

Reference

InputValue Class
VisualComponents.Messages Namespace


InputValue.Equals Method (Object)

InputValueEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.InputValue.Equals(System.Object)"]

See Also

Reference

InputValue Class
Equals Overload
VisualComponents.Messages Namespace


InputValue.Equals Method (InputValue)

InputValueEquals Method (InputValue)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    InputValue other
)
public:
virtual bool Equals(
    InputValue^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesInputValue

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.InputValue.Equals(VisualComponents.Messages.InputValue)"]

Implements

IEquatableTEquals(T)
See Also

Reference

InputValue Class
Equals Overload
VisualComponents.Messages Namespace


InputValue.GetHashCode Method

InputValueGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.InputValue.GetHashCode"]

See Also

Reference

InputValue Class
VisualComponents.Messages Namespace


InputValue.MergeFrom Method

InputValueMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(InputValue) |
Top
See Also

Reference

InputValue Class
VisualComponents.Messages Namespace


InputValue.MergeFrom Method (CodedInputStream)

InputValueMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

InputValue Class
MergeFrom Overload
VisualComponents.Messages Namespace


InputValue.MergeFrom Method (InputValue)

InputValueMergeFrom Method (InputValue)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    InputValue other
)
public:
virtual void MergeFrom(
    InputValue^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesInputValue

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

InputValue Class
MergeFrom Overload
VisualComponents.Messages Namespace


InputValue.ToString Method

InputValueToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.InputValue.ToString"]

See Also

Reference

InputValue Class
VisualComponents.Messages Namespace


InputValue.WriteTo Method

InputValueWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

InputValue Class
VisualComponents.Messages Namespace


InputValue Fields

The InputValue type exposes the following members.

Fields
Name | Description
Axis2DFieldNumber | Field number for the "axis_2d" field.
AxisFieldNumber | Field number for the "axis" field.
ButtonFieldNumber | Field number for the "button" field.
NameFieldNumber | Field number for the "name" field.
Top
See Also

Reference

InputValue Class
VisualComponents.Messages Namespace


InputValue.Axis2DFieldNumber Field

InputValueAxis2DFieldNumber Field

Field number for the "axis_2d" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int Axis2DFieldNumber = 2
public:
literal int Axis2DFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

InputValue Class
VisualComponents.Messages Namespace


InputValue.AxisFieldNumber Field

InputValueAxisFieldNumber Field

Field number for the "axis" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int AxisFieldNumber = 3
public:
literal int AxisFieldNumber = 3

Field Value

Type: Int32
See Also

Reference

InputValue Class
VisualComponents.Messages Namespace


InputValue.ButtonFieldNumber Field

InputValueButtonFieldNumber Field

Field number for the "button" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ButtonFieldNumber = 4
public:
literal int ButtonFieldNumber = 4

Field Value

Type: Int32
See Also

Reference

InputValue Class
VisualComponents.Messages Namespace


InputValue.NameFieldNumber Field

InputValueNameFieldNumber Field

Field number for the "name" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int NameFieldNumber = 1
public:
literal int NameFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

InputValue Class
VisualComponents.Messages Namespace


InputValue.InputOneofCase Enumeration

InputValueInputOneofCase Enumeration

Enum of possible cases for the "input" oneof.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum InputOneofCase
public enum class InputOneofCase
Members
Member name | Value | Description
None | 0 |
Axis2D | 2 |
Axis | 3 |
Button | 4 |
See Also

Reference

VisualComponents.Messages Namespace


InputValue.Types Class

InputValueTypes Class

Container for nested types declared in the InputValue message type.
Inheritance Hierarchy
SystemObject
VisualComponents.MessagesInputValueTypes

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class Types
public ref class Types abstract sealed
See Also

Reference

VisualComponents.Messages Namespace


InputValue.Types.Axis Class

InputValueTypesAxis Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesInputValueTypesAxis

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class Axis : IMessage<InputValueTypesAxis>,
    IMessage, IEquatable<InputValueTypesAxis>, IDeepCloneable<InputValueTypesAxis>
public ref class Axis sealed : IMessage<InputValueTypesAxis^>,
    IMessage, IEquatable<InputValueTypesAxis^>, IDeepCloneable<InputValueTypesAxis^>

The InputValueTypesAxis type exposes the following members.

Constructors
 | Name | Description
Public method | InputValueTypesAxis | Initializes a new instance of the InputValueTypesAxis class
Public method | InputValueTypesAxis(InputValueTypesAxis) | Initializes a new instance of the InputValueTypesAxis class
Top
Properties
 | Name | Description
 | Descriptor |
 | Parser |
Public property | Value |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(InputValueTypesAxis) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(InputValueTypesAxis) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
ValueFieldNumber | Field number for the "value" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


Axis Constructor

Overload List
 | Name | Description
Public method | InputValueTypesAxis | Initializes a new instance of the InputValueTypesAxis class
Public method | InputValueTypesAxis(InputValueTypesAxis) | Initializes a new instance of the InputValueTypesAxis class
Top
See Also

Reference

InputValueTypesAxis Class
VisualComponents.Messages Namespace


InputValue.Types.Axis Constructor

InputValueTypesAxis Constructor

Initializes a new instance of the InputValueTypesAxis class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Axis()
public:
Axis()
See Also

Reference

InputValueTypesAxis Class
InputValueTypesAxis Overload
VisualComponents.Messages Namespace


InputValue.Types.Axis Constructor (InputValue.Types.Axis)

InputValueTypesAxis Constructor (InputValueTypesAxis)

Initializes a new instance of the InputValueTypesAxis class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Axis(
    InputValueTypesAxis other
)
public:
Axis(
    InputValueTypesAxis^ other
)

Parameters

other
Type: VisualComponents.MessagesInputValueTypesAxis
See Also

Reference

InputValueTypesAxis Class
InputValueTypesAxis Overload
VisualComponents.Messages Namespace


Axis Properties

The InputValueTypesAxis type exposes the following members.

Properties
 | Name | Description
 | Descriptor |
 | Parser |
Public property | Value |
Top
See Also

Reference

InputValueTypesAxis Class
VisualComponents.Messages Namespace


InputValue.Types.Axis.Descriptor Property

InputValueTypesAxisDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

InputValueTypesAxis Class
VisualComponents.Messages Namespace


InputValue.Types.Axis.Parser Property

InputValueTypesAxisParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<InputValueTypesAxis> Parser { get; }
public:
static property MessageParser<InputValueTypesAxis^>^ Parser {
    MessageParser<InputValueTypesAxis^>^ get ();
}

Property Value

Type: MessageParserInputValueTypesAxis
See Also

Reference

InputValueTypesAxis Class
VisualComponents.Messages Namespace


InputValue.Types.Axis.Value Property

InputValueTypesAxisValue Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float Value { get; set; }
public:
property float Value {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

InputValueTypesAxis Class
VisualComponents.Messages Namespace


Axis Methods

The InputValueTypesAxis type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(InputValueTypesAxis) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(InputValueTypesAxis) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

InputValueTypesAxis Class
VisualComponents.Messages Namespace


InputValue.Types.Axis.CalculateSize Method

InputValueTypesAxisCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.InputValue.Types.Axis.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

InputValueTypesAxis Class
VisualComponents.Messages Namespace


InputValue.Types.Axis.Clone Method

InputValueTypesAxisClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InputValueTypesAxis Clone()
public:
virtual InputValueTypesAxis^ Clone() sealed

Return Value

Type: InputValueTypesAxis

[Missing <returns> documentation for "M:VisualComponents.Messages.InputValue.Types.Axis.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

InputValueTypesAxis Class
VisualComponents.Messages Namespace


Axis.Equals Method

AxisEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(InputValueTypesAxis) |
Top
See Also

Reference

InputValueTypesAxis Class
VisualComponents.Messages Namespace


InputValue.Types.Axis.Equals Method (Object)

InputValueTypesAxisEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.InputValue.Types.Axis.Equals(System.Object)"]

See Also

Reference

InputValueTypesAxis Class
Equals Overload
VisualComponents.Messages Namespace


InputValue.Types.Axis.Equals Method (InputValue.Types.Axis)

InputValueTypesAxisEquals Method (InputValueTypesAxis)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    InputValueTypesAxis other
)
public:
virtual bool Equals(
    InputValueTypesAxis^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesInputValueTypesAxis

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.InputValue.Types.Axis.Equals(VisualComponents.Messages.InputValue.Types.Axis)"]

Implements

IEquatableTEquals(T)
See Also

Reference

InputValueTypesAxis Class
Equals Overload
VisualComponents.Messages Namespace


InputValue.Types.Axis.GetHashCode Method

InputValueTypesAxisGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.InputValue.Types.Axis.GetHashCode"]

See Also

Reference

InputValueTypesAxis Class
VisualComponents.Messages Namespace


Axis.MergeFrom Method

AxisMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(InputValueTypesAxis) |
Top
See Also

Reference

InputValueTypesAxis Class
VisualComponents.Messages Namespace


InputValue.Types.Axis.MergeFrom Method (CodedInputStream)

InputValueTypesAxisMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

InputValueTypesAxis Class
MergeFrom Overload
VisualComponents.Messages Namespace


InputValue.Types.Axis.MergeFrom Method (InputValue.Types.Axis)

InputValueTypesAxisMergeFrom Method (InputValueTypesAxis)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    InputValueTypesAxis other
)
public:
virtual void MergeFrom(
    InputValueTypesAxis^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesInputValueTypesAxis

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

InputValueTypesAxis Class
MergeFrom Overload
VisualComponents.Messages Namespace


InputValue.Types.Axis.ToString Method

InputValueTypesAxisToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.InputValue.Types.Axis.ToString"]

See Also

Reference

InputValueTypesAxis Class
VisualComponents.Messages Namespace


InputValue.Types.Axis.WriteTo Method

InputValueTypesAxisWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

InputValueTypesAxis Class
VisualComponents.Messages Namespace


Axis Fields

The InputValueTypesAxis type exposes the following members.

Fields
Name | Description
ValueFieldNumber | Field number for the "value" field.
Top
See Also

Reference

InputValueTypesAxis Class
VisualComponents.Messages Namespace


InputValue.Types.Axis.ValueFieldNumber Field

InputValueTypesAxisValueFieldNumber Field

Field number for the "value" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ValueFieldNumber = 1
public:
literal int ValueFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

InputValueTypesAxis Class
VisualComponents.Messages Namespace


InputValue.Types.Axis2D Class

InputValueTypesAxis2D Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesInputValueTypesAxis2D

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class Axis2D : IMessage<InputValueTypesAxis2D>,
    IMessage, IEquatable<InputValueTypesAxis2D>, IDeepCloneable<InputValueTypesAxis2D>
public ref class Axis2D sealed : IMessage<InputValueTypesAxis2D^>,
    IMessage, IEquatable<InputValueTypesAxis2D^>, IDeepCloneable<InputValueTypesAxis2D^>

The InputValueTypesAxis2D type exposes the following members.

Constructors
 | Name | Description
Public method | InputValueTypesAxis2D | Initializes a new instance of the InputValueTypesAxis2D class
Public method | InputValueTypesAxis2D(InputValueTypesAxis2D) | Initializes a new instance of the InputValueTypesAxis2D class
Top
Properties
 | Name | Description
 | Descriptor |
 | Parser |
Public property | X |
Public property | Y |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(InputValueTypesAxis2D) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(InputValueTypesAxis2D) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
XFieldNumber | Field number for the "x" field.
YFieldNumber | Field number for the "y" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


Axis2D Constructor

Overload List
 | Name | Description
Public method | InputValueTypesAxis2D | Initializes a new instance of the InputValueTypesAxis2D class
Public method | InputValueTypesAxis2D(InputValueTypesAxis2D) | Initializes a new instance of the InputValueTypesAxis2D class
Top
See Also

Reference

InputValueTypesAxis2D Class
VisualComponents.Messages Namespace


InputValue.Types.Axis2D Constructor

InputValueTypesAxis2D Constructor

Initializes a new instance of the InputValueTypesAxis2D class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Axis2D()
public:
Axis2D()
See Also

Reference

InputValueTypesAxis2D Class
InputValueTypesAxis2D Overload
VisualComponents.Messages Namespace


InputValue.Types.Axis2D Constructor (InputValue.Types.Axis2D)

InputValueTypesAxis2D Constructor (InputValueTypesAxis2D)

Initializes a new instance of the InputValueTypesAxis2D class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Axis2D(
    InputValueTypesAxis2D other
)
public:
Axis2D(
    InputValueTypesAxis2D^ other
)

Parameters

other
Type: VisualComponents.MessagesInputValueTypesAxis2D
See Also

Reference

InputValueTypesAxis2D Class
InputValueTypesAxis2D Overload
VisualComponents.Messages Namespace


Axis2D Properties

The InputValueTypesAxis2D type exposes the following members.

Properties
 | Name | Description
 | Descriptor |
 | Parser |
Public property | X |
Public property | Y |
Top
See Also

Reference

InputValueTypesAxis2D Class
VisualComponents.Messages Namespace


InputValue.Types.Axis2D.Descriptor Property

InputValueTypesAxis2DDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

InputValueTypesAxis2D Class
VisualComponents.Messages Namespace


InputValue.Types.Axis2D.Parser Property

InputValueTypesAxis2DParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<InputValueTypesAxis2D> Parser { get; }
public:
static property MessageParser<InputValueTypesAxis2D^>^ Parser {
    MessageParser<InputValueTypesAxis2D^>^ get ();
}

Property Value

Type: MessageParserInputValueTypesAxis2D
See Also

Reference

InputValueTypesAxis2D Class
VisualComponents.Messages Namespace


InputValue.Types.Axis2D.X Property

InputValueTypesAxis2DX Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float X { get; set; }
public:
property float X {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

InputValueTypesAxis2D Class
VisualComponents.Messages Namespace


InputValue.Types.Axis2D.Y Property

InputValueTypesAxis2DY Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float Y { get; set; }
public:
property float Y {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

InputValueTypesAxis2D Class
VisualComponents.Messages Namespace


Axis2D Methods

The InputValueTypesAxis2D type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(InputValueTypesAxis2D) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(InputValueTypesAxis2D) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

InputValueTypesAxis2D Class
VisualComponents.Messages Namespace


InputValue.Types.Axis2D.CalculateSize Method

InputValueTypesAxis2DCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.InputValue.Types.Axis2D.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

InputValueTypesAxis2D Class
VisualComponents.Messages Namespace


InputValue.Types.Axis2D.Clone Method

InputValueTypesAxis2DClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InputValueTypesAxis2D Clone()
public:
virtual InputValueTypesAxis2D^ Clone() sealed

Return Value

Type: InputValueTypesAxis2D

[Missing <returns> documentation for "M:VisualComponents.Messages.InputValue.Types.Axis2D.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

InputValueTypesAxis2D Class
VisualComponents.Messages Namespace


Axis2D.Equals Method

Axis2DEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(InputValueTypesAxis2D) |
Top
See Also

Reference

InputValueTypesAxis2D Class
VisualComponents.Messages Namespace


InputValue.Types.Axis2D.Equals Method (Object)

InputValueTypesAxis2DEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.InputValue.Types.Axis2D.Equals(System.Object)"]

See Also

Reference

InputValueTypesAxis2D Class
Equals Overload
VisualComponents.Messages Namespace


InputValue.Types.Axis2D.Equals Method (InputValue.Types.Axis2D)

InputValueTypesAxis2DEquals Method (InputValueTypesAxis2D)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    InputValueTypesAxis2D other
)
public:
virtual bool Equals(
    InputValueTypesAxis2D^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesInputValueTypesAxis2D

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.InputValue.Types.Axis2D.Equals(VisualComponents.Messages.InputValue.Types.Axis2D)"]

Implements

IEquatableTEquals(T)
See Also

Reference

InputValueTypesAxis2D Class
Equals Overload
VisualComponents.Messages Namespace


InputValue.Types.Axis2D.GetHashCode Method

InputValueTypesAxis2DGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.InputValue.Types.Axis2D.GetHashCode"]

See Also

Reference

InputValueTypesAxis2D Class
VisualComponents.Messages Namespace


Axis2D.MergeFrom Method

Axis2DMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(InputValueTypesAxis2D) |
Top
See Also

Reference

InputValueTypesAxis2D Class
VisualComponents.Messages Namespace


InputValue.Types.Axis2D.MergeFrom Method (CodedInputStream)

InputValueTypesAxis2DMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

InputValueTypesAxis2D Class
MergeFrom Overload
VisualComponents.Messages Namespace


InputValue.Types.Axis2D.MergeFrom Method (InputValue.Types.Axis2D)

InputValueTypesAxis2DMergeFrom Method (InputValueTypesAxis2D)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    InputValueTypesAxis2D other
)
public:
virtual void MergeFrom(
    InputValueTypesAxis2D^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesInputValueTypesAxis2D

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

InputValueTypesAxis2D Class
MergeFrom Overload
VisualComponents.Messages Namespace


InputValue.Types.Axis2D.ToString Method

InputValueTypesAxis2DToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.InputValue.Types.Axis2D.ToString"]

See Also

Reference

InputValueTypesAxis2D Class
VisualComponents.Messages Namespace


InputValue.Types.Axis2D.WriteTo Method

InputValueTypesAxis2DWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

InputValueTypesAxis2D Class
VisualComponents.Messages Namespace


Axis2D Fields

The InputValueTypesAxis2D type exposes the following members.

Fields
Name | Description
XFieldNumber | Field number for the "x" field.
YFieldNumber | Field number for the "y" field.
Top
See Also

Reference

InputValueTypesAxis2D Class
VisualComponents.Messages Namespace


InputValue.Types.Axis2D.XFieldNumber Field

InputValueTypesAxis2DXFieldNumber Field

Field number for the "x" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int XFieldNumber = 1
public:
literal int XFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

InputValueTypesAxis2D Class
VisualComponents.Messages Namespace


InputValue.Types.Axis2D.YFieldNumber Field

InputValueTypesAxis2DYFieldNumber Field

Field number for the "y" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int YFieldNumber = 2
public:
literal int YFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

InputValueTypesAxis2D Class
VisualComponents.Messages Namespace


InputValue.Types.Button Class

InputValueTypesButton Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesInputValueTypesButton

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class Button : IMessage<InputValueTypesButton>,
    IMessage, IEquatable<InputValueTypesButton>, IDeepCloneable<InputValueTypesButton>
public ref class Button sealed : IMessage<InputValueTypesButton^>,
    IMessage, IEquatable<InputValueTypesButton^>, IDeepCloneable<InputValueTypesButton^>

The InputValueTypesButton type exposes the following members.

Constructors
 | Name | Description
Public method | InputValueTypesButton | Initializes a new instance of the InputValueTypesButton class
Public method | InputValueTypesButton(InputValueTypesButton) | Initializes a new instance of the InputValueTypesButton class
Top
Properties
 | Name | Description
 | Descriptor |
 | Parser |
Public property | Value |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(InputValueTypesButton) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(InputValueTypesButton) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
ValueFieldNumber | Field number for the "value" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


Button Constructor

Overload List
 | Name | Description
Public method | InputValueTypesButton | Initializes a new instance of the InputValueTypesButton class
Public method | InputValueTypesButton(InputValueTypesButton) | Initializes a new instance of the InputValueTypesButton class
Top
See Also

Reference

InputValueTypesButton Class
VisualComponents.Messages Namespace


InputValue.Types.Button Constructor

InputValueTypesButton Constructor

Initializes a new instance of the InputValueTypesButton class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Button()
public:
Button()
See Also

Reference

InputValueTypesButton Class
InputValueTypesButton Overload
VisualComponents.Messages Namespace


InputValue.Types.Button Constructor (InputValue.Types.Button)

InputValueTypesButton Constructor (InputValueTypesButton)

Initializes a new instance of the InputValueTypesButton class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Button(
    InputValueTypesButton other
)
public:
Button(
    InputValueTypesButton^ other
)

Parameters

other
Type: VisualComponents.MessagesInputValueTypesButton
See Also

Reference

InputValueTypesButton Class
InputValueTypesButton Overload
VisualComponents.Messages Namespace


Button Properties

The InputValueTypesButton type exposes the following members.

Properties
 | Name | Description
 | Descriptor |
 | Parser |
Public property | Value |
Top
See Also

Reference

InputValueTypesButton Class
VisualComponents.Messages Namespace


InputValue.Types.Button.Descriptor Property

InputValueTypesButtonDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

InputValueTypesButton Class
VisualComponents.Messages Namespace


InputValue.Types.Button.Parser Property

InputValueTypesButtonParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<InputValueTypesButton> Parser { get; }
public:
static property MessageParser<InputValueTypesButton^>^ Parser {
    MessageParser<InputValueTypesButton^>^ get ();
}

Property Value

Type: MessageParserInputValueTypesButton
See Also

Reference

InputValueTypesButton Class
VisualComponents.Messages Namespace


InputValue.Types.Button.Value Property

InputValueTypesButtonValue Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Value { get; set; }
public:
property bool Value {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

InputValueTypesButton Class
VisualComponents.Messages Namespace


Button Methods

The InputValueTypesButton type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(InputValueTypesButton) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(InputValueTypesButton) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

InputValueTypesButton Class
VisualComponents.Messages Namespace


InputValue.Types.Button.CalculateSize Method

InputValueTypesButtonCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.InputValue.Types.Button.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

InputValueTypesButton Class
VisualComponents.Messages Namespace


InputValue.Types.Button.Clone Method

InputValueTypesButtonClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InputValueTypesButton Clone()
public:
virtual InputValueTypesButton^ Clone() sealed

Return Value

Type: InputValueTypesButton

[Missing <returns> documentation for "M:VisualComponents.Messages.InputValue.Types.Button.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

InputValueTypesButton Class
VisualComponents.Messages Namespace


Button.Equals Method

ButtonEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(InputValueTypesButton) |
Top
See Also

Reference

InputValueTypesButton Class
VisualComponents.Messages Namespace


InputValue.Types.Button.Equals Method (Object)

InputValueTypesButtonEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.InputValue.Types.Button.Equals(System.Object)"]

See Also

Reference

InputValueTypesButton Class
Equals Overload
VisualComponents.Messages Namespace


InputValue.Types.Button.Equals Method (InputValue.Types.Button)

InputValueTypesButtonEquals Method (InputValueTypesButton)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    InputValueTypesButton other
)
public:
virtual bool Equals(
    InputValueTypesButton^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesInputValueTypesButton

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.InputValue.Types.Button.Equals(VisualComponents.Messages.InputValue.Types.Button)"]

Implements

IEquatableTEquals(T)
See Also

Reference

InputValueTypesButton Class
Equals Overload
VisualComponents.Messages Namespace


InputValue.Types.Button.GetHashCode Method

InputValueTypesButtonGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.InputValue.Types.Button.GetHashCode"]

See Also

Reference

InputValueTypesButton Class
VisualComponents.Messages Namespace


Button.MergeFrom Method

ButtonMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(InputValueTypesButton) |
Top
See Also

Reference

InputValueTypesButton Class
VisualComponents.Messages Namespace


InputValue.Types.Button.MergeFrom Method (CodedInputStream)

InputValueTypesButtonMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

InputValueTypesButton Class
MergeFrom Overload
VisualComponents.Messages Namespace


InputValue.Types.Button.MergeFrom Method (InputValue.Types.Button)

InputValueTypesButtonMergeFrom Method (InputValueTypesButton)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    InputValueTypesButton other
)
public:
virtual void MergeFrom(
    InputValueTypesButton^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesInputValueTypesButton

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

InputValueTypesButton Class
MergeFrom Overload
VisualComponents.Messages Namespace


InputValue.Types.Button.ToString Method

InputValueTypesButtonToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.InputValue.Types.Button.ToString"]

See Also

Reference

InputValueTypesButton Class
VisualComponents.Messages Namespace


InputValue.Types.Button.WriteTo Method

InputValueTypesButtonWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

InputValueTypesButton Class
VisualComponents.Messages Namespace


Button Fields

The InputValueTypesButton type exposes the following members.

Fields
Name | Description
ValueFieldNumber | Field number for the "value" field.
Top
See Also

Reference

InputValueTypesButton Class
VisualComponents.Messages Namespace


InputValue.Types.Button.ValueFieldNumber Field

InputValueTypesButtonValueFieldNumber Field

Field number for the "value" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ValueFieldNumber = 1
public:
literal int ValueFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

InputValueTypesButton Class
VisualComponents.Messages Namespace


LoadLayoutEcat Class

Note: this message requires CACHED_VR_ECAT_SUPPORT
Inheritance Hierarchy
SystemObject
VisualComponents.MessagesLoadLayoutEcat

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class LoadLayoutEcat : IMessage<LoadLayoutEcat>,
    IMessage, IEquatable<LoadLayoutEcat>, IDeepCloneable<LoadLayoutEcat>
public ref class LoadLayoutEcat sealed : IMessage<LoadLayoutEcat^>,
    IMessage, IEquatable<LoadLayoutEcat^>, IDeepCloneable<LoadLayoutEcat^>

The LoadLayoutEcat type exposes the following members.

Constructors
 | Name | Description
Public method | LoadLayoutEcat | Initializes a new instance of the LoadLayoutEcat class
Public method | LoadLayoutEcat(LoadLayoutEcat) | Initializes a new instance of the LoadLayoutEcat class
Top
Properties
 | Name | Description
 | Descriptor |
Public property | DoClear |
Public property | IsLoaded |
Public property | LayoutName |
 | Parser |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(LoadLayoutEcat) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(LoadLayoutEcat) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
DoClearFieldNumber | Field number for the "do_clear" field.
IsLoadedFieldNumber | Field number for the "is_loaded" field.
LayoutNameFieldNumber | Field number for the "layout_name" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


LoadLayoutEcat Constructor

Overload List
 | Name | Description
Public method | LoadLayoutEcat | Initializes a new instance of the LoadLayoutEcat class
Public method | LoadLayoutEcat(LoadLayoutEcat) | Initializes a new instance of the LoadLayoutEcat class
Top
See Also

Reference

LoadLayoutEcat Class
VisualComponents.Messages Namespace


LoadLayoutEcat Constructor

Initializes a new instance of the LoadLayoutEcat class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LoadLayoutEcat()
public:
LoadLayoutEcat()
See Also

Reference

LoadLayoutEcat Class
LoadLayoutEcat Overload
VisualComponents.Messages Namespace


LoadLayoutEcat Constructor (LoadLayoutEcat)

Initializes a new instance of the LoadLayoutEcat class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LoadLayoutEcat(
    LoadLayoutEcat other
)
public:
LoadLayoutEcat(
    LoadLayoutEcat^ other
)

Parameters

other
Type: VisualComponents.MessagesLoadLayoutEcat
See Also

Reference

LoadLayoutEcat Class
LoadLayoutEcat Overload
VisualComponents.Messages Namespace


LoadLayoutEcat Properties

The LoadLayoutEcat type exposes the following members.

Properties
 | Name | Description
 | Descriptor |
Public property | DoClear |
Public property | IsLoaded |
Public property | LayoutName |
 | Parser |
Top
See Also

Reference

LoadLayoutEcat Class
VisualComponents.Messages Namespace


LoadLayoutEcat.Descriptor Property

LoadLayoutEcatDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

LoadLayoutEcat Class
VisualComponents.Messages Namespace


LoadLayoutEcat.DoClear Property

LoadLayoutEcatDoClear Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool DoClear { get; set; }
public:
property bool DoClear {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LoadLayoutEcat Class
VisualComponents.Messages Namespace


LoadLayoutEcat.IsLoaded Property

LoadLayoutEcatIsLoaded Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsLoaded { get; set; }
public:
property bool IsLoaded {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LoadLayoutEcat Class
VisualComponents.Messages Namespace


LoadLayoutEcat.LayoutName Property

LoadLayoutEcatLayoutName Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string LayoutName { get; set; }
public:
property String^ LayoutName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LoadLayoutEcat Class
VisualComponents.Messages Namespace


LoadLayoutEcat.Parser Property

LoadLayoutEcatParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<LoadLayoutEcat> Parser { get; }
public:
static property MessageParser<LoadLayoutEcat^>^ Parser {
    MessageParser<LoadLayoutEcat^>^ get ();
}

Property Value

Type: MessageParserLoadLayoutEcat
See Also

Reference

LoadLayoutEcat Class
VisualComponents.Messages Namespace


LoadLayoutEcat Methods

The LoadLayoutEcat type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(LoadLayoutEcat) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(LoadLayoutEcat) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LoadLayoutEcat Class
VisualComponents.Messages Namespace


LoadLayoutEcat.CalculateSize Method

LoadLayoutEcatCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.LoadLayoutEcat.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

LoadLayoutEcat Class
VisualComponents.Messages Namespace


LoadLayoutEcat.Clone Method

LoadLayoutEcatClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LoadLayoutEcat Clone()
public:
virtual LoadLayoutEcat^ Clone() sealed

Return Value

Type: LoadLayoutEcat

[Missing <returns> documentation for "M:VisualComponents.Messages.LoadLayoutEcat.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

LoadLayoutEcat Class
VisualComponents.Messages Namespace


LoadLayoutEcat.Equals Method

LoadLayoutEcatEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(LoadLayoutEcat) |
Top
See Also

Reference

LoadLayoutEcat Class
VisualComponents.Messages Namespace


LoadLayoutEcat.Equals Method (Object)

LoadLayoutEcatEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.LoadLayoutEcat.Equals(System.Object)"]

See Also

Reference

LoadLayoutEcat Class
Equals Overload
VisualComponents.Messages Namespace


LoadLayoutEcat.Equals Method (LoadLayoutEcat)

LoadLayoutEcatEquals Method (LoadLayoutEcat)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    LoadLayoutEcat other
)
public:
virtual bool Equals(
    LoadLayoutEcat^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesLoadLayoutEcat

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.LoadLayoutEcat.Equals(VisualComponents.Messages.LoadLayoutEcat)"]

Implements

IEquatableTEquals(T)
See Also

Reference

LoadLayoutEcat Class
Equals Overload
VisualComponents.Messages Namespace


LoadLayoutEcat.GetHashCode Method

LoadLayoutEcatGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.LoadLayoutEcat.GetHashCode"]

See Also

Reference

LoadLayoutEcat Class
VisualComponents.Messages Namespace


LoadLayoutEcat.MergeFrom Method

LoadLayoutEcatMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(LoadLayoutEcat) |
Top
See Also

Reference

LoadLayoutEcat Class
VisualComponents.Messages Namespace


LoadLayoutEcat.MergeFrom Method (CodedInputStream)

LoadLayoutEcatMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

LoadLayoutEcat Class
MergeFrom Overload
VisualComponents.Messages Namespace


LoadLayoutEcat.MergeFrom Method (LoadLayoutEcat)

LoadLayoutEcatMergeFrom Method (LoadLayoutEcat)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    LoadLayoutEcat other
)
public:
virtual void MergeFrom(
    LoadLayoutEcat^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesLoadLayoutEcat

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

LoadLayoutEcat Class
MergeFrom Overload
VisualComponents.Messages Namespace


LoadLayoutEcat.ToString Method

LoadLayoutEcatToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.LoadLayoutEcat.ToString"]

See Also

Reference

LoadLayoutEcat Class
VisualComponents.Messages Namespace


LoadLayoutEcat.WriteTo Method

LoadLayoutEcatWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

LoadLayoutEcat Class
VisualComponents.Messages Namespace


LoadLayoutEcat Fields

The LoadLayoutEcat type exposes the following members.

Fields
Name | Description
DoClearFieldNumber | Field number for the "do_clear" field.
IsLoadedFieldNumber | Field number for the "is_loaded" field.
LayoutNameFieldNumber | Field number for the "layout_name" field.
Top
See Also

Reference

LoadLayoutEcat Class
VisualComponents.Messages Namespace


LoadLayoutEcat.DoClearFieldNumber Field

LoadLayoutEcatDoClearFieldNumber Field

Field number for the "do_clear" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int DoClearFieldNumber = 2
public:
literal int DoClearFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

LoadLayoutEcat Class
VisualComponents.Messages Namespace


LoadLayoutEcat.IsLoadedFieldNumber Field

LoadLayoutEcatIsLoadedFieldNumber Field

Field number for the "is_loaded" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int IsLoadedFieldNumber = 3
public:
literal int IsLoadedFieldNumber = 3

Field Value

Type: Int32
See Also

Reference

LoadLayoutEcat Class
VisualComponents.Messages Namespace


LoadLayoutEcat.LayoutNameFieldNumber Field

LoadLayoutEcatLayoutNameFieldNumber Field

Field number for the "layout_name" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int LayoutNameFieldNumber = 1
public:
literal int LayoutNameFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

LoadLayoutEcat Class
VisualComponents.Messages Namespace


LoadLayoutSimple Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesLoadLayoutSimple

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class LoadLayoutSimple : IMessage<LoadLayoutSimple>,
    IMessage, IEquatable<LoadLayoutSimple>, IDeepCloneable<LoadLayoutSimple>
public ref class LoadLayoutSimple sealed : IMessage<LoadLayoutSimple^>,
    IMessage, IEquatable<LoadLayoutSimple^>, IDeepCloneable<LoadLayoutSimple^>

The LoadLayoutSimple type exposes the following members.

Constructors
 | Name | Description
Public method | LoadLayoutSimple | Initializes a new instance of the LoadLayoutSimple class
Public method | LoadLayoutSimple(LoadLayoutSimple) | Initializes a new instance of the LoadLayoutSimple class
Top
Properties
 | Name | Description
 | Descriptor |
Public property | DoClear |
Public property | IsLoaded |
Public property | LayoutName |
 | Parser |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(LoadLayoutSimple) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(LoadLayoutSimple) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
DoClearFieldNumber | Field number for the "do_clear" field.
IsLoadedFieldNumber | Field number for the "is_loaded" field.
LayoutNameFieldNumber | Field number for the "layout_name" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


LoadLayoutSimple Constructor

Overload List
 | Name | Description
Public method | LoadLayoutSimple | Initializes a new instance of the LoadLayoutSimple class
Public method | LoadLayoutSimple(LoadLayoutSimple) | Initializes a new instance of the LoadLayoutSimple class
Top
See Also

Reference

LoadLayoutSimple Class
VisualComponents.Messages Namespace


LoadLayoutSimple Constructor

Initializes a new instance of the LoadLayoutSimple class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LoadLayoutSimple()
public:
LoadLayoutSimple()
See Also

Reference

LoadLayoutSimple Class
LoadLayoutSimple Overload
VisualComponents.Messages Namespace


LoadLayoutSimple Constructor (LoadLayoutSimple)

Initializes a new instance of the LoadLayoutSimple class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LoadLayoutSimple(
    LoadLayoutSimple other
)
public:
LoadLayoutSimple(
    LoadLayoutSimple^ other
)

Parameters

other
Type: VisualComponents.MessagesLoadLayoutSimple
See Also

Reference

LoadLayoutSimple Class
LoadLayoutSimple Overload
VisualComponents.Messages Namespace


LoadLayoutSimple Properties

The LoadLayoutSimple type exposes the following members.

Properties
 | Name | Description
 | Descriptor |
Public property | DoClear |
Public property | IsLoaded |
Public property | LayoutName |
 | Parser |
Top
See Also

Reference

LoadLayoutSimple Class
VisualComponents.Messages Namespace


LoadLayoutSimple.Descriptor Property

LoadLayoutSimpleDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

LoadLayoutSimple Class
VisualComponents.Messages Namespace


LoadLayoutSimple.DoClear Property

LoadLayoutSimpleDoClear Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool DoClear { get; set; }
public:
property bool DoClear {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LoadLayoutSimple Class
VisualComponents.Messages Namespace


LoadLayoutSimple.IsLoaded Property

LoadLayoutSimpleIsLoaded Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsLoaded { get; set; }
public:
property bool IsLoaded {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LoadLayoutSimple Class
VisualComponents.Messages Namespace


LoadLayoutSimple.LayoutName Property

LoadLayoutSimpleLayoutName Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string LayoutName { get; set; }
public:
property String^ LayoutName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LoadLayoutSimple Class
VisualComponents.Messages Namespace


LoadLayoutSimple.Parser Property

LoadLayoutSimpleParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<LoadLayoutSimple> Parser { get; }
public:
static property MessageParser<LoadLayoutSimple^>^ Parser {
    MessageParser<LoadLayoutSimple^>^ get ();
}

Property Value

Type: MessageParserLoadLayoutSimple
See Also

Reference

LoadLayoutSimple Class
VisualComponents.Messages Namespace


LoadLayoutSimple Methods

The LoadLayoutSimple type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(LoadLayoutSimple) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(LoadLayoutSimple) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LoadLayoutSimple Class
VisualComponents.Messages Namespace


LoadLayoutSimple.CalculateSize Method

LoadLayoutSimpleCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.LoadLayoutSimple.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

LoadLayoutSimple Class
VisualComponents.Messages Namespace


LoadLayoutSimple.Clone Method

LoadLayoutSimpleClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LoadLayoutSimple Clone()
public:
virtual LoadLayoutSimple^ Clone() sealed

Return Value

Type: LoadLayoutSimple

[Missing <returns> documentation for "M:VisualComponents.Messages.LoadLayoutSimple.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

LoadLayoutSimple Class
VisualComponents.Messages Namespace


LoadLayoutSimple.Equals Method

LoadLayoutSimpleEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(LoadLayoutSimple) |
Top
See Also

Reference

LoadLayoutSimple Class
VisualComponents.Messages Namespace


LoadLayoutSimple.Equals Method (Object)

LoadLayoutSimpleEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.LoadLayoutSimple.Equals(System.Object)"]

See Also

Reference

LoadLayoutSimple Class
Equals Overload
VisualComponents.Messages Namespace


LoadLayoutSimple.Equals Method (LoadLayoutSimple)

LoadLayoutSimpleEquals Method (LoadLayoutSimple)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    LoadLayoutSimple other
)
public:
virtual bool Equals(
    LoadLayoutSimple^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesLoadLayoutSimple

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.LoadLayoutSimple.Equals(VisualComponents.Messages.LoadLayoutSimple)"]

Implements

IEquatableTEquals(T)
See Also

Reference

LoadLayoutSimple Class
Equals Overload
VisualComponents.Messages Namespace


LoadLayoutSimple.GetHashCode Method

LoadLayoutSimpleGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.LoadLayoutSimple.GetHashCode"]

See Also

Reference

LoadLayoutSimple Class
VisualComponents.Messages Namespace


LoadLayoutSimple.MergeFrom Method

LoadLayoutSimpleMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(LoadLayoutSimple) |
Top
See Also

Reference

LoadLayoutSimple Class
VisualComponents.Messages Namespace


LoadLayoutSimple.MergeFrom Method (CodedInputStream)

LoadLayoutSimpleMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

LoadLayoutSimple Class
MergeFrom Overload
VisualComponents.Messages Namespace


LoadLayoutSimple.MergeFrom Method (LoadLayoutSimple)

LoadLayoutSimpleMergeFrom Method (LoadLayoutSimple)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    LoadLayoutSimple other
)
public:
virtual void MergeFrom(
    LoadLayoutSimple^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesLoadLayoutSimple

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

LoadLayoutSimple Class
MergeFrom Overload
VisualComponents.Messages Namespace


LoadLayoutSimple.ToString Method

LoadLayoutSimpleToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.LoadLayoutSimple.ToString"]

See Also

Reference

LoadLayoutSimple Class
VisualComponents.Messages Namespace


LoadLayoutSimple.WriteTo Method

LoadLayoutSimpleWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

LoadLayoutSimple Class
VisualComponents.Messages Namespace


LoadLayoutSimple Fields

The LoadLayoutSimple type exposes the following members.

Fields
Name | Description
DoClearFieldNumber | Field number for the "do_clear" field.
IsLoadedFieldNumber | Field number for the "is_loaded" field.
LayoutNameFieldNumber | Field number for the "layout_name" field.
Top
See Also

Reference

LoadLayoutSimple Class
VisualComponents.Messages Namespace


LoadLayoutSimple.DoClearFieldNumber Field

LoadLayoutSimpleDoClearFieldNumber Field

Field number for the "do_clear" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int DoClearFieldNumber = 2
public:
literal int DoClearFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

LoadLayoutSimple Class
VisualComponents.Messages Namespace


LoadLayoutSimple.IsLoadedFieldNumber Field

LoadLayoutSimpleIsLoadedFieldNumber Field

Field number for the "is_loaded" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int IsLoadedFieldNumber = 3
public:
literal int IsLoadedFieldNumber = 3

Field Value

Type: Int32
See Also

Reference

LoadLayoutSimple Class
VisualComponents.Messages Namespace


LoadLayoutSimple.LayoutNameFieldNumber Field

LoadLayoutSimpleLayoutNameFieldNumber Field

Field number for the "layout_name" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int LayoutNameFieldNumber = 1
public:
literal int LayoutNameFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

LoadLayoutSimple Class
VisualComponents.Messages Namespace


MaxUpdateRate Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesMaxUpdateRate

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class MaxUpdateRate : IMessage<MaxUpdateRate>,
    IMessage, IEquatable<MaxUpdateRate>, IDeepCloneable<MaxUpdateRate>
public ref class MaxUpdateRate sealed : IMessage<MaxUpdateRate^>,
    IMessage, IEquatable<MaxUpdateRate^>, IDeepCloneable<MaxUpdateRate^>

The MaxUpdateRate type exposes the following members.

Constructors
 | Name | Description
Public method | MaxUpdateRate | Initializes a new instance of the MaxUpdateRate class
Public method | MaxUpdateRate(MaxUpdateRate) | Initializes a new instance of the MaxUpdateRate class
Top
Properties
 | Name | Description
 | Descriptor |
 | Parser |
Public property | Value |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(MaxUpdateRate) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(MaxUpdateRate) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
ValueFieldNumber | Field number for the "value" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


MaxUpdateRate Constructor

Overload List
 | Name | Description
Public method | MaxUpdateRate | Initializes a new instance of the MaxUpdateRate class
Public method | MaxUpdateRate(MaxUpdateRate) | Initializes a new instance of the MaxUpdateRate class
Top
See Also

Reference

MaxUpdateRate Class
VisualComponents.Messages Namespace


MaxUpdateRate Constructor

Initializes a new instance of the MaxUpdateRate class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MaxUpdateRate()
public:
MaxUpdateRate()
See Also

Reference

MaxUpdateRate Class
MaxUpdateRate Overload
VisualComponents.Messages Namespace


MaxUpdateRate Constructor (MaxUpdateRate)

Initializes a new instance of the MaxUpdateRate class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MaxUpdateRate(
    MaxUpdateRate other
)
public:
MaxUpdateRate(
    MaxUpdateRate^ other
)

Parameters

other
Type: VisualComponents.MessagesMaxUpdateRate
See Also

Reference

MaxUpdateRate Class
MaxUpdateRate Overload
VisualComponents.Messages Namespace


MaxUpdateRate Properties

The MaxUpdateRate type exposes the following members.

Properties
 | Name | Description
 | Descriptor |
 | Parser |
Public property | Value |
Top
See Also

Reference

MaxUpdateRate Class
VisualComponents.Messages Namespace


MaxUpdateRate.Descriptor Property

MaxUpdateRateDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

MaxUpdateRate Class
VisualComponents.Messages Namespace


MaxUpdateRate.Parser Property

MaxUpdateRateParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<MaxUpdateRate> Parser { get; }
public:
static property MessageParser<MaxUpdateRate^>^ Parser {
    MessageParser<MaxUpdateRate^>^ get ();
}

Property Value

Type: MessageParserMaxUpdateRate
See Also

Reference

MaxUpdateRate Class
VisualComponents.Messages Namespace


MaxUpdateRate.Value Property

MaxUpdateRateValue Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Value { get; set; }
public:
property int Value {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

MaxUpdateRate Class
VisualComponents.Messages Namespace


MaxUpdateRate Methods

The MaxUpdateRate type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(MaxUpdateRate) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(MaxUpdateRate) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MaxUpdateRate Class
VisualComponents.Messages Namespace


MaxUpdateRate.CalculateSize Method

MaxUpdateRateCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.MaxUpdateRate.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

MaxUpdateRate Class
VisualComponents.Messages Namespace


MaxUpdateRate.Clone Method

MaxUpdateRateClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MaxUpdateRate Clone()
public:
virtual MaxUpdateRate^ Clone() sealed

Return Value

Type: MaxUpdateRate

[Missing <returns> documentation for "M:VisualComponents.Messages.MaxUpdateRate.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

MaxUpdateRate Class
VisualComponents.Messages Namespace


MaxUpdateRate.Equals Method

MaxUpdateRateEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(MaxUpdateRate) |
Top
See Also

Reference

MaxUpdateRate Class
VisualComponents.Messages Namespace


MaxUpdateRate.Equals Method (Object)

MaxUpdateRateEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.MaxUpdateRate.Equals(System.Object)"]

See Also

Reference

MaxUpdateRate Class
Equals Overload
VisualComponents.Messages Namespace


MaxUpdateRate.Equals Method (MaxUpdateRate)

MaxUpdateRateEquals Method (MaxUpdateRate)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    MaxUpdateRate other
)
public:
virtual bool Equals(
    MaxUpdateRate^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesMaxUpdateRate

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.MaxUpdateRate.Equals(VisualComponents.Messages.MaxUpdateRate)"]

Implements

IEquatableTEquals(T)
See Also

Reference

MaxUpdateRate Class
Equals Overload
VisualComponents.Messages Namespace


MaxUpdateRate.GetHashCode Method

MaxUpdateRateGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.MaxUpdateRate.GetHashCode"]

See Also

Reference

MaxUpdateRate Class
VisualComponents.Messages Namespace


MaxUpdateRate.MergeFrom Method

MaxUpdateRateMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(MaxUpdateRate) |
Top
See Also

Reference

MaxUpdateRate Class
VisualComponents.Messages Namespace


MaxUpdateRate.MergeFrom Method (CodedInputStream)

MaxUpdateRateMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

MaxUpdateRate Class
MergeFrom Overload
VisualComponents.Messages Namespace


MaxUpdateRate.MergeFrom Method (MaxUpdateRate)

MaxUpdateRateMergeFrom Method (MaxUpdateRate)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    MaxUpdateRate other
)
public:
virtual void MergeFrom(
    MaxUpdateRate^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesMaxUpdateRate

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

MaxUpdateRate Class
MergeFrom Overload
VisualComponents.Messages Namespace


MaxUpdateRate.ToString Method

MaxUpdateRateToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.MaxUpdateRate.ToString"]

See Also

Reference

MaxUpdateRate Class
VisualComponents.Messages Namespace


MaxUpdateRate.WriteTo Method

MaxUpdateRateWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

MaxUpdateRate Class
VisualComponents.Messages Namespace


MaxUpdateRate Fields

The MaxUpdateRate type exposes the following members.

Fields
Name | Description
ValueFieldNumber | Field number for the "value" field.
Top
See Also

Reference

MaxUpdateRate Class
VisualComponents.Messages Namespace


MaxUpdateRate.ValueFieldNumber Field

MaxUpdateRateValueFieldNumber Field

Field number for the "value" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ValueFieldNumber = 1
public:
literal int ValueFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

MaxUpdateRate Class
VisualComponents.Messages Namespace


MoveComponent Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesMoveComponent

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class MoveComponent : IMessage<MoveComponent>,
    IMessage, IEquatable<MoveComponent>, IDeepCloneable<MoveComponent>
public ref class MoveComponent sealed : IMessage<MoveComponent^>,
    IMessage, IEquatable<MoveComponent^>, IDeepCloneable<MoveComponent^>

The MoveComponent type exposes the following members.

Constructors
 | Name | Description
Public method | MoveComponent | Initializes a new instance of the MoveComponent class
Public method | MoveComponent(MoveComponent) | Initializes a new instance of the MoveComponent class
Top
Properties
 | Name | Description
Public property | Begin |
Public property | CameraFov |
Public property | CameraNearFar |
Public property | CameraPosition |
Public property | CameraRotation |
Public property | ComponentId |
 | Descriptor |
Public property | Finish |
Public property | IsEcat | Deprecated:
 | Parser |
Public property | Position |
Public property | Rotation |
Public property | Scale |
Public property | WindowSize |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(MoveComponent) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(MoveComponent) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
BeginFieldNumber | Field number for the "begin" field.
CameraFovFieldNumber | Field number for the "camera_fov" field.
CameraNearFarFieldNumber | Field number for the "camera_near_far" field.
CameraPositionFieldNumber | Field number for the "camera_position" field.
CameraRotationFieldNumber | Field number for the "camera_rotation" field.
ComponentIdFieldNumber | Field number for the "component_id" field.
FinishFieldNumber | Field number for the "finish" field.
IsEcatFieldNumber | Field number for the "is_ecat" field.
PositionFieldNumber | Field number for the "position" field.
RotationFieldNumber | Field number for the "rotation" field.
ScaleFieldNumber | Field number for the "scale" field.
WindowSizeFieldNumber | Field number for the "window_size" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


MoveComponent Constructor

Overload List
 | Name | Description
Public method | MoveComponent | Initializes a new instance of the MoveComponent class
Public method | MoveComponent(MoveComponent) | Initializes a new instance of the MoveComponent class
Top
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent Constructor

Initializes a new instance of the MoveComponent class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MoveComponent()
public:
MoveComponent()
See Also

Reference

MoveComponent Class
MoveComponent Overload
VisualComponents.Messages Namespace


MoveComponent Constructor (MoveComponent)

Initializes a new instance of the MoveComponent class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MoveComponent(
    MoveComponent other
)
public:
MoveComponent(
    MoveComponent^ other
)

Parameters

other
Type: VisualComponents.MessagesMoveComponent
See Also

Reference

MoveComponent Class
MoveComponent Overload
VisualComponents.Messages Namespace


MoveComponent Properties

The MoveComponent type exposes the following members.

Properties
 | Name | Description
Public property | Begin |
Public property | CameraFov |
Public property | CameraNearFar |
Public property | CameraPosition |
Public property | CameraRotation |
Public property | ComponentId |
 | Descriptor |
Public property | Finish |
Public property | IsEcat | Deprecated:
 | Parser |
Public property | Position |
Public property | Rotation |
Public property | Scale |
Public property | WindowSize |
Top
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.Begin Property

MoveComponentBegin Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Begin { get; set; }
public:
property bool Begin {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.CameraFov Property

MoveComponentCameraFov Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> CameraFov { get; }
public:
property RepeatedField<float>^ CameraFov {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.CameraNearFar Property

MoveComponentCameraNearFar Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> CameraNearFar { get; }
public:
property RepeatedField<float>^ CameraNearFar {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.CameraPosition Property

MoveComponentCameraPosition Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> CameraPosition { get; }
public:
property RepeatedField<float>^ CameraPosition {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.CameraRotation Property

MoveComponentCameraRotation Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> CameraRotation { get; }
public:
property RepeatedField<float>^ CameraRotation {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.ComponentId Property

MoveComponentComponentId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ComponentId { get; set; }
public:
property int ComponentId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.Descriptor Property

MoveComponentDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.Finish Property

MoveComponentFinish Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Finish { get; set; }
public:
property bool Finish {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.IsEcat Property

MoveComponentIsEcat Property

Deprecated:

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsEcat { get; set; }
public:
property bool IsEcat {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.Parser Property

MoveComponentParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<MoveComponent> Parser { get; }
public:
static property MessageParser<MoveComponent^>^ Parser {
    MessageParser<MoveComponent^>^ get ();
}

Property Value

Type: MessageParserMoveComponent
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.Position Property

MoveComponentPosition Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Position { get; }
public:
property RepeatedField<float>^ Position {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.Rotation Property

MoveComponentRotation Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Rotation { get; }
public:
property RepeatedField<float>^ Rotation {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.Scale Property

MoveComponentScale Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Scale { get; }
public:
property RepeatedField<float>^ Scale {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.WindowSize Property

MoveComponentWindowSize Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<int> WindowSize { get; }
public:
property RepeatedField<int>^ WindowSize {
    RepeatedField<int>^ get ();
}

Property Value

Type: RepeatedFieldInt32
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent Methods

The MoveComponent type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(MoveComponent) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(MoveComponent) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.CalculateSize Method

MoveComponentCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.MoveComponent.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.Clone Method

MoveComponentClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MoveComponent Clone()
public:
virtual MoveComponent^ Clone() sealed

Return Value

Type: MoveComponent

[Missing <returns> documentation for "M:VisualComponents.Messages.MoveComponent.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.Equals Method

MoveComponentEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(MoveComponent) |
Top
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.Equals Method (Object)

MoveComponentEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.MoveComponent.Equals(System.Object)"]

See Also

Reference

MoveComponent Class
Equals Overload
VisualComponents.Messages Namespace


MoveComponent.Equals Method (MoveComponent)

MoveComponentEquals Method (MoveComponent)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    MoveComponent other
)
public:
virtual bool Equals(
    MoveComponent^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesMoveComponent

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.MoveComponent.Equals(VisualComponents.Messages.MoveComponent)"]

Implements

IEquatableTEquals(T)
See Also

Reference

MoveComponent Class
Equals Overload
VisualComponents.Messages Namespace


MoveComponent.GetHashCode Method

MoveComponentGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.MoveComponent.GetHashCode"]

See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.MergeFrom Method

MoveComponentMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(MoveComponent) |
Top
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.MergeFrom Method (CodedInputStream)

MoveComponentMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

MoveComponent Class
MergeFrom Overload
VisualComponents.Messages Namespace


MoveComponent.MergeFrom Method (MoveComponent)

MoveComponentMergeFrom Method (MoveComponent)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    MoveComponent other
)
public:
virtual void MergeFrom(
    MoveComponent^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesMoveComponent

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

MoveComponent Class
MergeFrom Overload
VisualComponents.Messages Namespace


MoveComponent.ToString Method

MoveComponentToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.MoveComponent.ToString"]

See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.WriteTo Method

MoveComponentWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent Fields

The MoveComponent type exposes the following members.

Fields
Name | Description
BeginFieldNumber | Field number for the "begin" field.
CameraFovFieldNumber | Field number for the "camera_fov" field.
CameraNearFarFieldNumber | Field number for the "camera_near_far" field.
CameraPositionFieldNumber | Field number for the "camera_position" field.
CameraRotationFieldNumber | Field number for the "camera_rotation" field.
ComponentIdFieldNumber | Field number for the "component_id" field.
FinishFieldNumber | Field number for the "finish" field.
IsEcatFieldNumber | Field number for the "is_ecat" field.
PositionFieldNumber | Field number for the "position" field.
RotationFieldNumber | Field number for the "rotation" field.
ScaleFieldNumber | Field number for the "scale" field.
WindowSizeFieldNumber | Field number for the "window_size" field.
Top
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.BeginFieldNumber Field

MoveComponentBeginFieldNumber Field

Field number for the "begin" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int BeginFieldNumber = 5
public:
literal int BeginFieldNumber = 5

Field Value

Type: Int32
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.CameraFovFieldNumber Field

MoveComponentCameraFovFieldNumber Field

Field number for the "camera_fov" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int CameraFovFieldNumber = 10
public:
literal int CameraFovFieldNumber = 10

Field Value

Type: Int32
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.CameraNearFarFieldNumber Field

MoveComponentCameraNearFarFieldNumber Field

Field number for the "camera_near_far" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int CameraNearFarFieldNumber = 11
public:
literal int CameraNearFarFieldNumber = 11

Field Value

Type: Int32
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.CameraPositionFieldNumber Field

MoveComponentCameraPositionFieldNumber Field

Field number for the "camera_position" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int CameraPositionFieldNumber = 8
public:
literal int CameraPositionFieldNumber = 8

Field Value

Type: Int32
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.CameraRotationFieldNumber Field

MoveComponentCameraRotationFieldNumber Field

Field number for the "camera_rotation" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int CameraRotationFieldNumber = 9
public:
literal int CameraRotationFieldNumber = 9

Field Value

Type: Int32
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.ComponentIdFieldNumber Field

MoveComponentComponentIdFieldNumber Field

Field number for the "component_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ComponentIdFieldNumber = 1
public:
literal int ComponentIdFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.FinishFieldNumber Field

MoveComponentFinishFieldNumber Field

Field number for the "finish" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int FinishFieldNumber = 6
public:
literal int FinishFieldNumber = 6

Field Value

Type: Int32
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.IsEcatFieldNumber Field

MoveComponentIsEcatFieldNumber Field

Field number for the "is_ecat" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int IsEcatFieldNumber = 7
public:
literal int IsEcatFieldNumber = 7

Field Value

Type: Int32
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.PositionFieldNumber Field

MoveComponentPositionFieldNumber Field

Field number for the "position" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int PositionFieldNumber = 2
public:
literal int PositionFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.RotationFieldNumber Field

MoveComponentRotationFieldNumber Field

Field number for the "rotation" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int RotationFieldNumber = 3
public:
literal int RotationFieldNumber = 3

Field Value

Type: Int32
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.ScaleFieldNumber Field

MoveComponentScaleFieldNumber Field

Field number for the "scale" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ScaleFieldNumber = 4
public:
literal int ScaleFieldNumber = 4

Field Value

Type: Int32
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveComponent.WindowSizeFieldNumber Field

MoveComponentWindowSizeFieldNumber Field

Field number for the "window_size" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int WindowSizeFieldNumber = 12
public:
literal int WindowSizeFieldNumber = 12

Field Value

Type: Int32
See Also

Reference

MoveComponent Class
VisualComponents.Messages Namespace


MoveResult Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesMoveResult

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class MoveResult : IMessage<MoveResult>,
    IMessage, IEquatable<MoveResult>, IDeepCloneable<MoveResult>
public ref class MoveResult sealed : IMessage<MoveResult^>,
    IMessage, IEquatable<MoveResult^>, IDeepCloneable<MoveResult^>

The MoveResult type exposes the following members.

Constructors
 | Name | Description
Public method | MoveResult | Initializes a new instance of the MoveResult class
Public method | MoveResult(MoveResult) | Initializes a new instance of the MoveResult class
Top
Properties
 | Name | Description
Public property | ComponentId |
Public property | ComponentPosition |
Public property | ComponentRotation |
Public property | ComponentScale |
 | Descriptor |
Public property | Failed |
Public property | NearPlug |
 | Parser |
Public property | Plugged |
Public property | PlugLocalPosition |
Public property | PlugTargetPosition |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(MoveResult) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(MoveResult) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
ComponentIdFieldNumber | Field number for the "component_id" field.
ComponentPositionFieldNumber | Field number for the "component_position" field.
ComponentRotationFieldNumber | Field number for the "component_rotation" field.
ComponentScaleFieldNumber | Field number for the "component_scale" field.
FailedFieldNumber | Field number for the "failed" field.
NearPlugFieldNumber | Field number for the "near_plug" field.
PluggedFieldNumber | Field number for the "plugged" field.
PlugLocalPositionFieldNumber | Field number for the "plug_local_position" field.
PlugTargetPositionFieldNumber | Field number for the "plug_target_position" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


MoveResult Constructor

Overload List
 | Name | Description
Public method | MoveResult | Initializes a new instance of the MoveResult class
Public method | MoveResult(MoveResult) | Initializes a new instance of the MoveResult class
Top
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult Constructor

Initializes a new instance of the MoveResult class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MoveResult()
public:
MoveResult()
See Also

Reference

MoveResult Class
MoveResult Overload
VisualComponents.Messages Namespace


MoveResult Constructor (MoveResult)

Initializes a new instance of the MoveResult class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MoveResult(
    MoveResult other
)
public:
MoveResult(
    MoveResult^ other
)

Parameters

other
Type: VisualComponents.MessagesMoveResult
See Also

Reference

MoveResult Class
MoveResult Overload
VisualComponents.Messages Namespace


MoveResult Properties

The MoveResult type exposes the following members.

Properties
 | Name | Description
Public property | ComponentId |
Public property | ComponentPosition |
Public property | ComponentRotation |
Public property | ComponentScale |
 | Descriptor |
Public property | Failed |
Public property | NearPlug |
 | Parser |
Public property | Plugged |
Public property | PlugLocalPosition |
Public property | PlugTargetPosition |
Top
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult.ComponentId Property

MoveResultComponentId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ComponentId { get; set; }
public:
property int ComponentId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult.ComponentPosition Property

MoveResultComponentPosition Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> ComponentPosition { get; }
public:
property RepeatedField<float>^ ComponentPosition {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult.ComponentRotation Property

MoveResultComponentRotation Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> ComponentRotation { get; }
public:
property RepeatedField<float>^ ComponentRotation {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult.ComponentScale Property

MoveResultComponentScale Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> ComponentScale { get; }
public:
property RepeatedField<float>^ ComponentScale {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult.Descriptor Property

MoveResultDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult.Failed Property

MoveResultFailed Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Failed { get; set; }
public:
property bool Failed {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult.NearPlug Property

MoveResultNearPlug Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool NearPlug { get; set; }
public:
property bool NearPlug {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult.Parser Property

MoveResultParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<MoveResult> Parser { get; }
public:
static property MessageParser<MoveResult^>^ Parser {
    MessageParser<MoveResult^>^ get ();
}

Property Value

Type: MessageParserMoveResult
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult.Plugged Property

MoveResultPlugged Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Plugged { get; set; }
public:
property bool Plugged {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult.PlugLocalPosition Property

MoveResultPlugLocalPosition Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> PlugLocalPosition { get; }
public:
property RepeatedField<float>^ PlugLocalPosition {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult.PlugTargetPosition Property

MoveResultPlugTargetPosition Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> PlugTargetPosition { get; }
public:
property RepeatedField<float>^ PlugTargetPosition {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult Methods

The MoveResult type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(MoveResult) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(MoveResult) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult.CalculateSize Method

MoveResultCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.MoveResult.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult.Clone Method

MoveResultClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MoveResult Clone()
public:
virtual MoveResult^ Clone() sealed

Return Value

Type: MoveResult

[Missing <returns> documentation for "M:VisualComponents.Messages.MoveResult.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult.Equals Method

MoveResultEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(MoveResult) |
Top
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult.Equals Method (Object)

MoveResultEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.MoveResult.Equals(System.Object)"]

See Also

Reference

MoveResult Class
Equals Overload
VisualComponents.Messages Namespace


MoveResult.Equals Method (MoveResult)

MoveResultEquals Method (MoveResult)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    MoveResult other
)
public:
virtual bool Equals(
    MoveResult^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesMoveResult

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.MoveResult.Equals(VisualComponents.Messages.MoveResult)"]

Implements

IEquatableTEquals(T)
See Also

Reference

MoveResult Class
Equals Overload
VisualComponents.Messages Namespace


MoveResult.GetHashCode Method

MoveResultGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.MoveResult.GetHashCode"]

See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult.MergeFrom Method

MoveResultMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(MoveResult) |
Top
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult.MergeFrom Method (CodedInputStream)

MoveResultMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

MoveResult Class
MergeFrom Overload
VisualComponents.Messages Namespace


MoveResult.MergeFrom Method (MoveResult)

MoveResultMergeFrom Method (MoveResult)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    MoveResult other
)
public:
virtual void MergeFrom(
    MoveResult^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesMoveResult

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

MoveResult Class
MergeFrom Overload
VisualComponents.Messages Namespace


MoveResult.ToString Method

MoveResultToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.MoveResult.ToString"]

See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult.WriteTo Method

MoveResultWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult Fields

The MoveResult type exposes the following members.

Fields
Name | Description
ComponentIdFieldNumber | Field number for the "component_id" field.
ComponentPositionFieldNumber | Field number for the "component_position" field.
ComponentRotationFieldNumber | Field number for the "component_rotation" field.
ComponentScaleFieldNumber | Field number for the "component_scale" field.
FailedFieldNumber | Field number for the "failed" field.
NearPlugFieldNumber | Field number for the "near_plug" field.
PluggedFieldNumber | Field number for the "plugged" field.
PlugLocalPositionFieldNumber | Field number for the "plug_local_position" field.
PlugTargetPositionFieldNumber | Field number for the "plug_target_position" field.
Top
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult.ComponentIdFieldNumber Field

MoveResultComponentIdFieldNumber Field

Field number for the "component_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ComponentIdFieldNumber = 1
public:
literal int ComponentIdFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult.ComponentPositionFieldNumber Field

MoveResultComponentPositionFieldNumber Field

Field number for the "component_position" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ComponentPositionFieldNumber = 5
public:
literal int ComponentPositionFieldNumber = 5

Field Value

Type: Int32
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult.ComponentRotationFieldNumber Field

MoveResultComponentRotationFieldNumber Field

Field number for the "component_rotation" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ComponentRotationFieldNumber = 6
public:
literal int ComponentRotationFieldNumber = 6

Field Value

Type: Int32
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult.ComponentScaleFieldNumber Field

MoveResultComponentScaleFieldNumber Field

Field number for the "component_scale" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ComponentScaleFieldNumber = 7
public:
literal int ComponentScaleFieldNumber = 7

Field Value

Type: Int32
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult.FailedFieldNumber Field

MoveResultFailedFieldNumber Field

Field number for the "failed" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int FailedFieldNumber = 4
public:
literal int FailedFieldNumber = 4

Field Value

Type: Int32
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult.NearPlugFieldNumber Field

MoveResultNearPlugFieldNumber Field

Field number for the "near_plug" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int NearPlugFieldNumber = 3
public:
literal int NearPlugFieldNumber = 3

Field Value

Type: Int32
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult.PluggedFieldNumber Field

MoveResultPluggedFieldNumber Field

Field number for the "plugged" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int PluggedFieldNumber = 2
public:
literal int PluggedFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult.PlugLocalPositionFieldNumber Field

MoveResultPlugLocalPositionFieldNumber Field

Field number for the "plug_local_position" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int PlugLocalPositionFieldNumber = 8
public:
literal int PlugLocalPositionFieldNumber = 8

Field Value

Type: Int32
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


MoveResult.PlugTargetPositionFieldNumber Field

MoveResultPlugTargetPositionFieldNumber Field

Field number for the "plug_target_position" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int PlugTargetPositionFieldNumber = 9
public:
literal int PlugTargetPositionFieldNumber = 9

Field Value

Type: Int32
See Also

Reference

MoveResult Class
VisualComponents.Messages Namespace


NotifyPython Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesNotifyPython

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class NotifyPython : IMessage<NotifyPython>,
    IMessage, IEquatable<NotifyPython>, IDeepCloneable<NotifyPython>
public ref class NotifyPython sealed : IMessage<NotifyPython^>,
    IMessage, IEquatable<NotifyPython^>, IDeepCloneable<NotifyPython^>

The NotifyPython type exposes the following members.

Constructors
 | Name | Description
Public method | NotifyPython | Initializes a new instance of the NotifyPython class
Public method | NotifyPython(NotifyPython) | Initializes a new instance of the NotifyPython class
Top
Properties
 | Name | Description
Public property | Buttons |
Public property | ClientId |
 | Descriptor |
Public property | DeviceInfo |
Public property | DeviceInputs |
Public property | Directions |
Public property | EventsEnabled |
Public property | OneMeterLength |
 | Parser |
Public property | Positions |
Public property | RealEventCounter |
Public property | RoomCenter |
Public property | Times |
Public property | Touches |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(NotifyPython) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(NotifyPython) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
ButtonsFieldNumber | Field number for the "buttons" field.
ClientIdFieldNumber | Field number for the "client_id" field.
DeviceInfoFieldNumber | Field number for the "device_info" field.
DeviceInputsFieldNumber | Field number for the "device_inputs" field.
DirectionsFieldNumber | Field number for the "directions" field.
EventsEnabledFieldNumber | Field number for the "events_enabled" field.
OneMeterLengthFieldNumber | Field number for the "one_meter_length" field.
PositionsFieldNumber | Field number for the "positions" field.
RealEventCounterFieldNumber | Field number for the "real_event_counter" field.
RoomCenterFieldNumber | Field number for the "room_center" field.
TimesFieldNumber | Field number for the "times" field.
TouchesFieldNumber | Field number for the "touches" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


NotifyPython Constructor

Overload List
 | Name | Description
Public method | NotifyPython | Initializes a new instance of the NotifyPython class
Public method | NotifyPython(NotifyPython) | Initializes a new instance of the NotifyPython class
Top
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython Constructor

Initializes a new instance of the NotifyPython class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NotifyPython()
public:
NotifyPython()
See Also

Reference

NotifyPython Class
NotifyPython Overload
VisualComponents.Messages Namespace


NotifyPython Constructor (NotifyPython)

Initializes a new instance of the NotifyPython class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NotifyPython(
    NotifyPython other
)
public:
NotifyPython(
    NotifyPython^ other
)

Parameters

other
Type: VisualComponents.MessagesNotifyPython
See Also

Reference

NotifyPython Class
NotifyPython Overload
VisualComponents.Messages Namespace


NotifyPython Properties

The NotifyPython type exposes the following members.

Properties
 | Name | Description
Public property | Buttons |
Public property | ClientId |
 | Descriptor |
Public property | DeviceInfo |
Public property | DeviceInputs |
Public property | Directions |
Public property | EventsEnabled |
Public property | OneMeterLength |
 | Parser |
Public property | Positions |
Public property | RealEventCounter |
Public property | RoomCenter |
Public property | Times |
Public property | Touches |
Top
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.Buttons Property

NotifyPythonButtons Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<uint> Buttons { get; }
public:
property RepeatedField<unsigned int>^ Buttons {
    RepeatedField<unsigned int>^ get ();
}

Property Value

Type: RepeatedFieldUInt32
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.ClientId Property

NotifyPythonClientId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint ClientId { get; set; }
public:
property unsigned int ClientId {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.Descriptor Property

NotifyPythonDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.DeviceInfo Property

NotifyPythonDeviceInfo Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DeviceInfo DeviceInfo { get; set; }
public:
property DeviceInfo^ DeviceInfo {
    DeviceInfo^ get ();
    void set (DeviceInfo^ value);
}

Property Value

Type: DeviceInfo
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.DeviceInputs Property

NotifyPythonDeviceInputs Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<DeviceInput> DeviceInputs { get; }
public:
property RepeatedField<DeviceInput^>^ DeviceInputs {
    RepeatedField<DeviceInput^>^ get ();
}

Property Value

Type: RepeatedFieldDeviceInput
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.Directions Property

NotifyPythonDirections Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Directions { get; }
public:
property RepeatedField<float>^ Directions {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.EventsEnabled Property

NotifyPythonEventsEnabled Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool EventsEnabled { get; set; }
public:
property bool EventsEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.OneMeterLength Property

NotifyPythonOneMeterLength Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float OneMeterLength { get; set; }
public:
property float OneMeterLength {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.Parser Property

NotifyPythonParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<NotifyPython> Parser { get; }
public:
static property MessageParser<NotifyPython^>^ Parser {
    MessageParser<NotifyPython^>^ get ();
}

Property Value

Type: MessageParserNotifyPython
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.Positions Property

NotifyPythonPositions Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Positions { get; }
public:
property RepeatedField<float>^ Positions {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.RealEventCounter Property

NotifyPythonRealEventCounter Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int RealEventCounter { get; set; }
public:
property int RealEventCounter {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.RoomCenter Property

NotifyPythonRoomCenter Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> RoomCenter { get; }
public:
property RepeatedField<float>^ RoomCenter {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.Times Property

NotifyPythonTimes Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Times { get; }
public:
property RepeatedField<float>^ Times {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.Touches Property

NotifyPythonTouches Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Touches { get; }
public:
property RepeatedField<float>^ Touches {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython Methods

The NotifyPython type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(NotifyPython) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(NotifyPython) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.CalculateSize Method

NotifyPythonCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.NotifyPython.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.Clone Method

NotifyPythonClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NotifyPython Clone()
public:
virtual NotifyPython^ Clone() sealed

Return Value

Type: NotifyPython

[Missing <returns> documentation for "M:VisualComponents.Messages.NotifyPython.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.Equals Method

NotifyPythonEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(NotifyPython) |
Top
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.Equals Method (Object)

NotifyPythonEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.NotifyPython.Equals(System.Object)"]

See Also

Reference

NotifyPython Class
Equals Overload
VisualComponents.Messages Namespace


NotifyPython.Equals Method (NotifyPython)

NotifyPythonEquals Method (NotifyPython)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    NotifyPython other
)
public:
virtual bool Equals(
    NotifyPython^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesNotifyPython

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.NotifyPython.Equals(VisualComponents.Messages.NotifyPython)"]

Implements

IEquatableTEquals(T)
See Also

Reference

NotifyPython Class
Equals Overload
VisualComponents.Messages Namespace


NotifyPython.GetHashCode Method

NotifyPythonGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.NotifyPython.GetHashCode"]

See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.MergeFrom Method

NotifyPythonMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(NotifyPython) |
Top
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.MergeFrom Method (CodedInputStream)

NotifyPythonMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

NotifyPython Class
MergeFrom Overload
VisualComponents.Messages Namespace


NotifyPython.MergeFrom Method (NotifyPython)

NotifyPythonMergeFrom Method (NotifyPython)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    NotifyPython other
)
public:
virtual void MergeFrom(
    NotifyPython^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesNotifyPython

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

NotifyPython Class
MergeFrom Overload
VisualComponents.Messages Namespace


NotifyPython.ToString Method

NotifyPythonToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.NotifyPython.ToString"]

See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.WriteTo Method

NotifyPythonWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython Fields

The NotifyPython type exposes the following members.

Fields
Name | Description
ButtonsFieldNumber | Field number for the "buttons" field.
ClientIdFieldNumber | Field number for the "client_id" field.
DeviceInfoFieldNumber | Field number for the "device_info" field.
DeviceInputsFieldNumber | Field number for the "device_inputs" field.
DirectionsFieldNumber | Field number for the "directions" field.
EventsEnabledFieldNumber | Field number for the "events_enabled" field.
OneMeterLengthFieldNumber | Field number for the "one_meter_length" field.
PositionsFieldNumber | Field number for the "positions" field.
RealEventCounterFieldNumber | Field number for the "real_event_counter" field.
RoomCenterFieldNumber | Field number for the "room_center" field.
TimesFieldNumber | Field number for the "times" field.
TouchesFieldNumber | Field number for the "touches" field.
Top
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.ButtonsFieldNumber Field

NotifyPythonButtonsFieldNumber Field

Field number for the "buttons" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ButtonsFieldNumber = 9
public:
literal int ButtonsFieldNumber = 9

Field Value

Type: Int32
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.ClientIdFieldNumber Field

NotifyPythonClientIdFieldNumber Field

Field number for the "client_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ClientIdFieldNumber = 12
public:
literal int ClientIdFieldNumber = 12

Field Value

Type: Int32
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.DeviceInfoFieldNumber Field

NotifyPythonDeviceInfoFieldNumber Field

Field number for the "device_info" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int DeviceInfoFieldNumber = 10
public:
literal int DeviceInfoFieldNumber = 10

Field Value

Type: Int32
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.DeviceInputsFieldNumber Field

NotifyPythonDeviceInputsFieldNumber Field

Field number for the "device_inputs" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int DeviceInputsFieldNumber = 11
public:
literal int DeviceInputsFieldNumber = 11

Field Value

Type: Int32
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.DirectionsFieldNumber Field

NotifyPythonDirectionsFieldNumber Field

Field number for the "directions" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int DirectionsFieldNumber = 7
public:
literal int DirectionsFieldNumber = 7

Field Value

Type: Int32
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.EventsEnabledFieldNumber Field

NotifyPythonEventsEnabledFieldNumber Field

Field number for the "events_enabled" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int EventsEnabledFieldNumber = 1
public:
literal int EventsEnabledFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.OneMeterLengthFieldNumber Field

NotifyPythonOneMeterLengthFieldNumber Field

Field number for the "one_meter_length" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int OneMeterLengthFieldNumber = 3
public:
literal int OneMeterLengthFieldNumber = 3

Field Value

Type: Int32
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.PositionsFieldNumber Field

NotifyPythonPositionsFieldNumber Field

Field number for the "positions" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int PositionsFieldNumber = 6
public:
literal int PositionsFieldNumber = 6

Field Value

Type: Int32
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.RealEventCounterFieldNumber Field

NotifyPythonRealEventCounterFieldNumber Field

Field number for the "real_event_counter" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int RealEventCounterFieldNumber = 2
public:
literal int RealEventCounterFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.RoomCenterFieldNumber Field

NotifyPythonRoomCenterFieldNumber Field

Field number for the "room_center" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int RoomCenterFieldNumber = 4
public:
literal int RoomCenterFieldNumber = 4

Field Value

Type: Int32
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.TimesFieldNumber Field

NotifyPythonTimesFieldNumber Field

Field number for the "times" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int TimesFieldNumber = 5
public:
literal int TimesFieldNumber = 5

Field Value

Type: Int32
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


NotifyPython.TouchesFieldNumber Field

NotifyPythonTouchesFieldNumber Field

Field number for the "touches" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int TouchesFieldNumber = 8
public:
literal int TouchesFieldNumber = 8

Field Value

Type: Int32
See Also

Reference

NotifyPython Class
VisualComponents.Messages Namespace


PreviewImages Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesPreviewImages

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class PreviewImages : IMessage<PreviewImages>,
    IMessage, IEquatable<PreviewImages>, IDeepCloneable<PreviewImages>
public ref class PreviewImages sealed : IMessage<PreviewImages^>,
    IMessage, IEquatable<PreviewImages^>, IDeepCloneable<PreviewImages^>

The PreviewImages type exposes the following members.

Constructors
 | Name | Description
Public method | PreviewImages | Initializes a new instance of the PreviewImages class
Public method | PreviewImages(PreviewImages) | Initializes a new instance of the PreviewImages class
Top
Properties
 | Name | Description
Public property | Data |
 | Descriptor |
 | Parser |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(PreviewImages) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(PreviewImages) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
DataFieldNumber | Field number for the "data" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


PreviewImages Constructor

Overload List
 | Name | Description
Public method | PreviewImages | Initializes a new instance of the PreviewImages class
Public method | PreviewImages(PreviewImages) | Initializes a new instance of the PreviewImages class
Top
See Also

Reference

PreviewImages Class
VisualComponents.Messages Namespace


PreviewImages Constructor

Initializes a new instance of the PreviewImages class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PreviewImages()
public:
PreviewImages()
See Also

Reference

PreviewImages Class
PreviewImages Overload
VisualComponents.Messages Namespace


PreviewImages Constructor (PreviewImages)

Initializes a new instance of the PreviewImages class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PreviewImages(
    PreviewImages other
)
public:
PreviewImages(
    PreviewImages^ other
)

Parameters

other
Type: VisualComponents.MessagesPreviewImages
See Also

Reference

PreviewImages Class
PreviewImages Overload
VisualComponents.Messages Namespace


PreviewImages Properties

The PreviewImages type exposes the following members.

Properties
 | Name | Description
Public property | Data |
 | Descriptor |
 | Parser |
Top
See Also

Reference

PreviewImages Class
VisualComponents.Messages Namespace


PreviewImages.Data Property

PreviewImagesData Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ByteString Data { get; set; }
public:
property ByteString^ Data {
    ByteString^ get ();
    void set (ByteString^ value);
}

Property Value

Type: ByteString
See Also

Reference

PreviewImages Class
VisualComponents.Messages Namespace


PreviewImages.Descriptor Property

PreviewImagesDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

PreviewImages Class
VisualComponents.Messages Namespace


PreviewImages.Parser Property

PreviewImagesParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<PreviewImages> Parser { get; }
public:
static property MessageParser<PreviewImages^>^ Parser {
    MessageParser<PreviewImages^>^ get ();
}

Property Value

Type: MessageParserPreviewImages
See Also

Reference

PreviewImages Class
VisualComponents.Messages Namespace


PreviewImages Methods

The PreviewImages type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(PreviewImages) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(PreviewImages) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PreviewImages Class
VisualComponents.Messages Namespace


PreviewImages.CalculateSize Method

PreviewImagesCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.PreviewImages.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

PreviewImages Class
VisualComponents.Messages Namespace


PreviewImages.Clone Method

PreviewImagesClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PreviewImages Clone()
public:
virtual PreviewImages^ Clone() sealed

Return Value

Type: PreviewImages

[Missing <returns> documentation for "M:VisualComponents.Messages.PreviewImages.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

PreviewImages Class
VisualComponents.Messages Namespace


PreviewImages.Equals Method

PreviewImagesEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(PreviewImages) |
Top
See Also

Reference

PreviewImages Class
VisualComponents.Messages Namespace


PreviewImages.Equals Method (Object)

PreviewImagesEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.PreviewImages.Equals(System.Object)"]

See Also

Reference

PreviewImages Class
Equals Overload
VisualComponents.Messages Namespace


PreviewImages.Equals Method (PreviewImages)

PreviewImagesEquals Method (PreviewImages)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    PreviewImages other
)
public:
virtual bool Equals(
    PreviewImages^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesPreviewImages

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.PreviewImages.Equals(VisualComponents.Messages.PreviewImages)"]

Implements

IEquatableTEquals(T)
See Also

Reference

PreviewImages Class
Equals Overload
VisualComponents.Messages Namespace


PreviewImages.GetHashCode Method

PreviewImagesGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.PreviewImages.GetHashCode"]

See Also

Reference

PreviewImages Class
VisualComponents.Messages Namespace


PreviewImages.MergeFrom Method

PreviewImagesMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(PreviewImages) |
Top
See Also

Reference

PreviewImages Class
VisualComponents.Messages Namespace


PreviewImages.MergeFrom Method (CodedInputStream)

PreviewImagesMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

PreviewImages Class
MergeFrom Overload
VisualComponents.Messages Namespace


PreviewImages.MergeFrom Method (PreviewImages)

PreviewImagesMergeFrom Method (PreviewImages)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    PreviewImages other
)
public:
virtual void MergeFrom(
    PreviewImages^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesPreviewImages

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

PreviewImages Class
MergeFrom Overload
VisualComponents.Messages Namespace


PreviewImages.ToString Method

PreviewImagesToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.PreviewImages.ToString"]

See Also

Reference

PreviewImages Class
VisualComponents.Messages Namespace


PreviewImages.WriteTo Method

PreviewImagesWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

PreviewImages Class
VisualComponents.Messages Namespace


PreviewImages Fields

The PreviewImages type exposes the following members.

Fields
Name | Description
DataFieldNumber | Field number for the "data" field.
Top
See Also

Reference

PreviewImages Class
VisualComponents.Messages Namespace


PreviewImages.DataFieldNumber Field

PreviewImagesDataFieldNumber Field

Field number for the "data" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int DataFieldNumber = 1
public:
literal int DataFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

PreviewImages Class
VisualComponents.Messages Namespace


PythonRequest Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesPythonRequest

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class PythonRequest : IMessage<PythonRequest>,
    IMessage, IEquatable<PythonRequest>, IDeepCloneable<PythonRequest>
public ref class PythonRequest sealed : IMessage<PythonRequest^>,
    IMessage, IEquatable<PythonRequest^>, IDeepCloneable<PythonRequest^>

The PythonRequest type exposes the following members.

Constructors
 | Name | Description
Public method | PythonRequest | Initializes a new instance of the PythonRequest class
Public method | PythonRequest(PythonRequest) | Initializes a new instance of the PythonRequest class
Top
Properties
 | Name | Description
Public property | ComponentName |
 | Descriptor |
Public property | ErrorResult |
Public property | LayoutName |
Public property | MethodName |
 | Parser |
Public property | RequestArguments |
Public property | RequestResult |
Public property | ScriptName |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(PythonRequest) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(PythonRequest) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
ComponentNameFieldNumber | Field number for the "component_name" field.
ErrorResultFieldNumber | Field number for the "error_result" field.
LayoutNameFieldNumber | Field number for the "layout_name" field.
MethodNameFieldNumber | Field number for the "method_name" field.
RequestArgumentsFieldNumber | Field number for the "request_arguments" field.
RequestResultFieldNumber | Field number for the "request_result" field.
ScriptNameFieldNumber | Field number for the "script_name" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


PythonRequest Constructor

Overload List
 | Name | Description
Public method | PythonRequest | Initializes a new instance of the PythonRequest class
Public method | PythonRequest(PythonRequest) | Initializes a new instance of the PythonRequest class
Top
See Also

Reference

PythonRequest Class
VisualComponents.Messages Namespace


PythonRequest Constructor

Initializes a new instance of the PythonRequest class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PythonRequest()
public:
PythonRequest()
See Also

Reference

PythonRequest Class
PythonRequest Overload
VisualComponents.Messages Namespace


PythonRequest Constructor (PythonRequest)

Initializes a new instance of the PythonRequest class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PythonRequest(
    PythonRequest other
)
public:
PythonRequest(
    PythonRequest^ other
)

Parameters

other
Type: VisualComponents.MessagesPythonRequest
See Also

Reference

PythonRequest Class
PythonRequest Overload
VisualComponents.Messages Namespace


PythonRequest Properties

The PythonRequest type exposes the following members.

Properties
 | Name | Description
Public property | ComponentName |
 | Descriptor |
Public property | ErrorResult |
Public property | LayoutName |
Public property | MethodName |
 | Parser |
Public property | RequestArguments |
Public property | RequestResult |
Public property | ScriptName |
Top
See Also

Reference

PythonRequest Class
VisualComponents.Messages Namespace


PythonRequest.ComponentName Property

PythonRequestComponentName Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ComponentName { get; set; }
public:
property String^ ComponentName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PythonRequest Class
VisualComponents.Messages Namespace


PythonRequest.Descriptor Property

PythonRequestDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

PythonRequest Class
VisualComponents.Messages Namespace


PythonRequest.ErrorResult Property

PythonRequestErrorResult Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ErrorResult { get; set; }
public:
property String^ ErrorResult {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PythonRequest Class
VisualComponents.Messages Namespace


PythonRequest.LayoutName Property

PythonRequestLayoutName Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string LayoutName { get; set; }
public:
property String^ LayoutName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PythonRequest Class
VisualComponents.Messages Namespace


PythonRequest.MethodName Property

PythonRequestMethodName Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string MethodName { get; set; }
public:
property String^ MethodName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PythonRequest Class
VisualComponents.Messages Namespace


PythonRequest.Parser Property

PythonRequestParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<PythonRequest> Parser { get; }
public:
static property MessageParser<PythonRequest^>^ Parser {
    MessageParser<PythonRequest^>^ get ();
}

Property Value

Type: MessageParserPythonRequest
See Also

Reference

PythonRequest Class
VisualComponents.Messages Namespace


PythonRequest.RequestArguments Property

PythonRequestRequestArguments Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<string> RequestArguments { get; }
public:
property RepeatedField<String^>^ RequestArguments {
    RepeatedField<String^>^ get ();
}

Property Value

Type: RepeatedFieldString
See Also

Reference

PythonRequest Class
VisualComponents.Messages Namespace


PythonRequest.RequestResult Property

PythonRequestRequestResult Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string RequestResult { get; set; }
public:
property String^ RequestResult {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PythonRequest Class
VisualComponents.Messages Namespace


PythonRequest.ScriptName Property

PythonRequestScriptName Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ScriptName { get; set; }
public:
property String^ ScriptName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PythonRequest Class
VisualComponents.Messages Namespace


PythonRequest Methods

The PythonRequest type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(PythonRequest) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(PythonRequest) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PythonRequest Class
VisualComponents.Messages Namespace


PythonRequest.CalculateSize Method

PythonRequestCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.PythonRequest.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

PythonRequest Class
VisualComponents.Messages Namespace


PythonRequest.Clone Method

PythonRequestClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PythonRequest Clone()
public:
virtual PythonRequest^ Clone() sealed

Return Value

Type: PythonRequest

[Missing <returns> documentation for "M:VisualComponents.Messages.PythonRequest.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

PythonRequest Class
VisualComponents.Messages Namespace


PythonRequest.Equals Method

PythonRequestEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(PythonRequest) |
Top
See Also

Reference

PythonRequest Class
VisualComponents.Messages Namespace


PythonRequest.Equals Method (Object)

PythonRequestEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.PythonRequest.Equals(System.Object)"]

See Also

Reference

PythonRequest Class
Equals Overload
VisualComponents.Messages Namespace


PythonRequest.Equals Method (PythonRequest)

PythonRequestEquals Method (PythonRequest)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    PythonRequest other
)
public:
virtual bool Equals(
    PythonRequest^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesPythonRequest

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.PythonRequest.Equals(VisualComponents.Messages.PythonRequest)"]

Implements

IEquatableTEquals(T)
See Also

Reference

PythonRequest Class
Equals Overload
VisualComponents.Messages Namespace


PythonRequest.GetHashCode Method

PythonRequestGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.PythonRequest.GetHashCode"]

See Also

Reference

PythonRequest Class
VisualComponents.Messages Namespace


PythonRequest.MergeFrom Method

PythonRequestMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(PythonRequest) |
Top
See Also

Reference

PythonRequest Class
VisualComponents.Messages Namespace


PythonRequest.MergeFrom Method (CodedInputStream)

PythonRequestMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

PythonRequest Class
MergeFrom Overload
VisualComponents.Messages Namespace


PythonRequest.MergeFrom Method (PythonRequest)

PythonRequestMergeFrom Method (PythonRequest)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    PythonRequest other
)
public:
virtual void MergeFrom(
    PythonRequest^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesPythonRequest

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

PythonRequest Class
MergeFrom Overload
VisualComponents.Messages Namespace


PythonRequest.ToString Method

PythonRequestToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.PythonRequest.ToString"]

See Also

Reference

PythonRequest Class
VisualComponents.Messages Namespace


PythonRequest.WriteTo Method

PythonRequestWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

PythonRequest Class
VisualComponents.Messages Namespace


PythonRequest Fields

The PythonRequest type exposes the following members.

Fields
Name | Description
ComponentNameFieldNumber | Field number for the "component_name" field.
ErrorResultFieldNumber | Field number for the "error_result" field.
LayoutNameFieldNumber | Field number for the "layout_name" field.
MethodNameFieldNumber | Field number for the "method_name" field.
RequestArgumentsFieldNumber | Field number for the "request_arguments" field.
RequestResultFieldNumber | Field number for the "request_result" field.
ScriptNameFieldNumber | Field number for the "script_name" field.
Top
See Also

Reference

PythonRequest Class
VisualComponents.Messages Namespace


PythonRequest.ComponentNameFieldNumber Field

PythonRequestComponentNameFieldNumber Field

Field number for the "component_name" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ComponentNameFieldNumber = 20
public:
literal int ComponentNameFieldNumber = 20

Field Value

Type: Int32
See Also

Reference

PythonRequest Class
VisualComponents.Messages Namespace


PythonRequest.ErrorResultFieldNumber Field

PythonRequestErrorResultFieldNumber Field

Field number for the "error_result" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ErrorResultFieldNumber = 110
public:
literal int ErrorResultFieldNumber = 110

Field Value

Type: Int32
See Also

Reference

PythonRequest Class
VisualComponents.Messages Namespace


PythonRequest.LayoutNameFieldNumber Field

PythonRequestLayoutNameFieldNumber Field

Field number for the "layout_name" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int LayoutNameFieldNumber = 10
public:
literal int LayoutNameFieldNumber = 10

Field Value

Type: Int32
See Also

Reference

PythonRequest Class
VisualComponents.Messages Namespace


PythonRequest.MethodNameFieldNumber Field

PythonRequestMethodNameFieldNumber Field

Field number for the "method_name" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int MethodNameFieldNumber = 40
public:
literal int MethodNameFieldNumber = 40

Field Value

Type: Int32
See Also

Reference

PythonRequest Class
VisualComponents.Messages Namespace


PythonRequest.RequestArgumentsFieldNumber Field

PythonRequestRequestArgumentsFieldNumber Field

Field number for the "request_arguments" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int RequestArgumentsFieldNumber = 60
public:
literal int RequestArgumentsFieldNumber = 60

Field Value

Type: Int32
See Also

Reference

PythonRequest Class
VisualComponents.Messages Namespace


PythonRequest.RequestResultFieldNumber Field

PythonRequestRequestResultFieldNumber Field

Field number for the "request_result" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int RequestResultFieldNumber = 100
public:
literal int RequestResultFieldNumber = 100

Field Value

Type: Int32
See Also

Reference

PythonRequest Class
VisualComponents.Messages Namespace


PythonRequest.ScriptNameFieldNumber Field

PythonRequestScriptNameFieldNumber Field

Field number for the "script_name" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ScriptNameFieldNumber = 30
public:
literal int ScriptNameFieldNumber = 30

Field Value

Type: Int32
See Also

Reference

PythonRequest Class
VisualComponents.Messages Namespace


RemoveComponentKey Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesRemoveComponentKey

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class RemoveComponentKey : IMessage<RemoveComponentKey>,
    IMessage, IEquatable<RemoveComponentKey>, IDeepCloneable<RemoveComponentKey>
public ref class RemoveComponentKey sealed : IMessage<RemoveComponentKey^>,
    IMessage, IEquatable<RemoveComponentKey^>, IDeepCloneable<RemoveComponentKey^>

The RemoveComponentKey type exposes the following members.

Constructors
 | Name | Description
Public method | RemoveComponentKey | Initializes a new instance of the RemoveComponentKey class
Public method | RemoveComponentKey(RemoveComponentKey) | Initializes a new instance of the RemoveComponentKey class
Top
Properties
 | Name | Description
Public property | ComponentId |
 | Descriptor |
 | Parser |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(RemoveComponentKey) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(RemoveComponentKey) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
ComponentIdFieldNumber | Field number for the "component_id" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


RemoveComponentKey Constructor

Overload List
 | Name | Description
Public method | RemoveComponentKey | Initializes a new instance of the RemoveComponentKey class
Public method | RemoveComponentKey(RemoveComponentKey) | Initializes a new instance of the RemoveComponentKey class
Top
See Also

Reference

RemoveComponentKey Class
VisualComponents.Messages Namespace


RemoveComponentKey Constructor

Initializes a new instance of the RemoveComponentKey class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RemoveComponentKey()
public:
RemoveComponentKey()
See Also

Reference

RemoveComponentKey Class
RemoveComponentKey Overload
VisualComponents.Messages Namespace


RemoveComponentKey Constructor (RemoveComponentKey)

Initializes a new instance of the RemoveComponentKey class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RemoveComponentKey(
    RemoveComponentKey other
)
public:
RemoveComponentKey(
    RemoveComponentKey^ other
)

Parameters

other
Type: VisualComponents.MessagesRemoveComponentKey
See Also

Reference

RemoveComponentKey Class
RemoveComponentKey Overload
VisualComponents.Messages Namespace


RemoveComponentKey Properties

The RemoveComponentKey type exposes the following members.

Properties
 | Name | Description
Public property | ComponentId |
 | Descriptor |
 | Parser |
Top
See Also

Reference

RemoveComponentKey Class
VisualComponents.Messages Namespace


RemoveComponentKey.ComponentId Property

RemoveComponentKeyComponentId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ComponentId { get; set; }
public:
property int ComponentId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

RemoveComponentKey Class
VisualComponents.Messages Namespace


RemoveComponentKey.Descriptor Property

RemoveComponentKeyDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

RemoveComponentKey Class
VisualComponents.Messages Namespace


RemoveComponentKey.Parser Property

RemoveComponentKeyParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<RemoveComponentKey> Parser { get; }
public:
static property MessageParser<RemoveComponentKey^>^ Parser {
    MessageParser<RemoveComponentKey^>^ get ();
}

Property Value

Type: MessageParserRemoveComponentKey
See Also

Reference

RemoveComponentKey Class
VisualComponents.Messages Namespace


RemoveComponentKey Methods

The RemoveComponentKey type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(RemoveComponentKey) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(RemoveComponentKey) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RemoveComponentKey Class
VisualComponents.Messages Namespace


RemoveComponentKey.CalculateSize Method

RemoveComponentKeyCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.RemoveComponentKey.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

RemoveComponentKey Class
VisualComponents.Messages Namespace


RemoveComponentKey.Clone Method

RemoveComponentKeyClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RemoveComponentKey Clone()
public:
virtual RemoveComponentKey^ Clone() sealed

Return Value

Type: RemoveComponentKey

[Missing <returns> documentation for "M:VisualComponents.Messages.RemoveComponentKey.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

RemoveComponentKey Class
VisualComponents.Messages Namespace


RemoveComponentKey.Equals Method

RemoveComponentKeyEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(RemoveComponentKey) |
Top
See Also

Reference

RemoveComponentKey Class
VisualComponents.Messages Namespace


RemoveComponentKey.Equals Method (Object)

RemoveComponentKeyEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.RemoveComponentKey.Equals(System.Object)"]

See Also

Reference

RemoveComponentKey Class
Equals Overload
VisualComponents.Messages Namespace


RemoveComponentKey.Equals Method (RemoveComponentKey)

RemoveComponentKeyEquals Method (RemoveComponentKey)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    RemoveComponentKey other
)
public:
virtual bool Equals(
    RemoveComponentKey^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesRemoveComponentKey

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.RemoveComponentKey.Equals(VisualComponents.Messages.RemoveComponentKey)"]

Implements

IEquatableTEquals(T)
See Also

Reference

RemoveComponentKey Class
Equals Overload
VisualComponents.Messages Namespace


RemoveComponentKey.GetHashCode Method

RemoveComponentKeyGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.RemoveComponentKey.GetHashCode"]

See Also

Reference

RemoveComponentKey Class
VisualComponents.Messages Namespace


RemoveComponentKey.MergeFrom Method

RemoveComponentKeyMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(RemoveComponentKey) |
Top
See Also

Reference

RemoveComponentKey Class
VisualComponents.Messages Namespace


RemoveComponentKey.MergeFrom Method (CodedInputStream)

RemoveComponentKeyMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

RemoveComponentKey Class
MergeFrom Overload
VisualComponents.Messages Namespace


RemoveComponentKey.MergeFrom Method (RemoveComponentKey)

RemoveComponentKeyMergeFrom Method (RemoveComponentKey)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    RemoveComponentKey other
)
public:
virtual void MergeFrom(
    RemoveComponentKey^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesRemoveComponentKey

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

RemoveComponentKey Class
MergeFrom Overload
VisualComponents.Messages Namespace


RemoveComponentKey.ToString Method

RemoveComponentKeyToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.RemoveComponentKey.ToString"]

See Also

Reference

RemoveComponentKey Class
VisualComponents.Messages Namespace


RemoveComponentKey.WriteTo Method

RemoveComponentKeyWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

RemoveComponentKey Class
VisualComponents.Messages Namespace


RemoveComponentKey Fields

The RemoveComponentKey type exposes the following members.

Fields
Name | Description
ComponentIdFieldNumber | Field number for the "component_id" field.
Top
See Also

Reference

RemoveComponentKey Class
VisualComponents.Messages Namespace


RemoveComponentKey.ComponentIdFieldNumber Field

RemoveComponentKeyComponentIdFieldNumber Field

Field number for the "component_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ComponentIdFieldNumber = 1
public:
literal int ComponentIdFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

RemoveComponentKey Class
VisualComponents.Messages Namespace


ResetSim Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesResetSim

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ResetSim : IMessage<ResetSim>,
    IMessage, IEquatable<ResetSim>, IDeepCloneable<ResetSim>
public ref class ResetSim sealed : IMessage<ResetSim^>,
    IMessage, IEquatable<ResetSim^>, IDeepCloneable<ResetSim^>

The ResetSim type exposes the following members.

Constructors
 | Name | Description
Public method | ResetSim | Initializes a new instance of the ResetSim class
Public method | ResetSim(ResetSim) | Initializes a new instance of the ResetSim class
Top
Properties
 | Name | Description
 | Descriptor |
Public property | Dummy |
 | Parser |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ResetSim) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(ResetSim) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
DummyFieldNumber | Field number for the "dummy" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


ResetSim Constructor

Overload List
 | Name | Description
Public method | ResetSim | Initializes a new instance of the ResetSim class
Public method | ResetSim(ResetSim) | Initializes a new instance of the ResetSim class
Top
See Also

Reference

ResetSim Class
VisualComponents.Messages Namespace


ResetSim Constructor

Initializes a new instance of the ResetSim class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ResetSim()
public:
ResetSim()
See Also

Reference

ResetSim Class
ResetSim Overload
VisualComponents.Messages Namespace


ResetSim Constructor (ResetSim)

Initializes a new instance of the ResetSim class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ResetSim(
    ResetSim other
)
public:
ResetSim(
    ResetSim^ other
)

Parameters

other
Type: VisualComponents.MessagesResetSim
See Also

Reference

ResetSim Class
ResetSim Overload
VisualComponents.Messages Namespace


ResetSim Properties

The ResetSim type exposes the following members.

Properties
 | Name | Description
 | Descriptor |
Public property | Dummy |
 | Parser |
Top
See Also

Reference

ResetSim Class
VisualComponents.Messages Namespace


ResetSim.Descriptor Property

ResetSimDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

ResetSim Class
VisualComponents.Messages Namespace


ResetSim.Dummy Property

ResetSimDummy Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Dummy { get; set; }
public:
property bool Dummy {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ResetSim Class
VisualComponents.Messages Namespace


ResetSim.Parser Property

ResetSimParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<ResetSim> Parser { get; }
public:
static property MessageParser<ResetSim^>^ Parser {
    MessageParser<ResetSim^>^ get ();
}

Property Value

Type: MessageParserResetSim
See Also

Reference

ResetSim Class
VisualComponents.Messages Namespace


ResetSim Methods

The ResetSim type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ResetSim) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(ResetSim) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ResetSim Class
VisualComponents.Messages Namespace


ResetSim.CalculateSize Method

ResetSimCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.ResetSim.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

ResetSim Class
VisualComponents.Messages Namespace


ResetSim.Clone Method

ResetSimClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ResetSim Clone()
public:
virtual ResetSim^ Clone() sealed

Return Value

Type: ResetSim

[Missing <returns> documentation for "M:VisualComponents.Messages.ResetSim.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

ResetSim Class
VisualComponents.Messages Namespace


ResetSim.Equals Method

ResetSimEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ResetSim) |
Top
See Also

Reference

ResetSim Class
VisualComponents.Messages Namespace


ResetSim.Equals Method (Object)

ResetSimEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.ResetSim.Equals(System.Object)"]

See Also

Reference

ResetSim Class
Equals Overload
VisualComponents.Messages Namespace


ResetSim.Equals Method (ResetSim)

ResetSimEquals Method (ResetSim)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    ResetSim other
)
public:
virtual bool Equals(
    ResetSim^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesResetSim

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.ResetSim.Equals(VisualComponents.Messages.ResetSim)"]

Implements

IEquatableTEquals(T)
See Also

Reference

ResetSim Class
Equals Overload
VisualComponents.Messages Namespace


ResetSim.GetHashCode Method

ResetSimGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.ResetSim.GetHashCode"]

See Also

Reference

ResetSim Class
VisualComponents.Messages Namespace


ResetSim.MergeFrom Method

ResetSimMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(ResetSim) |
Top
See Also

Reference

ResetSim Class
VisualComponents.Messages Namespace


ResetSim.MergeFrom Method (CodedInputStream)

ResetSimMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

ResetSim Class
MergeFrom Overload
VisualComponents.Messages Namespace


ResetSim.MergeFrom Method (ResetSim)

ResetSimMergeFrom Method (ResetSim)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    ResetSim other
)
public:
virtual void MergeFrom(
    ResetSim^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesResetSim

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

ResetSim Class
MergeFrom Overload
VisualComponents.Messages Namespace


ResetSim.ToString Method

ResetSimToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.ResetSim.ToString"]

See Also

Reference

ResetSim Class
VisualComponents.Messages Namespace


ResetSim.WriteTo Method

ResetSimWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

ResetSim Class
VisualComponents.Messages Namespace


ResetSim Fields

The ResetSim type exposes the following members.

Fields
Name | Description
DummyFieldNumber | Field number for the "dummy" field.
Top
See Also

Reference

ResetSim Class
VisualComponents.Messages Namespace


ResetSim.DummyFieldNumber Field

ResetSimDummyFieldNumber Field

Field number for the "dummy" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int DummyFieldNumber = 1
public:
literal int DummyFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

ResetSim Class
VisualComponents.Messages Namespace


RunPauseSim Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesRunPauseSim

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class RunPauseSim : IMessage<RunPauseSim>,
    IMessage, IEquatable<RunPauseSim>, IDeepCloneable<RunPauseSim>
public ref class RunPauseSim sealed : IMessage<RunPauseSim^>,
    IMessage, IEquatable<RunPauseSim^>, IDeepCloneable<RunPauseSim^>

The RunPauseSim type exposes the following members.

Constructors
 | Name | Description
Public method | RunPauseSim | Initializes a new instance of the RunPauseSim class
Public method | RunPauseSim(RunPauseSim) | Initializes a new instance of the RunPauseSim class
Top
Properties
 | Name | Description
 | Descriptor |
Public property | DoRun |
 | Parser |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(RunPauseSim) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(RunPauseSim) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
DoRunFieldNumber | Field number for the "do_run" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


RunPauseSim Constructor

Overload List
 | Name | Description
Public method | RunPauseSim | Initializes a new instance of the RunPauseSim class
Public method | RunPauseSim(RunPauseSim) | Initializes a new instance of the RunPauseSim class
Top
See Also

Reference

RunPauseSim Class
VisualComponents.Messages Namespace


RunPauseSim Constructor

Initializes a new instance of the RunPauseSim class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RunPauseSim()
public:
RunPauseSim()
See Also

Reference

RunPauseSim Class
RunPauseSim Overload
VisualComponents.Messages Namespace


RunPauseSim Constructor (RunPauseSim)

Initializes a new instance of the RunPauseSim class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RunPauseSim(
    RunPauseSim other
)
public:
RunPauseSim(
    RunPauseSim^ other
)

Parameters

other
Type: VisualComponents.MessagesRunPauseSim
See Also

Reference

RunPauseSim Class
RunPauseSim Overload
VisualComponents.Messages Namespace


RunPauseSim Properties

The RunPauseSim type exposes the following members.

Properties
 | Name | Description
 | Descriptor |
Public property | DoRun |
 | Parser |
Top
See Also

Reference

RunPauseSim Class
VisualComponents.Messages Namespace


RunPauseSim.Descriptor Property

RunPauseSimDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

RunPauseSim Class
VisualComponents.Messages Namespace


RunPauseSim.DoRun Property

RunPauseSimDoRun Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool DoRun { get; set; }
public:
property bool DoRun {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

RunPauseSim Class
VisualComponents.Messages Namespace


RunPauseSim.Parser Property

RunPauseSimParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<RunPauseSim> Parser { get; }
public:
static property MessageParser<RunPauseSim^>^ Parser {
    MessageParser<RunPauseSim^>^ get ();
}

Property Value

Type: MessageParserRunPauseSim
See Also

Reference

RunPauseSim Class
VisualComponents.Messages Namespace


RunPauseSim Methods

The RunPauseSim type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(RunPauseSim) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(RunPauseSim) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RunPauseSim Class
VisualComponents.Messages Namespace


RunPauseSim.CalculateSize Method

RunPauseSimCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.RunPauseSim.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

RunPauseSim Class
VisualComponents.Messages Namespace


RunPauseSim.Clone Method

RunPauseSimClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RunPauseSim Clone()
public:
virtual RunPauseSim^ Clone() sealed

Return Value

Type: RunPauseSim

[Missing <returns> documentation for "M:VisualComponents.Messages.RunPauseSim.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

RunPauseSim Class
VisualComponents.Messages Namespace


RunPauseSim.Equals Method

RunPauseSimEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(RunPauseSim) |
Top
See Also

Reference

RunPauseSim Class
VisualComponents.Messages Namespace


RunPauseSim.Equals Method (Object)

RunPauseSimEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.RunPauseSim.Equals(System.Object)"]

See Also

Reference

RunPauseSim Class
Equals Overload
VisualComponents.Messages Namespace


RunPauseSim.Equals Method (RunPauseSim)

RunPauseSimEquals Method (RunPauseSim)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    RunPauseSim other
)
public:
virtual bool Equals(
    RunPauseSim^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesRunPauseSim

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.RunPauseSim.Equals(VisualComponents.Messages.RunPauseSim)"]

Implements

IEquatableTEquals(T)
See Also

Reference

RunPauseSim Class
Equals Overload
VisualComponents.Messages Namespace


RunPauseSim.GetHashCode Method

RunPauseSimGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.RunPauseSim.GetHashCode"]

See Also

Reference

RunPauseSim Class
VisualComponents.Messages Namespace


RunPauseSim.MergeFrom Method

RunPauseSimMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(RunPauseSim) |
Top
See Also

Reference

RunPauseSim Class
VisualComponents.Messages Namespace


RunPauseSim.MergeFrom Method (CodedInputStream)

RunPauseSimMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

RunPauseSim Class
MergeFrom Overload
VisualComponents.Messages Namespace


RunPauseSim.MergeFrom Method (RunPauseSim)

RunPauseSimMergeFrom Method (RunPauseSim)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    RunPauseSim other
)
public:
virtual void MergeFrom(
    RunPauseSim^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesRunPauseSim

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

RunPauseSim Class
MergeFrom Overload
VisualComponents.Messages Namespace


RunPauseSim.ToString Method

RunPauseSimToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.RunPauseSim.ToString"]

See Also

Reference

RunPauseSim Class
VisualComponents.Messages Namespace


RunPauseSim.WriteTo Method

RunPauseSimWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

RunPauseSim Class
VisualComponents.Messages Namespace


RunPauseSim Fields

The RunPauseSim type exposes the following members.

Fields
Name | Description
DoRunFieldNumber | Field number for the "do_run" field.
Top
See Also

Reference

RunPauseSim Class
VisualComponents.Messages Namespace


RunPauseSim.DoRunFieldNumber Field

RunPauseSimDoRunFieldNumber Field

Field number for the "do_run" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int DoRunFieldNumber = 1
public:
literal int DoRunFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

RunPauseSim Class
VisualComponents.Messages Namespace


Services Class

Services/messages and their managers/servers: - handshake - HandshakeServer.cs/cpp (todo) - establishing the connection. - stream - StreamServer.cs/cpp (todo) - serializing the whole layout. Keeping it in sync in the viewer side. - processed by Experience or ThreeJs viewer. - base - BaseServer.cs - vr_events - VREventsServer.cs - sending/receiving VR events and tracking data. Ports: - 6688 - VC.Engine.exe - 7000 - VC.Headless.exe / VC.Engine.exe - 700x - VC.Headless.exe Also see: - C:\bb1\visualcomponents-plugin\Plugin\Proto\Plugin.Cloud.Server.Messages.proto
Inheritance Hierarchy
SystemObject
VisualComponents.MessagesServices

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class Services : IMessage<Services>,
    IMessage, IEquatable<Services>, IDeepCloneable<Services>
public ref class Services sealed : IMessage<Services^>,
    IMessage, IEquatable<Services^>, IDeepCloneable<Services^>

The Services type exposes the following members.

Constructors
 | Name | Description
Public method | Services | Initializes a new instance of the Services class
Public method | Services(Services) | Initializes a new instance of the Services class
Top
Properties
 | Name | Description
Public property | Base |
 | Descriptor |
Public property | Handshake |
 | Parser |
Public property | Stream |
Public property | VrEvents |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(Services) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(Services) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
BaseFieldNumber | Field number for the "base" field.
HandshakeFieldNumber | Field number for the "handshake" field.
StreamFieldNumber | Field number for the "stream" field.
VrEventsFieldNumber | Field number for the "vr_events" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


Services Constructor

Overload List
 | Name | Description
Public method | Services | Initializes a new instance of the Services class
Public method | Services(Services) | Initializes a new instance of the Services class
Top
See Also

Reference

Services Class
VisualComponents.Messages Namespace


Services Constructor

Initializes a new instance of the Services class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Services()
public:
Services()
See Also

Reference

Services Class
Services Overload
VisualComponents.Messages Namespace


Services Constructor (Services)

Initializes a new instance of the Services class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Services(
    Services other
)
public:
Services(
    Services^ other
)

Parameters

other
Type: VisualComponents.MessagesServices
See Also

Reference

Services Class
Services Overload
VisualComponents.Messages Namespace


Services Properties

The Services type exposes the following members.

Properties
 | Name | Description
Public property | Base |
 | Descriptor |
Public property | Handshake |
 | Parser |
Public property | Stream |
Public property | VrEvents |
Top
See Also

Reference

Services Class
VisualComponents.Messages Namespace


Services.Base Property

ServicesBase Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ServicesTypesBase Base { get; set; }
public:
property ServicesTypesBase^ Base {
    ServicesTypesBase^ get ();
    void set (ServicesTypesBase^ value);
}

Property Value

Type: ServicesTypesBase
See Also

Reference

Services Class
VisualComponents.Messages Namespace


Services.Descriptor Property

ServicesDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

Services Class
VisualComponents.Messages Namespace


Services.Handshake Property

ServicesHandshake Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ServicesTypesHandShake Handshake { get; set; }
public:
property ServicesTypesHandShake^ Handshake {
    ServicesTypesHandShake^ get ();
    void set (ServicesTypesHandShake^ value);
}

Property Value

Type: ServicesTypesHandShake
See Also

Reference

Services Class
VisualComponents.Messages Namespace


Services.Parser Property

ServicesParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<Services> Parser { get; }
public:
static property MessageParser<Services^>^ Parser {
    MessageParser<Services^>^ get ();
}

Property Value

Type: MessageParserServices
See Also

Reference

Services Class
VisualComponents.Messages Namespace


Services.Stream Property

ServicesStream Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ServicesTypesStream Stream { get; set; }
public:
property ServicesTypesStream^ Stream {
    ServicesTypesStream^ get ();
    void set (ServicesTypesStream^ value);
}

Property Value

Type: ServicesTypesStream
See Also

Reference

Services Class
VisualComponents.Messages Namespace


Services.VrEvents Property

ServicesVrEvents Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ServicesTypesVREvents VrEvents { get; set; }
public:
property ServicesTypesVREvents^ VrEvents {
    ServicesTypesVREvents^ get ();
    void set (ServicesTypesVREvents^ value);
}

Property Value

Type: ServicesTypesVREvents
See Also

Reference

Services Class
VisualComponents.Messages Namespace


Services Methods

The Services type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(Services) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(Services) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

Services Class
VisualComponents.Messages Namespace


Services.CalculateSize Method

ServicesCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

Services Class
VisualComponents.Messages Namespace


Services.Clone Method

ServicesClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Services Clone()
public:
virtual Services^ Clone() sealed

Return Value

Type: Services

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

Services Class
VisualComponents.Messages Namespace


Services.Equals Method

ServicesEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(Services) |
Top
See Also

Reference

Services Class
VisualComponents.Messages Namespace


Services.Equals Method (Object)

ServicesEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.Equals(System.Object)"]

See Also

Reference

Services Class
Equals Overload
VisualComponents.Messages Namespace


Services.Equals Method (Services)

ServicesEquals Method (Services)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    Services other
)
public:
virtual bool Equals(
    Services^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesServices

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.Equals(VisualComponents.Messages.Services)"]

Implements

IEquatableTEquals(T)
See Also

Reference

Services Class
Equals Overload
VisualComponents.Messages Namespace


Services.GetHashCode Method

ServicesGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.GetHashCode"]

See Also

Reference

Services Class
VisualComponents.Messages Namespace


Services.MergeFrom Method

ServicesMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(Services) |
Top
See Also

Reference

Services Class
VisualComponents.Messages Namespace


Services.MergeFrom Method (CodedInputStream)

ServicesMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

Services Class
MergeFrom Overload
VisualComponents.Messages Namespace


Services.MergeFrom Method (Services)

ServicesMergeFrom Method (Services)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    Services other
)
public:
virtual void MergeFrom(
    Services^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesServices

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

Services Class
MergeFrom Overload
VisualComponents.Messages Namespace


Services.ToString Method

ServicesToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.ToString"]

See Also

Reference

Services Class
VisualComponents.Messages Namespace


Services.WriteTo Method

ServicesWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

Services Class
VisualComponents.Messages Namespace


Services Fields

The Services type exposes the following members.

Fields
Name | Description
BaseFieldNumber | Field number for the "base" field.
HandshakeFieldNumber | Field number for the "handshake" field.
StreamFieldNumber | Field number for the "stream" field.
VrEventsFieldNumber | Field number for the "vr_events" field.
Top
See Also

Reference

Services Class
VisualComponents.Messages Namespace


Services.BaseFieldNumber Field

ServicesBaseFieldNumber Field

Field number for the "base" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int BaseFieldNumber = 30
public:
literal int BaseFieldNumber = 30

Field Value

Type: Int32
See Also

Reference

Services Class
VisualComponents.Messages Namespace


Services.HandshakeFieldNumber Field

ServicesHandshakeFieldNumber Field

Field number for the "handshake" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int HandshakeFieldNumber = 10
public:
literal int HandshakeFieldNumber = 10

Field Value

Type: Int32
See Also

Reference

Services Class
VisualComponents.Messages Namespace


Services.StreamFieldNumber Field

ServicesStreamFieldNumber Field

Field number for the "stream" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int StreamFieldNumber = 20
public:
literal int StreamFieldNumber = 20

Field Value

Type: Int32
See Also

Reference

Services Class
VisualComponents.Messages Namespace


Services.VrEventsFieldNumber Field

ServicesVrEventsFieldNumber Field

Field number for the "vr_events" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int VrEventsFieldNumber = 40
public:
literal int VrEventsFieldNumber = 40

Field Value

Type: Int32
See Also

Reference

Services Class
VisualComponents.Messages Namespace


Services.Types Class

ServicesTypes Class

Container for nested types declared in the Services message type.
Inheritance Hierarchy
SystemObject
VisualComponents.MessagesServicesTypes

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class Types
public ref class Types abstract sealed
See Also

Reference

VisualComponents.Messages Namespace


Services.Types.Base Class

ServicesTypesBase Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesServicesTypesBase

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class Base : IMessage<ServicesTypesBase>,
    IMessage, IEquatable<ServicesTypesBase>, IDeepCloneable<ServicesTypesBase>
public ref class Base sealed : IMessage<ServicesTypesBase^>,
    IMessage, IEquatable<ServicesTypesBase^>, IDeepCloneable<ServicesTypesBase^>

The ServicesTypesBase type exposes the following members.

Constructors
 | Name | Description
Public method | ServicesTypesBase | Initializes a new instance of the ServicesTypesBase class
Public method | ServicesTypesBase(ServicesTypesBase) | Initializes a new instance of the ServicesTypesBase class
Top
Properties
 | Name | Description
Public property | DeleteComponent |
 | Descriptor |
Public property | GetDefaults |
Public property | InitDefaults |
Public property | LoadLayout |
Public property | LoadLayoutEcat |
Public property | MoveComponent |
Public property | MoveResult |
 | Parser |
Public property | PythonRequest |
Public property | ResetSim |
Public property | RunPauseSim |
Public property | SpeedFactor |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ServicesTypesBase) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(ServicesTypesBase) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
DeleteComponentFieldNumber | Field number for the "delete_component" field.
GetDefaultsFieldNumber | Field number for the "get_defaults" field.
InitDefaultsFieldNumber | Field number for the "init_defaults" field.
LoadLayoutEcatFieldNumber | Field number for the "load_layout_ecat" field.
LoadLayoutFieldNumber | Field number for the "load_layout" field.
MoveComponentFieldNumber | Field number for the "move_component" field.
MoveResultFieldNumber | Field number for the "move_result" field.
PythonRequestFieldNumber | Field number for the "python_request" field.
ResetSimFieldNumber | Field number for the "reset_sim" field.
RunPauseSimFieldNumber | Field number for the "run_pause_sim" field.
SpeedFactorFieldNumber | Field number for the "speed_factor" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


Base Constructor

Overload List
 | Name | Description
Public method | ServicesTypesBase | Initializes a new instance of the ServicesTypesBase class
Public method | ServicesTypesBase(ServicesTypesBase) | Initializes a new instance of the ServicesTypesBase class
Top
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base Constructor

ServicesTypesBase Constructor

Initializes a new instance of the ServicesTypesBase class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Base()
public:
Base()
See Also

Reference

ServicesTypesBase Class
ServicesTypesBase Overload
VisualComponents.Messages Namespace


Services.Types.Base Constructor (Services.Types.Base)

ServicesTypesBase Constructor (ServicesTypesBase)

Initializes a new instance of the ServicesTypesBase class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Base(
    ServicesTypesBase other
)
public:
Base(
    ServicesTypesBase^ other
)

Parameters

other
Type: VisualComponents.MessagesServicesTypesBase
See Also

Reference

ServicesTypesBase Class
ServicesTypesBase Overload
VisualComponents.Messages Namespace


Base Properties

The ServicesTypesBase type exposes the following members.

Properties
 | Name | Description
Public property | DeleteComponent |
 | Descriptor |
Public property | GetDefaults |
Public property | InitDefaults |
Public property | LoadLayout |
Public property | LoadLayoutEcat |
Public property | MoveComponent |
Public property | MoveResult |
 | Parser |
Public property | PythonRequest |
Public property | ResetSim |
Public property | RunPauseSim |
Public property | SpeedFactor |
Top
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.DeleteComponent Property

ServicesTypesBaseDeleteComponent Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DeleteComponent DeleteComponent { get; set; }
public:
property DeleteComponent^ DeleteComponent {
    DeleteComponent^ get ();
    void set (DeleteComponent^ value);
}

Property Value

Type: DeleteComponent
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.Descriptor Property

ServicesTypesBaseDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.GetDefaults Property

ServicesTypesBaseGetDefaults Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GetDefaults GetDefaults { get; set; }
public:
property GetDefaults^ GetDefaults {
    GetDefaults^ get ();
    void set (GetDefaults^ value);
}

Property Value

Type: GetDefaults
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.InitDefaults Property

ServicesTypesBaseInitDefaults Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InitDefaults InitDefaults { get; set; }
public:
property InitDefaults^ InitDefaults {
    InitDefaults^ get ();
    void set (InitDefaults^ value);
}

Property Value

Type: InitDefaults
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.LoadLayout Property

ServicesTypesBaseLoadLayout Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LoadLayoutSimple LoadLayout { get; set; }
public:
property LoadLayoutSimple^ LoadLayout {
    LoadLayoutSimple^ get ();
    void set (LoadLayoutSimple^ value);
}

Property Value

Type: LoadLayoutSimple
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.LoadLayoutEcat Property

ServicesTypesBaseLoadLayoutEcat Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LoadLayoutEcat LoadLayoutEcat { get; set; }
public:
property LoadLayoutEcat^ LoadLayoutEcat {
    LoadLayoutEcat^ get ();
    void set (LoadLayoutEcat^ value);
}

Property Value

Type: LoadLayoutEcat
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.MoveComponent Property

ServicesTypesBaseMoveComponent Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MoveComponent MoveComponent { get; set; }
public:
property MoveComponent^ MoveComponent {
    MoveComponent^ get ();
    void set (MoveComponent^ value);
}

Property Value

Type: MoveComponent
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.MoveResult Property

ServicesTypesBaseMoveResult Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MoveResult MoveResult { get; set; }
public:
property MoveResult^ MoveResult {
    MoveResult^ get ();
    void set (MoveResult^ value);
}

Property Value

Type: MoveResult
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.Parser Property

ServicesTypesBaseParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<ServicesTypesBase> Parser { get; }
public:
static property MessageParser<ServicesTypesBase^>^ Parser {
    MessageParser<ServicesTypesBase^>^ get ();
}

Property Value

Type: MessageParserServicesTypesBase
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.PythonRequest Property

ServicesTypesBasePythonRequest Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PythonRequest PythonRequest { get; set; }
public:
property PythonRequest^ PythonRequest {
    PythonRequest^ get ();
    void set (PythonRequest^ value);
}

Property Value

Type: PythonRequest
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.ResetSim Property

ServicesTypesBaseResetSim Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ResetSim ResetSim { get; set; }
public:
property ResetSim^ ResetSim {
    ResetSim^ get ();
    void set (ResetSim^ value);
}

Property Value

Type: ResetSim
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.RunPauseSim Property

ServicesTypesBaseRunPauseSim Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RunPauseSim RunPauseSim { get; set; }
public:
property RunPauseSim^ RunPauseSim {
    RunPauseSim^ get ();
    void set (RunPauseSim^ value);
}

Property Value

Type: RunPauseSim
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.SpeedFactor Property

ServicesTypesBaseSpeedFactor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SpeedFactor SpeedFactor { get; set; }
public:
property SpeedFactor^ SpeedFactor {
    SpeedFactor^ get ();
    void set (SpeedFactor^ value);
}

Property Value

Type: SpeedFactor
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Base Methods

The ServicesTypesBase type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ServicesTypesBase) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(ServicesTypesBase) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.CalculateSize Method

ServicesTypesBaseCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.Types.Base.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.Clone Method

ServicesTypesBaseClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ServicesTypesBase Clone()
public:
virtual ServicesTypesBase^ Clone() sealed

Return Value

Type: ServicesTypesBase

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.Types.Base.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Base.Equals Method

BaseEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ServicesTypesBase) |
Top
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.Equals Method (Object)

ServicesTypesBaseEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.Types.Base.Equals(System.Object)"]

See Also

Reference

ServicesTypesBase Class
Equals Overload
VisualComponents.Messages Namespace


Services.Types.Base.Equals Method (Services.Types.Base)

ServicesTypesBaseEquals Method (ServicesTypesBase)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    ServicesTypesBase other
)
public:
virtual bool Equals(
    ServicesTypesBase^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesServicesTypesBase

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.Types.Base.Equals(VisualComponents.Messages.Services.Types.Base)"]

Implements

IEquatableTEquals(T)
See Also

Reference

ServicesTypesBase Class
Equals Overload
VisualComponents.Messages Namespace


Services.Types.Base.GetHashCode Method

ServicesTypesBaseGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.Types.Base.GetHashCode"]

See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Base.MergeFrom Method

BaseMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(ServicesTypesBase) |
Top
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.MergeFrom Method (CodedInputStream)

ServicesTypesBaseMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

ServicesTypesBase Class
MergeFrom Overload
VisualComponents.Messages Namespace


Services.Types.Base.MergeFrom Method (Services.Types.Base)

ServicesTypesBaseMergeFrom Method (ServicesTypesBase)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    ServicesTypesBase other
)
public:
virtual void MergeFrom(
    ServicesTypesBase^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesServicesTypesBase

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

ServicesTypesBase Class
MergeFrom Overload
VisualComponents.Messages Namespace


Services.Types.Base.ToString Method

ServicesTypesBaseToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.Types.Base.ToString"]

See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.WriteTo Method

ServicesTypesBaseWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Base Fields

The ServicesTypesBase type exposes the following members.

Fields
Name | Description
DeleteComponentFieldNumber | Field number for the "delete_component" field.
GetDefaultsFieldNumber | Field number for the "get_defaults" field.
InitDefaultsFieldNumber | Field number for the "init_defaults" field.
LoadLayoutEcatFieldNumber | Field number for the "load_layout_ecat" field.
LoadLayoutFieldNumber | Field number for the "load_layout" field.
MoveComponentFieldNumber | Field number for the "move_component" field.
MoveResultFieldNumber | Field number for the "move_result" field.
PythonRequestFieldNumber | Field number for the "python_request" field.
ResetSimFieldNumber | Field number for the "reset_sim" field.
RunPauseSimFieldNumber | Field number for the "run_pause_sim" field.
SpeedFactorFieldNumber | Field number for the "speed_factor" field.
Top
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.DeleteComponentFieldNumber Field

ServicesTypesBaseDeleteComponentFieldNumber Field

Field number for the "delete_component" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int DeleteComponentFieldNumber = 100
public:
literal int DeleteComponentFieldNumber = 100

Field Value

Type: Int32
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.GetDefaultsFieldNumber Field

ServicesTypesBaseGetDefaultsFieldNumber Field

Field number for the "get_defaults" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int GetDefaultsFieldNumber = 20
public:
literal int GetDefaultsFieldNumber = 20

Field Value

Type: Int32
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.InitDefaultsFieldNumber Field

ServicesTypesBaseInitDefaultsFieldNumber Field

Field number for the "init_defaults" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int InitDefaultsFieldNumber = 10
public:
literal int InitDefaultsFieldNumber = 10

Field Value

Type: Int32
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.LoadLayoutEcatFieldNumber Field

ServicesTypesBaseLoadLayoutEcatFieldNumber Field

Field number for the "load_layout_ecat" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int LoadLayoutEcatFieldNumber = 60
public:
literal int LoadLayoutEcatFieldNumber = 60

Field Value

Type: Int32
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.LoadLayoutFieldNumber Field

ServicesTypesBaseLoadLayoutFieldNumber Field

Field number for the "load_layout" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int LoadLayoutFieldNumber = 70
public:
literal int LoadLayoutFieldNumber = 70

Field Value

Type: Int32
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.MoveComponentFieldNumber Field

ServicesTypesBaseMoveComponentFieldNumber Field

Field number for the "move_component" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int MoveComponentFieldNumber = 80
public:
literal int MoveComponentFieldNumber = 80

Field Value

Type: Int32
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.MoveResultFieldNumber Field

ServicesTypesBaseMoveResultFieldNumber Field

Field number for the "move_result" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int MoveResultFieldNumber = 90
public:
literal int MoveResultFieldNumber = 90

Field Value

Type: Int32
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.PythonRequestFieldNumber Field

ServicesTypesBasePythonRequestFieldNumber Field

Field number for the "python_request" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int PythonRequestFieldNumber = 110
public:
literal int PythonRequestFieldNumber = 110

Field Value

Type: Int32
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.ResetSimFieldNumber Field

ServicesTypesBaseResetSimFieldNumber Field

Field number for the "reset_sim" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ResetSimFieldNumber = 40
public:
literal int ResetSimFieldNumber = 40

Field Value

Type: Int32
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.RunPauseSimFieldNumber Field

ServicesTypesBaseRunPauseSimFieldNumber Field

Field number for the "run_pause_sim" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int RunPauseSimFieldNumber = 50
public:
literal int RunPauseSimFieldNumber = 50

Field Value

Type: Int32
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.Base.SpeedFactorFieldNumber Field

ServicesTypesBaseSpeedFactorFieldNumber Field

Field number for the "speed_factor" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int SpeedFactorFieldNumber = 30
public:
literal int SpeedFactorFieldNumber = 30

Field Value

Type: Int32
See Also

Reference

ServicesTypesBase Class
VisualComponents.Messages Namespace


Services.Types.HandShake Class

ServicesTypesHandShake Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesServicesTypesHandShake

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class HandShake : IMessage<ServicesTypesHandShake>,
    IMessage, IEquatable<ServicesTypesHandShake>, IDeepCloneable<ServicesTypesHandShake>
public ref class HandShake sealed : IMessage<ServicesTypesHandShake^>,
    IMessage, IEquatable<ServicesTypesHandShake^>, IDeepCloneable<ServicesTypesHandShake^>

The ServicesTypesHandShake type exposes the following members.

Constructors
 | Name | Description
Public method | ServicesTypesHandShake | Initializes a new instance of the ServicesTypesHandShake class
Public method | ServicesTypesHandShake(ServicesTypesHandShake) | Initializes a new instance of the ServicesTypesHandShake class
Top
Properties
 | Name | Description
Public property | AddSync |
Public property | CloseStream |
Public property | ConnectStream |
 | Descriptor |
Public property | FinishMessage |
 | Parser |
Public property | StartSocket |
Public property | StartStream |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ServicesTypesHandShake) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(ServicesTypesHandShake) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
AddSyncFieldNumber | Field number for the "add_sync" field.
CloseStreamFieldNumber | Field number for the "close_stream" field.
ConnectStreamFieldNumber | Field number for the "connect_stream" field.
FinishMessageFieldNumber | Field number for the "finish_message" field.
StartSocketFieldNumber | Field number for the "start_socket" field.
StartStreamFieldNumber | Field number for the "start_stream" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


HandShake Constructor

Overload List
 | Name | Description
Public method | ServicesTypesHandShake | Initializes a new instance of the ServicesTypesHandShake class
Public method | ServicesTypesHandShake(ServicesTypesHandShake) | Initializes a new instance of the ServicesTypesHandShake class
Top
See Also

Reference

ServicesTypesHandShake Class
VisualComponents.Messages Namespace


Services.Types.HandShake Constructor

ServicesTypesHandShake Constructor

Initializes a new instance of the ServicesTypesHandShake class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public HandShake()
public:
HandShake()
See Also

Reference

ServicesTypesHandShake Class
ServicesTypesHandShake Overload
VisualComponents.Messages Namespace


Services.Types.HandShake Constructor (Services.Types.HandShake)

ServicesTypesHandShake Constructor (ServicesTypesHandShake)

Initializes a new instance of the ServicesTypesHandShake class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public HandShake(
    ServicesTypesHandShake other
)
public:
HandShake(
    ServicesTypesHandShake^ other
)

Parameters

other
Type: VisualComponents.MessagesServicesTypesHandShake
See Also

Reference

ServicesTypesHandShake Class
ServicesTypesHandShake Overload
VisualComponents.Messages Namespace


HandShake Properties

The ServicesTypesHandShake type exposes the following members.

Properties
 | Name | Description
Public property | AddSync |
Public property | CloseStream |
Public property | ConnectStream |
 | Descriptor |
Public property | FinishMessage |
 | Parser |
Public property | StartSocket |
Public property | StartStream |
Top
See Also

Reference

ServicesTypesHandShake Class
VisualComponents.Messages Namespace


Services.Types.HandShake.AddSync Property

ServicesTypesHandShakeAddSync Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddSync AddSync { get; set; }
public:
property AddSync^ AddSync {
    AddSync^ get ();
    void set (AddSync^ value);
}

Property Value

Type: AddSync
See Also

Reference

ServicesTypesHandShake Class
VisualComponents.Messages Namespace


Services.Types.HandShake.CloseStream Property

ServicesTypesHandShakeCloseStream Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CloseStream CloseStream { get; set; }
public:
property CloseStream^ CloseStream {
    CloseStream^ get ();
    void set (CloseStream^ value);
}

Property Value

Type: CloseStream
See Also

Reference

ServicesTypesHandShake Class
VisualComponents.Messages Namespace


Services.Types.HandShake.ConnectStream Property

ServicesTypesHandShakeConnectStream Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectStream ConnectStream { get; set; }
public:
property ConnectStream^ ConnectStream {
    ConnectStream^ get ();
    void set (ConnectStream^ value);
}

Property Value

Type: ConnectStream
See Also

Reference

ServicesTypesHandShake Class
VisualComponents.Messages Namespace


Services.Types.HandShake.Descriptor Property

ServicesTypesHandShakeDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

ServicesTypesHandShake Class
VisualComponents.Messages Namespace


Services.Types.HandShake.FinishMessage Property

ServicesTypesHandShakeFinishMessage Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FinishMessage FinishMessage { get; set; }
public:
property FinishMessage^ FinishMessage {
    FinishMessage^ get ();
    void set (FinishMessage^ value);
}

Property Value

Type: FinishMessage
See Also

Reference

ServicesTypesHandShake Class
VisualComponents.Messages Namespace


Services.Types.HandShake.Parser Property

ServicesTypesHandShakeParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<ServicesTypesHandShake> Parser { get; }
public:
static property MessageParser<ServicesTypesHandShake^>^ Parser {
    MessageParser<ServicesTypesHandShake^>^ get ();
}

Property Value

Type: MessageParserServicesTypesHandShake
See Also

Reference

ServicesTypesHandShake Class
VisualComponents.Messages Namespace


Services.Types.HandShake.StartSocket Property

ServicesTypesHandShakeStartSocket Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StartSocket StartSocket { get; set; }
public:
property StartSocket^ StartSocket {
    StartSocket^ get ();
    void set (StartSocket^ value);
}

Property Value

Type: StartSocket
See Also

Reference

ServicesTypesHandShake Class
VisualComponents.Messages Namespace


Services.Types.HandShake.StartStream Property

ServicesTypesHandShakeStartStream Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StartStream StartStream { get; set; }
public:
property StartStream^ StartStream {
    StartStream^ get ();
    void set (StartStream^ value);
}

Property Value

Type: StartStream
See Also

Reference

ServicesTypesHandShake Class
VisualComponents.Messages Namespace


HandShake Methods

The ServicesTypesHandShake type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ServicesTypesHandShake) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(ServicesTypesHandShake) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ServicesTypesHandShake Class
VisualComponents.Messages Namespace


Services.Types.HandShake.CalculateSize Method

ServicesTypesHandShakeCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.Types.HandShake.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

ServicesTypesHandShake Class
VisualComponents.Messages Namespace


Services.Types.HandShake.Clone Method

ServicesTypesHandShakeClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ServicesTypesHandShake Clone()
public:
virtual ServicesTypesHandShake^ Clone() sealed

Return Value

Type: ServicesTypesHandShake

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.Types.HandShake.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

ServicesTypesHandShake Class
VisualComponents.Messages Namespace


HandShake.Equals Method

HandShakeEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ServicesTypesHandShake) |
Top
See Also

Reference

ServicesTypesHandShake Class
VisualComponents.Messages Namespace


Services.Types.HandShake.Equals Method (Object)

ServicesTypesHandShakeEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.Types.HandShake.Equals(System.Object)"]

See Also

Reference

ServicesTypesHandShake Class
Equals Overload
VisualComponents.Messages Namespace


Services.Types.HandShake.Equals Method (Services.Types.HandShake)

ServicesTypesHandShakeEquals Method (ServicesTypesHandShake)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    ServicesTypesHandShake other
)
public:
virtual bool Equals(
    ServicesTypesHandShake^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesServicesTypesHandShake

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.Types.HandShake.Equals(VisualComponents.Messages.Services.Types.HandShake)"]

Implements

IEquatableTEquals(T)
See Also

Reference

ServicesTypesHandShake Class
Equals Overload
VisualComponents.Messages Namespace


Services.Types.HandShake.GetHashCode Method

ServicesTypesHandShakeGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.Types.HandShake.GetHashCode"]

See Also

Reference

ServicesTypesHandShake Class
VisualComponents.Messages Namespace


HandShake.MergeFrom Method

HandShakeMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(ServicesTypesHandShake) |
Top
See Also

Reference

ServicesTypesHandShake Class
VisualComponents.Messages Namespace


Services.Types.HandShake.MergeFrom Method (CodedInputStream)

ServicesTypesHandShakeMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

ServicesTypesHandShake Class
MergeFrom Overload
VisualComponents.Messages Namespace


Services.Types.HandShake.MergeFrom Method (Services.Types.HandShake)

ServicesTypesHandShakeMergeFrom Method (ServicesTypesHandShake)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    ServicesTypesHandShake other
)
public:
virtual void MergeFrom(
    ServicesTypesHandShake^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesServicesTypesHandShake

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

ServicesTypesHandShake Class
MergeFrom Overload
VisualComponents.Messages Namespace


Services.Types.HandShake.ToString Method

ServicesTypesHandShakeToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.Types.HandShake.ToString"]

See Also

Reference

ServicesTypesHandShake Class
VisualComponents.Messages Namespace


Services.Types.HandShake.WriteTo Method

ServicesTypesHandShakeWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

ServicesTypesHandShake Class
VisualComponents.Messages Namespace


HandShake Fields

The ServicesTypesHandShake type exposes the following members.

Fields
Name | Description
AddSyncFieldNumber | Field number for the "add_sync" field.
CloseStreamFieldNumber | Field number for the "close_stream" field.
ConnectStreamFieldNumber | Field number for the "connect_stream" field.
FinishMessageFieldNumber | Field number for the "finish_message" field.
StartSocketFieldNumber | Field number for the "start_socket" field.
StartStreamFieldNumber | Field number for the "start_stream" field.
Top
See Also

Reference

ServicesTypesHandShake Class
VisualComponents.Messages Namespace


Services.Types.HandShake.AddSyncFieldNumber Field

ServicesTypesHandShakeAddSyncFieldNumber Field

Field number for the "add_sync" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int AddSyncFieldNumber = 40
public:
literal int AddSyncFieldNumber = 40

Field Value

Type: Int32
See Also

Reference

ServicesTypesHandShake Class
VisualComponents.Messages Namespace


Services.Types.HandShake.CloseStreamFieldNumber Field

ServicesTypesHandShakeCloseStreamFieldNumber Field

Field number for the "close_stream" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int CloseStreamFieldNumber = 50
public:
literal int CloseStreamFieldNumber = 50

Field Value

Type: Int32
See Also

Reference

ServicesTypesHandShake Class
VisualComponents.Messages Namespace


Services.Types.HandShake.ConnectStreamFieldNumber Field

ServicesTypesHandShakeConnectStreamFieldNumber Field

Field number for the "connect_stream" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ConnectStreamFieldNumber = 10
public:
literal int ConnectStreamFieldNumber = 10

Field Value

Type: Int32
See Also

Reference

ServicesTypesHandShake Class
VisualComponents.Messages Namespace


Services.Types.HandShake.FinishMessageFieldNumber Field

ServicesTypesHandShakeFinishMessageFieldNumber Field

Field number for the "finish_message" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int FinishMessageFieldNumber = 60
public:
literal int FinishMessageFieldNumber = 60

Field Value

Type: Int32
See Also

Reference

ServicesTypesHandShake Class
VisualComponents.Messages Namespace


Services.Types.HandShake.StartSocketFieldNumber Field

ServicesTypesHandShakeStartSocketFieldNumber Field

Field number for the "start_socket" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int StartSocketFieldNumber = 20
public:
literal int StartSocketFieldNumber = 20

Field Value

Type: Int32
See Also

Reference

ServicesTypesHandShake Class
VisualComponents.Messages Namespace


Services.Types.HandShake.StartStreamFieldNumber Field

ServicesTypesHandShakeStartStreamFieldNumber Field

Field number for the "start_stream" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int StartStreamFieldNumber = 30
public:
literal int StartStreamFieldNumber = 30

Field Value

Type: Int32
See Also

Reference

ServicesTypesHandShake Class
VisualComponents.Messages Namespace


Services.Types.Stream Class

ServicesTypesStream Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesServicesTypesStream

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class Stream : IMessage<ServicesTypesStream>,
    IMessage, IEquatable<ServicesTypesStream>, IDeepCloneable<ServicesTypesStream>
public ref class Stream sealed : IMessage<ServicesTypesStream^>,
    IMessage, IEquatable<ServicesTypesStream^>, IDeepCloneable<ServicesTypesStream^>

The ServicesTypesStream type exposes the following members.

Constructors
 | Name | Description
Public method | ServicesTypesStream | Initializes a new instance of the ServicesTypesStream class
Public method | ServicesTypesStream(ServicesTypesStream) | Initializes a new instance of the ServicesTypesStream class
Top
Properties
 | Name | Description
Public property | AbsoluteKey |
Public property | AddCamera |
Public property | AddComponent |
Public property | AddMaterial |
Public property | AddMesh |
Public property | AddNode |
Public property | AddShaderMaterial |
Public property | AddSubLine |
Public property | AddSubMesh |
Public property | AddSubMeshTopology |
Public property | AddSubMeshTopologyCurve |
Public property | AddTexture |
Public property | AddTimestep |
Public property | AddView |
Public property | ChangeMeshKey |
 | Descriptor |
 | Parser |
Public property | PreviewImages |
Public property | RemoveComponentKey |
Public property | SetBackground |
Public property | SetFloor |
Public property | SetNodeMaterials |
Public property | SetNodeMatrix |
Public property | SetParentKey |
Public property | SetUvKey |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ServicesTypesStream) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(ServicesTypesStream) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
AbsoluteKeyFieldNumber | Field number for the "absolute_key" field.
AddCameraFieldNumber | Field number for the "add_camera" field.
AddComponentFieldNumber | Field number for the "add_component" field.
AddMaterialFieldNumber | Field number for the "add_material" field.
AddMeshFieldNumber | Field number for the "add_mesh" field.
AddNodeFieldNumber | Field number for the "add_node" field.
AddShaderMaterialFieldNumber | Field number for the "add_shader_material" field.
AddSubLineFieldNumber | Field number for the "add_sub_line" field.
AddSubMeshFieldNumber | Field number for the "add_sub_mesh" field.
AddSubMeshTopologyCurveFieldNumber | Field number for the "add_sub_mesh_topology_curve" field.
AddSubMeshTopologyFieldNumber | Field number for the "add_sub_mesh_topology" field.
AddTextureFieldNumber | Field number for the "add_texture" field.
AddTimestepFieldNumber | Field number for the "add_timestep" field.
AddViewFieldNumber | Field number for the "add_view" field.
ChangeMeshKeyFieldNumber | Field number for the "change_mesh_key" field.
PreviewImagesFieldNumber | Field number for the "preview_images" field.
RemoveComponentKeyFieldNumber | Field number for the "remove_component_key" field.
SetBackgroundFieldNumber | Field number for the "set_background" field.
SetFloorFieldNumber | Field number for the "set_floor" field.
SetNodeMaterialsFieldNumber | Field number for the "set_node_materials" field.
SetNodeMatrixFieldNumber | Field number for the "set_node_matrix" field.
SetParentKeyFieldNumber | Field number for the "set_parent_key" field.
SetUvKeyFieldNumber | Field number for the "set_uv_key" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


Stream Constructor

Overload List
 | Name | Description
Public method | ServicesTypesStream | Initializes a new instance of the ServicesTypesStream class
Public method | ServicesTypesStream(ServicesTypesStream) | Initializes a new instance of the ServicesTypesStream class
Top
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream Constructor

ServicesTypesStream Constructor

Initializes a new instance of the ServicesTypesStream class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Stream()
public:
Stream()
See Also

Reference

ServicesTypesStream Class
ServicesTypesStream Overload
VisualComponents.Messages Namespace


Services.Types.Stream Constructor (Services.Types.Stream)

ServicesTypesStream Constructor (ServicesTypesStream)

Initializes a new instance of the ServicesTypesStream class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Stream(
    ServicesTypesStream other
)
public:
Stream(
    ServicesTypesStream^ other
)

Parameters

other
Type: VisualComponents.MessagesServicesTypesStream
See Also

Reference

ServicesTypesStream Class
ServicesTypesStream Overload
VisualComponents.Messages Namespace


Stream Properties

The ServicesTypesStream type exposes the following members.

Properties
 | Name | Description
Public property | AbsoluteKey |
Public property | AddCamera |
Public property | AddComponent |
Public property | AddMaterial |
Public property | AddMesh |
Public property | AddNode |
Public property | AddShaderMaterial |
Public property | AddSubLine |
Public property | AddSubMesh |
Public property | AddSubMeshTopology |
Public property | AddSubMeshTopologyCurve |
Public property | AddTexture |
Public property | AddTimestep |
Public property | AddView |
Public property | ChangeMeshKey |
 | Descriptor |
 | Parser |
Public property | PreviewImages |
Public property | RemoveComponentKey |
Public property | SetBackground |
Public property | SetFloor |
Public property | SetNodeMaterials |
Public property | SetNodeMatrix |
Public property | SetParentKey |
Public property | SetUvKey |
Top
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.AbsoluteKey Property

ServicesTypesStreamAbsoluteKey Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AbsoluteKey AbsoluteKey { get; set; }
public:
property AbsoluteKey^ AbsoluteKey {
    AbsoluteKey^ get ();
    void set (AbsoluteKey^ value);
}

Property Value

Type: AbsoluteKey
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.AddCamera Property

ServicesTypesStreamAddCamera Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddCamera AddCamera { get; set; }
public:
property AddCamera^ AddCamera {
    AddCamera^ get ();
    void set (AddCamera^ value);
}

Property Value

Type: AddCamera
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.AddComponent Property

ServicesTypesStreamAddComponent Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddComponent AddComponent { get; set; }
public:
property AddComponent^ AddComponent {
    AddComponent^ get ();
    void set (AddComponent^ value);
}

Property Value

Type: AddComponent
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.AddMaterial Property

ServicesTypesStreamAddMaterial Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddMaterial AddMaterial { get; set; }
public:
property AddMaterial^ AddMaterial {
    AddMaterial^ get ();
    void set (AddMaterial^ value);
}

Property Value

Type: AddMaterial
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.AddMesh Property

ServicesTypesStreamAddMesh Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddMesh AddMesh { get; set; }
public:
property AddMesh^ AddMesh {
    AddMesh^ get ();
    void set (AddMesh^ value);
}

Property Value

Type: AddMesh
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.AddNode Property

ServicesTypesStreamAddNode Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddNode AddNode { get; set; }
public:
property AddNode^ AddNode {
    AddNode^ get ();
    void set (AddNode^ value);
}

Property Value

Type: AddNode
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.AddShaderMaterial Property

ServicesTypesStreamAddShaderMaterial Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddShaderMaterial AddShaderMaterial { get; set; }
public:
property AddShaderMaterial^ AddShaderMaterial {
    AddShaderMaterial^ get ();
    void set (AddShaderMaterial^ value);
}

Property Value

Type: AddShaderMaterial
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.AddSubLine Property

ServicesTypesStreamAddSubLine Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddSubLine AddSubLine { get; set; }
public:
property AddSubLine^ AddSubLine {
    AddSubLine^ get ();
    void set (AddSubLine^ value);
}

Property Value

Type: AddSubLine
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.AddSubMesh Property

ServicesTypesStreamAddSubMesh Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddSubMesh AddSubMesh { get; set; }
public:
property AddSubMesh^ AddSubMesh {
    AddSubMesh^ get ();
    void set (AddSubMesh^ value);
}

Property Value

Type: AddSubMesh
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.AddSubMeshTopology Property

ServicesTypesStreamAddSubMeshTopology Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddSubMeshTopology AddSubMeshTopology { get; set; }
public:
property AddSubMeshTopology^ AddSubMeshTopology {
    AddSubMeshTopology^ get ();
    void set (AddSubMeshTopology^ value);
}

Property Value

Type: AddSubMeshTopology
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.AddSubMeshTopologyCurve Property

ServicesTypesStreamAddSubMeshTopologyCurve Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddSubMeshTopologyCurve AddSubMeshTopologyCurve { get; set; }
public:
property AddSubMeshTopologyCurve^ AddSubMeshTopologyCurve {
    AddSubMeshTopologyCurve^ get ();
    void set (AddSubMeshTopologyCurve^ value);
}

Property Value

Type: AddSubMeshTopologyCurve
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.AddTexture Property

ServicesTypesStreamAddTexture Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddTexture AddTexture { get; set; }
public:
property AddTexture^ AddTexture {
    AddTexture^ get ();
    void set (AddTexture^ value);
}

Property Value

Type: AddTexture
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.AddTimestep Property

ServicesTypesStreamAddTimestep Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddTimeStep AddTimestep { get; set; }
public:
property AddTimeStep^ AddTimestep {
    AddTimeStep^ get ();
    void set (AddTimeStep^ value);
}

Property Value

Type: AddTimeStep
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.AddView Property

ServicesTypesStreamAddView Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AddView AddView { get; set; }
public:
property AddView^ AddView {
    AddView^ get ();
    void set (AddView^ value);
}

Property Value

Type: AddView
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.ChangeMeshKey Property

ServicesTypesStreamChangeMeshKey Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ChangeMeshKey ChangeMeshKey { get; set; }
public:
property ChangeMeshKey^ ChangeMeshKey {
    ChangeMeshKey^ get ();
    void set (ChangeMeshKey^ value);
}

Property Value

Type: ChangeMeshKey
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.Descriptor Property

ServicesTypesStreamDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.Parser Property

ServicesTypesStreamParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<ServicesTypesStream> Parser { get; }
public:
static property MessageParser<ServicesTypesStream^>^ Parser {
    MessageParser<ServicesTypesStream^>^ get ();
}

Property Value

Type: MessageParserServicesTypesStream
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.PreviewImages Property

ServicesTypesStreamPreviewImages Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PreviewImages PreviewImages { get; set; }
public:
property PreviewImages^ PreviewImages {
    PreviewImages^ get ();
    void set (PreviewImages^ value);
}

Property Value

Type: PreviewImages
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.RemoveComponentKey Property

ServicesTypesStreamRemoveComponentKey Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RemoveComponentKey RemoveComponentKey { get; set; }
public:
property RemoveComponentKey^ RemoveComponentKey {
    RemoveComponentKey^ get ();
    void set (RemoveComponentKey^ value);
}

Property Value

Type: RemoveComponentKey
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.SetBackground Property

ServicesTypesStreamSetBackground Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetBackground SetBackground { get; set; }
public:
property SetBackground^ SetBackground {
    SetBackground^ get ();
    void set (SetBackground^ value);
}

Property Value

Type: SetBackground
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.SetFloor Property

ServicesTypesStreamSetFloor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetFloor SetFloor { get; set; }
public:
property SetFloor^ SetFloor {
    SetFloor^ get ();
    void set (SetFloor^ value);
}

Property Value

Type: SetFloor
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.SetNodeMaterials Property

ServicesTypesStreamSetNodeMaterials Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetNodeMaterials SetNodeMaterials { get; set; }
public:
property SetNodeMaterials^ SetNodeMaterials {
    SetNodeMaterials^ get ();
    void set (SetNodeMaterials^ value);
}

Property Value

Type: SetNodeMaterials
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.SetNodeMatrix Property

ServicesTypesStreamSetNodeMatrix Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetNodeMatrix SetNodeMatrix { get; set; }
public:
property SetNodeMatrix^ SetNodeMatrix {
    SetNodeMatrix^ get ();
    void set (SetNodeMatrix^ value);
}

Property Value

Type: SetNodeMatrix
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.SetParentKey Property

ServicesTypesStreamSetParentKey Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetParentKey SetParentKey { get; set; }
public:
property SetParentKey^ SetParentKey {
    SetParentKey^ get ();
    void set (SetParentKey^ value);
}

Property Value

Type: SetParentKey
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.SetUvKey Property

ServicesTypesStreamSetUvKey Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetUVKey SetUvKey { get; set; }
public:
property SetUVKey^ SetUvKey {
    SetUVKey^ get ();
    void set (SetUVKey^ value);
}

Property Value

Type: SetUVKey
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Stream Methods

The ServicesTypesStream type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ServicesTypesStream) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(ServicesTypesStream) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.CalculateSize Method

ServicesTypesStreamCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.Types.Stream.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.Clone Method

ServicesTypesStreamClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ServicesTypesStream Clone()
public:
virtual ServicesTypesStream^ Clone() sealed

Return Value

Type: ServicesTypesStream

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.Types.Stream.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Stream.Equals Method

StreamEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ServicesTypesStream) |
Top
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.Equals Method (Object)

ServicesTypesStreamEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.Types.Stream.Equals(System.Object)"]

See Also

Reference

ServicesTypesStream Class
Equals Overload
VisualComponents.Messages Namespace


Services.Types.Stream.Equals Method (Services.Types.Stream)

ServicesTypesStreamEquals Method (ServicesTypesStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    ServicesTypesStream other
)
public:
virtual bool Equals(
    ServicesTypesStream^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesServicesTypesStream

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.Types.Stream.Equals(VisualComponents.Messages.Services.Types.Stream)"]

Implements

IEquatableTEquals(T)
See Also

Reference

ServicesTypesStream Class
Equals Overload
VisualComponents.Messages Namespace


Services.Types.Stream.GetHashCode Method

ServicesTypesStreamGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.Types.Stream.GetHashCode"]

See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Stream.MergeFrom Method

StreamMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(ServicesTypesStream) |
Top
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.MergeFrom Method (CodedInputStream)

ServicesTypesStreamMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

ServicesTypesStream Class
MergeFrom Overload
VisualComponents.Messages Namespace


Services.Types.Stream.MergeFrom Method (Services.Types.Stream)

ServicesTypesStreamMergeFrom Method (ServicesTypesStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    ServicesTypesStream other
)
public:
virtual void MergeFrom(
    ServicesTypesStream^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesServicesTypesStream

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

ServicesTypesStream Class
MergeFrom Overload
VisualComponents.Messages Namespace


Services.Types.Stream.ToString Method

ServicesTypesStreamToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.Types.Stream.ToString"]

See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.WriteTo Method

ServicesTypesStreamWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Stream Fields

The ServicesTypesStream type exposes the following members.

Fields
Name | Description
AbsoluteKeyFieldNumber | Field number for the "absolute_key" field.
AddCameraFieldNumber | Field number for the "add_camera" field.
AddComponentFieldNumber | Field number for the "add_component" field.
AddMaterialFieldNumber | Field number for the "add_material" field.
AddMeshFieldNumber | Field number for the "add_mesh" field.
AddNodeFieldNumber | Field number for the "add_node" field.
AddShaderMaterialFieldNumber | Field number for the "add_shader_material" field.
AddSubLineFieldNumber | Field number for the "add_sub_line" field.
AddSubMeshFieldNumber | Field number for the "add_sub_mesh" field.
AddSubMeshTopologyCurveFieldNumber | Field number for the "add_sub_mesh_topology_curve" field.
AddSubMeshTopologyFieldNumber | Field number for the "add_sub_mesh_topology" field.
AddTextureFieldNumber | Field number for the "add_texture" field.
AddTimestepFieldNumber | Field number for the "add_timestep" field.
AddViewFieldNumber | Field number for the "add_view" field.
ChangeMeshKeyFieldNumber | Field number for the "change_mesh_key" field.
PreviewImagesFieldNumber | Field number for the "preview_images" field.
RemoveComponentKeyFieldNumber | Field number for the "remove_component_key" field.
SetBackgroundFieldNumber | Field number for the "set_background" field.
SetFloorFieldNumber | Field number for the "set_floor" field.
SetNodeMaterialsFieldNumber | Field number for the "set_node_materials" field.
SetNodeMatrixFieldNumber | Field number for the "set_node_matrix" field.
SetParentKeyFieldNumber | Field number for the "set_parent_key" field.
SetUvKeyFieldNumber | Field number for the "set_uv_key" field.
Top
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.AbsoluteKeyFieldNumber Field

ServicesTypesStreamAbsoluteKeyFieldNumber Field

Field number for the "absolute_key" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int AbsoluteKeyFieldNumber = 40
public:
literal int AbsoluteKeyFieldNumber = 40

Field Value

Type: Int32
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.AddCameraFieldNumber Field

ServicesTypesStreamAddCameraFieldNumber Field

Field number for the "add_camera" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int AddCameraFieldNumber = 141
public:
literal int AddCameraFieldNumber = 141

Field Value

Type: Int32
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.AddComponentFieldNumber Field

ServicesTypesStreamAddComponentFieldNumber Field

Field number for the "add_component" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int AddComponentFieldNumber = 10
public:
literal int AddComponentFieldNumber = 10

Field Value

Type: Int32
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.AddMaterialFieldNumber Field

ServicesTypesStreamAddMaterialFieldNumber Field

Field number for the "add_material" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int AddMaterialFieldNumber = 80
public:
literal int AddMaterialFieldNumber = 80

Field Value

Type: Int32
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.AddMeshFieldNumber Field

ServicesTypesStreamAddMeshFieldNumber Field

Field number for the "add_mesh" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int AddMeshFieldNumber = 60
public:
literal int AddMeshFieldNumber = 60

Field Value

Type: Int32
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.AddNodeFieldNumber Field

ServicesTypesStreamAddNodeFieldNumber Field

Field number for the "add_node" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int AddNodeFieldNumber = 20
public:
literal int AddNodeFieldNumber = 20

Field Value

Type: Int32
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.AddShaderMaterialFieldNumber Field

ServicesTypesStreamAddShaderMaterialFieldNumber Field

Field number for the "add_shader_material" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int AddShaderMaterialFieldNumber = 90
public:
literal int AddShaderMaterialFieldNumber = 90

Field Value

Type: Int32
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.AddSubLineFieldNumber Field

ServicesTypesStreamAddSubLineFieldNumber Field

Field number for the "add_sub_line" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int AddSubLineFieldNumber = 71
public:
literal int AddSubLineFieldNumber = 71

Field Value

Type: Int32
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.AddSubMeshFieldNumber Field

ServicesTypesStreamAddSubMeshFieldNumber Field

Field number for the "add_sub_mesh" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int AddSubMeshFieldNumber = 70
public:
literal int AddSubMeshFieldNumber = 70

Field Value

Type: Int32
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.AddSubMeshTopologyCurveFieldNumber Field

ServicesTypesStreamAddSubMeshTopologyCurveFieldNumber Field

Field number for the "add_sub_mesh_topology_curve" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int AddSubMeshTopologyCurveFieldNumber = 73
public:
literal int AddSubMeshTopologyCurveFieldNumber = 73

Field Value

Type: Int32
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.AddSubMeshTopologyFieldNumber Field

ServicesTypesStreamAddSubMeshTopologyFieldNumber Field

Field number for the "add_sub_mesh_topology" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int AddSubMeshTopologyFieldNumber = 72
public:
literal int AddSubMeshTopologyFieldNumber = 72

Field Value

Type: Int32
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.AddTextureFieldNumber Field

ServicesTypesStreamAddTextureFieldNumber Field

Field number for the "add_texture" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int AddTextureFieldNumber = 100
public:
literal int AddTextureFieldNumber = 100

Field Value

Type: Int32
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.AddTimestepFieldNumber Field

ServicesTypesStreamAddTimestepFieldNumber Field

Field number for the "add_timestep" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int AddTimestepFieldNumber = 110
public:
literal int AddTimestepFieldNumber = 110

Field Value

Type: Int32
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.AddViewFieldNumber Field

ServicesTypesStreamAddViewFieldNumber Field

Field number for the "add_view" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int AddViewFieldNumber = 140
public:
literal int AddViewFieldNumber = 140

Field Value

Type: Int32
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.ChangeMeshKeyFieldNumber Field

ServicesTypesStreamChangeMeshKeyFieldNumber Field

Field number for the "change_mesh_key" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ChangeMeshKeyFieldNumber = 120
public:
literal int ChangeMeshKeyFieldNumber = 120

Field Value

Type: Int32
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.PreviewImagesFieldNumber Field

ServicesTypesStreamPreviewImagesFieldNumber Field

Field number for the "preview_images" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int PreviewImagesFieldNumber = 170
public:
literal int PreviewImagesFieldNumber = 170

Field Value

Type: Int32
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.RemoveComponentKeyFieldNumber Field

ServicesTypesStreamRemoveComponentKeyFieldNumber Field

Field number for the "remove_component_key" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int RemoveComponentKeyFieldNumber = 50
public:
literal int RemoveComponentKeyFieldNumber = 50

Field Value

Type: Int32
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.SetBackgroundFieldNumber Field

ServicesTypesStreamSetBackgroundFieldNumber Field

Field number for the "set_background" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int SetBackgroundFieldNumber = 180
public:
literal int SetBackgroundFieldNumber = 180

Field Value

Type: Int32
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.SetFloorFieldNumber Field

ServicesTypesStreamSetFloorFieldNumber Field

Field number for the "set_floor" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int SetFloorFieldNumber = 190
public:
literal int SetFloorFieldNumber = 190

Field Value

Type: Int32
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.SetNodeMaterialsFieldNumber Field

ServicesTypesStreamSetNodeMaterialsFieldNumber Field

Field number for the "set_node_materials" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int SetNodeMaterialsFieldNumber = 130
public:
literal int SetNodeMaterialsFieldNumber = 130

Field Value

Type: Int32
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.SetNodeMatrixFieldNumber Field

ServicesTypesStreamSetNodeMatrixFieldNumber Field

Field number for the "set_node_matrix" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int SetNodeMatrixFieldNumber = 150
public:
literal int SetNodeMatrixFieldNumber = 150

Field Value

Type: Int32
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.SetParentKeyFieldNumber Field

ServicesTypesStreamSetParentKeyFieldNumber Field

Field number for the "set_parent_key" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int SetParentKeyFieldNumber = 30
public:
literal int SetParentKeyFieldNumber = 30

Field Value

Type: Int32
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.Stream.SetUvKeyFieldNumber Field

ServicesTypesStreamSetUvKeyFieldNumber Field

Field number for the "set_uv_key" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int SetUvKeyFieldNumber = 160
public:
literal int SetUvKeyFieldNumber = 160

Field Value

Type: Int32
See Also

Reference

ServicesTypesStream Class
VisualComponents.Messages Namespace


Services.Types.VREvents Class

ServicesTypesVREvents Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesServicesTypesVREvents

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class VREvents : IMessage<ServicesTypesVREvents>,
    IMessage, IEquatable<ServicesTypesVREvents>, IDeepCloneable<ServicesTypesVREvents>
public ref class VREvents sealed : IMessage<ServicesTypesVREvents^>,
    IMessage, IEquatable<ServicesTypesVREvents^>, IDeepCloneable<ServicesTypesVREvents^>

The ServicesTypesVREvents type exposes the following members.

Constructors
 | Name | Description
Public method | ServicesTypesVREvents | Initializes a new instance of the ServicesTypesVREvents class
Public method | ServicesTypesVREvents(ServicesTypesVREvents) | Initializes a new instance of the ServicesTypesVREvents class
Top
Properties
 | Name | Description
 | Descriptor |
Public property | DeviceInfo |
Public property | EventCounter |
Public property | EventsEnabled |
Public property | MaxUpdateRate |
Public property | NotifyPython |
 | Parser |
Public property | ToggleAction |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ServicesTypesVREvents) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(ServicesTypesVREvents) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
DeviceInfoFieldNumber | Field number for the "device_info" field.
EventCounterFieldNumber | Field number for the "event_counter" field.
EventsEnabledFieldNumber | Field number for the "events_enabled" field.
MaxUpdateRateFieldNumber | Field number for the "max_update_rate" field.
NotifyPythonFieldNumber | Field number for the "notify_python" field.
ToggleActionFieldNumber | Field number for the "toggle_action" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


VREvents Constructor

Overload List
 | Name | Description
Public method | ServicesTypesVREvents | Initializes a new instance of the ServicesTypesVREvents class
Public method | ServicesTypesVREvents(ServicesTypesVREvents) | Initializes a new instance of the ServicesTypesVREvents class
Top
See Also

Reference

ServicesTypesVREvents Class
VisualComponents.Messages Namespace


Services.Types.VREvents Constructor

ServicesTypesVREvents Constructor

Initializes a new instance of the ServicesTypesVREvents class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VREvents()
public:
VREvents()
See Also

Reference

ServicesTypesVREvents Class
ServicesTypesVREvents Overload
VisualComponents.Messages Namespace


Services.Types.VREvents Constructor (Services.Types.VREvents)

ServicesTypesVREvents Constructor (ServicesTypesVREvents)

Initializes a new instance of the ServicesTypesVREvents class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VREvents(
    ServicesTypesVREvents other
)
public:
VREvents(
    ServicesTypesVREvents^ other
)

Parameters

other
Type: VisualComponents.MessagesServicesTypesVREvents
See Also

Reference

ServicesTypesVREvents Class
ServicesTypesVREvents Overload
VisualComponents.Messages Namespace


VREvents Properties

The ServicesTypesVREvents type exposes the following members.

Properties
 | Name | Description
 | Descriptor |
Public property | DeviceInfo |
Public property | EventCounter |
Public property | EventsEnabled |
Public property | MaxUpdateRate |
Public property | NotifyPython |
 | Parser |
Public property | ToggleAction |
Top
See Also

Reference

ServicesTypesVREvents Class
VisualComponents.Messages Namespace


Services.Types.VREvents.Descriptor Property

ServicesTypesVREventsDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

ServicesTypesVREvents Class
VisualComponents.Messages Namespace


Services.Types.VREvents.DeviceInfo Property

ServicesTypesVREventsDeviceInfo Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DeviceInfo DeviceInfo { get; set; }
public:
property DeviceInfo^ DeviceInfo {
    DeviceInfo^ get ();
    void set (DeviceInfo^ value);
}

Property Value

Type: DeviceInfo
See Also

Reference

ServicesTypesVREvents Class
VisualComponents.Messages Namespace


Services.Types.VREvents.EventCounter Property

ServicesTypesVREventsEventCounter Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EventCounter EventCounter { get; set; }
public:
property EventCounter^ EventCounter {
    EventCounter^ get ();
    void set (EventCounter^ value);
}

Property Value

Type: EventCounter
See Also

Reference

ServicesTypesVREvents Class
VisualComponents.Messages Namespace


Services.Types.VREvents.EventsEnabled Property

ServicesTypesVREventsEventsEnabled Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EventsEnabled EventsEnabled { get; set; }
public:
property EventsEnabled^ EventsEnabled {
    EventsEnabled^ get ();
    void set (EventsEnabled^ value);
}

Property Value

Type: EventsEnabled
See Also

Reference

ServicesTypesVREvents Class
VisualComponents.Messages Namespace


Services.Types.VREvents.MaxUpdateRate Property

ServicesTypesVREventsMaxUpdateRate Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MaxUpdateRate MaxUpdateRate { get; set; }
public:
property MaxUpdateRate^ MaxUpdateRate {
    MaxUpdateRate^ get ();
    void set (MaxUpdateRate^ value);
}

Property Value

Type: MaxUpdateRate
See Also

Reference

ServicesTypesVREvents Class
VisualComponents.Messages Namespace


Services.Types.VREvents.NotifyPython Property

ServicesTypesVREventsNotifyPython Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NotifyPython NotifyPython { get; set; }
public:
property NotifyPython^ NotifyPython {
    NotifyPython^ get ();
    void set (NotifyPython^ value);
}

Property Value

Type: NotifyPython
See Also

Reference

ServicesTypesVREvents Class
VisualComponents.Messages Namespace


Services.Types.VREvents.Parser Property

ServicesTypesVREventsParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<ServicesTypesVREvents> Parser { get; }
public:
static property MessageParser<ServicesTypesVREvents^>^ Parser {
    MessageParser<ServicesTypesVREvents^>^ get ();
}

Property Value

Type: MessageParserServicesTypesVREvents
See Also

Reference

ServicesTypesVREvents Class
VisualComponents.Messages Namespace


Services.Types.VREvents.ToggleAction Property

ServicesTypesVREventsToggleAction Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionTypesToggleAction ToggleAction { get; set; }
public:
property ActionTypesToggleAction^ ToggleAction {
    ActionTypesToggleAction^ get ();
    void set (ActionTypesToggleAction^ value);
}

Property Value

Type: ActionTypesToggleAction
See Also

Reference

ServicesTypesVREvents Class
VisualComponents.Messages Namespace


VREvents Methods

The ServicesTypesVREvents type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ServicesTypesVREvents) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(ServicesTypesVREvents) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ServicesTypesVREvents Class
VisualComponents.Messages Namespace


Services.Types.VREvents.CalculateSize Method

ServicesTypesVREventsCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.Types.VREvents.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

ServicesTypesVREvents Class
VisualComponents.Messages Namespace


Services.Types.VREvents.Clone Method

ServicesTypesVREventsClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ServicesTypesVREvents Clone()
public:
virtual ServicesTypesVREvents^ Clone() sealed

Return Value

Type: ServicesTypesVREvents

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.Types.VREvents.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

ServicesTypesVREvents Class
VisualComponents.Messages Namespace


VREvents.Equals Method

VREventsEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(ServicesTypesVREvents) |
Top
See Also

Reference

ServicesTypesVREvents Class
VisualComponents.Messages Namespace


Services.Types.VREvents.Equals Method (Object)

ServicesTypesVREventsEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.Types.VREvents.Equals(System.Object)"]

See Also

Reference

ServicesTypesVREvents Class
Equals Overload
VisualComponents.Messages Namespace


Services.Types.VREvents.Equals Method (Services.Types.VREvents)

ServicesTypesVREventsEquals Method (ServicesTypesVREvents)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    ServicesTypesVREvents other
)
public:
virtual bool Equals(
    ServicesTypesVREvents^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesServicesTypesVREvents

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.Types.VREvents.Equals(VisualComponents.Messages.Services.Types.VREvents)"]

Implements

IEquatableTEquals(T)
See Also

Reference

ServicesTypesVREvents Class
Equals Overload
VisualComponents.Messages Namespace


Services.Types.VREvents.GetHashCode Method

ServicesTypesVREventsGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.Types.VREvents.GetHashCode"]

See Also

Reference

ServicesTypesVREvents Class
VisualComponents.Messages Namespace


VREvents.MergeFrom Method

VREventsMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(ServicesTypesVREvents) |
Top
See Also

Reference

ServicesTypesVREvents Class
VisualComponents.Messages Namespace


Services.Types.VREvents.MergeFrom Method (CodedInputStream)

ServicesTypesVREventsMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

ServicesTypesVREvents Class
MergeFrom Overload
VisualComponents.Messages Namespace


Services.Types.VREvents.MergeFrom Method (Services.Types.VREvents)

ServicesTypesVREventsMergeFrom Method (ServicesTypesVREvents)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    ServicesTypesVREvents other
)
public:
virtual void MergeFrom(
    ServicesTypesVREvents^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesServicesTypesVREvents

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

ServicesTypesVREvents Class
MergeFrom Overload
VisualComponents.Messages Namespace


Services.Types.VREvents.ToString Method

ServicesTypesVREventsToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.Services.Types.VREvents.ToString"]

See Also

Reference

ServicesTypesVREvents Class
VisualComponents.Messages Namespace


Services.Types.VREvents.WriteTo Method

ServicesTypesVREventsWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

ServicesTypesVREvents Class
VisualComponents.Messages Namespace


VREvents Fields

The ServicesTypesVREvents type exposes the following members.

Fields
Name | Description
DeviceInfoFieldNumber | Field number for the "device_info" field.
EventCounterFieldNumber | Field number for the "event_counter" field.
EventsEnabledFieldNumber | Field number for the "events_enabled" field.
MaxUpdateRateFieldNumber | Field number for the "max_update_rate" field.
NotifyPythonFieldNumber | Field number for the "notify_python" field.
ToggleActionFieldNumber | Field number for the "toggle_action" field.
Top
See Also

Reference

ServicesTypesVREvents Class
VisualComponents.Messages Namespace


Services.Types.VREvents.DeviceInfoFieldNumber Field

ServicesTypesVREventsDeviceInfoFieldNumber Field

Field number for the "device_info" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int DeviceInfoFieldNumber = 50
public:
literal int DeviceInfoFieldNumber = 50

Field Value

Type: Int32
See Also

Reference

ServicesTypesVREvents Class
VisualComponents.Messages Namespace


Services.Types.VREvents.EventCounterFieldNumber Field

ServicesTypesVREventsEventCounterFieldNumber Field

Field number for the "event_counter" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int EventCounterFieldNumber = 30
public:
literal int EventCounterFieldNumber = 30

Field Value

Type: Int32
See Also

Reference

ServicesTypesVREvents Class
VisualComponents.Messages Namespace


Services.Types.VREvents.EventsEnabledFieldNumber Field

ServicesTypesVREventsEventsEnabledFieldNumber Field

Field number for the "events_enabled" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int EventsEnabledFieldNumber = 10
public:
literal int EventsEnabledFieldNumber = 10

Field Value

Type: Int32
See Also

Reference

ServicesTypesVREvents Class
VisualComponents.Messages Namespace


Services.Types.VREvents.MaxUpdateRateFieldNumber Field

ServicesTypesVREventsMaxUpdateRateFieldNumber Field

Field number for the "max_update_rate" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int MaxUpdateRateFieldNumber = 20
public:
literal int MaxUpdateRateFieldNumber = 20

Field Value

Type: Int32
See Also

Reference

ServicesTypesVREvents Class
VisualComponents.Messages Namespace


Services.Types.VREvents.NotifyPythonFieldNumber Field

ServicesTypesVREventsNotifyPythonFieldNumber Field

Field number for the "notify_python" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int NotifyPythonFieldNumber = 40
public:
literal int NotifyPythonFieldNumber = 40

Field Value

Type: Int32
See Also

Reference

ServicesTypesVREvents Class
VisualComponents.Messages Namespace


Services.Types.VREvents.ToggleActionFieldNumber Field

ServicesTypesVREventsToggleActionFieldNumber Field

Field number for the "toggle_action" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ToggleActionFieldNumber = 60
public:
literal int ToggleActionFieldNumber = 60

Field Value

Type: Int32
See Also

Reference

ServicesTypesVREvents Class
VisualComponents.Messages Namespace


SetBackground Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesSetBackground

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class SetBackground : IMessage<SetBackground>,
    IMessage, IEquatable<SetBackground>, IDeepCloneable<SetBackground>
public ref class SetBackground sealed : IMessage<SetBackground^>,
    IMessage, IEquatable<SetBackground^>, IDeepCloneable<SetBackground^>

The SetBackground type exposes the following members.

Constructors
 | Name | Description
Public method | SetBackground | Initializes a new instance of the SetBackground class
Public method | SetBackground(SetBackground) | Initializes a new instance of the SetBackground class
Top
Properties
 | Name | Description
Public property | Color |
 | Descriptor |
 | Parser |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(SetBackground) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(SetBackground) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
ColorFieldNumber | Field number for the "color" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


SetBackground Constructor

Overload List
 | Name | Description
Public method | SetBackground | Initializes a new instance of the SetBackground class
Public method | SetBackground(SetBackground) | Initializes a new instance of the SetBackground class
Top
See Also

Reference

SetBackground Class
VisualComponents.Messages Namespace


SetBackground Constructor

Initializes a new instance of the SetBackground class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetBackground()
public:
SetBackground()
See Also

Reference

SetBackground Class
SetBackground Overload
VisualComponents.Messages Namespace


SetBackground Constructor (SetBackground)

Initializes a new instance of the SetBackground class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetBackground(
    SetBackground other
)
public:
SetBackground(
    SetBackground^ other
)

Parameters

other
Type: VisualComponents.MessagesSetBackground
See Also

Reference

SetBackground Class
SetBackground Overload
VisualComponents.Messages Namespace


SetBackground Properties

The SetBackground type exposes the following members.

Properties
 | Name | Description
Public property | Color |
 | Descriptor |
 | Parser |
Top
See Also

Reference

SetBackground Class
VisualComponents.Messages Namespace


SetBackground.Color Property

SetBackgroundColor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Color { get; }
public:
property RepeatedField<float>^ Color {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

SetBackground Class
VisualComponents.Messages Namespace


SetBackground.Descriptor Property

SetBackgroundDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

SetBackground Class
VisualComponents.Messages Namespace


SetBackground.Parser Property

SetBackgroundParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<SetBackground> Parser { get; }
public:
static property MessageParser<SetBackground^>^ Parser {
    MessageParser<SetBackground^>^ get ();
}

Property Value

Type: MessageParserSetBackground
See Also

Reference

SetBackground Class
VisualComponents.Messages Namespace


SetBackground Methods

The SetBackground type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(SetBackground) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(SetBackground) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SetBackground Class
VisualComponents.Messages Namespace


SetBackground.CalculateSize Method

SetBackgroundCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.SetBackground.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

SetBackground Class
VisualComponents.Messages Namespace


SetBackground.Clone Method

SetBackgroundClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetBackground Clone()
public:
virtual SetBackground^ Clone() sealed

Return Value

Type: SetBackground

[Missing <returns> documentation for "M:VisualComponents.Messages.SetBackground.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

SetBackground Class
VisualComponents.Messages Namespace


SetBackground.Equals Method

SetBackgroundEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(SetBackground) |
Top
See Also

Reference

SetBackground Class
VisualComponents.Messages Namespace


SetBackground.Equals Method (Object)

SetBackgroundEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.SetBackground.Equals(System.Object)"]

See Also

Reference

SetBackground Class
Equals Overload
VisualComponents.Messages Namespace


SetBackground.Equals Method (SetBackground)

SetBackgroundEquals Method (SetBackground)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    SetBackground other
)
public:
virtual bool Equals(
    SetBackground^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesSetBackground

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.SetBackground.Equals(VisualComponents.Messages.SetBackground)"]

Implements

IEquatableTEquals(T)
See Also

Reference

SetBackground Class
Equals Overload
VisualComponents.Messages Namespace


SetBackground.GetHashCode Method

SetBackgroundGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.SetBackground.GetHashCode"]

See Also

Reference

SetBackground Class
VisualComponents.Messages Namespace


SetBackground.MergeFrom Method

SetBackgroundMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(SetBackground) |
Top
See Also

Reference

SetBackground Class
VisualComponents.Messages Namespace


SetBackground.MergeFrom Method (CodedInputStream)

SetBackgroundMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

SetBackground Class
MergeFrom Overload
VisualComponents.Messages Namespace


SetBackground.MergeFrom Method (SetBackground)

SetBackgroundMergeFrom Method (SetBackground)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    SetBackground other
)
public:
virtual void MergeFrom(
    SetBackground^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesSetBackground

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

SetBackground Class
MergeFrom Overload
VisualComponents.Messages Namespace


SetBackground.ToString Method

SetBackgroundToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.SetBackground.ToString"]

See Also

Reference

SetBackground Class
VisualComponents.Messages Namespace


SetBackground.WriteTo Method

SetBackgroundWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

SetBackground Class
VisualComponents.Messages Namespace


SetBackground Fields

The SetBackground type exposes the following members.

Fields
Name | Description
ColorFieldNumber | Field number for the "color" field.
Top
See Also

Reference

SetBackground Class
VisualComponents.Messages Namespace


SetBackground.ColorFieldNumber Field

SetBackgroundColorFieldNumber Field

Field number for the "color" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ColorFieldNumber = 1
public:
literal int ColorFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

SetBackground Class
VisualComponents.Messages Namespace


SetFloor Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesSetFloor

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class SetFloor : IMessage<SetFloor>,
    IMessage, IEquatable<SetFloor>, IDeepCloneable<SetFloor>
public ref class SetFloor sealed : IMessage<SetFloor^>,
    IMessage, IEquatable<SetFloor^>, IDeepCloneable<SetFloor^>

The SetFloor type exposes the following members.

Constructors
 | Name | Description
Public method | SetFloor | Initializes a new instance of the SetFloor class
Public method | SetFloor(SetFloor) | Initializes a new instance of the SetFloor class
Top
Properties
 | Name | Description
 | Descriptor |
Public property | FloorColor |
Public property | FloorSizeX |
Public property | FloorSizeY |
Public property | FloorVisibility |
Public property | GridSizeX |
Public property | GridSizeY |
Public property | GridVisibility |
Public property | MajorGridLineColor |
Public property | MinorGridLineColor |
 | Parser |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(SetFloor) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(SetFloor) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
FloorColorFieldNumber | Field number for the "floor_color" field.
FloorSizeXFieldNumber | Field number for the "floor_size_x" field.
FloorSizeYFieldNumber | Field number for the "floor_size_y" field.
FloorVisibilityFieldNumber | Field number for the "floor_visibility" field.
GridSizeXFieldNumber | Field number for the "grid_size_x" field.
GridSizeYFieldNumber | Field number for the "grid_size_y" field.
GridVisibilityFieldNumber | Field number for the "grid_visibility" field.
MajorGridLineColorFieldNumber | Field number for the "major_grid_line_color" field.
MinorGridLineColorFieldNumber | Field number for the "minor_grid_line_color" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


SetFloor Constructor

Overload List
 | Name | Description
Public method | SetFloor | Initializes a new instance of the SetFloor class
Public method | SetFloor(SetFloor) | Initializes a new instance of the SetFloor class
Top
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor Constructor

Initializes a new instance of the SetFloor class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetFloor()
public:
SetFloor()
See Also

Reference

SetFloor Class
SetFloor Overload
VisualComponents.Messages Namespace


SetFloor Constructor (SetFloor)

Initializes a new instance of the SetFloor class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetFloor(
    SetFloor other
)
public:
SetFloor(
    SetFloor^ other
)

Parameters

other
Type: VisualComponents.MessagesSetFloor
See Also

Reference

SetFloor Class
SetFloor Overload
VisualComponents.Messages Namespace


SetFloor Properties

The SetFloor type exposes the following members.

Properties
 | Name | Description
 | Descriptor |
Public property | FloorColor |
Public property | FloorSizeX |
Public property | FloorSizeY |
Public property | FloorVisibility |
Public property | GridSizeX |
Public property | GridSizeY |
Public property | GridVisibility |
Public property | MajorGridLineColor |
Public property | MinorGridLineColor |
 | Parser |
Top
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor.Descriptor Property

SetFloorDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor.FloorColor Property

SetFloorFloorColor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> FloorColor { get; }
public:
property RepeatedField<float>^ FloorColor {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor.FloorSizeX Property

SetFloorFloorSizeX Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float FloorSizeX { get; set; }
public:
property float FloorSizeX {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor.FloorSizeY Property

SetFloorFloorSizeY Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float FloorSizeY { get; set; }
public:
property float FloorSizeY {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor.FloorVisibility Property

SetFloorFloorVisibility Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool FloorVisibility { get; set; }
public:
property bool FloorVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor.GridSizeX Property

SetFloorGridSizeX Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float GridSizeX { get; set; }
public:
property float GridSizeX {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor.GridSizeY Property

SetFloorGridSizeY Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public float GridSizeY { get; set; }
public:
property float GridSizeY {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor.GridVisibility Property

SetFloorGridVisibility Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool GridVisibility { get; set; }
public:
property bool GridVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor.MajorGridLineColor Property

SetFloorMajorGridLineColor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> MajorGridLineColor { get; }
public:
property RepeatedField<float>^ MajorGridLineColor {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor.MinorGridLineColor Property

SetFloorMinorGridLineColor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> MinorGridLineColor { get; }
public:
property RepeatedField<float>^ MinorGridLineColor {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor.Parser Property

SetFloorParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<SetFloor> Parser { get; }
public:
static property MessageParser<SetFloor^>^ Parser {
    MessageParser<SetFloor^>^ get ();
}

Property Value

Type: MessageParserSetFloor
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor Methods

The SetFloor type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(SetFloor) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(SetFloor) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor.CalculateSize Method

SetFloorCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.SetFloor.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor.Clone Method

SetFloorClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetFloor Clone()
public:
virtual SetFloor^ Clone() sealed

Return Value

Type: SetFloor

[Missing <returns> documentation for "M:VisualComponents.Messages.SetFloor.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor.Equals Method

SetFloorEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(SetFloor) |
Top
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor.Equals Method (Object)

SetFloorEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.SetFloor.Equals(System.Object)"]

See Also

Reference

SetFloor Class
Equals Overload
VisualComponents.Messages Namespace


SetFloor.Equals Method (SetFloor)

SetFloorEquals Method (SetFloor)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    SetFloor other
)
public:
virtual bool Equals(
    SetFloor^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesSetFloor

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.SetFloor.Equals(VisualComponents.Messages.SetFloor)"]

Implements

IEquatableTEquals(T)
See Also

Reference

SetFloor Class
Equals Overload
VisualComponents.Messages Namespace


SetFloor.GetHashCode Method

SetFloorGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.SetFloor.GetHashCode"]

See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor.MergeFrom Method

SetFloorMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(SetFloor) |
Top
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor.MergeFrom Method (CodedInputStream)

SetFloorMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

SetFloor Class
MergeFrom Overload
VisualComponents.Messages Namespace


SetFloor.MergeFrom Method (SetFloor)

SetFloorMergeFrom Method (SetFloor)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    SetFloor other
)
public:
virtual void MergeFrom(
    SetFloor^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesSetFloor

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

SetFloor Class
MergeFrom Overload
VisualComponents.Messages Namespace


SetFloor.ToString Method

SetFloorToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.SetFloor.ToString"]

See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor.WriteTo Method

SetFloorWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor Fields

The SetFloor type exposes the following members.

Fields
Name | Description
FloorColorFieldNumber | Field number for the "floor_color" field.
FloorSizeXFieldNumber | Field number for the "floor_size_x" field.
FloorSizeYFieldNumber | Field number for the "floor_size_y" field.
FloorVisibilityFieldNumber | Field number for the "floor_visibility" field.
GridSizeXFieldNumber | Field number for the "grid_size_x" field.
GridSizeYFieldNumber | Field number for the "grid_size_y" field.
GridVisibilityFieldNumber | Field number for the "grid_visibility" field.
MajorGridLineColorFieldNumber | Field number for the "major_grid_line_color" field.
MinorGridLineColorFieldNumber | Field number for the "minor_grid_line_color" field.
Top
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor.FloorColorFieldNumber Field

SetFloorFloorColorFieldNumber Field

Field number for the "floor_color" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int FloorColorFieldNumber = 1
public:
literal int FloorColorFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor.FloorSizeXFieldNumber Field

SetFloorFloorSizeXFieldNumber Field

Field number for the "floor_size_x" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int FloorSizeXFieldNumber = 8
public:
literal int FloorSizeXFieldNumber = 8

Field Value

Type: Int32
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor.FloorSizeYFieldNumber Field

SetFloorFloorSizeYFieldNumber Field

Field number for the "floor_size_y" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int FloorSizeYFieldNumber = 9
public:
literal int FloorSizeYFieldNumber = 9

Field Value

Type: Int32
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor.FloorVisibilityFieldNumber Field

SetFloorFloorVisibilityFieldNumber Field

Field number for the "floor_visibility" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int FloorVisibilityFieldNumber = 4
public:
literal int FloorVisibilityFieldNumber = 4

Field Value

Type: Int32
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor.GridSizeXFieldNumber Field

SetFloorGridSizeXFieldNumber Field

Field number for the "grid_size_x" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int GridSizeXFieldNumber = 6
public:
literal int GridSizeXFieldNumber = 6

Field Value

Type: Int32
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor.GridSizeYFieldNumber Field

SetFloorGridSizeYFieldNumber Field

Field number for the "grid_size_y" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int GridSizeYFieldNumber = 7
public:
literal int GridSizeYFieldNumber = 7

Field Value

Type: Int32
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor.GridVisibilityFieldNumber Field

SetFloorGridVisibilityFieldNumber Field

Field number for the "grid_visibility" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int GridVisibilityFieldNumber = 5
public:
literal int GridVisibilityFieldNumber = 5

Field Value

Type: Int32
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor.MajorGridLineColorFieldNumber Field

SetFloorMajorGridLineColorFieldNumber Field

Field number for the "major_grid_line_color" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int MajorGridLineColorFieldNumber = 2
public:
literal int MajorGridLineColorFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetFloor.MinorGridLineColorFieldNumber Field

SetFloorMinorGridLineColorFieldNumber Field

Field number for the "minor_grid_line_color" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int MinorGridLineColorFieldNumber = 3
public:
literal int MinorGridLineColorFieldNumber = 3

Field Value

Type: Int32
See Also

Reference

SetFloor Class
VisualComponents.Messages Namespace


SetNodeMaterials Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesSetNodeMaterials

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class SetNodeMaterials : IMessage<SetNodeMaterials>,
    IMessage, IEquatable<SetNodeMaterials>, IDeepCloneable<SetNodeMaterials>
public ref class SetNodeMaterials sealed : IMessage<SetNodeMaterials^>,
    IMessage, IEquatable<SetNodeMaterials^>, IDeepCloneable<SetNodeMaterials^>

The SetNodeMaterials type exposes the following members.

Constructors
 | Name | Description
Public method | SetNodeMaterials | Initializes a new instance of the SetNodeMaterials class
Public method | SetNodeMaterials(SetNodeMaterials) | Initializes a new instance of the SetNodeMaterials class
Top
Properties
 | Name | Description
Public property | ComponentId |
 | Descriptor |
Public property | MaterialOverrides |
Public property | NodeId |
 | Parser |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(SetNodeMaterials) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(SetNodeMaterials) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
ComponentIdFieldNumber | Field number for the "component_id" field.
MaterialOverridesFieldNumber | Field number for the "material_overrides" field.
NodeIdFieldNumber | Field number for the "node_id" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


SetNodeMaterials Constructor

Overload List
 | Name | Description
Public method | SetNodeMaterials | Initializes a new instance of the SetNodeMaterials class
Public method | SetNodeMaterials(SetNodeMaterials) | Initializes a new instance of the SetNodeMaterials class
Top
See Also

Reference

SetNodeMaterials Class
VisualComponents.Messages Namespace


SetNodeMaterials Constructor

Initializes a new instance of the SetNodeMaterials class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetNodeMaterials()
public:
SetNodeMaterials()
See Also

Reference

SetNodeMaterials Class
SetNodeMaterials Overload
VisualComponents.Messages Namespace


SetNodeMaterials Constructor (SetNodeMaterials)

Initializes a new instance of the SetNodeMaterials class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetNodeMaterials(
    SetNodeMaterials other
)
public:
SetNodeMaterials(
    SetNodeMaterials^ other
)

Parameters

other
Type: VisualComponents.MessagesSetNodeMaterials
See Also

Reference

SetNodeMaterials Class
SetNodeMaterials Overload
VisualComponents.Messages Namespace


SetNodeMaterials Properties

The SetNodeMaterials type exposes the following members.

Properties
 | Name | Description
Public property | ComponentId |
 | Descriptor |
Public property | MaterialOverrides |
Public property | NodeId |
 | Parser |
Top
See Also

Reference

SetNodeMaterials Class
VisualComponents.Messages Namespace


SetNodeMaterials.ComponentId Property

SetNodeMaterialsComponentId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ComponentId { get; set; }
public:
property int ComponentId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SetNodeMaterials Class
VisualComponents.Messages Namespace


SetNodeMaterials.Descriptor Property

SetNodeMaterialsDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

SetNodeMaterials Class
VisualComponents.Messages Namespace


SetNodeMaterials.MaterialOverrides Property

SetNodeMaterialsMaterialOverrides Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<int> MaterialOverrides { get; }
public:
property RepeatedField<int>^ MaterialOverrides {
    RepeatedField<int>^ get ();
}

Property Value

Type: RepeatedFieldInt32
See Also

Reference

SetNodeMaterials Class
VisualComponents.Messages Namespace


SetNodeMaterials.NodeId Property

SetNodeMaterialsNodeId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int NodeId { get; set; }
public:
property int NodeId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SetNodeMaterials Class
VisualComponents.Messages Namespace


SetNodeMaterials.Parser Property

SetNodeMaterialsParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<SetNodeMaterials> Parser { get; }
public:
static property MessageParser<SetNodeMaterials^>^ Parser {
    MessageParser<SetNodeMaterials^>^ get ();
}

Property Value

Type: MessageParserSetNodeMaterials
See Also

Reference

SetNodeMaterials Class
VisualComponents.Messages Namespace


SetNodeMaterials Methods

The SetNodeMaterials type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(SetNodeMaterials) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(SetNodeMaterials) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SetNodeMaterials Class
VisualComponents.Messages Namespace


SetNodeMaterials.CalculateSize Method

SetNodeMaterialsCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.SetNodeMaterials.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

SetNodeMaterials Class
VisualComponents.Messages Namespace


SetNodeMaterials.Clone Method

SetNodeMaterialsClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetNodeMaterials Clone()
public:
virtual SetNodeMaterials^ Clone() sealed

Return Value

Type: SetNodeMaterials

[Missing <returns> documentation for "M:VisualComponents.Messages.SetNodeMaterials.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

SetNodeMaterials Class
VisualComponents.Messages Namespace


SetNodeMaterials.Equals Method

SetNodeMaterialsEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(SetNodeMaterials) |
Top
See Also

Reference

SetNodeMaterials Class
VisualComponents.Messages Namespace


SetNodeMaterials.Equals Method (Object)

SetNodeMaterialsEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.SetNodeMaterials.Equals(System.Object)"]

See Also

Reference

SetNodeMaterials Class
Equals Overload
VisualComponents.Messages Namespace


SetNodeMaterials.Equals Method (SetNodeMaterials)

SetNodeMaterialsEquals Method (SetNodeMaterials)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    SetNodeMaterials other
)
public:
virtual bool Equals(
    SetNodeMaterials^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesSetNodeMaterials

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.SetNodeMaterials.Equals(VisualComponents.Messages.SetNodeMaterials)"]

Implements

IEquatableTEquals(T)
See Also

Reference

SetNodeMaterials Class
Equals Overload
VisualComponents.Messages Namespace


SetNodeMaterials.GetHashCode Method

SetNodeMaterialsGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.SetNodeMaterials.GetHashCode"]

See Also

Reference

SetNodeMaterials Class
VisualComponents.Messages Namespace


SetNodeMaterials.MergeFrom Method

SetNodeMaterialsMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(SetNodeMaterials) |
Top
See Also

Reference

SetNodeMaterials Class
VisualComponents.Messages Namespace


SetNodeMaterials.MergeFrom Method (CodedInputStream)

SetNodeMaterialsMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

SetNodeMaterials Class
MergeFrom Overload
VisualComponents.Messages Namespace


SetNodeMaterials.MergeFrom Method (SetNodeMaterials)

SetNodeMaterialsMergeFrom Method (SetNodeMaterials)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    SetNodeMaterials other
)
public:
virtual void MergeFrom(
    SetNodeMaterials^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesSetNodeMaterials

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

SetNodeMaterials Class
MergeFrom Overload
VisualComponents.Messages Namespace


SetNodeMaterials.ToString Method

SetNodeMaterialsToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.SetNodeMaterials.ToString"]

See Also

Reference

SetNodeMaterials Class
VisualComponents.Messages Namespace


SetNodeMaterials.WriteTo Method

SetNodeMaterialsWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

SetNodeMaterials Class
VisualComponents.Messages Namespace


SetNodeMaterials Fields

The SetNodeMaterials type exposes the following members.

Fields
Name | Description
ComponentIdFieldNumber | Field number for the "component_id" field.
MaterialOverridesFieldNumber | Field number for the "material_overrides" field.
NodeIdFieldNumber | Field number for the "node_id" field.
Top
See Also

Reference

SetNodeMaterials Class
VisualComponents.Messages Namespace


SetNodeMaterials.ComponentIdFieldNumber Field

SetNodeMaterialsComponentIdFieldNumber Field

Field number for the "component_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ComponentIdFieldNumber = 2
public:
literal int ComponentIdFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

SetNodeMaterials Class
VisualComponents.Messages Namespace


SetNodeMaterials.MaterialOverridesFieldNumber Field

SetNodeMaterialsMaterialOverridesFieldNumber Field

Field number for the "material_overrides" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int MaterialOverridesFieldNumber = 3
public:
literal int MaterialOverridesFieldNumber = 3

Field Value

Type: Int32
See Also

Reference

SetNodeMaterials Class
VisualComponents.Messages Namespace


SetNodeMaterials.NodeIdFieldNumber Field

SetNodeMaterialsNodeIdFieldNumber Field

Field number for the "node_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int NodeIdFieldNumber = 1
public:
literal int NodeIdFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

SetNodeMaterials Class
VisualComponents.Messages Namespace


SetNodeMatrix Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesSetNodeMatrix

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class SetNodeMatrix : IMessage<SetNodeMatrix>,
    IMessage, IEquatable<SetNodeMatrix>, IDeepCloneable<SetNodeMatrix>
public ref class SetNodeMatrix sealed : IMessage<SetNodeMatrix^>,
    IMessage, IEquatable<SetNodeMatrix^>, IDeepCloneable<SetNodeMatrix^>

The SetNodeMatrix type exposes the following members.

Constructors
 | Name | Description
Public method | SetNodeMatrix | Initializes a new instance of the SetNodeMatrix class
Public method | SetNodeMatrix(SetNodeMatrix) | Initializes a new instance of the SetNodeMatrix class
Top
Properties
Name | Description
Descriptor |
Parser |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(SetNodeMatrix) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(SetNodeMatrix) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


SetNodeMatrix Constructor

Overload List
 | Name | Description
Public method | SetNodeMatrix | Initializes a new instance of the SetNodeMatrix class
Public method | SetNodeMatrix(SetNodeMatrix) | Initializes a new instance of the SetNodeMatrix class
Top
See Also

Reference

SetNodeMatrix Class
VisualComponents.Messages Namespace


SetNodeMatrix Constructor

Initializes a new instance of the SetNodeMatrix class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetNodeMatrix()
public:
SetNodeMatrix()
See Also

Reference

SetNodeMatrix Class
SetNodeMatrix Overload
VisualComponents.Messages Namespace


SetNodeMatrix Constructor (SetNodeMatrix)

Initializes a new instance of the SetNodeMatrix class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetNodeMatrix(
    SetNodeMatrix other
)
public:
SetNodeMatrix(
    SetNodeMatrix^ other
)

Parameters

other
Type: VisualComponents.MessagesSetNodeMatrix
See Also

Reference

SetNodeMatrix Class
SetNodeMatrix Overload
VisualComponents.Messages Namespace


SetNodeMatrix Properties

The SetNodeMatrix type exposes the following members.

Properties
Name | Description
Descriptor |
Parser |
Top
See Also

Reference

SetNodeMatrix Class
VisualComponents.Messages Namespace


SetNodeMatrix.Descriptor Property

SetNodeMatrixDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

SetNodeMatrix Class
VisualComponents.Messages Namespace


SetNodeMatrix.Parser Property

SetNodeMatrixParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<SetNodeMatrix> Parser { get; }
public:
static property MessageParser<SetNodeMatrix^>^ Parser {
    MessageParser<SetNodeMatrix^>^ get ();
}

Property Value

Type: MessageParserSetNodeMatrix
See Also

Reference

SetNodeMatrix Class
VisualComponents.Messages Namespace


SetNodeMatrix Methods

The SetNodeMatrix type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(SetNodeMatrix) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(SetNodeMatrix) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SetNodeMatrix Class
VisualComponents.Messages Namespace


SetNodeMatrix.CalculateSize Method

SetNodeMatrixCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.SetNodeMatrix.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

SetNodeMatrix Class
VisualComponents.Messages Namespace


SetNodeMatrix.Clone Method

SetNodeMatrixClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetNodeMatrix Clone()
public:
virtual SetNodeMatrix^ Clone() sealed

Return Value

Type: SetNodeMatrix

[Missing <returns> documentation for "M:VisualComponents.Messages.SetNodeMatrix.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

SetNodeMatrix Class
VisualComponents.Messages Namespace


SetNodeMatrix.Equals Method

SetNodeMatrixEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(SetNodeMatrix) |
Top
See Also

Reference

SetNodeMatrix Class
VisualComponents.Messages Namespace


SetNodeMatrix.Equals Method (Object)

SetNodeMatrixEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.SetNodeMatrix.Equals(System.Object)"]

See Also

Reference

SetNodeMatrix Class
Equals Overload
VisualComponents.Messages Namespace


SetNodeMatrix.Equals Method (SetNodeMatrix)

SetNodeMatrixEquals Method (SetNodeMatrix)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    SetNodeMatrix other
)
public:
virtual bool Equals(
    SetNodeMatrix^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesSetNodeMatrix

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.SetNodeMatrix.Equals(VisualComponents.Messages.SetNodeMatrix)"]

Implements

IEquatableTEquals(T)
See Also

Reference

SetNodeMatrix Class
Equals Overload
VisualComponents.Messages Namespace


SetNodeMatrix.GetHashCode Method

SetNodeMatrixGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.SetNodeMatrix.GetHashCode"]

See Also

Reference

SetNodeMatrix Class
VisualComponents.Messages Namespace


SetNodeMatrix.MergeFrom Method

SetNodeMatrixMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(SetNodeMatrix) |
Top
See Also

Reference

SetNodeMatrix Class
VisualComponents.Messages Namespace


SetNodeMatrix.MergeFrom Method (CodedInputStream)

SetNodeMatrixMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

SetNodeMatrix Class
MergeFrom Overload
VisualComponents.Messages Namespace


SetNodeMatrix.MergeFrom Method (SetNodeMatrix)

SetNodeMatrixMergeFrom Method (SetNodeMatrix)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    SetNodeMatrix other
)
public:
virtual void MergeFrom(
    SetNodeMatrix^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesSetNodeMatrix

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

SetNodeMatrix Class
MergeFrom Overload
VisualComponents.Messages Namespace


SetNodeMatrix.ToString Method

SetNodeMatrixToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.SetNodeMatrix.ToString"]

See Also

Reference

SetNodeMatrix Class
VisualComponents.Messages Namespace


SetNodeMatrix.WriteTo Method

SetNodeMatrixWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

SetNodeMatrix Class
VisualComponents.Messages Namespace


SetParentKey Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesSetParentKey

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class SetParentKey : IMessage<SetParentKey>,
    IMessage, IEquatable<SetParentKey>, IDeepCloneable<SetParentKey>
public ref class SetParentKey sealed : IMessage<SetParentKey^>,
    IMessage, IEquatable<SetParentKey^>, IDeepCloneable<SetParentKey^>

The SetParentKey type exposes the following members.

Constructors
 | Name | Description
Public method | SetParentKey | Initializes a new instance of the SetParentKey class
Public method | SetParentKey(SetParentKey) | Initializes a new instance of the SetParentKey class
Top
Properties
 | Name | Description
Public property | ComponentId |
 | Descriptor |
Public property | NodeId |
Public property | OldPosition |
Public property | OldRotation |
Public property | ParentComponentId |
Public property | ParentNodeId |
 | Parser |
Public property | Position |
Public property | Rotation |
Public property | Rotation2 |
Public property | Scale |
Public property | Scale2 |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(SetParentKey) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(SetParentKey) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
ComponentIdFieldNumber | Field number for the "component_id" field.
NodeIdFieldNumber | Field number for the "node_id" field.
OldPositionFieldNumber | Field number for the "old_position" field.
OldRotationFieldNumber | Field number for the "old_rotation" field.
ParentComponentIdFieldNumber | Field number for the "parent_component_id" field.
ParentNodeIdFieldNumber | Field number for the "parent_node_id" field.
PositionFieldNumber | Field number for the "position" field.
Rotation2FieldNumber | Field number for the "rotation_2" field.
RotationFieldNumber | Field number for the "rotation" field.
Scale2FieldNumber | Field number for the "scale_2" field.
ScaleFieldNumber | Field number for the "scale" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


SetParentKey Constructor

Overload List
 | Name | Description
Public method | SetParentKey | Initializes a new instance of the SetParentKey class
Public method | SetParentKey(SetParentKey) | Initializes a new instance of the SetParentKey class
Top
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey Constructor

Initializes a new instance of the SetParentKey class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetParentKey()
public:
SetParentKey()
See Also

Reference

SetParentKey Class
SetParentKey Overload
VisualComponents.Messages Namespace


SetParentKey Constructor (SetParentKey)

Initializes a new instance of the SetParentKey class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetParentKey(
    SetParentKey other
)
public:
SetParentKey(
    SetParentKey^ other
)

Parameters

other
Type: VisualComponents.MessagesSetParentKey
See Also

Reference

SetParentKey Class
SetParentKey Overload
VisualComponents.Messages Namespace


SetParentKey Properties

The SetParentKey type exposes the following members.

Properties
 | Name | Description
Public property | ComponentId |
 | Descriptor |
Public property | NodeId |
Public property | OldPosition |
Public property | OldRotation |
Public property | ParentComponentId |
Public property | ParentNodeId |
 | Parser |
Public property | Position |
Public property | Rotation |
Public property | Rotation2 |
Public property | Scale |
Public property | Scale2 |
Top
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.ComponentId Property

SetParentKeyComponentId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ComponentId { get; set; }
public:
property int ComponentId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.Descriptor Property

SetParentKeyDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.NodeId Property

SetParentKeyNodeId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int NodeId { get; set; }
public:
property int NodeId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.OldPosition Property

SetParentKeyOldPosition Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> OldPosition { get; }
public:
property RepeatedField<float>^ OldPosition {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.OldRotation Property

SetParentKeyOldRotation Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> OldRotation { get; }
public:
property RepeatedField<float>^ OldRotation {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.ParentComponentId Property

SetParentKeyParentComponentId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ParentComponentId { get; set; }
public:
property int ParentComponentId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.ParentNodeId Property

SetParentKeyParentNodeId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ParentNodeId { get; set; }
public:
property int ParentNodeId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.Parser Property

SetParentKeyParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<SetParentKey> Parser { get; }
public:
static property MessageParser<SetParentKey^>^ Parser {
    MessageParser<SetParentKey^>^ get ();
}

Property Value

Type: MessageParserSetParentKey
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.Position Property

SetParentKeyPosition Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Position { get; }
public:
property RepeatedField<float>^ Position {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.Rotation Property

SetParentKeyRotation Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Rotation { get; }
public:
property RepeatedField<float>^ Rotation {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.Rotation2 Property

SetParentKeyRotation2 Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Rotation2 { get; }
public:
property RepeatedField<float>^ Rotation2 {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.Scale Property

SetParentKeyScale Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Scale { get; }
public:
property RepeatedField<float>^ Scale {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.Scale2 Property

SetParentKeyScale2 Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RepeatedField<float> Scale2 { get; }
public:
property RepeatedField<float>^ Scale2 {
    RepeatedField<float>^ get ();
}

Property Value

Type: RepeatedFieldSingle
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey Methods

The SetParentKey type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(SetParentKey) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(SetParentKey) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.CalculateSize Method

SetParentKeyCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.SetParentKey.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.Clone Method

SetParentKeyClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetParentKey Clone()
public:
virtual SetParentKey^ Clone() sealed

Return Value

Type: SetParentKey

[Missing <returns> documentation for "M:VisualComponents.Messages.SetParentKey.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.Equals Method

SetParentKeyEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(SetParentKey) |
Top
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.Equals Method (Object)

SetParentKeyEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.SetParentKey.Equals(System.Object)"]

See Also

Reference

SetParentKey Class
Equals Overload
VisualComponents.Messages Namespace


SetParentKey.Equals Method (SetParentKey)

SetParentKeyEquals Method (SetParentKey)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    SetParentKey other
)
public:
virtual bool Equals(
    SetParentKey^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesSetParentKey

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.SetParentKey.Equals(VisualComponents.Messages.SetParentKey)"]

Implements

IEquatableTEquals(T)
See Also

Reference

SetParentKey Class
Equals Overload
VisualComponents.Messages Namespace


SetParentKey.GetHashCode Method

SetParentKeyGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.SetParentKey.GetHashCode"]

See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.MergeFrom Method

SetParentKeyMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(SetParentKey) |
Top
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.MergeFrom Method (CodedInputStream)

SetParentKeyMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

SetParentKey Class
MergeFrom Overload
VisualComponents.Messages Namespace


SetParentKey.MergeFrom Method (SetParentKey)

SetParentKeyMergeFrom Method (SetParentKey)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    SetParentKey other
)
public:
virtual void MergeFrom(
    SetParentKey^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesSetParentKey

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

SetParentKey Class
MergeFrom Overload
VisualComponents.Messages Namespace


SetParentKey.ToString Method

SetParentKeyToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.SetParentKey.ToString"]

See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.WriteTo Method

SetParentKeyWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey Fields

The SetParentKey type exposes the following members.

Fields
Name | Description
ComponentIdFieldNumber | Field number for the "component_id" field.
NodeIdFieldNumber | Field number for the "node_id" field.
OldPositionFieldNumber | Field number for the "old_position" field.
OldRotationFieldNumber | Field number for the "old_rotation" field.
ParentComponentIdFieldNumber | Field number for the "parent_component_id" field.
ParentNodeIdFieldNumber | Field number for the "parent_node_id" field.
PositionFieldNumber | Field number for the "position" field.
Rotation2FieldNumber | Field number for the "rotation_2" field.
RotationFieldNumber | Field number for the "rotation" field.
Scale2FieldNumber | Field number for the "scale_2" field.
ScaleFieldNumber | Field number for the "scale" field.
Top
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.ComponentIdFieldNumber Field

SetParentKeyComponentIdFieldNumber Field

Field number for the "component_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ComponentIdFieldNumber = 2
public:
literal int ComponentIdFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.NodeIdFieldNumber Field

SetParentKeyNodeIdFieldNumber Field

Field number for the "node_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int NodeIdFieldNumber = 1
public:
literal int NodeIdFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.OldPositionFieldNumber Field

SetParentKeyOldPositionFieldNumber Field

Field number for the "old_position" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int OldPositionFieldNumber = 5
public:
literal int OldPositionFieldNumber = 5

Field Value

Type: Int32
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.OldRotationFieldNumber Field

SetParentKeyOldRotationFieldNumber Field

Field number for the "old_rotation" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int OldRotationFieldNumber = 6
public:
literal int OldRotationFieldNumber = 6

Field Value

Type: Int32
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.ParentComponentIdFieldNumber Field

SetParentKeyParentComponentIdFieldNumber Field

Field number for the "parent_component_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ParentComponentIdFieldNumber = 4
public:
literal int ParentComponentIdFieldNumber = 4

Field Value

Type: Int32
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.ParentNodeIdFieldNumber Field

SetParentKeyParentNodeIdFieldNumber Field

Field number for the "parent_node_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ParentNodeIdFieldNumber = 3
public:
literal int ParentNodeIdFieldNumber = 3

Field Value

Type: Int32
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.PositionFieldNumber Field

SetParentKeyPositionFieldNumber Field

Field number for the "position" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int PositionFieldNumber = 7
public:
literal int PositionFieldNumber = 7

Field Value

Type: Int32
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.Rotation2FieldNumber Field

SetParentKeyRotation2FieldNumber Field

Field number for the "rotation_2" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int Rotation2FieldNumber = 10
public:
literal int Rotation2FieldNumber = 10

Field Value

Type: Int32
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.RotationFieldNumber Field

SetParentKeyRotationFieldNumber Field

Field number for the "rotation" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int RotationFieldNumber = 8
public:
literal int RotationFieldNumber = 8

Field Value

Type: Int32
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.Scale2FieldNumber Field

SetParentKeyScale2FieldNumber Field

Field number for the "scale_2" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int Scale2FieldNumber = 11
public:
literal int Scale2FieldNumber = 11

Field Value

Type: Int32
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetParentKey.ScaleFieldNumber Field

SetParentKeyScaleFieldNumber Field

Field number for the "scale" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ScaleFieldNumber = 9
public:
literal int ScaleFieldNumber = 9

Field Value

Type: Int32
See Also

Reference

SetParentKey Class
VisualComponents.Messages Namespace


SetUVKey Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesSetUVKey

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class SetUVKey : IMessage<SetUVKey>,
    IMessage, IEquatable<SetUVKey>, IDeepCloneable<SetUVKey>
public ref class SetUVKey sealed : IMessage<SetUVKey^>,
    IMessage, IEquatable<SetUVKey^>, IDeepCloneable<SetUVKey^>

The SetUVKey type exposes the following members.

Constructors
 | Name | Description
Public method | SetUVKey | Initializes a new instance of the SetUVKey class
Public method | SetUVKey(SetUVKey) | Initializes a new instance of the SetUVKey class
Top
Properties
Name | Description
Descriptor |
Parser |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(SetUVKey) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(SetUVKey) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


SetUVKey Constructor

Overload List
 | Name | Description
Public method | SetUVKey | Initializes a new instance of the SetUVKey class
Public method | SetUVKey(SetUVKey) | Initializes a new instance of the SetUVKey class
Top
See Also

Reference

SetUVKey Class
VisualComponents.Messages Namespace


SetUVKey Constructor

Initializes a new instance of the SetUVKey class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetUVKey()
public:
SetUVKey()
See Also

Reference

SetUVKey Class
SetUVKey Overload
VisualComponents.Messages Namespace


SetUVKey Constructor (SetUVKey)

Initializes a new instance of the SetUVKey class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetUVKey(
    SetUVKey other
)
public:
SetUVKey(
    SetUVKey^ other
)

Parameters

other
Type: VisualComponents.MessagesSetUVKey
See Also

Reference

SetUVKey Class
SetUVKey Overload
VisualComponents.Messages Namespace


SetUVKey Properties

The SetUVKey type exposes the following members.

Properties
Name | Description
Descriptor |
Parser |
Top
See Also

Reference

SetUVKey Class
VisualComponents.Messages Namespace


SetUVKey.Descriptor Property

SetUVKeyDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

SetUVKey Class
VisualComponents.Messages Namespace


SetUVKey.Parser Property

SetUVKeyParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<SetUVKey> Parser { get; }
public:
static property MessageParser<SetUVKey^>^ Parser {
    MessageParser<SetUVKey^>^ get ();
}

Property Value

Type: MessageParserSetUVKey
See Also

Reference

SetUVKey Class
VisualComponents.Messages Namespace


SetUVKey Methods

The SetUVKey type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(SetUVKey) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(SetUVKey) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SetUVKey Class
VisualComponents.Messages Namespace


SetUVKey.CalculateSize Method

SetUVKeyCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.SetUVKey.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

SetUVKey Class
VisualComponents.Messages Namespace


SetUVKey.Clone Method

SetUVKeyClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetUVKey Clone()
public:
virtual SetUVKey^ Clone() sealed

Return Value

Type: SetUVKey

[Missing <returns> documentation for "M:VisualComponents.Messages.SetUVKey.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

SetUVKey Class
VisualComponents.Messages Namespace


SetUVKey.Equals Method

SetUVKeyEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(SetUVKey) |
Top
See Also

Reference

SetUVKey Class
VisualComponents.Messages Namespace


SetUVKey.Equals Method (Object)

SetUVKeyEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.SetUVKey.Equals(System.Object)"]

See Also

Reference

SetUVKey Class
Equals Overload
VisualComponents.Messages Namespace


SetUVKey.Equals Method (SetUVKey)

SetUVKeyEquals Method (SetUVKey)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    SetUVKey other
)
public:
virtual bool Equals(
    SetUVKey^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesSetUVKey

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.SetUVKey.Equals(VisualComponents.Messages.SetUVKey)"]

Implements

IEquatableTEquals(T)
See Also

Reference

SetUVKey Class
Equals Overload
VisualComponents.Messages Namespace


SetUVKey.GetHashCode Method

SetUVKeyGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.SetUVKey.GetHashCode"]

See Also

Reference

SetUVKey Class
VisualComponents.Messages Namespace


SetUVKey.MergeFrom Method

SetUVKeyMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(SetUVKey) |
Top
See Also

Reference

SetUVKey Class
VisualComponents.Messages Namespace


SetUVKey.MergeFrom Method (CodedInputStream)

SetUVKeyMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

SetUVKey Class
MergeFrom Overload
VisualComponents.Messages Namespace


SetUVKey.MergeFrom Method (SetUVKey)

SetUVKeyMergeFrom Method (SetUVKey)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    SetUVKey other
)
public:
virtual void MergeFrom(
    SetUVKey^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesSetUVKey

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

SetUVKey Class
MergeFrom Overload
VisualComponents.Messages Namespace


SetUVKey.ToString Method

SetUVKeyToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.SetUVKey.ToString"]

See Also

Reference

SetUVKey Class
VisualComponents.Messages Namespace


SetUVKey.WriteTo Method

SetUVKeyWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

SetUVKey Class
VisualComponents.Messages Namespace


SpeedFactor Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesSpeedFactor

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class SpeedFactor : IMessage<SpeedFactor>,
    IMessage, IEquatable<SpeedFactor>, IDeepCloneable<SpeedFactor>
public ref class SpeedFactor sealed : IMessage<SpeedFactor^>,
    IMessage, IEquatable<SpeedFactor^>, IDeepCloneable<SpeedFactor^>

The SpeedFactor type exposes the following members.

Constructors
 | Name | Description
Public method | SpeedFactor | Initializes a new instance of the SpeedFactor class
Public method | SpeedFactor(SpeedFactor) | Initializes a new instance of the SpeedFactor class
Top
Properties
 | Name | Description
 | Descriptor |
 | Parser |
Public property | Value |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(SpeedFactor) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(SpeedFactor) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
ValueFieldNumber | Field number for the "value" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


SpeedFactor Constructor

Overload List
 | Name | Description
Public method | SpeedFactor | Initializes a new instance of the SpeedFactor class
Public method | SpeedFactor(SpeedFactor) | Initializes a new instance of the SpeedFactor class
Top
See Also

Reference

SpeedFactor Class
VisualComponents.Messages Namespace


SpeedFactor Constructor

Initializes a new instance of the SpeedFactor class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SpeedFactor()
public:
SpeedFactor()
See Also

Reference

SpeedFactor Class
SpeedFactor Overload
VisualComponents.Messages Namespace


SpeedFactor Constructor (SpeedFactor)

Initializes a new instance of the SpeedFactor class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SpeedFactor(
    SpeedFactor other
)
public:
SpeedFactor(
    SpeedFactor^ other
)

Parameters

other
Type: VisualComponents.MessagesSpeedFactor
See Also

Reference

SpeedFactor Class
SpeedFactor Overload
VisualComponents.Messages Namespace


SpeedFactor Properties

The SpeedFactor type exposes the following members.

Properties
 | Name | Description
 | Descriptor |
 | Parser |
Public property | Value |
Top
See Also

Reference

SpeedFactor Class
VisualComponents.Messages Namespace


SpeedFactor.Descriptor Property

SpeedFactorDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

SpeedFactor Class
VisualComponents.Messages Namespace


SpeedFactor.Parser Property

SpeedFactorParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<SpeedFactor> Parser { get; }
public:
static property MessageParser<SpeedFactor^>^ Parser {
    MessageParser<SpeedFactor^>^ get ();
}

Property Value

Type: MessageParserSpeedFactor
See Also

Reference

SpeedFactor Class
VisualComponents.Messages Namespace


SpeedFactor.Value Property

SpeedFactorValue Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Value { get; set; }
public:
property double Value {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

SpeedFactor Class
VisualComponents.Messages Namespace


SpeedFactor Methods

The SpeedFactor type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(SpeedFactor) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(SpeedFactor) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SpeedFactor Class
VisualComponents.Messages Namespace


SpeedFactor.CalculateSize Method

SpeedFactorCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.SpeedFactor.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

SpeedFactor Class
VisualComponents.Messages Namespace


SpeedFactor.Clone Method

SpeedFactorClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SpeedFactor Clone()
public:
virtual SpeedFactor^ Clone() sealed

Return Value

Type: SpeedFactor

[Missing <returns> documentation for "M:VisualComponents.Messages.SpeedFactor.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

SpeedFactor Class
VisualComponents.Messages Namespace


SpeedFactor.Equals Method

SpeedFactorEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(SpeedFactor) |
Top
See Also

Reference

SpeedFactor Class
VisualComponents.Messages Namespace


SpeedFactor.Equals Method (Object)

SpeedFactorEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.SpeedFactor.Equals(System.Object)"]

See Also

Reference

SpeedFactor Class
Equals Overload
VisualComponents.Messages Namespace


SpeedFactor.Equals Method (SpeedFactor)

SpeedFactorEquals Method (SpeedFactor)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    SpeedFactor other
)
public:
virtual bool Equals(
    SpeedFactor^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesSpeedFactor

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.SpeedFactor.Equals(VisualComponents.Messages.SpeedFactor)"]

Implements

IEquatableTEquals(T)
See Also

Reference

SpeedFactor Class
Equals Overload
VisualComponents.Messages Namespace


SpeedFactor.GetHashCode Method

SpeedFactorGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.SpeedFactor.GetHashCode"]

See Also

Reference

SpeedFactor Class
VisualComponents.Messages Namespace


SpeedFactor.MergeFrom Method

SpeedFactorMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(SpeedFactor) |
Top
See Also

Reference

SpeedFactor Class
VisualComponents.Messages Namespace


SpeedFactor.MergeFrom Method (CodedInputStream)

SpeedFactorMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

SpeedFactor Class
MergeFrom Overload
VisualComponents.Messages Namespace


SpeedFactor.MergeFrom Method (SpeedFactor)

SpeedFactorMergeFrom Method (SpeedFactor)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    SpeedFactor other
)
public:
virtual void MergeFrom(
    SpeedFactor^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesSpeedFactor

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

SpeedFactor Class
MergeFrom Overload
VisualComponents.Messages Namespace


SpeedFactor.ToString Method

SpeedFactorToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.SpeedFactor.ToString"]

See Also

Reference

SpeedFactor Class
VisualComponents.Messages Namespace


SpeedFactor.WriteTo Method

SpeedFactorWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

SpeedFactor Class
VisualComponents.Messages Namespace


SpeedFactor Fields

The SpeedFactor type exposes the following members.

Fields
Name | Description
ValueFieldNumber | Field number for the "value" field.
Top
See Also

Reference

SpeedFactor Class
VisualComponents.Messages Namespace


SpeedFactor.ValueFieldNumber Field

SpeedFactorValueFieldNumber Field

Field number for the "value" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int ValueFieldNumber = 1
public:
literal int ValueFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

SpeedFactor Class
VisualComponents.Messages Namespace


StartSocket Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesStartSocket

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class StartSocket : IMessage<StartSocket>,
    IMessage, IEquatable<StartSocket>, IDeepCloneable<StartSocket>
public ref class StartSocket sealed : IMessage<StartSocket^>,
    IMessage, IEquatable<StartSocket^>, IDeepCloneable<StartSocket^>

The StartSocket type exposes the following members.

Constructors
 | Name | Description
Public method | StartSocket | Initializes a new instance of the StartSocket class
Public method | StartSocket(StartSocket) | Initializes a new instance of the StartSocket class
Top
Properties
 | Name | Description
 | Descriptor |
Public property | Header1 |
Public property | Header2 |
Public property | Header3 |
 | Parser |
Public property | StreamId |
Public property | StreamName |
Public property | StreamNameLength |
Public property | StreamVersion |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(StartSocket) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(StartSocket) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
Header1FieldNumber | Field number for the "header1" field.
Header2FieldNumber | Field number for the "header2" field.
Header3FieldNumber | Field number for the "header3" field.
StreamIdFieldNumber | Field number for the "stream_id" field.
StreamNameFieldNumber | Field number for the "stream_name" field.
StreamNameLengthFieldNumber | Field number for the "stream_name_length" field.
StreamVersionFieldNumber | Field number for the "stream_version" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


StartSocket Constructor

Overload List
 | Name | Description
Public method | StartSocket | Initializes a new instance of the StartSocket class
Public method | StartSocket(StartSocket) | Initializes a new instance of the StartSocket class
Top
See Also

Reference

StartSocket Class
VisualComponents.Messages Namespace


StartSocket Constructor

Initializes a new instance of the StartSocket class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StartSocket()
public:
StartSocket()
See Also

Reference

StartSocket Class
StartSocket Overload
VisualComponents.Messages Namespace


StartSocket Constructor (StartSocket)

Initializes a new instance of the StartSocket class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StartSocket(
    StartSocket other
)
public:
StartSocket(
    StartSocket^ other
)

Parameters

other
Type: VisualComponents.MessagesStartSocket
See Also

Reference

StartSocket Class
StartSocket Overload
VisualComponents.Messages Namespace


StartSocket Properties

The StartSocket type exposes the following members.

Properties
 | Name | Description
 | Descriptor |
Public property | Header1 |
Public property | Header2 |
Public property | Header3 |
 | Parser |
Public property | StreamId |
Public property | StreamName |
Public property | StreamNameLength |
Public property | StreamVersion |
Top
See Also

Reference

StartSocket Class
VisualComponents.Messages Namespace


StartSocket.Descriptor Property

StartSocketDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

StartSocket Class
VisualComponents.Messages Namespace


StartSocket.Header1 Property

StartSocketHeader1 Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint Header1 { get; set; }
public:
property unsigned int Header1 {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

StartSocket Class
VisualComponents.Messages Namespace


StartSocket.Header2 Property

StartSocketHeader2 Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint Header2 { get; set; }
public:
property unsigned int Header2 {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

StartSocket Class
VisualComponents.Messages Namespace


StartSocket.Header3 Property

StartSocketHeader3 Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint Header3 { get; set; }
public:
property unsigned int Header3 {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

StartSocket Class
VisualComponents.Messages Namespace


StartSocket.Parser Property

StartSocketParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<StartSocket> Parser { get; }
public:
static property MessageParser<StartSocket^>^ Parser {
    MessageParser<StartSocket^>^ get ();
}

Property Value

Type: MessageParserStartSocket
See Also

Reference

StartSocket Class
VisualComponents.Messages Namespace


StartSocket.StreamId Property

StartSocketStreamId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint StreamId { get; set; }
public:
property unsigned int StreamId {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

StartSocket Class
VisualComponents.Messages Namespace


StartSocket.StreamName Property

StartSocketStreamName Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string StreamName { get; set; }
public:
property String^ StreamName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

StartSocket Class
VisualComponents.Messages Namespace


StartSocket.StreamNameLength Property

StartSocketStreamNameLength Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint StreamNameLength { get; set; }
public:
property unsigned int StreamNameLength {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

StartSocket Class
VisualComponents.Messages Namespace


StartSocket.StreamVersion Property

StartSocketStreamVersion Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint StreamVersion { get; set; }
public:
property unsigned int StreamVersion {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

StartSocket Class
VisualComponents.Messages Namespace


StartSocket Methods

The StartSocket type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(StartSocket) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(StartSocket) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

StartSocket Class
VisualComponents.Messages Namespace


StartSocket.CalculateSize Method

StartSocketCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.StartSocket.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

StartSocket Class
VisualComponents.Messages Namespace


StartSocket.Clone Method

StartSocketClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StartSocket Clone()
public:
virtual StartSocket^ Clone() sealed

Return Value

Type: StartSocket

[Missing <returns> documentation for "M:VisualComponents.Messages.StartSocket.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

StartSocket Class
VisualComponents.Messages Namespace


StartSocket.Equals Method

StartSocketEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(StartSocket) |
Top
See Also

Reference

StartSocket Class
VisualComponents.Messages Namespace


StartSocket.Equals Method (Object)

StartSocketEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.StartSocket.Equals(System.Object)"]

See Also

Reference

StartSocket Class
Equals Overload
VisualComponents.Messages Namespace


StartSocket.Equals Method (StartSocket)

StartSocketEquals Method (StartSocket)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    StartSocket other
)
public:
virtual bool Equals(
    StartSocket^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesStartSocket

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.StartSocket.Equals(VisualComponents.Messages.StartSocket)"]

Implements

IEquatableTEquals(T)
See Also

Reference

StartSocket Class
Equals Overload
VisualComponents.Messages Namespace


StartSocket.GetHashCode Method

StartSocketGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.StartSocket.GetHashCode"]

See Also

Reference

StartSocket Class
VisualComponents.Messages Namespace


StartSocket.MergeFrom Method

StartSocketMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(StartSocket) |
Top
See Also

Reference

StartSocket Class
VisualComponents.Messages Namespace


StartSocket.MergeFrom Method (CodedInputStream)

StartSocketMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

StartSocket Class
MergeFrom Overload
VisualComponents.Messages Namespace


StartSocket.MergeFrom Method (StartSocket)

StartSocketMergeFrom Method (StartSocket)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    StartSocket other
)
public:
virtual void MergeFrom(
    StartSocket^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesStartSocket

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

StartSocket Class
MergeFrom Overload
VisualComponents.Messages Namespace


StartSocket.ToString Method

StartSocketToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.StartSocket.ToString"]

See Also

Reference

StartSocket Class
VisualComponents.Messages Namespace


StartSocket.WriteTo Method

StartSocketWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

StartSocket Class
VisualComponents.Messages Namespace


StartSocket Fields

The StartSocket type exposes the following members.

Fields
Name | Description
Header1FieldNumber | Field number for the "header1" field.
Header2FieldNumber | Field number for the "header2" field.
Header3FieldNumber | Field number for the "header3" field.
StreamIdFieldNumber | Field number for the "stream_id" field.
StreamNameFieldNumber | Field number for the "stream_name" field.
StreamNameLengthFieldNumber | Field number for the "stream_name_length" field.
StreamVersionFieldNumber | Field number for the "stream_version" field.
Top
See Also

Reference

StartSocket Class
VisualComponents.Messages Namespace


StartSocket.Header1FieldNumber Field

StartSocketHeader1FieldNumber Field

Field number for the "header1" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int Header1FieldNumber = 1
public:
literal int Header1FieldNumber = 1

Field Value

Type: Int32
See Also

Reference

StartSocket Class
VisualComponents.Messages Namespace


StartSocket.Header2FieldNumber Field

StartSocketHeader2FieldNumber Field

Field number for the "header2" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int Header2FieldNumber = 2
public:
literal int Header2FieldNumber = 2

Field Value

Type: Int32
See Also

Reference

StartSocket Class
VisualComponents.Messages Namespace


StartSocket.Header3FieldNumber Field

StartSocketHeader3FieldNumber Field

Field number for the "header3" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int Header3FieldNumber = 3
public:
literal int Header3FieldNumber = 3

Field Value

Type: Int32
See Also

Reference

StartSocket Class
VisualComponents.Messages Namespace


StartSocket.StreamIdFieldNumber Field

StartSocketStreamIdFieldNumber Field

Field number for the "stream_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int StreamIdFieldNumber = 4
public:
literal int StreamIdFieldNumber = 4

Field Value

Type: Int32
See Also

Reference

StartSocket Class
VisualComponents.Messages Namespace


StartSocket.StreamNameFieldNumber Field

StartSocketStreamNameFieldNumber Field

Field number for the "stream_name" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int StreamNameFieldNumber = 7
public:
literal int StreamNameFieldNumber = 7

Field Value

Type: Int32
See Also

Reference

StartSocket Class
VisualComponents.Messages Namespace


StartSocket.StreamNameLengthFieldNumber Field

StartSocketStreamNameLengthFieldNumber Field

Field number for the "stream_name_length" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int StreamNameLengthFieldNumber = 6
public:
literal int StreamNameLengthFieldNumber = 6

Field Value

Type: Int32
See Also

Reference

StartSocket Class
VisualComponents.Messages Namespace


StartSocket.StreamVersionFieldNumber Field

StartSocketStreamVersionFieldNumber Field

Field number for the "stream_version" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int StreamVersionFieldNumber = 5
public:
literal int StreamVersionFieldNumber = 5

Field Value

Type: Int32
See Also

Reference

StartSocket Class
VisualComponents.Messages Namespace


StartStream Class

Inheritance Hierarchy
SystemObject
VisualComponents.MessagesStartStream

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class StartStream : IMessage<StartStream>,
    IMessage, IEquatable<StartStream>, IDeepCloneable<StartStream>
public ref class StartStream sealed : IMessage<StartStream^>,
    IMessage, IEquatable<StartStream^>, IDeepCloneable<StartStream^>

The StartStream type exposes the following members.

Constructors
 | Name | Description
Public method | StartStream | Initializes a new instance of the StartStream class
Public method | StartStream(StartStream) | Initializes a new instance of the StartStream class
Top
Properties
 | Name | Description
 | Descriptor |
Public property | HeaderId |
Public property | MajorVersion |
Public property | MinorVersion |
 | Parser |
Top
Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(StartStream) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(StartStream) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Fields
Name | Description
HeaderIdFieldNumber | Field number for the "header_id" field.
MajorVersionFieldNumber | Field number for the "major_version" field.
MinorVersionFieldNumber | Field number for the "minor_version" field.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.Messages Namespace


StartStream Constructor

Overload List
 | Name | Description
Public method | StartStream | Initializes a new instance of the StartStream class
Public method | StartStream(StartStream) | Initializes a new instance of the StartStream class
Top
See Also

Reference

StartStream Class
VisualComponents.Messages Namespace


StartStream Constructor

Initializes a new instance of the StartStream class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StartStream()
public:
StartStream()
See Also

Reference

StartStream Class
StartStream Overload
VisualComponents.Messages Namespace


StartStream Constructor (StartStream)

Initializes a new instance of the StartStream class

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StartStream(
    StartStream other
)
public:
StartStream(
    StartStream^ other
)

Parameters

other
Type: VisualComponents.MessagesStartStream
See Also

Reference

StartStream Class
StartStream Overload
VisualComponents.Messages Namespace


StartStream Properties

The StartStream type exposes the following members.

Properties
 | Name | Description
 | Descriptor |
Public property | HeaderId |
Public property | MajorVersion |
Public property | MinorVersion |
 | Parser |
Top
See Also

Reference

StartStream Class
VisualComponents.Messages Namespace


StartStream.Descriptor Property

StartStreamDescriptor Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageDescriptor Descriptor { get; }
public:
static property MessageDescriptor^ Descriptor {
    MessageDescriptor^ get ();
}

Property Value

Type: MessageDescriptor
See Also

Reference

StartStream Class
VisualComponents.Messages Namespace


StartStream.HeaderId Property

StartStreamHeaderId Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint HeaderId { get; set; }
public:
property unsigned int HeaderId {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

StartStream Class
VisualComponents.Messages Namespace


StartStream.MajorVersion Property

StartStreamMajorVersion Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint MajorVersion { get; set; }
public:
property unsigned int MajorVersion {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

StartStream Class
VisualComponents.Messages Namespace


StartStream.MinorVersion Property

StartStreamMinorVersion Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint MinorVersion { get; set; }
public:
property unsigned int MinorVersion {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

StartStream Class
VisualComponents.Messages Namespace


StartStream.Parser Property

StartStreamParser Property

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageParser<StartStream> Parser { get; }
public:
static property MessageParser<StartStream^>^ Parser {
    MessageParser<StartStream^>^ get ();
}

Property Value

Type: MessageParserStartStream
See Also

Reference

StartStream Class
VisualComponents.Messages Namespace


StartStream Methods

The StartStream type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSize |
Public method | Clone |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(StartStream) |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(StartStream) |
Public method | ToString | (Overrides ObjectToString.)
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

StartStream Class
VisualComponents.Messages Namespace


StartStream.CalculateSize Method

StartStreamCalculateSize Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CalculateSize()
public:
virtual int CalculateSize() sealed

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.StartStream.CalculateSize"]

Implements

IMessage.CalculateSize
See Also

Reference

StartStream Class
VisualComponents.Messages Namespace


StartStream.Clone Method

StartStreamClone Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StartStream Clone()
public:
virtual StartStream^ Clone() sealed

Return Value

Type: StartStream

[Missing <returns> documentation for "M:VisualComponents.Messages.StartStream.Clone"]

Implements

IDeepCloneable.Clone
See Also

Reference

StartStream Class
VisualComponents.Messages Namespace


StartStream.Equals Method

StartStreamEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(StartStream) |
Top
See Also

Reference

StartStream Class
VisualComponents.Messages Namespace


StartStream.Equals Method (Object)

StartStreamEquals Method (Object)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object other
)
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.StartStream.Equals(System.Object)"]

See Also

Reference

StartStream Class
Equals Overload
VisualComponents.Messages Namespace


StartStream.Equals Method (StartStream)

StartStreamEquals Method (StartStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    StartStream other
)
public:
virtual bool Equals(
    StartStream^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesStartStream

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.Messages.StartStream.Equals(VisualComponents.Messages.StartStream)"]

Implements

IEquatableTEquals(T)
See Also

Reference

StartStream Class
Equals Overload
VisualComponents.Messages Namespace


StartStream.GetHashCode Method

StartStreamGetHashCode Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.Messages.StartStream.GetHashCode"]

See Also

Reference

StartStream Class
VisualComponents.Messages Namespace


StartStream.MergeFrom Method

StartStreamMergeFrom Method

Overload List
 | Name | Description
Public method | MergeFrom(CodedInputStream) |
Public method | MergeFrom(StartStream) |
Top
See Also

Reference

StartStream Class
VisualComponents.Messages Namespace


StartStream.MergeFrom Method (CodedInputStream)

StartStreamMergeFrom Method (CodedInputStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    CodedInputStream input
)
public:
virtual void MergeFrom(
    CodedInputStream^ input
) sealed

Parameters

input
Type: CodedInputStream

Implements

IMessage.MergeFrom(CodedInputStream)
See Also

Reference

StartStream Class
MergeFrom Overload
VisualComponents.Messages Namespace


StartStream.MergeFrom Method (StartStream)

StartStreamMergeFrom Method (StartStream)

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MergeFrom(
    StartStream other
)
public:
virtual void MergeFrom(
    StartStream^ other
) sealed

Parameters

other
Type: VisualComponents.MessagesStartStream

Implements

IMessage.MergeFrom(UTP)
See Also

Reference

StartStream Class
MergeFrom Overload
VisualComponents.Messages Namespace


StartStream.ToString Method

StartStreamToString Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.Messages.StartStream.ToString"]

See Also

Reference

StartStream Class
VisualComponents.Messages Namespace


StartStream.WriteTo Method

StartStreamWriteTo Method

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteTo(
    CodedOutputStream output
)
public:
virtual void WriteTo(
    CodedOutputStream^ output
) sealed

Parameters

output
Type: CodedOutputStream

Implements

IMessage.WriteTo(CodedOutputStream)
See Also

Reference

StartStream Class
VisualComponents.Messages Namespace


StartStream Fields

The StartStream type exposes the following members.

Fields
Name | Description
HeaderIdFieldNumber | Field number for the "header_id" field.
MajorVersionFieldNumber | Field number for the "major_version" field.
MinorVersionFieldNumber | Field number for the "minor_version" field.
Top
See Also

Reference

StartStream Class
VisualComponents.Messages Namespace


StartStream.HeaderIdFieldNumber Field

StartStreamHeaderIdFieldNumber Field

Field number for the "header_id" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int HeaderIdFieldNumber = 1
public:
literal int HeaderIdFieldNumber = 1

Field Value

Type: Int32
See Also

Reference

StartStream Class
VisualComponents.Messages Namespace


StartStream.MajorVersionFieldNumber Field

StartStreamMajorVersionFieldNumber Field

Field number for the "major_version" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int MajorVersionFieldNumber = 2
public:
literal int MajorVersionFieldNumber = 2

Field Value

Type: Int32
See Also

Reference

StartStream Class
VisualComponents.Messages Namespace


StartStream.MinorVersionFieldNumber Field

StartStreamMinorVersionFieldNumber Field

Field number for the "minor_version" field.

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int MinorVersionFieldNumber = 3
public:
literal int MinorVersionFieldNumber = 3

Field Value

Type: Int32
See Also

Reference

StartStream Class
VisualComponents.Messages Namespace


VisualComponentsMessagesReflection Class

Holder for reflection information generated from VisualComponents_Messages.proto
Inheritance Hierarchy
SystemObject
VisualComponents.MessagesVisualComponentsMessagesReflection

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class VisualComponentsMessagesReflection
public ref class VisualComponentsMessagesReflection abstract sealed

The VisualComponentsMessagesReflection type exposes the following members.

Properties
Name | Description
Descriptor | File descriptor for VisualComponents_Messages.proto
Top
See Also

Reference

VisualComponents.Messages Namespace


VisualComponentsMessagesReflection Properties

The VisualComponentsMessagesReflection type exposes the following members.

Properties
Name | Description
Descriptor | File descriptor for VisualComponents_Messages.proto
Top
See Also

Reference

VisualComponentsMessagesReflection Class
VisualComponents.Messages Namespace


VisualComponentsMessagesReflection.Descriptor Property

VisualComponentsMessagesReflectionDescriptor Property

File descriptor for VisualComponents_Messages.proto

Namespace: VisualComponents.Messages
Assembly: Create3D.Shared (in Create3D.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static FileDescriptor Descriptor { get; }
public:
static property FileDescriptor^ Descriptor {
    FileDescriptor^ get ();
}

Property Value

Type: FileDescriptor
See Also

Reference

VisualComponentsMessagesReflection Class
VisualComponents.Messages Namespace


VisualComponents.UX Namespace

Classes
 | Class | Description
Public class | DependencyObjExtensions |
Public class | DockingPaneLocationEnum |


DependencyObjExtensions Class

Inheritance Hierarchy
SystemObject
VisualComponents.UXDependencyObjExtensions

Namespace: VisualComponents.UX
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class DependencyObjExtensions
[ExtensionAttribute]
public ref class DependencyObjExtensions abstract sealed

The DependencyObjExtensions type exposes the following members.

Methods
Name | Description
FindChildT(DependencyObject) | Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead.
FindChildT(DependencyObject, FuncT, Boolean) | Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead.
FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate
FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T.
FindVisualParentT | Finds a parent of a given item on the visual tree.
TryFindChildT(DependencyObject, T) | Use this overload if the child you're looking may not exist.
TryFindChildT(DependencyObject, FuncT, Boolean, T) | Use this overload if the child you're looking may not exist.
Top
See Also

Reference

VisualComponents.UX Namespace


DependencyObjExtensions Methods

The DependencyObjExtensions type exposes the following members.

Methods
Name | Description
FindChildT(DependencyObject) | Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead.
FindChildT(DependencyObject, FuncT, Boolean) | Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead.
FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate
FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T.
FindVisualParentT | Finds a parent of a given item on the visual tree.
TryFindChildT(DependencyObject, T) | Use this overload if the child you're looking may not exist.
TryFindChildT(DependencyObject, FuncT, Boolean, T) | Use this overload if the child you're looking may not exist.
Top
See Also

Reference

DependencyObjExtensions Class
VisualComponents.UX Namespace


DependencyObjExtensions.FindChild Method

DependencyObjExtensionsFindChild Method

Overload List
Name | Description
FindChildT(DependencyObject) | Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead.
FindChildT(DependencyObject, FuncT, Boolean) | Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead.
Top
See Also

Reference

DependencyObjExtensions Class
VisualComponents.UX Namespace


DependencyObjExtensions.FindChild(T) Method (DependencyObject)

DependencyObjExtensionsFindChildT Method (DependencyObject)

Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead.

Namespace: VisualComponents.UX
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static T FindChild<T>(
    this DependencyObject parent
)
where T : DependencyObject

public:
[ExtensionAttribute]
generic<typename T>
where T : DependencyObject
static T FindChild(
    DependencyObject^ parent
)

Parameters

parent
Type: System.WindowsDependencyObject
The dependency object whose children you wish to scan

Type Parameters

T
The type of child you want to find

Return Value

Type: T
The first descendant of the specified type

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DependencyObject. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
usage: myWindow.FindChild()
See Also

Reference

DependencyObjExtensions Class
FindChild Overload
VisualComponents.UX Namespace


DependencyObjExtensions.FindChild(T) Method (DependencyObject, Func(T, Boolean))

DependencyObjExtensionsFindChildT Method (DependencyObject, FuncT, Boolean)

Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead.

Namespace: VisualComponents.UX
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static T FindChild<T>(
    this DependencyObject parent,
    Func<T, bool> predicate
)
where T : DependencyObject

public:
[ExtensionAttribute]
generic<typename T>
where T : DependencyObject
static T FindChild(
    DependencyObject^ parent,
    Func<T, bool>^ predicate
)

Parameters

parent
Type: System.WindowsDependencyObject
The dependency object whose children you wish to scan
predicate
Type: SystemFuncT, Boolean
The child object is selected if the predicate evaluates to true

Type Parameters

T
The type of child you want to find

Return Value

Type: T
The first matching descendant of the specified type

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DependencyObject. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
usage: myWindow.FindChild( child => child.Name == "myPanel" )
See Also

Reference

DependencyObjExtensions Class
FindChild Overload
VisualComponents.UX Namespace


DependencyObjExtensions.FindChildren(T) Method

DependencyObjExtensionsFindChildrenT Method

Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate

Namespace: VisualComponents.UX
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IEnumerable<T> FindChildren<T>(
    this DependencyObject parent,
    Func<T, bool> predicate
)
where T : DependencyObject

public:
[ExtensionAttribute]
generic<typename T>
where T : DependencyObject
static IEnumerable<T>^ FindChildren(
    DependencyObject^ parent,
    Func<T, bool>^ predicate
)

Parameters

parent
Type: System.WindowsDependencyObject
The dependency object whose children you wish to scan
predicate
Type: SystemFuncT, Boolean
The child object is selected if the predicate evaluates to true

Type Parameters

T
The type of child you want to find

Return Value

Type: IEnumerableT
The first matching descendant of the specified type

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DependencyObject. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
usage: myWindow.FindChildren( child => child.Name == "myPanel" )
See Also

Reference

DependencyObjExtensions Class
VisualComponents.UX Namespace


DependencyObjExtensions.FindChildrenFast(T) Method

DependencyObjExtensionsFindChildrenFastT Method

Similar to FindChildren, but doesn't recurse into the object of type T.

Namespace: VisualComponents.UX
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IEnumerable<T> FindChildrenFast<T>(
    this DependencyObject parent,
    Func<T, bool> predicate
)
where T : DependencyObject

public:
[ExtensionAttribute]
generic<typename T>
where T : DependencyObject
static IEnumerable<T>^ FindChildrenFast(
    DependencyObject^ parent,
    Func<T, bool>^ predicate
)

Parameters

parent
Type: System.WindowsDependencyObject
predicate
Type: SystemFuncT, Boolean

Type Parameters

T

Return Value

Type: IEnumerableT

[Missing <returns> documentation for "M:VisualComponents.UX.DependencyObjExtensions.FindChildrenFast``1(System.Windows.DependencyObject,System.Func{``0,System.Boolean})"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DependencyObject. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DependencyObjExtensions Class
VisualComponents.UX Namespace


DependencyObjExtensions.FindVisualParent(T) Method

DependencyObjExtensionsFindVisualParentT Method

Finds a parent of a given item on the visual tree.

Namespace: VisualComponents.UX
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static T FindVisualParent<T>(
    this DependencyObject child
)
where T : DependencyObject

public:
[ExtensionAttribute]
generic<typename T>
where T : DependencyObject
static T FindVisualParent(
    DependencyObject^ child
)

Parameters

child
Type: System.WindowsDependencyObject
A direct or indirect child of the queried item.

Type Parameters

T
The type of the queried item.

Return Value

Type: T
The first parent item that matches the submitted type parameter. If not matching item can be found, a null reference is being returned.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DependencyObject. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DependencyObjExtensions Class
VisualComponents.UX Namespace


DependencyObjExtensions.TryFindChild Method

DependencyObjExtensionsTryFindChild Method

Overload List
Name | Description
TryFindChildT(DependencyObject, T) | Use this overload if the child you're looking may not exist.
TryFindChildT(DependencyObject, FuncT, Boolean, T) | Use this overload if the child you're looking may not exist.
Top
See Also

Reference

DependencyObjExtensions Class
VisualComponents.UX Namespace


DependencyObjExtensions.TryFindChild(T) Method (DependencyObject, T)

DependencyObjExtensionsTryFindChildT Method (DependencyObject, T)

Use this overload if the child you're looking may not exist.

Namespace: VisualComponents.UX
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool TryFindChild<T>(
    this DependencyObject parent,
    out T foundChild
)
where T : DependencyObject

public:
[ExtensionAttribute]
generic<typename T>
where T : DependencyObject
static bool TryFindChild(
    DependencyObject^ parent,
    [OutAttribute] T% foundChild
)

Parameters

parent
Type: System.WindowsDependencyObject
The dependency object whose children you wish to scan
foundChild
Type: T
out param - the found child dependencyobject, null if the method returns false

Type Parameters

T
The type of child you're looking for

Return Value

Type: Boolean
True if a child was found, else false

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DependencyObject. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DependencyObjExtensions Class
TryFindChild Overload
VisualComponents.UX Namespace


DependencyObjExtensions.TryFindChild(T) Method (DependencyObject, Func(T, Boolean), T)

DependencyObjExtensionsTryFindChildT Method (DependencyObject, FuncT, Boolean, T)

Use this overload if the child you're looking may not exist.

Namespace: VisualComponents.UX
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool TryFindChild<T>(
    this DependencyObject parent,
    Func<T, bool> predicate,
    out T foundChild
)
where T : DependencyObject

public:
[ExtensionAttribute]
generic<typename T>
where T : DependencyObject
static bool TryFindChild(
    DependencyObject^ parent,
    Func<T, bool>^ predicate,
    [OutAttribute] T% foundChild
)

Parameters

parent
Type: System.WindowsDependencyObject
The dependency object whose children you wish to scan
predicate
Type: SystemFuncT, Boolean
The child object is selected if the predicate evaluates to true
foundChild
Type: T
out param - the found child dependencyobject, null if the method returns false

Type Parameters

T
The type of child you're looking for

Return Value

Type: Boolean
True if a child was found, else false

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DependencyObject. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DependencyObjExtensions Class
TryFindChild Overload
VisualComponents.UX Namespace


DockingPaneLocationEnum Class

Inheritance Hierarchy
SystemObject
VisualComponents.UXDockingPaneLocationEnum

Namespace: VisualComponents.UX
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class DockingPaneLocationEnum
[ExtensionAttribute]
public ref class DockingPaneLocationEnum abstract sealed

The DockingPaneLocationEnum type exposes the following members.

Methods
Name | Description
ToInitialPaneLocation |
ToPaneLocation |
Top
See Also

Reference

VisualComponents.UX Namespace


DockingPaneLocationEnum Methods

The DockingPaneLocationEnum type exposes the following members.

Methods
Name | Description
ToInitialPaneLocation |
ToPaneLocation |
Top
See Also

Reference

DockingPaneLocationEnum Class
VisualComponents.UX Namespace


DockingPaneLocationEnum.ToInitialPaneLocation Method

DockingPaneLocationEnumToInitialPaneLocation Method

Namespace: VisualComponents.UX
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static InitialPaneLocation ToInitialPaneLocation(
    this PaneLocation location
)
public:
[ExtensionAttribute]
static InitialPaneLocation ToInitialPaneLocation(
    PaneLocation location
)

Parameters

location
Type: PaneLocation

Return Value

Type: InitialPaneLocation

[Missing <returns> documentation for "M:VisualComponents.UX.DockingPaneLocationEnum.ToInitialPaneLocation(Infragistics.Windows.DockManager.PaneLocation)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PaneLocation. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DockingPaneLocationEnum Class
VisualComponents.UX Namespace


DockingPaneLocationEnum.ToPaneLocation Method

DockingPaneLocationEnumToPaneLocation Method

Namespace: VisualComponents.UX
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static PaneLocation ToPaneLocation(
    this InitialPaneLocation location
)
public:
[ExtensionAttribute]
static PaneLocation ToPaneLocation(
    InitialPaneLocation location
)

Parameters

location
Type: InitialPaneLocation

Return Value

Type: PaneLocation

[Missing <returns> documentation for "M:VisualComponents.UX.DockingPaneLocationEnum.ToPaneLocation(Infragistics.Windows.DockManager.InitialPaneLocation)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type InitialPaneLocation. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DockingPaneLocationEnum Class
VisualComponents.UX Namespace


VisualComponents.UX.Input Namespace

Classes
 | Class | Description
Public class | AnnotationManipulateHandler |
Public class | AreaSelectHandler |
Public class | DimensionManipulateHandler |
Public class | HelperViewport | A control that manipulates the camera and objects by mouse and keyboard gestures.
Public class | HelperViewportInteractiveObject |
Public class | InputBindingTrigger |
Public class | InputBindingTriggerEx |
Public class | ManipulationEventArgs | Provides data for the manipulation events.
Public class | MouseGestureHandler | An abstract base class for the mouse gesture handlers.
Public class | ObjectRotateHandler | Handles rotation. Deprecated. Now Control is reserved to area selection.
Public class | PanHandler | Handles panning.
Public class | PickHandler |
Public class | PlugPlayLogicalHandler |
Public class | QuickCopyPasteHandler |
Public class | RotateHandler | Handles camera rotation (orbit).
Public class | SelectHandler |
Public class | SelectParentHandler |
Public class | SetCenterOfInterestHandler | Handles rotation.
Public class | ShowContextMenuHandler | Shows/hides right-click-menu in 3D window.
Public class | SiAppNativeMethods | PInvoke calls to 3DConnexion spacemouse.
Public class | TranslateHandler |
Public class | ZoomHandler | Handles zooming.
Structures
 | Structure | Description
Public structure | SiAppNativeMethodsMSG |
Public structure | SiAppNativeMethodsSiButtonData |
Public structure | SiAppNativeMethodsSiButtonName |
Public structure | SiAppNativeMethodsSiDeviceChangeEventData |
Public structure | SiAppNativeMethodsSiDeviceName |
Public structure | SiAppNativeMethodsSiDevInfo |
Public structure | SiAppNativeMethodsSiDevPort |
Public structure | SiAppNativeMethodsSiGetEventData |
Public structure | SiAppNativeMethodsSiKeyboardData |
Public structure | SiAppNativeMethodsSiOpenData |
Public structure | SiAppNativeMethodsSiOrientation1 |
Public structure | SiAppNativeMethodsSiPortName |
Public structure | SiAppNativeMethodsSiSpwData |
Public structure | SiAppNativeMethodsSiSpwEvent |
Public structure | SiAppNativeMethodsSiSpwEvent_DeviceChange |
Public structure | SiAppNativeMethodsSiSpwEvent_JustType |
Public structure | SiAppNativeMethodsSiSpwEvent_SpwData |
Public structure | SiAppNativeMethodsSiSpwOOB |
Public structure | SiAppNativeMethodsSiTypeMask |
Enumerations
 | Enumeration | Description
Public enumeration | CameraMode | Camera movement modes.
Public enumeration | CameraRotationMode | Camera rotation modes.
Public enumeration | SiAppNativeMethodsSiCmdType |
Public enumeration | SiAppNativeMethodsSiDeviceChangeType |
Public enumeration | SiAppNativeMethodsSiDevType |
Public enumeration | SiAppNativeMethodsSiEventType |
Public enumeration | SiAppNativeMethodsSiOrientation |
Public enumeration | SiAppNativeMethodsSiV3D_Key |
Public enumeration | SiAppNativeMethodsSpwRetVal |


AnnotationManipulateHandler Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.InputMouseGestureHandler
VisualComponents.UX.InputAnnotationManipulateHandler

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class AnnotationManipulateHandler : MouseGestureHandler
public ref class AnnotationManipulateHandler sealed : public MouseGestureHandler

The AnnotationManipulateHandler type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationManipulateHandler | Initializes a new instance of the AnnotationManipulateHandler class
Top
Properties
 | Name | Description
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Top
Methods
 | Name | Description
Public method | CanExecute | (Overrides MouseGestureHandlerCanExecute.)
Public method | Completed | (Overrides MouseGestureHandlerCompleted(ManipulationEventArgs).)
Public method | Delta | (Overrides MouseGestureHandlerDelta(ManipulationEventArgs).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnLostMouseCapture | (Overrides MouseGestureHandlerOnLostMouseCapture(Object, MouseEventArgs).)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


AnnotationManipulateHandler Constructor

Initializes a new instance of the AnnotationManipulateHandler class

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AnnotationManipulateHandler(
    HelperViewport controller
)
public:
AnnotationManipulateHandler(
    HelperViewport^ controller
)

Parameters

controller
Type: VisualComponents.UX.InputHelperViewport
See Also

Reference

AnnotationManipulateHandler Class
VisualComponents.UX.Input Namespace


AnnotationManipulateHandler Properties

The AnnotationManipulateHandler type exposes the following members.

Properties
 | Name | Description
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Top
See Also

Reference

AnnotationManipulateHandler Class
VisualComponents.UX.Input Namespace


AnnotationManipulateHandler Methods

The AnnotationManipulateHandler type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | (Overrides MouseGestureHandlerCanExecute.)
Public method | Completed | (Overrides MouseGestureHandlerCompleted(ManipulationEventArgs).)
Public method | Delta | (Overrides MouseGestureHandlerDelta(ManipulationEventArgs).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnLostMouseCapture | (Overrides MouseGestureHandlerOnLostMouseCapture(Object, MouseEventArgs).)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AnnotationManipulateHandler Class
VisualComponents.UX.Input Namespace


AnnotationManipulateHandler.CanExecute Method

AnnotationManipulateHandlerCanExecute Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool CanExecute()
public:
virtual bool CanExecute() override

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Input.AnnotationManipulateHandler.CanExecute"]

See Also

Reference

AnnotationManipulateHandler Class
VisualComponents.UX.Input Namespace


AnnotationManipulateHandler.Completed Method

AnnotationManipulateHandlerCompleted Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Completed(
    ManipulationEventArgs e
)
public:
virtual void Completed(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

AnnotationManipulateHandler Class
VisualComponents.UX.Input Namespace


AnnotationManipulateHandler.Delta Method

AnnotationManipulateHandlerDelta Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Delta(
    ManipulationEventArgs e
)
public:
virtual void Delta(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

AnnotationManipulateHandler Class
VisualComponents.UX.Input Namespace


AnnotationManipulateHandler.OnLostMouseCapture Method

AnnotationManipulateHandlerOnLostMouseCapture Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnLostMouseCapture(
    Object sender,
    MouseEventArgs e
)
public:
virtual void OnLostMouseCapture(
    Object^ sender,
    MouseEventArgs^ e
) override

Parameters

sender
Type: SystemObject
e
Type: System.Windows.InputMouseEventArgs
See Also

Reference

AnnotationManipulateHandler Class
VisualComponents.UX.Input Namespace


AnnotationManipulateHandler.Started Method

AnnotationManipulateHandlerStarted Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Started(
    ManipulationEventArgs e
)
public:
virtual void Started(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

AnnotationManipulateHandler Class
VisualComponents.UX.Input Namespace


AreaSelectHandler Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.InputMouseGestureHandler
VisualComponents.UX.InputAreaSelectHandler

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class AreaSelectHandler : MouseGestureHandler
public ref class AreaSelectHandler sealed : public MouseGestureHandler

The AreaSelectHandler type exposes the following members.

Constructors
 | Name | Description
Public method | AreaSelectHandler | Initializes a new instance of the AreaSelectHandler class
Top
Properties
 | Name | Description
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Public property | UseMultiselect |
Top
Methods
 | Name | Description
Public method | CanExecute | (Overrides MouseGestureHandlerCanExecute.)
Public method | Completed | (Overrides MouseGestureHandlerCompleted(ManipulationEventArgs).)
Public method | Delta | (Overrides MouseGestureHandlerDelta(ManipulationEventArgs).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnLostMouseCapture | (Inherited from MouseGestureHandler.)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


AreaSelectHandler Constructor

Initializes a new instance of the AreaSelectHandler class

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AreaSelectHandler(
    HelperViewport controller,
    bool useMultiSelect
)
public:
AreaSelectHandler(
    HelperViewport^ controller,
    bool useMultiSelect
)

Parameters

controller
Type: VisualComponents.UX.InputHelperViewport
useMultiSelect
Type: SystemBoolean
See Also

Reference

AreaSelectHandler Class
VisualComponents.UX.Input Namespace


AreaSelectHandler Properties

The AreaSelectHandler type exposes the following members.

Properties
 | Name | Description
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Public property | UseMultiselect |
Top
See Also

Reference

AreaSelectHandler Class
VisualComponents.UX.Input Namespace


AreaSelectHandler.UseMultiselect Property

AreaSelectHandlerUseMultiselect Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool UseMultiselect { get; set; }
public:
property bool UseMultiselect {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AreaSelectHandler Class
VisualComponents.UX.Input Namespace


AreaSelectHandler Methods

The AreaSelectHandler type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | (Overrides MouseGestureHandlerCanExecute.)
Public method | Completed | (Overrides MouseGestureHandlerCompleted(ManipulationEventArgs).)
Public method | Delta | (Overrides MouseGestureHandlerDelta(ManipulationEventArgs).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnLostMouseCapture | (Inherited from MouseGestureHandler.)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AreaSelectHandler Class
VisualComponents.UX.Input Namespace


AreaSelectHandler.CanExecute Method

AreaSelectHandlerCanExecute Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool CanExecute()
public:
virtual bool CanExecute() override

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Input.AreaSelectHandler.CanExecute"]

See Also

Reference

AreaSelectHandler Class
VisualComponents.UX.Input Namespace


AreaSelectHandler.Completed Method

AreaSelectHandlerCompleted Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Completed(
    ManipulationEventArgs e
)
public:
virtual void Completed(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

AreaSelectHandler Class
VisualComponents.UX.Input Namespace


AreaSelectHandler.Delta Method

AreaSelectHandlerDelta Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Delta(
    ManipulationEventArgs e
)
public:
virtual void Delta(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

AreaSelectHandler Class
VisualComponents.UX.Input Namespace


AreaSelectHandler.Started Method

AreaSelectHandlerStarted Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Started(
    ManipulationEventArgs e
)
public:
virtual void Started(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

AreaSelectHandler Class
VisualComponents.UX.Input Namespace


CameraMode Enumeration

Camera movement modes.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum CameraMode
public enum class CameraMode
Members
Member name | Value | Description
Inspect | 0 | Orbits around a point (fixed target position, move closer target when zooming).
WalkAround | 1 | Walk around (fixed camera position, move in cameradirection when zooming).
FixedPosition | 2 | Fixed camera target, change FOV when zooming.
See Also

Reference

VisualComponents.UX.Input Namespace


CameraRotationMode Enumeration

Camera rotation modes.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum CameraRotationMode
public enum class CameraRotationMode
Members
Member name | Value | Description
Turntable | 0 | Turntable is constrained to two axes of rotation (model up and right direction)
Turnball | 1 | Turntable using three axes (look direction, right direction and up direction (on the left/right edges)).
Trackball | 2 | Using a virtual trackball.
See Also

Reference

VisualComponents.UX.Input Namespace


DimensionManipulateHandler Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.InputMouseGestureHandler
VisualComponents.UX.InputDimensionManipulateHandler

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class DimensionManipulateHandler : MouseGestureHandler
public ref class DimensionManipulateHandler sealed : public MouseGestureHandler

The DimensionManipulateHandler type exposes the following members.

Constructors
 | Name | Description
Public method | DimensionManipulateHandler | Initializes a new instance of the DimensionManipulateHandler class
Top
Properties
 | Name | Description
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Top
Methods
 | Name | Description
Public method | CanExecute | (Overrides MouseGestureHandlerCanExecute.)
Public method | Completed | (Overrides MouseGestureHandlerCompleted(ManipulationEventArgs).)
Public method | Delta | (Overrides MouseGestureHandlerDelta(ManipulationEventArgs).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnLostMouseCapture | (Overrides MouseGestureHandlerOnLostMouseCapture(Object, MouseEventArgs).)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


DimensionManipulateHandler Constructor

Initializes a new instance of the DimensionManipulateHandler class

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DimensionManipulateHandler(
    HelperViewport controller
)
public:
DimensionManipulateHandler(
    HelperViewport^ controller
)

Parameters

controller
Type: VisualComponents.UX.InputHelperViewport
See Also

Reference

DimensionManipulateHandler Class
VisualComponents.UX.Input Namespace


DimensionManipulateHandler Properties

The DimensionManipulateHandler type exposes the following members.

Properties
 | Name | Description
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Top
See Also

Reference

DimensionManipulateHandler Class
VisualComponents.UX.Input Namespace


DimensionManipulateHandler Methods

The DimensionManipulateHandler type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | (Overrides MouseGestureHandlerCanExecute.)
Public method | Completed | (Overrides MouseGestureHandlerCompleted(ManipulationEventArgs).)
Public method | Delta | (Overrides MouseGestureHandlerDelta(ManipulationEventArgs).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnLostMouseCapture | (Overrides MouseGestureHandlerOnLostMouseCapture(Object, MouseEventArgs).)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DimensionManipulateHandler Class
VisualComponents.UX.Input Namespace


DimensionManipulateHandler.CanExecute Method

DimensionManipulateHandlerCanExecute Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool CanExecute()
public:
virtual bool CanExecute() override

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Input.DimensionManipulateHandler.CanExecute"]

See Also

Reference

DimensionManipulateHandler Class
VisualComponents.UX.Input Namespace


DimensionManipulateHandler.Completed Method

DimensionManipulateHandlerCompleted Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Completed(
    ManipulationEventArgs e
)
public:
virtual void Completed(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

DimensionManipulateHandler Class
VisualComponents.UX.Input Namespace


DimensionManipulateHandler.Delta Method

DimensionManipulateHandlerDelta Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Delta(
    ManipulationEventArgs e
)
public:
virtual void Delta(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

DimensionManipulateHandler Class
VisualComponents.UX.Input Namespace


DimensionManipulateHandler.OnLostMouseCapture Method

DimensionManipulateHandlerOnLostMouseCapture Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnLostMouseCapture(
    Object sender,
    MouseEventArgs e
)
public:
virtual void OnLostMouseCapture(
    Object^ sender,
    MouseEventArgs^ e
) override

Parameters

sender
Type: SystemObject
e
Type: System.Windows.InputMouseEventArgs
See Also

Reference

DimensionManipulateHandler Class
VisualComponents.UX.Input Namespace


DimensionManipulateHandler.Started Method

DimensionManipulateHandlerStarted Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Started(
    ManipulationEventArgs e
)
public:
virtual void Started(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

DimensionManipulateHandler Class
VisualComponents.UX.Input Namespace


HelperViewport Class

A control that manipulates the camera and objects by mouse and keyboard gestures.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsPanel
System.Windows.ControlsGrid
VisualComponents.UX.InputHelperViewport

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class HelperViewport : Grid
public ref class HelperViewport : public Grid

The HelperViewport type exposes the following members.

Constructors
 | Name | Description
Public method | HelperViewport | Initializes a new instance of the CameraController class.
Top
Properties
 | Name | Description
 | ActiveViewport |
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AnnotationManipulateHandler | The annotation event handler.
 | Application |
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreaSelectHandler |
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CameraForwardDirection | Gets or sets the world camera forward direction.
Public property | CameraMode | Gets or sets CameraMode.
Public property | CameraRightDirection | Gets or sets the world camera right direction.
Public property | CameraRotationMode | Gets or sets CameraRotationMode.
Public property | CameraUpDirection | Gets or sets the world camera up direction.
 | CanPickAbortAction |
Public property | ChangeFieldOfViewCursor | Gets or sets the change fov cursor.
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | ColumnDefinitions | Gets a ColumnDefinitionCollection defined on this instance of Grid. (Inherited from Grid.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DimensionManipulateHandler | The dimension event handler.
Public property | Direct3DViewPortElement | Gets or sets reference to D3DImage element.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
 | DoubleClickStartedWith |
Public property | DXViewport |
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | Enabled | Gets or sets a value indicating whether Enabled.
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
 | FocusedPart |
 | FocusedPosition |
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | HasLogicalOrientationPublic | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
 | InteractionService |
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsPanEnabled | Gets or sets a value indicating whether IsPanEnabled.
 | IsPickActionInProgress |
Public property | IsRotationEnabled | Gets or sets a value indicating whether IsRotationEnabled.
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
 | IsSnapInContinuousMode |
 | IsSnapModeEnabled |
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | IsZoomEnabled | Gets or sets a value indicating whether IsZoomEnabled.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical children of this Grid. (Inherited from Grid.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | LogicalOrientationPublic | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Protected property | ManipulateViewModel |
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MultiPickHandler |
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | ObjectQuickMenuDisplayHandler |
Public property | ObjectRotateHandler | The object rotate event handler.
Public property | ObjectSelectionMode |
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | PanCursor | Gets or sets the pan cursor.
Public property | PanHandler | The pan event handler.
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | PickCursor | Gets or sets the rotate cursor.
Public property | PickHandler |
Public property | PlugPlayLogicalHandler | Logical plug and play event handler.
Public property | QuickCopyPasteHandler |
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | ReverseDpiScale |
Public property | RotateCursor | Gets or sets the rotate cursor.
Public property | RotateHandler |
Public property | RowDefinitions | Gets a RowDefinitionCollection defined on this instance of Grid. (Inherited from Grid.)
Public property | SelectParentHandler |
Public property | SetCenterOfInterestHandler | Set center of interest event handler.
Public property | ShowContextMenuHandler | Show context menu event handler.
Public property | ShowGridLines | Gets or sets a value that indicates whether grid lines are visible within this Grid. (Inherited from Grid.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Protected property | TeachContext |
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TranslateHandler | The translate event handler.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Viewport | Gets or sets Viewport.
Public property | Window |
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets a value that represents the total number of Visual children within this instance of Grid. (Inherited from Grid.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZoomCursor | Gets or sets the zoom cursor.
Public property | ZoomHandler |
Public property | ZoomRectangleCursor | Gets or sets the zoom rectangle cursor.
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddMouseListener |
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Arranges the content of a Grid element. (Inherited from Grid.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearMouseListeners |
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
 | ConsumeDoubleClick |
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
 | GetScreenSize(Size, Boolean) |
 | GetScreenSize(Double, Double, Boolean) |
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Gets the child Visual at the specified index position. (Inherited from Grid.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Measures the children of a Grid in anticipation of arranging them during the ArrangeOverride(Size) pass. (Inherited from Grid.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Processes Drop event. (Overrides UIElementOnDrop(DragEventArgs).)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture(MouseEventArgs) | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture(Object, MouseEventArgs) |
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Overrides UIElementOnManipulationDelta(ManipulationDeltaEventArgs).)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Overrides UIElementOnManipulationStarted(ManipulationStartedEventArgs).)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Overrides UIElementOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the visual children of a Grid element change. (Inherited from Grid.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
 | RaycastSceneEx |
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ResetCamera | The reset camera.
Public method | ResetCameraUpDirection | Resets the camera up direction.
 | RestorePnpMode |
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetSelectionCanvasNeeded |
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | ShouldSerializeColumnDefinitions | Returns true if ColumnDefinitionCollection associated with this instance of Grid is not empty. (Inherited from Grid.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeRowDefinitions | Returns true if RowDefinitionCollection associated with this instance of Grid is not empty. (Inherited from Grid.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
 | TryPnpOne |
 | TrySelectAdded |
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateCamera |
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Zoom | Zooms by the specified delta value.
Top
Events
 | Name | Description
Public event | CameraChanged |
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Public event | ViewportMouseDown | Additional functionality for MouseDown event, happens when this class handles PreviewMouseDown
Top
Fields
 | Name | Description
 | ActivePersistentSnapAction |
 | AnnotationInteractCommand | The annotation manipulation command.
 | AreaSelectCommand | The area select command.
Public field | areaSelectionRectangle |
 | BackViewCommand | The back view command.
 | BottomViewCommand | The bottom view command.
 | CameraForwardDirectionProperty | Describes the forward direction of the world camera.
 | CameraModeProperty | The camera mode property.
 | CameraRightDirectionProperty | Describes the right direction of the world camera.
 | CameraRotationModeProperty | The camera rotation mode property.
 | CameraUpDirectionProperty | Describes the up direction of the world camera.
 | ChangeFieldOfViewCursorProperty | The change fov cursor property.
 | ClickPixelTolerance |
 | DimensionInteractCommand | The dimension manipulation command.
 | Direct3DViewPortElementProperty | The Direct3DViewPortElementProperty property.
 | EnabledProperty | The enabled property.
Public field | exportAreaSelectionRectangle |
 | FrontViewCommand | The front view command.
 | IsPanEnabledProperty | The is pan enabled property.
 | IsRotationEnabledProperty | The is rotation enabled property.
 | IsZoomEnabledProperty | The is zoom enabled property.
Public field | lassoSelectionPolyline |
 | LeftViewCommand | The left view command.
 | MultiselectPickCommand | The multiselectpick command.
 | ObjectRotateCommand | The object rotate command.
 | ObjectSelectionModeProperty | The rotate cursor property.
 | OnModifierChange |
 | OrbitCommand | The camera rotate command.
 | PanCommand | The pan command.
 | PanCursorProperty | The pan cursor property.
 | PickCommand | The pick command.
 | PickCursorProperty | The rotate cursor property.
 | QuickCopyPasteCommand | The quick copy/paste with auto pnp command.
 | RightViewCommand | The right view command.
 | RotateCursorProperty | The rotate cursor property.
Public field | SelectionCanvas |
 | SelectParentCommand |
 | SetCenterOfInterestedCommand | Set center of interested command
 | ShowContextMenuCommand | The area show context menu command.
 | TopViewCommand | The top view command.
 | TranslateCommand | The translate command.
 | ViewportProperty | The viewport property.
 | ZoomCommand | The zoom command.
 | ZoomCursorProperty | The zoom cursor property.
 | ZoomRectangleCursorProperty | The zoom rectangle cursor property.
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


HelperViewport Constructor

Initializes a new instance of the CameraController class.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public HelperViewport()
public:
HelperViewport()
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport Properties

The HelperViewport type exposes the following members.

Properties
 | Name | Description
 | ActiveViewport |
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AnnotationManipulateHandler | The annotation event handler.
 | Application |
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreaSelectHandler |
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CameraForwardDirection | Gets or sets the world camera forward direction.
Public property | CameraMode | Gets or sets CameraMode.
Public property | CameraRightDirection | Gets or sets the world camera right direction.
Public property | CameraRotationMode | Gets or sets CameraRotationMode.
Public property | CameraUpDirection | Gets or sets the world camera up direction.
 | CanPickAbortAction |
Public property | ChangeFieldOfViewCursor | Gets or sets the change fov cursor.
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | ColumnDefinitions | Gets a ColumnDefinitionCollection defined on this instance of Grid. (Inherited from Grid.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DimensionManipulateHandler | The dimension event handler.
Public property | Direct3DViewPortElement | Gets or sets reference to D3DImage element.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
 | DoubleClickStartedWith |
Public property | DXViewport |
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | Enabled | Gets or sets a value indicating whether Enabled.
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
 | FocusedPart |
 | FocusedPosition |
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | HasLogicalOrientationPublic | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
 | InteractionService |
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsPanEnabled | Gets or sets a value indicating whether IsPanEnabled.
 | IsPickActionInProgress |
Public property | IsRotationEnabled | Gets or sets a value indicating whether IsRotationEnabled.
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
 | IsSnapInContinuousMode |
 | IsSnapModeEnabled |
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | IsZoomEnabled | Gets or sets a value indicating whether IsZoomEnabled.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical children of this Grid. (Inherited from Grid.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | LogicalOrientationPublic | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Protected property | ManipulateViewModel |
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MultiPickHandler |
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | ObjectQuickMenuDisplayHandler |
Public property | ObjectRotateHandler | The object rotate event handler.
Public property | ObjectSelectionMode |
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | PanCursor | Gets or sets the pan cursor.
Public property | PanHandler | The pan event handler.
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | PickCursor | Gets or sets the rotate cursor.
Public property | PickHandler |
Public property | PlugPlayLogicalHandler | Logical plug and play event handler.
Public property | QuickCopyPasteHandler |
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | ReverseDpiScale |
Public property | RotateCursor | Gets or sets the rotate cursor.
Public property | RotateHandler |
Public property | RowDefinitions | Gets a RowDefinitionCollection defined on this instance of Grid. (Inherited from Grid.)
Public property | SelectParentHandler |
Public property | SetCenterOfInterestHandler | Set center of interest event handler.
Public property | ShowContextMenuHandler | Show context menu event handler.
Public property | ShowGridLines | Gets or sets a value that indicates whether grid lines are visible within this Grid. (Inherited from Grid.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Protected property | TeachContext |
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TranslateHandler | The translate event handler.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Viewport | Gets or sets Viewport.
Public property | Window |
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets a value that represents the total number of Visual children within this instance of Grid. (Inherited from Grid.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | ZoomCursor | Gets or sets the zoom cursor.
Public property | ZoomHandler |
Public property | ZoomRectangleCursor | Gets or sets the zoom rectangle cursor.
Top
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.ActiveViewport Property

HelperViewportActiveViewport Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IViewport ActiveViewport { get; set; }
public:
static property IViewport^ ActiveViewport {
    IViewport^ get ();
    void set (IViewport^ value);
}

Property Value

Type: IViewport
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.AnnotationManipulateHandler Property

HelperViewportAnnotationManipulateHandler Property

The annotation event handler.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AnnotationManipulateHandler AnnotationManipulateHandler { get; protected set; }
public:
property AnnotationManipulateHandler^ AnnotationManipulateHandler {
    AnnotationManipulateHandler^ get ();
    protected: void set (AnnotationManipulateHandler^ value);
}

Property Value

Type: AnnotationManipulateHandler
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.Application Property

HelperViewportApplication Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IApplication Application { get; }
public:
static property IApplication^ Application {
    IApplication^ get ();
}

Property Value

Type: IApplication
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.AreaSelectHandler Property

HelperViewportAreaSelectHandler Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AreaSelectHandler AreaSelectHandler { get; protected set; }
public:
property AreaSelectHandler^ AreaSelectHandler {
    AreaSelectHandler^ get ();
    protected: void set (AreaSelectHandler^ value);
}

Property Value

Type: AreaSelectHandler
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.CameraForwardDirection Property

HelperViewportCameraForwardDirection Property

Gets or sets the world camera forward direction.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3D CameraForwardDirection { get; set; }
public:
property Vector3D CameraForwardDirection {
    Vector3D get ();
    void set (Vector3D value);
}

Property Value

Type: Vector3D
The forward direction.
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.CameraMode Property

HelperViewportCameraMode Property

Gets or sets CameraMode.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CameraMode CameraMode { get; set; }
public:
property CameraMode CameraMode {
    CameraMode get ();
    void set (CameraMode value);
}

Property Value

Type: CameraMode
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.CameraRightDirection Property

HelperViewportCameraRightDirection Property

Gets or sets the world camera right direction.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3D CameraRightDirection { get; set; }
public:
property Vector3D CameraRightDirection {
    Vector3D get ();
    void set (Vector3D value);
}

Property Value

Type: Vector3D
The right direction.
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.CameraRotationMode Property

HelperViewportCameraRotationMode Property

Gets or sets CameraRotationMode.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CameraRotationMode CameraRotationMode { get; set; }
public:
property CameraRotationMode CameraRotationMode {
    CameraRotationMode get ();
    void set (CameraRotationMode value);
}

Property Value

Type: CameraRotationMode
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.CameraUpDirection Property

HelperViewportCameraUpDirection Property

Gets or sets the world camera up direction.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3D CameraUpDirection { get; set; }
public:
property Vector3D CameraUpDirection {
    Vector3D get ();
    void set (Vector3D value);
}

Property Value

Type: Vector3D
The up direction.
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.CanPickAbortAction Property

HelperViewportCanPickAbortAction Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool CanPickAbortAction { get; set; }
public:
static property bool CanPickAbortAction {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.ChangeFieldOfViewCursor Property

HelperViewportChangeFieldOfViewCursor Property

Gets or sets the change fov cursor.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Cursor ChangeFieldOfViewCursor { get; set; }
public:
property Cursor^ ChangeFieldOfViewCursor {
    Cursor^ get ();
    void set (Cursor^ value);
}

Property Value

Type: Cursor
The change fov cursor.
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.DimensionManipulateHandler Property

HelperViewportDimensionManipulateHandler Property

The dimension event handler.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DimensionManipulateHandler DimensionManipulateHandler { get; protected set; }
public:
property DimensionManipulateHandler^ DimensionManipulateHandler {
    DimensionManipulateHandler^ get ();
    protected: void set (DimensionManipulateHandler^ value);
}

Property Value

Type: DimensionManipulateHandler
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.Direct3DViewPortElement Property

HelperViewportDirect3DViewPortElement Property

Gets or sets reference to D3DImage element.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FrameworkElement Direct3DViewPortElement { get; set; }
public:
property FrameworkElement^ Direct3DViewPortElement {
    FrameworkElement^ get ();
    void set (FrameworkElement^ value);
}

Property Value

Type: FrameworkElement
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.DoubleClickStartedWith Property

HelperViewportDoubleClickStartedWith Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Object DoubleClickStartedWith { get; set; }
public:
static property Object^ DoubleClickStartedWith {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.DXViewport Property

HelperViewportDXViewport Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IViewport DXViewport { get; set; }
public:
property IViewport^ DXViewport {
    IViewport^ get ();
    void set (IViewport^ value);
}

Property Value

Type: IViewport
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.Enabled Property

HelperViewportEnabled Property

Gets or sets a value indicating whether Enabled.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Enabled { get; set; }
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.FocusedPart Property

HelperViewportFocusedPart Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Object FocusedPart { get; set; }
public:
static property Object^ FocusedPart {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.FocusedPosition Property

HelperViewportFocusedPosition Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Object FocusedPosition { get; set; }
public:
static property Object^ FocusedPosition {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.InteractionService Property

HelperViewportInteractionService Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IInteractionService InteractionService { get; }
public:
static property IInteractionService^ InteractionService {
    IInteractionService^ get ();
}

Property Value

Type: IInteractionService
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.IsPanEnabled Property

HelperViewportIsPanEnabled Property

Gets or sets a value indicating whether IsPanEnabled.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsPanEnabled { get; set; }
public:
property bool IsPanEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.IsPickActionInProgress Property

HelperViewportIsPickActionInProgress Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsPickActionInProgress { get; set; }
public:
static property bool IsPickActionInProgress {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.IsRotationEnabled Property

HelperViewportIsRotationEnabled Property

Gets or sets a value indicating whether IsRotationEnabled.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsRotationEnabled { get; set; }
public:
property bool IsRotationEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.IsSnapInContinuousMode Property

HelperViewportIsSnapInContinuousMode Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsSnapInContinuousMode { get; }
public:
static property bool IsSnapInContinuousMode {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.IsSnapModeEnabled Property

HelperViewportIsSnapModeEnabled Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsSnapModeEnabled { get; set; }
public:
static property bool IsSnapModeEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.IsZoomEnabled Property

HelperViewportIsZoomEnabled Property

Gets or sets a value indicating whether IsZoomEnabled.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsZoomEnabled { get; set; }
public:
property bool IsZoomEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.ManipulateViewModel Property

HelperViewportManipulateViewModel Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected IManipulateViewModel ManipulateViewModel { get; }
protected:
property IManipulateViewModel^ ManipulateViewModel {
    IManipulateViewModel^ get ();
}

Property Value

Type: IManipulateViewModel
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.MultiPickHandler Property

HelperViewportMultiPickHandler Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PickHandler MultiPickHandler { get; protected set; }
public:
property PickHandler^ MultiPickHandler {
    PickHandler^ get ();
    protected: void set (PickHandler^ value);
}

Property Value

Type: PickHandler
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.ObjectQuickMenuDisplayHandler Property

HelperViewportObjectQuickMenuDisplayHandler Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObjectQuickMenuDisplayHandler ObjectQuickMenuDisplayHandler { get; protected set; }
public:
property ObjectQuickMenuDisplayHandler^ ObjectQuickMenuDisplayHandler {
    ObjectQuickMenuDisplayHandler^ get ();
    protected: void set (ObjectQuickMenuDisplayHandler^ value);
}

Property Value

Type: ObjectQuickMenuDisplayHandler
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.ObjectRotateHandler Property

HelperViewportObjectRotateHandler Property

The object rotate event handler.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObjectRotateHandler ObjectRotateHandler { get; protected set; }
public:
property ObjectRotateHandler^ ObjectRotateHandler {
    ObjectRotateHandler^ get ();
    protected: void set (ObjectRotateHandler^ value);
}

Property Value

Type: ObjectRotateHandler
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.ObjectSelectionMode Property

HelperViewportObjectSelectionMode Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObjectSelectionMode ObjectSelectionMode { get; set; }
public:
property ObjectSelectionMode ObjectSelectionMode {
    ObjectSelectionMode get ();
    void set (ObjectSelectionMode value);
}

Property Value

Type: ObjectSelectionMode
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.PanCursor Property

HelperViewportPanCursor Property

Gets or sets the pan cursor.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Cursor PanCursor { get; set; }
public:
property Cursor^ PanCursor {
    Cursor^ get ();
    void set (Cursor^ value);
}

Property Value

Type: Cursor
The pan cursor.
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.PanHandler Property

HelperViewportPanHandler Property

The pan event handler.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PanHandler PanHandler { get; protected set; }
public:
property PanHandler^ PanHandler {
    PanHandler^ get ();
    protected: void set (PanHandler^ value);
}

Property Value

Type: PanHandler
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.PickCursor Property

HelperViewportPickCursor Property

Gets or sets the rotate cursor.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Cursor PickCursor { get; set; }
public:
property Cursor^ PickCursor {
    Cursor^ get ();
    void set (Cursor^ value);
}

Property Value

Type: Cursor
The rotate cursor.
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.PickHandler Property

HelperViewportPickHandler Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PickHandler PickHandler { get; protected set; }
public:
property PickHandler^ PickHandler {
    PickHandler^ get ();
    protected: void set (PickHandler^ value);
}

Property Value

Type: PickHandler
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.PlugPlayLogicalHandler Property

HelperViewportPlugPlayLogicalHandler Property

Logical plug and play event handler.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PlugPlayLogicalHandler PlugPlayLogicalHandler { get; protected set; }
public:
property PlugPlayLogicalHandler^ PlugPlayLogicalHandler {
    PlugPlayLogicalHandler^ get ();
    protected: void set (PlugPlayLogicalHandler^ value);
}

Property Value

Type: PlugPlayLogicalHandler
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.QuickCopyPasteHandler Property

HelperViewportQuickCopyPasteHandler Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public QuickCopyPasteHandler QuickCopyPasteHandler { get; protected set; }
public:
property QuickCopyPasteHandler^ QuickCopyPasteHandler {
    QuickCopyPasteHandler^ get ();
    protected: void set (QuickCopyPasteHandler^ value);
}

Property Value

Type: QuickCopyPasteHandler
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.ReverseDpiScale Property

HelperViewportReverseDpiScale Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double ReverseDpiScale { get; set; }
public:
property double ReverseDpiScale {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.RotateCursor Property

HelperViewportRotateCursor Property

Gets or sets the rotate cursor.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Cursor RotateCursor { get; set; }
public:
property Cursor^ RotateCursor {
    Cursor^ get ();
    void set (Cursor^ value);
}

Property Value

Type: Cursor
The rotate cursor.
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.RotateHandler Property

HelperViewportRotateHandler Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RotateHandler RotateHandler { get; protected set; }
public:
property RotateHandler^ RotateHandler {
    RotateHandler^ get ();
    protected: void set (RotateHandler^ value);
}

Property Value

Type: RotateHandler
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.SelectParentHandler Property

HelperViewportSelectParentHandler Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SelectParentHandler SelectParentHandler { get; protected set; }
public:
property SelectParentHandler^ SelectParentHandler {
    SelectParentHandler^ get ();
    protected: void set (SelectParentHandler^ value);
}

Property Value

Type: SelectParentHandler
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.SetCenterOfInterestHandler Property

HelperViewportSetCenterOfInterestHandler Property

Set center of interest event handler.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetCenterOfInterestHandler SetCenterOfInterestHandler { get; protected set; }
public:
property SetCenterOfInterestHandler^ SetCenterOfInterestHandler {
    SetCenterOfInterestHandler^ get ();
    protected: void set (SetCenterOfInterestHandler^ value);
}

Property Value

Type: SetCenterOfInterestHandler
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.ShowContextMenuHandler Property

HelperViewportShowContextMenuHandler Property

Show context menu event handler.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ShowContextMenuHandler ShowContextMenuHandler { get; protected set; }
public:
property ShowContextMenuHandler^ ShowContextMenuHandler {
    ShowContextMenuHandler^ get ();
    protected: void set (ShowContextMenuHandler^ value);
}

Property Value

Type: ShowContextMenuHandler
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.TeachContext Property

HelperViewportTeachContext Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected ITeachContext TeachContext { get; }
protected:
property ITeachContext^ TeachContext {
    ITeachContext^ get ();
}

Property Value

Type: ITeachContext
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.TranslateHandler Property

HelperViewportTranslateHandler Property

The translate event handler.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TranslateHandler TranslateHandler { get; protected set; }
public:
property TranslateHandler^ TranslateHandler {
    TranslateHandler^ get ();
    protected: void set (TranslateHandler^ value);
}

Property Value

Type: TranslateHandler
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.Viewport Property

HelperViewportViewport Property

Gets or sets Viewport.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Viewport3D Viewport { get; set; }
public:
property Viewport3D^ Viewport {
    Viewport3D^ get ();
    void set (Viewport3D^ value);
}

Property Value

Type: Viewport3D
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.Window Property

HelperViewportWindow Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IWindow3D Window { get; }
public:
property IWindow3D^ Window {
    IWindow3D^ get ();
}

Property Value

Type: IWindow3D
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.ZoomCursor Property

HelperViewportZoomCursor Property

Gets or sets the zoom cursor.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Cursor ZoomCursor { get; set; }
public:
property Cursor^ ZoomCursor {
    Cursor^ get ();
    void set (Cursor^ value);
}

Property Value

Type: Cursor
The zoom cursor.
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.ZoomHandler Property

HelperViewportZoomHandler Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ZoomHandler ZoomHandler { get; protected set; }
public:
property ZoomHandler^ ZoomHandler {
    ZoomHandler^ get ();
    protected: void set (ZoomHandler^ value);
}

Property Value

Type: ZoomHandler
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.ZoomRectangleCursor Property

HelperViewportZoomRectangleCursor Property

Gets or sets the zoom rectangle cursor.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Cursor ZoomRectangleCursor { get; set; }
public:
property Cursor^ ZoomRectangleCursor {
    Cursor^ get ();
    void set (Cursor^ value);
}

Property Value

Type: Cursor
The zoom rectangle cursor.
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport Methods

The HelperViewport type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddMouseListener |
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Arranges the content of a Grid element. (Inherited from Grid.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearMouseListeners |
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
 | ConsumeDoubleClick |
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
 | GetScreenSize(Size, Boolean) |
 | GetScreenSize(Double, Double, Boolean) |
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Gets the child Visual at the specified index position. (Inherited from Grid.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Measures the children of a Grid in anticipation of arranging them during the ArrangeOverride(Size) pass. (Inherited from Grid.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Processes Drop event. (Overrides UIElementOnDrop(DragEventArgs).)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture(MouseEventArgs) | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture(Object, MouseEventArgs) |
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Overrides UIElementOnManipulationDelta(ManipulationDeltaEventArgs).)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Overrides UIElementOnManipulationStarted(ManipulationStartedEventArgs).)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Overrides UIElementOnMouseDown(MouseButtonEventArgs).)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the visual children of a Grid element change. (Inherited from Grid.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
 | RaycastSceneEx |
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ResetCamera | The reset camera.
Public method | ResetCameraUpDirection | Resets the camera up direction.
 | RestorePnpMode |
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetSelectionCanvasNeeded |
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | ShouldSerializeColumnDefinitions | Returns true if ColumnDefinitionCollection associated with this instance of Grid is not empty. (Inherited from Grid.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeRowDefinitions | Returns true if RowDefinitionCollection associated with this instance of Grid is not empty. (Inherited from Grid.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
 | TryPnpOne |
 | TrySelectAdded |
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateCamera |
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Zoom | Zooms by the specified delta value.
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.AddMouseListener Method

HelperViewportAddMouseListener Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void AddMouseListener(
    MouseGestureHandler handler
)
public:
void AddMouseListener(
    MouseGestureHandler^ handler
)

Parameters

handler
Type: VisualComponents.UX.InputMouseGestureHandler
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.ClearMouseListeners Method

HelperViewportClearMouseListeners Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ClearMouseListeners()
public:
void ClearMouseListeners()
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.ConsumeDoubleClick Method

HelperViewportConsumeDoubleClick Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool ConsumeDoubleClick(
    MouseButtonEventArgs e
)
public:
static bool ConsumeDoubleClick(
    MouseButtonEventArgs^ e
)

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Input.HelperViewport.ConsumeDoubleClick(System.Windows.Input.MouseButtonEventArgs)"]

See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.GetScreenSize Method

HelperViewportGetScreenSize Method

Overload List
Name | Description
GetScreenSize(Size, Boolean) |
GetScreenSize(Double, Double, Boolean) |
Top
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.GetScreenSize Method (Size, Boolean)

HelperViewportGetScreenSize Method (Size, Boolean)

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Size GetScreenSize(
    Size size,
    bool round = true
)
public:
static Size GetScreenSize(
    Size size,
    bool round = true
)

Parameters

size
Type: System.WindowsSize
round (Optional)
Type: SystemBoolean

Return Value

Type: Size

[Missing <returns> documentation for "M:VisualComponents.UX.Input.HelperViewport.GetScreenSize(System.Windows.Size,System.Boolean)"]

See Also

Reference

HelperViewport Class
GetScreenSize Overload
VisualComponents.UX.Input Namespace


HelperViewport.GetScreenSize Method (Double, Double, Boolean)

HelperViewportGetScreenSize Method (Double, Double, Boolean)

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Size GetScreenSize(
    double width,
    double height,
    bool round = true
)
public:
static Size GetScreenSize(
    double width,
    double height,
    bool round = true
)

Parameters

width
Type: SystemDouble
height
Type: SystemDouble
round (Optional)
Type: SystemBoolean

Return Value

Type: Size

[Missing <returns> documentation for "M:VisualComponents.UX.Input.HelperViewport.GetScreenSize(System.Double,System.Double,System.Boolean)"]

See Also

Reference

HelperViewport Class
GetScreenSize Overload
VisualComponents.UX.Input Namespace


HelperViewport.OnDrop Method

HelperViewportOnDrop Method

Processes Drop event.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnDrop(
    DragEventArgs e
)
protected:
virtual void OnDrop(
    DragEventArgs^ e
) override

Parameters

e
Type: System.WindowsDragEventArgs
Remarks
Note: If the process is running elevated while UAC is enabled Drag & Drop does not work.
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.OnLostMouseCapture Method

HelperViewportOnLostMouseCapture Method

Overload List
 | Name | Description
Protected method | OnLostMouseCapture(MouseEventArgs) | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture(Object, MouseEventArgs) |
Top
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.OnLostMouseCapture Method (Object, MouseEventArgs)

HelperViewportOnLostMouseCapture Method (Object, MouseEventArgs)

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void OnLostMouseCapture(
    Object sender,
    MouseEventArgs e
)
protected:
virtual void OnLostMouseCapture(
    Object^ sender,
    MouseEventArgs^ e
)

Parameters

sender
Type: SystemObject
e
Type: System.Windows.InputMouseEventArgs
See Also

Reference

HelperViewport Class
OnLostMouseCapture Overload
VisualComponents.UX.Input Namespace


HelperViewport.OnManipulationDelta Method

HelperViewportOnManipulationDelta Method

Called when the ManipulationDelta event occurs.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnManipulationDelta(
    ManipulationDeltaEventArgs e
)
protected:
virtual void OnManipulationDelta(
    ManipulationDeltaEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputManipulationDeltaEventArgs
The data for the event.
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.OnManipulationStarted Method

HelperViewportOnManipulationStarted Method

Called when the ManipulationStarted event occurs.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnManipulationStarted(
    ManipulationStartedEventArgs e
)
protected:
virtual void OnManipulationStarted(
    ManipulationStartedEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputManipulationStartedEventArgs
The data for the event.
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.OnMouseDown Method

HelperViewportOnMouseDown Method

Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnMouseDown(
    MouseButtonEventArgs e
)
protected:
virtual void OnMouseDown(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
The MouseButtonEventArgs that contains the event data. This event data reports details about the mouse button that was pressed and the handled state.
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.RaycastSceneEx Method

HelperViewportRaycastSceneEx Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Object RaycastSceneEx(
    int type,
    Point mousePoint,
    ref bool aborted,
    ref double dist_to_ray,
    double snapThreshold
)
public:
static Object^ RaycastSceneEx(
    int type,
    Point mousePoint,
    bool% aborted,
    double% dist_to_ray,
    double snapThreshold
)

Parameters

type
Type: SystemInt32
mousePoint
Type: System.WindowsPoint
aborted
Type: SystemBoolean
dist_to_ray
Type: SystemDouble
snapThreshold
Type: SystemDouble

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Input.HelperViewport.RaycastSceneEx(System.Int32,System.Windows.Point,System.Boolean@,System.Double@,System.Double)"]

See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.ResetCamera Method

HelperViewportResetCamera Method

The reset camera.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ResetCamera()
public:
void ResetCamera()
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.ResetCameraUpDirection Method

HelperViewportResetCameraUpDirection Method

Resets the camera up direction.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ResetCameraUpDirection()
public:
void ResetCameraUpDirection()
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.RestorePnpMode Method

HelperViewportRestorePnpMode Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void RestorePnpMode()
public:
static void RestorePnpMode()
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.SetSelectionCanvasNeeded Method

HelperViewportSetSelectionCanvasNeeded Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetSelectionCanvasNeeded(
    bool needed
)
public:
void SetSelectionCanvasNeeded(
    bool needed
)

Parameters

needed
Type: SystemBoolean
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.TryPnpOne Method

HelperViewportTryPnpOne Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void TryPnpOne(
    ISimComponent component
)
public:
static void TryPnpOne(
    ISimComponent^ component
)

Parameters

component
Type: VisualComponents.Create3DISimComponent
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.TrySelectAdded Method

HelperViewportTrySelectAdded Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void TrySelectAdded(
    Dictionary<ISimComponent, int> lastComponents,
    bool doPnp
)
public:
static void TrySelectAdded(
    Dictionary<ISimComponent^, int>^ lastComponents,
    bool doPnp
)

Parameters

lastComponents
Type: System.Collections.GenericDictionaryISimComponent, Int32
doPnp
Type: SystemBoolean
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.UpdateCamera Method

HelperViewportUpdateCamera Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void UpdateCamera()
public:
void UpdateCamera()
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.Zoom Method

HelperViewportZoom Method

Zooms by the specified delta value.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Zoom(
    double delta
)
public:
void Zoom(
    double delta
)

Parameters

delta
Type: SystemDouble
The delta value.
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport Events

The HelperViewport type exposes the following members.

Events
 | Name | Description
Public event | CameraChanged |
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Public event | ViewportMouseDown | Additional functionality for MouseDown event, happens when this class handles PreviewMouseDown
Top
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.CameraChanged Event

HelperViewportCameraChanged Event

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler CameraChanged
public:
 event EventHandler^ CameraChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.ViewportMouseDown Event

HelperViewportViewportMouseDown Event

Additional functionality for MouseDown event, happens when this class handles PreviewMouseDown

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event MouseButtonEventHandler ViewportMouseDown
public:
 event MouseButtonEventHandler^ ViewportMouseDown {
    void add (MouseButtonEventHandler^ value);
    void remove (MouseButtonEventHandler^ value);
}

Value

Type: System.Windows.InputMouseButtonEventHandler
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport Fields

The HelperViewport type exposes the following members.

Fields
 | Name | Description
 | ActivePersistentSnapAction |
 | AnnotationInteractCommand | The annotation manipulation command.
 | AreaSelectCommand | The area select command.
Public field | areaSelectionRectangle |
 | BackViewCommand | The back view command.
 | BottomViewCommand | The bottom view command.
 | CameraForwardDirectionProperty | Describes the forward direction of the world camera.
 | CameraModeProperty | The camera mode property.
 | CameraRightDirectionProperty | Describes the right direction of the world camera.
 | CameraRotationModeProperty | The camera rotation mode property.
 | CameraUpDirectionProperty | Describes the up direction of the world camera.
 | ChangeFieldOfViewCursorProperty | The change fov cursor property.
 | ClickPixelTolerance |
 | DimensionInteractCommand | The dimension manipulation command.
 | Direct3DViewPortElementProperty | The Direct3DViewPortElementProperty property.
 | EnabledProperty | The enabled property.
Public field | exportAreaSelectionRectangle |
 | FrontViewCommand | The front view command.
 | IsPanEnabledProperty | The is pan enabled property.
 | IsRotationEnabledProperty | The is rotation enabled property.
 | IsZoomEnabledProperty | The is zoom enabled property.
Public field | lassoSelectionPolyline |
 | LeftViewCommand | The left view command.
 | MultiselectPickCommand | The multiselectpick command.
 | ObjectRotateCommand | The object rotate command.
 | ObjectSelectionModeProperty | The rotate cursor property.
 | OnModifierChange |
 | OrbitCommand | The camera rotate command.
 | PanCommand | The pan command.
 | PanCursorProperty | The pan cursor property.
 | PickCommand | The pick command.
 | PickCursorProperty | The rotate cursor property.
 | QuickCopyPasteCommand | The quick copy/paste with auto pnp command.
 | RightViewCommand | The right view command.
 | RotateCursorProperty | The rotate cursor property.
Public field | SelectionCanvas |
 | SelectParentCommand |
 | SetCenterOfInterestedCommand | Set center of interested command
 | ShowContextMenuCommand | The area show context menu command.
 | TopViewCommand | The top view command.
 | TranslateCommand | The translate command.
 | ViewportProperty | The viewport property.
 | ZoomCommand | The zoom command.
 | ZoomCursorProperty | The zoom cursor property.
 | ZoomRectangleCursorProperty | The zoom rectangle cursor property.
Top
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.ActivePersistentSnapAction Field

HelperViewportActivePersistentSnapAction Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static SnapAction ActivePersistentSnapAction
public:
static SnapAction^ ActivePersistentSnapAction

Field Value

Type: SnapAction
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.AnnotationInteractCommand Field

HelperViewportAnnotationInteractCommand Field

The annotation manipulation command.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static RoutedCommand AnnotationInteractCommand
public:
static RoutedCommand^ AnnotationInteractCommand

Field Value

Type: RoutedCommand
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.AreaSelectCommand Field

HelperViewportAreaSelectCommand Field

The area select command.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static RoutedCommand AreaSelectCommand
public:
static RoutedCommand^ AreaSelectCommand

Field Value

Type: RoutedCommand
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.areaSelectionRectangle Field

HelperViewportareaSelectionRectangle Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Rectangle areaSelectionRectangle
public:
Rectangle^ areaSelectionRectangle

Field Value

Type: Rectangle
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.BackViewCommand Field

HelperViewportBackViewCommand Field

The back view command.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static RoutedCommand BackViewCommand
public:
static RoutedCommand^ BackViewCommand

Field Value

Type: RoutedCommand
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.BottomViewCommand Field

HelperViewportBottomViewCommand Field

The bottom view command.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static RoutedCommand BottomViewCommand
public:
static RoutedCommand^ BottomViewCommand

Field Value

Type: RoutedCommand
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.CameraForwardDirectionProperty Field

HelperViewportCameraForwardDirectionProperty Field

Describes the forward direction of the world camera.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty CameraForwardDirectionProperty
public:
static initonly DependencyProperty^ CameraForwardDirectionProperty

Field Value

Type: DependencyProperty
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.CameraModeProperty Field

HelperViewportCameraModeProperty Field

The camera mode property.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty CameraModeProperty
public:
static initonly DependencyProperty^ CameraModeProperty

Field Value

Type: DependencyProperty
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.CameraRightDirectionProperty Field

HelperViewportCameraRightDirectionProperty Field

Describes the right direction of the world camera.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty CameraRightDirectionProperty
public:
static initonly DependencyProperty^ CameraRightDirectionProperty

Field Value

Type: DependencyProperty
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.CameraRotationModeProperty Field

HelperViewportCameraRotationModeProperty Field

The camera rotation mode property.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty CameraRotationModeProperty
public:
static initonly DependencyProperty^ CameraRotationModeProperty

Field Value

Type: DependencyProperty
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.CameraUpDirectionProperty Field

HelperViewportCameraUpDirectionProperty Field

Describes the up direction of the world camera.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty CameraUpDirectionProperty
public:
static initonly DependencyProperty^ CameraUpDirectionProperty

Field Value

Type: DependencyProperty
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.ChangeFieldOfViewCursorProperty Field

HelperViewportChangeFieldOfViewCursorProperty Field

The change fov cursor property.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ChangeFieldOfViewCursorProperty
public:
static initonly DependencyProperty^ ChangeFieldOfViewCursorProperty

Field Value

Type: DependencyProperty
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.ClickPixelTolerance Field

HelperViewportClickPixelTolerance Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static double ClickPixelTolerance
public:
static double ClickPixelTolerance

Field Value

Type: Double
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.DimensionInteractCommand Field

HelperViewportDimensionInteractCommand Field

The dimension manipulation command.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static RoutedCommand DimensionInteractCommand
public:
static RoutedCommand^ DimensionInteractCommand

Field Value

Type: RoutedCommand
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.Direct3DViewPortElementProperty Field

HelperViewportDirect3DViewPortElementProperty Field

The Direct3DViewPortElementProperty property.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty Direct3DViewPortElementProperty
public:
static initonly DependencyProperty^ Direct3DViewPortElementProperty

Field Value

Type: DependencyProperty
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.EnabledProperty Field

HelperViewportEnabledProperty Field

The enabled property.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty EnabledProperty
public:
static initonly DependencyProperty^ EnabledProperty

Field Value

Type: DependencyProperty
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.exportAreaSelectionRectangle Field

HelperViewportexportAreaSelectionRectangle Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Rectangle exportAreaSelectionRectangle
public:
Rectangle^ exportAreaSelectionRectangle

Field Value

Type: Rectangle
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.FrontViewCommand Field

HelperViewportFrontViewCommand Field

The front view command.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static RoutedCommand FrontViewCommand
public:
static RoutedCommand^ FrontViewCommand

Field Value

Type: RoutedCommand
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.IsPanEnabledProperty Field

HelperViewportIsPanEnabledProperty Field

The is pan enabled property.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsPanEnabledProperty
public:
static initonly DependencyProperty^ IsPanEnabledProperty

Field Value

Type: DependencyProperty
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.IsRotationEnabledProperty Field

HelperViewportIsRotationEnabledProperty Field

The is rotation enabled property.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsRotationEnabledProperty
public:
static initonly DependencyProperty^ IsRotationEnabledProperty

Field Value

Type: DependencyProperty
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.IsZoomEnabledProperty Field

HelperViewportIsZoomEnabledProperty Field

The is zoom enabled property.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsZoomEnabledProperty
public:
static initonly DependencyProperty^ IsZoomEnabledProperty

Field Value

Type: DependencyProperty
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.lassoSelectionPolyline Field

HelperViewportlassoSelectionPolyline Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Polyline lassoSelectionPolyline
public:
Polyline^ lassoSelectionPolyline

Field Value

Type: Polyline
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.LeftViewCommand Field

HelperViewportLeftViewCommand Field

The left view command.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static RoutedCommand LeftViewCommand
public:
static RoutedCommand^ LeftViewCommand

Field Value

Type: RoutedCommand
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.MultiselectPickCommand Field

HelperViewportMultiselectPickCommand Field

The multiselectpick command.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static RoutedCommand MultiselectPickCommand
public:
static RoutedCommand^ MultiselectPickCommand

Field Value

Type: RoutedCommand
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.ObjectRotateCommand Field

HelperViewportObjectRotateCommand Field

The object rotate command.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static RoutedCommand ObjectRotateCommand
public:
static RoutedCommand^ ObjectRotateCommand

Field Value

Type: RoutedCommand
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.ObjectSelectionModeProperty Field

HelperViewportObjectSelectionModeProperty Field

The rotate cursor property.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ObjectSelectionModeProperty
public:
static initonly DependencyProperty^ ObjectSelectionModeProperty

Field Value

Type: DependencyProperty
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.OnModifierChange Field

HelperViewportOnModifierChange Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Action<KeyEventArgs> OnModifierChange
public:
static Action<KeyEventArgs^>^ OnModifierChange

Field Value

Type: ActionKeyEventArgs
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.OrbitCommand Field

HelperViewportOrbitCommand Field

The camera rotate command.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static RoutedCommand OrbitCommand
public:
static RoutedCommand^ OrbitCommand

Field Value

Type: RoutedCommand
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.PanCommand Field

HelperViewportPanCommand Field

The pan command.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static RoutedCommand PanCommand
public:
static RoutedCommand^ PanCommand

Field Value

Type: RoutedCommand
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.PanCursorProperty Field

HelperViewportPanCursorProperty Field

The pan cursor property.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty PanCursorProperty
public:
static initonly DependencyProperty^ PanCursorProperty

Field Value

Type: DependencyProperty
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.PickCommand Field

HelperViewportPickCommand Field

The pick command.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static RoutedCommand PickCommand
public:
static RoutedCommand^ PickCommand

Field Value

Type: RoutedCommand
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.PickCursorProperty Field

HelperViewportPickCursorProperty Field

The rotate cursor property.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty PickCursorProperty
public:
static initonly DependencyProperty^ PickCursorProperty

Field Value

Type: DependencyProperty
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.QuickCopyPasteCommand Field

HelperViewportQuickCopyPasteCommand Field

The quick copy/paste with auto pnp command.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static RoutedCommand QuickCopyPasteCommand
public:
static RoutedCommand^ QuickCopyPasteCommand

Field Value

Type: RoutedCommand
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.RightViewCommand Field

HelperViewportRightViewCommand Field

The right view command.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static RoutedCommand RightViewCommand
public:
static RoutedCommand^ RightViewCommand

Field Value

Type: RoutedCommand
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.RotateCursorProperty Field

HelperViewportRotateCursorProperty Field

The rotate cursor property.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty RotateCursorProperty
public:
static initonly DependencyProperty^ RotateCursorProperty

Field Value

Type: DependencyProperty
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.SelectionCanvas Field

HelperViewportSelectionCanvas Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Canvas SelectionCanvas
public:
Canvas^ SelectionCanvas

Field Value

Type: Canvas
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.SelectParentCommand Field

HelperViewportSelectParentCommand Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static RoutedCommand SelectParentCommand
public:
static RoutedCommand^ SelectParentCommand

Field Value

Type: RoutedCommand
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.SetCenterOfInterestedCommand Field

HelperViewportSetCenterOfInterestedCommand Field

Set center of interested command

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static RoutedCommand SetCenterOfInterestedCommand
public:
static RoutedCommand^ SetCenterOfInterestedCommand

Field Value

Type: RoutedCommand
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.ShowContextMenuCommand Field

HelperViewportShowContextMenuCommand Field

The area show context menu command.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static RoutedCommand ShowContextMenuCommand
public:
static RoutedCommand^ ShowContextMenuCommand

Field Value

Type: RoutedCommand
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.TopViewCommand Field

HelperViewportTopViewCommand Field

The top view command.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static RoutedCommand TopViewCommand
public:
static RoutedCommand^ TopViewCommand

Field Value

Type: RoutedCommand
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.TranslateCommand Field

HelperViewportTranslateCommand Field

The translate command.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static RoutedCommand TranslateCommand
public:
static RoutedCommand^ TranslateCommand

Field Value

Type: RoutedCommand
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.ViewportProperty Field

HelperViewportViewportProperty Field

The viewport property.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ViewportProperty
public:
static initonly DependencyProperty^ ViewportProperty

Field Value

Type: DependencyProperty
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.ZoomCommand Field

HelperViewportZoomCommand Field

The zoom command.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static RoutedCommand ZoomCommand
public:
static RoutedCommand^ ZoomCommand

Field Value

Type: RoutedCommand
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.ZoomCursorProperty Field

HelperViewportZoomCursorProperty Field

The zoom cursor property.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ZoomCursorProperty
public:
static initonly DependencyProperty^ ZoomCursorProperty

Field Value

Type: DependencyProperty
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.ZoomRectangleCursorProperty Field

HelperViewportZoomRectangleCursorProperty Field

The zoom rectangle cursor property.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ZoomRectangleCursorProperty
public:
static initonly DependencyProperty^ ZoomRectangleCursorProperty

Field Value

Type: DependencyProperty
See Also

Reference

HelperViewport Class
VisualComponents.UX.Input Namespace


HelperViewport.InteractiveObject Class

HelperViewportInteractiveObject Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.InputHelperViewportInteractiveObject

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class InteractiveObject
public ref class InteractiveObject

The HelperViewportInteractiveObject type exposes the following members.

Constructors
 | Name | Description
Public method | HelperViewportInteractiveObject | Initializes a new instance of the HelperViewportInteractiveObject class
Top
Properties
 | Name | Description
Public property | Reference |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


HelperViewport.InteractiveObject Constructor

HelperViewportInteractiveObject Constructor

Initializes a new instance of the HelperViewportInteractiveObject class

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InteractiveObject()
public:
InteractiveObject()
See Also

Reference

HelperViewportInteractiveObject Class
VisualComponents.UX.Input Namespace


InteractiveObject Properties

The HelperViewportInteractiveObject type exposes the following members.

Properties
 | Name | Description
Public property | Reference |
Top
See Also

Reference

HelperViewportInteractiveObject Class
VisualComponents.UX.Input Namespace


HelperViewport.InteractiveObject.Reference Property

HelperViewportInteractiveObjectReference Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Reference { get; set; }
public:
property Object^ Reference {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

HelperViewportInteractiveObject Class
VisualComponents.UX.Input Namespace


InteractiveObject Methods

The HelperViewportInteractiveObject type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

HelperViewportInteractiveObject Class
VisualComponents.UX.Input Namespace


InputBindingTrigger Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.WindowsFreezable
System.Windows.Media.AnimationAnimatable
TriggerBase
TriggerBaseFrameworkElement
VisualComponents.UX.InputInputBindingTrigger

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class InputBindingTrigger : TriggerBase<FrameworkElement>,
    ICommand
public ref class InputBindingTrigger : public TriggerBase<FrameworkElement^>,
    ICommand

The InputBindingTrigger type exposes the following members.

Constructors
 | Name | Description
Public method | InputBindingTrigger | Initializes a new instance of the InputBindingTrigger class
Top
Properties
 | Name | Description
Public property | Actions | (Inherited from TriggerBase.)
Protected property | AssociatedObject | (Inherited from TriggerBaseFrameworkElement.)
Protected property | AssociatedObjectTypeConstraint | (Inherited from TriggerBaseFrameworkElement.)
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Inherited from Animatable.)
Public property | InputBinding |
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Top
Methods
 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | Attach | (Inherited from TriggerBase.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | CanExecute |
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of this Animatable, making deep copies of this object's values. When copying this object's dependency properties, this method copies resource references and data bindings (but they might no longer resolve) but not animations or their current values. (Inherited from Animatable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | (Inherited from TriggerBase.)
Public method | Detach | (Inherited from TriggerBase.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Public method | Execute |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to . (Inherited from Freezable.)
Protected method | FreezeCore | Makes this Animatable object unmodifiable or determines whether it can be made unmodifiable. (Inherited from Animatable.)
Public method | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Inherited from Animatable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvokeActions | (Inherited from TriggerBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttached | (Overrides TriggerBase.OnAttached.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnDetaching | (Inherited from TriggerBase.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
Events
 | Name | Description
Public event | CanExecuteChanged |
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Public event | PreviewInvoke | (Inherited from TriggerBase.)
Top
Fields
Name | Description
InputBindingProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


InputBindingTrigger Constructor

Initializes a new instance of the InputBindingTrigger class

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InputBindingTrigger()
public:
InputBindingTrigger()
See Also

Reference

InputBindingTrigger Class
VisualComponents.UX.Input Namespace


InputBindingTrigger Properties

The InputBindingTrigger type exposes the following members.

Properties
 | Name | Description
Public property | Actions | (Inherited from TriggerBase.)
Protected property | AssociatedObject | (Inherited from TriggerBaseFrameworkElement.)
Protected property | AssociatedObjectTypeConstraint | (Inherited from TriggerBaseFrameworkElement.)
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Inherited from Animatable.)
Public property | InputBinding |
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Top
See Also

Reference

InputBindingTrigger Class
VisualComponents.UX.Input Namespace


InputBindingTrigger.InputBinding Property

InputBindingTriggerInputBinding Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InputBinding InputBinding { get; set; }
public:
property InputBinding^ InputBinding {
    InputBinding^ get ();
    void set (InputBinding^ value);
}

Property Value

Type: InputBinding
See Also

Reference

InputBindingTrigger Class
VisualComponents.UX.Input Namespace


InputBindingTrigger Methods

The InputBindingTrigger type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | Attach | (Inherited from TriggerBase.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | CanExecute |
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of this Animatable, making deep copies of this object's values. When copying this object's dependency properties, this method copies resource references and data bindings (but they might no longer resolve) but not animations or their current values. (Inherited from Animatable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | (Inherited from TriggerBase.)
Public method | Detach | (Inherited from TriggerBase.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Public method | Execute |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to . (Inherited from Freezable.)
Protected method | FreezeCore | Makes this Animatable object unmodifiable or determines whether it can be made unmodifiable. (Inherited from Animatable.)
Public method | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Inherited from Animatable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvokeActions | (Inherited from TriggerBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttached | (Overrides TriggerBase.OnAttached.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnDetaching | (Inherited from TriggerBase.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

InputBindingTrigger Class
VisualComponents.UX.Input Namespace


InputBindingTrigger.CanExecute Method

InputBindingTriggerCanExecute Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanExecute(
    Object parameter
)
public:
virtual bool CanExecute(
    Object^ parameter
) sealed

Parameters

parameter
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Input.InputBindingTrigger.CanExecute(System.Object)"]

Implements

ICommandCanExecute(Object)
See Also

Reference

InputBindingTrigger Class
VisualComponents.UX.Input Namespace


InputBindingTrigger.Execute Method

InputBindingTriggerExecute Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    Object parameter
)
public:
virtual void Execute(
    Object^ parameter
) sealed

Parameters

parameter
Type: SystemObject

Implements

ICommandExecute(Object)
See Also

Reference

InputBindingTrigger Class
VisualComponents.UX.Input Namespace


InputBindingTrigger.OnAttached Method

InputBindingTriggerOnAttached Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnAttached()
protected:
virtual void OnAttached() override
See Also

Reference

InputBindingTrigger Class
VisualComponents.UX.Input Namespace


InputBindingTrigger Events

The InputBindingTrigger type exposes the following members.

Events
 | Name | Description
Public event | CanExecuteChanged |
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Public event | PreviewInvoke | (Inherited from TriggerBase.)
Top
See Also

Reference

InputBindingTrigger Class
VisualComponents.UX.Input Namespace


InputBindingTrigger.CanExecuteChanged Event

InputBindingTriggerCanExecuteChanged Event

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler CanExecuteChanged
public:
virtual  event EventHandler^ CanExecuteChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

ICommandCanExecuteChanged
See Also

Reference

InputBindingTrigger Class
VisualComponents.UX.Input Namespace


InputBindingTrigger Fields

The InputBindingTrigger type exposes the following members.

Fields
Name | Description
InputBindingProperty |
Top
See Also

Reference

InputBindingTrigger Class
VisualComponents.UX.Input Namespace


InputBindingTrigger.InputBindingProperty Field

InputBindingTriggerInputBindingProperty Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty InputBindingProperty
public:
static initonly DependencyProperty^ InputBindingProperty

Field Value

Type: DependencyProperty
See Also

Reference

InputBindingTrigger Class
VisualComponents.UX.Input Namespace


InputBindingTriggerEx Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.InputInputBindingTriggerEx

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class InputBindingTriggerEx : ICommand
public ref class InputBindingTriggerEx sealed : ICommand

The InputBindingTriggerEx type exposes the following members.

Constructors
 | Name | Description
Public method | InputBindingTriggerEx | Initializes a new instance of the InputBindingTriggerEx class
Top
Properties
 | Name | Description
Public property | Action |
Public property | MenuItem |
Public property | Method |
Top
Methods
 | Name | Description
Public method | CanExecute |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CanExecuteChanged |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


InputBindingTriggerEx Constructor

Initializes a new instance of the InputBindingTriggerEx class

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InputBindingTriggerEx()
public:
InputBindingTriggerEx()
See Also

Reference

InputBindingTriggerEx Class
VisualComponents.UX.Input Namespace


InputBindingTriggerEx Properties

The InputBindingTriggerEx type exposes the following members.

Properties
 | Name | Description
Public property | Action |
Public property | MenuItem |
Public property | Method |
Top
See Also

Reference

InputBindingTriggerEx Class
VisualComponents.UX.Input Namespace


InputBindingTriggerEx.Action Property

InputBindingTriggerExAction Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IActionItem Action { get; set; }
public:
property IActionItem^ Action {
    IActionItem^ get ();
    void set (IActionItem^ value);
}

Property Value

Type: IActionItem
See Also

Reference

InputBindingTriggerEx Class
VisualComponents.UX.Input Namespace


InputBindingTriggerEx.MenuItem Property

InputBindingTriggerExMenuItem Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MenuItemBase MenuItem { get; set; }
public:
property MenuItemBase^ MenuItem {
    MenuItemBase^ get ();
    void set (MenuItemBase^ value);
}

Property Value

Type: MenuItemBase
See Also

Reference

InputBindingTriggerEx Class
VisualComponents.UX.Input Namespace


InputBindingTriggerEx.Method Property

InputBindingTriggerExMethod Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MethodInfo Method { get; set; }
public:
property MethodInfo^ Method {
    MethodInfo^ get ();
    void set (MethodInfo^ value);
}

Property Value

Type: MethodInfo
See Also

Reference

InputBindingTriggerEx Class
VisualComponents.UX.Input Namespace


InputBindingTriggerEx Methods

The InputBindingTriggerEx type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

InputBindingTriggerEx Class
VisualComponents.UX.Input Namespace


InputBindingTriggerEx.CanExecute Method

InputBindingTriggerExCanExecute Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanExecute(
    Object parameter
)
public:
virtual bool CanExecute(
    Object^ parameter
) sealed

Parameters

parameter
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Input.InputBindingTriggerEx.CanExecute(System.Object)"]

Implements

ICommandCanExecute(Object)
See Also

Reference

InputBindingTriggerEx Class
VisualComponents.UX.Input Namespace


InputBindingTriggerEx.Execute Method

InputBindingTriggerExExecute Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    Object parameter
)
public:
virtual void Execute(
    Object^ parameter
) sealed

Parameters

parameter
Type: SystemObject

Implements

ICommandExecute(Object)
See Also

Reference

InputBindingTriggerEx Class
VisualComponents.UX.Input Namespace


InputBindingTriggerEx Events

The InputBindingTriggerEx type exposes the following members.

Events
 | Name | Description
Public event | CanExecuteChanged |
Top
See Also

Reference

InputBindingTriggerEx Class
VisualComponents.UX.Input Namespace


InputBindingTriggerEx.CanExecuteChanged Event

InputBindingTriggerExCanExecuteChanged Event

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler CanExecuteChanged
public:
virtual  event EventHandler^ CanExecuteChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

ICommandCanExecuteChanged
See Also

Reference

InputBindingTriggerEx Class
VisualComponents.UX.Input Namespace


ManipulationEventArgs Class

Provides data for the manipulation events.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.InputManipulationEventArgs

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ManipulationEventArgs
public ref class ManipulationEventArgs

The ManipulationEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ManipulationEventArgs | Initializes a new instance of the ManipulationEventArgs class.
Top
Properties
 | Name | Description
Public property | BoundaryPointList |
Public property | CurrentPosition | Gets or sets the current position.
Public property | Timestamp |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


ManipulationEventArgs Constructor

Initializes a new instance of the ManipulationEventArgs class.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ManipulationEventArgs(
    Point currentPosition
)
public:
ManipulationEventArgs(
    Point currentPosition
)

Parameters

currentPosition
Type: System.WindowsPoint
The current position.
See Also

Reference

ManipulationEventArgs Class
VisualComponents.UX.Input Namespace


ManipulationEventArgs Properties

The ManipulationEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | BoundaryPointList |
Public property | CurrentPosition | Gets or sets the current position.
Public property | Timestamp |
Top
See Also

Reference

ManipulationEventArgs Class
VisualComponents.UX.Input Namespace


ManipulationEventArgs.BoundaryPointList Property

ManipulationEventArgsBoundaryPointList Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<Point> BoundaryPointList { get; set; }
public:
property List<Point>^ BoundaryPointList {
    List<Point>^ get ();
    void set (List<Point>^ value);
}

Property Value

Type: ListPoint
See Also

Reference

ManipulationEventArgs Class
VisualComponents.UX.Input Namespace


ManipulationEventArgs.CurrentPosition Property

ManipulationEventArgsCurrentPosition Property

Gets or sets the current position.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Point CurrentPosition { get; }
public:
property Point CurrentPosition {
    Point get ();
}

Property Value

Type: Point
The current position.
See Also

Reference

ManipulationEventArgs Class
VisualComponents.UX.Input Namespace


ManipulationEventArgs.Timestamp Property

ManipulationEventArgsTimestamp Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<int> Timestamp { get; set; }
public:
property Nullable<int> Timestamp {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Property Value

Type: NullableInt32
See Also

Reference

ManipulationEventArgs Class
VisualComponents.UX.Input Namespace


ManipulationEventArgs Methods

The ManipulationEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ManipulationEventArgs Class
VisualComponents.UX.Input Namespace


MouseGestureHandler Class

An abstract base class for the mouse gesture handlers.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.InputMouseGestureHandler
More...

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract class MouseGestureHandler
public ref class MouseGestureHandler abstract

The MouseGestureHandler type exposes the following members.

Constructors
 | Name | Description
Protected method | MouseGestureHandler | Initializes a new instance of the MouseGestureHandler class.
Top
Properties
 | Name | Description
Protected property | Application |
Protected property | Camera | Gets the camera.
Protected property | CameraMode | Gets the camera mode.
Protected property | Controller | Gets or sets the controller.
Protected property | EventMng |
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler.
Protected property | LastPoint | Gets or sets the last point (2D screen coordinates).
Protected property | LastPoint3D | Gets or sets the last point (3D world coordinates).
Protected property | ManipulateViewModel |
Protected property | ManipulationWatch | Gets or sets the manipulation watch.
Protected property | MouseDownNearestPoint3D | Gets or sets the mouse down point at the nearest hit element (3D world coordinates).
Protected property | MouseDownPoint | Gets or sets the mouse down point (2D screen coordinates).
Protected property | MouseDownPoint3D | Gets or sets the mouse down point (3D world coordinates).
Protected property | ObjectSelectionMode |
Public property | Origin | Gets Origin.
Protected property | RenderingService |
Protected property | SimulationService |
Protected property | TranslationRotationService |
Protected property | Viewport | Gets the viewport.
Protected property | ViewportHeight | Gets the height of the viewport.
Protected property | ViewportWidth | Gets the width of the viewport.
Top
Methods
 | Name | Description
Public method | CanExecute | Occurs when the command associated with this handler initiates a check to determine whether the command can be executed on the command target.
Public method | Completed | Occurs when the manipulation is completed.
Public method | Delta | Occurs when the position is changed during a manipulation.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCursor | Gets the cursor for the gesture.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetManipulationTarget(IEnumerableIVisualObject) |
Protected method | GetManipulationTarget(IVisualObject) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnInertiaStarting | Called when inertia is starting.
Public method | OnLostMouseCapture |
Protected method | OnMouseDown | Called when the mouse button is pressed down.
Public method | OnMouseMove | The on mouse move.
Public method | OnMouseUp | The on mouse up.
Public method | Started | Occurs when the manipulation is started.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _renderService |
Protected field | _selectionManager |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace
Inheritance Hierarchy
SystemObject
VisualComponents.UX.InputMouseGestureHandler
VisualComponents.UX.InputAnnotationManipulateHandler
VisualComponents.UX.InputAreaSelectHandler
VisualComponents.UX.InputDimensionManipulateHandler
VisualComponents.UX.InputObjectRotateHandler
VisualComponents.UX.InputPanHandler
VisualComponents.UX.InputPickHandler
VisualComponents.UX.InputPlugPlayLogicalHandler
VisualComponents.UX.InputQuickCopyPasteHandler
VisualComponents.UX.InputRotateHandler
VisualComponents.UX.InputSelectHandler
VisualComponents.UX.InputSelectParentHandler
VisualComponents.UX.InputSetCenterOfInterestHandler
VisualComponents.UX.InputShowContextMenuHandler
VisualComponents.UX.InputTranslateHandler
VisualComponents.UX.InputZoomHandler
VisualComponents.UX.SharedObjectQuickMenuDisplayHandler


MouseGestureHandler Constructor

Initializes a new instance of the MouseGestureHandler class.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected MouseGestureHandler(
    HelperViewport controller
)
protected:
MouseGestureHandler(
    HelperViewport^ controller
)

Parameters

controller
Type: VisualComponents.UX.InputHelperViewport
The controller.
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler Properties

The MouseGestureHandler type exposes the following members.

Properties
 | Name | Description
Protected property | Application |
Protected property | Camera | Gets the camera.
Protected property | CameraMode | Gets the camera mode.
Protected property | Controller | Gets or sets the controller.
Protected property | EventMng |
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler.
Protected property | LastPoint | Gets or sets the last point (2D screen coordinates).
Protected property | LastPoint3D | Gets or sets the last point (3D world coordinates).
Protected property | ManipulateViewModel |
Protected property | ManipulationWatch | Gets or sets the manipulation watch.
Protected property | MouseDownNearestPoint3D | Gets or sets the mouse down point at the nearest hit element (3D world coordinates).
Protected property | MouseDownPoint | Gets or sets the mouse down point (2D screen coordinates).
Protected property | MouseDownPoint3D | Gets or sets the mouse down point (3D world coordinates).
Protected property | ObjectSelectionMode |
Public property | Origin | Gets Origin.
Protected property | RenderingService |
Protected property | SimulationService |
Protected property | TranslationRotationService |
Protected property | Viewport | Gets the viewport.
Protected property | ViewportHeight | Gets the height of the viewport.
Protected property | ViewportWidth | Gets the width of the viewport.
Top
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.Application Property

MouseGestureHandlerApplication Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected IApplication Application { get; set; }
protected:
property IApplication^ Application {
    IApplication^ get ();
    void set (IApplication^ value);
}

Property Value

Type: IApplication
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.Camera Property

MouseGestureHandlerCamera Property

Gets the camera.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected ProjectionCamera Camera { get; }
protected:
property ProjectionCamera^ Camera {
    ProjectionCamera^ get ();
}

Property Value

Type: ProjectionCamera
The camera.
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.CameraMode Property

MouseGestureHandlerCameraMode Property

Gets the camera mode.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected CameraMode CameraMode { get; }
protected:
property CameraMode CameraMode {
    CameraMode get ();
}

Property Value

Type: CameraMode
The camera mode.
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.Controller Property

MouseGestureHandlerController Property

Gets or sets the controller.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected HelperViewport Controller { get; }
protected:
property HelperViewport^ Controller {
    HelperViewport^ get ();
}

Property Value

Type: HelperViewport
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.EventMng Property

MouseGestureHandlerEventMng Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected IEventAggregator EventMng { get; set; }
protected:
property IEventAggregator^ EventMng {
    IEventAggregator^ get ();
    void set (IEventAggregator^ value);
}

Property Value

Type: IEventAggregator
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.ExecutionParameter Property

MouseGestureHandlerExecutionParameter Property

Viewport passes the bound interaction type to the handler.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Interaction ExecutionParameter { get; protected set; }
public:
property Interaction ExecutionParameter {
    Interaction get ();
    protected: void set (Interaction value);
}

Property Value

Type: Interaction
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.LastPoint Property

MouseGestureHandlerLastPoint Property

Gets or sets the last point (2D screen coordinates).

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected Point LastPoint { get; set; }
protected:
property Point LastPoint {
    Point get ();
    void set (Point value);
}

Property Value

Type: Point
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.LastPoint3D Property

MouseGestureHandlerLastPoint3D Property

Gets or sets the last point (3D world coordinates).

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected Nullable<Point3D> LastPoint3D { get; set; }
protected:
property Nullable<Point3D> LastPoint3D {
    Nullable<Point3D> get ();
    void set (Nullable<Point3D> value);
}

Property Value

Type: NullablePoint3D
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.ManipulateViewModel Property

MouseGestureHandlerManipulateViewModel Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected IManipulateViewModel ManipulateViewModel { get; set; }
protected:
property IManipulateViewModel^ ManipulateViewModel {
    IManipulateViewModel^ get ();
    void set (IManipulateViewModel^ value);
}

Property Value

Type: IManipulateViewModel
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.ManipulationWatch Property

MouseGestureHandlerManipulationWatch Property

Gets or sets the manipulation watch.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected Stopwatch ManipulationWatch { get; }
protected:
property Stopwatch^ ManipulationWatch {
    Stopwatch^ get ();
}

Property Value

Type: Stopwatch
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.MouseDownNearestPoint3D Property

MouseGestureHandlerMouseDownNearestPoint3D Property

Gets or sets the mouse down point at the nearest hit element (3D world coordinates).

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected Nullable<Point3D> MouseDownNearestPoint3D { get; set; }
protected:
property Nullable<Point3D> MouseDownNearestPoint3D {
    Nullable<Point3D> get ();
    void set (Nullable<Point3D> value);
}

Property Value

Type: NullablePoint3D
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.MouseDownPoint Property

MouseGestureHandlerMouseDownPoint Property

Gets or sets the mouse down point (2D screen coordinates).

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected Point MouseDownPoint { get; set; }
protected:
property Point MouseDownPoint {
    Point get ();
    void set (Point value);
}

Property Value

Type: Point
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.MouseDownPoint3D Property

MouseGestureHandlerMouseDownPoint3D Property

Gets or sets the mouse down point (3D world coordinates).

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected Nullable<Point3D> MouseDownPoint3D { get; set; }
protected:
property Nullable<Point3D> MouseDownPoint3D {
    Nullable<Point3D> get ();
    void set (Nullable<Point3D> value);
}

Property Value

Type: NullablePoint3D
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.ObjectSelectionMode Property

MouseGestureHandlerObjectSelectionMode Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected ObjectSelectionMode ObjectSelectionMode { get; set; }
protected:
property ObjectSelectionMode ObjectSelectionMode {
    ObjectSelectionMode get ();
    void set (ObjectSelectionMode value);
}

Property Value

Type: ObjectSelectionMode
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.Origin Property

MouseGestureHandlerOrigin Property

Gets Origin.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Point3D Origin { get; }
public:
property Point3D Origin {
    Point3D get ();
}

Property Value

Type: Point3D
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.RenderingService Property

MouseGestureHandlerRenderingService Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected IRenderService RenderingService { get; set; }
protected:
property IRenderService^ RenderingService {
    IRenderService^ get ();
    void set (IRenderService^ value);
}

Property Value

Type: IRenderService
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.SimulationService Property

MouseGestureHandlerSimulationService Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected ISimulationService SimulationService { get; set; }
protected:
property ISimulationService^ SimulationService {
    ISimulationService^ get ();
    void set (ISimulationService^ value);
}

Property Value

Type: ISimulationService
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.TranslationRotationService Property

MouseGestureHandlerTranslationRotationService Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected ITranslationRotationService TranslationRotationService { get; set; }
protected:
property ITranslationRotationService^ TranslationRotationService {
    ITranslationRotationService^ get ();
    void set (ITranslationRotationService^ value);
}

Property Value

Type: ITranslationRotationService
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.Viewport Property

MouseGestureHandlerViewport Property

Gets the viewport.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected Viewport3D Viewport { get; }
protected:
property Viewport3D^ Viewport {
    Viewport3D^ get ();
}

Property Value

Type: Viewport3D
The viewport.
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.ViewportHeight Property

MouseGestureHandlerViewportHeight Property

Gets the height of the viewport.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected double ViewportHeight { get; }
protected:
property double ViewportHeight {
    double get ();
}

Property Value

Type: Double
The height of the viewport.
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.ViewportWidth Property

MouseGestureHandlerViewportWidth Property

Gets the width of the viewport.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected double ViewportWidth { get; }
protected:
property double ViewportWidth {
    double get ();
}

Property Value

Type: Double
The width of the viewport.
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler Methods

The MouseGestureHandler type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Occurs when the command associated with this handler initiates a check to determine whether the command can be executed on the command target.
Public method | Completed | Occurs when the manipulation is completed.
Public method | Delta | Occurs when the position is changed during a manipulation.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCursor | Gets the cursor for the gesture.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetManipulationTarget(IEnumerableIVisualObject) |
Protected method | GetManipulationTarget(IVisualObject) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnInertiaStarting | Called when inertia is starting.
Public method | OnLostMouseCapture |
Protected method | OnMouseDown | Called when the mouse button is pressed down.
Public method | OnMouseMove | The on mouse move.
Public method | OnMouseUp | The on mouse up.
Public method | Started | Occurs when the manipulation is started.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.CanExecute Method

MouseGestureHandlerCanExecute Method

Occurs when the command associated with this handler initiates a check to determine whether the command can be executed on the command target.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual bool CanExecute()
public:
virtual bool CanExecute()

Return Value

Type: Boolean
True if the execution can continue.
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.Completed Method

MouseGestureHandlerCompleted Method

Occurs when the manipulation is completed.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void Completed(
    ManipulationEventArgs e
)
public:
virtual void Completed(
    ManipulationEventArgs^ e
)

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
The ManipulationEventArgs instance containing the event data.
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.Delta Method

MouseGestureHandlerDelta Method

Occurs when the position is changed during a manipulation.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void Delta(
    ManipulationEventArgs e
)
public:
virtual void Delta(
    ManipulationEventArgs^ e
)

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
The ManipulationEventArgs instance containing the event data.
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.Execute Method

MouseGestureHandlerExecute Method

Executes the mousegesture command.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void Execute(
    Object sender,
    ExecutedRoutedEventArgs e
)
public:
virtual void Execute(
    Object^ sender,
    ExecutedRoutedEventArgs^ e
)

Parameters

sender
Type: SystemObject
The sender.
e
Type: System.Windows.InputExecutedRoutedEventArgs
The event arguments.
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.GetCursor Method

MouseGestureHandlerGetCursor Method

Gets the cursor for the gesture.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected abstract Cursor GetCursor()
protected:
virtual Cursor^ GetCursor() abstract

Return Value

Type: Cursor
A cursor.
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.GetManipulationTarget Method

MouseGestureHandlerGetManipulationTarget Method

Overload List
 | Name | Description
Protected method | GetManipulationTarget(IEnumerableIVisualObject) |
Protected method | GetManipulationTarget(IVisualObject) |
Top
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.GetManipulationTarget Method (IEnumerable(IVisualObject))

MouseGestureHandlerGetManipulationTarget Method (IEnumerableIVisualObject)

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected IManipulationTarget GetManipulationTarget(
    IEnumerable<IVisualObject> items
)
protected:
IManipulationTarget^ GetManipulationTarget(
    IEnumerable<IVisualObject^>^ items
)

Parameters

items
Type: System.Collections.GenericIEnumerableIVisualObject

Return Value

Type: IManipulationTarget

[Missing <returns> documentation for "M:VisualComponents.UX.Input.MouseGestureHandler.GetManipulationTarget(System.Collections.Generic.IEnumerable{VisualComponents.Create3D.IVisualObject})"]

See Also

Reference

MouseGestureHandler Class
GetManipulationTarget Overload
VisualComponents.UX.Input Namespace


MouseGestureHandler.GetManipulationTarget Method (IVisualObject)

MouseGestureHandlerGetManipulationTarget Method (IVisualObject)

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected IManipulationTarget GetManipulationTarget(
    IVisualObject item
)
protected:
IManipulationTarget^ GetManipulationTarget(
    IVisualObject^ item
)

Parameters

item
Type: VisualComponents.Create3DIVisualObject

Return Value

Type: IManipulationTarget

[Missing <returns> documentation for "M:VisualComponents.UX.Input.MouseGestureHandler.GetManipulationTarget(VisualComponents.Create3D.IVisualObject)"]

See Also

Reference

MouseGestureHandler Class
GetManipulationTarget Overload
VisualComponents.UX.Input Namespace


MouseGestureHandler.OnInertiaStarting Method

MouseGestureHandlerOnInertiaStarting Method

Called when inertia is starting.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void OnInertiaStarting(
    int elapsedTime
)
protected:
virtual void OnInertiaStarting(
    int elapsedTime
)

Parameters

elapsedTime
Type: SystemInt32
The elapsed time (milliseconds).
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.OnLostMouseCapture Method

MouseGestureHandlerOnLostMouseCapture Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void OnLostMouseCapture(
    Object sender,
    MouseEventArgs e
)
public:
virtual void OnLostMouseCapture(
    Object^ sender,
    MouseEventArgs^ e
)

Parameters

sender
Type: SystemObject
e
Type: System.Windows.InputMouseEventArgs
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.OnMouseDown Method

MouseGestureHandlerOnMouseDown Method

Called when the mouse button is pressed down.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void OnMouseDown(
    Object sender,
    MouseEventArgs e
)
protected:
virtual void OnMouseDown(
    Object^ sender,
    MouseEventArgs^ e
)

Parameters

sender
Type: SystemObject
The sender.
e
Type: System.Windows.InputMouseEventArgs
The MouseEventArgs instance containing the event data.
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.OnMouseMove Method

MouseGestureHandlerOnMouseMove Method

The on mouse move.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void OnMouseMove(
    Object sender,
    MouseEventArgs e
)
public:
virtual void OnMouseMove(
    Object^ sender,
    MouseEventArgs^ e
)

Parameters

sender
Type: SystemObject
The sender.
e
Type: System.Windows.InputMouseEventArgs
The event arguments.
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.OnMouseUp Method

MouseGestureHandlerOnMouseUp Method

The on mouse up.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void OnMouseUp(
    Object sender,
    MouseEventArgs e
)
public:
virtual void OnMouseUp(
    Object^ sender,
    MouseEventArgs^ e
)

Parameters

sender
Type: SystemObject
The sender.
e
Type: System.Windows.InputMouseEventArgs
The event arguments.
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler.Started Method

MouseGestureHandlerStarted Method

Occurs when the manipulation is started.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void Started(
    ManipulationEventArgs e
)
public:
virtual void Started(
    ManipulationEventArgs^ e
)

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
The ManipulationEventArgs instance containing the event data.
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler Fields

The MouseGestureHandler type exposes the following members.

Fields
 | Name | Description
Protected field | _renderService |
Protected field | _selectionManager |
Top
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler._renderService Field

MouseGestureHandler_renderService Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected readonly IRenderService _renderService
protected:
initonly IRenderService^ _renderService

Field Value

Type: IRenderService
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


MouseGestureHandler._selectionManager Field

MouseGestureHandler_selectionManager Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected readonly ISelectionManager _selectionManager
protected:
initonly ISelectionManager^ _selectionManager

Field Value

Type: ISelectionManager
See Also

Reference

MouseGestureHandler Class
VisualComponents.UX.Input Namespace


ObjectRotateHandler Class

Handles rotation. Deprecated. Now Control is reserved to area selection.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.InputMouseGestureHandler
VisualComponents.UX.InputObjectRotateHandler

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ObjectRotateHandler : MouseGestureHandler
public ref class ObjectRotateHandler sealed : public MouseGestureHandler

The ObjectRotateHandler type exposes the following members.

Constructors
 | Name | Description
Public method | ObjectRotateHandler | Initializes a new instance of the ObjectRotateHandler class
Top
Properties
 | Name | Description
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Top
Methods
 | Name | Description
Public method | CanExecute | (Overrides MouseGestureHandlerCanExecute.)
Public method | Completed | (Overrides MouseGestureHandlerCompleted(ManipulationEventArgs).)
Public method | Delta | (Overrides MouseGestureHandlerDelta(ManipulationEventArgs).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnLostMouseCapture | (Inherited from MouseGestureHandler.)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


ObjectRotateHandler Constructor

Initializes a new instance of the ObjectRotateHandler class

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObjectRotateHandler(
    HelperViewport controller
)
public:
ObjectRotateHandler(
    HelperViewport^ controller
)

Parameters

controller
Type: VisualComponents.UX.InputHelperViewport
See Also

Reference

ObjectRotateHandler Class
VisualComponents.UX.Input Namespace


ObjectRotateHandler Properties

The ObjectRotateHandler type exposes the following members.

Properties
 | Name | Description
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Top
See Also

Reference

ObjectRotateHandler Class
VisualComponents.UX.Input Namespace


ObjectRotateHandler Methods

The ObjectRotateHandler type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | (Overrides MouseGestureHandlerCanExecute.)
Public method | Completed | (Overrides MouseGestureHandlerCompleted(ManipulationEventArgs).)
Public method | Delta | (Overrides MouseGestureHandlerDelta(ManipulationEventArgs).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnLostMouseCapture | (Inherited from MouseGestureHandler.)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ObjectRotateHandler Class
VisualComponents.UX.Input Namespace


ObjectRotateHandler.CanExecute Method

ObjectRotateHandlerCanExecute Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool CanExecute()
public:
virtual bool CanExecute() override

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Input.ObjectRotateHandler.CanExecute"]

See Also

Reference

ObjectRotateHandler Class
VisualComponents.UX.Input Namespace


ObjectRotateHandler.Completed Method

ObjectRotateHandlerCompleted Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Completed(
    ManipulationEventArgs e
)
public:
virtual void Completed(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

ObjectRotateHandler Class
VisualComponents.UX.Input Namespace


ObjectRotateHandler.Delta Method

ObjectRotateHandlerDelta Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Delta(
    ManipulationEventArgs e
)
public:
virtual void Delta(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

ObjectRotateHandler Class
VisualComponents.UX.Input Namespace


ObjectRotateHandler.Started Method

ObjectRotateHandlerStarted Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Started(
    ManipulationEventArgs e
)
public:
virtual void Started(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

ObjectRotateHandler Class
VisualComponents.UX.Input Namespace


PanHandler Class

Handles panning.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.InputMouseGestureHandler
VisualComponents.UX.InputPanHandler

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class PanHandler : MouseGestureHandler
public ref class PanHandler sealed : public MouseGestureHandler

The PanHandler type exposes the following members.

Constructors
 | Name | Description
Public method | PanHandler | Initializes a new instance of the PanHandler class.
Top
Properties
 | Name | Description
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Top
Methods
 | Name | Description
Public method | CanExecute | Occurs when the command associated with this handler initiates a check to determine whether the command can be executed on the command target. (Overrides MouseGestureHandlerCanExecute.)
Public method | Completed | Occurs when the manipulation is completed. (Overrides MouseGestureHandlerCompleted(ManipulationEventArgs).)
Public method | Delta | Occurs when the position is changed during a manipulation. (Overrides MouseGestureHandlerDelta(ManipulationEventArgs).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | (Overrides MouseGestureHandlerExecute(Object, ExecutedRoutedEventArgs).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnLostMouseCapture | (Inherited from MouseGestureHandler.)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Pan(Vector3D) | Pans the camera by the specified 3D vector (world coordinates).
Public method | Pan(Vector) | Pans the camera by the specified 2D vector (screen coordinates).
Public method | Started | Occurs when the manipulation is started. (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


PanHandler Constructor

Initializes a new instance of the PanHandler class.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PanHandler(
    HelperViewport controller
)
public:
PanHandler(
    HelperViewport^ controller
)

Parameters

controller
Type: VisualComponents.UX.InputHelperViewport
The controller.
See Also

Reference

PanHandler Class
VisualComponents.UX.Input Namespace


PanHandler Properties

The PanHandler type exposes the following members.

Properties
 | Name | Description
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Top
See Also

Reference

PanHandler Class
VisualComponents.UX.Input Namespace


PanHandler Methods

The PanHandler type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Occurs when the command associated with this handler initiates a check to determine whether the command can be executed on the command target. (Overrides MouseGestureHandlerCanExecute.)
Public method | Completed | Occurs when the manipulation is completed. (Overrides MouseGestureHandlerCompleted(ManipulationEventArgs).)
Public method | Delta | Occurs when the position is changed during a manipulation. (Overrides MouseGestureHandlerDelta(ManipulationEventArgs).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | (Overrides MouseGestureHandlerExecute(Object, ExecutedRoutedEventArgs).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnLostMouseCapture | (Inherited from MouseGestureHandler.)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Pan(Vector3D) | Pans the camera by the specified 3D vector (world coordinates).
Public method | Pan(Vector) | Pans the camera by the specified 2D vector (screen coordinates).
Public method | Started | Occurs when the manipulation is started. (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PanHandler Class
VisualComponents.UX.Input Namespace


PanHandler.CanExecute Method

PanHandlerCanExecute Method

Occurs when the command associated with this handler initiates a check to determine whether the command can be executed on the command target.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool CanExecute()
public:
virtual bool CanExecute() override

Return Value

Type: Boolean
True if the execution can continue.
See Also

Reference

PanHandler Class
VisualComponents.UX.Input Namespace


PanHandler.Completed Method

PanHandlerCompleted Method

Occurs when the manipulation is completed.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Completed(
    ManipulationEventArgs e
)
public:
virtual void Completed(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
The ManipulationEventArgs instance containing the event data.
See Also

Reference

PanHandler Class
VisualComponents.UX.Input Namespace


PanHandler.Delta Method

PanHandlerDelta Method

Occurs when the position is changed during a manipulation.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Delta(
    ManipulationEventArgs e
)
public:
virtual void Delta(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
The ManipulationEventArgs instance containing the event data.
See Also

Reference

PanHandler Class
VisualComponents.UX.Input Namespace


PanHandler.Execute Method

PanHandlerExecute Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Execute(
    Object sender,
    ExecutedRoutedEventArgs e
)
public:
virtual void Execute(
    Object^ sender,
    ExecutedRoutedEventArgs^ e
) override

Parameters

sender
Type: SystemObject
e
Type: System.Windows.InputExecutedRoutedEventArgs
See Also

Reference

PanHandler Class
VisualComponents.UX.Input Namespace


PanHandler.Pan Method

PanHandlerPan Method

Overload List
 | Name | Description
Public method | Pan(Vector3D) | Pans the camera by the specified 3D vector (world coordinates).
Public method | Pan(Vector) | Pans the camera by the specified 2D vector (screen coordinates).
Top
See Also

Reference

PanHandler Class
VisualComponents.UX.Input Namespace


PanHandler.Pan Method (Vector3D)

PanHandlerPan Method (Vector3D)

Pans the camera by the specified 3D vector (world coordinates).

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Pan(
    Vector3D delta
)
public:
void Pan(
    Vector3D delta
)

Parameters

delta
Type: System.Windows.Media.Media3DVector3D
The panning vector.
See Also

Reference

PanHandler Class
Pan Overload
VisualComponents.UX.Input Namespace


PanHandler.Pan Method (Vector)

PanHandlerPan Method (Vector)

Pans the camera by the specified 2D vector (screen coordinates).

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Pan(
    Vector delta
)
public:
void Pan(
    Vector delta
)

Parameters

delta
Type: System.WindowsVector
The delta.
See Also

Reference

PanHandler Class
Pan Overload
VisualComponents.UX.Input Namespace


PanHandler.Started Method

PanHandlerStarted Method

Occurs when the manipulation is started.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Started(
    ManipulationEventArgs e
)
public:
virtual void Started(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
The ManipulationEventArgs instance containing the event data.
See Also

Reference

PanHandler Class
VisualComponents.UX.Input Namespace


PickHandler Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.InputMouseGestureHandler
VisualComponents.UX.InputPickHandler

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class PickHandler : MouseGestureHandler
public ref class PickHandler sealed : public MouseGestureHandler

The PickHandler type exposes the following members.

Constructors
 | Name | Description
Public method | PickHandler | Initializes a new instance of the PickHandler class
Top
Properties
 | Name | Description
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Public property | PickResult |
Top
Methods
 | Name | Description
Public method | CanExecute | (Overrides MouseGestureHandlerCanExecute.)
Public method | Completed | (Overrides MouseGestureHandlerCompleted(ManipulationEventArgs).)
Public method | Delta | (Overrides MouseGestureHandlerDelta(ManipulationEventArgs).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnLostMouseCapture | (Inherited from MouseGestureHandler.)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
 | SwitchToPositionFrameSelection |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


PickHandler Constructor

Initializes a new instance of the PickHandler class

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PickHandler(
    HelperViewport controller
)
public:
PickHandler(
    HelperViewport^ controller
)

Parameters

controller
Type: VisualComponents.UX.InputHelperViewport
See Also

Reference

PickHandler Class
VisualComponents.UX.Input Namespace


PickHandler Properties

The PickHandler type exposes the following members.

Properties
 | Name | Description
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Public property | PickResult |
Top
See Also

Reference

PickHandler Class
VisualComponents.UX.Input Namespace


PickHandler.PickResult Property

PickHandlerPickResult Property

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PickResult PickResult { get; }
public:
property PickResult PickResult {
    PickResult get ();
}

Property Value

Type: PickResult
See Also

Reference

PickHandler Class
VisualComponents.UX.Input Namespace


PickHandler Methods

The PickHandler type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | (Overrides MouseGestureHandlerCanExecute.)
Public method | Completed | (Overrides MouseGestureHandlerCompleted(ManipulationEventArgs).)
Public method | Delta | (Overrides MouseGestureHandlerDelta(ManipulationEventArgs).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnLostMouseCapture | (Inherited from MouseGestureHandler.)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
 | SwitchToPositionFrameSelection |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PickHandler Class
VisualComponents.UX.Input Namespace


PickHandler.CanExecute Method

PickHandlerCanExecute Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool CanExecute()
public:
virtual bool CanExecute() override

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Input.PickHandler.CanExecute"]

See Also

Reference

PickHandler Class
VisualComponents.UX.Input Namespace


PickHandler.Completed Method

PickHandlerCompleted Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Completed(
    ManipulationEventArgs e
)
public:
virtual void Completed(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

PickHandler Class
VisualComponents.UX.Input Namespace


PickHandler.Delta Method

PickHandlerDelta Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Delta(
    ManipulationEventArgs e
)
public:
virtual void Delta(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

PickHandler Class
VisualComponents.UX.Input Namespace


PickHandler.Started Method

PickHandlerStarted Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Started(
    ManipulationEventArgs e
)
public:
virtual void Started(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

PickHandler Class
VisualComponents.UX.Input Namespace


PickHandler.SwitchToPositionFrameSelection Method

PickHandlerSwitchToPositionFrameSelection Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SwitchToPositionFrameSelection()
public:
static void SwitchToPositionFrameSelection()
See Also

Reference

PickHandler Class
VisualComponents.UX.Input Namespace


PlugPlayLogicalHandler Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.InputMouseGestureHandler
VisualComponents.UX.InputPlugPlayLogicalHandler

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class PlugPlayLogicalHandler : MouseGestureHandler
public ref class PlugPlayLogicalHandler sealed : public MouseGestureHandler

The PlugPlayLogicalHandler type exposes the following members.

Constructors
 | Name | Description
Public method | PlugPlayLogicalHandler | Initializes a new instance of the PlugPlayLogicalHandler class
Top
Properties
 | Name | Description
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Top
Methods
 | Name | Description
Public method | CanExecute | (Overrides MouseGestureHandlerCanExecute.)
Public method | Completed | (Overrides MouseGestureHandlerCompleted(ManipulationEventArgs).)
Public method | Delta | Occurs when the position is changed during a manipulation. (Inherited from MouseGestureHandler.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnLostMouseCapture | (Inherited from MouseGestureHandler.)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | Occurs when the manipulation is started. (Inherited from MouseGestureHandler.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


PlugPlayLogicalHandler Constructor

Initializes a new instance of the PlugPlayLogicalHandler class

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PlugPlayLogicalHandler(
    HelperViewport controller
)
public:
PlugPlayLogicalHandler(
    HelperViewport^ controller
)

Parameters

controller
Type: VisualComponents.UX.InputHelperViewport
See Also

Reference

PlugPlayLogicalHandler Class
VisualComponents.UX.Input Namespace


PlugPlayLogicalHandler Properties

The PlugPlayLogicalHandler type exposes the following members.

Properties
 | Name | Description
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Top
See Also

Reference

PlugPlayLogicalHandler Class
VisualComponents.UX.Input Namespace


PlugPlayLogicalHandler Methods

The PlugPlayLogicalHandler type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | (Overrides MouseGestureHandlerCanExecute.)
Public method | Completed | (Overrides MouseGestureHandlerCompleted(ManipulationEventArgs).)
Public method | Delta | Occurs when the position is changed during a manipulation. (Inherited from MouseGestureHandler.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnLostMouseCapture | (Inherited from MouseGestureHandler.)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | Occurs when the manipulation is started. (Inherited from MouseGestureHandler.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PlugPlayLogicalHandler Class
VisualComponents.UX.Input Namespace


PlugPlayLogicalHandler.CanExecute Method

PlugPlayLogicalHandlerCanExecute Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool CanExecute()
public:
virtual bool CanExecute() override

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Input.PlugPlayLogicalHandler.CanExecute"]

See Also

Reference

PlugPlayLogicalHandler Class
VisualComponents.UX.Input Namespace


PlugPlayLogicalHandler.Completed Method

PlugPlayLogicalHandlerCompleted Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Completed(
    ManipulationEventArgs e
)
public:
virtual void Completed(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

PlugPlayLogicalHandler Class
VisualComponents.UX.Input Namespace


QuickCopyPasteHandler Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.InputMouseGestureHandler
VisualComponents.UX.InputQuickCopyPasteHandler

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class QuickCopyPasteHandler : MouseGestureHandler
public ref class QuickCopyPasteHandler : public MouseGestureHandler

The QuickCopyPasteHandler type exposes the following members.

Constructors
 | Name | Description
Public method | QuickCopyPasteHandler | Initializes a new instance of the QuickCopyPasteHandler class
Top
Properties
 | Name | Description
Protected property | Application | (Inherited from MouseGestureHandler.)
Protected property | Camera | Gets the camera. (Inherited from MouseGestureHandler.)
Protected property | CameraMode | Gets the camera mode. (Inherited from MouseGestureHandler.)
Protected property | Controller | Gets or sets the controller. (Inherited from MouseGestureHandler.)
Protected property | EventMng | (Inherited from MouseGestureHandler.)
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Protected property | LastPoint | Gets or sets the last point (2D screen coordinates). (Inherited from MouseGestureHandler.)
Protected property | LastPoint3D | Gets or sets the last point (3D world coordinates). (Inherited from MouseGestureHandler.)
Protected property | ManipulateViewModel | (Inherited from MouseGestureHandler.)
Protected property | ManipulationWatch | Gets or sets the manipulation watch. (Inherited from MouseGestureHandler.)
Protected property | MouseDownNearestPoint3D | Gets or sets the mouse down point at the nearest hit element (3D world coordinates). (Inherited from MouseGestureHandler.)
Protected property | MouseDownPoint | Gets or sets the mouse down point (2D screen coordinates). (Inherited from MouseGestureHandler.)
Protected property | MouseDownPoint3D | Gets or sets the mouse down point (3D world coordinates). (Inherited from MouseGestureHandler.)
Protected property | ObjectSelectionMode | (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Protected property | RenderingService | (Inherited from MouseGestureHandler.)
Protected property | SimulationService | (Inherited from MouseGestureHandler.)
Protected property | TranslationRotationService | (Inherited from MouseGestureHandler.)
Protected property | Viewport | Gets the viewport. (Inherited from MouseGestureHandler.)
Protected property | ViewportHeight | Gets the height of the viewport. (Inherited from MouseGestureHandler.)
Protected property | ViewportWidth | Gets the width of the viewport. (Inherited from MouseGestureHandler.)
Top
Methods
 | Name | Description
Public method | CanExecute | Occurs when the command associated with this handler initiates a check to determine whether the command can be executed on the command target. (Inherited from MouseGestureHandler.)
Public method | Completed | Occurs when the manipulation is completed. (Inherited from MouseGestureHandler.)
Public method | Delta | Occurs when the position is changed during a manipulation. (Inherited from MouseGestureHandler.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCursor | (Overrides MouseGestureHandlerGetCursor.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetManipulationTarget(IEnumerableIVisualObject) | (Inherited from MouseGestureHandler.)
Protected method | GetManipulationTarget(IVisualObject) | (Inherited from MouseGestureHandler.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnInertiaStarting | Called when inertia is starting. (Inherited from MouseGestureHandler.)
Public method | OnLostMouseCapture | (Inherited from MouseGestureHandler.)
Protected method | OnMouseDown | Called when the mouse button is pressed down. (Inherited from MouseGestureHandler.)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _renderService | (Inherited from MouseGestureHandler.)
Protected field | _selectionManager | (Inherited from MouseGestureHandler.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


QuickCopyPasteHandler Constructor

Initializes a new instance of the QuickCopyPasteHandler class

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public QuickCopyPasteHandler(
    HelperViewport helperViewport
)
public:
QuickCopyPasteHandler(
    HelperViewport^ helperViewport
)

Parameters

helperViewport
Type: VisualComponents.UX.InputHelperViewport
See Also

Reference

QuickCopyPasteHandler Class
VisualComponents.UX.Input Namespace


QuickCopyPasteHandler Properties

The QuickCopyPasteHandler type exposes the following members.

Properties
 | Name | Description
Protected property | Application | (Inherited from MouseGestureHandler.)
Protected property | Camera | Gets the camera. (Inherited from MouseGestureHandler.)
Protected property | CameraMode | Gets the camera mode. (Inherited from MouseGestureHandler.)
Protected property | Controller | Gets or sets the controller. (Inherited from MouseGestureHandler.)
Protected property | EventMng | (Inherited from MouseGestureHandler.)
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Protected property | LastPoint | Gets or sets the last point (2D screen coordinates). (Inherited from MouseGestureHandler.)
Protected property | LastPoint3D | Gets or sets the last point (3D world coordinates). (Inherited from MouseGestureHandler.)
Protected property | ManipulateViewModel | (Inherited from MouseGestureHandler.)
Protected property | ManipulationWatch | Gets or sets the manipulation watch. (Inherited from MouseGestureHandler.)
Protected property | MouseDownNearestPoint3D | Gets or sets the mouse down point at the nearest hit element (3D world coordinates). (Inherited from MouseGestureHandler.)
Protected property | MouseDownPoint | Gets or sets the mouse down point (2D screen coordinates). (Inherited from MouseGestureHandler.)
Protected property | MouseDownPoint3D | Gets or sets the mouse down point (3D world coordinates). (Inherited from MouseGestureHandler.)
Protected property | ObjectSelectionMode | (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Protected property | RenderingService | (Inherited from MouseGestureHandler.)
Protected property | SimulationService | (Inherited from MouseGestureHandler.)
Protected property | TranslationRotationService | (Inherited from MouseGestureHandler.)
Protected property | Viewport | Gets the viewport. (Inherited from MouseGestureHandler.)
Protected property | ViewportHeight | Gets the height of the viewport. (Inherited from MouseGestureHandler.)
Protected property | ViewportWidth | Gets the width of the viewport. (Inherited from MouseGestureHandler.)
Top
See Also

Reference

QuickCopyPasteHandler Class
VisualComponents.UX.Input Namespace


QuickCopyPasteHandler Methods

The QuickCopyPasteHandler type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Occurs when the command associated with this handler initiates a check to determine whether the command can be executed on the command target. (Inherited from MouseGestureHandler.)
Public method | Completed | Occurs when the manipulation is completed. (Inherited from MouseGestureHandler.)
Public method | Delta | Occurs when the position is changed during a manipulation. (Inherited from MouseGestureHandler.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCursor | (Overrides MouseGestureHandlerGetCursor.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetManipulationTarget(IEnumerableIVisualObject) | (Inherited from MouseGestureHandler.)
Protected method | GetManipulationTarget(IVisualObject) | (Inherited from MouseGestureHandler.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnInertiaStarting | Called when inertia is starting. (Inherited from MouseGestureHandler.)
Public method | OnLostMouseCapture | (Inherited from MouseGestureHandler.)
Protected method | OnMouseDown | Called when the mouse button is pressed down. (Inherited from MouseGestureHandler.)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

QuickCopyPasteHandler Class
VisualComponents.UX.Input Namespace


QuickCopyPasteHandler.GetCursor Method

QuickCopyPasteHandlerGetCursor Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Cursor GetCursor()
protected:
virtual Cursor^ GetCursor() override

Return Value

Type: Cursor

[Missing <returns> documentation for "M:VisualComponents.UX.Input.QuickCopyPasteHandler.GetCursor"]

See Also

Reference

QuickCopyPasteHandler Class
VisualComponents.UX.Input Namespace


QuickCopyPasteHandler.Started Method

QuickCopyPasteHandlerStarted Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Started(
    ManipulationEventArgs e
)
public:
virtual void Started(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

QuickCopyPasteHandler Class
VisualComponents.UX.Input Namespace


QuickCopyPasteHandler Fields

The QuickCopyPasteHandler type exposes the following members.

Fields
 | Name | Description
Protected field | _renderService | (Inherited from MouseGestureHandler.)
Protected field | _selectionManager | (Inherited from MouseGestureHandler.)
Top
See Also

Reference

QuickCopyPasteHandler Class
VisualComponents.UX.Input Namespace


RotateHandler Class

Handles camera rotation (orbit).
Inheritance Hierarchy
SystemObject
VisualComponents.UX.InputMouseGestureHandler
VisualComponents.UX.InputRotateHandler

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class RotateHandler : MouseGestureHandler
public ref class RotateHandler sealed : public MouseGestureHandler

The RotateHandler type exposes the following members.

Constructors
 | Name | Description
Public method | RotateHandler | Initializes a new instance of the RotateHandler class.
Top
Properties
 | Name | Description
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Top
Methods
 | Name | Description
Public method | CanExecute | The can execute. (Overrides MouseGestureHandlerCanExecute.)
Public method | Completed | Occurs when the manipulation is completed. (Overrides MouseGestureHandlerCompleted(ManipulationEventArgs).)
Public method | Delta | Occurs when the position is changed during a manipulation. (Overrides MouseGestureHandlerDelta(ManipulationEventArgs).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LookAt | Change the "look-at" point.
Public method | OnLostMouseCapture | (Inherited from MouseGestureHandler.)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | Occurs when the manipulation is started. (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


RotateHandler Constructor

Initializes a new instance of the RotateHandler class.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RotateHandler(
    HelperViewport controller,
    bool changeLookAt = false
)
public:
RotateHandler(
    HelperViewport^ controller,
    bool changeLookAt = false
)

Parameters

controller
Type: VisualComponents.UX.InputHelperViewport
The controller.
changeLookAt (Optional)
Type: SystemBoolean
The change look at.
See Also

Reference

RotateHandler Class
VisualComponents.UX.Input Namespace


RotateHandler Properties

The RotateHandler type exposes the following members.

Properties
 | Name | Description
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Top
See Also

Reference

RotateHandler Class
VisualComponents.UX.Input Namespace


RotateHandler Methods

The RotateHandler type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | The can execute. (Overrides MouseGestureHandlerCanExecute.)
Public method | Completed | Occurs when the manipulation is completed. (Overrides MouseGestureHandlerCompleted(ManipulationEventArgs).)
Public method | Delta | Occurs when the position is changed during a manipulation. (Overrides MouseGestureHandlerDelta(ManipulationEventArgs).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LookAt | Change the "look-at" point.
Public method | OnLostMouseCapture | (Inherited from MouseGestureHandler.)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | Occurs when the manipulation is started. (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RotateHandler Class
VisualComponents.UX.Input Namespace


RotateHandler.CanExecute Method

RotateHandlerCanExecute Method

The can execute.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool CanExecute()
public:
virtual bool CanExecute() override

Return Value

Type: Boolean
True if the execution can continue.
See Also

Reference

RotateHandler Class
VisualComponents.UX.Input Namespace


RotateHandler.Completed Method

RotateHandlerCompleted Method

Occurs when the manipulation is completed.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Completed(
    ManipulationEventArgs e
)
public:
virtual void Completed(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
The ManipulationEventArgs instance containing the event data.
See Also

Reference

RotateHandler Class
VisualComponents.UX.Input Namespace


RotateHandler.Delta Method

RotateHandlerDelta Method

Occurs when the position is changed during a manipulation.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Delta(
    ManipulationEventArgs e
)
public:
virtual void Delta(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
The ManipulationEventArgs instance containing the event data.
See Also

Reference

RotateHandler Class
VisualComponents.UX.Input Namespace


RotateHandler.LookAt Method

RotateHandlerLookAt Method

Change the "look-at" point.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void LookAt(
    Point3D target,
    double animationTime
)
public:
void LookAt(
    Point3D target,
    double animationTime
)

Parameters

target
Type: System.Windows.Media.Media3DPoint3D
The target.
animationTime
Type: SystemDouble
The animation time.
See Also

Reference

RotateHandler Class
VisualComponents.UX.Input Namespace


RotateHandler.Started Method

RotateHandlerStarted Method

Occurs when the manipulation is started.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Started(
    ManipulationEventArgs e
)
public:
virtual void Started(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
The ManipulationEventArgs instance containing the event data.
See Also

Reference

RotateHandler Class
VisualComponents.UX.Input Namespace


SelectHandler Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.InputMouseGestureHandler
VisualComponents.UX.InputSelectHandler

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class SelectHandler : MouseGestureHandler
public ref class SelectHandler sealed : public MouseGestureHandler

The SelectHandler type exposes the following members.

Constructors
 | Name | Description
Public method | SelectHandler | Initializes a new instance of the SelectHandler class
Top
Properties
 | Name | Description
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Top
Methods
 | Name | Description
Public method | CanExecute | (Overrides MouseGestureHandlerCanExecute.)
Public method | Completed | (Overrides MouseGestureHandlerCompleted(ManipulationEventArgs).)
Public method | Delta | (Overrides MouseGestureHandlerDelta(ManipulationEventArgs).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnLostMouseCapture | (Inherited from MouseGestureHandler.)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


SelectHandler Constructor

Initializes a new instance of the SelectHandler class

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SelectHandler(
    HelperViewport controller,
    bool forMultiselect
)
public:
SelectHandler(
    HelperViewport^ controller,
    bool forMultiselect
)

Parameters

controller
Type: VisualComponents.UX.InputHelperViewport
forMultiselect
Type: SystemBoolean
See Also

Reference

SelectHandler Class
VisualComponents.UX.Input Namespace


SelectHandler Properties

The SelectHandler type exposes the following members.

Properties
 | Name | Description
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Top
See Also

Reference

SelectHandler Class
VisualComponents.UX.Input Namespace


SelectHandler Methods

The SelectHandler type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | (Overrides MouseGestureHandlerCanExecute.)
Public method | Completed | (Overrides MouseGestureHandlerCompleted(ManipulationEventArgs).)
Public method | Delta | (Overrides MouseGestureHandlerDelta(ManipulationEventArgs).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnLostMouseCapture | (Inherited from MouseGestureHandler.)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SelectHandler Class
VisualComponents.UX.Input Namespace


SelectHandler.CanExecute Method

SelectHandlerCanExecute Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool CanExecute()
public:
virtual bool CanExecute() override

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Input.SelectHandler.CanExecute"]

See Also

Reference

SelectHandler Class
VisualComponents.UX.Input Namespace


SelectHandler.Completed Method

SelectHandlerCompleted Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Completed(
    ManipulationEventArgs e
)
public:
virtual void Completed(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

SelectHandler Class
VisualComponents.UX.Input Namespace


SelectHandler.Delta Method

SelectHandlerDelta Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Delta(
    ManipulationEventArgs e
)
public:
virtual void Delta(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

SelectHandler Class
VisualComponents.UX.Input Namespace


SelectHandler.Started Method

SelectHandlerStarted Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Started(
    ManipulationEventArgs e
)
public:
virtual void Started(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

SelectHandler Class
VisualComponents.UX.Input Namespace


SelectParentHandler Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.InputMouseGestureHandler
VisualComponents.UX.InputSelectParentHandler

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SelectParentHandler : MouseGestureHandler
public ref class SelectParentHandler : public MouseGestureHandler

The SelectParentHandler type exposes the following members.

Constructors
 | Name | Description
Public method | SelectParentHandler | Initializes a new instance of the SelectParentHandler class
Top
Properties
 | Name | Description
Protected property | Application | (Inherited from MouseGestureHandler.)
Protected property | Camera | Gets the camera. (Inherited from MouseGestureHandler.)
Protected property | CameraMode | Gets the camera mode. (Inherited from MouseGestureHandler.)
Protected property | Controller | Gets or sets the controller. (Inherited from MouseGestureHandler.)
Protected property | EventMng | (Inherited from MouseGestureHandler.)
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Protected property | LastPoint | Gets or sets the last point (2D screen coordinates). (Inherited from MouseGestureHandler.)
Protected property | LastPoint3D | Gets or sets the last point (3D world coordinates). (Inherited from MouseGestureHandler.)
Protected property | ManipulateViewModel | (Inherited from MouseGestureHandler.)
Protected property | ManipulationWatch | Gets or sets the manipulation watch. (Inherited from MouseGestureHandler.)
Protected property | MouseDownNearestPoint3D | Gets or sets the mouse down point at the nearest hit element (3D world coordinates). (Inherited from MouseGestureHandler.)
Protected property | MouseDownPoint | Gets or sets the mouse down point (2D screen coordinates). (Inherited from MouseGestureHandler.)
Protected property | MouseDownPoint3D | Gets or sets the mouse down point (3D world coordinates). (Inherited from MouseGestureHandler.)
Protected property | ObjectSelectionMode | (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Protected property | RenderingService | (Inherited from MouseGestureHandler.)
Protected property | SimulationService | (Inherited from MouseGestureHandler.)
Protected property | TranslationRotationService | (Inherited from MouseGestureHandler.)
Protected property | Viewport | Gets the viewport. (Inherited from MouseGestureHandler.)
Protected property | ViewportHeight | Gets the height of the viewport. (Inherited from MouseGestureHandler.)
Protected property | ViewportWidth | Gets the width of the viewport. (Inherited from MouseGestureHandler.)
Top
Methods
 | Name | Description
Public method | CanExecute | Occurs when the command associated with this handler initiates a check to determine whether the command can be executed on the command target. (Inherited from MouseGestureHandler.)
Public method | Completed | Occurs when the manipulation is completed. (Inherited from MouseGestureHandler.)
Public method | Delta | Occurs when the position is changed during a manipulation. (Inherited from MouseGestureHandler.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCursor | (Overrides MouseGestureHandlerGetCursor.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetManipulationTarget(IEnumerableIVisualObject) | (Inherited from MouseGestureHandler.)
Protected method | GetManipulationTarget(IVisualObject) | (Inherited from MouseGestureHandler.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnInertiaStarting | Called when inertia is starting. (Inherited from MouseGestureHandler.)
Public method | OnLostMouseCapture | (Inherited from MouseGestureHandler.)
Protected method | OnMouseDown | Called when the mouse button is pressed down. (Inherited from MouseGestureHandler.)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _renderService | (Inherited from MouseGestureHandler.)
Protected field | _selectionManager | (Inherited from MouseGestureHandler.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


SelectParentHandler Constructor

Initializes a new instance of the SelectParentHandler class

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SelectParentHandler(
    HelperViewport helperViewport
)
public:
SelectParentHandler(
    HelperViewport^ helperViewport
)

Parameters

helperViewport
Type: VisualComponents.UX.InputHelperViewport
See Also

Reference

SelectParentHandler Class
VisualComponents.UX.Input Namespace


SelectParentHandler Properties

The SelectParentHandler type exposes the following members.

Properties
 | Name | Description
Protected property | Application | (Inherited from MouseGestureHandler.)
Protected property | Camera | Gets the camera. (Inherited from MouseGestureHandler.)
Protected property | CameraMode | Gets the camera mode. (Inherited from MouseGestureHandler.)
Protected property | Controller | Gets or sets the controller. (Inherited from MouseGestureHandler.)
Protected property | EventMng | (Inherited from MouseGestureHandler.)
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Protected property | LastPoint | Gets or sets the last point (2D screen coordinates). (Inherited from MouseGestureHandler.)
Protected property | LastPoint3D | Gets or sets the last point (3D world coordinates). (Inherited from MouseGestureHandler.)
Protected property | ManipulateViewModel | (Inherited from MouseGestureHandler.)
Protected property | ManipulationWatch | Gets or sets the manipulation watch. (Inherited from MouseGestureHandler.)
Protected property | MouseDownNearestPoint3D | Gets or sets the mouse down point at the nearest hit element (3D world coordinates). (Inherited from MouseGestureHandler.)
Protected property | MouseDownPoint | Gets or sets the mouse down point (2D screen coordinates). (Inherited from MouseGestureHandler.)
Protected property | MouseDownPoint3D | Gets or sets the mouse down point (3D world coordinates). (Inherited from MouseGestureHandler.)
Protected property | ObjectSelectionMode | (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Protected property | RenderingService | (Inherited from MouseGestureHandler.)
Protected property | SimulationService | (Inherited from MouseGestureHandler.)
Protected property | TranslationRotationService | (Inherited from MouseGestureHandler.)
Protected property | Viewport | Gets the viewport. (Inherited from MouseGestureHandler.)
Protected property | ViewportHeight | Gets the height of the viewport. (Inherited from MouseGestureHandler.)
Protected property | ViewportWidth | Gets the width of the viewport. (Inherited from MouseGestureHandler.)
Top
See Also

Reference

SelectParentHandler Class
VisualComponents.UX.Input Namespace


SelectParentHandler Methods

The SelectParentHandler type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Occurs when the command associated with this handler initiates a check to determine whether the command can be executed on the command target. (Inherited from MouseGestureHandler.)
Public method | Completed | Occurs when the manipulation is completed. (Inherited from MouseGestureHandler.)
Public method | Delta | Occurs when the position is changed during a manipulation. (Inherited from MouseGestureHandler.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCursor | (Overrides MouseGestureHandlerGetCursor.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetManipulationTarget(IEnumerableIVisualObject) | (Inherited from MouseGestureHandler.)
Protected method | GetManipulationTarget(IVisualObject) | (Inherited from MouseGestureHandler.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnInertiaStarting | Called when inertia is starting. (Inherited from MouseGestureHandler.)
Public method | OnLostMouseCapture | (Inherited from MouseGestureHandler.)
Protected method | OnMouseDown | Called when the mouse button is pressed down. (Inherited from MouseGestureHandler.)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SelectParentHandler Class
VisualComponents.UX.Input Namespace


SelectParentHandler.GetCursor Method

SelectParentHandlerGetCursor Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Cursor GetCursor()
protected:
virtual Cursor^ GetCursor() override

Return Value

Type: Cursor

[Missing <returns> documentation for "M:VisualComponents.UX.Input.SelectParentHandler.GetCursor"]

See Also

Reference

SelectParentHandler Class
VisualComponents.UX.Input Namespace


SelectParentHandler.Started Method

SelectParentHandlerStarted Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Started(
    ManipulationEventArgs e
)
public:
virtual void Started(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

SelectParentHandler Class
VisualComponents.UX.Input Namespace


SelectParentHandler Fields

The SelectParentHandler type exposes the following members.

Fields
 | Name | Description
Protected field | _renderService | (Inherited from MouseGestureHandler.)
Protected field | _selectionManager | (Inherited from MouseGestureHandler.)
Top
See Also

Reference

SelectParentHandler Class
VisualComponents.UX.Input Namespace


SetCenterOfInterestHandler Class

Handles rotation.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.InputMouseGestureHandler
VisualComponents.UX.InputSetCenterOfInterestHandler

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class SetCenterOfInterestHandler : MouseGestureHandler
public ref class SetCenterOfInterestHandler sealed : public MouseGestureHandler

The SetCenterOfInterestHandler type exposes the following members.

Constructors
 | Name | Description
Public method | SetCenterOfInterestHandler | Initializes a new instance of the SetCenterOfInterestHandler class
Top
Properties
 | Name | Description
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Top
Methods
 | Name | Description
Public method | CanExecute | (Overrides MouseGestureHandlerCanExecute.)
Public method | Completed | Occurs when the manipulation is completed. (Overrides MouseGestureHandlerCompleted(ManipulationEventArgs).)
Public method | Delta | (Overrides MouseGestureHandlerDelta(ManipulationEventArgs).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnLostMouseCapture | (Inherited from MouseGestureHandler.)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | Occurs when the manipulation is started. (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


SetCenterOfInterestHandler Constructor

Initializes a new instance of the SetCenterOfInterestHandler class

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetCenterOfInterestHandler(
    HelperViewport controller
)
public:
SetCenterOfInterestHandler(
    HelperViewport^ controller
)

Parameters

controller
Type: VisualComponents.UX.InputHelperViewport
See Also

Reference

SetCenterOfInterestHandler Class
VisualComponents.UX.Input Namespace


SetCenterOfInterestHandler Properties

The SetCenterOfInterestHandler type exposes the following members.

Properties
 | Name | Description
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Top
See Also

Reference

SetCenterOfInterestHandler Class
VisualComponents.UX.Input Namespace


SetCenterOfInterestHandler Methods

The SetCenterOfInterestHandler type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | (Overrides MouseGestureHandlerCanExecute.)
Public method | Completed | Occurs when the manipulation is completed. (Overrides MouseGestureHandlerCompleted(ManipulationEventArgs).)
Public method | Delta | (Overrides MouseGestureHandlerDelta(ManipulationEventArgs).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnLostMouseCapture | (Inherited from MouseGestureHandler.)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | Occurs when the manipulation is started. (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SetCenterOfInterestHandler Class
VisualComponents.UX.Input Namespace


SetCenterOfInterestHandler.CanExecute Method

SetCenterOfInterestHandlerCanExecute Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool CanExecute()
public:
virtual bool CanExecute() override

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Input.SetCenterOfInterestHandler.CanExecute"]

See Also

Reference

SetCenterOfInterestHandler Class
VisualComponents.UX.Input Namespace


SetCenterOfInterestHandler.Completed Method

SetCenterOfInterestHandlerCompleted Method

Occurs when the manipulation is completed.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Completed(
    ManipulationEventArgs e
)
public:
virtual void Completed(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
The ManipulationEventArgs instance containing the event data.
See Also

Reference

SetCenterOfInterestHandler Class
VisualComponents.UX.Input Namespace


SetCenterOfInterestHandler.Delta Method

SetCenterOfInterestHandlerDelta Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Delta(
    ManipulationEventArgs e
)
public:
virtual void Delta(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

SetCenterOfInterestHandler Class
VisualComponents.UX.Input Namespace


SetCenterOfInterestHandler.Started Method

SetCenterOfInterestHandlerStarted Method

Occurs when the manipulation is started.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Started(
    ManipulationEventArgs e
)
public:
virtual void Started(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
The ManipulationEventArgs instance containing the event data.
See Also

Reference

SetCenterOfInterestHandler Class
VisualComponents.UX.Input Namespace


ShowContextMenuHandler Class

Shows/hides right-click-menu in 3D window.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.InputMouseGestureHandler
VisualComponents.UX.InputShowContextMenuHandler

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ShowContextMenuHandler : MouseGestureHandler
public ref class ShowContextMenuHandler sealed : public MouseGestureHandler

The ShowContextMenuHandler type exposes the following members.

Constructors
 | Name | Description
Public method | ShowContextMenuHandler | Initializes a new instance of the ShowContextMenuHandler class
Top
Properties
 | Name | Description
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Top
Methods
 | Name | Description
Public method | CanExecute | (Overrides MouseGestureHandlerCanExecute.)
Public method | Completed | Occurs when the manipulation is completed. Note: PickAction is not sending BeginInteractionMessage message, because we don't want to trigger scene rendering. (Overrides MouseGestureHandlerCompleted(ManipulationEventArgs).)
Public method | Delta | (Overrides MouseGestureHandlerDelta(ManipulationEventArgs).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnLostMouseCapture | (Inherited from MouseGestureHandler.)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | Occurs when the manipulation is started. (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


ShowContextMenuHandler Constructor

Initializes a new instance of the ShowContextMenuHandler class

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ShowContextMenuHandler(
    HelperViewport controller
)
public:
ShowContextMenuHandler(
    HelperViewport^ controller
)

Parameters

controller
Type: VisualComponents.UX.InputHelperViewport
See Also

Reference

ShowContextMenuHandler Class
VisualComponents.UX.Input Namespace


ShowContextMenuHandler Properties

The ShowContextMenuHandler type exposes the following members.

Properties
 | Name | Description
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Top
See Also

Reference

ShowContextMenuHandler Class
VisualComponents.UX.Input Namespace


ShowContextMenuHandler Methods

The ShowContextMenuHandler type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | (Overrides MouseGestureHandlerCanExecute.)
Public method | Completed | Occurs when the manipulation is completed. Note: PickAction is not sending BeginInteractionMessage message, because we don't want to trigger scene rendering. (Overrides MouseGestureHandlerCompleted(ManipulationEventArgs).)
Public method | Delta | (Overrides MouseGestureHandlerDelta(ManipulationEventArgs).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnLostMouseCapture | (Inherited from MouseGestureHandler.)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | Occurs when the manipulation is started. (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ShowContextMenuHandler Class
VisualComponents.UX.Input Namespace


ShowContextMenuHandler.CanExecute Method

ShowContextMenuHandlerCanExecute Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool CanExecute()
public:
virtual bool CanExecute() override

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Input.ShowContextMenuHandler.CanExecute"]

See Also

Reference

ShowContextMenuHandler Class
VisualComponents.UX.Input Namespace


ShowContextMenuHandler.Completed Method

ShowContextMenuHandlerCompleted Method

Occurs when the manipulation is completed. Note: PickAction is not sending BeginInteractionMessage message, because we don't want to trigger scene rendering.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Completed(
    ManipulationEventArgs e
)
public:
virtual void Completed(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
The ManipulationEventArgs instance containing the event data.
See Also

Reference

ShowContextMenuHandler Class
VisualComponents.UX.Input Namespace


ShowContextMenuHandler.Delta Method

ShowContextMenuHandlerDelta Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Delta(
    ManipulationEventArgs e
)
public:
virtual void Delta(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

ShowContextMenuHandler Class
VisualComponents.UX.Input Namespace


ShowContextMenuHandler.Started Method

ShowContextMenuHandlerStarted Method

Occurs when the manipulation is started.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Started(
    ManipulationEventArgs e
)
public:
virtual void Started(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
The ManipulationEventArgs instance containing the event data.
See Also

Reference

ShowContextMenuHandler Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods Class

PInvoke calls to 3DConnexion spacemouse.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.InputSiAppNativeMethods

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SiAppNativeMethods
public ref class SiAppNativeMethods

The SiAppNativeMethods type exposes the following members.

Constructors
 | Name | Description
Public method | SiAppNativeMethods | Initializes a new instance of the SiAppNativeMethods class
Top
Methods
 | Name | Description
 | DispatchMessage |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetMessage |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SiButtonPressed |
 | SiClose |
 | SiGetButtonName |
 | SiGetDeviceInfo |
 | SiGetDeviceName |
 | SiGetDevicePort |
 | SiGetEvent |
 | SiGetEventEx |
 | SiGetEventWinInit |
 | SiGetNumDevices |
 | SiInitialize |
 | SiOpen |
 | SiOpenPort |
 | SiOpenWinInit |
 | SiRezero |
 | SiSetLEDs |
 | SiSetUiMode |
 | SiTerminate |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TranslateMessage |
Top
Fields
Name | Description
SI_ANY_DEVICE |
SI_AVERAGE_EVENTS |
SI_EVENT |
SI_NO_BUTTON |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


SiAppNativeMethods Constructor

Initializes a new instance of the SiAppNativeMethods class

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SiAppNativeMethods()
public:
SiAppNativeMethods()
See Also

Reference

SiAppNativeMethods Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods Methods

The SiAppNativeMethods type exposes the following members.

Methods
 | Name | Description
 | DispatchMessage |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetMessage |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SiButtonPressed |
 | SiClose |
 | SiGetButtonName |
 | SiGetDeviceInfo |
 | SiGetDeviceName |
 | SiGetDevicePort |
 | SiGetEvent |
 | SiGetEventEx |
 | SiGetEventWinInit |
 | SiGetNumDevices |
 | SiInitialize |
 | SiOpen |
 | SiOpenPort |
 | SiOpenWinInit |
 | SiRezero |
 | SiSetLEDs |
 | SiSetUiMode |
 | SiTerminate |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TranslateMessage |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SiAppNativeMethods Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods.DispatchMessage Method

SiAppNativeMethodsDispatchMessage Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IntPtr DispatchMessage(
    ref SiAppNativeMethodsMSG lpmsg
)
public:
static IntPtr DispatchMessage(
    [InAttribute] SiAppNativeMethodsMSG% lpmsg
)

Parameters

lpmsg
Type: VisualComponents.UX.InputSiAppNativeMethodsMSG

Return Value

Type: IntPtr

[Missing <returns> documentation for "M:VisualComponents.UX.Input.SiAppNativeMethods.DispatchMessage(VisualComponents.UX.Input.SiAppNativeMethods.MSG@)"]

See Also

Reference

SiAppNativeMethods Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods.GetMessage Method

SiAppNativeMethodsGetMessage Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static sbyte GetMessage(
    out SiAppNativeMethodsMSG lpMsg,
    IntPtr hWnd,
    uint wMsgFilterMin,
    uint wMsgFilterMax
)
public:
static signed char GetMessage(
    [OutAttribute] SiAppNativeMethodsMSG% lpMsg,
    IntPtr hWnd,
    unsigned int wMsgFilterMin,
    unsigned int wMsgFilterMax
)

Parameters

lpMsg
Type: VisualComponents.UX.InputSiAppNativeMethodsMSG
hWnd
Type: SystemIntPtr
wMsgFilterMin
Type: SystemUInt32
wMsgFilterMax
Type: SystemUInt32

Return Value

Type: SByte

[Missing <returns> documentation for "M:VisualComponents.UX.Input.SiAppNativeMethods.GetMessage(VisualComponents.UX.Input.SiAppNativeMethods.MSG@,System.IntPtr,System.UInt32,System.UInt32)"]

See Also

Reference

SiAppNativeMethods Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiButtonPressed Method

SiAppNativeMethodsSiButtonPressed Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int SiButtonPressed(
    ref SiAppNativeMethodsSiSpwEvent_SpwData pEvent
)
public:
static int SiButtonPressed(
    SiAppNativeMethodsSiSpwEvent_SpwData% pEvent
)

Parameters

pEvent
Type: VisualComponents.UX.InputSiAppNativeMethodsSiSpwEvent_SpwData

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Input.SiAppNativeMethods.SiButtonPressed(VisualComponents.UX.Input.SiAppNativeMethods.SiSpwEvent_SpwData@)"]

See Also

Reference

SiAppNativeMethods Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiClose Method

SiAppNativeMethodsSiClose Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static SiAppNativeMethodsSpwRetVal SiClose(
    IntPtr hdl
)
public:
static SiAppNativeMethodsSpwRetVal SiClose(
    IntPtr hdl
)

Parameters

hdl
Type: SystemIntPtr

Return Value

Type: SiAppNativeMethodsSpwRetVal

[Missing <returns> documentation for "M:VisualComponents.UX.Input.SiAppNativeMethods.SiClose(System.IntPtr)"]

See Also

Reference

SiAppNativeMethods Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiGetButtonName Method

SiAppNativeMethodsSiGetButtonName Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static SiAppNativeMethodsSpwRetVal SiGetButtonName(
    IntPtr hdl,
    uint buttonNumber,
    out string name
)
public:
static SiAppNativeMethodsSpwRetVal SiGetButtonName(
    IntPtr hdl,
    unsigned int buttonNumber,
    [OutAttribute] String^% name
)

Parameters

hdl
Type: SystemIntPtr
buttonNumber
Type: SystemUInt32
name
Type: SystemString

Return Value

Type: SiAppNativeMethodsSpwRetVal

[Missing <returns> documentation for "M:VisualComponents.UX.Input.SiAppNativeMethods.SiGetButtonName(System.IntPtr,System.UInt32,System.String@)"]

See Also

Reference

SiAppNativeMethods Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiGetDeviceInfo Method

SiAppNativeMethodsSiGetDeviceInfo Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static SiAppNativeMethodsSpwRetVal SiGetDeviceInfo(
    IntPtr hdl,
    ref SiAppNativeMethodsSiDevInfo pInfo
)
public:
static SiAppNativeMethodsSpwRetVal SiGetDeviceInfo(
    IntPtr hdl,
    SiAppNativeMethodsSiDevInfo% pInfo
)

Parameters

hdl
Type: SystemIntPtr
pInfo
Type: VisualComponents.UX.InputSiAppNativeMethodsSiDevInfo

Return Value

Type: SiAppNativeMethodsSpwRetVal

[Missing <returns> documentation for "M:VisualComponents.UX.Input.SiAppNativeMethods.SiGetDeviceInfo(System.IntPtr,VisualComponents.UX.Input.SiAppNativeMethods.SiDevInfo@)"]

See Also

Reference

SiAppNativeMethods Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiGetDeviceName Method

SiAppNativeMethodsSiGetDeviceName Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static SiAppNativeMethodsSpwRetVal SiGetDeviceName(
    IntPtr hdl,
    out string name
)
public:
static SiAppNativeMethodsSpwRetVal SiGetDeviceName(
    IntPtr hdl,
    [OutAttribute] String^% name
)

Parameters

hdl
Type: SystemIntPtr
name
Type: SystemString

Return Value

Type: SiAppNativeMethodsSpwRetVal

[Missing <returns> documentation for "M:VisualComponents.UX.Input.SiAppNativeMethods.SiGetDeviceName(System.IntPtr,System.String@)"]

See Also

Reference

SiAppNativeMethods Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiGetDevicePort Method

SiAppNativeMethodsSiGetDevicePort Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static SiAppNativeMethodsSpwRetVal SiGetDevicePort(
    IntPtr hdl,
    ref SiAppNativeMethodsSiDevPort pPort
)
public:
static SiAppNativeMethodsSpwRetVal SiGetDevicePort(
    IntPtr hdl,
    SiAppNativeMethodsSiDevPort% pPort
)

Parameters

hdl
Type: SystemIntPtr
pPort
Type: VisualComponents.UX.InputSiAppNativeMethodsSiDevPort

Return Value

Type: SiAppNativeMethodsSpwRetVal

[Missing <returns> documentation for "M:VisualComponents.UX.Input.SiAppNativeMethods.SiGetDevicePort(System.IntPtr,VisualComponents.UX.Input.SiAppNativeMethods.SiDevPort@)"]

See Also

Reference

SiAppNativeMethods Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiGetEvent Method

SiAppNativeMethodsSiGetEvent Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static SiAppNativeMethodsSpwRetVal SiGetEvent(
    IntPtr hdl,
    int flags,
    ref SiAppNativeMethodsSiGetEventData pData,
    IntPtr pEvent
)
public:
static SiAppNativeMethodsSpwRetVal SiGetEvent(
    IntPtr hdl,
    int flags,
    SiAppNativeMethodsSiGetEventData% pData,
    IntPtr pEvent
)

Parameters

hdl
Type: SystemIntPtr
flags
Type: SystemInt32
pData
Type: VisualComponents.UX.InputSiAppNativeMethodsSiGetEventData
pEvent
Type: SystemIntPtr

Return Value

Type: SiAppNativeMethodsSpwRetVal

[Missing <returns> documentation for "M:VisualComponents.UX.Input.SiAppNativeMethods.SiGetEvent(System.IntPtr,System.Int32,VisualComponents.UX.Input.SiAppNativeMethods.SiGetEventData@,System.IntPtr)"]

See Also

Reference

SiAppNativeMethods Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiGetEventEx Method

SiAppNativeMethodsSiGetEventEx Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool SiGetEventEx(
    IntPtr hdl,
    int flags,
    ref int msg,
    ref IntPtr wParam,
    ref IntPtr lParam,
    ref SiAppNativeMethodsSiSpwEvent_SpwData mouseEvent
)
public:
static bool SiGetEventEx(
    IntPtr hdl,
    int flags,
    int% msg,
    IntPtr% wParam,
    IntPtr% lParam,
    SiAppNativeMethodsSiSpwEvent_SpwData% mouseEvent
)

Parameters

hdl
Type: SystemIntPtr
flags
Type: SystemInt32
msg
Type: SystemInt32
wParam
Type: SystemIntPtr
lParam
Type: SystemIntPtr
mouseEvent
Type: VisualComponents.UX.InputSiAppNativeMethodsSiSpwEvent_SpwData

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Input.SiAppNativeMethods.SiGetEventEx(System.IntPtr,System.Int32,System.Int32@,System.IntPtr@,System.IntPtr@,VisualComponents.UX.Input.SiAppNativeMethods.SiSpwEvent_SpwData@)"]

See Also

Reference

SiAppNativeMethods Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiGetEventWinInit Method

SiAppNativeMethodsSiGetEventWinInit Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SiGetEventWinInit(
    ref SiAppNativeMethodsSiGetEventData pData,
    int msg,
    IntPtr wParam,
    IntPtr lParam
)
public:
static void SiGetEventWinInit(
    SiAppNativeMethodsSiGetEventData% pData,
    int msg,
    IntPtr wParam,
    IntPtr lParam
)

Parameters

pData
Type: VisualComponents.UX.InputSiAppNativeMethodsSiGetEventData
msg
Type: SystemInt32
wParam
Type: SystemIntPtr
lParam
Type: SystemIntPtr
See Also

Reference

SiAppNativeMethods Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiGetNumDevices Method

SiAppNativeMethodsSiGetNumDevices Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int SiGetNumDevices()
public:
static int SiGetNumDevices()

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Input.SiAppNativeMethods.SiGetNumDevices"]

See Also

Reference

SiAppNativeMethods Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiInitialize Method

SiAppNativeMethodsSiInitialize Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static SiAppNativeMethodsSpwRetVal SiInitialize()
public:
static SiAppNativeMethodsSpwRetVal SiInitialize()

Return Value

Type: SiAppNativeMethodsSpwRetVal

[Missing <returns> documentation for "M:VisualComponents.UX.Input.SiAppNativeMethods.SiInitialize"]

See Also

Reference

SiAppNativeMethods Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiOpen Method

SiAppNativeMethodsSiOpen Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IntPtr SiOpen(
    string pAppName,
    int devID,
    IntPtr pTMask,
    int mode,
    ref SiAppNativeMethodsSiOpenData pData
)
public:
static IntPtr SiOpen(
    String^ pAppName,
    int devID,
    IntPtr pTMask,
    int mode,
    SiAppNativeMethodsSiOpenData% pData
)

Parameters

pAppName
Type: SystemString
devID
Type: SystemInt32
pTMask
Type: SystemIntPtr
mode
Type: SystemInt32
pData
Type: VisualComponents.UX.InputSiAppNativeMethodsSiOpenData

Return Value

Type: IntPtr

[Missing <returns> documentation for "M:VisualComponents.UX.Input.SiAppNativeMethods.SiOpen(System.String,System.Int32,System.IntPtr,System.Int32,VisualComponents.UX.Input.SiAppNativeMethods.SiOpenData@)"]

See Also

Reference

SiAppNativeMethods Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiOpenPort Method

SiAppNativeMethodsSiOpenPort Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IntPtr SiOpenPort(
    string pAppName,
    ref SiAppNativeMethodsSiDevPort pPort,
    int mode,
    ref SiAppNativeMethodsSiOpenData pData
)
public:
static IntPtr SiOpenPort(
    String^ pAppName,
    SiAppNativeMethodsSiDevPort% pPort,
    int mode,
    SiAppNativeMethodsSiOpenData% pData
)

Parameters

pAppName
Type: SystemString
pPort
Type: VisualComponents.UX.InputSiAppNativeMethodsSiDevPort
mode
Type: SystemInt32
pData
Type: VisualComponents.UX.InputSiAppNativeMethodsSiOpenData

Return Value

Type: IntPtr

[Missing <returns> documentation for "M:VisualComponents.UX.Input.SiAppNativeMethods.SiOpenPort(System.String,VisualComponents.UX.Input.SiAppNativeMethods.SiDevPort@,System.Int32,VisualComponents.UX.Input.SiAppNativeMethods.SiOpenData@)"]

See Also

Reference

SiAppNativeMethods Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiOpenWinInit Method

SiAppNativeMethodsSiOpenWinInit Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int SiOpenWinInit(
    ref SiAppNativeMethodsSiOpenData o,
    int hwnd
)
public:
static int SiOpenWinInit(
    SiAppNativeMethodsSiOpenData% o,
    int hwnd
)

Parameters

o
Type: VisualComponents.UX.InputSiAppNativeMethodsSiOpenData
hwnd
Type: SystemInt32

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Input.SiAppNativeMethods.SiOpenWinInit(VisualComponents.UX.Input.SiAppNativeMethods.SiOpenData@,System.Int32)"]

See Also

Reference

SiAppNativeMethods Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiRezero Method

SiAppNativeMethodsSiRezero Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static SiAppNativeMethodsSpwRetVal SiRezero(
    IntPtr hdl
)
public:
static SiAppNativeMethodsSpwRetVal SiRezero(
    IntPtr hdl
)

Parameters

hdl
Type: SystemIntPtr

Return Value

Type: SiAppNativeMethodsSpwRetVal

[Missing <returns> documentation for "M:VisualComponents.UX.Input.SiAppNativeMethods.SiRezero(System.IntPtr)"]

See Also

Reference

SiAppNativeMethods Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiSetLEDs Method

SiAppNativeMethodsSiSetLEDs Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static SiAppNativeMethodsSpwRetVal SiSetLEDs(
    IntPtr hdl,
    long mask
)
public:
static SiAppNativeMethodsSpwRetVal SiSetLEDs(
    IntPtr hdl,
    long long mask
)

Parameters

hdl
Type: SystemIntPtr
mask
Type: SystemInt64

Return Value

Type: SiAppNativeMethodsSpwRetVal

[Missing <returns> documentation for "M:VisualComponents.UX.Input.SiAppNativeMethods.SiSetLEDs(System.IntPtr,System.Int64)"]

See Also

Reference

SiAppNativeMethods Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiSetUiMode Method

SiAppNativeMethodsSiSetUiMode Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static SiAppNativeMethodsSpwRetVal SiSetUiMode(
    IntPtr hdl,
    long mode
)
public:
static SiAppNativeMethodsSpwRetVal SiSetUiMode(
    IntPtr hdl,
    long long mode
)

Parameters

hdl
Type: SystemIntPtr
mode
Type: SystemInt64

Return Value

Type: SiAppNativeMethodsSpwRetVal

[Missing <returns> documentation for "M:VisualComponents.UX.Input.SiAppNativeMethods.SiSetUiMode(System.IntPtr,System.Int64)"]

See Also

Reference

SiAppNativeMethods Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiTerminate Method

SiAppNativeMethodsSiTerminate Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int SiTerminate()
public:
static int SiTerminate()

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Input.SiAppNativeMethods.SiTerminate"]

See Also

Reference

SiAppNativeMethods Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods.TranslateMessage Method

SiAppNativeMethodsTranslateMessage Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool TranslateMessage(
    ref SiAppNativeMethodsMSG m
)
public:
static bool TranslateMessage(
    [InAttribute] SiAppNativeMethodsMSG% m
)

Parameters

m
Type: VisualComponents.UX.InputSiAppNativeMethodsMSG

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Input.SiAppNativeMethods.TranslateMessage(VisualComponents.UX.Input.SiAppNativeMethods.MSG@)"]

See Also

Reference

SiAppNativeMethods Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods Fields

The SiAppNativeMethods type exposes the following members.

Fields
Name | Description
SI_ANY_DEVICE |
SI_AVERAGE_EVENTS |
SI_EVENT |
SI_NO_BUTTON |
Top
See Also

Reference

SiAppNativeMethods Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SI_ANY_DEVICE Field

SiAppNativeMethodsSI_ANY_DEVICE Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int SI_ANY_DEVICE = -1
public:
literal int SI_ANY_DEVICE = -1

Field Value

Type: Int32
See Also

Reference

SiAppNativeMethods Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SI_AVERAGE_EVENTS Field

SiAppNativeMethodsSI_AVERAGE_EVENTS Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int SI_AVERAGE_EVENTS = 1
public:
literal int SI_AVERAGE_EVENTS = 1

Field Value

Type: Int32
See Also

Reference

SiAppNativeMethods Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SI_EVENT Field

SiAppNativeMethodsSI_EVENT Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int SI_EVENT = 1
public:
literal int SI_EVENT = 1

Field Value

Type: Int32
See Also

Reference

SiAppNativeMethods Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SI_NO_BUTTON Field

SiAppNativeMethodsSI_NO_BUTTON Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int SI_NO_BUTTON = -1
public:
literal int SI_NO_BUTTON = -1

Field Value

Type: Int32
See Also

Reference

SiAppNativeMethods Class
VisualComponents.UX.Input Namespace


SiAppNativeMethods.MSG Structure

SiAppNativeMethodsMSG Structure

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct MSG
public value class MSG

The SiAppNativeMethodsMSG type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | hwnd |
Public field | lParam |
Public field | message |
Public field | pointX |
Public field | pointY |
Public field | time |
Public field | wParam |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


MSG Methods

The SiAppNativeMethodsMSG type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SiAppNativeMethodsMSG Structure
VisualComponents.UX.Input Namespace


MSG Fields

The SiAppNativeMethodsMSG type exposes the following members.

Fields
 | Name | Description
Public field | hwnd |
Public field | lParam |
Public field | message |
Public field | pointX |
Public field | pointY |
Public field | time |
Public field | wParam |
Top
See Also

Reference

SiAppNativeMethodsMSG Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.MSG.hwnd Field

SiAppNativeMethodsMSGhwnd Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IntPtr hwnd
public:
IntPtr hwnd

Field Value

Type: IntPtr
See Also

Reference

SiAppNativeMethodsMSG Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.MSG.lParam Field

SiAppNativeMethodsMSGlParam Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IntPtr lParam
public:
IntPtr lParam

Field Value

Type: IntPtr
See Also

Reference

SiAppNativeMethodsMSG Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.MSG.message Field

SiAppNativeMethodsMSGmessage Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int message
public:
int message

Field Value

Type: Int32
See Also

Reference

SiAppNativeMethodsMSG Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.MSG.pointX Field

SiAppNativeMethodsMSGpointX Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int pointX
public:
int pointX

Field Value

Type: Int32
See Also

Reference

SiAppNativeMethodsMSG Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.MSG.pointY Field

SiAppNativeMethodsMSGpointY Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int pointY
public:
int pointY

Field Value

Type: Int32
See Also

Reference

SiAppNativeMethodsMSG Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.MSG.time Field

SiAppNativeMethodsMSGtime Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint time
public:
unsigned int time

Field Value

Type: UInt32
See Also

Reference

SiAppNativeMethodsMSG Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.MSG.wParam Field

SiAppNativeMethodsMSGwParam Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IntPtr wParam
public:
IntPtr wParam

Field Value

Type: IntPtr
See Also

Reference

SiAppNativeMethodsMSG Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiButtonData Structure

SiAppNativeMethodsSiButtonData Structure

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct SiButtonData
public value class SiButtonData

The SiAppNativeMethodsSiButtonData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | current |
Public field | last |
Public field | pressed |
Public field | released |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


SiButtonData Methods

The SiAppNativeMethodsSiButtonData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SiAppNativeMethodsSiButtonData Structure
VisualComponents.UX.Input Namespace


SiButtonData Fields

The SiAppNativeMethodsSiButtonData type exposes the following members.

Fields
 | Name | Description
Public field | current |
Public field | last |
Public field | pressed |
Public field | released |
Top
See Also

Reference

SiAppNativeMethodsSiButtonData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiButtonData.current Field

SiAppNativeMethodsSiButtonDatacurrent Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint current
public:
unsigned int current

Field Value

Type: UInt32
See Also

Reference

SiAppNativeMethodsSiButtonData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiButtonData.last Field

SiAppNativeMethodsSiButtonDatalast Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint last
public:
unsigned int last

Field Value

Type: UInt32
See Also

Reference

SiAppNativeMethodsSiButtonData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiButtonData.pressed Field

SiAppNativeMethodsSiButtonDatapressed Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint pressed
public:
unsigned int pressed

Field Value

Type: UInt32
See Also

Reference

SiAppNativeMethodsSiButtonData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiButtonData.released Field

SiAppNativeMethodsSiButtonDatareleased Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint released
public:
unsigned int released

Field Value

Type: UInt32
See Also

Reference

SiAppNativeMethodsSiButtonData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiButtonName Structure

SiAppNativeMethodsSiButtonName Structure

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct SiButtonName
public value class SiButtonName

The SiAppNativeMethodsSiButtonName type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | name |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


SiButtonName Methods

The SiAppNativeMethodsSiButtonName type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SiAppNativeMethodsSiButtonName Structure
VisualComponents.UX.Input Namespace


SiButtonName Fields

The SiAppNativeMethodsSiButtonName type exposes the following members.

Fields
 | Name | Description
Public field | name |
Top
See Also

Reference

SiAppNativeMethodsSiButtonName Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiButtonName.name Field

SiAppNativeMethodsSiButtonNamename Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string name
public:
String^ name

Field Value

Type: String
See Also

Reference

SiAppNativeMethodsSiButtonName Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiCmdType Enumeration

SiAppNativeMethodsSiCmdType Enumeration

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum SiCmdType
public enum class SiCmdType
Members
Member name | Value | Description
V3DCMD_NOOP | 0 |
V3DCMD_MENU_OPTIONS | 1 |
V3DCMD_VIEW_FIT | 2 |
V3DCMD_VIEW_TOP | 3 |
V3DCMD_VIEW_LEFT | 4 |
V3DCMD_VIEW_RIGHT | 5 |
V3DCMD_VIEW_FRONT | 6 |
V3DCMD_VIEW_BOTTOM | 7 |
V3DCMD_VIEW_BACK | 8 |
V3DCMD_VIEW_ROLLCW | 9 |
V3DCMD_VIEW_ROLLCCW | 10 |
V3DCMD_VIEW_ISO1 | 11 |
V3DCMD_VIEW_ISO2 | 12 |
V3DCMD_KEY_F1 | 13 |
V3DCMD_KEY_F2 | 14 |
V3DCMD_KEY_F3 | 15 |
V3DCMD_KEY_F4 | 16 |
V3DCMD_KEY_F5 | 17 |
V3DCMD_KEY_F6 | 18 |
V3DCMD_KEY_F7 | 19 |
V3DCMD_KEY_F8 | 20 |
V3DCMD_KEY_F9 | 21 |
V3DCMD_KEY_F10 | 22 |
V3DCMD_KEY_F11 | 23 |
V3DCMD_KEY_F12 | 24 |
V3DCMD_KEY_ESC | 25 |
V3DCMD_KEY_ALT | 26 |
V3DCMD_KEY_SHIFT | 27 |
V3DCMD_KEY_CTRL | 28 |
V3DCMD_FILTER_ROTATE | 29 |
V3DCMD_FILTER_PANZOOM | 30 |
V3DCMD_FILTER_DOMINANT | 31 |
V3DCMD_SCALE_PLUS | 32 |
V3DCMD_SCALE_MINUS | 33 |
V3DCMD_VIEW_SPINCW | 34 |
V3DCMD_VIEW_SPINCCW | 35 |
V3DCMD_VIEW_TILTCW | 36 |
V3DCMD_VIEW_TILTCCW | 37 |
V3DCMD_MENU_POPUP | 38 |
V3DCMD_MENU_BUTTONMAPPINGEDITOR | 39 |
V3DCMD_MENU_ADVANCEDSETTINGSEDITOR | 40 |
V3DCMD_MOTIONMACRO_ZOOM | 41 |
V3DCMD_MOTIONMACRO_ZOOMOUT_CURSORTOCENTER | 42 |
V3DCMD_MOTIONMACRO_ZOOMIN_CURSORTOCENTER | 43 |
V3DCMD_MOTIONMACRO_ZOOMOUT_CENTERTOCENTER | 44 |
V3DCMD_MOTIONMACRO_ZOOMIN_CENTERTOCENTER | 45 |
V3DCMD_MOTIONMACRO_ZOOMOUT_CURSORTOCURSOR | 46 |
V3DCMD_MOTIONMACRO_ZOOMIN_CURSORTOCURSOR | 47 |
V3DCMD_VIEW_QZ_IN | 48 |
V3DCMD_VIEW_QZ_OUT | 49 |
See Also

Reference

VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiDeviceChangeEventData Structure

SiAppNativeMethodsSiDeviceChangeEventData Structure

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct SiDeviceChangeEventData
public value class SiDeviceChangeEventData

The SiAppNativeMethodsSiDeviceChangeEventData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | devID |
Public field | portName |
Public field | type |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


SiDeviceChangeEventData Methods

The SiAppNativeMethodsSiDeviceChangeEventData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SiAppNativeMethodsSiDeviceChangeEventData Structure
VisualComponents.UX.Input Namespace


SiDeviceChangeEventData Fields

The SiAppNativeMethodsSiDeviceChangeEventData type exposes the following members.

Fields
 | Name | Description
Public field | devID |
Public field | portName |
Public field | type |
Top
See Also

Reference

SiAppNativeMethodsSiDeviceChangeEventData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiDeviceChangeEventData.devID Field

SiAppNativeMethodsSiDeviceChangeEventDatadevID Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int devID
public:
int devID

Field Value

Type: Int32
See Also

Reference

SiAppNativeMethodsSiDeviceChangeEventData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiDeviceChangeEventData.portName Field

SiAppNativeMethodsSiDeviceChangeEventDataportName Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SiAppNativeMethodsSiPortName portName
public:
SiAppNativeMethodsSiPortName portName

Field Value

Type: SiAppNativeMethodsSiPortName
See Also

Reference

SiAppNativeMethodsSiDeviceChangeEventData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiDeviceChangeEventData.type Field

SiAppNativeMethodsSiDeviceChangeEventDatatype Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int type
public:
int type

Field Value

Type: Int32
See Also

Reference

SiAppNativeMethodsSiDeviceChangeEventData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiDeviceChangeType Enumeration

SiAppNativeMethodsSiDeviceChangeType Enumeration

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum SiDeviceChangeType
public enum class SiDeviceChangeType
Members
Member name | Value | Description
SI_DEVICE_CHANGE_CONNECT | 0 |
SI_DEVICE_CHANGE_DISCONNECT | 1 |
See Also

Reference

VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiDeviceName Structure

SiAppNativeMethodsSiDeviceName Structure

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct SiDeviceName
public value class SiDeviceName

The SiAppNativeMethodsSiDeviceName type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | name |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


SiDeviceName Methods

The SiAppNativeMethodsSiDeviceName type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SiAppNativeMethodsSiDeviceName Structure
VisualComponents.UX.Input Namespace


SiDeviceName Fields

The SiAppNativeMethodsSiDeviceName type exposes the following members.

Fields
 | Name | Description
Public field | name |
Top
See Also

Reference

SiAppNativeMethodsSiDeviceName Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiDeviceName.name Field

SiAppNativeMethodsSiDeviceNamename Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string name
public:
String^ name

Field Value

Type: String
See Also

Reference

SiAppNativeMethodsSiDeviceName Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiDevInfo Structure

SiAppNativeMethodsSiDevInfo Structure

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct SiDevInfo
public value class SiDevInfo

The SiAppNativeMethodsSiDevInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | canBeep |
Public field | devType |
Public field | firmware |
Public field | majorVersion |
Public field | minorVersion |
Public field | numButtons |
Public field | numDegrees |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


SiDevInfo Methods

The SiAppNativeMethodsSiDevInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SiAppNativeMethodsSiDevInfo Structure
VisualComponents.UX.Input Namespace


SiDevInfo Fields

The SiAppNativeMethodsSiDevInfo type exposes the following members.

Fields
 | Name | Description
Public field | canBeep |
Public field | devType |
Public field | firmware |
Public field | majorVersion |
Public field | minorVersion |
Public field | numButtons |
Public field | numDegrees |
Top
See Also

Reference

SiAppNativeMethodsSiDevInfo Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiDevInfo.canBeep Field

SiAppNativeMethodsSiDevInfocanBeep Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int canBeep
public:
int canBeep

Field Value

Type: Int32
See Also

Reference

SiAppNativeMethodsSiDevInfo Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiDevInfo.devType Field

SiAppNativeMethodsSiDevInfodevType Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int devType
public:
int devType

Field Value

Type: Int32
See Also

Reference

SiAppNativeMethodsSiDevInfo Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiDevInfo.firmware Field

SiAppNativeMethodsSiDevInfofirmware Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string firmware
public:
String^ firmware

Field Value

Type: String
See Also

Reference

SiAppNativeMethodsSiDevInfo Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiDevInfo.majorVersion Field

SiAppNativeMethodsSiDevInfomajorVersion Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int majorVersion
public:
int majorVersion

Field Value

Type: Int32
See Also

Reference

SiAppNativeMethodsSiDevInfo Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiDevInfo.minorVersion Field

SiAppNativeMethodsSiDevInfominorVersion Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int minorVersion
public:
int minorVersion

Field Value

Type: Int32
See Also

Reference

SiAppNativeMethodsSiDevInfo Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiDevInfo.numButtons Field

SiAppNativeMethodsSiDevInfonumButtons Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int numButtons
public:
int numButtons

Field Value

Type: Int32
See Also

Reference

SiAppNativeMethodsSiDevInfo Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiDevInfo.numDegrees Field

SiAppNativeMethodsSiDevInfonumDegrees Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int numDegrees
public:
int numDegrees

Field Value

Type: Int32
See Also

Reference

SiAppNativeMethodsSiDevInfo Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiDevPort Structure

SiAppNativeMethodsSiDevPort Structure

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct SiDevPort
public value class SiDevPort

The SiAppNativeMethodsSiDevPort type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | devClass |
Public field | devID |
Public field | devName |
Public field | devType |
Public field | portName |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


SiDevPort Methods

The SiAppNativeMethodsSiDevPort type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SiAppNativeMethodsSiDevPort Structure
VisualComponents.UX.Input Namespace


SiDevPort Fields

The SiAppNativeMethodsSiDevPort type exposes the following members.

Fields
 | Name | Description
Public field | devClass |
Public field | devID |
Public field | devName |
Public field | devType |
Public field | portName |
Top
See Also

Reference

SiAppNativeMethodsSiDevPort Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiDevPort.devClass Field

SiAppNativeMethodsSiDevPortdevClass Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int devClass
public:
int devClass

Field Value

Type: Int32
See Also

Reference

SiAppNativeMethodsSiDevPort Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiDevPort.devID Field

SiAppNativeMethodsSiDevPortdevID Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int devID
public:
int devID

Field Value

Type: Int32
See Also

Reference

SiAppNativeMethodsSiDevPort Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiDevPort.devName Field

SiAppNativeMethodsSiDevPortdevName Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string devName
public:
String^ devName

Field Value

Type: String
See Also

Reference

SiAppNativeMethodsSiDevPort Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiDevPort.devType Field

SiAppNativeMethodsSiDevPortdevType Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int devType
public:
int devType

Field Value

Type: Int32
See Also

Reference

SiAppNativeMethodsSiDevPort Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiDevPort.portName Field

SiAppNativeMethodsSiDevPortportName Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string portName
public:
String^ portName

Field Value

Type: String
See Also

Reference

SiAppNativeMethodsSiDevPort Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiDevType Enumeration

SiAppNativeMethodsSiDevType Enumeration

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum SiDevType
public enum class SiDevType
Members
Member name | Value | Description
SI_UNKNOWN_DEVICE | 0 |
SI_SPACEBALL_2003 | 1 |
SI_SPACEBALL_3003 | 2 |
SI_SPACE_CONTROLLER | 3 |
SI_SPACEEXPLORER | 4 |
SI_SPACENAVIGATOR_FOR_NOTEBOOKS | 5 |
SI_SPACENAVIGATOR | 6 |
SI_SPACEBALL_2003A | 7 |
SI_SPACEBALL_2003B | 8 |
SI_SPACEBALL_2003C | 9 |
SI_SPACEBALL_3003A | 10 |
SI_SPACEBALL_3003B | 11 |
SI_SPACEBALL_3003C | 12 |
SI_SPACEBALL_4000 | 13 |
SI_SPACEMOUSE_CLASSIC | 14 |
SI_SPACEMOUSE_PLUS | 15 |
SI_SPACEMOUSE_XT | 16 |
SI_CYBERMAN | 17 |
SI_CADMAN | 18 |
SI_SPACEMOUSE_CLASSIC_PROMO | 19 |
SI_SERIAL_CADMAN | 20 |
SI_SPACEBALL_5000 | 21 |
SI_TEST_NO_DEVICE | 22 |
SI_3DX_KEYBOARD_BLACK | 23 |
SI_3DX_KEYBOARD_WHITE | 24 |
SI_TRAVELER | 25 |
SI_TRAVELER1 | 26 |
SI_SPACEBALL_5000A | 27 |
SI_SPACEDRAGON | 28 |
SI_SPACEPILOT | 29 |
SI_MB | 30 |
SI_SPACEPILOT_PRO | 50729 |
SI_SPACEMOUSE_PRO | 50731 |
SI_SPACEMOUSE_TOUCH | 50732 |
SI_SPACEMOUSE_WIRELESS | 50734 |
See Also

Reference

VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiEventType Enumeration

SiAppNativeMethodsSiEventType Enumeration

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum SiEventType
public enum class SiEventType
Members
Member name | Value | Description
SI_BUTTON_EVENT | 1 |
SI_MOTION_EVENT | 2 |
SI_COMBO_EVENT | 3 |
SI_ZERO_EVENT | 4 |
SI_EXCEPTION_EVENT | 5 |
SI_OUT_OF_BAND | 6 |
SI_ORIENTATION_EVENT | 7 |
SI_KEYBOARD_EVENT | 8 |
SI_LPFK_EVENT | 9 |
SI_APP_EVENT | 10 |
SI_SYNC_EVENT | 11 |
SI_BUTTON_PRESS_EVENT | 12 |
SI_BUTTON_RELEASE_EVENT | 13 |
SI_DEVICE_CHANGE_EVENT | 14 |
SI_MOUSE_EVENT | 15 |
SI_JOYSTICK_EVENT | 16 |
SI_CMD_EVENT | 17 |
See Also

Reference

VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiGetEventData Structure

SiAppNativeMethodsSiGetEventData Structure

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct SiGetEventData
public value class SiGetEventData

The SiAppNativeMethodsSiGetEventData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | lParam |
Public field | msg |
Public field | wParam |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


SiGetEventData Methods

The SiAppNativeMethodsSiGetEventData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SiAppNativeMethodsSiGetEventData Structure
VisualComponents.UX.Input Namespace


SiGetEventData Fields

The SiAppNativeMethodsSiGetEventData type exposes the following members.

Fields
 | Name | Description
Public field | lParam |
Public field | msg |
Public field | wParam |
Top
See Also

Reference

SiAppNativeMethodsSiGetEventData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiGetEventData.lParam Field

SiAppNativeMethodsSiGetEventDatalParam Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IntPtr lParam
public:
IntPtr lParam

Field Value

Type: IntPtr
See Also

Reference

SiAppNativeMethodsSiGetEventData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiGetEventData.msg Field

SiAppNativeMethodsSiGetEventDatamsg Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint msg
public:
unsigned int msg

Field Value

Type: UInt32
See Also

Reference

SiAppNativeMethodsSiGetEventData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiGetEventData.wParam Field

SiAppNativeMethodsSiGetEventDatawParam Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IntPtr wParam
public:
IntPtr wParam

Field Value

Type: IntPtr
See Also

Reference

SiAppNativeMethodsSiGetEventData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiKeyboardData Structure

SiAppNativeMethodsSiKeyboardData Structure

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct SiKeyboardData
public value class SiKeyboardData

The SiAppNativeMethodsSiKeyboardData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | kstring |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


SiKeyboardData Methods

The SiAppNativeMethodsSiKeyboardData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SiAppNativeMethodsSiKeyboardData Structure
VisualComponents.UX.Input Namespace


SiKeyboardData Fields

The SiAppNativeMethodsSiKeyboardData type exposes the following members.

Fields
 | Name | Description
Public field | kstring |
Top
See Also

Reference

SiAppNativeMethodsSiKeyboardData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiKeyboardData.kstring Field

SiAppNativeMethodsSiKeyboardDatakstring Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public byte[] kstring
public:
array<unsigned char>^ kstring

Field Value

Type: Byte
See Also

Reference

SiAppNativeMethodsSiKeyboardData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiOpenData Structure

SiAppNativeMethodsSiOpenData Structure

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct SiOpenData
public value class SiOpenData

The SiAppNativeMethodsSiOpenData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | exeFile |
Public field | hWnd |
Public field | libFlag |
Public field | processID |
Public field | transCtl |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


SiOpenData Methods

The SiAppNativeMethodsSiOpenData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SiAppNativeMethodsSiOpenData Structure
VisualComponents.UX.Input Namespace


SiOpenData Fields

The SiAppNativeMethodsSiOpenData type exposes the following members.

Fields
 | Name | Description
Public field | exeFile |
Public field | hWnd |
Public field | libFlag |
Public field | processID |
Public field | transCtl |
Top
See Also

Reference

SiAppNativeMethodsSiOpenData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiOpenData.exeFile Field

SiAppNativeMethodsSiOpenDataexeFile Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string exeFile
public:
String^ exeFile

Field Value

Type: String
See Also

Reference

SiAppNativeMethodsSiOpenData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiOpenData.hWnd Field

SiAppNativeMethodsSiOpenDatahWnd Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int hWnd
public:
int hWnd

Field Value

Type: Int32
See Also

Reference

SiAppNativeMethodsSiOpenData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiOpenData.libFlag Field

SiAppNativeMethodsSiOpenDatalibFlag Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int libFlag
public:
int libFlag

Field Value

Type: Int32
See Also

Reference

SiAppNativeMethodsSiOpenData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiOpenData.processID Field

SiAppNativeMethodsSiOpenDataprocessID Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int processID
public:
int processID

Field Value

Type: Int32
See Also

Reference

SiAppNativeMethodsSiOpenData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiOpenData.transCtl Field

SiAppNativeMethodsSiOpenDatatransCtl Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IntPtr transCtl
public:
IntPtr transCtl

Field Value

Type: IntPtr
See Also

Reference

SiAppNativeMethodsSiOpenData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiOrientation Enumeration

SiAppNativeMethodsSiOrientation Enumeration

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum SiOrientation
public enum class SiOrientation
Members
Member name | Value | Description
SI_LEFT | 0 |
SI_RIGHT | 1 |
See Also

Reference

VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiOrientation1 Structure

SiAppNativeMethodsSiOrientation1 Structure

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct SiOrientation1
public value class SiOrientation1

The SiAppNativeMethodsSiOrientation1 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | orientation |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


SiOrientation1 Methods

The SiAppNativeMethodsSiOrientation1 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SiAppNativeMethodsSiOrientation1 Structure
VisualComponents.UX.Input Namespace


SiOrientation1 Fields

The SiAppNativeMethodsSiOrientation1 type exposes the following members.

Fields
 | Name | Description
Public field | orientation |
Top
See Also

Reference

SiAppNativeMethodsSiOrientation1 Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiOrientation1.orientation Field

SiAppNativeMethodsSiOrientation1orientation Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int orientation
public:
int orientation

Field Value

Type: Int32
See Also

Reference

SiAppNativeMethodsSiOrientation1 Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiPortName Structure

SiAppNativeMethodsSiPortName Structure

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct SiPortName
public value class SiPortName

The SiAppNativeMethodsSiPortName type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | name |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


SiPortName Methods

The SiAppNativeMethodsSiPortName type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SiAppNativeMethodsSiPortName Structure
VisualComponents.UX.Input Namespace


SiPortName Fields

The SiAppNativeMethodsSiPortName type exposes the following members.

Fields
 | Name | Description
Public field | name |
Top
See Also

Reference

SiAppNativeMethodsSiPortName Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiPortName.name Field

SiAppNativeMethodsSiPortNamename Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string name
public:
String^ name

Field Value

Type: String
See Also

Reference

SiAppNativeMethodsSiPortName Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiSpwData Structure

SiAppNativeMethodsSiSpwData Structure

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct SiSpwData
public value class SiSpwData

The SiAppNativeMethodsSiSpwData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | bData |
Public field | exData |
Public field | mData |
Public field | period |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


SiSpwData Methods

The SiAppNativeMethodsSiSpwData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SiAppNativeMethodsSiSpwData Structure
VisualComponents.UX.Input Namespace


SiSpwData Fields

The SiAppNativeMethodsSiSpwData type exposes the following members.

Fields
 | Name | Description
Public field | bData |
Public field | exData |
Public field | mData |
Public field | period |
Top
See Also

Reference

SiAppNativeMethodsSiSpwData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiSpwData.bData Field

SiAppNativeMethodsSiSpwDatabData Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SiAppNativeMethodsSiButtonData bData
public:
SiAppNativeMethodsSiButtonData bData

Field Value

Type: SiAppNativeMethodsSiButtonData
See Also

Reference

SiAppNativeMethodsSiSpwData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiSpwData.exData Field

SiAppNativeMethodsSiSpwDataexData Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public byte[] exData
public:
array<unsigned char>^ exData

Field Value

Type: Byte
See Also

Reference

SiAppNativeMethodsSiSpwData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiSpwData.mData Field

SiAppNativeMethodsSiSpwDatamData Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int[] mData
public:
array<int>^ mData

Field Value

Type: Int32
See Also

Reference

SiAppNativeMethodsSiSpwData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiSpwData.period Field

SiAppNativeMethodsSiSpwDataperiod Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int period
public:
int period

Field Value

Type: Int32
See Also

Reference

SiAppNativeMethodsSiSpwData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiSpwEvent Structure

SiAppNativeMethodsSiSpwEvent Structure

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct SiSpwEvent
public value class SiSpwEvent

The SiAppNativeMethodsSiSpwEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | eventType |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


SiSpwEvent Methods

The SiAppNativeMethodsSiSpwEvent type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SiAppNativeMethodsSiSpwEvent Structure
VisualComponents.UX.Input Namespace


SiSpwEvent Fields

The SiAppNativeMethodsSiSpwEvent type exposes the following members.

Fields
 | Name | Description
Public field | eventType |
Top
See Also

Reference

SiAppNativeMethodsSiSpwEvent Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiSpwEvent.eventType Field

SiAppNativeMethodsSiSpwEventeventType Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int eventType
public:
int eventType

Field Value

Type: Int32
See Also

Reference

SiAppNativeMethodsSiSpwEvent Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiSpwEvent_DeviceChange Structure

SiAppNativeMethodsSiSpwEvent_DeviceChange Structure

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct SiSpwEvent_DeviceChange
public value class SiSpwEvent_DeviceChange

The SiAppNativeMethodsSiSpwEvent_DeviceChange type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | deviceChangeEventData |
Public field | type |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


SiSpwEvent_DeviceChange Methods

The SiAppNativeMethodsSiSpwEvent_DeviceChange type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SiAppNativeMethodsSiSpwEvent_DeviceChange Structure
VisualComponents.UX.Input Namespace


SiSpwEvent_DeviceChange Fields

The SiAppNativeMethodsSiSpwEvent_DeviceChange type exposes the following members.

Fields
 | Name | Description
Public field | deviceChangeEventData |
Public field | type |
Top
See Also

Reference

SiAppNativeMethodsSiSpwEvent_DeviceChange Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiSpwEvent_DeviceChange.deviceChangeEventData Field

SiAppNativeMethodsSiSpwEvent_DeviceChangedeviceChangeEventData Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SiAppNativeMethodsSiDeviceChangeEventData deviceChangeEventData
public:
SiAppNativeMethodsSiDeviceChangeEventData deviceChangeEventData

Field Value

Type: SiAppNativeMethodsSiDeviceChangeEventData
See Also

Reference

SiAppNativeMethodsSiSpwEvent_DeviceChange Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiSpwEvent_DeviceChange.type Field

SiAppNativeMethodsSiSpwEvent_DeviceChangetype Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SiAppNativeMethodsSiEventType type
public:
SiAppNativeMethodsSiEventType type

Field Value

Type: SiAppNativeMethodsSiEventType
See Also

Reference

SiAppNativeMethodsSiSpwEvent_DeviceChange Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiSpwEvent_JustType Structure

SiAppNativeMethodsSiSpwEvent_JustType Structure

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct SiSpwEvent_JustType
public value class SiSpwEvent_JustType

The SiAppNativeMethodsSiSpwEvent_JustType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | type |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


SiSpwEvent_JustType Methods

The SiAppNativeMethodsSiSpwEvent_JustType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SiAppNativeMethodsSiSpwEvent_JustType Structure
VisualComponents.UX.Input Namespace


SiSpwEvent_JustType Fields

The SiAppNativeMethodsSiSpwEvent_JustType type exposes the following members.

Fields
 | Name | Description
Public field | type |
Top
See Also

Reference

SiAppNativeMethodsSiSpwEvent_JustType Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiSpwEvent_JustType.type Field

SiAppNativeMethodsSiSpwEvent_JustTypetype Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SiAppNativeMethodsSiEventType type
public:
SiAppNativeMethodsSiEventType type

Field Value

Type: SiAppNativeMethodsSiEventType
See Also

Reference

SiAppNativeMethodsSiSpwEvent_JustType Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiSpwEvent_SpwData Structure

SiAppNativeMethodsSiSpwEvent_SpwData Structure

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct SiSpwEvent_SpwData
public value class SiSpwEvent_SpwData

The SiAppNativeMethodsSiSpwEvent_SpwData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | spwData |
Public field | type |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


SiSpwEvent_SpwData Methods

The SiAppNativeMethodsSiSpwEvent_SpwData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SiAppNativeMethodsSiSpwEvent_SpwData Structure
VisualComponents.UX.Input Namespace


SiSpwEvent_SpwData Fields

The SiAppNativeMethodsSiSpwEvent_SpwData type exposes the following members.

Fields
 | Name | Description
Public field | spwData |
Public field | type |
Top
See Also

Reference

SiAppNativeMethodsSiSpwEvent_SpwData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiSpwEvent_SpwData.spwData Field

SiAppNativeMethodsSiSpwEvent_SpwDataspwData Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SiAppNativeMethodsSiSpwData spwData
public:
SiAppNativeMethodsSiSpwData spwData

Field Value

Type: SiAppNativeMethodsSiSpwData
See Also

Reference

SiAppNativeMethodsSiSpwEvent_SpwData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiSpwEvent_SpwData.type Field

SiAppNativeMethodsSiSpwEvent_SpwDatatype Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SiAppNativeMethodsSiEventType type
public:
SiAppNativeMethodsSiEventType type

Field Value

Type: SiAppNativeMethodsSiEventType
See Also

Reference

SiAppNativeMethodsSiSpwEvent_SpwData Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiSpwOOB Structure

SiAppNativeMethodsSiSpwOOB Structure

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct SiSpwOOB
public value class SiSpwOOB

The SiAppNativeMethodsSiSpwOOB type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | code |
Public field | message |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


SiSpwOOB Methods

The SiAppNativeMethodsSiSpwOOB type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SiAppNativeMethodsSiSpwOOB Structure
VisualComponents.UX.Input Namespace


SiSpwOOB Fields

The SiAppNativeMethodsSiSpwOOB type exposes the following members.

Fields
 | Name | Description
Public field | code |
Public field | message |
Top
See Also

Reference

SiAppNativeMethodsSiSpwOOB Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiSpwOOB.code Field

SiAppNativeMethodsSiSpwOOBcode Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public byte code
public:
unsigned char code

Field Value

Type: Byte
See Also

Reference

SiAppNativeMethodsSiSpwOOB Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiSpwOOB.message Field

SiAppNativeMethodsSiSpwOOBmessage Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public byte[] message
public:
array<unsigned char>^ message

Field Value

Type: Byte
See Also

Reference

SiAppNativeMethodsSiSpwOOB Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiTypeMask Structure

SiAppNativeMethodsSiTypeMask Structure

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct SiTypeMask
public value class SiTypeMask

The SiAppNativeMethodsSiTypeMask type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | mask |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


SiTypeMask Methods

The SiAppNativeMethodsSiTypeMask type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SiAppNativeMethodsSiTypeMask Structure
VisualComponents.UX.Input Namespace


SiTypeMask Fields

The SiAppNativeMethodsSiTypeMask type exposes the following members.

Fields
 | Name | Description
Public field | mask |
Top
See Also

Reference

SiAppNativeMethodsSiTypeMask Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiTypeMask.mask Field

SiAppNativeMethodsSiTypeMaskmask Field

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public byte[] mask
public:
array<unsigned char>^ mask

Field Value

Type: Byte
See Also

Reference

SiAppNativeMethodsSiTypeMask Structure
VisualComponents.UX.Input Namespace


SiAppNativeMethods.SiV3D_Key Enumeration

SiAppNativeMethodsSiV3D_Key Enumeration

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum SiV3D_Key
public enum class SiV3D_Key
Members
Member name | Value | Description
V3DK_MENU | 1 |
V3DK_FIT | 2 |
V3DK_TOP | 3 |
V3DK_LEFT | 4 |
V3DK_RIGHT | 5 |
V3DK_FRONT | 6 |
V3DK_BOTTOM | 7 |
V3DK_BACK | 8 |
V3DK_ROLL_CW | 9 |
V3DK_ROLL_CCW | 10 |
V3DK_ISO1 | 11 |
V3DK_ISO2 | 12 |
V3DK_1 | 13 |
V3DK_2 | 14 |
V3DK_3 | 15 |
V3DK_4 | 16 |
V3DK_5 | 17 |
V3DK_6 | 18 |
V3DK_7 | 19 |
V3DK_8 | 20 |
V3DK_9 | 21 |
V3DK_10 | 22 |
V3DK_ESC | 23 |
V3DK_ALT | 24 |
V3DK_SHIFT | 25 |
V3DK_CTRL | 26 |
V3DK_ROTATE | 27 |
V3DK_PANZOOM | 28 |
V3DK_DOMINANT | 29 |
V3DK_PLUS | 30 |
V3DK_MINUS | 31 |
V3DK_SPIN_CW | 32 |
V3DK_SPIN_CCW | 33 |
V3DK_TILT_CW | 34 |
V3DK_TILT_CCW | 35 |
V3DK_ENTER | 36 |
V3DK_DEL | 37 |
V3DK_RESERVED0 | 38 |
V3DK_RESERVED1 | 39 |
V3DK_RESERVED2 | 40 |
V3DK_F1 | 41 |
V3DK_F2 | 42 |
V3DK_F3 | 43 |
V3DK_F4 | 44 |
V3DK_F5 | 45 |
V3DK_F6 | 46 |
V3DK_F7 | 47 |
V3DK_F8 | 48 |
V3DK_F9 | 49 |
V3DK_F10 | 50 |
V3DK_F11 | 51 |
V3DK_F12 | 52 |
V3DK_F13 | 53 |
V3DK_F14 | 54 |
V3DK_F15 | 55 |
V3DK_F16 | 56 |
V3DK_F17 | 57 |
V3DK_F18 | 58 |
V3DK_F19 | 59 |
V3DK_F20 | 60 |
V3DK_F21 | 61 |
V3DK_F22 | 62 |
V3DK_F23 | 63 |
V3DK_F24 | 64 |
See Also

Reference

VisualComponents.UX.Input Namespace


SiAppNativeMethods.SpwRetVal Enumeration

SiAppNativeMethodsSpwRetVal Enumeration

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum SpwRetVal
public enum class SpwRetVal
Members
Member name | Value | Description
SPW_NO_ERROR | 0 |
SPW_ERROR | 1 |
SI_BAD_HANDLE | 2 |
SI_BAD_ID | 3 |
SI_BAD_VALUE | 4 |
SI_IS_EVENT | 5 |
SI_SKIP_EVENT | 6 |
SI_NOT_EVENT | 7 |
SI_NO_DRIVER | 8 |
SI_NO_RESPONSE | 9 |
SI_UNSUPPORTED | 10 |
SI_UNINITIALIZED | 11 |
SI_WRONG_DRIVER | 12 |
SI_INTERNAL_ERROR | 13 |
SI_BAD_PROTOCOL | 14 |
SI_OUT_OF_MEMORY | 15 |
SPW_DLL_LOAD_ERROR | 16 |
SI_NOT_OPEN | 17 |
SI_ITEM_NOT_FOUND | 18 |
SI_UNSUPPORTED_DEVICE | 19 |
See Also

Reference

VisualComponents.UX.Input Namespace


TranslateHandler Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.InputMouseGestureHandler
VisualComponents.UX.InputTranslateHandler

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class TranslateHandler : MouseGestureHandler
public ref class TranslateHandler sealed : public MouseGestureHandler

The TranslateHandler type exposes the following members.

Constructors
 | Name | Description
Public method | TranslateHandler | Initializes a new instance of the TranslateHandler class
Top
Properties
 | Name | Description
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Top
Methods
 | Name | Description
Public method | CanExecute | (Overrides MouseGestureHandlerCanExecute.)
Public method | Completed | (Overrides MouseGestureHandlerCompleted(ManipulationEventArgs).)
Public method | Delta | (Overrides MouseGestureHandlerDelta(ManipulationEventArgs).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnLostMouseCapture | (Overrides MouseGestureHandlerOnLostMouseCapture(Object, MouseEventArgs).)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


TranslateHandler Constructor

Initializes a new instance of the TranslateHandler class

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TranslateHandler(
    HelperViewport controller
)
public:
TranslateHandler(
    HelperViewport^ controller
)

Parameters

controller
Type: VisualComponents.UX.InputHelperViewport
See Also

Reference

TranslateHandler Class
VisualComponents.UX.Input Namespace


TranslateHandler Properties

The TranslateHandler type exposes the following members.

Properties
 | Name | Description
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Top
See Also

Reference

TranslateHandler Class
VisualComponents.UX.Input Namespace


TranslateHandler Methods

The TranslateHandler type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | (Overrides MouseGestureHandlerCanExecute.)
Public method | Completed | (Overrides MouseGestureHandlerCompleted(ManipulationEventArgs).)
Public method | Delta | (Overrides MouseGestureHandlerDelta(ManipulationEventArgs).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnLostMouseCapture | (Overrides MouseGestureHandlerOnLostMouseCapture(Object, MouseEventArgs).)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TranslateHandler Class
VisualComponents.UX.Input Namespace


TranslateHandler.CanExecute Method

TranslateHandlerCanExecute Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool CanExecute()
public:
virtual bool CanExecute() override

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Input.TranslateHandler.CanExecute"]

See Also

Reference

TranslateHandler Class
VisualComponents.UX.Input Namespace


TranslateHandler.Completed Method

TranslateHandlerCompleted Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Completed(
    ManipulationEventArgs e
)
public:
virtual void Completed(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

TranslateHandler Class
VisualComponents.UX.Input Namespace


TranslateHandler.Delta Method

TranslateHandlerDelta Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Delta(
    ManipulationEventArgs e
)
public:
virtual void Delta(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

TranslateHandler Class
VisualComponents.UX.Input Namespace


TranslateHandler.OnLostMouseCapture Method

TranslateHandlerOnLostMouseCapture Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnLostMouseCapture(
    Object sender,
    MouseEventArgs e
)
public:
virtual void OnLostMouseCapture(
    Object^ sender,
    MouseEventArgs^ e
) override

Parameters

sender
Type: SystemObject
e
Type: System.Windows.InputMouseEventArgs
See Also

Reference

TranslateHandler Class
VisualComponents.UX.Input Namespace


TranslateHandler.Started Method

TranslateHandlerStarted Method

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Started(
    ManipulationEventArgs e
)
public:
virtual void Started(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

TranslateHandler Class
VisualComponents.UX.Input Namespace


ZoomHandler Class

Handles zooming.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.InputMouseGestureHandler
VisualComponents.UX.InputZoomHandler

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ZoomHandler : MouseGestureHandler
public ref class ZoomHandler sealed : public MouseGestureHandler

The ZoomHandler type exposes the following members.

Constructors
 | Name | Description
Public method | ZoomHandler | Initializes a new instance of the ZoomHandler class.
Top
Properties
 | Name | Description
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Top
Methods
 | Name | Description
Public method | CanExecute | Occurs when the command associated with this handler initiates a check to determine whether the command can be executed on the command target. (Overrides MouseGestureHandlerCanExecute.)
Public method | Completed | Occurs when the manipulation is completed. (Overrides MouseGestureHandlerCompleted(ManipulationEventArgs).)
Public method | Delta | Occurs when the position is changed during a manipulation. (Overrides MouseGestureHandlerDelta(ManipulationEventArgs).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnLostMouseCapture | (Inherited from MouseGestureHandler.)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | Occurs when the manipulation is started. (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Input Namespace


ZoomHandler Constructor

Initializes a new instance of the ZoomHandler class.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ZoomHandler(
    HelperViewport controller,
    bool changeFieldOfView = false
)
public:
ZoomHandler(
    HelperViewport^ controller,
    bool changeFieldOfView = false
)

Parameters

controller
Type: VisualComponents.UX.InputHelperViewport
The controller.
changeFieldOfView (Optional)
Type: SystemBoolean
if set to true [change field of view].
See Also

Reference

ZoomHandler Class
VisualComponents.UX.Input Namespace


ZoomHandler Properties

The ZoomHandler type exposes the following members.

Properties
 | Name | Description
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Top
See Also

Reference

ZoomHandler Class
VisualComponents.UX.Input Namespace


ZoomHandler Methods

The ZoomHandler type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | Occurs when the command associated with this handler initiates a check to determine whether the command can be executed on the command target. (Overrides MouseGestureHandlerCanExecute.)
Public method | Completed | Occurs when the manipulation is completed. (Overrides MouseGestureHandlerCompleted(ManipulationEventArgs).)
Public method | Delta | Occurs when the position is changed during a manipulation. (Overrides MouseGestureHandlerDelta(ManipulationEventArgs).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnLostMouseCapture | (Inherited from MouseGestureHandler.)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | Occurs when the manipulation is started. (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ZoomHandler Class
VisualComponents.UX.Input Namespace


ZoomHandler.CanExecute Method

ZoomHandlerCanExecute Method

Occurs when the command associated with this handler initiates a check to determine whether the command can be executed on the command target.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool CanExecute()
public:
virtual bool CanExecute() override

Return Value

Type: Boolean
True if the execution can continue.
See Also

Reference

ZoomHandler Class
VisualComponents.UX.Input Namespace


ZoomHandler.Completed Method

ZoomHandlerCompleted Method

Occurs when the manipulation is completed.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Completed(
    ManipulationEventArgs e
)
public:
virtual void Completed(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
The ManipulationEventArgs instance containing the event data.
See Also

Reference

ZoomHandler Class
VisualComponents.UX.Input Namespace


ZoomHandler.Delta Method

ZoomHandlerDelta Method

Occurs when the position is changed during a manipulation.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Delta(
    ManipulationEventArgs e
)
public:
virtual void Delta(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
The ManipulationEventArgs instance containing the event data.
See Also

Reference

ZoomHandler Class
VisualComponents.UX.Input Namespace


ZoomHandler.Started Method

ZoomHandlerStarted Method

Occurs when the manipulation is started.

Namespace: VisualComponents.UX.Input
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Started(
    ManipulationEventArgs e
)
public:
virtual void Started(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
The ManipulationEventArgs instance containing the event data.
See Also

Reference

ZoomHandler Class
VisualComponents.UX.Input Namespace


VisualComponents.UX.Shared Namespace

Classes
 | Class | Description
Public class | ActionConfigurationView | Interaction logic for ActionConfigurationView.xaml
Public class | ActionExecutionScope | Action Execution Scope
Public class | ActionItem | ActionItem class
Public class | ActionItemT1 |
Public class | ActionItemT1, T2 |
Public class | ActionItemT1, T2, T3 |
Public class | ActionItemT1, T2, T3, T4 |
Public class | ActionItemT1, T2, T3, T4, T5 |
Public class | ActionItemT1, T2, T3, T4, T5, T6 |
Public class | ActionItemT1, T2, T3, T4, T5, T6, T7 |
Public class | ActionItemExecutedMessage | This message is published when IActionItem instance has finished executing.
Public class | ActionItemExecutingMessage | This message is published when IActionItem instance starts executing.
Public class | ActionItemPreviewMessage | Message that can be used to visualize results of any command panel action. Currently not used.
Public class | ActionItemTemplateSelector |
Public class | ActionRequestedEventArgs |
Public class | ActiveViewportChangedMessage |
Public class | AddOnHelper |
Public class | AdornedControl |
Public class | AdornerEventArgs |
Public class | AfterExecuteEventArgs |
Public class | AlignPrimitiveAction |
Public class | AllowedValueContainer | Stores Allowed values . Derives from DependencyObject so that it gets the DataContext property.
Public class | AngularDimensionCreateAction |
Public class | AnnotationManipulateAction | Annotation Manipulate Action
Public class | AnnotationManipulateMessage |
Public class | ApplicationMenuSelectionChangedEventArgs | Event args for the ribbon application menu selection changed event.
Public class | AreaSelectAction |
Public class | AreaSelectionCompletedMessage |
Public class | AutoPlugPlayAction | Automatic plug and play action
Public class | AutoScrollBehavior |
Public class | BalloomAnnotationCreatedMessage |
Public class | BaseActionItem | Base Action Item
Public class | BaseConfigCollectionT | Generic base class for config collections.
Public class | BeforeExecuteEventArgs |
Public class | BeginDraggingAlignMessage |
Public class | BeginInteractionMessage |
Public class | BeginRestoreMessage | Broad casted when autosave restoration is starting.
Public class | Bindable |
Public class | BindableT | Allows the Binding to receive property changed notifications from native wrappers or objects that don't directly implement INotifyPropertyChanged.
Public class | BindingProxy |
Public class | BitmapEditor |
Public class | BitmapExportStatusMessage |
Public class | BitmapImageSourceEditor | Bitmap control which allows changing bitmaproperty by using bitmap object or file location.
Public class | BitmapProperty |
Public class | BlockedItemsConfigElement | blocked item config element
Public class | BlockedRibbonItemConfigCollection | blocked item config collection
Public class | BlockedRibbonItemsSection | blocked items section
Public class | BoolToLeftMarginConverter |
Public class | BoolToListSortDirectionConverter |
Public class | BoundColumn | Custom column type for XamGrid which gives control of the actual data presentation to the column's CellStyle and establishes data binding to the property specified in Key attribute. Unlike TemplateColumn, this column will not try to bind itself (=> no more WPF exceptions) and does not require the property specified in Key attribute to exist in ViewModel.
Public class | BoundColumnContentProvider | Provides content to Cell objects residing in BoundColumn
 | BusyScope | BusyScope is to be used with using -keyword. While it is active, OverrideCursor is set to use the Wait cursor.
Public class | ButtonProperty |
Public class | CADFilesList |
Public class | CADImportAction |
Public class | CADImportPresetsSection |
Public class | CadPresetConfigElement | blocked item config element
Public class | CadPresetEntryConfigElement | blocked item config element
Public class | CadPresetsConfigCollection |
Public class | CadPresetsEntryConfigCollection |
Public class | CaptionBarInfo | Information about titles and logo displayed in caption bar.
Public class | CaptionBarInfoToApplicationTitleConverter |
Public class | CaptionBarInfoToResourceObjectConverter |
Public class | ChainConverter |
Public class | CharHelper |
Public class | ClearWorldMessage |
Public class | ClipboardHelper |
Public class | ClipData |
Public class | CollapsiblePanel |
Public class | CollisionDetectionEditAction |
Public class | CollisionOverrideAction |
Public class | ColorUtility | color helper
Public class | Column | Column is used to stack layout elements in vertical column. It is possible for a row to contain multiple columns.
Public class | ComboBoxEditorPropertyProxy | Helper class that allows to modify combobox Items without changing the selected item.
Public class | ComboBoxEx |
Public class | ComboItemBase | Base class for items presented in ComboEditortool
Public class | CommandPanelHideMessage |
Public class | CommandPanelShowMessage |
Public class | CompletedRestoreMessage | Broad casted after autosave restoration is completed.
Public class | ComponentHelper |
Public class | ComponentMetadataMessage |
Public class | ComponentPdfInfo |
Public class | ComponentPicker |
Public class | ComponentPropertyGridEx |
Public class | ComponentQuickMenu | Interaction logic for ComponentQuickMenu.xaml
Public class | ComponentStructureMessage |
Public class | ConnectionBadIndicator | This class is just a place holder for showing a 'bad connection' indicator in the graph. It is used when a connection is dragged out to a connector, to which a valid connection can't be made.
Public class | ConnectionOkIndicator | This class is just a place holder for showing a 'connection ok' indicator in the graph. It is used when a connection is dragged out to a connector, to which a valid connection can be made.
Public class | ConnectionStatusEventArgs |
Public class | ConstantMultiplyConverter |
Public class | ConstantMultiplyPointConverter |
Public class | ConstantSumConverter |
Public class | ConstraintToBooleanConverter | Returns true if the value (first) is less than or equals to constraint (parameter/second).
Public class | ContentTextChangedEventArgs |
Public class | ContinueActionMessageFromHandle |
Public class | ContinueInteractionMessage |
Public class | ControlDescription | Connects the property to a gui element, for example a textbox.
Public class | ControlDescriptionNameComparer |
Public class | ControlVisibilityBehavior | Attached Behavior to control Non-Ribbon UI element visibility based on configuration setting.
Public class | ConverterFactory | Exposes singleton instances of all Converters to be used with {x:Static}.
Public class | CopyToClipboardStatusMessage |
Public class | CornerRadiusClipConverter |
Public class | CoroutineEx | Adds support for aborting actions.
Public class | CultureAwareBinding |
Public class | CursorHelper |
Public class | CustomPropertyEditorGrid |
Public class | DatacontextToActionItemConverter |
Public class | DebugConverter |
Public class | DebugHelper |
Public class | DebugLight |
Public class | DecimateAction |
Public class | DelegateCommand |
Public class | DependencyObjectHelper |
Public class | DesignTimeDictionary | Class includes resources at Design Time only
Public class | DesiredSizeChangedEventArgs |
Public class | DimensionManipulateAction | Dimension Manipulate Action
Public class | DimensionManipulateMessage |
Public class | Direct3DToolBar | Interaction logic for Direct3DToolBar.xaml
Public class | Direct3DToolBarActionItemDataTemplateSelector | This DataTemplateSelector is responsible for resolving template for ribbon Commands.
Public class | DisabledRenderingScope |
Public class | DistanceBasedOpacityContainer |
Public class | DistributionEditor |
Public class | DistributionProperty |
Public class | DistributionTypeEditorDialog |
Public class | DistributionTypeEditorView | Interaction logic for DistributionTypeEditorView.xaml
Public class | DockableConductorT |
Public class | DockableConductorSingleActiveT |
Public class | DockableMultiConductorT |
Public class | DockableScreen |
Public class | DockAwareWindowManager |
Public class | DOFEditorView | Interaction logic for DOFEditorView.xaml
Public class | DoubleParsingExceptionValidationRule |
Public class | DoubleToPropertyEditorWidthConverter |
Public class | DoubleValidationRule |
Public class | DragAdornerVisualEventArgs |
Public class | DropEventArgs |
Public class | DropIndicator |
Public class | eCatGroupBoxWidthConverter |
Public class | EditableLabel |
Public class | EditableTextBlock | EditableTextBlock
Public class | EditBox |
Public class | EditConnectorSignalView | Interaction logic for EditConnectorSignalView.xaml
Public class | EditConnectorSignalViewModel |
Public class | EditorProperty | Defines UX property
Public class | ElementAdorner | Adorner which allows to assign any FrameworkElement as its content.
Public class | EmailValidationRule |
Public class | EmptyToVisibilityConverter |
Public class | EndInteractionMessage | Interaction ended message. Used to update the UI and WPF graphics.
Public class | EnumBindingSourceExtension | Helper class to assign itemsourse from enum .
Public class | EnumerableHelper |
Public class | EnumToBooleanConverter |
Public class | EventHelper |
Public class | ExchangeRobotAction |
Public class | ExecuteCommandMessage | Obsolete.
Public class | ExpanderPropertyExtender |
Public class | ExportCommandMessage |
Public class | ExpressionEditor |
Public class | ExpressionProperty |
Public class | ExpressionValidationRule |
Public class | ExtendedExpander |
Public class | ExtendedTextBox |
Public class | ExtendedToggleButton |
Public class | ExtendedUserControl |
Public class | Extensions |
Public class | FastPropertyChangedBase | A slightly faster simpler alternative to PropertyChangedBase that avoids allocating objects on each call. Also provides filtering to only raise the event on value change if NotifyOfPropertyChange(String, Object, Boolean) is used.
Public class | FeatureNodeEditorView | Interaction logic for FeatureNodeEditorView.xaml
Public class | FileActionMessage |
Public class | FileExtensionToIconSourceConverter |
Public class | FilterOption |
Public class | FinishSnapMessage | This message is used to finalize secondary snapping result, which might become deprecated after 2 seconds of idling.
Public class | FixedPropertyContainer | Fixed property container implementation.
Public class | FloatingLicenseServerConfiguration |
Public class | FloatingPositionHelper | Handles pose updates for floating elements (Annotations, TextFeatures)
Public class | FocusBehavior |
Public class | ForEachHelper | ForEach helper
Public class | FramesVisibilityAction |
Public class | FullScreenModeStatusMessage |
Public class | GalleryGroup |
Public class | GalleryGroupConfigElement | blocked item config element
Public class | GalleryGroupEntryConfigElement | blocked item config element
Public class | GalleryGroupsConfigCollection |
Public class | GalleryGroupsEntryConfigCollection |
Public class | GalleryInfo |
Public class | GalleryItemEx |
Public class | GalleryItemSetup |
Public class | GalleryItemWrapper |
Public class | GalleryTool |
Public class | GeoFeatureBaseOperationUtility |
Public class | GeometryContainer | Creates a custom shape with provided geometry.
Public class | GeometryFeatureBrepView | Interaction logic for GeometryFeatureBrepView.xaml
Public class | HeaderedToolTip | Headered content control that is being styled as a ToolTip. Used visual states for transitions.
Public class | HeaderModel |
Public class | HelpProvider |
Public class | HtmlRichTextBoxBehavior |
Public class | HtmlToXamlConverter | HtmlToXamlConverter is a static class that takes an HTML string and converts it into XAML
Public class | ImageAnimationController | Provides a way to pause, resume or seek a GIF animation.
Public class | ImageBehavior | Provides attached properties that display animated GIFs in a standard Image control.
Public class | ImageHelper |
Public class | ImageSourceConverter |
Public class | ImportCommandMessage |
Public class | ImportCompletedEventArgs |
Public class | ImportDrawingTemplateAction |
Public class | InformationDisplayMessage | Message used to activate 3d wpf visualization with a text. Used for example in: - show paint thickness (in MeasurePaintThicknessAction) after user clicks
Public class | InputBindingsManager |
Public class | InputConfigElement | Define a custom configuration element to be contained by the InputConfigElement. This element stores Properties that are altered from Display tab Inside Options Backstage item .
Public class | InputConfigurationConfigCollection |
Public class | InputSection |
Public class | InstanceToTypeConverter |
Public class | InteractAction |
Public class | InterfaceSectionItem |
Public class | InterfacesEditorView | Interaction logic for InterfacesEditorView.xaml
Public class | InternalEndInteractionMessage | Interaction finalization message. Used internally to finalize the interaction.
Public class | IntToBooleanConverter |
Public class | IntToOppositeBooleanConverter |
Public class | IntToVisibilityConverter |
Public class | IsCheckedProxy | Helper class that allows to modify combobox Items without changing the selected item.
Public class | ItemsChangeObservableCollectionT | This class adds the ability to refresh the list when any property of the objects changes in the list which implements the INotifyPropertyChanged.
Public class | JointSlider |
Public class | KeepLatestWorkerT1, T2, TResult |
Public class | KeyboardExtensions |
Public class | KeyboardPattern |
Public class | LayoutClearedMessage |
Public class | LayoutElement | Base class for all layout elements.
Public class | LayoutItemCommandStatusMessage |
Public class | LayoutLoadedMessage |
Public class | LayoutMetaDataSettings | layout MetaData Settings
Public class | LeftMarginMultiplierConverter |
Public class | LicensedAddOnBase | Provides license checking functionality for add-ons with external licensing.
Public class | LinearDimensionCreateAction |
Public class | LineRenderer |
Public class | ListBoxItemAttachedProperties |
Public class | ListEditorView | Interaction logic for ListEditorView.xaml
Public class | ListProperty |
Public class | ListViewEx | Extended ListView with built-in Drag-and-Drop functionality. It is recommended to use ObservableCollectionEx as the ItemsSource. Other types were not tested.
Public class | LocalizationConverter |
Public class | LocalizationDesignTimeDictionary | Class includes localization resources at Design Time only
Public class | LookupDialog |
Public class | LookupDialogView | Interaction logic for LookupDialog.xaml
Public class | LookupItem |
Public class | ManipulationModeChangedMessage |
Public class | MaterialEditor |
Public class | MatrixEditor |
Public class | MatrixProperty |
Public class | MeasureAction |
Public class | MeasureResultMessage | Message used to activate additional focus visualization. Used to: - hilight two snapping results when measuring (in MeasureAction) - show snapping result when doing aim snapping (in CombinedManipulator) - show snapping result and arrow when doing ctrl+dragging on arrow manipulator (in TranslateManipulatorPart)
Public class | MenuActionItem |
Public class | MenuItemBase | Base class for items presented in a menutoolcommand.
Public class | MenuToolButtonTypeConverter | A converter from enum ToolSizingMode to Infragistics ToolSizingMode
Public class | MenuToolEx | Extended MenuTool with ability to stay open when the user clicks on focusable child elements and/or any elements outside the popup.
Public class | MenuToolPanelEx |
Public class | MenuTools |
Public class | MenuToolTypeConverter | A converter from enum ToolSizingMode to Infragistics ToolSizingMode
Public class | MessageBoxResultEx |
Public class | MetaDataSettings | MetaData Settings
Public class | MinMaxValidationRule |
Public class | MouseButtonArrayConverter |
Public class | MouseHelper |
Public class | MouseHelperMouseHookStruct |
Public class | MouseHelperPOINT |
Public class | MouseListener |
Public class | MouseMessage | MouseMessage is used to update SnapAction's snapping. This message is sent in 4 cases: - when user clicks a button - when user moves the mouse - when user stops moving the mouse and 100ms elapsed (in rare cases) - when user stops scrolling the mouse wheel and 100ms elapsed
Public class | MouseTouchDevice | Implements a mouse touch device, which promotes mouse input to touch input.
Public class | MultilineStringEditor |
Public class | MultilineStringProperty |
Public class | MultiplyConverter |
Public class | NaturalStringAscendingComparer | Alphanumeric comparer to use with data bindings.
Public class | NaturalStringDescendingComparer |
Public class | NetworkStatus |
Public class | NetworkStatusChangedArgs | Describes the overall network connectivity of the machine.
Public class | NewFileAction | "New File" Action
Public class | NewValueCreationType | Placeholder value object for the new value creation types.
Public class | NodeContextMenuEventArgs |
Public class | NodeEventArgs |
Public class | NodeKeyEventArgs |
Public class | NodeMouseButtonEventArgs |
Public class | NodeMouseEventArgs |
Public class | NodePropertyChangedEventArgs |
Public class | NodesPanelEx |
Public class | NonTopmostPopup |
Public class | NoteEditor |
Public class | NoteEditorView | NoteEditorView
Public class | NoteProperty |
Public class | NoteView | Interaction logic for NoteService.xaml
Public class | NoteViewModel |
Public class | ObjectQuickMenuDisplayHandler |
Public class | ObjectRotateAction | Object Rotate Action
Public class | ObjectToWindowIconConverter |
Public class | ObservableCollectionProxy | Adds unit conversion support for set of values.
Public class | OpenFileAction | Open file Action
Public class | OpenHelpDocumentCommand |
Public class | OpenHelpDocumentCommandCommandHandler |
Public class | OpenSaveFolderConfigCollection | Represents a configuration element recent Open/Save folder.
Public class | OpenSaveFolderConfigElement | Open/Save folder config element
Public class | Overlay |
Public class | PaneWindowToRestoreMessage |
Public class | PasswordAgainValidationRule |
Public class | PasswordValidationRule |
Public class | PathSmoothAction |
Public class | PathTeachSegment | Information about a part of a curve.
Public class | PathTeachSnapper | Snaps based on current state of PathTeachAction.
Public class | PatternDesignerHelper |
Public class | PdfExportAction |
Public class | PdfExportActionWithGroup |
Public class | PdfExporterItem |
Public class | PdfSettingView | Interaction logic for PdfSettingView.xaml
Public class | PhysicsJointD6EditorView | Interaction logic for PhysicsJointD6EditorView.xaml
Public class | PhysicsRopeEditorView | Interaction logic for PhysicsRopeEditorView.xaml
Public class | PickAction | Action that waits for pick in 3D world.
Public class | PickEventArgs |
Public class | PickMessage |
Public class | PlaceholderNode | TreeNodeEx pre-configured to act as placeholder node.
Public class | PlugPlayAction |
Public class | PlugPlayCompletionEventArgs |
Public class | PlugPlayLogicalAction |
Public class | PnPIndicationPointsMessage |
Public class | PositionProperty |
Public class | ProcessRuleEditorView | Interaction logic for ProcessRuleEditorView.xaml
Public class | ProcessTableLineView | Interaction logic for ProcessTableLineView.xaml
Public class | ProduckKeySelectedMessage | Obsolete.
Public class | ProductDetailInfoEntry |
Public class | ProductInfo | Provides information about the runtime environment.
Public class | ProductInfoEntry |
Public class | ProductKeyStringConverter | Product key string converter
Public class | ProgramStatementPositionPickedMessage | Obsolete.
Public class | ProgramStatementPositionsUpdateMessage | Obsolete.
Public class | ProgressDialog | Interaction logic for ProgressDialog.xaml
Public class | ProgressDialog2 | Interaction logic for ProgressDialog.xaml
Public class | ProgressDialogSettings |
Public class | ProgressEventArgs | Occurs when action is progressing.
Public class | PropertyAllowedValueModel | Represents an bindable item from allowed value set of a property.
Public class | PropertyAttribute |
Public class | PropertyCategory |
Public class | PropertyDataTemplateSelector | This template selector is used to select contentcontrol to display the property. This template then uses another template selector based on the control of the property. todo: these could probably be combined to a single templateselector
Public class | PropertyDescription | Property description contains property related metadata, such as name, description etc.
Public class | PropertyEditorView | Interaction logic for PropertyEditorView.xaml
Public class | PropertyGridBehavior | Attached Behavior to control Non-Ribbon UI element visibility based on configuration setting.
Public class | PropertyHelper |
Public class | PropertyLayout | PropertyLayout defines the user interface for a set of properties. Layout consists of a set of rows, divided in to columns. Columns can contain a set of layout elements (controls, rows, tabs).
Public class | PropertyList |
Public class | PropertyObjectEditorAction |
Public class | PropertyOrderingHelper | Helper class to order IProperty instances.
Public class | PropertyTemplateSelector |
Public class | PropertyUnitEditorView |
Public class | PythonActionItem |
Public class | PythonAttributeInformation |
Public class | PythonClassInfo |
Public class | PythonContextualRibbonTab |
Public class | PythonEditorView | Interaction logic for PythonEditorView.xaml
Public class | PythonEditorViewModel |
Public class | PythonGalleryActionItem |
Public class | PythonGalleryItemActionItem |
Public class | PythonIntellisense |
Public class | PythonRibbonTab |
Public class | QatRibbonGroupsConfigCollection |
Public class | QatRibbonGroupsConfigElement |
Public class | QatRibbonToolsConfigCollection |
Public class | QatRibbonToolsConfigElement |
Public class | QuickMenu | Interaction logic for QuickMenu.xaml
Public class | QuickMenuActionItemDataTemplateSelector | This DataTemplateSelector is responsible for resolving template for ribbon Commands.
Public class | QuickMenuDisplayMessage |
Public class | RawMouseArgs | Raw mouse arguments.
Public class | RecentDocumentConfigCollection |
Public class | RecentDocumentConfigElement |
Public class | RecentDocumentSection |
Public class | RecentFilePresenter |
Public class | RecentFolderConfigCollection | "Recent Folder" config collection
Public class | RecentFolderConfigElement | "Recent Folder" config element
Public class | RecentFolderSection | Recent folder section
Public class | RecentOpenSaveFolderSection | Recent Open/Save folder section
Public class | RecordView__DEPRECATED__ | RecordView__DEPRECATED__
Public class | RectangularAnnotationCreateAction |
Public class | RectHelper |
Public class | ReflectionHelper |
Public class | RegionQuadTreeT | Stores spatial data (rectangular bounds and positions) of objects (i.e. UI elements) in prioritized order and allows to retrieve it in a lazy manner.
Public class | ReportEx | Inherited from Report to allow custom report initialization. This is needed for proper operation of XamReportPreviewEx.
Public class | RequestActionAbortMessage | Message that is signalled when abortable actions should be aborted.
Public class | RequestCommandPanelCanApplyCancelUpdate |
Public class | RequiredFieldValidationRule |
Public class | ResetableTextBox |
Public class | ResourceFileHelper |
Public class | RibbonConfigElement | Define a custom configuration element to be contained by the ImportSection. This element stores Properties that are altered from Import tab Inside Options Backstage item .
Public class | RibbonInitializedEventArgs | Event args for the ribbon initialized event of the application Ribbon.
Public class | RibbonSection |
Public class | RibbonTab | Represents a tab in ribbon.
Public class | RibbonTabSelectedEventArgs | Event args for the RibbonTabItemOpening event of the Application Ribbon.
Public class | RibbonToolWrapPanel | Wrap panel that combines measure/arrange behavior of ToolVerticalWrapPanel and resizing behavior of ToolHorizontalWrapPanel, avoids falling into infinite layout loop and speeds up (a bit) arrangement of Ribbon tools. Known issues: depends on ToolHorizontalWrapPanel.
Public class | RichTextBoxEx |
Public class | RobotFrameEditorView | Interaction logic for RobotFrameEditorView.xaml
Public class | RootGridWidthToTabWidthConverter |
Public class | RoutedEventTrigger |
Public class | RouteFixedLineView | Interaction logic for RouteFixedLineView.xaml
Public class | RoutePercentageLineView | Interaction logic for RoutePercentageLineView.xaml
Public class | RouteSimpleLineView | Interaction logic for RouteSimpleLineView.xaml
Public class | RouteTableLineView | Interaction logic for RouteTableLineView.xaml
Public class | RouteTransportSolutionLineView | Interaction logic for RouteFixedLineView.xaml
Public class | RoutineVariablesEditorView | Interaction logic for RoutineVariablesEditorView.xaml
Public class | RoutingRuleEditorView | Interaction logic for RoutingRuleEditorView.xaml
Public class | RoutingRuleView | Interaction logic for RoutingRuleView.xaml
Public class | Row |
Public class | SaveComponentAction | Save component action
Public class | SaveLayoutAction |
Public class | SchedulerHelper |
Public class | SchedulerService |
Public class | SchemaPathStatement |
Public class | SchemaPositionsView | Interaction logic for SchemaPositionsView.xaml
Public class | ScriptEditor |
Public class | ScriptProperty |
Public class | ScrollViewerMonitor |
Public class | SearchableTextblock |
Public class | SearchTextBox | Property search box control.
Public class | SectionFieldItem |
Public class | SelectAction | Action that waits for pick in 3D world.
Public class | SelectedNodesChangedEventArgs |
Public class | Settings |
Public class | SetValuesValidationRule |
Public class | ShiftPanel |
Public class | ShortcutKeyManager |
Public class | ShortCutKeys |
Public class | ShortcutParser |
Public class | ShowDebugViewModelMessage | Reserved for internal use only.
Public class | SignalChangedEventArgs |
Public class | SignalConnectionPair | Represents a connection between 2 signals
Public class | SignalInformation |
Public class | SignalNetworkView | SignalNetworkView
Public class | SignalNetworkViewModel | Signal Network View Model
Public class | SignalNetworkViewModelAlteredConnection |
Public class | SignalNetworkViewModelConnectionStore |
Public class | SimNode3DPickerView | Interaction logic for SimNode3DPickerView.xaml
Public class | SimplePropertyEditorView | Interaction logic for SimplePropertyEditorView.xaml
Public class | SimulationControlView | Interaction logic for SimulationControlView.xaml
Public class | SimulationModeEnumToBoolConveter |
Public class | SimulationModeEnumToForegroundConveter |
Public class | SimulationSettingView | Interaction logic for SimulationSettingView.xaml
Public class | SimulationStateBasedBehavior |
Public class | SimulationStateChangedEventArgs |
Public class | SimulationTimePicker | Bitmap control which allows changing bitmaproperty by using bitmap object or file location.
Public class | SimulationTimePickerBlock | Bitmap control which allows changing bitmaproperty by using bitmap object or file location.
Public class | SimulationTimeValidationRule |
Public class | SnapAction | Action that waits for pick to snap in 3D world.
Public class | SnapCompletedAltMessage | Basically MouseUp event that is used to end actions like PathTeachAction.
Public class | SnapCompletedMessage | Basically MouseDown event that is used to end SnapAction and PickAction actions.
Public class | SnapHideMessage |
Public class | SnapPrimitiveAction |
Public class | SnapResultMessage | Message used to publish snapping result of various actions. It is used to update focus visualization for: - SnapAction - PathTeachSnapper - DraggingAlignManipulator (this class has nothing to do with classes: PickResult, PickAction, SnapCompletedMessage)
Public class | SortableObservableCollectionT | Represent Extended ObservableCollection that has a Sort method , give it a lambda to sort on and a direction.
Public class | SourceIndexingEventArgs |
Public class | SpaceMouseHandler |
Public class | SpeedFactorConverter |
Public class | StateMapTier |
Public class | Statement |
Public class | StatementGroup |
Public class | StatementHelper | Singleton class with utility functions for program statements.
Public class | StatisticsChartPrintingMessage |
Public class | StatisticsStateEditorView | Interaction logic for StatisticsStateEditorView.xaml
Public class | StringEnumHelper | Helper class for working with 'extended' enums using StringValueAttribute attributes.
Public class | StringHelper | Helper class for String-related functions (sorting, comparison, conversion, etc.)
Public class | StringToPathGeometryConverter | String to path geometry converter
Public class | StringToResourceConverter |
Public class | StringToTrimmedConverter |
Public class | StringToUriConverter |
Public class | StringValueAttribute | Simple attribute class for storing String Values
Public class | SvgImage |
Public class | Tab |
Public class | TabHeadearProperties |
Public class | TabOrPropertyLayoutDataTemplateSelector |
Public class | TabPage |
Public class | TextFieldEditorView | Interaction logic for TextFeatureEditorView.xaml
Public class | TextFieldEditorViewModel |
Public class | ThicknessToOppositeConverter |
Public class | TimeFormatHelper |
Public class | TimeSpanToMillisecondsConverter |
Public class | ToggleLogicalPnP |
Public class | ToggleManipulationToolMessage | Allows publisher to toggle handles.
Public class | ToggleNavigationModeMessage |
Public class | ToggleSelectionModeMessage |
Public class | ToggleShapeManipulationMessage |
Public class | ToolTipBehavior | Provides a way to quickly configure a tooltip for arbitrary framework elements.
Public class | ToolTipDisplayMessage |
Public class | ToolTipManagerView | Interaction logic for ToolTipManagerView.xaml
Public class | ToolTipManagerViewModel |
Public class | ToolTipPointerView | Interaction logic for ToolTipPointerView.xaml
Public class | ToolTipPointerViewModel |
Public class | ToolTipView | Interaction logic for ToolTipView.xaml
Public class | ToolTipViewModel |
Public class | ToolVerticalWrapPanelEx | Wrap panel which tries to replicate the measure/arrange behavior produced by ToolVerticalWrapPanel. Known issues: requires 2 layout passes to arrange tools and still differs a bit from original one.
Public class | ToRibbonToolIdConverter |
Public class | ToTreeNodeWidthConverter | Used to make tree use the full available width of the parent control.
Public class | ToXamDataTreeWidthConverter |
Public class | TranslateAction | Translate Action
Public class | TransportLinkView | Interaction logic for TransportLinkView.xaml
Public class | TreeFlattener |
Public class | TreeGridView | Adds the ability to present data in columns for TreeViewEx.
Public class | TreeNodeCollectionEx |
Public class | TreeNodeEx |
Public class | TreeNodeViewEx |
Public class | TreeViewCell | Convenient ContentControl implementing GridView hacks found in TreeNodeViewEx. Use it as a first element in GridViewColumn's (or TreeViewColumn's) cell template.
Public class | TreeViewColumn |
Public class | TreeViewEx | Extended TreeView with built-in support for Columns and Drag-and-Drop functionality.
Public class | TreeViewExCommandHandler |
Public class | TreeViewItemEx |
Public class | TriggerActionTextChanged |
Public class | TriggerTracing | Contains attached properties to activate Trigger Tracing on the specified Triggers. This file alone should be dropped into your app.
Public class | UiElementExtensions |
Public class | UndoableRichTextBox | Optionally overwrites the default Undo/Redo operations with VC commands.
Public class | UndoableTextBox | Optionally overwrites the default Undo/Redo operations with VC commands.
Public class | UniqueNameHelper |
Public class | UriEditor |
Public class | UriToBitmapImageConverter |
Public class | UserControlOptimizedView | Note: this class is needed only when ViewModel is using "CacheViews = false".
Public class | UXEntryAddedEventArgs |
Public class | UXEntryRemovedEventArgs |
Public class | UxListPropertyT |
Public class | UxPropertyT | Implements managed IProperty Note: no need to implement PropertyChanged, because we can use EditorProperty for that.
Public class | UXSiteAddedEventArgs |
Public class | UXSiteChangedEventArgs |
Public class | UXSiteConfigElement | blocked item config element
Public class | UXSiteEntryConfigElement | blocked item config element
Public class | UXSiteRemovedEventArgs |
Public class | UXSites |
Public class | UXSitesConfigCollection |
Public class | UXSitesEntryConfigCollection |
Public class | UXSiteSetup | Setup information for the UXSite and UXEntries in it.
Public class | UXSitesSection |
Public class | ValidationErrorToErrorContentConverter |
Public class | ValueAndUnitToStringConverter | concatenate value and unit .
Public class | VariableEditorView | Interaction logic for VariableEditorView.xaml
Public class | WarningMessageArgs |
Public class | VcAttachProperty |
Public class | VcEditableTextBox |
Public class | VcMessageBox | Interaction logic for VcMessageBox.xaml
Public class | VcMessageBoxExtension |
Public class | VcWindow | Interaction logic for WindowBorderLess.xaml
Public class | WebBrowserBehavior |
Public class | VectorEditor |
Public class | VectorEditorComponent |
Public class | VectorProperty |
Public class | VideoExporterItem |
Public class | ViewportSizeChangedMessage |
Public class | ViewPreviewImageSourceConverter | Converter class that's used for converting PreviewImage to image source.
Public class | Win32Helper |
Public class | Window3DExtensions |
Public class | WindowCaptionButtons | Interaction logic for WindowCaptionButtons.xaml
Public class | WindowHeightToWindowContentHeightConverter | This converter is used to calculate window content hieght from window Height.It is used when creating popup window.
Public class | VirtualizingCanvas | Canvas with support for virtualization, panning and zooming.
Public class | VirtualizingCanvasItemContainerEventArgs |
Public class | VirtualizingCanvasVirtualizationEventArgs |
Public class | XamDockWindowManagerLoader | Creates and registers instance of XamDockWindowManager
Public class | XamReportPreviewEx | Extended (actually currently it has less functionality than the original) XamReportPreview that allows us to debug and catch internal exceptions. Cannot show the report progress.
Public class | XElementExt |
Public class | XmlExtensions |
Structures
 | Structure | Description
Public structure | ClockDisplayFormat |
Public structure | MouseHelperPOINTSTRUCT |
Public structure | NonTopmostPopupRECT |
Public structure | PathTeachPoint | Information about path point.
Public structure | RobotFrameVisibilityMode |
Public structure | ShadingMode |
Public structure | VcImageSize |
Public structure | VcImageSizeUnit |
Public structure | VcRasterEffect |
Public structure | VcTime |
Public structure | VcTimePart |
Public structure | Win32HelperCURSORINFO |
Public structure | Win32HelperICONINFO |
Public structure | Win32HelperPOINT |
Interfaces
 | Interface | Description
Public interface | IAbortableAction |
Public interface | IActionItem |
Public interface | IActionResult | CoRoutine with command properties.
Public interface | IActivatorViewModel |
Public interface | IActiveObjectsEx |
Public interface | IAddDecalAction |
Public interface | IAddDecalViewModel |
Public interface | IAddOnActivationSettings | Additional settings related to IAddOnSetting.
Public interface | IAddOnSetting | AddOn setting interface.
Public interface | IAllFrameFeaturesVisibilityCommand | Feature Frame visibility toggling command.
Public interface | IApplicationStatusService |
Public interface | IApproachAxisCommand |
Public interface | IAreaSelectionSnap |
Public interface | IAttachmentManipulator | Terminology: Attachment - an interface for attaching rSimLinks (kinda like rSimHierarchyField, but without limitation of parenting only to component)
Public interface | IAuthoringDualTreeViewModel |
Public interface | IAuthoringManager |
Public interface | IAuthoringTreeViewModel |
Public interface | IAutosaveAgent |
Public interface | IBackstageViewModel | Defines the functionality that third parties have to implement for Backstage item plug in
Public interface | IBlockedRibbonItemsSection | blocked items section
Public interface | ICADAnalizeAction |
Public interface | ICADImportViewModel | Todo: remove this kind of interfaces. We don't want to reference UI items directly.
Public interface | ICADPresetsConfiguration |
Public interface | ICellGraphViewModel |
Public interface | ICheckBoxToolCommand | Implement for menu tools that use CheckBoxTool
Public interface | IClipDataWithItems |
Public interface | ICollisionDetectionEditAction |
Public interface | ICollisionDetectionEditCommand |
Public interface | ICollisionDetectorEdit | Collision edit view model interface
Public interface | ICollisionOverrideViewModel | Collision override view model interface
Public interface | ICollisionSettingsCommand |
Public interface | ICollisionSettingsViewModel | Collision settings view model interface
Public interface | IComboEditorToolCommand | Implement for commands that should be presented as menu tool / combobox.
Public interface | ICommandHostPanel |
Public interface | ICommandPanelAction | Provides panel UI data for commands to are executed in action panel.
Public interface | ICommandPanelAction2 |
Public interface | ICommandRegistry | CommandRegistery is a repository for .NET commands.
Public interface | ICommandViewModel | Command view model interface
Public interface | IComponentEditorExViewModel |
Public interface | IComponentEditorExViewModelEx |
Public interface | IComponentMetaDataEditorViewModel | Layout metadata members definition
Public interface | IConnectingLinesAction |
Public interface | IContextualTabGroup | Marker interface a ribbon contextual tab group.
Public interface | ICustomScreenAvailability | Allows dockable screens to prevent their display based on custom logic.
Public interface | ICustomScreenVisibility | Allows dockable screens to prevent their visibiliyt based on custom logic.
Public interface | IDecimateAction |
Public interface | IDecimateViewModel | Decimate view model interface
Public interface | IDefaultPropertyEditor |
Public interface | IDisableWindowLayoutPersistance | Marker interface for screens that should not automatically trigger window layout configuration persistancy.
Public interface | IDistributionTypeEditorViewModel |
Public interface | IDockableScreen | Provides access to pane that can be docked with DockManager.
Public interface | IDockAwareWindowManager | A service that manages windows panel.
Public interface | IDpiAwareViewModel |
Public interface | IDrawingViewGenerationAction |
Public interface | IECatalogue |
Public interface | IExportToAnimationAction | Action interface for recording vcax animation files.
Public interface | IExportToAnimationCommand |
Public interface | IExportToAnimationCommandPanelAction | Export to animation command panel interface.
Public interface | IExportToPDFCommand |
Public interface | IExportToPDFViewModel | Interface to pdf recording UI. Not defined in 3DEmbedded. Note: both methods also start/stop simulation on every execution.
Public interface | IExportToVideoCommand |
Public interface | IExportToVideoViewModel | Interface to pdf recording UI. Not defined in 3DEmbedded. Note: both methods also start/stop simulation on every execution.
Public interface | IExportViewModel | Export view model interface
Public interface | IFileDialogService |
Public interface | IFilterTransportLinksCommand |
Public interface | IFloatingActivatorConfigureViewModel |
Public interface | IFloatingLicenseServerConfiguration |
Public interface | IFlowEditorCommand |
Public interface | IFlowEditorViewModel |
Public interface | IFrameVisibilityType | Frame visibility toggling command. See also IRobotFrameVisibilityType and IAllFrameFeaturesVisibilityCommand
Public interface | IFrameVisibilityTypeSettingsToolbarCommand | Global frame visibility action.
Public interface | IFullScreenSimulationControlViewModel |
Public interface | IGalleryItem |
Public interface | IGalleryMenuToolCommand |
Public interface | IGenericCommandViewModel | Generic command view model interface
Public interface | IGenericSnapActionViewModel | Any action that is using SnapAction as it's sub-action and wants to display the default UI for it.
Public interface | IGeoFeatureBaseOperationLevelAction |
Public interface | IGeoFeatureInvertViewModel | Geo feature invert geometry view model interface
Public interface | IGeoFeatureSplitViewModel | Geo feature split view model interface
Public interface | IGridSnapSizeCommand |
Public interface | IGridSnapZoomBasedCommand |
Public interface | IHeaderModel | Obsolete.
Public interface | IHelpActionItem | ActionItem with additional information.
Public interface | IImportDrawingTemplateAction |
Public interface | IImportDrawingTemplateViewModel | Import drawing template view model interface
Public interface | IInputSection |
Public interface | IInterfaceEditorNotifier |
Public interface | IInterfacesVisibilityCommand |
Public interface | IJogViewModel |
Public interface | ILayoutInfo | LayoutInfo contains information about status of the current file.
Public interface | ILayoutMetaDataEditorViewModel | Layout metadata members definition
Public interface | IListEditorViewModel |
Public interface | IListViewExItem |
Public interface | ILookupDialogViewModel |
Public interface | IManipulatorToolbar |
Public interface | IMaterialAssignViewModel | Material assign view model interface
Public interface | IMaterialEditViewModel |
Public interface | IMaterialUX |
Public interface | IMeasurePaintToolViewModel |
Public interface | IMenuToolCommand | Implement for commands that should be presented as menu tool / combobox in ribbon.
Public interface | IMergeFacesViewModel | merge faces view model interface
Public interface | IMetadataEditorViewModel | Read and save component metadata
Public interface | INonRibbonTool |
Public interface | INotAbortableCommand |
Public interface | INoteEditorViewModel |
Public interface | INoteViewModel |
Public interface | INumericTextEditorTool | Implement for commands that should be shown using texteditor tool for numeric values and display the unit in ribbon.
Public interface | IOpenAndCreateProductEditorCommand | Product type editor command that open and create new product type.
Public interface | IOpenFileCommand |
Public interface | IOpenSaveUserFolderSettings | Keep recent user folder paths
Public interface | IPaintColorMapsEditorViewModel |
Public interface | IPathSmoothAction | Instance of this interface is created with Get``1(String).
Public interface | IPathSmoothCommand |
Public interface | IPathTeachAction | Instance of this interface is created with Get``1(String).
Public interface | IPathTeachViewModel | Path teach view model interface
Public interface | IPatternEditorViewModel | Pattern editor.
Public interface | IPdfRecordSetting |
Public interface | IPinManipulator | Terminology: Pin - a "control point" or "constraint point", typically used to define rope's position and attachments.
Public interface | IPlaceHolderCommand |
Public interface | IPlugin | Marker interface for UX Plugins
Public interface | IPrepareForPaintingViewModel |
Public interface | IPrintContent |
Public interface | IProcessConfiguratorCommand |
Public interface | IProcessConfiguratorViewModel |
Public interface | IProcessEditorCommand |
Public interface | IProcessEditorViewModel |
Public interface | IProcessMapViewModel |
Public interface | IProcessMapVisibilityCommand |
Public interface | IProcessRuleEditorLine |
Public interface | IProcessRuleEditorViewModel |
Public interface | IProcessTableLineViewModel |
Public interface | IProductActivator |
Public interface | IProductCreatorEditor |
Public interface | IProductEditorCommand |
Public interface | IProductEditorViewModel | Product type editor.
Public interface | IProductPropertyEditor |
Public interface | IProgramEditorChild |
Public interface | IPropertyEditor |
Public interface | IPropertyEditorExtendedContent |
Public interface | IPropertyEditorExtendedContentContainer |
Public interface | IPropertyObjectEditor | Property object editor interface
Public interface | IPropertyObjectEditorAction |
Public interface | IPythonEditorViewModel |
Public interface | IPythonIntellisense |
Public interface | IRadioButtonToolCommand | Interface for action items that should be represented as radio buttons.
Public interface | IRecentDocumentSection | Recent Documents section interface
Public interface | IRecentFolderSection | "Recent Folder" section interface
Public interface | IRecentOpenSaveFolder | Recent Open/Save folder interface
Public interface | IRecordExporterMetadata | This is the interface we will use to describe the metadata being applied to exports of type IPdfRecordExporter.
Public interface | IRecordSetting |
Public interface | IRecordViewModel |
Public interface | IRenderingPresetCommand |
Public interface | IReportingViewModel |
Public interface | IReportProgress | Action interface for reporting progress status.
Public interface | IReportViewModel |
Public interface | IRibbonGroup | Marker interface a ribbon group item.
Public interface | IRibbonSection |
Public interface | IRibbonTab | Marker interface a ribbon tab item.
Public interface | IRibbonToolCommand | Implement for commands that should be presented as toggle tool .
Public interface | IRibbonViewModel |
Public interface | IRobotConversionHelper |
Public interface | IRobotFramesVisibilityAction |
Public interface | IRobotFrameVisibilityCommand |
Public interface | IRobotFrameVisibilityType | Robot Frame visibility toggling command (not related to feature frames).
Public interface | IRobotProgramEditor |
Public interface | IRobotProgramEditorFactory |
Public interface | IRobotTeachOverlayViewModel | Teach 3D overlay menu interface.
Public interface | IRobotTeachViewModel |
Public interface | IRotateViewModel | Rotate view model interface
Public interface | IRouteFixedLineViewModel |
Public interface | IRoutePercentageLineViewModel |
Public interface | IRouteSimpleLineViewModel |
Public interface | IRouteTableLineViewModel |
Public interface | IRoutineVariablesEditorViewModel |
Public interface | IRoutingRuleEditorLine |
Public interface | IRoutingRuleEditorViewModel |
Public interface | IRuleEditor |
Public interface | ISaveComponentAction | Action interface of component saving
Public interface | ISectionEditorNotifier |
Public interface | ISetActiveObjectsEx |
Public interface | ISetOriginCommand |
Public interface | ISettingsHeadersViewModel |
Public interface | IShadingOptionCommand |
Public interface | IShell | Application shell
Public interface | ISignalMapViewModel |
Public interface | ISignalsVisibilityCommand |
Public interface | ISimplePropertyEditorViewModel |
Public interface | ISimulationControlViewModel |
Public interface | ISimulationControlVisibilityCommand |
Public interface | ISimulationNodeTreeViewModel |
Public interface | ISimulationSettingViewModel |
Public interface | ISimulationWorldTreeviewViewModel |
Public interface | ISliceGeometryCommandViewModel |
Public interface | ISnapAxisCommand |
Public interface | ISnapFiltersViewModel |
Public interface | ISnapOriginCommand |
Public interface | IStandaloneActivatorPage |
Public interface | IStartPageViewModel |
Public interface | IStatementTree |
Public interface | IStatisticsPrintCommand |
Public interface | IStatisticsStateMap |
Public interface | ITabPageViewModel |
Public interface | ITextEditorTool | Implement for commands that should be shown using texteditor tool in ribbon.
Public interface | ITextFieldEditorViewModel |
Public interface | ITextureMappingAction |
Public interface | ITextureMappingViewModel |
Public interface | IToggleSnapFilterCommand |
Public interface | IToolTip |
Public interface | IToolTipManager |
Public interface | IToolTipPointerViewModel |
Public interface | IToolTipService |
Public interface | IToolTipViewModel |
Public interface | ITranslateViewModel | Translate view model interface
Public interface | ITreeNode |
Public interface | ITreeViewModel |
Public interface | IUXConfiguration |
Public interface | IVariableLine |
Public interface | IViewportContainer | Represents a ViewModel that manages its own IViewport instance.
Public interface | IViewportContent | Represents the IViewport instance.
Public interface | IViewportToolbar |
Public interface | IWorldGraphView |
Delegates
 | Delegate | Description
Public delegate | ActiveDocumentChangedHandler |
Public delegate | AdornerEventHandler |
Public delegate | FilterPredicate |
Public delegate | LicenseServerConnectionStatusChangeHandler |
Public delegate | MouseHelperHookProc |
Public delegate | NetworkStatusChangedHandler | Define the method signature for network status changes.
Public delegate | OnApplicationMenuClosedHandler |
Public delegate | OnApplicationMenuOpenedHandler |
Public delegate | OnApplicationMenuSelectionChangedHandler |
Public delegate | RawMouseDownHandler | Raw mouse down handler.
Public delegate | RawMouseMoveHandler | Raw mouse move handler.
Public delegate | RibbonInitializedHandler |
Public delegate | RibbonTabItemSelectedHandler | Obsolete.
Public delegate | RibbonTabSelectedHandler |
Enumerations
 | Enumeration | Description
Public enumeration | AreaSelectionActionMode |
Public enumeration | AxisType |
Public enumeration | BackstageHeaderType |
Public enumeration | ButtonType | Defines how buttons are laid out.
Public enumeration | DesiredPaneLocation | Specifies the desired location to dock the pane on the panel.
Public enumeration | DialogType |
Public enumeration | DimensionPart |
Public enumeration | DockManagerPane |
Public enumeration | DrawingViewPoints | Available drawing view points
Public enumeration | DropType |
Public enumeration | ElementType |
Public enumeration | FileStatus |
Public enumeration | FilterMode |
Public enumeration | FilterOptionType |
Public enumeration | FilterType |
Public enumeration | FolderNodeType |
Public enumeration | HoverHighlightType |
Public enumeration | ImageSizeUnits |
Public enumeration | Interaction |
Public enumeration | ItemDropSide |
Public enumeration | LayoutClearingStatus |
Public enumeration | LayoutItemCommandStatus |
Public enumeration | LayoutLoadingStatus |
Public enumeration | ManipulateViews |
Public enumeration | MeasureMode |
Public enumeration | MetadataEditViews |
Public enumeration | OpenFileActionErrorCodes | Available values for ErrorCode.
Public enumeration | OpenSaveFolderType | The Open/Save folders type
Public enumeration | PaintColorVisualization |
Public enumeration | PathTeachResultType |
Public enumeration | PlaceholderNodePlacement |
Public enumeration | PlugMovement |
Public enumeration | ProgressBarStates |
Public enumeration | PythonAttributeEnumType |
Public enumeration | ResourceType |
Public enumeration | SaveComponentActionType | Type of saving commponent
Public enumeration | SearchMode | Defines the search behavior of SearchTextBox.
Public enumeration | SelectAllMode |
Public enumeration | SelectionMode |
Public enumeration | ShapeMaipulatorType |
Public enumeration | ShiftPanelAlignment | Describes content alignment options
Public enumeration | ShiftPanelScaling | Describes content scaling options
Public enumeration | SignalNetworkViewModelConnectionMode | Defines which hidden connections (connections that do not go to selected interface) should be taken into account
Public enumeration | SignalNetworkViewModelDoubleClickCancelAction | Defines how snap action should behave when two clicks were performed within DoubleClickSpeed interval, but in two positions, difference between which is bigger than the DoubleClickWidth
Public enumeration | SignalNetworkViewModelGhostMode | Defines which components should be rendered in ghost mode
Public enumeration | SignalNetworkViewModelNodeExpansionMode | Describes how node expansion works
Public enumeration | SignalNetworkViewModelNodePinningMode | Describes how node pinning works
Public enumeration | SignalNetworkViewModelNonAbstractMode | Controls whether non-abstract components and interfaces can be selected
Public enumeration | SmoothActionErrorCode |
Public enumeration | TextInputType |
Public enumeration | ToolSizingMode | Defines how image and text sizing for the tool.
Public enumeration | ToolTipCategory | Flags that control themed ToolTips.
Public enumeration | ToolTipTemplate | Flags that control ToolTips template.
Public enumeration | TreeMode |
Public enumeration | TreeNodeSelectionMode |
Public enumeration | TreeNodeType |
Public enumeration | TreeViewColumnType |
Public enumeration | UnitFormat |
Public enumeration | UXSiteType |
Public enumeration | VectorOrentation |
Public enumeration | Win32HelperTernaryRasterOperations |
Public enumeration | WindowCaptionButtonsCaptionType | Enum of the types of caption buttons


ActionConfigurationView Class

Interaction logic for ActionConfigurationView.xaml
ActionConfigurationView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedUserControlOptimizedView
VisualComponents.UX.SharedActionConfigurationView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ActionConfigurationView : UserControlOptimizedView,
    IComponentConnector
public ref class ActionConfigurationView : public UserControlOptimizedView,
    IComponentConnector

The ActionConfigurationView type exposes the following members.

Constructors
 | Name | Description
Public method | ActionConfigurationView | Initializes a new instance of the ActionConfigurationView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | (Inherited from UserControlOptimizedView.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ActionConfigurationView Constructor

Initializes a new instance of the ActionConfigurationView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionConfigurationView()
public:
ActionConfigurationView()
See Also

Reference

ActionConfigurationView Class
VisualComponents.UX.Shared Namespace


ActionConfigurationView Properties

The ActionConfigurationView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ActionConfigurationView Class
VisualComponents.UX.Shared Namespace


ActionConfigurationView Methods

The ActionConfigurationView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | (Inherited from UserControlOptimizedView.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ActionConfigurationView Class
VisualComponents.UX.Shared Namespace


ActionConfigurationView.InitializeComponent Method

ActionConfigurationViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

ActionConfigurationView Class
VisualComponents.UX.Shared Namespace


ActionConfigurationView Events

The ActionConfigurationView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ActionConfigurationView Class
VisualComponents.UX.Shared Namespace


ActionExecutionScope Class

Action Execution Scope
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedActionExecutionScope

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ActionExecutionScope : IDisposable
public ref class ActionExecutionScope sealed : IDisposable

The ActionExecutionScope type exposes the following members.

Constructors
 | Name | Description
Public method | ActionExecutionScope | constructor
Top
Methods
 | Name | Description
Public method | Dispose | Dispose method
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ActionExecutionScope Constructor

constructor

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionExecutionScope(
    IEventAggregator eventAggregator,
    IActionItem actionItem
)
public:
ActionExecutionScope(
    IEventAggregator^ eventAggregator,
    IActionItem^ actionItem
)

Parameters

eventAggregator
Type: IEventAggregator
actionItem
Type: VisualComponents.UX.SharedIActionItem
See Also

Reference

ActionExecutionScope Class
VisualComponents.UX.Shared Namespace


ActionExecutionScope Methods

The ActionExecutionScope type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Dispose method
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ActionExecutionScope Class
VisualComponents.UX.Shared Namespace


ActionExecutionScope.Dispose Method

ActionExecutionScopeDispose Method

Dispose method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Dispose()
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

ActionExecutionScope Class
VisualComponents.UX.Shared Namespace


ActionItem Class

ActionItem class
Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.SharedBaseActionItem
VisualComponents.UX.SharedActionItem

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ActionItem : BaseActionItem
public ref class ActionItem : public BaseActionItem

The ActionItem type exposes the following members.

Constructors
 | Name | Description
Public method | ActionItem(String) | Initializes a new instance of ActionItem class
Public method | ActionItem(String, String, String) | Initializes a new instance of ActionItem class
Public method | ActionItem(String, String, String, Action, String, Boolean, Boolean) | Initializes a new instance of ActionItem class
Top
Properties
 | Name | Description
Public property | ActiveAction | Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this). (Inherited from BaseActionItem.)
Protected property | Application | (Inherited from BaseActionItem.)
Public property | AttachTo | (Inherited from BaseActionItem.)
Public property | ButtonMaxWidth | (Inherited from BaseActionItem.)
Public property | ButtonMinWidth | (Inherited from BaseActionItem.)
Public property | ButtonWidth | (Inherited from BaseActionItem.)
Public property | CanExecute | (Inherited from BaseActionItem.)
Protected property | canExecuteAction | Similar to canExecute. This is provided for Visual Basic compatibility. (Inherited from BaseActionItem.)
Public property | CollapseWhenDeactivated | (Inherited from BaseActionItem.)
Public property | CommandRegistry | This references is assigned by CommandRegistry on startup. (Inherited from BaseActionItem.)
Public property | Content | (Inherited from BaseActionItem.)
Public property | Context | (Inherited from BaseActionItem.)
Public property | ContextFilter | (Inherited from BaseActionItem.)
Public property | ControlType | (Inherited from BaseActionItem.)
Public property | Customization | (Inherited from BaseActionItem.)
Protected property | EventMng | Event aggregator (Inherited from BaseActionItem.)
Public property | Icon | (Inherited from BaseActionItem.)
Public property | IconName | (Inherited from BaseActionItem.)
Public property | Id | (Inherited from BaseActionItem.)
Public property | ImageSource | (Inherited from BaseActionItem.)
Public property | IsActivated | (Inherited from BaseActionItem.)
Public property | IsBackgroundVisible | (Inherited from BaseActionItem.)
Public property | IsColoredIcon | (Inherited from BaseActionItem.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsQatCommonTool | (Inherited from BaseActionItem.)
Public property | IsToolNotInRibbon | (Inherited from BaseActionItem.)
Public property | Localization | (Inherited from BaseActionItem.)
Public property | RibbonId | (Inherited from BaseActionItem.)
Public property | SiteOrder | (Inherited from BaseActionItem.)
Protected property | SkipAbortWhenExecuted | If true, action will not abort currently executing action. (Inherited from BaseActionItem.)
Public property | Tag | (Inherited from BaseActionItem.)
Public property | ToolSize | (Inherited from BaseActionItem.)
Public property | ToolTipBookmark | (Inherited from BaseActionItem.)
Public property | ToolTipContent | (Inherited from BaseActionItem.)
Public property | ToolTipContentImage | (Inherited from BaseActionItem.)
Public property | ToolTipFooter | (Inherited from BaseActionItem.)
Public property | ToolTipFooterSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipFooterVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipHeader | (Inherited from BaseActionItem.)
Public property | ToolTipHeaderSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipMoreInfoUrl | (Inherited from BaseActionItem.)
Public property | ToolTipVisibility | (Inherited from BaseActionItem.)
Public property | UxConfig | (Inherited from BaseActionItem.)
Public property | Visibility | (Inherited from BaseActionItem.)
Top
Methods
 | Name | Description
Public method | AfterExecute | (Inherited from BaseActionItem.)
Public method | BeforeExecute | (Inherited from BaseActionItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute | Updates the value of CanExecute (Inherited from BaseActionItem.)
Public method | Execute | The action associated to the ActionItem (Overrides BaseActionItemExecute.)
Public method | Execute(PropertyCollection) | (Inherited from BaseActionItem.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from BaseActionItem.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableForObject | (Inherited from BaseActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from BaseActionItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from BaseActionItem.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | OnImportsSatisfied | Overriding class should call baseclass implementation. (Inherited from BaseActionItem.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SetupBaseActionItem | (Inherited from BaseActionItem.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Protected method | StartAction | Shortcut for calling CommandRegistry.StartCommandPanelAction(this). (Inherited from BaseActionItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
Fields
 | Name | Description
Protected field | _getIconPathFromFile | (Inherited from BaseActionItem.)
Protected field | _isColoredIcon | (Inherited from BaseActionItem.)
Protected field | canExecute | Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called. (Inherited from BaseActionItem.)
Protected field | executeAction |
Protected field | RequestedFeatures | Contains license features requested by the action item. This collection should be populated by the implementing class. (Inherited from BaseActionItem.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ActionItem Constructor

Overload List
 | Name | Description
Public method | ActionItem(String) | Initializes a new instance of ActionItem class
Public method | ActionItem(String, String, String) | Initializes a new instance of ActionItem class
Public method | ActionItem(String, String, String, Action, String, Boolean, Boolean) | Initializes a new instance of ActionItem class
Top
See Also

Reference

ActionItem Class
VisualComponents.UX.Shared Namespace


ActionItem Constructor (String)

Initializes a new instance of ActionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionItem(
    string id
)
public:
ActionItem(
    String^ id
)

Parameters

id
Type: SystemString
See Also

Reference

ActionItem Class
ActionItem Overload
VisualComponents.UX.Shared Namespace


ActionItem Constructor (String, String, String)

Initializes a new instance of ActionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionItem(
    string id,
    string translatedTextId,
    string iconName
)
public:
ActionItem(
    String^ id,
    String^ translatedTextId,
    String^ iconName
)

Parameters

id
Type: SystemString
translatedTextId
Type: SystemString
iconName
Type: SystemString
See Also

Reference

ActionItem Class
ActionItem Overload
VisualComponents.UX.Shared Namespace


ActionItem Constructor (String, String, String, Action, String, Boolean, Boolean)

Initializes a new instance of ActionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionItem(
    string id,
    string translatedTextId,
    string iconName,
    Action execute,
    string controlType = "Button",
    bool getIconPathFromFile = true,
    bool isColoredIcon = true
)
public:
ActionItem(
    String^ id,
    String^ translatedTextId,
    String^ iconName,
    Action^ execute,
    String^ controlType = L"Button",
    bool getIconPathFromFile = true,
    bool isColoredIcon = true
)

Parameters

id
Type: SystemString
translatedTextId
Type: SystemString
iconName
Type: SystemString
vector image file name or path data
execute
Type: SystemAction
controlType (Optional)
Type: SystemString
getIconPathFromFile (Optional)
Type: SystemBoolean
indicator of using default icon path
isColoredIcon (Optional)
Type: SystemBoolean
See Also

Reference

ActionItem Class
ActionItem Overload
VisualComponents.UX.Shared Namespace


ActionItem Properties

The ActionItem type exposes the following members.

Properties
 | Name | Description
Public property | ActiveAction | Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this). (Inherited from BaseActionItem.)
Protected property | Application | (Inherited from BaseActionItem.)
Public property | AttachTo | (Inherited from BaseActionItem.)
Public property | ButtonMaxWidth | (Inherited from BaseActionItem.)
Public property | ButtonMinWidth | (Inherited from BaseActionItem.)
Public property | ButtonWidth | (Inherited from BaseActionItem.)
Public property | CanExecute | (Inherited from BaseActionItem.)
Protected property | canExecuteAction | Similar to canExecute. This is provided for Visual Basic compatibility. (Inherited from BaseActionItem.)
Public property | CollapseWhenDeactivated | (Inherited from BaseActionItem.)
Public property | CommandRegistry | This references is assigned by CommandRegistry on startup. (Inherited from BaseActionItem.)
Public property | Content | (Inherited from BaseActionItem.)
Public property | Context | (Inherited from BaseActionItem.)
Public property | ContextFilter | (Inherited from BaseActionItem.)
Public property | ControlType | (Inherited from BaseActionItem.)
Public property | Customization | (Inherited from BaseActionItem.)
Protected property | EventMng | Event aggregator (Inherited from BaseActionItem.)
Public property | Icon | (Inherited from BaseActionItem.)
Public property | IconName | (Inherited from BaseActionItem.)
Public property | Id | (Inherited from BaseActionItem.)
Public property | ImageSource | (Inherited from BaseActionItem.)
Public property | IsActivated | (Inherited from BaseActionItem.)
Public property | IsBackgroundVisible | (Inherited from BaseActionItem.)
Public property | IsColoredIcon | (Inherited from BaseActionItem.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsQatCommonTool | (Inherited from BaseActionItem.)
Public property | IsToolNotInRibbon | (Inherited from BaseActionItem.)
Public property | Localization | (Inherited from BaseActionItem.)
Public property | RibbonId | (Inherited from BaseActionItem.)
Public property | SiteOrder | (Inherited from BaseActionItem.)
Protected property | SkipAbortWhenExecuted | If true, action will not abort currently executing action. (Inherited from BaseActionItem.)
Public property | Tag | (Inherited from BaseActionItem.)
Public property | ToolSize | (Inherited from BaseActionItem.)
Public property | ToolTipBookmark | (Inherited from BaseActionItem.)
Public property | ToolTipContent | (Inherited from BaseActionItem.)
Public property | ToolTipContentImage | (Inherited from BaseActionItem.)
Public property | ToolTipFooter | (Inherited from BaseActionItem.)
Public property | ToolTipFooterSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipFooterVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipHeader | (Inherited from BaseActionItem.)
Public property | ToolTipHeaderSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipMoreInfoUrl | (Inherited from BaseActionItem.)
Public property | ToolTipVisibility | (Inherited from BaseActionItem.)
Public property | UxConfig | (Inherited from BaseActionItem.)
Public property | Visibility | (Inherited from BaseActionItem.)
Top
See Also

Reference

ActionItem Class
VisualComponents.UX.Shared Namespace


ActionItem Methods

The ActionItem type exposes the following members.

Methods
 | Name | Description
Public method | AfterExecute | (Inherited from BaseActionItem.)
Public method | BeforeExecute | (Inherited from BaseActionItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute | Updates the value of CanExecute (Inherited from BaseActionItem.)
Public method | Execute | The action associated to the ActionItem (Overrides BaseActionItemExecute.)
Public method | Execute(PropertyCollection) | (Inherited from BaseActionItem.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from BaseActionItem.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableForObject | (Inherited from BaseActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from BaseActionItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from BaseActionItem.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | OnImportsSatisfied | Overriding class should call baseclass implementation. (Inherited from BaseActionItem.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SetupBaseActionItem | (Inherited from BaseActionItem.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Protected method | StartAction | Shortcut for calling CommandRegistry.StartCommandPanelAction(this). (Inherited from BaseActionItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ActionItem Class
VisualComponents.UX.Shared Namespace


ActionItem.Execute Method

ActionItemExecute Method

Overload List
 | Name | Description
Public method | Execute | The action associated to the ActionItem (Overrides BaseActionItemExecute.)
Public method | Execute(PropertyCollection) | (Inherited from BaseActionItem.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from BaseActionItem.)
Top
See Also

Reference

ActionItem Class
VisualComponents.UX.Shared Namespace


ActionItem.Execute Method

ActionItemExecute Method

The action associated to the ActionItem

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Execute()
public:
virtual void Execute() override

Implements

IActionItemExecute
See Also

Reference

ActionItem Class
Execute Overload
VisualComponents.UX.Shared Namespace


ActionItem Events

The ActionItem type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
See Also

Reference

ActionItem Class
VisualComponents.UX.Shared Namespace


ActionItem Fields

The ActionItem type exposes the following members.

Fields
 | Name | Description
Protected field | _getIconPathFromFile | (Inherited from BaseActionItem.)
Protected field | _isColoredIcon | (Inherited from BaseActionItem.)
Protected field | canExecute | Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called. (Inherited from BaseActionItem.)
Protected field | executeAction |
Protected field | RequestedFeatures | Contains license features requested by the action item. This collection should be populated by the implementing class. (Inherited from BaseActionItem.)
Top
See Also

Reference

ActionItem Class
VisualComponents.UX.Shared Namespace


ActionItem.executeAction Field

ActionItemexecuteAction Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected Action executeAction
protected:
Action^ executeAction

Field Value

Type: Action
See Also

Reference

ActionItem Class
VisualComponents.UX.Shared Namespace


ActionItem(T1) Class

ActionItemT1 Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.SharedBaseActionItem
VisualComponents.UX.SharedActionItemT1
VisualComponents.UX.SharedPythonActionItem

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ActionItem<T1> : BaseActionItem

generic<typename T1>
public ref class ActionItem : public BaseActionItem

Type Parameters

T1

The ActionItemT1 type exposes the following members.

Constructors
 | Name | Description
Public method | ActionItemT1(String) | Initializes a new instance of ActionItem class
Public method | ActionItemT1(String, String, String) | Initializes a new instance of ActionItem class
Public method | ActionItemT1(String, String, String, ActionT1, String, Boolean, Boolean) | Initializes a new instance of ActionItem class
Top
Properties
 | Name | Description
Public property | ActiveAction | Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this). (Inherited from BaseActionItem.)
Protected property | Application | (Inherited from BaseActionItem.)
Public property | AttachTo | (Inherited from BaseActionItem.)
Public property | ButtonMaxWidth | (Inherited from BaseActionItem.)
Public property | ButtonMinWidth | (Inherited from BaseActionItem.)
Public property | ButtonWidth | (Inherited from BaseActionItem.)
Public property | CanExecute | (Inherited from BaseActionItem.)
Protected property | canExecuteAction | Similar to canExecute. This is provided for Visual Basic compatibility. (Inherited from BaseActionItem.)
Public property | CollapseWhenDeactivated | (Inherited from BaseActionItem.)
Public property | CommandRegistry | This references is assigned by CommandRegistry on startup. (Inherited from BaseActionItem.)
Public property | Content | (Inherited from BaseActionItem.)
Public property | Context | (Inherited from BaseActionItem.)
Public property | ContextFilter | (Inherited from BaseActionItem.)
Public property | ControlType | (Inherited from BaseActionItem.)
Public property | Customization | (Inherited from BaseActionItem.)
Protected property | EventMng | Event aggregator (Inherited from BaseActionItem.)
Public property | Icon | (Inherited from BaseActionItem.)
Public property | IconName | (Inherited from BaseActionItem.)
Public property | Id | (Inherited from BaseActionItem.)
Public property | ImageSource | (Inherited from BaseActionItem.)
Public property | IsActivated | (Inherited from BaseActionItem.)
Public property | IsBackgroundVisible | (Inherited from BaseActionItem.)
Public property | IsColoredIcon | (Inherited from BaseActionItem.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsQatCommonTool | (Inherited from BaseActionItem.)
Public property | IsToolNotInRibbon | (Inherited from BaseActionItem.)
Public property | Localization | (Inherited from BaseActionItem.)
Public property | RibbonId | (Inherited from BaseActionItem.)
Public property | SiteOrder | (Inherited from BaseActionItem.)
Protected property | SkipAbortWhenExecuted | If true, action will not abort currently executing action. (Inherited from BaseActionItem.)
Public property | Tag | (Inherited from BaseActionItem.)
Public property | ToolSize | (Inherited from BaseActionItem.)
Public property | ToolTipBookmark | (Inherited from BaseActionItem.)
Public property | ToolTipContent | (Inherited from BaseActionItem.)
Public property | ToolTipContentImage | (Inherited from BaseActionItem.)
Public property | ToolTipFooter | (Inherited from BaseActionItem.)
Public property | ToolTipFooterSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipFooterVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipHeader | (Inherited from BaseActionItem.)
Public property | ToolTipHeaderSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipMoreInfoUrl | (Inherited from BaseActionItem.)
Public property | ToolTipVisibility | (Inherited from BaseActionItem.)
Public property | UxConfig | (Inherited from BaseActionItem.)
Public property | Visibility | (Inherited from BaseActionItem.)
Top
Methods
 | Name | Description
Public method | AfterExecute | (Inherited from BaseActionItem.)
Public method | BeforeExecute | (Inherited from BaseActionItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute | Updates the value of CanExecute (Inherited from BaseActionItem.)
Public method | Execute | (Overrides BaseActionItemExecute.)
Public method | Execute(T1) | The action associated to the ActionItem
Public method | Execute(PropertyCollection) | (Overrides BaseActionItemExecute(PropertyCollection).)
Public method | Execute(SetupPythonActionMessage) | (Overrides BaseActionItemExecute(SetupPythonActionMessage).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableForObject | (Inherited from BaseActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from BaseActionItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from BaseActionItem.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | OnImportsSatisfied | Overriding class should call baseclass implementation. (Inherited from BaseActionItem.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SetupBaseActionItem | (Inherited from BaseActionItem.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Protected method | StartAction | Shortcut for calling CommandRegistry.StartCommandPanelAction(this). (Inherited from BaseActionItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
Fields
 | Name | Description
Protected field | _getIconPathFromFile | (Inherited from BaseActionItem.)
Protected field | _isColoredIcon | (Inherited from BaseActionItem.)
Protected field | canExecute | Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called. (Inherited from BaseActionItem.)
Protected field | executeAction |
Protected field | RequestedFeatures | Contains license features requested by the action item. This collection should be populated by the implementing class. (Inherited from BaseActionItem.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ActionItem(T1) Constructor

ActionItemT1 Constructor

Overload List
 | Name | Description
Public method | ActionItemT1(String) | Initializes a new instance of ActionItem class
Public method | ActionItemT1(String, String, String) | Initializes a new instance of ActionItem class
Public method | ActionItemT1(String, String, String, ActionT1, String, Boolean, Boolean) | Initializes a new instance of ActionItem class
Top
See Also

Reference

ActionItemT1 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1) Constructor (String)

ActionItemT1 Constructor (String)

Initializes a new instance of ActionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionItem(
    string id
)
public:
ActionItem(
    String^ id
)

Parameters

id
Type: SystemString
See Also

Reference

ActionItemT1 Class
ActionItemT1 Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1) Constructor (String, String, String)

ActionItemT1 Constructor (String, String, String)

Initializes a new instance of ActionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionItem(
    string id,
    string translatedTextId,
    string iconName
)
public:
ActionItem(
    String^ id,
    String^ translatedTextId,
    String^ iconName
)

Parameters

id
Type: SystemString
translatedTextId
Type: SystemString
iconName
Type: SystemString
See Also

Reference

ActionItemT1 Class
ActionItemT1 Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1) Constructor (String, String, String, Action(T1), String, Boolean, Boolean)

ActionItemT1 Constructor (String, String, String, ActionT1, String, Boolean, Boolean)

Initializes a new instance of ActionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionItem(
    string id,
    string translatedTextId,
    string iconName,
    Action<T1> execute,
    string controlType = "Button",
    bool getIconPathFromFile = false,
    bool isColoredIcon = true
)
public:
ActionItem(
    String^ id,
    String^ translatedTextId,
    String^ iconName,
    Action<T1>^ execute,
    String^ controlType = L"Button",
    bool getIconPathFromFile = false,
    bool isColoredIcon = true
)

Parameters

id
Type: SystemString
translatedTextId
Type: SystemString
iconName
Type: SystemString
vector image file name or path data
execute
Type: SystemActionT1
controlType (Optional)
Type: SystemString
getIconPathFromFile (Optional)
Type: SystemBoolean
indicator of using default icon path
isColoredIcon (Optional)
Type: SystemBoolean
See Also

Reference

ActionItemT1 Class
ActionItemT1 Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1) Properties

ActionItemT1 Properties

The ActionItemT1 generic type exposes the following members.

Properties
 | Name | Description
Public property | ActiveAction | Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this). (Inherited from BaseActionItem.)
Protected property | Application | (Inherited from BaseActionItem.)
Public property | AttachTo | (Inherited from BaseActionItem.)
Public property | ButtonMaxWidth | (Inherited from BaseActionItem.)
Public property | ButtonMinWidth | (Inherited from BaseActionItem.)
Public property | ButtonWidth | (Inherited from BaseActionItem.)
Public property | CanExecute | (Inherited from BaseActionItem.)
Protected property | canExecuteAction | Similar to canExecute. This is provided for Visual Basic compatibility. (Inherited from BaseActionItem.)
Public property | CollapseWhenDeactivated | (Inherited from BaseActionItem.)
Public property | CommandRegistry | This references is assigned by CommandRegistry on startup. (Inherited from BaseActionItem.)
Public property | Content | (Inherited from BaseActionItem.)
Public property | Context | (Inherited from BaseActionItem.)
Public property | ContextFilter | (Inherited from BaseActionItem.)
Public property | ControlType | (Inherited from BaseActionItem.)
Public property | Customization | (Inherited from BaseActionItem.)
Protected property | EventMng | Event aggregator (Inherited from BaseActionItem.)
Public property | Icon | (Inherited from BaseActionItem.)
Public property | IconName | (Inherited from BaseActionItem.)
Public property | Id | (Inherited from BaseActionItem.)
Public property | ImageSource | (Inherited from BaseActionItem.)
Public property | IsActivated | (Inherited from BaseActionItem.)
Public property | IsBackgroundVisible | (Inherited from BaseActionItem.)
Public property | IsColoredIcon | (Inherited from BaseActionItem.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsQatCommonTool | (Inherited from BaseActionItem.)
Public property | IsToolNotInRibbon | (Inherited from BaseActionItem.)
Public property | Localization | (Inherited from BaseActionItem.)
Public property | RibbonId | (Inherited from BaseActionItem.)
Public property | SiteOrder | (Inherited from BaseActionItem.)
Protected property | SkipAbortWhenExecuted | If true, action will not abort currently executing action. (Inherited from BaseActionItem.)
Public property | Tag | (Inherited from BaseActionItem.)
Public property | ToolSize | (Inherited from BaseActionItem.)
Public property | ToolTipBookmark | (Inherited from BaseActionItem.)
Public property | ToolTipContent | (Inherited from BaseActionItem.)
Public property | ToolTipContentImage | (Inherited from BaseActionItem.)
Public property | ToolTipFooter | (Inherited from BaseActionItem.)
Public property | ToolTipFooterSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipFooterVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipHeader | (Inherited from BaseActionItem.)
Public property | ToolTipHeaderSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipMoreInfoUrl | (Inherited from BaseActionItem.)
Public property | ToolTipVisibility | (Inherited from BaseActionItem.)
Public property | UxConfig | (Inherited from BaseActionItem.)
Public property | Visibility | (Inherited from BaseActionItem.)
Top
See Also

Reference

ActionItemT1 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1) Methods

ActionItemT1 Methods

The ActionItemT1 generic type exposes the following members.

Methods
 | Name | Description
Public method | AfterExecute | (Inherited from BaseActionItem.)
Public method | BeforeExecute | (Inherited from BaseActionItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute | Updates the value of CanExecute (Inherited from BaseActionItem.)
Public method | Execute | (Overrides BaseActionItemExecute.)
Public method | Execute(T1) | The action associated to the ActionItem
Public method | Execute(PropertyCollection) | (Overrides BaseActionItemExecute(PropertyCollection).)
Public method | Execute(SetupPythonActionMessage) | (Overrides BaseActionItemExecute(SetupPythonActionMessage).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableForObject | (Inherited from BaseActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from BaseActionItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from BaseActionItem.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | OnImportsSatisfied | Overriding class should call baseclass implementation. (Inherited from BaseActionItem.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SetupBaseActionItem | (Inherited from BaseActionItem.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Protected method | StartAction | Shortcut for calling CommandRegistry.StartCommandPanelAction(this). (Inherited from BaseActionItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ActionItemT1 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1).Execute Method

ActionItemT1Execute Method

Overload List
 | Name | Description
Public method | Execute | (Overrides BaseActionItemExecute.)
Public method | Execute(T1) | The action associated to the ActionItem
Public method | Execute(PropertyCollection) | (Overrides BaseActionItemExecute(PropertyCollection).)
Public method | Execute(SetupPythonActionMessage) | (Overrides BaseActionItemExecute(SetupPythonActionMessage).)
Top
See Also

Reference

ActionItemT1 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1).Execute Method

ActionItemT1Execute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Execute()
public:
virtual void Execute() override

Implements

IActionItemExecute
See Also

Reference

ActionItemT1 Class
Execute Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1).Execute Method (T1)

ActionItemT1Execute Method (T1)

The action associated to the ActionItem

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void Execute(
    T1 p1
)
public:
virtual void Execute(
    T1 p1
)

Parameters

p1
Type: T1
See Also

Reference

ActionItemT1 Class
Execute Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1).Execute Method (PropertyCollection)

ActionItemT1Execute Method (PropertyCollection)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Execute(
    PropertyCollection args
)
public:
virtual void Execute(
    PropertyCollection^ args
) override

Parameters

args
Type: VisualComponents.Create3DPropertyCollection

Implements

IActionItemExecute(PropertyCollection)
See Also

Reference

ActionItemT1 Class
Execute Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1).Execute Method (SetupPythonActionMessage)

ActionItemT1Execute Method (SetupPythonActionMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Execute(
    SetupPythonActionMessage message
)
public:
virtual void Execute(
    SetupPythonActionMessage^ message
) override

Parameters

message
Type: VisualComponents.Create3DSetupPythonActionMessage

Implements

IActionItemExecute(SetupPythonActionMessage)
See Also

Reference

ActionItemT1 Class
Execute Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1) Events

ActionItemT1 Events

The ActionItemT1 generic type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
See Also

Reference

ActionItemT1 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1) Fields

ActionItemT1 Fields

The ActionItemT1 generic type exposes the following members.

Fields
 | Name | Description
Protected field | _getIconPathFromFile | (Inherited from BaseActionItem.)
Protected field | _isColoredIcon | (Inherited from BaseActionItem.)
Protected field | canExecute | Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called. (Inherited from BaseActionItem.)
Protected field | executeAction |
Protected field | RequestedFeatures | Contains license features requested by the action item. This collection should be populated by the implementing class. (Inherited from BaseActionItem.)
Top
See Also

Reference

ActionItemT1 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1).executeAction Field

ActionItemT1executeAction Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected Action<T1> executeAction
protected:
Action<T1>^ executeAction

Field Value

Type: ActionT1
See Also

Reference

ActionItemT1 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2) Class

ActionItemT1, T2 Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.SharedBaseActionItem
VisualComponents.UX.SharedActionItemT1, T2

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ActionItem<T1, T2> : BaseActionItem

generic<typename T1, typename T2>
public ref class ActionItem : public BaseActionItem

Type Parameters

T1
T2

The ActionItemT1, T2 type exposes the following members.

Constructors
 | Name | Description
Public method | ActionItemT1, T2(String) | Initializes a new instance of ActionItem class
Public method | ActionItemT1, T2(String, String, String) | Initializes a new instance of ActionItem class
Public method | ActionItemT1, T2(String, String, String, ActionT1, T2, String, Boolean, Boolean) | Initializes a new instance of ActionItem class
Top
Properties
 | Name | Description
Public property | ActiveAction | Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this). (Inherited from BaseActionItem.)
Protected property | Application | (Inherited from BaseActionItem.)
Public property | AttachTo | (Inherited from BaseActionItem.)
Public property | ButtonMaxWidth | (Inherited from BaseActionItem.)
Public property | ButtonMinWidth | (Inherited from BaseActionItem.)
Public property | ButtonWidth | (Inherited from BaseActionItem.)
Public property | CanExecute | (Inherited from BaseActionItem.)
Protected property | canExecuteAction | Similar to canExecute. This is provided for Visual Basic compatibility. (Inherited from BaseActionItem.)
Public property | CollapseWhenDeactivated | (Inherited from BaseActionItem.)
Public property | CommandRegistry | This references is assigned by CommandRegistry on startup. (Inherited from BaseActionItem.)
Public property | Content | (Inherited from BaseActionItem.)
Public property | Context | (Inherited from BaseActionItem.)
Public property | ContextFilter | (Inherited from BaseActionItem.)
Public property | ControlType | (Inherited from BaseActionItem.)
Public property | Customization | (Inherited from BaseActionItem.)
Protected property | EventMng | Event aggregator (Inherited from BaseActionItem.)
Public property | Icon | (Inherited from BaseActionItem.)
Public property | IconName | (Inherited from BaseActionItem.)
Public property | Id | (Inherited from BaseActionItem.)
Public property | ImageSource | (Inherited from BaseActionItem.)
Public property | IsActivated | (Inherited from BaseActionItem.)
Public property | IsBackgroundVisible | (Inherited from BaseActionItem.)
Public property | IsColoredIcon | (Inherited from BaseActionItem.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsQatCommonTool | (Inherited from BaseActionItem.)
Public property | IsToolNotInRibbon | (Inherited from BaseActionItem.)
Public property | Localization | (Inherited from BaseActionItem.)
Public property | RibbonId | (Inherited from BaseActionItem.)
Public property | SiteOrder | (Inherited from BaseActionItem.)
Protected property | SkipAbortWhenExecuted | If true, action will not abort currently executing action. (Inherited from BaseActionItem.)
Public property | Tag | (Inherited from BaseActionItem.)
Public property | ToolSize | (Inherited from BaseActionItem.)
Public property | ToolTipBookmark | (Inherited from BaseActionItem.)
Public property | ToolTipContent | (Inherited from BaseActionItem.)
Public property | ToolTipContentImage | (Inherited from BaseActionItem.)
Public property | ToolTipFooter | (Inherited from BaseActionItem.)
Public property | ToolTipFooterSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipFooterVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipHeader | (Inherited from BaseActionItem.)
Public property | ToolTipHeaderSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipMoreInfoUrl | (Inherited from BaseActionItem.)
Public property | ToolTipVisibility | (Inherited from BaseActionItem.)
Public property | UxConfig | (Inherited from BaseActionItem.)
Public property | Visibility | (Inherited from BaseActionItem.)
Top
Methods
 | Name | Description
Public method | AfterExecute | (Inherited from BaseActionItem.)
Public method | BeforeExecute | (Inherited from BaseActionItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute | Updates the value of CanExecute (Inherited from BaseActionItem.)
Public method | Execute | (Overrides BaseActionItemExecute.)
Public method | Execute(PropertyCollection) | (Inherited from BaseActionItem.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from BaseActionItem.)
Public method | Execute(T1, T2) | The action associated to the ActionItem
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableForObject | (Inherited from BaseActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from BaseActionItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from BaseActionItem.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | OnImportsSatisfied | Overriding class should call baseclass implementation. (Inherited from BaseActionItem.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SetupBaseActionItem | (Inherited from BaseActionItem.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Protected method | StartAction | Shortcut for calling CommandRegistry.StartCommandPanelAction(this). (Inherited from BaseActionItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
Fields
 | Name | Description
Protected field | _getIconPathFromFile | (Inherited from BaseActionItem.)
Protected field | _isColoredIcon | (Inherited from BaseActionItem.)
Protected field | canExecute | Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called. (Inherited from BaseActionItem.)
Protected field | executeAction |
Protected field | RequestedFeatures | Contains license features requested by the action item. This collection should be populated by the implementing class. (Inherited from BaseActionItem.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ActionItem(T1, T2) Constructor

ActionItemT1, T2 Constructor

Overload List
 | Name | Description
Public method | ActionItemT1, T2(String) | Initializes a new instance of ActionItem class
Public method | ActionItemT1, T2(String, String, String) | Initializes a new instance of ActionItem class
Public method | ActionItemT1, T2(String, String, String, ActionT1, T2, String, Boolean, Boolean) | Initializes a new instance of ActionItem class
Top
See Also

Reference

ActionItemT1, T2 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2) Constructor (String)

ActionItemT1, T2 Constructor (String)

Initializes a new instance of ActionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionItem(
    string id
)
public:
ActionItem(
    String^ id
)

Parameters

id
Type: SystemString
See Also

Reference

ActionItemT1, T2 Class
ActionItemT1, T2 Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2) Constructor (String, String, String)

ActionItemT1, T2 Constructor (String, String, String)

Initializes a new instance of ActionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionItem(
    string id,
    string translatedTextId,
    string iconName
)
public:
ActionItem(
    String^ id,
    String^ translatedTextId,
    String^ iconName
)

Parameters

id
Type: SystemString
translatedTextId
Type: SystemString
iconName
Type: SystemString
See Also

Reference

ActionItemT1, T2 Class
ActionItemT1, T2 Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2) Constructor (String, String, String, Action(T1, T2), String, Boolean, Boolean)

ActionItemT1, T2 Constructor (String, String, String, ActionT1, T2, String, Boolean, Boolean)

Initializes a new instance of ActionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionItem(
    string id,
    string content,
    string iconName,
    Action<T1, T2> execute,
    string controlType = "Button",
    bool getIconPathFromFile = false,
    bool isColoredIcon = true
)
public:
ActionItem(
    String^ id,
    String^ content,
    String^ iconName,
    Action<T1, T2>^ execute,
    String^ controlType = L"Button",
    bool getIconPathFromFile = false,
    bool isColoredIcon = true
)

Parameters

id
Type: SystemString
content
Type: SystemString
iconName
Type: SystemString
vector image file name or path data
execute
Type: SystemActionT1, T2
controlType (Optional)
Type: SystemString
getIconPathFromFile (Optional)
Type: SystemBoolean
indicator of using default icon path
isColoredIcon (Optional)
Type: SystemBoolean
See Also

Reference

ActionItemT1, T2 Class
ActionItemT1, T2 Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2) Properties

ActionItemT1, T2 Properties

The ActionItemT1, T2 generic type exposes the following members.

Properties
 | Name | Description
Public property | ActiveAction | Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this). (Inherited from BaseActionItem.)
Protected property | Application | (Inherited from BaseActionItem.)
Public property | AttachTo | (Inherited from BaseActionItem.)
Public property | ButtonMaxWidth | (Inherited from BaseActionItem.)
Public property | ButtonMinWidth | (Inherited from BaseActionItem.)
Public property | ButtonWidth | (Inherited from BaseActionItem.)
Public property | CanExecute | (Inherited from BaseActionItem.)
Protected property | canExecuteAction | Similar to canExecute. This is provided for Visual Basic compatibility. (Inherited from BaseActionItem.)
Public property | CollapseWhenDeactivated | (Inherited from BaseActionItem.)
Public property | CommandRegistry | This references is assigned by CommandRegistry on startup. (Inherited from BaseActionItem.)
Public property | Content | (Inherited from BaseActionItem.)
Public property | Context | (Inherited from BaseActionItem.)
Public property | ContextFilter | (Inherited from BaseActionItem.)
Public property | ControlType | (Inherited from BaseActionItem.)
Public property | Customization | (Inherited from BaseActionItem.)
Protected property | EventMng | Event aggregator (Inherited from BaseActionItem.)
Public property | Icon | (Inherited from BaseActionItem.)
Public property | IconName | (Inherited from BaseActionItem.)
Public property | Id | (Inherited from BaseActionItem.)
Public property | ImageSource | (Inherited from BaseActionItem.)
Public property | IsActivated | (Inherited from BaseActionItem.)
Public property | IsBackgroundVisible | (Inherited from BaseActionItem.)
Public property | IsColoredIcon | (Inherited from BaseActionItem.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsQatCommonTool | (Inherited from BaseActionItem.)
Public property | IsToolNotInRibbon | (Inherited from BaseActionItem.)
Public property | Localization | (Inherited from BaseActionItem.)
Public property | RibbonId | (Inherited from BaseActionItem.)
Public property | SiteOrder | (Inherited from BaseActionItem.)
Protected property | SkipAbortWhenExecuted | If true, action will not abort currently executing action. (Inherited from BaseActionItem.)
Public property | Tag | (Inherited from BaseActionItem.)
Public property | ToolSize | (Inherited from BaseActionItem.)
Public property | ToolTipBookmark | (Inherited from BaseActionItem.)
Public property | ToolTipContent | (Inherited from BaseActionItem.)
Public property | ToolTipContentImage | (Inherited from BaseActionItem.)
Public property | ToolTipFooter | (Inherited from BaseActionItem.)
Public property | ToolTipFooterSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipFooterVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipHeader | (Inherited from BaseActionItem.)
Public property | ToolTipHeaderSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipMoreInfoUrl | (Inherited from BaseActionItem.)
Public property | ToolTipVisibility | (Inherited from BaseActionItem.)
Public property | UxConfig | (Inherited from BaseActionItem.)
Public property | Visibility | (Inherited from BaseActionItem.)
Top
See Also

Reference

ActionItemT1, T2 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2) Methods

ActionItemT1, T2 Methods

The ActionItemT1, T2 generic type exposes the following members.

Methods
 | Name | Description
Public method | AfterExecute | (Inherited from BaseActionItem.)
Public method | BeforeExecute | (Inherited from BaseActionItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute | Updates the value of CanExecute (Inherited from BaseActionItem.)
Public method | Execute | (Overrides BaseActionItemExecute.)
Public method | Execute(PropertyCollection) | (Inherited from BaseActionItem.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from BaseActionItem.)
Public method | Execute(T1, T2) | The action associated to the ActionItem
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableForObject | (Inherited from BaseActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from BaseActionItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from BaseActionItem.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | OnImportsSatisfied | Overriding class should call baseclass implementation. (Inherited from BaseActionItem.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SetupBaseActionItem | (Inherited from BaseActionItem.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Protected method | StartAction | Shortcut for calling CommandRegistry.StartCommandPanelAction(this). (Inherited from BaseActionItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ActionItemT1, T2 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2).Execute Method

ActionItemT1, T2Execute Method

Overload List
 | Name | Description
Public method | Execute | (Overrides BaseActionItemExecute.)
Public method | Execute(PropertyCollection) | (Inherited from BaseActionItem.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from BaseActionItem.)
Public method | Execute(T1, T2) | The action associated to the ActionItem
Top
See Also

Reference

ActionItemT1, T2 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2).Execute Method

ActionItemT1, T2Execute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Execute()
public:
virtual void Execute() override

Implements

IActionItemExecute
See Also

Reference

ActionItemT1, T2 Class
Execute Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2).Execute Method (T1, T2)

ActionItemT1, T2Execute Method (T1, T2)

The action associated to the ActionItem

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void Execute(
    T1 p1,
    T2 p2
)
public:
virtual void Execute(
    T1 p1,
    T2 p2
)

Parameters

p1
Type: T1
p2
Type: T2
See Also

Reference

ActionItemT1, T2 Class
Execute Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2) Events

ActionItemT1, T2 Events

The ActionItemT1, T2 generic type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
See Also

Reference

ActionItemT1, T2 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2) Fields

ActionItemT1, T2 Fields

The ActionItemT1, T2 generic type exposes the following members.

Fields
 | Name | Description
Protected field | _getIconPathFromFile | (Inherited from BaseActionItem.)
Protected field | _isColoredIcon | (Inherited from BaseActionItem.)
Protected field | canExecute | Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called. (Inherited from BaseActionItem.)
Protected field | executeAction |
Protected field | RequestedFeatures | Contains license features requested by the action item. This collection should be populated by the implementing class. (Inherited from BaseActionItem.)
Top
See Also

Reference

ActionItemT1, T2 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2).executeAction Field

ActionItemT1, T2executeAction Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected Action<T1, T2> executeAction
protected:
Action<T1, T2>^ executeAction

Field Value

Type: ActionT1, T2
See Also

Reference

ActionItemT1, T2 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3) Class

ActionItemT1, T2, T3 Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.SharedBaseActionItem
VisualComponents.UX.SharedActionItemT1, T2, T3

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ActionItem<T1, T2, T3> : BaseActionItem

generic<typename T1, typename T2, typename T3>
public ref class ActionItem : public BaseActionItem

Type Parameters

T1
T2
T3

The ActionItemT1, T2, T3 type exposes the following members.

Constructors
 | Name | Description
Public method | ActionItemT1, T2, T3(String) | Initializes a new instance of ActionItem class
Public method | ActionItemT1, T2, T3(String, String, String) | Initializes a new instance of ActionItem class
Public method | ActionItemT1, T2, T3(String, String, String, ActionT1, T2, T3, String, Boolean, Boolean) | Initializes a new instance of ActionItem class
Top
Properties
 | Name | Description
Public property | ActiveAction | Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this). (Inherited from BaseActionItem.)
Protected property | Application | (Inherited from BaseActionItem.)
Public property | AttachTo | (Inherited from BaseActionItem.)
Public property | ButtonMaxWidth | (Inherited from BaseActionItem.)
Public property | ButtonMinWidth | (Inherited from BaseActionItem.)
Public property | ButtonWidth | (Inherited from BaseActionItem.)
Public property | CanExecute | (Inherited from BaseActionItem.)
Protected property | canExecuteAction | Similar to canExecute. This is provided for Visual Basic compatibility. (Inherited from BaseActionItem.)
Public property | CollapseWhenDeactivated | (Inherited from BaseActionItem.)
Public property | CommandRegistry | This references is assigned by CommandRegistry on startup. (Inherited from BaseActionItem.)
Public property | Content | (Inherited from BaseActionItem.)
Public property | Context | (Inherited from BaseActionItem.)
Public property | ContextFilter | (Inherited from BaseActionItem.)
Public property | ControlType | (Inherited from BaseActionItem.)
Public property | Customization | (Inherited from BaseActionItem.)
Protected property | EventMng | Event aggregator (Inherited from BaseActionItem.)
Public property | Icon | (Inherited from BaseActionItem.)
Public property | IconName | (Inherited from BaseActionItem.)
Public property | Id | (Inherited from BaseActionItem.)
Public property | ImageSource | (Inherited from BaseActionItem.)
Public property | IsActivated | (Inherited from BaseActionItem.)
Public property | IsBackgroundVisible | (Inherited from BaseActionItem.)
Public property | IsColoredIcon | (Inherited from BaseActionItem.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsQatCommonTool | (Inherited from BaseActionItem.)
Public property | IsToolNotInRibbon | (Inherited from BaseActionItem.)
Public property | Localization | (Inherited from BaseActionItem.)
Public property | RibbonId | (Inherited from BaseActionItem.)
Public property | SiteOrder | (Inherited from BaseActionItem.)
Protected property | SkipAbortWhenExecuted | If true, action will not abort currently executing action. (Inherited from BaseActionItem.)
Public property | Tag | (Inherited from BaseActionItem.)
Public property | ToolSize | (Inherited from BaseActionItem.)
Public property | ToolTipBookmark | (Inherited from BaseActionItem.)
Public property | ToolTipContent | (Inherited from BaseActionItem.)
Public property | ToolTipContentImage | (Inherited from BaseActionItem.)
Public property | ToolTipFooter | (Inherited from BaseActionItem.)
Public property | ToolTipFooterSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipFooterVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipHeader | (Inherited from BaseActionItem.)
Public property | ToolTipHeaderSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipMoreInfoUrl | (Inherited from BaseActionItem.)
Public property | ToolTipVisibility | (Inherited from BaseActionItem.)
Public property | UxConfig | (Inherited from BaseActionItem.)
Public property | Visibility | (Inherited from BaseActionItem.)
Top
Methods
 | Name | Description
Public method | AfterExecute | (Inherited from BaseActionItem.)
Public method | BeforeExecute | (Inherited from BaseActionItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute | Updates the value of CanExecute (Inherited from BaseActionItem.)
Public method | Execute | (Overrides BaseActionItemExecute.)
Public method | Execute(PropertyCollection) | (Inherited from BaseActionItem.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from BaseActionItem.)
Public method | Execute(T1, T2, T3) | The action associated to the ActionItem
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableForObject | (Inherited from BaseActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from BaseActionItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from BaseActionItem.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | OnImportsSatisfied | Overriding class should call baseclass implementation. (Inherited from BaseActionItem.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SetupBaseActionItem | (Inherited from BaseActionItem.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Protected method | StartAction | Shortcut for calling CommandRegistry.StartCommandPanelAction(this). (Inherited from BaseActionItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
Fields
 | Name | Description
Protected field | _getIconPathFromFile | (Inherited from BaseActionItem.)
Protected field | _isColoredIcon | (Inherited from BaseActionItem.)
Protected field | canExecute | Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called. (Inherited from BaseActionItem.)
Protected field | executeAction |
Protected field | RequestedFeatures | Contains license features requested by the action item. This collection should be populated by the implementing class. (Inherited from BaseActionItem.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3) Constructor

ActionItemT1, T2, T3 Constructor

Overload List
 | Name | Description
Public method | ActionItemT1, T2, T3(String) | Initializes a new instance of ActionItem class
Public method | ActionItemT1, T2, T3(String, String, String) | Initializes a new instance of ActionItem class
Public method | ActionItemT1, T2, T3(String, String, String, ActionT1, T2, T3, String, Boolean, Boolean) | Initializes a new instance of ActionItem class
Top
See Also

Reference

ActionItemT1, T2, T3 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3) Constructor (String)

ActionItemT1, T2, T3 Constructor (String)

Initializes a new instance of ActionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionItem(
    string id
)
public:
ActionItem(
    String^ id
)

Parameters

id
Type: SystemString
See Also

Reference

ActionItemT1, T2, T3 Class
ActionItemT1, T2, T3 Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3) Constructor (String, String, String)

ActionItemT1, T2, T3 Constructor (String, String, String)

Initializes a new instance of ActionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionItem(
    string id,
    string translatedTextId,
    string iconName
)
public:
ActionItem(
    String^ id,
    String^ translatedTextId,
    String^ iconName
)

Parameters

id
Type: SystemString
translatedTextId
Type: SystemString
iconName
Type: SystemString
See Also

Reference

ActionItemT1, T2, T3 Class
ActionItemT1, T2, T3 Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3) Constructor (String, String, String, Action(T1, T2, T3), String, Boolean, Boolean)

ActionItemT1, T2, T3 Constructor (String, String, String, ActionT1, T2, T3, String, Boolean, Boolean)

Initializes a new instance of ActionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionItem(
    string id,
    string content,
    string iconName,
    Action<T1, T2, T3> execute,
    string controlType = "Button",
    bool getIconPathFromFile = false,
    bool isColoredIcon = true
)
public:
ActionItem(
    String^ id,
    String^ content,
    String^ iconName,
    Action<T1, T2, T3>^ execute,
    String^ controlType = L"Button",
    bool getIconPathFromFile = false,
    bool isColoredIcon = true
)

Parameters

id
Type: SystemString
content
Type: SystemString
iconName
Type: SystemString
vector image file name or path data
execute
Type: SystemActionT1, T2, T3
controlType (Optional)
Type: SystemString
getIconPathFromFile (Optional)
Type: SystemBoolean
indicator of using default icon path
isColoredIcon (Optional)
Type: SystemBoolean
See Also

Reference

ActionItemT1, T2, T3 Class
ActionItemT1, T2, T3 Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3) Properties

ActionItemT1, T2, T3 Properties

The ActionItemT1, T2, T3 generic type exposes the following members.

Properties
 | Name | Description
Public property | ActiveAction | Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this). (Inherited from BaseActionItem.)
Protected property | Application | (Inherited from BaseActionItem.)
Public property | AttachTo | (Inherited from BaseActionItem.)
Public property | ButtonMaxWidth | (Inherited from BaseActionItem.)
Public property | ButtonMinWidth | (Inherited from BaseActionItem.)
Public property | ButtonWidth | (Inherited from BaseActionItem.)
Public property | CanExecute | (Inherited from BaseActionItem.)
Protected property | canExecuteAction | Similar to canExecute. This is provided for Visual Basic compatibility. (Inherited from BaseActionItem.)
Public property | CollapseWhenDeactivated | (Inherited from BaseActionItem.)
Public property | CommandRegistry | This references is assigned by CommandRegistry on startup. (Inherited from BaseActionItem.)
Public property | Content | (Inherited from BaseActionItem.)
Public property | Context | (Inherited from BaseActionItem.)
Public property | ContextFilter | (Inherited from BaseActionItem.)
Public property | ControlType | (Inherited from BaseActionItem.)
Public property | Customization | (Inherited from BaseActionItem.)
Protected property | EventMng | Event aggregator (Inherited from BaseActionItem.)
Public property | Icon | (Inherited from BaseActionItem.)
Public property | IconName | (Inherited from BaseActionItem.)
Public property | Id | (Inherited from BaseActionItem.)
Public property | ImageSource | (Inherited from BaseActionItem.)
Public property | IsActivated | (Inherited from BaseActionItem.)
Public property | IsBackgroundVisible | (Inherited from BaseActionItem.)
Public property | IsColoredIcon | (Inherited from BaseActionItem.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsQatCommonTool | (Inherited from BaseActionItem.)
Public property | IsToolNotInRibbon | (Inherited from BaseActionItem.)
Public property | Localization | (Inherited from BaseActionItem.)
Public property | RibbonId | (Inherited from BaseActionItem.)
Public property | SiteOrder | (Inherited from BaseActionItem.)
Protected property | SkipAbortWhenExecuted | If true, action will not abort currently executing action. (Inherited from BaseActionItem.)
Public property | Tag | (Inherited from BaseActionItem.)
Public property | ToolSize | (Inherited from BaseActionItem.)
Public property | ToolTipBookmark | (Inherited from BaseActionItem.)
Public property | ToolTipContent | (Inherited from BaseActionItem.)
Public property | ToolTipContentImage | (Inherited from BaseActionItem.)
Public property | ToolTipFooter | (Inherited from BaseActionItem.)
Public property | ToolTipFooterSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipFooterVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipHeader | (Inherited from BaseActionItem.)
Public property | ToolTipHeaderSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipMoreInfoUrl | (Inherited from BaseActionItem.)
Public property | ToolTipVisibility | (Inherited from BaseActionItem.)
Public property | UxConfig | (Inherited from BaseActionItem.)
Public property | Visibility | (Inherited from BaseActionItem.)
Top
See Also

Reference

ActionItemT1, T2, T3 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3) Methods

ActionItemT1, T2, T3 Methods

The ActionItemT1, T2, T3 generic type exposes the following members.

Methods
 | Name | Description
Public method | AfterExecute | (Inherited from BaseActionItem.)
Public method | BeforeExecute | (Inherited from BaseActionItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute | Updates the value of CanExecute (Inherited from BaseActionItem.)
Public method | Execute | (Overrides BaseActionItemExecute.)
Public method | Execute(PropertyCollection) | (Inherited from BaseActionItem.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from BaseActionItem.)
Public method | Execute(T1, T2, T3) | The action associated to the ActionItem
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableForObject | (Inherited from BaseActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from BaseActionItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from BaseActionItem.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | OnImportsSatisfied | Overriding class should call baseclass implementation. (Inherited from BaseActionItem.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SetupBaseActionItem | (Inherited from BaseActionItem.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Protected method | StartAction | Shortcut for calling CommandRegistry.StartCommandPanelAction(this). (Inherited from BaseActionItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ActionItemT1, T2, T3 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3).Execute Method

ActionItemT1, T2, T3Execute Method

Overload List
 | Name | Description
Public method | Execute | (Overrides BaseActionItemExecute.)
Public method | Execute(PropertyCollection) | (Inherited from BaseActionItem.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from BaseActionItem.)
Public method | Execute(T1, T2, T3) | The action associated to the ActionItem
Top
See Also

Reference

ActionItemT1, T2, T3 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3).Execute Method

ActionItemT1, T2, T3Execute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Execute()
public:
virtual void Execute() override

Implements

IActionItemExecute
See Also

Reference

ActionItemT1, T2, T3 Class
Execute Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3).Execute Method (T1, T2, T3)

ActionItemT1, T2, T3Execute Method (T1, T2, T3)

The action associated to the ActionItem

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void Execute(
    T1 p1,
    T2 p2,
    T3 p3
)
public:
virtual void Execute(
    T1 p1,
    T2 p2,
    T3 p3
)

Parameters

p1
Type: T1
p2
Type: T2
p3
Type: T3
See Also

Reference

ActionItemT1, T2, T3 Class
Execute Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3) Events

ActionItemT1, T2, T3 Events

The ActionItemT1, T2, T3 generic type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
See Also

Reference

ActionItemT1, T2, T3 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3) Fields

ActionItemT1, T2, T3 Fields

The ActionItemT1, T2, T3 generic type exposes the following members.

Fields
 | Name | Description
Protected field | _getIconPathFromFile | (Inherited from BaseActionItem.)
Protected field | _isColoredIcon | (Inherited from BaseActionItem.)
Protected field | canExecute | Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called. (Inherited from BaseActionItem.)
Protected field | executeAction |
Protected field | RequestedFeatures | Contains license features requested by the action item. This collection should be populated by the implementing class. (Inherited from BaseActionItem.)
Top
See Also

Reference

ActionItemT1, T2, T3 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3).executeAction Field

ActionItemT1, T2, T3executeAction Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected Action<T1, T2, T3> executeAction
protected:
Action<T1, T2, T3>^ executeAction

Field Value

Type: ActionT1, T2, T3
See Also

Reference

ActionItemT1, T2, T3 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4) Class

ActionItemT1, T2, T3, T4 Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.SharedBaseActionItem
VisualComponents.UX.SharedActionItemT1, T2, T3, T4

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ActionItem<T1, T2, T3, T4> : BaseActionItem

generic<typename T1, typename T2, typename T3, typename T4>
public ref class ActionItem : public BaseActionItem

Type Parameters

T1
T2
T3
T4

The ActionItemT1, T2, T3, T4 type exposes the following members.

Constructors
 | Name | Description
Public method | ActionItemT1, T2, T3, T4(String) | Initializes a new instance of ActionItem class
Public method | ActionItemT1, T2, T3, T4(String, String, String) | Initializes a new instance of ActionItem class
Public method | ActionItemT1, T2, T3, T4(String, String, String, ActionT1, T2, T3, T4, String, Boolean, Boolean) | Initializes a new instance of ActionItem class
Top
Properties
 | Name | Description
Public property | ActiveAction | Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this). (Inherited from BaseActionItem.)
Protected property | Application | (Inherited from BaseActionItem.)
Public property | AttachTo | (Inherited from BaseActionItem.)
Public property | ButtonMaxWidth | (Inherited from BaseActionItem.)
Public property | ButtonMinWidth | (Inherited from BaseActionItem.)
Public property | ButtonWidth | (Inherited from BaseActionItem.)
Public property | CanExecute | (Inherited from BaseActionItem.)
Protected property | canExecuteAction | Similar to canExecute. This is provided for Visual Basic compatibility. (Inherited from BaseActionItem.)
Public property | CollapseWhenDeactivated | (Inherited from BaseActionItem.)
Public property | CommandRegistry | This references is assigned by CommandRegistry on startup. (Inherited from BaseActionItem.)
Public property | Content | (Inherited from BaseActionItem.)
Public property | Context | (Inherited from BaseActionItem.)
Public property | ContextFilter | (Inherited from BaseActionItem.)
Public property | ControlType | (Inherited from BaseActionItem.)
Public property | Customization | (Inherited from BaseActionItem.)
Protected property | EventMng | Event aggregator (Inherited from BaseActionItem.)
Public property | Icon | (Inherited from BaseActionItem.)
Public property | IconName | (Inherited from BaseActionItem.)
Public property | Id | (Inherited from BaseActionItem.)
Public property | ImageSource | (Inherited from BaseActionItem.)
Public property | IsActivated | (Inherited from BaseActionItem.)
Public property | IsBackgroundVisible | (Inherited from BaseActionItem.)
Public property | IsColoredIcon | (Inherited from BaseActionItem.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsQatCommonTool | (Inherited from BaseActionItem.)
Public property | IsToolNotInRibbon | (Inherited from BaseActionItem.)
Public property | Localization | (Inherited from BaseActionItem.)
Public property | RibbonId | (Inherited from BaseActionItem.)
Public property | SiteOrder | (Inherited from BaseActionItem.)
Protected property | SkipAbortWhenExecuted | If true, action will not abort currently executing action. (Inherited from BaseActionItem.)
Public property | Tag | (Inherited from BaseActionItem.)
Public property | ToolSize | (Inherited from BaseActionItem.)
Public property | ToolTipBookmark | (Inherited from BaseActionItem.)
Public property | ToolTipContent | (Inherited from BaseActionItem.)
Public property | ToolTipContentImage | (Inherited from BaseActionItem.)
Public property | ToolTipFooter | (Inherited from BaseActionItem.)
Public property | ToolTipFooterSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipFooterVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipHeader | (Inherited from BaseActionItem.)
Public property | ToolTipHeaderSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipMoreInfoUrl | (Inherited from BaseActionItem.)
Public property | ToolTipVisibility | (Inherited from BaseActionItem.)
Public property | UxConfig | (Inherited from BaseActionItem.)
Public property | Visibility | (Inherited from BaseActionItem.)
Top
Methods
 | Name | Description
Public method | AfterExecute | (Inherited from BaseActionItem.)
Public method | BeforeExecute | (Inherited from BaseActionItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute | Updates the value of CanExecute (Inherited from BaseActionItem.)
Public method | Execute | (Overrides BaseActionItemExecute.)
Public method | Execute(PropertyCollection) | (Inherited from BaseActionItem.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from BaseActionItem.)
Public method | Execute(T1, T2, T3, T4) | The action associated to the ActionItem
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableForObject | (Inherited from BaseActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from BaseActionItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from BaseActionItem.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | OnImportsSatisfied | Overriding class should call baseclass implementation. (Inherited from BaseActionItem.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SetupBaseActionItem | (Inherited from BaseActionItem.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Protected method | StartAction | Shortcut for calling CommandRegistry.StartCommandPanelAction(this). (Inherited from BaseActionItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
Fields
 | Name | Description
Protected field | _getIconPathFromFile | (Inherited from BaseActionItem.)
Protected field | _isColoredIcon | (Inherited from BaseActionItem.)
Protected field | canExecute | Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called. (Inherited from BaseActionItem.)
Protected field | executeAction |
Protected field | RequestedFeatures | Contains license features requested by the action item. This collection should be populated by the implementing class. (Inherited from BaseActionItem.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4) Constructor

ActionItemT1, T2, T3, T4 Constructor

Overload List
 | Name | Description
Public method | ActionItemT1, T2, T3, T4(String) | Initializes a new instance of ActionItem class
Public method | ActionItemT1, T2, T3, T4(String, String, String) | Initializes a new instance of ActionItem class
Public method | ActionItemT1, T2, T3, T4(String, String, String, ActionT1, T2, T3, T4, String, Boolean, Boolean) | Initializes a new instance of ActionItem class
Top
See Also

Reference

ActionItemT1, T2, T3, T4 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4) Constructor (String)

ActionItemT1, T2, T3, T4 Constructor (String)

Initializes a new instance of ActionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionItem(
    string id
)
public:
ActionItem(
    String^ id
)

Parameters

id
Type: SystemString
See Also

Reference

ActionItemT1, T2, T3, T4 Class
ActionItemT1, T2, T3, T4 Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4) Constructor (String, String, String)

ActionItemT1, T2, T3, T4 Constructor (String, String, String)

Initializes a new instance of ActionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionItem(
    string id,
    string translatedTextId,
    string iconName
)
public:
ActionItem(
    String^ id,
    String^ translatedTextId,
    String^ iconName
)

Parameters

id
Type: SystemString
translatedTextId
Type: SystemString
iconName
Type: SystemString
See Also

Reference

ActionItemT1, T2, T3, T4 Class
ActionItemT1, T2, T3, T4 Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4) Constructor (String, String, String, Action(T1, T2, T3, T4), String, Boolean, Boolean)

ActionItemT1, T2, T3, T4 Constructor (String, String, String, ActionT1, T2, T3, T4, String, Boolean, Boolean)

Initializes a new instance of ActionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionItem(
    string id,
    string content,
    string iconName,
    Action<T1, T2, T3, T4> execute,
    string controlType = "Button",
    bool getIconPathFromFile = false,
    bool isColoredIcon = true
)
public:
ActionItem(
    String^ id,
    String^ content,
    String^ iconName,
    Action<T1, T2, T3, T4>^ execute,
    String^ controlType = L"Button",
    bool getIconPathFromFile = false,
    bool isColoredIcon = true
)

Parameters

id
Type: SystemString
content
Type: SystemString
iconName
Type: SystemString
vector image file name or path data
execute
Type: SystemActionT1, T2, T3, T4
controlType (Optional)
Type: SystemString
getIconPathFromFile (Optional)
Type: SystemBoolean
indicator of using default icon path
isColoredIcon (Optional)
Type: SystemBoolean
See Also

Reference

ActionItemT1, T2, T3, T4 Class
ActionItemT1, T2, T3, T4 Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4) Properties

ActionItemT1, T2, T3, T4 Properties

The ActionItemT1, T2, T3, T4 generic type exposes the following members.

Properties
 | Name | Description
Public property | ActiveAction | Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this). (Inherited from BaseActionItem.)
Protected property | Application | (Inherited from BaseActionItem.)
Public property | AttachTo | (Inherited from BaseActionItem.)
Public property | ButtonMaxWidth | (Inherited from BaseActionItem.)
Public property | ButtonMinWidth | (Inherited from BaseActionItem.)
Public property | ButtonWidth | (Inherited from BaseActionItem.)
Public property | CanExecute | (Inherited from BaseActionItem.)
Protected property | canExecuteAction | Similar to canExecute. This is provided for Visual Basic compatibility. (Inherited from BaseActionItem.)
Public property | CollapseWhenDeactivated | (Inherited from BaseActionItem.)
Public property | CommandRegistry | This references is assigned by CommandRegistry on startup. (Inherited from BaseActionItem.)
Public property | Content | (Inherited from BaseActionItem.)
Public property | Context | (Inherited from BaseActionItem.)
Public property | ContextFilter | (Inherited from BaseActionItem.)
Public property | ControlType | (Inherited from BaseActionItem.)
Public property | Customization | (Inherited from BaseActionItem.)
Protected property | EventMng | Event aggregator (Inherited from BaseActionItem.)
Public property | Icon | (Inherited from BaseActionItem.)
Public property | IconName | (Inherited from BaseActionItem.)
Public property | Id | (Inherited from BaseActionItem.)
Public property | ImageSource | (Inherited from BaseActionItem.)
Public property | IsActivated | (Inherited from BaseActionItem.)
Public property | IsBackgroundVisible | (Inherited from BaseActionItem.)
Public property | IsColoredIcon | (Inherited from BaseActionItem.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsQatCommonTool | (Inherited from BaseActionItem.)
Public property | IsToolNotInRibbon | (Inherited from BaseActionItem.)
Public property | Localization | (Inherited from BaseActionItem.)
Public property | RibbonId | (Inherited from BaseActionItem.)
Public property | SiteOrder | (Inherited from BaseActionItem.)
Protected property | SkipAbortWhenExecuted | If true, action will not abort currently executing action. (Inherited from BaseActionItem.)
Public property | Tag | (Inherited from BaseActionItem.)
Public property | ToolSize | (Inherited from BaseActionItem.)
Public property | ToolTipBookmark | (Inherited from BaseActionItem.)
Public property | ToolTipContent | (Inherited from BaseActionItem.)
Public property | ToolTipContentImage | (Inherited from BaseActionItem.)
Public property | ToolTipFooter | (Inherited from BaseActionItem.)
Public property | ToolTipFooterSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipFooterVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipHeader | (Inherited from BaseActionItem.)
Public property | ToolTipHeaderSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipMoreInfoUrl | (Inherited from BaseActionItem.)
Public property | ToolTipVisibility | (Inherited from BaseActionItem.)
Public property | UxConfig | (Inherited from BaseActionItem.)
Public property | Visibility | (Inherited from BaseActionItem.)
Top
See Also

Reference

ActionItemT1, T2, T3, T4 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4) Methods

ActionItemT1, T2, T3, T4 Methods

The ActionItemT1, T2, T3, T4 generic type exposes the following members.

Methods
 | Name | Description
Public method | AfterExecute | (Inherited from BaseActionItem.)
Public method | BeforeExecute | (Inherited from BaseActionItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute | Updates the value of CanExecute (Inherited from BaseActionItem.)
Public method | Execute | (Overrides BaseActionItemExecute.)
Public method | Execute(PropertyCollection) | (Inherited from BaseActionItem.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from BaseActionItem.)
Public method | Execute(T1, T2, T3, T4) | The action associated to the ActionItem
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableForObject | (Inherited from BaseActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from BaseActionItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from BaseActionItem.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | OnImportsSatisfied | Overriding class should call baseclass implementation. (Inherited from BaseActionItem.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SetupBaseActionItem | (Inherited from BaseActionItem.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Protected method | StartAction | Shortcut for calling CommandRegistry.StartCommandPanelAction(this). (Inherited from BaseActionItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ActionItemT1, T2, T3, T4 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4).Execute Method

ActionItemT1, T2, T3, T4Execute Method

Overload List
 | Name | Description
Public method | Execute | (Overrides BaseActionItemExecute.)
Public method | Execute(PropertyCollection) | (Inherited from BaseActionItem.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from BaseActionItem.)
Public method | Execute(T1, T2, T3, T4) | The action associated to the ActionItem
Top
See Also

Reference

ActionItemT1, T2, T3, T4 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4).Execute Method

ActionItemT1, T2, T3, T4Execute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Execute()
public:
virtual void Execute() override

Implements

IActionItemExecute
See Also

Reference

ActionItemT1, T2, T3, T4 Class
Execute Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4).Execute Method (T1, T2, T3, T4)

ActionItemT1, T2, T3, T4Execute Method (T1, T2, T3, T4)

The action associated to the ActionItem

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void Execute(
    T1 p1,
    T2 p2,
    T3 p3,
    T4 p4
)
public:
virtual void Execute(
    T1 p1,
    T2 p2,
    T3 p3,
    T4 p4
)

Parameters

p1
Type: T1
p2
Type: T2
p3
Type: T3
p4
Type: T4
See Also

Reference

ActionItemT1, T2, T3, T4 Class
Execute Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4) Events

ActionItemT1, T2, T3, T4 Events

The ActionItemT1, T2, T3, T4 generic type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
See Also

Reference

ActionItemT1, T2, T3, T4 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4) Fields

ActionItemT1, T2, T3, T4 Fields

The ActionItemT1, T2, T3, T4 generic type exposes the following members.

Fields
 | Name | Description
Protected field | _getIconPathFromFile | (Inherited from BaseActionItem.)
Protected field | _isColoredIcon | (Inherited from BaseActionItem.)
Protected field | canExecute | Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called. (Inherited from BaseActionItem.)
Protected field | executeAction |
Protected field | RequestedFeatures | Contains license features requested by the action item. This collection should be populated by the implementing class. (Inherited from BaseActionItem.)
Top
See Also

Reference

ActionItemT1, T2, T3, T4 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4).executeAction Field

ActionItemT1, T2, T3, T4executeAction Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected Action<T1, T2, T3, T4> executeAction
protected:
Action<T1, T2, T3, T4>^ executeAction

Field Value

Type: ActionT1, T2, T3, T4
See Also

Reference

ActionItemT1, T2, T3, T4 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5) Class

ActionItemT1, T2, T3, T4, T5 Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.SharedBaseActionItem
VisualComponents.UX.SharedActionItemT1, T2, T3, T4, T5

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ActionItem<T1, T2, T3, T4, T5> : BaseActionItem

generic<typename T1, typename T2, typename T3, typename T4, typename T5>
public ref class ActionItem : public BaseActionItem

Type Parameters

T1
T2
T3
T4
T5

The ActionItemT1, T2, T3, T4, T5 type exposes the following members.

Constructors
 | Name | Description
Public method | ActionItemT1, T2, T3, T4, T5(String) | Initializes a new instance of ActionItem class
Public method | ActionItemT1, T2, T3, T4, T5(String, String, String) | Initializes a new instance of ActionItem class
Public method | ActionItemT1, T2, T3, T4, T5(String, String, String, ActionT1, T2, T3, T4, T5, String, Boolean, Boolean) | Initializes a new instance of ActionItem class
Top
Properties
 | Name | Description
Public property | ActiveAction | Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this). (Inherited from BaseActionItem.)
Protected property | Application | (Inherited from BaseActionItem.)
Public property | AttachTo | (Inherited from BaseActionItem.)
Public property | ButtonMaxWidth | (Inherited from BaseActionItem.)
Public property | ButtonMinWidth | (Inherited from BaseActionItem.)
Public property | ButtonWidth | (Inherited from BaseActionItem.)
Public property | CanExecute | (Inherited from BaseActionItem.)
Protected property | canExecuteAction | Similar to canExecute. This is provided for Visual Basic compatibility. (Inherited from BaseActionItem.)
Public property | CollapseWhenDeactivated | (Inherited from BaseActionItem.)
Public property | CommandRegistry | This references is assigned by CommandRegistry on startup. (Inherited from BaseActionItem.)
Public property | Content | (Inherited from BaseActionItem.)
Public property | Context | (Inherited from BaseActionItem.)
Public property | ContextFilter | (Inherited from BaseActionItem.)
Public property | ControlType | (Inherited from BaseActionItem.)
Public property | Customization | (Inherited from BaseActionItem.)
Protected property | EventMng | Event aggregator (Inherited from BaseActionItem.)
Public property | Icon | (Inherited from BaseActionItem.)
Public property | IconName | (Inherited from BaseActionItem.)
Public property | Id | (Inherited from BaseActionItem.)
Public property | ImageSource | (Inherited from BaseActionItem.)
Public property | IsActivated | (Inherited from BaseActionItem.)
Public property | IsBackgroundVisible | (Inherited from BaseActionItem.)
Public property | IsColoredIcon | (Inherited from BaseActionItem.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsQatCommonTool | (Inherited from BaseActionItem.)
Public property | IsToolNotInRibbon | (Inherited from BaseActionItem.)
Public property | Localization | (Inherited from BaseActionItem.)
Public property | RibbonId | (Inherited from BaseActionItem.)
Public property | SiteOrder | (Inherited from BaseActionItem.)
Protected property | SkipAbortWhenExecuted | If true, action will not abort currently executing action. (Inherited from BaseActionItem.)
Public property | Tag | (Inherited from BaseActionItem.)
Public property | ToolSize | (Inherited from BaseActionItem.)
Public property | ToolTipBookmark | (Inherited from BaseActionItem.)
Public property | ToolTipContent | (Inherited from BaseActionItem.)
Public property | ToolTipContentImage | (Inherited from BaseActionItem.)
Public property | ToolTipFooter | (Inherited from BaseActionItem.)
Public property | ToolTipFooterSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipFooterVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipHeader | (Inherited from BaseActionItem.)
Public property | ToolTipHeaderSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipMoreInfoUrl | (Inherited from BaseActionItem.)
Public property | ToolTipVisibility | (Inherited from BaseActionItem.)
Public property | UxConfig | (Inherited from BaseActionItem.)
Public property | Visibility | (Inherited from BaseActionItem.)
Top
Methods
 | Name | Description
Public method | AfterExecute | (Inherited from BaseActionItem.)
Public method | BeforeExecute | (Inherited from BaseActionItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute | Updates the value of CanExecute (Inherited from BaseActionItem.)
Public method | Execute | (Overrides BaseActionItemExecute.)
Public method | Execute(PropertyCollection) | (Inherited from BaseActionItem.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from BaseActionItem.)
Public method | Execute(T1, T2, T3, T4, T5) | The action associated to the ActionItem
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableForObject | (Inherited from BaseActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from BaseActionItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from BaseActionItem.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | OnImportsSatisfied | Overriding class should call baseclass implementation. (Inherited from BaseActionItem.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SetupBaseActionItem | (Inherited from BaseActionItem.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Protected method | StartAction | Shortcut for calling CommandRegistry.StartCommandPanelAction(this). (Inherited from BaseActionItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
Fields
 | Name | Description
Protected field | _getIconPathFromFile | (Inherited from BaseActionItem.)
Protected field | _isColoredIcon | (Inherited from BaseActionItem.)
Protected field | canExecute | Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called. (Inherited from BaseActionItem.)
Protected field | executeAction |
Protected field | RequestedFeatures | Contains license features requested by the action item. This collection should be populated by the implementing class. (Inherited from BaseActionItem.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5) Constructor

ActionItemT1, T2, T3, T4, T5 Constructor

Overload List
 | Name | Description
Public method | ActionItemT1, T2, T3, T4, T5(String) | Initializes a new instance of ActionItem class
Public method | ActionItemT1, T2, T3, T4, T5(String, String, String) | Initializes a new instance of ActionItem class
Public method | ActionItemT1, T2, T3, T4, T5(String, String, String, ActionT1, T2, T3, T4, T5, String, Boolean, Boolean) | Initializes a new instance of ActionItem class
Top
See Also

Reference

ActionItemT1, T2, T3, T4, T5 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5) Constructor (String)

ActionItemT1, T2, T3, T4, T5 Constructor (String)

Initializes a new instance of ActionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionItem(
    string id
)
public:
ActionItem(
    String^ id
)

Parameters

id
Type: SystemString
See Also

Reference

ActionItemT1, T2, T3, T4, T5 Class
ActionItemT1, T2, T3, T4, T5 Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5) Constructor (String, String, String)

ActionItemT1, T2, T3, T4, T5 Constructor (String, String, String)

Initializes a new instance of ActionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionItem(
    string id,
    string translatedTextId,
    string iconName
)
public:
ActionItem(
    String^ id,
    String^ translatedTextId,
    String^ iconName
)

Parameters

id
Type: SystemString
translatedTextId
Type: SystemString
iconName
Type: SystemString
See Also

Reference

ActionItemT1, T2, T3, T4, T5 Class
ActionItemT1, T2, T3, T4, T5 Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5) Constructor (String, String, String, Action(T1, T2, T3, T4, T5), String, Boolean, Boolean)

ActionItemT1, T2, T3, T4, T5 Constructor (String, String, String, ActionT1, T2, T3, T4, T5, String, Boolean, Boolean)

Initializes a new instance of ActionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionItem(
    string id,
    string content,
    string iconName,
    Action<T1, T2, T3, T4, T5> execute,
    string controlType = "Button",
    bool getIconPathFromFile = false,
    bool isColoredIcon = true
)
public:
ActionItem(
    String^ id,
    String^ content,
    String^ iconName,
    Action<T1, T2, T3, T4, T5>^ execute,
    String^ controlType = L"Button",
    bool getIconPathFromFile = false,
    bool isColoredIcon = true
)

Parameters

id
Type: SystemString
content
Type: SystemString
iconName
Type: SystemString
vector image file name or path data
execute
Type: SystemActionT1, T2, T3, T4, T5
controlType (Optional)
Type: SystemString
getIconPathFromFile (Optional)
Type: SystemBoolean
indicator of using default icon path
isColoredIcon (Optional)
Type: SystemBoolean
See Also

Reference

ActionItemT1, T2, T3, T4, T5 Class
ActionItemT1, T2, T3, T4, T5 Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5) Properties

ActionItemT1, T2, T3, T4, T5 Properties

The ActionItemT1, T2, T3, T4, T5 generic type exposes the following members.

Properties
 | Name | Description
Public property | ActiveAction | Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this). (Inherited from BaseActionItem.)
Protected property | Application | (Inherited from BaseActionItem.)
Public property | AttachTo | (Inherited from BaseActionItem.)
Public property | ButtonMaxWidth | (Inherited from BaseActionItem.)
Public property | ButtonMinWidth | (Inherited from BaseActionItem.)
Public property | ButtonWidth | (Inherited from BaseActionItem.)
Public property | CanExecute | (Inherited from BaseActionItem.)
Protected property | canExecuteAction | Similar to canExecute. This is provided for Visual Basic compatibility. (Inherited from BaseActionItem.)
Public property | CollapseWhenDeactivated | (Inherited from BaseActionItem.)
Public property | CommandRegistry | This references is assigned by CommandRegistry on startup. (Inherited from BaseActionItem.)
Public property | Content | (Inherited from BaseActionItem.)
Public property | Context | (Inherited from BaseActionItem.)
Public property | ContextFilter | (Inherited from BaseActionItem.)
Public property | ControlType | (Inherited from BaseActionItem.)
Public property | Customization | (Inherited from BaseActionItem.)
Protected property | EventMng | Event aggregator (Inherited from BaseActionItem.)
Public property | Icon | (Inherited from BaseActionItem.)
Public property | IconName | (Inherited from BaseActionItem.)
Public property | Id | (Inherited from BaseActionItem.)
Public property | ImageSource | (Inherited from BaseActionItem.)
Public property | IsActivated | (Inherited from BaseActionItem.)
Public property | IsBackgroundVisible | (Inherited from BaseActionItem.)
Public property | IsColoredIcon | (Inherited from BaseActionItem.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsQatCommonTool | (Inherited from BaseActionItem.)
Public property | IsToolNotInRibbon | (Inherited from BaseActionItem.)
Public property | Localization | (Inherited from BaseActionItem.)
Public property | RibbonId | (Inherited from BaseActionItem.)
Public property | SiteOrder | (Inherited from BaseActionItem.)
Protected property | SkipAbortWhenExecuted | If true, action will not abort currently executing action. (Inherited from BaseActionItem.)
Public property | Tag | (Inherited from BaseActionItem.)
Public property | ToolSize | (Inherited from BaseActionItem.)
Public property | ToolTipBookmark | (Inherited from BaseActionItem.)
Public property | ToolTipContent | (Inherited from BaseActionItem.)
Public property | ToolTipContentImage | (Inherited from BaseActionItem.)
Public property | ToolTipFooter | (Inherited from BaseActionItem.)
Public property | ToolTipFooterSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipFooterVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipHeader | (Inherited from BaseActionItem.)
Public property | ToolTipHeaderSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipMoreInfoUrl | (Inherited from BaseActionItem.)
Public property | ToolTipVisibility | (Inherited from BaseActionItem.)
Public property | UxConfig | (Inherited from BaseActionItem.)
Public property | Visibility | (Inherited from BaseActionItem.)
Top
See Also

Reference

ActionItemT1, T2, T3, T4, T5 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5) Methods

ActionItemT1, T2, T3, T4, T5 Methods

The ActionItemT1, T2, T3, T4, T5 generic type exposes the following members.

Methods
 | Name | Description
Public method | AfterExecute | (Inherited from BaseActionItem.)
Public method | BeforeExecute | (Inherited from BaseActionItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute | Updates the value of CanExecute (Inherited from BaseActionItem.)
Public method | Execute | (Overrides BaseActionItemExecute.)
Public method | Execute(PropertyCollection) | (Inherited from BaseActionItem.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from BaseActionItem.)
Public method | Execute(T1, T2, T3, T4, T5) | The action associated to the ActionItem
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableForObject | (Inherited from BaseActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from BaseActionItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from BaseActionItem.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | OnImportsSatisfied | Overriding class should call baseclass implementation. (Inherited from BaseActionItem.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SetupBaseActionItem | (Inherited from BaseActionItem.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Protected method | StartAction | Shortcut for calling CommandRegistry.StartCommandPanelAction(this). (Inherited from BaseActionItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ActionItemT1, T2, T3, T4, T5 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5).Execute Method

ActionItemT1, T2, T3, T4, T5Execute Method

Overload List
 | Name | Description
Public method | Execute | (Overrides BaseActionItemExecute.)
Public method | Execute(PropertyCollection) | (Inherited from BaseActionItem.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from BaseActionItem.)
Public method | Execute(T1, T2, T3, T4, T5) | The action associated to the ActionItem
Top
See Also

Reference

ActionItemT1, T2, T3, T4, T5 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5).Execute Method

ActionItemT1, T2, T3, T4, T5Execute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Execute()
public:
virtual void Execute() override

Implements

IActionItemExecute
See Also

Reference

ActionItemT1, T2, T3, T4, T5 Class
Execute Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5).Execute Method (T1, T2, T3, T4, T5)

ActionItemT1, T2, T3, T4, T5Execute Method (T1, T2, T3, T4, T5)

The action associated to the ActionItem

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void Execute(
    T1 p1,
    T2 p2,
    T3 p3,
    T4 p4,
    T5 p5
)
public:
virtual void Execute(
    T1 p1,
    T2 p2,
    T3 p3,
    T4 p4,
    T5 p5
)

Parameters

p1
Type: T1
p2
Type: T2
p3
Type: T3
p4
Type: T4
p5
Type: T5
See Also

Reference

ActionItemT1, T2, T3, T4, T5 Class
Execute Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5) Events

ActionItemT1, T2, T3, T4, T5 Events

The ActionItemT1, T2, T3, T4, T5 generic type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
See Also

Reference

ActionItemT1, T2, T3, T4, T5 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5) Fields

ActionItemT1, T2, T3, T4, T5 Fields

The ActionItemT1, T2, T3, T4, T5 generic type exposes the following members.

Fields
 | Name | Description
Protected field | _getIconPathFromFile | (Inherited from BaseActionItem.)
Protected field | _isColoredIcon | (Inherited from BaseActionItem.)
Protected field | canExecute | Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called. (Inherited from BaseActionItem.)
Protected field | executeAction |
Protected field | RequestedFeatures | Contains license features requested by the action item. This collection should be populated by the implementing class. (Inherited from BaseActionItem.)
Top
See Also

Reference

ActionItemT1, T2, T3, T4, T5 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5).executeAction Field

ActionItemT1, T2, T3, T4, T5executeAction Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected Action<T1, T2, T3, T4, T5> executeAction
protected:
Action<T1, T2, T3, T4, T5>^ executeAction

Field Value

Type: ActionT1, T2, T3, T4, T5
See Also

Reference

ActionItemT1, T2, T3, T4, T5 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5, T6) Class

ActionItemT1, T2, T3, T4, T5, T6 Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.SharedBaseActionItem
VisualComponents.UX.SharedActionItemT1, T2, T3, T4, T5, T6

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ActionItem<T1, T2, T3, T4, T5, T6> : BaseActionItem

generic<typename T1, typename T2, typename T3, typename T4, typename T5, typename T6>
public ref class ActionItem : public BaseActionItem

Type Parameters

T1
T2
T3
T4
T5
T6

The ActionItemT1, T2, T3, T4, T5, T6 type exposes the following members.

Constructors
 | Name | Description
Public method | ActionItemT1, T2, T3, T4, T5, T6(String) | Initializes a new instance of ActionItem class
Public method | ActionItemT1, T2, T3, T4, T5, T6(String, String, String) | Initializes a new instance of ActionItem class
Public method | ActionItemT1, T2, T3, T4, T5, T6(String, String, String, ActionT1, T2, T3, T4, T5, T6, String, Boolean, Boolean) | Initializes a new instance of ActionItem class
Top
Properties
 | Name | Description
Public property | ActiveAction | Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this). (Inherited from BaseActionItem.)
Protected property | Application | (Inherited from BaseActionItem.)
Public property | AttachTo | (Inherited from BaseActionItem.)
Public property | ButtonMaxWidth | (Inherited from BaseActionItem.)
Public property | ButtonMinWidth | (Inherited from BaseActionItem.)
Public property | ButtonWidth | (Inherited from BaseActionItem.)
Public property | CanExecute | (Inherited from BaseActionItem.)
Protected property | canExecuteAction | Similar to canExecute. This is provided for Visual Basic compatibility. (Inherited from BaseActionItem.)
Public property | CollapseWhenDeactivated | (Inherited from BaseActionItem.)
Public property | CommandRegistry | This references is assigned by CommandRegistry on startup. (Inherited from BaseActionItem.)
Public property | Content | (Inherited from BaseActionItem.)
Public property | Context | (Inherited from BaseActionItem.)
Public property | ContextFilter | (Inherited from BaseActionItem.)
Public property | ControlType | (Inherited from BaseActionItem.)
Public property | Customization | (Inherited from BaseActionItem.)
Protected property | EventMng | Event aggregator (Inherited from BaseActionItem.)
Public property | Icon | (Inherited from BaseActionItem.)
Public property | IconName | (Inherited from BaseActionItem.)
Public property | Id | (Inherited from BaseActionItem.)
Public property | ImageSource | (Inherited from BaseActionItem.)
Public property | IsActivated | (Inherited from BaseActionItem.)
Public property | IsBackgroundVisible | (Inherited from BaseActionItem.)
Public property | IsColoredIcon | (Inherited from BaseActionItem.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsQatCommonTool | (Inherited from BaseActionItem.)
Public property | IsToolNotInRibbon | (Inherited from BaseActionItem.)
Public property | Localization | (Inherited from BaseActionItem.)
Public property | RibbonId | (Inherited from BaseActionItem.)
Public property | SiteOrder | (Inherited from BaseActionItem.)
Protected property | SkipAbortWhenExecuted | If true, action will not abort currently executing action. (Inherited from BaseActionItem.)
Public property | Tag | (Inherited from BaseActionItem.)
Public property | ToolSize | (Inherited from BaseActionItem.)
Public property | ToolTipBookmark | (Inherited from BaseActionItem.)
Public property | ToolTipContent | (Inherited from BaseActionItem.)
Public property | ToolTipContentImage | (Inherited from BaseActionItem.)
Public property | ToolTipFooter | (Inherited from BaseActionItem.)
Public property | ToolTipFooterSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipFooterVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipHeader | (Inherited from BaseActionItem.)
Public property | ToolTipHeaderSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipMoreInfoUrl | (Inherited from BaseActionItem.)
Public property | ToolTipVisibility | (Inherited from BaseActionItem.)
Public property | UxConfig | (Inherited from BaseActionItem.)
Public property | Visibility | (Inherited from BaseActionItem.)
Top
Methods
 | Name | Description
Public method | AfterExecute | (Inherited from BaseActionItem.)
Public method | BeforeExecute | (Inherited from BaseActionItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute | Updates the value of CanExecute (Inherited from BaseActionItem.)
Public method | Execute | (Overrides BaseActionItemExecute.)
Public method | Execute(PropertyCollection) | (Inherited from BaseActionItem.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from BaseActionItem.)
Public method | Execute(T1, T2, T3, T4, T5, T6) | The action associated to the ActionItem
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableForObject | (Inherited from BaseActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from BaseActionItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from BaseActionItem.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | OnImportsSatisfied | Overriding class should call baseclass implementation. (Inherited from BaseActionItem.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SetupBaseActionItem | (Inherited from BaseActionItem.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Protected method | StartAction | Shortcut for calling CommandRegistry.StartCommandPanelAction(this). (Inherited from BaseActionItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
Fields
 | Name | Description
Protected field | _getIconPathFromFile | (Inherited from BaseActionItem.)
Protected field | _isColoredIcon | (Inherited from BaseActionItem.)
Protected field | canExecute | Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called. (Inherited from BaseActionItem.)
Protected field | executeAction |
Protected field | RequestedFeatures | Contains license features requested by the action item. This collection should be populated by the implementing class. (Inherited from BaseActionItem.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5, T6) Constructor

ActionItemT1, T2, T3, T4, T5, T6 Constructor

Overload List
 | Name | Description
Public method | ActionItemT1, T2, T3, T4, T5, T6(String) | Initializes a new instance of ActionItem class
Public method | ActionItemT1, T2, T3, T4, T5, T6(String, String, String) | Initializes a new instance of ActionItem class
Public method | ActionItemT1, T2, T3, T4, T5, T6(String, String, String, ActionT1, T2, T3, T4, T5, T6, String, Boolean, Boolean) | Initializes a new instance of ActionItem class
Top
See Also

Reference

ActionItemT1, T2, T3, T4, T5, T6 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5, T6) Constructor (String)

ActionItemT1, T2, T3, T4, T5, T6 Constructor (String)

Initializes a new instance of ActionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionItem(
    string id
)
public:
ActionItem(
    String^ id
)

Parameters

id
Type: SystemString
See Also

Reference

ActionItemT1, T2, T3, T4, T5, T6 Class
ActionItemT1, T2, T3, T4, T5, T6 Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5, T6) Constructor (String, String, String)

ActionItemT1, T2, T3, T4, T5, T6 Constructor (String, String, String)

Initializes a new instance of ActionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionItem(
    string id,
    string translatedTextId,
    string iconName
)
public:
ActionItem(
    String^ id,
    String^ translatedTextId,
    String^ iconName
)

Parameters

id
Type: SystemString
translatedTextId
Type: SystemString
iconName
Type: SystemString
See Also

Reference

ActionItemT1, T2, T3, T4, T5, T6 Class
ActionItemT1, T2, T3, T4, T5, T6 Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5, T6) Constructor (String, String, String, Action(T1, T2, T3, T4, T5, T6), String, Boolean, Boolean)

ActionItemT1, T2, T3, T4, T5, T6 Constructor (String, String, String, ActionT1, T2, T3, T4, T5, T6, String, Boolean, Boolean)

Initializes a new instance of ActionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionItem(
    string id,
    string content,
    string iconName,
    Action<T1, T2, T3, T4, T5, T6> execute,
    string controlType = "Button",
    bool getIconPathFromFile = false,
    bool isColoredIcon = true
)
public:
ActionItem(
    String^ id,
    String^ content,
    String^ iconName,
    Action<T1, T2, T3, T4, T5, T6>^ execute,
    String^ controlType = L"Button",
    bool getIconPathFromFile = false,
    bool isColoredIcon = true
)

Parameters

id
Type: SystemString
content
Type: SystemString
iconName
Type: SystemString
vector image file name or path data
execute
Type: SystemActionT1, T2, T3, T4, T5, T6
controlType (Optional)
Type: SystemString
getIconPathFromFile (Optional)
Type: SystemBoolean
indicator of using default icon path
isColoredIcon (Optional)
Type: SystemBoolean
See Also

Reference

ActionItemT1, T2, T3, T4, T5, T6 Class
ActionItemT1, T2, T3, T4, T5, T6 Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5, T6) Properties

ActionItemT1, T2, T3, T4, T5, T6 Properties

The ActionItemT1, T2, T3, T4, T5, T6 generic type exposes the following members.

Properties
 | Name | Description
Public property | ActiveAction | Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this). (Inherited from BaseActionItem.)
Protected property | Application | (Inherited from BaseActionItem.)
Public property | AttachTo | (Inherited from BaseActionItem.)
Public property | ButtonMaxWidth | (Inherited from BaseActionItem.)
Public property | ButtonMinWidth | (Inherited from BaseActionItem.)
Public property | ButtonWidth | (Inherited from BaseActionItem.)
Public property | CanExecute | (Inherited from BaseActionItem.)
Protected property | canExecuteAction | Similar to canExecute. This is provided for Visual Basic compatibility. (Inherited from BaseActionItem.)
Public property | CollapseWhenDeactivated | (Inherited from BaseActionItem.)
Public property | CommandRegistry | This references is assigned by CommandRegistry on startup. (Inherited from BaseActionItem.)
Public property | Content | (Inherited from BaseActionItem.)
Public property | Context | (Inherited from BaseActionItem.)
Public property | ContextFilter | (Inherited from BaseActionItem.)
Public property | ControlType | (Inherited from BaseActionItem.)
Public property | Customization | (Inherited from BaseActionItem.)
Protected property | EventMng | Event aggregator (Inherited from BaseActionItem.)
Public property | Icon | (Inherited from BaseActionItem.)
Public property | IconName | (Inherited from BaseActionItem.)
Public property | Id | (Inherited from BaseActionItem.)
Public property | ImageSource | (Inherited from BaseActionItem.)
Public property | IsActivated | (Inherited from BaseActionItem.)
Public property | IsBackgroundVisible | (Inherited from BaseActionItem.)
Public property | IsColoredIcon | (Inherited from BaseActionItem.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsQatCommonTool | (Inherited from BaseActionItem.)
Public property | IsToolNotInRibbon | (Inherited from BaseActionItem.)
Public property | Localization | (Inherited from BaseActionItem.)
Public property | RibbonId | (Inherited from BaseActionItem.)
Public property | SiteOrder | (Inherited from BaseActionItem.)
Protected property | SkipAbortWhenExecuted | If true, action will not abort currently executing action. (Inherited from BaseActionItem.)
Public property | Tag | (Inherited from BaseActionItem.)
Public property | ToolSize | (Inherited from BaseActionItem.)
Public property | ToolTipBookmark | (Inherited from BaseActionItem.)
Public property | ToolTipContent | (Inherited from BaseActionItem.)
Public property | ToolTipContentImage | (Inherited from BaseActionItem.)
Public property | ToolTipFooter | (Inherited from BaseActionItem.)
Public property | ToolTipFooterSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipFooterVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipHeader | (Inherited from BaseActionItem.)
Public property | ToolTipHeaderSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipMoreInfoUrl | (Inherited from BaseActionItem.)
Public property | ToolTipVisibility | (Inherited from BaseActionItem.)
Public property | UxConfig | (Inherited from BaseActionItem.)
Public property | Visibility | (Inherited from BaseActionItem.)
Top
See Also

Reference

ActionItemT1, T2, T3, T4, T5, T6 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5, T6) Methods

ActionItemT1, T2, T3, T4, T5, T6 Methods

The ActionItemT1, T2, T3, T4, T5, T6 generic type exposes the following members.

Methods
 | Name | Description
Public method | AfterExecute | (Inherited from BaseActionItem.)
Public method | BeforeExecute | (Inherited from BaseActionItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute | Updates the value of CanExecute (Inherited from BaseActionItem.)
Public method | Execute | (Overrides BaseActionItemExecute.)
Public method | Execute(PropertyCollection) | (Inherited from BaseActionItem.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from BaseActionItem.)
Public method | Execute(T1, T2, T3, T4, T5, T6) | The action associated to the ActionItem
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableForObject | (Inherited from BaseActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from BaseActionItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from BaseActionItem.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | OnImportsSatisfied | Overriding class should call baseclass implementation. (Inherited from BaseActionItem.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SetupBaseActionItem | (Inherited from BaseActionItem.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Protected method | StartAction | Shortcut for calling CommandRegistry.StartCommandPanelAction(this). (Inherited from BaseActionItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ActionItemT1, T2, T3, T4, T5, T6 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5, T6).Execute Method

ActionItemT1, T2, T3, T4, T5, T6Execute Method

Overload List
 | Name | Description
Public method | Execute | (Overrides BaseActionItemExecute.)
Public method | Execute(PropertyCollection) | (Inherited from BaseActionItem.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from BaseActionItem.)
Public method | Execute(T1, T2, T3, T4, T5, T6) | The action associated to the ActionItem
Top
See Also

Reference

ActionItemT1, T2, T3, T4, T5, T6 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5, T6).Execute Method

ActionItemT1, T2, T3, T4, T5, T6Execute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Execute()
public:
virtual void Execute() override

Implements

IActionItemExecute
See Also

Reference

ActionItemT1, T2, T3, T4, T5, T6 Class
Execute Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5, T6).Execute Method (T1, T2, T3, T4, T5, T6)

ActionItemT1, T2, T3, T4, T5, T6Execute Method (T1, T2, T3, T4, T5, T6)

The action associated to the ActionItem

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void Execute(
    T1 p1,
    T2 p2,
    T3 p3,
    T4 p4,
    T5 p5,
    T6 p6
)
public:
virtual void Execute(
    T1 p1,
    T2 p2,
    T3 p3,
    T4 p4,
    T5 p5,
    T6 p6
)

Parameters

p1
Type: T1
p2
Type: T2
p3
Type: T3
p4
Type: T4
p5
Type: T5
p6
Type: T6
See Also

Reference

ActionItemT1, T2, T3, T4, T5, T6 Class
Execute Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5, T6) Events

ActionItemT1, T2, T3, T4, T5, T6 Events

The ActionItemT1, T2, T3, T4, T5, T6 generic type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
See Also

Reference

ActionItemT1, T2, T3, T4, T5, T6 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5, T6) Fields

ActionItemT1, T2, T3, T4, T5, T6 Fields

The ActionItemT1, T2, T3, T4, T5, T6 generic type exposes the following members.

Fields
 | Name | Description
Protected field | _getIconPathFromFile | (Inherited from BaseActionItem.)
Protected field | _isColoredIcon | (Inherited from BaseActionItem.)
Protected field | canExecute | Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called. (Inherited from BaseActionItem.)
Protected field | executeAction |
Protected field | RequestedFeatures | Contains license features requested by the action item. This collection should be populated by the implementing class. (Inherited from BaseActionItem.)
Top
See Also

Reference

ActionItemT1, T2, T3, T4, T5, T6 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5, T6).executeAction Field

ActionItemT1, T2, T3, T4, T5, T6executeAction Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected Action<T1, T2, T3, T4, T5, T6> executeAction
protected:
Action<T1, T2, T3, T4, T5, T6>^ executeAction

Field Value

Type: ActionT1, T2, T3, T4, T5, T6
See Also

Reference

ActionItemT1, T2, T3, T4, T5, T6 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5, T6, T7) Class

ActionItemT1, T2, T3, T4, T5, T6, T7 Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.SharedBaseActionItem
VisualComponents.UX.SharedActionItemT1, T2, T3, T4, T5, T6, T7

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ActionItem<T1, T2, T3, T4, T5, T6, T7> : BaseActionItem

generic<typename T1, typename T2, typename T3, typename T4, typename T5, typename T6, typename T7>
public ref class ActionItem : public BaseActionItem

Type Parameters

T1
T2
T3
T4
T5
T6
T7

The ActionItemT1, T2, T3, T4, T5, T6, T7 type exposes the following members.

Constructors
 | Name | Description
Public method | ActionItemT1, T2, T3, T4, T5, T6, T7(String) | Initializes a new instance of ActionItem class
Public method | ActionItemT1, T2, T3, T4, T5, T6, T7(String, String, String) | Initializes a new instance of ActionItem class
Public method | ActionItemT1, T2, T3, T4, T5, T6, T7(String, String, String, ActionT1, T2, T3, T4, T5, T6, T7, String, Boolean, Boolean) | Initializes a new instance of ActionItem class
Top
Properties
 | Name | Description
Public property | ActiveAction | Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this). (Inherited from BaseActionItem.)
Protected property | Application | (Inherited from BaseActionItem.)
Public property | AttachTo | (Inherited from BaseActionItem.)
Public property | ButtonMaxWidth | (Inherited from BaseActionItem.)
Public property | ButtonMinWidth | (Inherited from BaseActionItem.)
Public property | ButtonWidth | (Inherited from BaseActionItem.)
Public property | CanExecute | (Inherited from BaseActionItem.)
Protected property | canExecuteAction | Similar to canExecute. This is provided for Visual Basic compatibility. (Inherited from BaseActionItem.)
Public property | CollapseWhenDeactivated | (Inherited from BaseActionItem.)
Public property | CommandRegistry | This references is assigned by CommandRegistry on startup. (Inherited from BaseActionItem.)
Public property | Content | (Inherited from BaseActionItem.)
Public property | Context | (Inherited from BaseActionItem.)
Public property | ContextFilter | (Inherited from BaseActionItem.)
Public property | ControlType | (Inherited from BaseActionItem.)
Public property | Customization | (Inherited from BaseActionItem.)
Protected property | EventMng | Event aggregator (Inherited from BaseActionItem.)
Public property | Icon | (Inherited from BaseActionItem.)
Public property | IconName | (Inherited from BaseActionItem.)
Public property | Id | (Inherited from BaseActionItem.)
Public property | ImageSource | (Inherited from BaseActionItem.)
Public property | IsActivated | (Inherited from BaseActionItem.)
Public property | IsBackgroundVisible | (Inherited from BaseActionItem.)
Public property | IsColoredIcon | (Inherited from BaseActionItem.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsQatCommonTool | (Inherited from BaseActionItem.)
Public property | IsToolNotInRibbon | (Inherited from BaseActionItem.)
Public property | Localization | (Inherited from BaseActionItem.)
Public property | RibbonId | (Inherited from BaseActionItem.)
Public property | SiteOrder | (Inherited from BaseActionItem.)
Protected property | SkipAbortWhenExecuted | If true, action will not abort currently executing action. (Inherited from BaseActionItem.)
Public property | Tag | (Inherited from BaseActionItem.)
Public property | ToolSize | (Inherited from BaseActionItem.)
Public property | ToolTipBookmark | (Inherited from BaseActionItem.)
Public property | ToolTipContent | (Inherited from BaseActionItem.)
Public property | ToolTipContentImage | (Inherited from BaseActionItem.)
Public property | ToolTipFooter | (Inherited from BaseActionItem.)
Public property | ToolTipFooterSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipFooterVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipHeader | (Inherited from BaseActionItem.)
Public property | ToolTipHeaderSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipMoreInfoUrl | (Inherited from BaseActionItem.)
Public property | ToolTipVisibility | (Inherited from BaseActionItem.)
Public property | UxConfig | (Inherited from BaseActionItem.)
Public property | Visibility | (Inherited from BaseActionItem.)
Top
Methods
 | Name | Description
Public method | AfterExecute | (Inherited from BaseActionItem.)
Public method | BeforeExecute | (Inherited from BaseActionItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute | Updates the value of CanExecute (Inherited from BaseActionItem.)
Public method | Execute | (Overrides BaseActionItemExecute.)
Public method | Execute(PropertyCollection) | (Inherited from BaseActionItem.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from BaseActionItem.)
Public method | Execute(T1, T2, T3, T4, T5, T6, T7) | The action associated to the ActionItem
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableForObject | (Inherited from BaseActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from BaseActionItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from BaseActionItem.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | OnImportsSatisfied | Overriding class should call baseclass implementation. (Inherited from BaseActionItem.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SetupBaseActionItem | (Inherited from BaseActionItem.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Protected method | StartAction | Shortcut for calling CommandRegistry.StartCommandPanelAction(this). (Inherited from BaseActionItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
Fields
 | Name | Description
Protected field | _getIconPathFromFile | (Inherited from BaseActionItem.)
Protected field | _isColoredIcon | (Inherited from BaseActionItem.)
Protected field | canExecute | Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called. (Inherited from BaseActionItem.)
Protected field | executeAction |
Protected field | RequestedFeatures | Contains license features requested by the action item. This collection should be populated by the implementing class. (Inherited from BaseActionItem.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5, T6, T7) Constructor

ActionItemT1, T2, T3, T4, T5, T6, T7 Constructor

Overload List
 | Name | Description
Public method | ActionItemT1, T2, T3, T4, T5, T6, T7(String) | Initializes a new instance of ActionItem class
Public method | ActionItemT1, T2, T3, T4, T5, T6, T7(String, String, String) | Initializes a new instance of ActionItem class
Public method | ActionItemT1, T2, T3, T4, T5, T6, T7(String, String, String, ActionT1, T2, T3, T4, T5, T6, T7, String, Boolean, Boolean) | Initializes a new instance of ActionItem class
Top
See Also

Reference

ActionItemT1, T2, T3, T4, T5, T6, T7 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5, T6, T7) Constructor (String)

ActionItemT1, T2, T3, T4, T5, T6, T7 Constructor (String)

Initializes a new instance of ActionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionItem(
    string id
)
public:
ActionItem(
    String^ id
)

Parameters

id
Type: SystemString
See Also

Reference

ActionItemT1, T2, T3, T4, T5, T6, T7 Class
ActionItemT1, T2, T3, T4, T5, T6, T7 Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5, T6, T7) Constructor (String, String, String)

ActionItemT1, T2, T3, T4, T5, T6, T7 Constructor (String, String, String)

Initializes a new instance of ActionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionItem(
    string id,
    string translatedTextId,
    string iconName
)
public:
ActionItem(
    String^ id,
    String^ translatedTextId,
    String^ iconName
)

Parameters

id
Type: SystemString
translatedTextId
Type: SystemString
iconName
Type: SystemString
See Also

Reference

ActionItemT1, T2, T3, T4, T5, T6, T7 Class
ActionItemT1, T2, T3, T4, T5, T6, T7 Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5, T6, T7) Constructor (String, String, String, Action(T1, T2, T3, T4, T5, T6, T7), String, Boolean, Boolean)

ActionItemT1, T2, T3, T4, T5, T6, T7 Constructor (String, String, String, ActionT1, T2, T3, T4, T5, T6, T7, String, Boolean, Boolean)

Initializes a new instance of ActionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionItem(
    string id,
    string content,
    string iconName,
    Action<T1, T2, T3, T4, T5, T6, T7> execute,
    string controlType = "Button",
    bool getIconPathFromFile = false,
    bool isColoredIcon = true
)
public:
ActionItem(
    String^ id,
    String^ content,
    String^ iconName,
    Action<T1, T2, T3, T4, T5, T6, T7>^ execute,
    String^ controlType = L"Button",
    bool getIconPathFromFile = false,
    bool isColoredIcon = true
)

Parameters

id
Type: SystemString
content
Type: SystemString
iconName
Type: SystemString
vector image file name or path data
execute
Type: SystemActionT1, T2, T3, T4, T5, T6, T7
controlType (Optional)
Type: SystemString
getIconPathFromFile (Optional)
Type: SystemBoolean
indicator of using default icon path
isColoredIcon (Optional)
Type: SystemBoolean
See Also

Reference

ActionItemT1, T2, T3, T4, T5, T6, T7 Class
ActionItemT1, T2, T3, T4, T5, T6, T7 Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5, T6, T7) Properties

ActionItemT1, T2, T3, T4, T5, T6, T7 Properties

The ActionItemT1, T2, T3, T4, T5, T6, T7 generic type exposes the following members.

Properties
 | Name | Description
Public property | ActiveAction | Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this). (Inherited from BaseActionItem.)
Protected property | Application | (Inherited from BaseActionItem.)
Public property | AttachTo | (Inherited from BaseActionItem.)
Public property | ButtonMaxWidth | (Inherited from BaseActionItem.)
Public property | ButtonMinWidth | (Inherited from BaseActionItem.)
Public property | ButtonWidth | (Inherited from BaseActionItem.)
Public property | CanExecute | (Inherited from BaseActionItem.)
Protected property | canExecuteAction | Similar to canExecute. This is provided for Visual Basic compatibility. (Inherited from BaseActionItem.)
Public property | CollapseWhenDeactivated | (Inherited from BaseActionItem.)
Public property | CommandRegistry | This references is assigned by CommandRegistry on startup. (Inherited from BaseActionItem.)
Public property | Content | (Inherited from BaseActionItem.)
Public property | Context | (Inherited from BaseActionItem.)
Public property | ContextFilter | (Inherited from BaseActionItem.)
Public property | ControlType | (Inherited from BaseActionItem.)
Public property | Customization | (Inherited from BaseActionItem.)
Protected property | EventMng | Event aggregator (Inherited from BaseActionItem.)
Public property | Icon | (Inherited from BaseActionItem.)
Public property | IconName | (Inherited from BaseActionItem.)
Public property | Id | (Inherited from BaseActionItem.)
Public property | ImageSource | (Inherited from BaseActionItem.)
Public property | IsActivated | (Inherited from BaseActionItem.)
Public property | IsBackgroundVisible | (Inherited from BaseActionItem.)
Public property | IsColoredIcon | (Inherited from BaseActionItem.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsQatCommonTool | (Inherited from BaseActionItem.)
Public property | IsToolNotInRibbon | (Inherited from BaseActionItem.)
Public property | Localization | (Inherited from BaseActionItem.)
Public property | RibbonId | (Inherited from BaseActionItem.)
Public property | SiteOrder | (Inherited from BaseActionItem.)
Protected property | SkipAbortWhenExecuted | If true, action will not abort currently executing action. (Inherited from BaseActionItem.)
Public property | Tag | (Inherited from BaseActionItem.)
Public property | ToolSize | (Inherited from BaseActionItem.)
Public property | ToolTipBookmark | (Inherited from BaseActionItem.)
Public property | ToolTipContent | (Inherited from BaseActionItem.)
Public property | ToolTipContentImage | (Inherited from BaseActionItem.)
Public property | ToolTipFooter | (Inherited from BaseActionItem.)
Public property | ToolTipFooterSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipFooterVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipHeader | (Inherited from BaseActionItem.)
Public property | ToolTipHeaderSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipMoreInfoUrl | (Inherited from BaseActionItem.)
Public property | ToolTipVisibility | (Inherited from BaseActionItem.)
Public property | UxConfig | (Inherited from BaseActionItem.)
Public property | Visibility | (Inherited from BaseActionItem.)
Top
See Also

Reference

ActionItemT1, T2, T3, T4, T5, T6, T7 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5, T6, T7) Methods

ActionItemT1, T2, T3, T4, T5, T6, T7 Methods

The ActionItemT1, T2, T3, T4, T5, T6, T7 generic type exposes the following members.

Methods
 | Name | Description
Public method | AfterExecute | (Inherited from BaseActionItem.)
Public method | BeforeExecute | (Inherited from BaseActionItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute | Updates the value of CanExecute (Inherited from BaseActionItem.)
Public method | Execute | (Overrides BaseActionItemExecute.)
Public method | Execute(PropertyCollection) | (Inherited from BaseActionItem.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from BaseActionItem.)
Public method | Execute(T1, T2, T3, T4, T5, T6, T7) | The action associated to the ActionItem
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableForObject | (Inherited from BaseActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from BaseActionItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from BaseActionItem.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | OnImportsSatisfied | Overriding class should call baseclass implementation. (Inherited from BaseActionItem.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SetupBaseActionItem | (Inherited from BaseActionItem.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Protected method | StartAction | Shortcut for calling CommandRegistry.StartCommandPanelAction(this). (Inherited from BaseActionItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ActionItemT1, T2, T3, T4, T5, T6, T7 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5, T6, T7).Execute Method

ActionItemT1, T2, T3, T4, T5, T6, T7Execute Method

Overload List
 | Name | Description
Public method | Execute | (Overrides BaseActionItemExecute.)
Public method | Execute(PropertyCollection) | (Inherited from BaseActionItem.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from BaseActionItem.)
Public method | Execute(T1, T2, T3, T4, T5, T6, T7) | The action associated to the ActionItem
Top
See Also

Reference

ActionItemT1, T2, T3, T4, T5, T6, T7 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5, T6, T7).Execute Method

ActionItemT1, T2, T3, T4, T5, T6, T7Execute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Execute()
public:
virtual void Execute() override

Implements

IActionItemExecute
See Also

Reference

ActionItemT1, T2, T3, T4, T5, T6, T7 Class
Execute Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5, T6, T7).Execute Method (T1, T2, T3, T4, T5, T6, T7)

ActionItemT1, T2, T3, T4, T5, T6, T7Execute Method (T1, T2, T3, T4, T5, T6, T7)

The action associated to the ActionItem

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void Execute(
    T1 p1,
    T2 p2,
    T3 p3,
    T4 p4,
    T5 p5,
    T6 p6,
    T7 p7
)
public:
virtual void Execute(
    T1 p1,
    T2 p2,
    T3 p3,
    T4 p4,
    T5 p5,
    T6 p6,
    T7 p7
)

Parameters

p1
Type: T1
p2
Type: T2
p3
Type: T3
p4
Type: T4
p5
Type: T5
p6
Type: T6
p7
Type: T7
See Also

Reference

ActionItemT1, T2, T3, T4, T5, T6, T7 Class
Execute Overload
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5, T6, T7) Events

ActionItemT1, T2, T3, T4, T5, T6, T7 Events

The ActionItemT1, T2, T3, T4, T5, T6, T7 generic type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
See Also

Reference

ActionItemT1, T2, T3, T4, T5, T6, T7 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5, T6, T7) Fields

ActionItemT1, T2, T3, T4, T5, T6, T7 Fields

The ActionItemT1, T2, T3, T4, T5, T6, T7 generic type exposes the following members.

Fields
 | Name | Description
Protected field | _getIconPathFromFile | (Inherited from BaseActionItem.)
Protected field | _isColoredIcon | (Inherited from BaseActionItem.)
Protected field | canExecute | Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called. (Inherited from BaseActionItem.)
Protected field | executeAction |
Protected field | RequestedFeatures | Contains license features requested by the action item. This collection should be populated by the implementing class. (Inherited from BaseActionItem.)
Top
See Also

Reference

ActionItemT1, T2, T3, T4, T5, T6, T7 Class
VisualComponents.UX.Shared Namespace


ActionItem(T1, T2, T3, T4, T5, T6, T7).executeAction Field

ActionItemT1, T2, T3, T4, T5, T6, T7executeAction Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected Action<T1, T2, T3, T4, T5, T6, T7> executeAction
protected:
Action<T1, T2, T3, T4, T5, T6, T7>^ executeAction

Field Value

Type: ActionT1, T2, T3, T4, T5, T6, T7
See Also

Reference

ActionItemT1, T2, T3, T4, T5, T6, T7 Class
VisualComponents.UX.Shared Namespace


ActionItemExecutedMessage Class

This message is published when IActionItem instance has finished executing.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedActionItemExecutedMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ActionItemExecutedMessage
public ref class ActionItemExecutedMessage

The ActionItemExecutedMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ActionItemExecutedMessage | Initializes a new instance of the ActionItemExecutedMessage class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | ActionItem |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ActionItemExecutedMessage Constructor

Initializes a new instance of the ActionItemExecutedMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionItemExecutedMessage(
    IActionItem item
)
public:
ActionItemExecutedMessage(
    IActionItem^ item
)

Parameters

item
Type: VisualComponents.UX.SharedIActionItem
See Also

Reference

ActionItemExecutedMessage Class
VisualComponents.UX.Shared Namespace


ActionItemExecutedMessage Methods

The ActionItemExecutedMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ActionItemExecutedMessage Class
VisualComponents.UX.Shared Namespace


ActionItemExecutedMessage Fields

The ActionItemExecutedMessage type exposes the following members.

Fields
 | Name | Description
Public field | ActionItem |
Top
See Also

Reference

ActionItemExecutedMessage Class
VisualComponents.UX.Shared Namespace


ActionItemExecutedMessage.ActionItem Field

ActionItemExecutedMessageActionItem Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public readonly IActionItem ActionItem
public:
initonly IActionItem^ ActionItem

Field Value

Type: IActionItem
See Also

Reference

ActionItemExecutedMessage Class
VisualComponents.UX.Shared Namespace


ActionItemExecutingMessage Class

This message is published when IActionItem instance starts executing.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedActionItemExecutingMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ActionItemExecutingMessage
public ref class ActionItemExecutingMessage

The ActionItemExecutingMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ActionItemExecutingMessage | Initializes a new instance of the ActionItemExecutingMessage class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | ActionItem |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ActionItemExecutingMessage Constructor

Initializes a new instance of the ActionItemExecutingMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionItemExecutingMessage(
    IActionItem item
)
public:
ActionItemExecutingMessage(
    IActionItem^ item
)

Parameters

item
Type: VisualComponents.UX.SharedIActionItem
See Also

Reference

ActionItemExecutingMessage Class
VisualComponents.UX.Shared Namespace


ActionItemExecutingMessage Methods

The ActionItemExecutingMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ActionItemExecutingMessage Class
VisualComponents.UX.Shared Namespace


ActionItemExecutingMessage Fields

The ActionItemExecutingMessage type exposes the following members.

Fields
 | Name | Description
Public field | ActionItem |
Top
See Also

Reference

ActionItemExecutingMessage Class
VisualComponents.UX.Shared Namespace


ActionItemExecutingMessage.ActionItem Field

ActionItemExecutingMessageActionItem Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public readonly IActionItem ActionItem
public:
initonly IActionItem^ ActionItem

Field Value

Type: IActionItem
See Also

Reference

ActionItemExecutingMessage Class
VisualComponents.UX.Shared Namespace


ActionItemPreviewMessage Class

Message that can be used to visualize results of any command panel action. Currently not used.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedActionItemPreviewMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ActionItemPreviewMessage
public ref class ActionItemPreviewMessage

The ActionItemPreviewMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ActionItemPreviewMessage | Initializes a new instance of the ActionItemPreviewMessage class
Top
Properties
 | Name | Description
Public property | ActionForPreview |
Public property | PreviewColors |
Public property | PreviewMeshes |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ActionItemPreviewMessage Constructor

Initializes a new instance of the ActionItemPreviewMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionItemPreviewMessage()
public:
ActionItemPreviewMessage()
See Also

Reference

ActionItemPreviewMessage Class
VisualComponents.UX.Shared Namespace


ActionItemPreviewMessage Properties

The ActionItemPreviewMessage type exposes the following members.

Properties
 | Name | Description
Public property | ActionForPreview |
Public property | PreviewColors |
Public property | PreviewMeshes |
Top
See Also

Reference

ActionItemPreviewMessage Class
VisualComponents.UX.Shared Namespace


ActionItemPreviewMessage.ActionForPreview Property

ActionItemPreviewMessageActionForPreview Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ICommandPanelAction ActionForPreview { get; set; }
public:
property ICommandPanelAction^ ActionForPreview {
    ICommandPanelAction^ get ();
    void set (ICommandPanelAction^ value);
}

Property Value

Type: ICommandPanelAction
See Also

Reference

ActionItemPreviewMessage Class
VisualComponents.UX.Shared Namespace


ActionItemPreviewMessage.PreviewColors Property

ActionItemPreviewMessagePreviewColors Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Color[] PreviewColors { get; set; }
public:
property array<Color>^ PreviewColors {
    array<Color>^ get ();
    void set (array<Color>^ value);
}

Property Value

Type: Color
See Also

Reference

ActionItemPreviewMessage Class
VisualComponents.UX.Shared Namespace


ActionItemPreviewMessage.PreviewMeshes Property

ActionItemPreviewMessagePreviewMeshes Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Geometry3D[] PreviewMeshes { get; set; }
public:
property array<Geometry3D^>^ PreviewMeshes {
    array<Geometry3D^>^ get ();
    void set (array<Geometry3D^>^ value);
}

Property Value

Type: Geometry3D
See Also

Reference

ActionItemPreviewMessage Class
VisualComponents.UX.Shared Namespace


ActionItemPreviewMessage Methods

The ActionItemPreviewMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ActionItemPreviewMessage Class
VisualComponents.UX.Shared Namespace


ActionItemTemplateSelector Class

Inheritance Hierarchy
SystemObject
System.Windows.ControlsDataTemplateSelector
VisualComponents.UX.SharedActionItemTemplateSelector

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ActionItemTemplateSelector : DataTemplateSelector
public ref class ActionItemTemplateSelector sealed : public DataTemplateSelector

The ActionItemTemplateSelector type exposes the following members.

Constructors
 | Name | Description
Public method | ActionItemTemplateSelector | Initializes a new instance of the ActionItemTemplateSelector class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SelectTemplate | (Overrides DataTemplateSelectorSelectTemplate(Object, DependencyObject).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ActionItemTemplateSelector Constructor

Initializes a new instance of the ActionItemTemplateSelector class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionItemTemplateSelector()
public:
ActionItemTemplateSelector()
See Also

Reference

ActionItemTemplateSelector Class
VisualComponents.UX.Shared Namespace


ActionItemTemplateSelector Methods

The ActionItemTemplateSelector type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SelectTemplate | (Overrides DataTemplateSelectorSelectTemplate(Object, DependencyObject).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ActionItemTemplateSelector Class
VisualComponents.UX.Shared Namespace


ActionItemTemplateSelector.SelectTemplate Method

ActionItemTemplateSelectorSelectTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override DataTemplate SelectTemplate(
    Object item,
    DependencyObject container
)
public:
virtual DataTemplate^ SelectTemplate(
    Object^ item,
    DependencyObject^ container
) override

Parameters

item
Type: SystemObject
container
Type: System.WindowsDependencyObject

Return Value

Type: DataTemplate

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ActionItemTemplateSelector.SelectTemplate(System.Object,System.Windows.DependencyObject)"]

See Also

Reference

ActionItemTemplateSelector Class
VisualComponents.UX.Shared Namespace


ActionRequestedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.UX.SharedActionRequestedEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ActionRequestedEventArgs : EventArgs
public ref class ActionRequestedEventArgs : public EventArgs

The ActionRequestedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ActionRequestedEventArgs | Initializes a new instance of the ActionRequestedEventArgs class
Top
Properties
 | Name | Description
Public property | Handled |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ActionRequestedEventArgs Constructor

Initializes a new instance of the ActionRequestedEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActionRequestedEventArgs()
public:
ActionRequestedEventArgs()
See Also

Reference

ActionRequestedEventArgs Class
VisualComponents.UX.Shared Namespace


ActionRequestedEventArgs Properties

The ActionRequestedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Handled |
Top
See Also

Reference

ActionRequestedEventArgs Class
VisualComponents.UX.Shared Namespace


ActionRequestedEventArgs.Handled Property

ActionRequestedEventArgsHandled Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Handled { get; set; }
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ActionRequestedEventArgs Class
VisualComponents.UX.Shared Namespace


ActionRequestedEventArgs Methods

The ActionRequestedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ActionRequestedEventArgs Class
VisualComponents.UX.Shared Namespace


ActiveDocumentChangedHandler Delegate

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public delegate void ActiveDocumentChangedHandler(
    Object o,
    RoutedPropertyChangedEventArgs<IDocumentContent> e
)
public delegate void ActiveDocumentChangedHandler(
    Object^ o,
    RoutedPropertyChangedEventArgs<IDocumentContent^>^ e
)

Parameters

o
Type: SystemObject
e
Type: System.WindowsRoutedPropertyChangedEventArgsIDocumentContent
See Also

Reference

VisualComponents.UX.Shared Namespace


ActiveViewportChangedMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedActiveViewportChangedMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ActiveViewportChangedMessage
public ref class ActiveViewportChangedMessage

The ActiveViewportChangedMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ActiveViewportChangedMessage | Initializes a new instance of the ActiveViewportChangedMessage class
Public method | ActiveViewportChangedMessage(IViewport, IViewport) | Initializes a new instance of the ActiveViewportChangedMessage class
Top
Properties
 | Name | Description
Public property | NewViewport |
Public property | OldViewport |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ActiveViewportChangedMessage Constructor

Overload List
 | Name | Description
Public method | ActiveViewportChangedMessage | Initializes a new instance of the ActiveViewportChangedMessage class
Public method | ActiveViewportChangedMessage(IViewport, IViewport) | Initializes a new instance of the ActiveViewportChangedMessage class
Top
See Also

Reference

ActiveViewportChangedMessage Class
VisualComponents.UX.Shared Namespace


ActiveViewportChangedMessage Constructor

Initializes a new instance of the ActiveViewportChangedMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActiveViewportChangedMessage()
public:
ActiveViewportChangedMessage()
See Also

Reference

ActiveViewportChangedMessage Class
ActiveViewportChangedMessage Overload
VisualComponents.UX.Shared Namespace


ActiveViewportChangedMessage Constructor (IViewport, IViewport)

Initializes a new instance of the ActiveViewportChangedMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ActiveViewportChangedMessage(
    IViewport oldViewport,
    IViewport newViewport
)
public:
ActiveViewportChangedMessage(
    IViewport^ oldViewport,
    IViewport^ newViewport
)

Parameters

oldViewport
Type: VisualComponents.Create3DIViewport
newViewport
Type: VisualComponents.Create3DIViewport
See Also

Reference

ActiveViewportChangedMessage Class
ActiveViewportChangedMessage Overload
VisualComponents.UX.Shared Namespace


ActiveViewportChangedMessage Properties

The ActiveViewportChangedMessage type exposes the following members.

Properties
 | Name | Description
Public property | NewViewport |
Public property | OldViewport |
Top
See Also

Reference

ActiveViewportChangedMessage Class
VisualComponents.UX.Shared Namespace


ActiveViewportChangedMessage.NewViewport Property

ActiveViewportChangedMessageNewViewport Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IViewport NewViewport { get; set; }
public:
property IViewport^ NewViewport {
    IViewport^ get ();
    void set (IViewport^ value);
}

Property Value

Type: IViewport
See Also

Reference

ActiveViewportChangedMessage Class
VisualComponents.UX.Shared Namespace


ActiveViewportChangedMessage.OldViewport Property

ActiveViewportChangedMessageOldViewport Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IViewport OldViewport { get; set; }
public:
property IViewport^ OldViewport {
    IViewport^ get ();
    void set (IViewport^ value);
}

Property Value

Type: IViewport
See Also

Reference

ActiveViewportChangedMessage Class
VisualComponents.UX.Shared Namespace


ActiveViewportChangedMessage Methods

The ActiveViewportChangedMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ActiveViewportChangedMessage Class
VisualComponents.UX.Shared Namespace


AddOnHelper Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedAddOnHelper

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class AddOnHelper
public ref class AddOnHelper sealed

The AddOnHelper type exposes the following members.

Properties
 | Name | Description
Public property | AddOnFeatures |
 | Self |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RaiseAddOnStateChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | AddOnFeaturesChanged |
Public event | AddOnStateChanged |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


AddOnHelper Properties

The AddOnHelper type exposes the following members.

Properties
 | Name | Description
Public property | AddOnFeatures |
 | Self |
Top
See Also

Reference

AddOnHelper Class
VisualComponents.UX.Shared Namespace


AddOnHelper.AddOnFeatures Property

AddOnHelperAddOnFeatures Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IReadOnlyDictionary<IAddOnSetting, IReadOnlyList<ProductFeature>> AddOnFeatures { get; }
public:
property IReadOnlyDictionary<IAddOnSetting^, IReadOnlyList<ProductFeature>^>^ AddOnFeatures {
    IReadOnlyDictionary<IAddOnSetting^, IReadOnlyList<ProductFeature>^>^ get ();
}

Property Value

Type: IReadOnlyDictionaryIAddOnSetting, IReadOnlyListProductFeature
See Also

Reference

AddOnHelper Class
VisualComponents.UX.Shared Namespace


AddOnHelper.Self Property

AddOnHelperSelf Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static AddOnHelper Self { get; }
public:
static property AddOnHelper^ Self {
    AddOnHelper^ get ();
}

Property Value

Type: AddOnHelper
See Also

Reference

AddOnHelper Class
VisualComponents.UX.Shared Namespace


AddOnHelper Methods

The AddOnHelper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RaiseAddOnStateChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AddOnHelper Class
VisualComponents.UX.Shared Namespace


AddOnHelper.RaiseAddOnStateChanged Method

AddOnHelperRaiseAddOnStateChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RaiseAddOnStateChanged(
    IAddOnSetting addOn
)
public:
void RaiseAddOnStateChanged(
    IAddOnSetting^ addOn
)

Parameters

addOn
Type: VisualComponents.UX.SharedIAddOnSetting
See Also

Reference

AddOnHelper Class
VisualComponents.UX.Shared Namespace


AddOnHelper Events

The AddOnHelper type exposes the following members.

Events
 | Name | Description
Public event | AddOnFeaturesChanged |
Public event | AddOnStateChanged |
Top
See Also

Reference

AddOnHelper Class
VisualComponents.UX.Shared Namespace


AddOnHelper.AddOnFeaturesChanged Event

AddOnHelperAddOnFeaturesChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<EventArgs> AddOnFeaturesChanged
public:
 event EventHandler<EventArgs^>^ AddOnFeaturesChanged {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

AddOnHelper Class
VisualComponents.UX.Shared Namespace


AddOnHelper.AddOnStateChanged Event

AddOnHelperAddOnStateChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<IAddOnSetting> AddOnStateChanged
public:
 event EventHandler<IAddOnSetting^>^ AddOnStateChanged {
    void add (EventHandler<IAddOnSetting^>^ value);
    void remove (EventHandler<IAddOnSetting^>^ value);
}

Value

Type: SystemEventHandlerIAddOnSetting
See Also

Reference

AddOnHelper Class
VisualComponents.UX.Shared Namespace


AdornedControl Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
VisualComponents.UX.SharedAdornedControl

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class AdornedControl : ContentControl
public ref class AdornedControl : public ContentControl

The AdornedControl type exposes the following members.

Constructors
 | Name | Description
Public method | AdornedControl | Initializes a new instance of the AdornedControl class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AdornedTemplatePartName | By default this property is set to null. When set to non-null it specifies the part name of a UI element in the visual tree of the AdornedControl content that is to be adorned. When this property is null it is the AdornerControl content that is adorned, however when it is set the visual-tree is searched for a UI element that has the specified part name, if the part is found then that UI element is adorned, otherwise an exception "Failed to find part ..." is thrown. ///
Public property | AdornerContent | Used in XAML to define the UI content of the adorner.
Public property | AdornerOffsetX | X offset of the adorner.
Public property | AdornerOffsetY | Y offset of the adorner.
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CloseAdornerTimeOut | Specifies the time (in seconds) after the mouse cursor moves away from the adorned control (or the adorner) when the adorner begins to fade out.
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FadeInTime | Specifies the time (in seconds) it takes to fade in the adorner.
Public property | FadeOutTime | Specifies the time (in seconds) it takes to fade out the adorner.
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAdornerPlacement | Specifies the horizontal placement of the adorner relative to the adorned control.
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsAdornerVisible | Shows or hides the adorner. Set to 'true' to show the adorner or 'false' to hide the adorner.
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOverShowEnabled | Set to 'true' to make the adorner automatically fade-in and become visible when the mouse is hovered over the adorned control. Also the adorner automatically fades-out when the mouse cursor is moved aware from the adorned control (and the adorner).
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAdornerPlacement | Specifies the vertical placement of the adorner relative to the adorned control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Public method | FadeInAdorner | Fade the adorner in and make it visible.
Public method | FadeOutAdorner | Fade the adorner out and make it visible.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
 | FindNamedChild | Finds a child element in the visual tree that has the specified name. Returns null if no child with that name exists.
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | HideAdorner | Hide the adorner.
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | Called to build the visual tree. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Called when the mouse cursor enters the area of the adorned control. (Overrides UIElementOnMouseEnter(MouseEventArgs).)
Protected method | OnMouseLeave | Called when the mouse cursor leaves the area of the adorned control. (Overrides UIElementOnMouseLeave(MouseEventArgs).)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ShowAdorner | Show the adorner.
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | AdornerHidden | Event raised when the adorner is hidden.
Public event | AdornerShown | Event raised when the adorner is shown.
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AdornedTemplatePartNameProperty |
AdornerContentProperty |
AdornerHiddenEvent |
AdornerOffsetXProperty |
AdornerOffsetYProperty |
AdornerShownEvent |
CloseAdornerTimeOutProperty |
FadeInAdornerCommand |
FadeInTimeProperty |
FadeOutAdornerCommand |
FadeOutTimeProperty |
HideAdornerCommand |
HorizontalAdornerPlacementProperty |
IsAdornerVisibleProperty | Dependency properties.
IsMouseOverShowEnabledProperty |
ShowAdornerCommand | Commands.
VerticalAdornerPlacementProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


AdornedControl Constructor

Initializes a new instance of the AdornedControl class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AdornedControl()
public:
AdornedControl()
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl Properties

The AdornedControl type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AdornedTemplatePartName | By default this property is set to null. When set to non-null it specifies the part name of a UI element in the visual tree of the AdornedControl content that is to be adorned. When this property is null it is the AdornerControl content that is adorned, however when it is set the visual-tree is searched for a UI element that has the specified part name, if the part is found then that UI element is adorned, otherwise an exception "Failed to find part ..." is thrown. ///
Public property | AdornerContent | Used in XAML to define the UI content of the adorner.
Public property | AdornerOffsetX | X offset of the adorner.
Public property | AdornerOffsetY | Y offset of the adorner.
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CloseAdornerTimeOut | Specifies the time (in seconds) after the mouse cursor moves away from the adorned control (or the adorner) when the adorner begins to fade out.
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FadeInTime | Specifies the time (in seconds) it takes to fade in the adorner.
Public property | FadeOutTime | Specifies the time (in seconds) it takes to fade out the adorner.
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAdornerPlacement | Specifies the horizontal placement of the adorner relative to the adorned control.
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsAdornerVisible | Shows or hides the adorner. Set to 'true' to show the adorner or 'false' to hide the adorner.
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOverShowEnabled | Set to 'true' to make the adorner automatically fade-in and become visible when the mouse is hovered over the adorned control. Also the adorner automatically fades-out when the mouse cursor is moved aware from the adorned control (and the adorner).
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAdornerPlacement | Specifies the vertical placement of the adorner relative to the adorned control.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.AdornedTemplatePartName Property

AdornedControlAdornedTemplatePartName Property

By default this property is set to null. When set to non-null it specifies the part name of a UI element in the visual tree of the AdornedControl content that is to be adorned. When this property is null it is the AdornerControl content that is adorned, however when it is set the visual-tree is searched for a UI element that has the specified part name, if the part is found then that UI element is adorned, otherwise an exception "Failed to find part ..." is thrown. ///

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AdornedTemplatePartName { get; set; }
public:
property String^ AdornedTemplatePartName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.AdornerContent Property

AdornedControlAdornerContent Property

Used in XAML to define the UI content of the adorner.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FrameworkElement AdornerContent { get; set; }
public:
property FrameworkElement^ AdornerContent {
    FrameworkElement^ get ();
    void set (FrameworkElement^ value);
}

Property Value

Type: FrameworkElement
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.AdornerOffsetX Property

AdornedControlAdornerOffsetX Property

X offset of the adorner.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double AdornerOffsetX { get; set; }
public:
property double AdornerOffsetX {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.AdornerOffsetY Property

AdornedControlAdornerOffsetY Property

Y offset of the adorner.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double AdornerOffsetY { get; set; }
public:
property double AdornerOffsetY {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.CloseAdornerTimeOut Property

AdornedControlCloseAdornerTimeOut Property

Specifies the time (in seconds) after the mouse cursor moves away from the adorned control (or the adorner) when the adorner begins to fade out.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double CloseAdornerTimeOut { get; set; }
public:
property double CloseAdornerTimeOut {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.FadeInTime Property

AdornedControlFadeInTime Property

Specifies the time (in seconds) it takes to fade in the adorner.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double FadeInTime { get; set; }
public:
property double FadeInTime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.FadeOutTime Property

AdornedControlFadeOutTime Property

Specifies the time (in seconds) it takes to fade out the adorner.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double FadeOutTime { get; set; }
public:
property double FadeOutTime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.HorizontalAdornerPlacement Property

AdornedControlHorizontalAdornerPlacement Property

Specifies the horizontal placement of the adorner relative to the adorned control.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AdornerPlacement HorizontalAdornerPlacement { get; set; }
public:
property AdornerPlacement HorizontalAdornerPlacement {
    AdornerPlacement get ();
    void set (AdornerPlacement value);
}

Property Value

Type: AdornerPlacement
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.IsAdornerVisible Property

AdornedControlIsAdornerVisible Property

Shows or hides the adorner. Set to 'true' to show the adorner or 'false' to hide the adorner.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsAdornerVisible { get; set; }
public:
property bool IsAdornerVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.IsMouseOverShowEnabled Property

AdornedControlIsMouseOverShowEnabled Property

Set to 'true' to make the adorner automatically fade-in and become visible when the mouse is hovered over the adorned control. Also the adorner automatically fades-out when the mouse cursor is moved aware from the adorned control (and the adorner).

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsMouseOverShowEnabled { get; set; }
public:
property bool IsMouseOverShowEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.VerticalAdornerPlacement Property

AdornedControlVerticalAdornerPlacement Property

Specifies the vertical placement of the adorner relative to the adorned control.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AdornerPlacement VerticalAdornerPlacement { get; set; }
public:
property AdornerPlacement VerticalAdornerPlacement {
    AdornerPlacement get ();
    void set (AdornerPlacement value);
}

Property Value

Type: AdornerPlacement
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl Methods

The AdornedControl type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Public method | FadeInAdorner | Fade the adorner in and make it visible.
Public method | FadeOutAdorner | Fade the adorner out and make it visible.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
 | FindNamedChild | Finds a child element in the visual tree that has the specified name. Returns null if no child with that name exists.
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | HideAdorner | Hide the adorner.
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | Called to build the visual tree. (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Called when the mouse cursor enters the area of the adorned control. (Overrides UIElementOnMouseEnter(MouseEventArgs).)
Protected method | OnMouseLeave | Called when the mouse cursor leaves the area of the adorned control. (Overrides UIElementOnMouseLeave(MouseEventArgs).)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ShowAdorner | Show the adorner.
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.FadeInAdorner Method

AdornedControlFadeInAdorner Method

Fade the adorner in and make it visible.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void FadeInAdorner()
public:
void FadeInAdorner()
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.FadeOutAdorner Method

AdornedControlFadeOutAdorner Method

Fade the adorner out and make it visible.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void FadeOutAdorner()
public:
void FadeOutAdorner()
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.FindNamedChild Method

AdornedControlFindNamedChild Method

Finds a child element in the visual tree that has the specified name. Returns null if no child with that name exists.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static FrameworkElement FindNamedChild(
    FrameworkElement rootElement,
    string childName
)
public:
static FrameworkElement^ FindNamedChild(
    FrameworkElement^ rootElement,
    String^ childName
)

Parameters

rootElement
Type: System.WindowsFrameworkElement
childName
Type: SystemString

Return Value

Type: FrameworkElement

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.AdornedControl.FindNamedChild(System.Windows.FrameworkElement,System.String)"]

See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.HideAdorner Method

AdornedControlHideAdorner Method

Hide the adorner.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void HideAdorner()
public:
void HideAdorner()
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.OnApplyTemplate Method

AdornedControlOnApplyTemplate Method

Called to build the visual tree.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.OnMouseEnter Method

AdornedControlOnMouseEnter Method

Called when the mouse cursor enters the area of the adorned control.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnMouseEnter(
    MouseEventArgs e
)
protected:
virtual void OnMouseEnter(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputMouseEventArgs
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.OnMouseLeave Method

AdornedControlOnMouseLeave Method

Called when the mouse cursor leaves the area of the adorned control.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnMouseLeave(
    MouseEventArgs e
)
protected:
virtual void OnMouseLeave(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputMouseEventArgs
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.ShowAdorner Method

AdornedControlShowAdorner Method

Show the adorner.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ShowAdorner()
public:
void ShowAdorner()
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl Events

The AdornedControl type exposes the following members.

Events
 | Name | Description
Public event | AdornerHidden | Event raised when the adorner is hidden.
Public event | AdornerShown | Event raised when the adorner is shown.
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.AdornerHidden Event

AdornedControlAdornerHidden Event

Event raised when the adorner is hidden.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event AdornerEventHandler AdornerHidden
public:
 event AdornerEventHandler^ AdornerHidden {
    void add (AdornerEventHandler^ value);
    void remove (AdornerEventHandler^ value);
}

Value

Type: VisualComponents.UX.SharedAdornerEventHandler
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.AdornerShown Event

AdornedControlAdornerShown Event

Event raised when the adorner is shown.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event AdornerEventHandler AdornerShown
public:
 event AdornerEventHandler^ AdornerShown {
    void add (AdornerEventHandler^ value);
    void remove (AdornerEventHandler^ value);
}

Value

Type: VisualComponents.UX.SharedAdornerEventHandler
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl Fields

The AdornedControl type exposes the following members.

Fields
Name | Description
AdornedTemplatePartNameProperty |
AdornerContentProperty |
AdornerHiddenEvent |
AdornerOffsetXProperty |
AdornerOffsetYProperty |
AdornerShownEvent |
CloseAdornerTimeOutProperty |
FadeInAdornerCommand |
FadeInTimeProperty |
FadeOutAdornerCommand |
FadeOutTimeProperty |
HideAdornerCommand |
HorizontalAdornerPlacementProperty |
IsAdornerVisibleProperty | Dependency properties.
IsMouseOverShowEnabledProperty |
ShowAdornerCommand | Commands.
VerticalAdornerPlacementProperty |
Top
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.AdornedTemplatePartNameProperty Field

AdornedControlAdornedTemplatePartNameProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty AdornedTemplatePartNameProperty
public:
static initonly DependencyProperty^ AdornedTemplatePartNameProperty

Field Value

Type: DependencyProperty
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.AdornerContentProperty Field

AdornedControlAdornerContentProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty AdornerContentProperty
public:
static initonly DependencyProperty^ AdornerContentProperty

Field Value

Type: DependencyProperty
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.AdornerHiddenEvent Field

AdornedControlAdornerHiddenEvent Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly RoutedEvent AdornerHiddenEvent
public:
static initonly RoutedEvent^ AdornerHiddenEvent

Field Value

Type: RoutedEvent
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.AdornerOffsetXProperty Field

AdornedControlAdornerOffsetXProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty AdornerOffsetXProperty
public:
static initonly DependencyProperty^ AdornerOffsetXProperty

Field Value

Type: DependencyProperty
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.AdornerOffsetYProperty Field

AdornedControlAdornerOffsetYProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty AdornerOffsetYProperty
public:
static initonly DependencyProperty^ AdornerOffsetYProperty

Field Value

Type: DependencyProperty
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.AdornerShownEvent Field

AdornedControlAdornerShownEvent Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly RoutedEvent AdornerShownEvent
public:
static initonly RoutedEvent^ AdornerShownEvent

Field Value

Type: RoutedEvent
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.CloseAdornerTimeOutProperty Field

AdornedControlCloseAdornerTimeOutProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty CloseAdornerTimeOutProperty
public:
static initonly DependencyProperty^ CloseAdornerTimeOutProperty

Field Value

Type: DependencyProperty
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.FadeInAdornerCommand Field

AdornedControlFadeInAdornerCommand Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly RoutedCommand FadeInAdornerCommand
public:
static initonly RoutedCommand^ FadeInAdornerCommand

Field Value

Type: RoutedCommand
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.FadeInTimeProperty Field

AdornedControlFadeInTimeProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty FadeInTimeProperty
public:
static initonly DependencyProperty^ FadeInTimeProperty

Field Value

Type: DependencyProperty
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.FadeOutAdornerCommand Field

AdornedControlFadeOutAdornerCommand Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly RoutedCommand FadeOutAdornerCommand
public:
static initonly RoutedCommand^ FadeOutAdornerCommand

Field Value

Type: RoutedCommand
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.FadeOutTimeProperty Field

AdornedControlFadeOutTimeProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty FadeOutTimeProperty
public:
static initonly DependencyProperty^ FadeOutTimeProperty

Field Value

Type: DependencyProperty
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.HideAdornerCommand Field

AdornedControlHideAdornerCommand Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly RoutedCommand HideAdornerCommand
public:
static initonly RoutedCommand^ HideAdornerCommand

Field Value

Type: RoutedCommand
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.HorizontalAdornerPlacementProperty Field

AdornedControlHorizontalAdornerPlacementProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty HorizontalAdornerPlacementProperty
public:
static initonly DependencyProperty^ HorizontalAdornerPlacementProperty

Field Value

Type: DependencyProperty
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.IsAdornerVisibleProperty Field

AdornedControlIsAdornerVisibleProperty Field

Dependency properties.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsAdornerVisibleProperty
public:
static initonly DependencyProperty^ IsAdornerVisibleProperty

Field Value

Type: DependencyProperty
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.IsMouseOverShowEnabledProperty Field

AdornedControlIsMouseOverShowEnabledProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsMouseOverShowEnabledProperty
public:
static initonly DependencyProperty^ IsMouseOverShowEnabledProperty

Field Value

Type: DependencyProperty
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.ShowAdornerCommand Field

AdornedControlShowAdornerCommand Field

Commands.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly RoutedCommand ShowAdornerCommand
public:
static initonly RoutedCommand^ ShowAdornerCommand

Field Value

Type: RoutedCommand
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornedControl.VerticalAdornerPlacementProperty Field

AdornedControlVerticalAdornerPlacementProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty VerticalAdornerPlacementProperty
public:
static initonly DependencyProperty^ VerticalAdornerPlacementProperty

Field Value

Type: DependencyProperty
See Also

Reference

AdornedControl Class
VisualComponents.UX.Shared Namespace


AdornerEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
VisualComponents.UX.SharedAdornerEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class AdornerEventArgs : RoutedEventArgs
public ref class AdornerEventArgs : public RoutedEventArgs

The AdornerEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AdornerEventArgs | Initializes a new instance of the AdornerEventArgs class
Top
Properties
 | Name | Description
Public property | Adorner |
Public property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from RoutedEventArgs.)
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)
Public property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from RoutedEventArgs.)
Public property | Source | Gets or sets a reference to the object that raised the event. (Inherited from RoutedEventArgs.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokeEventHandler | When overridden in a derived class, provides a way to invoke event handlers in a type-specific way, which can increase efficiency over the base implementation. (Inherited from RoutedEventArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnSetSource | When overridden in a derived class, provides a notification callback entry point whenever the value of the Source property of an instance changes. (Inherited from RoutedEventArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


AdornerEventArgs Constructor

Initializes a new instance of the AdornerEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AdornerEventArgs(
    RoutedEvent routedEvent,
    Object source,
    FrameworkElement adorner
)
public:
AdornerEventArgs(
    RoutedEvent^ routedEvent,
    Object^ source,
    FrameworkElement^ adorner
)

Parameters

routedEvent
Type: System.WindowsRoutedEvent
source
Type: SystemObject
adorner
Type: System.WindowsFrameworkElement
See Also

Reference

AdornerEventArgs Class
VisualComponents.UX.Shared Namespace


AdornerEventArgs Properties

The AdornerEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Adorner |
Public property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from RoutedEventArgs.)
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)
Public property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from RoutedEventArgs.)
Public property | Source | Gets or sets a reference to the object that raised the event. (Inherited from RoutedEventArgs.)
Top
See Also

Reference

AdornerEventArgs Class
VisualComponents.UX.Shared Namespace


AdornerEventArgs.Adorner Property

AdornerEventArgsAdorner Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FrameworkElement Adorner { get; }
public:
property FrameworkElement^ Adorner {
    FrameworkElement^ get ();
}

Property Value

Type: FrameworkElement
See Also

Reference

AdornerEventArgs Class
VisualComponents.UX.Shared Namespace


AdornerEventArgs Methods

The AdornerEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokeEventHandler | When overridden in a derived class, provides a way to invoke event handlers in a type-specific way, which can increase efficiency over the base implementation. (Inherited from RoutedEventArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnSetSource | When overridden in a derived class, provides a notification callback entry point whenever the value of the Source property of an instance changes. (Inherited from RoutedEventArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AdornerEventArgs Class
VisualComponents.UX.Shared Namespace


AdornerEventHandler Delegate

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public delegate void AdornerEventHandler(
    Object sender,
    AdornerEventArgs e
)
public delegate void AdornerEventHandler(
    Object^ sender,
    AdornerEventArgs^ e
)

Parameters

sender
Type: SystemObject
e
Type: VisualComponents.UX.SharedAdornerEventArgs
See Also

Reference

VisualComponents.UX.Shared Namespace


AfterExecuteEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.UX.SharedAfterExecuteEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class AfterExecuteEventArgs : EventArgs
public ref class AfterExecuteEventArgs : public EventArgs

The AfterExecuteEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | AfterExecuteEventArgs | Initializes a new instance of the AfterExecuteEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


AfterExecuteEventArgs Constructor

Initializes a new instance of the AfterExecuteEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AfterExecuteEventArgs()
public:
AfterExecuteEventArgs()
See Also

Reference

AfterExecuteEventArgs Class
VisualComponents.UX.Shared Namespace


AfterExecuteEventArgs Methods

The AfterExecuteEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AfterExecuteEventArgs Class
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedAlignPrimitiveAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class AlignPrimitiveAction : ICommandPanelAction,
    IHandle<SnapHideMessage>, IHandle, IHandle<SnapResultMessage>,
    IHandle<RequestActionAbortMessage>
public ref class AlignPrimitiveAction sealed : ICommandPanelAction,
    IHandle<SnapHideMessage^>, IHandle, IHandle<SnapResultMessage^>,
    IHandle<RequestActionAbortMessage^>

The AlignPrimitiveAction type exposes the following members.

Constructors
 | Name | Description
Public method | AlignPrimitiveAction | Initializes a new instance of the AlignPrimitiveAction class
Top
Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
 | alignAxisIndex |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
 | IsExecuting |
Public property | Target |
Public property | Title |
Top
Methods
 | Name | Description
Public method | ApplyAction |
Public method | CalcMatrix |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle(RequestActionAbortMessage) |
Public method | Handle(SnapHideMessage) |
Public method | Handle(SnapResultMessage) |
 | IsSame |
 | IsSameObj |
 | OnPropertyChanged |
Public method | StartAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
Name | Description
IsExecutingChanged |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


AlignPrimitiveAction Constructor

Initializes a new instance of the AlignPrimitiveAction class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AlignPrimitiveAction(
    IManipulationTarget target,
    bool stayResident
)
public:
AlignPrimitiveAction(
    IManipulationTarget^ target,
    bool stayResident
)

Parameters

target
Type: VisualComponents.Create3DIManipulationTarget
stayResident
Type: SystemBoolean
See Also

Reference

AlignPrimitiveAction Class
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction Properties

The AlignPrimitiveAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
 | alignAxisIndex |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
 | IsExecuting |
Public property | Target |
Public property | Title |
Top
See Also

Reference

AlignPrimitiveAction Class
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction.ActionFinished Property

AlignPrimitiveActionActionFinished Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ActionFinished { get; }
public:
virtual property bool ActionFinished {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ICommandPanelActionActionFinished
See Also

Reference

AlignPrimitiveAction Class
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction.ActionProperties Property

AlignPrimitiveActionActionProperties Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<IProperty> ActionProperties { get; }
public:
virtual property List<IProperty^>^ ActionProperties {
    List<IProperty^>^ get () sealed;
}

Property Value

Type: ListIProperty

Implements

ICommandPanelActionActionProperties
See Also

Reference

AlignPrimitiveAction Class
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction.alignAxisIndex Property

AlignPrimitiveActionalignAxisIndex Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int alignAxisIndex { get; set; }
public:
static property int alignAxisIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AlignPrimitiveAction Class
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction.ApplyButtonText Property

AlignPrimitiveActionApplyButtonText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ApplyButtonText { get; }
public:
virtual property String^ ApplyButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionApplyButtonText
See Also

Reference

AlignPrimitiveAction Class
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction.AssociatedModelId Property

AlignPrimitiveActionAssociatedModelId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedModelId { get; }
public:
virtual property String^ AssociatedModelId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedModelId
See Also

Reference

AlignPrimitiveAction Class
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction.AssociatedSiteId Property

AlignPrimitiveActionAssociatedSiteId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedSiteId { get; }
public:
virtual property String^ AssociatedSiteId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedSiteId
See Also

Reference

AlignPrimitiveAction Class
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction.CallingCommandName Property

AlignPrimitiveActionCallingCommandName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CallingCommandName { get; }
public:
virtual property String^ CallingCommandName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCallingCommandName
See Also

Reference

AlignPrimitiveAction Class
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction.CancelButtonText Property

AlignPrimitiveActionCancelButtonText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CancelButtonText { get; }
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCancelButtonText
See Also

Reference

AlignPrimitiveAction Class
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction.Description Property

AlignPrimitiveActionDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; }
public:
virtual property String^ Description {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionDescription
See Also

Reference

AlignPrimitiveAction Class
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction.ErrorMessage Property

AlignPrimitiveActionErrorMessage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ErrorMessage { get; set; }
public:
virtual property String^ ErrorMessage {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionErrorMessage
See Also

Reference

AlignPrimitiveAction Class
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction.IsExecuting Property

AlignPrimitiveActionIsExecuting Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsExecuting { get; }
public:
static property bool IsExecuting {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

AlignPrimitiveAction Class
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction.Target Property

AlignPrimitiveActionTarget Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IManipulationTarget Target { get; }
public:
property IManipulationTarget^ Target {
    IManipulationTarget^ get ();
}

Property Value

Type: IManipulationTarget
See Also

Reference

AlignPrimitiveAction Class
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction.Title Property

AlignPrimitiveActionTitle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; }
public:
virtual property String^ Title {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionTitle
See Also

Reference

AlignPrimitiveAction Class
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction Methods

The AlignPrimitiveAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction |
Public method | CalcMatrix |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle(RequestActionAbortMessage) |
Public method | Handle(SnapHideMessage) |
Public method | Handle(SnapResultMessage) |
 | IsSame |
 | IsSameObj |
 | OnPropertyChanged |
Public method | StartAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AlignPrimitiveAction Class
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction.ApplyAction Method

AlignPrimitiveActionApplyAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ApplyAction()
public:
virtual bool ApplyAction() sealed

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.AlignPrimitiveAction.ApplyAction"]

Implements

ICommandPanelActionApplyAction
See Also

Reference

AlignPrimitiveAction Class
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction.CalcMatrix Method

AlignPrimitiveActionCalcMatrix Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CalcMatrix(
    SnapResult[] picks,
    out Matrix mat
)
public:
bool CalcMatrix(
    array<SnapResult>^ picks,
    [OutAttribute] Matrix% mat
)

Parameters

picks
Type: VisualComponents.Create3DSnapResult
mat
Type: VisualComponents.Create3DMatrix

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.AlignPrimitiveAction.CalcMatrix(VisualComponents.Create3D.SnapResult[],VisualComponents.Create3D.Matrix@)"]

See Also

Reference

AlignPrimitiveAction Class
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction.CancelAction Method

AlignPrimitiveActionCancelAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CancelAction()
public:
virtual void CancelAction() sealed

Implements

ICommandPanelActionCancelAction
See Also

Reference

AlignPrimitiveAction Class
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction.Execute Method

AlignPrimitiveActionExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<IResult> Execute()
public:
IEnumerable<IResult^>^ Execute()

Return Value

Type: IEnumerableIResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.AlignPrimitiveAction.Execute"]

See Also

Reference

AlignPrimitiveAction Class
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction.Handle Method

AlignPrimitiveActionHandle Method

Overload List
 | Name | Description
Public method | Handle(RequestActionAbortMessage) |
Public method | Handle(SnapHideMessage) |
Public method | Handle(SnapResultMessage) |
Top
See Also

Reference

AlignPrimitiveAction Class
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction.Handle Method (RequestActionAbortMessage)

AlignPrimitiveActionHandle Method (RequestActionAbortMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    RequestActionAbortMessage message
)
public:
virtual void Handle(
    RequestActionAbortMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedRequestActionAbortMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

AlignPrimitiveAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction.Handle Method (SnapHideMessage)

AlignPrimitiveActionHandle Method (SnapHideMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    SnapHideMessage message
)
public:
virtual void Handle(
    SnapHideMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedSnapHideMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

AlignPrimitiveAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction.Handle Method (SnapResultMessage)

AlignPrimitiveActionHandle Method (SnapResultMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    SnapResultMessage message
)
public:
virtual void Handle(
    SnapResultMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedSnapResultMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

AlignPrimitiveAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction.IsSame Method

AlignPrimitiveActionIsSame Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsSame(
    IVisualObject obj1,
    IVisualObject obj2
)
public:
static bool IsSame(
    IVisualObject^ obj1,
    IVisualObject^ obj2
)

Parameters

obj1
Type: VisualComponents.Create3DIVisualObject
obj2
Type: VisualComponents.Create3DIVisualObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.AlignPrimitiveAction.IsSame(VisualComponents.Create3D.IVisualObject,VisualComponents.Create3D.IVisualObject)"]

See Also

Reference

AlignPrimitiveAction Class
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction.IsSameObj Method

AlignPrimitiveActionIsSameObj Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsSameObj(
    IVisualObject obj1,
    Object obj2
)
public:
static bool IsSameObj(
    IVisualObject^ obj1,
    Object^ obj2
)

Parameters

obj1
Type: VisualComponents.Create3DIVisualObject
obj2
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.AlignPrimitiveAction.IsSameObj(VisualComponents.Create3D.IVisualObject,System.Object)"]

See Also

Reference

AlignPrimitiveAction Class
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction.OnPropertyChanged Method

AlignPrimitiveActionOnPropertyChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void OnPropertyChanged(
    string name
)
public:
static void OnPropertyChanged(
    String^ name
)

Parameters

name
Type: SystemString
See Also

Reference

AlignPrimitiveAction Class
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction.StartAction Method

AlignPrimitiveActionStartAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    EventHandler<ResultCompletionEventArgs> completed = null
)
public:
virtual void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr
) sealed

Parameters

completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs

Implements

ICommandPanelActionStartAction(EventHandlerResultCompletionEventArgs)
See Also

Reference

AlignPrimitiveAction Class
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction Events

The AlignPrimitiveAction type exposes the following members.

Events
Name | Description
IsExecutingChanged |
Top
See Also

Reference

AlignPrimitiveAction Class
VisualComponents.UX.Shared Namespace


AlignPrimitiveAction.IsExecutingChanged Event

AlignPrimitiveActionIsExecutingChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static event PropertyChangedEventHandler IsExecutingChanged
public:
static  event PropertyChangedEventHandler^ IsExecutingChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler
See Also

Reference

AlignPrimitiveAction Class
VisualComponents.UX.Shared Namespace


AllowedValueContainer Class

Stores Allowed values . Derives from DependencyObject so that it gets the DataContext property.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
VisualComponents.UX.SharedAllowedValueContainer

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class AllowedValueContainer : DependencyObject
public ref class AllowedValueContainer : public DependencyObject

The AllowedValueContainer type exposes the following members.

Constructors
 | Name | Description
Public method | AllowedValueContainer | Initializes a new instance of the AllowedValueContainer class
Top
Properties
 | Name | Description
Public property | AllowedMaximumValue |
Public property | AllowedMinimumValue |
Public property | Context |
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | Property |
Public property | PropertyType |
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from DependencyObject.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
AllowedMaximumValueProperty |
AllowedMinimumValueProperty |
ContextProperty |
PropertyProperty |
PropertyTypeProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


AllowedValueContainer Constructor

Initializes a new instance of the AllowedValueContainer class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AllowedValueContainer()
public:
AllowedValueContainer()
See Also

Reference

AllowedValueContainer Class
VisualComponents.UX.Shared Namespace


AllowedValueContainer Properties

The AllowedValueContainer type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximumValue |
Public property | AllowedMinimumValue |
Public property | Context |
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | Property |
Public property | PropertyType |
Top
See Also

Reference

AllowedValueContainer Class
VisualComponents.UX.Shared Namespace


AllowedValueContainer.AllowedMaximumValue Property

AllowedValueContainerAllowedMaximumValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IComparable AllowedMaximumValue { get; set; }
public:
property IComparable^ AllowedMaximumValue {
    IComparable^ get ();
    void set (IComparable^ value);
}

Property Value

Type: IComparable
See Also

Reference

AllowedValueContainer Class
VisualComponents.UX.Shared Namespace


AllowedValueContainer.AllowedMinimumValue Property

AllowedValueContainerAllowedMinimumValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IComparable AllowedMinimumValue { get; set; }
public:
property IComparable^ AllowedMinimumValue {
    IComparable^ get ();
    void set (IComparable^ value);
}

Property Value

Type: IComparable
See Also

Reference

AllowedValueContainer Class
VisualComponents.UX.Shared Namespace


AllowedValueContainer.Context Property

AllowedValueContainerContext Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IExpressionContext Context { get; set; }
public:
property IExpressionContext^ Context {
    IExpressionContext^ get ();
    void set (IExpressionContext^ value);
}

Property Value

Type: IExpressionContext
See Also

Reference

AllowedValueContainer Class
VisualComponents.UX.Shared Namespace


AllowedValueContainer.Property Property

AllowedValueContainerProperty Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EditorProperty Property { get; set; }
public:
property EditorProperty^ Property {
    EditorProperty^ get ();
    void set (EditorProperty^ value);
}

Property Value

Type: EditorProperty
See Also

Reference

AllowedValueContainer Class
VisualComponents.UX.Shared Namespace


AllowedValueContainer.PropertyType Property

AllowedValueContainerPropertyType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type PropertyType { get; set; }
public:
property Type^ PropertyType {
    Type^ get ();
    void set (Type^ value);
}

Property Value

Type: Type
See Also

Reference

AllowedValueContainer Class
VisualComponents.UX.Shared Namespace


AllowedValueContainer Methods

The AllowedValueContainer type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from DependencyObject.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AllowedValueContainer Class
VisualComponents.UX.Shared Namespace


AllowedValueContainer Fields

The AllowedValueContainer type exposes the following members.

Fields
Name | Description
AllowedMaximumValueProperty |
AllowedMinimumValueProperty |
ContextProperty |
PropertyProperty |
PropertyTypeProperty |
Top
See Also

Reference

AllowedValueContainer Class
VisualComponents.UX.Shared Namespace


AllowedValueContainer.AllowedMaximumValueProperty Field

AllowedValueContainerAllowedMaximumValueProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty AllowedMaximumValueProperty
public:
static initonly DependencyProperty^ AllowedMaximumValueProperty

Field Value

Type: DependencyProperty
See Also

Reference

AllowedValueContainer Class
VisualComponents.UX.Shared Namespace


AllowedValueContainer.AllowedMinimumValueProperty Field

AllowedValueContainerAllowedMinimumValueProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty AllowedMinimumValueProperty
public:
static initonly DependencyProperty^ AllowedMinimumValueProperty

Field Value

Type: DependencyProperty
See Also

Reference

AllowedValueContainer Class
VisualComponents.UX.Shared Namespace


AllowedValueContainer.ContextProperty Field

AllowedValueContainerContextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ContextProperty
public:
static initonly DependencyProperty^ ContextProperty

Field Value

Type: DependencyProperty
See Also

Reference

AllowedValueContainer Class
VisualComponents.UX.Shared Namespace


AllowedValueContainer.PropertyProperty Field

AllowedValueContainerPropertyProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty PropertyProperty
public:
static initonly DependencyProperty^ PropertyProperty

Field Value

Type: DependencyProperty
See Also

Reference

AllowedValueContainer Class
VisualComponents.UX.Shared Namespace


AllowedValueContainer.PropertyTypeProperty Field

AllowedValueContainerPropertyTypeProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty PropertyTypeProperty
public:
static initonly DependencyProperty^ PropertyTypeProperty

Field Value

Type: DependencyProperty
See Also

Reference

AllowedValueContainer Class
VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedAngularDimensionCreateAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class AngularDimensionCreateAction : ICommandPanelAction,
    IHandle<SnapResultMessage>, IHandle, IHandle<PickMessage>,
    IHandle<RequestActionAbortMessage>
public ref class AngularDimensionCreateAction : ICommandPanelAction,
    IHandle<SnapResultMessage^>, IHandle, IHandle<PickMessage^>,
    IHandle<RequestActionAbortMessage^>

The AngularDimensionCreateAction type exposes the following members.

Constructors
 | Name | Description
Public method | AngularDimensionCreateAction | Initializes a new instance of the AngularDimensionCreateAction class
Top
Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
 | IsExecuting |
Public property | Name |
Public property | Title |
Top
Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle(PickMessage) |
Public method | Handle(RequestActionAbortMessage) |
Public method | Handle(SnapResultMessage) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnPropertyChanged |
Public method | StartAction(EventHandlerResultCompletionEventArgs) |
Public method | StartAction(EventHandlerResultCompletionEventArgs, Boolean) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
Name | Description
IsExecutingChanged |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction Constructor

Initializes a new instance of the AngularDimensionCreateAction class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AngularDimensionCreateAction()
public:
AngularDimensionCreateAction()
See Also

Reference

AngularDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction Properties

The AngularDimensionCreateAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
 | IsExecuting |
Public property | Name |
Public property | Title |
Top
See Also

Reference

AngularDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction.ActionFinished Property

AngularDimensionCreateActionActionFinished Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ActionFinished { get; }
public:
virtual property bool ActionFinished {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ICommandPanelActionActionFinished
See Also

Reference

AngularDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction.ActionProperties Property

AngularDimensionCreateActionActionProperties Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<IProperty> ActionProperties { get; }
public:
virtual property List<IProperty^>^ ActionProperties {
    List<IProperty^>^ get () sealed;
}

Property Value

Type: ListIProperty

Implements

ICommandPanelActionActionProperties
See Also

Reference

AngularDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction.ApplyButtonText Property

AngularDimensionCreateActionApplyButtonText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ApplyButtonText { get; }
public:
virtual property String^ ApplyButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionApplyButtonText
See Also

Reference

AngularDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction.AssociatedModelId Property

AngularDimensionCreateActionAssociatedModelId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedModelId { get; }
public:
virtual property String^ AssociatedModelId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedModelId
See Also

Reference

AngularDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction.AssociatedSiteId Property

AngularDimensionCreateActionAssociatedSiteId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedSiteId { get; }
public:
virtual property String^ AssociatedSiteId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedSiteId
See Also

Reference

AngularDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction.CallingCommandName Property

AngularDimensionCreateActionCallingCommandName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CallingCommandName { get; }
public:
virtual property String^ CallingCommandName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCallingCommandName
See Also

Reference

AngularDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction.CancelButtonText Property

AngularDimensionCreateActionCancelButtonText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CancelButtonText { get; }
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCancelButtonText
See Also

Reference

AngularDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction.Description Property

AngularDimensionCreateActionDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; }
public:
virtual property String^ Description {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionDescription
See Also

Reference

AngularDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction.ErrorMessage Property

AngularDimensionCreateActionErrorMessage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ErrorMessage { get; set; }
public:
virtual property String^ ErrorMessage {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionErrorMessage
See Also

Reference

AngularDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction.IsExecuting Property

AngularDimensionCreateActionIsExecuting Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsExecuting { get; }
public:
static property bool IsExecuting {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

AngularDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction.Name Property

AngularDimensionCreateActionName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; }
public:
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

AngularDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction.Title Property

AngularDimensionCreateActionTitle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; }
public:
virtual property String^ Title {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionTitle
See Also

Reference

AngularDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction Methods

The AngularDimensionCreateAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle(PickMessage) |
Public method | Handle(RequestActionAbortMessage) |
Public method | Handle(SnapResultMessage) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnPropertyChanged |
Public method | StartAction(EventHandlerResultCompletionEventArgs) |
Public method | StartAction(EventHandlerResultCompletionEventArgs, Boolean) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AngularDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction.ApplyAction Method

AngularDimensionCreateActionApplyAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ApplyAction()
public:
virtual bool ApplyAction() sealed

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.AngularDimensionCreateAction.ApplyAction"]

Implements

ICommandPanelActionApplyAction
See Also

Reference

AngularDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction.CancelAction Method

AngularDimensionCreateActionCancelAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CancelAction()
public:
virtual void CancelAction() sealed

Implements

ICommandPanelActionCancelAction
See Also

Reference

AngularDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction.Execute Method

AngularDimensionCreateActionExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<IResult> Execute()
public:
IEnumerable<IResult^>^ Execute()

Return Value

Type: IEnumerableIResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.AngularDimensionCreateAction.Execute"]

See Also

Reference

AngularDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction.Handle Method

AngularDimensionCreateActionHandle Method

Overload List
 | Name | Description
Public method | Handle(PickMessage) |
Public method | Handle(RequestActionAbortMessage) |
Public method | Handle(SnapResultMessage) |
Top
See Also

Reference

AngularDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction.Handle Method (PickMessage)

AngularDimensionCreateActionHandle Method (PickMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    PickMessage message
)
public:
virtual void Handle(
    PickMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedPickMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

AngularDimensionCreateAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction.Handle Method (RequestActionAbortMessage)

AngularDimensionCreateActionHandle Method (RequestActionAbortMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    RequestActionAbortMessage message
)
public:
virtual void Handle(
    RequestActionAbortMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedRequestActionAbortMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

AngularDimensionCreateAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction.Handle Method (SnapResultMessage)

AngularDimensionCreateActionHandle Method (SnapResultMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    SnapResultMessage message
)
public:
virtual void Handle(
    SnapResultMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedSnapResultMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

AngularDimensionCreateAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction.OnPropertyChanged Method

AngularDimensionCreateActionOnPropertyChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void OnPropertyChanged(
    string name
)
public:
static void OnPropertyChanged(
    String^ name
)

Parameters

name
Type: SystemString
See Also

Reference

AngularDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction.StartAction Method

AngularDimensionCreateActionStartAction Method

Overload List
 | Name | Description
Public method | StartAction(EventHandlerResultCompletionEventArgs) |
Public method | StartAction(EventHandlerResultCompletionEventArgs, Boolean) |
Top
See Also

Reference

AngularDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction.StartAction Method (EventHandler(ResultCompletionEventArgs))

AngularDimensionCreateActionStartAction Method (EventHandlerResultCompletionEventArgs)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    EventHandler<ResultCompletionEventArgs> completed = null
)
public:
virtual void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr
) sealed

Parameters

completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs

Implements

ICommandPanelActionStartAction(EventHandlerResultCompletionEventArgs)
See Also

Reference

AngularDimensionCreateAction Class
StartAction Overload
VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction.StartAction Method (EventHandler(ResultCompletionEventArgs), Boolean)

AngularDimensionCreateActionStartAction Method (EventHandlerResultCompletionEventArgs, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    EventHandler<ResultCompletionEventArgs> completed,
    bool multiShot
)
public:
void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed,
    bool multiShot
)

Parameters

completed
Type: SystemEventHandlerResultCompletionEventArgs
multiShot
Type: SystemBoolean
See Also

Reference

AngularDimensionCreateAction Class
StartAction Overload
VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction Events

The AngularDimensionCreateAction type exposes the following members.

Events
Name | Description
IsExecutingChanged |
Top
See Also

Reference

AngularDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


AngularDimensionCreateAction.IsExecutingChanged Event

AngularDimensionCreateActionIsExecutingChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static event PropertyChangedEventHandler IsExecutingChanged
public:
static  event PropertyChangedEventHandler^ IsExecutingChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler
See Also

Reference

AngularDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


AnnotationManipulateAction Class

Annotation Manipulate Action
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedFixedPropertyContainer
VisualComponents.UX.SharedAnnotationManipulateAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class AnnotationManipulateAction : FixedPropertyContainer,
    IActionResult, IResult, IPropertyContainer, IBatchModeObject, IHandle<AnnotationManipulateMessage>,
    IHandle
public ref class AnnotationManipulateAction sealed : public FixedPropertyContainer,
    IActionResult, IResult, IPropertyContainer, IBatchModeObject, IHandle<AnnotationManipulateMessage^>,
    IHandle

The AnnotationManipulateAction type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationManipulateAction | Initializes a new instance of the AnnotationManipulateAction class
Top
Properties
 | Name | Description
Public property | ChangeBatchLevel | (Inherited from FixedPropertyContainer.)
Public property | ContainerExpressionContext | (Inherited from FixedPropertyContainer.)
 | IsActive |
Public property | Properties | get properties (Inherited from FixedPropertyContainer.)
Public property | PropertyNames | (Inherited from FixedPropertyContainer.)
Public property | PropertyNamesAndValues | (Inherited from FixedPropertyContainer.)
Public property | PropertyValues | (Inherited from FixedPropertyContainer.)
Public property | TranslationRotationService |
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType) | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from FixedPropertyContainer.)
Public method | DeleteProperty | (Inherited from FixedPropertyContainer.)
Public method | EndChangeBatch | (Inherited from FixedPropertyContainer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperty | (Inherited from FixedPropertyContainer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle |
 | Manipulate |
Public method | NotifyPropertyChanged | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Completed |
Public event | PropertyChanged | (Inherited from FixedPropertyContainer.)
Public event | PropertyContainerChanged | (Inherited from FixedPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


AnnotationManipulateAction Constructor

Initializes a new instance of the AnnotationManipulateAction class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AnnotationManipulateAction()
public:
AnnotationManipulateAction()
See Also

Reference

AnnotationManipulateAction Class
VisualComponents.UX.Shared Namespace


AnnotationManipulateAction Properties

The AnnotationManipulateAction type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | (Inherited from FixedPropertyContainer.)
Public property | ContainerExpressionContext | (Inherited from FixedPropertyContainer.)
 | IsActive |
Public property | Properties | get properties (Inherited from FixedPropertyContainer.)
Public property | PropertyNames | (Inherited from FixedPropertyContainer.)
Public property | PropertyNamesAndValues | (Inherited from FixedPropertyContainer.)
Public property | PropertyValues | (Inherited from FixedPropertyContainer.)
Public property | TranslationRotationService |
Top
See Also

Reference

AnnotationManipulateAction Class
VisualComponents.UX.Shared Namespace


AnnotationManipulateAction.IsActive Property

AnnotationManipulateActionIsActive Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsActive { get; set; }
public:
static property bool IsActive {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AnnotationManipulateAction Class
VisualComponents.UX.Shared Namespace


AnnotationManipulateAction.TranslationRotationService Property

AnnotationManipulateActionTranslationRotationService Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ITranslationRotationService TranslationRotationService { get; }
public:
property ITranslationRotationService^ TranslationRotationService {
    ITranslationRotationService^ get ();
}

Property Value

Type: ITranslationRotationService
See Also

Reference

AnnotationManipulateAction Class
VisualComponents.UX.Shared Namespace


AnnotationManipulateAction Methods

The AnnotationManipulateAction type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType) | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from FixedPropertyContainer.)
Public method | DeleteProperty | (Inherited from FixedPropertyContainer.)
Public method | EndChangeBatch | (Inherited from FixedPropertyContainer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperty | (Inherited from FixedPropertyContainer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle |
 | Manipulate |
Public method | NotifyPropertyChanged | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AnnotationManipulateAction Class
VisualComponents.UX.Shared Namespace


AnnotationManipulateAction.Execute Method

AnnotationManipulateActionExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    ActionExecutionContext context
)
public:
virtual void Execute(
    ActionExecutionContext^ context
) sealed

Parameters

context
Type: ActionExecutionContext

Implements

IResult.Execute(ActionExecutionContext)
See Also

Reference

AnnotationManipulateAction Class
VisualComponents.UX.Shared Namespace


AnnotationManipulateAction.Handle Method

AnnotationManipulateActionHandle Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    AnnotationManipulateMessage message
)
public:
virtual void Handle(
    AnnotationManipulateMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedAnnotationManipulateMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

AnnotationManipulateAction Class
VisualComponents.UX.Shared Namespace


AnnotationManipulateAction.Manipulate Method

AnnotationManipulateActionManipulate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IEnumerable<IResult> Manipulate()
public:
static IEnumerable<IResult^>^ Manipulate()

Return Value

Type: IEnumerableIResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.AnnotationManipulateAction.Manipulate"]

See Also

Reference

AnnotationManipulateAction Class
VisualComponents.UX.Shared Namespace


AnnotationManipulateAction Events

The AnnotationManipulateAction type exposes the following members.

Events
 | Name | Description
Public event | Completed |
Public event | PropertyChanged | (Inherited from FixedPropertyContainer.)
Public event | PropertyContainerChanged | (Inherited from FixedPropertyContainer.)
Top
See Also

Reference

AnnotationManipulateAction Class
VisualComponents.UX.Shared Namespace


AnnotationManipulateAction.Completed Event

AnnotationManipulateActionCompleted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ResultCompletionEventArgs> Completed
public:
virtual  event EventHandler<ResultCompletionEventArgs^>^ Completed {
    void add (EventHandler<ResultCompletionEventArgs^>^ value);
    void remove (EventHandler<ResultCompletionEventArgs^>^ value);
}

Value

Type: SystemEventHandlerResultCompletionEventArgs

Implements

IResult.Completed
See Also

Reference

AnnotationManipulateAction Class
VisualComponents.UX.Shared Namespace


AnnotationManipulateMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedAnnotationManipulateMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class AnnotationManipulateMessage
public ref class AnnotationManipulateMessage

The AnnotationManipulateMessage type exposes the following members.

Constructors
 | Name | Description
Public method | AnnotationManipulateMessage | Initializes a new instance of the AnnotationManipulateMessage class
Top
Properties
 | Name | Description
Public property | Annotation |
Public property | Continue |
Public property | CurrentPoint |
Public property | IsAnnoatationBody |
Public property | LastPoint |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


AnnotationManipulateMessage Constructor

Initializes a new instance of the AnnotationManipulateMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AnnotationManipulateMessage()
public:
AnnotationManipulateMessage()
See Also

Reference

AnnotationManipulateMessage Class
VisualComponents.UX.Shared Namespace


AnnotationManipulateMessage Properties

The AnnotationManipulateMessage type exposes the following members.

Properties
 | Name | Description
Public property | Annotation |
Public property | Continue |
Public property | CurrentPoint |
Public property | IsAnnoatationBody |
Public property | LastPoint |
Top
See Also

Reference

AnnotationManipulateMessage Class
VisualComponents.UX.Shared Namespace


AnnotationManipulateMessage.Annotation Property

AnnotationManipulateMessageAnnotation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IAnnotation Annotation { get; set; }
public:
property IAnnotation^ Annotation {
    IAnnotation^ get ();
    void set (IAnnotation^ value);
}

Property Value

Type: IAnnotation
See Also

Reference

AnnotationManipulateMessage Class
VisualComponents.UX.Shared Namespace


AnnotationManipulateMessage.Continue Property

AnnotationManipulateMessageContinue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Continue { get; set; }
public:
property bool Continue {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AnnotationManipulateMessage Class
VisualComponents.UX.Shared Namespace


AnnotationManipulateMessage.CurrentPoint Property

AnnotationManipulateMessageCurrentPoint Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Point CurrentPoint { get; set; }
public:
property Point CurrentPoint {
    Point get ();
    void set (Point value);
}

Property Value

Type: Point
See Also

Reference

AnnotationManipulateMessage Class
VisualComponents.UX.Shared Namespace


AnnotationManipulateMessage.IsAnnoatationBody Property

AnnotationManipulateMessageIsAnnoatationBody Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsAnnoatationBody { get; set; }
public:
property bool IsAnnoatationBody {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AnnotationManipulateMessage Class
VisualComponents.UX.Shared Namespace


AnnotationManipulateMessage.LastPoint Property

AnnotationManipulateMessageLastPoint Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Point LastPoint { get; set; }
public:
property Point LastPoint {
    Point get ();
    void set (Point value);
}

Property Value

Type: Point
See Also

Reference

AnnotationManipulateMessage Class
VisualComponents.UX.Shared Namespace


AnnotationManipulateMessage Methods

The AnnotationManipulateMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AnnotationManipulateMessage Class
VisualComponents.UX.Shared Namespace


ApplicationMenuSelectionChangedEventArgs Class

Event args for the ribbon application menu selection changed event.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.UX.SharedApplicationMenuSelectionChangedEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ApplicationMenuSelectionChangedEventArgs : EventArgs
public ref class ApplicationMenuSelectionChangedEventArgs : public EventArgs

The ApplicationMenuSelectionChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ApplicationMenuSelectionChangedEventArgs | Initializes a new ApplicationMenuSelectionChangedEventArgs
Top
Properties
 | Name | Description
Public property | SelectedItem | Returns selected application menu item.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ApplicationMenuSelectionChangedEventArgs Constructor

Initializes a new ApplicationMenuSelectionChangedEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ApplicationMenuSelectionChangedEventArgs(
    IBackstageViewModel selectedItem
)
public:
ApplicationMenuSelectionChangedEventArgs(
    IBackstageViewModel^ selectedItem
)

Parameters

selectedItem
Type: VisualComponents.UX.SharedIBackstageViewModel
returns selected application menu item.
See Also

Reference

ApplicationMenuSelectionChangedEventArgs Class
VisualComponents.UX.Shared Namespace


ApplicationMenuSelectionChangedEventArgs Properties

The ApplicationMenuSelectionChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | SelectedItem | Returns selected application menu item.
Top
See Also

Reference

ApplicationMenuSelectionChangedEventArgs Class
VisualComponents.UX.Shared Namespace


ApplicationMenuSelectionChangedEventArgs.SelectedItem Property

ApplicationMenuSelectionChangedEventArgsSelectedItem Property

Returns selected application menu item.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IBackstageViewModel SelectedItem { get; protected set; }
public:
property IBackstageViewModel^ SelectedItem {
    IBackstageViewModel^ get ();
    protected: void set (IBackstageViewModel^ value);
}

Property Value

Type: IBackstageViewModel
See Also

Reference

ApplicationMenuSelectionChangedEventArgs Class
VisualComponents.UX.Shared Namespace


ApplicationMenuSelectionChangedEventArgs Methods

The ApplicationMenuSelectionChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ApplicationMenuSelectionChangedEventArgs Class
VisualComponents.UX.Shared Namespace


AreaSelectAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedFixedPropertyContainer
VisualComponents.UX.SharedAreaSelectAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class AreaSelectAction : FixedPropertyContainer,
    IActionResult, IResult, IPropertyContainer, IBatchModeObject
public ref class AreaSelectAction : public FixedPropertyContainer,
    IActionResult, IResult, IPropertyContainer, IBatchModeObject

The AreaSelectAction type exposes the following members.

Constructors
 | Name | Description
Public method | AreaSelectAction | Initializes a new instance of the AreaSelectAction class
Top
Properties
 | Name | Description
 | ActionMode |
Public property | AppendSelection |
Public property | ChangeBatchLevel | (Inherited from FixedPropertyContainer.)
Public property | ContainerExpressionContext | (Inherited from FixedPropertyContainer.)
Protected property | EventMng | Event aggregator (Inherited from FixedPropertyContainer.)
 | Filter | Gets or sets a filter function that can be used to manipulate collection of items before they are selected.
Public property | ManipulationArgs |
Public property | Properties | get properties (Inherited from FixedPropertyContainer.)
Public property | PropertyNames | (Inherited from FixedPropertyContainer.)
Public property | PropertyNamesAndValues | (Inherited from FixedPropertyContainer.)
Public property | PropertyValues | (Inherited from FixedPropertyContainer.)
Public property | SelectionMode |
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType) | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from FixedPropertyContainer.)
Public method | DeleteProperty | (Inherited from FixedPropertyContainer.)
Public method | EndChangeBatch | (Inherited from FixedPropertyContainer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperty | (Inherited from FixedPropertyContainer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotifyChanged | (Inherited from FixedPropertyContainer.)
Public method | NotifyPropertyChanged | (Inherited from FixedPropertyContainer.)
 | Select |
Public method | SetPropertyValues(IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Completed |
Public event | PropertyChanged | (Inherited from FixedPropertyContainer.)
Public event | PropertyContainerChanged | (Inherited from FixedPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


AreaSelectAction Constructor

Initializes a new instance of the AreaSelectAction class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AreaSelectAction()
public:
AreaSelectAction()
See Also

Reference

AreaSelectAction Class
VisualComponents.UX.Shared Namespace


AreaSelectAction Properties

The AreaSelectAction type exposes the following members.

Properties
 | Name | Description
 | ActionMode |
Public property | AppendSelection |
Public property | ChangeBatchLevel | (Inherited from FixedPropertyContainer.)
Public property | ContainerExpressionContext | (Inherited from FixedPropertyContainer.)
Protected property | EventMng | Event aggregator (Inherited from FixedPropertyContainer.)
 | Filter | Gets or sets a filter function that can be used to manipulate collection of items before they are selected.
Public property | ManipulationArgs |
Public property | Properties | get properties (Inherited from FixedPropertyContainer.)
Public property | PropertyNames | (Inherited from FixedPropertyContainer.)
Public property | PropertyNamesAndValues | (Inherited from FixedPropertyContainer.)
Public property | PropertyValues | (Inherited from FixedPropertyContainer.)
Public property | SelectionMode |
Top
See Also

Reference

AreaSelectAction Class
VisualComponents.UX.Shared Namespace


AreaSelectAction.ActionMode Property

AreaSelectActionActionMode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static AreaSelectionActionMode ActionMode { get; set; }
public:
static property AreaSelectionActionMode ActionMode {
    AreaSelectionActionMode get ();
    void set (AreaSelectionActionMode value);
}

Property Value

Type: AreaSelectionActionMode
See Also

Reference

AreaSelectAction Class
VisualComponents.UX.Shared Namespace


AreaSelectAction.AppendSelection Property

AreaSelectActionAppendSelection Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool AppendSelection { get; set; }
public:
property bool AppendSelection {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AreaSelectAction Class
VisualComponents.UX.Shared Namespace


AreaSelectAction.Filter Property

AreaSelectActionFilter Property

Gets or sets a filter function that can be used to manipulate collection of items before they are selected.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Action<List<IVisualObject>> Filter { get; set; }
public:
static property Action<List<IVisualObject^>^>^ Filter {
    Action<List<IVisualObject^>^>^ get ();
    void set (Action<List<IVisualObject^>^>^ value);
}

Property Value

Type: ActionListIVisualObject
See Also

Reference

AreaSelectAction Class
VisualComponents.UX.Shared Namespace


AreaSelectAction.ManipulationArgs Property

AreaSelectActionManipulationArgs Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ManipulationEventArgs ManipulationArgs { get; set; }
public:
property ManipulationEventArgs^ ManipulationArgs {
    ManipulationEventArgs^ get ();
    void set (ManipulationEventArgs^ value);
}

Property Value

Type: ManipulationEventArgs
See Also

Reference

AreaSelectAction Class
VisualComponents.UX.Shared Namespace


AreaSelectAction.SelectionMode Property

AreaSelectActionSelectionMode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObjectSelectionMode SelectionMode { get; set; }
public:
property ObjectSelectionMode SelectionMode {
    ObjectSelectionMode get ();
    void set (ObjectSelectionMode value);
}

Property Value

Type: ObjectSelectionMode
See Also

Reference

AreaSelectAction Class
VisualComponents.UX.Shared Namespace


AreaSelectAction Methods

The AreaSelectAction type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType) | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from FixedPropertyContainer.)
Public method | DeleteProperty | (Inherited from FixedPropertyContainer.)
Public method | EndChangeBatch | (Inherited from FixedPropertyContainer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperty | (Inherited from FixedPropertyContainer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotifyChanged | (Inherited from FixedPropertyContainer.)
Public method | NotifyPropertyChanged | (Inherited from FixedPropertyContainer.)
 | Select |
Public method | SetPropertyValues(IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AreaSelectAction Class
VisualComponents.UX.Shared Namespace


AreaSelectAction.Execute Method

AreaSelectActionExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    ActionExecutionContext context
)
public:
virtual void Execute(
    ActionExecutionContext^ context
) sealed

Parameters

context
Type: ActionExecutionContext

Implements

IResult.Execute(ActionExecutionContext)
See Also

Reference

AreaSelectAction Class
VisualComponents.UX.Shared Namespace


AreaSelectAction.Select Method

AreaSelectActionSelect Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IEnumerable<IResult> Select(
    ManipulationEventArgs args,
    ObjectSelectionMode selectionMode,
    bool append
)
public:
static IEnumerable<IResult^>^ Select(
    ManipulationEventArgs^ args,
    ObjectSelectionMode selectionMode,
    bool append
)

Parameters

args
Type: VisualComponents.UX.InputManipulationEventArgs
selectionMode
Type: VisualComponents.Create3DObjectSelectionMode
append
Type: SystemBoolean

Return Value

Type: IEnumerableIResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.AreaSelectAction.Select(VisualComponents.UX.Input.ManipulationEventArgs,VisualComponents.Create3D.ObjectSelectionMode,System.Boolean)"]

See Also

Reference

AreaSelectAction Class
VisualComponents.UX.Shared Namespace


AreaSelectAction Events

The AreaSelectAction type exposes the following members.

Events
 | Name | Description
Public event | Completed |
Public event | PropertyChanged | (Inherited from FixedPropertyContainer.)
Public event | PropertyContainerChanged | (Inherited from FixedPropertyContainer.)
Top
See Also

Reference

AreaSelectAction Class
VisualComponents.UX.Shared Namespace


AreaSelectAction.Completed Event

AreaSelectActionCompleted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ResultCompletionEventArgs> Completed
public:
virtual  event EventHandler<ResultCompletionEventArgs^>^ Completed {
    void add (EventHandler<ResultCompletionEventArgs^>^ value);
    void remove (EventHandler<ResultCompletionEventArgs^>^ value);
}

Value

Type: SystemEventHandlerResultCompletionEventArgs

Implements

IResult.Completed
See Also

Reference

AreaSelectAction Class
VisualComponents.UX.Shared Namespace


AreaSelectionActionMode Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum AreaSelectionActionMode
public enum class AreaSelectionActionMode
Members
Member name | Value | Description
Select | 0 |
Pick | 1 |
See Also

Reference

VisualComponents.UX.Shared Namespace


AreaSelectionCompletedMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedAreaSelectionCompletedMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class AreaSelectionCompletedMessage
public ref class AreaSelectionCompletedMessage sealed

The AreaSelectionCompletedMessage type exposes the following members.

Constructors
 | Name | Description
Public method | AreaSelectionCompletedMessage | Initializes a new instance of the AreaSelectionCompletedMessage class
Top
Properties
 | Name | Description
Public property | PointList |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


AreaSelectionCompletedMessage Constructor

Initializes a new instance of the AreaSelectionCompletedMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AreaSelectionCompletedMessage()
public:
AreaSelectionCompletedMessage()
See Also

Reference

AreaSelectionCompletedMessage Class
VisualComponents.UX.Shared Namespace


AreaSelectionCompletedMessage Properties

The AreaSelectionCompletedMessage type exposes the following members.

Properties
 | Name | Description
Public property | PointList |
Top
See Also

Reference

AreaSelectionCompletedMessage Class
VisualComponents.UX.Shared Namespace


AreaSelectionCompletedMessage.PointList Property

AreaSelectionCompletedMessagePointList Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<Point> PointList { get; set; }
public:
property List<Point>^ PointList {
    List<Point>^ get ();
    void set (List<Point>^ value);
}

Property Value

Type: ListPoint
See Also

Reference

AreaSelectionCompletedMessage Class
VisualComponents.UX.Shared Namespace


AreaSelectionCompletedMessage Methods

The AreaSelectionCompletedMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AreaSelectionCompletedMessage Class
VisualComponents.UX.Shared Namespace


AutoPlugPlayAction Class

Automatic plug and play action
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedAutoPlugPlayAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class AutoPlugPlayAction : IResult
public ref class AutoPlugPlayAction sealed : IResult

The AutoPlugPlayAction type exposes the following members.

Constructors
 | Name | Description
Public method | AutoPlugPlayAction | Default constructor
Top
Properties
 | Name | Description
Public property | ConnectTo | Gets or sets the component to which 'ToConnect' component will be connected
 | IsEnabled | Defines if the command is enabled
Public property | ToConnect | Gets or sets the component which will be connected to 'ConnectTo' component
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Completed |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


AutoPlugPlayAction Constructor

Default constructor

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AutoPlugPlayAction()
public:
AutoPlugPlayAction()
See Also

Reference

AutoPlugPlayAction Class
VisualComponents.UX.Shared Namespace


AutoPlugPlayAction Properties

The AutoPlugPlayAction type exposes the following members.

Properties
 | Name | Description
Public property | ConnectTo | Gets or sets the component to which 'ToConnect' component will be connected
 | IsEnabled | Defines if the command is enabled
Public property | ToConnect | Gets or sets the component which will be connected to 'ConnectTo' component
Top
See Also

Reference

AutoPlugPlayAction Class
VisualComponents.UX.Shared Namespace


AutoPlugPlayAction.ConnectTo Property

AutoPlugPlayActionConnectTo Property

Gets or sets the component to which 'ToConnect' component will be connected

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimComponent ConnectTo { get; set; }
public:
property ISimComponent^ ConnectTo {
    ISimComponent^ get ();
    void set (ISimComponent^ value);
}

Property Value

Type: ISimComponent
See Also

Reference

AutoPlugPlayAction Class
VisualComponents.UX.Shared Namespace


AutoPlugPlayAction.IsEnabled Property

AutoPlugPlayActionIsEnabled Property

Defines if the command is enabled

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsEnabled { get; set; }
public:
static property bool IsEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AutoPlugPlayAction Class
VisualComponents.UX.Shared Namespace


AutoPlugPlayAction.ToConnect Property

AutoPlugPlayActionToConnect Property

Gets or sets the component which will be connected to 'ConnectTo' component

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimComponent ToConnect { get; set; }
public:
property ISimComponent^ ToConnect {
    ISimComponent^ get ();
    void set (ISimComponent^ value);
}

Property Value

Type: ISimComponent
See Also

Reference

AutoPlugPlayAction Class
VisualComponents.UX.Shared Namespace


AutoPlugPlayAction Methods

The AutoPlugPlayAction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AutoPlugPlayAction Class
VisualComponents.UX.Shared Namespace


AutoPlugPlayAction.Execute Method

AutoPlugPlayActionExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    ActionExecutionContext context
)
public:
virtual void Execute(
    ActionExecutionContext^ context
) sealed

Parameters

context
Type: ActionExecutionContext

Implements

IResult.Execute(ActionExecutionContext)
See Also

Reference

AutoPlugPlayAction Class
VisualComponents.UX.Shared Namespace


AutoPlugPlayAction Events

The AutoPlugPlayAction type exposes the following members.

Events
 | Name | Description
Public event | Completed |
Top
See Also

Reference

AutoPlugPlayAction Class
VisualComponents.UX.Shared Namespace


AutoPlugPlayAction.Completed Event

AutoPlugPlayActionCompleted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ResultCompletionEventArgs> Completed
public:
virtual  event EventHandler<ResultCompletionEventArgs^>^ Completed {
    void add (EventHandler<ResultCompletionEventArgs^>^ value);
    void remove (EventHandler<ResultCompletionEventArgs^>^ value);
}

Value

Type: SystemEventHandlerResultCompletionEventArgs

Implements

IResult.Completed
See Also

Reference

AutoPlugPlayAction Class
VisualComponents.UX.Shared Namespace


AutoScrollBehavior Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.WindowsFreezable
System.Windows.Media.AnimationAnimatable
Behavior
BehaviorScrollViewer
VisualComponents.UX.SharedAutoScrollBehavior

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class AutoScrollBehavior : Behavior<ScrollViewer>
public ref class AutoScrollBehavior : public Behavior<ScrollViewer^>

The AutoScrollBehavior type exposes the following members.

Constructors
 | Name | Description
Public method | AutoScrollBehavior | Initializes a new instance of the AutoScrollBehavior class
Top
Properties
 | Name | Description
Protected property | AssociatedObject | (Inherited from BehaviorScrollViewer.)
Protected property | AssociatedType | (Inherited from Behavior.)
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Inherited from Animatable.)
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Top
Methods
 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | Attach | (Inherited from Behavior.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of this Animatable, making deep copies of this object's values. When copying this object's dependency properties, this method copies resource references and data bindings (but they might no longer resolve) but not animations or their current values. (Inherited from Animatable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | (Inherited from Behavior.)
Public method | Detach | (Inherited from Behavior.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to . (Inherited from Freezable.)
Protected method | FreezeCore | Makes this Animatable object unmodifiable or determines whether it can be made unmodifiable. (Inherited from Animatable.)
Public method | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Inherited from Animatable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttached | (Overrides Behavior.OnAttached.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnDetaching | (Overrides Behavior.OnDetaching.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
Events
 | Name | Description
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


AutoScrollBehavior Constructor

Initializes a new instance of the AutoScrollBehavior class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AutoScrollBehavior()
public:
AutoScrollBehavior()
See Also

Reference

AutoScrollBehavior Class
VisualComponents.UX.Shared Namespace


AutoScrollBehavior Properties

The AutoScrollBehavior type exposes the following members.

Properties
 | Name | Description
Protected property | AssociatedObject | (Inherited from BehaviorScrollViewer.)
Protected property | AssociatedType | (Inherited from Behavior.)
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Inherited from Animatable.)
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Top
See Also

Reference

AutoScrollBehavior Class
VisualComponents.UX.Shared Namespace


AutoScrollBehavior Methods

The AutoScrollBehavior type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | Attach | (Inherited from Behavior.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of this Animatable, making deep copies of this object's values. When copying this object's dependency properties, this method copies resource references and data bindings (but they might no longer resolve) but not animations or their current values. (Inherited from Animatable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | (Inherited from Behavior.)
Public method | Detach | (Inherited from Behavior.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to . (Inherited from Freezable.)
Protected method | FreezeCore | Makes this Animatable object unmodifiable or determines whether it can be made unmodifiable. (Inherited from Animatable.)
Public method | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Inherited from Animatable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttached | (Overrides Behavior.OnAttached.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnDetaching | (Overrides Behavior.OnDetaching.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

AutoScrollBehavior Class
VisualComponents.UX.Shared Namespace


AutoScrollBehavior.OnAttached Method

AutoScrollBehaviorOnAttached Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnAttached()
protected:
virtual void OnAttached() override
See Also

Reference

AutoScrollBehavior Class
VisualComponents.UX.Shared Namespace


AutoScrollBehavior.OnDetaching Method

AutoScrollBehaviorOnDetaching Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnDetaching()
protected:
virtual void OnDetaching() override
See Also

Reference

AutoScrollBehavior Class
VisualComponents.UX.Shared Namespace


AutoScrollBehavior Events

The AutoScrollBehavior type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Top
See Also

Reference

AutoScrollBehavior Class
VisualComponents.UX.Shared Namespace


AxisType Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum AxisType
public enum class AxisType
Members
Member name | Value | Description
UNKNOWN | -1 |
PLUS_Z | 0 |
MINUS_Z | 1 |
PLUS_Y | 2 |
MINUS_Y | 3 |
PLUS_X | 4 |
MINUS_X | 5 |
See Also

Reference

VisualComponents.UX.Shared Namespace


BackstageHeaderType Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum BackstageHeaderType
public enum class BackstageHeaderType
Members
Member name | Value | Description
Button | 0 |
Tab | 1 |
See Also

Reference

VisualComponents.UX.Shared Namespace


BalloomAnnotationCreatedMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedBalloomAnnotationCreatedMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class BalloomAnnotationCreatedMessage
public ref class BalloomAnnotationCreatedMessage

The BalloomAnnotationCreatedMessage type exposes the following members.

Constructors
 | Name | Description
Public method | BalloomAnnotationCreatedMessage | Initializes a new instance of the BalloomAnnotationCreatedMessage class
Top
Properties
 | Name | Description
Public property | Annotation |
Public property | ComponentName |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


BalloomAnnotationCreatedMessage Constructor

Initializes a new instance of the BalloomAnnotationCreatedMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BalloomAnnotationCreatedMessage(
    IAnnotation a,
    string name
)
public:
BalloomAnnotationCreatedMessage(
    IAnnotation^ a,
    String^ name
)

Parameters

a
Type: VisualComponents.Create3DIAnnotation
name
Type: SystemString
See Also

Reference

BalloomAnnotationCreatedMessage Class
VisualComponents.UX.Shared Namespace


BalloomAnnotationCreatedMessage Properties

The BalloomAnnotationCreatedMessage type exposes the following members.

Properties
 | Name | Description
Public property | Annotation |
Public property | ComponentName |
Top
See Also

Reference

BalloomAnnotationCreatedMessage Class
VisualComponents.UX.Shared Namespace


BalloomAnnotationCreatedMessage.Annotation Property

BalloomAnnotationCreatedMessageAnnotation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IAnnotation Annotation { get; set; }
public:
property IAnnotation^ Annotation {
    IAnnotation^ get ();
    void set (IAnnotation^ value);
}

Property Value

Type: IAnnotation
See Also

Reference

BalloomAnnotationCreatedMessage Class
VisualComponents.UX.Shared Namespace


BalloomAnnotationCreatedMessage.ComponentName Property

BalloomAnnotationCreatedMessageComponentName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ComponentName { get; set; }
public:
property String^ ComponentName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

BalloomAnnotationCreatedMessage Class
VisualComponents.UX.Shared Namespace


BalloomAnnotationCreatedMessage Methods

The BalloomAnnotationCreatedMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BalloomAnnotationCreatedMessage Class
VisualComponents.UX.Shared Namespace


BaseActionItem Class

Base Action Item
Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.SharedBaseActionItem
More...

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract class BaseActionItem : PropertyChangedBase,
    IActionItem, INotifyPropertyChangedEx, INotifyPropertyChanged, IToolTip, IPartImportsSatisfiedNotification
public ref class BaseActionItem abstract : public PropertyChangedBase,
    IActionItem, INotifyPropertyChangedEx, INotifyPropertyChanged, IToolTip, IPartImportsSatisfiedNotification

The BaseActionItem type exposes the following members.

Constructors
 | Name | Description
Public method | BaseActionItem | Initializes a new instance of the BaseActionItem class
Public method | BaseActionItem(String, String, String, String, Boolean, Boolean) | Initializes a new instance of ActionItem class.
Top
Properties
 | Name | Description
Public property | ActiveAction | Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this).
Protected property | Application |
Public property | AttachTo |
Public property | ButtonMaxWidth |
Public property | ButtonMinWidth |
Public property | ButtonWidth |
Public property | CanExecute |
Protected property | canExecuteAction | Similar to canExecute. This is provided for Visual Basic compatibility.
Public property | CollapseWhenDeactivated |
Public property | CommandRegistry | This references is assigned by CommandRegistry on startup.
Public property | Content |
Public property | Context |
Public property | ContextFilter |
Public property | ControlType |
Public property | Customization |
Protected property | EventMng | Event aggregator
Public property | Icon |
Public property | IconName |
Public property | Id |
Public property | ImageSource |
Public property | IsActivated |
Public property | IsBackgroundVisible |
Public property | IsColoredIcon |
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsQatCommonTool |
Public property | IsToolNotInRibbon |
Public property | Localization |
Public property | RibbonId |
Public property | SiteOrder |
Protected property | SkipAbortWhenExecuted | If true, action will not abort currently executing action.
Public property | Tag |
Public property | ToolSize |
Public property | ToolTipBookmark |
Public property | ToolTipContent |
Public property | ToolTipContentImage |
Public property | ToolTipFooter |
Public property | ToolTipFooterSeparatorVisibility |
Public property | ToolTipFooterVisibility |
Public property | ToolTipHeader |
Public property | ToolTipHeaderSeparatorVisibility |
Public property | ToolTipMoreInfoUrl |
Public property | ToolTipVisibility |
Public property | UxConfig |
Public property | Visibility |
Top
Methods
 | Name | Description
Public method | AfterExecute |
Public method | BeforeExecute |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute | Updates the value of CanExecute
Public method | Execute | Implement command execution logic here. Base class implementation should always be called.
Public method | Execute(PropertyCollection) |
Public method | Execute(SetupPythonActionMessage) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableForObject |
Public method | IsAvailableInCurrentContextAndSite |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | OnImportsSatisfied | Overriding class should call baseclass implementation.
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SetupBaseActionItem |
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Protected method | StartAction | Shortcut for calling CommandRegistry.StartCommandPanelAction(this).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
Fields
 | Name | Description
Protected field | _getIconPathFromFile |
Protected field | _isColoredIcon |
Protected field | canExecute | Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called.
Protected field | RequestedFeatures | Contains license features requested by the action item. This collection should be populated by the implementing class.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace
Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.SharedBaseActionItem
VisualComponents.UX.SharedActionItem
VisualComponents.UX.SharedActionItemT1
VisualComponents.UX.SharedActionItemT1, T2
VisualComponents.UX.SharedActionItemT1, T2, T3
VisualComponents.UX.SharedActionItemT1, T2, T3, T4
VisualComponents.UX.SharedActionItemT1, T2, T3, T4, T5
VisualComponents.UX.SharedActionItemT1, T2, T3, T4, T5, T6
VisualComponents.UX.SharedActionItemT1, T2, T3, T4, T5, T6, T7


BaseActionItem Constructor

Overload List
 | Name | Description
Public method | BaseActionItem | Initializes a new instance of the BaseActionItem class
Public method | BaseActionItem(String, String, String, String, Boolean, Boolean) | Initializes a new instance of ActionItem class.
Top
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem Constructor

Initializes a new instance of the BaseActionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BaseActionItem()
public:
BaseActionItem()
See Also

Reference

BaseActionItem Class
BaseActionItem Overload
VisualComponents.UX.Shared Namespace


BaseActionItem Constructor (String, String, String, String, Boolean, Boolean)

Initializes a new instance of ActionItem class.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BaseActionItem(
    string id,
    string translatedTextId,
    string iconPath,
    string controlType = "Button",
    bool getIconPathFromFile = true,
    bool isColoredIcon = true
)
public:
BaseActionItem(
    String^ id,
    String^ translatedTextId,
    String^ iconPath,
    String^ controlType = L"Button",
    bool getIconPathFromFile = true,
    bool isColoredIcon = true
)

Parameters

id
Type: SystemString
translatedTextId
Type: SystemString
If null it will use id value to set content. If empty string then content is empty and will not be visible in UI.
iconPath
Type: SystemString
controlType (Optional)
Type: SystemString
getIconPathFromFile (Optional)
Type: SystemBoolean
indicator of using default icon path
isColoredIcon (Optional)
Type: SystemBoolean
See Also

Reference

BaseActionItem Class
BaseActionItem Overload
VisualComponents.UX.Shared Namespace


BaseActionItem Properties

The BaseActionItem type exposes the following members.

Properties
 | Name | Description
Public property | ActiveAction | Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this).
Protected property | Application |
Public property | AttachTo |
Public property | ButtonMaxWidth |
Public property | ButtonMinWidth |
Public property | ButtonWidth |
Public property | CanExecute |
Protected property | canExecuteAction | Similar to canExecute. This is provided for Visual Basic compatibility.
Public property | CollapseWhenDeactivated |
Public property | CommandRegistry | This references is assigned by CommandRegistry on startup.
Public property | Content |
Public property | Context |
Public property | ContextFilter |
Public property | ControlType |
Public property | Customization |
Protected property | EventMng | Event aggregator
Public property | Icon |
Public property | IconName |
Public property | Id |
Public property | ImageSource |
Public property | IsActivated |
Public property | IsBackgroundVisible |
Public property | IsColoredIcon |
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsQatCommonTool |
Public property | IsToolNotInRibbon |
Public property | Localization |
Public property | RibbonId |
Public property | SiteOrder |
Protected property | SkipAbortWhenExecuted | If true, action will not abort currently executing action.
Public property | Tag |
Public property | ToolSize |
Public property | ToolTipBookmark |
Public property | ToolTipContent |
Public property | ToolTipContentImage |
Public property | ToolTipFooter |
Public property | ToolTipFooterSeparatorVisibility |
Public property | ToolTipFooterVisibility |
Public property | ToolTipHeader |
Public property | ToolTipHeaderSeparatorVisibility |
Public property | ToolTipMoreInfoUrl |
Public property | ToolTipVisibility |
Public property | UxConfig |
Public property | Visibility |
Top
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.ActiveAction Property

BaseActionItemActiveAction Property

Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this).

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ICommandPanelAction ActiveAction { get; }
public:
property ICommandPanelAction^ ActiveAction {
    ICommandPanelAction^ get ();
}

Property Value

Type: ICommandPanelAction
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.Application Property

BaseActionItemApplication Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected IApplication Application { get; }
protected:
property IApplication^ Application {
    IApplication^ get ();
}

Property Value

Type: IApplication
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.AttachTo Property

BaseActionItemAttachTo Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AttachTo { get; set; }
public:
property String^ AttachTo {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.ButtonMaxWidth Property

BaseActionItemButtonMaxWidth Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ButtonMaxWidth { get; set; }
public:
property int ButtonMaxWidth {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.ButtonMinWidth Property

BaseActionItemButtonMinWidth Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ButtonMinWidth { get; set; }
public:
property int ButtonMinWidth {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.ButtonWidth Property

BaseActionItemButtonWidth Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double ButtonWidth { get; set; }
public:
property double ButtonWidth {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.CanExecute Property

BaseActionItemCanExecute Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanExecute { get; }
public:
virtual property bool CanExecute {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IActionItemCanExecute
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.canExecuteAction Property

BaseActionItemcanExecuteAction Property

Similar to canExecute. This is provided for Visual Basic compatibility.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected Func<bool> canExecuteAction { get; set; }
protected:
property Func<bool>^ canExecuteAction {
    Func<bool>^ get ();
    void set (Func<bool>^ value);
}

Property Value

Type: FuncBoolean
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.CollapseWhenDeactivated Property

BaseActionItemCollapseWhenDeactivated Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CollapseWhenDeactivated { get; set; }
public:
property bool CollapseWhenDeactivated {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.CommandRegistry Property

BaseActionItemCommandRegistry Property

This references is assigned by CommandRegistry on startup.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ICommandRegistry CommandRegistry { get; set; }
public:
property ICommandRegistry^ CommandRegistry {
    ICommandRegistry^ get ();
    void set (ICommandRegistry^ value);
}

Property Value

Type: ICommandRegistry
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.Content Property

BaseActionItemContent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Content { get; set; }
public:
virtual property String^ Content {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IActionItemContent
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.Context Property

BaseActionItemContext Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IApplicationContext Context { get; set; }
public:
property IApplicationContext^ Context {
    IApplicationContext^ get ();
    void set (IApplicationContext^ value);
}

Property Value

Type: IApplicationContext
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.ContextFilter Property

BaseActionItemContextFilter Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ContextFilter { get; set; }
public:
virtual property String^ ContextFilter {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IActionItemContextFilter
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.ControlType Property

BaseActionItemControlType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ControlType { get; set; }
public:
virtual property String^ ControlType {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IActionItemControlType
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.Customization Property

BaseActionItemCustomization Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ICustomizationService Customization { get; }
public:
property ICustomizationService^ Customization {
    ICustomizationService^ get ();
}

Property Value

Type: ICustomizationService
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.EventMng Property

BaseActionItemEventMng Property

Event aggregator

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected IEventAggregator EventMng { get; }
protected:
property IEventAggregator^ EventMng {
    IEventAggregator^ get ();
}

Property Value

Type: IEventAggregator
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.Icon Property

BaseActionItemIcon Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Icon { get; }
public:
property String^ Icon {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.IconName Property

BaseActionItemIconName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string IconName { get; set; }
public:
virtual property String^ IconName {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IActionItemIconName
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.Id Property

BaseActionItemId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Id { get; set; }
public:
virtual property String^ Id {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IActionItemId
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.ImageSource Property

BaseActionItemImageSource Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ImageSource { get; set; }
public:
virtual property String^ ImageSource {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IToolTipImageSource
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.IsActivated Property

BaseActionItemIsActivated Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsActivated { get; }
public:
property bool IsActivated {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.IsBackgroundVisible Property

BaseActionItemIsBackgroundVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsBackgroundVisible { get; }
public:
property bool IsBackgroundVisible {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.IsColoredIcon Property

BaseActionItemIsColoredIcon Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsColoredIcon { get; }
public:
property bool IsColoredIcon {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.IsQatCommonTool Property

BaseActionItemIsQatCommonTool Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsQatCommonTool { get; set; }
public:
property bool IsQatCommonTool {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.IsToolNotInRibbon Property

BaseActionItemIsToolNotInRibbon Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsToolNotInRibbon { get; set; }
public:
property bool IsToolNotInRibbon {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.Localization Property

BaseActionItemLocalization Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ILocalizationService Localization { get; }
public:
property ILocalizationService^ Localization {
    ILocalizationService^ get ();
}

Property Value

Type: ILocalizationService
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.RibbonId Property

BaseActionItemRibbonId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string RibbonId { get; set; }
public:
virtual property String^ RibbonId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IActionItemRibbonId
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.SiteOrder Property

BaseActionItemSiteOrder Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double SiteOrder { get; set; }
public:
virtual property double SiteOrder {
    double get () sealed;
    void set (double value) sealed;
}

Property Value

Type: Double

Implements

IActionItemSiteOrder
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.SkipAbortWhenExecuted Property

BaseActionItemSkipAbortWhenExecuted Property

If true, action will not abort currently executing action.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected bool SkipAbortWhenExecuted { get; set; }
protected:
property bool SkipAbortWhenExecuted {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.Tag Property

BaseActionItemTag Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual Object Tag { get; set; }
public:
virtual property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object

Implements

IActionItemTag
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.ToolSize Property

BaseActionItemToolSize Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ToolSizingMode ToolSize { get; set; }
public:
virtual property ToolSizingMode ToolSize {
    ToolSizingMode get () sealed;
    void set (ToolSizingMode value) sealed;
}

Property Value

Type: ToolSizingMode
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.ToolTipBookmark Property

BaseActionItemToolTipBookmark Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ToolTipBookmark { get; set; }
public:
virtual property String^ ToolTipBookmark {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IToolTipToolTipBookmark
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.ToolTipContent Property

BaseActionItemToolTipContent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ToolTipContent { get; set; }
public:
virtual property String^ ToolTipContent {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IToolTipToolTipContent
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.ToolTipContentImage Property

BaseActionItemToolTipContentImage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ToolTipContentImage { get; set; }
public:
virtual property String^ ToolTipContentImage {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IToolTipToolTipContentImage
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.ToolTipFooter Property

BaseActionItemToolTipFooter Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ToolTipFooter { get; set; }
public:
virtual property String^ ToolTipFooter {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IToolTipToolTipFooter
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.ToolTipFooterSeparatorVisibility Property

BaseActionItemToolTipFooterSeparatorVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Visibility ToolTipFooterSeparatorVisibility { get; set; }
public:
virtual property Visibility ToolTipFooterSeparatorVisibility {
    Visibility get () sealed;
    void set (Visibility value) sealed;
}

Property Value

Type: Visibility

Implements

IToolTipToolTipFooterSeparatorVisibility
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.ToolTipFooterVisibility Property

BaseActionItemToolTipFooterVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Visibility ToolTipFooterVisibility { get; set; }
public:
virtual property Visibility ToolTipFooterVisibility {
    Visibility get () sealed;
    void set (Visibility value) sealed;
}

Property Value

Type: Visibility

Implements

IToolTipToolTipFooterVisibility
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.ToolTipHeader Property

BaseActionItemToolTipHeader Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ToolTipHeader { get; set; }
public:
virtual property String^ ToolTipHeader {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IToolTipToolTipHeader
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.ToolTipHeaderSeparatorVisibility Property

BaseActionItemToolTipHeaderSeparatorVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Visibility ToolTipHeaderSeparatorVisibility { get; set; }
public:
virtual property Visibility ToolTipHeaderSeparatorVisibility {
    Visibility get () sealed;
    void set (Visibility value) sealed;
}

Property Value

Type: Visibility

Implements

IToolTipToolTipHeaderSeparatorVisibility
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.ToolTipMoreInfoUrl Property

BaseActionItemToolTipMoreInfoUrl Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ToolTipMoreInfoUrl { get; set; }
public:
virtual property String^ ToolTipMoreInfoUrl {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IToolTipToolTipMoreInfoUrl
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.ToolTipVisibility Property

BaseActionItemToolTipVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Visibility ToolTipVisibility { get; set; }
public:
virtual property Visibility ToolTipVisibility {
    Visibility get () sealed;
    void set (Visibility value) sealed;
}

Property Value

Type: Visibility

Implements

IToolTipToolTipVisibility
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.UxConfig Property

BaseActionItemUxConfig Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IUXConfiguration UxConfig { get; set; }
public:
property IUXConfiguration^ UxConfig {
    IUXConfiguration^ get ();
    void set (IUXConfiguration^ value);
}

Property Value

Type: IUXConfiguration
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.Visibility Property

BaseActionItemVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Visibility Visibility { get; set; }
public:
virtual property Visibility Visibility {
    Visibility get () sealed;
    void set (Visibility value) sealed;
}

Property Value

Type: Visibility

Implements

IActionItemVisibility
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem Methods

The BaseActionItem type exposes the following members.

Methods
 | Name | Description
Public method | AfterExecute |
Public method | BeforeExecute |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute | Updates the value of CanExecute
Public method | Execute | Implement command execution logic here. Base class implementation should always be called.
Public method | Execute(PropertyCollection) |
Public method | Execute(SetupPythonActionMessage) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableForObject |
Public method | IsAvailableInCurrentContextAndSite |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | OnImportsSatisfied | Overriding class should call baseclass implementation.
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SetupBaseActionItem |
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Protected method | StartAction | Shortcut for calling CommandRegistry.StartCommandPanelAction(this).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.AfterExecute Method

BaseActionItemAfterExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void AfterExecute()
public:
void AfterExecute()
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.BeforeExecute Method

BaseActionItemBeforeExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void BeforeExecute()
public:
virtual void BeforeExecute()
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.EvaluateCanExecute Method

BaseActionItemEvaluateCanExecute Method

Updates the value of CanExecute

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void EvaluateCanExecute()
public:
virtual void EvaluateCanExecute() sealed

Implements

IActionItemEvaluateCanExecute
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.Execute Method

BaseActionItemExecute Method

Overload List
 | Name | Description
Public method | Execute | Implement command execution logic here. Base class implementation should always be called.
Public method | Execute(PropertyCollection) |
Public method | Execute(SetupPythonActionMessage) |
Top
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.Execute Method

BaseActionItemExecute Method

Implement command execution logic here. Base class implementation should always be called.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract void Execute()
public:
virtual void Execute() abstract

Implements

IActionItemExecute
See Also

Reference

BaseActionItem Class
Execute Overload
VisualComponents.UX.Shared Namespace


BaseActionItem.Execute Method (PropertyCollection)

BaseActionItemExecute Method (PropertyCollection)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void Execute(
    PropertyCollection args
)
public:
virtual void Execute(
    PropertyCollection^ args
)

Parameters

args
Type: VisualComponents.Create3DPropertyCollection

Implements

IActionItemExecute(PropertyCollection)
See Also

Reference

BaseActionItem Class
Execute Overload
VisualComponents.UX.Shared Namespace


BaseActionItem.Execute Method (SetupPythonActionMessage)

BaseActionItemExecute Method (SetupPythonActionMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void Execute(
    SetupPythonActionMessage message
)
public:
virtual void Execute(
    SetupPythonActionMessage^ message
)

Parameters

message
Type: VisualComponents.Create3DSetupPythonActionMessage

Implements

IActionItemExecute(SetupPythonActionMessage)
See Also

Reference

BaseActionItem Class
Execute Overload
VisualComponents.UX.Shared Namespace


BaseActionItem.IsAvailableForObject Method

BaseActionItemIsAvailableForObject Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual bool IsAvailableForObject(
    Object item
)
public:
virtual bool IsAvailableForObject(
    Object^ item
)

Parameters

item
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.BaseActionItem.IsAvailableForObject(System.Object)"]

See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.IsAvailableInCurrentContextAndSite Method

BaseActionItemIsAvailableInCurrentContextAndSite Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual bool IsAvailableInCurrentContextAndSite(
    string uxsiteId
)
public:
virtual bool IsAvailableInCurrentContextAndSite(
    String^ uxsiteId
)

Parameters

uxsiteId
Type: SystemString

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.BaseActionItem.IsAvailableInCurrentContextAndSite(System.String)"]

Implements

IActionItemIsAvailableInCurrentContextAndSite(String)
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.NotifyAnotherActionItem Method

BaseActionItemNotifyAnotherActionItem Method

Another action item will be evaluated by calling EvaluateCanExecute

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void NotifyAnotherActionItem(
    string actionName
)
public:
virtual void NotifyAnotherActionItem(
    String^ actionName
) sealed

Parameters

actionName
Type: SystemString
action item name which will be notified

Implements

IActionItemNotifyAnotherActionItem(String)
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.OnImportsSatisfied Method

BaseActionItemOnImportsSatisfied Method

Overriding class should call baseclass implementation.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void OnImportsSatisfied()
public:
virtual void OnImportsSatisfied()

Implements

IPartImportsSatisfiedNotificationOnImportsSatisfied
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.SetupBaseActionItem Method

BaseActionItemSetupBaseActionItem Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetupBaseActionItem(
    string translatedTextId,
    string iconPath,
    string controlType = "Button",
    bool getIconPathFromFile = true,
    bool isColoredIcon = true
)
public:
void SetupBaseActionItem(
    String^ translatedTextId,
    String^ iconPath,
    String^ controlType = L"Button",
    bool getIconPathFromFile = true,
    bool isColoredIcon = true
)

Parameters

translatedTextId
Type: SystemString
iconPath
Type: SystemString
controlType (Optional)
Type: SystemString
getIconPathFromFile (Optional)
Type: SystemBoolean
isColoredIcon (Optional)
Type: SystemBoolean
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.StartAction Method

BaseActionItemStartAction Method

Shortcut for calling CommandRegistry.StartCommandPanelAction(this).

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected void StartAction(
    ICommandPanelAction action,
    EventHandler<ResultCompletionEventArgs> completed
)
protected:
void StartAction(
    ICommandPanelAction^ action,
    EventHandler<ResultCompletionEventArgs^>^ completed
)

Parameters

action
Type: VisualComponents.UX.SharedICommandPanelAction
completed
Type: SystemEventHandlerResultCompletionEventArgs
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem Events

The BaseActionItem type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem Fields

The BaseActionItem type exposes the following members.

Fields
 | Name | Description
Protected field | _getIconPathFromFile |
Protected field | _isColoredIcon |
Protected field | canExecute | Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called.
Protected field | RequestedFeatures | Contains license features requested by the action item. This collection should be populated by the implementing class.
Top
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem._getIconPathFromFile Field

BaseActionItem_getIconPathFromFile Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected bool _getIconPathFromFile
protected:
bool _getIconPathFromFile

Field Value

Type: Boolean
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem._isColoredIcon Field

BaseActionItem_isColoredIcon Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected bool _isColoredIcon
protected:
bool _isColoredIcon

Field Value

Type: Boolean
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.canExecute Field

BaseActionItemcanExecute Field

Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected Func<bool> canExecute
protected:
Func<bool>^ canExecute

Field Value

Type: FuncBoolean
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseActionItem.RequestedFeatures Field

BaseActionItemRequestedFeatures Field

Contains license features requested by the action item. This collection should be populated by the implementing class.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected readonly IList<ProductFeature> RequestedFeatures
protected:
initonly IList<ProductFeature>^ RequestedFeatures

Field Value

Type: IListProductFeature
See Also

Reference

BaseActionItem Class
VisualComponents.UX.Shared Namespace


BaseConfigCollection(T) Class

BaseConfigCollectionT Class

Generic base class for config collections.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationElementCollection
VisualComponents.UX.SharedBaseConfigCollectionT
More...

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract class BaseConfigCollection<T> : ConfigurationElementCollection
where T : new(), ConfigurationElement

generic<typename T>
where T : gcnew(), ConfigurationElement
public ref class BaseConfigCollection abstract : public ConfigurationElementCollection

Type Parameters

T
type inheriting from ConfigurationElement

The BaseConfigCollectionT type exposes the following members.

Constructors
 | Name | Description
Protected method | BaseConfigCollectionT | Initializes a new instance of the BaseConfigCollectionT class
Top
Properties
 | Name | Description
Protected property | AddElementName | Gets or sets the name of the ConfigurationElement to associate with the add operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected property | ClearElementName | Gets or sets the name for the ConfigurationElement to associate with the clear operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementName | Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is . (Inherited from ConfigurationElement.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | ItemInt32 |
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Protected property | RemoveElementName | Gets or sets the name of the ConfigurationElement to associate with the remove operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected property | ThrowOnDuplicate | Gets a value indicating whether an attempt to add a duplicate ConfigurationElement to the ConfigurationElementCollection will cause an exception to be thrown. (Inherited from ConfigurationElementCollection.)
Top
Methods
 | Name | Description
Public method | Add | Add item to the collection
Protected method | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseClear | Removes all configuration element objects from the collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGet(Object) | Returns the configuration element with the specified key. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGet(Int32) | Gets the configuration element at the specified index location. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGetAllKeys | Returns an array of the keys for all of the configuration elements contained in the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGetKey | Gets the key for the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
Protected method | BaseIndexOf | Indicates the index of the specified ConfigurationElement. (Inherited from ConfigurationElementCollection.)
Protected method | BaseIsRemoved | Indicates whether the ConfigurationElement with the specified key has been removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseRemove | Removes a ConfigurationElement from the collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseRemoveAt | Removes the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
Public method | Clear | clear the collection
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Protected method | CreateNewElement | create new element (Overrides ConfigurationElementCollectionCreateNewElement.)
Protected method | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetElementKey | Gets the element key for a specified configuration element when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | get the collection index of the element
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public method | Insert | Inserts an item into the collection at the specified index.
Protected method | IsElementName | Indicates whether the specified ConfigurationElement exists in the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | IsElementRemovable | Indicates whether the specified ConfigurationElement can be removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | IsModified | Indicates whether this ConfigurationElementCollection has been modified since it was last saved or loaded when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Causes the configuration system to throw an exception. (Inherited from ConfigurationElementCollection.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Public method | Remove | remove the element from the collection
Public method | RemoveAt | remove the element from the collection by the index
Protected method | Reset | Resets the ConfigurationElementCollection to its unmodified state when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | ResetModified | Resets the value of the IsModified property to when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | SerializeElement | Writes the configuration data to an XML element in the configuration file when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElementCollection object and for all sub-elements. (Inherited from ConfigurationElementCollection.)
Public method | ToList | Returns list of items
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Reverses the effect of merging configuration information from different levels of the configuration hierarchy (Inherited from ConfigurationElementCollection.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationElementCollection
VisualComponents.UX.SharedBaseConfigCollectionT
VisualComponents.UX.SharedBlockedRibbonItemConfigCollection
VisualComponents.UX.SharedCadPresetsConfigCollection
VisualComponents.UX.SharedCadPresetsEntryConfigCollection
VisualComponents.UX.SharedGalleryGroupsConfigCollection
VisualComponents.UX.SharedGalleryGroupsEntryConfigCollection
VisualComponents.UX.SharedInputConfigurationConfigCollection
VisualComponents.UX.SharedOpenSaveFolderConfigCollection
VisualComponents.UX.SharedUXSitesConfigCollection
VisualComponents.UX.SharedUXSitesEntryConfigCollection


BaseConfigCollection(T) Constructor

BaseConfigCollectionT Constructor

Initializes a new instance of the BaseConfigCollectionT class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected BaseConfigCollection()
protected:
BaseConfigCollection()
See Also

Reference

BaseConfigCollectionT Class
VisualComponents.UX.Shared Namespace


BaseConfigCollection(T) Properties

BaseConfigCollectionT Properties

The BaseConfigCollectionT generic type exposes the following members.

Properties
 | Name | Description
Protected property | AddElementName | Gets or sets the name of the ConfigurationElement to associate with the add operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected property | ClearElementName | Gets or sets the name for the ConfigurationElement to associate with the clear operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementName | Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is . (Inherited from ConfigurationElement.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | ItemInt32 |
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Protected property | RemoveElementName | Gets or sets the name of the ConfigurationElement to associate with the remove operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected property | ThrowOnDuplicate | Gets a value indicating whether an attempt to add a duplicate ConfigurationElement to the ConfigurationElementCollection will cause an exception to be thrown. (Inherited from ConfigurationElementCollection.)
Top
See Also

Reference

BaseConfigCollectionT Class
VisualComponents.UX.Shared Namespace


BaseConfigCollection(T).Item Property

BaseConfigCollectionTItem Property

Overload List
 | Name | Description
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | ItemInt32 |
Top
See Also

Reference

BaseConfigCollectionT Class
VisualComponents.UX.Shared Namespace


BaseConfigCollection(T).Item Property (Int32)

BaseConfigCollectionTItem Property (Int32)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public T this[
    int index
] { get; set; }
public:
property T default[int index] {
    T get (int index);
    void set (int index, T value);
}

Parameters

index
Type: SystemInt32

Property Value

Type: T
See Also

Reference

BaseConfigCollectionT Class
Item Overload
VisualComponents.UX.Shared Namespace


BaseConfigCollection(T) Methods

BaseConfigCollectionT Methods

The BaseConfigCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add item to the collection
Protected method | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseClear | Removes all configuration element objects from the collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGet(Object) | Returns the configuration element with the specified key. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGet(Int32) | Gets the configuration element at the specified index location. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGetAllKeys | Returns an array of the keys for all of the configuration elements contained in the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGetKey | Gets the key for the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
Protected method | BaseIndexOf | Indicates the index of the specified ConfigurationElement. (Inherited from ConfigurationElementCollection.)
Protected method | BaseIsRemoved | Indicates whether the ConfigurationElement with the specified key has been removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseRemove | Removes a ConfigurationElement from the collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseRemoveAt | Removes the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
Public method | Clear | clear the collection
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Protected method | CreateNewElement | create new element (Overrides ConfigurationElementCollectionCreateNewElement.)
Protected method | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetElementKey | Gets the element key for a specified configuration element when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | get the collection index of the element
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public method | Insert | Inserts an item into the collection at the specified index.
Protected method | IsElementName | Indicates whether the specified ConfigurationElement exists in the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | IsElementRemovable | Indicates whether the specified ConfigurationElement can be removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | IsModified | Indicates whether this ConfigurationElementCollection has been modified since it was last saved or loaded when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Causes the configuration system to throw an exception. (Inherited from ConfigurationElementCollection.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Public method | Remove | remove the element from the collection
Public method | RemoveAt | remove the element from the collection by the index
Protected method | Reset | Resets the ConfigurationElementCollection to its unmodified state when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | ResetModified | Resets the value of the IsModified property to when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | SerializeElement | Writes the configuration data to an XML element in the configuration file when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElementCollection object and for all sub-elements. (Inherited from ConfigurationElementCollection.)
Public method | ToList | Returns list of items
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Reverses the effect of merging configuration information from different levels of the configuration hierarchy (Inherited from ConfigurationElementCollection.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BaseConfigCollectionT Class
VisualComponents.UX.Shared Namespace


BaseConfigCollection(T).Add Method

BaseConfigCollectionTAdd Method

Add item to the collection

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Add(
    T element
)
public:
void Add(
    T element
)

Parameters

element
Type: T
item for adding to the collection
See Also

Reference

BaseConfigCollectionT Class
VisualComponents.UX.Shared Namespace


BaseConfigCollection(T).Clear Method

BaseConfigCollectionTClear Method

clear the collection

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Clear()
public:
void Clear()
See Also

Reference

BaseConfigCollectionT Class
VisualComponents.UX.Shared Namespace


BaseConfigCollection(T).CreateNewElement Method

BaseConfigCollectionTCreateNewElement Method

Overload List
 | Name | Description
Protected method | CreateNewElement | create new element (Overrides ConfigurationElementCollectionCreateNewElement.)
Protected method | CreateNewElement(String) | Creates a new ConfigurationElement when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Top
See Also

Reference

BaseConfigCollectionT Class
VisualComponents.UX.Shared Namespace


BaseConfigCollection(T).CreateNewElement Method

BaseConfigCollectionTCreateNewElement Method

create new element

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override ConfigurationElement CreateNewElement()
protected:
virtual ConfigurationElement^ CreateNewElement() override

Return Value

Type: ConfigurationElement
new element
See Also

Reference

BaseConfigCollectionT Class
CreateNewElement Overload
VisualComponents.UX.Shared Namespace


BaseConfigCollection(T).IndexOf Method

BaseConfigCollectionTIndexOf Method

get the collection index of the element

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int IndexOf(
    T element
)
public:
int IndexOf(
    T element
)

Parameters

element
Type: T
element instance

Return Value

Type: Int32
index of the element
See Also

Reference

BaseConfigCollectionT Class
VisualComponents.UX.Shared Namespace


BaseConfigCollection(T).Insert Method

BaseConfigCollectionTInsert Method

Inserts an item into the collection at the specified index.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Insert(
    int index,
    T element
)
public:
void Insert(
    int index,
    T element
)

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
element
Type: T
The object to insert.
See Also

Reference

BaseConfigCollectionT Class
VisualComponents.UX.Shared Namespace


BaseConfigCollection(T).Remove Method

BaseConfigCollectionTRemove Method

remove the element from the collection

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Remove(
    T element
)
public:
void Remove(
    T element
)

Parameters

element
Type: T
instance of the element
See Also

Reference

BaseConfigCollectionT Class
VisualComponents.UX.Shared Namespace


BaseConfigCollection(T).RemoveAt Method

BaseConfigCollectionTRemoveAt Method

remove the element from the collection by the index

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RemoveAt(
    int index
)
public:
void RemoveAt(
    int index
)

Parameters

index
Type: SystemInt32
index of the element
See Also

Reference

BaseConfigCollectionT Class
VisualComponents.UX.Shared Namespace


BaseConfigCollection(T).ToList Method

BaseConfigCollectionTToList Method

Returns list of items

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList<T> ToList()
public:
IList<T>^ ToList()

Return Value

Type: IListT
list of items
See Also

Reference

BaseConfigCollectionT Class
VisualComponents.UX.Shared Namespace


BeforeExecuteEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.UX.SharedBeforeExecuteEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class BeforeExecuteEventArgs : EventArgs
public ref class BeforeExecuteEventArgs : public EventArgs

The BeforeExecuteEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BeforeExecuteEventArgs | Initializes a new instance of the BeforeExecuteEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


BeforeExecuteEventArgs Constructor

Initializes a new instance of the BeforeExecuteEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BeforeExecuteEventArgs()
public:
BeforeExecuteEventArgs()
See Also

Reference

BeforeExecuteEventArgs Class
VisualComponents.UX.Shared Namespace


BeforeExecuteEventArgs Methods

The BeforeExecuteEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BeforeExecuteEventArgs Class
VisualComponents.UX.Shared Namespace


BeginDraggingAlignMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedBeginDraggingAlignMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class BeginDraggingAlignMessage
public ref class BeginDraggingAlignMessage

The BeginDraggingAlignMessage type exposes the following members.

Constructors
 | Name | Description
Public method | BeginDraggingAlignMessage | Initializes a new instance of the BeginDraggingAlignMessage class
Top
Properties
 | Name | Description
Public property | BeganAction |
Public property | BeginAction |
Public property | MousePosition |
Public property | OthersWereHidden |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


BeginDraggingAlignMessage Constructor

Initializes a new instance of the BeginDraggingAlignMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BeginDraggingAlignMessage()
public:
BeginDraggingAlignMessage()
See Also

Reference

BeginDraggingAlignMessage Class
VisualComponents.UX.Shared Namespace


BeginDraggingAlignMessage Properties

The BeginDraggingAlignMessage type exposes the following members.

Properties
 | Name | Description
Public property | BeganAction |
Public property | BeginAction |
Public property | MousePosition |
Public property | OthersWereHidden |
Top
See Also

Reference

BeginDraggingAlignMessage Class
VisualComponents.UX.Shared Namespace


BeginDraggingAlignMessage.BeganAction Property

BeginDraggingAlignMessageBeganAction Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool BeganAction { get; set; }
public:
property bool BeganAction {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

BeginDraggingAlignMessage Class
VisualComponents.UX.Shared Namespace


BeginDraggingAlignMessage.BeginAction Property

BeginDraggingAlignMessageBeginAction Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool BeginAction { get; set; }
public:
property bool BeginAction {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

BeginDraggingAlignMessage Class
VisualComponents.UX.Shared Namespace


BeginDraggingAlignMessage.MousePosition Property

BeginDraggingAlignMessageMousePosition Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Point MousePosition { get; set; }
public:
property Point MousePosition {
    Point get ();
    void set (Point value);
}

Property Value

Type: Point
See Also

Reference

BeginDraggingAlignMessage Class
VisualComponents.UX.Shared Namespace


BeginDraggingAlignMessage.OthersWereHidden Property

BeginDraggingAlignMessageOthersWereHidden Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool OthersWereHidden { get; set; }
public:
property bool OthersWereHidden {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

BeginDraggingAlignMessage Class
VisualComponents.UX.Shared Namespace


BeginDraggingAlignMessage Methods

The BeginDraggingAlignMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BeginDraggingAlignMessage Class
VisualComponents.UX.Shared Namespace


BeginInteractionMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedBeginInteractionMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class BeginInteractionMessage
public ref class BeginInteractionMessage

The BeginInteractionMessage type exposes the following members.

Constructors
 | Name | Description
Public method | BeginInteractionMessage | Initializes a new instance of the BeginInteractionMessage class
Top
Properties
 | Name | Description
Public property | Action |
Public property | Args |
Public property | Target |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


BeginInteractionMessage Constructor

Initializes a new instance of the BeginInteractionMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BeginInteractionMessage()
public:
BeginInteractionMessage()
See Also

Reference

BeginInteractionMessage Class
VisualComponents.UX.Shared Namespace


BeginInteractionMessage Properties

The BeginInteractionMessage type exposes the following members.

Properties
 | Name | Description
Public property | Action |
Public property | Args |
Public property | Target |
Top
See Also

Reference

BeginInteractionMessage Class
VisualComponents.UX.Shared Namespace


BeginInteractionMessage.Action Property

BeginInteractionMessageAction Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Action Action { get; set; }
public:
property Action Action {
    Action get ();
    void set (Action value);
}

Property Value

Type: Action
See Also

Reference

BeginInteractionMessage Class
VisualComponents.UX.Shared Namespace


BeginInteractionMessage.Args Property

BeginInteractionMessageArgs Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ManipulationEventArgs Args { get; set; }
public:
property ManipulationEventArgs^ Args {
    ManipulationEventArgs^ get ();
    void set (ManipulationEventArgs^ value);
}

Property Value

Type: ManipulationEventArgs
See Also

Reference

BeginInteractionMessage Class
VisualComponents.UX.Shared Namespace


BeginInteractionMessage.Target Property

BeginInteractionMessageTarget Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IManipulationTarget Target { get; set; }
public:
property IManipulationTarget^ Target {
    IManipulationTarget^ get ();
    void set (IManipulationTarget^ value);
}

Property Value

Type: IManipulationTarget
See Also

Reference

BeginInteractionMessage Class
VisualComponents.UX.Shared Namespace


BeginInteractionMessage Methods

The BeginInteractionMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BeginInteractionMessage Class
VisualComponents.UX.Shared Namespace


BeginRestoreMessage Class

Broad casted when autosave restoration is starting.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedBeginRestoreMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class BeginRestoreMessage
public ref class BeginRestoreMessage sealed

The BeginRestoreMessage type exposes the following members.

Constructors
 | Name | Description
Public method | BeginRestoreMessage | Initializes a new instance of the BeginRestoreMessage class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


BeginRestoreMessage Constructor

Initializes a new instance of the BeginRestoreMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BeginRestoreMessage()
public:
BeginRestoreMessage()
See Also

Reference

BeginRestoreMessage Class
VisualComponents.UX.Shared Namespace


BeginRestoreMessage Methods

The BeginRestoreMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BeginRestoreMessage Class
VisualComponents.UX.Shared Namespace


Bindable Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedBindable
VisualComponents.UX.SharedBindableT

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class Bindable : INotifyPropertyChanged
public ref class Bindable : INotifyPropertyChanged

The Bindable type exposes the following members.

Constructors
 | Name | Description
Protected method | Bindable | Initializes a new instance of the Bindable class
Top
Properties
 | Name | Description
Public property | Item |
Public property | Source |
Public property | Type |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInfo |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RaisePropertyChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
Fields
 | Name | Description
Protected field | _properties |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


Bindable Constructor

Initializes a new instance of the Bindable class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected Bindable()
protected:
Bindable()
See Also

Reference

Bindable Class
VisualComponents.UX.Shared Namespace


Bindable Properties

The Bindable type exposes the following members.

Properties
 | Name | Description
Public property | Item |
Public property | Source |
Public property | Type |
Top
See Also

Reference

Bindable Class
VisualComponents.UX.Shared Namespace


Bindable.Item Property

BindableItem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object this[
    string key
] { get; set; }
public:
property Object^ default[String^ key] {
    Object^ get (String^ key);
    void set (String^ key, Object^ value);
}

Parameters

key
Type: SystemString

Property Value

Type: Object
See Also

Reference

Bindable Class
VisualComponents.UX.Shared Namespace


Bindable.Source Property

BindableSource Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Source { get; protected set; }
public:
property Object^ Source {
    Object^ get ();
    protected: void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

Bindable Class
VisualComponents.UX.Shared Namespace


Bindable.Type Property

BindableType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type Type { get; protected set; }
public:
property Type^ Type {
    Type^ get ();
    protected: void set (Type^ value);
}

Property Value

Type: Type
See Also

Reference

Bindable Class
VisualComponents.UX.Shared Namespace


Bindable Methods

The Bindable type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInfo |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RaisePropertyChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

Bindable Class
VisualComponents.UX.Shared Namespace


Bindable.GetInfo Method

BindableGetInfo Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyInfo GetInfo(
    string key
)
public:
PropertyInfo^ GetInfo(
    String^ key
)

Parameters

key
Type: SystemString

Return Value

Type: PropertyInfo

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Bindable.GetInfo(System.String)"]

See Also

Reference

Bindable Class
VisualComponents.UX.Shared Namespace


Bindable.RaisePropertyChanged Method

BindableRaisePropertyChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RaisePropertyChanged()
public:
void RaisePropertyChanged()
See Also

Reference

Bindable Class
VisualComponents.UX.Shared Namespace


Bindable Events

The Bindable type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

Bindable Class
VisualComponents.UX.Shared Namespace


Bindable.PropertyChanged Event

BindablePropertyChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event PropertyChangedEventHandler PropertyChanged
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

Bindable Class
VisualComponents.UX.Shared Namespace


Bindable Fields

The Bindable type exposes the following members.

Fields
 | Name | Description
Protected field | _properties |
Top
See Also

Reference

Bindable Class
VisualComponents.UX.Shared Namespace


Bindable._properties Field

Bindable_properties Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected Dictionary<string, PropertyInfo> _properties
protected:
Dictionary<String^, PropertyInfo^>^ _properties

Field Value

Type: DictionaryString, PropertyInfo
See Also

Reference

Bindable Class
VisualComponents.UX.Shared Namespace


Bindable(T) Class

BindableT Class

Allows the Binding to receive property changed notifications from native wrappers or objects that don't directly implement INotifyPropertyChanged.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedBindable
VisualComponents.UX.SharedBindableT

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class Bindable<T> : Bindable

generic<typename T>
public ref class Bindable : public Bindable

Type Parameters

T

The BindableT type exposes the following members.

Constructors
 | Name | Description
Public method | BindableT | Constructs a new typed Bindable.
Top
Properties
 | Name | Description
Public property | Item | (Inherited from Bindable.)
Public property | Source | (Inherited from Bindable.)
Public property | Type | (Inherited from Bindable.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInfo | (Inherited from Bindable.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RaisePropertyChanged | (Inherited from Bindable.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from Bindable.)
Top
Fields
 | Name | Description
Protected field | _properties | (Inherited from Bindable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks
Use indexer notation in the PropertyPath (Bindable[WrappedPropertyName] instead of Bindable.WrappedPropertyName) and do not bind to the Source, since property changed notifications aren't published for it. Currently WPF doesn't support notifications by specific index keys so all of them will be notified. If you have to bind to multiple properties of wrapped object please consider using something else, for performance reasons...
See Also

Reference

VisualComponents.UX.Shared Namespace


Bindable(T) Constructor

BindableT Constructor

Constructs a new typed Bindable.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Bindable(
    T source
)
public:
Bindable(
    T source
)

Parameters

source
Type: T
See Also

Reference

BindableT Class
VisualComponents.UX.Shared Namespace


Bindable(T) Properties

BindableT Properties

The BindableT generic type exposes the following members.

Properties
 | Name | Description
Public property | Item | (Inherited from Bindable.)
Public property | Source | (Inherited from Bindable.)
Public property | Type | (Inherited from Bindable.)
Top
See Also

Reference

BindableT Class
VisualComponents.UX.Shared Namespace


Bindable(T) Methods

BindableT Methods

The BindableT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInfo | (Inherited from Bindable.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RaisePropertyChanged | (Inherited from Bindable.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BindableT Class
VisualComponents.UX.Shared Namespace


Bindable(T) Events

BindableT Events

The BindableT generic type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from Bindable.)
Top
See Also

Reference

BindableT Class
VisualComponents.UX.Shared Namespace


Bindable(T) Fields

BindableT Fields

The BindableT generic type exposes the following members.

Fields
 | Name | Description
Protected field | _properties | (Inherited from Bindable.)
Top
See Also

Reference

BindableT Class
VisualComponents.UX.Shared Namespace


BindingProxy Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.WindowsFreezable
VisualComponents.UX.SharedBindingProxy

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class BindingProxy : Freezable
public ref class BindingProxy : public Freezable

The BindingProxy type exposes the following members.

Constructors
 | Name | Description
Public method | BindingProxy | Initializes a new instance of the BindingProxy class
Top
Properties
 | Name | Description
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | Data |
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of the Freezable, making deep copies of the object's values. When copying the object's dependency properties, this method copies expressions (which might no longer resolve) but not animations or their current values. (Inherited from Freezable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | (Overrides FreezableCreateInstanceCore.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to . (Inherited from Freezable.)
Protected method | FreezeCore | Makes the Freezable object unmodifiable or tests whether it can be made unmodifiable. (Inherited from Freezable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
Events
 | Name | Description
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Top
Fields
Name | Description
DataProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


BindingProxy Constructor

Initializes a new instance of the BindingProxy class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BindingProxy()
public:
BindingProxy()
See Also

Reference

BindingProxy Class
VisualComponents.UX.Shared Namespace


BindingProxy Properties

The BindingProxy type exposes the following members.

Properties
 | Name | Description
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | Data |
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Top
See Also

Reference

BindingProxy Class
VisualComponents.UX.Shared Namespace


BindingProxy.Data Property

BindingProxyData Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Data { get; set; }
public:
property Object^ Data {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

BindingProxy Class
VisualComponents.UX.Shared Namespace


BindingProxy Methods

The BindingProxy type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of the Freezable, making deep copies of the object's values. When copying the object's dependency properties, this method copies expressions (which might no longer resolve) but not animations or their current values. (Inherited from Freezable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | (Overrides FreezableCreateInstanceCore.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to . (Inherited from Freezable.)
Protected method | FreezeCore | Makes the Freezable object unmodifiable or tests whether it can be made unmodifiable. (Inherited from Freezable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BindingProxy Class
VisualComponents.UX.Shared Namespace


BindingProxy.CreateInstanceCore Method

BindingProxyCreateInstanceCore Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Freezable CreateInstanceCore()
protected:
virtual Freezable^ CreateInstanceCore() override

Return Value

Type: Freezable

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.BindingProxy.CreateInstanceCore"]

See Also

Reference

BindingProxy Class
VisualComponents.UX.Shared Namespace


BindingProxy Events

The BindingProxy type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Top
See Also

Reference

BindingProxy Class
VisualComponents.UX.Shared Namespace


BindingProxy Fields

The BindingProxy type exposes the following members.

Fields
Name | Description
DataProperty |
Top
See Also

Reference

BindingProxy Class
VisualComponents.UX.Shared Namespace


BindingProxy.DataProperty Field

BindingProxyDataProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty DataProperty
public:
static initonly DependencyProperty^ DataProperty

Field Value

Type: DependencyProperty
See Also

Reference

BindingProxy Class
VisualComponents.UX.Shared Namespace


BitmapEditor Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
VisualComponents.UX.SharedBitmapEditor

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class BitmapEditor : Control
public ref class BitmapEditor : public Control

The BitmapEditor type exposes the following members.

Constructors
 | Name | Description
Public method | BitmapEditor | Initializes a new instance of the BitmapEditor class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | ImageSource |
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsBitmapBrowsingCompleted |
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | BitmapBrowseCompleted |
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
BitmapBrowseCompletedEvent |
ImageSourceProperty |
IsBitmapBrowsingCompletedProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


BitmapEditor Constructor

Initializes a new instance of the BitmapEditor class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BitmapEditor()
public:
BitmapEditor()
See Also

Reference

BitmapEditor Class
VisualComponents.UX.Shared Namespace


BitmapEditor Properties

The BitmapEditor type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | ImageSource |
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsBitmapBrowsingCompleted |
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

BitmapEditor Class
VisualComponents.UX.Shared Namespace


BitmapEditor.ImageSource Property

BitmapEditorImageSource Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ImageSource { get; set; }
public:
property String^ ImageSource {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

BitmapEditor Class
VisualComponents.UX.Shared Namespace


BitmapEditor.IsBitmapBrowsingCompleted Property

BitmapEditorIsBitmapBrowsingCompleted Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsBitmapBrowsingCompleted { get; }
public:
property bool IsBitmapBrowsingCompleted {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

BitmapEditor Class
VisualComponents.UX.Shared Namespace


BitmapEditor Methods

The BitmapEditor type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BitmapEditor Class
VisualComponents.UX.Shared Namespace


BitmapEditor.OnApplyTemplate Method

BitmapEditorOnApplyTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

BitmapEditor Class
VisualComponents.UX.Shared Namespace


BitmapEditor Events

The BitmapEditor type exposes the following members.

Events
 | Name | Description
Public event | BitmapBrowseCompleted |
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

BitmapEditor Class
VisualComponents.UX.Shared Namespace


BitmapEditor.BitmapBrowseCompleted Event

BitmapEditorBitmapBrowseCompleted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event RoutedEventHandler BitmapBrowseCompleted
public:
 event RoutedEventHandler^ BitmapBrowseCompleted {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

BitmapEditor Class
VisualComponents.UX.Shared Namespace


BitmapEditor Fields

The BitmapEditor type exposes the following members.

Fields
Name | Description
BitmapBrowseCompletedEvent |
ImageSourceProperty |
IsBitmapBrowsingCompletedProperty |
Top
See Also

Reference

BitmapEditor Class
VisualComponents.UX.Shared Namespace


BitmapEditor.BitmapBrowseCompletedEvent Field

BitmapEditorBitmapBrowseCompletedEvent Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly RoutedEvent BitmapBrowseCompletedEvent
public:
static initonly RoutedEvent^ BitmapBrowseCompletedEvent

Field Value

Type: RoutedEvent
See Also

Reference

BitmapEditor Class
VisualComponents.UX.Shared Namespace


BitmapEditor.ImageSourceProperty Field

BitmapEditorImageSourceProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty ImageSourceProperty
public:
static DependencyProperty^ ImageSourceProperty

Field Value

Type: DependencyProperty
See Also

Reference

BitmapEditor Class
VisualComponents.UX.Shared Namespace


BitmapEditor.IsBitmapBrowsingCompletedProperty Field

BitmapEditorIsBitmapBrowsingCompletedProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty IsBitmapBrowsingCompletedProperty
public:
static DependencyProperty^ IsBitmapBrowsingCompletedProperty

Field Value

Type: DependencyProperty
See Also

Reference

BitmapEditor Class
VisualComponents.UX.Shared Namespace


BitmapExportStatusMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedBitmapExportStatusMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class BitmapExportStatusMessage
public ref class BitmapExportStatusMessage

The BitmapExportStatusMessage type exposes the following members.

Constructors
 | Name | Description
Public method | BitmapExportStatusMessage | Initializes a new instance of the BitmapExportStatusMessage class
Top
Properties
 | Name | Description
Public property | Status |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | FilePath |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


BitmapExportStatusMessage Constructor

Initializes a new instance of the BitmapExportStatusMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BitmapExportStatusMessage(
    string filepath,
    FileStatus status = FileStatus.Unknown
)
public:
BitmapExportStatusMessage(
    String^ filepath,
    FileStatus status = FileStatus::Unknown
)

Parameters

filepath
Type: SystemString
status (Optional)
Type: VisualComponents.UX.SharedFileStatus
See Also

Reference

BitmapExportStatusMessage Class
VisualComponents.UX.Shared Namespace


BitmapExportStatusMessage Properties

The BitmapExportStatusMessage type exposes the following members.

Properties
 | Name | Description
Public property | Status |
Top
See Also

Reference

BitmapExportStatusMessage Class
VisualComponents.UX.Shared Namespace


BitmapExportStatusMessage.Status Property

BitmapExportStatusMessageStatus Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FileStatus Status { get; }
public:
property FileStatus Status {
    FileStatus get ();
}

Property Value

Type: FileStatus
See Also

Reference

BitmapExportStatusMessage Class
VisualComponents.UX.Shared Namespace


BitmapExportStatusMessage Methods

The BitmapExportStatusMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BitmapExportStatusMessage Class
VisualComponents.UX.Shared Namespace


BitmapExportStatusMessage Fields

The BitmapExportStatusMessage type exposes the following members.

Fields
 | Name | Description
Public field | FilePath |
Top
See Also

Reference

BitmapExportStatusMessage Class
VisualComponents.UX.Shared Namespace


BitmapExportStatusMessage.FilePath Field

BitmapExportStatusMessageFilePath Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public readonly string FilePath
public:
initonly String^ FilePath

Field Value

Type: String
See Also

Reference

BitmapExportStatusMessage Class
VisualComponents.UX.Shared Namespace


BitmapImageSourceEditor Class

Bitmap control which allows changing bitmaproperty by using bitmap object or file location.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
VisualComponents.UX.SharedBitmapImageSourceEditor

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class BitmapImageSourceEditor : Control
public ref class BitmapImageSourceEditor : public Control

The BitmapImageSourceEditor type exposes the following members.

Constructors
 | Name | Description
Public method | BitmapImageSourceEditor | Initializes a new instance of the BitmapImageSourceEditor class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | ImageSource |
Public property | ImageSourcePath |
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsBitmapBrowsingCompleted |
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | BitmapBrowseCompleted |
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
BitmapBrowseCompletedEvent |
ImageSourcePathProperty |
ImageSourceProperty |
IsBitmapBrowsingCompletedProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


BitmapImageSourceEditor Constructor

Initializes a new instance of the BitmapImageSourceEditor class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BitmapImageSourceEditor()
public:
BitmapImageSourceEditor()
See Also

Reference

BitmapImageSourceEditor Class
VisualComponents.UX.Shared Namespace


BitmapImageSourceEditor Properties

The BitmapImageSourceEditor type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | ImageSource |
Public property | ImageSourcePath |
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsBitmapBrowsingCompleted |
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

BitmapImageSourceEditor Class
VisualComponents.UX.Shared Namespace


BitmapImageSourceEditor.ImageSource Property

BitmapImageSourceEditorImageSource Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Bitmap ImageSource { get; set; }
public:
property Bitmap^ ImageSource {
    Bitmap^ get ();
    void set (Bitmap^ value);
}

Property Value

Type: Bitmap
See Also

Reference

BitmapImageSourceEditor Class
VisualComponents.UX.Shared Namespace


BitmapImageSourceEditor.ImageSourcePath Property

BitmapImageSourceEditorImageSourcePath Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ImageSourcePath { get; set; }
public:
property String^ ImageSourcePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

BitmapImageSourceEditor Class
VisualComponents.UX.Shared Namespace


BitmapImageSourceEditor.IsBitmapBrowsingCompleted Property

BitmapImageSourceEditorIsBitmapBrowsingCompleted Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsBitmapBrowsingCompleted { get; }
public:
property bool IsBitmapBrowsingCompleted {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

BitmapImageSourceEditor Class
VisualComponents.UX.Shared Namespace


BitmapImageSourceEditor Methods

The BitmapImageSourceEditor type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BitmapImageSourceEditor Class
VisualComponents.UX.Shared Namespace


BitmapImageSourceEditor.OnApplyTemplate Method

BitmapImageSourceEditorOnApplyTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

BitmapImageSourceEditor Class
VisualComponents.UX.Shared Namespace


BitmapImageSourceEditor Events

The BitmapImageSourceEditor type exposes the following members.

Events
 | Name | Description
Public event | BitmapBrowseCompleted |
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

BitmapImageSourceEditor Class
VisualComponents.UX.Shared Namespace


BitmapImageSourceEditor.BitmapBrowseCompleted Event

BitmapImageSourceEditorBitmapBrowseCompleted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event RoutedEventHandler BitmapBrowseCompleted
public:
 event RoutedEventHandler^ BitmapBrowseCompleted {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

BitmapImageSourceEditor Class
VisualComponents.UX.Shared Namespace


BitmapImageSourceEditor Fields

The BitmapImageSourceEditor type exposes the following members.

Fields
Name | Description
BitmapBrowseCompletedEvent |
ImageSourcePathProperty |
ImageSourceProperty |
IsBitmapBrowsingCompletedProperty |
Top
See Also

Reference

BitmapImageSourceEditor Class
VisualComponents.UX.Shared Namespace


BitmapImageSourceEditor.BitmapBrowseCompletedEvent Field

BitmapImageSourceEditorBitmapBrowseCompletedEvent Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly RoutedEvent BitmapBrowseCompletedEvent
public:
static initonly RoutedEvent^ BitmapBrowseCompletedEvent

Field Value

Type: RoutedEvent
See Also

Reference

BitmapImageSourceEditor Class
VisualComponents.UX.Shared Namespace


BitmapImageSourceEditor.ImageSourcePathProperty Field

BitmapImageSourceEditorImageSourcePathProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ImageSourcePathProperty
public:
static initonly DependencyProperty^ ImageSourcePathProperty

Field Value

Type: DependencyProperty
See Also

Reference

BitmapImageSourceEditor Class
VisualComponents.UX.Shared Namespace


BitmapImageSourceEditor.ImageSourceProperty Field

BitmapImageSourceEditorImageSourceProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty ImageSourceProperty
public:
static DependencyProperty^ ImageSourceProperty

Field Value

Type: DependencyProperty
See Also

Reference

BitmapImageSourceEditor Class
VisualComponents.UX.Shared Namespace


BitmapImageSourceEditor.IsBitmapBrowsingCompletedProperty Field

BitmapImageSourceEditorIsBitmapBrowsingCompletedProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty IsBitmapBrowsingCompletedProperty
public:
static DependencyProperty^ IsBitmapBrowsingCompletedProperty

Field Value

Type: DependencyProperty
See Also

Reference

BitmapImageSourceEditor Class
VisualComponents.UX.Shared Namespace


BitmapProperty Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedEditorProperty
VisualComponents.UX.SharedBitmapProperty

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class BitmapProperty : EditorProperty
public ref class BitmapProperty : public EditorProperty

The BitmapProperty type exposes the following members.

Constructors
 | Name | Description
Public method | BitmapProperty | Initializes a new instance of the BitmapProperty class
Top
Properties
 | Name | Description
Public property | AllowedMaximum | (Inherited from EditorProperty.)
Public property | AllowedMinimum | (Inherited from EditorProperty.)
Public property | AllowedValues | (Inherited from EditorProperty.)
Public property | CanCreateNewValue | (Inherited from EditorProperty.)
Public property | Category | (Inherited from EditorProperty.)
Public property | ConstraintType | (Inherited from EditorProperty.)
Public property | Container | (Inherited from EditorProperty.)
Public property | ContainerExpressionContext | (Inherited from EditorProperty.)
Public property | ContainerObject | Similar to IProperty.Container, but for any object. (Inherited from EditorProperty.)
Public property | CreationTypes | (Inherited from EditorProperty.)
Public property | Description | (Inherited from EditorProperty.)
Public property | DisabledStateToolTip | (Inherited from EditorProperty.)
Public property | DistributionExpression | (Inherited from EditorProperty.)
Public property | Error | (Inherited from EditorProperty.)
Public property | ErrorMessage | (Inherited from EditorProperty.)
Public property | HasDistribution | (Inherited from EditorProperty.)
Public property | History | (Inherited from EditorProperty.)
Public property | Image |
Public property | ImagePath |
Public property | Index_ForComboBox | (Inherited from EditorProperty.)
Public property | IsDesignTime | (Inherited from EditorProperty.)
Public property | IsEditable | Helper property since in XAML negating binding value is not possible without using BoolToOppositeConverter (Inherited from EditorProperty.)
Public property | IsEditableInGui | (Inherited from EditorProperty.)
Public property | IsExceptionallyInHome | (Inherited from EditorProperty.)
Public property | IsInternal | (Inherited from EditorProperty.)
Public property | IsLocked | (Inherited from EditorProperty.)
Public property | IsPersistent | (Inherited from EditorProperty.)
Public property | IsQuantityValue | (Inherited from EditorProperty.)
Public property | IsReadOnly | (Inherited from EditorProperty.)
Public property | IsValid | (Inherited from EditorProperty.)
Public property | IsVisible | (Inherited from EditorProperty.)
Public property | IsVisibleDesignTime | (Inherited from EditorProperty.)
Public property | IsVisibleForced | (Inherited from EditorProperty.)
Public property | IsVisibleInGui | IsVisibleInGui is used to bind GUI visibility. Setting this value affects only _isVisibleForcedOff. (Inherited from EditorProperty.)
Public property | Item | (Inherited from EditorProperty.)
Public property | Name | (Inherited from EditorProperty.)
Public property | NonLocalizedName | (Inherited from EditorProperty.)
Public property | Order | (Inherited from EditorProperty.)
Public property | Property | (Inherited from EditorProperty.)
Public property | PropertyDescription | (Inherited from EditorProperty.)
Public property | PropertyType | (Inherited from EditorProperty.)
Public property | Quantity | (Inherited from EditorProperty.)
Public property | ResourceType | In case of having an IUriProperty, this determines if the editor should allow folder selection instead of file selection (Inherited from EditorProperty.)
Public property | RotationSystem | (Inherited from EditorProperty.)
Public property | ShowValuepicker | (Inherited from EditorProperty.)
Public property | TabHeader | (Inherited from EditorProperty.)
Public property | Unit | (Inherited from EditorProperty.)
Public property | Value | (Inherited from EditorProperty.)
Public property | Value_ForComboBox | Helper property, used only by ComboBox. (Inherited from EditorProperty.)
Public property | ValueString | (Inherited from EditorProperty.)
Top
Methods
 | Name | Description
Public method | Associate | (Inherited from EditorProperty.)
Public method | CheckEditableInGui | (Inherited from EditorProperty.)
Protected method | CheckPropertyObjDispose | (Inherited from EditorProperty.)
Public method | CheckRebuild | This happens only on UI changes. If containeris a behavior of feature call evaluate or rebuild to update geometry. (Inherited from EditorProperty.)
Public method | CheckRebuildSmart | (Inherited from EditorProperty.)
Public method | Clone | (Inherited from EditorProperty.)
Public method | CreateAndSetNewValue | (Inherited from EditorProperty.)
Public method | Disassociate | (Inherited from EditorProperty.)
Public method | Dispose | (Inherited from EditorProperty.)
Protected method | Dispose(Boolean) | (Inherited from EditorProperty.)
Public method | EndBatch | (Inherited from EditorProperty.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from EditorProperty.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokePropertyChanged | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedEx | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedValue_Begin | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedValue_Process | (Inherited from EditorProperty.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Note: This is Not just called on IProperty.Value change. It's called by PropertyWrapper::NotifyPropertyChanged with different names (like "Value", "Expression", etc). It's called on rVariable::SetupChanged, on variable flag changes. (Inherited from EditorProperty.)
Public method | PickValue | Execute PickAction and wait for user to click on some object. (Inherited from EditorProperty.)
Public method | PickValueProxy | (Inherited from EditorProperty.)
Public method | SetQuantity | (Inherited from EditorProperty.)
Public method | SetUnitMagnitude | (Inherited from EditorProperty.)
Public method | StartBatch | (Inherited from EditorProperty.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | property changed event (Inherited from EditorProperty.)
Top
Fields
 | Name | Description
Public field | SuppressValueChange | (Inherited from EditorProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


BitmapProperty Constructor

Initializes a new instance of the BitmapProperty class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BitmapProperty(
    IProperty property
)
public:
BitmapProperty(
    IProperty^ property
)

Parameters

property
Type: VisualComponents.Create3DIProperty
See Also

Reference

BitmapProperty Class
VisualComponents.UX.Shared Namespace


BitmapProperty Properties

The BitmapProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | (Inherited from EditorProperty.)
Public property | AllowedMinimum | (Inherited from EditorProperty.)
Public property | AllowedValues | (Inherited from EditorProperty.)
Public property | CanCreateNewValue | (Inherited from EditorProperty.)
Public property | Category | (Inherited from EditorProperty.)
Public property | ConstraintType | (Inherited from EditorProperty.)
Public property | Container | (Inherited from EditorProperty.)
Public property | ContainerExpressionContext | (Inherited from EditorProperty.)
Public property | ContainerObject | Similar to IProperty.Container, but for any object. (Inherited from EditorProperty.)
Public property | CreationTypes | (Inherited from EditorProperty.)
Public property | Description | (Inherited from EditorProperty.)
Public property | DisabledStateToolTip | (Inherited from EditorProperty.)
Public property | DistributionExpression | (Inherited from EditorProperty.)
Public property | Error | (Inherited from EditorProperty.)
Public property | ErrorMessage | (Inherited from EditorProperty.)
Public property | HasDistribution | (Inherited from EditorProperty.)
Public property | History | (Inherited from EditorProperty.)
Public property | Image |
Public property | ImagePath |
Public property | Index_ForComboBox | (Inherited from EditorProperty.)
Public property | IsDesignTime | (Inherited from EditorProperty.)
Public property | IsEditable | Helper property since in XAML negating binding value is not possible without using BoolToOppositeConverter (Inherited from EditorProperty.)
Public property | IsEditableInGui | (Inherited from EditorProperty.)
Public property | IsExceptionallyInHome | (Inherited from EditorProperty.)
Public property | IsInternal | (Inherited from EditorProperty.)
Public property | IsLocked | (Inherited from EditorProperty.)
Public property | IsPersistent | (Inherited from EditorProperty.)
Public property | IsQuantityValue | (Inherited from EditorProperty.)
Public property | IsReadOnly | (Inherited from EditorProperty.)
Public property | IsValid | (Inherited from EditorProperty.)
Public property | IsVisible | (Inherited from EditorProperty.)
Public property | IsVisibleDesignTime | (Inherited from EditorProperty.)
Public property | IsVisibleForced | (Inherited from EditorProperty.)
Public property | IsVisibleInGui | IsVisibleInGui is used to bind GUI visibility. Setting this value affects only _isVisibleForcedOff. (Inherited from EditorProperty.)
Public property | Item | (Inherited from EditorProperty.)
Public property | Name | (Inherited from EditorProperty.)
Public property | NonLocalizedName | (Inherited from EditorProperty.)
Public property | Order | (Inherited from EditorProperty.)
Public property | Property | (Inherited from EditorProperty.)
Public property | PropertyDescription | (Inherited from EditorProperty.)
Public property | PropertyType | (Inherited from EditorProperty.)
Public property | Quantity | (Inherited from EditorProperty.)
Public property | ResourceType | In case of having an IUriProperty, this determines if the editor should allow folder selection instead of file selection (Inherited from EditorProperty.)
Public property | RotationSystem | (Inherited from EditorProperty.)
Public property | ShowValuepicker | (Inherited from EditorProperty.)
Public property | TabHeader | (Inherited from EditorProperty.)
Public property | Unit | (Inherited from EditorProperty.)
Public property | Value | (Inherited from EditorProperty.)
Public property | Value_ForComboBox | Helper property, used only by ComboBox. (Inherited from EditorProperty.)
Public property | ValueString | (Inherited from EditorProperty.)
Top
See Also

Reference

BitmapProperty Class
VisualComponents.UX.Shared Namespace


BitmapProperty.Image Property

BitmapPropertyImage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Bitmap Image { get; set; }
public:
property Bitmap^ Image {
    Bitmap^ get ();
    void set (Bitmap^ value);
}

Property Value

Type: Bitmap
See Also

Reference

BitmapProperty Class
VisualComponents.UX.Shared Namespace


BitmapProperty.ImagePath Property

BitmapPropertyImagePath Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ImagePath { get; set; }
public:
property String^ ImagePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

BitmapProperty Class
VisualComponents.UX.Shared Namespace


BitmapProperty Methods

The BitmapProperty type exposes the following members.

Methods
 | Name | Description
Public method | Associate | (Inherited from EditorProperty.)
Public method | CheckEditableInGui | (Inherited from EditorProperty.)
Protected method | CheckPropertyObjDispose | (Inherited from EditorProperty.)
Public method | CheckRebuild | This happens only on UI changes. If containeris a behavior of feature call evaluate or rebuild to update geometry. (Inherited from EditorProperty.)
Public method | CheckRebuildSmart | (Inherited from EditorProperty.)
Public method | Clone | (Inherited from EditorProperty.)
Public method | CreateAndSetNewValue | (Inherited from EditorProperty.)
Public method | Disassociate | (Inherited from EditorProperty.)
Public method | Dispose | (Inherited from EditorProperty.)
Protected method | Dispose(Boolean) | (Inherited from EditorProperty.)
Public method | EndBatch | (Inherited from EditorProperty.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from EditorProperty.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokePropertyChanged | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedEx | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedValue_Begin | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedValue_Process | (Inherited from EditorProperty.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Note: This is Not just called on IProperty.Value change. It's called by PropertyWrapper::NotifyPropertyChanged with different names (like "Value", "Expression", etc). It's called on rVariable::SetupChanged, on variable flag changes. (Inherited from EditorProperty.)
Public method | PickValue | Execute PickAction and wait for user to click on some object. (Inherited from EditorProperty.)
Public method | PickValueProxy | (Inherited from EditorProperty.)
Public method | SetQuantity | (Inherited from EditorProperty.)
Public method | SetUnitMagnitude | (Inherited from EditorProperty.)
Public method | StartBatch | (Inherited from EditorProperty.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BitmapProperty Class
VisualComponents.UX.Shared Namespace


BitmapProperty Events

The BitmapProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | property changed event (Inherited from EditorProperty.)
Top
See Also

Reference

BitmapProperty Class
VisualComponents.UX.Shared Namespace


BitmapProperty Fields

The BitmapProperty type exposes the following members.

Fields
 | Name | Description
Public field | SuppressValueChange | (Inherited from EditorProperty.)
Top
See Also

Reference

BitmapProperty Class
VisualComponents.UX.Shared Namespace


BlockedItemsConfigElement Class

blocked item config element
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.UX.SharedBlockedItemsConfigElement

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class BlockedItemsConfigElement : ConfigurationElement
public ref class BlockedItemsConfigElement sealed : public ConfigurationElement

The BlockedItemsConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | BlockedItemsConfigElement | Initializes a new instance of the BlockedItemsConfigElement class
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | ItemId | item ID
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


BlockedItemsConfigElement Constructor

Initializes a new instance of the BlockedItemsConfigElement class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BlockedItemsConfigElement()
public:
BlockedItemsConfigElement()
See Also

Reference

BlockedItemsConfigElement Class
VisualComponents.UX.Shared Namespace


BlockedItemsConfigElement Properties

The BlockedItemsConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | ItemId | item ID
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Top
See Also

Reference

BlockedItemsConfigElement Class
VisualComponents.UX.Shared Namespace


BlockedItemsConfigElement.ItemId Property

BlockedItemsConfigElementItemId Property

item ID

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ItemId { get; set; }
public:
property String^ ItemId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

BlockedItemsConfigElement Class
VisualComponents.UX.Shared Namespace


BlockedItemsConfigElement Methods

The BlockedItemsConfigElement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BlockedItemsConfigElement Class
VisualComponents.UX.Shared Namespace


BlockedRibbonItemConfigCollection Class

blocked item config collection
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationElementCollection
VisualComponents.UX.SharedBaseConfigCollection BlockedItemsConfigElement
VisualComponents.UX.SharedBlockedRibbonItemConfigCollection

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class BlockedRibbonItemConfigCollection : BaseConfigCollection<BlockedItemsConfigElement>
public ref class BlockedRibbonItemConfigCollection sealed : public BaseConfigCollection<BlockedItemsConfigElement^>

The BlockedRibbonItemConfigCollection type exposes the following members.

Constructors
 | Name | Description
Public method | BlockedRibbonItemConfigCollection | Initializes a new instance of the BlockedRibbonItemConfigCollection class
Top
Properties
 | Name | Description
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Public property | ItemInt32 | (Inherited from BaseConfigCollectionT.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Top
Methods
 | Name | Description
Public method | Add | Add item to the collection (Inherited from BaseConfigCollectionT.)
Public method | Clear | clear the collection (Inherited from BaseConfigCollectionT.)
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | get the collection index of the element (Inherited from BaseConfigCollectionT.)
Public method | Insert | Inserts an item into the collection at the specified index. (Inherited from BaseConfigCollectionT.)
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Public method | Remove | remove the element from the collection (Inherited from BaseConfigCollectionT.)
Public method | RemoveAt | remove the element from the collection by the index (Inherited from BaseConfigCollectionT.)
Public method | ToList | Returns list of items (Inherited from BaseConfigCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


BlockedRibbonItemConfigCollection Constructor

Initializes a new instance of the BlockedRibbonItemConfigCollection class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BlockedRibbonItemConfigCollection()
public:
BlockedRibbonItemConfigCollection()
See Also

Reference

BlockedRibbonItemConfigCollection Class
VisualComponents.UX.Shared Namespace


BlockedRibbonItemConfigCollection Properties

The BlockedRibbonItemConfigCollection type exposes the following members.

Properties
 | Name | Description
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Public property | ItemInt32 | (Inherited from BaseConfigCollectionT.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Top
See Also

Reference

BlockedRibbonItemConfigCollection Class
VisualComponents.UX.Shared Namespace


BlockedRibbonItemConfigCollection Methods

The BlockedRibbonItemConfigCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add item to the collection (Inherited from BaseConfigCollectionT.)
Public method | Clear | clear the collection (Inherited from BaseConfigCollectionT.)
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | get the collection index of the element (Inherited from BaseConfigCollectionT.)
Public method | Insert | Inserts an item into the collection at the specified index. (Inherited from BaseConfigCollectionT.)
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Public method | Remove | remove the element from the collection (Inherited from BaseConfigCollectionT.)
Public method | RemoveAt | remove the element from the collection by the index (Inherited from BaseConfigCollectionT.)
Public method | ToList | Returns list of items (Inherited from BaseConfigCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BlockedRibbonItemConfigCollection Class
VisualComponents.UX.Shared Namespace


BlockedRibbonItemsSection Class

blocked items section
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationSection
VisualComponents.UX.SharedBlockedRibbonItemsSection

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class BlockedRibbonItemsSection : ConfigurationSection,
    ISection, IBlockedRibbonItemsSection
public ref class BlockedRibbonItemsSection sealed : public ConfigurationSection,
    ISection, IBlockedRibbonItemsSection

The BlockedRibbonItemsSection type exposes the following members.

Constructors
 | Name | Description
Public method | BlockedRibbonItemsSection | Initializes a new instance of the BlockedRibbonItemsSection class
Top
Properties
 | Name | Description
Public property | BlockedNonRibbonControlItems |
Public property | BlockedPaneItems |
Public property | BlockedQuickMenuItems |
Public property | BlockedRibbonBackstageItems |
Public property | BlockedRibbonGroups |
Public property | BlockedRibbonTabs |
Public property | BlockedRibbonTools |
Public property | BlockedToolsNotInRibbonItems |
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName |
Public property | SectionType |
Public property | SectionVersion |
Top
Methods
 | Name | Description
Public method | CheckVersion |
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


BlockedRibbonItemsSection Constructor

Initializes a new instance of the BlockedRibbonItemsSection class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BlockedRibbonItemsSection()
public:
BlockedRibbonItemsSection()
See Also

Reference

BlockedRibbonItemsSection Class
VisualComponents.UX.Shared Namespace


BlockedRibbonItemsSection Properties

The BlockedRibbonItemsSection type exposes the following members.

Properties
 | Name | Description
Public property | BlockedNonRibbonControlItems |
Public property | BlockedPaneItems |
Public property | BlockedQuickMenuItems |
Public property | BlockedRibbonBackstageItems |
Public property | BlockedRibbonGroups |
Public property | BlockedRibbonTabs |
Public property | BlockedRibbonTools |
Public property | BlockedToolsNotInRibbonItems |
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName |
Public property | SectionType |
Public property | SectionVersion |
Top
See Also

Reference

BlockedRibbonItemsSection Class
VisualComponents.UX.Shared Namespace


BlockedRibbonItemsSection.BlockedNonRibbonControlItems Property

BlockedRibbonItemsSectionBlockedNonRibbonControlItems Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BlockedRibbonItemConfigCollection BlockedNonRibbonControlItems { get; }
public:
virtual property BlockedRibbonItemConfigCollection^ BlockedNonRibbonControlItems {
    BlockedRibbonItemConfigCollection^ get () sealed;
}

Property Value

Type: BlockedRibbonItemConfigCollection

Implements

IBlockedRibbonItemsSectionBlockedNonRibbonControlItems
See Also

Reference

BlockedRibbonItemsSection Class
VisualComponents.UX.Shared Namespace


BlockedRibbonItemsSection.BlockedPaneItems Property

BlockedRibbonItemsSectionBlockedPaneItems Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BlockedRibbonItemConfigCollection BlockedPaneItems { get; }
public:
virtual property BlockedRibbonItemConfigCollection^ BlockedPaneItems {
    BlockedRibbonItemConfigCollection^ get () sealed;
}

Property Value

Type: BlockedRibbonItemConfigCollection

Implements

IBlockedRibbonItemsSectionBlockedPaneItems
See Also

Reference

BlockedRibbonItemsSection Class
VisualComponents.UX.Shared Namespace


BlockedRibbonItemsSection.BlockedQuickMenuItems Property

BlockedRibbonItemsSectionBlockedQuickMenuItems Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BlockedRibbonItemConfigCollection BlockedQuickMenuItems { get; }
public:
virtual property BlockedRibbonItemConfigCollection^ BlockedQuickMenuItems {
    BlockedRibbonItemConfigCollection^ get () sealed;
}

Property Value

Type: BlockedRibbonItemConfigCollection

Implements

IBlockedRibbonItemsSectionBlockedQuickMenuItems
See Also

Reference

BlockedRibbonItemsSection Class
VisualComponents.UX.Shared Namespace


BlockedRibbonItemsSection.BlockedRibbonBackstageItems Property

BlockedRibbonItemsSectionBlockedRibbonBackstageItems Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BlockedRibbonItemConfigCollection BlockedRibbonBackstageItems { get; }
public:
virtual property BlockedRibbonItemConfigCollection^ BlockedRibbonBackstageItems {
    BlockedRibbonItemConfigCollection^ get () sealed;
}

Property Value

Type: BlockedRibbonItemConfigCollection

Implements

IBlockedRibbonItemsSectionBlockedRibbonBackstageItems
See Also

Reference

BlockedRibbonItemsSection Class
VisualComponents.UX.Shared Namespace


BlockedRibbonItemsSection.BlockedRibbonGroups Property

BlockedRibbonItemsSectionBlockedRibbonGroups Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BlockedRibbonItemConfigCollection BlockedRibbonGroups { get; }
public:
virtual property BlockedRibbonItemConfigCollection^ BlockedRibbonGroups {
    BlockedRibbonItemConfigCollection^ get () sealed;
}

Property Value

Type: BlockedRibbonItemConfigCollection

Implements

IBlockedRibbonItemsSectionBlockedRibbonGroups
See Also

Reference

BlockedRibbonItemsSection Class
VisualComponents.UX.Shared Namespace


BlockedRibbonItemsSection.BlockedRibbonTabs Property

BlockedRibbonItemsSectionBlockedRibbonTabs Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BlockedRibbonItemConfigCollection BlockedRibbonTabs { get; }
public:
virtual property BlockedRibbonItemConfigCollection^ BlockedRibbonTabs {
    BlockedRibbonItemConfigCollection^ get () sealed;
}

Property Value

Type: BlockedRibbonItemConfigCollection

Implements

IBlockedRibbonItemsSectionBlockedRibbonTabs
See Also

Reference

BlockedRibbonItemsSection Class
VisualComponents.UX.Shared Namespace


BlockedRibbonItemsSection.BlockedRibbonTools Property

BlockedRibbonItemsSectionBlockedRibbonTools Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BlockedRibbonItemConfigCollection BlockedRibbonTools { get; }
public:
virtual property BlockedRibbonItemConfigCollection^ BlockedRibbonTools {
    BlockedRibbonItemConfigCollection^ get () sealed;
}

Property Value

Type: BlockedRibbonItemConfigCollection

Implements

IBlockedRibbonItemsSectionBlockedRibbonTools
See Also

Reference

BlockedRibbonItemsSection Class
VisualComponents.UX.Shared Namespace


BlockedRibbonItemsSection.BlockedToolsNotInRibbonItems Property

BlockedRibbonItemsSectionBlockedToolsNotInRibbonItems Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BlockedRibbonItemConfigCollection BlockedToolsNotInRibbonItems { get; }
public:
virtual property BlockedRibbonItemConfigCollection^ BlockedToolsNotInRibbonItems {
    BlockedRibbonItemConfigCollection^ get () sealed;
}

Property Value

Type: BlockedRibbonItemConfigCollection

Implements

IBlockedRibbonItemsSectionBlockedToolsNotInRibbonItems
See Also

Reference

BlockedRibbonItemsSection Class
VisualComponents.UX.Shared Namespace


BlockedRibbonItemsSection.SectionName Property

BlockedRibbonItemsSectionSectionName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SectionName { get; }
public:
virtual property String^ SectionName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ISectionSectionName
See Also

Reference

BlockedRibbonItemsSection Class
VisualComponents.UX.Shared Namespace


BlockedRibbonItemsSection.SectionType Property

BlockedRibbonItemsSectionSectionType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type SectionType { get; }
public:
virtual property Type^ SectionType {
    Type^ get () sealed;
}

Property Value

Type: Type

Implements

ISectionSectionType
See Also

Reference

BlockedRibbonItemsSection Class
VisualComponents.UX.Shared Namespace


BlockedRibbonItemsSection.SectionVersion Property

BlockedRibbonItemsSectionSectionVersion Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int SectionVersion { get; }
public:
virtual property int SectionVersion {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISectionSectionVersion
See Also

Reference

BlockedRibbonItemsSection Class
VisualComponents.UX.Shared Namespace


BlockedRibbonItemsSection Methods

The BlockedRibbonItemsSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion |
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BlockedRibbonItemsSection Class
VisualComponents.UX.Shared Namespace


BlockedRibbonItemsSection.CheckVersion Method

BlockedRibbonItemsSectionCheckVersion Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CheckVersion()
public:
virtual void CheckVersion() sealed

Implements

ISectionCheckVersion
See Also

Reference

BlockedRibbonItemsSection Class
VisualComponents.UX.Shared Namespace


BlockedRibbonItemsSection.GetSection Method

BlockedRibbonItemsSectionGetSection Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISection GetSection(
    Configuration userSettingConfiguration
)
public:
virtual ISection^ GetSection(
    Configuration^ userSettingConfiguration
) sealed

Parameters

userSettingConfiguration
Type: System.ConfigurationConfiguration

Return Value

Type: ISection

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.BlockedRibbonItemsSection.GetSection(System.Configuration.Configuration)"]

Implements

ISectionGetSection(Configuration)
See Also

Reference

BlockedRibbonItemsSection Class
VisualComponents.UX.Shared Namespace


BoolToLeftMarginConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedBoolToLeftMarginConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class BoolToLeftMarginConverter : IValueConverter
public ref class BoolToLeftMarginConverter : IValueConverter

The BoolToLeftMarginConverter type exposes the following members.

Constructors
 | Name | Description
Public method | BoolToLeftMarginConverter | Initializes a new instance of the BoolToLeftMarginConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


BoolToLeftMarginConverter Constructor

Initializes a new instance of the BoolToLeftMarginConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BoolToLeftMarginConverter()
public:
BoolToLeftMarginConverter()
See Also

Reference

BoolToLeftMarginConverter Class
VisualComponents.UX.Shared Namespace


BoolToLeftMarginConverter Methods

The BoolToLeftMarginConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BoolToLeftMarginConverter Class
VisualComponents.UX.Shared Namespace


BoolToLeftMarginConverter.Convert Method

BoolToLeftMarginConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.BoolToLeftMarginConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

BoolToLeftMarginConverter Class
VisualComponents.UX.Shared Namespace


BoolToLeftMarginConverter.ConvertBack Method

BoolToLeftMarginConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.BoolToLeftMarginConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

BoolToLeftMarginConverter Class
VisualComponents.UX.Shared Namespace


BoolToListSortDirectionConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedBoolToListSortDirectionConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class BoolToListSortDirectionConverter : IValueConverter
public ref class BoolToListSortDirectionConverter : IValueConverter

The BoolToListSortDirectionConverter type exposes the following members.

Constructors
 | Name | Description
Public method | BoolToListSortDirectionConverter | Initializes a new instance of the BoolToListSortDirectionConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


BoolToListSortDirectionConverter Constructor

Initializes a new instance of the BoolToListSortDirectionConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BoolToListSortDirectionConverter()
public:
BoolToListSortDirectionConverter()
See Also

Reference

BoolToListSortDirectionConverter Class
VisualComponents.UX.Shared Namespace


BoolToListSortDirectionConverter Methods

The BoolToListSortDirectionConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BoolToListSortDirectionConverter Class
VisualComponents.UX.Shared Namespace


BoolToListSortDirectionConverter.Convert Method

BoolToListSortDirectionConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.BoolToListSortDirectionConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

BoolToListSortDirectionConverter Class
VisualComponents.UX.Shared Namespace


BoolToListSortDirectionConverter.ConvertBack Method

BoolToListSortDirectionConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.BoolToListSortDirectionConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

BoolToListSortDirectionConverter Class
VisualComponents.UX.Shared Namespace


BoundColumn Class

Custom column type for XamGrid which gives control of the actual data presentation to the column's CellStyle and establishes data binding to the property specified in Key attribute. Unlike TemplateColumn, this column will not try to bind itself (=> no more WPF exceptions) and does not require the property specified in Key attribute to exist in ViewModel.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
DependencyObjectNotifier
ColumnBase
Column
EditableColumn
TemplateColumn
VisualComponents.UX.SharedBoundColumn

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class BoundColumn : TemplateColumn
public ref class BoundColumn : public TemplateColumn

The BoundColumn type exposes the following members.

Constructors
 | Name | Description
Public method | BoundColumn | Initializes a new instance of the BoundColumn class
Top
Properties
 | Name | Description
Public property | ActualWidth | (Inherited from Column.)
Public property | AddNewRowCellStyle | (Inherited from Column.)
Public property | AddNewRowEditorTemplate | (Inherited from Column.)
Public property | AddNewRowEditorTemplateHorizontalContentAlignment | (Inherited from Column.)
Public property | AddNewRowEditorTemplateVerticalContentAlignment | (Inherited from Column.)
Public property | AddNewRowItemTemplate | (Inherited from Column.)
Public property | AddNewRowItemTemplateHorizontalContentAlignment | (Inherited from Column.)
Public property | AddNewRowItemTemplateVerticalContentAlignment | (Inherited from Column.)
Public property | AllColumns | (Inherited from Column.)
Public property | AllowCaseSensitiveSort | (Inherited from Column.)
Protected property | AllowCellEditorValueChangedFiltering | (Inherited from Column.)
Public property | AllowEditingValidation | (Inherited from EditableColumn.)
Public property | AllowToolTips | (Inherited from Column.)
Public property | AllVisibleChildColumns | (Inherited from Column.)
Protected property | CanBeFiltered | (Inherited from Column.)
Protected property | CanBeGroupedBy | (Inherited from Column.)
Protected property | CanBeSorted | (Inherited from Column.)
Public property | CellStyle | (Inherited from ColumnBase.)
Public property | CellStyleResolved | (Inherited from ColumnBase.)
Public property | ColumnLayout | (Inherited from ColumnBase.)
Public property | ConditionalFormatCollection | (Inherited from Column.)
Protected property | DataField | (Inherited from ColumnBase.)
Public property | DataType | (Inherited from ColumnBase.)
Protected property | DefaultFilterOperand | (Inherited from Column.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayNameResolved | (Inherited from ColumnBase.)
Public property | EditorHorizontalContentAlignment | (Inherited from EditableColumn.)
Public property | EditorStyle | (Inherited from EditableColumn.)
Public property | EditorTemplate | (Inherited from TemplateColumn.)
Public property | EditorValueConverter | (Inherited from TemplateColumn.)
Public property | EditorValueConverterParameter | (Inherited from TemplateColumn.)
Public property | EditorVerticalContentAlignment | (Inherited from EditableColumn.)
Public property | FilterColumnSettings | (Inherited from Column.)
Public property | FilterEditorTemplate | (Inherited from TemplateColumn.)
Public property | FilterItemTemplate | (Inherited from TemplateColumn.)
Protected property | FilterMenuCustomFilterString | (Inherited from TemplateColumn.)
Public property | FirstSortDirection | (Inherited from Column.)
Public property | FirstSortDirectionResolved | (Inherited from Column.)
Public property | FixedIndicatorDirection | (Inherited from Column.)
Public property | FixedIndicatorDirectionResolved | (Inherited from Column.)
Public property | FooterStyle | (Inherited from ColumnBase.)
Public property | FooterStyleResolved | (Inherited from ColumnBase.)
Public property | FooterTemplate | (Inherited from Column.)
Public property | FooterText | (Inherited from Column.)
Protected property | FormatStringResolved | (Inherited from Column.)
Public property | GroupByComparer | (Inherited from Column.)
Public property | GroupByHeaderStyle | (Inherited from Column.)
Public property | GroupByItemTemplate | (Inherited from Column.)
Public property | GroupByRowStyle | (Inherited from Column.)
Public property | HeaderStyle | (Inherited from ColumnBase.)
Public property | HeaderStyleResolved | (Inherited from ColumnBase.)
Public property | HeaderTemplate | (Inherited from ColumnBase.)
Public property | HeaderText | (Inherited from ColumnBase.)
Public property | HeaderTextHorizontalAlignment | (Inherited from Column.)
Public property | HeaderTextHorizontalAlignmentResolved | (Inherited from Column.)
Public property | HeaderTextVerticalAlignment | (Inherited from Column.)
Public property | HeaderTextVerticalAlignmentResolved | (Inherited from Column.)
Public property | HorizontalContentAlignment | (Inherited from Column.)
Public property | IsAutoGenerated | (Inherited from ColumnBase.)
Protected property | IsEditable | (Inherited from TemplateColumn.)
Public property | IsFilterable | (Inherited from Column.)
Public property | IsFixable | (Inherited from Column.)
Public property | IsFixed | (Inherited from Column.)
Public property | IsGroupable | (Inherited from Column.)
Public property | IsGroupBy | (Inherited from Column.)
Public property | IsHideable | (Inherited from ColumnBase.)
Public property | IsMovable | (Inherited from Column.)
Public property | IsReadOnly | (Inherited from EditableColumn.)
Public property | IsResizable | (Inherited from Column.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelected | (Inherited from Column.)
Public property | IsSortable | (Inherited from TemplateColumn.)
Public property | IsSorted | (Inherited from Column.)
Public property | IsSummable | (Inherited from Column.)
Public property | ItemTemplate | (Inherited from TemplateColumn.)
Public property | Key | (Inherited from ColumnBase.)
Public property | MaximumWidth | (Inherited from Column.)
Public property | MergeCellStyle | (Inherited from Column.)
Public property | MergedItemTemplate | (Inherited from Column.)
Public property | MinimumWidth | (Inherited from Column.)
Protected property | ParentColumn | (Inherited from Column.)
Protected property | PriorityProperties | (Inherited from ColumnBase.)
Protected property | PropertiesToIgnore | (Inherited from Column.)
Protected property | RequiresBoundDataKey | Property specified in Key attribute does not have to exist. If it does not exist, the binding will not be established for the cells. (Overrides ColumnBase.RequiresBoundDataKey.)
Protected property | RequiresFullRedrawOnEditorStyleUpdate | (Inherited from EditableColumn.)
Protected property | ResetCellValueObjectAfterEditing | (Inherited from Column.)
Protected property | ResizeColumnResolved | (Inherited from Column.)
Public property | SortComparer | (Inherited from Column.)
Public property | SummaryColumnSettings | (Inherited from Column.)
Protected property | SupportsActivationAndSelection | (Inherited from Column.)
Protected property | SupportsHeaderFooterContent | (Inherited from Column.)
Public property | Tag | (Inherited from ColumnBase.)
Public property | ToolTipContentTemplate | (Inherited from Column.)
Public property | ToolTipStyle | (Inherited from Column.)
Protected property | TopParentColumn | (Inherited from Column.)
Protected property | UniqueColumnContent | (Inherited from TemplateColumn.)
Protected property | UseReadOnlyFlag | (Inherited from TemplateColumn.)
Public property | ValueConverter | (Inherited from TemplateColumn.)
Public property | ValueConverterParameter | (Inherited from TemplateColumn.)
Public property | VerticalContentAlignment | (Inherited from Column.)
Public property | Width | (Inherited from Column.)
Public property | WidthResolved | (Inherited from Column.)
Public property | Visibility | (Inherited from ColumnBase.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | FillAvailableFilters | (Inherited from TemplateColumn.)
Protected method | FillAvailableSummaries | (Inherited from Column.)
Protected method | FillFilterMenuOptions | (Inherited from TemplateColumn.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinishedLoadingPersistence | (Inherited from ColumnBase.)
Protected method | GenerateCell | (Inherited from Column.)
Protected method | GenerateContentProvider | Generates control template for its Cell objects. (Overrides TemplateColumn.GenerateContentProvider.)
Protected method | GenerateDataCell | (Inherited from Column.)
Protected method | GenerateFilterSelectionControl | (Inherited from Column.)
Protected method | GenerateFooterCell | (Inherited from Column.)
Protected method | GenerateHeaderCell | (Inherited from Column.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisibility | (Inherited from Column.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnColumnLayoutChanged | (Inherited from Column.)
Protected method | OnDataTypeChanged | (Inherited from TemplateColumn.)
Protected method | OnPropertyChanged(String) | (Inherited from DependencyObjectNotifier.)
Protected method | OnPropertyChanged(DependencyPropertyChangedEventArgs) | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from DependencyObject.)
Protected method | OnShowAvailableColumnFilterOperands | (Inherited from Column.)
Protected method | OnStyleChanged | (Inherited from ColumnBase.)
Protected method | OnVisibilityChanged | (Inherited from Column.)
Protected method | RaisePropertyChangedEvent(String) | (Inherited from DependencyObjectNotifier.)
Protected method | RaisePropertyChangedEvent(String, Object, PropertyChangedEventArgs) | Obsolete. (Inherited from DependencyObjectNotifier.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ResolveChildColumns | (Inherited from Column.)
Protected method | ResolveValue(Object) | (Inherited from ColumnBase.)
Protected method | ResolveValue(Object, CultureInfo) | (Inherited from ColumnBase.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Protected method | SetSelected | (Inherited from Column.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | ValidateGroupByComparer | (Inherited from Column.)
Protected method | ValidateSortComparer | (Inherited from Column.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from DependencyObjectNotifier.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


BoundColumn Constructor

Initializes a new instance of the BoundColumn class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BoundColumn()
public:
BoundColumn()
See Also

Reference

BoundColumn Class
VisualComponents.UX.Shared Namespace


BoundColumn Properties

The BoundColumn type exposes the following members.

Properties
 | Name | Description
Public property | ActualWidth | (Inherited from Column.)
Public property | AddNewRowCellStyle | (Inherited from Column.)
Public property | AddNewRowEditorTemplate | (Inherited from Column.)
Public property | AddNewRowEditorTemplateHorizontalContentAlignment | (Inherited from Column.)
Public property | AddNewRowEditorTemplateVerticalContentAlignment | (Inherited from Column.)
Public property | AddNewRowItemTemplate | (Inherited from Column.)
Public property | AddNewRowItemTemplateHorizontalContentAlignment | (Inherited from Column.)
Public property | AddNewRowItemTemplateVerticalContentAlignment | (Inherited from Column.)
Public property | AllColumns | (Inherited from Column.)
Public property | AllowCaseSensitiveSort | (Inherited from Column.)
Protected property | AllowCellEditorValueChangedFiltering | (Inherited from Column.)
Public property | AllowEditingValidation | (Inherited from EditableColumn.)
Public property | AllowToolTips | (Inherited from Column.)
Public property | AllVisibleChildColumns | (Inherited from Column.)
Protected property | CanBeFiltered | (Inherited from Column.)
Protected property | CanBeGroupedBy | (Inherited from Column.)
Protected property | CanBeSorted | (Inherited from Column.)
Public property | CellStyle | (Inherited from ColumnBase.)
Public property | CellStyleResolved | (Inherited from ColumnBase.)
Public property | ColumnLayout | (Inherited from ColumnBase.)
Public property | ConditionalFormatCollection | (Inherited from Column.)
Protected property | DataField | (Inherited from ColumnBase.)
Public property | DataType | (Inherited from ColumnBase.)
Protected property | DefaultFilterOperand | (Inherited from Column.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayNameResolved | (Inherited from ColumnBase.)
Public property | EditorHorizontalContentAlignment | (Inherited from EditableColumn.)
Public property | EditorStyle | (Inherited from EditableColumn.)
Public property | EditorTemplate | (Inherited from TemplateColumn.)
Public property | EditorValueConverter | (Inherited from TemplateColumn.)
Public property | EditorValueConverterParameter | (Inherited from TemplateColumn.)
Public property | EditorVerticalContentAlignment | (Inherited from EditableColumn.)
Public property | FilterColumnSettings | (Inherited from Column.)
Public property | FilterEditorTemplate | (Inherited from TemplateColumn.)
Public property | FilterItemTemplate | (Inherited from TemplateColumn.)
Protected property | FilterMenuCustomFilterString | (Inherited from TemplateColumn.)
Public property | FirstSortDirection | (Inherited from Column.)
Public property | FirstSortDirectionResolved | (Inherited from Column.)
Public property | FixedIndicatorDirection | (Inherited from Column.)
Public property | FixedIndicatorDirectionResolved | (Inherited from Column.)
Public property | FooterStyle | (Inherited from ColumnBase.)
Public property | FooterStyleResolved | (Inherited from ColumnBase.)
Public property | FooterTemplate | (Inherited from Column.)
Public property | FooterText | (Inherited from Column.)
Protected property | FormatStringResolved | (Inherited from Column.)
Public property | GroupByComparer | (Inherited from Column.)
Public property | GroupByHeaderStyle | (Inherited from Column.)
Public property | GroupByItemTemplate | (Inherited from Column.)
Public property | GroupByRowStyle | (Inherited from Column.)
Public property | HeaderStyle | (Inherited from ColumnBase.)
Public property | HeaderStyleResolved | (Inherited from ColumnBase.)
Public property | HeaderTemplate | (Inherited from ColumnBase.)
Public property | HeaderText | (Inherited from ColumnBase.)
Public property | HeaderTextHorizontalAlignment | (Inherited from Column.)
Public property | HeaderTextHorizontalAlignmentResolved | (Inherited from Column.)
Public property | HeaderTextVerticalAlignment | (Inherited from Column.)
Public property | HeaderTextVerticalAlignmentResolved | (Inherited from Column.)
Public property | HorizontalContentAlignment | (Inherited from Column.)
Public property | IsAutoGenerated | (Inherited from ColumnBase.)
Protected property | IsEditable | (Inherited from TemplateColumn.)
Public property | IsFilterable | (Inherited from Column.)
Public property | IsFixable | (Inherited from Column.)
Public property | IsFixed | (Inherited from Column.)
Public property | IsGroupable | (Inherited from Column.)
Public property | IsGroupBy | (Inherited from Column.)
Public property | IsHideable | (Inherited from ColumnBase.)
Public property | IsMovable | (Inherited from Column.)
Public property | IsReadOnly | (Inherited from EditableColumn.)
Public property | IsResizable | (Inherited from Column.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelected | (Inherited from Column.)
Public property | IsSortable | (Inherited from TemplateColumn.)
Public property | IsSorted | (Inherited from Column.)
Public property | IsSummable | (Inherited from Column.)
Public property | ItemTemplate | (Inherited from TemplateColumn.)
Public property | Key | (Inherited from ColumnBase.)
Public property | MaximumWidth | (Inherited from Column.)
Public property | MergeCellStyle | (Inherited from Column.)
Public property | MergedItemTemplate | (Inherited from Column.)
Public property | MinimumWidth | (Inherited from Column.)
Protected property | ParentColumn | (Inherited from Column.)
Protected property | PriorityProperties | (Inherited from ColumnBase.)
Protected property | PropertiesToIgnore | (Inherited from Column.)
Protected property | RequiresBoundDataKey | Property specified in Key attribute does not have to exist. If it does not exist, the binding will not be established for the cells. (Overrides ColumnBase.RequiresBoundDataKey.)
Protected property | RequiresFullRedrawOnEditorStyleUpdate | (Inherited from EditableColumn.)
Protected property | ResetCellValueObjectAfterEditing | (Inherited from Column.)
Protected property | ResizeColumnResolved | (Inherited from Column.)
Public property | SortComparer | (Inherited from Column.)
Public property | SummaryColumnSettings | (Inherited from Column.)
Protected property | SupportsActivationAndSelection | (Inherited from Column.)
Protected property | SupportsHeaderFooterContent | (Inherited from Column.)
Public property | Tag | (Inherited from ColumnBase.)
Public property | ToolTipContentTemplate | (Inherited from Column.)
Public property | ToolTipStyle | (Inherited from Column.)
Protected property | TopParentColumn | (Inherited from Column.)
Protected property | UniqueColumnContent | (Inherited from TemplateColumn.)
Protected property | UseReadOnlyFlag | (Inherited from TemplateColumn.)
Public property | ValueConverter | (Inherited from TemplateColumn.)
Public property | ValueConverterParameter | (Inherited from TemplateColumn.)
Public property | VerticalContentAlignment | (Inherited from Column.)
Public property | Width | (Inherited from Column.)
Public property | WidthResolved | (Inherited from Column.)
Public property | Visibility | (Inherited from ColumnBase.)
Top
See Also

Reference

BoundColumn Class
VisualComponents.UX.Shared Namespace


BoundColumn.RequiresBoundDataKey Property

BoundColumnRequiresBoundDataKey Property

Property specified in Key attribute does not have to exist. If it does not exist, the binding will not be established for the cells.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override bool RequiresBoundDataKey { get; }
protected:
virtual property bool RequiresBoundDataKey {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

BoundColumn Class
VisualComponents.UX.Shared Namespace


BoundColumn Methods

The BoundColumn type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | FillAvailableFilters | (Inherited from TemplateColumn.)
Protected method | FillAvailableSummaries | (Inherited from Column.)
Protected method | FillFilterMenuOptions | (Inherited from TemplateColumn.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FinishedLoadingPersistence | (Inherited from ColumnBase.)
Protected method | GenerateCell | (Inherited from Column.)
Protected method | GenerateContentProvider | Generates control template for its Cell objects. (Overrides TemplateColumn.GenerateContentProvider.)
Protected method | GenerateDataCell | (Inherited from Column.)
Protected method | GenerateFilterSelectionControl | (Inherited from Column.)
Protected method | GenerateFooterCell | (Inherited from Column.)
Protected method | GenerateHeaderCell | (Inherited from Column.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvalidateVisibility | (Inherited from Column.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnColumnLayoutChanged | (Inherited from Column.)
Protected method | OnDataTypeChanged | (Inherited from TemplateColumn.)
Protected method | OnPropertyChanged(String) | (Inherited from DependencyObjectNotifier.)
Protected method | OnPropertyChanged(DependencyPropertyChangedEventArgs) | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from DependencyObject.)
Protected method | OnShowAvailableColumnFilterOperands | (Inherited from Column.)
Protected method | OnStyleChanged | (Inherited from ColumnBase.)
Protected method | OnVisibilityChanged | (Inherited from Column.)
Protected method | RaisePropertyChangedEvent(String) | (Inherited from DependencyObjectNotifier.)
Protected method | RaisePropertyChangedEvent(String, Object, PropertyChangedEventArgs) | Obsolete. (Inherited from DependencyObjectNotifier.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ResolveChildColumns | (Inherited from Column.)
Protected method | ResolveValue(Object) | (Inherited from ColumnBase.)
Protected method | ResolveValue(Object, CultureInfo) | (Inherited from ColumnBase.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Protected method | SetSelected | (Inherited from Column.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | ValidateGroupByComparer | (Inherited from Column.)
Protected method | ValidateSortComparer | (Inherited from Column.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BoundColumn Class
VisualComponents.UX.Shared Namespace


BoundColumn.GenerateContentProvider Method

BoundColumnGenerateContentProvider Method

Generates control template for its Cell objects.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override ColumnContentProviderBase GenerateContentProvider()
protected:
virtual ColumnContentProviderBase^ GenerateContentProvider() override

Return Value

Type: ColumnContentProviderBase

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.BoundColumn.GenerateContentProvider"]

See Also

Reference

BoundColumn Class
VisualComponents.UX.Shared Namespace


BoundColumn Events

The BoundColumn type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from DependencyObjectNotifier.)
Top
See Also

Reference

BoundColumn Class
VisualComponents.UX.Shared Namespace


BoundColumnContentProvider Class

Provides content to Cell objects residing in BoundColumn
Inheritance Hierarchy
SystemObject
ColumnContentProviderBase
TemplateColumnContentProvider
VisualComponents.UX.SharedBoundColumnContentProvider

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class BoundColumnContentProvider : TemplateColumnContentProvider
public ref class BoundColumnContentProvider : public TemplateColumnContentProvider

The BoundColumnContentProvider type exposes the following members.

Constructors
 | Name | Description
Public method | BoundColumnContentProvider | Initializes a new instance of the BoundColumnContentProvider class
Top
Properties
 | Name | Description
Protected property | CanResolveValueFromEditor | (Inherited from TemplateColumnContentProvider.)
Public property | IsToolTip | (Inherited from ColumnContentProviderBase.)
Public property | RemovePaddingDuringEditing | (Inherited from TemplateColumnContentProvider.)
Top
Methods
 | Name | Description
Public method | AdjustDisplayElement | (Inherited from TemplateColumnContentProvider.)
Protected method | ApplyAddNewRowEditorTemplate | (Inherited from TemplateColumnContentProvider.)
Protected method | ApplyAddNewRowItemTemplate | (Inherited from ColumnContentProviderBase.)
Public method | ApplyFormatting | (Inherited from ColumnContentProviderBase.)
Public method | EditorLoaded | (Inherited from ColumnContentProviderBase.)
Public method | EditorRemoved | (Inherited from TemplateColumnContentProvider.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FocusEditor | (Inherited from TemplateColumnContentProvider.)
Public method | GenerateGroupByCellContent | (Inherited from ColumnContentProviderBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotifyEditorValueChanged | (Inherited from ColumnContentProviderBase.)
Public method | ResetContent | (Inherited from TemplateColumnContentProvider.)
Protected method | ResolveBinding | (Inherited from ColumnContentProviderBase.)
Public method | ResolveDisplayElement | (Overrides TemplateColumnContentProvider.ResolveDisplayElement(Cell, Binding).)
Protected method | ResolveDisplayElementInternal(Cell, Binding) | (Inherited from ColumnContentProviderBase.)
Protected method | ResolveDisplayElementInternal(Cell, Binding, RowType) | (Inherited from ColumnContentProviderBase.)
Public method | ResolveEditor | (Inherited from ColumnContentProviderBase.)
Protected method | ResolveEditorBinding | (Inherited from ColumnContentProviderBase.)
Protected method | ResolveEditorControl | (Inherited from TemplateColumnContentProvider.)
Protected method | ResolveEditorControlInternal | (Inherited from ColumnContentProviderBase.)
Public method | ResolveValueFromEditor | (Inherited from TemplateColumnContentProvider.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


BoundColumnContentProvider Constructor

Initializes a new instance of the BoundColumnContentProvider class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BoundColumnContentProvider()
public:
BoundColumnContentProvider()
See Also

Reference

BoundColumnContentProvider Class
VisualComponents.UX.Shared Namespace


BoundColumnContentProvider Properties

The BoundColumnContentProvider type exposes the following members.

Properties
 | Name | Description
Protected property | CanResolveValueFromEditor | (Inherited from TemplateColumnContentProvider.)
Public property | IsToolTip | (Inherited from ColumnContentProviderBase.)
Public property | RemovePaddingDuringEditing | (Inherited from TemplateColumnContentProvider.)
Top
See Also

Reference

BoundColumnContentProvider Class
VisualComponents.UX.Shared Namespace


BoundColumnContentProvider Methods

The BoundColumnContentProvider type exposes the following members.

Methods
 | Name | Description
Public method | AdjustDisplayElement | (Inherited from TemplateColumnContentProvider.)
Protected method | ApplyAddNewRowEditorTemplate | (Inherited from TemplateColumnContentProvider.)
Protected method | ApplyAddNewRowItemTemplate | (Inherited from ColumnContentProviderBase.)
Public method | ApplyFormatting | (Inherited from ColumnContentProviderBase.)
Public method | EditorLoaded | (Inherited from ColumnContentProviderBase.)
Public method | EditorRemoved | (Inherited from TemplateColumnContentProvider.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FocusEditor | (Inherited from TemplateColumnContentProvider.)
Public method | GenerateGroupByCellContent | (Inherited from ColumnContentProviderBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotifyEditorValueChanged | (Inherited from ColumnContentProviderBase.)
Public method | ResetContent | (Inherited from TemplateColumnContentProvider.)
Protected method | ResolveBinding | (Inherited from ColumnContentProviderBase.)
Public method | ResolveDisplayElement | (Overrides TemplateColumnContentProvider.ResolveDisplayElement(Cell, Binding).)
Protected method | ResolveDisplayElementInternal(Cell, Binding) | (Inherited from ColumnContentProviderBase.)
Protected method | ResolveDisplayElementInternal(Cell, Binding, RowType) | (Inherited from ColumnContentProviderBase.)
Public method | ResolveEditor | (Inherited from ColumnContentProviderBase.)
Protected method | ResolveEditorBinding | (Inherited from ColumnContentProviderBase.)
Protected method | ResolveEditorControl | (Inherited from TemplateColumnContentProvider.)
Protected method | ResolveEditorControlInternal | (Inherited from ColumnContentProviderBase.)
Public method | ResolveValueFromEditor | (Inherited from TemplateColumnContentProvider.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BoundColumnContentProvider Class
VisualComponents.UX.Shared Namespace


BoundColumnContentProvider.ResolveDisplayElement Method

BoundColumnContentProviderResolveDisplayElement Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override FrameworkElement ResolveDisplayElement(
    Cell cell,
    Binding cellBinding
)
public:
virtual FrameworkElement^ ResolveDisplayElement(
    Cell^ cell,
    Binding^ cellBinding
) override

Parameters

cell
Type: Cell
cellBinding
Type: System.Windows.DataBinding

Return Value

Type: FrameworkElement

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.BoundColumnContentProvider.ResolveDisplayElement(Infragistics.Controls.Grids.Cell,System.Windows.Data.Binding)"]

See Also

Reference

BoundColumnContentProvider Class
VisualComponents.UX.Shared Namespace


BusyScope Class

BusyScope is to be used with using -keyword. While it is active, OverrideCursor is set to use the Wait cursor.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedBusyScope

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class BusyScope : IDisposable
public ref class BusyScope : IDisposable

The BusyScope type exposes the following members.

Constructors
 | Name | Description
Public method | BusyScope | Use this constructor to indicate a busy state without showing a progress window.
Public method | BusyScope(IApplication) | Use this constructor to indicate a busy state without showing a progress window.
Public method | BusyScope(Boolean, String, IApplication) | Use this constructor to indicate a busy state and optionally allow showing a progress window.
Public method | BusyScope(Boolean, String, IApplication, Boolean) | Initializes a new instance of the BusyScope class
Public method | BusyScope(Boolean, String, IApplication, Boolean, Boolean) | Initializes a new instance of the BusyScope class
Public method | BusyScope(Boolean, String, IApplication, Boolean, Boolean, Boolean) | Initializes a new instance of the BusyScope class
Top
Properties
 | Name | Description
 | DisableProgressBarUpdating |
 | OpenDialogs | A list of all currently open progress dialogs.
Public property | ProgressDialog | Obsolete.
Public property | ProgressDialog2 | Obsolete.
Public property | ReThrowExceptions | Obsolete. If true, any exception thrown by the Task will be caught and rethrown from either ShowDialog() or Dispose().
Public property | Task | Obsolete.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the BusyScope
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RestoreMouseCursor | Resets OverrideCursor to the value it had when this instance was created.
Protected method | RethrowExceptionMechanism | If RunTaskMechanism(Task, Boolean) throws an exception, and the rethrow mechanism is enabled, then this method does the rethrow. The default implementation will wrap the Exception into a AggregateException.
Protected method | RunTaskMechanism | This method is responsible for actually running the Task. Exceptions thrown by this method are either passed to the caller or rethrown in RethrowExceptionMechanism(Exception). The default implementation can throw anything thrown by RunSynchronously or Wait.
Public method | Show | Shows the progress window (if allowed). Returns without waiting for the window to close.
Public method | Show(Boolean) | Shows the progress window (if allowed). Returns without waiting for the window to close.
Public method | ShowDialog(Task) | Shows the progress window (if allowed) and runs taskToRun synchronously. The window is closed after taskToRun is finished. Can throw anything thrown by RunTaskMechanism(Task, Boolean) or RethrowExceptionMechanism(Exception). For reporting progress, see ProgressContext.
Public method | ShowDialog(Task, Task) | Shows the progress window (if allowed) and runs taskToRun synchronously. The window is closed after taskToRun is finished. Can throw anything thrown by RunTaskMechanism(Task, Boolean) or RethrowExceptionMechanism(Exception). For reporting progress, see ProgressContext.
 | StartTrackingBackgroundProgress |
 | StopTrackingBackgroundProgress |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateProgress |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Examples
Copy
using (new BusyScope())
{
   // ...do time consuming work
}
Examples
Copy
using (var bs = new BusyScope(true, "Doing the Work", _application))
{
   var actionTask = new Task(() =>
   {
       _application.ProgressContext.Value = 0.0;
       _application.ProgressContext.Status = "Doing work";

       int progress = 0;
       while (progress < 100)
       {
           // ... do work here
           progress++;
           _application.ProgressContext.Value = ((double)progress/100.0);
       }
   });

   bs.ShowDialog(actionTask);
}
See Also

Reference

VisualComponents.UX.Shared Namespace


BusyScope Constructor

Overload List
 | Name | Description
Public method | BusyScope | Use this constructor to indicate a busy state without showing a progress window.
Public method | BusyScope(IApplication) | Use this constructor to indicate a busy state without showing a progress window.
Public method | BusyScope(Boolean, String, IApplication) | Use this constructor to indicate a busy state and optionally allow showing a progress window.
Public method | BusyScope(Boolean, String, IApplication, Boolean) | Initializes a new instance of the BusyScope class
Public method | BusyScope(Boolean, String, IApplication, Boolean, Boolean) | Initializes a new instance of the BusyScope class
Public method | BusyScope(Boolean, String, IApplication, Boolean, Boolean, Boolean) | Initializes a new instance of the BusyScope class
Top
See Also

Reference

BusyScope Class
VisualComponents.UX.Shared Namespace


BusyScope Constructor

Use this constructor to indicate a busy state without showing a progress window.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BusyScope()
public:
BusyScope()
See Also

Reference

BusyScope Class
BusyScope Overload
VisualComponents.UX.Shared Namespace


BusyScope Constructor (IApplication)

Use this constructor to indicate a busy state without showing a progress window.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BusyScope(
    IApplication application
)
public:
BusyScope(
    IApplication^ application
)

Parameters

application
Type: VisualComponents.Create3DIApplication
See Also

Reference

BusyScope Class
BusyScope Overload
VisualComponents.UX.Shared Namespace


BusyScope Constructor (Boolean, String, IApplication)

Use this constructor to indicate a busy state and optionally allow showing a progress window.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BusyScope(
    bool showProgressBarDialog,
    string progressBarDialogTitle,
    IApplication application
)
public:
BusyScope(
    bool showProgressBarDialog,
    String^ progressBarDialogTitle,
    IApplication^ application
)

Parameters

showProgressBarDialog
Type: SystemBoolean
If true, will allow showing a progress window.
progressBarDialogTitle
Type: SystemString
The title for the window.
application
Type: VisualComponents.Create3DIApplication
IApplication instance to use.
See Also

Reference

BusyScope Class
BusyScope Overload
VisualComponents.UX.Shared Namespace


BusyScope Constructor (Boolean, String, IApplication, Boolean)

Initializes a new instance of the BusyScope class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BusyScope(
    bool showProgressBarDialog,
    string progressBarDialogTitle,
    IApplication application,
    bool isSynchronous
)
public:
BusyScope(
    bool showProgressBarDialog,
    String^ progressBarDialogTitle,
    IApplication^ application,
    bool isSynchronous
)

Parameters

showProgressBarDialog
Type: SystemBoolean
progressBarDialogTitle
Type: SystemString
application
Type: VisualComponents.Create3DIApplication
isSynchronous
Type: SystemBoolean
See Also

Reference

BusyScope Class
BusyScope Overload
VisualComponents.UX.Shared Namespace


BusyScope Constructor (Boolean, String, IApplication, Boolean, Boolean)

Initializes a new instance of the BusyScope class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BusyScope(
    bool showProgressBarDialog,
    string progressBarDialogTitle,
    IApplication application,
    bool isSynchronous,
    bool isInDeterminate
)
public:
BusyScope(
    bool showProgressBarDialog,
    String^ progressBarDialogTitle,
    IApplication^ application,
    bool isSynchronous,
    bool isInDeterminate
)

Parameters

showProgressBarDialog
Type: SystemBoolean
progressBarDialogTitle
Type: SystemString
application
Type: VisualComponents.Create3DIApplication
isSynchronous
Type: SystemBoolean
isInDeterminate
Type: SystemBoolean
See Also

Reference

BusyScope Class
BusyScope Overload
VisualComponents.UX.Shared Namespace


BusyScope Constructor (Boolean, String, IApplication, Boolean, Boolean, Boolean)

Initializes a new instance of the BusyScope class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BusyScope(
    bool showProgressBarDialog,
    string progressBarDialogTitle,
    IApplication application,
    bool isSynchronous,
    bool isInDeterminate,
    bool old
)
public:
BusyScope(
    bool showProgressBarDialog,
    String^ progressBarDialogTitle,
    IApplication^ application,
    bool isSynchronous,
    bool isInDeterminate,
    bool old
)

Parameters

showProgressBarDialog
Type: SystemBoolean
progressBarDialogTitle
Type: SystemString
application
Type: VisualComponents.Create3DIApplication
isSynchronous
Type: SystemBoolean
isInDeterminate
Type: SystemBoolean
old
Type: SystemBoolean
See Also

Reference

BusyScope Class
BusyScope Overload
VisualComponents.UX.Shared Namespace


BusyScope Properties

The BusyScope type exposes the following members.

Properties
 | Name | Description
 | DisableProgressBarUpdating |
 | OpenDialogs | A list of all currently open progress dialogs.
Public property | ProgressDialog | Obsolete.
Public property | ProgressDialog2 | Obsolete.
Public property | ReThrowExceptions | Obsolete. If true, any exception thrown by the Task will be caught and rethrown from either ShowDialog() or Dispose().
Public property | Task | Obsolete.
Top
See Also

Reference

BusyScope Class
VisualComponents.UX.Shared Namespace


BusyScope.DisableProgressBarUpdating Property

BusyScopeDisableProgressBarUpdating Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool DisableProgressBarUpdating { get; set; }
public:
static property bool DisableProgressBarUpdating {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

BusyScope Class
VisualComponents.UX.Shared Namespace


BusyScope.OpenDialogs Property

BusyScopeOpenDialogs Property

A list of all currently open progress dialogs.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IList<Window> OpenDialogs { get; }
public:
static property IList<Window^>^ OpenDialogs {
    IList<Window^>^ get ();
}

Property Value

Type: IListWindow
See Also

Reference

BusyScope Class
VisualComponents.UX.Shared Namespace


BusyScope.ProgressDialog Property

BusyScopeProgressDialog Property

Note: This API is now obsolete.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Please use the ShowDialog and Show methods instead.")]
public ProgressDialog ProgressDialog { get; set; }
public:
[ObsoleteAttribute(L"Please use the ShowDialog and Show methods instead.")]
property ProgressDialog^ ProgressDialog {
    ProgressDialog^ get ();
    void set (ProgressDialog^ value);
}

Property Value

Type: ProgressDialog
See Also

Reference

BusyScope Class
VisualComponents.UX.Shared Namespace


BusyScope.ProgressDialog2 Property

BusyScopeProgressDialog2 Property

Note: This API is now obsolete.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Please use the ShowDialog and Show methods instead.")]
public ProgressDialog2 ProgressDialog2 { get; set; }
public:
[ObsoleteAttribute(L"Please use the ShowDialog and Show methods instead.")]
property ProgressDialog2^ ProgressDialog2 {
    ProgressDialog2^ get ();
    void set (ProgressDialog2^ value);
}

Property Value

Type: ProgressDialog2
See Also

Reference

BusyScope Class
VisualComponents.UX.Shared Namespace


BusyScope.ReThrowExceptions Property

BusyScopeReThrowExceptions Property

Note: This API is now obsolete.

If true, any exception thrown by the Task will be caught and rethrown from either ShowDialog() or Dispose().

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Not necessary anymore. Exceptions have to be rethrown if the dialog is modal. If not, then this is initialized to false.")]
public bool ReThrowExceptions { get; set; }
public:
[ObsoleteAttribute(L"Not necessary anymore. Exceptions have to be rethrown if the dialog is modal. If not, then this is initialized to false.")]
property bool ReThrowExceptions {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

BusyScope Class
VisualComponents.UX.Shared Namespace


BusyScope.Task Property

BusyScopeTask Property

Note: This API is now obsolete.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Please use the ShowDialog method instead.")]
public Task Task { get; set; }
public:
[ObsoleteAttribute(L"Please use the ShowDialog method instead.")]
property Task^ Task {
    Task^ get ();
    void set (Task^ value);
}

Property Value

Type: Task
See Also

Reference

BusyScope Class
VisualComponents.UX.Shared Namespace


BusyScope Methods

The BusyScope type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RestoreMouseCursor | Resets OverrideCursor to the value it had when this instance was created.
Protected method | RethrowExceptionMechanism | If RunTaskMechanism(Task, Boolean) throws an exception, and the rethrow mechanism is enabled, then this method does the rethrow. The default implementation will wrap the Exception into a AggregateException.
Protected method | RunTaskMechanism | This method is responsible for actually running the Task. Exceptions thrown by this method are either passed to the caller or rethrown in RethrowExceptionMechanism(Exception). The default implementation can throw anything thrown by RunSynchronously or Wait.
Public method | Show | Shows the progress window (if allowed). Returns without waiting for the window to close.
Public method | Show(Boolean) | Shows the progress window (if allowed). Returns without waiting for the window to close.
Public method | ShowDialog(Task) | Shows the progress window (if allowed) and runs taskToRun synchronously. The window is closed after taskToRun is finished. Can throw anything thrown by RunTaskMechanism(Task, Boolean) or RethrowExceptionMechanism(Exception). For reporting progress, see ProgressContext.
Public method | ShowDialog(Task, Task) | Shows the progress window (if allowed) and runs taskToRun synchronously. The window is closed after taskToRun is finished. Can throw anything thrown by RunTaskMechanism(Task, Boolean) or RethrowExceptionMechanism(Exception). For reporting progress, see ProgressContext.
 | StartTrackingBackgroundProgress |
 | StopTrackingBackgroundProgress |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateProgress |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

BusyScope Class
VisualComponents.UX.Shared Namespace


BusyScope.Dispose Method

BusyScopeDispose Method

Releases all resources used by the BusyScope

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Dispose()
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

BusyScope Class
VisualComponents.UX.Shared Namespace


BusyScope.RestoreMouseCursor Method

BusyScopeRestoreMouseCursor Method

Resets OverrideCursor to the value it had when this instance was created.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RestoreMouseCursor()
public:
void RestoreMouseCursor()
See Also

Reference

BusyScope Class
VisualComponents.UX.Shared Namespace


BusyScope.RethrowExceptionMechanism Method

BusyScopeRethrowExceptionMechanism Method

If RunTaskMechanism(Task, Boolean) throws an exception, and the rethrow mechanism is enabled, then this method does the rethrow.

The default implementation will wrap the Exception into a AggregateException.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void RethrowExceptionMechanism(
    Exception exception
)
protected:
virtual void RethrowExceptionMechanism(
    Exception^ exception
)

Parameters

exception
Type: SystemException
Exceptions
Exception | Condition
AggregateException |
See Also

Reference

BusyScope Class
VisualComponents.UX.Shared Namespace


BusyScope.RunTaskMechanism Method

BusyScopeRunTaskMechanism Method

This method is responsible for actually running the Task.

Exceptions thrown by this method are either passed to the caller or rethrown in RethrowExceptionMechanism(Exception).

The default implementation can throw anything thrown by RunSynchronously or Wait.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void RunTaskMechanism(
    Task task,
    bool calledFromDialog
)
protected:
virtual void RunTaskMechanism(
    Task^ task,
    bool calledFromDialog
)

Parameters

task
Type: System.Threading.TasksTask
calledFromDialog
Type: SystemBoolean
True only if this is executed from a dialog, false if executed directly."/>.
See Also

Reference

BusyScope Class
VisualComponents.UX.Shared Namespace


BusyScope.Show Method

BusyScopeShow Method

Overload List
 | Name | Description
Public method | Show | Shows the progress window (if allowed). Returns without waiting for the window to close.
Public method | Show(Boolean) | Shows the progress window (if allowed). Returns without waiting for the window to close.
Top
See Also

Reference

BusyScope Class
VisualComponents.UX.Shared Namespace


BusyScope.Show Method

BusyScopeShow Method

Shows the progress window (if allowed). Returns without waiting for the window to close.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Show()
public:
void Show()
See Also

Reference

BusyScope Class
Show Overload
VisualComponents.UX.Shared Namespace


BusyScope.Show Method (Boolean)

BusyScopeShow Method (Boolean)

Shows the progress window (if allowed). Returns without waiting for the window to close.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Show(
    bool emulateModal
)
public:
void Show(
    bool emulateModal
)

Parameters

emulateModal
Type: SystemBoolean
If true, will temporarily block interaction with the main window.
See Also

Reference

BusyScope Class
Show Overload
VisualComponents.UX.Shared Namespace


BusyScope.ShowDialog Method

BusyScopeShowDialog Method

Overload List
 | Name | Description
Public method | ShowDialog(Task) | Shows the progress window (if allowed) and runs taskToRun synchronously. The window is closed after taskToRun is finished. Can throw anything thrown by RunTaskMechanism(Task, Boolean) or RethrowExceptionMechanism(Exception). For reporting progress, see ProgressContext.
Public method | ShowDialog(Task, Task) | Shows the progress window (if allowed) and runs taskToRun synchronously. The window is closed after taskToRun is finished. Can throw anything thrown by RunTaskMechanism(Task, Boolean) or RethrowExceptionMechanism(Exception). For reporting progress, see ProgressContext.
Top
See Also

Reference

BusyScope Class
VisualComponents.UX.Shared Namespace


BusyScope.ShowDialog Method (Task)

BusyScopeShowDialog Method (Task)

Shows the progress window (if allowed) and runs taskToRun synchronously. The window is closed after taskToRun is finished.

Can throw anything thrown by RunTaskMechanism(Task, Boolean) or RethrowExceptionMechanism(Exception).

For reporting progress, see ProgressContext.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ShowDialog(
    Task taskToRun
)
public:
void ShowDialog(
    Task^ taskToRun
)

Parameters

taskToRun
Type: System.Threading.TasksTask
Task to run once the window is shown
See Also

Reference

BusyScope Class
ShowDialog Overload
VisualComponents.UX.Shared Namespace
BusyScope.ShowDialogIsModal
IApplicationProgressContext


BusyScope.ShowDialog Method (Task, Task)

BusyScopeShowDialog Method (Task, Task)

Shows the progress window (if allowed) and runs taskToRun synchronously. The window is closed after taskToRun is finished.

Can throw anything thrown by RunTaskMechanism(Task, Boolean) or RethrowExceptionMechanism(Exception).

For reporting progress, see ProgressContext.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ShowDialog(
    Task taskToRun,
    Task cancelTask
)
public:
void ShowDialog(
    Task^ taskToRun,
    Task^ cancelTask
)

Parameters

taskToRun
Type: System.Threading.TasksTask
Task to run once the window is shown
cancelTask
Type: System.Threading.TasksTask
Task to run in case user presses Cancel
See Also

Reference

BusyScope Class
ShowDialog Overload
VisualComponents.UX.Shared Namespace
BusyScope.ShowDialogIsModal
IApplicationProgressContext


BusyScope.StartTrackingBackgroundProgress Method

BusyScopeStartTrackingBackgroundProgress Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void StartTrackingBackgroundProgress(
    IApplication application
)
public:
static void StartTrackingBackgroundProgress(
    IApplication^ application
)

Parameters

application
Type: VisualComponents.Create3DIApplication
See Also

Reference

BusyScope Class
VisualComponents.UX.Shared Namespace


BusyScope.StopTrackingBackgroundProgress Method

BusyScopeStopTrackingBackgroundProgress Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void StopTrackingBackgroundProgress(
    IApplication application
)
public:
static void StopTrackingBackgroundProgress(
    IApplication^ application
)

Parameters

application
Type: VisualComponents.Create3DIApplication
See Also

Reference

BusyScope Class
VisualComponents.UX.Shared Namespace


BusyScope.UpdateProgress Method

BusyScopeUpdateProgress Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void UpdateProgress(
    string status,
    double progressPercentage
)
public:
void UpdateProgress(
    String^ status,
    double progressPercentage
)

Parameters

status
Type: SystemString
progressPercentage
Type: SystemDouble
See Also

Reference

BusyScope Class
VisualComponents.UX.Shared Namespace


ButtonProperty Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedEditorProperty
VisualComponents.UX.SharedButtonProperty

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ButtonProperty : EditorProperty
public ref class ButtonProperty sealed : public EditorProperty

The ButtonProperty type exposes the following members.

Constructors
 | Name | Description
Public method | ButtonProperty | Initializes a new instance of the ButtonProperty class
Top
Properties
 | Name | Description
Public property | AllowedMaximum | (Inherited from EditorProperty.)
Public property | AllowedMinimum | (Inherited from EditorProperty.)
Public property | AllowedValues | (Inherited from EditorProperty.)
Public property | CanCreateNewValue | (Inherited from EditorProperty.)
Public property | Category | (Inherited from EditorProperty.)
Public property | ConstraintType | (Inherited from EditorProperty.)
Public property | Container | (Inherited from EditorProperty.)
Public property | ContainerExpressionContext | (Inherited from EditorProperty.)
Public property | ContainerObject | Similar to IProperty.Container, but for any object. (Inherited from EditorProperty.)
Public property | CreationTypes | (Inherited from EditorProperty.)
Public property | Description | (Inherited from EditorProperty.)
Public property | DisabledStateToolTip | (Inherited from EditorProperty.)
Public property | DistributionExpression | (Inherited from EditorProperty.)
Public property | Error | (Inherited from EditorProperty.)
Public property | ErrorMessage | (Inherited from EditorProperty.)
Public property | HasDistribution | (Inherited from EditorProperty.)
Public property | History | (Inherited from EditorProperty.)
Public property | Index_ForComboBox | (Inherited from EditorProperty.)
Public property | IsDesignTime | (Inherited from EditorProperty.)
Public property | IsEditable | Helper property since in XAML negating binding value is not possible without using BoolToOppositeConverter (Inherited from EditorProperty.)
Public property | IsEditableInGui | (Inherited from EditorProperty.)
Public property | IsExceptionallyInHome | (Inherited from EditorProperty.)
Public property | IsInternal | (Inherited from EditorProperty.)
Public property | IsLocked | (Inherited from EditorProperty.)
Public property | IsPersistent | (Inherited from EditorProperty.)
Public property | IsQuantityValue | (Inherited from EditorProperty.)
Public property | IsReadOnly | (Inherited from EditorProperty.)
Public property | IsValid | (Inherited from EditorProperty.)
Public property | IsVisible | (Inherited from EditorProperty.)
Public property | IsVisibleDesignTime | (Inherited from EditorProperty.)
Public property | IsVisibleForced | (Inherited from EditorProperty.)
Public property | IsVisibleInGui | IsVisibleInGui is used to bind GUI visibility. Setting this value affects only _isVisibleForcedOff. (Inherited from EditorProperty.)
Public property | Item | (Inherited from EditorProperty.)
Public property | Name | (Inherited from EditorProperty.)
Public property | NonLocalizedName | (Inherited from EditorProperty.)
Public property | Order | (Inherited from EditorProperty.)
Public property | Property | (Inherited from EditorProperty.)
Public property | PropertyDescription | (Inherited from EditorProperty.)
Public property | PropertyType | (Inherited from EditorProperty.)
Public property | Quantity | (Inherited from EditorProperty.)
Public property | ResourceType | In case of having an IUriProperty, this determines if the editor should allow folder selection instead of file selection (Inherited from EditorProperty.)
Public property | RotationSystem | (Inherited from EditorProperty.)
Public property | ShowValuepicker | (Inherited from EditorProperty.)
Public property | TabHeader | (Inherited from EditorProperty.)
Public property | Unit | (Inherited from EditorProperty.)
Public property | Value | (Inherited from EditorProperty.)
Public property | Value_ForComboBox | Helper property, used only by ComboBox. (Inherited from EditorProperty.)
Public property | ValueString | (Inherited from EditorProperty.)
Top
Methods
 | Name | Description
Public method | Associate | (Inherited from EditorProperty.)
Public method | CheckEditableInGui | (Inherited from EditorProperty.)
Public method | CheckRebuild | This happens only on UI changes. If containeris a behavior of feature call evaluate or rebuild to update geometry. (Inherited from EditorProperty.)
Public method | CheckRebuildSmart | (Inherited from EditorProperty.)
Public method | Click |
Public method | Clone | (Inherited from EditorProperty.)
Public method | CreateAndSetNewValue | (Inherited from EditorProperty.)
Public method | Disassociate | (Inherited from EditorProperty.)
Public method | Dispose | (Inherited from EditorProperty.)
Public method | EndBatch | (Inherited from EditorProperty.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PickValue | Execute PickAction and wait for user to click on some object. (Inherited from EditorProperty.)
Public method | PickValueProxy | (Inherited from EditorProperty.)
Public method | SetQuantity | (Inherited from EditorProperty.)
Public method | SetUnitMagnitude | (Inherited from EditorProperty.)
Public method | StartBatch | (Inherited from EditorProperty.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | property changed event (Inherited from EditorProperty.)
Top
Fields
 | Name | Description
Public field | SuppressValueChange | (Inherited from EditorProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ButtonProperty Constructor

Initializes a new instance of the ButtonProperty class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ButtonProperty(
    IProperty property
)
public:
ButtonProperty(
    IProperty^ property
)

Parameters

property
Type: VisualComponents.Create3DIProperty
See Also

Reference

ButtonProperty Class
VisualComponents.UX.Shared Namespace


ButtonProperty Properties

The ButtonProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | (Inherited from EditorProperty.)
Public property | AllowedMinimum | (Inherited from EditorProperty.)
Public property | AllowedValues | (Inherited from EditorProperty.)
Public property | CanCreateNewValue | (Inherited from EditorProperty.)
Public property | Category | (Inherited from EditorProperty.)
Public property | ConstraintType | (Inherited from EditorProperty.)
Public property | Container | (Inherited from EditorProperty.)
Public property | ContainerExpressionContext | (Inherited from EditorProperty.)
Public property | ContainerObject | Similar to IProperty.Container, but for any object. (Inherited from EditorProperty.)
Public property | CreationTypes | (Inherited from EditorProperty.)
Public property | Description | (Inherited from EditorProperty.)
Public property | DisabledStateToolTip | (Inherited from EditorProperty.)
Public property | DistributionExpression | (Inherited from EditorProperty.)
Public property | Error | (Inherited from EditorProperty.)
Public property | ErrorMessage | (Inherited from EditorProperty.)
Public property | HasDistribution | (Inherited from EditorProperty.)
Public property | History | (Inherited from EditorProperty.)
Public property | Index_ForComboBox | (Inherited from EditorProperty.)
Public property | IsDesignTime | (Inherited from EditorProperty.)
Public property | IsEditable | Helper property since in XAML negating binding value is not possible without using BoolToOppositeConverter (Inherited from EditorProperty.)
Public property | IsEditableInGui | (Inherited from EditorProperty.)
Public property | IsExceptionallyInHome | (Inherited from EditorProperty.)
Public property | IsInternal | (Inherited from EditorProperty.)
Public property | IsLocked | (Inherited from EditorProperty.)
Public property | IsPersistent | (Inherited from EditorProperty.)
Public property | IsQuantityValue | (Inherited from EditorProperty.)
Public property | IsReadOnly | (Inherited from EditorProperty.)
Public property | IsValid | (Inherited from EditorProperty.)
Public property | IsVisible | (Inherited from EditorProperty.)
Public property | IsVisibleDesignTime | (Inherited from EditorProperty.)
Public property | IsVisibleForced | (Inherited from EditorProperty.)
Public property | IsVisibleInGui | IsVisibleInGui is used to bind GUI visibility. Setting this value affects only _isVisibleForcedOff. (Inherited from EditorProperty.)
Public property | Item | (Inherited from EditorProperty.)
Public property | Name | (Inherited from EditorProperty.)
Public property | NonLocalizedName | (Inherited from EditorProperty.)
Public property | Order | (Inherited from EditorProperty.)
Public property | Property | (Inherited from EditorProperty.)
Public property | PropertyDescription | (Inherited from EditorProperty.)
Public property | PropertyType | (Inherited from EditorProperty.)
Public property | Quantity | (Inherited from EditorProperty.)
Public property | ResourceType | In case of having an IUriProperty, this determines if the editor should allow folder selection instead of file selection (Inherited from EditorProperty.)
Public property | RotationSystem | (Inherited from EditorProperty.)
Public property | ShowValuepicker | (Inherited from EditorProperty.)
Public property | TabHeader | (Inherited from EditorProperty.)
Public property | Unit | (Inherited from EditorProperty.)
Public property | Value | (Inherited from EditorProperty.)
Public property | Value_ForComboBox | Helper property, used only by ComboBox. (Inherited from EditorProperty.)
Public property | ValueString | (Inherited from EditorProperty.)
Top
See Also

Reference

ButtonProperty Class
VisualComponents.UX.Shared Namespace


ButtonProperty Methods

The ButtonProperty type exposes the following members.

Methods
 | Name | Description
Public method | Associate | (Inherited from EditorProperty.)
Public method | CheckEditableInGui | (Inherited from EditorProperty.)
Public method | CheckRebuild | This happens only on UI changes. If containeris a behavior of feature call evaluate or rebuild to update geometry. (Inherited from EditorProperty.)
Public method | CheckRebuildSmart | (Inherited from EditorProperty.)
Public method | Click |
Public method | Clone | (Inherited from EditorProperty.)
Public method | CreateAndSetNewValue | (Inherited from EditorProperty.)
Public method | Disassociate | (Inherited from EditorProperty.)
Public method | Dispose | (Inherited from EditorProperty.)
Public method | EndBatch | (Inherited from EditorProperty.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PickValue | Execute PickAction and wait for user to click on some object. (Inherited from EditorProperty.)
Public method | PickValueProxy | (Inherited from EditorProperty.)
Public method | SetQuantity | (Inherited from EditorProperty.)
Public method | SetUnitMagnitude | (Inherited from EditorProperty.)
Public method | StartBatch | (Inherited from EditorProperty.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ButtonProperty Class
VisualComponents.UX.Shared Namespace


ButtonProperty.Click Method

ButtonPropertyClick Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Click()
public:
void Click()
See Also

Reference

ButtonProperty Class
VisualComponents.UX.Shared Namespace


ButtonProperty Events

The ButtonProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | property changed event (Inherited from EditorProperty.)
Top
See Also

Reference

ButtonProperty Class
VisualComponents.UX.Shared Namespace


ButtonProperty Fields

The ButtonProperty type exposes the following members.

Fields
 | Name | Description
Public field | SuppressValueChange | (Inherited from EditorProperty.)
Top
See Also

Reference

ButtonProperty Class
VisualComponents.UX.Shared Namespace


ButtonType Enumeration

Defines how buttons are laid out.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ButtonType
public enum class ButtonType
Members
Member name | Value | Description
DropDown | 0 | Pressing the left mouse down anywhere on the menu tool will toggle the tools Infragistics.Windows.Ribbon.MenuToolBase.IsOpen property raising either the Infragistics.Windows.Ribbon.MenuToolBase.Closed event or the Infragistics.Windows.Ribbon.MenuToolBase.Opening/Infragistics.Windows.Ribbon.MenuToolBase.Opened event pair.
Segmented | 1 | The tool is segmented into 2 button areas. Pressing the left mouse down on one area will toggle the tools Infragistics.Windows.Ribbon.MenuToolBase.IsOpen property raising either the Infragistics.Windows.Ribbon.MenuToolBase.Closed event or the Infragistics.Windows.Ribbon.MenuToolBase.Opening/Infragistics.Windows.Ribbon.MenuToolBase.Opened event pair. Clicking on the other area with the left mouse button will raise the tools Infragistics.Windows.Ribbon.MenuTool.Click event. Note: this event is raised on the mouse up.
SegmentedState | 2 | The tool is segmented into 2 button areas. Pressing the left mouse down on one area will toggle the tools Infragistics.Windows.Ribbon.MenuToolBase.IsOpen property raising either the Infragistics.Windows.Ribbon.MenuToolBase.Closed event or the Infragistics.Windows.Ribbon.MenuToolBase.Opening/Infragistics.Windows.Ribbon.MenuToolBase.Opened event pair. Clicking on the other area with the left mouse button will raise the tools Infragistics.Windows.Ribbon.MenuTool.Checked or Infragistics.Windows.Ribbon.MenuTool.Unchecked event. Note: these events are raised on the mouse up.
See Also

Reference

VisualComponents.UX.Shared Namespace


CADFilesList Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedCADFilesList

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class CADFilesList
public ref class CADFilesList abstract sealed

The CADFilesList type exposes the following members.

Methods
Name | Description
GetDrawingFilter |
GetExtensionFormated | Get formatted file extensions
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


CADFilesList Methods

The CADFilesList type exposes the following members.

Methods
Name | Description
GetDrawingFilter |
GetExtensionFormated | Get formatted file extensions
Top
See Also

Reference

CADFilesList Class
VisualComponents.UX.Shared Namespace


CADFilesList.GetDrawingFilter Method

CADFilesListGetDrawingFilter Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetDrawingFilter()
public:
static String^ GetDrawingFilter()

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.CADFilesList.GetDrawingFilter"]

See Also

Reference

CADFilesList Class
VisualComponents.UX.Shared Namespace


CADFilesList.GetExtensionFormated Method

CADFilesListGetExtensionFormated Method

Get formatted file extensions

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void GetExtensionFormated(
    string[] extensions,
    StringBuilder ret
)
public:
static void GetExtensionFormated(
    array<String^>^ extensions,
    StringBuilder^ ret
)

Parameters

extensions
Type: SystemString
list of extensions
ret
Type: System.TextStringBuilder
list of formatted extensions
See Also

Reference

CADFilesList Class
VisualComponents.UX.Shared Namespace


CADImportAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedCADImportAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class CADImportAction : ICommandPanelAction,
    ICADAnalizeAction, IHandle<RequestActionAbortMessage>, IHandle
public ref class CADImportAction sealed : ICommandPanelAction,
    ICADAnalizeAction, IHandle<RequestActionAbortMessage^>, IHandle

The CADImportAction type exposes the following members.

Constructors
 | Name | Description
Public method | CADImportAction | Initializes a new instance of the CADImportAction class
Top
Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
Public property | Title |
Top
Methods
 | Name | Description
Public method | AnalyzeAction |
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle |
Public method | IsFileSettingsSupported |
Public method | SetImportValues |
Public method | StartAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
Name | Description
ImportCompleted |
Top
Fields
Name | Description
IsAnalyzing |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


CADImportAction Constructor

Initializes a new instance of the CADImportAction class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CADImportAction()
public:
CADImportAction()
See Also

Reference

CADImportAction Class
VisualComponents.UX.Shared Namespace


CADImportAction Properties

The CADImportAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
Public property | Title |
Top
See Also

Reference

CADImportAction Class
VisualComponents.UX.Shared Namespace


CADImportAction.ActionFinished Property

CADImportActionActionFinished Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ActionFinished { get; set; }
public:
virtual property bool ActionFinished {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ICommandPanelActionActionFinished
See Also

Reference

CADImportAction Class
VisualComponents.UX.Shared Namespace


CADImportAction.ActionProperties Property

CADImportActionActionProperties Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<IProperty> ActionProperties { get; }
public:
virtual property List<IProperty^>^ ActionProperties {
    List<IProperty^>^ get () sealed;
}

Property Value

Type: ListIProperty

Implements

ICommandPanelActionActionProperties
See Also

Reference

CADImportAction Class
VisualComponents.UX.Shared Namespace


CADImportAction.ApplyButtonText Property

CADImportActionApplyButtonText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ApplyButtonText { get; }
public:
virtual property String^ ApplyButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionApplyButtonText
See Also

Reference

CADImportAction Class
VisualComponents.UX.Shared Namespace


CADImportAction.AssociatedModelId Property

CADImportActionAssociatedModelId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedModelId { get; }
public:
virtual property String^ AssociatedModelId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedModelId
See Also

Reference

CADImportAction Class
VisualComponents.UX.Shared Namespace


CADImportAction.AssociatedSiteId Property

CADImportActionAssociatedSiteId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedSiteId { get; }
public:
virtual property String^ AssociatedSiteId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedSiteId
See Also

Reference

CADImportAction Class
VisualComponents.UX.Shared Namespace


CADImportAction.CallingCommandName Property

CADImportActionCallingCommandName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CallingCommandName { get; }
public:
virtual property String^ CallingCommandName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCallingCommandName
See Also

Reference

CADImportAction Class
VisualComponents.UX.Shared Namespace


CADImportAction.CancelButtonText Property

CADImportActionCancelButtonText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CancelButtonText { get; }
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCancelButtonText
See Also

Reference

CADImportAction Class
VisualComponents.UX.Shared Namespace


CADImportAction.Description Property

CADImportActionDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; }
public:
virtual property String^ Description {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionDescription
See Also

Reference

CADImportAction Class
VisualComponents.UX.Shared Namespace


CADImportAction.ErrorMessage Property

CADImportActionErrorMessage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ErrorMessage { get; set; }
public:
virtual property String^ ErrorMessage {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionErrorMessage
See Also

Reference

CADImportAction Class
VisualComponents.UX.Shared Namespace


CADImportAction.Title Property

CADImportActionTitle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; }
public:
virtual property String^ Title {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionTitle
See Also

Reference

CADImportAction Class
VisualComponents.UX.Shared Namespace


CADImportAction Methods

The CADImportAction type exposes the following members.

Methods
 | Name | Description
Public method | AnalyzeAction |
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle |
Public method | IsFileSettingsSupported |
Public method | SetImportValues |
Public method | StartAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CADImportAction Class
VisualComponents.UX.Shared Namespace


CADImportAction.AnalyzeAction Method

CADImportActionAnalyzeAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void AnalyzeAction()
public:
virtual void AnalyzeAction() sealed

Implements

ICADAnalizeActionAnalyzeAction
See Also

Reference

CADImportAction Class
VisualComponents.UX.Shared Namespace


CADImportAction.ApplyAction Method

CADImportActionApplyAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ApplyAction()
public:
virtual bool ApplyAction() sealed

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.CADImportAction.ApplyAction"]

Implements

ICommandPanelActionApplyAction
See Also

Reference

CADImportAction Class
VisualComponents.UX.Shared Namespace


CADImportAction.CancelAction Method

CADImportActionCancelAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CancelAction()
public:
virtual void CancelAction() sealed

Implements

ICommandPanelActionCancelAction
See Also

Reference

CADImportAction Class
VisualComponents.UX.Shared Namespace


CADImportAction.Handle Method

CADImportActionHandle Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    RequestActionAbortMessage message
)
public:
virtual void Handle(
    RequestActionAbortMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedRequestActionAbortMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

CADImportAction Class
VisualComponents.UX.Shared Namespace


CADImportAction.IsFileSettingsSupported Method

CADImportActionIsFileSettingsSupported Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsFileSettingsSupported(
    string uri
)
public:
virtual bool IsFileSettingsSupported(
    String^ uri
) sealed

Parameters

uri
Type: SystemString

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.CADImportAction.IsFileSettingsSupported(System.String)"]

Implements

ICADAnalizeActionIsFileSettingsSupported(String)
See Also

Reference

CADImportAction Class
VisualComponents.UX.Shared Namespace


CADImportAction.SetImportValues Method

CADImportActionSetImportValues Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetImportValues(
    ImportSummaryMessage message
)
public:
void SetImportValues(
    ImportSummaryMessage^ message
)

Parameters

message
Type: VisualComponents.Create3DImportSummaryMessage
See Also

Reference

CADImportAction Class
VisualComponents.UX.Shared Namespace


CADImportAction.StartAction Method

CADImportActionStartAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    EventHandler<ResultCompletionEventArgs> completed = null
)
public:
virtual void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr
) sealed

Parameters

completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs

Implements

ICommandPanelActionStartAction(EventHandlerResultCompletionEventArgs)
See Also

Reference

CADImportAction Class
VisualComponents.UX.Shared Namespace


CADImportAction Events

The CADImportAction type exposes the following members.

Events
Name | Description
ImportCompleted |
Top
See Also

Reference

CADImportAction Class
VisualComponents.UX.Shared Namespace


CADImportAction.ImportCompleted Event

CADImportActionImportCompleted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static event EventHandler ImportCompleted
public:
static  event EventHandler^ ImportCompleted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

CADImportAction Class
VisualComponents.UX.Shared Namespace


CADImportAction Fields

The CADImportAction type exposes the following members.

Fields
Name | Description
IsAnalyzing |
Top
See Also

Reference

CADImportAction Class
VisualComponents.UX.Shared Namespace


CADImportAction.IsAnalyzing Field

CADImportActionIsAnalyzing Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsAnalyzing
public:
static bool IsAnalyzing

Field Value

Type: Boolean
See Also

Reference

CADImportAction Class
VisualComponents.UX.Shared Namespace


CADImportPresetsSection Class

Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationSection
VisualComponents.UX.SharedCADImportPresetsSection

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class CADImportPresetsSection : ConfigurationSection,
    ISection
public ref class CADImportPresetsSection sealed : public ConfigurationSection,
    ISection

The CADImportPresetsSection type exposes the following members.

Constructors
 | Name | Description
Public method | CADImportPresetsSection | Initializes a new instance of the CADImportPresetsSection class
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | Presets |
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName |
Public property | SectionType |
Public property | SectionVersion |
Top
Methods
 | Name | Description
Public method | CheckVersion |
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


CADImportPresetsSection Constructor

Initializes a new instance of the CADImportPresetsSection class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CADImportPresetsSection()
public:
CADImportPresetsSection()
See Also

Reference

CADImportPresetsSection Class
VisualComponents.UX.Shared Namespace


CADImportPresetsSection Properties

The CADImportPresetsSection type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | Presets |
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName |
Public property | SectionType |
Public property | SectionVersion |
Top
See Also

Reference

CADImportPresetsSection Class
VisualComponents.UX.Shared Namespace


CADImportPresetsSection.Presets Property

CADImportPresetsSectionPresets Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CadPresetsConfigCollection Presets { get; }
public:
property CadPresetsConfigCollection^ Presets {
    CadPresetsConfigCollection^ get ();
}

Property Value

Type: CadPresetsConfigCollection
See Also

Reference

CADImportPresetsSection Class
VisualComponents.UX.Shared Namespace


CADImportPresetsSection.SectionName Property

CADImportPresetsSectionSectionName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SectionName { get; }
public:
virtual property String^ SectionName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ISectionSectionName
See Also

Reference

CADImportPresetsSection Class
VisualComponents.UX.Shared Namespace


CADImportPresetsSection.SectionType Property

CADImportPresetsSectionSectionType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type SectionType { get; }
public:
virtual property Type^ SectionType {
    Type^ get () sealed;
}

Property Value

Type: Type

Implements

ISectionSectionType
See Also

Reference

CADImportPresetsSection Class
VisualComponents.UX.Shared Namespace


CADImportPresetsSection.SectionVersion Property

CADImportPresetsSectionSectionVersion Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int SectionVersion { get; }
public:
virtual property int SectionVersion {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISectionSectionVersion
See Also

Reference

CADImportPresetsSection Class
VisualComponents.UX.Shared Namespace


CADImportPresetsSection Methods

The CADImportPresetsSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion |
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CADImportPresetsSection Class
VisualComponents.UX.Shared Namespace


CADImportPresetsSection.CheckVersion Method

CADImportPresetsSectionCheckVersion Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CheckVersion()
public:
virtual void CheckVersion() sealed

Implements

ISectionCheckVersion
See Also

Reference

CADImportPresetsSection Class
VisualComponents.UX.Shared Namespace


CADImportPresetsSection.GetSection Method

CADImportPresetsSectionGetSection Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISection GetSection(
    Configuration userSettingConfiguration
)
public:
virtual ISection^ GetSection(
    Configuration^ userSettingConfiguration
) sealed

Parameters

userSettingConfiguration
Type: System.ConfigurationConfiguration

Return Value

Type: ISection

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.CADImportPresetsSection.GetSection(System.Configuration.Configuration)"]

Implements

ISectionGetSection(Configuration)
See Also

Reference

CADImportPresetsSection Class
VisualComponents.UX.Shared Namespace


CadPresetConfigElement Class

blocked item config element
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.UX.SharedCadPresetConfigElement

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class CadPresetConfigElement : ConfigurationElement
public ref class CadPresetConfigElement sealed : public ConfigurationElement

The CadPresetConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | CadPresetConfigElement | Initializes a new instance of the CadPresetConfigElement class
Top
Properties
 | Name | Description
Public property | CADPresetEntries |
Public property | CADPresets |
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | ItemId | Item ID
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


CadPresetConfigElement Constructor

Initializes a new instance of the CadPresetConfigElement class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CadPresetConfigElement()
public:
CadPresetConfigElement()
See Also

Reference

CadPresetConfigElement Class
VisualComponents.UX.Shared Namespace


CadPresetConfigElement Properties

The CadPresetConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CADPresetEntries |
Public property | CADPresets |
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | ItemId | Item ID
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Top
See Also

Reference

CadPresetConfigElement Class
VisualComponents.UX.Shared Namespace


CadPresetConfigElement.CADPresetEntries Property

CadPresetConfigElementCADPresetEntries Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CadPresetsEntryConfigCollection CADPresetEntries { get; }
public:
property CadPresetsEntryConfigCollection^ CADPresetEntries {
    CadPresetsEntryConfigCollection^ get ();
}

Property Value

Type: CadPresetsEntryConfigCollection
See Also

Reference

CadPresetConfigElement Class
VisualComponents.UX.Shared Namespace


CadPresetConfigElement.CADPresets Property

CadPresetConfigElementCADPresets Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CadPresetsConfigCollection CADPresets { get; }
public:
property CadPresetsConfigCollection^ CADPresets {
    CadPresetsConfigCollection^ get ();
}

Property Value

Type: CadPresetsConfigCollection
See Also

Reference

CadPresetConfigElement Class
VisualComponents.UX.Shared Namespace


CadPresetConfigElement.ItemId Property

CadPresetConfigElementItemId Property

Item ID

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ItemId { get; set; }
public:
property String^ ItemId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

CadPresetConfigElement Class
VisualComponents.UX.Shared Namespace


CadPresetConfigElement Methods

The CadPresetConfigElement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CadPresetConfigElement Class
VisualComponents.UX.Shared Namespace


CadPresetEntryConfigElement Class

blocked item config element
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.UX.SharedCadPresetEntryConfigElement

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class CadPresetEntryConfigElement : ConfigurationElement
public ref class CadPresetEntryConfigElement sealed : public ConfigurationElement

The CadPresetEntryConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | CadPresetEntryConfigElement | Initializes a new instance of the CadPresetEntryConfigElement class
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | Key | Item ID
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | Value | Row start
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


CadPresetEntryConfigElement Constructor

Initializes a new instance of the CadPresetEntryConfigElement class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CadPresetEntryConfigElement()
public:
CadPresetEntryConfigElement()
See Also

Reference

CadPresetEntryConfigElement Class
VisualComponents.UX.Shared Namespace


CadPresetEntryConfigElement Properties

The CadPresetEntryConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | Key | Item ID
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | Value | Row start
Top
See Also

Reference

CadPresetEntryConfigElement Class
VisualComponents.UX.Shared Namespace


CadPresetEntryConfigElement.Key Property

CadPresetEntryConfigElementKey Property

Item ID

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Key { get; set; }
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

CadPresetEntryConfigElement Class
VisualComponents.UX.Shared Namespace


CadPresetEntryConfigElement.Value Property

CadPresetEntryConfigElementValue Property

Row start

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Value { get; set; }
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

CadPresetEntryConfigElement Class
VisualComponents.UX.Shared Namespace


CadPresetEntryConfigElement Methods

The CadPresetEntryConfigElement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CadPresetEntryConfigElement Class
VisualComponents.UX.Shared Namespace


CadPresetsConfigCollection Class

Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationElementCollection
VisualComponents.UX.SharedBaseConfigCollection CadPresetConfigElement
VisualComponents.UX.SharedCadPresetsConfigCollection

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class CadPresetsConfigCollection : BaseConfigCollection<CadPresetConfigElement>
public ref class CadPresetsConfigCollection sealed : public BaseConfigCollection<CadPresetConfigElement^>

The CadPresetsConfigCollection type exposes the following members.

Constructors
 | Name | Description
Public method | CadPresetsConfigCollection | Initializes a new instance of the CadPresetsConfigCollection class
Top
Properties
 | Name | Description
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Public property | ItemInt32 | (Inherited from BaseConfigCollectionT.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Top
Methods
 | Name | Description
Public method | Add | Add item to the collection (Inherited from BaseConfigCollectionT.)
Public method | Clear | clear the collection (Inherited from BaseConfigCollectionT.)
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | get the collection index of the element (Inherited from BaseConfigCollectionT.)
Public method | Insert | Inserts an item into the collection at the specified index. (Inherited from BaseConfigCollectionT.)
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Public method | Remove | remove the element from the collection (Inherited from BaseConfigCollectionT.)
Public method | RemoveAt | remove the element from the collection by the index (Inherited from BaseConfigCollectionT.)
Public method | ToList | Returns list of items (Inherited from BaseConfigCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


CadPresetsConfigCollection Constructor

Initializes a new instance of the CadPresetsConfigCollection class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CadPresetsConfigCollection()
public:
CadPresetsConfigCollection()
See Also

Reference

CadPresetsConfigCollection Class
VisualComponents.UX.Shared Namespace


CadPresetsConfigCollection Properties

The CadPresetsConfigCollection type exposes the following members.

Properties
 | Name | Description
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Public property | ItemInt32 | (Inherited from BaseConfigCollectionT.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Top
See Also

Reference

CadPresetsConfigCollection Class
VisualComponents.UX.Shared Namespace


CadPresetsConfigCollection Methods

The CadPresetsConfigCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add item to the collection (Inherited from BaseConfigCollectionT.)
Public method | Clear | clear the collection (Inherited from BaseConfigCollectionT.)
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | get the collection index of the element (Inherited from BaseConfigCollectionT.)
Public method | Insert | Inserts an item into the collection at the specified index. (Inherited from BaseConfigCollectionT.)
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Public method | Remove | remove the element from the collection (Inherited from BaseConfigCollectionT.)
Public method | RemoveAt | remove the element from the collection by the index (Inherited from BaseConfigCollectionT.)
Public method | ToList | Returns list of items (Inherited from BaseConfigCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CadPresetsConfigCollection Class
VisualComponents.UX.Shared Namespace


CadPresetsEntryConfigCollection Class

Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationElementCollection
VisualComponents.UX.SharedBaseConfigCollection CadPresetEntryConfigElement
VisualComponents.UX.SharedCadPresetsEntryConfigCollection

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class CadPresetsEntryConfigCollection : BaseConfigCollection<CadPresetEntryConfigElement>
public ref class CadPresetsEntryConfigCollection sealed : public BaseConfigCollection<CadPresetEntryConfigElement^>

The CadPresetsEntryConfigCollection type exposes the following members.

Constructors
 | Name | Description
Public method | CadPresetsEntryConfigCollection | Initializes a new instance of the CadPresetsEntryConfigCollection class
Top
Properties
 | Name | Description
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Public property | ItemInt32 | (Inherited from BaseConfigCollectionT.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Top
Methods
 | Name | Description
Public method | Add | Add item to the collection (Inherited from BaseConfigCollectionT.)
Public method | Clear | clear the collection (Inherited from BaseConfigCollectionT.)
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | get the collection index of the element (Inherited from BaseConfigCollectionT.)
Public method | Insert | Inserts an item into the collection at the specified index. (Inherited from BaseConfigCollectionT.)
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Public method | Remove | remove the element from the collection (Inherited from BaseConfigCollectionT.)
Public method | RemoveAt | remove the element from the collection by the index (Inherited from BaseConfigCollectionT.)
Public method | ToList | Returns list of items (Inherited from BaseConfigCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


CadPresetsEntryConfigCollection Constructor

Initializes a new instance of the CadPresetsEntryConfigCollection class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CadPresetsEntryConfigCollection()
public:
CadPresetsEntryConfigCollection()
See Also

Reference

CadPresetsEntryConfigCollection Class
VisualComponents.UX.Shared Namespace


CadPresetsEntryConfigCollection Properties

The CadPresetsEntryConfigCollection type exposes the following members.

Properties
 | Name | Description
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Public property | ItemInt32 | (Inherited from BaseConfigCollectionT.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Top
See Also

Reference

CadPresetsEntryConfigCollection Class
VisualComponents.UX.Shared Namespace


CadPresetsEntryConfigCollection Methods

The CadPresetsEntryConfigCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add item to the collection (Inherited from BaseConfigCollectionT.)
Public method | Clear | clear the collection (Inherited from BaseConfigCollectionT.)
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | get the collection index of the element (Inherited from BaseConfigCollectionT.)
Public method | Insert | Inserts an item into the collection at the specified index. (Inherited from BaseConfigCollectionT.)
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Public method | Remove | remove the element from the collection (Inherited from BaseConfigCollectionT.)
Public method | RemoveAt | remove the element from the collection by the index (Inherited from BaseConfigCollectionT.)
Public method | ToList | Returns list of items (Inherited from BaseConfigCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CadPresetsEntryConfigCollection Class
VisualComponents.UX.Shared Namespace


CaptionBarInfo Class

Information about titles and logo displayed in caption bar.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedCaptionBarInfo

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class CaptionBarInfo
public ref class CaptionBarInfo

The CaptionBarInfo type exposes the following members.

Constructors
 | Name | Description
Public method | CaptionBarInfo | Initializes a new instance of the CaptionBarInfo class
Top
Properties
 | Name | Description
Public property | IsVcResource | Is this a Visual Components resource.
Public property | Key | WPF resource key
Public property | Source | PackURI to the xaml resource.
Public property | Tag | Filename of the currently open file.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


CaptionBarInfo Constructor

Initializes a new instance of the CaptionBarInfo class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CaptionBarInfo()
public:
CaptionBarInfo()
See Also

Reference

CaptionBarInfo Class
VisualComponents.UX.Shared Namespace


CaptionBarInfo Properties

The CaptionBarInfo type exposes the following members.

Properties
 | Name | Description
Public property | IsVcResource | Is this a Visual Components resource.
Public property | Key | WPF resource key
Public property | Source | PackURI to the xaml resource.
Public property | Tag | Filename of the currently open file.
Top
See Also

Reference

CaptionBarInfo Class
VisualComponents.UX.Shared Namespace


CaptionBarInfo.IsVcResource Property

CaptionBarInfoIsVcResource Property

Is this a Visual Components resource.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsVcResource { get; set; }
public:
property bool IsVcResource {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CaptionBarInfo Class
VisualComponents.UX.Shared Namespace


CaptionBarInfo.Key Property

CaptionBarInfoKey Property

WPF resource key

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Key { get; set; }
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

CaptionBarInfo Class
VisualComponents.UX.Shared Namespace


CaptionBarInfo.Source Property

CaptionBarInfoSource Property

PackURI to the xaml resource.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Source { get; set; }
public:
property String^ Source {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

CaptionBarInfo Class
VisualComponents.UX.Shared Namespace


CaptionBarInfo.Tag Property

CaptionBarInfoTag Property

Filename of the currently open file.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Tag { get; set; }
public:
property String^ Tag {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

CaptionBarInfo Class
VisualComponents.UX.Shared Namespace


CaptionBarInfo Methods

The CaptionBarInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CaptionBarInfo Class
VisualComponents.UX.Shared Namespace


CaptionBarInfoToApplicationTitleConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedCaptionBarInfoToApplicationTitleConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class CaptionBarInfoToApplicationTitleConverter : IValueConverter
public ref class CaptionBarInfoToApplicationTitleConverter sealed : IValueConverter

The CaptionBarInfoToApplicationTitleConverter type exposes the following members.

Constructors
 | Name | Description
Public method | CaptionBarInfoToApplicationTitleConverter | Initializes a new instance of the CaptionBarInfoToApplicationTitleConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


CaptionBarInfoToApplicationTitleConverter Constructor

Initializes a new instance of the CaptionBarInfoToApplicationTitleConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CaptionBarInfoToApplicationTitleConverter()
public:
CaptionBarInfoToApplicationTitleConverter()
See Also

Reference

CaptionBarInfoToApplicationTitleConverter Class
VisualComponents.UX.Shared Namespace


CaptionBarInfoToApplicationTitleConverter Methods

The CaptionBarInfoToApplicationTitleConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CaptionBarInfoToApplicationTitleConverter Class
VisualComponents.UX.Shared Namespace


CaptionBarInfoToApplicationTitleConverter.Convert Method

CaptionBarInfoToApplicationTitleConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.CaptionBarInfoToApplicationTitleConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

CaptionBarInfoToApplicationTitleConverter Class
VisualComponents.UX.Shared Namespace


CaptionBarInfoToApplicationTitleConverter.ConvertBack Method

CaptionBarInfoToApplicationTitleConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetTypes,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetTypes,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetTypes
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.CaptionBarInfoToApplicationTitleConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

CaptionBarInfoToApplicationTitleConverter Class
VisualComponents.UX.Shared Namespace


CaptionBarInfoToResourceObjectConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedCaptionBarInfoToResourceObjectConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class CaptionBarInfoToResourceObjectConverter : IValueConverter
public ref class CaptionBarInfoToResourceObjectConverter sealed : IValueConverter

The CaptionBarInfoToResourceObjectConverter type exposes the following members.

Constructors
 | Name | Description
Public method | CaptionBarInfoToResourceObjectConverter | Initializes a new instance of the CaptionBarInfoToResourceObjectConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


CaptionBarInfoToResourceObjectConverter Constructor

Initializes a new instance of the CaptionBarInfoToResourceObjectConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CaptionBarInfoToResourceObjectConverter()
public:
CaptionBarInfoToResourceObjectConverter()
See Also

Reference

CaptionBarInfoToResourceObjectConverter Class
VisualComponents.UX.Shared Namespace


CaptionBarInfoToResourceObjectConverter Methods

The CaptionBarInfoToResourceObjectConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CaptionBarInfoToResourceObjectConverter Class
VisualComponents.UX.Shared Namespace


CaptionBarInfoToResourceObjectConverter.Convert Method

CaptionBarInfoToResourceObjectConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.CaptionBarInfoToResourceObjectConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

CaptionBarInfoToResourceObjectConverter Class
VisualComponents.UX.Shared Namespace


CaptionBarInfoToResourceObjectConverter.ConvertBack Method

CaptionBarInfoToResourceObjectConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetTypes,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetTypes,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetTypes
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.CaptionBarInfoToResourceObjectConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

CaptionBarInfoToResourceObjectConverter Class
VisualComponents.UX.Shared Namespace


ChainConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedChainConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ChainConverter : IValueConverter
public ref class ChainConverter : IValueConverter

The ChainConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ChainConverter | Initializes a new instance of the ChainConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ChainConverter Constructor

Initializes a new instance of the ChainConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ChainConverter()
public:
ChainConverter()
See Also

Reference

ChainConverter Class
VisualComponents.UX.Shared Namespace


ChainConverter Methods

The ChainConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ChainConverter Class
VisualComponents.UX.Shared Namespace


ChainConverter.Convert Method

ChainConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ChainConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

ChainConverter Class
VisualComponents.UX.Shared Namespace


ChainConverter.ConvertBack Method

ChainConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ChainConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

ChainConverter Class
VisualComponents.UX.Shared Namespace


CharHelper Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedCharHelper

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class CharHelper
public ref class CharHelper abstract sealed

The CharHelper type exposes the following members.

Methods
Name | Description
GetCharacter |
IsLatinDigit | Checks whether character is one of the Latin digits (0-9) with code points from U+0030 to U+0039.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


CharHelper Methods

The CharHelper type exposes the following members.

Methods
Name | Description
GetCharacter |
IsLatinDigit | Checks whether character is one of the Latin digits (0-9) with code points from U+0030 to U+0039.
Top
See Also

Reference

CharHelper Class
VisualComponents.UX.Shared Namespace


CharHelper.GetCharacter Method

CharHelperGetCharacter Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static char GetCharacter(
    Key key
)
public:
static wchar_t GetCharacter(
    Key key
)

Parameters

key
Type: System.Windows.InputKey

Return Value

Type: Char

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.CharHelper.GetCharacter(System.Windows.Input.Key)"]

See Also

Reference

CharHelper Class
VisualComponents.UX.Shared Namespace


CharHelper.IsLatinDigit Method

CharHelperIsLatinDigit Method

Checks whether character is one of the Latin digits (0-9) with code points from U+0030 to U+0039.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsLatinDigit(
    char character
)
public:
static bool IsLatinDigit(
    wchar_t character
)

Parameters

character
Type: SystemChar

Return Value

Type: Boolean
True if the character is a Latin digit.
See Also

Reference

CharHelper Class
VisualComponents.UX.Shared Namespace


ClearWorldMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedClearWorldMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ClearWorldMessage
public ref class ClearWorldMessage

The ClearWorldMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ClearWorldMessage | Initializes a new instance of the ClearWorldMessage class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ClearWorldMessage Constructor

Initializes a new instance of the ClearWorldMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ClearWorldMessage()
public:
ClearWorldMessage()
See Also

Reference

ClearWorldMessage Class
VisualComponents.UX.Shared Namespace


ClearWorldMessage Methods

The ClearWorldMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ClearWorldMessage Class
VisualComponents.UX.Shared Namespace


ClipboardHelper Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedClipboardHelper

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ClipboardHelper
public ref class ClipboardHelper sealed

The ClipboardHelper type exposes the following members.

Properties
Name | Description
Self |
Top
Methods
 | Name | Description
 | AddClipboardFormatListener |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RaiseClipboardChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ClipboardChanged |
Top
Fields
Name | Description
WM_CLIPBOARDUPDATE |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ClipboardHelper Properties

The ClipboardHelper type exposes the following members.

Properties
Name | Description
Self |
Top
See Also

Reference

ClipboardHelper Class
VisualComponents.UX.Shared Namespace


ClipboardHelper.Self Property

ClipboardHelperSelf Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ClipboardHelper Self { get; }
public:
static property ClipboardHelper^ Self {
    ClipboardHelper^ get ();
}

Property Value

Type: ClipboardHelper
See Also

Reference

ClipboardHelper Class
VisualComponents.UX.Shared Namespace


ClipboardHelper Methods

The ClipboardHelper type exposes the following members.

Methods
 | Name | Description
 | AddClipboardFormatListener |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RaiseClipboardChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ClipboardHelper Class
VisualComponents.UX.Shared Namespace


ClipboardHelper.AddClipboardFormatListener Method

ClipboardHelperAddClipboardFormatListener Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool AddClipboardFormatListener(
    IntPtr hwnd
)
public:
static bool AddClipboardFormatListener(
    IntPtr hwnd
)

Parameters

hwnd
Type: SystemIntPtr

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ClipboardHelper.AddClipboardFormatListener(System.IntPtr)"]

See Also

Reference

ClipboardHelper Class
VisualComponents.UX.Shared Namespace


ClipboardHelper.RaiseClipboardChanged Method

ClipboardHelperRaiseClipboardChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RaiseClipboardChanged(
    Object sender
)
public:
void RaiseClipboardChanged(
    Object^ sender
)

Parameters

sender
Type: SystemObject
See Also

Reference

ClipboardHelper Class
VisualComponents.UX.Shared Namespace


ClipboardHelper Events

The ClipboardHelper type exposes the following members.

Events
 | Name | Description
Public event | ClipboardChanged |
Top
See Also

Reference

ClipboardHelper Class
VisualComponents.UX.Shared Namespace


ClipboardHelper.ClipboardChanged Event

ClipboardHelperClipboardChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler ClipboardChanged
public:
 event EventHandler^ ClipboardChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ClipboardHelper Class
VisualComponents.UX.Shared Namespace


ClipboardHelper Fields

The ClipboardHelper type exposes the following members.

Fields
Name | Description
WM_CLIPBOARDUPDATE |
Top
See Also

Reference

ClipboardHelper Class
VisualComponents.UX.Shared Namespace


ClipboardHelper.WM_CLIPBOARDUPDATE Field

ClipboardHelperWM_CLIPBOARDUPDATE Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int WM_CLIPBOARDUPDATE = 797
public:
literal int WM_CLIPBOARDUPDATE = 797

Field Value

Type: Int32
See Also

Reference

ClipboardHelper Class
VisualComponents.UX.Shared Namespace


ClipData Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedClipData

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ClipData : IClipDataWithItems, IDisposable
public ref class ClipData : IClipDataWithItems,
    IDisposable

The ClipData type exposes the following members.

Constructors
 | Name | Description
Public method | ClipData | Initializes a new instance of the ClipData class
Public method | ClipData(IEnumerableISharedCloneable) | Initializes a new instance of the ClipData class
Top
Properties
 | Name | Description
Public property | BoundCenter |
Public property | BoundDiagonal |
Public property | HasBound |
Public property | HasItems |
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ClipData
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetCopyDataT | Generic helper method for getting copy data of specific class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeCopy |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ClipData Constructor

Overload List
 | Name | Description
Public method | ClipData | Initializes a new instance of the ClipData class
Public method | ClipData(IEnumerableISharedCloneable) | Initializes a new instance of the ClipData class
Top
See Also

Reference

ClipData Class
VisualComponents.UX.Shared Namespace


ClipData Constructor

Initializes a new instance of the ClipData class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ClipData()
public:
ClipData()
See Also

Reference

ClipData Class
ClipData Overload
VisualComponents.UX.Shared Namespace


ClipData Constructor (IEnumerable(ISharedCloneable))

ClipData Constructor (IEnumerableISharedCloneable)

Initializes a new instance of the ClipData class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ClipData(
    IEnumerable<ISharedCloneable> items
)
public:
ClipData(
    IEnumerable<ISharedCloneable^>^ items
)

Parameters

items
Type: System.Collections.GenericIEnumerableISharedCloneable
See Also

Reference

ClipData Class
ClipData Overload
VisualComponents.UX.Shared Namespace


ClipData Properties

The ClipData type exposes the following members.

Properties
 | Name | Description
Public property | BoundCenter |
Public property | BoundDiagonal |
Public property | HasBound |
Public property | HasItems |
Top
See Also

Reference

ClipData Class
VisualComponents.UX.Shared Namespace


ClipData.BoundCenter Property

ClipDataBoundCenter Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 BoundCenter { get; }
public:
property Vector3 BoundCenter {
    Vector3 get ();
}

Property Value

Type: Vector3
See Also

Reference

ClipData Class
VisualComponents.UX.Shared Namespace


ClipData.BoundDiagonal Property

ClipDataBoundDiagonal Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 BoundDiagonal { get; }
public:
property Vector3 BoundDiagonal {
    Vector3 get ();
}

Property Value

Type: Vector3
See Also

Reference

ClipData Class
VisualComponents.UX.Shared Namespace


ClipData.HasBound Property

ClipDataHasBound Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HasBound { get; }
public:
property bool HasBound {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ClipData Class
VisualComponents.UX.Shared Namespace


ClipData.HasItems Property

ClipDataHasItems Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HasItems { get; }
public:
virtual property bool HasItems {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IClipDataWithItemsHasItems
See Also

Reference

ClipData Class
VisualComponents.UX.Shared Namespace


ClipData Methods

The ClipData type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetCopyDataT | Generic helper method for getting copy data of specific class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MakeCopy |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ClipData Class
VisualComponents.UX.Shared Namespace


ClipData.Dispose Method

ClipDataDispose Method

Releases all resources used by the ClipData

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Dispose()
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

ClipData Class
VisualComponents.UX.Shared Namespace


ClipData.GetCopyData(T) Method

ClipDataGetCopyDataT Method

Generic helper method for getting copy data of specific class.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static T GetCopyData<T>()
where T : IClipDataWithItems

public:
generic<typename T>
where T : IClipDataWithItems
static T GetCopyData()

Type Parameters

T

Return Value

Type: T

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ClipData.GetCopyData``1"]

See Also

Reference

ClipData Class
VisualComponents.UX.Shared Namespace


ClipData.MakeCopy Method

ClipDataMakeCopy Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISharedCloneable[] MakeCopy(
    Matrix offset,
    bool extraOffset = false
)
public:
array<ISharedCloneable^>^ MakeCopy(
    Matrix offset,
    bool extraOffset = false
)

Parameters

offset
Type: VisualComponents.Create3DMatrix
extraOffset (Optional)
Type: SystemBoolean

Return Value

Type: ISharedCloneable

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ClipData.MakeCopy(VisualComponents.Create3D.Matrix,System.Boolean)"]

See Also

Reference

ClipData Class
VisualComponents.UX.Shared Namespace


ClockDisplayFormat Structure

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct ClockDisplayFormat
public value class ClockDisplayFormat

The ClockDisplayFormat type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName |
Public property | Id |
Public property | Name |
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ClockDisplayFormat Properties

The ClockDisplayFormat type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName |
Public property | Id |
Public property | Name |
Top
See Also

Reference

ClockDisplayFormat Structure
VisualComponents.UX.Shared Namespace


ClockDisplayFormat.DisplayName Property

ClockDisplayFormatDisplayName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string DisplayName { get; set; }
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ClockDisplayFormat Structure
VisualComponents.UX.Shared Namespace


ClockDisplayFormat.Id Property

ClockDisplayFormatId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Id { get; set; }
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ClockDisplayFormat Structure
VisualComponents.UX.Shared Namespace


ClockDisplayFormat.Name Property

ClockDisplayFormatName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; set; }
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ClockDisplayFormat Structure
VisualComponents.UX.Shared Namespace


ClockDisplayFormat Methods

The ClockDisplayFormat type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ClockDisplayFormat Structure
VisualComponents.UX.Shared Namespace


CollapsiblePanel Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsHeaderedContentControl
System.Windows.ControlsExpander
VisualComponents.UX.SharedCollapsiblePanel

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class CollapsiblePanel : Expander
public ref class CollapsiblePanel : public Expander

The CollapsiblePanel type exposes the following members.

Constructors
 | Name | Description
Public method | CollapsiblePanel | Initializes a new instance of the CollapsiblePanel class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExpandDirection | Gets or sets the direction in which the Expander content window opens. (Inherited from Expander.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | HasHeader | Gets a value that indicates whether the header is . (Inherited from HeaderedContentControl.)
Public property | Header | Gets or sets the data used for the header of each control. (Inherited from HeaderedContentControl.)
Public property | HeaderStringFormat | Gets or sets a composite string that specifies how to format the Header property if it is displayed as a string. (Inherited from HeaderedContentControl.)
Public property | HeaderTemplate | Gets or sets the template used to display the content of the control's header. (Inherited from HeaderedContentControl.)
Public property | HeaderTemplateSelector | Gets or sets a data template selector that provides custom logic for choosing the template used to display the header. (Inherited from HeaderedContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsExpanded | Gets or sets whether the Expander content window is visible. (Inherited from Expander.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the logical child elements of the ControlTemplate. (Inherited from HeaderedContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call the ApplyTemplate method. (Inherited from Expander.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnCollapsed | Raises the Collapsed event when the IsExpanded property changes from to . (Inherited from Expander.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates the implementation of AutomationPeer for the Expander control. (Inherited from Expander.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnExpanded | Raises the Expanded event when the IsExpanded property changes from to . (Inherited from Expander.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnHeaderChanged | Called when the Header property of a HeaderedContentControl changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderStringFormatChanged | Called when the HeaderStringFormat property changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderTemplateChanged | Called when the HeaderTemplate property changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderTemplateSelectorChanged | Called when the HeaderTemplateSelector property changes. (Inherited from HeaderedContentControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Provides a string representation of a HeaderedContentControl. (Inherited from HeaderedContentControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | Collapsed | Occurs when the content window of an Expander control closes and only the Header is visible. (Inherited from Expander.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | Expanded | Occurs when the content window of an Expander control opens to display both its header and content. (Inherited from Expander.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


CollapsiblePanel Constructor

Initializes a new instance of the CollapsiblePanel class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CollapsiblePanel()
public:
CollapsiblePanel()
See Also

Reference

CollapsiblePanel Class
VisualComponents.UX.Shared Namespace


CollapsiblePanel Properties

The CollapsiblePanel type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExpandDirection | Gets or sets the direction in which the Expander content window opens. (Inherited from Expander.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | HasHeader | Gets a value that indicates whether the header is . (Inherited from HeaderedContentControl.)
Public property | Header | Gets or sets the data used for the header of each control. (Inherited from HeaderedContentControl.)
Public property | HeaderStringFormat | Gets or sets a composite string that specifies how to format the Header property if it is displayed as a string. (Inherited from HeaderedContentControl.)
Public property | HeaderTemplate | Gets or sets the template used to display the content of the control's header. (Inherited from HeaderedContentControl.)
Public property | HeaderTemplateSelector | Gets or sets a data template selector that provides custom logic for choosing the template used to display the header. (Inherited from HeaderedContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsExpanded | Gets or sets whether the Expander content window is visible. (Inherited from Expander.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the logical child elements of the ControlTemplate. (Inherited from HeaderedContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

CollapsiblePanel Class
VisualComponents.UX.Shared Namespace


CollapsiblePanel Methods

The CollapsiblePanel type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | Invoked whenever application code or internal processes call the ApplyTemplate method. (Inherited from Expander.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnCollapsed | Raises the Collapsed event when the IsExpanded property changes from to . (Inherited from Expander.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates the implementation of AutomationPeer for the Expander control. (Inherited from Expander.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnExpanded | Raises the Expanded event when the IsExpanded property changes from to . (Inherited from Expander.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnHeaderChanged | Called when the Header property of a HeaderedContentControl changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderStringFormatChanged | Called when the HeaderStringFormat property changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderTemplateChanged | Called when the HeaderTemplate property changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderTemplateSelectorChanged | Called when the HeaderTemplateSelector property changes. (Inherited from HeaderedContentControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Provides a string representation of a HeaderedContentControl. (Inherited from HeaderedContentControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CollapsiblePanel Class
VisualComponents.UX.Shared Namespace


CollapsiblePanel Events

The CollapsiblePanel type exposes the following members.

Events
 | Name | Description
Public event | Collapsed | Occurs when the content window of an Expander control closes and only the Header is visible. (Inherited from Expander.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | Expanded | Occurs when the content window of an Expander control opens to display both its header and content. (Inherited from Expander.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

CollapsiblePanel Class
VisualComponents.UX.Shared Namespace


CollisionDetectionEditAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedCollisionDetectionEditAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class CollisionDetectionEditAction : ICommandPanelAction,
    ICollisionDetectionEditAction, IHandle<RequestActionAbortMessage>, IHandle
public ref class CollisionDetectionEditAction sealed : ICommandPanelAction,
    ICollisionDetectionEditAction, IHandle<RequestActionAbortMessage^>, IHandle

The CollisionDetectionEditAction type exposes the following members.

Constructors
 | Name | Description
Public method | CollisionDetectionEditAction | Initializes a new instance of the CollisionDetectionEditAction class
Top
Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
Public property | Title |
Top
Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle |
Public method | StartAction(EventHandlerResultCompletionEventArgs) |
Public method | StartAction(EventHandlerResultCompletionEventArgs, ICollisionDetector) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


CollisionDetectionEditAction Constructor

Initializes a new instance of the CollisionDetectionEditAction class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CollisionDetectionEditAction()
public:
CollisionDetectionEditAction()
See Also

Reference

CollisionDetectionEditAction Class
VisualComponents.UX.Shared Namespace


CollisionDetectionEditAction Properties

The CollisionDetectionEditAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
Public property | Title |
Top
See Also

Reference

CollisionDetectionEditAction Class
VisualComponents.UX.Shared Namespace


CollisionDetectionEditAction.ActionFinished Property

CollisionDetectionEditActionActionFinished Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ActionFinished { get; set; }
public:
virtual property bool ActionFinished {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ICommandPanelActionActionFinished
See Also

Reference

CollisionDetectionEditAction Class
VisualComponents.UX.Shared Namespace


CollisionDetectionEditAction.ActionProperties Property

CollisionDetectionEditActionActionProperties Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<IProperty> ActionProperties { get; }
public:
virtual property List<IProperty^>^ ActionProperties {
    List<IProperty^>^ get () sealed;
}

Property Value

Type: ListIProperty

Implements

ICommandPanelActionActionProperties
See Also

Reference

CollisionDetectionEditAction Class
VisualComponents.UX.Shared Namespace


CollisionDetectionEditAction.ApplyButtonText Property

CollisionDetectionEditActionApplyButtonText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ApplyButtonText { get; }
public:
virtual property String^ ApplyButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionApplyButtonText
See Also

Reference

CollisionDetectionEditAction Class
VisualComponents.UX.Shared Namespace


CollisionDetectionEditAction.AssociatedModelId Property

CollisionDetectionEditActionAssociatedModelId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedModelId { get; }
public:
virtual property String^ AssociatedModelId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedModelId
See Also

Reference

CollisionDetectionEditAction Class
VisualComponents.UX.Shared Namespace


CollisionDetectionEditAction.AssociatedSiteId Property

CollisionDetectionEditActionAssociatedSiteId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedSiteId { get; }
public:
virtual property String^ AssociatedSiteId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedSiteId
See Also

Reference

CollisionDetectionEditAction Class
VisualComponents.UX.Shared Namespace


CollisionDetectionEditAction.CallingCommandName Property

CollisionDetectionEditActionCallingCommandName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CallingCommandName { get; }
public:
virtual property String^ CallingCommandName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCallingCommandName
See Also

Reference

CollisionDetectionEditAction Class
VisualComponents.UX.Shared Namespace


CollisionDetectionEditAction.CancelButtonText Property

CollisionDetectionEditActionCancelButtonText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CancelButtonText { get; }
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCancelButtonText
See Also

Reference

CollisionDetectionEditAction Class
VisualComponents.UX.Shared Namespace


CollisionDetectionEditAction.Description Property

CollisionDetectionEditActionDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; }
public:
virtual property String^ Description {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionDescription
See Also

Reference

CollisionDetectionEditAction Class
VisualComponents.UX.Shared Namespace


CollisionDetectionEditAction.ErrorMessage Property

CollisionDetectionEditActionErrorMessage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ErrorMessage { get; set; }
public:
virtual property String^ ErrorMessage {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionErrorMessage
See Also

Reference

CollisionDetectionEditAction Class
VisualComponents.UX.Shared Namespace


CollisionDetectionEditAction.Title Property

CollisionDetectionEditActionTitle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; }
public:
virtual property String^ Title {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionTitle
See Also

Reference

CollisionDetectionEditAction Class
VisualComponents.UX.Shared Namespace


CollisionDetectionEditAction Methods

The CollisionDetectionEditAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle |
Public method | StartAction(EventHandlerResultCompletionEventArgs) |
Public method | StartAction(EventHandlerResultCompletionEventArgs, ICollisionDetector) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CollisionDetectionEditAction Class
VisualComponents.UX.Shared Namespace


CollisionDetectionEditAction.ApplyAction Method

CollisionDetectionEditActionApplyAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ApplyAction()
public:
virtual bool ApplyAction() sealed

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.CollisionDetectionEditAction.ApplyAction"]

Implements

ICommandPanelActionApplyAction
See Also

Reference

CollisionDetectionEditAction Class
VisualComponents.UX.Shared Namespace


CollisionDetectionEditAction.CancelAction Method

CollisionDetectionEditActionCancelAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CancelAction()
public:
virtual void CancelAction() sealed

Implements

ICommandPanelActionCancelAction
See Also

Reference

CollisionDetectionEditAction Class
VisualComponents.UX.Shared Namespace


CollisionDetectionEditAction.Handle Method

CollisionDetectionEditActionHandle Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    RequestActionAbortMessage message
)
public:
virtual void Handle(
    RequestActionAbortMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedRequestActionAbortMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

CollisionDetectionEditAction Class
VisualComponents.UX.Shared Namespace


CollisionDetectionEditAction.StartAction Method

CollisionDetectionEditActionStartAction Method

Overload List
 | Name | Description
Public method | StartAction(EventHandlerResultCompletionEventArgs) |
Public method | StartAction(EventHandlerResultCompletionEventArgs, ICollisionDetector) |
Top
See Also

Reference

CollisionDetectionEditAction Class
VisualComponents.UX.Shared Namespace


CollisionDetectionEditAction.StartAction Method (EventHandler(ResultCompletionEventArgs))

CollisionDetectionEditActionStartAction Method (EventHandlerResultCompletionEventArgs)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    EventHandler<ResultCompletionEventArgs> completed = null
)
public:
virtual void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr
) sealed

Parameters

completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs

Implements

ICommandPanelActionStartAction(EventHandlerResultCompletionEventArgs)
See Also

Reference

CollisionDetectionEditAction Class
StartAction Overload
VisualComponents.UX.Shared Namespace


CollisionDetectionEditAction.StartAction Method (EventHandler(ResultCompletionEventArgs), ICollisionDetector)

CollisionDetectionEditActionStartAction Method (EventHandlerResultCompletionEventArgs, ICollisionDetector)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    EventHandler<ResultCompletionEventArgs> completed,
    ICollisionDetector e
)
public:
virtual void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed,
    ICollisionDetector^ e
) sealed

Parameters

completed
Type: SystemEventHandlerResultCompletionEventArgs
e
Type: VisualComponents.Create3DICollisionDetector

Implements

ICollisionDetectionEditActionStartAction(EventHandlerResultCompletionEventArgs, ICollisionDetector)
See Also

Reference

CollisionDetectionEditAction Class
StartAction Overload
VisualComponents.UX.Shared Namespace


CollisionOverrideAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedCollisionOverrideAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class CollisionOverrideAction : ICommandPanelAction,
    IHandle<ItemSelectedMessage<IRobot>>, IHandle
public ref class CollisionOverrideAction sealed : ICommandPanelAction,
    IHandle<ItemSelectedMessage<IRobot^>^>, IHandle

The CollisionOverrideAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
 | Instance |
Public property | Title |
Top
Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle |
Public method | StartAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


CollisionOverrideAction Properties

The CollisionOverrideAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
 | Instance |
Public property | Title |
Top
See Also

Reference

CollisionOverrideAction Class
VisualComponents.UX.Shared Namespace


CollisionOverrideAction.ActionFinished Property

CollisionOverrideActionActionFinished Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ActionFinished { get; set; }
public:
virtual property bool ActionFinished {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ICommandPanelActionActionFinished
See Also

Reference

CollisionOverrideAction Class
VisualComponents.UX.Shared Namespace


CollisionOverrideAction.ActionProperties Property

CollisionOverrideActionActionProperties Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<IProperty> ActionProperties { get; }
public:
virtual property List<IProperty^>^ ActionProperties {
    List<IProperty^>^ get () sealed;
}

Property Value

Type: ListIProperty

Implements

ICommandPanelActionActionProperties
See Also

Reference

CollisionOverrideAction Class
VisualComponents.UX.Shared Namespace


CollisionOverrideAction.ApplyButtonText Property

CollisionOverrideActionApplyButtonText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ApplyButtonText { get; }
public:
virtual property String^ ApplyButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionApplyButtonText
See Also

Reference

CollisionOverrideAction Class
VisualComponents.UX.Shared Namespace


CollisionOverrideAction.AssociatedModelId Property

CollisionOverrideActionAssociatedModelId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedModelId { get; }
public:
virtual property String^ AssociatedModelId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedModelId
See Also

Reference

CollisionOverrideAction Class
VisualComponents.UX.Shared Namespace


CollisionOverrideAction.AssociatedSiteId Property

CollisionOverrideActionAssociatedSiteId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedSiteId { get; }
public:
virtual property String^ AssociatedSiteId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedSiteId
See Also

Reference

CollisionOverrideAction Class
VisualComponents.UX.Shared Namespace


CollisionOverrideAction.CallingCommandName Property

CollisionOverrideActionCallingCommandName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CallingCommandName { get; }
public:
virtual property String^ CallingCommandName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCallingCommandName
See Also

Reference

CollisionOverrideAction Class
VisualComponents.UX.Shared Namespace


CollisionOverrideAction.CancelButtonText Property

CollisionOverrideActionCancelButtonText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CancelButtonText { get; }
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCancelButtonText
See Also

Reference

CollisionOverrideAction Class
VisualComponents.UX.Shared Namespace


CollisionOverrideAction.Description Property

CollisionOverrideActionDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; }
public:
virtual property String^ Description {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionDescription
See Also

Reference

CollisionOverrideAction Class
VisualComponents.UX.Shared Namespace


CollisionOverrideAction.ErrorMessage Property

CollisionOverrideActionErrorMessage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ErrorMessage { get; set; }
public:
virtual property String^ ErrorMessage {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionErrorMessage
See Also

Reference

CollisionOverrideAction Class
VisualComponents.UX.Shared Namespace


CollisionOverrideAction.Instance Property

CollisionOverrideActionInstance Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static CollisionOverrideAction Instance { get; }
public:
static property CollisionOverrideAction^ Instance {
    CollisionOverrideAction^ get ();
}

Property Value

Type: CollisionOverrideAction
See Also

Reference

CollisionOverrideAction Class
VisualComponents.UX.Shared Namespace


CollisionOverrideAction.Title Property

CollisionOverrideActionTitle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; }
public:
virtual property String^ Title {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionTitle
See Also

Reference

CollisionOverrideAction Class
VisualComponents.UX.Shared Namespace


CollisionOverrideAction Methods

The CollisionOverrideAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle |
Public method | StartAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CollisionOverrideAction Class
VisualComponents.UX.Shared Namespace


CollisionOverrideAction.ApplyAction Method

CollisionOverrideActionApplyAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ApplyAction()
public:
virtual bool ApplyAction() sealed

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.CollisionOverrideAction.ApplyAction"]

Implements

ICommandPanelActionApplyAction
See Also

Reference

CollisionOverrideAction Class
VisualComponents.UX.Shared Namespace


CollisionOverrideAction.CancelAction Method

CollisionOverrideActionCancelAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CancelAction()
public:
virtual void CancelAction() sealed

Implements

ICommandPanelActionCancelAction
See Also

Reference

CollisionOverrideAction Class
VisualComponents.UX.Shared Namespace


CollisionOverrideAction.Handle Method

CollisionOverrideActionHandle Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    ItemSelectedMessage<IRobot> message
)
public:
virtual void Handle(
    ItemSelectedMessage<IRobot^>^ message
) sealed

Parameters

message
Type: VisualComponents.Create3DItemSelectedMessage IRobot

Implements

IHandle.Handle(UTP)
See Also

Reference

CollisionOverrideAction Class
VisualComponents.UX.Shared Namespace


CollisionOverrideAction.StartAction Method

CollisionOverrideActionStartAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    EventHandler<ResultCompletionEventArgs> completed = null
)
public:
virtual void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr
) sealed

Parameters

completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs

Implements

ICommandPanelActionStartAction(EventHandlerResultCompletionEventArgs)
See Also

Reference

CollisionOverrideAction Class
VisualComponents.UX.Shared Namespace


ColorUtility Class

color helper
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedColorUtility

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ColorUtility
public ref class ColorUtility

The ColorUtility type exposes the following members.

Constructors
 | Name | Description
Public method | ColorUtility | Initializes a new instance of the ColorUtility class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetRgb | Convert RGB values in double format to color
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ColorUtility Constructor

Initializes a new instance of the ColorUtility class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ColorUtility()
public:
ColorUtility()
See Also

Reference

ColorUtility Class
VisualComponents.UX.Shared Namespace


ColorUtility Methods

The ColorUtility type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetRgb | Convert RGB values in double format to color
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ColorUtility Class
VisualComponents.UX.Shared Namespace


ColorUtility.GetRgb Method

ColorUtilityGetRgb Method

Convert RGB values in double format to color

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Color GetRgb(
    double r,
    double g,
    double b
)
public:
static Color GetRgb(
    double r,
    double g,
    double b
)

Parameters

r
Type: SystemDouble
The red channel
g
Type: SystemDouble
The green channel
b
Type: SystemDouble
The blue channnel

Return Value

Type: Color
Color
See Also

Reference

ColorUtility Class
VisualComponents.UX.Shared Namespace


Column Class

Column is used to stack layout elements in vertical column. It is possible for a row to contain multiple columns.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedLayoutElement
VisualComponents.UX.SharedColumn

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class Column : LayoutElement,
    INotifyPropertyChanged
public ref class Column sealed : public LayoutElement,
    INotifyPropertyChanged

The Column type exposes the following members.

Constructors
 | Name | Description
Public method | Column | Initializes a new instance of the Column class
Top
Properties
 | Name | Description
Public property | Children | Provides capability to add child elements to any layout element. (Inherited from LayoutElement.)
Public property | Content | Not in use.
Public property | Controls | Set of controls in column.
Public property | ElementType | (Inherited from LayoutElement.)
Public property | Index |
Public property | Rows | Set of rows in column.
Public property | Tabs | Set of tabs in column.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NotifyPropertyChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


Column Constructor

Initializes a new instance of the Column class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Column()
public:
Column()
See Also

Reference

Column Class
VisualComponents.UX.Shared Namespace


Column Properties

The Column type exposes the following members.

Properties
 | Name | Description
Public property | Children | Provides capability to add child elements to any layout element. (Inherited from LayoutElement.)
Public property | Content | Not in use.
Public property | Controls | Set of controls in column.
Public property | ElementType | (Inherited from LayoutElement.)
Public property | Index |
Public property | Rows | Set of rows in column.
Public property | Tabs | Set of tabs in column.
Top
See Also

Reference

Column Class
VisualComponents.UX.Shared Namespace


Column.Content Property

ColumnContent Property

Not in use.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Content { get; set; }
public:
property String^ Content {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Column Class
VisualComponents.UX.Shared Namespace


Column.Controls Property

ColumnControls Property

Set of controls in column.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IReadOnlyCollection<ControlDescription> Controls { get; }
public:
property IReadOnlyCollection<ControlDescription^>^ Controls {
    IReadOnlyCollection<ControlDescription^>^ get ();
}

Property Value

Type: IReadOnlyCollectionControlDescription
See Also

Reference

Column Class
VisualComponents.UX.Shared Namespace


Column.Index Property

ColumnIndex Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Index { get; set; }
public:
property int Index {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

Column Class
VisualComponents.UX.Shared Namespace


Column.Rows Property

ColumnRows Property

Set of rows in column.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<Row> Rows { get; }
public:
property ReadOnlyCollection<Row^>^ Rows {
    ReadOnlyCollection<Row^>^ get ();
}

Property Value

Type: ReadOnlyCollectionRow
See Also

Reference

Column Class
VisualComponents.UX.Shared Namespace


Column.Tabs Property

ColumnTabs Property

Set of tabs in column.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<Tab> Tabs { get; }
public:
property ReadOnlyCollection<Tab^>^ Tabs {
    ReadOnlyCollection<Tab^>^ get ();
}

Property Value

Type: ReadOnlyCollectionTab
See Also

Reference

Column Class
VisualComponents.UX.Shared Namespace


Column Methods

The Column type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NotifyPropertyChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

Column Class
VisualComponents.UX.Shared Namespace


Column.NotifyPropertyChanged Method

ColumnNotifyPropertyChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void NotifyPropertyChanged(
    string propertyName
)
public:
void NotifyPropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: SystemString
See Also

Reference

Column Class
VisualComponents.UX.Shared Namespace


Column Events

The Column type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

Column Class
VisualComponents.UX.Shared Namespace


Column.PropertyChanged Event

ColumnPropertyChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event PropertyChangedEventHandler PropertyChanged
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

Column Class
VisualComponents.UX.Shared Namespace


ComboBoxEditorPropertyProxy Class

Helper class that allows to modify combobox Items without changing the selected item.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedComboBoxEditorPropertyProxy

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class ComboBoxEditorPropertyProxy
public ref class ComboBoxEditorPropertyProxy abstract sealed

The ComboBoxEditorPropertyProxy type exposes the following members.

Methods
Name | Description
GetItemsSource |
SetItemsSource |
Top
Fields
Name | Description
ItemsSourceProperty |
Top
Attached Properties
 | Name | Description
Public attached property | ItemsSource |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ComboBoxEditorPropertyProxy Methods

The ComboBoxEditorPropertyProxy type exposes the following members.

Methods
Name | Description
GetItemsSource |
SetItemsSource |
Top
See Also

Reference

ComboBoxEditorPropertyProxy Class
VisualComponents.UX.Shared Namespace


ComboBoxEditorPropertyProxy.GetItemsSource Method

ComboBoxEditorPropertyProxyGetItemsSource Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IEnumerable GetItemsSource(
    UIElement element
)
public:
static IEnumerable^ GetItemsSource(
    UIElement^ element
)

Parameters

element
Type: System.WindowsUIElement

Return Value

Type: IEnumerable

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ComboBoxEditorPropertyProxy.GetItemsSource(System.Windows.UIElement)"]

See Also

Reference

ComboBoxEditorPropertyProxy Class
VisualComponents.UX.Shared Namespace


ComboBoxEditorPropertyProxy.SetItemsSource Method

ComboBoxEditorPropertyProxySetItemsSource Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetItemsSource(
    UIElement element,
    bool value
)
public:
static void SetItemsSource(
    UIElement^ element,
    bool value
)

Parameters

element
Type: System.WindowsUIElement
value
Type: SystemBoolean
See Also

Reference

ComboBoxEditorPropertyProxy Class
VisualComponents.UX.Shared Namespace


ComboBoxEditorPropertyProxy Fields

The ComboBoxEditorPropertyProxy type exposes the following members.

Fields
Name | Description
ItemsSourceProperty |
Top
See Also

Reference

ComboBoxEditorPropertyProxy Class
VisualComponents.UX.Shared Namespace


ComboBoxEditorPropertyProxy.ItemsSourceProperty Field

ComboBoxEditorPropertyProxyItemsSourceProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ItemsSourceProperty
public:
static initonly DependencyProperty^ ItemsSourceProperty

Field Value

Type: DependencyProperty
See Also

Reference

ComboBoxEditorPropertyProxy Class
VisualComponents.UX.Shared Namespace


ComboBoxEditorPropertyProxy Attached Properties

The ComboBoxEditorPropertyProxy type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | ItemsSource |
Top
See Also

Reference

ComboBoxEditorPropertyProxy Class
VisualComponents.UX.Shared Namespace


ComboBoxEditorPropertyProxy.ItemsSource Attached Property

ComboBoxEditorPropertyProxyItemsSource Attached Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See GetItemsSource, SetItemsSource
See GetItemsSource, SetItemsSource

Property Value

Type: IEnumerable
See Also

Reference

ComboBoxEditorPropertyProxy Class
VisualComponents.UX.Shared Namespace


ComboBoxEx Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsItemsControl
System.Windows.Controls.PrimitivesSelector
System.Windows.ControlsComboBox
VisualComponents.UX.SharedComboBoxEx

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ComboBoxEx : ComboBox
public ref class ComboBoxEx : public ComboBox

The ComboBoxEx type exposes the following members.

Constructors
 | Name | Description
Public method | ComboBoxEx | Initializes a new instance of the ComboBoxEx class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a combo box supports scrolling. (Inherited from ComboBox.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the ComboBox has focus. (Inherited from ComboBox.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsDropDownOpen | Gets or sets a value that indicates whether the drop-down for a combo box is currently open. (Inherited from ComboBox.)
Public property | IsEditable | Gets or sets a value that enables or disables editing of the text in text box of the ComboBox. (Inherited from ComboBox.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that enables selection-only mode, in which the contents of the combo box are selectable but not editable. (Inherited from ComboBox.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionBoxHighlighted | Gets whether the SelectionBoxItem is highlighted. (Inherited from ComboBox.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemSelector |
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxDropDownHeight | Gets or sets the maximum height for a combo box drop-down. (Inherited from ComboBox.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedItems |
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionBoxItem | Gets the item that is displayed in the selection box. (Inherited from ComboBox.)
Public property | SelectionBoxItems |
Public property | SelectionBoxItemStringFormat | Gets a composite string that specifies how to format the selected item in the selection box if it is displayed as a string. (Inherited from ComboBox.)
Public property | SelectionBoxItemTemplate | Gets the item template of the selection box content. (Inherited from ComboBox.)
Public property | SelectionMode |
Public property | ShouldPreserveUserEnteredPrefix | Gets or sets a value that indicates whether the ComboBox keeps the user's input or replaces the input with a matching item. (Inherited from ComboBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | StaysOpenOnEdit | Gets or sets whether a ComboBox that is open and displays a drop-down control will remain open when a user clicks the TextBox. (Inherited from ComboBox.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Gets or sets the text of the currently selected item. (Inherited from ComboBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Returns an item container to the state it was in before PrepareContainerForItemOverride(DependencyObject, Object). (Inherited from Selector.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Inherited from ComboBox.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | IsItemItsOwnContainer | Determines if the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ComboBox.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | (Overrides ComboBoxOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ComboBoxAutomationPeer implementation for this control, as part of the WPF infrastructure. (Inherited from ComboBox.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDropDownClosed | Reports when a combo box's popup closes. (Inherited from ComboBox.)
Protected method | OnDropDownOpened | Reports when a combo box's popup opens. (Inherited from ComboBox.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to internally. (Inherited from Selector.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from ComboBox.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes. (Inherited from ComboBox.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Invoked when a KeyDown attached routed event occurs. (Inherited from ComboBox.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Called to report that the left mouse button was released. (Inherited from ComboBox.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when a PreviewKeyDown attached routed event occurs. (Inherited from ComboBox.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | (Overrides FrameworkElementOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | (Overrides ComboBoxOnSelectionChanged(SelectionChangedEventArgs).)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ComboBox.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropDownClosed | Occurs when the drop-down list of the combo box closes. (Inherited from ComboBox.)
Public event | DropDownOpened | Occurs when the drop-down list of the combo box opens. (Inherited from ComboBox.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
ItemSelectorProperty |
ItemSelectorPropertyKey |
SelectedItemsProperty |
SelectedItemsPropertyKey |
SelectionBoxItemsProperty |
SelectionBoxItemsPropertyKey |
SelectionModeProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ComboBoxEx Constructor

Initializes a new instance of the ComboBoxEx class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ComboBoxEx()
public:
ComboBoxEx()
See Also

Reference

ComboBoxEx Class
VisualComponents.UX.Shared Namespace


ComboBoxEx Properties

The ComboBoxEx type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a combo box supports scrolling. (Inherited from ComboBox.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the ComboBox has focus. (Inherited from ComboBox.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsDropDownOpen | Gets or sets a value that indicates whether the drop-down for a combo box is currently open. (Inherited from ComboBox.)
Public property | IsEditable | Gets or sets a value that enables or disables editing of the text in text box of the ComboBox. (Inherited from ComboBox.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that enables selection-only mode, in which the contents of the combo box are selectable but not editable. (Inherited from ComboBox.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionBoxHighlighted | Gets whether the SelectionBoxItem is highlighted. (Inherited from ComboBox.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemSelector |
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxDropDownHeight | Gets or sets the maximum height for a combo box drop-down. (Inherited from ComboBox.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedItems |
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionBoxItem | Gets the item that is displayed in the selection box. (Inherited from ComboBox.)
Public property | SelectionBoxItems |
Public property | SelectionBoxItemStringFormat | Gets a composite string that specifies how to format the selected item in the selection box if it is displayed as a string. (Inherited from ComboBox.)
Public property | SelectionBoxItemTemplate | Gets the item template of the selection box content. (Inherited from ComboBox.)
Public property | SelectionMode |
Public property | ShouldPreserveUserEnteredPrefix | Gets or sets a value that indicates whether the ComboBox keeps the user's input or replaces the input with a matching item. (Inherited from ComboBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | StaysOpenOnEdit | Gets or sets whether a ComboBox that is open and displays a drop-down control will remain open when a user clicks the TextBox. (Inherited from ComboBox.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Gets or sets the text of the currently selected item. (Inherited from ComboBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ComboBoxEx Class
VisualComponents.UX.Shared Namespace


ComboBoxEx.ItemSelector Property

ComboBoxExItemSelector Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ListBox ItemSelector { get; }
public:
property ListBox^ ItemSelector {
    ListBox^ get ();
}

Property Value

Type: ListBox
See Also

Reference

ComboBoxEx Class
VisualComponents.UX.Shared Namespace


ComboBoxEx.SelectedItems Property

ComboBoxExSelectedItems Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList SelectedItems { get; }
public:
property IList^ SelectedItems {
    IList^ get ();
}

Property Value

Type: IList
See Also

Reference

ComboBoxEx Class
VisualComponents.UX.Shared Namespace


ComboBoxEx.SelectionBoxItems Property

ComboBoxExSelectionBoxItems Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList SelectionBoxItems { get; }
public:
property IList^ SelectionBoxItems {
    IList^ get ();
}

Property Value

Type: IList
See Also

Reference

ComboBoxEx Class
VisualComponents.UX.Shared Namespace


ComboBoxEx.SelectionMode Property

ComboBoxExSelectionMode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SelectionMode SelectionMode { get; set; }
public:
property SelectionMode SelectionMode {
    SelectionMode get ();
    void set (SelectionMode value);
}

Property Value

Type: SelectionMode
See Also

Reference

ComboBoxEx Class
VisualComponents.UX.Shared Namespace


ComboBoxEx Methods

The ComboBoxEx type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Returns an item container to the state it was in before PrepareContainerForItemOverride(DependencyObject, Object). (Inherited from Selector.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Inherited from ComboBox.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | IsItemItsOwnContainer | Determines if the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ComboBox.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | (Overrides ComboBoxOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ComboBoxAutomationPeer implementation for this control, as part of the WPF infrastructure. (Inherited from ComboBox.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDropDownClosed | Reports when a combo box's popup closes. (Inherited from ComboBox.)
Protected method | OnDropDownOpened | Reports when a combo box's popup opens. (Inherited from ComboBox.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to internally. (Inherited from Selector.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from ComboBox.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes. (Inherited from ComboBox.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Invoked when a KeyDown attached routed event occurs. (Inherited from ComboBox.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Called to report that the left mouse button was released. (Inherited from ComboBox.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when a PreviewKeyDown attached routed event occurs. (Inherited from ComboBox.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | (Overrides FrameworkElementOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | (Overrides ComboBoxOnSelectionChanged(SelectionChangedEventArgs).)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ComboBox.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ComboBoxEx Class
VisualComponents.UX.Shared Namespace


ComboBoxEx.OnApplyTemplate Method

ComboBoxExOnApplyTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

ComboBoxEx Class
VisualComponents.UX.Shared Namespace


ComboBoxEx.OnPropertyChanged Method

ComboBoxExOnPropertyChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
)
protected:
virtual void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
) override

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
See Also

Reference

ComboBoxEx Class
VisualComponents.UX.Shared Namespace


ComboBoxEx.OnSelectionChanged Method

ComboBoxExOnSelectionChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnSelectionChanged(
    SelectionChangedEventArgs e
)
protected:
virtual void OnSelectionChanged(
    SelectionChangedEventArgs^ e
) override

Parameters

e
Type: System.Windows.ControlsSelectionChangedEventArgs
See Also

Reference

ComboBoxEx Class
VisualComponents.UX.Shared Namespace


ComboBoxEx Events

The ComboBoxEx type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropDownClosed | Occurs when the drop-down list of the combo box closes. (Inherited from ComboBox.)
Public event | DropDownOpened | Occurs when the drop-down list of the combo box opens. (Inherited from ComboBox.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ComboBoxEx Class
VisualComponents.UX.Shared Namespace


ComboBoxEx Fields

The ComboBoxEx type exposes the following members.

Fields
Name | Description
ItemSelectorProperty |
ItemSelectorPropertyKey |
SelectedItemsProperty |
SelectedItemsPropertyKey |
SelectionBoxItemsProperty |
SelectionBoxItemsPropertyKey |
SelectionModeProperty |
Top
See Also

Reference

ComboBoxEx Class
VisualComponents.UX.Shared Namespace


ComboBoxEx.ItemSelectorProperty Field

ComboBoxExItemSelectorProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ItemSelectorProperty
public:
static initonly DependencyProperty^ ItemSelectorProperty

Field Value

Type: DependencyProperty
See Also

Reference

ComboBoxEx Class
VisualComponents.UX.Shared Namespace


ComboBoxEx.ItemSelectorPropertyKey Field

ComboBoxExItemSelectorPropertyKey Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyPropertyKey ItemSelectorPropertyKey
public:
static initonly DependencyPropertyKey^ ItemSelectorPropertyKey

Field Value

Type: DependencyPropertyKey
See Also

Reference

ComboBoxEx Class
VisualComponents.UX.Shared Namespace


ComboBoxEx.SelectedItemsProperty Field

ComboBoxExSelectedItemsProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty SelectedItemsProperty
public:
static initonly DependencyProperty^ SelectedItemsProperty

Field Value

Type: DependencyProperty
See Also

Reference

ComboBoxEx Class
VisualComponents.UX.Shared Namespace


ComboBoxEx.SelectedItemsPropertyKey Field

ComboBoxExSelectedItemsPropertyKey Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyPropertyKey SelectedItemsPropertyKey
public:
static initonly DependencyPropertyKey^ SelectedItemsPropertyKey

Field Value

Type: DependencyPropertyKey
See Also

Reference

ComboBoxEx Class
VisualComponents.UX.Shared Namespace


ComboBoxEx.SelectionBoxItemsProperty Field

ComboBoxExSelectionBoxItemsProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty SelectionBoxItemsProperty
public:
static initonly DependencyProperty^ SelectionBoxItemsProperty

Field Value

Type: DependencyProperty
See Also

Reference

ComboBoxEx Class
VisualComponents.UX.Shared Namespace


ComboBoxEx.SelectionBoxItemsPropertyKey Field

ComboBoxExSelectionBoxItemsPropertyKey Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyPropertyKey SelectionBoxItemsPropertyKey
public:
static initonly DependencyPropertyKey^ SelectionBoxItemsPropertyKey

Field Value

Type: DependencyPropertyKey
See Also

Reference

ComboBoxEx Class
VisualComponents.UX.Shared Namespace


ComboBoxEx.SelectionModeProperty Field

ComboBoxExSelectionModeProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty SelectionModeProperty
public:
static initonly DependencyProperty^ SelectionModeProperty

Field Value

Type: DependencyProperty
See Also

Reference

ComboBoxEx Class
VisualComponents.UX.Shared Namespace


ComboItemBase Class

Base class for items presented in ComboEditortool
Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.SharedComboItemBase

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ComboItemBase : PropertyChangedBase
public ref class ComboItemBase : public PropertyChangedBase

The ComboItemBase type exposes the following members.

Constructors
 | Name | Description
Public method | ComboItemBase | Initializes a new instance of the ComboItemBase class
Top
Properties
 | Name | Description
Public property | Content | Display member of the combo box item.
Public property | Id | Id member of the combo box item
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | Parent | Action that contains the combo box.
Public property | Value | Value member of the combo box item
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ComboItemBase Constructor

Initializes a new instance of the ComboItemBase class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ComboItemBase()
public:
ComboItemBase()
See Also

Reference

ComboItemBase Class
VisualComponents.UX.Shared Namespace


ComboItemBase Properties

The ComboItemBase type exposes the following members.

Properties
 | Name | Description
Public property | Content | Display member of the combo box item.
Public property | Id | Id member of the combo box item
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | Parent | Action that contains the combo box.
Public property | Value | Value member of the combo box item
Top
See Also

Reference

ComboItemBase Class
VisualComponents.UX.Shared Namespace


ComboItemBase.Content Property

ComboItemBaseContent Property

Display member of the combo box item.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Content { get; set; }
public:
property String^ Content {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ComboItemBase Class
VisualComponents.UX.Shared Namespace


ComboItemBase.Id Property

ComboItemBaseId Property

Id member of the combo box item

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Id { get; set; }
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ComboItemBase Class
VisualComponents.UX.Shared Namespace


ComboItemBase.Parent Property

ComboItemBaseParent Property

Action that contains the combo box.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BaseActionItem Parent { get; set; }
public:
property BaseActionItem^ Parent {
    BaseActionItem^ get ();
    void set (BaseActionItem^ value);
}

Property Value

Type: BaseActionItem
See Also

Reference

ComboItemBase Class
VisualComponents.UX.Shared Namespace


ComboItemBase.Value Property

ComboItemBaseValue Property

Value member of the combo box item

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Value { get; set; }
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

ComboItemBase Class
VisualComponents.UX.Shared Namespace


ComboItemBase Methods

The ComboItemBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ComboItemBase Class
VisualComponents.UX.Shared Namespace


ComboItemBase Events

The ComboItemBase type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
See Also

Reference

ComboItemBase Class
VisualComponents.UX.Shared Namespace


CommandPanelHideMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedCommandPanelHideMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class CommandPanelHideMessage
public ref class CommandPanelHideMessage

The CommandPanelHideMessage type exposes the following members.

Constructors
 | Name | Description
Public method | CommandPanelHideMessage | Initializes a new instance of the CommandPanelHideMessage class
Top
Properties
 | Name | Description
Public property | Action |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


CommandPanelHideMessage Constructor

Initializes a new instance of the CommandPanelHideMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CommandPanelHideMessage(
    ICommandPanelAction action
)
public:
CommandPanelHideMessage(
    ICommandPanelAction^ action
)

Parameters

action
Type: VisualComponents.UX.SharedICommandPanelAction
See Also

Reference

CommandPanelHideMessage Class
VisualComponents.UX.Shared Namespace


CommandPanelHideMessage Properties

The CommandPanelHideMessage type exposes the following members.

Properties
 | Name | Description
Public property | Action |
Top
See Also

Reference

CommandPanelHideMessage Class
VisualComponents.UX.Shared Namespace


CommandPanelHideMessage.Action Property

CommandPanelHideMessageAction Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ICommandPanelAction Action { get; }
public:
property ICommandPanelAction^ Action {
    ICommandPanelAction^ get ();
}

Property Value

Type: ICommandPanelAction
See Also

Reference

CommandPanelHideMessage Class
VisualComponents.UX.Shared Namespace


CommandPanelHideMessage Methods

The CommandPanelHideMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CommandPanelHideMessage Class
VisualComponents.UX.Shared Namespace


CommandPanelShowMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedCommandPanelShowMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class CommandPanelShowMessage
public ref class CommandPanelShowMessage

The CommandPanelShowMessage type exposes the following members.

Constructors
 | Name | Description
Public method | CommandPanelShowMessage | Initializes a new instance of the CommandPanelShowMessage class
Top
Properties
 | Name | Description
Public property | Action |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


CommandPanelShowMessage Constructor

Initializes a new instance of the CommandPanelShowMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CommandPanelShowMessage(
    ICommandPanelAction action
)
public:
CommandPanelShowMessage(
    ICommandPanelAction^ action
)

Parameters

action
Type: VisualComponents.UX.SharedICommandPanelAction
See Also

Reference

CommandPanelShowMessage Class
VisualComponents.UX.Shared Namespace


CommandPanelShowMessage Properties

The CommandPanelShowMessage type exposes the following members.

Properties
 | Name | Description
Public property | Action |
Top
See Also

Reference

CommandPanelShowMessage Class
VisualComponents.UX.Shared Namespace


CommandPanelShowMessage.Action Property

CommandPanelShowMessageAction Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ICommandPanelAction Action { get; }
public:
property ICommandPanelAction^ Action {
    ICommandPanelAction^ get ();
}

Property Value

Type: ICommandPanelAction
See Also

Reference

CommandPanelShowMessage Class
VisualComponents.UX.Shared Namespace


CommandPanelShowMessage Methods

The CommandPanelShowMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CommandPanelShowMessage Class
VisualComponents.UX.Shared Namespace


CompletedRestoreMessage Class

Broad casted after autosave restoration is completed.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedCompletedRestoreMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class CompletedRestoreMessage
public ref class CompletedRestoreMessage sealed

The CompletedRestoreMessage type exposes the following members.

Constructors
 | Name | Description
Public method | CompletedRestoreMessage | Initializes a new instance of the CompletedRestoreMessage class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


CompletedRestoreMessage Constructor

Initializes a new instance of the CompletedRestoreMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CompletedRestoreMessage()
public:
CompletedRestoreMessage()
See Also

Reference

CompletedRestoreMessage Class
VisualComponents.UX.Shared Namespace


CompletedRestoreMessage Methods

The CompletedRestoreMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CompletedRestoreMessage Class
VisualComponents.UX.Shared Namespace


ComponentHelper Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedComponentHelper

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ComponentHelper
public ref class ComponentHelper

The ComponentHelper type exposes the following members.

Constructors
 | Name | Description
Public method | ComponentHelper | Initializes a new instance of the ComponentHelper class
Top
Properties
 | Name | Description
Public property | MaxBound |
Public property | MinBound |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSelectedComponentMinMaxBound(ISimComponent) |
Public method | GetSelectedComponentMinMaxBound(IEnumerableIVisualObject, ISimComponent) |
Public method | GetSelectedFeturesMinMaxBound |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ResolveNode |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ComponentHelper Constructor

Initializes a new instance of the ComponentHelper class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ComponentHelper()
public:
ComponentHelper()
See Also

Reference

ComponentHelper Class
VisualComponents.UX.Shared Namespace


ComponentHelper Properties

The ComponentHelper type exposes the following members.

Properties
 | Name | Description
Public property | MaxBound |
Public property | MinBound |
Top
See Also

Reference

ComponentHelper Class
VisualComponents.UX.Shared Namespace


ComponentHelper.MaxBound Property

ComponentHelperMaxBound Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 MaxBound { get; set; }
public:
property Vector3 MaxBound {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

ComponentHelper Class
VisualComponents.UX.Shared Namespace


ComponentHelper.MinBound Property

ComponentHelperMinBound Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 MinBound { get; set; }
public:
property Vector3 MinBound {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

ComponentHelper Class
VisualComponents.UX.Shared Namespace


ComponentHelper Methods

The ComponentHelper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSelectedComponentMinMaxBound(ISimComponent) |
Public method | GetSelectedComponentMinMaxBound(IEnumerableIVisualObject, ISimComponent) |
Public method | GetSelectedFeturesMinMaxBound |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ResolveNode |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ComponentHelper Class
VisualComponents.UX.Shared Namespace


ComponentHelper.GetSelectedComponentMinMaxBound Method

ComponentHelperGetSelectedComponentMinMaxBound Method

Overload List
 | Name | Description
Public method | GetSelectedComponentMinMaxBound(ISimComponent) |
Public method | GetSelectedComponentMinMaxBound(IEnumerableIVisualObject, ISimComponent) |
Top
See Also

Reference

ComponentHelper Class
VisualComponents.UX.Shared Namespace


ComponentHelper.GetSelectedComponentMinMaxBound Method (ISimComponent)

ComponentHelperGetSelectedComponentMinMaxBound Method (ISimComponent)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool GetSelectedComponentMinMaxBound(
    ISimComponent selectedComponent
)
public:
bool GetSelectedComponentMinMaxBound(
    ISimComponent^ selectedComponent
)

Parameters

selectedComponent
Type: VisualComponents.Create3DISimComponent

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ComponentHelper.GetSelectedComponentMinMaxBound(VisualComponents.Create3D.ISimComponent)"]

See Also

Reference

ComponentHelper Class
GetSelectedComponentMinMaxBound Overload
VisualComponents.UX.Shared Namespace


ComponentHelper.GetSelectedComponentMinMaxBound Method (IEnumerable(IVisualObject), ISimComponent)

ComponentHelperGetSelectedComponentMinMaxBound Method (IEnumerableIVisualObject, ISimComponent)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool GetSelectedComponentMinMaxBound(
    IEnumerable<IVisualObject> allSelected,
    ISimComponent selectedComponent
)
public:
bool GetSelectedComponentMinMaxBound(
    IEnumerable<IVisualObject^>^ allSelected,
    ISimComponent^ selectedComponent
)

Parameters

allSelected
Type: System.Collections.GenericIEnumerableIVisualObject
selectedComponent
Type: VisualComponents.Create3DISimComponent

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ComponentHelper.GetSelectedComponentMinMaxBound(System.Collections.Generic.IEnumerable{VisualComponents.Create3D.IVisualObject},VisualComponents.Create3D.ISimComponent)"]

See Also

Reference

ComponentHelper Class
GetSelectedComponentMinMaxBound Overload
VisualComponents.UX.Shared Namespace


ComponentHelper.GetSelectedFeturesMinMaxBound Method

ComponentHelperGetSelectedFeturesMinMaxBound Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool GetSelectedFeturesMinMaxBound(
    IEnumerable<IVisualObject> allSelected,
    ISimComponent selectedComponent
)
public:
bool GetSelectedFeturesMinMaxBound(
    IEnumerable<IVisualObject^>^ allSelected,
    ISimComponent^ selectedComponent
)

Parameters

allSelected
Type: System.Collections.GenericIEnumerableIVisualObject
selectedComponent
Type: VisualComponents.Create3DISimComponent

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ComponentHelper.GetSelectedFeturesMinMaxBound(System.Collections.Generic.IEnumerable{VisualComponents.Create3D.IVisualObject},VisualComponents.Create3D.ISimComponent)"]

See Also

Reference

ComponentHelper Class
VisualComponents.UX.Shared Namespace


ComponentHelper.ResolveNode Method

ComponentHelperResolveNode Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ISimNode ResolveNode(
    IApplication app,
    string name
)
public:
static ISimNode^ ResolveNode(
    IApplication^ app,
    String^ name
)

Parameters

app
Type: VisualComponents.Create3DIApplication
name
Type: SystemString

Return Value

Type: ISimNode

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ComponentHelper.ResolveNode(VisualComponents.Create3D.IApplication,System.String)"]

See Also

Reference

ComponentHelper Class
VisualComponents.UX.Shared Namespace


ComponentMetadataMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedComponentMetadataMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ComponentMetadataMessage
public ref class ComponentMetadataMessage

The ComponentMetadataMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ComponentMetadataMessage | Initializes a new instance of the ComponentMetadataMessage class
Top
Properties
 | Name | Description
Public property | SelectedComponents |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ComponentMetadataMessage Constructor

Initializes a new instance of the ComponentMetadataMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ComponentMetadataMessage(
    IEnumerable<ISimComponent> selectedComponents
)
public:
ComponentMetadataMessage(
    IEnumerable<ISimComponent^>^ selectedComponents
)

Parameters

selectedComponents
Type: System.Collections.GenericIEnumerableISimComponent
See Also

Reference

ComponentMetadataMessage Class
VisualComponents.UX.Shared Namespace


ComponentMetadataMessage Properties

The ComponentMetadataMessage type exposes the following members.

Properties
 | Name | Description
Public property | SelectedComponents |
Top
See Also

Reference

ComponentMetadataMessage Class
VisualComponents.UX.Shared Namespace


ComponentMetadataMessage.SelectedComponents Property

ComponentMetadataMessageSelectedComponents Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<ISimComponent> SelectedComponents { get; }
public:
property IEnumerable<ISimComponent^>^ SelectedComponents {
    IEnumerable<ISimComponent^>^ get ();
}

Property Value

Type: IEnumerableISimComponent
See Also

Reference

ComponentMetadataMessage Class
VisualComponents.UX.Shared Namespace


ComponentMetadataMessage Methods

The ComponentMetadataMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ComponentMetadataMessage Class
VisualComponents.UX.Shared Namespace


ComponentPdfInfo Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedComponentPdfInfo

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ComponentPdfInfo : IComponentPdfInfo
public ref class ComponentPdfInfo : IComponentPdfInfo

The ComponentPdfInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ComponentPdfInfo | Initializes a new instance of the ComponentPdfInfo class
Top
Properties
 | Name | Description
Public property | CameraDistance |
Public property | Description |
Public property | Id |
Public property | Name |
Public property | Origin |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ComponentPdfInfo Constructor

Initializes a new instance of the ComponentPdfInfo class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ComponentPdfInfo()
public:
ComponentPdfInfo()
See Also

Reference

ComponentPdfInfo Class
VisualComponents.UX.Shared Namespace


ComponentPdfInfo Properties

The ComponentPdfInfo type exposes the following members.

Properties
 | Name | Description
Public property | CameraDistance |
Public property | Description |
Public property | Id |
Public property | Name |
Public property | Origin |
Top
See Also

Reference

ComponentPdfInfo Class
VisualComponents.UX.Shared Namespace


ComponentPdfInfo.CameraDistance Property

ComponentPdfInfoCameraDistance Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double CameraDistance { get; set; }
public:
virtual property double CameraDistance {
    double get () sealed;
    void set (double value) sealed;
}

Property Value

Type: Double

Implements

IComponentPdfInfoCameraDistance
See Also

Reference

ComponentPdfInfo Class
VisualComponents.UX.Shared Namespace


ComponentPdfInfo.Description Property

ComponentPdfInfoDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; set; }
public:
virtual property String^ Description {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IComponentPdfInfoDescription
See Also

Reference

ComponentPdfInfo Class
VisualComponents.UX.Shared Namespace


ComponentPdfInfo.Id Property

ComponentPdfInfoId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Id { get; set; }
public:
virtual property String^ Id {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IComponentPdfInfoId
See Also

Reference

ComponentPdfInfo Class
VisualComponents.UX.Shared Namespace


ComponentPdfInfo.Name Property

ComponentPdfInfoName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; set; }
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IComponentPdfInfoName
See Also

Reference

ComponentPdfInfo Class
VisualComponents.UX.Shared Namespace


ComponentPdfInfo.Origin Property

ComponentPdfInfoOrigin Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Point3D Origin { get; set; }
public:
virtual property Point3D Origin {
    Point3D get () sealed;
    void set (Point3D value) sealed;
}

Property Value

Type: Point3D

Implements

IComponentPdfInfoOrigin
See Also

Reference

ComponentPdfInfo Class
VisualComponents.UX.Shared Namespace


ComponentPdfInfo Methods

The ComponentPdfInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ComponentPdfInfo Class
VisualComponents.UX.Shared Namespace


ComponentPicker Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
VisualComponents.UX.SharedComponentPicker

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ComponentPicker : Control
public ref class ComponentPicker : public Control

The ComponentPicker type exposes the following members.

Constructors
 | Name | Description
Public method | ComponentPicker | Initializes a new instance of the ComponentPicker class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Source |
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
SourceProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ComponentPicker Constructor

Initializes a new instance of the ComponentPicker class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ComponentPicker()
public:
ComponentPicker()
See Also

Reference

ComponentPicker Class
VisualComponents.UX.Shared Namespace


ComponentPicker Properties

The ComponentPicker type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Source |
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ComponentPicker Class
VisualComponents.UX.Shared Namespace


ComponentPicker.Source Property

ComponentPickerSource Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Source { get; set; }
public:
property String^ Source {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ComponentPicker Class
VisualComponents.UX.Shared Namespace


ComponentPicker Methods

The ComponentPicker type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ComponentPicker Class
VisualComponents.UX.Shared Namespace


ComponentPicker.OnApplyTemplate Method

ComponentPickerOnApplyTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

ComponentPicker Class
VisualComponents.UX.Shared Namespace


ComponentPicker Events

The ComponentPicker type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ComponentPicker Class
VisualComponents.UX.Shared Namespace


ComponentPicker Fields

The ComponentPicker type exposes the following members.

Fields
Name | Description
SourceProperty |
Top
See Also

Reference

ComponentPicker Class
VisualComponents.UX.Shared Namespace


ComponentPicker.SourceProperty Field

ComponentPickerSourceProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty SourceProperty
public:
static DependencyProperty^ SourceProperty

Field Value

Type: DependencyProperty
See Also

Reference

ComponentPicker Class
VisualComponents.UX.Shared Namespace


ComponentPropertyGridEx Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
VisualComponents.UX.SharedComponentPropertyGridEx

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ComponentPropertyGridEx : ContentControl
public ref class ComponentPropertyGridEx : public ContentControl

The ComponentPropertyGridEx type exposes the following members.

Constructors
 | Name | Description
Public method | ComponentPropertyGridEx | Initializes a new instance of the ComponentPropertyGridEx class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Headline | Gets or sets the Headline of the Propertygrid.
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedObject | Reference to the object which properties are being displayed.
Public property | SelectedProperty | Get or Sets the currently selected property of the propertygrid.
Public property | ShowDescription | Gets or sets ShowDecription dependency property
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
HeadlineProperty | DependenyProperty for the headline of the Propertygrid.
SelectedObjectProperty |
SelectedPropertyProperty |
ShowDescriptionProperty | Identifies the ShowDescription dependency property
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ComponentPropertyGridEx Constructor

Initializes a new instance of the ComponentPropertyGridEx class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ComponentPropertyGridEx()
public:
ComponentPropertyGridEx()
See Also

Reference

ComponentPropertyGridEx Class
VisualComponents.UX.Shared Namespace


ComponentPropertyGridEx Properties

The ComponentPropertyGridEx type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Headline | Gets or sets the Headline of the Propertygrid.
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedObject | Reference to the object which properties are being displayed.
Public property | SelectedProperty | Get or Sets the currently selected property of the propertygrid.
Public property | ShowDescription | Gets or sets ShowDecription dependency property
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ComponentPropertyGridEx Class
VisualComponents.UX.Shared Namespace


ComponentPropertyGridEx.Headline Property

ComponentPropertyGridExHeadline Property

Gets or sets the Headline of the Propertygrid.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Headline { get; set; }
public:
property String^ Headline {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ComponentPropertyGridEx Class
VisualComponents.UX.Shared Namespace


ComponentPropertyGridEx.SelectedObject Property

ComponentPropertyGridExSelectedObject Property

Reference to the object which properties are being displayed.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IPropertyContainer SelectedObject { get; set; }
public:
property IPropertyContainer^ SelectedObject {
    IPropertyContainer^ get ();
    void set (IPropertyContainer^ value);
}

Property Value

Type: IPropertyContainer
See Also

Reference

ComponentPropertyGridEx Class
VisualComponents.UX.Shared Namespace


ComponentPropertyGridEx.SelectedProperty Property

ComponentPropertyGridExSelectedProperty Property

Get or Sets the currently selected property of the propertygrid.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty SelectedProperty { get; set; }
public:
property IProperty^ SelectedProperty {
    IProperty^ get ();
    void set (IProperty^ value);
}

Property Value

Type: IProperty
See Also

Reference

ComponentPropertyGridEx Class
VisualComponents.UX.Shared Namespace


ComponentPropertyGridEx.ShowDescription Property

ComponentPropertyGridExShowDescription Property

Gets or sets ShowDecription dependency property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowDescription { get; set; }
public:
property bool ShowDescription {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ComponentPropertyGridEx Class
VisualComponents.UX.Shared Namespace


ComponentPropertyGridEx Methods

The ComponentPropertyGridEx type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ComponentPropertyGridEx Class
VisualComponents.UX.Shared Namespace


ComponentPropertyGridEx Events

The ComponentPropertyGridEx type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ComponentPropertyGridEx Class
VisualComponents.UX.Shared Namespace


ComponentPropertyGridEx Fields

The ComponentPropertyGridEx type exposes the following members.

Fields
Name | Description
HeadlineProperty | DependenyProperty for the headline of the Propertygrid.
SelectedObjectProperty |
SelectedPropertyProperty |
ShowDescriptionProperty | Identifies the ShowDescription dependency property
Top
See Also

Reference

ComponentPropertyGridEx Class
VisualComponents.UX.Shared Namespace


ComponentPropertyGridEx.HeadlineProperty Field

ComponentPropertyGridExHeadlineProperty Field

DependenyProperty for the headline of the Propertygrid.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty HeadlineProperty
public:
static initonly DependencyProperty^ HeadlineProperty

Field Value

Type: DependencyProperty
See Also

Reference

ComponentPropertyGridEx Class
VisualComponents.UX.Shared Namespace


ComponentPropertyGridEx.SelectedObjectProperty Field

ComponentPropertyGridExSelectedObjectProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty SelectedObjectProperty
public:
static initonly DependencyProperty^ SelectedObjectProperty

Field Value

Type: DependencyProperty
See Also

Reference

ComponentPropertyGridEx Class
VisualComponents.UX.Shared Namespace


ComponentPropertyGridEx.SelectedPropertyProperty Field

ComponentPropertyGridExSelectedPropertyProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty SelectedPropertyProperty
public:
static initonly DependencyProperty^ SelectedPropertyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ComponentPropertyGridEx Class
VisualComponents.UX.Shared Namespace


ComponentPropertyGridEx.ShowDescriptionProperty Field

ComponentPropertyGridExShowDescriptionProperty Field

Identifies the ShowDescription dependency property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty ShowDescriptionProperty
public:
static DependencyProperty^ ShowDescriptionProperty

Field Value

Type: DependencyProperty
See Also

Reference

ComponentPropertyGridEx Class
VisualComponents.UX.Shared Namespace


ComponentQuickMenu Class

Interaction logic for ComponentQuickMenu.xaml
ComponentQuickMenu
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedComponentQuickMenu

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ComponentQuickMenu : UserControl,
    INotifyPropertyChanged, IHandle<QuickMenuDisplayMessage>, IHandle, IHandle<ApplicationContextChangedMessage>,
    IHandle<ApplicationSubContextRequestMessage>, IHandle<ActionItemExecutedMessage>, IComponentConnector
public ref class ComponentQuickMenu : public UserControl,
    INotifyPropertyChanged, IHandle<QuickMenuDisplayMessage^>, IHandle, IHandle<ApplicationContextChangedMessage^>,
    IHandle<ApplicationSubContextRequestMessage^>, IHandle<ActionItemExecutedMessage^>, IComponentConnector

The ComponentQuickMenu type exposes the following members.

Constructors
 | Name | Description
Public method | ComponentQuickMenu | Initializes a new instance of the ComponentQuickMenu class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContainerHeight |
Public property | ContainerWidth |
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DistanceBasedOpacity |
Public property | EditMenuItems |
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | QuickMenuVisibility |
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | ReverseDpiScale |
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XPosition |
Public property | YPosition |
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Handle(ActionItemExecutedMessage) |
Public method | Handle(ApplicationContextChangedMessage) |
Public method | Handle(ApplicationSubContextRequestMessage) |
Public method | Handle(QuickMenuDisplayMessage) |
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | (Overrides FrameworkElementOnVisualParentChanged(DependencyObject).)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PropertyChanged |
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
ContainerHeightProperty |
ContainerWidthProperty |
EditMenuItemsProperty |
ReverseDpiScaleProperty |
XPositionProperty |
YPositionProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ComponentQuickMenu Constructor

Initializes a new instance of the ComponentQuickMenu class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ComponentQuickMenu()
public:
ComponentQuickMenu()
See Also

Reference

ComponentQuickMenu Class
VisualComponents.UX.Shared Namespace


ComponentQuickMenu Properties

The ComponentQuickMenu type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContainerHeight |
Public property | ContainerWidth |
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DistanceBasedOpacity |
Public property | EditMenuItems |
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | QuickMenuVisibility |
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | ReverseDpiScale |
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XPosition |
Public property | YPosition |
Top
See Also

Reference

ComponentQuickMenu Class
VisualComponents.UX.Shared Namespace


ComponentQuickMenu.ContainerHeight Property

ComponentQuickMenuContainerHeight Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double ContainerHeight { get; set; }
public:
property double ContainerHeight {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ComponentQuickMenu Class
VisualComponents.UX.Shared Namespace


ComponentQuickMenu.ContainerWidth Property

ComponentQuickMenuContainerWidth Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double ContainerWidth { get; set; }
public:
property double ContainerWidth {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ComponentQuickMenu Class
VisualComponents.UX.Shared Namespace


ComponentQuickMenu.DistanceBasedOpacity Property

ComponentQuickMenuDistanceBasedOpacity Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double DistanceBasedOpacity { get; set; }
public:
property double DistanceBasedOpacity {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ComponentQuickMenu Class
VisualComponents.UX.Shared Namespace


ComponentQuickMenu.EditMenuItems Property

ComponentQuickMenuEditMenuItems Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObservableCollectionEx<IActionItem> EditMenuItems { get; set; }
public:
property ObservableCollectionEx<IActionItem^>^ EditMenuItems {
    ObservableCollectionEx<IActionItem^>^ get ();
    void set (ObservableCollectionEx<IActionItem^>^ value);
}

Property Value

Type: ObservableCollectionEx IActionItem
See Also

Reference

ComponentQuickMenu Class
VisualComponents.UX.Shared Namespace


ComponentQuickMenu.QuickMenuVisibility Property

ComponentQuickMenuQuickMenuVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Visibility QuickMenuVisibility { get; set; }
public:
property Visibility QuickMenuVisibility {
    Visibility get ();
    void set (Visibility value);
}

Property Value

Type: Visibility
See Also

Reference

ComponentQuickMenu Class
VisualComponents.UX.Shared Namespace


ComponentQuickMenu.ReverseDpiScale Property

ComponentQuickMenuReverseDpiScale Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double ReverseDpiScale { get; set; }
public:
property double ReverseDpiScale {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ComponentQuickMenu Class
VisualComponents.UX.Shared Namespace


ComponentQuickMenu.XPosition Property

ComponentQuickMenuXPosition Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double XPosition { get; set; }
public:
property double XPosition {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ComponentQuickMenu Class
VisualComponents.UX.Shared Namespace


ComponentQuickMenu.YPosition Property

ComponentQuickMenuYPosition Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double YPosition { get; set; }
public:
property double YPosition {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ComponentQuickMenu Class
VisualComponents.UX.Shared Namespace


ComponentQuickMenu Methods

The ComponentQuickMenu type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Handle(ActionItemExecutedMessage) |
Public method | Handle(ApplicationContextChangedMessage) |
Public method | Handle(ApplicationSubContextRequestMessage) |
Public method | Handle(QuickMenuDisplayMessage) |
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | (Overrides FrameworkElementOnVisualParentChanged(DependencyObject).)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ComponentQuickMenu Class
VisualComponents.UX.Shared Namespace


ComponentQuickMenu.Handle Method

ComponentQuickMenuHandle Method

Overload List
 | Name | Description
Public method | Handle(ActionItemExecutedMessage) |
Public method | Handle(ApplicationContextChangedMessage) |
Public method | Handle(ApplicationSubContextRequestMessage) |
Public method | Handle(QuickMenuDisplayMessage) |
Top
See Also

Reference

ComponentQuickMenu Class
VisualComponents.UX.Shared Namespace


ComponentQuickMenu.Handle Method (ActionItemExecutedMessage)

ComponentQuickMenuHandle Method (ActionItemExecutedMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    ActionItemExecutedMessage message
)
public:
virtual void Handle(
    ActionItemExecutedMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedActionItemExecutedMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

ComponentQuickMenu Class
Handle Overload
VisualComponents.UX.Shared Namespace


ComponentQuickMenu.Handle Method (ApplicationContextChangedMessage)

ComponentQuickMenuHandle Method (ApplicationContextChangedMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    ApplicationContextChangedMessage message
)
public:
virtual void Handle(
    ApplicationContextChangedMessage^ message
) sealed

Parameters

message
Type: VisualComponents.Create3DApplicationContextChangedMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

ComponentQuickMenu Class
Handle Overload
VisualComponents.UX.Shared Namespace


ComponentQuickMenu.Handle Method (ApplicationSubContextRequestMessage)

ComponentQuickMenuHandle Method (ApplicationSubContextRequestMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    ApplicationSubContextRequestMessage message
)
public:
virtual void Handle(
    ApplicationSubContextRequestMessage^ message
) sealed

Parameters

message
Type: VisualComponents.Create3DApplicationSubContextRequestMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

ComponentQuickMenu Class
Handle Overload
VisualComponents.UX.Shared Namespace


ComponentQuickMenu.Handle Method (QuickMenuDisplayMessage)

ComponentQuickMenuHandle Method (QuickMenuDisplayMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    QuickMenuDisplayMessage message
)
public:
virtual void Handle(
    QuickMenuDisplayMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedQuickMenuDisplayMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

ComponentQuickMenu Class
Handle Overload
VisualComponents.UX.Shared Namespace


ComponentQuickMenu.InitializeComponent Method

ComponentQuickMenuInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

ComponentQuickMenu Class
VisualComponents.UX.Shared Namespace


ComponentQuickMenu.OnVisualParentChanged Method

ComponentQuickMenuOnVisualParentChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnVisualParentChanged(
    DependencyObject oldParent
)
protected:
virtual void OnVisualParentChanged(
    DependencyObject^ oldParent
) override

Parameters

oldParent
Type: System.WindowsDependencyObject
See Also

Reference

ComponentQuickMenu Class
VisualComponents.UX.Shared Namespace


ComponentQuickMenu Events

The ComponentQuickMenu type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PropertyChanged |
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ComponentQuickMenu Class
VisualComponents.UX.Shared Namespace


ComponentQuickMenu.PropertyChanged Event

ComponentQuickMenuPropertyChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event PropertyChangedEventHandler PropertyChanged
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

ComponentQuickMenu Class
VisualComponents.UX.Shared Namespace


ComponentQuickMenu Fields

The ComponentQuickMenu type exposes the following members.

Fields
Name | Description
ContainerHeightProperty |
ContainerWidthProperty |
EditMenuItemsProperty |
ReverseDpiScaleProperty |
XPositionProperty |
YPositionProperty |
Top
See Also

Reference

ComponentQuickMenu Class
VisualComponents.UX.Shared Namespace


ComponentQuickMenu.ContainerHeightProperty Field

ComponentQuickMenuContainerHeightProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ContainerHeightProperty
public:
static initonly DependencyProperty^ ContainerHeightProperty

Field Value

Type: DependencyProperty
See Also

Reference

ComponentQuickMenu Class
VisualComponents.UX.Shared Namespace


ComponentQuickMenu.ContainerWidthProperty Field

ComponentQuickMenuContainerWidthProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ContainerWidthProperty
public:
static initonly DependencyProperty^ ContainerWidthProperty

Field Value

Type: DependencyProperty
See Also

Reference

ComponentQuickMenu Class
VisualComponents.UX.Shared Namespace


ComponentQuickMenu.EditMenuItemsProperty Field

ComponentQuickMenuEditMenuItemsProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty EditMenuItemsProperty
public:
static initonly DependencyProperty^ EditMenuItemsProperty

Field Value

Type: DependencyProperty
See Also

Reference

ComponentQuickMenu Class
VisualComponents.UX.Shared Namespace


ComponentQuickMenu.ReverseDpiScaleProperty Field

ComponentQuickMenuReverseDpiScaleProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ReverseDpiScaleProperty
public:
static initonly DependencyProperty^ ReverseDpiScaleProperty

Field Value

Type: DependencyProperty
See Also

Reference

ComponentQuickMenu Class
VisualComponents.UX.Shared Namespace


ComponentQuickMenu.XPositionProperty Field

ComponentQuickMenuXPositionProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty XPositionProperty
public:
static initonly DependencyProperty^ XPositionProperty

Field Value

Type: DependencyProperty
See Also

Reference

ComponentQuickMenu Class
VisualComponents.UX.Shared Namespace


ComponentQuickMenu.YPositionProperty Field

ComponentQuickMenuYPositionProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty YPositionProperty
public:
static initonly DependencyProperty^ YPositionProperty

Field Value

Type: DependencyProperty
See Also

Reference

ComponentQuickMenu Class
VisualComponents.UX.Shared Namespace


ComponentStructureMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedComponentStructureMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ComponentStructureMessage
public ref class ComponentStructureMessage

The ComponentStructureMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ComponentStructureMessage | Initializes a new instance of the ComponentStructureMessage class
Top
Properties
 | Name | Description
Public property | Show |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ComponentStructureMessage Constructor

Initializes a new instance of the ComponentStructureMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ComponentStructureMessage()
public:
ComponentStructureMessage()
See Also

Reference

ComponentStructureMessage Class
VisualComponents.UX.Shared Namespace


ComponentStructureMessage Properties

The ComponentStructureMessage type exposes the following members.

Properties
 | Name | Description
Public property | Show |
Top
See Also

Reference

ComponentStructureMessage Class
VisualComponents.UX.Shared Namespace


ComponentStructureMessage.Show Property

ComponentStructureMessageShow Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Show { get; set; }
public:
property bool Show {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ComponentStructureMessage Class
VisualComponents.UX.Shared Namespace


ComponentStructureMessage Methods

The ComponentStructureMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ComponentStructureMessage Class
VisualComponents.UX.Shared Namespace


ConnectionBadIndicator Class

This class is just a place holder for showing a 'bad connection' indicator in the graph. It is used when a connection is dragged out to a connector, to which a valid connection can't be made.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedConnectionBadIndicator

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ConnectionBadIndicator
public ref class ConnectionBadIndicator

The ConnectionBadIndicator type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionBadIndicator | Initializes a new instance of the ConnectionBadIndicator class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ConnectionBadIndicator Constructor

Initializes a new instance of the ConnectionBadIndicator class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectionBadIndicator()
public:
ConnectionBadIndicator()
See Also

Reference

ConnectionBadIndicator Class
VisualComponents.UX.Shared Namespace


ConnectionBadIndicator Methods

The ConnectionBadIndicator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ConnectionBadIndicator Class
VisualComponents.UX.Shared Namespace


ConnectionOkIndicator Class

This class is just a place holder for showing a 'connection ok' indicator in the graph. It is used when a connection is dragged out to a connector, to which a valid connection can be made.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedConnectionOkIndicator

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ConnectionOkIndicator
public ref class ConnectionOkIndicator

The ConnectionOkIndicator type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionOkIndicator | Initializes a new instance of the ConnectionOkIndicator class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ConnectionOkIndicator Constructor

Initializes a new instance of the ConnectionOkIndicator class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectionOkIndicator()
public:
ConnectionOkIndicator()
See Also

Reference

ConnectionOkIndicator Class
VisualComponents.UX.Shared Namespace


ConnectionOkIndicator Methods

The ConnectionOkIndicator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ConnectionOkIndicator Class
VisualComponents.UX.Shared Namespace


ConnectionStatusEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.UX.SharedConnectionStatusEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ConnectionStatusEventArgs : EventArgs
public ref class ConnectionStatusEventArgs : public EventArgs

The ConnectionStatusEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionStatusEventArgs | Initializes a new instance of the ConnectionStatusEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | IsConnected |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ConnectionStatusEventArgs Constructor

Initializes a new instance of the ConnectionStatusEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectionStatusEventArgs(
    bool isConnected
)
public:
ConnectionStatusEventArgs(
    bool isConnected
)

Parameters

isConnected
Type: SystemBoolean
See Also

Reference

ConnectionStatusEventArgs Class
VisualComponents.UX.Shared Namespace


ConnectionStatusEventArgs Methods

The ConnectionStatusEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ConnectionStatusEventArgs Class
VisualComponents.UX.Shared Namespace


ConnectionStatusEventArgs Fields

The ConnectionStatusEventArgs type exposes the following members.

Fields
 | Name | Description
Public field | IsConnected |
Top
See Also

Reference

ConnectionStatusEventArgs Class
VisualComponents.UX.Shared Namespace


ConnectionStatusEventArgs.IsConnected Field

ConnectionStatusEventArgsIsConnected Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public readonly bool IsConnected
public:
initonly bool IsConnected

Field Value

Type: Boolean
See Also

Reference

ConnectionStatusEventArgs Class
VisualComponents.UX.Shared Namespace


ConstantMultiplyConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedConstantMultiplyConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ConstantMultiplyConverter : IValueConverter
public ref class ConstantMultiplyConverter : IValueConverter

The ConstantMultiplyConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ConstantMultiplyConverter | Initializes a new instance of the ConstantMultiplyConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ConstantMultiplyConverter Constructor

Initializes a new instance of the ConstantMultiplyConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConstantMultiplyConverter()
public:
ConstantMultiplyConverter()
See Also

Reference

ConstantMultiplyConverter Class
VisualComponents.UX.Shared Namespace


ConstantMultiplyConverter Methods

The ConstantMultiplyConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ConstantMultiplyConverter Class
VisualComponents.UX.Shared Namespace


ConstantMultiplyConverter.Convert Method

ConstantMultiplyConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ConstantMultiplyConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

ConstantMultiplyConverter Class
VisualComponents.UX.Shared Namespace


ConstantMultiplyConverter.ConvertBack Method

ConstantMultiplyConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ConstantMultiplyConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

ConstantMultiplyConverter Class
VisualComponents.UX.Shared Namespace


ConstantMultiplyPointConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedConstantMultiplyPointConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ConstantMultiplyPointConverter : IValueConverter
public ref class ConstantMultiplyPointConverter : IValueConverter

The ConstantMultiplyPointConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ConstantMultiplyPointConverter | Initializes a new instance of the ConstantMultiplyPointConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ConstantMultiplyPointConverter Constructor

Initializes a new instance of the ConstantMultiplyPointConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConstantMultiplyPointConverter()
public:
ConstantMultiplyPointConverter()
See Also

Reference

ConstantMultiplyPointConverter Class
VisualComponents.UX.Shared Namespace


ConstantMultiplyPointConverter Methods

The ConstantMultiplyPointConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ConstantMultiplyPointConverter Class
VisualComponents.UX.Shared Namespace


ConstantMultiplyPointConverter.Convert Method

ConstantMultiplyPointConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ConstantMultiplyPointConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

ConstantMultiplyPointConverter Class
VisualComponents.UX.Shared Namespace


ConstantMultiplyPointConverter.ConvertBack Method

ConstantMultiplyPointConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ConstantMultiplyPointConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

ConstantMultiplyPointConverter Class
VisualComponents.UX.Shared Namespace


ConstantSumConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedConstantSumConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ConstantSumConverter : IValueConverter
public ref class ConstantSumConverter : IValueConverter

The ConstantSumConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ConstantSumConverter | Initializes a new instance of the ConstantSumConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ConstantSumConverter Constructor

Initializes a new instance of the ConstantSumConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConstantSumConverter()
public:
ConstantSumConverter()
See Also

Reference

ConstantSumConverter Class
VisualComponents.UX.Shared Namespace


ConstantSumConverter Methods

The ConstantSumConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ConstantSumConverter Class
VisualComponents.UX.Shared Namespace


ConstantSumConverter.Convert Method

ConstantSumConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ConstantSumConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

ConstantSumConverter Class
VisualComponents.UX.Shared Namespace


ConstantSumConverter.ConvertBack Method

ConstantSumConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ConstantSumConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

ConstantSumConverter Class
VisualComponents.UX.Shared Namespace


ConstraintToBooleanConverter Class

Returns true if the value (first) is less than or equals to constraint (parameter/second).
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedConstraintToBooleanConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ConstraintToBooleanConverter : IMultiValueConverter
public ref class ConstraintToBooleanConverter : IMultiValueConverter

The ConstraintToBooleanConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ConstraintToBooleanConverter | Initializes a new instance of the ConstraintToBooleanConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ConstraintToBooleanConverter Constructor

Initializes a new instance of the ConstraintToBooleanConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConstraintToBooleanConverter()
public:
ConstraintToBooleanConverter()
See Also

Reference

ConstraintToBooleanConverter Class
VisualComponents.UX.Shared Namespace


ConstraintToBooleanConverter Methods

The ConstraintToBooleanConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ConstraintToBooleanConverter Class
VisualComponents.UX.Shared Namespace


ConstraintToBooleanConverter.Convert Method

ConstraintToBooleanConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    array<Object^>^ values,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

values
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ConstraintToBooleanConverter.Convert(System.Object[],System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

ConstraintToBooleanConverter Class
VisualComponents.UX.Shared Namespace


ConstraintToBooleanConverter.ConvertBack Method

ConstraintToBooleanConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
public:
virtual array<Object^>^ ConvertBack(
    Object^ value,
    array<Type^>^ targetTypes,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetTypes
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ConstraintToBooleanConverter.ConvertBack(System.Object,System.Type[],System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

ConstraintToBooleanConverter Class
VisualComponents.UX.Shared Namespace


ContentTextChangedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.UX.SharedContentTextChangedEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ContentTextChangedEventArgs : EventArgs
public ref class ContentTextChangedEventArgs : public EventArgs

The ContentTextChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ContentTextChangedEventArgs | Initializes a new instance of the ContentTextChangedEventArgs class
Top
Properties
 | Name | Description
Public property | NewValue | Gets the new value.
Public property | OldValue | Gets the old value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ContentTextChangedEventArgs Constructor

Initializes a new instance of the ContentTextChangedEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ContentTextChangedEventArgs(
    string oldValue,
    string newValue
)
public:
ContentTextChangedEventArgs(
    String^ oldValue,
    String^ newValue
)

Parameters

oldValue
Type: SystemString
newValue
Type: SystemString
See Also

Reference

ContentTextChangedEventArgs Class
VisualComponents.UX.Shared Namespace


ContentTextChangedEventArgs Properties

The ContentTextChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewValue | Gets the new value.
Public property | OldValue | Gets the old value.
Top
See Also

Reference

ContentTextChangedEventArgs Class
VisualComponents.UX.Shared Namespace


ContentTextChangedEventArgs.NewValue Property

ContentTextChangedEventArgsNewValue Property

Gets the new value.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string NewValue { get; }
public:
property String^ NewValue {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ContentTextChangedEventArgs Class
VisualComponents.UX.Shared Namespace


ContentTextChangedEventArgs.OldValue Property

ContentTextChangedEventArgsOldValue Property

Gets the old value.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string OldValue { get; }
public:
property String^ OldValue {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ContentTextChangedEventArgs Class
VisualComponents.UX.Shared Namespace


ContentTextChangedEventArgs Methods

The ContentTextChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ContentTextChangedEventArgs Class
VisualComponents.UX.Shared Namespace


ContinueActionMessageFromHandle Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedContinueActionMessageFromHandle

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ContinueActionMessageFromHandle
public ref class ContinueActionMessageFromHandle

The ContinueActionMessageFromHandle type exposes the following members.

Constructors
 | Name | Description
Public method | ContinueActionMessageFromHandle(Vector3D) | Initializes a new instance of the ContinueActionMessageFromHandle class
Public method | ContinueActionMessageFromHandle(Double, Vector3D) | Initializes a new instance of the ContinueActionMessageFromHandle class
Public method | ContinueActionMessageFromHandle(Vector3D, Vector3D, Boolean) | Initializes a new instance of the ContinueActionMessageFromHandle class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | action |
Public field | angle |
Public field | delta |
Public field | planeDirection |
Public field | rememberDeltaWhenGridEnabled |
Public field | rotationEulerAngles |
Public field | useScreenSpaceForPnP |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ContinueActionMessageFromHandle Constructor

Overload List
 | Name | Description
Public method | ContinueActionMessageFromHandle(Vector3D) | Initializes a new instance of the ContinueActionMessageFromHandle class
Public method | ContinueActionMessageFromHandle(Double, Vector3D) | Initializes a new instance of the ContinueActionMessageFromHandle class
Public method | ContinueActionMessageFromHandle(Vector3D, Vector3D, Boolean) | Initializes a new instance of the ContinueActionMessageFromHandle class
Top
See Also

Reference

ContinueActionMessageFromHandle Class
VisualComponents.UX.Shared Namespace


ContinueActionMessageFromHandle Constructor (Vector3D)

Initializes a new instance of the ContinueActionMessageFromHandle class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ContinueActionMessageFromHandle(
    Vector3D rotationEulerAngles
)
public:
ContinueActionMessageFromHandle(
    Vector3D rotationEulerAngles
)

Parameters

rotationEulerAngles
Type: System.Windows.Media.Media3DVector3D
See Also

Reference

ContinueActionMessageFromHandle Class
ContinueActionMessageFromHandle Overload
VisualComponents.UX.Shared Namespace


ContinueActionMessageFromHandle Constructor (Double, Vector3D)

Initializes a new instance of the ContinueActionMessageFromHandle class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ContinueActionMessageFromHandle(
    double angle,
    Vector3D planeDirection
)
public:
ContinueActionMessageFromHandle(
    double angle,
    Vector3D planeDirection
)

Parameters

angle
Type: SystemDouble
planeDirection
Type: System.Windows.Media.Media3DVector3D
See Also

Reference

ContinueActionMessageFromHandle Class
ContinueActionMessageFromHandle Overload
VisualComponents.UX.Shared Namespace


ContinueActionMessageFromHandle Constructor (Vector3D, Vector3D, Boolean)

Initializes a new instance of the ContinueActionMessageFromHandle class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ContinueActionMessageFromHandle(
    Vector3D delta,
    Vector3D planeDirection,
    bool rememberDeltaWhenGridEnabled = true
)
public:
ContinueActionMessageFromHandle(
    Vector3D delta,
    Vector3D planeDirection,
    bool rememberDeltaWhenGridEnabled = true
)

Parameters

delta
Type: System.Windows.Media.Media3DVector3D
planeDirection
Type: System.Windows.Media.Media3DVector3D
rememberDeltaWhenGridEnabled (Optional)
Type: SystemBoolean
See Also

Reference

ContinueActionMessageFromHandle Class
ContinueActionMessageFromHandle Overload
VisualComponents.UX.Shared Namespace


ContinueActionMessageFromHandle Methods

The ContinueActionMessageFromHandle type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ContinueActionMessageFromHandle Class
VisualComponents.UX.Shared Namespace


ContinueActionMessageFromHandle Fields

The ContinueActionMessageFromHandle type exposes the following members.

Fields
 | Name | Description
Public field | action |
Public field | angle |
Public field | delta |
Public field | planeDirection |
Public field | rememberDeltaWhenGridEnabled |
Public field | rotationEulerAngles |
Public field | useScreenSpaceForPnP |
Top
See Also

Reference

ContinueActionMessageFromHandle Class
VisualComponents.UX.Shared Namespace


ContinueActionMessageFromHandle.action Field

ContinueActionMessageFromHandleaction Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Action action
public:
Action action

Field Value

Type: Action
See Also

Reference

ContinueActionMessageFromHandle Class
VisualComponents.UX.Shared Namespace


ContinueActionMessageFromHandle.angle Field

ContinueActionMessageFromHandleangle Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double angle
public:
double angle

Field Value

Type: Double
See Also

Reference

ContinueActionMessageFromHandle Class
VisualComponents.UX.Shared Namespace


ContinueActionMessageFromHandle.delta Field

ContinueActionMessageFromHandledelta Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3D delta
public:
Vector3D delta

Field Value

Type: Vector3D
See Also

Reference

ContinueActionMessageFromHandle Class
VisualComponents.UX.Shared Namespace


ContinueActionMessageFromHandle.planeDirection Field

ContinueActionMessageFromHandleplaneDirection Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3D planeDirection
public:
Vector3D planeDirection

Field Value

Type: Vector3D
See Also

Reference

ContinueActionMessageFromHandle Class
VisualComponents.UX.Shared Namespace


ContinueActionMessageFromHandle.rememberDeltaWhenGridEnabled Field

ContinueActionMessageFromHandlerememberDeltaWhenGridEnabled Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool rememberDeltaWhenGridEnabled
public:
bool rememberDeltaWhenGridEnabled

Field Value

Type: Boolean
See Also

Reference

ContinueActionMessageFromHandle Class
VisualComponents.UX.Shared Namespace


ContinueActionMessageFromHandle.rotationEulerAngles Field

ContinueActionMessageFromHandlerotationEulerAngles Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<Vector3D> rotationEulerAngles
public:
Nullable<Vector3D> rotationEulerAngles

Field Value

Type: NullableVector3D
See Also

Reference

ContinueActionMessageFromHandle Class
VisualComponents.UX.Shared Namespace


ContinueActionMessageFromHandle.useScreenSpaceForPnP Field

ContinueActionMessageFromHandleuseScreenSpaceForPnP Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool useScreenSpaceForPnP
public:
bool useScreenSpaceForPnP

Field Value

Type: Boolean
See Also

Reference

ContinueActionMessageFromHandle Class
VisualComponents.UX.Shared Namespace


ContinueInteractionMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedContinueInteractionMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ContinueInteractionMessage
public ref class ContinueInteractionMessage sealed

The ContinueInteractionMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ContinueInteractionMessage | Initializes a new instance of the ContinueInteractionMessage class
Top
Properties
 | Name | Description
Public property | Action |
Public property | Args |
Public property | LastPosition |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ContinueInteractionMessage Constructor

Initializes a new instance of the ContinueInteractionMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ContinueInteractionMessage()
public:
ContinueInteractionMessage()
See Also

Reference

ContinueInteractionMessage Class
VisualComponents.UX.Shared Namespace


ContinueInteractionMessage Properties

The ContinueInteractionMessage type exposes the following members.

Properties
 | Name | Description
Public property | Action |
Public property | Args |
Public property | LastPosition |
Top
See Also

Reference

ContinueInteractionMessage Class
VisualComponents.UX.Shared Namespace


ContinueInteractionMessage.Action Property

ContinueInteractionMessageAction Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Action Action { get; set; }
public:
property Action^ Action {
    Action^ get ();
    void set (Action^ value);
}

Property Value

Type: Action
See Also

Reference

ContinueInteractionMessage Class
VisualComponents.UX.Shared Namespace


ContinueInteractionMessage.Args Property

ContinueInteractionMessageArgs Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ManipulationEventArgs Args { get; set; }
public:
property ManipulationEventArgs^ Args {
    ManipulationEventArgs^ get ();
    void set (ManipulationEventArgs^ value);
}

Property Value

Type: ManipulationEventArgs
See Also

Reference

ContinueInteractionMessage Class
VisualComponents.UX.Shared Namespace


ContinueInteractionMessage.LastPosition Property

ContinueInteractionMessageLastPosition Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Point LastPosition { get; set; }
public:
property Point LastPosition {
    Point get ();
    void set (Point value);
}

Property Value

Type: Point
See Also

Reference

ContinueInteractionMessage Class
VisualComponents.UX.Shared Namespace


ContinueInteractionMessage Methods

The ContinueInteractionMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ContinueInteractionMessage Class
VisualComponents.UX.Shared Namespace


ControlDescription Class

Connects the property to a gui element, for example a textbox.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedLayoutElement
VisualComponents.UX.SharedControlDescription

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ControlDescription : LayoutElement,
    INotifyPropertyChanged
public ref class ControlDescription sealed : public LayoutElement,
    INotifyPropertyChanged

The ControlDescription type exposes the following members.

Constructors
 | Name | Description
Public method | ControlDescription | Initializes a new instance of the ControlDescription class
Top
Properties
 | Name | Description
Public property | Children | Provides capability to add child elements to any layout element. (Inherited from LayoutElement.)
Public property | Content |
Public property | ControlType |
Public property | ControlViewModel | Reference View Model and the view that is going to be shown in gui.
Public property | DisplayUnitFormat |
Public property | ElementType | (Inherited from LayoutElement.)
Public property | PropertyDescription |
Public property | PropertyDescriptionId |
Public property | PropertyName |
Public property | TabHeaderName |
Public property | TargetProperty | Helper property to enable direct binding to target property.
Public property | TypeString |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
Fields
 | Name | Description
Public field | _propertyDescription |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ControlDescription Constructor

Initializes a new instance of the ControlDescription class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ControlDescription()
public:
ControlDescription()
See Also

Reference

ControlDescription Class
VisualComponents.UX.Shared Namespace


ControlDescription Properties

The ControlDescription type exposes the following members.

Properties
 | Name | Description
Public property | Children | Provides capability to add child elements to any layout element. (Inherited from LayoutElement.)
Public property | Content |
Public property | ControlType |
Public property | ControlViewModel | Reference View Model and the view that is going to be shown in gui.
Public property | DisplayUnitFormat |
Public property | ElementType | (Inherited from LayoutElement.)
Public property | PropertyDescription |
Public property | PropertyDescriptionId |
Public property | PropertyName |
Public property | TabHeaderName |
Public property | TargetProperty | Helper property to enable direct binding to target property.
Public property | TypeString |
Top
See Also

Reference

ControlDescription Class
VisualComponents.UX.Shared Namespace


ControlDescription.Content Property

ControlDescriptionContent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Content { get; set; }
public:
property String^ Content {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ControlDescription Class
VisualComponents.UX.Shared Namespace


ControlDescription.ControlType Property

ControlDescriptionControlType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type ControlType { get; set; }
public:
property Type^ ControlType {
    Type^ get ();
    void set (Type^ value);
}

Property Value

Type: Type
See Also

Reference

ControlDescription Class
VisualComponents.UX.Shared Namespace


ControlDescription.ControlViewModel Property

ControlDescriptionControlViewModel Property

Reference View Model and the view that is going to be shown in gui.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ControlViewModel { get; set; }
public:
property Object^ ControlViewModel {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

ControlDescription Class
VisualComponents.UX.Shared Namespace


ControlDescription.DisplayUnitFormat Property

ControlDescriptionDisplayUnitFormat Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UnitFormat DisplayUnitFormat { get; set; }
public:
property UnitFormat DisplayUnitFormat {
    UnitFormat get ();
    void set (UnitFormat value);
}

Property Value

Type: UnitFormat
See Also

Reference

ControlDescription Class
VisualComponents.UX.Shared Namespace


ControlDescription.PropertyDescription Property

ControlDescriptionPropertyDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyDescription PropertyDescription { get; set; }
public:
property PropertyDescription^ PropertyDescription {
    PropertyDescription^ get ();
    void set (PropertyDescription^ value);
}

Property Value

Type: PropertyDescription
See Also

Reference

ControlDescription Class
VisualComponents.UX.Shared Namespace


ControlDescription.PropertyDescriptionId Property

ControlDescriptionPropertyDescriptionId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int PropertyDescriptionId { get; set; }
public:
property int PropertyDescriptionId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ControlDescription Class
VisualComponents.UX.Shared Namespace


ControlDescription.PropertyName Property

ControlDescriptionPropertyName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string PropertyName { get; set; }
public:
property String^ PropertyName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ControlDescription Class
VisualComponents.UX.Shared Namespace


ControlDescription.TabHeaderName Property

ControlDescriptionTabHeaderName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string TabHeaderName { get; set; }
public:
property String^ TabHeaderName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ControlDescription Class
VisualComponents.UX.Shared Namespace


ControlDescription.TargetProperty Property

ControlDescriptionTargetProperty Property

Helper property to enable direct binding to target property.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EditorProperty TargetProperty { get; }
public:
property EditorProperty^ TargetProperty {
    EditorProperty^ get ();
}

Property Value

Type: EditorProperty
See Also

Reference

ControlDescription Class
VisualComponents.UX.Shared Namespace


ControlDescription.TypeString Property

ControlDescriptionTypeString Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string TypeString { get; set; }
public:
property String^ TypeString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ControlDescription Class
VisualComponents.UX.Shared Namespace


ControlDescription Methods

The ControlDescription type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ControlDescription Class
VisualComponents.UX.Shared Namespace


ControlDescription Events

The ControlDescription type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

ControlDescription Class
VisualComponents.UX.Shared Namespace


ControlDescription.PropertyChanged Event

ControlDescriptionPropertyChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event PropertyChangedEventHandler PropertyChanged
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

ControlDescription Class
VisualComponents.UX.Shared Namespace


ControlDescription Fields

The ControlDescription type exposes the following members.

Fields
 | Name | Description
Public field | _propertyDescription |
Top
See Also

Reference

ControlDescription Class
VisualComponents.UX.Shared Namespace


ControlDescription._propertyDescription Field

ControlDescription_propertyDescription Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyDescription _propertyDescription
public:
PropertyDescription^ _propertyDescription

Field Value

Type: PropertyDescription
See Also

Reference

ControlDescription Class
VisualComponents.UX.Shared Namespace


ControlDescriptionNameComparer Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedControlDescriptionNameComparer

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ControlDescriptionNameComparer : IComparer<LayoutElement>
public ref class ControlDescriptionNameComparer : IComparer<LayoutElement^>

The ControlDescriptionNameComparer type exposes the following members.

Constructors
 | Name | Description
Public method | ControlDescriptionNameComparer | Initializes a new instance of the ControlDescriptionNameComparer class
Top
Properties
 | Name | Description
Public property | SortingOrder |
Top
Methods
 | Name | Description
Public method | Compare |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ControlDescriptionNameComparer Constructor

Initializes a new instance of the ControlDescriptionNameComparer class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ControlDescriptionNameComparer()
public:
ControlDescriptionNameComparer()
See Also

Reference

ControlDescriptionNameComparer Class
VisualComponents.UX.Shared Namespace


ControlDescriptionNameComparer Properties

The ControlDescriptionNameComparer type exposes the following members.

Properties
 | Name | Description
Public property | SortingOrder |
Top
See Also

Reference

ControlDescriptionNameComparer Class
VisualComponents.UX.Shared Namespace


ControlDescriptionNameComparer.SortingOrder Property

ControlDescriptionNameComparerSortingOrder Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SortOrder SortingOrder { get; set; }
public:
property SortOrder SortingOrder {
    SortOrder get ();
    void set (SortOrder value);
}

Property Value

Type: SortOrder
See Also

Reference

ControlDescriptionNameComparer Class
VisualComponents.UX.Shared Namespace


ControlDescriptionNameComparer Methods

The ControlDescriptionNameComparer type exposes the following members.

Methods
 | Name | Description
Public method | Compare |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ControlDescriptionNameComparer Class
VisualComponents.UX.Shared Namespace


ControlDescriptionNameComparer.Compare Method

ControlDescriptionNameComparerCompare Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Compare(
    LayoutElement xx,
    LayoutElement yy
)
public:
virtual int Compare(
    LayoutElement^ xx,
    LayoutElement^ yy
) sealed

Parameters

xx
Type: VisualComponents.UX.SharedLayoutElement
yy
Type: VisualComponents.UX.SharedLayoutElement

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ControlDescriptionNameComparer.Compare(VisualComponents.UX.Shared.LayoutElement,VisualComponents.UX.Shared.LayoutElement)"]

Implements

IComparerTCompare(T, T)
See Also

Reference

ControlDescriptionNameComparer Class
VisualComponents.UX.Shared Namespace


ControlVisibilityBehavior Class

Attached Behavior to control Non-Ribbon UI element visibility based on configuration setting.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.WindowsFreezable
System.Windows.Media.AnimationAnimatable
Behavior
BehaviorFrameworkElement
VisualComponents.UX.SharedControlVisibilityBehavior

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ControlVisibilityBehavior : Behavior<FrameworkElement>
public ref class ControlVisibilityBehavior : public Behavior<FrameworkElement^>

The ControlVisibilityBehavior type exposes the following members.

Constructors
 | Name | Description
Public method | ControlVisibilityBehavior | Initializes a new instance of the ControlVisibilityBehavior class
Top
Properties
 | Name | Description
Protected property | AssociatedObject | (Inherited from BehaviorFrameworkElement.)
Protected property | AssociatedType | (Inherited from Behavior.)
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Inherited from Animatable.)
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | VisibilityId | Item id that is going to be used to determine control visibility.
Top
Methods
 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | Attach | (Inherited from Behavior.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of this Animatable, making deep copies of this object's values. When copying this object's dependency properties, this method copies resource references and data bindings (but they might no longer resolve) but not animations or their current values. (Inherited from Animatable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | (Inherited from Behavior.)
Public method | Detach | (Inherited from Behavior.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to . (Inherited from Freezable.)
Protected method | FreezeCore | Makes this Animatable object unmodifiable or determines whether it can be made unmodifiable. (Inherited from Animatable.)
Public method | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Inherited from Animatable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttached | (Overrides Behavior.OnAttached.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnDetaching | (Overrides Behavior.OnDetaching.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
Events
 | Name | Description
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Top
Fields
Name | Description
VisibilityIdProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ControlVisibilityBehavior Constructor

Initializes a new instance of the ControlVisibilityBehavior class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ControlVisibilityBehavior()
public:
ControlVisibilityBehavior()
See Also

Reference

ControlVisibilityBehavior Class
VisualComponents.UX.Shared Namespace


ControlVisibilityBehavior Properties

The ControlVisibilityBehavior type exposes the following members.

Properties
 | Name | Description
Protected property | AssociatedObject | (Inherited from BehaviorFrameworkElement.)
Protected property | AssociatedType | (Inherited from Behavior.)
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Inherited from Animatable.)
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | VisibilityId | Item id that is going to be used to determine control visibility.
Top
See Also

Reference

ControlVisibilityBehavior Class
VisualComponents.UX.Shared Namespace


ControlVisibilityBehavior.VisibilityId Property

ControlVisibilityBehaviorVisibilityId Property

Item id that is going to be used to determine control visibility.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string VisibilityId { get; set; }
public:
property String^ VisibilityId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ControlVisibilityBehavior Class
VisualComponents.UX.Shared Namespace


ControlVisibilityBehavior Methods

The ControlVisibilityBehavior type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | Attach | (Inherited from Behavior.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of this Animatable, making deep copies of this object's values. When copying this object's dependency properties, this method copies resource references and data bindings (but they might no longer resolve) but not animations or their current values. (Inherited from Animatable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | (Inherited from Behavior.)
Public method | Detach | (Inherited from Behavior.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to . (Inherited from Freezable.)
Protected method | FreezeCore | Makes this Animatable object unmodifiable or determines whether it can be made unmodifiable. (Inherited from Animatable.)
Public method | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Inherited from Animatable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttached | (Overrides Behavior.OnAttached.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnDetaching | (Overrides Behavior.OnDetaching.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ControlVisibilityBehavior Class
VisualComponents.UX.Shared Namespace


ControlVisibilityBehavior.OnAttached Method

ControlVisibilityBehaviorOnAttached Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnAttached()
protected:
virtual void OnAttached() override
See Also

Reference

ControlVisibilityBehavior Class
VisualComponents.UX.Shared Namespace


ControlVisibilityBehavior.OnDetaching Method

ControlVisibilityBehaviorOnDetaching Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnDetaching()
protected:
virtual void OnDetaching() override
See Also

Reference

ControlVisibilityBehavior Class
VisualComponents.UX.Shared Namespace


ControlVisibilityBehavior Events

The ControlVisibilityBehavior type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Top
See Also

Reference

ControlVisibilityBehavior Class
VisualComponents.UX.Shared Namespace


ControlVisibilityBehavior Fields

The ControlVisibilityBehavior type exposes the following members.

Fields
Name | Description
VisibilityIdProperty |
Top
See Also

Reference

ControlVisibilityBehavior Class
VisualComponents.UX.Shared Namespace


ControlVisibilityBehavior.VisibilityIdProperty Field

ControlVisibilityBehaviorVisibilityIdProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty VisibilityIdProperty
public:
static initonly DependencyProperty^ VisibilityIdProperty

Field Value

Type: DependencyProperty
See Also

Reference

ControlVisibilityBehavior Class
VisualComponents.UX.Shared Namespace


ConverterFactory Class

Exposes singleton instances of all Converters to be used with {x:Static}.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedConverterFactory

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class ConverterFactory
public ref class ConverterFactory abstract sealed

The ConverterFactory type exposes the following members.

Properties
Name | Description
ApplicationMenuButton |
ApplicationMenuTabFont |
BoolToCapabilityIcon |
BoolToColor |
BoolToExpandedIndicatorTag |
BoolToHiddenVisibility |
BoolToLeftMargin |
BoolToListSortDirection |
BoolToOpposite |
BoolToOppositeHiddenVisibility |
BoolToOppositeVisibility |
BoolToParameterValue |
BoolToVisibility |
BoolType |
CalculatedForeground |
CameraAnimationTimeToBool |
CaptionBarInfoToApplicationTitle |
CaptionBarInfoToResourceObject |
Chain |
CloseActionToBool |
CollectionRoleToSeparatorVisibility |
ColorToSolidColorBrushColor |
Complement |
ConstantMultiply |
ConstantMultiplyPoint |
ConstantSum |
ConstraintToBool |
ContentValidation |
ContextualTabBaseColorToHoverBrush |
CornerRadiusClip |
CultureValue |
DataContextToActionItem |
DateFilterType |
Debug |
DimensionsToPlaceholderIcon |
DoubleToPropertyEditorWidth |
DoubleType |
DoubleTypeEx |
DoubleTypeWithUnits |
DoubleTypeWithUnitsEx |
DoubleWithUnitType |
DoubleWithUnitTypeNonShared |
ECatGroupBoxWidth |
ECatTreeViewItemBorderLength |
EmptyToVisibility |
EnumToBool |
EnumType |
FileExtensionToIconSource |
FilterTypeToTemplate |
FloorVisibilityAndAutoResizeToBool |
HorizontalToTextAlignment |
HorizontalToVisibility |
IconStackYPosition |
ImageSource |
InstanceToType |
IntToBool |
IntToOppositeBool |
IntToVisibility |
IntTypeWithUnits |
IsDraggingToOpacity |
IsSwappingToFill |
IsSwappingToFillStatistics |
IsTrimmedToVisibility |
ItemDataToResource |
ItemDataToVisibility |
ItemToIsReadOnly |
KrcStatusToIconColor |
KrcStatusToString |
Language |
LeftMarginMultiplier |
LicenseKeyConverter |
LicenseServerHostConverter |
LicenseServerPortConverter |
ListToString |
ListToVisibility |
Localization |
MediaColorToSolidColorBrushColor |
MenuScrollingVisibility |
MenuToolButtonType |
MenuToolType |
MultipleBoolValueToIsEnabled |
Multiply |
NewLineToSpace |
NullableColor |
NullableToVisibility |
NullToBool |
NullToFalse |
NullToHiddenVisibility |
NullToOppositeVisibility |
NullToVisibility |
ObjectToString |
ObjectToWindowIcon |
OverlayBlend |
ParameterEqualityToVisibility |
PathAndColumnToImageSource |
ProductKeyString |
RootGridWidthToTabWidth |
SecondToTimeSpan |
ServerNodeIcon |
SimulationModeEnumToBool |
SimulationTimeForCameraEditor |
SpecializedTextBoxValue |
SpeedFactor |
StateToCollapsedGlyphVisibility |
StateToExpandCollapseTooltip |
StateToExpandedGlyphVisibility |
StateToMaximizeGlyphVisibility |
StateToMaximizeMinimizeTooltip |
StateToRestoreGlyphVisibility |
StringFormat |
StringToBool |
StringToDoubleWithUnit |
StringToPathGeometry |
StringToResource |
StringToTrimmed |
StringToUri |
StringToVisibility |
StringWithoutMnemonics |
SummaryResultFormatStringValue |
TextAlignmentToHorizontalAlignment |
TextInputType |
ThicknessToOpposite |
TimeSpanToMilliseconds |
ToRibbonToolId |
ToXamDataTreeWidth |
TreeNodeWidth |
TwoStringsEquality |
TwoValuesEquality |
TypeCheck |
Unit |
UnitType |
UnprecisedDoubleTypeWithUnits |
UriToBitmapImage |
UriToImage |
UTCToLocalDateTime |
ValidationErrorToErrorContent |
ValueAndUnitToString |
VariableWidth |
VectorOrientationToOrientation |
VectorToColor |
VerticalToVisibility |
ViewOptionToTemplate |
ViewPreviewImageSource |
WindowHeightToWindowContentHeight |
VisibilityToBool |
VisibilityToBoolValue |
VisibilityToOpposite |
Top
Fields
Name | Description
_visibilityToBool |
_visibilityToOpposite |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ConverterFactory Properties

The ConverterFactory type exposes the following members.

Properties
Name | Description
ApplicationMenuButton |
ApplicationMenuTabFont |
BoolToCapabilityIcon |
BoolToColor |
BoolToExpandedIndicatorTag |
BoolToHiddenVisibility |
BoolToLeftMargin |
BoolToListSortDirection |
BoolToOpposite |
BoolToOppositeHiddenVisibility |
BoolToOppositeVisibility |
BoolToParameterValue |
BoolToVisibility |
BoolType |
CalculatedForeground |
CameraAnimationTimeToBool |
CaptionBarInfoToApplicationTitle |
CaptionBarInfoToResourceObject |
Chain |
CloseActionToBool |
CollectionRoleToSeparatorVisibility |
ColorToSolidColorBrushColor |
Complement |
ConstantMultiply |
ConstantMultiplyPoint |
ConstantSum |
ConstraintToBool |
ContentValidation |
ContextualTabBaseColorToHoverBrush |
CornerRadiusClip |
CultureValue |
DataContextToActionItem |
DateFilterType |
Debug |
DimensionsToPlaceholderIcon |
DoubleToPropertyEditorWidth |
DoubleType |
DoubleTypeEx |
DoubleTypeWithUnits |
DoubleTypeWithUnitsEx |
DoubleWithUnitType |
DoubleWithUnitTypeNonShared |
ECatGroupBoxWidth |
ECatTreeViewItemBorderLength |
EmptyToVisibility |
EnumToBool |
EnumType |
FileExtensionToIconSource |
FilterTypeToTemplate |
FloorVisibilityAndAutoResizeToBool |
HorizontalToTextAlignment |
HorizontalToVisibility |
IconStackYPosition |
ImageSource |
InstanceToType |
IntToBool |
IntToOppositeBool |
IntToVisibility |
IntTypeWithUnits |
IsDraggingToOpacity |
IsSwappingToFill |
IsSwappingToFillStatistics |
IsTrimmedToVisibility |
ItemDataToResource |
ItemDataToVisibility |
ItemToIsReadOnly |
KrcStatusToIconColor |
KrcStatusToString |
Language |
LeftMarginMultiplier |
LicenseKeyConverter |
LicenseServerHostConverter |
LicenseServerPortConverter |
ListToString |
ListToVisibility |
Localization |
MediaColorToSolidColorBrushColor |
MenuScrollingVisibility |
MenuToolButtonType |
MenuToolType |
MultipleBoolValueToIsEnabled |
Multiply |
NewLineToSpace |
NullableColor |
NullableToVisibility |
NullToBool |
NullToFalse |
NullToHiddenVisibility |
NullToOppositeVisibility |
NullToVisibility |
ObjectToString |
ObjectToWindowIcon |
OverlayBlend |
ParameterEqualityToVisibility |
PathAndColumnToImageSource |
ProductKeyString |
RootGridWidthToTabWidth |
SecondToTimeSpan |
ServerNodeIcon |
SimulationModeEnumToBool |
SimulationTimeForCameraEditor |
SpecializedTextBoxValue |
SpeedFactor |
StateToCollapsedGlyphVisibility |
StateToExpandCollapseTooltip |
StateToExpandedGlyphVisibility |
StateToMaximizeGlyphVisibility |
StateToMaximizeMinimizeTooltip |
StateToRestoreGlyphVisibility |
StringFormat |
StringToBool |
StringToDoubleWithUnit |
StringToPathGeometry |
StringToResource |
StringToTrimmed |
StringToUri |
StringToVisibility |
StringWithoutMnemonics |
SummaryResultFormatStringValue |
TextAlignmentToHorizontalAlignment |
TextInputType |
ThicknessToOpposite |
TimeSpanToMilliseconds |
ToRibbonToolId |
ToXamDataTreeWidth |
TreeNodeWidth |
TwoStringsEquality |
TwoValuesEquality |
TypeCheck |
Unit |
UnitType |
UnprecisedDoubleTypeWithUnits |
UriToBitmapImage |
UriToImage |
UTCToLocalDateTime |
ValidationErrorToErrorContent |
ValueAndUnitToString |
VariableWidth |
VectorOrientationToOrientation |
VectorToColor |
VerticalToVisibility |
ViewOptionToTemplate |
ViewPreviewImageSource |
WindowHeightToWindowContentHeight |
VisibilityToBool |
VisibilityToBoolValue |
VisibilityToOpposite |
Top
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ApplicationMenuButton Property

ConverterFactoryApplicationMenuButton Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ApplicationMenuButtonTransformConverter ApplicationMenuButton { get; }
public:
static property ApplicationMenuButtonTransformConverter^ ApplicationMenuButton {
    ApplicationMenuButtonTransformConverter^ get ();
}

Property Value

Type: ApplicationMenuButtonTransformConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ApplicationMenuTabFont Property

ConverterFactoryApplicationMenuTabFont Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ScaledDoubleConverter ApplicationMenuTabFont { get; }
public:
static property ScaledDoubleConverter^ ApplicationMenuTabFont {
    ScaledDoubleConverter^ get ();
}

Property Value

Type: ScaledDoubleConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.BoolToCapabilityIcon Property

ConverterFactoryBoolToCapabilityIcon Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IValueConverter BoolToCapabilityIcon { get; set; }
public:
static property IValueConverter^ BoolToCapabilityIcon {
    IValueConverter^ get ();
    void set (IValueConverter^ value);
}

Property Value

Type: IValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.BoolToColor Property

ConverterFactoryBoolToColor Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static BoolToColorConverter BoolToColor { get; }
public:
static property BoolToColorConverter^ BoolToColor {
    BoolToColorConverter^ get ();
}

Property Value

Type: BoolToColorConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.BoolToExpandedIndicatorTag Property

ConverterFactoryBoolToExpandedIndicatorTag Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IValueConverter BoolToExpandedIndicatorTag { get; set; }
public:
static property IValueConverter^ BoolToExpandedIndicatorTag {
    IValueConverter^ get ();
    void set (IValueConverter^ value);
}

Property Value

Type: IValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.BoolToHiddenVisibility Property

ConverterFactoryBoolToHiddenVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IValueConverter BoolToHiddenVisibility { get; }
public:
static property IValueConverter^ BoolToHiddenVisibility {
    IValueConverter^ get ();
}

Property Value

Type: IValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.BoolToLeftMargin Property

ConverterFactoryBoolToLeftMargin Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static BoolToLeftMarginConverter BoolToLeftMargin { get; }
public:
static property BoolToLeftMarginConverter^ BoolToLeftMargin {
    BoolToLeftMarginConverter^ get ();
}

Property Value

Type: BoolToLeftMarginConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.BoolToListSortDirection Property

ConverterFactoryBoolToListSortDirection Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static BoolToListSortDirectionConverter BoolToListSortDirection { get; }
public:
static property BoolToListSortDirectionConverter^ BoolToListSortDirection {
    BoolToListSortDirectionConverter^ get ();
}

Property Value

Type: BoolToListSortDirectionConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.BoolToOpposite Property

ConverterFactoryBoolToOpposite Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static BoolToOppositeConverter BoolToOpposite { get; }
public:
static property BoolToOppositeConverter^ BoolToOpposite {
    BoolToOppositeConverter^ get ();
}

Property Value

Type: BoolToOppositeConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.BoolToOppositeHiddenVisibility Property

ConverterFactoryBoolToOppositeHiddenVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IValueConverter BoolToOppositeHiddenVisibility { get; }
public:
static property IValueConverter^ BoolToOppositeHiddenVisibility {
    IValueConverter^ get ();
}

Property Value

Type: IValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.BoolToOppositeVisibility Property

ConverterFactoryBoolToOppositeVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static BooleanToOppositeVisibilityConverter BoolToOppositeVisibility { get; }
public:
static property BooleanToOppositeVisibilityConverter^ BoolToOppositeVisibility {
    BooleanToOppositeVisibilityConverter^ get ();
}

Property Value

Type: BooleanToOppositeVisibilityConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.BoolToParameterValue Property

ConverterFactoryBoolToParameterValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static BoolToParameterValueConverter BoolToParameterValue { get; }
public:
static property BoolToParameterValueConverter^ BoolToParameterValue {
    BoolToParameterValueConverter^ get ();
}

Property Value

Type: BoolToParameterValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.BoolToVisibility Property

ConverterFactoryBoolToVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static BooleanToVisibilityConverter BoolToVisibility { get; }
public:
static property BooleanToVisibilityConverter^ BoolToVisibility {
    BooleanToVisibilityConverter^ get ();
}

Property Value

Type: BooleanToVisibilityConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.BoolType Property

ConverterFactoryBoolType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static BoolTypeConverter BoolType { get; }
public:
static property BoolTypeConverter^ BoolType {
    BoolTypeConverter^ get ();
}

Property Value

Type: BoolTypeConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.CalculatedForeground Property

ConverterFactoryCalculatedForeground Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static CalculatedForegroundConverter CalculatedForeground { get; }
public:
static property CalculatedForegroundConverter^ CalculatedForeground {
    CalculatedForegroundConverter^ get ();
}

Property Value

Type: CalculatedForegroundConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.CameraAnimationTimeToBool Property

ConverterFactoryCameraAnimationTimeToBool Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static CameraAnimationTimeToBoolConverter CameraAnimationTimeToBool { get; }
public:
static property CameraAnimationTimeToBoolConverter^ CameraAnimationTimeToBool {
    CameraAnimationTimeToBoolConverter^ get ();
}

Property Value

Type: CameraAnimationTimeToBoolConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.CaptionBarInfoToApplicationTitle Property

ConverterFactoryCaptionBarInfoToApplicationTitle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static CaptionBarInfoToApplicationTitleConverter CaptionBarInfoToApplicationTitle { get; }
public:
static property CaptionBarInfoToApplicationTitleConverter^ CaptionBarInfoToApplicationTitle {
    CaptionBarInfoToApplicationTitleConverter^ get ();
}

Property Value

Type: CaptionBarInfoToApplicationTitleConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.CaptionBarInfoToResourceObject Property

ConverterFactoryCaptionBarInfoToResourceObject Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static CaptionBarInfoToResourceObjectConverter CaptionBarInfoToResourceObject { get; }
public:
static property CaptionBarInfoToResourceObjectConverter^ CaptionBarInfoToResourceObject {
    CaptionBarInfoToResourceObjectConverter^ get ();
}

Property Value

Type: CaptionBarInfoToResourceObjectConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.Chain Property

ConverterFactoryChain Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ChainConverter Chain { get; }
public:
static property ChainConverter^ Chain {
    ChainConverter^ get ();
}

Property Value

Type: ChainConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.CloseActionToBool Property

ConverterFactoryCloseActionToBool Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ValueConverterGroup CloseActionToBool { get; }
public:
static property ValueConverterGroup^ CloseActionToBool {
    ValueConverterGroup^ get ();
}

Property Value

Type: ValueConverterGroup
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.CollectionRoleToSeparatorVisibility Property

ConverterFactoryCollectionRoleToSeparatorVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IValueConverter CollectionRoleToSeparatorVisibility { get; set; }
public:
static property IValueConverter^ CollectionRoleToSeparatorVisibility {
    IValueConverter^ get ();
    void set (IValueConverter^ value);
}

Property Value

Type: IValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ColorToSolidColorBrushColor Property

ConverterFactoryColorToSolidColorBrushColor Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ColorToSolidColorBrushColorConverter ColorToSolidColorBrushColor { get; }
public:
static property ColorToSolidColorBrushColorConverter^ ColorToSolidColorBrushColor {
    ColorToSolidColorBrushColorConverter^ get ();
}

Property Value

Type: ColorToSolidColorBrushColorConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.Complement Property

ConverterFactoryComplement Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static BoolToValueConverter Complement { get; }
public:
static property BoolToValueConverter^ Complement {
    BoolToValueConverter^ get ();
}

Property Value

Type: BoolToValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ConstantMultiply Property

ConverterFactoryConstantMultiply Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ConstantMultiplyConverter ConstantMultiply { get; }
public:
static property ConstantMultiplyConverter^ ConstantMultiply {
    ConstantMultiplyConverter^ get ();
}

Property Value

Type: ConstantMultiplyConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ConstantMultiplyPoint Property

ConverterFactoryConstantMultiplyPoint Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ConstantMultiplyPointConverter ConstantMultiplyPoint { get; }
public:
static property ConstantMultiplyPointConverter^ ConstantMultiplyPoint {
    ConstantMultiplyPointConverter^ get ();
}

Property Value

Type: ConstantMultiplyPointConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ConstantSum Property

ConverterFactoryConstantSum Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ConstantSumConverter ConstantSum { get; }
public:
static property ConstantSumConverter^ ConstantSum {
    ConstantSumConverter^ get ();
}

Property Value

Type: ConstantSumConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ConstraintToBool Property

ConverterFactoryConstraintToBool Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ConstraintToBooleanConverter ConstraintToBool { get; }
public:
static property ConstraintToBooleanConverter^ ConstraintToBool {
    ConstraintToBooleanConverter^ get ();
}

Property Value

Type: ConstraintToBooleanConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ContentValidation Property

ConverterFactoryContentValidation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ContentValidationConverter ContentValidation { get; }
public:
static property ContentValidationConverter^ ContentValidation {
    ContentValidationConverter^ get ();
}

Property Value

Type: ContentValidationConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ContextualTabBaseColorToHoverBrush Property

ConverterFactoryContextualTabBaseColorToHoverBrush Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ContextualTabBaseColorToHoverBrushConverter ContextualTabBaseColorToHoverBrush { get; }
public:
static property ContextualTabBaseColorToHoverBrushConverter^ ContextualTabBaseColorToHoverBrush {
    ContextualTabBaseColorToHoverBrushConverter^ get ();
}

Property Value

Type: ContextualTabBaseColorToHoverBrushConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.CornerRadiusClip Property

ConverterFactoryCornerRadiusClip Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static CornerRadiusClipConverter CornerRadiusClip { get; }
public:
static property CornerRadiusClipConverter^ CornerRadiusClip {
    CornerRadiusClipConverter^ get ();
}

Property Value

Type: CornerRadiusClipConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.CultureValue Property

ConverterFactoryCultureValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static CultureValueConverter CultureValue { get; }
public:
static property CultureValueConverter^ CultureValue {
    CultureValueConverter^ get ();
}

Property Value

Type: CultureValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.DataContextToActionItem Property

ConverterFactoryDataContextToActionItem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IValueConverter DataContextToActionItem { get; set; }
public:
static property IValueConverter^ DataContextToActionItem {
    IValueConverter^ get ();
    void set (IValueConverter^ value);
}

Property Value

Type: IValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.DateFilterType Property

ConverterFactoryDateFilterType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DateFilterTypeConverter DateFilterType { get; }
public:
static property DateFilterTypeConverter^ DateFilterType {
    DateFilterTypeConverter^ get ();
}

Property Value

Type: DateFilterTypeConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.Debug Property

ConverterFactoryDebug Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DebugConverter Debug { get; }
public:
static property DebugConverter^ Debug {
    DebugConverter^ get ();
}

Property Value

Type: DebugConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.DimensionsToPlaceholderIcon Property

ConverterFactoryDimensionsToPlaceholderIcon Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IMultiValueConverter DimensionsToPlaceholderIcon { get; set; }
public:
static property IMultiValueConverter^ DimensionsToPlaceholderIcon {
    IMultiValueConverter^ get ();
    void set (IMultiValueConverter^ value);
}

Property Value

Type: IMultiValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.DoubleToPropertyEditorWidth Property

ConverterFactoryDoubleToPropertyEditorWidth Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DoubleToPropertyEditorWidthConverter DoubleToPropertyEditorWidth { get; }
public:
static property DoubleToPropertyEditorWidthConverter^ DoubleToPropertyEditorWidth {
    DoubleToPropertyEditorWidthConverter^ get ();
}

Property Value

Type: DoubleToPropertyEditorWidthConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.DoubleType Property

ConverterFactoryDoubleType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DoubleTypeConverter DoubleType { get; }
public:
static property DoubleTypeConverter^ DoubleType {
    DoubleTypeConverter^ get ();
}

Property Value

Type: DoubleTypeConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.DoubleTypeEx Property

ConverterFactoryDoubleTypeEx Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DoubleTypeConverterEx DoubleTypeEx { get; }
public:
static property DoubleTypeConverterEx^ DoubleTypeEx {
    DoubleTypeConverterEx^ get ();
}

Property Value

Type: DoubleTypeConverterEx
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.DoubleTypeWithUnits Property

ConverterFactoryDoubleTypeWithUnits Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DoubleTypeConverterWithUnits DoubleTypeWithUnits { get; }
public:
static property DoubleTypeConverterWithUnits^ DoubleTypeWithUnits {
    DoubleTypeConverterWithUnits^ get ();
}

Property Value

Type: DoubleTypeConverterWithUnits
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.DoubleTypeWithUnitsEx Property

ConverterFactoryDoubleTypeWithUnitsEx Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DoubleTypeConverterWithUnitsEx DoubleTypeWithUnitsEx { get; }
public:
static property DoubleTypeConverterWithUnitsEx^ DoubleTypeWithUnitsEx {
    DoubleTypeConverterWithUnitsEx^ get ();
}

Property Value

Type: DoubleTypeConverterWithUnitsEx
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.DoubleWithUnitType Property

ConverterFactoryDoubleWithUnitType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DoubleWithUnitTypeConverter DoubleWithUnitType { get; }
public:
static property DoubleWithUnitTypeConverter^ DoubleWithUnitType {
    DoubleWithUnitTypeConverter^ get ();
}

Property Value

Type: DoubleWithUnitTypeConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.DoubleWithUnitTypeNonShared Property

ConverterFactoryDoubleWithUnitTypeNonShared Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DoubleWithUnitTypeConverter DoubleWithUnitTypeNonShared { get; }
public:
static property DoubleWithUnitTypeConverter^ DoubleWithUnitTypeNonShared {
    DoubleWithUnitTypeConverter^ get ();
}

Property Value

Type: DoubleWithUnitTypeConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ECatGroupBoxWidth Property

ConverterFactoryECatGroupBoxWidth Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static eCatGroupBoxWidthConverter ECatGroupBoxWidth { get; }
public:
static property eCatGroupBoxWidthConverter^ ECatGroupBoxWidth {
    eCatGroupBoxWidthConverter^ get ();
}

Property Value

Type: eCatGroupBoxWidthConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ECatTreeViewItemBorderLength Property

ConverterFactoryECatTreeViewItemBorderLength Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static LeftMarginMultiplierConverter ECatTreeViewItemBorderLength { get; }
public:
static property LeftMarginMultiplierConverter^ ECatTreeViewItemBorderLength {
    LeftMarginMultiplierConverter^ get ();
}

Property Value

Type: LeftMarginMultiplierConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.EmptyToVisibility Property

ConverterFactoryEmptyToVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static EmptyToVisibilityConverter EmptyToVisibility { get; }
public:
static property EmptyToVisibilityConverter^ EmptyToVisibility {
    EmptyToVisibilityConverter^ get ();
}

Property Value

Type: EmptyToVisibilityConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.EnumToBool Property

ConverterFactoryEnumToBool Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static EnumToBooleanConverter EnumToBool { get; }
public:
static property EnumToBooleanConverter^ EnumToBool {
    EnumToBooleanConverter^ get ();
}

Property Value

Type: EnumToBooleanConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.EnumType Property

ConverterFactoryEnumType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static EnumTypeConverter EnumType { get; }
public:
static property EnumTypeConverter^ EnumType {
    EnumTypeConverter^ get ();
}

Property Value

Type: EnumTypeConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.FileExtensionToIconSource Property

ConverterFactoryFileExtensionToIconSource Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static FileExtensionToIconSourceConverter FileExtensionToIconSource { get; }
public:
static property FileExtensionToIconSourceConverter^ FileExtensionToIconSource {
    FileExtensionToIconSourceConverter^ get ();
}

Property Value

Type: FileExtensionToIconSourceConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.FilterTypeToTemplate Property

ConverterFactoryFilterTypeToTemplate Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IValueConverter FilterTypeToTemplate { get; set; }
public:
static property IValueConverter^ FilterTypeToTemplate {
    IValueConverter^ get ();
    void set (IValueConverter^ value);
}

Property Value

Type: IValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.FloorVisibilityAndAutoResizeToBool Property

ConverterFactoryFloorVisibilityAndAutoResizeToBool Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IMultiValueConverter FloorVisibilityAndAutoResizeToBool { get; set; }
public:
static property IMultiValueConverter^ FloorVisibilityAndAutoResizeToBool {
    IMultiValueConverter^ get ();
    void set (IMultiValueConverter^ value);
}

Property Value

Type: IMultiValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.HorizontalToTextAlignment Property

ConverterFactoryHorizontalToTextAlignment Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static HorizontalToTextAlignmentConverter HorizontalToTextAlignment { get; }
public:
static property HorizontalToTextAlignmentConverter^ HorizontalToTextAlignment {
    HorizontalToTextAlignmentConverter^ get ();
}

Property Value

Type: HorizontalToTextAlignmentConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.HorizontalToVisibility Property

ConverterFactoryHorizontalToVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ValueConverterGroup HorizontalToVisibility { get; }
public:
static property ValueConverterGroup^ HorizontalToVisibility {
    ValueConverterGroup^ get ();
}

Property Value

Type: ValueConverterGroup
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.IconStackYPosition Property

ConverterFactoryIconStackYPosition Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IMultiValueConverter IconStackYPosition { get; set; }
public:
static property IMultiValueConverter^ IconStackYPosition {
    IMultiValueConverter^ get ();
    void set (IMultiValueConverter^ value);
}

Property Value

Type: IMultiValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ImageSource Property

ConverterFactoryImageSource Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ImageSourceConverter ImageSource { get; }
public:
static property ImageSourceConverter^ ImageSource {
    ImageSourceConverter^ get ();
}

Property Value

Type: ImageSourceConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.InstanceToType Property

ConverterFactoryInstanceToType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static InstanceToTypeConverter InstanceToType { get; }
public:
static property InstanceToTypeConverter^ InstanceToType {
    InstanceToTypeConverter^ get ();
}

Property Value

Type: InstanceToTypeConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.IntToBool Property

ConverterFactoryIntToBool Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IntToBooleanConverter IntToBool { get; }
public:
static property IntToBooleanConverter^ IntToBool {
    IntToBooleanConverter^ get ();
}

Property Value

Type: IntToBooleanConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.IntToOppositeBool Property

ConverterFactoryIntToOppositeBool Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IntToOppositeBooleanConverter IntToOppositeBool { get; }
public:
static property IntToOppositeBooleanConverter^ IntToOppositeBool {
    IntToOppositeBooleanConverter^ get ();
}

Property Value

Type: IntToOppositeBooleanConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.IntToVisibility Property

ConverterFactoryIntToVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IntToVisibilityConverter IntToVisibility { get; }
public:
static property IntToVisibilityConverter^ IntToVisibility {
    IntToVisibilityConverter^ get ();
}

Property Value

Type: IntToVisibilityConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.IntTypeWithUnits Property

ConverterFactoryIntTypeWithUnits Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IntTypeConverterWithUnits IntTypeWithUnits { get; }
public:
static property IntTypeConverterWithUnits^ IntTypeWithUnits {
    IntTypeConverterWithUnits^ get ();
}

Property Value

Type: IntTypeConverterWithUnits
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.IsDraggingToOpacity Property

ConverterFactoryIsDraggingToOpacity Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ValueConverterGroup IsDraggingToOpacity { get; }
public:
static property ValueConverterGroup^ IsDraggingToOpacity {
    ValueConverterGroup^ get ();
}

Property Value

Type: ValueConverterGroup
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.IsSwappingToFill Property

ConverterFactoryIsSwappingToFill Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ValueConverterGroup IsSwappingToFill { get; }
public:
static property ValueConverterGroup^ IsSwappingToFill {
    ValueConverterGroup^ get ();
}

Property Value

Type: ValueConverterGroup
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.IsSwappingToFillStatistics Property

ConverterFactoryIsSwappingToFillStatistics Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ValueConverterGroup IsSwappingToFillStatistics { get; }
public:
static property ValueConverterGroup^ IsSwappingToFillStatistics {
    ValueConverterGroup^ get ();
}

Property Value

Type: ValueConverterGroup
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.IsTrimmedToVisibility Property

ConverterFactoryIsTrimmedToVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IsTrimmedToVisibilityConverter IsTrimmedToVisibility { get; }
public:
static property IsTrimmedToVisibilityConverter^ IsTrimmedToVisibility {
    IsTrimmedToVisibilityConverter^ get ();
}

Property Value

Type: IsTrimmedToVisibilityConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ItemDataToResource Property

ConverterFactoryItemDataToResource Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IValueConverter ItemDataToResource { get; set; }
public:
static property IValueConverter^ ItemDataToResource {
    IValueConverter^ get ();
    void set (IValueConverter^ value);
}

Property Value

Type: IValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ItemDataToVisibility Property

ConverterFactoryItemDataToVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IValueConverter ItemDataToVisibility { get; set; }
public:
static property IValueConverter^ ItemDataToVisibility {
    IValueConverter^ get ();
    void set (IValueConverter^ value);
}

Property Value

Type: IValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ItemToIsReadOnly Property

ConverterFactoryItemToIsReadOnly Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IValueConverter ItemToIsReadOnly { get; set; }
public:
static property IValueConverter^ ItemToIsReadOnly {
    IValueConverter^ get ();
    void set (IValueConverter^ value);
}

Property Value

Type: IValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.KrcStatusToIconColor Property

ConverterFactoryKrcStatusToIconColor Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IValueConverter KrcStatusToIconColor { get; set; }
public:
static property IValueConverter^ KrcStatusToIconColor {
    IValueConverter^ get ();
    void set (IValueConverter^ value);
}

Property Value

Type: IValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.KrcStatusToString Property

ConverterFactoryKrcStatusToString Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IValueConverter KrcStatusToString { get; set; }
public:
static property IValueConverter^ KrcStatusToString {
    IValueConverter^ get ();
    void set (IValueConverter^ value);
}

Property Value

Type: IValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.Language Property

ConverterFactoryLanguage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static LanguageConverter Language { get; }
public:
static property LanguageConverter^ Language {
    LanguageConverter^ get ();
}

Property Value

Type: LanguageConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.LeftMarginMultiplier Property

ConverterFactoryLeftMarginMultiplier Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static LeftMarginMultiplierConverter LeftMarginMultiplier { get; }
public:
static property LeftMarginMultiplierConverter^ LeftMarginMultiplier {
    LeftMarginMultiplierConverter^ get ();
}

Property Value

Type: LeftMarginMultiplierConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.LicenseKeyConverter Property

ConverterFactoryLicenseKeyConverter Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IValueConverter LicenseKeyConverter { get; set; }
public:
static property IValueConverter^ LicenseKeyConverter {
    IValueConverter^ get ();
    void set (IValueConverter^ value);
}

Property Value

Type: IValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.LicenseServerHostConverter Property

ConverterFactoryLicenseServerHostConverter Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IValueConverter LicenseServerHostConverter { get; set; }
public:
static property IValueConverter^ LicenseServerHostConverter {
    IValueConverter^ get ();
    void set (IValueConverter^ value);
}

Property Value

Type: IValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.LicenseServerPortConverter Property

ConverterFactoryLicenseServerPortConverter Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IValueConverter LicenseServerPortConverter { get; set; }
public:
static property IValueConverter^ LicenseServerPortConverter {
    IValueConverter^ get ();
    void set (IValueConverter^ value);
}

Property Value

Type: IValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ListToString Property

ConverterFactoryListToString Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ListToStringConverter ListToString { get; }
public:
static property ListToStringConverter^ ListToString {
    ListToStringConverter^ get ();
}

Property Value

Type: ListToStringConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ListToVisibility Property

ConverterFactoryListToVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ListToVisibilityConverter ListToVisibility { get; }
public:
static property ListToVisibilityConverter^ ListToVisibility {
    ListToVisibilityConverter^ get ();
}

Property Value

Type: ListToVisibilityConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.Localization Property

ConverterFactoryLocalization Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static LocalizationConverter Localization { get; }
public:
static property LocalizationConverter^ Localization {
    LocalizationConverter^ get ();
}

Property Value

Type: LocalizationConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.MediaColorToSolidColorBrushColor Property

ConverterFactoryMediaColorToSolidColorBrushColor Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MediaColorToSolidColorBrushColorConverter MediaColorToSolidColorBrushColor { get; }
public:
static property MediaColorToSolidColorBrushColorConverter^ MediaColorToSolidColorBrushColor {
    MediaColorToSolidColorBrushColorConverter^ get ();
}

Property Value

Type: MediaColorToSolidColorBrushColorConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.MenuScrollingVisibility Property

ConverterFactoryMenuScrollingVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MenuScrollingVisibilityConverter MenuScrollingVisibility { get; }
public:
static property MenuScrollingVisibilityConverter^ MenuScrollingVisibility {
    MenuScrollingVisibilityConverter^ get ();
}

Property Value

Type: MenuScrollingVisibilityConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.MenuToolButtonType Property

ConverterFactoryMenuToolButtonType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MenuToolButtonTypeConverter MenuToolButtonType { get; }
public:
static property MenuToolButtonTypeConverter^ MenuToolButtonType {
    MenuToolButtonTypeConverter^ get ();
}

Property Value

Type: MenuToolButtonTypeConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.MenuToolType Property

ConverterFactoryMenuToolType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MenuToolTypeConverter MenuToolType { get; }
public:
static property MenuToolTypeConverter^ MenuToolType {
    MenuToolTypeConverter^ get ();
}

Property Value

Type: MenuToolTypeConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.MultipleBoolValueToIsEnabled Property

ConverterFactoryMultipleBoolValueToIsEnabled Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MultipleBoolValueToIsEnabledConverter MultipleBoolValueToIsEnabled { get; }
public:
static property MultipleBoolValueToIsEnabledConverter^ MultipleBoolValueToIsEnabled {
    MultipleBoolValueToIsEnabledConverter^ get ();
}

Property Value

Type: MultipleBoolValueToIsEnabledConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.Multiply Property

ConverterFactoryMultiply Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MultiplyConverter Multiply { get; }
public:
static property MultiplyConverter^ Multiply {
    MultiplyConverter^ get ();
}

Property Value

Type: MultiplyConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.NewLineToSpace Property

ConverterFactoryNewLineToSpace Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static NewLineToSpaceConverter NewLineToSpace { get; }
public:
static property NewLineToSpaceConverter^ NewLineToSpace {
    NewLineToSpaceConverter^ get ();
}

Property Value

Type: NewLineToSpaceConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.NullableColor Property

ConverterFactoryNullableColor Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static NullableColorConverter NullableColor { get; }
public:
static property NullableColorConverter^ NullableColor {
    NullableColorConverter^ get ();
}

Property Value

Type: NullableColorConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.NullableToVisibility Property

ConverterFactoryNullableToVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static NullableToVisibilityConverter NullableToVisibility { get; }
public:
static property NullableToVisibilityConverter^ NullableToVisibility {
    NullableToVisibilityConverter^ get ();
}

Property Value

Type: NullableToVisibilityConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.NullToBool Property

ConverterFactoryNullToBool Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static NullToBooleanConverter NullToBool { get; }
public:
static property NullToBooleanConverter^ NullToBool {
    NullToBooleanConverter^ get ();
}

Property Value

Type: NullToBooleanConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.NullToFalse Property

ConverterFactoryNullToFalse Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static NullToFalseConverter NullToFalse { get; }
public:
static property NullToFalseConverter^ NullToFalse {
    NullToFalseConverter^ get ();
}

Property Value

Type: NullToFalseConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.NullToHiddenVisibility Property

ConverterFactoryNullToHiddenVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static NullToHiddenVisibilityConverter NullToHiddenVisibility { get; }
public:
static property NullToHiddenVisibilityConverter^ NullToHiddenVisibility {
    NullToHiddenVisibilityConverter^ get ();
}

Property Value

Type: NullToHiddenVisibilityConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.NullToOppositeVisibility Property

ConverterFactoryNullToOppositeVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static NullToOppositeVisibilityConverter NullToOppositeVisibility { get; }
public:
static property NullToOppositeVisibilityConverter^ NullToOppositeVisibility {
    NullToOppositeVisibilityConverter^ get ();
}

Property Value

Type: NullToOppositeVisibilityConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.NullToVisibility Property

ConverterFactoryNullToVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static NullToVisibilityConverter NullToVisibility { get; }
public:
static property NullToVisibilityConverter^ NullToVisibility {
    NullToVisibilityConverter^ get ();
}

Property Value

Type: NullToVisibilityConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ObjectToString Property

ConverterFactoryObjectToString Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ObjectToStringConverter ObjectToString { get; }
public:
static property ObjectToStringConverter^ ObjectToString {
    ObjectToStringConverter^ get ();
}

Property Value

Type: ObjectToStringConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ObjectToWindowIcon Property

ConverterFactoryObjectToWindowIcon Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ObjectToWindowIconConverter ObjectToWindowIcon { get; }
public:
static property ObjectToWindowIconConverter^ ObjectToWindowIcon {
    ObjectToWindowIconConverter^ get ();
}

Property Value

Type: ObjectToWindowIconConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.OverlayBlend Property

ConverterFactoryOverlayBlend Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ColorBlendConverter OverlayBlend { get; }
public:
static property ColorBlendConverter^ OverlayBlend {
    ColorBlendConverter^ get ();
}

Property Value

Type: ColorBlendConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ParameterEqualityToVisibility Property

ConverterFactoryParameterEqualityToVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ParameterEqualityToVisibilityConverter ParameterEqualityToVisibility { get; }
public:
static property ParameterEqualityToVisibilityConverter^ ParameterEqualityToVisibility {
    ParameterEqualityToVisibilityConverter^ get ();
}

Property Value

Type: ParameterEqualityToVisibilityConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.PathAndColumnToImageSource Property

ConverterFactoryPathAndColumnToImageSource Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IMultiValueConverter PathAndColumnToImageSource { get; set; }
public:
static property IMultiValueConverter^ PathAndColumnToImageSource {
    IMultiValueConverter^ get ();
    void set (IMultiValueConverter^ value);
}

Property Value

Type: IMultiValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ProductKeyString Property

ConverterFactoryProductKeyString Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ProductKeyStringConverter ProductKeyString { get; }
public:
static property ProductKeyStringConverter^ ProductKeyString {
    ProductKeyStringConverter^ get ();
}

Property Value

Type: ProductKeyStringConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.RootGridWidthToTabWidth Property

ConverterFactoryRootGridWidthToTabWidth Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static RootGridWidthToTabWidthConverter RootGridWidthToTabWidth { get; }
public:
static property RootGridWidthToTabWidthConverter^ RootGridWidthToTabWidth {
    RootGridWidthToTabWidthConverter^ get ();
}

Property Value

Type: RootGridWidthToTabWidthConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.SecondToTimeSpan Property

ConverterFactorySecondToTimeSpan Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static SecondToTimeSpanConverter SecondToTimeSpan { get; }
public:
static property SecondToTimeSpanConverter^ SecondToTimeSpan {
    SecondToTimeSpanConverter^ get ();
}

Property Value

Type: SecondToTimeSpanConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ServerNodeIcon Property

ConverterFactoryServerNodeIcon Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IMultiValueConverter ServerNodeIcon { get; set; }
public:
static property IMultiValueConverter^ ServerNodeIcon {
    IMultiValueConverter^ get ();
    void set (IMultiValueConverter^ value);
}

Property Value

Type: IMultiValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.SimulationModeEnumToBool Property

ConverterFactorySimulationModeEnumToBool Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static SimulationModeEnumToBoolConveter SimulationModeEnumToBool { get; }
public:
static property SimulationModeEnumToBoolConveter^ SimulationModeEnumToBool {
    SimulationModeEnumToBoolConveter^ get ();
}

Property Value

Type: SimulationModeEnumToBoolConveter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.SimulationTimeForCameraEditor Property

ConverterFactorySimulationTimeForCameraEditor Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static SimulationTimeConverterForCameraEditor SimulationTimeForCameraEditor { get; }
public:
static property SimulationTimeConverterForCameraEditor^ SimulationTimeForCameraEditor {
    SimulationTimeConverterForCameraEditor^ get ();
}

Property Value

Type: SimulationTimeConverterForCameraEditor
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.SpecializedTextBoxValue Property

ConverterFactorySpecializedTextBoxValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static SpecializedTextBoxValueConverter SpecializedTextBoxValue { get; }
public:
static property SpecializedTextBoxValueConverter^ SpecializedTextBoxValue {
    SpecializedTextBoxValueConverter^ get ();
}

Property Value

Type: SpecializedTextBoxValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.SpeedFactor Property

ConverterFactorySpeedFactor Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static SpeedFactorConverter SpeedFactor { get; }
public:
static property SpeedFactorConverter^ SpeedFactor {
    SpeedFactorConverter^ get ();
}

Property Value

Type: SpeedFactorConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.StateToCollapsedGlyphVisibility Property

ConverterFactoryStateToCollapsedGlyphVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ValueConverterGroup StateToCollapsedGlyphVisibility { get; }
public:
static property ValueConverterGroup^ StateToCollapsedGlyphVisibility {
    ValueConverterGroup^ get ();
}

Property Value

Type: ValueConverterGroup
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.StateToExpandCollapseTooltip Property

ConverterFactoryStateToExpandCollapseTooltip Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ValueConverterGroup StateToExpandCollapseTooltip { get; }
public:
static property ValueConverterGroup^ StateToExpandCollapseTooltip {
    ValueConverterGroup^ get ();
}

Property Value

Type: ValueConverterGroup
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.StateToExpandedGlyphVisibility Property

ConverterFactoryStateToExpandedGlyphVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ValueConverterGroup StateToExpandedGlyphVisibility { get; }
public:
static property ValueConverterGroup^ StateToExpandedGlyphVisibility {
    ValueConverterGroup^ get ();
}

Property Value

Type: ValueConverterGroup
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.StateToMaximizeGlyphVisibility Property

ConverterFactoryStateToMaximizeGlyphVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ValueConverterGroup StateToMaximizeGlyphVisibility { get; }
public:
static property ValueConverterGroup^ StateToMaximizeGlyphVisibility {
    ValueConverterGroup^ get ();
}

Property Value

Type: ValueConverterGroup
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.StateToMaximizeMinimizeTooltip Property

ConverterFactoryStateToMaximizeMinimizeTooltip Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ValueConverterGroup StateToMaximizeMinimizeTooltip { get; }
public:
static property ValueConverterGroup^ StateToMaximizeMinimizeTooltip {
    ValueConverterGroup^ get ();
}

Property Value

Type: ValueConverterGroup
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.StateToRestoreGlyphVisibility Property

ConverterFactoryStateToRestoreGlyphVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ValueConverterGroup StateToRestoreGlyphVisibility { get; }
public:
static property ValueConverterGroup^ StateToRestoreGlyphVisibility {
    ValueConverterGroup^ get ();
}

Property Value

Type: ValueConverterGroup
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.StringFormat Property

ConverterFactoryStringFormat Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static StringFormatConverter StringFormat { get; }
public:
static property StringFormatConverter^ StringFormat {
    StringFormatConverter^ get ();
}

Property Value

Type: StringFormatConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.StringToBool Property

ConverterFactoryStringToBool Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static StringToBooleanConverter StringToBool { get; }
public:
static property StringToBooleanConverter^ StringToBool {
    StringToBooleanConverter^ get ();
}

Property Value

Type: StringToBooleanConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.StringToDoubleWithUnit Property

ConverterFactoryStringToDoubleWithUnit Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static StringToDoubleWithUnitConverter StringToDoubleWithUnit { get; }
public:
static property StringToDoubleWithUnitConverter^ StringToDoubleWithUnit {
    StringToDoubleWithUnitConverter^ get ();
}

Property Value

Type: StringToDoubleWithUnitConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.StringToPathGeometry Property

ConverterFactoryStringToPathGeometry Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static StringToPathGeometryConverter StringToPathGeometry { get; }
public:
static property StringToPathGeometryConverter^ StringToPathGeometry {
    StringToPathGeometryConverter^ get ();
}

Property Value

Type: StringToPathGeometryConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.StringToResource Property

ConverterFactoryStringToResource Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static StringToResourceConverter StringToResource { get; }
public:
static property StringToResourceConverter^ StringToResource {
    StringToResourceConverter^ get ();
}

Property Value

Type: StringToResourceConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.StringToTrimmed Property

ConverterFactoryStringToTrimmed Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static StringToTrimmedConverter StringToTrimmed { get; }
public:
static property StringToTrimmedConverter^ StringToTrimmed {
    StringToTrimmedConverter^ get ();
}

Property Value

Type: StringToTrimmedConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.StringToUri Property

ConverterFactoryStringToUri Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static StringToUriConverter StringToUri { get; }
public:
static property StringToUriConverter^ StringToUri {
    StringToUriConverter^ get ();
}

Property Value

Type: StringToUriConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.StringToVisibility Property

ConverterFactoryStringToVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static StringToVisibilityConverter StringToVisibility { get; }
public:
static property StringToVisibilityConverter^ StringToVisibility {
    StringToVisibilityConverter^ get ();
}

Property Value

Type: StringToVisibilityConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.StringWithoutMnemonics Property

ConverterFactoryStringWithoutMnemonics Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static StringWithoutMnemonicsConverter StringWithoutMnemonics { get; }
public:
static property StringWithoutMnemonicsConverter^ StringWithoutMnemonics {
    StringWithoutMnemonicsConverter^ get ();
}

Property Value

Type: StringWithoutMnemonicsConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.SummaryResultFormatStringValue Property

ConverterFactorySummaryResultFormatStringValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static SummaryResultFormatStringValueConverter SummaryResultFormatStringValue { get; }
public:
static property SummaryResultFormatStringValueConverter^ SummaryResultFormatStringValue {
    SummaryResultFormatStringValueConverter^ get ();
}

Property Value

Type: SummaryResultFormatStringValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.TextAlignmentToHorizontalAlignment Property

ConverterFactoryTextAlignmentToHorizontalAlignment Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static TextAlignmentToHorizontalAlignmentConverter TextAlignmentToHorizontalAlignment { get; }
public:
static property TextAlignmentToHorizontalAlignmentConverter^ TextAlignmentToHorizontalAlignment {
    TextAlignmentToHorizontalAlignmentConverter^ get ();
}

Property Value

Type: TextAlignmentToHorizontalAlignmentConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.TextInputType Property

ConverterFactoryTextInputType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static TextInputTypeConverter TextInputType { get; }
public:
static property TextInputTypeConverter^ TextInputType {
    TextInputTypeConverter^ get ();
}

Property Value

Type: TextInputTypeConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ThicknessToOpposite Property

ConverterFactoryThicknessToOpposite Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ThicknessToOppositeConverter ThicknessToOpposite { get; }
public:
static property ThicknessToOppositeConverter^ ThicknessToOpposite {
    ThicknessToOppositeConverter^ get ();
}

Property Value

Type: ThicknessToOppositeConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.TimeSpanToMilliseconds Property

ConverterFactoryTimeSpanToMilliseconds Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static TimeSpanToMillisecondsConverter TimeSpanToMilliseconds { get; }
public:
static property TimeSpanToMillisecondsConverter^ TimeSpanToMilliseconds {
    TimeSpanToMillisecondsConverter^ get ();
}

Property Value

Type: TimeSpanToMillisecondsConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ToRibbonToolId Property

ConverterFactoryToRibbonToolId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ToRibbonToolIdConverter ToRibbonToolId { get; }
public:
static property ToRibbonToolIdConverter^ ToRibbonToolId {
    ToRibbonToolIdConverter^ get ();
}

Property Value

Type: ToRibbonToolIdConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ToXamDataTreeWidth Property

ConverterFactoryToXamDataTreeWidth Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ToXamDataTreeWidthConverter ToXamDataTreeWidth { get; }
public:
static property ToXamDataTreeWidthConverter^ ToXamDataTreeWidth {
    ToXamDataTreeWidthConverter^ get ();
}

Property Value

Type: ToXamDataTreeWidthConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.TreeNodeWidth Property

ConverterFactoryTreeNodeWidth Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ToTreeNodeWidthConverter TreeNodeWidth { get; }
public:
static property ToTreeNodeWidthConverter^ TreeNodeWidth {
    ToTreeNodeWidthConverter^ get ();
}

Property Value

Type: ToTreeNodeWidthConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.TwoStringsEquality Property

ConverterFactoryTwoStringsEquality Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static TwoStringsEqualityConverter TwoStringsEquality { get; }
public:
static property TwoStringsEqualityConverter^ TwoStringsEquality {
    TwoStringsEqualityConverter^ get ();
}

Property Value

Type: TwoStringsEqualityConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.TwoValuesEquality Property

ConverterFactoryTwoValuesEquality Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static TwoValuesEqualityConverter TwoValuesEquality { get; }
public:
static property TwoValuesEqualityConverter^ TwoValuesEquality {
    TwoValuesEqualityConverter^ get ();
}

Property Value

Type: TwoValuesEqualityConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.TypeCheck Property

ConverterFactoryTypeCheck Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static TypeCheckConverter TypeCheck { get; }
public:
static property TypeCheckConverter^ TypeCheck {
    TypeCheckConverter^ get ();
}

Property Value

Type: TypeCheckConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.Unit Property

ConverterFactoryUnit Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static UnitConverter Unit { get; }
public:
static property UnitConverter^ Unit {
    UnitConverter^ get ();
}

Property Value

Type: UnitConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.UnitType Property

ConverterFactoryUnitType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static UnitTypeConverter UnitType { get; }
public:
static property UnitTypeConverter^ UnitType {
    UnitTypeConverter^ get ();
}

Property Value

Type: UnitTypeConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.UnprecisedDoubleTypeWithUnits Property

ConverterFactoryUnprecisedDoubleTypeWithUnits Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static UnprecisedDoubleTypeConverterWithUnits UnprecisedDoubleTypeWithUnits { get; }
public:
static property UnprecisedDoubleTypeConverterWithUnits^ UnprecisedDoubleTypeWithUnits {
    UnprecisedDoubleTypeConverterWithUnits^ get ();
}

Property Value

Type: UnprecisedDoubleTypeConverterWithUnits
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.UriToBitmapImage Property

ConverterFactoryUriToBitmapImage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static UriToBitmapImageConverter UriToBitmapImage { get; }
public:
static property UriToBitmapImageConverter^ UriToBitmapImage {
    UriToBitmapImageConverter^ get ();
}

Property Value

Type: UriToBitmapImageConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.UriToImage Property

ConverterFactoryUriToImage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IMultiValueConverter UriToImage { get; set; }
public:
static property IMultiValueConverter^ UriToImage {
    IMultiValueConverter^ get ();
    void set (IMultiValueConverter^ value);
}

Property Value

Type: IMultiValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.UTCToLocalDateTime Property

ConverterFactoryUTCToLocalDateTime Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static UTCToLocalDateTimeConverter UTCToLocalDateTime { get; }
public:
static property UTCToLocalDateTimeConverter^ UTCToLocalDateTime {
    UTCToLocalDateTimeConverter^ get ();
}

Property Value

Type: UTCToLocalDateTimeConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ValidationErrorToErrorContent Property

ConverterFactoryValidationErrorToErrorContent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ValidationErrorToErrorContentConverter ValidationErrorToErrorContent { get; }
public:
static property ValidationErrorToErrorContentConverter^ ValidationErrorToErrorContent {
    ValidationErrorToErrorContentConverter^ get ();
}

Property Value

Type: ValidationErrorToErrorContentConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ValueAndUnitToString Property

ConverterFactoryValueAndUnitToString Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ValueAndUnitToStringConverter ValueAndUnitToString { get; }
public:
static property ValueAndUnitToStringConverter^ ValueAndUnitToString {
    ValueAndUnitToStringConverter^ get ();
}

Property Value

Type: ValueAndUnitToStringConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.VariableWidth Property

ConverterFactoryVariableWidth Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IMultiValueConverter VariableWidth { get; set; }
public:
static property IMultiValueConverter^ VariableWidth {
    IMultiValueConverter^ get ();
    void set (IMultiValueConverter^ value);
}

Property Value

Type: IMultiValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.VectorOrientationToOrientation Property

ConverterFactoryVectorOrientationToOrientation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static VectorOrientationToOrientationConverter VectorOrientationToOrientation { get; }
public:
static property VectorOrientationToOrientationConverter^ VectorOrientationToOrientation {
    VectorOrientationToOrientationConverter^ get ();
}

Property Value

Type: VectorOrientationToOrientationConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.VectorToColor Property

ConverterFactoryVectorToColor Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static VectorToColorConverter VectorToColor { get; }
public:
static property VectorToColorConverter^ VectorToColor {
    VectorToColorConverter^ get ();
}

Property Value

Type: VectorToColorConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.VerticalToVisibility Property

ConverterFactoryVerticalToVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ValueConverterGroup VerticalToVisibility { get; }
public:
static property ValueConverterGroup^ VerticalToVisibility {
    ValueConverterGroup^ get ();
}

Property Value

Type: ValueConverterGroup
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ViewOptionToTemplate Property

ConverterFactoryViewOptionToTemplate Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IValueConverter ViewOptionToTemplate { get; set; }
public:
static property IValueConverter^ ViewOptionToTemplate {
    IValueConverter^ get ();
    void set (IValueConverter^ value);
}

Property Value

Type: IValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.ViewPreviewImageSource Property

ConverterFactoryViewPreviewImageSource Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ViewPreviewImageSourceConverter ViewPreviewImageSource { get; }
public:
static property ViewPreviewImageSourceConverter^ ViewPreviewImageSource {
    ViewPreviewImageSourceConverter^ get ();
}

Property Value

Type: ViewPreviewImageSourceConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.WindowHeightToWindowContentHeight Property

ConverterFactoryWindowHeightToWindowContentHeight Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static WindowHeightToWindowContentHeightConverter WindowHeightToWindowContentHeight { get; }
public:
static property WindowHeightToWindowContentHeightConverter^ WindowHeightToWindowContentHeight {
    WindowHeightToWindowContentHeightConverter^ get ();
}

Property Value

Type: WindowHeightToWindowContentHeightConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.VisibilityToBool Property

ConverterFactoryVisibilityToBool Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static VisibilityToBooleanConverter VisibilityToBool { get; }
public:
static property VisibilityToBooleanConverter^ VisibilityToBool {
    VisibilityToBooleanConverter^ get ();
}

Property Value

Type: VisibilityToBooleanConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.VisibilityToBoolValue Property

ConverterFactoryVisibilityToBoolValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static VisibilityToBoolValueConverter VisibilityToBoolValue { get; }
public:
static property VisibilityToBoolValueConverter^ VisibilityToBoolValue {
    VisibilityToBoolValueConverter^ get ();
}

Property Value

Type: VisibilityToBoolValueConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory.VisibilityToOpposite Property

ConverterFactoryVisibilityToOpposite Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static VisibilityToOppositeConverter VisibilityToOpposite { get; }
public:
static property VisibilityToOppositeConverter^ VisibilityToOpposite {
    VisibilityToOppositeConverter^ get ();
}

Property Value

Type: VisibilityToOppositeConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory Fields

The ConverterFactory type exposes the following members.

Fields
Name | Description
_visibilityToBool |
_visibilityToOpposite |
Top
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory._visibilityToBool Field

ConverterFactory_visibilityToBool Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static VisibilityToBooleanConverter _visibilityToBool
public:
static VisibilityToBooleanConverter^ _visibilityToBool

Field Value

Type: VisibilityToBooleanConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


ConverterFactory._visibilityToOpposite Field

ConverterFactory_visibilityToOpposite Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static VisibilityToOppositeConverter _visibilityToOpposite
public:
static VisibilityToOppositeConverter^ _visibilityToOpposite

Field Value

Type: VisibilityToOppositeConverter
See Also

Reference

ConverterFactory Class
VisualComponents.UX.Shared Namespace


CopyToClipboardStatusMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedCopyToClipboardStatusMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class CopyToClipboardStatusMessage
public ref class CopyToClipboardStatusMessage

The CopyToClipboardStatusMessage type exposes the following members.

Constructors
 | Name | Description
Public method | CopyToClipboardStatusMessage | Initializes a new instance of the CopyToClipboardStatusMessage class
Top
Properties
 | Name | Description
Public property | Image |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


CopyToClipboardStatusMessage Constructor

Initializes a new instance of the CopyToClipboardStatusMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CopyToClipboardStatusMessage(
    BitmapImage image
)
public:
CopyToClipboardStatusMessage(
    BitmapImage^ image
)

Parameters

image
Type: System.Windows.Media.ImagingBitmapImage
See Also

Reference

CopyToClipboardStatusMessage Class
VisualComponents.UX.Shared Namespace


CopyToClipboardStatusMessage Properties

The CopyToClipboardStatusMessage type exposes the following members.

Properties
 | Name | Description
Public property | Image |
Top
See Also

Reference

CopyToClipboardStatusMessage Class
VisualComponents.UX.Shared Namespace


CopyToClipboardStatusMessage.Image Property

CopyToClipboardStatusMessageImage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BitmapImage Image { get; }
public:
property BitmapImage^ Image {
    BitmapImage^ get ();
}

Property Value

Type: BitmapImage
See Also

Reference

CopyToClipboardStatusMessage Class
VisualComponents.UX.Shared Namespace


CopyToClipboardStatusMessage Methods

The CopyToClipboardStatusMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CopyToClipboardStatusMessage Class
VisualComponents.UX.Shared Namespace


CornerRadiusClipConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedCornerRadiusClipConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class CornerRadiusClipConverter : IMultiValueConverter
public ref class CornerRadiusClipConverter : IMultiValueConverter

The CornerRadiusClipConverter type exposes the following members.

Constructors
 | Name | Description
Public method | CornerRadiusClipConverter | Initializes a new instance of the CornerRadiusClipConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


CornerRadiusClipConverter Constructor

Initializes a new instance of the CornerRadiusClipConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CornerRadiusClipConverter()
public:
CornerRadiusClipConverter()
See Also

Reference

CornerRadiusClipConverter Class
VisualComponents.UX.Shared Namespace


CornerRadiusClipConverter Methods

The CornerRadiusClipConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CornerRadiusClipConverter Class
VisualComponents.UX.Shared Namespace


CornerRadiusClipConverter.Convert Method

CornerRadiusClipConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    array<Object^>^ values,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

values
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.CornerRadiusClipConverter.Convert(System.Object[],System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

CornerRadiusClipConverter Class
VisualComponents.UX.Shared Namespace


CornerRadiusClipConverter.ConvertBack Method

CornerRadiusClipConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
public:
virtual array<Object^>^ ConvertBack(
    Object^ value,
    array<Type^>^ targetTypes,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetTypes
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.CornerRadiusClipConverter.ConvertBack(System.Object,System.Type[],System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

CornerRadiusClipConverter Class
VisualComponents.UX.Shared Namespace


CoroutineEx Class

Adds support for aborting actions.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedCoroutineEx

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class CoroutineEx
public ref class CoroutineEx abstract sealed

The CoroutineEx type exposes the following members.

Methods
Name | Description
BeginExecute | Executes a coroutine.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


CoroutineEx Methods

The CoroutineEx type exposes the following members.

Methods
Name | Description
BeginExecute | Executes a coroutine.
Top
See Also

Reference

CoroutineEx Class
VisualComponents.UX.Shared Namespace


CoroutineEx.BeginExecute Method

CoroutineExBeginExecute Method

Executes a coroutine.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void BeginExecute(
    IAbortableAction action,
    IEnumerator<IResult> coroutine,
    ActionExecutionContext context = null,
    EventHandler<ResultCompletionEventArgs> callback = null
)
public:
static void BeginExecute(
    IAbortableAction^ action,
    IEnumerator<IResult^>^ coroutine,
    ActionExecutionContext^ context = nullptr,
    EventHandler<ResultCompletionEventArgs^>^ callback = nullptr
)

Parameters

action
Type: VisualComponents.UX.SharedIAbortableAction
coroutine
Type: System.Collections.GenericIEnumeratorIResult
The coroutine to execute.
context (Optional)
Type: ActionExecutionContext
The context to execute the coroutine within.
callback (Optional)
Type: SystemEventHandlerResultCompletionEventArgs
The completion callback for the coroutine.
See Also

Reference

CoroutineEx Class
VisualComponents.UX.Shared Namespace


CultureAwareBinding Class

Inheritance Hierarchy
SystemObject
System.Windows.MarkupMarkupExtension
System.Windows.DataBindingBase
System.Windows.DataBinding
VisualComponents.UX.SharedCultureAwareBinding

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class CultureAwareBinding : Binding
public ref class CultureAwareBinding : public Binding

The CultureAwareBinding type exposes the following members.

Constructors
 | Name | Description
Public method | CultureAwareBinding | Initializes a new instance of the CultureAwareBinding class
Top
Properties
 | Name | Description
Public property | AsyncState | Gets or sets opaque data passed to the asynchronous data dispatcher. (Inherited from Binding.)
Public property | BindingGroupName | Gets or sets the name of the BindingGroup to which this binding belongs. (Inherited from BindingBase.)
Public property | BindsDirectlyToSource | Gets or sets a value that indicates whether to evaluate the Path relative to the data item or the DataSourceProvider object. (Inherited from Binding.)
Public property | Converter | Gets or sets the converter to use. (Inherited from Binding.)
Public property | ConverterCulture | Gets or sets the culture in which to evaluate the converter. (Inherited from Binding.)
Public property | ConverterParameter | Gets or sets the parameter to pass to the Converter. (Inherited from Binding.)
Public property | Delay | Gets or sets the amount of time, in milliseconds, to wait before updating the binding source after the value on the target changes. (Inherited from BindingBase.)
Public property | ElementName | Gets or sets the name of the element to use as the binding source object. (Inherited from Binding.)
Public property | FallbackValue | Gets or sets the value to use when the binding is unable to return a value. (Inherited from BindingBase.)
Public property | IsAsync | Gets or sets a value that indicates whether the Binding should get and set values asynchronously. (Inherited from Binding.)
Public property | Mode | Gets or sets a value that indicates the direction of the data flow in the binding. (Inherited from Binding.)
Public property | NotifyOnSourceUpdated | Gets or sets a value that indicates whether to raise the SourceUpdated event when a value is transferred from the binding target to the binding source. (Inherited from Binding.)
Public property | NotifyOnTargetUpdated | Gets or sets a value that indicates whether to raise the TargetUpdated event when a value is transferred from the binding source to the binding target. (Inherited from Binding.)
Public property | NotifyOnValidationError | Gets or sets a value that indicates whether to raise the Error attached event on the bound object. (Inherited from Binding.)
Public property | Path | Gets or sets the path to the binding source property. (Inherited from Binding.)
Public property | RelativeSource | Gets or sets the binding source by specifying its location relative to the position of the binding target. (Inherited from Binding.)
Public property | Source | Gets or sets the object to use as the binding source. (Inherited from Binding.)
Public property | StringFormat | Gets or sets a string that specifies how to format the binding if it displays the bound value as a string. (Inherited from BindingBase.)
Public property | TargetNullValue | Gets or sets the value that is used in the target when the value of the source is . (Inherited from BindingBase.)
Public property | UpdateSourceExceptionFilter | Gets or sets a handler you can use to provide custom logic for handling exceptions that the binding engine encounters during the update of the binding source value. This is only applicable if you have associated an ExceptionValidationRule with your binding. (Inherited from Binding.)
Public property | UpdateSourceTrigger | Gets or sets a value that determines the timing of binding source updates. (Inherited from Binding.)
Public property | ValidatesOnDataErrors | Gets or sets a value that indicates whether to include the DataErrorValidationRule. (Inherited from Binding.)
Public property | ValidatesOnExceptions | Gets or sets a value that indicates whether to include the ExceptionValidationRule. (Inherited from Binding.)
Public property | ValidatesOnNotifyDataErrors | Gets or sets a value that indicates whether to include the NotifyDataErrorValidationRule. (Inherited from Binding.)
Public property | ValidationRules | Gets a collection of rules that check the validity of the user input. (Inherited from Binding.)
Public property | XPath | Gets or sets an XPath query that returns the value on the XML binding source to use. (Inherited from Binding.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProvideValue | Returns an object that should be set on the property where this binding and extension are applied. (Inherited from BindingBase.)
Public method | ShouldSerializeFallbackValue | Returns a value that indicates whether serialization processes should serialize the effective value of the FallbackValue property on instances of this class. (Inherited from BindingBase.)
Public method | ShouldSerializePath | Indicates whether the Path property should be persisted. (Inherited from Binding.)
Public method | ShouldSerializeSource | Indicates whether the Source property should be persisted. (Inherited from Binding.)
Public method | ShouldSerializeTargetNullValue | Returns a value that indicates whether the TargetNullValue property should be serialized. (Inherited from BindingBase.)
Public method | ShouldSerializeValidationRules | Indicates whether the ValidationRules property should be persisted. (Inherited from Binding.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


CultureAwareBinding Constructor

Initializes a new instance of the CultureAwareBinding class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CultureAwareBinding()
public:
CultureAwareBinding()
See Also

Reference

CultureAwareBinding Class
VisualComponents.UX.Shared Namespace


CultureAwareBinding Properties

The CultureAwareBinding type exposes the following members.

Properties
 | Name | Description
Public property | AsyncState | Gets or sets opaque data passed to the asynchronous data dispatcher. (Inherited from Binding.)
Public property | BindingGroupName | Gets or sets the name of the BindingGroup to which this binding belongs. (Inherited from BindingBase.)
Public property | BindsDirectlyToSource | Gets or sets a value that indicates whether to evaluate the Path relative to the data item or the DataSourceProvider object. (Inherited from Binding.)
Public property | Converter | Gets or sets the converter to use. (Inherited from Binding.)
Public property | ConverterCulture | Gets or sets the culture in which to evaluate the converter. (Inherited from Binding.)
Public property | ConverterParameter | Gets or sets the parameter to pass to the Converter. (Inherited from Binding.)
Public property | Delay | Gets or sets the amount of time, in milliseconds, to wait before updating the binding source after the value on the target changes. (Inherited from BindingBase.)
Public property | ElementName | Gets or sets the name of the element to use as the binding source object. (Inherited from Binding.)
Public property | FallbackValue | Gets or sets the value to use when the binding is unable to return a value. (Inherited from BindingBase.)
Public property | IsAsync | Gets or sets a value that indicates whether the Binding should get and set values asynchronously. (Inherited from Binding.)
Public property | Mode | Gets or sets a value that indicates the direction of the data flow in the binding. (Inherited from Binding.)
Public property | NotifyOnSourceUpdated | Gets or sets a value that indicates whether to raise the SourceUpdated event when a value is transferred from the binding target to the binding source. (Inherited from Binding.)
Public property | NotifyOnTargetUpdated | Gets or sets a value that indicates whether to raise the TargetUpdated event when a value is transferred from the binding source to the binding target. (Inherited from Binding.)
Public property | NotifyOnValidationError | Gets or sets a value that indicates whether to raise the Error attached event on the bound object. (Inherited from Binding.)
Public property | Path | Gets or sets the path to the binding source property. (Inherited from Binding.)
Public property | RelativeSource | Gets or sets the binding source by specifying its location relative to the position of the binding target. (Inherited from Binding.)
Public property | Source | Gets or sets the object to use as the binding source. (Inherited from Binding.)
Public property | StringFormat | Gets or sets a string that specifies how to format the binding if it displays the bound value as a string. (Inherited from BindingBase.)
Public property | TargetNullValue | Gets or sets the value that is used in the target when the value of the source is . (Inherited from BindingBase.)
Public property | UpdateSourceExceptionFilter | Gets or sets a handler you can use to provide custom logic for handling exceptions that the binding engine encounters during the update of the binding source value. This is only applicable if you have associated an ExceptionValidationRule with your binding. (Inherited from Binding.)
Public property | UpdateSourceTrigger | Gets or sets a value that determines the timing of binding source updates. (Inherited from Binding.)
Public property | ValidatesOnDataErrors | Gets or sets a value that indicates whether to include the DataErrorValidationRule. (Inherited from Binding.)
Public property | ValidatesOnExceptions | Gets or sets a value that indicates whether to include the ExceptionValidationRule. (Inherited from Binding.)
Public property | ValidatesOnNotifyDataErrors | Gets or sets a value that indicates whether to include the NotifyDataErrorValidationRule. (Inherited from Binding.)
Public property | ValidationRules | Gets a collection of rules that check the validity of the user input. (Inherited from Binding.)
Public property | XPath | Gets or sets an XPath query that returns the value on the XML binding source to use. (Inherited from Binding.)
Top
See Also

Reference

CultureAwareBinding Class
VisualComponents.UX.Shared Namespace


CultureAwareBinding Methods

The CultureAwareBinding type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProvideValue | Returns an object that should be set on the property where this binding and extension are applied. (Inherited from BindingBase.)
Public method | ShouldSerializeFallbackValue | Returns a value that indicates whether serialization processes should serialize the effective value of the FallbackValue property on instances of this class. (Inherited from BindingBase.)
Public method | ShouldSerializePath | Indicates whether the Path property should be persisted. (Inherited from Binding.)
Public method | ShouldSerializeSource | Indicates whether the Source property should be persisted. (Inherited from Binding.)
Public method | ShouldSerializeTargetNullValue | Returns a value that indicates whether the TargetNullValue property should be serialized. (Inherited from BindingBase.)
Public method | ShouldSerializeValidationRules | Indicates whether the ValidationRules property should be persisted. (Inherited from Binding.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CultureAwareBinding Class
VisualComponents.UX.Shared Namespace


CursorHelper Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedCursorHelper

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class CursorHelper
public ref class CursorHelper

The CursorHelper type exposes the following members.

Constructors
 | Name | Description
Public method | CursorHelper | Initializes a new instance of the CursorHelper class
Top
Methods
 | Name | Description
 | CreateCursor |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


CursorHelper Constructor

Initializes a new instance of the CursorHelper class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CursorHelper()
public:
CursorHelper()
See Also

Reference

CursorHelper Class
VisualComponents.UX.Shared Namespace


CursorHelper Methods

The CursorHelper type exposes the following members.

Methods
 | Name | Description
 | CreateCursor |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CursorHelper Class
VisualComponents.UX.Shared Namespace


CursorHelper.CreateCursor Method

CursorHelperCreateCursor Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Cursor CreateCursor(
    UIElement element,
    int xHotSpot,
    int yHotSpot
)
public:
static Cursor^ CreateCursor(
    UIElement^ element,
    int xHotSpot,
    int yHotSpot
)

Parameters

element
Type: System.WindowsUIElement
xHotSpot
Type: SystemInt32
yHotSpot
Type: SystemInt32

Return Value

Type: Cursor

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.CursorHelper.CreateCursor(System.Windows.UIElement,System.Int32,System.Int32)"]

See Also

Reference

CursorHelper Class
VisualComponents.UX.Shared Namespace


CustomPropertyEditorGrid Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsPanel
System.Windows.ControlsGrid
VisualComponents.UX.SharedCustomPropertyEditorGrid

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class CustomPropertyEditorGrid : Grid
public ref class CustomPropertyEditorGrid : public Grid

The CustomPropertyEditorGrid type exposes the following members.

Constructors
 | Name | Description
Public method | CustomPropertyEditorGrid | Initializes a new instance of the CustomPropertyEditorGrid class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | ColumnDefinitions | Gets a ColumnDefinitionCollection defined on this instance of Grid. (Inherited from Grid.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | HasLogicalOrientationPublic | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical children of this Grid. (Inherited from Grid.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | LogicalOrientationPublic | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RowDefinitions | Gets a RowDefinitionCollection defined on this instance of Grid. (Inherited from Grid.)
Public property | ShowGridLines | Gets or sets a value that indicates whether grid lines are visible within this Grid. (Inherited from Grid.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets a value that represents the total number of Visual children within this instance of Grid. (Inherited from Grid.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Arranges the content of a Grid element. (Inherited from Grid.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Gets the child Visual at the specified index position. (Inherited from Grid.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Measures the children of a Grid in anticipation of arranging them during the ArrangeOverride(Size) pass. (Inherited from Grid.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the visual children of a Grid element change. (Inherited from Grid.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | ShouldSerializeColumnDefinitions | Returns true if ColumnDefinitionCollection associated with this instance of Grid is not empty. (Inherited from Grid.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeRowDefinitions | Returns true if RowDefinitionCollection associated with this instance of Grid is not empty. (Inherited from Grid.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


CustomPropertyEditorGrid Constructor

Initializes a new instance of the CustomPropertyEditorGrid class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CustomPropertyEditorGrid()
public:
CustomPropertyEditorGrid()
See Also

Reference

CustomPropertyEditorGrid Class
VisualComponents.UX.Shared Namespace


CustomPropertyEditorGrid Properties

The CustomPropertyEditorGrid type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | ColumnDefinitions | Gets a ColumnDefinitionCollection defined on this instance of Grid. (Inherited from Grid.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | HasLogicalOrientationPublic | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical children of this Grid. (Inherited from Grid.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | LogicalOrientationPublic | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RowDefinitions | Gets a RowDefinitionCollection defined on this instance of Grid. (Inherited from Grid.)
Public property | ShowGridLines | Gets or sets a value that indicates whether grid lines are visible within this Grid. (Inherited from Grid.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets a value that represents the total number of Visual children within this instance of Grid. (Inherited from Grid.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

CustomPropertyEditorGrid Class
VisualComponents.UX.Shared Namespace


CustomPropertyEditorGrid Methods

The CustomPropertyEditorGrid type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Arranges the content of a Grid element. (Inherited from Grid.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Gets the child Visual at the specified index position. (Inherited from Grid.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Measures the children of a Grid in anticipation of arranging them during the ArrangeOverride(Size) pass. (Inherited from Grid.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the visual children of a Grid element change. (Inherited from Grid.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | ShouldSerializeColumnDefinitions | Returns true if ColumnDefinitionCollection associated with this instance of Grid is not empty. (Inherited from Grid.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeRowDefinitions | Returns true if RowDefinitionCollection associated with this instance of Grid is not empty. (Inherited from Grid.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

CustomPropertyEditorGrid Class
VisualComponents.UX.Shared Namespace


CustomPropertyEditorGrid Events

The CustomPropertyEditorGrid type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

CustomPropertyEditorGrid Class
VisualComponents.UX.Shared Namespace


DatacontextToActionItemConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedDatacontextToActionItemConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class DatacontextToActionItemConverter : IValueConverter
public ref class DatacontextToActionItemConverter : IValueConverter

The DatacontextToActionItemConverter type exposes the following members.

Constructors
 | Name | Description
Public method | DatacontextToActionItemConverter | Initializes a new instance of the DatacontextToActionItemConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DatacontextToActionItemConverter Constructor

Initializes a new instance of the DatacontextToActionItemConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DatacontextToActionItemConverter()
public:
DatacontextToActionItemConverter()
See Also

Reference

DatacontextToActionItemConverter Class
VisualComponents.UX.Shared Namespace


DatacontextToActionItemConverter Methods

The DatacontextToActionItemConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DatacontextToActionItemConverter Class
VisualComponents.UX.Shared Namespace


DatacontextToActionItemConverter.Convert Method

DatacontextToActionItemConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.DatacontextToActionItemConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

DatacontextToActionItemConverter Class
VisualComponents.UX.Shared Namespace


DatacontextToActionItemConverter.ConvertBack Method

DatacontextToActionItemConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.DatacontextToActionItemConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

DatacontextToActionItemConverter Class
VisualComponents.UX.Shared Namespace


DebugConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedDebugConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class DebugConverter : IValueConverter
public ref class DebugConverter : IValueConverter

The DebugConverter type exposes the following members.

Constructors
 | Name | Description
Public method | DebugConverter | Initializes a new instance of the DebugConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DebugConverter Constructor

Initializes a new instance of the DebugConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DebugConverter()
public:
DebugConverter()
See Also

Reference

DebugConverter Class
VisualComponents.UX.Shared Namespace


DebugConverter Methods

The DebugConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DebugConverter Class
VisualComponents.UX.Shared Namespace


DebugConverter.Convert Method

DebugConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.DebugConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

DebugConverter Class
VisualComponents.UX.Shared Namespace


DebugConverter.ConvertBack Method

DebugConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.DebugConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

DebugConverter Class
VisualComponents.UX.Shared Namespace


DebugHelper Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedDebugHelper

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class DebugHelper
public ref class DebugHelper sealed

The DebugHelper type exposes the following members.

Properties
Name | Description
Light |
Self |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DebugHelper Properties

The DebugHelper type exposes the following members.

Properties
Name | Description
Light |
Self |
Top
See Also

Reference

DebugHelper Class
VisualComponents.UX.Shared Namespace


DebugHelper.Light Property

DebugHelperLight Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DebugLight Light { get; }
public:
static property DebugLight^ Light {
    DebugLight^ get ();
}

Property Value

Type: DebugLight
See Also

Reference

DebugHelper Class
VisualComponents.UX.Shared Namespace


DebugHelper.Self Property

DebugHelperSelf Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DebugHelper Self { get; }
public:
static property DebugHelper^ Self {
    DebugHelper^ get ();
}

Property Value

Type: DebugHelper
See Also

Reference

DebugHelper Class
VisualComponents.UX.Shared Namespace


DebugHelper Methods

The DebugHelper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DebugHelper Class
VisualComponents.UX.Shared Namespace


DebugLight Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.SharedDebugLight

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class DebugLight : PropertyChangedBase
public ref class DebugLight sealed : public PropertyChangedBase

The DebugLight type exposes the following members.

Properties
 | Name | Description
Public property | Color |
Public property | IsChecked |
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | Visibility |
Top
Methods
 | Name | Description
Public method | Blink |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide |
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | Off |
Public method | On |
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | Show |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Public event | Toggle |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DebugLight Properties

The DebugLight type exposes the following members.

Properties
 | Name | Description
Public property | Color |
Public property | IsChecked |
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | Visibility |
Top
See Also

Reference

DebugLight Class
VisualComponents.UX.Shared Namespace


DebugLight.Color Property

DebugLightColor Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Brush Color { get; set; }
public:
property Brush^ Color {
    Brush^ get ();
    void set (Brush^ value);
}

Property Value

Type: Brush
See Also

Reference

DebugLight Class
VisualComponents.UX.Shared Namespace


DebugLight.IsChecked Property

DebugLightIsChecked Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsChecked { get; set; }
public:
property bool IsChecked {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DebugLight Class
VisualComponents.UX.Shared Namespace


DebugLight.Visibility Property

DebugLightVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Visibility Visibility { get; set; }
public:
property Visibility Visibility {
    Visibility get ();
    void set (Visibility value);
}

Property Value

Type: Visibility
See Also

Reference

DebugLight Class
VisualComponents.UX.Shared Namespace


DebugLight Methods

The DebugLight type exposes the following members.

Methods
 | Name | Description
Public method | Blink |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide |
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | Off |
Public method | On |
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | Show |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DebugLight Class
VisualComponents.UX.Shared Namespace


DebugLight.Blink Method

DebugLightBlink Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Blink(
    uint duration = 1000
)
public:
void Blink(
    unsigned int duration = 1000
)

Parameters

duration (Optional)
Type: SystemUInt32
See Also

Reference

DebugLight Class
VisualComponents.UX.Shared Namespace


DebugLight.Hide Method

DebugLightHide Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Hide()
public:
void Hide()
See Also

Reference

DebugLight Class
VisualComponents.UX.Shared Namespace


DebugLight.Off Method

DebugLightOff Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Off()
public:
void Off()
See Also

Reference

DebugLight Class
VisualComponents.UX.Shared Namespace


DebugLight.On Method

DebugLightOn Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void On()
public:
void On()
See Also

Reference

DebugLight Class
VisualComponents.UX.Shared Namespace


DebugLight.Show Method

DebugLightShow Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Show()
public:
void Show()
See Also

Reference

DebugLight Class
VisualComponents.UX.Shared Namespace


DebugLight Events

The DebugLight type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Public event | Toggle |
Top
See Also

Reference

DebugLight Class
VisualComponents.UX.Shared Namespace


DebugLight.Toggle Event

DebugLightToggle Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<bool> Toggle
public:
 event EventHandler<bool>^ Toggle {
    void add (EventHandler<bool>^ value);
    void remove (EventHandler<bool>^ value);
}

Value

Type: SystemEventHandlerBoolean
See Also

Reference

DebugLight Class
VisualComponents.UX.Shared Namespace


DecimateAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedDecimateAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class DecimateAction : ICommandPanelAction,
    IDecimateAction
public ref class DecimateAction : ICommandPanelAction,
    IDecimateAction

The DecimateAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
Public property | IsActive |
Public property | Title |
Top
Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DecimateAction Properties

The DecimateAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
Public property | IsActive |
Public property | Title |
Top
See Also

Reference

DecimateAction Class
VisualComponents.UX.Shared Namespace


DecimateAction.ActionFinished Property

DecimateActionActionFinished Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ActionFinished { get; set; }
public:
virtual property bool ActionFinished {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ICommandPanelActionActionFinished
See Also

Reference

DecimateAction Class
VisualComponents.UX.Shared Namespace


DecimateAction.ActionProperties Property

DecimateActionActionProperties Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<IProperty> ActionProperties { get; }
public:
virtual property List<IProperty^>^ ActionProperties {
    List<IProperty^>^ get () sealed;
}

Property Value

Type: ListIProperty

Implements

ICommandPanelActionActionProperties
See Also

Reference

DecimateAction Class
VisualComponents.UX.Shared Namespace


DecimateAction.ApplyButtonText Property

DecimateActionApplyButtonText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ApplyButtonText { get; }
public:
virtual property String^ ApplyButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionApplyButtonText
See Also

Reference

DecimateAction Class
VisualComponents.UX.Shared Namespace


DecimateAction.AssociatedModelId Property

DecimateActionAssociatedModelId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedModelId { get; }
public:
virtual property String^ AssociatedModelId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedModelId
See Also

Reference

DecimateAction Class
VisualComponents.UX.Shared Namespace


DecimateAction.AssociatedSiteId Property

DecimateActionAssociatedSiteId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedSiteId { get; }
public:
virtual property String^ AssociatedSiteId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedSiteId
See Also

Reference

DecimateAction Class
VisualComponents.UX.Shared Namespace


DecimateAction.CallingCommandName Property

DecimateActionCallingCommandName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CallingCommandName { get; }
public:
virtual property String^ CallingCommandName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCallingCommandName
See Also

Reference

DecimateAction Class
VisualComponents.UX.Shared Namespace


DecimateAction.CancelButtonText Property

DecimateActionCancelButtonText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CancelButtonText { get; }
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCancelButtonText
See Also

Reference

DecimateAction Class
VisualComponents.UX.Shared Namespace


DecimateAction.Description Property

DecimateActionDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; }
public:
virtual property String^ Description {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionDescription
See Also

Reference

DecimateAction Class
VisualComponents.UX.Shared Namespace


DecimateAction.ErrorMessage Property

DecimateActionErrorMessage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ErrorMessage { get; set; }
public:
virtual property String^ ErrorMessage {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionErrorMessage
See Also

Reference

DecimateAction Class
VisualComponents.UX.Shared Namespace


DecimateAction.IsActive Property

DecimateActionIsActive Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsActive { get; }
public:
property bool IsActive {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DecimateAction Class
VisualComponents.UX.Shared Namespace


DecimateAction.Title Property

DecimateActionTitle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; }
public:
virtual property String^ Title {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionTitle
See Also

Reference

DecimateAction Class
VisualComponents.UX.Shared Namespace


DecimateAction Methods

The DecimateAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DecimateAction Class
VisualComponents.UX.Shared Namespace


DecimateAction.ApplyAction Method

DecimateActionApplyAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ApplyAction()
public:
virtual bool ApplyAction() sealed

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.DecimateAction.ApplyAction"]

Implements

ICommandPanelActionApplyAction
See Also

Reference

DecimateAction Class
VisualComponents.UX.Shared Namespace


DecimateAction.CancelAction Method

DecimateActionCancelAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CancelAction()
public:
virtual void CancelAction() sealed

Implements

ICommandPanelActionCancelAction
See Also

Reference

DecimateAction Class
VisualComponents.UX.Shared Namespace


DecimateAction.StartAction Method

DecimateActionStartAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    EventHandler<ResultCompletionEventArgs> completed = null
)
public:
virtual void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr
) sealed

Parameters

completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs

Implements

ICommandPanelActionStartAction(EventHandlerResultCompletionEventArgs)
See Also

Reference

DecimateAction Class
VisualComponents.UX.Shared Namespace


DelegateCommand Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedDelegateCommand

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class DelegateCommand : ICommand
public ref class DelegateCommand : ICommand

The DelegateCommand type exposes the following members.

Constructors
 | Name | Description
Public method | DelegateCommand(ActionObject) | Initializes a new instance of the DelegateCommand class
Public method | DelegateCommand(ActionObject, PredicateObject) | Initializes a new instance of the DelegateCommand class
Top
Methods
 | Name | Description
Public method | CanExecute |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RaiseCanExecuteChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CanExecuteChanged |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DelegateCommand Constructor

Overload List
 | Name | Description
Public method | DelegateCommand(ActionObject) | Initializes a new instance of the DelegateCommand class
Public method | DelegateCommand(ActionObject, PredicateObject) | Initializes a new instance of the DelegateCommand class
Top
See Also

Reference

DelegateCommand Class
VisualComponents.UX.Shared Namespace


DelegateCommand Constructor (Action(Object))

DelegateCommand Constructor (ActionObject)

Initializes a new instance of the DelegateCommand class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DelegateCommand(
    Action<Object> execute
)
public:
DelegateCommand(
    Action<Object^>^ execute
)

Parameters

execute
Type: SystemActionObject
See Also

Reference

DelegateCommand Class
DelegateCommand Overload
VisualComponents.UX.Shared Namespace


DelegateCommand Constructor (Action(Object), Predicate(Object))

DelegateCommand Constructor (ActionObject, PredicateObject)

Initializes a new instance of the DelegateCommand class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DelegateCommand(
    Action<Object> execute,
    Predicate<Object> canExecute
)
public:
DelegateCommand(
    Action<Object^>^ execute,
    Predicate<Object^>^ canExecute
)

Parameters

execute
Type: SystemActionObject
canExecute
Type: SystemPredicateObject
See Also

Reference

DelegateCommand Class
DelegateCommand Overload
VisualComponents.UX.Shared Namespace


DelegateCommand Methods

The DelegateCommand type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RaiseCanExecuteChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DelegateCommand Class
VisualComponents.UX.Shared Namespace


DelegateCommand.CanExecute Method

DelegateCommandCanExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanExecute(
    Object parameter
)
public:
virtual bool CanExecute(
    Object^ parameter
) sealed

Parameters

parameter
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.DelegateCommand.CanExecute(System.Object)"]

Implements

ICommandCanExecute(Object)
See Also

Reference

DelegateCommand Class
VisualComponents.UX.Shared Namespace


DelegateCommand.Execute Method

DelegateCommandExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    Object parameter
)
public:
virtual void Execute(
    Object^ parameter
) sealed

Parameters

parameter
Type: SystemObject

Implements

ICommandExecute(Object)
See Also

Reference

DelegateCommand Class
VisualComponents.UX.Shared Namespace


DelegateCommand.RaiseCanExecuteChanged Method

DelegateCommandRaiseCanExecuteChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RaiseCanExecuteChanged()
public:
void RaiseCanExecuteChanged()
See Also

Reference

DelegateCommand Class
VisualComponents.UX.Shared Namespace


DelegateCommand Events

The DelegateCommand type exposes the following members.

Events
 | Name | Description
Public event | CanExecuteChanged |
Top
See Also

Reference

DelegateCommand Class
VisualComponents.UX.Shared Namespace


DelegateCommand.CanExecuteChanged Event

DelegateCommandCanExecuteChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler CanExecuteChanged
public:
virtual  event EventHandler^ CanExecuteChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

ICommandCanExecuteChanged
See Also

Reference

DelegateCommand Class
VisualComponents.UX.Shared Namespace


DependencyObjectHelper Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedDependencyObjectHelper

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class DependencyObjectHelper
[ExtensionAttribute]
public ref class DependencyObjectHelper abstract sealed

The DependencyObjectHelper type exposes the following members.

Methods
Name | Description
FirstAncestorT |
LastAncestorT |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DependencyObjectHelper Methods

The DependencyObjectHelper type exposes the following members.

Methods
Name | Description
FirstAncestorT |
LastAncestorT |
Top
See Also

Reference

DependencyObjectHelper Class
VisualComponents.UX.Shared Namespace


DependencyObjectHelper.FirstAncestor(T) Method

DependencyObjectHelperFirstAncestorT Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static T FirstAncestor<T>(
    this DependencyObject source,
    Func<DependencyObject, bool> stop = null
)
where T : class

public:
[ExtensionAttribute]
generic<typename T>
where T : ref class
static T FirstAncestor(
    DependencyObject^ source,
    Func<DependencyObject^, bool>^ stop = nullptr
)

Parameters

source
Type: System.WindowsDependencyObject
stop (Optional)
Type: SystemFuncDependencyObject, Boolean

Type Parameters

T

Return Value

Type: T

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.DependencyObjectHelper.FirstAncestor``1(System.Windows.DependencyObject,System.Func{System.Windows.DependencyObject,System.Boolean})"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DependencyObject. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DependencyObjectHelper Class
VisualComponents.UX.Shared Namespace


DependencyObjectHelper.LastAncestor(T) Method

DependencyObjectHelperLastAncestorT Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static T LastAncestor<T>(
    this DependencyObject source,
    Func<DependencyObject, bool> stop = null
)
where T : class

public:
[ExtensionAttribute]
generic<typename T>
where T : ref class
static T LastAncestor(
    DependencyObject^ source,
    Func<DependencyObject^, bool>^ stop = nullptr
)

Parameters

source
Type: System.WindowsDependencyObject
stop (Optional)
Type: SystemFuncDependencyObject, Boolean

Type Parameters

T

Return Value

Type: T

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.DependencyObjectHelper.LastAncestor``1(System.Windows.DependencyObject,System.Func{System.Windows.DependencyObject,System.Boolean})"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DependencyObject. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DependencyObjectHelper Class
VisualComponents.UX.Shared Namespace


DesignTimeDictionary Class

Class includes resources at Design Time only
Inheritance Hierarchy
SystemObject
System.WindowsResourceDictionary
VisualComponents.UX.SharedDesignTimeDictionary

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class DesignTimeDictionary : ResourceDictionary
public ref class DesignTimeDictionary : public ResourceDictionary

The DesignTimeDictionary type exposes the following members.

Constructors
 | Name | Description
Public method | DesignTimeDictionary | Initializes a new instance of the DesignTimeDictionary class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of entries in the base ResourceDictionary. (Inherited from ResourceDictionary.)
Public property | DeferrableContent | Gets or sets the deferrable content for this resource dictionary. (Inherited from ResourceDictionary.)
Public property | InvalidatesImplicitDataTemplateResources | Gets or sets a value that indicates whether the invalidations fired by the ResourceDictionary object cause ContentPresenter objects to reevaluate their choice of template. The invalidations happen when an implicit data template resource changes. (Inherited from ResourceDictionary.)
Public property | IsFixedSize | Gets whether this ResourceDictionary is fixed-size. (Inherited from ResourceDictionary.)
Public property | IsInDesignMode |
Public property | IsReadOnly | Gets whether this ResourceDictionary is read-only. (Inherited from ResourceDictionary.)
Public property | Item | Gets or sets the value associated with the given key. (Inherited from ResourceDictionary.)
Public property | Keys | Gets a collection of all keys contained in this ResourceDictionary. (Inherited from ResourceDictionary.)
Public property | MergedDictionaries | Gets a collection of the ResourceDictionary dictionaries that constitute the various resource dictionaries in the merged dictionaries. (Inherited from ResourceDictionary.)
Public property | Source |
Public property | Values | Gets a collection of all values associated with keys contained in this ResourceDictionary. (Inherited from ResourceDictionary.)
Top
Methods
 | Name | Description
Public method | Add | Adds a resource by key to this ResourceDictionary. (Inherited from ResourceDictionary.)
Public method | BeginInit | Begins the initialization phase for this ResourceDictionary. (Inherited from ResourceDictionary.)
Public method | Clear | Clears all keys (and values) in the base ResourceDictionary. This does not clear any merged dictionary items. (Inherited from ResourceDictionary.)
Public method | Contains | Determines whether the ResourceDictionary contains an element with the specified key. (Inherited from ResourceDictionary.)
Public method | CopyTo | Copies the ResourceDictionary elements to a one-dimensional DictionaryEntry at the specified index. (Inherited from ResourceDictionary.)
Public method | EndInit | Ends the initialization phase, and invalidates the previous tree such that all changes made to keys during the initialization phase can be accounted for. (Inherited from ResourceDictionary.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Not supported by this Dictionary implementation. (Inherited from ResourceDictionary.)
Public method | GetEnumerator | Returns an IDictionaryEnumerator that can be used to iterate through the ResourceDictionary. (Inherited from ResourceDictionary.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnGettingValue | Occurs when the ResourceDictionary receives a request for a resource. (Inherited from ResourceDictionary.)
Public method | RegisterName | Not supported by this Dictionary implementation. (Inherited from ResourceDictionary.)
Public method | Remove | Removes the entry with the specified key from the base dictionary. (Inherited from ResourceDictionary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterName | Not supported by this Dictionary implementation. (Inherited from ResourceDictionary.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DesignTimeDictionary Constructor

Initializes a new instance of the DesignTimeDictionary class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DesignTimeDictionary()
public:
DesignTimeDictionary()
See Also

Reference

DesignTimeDictionary Class
VisualComponents.UX.Shared Namespace


DesignTimeDictionary Properties

The DesignTimeDictionary type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entries in the base ResourceDictionary. (Inherited from ResourceDictionary.)
Public property | DeferrableContent | Gets or sets the deferrable content for this resource dictionary. (Inherited from ResourceDictionary.)
Public property | InvalidatesImplicitDataTemplateResources | Gets or sets a value that indicates whether the invalidations fired by the ResourceDictionary object cause ContentPresenter objects to reevaluate their choice of template. The invalidations happen when an implicit data template resource changes. (Inherited from ResourceDictionary.)
Public property | IsFixedSize | Gets whether this ResourceDictionary is fixed-size. (Inherited from ResourceDictionary.)
Public property | IsInDesignMode |
Public property | IsReadOnly | Gets whether this ResourceDictionary is read-only. (Inherited from ResourceDictionary.)
Public property | Item | Gets or sets the value associated with the given key. (Inherited from ResourceDictionary.)
Public property | Keys | Gets a collection of all keys contained in this ResourceDictionary. (Inherited from ResourceDictionary.)
Public property | MergedDictionaries | Gets a collection of the ResourceDictionary dictionaries that constitute the various resource dictionaries in the merged dictionaries. (Inherited from ResourceDictionary.)
Public property | Source |
Public property | Values | Gets a collection of all values associated with keys contained in this ResourceDictionary. (Inherited from ResourceDictionary.)
Top
See Also

Reference

DesignTimeDictionary Class
VisualComponents.UX.Shared Namespace


DesignTimeDictionary.IsInDesignMode Property

DesignTimeDictionaryIsInDesignMode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsInDesignMode { get; }
public:
property bool IsInDesignMode {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DesignTimeDictionary Class
VisualComponents.UX.Shared Namespace


DesignTimeDictionary.Source Property

DesignTimeDictionarySource Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Uri Source { get; set; }
public:
property Uri^ Source {
    Uri^ get ();
    void set (Uri^ value);
}

Property Value

Type: Uri
See Also

Reference

DesignTimeDictionary Class
VisualComponents.UX.Shared Namespace


DesignTimeDictionary Methods

The DesignTimeDictionary type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a resource by key to this ResourceDictionary. (Inherited from ResourceDictionary.)
Public method | BeginInit | Begins the initialization phase for this ResourceDictionary. (Inherited from ResourceDictionary.)
Public method | Clear | Clears all keys (and values) in the base ResourceDictionary. This does not clear any merged dictionary items. (Inherited from ResourceDictionary.)
Public method | Contains | Determines whether the ResourceDictionary contains an element with the specified key. (Inherited from ResourceDictionary.)
Public method | CopyTo | Copies the ResourceDictionary elements to a one-dimensional DictionaryEntry at the specified index. (Inherited from ResourceDictionary.)
Public method | EndInit | Ends the initialization phase, and invalidates the previous tree such that all changes made to keys during the initialization phase can be accounted for. (Inherited from ResourceDictionary.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Not supported by this Dictionary implementation. (Inherited from ResourceDictionary.)
Public method | GetEnumerator | Returns an IDictionaryEnumerator that can be used to iterate through the ResourceDictionary. (Inherited from ResourceDictionary.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnGettingValue | Occurs when the ResourceDictionary receives a request for a resource. (Inherited from ResourceDictionary.)
Public method | RegisterName | Not supported by this Dictionary implementation. (Inherited from ResourceDictionary.)
Public method | Remove | Removes the entry with the specified key from the base dictionary. (Inherited from ResourceDictionary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterName | Not supported by this Dictionary implementation. (Inherited from ResourceDictionary.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DesignTimeDictionary Class
VisualComponents.UX.Shared Namespace


DesiredPaneLocation Enumeration

Specifies the desired location to dock the pane on the panel.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum DesiredPaneLocation
public enum class DesiredPaneLocation
Members
Member name | Value | Description
DockedLeft | 0 | Docks to the left of the panel.
DockedTop | 1 | Docks to the top of the panel.
DockedRight | 2 | Docks to the right of the panel.
DockedBottom | 3 | Docks to the bottom of the panel.
DockableFloating | 4 | Floats but can be docked anywhere.
FloatingOnly | 5 | Floats and is not allowed to dock.
See Also

Reference

VisualComponents.UX.Shared Namespace


DesiredSizeChangedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.UX.SharedDesiredSizeChangedEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class DesiredSizeChangedEventArgs : EventArgs
public ref class DesiredSizeChangedEventArgs : public EventArgs

The DesiredSizeChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DesiredSizeChangedEventArgs | Initializes a new instance of the DesiredSizeChangedEventArgs class
Top
Properties
 | Name | Description
Public property | NewSize |
Public property | OldSize |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DesiredSizeChangedEventArgs Constructor

Initializes a new instance of the DesiredSizeChangedEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DesiredSizeChangedEventArgs(
    Size oldSize,
    Size newSize
)
public:
DesiredSizeChangedEventArgs(
    Size oldSize,
    Size newSize
)

Parameters

oldSize
Type: System.WindowsSize
newSize
Type: System.WindowsSize
See Also

Reference

DesiredSizeChangedEventArgs Class
VisualComponents.UX.Shared Namespace


DesiredSizeChangedEventArgs Properties

The DesiredSizeChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewSize |
Public property | OldSize |
Top
See Also

Reference

DesiredSizeChangedEventArgs Class
VisualComponents.UX.Shared Namespace


DesiredSizeChangedEventArgs.NewSize Property

DesiredSizeChangedEventArgsNewSize Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Size NewSize { get; }
public:
property Size NewSize {
    Size get ();
}

Property Value

Type: Size
See Also

Reference

DesiredSizeChangedEventArgs Class
VisualComponents.UX.Shared Namespace


DesiredSizeChangedEventArgs.OldSize Property

DesiredSizeChangedEventArgsOldSize Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Size OldSize { get; }
public:
property Size OldSize {
    Size get ();
}

Property Value

Type: Size
See Also

Reference

DesiredSizeChangedEventArgs Class
VisualComponents.UX.Shared Namespace


DesiredSizeChangedEventArgs Methods

The DesiredSizeChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DesiredSizeChangedEventArgs Class
VisualComponents.UX.Shared Namespace


DialogType Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum DialogType
public enum class DialogType
Members
Member name | Value | Description
Open | 0 |
Save | 1 |
See Also

Reference

VisualComponents.UX.Shared Namespace


DimensionManipulateAction Class

Dimension Manipulate Action
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedFixedPropertyContainer
VisualComponents.UX.SharedDimensionManipulateAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class DimensionManipulateAction : FixedPropertyContainer,
    IActionResult, IResult, IPropertyContainer, IBatchModeObject, IHandle<DimensionManipulateMessage>,
    IHandle
public ref class DimensionManipulateAction sealed : public FixedPropertyContainer,
    IActionResult, IResult, IPropertyContainer, IBatchModeObject, IHandle<DimensionManipulateMessage^>,
    IHandle

The DimensionManipulateAction type exposes the following members.

Constructors
 | Name | Description
Public method | DimensionManipulateAction | Initializes a new instance of the DimensionManipulateAction class
Top
Properties
 | Name | Description
Public property | ChangeBatchLevel | (Inherited from FixedPropertyContainer.)
Public property | ContainerExpressionContext | (Inherited from FixedPropertyContainer.)
Public property | Dimension |
 | IsActive |
Public property | Properties | get properties (Inherited from FixedPropertyContainer.)
Public property | PropertyNames | (Inherited from FixedPropertyContainer.)
Public property | PropertyNamesAndValues | (Inherited from FixedPropertyContainer.)
Public property | PropertyValues | (Inherited from FixedPropertyContainer.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType) | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from FixedPropertyContainer.)
Public method | DeleteProperty | (Inherited from FixedPropertyContainer.)
Public method | EndChangeBatch | (Inherited from FixedPropertyContainer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperty | (Inherited from FixedPropertyContainer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle |
 | Manipulate |
Public method | NotifyPropertyChanged | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Completed |
Public event | PropertyChanged | (Inherited from FixedPropertyContainer.)
Public event | PropertyContainerChanged | (Inherited from FixedPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DimensionManipulateAction Constructor

Initializes a new instance of the DimensionManipulateAction class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DimensionManipulateAction()
public:
DimensionManipulateAction()
See Also

Reference

DimensionManipulateAction Class
VisualComponents.UX.Shared Namespace


DimensionManipulateAction Properties

The DimensionManipulateAction type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | (Inherited from FixedPropertyContainer.)
Public property | ContainerExpressionContext | (Inherited from FixedPropertyContainer.)
Public property | Dimension |
 | IsActive |
Public property | Properties | get properties (Inherited from FixedPropertyContainer.)
Public property | PropertyNames | (Inherited from FixedPropertyContainer.)
Public property | PropertyNamesAndValues | (Inherited from FixedPropertyContainer.)
Public property | PropertyValues | (Inherited from FixedPropertyContainer.)
Top
See Also

Reference

DimensionManipulateAction Class
VisualComponents.UX.Shared Namespace


DimensionManipulateAction.Dimension Property

DimensionManipulateActionDimension Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IDimension Dimension { get; set; }
public:
property IDimension^ Dimension {
    IDimension^ get ();
    void set (IDimension^ value);
}

Property Value

Type: IDimension
See Also

Reference

DimensionManipulateAction Class
VisualComponents.UX.Shared Namespace


DimensionManipulateAction.IsActive Property

DimensionManipulateActionIsActive Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsActive { get; }
public:
static property bool IsActive {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DimensionManipulateAction Class
VisualComponents.UX.Shared Namespace


DimensionManipulateAction Methods

The DimensionManipulateAction type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType) | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from FixedPropertyContainer.)
Public method | DeleteProperty | (Inherited from FixedPropertyContainer.)
Public method | EndChangeBatch | (Inherited from FixedPropertyContainer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperty | (Inherited from FixedPropertyContainer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle |
 | Manipulate |
Public method | NotifyPropertyChanged | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DimensionManipulateAction Class
VisualComponents.UX.Shared Namespace


DimensionManipulateAction.Execute Method

DimensionManipulateActionExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    ActionExecutionContext context
)
public:
virtual void Execute(
    ActionExecutionContext^ context
) sealed

Parameters

context
Type: ActionExecutionContext

Implements

IResult.Execute(ActionExecutionContext)
See Also

Reference

DimensionManipulateAction Class
VisualComponents.UX.Shared Namespace


DimensionManipulateAction.Handle Method

DimensionManipulateActionHandle Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    DimensionManipulateMessage message
)
public:
virtual void Handle(
    DimensionManipulateMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedDimensionManipulateMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

DimensionManipulateAction Class
VisualComponents.UX.Shared Namespace


DimensionManipulateAction.Manipulate Method

DimensionManipulateActionManipulate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IEnumerable<IResult> Manipulate()
public:
static IEnumerable<IResult^>^ Manipulate()

Return Value

Type: IEnumerableIResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.DimensionManipulateAction.Manipulate"]

See Also

Reference

DimensionManipulateAction Class
VisualComponents.UX.Shared Namespace


DimensionManipulateAction Events

The DimensionManipulateAction type exposes the following members.

Events
 | Name | Description
Public event | Completed |
Public event | PropertyChanged | (Inherited from FixedPropertyContainer.)
Public event | PropertyContainerChanged | (Inherited from FixedPropertyContainer.)
Top
See Also

Reference

DimensionManipulateAction Class
VisualComponents.UX.Shared Namespace


DimensionManipulateAction.Completed Event

DimensionManipulateActionCompleted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ResultCompletionEventArgs> Completed
public:
virtual  event EventHandler<ResultCompletionEventArgs^>^ Completed {
    void add (EventHandler<ResultCompletionEventArgs^>^ value);
    void remove (EventHandler<ResultCompletionEventArgs^>^ value);
}

Value

Type: SystemEventHandlerResultCompletionEventArgs

Implements

IResult.Completed
See Also

Reference

DimensionManipulateAction Class
VisualComponents.UX.Shared Namespace


DimensionManipulateMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedDimensionManipulateMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class DimensionManipulateMessage
public ref class DimensionManipulateMessage

The DimensionManipulateMessage type exposes the following members.

Constructors
 | Name | Description
Public method | DimensionManipulateMessage | Initializes a new instance of the DimensionManipulateMessage class
Top
Properties
 | Name | Description
Public property | Continue |
Public property | CurrentPoint |
Public property | Dimension |
Public property | LastPoint |
Public property | Part |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DimensionManipulateMessage Constructor

Initializes a new instance of the DimensionManipulateMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DimensionManipulateMessage()
public:
DimensionManipulateMessage()
See Also

Reference

DimensionManipulateMessage Class
VisualComponents.UX.Shared Namespace


DimensionManipulateMessage Properties

The DimensionManipulateMessage type exposes the following members.

Properties
 | Name | Description
Public property | Continue |
Public property | CurrentPoint |
Public property | Dimension |
Public property | LastPoint |
Public property | Part |
Top
See Also

Reference

DimensionManipulateMessage Class
VisualComponents.UX.Shared Namespace


DimensionManipulateMessage.Continue Property

DimensionManipulateMessageContinue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Continue { get; set; }
public:
property bool Continue {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DimensionManipulateMessage Class
VisualComponents.UX.Shared Namespace


DimensionManipulateMessage.CurrentPoint Property

DimensionManipulateMessageCurrentPoint Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Point CurrentPoint { get; set; }
public:
property Point CurrentPoint {
    Point get ();
    void set (Point value);
}

Property Value

Type: Point
See Also

Reference

DimensionManipulateMessage Class
VisualComponents.UX.Shared Namespace


DimensionManipulateMessage.Dimension Property

DimensionManipulateMessageDimension Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IDimension Dimension { get; set; }
public:
property IDimension^ Dimension {
    IDimension^ get ();
    void set (IDimension^ value);
}

Property Value

Type: IDimension
See Also

Reference

DimensionManipulateMessage Class
VisualComponents.UX.Shared Namespace


DimensionManipulateMessage.LastPoint Property

DimensionManipulateMessageLastPoint Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Point LastPoint { get; set; }
public:
property Point LastPoint {
    Point get ();
    void set (Point value);
}

Property Value

Type: Point
See Also

Reference

DimensionManipulateMessage Class
VisualComponents.UX.Shared Namespace


DimensionManipulateMessage.Part Property

DimensionManipulateMessagePart Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DimensionPart Part { get; set; }
public:
property DimensionPart Part {
    DimensionPart get ();
    void set (DimensionPart value);
}

Property Value

Type: DimensionPart
See Also

Reference

DimensionManipulateMessage Class
VisualComponents.UX.Shared Namespace


DimensionManipulateMessage Methods

The DimensionManipulateMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DimensionManipulateMessage Class
VisualComponents.UX.Shared Namespace


DimensionPart Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum DimensionPart
public enum class DimensionPart
Members
Member name | Value | Description
Left | 0 |
Right | 1 |
Center | 2 |
LeftLine | 3 |
RightLine | 4 |
CenterLine | 5 |
See Also

Reference

VisualComponents.UX.Shared Namespace


Direct3DToolBar Class

Interaction logic for Direct3DToolBar.xaml
Direct3DToolBar
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedDirect3DToolBar

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class Direct3DToolBar : UserControl,
    INotifyPropertyChanged, IHandle<ApplicationContextChangedMessage>, IHandle, IHandle<FullScreenModeStatusMessage>,
    IComponentConnector
public ref class Direct3DToolBar : public UserControl,
    INotifyPropertyChanged, IHandle<ApplicationContextChangedMessage^>, IHandle, IHandle<FullScreenModeStatusMessage^>,
    IComponentConnector

The Direct3DToolBar type exposes the following members.

Constructors
 | Name | Description
Public method | Direct3DToolBar | Initializes a new instance of the Direct3DToolBar class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContainerHeight |
Public property | ContainerWidth |
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DistanceBasedOpacity |
Public property | EditMenuItems |
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | ReverseDpiScale |
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XPosition |
Public property | YPosition |
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Handle(ApplicationContextChangedMessage) |
Public method | Handle(FullScreenModeStatusMessage) |
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | Init |
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Public method | OnViewportClosed |
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Set3DToolbarVisibility |
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateDirect3DtoolBarLocation |
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PropertyChanged |
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
 | Name | Description
Protected field | _appcontext |
Protected field | _commandRegistry |
Protected field | _uxConfig |
 | ContainerHeightProperty |
 | ContainerWidthProperty |
 | DistanceBasedOpacityProperty |
 | EditMenuItemsProperty |
 | ReverseDpiScaleProperty |
 | XPositionProperty |
 | YPositionProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


Direct3DToolBar Constructor

Initializes a new instance of the Direct3DToolBar class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Direct3DToolBar()
public:
Direct3DToolBar()
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBar Properties

The Direct3DToolBar type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContainerHeight |
Public property | ContainerWidth |
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DistanceBasedOpacity |
Public property | EditMenuItems |
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | ReverseDpiScale |
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XPosition |
Public property | YPosition |
Top
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBar.ContainerHeight Property

Direct3DToolBarContainerHeight Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double ContainerHeight { get; set; }
public:
property double ContainerHeight {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBar.ContainerWidth Property

Direct3DToolBarContainerWidth Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double ContainerWidth { get; set; }
public:
property double ContainerWidth {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBar.DistanceBasedOpacity Property

Direct3DToolBarDistanceBasedOpacity Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double DistanceBasedOpacity { get; set; }
public:
property double DistanceBasedOpacity {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBar.EditMenuItems Property

Direct3DToolBarEditMenuItems Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObservableCollectionEx<IActionItem> EditMenuItems { get; set; }
public:
property ObservableCollectionEx<IActionItem^>^ EditMenuItems {
    ObservableCollectionEx<IActionItem^>^ get ();
    void set (ObservableCollectionEx<IActionItem^>^ value);
}

Property Value

Type: ObservableCollectionEx IActionItem
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBar.ReverseDpiScale Property

Direct3DToolBarReverseDpiScale Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double ReverseDpiScale { get; set; }
public:
property double ReverseDpiScale {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBar.XPosition Property

Direct3DToolBarXPosition Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double XPosition { get; set; }
public:
property double XPosition {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBar.YPosition Property

Direct3DToolBarYPosition Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double YPosition { get; set; }
public:
property double YPosition {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBar Methods

The Direct3DToolBar type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Handle(ApplicationContextChangedMessage) |
Public method | Handle(FullScreenModeStatusMessage) |
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | Init |
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Public method | OnViewportClosed |
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | Set3DToolbarVisibility |
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateDirect3DtoolBarLocation |
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBar.Handle Method

Direct3DToolBarHandle Method

Overload List
 | Name | Description
Public method | Handle(ApplicationContextChangedMessage) |
Public method | Handle(FullScreenModeStatusMessage) |
Top
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBar.Handle Method (ApplicationContextChangedMessage)

Direct3DToolBarHandle Method (ApplicationContextChangedMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    ApplicationContextChangedMessage message
)
public:
virtual void Handle(
    ApplicationContextChangedMessage^ message
) sealed

Parameters

message
Type: VisualComponents.Create3DApplicationContextChangedMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

Direct3DToolBar Class
Handle Overload
VisualComponents.UX.Shared Namespace


Direct3DToolBar.Handle Method (FullScreenModeStatusMessage)

Direct3DToolBarHandle Method (FullScreenModeStatusMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    FullScreenModeStatusMessage message
)
public:
virtual void Handle(
    FullScreenModeStatusMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedFullScreenModeStatusMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

Direct3DToolBar Class
Handle Overload
VisualComponents.UX.Shared Namespace


Direct3DToolBar.Init Method

Direct3DToolBarInit Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Init()
public:
void Init()
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBar.InitializeComponent Method

Direct3DToolBarInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBar.OnViewportClosed Method

Direct3DToolBarOnViewportClosed Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void OnViewportClosed()
public:
void OnViewportClosed()
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBar.Set3DToolbarVisibility Method

Direct3DToolBarSet3DToolbarVisibility Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Set3DToolbarVisibility()
public:
void Set3DToolbarVisibility()
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBar.UpdateDirect3DtoolBarLocation Method

Direct3DToolBarUpdateDirect3DtoolBarLocation Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void UpdateDirect3DtoolBarLocation()
public:
void UpdateDirect3DtoolBarLocation()
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBar Events

The Direct3DToolBar type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PropertyChanged |
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBar.PropertyChanged Event

Direct3DToolBarPropertyChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event PropertyChangedEventHandler PropertyChanged
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBar Fields

The Direct3DToolBar type exposes the following members.

Fields
 | Name | Description
Protected field | _appcontext |
Protected field | _commandRegistry |
Protected field | _uxConfig |
 | ContainerHeightProperty |
 | ContainerWidthProperty |
 | DistanceBasedOpacityProperty |
 | EditMenuItemsProperty |
 | ReverseDpiScaleProperty |
 | XPositionProperty |
 | YPositionProperty |
Top
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBar._appcontext Field

Direct3DToolBar_appcontext Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected readonly IApplicationContext _appcontext
protected:
initonly IApplicationContext^ _appcontext

Field Value

Type: IApplicationContext
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBar._commandRegistry Field

Direct3DToolBar_commandRegistry Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected readonly ICommandRegistry _commandRegistry
protected:
initonly ICommandRegistry^ _commandRegistry

Field Value

Type: ICommandRegistry
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBar._uxConfig Field

Direct3DToolBar_uxConfig Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected readonly IUXConfiguration _uxConfig
protected:
initonly IUXConfiguration^ _uxConfig

Field Value

Type: IUXConfiguration
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBar.ContainerHeightProperty Field

Direct3DToolBarContainerHeightProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ContainerHeightProperty
public:
static initonly DependencyProperty^ ContainerHeightProperty

Field Value

Type: DependencyProperty
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBar.ContainerWidthProperty Field

Direct3DToolBarContainerWidthProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ContainerWidthProperty
public:
static initonly DependencyProperty^ ContainerWidthProperty

Field Value

Type: DependencyProperty
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBar.DistanceBasedOpacityProperty Field

Direct3DToolBarDistanceBasedOpacityProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty DistanceBasedOpacityProperty
public:
static initonly DependencyProperty^ DistanceBasedOpacityProperty

Field Value

Type: DependencyProperty
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBar.EditMenuItemsProperty Field

Direct3DToolBarEditMenuItemsProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty EditMenuItemsProperty
public:
static initonly DependencyProperty^ EditMenuItemsProperty

Field Value

Type: DependencyProperty
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBar.ReverseDpiScaleProperty Field

Direct3DToolBarReverseDpiScaleProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ReverseDpiScaleProperty
public:
static initonly DependencyProperty^ ReverseDpiScaleProperty

Field Value

Type: DependencyProperty
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBar.XPositionProperty Field

Direct3DToolBarXPositionProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty XPositionProperty
public:
static initonly DependencyProperty^ XPositionProperty

Field Value

Type: DependencyProperty
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBar.YPositionProperty Field

Direct3DToolBarYPositionProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty YPositionProperty
public:
static initonly DependencyProperty^ YPositionProperty

Field Value

Type: DependencyProperty
See Also

Reference

Direct3DToolBar Class
VisualComponents.UX.Shared Namespace


Direct3DToolBarActionItemDataTemplateSelector Class

This DataTemplateSelector is responsible for resolving template for ribbon Commands.
Inheritance Hierarchy
SystemObject
System.Windows.ControlsDataTemplateSelector
VisualComponents.UX.SharedDirect3DToolBarActionItemDataTemplateSelector

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class Direct3DToolBarActionItemDataTemplateSelector : DataTemplateSelector
public ref class Direct3DToolBarActionItemDataTemplateSelector sealed : public DataTemplateSelector

The Direct3DToolBarActionItemDataTemplateSelector type exposes the following members.

Constructors
 | Name | Description
Public method | Direct3DToolBarActionItemDataTemplateSelector | Initializes a new instance of the Direct3DToolBarActionItemDataTemplateSelector class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SelectTemplate | (Overrides DataTemplateSelectorSelectTemplate(Object, DependencyObject).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


Direct3DToolBarActionItemDataTemplateSelector Constructor

Initializes a new instance of the Direct3DToolBarActionItemDataTemplateSelector class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Direct3DToolBarActionItemDataTemplateSelector()
public:
Direct3DToolBarActionItemDataTemplateSelector()
See Also

Reference

Direct3DToolBarActionItemDataTemplateSelector Class
VisualComponents.UX.Shared Namespace


Direct3DToolBarActionItemDataTemplateSelector Methods

The Direct3DToolBarActionItemDataTemplateSelector type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SelectTemplate | (Overrides DataTemplateSelectorSelectTemplate(Object, DependencyObject).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

Direct3DToolBarActionItemDataTemplateSelector Class
VisualComponents.UX.Shared Namespace


Direct3DToolBarActionItemDataTemplateSelector.SelectTemplate Method

Direct3DToolBarActionItemDataTemplateSelectorSelectTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override DataTemplate SelectTemplate(
    Object item,
    DependencyObject container
)
public:
virtual DataTemplate^ SelectTemplate(
    Object^ item,
    DependencyObject^ container
) override

Parameters

item
Type: SystemObject
container
Type: System.WindowsDependencyObject

Return Value

Type: DataTemplate

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Direct3DToolBarActionItemDataTemplateSelector.SelectTemplate(System.Object,System.Windows.DependencyObject)"]

See Also

Reference

Direct3DToolBarActionItemDataTemplateSelector Class
VisualComponents.UX.Shared Namespace


DisabledRenderingScope Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedDisabledRenderingScope

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class DisabledRenderingScope : IDisposable
public ref class DisabledRenderingScope : IDisposable

The DisabledRenderingScope type exposes the following members.

Constructors
 | Name | Description
Public method | DisabledRenderingScope | Initializes a new instance of the DisabledRenderingScope class
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the DisabledRenderingScope
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DisabledRenderingScope Constructor

Initializes a new instance of the DisabledRenderingScope class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DisabledRenderingScope()
public:
DisabledRenderingScope()
See Also

Reference

DisabledRenderingScope Class
VisualComponents.UX.Shared Namespace


DisabledRenderingScope Methods

The DisabledRenderingScope type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DisabledRenderingScope Class
VisualComponents.UX.Shared Namespace


DisabledRenderingScope.Dispose Method

DisabledRenderingScopeDispose Method

Releases all resources used by the DisabledRenderingScope

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Dispose()
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

DisabledRenderingScope Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
VisualComponents.UX.SharedDistanceBasedOpacityContainer

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class DistanceBasedOpacityContainer : ContentControl
public ref class DistanceBasedOpacityContainer : public ContentControl

The DistanceBasedOpacityContainer type exposes the following members.

Constructors
 | Name | Description
Public method | DistanceBasedOpacityContainer | Initializes a new instance of the DistanceBasedOpacityContainer class
Top
Properties
 | Name | Description
Public property | ActiveOpacityLevel |
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanDetectAfterMouseLeave |
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ComputedOpacity |
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentBindingProxy |
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | ControlOpacity |
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DistanceStep |
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOverContent |
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStepDetectionActive |
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityLevels |
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | StepRadius |
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | (Overrides UIElementOnMouseEnter(MouseEventArgs).)
Protected method | OnMouseLeave | (Overrides UIElementOnMouseLeave(MouseEventArgs).)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ActiveOpacityLevelChanged |
Public event | ComputedOpacityChanged |
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsMouseOverContentChanged |
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
ActiveOpacityLevelProperty |
ActiveOpacityLevelPropertyKey |
CanDetectAfterMouseLeaveProperty |
ComputedOpacityProperty |
ComputedOpacityPropertyKey |
ControlOpacityProperty |
DistanceStepProperty |
IsMouseOverContentProperty |
IsStepDetectionActiveProperty |
IsStepDetectionActivePropertyKey |
OpacityLevelsProperty |
StepRadiusProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer Constructor

Initializes a new instance of the DistanceBasedOpacityContainer class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DistanceBasedOpacityContainer()
public:
DistanceBasedOpacityContainer()
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer Properties

The DistanceBasedOpacityContainer type exposes the following members.

Properties
 | Name | Description
Public property | ActiveOpacityLevel |
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanDetectAfterMouseLeave |
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ComputedOpacity |
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentBindingProxy |
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | ControlOpacity |
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DistanceStep |
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOverContent |
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStepDetectionActive |
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityLevels |
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | StepRadius |
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer.ActiveOpacityLevel Property

DistanceBasedOpacityContainerActiveOpacityLevel Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ActiveOpacityLevel { get; }
public:
property int ActiveOpacityLevel {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer.CanDetectAfterMouseLeave Property

DistanceBasedOpacityContainerCanDetectAfterMouseLeave Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanDetectAfterMouseLeave { get; set; }
public:
property bool CanDetectAfterMouseLeave {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer.ComputedOpacity Property

DistanceBasedOpacityContainerComputedOpacity Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double ComputedOpacity { get; }
public:
property double ComputedOpacity {
    double get ();
}

Property Value

Type: Double
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer.ContentBindingProxy Property

DistanceBasedOpacityContainerContentBindingProxy Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Border ContentBindingProxy { get; }
public:
property Border^ ContentBindingProxy {
    Border^ get ();
}

Property Value

Type: Border
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer.ControlOpacity Property

DistanceBasedOpacityContainerControlOpacity Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ControlOpacity { get; set; }
public:
property bool ControlOpacity {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer.DistanceStep Property

DistanceBasedOpacityContainerDistanceStep Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Thickness DistanceStep { get; set; }
public:
property Thickness DistanceStep {
    Thickness get ();
    void set (Thickness value);
}

Property Value

Type: Thickness
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer.IsMouseOverContent Property

DistanceBasedOpacityContainerIsMouseOverContent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsMouseOverContent { get; set; }
public:
property bool IsMouseOverContent {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer.IsStepDetectionActive Property

DistanceBasedOpacityContainerIsStepDetectionActive Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsStepDetectionActive { get; }
public:
property bool IsStepDetectionActive {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer.OpacityLevels Property

DistanceBasedOpacityContainerOpacityLevels Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int OpacityLevels { get; set; }
public:
property int OpacityLevels {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer.StepRadius Property

DistanceBasedOpacityContainerStepRadius Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CornerRadius StepRadius { get; set; }
public:
property CornerRadius StepRadius {
    CornerRadius get ();
    void set (CornerRadius value);
}

Property Value

Type: CornerRadius
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer Methods

The DistanceBasedOpacityContainer type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | (Overrides UIElementOnMouseEnter(MouseEventArgs).)
Protected method | OnMouseLeave | (Overrides UIElementOnMouseLeave(MouseEventArgs).)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer.OnApplyTemplate Method

DistanceBasedOpacityContainerOnApplyTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer.OnMouseEnter Method

DistanceBasedOpacityContainerOnMouseEnter Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnMouseEnter(
    MouseEventArgs e
)
protected:
virtual void OnMouseEnter(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputMouseEventArgs
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer.OnMouseLeave Method

DistanceBasedOpacityContainerOnMouseLeave Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnMouseLeave(
    MouseEventArgs e
)
protected:
virtual void OnMouseLeave(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputMouseEventArgs
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer Events

The DistanceBasedOpacityContainer type exposes the following members.

Events
 | Name | Description
Public event | ActiveOpacityLevelChanged |
Public event | ComputedOpacityChanged |
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsMouseOverContentChanged |
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer.ActiveOpacityLevelChanged Event

DistanceBasedOpacityContainerActiveOpacityLevelChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<DependencyPropertyChangedEventArgs> ActiveOpacityLevelChanged
public:
 event EventHandler<DependencyPropertyChangedEventArgs>^ ActiveOpacityLevelChanged {
    void add (EventHandler<DependencyPropertyChangedEventArgs>^ value);
    void remove (EventHandler<DependencyPropertyChangedEventArgs>^ value);
}

Value

Type: SystemEventHandlerDependencyPropertyChangedEventArgs
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer.ComputedOpacityChanged Event

DistanceBasedOpacityContainerComputedOpacityChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<DependencyPropertyChangedEventArgs> ComputedOpacityChanged
public:
 event EventHandler<DependencyPropertyChangedEventArgs>^ ComputedOpacityChanged {
    void add (EventHandler<DependencyPropertyChangedEventArgs>^ value);
    void remove (EventHandler<DependencyPropertyChangedEventArgs>^ value);
}

Value

Type: SystemEventHandlerDependencyPropertyChangedEventArgs
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer.IsMouseOverContentChanged Event

DistanceBasedOpacityContainerIsMouseOverContentChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<DependencyPropertyChangedEventArgs> IsMouseOverContentChanged
public:
 event EventHandler<DependencyPropertyChangedEventArgs>^ IsMouseOverContentChanged {
    void add (EventHandler<DependencyPropertyChangedEventArgs>^ value);
    void remove (EventHandler<DependencyPropertyChangedEventArgs>^ value);
}

Value

Type: SystemEventHandlerDependencyPropertyChangedEventArgs
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer Fields

The DistanceBasedOpacityContainer type exposes the following members.

Fields
Name | Description
ActiveOpacityLevelProperty |
ActiveOpacityLevelPropertyKey |
CanDetectAfterMouseLeaveProperty |
ComputedOpacityProperty |
ComputedOpacityPropertyKey |
ControlOpacityProperty |
DistanceStepProperty |
IsMouseOverContentProperty |
IsStepDetectionActiveProperty |
IsStepDetectionActivePropertyKey |
OpacityLevelsProperty |
StepRadiusProperty |
Top
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer.ActiveOpacityLevelProperty Field

DistanceBasedOpacityContainerActiveOpacityLevelProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ActiveOpacityLevelProperty
public:
static initonly DependencyProperty^ ActiveOpacityLevelProperty

Field Value

Type: DependencyProperty
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer.ActiveOpacityLevelPropertyKey Field

DistanceBasedOpacityContainerActiveOpacityLevelPropertyKey Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyPropertyKey ActiveOpacityLevelPropertyKey
public:
static initonly DependencyPropertyKey^ ActiveOpacityLevelPropertyKey

Field Value

Type: DependencyPropertyKey
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer.CanDetectAfterMouseLeaveProperty Field

DistanceBasedOpacityContainerCanDetectAfterMouseLeaveProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty CanDetectAfterMouseLeaveProperty
public:
static initonly DependencyProperty^ CanDetectAfterMouseLeaveProperty

Field Value

Type: DependencyProperty
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer.ComputedOpacityProperty Field

DistanceBasedOpacityContainerComputedOpacityProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ComputedOpacityProperty
public:
static initonly DependencyProperty^ ComputedOpacityProperty

Field Value

Type: DependencyProperty
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer.ComputedOpacityPropertyKey Field

DistanceBasedOpacityContainerComputedOpacityPropertyKey Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyPropertyKey ComputedOpacityPropertyKey
public:
static initonly DependencyPropertyKey^ ComputedOpacityPropertyKey

Field Value

Type: DependencyPropertyKey
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer.ControlOpacityProperty Field

DistanceBasedOpacityContainerControlOpacityProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ControlOpacityProperty
public:
static initonly DependencyProperty^ ControlOpacityProperty

Field Value

Type: DependencyProperty
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer.DistanceStepProperty Field

DistanceBasedOpacityContainerDistanceStepProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty DistanceStepProperty
public:
static initonly DependencyProperty^ DistanceStepProperty

Field Value

Type: DependencyProperty
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer.IsMouseOverContentProperty Field

DistanceBasedOpacityContainerIsMouseOverContentProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsMouseOverContentProperty
public:
static initonly DependencyProperty^ IsMouseOverContentProperty

Field Value

Type: DependencyProperty
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer.IsStepDetectionActiveProperty Field

DistanceBasedOpacityContainerIsStepDetectionActiveProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsStepDetectionActiveProperty
public:
static initonly DependencyProperty^ IsStepDetectionActiveProperty

Field Value

Type: DependencyProperty
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer.IsStepDetectionActivePropertyKey Field

DistanceBasedOpacityContainerIsStepDetectionActivePropertyKey Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyPropertyKey IsStepDetectionActivePropertyKey
public:
static initonly DependencyPropertyKey^ IsStepDetectionActivePropertyKey

Field Value

Type: DependencyPropertyKey
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer.OpacityLevelsProperty Field

DistanceBasedOpacityContainerOpacityLevelsProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty OpacityLevelsProperty
public:
static initonly DependencyProperty^ OpacityLevelsProperty

Field Value

Type: DependencyProperty
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistanceBasedOpacityContainer.StepRadiusProperty Field

DistanceBasedOpacityContainerStepRadiusProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty StepRadiusProperty
public:
static initonly DependencyProperty^ StepRadiusProperty

Field Value

Type: DependencyProperty
See Also

Reference

DistanceBasedOpacityContainer Class
VisualComponents.UX.Shared Namespace


DistributionEditor Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
VisualComponents.UX.SharedDistributionEditor

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class DistributionEditor : Control,
    INotifyPropertyChanged
public ref class DistributionEditor : public Control,
    INotifyPropertyChanged

The DistributionEditor type exposes the following members.

Constructors
 | Name | Description
Public method | DistributionEditor | Initializes a new instance of the DistributionEditor class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsReadOnly |
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | Property |
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text |
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | OpenLookupDialog |
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | RaisePropertyChanged |
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PropertyChanged |
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
IsReadOnlyProperty |
PropertyProperty |
TextProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DistributionEditor Constructor

Initializes a new instance of the DistributionEditor class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DistributionEditor()
public:
DistributionEditor()
See Also

Reference

DistributionEditor Class
VisualComponents.UX.Shared Namespace


DistributionEditor Properties

The DistributionEditor type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsReadOnly |
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | Property |
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text |
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DistributionEditor Class
VisualComponents.UX.Shared Namespace


DistributionEditor.IsReadOnly Property

DistributionEditorIsReadOnly Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsReadOnly { get; set; }
public:
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DistributionEditor Class
VisualComponents.UX.Shared Namespace


DistributionEditor.Property Property

DistributionEditorProperty Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Property { get; set; }
public:
property Object^ Property {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

DistributionEditor Class
VisualComponents.UX.Shared Namespace


DistributionEditor.Text Property

DistributionEditorText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Text { get; set; }
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DistributionEditor Class
VisualComponents.UX.Shared Namespace


DistributionEditor Methods

The DistributionEditor type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | OpenLookupDialog |
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | RaisePropertyChanged |
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DistributionEditor Class
VisualComponents.UX.Shared Namespace


DistributionEditor.OnApplyTemplate Method

DistributionEditorOnApplyTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

DistributionEditor Class
VisualComponents.UX.Shared Namespace


DistributionEditor.OpenLookupDialog Method

DistributionEditorOpenLookupDialog Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<IResult> OpenLookupDialog(
    IProperty prop,
    Bindable bindable = null
)
public:
IEnumerable<IResult^>^ OpenLookupDialog(
    IProperty^ prop,
    Bindable^ bindable = nullptr
)

Parameters

prop
Type: VisualComponents.Create3DIProperty
bindable (Optional)
Type: VisualComponents.UX.SharedBindable

Return Value

Type: IEnumerableIResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.DistributionEditor.OpenLookupDialog(VisualComponents.Create3D.IProperty,VisualComponents.UX.Shared.Bindable)"]

See Also

Reference

DistributionEditor Class
VisualComponents.UX.Shared Namespace


DistributionEditor.RaisePropertyChanged Method

DistributionEditorRaisePropertyChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RaisePropertyChanged(
    string PropertyName
)
public:
void RaisePropertyChanged(
    String^ PropertyName
)

Parameters

PropertyName
Type: SystemString
See Also

Reference

DistributionEditor Class
VisualComponents.UX.Shared Namespace


DistributionEditor Events

The DistributionEditor type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PropertyChanged |
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

DistributionEditor Class
VisualComponents.UX.Shared Namespace


DistributionEditor.PropertyChanged Event

DistributionEditorPropertyChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event PropertyChangedEventHandler PropertyChanged
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

DistributionEditor Class
VisualComponents.UX.Shared Namespace


DistributionEditor Fields

The DistributionEditor type exposes the following members.

Fields
Name | Description
IsReadOnlyProperty |
PropertyProperty |
TextProperty |
Top
See Also

Reference

DistributionEditor Class
VisualComponents.UX.Shared Namespace


DistributionEditor.IsReadOnlyProperty Field

DistributionEditorIsReadOnlyProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty IsReadOnlyProperty
public:
static DependencyProperty^ IsReadOnlyProperty

Field Value

Type: DependencyProperty
See Also

Reference

DistributionEditor Class
VisualComponents.UX.Shared Namespace


DistributionEditor.PropertyProperty Field

DistributionEditorPropertyProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty PropertyProperty
public:
static DependencyProperty^ PropertyProperty

Field Value

Type: DependencyProperty
See Also

Reference

DistributionEditor Class
VisualComponents.UX.Shared Namespace


DistributionEditor.TextProperty Field

DistributionEditorTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty TextProperty
public:
static DependencyProperty^ TextProperty

Field Value

Type: DependencyProperty
See Also

Reference

DistributionEditor Class
VisualComponents.UX.Shared Namespace


DistributionProperty Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedEditorProperty
VisualComponents.UX.SharedDistributionProperty

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class DistributionProperty : EditorProperty,
    IDistributionProperty, IProperty, INotifyPropertyChanged, IDisposable, INamed
public ref class DistributionProperty sealed : public EditorProperty,
    IDistributionProperty, IProperty, INotifyPropertyChanged, IDisposable, INamed

The DistributionProperty type exposes the following members.

Constructors
 | Name | Description
Public method | DistributionProperty | Initializes a new instance of the DistributionProperty class
Top
Properties
 | Name | Description
Public property | AllowedMaximum | (Inherited from EditorProperty.)
Public property | AllowedMinimum | (Inherited from EditorProperty.)
Public property | AllowedValues | (Inherited from EditorProperty.)
Public property | CanCreateNewValue | (Inherited from EditorProperty.)
Public property | Category | (Inherited from EditorProperty.)
Public property | ConstraintType | (Inherited from EditorProperty.)
Public property | Container | (Inherited from EditorProperty.)
Public property | ContainerExpressionContext | (Inherited from EditorProperty.)
Public property | ContainerObject | Similar to IProperty.Container, but for any object. (Inherited from EditorProperty.)
Public property | CreationTypes | (Inherited from EditorProperty.)
Public property | Description | (Inherited from EditorProperty.)
Public property | DisabledStateToolTip | (Inherited from EditorProperty.)
Public property | Distribution |
Public property | DistributionExpression | (Inherited from EditorProperty.)
Public property | DistributionType |
Public property | Error | (Inherited from EditorProperty.)
Public property | ErrorMessage | (Inherited from EditorProperty.)
Public property | HasDistribution | (Inherited from EditorProperty.)
Public property | History | (Inherited from EditorProperty.)
Public property | Index_ForComboBox | (Inherited from EditorProperty.)
Public property | IsDesignTime | (Inherited from EditorProperty.)
Public property | IsEditable | Helper property since in XAML negating binding value is not possible without using BoolToOppositeConverter (Inherited from EditorProperty.)
Public property | IsEditableInGui | (Inherited from EditorProperty.)
Public property | IsExceptionallyInHome | (Inherited from EditorProperty.)
Public property | IsInternal | (Inherited from EditorProperty.)
Public property | IsLocked | (Inherited from EditorProperty.)
Public property | IsPersistent | (Inherited from EditorProperty.)
Public property | IsQuantityValue | (Inherited from EditorProperty.)
Public property | IsReadOnly | (Inherited from EditorProperty.)
Public property | IsValid | (Inherited from EditorProperty.)
Public property | IsVisible | (Inherited from EditorProperty.)
Public property | IsVisibleDesignTime | (Inherited from EditorProperty.)
Public property | IsVisibleForced | (Inherited from EditorProperty.)
Public property | IsVisibleInGui | IsVisibleInGui is used to bind GUI visibility. Setting this value affects only _isVisibleForcedOff. (Inherited from EditorProperty.)
Public property | Item | (Inherited from EditorProperty.)
Public property | Name | (Inherited from EditorProperty.)
Public property | NonLocalizedName | (Inherited from EditorProperty.)
Public property | Order | (Inherited from EditorProperty.)
Public property | Parameters |
Public property | Property | (Inherited from EditorProperty.)
Public property | PropertyDescription | (Inherited from EditorProperty.)
Public property | PropertyType | (Inherited from EditorProperty.)
Public property | Quantity | (Inherited from EditorProperty.)
Public property | RandomStream |
Public property | ResourceType | In case of having an IUriProperty, this determines if the editor should allow folder selection instead of file selection (Inherited from EditorProperty.)
Public property | RotationSystem | (Inherited from EditorProperty.)
Public property | ShowValuepicker | (Inherited from EditorProperty.)
Public property | TabHeader | (Inherited from EditorProperty.)
Public property | Unit | (Inherited from EditorProperty.)
Public property | UserSettingService |
Public property | Value | (Inherited from EditorProperty.)
Public property | Value_ForComboBox | Helper property, used only by ComboBox. (Inherited from EditorProperty.)
Public property | ValueString | (Inherited from EditorProperty.)
Top
Methods
 | Name | Description
Public method | Associate | (Inherited from EditorProperty.)
Public method | CheckEditableInGui | (Inherited from EditorProperty.)
Public method | CheckRebuild | This happens only on UI changes. If containeris a behavior of feature call evaluate or rebuild to update geometry. (Inherited from EditorProperty.)
Public method | CheckRebuildSmart | (Inherited from EditorProperty.)
Public method | Clone | (Inherited from EditorProperty.)
Public method | CreateAndSetNewValue | (Inherited from EditorProperty.)
Public method | Disassociate | (Inherited from EditorProperty.)
Public method | Dispose | (Inherited from EditorProperty.)
Public method | EndBatch | (Inherited from EditorProperty.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PickValue | Execute PickAction and wait for user to click on some object. (Inherited from EditorProperty.)
Public method | PickValueProxy | (Inherited from EditorProperty.)
Public method | SetQuantity | (Inherited from EditorProperty.)
Public method | SetUnitMagnitude | (Inherited from EditorProperty.)
Public method | StartBatch | (Inherited from EditorProperty.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | property changed event (Inherited from EditorProperty.)
Top
Fields
 | Name | Description
Public field | SuppressValueChange | (Inherited from EditorProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DistributionProperty Constructor

Initializes a new instance of the DistributionProperty class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DistributionProperty(
    IProperty property
)
public:
DistributionProperty(
    IProperty^ property
)

Parameters

property
Type: VisualComponents.Create3DIProperty
See Also

Reference

DistributionProperty Class
VisualComponents.UX.Shared Namespace


DistributionProperty Properties

The DistributionProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | (Inherited from EditorProperty.)
Public property | AllowedMinimum | (Inherited from EditorProperty.)
Public property | AllowedValues | (Inherited from EditorProperty.)
Public property | CanCreateNewValue | (Inherited from EditorProperty.)
Public property | Category | (Inherited from EditorProperty.)
Public property | ConstraintType | (Inherited from EditorProperty.)
Public property | Container | (Inherited from EditorProperty.)
Public property | ContainerExpressionContext | (Inherited from EditorProperty.)
Public property | ContainerObject | Similar to IProperty.Container, but for any object. (Inherited from EditorProperty.)
Public property | CreationTypes | (Inherited from EditorProperty.)
Public property | Description | (Inherited from EditorProperty.)
Public property | DisabledStateToolTip | (Inherited from EditorProperty.)
Public property | Distribution |
Public property | DistributionExpression | (Inherited from EditorProperty.)
Public property | DistributionType |
Public property | Error | (Inherited from EditorProperty.)
Public property | ErrorMessage | (Inherited from EditorProperty.)
Public property | HasDistribution | (Inherited from EditorProperty.)
Public property | History | (Inherited from EditorProperty.)
Public property | Index_ForComboBox | (Inherited from EditorProperty.)
Public property | IsDesignTime | (Inherited from EditorProperty.)
Public property | IsEditable | Helper property since in XAML negating binding value is not possible without using BoolToOppositeConverter (Inherited from EditorProperty.)
Public property | IsEditableInGui | (Inherited from EditorProperty.)
Public property | IsExceptionallyInHome | (Inherited from EditorProperty.)
Public property | IsInternal | (Inherited from EditorProperty.)
Public property | IsLocked | (Inherited from EditorProperty.)
Public property | IsPersistent | (Inherited from EditorProperty.)
Public property | IsQuantityValue | (Inherited from EditorProperty.)
Public property | IsReadOnly | (Inherited from EditorProperty.)
Public property | IsValid | (Inherited from EditorProperty.)
Public property | IsVisible | (Inherited from EditorProperty.)
Public property | IsVisibleDesignTime | (Inherited from EditorProperty.)
Public property | IsVisibleForced | (Inherited from EditorProperty.)
Public property | IsVisibleInGui | IsVisibleInGui is used to bind GUI visibility. Setting this value affects only _isVisibleForcedOff. (Inherited from EditorProperty.)
Public property | Item | (Inherited from EditorProperty.)
Public property | Name | (Inherited from EditorProperty.)
Public property | NonLocalizedName | (Inherited from EditorProperty.)
Public property | Order | (Inherited from EditorProperty.)
Public property | Parameters |
Public property | Property | (Inherited from EditorProperty.)
Public property | PropertyDescription | (Inherited from EditorProperty.)
Public property | PropertyType | (Inherited from EditorProperty.)
Public property | Quantity | (Inherited from EditorProperty.)
Public property | RandomStream |
Public property | ResourceType | In case of having an IUriProperty, this determines if the editor should allow folder selection instead of file selection (Inherited from EditorProperty.)
Public property | RotationSystem | (Inherited from EditorProperty.)
Public property | ShowValuepicker | (Inherited from EditorProperty.)
Public property | TabHeader | (Inherited from EditorProperty.)
Public property | Unit | (Inherited from EditorProperty.)
Public property | UserSettingService |
Public property | Value | (Inherited from EditorProperty.)
Public property | Value_ForComboBox | Helper property, used only by ComboBox. (Inherited from EditorProperty.)
Public property | ValueString | (Inherited from EditorProperty.)
Top
See Also

Reference

DistributionProperty Class
VisualComponents.UX.Shared Namespace


DistributionProperty.Distribution Property

DistributionPropertyDistribution Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Distribution { get; set; }
public:
virtual property String^ Distribution {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IDistributionPropertyDistribution
See Also

Reference

DistributionProperty Class
VisualComponents.UX.Shared Namespace


DistributionProperty.DistributionType Property

DistributionPropertyDistributionType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DistributionType DistributionType { get; }
public:
virtual property DistributionType DistributionType {
    DistributionType get () sealed;
}

Property Value

Type: DistributionType

Implements

IDistributionPropertyDistributionType
See Also

Reference

DistributionProperty Class
VisualComponents.UX.Shared Namespace


DistributionProperty.Parameters Property

DistributionPropertyParameters Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IDistributionParameters Parameters { get; set; }
public:
virtual property IDistributionParameters^ Parameters {
    IDistributionParameters^ get () sealed;
    void set (IDistributionParameters^ value) sealed;
}

Property Value

Type: IDistributionParameters

Implements

IDistributionPropertyParameters
See Also

Reference

DistributionProperty Class
VisualComponents.UX.Shared Namespace


DistributionProperty.RandomStream Property

DistributionPropertyRandomStream Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int RandomStream { get; set; }
public:
virtual property int RandomStream {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

IDistributionPropertyRandomStream
See Also

Reference

DistributionProperty Class
VisualComponents.UX.Shared Namespace


DistributionProperty.UserSettingService Property

DistributionPropertyUserSettingService Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IUserSettingService UserSettingService { get; }
public:
property IUserSettingService^ UserSettingService {
    IUserSettingService^ get ();
}

Property Value

Type: IUserSettingService
See Also

Reference

DistributionProperty Class
VisualComponents.UX.Shared Namespace


DistributionProperty Methods

The DistributionProperty type exposes the following members.

Methods
 | Name | Description
Public method | Associate | (Inherited from EditorProperty.)
Public method | CheckEditableInGui | (Inherited from EditorProperty.)
Public method | CheckRebuild | This happens only on UI changes. If containeris a behavior of feature call evaluate or rebuild to update geometry. (Inherited from EditorProperty.)
Public method | CheckRebuildSmart | (Inherited from EditorProperty.)
Public method | Clone | (Inherited from EditorProperty.)
Public method | CreateAndSetNewValue | (Inherited from EditorProperty.)
Public method | Disassociate | (Inherited from EditorProperty.)
Public method | Dispose | (Inherited from EditorProperty.)
Public method | EndBatch | (Inherited from EditorProperty.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PickValue | Execute PickAction and wait for user to click on some object. (Inherited from EditorProperty.)
Public method | PickValueProxy | (Inherited from EditorProperty.)
Public method | SetQuantity | (Inherited from EditorProperty.)
Public method | SetUnitMagnitude | (Inherited from EditorProperty.)
Public method | StartBatch | (Inherited from EditorProperty.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DistributionProperty Class
VisualComponents.UX.Shared Namespace


DistributionProperty Events

The DistributionProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | property changed event (Inherited from EditorProperty.)
Top
See Also

Reference

DistributionProperty Class
VisualComponents.UX.Shared Namespace


DistributionProperty Fields

The DistributionProperty type exposes the following members.

Fields
 | Name | Description
Public field | SuppressValueChange | (Inherited from EditorProperty.)
Top
See Also

Reference

DistributionProperty Class
VisualComponents.UX.Shared Namespace


DistributionTypeEditorDialog Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedDistributionTypeEditorDialog

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class DistributionTypeEditorDialog : IResult
public ref class DistributionTypeEditorDialog : IResult

The DistributionTypeEditorDialog type exposes the following members.

Constructors
 | Name | Description
Public method | DistributionTypeEditorDialog | Initializes a new instance of the DistributionTypeEditorDialog class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Completed |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DistributionTypeEditorDialog Constructor

Initializes a new instance of the DistributionTypeEditorDialog class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DistributionTypeEditorDialog(
    IProperty property,
    Bindable bindable = null
)
public:
DistributionTypeEditorDialog(
    IProperty^ property,
    Bindable^ bindable = nullptr
)

Parameters

property
Type: VisualComponents.Create3DIProperty
bindable (Optional)
Type: VisualComponents.UX.SharedBindable
See Also

Reference

DistributionTypeEditorDialog Class
VisualComponents.UX.Shared Namespace


DistributionTypeEditorDialog Methods

The DistributionTypeEditorDialog type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DistributionTypeEditorDialog Class
VisualComponents.UX.Shared Namespace


DistributionTypeEditorDialog.Execute Method

DistributionTypeEditorDialogExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    ActionExecutionContext context
)
public:
virtual void Execute(
    ActionExecutionContext^ context
) sealed

Parameters

context
Type: ActionExecutionContext

Implements

IResult.Execute(ActionExecutionContext)
See Also

Reference

DistributionTypeEditorDialog Class
VisualComponents.UX.Shared Namespace


DistributionTypeEditorDialog Events

The DistributionTypeEditorDialog type exposes the following members.

Events
 | Name | Description
Public event | Completed |
Top
See Also

Reference

DistributionTypeEditorDialog Class
VisualComponents.UX.Shared Namespace


DistributionTypeEditorDialog.Completed Event

DistributionTypeEditorDialogCompleted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ResultCompletionEventArgs> Completed
public:
virtual  event EventHandler<ResultCompletionEventArgs^>^ Completed {
    void add (EventHandler<ResultCompletionEventArgs^>^ value);
    void remove (EventHandler<ResultCompletionEventArgs^>^ value);
}

Value

Type: SystemEventHandlerResultCompletionEventArgs

Implements

IResult.Completed
See Also

Reference

DistributionTypeEditorDialog Class
VisualComponents.UX.Shared Namespace


DistributionTypeEditorView Class

Interaction logic for DistributionTypeEditorView.xaml
DistributionTypeEditorView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedDistributionTypeEditorView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class DistributionTypeEditorView : UserControl,
    IComponentConnector
public ref class DistributionTypeEditorView : public UserControl,
    IComponentConnector

The DistributionTypeEditorView type exposes the following members.

Constructors
 | Name | Description
Public method | DistributionTypeEditorView | Initializes a new instance of the DistributionTypeEditorView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DistributionTypeEditorView Constructor

Initializes a new instance of the DistributionTypeEditorView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DistributionTypeEditorView()
public:
DistributionTypeEditorView()
See Also

Reference

DistributionTypeEditorView Class
VisualComponents.UX.Shared Namespace


DistributionTypeEditorView Properties

The DistributionTypeEditorView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DistributionTypeEditorView Class
VisualComponents.UX.Shared Namespace


DistributionTypeEditorView Methods

The DistributionTypeEditorView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DistributionTypeEditorView Class
VisualComponents.UX.Shared Namespace


DistributionTypeEditorView.InitializeComponent Method

DistributionTypeEditorViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

DistributionTypeEditorView Class
VisualComponents.UX.Shared Namespace


DistributionTypeEditorView Events

The DistributionTypeEditorView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

DistributionTypeEditorView Class
VisualComponents.UX.Shared Namespace


DockableConductor(T) Class

DockableConductorT Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
ViewAware
Screen
ConductorBaseT
ConductorBaseWithActiveItemT
OneActive
VisualComponents.UX.SharedDockableConductorT

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract class DockableConductor<T> : OneActive,
    IDockableScreen, IScreen, IHaveDisplayName, IActivate, IDeactivate,
    IGuardClose, IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
where T : class

generic<typename T>
where T : ref class
public ref class DockableConductor abstract : public OneActive,
    IDockableScreen, IScreen, IHaveDisplayName, IActivate, IDeactivate,
    IGuardClose, IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

Type Parameters

T

The DockableConductorT type exposes the following members.

Constructors
 | Name | Description
Public method | DockableConductorT | Initializes a new instance of the DockableConductorT class
Top
Properties
 | Name | Description
Public property | ActiveItem | (Inherited from ConductorBaseWithActiveItemT.)
Protected property | CacheViews | (Inherited from ViewAware.)
Public property | CanDropToDocumentHost |
Public property | CloseStrategy | (Inherited from ConductorBaseT.)
Public property | ContextFilter |
Public property | DesiredPanePosition | Desired position within the pane.
Public property | DisplayName | (Inherited from Screen.)
Public property | Height |
Public property | IsActive | (Inherited from Screen.)
Public property | IsInitialized | (Inherited from Screen.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsPinned |
Public property | IsSelected | If true it will be selected in TabGroupPane
Public property | IsVisible |
Public property | Items | (Inherited from OneActive.)
Public property | PanelId |
Public property | PaneLocation |
Public property | PaneOrientation |
Public property | Parent | (Inherited from Screen.)
Public property | SplitPaneId |
Public property | TabGroupId |
Public property | Width |
Top
Methods
 | Name | Description
Public method | ActivateItem | (Inherited from OneActive.)
Public method | CanClose | (Inherited from OneActive.)
Protected method | ChangeActiveItem | (Inherited from ConductorBaseWithActiveItemT.)
Public method | DeactivateItem | (Inherited from OneActive.)
Protected method | DetermineNextItemToActivate | (Inherited from OneActive.)
Protected method | EnsureItem | (Inherited from OneActive.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChildren | (Inherited from OneActive.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetView | (Inherited from ViewAware.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Protected method | OnActivate | (Inherited from OneActive.)
Protected method | OnActivationProcessed | (Inherited from ConductorBaseT.)
Protected method | OnDeactivate | (Inherited from OneActive.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnInitialize | (Inherited from Screen.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Protected method | OnViewAttached | (Inherited from ViewAware.)
Protected method | OnViewLoaded | (Inherited from ViewAware.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryClose | (Inherited from Screen.)
Public method | TryClose(NullableBoolean) | (Inherited from Screen.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from Screen.)
Public event | ActivationProcessed | (Inherited from ConductorBaseT.)
Public event | AttemptingDeactivation | (Inherited from Screen.)
Public event | Deactivated | (Inherited from Screen.)
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Public event | ViewAttached | (Inherited from ViewAware.)
Top
Fields
 | Name | Description
Protected field | Views | (Inherited from ViewAware.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DockableConductor(T) Constructor

DockableConductorT Constructor

Initializes a new instance of the DockableConductorT class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DockableConductor()
public:
DockableConductor()
See Also

Reference

DockableConductorT Class
VisualComponents.UX.Shared Namespace


DockableConductor(T) Properties

DockableConductorT Properties

The DockableConductorT generic type exposes the following members.

Properties
 | Name | Description
Public property | ActiveItem | (Inherited from ConductorBaseWithActiveItemT .)
Protected property | CacheViews | (Inherited from ViewAware.)
Public property | CanDropToDocumentHost |
Public property | CloseStrategy | (Inherited from ConductorBaseT .)
Public property | ContextFilter |
Public property | DesiredPanePosition | Desired position within the pane.
Public property | DisplayName | (Inherited from Screen.)
Public property | Height |
Public property | IsActive | (Inherited from Screen.)
Public property | IsInitialized | (Inherited from Screen.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsPinned |
Public property | IsSelected | If true it will be selected in TabGroupPane
Public property | IsVisible |
Public property | Items | (Inherited from OneActive.)
Public property | PanelId |
Public property | PaneLocation |
Public property | PaneOrientation |
Public property | Parent | (Inherited from Screen.)
Public property | SplitPaneId |
Public property | TabGroupId |
Public property | Width |
Top
See Also

Reference

DockableConductorT Class
VisualComponents.UX.Shared Namespace


DockableConductor(T).CanDropToDocumentHost Property

DockableConductorTCanDropToDocumentHost Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanDropToDocumentHost { get; set; }
public:
property bool CanDropToDocumentHost {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DockableConductorT Class
VisualComponents.UX.Shared Namespace


DockableConductor(T).ContextFilter Property

DockableConductorTContextFilter Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ContextFilter { get; set; }
public:
virtual property String^ ContextFilter {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IDockableScreenContextFilter
See Also

Reference

DockableConductorT Class
VisualComponents.UX.Shared Namespace


DockableConductor(T).DesiredPanePosition Property

DockableConductorTDesiredPanePosition Property

Desired position within the pane.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int DesiredPanePosition { get; set; }
public:
virtual property int DesiredPanePosition {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

IDockableScreenDesiredPanePosition
See Also

Reference

DockableConductorT Class
VisualComponents.UX.Shared Namespace


DockableConductor(T).Height Property

DockableConductorTHeight Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Height { get; set; }
public:
virtual property double Height {
    double get () sealed;
    void set (double value) sealed;
}

Property Value

Type: Double

Implements

IDockableScreenHeight
See Also

Reference

DockableConductorT Class
VisualComponents.UX.Shared Namespace


DockableConductor(T).IsPinned Property

DockableConductorTIsPinned Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsPinned { get; set; }
public:
virtual property bool IsPinned {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IDockableScreenIsPinned
See Also

Reference

DockableConductorT Class
VisualComponents.UX.Shared Namespace


DockableConductor(T).IsSelected Property

DockableConductorTIsSelected Property

If true it will be selected in TabGroupPane

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsSelected { get; set; }
public:
virtual property bool IsSelected {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IDockableScreenIsSelected
See Also

Reference

DockableConductorT Class
VisualComponents.UX.Shared Namespace


DockableConductor(T).IsVisible Property

DockableConductorTIsVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsVisible { get; set; }
public:
virtual property bool IsVisible {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IDockableScreenIsVisible
See Also

Reference

DockableConductorT Class
VisualComponents.UX.Shared Namespace


DockableConductor(T).PanelId Property

DockableConductorTPanelId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string PanelId { get; set; }
public:
virtual property String^ PanelId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IDockableScreenPanelId
See Also

Reference

DockableConductorT Class
VisualComponents.UX.Shared Namespace


DockableConductor(T).PaneLocation Property

DockableConductorTPaneLocation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DesiredPaneLocation PaneLocation { get; set; }
public:
virtual property DesiredPaneLocation PaneLocation {
    DesiredPaneLocation get () sealed;
    void set (DesiredPaneLocation value) sealed;
}

Property Value

Type: DesiredPaneLocation

Implements

IDockableScreenPaneLocation
See Also

Reference

DockableConductorT Class
VisualComponents.UX.Shared Namespace


DockableConductor(T).PaneOrientation Property

DockableConductorTPaneOrientation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Orientation PaneOrientation { get; set; }
public:
virtual property Orientation PaneOrientation {
    Orientation get () sealed;
    void set (Orientation value) sealed;
}

Property Value

Type: Orientation

Implements

IDockableScreenPaneOrientation
See Also

Reference

DockableConductorT Class
VisualComponents.UX.Shared Namespace


DockableConductor(T).SplitPaneId Property

DockableConductorTSplitPaneId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SplitPaneId { get; set; }
public:
virtual property String^ SplitPaneId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IDockableScreenSplitPaneId
See Also

Reference

DockableConductorT Class
VisualComponents.UX.Shared Namespace


DockableConductor(T).TabGroupId Property

DockableConductorTTabGroupId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string TabGroupId { get; set; }
public:
virtual property String^ TabGroupId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IDockableScreenTabGroupId
See Also

Reference

DockableConductorT Class
VisualComponents.UX.Shared Namespace


DockableConductor(T).Width Property

DockableConductorTWidth Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Width { get; set; }
public:
virtual property double Width {
    double get () sealed;
    void set (double value) sealed;
}

Property Value

Type: Double

Implements

IDockableScreenWidth
See Also

Reference

DockableConductorT Class
VisualComponents.UX.Shared Namespace


DockableConductor(T) Methods

DockableConductorT Methods

The DockableConductorT generic type exposes the following members.

Methods
 | Name | Description
Public method | ActivateItem | (Inherited from OneActive.)
Public method | CanClose | (Inherited from OneActive.)
Protected method | ChangeActiveItem | (Inherited from ConductorBaseWithActiveItemT .)
Public method | DeactivateItem | (Inherited from OneActive.)
Protected method | DetermineNextItemToActivate | (Inherited from OneActive.)
Protected method | EnsureItem | (Inherited from OneActive.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChildren | (Inherited from OneActive.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetView | (Inherited from ViewAware.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Protected method | OnActivate | (Inherited from OneActive.)
Protected method | OnActivationProcessed | (Inherited from ConductorBaseT .)
Protected method | OnDeactivate | (Inherited from OneActive.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnInitialize | (Inherited from Screen.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Protected method | OnViewAttached | (Inherited from ViewAware.)
Protected method | OnViewLoaded | (Inherited from ViewAware.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryClose | (Inherited from Screen.)
Public method | TryClose(NullableBoolean) | (Inherited from Screen.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DockableConductorT Class
VisualComponents.UX.Shared Namespace


DockableConductor(T) Events

DockableConductorT Events

The DockableConductorT generic type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from Screen.)
Public event | ActivationProcessed | (Inherited from ConductorBaseT .)
Public event | AttemptingDeactivation | (Inherited from Screen.)
Public event | Deactivated | (Inherited from Screen.)
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Public event | ViewAttached | (Inherited from ViewAware.)
Top
See Also

Reference

DockableConductorT Class
VisualComponents.UX.Shared Namespace


DockableConductor(T) Fields

DockableConductorT Fields

The DockableConductorT generic type exposes the following members.

Fields
 | Name | Description
Protected field | Views | (Inherited from ViewAware.)
Top
See Also

Reference

DockableConductorT Class
VisualComponents.UX.Shared Namespace


DockableConductorSingleActive(T) Class

DockableConductorSingleActiveT Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
ViewAware
Screen
ConductorBaseT
ConductorBaseWithActiveItemT
ConductorT
VisualComponents.UX.SharedDockableConductorSingleActiveT

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract class DockableConductorSingleActive<T> : Conductor<T>,
    IDockableScreen, IScreen, IHaveDisplayName, IActivate, IDeactivate,
    IGuardClose, IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
where T : class

generic<typename T>
where T : ref class
public ref class DockableConductorSingleActive abstract : public Conductor<T>,
    IDockableScreen, IScreen, IHaveDisplayName, IActivate, IDeactivate,
    IGuardClose, IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

Type Parameters

T

The DockableConductorSingleActiveT type exposes the following members.

Constructors
 | Name | Description
Public method | DockableConductorSingleActiveT | Initializes a new instance of the DockableConductorSingleActiveT class
Top
Properties
 | Name | Description
Public property | ActiveItem | (Inherited from ConductorBaseWithActiveItemT.)
Protected property | CacheViews | (Inherited from ViewAware.)
Public property | CanDropToDocumentHost |
Public property | CloseStrategy | (Inherited from ConductorBaseT.)
Public property | ContextFilter |
Public property | DesiredPanePosition | Desired position within the pane.
Public property | DisplayName | (Inherited from Screen.)
Public property | Height |
Public property | IsActive | (Inherited from Screen.)
Public property | IsInitialized | (Inherited from Screen.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsPinned |
Public property | IsSelected | If true it will be selected in TabGroupPane
Public property | IsVisible |
Public property | PanelId |
Public property | PaneLocation |
Public property | PaneOrientation |
Public property | Parent | (Inherited from Screen.)
Public property | SplitPaneId |
Public property | TabGroupId |
Public property | Width |
Top
Methods
 | Name | Description
Public method | ActivateItem | (Inherited from ConductorT.)
Public method | CanClose | (Inherited from ConductorT.)
Protected method | ChangeActiveItem | (Inherited from ConductorBaseWithActiveItemT.)
Public method | DeactivateItem | (Inherited from ConductorT.)
Protected method | EnsureItem | (Inherited from ConductorBaseT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChildren | (Inherited from ConductorT.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetView | (Inherited from ViewAware.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Protected method | OnActivate | (Inherited from ConductorT.)
Protected method | OnActivationProcessed | (Inherited from ConductorBaseT.)
Protected method | OnDeactivate | (Inherited from ConductorT.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnInitialize | (Inherited from Screen.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Protected method | OnViewAttached | (Inherited from ViewAware.)
Protected method | OnViewLoaded | (Inherited from ViewAware.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryClose | (Inherited from Screen.)
Public method | TryClose(NullableBoolean) | (Inherited from Screen.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from Screen.)
Public event | ActivationProcessed | (Inherited from ConductorBaseT.)
Public event | AttemptingDeactivation | (Inherited from Screen.)
Public event | Deactivated | (Inherited from Screen.)
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Public event | ViewAttached | (Inherited from ViewAware.)
Top
Fields
 | Name | Description
Protected field | Views | (Inherited from ViewAware.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DockableConductorSingleActive(T) Constructor

DockableConductorSingleActiveT Constructor

Initializes a new instance of the DockableConductorSingleActiveT class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DockableConductorSingleActive()
public:
DockableConductorSingleActive()
See Also

Reference

DockableConductorSingleActiveT Class
VisualComponents.UX.Shared Namespace


DockableConductorSingleActive(T) Properties

DockableConductorSingleActiveT Properties

The DockableConductorSingleActiveT generic type exposes the following members.

Properties
 | Name | Description
Public property | ActiveItem | (Inherited from ConductorBaseWithActiveItemT .)
Protected property | CacheViews | (Inherited from ViewAware.)
Public property | CanDropToDocumentHost |
Public property | CloseStrategy | (Inherited from ConductorBaseT .)
Public property | ContextFilter |
Public property | DesiredPanePosition | Desired position within the pane.
Public property | DisplayName | (Inherited from Screen.)
Public property | Height |
Public property | IsActive | (Inherited from Screen.)
Public property | IsInitialized | (Inherited from Screen.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsPinned |
Public property | IsSelected | If true it will be selected in TabGroupPane
Public property | IsVisible |
Public property | PanelId |
Public property | PaneLocation |
Public property | PaneOrientation |
Public property | Parent | (Inherited from Screen.)
Public property | SplitPaneId |
Public property | TabGroupId |
Public property | Width |
Top
See Also

Reference

DockableConductorSingleActiveT Class
VisualComponents.UX.Shared Namespace


DockableConductorSingleActive(T).CanDropToDocumentHost Property

DockableConductorSingleActiveTCanDropToDocumentHost Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanDropToDocumentHost { get; set; }
public:
property bool CanDropToDocumentHost {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DockableConductorSingleActiveT Class
VisualComponents.UX.Shared Namespace


DockableConductorSingleActive(T).ContextFilter Property

DockableConductorSingleActiveTContextFilter Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ContextFilter { get; set; }
public:
virtual property String^ ContextFilter {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IDockableScreenContextFilter
See Also

Reference

DockableConductorSingleActiveT Class
VisualComponents.UX.Shared Namespace


DockableConductorSingleActive(T).DesiredPanePosition Property

DockableConductorSingleActiveTDesiredPanePosition Property

Desired position within the pane.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int DesiredPanePosition { get; set; }
public:
virtual property int DesiredPanePosition {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

IDockableScreenDesiredPanePosition
See Also

Reference

DockableConductorSingleActiveT Class
VisualComponents.UX.Shared Namespace


DockableConductorSingleActive(T).Height Property

DockableConductorSingleActiveTHeight Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Height { get; set; }
public:
virtual property double Height {
    double get () sealed;
    void set (double value) sealed;
}

Property Value

Type: Double

Implements

IDockableScreenHeight
See Also

Reference

DockableConductorSingleActiveT Class
VisualComponents.UX.Shared Namespace


DockableConductorSingleActive(T).IsPinned Property

DockableConductorSingleActiveTIsPinned Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsPinned { get; set; }
public:
virtual property bool IsPinned {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IDockableScreenIsPinned
See Also

Reference

DockableConductorSingleActiveT Class
VisualComponents.UX.Shared Namespace


DockableConductorSingleActive(T).IsSelected Property

DockableConductorSingleActiveTIsSelected Property

If true it will be selected in TabGroupPane

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsSelected { get; set; }
public:
virtual property bool IsSelected {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IDockableScreenIsSelected
See Also

Reference

DockableConductorSingleActiveT Class
VisualComponents.UX.Shared Namespace


DockableConductorSingleActive(T).IsVisible Property

DockableConductorSingleActiveTIsVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsVisible { get; set; }
public:
virtual property bool IsVisible {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IDockableScreenIsVisible
See Also

Reference

DockableConductorSingleActiveT Class
VisualComponents.UX.Shared Namespace


DockableConductorSingleActive(T).PanelId Property

DockableConductorSingleActiveTPanelId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string PanelId { get; set; }
public:
virtual property String^ PanelId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IDockableScreenPanelId
See Also

Reference

DockableConductorSingleActiveT Class
VisualComponents.UX.Shared Namespace


DockableConductorSingleActive(T).PaneLocation Property

DockableConductorSingleActiveTPaneLocation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DesiredPaneLocation PaneLocation { get; set; }
public:
virtual property DesiredPaneLocation PaneLocation {
    DesiredPaneLocation get () sealed;
    void set (DesiredPaneLocation value) sealed;
}

Property Value

Type: DesiredPaneLocation

Implements

IDockableScreenPaneLocation
See Also

Reference

DockableConductorSingleActiveT Class
VisualComponents.UX.Shared Namespace


DockableConductorSingleActive(T).PaneOrientation Property

DockableConductorSingleActiveTPaneOrientation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Orientation PaneOrientation { get; set; }
public:
virtual property Orientation PaneOrientation {
    Orientation get () sealed;
    void set (Orientation value) sealed;
}

Property Value

Type: Orientation

Implements

IDockableScreenPaneOrientation
See Also

Reference

DockableConductorSingleActiveT Class
VisualComponents.UX.Shared Namespace


DockableConductorSingleActive(T).SplitPaneId Property

DockableConductorSingleActiveTSplitPaneId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SplitPaneId { get; set; }
public:
virtual property String^ SplitPaneId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IDockableScreenSplitPaneId
See Also

Reference

DockableConductorSingleActiveT Class
VisualComponents.UX.Shared Namespace


DockableConductorSingleActive(T).TabGroupId Property

DockableConductorSingleActiveTTabGroupId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string TabGroupId { get; set; }
public:
virtual property String^ TabGroupId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IDockableScreenTabGroupId
See Also

Reference

DockableConductorSingleActiveT Class
VisualComponents.UX.Shared Namespace


DockableConductorSingleActive(T).Width Property

DockableConductorSingleActiveTWidth Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Width { get; set; }
public:
virtual property double Width {
    double get () sealed;
    void set (double value) sealed;
}

Property Value

Type: Double

Implements

IDockableScreenWidth
See Also

Reference

DockableConductorSingleActiveT Class
VisualComponents.UX.Shared Namespace


DockableConductorSingleActive(T) Methods

DockableConductorSingleActiveT Methods

The DockableConductorSingleActiveT generic type exposes the following members.

Methods
 | Name | Description
Public method | ActivateItem | (Inherited from ConductorT .)
Public method | CanClose | (Inherited from ConductorT .)
Protected method | ChangeActiveItem | (Inherited from ConductorBaseWithActiveItemT .)
Public method | DeactivateItem | (Inherited from ConductorT .)
Protected method | EnsureItem | (Inherited from ConductorBaseT .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChildren | (Inherited from ConductorT .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetView | (Inherited from ViewAware.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Protected method | OnActivate | (Inherited from ConductorT .)
Protected method | OnActivationProcessed | (Inherited from ConductorBaseT .)
Protected method | OnDeactivate | (Inherited from ConductorT .)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnInitialize | (Inherited from Screen.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Protected method | OnViewAttached | (Inherited from ViewAware.)
Protected method | OnViewLoaded | (Inherited from ViewAware.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryClose | (Inherited from Screen.)
Public method | TryClose(NullableBoolean) | (Inherited from Screen.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DockableConductorSingleActiveT Class
VisualComponents.UX.Shared Namespace


DockableConductorSingleActive(T) Events

DockableConductorSingleActiveT Events

The DockableConductorSingleActiveT generic type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from Screen.)
Public event | ActivationProcessed | (Inherited from ConductorBaseT .)
Public event | AttemptingDeactivation | (Inherited from Screen.)
Public event | Deactivated | (Inherited from Screen.)
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Public event | ViewAttached | (Inherited from ViewAware.)
Top
See Also

Reference

DockableConductorSingleActiveT Class
VisualComponents.UX.Shared Namespace


DockableConductorSingleActive(T) Fields

DockableConductorSingleActiveT Fields

The DockableConductorSingleActiveT generic type exposes the following members.

Fields
 | Name | Description
Protected field | Views | (Inherited from ViewAware.)
Top
See Also

Reference

DockableConductorSingleActiveT Class
VisualComponents.UX.Shared Namespace


DockableMultiConductor(T) Class

DockableMultiConductorT Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
ViewAware
Screen
ConductorBaseT
AllActive
VisualComponents.UX.SharedDockableMultiConductorT

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract class DockableMultiConductor<T> : AllActive,
    IDockableScreen, IScreen, IHaveDisplayName, IActivate, IDeactivate,
    IGuardClose, IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
where T : class

generic<typename T>
where T : ref class
public ref class DockableMultiConductor abstract : public AllActive,
    IDockableScreen, IScreen, IHaveDisplayName, IActivate, IDeactivate,
    IGuardClose, IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

Type Parameters

T

The DockableMultiConductorT type exposes the following members.

Constructors
 | Name | Description
Public method | DockableMultiConductorT | Initializes a new instance of the DockableMultiConductorT class
Top
Properties
 | Name | Description
Protected property | CacheViews | (Inherited from ViewAware.)
Public property | CanDropToDocumentHost |
Public property | CloseStrategy | (Inherited from ConductorBaseT.)
Public property | ContextFilter |
Public property | DesiredPanePosition | Desired position within the pane.
Public property | DisplayName | (Inherited from Screen.)
Public property | Height |
Public property | IsActive | (Inherited from Screen.)
Public property | IsInitialized | (Inherited from Screen.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsPinned |
Public property | IsSelected | If true it will be selected in TabGroupPane
Public property | IsVisible |
Public property | Items | (Inherited from AllActive.)
Public property | PanelId |
Public property | PaneLocation |
Public property | PaneOrientation |
Public property | Parent | (Inherited from Screen.)
Public property | SplitPaneId |
Public property | TabGroupId |
Public property | Width |
Top
Methods
 | Name | Description
Public method | ActivateItem | (Inherited from AllActive.)
Public method | CanClose | (Inherited from AllActive.)
Public method | DeactivateItem | (Inherited from AllActive.)
Protected method | EnsureItem | (Inherited from AllActive.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChildren | (Inherited from AllActive.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetView | (Inherited from ViewAware.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Protected method | OnActivate | (Inherited from AllActive.)
Protected method | OnActivationProcessed | (Inherited from ConductorBaseT.)
Protected method | OnDeactivate | (Inherited from AllActive.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnInitialize | (Inherited from AllActive.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Protected method | OnViewAttached | (Inherited from ViewAware.)
Protected method | OnViewLoaded | (Inherited from ViewAware.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryClose | (Inherited from Screen.)
Public method | TryClose(NullableBoolean) | (Inherited from Screen.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from Screen.)
Public event | ActivationProcessed | (Inherited from ConductorBaseT.)
Public event | AttemptingDeactivation | (Inherited from Screen.)
Public event | Deactivated | (Inherited from Screen.)
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Public event | ViewAttached | (Inherited from ViewAware.)
Top
Fields
 | Name | Description
Protected field | Views | (Inherited from ViewAware.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DockableMultiConductor(T) Constructor

DockableMultiConductorT Constructor

Initializes a new instance of the DockableMultiConductorT class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DockableMultiConductor()
public:
DockableMultiConductor()
See Also

Reference

DockableMultiConductorT Class
VisualComponents.UX.Shared Namespace


DockableMultiConductor(T) Properties

DockableMultiConductorT Properties

The DockableMultiConductorT generic type exposes the following members.

Properties
 | Name | Description
Protected property | CacheViews | (Inherited from ViewAware.)
Public property | CanDropToDocumentHost |
Public property | CloseStrategy | (Inherited from ConductorBaseT .)
Public property | ContextFilter |
Public property | DesiredPanePosition | Desired position within the pane.
Public property | DisplayName | (Inherited from Screen.)
Public property | Height |
Public property | IsActive | (Inherited from Screen.)
Public property | IsInitialized | (Inherited from Screen.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsPinned |
Public property | IsSelected | If true it will be selected in TabGroupPane
Public property | IsVisible |
Public property | Items | (Inherited from AllActive.)
Public property | PanelId |
Public property | PaneLocation |
Public property | PaneOrientation |
Public property | Parent | (Inherited from Screen.)
Public property | SplitPaneId |
Public property | TabGroupId |
Public property | Width |
Top
See Also

Reference

DockableMultiConductorT Class
VisualComponents.UX.Shared Namespace


DockableMultiConductor(T).CanDropToDocumentHost Property

DockableMultiConductorTCanDropToDocumentHost Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanDropToDocumentHost { get; set; }
public:
property bool CanDropToDocumentHost {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DockableMultiConductorT Class
VisualComponents.UX.Shared Namespace


DockableMultiConductor(T).ContextFilter Property

DockableMultiConductorTContextFilter Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ContextFilter { get; set; }
public:
virtual property String^ ContextFilter {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IDockableScreenContextFilter
See Also

Reference

DockableMultiConductorT Class
VisualComponents.UX.Shared Namespace


DockableMultiConductor(T).DesiredPanePosition Property

DockableMultiConductorTDesiredPanePosition Property

Desired position within the pane.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int DesiredPanePosition { get; set; }
public:
virtual property int DesiredPanePosition {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

IDockableScreenDesiredPanePosition
See Also

Reference

DockableMultiConductorT Class
VisualComponents.UX.Shared Namespace


DockableMultiConductor(T).Height Property

DockableMultiConductorTHeight Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Height { get; set; }
public:
virtual property double Height {
    double get () sealed;
    void set (double value) sealed;
}

Property Value

Type: Double

Implements

IDockableScreenHeight
See Also

Reference

DockableMultiConductorT Class
VisualComponents.UX.Shared Namespace


DockableMultiConductor(T).IsPinned Property

DockableMultiConductorTIsPinned Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsPinned { get; set; }
public:
virtual property bool IsPinned {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IDockableScreenIsPinned
See Also

Reference

DockableMultiConductorT Class
VisualComponents.UX.Shared Namespace


DockableMultiConductor(T).IsSelected Property

DockableMultiConductorTIsSelected Property

If true it will be selected in TabGroupPane

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsSelected { get; set; }
public:
virtual property bool IsSelected {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IDockableScreenIsSelected
See Also

Reference

DockableMultiConductorT Class
VisualComponents.UX.Shared Namespace


DockableMultiConductor(T).IsVisible Property

DockableMultiConductorTIsVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsVisible { get; set; }
public:
virtual property bool IsVisible {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IDockableScreenIsVisible
See Also

Reference

DockableMultiConductorT Class
VisualComponents.UX.Shared Namespace


DockableMultiConductor(T).PanelId Property

DockableMultiConductorTPanelId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string PanelId { get; set; }
public:
virtual property String^ PanelId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IDockableScreenPanelId
See Also

Reference

DockableMultiConductorT Class
VisualComponents.UX.Shared Namespace


DockableMultiConductor(T).PaneLocation Property

DockableMultiConductorTPaneLocation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DesiredPaneLocation PaneLocation { get; set; }
public:
virtual property DesiredPaneLocation PaneLocation {
    DesiredPaneLocation get () sealed;
    void set (DesiredPaneLocation value) sealed;
}

Property Value

Type: DesiredPaneLocation

Implements

IDockableScreenPaneLocation
See Also

Reference

DockableMultiConductorT Class
VisualComponents.UX.Shared Namespace


DockableMultiConductor(T).PaneOrientation Property

DockableMultiConductorTPaneOrientation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Orientation PaneOrientation { get; set; }
public:
virtual property Orientation PaneOrientation {
    Orientation get () sealed;
    void set (Orientation value) sealed;
}

Property Value

Type: Orientation

Implements

IDockableScreenPaneOrientation
See Also

Reference

DockableMultiConductorT Class
VisualComponents.UX.Shared Namespace


DockableMultiConductor(T).SplitPaneId Property

DockableMultiConductorTSplitPaneId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SplitPaneId { get; set; }
public:
virtual property String^ SplitPaneId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IDockableScreenSplitPaneId
See Also

Reference

DockableMultiConductorT Class
VisualComponents.UX.Shared Namespace


DockableMultiConductor(T).TabGroupId Property

DockableMultiConductorTTabGroupId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string TabGroupId { get; set; }
public:
virtual property String^ TabGroupId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IDockableScreenTabGroupId
See Also

Reference

DockableMultiConductorT Class
VisualComponents.UX.Shared Namespace


DockableMultiConductor(T).Width Property

DockableMultiConductorTWidth Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Width { get; set; }
public:
virtual property double Width {
    double get () sealed;
    void set (double value) sealed;
}

Property Value

Type: Double

Implements

IDockableScreenWidth
See Also

Reference

DockableMultiConductorT Class
VisualComponents.UX.Shared Namespace


DockableMultiConductor(T) Methods

DockableMultiConductorT Methods

The DockableMultiConductorT generic type exposes the following members.

Methods
 | Name | Description
Public method | ActivateItem | (Inherited from AllActive.)
Public method | CanClose | (Inherited from AllActive.)
Public method | DeactivateItem | (Inherited from AllActive.)
Protected method | EnsureItem | (Inherited from AllActive.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChildren | (Inherited from AllActive.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetView | (Inherited from ViewAware.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Protected method | OnActivate | (Inherited from AllActive.)
Protected method | OnActivationProcessed | (Inherited from ConductorBaseT .)
Protected method | OnDeactivate | (Inherited from AllActive.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnInitialize | (Inherited from AllActive.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Protected method | OnViewAttached | (Inherited from ViewAware.)
Protected method | OnViewLoaded | (Inherited from ViewAware.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryClose | (Inherited from Screen.)
Public method | TryClose(NullableBoolean) | (Inherited from Screen.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DockableMultiConductorT Class
VisualComponents.UX.Shared Namespace


DockableMultiConductor(T) Events

DockableMultiConductorT Events

The DockableMultiConductorT generic type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from Screen.)
Public event | ActivationProcessed | (Inherited from ConductorBaseT .)
Public event | AttemptingDeactivation | (Inherited from Screen.)
Public event | Deactivated | (Inherited from Screen.)
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Public event | ViewAttached | (Inherited from ViewAware.)
Top
See Also

Reference

DockableMultiConductorT Class
VisualComponents.UX.Shared Namespace


DockableMultiConductor(T) Fields

DockableMultiConductorT Fields

The DockableMultiConductorT generic type exposes the following members.

Fields
 | Name | Description
Protected field | Views | (Inherited from ViewAware.)
Top
See Also

Reference

DockableMultiConductorT Class
VisualComponents.UX.Shared Namespace


DockableScreen Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
ViewAware
Screen
VisualComponents.UX.SharedDockableScreen

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract class DockableScreen : Screen,
    IDockableScreen, IScreen, IHaveDisplayName, IActivate, IDeactivate,
    IGuardClose, IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public ref class DockableScreen abstract : public Screen,
    IDockableScreen, IScreen, IHaveDisplayName, IActivate, IDeactivate,
    IGuardClose, IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The DockableScreen type exposes the following members.

Constructors
 | Name | Description
Public method | DockableScreen | Initializes a new instance of the DockableScreen class
Top
Properties
 | Name | Description
Protected property | CacheViews | (Inherited from ViewAware.)
Public property | ContextFilter |
Public property | DesiredPanePosition | Desired position within the pane. This value determine the order panels
Public property | DisplayName | (Inherited from Screen.)
Public property | Height |
Public property | IsActive | (Inherited from Screen.)
Public property | IsInitialized | (Inherited from Screen.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsPinned |
Public property | IsSelected | If true it will be selected in TabGroupPane
Public property | IsVisible |
Public property | PanelId |
Public property | PaneLocation |
Public property | PaneOrientation |
Public property | Parent | (Inherited from Screen.)
Public property | SplitPaneId |
Public property | TabGroupId |
Public property | Width |
Top
Methods
 | Name | Description
Public method | CanClose | (Inherited from Screen.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetView | (Inherited from ViewAware.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Protected method | OnActivate | (Inherited from Screen.)
Protected method | OnDeactivate | (Inherited from Screen.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnInitialize | (Inherited from Screen.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Protected method | OnViewAttached | (Inherited from ViewAware.)
Protected method | OnViewLoaded | (Inherited from ViewAware.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryClose | (Inherited from Screen.)
Public method | TryClose(NullableBoolean) | (Inherited from Screen.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from Screen.)
Public event | AttemptingDeactivation | (Inherited from Screen.)
Public event | Deactivated | (Inherited from Screen.)
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Public event | ViewAttached | (Inherited from ViewAware.)
Top
Fields
 | Name | Description
Protected field | Views | (Inherited from ViewAware.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DockableScreen Constructor

Initializes a new instance of the DockableScreen class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DockableScreen()
public:
DockableScreen()
See Also

Reference

DockableScreen Class
VisualComponents.UX.Shared Namespace


DockableScreen Properties

The DockableScreen type exposes the following members.

Properties
 | Name | Description
Protected property | CacheViews | (Inherited from ViewAware.)
Public property | ContextFilter |
Public property | DesiredPanePosition | Desired position within the pane. This value determine the order panels
Public property | DisplayName | (Inherited from Screen.)
Public property | Height |
Public property | IsActive | (Inherited from Screen.)
Public property | IsInitialized | (Inherited from Screen.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsPinned |
Public property | IsSelected | If true it will be selected in TabGroupPane
Public property | IsVisible |
Public property | PanelId |
Public property | PaneLocation |
Public property | PaneOrientation |
Public property | Parent | (Inherited from Screen.)
Public property | SplitPaneId |
Public property | TabGroupId |
Public property | Width |
Top
See Also

Reference

DockableScreen Class
VisualComponents.UX.Shared Namespace


DockableScreen.ContextFilter Property

DockableScreenContextFilter Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ContextFilter { get; set; }
public:
virtual property String^ ContextFilter {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IDockableScreenContextFilter
See Also

Reference

DockableScreen Class
VisualComponents.UX.Shared Namespace


DockableScreen.DesiredPanePosition Property

DockableScreenDesiredPanePosition Property

Desired position within the pane. This value determine the order panels

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int DesiredPanePosition { get; set; }
public:
virtual property int DesiredPanePosition {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

IDockableScreenDesiredPanePosition
See Also

Reference

DockableScreen Class
VisualComponents.UX.Shared Namespace


DockableScreen.Height Property

DockableScreenHeight Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Height { get; set; }
public:
virtual property double Height {
    double get () sealed;
    void set (double value) sealed;
}

Property Value

Type: Double

Implements

IDockableScreenHeight
See Also

Reference

DockableScreen Class
VisualComponents.UX.Shared Namespace


DockableScreen.IsPinned Property

DockableScreenIsPinned Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsPinned { get; set; }
public:
virtual property bool IsPinned {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IDockableScreenIsPinned
See Also

Reference

DockableScreen Class
VisualComponents.UX.Shared Namespace


DockableScreen.IsSelected Property

DockableScreenIsSelected Property

If true it will be selected in TabGroupPane

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsSelected { get; set; }
public:
virtual property bool IsSelected {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IDockableScreenIsSelected
See Also

Reference

DockableScreen Class
VisualComponents.UX.Shared Namespace


DockableScreen.IsVisible Property

DockableScreenIsVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsVisible { get; set; }
public:
virtual property bool IsVisible {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IDockableScreenIsVisible
See Also

Reference

DockableScreen Class
VisualComponents.UX.Shared Namespace


DockableScreen.PanelId Property

DockableScreenPanelId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string PanelId { get; set; }
public:
virtual property String^ PanelId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IDockableScreenPanelId
See Also

Reference

DockableScreen Class
VisualComponents.UX.Shared Namespace


DockableScreen.PaneLocation Property

DockableScreenPaneLocation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DesiredPaneLocation PaneLocation { get; set; }
public:
virtual property DesiredPaneLocation PaneLocation {
    DesiredPaneLocation get () sealed;
    void set (DesiredPaneLocation value) sealed;
}

Property Value

Type: DesiredPaneLocation

Implements

IDockableScreenPaneLocation
See Also

Reference

DockableScreen Class
VisualComponents.UX.Shared Namespace


DockableScreen.PaneOrientation Property

DockableScreenPaneOrientation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Orientation PaneOrientation { get; set; }
public:
virtual property Orientation PaneOrientation {
    Orientation get () sealed;
    void set (Orientation value) sealed;
}

Property Value

Type: Orientation

Implements

IDockableScreenPaneOrientation
See Also

Reference

DockableScreen Class
VisualComponents.UX.Shared Namespace


DockableScreen.SplitPaneId Property

DockableScreenSplitPaneId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SplitPaneId { get; set; }
public:
virtual property String^ SplitPaneId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IDockableScreenSplitPaneId
See Also

Reference

DockableScreen Class
VisualComponents.UX.Shared Namespace


DockableScreen.TabGroupId Property

DockableScreenTabGroupId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string TabGroupId { get; set; }
public:
virtual property String^ TabGroupId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IDockableScreenTabGroupId
See Also

Reference

DockableScreen Class
VisualComponents.UX.Shared Namespace


DockableScreen.Width Property

DockableScreenWidth Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Width { get; set; }
public:
virtual property double Width {
    double get () sealed;
    void set (double value) sealed;
}

Property Value

Type: Double

Implements

IDockableScreenWidth
See Also

Reference

DockableScreen Class
VisualComponents.UX.Shared Namespace


DockableScreen Methods

The DockableScreen type exposes the following members.

Methods
 | Name | Description
Public method | CanClose | (Inherited from Screen.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetView | (Inherited from ViewAware.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Protected method | OnActivate | (Inherited from Screen.)
Protected method | OnDeactivate | (Inherited from Screen.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnInitialize | (Inherited from Screen.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Protected method | OnViewAttached | (Inherited from ViewAware.)
Protected method | OnViewLoaded | (Inherited from ViewAware.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryClose | (Inherited from Screen.)
Public method | TryClose(NullableBoolean) | (Inherited from Screen.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DockableScreen Class
VisualComponents.UX.Shared Namespace


DockableScreen Events

The DockableScreen type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from Screen.)
Public event | AttemptingDeactivation | (Inherited from Screen.)
Public event | Deactivated | (Inherited from Screen.)
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Public event | ViewAttached | (Inherited from ViewAware.)
Top
See Also

Reference

DockableScreen Class
VisualComponents.UX.Shared Namespace


DockableScreen Fields

The DockableScreen type exposes the following members.

Fields
 | Name | Description
Protected field | Views | (Inherited from ViewAware.)
Top
See Also

Reference

DockableScreen Class
VisualComponents.UX.Shared Namespace


DockAwareWindowManager Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedDockAwareWindowManager

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class DockAwareWindowManager
public ref class DockAwareWindowManager abstract sealed

The DockAwareWindowManager type exposes the following members.

Fields
Name | Description
CustomLayoutFileName | File pattern used for users custom docking pane layout configuration file stored in isolated storage.
DefaultLayoutFileName | File pattern used for default docking pane layout configuration file stored in isolated storage.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DockAwareWindowManager Fields

The DockAwareWindowManager type exposes the following members.

Fields
Name | Description
CustomLayoutFileName | File pattern used for users custom docking pane layout configuration file stored in isolated storage.
DefaultLayoutFileName | File pattern used for default docking pane layout configuration file stored in isolated storage.
Top
See Also

Reference

DockAwareWindowManager Class
VisualComponents.UX.Shared Namespace


DockAwareWindowManager.CustomLayoutFileName Field

DockAwareWindowManagerCustomLayoutFileName Field

File pattern used for users custom docking pane layout configuration file stored in isolated storage.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string CustomLayoutFileName = "UserLayout_{0}.xml"
public:
literal String^ CustomLayoutFileName = "UserLayout_{0}.xml"

Field Value

Type: String
See Also

Reference

DockAwareWindowManager Class
VisualComponents.UX.Shared Namespace


DockAwareWindowManager.DefaultLayoutFileName Field

DockAwareWindowManagerDefaultLayoutFileName Field

File pattern used for default docking pane layout configuration file stored in isolated storage.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string DefaultLayoutFileName = "DefaultLayout_{0}.xml"
public:
literal String^ DefaultLayoutFileName = "DefaultLayout_{0}.xml"

Field Value

Type: String
See Also

Reference

DockAwareWindowManager Class
VisualComponents.UX.Shared Namespace


DockManagerPane Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum DockManagerPane
public enum class DockManagerPane
Members
Member name | Value | Description
OutPutPane | 0 |
ComponentEditorPane | 1 |
ECataloguePane | 2 |
ManipulatePane | 3 |
Treeview | 4 |
See Also

Reference

VisualComponents.UX.Shared Namespace


DOFEditorView Class

Interaction logic for DOFEditorView.xaml
DOFEditorView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedDOFEditorView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class DOFEditorView : UserControl,
    IComponentConnector
public ref class DOFEditorView : public UserControl,
    IComponentConnector

The DOFEditorView type exposes the following members.

Constructors
 | Name | Description
Public method | DOFEditorView | Initializes a new instance of the DOFEditorView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DOFEditorView Constructor

Initializes a new instance of the DOFEditorView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DOFEditorView()
public:
DOFEditorView()
See Also

Reference

DOFEditorView Class
VisualComponents.UX.Shared Namespace


DOFEditorView Properties

The DOFEditorView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DOFEditorView Class
VisualComponents.UX.Shared Namespace


DOFEditorView Methods

The DOFEditorView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DOFEditorView Class
VisualComponents.UX.Shared Namespace


DOFEditorView.InitializeComponent Method

DOFEditorViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

DOFEditorView Class
VisualComponents.UX.Shared Namespace


DOFEditorView Events

The DOFEditorView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

DOFEditorView Class
VisualComponents.UX.Shared Namespace


DoubleParsingExceptionValidationRule Class

Inheritance Hierarchy
SystemObject
System.Windows.ControlsValidationRule
VisualComponents.UX.SharedDoubleParsingExceptionValidationRule

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class DoubleParsingExceptionValidationRule : ValidationRule
public ref class DoubleParsingExceptionValidationRule : public ValidationRule

The DoubleParsingExceptionValidationRule type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleParsingExceptionValidationRule | Initializes a new instance of the DoubleParsingExceptionValidationRule class
Top
Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DoubleParsingExceptionValidationRule Constructor

Initializes a new instance of the DoubleParsingExceptionValidationRule class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DoubleParsingExceptionValidationRule()
public:
DoubleParsingExceptionValidationRule()
See Also

Reference

DoubleParsingExceptionValidationRule Class
VisualComponents.UX.Shared Namespace


DoubleParsingExceptionValidationRule Properties

The DoubleParsingExceptionValidationRule type exposes the following members.

Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
See Also

Reference

DoubleParsingExceptionValidationRule Class
VisualComponents.UX.Shared Namespace


DoubleParsingExceptionValidationRule Methods

The DoubleParsingExceptionValidationRule type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DoubleParsingExceptionValidationRule Class
VisualComponents.UX.Shared Namespace


DoubleParsingExceptionValidationRule.Validate Method

DoubleParsingExceptionValidationRuleValidate Method

Overload List
 | Name | Description
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
See Also

Reference

DoubleParsingExceptionValidationRule Class
VisualComponents.UX.Shared Namespace


DoubleParsingExceptionValidationRule.Validate Method (Object, CultureInfo)

DoubleParsingExceptionValidationRuleValidate Method (Object, CultureInfo)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override ValidationResult Validate(
    Object value,
    CultureInfo cultureInfo
)
public:
virtual ValidationResult^ Validate(
    Object^ value,
    CultureInfo^ cultureInfo
) override

Parameters

value
Type: SystemObject
cultureInfo
Type: System.GlobalizationCultureInfo

Return Value

Type: ValidationResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.DoubleParsingExceptionValidationRule.Validate(System.Object,System.Globalization.CultureInfo)"]

See Also

Reference

DoubleParsingExceptionValidationRule Class
Validate Overload
VisualComponents.UX.Shared Namespace


DoubleToPropertyEditorWidthConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedDoubleToPropertyEditorWidthConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class DoubleToPropertyEditorWidthConverter : IMultiValueConverter
public ref class DoubleToPropertyEditorWidthConverter : IMultiValueConverter

The DoubleToPropertyEditorWidthConverter type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleToPropertyEditorWidthConverter | Initializes a new instance of the DoubleToPropertyEditorWidthConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DoubleToPropertyEditorWidthConverter Constructor

Initializes a new instance of the DoubleToPropertyEditorWidthConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DoubleToPropertyEditorWidthConverter()
public:
DoubleToPropertyEditorWidthConverter()
See Also

Reference

DoubleToPropertyEditorWidthConverter Class
VisualComponents.UX.Shared Namespace


DoubleToPropertyEditorWidthConverter Methods

The DoubleToPropertyEditorWidthConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DoubleToPropertyEditorWidthConverter Class
VisualComponents.UX.Shared Namespace


DoubleToPropertyEditorWidthConverter.Convert Method

DoubleToPropertyEditorWidthConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    array<Object^>^ values,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

values
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.DoubleToPropertyEditorWidthConverter.Convert(System.Object[],System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

DoubleToPropertyEditorWidthConverter Class
VisualComponents.UX.Shared Namespace


DoubleToPropertyEditorWidthConverter.ConvertBack Method

DoubleToPropertyEditorWidthConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
public:
virtual array<Object^>^ ConvertBack(
    Object^ value,
    array<Type^>^ targetTypes,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetTypes
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.DoubleToPropertyEditorWidthConverter.ConvertBack(System.Object,System.Type[],System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

DoubleToPropertyEditorWidthConverter Class
VisualComponents.UX.Shared Namespace


DoubleValidationRule Class

Inheritance Hierarchy
SystemObject
System.Windows.ControlsValidationRule
VisualComponents.UX.SharedDoubleValidationRule

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class DoubleValidationRule : ValidationRule
public ref class DoubleValidationRule : public ValidationRule

The DoubleValidationRule type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleValidationRule | Initializes a new instance of the DoubleValidationRule class
Top
Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DoubleValidationRule Constructor

Initializes a new instance of the DoubleValidationRule class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DoubleValidationRule()
public:
DoubleValidationRule()
See Also

Reference

DoubleValidationRule Class
VisualComponents.UX.Shared Namespace


DoubleValidationRule Properties

The DoubleValidationRule type exposes the following members.

Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
See Also

Reference

DoubleValidationRule Class
VisualComponents.UX.Shared Namespace


DoubleValidationRule Methods

The DoubleValidationRule type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DoubleValidationRule Class
VisualComponents.UX.Shared Namespace


DoubleValidationRule.Validate Method

DoubleValidationRuleValidate Method

Overload List
 | Name | Description
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
See Also

Reference

DoubleValidationRule Class
VisualComponents.UX.Shared Namespace


DoubleValidationRule.Validate Method (Object, CultureInfo)

DoubleValidationRuleValidate Method (Object, CultureInfo)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override ValidationResult Validate(
    Object value,
    CultureInfo cultureInfo
)
public:
virtual ValidationResult^ Validate(
    Object^ value,
    CultureInfo^ cultureInfo
) override

Parameters

value
Type: SystemObject
cultureInfo
Type: System.GlobalizationCultureInfo

Return Value

Type: ValidationResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.DoubleValidationRule.Validate(System.Object,System.Globalization.CultureInfo)"]

See Also

Reference

DoubleValidationRule Class
Validate Overload
VisualComponents.UX.Shared Namespace


DragAdornerVisualEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.UX.SharedDragAdornerVisualEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class DragAdornerVisualEventArgs : EventArgs
public ref class DragAdornerVisualEventArgs : public EventArgs

The DragAdornerVisualEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DragAdornerVisualEventArgs | Initializes a new instance of the DragAdornerVisualEventArgs class
Top
Properties
 | Name | Description
Public property | Handled |
Public property | RenderingFinishedAction |
Public property | SourceVisual |
Public property | SourceVisualOffset |
Public property | Visual |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DragAdornerVisualEventArgs Constructor

Initializes a new instance of the DragAdornerVisualEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DragAdornerVisualEventArgs(
    FrameworkElement sourceVisual
)
public:
DragAdornerVisualEventArgs(
    FrameworkElement^ sourceVisual
)

Parameters

sourceVisual
Type: System.WindowsFrameworkElement
See Also

Reference

DragAdornerVisualEventArgs Class
VisualComponents.UX.Shared Namespace


DragAdornerVisualEventArgs Properties

The DragAdornerVisualEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Handled |
Public property | RenderingFinishedAction |
Public property | SourceVisual |
Public property | SourceVisualOffset |
Public property | Visual |
Top
See Also

Reference

DragAdornerVisualEventArgs Class
VisualComponents.UX.Shared Namespace


DragAdornerVisualEventArgs.Handled Property

DragAdornerVisualEventArgsHandled Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Handled { get; set; }
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DragAdornerVisualEventArgs Class
VisualComponents.UX.Shared Namespace


DragAdornerVisualEventArgs.RenderingFinishedAction Property

DragAdornerVisualEventArgsRenderingFinishedAction Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Action RenderingFinishedAction { get; set; }
public:
property Action^ RenderingFinishedAction {
    Action^ get ();
    void set (Action^ value);
}

Property Value

Type: Action
See Also

Reference

DragAdornerVisualEventArgs Class
VisualComponents.UX.Shared Namespace


DragAdornerVisualEventArgs.SourceVisual Property

DragAdornerVisualEventArgsSourceVisual Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FrameworkElement SourceVisual { get; set; }
public:
property FrameworkElement^ SourceVisual {
    FrameworkElement^ get ();
    void set (FrameworkElement^ value);
}

Property Value

Type: FrameworkElement
See Also

Reference

DragAdornerVisualEventArgs Class
VisualComponents.UX.Shared Namespace


DragAdornerVisualEventArgs.SourceVisualOffset Property

DragAdornerVisualEventArgsSourceVisualOffset Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Thickness SourceVisualOffset { get; set; }
public:
property Thickness SourceVisualOffset {
    Thickness get ();
    void set (Thickness value);
}

Property Value

Type: Thickness
See Also

Reference

DragAdornerVisualEventArgs Class
VisualComponents.UX.Shared Namespace


DragAdornerVisualEventArgs.Visual Property

DragAdornerVisualEventArgsVisual Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FrameworkElement Visual { get; set; }
public:
property FrameworkElement^ Visual {
    FrameworkElement^ get ();
    void set (FrameworkElement^ value);
}

Property Value

Type: FrameworkElement
See Also

Reference

DragAdornerVisualEventArgs Class
VisualComponents.UX.Shared Namespace


DragAdornerVisualEventArgs Methods

The DragAdornerVisualEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DragAdornerVisualEventArgs Class
VisualComponents.UX.Shared Namespace


DrawingViewPoints Enumeration

Available drawing view points

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum DrawingViewPoints
public enum class DrawingViewPoints
Members
Member name | Value | Description
Top | 0 |
Down | 1 |
Front | 2 |
Back | 3 |
Left | 4 |
Right | 5 |
Current | 6 |
See Also

Reference

VisualComponents.UX.Shared Namespace


DropEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.UX.SharedDropEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class DropEventArgs : EventArgs
public ref class DropEventArgs : public EventArgs

The DropEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DropEventArgs(DragDropEffects) | Initializes a new instance of the DropEventArgs class
Public method | DropEventArgs(DragDropEffects, IDataObject) | Initializes a new instance of the DropEventArgs class
Public method | DropEventArgs(IList, IDataObject, Int32, Boolean, Boolean, DragDropEffects, DragDropEffects, Point) | Initializes a new instance of the DropEventArgs class
Top
Properties
 | Name | Description
Public property | AdjustIndex |
Public property | AllowedEffects |
Public property | CloneItems |
Public property | Data |
Public property | Effects |
Public property | Handled |
Public property | Index |
Public property | ItemCursorPosition |
Public property | ItemsSource |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DropEventArgs Constructor

Overload List
 | Name | Description
Public method | DropEventArgs(DragDropEffects) | Initializes a new instance of the DropEventArgs class
Public method | DropEventArgs(DragDropEffects, IDataObject) | Initializes a new instance of the DropEventArgs class
Public method | DropEventArgs(IList, IDataObject, Int32, Boolean, Boolean, DragDropEffects, DragDropEffects, Point) | Initializes a new instance of the DropEventArgs class
Top
See Also

Reference

DropEventArgs Class
VisualComponents.UX.Shared Namespace


DropEventArgs Constructor (DragDropEffects)

Initializes a new instance of the DropEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DropEventArgs(
    DragDropEffects effects
)
public:
DropEventArgs(
    DragDropEffects effects
)

Parameters

effects
Type: System.WindowsDragDropEffects
See Also

Reference

DropEventArgs Class
DropEventArgs Overload
VisualComponents.UX.Shared Namespace


DropEventArgs Constructor (DragDropEffects, IDataObject)

Initializes a new instance of the DropEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DropEventArgs(
    DragDropEffects effects,
    IDataObject data
)
public:
DropEventArgs(
    DragDropEffects effects,
    IDataObject^ data
)

Parameters

effects
Type: System.WindowsDragDropEffects
data
Type: System.WindowsIDataObject
See Also

Reference

DropEventArgs Class
DropEventArgs Overload
VisualComponents.UX.Shared Namespace


DropEventArgs Constructor (IList, IDataObject, Int32, Boolean, Boolean, DragDropEffects, DragDropEffects, Point)

Initializes a new instance of the DropEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DropEventArgs(
    IList itemsSource,
    IDataObject data,
    int index,
    bool adjustIndex,
    bool cloneItems,
    DragDropEffects allowedEffects,
    DragDropEffects effects,
    Point itemCursorPosition
)
public:
DropEventArgs(
    IList^ itemsSource,
    IDataObject^ data,
    int index,
    bool adjustIndex,
    bool cloneItems,
    DragDropEffects allowedEffects,
    DragDropEffects effects,
    Point itemCursorPosition
)

Parameters

itemsSource
Type: System.CollectionsIList
data
Type: System.WindowsIDataObject
index
Type: SystemInt32
adjustIndex
Type: SystemBoolean
cloneItems
Type: SystemBoolean
allowedEffects
Type: System.WindowsDragDropEffects
effects
Type: System.WindowsDragDropEffects
itemCursorPosition
Type: System.WindowsPoint
See Also

Reference

DropEventArgs Class
DropEventArgs Overload
VisualComponents.UX.Shared Namespace


DropEventArgs Properties

The DropEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | AdjustIndex |
Public property | AllowedEffects |
Public property | CloneItems |
Public property | Data |
Public property | Effects |
Public property | Handled |
Public property | Index |
Public property | ItemCursorPosition |
Public property | ItemsSource |
Top
See Also

Reference

DropEventArgs Class
VisualComponents.UX.Shared Namespace


DropEventArgs.AdjustIndex Property

DropEventArgsAdjustIndex Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool AdjustIndex { get; }
public:
property bool AdjustIndex {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DropEventArgs Class
VisualComponents.UX.Shared Namespace


DropEventArgs.AllowedEffects Property

DropEventArgsAllowedEffects Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DragDropEffects AllowedEffects { get; }
public:
property DragDropEffects AllowedEffects {
    DragDropEffects get ();
}

Property Value

Type: DragDropEffects
See Also

Reference

DropEventArgs Class
VisualComponents.UX.Shared Namespace


DropEventArgs.CloneItems Property

DropEventArgsCloneItems Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CloneItems { get; }
public:
property bool CloneItems {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DropEventArgs Class
VisualComponents.UX.Shared Namespace


DropEventArgs.Data Property

DropEventArgsData Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IDataObject Data { get; }
public:
property IDataObject^ Data {
    IDataObject^ get ();
}

Property Value

Type: IDataObject
See Also

Reference

DropEventArgs Class
VisualComponents.UX.Shared Namespace


DropEventArgs.Effects Property

DropEventArgsEffects Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DragDropEffects Effects { get; set; }
public:
property DragDropEffects Effects {
    DragDropEffects get ();
    void set (DragDropEffects value);
}

Property Value

Type: DragDropEffects
See Also

Reference

DropEventArgs Class
VisualComponents.UX.Shared Namespace


DropEventArgs.Handled Property

DropEventArgsHandled Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Handled { get; set; }
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DropEventArgs Class
VisualComponents.UX.Shared Namespace


DropEventArgs.Index Property

DropEventArgsIndex Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Index { get; }
public:
property int Index {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DropEventArgs Class
VisualComponents.UX.Shared Namespace


DropEventArgs.ItemCursorPosition Property

DropEventArgsItemCursorPosition Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Point ItemCursorPosition { get; }
public:
property Point ItemCursorPosition {
    Point get ();
}

Property Value

Type: Point
See Also

Reference

DropEventArgs Class
VisualComponents.UX.Shared Namespace


DropEventArgs.ItemsSource Property

DropEventArgsItemsSource Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList ItemsSource { get; }
public:
property IList^ ItemsSource {
    IList^ get ();
}

Property Value

Type: IList
See Also

Reference

DropEventArgs Class
VisualComponents.UX.Shared Namespace


DropEventArgs Methods

The DropEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DropEventArgs Class
VisualComponents.UX.Shared Namespace


DropIndicator Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
VisualComponents.UX.SharedDropIndicator

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class DropIndicator : Control
public ref class DropIndicator : public Control

The DropIndicator type exposes the following members.

Constructors
 | Name | Description
Public method | DropIndicator | Initializes a new instance of the DropIndicator class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


DropIndicator Constructor

Initializes a new instance of the DropIndicator class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DropIndicator()
public:
DropIndicator()
See Also

Reference

DropIndicator Class
VisualComponents.UX.Shared Namespace


DropIndicator Properties

The DropIndicator type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

DropIndicator Class
VisualComponents.UX.Shared Namespace


DropIndicator Methods

The DropIndicator type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

DropIndicator Class
VisualComponents.UX.Shared Namespace


DropIndicator Events

The DropIndicator type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

DropIndicator Class
VisualComponents.UX.Shared Namespace


DropType Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum DropType
public enum class DropType
Members
Member name | Value | Description
Before | 0 |
Onto | 1 |
After | 2 |
ToFirst | 3 |
ToLast | 4 |
See Also

Reference

VisualComponents.UX.Shared Namespace


eCatGroupBoxWidthConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedeCatGroupBoxWidthConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class eCatGroupBoxWidthConverter : IMultiValueConverter
public ref class eCatGroupBoxWidthConverter : IMultiValueConverter

The eCatGroupBoxWidthConverter type exposes the following members.

Constructors
 | Name | Description
Public method | eCatGroupBoxWidthConverter | Initializes a new instance of the eCatGroupBoxWidthConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


eCatGroupBoxWidthConverter Constructor

Initializes a new instance of the eCatGroupBoxWidthConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public eCatGroupBoxWidthConverter()
public:
eCatGroupBoxWidthConverter()
See Also

Reference

eCatGroupBoxWidthConverter Class
VisualComponents.UX.Shared Namespace


eCatGroupBoxWidthConverter Methods

The eCatGroupBoxWidthConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

eCatGroupBoxWidthConverter Class
VisualComponents.UX.Shared Namespace


eCatGroupBoxWidthConverter.Convert Method

eCatGroupBoxWidthConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    array<Object^>^ values,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

values
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.eCatGroupBoxWidthConverter.Convert(System.Object[],System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

eCatGroupBoxWidthConverter Class
VisualComponents.UX.Shared Namespace


eCatGroupBoxWidthConverter.ConvertBack Method

eCatGroupBoxWidthConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
public:
virtual array<Object^>^ ConvertBack(
    Object^ value,
    array<Type^>^ targetTypes,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetTypes
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.eCatGroupBoxWidthConverter.ConvertBack(System.Object,System.Type[],System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

eCatGroupBoxWidthConverter Class
VisualComponents.UX.Shared Namespace


EditableLabel Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsLabel
VisualComponents.UX.SharedEditableLabel

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class EditableLabel : Label
public ref class EditableLabel : public Label

The EditableLabel type exposes the following members.

Constructors
 | Name | Description
Public method | EditableLabel | Initializes a new instance of the EditableLabel class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Target | Gets or sets the element that receives focus when the user presses the label's access key. (Inherited from Label.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | (Overrides ContentControlOnContentChanged(Object, Object).)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Provides an appropriate LabelAutomationPeer implementation for this control, as part of the WPF infrastructure. (Inherited from Label.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | (Overrides FrameworkElementOnGotFocus(RoutedEventArgs).)
Protected method | OnGotKeyboardFocus | (Overrides UIElementOnGotKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | (Overrides UIElementOnLostFocus(RoutedEventArgs).)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | (Overrides ControlOnMouseDoubleClick(MouseButtonEventArgs).)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContentChanged |
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


EditableLabel Constructor

Initializes a new instance of the EditableLabel class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EditableLabel()
public:
EditableLabel()
See Also

Reference

EditableLabel Class
VisualComponents.UX.Shared Namespace


EditableLabel Properties

The EditableLabel type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Target | Gets or sets the element that receives focus when the user presses the label's access key. (Inherited from Label.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

EditableLabel Class
VisualComponents.UX.Shared Namespace


EditableLabel Methods

The EditableLabel type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | (Overrides ContentControlOnContentChanged(Object, Object).)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Provides an appropriate LabelAutomationPeer implementation for this control, as part of the WPF infrastructure. (Inherited from Label.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | (Overrides FrameworkElementOnGotFocus(RoutedEventArgs).)
Protected method | OnGotKeyboardFocus | (Overrides UIElementOnGotKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | (Overrides UIElementOnLostFocus(RoutedEventArgs).)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | (Overrides ControlOnMouseDoubleClick(MouseButtonEventArgs).)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

EditableLabel Class
VisualComponents.UX.Shared Namespace


EditableLabel.OnApplyTemplate Method

EditableLabelOnApplyTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

EditableLabel Class
VisualComponents.UX.Shared Namespace


EditableLabel.OnContentChanged Method

EditableLabelOnContentChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnContentChanged(
    Object oldContent,
    Object newContent
)
protected:
virtual void OnContentChanged(
    Object^ oldContent,
    Object^ newContent
) override

Parameters

oldContent
Type: SystemObject
newContent
Type: SystemObject
See Also

Reference

EditableLabel Class
VisualComponents.UX.Shared Namespace


EditableLabel.OnGotFocus Method

EditableLabelOnGotFocus Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
protected:
virtual void OnGotFocus(
    RoutedEventArgs^ e
) override

Parameters

e
Type: System.WindowsRoutedEventArgs
See Also

Reference

EditableLabel Class
VisualComponents.UX.Shared Namespace


EditableLabel.OnGotKeyboardFocus Method

EditableLabelOnGotKeyboardFocus Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnGotKeyboardFocus(
    KeyboardFocusChangedEventArgs e
)
protected:
virtual void OnGotKeyboardFocus(
    KeyboardFocusChangedEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputKeyboardFocusChangedEventArgs
See Also

Reference

EditableLabel Class
VisualComponents.UX.Shared Namespace


EditableLabel.OnLostFocus Method

EditableLabelOnLostFocus Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnLostFocus(
    RoutedEventArgs e
)
protected:
virtual void OnLostFocus(
    RoutedEventArgs^ e
) override

Parameters

e
Type: System.WindowsRoutedEventArgs
See Also

Reference

EditableLabel Class
VisualComponents.UX.Shared Namespace


EditableLabel.OnMouseDoubleClick Method

EditableLabelOnMouseDoubleClick Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnMouseDoubleClick(
    MouseButtonEventArgs e
)
protected:
virtual void OnMouseDoubleClick(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
See Also

Reference

EditableLabel Class
VisualComponents.UX.Shared Namespace


EditableLabel Events

The EditableLabel type exposes the following members.

Events
 | Name | Description
Public event | ContentChanged |
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

EditableLabel Class
VisualComponents.UX.Shared Namespace


EditableLabel.ContentChanged Event

EditableLabelContentChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler ContentChanged
public:
 event EventHandler^ ContentChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

EditableLabel Class
VisualComponents.UX.Shared Namespace


EditableTextBlock Class

EditableTextBlock
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedEditableTextBlock

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class EditableTextBlock : UserControl,
    INotifyPropertyChanged, IComponentConnector, IStyleConnector
public ref class EditableTextBlock : public UserControl,
    INotifyPropertyChanged, IComponentConnector, IStyleConnector

The EditableTextBlock type exposes the following members.

Constructors
 | Name | Description
Public method | EditableTextBlock | Initializes a new instance of the EditableTextBlock class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanResizeWhileEditing |
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | FormattedText |
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEditable |
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInEditMode |
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | ProxyText |
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text |
Public property | TextFormat |
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContentChanged |
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PropertyChanged |
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
CanResizeWhileEditingProperty |
IsEditableProperty |
IsInEditModeProperty |
ProxyTextProperty |
TextFormatProperty |
TextProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


EditableTextBlock Constructor

Initializes a new instance of the EditableTextBlock class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EditableTextBlock()
public:
EditableTextBlock()
See Also

Reference

EditableTextBlock Class
VisualComponents.UX.Shared Namespace


EditableTextBlock Properties

The EditableTextBlock type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanResizeWhileEditing |
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | FormattedText |
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEditable |
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInEditMode |
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | ProxyText |
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text |
Public property | TextFormat |
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

EditableTextBlock Class
VisualComponents.UX.Shared Namespace


EditableTextBlock.CanResizeWhileEditing Property

EditableTextBlockCanResizeWhileEditing Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanResizeWhileEditing { get; set; }
public:
property bool CanResizeWhileEditing {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

EditableTextBlock Class
VisualComponents.UX.Shared Namespace


EditableTextBlock.FormattedText Property

EditableTextBlockFormattedText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string FormattedText { get; }
public:
property String^ FormattedText {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

EditableTextBlock Class
VisualComponents.UX.Shared Namespace


EditableTextBlock.IsEditable Property

EditableTextBlockIsEditable Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsEditable { get; set; }
public:
property bool IsEditable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

EditableTextBlock Class
VisualComponents.UX.Shared Namespace


EditableTextBlock.IsInEditMode Property

EditableTextBlockIsInEditMode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsInEditMode { get; set; }
public:
property bool IsInEditMode {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

EditableTextBlock Class
VisualComponents.UX.Shared Namespace


EditableTextBlock.ProxyText Property

EditableTextBlockProxyText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ProxyText { get; set; }
public:
property String^ ProxyText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

EditableTextBlock Class
VisualComponents.UX.Shared Namespace


EditableTextBlock.Text Property

EditableTextBlockText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Text { get; set; }
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

EditableTextBlock Class
VisualComponents.UX.Shared Namespace


EditableTextBlock.TextFormat Property

EditableTextBlockTextFormat Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string TextFormat { get; set; }
public:
property String^ TextFormat {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

EditableTextBlock Class
VisualComponents.UX.Shared Namespace


EditableTextBlock Methods

The EditableTextBlock type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

EditableTextBlock Class
VisualComponents.UX.Shared Namespace


EditableTextBlock.InitializeComponent Method

EditableTextBlockInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

EditableTextBlock Class
VisualComponents.UX.Shared Namespace


EditableTextBlock Events

The EditableTextBlock type exposes the following members.

Events
 | Name | Description
Public event | ContentChanged |
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PropertyChanged |
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

EditableTextBlock Class
VisualComponents.UX.Shared Namespace


EditableTextBlock.ContentChanged Event

EditableTextBlockContentChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ContentTextChangedEventArgs> ContentChanged
public:
 event EventHandler<ContentTextChangedEventArgs^>^ ContentChanged {
    void add (EventHandler<ContentTextChangedEventArgs^>^ value);
    void remove (EventHandler<ContentTextChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerContentTextChangedEventArgs
See Also

Reference

EditableTextBlock Class
VisualComponents.UX.Shared Namespace


EditableTextBlock.PropertyChanged Event

EditableTextBlockPropertyChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event PropertyChangedEventHandler PropertyChanged
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

EditableTextBlock Class
VisualComponents.UX.Shared Namespace


EditableTextBlock Fields

The EditableTextBlock type exposes the following members.

Fields
Name | Description
CanResizeWhileEditingProperty |
IsEditableProperty |
IsInEditModeProperty |
ProxyTextProperty |
TextFormatProperty |
TextProperty |
Top
See Also

Reference

EditableTextBlock Class
VisualComponents.UX.Shared Namespace


EditableTextBlock.CanResizeWhileEditingProperty Field

EditableTextBlockCanResizeWhileEditingProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty CanResizeWhileEditingProperty
public:
static initonly DependencyProperty^ CanResizeWhileEditingProperty

Field Value

Type: DependencyProperty
See Also

Reference

EditableTextBlock Class
VisualComponents.UX.Shared Namespace


EditableTextBlock.IsEditableProperty Field

EditableTextBlockIsEditableProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsEditableProperty
public:
static initonly DependencyProperty^ IsEditableProperty

Field Value

Type: DependencyProperty
See Also

Reference

EditableTextBlock Class
VisualComponents.UX.Shared Namespace


EditableTextBlock.IsInEditModeProperty Field

EditableTextBlockIsInEditModeProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsInEditModeProperty
public:
static initonly DependencyProperty^ IsInEditModeProperty

Field Value

Type: DependencyProperty
See Also

Reference

EditableTextBlock Class
VisualComponents.UX.Shared Namespace


EditableTextBlock.ProxyTextProperty Field

EditableTextBlockProxyTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ProxyTextProperty
public:
static initonly DependencyProperty^ ProxyTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

EditableTextBlock Class
VisualComponents.UX.Shared Namespace


EditableTextBlock.TextFormatProperty Field

EditableTextBlockTextFormatProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty TextFormatProperty
public:
static initonly DependencyProperty^ TextFormatProperty

Field Value

Type: DependencyProperty
See Also

Reference

EditableTextBlock Class
VisualComponents.UX.Shared Namespace


EditableTextBlock.TextProperty Field

EditableTextBlockTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty TextProperty
public:
static initonly DependencyProperty^ TextProperty

Field Value

Type: DependencyProperty
See Also

Reference

EditableTextBlock Class
VisualComponents.UX.Shared Namespace


EditBox Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.Controls.PrimitivesTextBoxBase
System.Windows.ControlsTextBox
VisualComponents.UX.SharedEditBox

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class EditBox : TextBox
public ref class EditBox : public TextBox

The EditBox type exposes the following members.

Constructors
 | Name | Description
Public method | EditBox | Initializes a new instance of the EditBox class
Top
Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key. (Inherited from TextBoxBase.)
Public property | AcceptsTab | Gets or sets a value that indicates how the text editing control responds when the user presses the TAB key. (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoWordSelection | Gets or sets a value that determines whether when a user selects part of a word by dragging across it with the mouse, the rest of the word is selected. (Inherited from TextBoxBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanRedo | Gets a value that indicates whether the most recent undo action can be redone. (Inherited from TextBoxBase.)
Public property | CanUndo | Gets a value that indicates whether the most recent action can be undone. (Inherited from TextBoxBase.)
Public property | CaretBrush | Gets or sets the brush that is used to paint the caret of the text box. (Inherited from TextBoxBase.)
Public property | CaretIndex | Gets or sets the insertion position index of the caret. (Inherited from TextBox.)
Public property | CharacterCasing | Gets or sets how characters are cased when they are manually entered into the text box. (Inherited from TextBox.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExtentHeight | Gets the vertical size of the visible content area. (Inherited from TextBoxBase.)
Public property | ExtentWidth | Gets the horizontal size of the visible content area. (Inherited from TextBoxBase.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Gets or sets the horizontal scroll position. (Inherited from TextBoxBase.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal scroll bar is shown. (Inherited from TextBoxBase.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInactiveSelectionHighlightEnabled | Gets or sets a value that indicates whether the text box displays selected text when the text box does not have focus. (Inherited from TextBoxBase.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that indicates whether the text editing control is read-only to a user interacting with the control. (Inherited from TextBoxBase.)
Public property | IsReadOnlyCaretVisible | Gets or sets a value that indicates whether a read-only text box displays a caret. (Inherited from TextBoxBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionActive | Gets a value that indicates whether the text box has focus and selected text. (Inherited from TextBoxBase.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets a value that indicates whether undo support is enabled for the text-editing control. (Inherited from TextBoxBase.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Item |
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | LineCount | Gets the total number of lines in the text box. (Inherited from TextBox.)
Protected property | LogicalChildren | Gets an enumerator for the logical child elements of the TextBox. (Inherited from TextBox.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxLength | Gets or sets the maximum number of characters that can be manually entered into the text box. (Inherited from TextBox.)
Public property | MaxLines | Gets or sets the maximum number of visible lines. (Inherited from TextBox.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinLines | Gets or sets the minimum number of visible lines. (Inherited from TextBox.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Node |
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedText | Gets or sets the content of the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionBrush | Gets or sets the brush that highlights selected text. (Inherited from TextBoxBase.)
Public property | SelectionLength | Gets or sets a value indicating the number of characters in the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionOpacity | Gets or sets the opacity of the SelectionBrush. (Inherited from TextBoxBase.)
Public property | SelectionStart | Gets or sets a character index for the beginning of the current selection. (Inherited from TextBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | SpellCheck | Gets a SpellCheck object that provides access to spelling errors in the text contents of a TextBoxBase or RichTextBox. (Inherited from TextBoxBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Gets or sets the text contents of the text box. (Inherited from TextBox.)
Public property | TextAlignment | Gets or sets the horizontal alignment of the contents of the text box. (Inherited from TextBox.)
Public property | TextDecorations | Gets the text decorations to apply to the text box. (Inherited from TextBox.)
Public property | TextWrapping | Gets or sets how the text box should wrap text. (Inherited from TextBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Typography | Gets the currently effective typography variations for the text contents of the text box. (Inherited from TextBox.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UndoLimit | Gets or sets the number of actions stored in the undo queue. (Inherited from TextBoxBase.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Gets or sets the vertical scroll position. (Inherited from TextBoxBase.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical scroll bar is shown. (Inherited from TextBoxBase.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | ViewportHeight | Gets the vertical size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | ViewportWidth | Gets the horizontal size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AppendText | Appends a string to the contents of a text control. (Inherited from TextBoxBase.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginChange | Begins a change block. (Inherited from TextBoxBase.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | Clears all the content from the text box. (Inherited from TextBox.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Copy | Copies the current selection of the text editing control to the Clipboard. (Inherited from TextBoxBase.)
Public method | Cut | Removes the current selection from the text editing control and copies it to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeclareChangeBlock | Creates a change block. (Inherited from TextBoxBase.)
Public method | EndChange | Ends a change block. (Inherited from TextBoxBase.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetCharacterIndexFromLineIndex | Returns the zero-based character index for the first character in the specified line. (Inherited from TextBox.)
Public method | GetCharacterIndexFromPoint | Returns the zero-based index of the character that is closest to the specified point. (Inherited from TextBox.)
Public method | GetFirstVisibleLineIndex | Returns the line index for the first line that is currently visible in the text box. (Inherited from TextBox.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLastVisibleLineIndex | Returns the line index for the last line that is currently visible in the text box. (Inherited from TextBox.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLineIndexFromCharacterIndex | Returns the zero-based line index for the line that contains the specified character index. (Inherited from TextBox.)
Public method | GetLineLength | Returns the number of characters in the specified line. (Inherited from TextBox.)
Public method | GetLineText | Returns the text that is currently displayed on the specified line. (Inherited from TextBox.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetNextSpellingErrorCharacterIndex | Returns the beginning character index for the next spelling error in the contents of the text box. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32) | Returns the rectangle for the leading edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32, Boolean) | Returns the rectangle for the leading or trailing edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetSpellingError | Returns a SpellingError object associated with any spelling error at the specified character index. (Inherited from TextBox.)
Public method | GetSpellingErrorLength | Returns the length of any spelling error that includes the specified character. (Inherited from TextBox.)
Public method | GetSpellingErrorStart | Returns the beginning character index for any spelling error that includes the specified character. (Inherited from TextBox.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls the contents of the control down by one line. (Inherited from TextBoxBase.)
Public method | LineLeft | Scrolls the contents of the control to the left by one line. (Inherited from TextBoxBase.)
Public method | LineRight | Scrolls the contents of the control to the right by one line. (Inherited from TextBoxBase.)
Public method | LineUp | Scrolls the contents of the control upward by one line. (Inherited from TextBoxBase.)
Public method | LockCurrentUndoUnit | Locks the most recent undo unit of the undo stack of the application. This prevents the locked unit from being merged with undo units that are added subsequently. (Inherited from TextBoxBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Sizes the text box to its content. (Inherited from TextBox.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | Is called when a control template is applied. (Inherited from TextBoxBase.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Called whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for the text box. (Inherited from TextBox.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragLeave | Invoked whenever an unhandled DragLeave attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragOver | Invoked whenever an unhandled DragOver attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDrop | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGiveFeedback | Invoked whenever an unhandled GiveFeedback attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked whenever an unhandled GotKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | (Overrides TextBoxBaseOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | Invoked whenever an unhandled KeyUp attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostFocus | Raises the LostFocus event (using the provided arguments). (Inherited from TextBoxBase.)
Protected method | OnLostKeyboardFocus | (Overrides TextBoxBaseOnLostKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked whenever an unhandled MouseDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked whenever an unhandled MouseMove attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked whenever an unhandled MouseUp event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Is called when a MouseWheel event is routed to this class (or to a class that inherits from this class). (Inherited from TextBoxBase.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Called when the KeyDown occurs. (Inherited from TextBoxBase.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Called when one or more of the dependency properties that exist on the element have had their effective values changed. (Inherited from TextBox.)
Protected method | OnQueryContinueDrag | Invoked whenever an unhandled QueryContinueDrag attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnQueryCursor | Invoked whenever an unhandled QueryCursor attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Is called when the caret or current selection changes position. (Inherited from TextBoxBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Is called when the control template changes. (Inherited from TextBoxBase.)
Protected method | OnTextChanged | Is called when content in this editing control changes. (Inherited from TextBoxBase.)
Protected method | OnTextInput | Invoked whenever an unhandled TextInput attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | PageDown | Scrolls the contents of the control down by one page. (Inherited from TextBoxBase.)
Public method | PageLeft | Scrolls the contents of the control to the left by one page. (Inherited from TextBoxBase.)
Public method | PageRight | Scrolls the contents of the control to the right by one page. (Inherited from TextBoxBase.)
Public method | PageUp | Scrolls the contents of the control up by one page. (Inherited from TextBoxBase.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | Paste | Pastes the contents of the Clipboard over the current selection in the text editing control. (Inherited from TextBoxBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Redo | Undoes the most recent undo command. In other words, redoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollToEnd | Scrolls the view of the editing control to the end of the content. (Inherited from TextBoxBase.)
Public method | ScrollToHome | Scrolls the view of the editing control to the beginning of the viewport. (Inherited from TextBoxBase.)
Public method | ScrollToHorizontalOffset | Scrolls the contents of the editing control to the specified horizontal offset. (Inherited from TextBoxBase.)
Public method | ScrollToLine | Scrolls the line at the specified line index into view. (Inherited from TextBox.)
Public method | ScrollToVerticalOffset | Scrolls the contents of the editing control to the specified vertical offset. (Inherited from TextBoxBase.)
Public method | Select | Selects a range of text in the text box. (Inherited from TextBox.)
Public method | SelectAll | Selects all the contents of the text editing control. (Inherited from TextBoxBase.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeText | Returns a value that indicates whether the effective value of the Text property should be serialized during serialization of the TextBox object. (Inherited from TextBox.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | Undo | Undoes the most recent undo command. In other words, undoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBoxBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextChanged | Occurs when content changes in the text element. (Inherited from TextBoxBase.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


EditBox Constructor

Initializes a new instance of the EditBox class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EditBox()
public:
EditBox()
See Also

Reference

EditBox Class
VisualComponents.UX.Shared Namespace


EditBox Properties

The EditBox type exposes the following members.

Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key. (Inherited from TextBoxBase.)
Public property | AcceptsTab | Gets or sets a value that indicates how the text editing control responds when the user presses the TAB key. (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoWordSelection | Gets or sets a value that determines whether when a user selects part of a word by dragging across it with the mouse, the rest of the word is selected. (Inherited from TextBoxBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanRedo | Gets a value that indicates whether the most recent undo action can be redone. (Inherited from TextBoxBase.)
Public property | CanUndo | Gets a value that indicates whether the most recent action can be undone. (Inherited from TextBoxBase.)
Public property | CaretBrush | Gets or sets the brush that is used to paint the caret of the text box. (Inherited from TextBoxBase.)
Public property | CaretIndex | Gets or sets the insertion position index of the caret. (Inherited from TextBox.)
Public property | CharacterCasing | Gets or sets how characters are cased when they are manually entered into the text box. (Inherited from TextBox.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExtentHeight | Gets the vertical size of the visible content area. (Inherited from TextBoxBase.)
Public property | ExtentWidth | Gets the horizontal size of the visible content area. (Inherited from TextBoxBase.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Gets or sets the horizontal scroll position. (Inherited from TextBoxBase.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal scroll bar is shown. (Inherited from TextBoxBase.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInactiveSelectionHighlightEnabled | Gets or sets a value that indicates whether the text box displays selected text when the text box does not have focus. (Inherited from TextBoxBase.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that indicates whether the text editing control is read-only to a user interacting with the control. (Inherited from TextBoxBase.)
Public property | IsReadOnlyCaretVisible | Gets or sets a value that indicates whether a read-only text box displays a caret. (Inherited from TextBoxBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionActive | Gets a value that indicates whether the text box has focus and selected text. (Inherited from TextBoxBase.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets a value that indicates whether undo support is enabled for the text-editing control. (Inherited from TextBoxBase.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Item |
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | LineCount | Gets the total number of lines in the text box. (Inherited from TextBox.)
Protected property | LogicalChildren | Gets an enumerator for the logical child elements of the TextBox. (Inherited from TextBox.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxLength | Gets or sets the maximum number of characters that can be manually entered into the text box. (Inherited from TextBox.)
Public property | MaxLines | Gets or sets the maximum number of visible lines. (Inherited from TextBox.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinLines | Gets or sets the minimum number of visible lines. (Inherited from TextBox.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Node |
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedText | Gets or sets the content of the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionBrush | Gets or sets the brush that highlights selected text. (Inherited from TextBoxBase.)
Public property | SelectionLength | Gets or sets a value indicating the number of characters in the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionOpacity | Gets or sets the opacity of the SelectionBrush. (Inherited from TextBoxBase.)
Public property | SelectionStart | Gets or sets a character index for the beginning of the current selection. (Inherited from TextBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | SpellCheck | Gets a SpellCheck object that provides access to spelling errors in the text contents of a TextBoxBase or RichTextBox. (Inherited from TextBoxBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Gets or sets the text contents of the text box. (Inherited from TextBox.)
Public property | TextAlignment | Gets or sets the horizontal alignment of the contents of the text box. (Inherited from TextBox.)
Public property | TextDecorations | Gets the text decorations to apply to the text box. (Inherited from TextBox.)
Public property | TextWrapping | Gets or sets how the text box should wrap text. (Inherited from TextBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Typography | Gets the currently effective typography variations for the text contents of the text box. (Inherited from TextBox.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UndoLimit | Gets or sets the number of actions stored in the undo queue. (Inherited from TextBoxBase.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Gets or sets the vertical scroll position. (Inherited from TextBoxBase.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical scroll bar is shown. (Inherited from TextBoxBase.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | ViewportHeight | Gets the vertical size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | ViewportWidth | Gets the horizontal size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

EditBox Class
VisualComponents.UX.Shared Namespace


EditBox.Item Property

EditBoxItem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeViewItemEx Item { get; set; }
public:
property TreeViewItemEx^ Item {
    TreeViewItemEx^ get ();
    void set (TreeViewItemEx^ value);
}

Property Value

Type: TreeViewItemEx
See Also

Reference

EditBox Class
VisualComponents.UX.Shared Namespace


EditBox.Node Property

EditBoxNode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeNodeEx Node { get; }
public:
property TreeNodeEx^ Node {
    TreeNodeEx^ get ();
}

Property Value

Type: TreeNodeEx
See Also

Reference

EditBox Class
VisualComponents.UX.Shared Namespace


EditBox Methods

The EditBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AppendText | Appends a string to the contents of a text control. (Inherited from TextBoxBase.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginChange | Begins a change block. (Inherited from TextBoxBase.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | Clears all the content from the text box. (Inherited from TextBox.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Copy | Copies the current selection of the text editing control to the Clipboard. (Inherited from TextBoxBase.)
Public method | Cut | Removes the current selection from the text editing control and copies it to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeclareChangeBlock | Creates a change block. (Inherited from TextBoxBase.)
Public method | EndChange | Ends a change block. (Inherited from TextBoxBase.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetCharacterIndexFromLineIndex | Returns the zero-based character index for the first character in the specified line. (Inherited from TextBox.)
Public method | GetCharacterIndexFromPoint | Returns the zero-based index of the character that is closest to the specified point. (Inherited from TextBox.)
Public method | GetFirstVisibleLineIndex | Returns the line index for the first line that is currently visible in the text box. (Inherited from TextBox.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLastVisibleLineIndex | Returns the line index for the last line that is currently visible in the text box. (Inherited from TextBox.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLineIndexFromCharacterIndex | Returns the zero-based line index for the line that contains the specified character index. (Inherited from TextBox.)
Public method | GetLineLength | Returns the number of characters in the specified line. (Inherited from TextBox.)
Public method | GetLineText | Returns the text that is currently displayed on the specified line. (Inherited from TextBox.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetNextSpellingErrorCharacterIndex | Returns the beginning character index for the next spelling error in the contents of the text box. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32) | Returns the rectangle for the leading edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32, Boolean) | Returns the rectangle for the leading or trailing edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetSpellingError | Returns a SpellingError object associated with any spelling error at the specified character index. (Inherited from TextBox.)
Public method | GetSpellingErrorLength | Returns the length of any spelling error that includes the specified character. (Inherited from TextBox.)
Public method | GetSpellingErrorStart | Returns the beginning character index for any spelling error that includes the specified character. (Inherited from TextBox.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls the contents of the control down by one line. (Inherited from TextBoxBase.)
Public method | LineLeft | Scrolls the contents of the control to the left by one line. (Inherited from TextBoxBase.)
Public method | LineRight | Scrolls the contents of the control to the right by one line. (Inherited from TextBoxBase.)
Public method | LineUp | Scrolls the contents of the control upward by one line. (Inherited from TextBoxBase.)
Public method | LockCurrentUndoUnit | Locks the most recent undo unit of the undo stack of the application. This prevents the locked unit from being merged with undo units that are added subsequently. (Inherited from TextBoxBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Sizes the text box to its content. (Inherited from TextBox.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | Is called when a control template is applied. (Inherited from TextBoxBase.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Called whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for the text box. (Inherited from TextBox.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragLeave | Invoked whenever an unhandled DragLeave attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragOver | Invoked whenever an unhandled DragOver attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDrop | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGiveFeedback | Invoked whenever an unhandled GiveFeedback attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked whenever an unhandled GotKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | (Overrides TextBoxBaseOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | Invoked whenever an unhandled KeyUp attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostFocus | Raises the LostFocus event (using the provided arguments). (Inherited from TextBoxBase.)
Protected method | OnLostKeyboardFocus | (Overrides TextBoxBaseOnLostKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked whenever an unhandled MouseDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked whenever an unhandled MouseMove attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked whenever an unhandled MouseUp event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Is called when a MouseWheel event is routed to this class (or to a class that inherits from this class). (Inherited from TextBoxBase.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Called when the KeyDown occurs. (Inherited from TextBoxBase.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Called when one or more of the dependency properties that exist on the element have had their effective values changed. (Inherited from TextBox.)
Protected method | OnQueryContinueDrag | Invoked whenever an unhandled QueryContinueDrag attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnQueryCursor | Invoked whenever an unhandled QueryCursor attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Is called when the caret or current selection changes position. (Inherited from TextBoxBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Is called when the control template changes. (Inherited from TextBoxBase.)
Protected method | OnTextChanged | Is called when content in this editing control changes. (Inherited from TextBoxBase.)
Protected method | OnTextInput | Invoked whenever an unhandled TextInput attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | PageDown | Scrolls the contents of the control down by one page. (Inherited from TextBoxBase.)
Public method | PageLeft | Scrolls the contents of the control to the left by one page. (Inherited from TextBoxBase.)
Public method | PageRight | Scrolls the contents of the control to the right by one page. (Inherited from TextBoxBase.)
Public method | PageUp | Scrolls the contents of the control up by one page. (Inherited from TextBoxBase.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | Paste | Pastes the contents of the Clipboard over the current selection in the text editing control. (Inherited from TextBoxBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Redo | Undoes the most recent undo command. In other words, redoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollToEnd | Scrolls the view of the editing control to the end of the content. (Inherited from TextBoxBase.)
Public method | ScrollToHome | Scrolls the view of the editing control to the beginning of the viewport. (Inherited from TextBoxBase.)
Public method | ScrollToHorizontalOffset | Scrolls the contents of the editing control to the specified horizontal offset. (Inherited from TextBoxBase.)
Public method | ScrollToLine | Scrolls the line at the specified line index into view. (Inherited from TextBox.)
Public method | ScrollToVerticalOffset | Scrolls the contents of the editing control to the specified vertical offset. (Inherited from TextBoxBase.)
Public method | Select | Selects a range of text in the text box. (Inherited from TextBox.)
Public method | SelectAll | Selects all the contents of the text editing control. (Inherited from TextBoxBase.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeText | Returns a value that indicates whether the effective value of the Text property should be serialized during serialization of the TextBox object. (Inherited from TextBox.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | Undo | Undoes the most recent undo command. In other words, undoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

EditBox Class
VisualComponents.UX.Shared Namespace


EditBox.OnKeyDown Method

EditBoxOnKeyDown Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnKeyDown(
    KeyEventArgs e
)
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputKeyEventArgs
See Also

Reference

EditBox Class
VisualComponents.UX.Shared Namespace


EditBox.OnLostKeyboardFocus Method

EditBoxOnLostKeyboardFocus Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnLostKeyboardFocus(
    KeyboardFocusChangedEventArgs e
)
protected:
virtual void OnLostKeyboardFocus(
    KeyboardFocusChangedEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputKeyboardFocusChangedEventArgs
See Also

Reference

EditBox Class
VisualComponents.UX.Shared Namespace


EditBox Events

The EditBox type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBoxBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextChanged | Occurs when content changes in the text element. (Inherited from TextBoxBase.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

EditBox Class
VisualComponents.UX.Shared Namespace


EditConnectorSignalView Class

Interaction logic for EditConnectorSignalView.xaml
EditConnectorSignalView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedEditConnectorSignalView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class EditConnectorSignalView : UserControl,
    IComponentConnector
public ref class EditConnectorSignalView : public UserControl,
    IComponentConnector

The EditConnectorSignalView type exposes the following members.

Constructors
 | Name | Description
Public method | EditConnectorSignalView | Initializes a new instance of the EditConnectorSignalView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


EditConnectorSignalView Constructor

Initializes a new instance of the EditConnectorSignalView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EditConnectorSignalView()
public:
EditConnectorSignalView()
See Also

Reference

EditConnectorSignalView Class
VisualComponents.UX.Shared Namespace


EditConnectorSignalView Properties

The EditConnectorSignalView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

EditConnectorSignalView Class
VisualComponents.UX.Shared Namespace


EditConnectorSignalView Methods

The EditConnectorSignalView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

EditConnectorSignalView Class
VisualComponents.UX.Shared Namespace


EditConnectorSignalView.InitializeComponent Method

EditConnectorSignalViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

EditConnectorSignalView Class
VisualComponents.UX.Shared Namespace


EditConnectorSignalView Events

The EditConnectorSignalView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

EditConnectorSignalView Class
VisualComponents.UX.Shared Namespace


EditConnectorSignalViewModel Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
ViewAware
Screen
VisualComponents.UX.SharedEditConnectorSignalViewModel

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class EditConnectorSignalViewModel : Screen
public ref class EditConnectorSignalViewModel : public Screen

The EditConnectorSignalViewModel type exposes the following members.

Constructors
 | Name | Description
Public method | EditConnectorSignalViewModel | Initializes a new instance of the EditConnectorSignalViewModel class
Top
Properties
 | Name | Description
Protected property | CacheViews | (Inherited from ViewAware.)
Public property | Connector |
Public property | DisplayName | (Inherited from Screen.)
Public property | IsActive | (Inherited from Screen.)
Public property | IsInitialized | (Inherited from Screen.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | Parent | (Inherited from Screen.)
Public property | PossibleConnectors |
Public property | SignalInformation |
Public property | Title |
Top
Methods
 | Name | Description
Public method | CanClose | (Inherited from Screen.)
Public method | DoChange |
 | EditConnector |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetView | (Inherited from ViewAware.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Protected method | OnActivate | (Inherited from Screen.)
Protected method | OnDeactivate | (Inherited from Screen.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnInitialize | (Inherited from Screen.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Protected method | OnViewAttached | (Inherited from ViewAware.)
Protected method | OnViewLoaded | (Overrides ViewAware.OnViewLoaded(Object).)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryClose | (Inherited from Screen.)
Public method | TryClose(NullableBoolean) | (Inherited from Screen.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from Screen.)
Public event | AttemptingDeactivation | (Inherited from Screen.)
Public event | Deactivated | (Inherited from Screen.)
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Public event | ViewAttached | (Inherited from ViewAware.)
Top
Fields
 | Name | Description
Protected field | Views | (Inherited from ViewAware.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


EditConnectorSignalViewModel Constructor

Initializes a new instance of the EditConnectorSignalViewModel class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EditConnectorSignalViewModel(
    ConnectorViewModel connector
)
public:
EditConnectorSignalViewModel(
    ConnectorViewModel^ connector
)

Parameters

connector
Type: VisualComponents.UX.Shared.NetworkMapConnectorViewModel
See Also

Reference

EditConnectorSignalViewModel Class
VisualComponents.UX.Shared Namespace


EditConnectorSignalViewModel Properties

The EditConnectorSignalViewModel type exposes the following members.

Properties
 | Name | Description
Protected property | CacheViews | (Inherited from ViewAware.)
Public property | Connector |
Public property | DisplayName | (Inherited from Screen.)
Public property | IsActive | (Inherited from Screen.)
Public property | IsInitialized | (Inherited from Screen.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | Parent | (Inherited from Screen.)
Public property | PossibleConnectors |
Public property | SignalInformation |
Public property | Title |
Top
See Also

Reference

EditConnectorSignalViewModel Class
VisualComponents.UX.Shared Namespace


EditConnectorSignalViewModel.Connector Property

EditConnectorSignalViewModelConnector Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectorViewModel Connector { get; set; }
public:
property ConnectorViewModel^ Connector {
    ConnectorViewModel^ get ();
    void set (ConnectorViewModel^ value);
}

Property Value

Type: ConnectorViewModel
See Also

Reference

EditConnectorSignalViewModel Class
VisualComponents.UX.Shared Namespace


EditConnectorSignalViewModel.PossibleConnectors Property

EditConnectorSignalViewModelPossibleConnectors Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<SignalInformation> PossibleConnectors { get; set; }
public:
property List<SignalInformation^>^ PossibleConnectors {
    List<SignalInformation^>^ get ();
    void set (List<SignalInformation^>^ value);
}

Property Value

Type: ListSignalInformation
See Also

Reference

EditConnectorSignalViewModel Class
VisualComponents.UX.Shared Namespace


EditConnectorSignalViewModel.SignalInformation Property

EditConnectorSignalViewModelSignalInformation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SignalInformation SignalInformation { get; set; }
public:
property SignalInformation^ SignalInformation {
    SignalInformation^ get ();
    void set (SignalInformation^ value);
}

Property Value

Type: SignalInformation
See Also

Reference

EditConnectorSignalViewModel Class
VisualComponents.UX.Shared Namespace


EditConnectorSignalViewModel.Title Property

EditConnectorSignalViewModelTitle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; set; }
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

EditConnectorSignalViewModel Class
VisualComponents.UX.Shared Namespace


EditConnectorSignalViewModel Methods

The EditConnectorSignalViewModel type exposes the following members.

Methods
 | Name | Description
Public method | CanClose | (Inherited from Screen.)
Public method | DoChange |
 | EditConnector |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetView | (Inherited from ViewAware.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Protected method | OnActivate | (Inherited from Screen.)
Protected method | OnDeactivate | (Inherited from Screen.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnInitialize | (Inherited from Screen.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Protected method | OnViewAttached | (Inherited from ViewAware.)
Protected method | OnViewLoaded | (Overrides ViewAware.OnViewLoaded(Object).)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryClose | (Inherited from Screen.)
Public method | TryClose(NullableBoolean) | (Inherited from Screen.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

EditConnectorSignalViewModel Class
VisualComponents.UX.Shared Namespace


EditConnectorSignalViewModel.DoChange Method

EditConnectorSignalViewModelDoChange Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void DoChange()
public:
void DoChange()
See Also

Reference

EditConnectorSignalViewModel Class
VisualComponents.UX.Shared Namespace


EditConnectorSignalViewModel.EditConnector Method

EditConnectorSignalViewModelEditConnector Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void EditConnector(
    ConnectorViewModel connector
)
public:
static void EditConnector(
    ConnectorViewModel^ connector
)

Parameters

connector
Type: VisualComponents.UX.Shared.NetworkMapConnectorViewModel
See Also

Reference

EditConnectorSignalViewModel Class
VisualComponents.UX.Shared Namespace


EditConnectorSignalViewModel.OnViewLoaded Method

EditConnectorSignalViewModelOnViewLoaded Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnViewLoaded(
    Object view
)
protected:
virtual void OnViewLoaded(
    Object^ view
) override

Parameters

view
Type: SystemObject
See Also

Reference

EditConnectorSignalViewModel Class
VisualComponents.UX.Shared Namespace


EditConnectorSignalViewModel Events

The EditConnectorSignalViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from Screen.)
Public event | AttemptingDeactivation | (Inherited from Screen.)
Public event | Deactivated | (Inherited from Screen.)
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Public event | ViewAttached | (Inherited from ViewAware.)
Top
See Also

Reference

EditConnectorSignalViewModel Class
VisualComponents.UX.Shared Namespace


EditConnectorSignalViewModel Fields

The EditConnectorSignalViewModel type exposes the following members.

Fields
 | Name | Description
Protected field | Views | (Inherited from ViewAware.)
Top
See Also

Reference

EditConnectorSignalViewModel Class
VisualComponents.UX.Shared Namespace


EditorProperty Class

Defines UX property
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedEditorProperty
More...

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class EditorProperty : IProperty,
    INotifyPropertyChanged, IDisposable, INamed, IDataErrorInfo
public ref class EditorProperty : IProperty,
    INotifyPropertyChanged, IDisposable, INamed, IDataErrorInfo

The EditorProperty type exposes the following members.

Constructors
 | Name | Description
Public method | EditorProperty | Initializes a new instance of the EditorProperty class
Public method | EditorProperty(IProperty) | Initializes a new instance of the EditorProperty class
Public method | EditorProperty(IProperty, Boolean) | Initializes a new instance of the EditorProperty class
Top
Properties
 | Name | Description
Public property | AllowedMaximum |
Public property | AllowedMinimum |
Public property | AllowedValues |
Public property | CanCreateNewValue |
Public property | Category |
Public property | ConstraintType |
Public property | Container |
Public property | ContainerExpressionContext |
Public property | ContainerObject | Similar to IProperty.Container, but for any object.
Public property | CreationTypes |
Public property | Description |
Public property | DisabledStateToolTip |
Public property | DistributionExpression |
Public property | Error |
Public property | ErrorMessage |
Public property | HasDistribution |
Public property | History |
Public property | Index_ForComboBox |
Public property | IsDesignTime |
Public property | IsEditable | Helper property since in XAML negating binding value is not possible without using BoolToOppositeConverter
Public property | IsEditableInGui |
Public property | IsExceptionallyInHome |
Public property | IsInternal |
Public property | IsLocked |
Public property | IsPersistent |
Public property | IsQuantityValue |
Public property | IsReadOnly |
Public property | IsValid |
Public property | IsVisible |
Public property | IsVisibleDesignTime |
Public property | IsVisibleForced |
 | IsVisibleForcedGlobally |
Public property | IsVisibleInGui | IsVisibleInGui is used to bind GUI visibility. Setting this value affects only _isVisibleForcedOff.
Public property | Item |
Public property | Name |
Public property | NonLocalizedName |
Public property | Order |
Public property | Property |
Public property | PropertyDescription |
Public property | PropertyType |
Public property | Quantity |
Public property | ResourceType | In case of having an IUriProperty, this determines if the editor should allow folder selection instead of file selection
Public property | RotationSystem |
Public property | ShowValuepicker |
 | SuspendedProperties |
Public property | TabHeader |
Public property | Unit |
Public property | Value |
Public property | Value_ForComboBox | Helper property, used only by ComboBox.
Public property | ValueString |
Top
Methods
 | Name | Description
Public method | Associate |
Public method | CheckEditableInGui |
Protected method | CheckPropertyObjDispose |
Public method | CheckRebuild | This happens only on UI changes. If containeris a behavior of feature call evaluate or rebuild to update geometry.
Public method | CheckRebuildSmart |
Public method | Clone |
Public method | CreateAndSetNewValue |
Public method | Disassociate |
Public method | Dispose | Releases all resources used by the EditorProperty
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the EditorProperty and optionally releases the managed resources
Public method | EndBatch |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokePropertyChanged |
Protected method | InvokePropertyChangedEx |
Protected method | InvokePropertyChangedValue_Begin |
Protected method | InvokePropertyChangedValue_Process |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Note: This is Not just called on IProperty.Value change. It's called by PropertyWrapper::NotifyPropertyChanged with different names (like "Value", "Expression", etc). It's called on rVariable::SetupChanged, on variable flag changes.
Public method | PickValue | Execute PickAction and wait for user to click on some object.
Public method | PickValueProxy |
Public method | SetQuantity |
Public method | SetUnitMagnitude |
Public method | StartBatch |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | property changed event
Top
Fields
 | Name | Description
Public field | SuppressValueChange |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks
EditorProperty implements IProperty because WPF data templates do not support interface types
See Also

Reference

VisualComponents.UX.Shared Namespace
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedEditorProperty
VisualComponents.UX.SharedBitmapProperty
VisualComponents.UX.SharedButtonProperty
VisualComponents.UX.SharedDistributionProperty
VisualComponents.UX.SharedExpressionProperty
VisualComponents.UX.SharedListProperty
VisualComponents.UX.SharedMatrixProperty
VisualComponents.UX.SharedMultilineStringProperty
VisualComponents.UX.SharedNoteProperty
VisualComponents.UX.SharedPositionProperty
VisualComponents.UX.SharedScriptProperty
VisualComponents.UX.SharedVectorProperty


EditorProperty Constructor

Overload List
 | Name | Description
Public method | EditorProperty | Initializes a new instance of the EditorProperty class
Public method | EditorProperty(IProperty) | Initializes a new instance of the EditorProperty class
Public method | EditorProperty(IProperty, Boolean) | Initializes a new instance of the EditorProperty class
Top
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty Constructor

Initializes a new instance of the EditorProperty class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EditorProperty()
public:
EditorProperty()
See Also

Reference

EditorProperty Class
EditorProperty Overload
VisualComponents.UX.Shared Namespace


EditorProperty Constructor (IProperty)

Initializes a new instance of the EditorProperty class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EditorProperty(
    IProperty property
)
public:
EditorProperty(
    IProperty^ property
)

Parameters

property
Type: VisualComponents.Create3DIProperty
See Also

Reference

EditorProperty Class
EditorProperty Overload
VisualComponents.UX.Shared Namespace


EditorProperty Constructor (IProperty, Boolean)

Initializes a new instance of the EditorProperty class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EditorProperty(
    IProperty property,
    bool temporary
)
public:
EditorProperty(
    IProperty^ property,
    bool temporary
)

Parameters

property
Type: VisualComponents.Create3DIProperty
temporary
Type: SystemBoolean
See Also

Reference

EditorProperty Class
EditorProperty Overload
VisualComponents.UX.Shared Namespace


EditorProperty Properties

The EditorProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum |
Public property | AllowedMinimum |
Public property | AllowedValues |
Public property | CanCreateNewValue |
Public property | Category |
Public property | ConstraintType |
Public property | Container |
Public property | ContainerExpressionContext |
Public property | ContainerObject | Similar to IProperty.Container, but for any object.
Public property | CreationTypes |
Public property | Description |
Public property | DisabledStateToolTip |
Public property | DistributionExpression |
Public property | Error |
Public property | ErrorMessage |
Public property | HasDistribution |
Public property | History |
Public property | Index_ForComboBox |
Public property | IsDesignTime |
Public property | IsEditable | Helper property since in XAML negating binding value is not possible without using BoolToOppositeConverter
Public property | IsEditableInGui |
Public property | IsExceptionallyInHome |
Public property | IsInternal |
Public property | IsLocked |
Public property | IsPersistent |
Public property | IsQuantityValue |
Public property | IsReadOnly |
Public property | IsValid |
Public property | IsVisible |
Public property | IsVisibleDesignTime |
Public property | IsVisibleForced |
 | IsVisibleForcedGlobally |
Public property | IsVisibleInGui | IsVisibleInGui is used to bind GUI visibility. Setting this value affects only _isVisibleForcedOff.
Public property | Item |
Public property | Name |
Public property | NonLocalizedName |
Public property | Order |
Public property | Property |
Public property | PropertyDescription |
Public property | PropertyType |
Public property | Quantity |
Public property | ResourceType | In case of having an IUriProperty, this determines if the editor should allow folder selection instead of file selection
Public property | RotationSystem |
Public property | ShowValuepicker |
 | SuspendedProperties |
Public property | TabHeader |
Public property | Unit |
Public property | Value |
Public property | Value_ForComboBox | Helper property, used only by ComboBox.
Public property | ValueString |
Top
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.AllowedMaximum Property

EditorPropertyAllowedMaximum Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IComparable AllowedMaximum { get; set; }
public:
virtual property IComparable^ AllowedMaximum {
    IComparable^ get () sealed;
    void set (IComparable^ value) sealed;
}

Property Value

Type: IComparable

Implements

IPropertyAllowedMaximum
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.AllowedMinimum Property

EditorPropertyAllowedMinimum Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IComparable AllowedMinimum { get; set; }
public:
virtual property IComparable^ AllowedMinimum {
    IComparable^ get () sealed;
    void set (IComparable^ value) sealed;
}

Property Value

Type: IComparable

Implements

IPropertyAllowedMinimum
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.AllowedValues Property

EditorPropertyAllowedValues Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ICollection<PropertyAllowedValue> AllowedValues { get; }
public:
virtual property ICollection<PropertyAllowedValue>^ AllowedValues {
    ICollection<PropertyAllowedValue>^ get () sealed;
}

Property Value

Type: ICollectionPropertyAllowedValue

Implements

IPropertyAllowedValues
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.CanCreateNewValue Property

EditorPropertyCanCreateNewValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanCreateNewValue { get; }
public:
virtual property bool CanCreateNewValue {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IPropertyCanCreateNewValue
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.Category Property

EditorPropertyCategory Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Category { get; set; }
public:
virtual property String^ Category {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPropertyCategory
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.ConstraintType Property

EditorPropertyConstraintType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyConstraintType ConstraintType { get; }
public:
virtual property PropertyConstraintType ConstraintType {
    PropertyConstraintType get () sealed;
}

Property Value

Type: PropertyConstraintType

Implements

IPropertyConstraintType
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.Container Property

EditorPropertyContainer Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IPropertyContainer Container { get; }
public:
virtual property IPropertyContainer^ Container {
    IPropertyContainer^ get () sealed;
}

Property Value

Type: IPropertyContainer

Implements

IPropertyContainer
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.ContainerExpressionContext Property

EditorPropertyContainerExpressionContext Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IExpressionContext ContainerExpressionContext { get; }
public:
property IExpressionContext^ ContainerExpressionContext {
    IExpressionContext^ get ();
}

Property Value

Type: IExpressionContext
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.ContainerObject Property

EditorPropertyContainerObject Property

Similar to IProperty.Container, but for any object.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ContainerObject { get; set; }
public:
property Object^ ContainerObject {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.CreationTypes Property

EditorPropertyCreationTypes Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList<string> CreationTypes { get; }
public:
virtual property IList<String^>^ CreationTypes {
    IList<String^>^ get () sealed;
}

Property Value

Type: IListString

Implements

IPropertyCreationTypes
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.Description Property

EditorPropertyDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; set; }
public:
virtual property String^ Description {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPropertyDescription
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.DisabledStateToolTip Property

EditorPropertyDisabledStateToolTip Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string DisabledStateToolTip { get; set; }
public:
virtual property String^ DisabledStateToolTip {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPropertyDisabledStateToolTip
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.DistributionExpression Property

EditorPropertyDistributionExpression Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string DistributionExpression { get; set; }
public:
virtual property String^ DistributionExpression {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPropertyDistributionExpression
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.Error Property

EditorPropertyError Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Error { get; }
public:
virtual property String^ Error {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IDataErrorInfoError
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.ErrorMessage Property

EditorPropertyErrorMessage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ErrorMessage { get; }
public:
property String^ ErrorMessage {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.HasDistribution Property

EditorPropertyHasDistribution Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HasDistribution { get; }
public:
virtual property bool HasDistribution {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IPropertyHasDistribution
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.History Property

EditorPropertyHistory Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<HistoryItem> History { get; }
public:
virtual property ReadOnlyCollection<HistoryItem>^ History {
    ReadOnlyCollection<HistoryItem>^ get () sealed;
}

Property Value

Type: ReadOnlyCollectionHistoryItem

Implements

IPropertyHistory
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.Index_ForComboBox Property

EditorPropertyIndex_ForComboBox Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Index_ForComboBox { get; set; }
public:
property int Index_ForComboBox {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.IsDesignTime Property

EditorPropertyIsDesignTime Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsDesignTime { get; }
public:
virtual property bool IsDesignTime {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IPropertyIsDesignTime
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.IsEditable Property

EditorPropertyIsEditable Property

Helper property since in XAML negating binding value is not possible without using BoolToOppositeConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsEditable { get; set; }
public:
property bool IsEditable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.IsEditableInGui Property

EditorPropertyIsEditableInGui Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsEditableInGui { get; set; }
public:
property bool IsEditableInGui {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.IsExceptionallyInHome Property

EditorPropertyIsExceptionallyInHome Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsExceptionallyInHome { protected get; set; }
public:
property bool IsExceptionallyInHome {
    protected: bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.IsInternal Property

EditorPropertyIsInternal Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsInternal { get; }
public:
virtual property bool IsInternal {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IPropertyIsInternal
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.IsLocked Property

EditorPropertyIsLocked Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsLocked { get; }
public:
virtual property bool IsLocked {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IPropertyIsLocked
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.IsPersistent Property

EditorPropertyIsPersistent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsPersistent { get; set; }
public:
virtual property bool IsPersistent {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPropertyIsPersistent
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.IsQuantityValue Property

EditorPropertyIsQuantityValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsQuantityValue { get; }
public:
virtual property bool IsQuantityValue {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IPropertyIsQuantityValue
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.IsReadOnly Property

EditorPropertyIsReadOnly Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsReadOnly { get; set; }
public:
virtual property bool IsReadOnly {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPropertyIsReadOnly
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.IsValid Property

EditorPropertyIsValid Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsValid { get; }
public:
property bool IsValid {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.IsVisible Property

EditorPropertyIsVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsVisible { get; set; }
public:
virtual property bool IsVisible {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPropertyIsVisible
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.IsVisibleDesignTime Property

EditorPropertyIsVisibleDesignTime Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsVisibleDesignTime { get; }
public:
virtual property bool IsVisibleDesignTime {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IPropertyIsVisibleDesignTime
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.IsVisibleForced Property

EditorPropertyIsVisibleForced Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsVisibleForced { get; set; }
public:
property bool IsVisibleForced {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.IsVisibleForcedGlobally Property

EditorPropertyIsVisibleForcedGlobally Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsVisibleForcedGlobally { get; set; }
public:
static property bool IsVisibleForcedGlobally {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.IsVisibleInGui Property

EditorPropertyIsVisibleInGui Property

IsVisibleInGui is used to bind GUI visibility. Setting this value affects only _isVisibleForcedOff.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsVisibleInGui { get; set; }
public:
property bool IsVisibleInGui {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.Item Property

EditorPropertyItem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string this[
    string columnName
] { get; }
public:
virtual property String^ default[String^ columnName] {
    String^ get (String^ columnName) sealed;
}

Parameters

columnName
Type: SystemString

Property Value

Type: String

Implements

IDataErrorInfoItemString
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.Name Property

EditorPropertyName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; set; }
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

INamedName
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.NonLocalizedName Property

EditorPropertyNonLocalizedName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string NonLocalizedName { get; set; }
public:
property String^ NonLocalizedName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.Order Property

EditorPropertyOrder Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Order { get; set; }
public:
virtual property int Order {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

IPropertyOrder
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.Property Property

EditorPropertyProperty Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty Property { get; protected set; }
public:
property IProperty^ Property {
    IProperty^ get ();
    protected: void set (IProperty^ value);
}

Property Value

Type: IProperty
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.PropertyDescription Property

EditorPropertyPropertyDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyDescription PropertyDescription { get; }
public:
property PropertyDescription^ PropertyDescription {
    PropertyDescription^ get ();
}

Property Value

Type: PropertyDescription
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.PropertyType Property

EditorPropertyPropertyType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type PropertyType { get; }
public:
virtual property Type^ PropertyType {
    Type^ get () sealed;
}

Property Value

Type: Type

Implements

IPropertyPropertyType
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.Quantity Property

EditorPropertyQuantity Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IScalarQuantity Quantity { get; }
public:
virtual property IScalarQuantity^ Quantity {
    IScalarQuantity^ get () sealed;
}

Property Value

Type: IScalarQuantity

Implements

IPropertyQuantity
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.ResourceType Property

EditorPropertyResourceType Property

In case of having an IUriProperty, this determines if the editor should allow folder selection instead of file selection

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ResourceType ResourceType { get; }
public:
property ResourceType ResourceType {
    ResourceType get ();
}

Property Value

Type: ResourceType
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.RotationSystem Property

EditorPropertyRotationSystem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RotationCoordinateSystem RotationSystem { get; }
public:
property RotationCoordinateSystem RotationSystem {
    RotationCoordinateSystem get ();
}

Property Value

Type: RotationCoordinateSystem
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.ShowValuepicker Property

EditorPropertyShowValuepicker Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowValuepicker { get; }
public:
property bool ShowValuepicker {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.SuspendedProperties Property

EditorPropertySuspendedProperties Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static HashSet<string> SuspendedProperties { get; set; }
public:
static property HashSet<String^>^ SuspendedProperties {
    HashSet<String^>^ get ();
    void set (HashSet<String^>^ value);
}

Property Value

Type: HashSetString
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.TabHeader Property

EditorPropertyTabHeader Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string TabHeader { get; set; }
public:
virtual property String^ TabHeader {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPropertyTabHeader
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.Unit Property

EditorPropertyUnit Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IUnit Unit { get; }
public:
virtual property IUnit^ Unit {
    IUnit^ get () sealed;
}

Property Value

Type: IUnit

Implements

IPropertyUnit
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.Value Property

EditorPropertyValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Value { get; set; }
public:
virtual property Object^ Value {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}

Property Value

Type: Object

Implements

IPropertyValue
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.Value_ForComboBox Property

EditorPropertyValue_ForComboBox Property

Helper property, used only by ComboBox.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyAllowedValueModel Value_ForComboBox { get; set; }
public:
property PropertyAllowedValueModel^ Value_ForComboBox {
    PropertyAllowedValueModel^ get ();
    void set (PropertyAllowedValueModel^ value);
}

Property Value

Type: PropertyAllowedValueModel
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.ValueString Property

EditorPropertyValueString Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ValueString { get; set; }
public:
property String^ ValueString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty Methods

The EditorProperty type exposes the following members.

Methods
 | Name | Description
Public method | Associate |
Public method | CheckEditableInGui |
Protected method | CheckPropertyObjDispose |
Public method | CheckRebuild | This happens only on UI changes. If containeris a behavior of feature call evaluate or rebuild to update geometry.
Public method | CheckRebuildSmart |
Public method | Clone |
Public method | CreateAndSetNewValue |
Public method | Disassociate |
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | EndBatch |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokePropertyChanged |
Protected method | InvokePropertyChangedEx |
Protected method | InvokePropertyChangedValue_Begin |
Protected method | InvokePropertyChangedValue_Process |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Note: This is Not just called on IProperty.Value change. It's called by PropertyWrapper::NotifyPropertyChanged with different names (like "Value", "Expression", etc). It's called on rVariable::SetupChanged, on variable flag changes.
Public method | PickValue | Execute PickAction and wait for user to click on some object.
Public method | PickValueProxy |
Public method | SetQuantity |
Public method | SetUnitMagnitude |
Public method | StartBatch |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetBindable | (Defined by PropertyHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.Associate Method

EditorPropertyAssociate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Associate()
public:
void Associate()
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.CheckEditableInGui Method

EditorPropertyCheckEditableInGui Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CheckEditableInGui()
public:
void CheckEditableInGui()
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.CheckPropertyObjDispose Method

EditorPropertyCheckPropertyObjDispose Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected void CheckPropertyObjDispose()
protected:
void CheckPropertyObjDispose()
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.CheckRebuild Method

EditorPropertyCheckRebuild Method

This happens only on UI changes. If containeris a behavior of feature call evaluate or rebuild to update geometry.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CheckRebuild()
public:
void CheckRebuild()
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.CheckRebuildSmart Method

EditorPropertyCheckRebuildSmart Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CheckRebuildSmart(
    IProperty propertyBeforeAssign
)
public:
void CheckRebuildSmart(
    IProperty^ propertyBeforeAssign
)

Parameters

propertyBeforeAssign
Type: VisualComponents.Create3DIProperty
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.Clone Method

EditorPropertyClone Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty Clone()
public:
virtual IProperty^ Clone() sealed

Return Value

Type: IProperty

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.EditorProperty.Clone"]

Implements

IPropertyClone
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.CreateAndSetNewValue Method

EditorPropertyCreateAndSetNewValue Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object CreateAndSetNewValue(
    string creationType,
    bool setImmediately
)
public:
virtual Object^ CreateAndSetNewValue(
    String^ creationType,
    bool setImmediately
) sealed

Parameters

creationType
Type: SystemString
setImmediately
Type: SystemBoolean

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.EditorProperty.CreateAndSetNewValue(System.String,System.Boolean)"]

Implements

IPropertyCreateAndSetNewValue(String, Boolean)
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.Disassociate Method

EditorPropertyDisassociate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Disassociate()
public:
void Disassociate()
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.Dispose Method

EditorPropertyDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the EditorProperty
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the EditorProperty and optionally releases the managed resources
Top
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.Dispose Method

EditorPropertyDispose Method

Releases all resources used by the EditorProperty

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Dispose()
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

EditorProperty Class
Dispose Overload
VisualComponents.UX.Shared Namespace


EditorProperty.Dispose Method (Boolean)

EditorPropertyDispose Method (Boolean)

Releases the unmanaged resources used by the EditorProperty and optionally releases the managed resources

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void Dispose(
    bool disposing
)
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

EditorProperty Class
Dispose Overload
VisualComponents.UX.Shared Namespace


EditorProperty.EndBatch Method

EditorPropertyEndBatch Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void EndBatch(
    bool cancel
)
public:
virtual void EndBatch(
    bool cancel
) sealed

Parameters

cancel
Type: SystemBoolean

Implements

IPropertyEndBatch(Boolean)
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.Finalize Method

EditorPropertyFinalize Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void Finalize()
protected:
virtual void Finalize() override

Implements

ObjectFinalize
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.InvokePropertyChanged Method

EditorPropertyInvokePropertyChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected void InvokePropertyChanged(
    string name
)
protected:
void InvokePropertyChanged(
    String^ name
)

Parameters

name
Type: SystemString
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.InvokePropertyChangedEx Method

EditorPropertyInvokePropertyChangedEx Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected void InvokePropertyChangedEx(
    string name
)
protected:
void InvokePropertyChangedEx(
    String^ name
)

Parameters

name
Type: SystemString
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.InvokePropertyChangedValue_Begin Method

EditorPropertyInvokePropertyChangedValue_Begin Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected void InvokePropertyChangedValue_Begin()
protected:
void InvokePropertyChangedValue_Begin()
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.InvokePropertyChangedValue_Process Method

EditorPropertyInvokePropertyChangedValue_Process Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected void InvokePropertyChangedValue_Process()
protected:
void InvokePropertyChangedValue_Process()
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.OnPropertyChanged Method

EditorPropertyOnPropertyChanged Method

Note: This is Not just called on IProperty.Value change. It's called by PropertyWrapper::NotifyPropertyChanged with different names (like "Value", "Expression", etc). It's called on rVariable::SetupChanged, on variable flag changes.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void OnPropertyChanged(
    Object sender,
    PropertyChangedEventArgs e
)
protected:
virtual void OnPropertyChanged(
    Object^ sender,
    PropertyChangedEventArgs^ e
)

Parameters

sender
Type: SystemObject
e
Type: System.ComponentModelPropertyChangedEventArgs
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.PickValue Method

EditorPropertyPickValue Method

Execute PickAction and wait for user to click on some object.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void PickValue()
public:
void PickValue()
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.PickValueProxy Method

EditorPropertyPickValueProxy Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void PickValueProxy(
    Object bindingSource
)
public:
void PickValueProxy(
    Object^ bindingSource
)

Parameters

bindingSource
Type: SystemObject
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.SetQuantity Method

EditorPropertySetQuantity Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IUnitGroup SetQuantity(
    string value
)
public:
virtual IUnitGroup^ SetQuantity(
    String^ value
) sealed

Parameters

value
Type: SystemString

Return Value

Type: IUnitGroup

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.EditorProperty.SetQuantity(System.String)"]

Implements

IPropertySetQuantity(String)
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.SetUnitMagnitude Method

EditorPropertySetUnitMagnitude Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetUnitMagnitude(
    double value
)
public:
virtual void SetUnitMagnitude(
    double value
) sealed

Parameters

value
Type: SystemDouble

Implements

IPropertySetUnitMagnitude(Double)
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.StartBatch Method

EditorPropertyStartBatch Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartBatch()
public:
virtual void StartBatch() sealed

Implements

IPropertyStartBatch
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty Events

The EditorProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | property changed event
Top
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.PropertyChanged Event

EditorPropertyPropertyChanged Event

property changed event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event PropertyChangedEventHandler PropertyChanged
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty Fields

The EditorProperty type exposes the following members.

Fields
 | Name | Description
Public field | SuppressValueChange |
Top
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


EditorProperty.SuppressValueChange Field

EditorPropertySuppressValueChange Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool SuppressValueChange
public:
bool SuppressValueChange

Field Value

Type: Boolean
See Also

Reference

EditorProperty Class
VisualComponents.UX.Shared Namespace


ElementAdorner Class

Adorner which allows to assign any FrameworkElement as its content.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.DocumentsAdorner
VisualComponents.UX.SharedElementAdorner

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ElementAdorner : Adorner
public ref class ElementAdorner : public Adorner

The ElementAdorner type exposes the following members.

Constructors
 | Name | Description
Public method | ElementAdorner | Constructor. Adds 'childElement' to the adorner's visual and logical trees.
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AdornedElement | Gets the UIElement that this adorner is bound to. (Inherited from Adorner.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Child | Returns the child element hosted in the adorner.
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsClipEnabled | Gets or sets a value that indicates whether clipping of the adorner is enabled. (Inherited from Adorner.)
Public property | IsDirty | Defines whether adorner is able to update its position on AdornerLayer. Useful when offset changes should not be updating the position or when adorner is being deleted.
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsRendered | Indicates whether adorner is placed on AdornerLayer. This property must be set manually and only after the adorner is placed onto the desired AdornerLayer.
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | (Overrides FrameworkElementLogicalChildren.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | OffsetLeft | Gets/sets the horizontal offset of the adorner.
Public property | OffsetTop | Gets/sets the vertical offset of the adorner.
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Always returns 1. (Overrides FrameworkElementVisualChildrenCount.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | (Overrides FrameworkElementArrangeOverride(Size).)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetDesiredTransform | (Overrides AdornerGetDesiredTransform(GeneralTransform).)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | For a description of this member, see GetLayoutClip(Size). (Inherited from Adorner.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | (Overrides FrameworkElementGetVisualChild(Int32).)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | (Overrides AdornerMeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetOffsets | Updates the offsets of the adorner in one atomic operation.
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
OffsetLeftProperty |
OffsetTopProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ElementAdorner Constructor

Constructor. Adds 'childElement' to the adorner's visual and logical trees.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ElementAdorner(
    UIElement adornedElement,
    FrameworkElement childElement,
    bool clipHorizontally = false,
    bool clipVertically = false,
    double offsetLeft = 0,
    double offsetTop = 0,
    bool fixHorizontally = false,
    bool fixVertically = false
)
public:
ElementAdorner(
    UIElement^ adornedElement,
    FrameworkElement^ childElement,
    bool clipHorizontally = false,
    bool clipVertically = false,
    double offsetLeft = 0,
    double offsetTop = 0,
    bool fixHorizontally = false,
    bool fixVertically = false
)

Parameters

adornedElement
Type: System.WindowsUIElement
The element to which the adorner will be bound.
childElement
Type: System.WindowsFrameworkElement
The element to be displayed in the adorner.
clipHorizontally (Optional)
Type: SystemBoolean
Defines if child element should be clipped to adorned element's Width.
clipVertically (Optional)
Type: SystemBoolean
Defines if child element should be clipped to adorned element's Height.
offsetLeft (Optional)
Type: SystemDouble
Horizontal offset of the adorner.
offsetTop (Optional)
Type: SystemDouble
Vertical offset of the adorner.
fixHorizontally (Optional)
Type: SystemBoolean
fixVertically (Optional)
Type: SystemBoolean
See Also

Reference

ElementAdorner Class
VisualComponents.UX.Shared Namespace


ElementAdorner Properties

The ElementAdorner type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AdornedElement | Gets the UIElement that this adorner is bound to. (Inherited from Adorner.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Child | Returns the child element hosted in the adorner.
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsClipEnabled | Gets or sets a value that indicates whether clipping of the adorner is enabled. (Inherited from Adorner.)
Public property | IsDirty | Defines whether adorner is able to update its position on AdornerLayer. Useful when offset changes should not be updating the position or when adorner is being deleted.
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsRendered | Indicates whether adorner is placed on AdornerLayer. This property must be set manually and only after the adorner is placed onto the desired AdornerLayer.
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | (Overrides FrameworkElementLogicalChildren.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | OffsetLeft | Gets/sets the horizontal offset of the adorner.
Public property | OffsetTop | Gets/sets the vertical offset of the adorner.
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Always returns 1. (Overrides FrameworkElementVisualChildrenCount.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ElementAdorner Class
VisualComponents.UX.Shared Namespace


ElementAdorner.Child Property

ElementAdornerChild Property

Returns the child element hosted in the adorner.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FrameworkElement Child { get; set; }
public:
property FrameworkElement^ Child {
    FrameworkElement^ get ();
    void set (FrameworkElement^ value);
}

Property Value

Type: FrameworkElement
See Also

Reference

ElementAdorner Class
VisualComponents.UX.Shared Namespace


ElementAdorner.IsDirty Property

ElementAdornerIsDirty Property

Defines whether adorner is able to update its position on AdornerLayer. Useful when offset changes should not be updating the position or when adorner is being deleted.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsDirty { get; set; }
public:
property bool IsDirty {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ElementAdorner Class
VisualComponents.UX.Shared Namespace


ElementAdorner.IsRendered Property

ElementAdornerIsRendered Property

Indicates whether adorner is placed on AdornerLayer. This property must be set manually and only after the adorner is placed onto the desired AdornerLayer.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsRendered { get; set; }
public:
property bool IsRendered {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ElementAdorner Class
VisualComponents.UX.Shared Namespace


ElementAdorner.LogicalChildren Property

ElementAdornerLogicalChildren Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override IEnumerator LogicalChildren { get; }
protected:
virtual property IEnumerator^ LogicalChildren {
    IEnumerator^ get () override;
}

Property Value

Type: IEnumerator
See Also

Reference

ElementAdorner Class
VisualComponents.UX.Shared Namespace


ElementAdorner.OffsetLeft Property

ElementAdornerOffsetLeft Property

Gets/sets the horizontal offset of the adorner.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double OffsetLeft { get; set; }
public:
property double OffsetLeft {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ElementAdorner Class
VisualComponents.UX.Shared Namespace


ElementAdorner.OffsetTop Property

ElementAdornerOffsetTop Property

Gets/sets the vertical offset of the adorner.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double OffsetTop { get; set; }
public:
property double OffsetTop {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ElementAdorner Class
VisualComponents.UX.Shared Namespace


ElementAdorner.VisualChildrenCount Property

ElementAdornerVisualChildrenCount Property

Always returns 1.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override int VisualChildrenCount { get; }
protected:
virtual property int VisualChildrenCount {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

ElementAdorner Class
VisualComponents.UX.Shared Namespace


ElementAdorner Methods

The ElementAdorner type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | (Overrides FrameworkElementArrangeOverride(Size).)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetDesiredTransform | (Overrides AdornerGetDesiredTransform(GeneralTransform).)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | For a description of this member, see GetLayoutClip(Size). (Inherited from Adorner.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | (Overrides FrameworkElementGetVisualChild(Int32).)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | (Overrides AdornerMeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetOffsets | Updates the offsets of the adorner in one atomic operation.
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ElementAdorner Class
VisualComponents.UX.Shared Namespace


ElementAdorner.ArrangeOverride Method

ElementAdornerArrangeOverride Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
protected:
virtual Size ArrangeOverride(
    Size finalSize
) override

Parameters

finalSize
Type: System.WindowsSize

Return Value

Type: Size

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ElementAdorner.ArrangeOverride(System.Windows.Size)"]

See Also

Reference

ElementAdorner Class
VisualComponents.UX.Shared Namespace


ElementAdorner.GetDesiredTransform Method

ElementAdornerGetDesiredTransform Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override GeneralTransform GetDesiredTransform(
    GeneralTransform transform
)
public:
virtual GeneralTransform^ GetDesiredTransform(
    GeneralTransform^ transform
) override

Parameters

transform
Type: System.Windows.MediaGeneralTransform

Return Value

Type: GeneralTransform

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ElementAdorner.GetDesiredTransform(System.Windows.Media.GeneralTransform)"]

See Also

Reference

ElementAdorner Class
VisualComponents.UX.Shared Namespace


ElementAdorner.GetVisualChild Method

ElementAdornerGetVisualChild Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Visual GetVisualChild(
    int index
)
protected:
virtual Visual^ GetVisualChild(
    int index
) override

Parameters

index
Type: SystemInt32

Return Value

Type: Visual

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ElementAdorner.GetVisualChild(System.Int32)"]

See Also

Reference

ElementAdorner Class
VisualComponents.UX.Shared Namespace


ElementAdorner.MeasureOverride Method

ElementAdornerMeasureOverride Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Size MeasureOverride(
    Size constraint
)
protected:
virtual Size MeasureOverride(
    Size constraint
) override

Parameters

constraint
Type: System.WindowsSize

Return Value

Type: Size

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ElementAdorner.MeasureOverride(System.Windows.Size)"]

See Also

Reference

ElementAdorner Class
VisualComponents.UX.Shared Namespace


ElementAdorner.SetOffsets Method

ElementAdornerSetOffsets Method

Updates the offsets of the adorner in one atomic operation.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetOffsets(
    double left,
    double top
)
public:
void SetOffsets(
    double left,
    double top
)

Parameters

left
Type: SystemDouble
top
Type: SystemDouble
See Also

Reference

ElementAdorner Class
VisualComponents.UX.Shared Namespace


ElementAdorner Events

The ElementAdorner type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ElementAdorner Class
VisualComponents.UX.Shared Namespace


ElementAdorner Fields

The ElementAdorner type exposes the following members.

Fields
Name | Description
OffsetLeftProperty |
OffsetTopProperty |
Top
See Also

Reference

ElementAdorner Class
VisualComponents.UX.Shared Namespace


ElementAdorner.OffsetLeftProperty Field

ElementAdornerOffsetLeftProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty OffsetLeftProperty
public:
static initonly DependencyProperty^ OffsetLeftProperty

Field Value

Type: DependencyProperty
See Also

Reference

ElementAdorner Class
VisualComponents.UX.Shared Namespace


ElementAdorner.OffsetTopProperty Field

ElementAdornerOffsetTopProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty OffsetTopProperty
public:
static initonly DependencyProperty^ OffsetTopProperty

Field Value

Type: DependencyProperty
See Also

Reference

ElementAdorner Class
VisualComponents.UX.Shared Namespace


ElementType Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ElementType
public enum class ElementType
Members
Member name | Value | Description
Row | 0 |
Column | 1 |
Control | 2 |
Tab | 3 |
TabPage | 4 |
ContentControl | 5 |
See Also

Reference

VisualComponents.UX.Shared Namespace


EmailValidationRule Class

Inheritance Hierarchy
SystemObject
System.Windows.ControlsValidationRule
VisualComponents.UX.SharedEmailValidationRule

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class EmailValidationRule : ValidationRule
public ref class EmailValidationRule : public ValidationRule

The EmailValidationRule type exposes the following members.

Constructors
 | Name | Description
Public method | EmailValidationRule | Initializes a new instance of the EmailValidationRule class
Top
Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


EmailValidationRule Constructor

Initializes a new instance of the EmailValidationRule class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EmailValidationRule()
public:
EmailValidationRule()
See Also

Reference

EmailValidationRule Class
VisualComponents.UX.Shared Namespace


EmailValidationRule Properties

The EmailValidationRule type exposes the following members.

Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
See Also

Reference

EmailValidationRule Class
VisualComponents.UX.Shared Namespace


EmailValidationRule Methods

The EmailValidationRule type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

EmailValidationRule Class
VisualComponents.UX.Shared Namespace


EmailValidationRule.Validate Method

EmailValidationRuleValidate Method

Overload List
 | Name | Description
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
See Also

Reference

EmailValidationRule Class
VisualComponents.UX.Shared Namespace


EmailValidationRule.Validate Method (Object, CultureInfo)

EmailValidationRuleValidate Method (Object, CultureInfo)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override ValidationResult Validate(
    Object value,
    CultureInfo cultureInfo
)
public:
virtual ValidationResult^ Validate(
    Object^ value,
    CultureInfo^ cultureInfo
) override

Parameters

value
Type: SystemObject
cultureInfo
Type: System.GlobalizationCultureInfo

Return Value

Type: ValidationResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.EmailValidationRule.Validate(System.Object,System.Globalization.CultureInfo)"]

See Also

Reference

EmailValidationRule Class
Validate Overload
VisualComponents.UX.Shared Namespace


EmptyToVisibilityConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedEmptyToVisibilityConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class EmptyToVisibilityConverter : IMultiValueConverter
public ref class EmptyToVisibilityConverter : IMultiValueConverter

The EmptyToVisibilityConverter type exposes the following members.

Constructors
 | Name | Description
Public method | EmptyToVisibilityConverter | Initializes a new instance of the EmptyToVisibilityConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


EmptyToVisibilityConverter Constructor

Initializes a new instance of the EmptyToVisibilityConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EmptyToVisibilityConverter()
public:
EmptyToVisibilityConverter()
See Also

Reference

EmptyToVisibilityConverter Class
VisualComponents.UX.Shared Namespace


EmptyToVisibilityConverter Methods

The EmptyToVisibilityConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

EmptyToVisibilityConverter Class
VisualComponents.UX.Shared Namespace


EmptyToVisibilityConverter.Convert Method

EmptyToVisibilityConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    array<Object^>^ values,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

values
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.EmptyToVisibilityConverter.Convert(System.Object[],System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

EmptyToVisibilityConverter Class
VisualComponents.UX.Shared Namespace


EmptyToVisibilityConverter.ConvertBack Method

EmptyToVisibilityConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
public:
virtual array<Object^>^ ConvertBack(
    Object^ value,
    array<Type^>^ targetTypes,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetTypes
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.EmptyToVisibilityConverter.ConvertBack(System.Object,System.Type[],System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

EmptyToVisibilityConverter Class
VisualComponents.UX.Shared Namespace


EndInteractionMessage Class

Interaction ended message. Used to update the UI and WPF graphics.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedEndInteractionMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class EndInteractionMessage
public ref class EndInteractionMessage sealed

The EndInteractionMessage type exposes the following members.

Constructors
 | Name | Description
Public method | EndInteractionMessage | Initializes a new instance of the EndInteractionMessage class
Top
Properties
 | Name | Description
Public property | Action | The Action that ended.
Public property | Args |
Public property | PlugPlayWasUsed | True if PnP was used during the interaction.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


EndInteractionMessage Constructor

Initializes a new instance of the EndInteractionMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EndInteractionMessage()
public:
EndInteractionMessage()
See Also

Reference

EndInteractionMessage Class
VisualComponents.UX.Shared Namespace


EndInteractionMessage Properties

The EndInteractionMessage type exposes the following members.

Properties
 | Name | Description
Public property | Action | The Action that ended.
Public property | Args |
Public property | PlugPlayWasUsed | True if PnP was used during the interaction.
Top
See Also

Reference

EndInteractionMessage Class
VisualComponents.UX.Shared Namespace


EndInteractionMessage.Action Property

EndInteractionMessageAction Property

The Action that ended.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Action Action { get; set; }
public:
property Action Action {
    Action get ();
    void set (Action value);
}

Property Value

Type: Action
See Also

Reference

EndInteractionMessage Class
VisualComponents.UX.Shared Namespace


EndInteractionMessage.Args Property

EndInteractionMessageArgs Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ManipulationEventArgs Args { get; set; }
public:
property ManipulationEventArgs^ Args {
    ManipulationEventArgs^ get ();
    void set (ManipulationEventArgs^ value);
}

Property Value

Type: ManipulationEventArgs
See Also

Reference

EndInteractionMessage Class
VisualComponents.UX.Shared Namespace


EndInteractionMessage.PlugPlayWasUsed Property

EndInteractionMessagePlugPlayWasUsed Property

True if PnP was used during the interaction.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool PlugPlayWasUsed { get; set; }
public:
property bool PlugPlayWasUsed {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

EndInteractionMessage Class
VisualComponents.UX.Shared Namespace


EndInteractionMessage Methods

The EndInteractionMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

EndInteractionMessage Class
VisualComponents.UX.Shared Namespace


EnumBindingSourceExtension Class

Helper class to assign itemsourse from enum .
Inheritance Hierarchy
SystemObject
System.Windows.MarkupMarkupExtension
VisualComponents.UX.SharedEnumBindingSourceExtension

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class EnumBindingSourceExtension : MarkupExtension
public ref class EnumBindingSourceExtension : public MarkupExtension

The EnumBindingSourceExtension type exposes the following members.

Constructors
 | Name | Description
Public method | EnumBindingSourceExtension | Initializes a new instance of the EnumBindingSourceExtension class
Public method | EnumBindingSourceExtension(Type) | Initializes a new instance of the EnumBindingSourceExtension class
Top
Properties
 | Name | Description
Public property | EnumType |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProvideValue | (Overrides MarkupExtensionProvideValue(IServiceProvider).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


EnumBindingSourceExtension Constructor

Overload List
 | Name | Description
Public method | EnumBindingSourceExtension | Initializes a new instance of the EnumBindingSourceExtension class
Public method | EnumBindingSourceExtension(Type) | Initializes a new instance of the EnumBindingSourceExtension class
Top
See Also

Reference

EnumBindingSourceExtension Class
VisualComponents.UX.Shared Namespace


EnumBindingSourceExtension Constructor

Initializes a new instance of the EnumBindingSourceExtension class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EnumBindingSourceExtension()
public:
EnumBindingSourceExtension()
See Also

Reference

EnumBindingSourceExtension Class
EnumBindingSourceExtension Overload
VisualComponents.UX.Shared Namespace


EnumBindingSourceExtension Constructor (Type)

Initializes a new instance of the EnumBindingSourceExtension class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EnumBindingSourceExtension(
    Type enumType
)
public:
EnumBindingSourceExtension(
    Type^ enumType
)

Parameters

enumType
Type: SystemType
See Also

Reference

EnumBindingSourceExtension Class
EnumBindingSourceExtension Overload
VisualComponents.UX.Shared Namespace


EnumBindingSourceExtension Properties

The EnumBindingSourceExtension type exposes the following members.

Properties
 | Name | Description
Public property | EnumType |
Top
See Also

Reference

EnumBindingSourceExtension Class
VisualComponents.UX.Shared Namespace


EnumBindingSourceExtension.EnumType Property

EnumBindingSourceExtensionEnumType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type EnumType { get; set; }
public:
property Type^ EnumType {
    Type^ get ();
    void set (Type^ value);
}

Property Value

Type: Type
See Also

Reference

EnumBindingSourceExtension Class
VisualComponents.UX.Shared Namespace


EnumBindingSourceExtension Methods

The EnumBindingSourceExtension type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProvideValue | (Overrides MarkupExtensionProvideValue(IServiceProvider).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

EnumBindingSourceExtension Class
VisualComponents.UX.Shared Namespace


EnumBindingSourceExtension.ProvideValue Method

EnumBindingSourceExtensionProvideValue Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override Object ProvideValue(
    IServiceProvider serviceProvider
)
public:
virtual Object^ ProvideValue(
    IServiceProvider^ serviceProvider
) override

Parameters

serviceProvider
Type: SystemIServiceProvider

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.EnumBindingSourceExtension.ProvideValue(System.IServiceProvider)"]

See Also

Reference

EnumBindingSourceExtension Class
VisualComponents.UX.Shared Namespace


EnumerableHelper Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedEnumerableHelper

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class EnumerableHelper
[ExtensionAttribute]
public ref class EnumerableHelper abstract sealed

The EnumerableHelper type exposes the following members.

Methods
Name | Description
HasMoreThanT |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


EnumerableHelper Methods

The EnumerableHelper type exposes the following members.

Methods
Name | Description
HasMoreThanT |
Top
See Also

Reference

EnumerableHelper Class
VisualComponents.UX.Shared Namespace


EnumerableHelper.HasMoreThan(T) Method

EnumerableHelperHasMoreThanT Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool HasMoreThan<T>(
    this IEnumerable<T> source,
    int items
)

public:
[ExtensionAttribute]
generic<typename T>
static bool HasMoreThan(
    IEnumerable<T>^ source,
    int items
)

Parameters

source
Type: System.Collections.GenericIEnumerableT
items
Type: SystemInt32

Type Parameters

T

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.EnumerableHelper.HasMoreThan``1(System.Collections.Generic.IEnumerable{``0},System.Int32)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerableT. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

EnumerableHelper Class
VisualComponents.UX.Shared Namespace


EnumToBooleanConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedEnumToBooleanConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class EnumToBooleanConverter : IValueConverter
public ref class EnumToBooleanConverter : IValueConverter

The EnumToBooleanConverter type exposes the following members.

Constructors
 | Name | Description
Public method | EnumToBooleanConverter | Initializes a new instance of the EnumToBooleanConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


EnumToBooleanConverter Constructor

Initializes a new instance of the EnumToBooleanConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EnumToBooleanConverter()
public:
EnumToBooleanConverter()
See Also

Reference

EnumToBooleanConverter Class
VisualComponents.UX.Shared Namespace


EnumToBooleanConverter Methods

The EnumToBooleanConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

EnumToBooleanConverter Class
VisualComponents.UX.Shared Namespace


EnumToBooleanConverter.Convert Method

EnumToBooleanConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.EnumToBooleanConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

EnumToBooleanConverter Class
VisualComponents.UX.Shared Namespace


EnumToBooleanConverter.ConvertBack Method

EnumToBooleanConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.EnumToBooleanConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

EnumToBooleanConverter Class
VisualComponents.UX.Shared Namespace


EventHelper Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedEventHelper

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class EventHelper
public ref class EventHelper abstract sealed
Methods
Name | Description
Schedule(FuncBoolean, ActionEventHandler, ActionEventHandler) |
Schedule(FuncBoolean, ActionDependencyPropertyChangedEventHandler, ActionDependencyPropertyChangedEventHandler) |
Schedule(FuncBoolean, ActionRoutedEventHandler, ActionRoutedEventHandler) |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


EventHelper Methods

Methods
Name | Description
Schedule(FuncBoolean, ActionEventHandler, ActionEventHandler) |
Schedule(FuncBoolean, ActionDependencyPropertyChangedEventHandler, ActionDependencyPropertyChangedEventHandler) |
Schedule(FuncBoolean, ActionRoutedEventHandler, ActionRoutedEventHandler) |
Top
See Also

Reference

EventHelper Class
VisualComponents.UX.Shared Namespace


EventHelper.Schedule Method

EventHelperSchedule Method

Overload List
Name | Description
Schedule(FuncBoolean, ActionEventHandler, ActionEventHandler) |
Schedule(FuncBoolean, ActionDependencyPropertyChangedEventHandler, ActionDependencyPropertyChangedEventHandler) |
Schedule(FuncBoolean, ActionRoutedEventHandler, ActionRoutedEventHandler) |
Top
See Also

Reference

EventHelper Class
VisualComponents.UX.Shared Namespace


EventHelper.Schedule Method (Func(Boolean), Action(EventHandler), Action(EventHandler))

EventHelperSchedule Method (FuncBoolean, ActionEventHandler, ActionEventHandler)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void Schedule(
    Func<bool> action,
    Action<EventHandler> eventConstructor,
    Action<EventHandler> eventDestructor
)
public:
static void Schedule(
    Func<bool>^ action,
    Action<EventHandler^>^ eventConstructor,
    Action<EventHandler^>^ eventDestructor
)

Parameters

action
Type: SystemFuncBoolean
eventConstructor
Type: SystemActionEventHandler
eventDestructor
Type: SystemActionEventHandler
See Also

Reference

EventHelper Class
Schedule Overload
VisualComponents.UX.Shared Namespace


EventHelper.Schedule Method (Func(Boolean), Action(DependencyPropertyChangedEventHandler), Action(DependencyPropertyChangedEventHandler))

EventHelperSchedule Method (FuncBoolean, ActionDependencyPropertyChangedEventHandler, ActionDependencyPropertyChangedEventHandler)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void Schedule(
    Func<bool> action,
    Action<DependencyPropertyChangedEventHandler> eventConstructor,
    Action<DependencyPropertyChangedEventHandler> eventDestructor
)
public:
static void Schedule(
    Func<bool>^ action,
    Action<DependencyPropertyChangedEventHandler^>^ eventConstructor,
    Action<DependencyPropertyChangedEventHandler^>^ eventDestructor
)

Parameters

action
Type: SystemFuncBoolean
eventConstructor
Type: SystemActionDependencyPropertyChangedEventHandler
eventDestructor
Type: SystemActionDependencyPropertyChangedEventHandler
See Also

Reference

EventHelper Class
Schedule Overload
VisualComponents.UX.Shared Namespace


EventHelper.Schedule Method (Func(Boolean), Action(RoutedEventHandler), Action(RoutedEventHandler))

EventHelperSchedule Method (FuncBoolean, ActionRoutedEventHandler, ActionRoutedEventHandler)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void Schedule(
    Func<bool> action,
    Action<RoutedEventHandler> eventConstructor,
    Action<RoutedEventHandler> eventDestructor
)
public:
static void Schedule(
    Func<bool>^ action,
    Action<RoutedEventHandler^>^ eventConstructor,
    Action<RoutedEventHandler^>^ eventDestructor
)

Parameters

action
Type: SystemFuncBoolean
eventConstructor
Type: SystemActionRoutedEventHandler
eventDestructor
Type: SystemActionRoutedEventHandler
See Also

Reference

EventHelper Class
Schedule Overload
VisualComponents.UX.Shared Namespace


ExchangeRobotAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedExchangeRobotAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ExchangeRobotAction : IResult
public ref class ExchangeRobotAction : IResult

The ExchangeRobotAction type exposes the following members.

Constructors
 | Name | Description
Public method | ExchangeRobotAction | Initializes a new instance of the ExchangeRobotAction class
Top
Properties
 | Name | Description
Public property | ExchangeFrameNames |
Public property | RobotA |
Public property | RobotB |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToggleDebugExchangeAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Completed |
Top
Fields
Name | Description
DebugExchangeAction |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ExchangeRobotAction Constructor

Initializes a new instance of the ExchangeRobotAction class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ExchangeRobotAction()
public:
ExchangeRobotAction()
See Also

Reference

ExchangeRobotAction Class
VisualComponents.UX.Shared Namespace


ExchangeRobotAction Properties

The ExchangeRobotAction type exposes the following members.

Properties
 | Name | Description
Public property | ExchangeFrameNames |
Public property | RobotA |
Public property | RobotB |
Top
See Also

Reference

ExchangeRobotAction Class
VisualComponents.UX.Shared Namespace


ExchangeRobotAction.ExchangeFrameNames Property

ExchangeRobotActionExchangeFrameNames Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ExchangeFrameNames { get; set; }
public:
property bool ExchangeFrameNames {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ExchangeRobotAction Class
VisualComponents.UX.Shared Namespace


ExchangeRobotAction.RobotA Property

ExchangeRobotActionRobotA Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IRobot RobotA { get; set; }
public:
property IRobot^ RobotA {
    IRobot^ get ();
    void set (IRobot^ value);
}

Property Value

Type: IRobot
See Also

Reference

ExchangeRobotAction Class
VisualComponents.UX.Shared Namespace


ExchangeRobotAction.RobotB Property

ExchangeRobotActionRobotB Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IRobot RobotB { get; set; }
public:
property IRobot^ RobotB {
    IRobot^ get ();
    void set (IRobot^ value);
}

Property Value

Type: IRobot
See Also

Reference

ExchangeRobotAction Class
VisualComponents.UX.Shared Namespace


ExchangeRobotAction Methods

The ExchangeRobotAction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToggleDebugExchangeAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ExchangeRobotAction Class
VisualComponents.UX.Shared Namespace


ExchangeRobotAction.Execute Method

ExchangeRobotActionExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    ActionExecutionContext context
)
public:
virtual void Execute(
    ActionExecutionContext^ context
) sealed

Parameters

context
Type: ActionExecutionContext

Implements

IResult.Execute(ActionExecutionContext)
See Also

Reference

ExchangeRobotAction Class
VisualComponents.UX.Shared Namespace


ExchangeRobotAction.ToggleDebugExchangeAction Method

ExchangeRobotActionToggleDebugExchangeAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int ToggleDebugExchangeAction()
public:
static int ToggleDebugExchangeAction()

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ExchangeRobotAction.ToggleDebugExchangeAction"]

See Also

Reference

ExchangeRobotAction Class
VisualComponents.UX.Shared Namespace


ExchangeRobotAction Events

The ExchangeRobotAction type exposes the following members.

Events
 | Name | Description
Public event | Completed |
Top
See Also

Reference

ExchangeRobotAction Class
VisualComponents.UX.Shared Namespace


ExchangeRobotAction.Completed Event

ExchangeRobotActionCompleted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ResultCompletionEventArgs> Completed
public:
virtual  event EventHandler<ResultCompletionEventArgs^>^ Completed {
    void add (EventHandler<ResultCompletionEventArgs^>^ value);
    void remove (EventHandler<ResultCompletionEventArgs^>^ value);
}

Value

Type: SystemEventHandlerResultCompletionEventArgs

Implements

IResult.Completed
See Also

Reference

ExchangeRobotAction Class
VisualComponents.UX.Shared Namespace


ExchangeRobotAction Fields

The ExchangeRobotAction type exposes the following members.

Fields
Name | Description
DebugExchangeAction |
Top
See Also

Reference

ExchangeRobotAction Class
VisualComponents.UX.Shared Namespace


ExchangeRobotAction.DebugExchangeAction Field

ExchangeRobotActionDebugExchangeAction Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int DebugExchangeAction
public:
static int DebugExchangeAction

Field Value

Type: Int32
See Also

Reference

ExchangeRobotAction Class
VisualComponents.UX.Shared Namespace


ExecuteCommandMessage Class

Note: This API is now obsolete.

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedExecuteCommandMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Execute commands directly via commmand manager")]
public class ExecuteCommandMessage
[ObsoleteAttribute(L"Execute commands directly via commmand manager")]
public ref class ExecuteCommandMessage

The ExecuteCommandMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ExecuteCommandMessage | Initializes a new instance of the ExecuteCommandMessage class
Top
Properties
 | Name | Description
Public property | CommandToExecute |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ExecuteCommandMessage Constructor

Initializes a new instance of the ExecuteCommandMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ExecuteCommandMessage()
public:
ExecuteCommandMessage()
See Also

Reference

ExecuteCommandMessage Class
VisualComponents.UX.Shared Namespace


ExecuteCommandMessage Properties

The ExecuteCommandMessage type exposes the following members.

Properties
 | Name | Description
Public property | CommandToExecute |
Top
See Also

Reference

ExecuteCommandMessage Class
VisualComponents.UX.Shared Namespace


ExecuteCommandMessage.CommandToExecute Property

ExecuteCommandMessageCommandToExecute Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ICommand CommandToExecute { get; set; }
public:
property ICommand^ CommandToExecute {
    ICommand^ get ();
    void set (ICommand^ value);
}

Property Value

Type: ICommand
See Also

Reference

ExecuteCommandMessage Class
VisualComponents.UX.Shared Namespace


ExecuteCommandMessage Methods

The ExecuteCommandMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ExecuteCommandMessage Class
VisualComponents.UX.Shared Namespace


ExpanderPropertyExtender Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
VisualComponents.UX.SharedExpanderPropertyExtender

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ExpanderPropertyExtender : DependencyObject
public ref class ExpanderPropertyExtender : public DependencyObject

The ExpanderPropertyExtender type exposes the following members.

Constructors
 | Name | Description
Public method | ExpanderPropertyExtender | Initializes a new instance of the ExpanderPropertyExtender class
Top
Properties
 | Name | Description
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
 | GetIsExpanderHeaderVisible |
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from DependencyObject.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
 | SetIsExpanderHeaderVisible |
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
IsExpanderHeaderVisibleProperty |
Top
Attached Properties
 | Name | Description
Public attached property | IsExpanderHeaderVisible |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ExpanderPropertyExtender Constructor

Initializes a new instance of the ExpanderPropertyExtender class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ExpanderPropertyExtender()
public:
ExpanderPropertyExtender()
See Also

Reference

ExpanderPropertyExtender Class
VisualComponents.UX.Shared Namespace


ExpanderPropertyExtender Properties

The ExpanderPropertyExtender type exposes the following members.

Properties
 | Name | Description
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Top
See Also

Reference

ExpanderPropertyExtender Class
VisualComponents.UX.Shared Namespace


ExpanderPropertyExtender Methods

The ExpanderPropertyExtender type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
 | GetIsExpanderHeaderVisible |
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from DependencyObject.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
 | SetIsExpanderHeaderVisible |
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ExpanderPropertyExtender Class
VisualComponents.UX.Shared Namespace


ExpanderPropertyExtender.GetIsExpanderHeaderVisible Method

ExpanderPropertyExtenderGetIsExpanderHeaderVisible Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetIsExpanderHeaderVisible(
    UIElement element
)
public:
static String^ GetIsExpanderHeaderVisible(
    UIElement^ element
)

Parameters

element
Type: System.WindowsUIElement

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ExpanderPropertyExtender.GetIsExpanderHeaderVisible(System.Windows.UIElement)"]

See Also

Reference

ExpanderPropertyExtender Class
VisualComponents.UX.Shared Namespace


ExpanderPropertyExtender.SetIsExpanderHeaderVisible Method

ExpanderPropertyExtenderSetIsExpanderHeaderVisible Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetIsExpanderHeaderVisible(
    UIElement element,
    Object o
)
public:
static void SetIsExpanderHeaderVisible(
    UIElement^ element,
    Object^ o
)

Parameters

element
Type: System.WindowsUIElement
o
Type: SystemObject
See Also

Reference

ExpanderPropertyExtender Class
VisualComponents.UX.Shared Namespace


ExpanderPropertyExtender Fields

The ExpanderPropertyExtender type exposes the following members.

Fields
Name | Description
IsExpanderHeaderVisibleProperty |
Top
See Also

Reference

ExpanderPropertyExtender Class
VisualComponents.UX.Shared Namespace


ExpanderPropertyExtender.IsExpanderHeaderVisibleProperty Field

ExpanderPropertyExtenderIsExpanderHeaderVisibleProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsExpanderHeaderVisibleProperty
public:
static initonly DependencyProperty^ IsExpanderHeaderVisibleProperty

Field Value

Type: DependencyProperty
See Also

Reference

ExpanderPropertyExtender Class
VisualComponents.UX.Shared Namespace


ExpanderPropertyExtender Attached Properties

The ExpanderPropertyExtender type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | IsExpanderHeaderVisible |
Top
See Also

Reference

ExpanderPropertyExtender Class
VisualComponents.UX.Shared Namespace


ExpanderPropertyExtender.IsExpanderHeaderVisible Attached Property

ExpanderPropertyExtenderIsExpanderHeaderVisible Attached Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See GetIsExpanderHeaderVisible, SetIsExpanderHeaderVisible
See GetIsExpanderHeaderVisible, SetIsExpanderHeaderVisible

Property Value

Type: String
See Also

Reference

ExpanderPropertyExtender Class
VisualComponents.UX.Shared Namespace


ExportCommandMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedExportCommandMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ExportCommandMessage
public ref class ExportCommandMessage

The ExportCommandMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ExportCommandMessage | Initializes a new instance of the ExportCommandMessage class
Top
Properties
 | Name | Description
Public property | Status |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | LocalPath |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ExportCommandMessage Constructor

Initializes a new instance of the ExportCommandMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ExportCommandMessage(
    string filepath,
    FileStatus status = FileStatus.Unknown
)
public:
ExportCommandMessage(
    String^ filepath,
    FileStatus status = FileStatus::Unknown
)

Parameters

filepath
Type: SystemString
status (Optional)
Type: VisualComponents.UX.SharedFileStatus
See Also

Reference

ExportCommandMessage Class
VisualComponents.UX.Shared Namespace


ExportCommandMessage Properties

The ExportCommandMessage type exposes the following members.

Properties
 | Name | Description
Public property | Status |
Top
See Also

Reference

ExportCommandMessage Class
VisualComponents.UX.Shared Namespace


ExportCommandMessage.Status Property

ExportCommandMessageStatus Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FileStatus Status { get; }
public:
property FileStatus Status {
    FileStatus get ();
}

Property Value

Type: FileStatus
See Also

Reference

ExportCommandMessage Class
VisualComponents.UX.Shared Namespace


ExportCommandMessage Methods

The ExportCommandMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ExportCommandMessage Class
VisualComponents.UX.Shared Namespace


ExportCommandMessage Fields

The ExportCommandMessage type exposes the following members.

Fields
 | Name | Description
Public field | LocalPath |
Top
See Also

Reference

ExportCommandMessage Class
VisualComponents.UX.Shared Namespace


ExportCommandMessage.LocalPath Field

ExportCommandMessageLocalPath Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public readonly string LocalPath
public:
initonly String^ LocalPath

Field Value

Type: String
See Also

Reference

ExportCommandMessage Class
VisualComponents.UX.Shared Namespace


ExpressionEditor Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.Controls.PrimitivesTextBoxBase
System.Windows.ControlsTextBox
VisualComponents.UX.SharedUndoableTextBox
VisualComponents.UX.SharedExtendedTextBox
VisualComponents.UX.SharedExpressionEditor

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ExpressionEditor : ExtendedTextBox
public ref class ExpressionEditor : public ExtendedTextBox

The ExpressionEditor type exposes the following members.

Constructors
 | Name | Description
Public method | ExpressionEditor | Initializes a new instance of the ExpressionEditor class
Top
Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key. (Inherited from TextBoxBase.)
Public property | AcceptsTab | Gets or sets a value that indicates how the text editing control responds when the user presses the TAB key. (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoWordSelection | Gets or sets a value that determines whether when a user selects part of a word by dragging across it with the mouse, the rest of the word is selected. (Inherited from TextBoxBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanRedo | Gets a value that indicates whether the most recent undo action can be redone. (Inherited from TextBoxBase.)
Public property | CanUndo | Gets a value that indicates whether the most recent action can be undone. (Inherited from TextBoxBase.)
Public property | CaretBrush | Gets or sets the brush that is used to paint the caret of the text box. (Inherited from TextBoxBase.)
Public property | CaretIndex | Gets or sets the insertion position index of the caret. (Inherited from TextBox.)
Public property | CharacterCasing | Gets or sets how characters are cased when they are manually entered into the text box. (Inherited from TextBox.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExpressionContext | Decimal and digit (Inherited from ExtendedTextBox.)
Public property | ExtentHeight | Gets the vertical size of the visible content area. (Inherited from TextBoxBase.)
Public property | ExtentWidth | Gets the horizontal size of the visible content area. (Inherited from TextBoxBase.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Gets or sets the horizontal scroll position. (Inherited from TextBoxBase.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal scroll bar is shown. (Inherited from TextBoxBase.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInactiveSelectionHighlightEnabled | Gets or sets a value that indicates whether the text box displays selected text when the text box does not have focus. (Inherited from TextBoxBase.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that indicates whether the text editing control is read-only to a user interacting with the control. (Inherited from TextBoxBase.)
Public property | IsReadOnlyCaretVisible | Gets or sets a value that indicates whether a read-only text box displays a caret. (Inherited from TextBoxBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionActive | Gets a value that indicates whether the text box has focus and selected text. (Inherited from TextBoxBase.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets a value that indicates whether undo support is enabled for the text-editing control. (Inherited from TextBoxBase.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | LineCount | Gets the total number of lines in the text box. (Inherited from TextBox.)
Protected property | LogicalChildren | Gets an enumerator for the logical child elements of the TextBox. (Inherited from TextBox.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxLength | Gets or sets the maximum number of characters that can be manually entered into the text box. (Inherited from TextBox.)
Public property | MaxLines | Gets or sets the maximum number of visible lines. (Inherited from TextBox.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinLines | Gets or sets the minimum number of visible lines. (Inherited from TextBox.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedText | Gets or sets the content of the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionBrush | Gets or sets the brush that highlights selected text. (Inherited from TextBoxBase.)
Public property | SelectionLength | Gets or sets a value indicating the number of characters in the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionOpacity | Gets or sets the opacity of the SelectionBrush. (Inherited from TextBoxBase.)
Public property | SelectionStart | Gets or sets a character index for the beginning of the current selection. (Inherited from TextBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | SpellCheck | Gets a SpellCheck object that provides access to spelling errors in the text contents of a TextBoxBase or RichTextBox. (Inherited from TextBoxBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | SupportExpressions | (Inherited from ExtendedTextBox.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Gets or sets the text contents of the text box. (Inherited from TextBox.)
Public property | TextAlignment | Gets or sets the horizontal alignment of the contents of the text box. (Inherited from TextBox.)
Public property | TextDecorations | Gets the text decorations to apply to the text box. (Inherited from TextBox.)
Public property | TextInputType | (Inherited from ExtendedTextBox.)
Public property | TextWrapping | Gets or sets how the text box should wrap text. (Inherited from TextBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Typography | Gets the currently effective typography variations for the text contents of the text box. (Inherited from TextBox.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UndoLimit | Gets or sets the number of actions stored in the undo queue. (Inherited from TextBoxBase.)
Public property | UnitVisibility | Show or hide units. (Inherited from ExtendedTextBox.)
Public property | UpdateAfterAnyKey | If true, updates the source when any key is pressed. (Inherited from ExtendedTextBox.)
Public property | UpdateOnLostFocusTriggerOnly | If false, updates the source also when the Enter key is pressed, otherwise default (on lost focus). (Inherited from ExtendedTextBox.)
Public property | UseCustomUndo | (Inherited from UndoableTextBox.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Gets or sets the vertical scroll position. (Inherited from TextBoxBase.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical scroll bar is shown. (Inherited from TextBoxBase.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | ViewportHeight | Gets the vertical size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | ViewportWidth | Gets the horizontal size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AppendText | Appends a string to the contents of a text control. (Inherited from TextBoxBase.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginChange | Begins a change block. (Inherited from TextBoxBase.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | Clears all the content from the text box. (Inherited from TextBox.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Copy | Copies the current selection of the text editing control to the Clipboard. (Inherited from TextBoxBase.)
Public method | Cut | Removes the current selection from the text editing control and copies it to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeclareChangeBlock | Creates a change block. (Inherited from TextBoxBase.)
Public method | EndChange | Ends a change block. (Inherited from TextBoxBase.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetCharacterIndexFromLineIndex | Returns the zero-based character index for the first character in the specified line. (Inherited from TextBox.)
Public method | GetCharacterIndexFromPoint | Returns the zero-based index of the character that is closest to the specified point. (Inherited from TextBox.)
Public method | GetFirstVisibleLineIndex | Returns the line index for the first line that is currently visible in the text box. (Inherited from TextBox.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLastVisibleLineIndex | Returns the line index for the last line that is currently visible in the text box. (Inherited from TextBox.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLineIndexFromCharacterIndex | Returns the zero-based line index for the line that contains the specified character index. (Inherited from TextBox.)
Public method | GetLineLength | Returns the number of characters in the specified line. (Inherited from TextBox.)
Public method | GetLineText | Returns the text that is currently displayed on the specified line. (Inherited from TextBox.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetNextSpellingErrorCharacterIndex | Returns the beginning character index for the next spelling error in the contents of the text box. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32) | Returns the rectangle for the leading edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32, Boolean) | Returns the rectangle for the leading or trailing edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetSpellingError | Returns a SpellingError object associated with any spelling error at the specified character index. (Inherited from TextBox.)
Public method | GetSpellingErrorLength | Returns the length of any spelling error that includes the specified character. (Inherited from TextBox.)
Public method | GetSpellingErrorStart | Returns the beginning character index for any spelling error that includes the specified character. (Inherited from TextBox.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls the contents of the control down by one line. (Inherited from TextBoxBase.)
Public method | LineLeft | Scrolls the contents of the control to the left by one line. (Inherited from TextBoxBase.)
Public method | LineRight | Scrolls the contents of the control to the right by one line. (Inherited from TextBoxBase.)
Public method | LineUp | Scrolls the contents of the control upward by one line. (Inherited from TextBoxBase.)
Public method | LockCurrentUndoUnit | Locks the most recent undo unit of the undo stack of the application. This prevents the locked unit from being merged with undo units that are added subsequently. (Inherited from TextBoxBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Sizes the text box to its content. (Inherited from TextBox.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from ExtendedTextBox.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Called whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for the text box. (Inherited from TextBox.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragLeave | Invoked whenever an unhandled DragLeave attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragOver | Invoked whenever an unhandled DragOver attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDrop | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGiveFeedback | Invoked whenever an unhandled GiveFeedback attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotFocus | (Inherited from ExtendedTextBox.)
Protected method | OnGotKeyboardFocus | (Inherited from ExtendedTextBox.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | (Inherited from UndoableTextBox.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked whenever an unhandled KeyDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnKeyUp | Invoked whenever an unhandled KeyUp attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostFocus | (Inherited from ExtendedTextBox.)
Protected method | OnLostKeyboardFocus | (Inherited from ExtendedTextBox.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked whenever an unhandled MouseDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked whenever an unhandled MouseMove attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked whenever an unhandled MouseUp event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Is called when a MouseWheel event is routed to this class (or to a class that inherits from this class). (Inherited from TextBoxBase.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | (Inherited from ExtendedTextBox.)
Protected method | OnPreviewKeyUp | (Inherited from ExtendedTextBox.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | (Inherited from ExtendedTextBox.)
Protected method | OnPreviewMouseDown | (Inherited from ExtendedTextBox.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Ignore incorrect characters (one by one) (Inherited from ExtendedTextBox.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Called when one or more of the dependency properties that exist on the element have had their effective values changed. (Inherited from TextBox.)
Protected method | OnQueryContinueDrag | Invoked whenever an unhandled QueryContinueDrag attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnQueryCursor | Invoked whenever an unhandled QueryCursor attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Is called when the caret or current selection changes position. (Inherited from TextBoxBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Is called when the control template changes. (Inherited from TextBoxBase.)
Protected method | OnTextChanged | (Inherited from ExtendedTextBox.)
Protected method | OnTextInput | Invoked whenever an unhandled TextInput attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | PageDown | Scrolls the contents of the control down by one page. (Inherited from TextBoxBase.)
Public method | PageLeft | Scrolls the contents of the control to the left by one page. (Inherited from TextBoxBase.)
Public method | PageRight | Scrolls the contents of the control to the right by one page. (Inherited from TextBoxBase.)
Public method | PageUp | Scrolls the contents of the control up by one page. (Inherited from TextBoxBase.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | Paste | Pastes the contents of the Clipboard over the current selection in the text editing control. (Inherited from TextBoxBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Redo | Undoes the most recent undo command. In other words, redoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollToEnd | Scrolls the view of the editing control to the end of the content. (Inherited from TextBoxBase.)
Public method | ScrollToHome | Scrolls the view of the editing control to the beginning of the viewport. (Inherited from TextBoxBase.)
Public method | ScrollToHorizontalOffset | Scrolls the contents of the editing control to the specified horizontal offset. (Inherited from TextBoxBase.)
Public method | ScrollToLine | Scrolls the line at the specified line index into view. (Inherited from TextBox.)
Public method | ScrollToVerticalOffset | Scrolls the contents of the editing control to the specified vertical offset. (Inherited from TextBoxBase.)
Public method | Select | Selects a range of text in the text box. (Inherited from TextBox.)
Public method | SelectAll | Selects all the contents of the text editing control. (Inherited from TextBoxBase.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeText | Returns a value that indicates whether the effective value of the Text property should be serialized during serialization of the TextBox object. (Inherited from TextBox.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | Undo | Undoes the most recent undo command. In other words, undoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBoxBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextChanged | Occurs when content changes in the text element. (Inherited from TextBoxBase.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ExpressionEditor Constructor

Initializes a new instance of the ExpressionEditor class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ExpressionEditor()
public:
ExpressionEditor()
See Also

Reference

ExpressionEditor Class
VisualComponents.UX.Shared Namespace


ExpressionEditor Properties

The ExpressionEditor type exposes the following members.

Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key. (Inherited from TextBoxBase.)
Public property | AcceptsTab | Gets or sets a value that indicates how the text editing control responds when the user presses the TAB key. (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoWordSelection | Gets or sets a value that determines whether when a user selects part of a word by dragging across it with the mouse, the rest of the word is selected. (Inherited from TextBoxBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanRedo | Gets a value that indicates whether the most recent undo action can be redone. (Inherited from TextBoxBase.)
Public property | CanUndo | Gets a value that indicates whether the most recent action can be undone. (Inherited from TextBoxBase.)
Public property | CaretBrush | Gets or sets the brush that is used to paint the caret of the text box. (Inherited from TextBoxBase.)
Public property | CaretIndex | Gets or sets the insertion position index of the caret. (Inherited from TextBox.)
Public property | CharacterCasing | Gets or sets how characters are cased when they are manually entered into the text box. (Inherited from TextBox.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExpressionContext | Decimal and digit (Inherited from ExtendedTextBox.)
Public property | ExtentHeight | Gets the vertical size of the visible content area. (Inherited from TextBoxBase.)
Public property | ExtentWidth | Gets the horizontal size of the visible content area. (Inherited from TextBoxBase.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Gets or sets the horizontal scroll position. (Inherited from TextBoxBase.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal scroll bar is shown. (Inherited from TextBoxBase.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInactiveSelectionHighlightEnabled | Gets or sets a value that indicates whether the text box displays selected text when the text box does not have focus. (Inherited from TextBoxBase.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that indicates whether the text editing control is read-only to a user interacting with the control. (Inherited from TextBoxBase.)
Public property | IsReadOnlyCaretVisible | Gets or sets a value that indicates whether a read-only text box displays a caret. (Inherited from TextBoxBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionActive | Gets a value that indicates whether the text box has focus and selected text. (Inherited from TextBoxBase.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets a value that indicates whether undo support is enabled for the text-editing control. (Inherited from TextBoxBase.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | LineCount | Gets the total number of lines in the text box. (Inherited from TextBox.)
Protected property | LogicalChildren | Gets an enumerator for the logical child elements of the TextBox. (Inherited from TextBox.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxLength | Gets or sets the maximum number of characters that can be manually entered into the text box. (Inherited from TextBox.)
Public property | MaxLines | Gets or sets the maximum number of visible lines. (Inherited from TextBox.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinLines | Gets or sets the minimum number of visible lines. (Inherited from TextBox.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedText | Gets or sets the content of the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionBrush | Gets or sets the brush that highlights selected text. (Inherited from TextBoxBase.)
Public property | SelectionLength | Gets or sets a value indicating the number of characters in the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionOpacity | Gets or sets the opacity of the SelectionBrush. (Inherited from TextBoxBase.)
Public property | SelectionStart | Gets or sets a character index for the beginning of the current selection. (Inherited from TextBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | SpellCheck | Gets a SpellCheck object that provides access to spelling errors in the text contents of a TextBoxBase or RichTextBox. (Inherited from TextBoxBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | SupportExpressions | (Inherited from ExtendedTextBox.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Gets or sets the text contents of the text box. (Inherited from TextBox.)
Public property | TextAlignment | Gets or sets the horizontal alignment of the contents of the text box. (Inherited from TextBox.)
Public property | TextDecorations | Gets the text decorations to apply to the text box. (Inherited from TextBox.)
Public property | TextInputType | (Inherited from ExtendedTextBox.)
Public property | TextWrapping | Gets or sets how the text box should wrap text. (Inherited from TextBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Typography | Gets the currently effective typography variations for the text contents of the text box. (Inherited from TextBox.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UndoLimit | Gets or sets the number of actions stored in the undo queue. (Inherited from TextBoxBase.)
Public property | UnitVisibility | Show or hide units. (Inherited from ExtendedTextBox.)
Public property | UpdateAfterAnyKey | If true, updates the source when any key is pressed. (Inherited from ExtendedTextBox.)
Public property | UpdateOnLostFocusTriggerOnly | If false, updates the source also when the Enter key is pressed, otherwise default (on lost focus). (Inherited from ExtendedTextBox.)
Public property | UseCustomUndo | (Inherited from UndoableTextBox.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Gets or sets the vertical scroll position. (Inherited from TextBoxBase.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical scroll bar is shown. (Inherited from TextBoxBase.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | ViewportHeight | Gets the vertical size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | ViewportWidth | Gets the horizontal size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ExpressionEditor Class
VisualComponents.UX.Shared Namespace


ExpressionEditor Methods

The ExpressionEditor type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AppendText | Appends a string to the contents of a text control. (Inherited from TextBoxBase.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginChange | Begins a change block. (Inherited from TextBoxBase.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | Clears all the content from the text box. (Inherited from TextBox.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Copy | Copies the current selection of the text editing control to the Clipboard. (Inherited from TextBoxBase.)
Public method | Cut | Removes the current selection from the text editing control and copies it to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeclareChangeBlock | Creates a change block. (Inherited from TextBoxBase.)
Public method | EndChange | Ends a change block. (Inherited from TextBoxBase.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetCharacterIndexFromLineIndex | Returns the zero-based character index for the first character in the specified line. (Inherited from TextBox.)
Public method | GetCharacterIndexFromPoint | Returns the zero-based index of the character that is closest to the specified point. (Inherited from TextBox.)
Public method | GetFirstVisibleLineIndex | Returns the line index for the first line that is currently visible in the text box. (Inherited from TextBox.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLastVisibleLineIndex | Returns the line index for the last line that is currently visible in the text box. (Inherited from TextBox.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLineIndexFromCharacterIndex | Returns the zero-based line index for the line that contains the specified character index. (Inherited from TextBox.)
Public method | GetLineLength | Returns the number of characters in the specified line. (Inherited from TextBox.)
Public method | GetLineText | Returns the text that is currently displayed on the specified line. (Inherited from TextBox.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetNextSpellingErrorCharacterIndex | Returns the beginning character index for the next spelling error in the contents of the text box. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32) | Returns the rectangle for the leading edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32, Boolean) | Returns the rectangle for the leading or trailing edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetSpellingError | Returns a SpellingError object associated with any spelling error at the specified character index. (Inherited from TextBox.)
Public method | GetSpellingErrorLength | Returns the length of any spelling error that includes the specified character. (Inherited from TextBox.)
Public method | GetSpellingErrorStart | Returns the beginning character index for any spelling error that includes the specified character. (Inherited from TextBox.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls the contents of the control down by one line. (Inherited from TextBoxBase.)
Public method | LineLeft | Scrolls the contents of the control to the left by one line. (Inherited from TextBoxBase.)
Public method | LineRight | Scrolls the contents of the control to the right by one line. (Inherited from TextBoxBase.)
Public method | LineUp | Scrolls the contents of the control upward by one line. (Inherited from TextBoxBase.)
Public method | LockCurrentUndoUnit | Locks the most recent undo unit of the undo stack of the application. This prevents the locked unit from being merged with undo units that are added subsequently. (Inherited from TextBoxBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Sizes the text box to its content. (Inherited from TextBox.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from ExtendedTextBox.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Called whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for the text box. (Inherited from TextBox.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragLeave | Invoked whenever an unhandled DragLeave attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragOver | Invoked whenever an unhandled DragOver attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDrop | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGiveFeedback | Invoked whenever an unhandled GiveFeedback attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotFocus | (Inherited from ExtendedTextBox.)
Protected method | OnGotKeyboardFocus | (Inherited from ExtendedTextBox.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | (Inherited from UndoableTextBox.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked whenever an unhandled KeyDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnKeyUp | Invoked whenever an unhandled KeyUp attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostFocus | (Inherited from ExtendedTextBox.)
Protected method | OnLostKeyboardFocus | (Inherited from ExtendedTextBox.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked whenever an unhandled MouseDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked whenever an unhandled MouseMove attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked whenever an unhandled MouseUp event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Is called when a MouseWheel event is routed to this class (or to a class that inherits from this class). (Inherited from TextBoxBase.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | (Inherited from ExtendedTextBox.)
Protected method | OnPreviewKeyUp | (Inherited from ExtendedTextBox.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | (Inherited from ExtendedTextBox.)
Protected method | OnPreviewMouseDown | (Inherited from ExtendedTextBox.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Ignore incorrect characters (one by one) (Inherited from ExtendedTextBox.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Called when one or more of the dependency properties that exist on the element have had their effective values changed. (Inherited from TextBox.)
Protected method | OnQueryContinueDrag | Invoked whenever an unhandled QueryContinueDrag attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnQueryCursor | Invoked whenever an unhandled QueryCursor attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Is called when the caret or current selection changes position. (Inherited from TextBoxBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Is called when the control template changes. (Inherited from TextBoxBase.)
Protected method | OnTextChanged | (Inherited from ExtendedTextBox.)
Protected method | OnTextInput | Invoked whenever an unhandled TextInput attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | PageDown | Scrolls the contents of the control down by one page. (Inherited from TextBoxBase.)
Public method | PageLeft | Scrolls the contents of the control to the left by one page. (Inherited from TextBoxBase.)
Public method | PageRight | Scrolls the contents of the control to the right by one page. (Inherited from TextBoxBase.)
Public method | PageUp | Scrolls the contents of the control up by one page. (Inherited from TextBoxBase.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | Paste | Pastes the contents of the Clipboard over the current selection in the text editing control. (Inherited from TextBoxBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Redo | Undoes the most recent undo command. In other words, redoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollToEnd | Scrolls the view of the editing control to the end of the content. (Inherited from TextBoxBase.)
Public method | ScrollToHome | Scrolls the view of the editing control to the beginning of the viewport. (Inherited from TextBoxBase.)
Public method | ScrollToHorizontalOffset | Scrolls the contents of the editing control to the specified horizontal offset. (Inherited from TextBoxBase.)
Public method | ScrollToLine | Scrolls the line at the specified line index into view. (Inherited from TextBox.)
Public method | ScrollToVerticalOffset | Scrolls the contents of the editing control to the specified vertical offset. (Inherited from TextBoxBase.)
Public method | Select | Selects a range of text in the text box. (Inherited from TextBox.)
Public method | SelectAll | Selects all the contents of the text editing control. (Inherited from TextBoxBase.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeText | Returns a value that indicates whether the effective value of the Text property should be serialized during serialization of the TextBox object. (Inherited from TextBox.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | Undo | Undoes the most recent undo command. In other words, undoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ExpressionEditor Class
VisualComponents.UX.Shared Namespace


ExpressionEditor Events

The ExpressionEditor type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBoxBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextChanged | Occurs when content changes in the text element. (Inherited from TextBoxBase.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ExpressionEditor Class
VisualComponents.UX.Shared Namespace


ExpressionProperty Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedEditorProperty
VisualComponents.UX.SharedExpressionProperty

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ExpressionProperty : EditorProperty,
    IDataErrorInfo
public ref class ExpressionProperty sealed : public EditorProperty,
    IDataErrorInfo

The ExpressionProperty type exposes the following members.

Constructors
 | Name | Description
Public method | ExpressionProperty | Initializes a new instance of the ExpressionProperty class
Top
Properties
 | Name | Description
Public property | AllowedMaximum | (Inherited from EditorProperty.)
Public property | AllowedMinimum | (Inherited from EditorProperty.)
Public property | AllowedValues | (Inherited from EditorProperty.)
Public property | CanCreateNewValue | (Inherited from EditorProperty.)
Public property | Category | (Inherited from EditorProperty.)
Public property | ConstraintType | (Inherited from EditorProperty.)
Public property | Container | (Inherited from EditorProperty.)
Public property | ContainerExpressionContext | (Inherited from EditorProperty.)
Public property | ContainerObject | Similar to IProperty.Container, but for any object. (Inherited from EditorProperty.)
Public property | CreationTypes | (Inherited from EditorProperty.)
Public property | Description | (Inherited from EditorProperty.)
Public property | DisabledStateToolTip | (Inherited from EditorProperty.)
Public property | DistributionExpression | (Inherited from EditorProperty.)
Public property | Error |
Public property | ErrorMessage |
Public property | Expression |
Public property | ExpressionContext |
Public property | HasDistribution | (Inherited from EditorProperty.)
Public property | History | (Inherited from EditorProperty.)
Public property | Index_ForComboBox | (Inherited from EditorProperty.)
Public property | IsDesignTime | (Inherited from EditorProperty.)
Public property | IsEditable | Helper property since in XAML negating binding value is not possible without using BoolToOppositeConverter (Inherited from EditorProperty.)
Public property | IsEditableInGui | (Inherited from EditorProperty.)
Public property | IsExceptionallyInHome | (Inherited from EditorProperty.)
Public property | IsInternal | (Inherited from EditorProperty.)
Public property | IsLocked | (Inherited from EditorProperty.)
Public property | IsPersistent | (Inherited from EditorProperty.)
Public property | IsQuantityValue | (Inherited from EditorProperty.)
Public property | IsReadOnly | (Inherited from EditorProperty.)
Public property | IsValid | (Inherited from EditorProperty.)
Public property | IsVisible | (Inherited from EditorProperty.)
Public property | IsVisibleDesignTime | (Inherited from EditorProperty.)
Public property | IsVisibleForced | (Inherited from EditorProperty.)
Public property | IsVisibleInGui | IsVisibleInGui is used to bind GUI visibility. Setting this value affects only _isVisibleForcedOff. (Inherited from EditorProperty.)
Public property | Item |
Public property | Name | (Inherited from EditorProperty.)
Public property | NonLocalizedName | (Inherited from EditorProperty.)
Public property | Order | (Inherited from EditorProperty.)
Public property | Property | (Inherited from EditorProperty.)
Public property | PropertyDescription | (Inherited from EditorProperty.)
Public property | PropertyType | (Inherited from EditorProperty.)
Public property | Quantity | (Inherited from EditorProperty.)
Public property | RequiredExpressionType |
Public property | ResourceType | In case of having an IUriProperty, this determines if the editor should allow folder selection instead of file selection (Inherited from EditorProperty.)
Public property | ResultString |
Public property | RotationSystem | (Inherited from EditorProperty.)
Public property | ShowValuepicker | (Inherited from EditorProperty.)
Public property | TabHeader | (Inherited from EditorProperty.)
Public property | Unit | (Inherited from EditorProperty.)
Public property | Value | (Inherited from EditorProperty.)
Public property | Value_ForComboBox | Helper property, used only by ComboBox. (Inherited from EditorProperty.)
Public property | ValueString | (Inherited from EditorProperty.)
Top
Methods
 | Name | Description
Public method | Associate | (Inherited from EditorProperty.)
Public method | CheckEditableInGui | (Inherited from EditorProperty.)
Public method | CheckRebuild | This happens only on UI changes. If containeris a behavior of feature call evaluate or rebuild to update geometry. (Inherited from EditorProperty.)
Public method | CheckRebuildSmart | (Inherited from EditorProperty.)
Public method | Clone | (Inherited from EditorProperty.)
Public method | CreateAndSetNewValue | (Inherited from EditorProperty.)
Public method | Disassociate | (Inherited from EditorProperty.)
Public method | Dispose | (Inherited from EditorProperty.)
Public method | EndBatch | (Inherited from EditorProperty.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PickValue | Execute PickAction and wait for user to click on some object. (Inherited from EditorProperty.)
Public method | PickValueProxy | (Inherited from EditorProperty.)
Public method | RefreshTooltip |
Public method | SetQuantity | (Inherited from EditorProperty.)
Public method | SetUnitMagnitude | (Inherited from EditorProperty.)
Public method | StartBatch | (Inherited from EditorProperty.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | property changed event (Inherited from EditorProperty.)
Top
Fields
 | Name | Description
Public field | SuppressValueChange | (Inherited from EditorProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ExpressionProperty Constructor

Initializes a new instance of the ExpressionProperty class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ExpressionProperty(
    IProperty property
)
public:
ExpressionProperty(
    IProperty^ property
)

Parameters

property
Type: VisualComponents.Create3DIProperty
See Also

Reference

ExpressionProperty Class
VisualComponents.UX.Shared Namespace


ExpressionProperty Properties

The ExpressionProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | (Inherited from EditorProperty.)
Public property | AllowedMinimum | (Inherited from EditorProperty.)
Public property | AllowedValues | (Inherited from EditorProperty.)
Public property | CanCreateNewValue | (Inherited from EditorProperty.)
Public property | Category | (Inherited from EditorProperty.)
Public property | ConstraintType | (Inherited from EditorProperty.)
Public property | Container | (Inherited from EditorProperty.)
Public property | ContainerExpressionContext | (Inherited from EditorProperty.)
Public property | ContainerObject | Similar to IProperty.Container, but for any object. (Inherited from EditorProperty.)
Public property | CreationTypes | (Inherited from EditorProperty.)
Public property | Description | (Inherited from EditorProperty.)
Public property | DisabledStateToolTip | (Inherited from EditorProperty.)
Public property | DistributionExpression | (Inherited from EditorProperty.)
Public property | Error |
Public property | ErrorMessage |
Public property | Expression |
Public property | ExpressionContext |
Public property | HasDistribution | (Inherited from EditorProperty.)
Public property | History | (Inherited from EditorProperty.)
Public property | Index_ForComboBox | (Inherited from EditorProperty.)
Public property | IsDesignTime | (Inherited from EditorProperty.)
Public property | IsEditable | Helper property since in XAML negating binding value is not possible without using BoolToOppositeConverter (Inherited from EditorProperty.)
Public property | IsEditableInGui | (Inherited from EditorProperty.)
Public property | IsExceptionallyInHome | (Inherited from EditorProperty.)
Public property | IsInternal | (Inherited from EditorProperty.)
Public property | IsLocked | (Inherited from EditorProperty.)
Public property | IsPersistent | (Inherited from EditorProperty.)
Public property | IsQuantityValue | (Inherited from EditorProperty.)
Public property | IsReadOnly | (Inherited from EditorProperty.)
Public property | IsValid | (Inherited from EditorProperty.)
Public property | IsVisible | (Inherited from EditorProperty.)
Public property | IsVisibleDesignTime | (Inherited from EditorProperty.)
Public property | IsVisibleForced | (Inherited from EditorProperty.)
Public property | IsVisibleInGui | IsVisibleInGui is used to bind GUI visibility. Setting this value affects only _isVisibleForcedOff. (Inherited from EditorProperty.)
Public property | Item |
Public property | Name | (Inherited from EditorProperty.)
Public property | NonLocalizedName | (Inherited from EditorProperty.)
Public property | Order | (Inherited from EditorProperty.)
Public property | Property | (Inherited from EditorProperty.)
Public property | PropertyDescription | (Inherited from EditorProperty.)
Public property | PropertyType | (Inherited from EditorProperty.)
Public property | Quantity | (Inherited from EditorProperty.)
Public property | RequiredExpressionType |
Public property | ResourceType | In case of having an IUriProperty, this determines if the editor should allow folder selection instead of file selection (Inherited from EditorProperty.)
Public property | ResultString |
Public property | RotationSystem | (Inherited from EditorProperty.)
Public property | ShowValuepicker | (Inherited from EditorProperty.)
Public property | TabHeader | (Inherited from EditorProperty.)
Public property | Unit | (Inherited from EditorProperty.)
Public property | Value | (Inherited from EditorProperty.)
Public property | Value_ForComboBox | Helper property, used only by ComboBox. (Inherited from EditorProperty.)
Public property | ValueString | (Inherited from EditorProperty.)
Top
See Also

Reference

ExpressionProperty Class
VisualComponents.UX.Shared Namespace


ExpressionProperty.Error Property

ExpressionPropertyError Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Error { get; }
public:
virtual property String^ Error {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IDataErrorInfoError
See Also

Reference

ExpressionProperty Class
VisualComponents.UX.Shared Namespace


ExpressionProperty.ErrorMessage Property

ExpressionPropertyErrorMessage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ErrorMessage { get; }
public:
property String^ ErrorMessage {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ExpressionProperty Class
VisualComponents.UX.Shared Namespace


ExpressionProperty.Expression Property

ExpressionPropertyExpression Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Expression { get; set; }
public:
property String^ Expression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ExpressionProperty Class
VisualComponents.UX.Shared Namespace


ExpressionProperty.ExpressionContext Property

ExpressionPropertyExpressionContext Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IExpressionContext ExpressionContext { get; }
public:
property IExpressionContext^ ExpressionContext {
    IExpressionContext^ get ();
}

Property Value

Type: IExpressionContext
See Also

Reference

ExpressionProperty Class
VisualComponents.UX.Shared Namespace


ExpressionProperty.Item Property

ExpressionPropertyItem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string this[
    string columnName
] { get; }
public:
virtual property String^ default[String^ columnName] {
    String^ get (String^ columnName) sealed;
}

Parameters

columnName
Type: SystemString

Property Value

Type: String

Implements

IDataErrorInfoItemString
See Also

Reference

ExpressionProperty Class
VisualComponents.UX.Shared Namespace


ExpressionProperty.RequiredExpressionType Property

ExpressionPropertyRequiredExpressionType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type RequiredExpressionType { get; }
public:
property Type^ RequiredExpressionType {
    Type^ get ();
}

Property Value

Type: Type
See Also

Reference

ExpressionProperty Class
VisualComponents.UX.Shared Namespace


ExpressionProperty.ResultString Property

ExpressionPropertyResultString Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ResultString { get; }
public:
property String^ ResultString {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ExpressionProperty Class
VisualComponents.UX.Shared Namespace


ExpressionProperty Methods

The ExpressionProperty type exposes the following members.

Methods
 | Name | Description
Public method | Associate | (Inherited from EditorProperty.)
Public method | CheckEditableInGui | (Inherited from EditorProperty.)
Public method | CheckRebuild | This happens only on UI changes. If containeris a behavior of feature call evaluate or rebuild to update geometry. (Inherited from EditorProperty.)
Public method | CheckRebuildSmart | (Inherited from EditorProperty.)
Public method | Clone | (Inherited from EditorProperty.)
Public method | CreateAndSetNewValue | (Inherited from EditorProperty.)
Public method | Disassociate | (Inherited from EditorProperty.)
Public method | Dispose | (Inherited from EditorProperty.)
Public method | EndBatch | (Inherited from EditorProperty.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PickValue | Execute PickAction and wait for user to click on some object. (Inherited from EditorProperty.)
Public method | PickValueProxy | (Inherited from EditorProperty.)
Public method | RefreshTooltip |
Public method | SetQuantity | (Inherited from EditorProperty.)
Public method | SetUnitMagnitude | (Inherited from EditorProperty.)
Public method | StartBatch | (Inherited from EditorProperty.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ExpressionProperty Class
VisualComponents.UX.Shared Namespace


ExpressionProperty.RefreshTooltip Method

ExpressionPropertyRefreshTooltip Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RefreshTooltip(
    Object sender
)
public:
void RefreshTooltip(
    Object^ sender
)

Parameters

sender
Type: SystemObject
See Also

Reference

ExpressionProperty Class
VisualComponents.UX.Shared Namespace


ExpressionProperty Events

The ExpressionProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | property changed event (Inherited from EditorProperty.)
Top
See Also

Reference

ExpressionProperty Class
VisualComponents.UX.Shared Namespace


ExpressionProperty Fields

The ExpressionProperty type exposes the following members.

Fields
 | Name | Description
Public field | SuppressValueChange | (Inherited from EditorProperty.)
Top
See Also

Reference

ExpressionProperty Class
VisualComponents.UX.Shared Namespace


ExpressionValidationRule Class

Inheritance Hierarchy
SystemObject
System.Windows.ControlsValidationRule
VisualComponents.UX.SharedExpressionValidationRule

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ExpressionValidationRule : ValidationRule
public ref class ExpressionValidationRule : public ValidationRule

The ExpressionValidationRule type exposes the following members.

Constructors
 | Name | Description
Public method | ExpressionValidationRule | Initializes a new instance of the ExpressionValidationRule class
Top
Properties
 | Name | Description
Public property | AllowedValueContainer |
 | ExpressionEvaluator |
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | EvaluateIfNeeded |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ExpressionValidationRule Constructor

Initializes a new instance of the ExpressionValidationRule class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ExpressionValidationRule()
public:
ExpressionValidationRule()
See Also

Reference

ExpressionValidationRule Class
VisualComponents.UX.Shared Namespace


ExpressionValidationRule Properties

The ExpressionValidationRule type exposes the following members.

Properties
 | Name | Description
Public property | AllowedValueContainer |
 | ExpressionEvaluator |
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
See Also

Reference

ExpressionValidationRule Class
VisualComponents.UX.Shared Namespace


ExpressionValidationRule.AllowedValueContainer Property

ExpressionValidationRuleAllowedValueContainer Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AllowedValueContainer AllowedValueContainer { get; set; }
public:
property AllowedValueContainer^ AllowedValueContainer {
    AllowedValueContainer^ get ();
    void set (AllowedValueContainer^ value);
}

Property Value

Type: AllowedValueContainer
See Also

Reference

ExpressionValidationRule Class
VisualComponents.UX.Shared Namespace


ExpressionValidationRule.ExpressionEvaluator Property

ExpressionValidationRuleExpressionEvaluator Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IExpressionEvaluator ExpressionEvaluator { get; }
public:
static property IExpressionEvaluator^ ExpressionEvaluator {
    IExpressionEvaluator^ get ();
}

Property Value

Type: IExpressionEvaluator
See Also

Reference

ExpressionValidationRule Class
VisualComponents.UX.Shared Namespace


ExpressionValidationRule Methods

The ExpressionValidationRule type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | EvaluateIfNeeded |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ExpressionValidationRule Class
VisualComponents.UX.Shared Namespace


ExpressionValidationRule.EvaluateIfNeeded Method

ExpressionValidationRuleEvaluateIfNeeded Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool EvaluateIfNeeded(
    ref string value,
    TextInputType TextInputType,
    IExpressionContext ExpressionContext
)
public:
static bool EvaluateIfNeeded(
    String^% value,
    TextInputType TextInputType,
    IExpressionContext^ ExpressionContext
)

Parameters

value
Type: SystemString
TextInputType
Type: VisualComponents.UX.SharedTextInputType
ExpressionContext
Type: VisualComponents.Create3DIExpressionContext

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ExpressionValidationRule.EvaluateIfNeeded(System.String@,VisualComponents.UX.Shared.TextInputType,VisualComponents.Create3D.IExpressionContext)"]

See Also

Reference

ExpressionValidationRule Class
VisualComponents.UX.Shared Namespace


ExpressionValidationRule.Validate Method

ExpressionValidationRuleValidate Method

Overload List
 | Name | Description
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
See Also

Reference

ExpressionValidationRule Class
VisualComponents.UX.Shared Namespace


ExpressionValidationRule.Validate Method (Object, CultureInfo)

ExpressionValidationRuleValidate Method (Object, CultureInfo)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override ValidationResult Validate(
    Object value,
    CultureInfo cultureInfo
)
public:
virtual ValidationResult^ Validate(
    Object^ value,
    CultureInfo^ cultureInfo
) override

Parameters

value
Type: SystemObject
cultureInfo
Type: System.GlobalizationCultureInfo

Return Value

Type: ValidationResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ExpressionValidationRule.Validate(System.Object,System.Globalization.CultureInfo)"]

See Also

Reference

ExpressionValidationRule Class
Validate Overload
VisualComponents.UX.Shared Namespace


ExtendedExpander Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsHeaderedContentControl
System.Windows.ControlsExpander
VisualComponents.UX.SharedExtendedExpander

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ExtendedExpander : Expander
public ref class ExtendedExpander : public Expander

The ExtendedExpander type exposes the following members.

Constructors
 | Name | Description
Public method | ExtendedExpander | Initializes a new instance of the ExtendedExpander class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExpandDirection | Gets or sets the direction in which the Expander content window opens. (Inherited from Expander.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | HasHeader | Gets a value that indicates whether the header is . (Inherited from HeaderedContentControl.)
Public property | Header | Gets or sets the data used for the header of each control. (Inherited from HeaderedContentControl.)
Public property | HeaderStringFormat | Gets or sets a composite string that specifies how to format the Header property if it is displayed as a string. (Inherited from HeaderedContentControl.)
Public property | HeaderTemplate | Gets or sets the template used to display the content of the control's header. (Inherited from HeaderedContentControl.)
Public property | HeaderTemplateSelector | Gets or sets a data template selector that provides custom logic for choosing the template used to display the header. (Inherited from HeaderedContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InitialScaleY |
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsExpanded | Gets or sets whether the Expander content window is visible. (Inherited from Expander.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHeaderVisible |
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the logical child elements of the ControlTemplate. (Inherited from HeaderedContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides ExpanderOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnCollapsed | Raises the Collapsed event when the IsExpanded property changes from to . (Inherited from Expander.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates the implementation of AutomationPeer for the Expander control. (Inherited from Expander.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnExpanded | Raises the Expanded event when the IsExpanded property changes from to . (Inherited from Expander.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnHeaderChanged | Called when the Header property of a HeaderedContentControl changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderStringFormatChanged | Called when the HeaderStringFormat property changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderTemplateChanged | Called when the HeaderTemplate property changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderTemplateSelectorChanged | Called when the HeaderTemplateSelector property changes. (Inherited from HeaderedContentControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Provides a string representation of a HeaderedContentControl. (Inherited from HeaderedContentControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | Collapsed | Occurs when the content window of an Expander control closes and only the Header is visible. (Inherited from Expander.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | Expanded | Occurs when the content window of an Expander control opens to display both its header and content. (Inherited from Expander.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
IsHeaderVisibleProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ExtendedExpander Constructor

Initializes a new instance of the ExtendedExpander class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ExtendedExpander()
public:
ExtendedExpander()
See Also

Reference

ExtendedExpander Class
VisualComponents.UX.Shared Namespace


ExtendedExpander Properties

The ExtendedExpander type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExpandDirection | Gets or sets the direction in which the Expander content window opens. (Inherited from Expander.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | HasHeader | Gets a value that indicates whether the header is . (Inherited from HeaderedContentControl.)
Public property | Header | Gets or sets the data used for the header of each control. (Inherited from HeaderedContentControl.)
Public property | HeaderStringFormat | Gets or sets a composite string that specifies how to format the Header property if it is displayed as a string. (Inherited from HeaderedContentControl.)
Public property | HeaderTemplate | Gets or sets the template used to display the content of the control's header. (Inherited from HeaderedContentControl.)
Public property | HeaderTemplateSelector | Gets or sets a data template selector that provides custom logic for choosing the template used to display the header. (Inherited from HeaderedContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InitialScaleY |
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsExpanded | Gets or sets whether the Expander content window is visible. (Inherited from Expander.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHeaderVisible |
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the logical child elements of the ControlTemplate. (Inherited from HeaderedContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ExtendedExpander Class
VisualComponents.UX.Shared Namespace


ExtendedExpander.InitialScaleY Property

ExtendedExpanderInitialScaleY Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double InitialScaleY { get; }
public:
property double InitialScaleY {
    double get ();
}

Property Value

Type: Double
See Also

Reference

ExtendedExpander Class
VisualComponents.UX.Shared Namespace


ExtendedExpander.IsHeaderVisible Property

ExtendedExpanderIsHeaderVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsHeaderVisible { get; set; }
public:
property bool IsHeaderVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ExtendedExpander Class
VisualComponents.UX.Shared Namespace


ExtendedExpander Methods

The ExtendedExpander type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides ExpanderOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnCollapsed | Raises the Collapsed event when the IsExpanded property changes from to . (Inherited from Expander.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates the implementation of AutomationPeer for the Expander control. (Inherited from Expander.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnExpanded | Raises the Expanded event when the IsExpanded property changes from to . (Inherited from Expander.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnHeaderChanged | Called when the Header property of a HeaderedContentControl changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderStringFormatChanged | Called when the HeaderStringFormat property changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderTemplateChanged | Called when the HeaderTemplate property changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderTemplateSelectorChanged | Called when the HeaderTemplateSelector property changes. (Inherited from HeaderedContentControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Provides a string representation of a HeaderedContentControl. (Inherited from HeaderedContentControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ExtendedExpander Class
VisualComponents.UX.Shared Namespace


ExtendedExpander.OnApplyTemplate Method

ExtendedExpanderOnApplyTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

ExtendedExpander Class
VisualComponents.UX.Shared Namespace


ExtendedExpander Events

The ExtendedExpander type exposes the following members.

Events
 | Name | Description
Public event | Collapsed | Occurs when the content window of an Expander control closes and only the Header is visible. (Inherited from Expander.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | Expanded | Occurs when the content window of an Expander control opens to display both its header and content. (Inherited from Expander.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ExtendedExpander Class
VisualComponents.UX.Shared Namespace


ExtendedExpander Fields

The ExtendedExpander type exposes the following members.

Fields
Name | Description
IsHeaderVisibleProperty |
Top
See Also

Reference

ExtendedExpander Class
VisualComponents.UX.Shared Namespace


ExtendedExpander.IsHeaderVisibleProperty Field

ExtendedExpanderIsHeaderVisibleProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsHeaderVisibleProperty
public:
static initonly DependencyProperty^ IsHeaderVisibleProperty

Field Value

Type: DependencyProperty
See Also

Reference

ExtendedExpander Class
VisualComponents.UX.Shared Namespace


ExtendedTextBox Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.Controls.PrimitivesTextBoxBase
System.Windows.ControlsTextBox
VisualComponents.UX.SharedUndoableTextBox
VisualComponents.UX.SharedExtendedTextBox
VisualComponents.UX.SharedExpressionEditor

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ExtendedTextBox : UndoableTextBox
public ref class ExtendedTextBox : public UndoableTextBox

The ExtendedTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | ExtendedTextBox | Initializes a new instance of the ExtendedTextBox class
Top
Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key. (Inherited from TextBoxBase.)
Public property | AcceptsTab | Gets or sets a value that indicates how the text editing control responds when the user presses the TAB key. (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoWordSelection | Gets or sets a value that determines whether when a user selects part of a word by dragging across it with the mouse, the rest of the word is selected. (Inherited from TextBoxBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanRedo | Gets a value that indicates whether the most recent undo action can be redone. (Inherited from TextBoxBase.)
Public property | CanUndo | Gets a value that indicates whether the most recent action can be undone. (Inherited from TextBoxBase.)
Public property | CaretBrush | Gets or sets the brush that is used to paint the caret of the text box. (Inherited from TextBoxBase.)
Public property | CaretIndex | Gets or sets the insertion position index of the caret. (Inherited from TextBox.)
Public property | CharacterCasing | Gets or sets how characters are cased when they are manually entered into the text box. (Inherited from TextBox.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExpressionContext | Decimal and digit
 | ExpressionEvaluator |
Public property | ExtentHeight | Gets the vertical size of the visible content area. (Inherited from TextBoxBase.)
Public property | ExtentWidth | Gets the horizontal size of the visible content area. (Inherited from TextBoxBase.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Gets or sets the horizontal scroll position. (Inherited from TextBoxBase.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal scroll bar is shown. (Inherited from TextBoxBase.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInactiveSelectionHighlightEnabled | Gets or sets a value that indicates whether the text box displays selected text when the text box does not have focus. (Inherited from TextBoxBase.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that indicates whether the text editing control is read-only to a user interacting with the control. (Inherited from TextBoxBase.)
Public property | IsReadOnlyCaretVisible | Gets or sets a value that indicates whether a read-only text box displays a caret. (Inherited from TextBoxBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionActive | Gets a value that indicates whether the text box has focus and selected text. (Inherited from TextBoxBase.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets a value that indicates whether undo support is enabled for the text-editing control. (Inherited from TextBoxBase.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | LineCount | Gets the total number of lines in the text box. (Inherited from TextBox.)
Protected property | LogicalChildren | Gets an enumerator for the logical child elements of the TextBox. (Inherited from TextBox.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxLength | Gets or sets the maximum number of characters that can be manually entered into the text box. (Inherited from TextBox.)
Public property | MaxLines | Gets or sets the maximum number of visible lines. (Inherited from TextBox.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinLines | Gets or sets the minimum number of visible lines. (Inherited from TextBox.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedText | Gets or sets the content of the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionBrush | Gets or sets the brush that highlights selected text. (Inherited from TextBoxBase.)
Public property | SelectionLength | Gets or sets a value indicating the number of characters in the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionOpacity | Gets or sets the opacity of the SelectionBrush. (Inherited from TextBoxBase.)
Public property | SelectionStart | Gets or sets a character index for the beginning of the current selection. (Inherited from TextBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | SpellCheck | Gets a SpellCheck object that provides access to spelling errors in the text contents of a TextBoxBase or RichTextBox. (Inherited from TextBoxBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | SupportExpressions |
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Gets or sets the text contents of the text box. (Inherited from TextBox.)
Public property | TextAlignment | Gets or sets the horizontal alignment of the contents of the text box. (Inherited from TextBox.)
Public property | TextDecorations | Gets the text decorations to apply to the text box. (Inherited from TextBox.)
Public property | TextInputType |
Public property | TextWrapping | Gets or sets how the text box should wrap text. (Inherited from TextBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Typography | Gets the currently effective typography variations for the text contents of the text box. (Inherited from TextBox.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UndoLimit | Gets or sets the number of actions stored in the undo queue. (Inherited from TextBoxBase.)
Public property | UnitVisibility | Show or hide units.
Public property | UpdateAfterAnyKey | If true, updates the source when any key is pressed.
Public property | UpdateOnLostFocusTriggerOnly | If false, updates the source also when the Enter key is pressed, otherwise default (on lost focus).
Public property | UseCustomUndo | (Inherited from UndoableTextBox.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Gets or sets the vertical scroll position. (Inherited from TextBoxBase.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical scroll bar is shown. (Inherited from TextBoxBase.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | ViewportHeight | Gets the vertical size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | ViewportWidth | Gets the horizontal size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AppendText | Appends a string to the contents of a text control. (Inherited from TextBoxBase.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginChange | Begins a change block. (Inherited from TextBoxBase.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | Clears all the content from the text box. (Inherited from TextBox.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Copy | Copies the current selection of the text editing control to the Clipboard. (Inherited from TextBoxBase.)
Public method | Cut | Removes the current selection from the text editing control and copies it to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeclareChangeBlock | Creates a change block. (Inherited from TextBoxBase.)
Public method | EndChange | Ends a change block. (Inherited from TextBoxBase.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
 | EvaluateIfNeeded |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetCharacterIndexFromLineIndex | Returns the zero-based character index for the first character in the specified line. (Inherited from TextBox.)
Public method | GetCharacterIndexFromPoint | Returns the zero-based index of the character that is closest to the specified point. (Inherited from TextBox.)
Public method | GetFirstVisibleLineIndex | Returns the line index for the first line that is currently visible in the text box. (Inherited from TextBox.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLastVisibleLineIndex | Returns the line index for the last line that is currently visible in the text box. (Inherited from TextBox.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLineIndexFromCharacterIndex | Returns the zero-based line index for the line that contains the specified character index. (Inherited from TextBox.)
Public method | GetLineLength | Returns the number of characters in the specified line. (Inherited from TextBox.)
Public method | GetLineText | Returns the text that is currently displayed on the specified line. (Inherited from TextBox.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetNextSpellingErrorCharacterIndex | Returns the beginning character index for the next spelling error in the contents of the text box. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32) | Returns the rectangle for the leading edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32, Boolean) | Returns the rectangle for the leading or trailing edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetSpellingError | Returns a SpellingError object associated with any spelling error at the specified character index. (Inherited from TextBox.)
Public method | GetSpellingErrorLength | Returns the length of any spelling error that includes the specified character. (Inherited from TextBox.)
Public method | GetSpellingErrorStart | Returns the beginning character index for any spelling error that includes the specified character. (Inherited from TextBox.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls the contents of the control down by one line. (Inherited from TextBoxBase.)
Public method | LineLeft | Scrolls the contents of the control to the left by one line. (Inherited from TextBoxBase.)
Public method | LineRight | Scrolls the contents of the control to the right by one line. (Inherited from TextBoxBase.)
Public method | LineUp | Scrolls the contents of the control upward by one line. (Inherited from TextBoxBase.)
Public method | LockCurrentUndoUnit | Locks the most recent undo unit of the undo stack of the application. This prevents the locked unit from being merged with undo units that are added subsequently. (Inherited from TextBoxBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Sizes the text box to its content. (Inherited from TextBox.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides TextBoxBaseOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Called whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for the text box. (Inherited from TextBox.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragLeave | Invoked whenever an unhandled DragLeave attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragOver | Invoked whenever an unhandled DragOver attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDrop | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGiveFeedback | Invoked whenever an unhandled GiveFeedback attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotFocus | (Overrides FrameworkElementOnGotFocus(RoutedEventArgs).)
Protected method | OnGotKeyboardFocus | (Overrides TextBoxBaseOnGotKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | (Inherited from UndoableTextBox.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked whenever an unhandled KeyDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnKeyUp | Invoked whenever an unhandled KeyUp attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostFocus | (Overrides TextBoxBaseOnLostFocus(RoutedEventArgs).)
Protected method | OnLostKeyboardFocus | (Overrides TextBoxBaseOnLostKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked whenever an unhandled MouseDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked whenever an unhandled MouseMove attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked whenever an unhandled MouseUp event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Is called when a MouseWheel event is routed to this class (or to a class that inherits from this class). (Inherited from TextBoxBase.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | (Overrides TextBoxBaseOnPreviewKeyDown(KeyEventArgs).)
Protected method | OnPreviewKeyUp | (Overrides UIElementOnPreviewKeyUp(KeyEventArgs).)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | (Overrides ControlOnPreviewMouseDoubleClick(MouseButtonEventArgs).)
Protected method | OnPreviewMouseDown | (Overrides UIElementOnPreviewMouseDown(MouseButtonEventArgs).)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Ignore incorrect characters (one by one) (Overrides UIElementOnPreviewTextInput(TextCompositionEventArgs).)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Called when one or more of the dependency properties that exist on the element have had their effective values changed. (Inherited from TextBox.)
Protected method | OnQueryContinueDrag | Invoked whenever an unhandled QueryContinueDrag attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnQueryCursor | Invoked whenever an unhandled QueryCursor attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Is called when the caret or current selection changes position. (Inherited from TextBoxBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Is called when the control template changes. (Inherited from TextBoxBase.)
Protected method | OnTextChanged | (Overrides UndoableTextBoxOnTextChanged(TextChangedEventArgs).)
Protected method | OnTextInput | Invoked whenever an unhandled TextInput attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | PageDown | Scrolls the contents of the control down by one page. (Inherited from TextBoxBase.)
Public method | PageLeft | Scrolls the contents of the control to the left by one page. (Inherited from TextBoxBase.)
Public method | PageRight | Scrolls the contents of the control to the right by one page. (Inherited from TextBoxBase.)
Public method | PageUp | Scrolls the contents of the control up by one page. (Inherited from TextBoxBase.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | Paste | Pastes the contents of the Clipboard over the current selection in the text editing control. (Inherited from TextBoxBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Redo | Undoes the most recent undo command. In other words, redoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollToEnd | Scrolls the view of the editing control to the end of the content. (Inherited from TextBoxBase.)
Public method | ScrollToHome | Scrolls the view of the editing control to the beginning of the viewport. (Inherited from TextBoxBase.)
Public method | ScrollToHorizontalOffset | Scrolls the contents of the editing control to the specified horizontal offset. (Inherited from TextBoxBase.)
Public method | ScrollToLine | Scrolls the line at the specified line index into view. (Inherited from TextBox.)
Public method | ScrollToVerticalOffset | Scrolls the contents of the editing control to the specified vertical offset. (Inherited from TextBoxBase.)
Public method | Select | Selects a range of text in the text box. (Inherited from TextBox.)
Public method | SelectAll | Selects all the contents of the text editing control. (Inherited from TextBoxBase.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeText | Returns a value that indicates whether the effective value of the Text property should be serialized during serialization of the TextBox object. (Inherited from TextBox.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | Undo | Undoes the most recent undo command. In other words, undoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBoxBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextChanged | Occurs when content changes in the text element. (Inherited from TextBoxBase.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
ExpressionContextProperty |
TextInputTypeProperty |
UnitVisibilityProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ExtendedTextBox Constructor

Initializes a new instance of the ExtendedTextBox class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ExtendedTextBox()
public:
ExtendedTextBox()
See Also

Reference

ExtendedTextBox Class
VisualComponents.UX.Shared Namespace


ExtendedTextBox Properties

The ExtendedTextBox type exposes the following members.

Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key. (Inherited from TextBoxBase.)
Public property | AcceptsTab | Gets or sets a value that indicates how the text editing control responds when the user presses the TAB key. (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoWordSelection | Gets or sets a value that determines whether when a user selects part of a word by dragging across it with the mouse, the rest of the word is selected. (Inherited from TextBoxBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanRedo | Gets a value that indicates whether the most recent undo action can be redone. (Inherited from TextBoxBase.)
Public property | CanUndo | Gets a value that indicates whether the most recent action can be undone. (Inherited from TextBoxBase.)
Public property | CaretBrush | Gets or sets the brush that is used to paint the caret of the text box. (Inherited from TextBoxBase.)
Public property | CaretIndex | Gets or sets the insertion position index of the caret. (Inherited from TextBox.)
Public property | CharacterCasing | Gets or sets how characters are cased when they are manually entered into the text box. (Inherited from TextBox.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExpressionContext | Decimal and digit
 | ExpressionEvaluator |
Public property | ExtentHeight | Gets the vertical size of the visible content area. (Inherited from TextBoxBase.)
Public property | ExtentWidth | Gets the horizontal size of the visible content area. (Inherited from TextBoxBase.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Gets or sets the horizontal scroll position. (Inherited from TextBoxBase.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal scroll bar is shown. (Inherited from TextBoxBase.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInactiveSelectionHighlightEnabled | Gets or sets a value that indicates whether the text box displays selected text when the text box does not have focus. (Inherited from TextBoxBase.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that indicates whether the text editing control is read-only to a user interacting with the control. (Inherited from TextBoxBase.)
Public property | IsReadOnlyCaretVisible | Gets or sets a value that indicates whether a read-only text box displays a caret. (Inherited from TextBoxBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionActive | Gets a value that indicates whether the text box has focus and selected text. (Inherited from TextBoxBase.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets a value that indicates whether undo support is enabled for the text-editing control. (Inherited from TextBoxBase.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | LineCount | Gets the total number of lines in the text box. (Inherited from TextBox.)
Protected property | LogicalChildren | Gets an enumerator for the logical child elements of the TextBox. (Inherited from TextBox.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxLength | Gets or sets the maximum number of characters that can be manually entered into the text box. (Inherited from TextBox.)
Public property | MaxLines | Gets or sets the maximum number of visible lines. (Inherited from TextBox.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinLines | Gets or sets the minimum number of visible lines. (Inherited from TextBox.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedText | Gets or sets the content of the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionBrush | Gets or sets the brush that highlights selected text. (Inherited from TextBoxBase.)
Public property | SelectionLength | Gets or sets a value indicating the number of characters in the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionOpacity | Gets or sets the opacity of the SelectionBrush. (Inherited from TextBoxBase.)
Public property | SelectionStart | Gets or sets a character index for the beginning of the current selection. (Inherited from TextBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | SpellCheck | Gets a SpellCheck object that provides access to spelling errors in the text contents of a TextBoxBase or RichTextBox. (Inherited from TextBoxBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | SupportExpressions |
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Gets or sets the text contents of the text box. (Inherited from TextBox.)
Public property | TextAlignment | Gets or sets the horizontal alignment of the contents of the text box. (Inherited from TextBox.)
Public property | TextDecorations | Gets the text decorations to apply to the text box. (Inherited from TextBox.)
Public property | TextInputType |
Public property | TextWrapping | Gets or sets how the text box should wrap text. (Inherited from TextBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Typography | Gets the currently effective typography variations for the text contents of the text box. (Inherited from TextBox.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UndoLimit | Gets or sets the number of actions stored in the undo queue. (Inherited from TextBoxBase.)
Public property | UnitVisibility | Show or hide units.
Public property | UpdateAfterAnyKey | If true, updates the source when any key is pressed.
Public property | UpdateOnLostFocusTriggerOnly | If false, updates the source also when the Enter key is pressed, otherwise default (on lost focus).
Public property | UseCustomUndo | (Inherited from UndoableTextBox.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Gets or sets the vertical scroll position. (Inherited from TextBoxBase.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical scroll bar is shown. (Inherited from TextBoxBase.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | ViewportHeight | Gets the vertical size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | ViewportWidth | Gets the horizontal size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ExtendedTextBox Class
VisualComponents.UX.Shared Namespace


ExtendedTextBox.ExpressionContext Property

ExtendedTextBoxExpressionContext Property

Decimal and digit

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IExpressionContext ExpressionContext { get; set; }
public:
property IExpressionContext^ ExpressionContext {
    IExpressionContext^ get ();
    void set (IExpressionContext^ value);
}

Property Value

Type: IExpressionContext
See Also

Reference

ExtendedTextBox Class
VisualComponents.UX.Shared Namespace


ExtendedTextBox.ExpressionEvaluator Property

ExtendedTextBoxExpressionEvaluator Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IExpressionEvaluator ExpressionEvaluator { get; }
public:
static property IExpressionEvaluator^ ExpressionEvaluator {
    IExpressionEvaluator^ get ();
}

Property Value

Type: IExpressionEvaluator
See Also

Reference

ExtendedTextBox Class
VisualComponents.UX.Shared Namespace


ExtendedTextBox.SupportExpressions Property

ExtendedTextBoxSupportExpressions Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool SupportExpressions { get; }
public:
property bool SupportExpressions {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ExtendedTextBox Class
VisualComponents.UX.Shared Namespace


ExtendedTextBox.TextInputType Property

ExtendedTextBoxTextInputType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TextInputType TextInputType { get; set; }
public:
property TextInputType TextInputType {
    TextInputType get ();
    void set (TextInputType value);
}

Property Value

Type: TextInputType
See Also

Reference

ExtendedTextBox Class
VisualComponents.UX.Shared Namespace


ExtendedTextBox.UnitVisibility Property

ExtendedTextBoxUnitVisibility Property

Show or hide units.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Visibility UnitVisibility { get; set; }
public:
property Visibility UnitVisibility {
    Visibility get ();
    void set (Visibility value);
}

Property Value

Type: Visibility
See Also

Reference

ExtendedTextBox Class
VisualComponents.UX.Shared Namespace


ExtendedTextBox.UpdateAfterAnyKey Property

ExtendedTextBoxUpdateAfterAnyKey Property

If true, updates the source when any key is pressed.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool UpdateAfterAnyKey { get; set; }
public:
property bool UpdateAfterAnyKey {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ExtendedTextBox Class
VisualComponents.UX.Shared Namespace


ExtendedTextBox.UpdateOnLostFocusTriggerOnly Property

ExtendedTextBoxUpdateOnLostFocusTriggerOnly Property

If false, updates the source also when the Enter key is pressed, otherwise default (on lost focus).

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool UpdateOnLostFocusTriggerOnly { get; set; }
public:
property bool UpdateOnLostFocusTriggerOnly {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ExtendedTextBox Class
VisualComponents.UX.Shared Namespace


ExtendedTextBox Methods

The ExtendedTextBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AppendText | Appends a string to the contents of a text control. (Inherited from TextBoxBase.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginChange | Begins a change block. (Inherited from TextBoxBase.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | Clears all the content from the text box. (Inherited from TextBox.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Copy | Copies the current selection of the text editing control to the Clipboard. (Inherited from TextBoxBase.)
Public method | Cut | Removes the current selection from the text editing control and copies it to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeclareChangeBlock | Creates a change block. (Inherited from TextBoxBase.)
Public method | EndChange | Ends a change block. (Inherited from TextBoxBase.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
 | EvaluateIfNeeded |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetCharacterIndexFromLineIndex | Returns the zero-based character index for the first character in the specified line. (Inherited from TextBox.)
Public method | GetCharacterIndexFromPoint | Returns the zero-based index of the character that is closest to the specified point. (Inherited from TextBox.)
Public method | GetFirstVisibleLineIndex | Returns the line index for the first line that is currently visible in the text box. (Inherited from TextBox.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLastVisibleLineIndex | Returns the line index for the last line that is currently visible in the text box. (Inherited from TextBox.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLineIndexFromCharacterIndex | Returns the zero-based line index for the line that contains the specified character index. (Inherited from TextBox.)
Public method | GetLineLength | Returns the number of characters in the specified line. (Inherited from TextBox.)
Public method | GetLineText | Returns the text that is currently displayed on the specified line. (Inherited from TextBox.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetNextSpellingErrorCharacterIndex | Returns the beginning character index for the next spelling error in the contents of the text box. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32) | Returns the rectangle for the leading edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32, Boolean) | Returns the rectangle for the leading or trailing edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetSpellingError | Returns a SpellingError object associated with any spelling error at the specified character index. (Inherited from TextBox.)
Public method | GetSpellingErrorLength | Returns the length of any spelling error that includes the specified character. (Inherited from TextBox.)
Public method | GetSpellingErrorStart | Returns the beginning character index for any spelling error that includes the specified character. (Inherited from TextBox.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls the contents of the control down by one line. (Inherited from TextBoxBase.)
Public method | LineLeft | Scrolls the contents of the control to the left by one line. (Inherited from TextBoxBase.)
Public method | LineRight | Scrolls the contents of the control to the right by one line. (Inherited from TextBoxBase.)
Public method | LineUp | Scrolls the contents of the control upward by one line. (Inherited from TextBoxBase.)
Public method | LockCurrentUndoUnit | Locks the most recent undo unit of the undo stack of the application. This prevents the locked unit from being merged with undo units that are added subsequently. (Inherited from TextBoxBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Sizes the text box to its content. (Inherited from TextBox.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides TextBoxBaseOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Called whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for the text box. (Inherited from TextBox.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragLeave | Invoked whenever an unhandled DragLeave attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragOver | Invoked whenever an unhandled DragOver attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDrop | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGiveFeedback | Invoked whenever an unhandled GiveFeedback attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotFocus | (Overrides FrameworkElementOnGotFocus(RoutedEventArgs).)
Protected method | OnGotKeyboardFocus | (Overrides TextBoxBaseOnGotKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | (Inherited from UndoableTextBox.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked whenever an unhandled KeyDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnKeyUp | Invoked whenever an unhandled KeyUp attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostFocus | (Overrides TextBoxBaseOnLostFocus(RoutedEventArgs).)
Protected method | OnLostKeyboardFocus | (Overrides TextBoxBaseOnLostKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked whenever an unhandled MouseDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked whenever an unhandled MouseMove attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked whenever an unhandled MouseUp event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Is called when a MouseWheel event is routed to this class (or to a class that inherits from this class). (Inherited from TextBoxBase.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | (Overrides TextBoxBaseOnPreviewKeyDown(KeyEventArgs).)
Protected method | OnPreviewKeyUp | (Overrides UIElementOnPreviewKeyUp(KeyEventArgs).)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | (Overrides ControlOnPreviewMouseDoubleClick(MouseButtonEventArgs).)
Protected method | OnPreviewMouseDown | (Overrides UIElementOnPreviewMouseDown(MouseButtonEventArgs).)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Ignore incorrect characters (one by one) (Overrides UIElementOnPreviewTextInput(TextCompositionEventArgs).)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Called when one or more of the dependency properties that exist on the element have had their effective values changed. (Inherited from TextBox.)
Protected method | OnQueryContinueDrag | Invoked whenever an unhandled QueryContinueDrag attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnQueryCursor | Invoked whenever an unhandled QueryCursor attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Is called when the caret or current selection changes position. (Inherited from TextBoxBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Is called when the control template changes. (Inherited from TextBoxBase.)
Protected method | OnTextChanged | (Overrides UndoableTextBoxOnTextChanged(TextChangedEventArgs).)
Protected method | OnTextInput | Invoked whenever an unhandled TextInput attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | PageDown | Scrolls the contents of the control down by one page. (Inherited from TextBoxBase.)
Public method | PageLeft | Scrolls the contents of the control to the left by one page. (Inherited from TextBoxBase.)
Public method | PageRight | Scrolls the contents of the control to the right by one page. (Inherited from TextBoxBase.)
Public method | PageUp | Scrolls the contents of the control up by one page. (Inherited from TextBoxBase.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | Paste | Pastes the contents of the Clipboard over the current selection in the text editing control. (Inherited from TextBoxBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Redo | Undoes the most recent undo command. In other words, redoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollToEnd | Scrolls the view of the editing control to the end of the content. (Inherited from TextBoxBase.)
Public method | ScrollToHome | Scrolls the view of the editing control to the beginning of the viewport. (Inherited from TextBoxBase.)
Public method | ScrollToHorizontalOffset | Scrolls the contents of the editing control to the specified horizontal offset. (Inherited from TextBoxBase.)
Public method | ScrollToLine | Scrolls the line at the specified line index into view. (Inherited from TextBox.)
Public method | ScrollToVerticalOffset | Scrolls the contents of the editing control to the specified vertical offset. (Inherited from TextBoxBase.)
Public method | Select | Selects a range of text in the text box. (Inherited from TextBox.)
Public method | SelectAll | Selects all the contents of the text editing control. (Inherited from TextBoxBase.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeText | Returns a value that indicates whether the effective value of the Text property should be serialized during serialization of the TextBox object. (Inherited from TextBox.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | Undo | Undoes the most recent undo command. In other words, undoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ExtendedTextBox Class
VisualComponents.UX.Shared Namespace


ExtendedTextBox.EvaluateIfNeeded Method

ExtendedTextBoxEvaluateIfNeeded Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool EvaluateIfNeeded(
    ref string value,
    TextInputType TextInputType,
    IExpressionContext ExpressionContext
)
public:
static bool EvaluateIfNeeded(
    String^% value,
    TextInputType TextInputType,
    IExpressionContext^ ExpressionContext
)

Parameters

value
Type: SystemString
TextInputType
Type: VisualComponents.UX.SharedTextInputType
ExpressionContext
Type: VisualComponents.Create3DIExpressionContext

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ExtendedTextBox.EvaluateIfNeeded(System.String@,VisualComponents.UX.Shared.TextInputType,VisualComponents.Create3D.IExpressionContext)"]

See Also

Reference

ExtendedTextBox Class
VisualComponents.UX.Shared Namespace


ExtendedTextBox.OnApplyTemplate Method

ExtendedTextBoxOnApplyTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

ExtendedTextBox Class
VisualComponents.UX.Shared Namespace


ExtendedTextBox.OnGotFocus Method

ExtendedTextBoxOnGotFocus Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
protected:
virtual void OnGotFocus(
    RoutedEventArgs^ e
) override

Parameters

e
Type: System.WindowsRoutedEventArgs
See Also

Reference

ExtendedTextBox Class
VisualComponents.UX.Shared Namespace


ExtendedTextBox.OnGotKeyboardFocus Method

ExtendedTextBoxOnGotKeyboardFocus Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnGotKeyboardFocus(
    KeyboardFocusChangedEventArgs e
)
protected:
virtual void OnGotKeyboardFocus(
    KeyboardFocusChangedEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputKeyboardFocusChangedEventArgs
See Also

Reference

ExtendedTextBox Class
VisualComponents.UX.Shared Namespace


ExtendedTextBox.OnLostFocus Method

ExtendedTextBoxOnLostFocus Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnLostFocus(
    RoutedEventArgs e
)
protected:
virtual void OnLostFocus(
    RoutedEventArgs^ e
) override

Parameters

e
Type: System.WindowsRoutedEventArgs
See Also

Reference

ExtendedTextBox Class
VisualComponents.UX.Shared Namespace


ExtendedTextBox.OnLostKeyboardFocus Method

ExtendedTextBoxOnLostKeyboardFocus Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnLostKeyboardFocus(
    KeyboardFocusChangedEventArgs e
)
protected:
virtual void OnLostKeyboardFocus(
    KeyboardFocusChangedEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputKeyboardFocusChangedEventArgs
See Also

Reference

ExtendedTextBox Class
VisualComponents.UX.Shared Namespace


ExtendedTextBox.OnPreviewKeyDown Method

ExtendedTextBoxOnPreviewKeyDown Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnPreviewKeyDown(
    KeyEventArgs e
)
protected:
virtual void OnPreviewKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputKeyEventArgs
See Also

Reference

ExtendedTextBox Class
VisualComponents.UX.Shared Namespace


ExtendedTextBox.OnPreviewKeyUp Method

ExtendedTextBoxOnPreviewKeyUp Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnPreviewKeyUp(
    KeyEventArgs e
)
protected:
virtual void OnPreviewKeyUp(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputKeyEventArgs
See Also

Reference

ExtendedTextBox Class
VisualComponents.UX.Shared Namespace


ExtendedTextBox.OnPreviewMouseDoubleClick Method

ExtendedTextBoxOnPreviewMouseDoubleClick Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnPreviewMouseDoubleClick(
    MouseButtonEventArgs e
)
protected:
virtual void OnPreviewMouseDoubleClick(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
See Also

Reference

ExtendedTextBox Class
VisualComponents.UX.Shared Namespace


ExtendedTextBox.OnPreviewMouseDown Method

ExtendedTextBoxOnPreviewMouseDown Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnPreviewMouseDown(
    MouseButtonEventArgs e
)
protected:
virtual void OnPreviewMouseDown(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
See Also

Reference

ExtendedTextBox Class
VisualComponents.UX.Shared Namespace


ExtendedTextBox.OnPreviewTextInput Method

ExtendedTextBoxOnPreviewTextInput Method

Ignore incorrect characters (one by one)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnPreviewTextInput(
    TextCompositionEventArgs e
)
protected:
virtual void OnPreviewTextInput(
    TextCompositionEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputTextCompositionEventArgs
See Also

Reference

ExtendedTextBox Class
VisualComponents.UX.Shared Namespace


ExtendedTextBox.OnTextChanged Method

ExtendedTextBoxOnTextChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnTextChanged(
    TextChangedEventArgs e
)
protected:
virtual void OnTextChanged(
    TextChangedEventArgs^ e
) override

Parameters

e
Type: System.Windows.ControlsTextChangedEventArgs
See Also

Reference

ExtendedTextBox Class
VisualComponents.UX.Shared Namespace


ExtendedTextBox Events

The ExtendedTextBox type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBoxBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextChanged | Occurs when content changes in the text element. (Inherited from TextBoxBase.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ExtendedTextBox Class
VisualComponents.UX.Shared Namespace


ExtendedTextBox Fields

The ExtendedTextBox type exposes the following members.

Fields
Name | Description
ExpressionContextProperty |
TextInputTypeProperty |
UnitVisibilityProperty |
Top
See Also

Reference

ExtendedTextBox Class
VisualComponents.UX.Shared Namespace


ExtendedTextBox.ExpressionContextProperty Field

ExtendedTextBoxExpressionContextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ExpressionContextProperty
public:
static initonly DependencyProperty^ ExpressionContextProperty

Field Value

Type: DependencyProperty
See Also

Reference

ExtendedTextBox Class
VisualComponents.UX.Shared Namespace


ExtendedTextBox.TextInputTypeProperty Field

ExtendedTextBoxTextInputTypeProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty TextInputTypeProperty
public:
static initonly DependencyProperty^ TextInputTypeProperty

Field Value

Type: DependencyProperty
See Also

Reference

ExtendedTextBox Class
VisualComponents.UX.Shared Namespace


ExtendedTextBox.UnitVisibilityProperty Field

ExtendedTextBoxUnitVisibilityProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty UnitVisibilityProperty
public:
static initonly DependencyProperty^ UnitVisibilityProperty

Field Value

Type: DependencyProperty
See Also

Reference

ExtendedTextBox Class
VisualComponents.UX.Shared Namespace


ExtendedToggleButton Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.Controls.PrimitivesButtonBase
System.Windows.Controls.PrimitivesToggleButton
VisualComponents.UX.SharedExtendedToggleButton

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ExtendedToggleButton : ToggleButton
public ref class ExtendedToggleButton : public ToggleButton

The ExtendedToggleButton type exposes the following members.

Constructors
 | Name | Description
Public method | ExtendedToggleButton | Initializes a new instance of the ExtendedToggleButton class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | ClickMode | Gets or sets when the Click event occurs. (Inherited from ButtonBase.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | Command | Gets or sets the command to invoke when this button is pressed. (Inherited from ButtonBase.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property. (Inherited from ButtonBase.)
Public property | CommandTarget | Gets or sets the element on which to raise the specified command. (Inherited from ButtonBase.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IconHeight |
Public property | IconOnePath |
Public property | IconWidth |
Public property | IconViewBoxHeight |
Public property | IconViewBoxWidth |
Public property | ImageSource |
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsChecked | Gets or sets whether the ToggleButton is checked. (Inherited from ToggleButton.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets the value of the IsEnabled property. (Inherited from ButtonBase.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsPressed | Gets a value that indicates whether a ButtonBase is currently activated. (Inherited from ButtonBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsThreeState | Determines whether the control supports two or three states. (Inherited from ToggleButton.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Responds when the AccessKey for this control is called. (Inherited from ButtonBase.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChecked | Called when a ToggleButton raises a Checked event. (Inherited from ToggleButton.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClick | Called when a control is clicked by the mouse or the keyboard. (Inherited from ToggleButton.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ToggleButtonAutomationPeer implementation for this control, as part of the WPF infrastructure. (Inherited from ToggleButton.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnIndeterminate | Called when a ToggleButton raises an Indeterminate event. (Inherited from ToggleButton.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsPressedChanged | Called when the IsPressed property changes. (Inherited from ButtonBase.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Provides class handling for the KeyDown routed event that occurs when the user presses a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnKeyUp | Provides class handling for the KeyUp routed event that occurs when the user releases a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Called when an element loses keyboard focus. (Inherited from ButtonBase.)
Protected method | OnLostMouseCapture | Provides class handling for the LostMouseCapture routed event that occurs when this control is no longer receiving mouse event messages. (Inherited from ButtonBase.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Provides class handling for the ClickMode routed event that occurs when the mouse enters this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeave | Provides class handling for the MouseLeave routed event that occurs when the mouse leaves an element. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonDown | Provides class handling for the MouseLeftButtonDown routed event that occurs when the left mouse button is pressed while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonUp | Provides class handling for the MouseLeftButtonUp routed event that occurs when the left mouse button is released while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseMove | Provides class handling for the MouseMove routed event that occurs when the mouse pointer moves while over this element. (Inherited from ButtonBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Called when the rendered size of a control changes. (Inherited from ButtonBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToggle | Called by the OnClick method to implement toggle behavior. (Inherited from ToggleButton.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnUnchecked | Called when a ToggleButton raises an Unchecked event. (Inherited from ToggleButton.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a ToggleButton object. (Inherited from ToggleButton.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | Checked | Occurs when a ToggleButton is checked. (Inherited from ToggleButton.)
Public event | Click | Occurs when a Button is clicked. (Inherited from ButtonBase.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Indeterminate | Occurs when the state of a ToggleButton is neither on nor off. (Inherited from ToggleButton.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unchecked | Occurs when a ToggleButton is unchecked. (Inherited from ToggleButton.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
IconHeightProperty |
IconOnePathProperty |
IconWidthProperty |
IconViewBoxHeightProperty |
IconViewBoxWidthProperty |
ImageSourceProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ExtendedToggleButton Constructor

Initializes a new instance of the ExtendedToggleButton class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ExtendedToggleButton()
public:
ExtendedToggleButton()
See Also

Reference

ExtendedToggleButton Class
VisualComponents.UX.Shared Namespace


ExtendedToggleButton Properties

The ExtendedToggleButton type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | ClickMode | Gets or sets when the Click event occurs. (Inherited from ButtonBase.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | Command | Gets or sets the command to invoke when this button is pressed. (Inherited from ButtonBase.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property. (Inherited from ButtonBase.)
Public property | CommandTarget | Gets or sets the element on which to raise the specified command. (Inherited from ButtonBase.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IconHeight |
Public property | IconOnePath |
Public property | IconWidth |
Public property | IconViewBoxHeight |
Public property | IconViewBoxWidth |
Public property | ImageSource |
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsChecked | Gets or sets whether the ToggleButton is checked. (Inherited from ToggleButton.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets the value of the IsEnabled property. (Inherited from ButtonBase.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsPressed | Gets a value that indicates whether a ButtonBase is currently activated. (Inherited from ButtonBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsThreeState | Determines whether the control supports two or three states. (Inherited from ToggleButton.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ExtendedToggleButton Class
VisualComponents.UX.Shared Namespace


ExtendedToggleButton.IconHeight Property

ExtendedToggleButtonIconHeight Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double IconHeight { get; set; }
public:
property double IconHeight {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ExtendedToggleButton Class
VisualComponents.UX.Shared Namespace


ExtendedToggleButton.IconOnePath Property

ExtendedToggleButtonIconOnePath Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string IconOnePath { get; set; }
public:
property String^ IconOnePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ExtendedToggleButton Class
VisualComponents.UX.Shared Namespace


ExtendedToggleButton.IconWidth Property

ExtendedToggleButtonIconWidth Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double IconWidth { get; set; }
public:
property double IconWidth {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ExtendedToggleButton Class
VisualComponents.UX.Shared Namespace


ExtendedToggleButton.IconViewBoxHeight Property

ExtendedToggleButtonIconViewBoxHeight Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double IconViewBoxHeight { get; set; }
public:
property double IconViewBoxHeight {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ExtendedToggleButton Class
VisualComponents.UX.Shared Namespace


ExtendedToggleButton.IconViewBoxWidth Property

ExtendedToggleButtonIconViewBoxWidth Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double IconViewBoxWidth { get; set; }
public:
property double IconViewBoxWidth {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ExtendedToggleButton Class
VisualComponents.UX.Shared Namespace


ExtendedToggleButton.ImageSource Property

ExtendedToggleButtonImageSource Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ImageSource { get; set; }
public:
property String^ ImageSource {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ExtendedToggleButton Class
VisualComponents.UX.Shared Namespace


ExtendedToggleButton Methods

The ExtendedToggleButton type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Responds when the AccessKey for this control is called. (Inherited from ButtonBase.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChecked | Called when a ToggleButton raises a Checked event. (Inherited from ToggleButton.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClick | Called when a control is clicked by the mouse or the keyboard. (Inherited from ToggleButton.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ToggleButtonAutomationPeer implementation for this control, as part of the WPF infrastructure. (Inherited from ToggleButton.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnIndeterminate | Called when a ToggleButton raises an Indeterminate event. (Inherited from ToggleButton.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsPressedChanged | Called when the IsPressed property changes. (Inherited from ButtonBase.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Provides class handling for the KeyDown routed event that occurs when the user presses a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnKeyUp | Provides class handling for the KeyUp routed event that occurs when the user releases a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Called when an element loses keyboard focus. (Inherited from ButtonBase.)
Protected method | OnLostMouseCapture | Provides class handling for the LostMouseCapture routed event that occurs when this control is no longer receiving mouse event messages. (Inherited from ButtonBase.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Provides class handling for the ClickMode routed event that occurs when the mouse enters this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeave | Provides class handling for the MouseLeave routed event that occurs when the mouse leaves an element. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonDown | Provides class handling for the MouseLeftButtonDown routed event that occurs when the left mouse button is pressed while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonUp | Provides class handling for the MouseLeftButtonUp routed event that occurs when the left mouse button is released while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseMove | Provides class handling for the MouseMove routed event that occurs when the mouse pointer moves while over this element. (Inherited from ButtonBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Called when the rendered size of a control changes. (Inherited from ButtonBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToggle | Called by the OnClick method to implement toggle behavior. (Inherited from ToggleButton.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnUnchecked | Called when a ToggleButton raises an Unchecked event. (Inherited from ToggleButton.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a ToggleButton object. (Inherited from ToggleButton.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ExtendedToggleButton Class
VisualComponents.UX.Shared Namespace


ExtendedToggleButton.OnApplyTemplate Method

ExtendedToggleButtonOnApplyTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

ExtendedToggleButton Class
VisualComponents.UX.Shared Namespace


ExtendedToggleButton Events

The ExtendedToggleButton type exposes the following members.

Events
 | Name | Description
Public event | Checked | Occurs when a ToggleButton is checked. (Inherited from ToggleButton.)
Public event | Click | Occurs when a Button is clicked. (Inherited from ButtonBase.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Indeterminate | Occurs when the state of a ToggleButton is neither on nor off. (Inherited from ToggleButton.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unchecked | Occurs when a ToggleButton is unchecked. (Inherited from ToggleButton.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ExtendedToggleButton Class
VisualComponents.UX.Shared Namespace


ExtendedToggleButton Fields

The ExtendedToggleButton type exposes the following members.

Fields
Name | Description
IconHeightProperty |
IconOnePathProperty |
IconWidthProperty |
IconViewBoxHeightProperty |
IconViewBoxWidthProperty |
ImageSourceProperty |
Top
See Also

Reference

ExtendedToggleButton Class
VisualComponents.UX.Shared Namespace


ExtendedToggleButton.IconHeightProperty Field

ExtendedToggleButtonIconHeightProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IconHeightProperty
public:
static initonly DependencyProperty^ IconHeightProperty

Field Value

Type: DependencyProperty
See Also

Reference

ExtendedToggleButton Class
VisualComponents.UX.Shared Namespace


ExtendedToggleButton.IconOnePathProperty Field

ExtendedToggleButtonIconOnePathProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IconOnePathProperty
public:
static initonly DependencyProperty^ IconOnePathProperty

Field Value

Type: DependencyProperty
See Also

Reference

ExtendedToggleButton Class
VisualComponents.UX.Shared Namespace


ExtendedToggleButton.IconWidthProperty Field

ExtendedToggleButtonIconWidthProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IconWidthProperty
public:
static initonly DependencyProperty^ IconWidthProperty

Field Value

Type: DependencyProperty
See Also

Reference

ExtendedToggleButton Class
VisualComponents.UX.Shared Namespace


ExtendedToggleButton.IconViewBoxHeightProperty Field

ExtendedToggleButtonIconViewBoxHeightProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IconViewBoxHeightProperty
public:
static initonly DependencyProperty^ IconViewBoxHeightProperty

Field Value

Type: DependencyProperty
See Also

Reference

ExtendedToggleButton Class
VisualComponents.UX.Shared Namespace


ExtendedToggleButton.IconViewBoxWidthProperty Field

ExtendedToggleButtonIconViewBoxWidthProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IconViewBoxWidthProperty
public:
static initonly DependencyProperty^ IconViewBoxWidthProperty

Field Value

Type: DependencyProperty
See Also

Reference

ExtendedToggleButton Class
VisualComponents.UX.Shared Namespace


ExtendedToggleButton.ImageSourceProperty Field

ExtendedToggleButtonImageSourceProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ImageSourceProperty
public:
static initonly DependencyProperty^ ImageSourceProperty

Field Value

Type: DependencyProperty
See Also

Reference

ExtendedToggleButton Class
VisualComponents.UX.Shared Namespace


ExtendedUserControl Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedExtendedUserControl
VisualComponents.UX.SharedQuickMenu

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ExtendedUserControl : UserControl
public ref class ExtendedUserControl : public UserControl

The ExtendedUserControl type exposes the following members.

Constructors
 | Name | Description
Public method | ExtendedUserControl | Initializes a new instance of the ExtendedUserControl class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XPosition |
Public property | YPosition |
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
XPositionProperty |
YPositionProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ExtendedUserControl Constructor

Initializes a new instance of the ExtendedUserControl class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ExtendedUserControl()
public:
ExtendedUserControl()
See Also

Reference

ExtendedUserControl Class
VisualComponents.UX.Shared Namespace


ExtendedUserControl Properties

The ExtendedUserControl type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XPosition |
Public property | YPosition |
Top
See Also

Reference

ExtendedUserControl Class
VisualComponents.UX.Shared Namespace


ExtendedUserControl.XPosition Property

ExtendedUserControlXPosition Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double XPosition { get; set; }
public:
property double XPosition {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ExtendedUserControl Class
VisualComponents.UX.Shared Namespace


ExtendedUserControl.YPosition Property

ExtendedUserControlYPosition Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double YPosition { get; set; }
public:
property double YPosition {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ExtendedUserControl Class
VisualComponents.UX.Shared Namespace


ExtendedUserControl Methods

The ExtendedUserControl type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ExtendedUserControl Class
VisualComponents.UX.Shared Namespace


ExtendedUserControl.OnApplyTemplate Method

ExtendedUserControlOnApplyTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

ExtendedUserControl Class
VisualComponents.UX.Shared Namespace


ExtendedUserControl Events

The ExtendedUserControl type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ExtendedUserControl Class
VisualComponents.UX.Shared Namespace


ExtendedUserControl Fields

The ExtendedUserControl type exposes the following members.

Fields
Name | Description
XPositionProperty |
YPositionProperty |
Top
See Also

Reference

ExtendedUserControl Class
VisualComponents.UX.Shared Namespace


ExtendedUserControl.XPositionProperty Field

ExtendedUserControlXPositionProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty XPositionProperty
public:
static initonly DependencyProperty^ XPositionProperty

Field Value

Type: DependencyProperty
See Also

Reference

ExtendedUserControl Class
VisualComponents.UX.Shared Namespace


ExtendedUserControl.YPositionProperty Field

ExtendedUserControlYPositionProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty YPositionProperty
public:
static initonly DependencyProperty^ YPositionProperty

Field Value

Type: DependencyProperty
See Also

Reference

ExtendedUserControl Class
VisualComponents.UX.Shared Namespace


Extensions Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedExtensions

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class Extensions
[ExtensionAttribute]
public ref class Extensions abstract sealed

The Extensions type exposes the following members.

Methods
Name | Description
IsValid | Convenience function to check if wrapper is not null and IsValid is true;
SafePublish | Calls Publish on the EventAggregator and catches any exceptions.
ToObservableCollectionT |
ToObservableCollectionExT |
UnRegister |
ValidOrDefaultT | Convenience function that returns null if wrapper is not valid or it is null.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


Extensions Methods

The Extensions type exposes the following members.

Methods
Name | Description
IsValid | Convenience function to check if wrapper is not null and IsValid is true;
SafePublish | Calls Publish on the EventAggregator and catches any exceptions.
ToObservableCollectionT |
ToObservableCollectionExT |
UnRegister |
ValidOrDefaultT | Convenience function that returns null if wrapper is not valid or it is null.
Top
See Also

Reference

Extensions Class
VisualComponents.UX.Shared Namespace


Extensions.IsValid Method

ExtensionsIsValid Method

Convenience function to check if wrapper is not null and IsValid is true;

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsValid(
    this IWrapper wrapper
)
public:
[ExtensionAttribute]
static bool IsValid(
    IWrapper^ wrapper
)

Parameters

wrapper
Type: VisualComponents.Create3DIWrapper

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Extensions.IsValid(VisualComponents.Create3D.IWrapper)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IWrapper. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Extensions Class
VisualComponents.UX.Shared Namespace


Extensions.SafePublish Method

ExtensionsSafePublish Method

Calls Publish on the EventAggregator and catches any exceptions.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Exception SafePublish(
    this IEventAggregator evAggregator,
    Object message,
    ILog log = null,
    Action<Exception> actionIfException = null,
    bool rethrow = false
)
public:
[ExtensionAttribute]
static Exception^ SafePublish(
    IEventAggregator^ evAggregator,
    Object^ message,
    ILog^ log = nullptr,
    Action<Exception^>^ actionIfException = nullptr,
    bool rethrow = false
)

Parameters

evAggregator
Type: IEventAggregator
Caliburn Micro EventAggregator object.
message
Type: SystemObject
Message object.
log (Optional)
Type: ILog
Logger to use, or null.
actionIfException (Optional)
Type: SystemActionException
Action to invoke if an exception was caught, or null.
rethrow (Optional)
Type: SystemBoolean
If true, will rethrow the exception after all other operations.

Return Value

Type: Exception
The caught exception, or null if no exception.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEventAggregator. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Extensions Class
VisualComponents.UX.Shared Namespace


Extensions.ToObservableCollection(T) Method

ExtensionsToObservableCollectionT Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ObservableCollection<T> ToObservableCollection<T>(
    this IEnumerable<T> col
)

public:
[ExtensionAttribute]
generic<typename T>
static ObservableCollection<T>^ ToObservableCollection(
    IEnumerable<T>^ col
)

Parameters

col
Type: System.Collections.GenericIEnumerableT

Type Parameters

T

Return Value

Type: ObservableCollectionT

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Extensions.ToObservableCollection``1(System.Collections.Generic.IEnumerable{``0})"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerableT. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Extensions Class
VisualComponents.UX.Shared Namespace


Extensions.ToObservableCollectionEx(T) Method

ExtensionsToObservableCollectionExT Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ObservableCollectionEx<T> ToObservableCollectionEx<T>(
    this IEnumerable<T> col
)

public:
[ExtensionAttribute]
generic<typename T>
static ObservableCollectionEx<T>^ ToObservableCollectionEx(
    IEnumerable<T>^ col
)

Parameters

col
Type: System.Collections.GenericIEnumerableT

Type Parameters

T

Return Value

Type: ObservableCollectionEx T

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Extensions.ToObservableCollectionEx``1(System.Collections.Generic.IEnumerable{``0})"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerableT. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Extensions Class
VisualComponents.UX.Shared Namespace


Extensions.UnRegister Method

ExtensionsUnRegister Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void UnRegister(
    this Object obj,
    string eventName,
    Object listener
)
public:
[ExtensionAttribute]
static void UnRegister(
    Object^ obj,
    String^ eventName,
    Object^ listener
)

Parameters

obj
Type: SystemObject
eventName
Type: SystemString
listener
Type: SystemObject

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Extensions Class
VisualComponents.UX.Shared Namespace


Extensions.ValidOrDefault(T) Method

ExtensionsValidOrDefaultT Method

Convenience function that returns null if wrapper is not valid or it is null.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static T ValidOrDefault<T>(
    this T wrapper
)
where T : IWrapper

public:
[ExtensionAttribute]
generic<typename T>
where T : IWrapper
static T ValidOrDefault(
    T wrapper
)

Parameters

wrapper
Type: T

Type Parameters

T

Return Value

Type: T

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Extensions.ValidOrDefault``1(``0)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Extensions Class
VisualComponents.UX.Shared Namespace


FastPropertyChangedBase Class

A slightly faster simpler alternative to PropertyChangedBase that avoids allocating objects on each call. Also provides filtering to only raise the event on value change if NotifyOfPropertyChange(String, Object, Boolean) is used.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedFastPropertyChangedBase

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract class FastPropertyChangedBase : INotifyPropertyChanged
public ref class FastPropertyChangedBase abstract : INotifyPropertyChanged

The FastPropertyChangedBase type exposes the following members.

Constructors
 | Name | Description
Protected method | FastPropertyChangedBase | Initializes a new instance of the FastPropertyChangedBase class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotifyOfPropertyChange(String) | Raises PropertyChanged event, even if the value hasn't changed.
Protected method | NotifyOfPropertyChange(String, Object, Boolean) | Raises the PropertyChanged event if the value has changed or force is true.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks
This implementation is not thread-safe and it raises the event in the calling thread, not in UI thread like PropertyChangedBase
See Also

Reference

VisualComponents.UX.Shared Namespace


FastPropertyChangedBase Constructor

Initializes a new instance of the FastPropertyChangedBase class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected FastPropertyChangedBase()
protected:
FastPropertyChangedBase()
See Also

Reference

FastPropertyChangedBase Class
VisualComponents.UX.Shared Namespace


FastPropertyChangedBase Methods

The FastPropertyChangedBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotifyOfPropertyChange(String) | Raises PropertyChanged event, even if the value hasn't changed.
Protected method | NotifyOfPropertyChange(String, Object, Boolean) | Raises the PropertyChanged event if the value has changed or force is true.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

FastPropertyChangedBase Class
VisualComponents.UX.Shared Namespace


FastPropertyChangedBase.NotifyOfPropertyChange Method

FastPropertyChangedBaseNotifyOfPropertyChange Method

Overload List
 | Name | Description
Protected method | NotifyOfPropertyChange(String) | Raises PropertyChanged event, even if the value hasn't changed.
Protected method | NotifyOfPropertyChange(String, Object, Boolean) | Raises the PropertyChanged event if the value has changed or force is true.
Top
See Also

Reference

FastPropertyChangedBase Class
VisualComponents.UX.Shared Namespace


FastPropertyChangedBase.NotifyOfPropertyChange Method (String)

FastPropertyChangedBaseNotifyOfPropertyChange Method (String)

Raises PropertyChanged event, even if the value hasn't changed.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected void NotifyOfPropertyChange(
    string propertyName = null
)
protected:
void NotifyOfPropertyChange(
    String^ propertyName = nullptr
)

Parameters

propertyName (Optional)
Type: SystemString
The property name. If omitted, the compiler will substitute the calling member's name.
See Also

Reference

FastPropertyChangedBase Class
NotifyOfPropertyChange Overload
VisualComponents.UX.Shared Namespace


FastPropertyChangedBase.NotifyOfPropertyChange Method (String, Object, Boolean)

FastPropertyChangedBaseNotifyOfPropertyChange Method (String, Object, Boolean)

Raises the PropertyChanged event if the value has changed or force is true.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected bool NotifyOfPropertyChange(
    string propertyName,
    Object newValue,
    bool force = false
)
protected:
bool NotifyOfPropertyChange(
    String^ propertyName,
    Object^ newValue,
    bool force = false
)

Parameters

propertyName
Type: SystemString
The property name.
newValue
Type: SystemObject
New value assigned to the property.
force (Optional)
Type: SystemBoolean
When true, skips the value equality check and always raises the event.

Return Value

Type: Boolean
Whether the event was raised. False if there are no listeners for the event.
Remarks
The value change detection requires caching of the latest property value and passing it as Object causes boxing for value types.
See Also

Reference

FastPropertyChangedBase Class
NotifyOfPropertyChange Overload
VisualComponents.UX.Shared Namespace


FastPropertyChangedBase Events

The FastPropertyChangedBase type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

FastPropertyChangedBase Class
VisualComponents.UX.Shared Namespace


FastPropertyChangedBase.PropertyChanged Event

FastPropertyChangedBasePropertyChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event PropertyChangedEventHandler PropertyChanged
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

FastPropertyChangedBase Class
VisualComponents.UX.Shared Namespace


FeatureNodeEditorView Class

Interaction logic for FeatureNodeEditorView.xaml
FeatureNodeEditorView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedFeatureNodeEditorView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class FeatureNodeEditorView : UserControl,
    IComponentConnector
public ref class FeatureNodeEditorView : public UserControl,
    IComponentConnector

The FeatureNodeEditorView type exposes the following members.

Constructors
 | Name | Description
Public method | FeatureNodeEditorView | Initializes a new instance of the FeatureNodeEditorView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


FeatureNodeEditorView Constructor

Initializes a new instance of the FeatureNodeEditorView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FeatureNodeEditorView()
public:
FeatureNodeEditorView()
See Also

Reference

FeatureNodeEditorView Class
VisualComponents.UX.Shared Namespace


FeatureNodeEditorView Properties

The FeatureNodeEditorView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

FeatureNodeEditorView Class
VisualComponents.UX.Shared Namespace


FeatureNodeEditorView Methods

The FeatureNodeEditorView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

FeatureNodeEditorView Class
VisualComponents.UX.Shared Namespace


FeatureNodeEditorView.InitializeComponent Method

FeatureNodeEditorViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

FeatureNodeEditorView Class
VisualComponents.UX.Shared Namespace


FeatureNodeEditorView Events

The FeatureNodeEditorView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

FeatureNodeEditorView Class
VisualComponents.UX.Shared Namespace


FileActionMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedFileActionMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class FileActionMessage
public ref class FileActionMessage

The FileActionMessage type exposes the following members.

Constructors
 | Name | Description
Public method | FileActionMessage | Initializes a new instance of the FileActionMessage class
Top
Properties
 | Name | Description
Public property | FileUri |
Public property | IsComponent |
Public property | IsFromECat |
Public property | IsLocalCopy |
Public property | Status |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | LocalPath |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


FileActionMessage Constructor

Initializes a new instance of the FileActionMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FileActionMessage(
    Uri fileUri,
    string filepath,
    FileStatus status,
    bool component,
    bool fromECat,
    bool localCopy
)
public:
FileActionMessage(
    Uri^ fileUri,
    String^ filepath,
    FileStatus status,
    bool component,
    bool fromECat,
    bool localCopy
)

Parameters

fileUri
Type: SystemUri
filepath
Type: SystemString
status
Type: VisualComponents.UX.SharedFileStatus
component
Type: SystemBoolean
fromECat
Type: SystemBoolean
localCopy
Type: SystemBoolean
See Also

Reference

FileActionMessage Class
VisualComponents.UX.Shared Namespace


FileActionMessage Properties

The FileActionMessage type exposes the following members.

Properties
 | Name | Description
Public property | FileUri |
Public property | IsComponent |
Public property | IsFromECat |
Public property | IsLocalCopy |
Public property | Status |
Top
See Also

Reference

FileActionMessage Class
VisualComponents.UX.Shared Namespace


FileActionMessage.FileUri Property

FileActionMessageFileUri Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Uri FileUri { get; set; }
public:
property Uri^ FileUri {
    Uri^ get ();
    void set (Uri^ value);
}

Property Value

Type: Uri
See Also

Reference

FileActionMessage Class
VisualComponents.UX.Shared Namespace


FileActionMessage.IsComponent Property

FileActionMessageIsComponent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsComponent { get; set; }
public:
property bool IsComponent {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

FileActionMessage Class
VisualComponents.UX.Shared Namespace


FileActionMessage.IsFromECat Property

FileActionMessageIsFromECat Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsFromECat { get; set; }
public:
property bool IsFromECat {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

FileActionMessage Class
VisualComponents.UX.Shared Namespace


FileActionMessage.IsLocalCopy Property

FileActionMessageIsLocalCopy Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsLocalCopy { get; set; }
public:
property bool IsLocalCopy {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

FileActionMessage Class
VisualComponents.UX.Shared Namespace


FileActionMessage.Status Property

FileActionMessageStatus Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FileStatus Status { get; }
public:
property FileStatus Status {
    FileStatus get ();
}

Property Value

Type: FileStatus
See Also

Reference

FileActionMessage Class
VisualComponents.UX.Shared Namespace


FileActionMessage Methods

The FileActionMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

FileActionMessage Class
VisualComponents.UX.Shared Namespace


FileActionMessage Fields

The FileActionMessage type exposes the following members.

Fields
 | Name | Description
Public field | LocalPath |
Top
See Also

Reference

FileActionMessage Class
VisualComponents.UX.Shared Namespace


FileActionMessage.LocalPath Field

FileActionMessageLocalPath Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public readonly string LocalPath
public:
initonly String^ LocalPath

Field Value

Type: String
See Also

Reference

FileActionMessage Class
VisualComponents.UX.Shared Namespace


FileExtensionToIconSourceConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedFileExtensionToIconSourceConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class FileExtensionToIconSourceConverter : IValueConverter
public ref class FileExtensionToIconSourceConverter : IValueConverter

The FileExtensionToIconSourceConverter type exposes the following members.

Constructors
 | Name | Description
Public method | FileExtensionToIconSourceConverter | Initializes a new instance of the FileExtensionToIconSourceConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


FileExtensionToIconSourceConverter Constructor

Initializes a new instance of the FileExtensionToIconSourceConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FileExtensionToIconSourceConverter()
public:
FileExtensionToIconSourceConverter()
See Also

Reference

FileExtensionToIconSourceConverter Class
VisualComponents.UX.Shared Namespace


FileExtensionToIconSourceConverter Methods

The FileExtensionToIconSourceConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

FileExtensionToIconSourceConverter Class
VisualComponents.UX.Shared Namespace


FileExtensionToIconSourceConverter.Convert Method

FileExtensionToIconSourceConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.FileExtensionToIconSourceConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

FileExtensionToIconSourceConverter Class
VisualComponents.UX.Shared Namespace


FileExtensionToIconSourceConverter.ConvertBack Method

FileExtensionToIconSourceConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.FileExtensionToIconSourceConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

FileExtensionToIconSourceConverter Class
VisualComponents.UX.Shared Namespace


FileStatus Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum FileStatus
public enum class FileStatus
Members
Member name | Value | Description
Unknown | 0 |
New | 1 |
Open | 2 |
Close | 3 |
Saved | 4 |
Imported | 5 |
Exported | 6 |
DoesNotExit | 7 |
See Also

Reference

VisualComponents.UX.Shared Namespace


FilterMode Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum FilterMode
public enum class FilterMode
Members
Member name | Value | Description
Flat | 0 |
Hierarchical | 1 |
See Also

Reference

VisualComponents.UX.Shared Namespace


FilterOption Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedFilterOption

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class FilterOption : INotifyPropertyChanged
public ref class FilterOption : INotifyPropertyChanged

The FilterOption type exposes the following members.

Constructors
 | Name | Description
Public method | FilterOption | Initializes a new instance of the FilterOption class
Public method | FilterOption(FilterPredicate) | Initializes a new instance of the FilterOption class
Public method | FilterOption(FilterMode, FilterPredicate) | Initializes a new instance of the FilterOption class
Public method | FilterOption(FilterMode, FilterOptionType, String, FilterPredicate) | Initializes a new instance of the FilterOption class
Public method | FilterOption(FilterMode, FilterOptionType, String, String, FilterPredicate) | Initializes a new instance of the FilterOption class
Top
Properties
 | Name | Description
Public property | Description |
Public property | Mode |
Public property | ParameterName |
Public property | ParameterValue |
Public property | Predicate |
Public property | Type |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RaisePropertyChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


FilterOption Constructor

Overload List
 | Name | Description
Public method | FilterOption | Initializes a new instance of the FilterOption class
Public method | FilterOption(FilterPredicate) | Initializes a new instance of the FilterOption class
Public method | FilterOption(FilterMode, FilterPredicate) | Initializes a new instance of the FilterOption class
Public method | FilterOption(FilterMode, FilterOptionType, String, FilterPredicate) | Initializes a new instance of the FilterOption class
Public method | FilterOption(FilterMode, FilterOptionType, String, String, FilterPredicate) | Initializes a new instance of the FilterOption class
Top
See Also

Reference

FilterOption Class
VisualComponents.UX.Shared Namespace


FilterOption Constructor

Initializes a new instance of the FilterOption class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FilterOption()
public:
FilterOption()
See Also

Reference

FilterOption Class
FilterOption Overload
VisualComponents.UX.Shared Namespace


FilterOption Constructor (FilterPredicate)

Initializes a new instance of the FilterOption class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FilterOption(
    FilterPredicate predicate
)
public:
FilterOption(
    FilterPredicate^ predicate
)

Parameters

predicate
Type: VisualComponents.UX.SharedFilterPredicate
See Also

Reference

FilterOption Class
FilterOption Overload
VisualComponents.UX.Shared Namespace


FilterOption Constructor (FilterMode, FilterPredicate)

Initializes a new instance of the FilterOption class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FilterOption(
    FilterMode mode,
    FilterPredicate predicate
)
public:
FilterOption(
    FilterMode mode,
    FilterPredicate^ predicate
)

Parameters

mode
Type: VisualComponents.UX.SharedFilterMode
predicate
Type: VisualComponents.UX.SharedFilterPredicate
See Also

Reference

FilterOption Class
FilterOption Overload
VisualComponents.UX.Shared Namespace


FilterOption Constructor (FilterMode, FilterOptionType, String, FilterPredicate)

Initializes a new instance of the FilterOption class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FilterOption(
    FilterMode mode,
    FilterOptionType type,
    string parameterName,
    FilterPredicate predicate
)
public:
FilterOption(
    FilterMode mode,
    FilterOptionType type,
    String^ parameterName,
    FilterPredicate^ predicate
)

Parameters

mode
Type: VisualComponents.UX.SharedFilterMode
type
Type: VisualComponents.UX.SharedFilterOptionType
parameterName
Type: SystemString
predicate
Type: VisualComponents.UX.SharedFilterPredicate
See Also

Reference

FilterOption Class
FilterOption Overload
VisualComponents.UX.Shared Namespace


FilterOption Constructor (FilterMode, FilterOptionType, String, String, FilterPredicate)

Initializes a new instance of the FilterOption class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FilterOption(
    FilterMode mode,
    FilterOptionType type,
    string parameterName,
    string description,
    FilterPredicate predicate
)
public:
FilterOption(
    FilterMode mode,
    FilterOptionType type,
    String^ parameterName,
    String^ description,
    FilterPredicate^ predicate
)

Parameters

mode
Type: VisualComponents.UX.SharedFilterMode
type
Type: VisualComponents.UX.SharedFilterOptionType
parameterName
Type: SystemString
description
Type: SystemString
predicate
Type: VisualComponents.UX.SharedFilterPredicate
See Also

Reference

FilterOption Class
FilterOption Overload
VisualComponents.UX.Shared Namespace


FilterOption Properties

The FilterOption type exposes the following members.

Properties
 | Name | Description
Public property | Description |
Public property | Mode |
Public property | ParameterName |
Public property | ParameterValue |
Public property | Predicate |
Public property | Type |
Top
See Also

Reference

FilterOption Class
VisualComponents.UX.Shared Namespace


FilterOption.Description Property

FilterOptionDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; set; }
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

FilterOption Class
VisualComponents.UX.Shared Namespace


FilterOption.Mode Property

FilterOptionMode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FilterMode Mode { get; set; }
public:
property FilterMode Mode {
    FilterMode get ();
    void set (FilterMode value);
}

Property Value

Type: FilterMode
See Also

Reference

FilterOption Class
VisualComponents.UX.Shared Namespace


FilterOption.ParameterName Property

FilterOptionParameterName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ParameterName { get; set; }
public:
property String^ ParameterName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

FilterOption Class
VisualComponents.UX.Shared Namespace


FilterOption.ParameterValue Property

FilterOptionParameterValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ParameterValue { get; set; }
public:
property Object^ ParameterValue {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

FilterOption Class
VisualComponents.UX.Shared Namespace


FilterOption.Predicate Property

FilterOptionPredicate Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FilterPredicate Predicate { get; set; }
public:
property FilterPredicate^ Predicate {
    FilterPredicate^ get ();
    void set (FilterPredicate^ value);
}

Property Value

Type: FilterPredicate
See Also

Reference

FilterOption Class
VisualComponents.UX.Shared Namespace


FilterOption.Type Property

FilterOptionType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FilterOptionType Type { get; set; }
public:
property FilterOptionType Type {
    FilterOptionType get ();
    void set (FilterOptionType value);
}

Property Value

Type: FilterOptionType
See Also

Reference

FilterOption Class
VisualComponents.UX.Shared Namespace


FilterOption Methods

The FilterOption type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RaisePropertyChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

FilterOption Class
VisualComponents.UX.Shared Namespace


FilterOption.RaisePropertyChanged Method

FilterOptionRaisePropertyChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RaisePropertyChanged(
    string name = null
)
public:
void RaisePropertyChanged(
    String^ name = nullptr
)

Parameters

name (Optional)
Type: SystemString
See Also

Reference

FilterOption Class
VisualComponents.UX.Shared Namespace


FilterOption Events

The FilterOption type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

FilterOption Class
VisualComponents.UX.Shared Namespace


FilterOption.PropertyChanged Event

FilterOptionPropertyChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event PropertyChangedEventHandler PropertyChanged
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

FilterOption Class
VisualComponents.UX.Shared Namespace


FilterOptionType Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum FilterOptionType
public enum class FilterOptionType
Members
Member name | Value | Description
None | 0 |
Boolean | 1 |
String | 2 |
See Also

Reference

VisualComponents.UX.Shared Namespace


FilterPredicate Delegate

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public delegate bool FilterPredicate(
    Object target,
    Object parameter
)
public delegate bool FilterPredicate(
    Object^ target,
    Object^ parameter
)

Parameters

target
Type: SystemObject
parameter
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

VisualComponents.UX.Shared Namespace


FilterType Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum FilterType
public enum class FilterType
Members
Member name | Value | Description
Contains | 0 |
StartsWith | 1 |
EndsWith | 2 |
Regex | 3 |
See Also

Reference

VisualComponents.UX.Shared Namespace


FinishSnapMessage Class

This message is used to finalize secondary snapping result, which might become deprecated after 2 seconds of idling.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedFinishSnapMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class FinishSnapMessage
public ref class FinishSnapMessage

The FinishSnapMessage type exposes the following members.

Constructors
 | Name | Description
Public method | FinishSnapMessage | Initializes a new instance of the FinishSnapMessage class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


FinishSnapMessage Constructor

Initializes a new instance of the FinishSnapMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FinishSnapMessage()
public:
FinishSnapMessage()
See Also

Reference

FinishSnapMessage Class
VisualComponents.UX.Shared Namespace


FinishSnapMessage Methods

The FinishSnapMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

FinishSnapMessage Class
VisualComponents.UX.Shared Namespace


FixedPropertyContainer Class

Fixed property container implementation.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedFixedPropertyContainer
More...

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class FixedPropertyContainer : IPropertyContainer,
    IBatchModeObject, INotifyPropertyChanged
public ref class FixedPropertyContainer : IPropertyContainer,
    IBatchModeObject, INotifyPropertyChanged

The FixedPropertyContainer type exposes the following members.

Constructors
 | Name | Description
Public method | FixedPropertyContainer | Initializes a new instance of the FixedPropertyContainer class
Top
Properties
 | Name | Description
Public property | ChangeBatchLevel |
Public property | ContainerExpressionContext |
Protected property | EventMng | Event aggregator
Public property | Properties | get properties
Public property | PropertyNames |
Public property | PropertyNamesAndValues |
Public property | PropertyValues |
Top
Methods
 | Name | Description
Public method | BeginChangeBatch |
Public method | CreateProperty(Type, PropertyConstraintType) |
Public method | CreateProperty(Type, PropertyConstraintType, String) |
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) |
Public method | DeleteProperty |
Public method | EndChangeBatch |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperty |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotifyChanged |
Public method | NotifyPropertyChanged |
Public method | SetPropertyValues(IEnumerableObject) |
Public method | SetPropertyValues(IEnumerableTupleString, Object) |
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) |
Public method | SetPropertyValues(Int32, IEnumerableObject) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged |
Public event | PropertyContainerChanged |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedFixedPropertyContainer
VisualComponents.UX.SharedAnnotationManipulateAction
VisualComponents.UX.SharedAreaSelectAction
VisualComponents.UX.SharedDimensionManipulateAction
VisualComponents.UX.SharedObjectRotateAction
VisualComponents.UX.SharedPlugPlayAction
VisualComponents.UX.SharedPlugPlayLogicalAction
VisualComponents.UX.SharedTranslateAction


FixedPropertyContainer Constructor

Initializes a new instance of the FixedPropertyContainer class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FixedPropertyContainer()
public:
FixedPropertyContainer()
See Also

Reference

FixedPropertyContainer Class
VisualComponents.UX.Shared Namespace


FixedPropertyContainer Properties

The FixedPropertyContainer type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel |
Public property | ContainerExpressionContext |
Protected property | EventMng | Event aggregator
Public property | Properties | get properties
Public property | PropertyNames |
Public property | PropertyNamesAndValues |
Public property | PropertyValues |
Top
See Also

Reference

FixedPropertyContainer Class
VisualComponents.UX.Shared Namespace


FixedPropertyContainer.ChangeBatchLevel Property

FixedPropertyContainerChangeBatchLevel Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ChangeBatchLevel { get; }
public:
virtual property int ChangeBatchLevel {
    int get () sealed;
}

Property Value

Type: Int32

Implements

IBatchModeObjectChangeBatchLevel
See Also

Reference

FixedPropertyContainer Class
VisualComponents.UX.Shared Namespace


FixedPropertyContainer.ContainerExpressionContext Property

FixedPropertyContainerContainerExpressionContext Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IExpressionContext ContainerExpressionContext { get; }
public:
virtual property IExpressionContext^ ContainerExpressionContext {
    IExpressionContext^ get () sealed;
}

Property Value

Type: IExpressionContext

Implements

IPropertyContainerContainerExpressionContext
See Also

Reference

FixedPropertyContainer Class
VisualComponents.UX.Shared Namespace


FixedPropertyContainer.EventMng Property

FixedPropertyContainerEventMng Property

Event aggregator

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected IEventAggregator EventMng { get; }
protected:
property IEventAggregator^ EventMng {
    IEventAggregator^ get ();
}

Property Value

Type: IEventAggregator
See Also

Reference

FixedPropertyContainer Class
VisualComponents.UX.Shared Namespace


FixedPropertyContainer.Properties Property

FixedPropertyContainerProperties Property

get properties

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList<IProperty> Properties { get; }
public:
virtual property IList<IProperty^>^ Properties {
    IList<IProperty^>^ get () sealed;
}

Property Value

Type: IListIProperty

Implements

IPropertyContainerProperties
See Also

Reference

FixedPropertyContainer Class
VisualComponents.UX.Shared Namespace


FixedPropertyContainer.PropertyNames Property

FixedPropertyContainerPropertyNames Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<string> PropertyNames { get; }
public:
virtual property IEnumerable<String^>^ PropertyNames {
    IEnumerable<String^>^ get () sealed;
}

Property Value

Type: IEnumerableString

Implements

IPropertyContainerPropertyNames
See Also

Reference

FixedPropertyContainer Class
VisualComponents.UX.Shared Namespace


FixedPropertyContainer.PropertyNamesAndValues Property

FixedPropertyContainerPropertyNamesAndValues Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<Tuple<string, Object>> PropertyNamesAndValues { get; }
public:
virtual property IEnumerable<Tuple<String^, Object^>^>^ PropertyNamesAndValues {
    IEnumerable<Tuple<String^, Object^>^>^ get () sealed;
}

Property Value

Type: IEnumerableTupleString, Object

Implements

IPropertyContainerPropertyNamesAndValues
See Also

Reference

FixedPropertyContainer Class
VisualComponents.UX.Shared Namespace


FixedPropertyContainer.PropertyValues Property

FixedPropertyContainerPropertyValues Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<Object> PropertyValues { get; }
public:
virtual property IEnumerable<Object^>^ PropertyValues {
    IEnumerable<Object^>^ get () sealed;
}

Property Value

Type: IEnumerableObject

Implements

IPropertyContainerPropertyValues
See Also

Reference

FixedPropertyContainer Class
VisualComponents.UX.Shared Namespace


FixedPropertyContainer Methods

The FixedPropertyContainer type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch |
Public method | CreateProperty(Type, PropertyConstraintType) |
Public method | CreateProperty(Type, PropertyConstraintType, String) |
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) |
Public method | DeleteProperty |
Public method | EndChangeBatch |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperty |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotifyChanged |
Public method | NotifyPropertyChanged |
Public method | SetPropertyValues(IEnumerableObject) |
Public method | SetPropertyValues(IEnumerableTupleString, Object) |
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) |
Public method | SetPropertyValues(Int32, IEnumerableObject) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

FixedPropertyContainer Class
VisualComponents.UX.Shared Namespace


FixedPropertyContainer.BeginChangeBatch Method

FixedPropertyContainerBeginChangeBatch Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void BeginChangeBatch()
public:
virtual void BeginChangeBatch() sealed

Implements

IBatchModeObjectBeginChangeBatch
See Also

Reference

FixedPropertyContainer Class
VisualComponents.UX.Shared Namespace


FixedPropertyContainer.CreateProperty Method

FixedPropertyContainerCreateProperty Method

Overload List
 | Name | Description
Public method | CreateProperty(Type, PropertyConstraintType) |
Public method | CreateProperty(Type, PropertyConstraintType, String) |
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) |
Top
See Also

Reference

FixedPropertyContainer Class
VisualComponents.UX.Shared Namespace


FixedPropertyContainer.CreateProperty Method (Type, PropertyConstraintType)

FixedPropertyContainerCreateProperty Method (Type, PropertyConstraintType)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty CreateProperty(
    Type valueType,
    PropertyConstraintType constraintType
)
public:
virtual IProperty^ CreateProperty(
    Type^ valueType,
    PropertyConstraintType constraintType
) sealed

Parameters

valueType
Type: SystemType
constraintType
Type: VisualComponents.Create3DPropertyConstraintType

Return Value

Type: IProperty

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.FixedPropertyContainer.CreateProperty(System.Type,VisualComponents.Create3D.PropertyConstraintType)"]

Implements

IPropertyContainerCreateProperty(Type, PropertyConstraintType)
See Also

Reference

FixedPropertyContainer Class
CreateProperty Overload
VisualComponents.UX.Shared Namespace


FixedPropertyContainer.CreateProperty Method (Type, PropertyConstraintType, String)

FixedPropertyContainerCreateProperty Method (Type, PropertyConstraintType, String)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty CreateProperty(
    Type valueType,
    PropertyConstraintType constraintType,
    string name
)
public:
virtual IProperty^ CreateProperty(
    Type^ valueType,
    PropertyConstraintType constraintType,
    String^ name
) sealed

Parameters

valueType
Type: SystemType
constraintType
Type: VisualComponents.Create3DPropertyConstraintType
name
Type: SystemString

Return Value

Type: IProperty

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.FixedPropertyContainer.CreateProperty(System.Type,VisualComponents.Create3D.PropertyConstraintType,System.String)"]

Implements

IPropertyContainerCreateProperty(Type, PropertyConstraintType, String)
See Also

Reference

FixedPropertyContainer Class
CreateProperty Overload
VisualComponents.UX.Shared Namespace


FixedPropertyContainer.CreateProperty Method (Type, PropertyConstraintType, String, IProperty)

FixedPropertyContainerCreateProperty Method (Type, PropertyConstraintType, String, IProperty)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty CreateProperty(
    Type valueType,
    PropertyConstraintType constraintType,
    string name,
    IProperty toBeReplaced
)
public:
virtual IProperty^ CreateProperty(
    Type^ valueType,
    PropertyConstraintType constraintType,
    String^ name,
    IProperty^ toBeReplaced
) sealed

Parameters

valueType
Type: SystemType
constraintType
Type: VisualComponents.Create3DPropertyConstraintType
name
Type: SystemString
toBeReplaced
Type: VisualComponents.Create3DIProperty

Return Value

Type: IProperty

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.FixedPropertyContainer.CreateProperty(System.Type,VisualComponents.Create3D.PropertyConstraintType,System.String,VisualComponents.Create3D.IProperty)"]

Implements

IPropertyContainerCreateProperty(Type, PropertyConstraintType, String, IProperty)
See Also

Reference

FixedPropertyContainer Class
CreateProperty Overload
VisualComponents.UX.Shared Namespace


FixedPropertyContainer.DeleteProperty Method

FixedPropertyContainerDeleteProperty Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void DeleteProperty(
    IProperty prop
)
public:
virtual void DeleteProperty(
    IProperty^ prop
) sealed

Parameters

prop
Type: VisualComponents.Create3DIProperty

Implements

IPropertyContainerDeleteProperty(IProperty)
See Also

Reference

FixedPropertyContainer Class
VisualComponents.UX.Shared Namespace


FixedPropertyContainer.EndChangeBatch Method

FixedPropertyContainerEndChangeBatch Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void EndChangeBatch()
public:
virtual void EndChangeBatch() sealed

Implements

IBatchModeObjectEndChangeBatch
See Also

Reference

FixedPropertyContainer Class
VisualComponents.UX.Shared Namespace


FixedPropertyContainer.GetProperty Method

FixedPropertyContainerGetProperty Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty GetProperty(
    string name
)
public:
virtual IProperty^ GetProperty(
    String^ name
) sealed

Parameters

name
Type: SystemString

Return Value

Type: IProperty

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.FixedPropertyContainer.GetProperty(System.String)"]

Implements

IPropertyContainerGetProperty(String)
See Also

Reference

FixedPropertyContainer Class
VisualComponents.UX.Shared Namespace


FixedPropertyContainer.NotifyChanged Method

FixedPropertyContainerNotifyChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected void NotifyChanged(
    string propertyName
)
protected:
void NotifyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: SystemString
See Also

Reference

FixedPropertyContainer Class
VisualComponents.UX.Shared Namespace


FixedPropertyContainer.NotifyPropertyChanged Method

FixedPropertyContainerNotifyPropertyChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void NotifyPropertyChanged(
    string propertyName
)
public:
void NotifyPropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: SystemString
See Also

Reference

FixedPropertyContainer Class
VisualComponents.UX.Shared Namespace


FixedPropertyContainer.SetPropertyValues Method

FixedPropertyContainerSetPropertyValues Method

Overload List
 | Name | Description
Public method | SetPropertyValues(IEnumerableObject) |
Public method | SetPropertyValues(IEnumerableTupleString, Object) |
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) |
Public method | SetPropertyValues(Int32, IEnumerableObject) |
Top
See Also

Reference

FixedPropertyContainer Class
VisualComponents.UX.Shared Namespace


FixedPropertyContainer.SetPropertyValues Method (IEnumerable(Object))

FixedPropertyContainerSetPropertyValues Method (IEnumerableObject)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetPropertyValues(
    IEnumerable<Object> values
)
public:
virtual void SetPropertyValues(
    IEnumerable<Object^>^ values
) sealed

Parameters

values
Type: System.Collections.GenericIEnumerableObject

Implements

IPropertyContainerSetPropertyValues(IEnumerableObject)
See Also

Reference

FixedPropertyContainer Class
SetPropertyValues Overload
VisualComponents.UX.Shared Namespace


FixedPropertyContainer.SetPropertyValues Method (IEnumerable(Tuple(String, Object)))

FixedPropertyContainerSetPropertyValues Method (IEnumerableTupleString, Object)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetPropertyValues(
    IEnumerable<Tuple<string, Object>> namesAndValues
)
public:
virtual void SetPropertyValues(
    IEnumerable<Tuple<String^, Object^>^>^ namesAndValues
) sealed

Parameters

namesAndValues
Type: System.Collections.GenericIEnumerableTupleString, Object

Implements

IPropertyContainerSetPropertyValues(IEnumerableTupleString, Object)
See Also

Reference

FixedPropertyContainer Class
SetPropertyValues Overload
VisualComponents.UX.Shared Namespace


FixedPropertyContainer.SetPropertyValues Method (IEnumerable(String), IEnumerable(Object))

FixedPropertyContainerSetPropertyValues Method (IEnumerableString, IEnumerableObject)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetPropertyValues(
    IEnumerable<string> names,
    IEnumerable<Object> values
)
public:
virtual void SetPropertyValues(
    IEnumerable<String^>^ names,
    IEnumerable<Object^>^ values
) sealed

Parameters

names
Type: System.Collections.GenericIEnumerableString
values
Type: System.Collections.GenericIEnumerableObject

Implements

IPropertyContainerSetPropertyValues(IEnumerableString, IEnumerableObject)
See Also

Reference

FixedPropertyContainer Class
SetPropertyValues Overload
VisualComponents.UX.Shared Namespace


FixedPropertyContainer.SetPropertyValues Method (Int32, IEnumerable(Object))

FixedPropertyContainerSetPropertyValues Method (Int32, IEnumerableObject)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetPropertyValues(
    int startIndex,
    IEnumerable<Object> values
)
public:
virtual void SetPropertyValues(
    int startIndex,
    IEnumerable<Object^>^ values
) sealed

Parameters

startIndex
Type: SystemInt32
values
Type: System.Collections.GenericIEnumerableObject

Implements

IPropertyContainerSetPropertyValues(Int32, IEnumerableObject)
See Also

Reference

FixedPropertyContainer Class
SetPropertyValues Overload
VisualComponents.UX.Shared Namespace


FixedPropertyContainer Events

The FixedPropertyContainer type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Public event | PropertyContainerChanged |
Top
See Also

Reference

FixedPropertyContainer Class
VisualComponents.UX.Shared Namespace


FixedPropertyContainer.PropertyChanged Event

FixedPropertyContainerPropertyChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event PropertyChangedEventHandler PropertyChanged
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

FixedPropertyContainer Class
VisualComponents.UX.Shared Namespace


FixedPropertyContainer.PropertyContainerChanged Event

FixedPropertyContainerPropertyContainerChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<PropertyContainerChangedEventArgs> PropertyContainerChanged
public:
virtual  event EventHandler<PropertyContainerChangedEventArgs^>^ PropertyContainerChanged {
    void add (EventHandler<PropertyContainerChangedEventArgs^>^ value);
    void remove (EventHandler<PropertyContainerChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerPropertyContainerChangedEventArgs

Implements

IPropertyContainerPropertyContainerChanged
See Also

Reference

FixedPropertyContainer Class
VisualComponents.UX.Shared Namespace


FloatingLicenseServerConfiguration Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedFloatingLicenseServerConfiguration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class FloatingLicenseServerConfiguration : IFloatingLicenseServerConfiguration
public ref class FloatingLicenseServerConfiguration : IFloatingLicenseServerConfiguration

The FloatingLicenseServerConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | FloatingLicenseServerConfiguration | Initializes a new instance of the FloatingLicenseServerConfiguration class
Top
Properties
 | Name | Description
Public property | ServerAddress |
Public property | ServerPort |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


FloatingLicenseServerConfiguration Constructor

Initializes a new instance of the FloatingLicenseServerConfiguration class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FloatingLicenseServerConfiguration()
public:
FloatingLicenseServerConfiguration()
See Also

Reference

FloatingLicenseServerConfiguration Class
VisualComponents.UX.Shared Namespace


FloatingLicenseServerConfiguration Properties

The FloatingLicenseServerConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | ServerAddress |
Public property | ServerPort |
Top
See Also

Reference

FloatingLicenseServerConfiguration Class
VisualComponents.UX.Shared Namespace


FloatingLicenseServerConfiguration.ServerAddress Property

FloatingLicenseServerConfigurationServerAddress Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ServerAddress { get; set; }
public:
virtual property String^ ServerAddress {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IFloatingLicenseServerConfigurationServerAddress
See Also

Reference

FloatingLicenseServerConfiguration Class
VisualComponents.UX.Shared Namespace


FloatingLicenseServerConfiguration.ServerPort Property

FloatingLicenseServerConfigurationServerPort Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ServerPort { get; set; }
public:
virtual property String^ ServerPort {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IFloatingLicenseServerConfigurationServerPort
See Also

Reference

FloatingLicenseServerConfiguration Class
VisualComponents.UX.Shared Namespace


FloatingLicenseServerConfiguration Methods

The FloatingLicenseServerConfiguration type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

FloatingLicenseServerConfiguration Class
VisualComponents.UX.Shared Namespace


FloatingPositionHelper Class

Handles pose updates for floating elements (Annotations, TextFeatures)
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedFloatingPositionHelper

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class FloatingPositionHelper : IPlugin
public ref class FloatingPositionHelper sealed : IPlugin

The FloatingPositionHelper type exposes the following members.

Constructors
 | Name | Description
Public method | FloatingPositionHelper | Initializes a new instance of the FloatingPositionHelper class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exit |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initialize this plugin, called from ShellViewModel.InitializePlugins()
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


FloatingPositionHelper Constructor

Initializes a new instance of the FloatingPositionHelper class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FloatingPositionHelper()
public:
FloatingPositionHelper()
See Also

Reference

FloatingPositionHelper Class
VisualComponents.UX.Shared Namespace


FloatingPositionHelper Methods

The FloatingPositionHelper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exit |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initialize this plugin, called from ShellViewModel.InitializePlugins()
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

FloatingPositionHelper Class
VisualComponents.UX.Shared Namespace


FloatingPositionHelper.Exit Method

FloatingPositionHelperExit Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Exit()
public:
virtual void Exit() sealed

Implements

IPluginExit
See Also

Reference

FloatingPositionHelper Class
VisualComponents.UX.Shared Namespace


FloatingPositionHelper.Initialize Method

FloatingPositionHelperInitialize Method

Initialize this plugin, called from ShellViewModel.InitializePlugins()

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Initialize()
public:
virtual void Initialize() sealed

Implements

IPluginInitialize
See Also

Reference

FloatingPositionHelper Class
VisualComponents.UX.Shared Namespace


FocusBehavior Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.WindowsFreezable
System.Windows.Media.AnimationAnimatable
Behavior
BehaviorControl
VisualComponents.UX.SharedFocusBehavior

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class FocusBehavior : Behavior<Control>
public ref class FocusBehavior : public Behavior<Control^>

The FocusBehavior type exposes the following members.

Constructors
 | Name | Description
Public method | FocusBehavior | Initializes a new instance of the FocusBehavior class
Top
Properties
 | Name | Description
Protected property | AssociatedObject | (Inherited from BehaviorControl.)
Protected property | AssociatedType | (Inherited from Behavior.)
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Inherited from Animatable.)
Public property | HasInitialFocus |
Public property | IsFocused |
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Top
Methods
 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | Attach | (Inherited from Behavior.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of this Animatable, making deep copies of this object's values. When copying this object's dependency properties, this method copies resource references and data bindings (but they might no longer resolve) but not animations or their current values. (Inherited from Animatable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | (Inherited from Behavior.)
Public method | Detach | (Inherited from Behavior.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to . (Inherited from Freezable.)
Protected method | FreezeCore | Makes this Animatable object unmodifiable or determines whether it can be made unmodifiable. (Inherited from Animatable.)
Public method | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Inherited from Animatable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttached | (Overrides Behavior.OnAttached.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnDetaching | (Inherited from Behavior.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
Events
 | Name | Description
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Top
Fields
Name | Description
HasInitialFocusProperty |
IsFocusedProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


FocusBehavior Constructor

Initializes a new instance of the FocusBehavior class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FocusBehavior()
public:
FocusBehavior()
See Also

Reference

FocusBehavior Class
VisualComponents.UX.Shared Namespace


FocusBehavior Properties

The FocusBehavior type exposes the following members.

Properties
 | Name | Description
Protected property | AssociatedObject | (Inherited from BehaviorControl.)
Protected property | AssociatedType | (Inherited from Behavior.)
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Inherited from Animatable.)
Public property | HasInitialFocus |
Public property | IsFocused |
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Top
See Also

Reference

FocusBehavior Class
VisualComponents.UX.Shared Namespace


FocusBehavior.HasInitialFocus Property

FocusBehaviorHasInitialFocus Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HasInitialFocus { get; set; }
public:
property bool HasInitialFocus {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

FocusBehavior Class
VisualComponents.UX.Shared Namespace


FocusBehavior.IsFocused Property

FocusBehaviorIsFocused Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsFocused { get; set; }
public:
property bool IsFocused {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

FocusBehavior Class
VisualComponents.UX.Shared Namespace


FocusBehavior Methods

The FocusBehavior type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | Attach | (Inherited from Behavior.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of this Animatable, making deep copies of this object's values. When copying this object's dependency properties, this method copies resource references and data bindings (but they might no longer resolve) but not animations or their current values. (Inherited from Animatable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | (Inherited from Behavior.)
Public method | Detach | (Inherited from Behavior.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to . (Inherited from Freezable.)
Protected method | FreezeCore | Makes this Animatable object unmodifiable or determines whether it can be made unmodifiable. (Inherited from Animatable.)
Public method | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Inherited from Animatable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttached | (Overrides Behavior.OnAttached.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnDetaching | (Inherited from Behavior.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

FocusBehavior Class
VisualComponents.UX.Shared Namespace


FocusBehavior.OnAttached Method

FocusBehaviorOnAttached Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnAttached()
protected:
virtual void OnAttached() override
See Also

Reference

FocusBehavior Class
VisualComponents.UX.Shared Namespace


FocusBehavior Events

The FocusBehavior type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Top
See Also

Reference

FocusBehavior Class
VisualComponents.UX.Shared Namespace


FocusBehavior Fields

The FocusBehavior type exposes the following members.

Fields
Name | Description
HasInitialFocusProperty |
IsFocusedProperty |
Top
See Also

Reference

FocusBehavior Class
VisualComponents.UX.Shared Namespace


FocusBehavior.HasInitialFocusProperty Field

FocusBehaviorHasInitialFocusProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty HasInitialFocusProperty
public:
static initonly DependencyProperty^ HasInitialFocusProperty

Field Value

Type: DependencyProperty
See Also

Reference

FocusBehavior Class
VisualComponents.UX.Shared Namespace


FocusBehavior.IsFocusedProperty Field

FocusBehaviorIsFocusedProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsFocusedProperty
public:
static initonly DependencyProperty^ IsFocusedProperty

Field Value

Type: DependencyProperty
See Also

Reference

FocusBehavior Class
VisualComponents.UX.Shared Namespace


FolderNodeType Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum FolderNodeType
public enum class FolderNodeType
Members
Member name | Value | Description
ProductProperty | 0 |
ComponentProperty | 1 |
See Also

Reference

VisualComponents.UX.Shared Namespace


ForEachHelper Class

ForEach helper
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedForEachHelper

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class ForEachHelper
[ExtensionAttribute]
public ref class ForEachHelper abstract sealed

The ForEachHelper type exposes the following members.

Methods
Name | Description
ForEachT | Enumerate a cached collection performing the specified action on each item.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ForEachHelper Methods

The ForEachHelper type exposes the following members.

Methods
Name | Description
ForEachT | Enumerate a cached collection performing the specified action on each item.
Top
See Also

Reference

ForEachHelper Class
VisualComponents.UX.Shared Namespace


ForEachHelper.ForEach(T) Method

ForEachHelperForEachT Method

Enumerate a cached collection performing the specified action on each item.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void ForEach<T>(
    this IEnumerable<T> items,
    Action<T> action
)

public:
[ExtensionAttribute]
generic<typename T>
static void ForEach(
    IEnumerable<T>^ items,
    Action<T>^ action
)

Parameters

items
Type: System.Collections.GenericIEnumerableT
action
Type: SystemActionT

Type Parameters

T

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerableT. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ForEachHelper Class
VisualComponents.UX.Shared Namespace


FramesVisibilityAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedFramesVisibilityAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class FramesVisibilityAction : IHandle<ItemSelectedMessage<ISimComponent>>,
    IHandle
public ref class FramesVisibilityAction sealed : IHandle<ItemSelectedMessage<ISimComponent^>^>,
    IHandle

The FramesVisibilityAction type exposes the following members.

Methods
 | Name | Description
 | Cancel |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | Execute |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


FramesVisibilityAction Methods

The FramesVisibilityAction type exposes the following members.

Methods
 | Name | Description
 | Cancel |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | Execute |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

FramesVisibilityAction Class
VisualComponents.UX.Shared Namespace


FramesVisibilityAction.Cancel Method

FramesVisibilityActionCancel Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void Cancel()
public:
static void Cancel()
See Also

Reference

FramesVisibilityAction Class
VisualComponents.UX.Shared Namespace


FramesVisibilityAction.Execute Method

FramesVisibilityActionExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void Execute()
public:
static void Execute()
See Also

Reference

FramesVisibilityAction Class
VisualComponents.UX.Shared Namespace


FramesVisibilityAction.Handle Method

FramesVisibilityActionHandle Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    ItemSelectedMessage<ISimComponent> message
)
public:
virtual void Handle(
    ItemSelectedMessage<ISimComponent^>^ message
) sealed

Parameters

message
Type: VisualComponents.Create3DItemSelectedMessage ISimComponent

Implements

IHandle.Handle(UTP)
See Also

Reference

FramesVisibilityAction Class
VisualComponents.UX.Shared Namespace


FullScreenModeStatusMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedFullScreenModeStatusMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class FullScreenModeStatusMessage
public ref class FullScreenModeStatusMessage

The FullScreenModeStatusMessage type exposes the following members.

Constructors
 | Name | Description
Public method | FullScreenModeStatusMessage | Initializes a new instance of the FullScreenModeStatusMessage class
Top
Properties
 | Name | Description
Public property | IsApplicationInFullScreenMode |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


FullScreenModeStatusMessage Constructor

Initializes a new instance of the FullScreenModeStatusMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FullScreenModeStatusMessage(
    bool isApplicationInFullScreenMode
)
public:
FullScreenModeStatusMessage(
    bool isApplicationInFullScreenMode
)

Parameters

isApplicationInFullScreenMode
Type: SystemBoolean
See Also

Reference

FullScreenModeStatusMessage Class
VisualComponents.UX.Shared Namespace


FullScreenModeStatusMessage Properties

The FullScreenModeStatusMessage type exposes the following members.

Properties
 | Name | Description
Public property | IsApplicationInFullScreenMode |
Top
See Also

Reference

FullScreenModeStatusMessage Class
VisualComponents.UX.Shared Namespace


FullScreenModeStatusMessage.IsApplicationInFullScreenMode Property

FullScreenModeStatusMessageIsApplicationInFullScreenMode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsApplicationInFullScreenMode { get; }
public:
property bool IsApplicationInFullScreenMode {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

FullScreenModeStatusMessage Class
VisualComponents.UX.Shared Namespace


FullScreenModeStatusMessage Methods

The FullScreenModeStatusMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

FullScreenModeStatusMessage Class
VisualComponents.UX.Shared Namespace


GalleryGroup Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedGalleryGroup

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class GalleryGroup
public ref class GalleryGroup

The GalleryGroup type exposes the following members.

Constructors
 | Name | Description
Public method | GalleryGroup | Initializes a new instance of the GalleryGroup class
Top
Properties
 | Name | Description
Public property | ItemsKeys |
Public property | Key |
Public property | Title |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


GalleryGroup Constructor

Initializes a new instance of the GalleryGroup class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GalleryGroup()
public:
GalleryGroup()
See Also

Reference

GalleryGroup Class
VisualComponents.UX.Shared Namespace


GalleryGroup Properties

The GalleryGroup type exposes the following members.

Properties
 | Name | Description
Public property | ItemsKeys |
Public property | Key |
Public property | Title |
Top
See Also

Reference

GalleryGroup Class
VisualComponents.UX.Shared Namespace


GalleryGroup.ItemsKeys Property

GalleryGroupItemsKeys Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<string> ItemsKeys { get; set; }
public:
property List<String^>^ ItemsKeys {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Property Value

Type: ListString
See Also

Reference

GalleryGroup Class
VisualComponents.UX.Shared Namespace


GalleryGroup.Key Property

GalleryGroupKey Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Key { get; set; }
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

GalleryGroup Class
VisualComponents.UX.Shared Namespace


GalleryGroup.Title Property

GalleryGroupTitle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; set; }
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

GalleryGroup Class
VisualComponents.UX.Shared Namespace


GalleryGroup Methods

The GalleryGroup type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

GalleryGroup Class
VisualComponents.UX.Shared Namespace


GalleryGroupConfigElement Class

blocked item config element
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.UX.SharedGalleryGroupConfigElement

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class GalleryGroupConfigElement : ConfigurationElement
public ref class GalleryGroupConfigElement sealed : public ConfigurationElement

The GalleryGroupConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | GalleryGroupConfigElement | Initializes a new instance of the GalleryGroupConfigElement class
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | GalleryEntries |
Public property | GalleryGroups |
Public property | ItemId | Item ID
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | TitleKey |
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


GalleryGroupConfigElement Constructor

Initializes a new instance of the GalleryGroupConfigElement class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GalleryGroupConfigElement()
public:
GalleryGroupConfigElement()
See Also

Reference

GalleryGroupConfigElement Class
VisualComponents.UX.Shared Namespace


GalleryGroupConfigElement Properties

The GalleryGroupConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | GalleryEntries |
Public property | GalleryGroups |
Public property | ItemId | Item ID
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | TitleKey |
Top
See Also

Reference

GalleryGroupConfigElement Class
VisualComponents.UX.Shared Namespace


GalleryGroupConfigElement.GalleryEntries Property

GalleryGroupConfigElementGalleryEntries Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GalleryGroupsEntryConfigCollection GalleryEntries { get; }
public:
property GalleryGroupsEntryConfigCollection^ GalleryEntries {
    GalleryGroupsEntryConfigCollection^ get ();
}

Property Value

Type: GalleryGroupsEntryConfigCollection
See Also

Reference

GalleryGroupConfigElement Class
VisualComponents.UX.Shared Namespace


GalleryGroupConfigElement.GalleryGroups Property

GalleryGroupConfigElementGalleryGroups Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GalleryGroupsConfigCollection GalleryGroups { get; }
public:
property GalleryGroupsConfigCollection^ GalleryGroups {
    GalleryGroupsConfigCollection^ get ();
}

Property Value

Type: GalleryGroupsConfigCollection
See Also

Reference

GalleryGroupConfigElement Class
VisualComponents.UX.Shared Namespace


GalleryGroupConfigElement.ItemId Property

GalleryGroupConfigElementItemId Property

Item ID

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ItemId { get; set; }
public:
property String^ ItemId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

GalleryGroupConfigElement Class
VisualComponents.UX.Shared Namespace


GalleryGroupConfigElement.TitleKey Property

GalleryGroupConfigElementTitleKey Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string TitleKey { get; set; }
public:
property String^ TitleKey {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

GalleryGroupConfigElement Class
VisualComponents.UX.Shared Namespace


GalleryGroupConfigElement Methods

The GalleryGroupConfigElement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

GalleryGroupConfigElement Class
VisualComponents.UX.Shared Namespace


GalleryGroupEntryConfigElement Class

blocked item config element
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.UX.SharedGalleryGroupEntryConfigElement

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class GalleryGroupEntryConfigElement : ConfigurationElement
public ref class GalleryGroupEntryConfigElement sealed : public ConfigurationElement

The GalleryGroupEntryConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | GalleryGroupEntryConfigElement | Initializes a new instance of the GalleryGroupEntryConfigElement class
Top
Properties
 | Name | Description
Public property | CaptionKey |
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | IconKey |
Public property | Id |
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | Priority |
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


GalleryGroupEntryConfigElement Constructor

Initializes a new instance of the GalleryGroupEntryConfigElement class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GalleryGroupEntryConfigElement()
public:
GalleryGroupEntryConfigElement()
See Also

Reference

GalleryGroupEntryConfigElement Class
VisualComponents.UX.Shared Namespace


GalleryGroupEntryConfigElement Properties

The GalleryGroupEntryConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CaptionKey |
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | IconKey |
Public property | Id |
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | Priority |
Top
See Also

Reference

GalleryGroupEntryConfigElement Class
VisualComponents.UX.Shared Namespace


GalleryGroupEntryConfigElement.CaptionKey Property

GalleryGroupEntryConfigElementCaptionKey Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CaptionKey { get; set; }
public:
property String^ CaptionKey {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

GalleryGroupEntryConfigElement Class
VisualComponents.UX.Shared Namespace


GalleryGroupEntryConfigElement.IconKey Property

GalleryGroupEntryConfigElementIconKey Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string IconKey { get; set; }
public:
property String^ IconKey {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

GalleryGroupEntryConfigElement Class
VisualComponents.UX.Shared Namespace


GalleryGroupEntryConfigElement.Id Property

GalleryGroupEntryConfigElementId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Id { get; set; }
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

GalleryGroupEntryConfigElement Class
VisualComponents.UX.Shared Namespace


GalleryGroupEntryConfigElement.Priority Property

GalleryGroupEntryConfigElementPriority Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Priority { get; set; }
public:
property int Priority {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

GalleryGroupEntryConfigElement Class
VisualComponents.UX.Shared Namespace


GalleryGroupEntryConfigElement Methods

The GalleryGroupEntryConfigElement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

GalleryGroupEntryConfigElement Class
VisualComponents.UX.Shared Namespace


GalleryGroupsConfigCollection Class

Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationElementCollection
VisualComponents.UX.SharedBaseConfigCollection GalleryGroupConfigElement
VisualComponents.UX.SharedGalleryGroupsConfigCollection

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class GalleryGroupsConfigCollection : BaseConfigCollection<GalleryGroupConfigElement>
public ref class GalleryGroupsConfigCollection sealed : public BaseConfigCollection<GalleryGroupConfigElement^>

The GalleryGroupsConfigCollection type exposes the following members.

Constructors
 | Name | Description
Public method | GalleryGroupsConfigCollection | Initializes a new instance of the GalleryGroupsConfigCollection class
Top
Properties
 | Name | Description
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Public property | ItemInt32 | (Inherited from BaseConfigCollectionT.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Top
Methods
 | Name | Description
Public method | Add | Add item to the collection (Inherited from BaseConfigCollectionT.)
Public method | Clear | clear the collection (Inherited from BaseConfigCollectionT.)
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | get the collection index of the element (Inherited from BaseConfigCollectionT.)
Public method | Insert | Inserts an item into the collection at the specified index. (Inherited from BaseConfigCollectionT.)
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Public method | Remove | remove the element from the collection (Inherited from BaseConfigCollectionT.)
Public method | RemoveAt | remove the element from the collection by the index (Inherited from BaseConfigCollectionT.)
Public method | ToList | Returns list of items (Inherited from BaseConfigCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


GalleryGroupsConfigCollection Constructor

Initializes a new instance of the GalleryGroupsConfigCollection class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GalleryGroupsConfigCollection()
public:
GalleryGroupsConfigCollection()
See Also

Reference

GalleryGroupsConfigCollection Class
VisualComponents.UX.Shared Namespace


GalleryGroupsConfigCollection Properties

The GalleryGroupsConfigCollection type exposes the following members.

Properties
 | Name | Description
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Public property | ItemInt32 | (Inherited from BaseConfigCollectionT.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Top
See Also

Reference

GalleryGroupsConfigCollection Class
VisualComponents.UX.Shared Namespace


GalleryGroupsConfigCollection Methods

The GalleryGroupsConfigCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add item to the collection (Inherited from BaseConfigCollectionT.)
Public method | Clear | clear the collection (Inherited from BaseConfigCollectionT.)
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | get the collection index of the element (Inherited from BaseConfigCollectionT.)
Public method | Insert | Inserts an item into the collection at the specified index. (Inherited from BaseConfigCollectionT.)
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Public method | Remove | remove the element from the collection (Inherited from BaseConfigCollectionT.)
Public method | RemoveAt | remove the element from the collection by the index (Inherited from BaseConfigCollectionT.)
Public method | ToList | Returns list of items (Inherited from BaseConfigCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

GalleryGroupsConfigCollection Class
VisualComponents.UX.Shared Namespace


GalleryGroupsEntryConfigCollection Class

Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationElementCollection
VisualComponents.UX.SharedBaseConfigCollection GalleryGroupEntryConfigElement
VisualComponents.UX.SharedGalleryGroupsEntryConfigCollection

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class GalleryGroupsEntryConfigCollection : BaseConfigCollection<GalleryGroupEntryConfigElement>
public ref class GalleryGroupsEntryConfigCollection sealed : public BaseConfigCollection<GalleryGroupEntryConfigElement^>

The GalleryGroupsEntryConfigCollection type exposes the following members.

Constructors
 | Name | Description
Public method | GalleryGroupsEntryConfigCollection | Initializes a new instance of the GalleryGroupsEntryConfigCollection class
Top
Properties
 | Name | Description
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Public property | ItemInt32 | (Inherited from BaseConfigCollectionT.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Top
Methods
 | Name | Description
Public method | Add | Add item to the collection (Inherited from BaseConfigCollectionT.)
Public method | Clear | clear the collection (Inherited from BaseConfigCollectionT.)
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | get the collection index of the element (Inherited from BaseConfigCollectionT.)
Public method | Insert | Inserts an item into the collection at the specified index. (Inherited from BaseConfigCollectionT.)
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Public method | Remove | remove the element from the collection (Inherited from BaseConfigCollectionT.)
Public method | RemoveAt | remove the element from the collection by the index (Inherited from BaseConfigCollectionT.)
Public method | ToList | Returns list of items (Inherited from BaseConfigCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


GalleryGroupsEntryConfigCollection Constructor

Initializes a new instance of the GalleryGroupsEntryConfigCollection class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GalleryGroupsEntryConfigCollection()
public:
GalleryGroupsEntryConfigCollection()
See Also

Reference

GalleryGroupsEntryConfigCollection Class
VisualComponents.UX.Shared Namespace


GalleryGroupsEntryConfigCollection Properties

The GalleryGroupsEntryConfigCollection type exposes the following members.

Properties
 | Name | Description
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Public property | ItemInt32 | (Inherited from BaseConfigCollectionT.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Top
See Also

Reference

GalleryGroupsEntryConfigCollection Class
VisualComponents.UX.Shared Namespace


GalleryGroupsEntryConfigCollection Methods

The GalleryGroupsEntryConfigCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add item to the collection (Inherited from BaseConfigCollectionT.)
Public method | Clear | clear the collection (Inherited from BaseConfigCollectionT.)
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | get the collection index of the element (Inherited from BaseConfigCollectionT.)
Public method | Insert | Inserts an item into the collection at the specified index. (Inherited from BaseConfigCollectionT.)
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Public method | Remove | remove the element from the collection (Inherited from BaseConfigCollectionT.)
Public method | RemoveAt | remove the element from the collection by the index (Inherited from BaseConfigCollectionT.)
Public method | ToList | Returns list of items (Inherited from BaseConfigCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

GalleryGroupsEntryConfigCollection Class
VisualComponents.UX.Shared Namespace


GalleryInfo Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedGalleryInfo

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class GalleryInfo
public ref class GalleryInfo

The GalleryInfo type exposes the following members.

Constructors
 | Name | Description
Public method | GalleryInfo | Initializes a new instance of the GalleryInfo class
Top
Properties
 | Name | Description
Public property | Groups |
Public property | Items |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


GalleryInfo Constructor

Initializes a new instance of the GalleryInfo class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GalleryInfo(
    UXSiteConfigElement site
)
public:
GalleryInfo(
    UXSiteConfigElement^ site
)

Parameters

site
Type: VisualComponents.UX.SharedUXSiteConfigElement
See Also

Reference

GalleryInfo Class
VisualComponents.UX.Shared Namespace


GalleryInfo Properties

The GalleryInfo type exposes the following members.

Properties
 | Name | Description
Public property | Groups |
Public property | Items |
Top
See Also

Reference

GalleryInfo Class
VisualComponents.UX.Shared Namespace


GalleryInfo.Groups Property

GalleryInfoGroups Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObservableCollection<GalleryGroup> Groups { get; }
public:
property ObservableCollection<GalleryGroup^>^ Groups {
    ObservableCollection<GalleryGroup^>^ get ();
}

Property Value

Type: ObservableCollectionGalleryGroup
See Also

Reference

GalleryInfo Class
VisualComponents.UX.Shared Namespace


GalleryInfo.Items Property

GalleryInfoItems Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObservableCollection<GalleryItemEx> Items { get; }
public:
property ObservableCollection<GalleryItemEx^>^ Items {
    ObservableCollection<GalleryItemEx^>^ get ();
}

Property Value

Type: ObservableCollectionGalleryItemEx
See Also

Reference

GalleryInfo Class
VisualComponents.UX.Shared Namespace


GalleryInfo Methods

The GalleryInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

GalleryInfo Class
VisualComponents.UX.Shared Namespace


GalleryItemEx Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.SharedGalleryItemEx

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class GalleryItemEx : PropertyChangedBase,
    IGalleryItem
public ref class GalleryItemEx : public PropertyChangedBase,
    IGalleryItem

The GalleryItemEx type exposes the following members.

Constructors
 | Name | Description
Public method | GalleryItemEx | Initializes a new instance of the GalleryItemEx class
Top
Properties
 | Name | Description
Public property | Command |
Public property | Image |
Public property | IsEnabled |
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | Key |
Public property | Tag |
Public property | Text |
Public property | ToolTipImage |
Public property | ToolTipText |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


GalleryItemEx Constructor

Initializes a new instance of the GalleryItemEx class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GalleryItemEx()
public:
GalleryItemEx()
See Also

Reference

GalleryItemEx Class
VisualComponents.UX.Shared Namespace


GalleryItemEx Properties

The GalleryItemEx type exposes the following members.

Properties
 | Name | Description
Public property | Command |
Public property | Image |
Public property | IsEnabled |
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | Key |
Public property | Tag |
Public property | Text |
Public property | ToolTipImage |
Public property | ToolTipText |
Top
See Also

Reference

GalleryItemEx Class
VisualComponents.UX.Shared Namespace


GalleryItemEx.Command Property

GalleryItemExCommand Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IActionItem Command { get; set; }
public:
virtual property IActionItem^ Command {
    IActionItem^ get () sealed;
    void set (IActionItem^ value) sealed;
}

Property Value

Type: IActionItem

Implements

IGalleryItemCommand
See Also

Reference

GalleryItemEx Class
VisualComponents.UX.Shared Namespace


GalleryItemEx.Image Property

GalleryItemExImage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BitmapImage Image { get; set; }
public:
property BitmapImage^ Image {
    BitmapImage^ get ();
    void set (BitmapImage^ value);
}

Property Value

Type: BitmapImage
See Also

Reference

GalleryItemEx Class
VisualComponents.UX.Shared Namespace


GalleryItemEx.IsEnabled Property

GalleryItemExIsEnabled Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsEnabled { get; set; }
public:
virtual property bool IsEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IGalleryItemIsEnabled
See Also

Reference

GalleryItemEx Class
VisualComponents.UX.Shared Namespace


GalleryItemEx.Key Property

GalleryItemExKey Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Key { get; set; }
public:
virtual property String^ Key {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IGalleryItemKey
See Also

Reference

GalleryItemEx Class
VisualComponents.UX.Shared Namespace


GalleryItemEx.Tag Property

GalleryItemExTag Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Tag { get; set; }
public:
virtual property String^ Tag {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IGalleryItemTag
See Also

Reference

GalleryItemEx Class
VisualComponents.UX.Shared Namespace


GalleryItemEx.Text Property

GalleryItemExText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Text { get; set; }
public:
virtual property String^ Text {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IGalleryItemText
See Also

Reference

GalleryItemEx Class
VisualComponents.UX.Shared Namespace


GalleryItemEx.ToolTipImage Property

GalleryItemExToolTipImage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ToolTipImage { get; set; }
public:
virtual property String^ ToolTipImage {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IGalleryItemToolTipImage
See Also

Reference

GalleryItemEx Class
VisualComponents.UX.Shared Namespace


GalleryItemEx.ToolTipText Property

GalleryItemExToolTipText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ToolTipText { get; set; }
public:
virtual property String^ ToolTipText {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IGalleryItemToolTipText
See Also

Reference

GalleryItemEx Class
VisualComponents.UX.Shared Namespace


GalleryItemEx Methods

The GalleryItemEx type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

GalleryItemEx Class
VisualComponents.UX.Shared Namespace


GalleryItemEx Events

The GalleryItemEx type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
See Also

Reference

GalleryItemEx Class
VisualComponents.UX.Shared Namespace


GalleryItemSetup Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedGalleryItemSetup

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class GalleryItemSetup
public ref class GalleryItemSetup

The GalleryItemSetup type exposes the following members.

Constructors
 | Name | Description
Public method | GalleryItemSetup | Initializes a new instance of the GalleryItemSetup class
Top
Properties
 | Name | Description
Public property | Image |
Public property | Key |
Public property | Priority |
Public property | Tag |
Public property | Text |
Public property | Tooltip |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


GalleryItemSetup Constructor

Initializes a new instance of the GalleryItemSetup class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GalleryItemSetup()
public:
GalleryItemSetup()
See Also

Reference

GalleryItemSetup Class
VisualComponents.UX.Shared Namespace


GalleryItemSetup Properties

The GalleryItemSetup type exposes the following members.

Properties
 | Name | Description
Public property | Image |
Public property | Key |
Public property | Priority |
Public property | Tag |
Public property | Text |
Public property | Tooltip |
Top
See Also

Reference

GalleryItemSetup Class
VisualComponents.UX.Shared Namespace


GalleryItemSetup.Image Property

GalleryItemSetupImage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BitmapImage Image { get; set; }
public:
property BitmapImage^ Image {
    BitmapImage^ get ();
    void set (BitmapImage^ value);
}

Property Value

Type: BitmapImage
See Also

Reference

GalleryItemSetup Class
VisualComponents.UX.Shared Namespace


GalleryItemSetup.Key Property

GalleryItemSetupKey Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Key { get; set; }
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

GalleryItemSetup Class
VisualComponents.UX.Shared Namespace


GalleryItemSetup.Priority Property

GalleryItemSetupPriority Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Priority { get; set; }
public:
property int Priority {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

GalleryItemSetup Class
VisualComponents.UX.Shared Namespace


GalleryItemSetup.Tag Property

GalleryItemSetupTag Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Tag { get; set; }
public:
property String^ Tag {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

GalleryItemSetup Class
VisualComponents.UX.Shared Namespace


GalleryItemSetup.Text Property

GalleryItemSetupText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Text { get; set; }
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

GalleryItemSetup Class
VisualComponents.UX.Shared Namespace


GalleryItemSetup.Tooltip Property

GalleryItemSetupTooltip Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Tooltip { get; set; }
public:
property String^ Tooltip {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

GalleryItemSetup Class
VisualComponents.UX.Shared Namespace


GalleryItemSetup Methods

The GalleryItemSetup type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

GalleryItemSetup Class
VisualComponents.UX.Shared Namespace


GalleryItemWrapper Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
DependencyObjectNotifier
GalleryItem
VisualComponents.UX.SharedGalleryItemWrapper

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class GalleryItemWrapper : GalleryItem,
    IGalleryItem
public ref class GalleryItemWrapper : public GalleryItem,
    IGalleryItem

The GalleryItemWrapper type exposes the following members.

Constructors
 | Name | Description
Public method | GalleryItemWrapper | Initializes a new instance of the GalleryItemWrapper class
Top
Properties
 | Name | Description
Public property | ColumnSpan | (Inherited from GalleryItem.)
Public property | Command |
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Image | (Inherited from GalleryItem.)
Public property | IsEnabled |
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelected | (Inherited from GalleryItem.)
Public property | Key | (Inherited from GalleryItem.)
Public property | Settings | (Inherited from GalleryItem.)
Public property | Tag |
Public property | Text | (Inherited from GalleryItem.)
Public property | ToolTipImage |
Public property | ToolTipText |
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged(String) | (Inherited from DependencyObjectNotifier.)
Protected method | OnPropertyChanged(DependencyPropertyChangedEventArgs) | (Overrides GalleryItem.OnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | RaisePropertyChangedEvent(String) | (Inherited from DependencyObjectNotifier.)
Protected method | RaisePropertyChangedEvent(String, Object, PropertyChangedEventArgs) | Obsolete. (Inherited from DependencyObjectNotifier.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetBinding |
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetKeyBinding |
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
 | Wrap |
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from DependencyObjectNotifier.)
Top
Fields
Name | Description
CommandProperty |
IsEnabledProperty |
ToolTipImageProperty |
ToolTipTextProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


GalleryItemWrapper Constructor

Initializes a new instance of the GalleryItemWrapper class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GalleryItemWrapper()
public:
GalleryItemWrapper()
See Also

Reference

GalleryItemWrapper Class
VisualComponents.UX.Shared Namespace


GalleryItemWrapper Properties

The GalleryItemWrapper type exposes the following members.

Properties
 | Name | Description
Public property | ColumnSpan | (Inherited from GalleryItem.)
Public property | Command |
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Image | (Inherited from GalleryItem.)
Public property | IsEnabled |
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelected | (Inherited from GalleryItem.)
Public property | Key | (Inherited from GalleryItem.)
Public property | Settings | (Inherited from GalleryItem.)
Public property | Tag |
Public property | Text | (Inherited from GalleryItem.)
Public property | ToolTipImage |
Public property | ToolTipText |
Top
See Also

Reference

GalleryItemWrapper Class
VisualComponents.UX.Shared Namespace


GalleryItemWrapper.Command Property

GalleryItemWrapperCommand Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IActionItem Command { get; set; }
public:
virtual property IActionItem^ Command {
    IActionItem^ get () sealed;
    void set (IActionItem^ value) sealed;
}

Property Value

Type: IActionItem

Implements

IGalleryItemCommand
See Also

Reference

GalleryItemWrapper Class
VisualComponents.UX.Shared Namespace


GalleryItemWrapper.IsEnabled Property

GalleryItemWrapperIsEnabled Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsEnabled { get; set; }
public:
virtual property bool IsEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IGalleryItemIsEnabled
See Also

Reference

GalleryItemWrapper Class
VisualComponents.UX.Shared Namespace


GalleryItemWrapper.Tag Property

GalleryItemWrapperTag Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Tag { get; set; }
public:
virtual property String^ Tag {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IGalleryItemTag
See Also

Reference

GalleryItemWrapper Class
VisualComponents.UX.Shared Namespace


GalleryItemWrapper.ToolTipImage Property

GalleryItemWrapperToolTipImage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ToolTipImage { get; set; }
public:
virtual property String^ ToolTipImage {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IGalleryItemToolTipImage
See Also

Reference

GalleryItemWrapper Class
VisualComponents.UX.Shared Namespace


GalleryItemWrapper.ToolTipText Property

GalleryItemWrapperToolTipText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ToolTipText { get; set; }
public:
virtual property String^ ToolTipText {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IGalleryItemToolTipText
See Also

Reference

GalleryItemWrapper Class
VisualComponents.UX.Shared Namespace


GalleryItemWrapper Methods

The GalleryItemWrapper type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged(String) | (Inherited from DependencyObjectNotifier.)
Protected method | OnPropertyChanged(DependencyPropertyChangedEventArgs) | (Overrides GalleryItem.OnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | RaisePropertyChangedEvent(String) | (Inherited from DependencyObjectNotifier.)
Protected method | RaisePropertyChangedEvent(String, Object, PropertyChangedEventArgs) | Obsolete. (Inherited from DependencyObjectNotifier.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetBinding |
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetKeyBinding |
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
 | Wrap |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

GalleryItemWrapper Class
VisualComponents.UX.Shared Namespace


GalleryItemWrapper.OnPropertyChanged Method

GalleryItemWrapperOnPropertyChanged Method

Overload List
 | Name | Description
Protected method | OnPropertyChanged(String) | (Inherited from DependencyObjectNotifier.)
Protected method | OnPropertyChanged(DependencyPropertyChangedEventArgs) | (Overrides GalleryItem.OnPropertyChanged(DependencyPropertyChangedEventArgs).)
Top
See Also

Reference

GalleryItemWrapper Class
VisualComponents.UX.Shared Namespace


GalleryItemWrapper.OnPropertyChanged Method (DependencyPropertyChangedEventArgs)

GalleryItemWrapperOnPropertyChanged Method (DependencyPropertyChangedEventArgs)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
)
protected:
virtual void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
) override

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
See Also

Reference

GalleryItemWrapper Class
OnPropertyChanged Overload
VisualComponents.UX.Shared Namespace


GalleryItemWrapper.SetBinding Method

GalleryItemWrapperSetBinding Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetBinding(
    DependencyProperty property,
    BindingBase binding
)
public:
void SetBinding(
    DependencyProperty^ property,
    BindingBase^ binding
)

Parameters

property
Type: System.WindowsDependencyProperty
binding
Type: System.Windows.DataBindingBase
See Also

Reference

GalleryItemWrapper Class
VisualComponents.UX.Shared Namespace


GalleryItemWrapper.SetKeyBinding Method

GalleryItemWrapperSetKeyBinding Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetKeyBinding(
    BindingBase binding
)
public:
void SetKeyBinding(
    BindingBase^ binding
)

Parameters

binding
Type: System.Windows.DataBindingBase
See Also

Reference

GalleryItemWrapper Class
VisualComponents.UX.Shared Namespace


GalleryItemWrapper.Wrap Method

GalleryItemWrapperWrap Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static GalleryItemWrapper Wrap(
    GalleryItemEx item
)
public:
static GalleryItemWrapper^ Wrap(
    GalleryItemEx^ item
)

Parameters

item
Type: VisualComponents.UX.SharedGalleryItemEx

Return Value

Type: GalleryItemWrapper

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.GalleryItemWrapper.Wrap(VisualComponents.UX.Shared.GalleryItemEx)"]

See Also

Reference

GalleryItemWrapper Class
VisualComponents.UX.Shared Namespace


GalleryItemWrapper Events

The GalleryItemWrapper type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from DependencyObjectNotifier.)
Top
See Also

Reference

GalleryItemWrapper Class
VisualComponents.UX.Shared Namespace


GalleryItemWrapper Fields

The GalleryItemWrapper type exposes the following members.

Fields
Name | Description
CommandProperty |
IsEnabledProperty |
ToolTipImageProperty |
ToolTipTextProperty |
Top
See Also

Reference

GalleryItemWrapper Class
VisualComponents.UX.Shared Namespace


GalleryItemWrapper.CommandProperty Field

GalleryItemWrapperCommandProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty CommandProperty
public:
static initonly DependencyProperty^ CommandProperty

Field Value

Type: DependencyProperty
See Also

Reference

GalleryItemWrapper Class
VisualComponents.UX.Shared Namespace


GalleryItemWrapper.IsEnabledProperty Field

GalleryItemWrapperIsEnabledProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsEnabledProperty
public:
static initonly DependencyProperty^ IsEnabledProperty

Field Value

Type: DependencyProperty
See Also

Reference

GalleryItemWrapper Class
VisualComponents.UX.Shared Namespace


GalleryItemWrapper.ToolTipImageProperty Field

GalleryItemWrapperToolTipImageProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ToolTipImageProperty
public:
static initonly DependencyProperty^ ToolTipImageProperty

Field Value

Type: DependencyProperty
See Also

Reference

GalleryItemWrapper Class
VisualComponents.UX.Shared Namespace


GalleryItemWrapper.ToolTipTextProperty Field

GalleryItemWrapperToolTipTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ToolTipTextProperty
public:
static initonly DependencyProperty^ ToolTipTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

GalleryItemWrapper Class
VisualComponents.UX.Shared Namespace


GalleryTool Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedGalleryTool

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class GalleryTool
public ref class GalleryTool

The GalleryTool type exposes the following members.

Constructors
 | Name | Description
Public method | GalleryTool | Initializes a new instance of the GalleryTool class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetGroups |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetItems |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetGroups |
 | SetItems |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
GroupsProperty |
ItemsProperty |
Top
Attached Properties
 | Name | Description
Public attached property | Groups |
Public attached property | Items |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


GalleryTool Constructor

Initializes a new instance of the GalleryTool class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GalleryTool()
public:
GalleryTool()
See Also

Reference

GalleryTool Class
VisualComponents.UX.Shared Namespace


GalleryTool Methods

The GalleryTool type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetGroups |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetItems |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetGroups |
 | SetItems |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

GalleryTool Class
VisualComponents.UX.Shared Namespace


GalleryTool.GetGroups Method

GalleryToolGetGroups Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ObservableCollection<GalleryGroup> GetGroups(
    DependencyObject obj
)
public:
static ObservableCollection<GalleryGroup^>^ GetGroups(
    DependencyObject^ obj
)

Parameters

obj
Type: System.WindowsDependencyObject

Return Value

Type: ObservableCollectionGalleryGroup

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.GalleryTool.GetGroups(System.Windows.DependencyObject)"]

See Also

Reference

GalleryTool Class
VisualComponents.UX.Shared Namespace


GalleryTool.GetItems Method

GalleryToolGetItems Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ObservableCollection<GalleryItemEx> GetItems(
    DependencyObject obj
)
public:
static ObservableCollection<GalleryItemEx^>^ GetItems(
    DependencyObject^ obj
)

Parameters

obj
Type: System.WindowsDependencyObject

Return Value

Type: ObservableCollectionGalleryItemEx

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.GalleryTool.GetItems(System.Windows.DependencyObject)"]

See Also

Reference

GalleryTool Class
VisualComponents.UX.Shared Namespace


GalleryTool.SetGroups Method

GalleryToolSetGroups Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetGroups(
    DependencyObject obj,
    int value
)
public:
static void SetGroups(
    DependencyObject^ obj,
    int value
)

Parameters

obj
Type: System.WindowsDependencyObject
value
Type: SystemInt32
See Also

Reference

GalleryTool Class
VisualComponents.UX.Shared Namespace


GalleryTool.SetItems Method

GalleryToolSetItems Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetItems(
    DependencyObject obj,
    ObservableCollection<GalleryItemEx> value
)
public:
static void SetItems(
    DependencyObject^ obj,
    ObservableCollection<GalleryItemEx^>^ value
)

Parameters

obj
Type: System.WindowsDependencyObject
value
Type: System.Collections.ObjectModelObservableCollectionGalleryItemEx
See Also

Reference

GalleryTool Class
VisualComponents.UX.Shared Namespace


GalleryTool Fields

The GalleryTool type exposes the following members.

Fields
Name | Description
GroupsProperty |
ItemsProperty |
Top
See Also

Reference

GalleryTool Class
VisualComponents.UX.Shared Namespace


GalleryTool.GroupsProperty Field

GalleryToolGroupsProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty GroupsProperty
public:
static initonly DependencyProperty^ GroupsProperty

Field Value

Type: DependencyProperty
See Also

Reference

GalleryTool Class
VisualComponents.UX.Shared Namespace


GalleryTool.ItemsProperty Field

GalleryToolItemsProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ItemsProperty
public:
static initonly DependencyProperty^ ItemsProperty

Field Value

Type: DependencyProperty
See Also

Reference

GalleryTool Class
VisualComponents.UX.Shared Namespace


GalleryTool Attached Properties

The GalleryTool type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | Groups |
Public attached property | Items |
Top
See Also

Reference

GalleryTool Class
VisualComponents.UX.Shared Namespace


GalleryTool.Groups Attached Property

GalleryToolGroups Attached Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See GetGroups, SetGroups
See GetGroups, SetGroups

Property Value

Type: ObservableCollectionGalleryGroup
See Also

Reference

GalleryTool Class
VisualComponents.UX.Shared Namespace


GalleryTool.Items Attached Property

GalleryToolItems Attached Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See GetItems, SetItems
See GetItems, SetItems

Property Value

Type: ObservableCollectionGalleryItemEx
See Also

Reference

GalleryTool Class
VisualComponents.UX.Shared Namespace


GeoFeatureBaseOperationUtility Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedGeoFeatureBaseOperationUtility

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class GeoFeatureBaseOperationUtility
public ref class GeoFeatureBaseOperationUtility abstract sealed

The GeoFeatureBaseOperationUtility type exposes the following members.

Methods
Name | Description
FindFaces |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


GeoFeatureBaseOperationUtility Methods

The GeoFeatureBaseOperationUtility type exposes the following members.

Methods
Name | Description
FindFaces |
Top
See Also

Reference

GeoFeatureBaseOperationUtility Class
VisualComponents.UX.Shared Namespace


GeoFeatureBaseOperationUtility.FindFaces Method

GeoFeatureBaseOperationUtilityFindFaces Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Tuple<ISimComponent, IEnumerable<IFace>> FindFaces(
    int x,
    int y,
    FeatureOperationLevel level,
    string commandId,
    IApplication app,
    IApplicationStatusService applicationStatusService
)
public:
static Tuple<ISimComponent^, IEnumerable<IFace^>^>^ FindFaces(
    int x,
    int y,
    FeatureOperationLevel level,
    String^ commandId,
    IApplication^ app,
    IApplicationStatusService^ applicationStatusService
)

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
level
Type: VisualComponents.Create3DFeatureOperationLevel
commandId
Type: SystemString
app
Type: VisualComponents.Create3DIApplication
applicationStatusService
Type: VisualComponents.UX.SharedIApplicationStatusService

Return Value

Type: TupleISimComponent, IEnumerableIFace

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.GeoFeatureBaseOperationUtility.FindFaces(System.Int32,System.Int32,VisualComponents.Create3D.FeatureOperationLevel,System.String,VisualComponents.Create3D.IApplication,VisualComponents.UX.Shared.IApplicationStatusService)"]

See Also

Reference

GeoFeatureBaseOperationUtility Class
VisualComponents.UX.Shared Namespace


GeometryContainer Class

Creates a custom shape with provided geometry.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ShapesShape
VisualComponents.UX.SharedGeometryContainer

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ContentPropertyAttribute("Geometry")]
public class GeometryContainer : Shape
[ContentPropertyAttribute(L"Geometry")]
public ref class GeometryContainer : public Shape

The GeometryContainer type exposes the following members.

Constructors
 | Name | Description
Public method | GeometryContainer | Initializes a new instance of the GeometryContainer class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Protected property | DefiningGeometry | (Overrides ShapeDefiningGeometry.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | Fill | Gets or sets the Brush that specifies how the shape's interior is painted. (Inherited from Shape.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Geometry |
Public property | GeometryTransform | Gets a value that represents a Transform that is applied to the geometry of a Shape prior to when it is drawn. (Inherited from Shape.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderedGeometry | (Overrides ShapeRenderedGeometry.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Stretch | Gets or sets a Stretch enumeration value that describes how the shape fills its allocated space. (Inherited from Shape.)
Public property | Stroke | Gets or sets the Brush that specifies how the Shape outline is painted. (Inherited from Shape.)
Public property | StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline shapes. (Inherited from Shape.)
Public property | StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from Shape.)
Public property | StrokeDashGeometryAlternation |
Public property | StrokeDashOffset | Gets or sets a Double that specifies the distance within the dash pattern where a dash begins. (Inherited from Shape.)
Public property | StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from Shape.)
Public property | StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from Shape.)
Public property | StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from Shape.)
Public property | StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the start of a Stroke. (Inherited from Shape.)
Public property | StrokeThickness | Gets or sets the width of the Shape outline. (Inherited from Shape.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | (Overrides ShapeArrangeOverride(Size).)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | (Overrides ShapeMeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | (Overrides FrameworkElementOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | (Overrides ShapeOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
GeometryProperty |
StrokeDashGeometryAlternationProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


GeometryContainer Constructor

Initializes a new instance of the GeometryContainer class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GeometryContainer()
public:
GeometryContainer()
See Also

Reference

GeometryContainer Class
VisualComponents.UX.Shared Namespace


GeometryContainer Properties

The GeometryContainer type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Protected property | DefiningGeometry | (Overrides ShapeDefiningGeometry.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | Fill | Gets or sets the Brush that specifies how the shape's interior is painted. (Inherited from Shape.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Geometry |
Public property | GeometryTransform | Gets a value that represents a Transform that is applied to the geometry of a Shape prior to when it is drawn. (Inherited from Shape.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderedGeometry | (Overrides ShapeRenderedGeometry.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Stretch | Gets or sets a Stretch enumeration value that describes how the shape fills its allocated space. (Inherited from Shape.)
Public property | Stroke | Gets or sets the Brush that specifies how the Shape outline is painted. (Inherited from Shape.)
Public property | StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline shapes. (Inherited from Shape.)
Public property | StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from Shape.)
Public property | StrokeDashGeometryAlternation |
Public property | StrokeDashOffset | Gets or sets a Double that specifies the distance within the dash pattern where a dash begins. (Inherited from Shape.)
Public property | StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from Shape.)
Public property | StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from Shape.)
Public property | StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from Shape.)
Public property | StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the start of a Stroke. (Inherited from Shape.)
Public property | StrokeThickness | Gets or sets the width of the Shape outline. (Inherited from Shape.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

GeometryContainer Class
VisualComponents.UX.Shared Namespace


GeometryContainer.DefiningGeometry Property

GeometryContainerDefiningGeometry Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Geometry DefiningGeometry { get; }
protected:
virtual property Geometry^ DefiningGeometry {
    Geometry^ get () override;
}

Property Value

Type: Geometry
See Also

Reference

GeometryContainer Class
VisualComponents.UX.Shared Namespace


GeometryContainer.Geometry Property

GeometryContainerGeometry Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Geometry Geometry { get; set; }
public:
property Geometry^ Geometry {
    Geometry^ get ();
    void set (Geometry^ value);
}

Property Value

Type: Geometry
See Also

Reference

GeometryContainer Class
VisualComponents.UX.Shared Namespace


GeometryContainer.RenderedGeometry Property

GeometryContainerRenderedGeometry Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override Geometry RenderedGeometry { get; }
public:
virtual property Geometry^ RenderedGeometry {
    Geometry^ get () override;
}

Property Value

Type: Geometry
See Also

Reference

GeometryContainer Class
VisualComponents.UX.Shared Namespace


GeometryContainer.StrokeDashGeometryAlternation Property

GeometryContainerStrokeDashGeometryAlternation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Int32Collection StrokeDashGeometryAlternation { get; set; }
public:
property Int32Collection^ StrokeDashGeometryAlternation {
    Int32Collection^ get ();
    void set (Int32Collection^ value);
}

Property Value

Type: Int32Collection
See Also

Reference

GeometryContainer Class
VisualComponents.UX.Shared Namespace


GeometryContainer Methods

The GeometryContainer type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | (Overrides ShapeArrangeOverride(Size).)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | (Overrides ShapeMeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | (Overrides FrameworkElementOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | (Overrides ShapeOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

GeometryContainer Class
VisualComponents.UX.Shared Namespace


GeometryContainer.ArrangeOverride Method

GeometryContainerArrangeOverride Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
protected:
virtual Size ArrangeOverride(
    Size finalSize
) override

Parameters

finalSize
Type: System.WindowsSize

Return Value

Type: Size

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.GeometryContainer.ArrangeOverride(System.Windows.Size)"]

See Also

Reference

GeometryContainer Class
VisualComponents.UX.Shared Namespace


GeometryContainer.MeasureOverride Method

GeometryContainerMeasureOverride Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Size MeasureOverride(
    Size constraint
)
protected:
virtual Size MeasureOverride(
    Size constraint
) override

Parameters

constraint
Type: System.WindowsSize

Return Value

Type: Size

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.GeometryContainer.MeasureOverride(System.Windows.Size)"]

See Also

Reference

GeometryContainer Class
VisualComponents.UX.Shared Namespace


GeometryContainer.OnPropertyChanged Method

GeometryContainerOnPropertyChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
)
protected:
virtual void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
) override

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
See Also

Reference

GeometryContainer Class
VisualComponents.UX.Shared Namespace


GeometryContainer.OnRender Method

GeometryContainerOnRender Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
protected:
virtual void OnRender(
    DrawingContext^ drawingContext
) override

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
See Also

Reference

GeometryContainer Class
VisualComponents.UX.Shared Namespace


GeometryContainer Events

The GeometryContainer type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

GeometryContainer Class
VisualComponents.UX.Shared Namespace


GeometryContainer Fields

The GeometryContainer type exposes the following members.

Fields
Name | Description
GeometryProperty |
StrokeDashGeometryAlternationProperty |
Top
See Also

Reference

GeometryContainer Class
VisualComponents.UX.Shared Namespace


GeometryContainer.GeometryProperty Field

GeometryContainerGeometryProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty GeometryProperty
public:
static initonly DependencyProperty^ GeometryProperty

Field Value

Type: DependencyProperty
See Also

Reference

GeometryContainer Class
VisualComponents.UX.Shared Namespace


GeometryContainer.StrokeDashGeometryAlternationProperty Field

GeometryContainerStrokeDashGeometryAlternationProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty StrokeDashGeometryAlternationProperty
public:
static initonly DependencyProperty^ StrokeDashGeometryAlternationProperty

Field Value

Type: DependencyProperty
See Also

Reference

GeometryContainer Class
VisualComponents.UX.Shared Namespace


GeometryFeatureBrepView Class

Interaction logic for GeometryFeatureBrepView.xaml
GeometryFeatureBrepView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedGeometryFeatureBrepView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class GeometryFeatureBrepView : UserControl,
    IComponentConnector
public ref class GeometryFeatureBrepView : public UserControl,
    IComponentConnector

The GeometryFeatureBrepView type exposes the following members.

Constructors
 | Name | Description
Public method | GeometryFeatureBrepView | Initializes a new instance of the GeometryFeatureBrepView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


GeometryFeatureBrepView Constructor

Initializes a new instance of the GeometryFeatureBrepView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public GeometryFeatureBrepView()
public:
GeometryFeatureBrepView()
See Also

Reference

GeometryFeatureBrepView Class
VisualComponents.UX.Shared Namespace


GeometryFeatureBrepView Properties

The GeometryFeatureBrepView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

GeometryFeatureBrepView Class
VisualComponents.UX.Shared Namespace


GeometryFeatureBrepView Methods

The GeometryFeatureBrepView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

GeometryFeatureBrepView Class
VisualComponents.UX.Shared Namespace


GeometryFeatureBrepView.InitializeComponent Method

GeometryFeatureBrepViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

GeometryFeatureBrepView Class
VisualComponents.UX.Shared Namespace


GeometryFeatureBrepView Events

The GeometryFeatureBrepView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

GeometryFeatureBrepView Class
VisualComponents.UX.Shared Namespace


HeaderedToolTip Class

Headered content control that is being styled as a ToolTip. Used visual states for transitions.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsHeaderedContentControl
VisualComponents.UX.SharedHeaderedToolTip

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class HeaderedToolTip : HeaderedContentControl
public ref class HeaderedToolTip : public HeaderedContentControl

The HeaderedToolTip type exposes the following members.

Constructors
 | Name | Description
Public method | HeaderedToolTip | Initializes a new instance of the HeaderedToolTip class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
 | CloseCommand |
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Footer | Gets or sets the data used for the Footer of each control.
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | HasHeader | Gets a value that indicates whether the header is . (Inherited from HeaderedContentControl.)
Public property | Header | Gets or sets the data used for the header of each control. (Inherited from HeaderedContentControl.)
Public property | HeaderStringFormat | Gets or sets a composite string that specifies how to format the Header property if it is displayed as a string. (Inherited from HeaderedContentControl.)
Public property | HeaderTemplate | Gets or sets the template used to display the content of the control's header. (Inherited from HeaderedContentControl.)
Public property | HeaderTemplateSelector | Gets or sets a data template selector that provides custom logic for choosing the template used to display the header. (Inherited from HeaderedContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | ImageSource | Gets or sets the data used for the Footer of each control.
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the logical child elements of the ControlTemplate. (Inherited from HeaderedContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | TemplateType | Gets or sets the template type.
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | Triggers visual state once the control template was applied (switching state too early doesn't trigger anything, since the state management is in the control templates). (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnHeaderChanged | Called when the Header property of a HeaderedContentControl changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderStringFormatChanged | Called when the HeaderStringFormat property changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderTemplateChanged | Called when the HeaderTemplate property changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderTemplateSelectorChanged | Called when the HeaderTemplateSelector property changes. (Inherited from HeaderedContentControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Provides a string representation of a HeaderedContentControl. (Inherited from HeaderedContentControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
FooterProperty | Identifies HeaderedToolTip.Footer dependency property.
ImageSourceProperty | Identifies HeaderedToolTip.Footer dependency property.
TemplateTypeProperty | Identifies HeaderedToolTip.TemplateType dependency property.
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


HeaderedToolTip Constructor

Initializes a new instance of the HeaderedToolTip class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public HeaderedToolTip()
public:
HeaderedToolTip()
See Also

Reference

HeaderedToolTip Class
VisualComponents.UX.Shared Namespace


HeaderedToolTip Properties

The HeaderedToolTip type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
 | CloseCommand |
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | Footer | Gets or sets the data used for the Footer of each control.
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | HasHeader | Gets a value that indicates whether the header is . (Inherited from HeaderedContentControl.)
Public property | Header | Gets or sets the data used for the header of each control. (Inherited from HeaderedContentControl.)
Public property | HeaderStringFormat | Gets or sets a composite string that specifies how to format the Header property if it is displayed as a string. (Inherited from HeaderedContentControl.)
Public property | HeaderTemplate | Gets or sets the template used to display the content of the control's header. (Inherited from HeaderedContentControl.)
Public property | HeaderTemplateSelector | Gets or sets a data template selector that provides custom logic for choosing the template used to display the header. (Inherited from HeaderedContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | ImageSource | Gets or sets the data used for the Footer of each control.
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the logical child elements of the ControlTemplate. (Inherited from HeaderedContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | TemplateType | Gets or sets the template type.
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

HeaderedToolTip Class
VisualComponents.UX.Shared Namespace


HeaderedToolTip.CloseCommand Property

HeaderedToolTipCloseCommand Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static RoutedCommand CloseCommand { get; }
public:
static property RoutedCommand^ CloseCommand {
    RoutedCommand^ get ();
}

Property Value

Type: RoutedCommand
See Also

Reference

HeaderedToolTip Class
VisualComponents.UX.Shared Namespace


HeaderedToolTip.Footer Property

HeaderedToolTipFooter Property

Gets or sets the data used for the Footer of each control.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Footer { get; set; }
public:
virtual property String^ Footer {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
See Also

Reference

HeaderedToolTip Class
VisualComponents.UX.Shared Namespace


HeaderedToolTip.ImageSource Property

HeaderedToolTipImageSource Property

Gets or sets the data used for the Footer of each control.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ImageSource { get; set; }
public:
property String^ ImageSource {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

HeaderedToolTip Class
VisualComponents.UX.Shared Namespace


HeaderedToolTip.TemplateType Property

HeaderedToolTipTemplateType Property

Gets or sets the template type.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ToolTipTemplate TemplateType { get; set; }
public:
property ToolTipTemplate TemplateType {
    ToolTipTemplate get ();
    void set (ToolTipTemplate value);
}

Property Value

Type: ToolTipTemplate
See Also

Reference

HeaderedToolTip Class
VisualComponents.UX.Shared Namespace


HeaderedToolTip Methods

The HeaderedToolTip type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | Triggers visual state once the control template was applied (switching state too early doesn't trigger anything, since the state management is in the control templates). (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnHeaderChanged | Called when the Header property of a HeaderedContentControl changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderStringFormatChanged | Called when the HeaderStringFormat property changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderTemplateChanged | Called when the HeaderTemplate property changes. (Inherited from HeaderedContentControl.)
Protected method | OnHeaderTemplateSelectorChanged | Called when the HeaderTemplateSelector property changes. (Inherited from HeaderedContentControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Provides a string representation of a HeaderedContentControl. (Inherited from HeaderedContentControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

HeaderedToolTip Class
VisualComponents.UX.Shared Namespace


HeaderedToolTip.OnApplyTemplate Method

HeaderedToolTipOnApplyTemplate Method

Triggers visual state once the control template was applied (switching state too early doesn't trigger anything, since the state management is in the control templates).

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

HeaderedToolTip Class
VisualComponents.UX.Shared Namespace


HeaderedToolTip Events

The HeaderedToolTip type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

HeaderedToolTip Class
VisualComponents.UX.Shared Namespace


HeaderedToolTip Fields

The HeaderedToolTip type exposes the following members.

Fields
Name | Description
FooterProperty | Identifies HeaderedToolTip.Footer dependency property.
ImageSourceProperty | Identifies HeaderedToolTip.Footer dependency property.
TemplateTypeProperty | Identifies HeaderedToolTip.TemplateType dependency property.
Top
See Also

Reference

HeaderedToolTip Class
VisualComponents.UX.Shared Namespace


HeaderedToolTip.FooterProperty Field

HeaderedToolTipFooterProperty Field

Identifies HeaderedToolTip.Footer dependency property.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty FooterProperty
public:
static initonly DependencyProperty^ FooterProperty

Field Value

Type: DependencyProperty
See Also

Reference

HeaderedToolTip Class
VisualComponents.UX.Shared Namespace


HeaderedToolTip.ImageSourceProperty Field

HeaderedToolTipImageSourceProperty Field

Identifies HeaderedToolTip.Footer dependency property.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ImageSourceProperty
public:
static initonly DependencyProperty^ ImageSourceProperty

Field Value

Type: DependencyProperty
See Also

Reference

HeaderedToolTip Class
VisualComponents.UX.Shared Namespace


HeaderedToolTip.TemplateTypeProperty Field

HeaderedToolTipTemplateTypeProperty Field

Identifies HeaderedToolTip.TemplateType dependency property.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty TemplateTypeProperty
public:
static initonly DependencyProperty^ TemplateTypeProperty

Field Value

Type: DependencyProperty
See Also

Reference

HeaderedToolTip Class
VisualComponents.UX.Shared Namespace


HeaderModel Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedHeaderModel

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class HeaderModel : IHeaderModel,
    IHeaderModel
public ref class HeaderModel : IHeaderModel,
    IHeaderModel

The HeaderModel type exposes the following members.

Constructors
 | Name | Description
Public method | HeaderModel(String, String) | Initializes a new instance of the HeaderModel class
Public method | HeaderModel(String, String, String) | Initializes a new instance of the HeaderModel class
Top
Properties
 | Name | Description
Public property | HeaderIconPath | Gets or sets the identifying icon of the element.
Public property | HeaderId | Returns or sets a value that uniquely identifies the element. It should be the same as the view model it references.
Public property | HeaderName | Gets or sets the identifying name of the element.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


HeaderModel Constructor

Overload List
 | Name | Description
Public method | HeaderModel(String, String) | Initializes a new instance of the HeaderModel class
Public method | HeaderModel(String, String, String) | Initializes a new instance of the HeaderModel class
Top
See Also

Reference

HeaderModel Class
VisualComponents.UX.Shared Namespace


HeaderModel Constructor (String, String)

Initializes a new instance of the HeaderModel class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public HeaderModel(
    string headerName,
    string headerIconName
)
public:
HeaderModel(
    String^ headerName,
    String^ headerIconName
)

Parameters

headerName
Type: SystemString
headerIconName
Type: SystemString
See Also

Reference

HeaderModel Class
HeaderModel Overload
VisualComponents.UX.Shared Namespace


HeaderModel Constructor (String, String, String)

Initializes a new instance of the HeaderModel class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public HeaderModel(
    string headerName,
    string headerIconName,
    string Id
)
public:
HeaderModel(
    String^ headerName,
    String^ headerIconName,
    String^ Id
)

Parameters

headerName
Type: SystemString
headerIconName
Type: SystemString
Id
Type: SystemString
See Also

Reference

HeaderModel Class
HeaderModel Overload
VisualComponents.UX.Shared Namespace


HeaderModel Properties

The HeaderModel type exposes the following members.

Properties
 | Name | Description
Public property | HeaderIconPath | Gets or sets the identifying icon of the element.
Public property | HeaderId | Returns or sets a value that uniquely identifies the element. It should be the same as the view model it references.
Public property | HeaderName | Gets or sets the identifying name of the element.
Top
See Also

Reference

HeaderModel Class
VisualComponents.UX.Shared Namespace


HeaderModel.HeaderIconPath Property

HeaderModelHeaderIconPath Property

Gets or sets the identifying icon of the element.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string HeaderIconPath { get; set; }
public:
virtual property String^ HeaderIconPath {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IHeaderModelHeaderIconPath
See Also

Reference

HeaderModel Class
VisualComponents.UX.Shared Namespace


HeaderModel.HeaderId Property

HeaderModelHeaderId Property

Returns or sets a value that uniquely identifies the element. It should be the same as the view model it references.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string HeaderId { get; set; }
public:
virtual property String^ HeaderId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IHeaderModelHeaderId
See Also

Reference

HeaderModel Class
VisualComponents.UX.Shared Namespace


HeaderModel.HeaderName Property

HeaderModelHeaderName Property

Gets or sets the identifying name of the element.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string HeaderName { get; set; }
public:
virtual property String^ HeaderName {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IHeaderModelHeaderName
See Also

Reference

HeaderModel Class
VisualComponents.UX.Shared Namespace


HeaderModel Methods

The HeaderModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

HeaderModel Class
VisualComponents.UX.Shared Namespace


HelpProvider Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedHelpProvider

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class HelpProvider
public ref class HelpProvider

The HelpProvider type exposes the following members.

Constructors
 | Name | Description
Protected method | HelpProvider | Initializes a new instance of the HelpProvider class
Top
Properties
Name | Description
Instance |
Top
Methods
 | Name | Description
Public method | CloseHelpFiles | Closes all open help files.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Executed |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetHelpBookmark |
 | GetHelpString |
 | GetHelpUrl |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenHelpFile(String) |
Public method | OpenHelpFile(Object, String) | Obsolete.
Public method | OpenWebPage |
 | SetHelpBookmark |
 | SetHelpString |
 | SetHelpUrl |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
_helpBookmarkProperty |
_helpStringProperty |
_helpUrlProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


HelpProvider Constructor

Initializes a new instance of the HelpProvider class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected HelpProvider()
protected:
HelpProvider()
See Also

Reference

HelpProvider Class
VisualComponents.UX.Shared Namespace


HelpProvider Properties

The HelpProvider type exposes the following members.

Properties
Name | Description
Instance |
Top
See Also

Reference

HelpProvider Class
VisualComponents.UX.Shared Namespace


HelpProvider.Instance Property

HelpProviderInstance Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static HelpProvider Instance { get; }
public:
static property HelpProvider^ Instance {
    HelpProvider^ get ();
}

Property Value

Type: HelpProvider
See Also

Reference

HelpProvider Class
VisualComponents.UX.Shared Namespace


HelpProvider Methods

The HelpProvider type exposes the following members.

Methods
 | Name | Description
Public method | CloseHelpFiles | Closes all open help files.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Executed |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetHelpBookmark |
 | GetHelpString |
 | GetHelpUrl |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenHelpFile(String) |
Public method | OpenHelpFile(Object, String) | Obsolete.
Public method | OpenWebPage |
 | SetHelpBookmark |
 | SetHelpString |
 | SetHelpUrl |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

HelpProvider Class
VisualComponents.UX.Shared Namespace


HelpProvider.CloseHelpFiles Method

HelpProviderCloseHelpFiles Method

Closes all open help files.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CloseHelpFiles()
public:
void CloseHelpFiles()
See Also

Reference

HelpProvider Class
VisualComponents.UX.Shared Namespace


HelpProvider.Executed Method

HelpProviderExecuted Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Executed(
    Object sender,
    ExecutedRoutedEventArgs e
)
public:
void Executed(
    Object^ sender,
    ExecutedRoutedEventArgs^ e
)

Parameters

sender
Type: SystemObject
e
Type: System.Windows.InputExecutedRoutedEventArgs
See Also

Reference

HelpProvider Class
VisualComponents.UX.Shared Namespace


HelpProvider.GetHelpBookmark Method

HelpProviderGetHelpBookmark Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetHelpBookmark(
    DependencyObject obj
)
public:
static String^ GetHelpBookmark(
    DependencyObject^ obj
)

Parameters

obj
Type: System.WindowsDependencyObject

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.HelpProvider.GetHelpBookmark(System.Windows.DependencyObject)"]

See Also

Reference

HelpProvider Class
VisualComponents.UX.Shared Namespace


HelpProvider.GetHelpString Method

HelpProviderGetHelpString Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetHelpString(
    DependencyObject obj
)
public:
static String^ GetHelpString(
    DependencyObject^ obj
)

Parameters

obj
Type: System.WindowsDependencyObject

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.HelpProvider.GetHelpString(System.Windows.DependencyObject)"]

See Also

Reference

HelpProvider Class
VisualComponents.UX.Shared Namespace


HelpProvider.GetHelpUrl Method

HelpProviderGetHelpUrl Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetHelpUrl(
    DependencyObject obj
)
public:
static String^ GetHelpUrl(
    DependencyObject^ obj
)

Parameters

obj
Type: System.WindowsDependencyObject

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.HelpProvider.GetHelpUrl(System.Windows.DependencyObject)"]

See Also

Reference

HelpProvider Class
VisualComponents.UX.Shared Namespace


HelpProvider.OpenHelpFile Method

HelpProviderOpenHelpFile Method

Overload List
 | Name | Description
Public method | OpenHelpFile(String) |
Public method | OpenHelpFile(Object, String) | Obsolete.
Top
See Also

Reference

HelpProvider Class
VisualComponents.UX.Shared Namespace


HelpProvider.OpenHelpFile Method (String)

HelpProviderOpenHelpFile Method (String)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void OpenHelpFile(
    string helpFile = null
)
public:
void OpenHelpFile(
    String^ helpFile = nullptr
)

Parameters

helpFile (Optional)
Type: SystemString
See Also

Reference

HelpProvider Class
OpenHelpFile Overload
VisualComponents.UX.Shared Namespace


HelpProvider.OpenHelpFile Method (Object, String)

HelpProviderOpenHelpFile Method (Object, String)

Note: This API is now obsolete.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Use OpenHelpFile(string helpFile) instead.")]
public void OpenHelpFile(
    Object sender,
    string helpFile = ""
)
public:
[ObsoleteAttribute(L"Use OpenHelpFile(string helpFile) instead.")]
void OpenHelpFile(
    Object^ sender,
    String^ helpFile = L""
)

Parameters

sender
Type: SystemObject
helpFile (Optional)
Type: SystemString
See Also

Reference

HelpProvider Class
OpenHelpFile Overload
VisualComponents.UX.Shared Namespace


HelpProvider.OpenWebPage Method

HelpProviderOpenWebPage Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void OpenWebPage(
    string link
)
public:
void OpenWebPage(
    String^ link
)

Parameters

link
Type: SystemString
See Also

Reference

HelpProvider Class
VisualComponents.UX.Shared Namespace


HelpProvider.SetHelpBookmark Method

HelpProviderSetHelpBookmark Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetHelpBookmark(
    DependencyObject obj,
    string value
)
public:
static void SetHelpBookmark(
    DependencyObject^ obj,
    String^ value
)

Parameters

obj
Type: System.WindowsDependencyObject
value
Type: SystemString
See Also

Reference

HelpProvider Class
VisualComponents.UX.Shared Namespace


HelpProvider.SetHelpString Method

HelpProviderSetHelpString Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetHelpString(
    DependencyObject obj,
    string value
)
public:
static void SetHelpString(
    DependencyObject^ obj,
    String^ value
)

Parameters

obj
Type: System.WindowsDependencyObject
value
Type: SystemString
See Also

Reference

HelpProvider Class
VisualComponents.UX.Shared Namespace


HelpProvider.SetHelpUrl Method

HelpProviderSetHelpUrl Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetHelpUrl(
    DependencyObject obj,
    string value
)
public:
static void SetHelpUrl(
    DependencyObject^ obj,
    String^ value
)

Parameters

obj
Type: System.WindowsDependencyObject
value
Type: SystemString
See Also

Reference

HelpProvider Class
VisualComponents.UX.Shared Namespace


HelpProvider Fields

The HelpProvider type exposes the following members.

Fields
Name | Description
_helpBookmarkProperty |
_helpStringProperty |
_helpUrlProperty |
Top
See Also

Reference

HelpProvider Class
VisualComponents.UX.Shared Namespace


HelpProvider._helpBookmarkProperty Field

HelpProvider_helpBookmarkProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty _helpBookmarkProperty
public:
static initonly DependencyProperty^ _helpBookmarkProperty

Field Value

Type: DependencyProperty
See Also

Reference

HelpProvider Class
VisualComponents.UX.Shared Namespace


HelpProvider._helpStringProperty Field

HelpProvider_helpStringProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty _helpStringProperty
public:
static initonly DependencyProperty^ _helpStringProperty

Field Value

Type: DependencyProperty
See Also

Reference

HelpProvider Class
VisualComponents.UX.Shared Namespace


HelpProvider._helpUrlProperty Field

HelpProvider_helpUrlProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty _helpUrlProperty
public:
static initonly DependencyProperty^ _helpUrlProperty

Field Value

Type: DependencyProperty
See Also

Reference

HelpProvider Class
VisualComponents.UX.Shared Namespace


HoverHighlightType Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum HoverHighlightType
public enum class HoverHighlightType
Members
Member name | Value | Description
Border | 0 |
Fill | 1 |
See Also

Reference

VisualComponents.UX.Shared Namespace


HtmlRichTextBoxBehavior Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
VisualComponents.UX.SharedHtmlRichTextBoxBehavior

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class HtmlRichTextBoxBehavior : DependencyObject
public ref class HtmlRichTextBoxBehavior : public DependencyObject

The HtmlRichTextBoxBehavior type exposes the following members.

Constructors
 | Name | Description
Public method | HtmlRichTextBoxBehavior | Initializes a new instance of the HtmlRichTextBoxBehavior class
Top
Properties
 | Name | Description
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
 | GetText |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from DependencyObject.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
 | SetText |
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Fields
Name | Description
TextProperty |
Top
Attached Properties
 | Name | Description
Public attached property | Text |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


HtmlRichTextBoxBehavior Constructor

Initializes a new instance of the HtmlRichTextBoxBehavior class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public HtmlRichTextBoxBehavior()
public:
HtmlRichTextBoxBehavior()
See Also

Reference

HtmlRichTextBoxBehavior Class
VisualComponents.UX.Shared Namespace


HtmlRichTextBoxBehavior Properties

The HtmlRichTextBoxBehavior type exposes the following members.

Properties
 | Name | Description
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Top
See Also

Reference

HtmlRichTextBoxBehavior Class
VisualComponents.UX.Shared Namespace


HtmlRichTextBoxBehavior Methods

The HtmlRichTextBoxBehavior type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
 | GetText |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from DependencyObject.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
 | SetText |
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

HtmlRichTextBoxBehavior Class
VisualComponents.UX.Shared Namespace


HtmlRichTextBoxBehavior.GetText Method

HtmlRichTextBoxBehaviorGetText Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetText(
    RichTextBox o
)
public:
static String^ GetText(
    RichTextBox^ o
)

Parameters

o
Type: System.Windows.ControlsRichTextBox

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.HtmlRichTextBoxBehavior.GetText(System.Windows.Controls.RichTextBox)"]

See Also

Reference

HtmlRichTextBoxBehavior Class
VisualComponents.UX.Shared Namespace


HtmlRichTextBoxBehavior.SetText Method

HtmlRichTextBoxBehaviorSetText Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetText(
    RichTextBox o,
    string value
)
public:
static void SetText(
    RichTextBox^ o,
    String^ value
)

Parameters

o
Type: System.Windows.ControlsRichTextBox
value
Type: SystemString
See Also

Reference

HtmlRichTextBoxBehavior Class
VisualComponents.UX.Shared Namespace


HtmlRichTextBoxBehavior Fields

The HtmlRichTextBoxBehavior type exposes the following members.

Fields
Name | Description
TextProperty |
Top
See Also

Reference

HtmlRichTextBoxBehavior Class
VisualComponents.UX.Shared Namespace


HtmlRichTextBoxBehavior.TextProperty Field

HtmlRichTextBoxBehaviorTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty TextProperty
public:
static initonly DependencyProperty^ TextProperty

Field Value

Type: DependencyProperty
See Also

Reference

HtmlRichTextBoxBehavior Class
VisualComponents.UX.Shared Namespace


HtmlRichTextBoxBehavior Attached Properties

The HtmlRichTextBoxBehavior type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | Text |
Top
See Also

Reference

HtmlRichTextBoxBehavior Class
VisualComponents.UX.Shared Namespace


HtmlRichTextBoxBehavior.Text Attached Property

HtmlRichTextBoxBehaviorText Attached Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See GetText, SetText
See GetText, SetText

Property Value

Type: String
See Also

Reference

HtmlRichTextBoxBehavior Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter Class

HtmlToXamlConverter is a static class that takes an HTML string and converts it into XAML
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedHtmlToXamlConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class HtmlToXamlConverter
public ref class HtmlToXamlConverter abstract sealed

The HtmlToXamlConverter type exposes the following members.

Methods
Name | Description
ConvertHtmlToXaml | Converts an html string into xaml string.
GetAttribute | Returns a value for an attribute by its name (ignoring casing)
Top
Fields
Name | Description
Xaml_Background |
Xaml_BorderBrush |
Xaml_BorderThickness |
Xaml_Brushes_Black |
Xaml_FlowDocument |
Xaml_FontFamily |
Xaml_FontSize |
Xaml_FontSize_Large |
Xaml_FontSize_Medium |
Xaml_FontSize_Small |
Xaml_FontSize_XLarge |
Xaml_FontSize_XSmall |
Xaml_FontSize_XXLarge |
Xaml_FontSize_XXSmall |
Xaml_FontStyle |
Xaml_FontWeight |
Xaml_FontWeight_Bold |
Xaml_Foreground |
Xaml_Hyperlink |
Xaml_Hyperlink_NavigateUri |
Xaml_Hyperlink_TargetName |
Xaml_LineBreak |
Xaml_List |
Xaml_List_MarkerStyle |
Xaml_List_MarkerStyle_Box |
Xaml_List_MarkerStyle_Circle |
Xaml_List_MarkerStyle_Decimal |
Xaml_List_MarkerStyle_Disc |
Xaml_List_MarkerStyle_LowerLatin |
Xaml_List_MarkerStyle_LowerRoman |
Xaml_List_MarkerStyle_None |
Xaml_List_MarkerStyle_Square |
Xaml_List_MarkerStyle_UpperLatin |
Xaml_List_MarkerStyle_UpperRoman |
Xaml_ListItem |
Xaml_Margin |
Xaml_Padding |
Xaml_Paragraph |
Xaml_Run |
Xaml_Section |
Xaml_Span |
Xaml_Table |
Xaml_TableCell |
Xaml_TableCell_BorderBrush |
Xaml_TableCell_BorderThickness |
Xaml_TableCell_ColumnSpan |
Xaml_TableCell_RowSpan |
Xaml_TableColumn |
Xaml_TableRow |
Xaml_TableRowGroup |
Xaml_TextAlignment |
Xaml_TextDecorations |
Xaml_TextDecorations_Underline |
Xaml_TextIndent |
Xaml_Width |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


HtmlToXamlConverter Methods

The HtmlToXamlConverter type exposes the following members.

Methods
Name | Description
ConvertHtmlToXaml | Converts an html string into xaml string.
GetAttribute | Returns a value for an attribute by its name (ignoring casing)
Top
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.ConvertHtmlToXaml Method

HtmlToXamlConverterConvertHtmlToXaml Method

Converts an html string into xaml string.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string ConvertHtmlToXaml(
    string htmlString,
    bool asFlowDocument
)
public:
static String^ ConvertHtmlToXaml(
    String^ htmlString,
    bool asFlowDocument
)

Parameters

htmlString
Type: SystemString
Input html which may be badly formated xml.
asFlowDocument
Type: SystemBoolean
true indicates that we need a FlowDocument as a root element; false means that Section or Span elements will be used dependeing on StartFragment/EndFragment comments locations.

Return Value

Type: String
Well-formed xml representing XAML equivalent for the input html string.
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.GetAttribute Method

HtmlToXamlConverterGetAttribute Method

Returns a value for an attribute by its name (ignoring casing)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetAttribute(
    XmlElement element,
    string attributeName
)
public:
static String^ GetAttribute(
    XmlElement^ element,
    String^ attributeName
)

Parameters

element
Type: System.XmlXmlElement
XmlElement in which we are trying to find the specified attribute
attributeName
Type: SystemString
String representing the attribute name to be searched for

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.HtmlToXamlConverter.GetAttribute(System.Xml.XmlElement,System.String)"]

See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter Fields

The HtmlToXamlConverter type exposes the following members.

Fields
Name | Description
Xaml_Background |
Xaml_BorderBrush |
Xaml_BorderThickness |
Xaml_Brushes_Black |
Xaml_FlowDocument |
Xaml_FontFamily |
Xaml_FontSize |
Xaml_FontSize_Large |
Xaml_FontSize_Medium |
Xaml_FontSize_Small |
Xaml_FontSize_XLarge |
Xaml_FontSize_XSmall |
Xaml_FontSize_XXLarge |
Xaml_FontSize_XXSmall |
Xaml_FontStyle |
Xaml_FontWeight |
Xaml_FontWeight_Bold |
Xaml_Foreground |
Xaml_Hyperlink |
Xaml_Hyperlink_NavigateUri |
Xaml_Hyperlink_TargetName |
Xaml_LineBreak |
Xaml_List |
Xaml_List_MarkerStyle |
Xaml_List_MarkerStyle_Box |
Xaml_List_MarkerStyle_Circle |
Xaml_List_MarkerStyle_Decimal |
Xaml_List_MarkerStyle_Disc |
Xaml_List_MarkerStyle_LowerLatin |
Xaml_List_MarkerStyle_LowerRoman |
Xaml_List_MarkerStyle_None |
Xaml_List_MarkerStyle_Square |
Xaml_List_MarkerStyle_UpperLatin |
Xaml_List_MarkerStyle_UpperRoman |
Xaml_ListItem |
Xaml_Margin |
Xaml_Padding |
Xaml_Paragraph |
Xaml_Run |
Xaml_Section |
Xaml_Span |
Xaml_Table |
Xaml_TableCell |
Xaml_TableCell_BorderBrush |
Xaml_TableCell_BorderThickness |
Xaml_TableCell_ColumnSpan |
Xaml_TableCell_RowSpan |
Xaml_TableColumn |
Xaml_TableRow |
Xaml_TableRowGroup |
Xaml_TextAlignment |
Xaml_TextDecorations |
Xaml_TextDecorations_Underline |
Xaml_TextIndent |
Xaml_Width |
Top
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_Background Field

HtmlToXamlConverterXaml_Background Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_Background = "Background"
public:
literal String^ Xaml_Background = "Background"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_BorderBrush Field

HtmlToXamlConverterXaml_BorderBrush Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_BorderBrush = "BorderBrush"
public:
literal String^ Xaml_BorderBrush = "BorderBrush"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_BorderThickness Field

HtmlToXamlConverterXaml_BorderThickness Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_BorderThickness = "BorderThickness"
public:
literal String^ Xaml_BorderThickness = "BorderThickness"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_Brushes_Black Field

HtmlToXamlConverterXaml_Brushes_Black Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_Brushes_Black = "Black"
public:
literal String^ Xaml_Brushes_Black = "Black"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_FlowDocument Field

HtmlToXamlConverterXaml_FlowDocument Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_FlowDocument = "FlowDocument"
public:
literal String^ Xaml_FlowDocument = "FlowDocument"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_FontFamily Field

HtmlToXamlConverterXaml_FontFamily Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_FontFamily = "FontFamily"
public:
literal String^ Xaml_FontFamily = "FontFamily"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_FontSize Field

HtmlToXamlConverterXaml_FontSize Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_FontSize = "FontSize"
public:
literal String^ Xaml_FontSize = "FontSize"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_FontSize_Large Field

HtmlToXamlConverterXaml_FontSize_Large Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_FontSize_Large = "18pt"
public:
literal String^ Xaml_FontSize_Large = "18pt"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_FontSize_Medium Field

HtmlToXamlConverterXaml_FontSize_Medium Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_FontSize_Medium = "16pt"
public:
literal String^ Xaml_FontSize_Medium = "16pt"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_FontSize_Small Field

HtmlToXamlConverterXaml_FontSize_Small Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_FontSize_Small = "12pt"
public:
literal String^ Xaml_FontSize_Small = "12pt"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_FontSize_XLarge Field

HtmlToXamlConverterXaml_FontSize_XLarge Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_FontSize_XLarge = "20pt"
public:
literal String^ Xaml_FontSize_XLarge = "20pt"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_FontSize_XSmall Field

HtmlToXamlConverterXaml_FontSize_XSmall Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_FontSize_XSmall = "10pt"
public:
literal String^ Xaml_FontSize_XSmall = "10pt"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_FontSize_XXLarge Field

HtmlToXamlConverterXaml_FontSize_XXLarge Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_FontSize_XXLarge = "22pt"
public:
literal String^ Xaml_FontSize_XXLarge = "22pt"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_FontSize_XXSmall Field

HtmlToXamlConverterXaml_FontSize_XXSmall Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_FontSize_XXSmall = "8pt"
public:
literal String^ Xaml_FontSize_XXSmall = "8pt"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_FontStyle Field

HtmlToXamlConverterXaml_FontStyle Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_FontStyle = "FontStyle"
public:
literal String^ Xaml_FontStyle = "FontStyle"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_FontWeight Field

HtmlToXamlConverterXaml_FontWeight Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_FontWeight = "FontWeight"
public:
literal String^ Xaml_FontWeight = "FontWeight"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_FontWeight_Bold Field

HtmlToXamlConverterXaml_FontWeight_Bold Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_FontWeight_Bold = "Bold"
public:
literal String^ Xaml_FontWeight_Bold = "Bold"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_Foreground Field

HtmlToXamlConverterXaml_Foreground Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_Foreground = "Foreground"
public:
literal String^ Xaml_Foreground = "Foreground"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_Hyperlink Field

HtmlToXamlConverterXaml_Hyperlink Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_Hyperlink = "Hyperlink"
public:
literal String^ Xaml_Hyperlink = "Hyperlink"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_Hyperlink_NavigateUri Field

HtmlToXamlConverterXaml_Hyperlink_NavigateUri Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_Hyperlink_NavigateUri = "NavigateUri"
public:
literal String^ Xaml_Hyperlink_NavigateUri = "NavigateUri"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_Hyperlink_TargetName Field

HtmlToXamlConverterXaml_Hyperlink_TargetName Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_Hyperlink_TargetName = "TargetName"
public:
literal String^ Xaml_Hyperlink_TargetName = "TargetName"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_LineBreak Field

HtmlToXamlConverterXaml_LineBreak Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_LineBreak = "LineBreak"
public:
literal String^ Xaml_LineBreak = "LineBreak"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_List Field

HtmlToXamlConverterXaml_List Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_List = "List"
public:
literal String^ Xaml_List = "List"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_List_MarkerStyle Field

HtmlToXamlConverterXaml_List_MarkerStyle Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_List_MarkerStyle = "MarkerStyle"
public:
literal String^ Xaml_List_MarkerStyle = "MarkerStyle"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_List_MarkerStyle_Box Field

HtmlToXamlConverterXaml_List_MarkerStyle_Box Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_List_MarkerStyle_Box = "Box"
public:
literal String^ Xaml_List_MarkerStyle_Box = "Box"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_List_MarkerStyle_Circle Field

HtmlToXamlConverterXaml_List_MarkerStyle_Circle Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_List_MarkerStyle_Circle = "Circle"
public:
literal String^ Xaml_List_MarkerStyle_Circle = "Circle"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_List_MarkerStyle_Decimal Field

HtmlToXamlConverterXaml_List_MarkerStyle_Decimal Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_List_MarkerStyle_Decimal = "Decimal"
public:
literal String^ Xaml_List_MarkerStyle_Decimal = "Decimal"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_List_MarkerStyle_Disc Field

HtmlToXamlConverterXaml_List_MarkerStyle_Disc Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_List_MarkerStyle_Disc = "Disc"
public:
literal String^ Xaml_List_MarkerStyle_Disc = "Disc"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_List_MarkerStyle_LowerLatin Field

HtmlToXamlConverterXaml_List_MarkerStyle_LowerLatin Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_List_MarkerStyle_LowerLatin = "LowerLatin"
public:
literal String^ Xaml_List_MarkerStyle_LowerLatin = "LowerLatin"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_List_MarkerStyle_LowerRoman Field

HtmlToXamlConverterXaml_List_MarkerStyle_LowerRoman Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_List_MarkerStyle_LowerRoman = "LowerRoman"
public:
literal String^ Xaml_List_MarkerStyle_LowerRoman = "LowerRoman"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_List_MarkerStyle_None Field

HtmlToXamlConverterXaml_List_MarkerStyle_None Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_List_MarkerStyle_None = "None"
public:
literal String^ Xaml_List_MarkerStyle_None = "None"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_List_MarkerStyle_Square Field

HtmlToXamlConverterXaml_List_MarkerStyle_Square Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_List_MarkerStyle_Square = "Square"
public:
literal String^ Xaml_List_MarkerStyle_Square = "Square"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_List_MarkerStyle_UpperLatin Field

HtmlToXamlConverterXaml_List_MarkerStyle_UpperLatin Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_List_MarkerStyle_UpperLatin = "UpperLatin"
public:
literal String^ Xaml_List_MarkerStyle_UpperLatin = "UpperLatin"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_List_MarkerStyle_UpperRoman Field

HtmlToXamlConverterXaml_List_MarkerStyle_UpperRoman Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_List_MarkerStyle_UpperRoman = "UpperRoman"
public:
literal String^ Xaml_List_MarkerStyle_UpperRoman = "UpperRoman"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_ListItem Field

HtmlToXamlConverterXaml_ListItem Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_ListItem = "ListItem"
public:
literal String^ Xaml_ListItem = "ListItem"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_Margin Field

HtmlToXamlConverterXaml_Margin Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_Margin = "Margin"
public:
literal String^ Xaml_Margin = "Margin"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_Padding Field

HtmlToXamlConverterXaml_Padding Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_Padding = "Padding"
public:
literal String^ Xaml_Padding = "Padding"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_Paragraph Field

HtmlToXamlConverterXaml_Paragraph Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_Paragraph = "Paragraph"
public:
literal String^ Xaml_Paragraph = "Paragraph"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_Run Field

HtmlToXamlConverterXaml_Run Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_Run = "Run"
public:
literal String^ Xaml_Run = "Run"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_Section Field

HtmlToXamlConverterXaml_Section Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_Section = "Section"
public:
literal String^ Xaml_Section = "Section"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_Span Field

HtmlToXamlConverterXaml_Span Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_Span = "Span"
public:
literal String^ Xaml_Span = "Span"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_Table Field

HtmlToXamlConverterXaml_Table Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_Table = "Table"
public:
literal String^ Xaml_Table = "Table"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_TableCell Field

HtmlToXamlConverterXaml_TableCell Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_TableCell = "TableCell"
public:
literal String^ Xaml_TableCell = "TableCell"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_TableCell_BorderBrush Field

HtmlToXamlConverterXaml_TableCell_BorderBrush Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_TableCell_BorderBrush = "BorderBrush"
public:
literal String^ Xaml_TableCell_BorderBrush = "BorderBrush"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_TableCell_BorderThickness Field

HtmlToXamlConverterXaml_TableCell_BorderThickness Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_TableCell_BorderThickness = "BorderThickness"
public:
literal String^ Xaml_TableCell_BorderThickness = "BorderThickness"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_TableCell_ColumnSpan Field

HtmlToXamlConverterXaml_TableCell_ColumnSpan Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_TableCell_ColumnSpan = "ColumnSpan"
public:
literal String^ Xaml_TableCell_ColumnSpan = "ColumnSpan"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_TableCell_RowSpan Field

HtmlToXamlConverterXaml_TableCell_RowSpan Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_TableCell_RowSpan = "RowSpan"
public:
literal String^ Xaml_TableCell_RowSpan = "RowSpan"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_TableColumn Field

HtmlToXamlConverterXaml_TableColumn Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_TableColumn = "TableColumn"
public:
literal String^ Xaml_TableColumn = "TableColumn"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_TableRow Field

HtmlToXamlConverterXaml_TableRow Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_TableRow = "TableRow"
public:
literal String^ Xaml_TableRow = "TableRow"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_TableRowGroup Field

HtmlToXamlConverterXaml_TableRowGroup Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_TableRowGroup = "TableRowGroup"
public:
literal String^ Xaml_TableRowGroup = "TableRowGroup"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_TextAlignment Field

HtmlToXamlConverterXaml_TextAlignment Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_TextAlignment = "TextAlignment"
public:
literal String^ Xaml_TextAlignment = "TextAlignment"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_TextDecorations Field

HtmlToXamlConverterXaml_TextDecorations Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_TextDecorations = "TextDecorations"
public:
literal String^ Xaml_TextDecorations = "TextDecorations"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_TextDecorations_Underline Field

HtmlToXamlConverterXaml_TextDecorations_Underline Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_TextDecorations_Underline = "Underline"
public:
literal String^ Xaml_TextDecorations_Underline = "Underline"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_TextIndent Field

HtmlToXamlConverterXaml_TextIndent Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_TextIndent = "TextIndent"
public:
literal String^ Xaml_TextIndent = "TextIndent"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


HtmlToXamlConverter.Xaml_Width Field

HtmlToXamlConverterXaml_Width Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string Xaml_Width = "Width"
public:
literal String^ Xaml_Width = "Width"

Field Value

Type: String
See Also

Reference

HtmlToXamlConverter Class
VisualComponents.UX.Shared Namespace


IAbortableAction Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IAbortableAction
public interface class IAbortableAction

The IAbortableAction type exposes the following members.

Methods
 | Name | Description
Public method | Abort |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IAbortableAction Methods

The IAbortableAction type exposes the following members.

Methods
 | Name | Description
Public method | Abort |
Top
See Also

Reference

IAbortableAction Interface
VisualComponents.UX.Shared Namespace


IAbortableAction.Abort Method

IAbortableActionAbort Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Abort()
void Abort()
See Also

Reference

IAbortableAction Interface
VisualComponents.UX.Shared Namespace


IActionItem Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IActionItem : INotifyPropertyChangedEx,
    INotifyPropertyChanged
public interface class IActionItem : INotifyPropertyChangedEx,
    INotifyPropertyChanged

The IActionItem type exposes the following members.

Properties
 | Name | Description
Public property | CanExecute |
Public property | Content | Item text/header.
Public property | ContextFilter | Defines application contexts where action is available.
Public property | ControlType |
Public property | IconName | Gets the icon name.
Public property | Id |
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | RibbonId | Required for ribbon only, as all items in ribbon groups are required to have a unique id.
Public property | SiteOrder |
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element.
Public property | Visibility | Item Visibility
Top
Methods
 | Name | Description
Public method | EvaluateCanExecute |
Public method | Execute | Note: When executed from UI buttons we also call BeforeExecute(). Note: This is executed from both r-click and normal UI buttons. If need to distinguish between executing 'with command panel' and 'immediate execution' inherit from ActionItemT1 and define both Execute() and Execute(bool). Note: Some actions also use IsChecked to execute. They call BeforeExecute() manually.
Public method | Execute(PropertyCollection) |
Public method | Execute(SetupPythonActionMessage) | Obsolete.
Public method | IsAvailableInCurrentContextAndSite |
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IActionItem Properties

The IActionItem type exposes the following members.

Properties
 | Name | Description
Public property | CanExecute |
Public property | Content | Item text/header.
Public property | ContextFilter | Defines application contexts where action is available.
Public property | ControlType |
Public property | IconName | Gets the icon name.
Public property | Id |
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | RibbonId | Required for ribbon only, as all items in ribbon groups are required to have a unique id.
Public property | SiteOrder |
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element.
Public property | Visibility | Item Visibility
Top
See Also

Reference

IActionItem Interface
VisualComponents.UX.Shared Namespace


IActionItem.CanExecute Property

IActionItemCanExecute Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanExecute { get; }
property bool CanExecute {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IActionItem Interface
VisualComponents.UX.Shared Namespace


IActionItem.Content Property

IActionItemContent Property

Item text/header.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Content { get; set; }
property String^ Content {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IActionItem Interface
VisualComponents.UX.Shared Namespace


IActionItem.ContextFilter Property

IActionItemContextFilter Property

Defines application contexts where action is available.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ContextFilter { get; set; }
property String^ ContextFilter {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IActionItem Interface
VisualComponents.UX.Shared Namespace


IActionItem.ControlType Property

IActionItemControlType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ControlType { get; set; }
property String^ ControlType {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IActionItem Interface
VisualComponents.UX.Shared Namespace


IActionItem.IconName Property

IActionItemIconName Property

Gets the icon name.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string IconName { get; }
property String^ IconName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IActionItem Interface
VisualComponents.UX.Shared Namespace


IActionItem.Id Property

IActionItemId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Id { get; set; }
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IActionItem Interface
VisualComponents.UX.Shared Namespace


IActionItem.RibbonId Property

IActionItemRibbonId Property

Required for ribbon only, as all items in ribbon groups are required to have a unique id.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string RibbonId { get; set; }
property String^ RibbonId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IActionItem Interface
VisualComponents.UX.Shared Namespace


IActionItem.SiteOrder Property

IActionItemSiteOrder Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double SiteOrder { get; set; }
property double SiteOrder {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IActionItem Interface
VisualComponents.UX.Shared Namespace


IActionItem.Tag Property

IActionItemTag Property

Gets or sets an arbitrary object value that can be used to store custom information about this element.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object Tag { get; set; }
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

IActionItem Interface
VisualComponents.UX.Shared Namespace


IActionItem.Visibility Property

IActionItemVisibility Property

Item Visibility

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Visibility Visibility { get; set; }
property Visibility Visibility {
    Visibility get ();
    void set (Visibility value);
}

Property Value

Type: Visibility
See Also

Reference

IActionItem Interface
VisualComponents.UX.Shared Namespace


IActionItem Methods

The IActionItem type exposes the following members.

Methods
 | Name | Description
Public method | EvaluateCanExecute |
Public method | Execute | Note: When executed from UI buttons we also call BeforeExecute(). Note: This is executed from both r-click and normal UI buttons. If need to distinguish between executing 'with command panel' and 'immediate execution' inherit from ActionItemT1 and define both Execute() and Execute(bool). Note: Some actions also use IsChecked to execute. They call BeforeExecute() manually.
Public method | Execute(PropertyCollection) |
Public method | Execute(SetupPythonActionMessage) | Obsolete.
Public method | IsAvailableInCurrentContextAndSite |
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Top
See Also

Reference

IActionItem Interface
VisualComponents.UX.Shared Namespace


IActionItem.EvaluateCanExecute Method

IActionItemEvaluateCanExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void EvaluateCanExecute()
void EvaluateCanExecute()
See Also

Reference

IActionItem Interface
VisualComponents.UX.Shared Namespace


IActionItem.Execute Method

IActionItemExecute Method

Overload List
 | Name | Description
Public method | Execute | Note: When executed from UI buttons we also call BeforeExecute(). Note: This is executed from both r-click and normal UI buttons. If need to distinguish between executing 'with command panel' and 'immediate execution' inherit from ActionItemT1 and define both Execute() and Execute(bool). Note: Some actions also use IsChecked to execute. They call BeforeExecute() manually.
Public method | Execute(PropertyCollection) |
Public method | Execute(SetupPythonActionMessage) | Obsolete.
Top
See Also

Reference

IActionItem Interface
VisualComponents.UX.Shared Namespace


IActionItem.Execute Method

IActionItemExecute Method

Note: When executed from UI buttons we also call BeforeExecute(). Note: This is executed from both r-click and normal UI buttons. If need to distinguish between executing 'with command panel' and 'immediate execution' inherit from ActionItemT1 and define both Execute() and Execute(bool). Note: Some actions also use IsChecked to execute. They call BeforeExecute() manually.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Execute()
void Execute()
See Also

Reference

IActionItem Interface
Execute Overload
VisualComponents.UX.Shared Namespace


IActionItem.Execute Method (PropertyCollection)

IActionItemExecute Method (PropertyCollection)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Execute(
    PropertyCollection args
)
void Execute(
    PropertyCollection^ args
)

Parameters

args
Type: VisualComponents.Create3DPropertyCollection
See Also

Reference

IActionItem Interface
Execute Overload
VisualComponents.UX.Shared Namespace


IActionItem.Execute Method (SetupPythonActionMessage)

IActionItemExecute Method (SetupPythonActionMessage)

Note: This API is now obsolete.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute]
void Execute(
    SetupPythonActionMessage message
)
[ObsoleteAttribute]
void Execute(
    SetupPythonActionMessage^ message
)

Parameters

message
Type: VisualComponents.Create3DSetupPythonActionMessage
See Also

Reference

IActionItem Interface
Execute Overload
VisualComponents.UX.Shared Namespace


IActionItem.IsAvailableInCurrentContextAndSite Method

IActionItemIsAvailableInCurrentContextAndSite Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsAvailableInCurrentContextAndSite(
    string siteId
)
bool IsAvailableInCurrentContextAndSite(
    String^ siteId
)

Parameters

siteId
Type: SystemString

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IActionItem.IsAvailableInCurrentContextAndSite(System.String)"]

Remarks
Note: In total there are 3 checks: IsAvailableInCurrentContextAndSite, IsAvailableForObject, and CanExecute. First two affect the visibility, last one the disabled-state of a button.
See Also

Reference

IActionItem Interface
VisualComponents.UX.Shared Namespace


IActionItem.NotifyAnotherActionItem Method

IActionItemNotifyAnotherActionItem Method

Another action item will be evaluated by calling EvaluateCanExecute

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void NotifyAnotherActionItem(
    string actionName
)
void NotifyAnotherActionItem(
    String^ actionName
)

Parameters

actionName
Type: SystemString
action item name which will be notified
See Also

Reference

IActionItem Interface
VisualComponents.UX.Shared Namespace


IActionItem Events

The IActionItem type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IActionItem Interface
VisualComponents.UX.Shared Namespace


IActionResult Interface

CoRoutine with command properties.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IActionResult : IResult,
    IPropertyContainer, IBatchModeObject
public interface class IActionResult : IResult,
    IPropertyContainer, IBatchModeObject

The IActionResult type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Execute | (Inherited from IResult.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
Events
 | Name | Description
Public event | Completed | (Inherited from IResult.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IActionResult Properties

The IActionResult type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | Number of times BeginChangeBatch() has been called without calling EndChangeBatch(). (Inherited from IBatchModeObject.)
Public property | ContainerExpressionContext | Property expression context. (Inherited from IPropertyContainer.)
Public property | Properties | List of property objects. (Inherited from IPropertyContainer.)
Public property | PropertyNames | Get a list of all property names. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Public property | PropertyNamesAndValues | List of all name-value pairs. This list has the same order as Properties (Inherited from IPropertyContainer.)
Public property | PropertyValues | List of all property values. This list has the same order as Properties. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IActionResult Interface
VisualComponents.UX.Shared Namespace


IActionResult Methods

The IActionResult type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | Begin a change batch during which change notification events are suspended. (Inherited from IBatchModeObject.)
Public method | CreateProperty(Type, PropertyConstraintType) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | Create a property object that can be used with the property container. (Inherited from IPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from IPropertyContainer.)
Public method | DeleteProperty | Delete and invalidate the given property object. (Inherited from IPropertyContainer.)
Public method | EndChangeBatch | End a previously begun change batch, and trigger any notification events. (Inherited from IBatchModeObject.)
Public method | Execute | (Inherited from IResult.)
Public method | GetProperty | Get an individual named property object. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | Set property values sequentially from the beginning. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | Set the property values by name. (Inherited from IPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | Set property values sequentially starting from the given index. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IActionResult Interface
VisualComponents.UX.Shared Namespace


IActionResult Events

The IActionResult type exposes the following members.

Events
 | Name | Description
Public event | Completed | (Inherited from IResult.)
Public event | PropertyContainerChanged | Raised when a property has been created, moved or removed within the property container. (Inherited from IPropertyContainer.)
Top
See Also

Reference

IActionResult Interface
VisualComponents.UX.Shared Namespace


IActivatorViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IActivatorViewModel
public interface class IActivatorViewModel
See Also

Reference

VisualComponents.UX.Shared Namespace


IActiveObjectsEx Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IActiveObjectsEx
public interface class IActiveObjectsEx

The IActiveObjectsEx type exposes the following members.

Properties
 | Name | Description
Public property | ActiveObjectsEx |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IActiveObjectsEx Properties

The IActiveObjectsEx type exposes the following members.

Properties
 | Name | Description
Public property | ActiveObjectsEx |
Top
See Also

Reference

IActiveObjectsEx Interface
VisualComponents.UX.Shared Namespace


IActiveObjectsEx.ActiveObjectsEx Property

IActiveObjectsExActiveObjectsEx Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList ActiveObjectsEx { set; }
property IList^ ActiveObjectsEx {
    void set (IList^ value);
}

Property Value

Type: IList
See Also

Reference

IActiveObjectsEx Interface
VisualComponents.UX.Shared Namespace


IAddDecalAction Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IAddDecalAction : INotAbortableCommand,
    ICommandPanelAction
public interface class IAddDecalAction : INotAbortableCommand,
    ICommandPanelAction

The IAddDecalAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Top
Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | DoDecal |
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Public method | UpdateManipulatorSize |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IAddDecalAction Properties

The IAddDecalAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

IAddDecalAction Interface
VisualComponents.UX.Shared Namespace


IAddDecalAction Methods

The IAddDecalAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | DoDecal |
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Public method | UpdateManipulatorSize |
Top
See Also

Reference

IAddDecalAction Interface
VisualComponents.UX.Shared Namespace


IAddDecalAction.DoDecal Method

IAddDecalActionDoDecal Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DoDecal()
void DoDecal()
See Also

Reference

IAddDecalAction Interface
VisualComponents.UX.Shared Namespace


IAddDecalAction.UpdateManipulatorSize Method

IAddDecalActionUpdateManipulatorSize Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateManipulatorSize()
void UpdateManipulatorSize()
See Also

Reference

IAddDecalAction Interface
VisualComponents.UX.Shared Namespace


IAddDecalViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IAddDecalViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IAddDecalViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The IAddDecalViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Offset |
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Public property | UTiling |
Public property | VTiling |
Public property | X |
Public property | Y |
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IAddDecalViewModel Properties

The IAddDecalViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Offset |
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Public property | UTiling |
Public property | VTiling |
Public property | X |
Public property | Y |
Top
See Also

Reference

IAddDecalViewModel Interface
VisualComponents.UX.Shared Namespace


IAddDecalViewModel.Offset Property

IAddDecalViewModelOffset Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Offset { get; }
property double Offset {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IAddDecalViewModel Interface
VisualComponents.UX.Shared Namespace


IAddDecalViewModel.UTiling Property

IAddDecalViewModelUTiling Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double UTiling { get; }
property double UTiling {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IAddDecalViewModel Interface
VisualComponents.UX.Shared Namespace


IAddDecalViewModel.VTiling Property

IAddDecalViewModelVTiling Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double VTiling { get; }
property double VTiling {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IAddDecalViewModel Interface
VisualComponents.UX.Shared Namespace


IAddDecalViewModel.X Property

IAddDecalViewModelX Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double X { get; }
property double X {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IAddDecalViewModel Interface
VisualComponents.UX.Shared Namespace


IAddDecalViewModel.Y Property

IAddDecalViewModelY Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Y { get; }
property double Y {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IAddDecalViewModel Interface
VisualComponents.UX.Shared Namespace


IAddDecalViewModel Methods

The IAddDecalViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IAddDecalViewModel Interface
VisualComponents.UX.Shared Namespace


IAddDecalViewModel Events

The IAddDecalViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IAddDecalViewModel Interface
VisualComponents.UX.Shared Namespace


IAddOnActivationSettings Interface

Additional settings related to IAddOnSetting.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IAddOnActivationSettings
public interface class IAddOnActivationSettings

The IAddOnActivationSettings type exposes the following members.

Properties
 | Name | Description
Public property | RestartOnLicenseDeactivation | Whether the main application restart is required after the license for this add-on is successfully deactivated.
Top
Remarks
Breaking changes to this interface and its support are to be expected in future versions.
See Also

Reference

VisualComponents.UX.Shared Namespace


IAddOnActivationSettings Properties

The IAddOnActivationSettings type exposes the following members.

Properties
 | Name | Description
Public property | RestartOnLicenseDeactivation | Whether the main application restart is required after the license for this add-on is successfully deactivated.
Top
See Also

Reference

IAddOnActivationSettings Interface
VisualComponents.UX.Shared Namespace


IAddOnActivationSettings.RestartOnLicenseDeactivation Property

IAddOnActivationSettingsRestartOnLicenseDeactivation Property

Whether the main application restart is required after the license for this add-on is successfully deactivated.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool RestartOnLicenseDeactivation { get; }
property bool RestartOnLicenseDeactivation {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IAddOnActivationSettings Interface
VisualComponents.UX.Shared Namespace


IAddOnSetting Interface

AddOn setting interface.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IAddOnSetting
public interface class IAddOnSetting

The IAddOnSetting type exposes the following members.

Properties
 | Name | Description
Public property | IsEnabled | State of the plugin if it enabled in the UI.
Public property | Order | Define the order it is displayed
Top
Methods
 | Name | Description
Public method | CancelApplyingSetting | Cancel changes
Public method | DisableAddOn | Disable AddOn
Public method | EnableAddOn | Enable AddOn
Public method | SaveAndApplySetting | Apply and save setting change.
Top
Remarks
Any AddOn with additional setting in backstage needs to implement this interface inorder its content be loaded.
See Also

Reference

VisualComponents.UX.Shared Namespace


IAddOnSetting Properties

The IAddOnSetting type exposes the following members.

Properties
 | Name | Description
Public property | IsEnabled | State of the plugin if it enabled in the UI.
Public property | Order | Define the order it is displayed
Top
See Also

Reference

IAddOnSetting Interface
VisualComponents.UX.Shared Namespace


IAddOnSetting.IsEnabled Property

IAddOnSettingIsEnabled Property

State of the plugin if it enabled in the UI.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsEnabled { get; set; }
property bool IsEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IAddOnSetting Interface
VisualComponents.UX.Shared Namespace


IAddOnSetting.Order Property

IAddOnSettingOrder Property

Define the order it is displayed

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
uint Order { get; }
property unsigned int Order {
    unsigned int get ();
}

Property Value

Type: UInt32
See Also

Reference

IAddOnSetting Interface
VisualComponents.UX.Shared Namespace


IAddOnSetting Methods

The IAddOnSetting type exposes the following members.

Methods
 | Name | Description
Public method | CancelApplyingSetting | Cancel changes
Public method | DisableAddOn | Disable AddOn
Public method | EnableAddOn | Enable AddOn
Public method | SaveAndApplySetting | Apply and save setting change.
Top
See Also

Reference

IAddOnSetting Interface
VisualComponents.UX.Shared Namespace


IAddOnSetting.CancelApplyingSetting Method

IAddOnSettingCancelApplyingSetting Method

Cancel changes

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void CancelApplyingSetting()
void CancelApplyingSetting()
See Also

Reference

IAddOnSetting Interface
VisualComponents.UX.Shared Namespace


IAddOnSetting.DisableAddOn Method

IAddOnSettingDisableAddOn Method

Disable AddOn

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DisableAddOn()
void DisableAddOn()
See Also

Reference

IAddOnSetting Interface
VisualComponents.UX.Shared Namespace


IAddOnSetting.EnableAddOn Method

IAddOnSettingEnableAddOn Method

Enable AddOn

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void EnableAddOn()
void EnableAddOn()
See Also

Reference

IAddOnSetting Interface
VisualComponents.UX.Shared Namespace


IAddOnSetting.SaveAndApplySetting Method

IAddOnSettingSaveAndApplySetting Method

Apply and save setting change.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SaveAndApplySetting()
void SaveAndApplySetting()
See Also

Reference

IAddOnSetting Interface
VisualComponents.UX.Shared Namespace


IAllFrameFeaturesVisibilityCommand Interface

Feature Frame visibility toggling command.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IAllFrameFeaturesVisibilityCommand : IFrameVisibilityType
public interface class IAllFrameFeaturesVisibilityCommand : IFrameVisibilityType

The IAllFrameFeaturesVisibilityCommand type exposes the following members.

Properties
 | Name | Description
Public property | IsChecked | (Inherited from IFrameVisibilityType.)
Top
Methods
 | Name | Description
Public method | Execute | (Inherited from IFrameVisibilityType.)
Public method | RefreshSettings | (Inherited from IFrameVisibilityType.)
Public method | UpdateFeatureFrameVisibility |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IAllFrameFeaturesVisibilityCommand Properties

The IAllFrameFeaturesVisibilityCommand type exposes the following members.

Properties
 | Name | Description
Public property | IsChecked | (Inherited from IFrameVisibilityType.)
Top
See Also

Reference

IAllFrameFeaturesVisibilityCommand Interface
VisualComponents.UX.Shared Namespace


IAllFrameFeaturesVisibilityCommand Methods

The IAllFrameFeaturesVisibilityCommand type exposes the following members.

Methods
 | Name | Description
Public method | Execute | (Inherited from IFrameVisibilityType.)
Public method | RefreshSettings | (Inherited from IFrameVisibilityType.)
Public method | UpdateFeatureFrameVisibility |
Top
See Also

Reference

IAllFrameFeaturesVisibilityCommand Interface
VisualComponents.UX.Shared Namespace


IAllFrameFeaturesVisibilityCommand.UpdateFeatureFrameVisibility Method

IAllFrameFeaturesVisibilityCommandUpdateFeatureFrameVisibility Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateFeatureFrameVisibility()
void UpdateFeatureFrameVisibility()
See Also

Reference

IAllFrameFeaturesVisibilityCommand Interface
VisualComponents.UX.Shared Namespace


IApplicationStatusService Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IApplicationStatusService : INotifyPropertyChangedEx,
    INotifyPropertyChanged
public interface class IApplicationStatusService : INotifyPropertyChangedEx,
    INotifyPropertyChanged

The IApplicationStatusService type exposes the following members.

Properties
 | Name | Description
Public property | CurrentActionItem |
Public property | IsNewProgressBar |
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | ProgressBarState |
Public property | ProgressBarVisibility |
Public property | ProgressPercentage |
Public property | ProgressStatus |
Top
Methods
 | Name | Description
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | UpdateProgressBar |
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IApplicationStatusService Properties

The IApplicationStatusService type exposes the following members.

Properties
 | Name | Description
Public property | CurrentActionItem |
Public property | IsNewProgressBar |
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | ProgressBarState |
Public property | ProgressBarVisibility |
Public property | ProgressPercentage |
Public property | ProgressStatus |
Top
See Also

Reference

IApplicationStatusService Interface
VisualComponents.UX.Shared Namespace


IApplicationStatusService.CurrentActionItem Property

IApplicationStatusServiceCurrentActionItem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IActionItem CurrentActionItem { get; set; }
property IActionItem^ CurrentActionItem {
    IActionItem^ get ();
    void set (IActionItem^ value);
}

Property Value

Type: IActionItem
See Also

Reference

IApplicationStatusService Interface
VisualComponents.UX.Shared Namespace


IApplicationStatusService.IsNewProgressBar Property

IApplicationStatusServiceIsNewProgressBar Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsNewProgressBar { get; set; }
property bool IsNewProgressBar {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IApplicationStatusService Interface
VisualComponents.UX.Shared Namespace


IApplicationStatusService.ProgressBarState Property

IApplicationStatusServiceProgressBarState Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ProgressBarStates ProgressBarState { get; set; }
property ProgressBarStates ProgressBarState {
    ProgressBarStates get ();
    void set (ProgressBarStates value);
}

Property Value

Type: ProgressBarStates
See Also

Reference

IApplicationStatusService Interface
VisualComponents.UX.Shared Namespace


IApplicationStatusService.ProgressBarVisibility Property

IApplicationStatusServiceProgressBarVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Visibility ProgressBarVisibility { get; set; }
property Visibility ProgressBarVisibility {
    Visibility get ();
    void set (Visibility value);
}

Property Value

Type: Visibility
See Also

Reference

IApplicationStatusService Interface
VisualComponents.UX.Shared Namespace


IApplicationStatusService.ProgressPercentage Property

IApplicationStatusServiceProgressPercentage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double ProgressPercentage { get; set; }
property double ProgressPercentage {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IApplicationStatusService Interface
VisualComponents.UX.Shared Namespace


IApplicationStatusService.ProgressStatus Property

IApplicationStatusServiceProgressStatus Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ProgressStatus { get; set; }
property String^ ProgressStatus {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IApplicationStatusService Interface
VisualComponents.UX.Shared Namespace


IApplicationStatusService Methods

The IApplicationStatusService type exposes the following members.

Methods
 | Name | Description
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | UpdateProgressBar |
Top
See Also

Reference

IApplicationStatusService Interface
VisualComponents.UX.Shared Namespace


IApplicationStatusService.UpdateProgressBar Method

IApplicationStatusServiceUpdateProgressBar Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateProgressBar(
    string status,
    double progressPercentage
)
void UpdateProgressBar(
    String^ status,
    double progressPercentage
)

Parameters

status
Type: SystemString
progressPercentage
Type: SystemDouble
See Also

Reference

IApplicationStatusService Interface
VisualComponents.UX.Shared Namespace


IApplicationStatusService Events

The IApplicationStatusService type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IApplicationStatusService Interface
VisualComponents.UX.Shared Namespace


IApproachAxisCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IApproachAxisCommand
public interface class IApproachAxisCommand

The IApproachAxisCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApproachAxis |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IApproachAxisCommand Properties

The IApproachAxisCommand type exposes the following members.

Properties
 | Name | Description
Public property | ApproachAxis |
Top
See Also

Reference

IApproachAxisCommand Interface
VisualComponents.UX.Shared Namespace


IApproachAxisCommand.ApproachAxis Property

IApproachAxisCommandApproachAxis Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
AxisType ApproachAxis { get; set; }
property AxisType ApproachAxis {
    AxisType get ();
    void set (AxisType value);
}

Property Value

Type: AxisType
See Also

Reference

IApproachAxisCommand Interface
VisualComponents.UX.Shared Namespace


IAreaSelectionSnap Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IAreaSelectionSnap
public interface class IAreaSelectionSnap

The IAreaSelectionSnap type exposes the following members.

Properties
 | Name | Description
Public property | AreaSelectionReferencePointDown | Reference point used if area selection is selected when mouse button down
Public property | AreaSelectionReferencePointMove | Reference point used if area selection is selected when mouse is moving
Public property | AreaSelectionReferencePointUp | Reference point used if area selection is selected when mouse button up
Public property | InAreaSelection | Indicates if the object is awaiting for area selection to be completed
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IAreaSelectionSnap Properties

The IAreaSelectionSnap type exposes the following members.

Properties
 | Name | Description
Public property | AreaSelectionReferencePointDown | Reference point used if area selection is selected when mouse button down
Public property | AreaSelectionReferencePointMove | Reference point used if area selection is selected when mouse is moving
Public property | AreaSelectionReferencePointUp | Reference point used if area selection is selected when mouse button up
Public property | InAreaSelection | Indicates if the object is awaiting for area selection to be completed
Top
See Also

Reference

IAreaSelectionSnap Interface
VisualComponents.UX.Shared Namespace


IAreaSelectionSnap.AreaSelectionReferencePointDown Property

IAreaSelectionSnapAreaSelectionReferencePointDown Property

Reference point used if area selection is selected when mouse button down

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Nullable<Point> AreaSelectionReferencePointDown { get; }
property Nullable<Point> AreaSelectionReferencePointDown {
    Nullable<Point> get ();
}

Property Value

Type: NullablePoint
See Also

Reference

IAreaSelectionSnap Interface
VisualComponents.UX.Shared Namespace


IAreaSelectionSnap.AreaSelectionReferencePointMove Property

IAreaSelectionSnapAreaSelectionReferencePointMove Property

Reference point used if area selection is selected when mouse is moving

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Nullable<Point> AreaSelectionReferencePointMove { get; }
property Nullable<Point> AreaSelectionReferencePointMove {
    Nullable<Point> get ();
}

Property Value

Type: NullablePoint
See Also

Reference

IAreaSelectionSnap Interface
VisualComponents.UX.Shared Namespace


IAreaSelectionSnap.AreaSelectionReferencePointUp Property

IAreaSelectionSnapAreaSelectionReferencePointUp Property

Reference point used if area selection is selected when mouse button up

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Nullable<Point> AreaSelectionReferencePointUp { get; }
property Nullable<Point> AreaSelectionReferencePointUp {
    Nullable<Point> get ();
}

Property Value

Type: NullablePoint
See Also

Reference

IAreaSelectionSnap Interface
VisualComponents.UX.Shared Namespace


IAreaSelectionSnap.InAreaSelection Property

IAreaSelectionSnapInAreaSelection Property

Indicates if the object is awaiting for area selection to be completed

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool InAreaSelection { get; }
property bool InAreaSelection {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IAreaSelectionSnap Interface
VisualComponents.UX.Shared Namespace


IAttachmentManipulator Interface

Terminology: Attachment - an interface for attaching rSimLinks (kinda like rSimHierarchyField, but without limitation of parenting only to component)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IAttachmentManipulator
public interface class IAttachmentManipulator
See Also

Reference

VisualComponents.UX.Shared Namespace


IAuthoringDualTreeViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IAuthoringDualTreeViewModel : IHaveDisplayName,
    ITreeViewModel, IScreen, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IAuthoringDualTreeViewModel : IHaveDisplayName,
    ITreeViewModel, IScreen, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The IAuthoringDualTreeViewModel type exposes the following members.

Properties
 | Name | Description
Public property | CollapsedNodesCount | (Inherited from ITreeViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | FeatureTree | Feature tree for selected node.
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsXamTreeEx | (Inherited from ITreeViewModel.)
Public property | MainTree | Currently shown component tree.
Public property | SelectedSimNode | Node selected in feature tree or main tree.
Public property | SelectedTreeNodes | (Inherited from ITreeViewModel.)
Public property | ShowDropIndicators | (Inherited from ITreeViewModel.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | ApplyFilterToTreeNode | (Inherited from ITreeViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Clear | (Inherited from ITreeViewModel.)
Public method | CloneData | (Inherited from ITreeViewModel.)
Public method | Collapse | (Inherited from ITreeViewModel.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | DeleteData | (Inherited from ITreeViewModel.)
Public method | Expand | (Inherited from ITreeViewModel.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | PasteData | (Inherited from ITreeViewModel.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Public method | UpdateSelection | (Inherited from ITreeViewModel.)
Public method | UpdateTree | (Inherited from ITreeViewModel.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IAuthoringDualTreeViewModel Properties

The IAuthoringDualTreeViewModel type exposes the following members.

Properties
 | Name | Description
Public property | CollapsedNodesCount | (Inherited from ITreeViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | FeatureTree | Feature tree for selected node.
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsXamTreeEx | (Inherited from ITreeViewModel.)
Public property | MainTree | Currently shown component tree.
Public property | SelectedSimNode | Node selected in feature tree or main tree.
Public property | SelectedTreeNodes | (Inherited from ITreeViewModel.)
Public property | ShowDropIndicators | (Inherited from ITreeViewModel.)
Top
See Also

Reference

IAuthoringDualTreeViewModel Interface
VisualComponents.UX.Shared Namespace


IAuthoringDualTreeViewModel.FeatureTree Property

IAuthoringDualTreeViewModelFeatureTree Property

Feature tree for selected node.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IAuthoringTreeViewModel FeatureTree { get; }
property IAuthoringTreeViewModel^ FeatureTree {
    IAuthoringTreeViewModel^ get ();
}

Property Value

Type: IAuthoringTreeViewModel
See Also

Reference

IAuthoringDualTreeViewModel Interface
VisualComponents.UX.Shared Namespace


IAuthoringDualTreeViewModel.MainTree Property

IAuthoringDualTreeViewModelMainTree Property

Currently shown component tree.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IAuthoringTreeViewModel MainTree { get; }
property IAuthoringTreeViewModel^ MainTree {
    IAuthoringTreeViewModel^ get ();
}

Property Value

Type: IAuthoringTreeViewModel
See Also

Reference

IAuthoringDualTreeViewModel Interface
VisualComponents.UX.Shared Namespace


IAuthoringDualTreeViewModel.SelectedSimNode Property

IAuthoringDualTreeViewModelSelectedSimNode Property

Node selected in feature tree or main tree.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode SelectedSimNode { get; }
property ISimNode^ SelectedSimNode {
    ISimNode^ get ();
}

Property Value

Type: ISimNode
See Also

Reference

IAuthoringDualTreeViewModel Interface
VisualComponents.UX.Shared Namespace


IAuthoringDualTreeViewModel Methods

The IAuthoringDualTreeViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | ApplyFilterToTreeNode | (Inherited from ITreeViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Clear | (Inherited from ITreeViewModel.)
Public method | CloneData | (Inherited from ITreeViewModel.)
Public method | Collapse | (Inherited from ITreeViewModel.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | DeleteData | (Inherited from ITreeViewModel.)
Public method | Expand | (Inherited from ITreeViewModel.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | PasteData | (Inherited from ITreeViewModel.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Public method | UpdateSelection | (Inherited from ITreeViewModel.)
Public method | UpdateTree | (Inherited from ITreeViewModel.)
Top
See Also

Reference

IAuthoringDualTreeViewModel Interface
VisualComponents.UX.Shared Namespace


IAuthoringDualTreeViewModel Events

The IAuthoringDualTreeViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IAuthoringDualTreeViewModel Interface
VisualComponents.UX.Shared Namespace


IAuthoringManager Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IAuthoringManager
public interface class IAuthoringManager
See Also

Reference

VisualComponents.UX.Shared Namespace


IAuthoringTreeViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IAuthoringTreeViewModel : ITreeViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IAuthoringTreeViewModel : ITreeViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The IAuthoringTreeViewModel type exposes the following members.

Properties
 | Name | Description
Public property | AnchorFeature |
Public property | CollapsedNodesCount | (Inherited from ITreeViewModel.)
Public property | Config |
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsTreeActive |
Public property | IsXamTreeEx | (Inherited from ITreeViewModel.)
Public property | NodeVisitor |
Public property | SelectedComponent |
Public property | SelectedNode |
Public property | SelectedTreeNodes | (Inherited from ITreeViewModel.)
Public property | ShowDropIndicators | (Inherited from ITreeViewModel.)
Public property | ShowFilters |
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | ApplyFilterToTreeNode | (Inherited from ITreeViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Clear | (Inherited from ITreeViewModel.)
Public method | CloneData | (Inherited from ITreeViewModel.)
Public method | Collapse | (Inherited from ITreeViewModel.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | DeleteData | (Inherited from ITreeViewModel.)
Public method | DestroyTree | Free tree resources.
Public method | Expand | (Inherited from ITreeViewModel.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | PasteData | (Inherited from ITreeViewModel.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | Revisit | Forces reloading node subtree tree
Public method | TryClose | (Inherited from IClose.)
Public method | UpdateSelection | (Inherited from ITreeViewModel.)
Public method | UpdateTree | (Inherited from ITreeViewModel.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IAuthoringTreeViewModel Properties

The IAuthoringTreeViewModel type exposes the following members.

Properties
 | Name | Description
Public property | AnchorFeature |
Public property | CollapsedNodesCount | (Inherited from ITreeViewModel.)
Public property | Config |
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsTreeActive |
Public property | IsXamTreeEx | (Inherited from ITreeViewModel.)
Public property | NodeVisitor |
Public property | SelectedComponent |
Public property | SelectedNode |
Public property | SelectedTreeNodes | (Inherited from ITreeViewModel.)
Public property | ShowDropIndicators | (Inherited from ITreeViewModel.)
Public property | ShowFilters |
Top
See Also

Reference

IAuthoringTreeViewModel Interface
VisualComponents.UX.Shared Namespace


IAuthoringTreeViewModel.AnchorFeature Property

IAuthoringTreeViewModelAnchorFeature Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IFeature AnchorFeature { get; }
property IFeature^ AnchorFeature {
    IFeature^ get ();
}

Property Value

Type: IFeature
See Also

Reference

IAuthoringTreeViewModel Interface
VisualComponents.UX.Shared Namespace


IAuthoringTreeViewModel.Config Property

IAuthoringTreeViewModelConfig Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
TreeMode Config { get; }
property TreeMode Config {
    TreeMode get ();
}

Property Value

Type: TreeMode
See Also

Reference

IAuthoringTreeViewModel Interface
VisualComponents.UX.Shared Namespace


IAuthoringTreeViewModel.IsTreeActive Property

IAuthoringTreeViewModelIsTreeActive Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsTreeActive { get; set; }
property bool IsTreeActive {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IAuthoringTreeViewModel Interface
VisualComponents.UX.Shared Namespace


IAuthoringTreeViewModel.NodeVisitor Property

IAuthoringTreeViewModelNodeVisitor Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
VisitorBase NodeVisitor { get; }
property VisitorBase^ NodeVisitor {
    VisitorBase^ get ();
}

Property Value

Type: VisitorBase
See Also

Reference

IAuthoringTreeViewModel Interface
VisualComponents.UX.Shared Namespace


IAuthoringTreeViewModel.SelectedComponent Property

IAuthoringTreeViewModelSelectedComponent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent SelectedComponent { get; }
property ISimComponent^ SelectedComponent {
    ISimComponent^ get ();
}

Property Value

Type: ISimComponent
See Also

Reference

IAuthoringTreeViewModel Interface
VisualComponents.UX.Shared Namespace


IAuthoringTreeViewModel.SelectedNode Property

IAuthoringTreeViewModelSelectedNode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimNode SelectedNode { get; }
property ISimNode^ SelectedNode {
    ISimNode^ get ();
}

Property Value

Type: ISimNode
See Also

Reference

IAuthoringTreeViewModel Interface
VisualComponents.UX.Shared Namespace


IAuthoringTreeViewModel.ShowFilters Property

IAuthoringTreeViewModelShowFilters Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ShowFilters { get; set; }
property bool ShowFilters {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IAuthoringTreeViewModel Interface
VisualComponents.UX.Shared Namespace


IAuthoringTreeViewModel Methods

The IAuthoringTreeViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | ApplyFilterToTreeNode | (Inherited from ITreeViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Clear | (Inherited from ITreeViewModel.)
Public method | CloneData | (Inherited from ITreeViewModel.)
Public method | Collapse | (Inherited from ITreeViewModel.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | DeleteData | (Inherited from ITreeViewModel.)
Public method | DestroyTree | Free tree resources.
Public method | Expand | (Inherited from ITreeViewModel.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | PasteData | (Inherited from ITreeViewModel.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | Revisit | Forces reloading node subtree tree
Public method | TryClose | (Inherited from IClose.)
Public method | UpdateSelection | (Inherited from ITreeViewModel.)
Public method | UpdateTree | (Inherited from ITreeViewModel.)
Top
See Also

Reference

IAuthoringTreeViewModel Interface
VisualComponents.UX.Shared Namespace


IAuthoringTreeViewModel.DestroyTree Method

IAuthoringTreeViewModelDestroyTree Method

Free tree resources.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DestroyTree()
void DestroyTree()
See Also

Reference

IAuthoringTreeViewModel Interface
VisualComponents.UX.Shared Namespace


IAuthoringTreeViewModel.Revisit Method

IAuthoringTreeViewModelRevisit Method

Forces reloading node subtree tree

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Revisit(
    IWrapper parentSource,
    IWrapper newNodeSource
)
void Revisit(
    IWrapper^ parentSource,
    IWrapper^ newNodeSource
)

Parameters

parentSource
Type: VisualComponents.Create3DIWrapper
newNodeSource
Type: VisualComponents.Create3DIWrapper
See Also

Reference

IAuthoringTreeViewModel Interface
VisualComponents.UX.Shared Namespace


IAuthoringTreeViewModel Events

The IAuthoringTreeViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IAuthoringTreeViewModel Interface
VisualComponents.UX.Shared Namespace


IAutosaveAgent Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IAutosaveAgent
public interface class IAutosaveAgent

The IAutosaveAgent type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Toggles autosave on/off.
Top
Methods
 | Name | Description
Public method | ClearSessionData | Removes session data.
Public method | Restore | Restores previous session if a valid session state file is found.
Public method | Save | Stores current session to a file.
Public method | SessionExists | Returns true if data from previous session was found.
Public method | Update(ListISimComponent) | Updates components to latest revision found from ecat.
Public method | Update(ISimComponent) | Updates component to latest revision found from ecat.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IAutosaveAgent Properties

The IAutosaveAgent type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Toggles autosave on/off.
Top
See Also

Reference

IAutosaveAgent Interface
VisualComponents.UX.Shared Namespace


IAutosaveAgent.Enabled Property

IAutosaveAgentEnabled Property

Toggles autosave on/off.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool Enabled { get; set; }
property bool Enabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IAutosaveAgent Interface
VisualComponents.UX.Shared Namespace


IAutosaveAgent Methods

The IAutosaveAgent type exposes the following members.

Methods
 | Name | Description
Public method | ClearSessionData | Removes session data.
Public method | Restore | Restores previous session if a valid session state file is found.
Public method | Save | Stores current session to a file.
Public method | SessionExists | Returns true if data from previous session was found.
Public method | Update(ListISimComponent) | Updates components to latest revision found from ecat.
Public method | Update(ISimComponent) | Updates component to latest revision found from ecat.
Top
See Also

Reference

IAutosaveAgent Interface
VisualComponents.UX.Shared Namespace


IAutosaveAgent.ClearSessionData Method

IAutosaveAgentClearSessionData Method

Removes session data.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ClearSessionData()
void ClearSessionData()
See Also

Reference

IAutosaveAgent Interface
VisualComponents.UX.Shared Namespace


IAutosaveAgent.Restore Method

IAutosaveAgentRestore Method

Restores previous session if a valid session state file is found.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Restore()
void Restore()
See Also

Reference

IAutosaveAgent Interface
VisualComponents.UX.Shared Namespace


IAutosaveAgent.Save Method

IAutosaveAgentSave Method

Stores current session to a file.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Save()
void Save()
See Also

Reference

IAutosaveAgent Interface
VisualComponents.UX.Shared Namespace


IAutosaveAgent.SessionExists Method

IAutosaveAgentSessionExists Method

Returns true if data from previous session was found.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SessionExists()
bool SessionExists()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IAutosaveAgent.SessionExists"]

See Also

Reference

IAutosaveAgent Interface
VisualComponents.UX.Shared Namespace


IAutosaveAgent.Update Method

IAutosaveAgentUpdate Method

Overload List
 | Name | Description
Public method | Update(ListISimComponent) | Updates components to latest revision found from ecat.
Public method | Update(ISimComponent) | Updates component to latest revision found from ecat.
Top
See Also

Reference

IAutosaveAgent Interface
VisualComponents.UX.Shared Namespace


IAutosaveAgent.Update Method (List(ISimComponent))

IAutosaveAgentUpdate Method (ListISimComponent)

Updates components to latest revision found from ecat.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
List<ISimComponent> Update(
    List<ISimComponent> components
)
List<ISimComponent^>^ Update(
    List<ISimComponent^>^ components
)

Parameters

components
Type: System.Collections.GenericListISimComponent
Components to update.

Return Value

Type: ListISimComponent
Updated components.
See Also

Reference

IAutosaveAgent Interface
Update Overload
VisualComponents.UX.Shared Namespace


IAutosaveAgent.Update Method (ISimComponent)

IAutosaveAgentUpdate Method (ISimComponent)

Updates component to latest revision found from ecat.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent Update(
    ISimComponent component
)
ISimComponent^ Update(
    ISimComponent^ component
)

Parameters

component
Type: VisualComponents.Create3DISimComponent
Component to update.

Return Value

Type: ISimComponent
Updated component.
See Also

Reference

IAutosaveAgent Interface
Update Overload
VisualComponents.UX.Shared Namespace


IBackstageViewModel Interface

Defines the functionality that third parties have to implement for Backstage item plug in

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IBackstageViewModel : IScreen,
    IHaveDisplayName, IActivate, IDeactivate, IGuardClose, IClose,
    INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IBackstageViewModel : IScreen,
    IHaveDisplayName, IActivate, IDeactivate, IGuardClose, IClose,
    INotifyPropertyChangedEx, INotifyPropertyChanged

The IBackstageViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActiveViewModelAfterDeactivationHeader |
Public property | ContentViewModel |
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | Header |
Public property | HeaderType |
Public property | Id |
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | KeyTip | KeyTip defines the shortcut key for the backstage item which appears when users press Alt -key.
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | Show |
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IBackstageViewModel Properties

The IBackstageViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActiveViewModelAfterDeactivationHeader |
Public property | ContentViewModel |
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | Header |
Public property | HeaderType |
Public property | Id |
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | KeyTip | KeyTip defines the shortcut key for the backstage item which appears when users press Alt -key.
Top
See Also

Reference

IBackstageViewModel Interface
VisualComponents.UX.Shared Namespace


IBackstageViewModel.ActiveViewModelAfterDeactivationHeader Property

IBackstageViewModelActiveViewModelAfterDeactivationHeader Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ActiveViewModelAfterDeactivationHeader { get; }
property String^ ActiveViewModelAfterDeactivationHeader {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IBackstageViewModel Interface
VisualComponents.UX.Shared Namespace


IBackstageViewModel.ContentViewModel Property

IBackstageViewModelContentViewModel Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IBackstageViewModel ContentViewModel { get; }
property IBackstageViewModel^ ContentViewModel {
    IBackstageViewModel^ get ();
}

Property Value

Type: IBackstageViewModel
See Also

Reference

IBackstageViewModel Interface
VisualComponents.UX.Shared Namespace


IBackstageViewModel.Header Property

IBackstageViewModelHeader Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Header { get; }
property String^ Header {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IBackstageViewModel Interface
VisualComponents.UX.Shared Namespace


IBackstageViewModel.HeaderType Property

IBackstageViewModelHeaderType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
BackstageHeaderType HeaderType { get; }
property BackstageHeaderType HeaderType {
    BackstageHeaderType get ();
}

Property Value

Type: BackstageHeaderType
See Also

Reference

IBackstageViewModel Interface
VisualComponents.UX.Shared Namespace


IBackstageViewModel.Id Property

IBackstageViewModelId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Id { get; }
property String^ Id {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IBackstageViewModel Interface
VisualComponents.UX.Shared Namespace


IBackstageViewModel.KeyTip Property

IBackstageViewModelKeyTip Property

KeyTip defines the shortcut key for the backstage item which appears when users press Alt -key.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string KeyTip { get; }
property String^ KeyTip {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IBackstageViewModel Interface
VisualComponents.UX.Shared Namespace


IBackstageViewModel Methods

The IBackstageViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | Show |
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IBackstageViewModel Interface
VisualComponents.UX.Shared Namespace


IBackstageViewModel.Show Method

IBackstageViewModelShow Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Show()
void Show()
See Also

Reference

IBackstageViewModel Interface
VisualComponents.UX.Shared Namespace


IBackstageViewModel Events

The IBackstageViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IBackstageViewModel Interface
VisualComponents.UX.Shared Namespace


IBlockedRibbonItemsSection Interface

blocked items section

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IBlockedRibbonItemsSection
public interface class IBlockedRibbonItemsSection

The IBlockedRibbonItemsSection type exposes the following members.

Properties
 | Name | Description
Public property | BlockedNonRibbonControlItems |
Public property | BlockedPaneItems |
Public property | BlockedQuickMenuItems |
Public property | BlockedRibbonBackstageItems |
Public property | BlockedRibbonGroups |
Public property | BlockedRibbonTabs |
Public property | BlockedRibbonTools |
Public property | BlockedToolsNotInRibbonItems |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IBlockedRibbonItemsSection Properties

The IBlockedRibbonItemsSection type exposes the following members.

Properties
 | Name | Description
Public property | BlockedNonRibbonControlItems |
Public property | BlockedPaneItems |
Public property | BlockedQuickMenuItems |
Public property | BlockedRibbonBackstageItems |
Public property | BlockedRibbonGroups |
Public property | BlockedRibbonTabs |
Public property | BlockedRibbonTools |
Public property | BlockedToolsNotInRibbonItems |
Top
See Also

Reference

IBlockedRibbonItemsSection Interface
VisualComponents.UX.Shared Namespace


IBlockedRibbonItemsSection.BlockedNonRibbonControlItems Property

IBlockedRibbonItemsSectionBlockedNonRibbonControlItems Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
BlockedRibbonItemConfigCollection BlockedNonRibbonControlItems { get; }
property BlockedRibbonItemConfigCollection^ BlockedNonRibbonControlItems {
    BlockedRibbonItemConfigCollection^ get ();
}

Property Value

Type: BlockedRibbonItemConfigCollection
See Also

Reference

IBlockedRibbonItemsSection Interface
VisualComponents.UX.Shared Namespace


IBlockedRibbonItemsSection.BlockedPaneItems Property

IBlockedRibbonItemsSectionBlockedPaneItems Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
BlockedRibbonItemConfigCollection BlockedPaneItems { get; }
property BlockedRibbonItemConfigCollection^ BlockedPaneItems {
    BlockedRibbonItemConfigCollection^ get ();
}

Property Value

Type: BlockedRibbonItemConfigCollection
See Also

Reference

IBlockedRibbonItemsSection Interface
VisualComponents.UX.Shared Namespace


IBlockedRibbonItemsSection.BlockedQuickMenuItems Property

IBlockedRibbonItemsSectionBlockedQuickMenuItems Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
BlockedRibbonItemConfigCollection BlockedQuickMenuItems { get; }
property BlockedRibbonItemConfigCollection^ BlockedQuickMenuItems {
    BlockedRibbonItemConfigCollection^ get ();
}

Property Value

Type: BlockedRibbonItemConfigCollection
See Also

Reference

IBlockedRibbonItemsSection Interface
VisualComponents.UX.Shared Namespace


IBlockedRibbonItemsSection.BlockedRibbonBackstageItems Property

IBlockedRibbonItemsSectionBlockedRibbonBackstageItems Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
BlockedRibbonItemConfigCollection BlockedRibbonBackstageItems { get; }
property BlockedRibbonItemConfigCollection^ BlockedRibbonBackstageItems {
    BlockedRibbonItemConfigCollection^ get ();
}

Property Value

Type: BlockedRibbonItemConfigCollection
See Also

Reference

IBlockedRibbonItemsSection Interface
VisualComponents.UX.Shared Namespace


IBlockedRibbonItemsSection.BlockedRibbonGroups Property

IBlockedRibbonItemsSectionBlockedRibbonGroups Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
BlockedRibbonItemConfigCollection BlockedRibbonGroups { get; }
property BlockedRibbonItemConfigCollection^ BlockedRibbonGroups {
    BlockedRibbonItemConfigCollection^ get ();
}

Property Value

Type: BlockedRibbonItemConfigCollection
See Also

Reference

IBlockedRibbonItemsSection Interface
VisualComponents.UX.Shared Namespace


IBlockedRibbonItemsSection.BlockedRibbonTabs Property

IBlockedRibbonItemsSectionBlockedRibbonTabs Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
BlockedRibbonItemConfigCollection BlockedRibbonTabs { get; }
property BlockedRibbonItemConfigCollection^ BlockedRibbonTabs {
    BlockedRibbonItemConfigCollection^ get ();
}

Property Value

Type: BlockedRibbonItemConfigCollection
See Also

Reference

IBlockedRibbonItemsSection Interface
VisualComponents.UX.Shared Namespace


IBlockedRibbonItemsSection.BlockedRibbonTools Property

IBlockedRibbonItemsSectionBlockedRibbonTools Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
BlockedRibbonItemConfigCollection BlockedRibbonTools { get; }
property BlockedRibbonItemConfigCollection^ BlockedRibbonTools {
    BlockedRibbonItemConfigCollection^ get ();
}

Property Value

Type: BlockedRibbonItemConfigCollection
See Also

Reference

IBlockedRibbonItemsSection Interface
VisualComponents.UX.Shared Namespace


IBlockedRibbonItemsSection.BlockedToolsNotInRibbonItems Property

IBlockedRibbonItemsSectionBlockedToolsNotInRibbonItems Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
BlockedRibbonItemConfigCollection BlockedToolsNotInRibbonItems { get; }
property BlockedRibbonItemConfigCollection^ BlockedToolsNotInRibbonItems {
    BlockedRibbonItemConfigCollection^ get ();
}

Property Value

Type: BlockedRibbonItemConfigCollection
See Also

Reference

IBlockedRibbonItemsSection Interface
VisualComponents.UX.Shared Namespace


ICADAnalizeAction Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICADAnalizeAction
public interface class ICADAnalizeAction

The ICADAnalizeAction type exposes the following members.

Methods
 | Name | Description
Public method | AnalyzeAction |
Public method | IsFileSettingsSupported |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ICADAnalizeAction Methods

The ICADAnalizeAction type exposes the following members.

Methods
 | Name | Description
Public method | AnalyzeAction |
Public method | IsFileSettingsSupported |
Top
See Also

Reference

ICADAnalizeAction Interface
VisualComponents.UX.Shared Namespace


ICADAnalizeAction.AnalyzeAction Method

ICADAnalizeActionAnalyzeAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AnalyzeAction()
void AnalyzeAction()
See Also

Reference

ICADAnalizeAction Interface
VisualComponents.UX.Shared Namespace


ICADAnalizeAction.IsFileSettingsSupported Method

ICADAnalizeActionIsFileSettingsSupported Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsFileSettingsSupported(
    string uri
)
bool IsFileSettingsSupported(
    String^ uri
)

Parameters

uri
Type: SystemString

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ICADAnalizeAction.IsFileSettingsSupported(System.String)"]

See Also

Reference

ICADAnalizeAction Interface
VisualComponents.UX.Shared Namespace


ICADImportViewModel Interface

Todo: remove this kind of interfaces. We don't want to reference UI items directly.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICADImportViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class ICADImportViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The ICADImportViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ICADImportViewModel Properties

The ICADImportViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
See Also

Reference

ICADImportViewModel Interface
VisualComponents.UX.Shared Namespace


ICADImportViewModel Methods

The ICADImportViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

ICADImportViewModel Interface
VisualComponents.UX.Shared Namespace


ICADImportViewModel Events

The ICADImportViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

ICADImportViewModel Interface
VisualComponents.UX.Shared Namespace


ICADPresetsConfiguration Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICADPresetsConfiguration
public interface class ICADPresetsConfiguration

The ICADPresetsConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | Presets |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ICADPresetsConfiguration Properties

The ICADPresetsConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | Presets |
Top
See Also

Reference

ICADPresetsConfiguration Interface
VisualComponents.UX.Shared Namespace


ICADPresetsConfiguration.Presets Property

ICADPresetsConfigurationPresets Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
List<CadPresetConfigElement> Presets { get; }
property List<CadPresetConfigElement^>^ Presets {
    List<CadPresetConfigElement^>^ get ();
}

Property Value

Type: ListCadPresetConfigElement
See Also

Reference

ICADPresetsConfiguration Interface
VisualComponents.UX.Shared Namespace


ICellGraphViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICellGraphViewModel
public interface class ICellGraphViewModel
See Also

Reference

VisualComponents.UX.Shared Namespace


ICheckBoxToolCommand Interface

Implement for menu tools that use CheckBoxTool

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICheckBoxToolCommand
public interface class ICheckBoxToolCommand

The ICheckBoxToolCommand type exposes the following members.

Properties
 | Name | Description
Public property | IsChecked | Gets or sets if the check box is checked.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ICheckBoxToolCommand Properties

The ICheckBoxToolCommand type exposes the following members.

Properties
 | Name | Description
Public property | IsChecked | Gets or sets if the check box is checked.
Top
See Also

Reference

ICheckBoxToolCommand Interface
VisualComponents.UX.Shared Namespace


ICheckBoxToolCommand.IsChecked Property

ICheckBoxToolCommandIsChecked Property

Gets or sets if the check box is checked.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsChecked { get; set; }
property bool IsChecked {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ICheckBoxToolCommand Interface
VisualComponents.UX.Shared Namespace


IClipDataWithItems Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IClipDataWithItems
public interface class IClipDataWithItems

The IClipDataWithItems type exposes the following members.

Properties
 | Name | Description
Public property | HasItems |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IClipDataWithItems Properties

The IClipDataWithItems type exposes the following members.

Properties
 | Name | Description
Public property | HasItems |
Top
See Also

Reference

IClipDataWithItems Interface
VisualComponents.UX.Shared Namespace


IClipDataWithItems.HasItems Property

IClipDataWithItemsHasItems Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool HasItems { get; }
property bool HasItems {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IClipDataWithItems Interface
VisualComponents.UX.Shared Namespace


ICollisionDetectionEditAction Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICollisionDetectionEditAction
public interface class ICollisionDetectionEditAction

The ICollisionDetectionEditAction type exposes the following members.

Methods
 | Name | Description
Public method | StartAction |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ICollisionDetectionEditAction Methods

The ICollisionDetectionEditAction type exposes the following members.

Methods
 | Name | Description
Public method | StartAction |
Top
See Also

Reference

ICollisionDetectionEditAction Interface
VisualComponents.UX.Shared Namespace


ICollisionDetectionEditAction.StartAction Method

ICollisionDetectionEditActionStartAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StartAction(
    EventHandler<ResultCompletionEventArgs> completed,
    ICollisionDetector e
)
void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed,
    ICollisionDetector^ e
)

Parameters

completed
Type: SystemEventHandlerResultCompletionEventArgs
e
Type: VisualComponents.Create3DICollisionDetector
See Also

Reference

ICollisionDetectionEditAction Interface
VisualComponents.UX.Shared Namespace


ICollisionDetectionEditCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICollisionDetectionEditCommand
public interface class ICollisionDetectionEditCommand

The ICollisionDetectionEditCommand type exposes the following members.

Methods
 | Name | Description
Public method | Edit |
Public method | End |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ICollisionDetectionEditCommand Methods

The ICollisionDetectionEditCommand type exposes the following members.

Methods
 | Name | Description
Public method | Edit |
Public method | End |
Top
See Also

Reference

ICollisionDetectionEditCommand Interface
VisualComponents.UX.Shared Namespace


ICollisionDetectionEditCommand.Edit Method

ICollisionDetectionEditCommandEdit Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Edit(
    ICollisionDetector c
)
void Edit(
    ICollisionDetector^ c
)

Parameters

c
Type: VisualComponents.Create3DICollisionDetector
See Also

Reference

ICollisionDetectionEditCommand Interface
VisualComponents.UX.Shared Namespace


ICollisionDetectionEditCommand.End Method

ICollisionDetectionEditCommandEnd Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void End()
void End()
See Also

Reference

ICollisionDetectionEditCommand Interface
VisualComponents.UX.Shared Namespace


ICollisionDetectorEdit Interface

Collision edit view model interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICollisionDetectorEdit : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class ICollisionDetectorEdit : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The ICollisionDetectorEdit type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | AddSelectionToA |
Public method | AddSelectionToAB |
Public method | AddSelectionToB |
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | RemoveSelectionFromAll |
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ICollisionDetectorEdit Properties

The ICollisionDetectorEdit type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
See Also

Reference

ICollisionDetectorEdit Interface
VisualComponents.UX.Shared Namespace


ICollisionDetectorEdit Methods

The ICollisionDetectorEdit type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | AddSelectionToA |
Public method | AddSelectionToAB |
Public method | AddSelectionToB |
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | RemoveSelectionFromAll |
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

ICollisionDetectorEdit Interface
VisualComponents.UX.Shared Namespace


ICollisionDetectorEdit.AddSelectionToA Method

ICollisionDetectorEditAddSelectionToA Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddSelectionToA()
void AddSelectionToA()
See Also

Reference

ICollisionDetectorEdit Interface
VisualComponents.UX.Shared Namespace


ICollisionDetectorEdit.AddSelectionToAB Method

ICollisionDetectorEditAddSelectionToAB Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddSelectionToAB()
void AddSelectionToAB()
See Also

Reference

ICollisionDetectorEdit Interface
VisualComponents.UX.Shared Namespace


ICollisionDetectorEdit.AddSelectionToB Method

ICollisionDetectorEditAddSelectionToB Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddSelectionToB()
void AddSelectionToB()
See Also

Reference

ICollisionDetectorEdit Interface
VisualComponents.UX.Shared Namespace


ICollisionDetectorEdit.RemoveSelectionFromAll Method

ICollisionDetectorEditRemoveSelectionFromAll Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RemoveSelectionFromAll()
void RemoveSelectionFromAll()
See Also

Reference

ICollisionDetectorEdit Interface
VisualComponents.UX.Shared Namespace


ICollisionDetectorEdit Events

The ICollisionDetectorEdit type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

ICollisionDetectorEdit Interface
VisualComponents.UX.Shared Namespace


ICollisionOverrideViewModel Interface

Collision override view model interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICollisionOverrideViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class ICollisionOverrideViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The ICollisionOverrideViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ICollisionOverrideViewModel Properties

The ICollisionOverrideViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
See Also

Reference

ICollisionOverrideViewModel Interface
VisualComponents.UX.Shared Namespace


ICollisionOverrideViewModel Methods

The ICollisionOverrideViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

ICollisionOverrideViewModel Interface
VisualComponents.UX.Shared Namespace


ICollisionOverrideViewModel Events

The ICollisionOverrideViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

ICollisionOverrideViewModel Interface
VisualComponents.UX.Shared Namespace


ICollisionSettingsCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICollisionSettingsCommand
public interface class ICollisionSettingsCommand

The ICollisionSettingsCommand type exposes the following members.

Properties
 | Name | Description
Public property | IsOpen |
Top
Methods
 | Name | Description
Public method | Update |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ICollisionSettingsCommand Properties

The ICollisionSettingsCommand type exposes the following members.

Properties
 | Name | Description
Public property | IsOpen |
Top
See Also

Reference

ICollisionSettingsCommand Interface
VisualComponents.UX.Shared Namespace


ICollisionSettingsCommand.IsOpen Property

ICollisionSettingsCommandIsOpen Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsOpen { get; set; }
property bool IsOpen {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ICollisionSettingsCommand Interface
VisualComponents.UX.Shared Namespace


ICollisionSettingsCommand Methods

The ICollisionSettingsCommand type exposes the following members.

Methods
 | Name | Description
Public method | Update |
Top
See Also

Reference

ICollisionSettingsCommand Interface
VisualComponents.UX.Shared Namespace


ICollisionSettingsCommand.Update Method

ICollisionSettingsCommandUpdate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Update()
void Update()
See Also

Reference

ICollisionSettingsCommand Interface
VisualComponents.UX.Shared Namespace


ICollisionSettingsViewModel Interface

Collision settings view model interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICollisionSettingsViewModel
public interface class ICollisionSettingsViewModel

The ICollisionSettingsViewModel type exposes the following members.

Properties
 | Name | Description
Public property | CollisionSettingsCommand |
Top
Methods
 | Name | Description
Public method | Update |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ICollisionSettingsViewModel Properties

The ICollisionSettingsViewModel type exposes the following members.

Properties
 | Name | Description
Public property | CollisionSettingsCommand |
Top
See Also

Reference

ICollisionSettingsViewModel Interface
VisualComponents.UX.Shared Namespace


ICollisionSettingsViewModel.CollisionSettingsCommand Property

ICollisionSettingsViewModelCollisionSettingsCommand Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ICollisionSettingsCommand CollisionSettingsCommand { get; set; }
property ICollisionSettingsCommand^ CollisionSettingsCommand {
    ICollisionSettingsCommand^ get ();
    void set (ICollisionSettingsCommand^ value);
}

Property Value

Type: ICollisionSettingsCommand
See Also

Reference

ICollisionSettingsViewModel Interface
VisualComponents.UX.Shared Namespace


ICollisionSettingsViewModel Methods

The ICollisionSettingsViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Update |
Top
See Also

Reference

ICollisionSettingsViewModel Interface
VisualComponents.UX.Shared Namespace


ICollisionSettingsViewModel.Update Method

ICollisionSettingsViewModelUpdate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Update()
void Update()
See Also

Reference

ICollisionSettingsViewModel Interface
VisualComponents.UX.Shared Namespace


IComboEditorToolCommand Interface

Implement for commands that should be presented as menu tool / combobox.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IComboEditorToolCommand
public interface class IComboEditorToolCommand

The IComboEditorToolCommand type exposes the following members.

Properties
 | Name | Description
Public property | ComboItems | List of menu items.
Public property | SelectedComboItem | Selected item.
Top
Methods
 | Name | Description
Public method | Execute | Occurs when the selectedItem Changes
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IComboEditorToolCommand Properties

The IComboEditorToolCommand type exposes the following members.

Properties
 | Name | Description
Public property | ComboItems | List of menu items.
Public property | SelectedComboItem | Selected item.
Top
See Also

Reference

IComboEditorToolCommand Interface
VisualComponents.UX.Shared Namespace


IComboEditorToolCommand.ComboItems Property

IComboEditorToolCommandComboItems Property

List of menu items.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ObservableCollection<ComboItemBase> ComboItems { get; }
property ObservableCollection<ComboItemBase^>^ ComboItems {
    ObservableCollection<ComboItemBase^>^ get ();
}

Property Value

Type: ObservableCollectionComboItemBase
See Also

Reference

IComboEditorToolCommand Interface
VisualComponents.UX.Shared Namespace


IComboEditorToolCommand.SelectedComboItem Property

IComboEditorToolCommandSelectedComboItem Property

Selected item.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ComboItemBase SelectedComboItem { get; set; }
property ComboItemBase^ SelectedComboItem {
    ComboItemBase^ get ();
    void set (ComboItemBase^ value);
}

Property Value

Type: ComboItemBase
See Also

Reference

IComboEditorToolCommand Interface
VisualComponents.UX.Shared Namespace


IComboEditorToolCommand Methods

The IComboEditorToolCommand type exposes the following members.

Methods
 | Name | Description
Public method | Execute | Occurs when the selectedItem Changes
Top
See Also

Reference

IComboEditorToolCommand Interface
VisualComponents.UX.Shared Namespace


IComboEditorToolCommand.Execute Method

IComboEditorToolCommandExecute Method

Occurs when the selectedItem Changes

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Execute(
    RoutedPropertyChangedEventArgs<Object> e
)
void Execute(
    RoutedPropertyChangedEventArgs<Object^>^ e
)

Parameters

e
Type: System.WindowsRoutedPropertyChangedEventArgsObject
The event data.Provide data including the previous and current value of the property that changed.
See Also

Reference

IComboEditorToolCommand Interface
VisualComponents.UX.Shared Namespace


ICommandHostPanel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICommandHostPanel : INotifyPropertyChanged,
    IDockableScreen, IScreen, IHaveDisplayName, IActivate, IDeactivate,
    IGuardClose, IClose, INotifyPropertyChangedEx
public interface class ICommandHostPanel : INotifyPropertyChanged,
    IDockableScreen, IScreen, IHaveDisplayName, IActivate, IDeactivate,
    IGuardClose, IClose, INotifyPropertyChangedEx

The ICommandHostPanel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem |
Public property | ActiveViewItem |
Public property | ContextFilter | Gets or sets the context filter. The context defines one or more contexts where the panel is visible. (Inherited from IDockableScreen.)
Public property | DesiredPanePosition | Gets the desired pane position. If multiple panes are added, panes are ordered using this property. (Inherited from IDockableScreen.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | Height | Gets the Height of the pane. (Inherited from IDockableScreen.)
Public property | HorizontalScrollBarVisibility |
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsPinned | Gets or sets a Boolean value that indicates if the pane is pinned. (Inherited from IDockableScreen.)
Public property | IsSelected | Gets or sets a boolean value that indicates if the pane is selected in TabGroupPane (Inherited from IDockableScreen.)
Public property | IsVisible | Gets or sets a boolean value that indicates if the pane is visible (Inherited from IDockableScreen.)
Public property | PanelId | Gets the panel ID (Inherited from IDockableScreen.)
Public property | PaneLocation | Gets the desired panel location DesiredPaneLocation (Inherited from IDockableScreen.)
Public property | PaneOrientation | Gets the pane orientation (Inherited from IDockableScreen.)
Public property | SplitPaneId | Gets the split pane id. By default all panes within panel location use same split panel. Multiple split panels can be created by defining new split pane ids. (Inherited from IDockableScreen.)
 | TabGroupId | Gets the pane tab group id. Panes are splitted and ordered to different tabs within the splitpane based on TabGroupId. (Inherited from IDockableScreen.)
Public property | VerticalScrollBarVisibility |
Public property | Width | Gets the Width of the pane. (Inherited from IDockableScreen.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply |
Public method | Cancel |
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ICommandHostPanel Properties

The ICommandHostPanel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem |
Public property | ActiveViewItem |
Public property | ContextFilter | Gets or sets the context filter. The context defines one or more contexts where the panel is visible. (Inherited from IDockableScreen.)
Public property | DesiredPanePosition | Gets the desired pane position. If multiple panes are added, panes are ordered using this property. (Inherited from IDockableScreen.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | Height | Gets the Height of the pane. (Inherited from IDockableScreen.)
Public property | HorizontalScrollBarVisibility |
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsPinned | Gets or sets a Boolean value that indicates if the pane is pinned. (Inherited from IDockableScreen.)
Public property | IsSelected | Gets or sets a boolean value that indicates if the pane is selected in TabGroupPane (Inherited from IDockableScreen.)
Public property | IsVisible | Gets or sets a boolean value that indicates if the pane is visible (Inherited from IDockableScreen.)
Public property | PanelId | Gets the panel ID (Inherited from IDockableScreen.)
Public property | PaneLocation | Gets the desired panel location DesiredPaneLocation (Inherited from IDockableScreen.)
Public property | PaneOrientation | Gets the pane orientation (Inherited from IDockableScreen.)
Public property | SplitPaneId | Gets the split pane id. By default all panes within panel location use same split panel. Multiple split panels can be created by defining new split pane ids. (Inherited from IDockableScreen.)
 | TabGroupId | Gets the pane tab group id. Panes are splitted and ordered to different tabs within the splitpane based on TabGroupId. (Inherited from IDockableScreen.)
Public property | VerticalScrollBarVisibility |
Public property | Width | Gets the Width of the pane. (Inherited from IDockableScreen.)
Top
See Also

Reference

ICommandHostPanel Interface
VisualComponents.UX.Shared Namespace


ICommandHostPanel.ActionItem Property

ICommandHostPanelActionItem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ICommandPanelAction ActionItem { get; }
property ICommandPanelAction^ ActionItem {
    ICommandPanelAction^ get ();
}

Property Value

Type: ICommandPanelAction
See Also

Reference

ICommandHostPanel Interface
VisualComponents.UX.Shared Namespace


ICommandHostPanel.ActiveViewItem Property

ICommandHostPanelActiveViewItem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ICommandViewModel ActiveViewItem { get; }
property ICommandViewModel^ ActiveViewItem {
    ICommandViewModel^ get ();
}

Property Value

Type: ICommandViewModel
See Also

Reference

ICommandHostPanel Interface
VisualComponents.UX.Shared Namespace


ICommandHostPanel.HorizontalScrollBarVisibility Property

ICommandHostPanelHorizontalScrollBarVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ScrollBarVisibility HorizontalScrollBarVisibility { get; set; }
property ScrollBarVisibility HorizontalScrollBarVisibility {
    ScrollBarVisibility get ();
    void set (ScrollBarVisibility value);
}

Property Value

Type: ScrollBarVisibility
See Also

Reference

ICommandHostPanel Interface
VisualComponents.UX.Shared Namespace


ICommandHostPanel.VerticalScrollBarVisibility Property

ICommandHostPanelVerticalScrollBarVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ScrollBarVisibility VerticalScrollBarVisibility { get; set; }
property ScrollBarVisibility VerticalScrollBarVisibility {
    ScrollBarVisibility get ();
    void set (ScrollBarVisibility value);
}

Property Value

Type: ScrollBarVisibility
See Also

Reference

ICommandHostPanel Interface
VisualComponents.UX.Shared Namespace


ICommandHostPanel Methods

The ICommandHostPanel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply |
Public method | Cancel |
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

ICommandHostPanel Interface
VisualComponents.UX.Shared Namespace


ICommandHostPanel.Apply Method

ICommandHostPanelApply Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Apply()
void Apply()
See Also

Reference

ICommandHostPanel Interface
VisualComponents.UX.Shared Namespace


ICommandHostPanel.Cancel Method

ICommandHostPanelCancel Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Cancel()
void Cancel()
See Also

Reference

ICommandHostPanel Interface
VisualComponents.UX.Shared Namespace


ICommandHostPanel Events

The ICommandHostPanel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

ICommandHostPanel Interface
VisualComponents.UX.Shared Namespace


ICommandPanelAction Interface

Provides panel UI data for commands to are executed in action panel.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICommandPanelAction
public interface class ICommandPanelAction

The ICommandPanelAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active.
Public property | ActionProperties | Action properties
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel.
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate.
Public property | CallingCommandName | If launched from Python script the name of the calling python command.
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction
Public property | Description | Long description of what this action does. This text is dislayed along side of image.
Public property | ErrorMessage | Error message
Public property | Title | String that is shown in action panel title.
Top
Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel.
Public method | CancelAction |
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ICommandPanelAction Properties

The ICommandPanelAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active.
Public property | ActionProperties | Action properties
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel.
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate.
Public property | CallingCommandName | If launched from Python script the name of the calling python command.
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction
Public property | Description | Long description of what this action does. This text is dislayed along side of image.
Public property | ErrorMessage | Error message
Public property | Title | String that is shown in action panel title.
Top
See Also

Reference

ICommandPanelAction Interface
VisualComponents.UX.Shared Namespace


ICommandPanelAction.ActionFinished Property

ICommandPanelActionActionFinished Property

Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ActionFinished { get; }
property bool ActionFinished {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ICommandPanelAction Interface
VisualComponents.UX.Shared Namespace


ICommandPanelAction.ActionProperties Property

ICommandPanelActionActionProperties Property

Action properties

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
List<IProperty> ActionProperties { get; }
property List<IProperty^>^ ActionProperties {
    List<IProperty^>^ get ();
}

Property Value

Type: ListIProperty
See Also

Reference

ICommandPanelAction Interface
VisualComponents.UX.Shared Namespace


ICommandPanelAction.ApplyButtonText Property

ICommandPanelActionApplyButtonText Property

String that is shown in the button that triggers the ApplyAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ApplyButtonText { get; }
property String^ ApplyButtonText {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ICommandPanelAction Interface
VisualComponents.UX.Shared Namespace


ICommandPanelAction.AssociatedModelId Property

ICommandPanelActionAssociatedModelId Property

Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string AssociatedModelId { get; }
property String^ AssociatedModelId {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ICommandPanelAction Interface
VisualComponents.UX.Shared Namespace


ICommandPanelAction.AssociatedSiteId Property

ICommandPanelActionAssociatedSiteId Property

Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string AssociatedSiteId { get; }
property String^ AssociatedSiteId {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ICommandPanelAction Interface
VisualComponents.UX.Shared Namespace


ICommandPanelAction.CallingCommandName Property

ICommandPanelActionCallingCommandName Property

If launched from Python script the name of the calling python command.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string CallingCommandName { get; }
property String^ CallingCommandName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ICommandPanelAction Interface
VisualComponents.UX.Shared Namespace


ICommandPanelAction.CancelButtonText Property

ICommandPanelActionCancelButtonText Property

String that is shown in the button that triggers the CancelAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string CancelButtonText { get; }
property String^ CancelButtonText {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ICommandPanelAction Interface
VisualComponents.UX.Shared Namespace


ICommandPanelAction.Description Property

ICommandPanelActionDescription Property

Long description of what this action does. This text is dislayed along side of image.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Description { get; }
property String^ Description {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ICommandPanelAction Interface
VisualComponents.UX.Shared Namespace


ICommandPanelAction.ErrorMessage Property

ICommandPanelActionErrorMessage Property

Error message

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ErrorMessage { get; }
property String^ ErrorMessage {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ICommandPanelAction Interface
VisualComponents.UX.Shared Namespace


ICommandPanelAction.Title Property

ICommandPanelActionTitle Property

String that is shown in action panel title.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Title { get; }
property String^ Title {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ICommandPanelAction Interface
VisualComponents.UX.Shared Namespace


ICommandPanelAction Methods

The ICommandPanelAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel.
Public method | CancelAction |
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions.
Top
See Also

Reference

ICommandPanelAction Interface
VisualComponents.UX.Shared Namespace


ICommandPanelAction.ApplyAction Method

ICommandPanelActionApplyAction Method

Executes command. Returning true will close the action panel.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ApplyAction()
bool ApplyAction()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ICommandPanelAction.ApplyAction"]

See Also

Reference

ICommandPanelAction Interface
VisualComponents.UX.Shared Namespace


ICommandPanelAction.CancelAction Method

ICommandPanelActionCancelAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void CancelAction()
void CancelAction()
See Also

Reference

ICommandPanelAction Interface
VisualComponents.UX.Shared Namespace


ICommandPanelAction.StartAction Method

ICommandPanelActionStartAction Method

Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StartAction(
    EventHandler<ResultCompletionEventArgs> completed = null
)
void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr
)

Parameters

completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs
See Also

Reference

ICommandPanelAction Interface
VisualComponents.UX.Shared Namespace


ICommandPanelAction2 Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICommandPanelAction2 : ICommandPanelAction
public interface class ICommandPanelAction2 : ICommandPanelAction

The ICommandPanelAction2 type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CanApply |
Public property | CanCancel |
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Top
Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ICommandPanelAction2 Properties

The ICommandPanelAction2 type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CanApply |
Public property | CanCancel |
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

ICommandPanelAction2 Interface
VisualComponents.UX.Shared Namespace


ICommandPanelAction2.CanApply Property

ICommandPanelAction2CanApply Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanApply { get; }
property bool CanApply {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ICommandPanelAction2 Interface
VisualComponents.UX.Shared Namespace


ICommandPanelAction2.CanCancel Property

ICommandPanelAction2CanCancel Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanCancel { get; }
property bool CanCancel {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ICommandPanelAction2 Interface
VisualComponents.UX.Shared Namespace


ICommandPanelAction2 Methods

The ICommandPanelAction2 type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

ICommandPanelAction2 Interface
VisualComponents.UX.Shared Namespace


ICommandRegistry Interface

CommandRegistery is a repository for .NET commands.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICommandRegistry : INotifyPropertyChangedEx,
    INotifyPropertyChanged, ICommandExecution
public interface class ICommandRegistry : INotifyPropertyChangedEx,
    INotifyPropertyChanged, ICommandExecution

The ICommandRegistry type exposes the following members.

Properties
 | Name | Description
Public property | Actions | Gets all the available actions.
Public property | CommandPanelActions | Command panel actions that are currently active. Usually there's only one.
Public property | CommandPanels |
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Top
Methods
 | Name | Description
Public method | ExecuteAction(String) | Executes action/command. Note: ICommandRegistry.Actions are actually commands, ie classes using naming convetion "*Command.cs". Note: this method doesn't call BeforeExecute(). (Inherited from ICommandExecution.)
Public method | ExecuteAction(String, PropertyCollection) | (Inherited from ICommandExecution.)
Public method | ExecuteAction(String, SetupPythonActionMessage) | Obsolete.
Public method | ExecuteAction(String, Boolean, Boolean) |
Public method | ExecuteInPanel | (Inherited from ICommandExecution.)
Public method | FindCommandPanelActionT | Find command panel action of specific class, but only if it's active.
Public method | FindCommandPanelActionByCommand | Find command panel action by command that executed it.
Public method | FindCommandPanelViewModelT | Find command panel view model of specific class, but only if it's active.
Public method | FindItem | Return ActionItem for given key.
Public method | NotifyCommandPanelActionChange | This is typically called by StartCommandPanelAction_Completed. Idea is to keep CommandPanelActions populated as long as possible, so that completed-handlers have access to finished action. Note: This function can also be called individual actions, after their Completed-event was triggered and ActionFinished flag is false. This is useful when action is started without StartCommandPanelAction.
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | RegisterActionItem(IActionItem) | Registers actionitem without adding it to configuration.
Public method | RegisterActionItem(IActionItem, UXSiteSetup) | Registers actionitem.
Public method | RegisterActionItem(IActionItem, UXSiteSetup, Int32) | Registers actionitem at certain index position.
Public method | RegisterActionItem(IActionItem, UXSiteSetup, String, Int32) | Registers actionitem next to referenced item at certain offset position. ///
Public method | StartCommandPanelAction | This will register this command as "CommandPanelActions" in command registry.
Public method | UnRegisterActionItem(IActionItem) | Removes action item from ux configuration and removes it from the command registry
Public method | UnRegisterActionItem(IActionItem, Boolean) | Removes action item from ux configuration
Top
Events
 | Name | Description
Public event | ActionsCollectionChanged | Occurs when action item gets registered or unregistered.
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ICommandRegistry Properties

The ICommandRegistry type exposes the following members.

Properties
 | Name | Description
Public property | Actions | Gets all the available actions.
Public property | CommandPanelActions | Command panel actions that are currently active. Usually there's only one.
Public property | CommandPanels |
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Top
See Also

Reference

ICommandRegistry Interface
VisualComponents.UX.Shared Namespace


ICommandRegistry.Actions Property

ICommandRegistryActions Property

Gets all the available actions.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyCollection<IActionItem> Actions { get; }
property IReadOnlyCollection<IActionItem^>^ Actions {
    IReadOnlyCollection<IActionItem^>^ get ();
}

Property Value

Type: IReadOnlyCollectionIActionItem
See Also

Reference

ICommandRegistry Interface
VisualComponents.UX.Shared Namespace


ICommandRegistry.CommandPanelActions Property

ICommandRegistryCommandPanelActions Property

Command panel actions that are currently active. Usually there's only one.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ICommandPanelAction[] CommandPanelActions { get; }
property array<ICommandPanelAction^>^ CommandPanelActions {
    array<ICommandPanelAction^>^ get ();
}

Property Value

Type: ICommandPanelAction
See Also

Reference

ICommandRegistry Interface
VisualComponents.UX.Shared Namespace


ICommandRegistry.CommandPanels Property

ICommandRegistryCommandPanels Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ICommandHostPanel[] CommandPanels { get; }
property array<ICommandHostPanel^>^ CommandPanels {
    array<ICommandHostPanel^>^ get ();
}

Property Value

Type: ICommandHostPanel
See Also

Reference

ICommandRegistry Interface
VisualComponents.UX.Shared Namespace


ICommandRegistry Methods

The ICommandRegistry type exposes the following members.

Methods
 | Name | Description
Public method | ExecuteAction(String) | Executes action/command. Note: ICommandRegistry.Actions are actually commands, ie classes using naming convetion "*Command.cs". Note: this method doesn't call BeforeExecute(). (Inherited from ICommandExecution.)
Public method | ExecuteAction(String, PropertyCollection) | (Inherited from ICommandExecution.)
Public method | ExecuteAction(String, SetupPythonActionMessage) | Obsolete.
Public method | ExecuteAction(String, Boolean, Boolean) |
Public method | ExecuteInPanel | (Inherited from ICommandExecution.)
Public method | FindCommandPanelActionT | Find command panel action of specific class, but only if it's active.
Public method | FindCommandPanelActionByCommand | Find command panel action by command that executed it.
Public method | FindCommandPanelViewModelT | Find command panel view model of specific class, but only if it's active.
Public method | FindItem | Return ActionItem for given key.
Public method | NotifyCommandPanelActionChange | This is typically called by StartCommandPanelAction_Completed. Idea is to keep CommandPanelActions populated as long as possible, so that completed-handlers have access to finished action. Note: This function can also be called individual actions, after their Completed-event was triggered and ActionFinished flag is false. This is useful when action is started without StartCommandPanelAction.
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | RegisterActionItem(IActionItem) | Registers actionitem without adding it to configuration.
Public method | RegisterActionItem(IActionItem, UXSiteSetup) | Registers actionitem.
Public method | RegisterActionItem(IActionItem, UXSiteSetup, Int32) | Registers actionitem at certain index position.
Public method | RegisterActionItem(IActionItem, UXSiteSetup, String, Int32) | Registers actionitem next to referenced item at certain offset position. ///
Public method | StartCommandPanelAction | This will register this command as "CommandPanelActions" in command registry.
Public method | UnRegisterActionItem(IActionItem) | Removes action item from ux configuration and removes it from the command registry
Public method | UnRegisterActionItem(IActionItem, Boolean) | Removes action item from ux configuration
Top
See Also

Reference

ICommandRegistry Interface
VisualComponents.UX.Shared Namespace


ICommandRegistry.ExecuteAction Method

ICommandRegistryExecuteAction Method

Overload List
 | Name | Description
Public method | ExecuteAction(String) | Executes action/command. Note: ICommandRegistry.Actions are actually commands, ie classes using naming convetion "*Command.cs". Note: this method doesn't call BeforeExecute(). (Inherited from ICommandExecution.)
Public method | ExecuteAction(String, PropertyCollection) | (Inherited from ICommandExecution.)
Public method | ExecuteAction(String, SetupPythonActionMessage) | Obsolete.
Public method | ExecuteAction(String, Boolean, Boolean) |
Top
See Also

Reference

ICommandRegistry Interface
VisualComponents.UX.Shared Namespace


ICommandRegistry.ExecuteAction Method (String, SetupPythonActionMessage)

ICommandRegistryExecuteAction Method (String, SetupPythonActionMessage)

Note: This API is now obsolete.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute]
void ExecuteAction(
    string key,
    SetupPythonActionMessage pythonSetup
)
[ObsoleteAttribute]
void ExecuteAction(
    String^ key,
    SetupPythonActionMessage^ pythonSetup
)

Parameters

key
Type: SystemString
pythonSetup
Type: VisualComponents.Create3DSetupPythonActionMessage
See Also

Reference

ICommandRegistry Interface
ExecuteAction Overload
VisualComponents.UX.Shared Namespace


ICommandRegistry.ExecuteAction Method (String, Boolean, Boolean)

ICommandRegistryExecuteAction Method (String, Boolean, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ExecuteAction(
    string key,
    bool stopActive,
    bool checkCanExecute
)
void ExecuteAction(
    String^ key,
    bool stopActive,
    bool checkCanExecute
)

Parameters

key
Type: SystemString
stopActive
Type: SystemBoolean
checkCanExecute
Type: SystemBoolean
See Also

Reference

ICommandRegistry Interface
ExecuteAction Overload
VisualComponents.UX.Shared Namespace


ICommandRegistry.FindCommandPanelAction(T) Method

ICommandRegistryFindCommandPanelActionT Method

Find command panel action of specific class, but only if it's active.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
T FindCommandPanelAction<T>()

generic<typename T>
T FindCommandPanelAction()

Type Parameters

T

Return Value

Type: T

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ICommandRegistry.FindCommandPanelAction``1"]

See Also

Reference

ICommandRegistry Interface
VisualComponents.UX.Shared Namespace


ICommandRegistry.FindCommandPanelActionByCommand Method

ICommandRegistryFindCommandPanelActionByCommand Method

Find command panel action by command that executed it.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ICommandPanelAction FindCommandPanelActionByCommand(
    IActionItem command
)
ICommandPanelAction^ FindCommandPanelActionByCommand(
    IActionItem^ command
)

Parameters

command
Type: VisualComponents.UX.SharedIActionItem

Return Value

Type: ICommandPanelAction

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ICommandRegistry.FindCommandPanelActionByCommand(VisualComponents.UX.Shared.IActionItem)"]

See Also

Reference

ICommandRegistry Interface
VisualComponents.UX.Shared Namespace


ICommandRegistry.FindCommandPanelViewModel(T) Method

ICommandRegistryFindCommandPanelViewModelT Method

Find command panel view model of specific class, but only if it's active.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
T FindCommandPanelViewModel<T>()

generic<typename T>
T FindCommandPanelViewModel()

Type Parameters

T

Return Value

Type: T

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ICommandRegistry.FindCommandPanelViewModel``1"]

See Also

Reference

ICommandRegistry Interface
VisualComponents.UX.Shared Namespace


ICommandRegistry.FindItem Method

ICommandRegistryFindItem Method

Return ActionItem for given key.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IActionItem FindItem(
    string key
)
IActionItem^ FindItem(
    String^ key
)

Parameters

key
Type: SystemString

Return Value

Type: IActionItem

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ICommandRegistry.FindItem(System.String)"]

Remarks
Returns null if no action was found.
See Also

Reference

ICommandRegistry Interface
VisualComponents.UX.Shared Namespace


ICommandRegistry.NotifyCommandPanelActionChange Method

ICommandRegistryNotifyCommandPanelActionChange Method

This is typically called by StartCommandPanelAction_Completed. Idea is to keep CommandPanelActions populated as long as possible, so that completed-handlers have access to finished action. Note: This function can also be called individual actions, after their Completed-event was triggered and ActionFinished flag is false. This is useful when action is started without StartCommandPanelAction.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void NotifyCommandPanelActionChange()
void NotifyCommandPanelActionChange()
See Also

Reference

ICommandRegistry Interface
VisualComponents.UX.Shared Namespace


ICommandRegistry.RegisterActionItem Method

ICommandRegistryRegisterActionItem Method

Overload List
 | Name | Description
Public method | RegisterActionItem(IActionItem) | Registers actionitem without adding it to configuration.
Public method | RegisterActionItem(IActionItem, UXSiteSetup) | Registers actionitem.
Public method | RegisterActionItem(IActionItem, UXSiteSetup, Int32) | Registers actionitem at certain index position.
Public method | RegisterActionItem(IActionItem, UXSiteSetup, String, Int32) | Registers actionitem next to referenced item at certain offset position. ///
Top
See Also

Reference

ICommandRegistry Interface
VisualComponents.UX.Shared Namespace


ICommandRegistry.RegisterActionItem Method (IActionItem)

ICommandRegistryRegisterActionItem Method (IActionItem)

Registers actionitem without adding it to configuration.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RegisterActionItem(
    IActionItem actionItem
)
void RegisterActionItem(
    IActionItem^ actionItem
)

Parameters

actionItem
Type: VisualComponents.UX.SharedIActionItem
See Also

Reference

ICommandRegistry Interface
RegisterActionItem Overload
VisualComponents.UX.Shared Namespace


ICommandRegistry.RegisterActionItem Method (IActionItem, UXSiteSetup)

ICommandRegistryRegisterActionItem Method (IActionItem, UXSiteSetup)

Registers actionitem.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RegisterActionItem(
    IActionItem actionItem,
    UXSiteSetup setup
)
void RegisterActionItem(
    IActionItem^ actionItem,
    UXSiteSetup^ setup
)

Parameters

actionItem
Type: VisualComponents.UX.SharedIActionItem
setup
Type: VisualComponents.UX.SharedUXSiteSetup
See Also

Reference

ICommandRegistry Interface
RegisterActionItem Overload
VisualComponents.UX.Shared Namespace


ICommandRegistry.RegisterActionItem Method (IActionItem, UXSiteSetup, Int32)

ICommandRegistryRegisterActionItem Method (IActionItem, UXSiteSetup, Int32)

Registers actionitem at certain index position.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RegisterActionItem(
    IActionItem actionItem,
    UXSiteSetup setup,
    int index
)
void RegisterActionItem(
    IActionItem^ actionItem,
    UXSiteSetup^ setup,
    int index
)

Parameters

actionItem
Type: VisualComponents.UX.SharedIActionItem
setup
Type: VisualComponents.UX.SharedUXSiteSetup
index
Type: SystemInt32
See Also

Reference

ICommandRegistry Interface
RegisterActionItem Overload
VisualComponents.UX.Shared Namespace


ICommandRegistry.RegisterActionItem Method (IActionItem, UXSiteSetup, String, Int32)

ICommandRegistryRegisterActionItem Method (IActionItem, UXSiteSetup, String, Int32)

Registers actionitem next to referenced item at certain offset position. ///

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RegisterActionItem(
    IActionItem actionItem,
    UXSiteSetup setup,
    string referenceId,
    int index
)
void RegisterActionItem(
    IActionItem^ actionItem,
    UXSiteSetup^ setup,
    String^ referenceId,
    int index
)

Parameters

actionItem
Type: VisualComponents.UX.SharedIActionItem
setup
Type: VisualComponents.UX.SharedUXSiteSetup
referenceId
Type: SystemString
index
Type: SystemInt32
See Also

Reference

ICommandRegistry Interface
RegisterActionItem Overload
VisualComponents.UX.Shared Namespace


ICommandRegistry.StartCommandPanelAction Method

ICommandRegistryStartCommandPanelAction Method

This will register this command as "CommandPanelActions" in command registry.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StartCommandPanelAction(
    IActionItem command,
    ICommandPanelAction action,
    EventHandler<ResultCompletionEventArgs> completed = null
)
void StartCommandPanelAction(
    IActionItem^ command,
    ICommandPanelAction^ action,
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr
)

Parameters

command
Type: VisualComponents.UX.SharedIActionItem
action
Type: VisualComponents.UX.SharedICommandPanelAction
completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs
See Also

Reference

ICommandRegistry Interface
VisualComponents.UX.Shared Namespace


ICommandRegistry.UnRegisterActionItem Method

ICommandRegistryUnRegisterActionItem Method

Overload List
 | Name | Description
Public method | UnRegisterActionItem(IActionItem) | Removes action item from ux configuration and removes it from the command registry
Public method | UnRegisterActionItem(IActionItem, Boolean) | Removes action item from ux configuration
Top
See Also

Reference

ICommandRegistry Interface
VisualComponents.UX.Shared Namespace


ICommandRegistry.UnRegisterActionItem Method (IActionItem)

ICommandRegistryUnRegisterActionItem Method (IActionItem)

Removes action item from ux configuration and removes it from the command registry

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UnRegisterActionItem(
    IActionItem actionItem
)
void UnRegisterActionItem(
    IActionItem^ actionItem
)

Parameters

actionItem
Type: VisualComponents.UX.SharedIActionItem
Action item to be unregistered
See Also

Reference

ICommandRegistry Interface
UnRegisterActionItem Overload
VisualComponents.UX.Shared Namespace


ICommandRegistry.UnRegisterActionItem Method (IActionItem, Boolean)

ICommandRegistryUnRegisterActionItem Method (IActionItem, Boolean)

Removes action item from ux configuration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UnRegisterActionItem(
    IActionItem actionItem,
    bool removeItem
)
void UnRegisterActionItem(
    IActionItem^ actionItem,
    bool removeItem
)

Parameters

actionItem
Type: VisualComponents.UX.SharedIActionItem
Action item to be unregistered
removeItem
Type: SystemBoolean
True if the action item is removed from the registry.
See Also

Reference

ICommandRegistry Interface
UnRegisterActionItem Overload
VisualComponents.UX.Shared Namespace


ICommandRegistry Events

The ICommandRegistry type exposes the following members.

Events
 | Name | Description
Public event | ActionsCollectionChanged | Occurs when action item gets registered or unregistered.
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

ICommandRegistry Interface
VisualComponents.UX.Shared Namespace


ICommandRegistry.ActionsCollectionChanged Event

ICommandRegistryActionsCollectionChanged Event

Occurs when action item gets registered or unregistered.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler ActionsCollectionChanged
 event EventHandler^ ActionsCollectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ICommandRegistry Interface
VisualComponents.UX.Shared Namespace


ICommandViewModel Interface

Command view model interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICommandViewModel : IScreen,
    IHaveDisplayName, IActivate, IDeactivate, IGuardClose, IClose,
    INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class ICommandViewModel : IScreen,
    IHaveDisplayName, IActivate, IDeactivate, IGuardClose, IClose,
    INotifyPropertyChangedEx, INotifyPropertyChanged

The ICommandViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item
Public property | AssociatedCommandId | Id of command.
Public property | Description | Localized description shown in the help area of command panel.
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel.
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel.
Public method | Cancel | Cancels command execution.
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ICommandViewModel Properties

The ICommandViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item
Public property | AssociatedCommandId | Id of command.
Public property | Description | Localized description shown in the help area of command panel.
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel.
Top
See Also

Reference

ICommandViewModel Interface
VisualComponents.UX.Shared Namespace


ICommandViewModel.ActionItem Property

ICommandViewModelActionItem Property

Action item

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ICommandPanelAction ActionItem { get; set; }
property ICommandPanelAction^ ActionItem {
    ICommandPanelAction^ get ();
    void set (ICommandPanelAction^ value);
}

Property Value

Type: ICommandPanelAction
See Also

Reference

ICommandViewModel Interface
VisualComponents.UX.Shared Namespace


ICommandViewModel.AssociatedCommandId Property

ICommandViewModelAssociatedCommandId Property

Id of command.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string AssociatedCommandId { get; }
property String^ AssociatedCommandId {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ICommandViewModel Interface
VisualComponents.UX.Shared Namespace


ICommandViewModel.Description Property

ICommandViewModelDescription Property

Localized description shown in the help area of command panel.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Description { get; }
property String^ Description {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ICommandViewModel Interface
VisualComponents.UX.Shared Namespace


ICommandViewModel.Title Property

ICommandViewModelTitle Property

Localized title shown in title area of command panel.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Title { get; }
property String^ Title {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ICommandViewModel Interface
VisualComponents.UX.Shared Namespace


ICommandViewModel Methods

The ICommandViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel.
Public method | Cancel | Cancels command execution.
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

ICommandViewModel Interface
VisualComponents.UX.Shared Namespace


ICommandViewModel.Apply Method

ICommandViewModelApply Method

Executes command. Returning true will close the action panel.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool Apply()
bool Apply()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ICommandViewModel.Apply"]

See Also

Reference

ICommandViewModel Interface
VisualComponents.UX.Shared Namespace


ICommandViewModel.Cancel Method

ICommandViewModelCancel Method

Cancels command execution.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Cancel()
void Cancel()
See Also

Reference

ICommandViewModel Interface
VisualComponents.UX.Shared Namespace


ICommandViewModel Events

The ICommandViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

ICommandViewModel Interface
VisualComponents.UX.Shared Namespace


IComponentEditorExViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IComponentEditorExViewModel : IDockableScreen,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IComponentEditorExViewModel : IDockableScreen,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The IComponentEditorExViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActivePropertyEditor | Provides access to active property editor.
Public property | ContextFilter | Gets or sets the context filter. The context defines one or more contexts where the panel is visible. (Inherited from IDockableScreen.)
Public property | DefaultPropertyEditor | Provides access to default property editor.
Public property | DesiredPanePosition | Gets the desired pane position. If multiple panes are added, panes are ordered using this property. (Inherited from IDockableScreen.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | Height | Gets the Height of the pane. (Inherited from IDockableScreen.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsPinned | Gets or sets a Boolean value that indicates if the pane is pinned. (Inherited from IDockableScreen.)
Public property | IsSelected | Gets or sets a boolean value that indicates if the pane is selected in TabGroupPane (Inherited from IDockableScreen.)
Public property | IsVisible | Gets or sets a boolean value that indicates if the pane is visible (Inherited from IDockableScreen.)
Public property | PanelId | Gets the panel ID (Inherited from IDockableScreen.)
Public property | PaneLocation | Gets the desired panel location DesiredPaneLocation (Inherited from IDockableScreen.)
Public property | PaneOrientation | Gets the pane orientation (Inherited from IDockableScreen.)
Public property | PaneToReactivate | Allows children to prevent the panel from deactivating (when unpinned) during some actions that can fire ContentVisibleResolvedValueChanged.
Public property | SelectedObject | Note: when ManipulateViewModel.Target.PivotObject is Dof this points to ISimNode object.
Public property | SelectedPhysicsRope | Obsolete.
Public property | SelectedPhysicsRopePin | Obsolete.
Public property | Selection | Normally equals to ISelectionManager.GetAllSelected() list.
Public property | SplitPaneId | Gets the split pane id. By default all panes within panel location use same split panel. Multiple split panels can be created by defining new split pane ids. (Inherited from IDockableScreen.)
Public property | SuspendDisposal | Allows children to prevent the panel from deactivating (when unpinned) during some 3D-world related actions, such as the PickValueFrom3DWorld.
 | TabGroupId | Gets the pane tab group id. Panes are splitted and ordered to different tabs within the splitpane based on TabGroupId. (Inherited from IDockableScreen.)
Public property | Width | Gets the Width of the pane. (Inherited from IDockableScreen.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Public method | Update |
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IComponentEditorExViewModel Properties

The IComponentEditorExViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActivePropertyEditor | Provides access to active property editor.
Public property | ContextFilter | Gets or sets the context filter. The context defines one or more contexts where the panel is visible. (Inherited from IDockableScreen.)
Public property | DefaultPropertyEditor | Provides access to default property editor.
Public property | DesiredPanePosition | Gets the desired pane position. If multiple panes are added, panes are ordered using this property. (Inherited from IDockableScreen.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | Height | Gets the Height of the pane. (Inherited from IDockableScreen.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsPinned | Gets or sets a Boolean value that indicates if the pane is pinned. (Inherited from IDockableScreen.)
Public property | IsSelected | Gets or sets a boolean value that indicates if the pane is selected in TabGroupPane (Inherited from IDockableScreen.)
Public property | IsVisible | Gets or sets a boolean value that indicates if the pane is visible (Inherited from IDockableScreen.)
Public property | PanelId | Gets the panel ID (Inherited from IDockableScreen.)
Public property | PaneLocation | Gets the desired panel location DesiredPaneLocation (Inherited from IDockableScreen.)
Public property | PaneOrientation | Gets the pane orientation (Inherited from IDockableScreen.)
Public property | PaneToReactivate | Allows children to prevent the panel from deactivating (when unpinned) during some actions that can fire ContentVisibleResolvedValueChanged.
Public property | SelectedObject | Note: when ManipulateViewModel.Target.PivotObject is Dof this points to ISimNode object.
Public property | SelectedPhysicsRope | Obsolete.
Public property | SelectedPhysicsRopePin | Obsolete.
Public property | Selection | Normally equals to ISelectionManager.GetAllSelected() list.
Public property | SplitPaneId | Gets the split pane id. By default all panes within panel location use same split panel. Multiple split panels can be created by defining new split pane ids. (Inherited from IDockableScreen.)
Public property | SuspendDisposal | Allows children to prevent the panel from deactivating (when unpinned) during some 3D-world related actions, such as the PickValueFrom3DWorld.
 | TabGroupId | Gets the pane tab group id. Panes are splitted and ordered to different tabs within the splitpane based on TabGroupId. (Inherited from IDockableScreen.)
Public property | Width | Gets the Width of the pane. (Inherited from IDockableScreen.)
Top
See Also

Reference

IComponentEditorExViewModel Interface
VisualComponents.UX.Shared Namespace


IComponentEditorExViewModel.ActivePropertyEditor Property

IComponentEditorExViewModelActivePropertyEditor Property

Provides access to active property editor.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPropertyEditor ActivePropertyEditor { get; }
property IPropertyEditor^ ActivePropertyEditor {
    IPropertyEditor^ get ();
}

Property Value

Type: IPropertyEditor
See Also

Reference

IComponentEditorExViewModel Interface
VisualComponents.UX.Shared Namespace


IComponentEditorExViewModel.DefaultPropertyEditor Property

IComponentEditorExViewModelDefaultPropertyEditor Property

Provides access to default property editor.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IDefaultPropertyEditor DefaultPropertyEditor { get; }
property IDefaultPropertyEditor^ DefaultPropertyEditor {
    IDefaultPropertyEditor^ get ();
}

Property Value

Type: IDefaultPropertyEditor
See Also

Reference

IComponentEditorExViewModel Interface
VisualComponents.UX.Shared Namespace


IComponentEditorExViewModel.PaneToReactivate Property

IComponentEditorExViewModelPaneToReactivate Property

Allows children to prevent the panel from deactivating (when unpinned) during some actions that can fire ContentVisibleResolvedValueChanged.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ContentPane PaneToReactivate { get; set; }
property ContentPane^ PaneToReactivate {
    ContentPane^ get ();
    void set (ContentPane^ value);
}

Property Value

Type: ContentPane
See Also

Reference

IComponentEditorExViewModel Interface
VisualComponents.UX.Shared Namespace


IComponentEditorExViewModel.SelectedObject Property

IComponentEditorExViewModelSelectedObject Property

Note: when ManipulateViewModel.Target.PivotObject is Dof this points to ISimNode object.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
INamed SelectedObject { get; }
property INamed^ SelectedObject {
    INamed^ get ();
}

Property Value

Type: INamed
See Also

Reference

IComponentEditorExViewModel Interface
VisualComponents.UX.Shared Namespace


IComponentEditorExViewModel.SelectedPhysicsRope Property

IComponentEditorExViewModelSelectedPhysicsRope Property

Note: This API is now obsolete.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("This property is obsolete. Use ISelectionManager instead.",
    true)]
ISimComponent SelectedPhysicsRope { get; }
[ObsoleteAttribute(L"This property is obsolete. Use ISelectionManager instead.",
    true)]
property ISimComponent^ SelectedPhysicsRope {
    ISimComponent^ get ();
}

Property Value

Type: ISimComponent
See Also

Reference

IComponentEditorExViewModel Interface
VisualComponents.UX.Shared Namespace


IComponentEditorExViewModel.SelectedPhysicsRopePin Property

IComponentEditorExViewModelSelectedPhysicsRopePin Property

Note: This API is now obsolete.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("This property is obsolete. Use ISelectionManager instead.",
    true)]
ISimNode SelectedPhysicsRopePin { get; }
[ObsoleteAttribute(L"This property is obsolete. Use ISelectionManager instead.",
    true)]
property ISimNode^ SelectedPhysicsRopePin {
    ISimNode^ get ();
}

Property Value

Type: ISimNode
See Also

Reference

IComponentEditorExViewModel Interface
VisualComponents.UX.Shared Namespace


IComponentEditorExViewModel.Selection Property

IComponentEditorExViewModelSelection Property

Normally equals to ISelectionManager.GetAllSelected() list.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
List<INamed> Selection { get; }
property List<INamed^>^ Selection {
    List<INamed^>^ get ();
}

Property Value

Type: ListINamed
See Also

Reference

IComponentEditorExViewModel Interface
VisualComponents.UX.Shared Namespace


IComponentEditorExViewModel.SuspendDisposal Property

IComponentEditorExViewModelSuspendDisposal Property

Allows children to prevent the panel from deactivating (when unpinned) during some 3D-world related actions, such as the PickValueFrom3DWorld.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SuspendDisposal { get; set; }
property bool SuspendDisposal {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IComponentEditorExViewModel Interface
VisualComponents.UX.Shared Namespace


IComponentEditorExViewModel Methods

The IComponentEditorExViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Public method | Update |
Top
See Also

Reference

IComponentEditorExViewModel Interface
VisualComponents.UX.Shared Namespace


IComponentEditorExViewModel.Update Method

IComponentEditorExViewModelUpdate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Update()
void Update()
See Also

Reference

IComponentEditorExViewModel Interface
VisualComponents.UX.Shared Namespace


IComponentEditorExViewModel Events

The IComponentEditorExViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IComponentEditorExViewModel Interface
VisualComponents.UX.Shared Namespace


IComponentEditorExViewModelEx Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IComponentEditorExViewModelEx
public interface class IComponentEditorExViewModelEx

The IComponentEditorExViewModelEx type exposes the following members.

Properties
 | Name | Description
Public property | SelectedObjectEx | Same as SelectedObject, but can also store an object that does not implement INamed.
Public property | SelectionEx | Same as Selection, but can also contain objects that do not implement INamed.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IComponentEditorExViewModelEx Properties

The IComponentEditorExViewModelEx type exposes the following members.

Properties
 | Name | Description
Public property | SelectedObjectEx | Same as SelectedObject, but can also store an object that does not implement INamed.
Public property | SelectionEx | Same as Selection, but can also contain objects that do not implement INamed.
Top
See Also

Reference

IComponentEditorExViewModelEx Interface
VisualComponents.UX.Shared Namespace


IComponentEditorExViewModelEx.SelectedObjectEx Property

IComponentEditorExViewModelExSelectedObjectEx Property

Same as SelectedObject, but can also store an object that does not implement INamed.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object SelectedObjectEx { get; }
property Object^ SelectedObjectEx {
    Object^ get ();
}

Property Value

Type: Object
See Also

Reference

IComponentEditorExViewModelEx Interface
VisualComponents.UX.Shared Namespace


IComponentEditorExViewModelEx.SelectionEx Property

IComponentEditorExViewModelExSelectionEx Property

Same as Selection, but can also contain objects that do not implement INamed.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList SelectionEx { get; }
property IList^ SelectionEx {
    IList^ get ();
}

Property Value

Type: IList
See Also

Reference

IComponentEditorExViewModelEx Interface
VisualComponents.UX.Shared Namespace


IComponentMetaDataEditorViewModel Interface

Layout metadata members definition

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IComponentMetaDataEditorViewModel : IMetadataEditorViewModel
public interface class IComponentMetaDataEditorViewModel : IMetadataEditorViewModel

The IComponentMetaDataEditorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | Active | True when the ribbon tab is active
Public property | Metadata | current component metadata info (Inherited from IMetadataEditorViewModel.)
Public property | SelectedComponent | Currently selected component.
Top
Methods
 | Name | Description
Public method | SaveComponent | Save shown component to file.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IComponentMetaDataEditorViewModel Properties

The IComponentMetaDataEditorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | Active | True when the ribbon tab is active
Public property | Metadata | current component metadata info (Inherited from IMetadataEditorViewModel.)
Public property | SelectedComponent | Currently selected component.
Top
See Also

Reference

IComponentMetaDataEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IComponentMetaDataEditorViewModel.Active Property

IComponentMetaDataEditorViewModelActive Property

True when the ribbon tab is active

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool Active { get; }
property bool Active {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IComponentMetaDataEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IComponentMetaDataEditorViewModel.SelectedComponent Property

IComponentMetaDataEditorViewModelSelectedComponent Property

Currently selected component.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent SelectedComponent { get; }
property ISimComponent^ SelectedComponent {
    ISimComponent^ get ();
}

Property Value

Type: ISimComponent
See Also

Reference

IComponentMetaDataEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IComponentMetaDataEditorViewModel Methods

The IComponentMetaDataEditorViewModel type exposes the following members.

Methods
 | Name | Description
Public method | SaveComponent | Save shown component to file.
Top
See Also

Reference

IComponentMetaDataEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IComponentMetaDataEditorViewModel.SaveComponent Method

IComponentMetaDataEditorViewModelSaveComponent Method

Save shown component to file.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SaveComponent(
    string filePath
)
void SaveComponent(
    String^ filePath
)

Parameters

filePath
Type: SystemString
full path name
See Also

Reference

IComponentMetaDataEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IConnectingLinesAction Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IConnectingLinesAction
public interface class IConnectingLinesAction

The IConnectingLinesAction type exposes the following members.

Properties
 | Name | Description
Public property | IsActive |
Top
Methods
 | Name | Description
Public method | Execute |
Public method | HandleClick |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IConnectingLinesAction Properties

The IConnectingLinesAction type exposes the following members.

Properties
 | Name | Description
Public property | IsActive |
Top
See Also

Reference

IConnectingLinesAction Interface
VisualComponents.UX.Shared Namespace


IConnectingLinesAction.IsActive Property

IConnectingLinesActionIsActive Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsActive { get; }
property bool IsActive {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IConnectingLinesAction Interface
VisualComponents.UX.Shared Namespace


IConnectingLinesAction Methods

The IConnectingLinesAction type exposes the following members.

Methods
 | Name | Description
Public method | Execute |
Public method | HandleClick |
Top
See Also

Reference

IConnectingLinesAction Interface
VisualComponents.UX.Shared Namespace


IConnectingLinesAction.Execute Method

IConnectingLinesActionExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Execute(
    bool show
)
void Execute(
    bool show
)

Parameters

show
Type: SystemBoolean
See Also

Reference

IConnectingLinesAction Interface
VisualComponents.UX.Shared Namespace


IConnectingLinesAction.HandleClick Method

IConnectingLinesActionHandleClick Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool HandleClick(
    int x,
    int y,
    bool moveRobot,
    ref IPositionFrame frame
)
bool HandleClick(
    int x,
    int y,
    bool moveRobot,
    IPositionFrame^% frame
)

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
moveRobot
Type: SystemBoolean
frame
Type: VisualComponents.Create3DIPositionFrame

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IConnectingLinesAction.HandleClick(System.Int32,System.Int32,System.Boolean,VisualComponents.Create3D.IPositionFrame@)"]

See Also

Reference

IConnectingLinesAction Interface
VisualComponents.UX.Shared Namespace


IContextualTabGroup Interface

Marker interface a ribbon contextual tab group.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IContextualTabGroup
public interface class IContextualTabGroup

The IContextualTabGroup type exposes the following members.

Properties
 | Name | Description
Public property | BaseBackColor | Returns the color that should be used to determine the background for the caption of the group as well as the background of the tabs in the group.
Public property | Caption | Returns/sets the caption of the ContextualTabGroup.
Public property | IgContextualTabGroup |
Public property | IsVisible | Returns/sets whether the ContextualTabGroup is Visible. When set to false, any RibbonTabItems in the ContextualTabGroup will be hidden.
Public property | Key | Returns/sets the key of the ContextualTabGroup in the ContextualTabGroupCollection.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IContextualTabGroup Properties

The IContextualTabGroup type exposes the following members.

Properties
 | Name | Description
Public property | BaseBackColor | Returns the color that should be used to determine the background for the caption of the group as well as the background of the tabs in the group.
Public property | Caption | Returns/sets the caption of the ContextualTabGroup.
Public property | IgContextualTabGroup |
Public property | IsVisible | Returns/sets whether the ContextualTabGroup is Visible. When set to false, any RibbonTabItems in the ContextualTabGroup will be hidden.
Public property | Key | Returns/sets the key of the ContextualTabGroup in the ContextualTabGroupCollection.
Top
See Also

Reference

IContextualTabGroup Interface
VisualComponents.UX.Shared Namespace


IContextualTabGroup.BaseBackColor Property

IContextualTabGroupBaseBackColor Property

Returns the color that should be used to determine the background for the caption of the group as well as the background of the tabs in the group.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Nullable<Color> BaseBackColor { get; }
property Nullable<Color> BaseBackColor {
    Nullable<Color> get ();
}

Property Value

Type: NullableColor
See Also

Reference

IContextualTabGroup Interface
VisualComponents.UX.Shared Namespace


IContextualTabGroup.Caption Property

IContextualTabGroupCaption Property

Returns/sets the caption of the ContextualTabGroup.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Caption { get; }
property String^ Caption {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IContextualTabGroup Interface
VisualComponents.UX.Shared Namespace


IContextualTabGroup.IgContextualTabGroup Property

IContextualTabGroupIgContextualTabGroup Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object IgContextualTabGroup { get; set; }
property Object^ IgContextualTabGroup {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

IContextualTabGroup Interface
VisualComponents.UX.Shared Namespace


IContextualTabGroup.IsVisible Property

IContextualTabGroupIsVisible Property

Returns/sets whether the ContextualTabGroup is Visible. When set to false, any RibbonTabItems in the ContextualTabGroup will be hidden.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsVisible { get; }
property bool IsVisible {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IContextualTabGroup Interface
VisualComponents.UX.Shared Namespace


IContextualTabGroup.Key Property

IContextualTabGroupKey Property

Returns/sets the key of the ContextualTabGroup in the ContextualTabGroupCollection.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Key { get; }
property String^ Key {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IContextualTabGroup Interface
VisualComponents.UX.Shared Namespace


ICustomScreenAvailability Interface

Allows dockable screens to prevent their display based on custom logic.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICustomScreenAvailability
public interface class ICustomScreenAvailability

The ICustomScreenAvailability type exposes the following members.

Properties
 | Name | Description
Public property | IsAvailable | Whether this screen can be shown.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ICustomScreenAvailability Properties

The ICustomScreenAvailability type exposes the following members.

Properties
 | Name | Description
Public property | IsAvailable | Whether this screen can be shown.
Top
See Also

Reference

ICustomScreenAvailability Interface
VisualComponents.UX.Shared Namespace


ICustomScreenAvailability.IsAvailable Property

ICustomScreenAvailabilityIsAvailable Property

Whether this screen can be shown.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsAvailable { get; }
property bool IsAvailable {
    bool get ();
}

Property Value

Type: Boolean
Remarks
Returning false means if this item should not be shown regardless of other settings. This property is evaluated when application context is switched and when the visibility is set through the API. Returning true allows other settings to decide whether the screen can be shown.
See Also

Reference

ICustomScreenAvailability Interface
VisualComponents.UX.Shared Namespace


ICustomScreenVisibility Interface

Allows dockable screens to prevent their visibiliyt based on custom logic.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ICustomScreenVisibility
public interface class ICustomScreenVisibility

The ICustomScreenVisibility type exposes the following members.

Properties
 | Name | Description
Public property | IsHideable | Whether this screen visibility in dockmanager be modified.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ICustomScreenVisibility Properties

The ICustomScreenVisibility type exposes the following members.

Properties
 | Name | Description
Public property | IsHideable | Whether this screen visibility in dockmanager be modified.
Top
See Also

Reference

ICustomScreenVisibility Interface
VisualComponents.UX.Shared Namespace


ICustomScreenVisibility.IsHideable Property

ICustomScreenVisibilityIsHideable Property

Whether this screen visibility in dockmanager be modified.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsHideable { get; }
property bool IsHideable {
    bool get ();
}

Property Value

Type: Boolean
Remarks
By default all dockable screens are listed to be toggled to visible or hidden. Returning false means if this item should not be hidden or visible. Returning true allows to decide whether the screen can be toggled to visible or hidden.
See Also

Reference

ICustomScreenVisibility Interface
VisualComponents.UX.Shared Namespace


IDecimateAction Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDecimateAction : ICommandPanelAction
public interface class IDecimateAction : ICommandPanelAction

The IDecimateAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Top
Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IDecimateAction Properties

The IDecimateAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

IDecimateAction Interface
VisualComponents.UX.Shared Namespace


IDecimateAction Methods

The IDecimateAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

IDecimateAction Interface
VisualComponents.UX.Shared Namespace


IDecimateViewModel Interface

Decimate view model interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDecimateViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IDecimateViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The IDecimateViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IDecimateViewModel Properties

The IDecimateViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
See Also

Reference

IDecimateViewModel Interface
VisualComponents.UX.Shared Namespace


IDecimateViewModel Methods

The IDecimateViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IDecimateViewModel Interface
VisualComponents.UX.Shared Namespace


IDecimateViewModel Events

The IDecimateViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IDecimateViewModel Interface
VisualComponents.UX.Shared Namespace


IDefaultPropertyEditor Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDefaultPropertyEditor : IPropertyEditor,
    INotifyPropertyChanged
public interface class IDefaultPropertyEditor : IPropertyEditor,
    INotifyPropertyChanged

The IDefaultPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | DefinesName | Indicates that property panel doesn't need to display selected object's name (Inherited from IPropertyEditor.)
Public property | Layout |
Public property | SelectedTabName | selected tab name property
Public property | TranslateRotateVisibility | (Inherited from IPropertyEditor.)
Top
Methods
 | Name | Description
Public method | CanHandle | (Inherited from IPropertyEditor.)
Public method | Initialize | (Inherited from IPropertyEditor.)
Public method | SetActiveObjects | (Inherited from IPropertyEditor.)
Public method | SetFilter | (Inherited from IPropertyEditor.)
Public method | SortProperties | (Inherited from IPropertyEditor.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Public event | PropertySelectedTabChanged | selected tab change event
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IDefaultPropertyEditor Properties

The IDefaultPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | DefinesName | Indicates that property panel doesn't need to display selected object's name (Inherited from IPropertyEditor.)
Public property | Layout |
Public property | SelectedTabName | selected tab name property
Public property | TranslateRotateVisibility | (Inherited from IPropertyEditor.)
Top
See Also

Reference

IDefaultPropertyEditor Interface
VisualComponents.UX.Shared Namespace


IDefaultPropertyEditor.Layout Property

IDefaultPropertyEditorLayout Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
PropertyLayout Layout { get; set; }
property PropertyLayout^ Layout {
    PropertyLayout^ get ();
    void set (PropertyLayout^ value);
}

Property Value

Type: PropertyLayout
See Also

Reference

IDefaultPropertyEditor Interface
VisualComponents.UX.Shared Namespace


IDefaultPropertyEditor.SelectedTabName Property

IDefaultPropertyEditorSelectedTabName Property

selected tab name property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string SelectedTabName { get; set; }
property String^ SelectedTabName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IDefaultPropertyEditor Interface
VisualComponents.UX.Shared Namespace


IDefaultPropertyEditor Methods

The IDefaultPropertyEditor type exposes the following members.

Methods
 | Name | Description
Public method | CanHandle | (Inherited from IPropertyEditor.)
Public method | Initialize | (Inherited from IPropertyEditor.)
Public method | SetActiveObjects | (Inherited from IPropertyEditor.)
Public method | SetFilter | (Inherited from IPropertyEditor.)
Public method | SortProperties | (Inherited from IPropertyEditor.)
Top
See Also

Reference

IDefaultPropertyEditor Interface
VisualComponents.UX.Shared Namespace


IDefaultPropertyEditor Events

The IDefaultPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Public event | PropertySelectedTabChanged | selected tab change event
Top
See Also

Reference

IDefaultPropertyEditor Interface
VisualComponents.UX.Shared Namespace


IDefaultPropertyEditor.PropertySelectedTabChanged Event

IDefaultPropertyEditorPropertySelectedTabChanged Event

selected tab change event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event PropertyChangedEventHandler PropertySelectedTabChanged
 event PropertyChangedEventHandler^ PropertySelectedTabChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler
See Also

Reference

IDefaultPropertyEditor Interface
VisualComponents.UX.Shared Namespace


IDisableWindowLayoutPersistance Interface

Marker interface for screens that should not automatically trigger window layout configuration persistancy.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDisableWindowLayoutPersistance
public interface class IDisableWindowLayoutPersistance
See Also

Reference

VisualComponents.UX.Shared Namespace


IDistributionTypeEditorViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDistributionTypeEditorViewModel
public interface class IDistributionTypeEditorViewModel
Methods
 | Name | Description
Public method | Initialize(IDistributionProperty) |
Public method | Initialize(IUnionProperty) |
Public method | Initialize(IDistributionProperty, Bindable) |
Public method | Initialize(IUnionProperty, Bindable) |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IDistributionTypeEditorViewModel Methods

Methods
 | Name | Description
Public method | Initialize(IDistributionProperty) |
Public method | Initialize(IUnionProperty) |
Public method | Initialize(IDistributionProperty, Bindable) |
Public method | Initialize(IUnionProperty, Bindable) |
Top
See Also

Reference

IDistributionTypeEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IDistributionTypeEditorViewModel.Initialize Method

IDistributionTypeEditorViewModelInitialize Method

Overload List
 | Name | Description
Public method | Initialize(IDistributionProperty) |
Public method | Initialize(IUnionProperty) |
Public method | Initialize(IDistributionProperty, Bindable) |
Public method | Initialize(IUnionProperty, Bindable) |
Top
See Also

Reference

IDistributionTypeEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IDistributionTypeEditorViewModel.Initialize Method (IDistributionProperty)

IDistributionTypeEditorViewModelInitialize Method (IDistributionProperty)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Initialize(
    IDistributionProperty property
)
void Initialize(
    IDistributionProperty^ property
)

Parameters

property
Type: VisualComponents.Create3DIDistributionProperty
See Also

Reference

IDistributionTypeEditorViewModel Interface
Initialize Overload
VisualComponents.UX.Shared Namespace


IDistributionTypeEditorViewModel.Initialize Method (IUnionProperty)

IDistributionTypeEditorViewModelInitialize Method (IUnionProperty)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Initialize(
    IUnionProperty property
)
void Initialize(
    IUnionProperty^ property
)

Parameters

property
Type: VisualComponents.Create3DIUnionProperty
See Also

Reference

IDistributionTypeEditorViewModel Interface
Initialize Overload
VisualComponents.UX.Shared Namespace


IDistributionTypeEditorViewModel.Initialize Method (IDistributionProperty, Bindable)

IDistributionTypeEditorViewModelInitialize Method (IDistributionProperty, Bindable)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Initialize(
    IDistributionProperty property,
    Bindable bindable
)
void Initialize(
    IDistributionProperty^ property,
    Bindable^ bindable
)

Parameters

property
Type: VisualComponents.Create3DIDistributionProperty
bindable
Type: VisualComponents.UX.SharedBindable
See Also

Reference

IDistributionTypeEditorViewModel Interface
Initialize Overload
VisualComponents.UX.Shared Namespace


IDistributionTypeEditorViewModel.Initialize Method (IUnionProperty, Bindable)

IDistributionTypeEditorViewModelInitialize Method (IUnionProperty, Bindable)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Initialize(
    IUnionProperty property,
    Bindable bindable
)
void Initialize(
    IUnionProperty^ property,
    Bindable^ bindable
)

Parameters

property
Type: VisualComponents.Create3DIUnionProperty
bindable
Type: VisualComponents.UX.SharedBindable
See Also

Reference

IDistributionTypeEditorViewModel Interface
Initialize Overload
VisualComponents.UX.Shared Namespace


IDockableScreen Interface

Provides access to pane that can be docked with DockManager.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDockableScreen : IScreen,
    IHaveDisplayName, IActivate, IDeactivate, IGuardClose, IClose,
    INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IDockableScreen : IScreen,
    IHaveDisplayName, IActivate, IDeactivate, IGuardClose, IClose,
    INotifyPropertyChangedEx, INotifyPropertyChanged

The IDockableScreen type exposes the following members.

Properties
 | Name | Description
Public property | ContextFilter | Gets or sets the context filter. The context defines one or more contexts where the panel is visible.
Public property | DesiredPanePosition | Gets the desired pane position. If multiple panes are added, panes are ordered using this property.
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | Height | Gets the Height of the pane.
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsPinned | Gets or sets a Boolean value that indicates if the pane is pinned.
Public property | IsSelected | Gets or sets a boolean value that indicates if the pane is selected in TabGroupPane
Public property | IsVisible | Gets or sets a boolean value that indicates if the pane is visible
Public property | PanelId | Gets the panel ID
Public property | PaneLocation | Gets the desired panel location DesiredPaneLocation
Public property | PaneOrientation | Gets the pane orientation
Public property | SplitPaneId | Gets the split pane id. By default all panes within panel location use same split panel. Multiple split panels can be created by defining new split pane ids.
 | TabGroupId | Gets the pane tab group id. Panes are splitted and ordered to different tabs within the splitpane based on TabGroupId.
Public property | Width | Gets the Width of the pane.
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IDockableScreen Properties

The IDockableScreen type exposes the following members.

Properties
 | Name | Description
Public property | ContextFilter | Gets or sets the context filter. The context defines one or more contexts where the panel is visible.
Public property | DesiredPanePosition | Gets the desired pane position. If multiple panes are added, panes are ordered using this property.
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | Height | Gets the Height of the pane.
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsPinned | Gets or sets a Boolean value that indicates if the pane is pinned.
Public property | IsSelected | Gets or sets a boolean value that indicates if the pane is selected in TabGroupPane
Public property | IsVisible | Gets or sets a boolean value that indicates if the pane is visible
Public property | PanelId | Gets the panel ID
Public property | PaneLocation | Gets the desired panel location DesiredPaneLocation
Public property | PaneOrientation | Gets the pane orientation
Public property | SplitPaneId | Gets the split pane id. By default all panes within panel location use same split panel. Multiple split panels can be created by defining new split pane ids.
 | TabGroupId | Gets the pane tab group id. Panes are splitted and ordered to different tabs within the splitpane based on TabGroupId.
Public property | Width | Gets the Width of the pane.
Top
See Also

Reference

IDockableScreen Interface
VisualComponents.UX.Shared Namespace


IDockableScreen.ContextFilter Property

IDockableScreenContextFilter Property

Gets or sets the context filter. The context defines one or more contexts where the panel is visible.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ContextFilter { get; set; }
property String^ ContextFilter {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IDockableScreen Interface
VisualComponents.UX.Shared Namespace


IDockableScreen.DesiredPanePosition Property

IDockableScreenDesiredPanePosition Property

Gets the desired pane position. If multiple panes are added, panes are ordered using this property.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int DesiredPanePosition { get; }
property int DesiredPanePosition {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IDockableScreen Interface
VisualComponents.UX.Shared Namespace


IDockableScreen.Height Property

IDockableScreenHeight Property

Gets the Height of the pane.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Height { get; }
property double Height {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IDockableScreen Interface
VisualComponents.UX.Shared Namespace


IDockableScreen.IsPinned Property

IDockableScreenIsPinned Property

Gets or sets a Boolean value that indicates if the pane is pinned.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsPinned { get; set; }
property bool IsPinned {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IDockableScreen Interface
VisualComponents.UX.Shared Namespace


IDockableScreen.IsSelected Property

IDockableScreenIsSelected Property

Gets or sets a boolean value that indicates if the pane is selected in TabGroupPane

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsSelected { get; set; }
property bool IsSelected {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IDockableScreen Interface
VisualComponents.UX.Shared Namespace


IDockableScreen.IsVisible Property

IDockableScreenIsVisible Property

Gets or sets a boolean value that indicates if the pane is visible

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsVisible { get; set; }
property bool IsVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IDockableScreen Interface
VisualComponents.UX.Shared Namespace


IDockableScreen.PanelId Property

IDockableScreenPanelId Property

Gets the panel ID

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string PanelId { get; }
property String^ PanelId {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IDockableScreen Interface
VisualComponents.UX.Shared Namespace


IDockableScreen.PaneLocation Property

IDockableScreenPaneLocation Property

Gets the desired panel location DesiredPaneLocation

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
DesiredPaneLocation PaneLocation { get; }
property DesiredPaneLocation PaneLocation {
    DesiredPaneLocation get ();
}

Property Value

Type: DesiredPaneLocation
See Also

Reference

IDockableScreen Interface
VisualComponents.UX.Shared Namespace


IDockableScreen.PaneOrientation Property

IDockableScreenPaneOrientation Property

Gets the pane orientation

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Orientation PaneOrientation { get; }
property Orientation PaneOrientation {
    Orientation get ();
}

Property Value

Type: Orientation
See Also

Reference

IDockableScreen Interface
VisualComponents.UX.Shared Namespace


IDockableScreen.SplitPaneId Property

IDockableScreenSplitPaneId Property

Gets the split pane id. By default all panes within panel location use same split panel. Multiple split panels can be created by defining new split pane ids.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string SplitPaneId { get; }
property String^ SplitPaneId {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IDockableScreen Interface
VisualComponents.UX.Shared Namespace


IDockableScreen.TabGroupId Property

IDockableScreenTabGroupId Property

Gets the pane tab group id. Panes are splitted and ordered to different tabs within the splitpane based on TabGroupId.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string TabGroupId { get; }
property String^ TabGroupId {
    String^ get ();
}

Property Value

Type: String
Examples
Horizontal SplitPanel TabId1:ContentPanel1 TabId1:ContentPanel2 TabId2:ContentPanel3 ContentPanel4 (untabbed)
See Also

Reference

IDockableScreen Interface
VisualComponents.UX.Shared Namespace


IDockableScreen.Width Property

IDockableScreenWidth Property

Gets the Width of the pane.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Width { get; }
property double Width {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IDockableScreen Interface
VisualComponents.UX.Shared Namespace


IDockableScreen Methods

The IDockableScreen type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IDockableScreen Interface
VisualComponents.UX.Shared Namespace


IDockableScreen Events

The IDockableScreen type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IDockableScreen Interface
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager Interface

A service that manages windows panel.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDockAwareWindowManager : IWindowManager
public interface class IDockAwareWindowManager : IWindowManager

The IDockAwareWindowManager type exposes the following members.

Properties
 | Name | Description
Public property | DockManager |
Public property | DockPanels | Gets all dockable screens loaded to the application.Some of IDockableScreen are not included because they are filtered out by exclude filter setting in appconfig file.
Top
Methods
 | Name | Description
Public method | Close | Closes ContentPanes which hold a screen of the specified type.
Public method | CreateDockable | Does one of 3: finds a ContentPane by name, creates a ContentPane (if contentPaneName == null), or returns ViewLocator.LocateForModel(rootModel).
Public method | DeleteUserLayouts | Deletes persisted user docking layouts from isolated storage.
Public method | DeleteUserLayouts(IContext) | Deletes persisted user current context docking layout from isolated storage.
Public method | EnterFullScreenMode | Enter fullscreen mode by hiding all panes.
Public method | ExitFullScreenMode | Exits fullscreen mode, and restores visibility state of panes.
Public method | GetPanePosition | Obsolete.
Public method | IsScreenVisible | Checks the visibility ContentPanes which hold a screen of the specified type.
Public method | IsWindowPaneActive | Obsolete.
Public method | LoadLayoutFromConfigFolder(String, MemoryStream) | Load docking layout settings from application user setting
Public method | LoadLayoutFromConfigFolder(String, IContext, MemoryStream) | Load docking layout settings from application user setting.
Public method | LoadQuickAccessToolbarContent | Load QuickAccessToolbar Elements from config file
Public method | PopToFloatingWindow | Obsolete.
Public method | SaveLayoutInConfigFolder | Saves information about the current arrangement of the panes to the application user setting.
Public method | SaveQuickAccessToolbarContent | Save QuickAccessToolbar content to user config file
Public method | SetPanelSize | Obsolete.
Public method | SetScreenVisibility(IDockableScreen, Boolean) | Sets the visibility status of the ContentPanes which hold a screen of the specified type. If the screen is set to be shown, all the matching hidden panes are shown, and if no matches are found, a new one is created. If the screen is set to be invisible, they are simply hidden, and will be restored when the screen is again set to be visible.
Public method | SetScreenVisibility(IDockableScreen, Boolean, Boolean) | Sets the visibility status of the ContentPanes which hold a screen of the specified type. If the screen is set to be shown, all the matching hidden panes are shown, and if no matches are found, a new one is created. If the screen is set to be invisible, they are simply hidden, and will be restored when the screen is again set to be visible.
Public method | ShowDialog | (Inherited from IWindowManager.)
Public method | ShowDockedWindow | Shows a docked window.
Public method | ShowDockPanels | Shows all imported dock panels
Public method | ShowDockPanels(ListIDockableScreen) |
Public method | ShowDocumentHostContent | Shows a document host content.
Public method | ShowDocumentWindow | Shows a document window.
Public method | ShowFloatingWindow(String, Object, Object, Boolean, Boolean, Boolean) | Shows a floating window.
Public method | ShowFloatingWindow(String, Object, Size, Object, Boolean, Boolean, Boolean) | Shows a floating window.
Public method | ShowPopup | (Inherited from IWindowManager.)
Public method | ShowWindow | (Inherited from IWindowManager.)
Top
Events
 | Name | Description
Public event | ActiveDocumentChanged | Occurs when the DocumentContentHost Active Document changed.
Public event | DockPaneClosing | Occurs when IDockableScreen's ContentPane is about to be closed.
Public event | ScreenVisibilityChanged | Raised when the visibility of a screen has changed.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IDockAwareWindowManager Properties

The IDockAwareWindowManager type exposes the following members.

Properties
 | Name | Description
Public property | DockManager |
Public property | DockPanels | Gets all dockable screens loaded to the application.Some of IDockableScreen are not included because they are filtered out by exclude filter setting in appconfig file.
Top
See Also

Reference

IDockAwareWindowManager Interface
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.DockManager Property

IDockAwareWindowManagerDockManager Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
XamDockManager DockManager { get; }
property XamDockManager^ DockManager {
    XamDockManager^ get ();
}

Property Value

Type: XamDockManager
See Also

Reference

IDockAwareWindowManager Interface
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.DockPanels Property

IDockAwareWindowManagerDockPanels Property

Gets all dockable screens loaded to the application.Some of IDockableScreen are not included because they are filtered out by exclude filter setting in appconfig file.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
List<IDockableScreen> DockPanels { get; }
property List<IDockableScreen^>^ DockPanels {
    List<IDockableScreen^>^ get ();
}

Property Value

Type: ListIDockableScreen
See Also

Reference

IDockAwareWindowManager Interface
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager Methods

The IDockAwareWindowManager type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes ContentPanes which hold a screen of the specified type.
Public method | CreateDockable | Does one of 3: finds a ContentPane by name, creates a ContentPane (if contentPaneName == null), or returns ViewLocator.LocateForModel(rootModel).
Public method | DeleteUserLayouts | Deletes persisted user docking layouts from isolated storage.
Public method | DeleteUserLayouts(IContext) | Deletes persisted user current context docking layout from isolated storage.
Public method | EnterFullScreenMode | Enter fullscreen mode by hiding all panes.
Public method | ExitFullScreenMode | Exits fullscreen mode, and restores visibility state of panes.
Public method | GetPanePosition | Obsolete.
Public method | IsScreenVisible | Checks the visibility ContentPanes which hold a screen of the specified type.
Public method | IsWindowPaneActive | Obsolete.
Public method | LoadLayoutFromConfigFolder(String, MemoryStream) | Load docking layout settings from application user setting
Public method | LoadLayoutFromConfigFolder(String, IContext, MemoryStream) | Load docking layout settings from application user setting.
Public method | LoadQuickAccessToolbarContent | Load QuickAccessToolbar Elements from config file
Public method | PopToFloatingWindow | Obsolete.
Public method | SaveLayoutInConfigFolder | Saves information about the current arrangement of the panes to the application user setting.
Public method | SaveQuickAccessToolbarContent | Save QuickAccessToolbar content to user config file
Public method | SetPanelSize | Obsolete.
Public method | SetScreenVisibility(IDockableScreen, Boolean) | Sets the visibility status of the ContentPanes which hold a screen of the specified type. If the screen is set to be shown, all the matching hidden panes are shown, and if no matches are found, a new one is created. If the screen is set to be invisible, they are simply hidden, and will be restored when the screen is again set to be visible.
Public method | SetScreenVisibility(IDockableScreen, Boolean, Boolean) | Sets the visibility status of the ContentPanes which hold a screen of the specified type. If the screen is set to be shown, all the matching hidden panes are shown, and if no matches are found, a new one is created. If the screen is set to be invisible, they are simply hidden, and will be restored when the screen is again set to be visible.
Public method | ShowDialog | (Inherited from IWindowManager.)
Public method | ShowDockedWindow | Shows a docked window.
Public method | ShowDockPanels | Shows all imported dock panels
Public method | ShowDockPanels(ListIDockableScreen) |
Public method | ShowDocumentHostContent | Shows a document host content.
Public method | ShowDocumentWindow | Shows a document window.
Public method | ShowFloatingWindow(String, Object, Object, Boolean, Boolean, Boolean) | Shows a floating window.
Public method | ShowFloatingWindow(String, Object, Size, Object, Boolean, Boolean, Boolean) | Shows a floating window.
Public method | ShowPopup | (Inherited from IWindowManager.)
Public method | ShowWindow | (Inherited from IWindowManager.)
Top
See Also

Reference

IDockAwareWindowManager Interface
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.Close Method

IDockAwareWindowManagerClose Method

Closes ContentPanes which hold a screen of the specified type.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Close(
    IDockableScreen dockableScreen
)
void Close(
    IDockableScreen^ dockableScreen
)

Parameters

dockableScreen
Type: VisualComponents.UX.SharedIDockableScreen
A screen whose type is used to get the ContentPanes.
See Also

Reference

IDockAwareWindowManager Interface
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.CreateDockable Method

IDockAwareWindowManagerCreateDockable Method

Does one of 3: finds a ContentPane by name, creates a ContentPane (if contentPaneName == null), or returns ViewLocator.LocateForModel(rootModel).

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ContentPane CreateDockable(
    Object rootModel,
    Object context,
    string contentPaneName = null,
    bool register = true
)
ContentPane^ CreateDockable(
    Object^ rootModel,
    Object^ context,
    String^ contentPaneName = nullptr,
    bool register = true
)

Parameters

rootModel
Type: SystemObject
context
Type: SystemObject
contentPaneName (Optional)
Type: SystemString
register (Optional)
Type: SystemBoolean

Return Value

Type: ContentPane

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IDockAwareWindowManager.CreateDockable(System.Object,System.Object,System.String,System.Boolean)"]

See Also

Reference

IDockAwareWindowManager Interface
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.DeleteUserLayouts Method

IDockAwareWindowManagerDeleteUserLayouts Method

Overload List
 | Name | Description
Public method | DeleteUserLayouts | Deletes persisted user docking layouts from isolated storage.
Public method | DeleteUserLayouts(IContext) | Deletes persisted user current context docking layout from isolated storage.
Top
See Also

Reference

IDockAwareWindowManager Interface
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.DeleteUserLayouts Method

IDockAwareWindowManagerDeleteUserLayouts Method

Deletes persisted user docking layouts from isolated storage.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteUserLayouts()
void DeleteUserLayouts()
See Also

Reference

IDockAwareWindowManager Interface
DeleteUserLayouts Overload
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.DeleteUserLayouts Method (IContext)

IDockAwareWindowManagerDeleteUserLayouts Method (IContext)

Deletes persisted user current context docking layout from isolated storage.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteUserLayouts(
    IContext context
)
void DeleteUserLayouts(
    IContext^ context
)

Parameters

context
Type: VisualComponents.Create3DIContext
Current application context.
See Also

Reference

IDockAwareWindowManager Interface
DeleteUserLayouts Overload
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.EnterFullScreenMode Method

IDockAwareWindowManagerEnterFullScreenMode Method

Enter fullscreen mode by hiding all panes.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void EnterFullScreenMode()
void EnterFullScreenMode()
See Also

Reference

IDockAwareWindowManager Interface
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.ExitFullScreenMode Method

IDockAwareWindowManagerExitFullScreenMode Method

Exits fullscreen mode, and restores visibility state of panes.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ExitFullScreenMode()
void ExitFullScreenMode()
See Also

Reference

IDockAwareWindowManager Interface
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.GetPanePosition Method

IDockAwareWindowManagerGetPanePosition Method

Note: This API is now obsolete.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("This property is obsolete.", false)]
bool GetPanePosition(
    string windowname,
    ref Point position
)
[ObsoleteAttribute(L"This property is obsolete.", false)]
bool GetPanePosition(
    String^ windowname,
    Point% position
)

Parameters

windowname
Type: SystemString
position
Type: System.WindowsPoint

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IDockAwareWindowManager.GetPanePosition(System.String,System.Windows.Point@)"]

See Also

Reference

IDockAwareWindowManager Interface
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.IsScreenVisible Method

IDockAwareWindowManagerIsScreenVisible Method

Checks the visibility ContentPanes which hold a screen of the specified type.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsScreenVisible(
    IDockableScreen dockableScreen
)
bool IsScreenVisible(
    IDockableScreen^ dockableScreen
)

Parameters

dockableScreen
Type: VisualComponents.UX.SharedIDockableScreen
A screen whose type is used to get the ContentPanes.

Return Value

Type: Boolean
True if at least one pane is visible, otherwise False.
See Also

Reference

IDockAwareWindowManager Interface
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.IsWindowPaneActive Method

IDockAwareWindowManagerIsWindowPaneActive Method

Note: This API is now obsolete.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("This property is obsolete.", false)]
bool IsWindowPaneActive(
    string windowname
)
[ObsoleteAttribute(L"This property is obsolete.", false)]
bool IsWindowPaneActive(
    String^ windowname
)

Parameters

windowname
Type: SystemString

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IDockAwareWindowManager.IsWindowPaneActive(System.String)"]

See Also

Reference

IDockAwareWindowManager Interface
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.LoadLayoutFromConfigFolder Method

IDockAwareWindowManagerLoadLayoutFromConfigFolder Method

Overload List
 | Name | Description
Public method | LoadLayoutFromConfigFolder(String, MemoryStream) | Load docking layout settings from application user setting
Public method | LoadLayoutFromConfigFolder(String, IContext, MemoryStream) | Load docking layout settings from application user setting.
Top
See Also

Reference

IDockAwareWindowManager Interface
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.LoadLayoutFromConfigFolder Method (String, MemoryStream)

IDockAwareWindowManagerLoadLayoutFromConfigFolder Method (String, MemoryStream)

Load docking layout settings from application user setting

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool LoadLayoutFromConfigFolder(
    string fileName,
    MemoryStream stream
)
bool LoadLayoutFromConfigFolder(
    String^ fileName,
    MemoryStream^ stream
)

Parameters

fileName
Type: SystemString
File name where layout setting is stored
stream
Type: System.IOMemoryStream
The stream containing the saved layout

Return Value

Type: Boolean
True if loading was succesful.
See Also

Reference

IDockAwareWindowManager Interface
LoadLayoutFromConfigFolder Overload
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.LoadLayoutFromConfigFolder Method (String, IContext, MemoryStream)

IDockAwareWindowManagerLoadLayoutFromConfigFolder Method (String, IContext, MemoryStream)

Load docking layout settings from application user setting.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool LoadLayoutFromConfigFolder(
    string fileName,
    IContext context,
    MemoryStream stream
)
bool LoadLayoutFromConfigFolder(
    String^ fileName,
    IContext^ context,
    MemoryStream^ stream
)

Parameters

fileName
Type: SystemString
File name where layout setting is saved
context
Type: VisualComponents.Create3DIContext
Application context
stream
Type: System.IOMemoryStream
The stream containing the saved layout

Return Value

Type: Boolean
True if loading was successful.
See Also

Reference

IDockAwareWindowManager Interface
LoadLayoutFromConfigFolder Overload
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.LoadQuickAccessToolbarContent Method

IDockAwareWindowManagerLoadQuickAccessToolbarContent Method

Load QuickAccessToolbar Elements from config file

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void LoadQuickAccessToolbarContent(
    QuickAccessToolbar quickAccessToolbar
)
void LoadQuickAccessToolbarContent(
    QuickAccessToolbar^ quickAccessToolbar
)

Parameters

quickAccessToolbar
Type: QuickAccessToolbar
Infragistics.Windows.Ribbon.XamRibbon.QuickAccessToolbar for the Infragistics.Windows.Ribbon.XamRibbon
See Also

Reference

IDockAwareWindowManager Interface
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.PopToFloatingWindow Method

IDockAwareWindowManagerPopToFloatingWindow Method

Note: This API is now obsolete.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("This property is obsolete.", false)]
void PopToFloatingWindow(
    string windowName,
    bool select
)
[ObsoleteAttribute(L"This property is obsolete.", false)]
void PopToFloatingWindow(
    String^ windowName,
    bool select
)

Parameters

windowName
Type: SystemString
select
Type: SystemBoolean
See Also

Reference

IDockAwareWindowManager Interface
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.SaveLayoutInConfigFolder Method

IDockAwareWindowManagerSaveLayoutInConfigFolder Method

Saves information about the current arrangement of the panes to the application user setting.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SaveLayoutInConfigFolder(
    string fileName,
    MemoryStream stream,
    bool overwrite
)
void SaveLayoutInConfigFolder(
    String^ fileName,
    MemoryStream^ stream,
    bool overwrite
)

Parameters

fileName
Type: SystemString
File name where layout is going to be stored
stream
Type: System.IOMemoryStream
The stream to which the layout should be saved
overwrite
Type: SystemBoolean
True to overwite file if it exist. False otherwise
See Also

Reference

IDockAwareWindowManager Interface
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.SaveQuickAccessToolbarContent Method

IDockAwareWindowManagerSaveQuickAccessToolbarContent Method

Save QuickAccessToolbar content to user config file

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SaveQuickAccessToolbarContent(
    QuickAccessToolbar quickAccessToolbar
)
void SaveQuickAccessToolbarContent(
    QuickAccessToolbar^ quickAccessToolbar
)

Parameters

quickAccessToolbar
Type: QuickAccessToolbar
Infragistics.Windows.Ribbon.XamRibbon.QuickAccessToolbar for the Infragistics.Windows.Ribbon.XamRibbon
See Also

Reference

IDockAwareWindowManager Interface
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.SetPanelSize Method

IDockAwareWindowManagerSetPanelSize Method

Note: This API is now obsolete.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("This property is obsolete.", false)]
void SetPanelSize(
    Screen viewModel,
    double size
)
[ObsoleteAttribute(L"This property is obsolete.", false)]
void SetPanelSize(
    Screen^ viewModel,
    double size
)

Parameters

viewModel
Type: Screen
size
Type: SystemDouble
See Also

Reference

IDockAwareWindowManager Interface
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.SetScreenVisibility Method

IDockAwareWindowManagerSetScreenVisibility Method

Overload List
 | Name | Description
Public method | SetScreenVisibility(IDockableScreen, Boolean) | Sets the visibility status of the ContentPanes which hold a screen of the specified type. If the screen is set to be shown, all the matching hidden panes are shown, and if no matches are found, a new one is created. If the screen is set to be invisible, they are simply hidden, and will be restored when the screen is again set to be visible.
Public method | SetScreenVisibility(IDockableScreen, Boolean, Boolean) | Sets the visibility status of the ContentPanes which hold a screen of the specified type. If the screen is set to be shown, all the matching hidden panes are shown, and if no matches are found, a new one is created. If the screen is set to be invisible, they are simply hidden, and will be restored when the screen is again set to be visible.
Top
See Also

Reference

IDockAwareWindowManager Interface
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.SetScreenVisibility Method (IDockableScreen, Boolean)

IDockAwareWindowManagerSetScreenVisibility Method (IDockableScreen, Boolean)

Sets the visibility status of the ContentPanes which hold a screen of the specified type. If the screen is set to be shown, all the matching hidden panes are shown, and if no matches are found, a new one is created. If the screen is set to be invisible, they are simply hidden, and will be restored when the screen is again set to be visible.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetScreenVisibility(
    IDockableScreen dockableScreen,
    bool shouldBeVisible
)
void SetScreenVisibility(
    IDockableScreen^ dockableScreen,
    bool shouldBeVisible
)

Parameters

dockableScreen
Type: VisualComponents.UX.SharedIDockableScreen
A screen whose type is used to get the ContentPanes.
shouldBeVisible
Type: SystemBoolean
If true, panes are shown, otherwise panes are hidden.
See Also

Reference

IDockAwareWindowManager Interface
SetScreenVisibility Overload
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.SetScreenVisibility Method (IDockableScreen, Boolean, Boolean)

IDockAwareWindowManagerSetScreenVisibility Method (IDockableScreen, Boolean, Boolean)

Sets the visibility status of the ContentPanes which hold a screen of the specified type. If the screen is set to be shown, all the matching hidden panes are shown, and if no matches are found, a new one is created. If the screen is set to be invisible, they are simply hidden, and will be restored when the screen is again set to be visible.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetScreenVisibility(
    IDockableScreen dockableScreen,
    bool shouldBeVisible,
    bool makeSelected = true
)
void SetScreenVisibility(
    IDockableScreen^ dockableScreen,
    bool shouldBeVisible,
    bool makeSelected = true
)

Parameters

dockableScreen
Type: VisualComponents.UX.SharedIDockableScreen
A screen whose type is used to get the ContentPanes.
shouldBeVisible
Type: SystemBoolean
If true, panes are shown, otherwise panes are hidden.
makeSelected (Optional)
Type: SystemBoolean
If true and pane is inside a tabbed panel, it's pane is made active.
See Also

Reference

IDockAwareWindowManager Interface
SetScreenVisibility Overload
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.ShowDockedWindow Method

IDockAwareWindowManagerShowDockedWindow Method

Shows a docked window.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ShowDockedWindow(
    string dockedWindowName,
    Object viewModel,
    Object context = null,
    bool selectWhenShown = true,
    DesiredPaneLocation dockstate = DesiredPaneLocation.DockedLeft,
    bool isPinned = true,
    Orientation splitterOrientation = Orientation.Horizontal,
    string splitPaneId = ""
)
void ShowDockedWindow(
    String^ dockedWindowName,
    Object^ viewModel,
    Object^ context = nullptr,
    bool selectWhenShown = true,
    DesiredPaneLocation dockstate = DesiredPaneLocation::DockedLeft,
    bool isPinned = true,
    Orientation splitterOrientation = Orientation::Horizontal,
    String^ splitPaneId = L""
)

Parameters

dockedWindowName
Type: SystemString
viewModel
Type: SystemObject
The view model.
context (Optional)
Type: SystemObject
The context.
selectWhenShown (Optional)
Type: SystemBoolean
If set to true the window will be selected when shown.
dockstate (Optional)
Type: VisualComponents.UX.SharedDesiredPaneLocation
The dock side (Left, Right, Top, Bottom).
isPinned (Optional)
Type: SystemBoolean
Initial pinning mode
splitterOrientation (Optional)
Type: System.Windows.ControlsOrientation
If multiple windows are shown at same panel, what splittersetting is used.
splitPaneId (Optional)
Type: SystemString
If multiple split panes exits, what split pane is used.
See Also

Reference

IDockAwareWindowManager Interface
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.ShowDockPanels Method

IDockAwareWindowManagerShowDockPanels Method

Overload List
 | Name | Description
Public method | ShowDockPanels | Shows all imported dock panels
Public method | ShowDockPanels(ListIDockableScreen) |
Top
See Also

Reference

IDockAwareWindowManager Interface
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.ShowDockPanels Method

IDockAwareWindowManagerShowDockPanels Method

Shows all imported dock panels

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ShowDockPanels()
void ShowDockPanels()
See Also

Reference

IDockAwareWindowManager Interface
ShowDockPanels Overload
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.ShowDockPanels Method (List(IDockableScreen))

IDockAwareWindowManagerShowDockPanels Method (ListIDockableScreen)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ShowDockPanels(
    List<IDockableScreen> dockScreens
)
void ShowDockPanels(
    List<IDockableScreen^>^ dockScreens
)

Parameters

dockScreens
Type: System.Collections.GenericListIDockableScreen
See Also

Reference

IDockAwareWindowManager Interface
ShowDockPanels Overload
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.ShowDocumentHostContent Method

IDockAwareWindowManagerShowDocumentHostContent Method

Shows a document host content.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ShowDocumentHostContent(
    string windowName,
    Object viewModel,
    Object context = null,
    bool selectWhenShown = true,
    string contentPaneName = null,
    Func<Object, IList, bool> contextMenuCallback = null
)
void ShowDocumentHostContent(
    String^ windowName,
    Object^ viewModel,
    Object^ context = nullptr,
    bool selectWhenShown = true,
    String^ contentPaneName = nullptr,
    Func<Object^, IList^, bool>^ contextMenuCallback = nullptr
)

Parameters

windowName
Type: SystemString
viewModel
Type: SystemObject
The view model.
context (Optional)
Type: SystemObject
The context.
selectWhenShown (Optional)
Type: SystemBoolean
If set to true the window will be selected when shown.
contentPaneName (Optional)
Type: SystemString
Existing content pane, if null new content pane is created.
contextMenuCallback (Optional)
Type: SystemFuncObject, IList, Boolean
Callback to call when window's context menu is opening.
See Also

Reference

IDockAwareWindowManager Interface
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.ShowDocumentWindow Method

IDockAwareWindowManagerShowDocumentWindow Method

Shows a document window.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ShowDocumentWindow(
    string windowName,
    Object viewModel,
    Object context = null,
    bool selectWhenShown = true,
    string contentPaneName = null,
    Func<Object, IList, bool> contextMenuCallback = null
)
void ShowDocumentWindow(
    String^ windowName,
    Object^ viewModel,
    Object^ context = nullptr,
    bool selectWhenShown = true,
    String^ contentPaneName = nullptr,
    Func<Object^, IList^, bool>^ contextMenuCallback = nullptr
)

Parameters

windowName
Type: SystemString
viewModel
Type: SystemObject
The view model.
context (Optional)
Type: SystemObject
The context.
selectWhenShown (Optional)
Type: SystemBoolean
If set to true the window will be selected when shown.
contentPaneName (Optional)
Type: SystemString
Existing content pane, if null new content pane is created.
contextMenuCallback (Optional)
Type: SystemFuncObject, IList, Boolean
Callback to call when window's context menu is opening.
See Also

Reference

IDockAwareWindowManager Interface
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.ShowFloatingWindow Method

IDockAwareWindowManagerShowFloatingWindow Method

Overload List
 | Name | Description
Public method | ShowFloatingWindow(String, Object, Object, Boolean, Boolean, Boolean) | Shows a floating window.
Public method | ShowFloatingWindow(String, Object, Size, Object, Boolean, Boolean, Boolean) | Shows a floating window.
Top
See Also

Reference

IDockAwareWindowManager Interface
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.ShowFloatingWindow Method (String, Object, Object, Boolean, Boolean, Boolean)

IDockAwareWindowManagerShowFloatingWindow Method (String, Object, Object, Boolean, Boolean, Boolean)

Shows a floating window.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ShowFloatingWindow(
    string namePrefix,
    Object viewModel,
    Object context = null,
    bool select = true,
    bool showExistingWindow = false,
    bool assignUniqueName = false
)
void ShowFloatingWindow(
    String^ namePrefix,
    Object^ viewModel,
    Object^ context = nullptr,
    bool select = true,
    bool showExistingWindow = false,
    bool assignUniqueName = false
)

Parameters

namePrefix
Type: SystemString
Internal window name prefix.
viewModel
Type: SystemObject
Window ViewModel.
context (Optional)
Type: SystemObject
Window context.
select (Optional)
Type: SystemBoolean
If set to true newly created window will be selected.
showExistingWindow (Optional)
Type: SystemBoolean
If set to true and window with the given viewModel already exists, it will be shown instead of creating a new window.
assignUniqueName (Optional)
Type: SystemBoolean
If set to true unique name will be assigned to a new window. Otherwise an existing window with the same internal name will be deleted.
See Also

Reference

IDockAwareWindowManager Interface
ShowFloatingWindow Overload
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.ShowFloatingWindow Method (String, Object, Size, Object, Boolean, Boolean, Boolean)

IDockAwareWindowManagerShowFloatingWindow Method (String, Object, Size, Object, Boolean, Boolean, Boolean)

Shows a floating window.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ShowFloatingWindow(
    string namePrefix,
    Object viewModel,
    Size size,
    Object context = null,
    bool select = true,
    bool showExistingWindow = false,
    bool assignUniqueName = false
)
void ShowFloatingWindow(
    String^ namePrefix,
    Object^ viewModel,
    Size size,
    Object^ context = nullptr,
    bool select = true,
    bool showExistingWindow = false,
    bool assignUniqueName = false
)

Parameters

namePrefix
Type: SystemString
Internal window name prefix.
viewModel
Type: SystemObject
Window ViewModel.
size
Type: System.WindowsSize
Window size.
context (Optional)
Type: SystemObject
Window context.
select (Optional)
Type: SystemBoolean
If set to true newly created window will be selected.
showExistingWindow (Optional)
Type: SystemBoolean
If set to true and window with the given viewModel already exists, it will be shown instead of creating a new window.
assignUniqueName (Optional)
Type: SystemBoolean
If set to true unique name will be assigned to a new window. Otherwise an existing window with the same internal name will be deleted.
See Also

Reference

IDockAwareWindowManager Interface
ShowFloatingWindow Overload
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager Events

The IDockAwareWindowManager type exposes the following members.

Events
 | Name | Description
Public event | ActiveDocumentChanged | Occurs when the DocumentContentHost Active Document changed.
Public event | DockPaneClosing | Occurs when IDockableScreen's ContentPane is about to be closed.
Public event | ScreenVisibilityChanged | Raised when the visibility of a screen has changed.
Top
See Also

Reference

IDockAwareWindowManager Interface
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.ActiveDocumentChanged Event

IDockAwareWindowManagerActiveDocumentChanged Event

Occurs when the DocumentContentHost Active Document changed.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event ActiveDocumentChangedHandler ActiveDocumentChanged
 event ActiveDocumentChangedHandler^ ActiveDocumentChanged {
    void add (ActiveDocumentChangedHandler^ value);
    void remove (ActiveDocumentChangedHandler^ value);
}

Value

Type: VisualComponents.UX.SharedActiveDocumentChangedHandler
See Also

Reference

IDockAwareWindowManager Interface
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.DockPaneClosing Event

IDockAwareWindowManagerDockPaneClosing Event

Occurs when IDockableScreen's ContentPane is about to be closed.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<PaneClosingEventArgs> DockPaneClosing
 event EventHandler<PaneClosingEventArgs^>^ DockPaneClosing {
    void add (EventHandler<PaneClosingEventArgs^>^ value);
    void remove (EventHandler<PaneClosingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerPaneClosingEventArgs
See Also

Reference

IDockAwareWindowManager Interface
VisualComponents.UX.Shared Namespace


IDockAwareWindowManager.ScreenVisibilityChanged Event

IDockAwareWindowManagerScreenVisibilityChanged Event

Raised when the visibility of a screen has changed.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler ScreenVisibilityChanged
 event EventHandler^ ScreenVisibilityChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IDockAwareWindowManager Interface
VisualComponents.UX.Shared Namespace


IDpiAwareViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDpiAwareViewModel
public interface class IDpiAwareViewModel

The IDpiAwareViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ReverseDpiScale |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IDpiAwareViewModel Properties

The IDpiAwareViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ReverseDpiScale |
Top
See Also

Reference

IDpiAwareViewModel Interface
VisualComponents.UX.Shared Namespace


IDpiAwareViewModel.ReverseDpiScale Property

IDpiAwareViewModelReverseDpiScale Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double ReverseDpiScale { get; set; }
property double ReverseDpiScale {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IDpiAwareViewModel Interface
VisualComponents.UX.Shared Namespace


IDrawingViewGenerationAction Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IDrawingViewGenerationAction
public interface class IDrawingViewGenerationAction

The IDrawingViewGenerationAction type exposes the following members.

Methods
 | Name | Description
Public method | CreateView | Creates a DrawingView from the previously selected componets of the HOME tab
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IDrawingViewGenerationAction Methods

The IDrawingViewGenerationAction type exposes the following members.

Methods
 | Name | Description
Public method | CreateView | Creates a DrawingView from the previously selected componets of the HOME tab
Top
See Also

Reference

IDrawingViewGenerationAction Interface
VisualComponents.UX.Shared Namespace


IDrawingViewGenerationAction.CreateView Method

IDrawingViewGenerationActionCreateView Method

Creates a DrawingView from the previously selected componets of the HOME tab

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void CreateView(
    DrawingViewPoints viewPoint
)
void CreateView(
    DrawingViewPoints viewPoint
)

Parameters

viewPoint
Type: VisualComponents.UX.SharedDrawingViewPoints
Defines the camara view point from where the drawing view is going to be created
See Also

Reference

IDrawingViewGenerationAction Interface
VisualComponents.UX.Shared Namespace


IECatalogue Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IECatalogue : IDockableScreen,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IECatalogue : IDockableScreen,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The IECatalogue type exposes the following members.

Properties
 | Name | Description
Public property | ContextFilter | Gets or sets the context filter. The context defines one or more contexts where the panel is visible. (Inherited from IDockableScreen.)
Public property | DesiredPanePosition | Gets the desired pane position. If multiple panes are added, panes are ordered using this property. (Inherited from IDockableScreen.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | Height | Gets the Height of the pane. (Inherited from IDockableScreen.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsLocalCopyingUnfinished | Returns true if downloading local copies of remote items is ongoing.
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsPinned | Gets or sets a Boolean value that indicates if the pane is pinned. (Inherited from IDockableScreen.)
Public property | IsSelected | Gets or sets a boolean value that indicates if the pane is selected in TabGroupPane (Inherited from IDockableScreen.)
Public property | IsVisible | Gets or sets a boolean value that indicates if the pane is visible (Inherited from IDockableScreen.)
Public property | PanelId | Gets the panel ID (Inherited from IDockableScreen.)
Public property | PaneLocation | Gets the desired panel location DesiredPaneLocation (Inherited from IDockableScreen.)
Public property | PaneOrientation | Gets the pane orientation (Inherited from IDockableScreen.)
Public property | SplitPaneId | Gets the split pane id. By default all panes within panel location use same split panel. Multiple split panels can be created by defining new split pane ids. (Inherited from IDockableScreen.)
 | TabGroupId | Gets the pane tab group id. Panes are splitted and ordered to different tabs within the splitpane based on TabGroupId. (Inherited from IDockableScreen.)
Public property | Width | Gets the Width of the pane. (Inherited from IDockableScreen.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | CleanupDatabaseAtShutdown | For internal use. Clears the CurrentLayout folder and removes all corresponding database entries, including the Downloaded source. Returns true if the cleanup succeeded, otherwise false.
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | LocalCopyingFinished | Raised after local copying of files has finished, or after a check for such pending files has finished.
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Public event | SourceIndexingFinished | Raised after local or remote sources have been indexed to the database.
Public event | SourceIndexingStarted | Raised when indexing local or remote sources to the database has started.
Public event | WarningMessage | Raised if a warning is produced e.g. during downloading local copies.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IECatalogue Properties

The IECatalogue type exposes the following members.

Properties
 | Name | Description
Public property | ContextFilter | Gets or sets the context filter. The context defines one or more contexts where the panel is visible. (Inherited from IDockableScreen.)
Public property | DesiredPanePosition | Gets the desired pane position. If multiple panes are added, panes are ordered using this property. (Inherited from IDockableScreen.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | Height | Gets the Height of the pane. (Inherited from IDockableScreen.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsLocalCopyingUnfinished | Returns true if downloading local copies of remote items is ongoing.
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsPinned | Gets or sets a Boolean value that indicates if the pane is pinned. (Inherited from IDockableScreen.)
Public property | IsSelected | Gets or sets a boolean value that indicates if the pane is selected in TabGroupPane (Inherited from IDockableScreen.)
Public property | IsVisible | Gets or sets a boolean value that indicates if the pane is visible (Inherited from IDockableScreen.)
Public property | PanelId | Gets the panel ID (Inherited from IDockableScreen.)
Public property | PaneLocation | Gets the desired panel location DesiredPaneLocation (Inherited from IDockableScreen.)
Public property | PaneOrientation | Gets the pane orientation (Inherited from IDockableScreen.)
Public property | SplitPaneId | Gets the split pane id. By default all panes within panel location use same split panel. Multiple split panels can be created by defining new split pane ids. (Inherited from IDockableScreen.)
 | TabGroupId | Gets the pane tab group id. Panes are splitted and ordered to different tabs within the splitpane based on TabGroupId. (Inherited from IDockableScreen.)
Public property | Width | Gets the Width of the pane. (Inherited from IDockableScreen.)
Top
See Also

Reference

IECatalogue Interface
VisualComponents.UX.Shared Namespace


IECatalogue.IsLocalCopyingUnfinished Property

IECatalogueIsLocalCopyingUnfinished Property

Returns true if downloading local copies of remote items is ongoing.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsLocalCopyingUnfinished { get; }
property bool IsLocalCopyingUnfinished {
    bool get ();
}

Property Value

Type: Boolean
Remarks
This property does not implement property change notifications.
See Also

Reference

IECatalogue Interface
VisualComponents.UX.Shared Namespace


IECatalogue Methods

The IECatalogue type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | CleanupDatabaseAtShutdown | For internal use. Clears the CurrentLayout folder and removes all corresponding database entries, including the Downloaded source. Returns true if the cleanup succeeded, otherwise false.
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IECatalogue Interface
VisualComponents.UX.Shared Namespace


IECatalogue.CleanupDatabaseAtShutdown Method

IECatalogueCleanupDatabaseAtShutdown Method

For internal use. Clears the CurrentLayout folder and removes all corresponding database entries, including the Downloaded source. Returns true if the cleanup succeeded, otherwise false.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CleanupDatabaseAtShutdown()
bool CleanupDatabaseAtShutdown()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IECatalogue.CleanupDatabaseAtShutdown"]

See Also

Reference

IECatalogue Interface
VisualComponents.UX.Shared Namespace


IECatalogue Events

The IECatalogue type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | LocalCopyingFinished | Raised after local copying of files has finished, or after a check for such pending files has finished.
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Public event | SourceIndexingFinished | Raised after local or remote sources have been indexed to the database.
Public event | SourceIndexingStarted | Raised when indexing local or remote sources to the database has started.
Public event | WarningMessage | Raised if a warning is produced e.g. during downloading local copies.
Top
See Also

Reference

IECatalogue Interface
VisualComponents.UX.Shared Namespace


IECatalogue.LocalCopyingFinished Event

IECatalogueLocalCopyingFinished Event

Raised after local copying of files has finished, or after a check for such pending files has finished.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<EventArgs> LocalCopyingFinished
 event EventHandler<EventArgs^>^ LocalCopyingFinished {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

IECatalogue Interface
VisualComponents.UX.Shared Namespace


IECatalogue.SourceIndexingFinished Event

IECatalogueSourceIndexingFinished Event

Raised after local or remote sources have been indexed to the database.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<SourceIndexingEventArgs> SourceIndexingFinished
 event EventHandler<SourceIndexingEventArgs^>^ SourceIndexingFinished {
    void add (EventHandler<SourceIndexingEventArgs^>^ value);
    void remove (EventHandler<SourceIndexingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerSourceIndexingEventArgs
See Also

Reference

IECatalogue Interface
VisualComponents.UX.Shared Namespace


IECatalogue.SourceIndexingStarted Event

IECatalogueSourceIndexingStarted Event

Raised when indexing local or remote sources to the database has started.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<SourceIndexingEventArgs> SourceIndexingStarted
 event EventHandler<SourceIndexingEventArgs^>^ SourceIndexingStarted {
    void add (EventHandler<SourceIndexingEventArgs^>^ value);
    void remove (EventHandler<SourceIndexingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerSourceIndexingEventArgs
See Also

Reference

IECatalogue Interface
VisualComponents.UX.Shared Namespace


IECatalogue.WarningMessage Event

IECatalogueWarningMessage Event

Raised if a warning is produced e.g. during downloading local copies.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<WarningMessageArgs> WarningMessage
 event EventHandler<WarningMessageArgs^>^ WarningMessage {
    void add (EventHandler<WarningMessageArgs^>^ value);
    void remove (EventHandler<WarningMessageArgs^>^ value);
}

Value

Type: SystemEventHandlerWarningMessageArgs
See Also

Reference

IECatalogue Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationAction Interface

Action interface for recording vcax animation files.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IExportToAnimationAction : IResult
public interface class IExportToAnimationAction : IResult

The IExportToAnimationAction type exposes the following members.

Properties
 | Name | Description
Public property | CompressionLevel | Select specific compression plugin, 0 - uncompressed
Public property | FileUri | Gets or sets the recording destination file.
Public property | FrameRate | Gets or sets recording frame rate (fps).
Public property | IsRecording | Obsolete. Defines if recording is in progress.
Public property | IsStarted | Either recording vcax file, or connected to a server (for streaming).
Public property | OpenFileAfterRecording | Defines if the file is opened after recording has been finished.
Public property | RecordingMethod |
Public property | RecordingName | Gets or sets the metadata name of the recording.
Public property | SimulationRuntime | Gets or sets recording (max) run time.
Public property | SimulationTimeStreaming |
Public property | SimulationWarmupTime | Gets or sets recording warm up time.
Public property | StreamingHost | Gets or sets the hostname of the streaming viewer.
Public property | StreamingPort | Gets or sets the port of the streaming viewer.
Public property | StreamingServerRunning |
Top
Methods
 | Name | Description
Public method | Execute | (Inherited from IResult.)
Public method | RequestStreamingClear | Check socket connection, and request clear.
Public method | StartRecording | Starts simulation and recording a new vcax animation file.
Public method | StartStreamingServer |
Public method | StartStreamingToClient |
Public method | StartStreamingToServer |
Public method | StopRecording | Stops recording or disconnects from streaming server. When not streaming creates the resulting vcax animation file.
Top
Events
 | Name | Description
Public event | Completed | (Inherited from IResult.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IExportToAnimationAction Properties

The IExportToAnimationAction type exposes the following members.

Properties
 | Name | Description
Public property | CompressionLevel | Select specific compression plugin, 0 - uncompressed
Public property | FileUri | Gets or sets the recording destination file.
Public property | FrameRate | Gets or sets recording frame rate (fps).
Public property | IsRecording | Obsolete. Defines if recording is in progress.
Public property | IsStarted | Either recording vcax file, or connected to a server (for streaming).
Public property | OpenFileAfterRecording | Defines if the file is opened after recording has been finished.
Public property | RecordingMethod |
Public property | RecordingName | Gets or sets the metadata name of the recording.
Public property | SimulationRuntime | Gets or sets recording (max) run time.
Public property | SimulationTimeStreaming |
Public property | SimulationWarmupTime | Gets or sets recording warm up time.
Public property | StreamingHost | Gets or sets the hostname of the streaming viewer.
Public property | StreamingPort | Gets or sets the port of the streaming viewer.
Public property | StreamingServerRunning |
Top
See Also

Reference

IExportToAnimationAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationAction.CompressionLevel Property

IExportToAnimationActionCompressionLevel Property

Select specific compression plugin, 0 - uncompressed

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int CompressionLevel { get; set; }
property int CompressionLevel {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IExportToAnimationAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationAction.FileUri Property

IExportToAnimationActionFileUri Property

Gets or sets the recording destination file.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Uri FileUri { get; set; }
property Uri^ FileUri {
    Uri^ get ();
    void set (Uri^ value);
}

Property Value

Type: Uri
See Also

Reference

IExportToAnimationAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationAction.FrameRate Property

IExportToAnimationActionFrameRate Property

Gets or sets recording frame rate (fps).

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int FrameRate { get; set; }
property int FrameRate {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IExportToAnimationAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationAction.IsRecording Property

IExportToAnimationActionIsRecording Property

Note: This API is now obsolete.

Defines if recording is in progress.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Use IsStarted.")]
bool IsRecording { get; }
[ObsoleteAttribute(L"Use IsStarted.")]
property bool IsRecording {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IExportToAnimationAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationAction.IsStarted Property

IExportToAnimationActionIsStarted Property

Either recording vcax file, or connected to a server (for streaming).

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsStarted { get; }
property bool IsStarted {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IExportToAnimationAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationAction.OpenFileAfterRecording Property

IExportToAnimationActionOpenFileAfterRecording Property

Defines if the file is opened after recording has been finished.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool OpenFileAfterRecording { get; set; }
property bool OpenFileAfterRecording {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IExportToAnimationAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationAction.RecordingMethod Property

IExportToAnimationActionRecordingMethod Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
AnimationRecordingMethod RecordingMethod { get; }
property AnimationRecordingMethod RecordingMethod {
    AnimationRecordingMethod get ();
}

Property Value

Type: AnimationRecordingMethod
See Also

Reference

IExportToAnimationAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationAction.RecordingName Property

IExportToAnimationActionRecordingName Property

Gets or sets the metadata name of the recording.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string RecordingName { get; set; }
property String^ RecordingName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IExportToAnimationAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationAction.SimulationRuntime Property

IExportToAnimationActionSimulationRuntime Property

Gets or sets recording (max) run time.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double SimulationRuntime { get; set; }
property double SimulationRuntime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IExportToAnimationAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationAction.SimulationTimeStreaming Property

IExportToAnimationActionSimulationTimeStreaming Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SimulationTimeStreaming { get; set; }
property bool SimulationTimeStreaming {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IExportToAnimationAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationAction.SimulationWarmupTime Property

IExportToAnimationActionSimulationWarmupTime Property

Gets or sets recording warm up time.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double SimulationWarmupTime { get; set; }
property double SimulationWarmupTime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IExportToAnimationAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationAction.StreamingHost Property

IExportToAnimationActionStreamingHost Property

Gets or sets the hostname of the streaming viewer.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string StreamingHost { get; set; }
property String^ StreamingHost {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IExportToAnimationAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationAction.StreamingPort Property

IExportToAnimationActionStreamingPort Property

Gets or sets the port of the streaming viewer.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string StreamingPort { get; set; }
property String^ StreamingPort {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IExportToAnimationAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationAction.StreamingServerRunning Property

IExportToAnimationActionStreamingServerRunning Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool StreamingServerRunning { get; }
property bool StreamingServerRunning {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IExportToAnimationAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationAction Methods

The IExportToAnimationAction type exposes the following members.

Methods
 | Name | Description
Public method | Execute | (Inherited from IResult.)
Public method | RequestStreamingClear | Check socket connection, and request clear.
Public method | StartRecording | Starts simulation and recording a new vcax animation file.
Public method | StartStreamingServer |
Public method | StartStreamingToClient |
Public method | StartStreamingToServer |
Public method | StopRecording | Stops recording or disconnects from streaming server. When not streaming creates the resulting vcax animation file.
Top
See Also

Reference

IExportToAnimationAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationAction.RequestStreamingClear Method

IExportToAnimationActionRequestStreamingClear Method

Check socket connection, and request clear.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool RequestStreamingClear()
bool RequestStreamingClear()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IExportToAnimationAction.RequestStreamingClear"]

See Also

Reference

IExportToAnimationAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationAction.StartRecording Method

IExportToAnimationActionStartRecording Method

Starts simulation and recording a new vcax animation file.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StartRecording()
void StartRecording()
See Also

Reference

IExportToAnimationAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationAction.StartStreamingServer Method

IExportToAnimationActionStartStreamingServer Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool StartStreamingServer(
    int port
)
bool StartStreamingServer(
    int port
)

Parameters

port
Type: SystemInt32

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IExportToAnimationAction.StartStreamingServer(System.Int32)"]

See Also

Reference

IExportToAnimationAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationAction.StartStreamingToClient Method

IExportToAnimationActionStartStreamingToClient Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool StartStreamingToClient(
    Socket[] sockets,
    bool webSocketMode,
    bool protoBufMode
)
bool StartStreamingToClient(
    array<Socket^>^ sockets,
    bool webSocketMode,
    bool protoBufMode
)

Parameters

sockets
Type: System.Net.SocketsSocket
webSocketMode
Type: SystemBoolean
protoBufMode
Type: SystemBoolean

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IExportToAnimationAction.StartStreamingToClient(System.Net.Sockets.Socket[],System.Boolean,System.Boolean)"]

See Also

Reference

IExportToAnimationAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationAction.StartStreamingToServer Method

IExportToAnimationActionStartStreamingToServer Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StartStreamingToServer()
void StartStreamingToServer()
See Also

Reference

IExportToAnimationAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationAction.StopRecording Method

IExportToAnimationActionStopRecording Method

Stops recording or disconnects from streaming server. When not streaming creates the resulting vcax animation file.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StopRecording()
void StopRecording()
See Also

Reference

IExportToAnimationAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationAction Events

The IExportToAnimationAction type exposes the following members.

Events
 | Name | Description
Public event | Completed | (Inherited from IResult.)
Top
See Also

Reference

IExportToAnimationAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IExportToAnimationCommand : IActionItem,
    INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IExportToAnimationCommand : IActionItem,
    INotifyPropertyChangedEx, INotifyPropertyChanged

The IExportToAnimationCommand type exposes the following members.

Properties
 | Name | Description
Public property | CanExecute | (Inherited from IActionItem.)
Public property | CommandPanelAction |
Public property | Content | Item text/header. (Inherited from IActionItem.)
Public property | ContextFilter | Defines application contexts where action is available. (Inherited from IActionItem.)
Public property | ControlType | (Inherited from IActionItem.)
Public property | IconName | Gets the icon name. (Inherited from IActionItem.)
Public property | Id | (Inherited from IActionItem.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | RibbonId | Required for ribbon only, as all items in ribbon groups are required to have a unique id. (Inherited from IActionItem.)
Public property | SiteOrder | (Inherited from IActionItem.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from IActionItem.)
Public property | Visibility | Item Visibility (Inherited from IActionItem.)
Top
Methods
 | Name | Description
Public method | EvaluateCanExecute | (Inherited from IActionItem.)
Public method | Execute | Note: When executed from UI buttons we also call BeforeExecute(). Note: This is executed from both r-click and normal UI buttons. If need to distinguish between executing 'with command panel' and 'immediate execution' inherit from ActionItemT1 and define both Execute() and Execute(bool). Note: Some actions also use IsChecked to execute. They call BeforeExecute() manually. (Inherited from IActionItem.)
Public method | Execute(PropertyCollection) | (Inherited from IActionItem.)
Public method | Execute(SetupPythonActionMessage) | Obsolete. (Inherited from IActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from IActionItem.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from IActionItem.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IExportToAnimationCommand Properties

The IExportToAnimationCommand type exposes the following members.

Properties
 | Name | Description
Public property | CanExecute | (Inherited from IActionItem.)
Public property | CommandPanelAction |
Public property | Content | Item text/header. (Inherited from IActionItem.)
Public property | ContextFilter | Defines application contexts where action is available. (Inherited from IActionItem.)
Public property | ControlType | (Inherited from IActionItem.)
Public property | IconName | Gets the icon name. (Inherited from IActionItem.)
Public property | Id | (Inherited from IActionItem.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | RibbonId | Required for ribbon only, as all items in ribbon groups are required to have a unique id. (Inherited from IActionItem.)
Public property | SiteOrder | (Inherited from IActionItem.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from IActionItem.)
Public property | Visibility | Item Visibility (Inherited from IActionItem.)
Top
See Also

Reference

IExportToAnimationCommand Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationCommand.CommandPanelAction Property

IExportToAnimationCommandCommandPanelAction Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IExportToAnimationCommandPanelAction CommandPanelAction { get; }
property IExportToAnimationCommandPanelAction^ CommandPanelAction {
    IExportToAnimationCommandPanelAction^ get ();
}

Property Value

Type: IExportToAnimationCommandPanelAction
See Also

Reference

IExportToAnimationCommand Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationCommand Methods

The IExportToAnimationCommand type exposes the following members.

Methods
 | Name | Description
Public method | EvaluateCanExecute | (Inherited from IActionItem.)
Public method | Execute | Note: When executed from UI buttons we also call BeforeExecute(). Note: This is executed from both r-click and normal UI buttons. If need to distinguish between executing 'with command panel' and 'immediate execution' inherit from ActionItemT1 and define both Execute() and Execute(bool). Note: Some actions also use IsChecked to execute. They call BeforeExecute() manually. (Inherited from IActionItem.)
Public method | Execute(PropertyCollection) | (Inherited from IActionItem.)
Public method | Execute(SetupPythonActionMessage) | Obsolete. (Inherited from IActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from IActionItem.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from IActionItem.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Top
See Also

Reference

IExportToAnimationCommand Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationCommand Events

The IExportToAnimationCommand type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IExportToAnimationCommand Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationCommandPanelAction Interface

Export to animation command panel interface.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IExportToAnimationCommandPanelAction : ICommandPanelAction
public interface class IExportToAnimationCommandPanelAction : ICommandPanelAction

The IExportToAnimationCommandPanelAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | AllowsCloudUpload | Recording allows animation to be stored in the cloud
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | IsStarted | Either recording vcax file, or connected to a server (for streaming).
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Top
Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Public method | StartRecording | Opens up the animation recording command panel.
Public method | StartRecordingEx | Starts recording the animation file, or connects to the streaming server.
Public method | StartRecordingEx2 | Starts recording the animation file, or connects to the streaming server. Does this without showing the command panel.
Public method | StopRecording | Closes the recording command panel.
Public method | StopRecordingEx | Stops recording, or stops streaming.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IExportToAnimationCommandPanelAction Properties

The IExportToAnimationCommandPanelAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | AllowsCloudUpload | Recording allows animation to be stored in the cloud
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | IsStarted | Either recording vcax file, or connected to a server (for streaming).
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

IExportToAnimationCommandPanelAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationCommandPanelAction.AllowsCloudUpload Property

IExportToAnimationCommandPanelActionAllowsCloudUpload Property

Recording allows animation to be stored in the cloud

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool AllowsCloudUpload { get; }
property bool AllowsCloudUpload {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IExportToAnimationCommandPanelAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationCommandPanelAction.IsStarted Property

IExportToAnimationCommandPanelActionIsStarted Property

Either recording vcax file, or connected to a server (for streaming).

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsStarted { get; }
property bool IsStarted {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IExportToAnimationCommandPanelAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationCommandPanelAction Methods

The IExportToAnimationCommandPanelAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Public method | StartRecording | Opens up the animation recording command panel.
Public method | StartRecordingEx | Starts recording the animation file, or connects to the streaming server.
Public method | StartRecordingEx2 | Starts recording the animation file, or connects to the streaming server. Does this without showing the command panel.
Public method | StopRecording | Closes the recording command panel.
Public method | StopRecordingEx | Stops recording, or stops streaming.
Top
See Also

Reference

IExportToAnimationCommandPanelAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationCommandPanelAction.StartRecording Method

IExportToAnimationCommandPanelActionStartRecording Method

Opens up the animation recording command panel.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StartRecording()
void StartRecording()
See Also

Reference

IExportToAnimationCommandPanelAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationCommandPanelAction.StartRecordingEx Method

IExportToAnimationCommandPanelActionStartRecordingEx Method

Starts recording the animation file, or connects to the streaming server.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StartRecordingEx()
void StartRecordingEx()
See Also

Reference

IExportToAnimationCommandPanelAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationCommandPanelAction.StartRecordingEx2 Method

IExportToAnimationCommandPanelActionStartRecordingEx2 Method

Starts recording the animation file, or connects to the streaming server. Does this without showing the command panel.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StartRecordingEx2()
void StartRecordingEx2()
See Also

Reference

IExportToAnimationCommandPanelAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationCommandPanelAction.StopRecording Method

IExportToAnimationCommandPanelActionStopRecording Method

Closes the recording command panel.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StopRecording()
void StopRecording()
See Also

Reference

IExportToAnimationCommandPanelAction Interface
VisualComponents.UX.Shared Namespace


IExportToAnimationCommandPanelAction.StopRecordingEx Method

IExportToAnimationCommandPanelActionStopRecordingEx Method

Stops recording, or stops streaming.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StopRecordingEx()
void StopRecordingEx()
See Also

Reference

IExportToAnimationCommandPanelAction Interface
VisualComponents.UX.Shared Namespace


IExportToPDFCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IExportToPDFCommand
public interface class IExportToPDFCommand
See Also

Reference

VisualComponents.UX.Shared Namespace


IExportToPDFViewModel Interface

Interface to pdf recording UI. Not defined in 3DEmbedded. Note: both methods also start/stop simulation on every execution.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IExportToPDFViewModel
public interface class IExportToPDFViewModel

The IExportToPDFViewModel type exposes the following members.

Methods
 | Name | Description
Public method | StartRecordingEx |
Public method | StopRecordingEx |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IExportToPDFViewModel Methods

The IExportToPDFViewModel type exposes the following members.

Methods
 | Name | Description
Public method | StartRecordingEx |
Public method | StopRecordingEx |
Top
See Also

Reference

IExportToPDFViewModel Interface
VisualComponents.UX.Shared Namespace


IExportToPDFViewModel.StartRecordingEx Method

IExportToPDFViewModelStartRecordingEx Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StartRecordingEx()
void StartRecordingEx()
See Also

Reference

IExportToPDFViewModel Interface
VisualComponents.UX.Shared Namespace


IExportToPDFViewModel.StopRecordingEx Method

IExportToPDFViewModelStopRecordingEx Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StopRecordingEx(
    bool save
)
void StopRecordingEx(
    bool save
)

Parameters

save
Type: SystemBoolean
See Also

Reference

IExportToPDFViewModel Interface
VisualComponents.UX.Shared Namespace


IExportToVideoCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IExportToVideoCommand
public interface class IExportToVideoCommand
See Also

Reference

VisualComponents.UX.Shared Namespace


IExportToVideoViewModel Interface

Interface to pdf recording UI. Not defined in 3DEmbedded. Note: both methods also start/stop simulation on every execution.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IExportToVideoViewModel
public interface class IExportToVideoViewModel

The IExportToVideoViewModel type exposes the following members.

Methods
 | Name | Description
Public method | StartRecordingEx |
Public method | StopRecordingEx |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IExportToVideoViewModel Methods

The IExportToVideoViewModel type exposes the following members.

Methods
 | Name | Description
Public method | StartRecordingEx |
Public method | StopRecordingEx |
Top
See Also

Reference

IExportToVideoViewModel Interface
VisualComponents.UX.Shared Namespace


IExportToVideoViewModel.StartRecordingEx Method

IExportToVideoViewModelStartRecordingEx Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StartRecordingEx()
void StartRecordingEx()
See Also

Reference

IExportToVideoViewModel Interface
VisualComponents.UX.Shared Namespace


IExportToVideoViewModel.StopRecordingEx Method

IExportToVideoViewModelStopRecordingEx Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StopRecordingEx(
    bool save
)
void StopRecordingEx(
    bool save
)

Parameters

save
Type: SystemBoolean
See Also

Reference

IExportToVideoViewModel Interface
VisualComponents.UX.Shared Namespace


IExportViewModel Interface

Export view model interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IExportViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IExportViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The IExportViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IExportViewModel Properties

The IExportViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
See Also

Reference

IExportViewModel Interface
VisualComponents.UX.Shared Namespace


IExportViewModel Methods

The IExportViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IExportViewModel Interface
VisualComponents.UX.Shared Namespace


IExportViewModel Events

The IExportViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IExportViewModel Interface
VisualComponents.UX.Shared Namespace


IFileDialogService Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IFileDialogService
public interface class IFileDialogService

The IFileDialogService type exposes the following members.

Methods
 | Name | Description
Public method | OpenFileDialog(String) | Open file dialog
Public method | OpenFileDialog(String, String, String, String) | Open file dialog
Public method | OpenFileDialogDefault | Open file dialog with default parameters
Public method | SaveAsFileDialog(String, String, String, String) | "Save As" file dialog
Public method | SaveAsFileDialog(String, String, String, String, String) | "Save As" file dialog
Public method | SaveFileDialog(String) | Save file dialog
Public method | SaveFileDialog(String, String) | Save file dialog
Public method | SaveFileDialog(String, String, String, String) | Save file dialog
Public method | SaveFileDialog(String, String, String, String, Int32) | Save file dialog
Public method | SaveFileDialog(String, String, String, String, String) | Save file dialog
Public method | SaveFileDialog(String, String, String, String, Int32, String) | Save file dialog
Public method | SaveFileDialogDefault | Save file dialog with default parameters
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IFileDialogService Methods

The IFileDialogService type exposes the following members.

Methods
 | Name | Description
Public method | OpenFileDialog(String) | Open file dialog
Public method | OpenFileDialog(String, String, String, String) | Open file dialog
Public method | OpenFileDialogDefault | Open file dialog with default parameters
Public method | SaveAsFileDialog(String, String, String, String) | "Save As" file dialog
Public method | SaveAsFileDialog(String, String, String, String, String) | "Save As" file dialog
Public method | SaveFileDialog(String) | Save file dialog
Public method | SaveFileDialog(String, String) | Save file dialog
Public method | SaveFileDialog(String, String, String, String) | Save file dialog
Public method | SaveFileDialog(String, String, String, String, Int32) | Save file dialog
Public method | SaveFileDialog(String, String, String, String, String) | Save file dialog
Public method | SaveFileDialog(String, String, String, String, Int32, String) | Save file dialog
Public method | SaveFileDialogDefault | Save file dialog with default parameters
Top
See Also

Reference

IFileDialogService Interface
VisualComponents.UX.Shared Namespace


IFileDialogService.OpenFileDialog Method

IFileDialogServiceOpenFileDialog Method

Overload List
 | Name | Description
Public method | OpenFileDialog(String) | Open file dialog
Public method | OpenFileDialog(String, String, String, String) | Open file dialog
Top
See Also

Reference

IFileDialogService Interface
VisualComponents.UX.Shared Namespace


IFileDialogService.OpenFileDialog Method (String)

IFileDialogServiceOpenFileDialog Method (String)

Open file dialog

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string OpenFileDialog(
    string initialDirectory
)
String^ OpenFileDialog(
    String^ initialDirectory
)

Parameters

initialDirectory
Type: SystemString
initial directory that is displayed by a file dialog

Return Value

Type: String
the full path of the file selected in a file dialog
See Also

Reference

IFileDialogService Interface
OpenFileDialog Overload
VisualComponents.UX.Shared Namespace


IFileDialogService.OpenFileDialog Method (String, String, String, String)

IFileDialogServiceOpenFileDialog Method (String, String, String, String)

Open file dialog

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string OpenFileDialog(
    string initialDirectory,
    string defaultPath,
    string filter,
    string defaultExtension
)
String^ OpenFileDialog(
    String^ initialDirectory,
    String^ defaultPath,
    String^ filter,
    String^ defaultExtension
)

Parameters

initialDirectory
Type: SystemString
initial directory that is displayed by a file dialog
defaultPath
Type: SystemString
a string containing the full path of the file selected in a file dialog
filter
Type: SystemString
a filter string that determines what types of files are displayed from the dialog
defaultExtension
Type: SystemString
a value that specifies the default extension string to use to filter the list of files that are displayed

Return Value

Type: String
the full path of the file selected in a file dialog
See Also

Reference

IFileDialogService Interface
OpenFileDialog Overload
VisualComponents.UX.Shared Namespace


IFileDialogService.OpenFileDialogDefault Method

IFileDialogServiceOpenFileDialogDefault Method

Open file dialog with default parameters

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string OpenFileDialogDefault()
String^ OpenFileDialogDefault()

Return Value

Type: String
path and file name
Remarks
It calls OpenFileDialog with default parameters
See Also

Reference

IFileDialogService Interface
VisualComponents.UX.Shared Namespace


IFileDialogService.SaveAsFileDialog Method

IFileDialogServiceSaveAsFileDialog Method

Overload List
 | Name | Description
Public method | SaveAsFileDialog(String, String, String, String) | "Save As" file dialog
Public method | SaveAsFileDialog(String, String, String, String, String) | "Save As" file dialog
Top
See Also

Reference

IFileDialogService Interface
VisualComponents.UX.Shared Namespace


IFileDialogService.SaveAsFileDialog Method (String, String, String, String)

IFileDialogServiceSaveAsFileDialog Method (String, String, String, String)

"Save As" file dialog

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string SaveAsFileDialog(
    string initialDirectory,
    string defaultPath,
    string filter,
    string defaultExtension
)
String^ SaveAsFileDialog(
    String^ initialDirectory,
    String^ defaultPath,
    String^ filter,
    String^ defaultExtension
)

Parameters

initialDirectory
Type: SystemString
initial directory that is displayed by a file dialog
defaultPath
Type: SystemString
a string containing the full path of the file selected in a file dialog
filter
Type: SystemString
a filter string that determines what types of files are displayed from the dialog
defaultExtension
Type: SystemString
a value that specifies the default extension string to use to filter the list of files that are displayed

Return Value

Type: String
the full path of the file saved
See Also

Reference

IFileDialogService Interface
SaveAsFileDialog Overload
VisualComponents.UX.Shared Namespace


IFileDialogService.SaveAsFileDialog Method (String, String, String, String, String)

IFileDialogServiceSaveAsFileDialog Method (String, String, String, String, String)

"Save As" file dialog

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string SaveAsFileDialog(
    string initialDirectory,
    string defaultPath,
    string filter,
    string defaultExtension,
    string title
)
String^ SaveAsFileDialog(
    String^ initialDirectory,
    String^ defaultPath,
    String^ filter,
    String^ defaultExtension,
    String^ title
)

Parameters

initialDirectory
Type: SystemString
initial directory that is displayed by a file dialog
defaultPath
Type: SystemString
a string containing the full path of the file selected in a file dialog
filter
Type: SystemString
a filter string that determines what types of files are displayed from the dialog
defaultExtension
Type: SystemString
a value that specifies the default extension string to use to filter the list of files that are displayed
title
Type: SystemString
Title of the file dialog box.

Return Value

Type: String
the full path of the file saved
See Also

Reference

IFileDialogService Interface
SaveAsFileDialog Overload
VisualComponents.UX.Shared Namespace


IFileDialogService.SaveFileDialog Method

IFileDialogServiceSaveFileDialog Method

Overload List
 | Name | Description
Public method | SaveFileDialog(String) | Save file dialog
Public method | SaveFileDialog(String, String) | Save file dialog
Public method | SaveFileDialog(String, String, String, String) | Save file dialog
Public method | SaveFileDialog(String, String, String, String, Int32) | Save file dialog
Public method | SaveFileDialog(String, String, String, String, String) | Save file dialog
Public method | SaveFileDialog(String, String, String, String, Int32, String) | Save file dialog
Top
See Also

Reference

IFileDialogService Interface
VisualComponents.UX.Shared Namespace


IFileDialogService.SaveFileDialog Method (String)

IFileDialogServiceSaveFileDialog Method (String)

Save file dialog

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string SaveFileDialog(
    string initialDirectory
)
String^ SaveFileDialog(
    String^ initialDirectory
)

Parameters

initialDirectory
Type: SystemString
initial directory that is displayed by a file dialog

Return Value

Type: String
the full path of the file saved
See Also

Reference

IFileDialogService Interface
SaveFileDialog Overload
VisualComponents.UX.Shared Namespace


IFileDialogService.SaveFileDialog Method (String, String)

IFileDialogServiceSaveFileDialog Method (String, String)

Save file dialog

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string SaveFileDialog(
    string fileName,
    string initialDirectory
)
String^ SaveFileDialog(
    String^ fileName,
    String^ initialDirectory
)

Parameters

fileName
Type: SystemString
initial file name that is displayed by a file dialog
initialDirectory
Type: SystemString
initial directory that is displayed by a file dialog

Return Value

Type: String
the full path of the file saved
See Also

Reference

IFileDialogService Interface
SaveFileDialog Overload
VisualComponents.UX.Shared Namespace


IFileDialogService.SaveFileDialog Method (String, String, String, String)

IFileDialogServiceSaveFileDialog Method (String, String, String, String)

Save file dialog

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string SaveFileDialog(
    string initialDirectory,
    string defaultPath,
    string filter,
    string defaultExtension
)
String^ SaveFileDialog(
    String^ initialDirectory,
    String^ defaultPath,
    String^ filter,
    String^ defaultExtension
)

Parameters

initialDirectory
Type: SystemString
initial directory that is displayed by a file dialog
defaultPath
Type: SystemString
a string containing the full path of the file selected in a file dialog
filter
Type: SystemString
a filter string that determines what types of files are displayed from the dialog
defaultExtension
Type: SystemString
a value that specifies the default extension string to use to filter the list of files that are displayed

Return Value

Type: String
the full path of the file saved
See Also

Reference

IFileDialogService Interface
SaveFileDialog Overload
VisualComponents.UX.Shared Namespace


IFileDialogService.SaveFileDialog Method (String, String, String, String, Int32)

IFileDialogServiceSaveFileDialog Method (String, String, String, String, Int32)

Save file dialog

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string SaveFileDialog(
    string initialDirectory,
    string defaultPath,
    string filter,
    string defaultExtension,
    out int selectedFilter
)
String^ SaveFileDialog(
    String^ initialDirectory,
    String^ defaultPath,
    String^ filter,
    String^ defaultExtension,
    [OutAttribute] int% selectedFilter
)

Parameters

initialDirectory
Type: SystemString
initial directory that is displayed by a file dialog
defaultPath
Type: SystemString
a string containing the full path of the file selected in a file dialog
filter
Type: SystemString
a filter string that determines what types of files are displayed from the dialog
defaultExtension
Type: SystemString
a value that specifies the default extension string to use to filter the list of files that are displayed
selectedFilter
Type: SystemInt32
the index of the filter currently selected in a file dialog

Return Value

Type: String
the full path of the file saved
See Also

Reference

IFileDialogService Interface
SaveFileDialog Overload
VisualComponents.UX.Shared Namespace


IFileDialogService.SaveFileDialog Method (String, String, String, String, String)

IFileDialogServiceSaveFileDialog Method (String, String, String, String, String)

Save file dialog

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string SaveFileDialog(
    string initialDirectory,
    string defaultPath,
    string filter,
    string defaultExtension,
    string title
)
String^ SaveFileDialog(
    String^ initialDirectory,
    String^ defaultPath,
    String^ filter,
    String^ defaultExtension,
    String^ title
)

Parameters

initialDirectory
Type: SystemString
initial directory that is displayed by a file dialog
defaultPath
Type: SystemString
a string containing the full path of the file selected in a file dialog
filter
Type: SystemString
a filter string that determines what types of files are displayed from the dialog
defaultExtension
Type: SystemString
a value that specifies the default extension string to use to filter the list of files that are displayed
title
Type: SystemString
Title of the file dialog box.

Return Value

Type: String
the full path of the file saved
See Also

Reference

IFileDialogService Interface
SaveFileDialog Overload
VisualComponents.UX.Shared Namespace


IFileDialogService.SaveFileDialog Method (String, String, String, String, Int32, String)

IFileDialogServiceSaveFileDialog Method (String, String, String, String, Int32, String)

Save file dialog

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string SaveFileDialog(
    string initialDirectory,
    string defaultPath,
    string filter,
    string defaultExtension,
    out int selectedFilter,
    string title
)
String^ SaveFileDialog(
    String^ initialDirectory,
    String^ defaultPath,
    String^ filter,
    String^ defaultExtension,
    [OutAttribute] int% selectedFilter,
    String^ title
)

Parameters

initialDirectory
Type: SystemString
initial directory that is displayed by a file dialog
defaultPath
Type: SystemString
a string containing the full path of the file selected in a file dialog
filter
Type: SystemString
a filter string that determines what types of files are displayed from the dialog
defaultExtension
Type: SystemString
a value that specifies the default extension string to use to filter the list of files that are displayed
selectedFilter
Type: SystemInt32
the index of the filter currently selected in a file dialog
title
Type: SystemString
Title of the file dialog box.

Return Value

Type: String
the full path of the file saved
See Also

Reference

IFileDialogService Interface
SaveFileDialog Overload
VisualComponents.UX.Shared Namespace


IFileDialogService.SaveFileDialogDefault Method

IFileDialogServiceSaveFileDialogDefault Method

Save file dialog with default parameters

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string SaveFileDialogDefault()
String^ SaveFileDialogDefault()

Return Value

Type: String
path and file name
Remarks
It calls SaveFileDialog with default parameters
See Also

Reference

IFileDialogService Interface
VisualComponents.UX.Shared Namespace


IFilterTransportLinksCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IFilterTransportLinksCommand : ICheckBoxToolCommand,
    IActionItem, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IFilterTransportLinksCommand : ICheckBoxToolCommand,
    IActionItem, INotifyPropertyChangedEx, INotifyPropertyChanged

The IFilterTransportLinksCommand type exposes the following members.

Properties
 | Name | Description
Public property | CanExecute | (Inherited from IActionItem.)
Public property | Content | Item text/header. (Inherited from IActionItem.)
Public property | ContextFilter | Defines application contexts where action is available. (Inherited from IActionItem.)
Public property | ControlType | (Inherited from IActionItem.)
Public property | IconName | Gets the icon name. (Inherited from IActionItem.)
Public property | Id | (Inherited from IActionItem.)
Public property | IsChecked | Gets or sets if the check box is checked. (Inherited from ICheckBoxToolCommand.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | RibbonId | Required for ribbon only, as all items in ribbon groups are required to have a unique id. (Inherited from IActionItem.)
Public property | SiteOrder | (Inherited from IActionItem.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from IActionItem.)
Public property | Visibility | Item Visibility (Inherited from IActionItem.)
Top
Methods
 | Name | Description
Public method | EvaluateCanExecute | (Inherited from IActionItem.)
Public method | Execute | Note: When executed from UI buttons we also call BeforeExecute(). Note: This is executed from both r-click and normal UI buttons. If need to distinguish between executing 'with command panel' and 'immediate execution' inherit from ActionItemT1 and define both Execute() and Execute(bool). Note: Some actions also use IsChecked to execute. They call BeforeExecute() manually. (Inherited from IActionItem.)
Public method | Execute(PropertyCollection) | (Inherited from IActionItem.)
Public method | Execute(SetupPythonActionMessage) | Obsolete. (Inherited from IActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from IActionItem.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from IActionItem.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IFilterTransportLinksCommand Properties

The IFilterTransportLinksCommand type exposes the following members.

Properties
 | Name | Description
Public property | CanExecute | (Inherited from IActionItem.)
Public property | Content | Item text/header. (Inherited from IActionItem.)
Public property | ContextFilter | Defines application contexts where action is available. (Inherited from IActionItem.)
Public property | ControlType | (Inherited from IActionItem.)
Public property | IconName | Gets the icon name. (Inherited from IActionItem.)
Public property | Id | (Inherited from IActionItem.)
Public property | IsChecked | Gets or sets if the check box is checked. (Inherited from ICheckBoxToolCommand.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | RibbonId | Required for ribbon only, as all items in ribbon groups are required to have a unique id. (Inherited from IActionItem.)
Public property | SiteOrder | (Inherited from IActionItem.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from IActionItem.)
Public property | Visibility | Item Visibility (Inherited from IActionItem.)
Top
See Also

Reference

IFilterTransportLinksCommand Interface
VisualComponents.UX.Shared Namespace


IFilterTransportLinksCommand Methods

The IFilterTransportLinksCommand type exposes the following members.

Methods
 | Name | Description
Public method | EvaluateCanExecute | (Inherited from IActionItem.)
Public method | Execute | Note: When executed from UI buttons we also call BeforeExecute(). Note: This is executed from both r-click and normal UI buttons. If need to distinguish between executing 'with command panel' and 'immediate execution' inherit from ActionItemT1 and define both Execute() and Execute(bool). Note: Some actions also use IsChecked to execute. They call BeforeExecute() manually. (Inherited from IActionItem.)
Public method | Execute(PropertyCollection) | (Inherited from IActionItem.)
Public method | Execute(SetupPythonActionMessage) | Obsolete. (Inherited from IActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from IActionItem.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from IActionItem.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Top
See Also

Reference

IFilterTransportLinksCommand Interface
VisualComponents.UX.Shared Namespace


IFilterTransportLinksCommand Events

The IFilterTransportLinksCommand type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IFilterTransportLinksCommand Interface
VisualComponents.UX.Shared Namespace


IFloatingActivatorConfigureViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IFloatingActivatorConfigureViewModel
public interface class IFloatingActivatorConfigureViewModel

The IFloatingActivatorConfigureViewModel type exposes the following members.

Properties
 | Name | Description
Public property | IsConnected |
Public property | PortNumber |
Public property | ServerAddress |
Top
Methods
 | Name | Description
Public method | ChangeLicenseConnectionStatus |
Top
Events
 | Name | Description
Public event | ConnectionStateChanged |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IFloatingActivatorConfigureViewModel Properties

The IFloatingActivatorConfigureViewModel type exposes the following members.

Properties
 | Name | Description
Public property | IsConnected |
Public property | PortNumber |
Public property | ServerAddress |
Top
See Also

Reference

IFloatingActivatorConfigureViewModel Interface
VisualComponents.UX.Shared Namespace


IFloatingActivatorConfigureViewModel.IsConnected Property

IFloatingActivatorConfigureViewModelIsConnected Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsConnected { get; set; }
property bool IsConnected {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IFloatingActivatorConfigureViewModel Interface
VisualComponents.UX.Shared Namespace


IFloatingActivatorConfigureViewModel.PortNumber Property

IFloatingActivatorConfigureViewModelPortNumber Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int PortNumber { get; set; }
property int PortNumber {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IFloatingActivatorConfigureViewModel Interface
VisualComponents.UX.Shared Namespace


IFloatingActivatorConfigureViewModel.ServerAddress Property

IFloatingActivatorConfigureViewModelServerAddress Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ServerAddress { get; set; }
property String^ ServerAddress {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IFloatingActivatorConfigureViewModel Interface
VisualComponents.UX.Shared Namespace


IFloatingActivatorConfigureViewModel Methods

The IFloatingActivatorConfigureViewModel type exposes the following members.

Methods
 | Name | Description
Public method | ChangeLicenseConnectionStatus |
Top
See Also

Reference

IFloatingActivatorConfigureViewModel Interface
VisualComponents.UX.Shared Namespace


IFloatingActivatorConfigureViewModel.ChangeLicenseConnectionStatus Method

IFloatingActivatorConfigureViewModelChangeLicenseConnectionStatus Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ChangeLicenseConnectionStatus(
    bool connect
)
void ChangeLicenseConnectionStatus(
    bool connect
)

Parameters

connect
Type: SystemBoolean
See Also

Reference

IFloatingActivatorConfigureViewModel Interface
VisualComponents.UX.Shared Namespace


IFloatingActivatorConfigureViewModel Events

The IFloatingActivatorConfigureViewModel type exposes the following members.

Events
 | Name | Description
Public event | ConnectionStateChanged |
Top
See Also

Reference

IFloatingActivatorConfigureViewModel Interface
VisualComponents.UX.Shared Namespace


IFloatingActivatorConfigureViewModel.ConnectionStateChanged Event

IFloatingActivatorConfigureViewModelConnectionStateChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event LicenseServerConnectionStatusChangeHandler ConnectionStateChanged
 event LicenseServerConnectionStatusChangeHandler^ ConnectionStateChanged {
    void add (LicenseServerConnectionStatusChangeHandler^ value);
    void remove (LicenseServerConnectionStatusChangeHandler^ value);
}

Value

Type: VisualComponents.UX.SharedLicenseServerConnectionStatusChangeHandler
See Also

Reference

IFloatingActivatorConfigureViewModel Interface
VisualComponents.UX.Shared Namespace


IFloatingLicenseServerConfiguration Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IFloatingLicenseServerConfiguration
public interface class IFloatingLicenseServerConfiguration

The IFloatingLicenseServerConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | ServerAddress |
Public property | ServerPort |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IFloatingLicenseServerConfiguration Properties

The IFloatingLicenseServerConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | ServerAddress |
Public property | ServerPort |
Top
See Also

Reference

IFloatingLicenseServerConfiguration Interface
VisualComponents.UX.Shared Namespace


IFloatingLicenseServerConfiguration.ServerAddress Property

IFloatingLicenseServerConfigurationServerAddress Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ServerAddress { get; set; }
property String^ ServerAddress {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IFloatingLicenseServerConfiguration Interface
VisualComponents.UX.Shared Namespace


IFloatingLicenseServerConfiguration.ServerPort Property

IFloatingLicenseServerConfigurationServerPort Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ServerPort { get; set; }
property String^ ServerPort {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IFloatingLicenseServerConfiguration Interface
VisualComponents.UX.Shared Namespace


IFlowEditorCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IFlowEditorCommand : IActionItem,
    INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IFlowEditorCommand : IActionItem,
    INotifyPropertyChangedEx, INotifyPropertyChanged

The IFlowEditorCommand type exposes the following members.

Properties
 | Name | Description
Public property | CanExecute | (Inherited from IActionItem.)
Public property | Content | Item text/header. (Inherited from IActionItem.)
Public property | ContextFilter | Defines application contexts where action is available. (Inherited from IActionItem.)
Public property | ControlType | (Inherited from IActionItem.)
Public property | IconName | Gets the icon name. (Inherited from IActionItem.)
Public property | Id | (Inherited from IActionItem.)
Public property | IsChecked |
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | RibbonId | Required for ribbon only, as all items in ribbon groups are required to have a unique id. (Inherited from IActionItem.)
Public property | SiteOrder | (Inherited from IActionItem.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from IActionItem.)
Public property | Visibility | Item Visibility (Inherited from IActionItem.)
Top
Methods
 | Name | Description
Public method | EvaluateCanExecute | (Inherited from IActionItem.)
Public method | Execute | Note: When executed from UI buttons we also call BeforeExecute(). Note: This is executed from both r-click and normal UI buttons. If need to distinguish between executing 'with command panel' and 'immediate execution' inherit from ActionItemT1 and define both Execute() and Execute(bool). Note: Some actions also use IsChecked to execute. They call BeforeExecute() manually. (Inherited from IActionItem.)
Public method | Execute(PropertyCollection) | (Inherited from IActionItem.)
Public method | Execute(SetupPythonActionMessage) | Obsolete. (Inherited from IActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from IActionItem.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from IActionItem.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IFlowEditorCommand Properties

The IFlowEditorCommand type exposes the following members.

Properties
 | Name | Description
Public property | CanExecute | (Inherited from IActionItem.)
Public property | Content | Item text/header. (Inherited from IActionItem.)
Public property | ContextFilter | Defines application contexts where action is available. (Inherited from IActionItem.)
Public property | ControlType | (Inherited from IActionItem.)
Public property | IconName | Gets the icon name. (Inherited from IActionItem.)
Public property | Id | (Inherited from IActionItem.)
Public property | IsChecked |
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | RibbonId | Required for ribbon only, as all items in ribbon groups are required to have a unique id. (Inherited from IActionItem.)
Public property | SiteOrder | (Inherited from IActionItem.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from IActionItem.)
Public property | Visibility | Item Visibility (Inherited from IActionItem.)
Top
See Also

Reference

IFlowEditorCommand Interface
VisualComponents.UX.Shared Namespace


IFlowEditorCommand.IsChecked Property

IFlowEditorCommandIsChecked Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsChecked { get; set; }
property bool IsChecked {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IFlowEditorCommand Interface
VisualComponents.UX.Shared Namespace


IFlowEditorCommand Methods

The IFlowEditorCommand type exposes the following members.

Methods
 | Name | Description
Public method | EvaluateCanExecute | (Inherited from IActionItem.)
Public method | Execute | Note: When executed from UI buttons we also call BeforeExecute(). Note: This is executed from both r-click and normal UI buttons. If need to distinguish between executing 'with command panel' and 'immediate execution' inherit from ActionItemT1 and define both Execute() and Execute(bool). Note: Some actions also use IsChecked to execute. They call BeforeExecute() manually. (Inherited from IActionItem.)
Public method | Execute(PropertyCollection) | (Inherited from IActionItem.)
Public method | Execute(SetupPythonActionMessage) | Obsolete. (Inherited from IActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from IActionItem.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from IActionItem.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Top
See Also

Reference

IFlowEditorCommand Interface
VisualComponents.UX.Shared Namespace


IFlowEditorCommand Events

The IFlowEditorCommand type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IFlowEditorCommand Interface
VisualComponents.UX.Shared Namespace


IFlowEditorViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IFlowEditorViewModel : IDockableScreen,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IFlowEditorViewModel : IDockableScreen,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The IFlowEditorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | Command |
Public property | ContextFilter | Gets or sets the context filter. The context defines one or more contexts where the panel is visible. (Inherited from IDockableScreen.)
Public property | DesiredPanePosition | Gets the desired pane position. If multiple panes are added, panes are ordered using this property. (Inherited from IDockableScreen.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | Height | Gets the Height of the pane. (Inherited from IDockableScreen.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsEnabled |
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsPinned | Gets or sets a Boolean value that indicates if the pane is pinned. (Inherited from IDockableScreen.)
Public property | IsSelected | Gets or sets a boolean value that indicates if the pane is selected in TabGroupPane (Inherited from IDockableScreen.)
Public property | IsVisible | Gets or sets a boolean value that indicates if the pane is visible (Inherited from IDockableScreen.)
Public property | PanelId | Gets the panel ID (Inherited from IDockableScreen.)
Public property | PaneLocation | Gets the desired panel location DesiredPaneLocation (Inherited from IDockableScreen.)
Public property | PaneOrientation | Gets the pane orientation (Inherited from IDockableScreen.)
Public property | SplitPaneId | Gets the split pane id. By default all panes within panel location use same split panel. Multiple split panels can be created by defining new split pane ids. (Inherited from IDockableScreen.)
 | TabGroupId | Gets the pane tab group id. Panes are splitted and ordered to different tabs within the splitpane based on TabGroupId. (Inherited from IDockableScreen.)
Public property | Width | Gets the Width of the pane. (Inherited from IDockableScreen.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IFlowEditorViewModel Properties

The IFlowEditorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | Command |
Public property | ContextFilter | Gets or sets the context filter. The context defines one or more contexts where the panel is visible. (Inherited from IDockableScreen.)
Public property | DesiredPanePosition | Gets the desired pane position. If multiple panes are added, panes are ordered using this property. (Inherited from IDockableScreen.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | Height | Gets the Height of the pane. (Inherited from IDockableScreen.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsEnabled |
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsPinned | Gets or sets a Boolean value that indicates if the pane is pinned. (Inherited from IDockableScreen.)
Public property | IsSelected | Gets or sets a boolean value that indicates if the pane is selected in TabGroupPane (Inherited from IDockableScreen.)
Public property | IsVisible | Gets or sets a boolean value that indicates if the pane is visible (Inherited from IDockableScreen.)
Public property | PanelId | Gets the panel ID (Inherited from IDockableScreen.)
Public property | PaneLocation | Gets the desired panel location DesiredPaneLocation (Inherited from IDockableScreen.)
Public property | PaneOrientation | Gets the pane orientation (Inherited from IDockableScreen.)
Public property | SplitPaneId | Gets the split pane id. By default all panes within panel location use same split panel. Multiple split panels can be created by defining new split pane ids. (Inherited from IDockableScreen.)
 | TabGroupId | Gets the pane tab group id. Panes are splitted and ordered to different tabs within the splitpane based on TabGroupId. (Inherited from IDockableScreen.)
Public property | Width | Gets the Width of the pane. (Inherited from IDockableScreen.)
Top
See Also

Reference

IFlowEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IFlowEditorViewModel.Command Property

IFlowEditorViewModelCommand Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessMapVisibilityCommand Command { get; set; }
property IProcessMapVisibilityCommand^ Command {
    IProcessMapVisibilityCommand^ get ();
    void set (IProcessMapVisibilityCommand^ value);
}

Property Value

Type: IProcessMapVisibilityCommand
See Also

Reference

IFlowEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IFlowEditorViewModel.IsEnabled Property

IFlowEditorViewModelIsEnabled Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsEnabled { get; set; }
property bool IsEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IFlowEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IFlowEditorViewModel Methods

The IFlowEditorViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IFlowEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IFlowEditorViewModel Events

The IFlowEditorViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IFlowEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IFrameVisibilityType Interface

Frame visibility toggling command. See also IRobotFrameVisibilityType and IAllFrameFeaturesVisibilityCommand

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IFrameVisibilityType
public interface class IFrameVisibilityType

The IFrameVisibilityType type exposes the following members.

Properties
 | Name | Description
Public property | IsChecked |
Top
Methods
 | Name | Description
Public method | Execute |
Public method | RefreshSettings |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IFrameVisibilityType Properties

The IFrameVisibilityType type exposes the following members.

Properties
 | Name | Description
Public property | IsChecked |
Top
See Also

Reference

IFrameVisibilityType Interface
VisualComponents.UX.Shared Namespace


IFrameVisibilityType.IsChecked Property

IFrameVisibilityTypeIsChecked Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsChecked { get; set; }
property bool IsChecked {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IFrameVisibilityType Interface
VisualComponents.UX.Shared Namespace


IFrameVisibilityType Methods

The IFrameVisibilityType type exposes the following members.

Methods
 | Name | Description
Public method | Execute |
Public method | RefreshSettings |
Top
See Also

Reference

IFrameVisibilityType Interface
VisualComponents.UX.Shared Namespace


IFrameVisibilityType.Execute Method

IFrameVisibilityTypeExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Execute(
    bool isChecked
)
void Execute(
    bool isChecked
)

Parameters

isChecked
Type: SystemBoolean
See Also

Reference

IFrameVisibilityType Interface
VisualComponents.UX.Shared Namespace


IFrameVisibilityType.RefreshSettings Method

IFrameVisibilityTypeRefreshSettings Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RefreshSettings()
void RefreshSettings()
See Also

Reference

IFrameVisibilityType Interface
VisualComponents.UX.Shared Namespace


IFrameVisibilityTypeSettingsToolbarCommand Interface

Global frame visibility action.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IFrameVisibilityTypeSettingsToolbarCommand
public interface class IFrameVisibilityTypeSettingsToolbarCommand

The IFrameVisibilityTypeSettingsToolbarCommand type exposes the following members.

Properties
 | Name | Description
Public property | IsChecked |
Public property | IsUpdating |
Top
Methods
 | Name | Description
Public method | UpdateFrameVisibility |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IFrameVisibilityTypeSettingsToolbarCommand Properties

The IFrameVisibilityTypeSettingsToolbarCommand type exposes the following members.

Properties
 | Name | Description
Public property | IsChecked |
Public property | IsUpdating |
Top
See Also

Reference

IFrameVisibilityTypeSettingsToolbarCommand Interface
VisualComponents.UX.Shared Namespace


IFrameVisibilityTypeSettingsToolbarCommand.IsChecked Property

IFrameVisibilityTypeSettingsToolbarCommandIsChecked Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsChecked { get; set; }
property bool IsChecked {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IFrameVisibilityTypeSettingsToolbarCommand Interface
VisualComponents.UX.Shared Namespace


IFrameVisibilityTypeSettingsToolbarCommand.IsUpdating Property

IFrameVisibilityTypeSettingsToolbarCommandIsUpdating Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsUpdating { get; set; }
property bool IsUpdating {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IFrameVisibilityTypeSettingsToolbarCommand Interface
VisualComponents.UX.Shared Namespace


IFrameVisibilityTypeSettingsToolbarCommand Methods

The IFrameVisibilityTypeSettingsToolbarCommand type exposes the following members.

Methods
 | Name | Description
Public method | UpdateFrameVisibility |
Top
See Also

Reference

IFrameVisibilityTypeSettingsToolbarCommand Interface
VisualComponents.UX.Shared Namespace


IFrameVisibilityTypeSettingsToolbarCommand.UpdateFrameVisibility Method

IFrameVisibilityTypeSettingsToolbarCommandUpdateFrameVisibility Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateFrameVisibility()
void UpdateFrameVisibility()
See Also

Reference

IFrameVisibilityTypeSettingsToolbarCommand Interface
VisualComponents.UX.Shared Namespace


IFullScreenSimulationControlViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IFullScreenSimulationControlViewModel : ISimulationControlViewModel,
    ISimulationService, INotifyPropertyChangedEx, INotifyPropertyChanged, IScreen, IHaveDisplayName,
    IActivate, IDeactivate, IGuardClose, IClose
public interface class IFullScreenSimulationControlViewModel : ISimulationControlViewModel,
    ISimulationService, INotifyPropertyChangedEx, INotifyPropertyChanged, IScreen, IHaveDisplayName,
    IActivate, IDeactivate, IGuardClose, IClose

The IFullScreenSimulationControlViewModel type exposes the following members.

Properties
Name | Description
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property Elapsed
Note: this is similar to ISimulation.Elapsed, but expressed in TimeSpan not seconds.
(Inherited from ISimulationService.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsAnimationRecordingButtonVisible | (Inherited from ISimulationControlViewModel.)
Public property | IsLooping | (Inherited from ISimulationService.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsRecordingOn | (Inherited from ISimulationService.)
Public property | IsSimulationAtStart | (Inherited from ISimulationService.)
Public property | IsSimulationClockVisible | (Inherited from ISimulationControlViewModel.)
Public property | IsSimulationPaused | (Inherited from ISimulationService.)
Public property | IsSimulationRecordingOn | (Inherited from ISimulationService.)
Public property IsSimulationRunning
Note: this can return false when simulation is technically running, but halt-event was already scheduled.
(Inherited from ISimulationService.)
Public property | IsStreamingOn | (Inherited from ISimulationService.)
Public property | IsVideoRecordingButtonVisible | (Inherited from ISimulationControlViewModel.)
Public property | SimulationMode | (Inherited from ISimulationService.)
Public property | SpeedFactor | (Inherited from ISimulationService.)
Public property | SpeedFactorInputValue | (Inherited from ISimulationService.)
Public property UseExternalClock
Defines if simulation is controlled by external clock. If this property is
Copy
true
simulation must be executed manually using Simulate(Double).
(Inherited from ISimulationService.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | KeepMenuToolOpen | (Inherited from ISimulationControlViewModel.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | PauseSimulation | (Inherited from ISimulationService.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | RepeatSimulation | (Inherited from ISimulationService.)
Public method | ResetSimulation | (Inherited from ISimulationService.)
Public method | ResetSimulation(Boolean) | (Inherited from ISimulationService.)
Public method | ResetSpeedFactor | (Inherited from ISimulationService.)
Public method | RunSimulation | (Inherited from ISimulationService.)
Public method | SaveSimulationState | (Inherited from ISimulationService.)
Public method | SetSimulationMode | (Inherited from ISimulationService.)
Public method | SwitchRunState | (Inherited from ISimulationControlViewModel.)
Public method | SwitchRunState(Double) | (Inherited from ISimulationService.)
Public method | SwitchRunState(Double, Double) | (Inherited from ISimulationService.)
Public method | TryClose | (Inherited from IClose.)
Public method | UpdateSimulationRecordingState | (Inherited from ISimulationService.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Public event | SimulationRunStateChanged | (Inherited from ISimulationControlViewModel.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IFullScreenSimulationControlViewModel Properties

The IFullScreenSimulationControlViewModel type exposes the following members.

Properties
Name | Description
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property Elapsed
Note: this is similar to ISimulation.Elapsed, but expressed in TimeSpan not seconds.
(Inherited from ISimulationService.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsAnimationRecordingButtonVisible | (Inherited from ISimulationControlViewModel.)
Public property | IsLooping | (Inherited from ISimulationService.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsRecordingOn | (Inherited from ISimulationService.)
Public property | IsSimulationAtStart | (Inherited from ISimulationService.)
Public property | IsSimulationClockVisible | (Inherited from ISimulationControlViewModel.)
Public property | IsSimulationPaused | (Inherited from ISimulationService.)
Public property | IsSimulationRecordingOn | (Inherited from ISimulationService.)
Public property IsSimulationRunning
Note: this can return false when simulation is technically running, but halt-event was already scheduled.
(Inherited from ISimulationService.)
Public property | IsStreamingOn | (Inherited from ISimulationService.)
Public property | IsVideoRecordingButtonVisible | (Inherited from ISimulationControlViewModel.)
Public property | SimulationMode | (Inherited from ISimulationService.)
Public property | SpeedFactor | (Inherited from ISimulationService.)
Public property | SpeedFactorInputValue | (Inherited from ISimulationService.)
Public property UseExternalClock
Defines if simulation is controlled by external clock. If this property is
Copy
true
simulation must be executed manually using Simulate(Double).
(Inherited from ISimulationService.)
Top
See Also

Reference

IFullScreenSimulationControlViewModel Interface
VisualComponents.UX.Shared Namespace


IFullScreenSimulationControlViewModel Methods

The IFullScreenSimulationControlViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | KeepMenuToolOpen | (Inherited from ISimulationControlViewModel.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | PauseSimulation | (Inherited from ISimulationService.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | RepeatSimulation | (Inherited from ISimulationService.)
Public method | ResetSimulation | (Inherited from ISimulationService.)
Public method | ResetSimulation(Boolean) | (Inherited from ISimulationService.)
Public method | ResetSpeedFactor | (Inherited from ISimulationService.)
Public method | RunSimulation | (Inherited from ISimulationService.)
Public method | SaveSimulationState | (Inherited from ISimulationService.)
Public method | SetSimulationMode | (Inherited from ISimulationService.)
Public method | SwitchRunState | (Inherited from ISimulationControlViewModel.)
Public method | SwitchRunState(Double) | (Inherited from ISimulationService.)
Public method | SwitchRunState(Double, Double) | (Inherited from ISimulationService.)
Public method | TryClose | (Inherited from IClose.)
Public method | UpdateSimulationRecordingState | (Inherited from ISimulationService.)
Top
See Also

Reference

IFullScreenSimulationControlViewModel Interface
VisualComponents.UX.Shared Namespace


IFullScreenSimulationControlViewModel Events

The IFullScreenSimulationControlViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Public event | SimulationRunStateChanged | (Inherited from ISimulationControlViewModel.)
Top
See Also

Reference

IFullScreenSimulationControlViewModel Interface
VisualComponents.UX.Shared Namespace


IGalleryItem Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IGalleryItem
public interface class IGalleryItem

The IGalleryItem type exposes the following members.

Properties
 | Name | Description
Public property | Command | IActionItem represented by this GalleryItem.
Public property | IsEnabled | Returns/sets whether this GalleryItem is enabled item in the GalleryTool.
Public property | Key | Returns/sets the string key associated with this GalleryItem.
Public property | Tag | Returns/sets icon data that is stored with the GalleryItem.
Public property | Text | Returns/sets the text that is displayed for the GalleryItem when it is displayed in the GalleryTool dropdown.
Public property | ToolTipImage | Returns/sets the tooltip image path that is displayed for the GalleryItem .
Public property | ToolTipText | Returns/sets the tooltip text that is displayed for the GalleryItem.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IGalleryItem Properties

The IGalleryItem type exposes the following members.

Properties
 | Name | Description
Public property | Command | IActionItem represented by this GalleryItem.
Public property | IsEnabled | Returns/sets whether this GalleryItem is enabled item in the GalleryTool.
Public property | Key | Returns/sets the string key associated with this GalleryItem.
Public property | Tag | Returns/sets icon data that is stored with the GalleryItem.
Public property | Text | Returns/sets the text that is displayed for the GalleryItem when it is displayed in the GalleryTool dropdown.
Public property | ToolTipImage | Returns/sets the tooltip image path that is displayed for the GalleryItem .
Public property | ToolTipText | Returns/sets the tooltip text that is displayed for the GalleryItem.
Top
See Also

Reference

IGalleryItem Interface
VisualComponents.UX.Shared Namespace


IGalleryItem.Command Property

IGalleryItemCommand Property

IActionItem represented by this GalleryItem.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IActionItem Command { get; set; }
property IActionItem^ Command {
    IActionItem^ get ();
    void set (IActionItem^ value);
}

Property Value

Type: IActionItem
See Also

Reference

IGalleryItem Interface
VisualComponents.UX.Shared Namespace


IGalleryItem.IsEnabled Property

IGalleryItemIsEnabled Property

Returns/sets whether this GalleryItem is enabled item in the GalleryTool.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsEnabled { get; set; }
property bool IsEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IGalleryItem Interface
VisualComponents.UX.Shared Namespace


IGalleryItem.Key Property

IGalleryItemKey Property

Returns/sets the string key associated with this GalleryItem.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Key { get; set; }
property String^ Key {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IGalleryItem Interface
VisualComponents.UX.Shared Namespace


IGalleryItem.Tag Property

IGalleryItemTag Property

Returns/sets icon data that is stored with the GalleryItem.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Tag { get; set; }
property String^ Tag {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IGalleryItem Interface
VisualComponents.UX.Shared Namespace


IGalleryItem.Text Property

IGalleryItemText Property

Returns/sets the text that is displayed for the GalleryItem when it is displayed in the GalleryTool dropdown.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Text { get; set; }
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IGalleryItem Interface
VisualComponents.UX.Shared Namespace


IGalleryItem.ToolTipImage Property

IGalleryItemToolTipImage Property

Returns/sets the tooltip image path that is displayed for the GalleryItem .

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ToolTipImage { get; set; }
property String^ ToolTipImage {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IGalleryItem Interface
VisualComponents.UX.Shared Namespace


IGalleryItem.ToolTipText Property

IGalleryItemToolTipText Property

Returns/sets the tooltip text that is displayed for the GalleryItem.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ToolTipText { get; set; }
property String^ ToolTipText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IGalleryItem Interface
VisualComponents.UX.Shared Namespace


IGalleryMenuToolCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IGalleryMenuToolCommand : IRibbonToolCommand
public interface class IGalleryMenuToolCommand : IRibbonToolCommand

The IGalleryMenuToolCommand type exposes the following members.

Properties
 | Name | Description
Public property | GalleryItems | Represents a list of items in a GalleryTool that displays an image and/or text
Public property | GroupItems | Represents an a group list of GalleryItem that is shown in dropdown.
Public property | MaxDropDownColumns | Returns/sets the maximum number of columns that can be displayed in the gallery drop down.
Public property | MaxPreviewColumns | Returns/sets the maximum number of columns that can be displayed in the gallery preview.
Public property | MinDropDownColumns | Returns/sets the minimum number of columns that can be displayed in the gallery drop down.
Public property | MinPreviewColumns | Returns/sets the minimum number of columns that can be displayed in the gallery preview.
Public property | PreferredDropDownColumns | Returns/sets the preferred number of columns that should be displayed in the gallery dropdown.
Public property | ShouldDisplayGalleryPreview | Gets/sets whether a gallery tool will display its items in the gallery preview area of the menu when it is displayed on a RibbonGroup.
Public property | ToolSize | Determines the sizing mode of a Menu tool which affects the size of a tool and whether it displays image, text or both. (Inherited from IRibbonToolCommand.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IGalleryMenuToolCommand Properties

The IGalleryMenuToolCommand type exposes the following members.

Properties
 | Name | Description
Public property | GalleryItems | Represents a list of items in a GalleryTool that displays an image and/or text
Public property | GroupItems | Represents an a group list of GalleryItem that is shown in dropdown.
Public property | MaxDropDownColumns | Returns/sets the maximum number of columns that can be displayed in the gallery drop down.
Public property | MaxPreviewColumns | Returns/sets the maximum number of columns that can be displayed in the gallery preview.
Public property | MinDropDownColumns | Returns/sets the minimum number of columns that can be displayed in the gallery drop down.
Public property | MinPreviewColumns | Returns/sets the minimum number of columns that can be displayed in the gallery preview.
Public property | PreferredDropDownColumns | Returns/sets the preferred number of columns that should be displayed in the gallery dropdown.
Public property | ShouldDisplayGalleryPreview | Gets/sets whether a gallery tool will display its items in the gallery preview area of the menu when it is displayed on a RibbonGroup.
Public property | ToolSize | Determines the sizing mode of a Menu tool which affects the size of a tool and whether it displays image, text or both. (Inherited from IRibbonToolCommand.)
Top
See Also

Reference

IGalleryMenuToolCommand Interface
VisualComponents.UX.Shared Namespace


IGalleryMenuToolCommand.GalleryItems Property

IGalleryMenuToolCommandGalleryItems Property

Represents a list of items in a GalleryTool that displays an image and/or text

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ObservableCollection<GalleryItemEx> GalleryItems { get; set; }
property ObservableCollection<GalleryItemEx^>^ GalleryItems {
    ObservableCollection<GalleryItemEx^>^ get ();
    void set (ObservableCollection<GalleryItemEx^>^ value);
}

Property Value

Type: ObservableCollectionGalleryItemEx
See Also

Reference

IGalleryMenuToolCommand Interface
VisualComponents.UX.Shared Namespace


IGalleryMenuToolCommand.GroupItems Property

IGalleryMenuToolCommandGroupItems Property

Represents an a group list of GalleryItem that is shown in dropdown.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ObservableCollection<GalleryGroup> GroupItems { get; set; }
property ObservableCollection<GalleryGroup^>^ GroupItems {
    ObservableCollection<GalleryGroup^>^ get ();
    void set (ObservableCollection<GalleryGroup^>^ value);
}

Property Value

Type: ObservableCollectionGalleryGroup
See Also

Reference

IGalleryMenuToolCommand Interface
VisualComponents.UX.Shared Namespace


IGalleryMenuToolCommand.MaxDropDownColumns Property

IGalleryMenuToolCommandMaxDropDownColumns Property

Returns/sets the maximum number of columns that can be displayed in the gallery drop down.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int MaxDropDownColumns { get; set; }
property int MaxDropDownColumns {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IGalleryMenuToolCommand Interface
VisualComponents.UX.Shared Namespace


IGalleryMenuToolCommand.MaxPreviewColumns Property

IGalleryMenuToolCommandMaxPreviewColumns Property

Returns/sets the maximum number of columns that can be displayed in the gallery preview.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int MaxPreviewColumns { get; set; }
property int MaxPreviewColumns {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IGalleryMenuToolCommand Interface
VisualComponents.UX.Shared Namespace


IGalleryMenuToolCommand.MinDropDownColumns Property

IGalleryMenuToolCommandMinDropDownColumns Property

Returns/sets the minimum number of columns that can be displayed in the gallery drop down.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int MinDropDownColumns { get; set; }
property int MinDropDownColumns {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IGalleryMenuToolCommand Interface
VisualComponents.UX.Shared Namespace


IGalleryMenuToolCommand.MinPreviewColumns Property

IGalleryMenuToolCommandMinPreviewColumns Property

Returns/sets the minimum number of columns that can be displayed in the gallery preview.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int MinPreviewColumns { get; set; }
property int MinPreviewColumns {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IGalleryMenuToolCommand Interface
VisualComponents.UX.Shared Namespace


IGalleryMenuToolCommand.PreferredDropDownColumns Property

IGalleryMenuToolCommandPreferredDropDownColumns Property

Returns/sets the preferred number of columns that should be displayed in the gallery dropdown.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int PreferredDropDownColumns { get; set; }
property int PreferredDropDownColumns {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IGalleryMenuToolCommand Interface
VisualComponents.UX.Shared Namespace


IGalleryMenuToolCommand.ShouldDisplayGalleryPreview Property

IGalleryMenuToolCommandShouldDisplayGalleryPreview Property

Gets/sets whether a gallery tool will display its items in the gallery preview area of the menu when it is displayed on a RibbonGroup.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ShouldDisplayGalleryPreview { get; set; }
property bool ShouldDisplayGalleryPreview {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IGalleryMenuToolCommand Interface
VisualComponents.UX.Shared Namespace


IGenericCommandViewModel Interface

Generic command view model interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IGenericCommandViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IGenericCommandViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The IGenericCommandViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IGenericCommandViewModel Properties

The IGenericCommandViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
See Also

Reference

IGenericCommandViewModel Interface
VisualComponents.UX.Shared Namespace


IGenericCommandViewModel Methods

The IGenericCommandViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IGenericCommandViewModel Interface
VisualComponents.UX.Shared Namespace


IGenericCommandViewModel Events

The IGenericCommandViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IGenericCommandViewModel Interface
VisualComponents.UX.Shared Namespace


IGenericSnapActionViewModel Interface

Any action that is using SnapAction as it's sub-action and wants to display the default UI for it.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IGenericSnapActionViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IGenericSnapActionViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The IGenericSnapActionViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | NotifyOptionsChanged |
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IGenericSnapActionViewModel Properties

The IGenericSnapActionViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
See Also

Reference

IGenericSnapActionViewModel Interface
VisualComponents.UX.Shared Namespace


IGenericSnapActionViewModel Methods

The IGenericSnapActionViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | NotifyOptionsChanged |
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IGenericSnapActionViewModel Interface
VisualComponents.UX.Shared Namespace


IGenericSnapActionViewModel.NotifyOptionsChanged Method

IGenericSnapActionViewModelNotifyOptionsChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void NotifyOptionsChanged()
void NotifyOptionsChanged()
See Also

Reference

IGenericSnapActionViewModel Interface
VisualComponents.UX.Shared Namespace


IGenericSnapActionViewModel Events

The IGenericSnapActionViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IGenericSnapActionViewModel Interface
VisualComponents.UX.Shared Namespace


IGeoFeatureBaseOperationLevelAction Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IGeoFeatureBaseOperationLevelAction
public interface class IGeoFeatureBaseOperationLevelAction

The IGeoFeatureBaseOperationLevelAction type exposes the following members.

Properties
 | Name | Description
Public property | IsActive |
Public property | Level |
Top
Methods
 | Name | Description
Public method | FindFaces |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IGeoFeatureBaseOperationLevelAction Properties

The IGeoFeatureBaseOperationLevelAction type exposes the following members.

Properties
 | Name | Description
Public property | IsActive |
Public property | Level |
Top
See Also

Reference

IGeoFeatureBaseOperationLevelAction Interface
VisualComponents.UX.Shared Namespace


IGeoFeatureBaseOperationLevelAction.IsActive Property

IGeoFeatureBaseOperationLevelActionIsActive Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsActive { get; }
property bool IsActive {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IGeoFeatureBaseOperationLevelAction Interface
VisualComponents.UX.Shared Namespace


IGeoFeatureBaseOperationLevelAction.Level Property

IGeoFeatureBaseOperationLevelActionLevel Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
FeatureOperationLevel Level { get; set; }
property FeatureOperationLevel Level {
    FeatureOperationLevel get ();
    void set (FeatureOperationLevel value);
}

Property Value

Type: FeatureOperationLevel
See Also

Reference

IGeoFeatureBaseOperationLevelAction Interface
VisualComponents.UX.Shared Namespace


IGeoFeatureBaseOperationLevelAction Methods

The IGeoFeatureBaseOperationLevelAction type exposes the following members.

Methods
 | Name | Description
Public method | FindFaces |
Top
See Also

Reference

IGeoFeatureBaseOperationLevelAction Interface
VisualComponents.UX.Shared Namespace


IGeoFeatureBaseOperationLevelAction.FindFaces Method

IGeoFeatureBaseOperationLevelActionFindFaces Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Tuple<ISimComponent, IEnumerable<IFace>> FindFaces(
    int x,
    int y
)
Tuple<ISimComponent^, IEnumerable<IFace^>^>^ FindFaces(
    int x,
    int y
)

Parameters

x
Type: SystemInt32
y
Type: SystemInt32

Return Value

Type: TupleISimComponent, IEnumerableIFace

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IGeoFeatureBaseOperationLevelAction.FindFaces(System.Int32,System.Int32)"]

See Also

Reference

IGeoFeatureBaseOperationLevelAction Interface
VisualComponents.UX.Shared Namespace


IGeoFeatureInvertViewModel Interface

Geo feature invert geometry view model interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IGeoFeatureInvertViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IGeoFeatureInvertViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The IGeoFeatureInvertViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IGeoFeatureInvertViewModel Properties

The IGeoFeatureInvertViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
See Also

Reference

IGeoFeatureInvertViewModel Interface
VisualComponents.UX.Shared Namespace


IGeoFeatureInvertViewModel Methods

The IGeoFeatureInvertViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IGeoFeatureInvertViewModel Interface
VisualComponents.UX.Shared Namespace


IGeoFeatureInvertViewModel Events

The IGeoFeatureInvertViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IGeoFeatureInvertViewModel Interface
VisualComponents.UX.Shared Namespace


IGeoFeatureSplitViewModel Interface

Geo feature split view model interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IGeoFeatureSplitViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IGeoFeatureSplitViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The IGeoFeatureSplitViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IGeoFeatureSplitViewModel Properties

The IGeoFeatureSplitViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
See Also

Reference

IGeoFeatureSplitViewModel Interface
VisualComponents.UX.Shared Namespace


IGeoFeatureSplitViewModel Methods

The IGeoFeatureSplitViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IGeoFeatureSplitViewModel Interface
VisualComponents.UX.Shared Namespace


IGeoFeatureSplitViewModel Events

The IGeoFeatureSplitViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IGeoFeatureSplitViewModel Interface
VisualComponents.UX.Shared Namespace


IGridSnapSizeCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IGridSnapSizeCommand
public interface class IGridSnapSizeCommand

The IGridSnapSizeCommand type exposes the following members.

Properties
 | Name | Description
Public property | CanExecute |
Public property | Value |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IGridSnapSizeCommand Properties

The IGridSnapSizeCommand type exposes the following members.

Properties
 | Name | Description
Public property | CanExecute |
Public property | Value |
Top
See Also

Reference

IGridSnapSizeCommand Interface
VisualComponents.UX.Shared Namespace


IGridSnapSizeCommand.CanExecute Property

IGridSnapSizeCommandCanExecute Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanExecute { get; set; }
property bool CanExecute {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IGridSnapSizeCommand Interface
VisualComponents.UX.Shared Namespace


IGridSnapSizeCommand.Value Property

IGridSnapSizeCommandValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Value { get; set; }
property double Value {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IGridSnapSizeCommand Interface
VisualComponents.UX.Shared Namespace


IGridSnapZoomBasedCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IGridSnapZoomBasedCommand : ICheckBoxToolCommand
public interface class IGridSnapZoomBasedCommand : ICheckBoxToolCommand

The IGridSnapZoomBasedCommand type exposes the following members.

Properties
 | Name | Description
Public property | IsChecked | Gets or sets if the check box is checked. (Inherited from ICheckBoxToolCommand.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IGridSnapZoomBasedCommand Properties

The IGridSnapZoomBasedCommand type exposes the following members.

Properties
 | Name | Description
Public property | IsChecked | Gets or sets if the check box is checked. (Inherited from ICheckBoxToolCommand.)
Top
See Also

Reference

IGridSnapZoomBasedCommand Interface
VisualComponents.UX.Shared Namespace


IHeaderModel Interface

Note: This API is now obsolete.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("This interface is obsolete. Please use IHeaderModel interface from VisualComponents.Create3D namespace!")]
public interface IHeaderModel : IHeaderModel
[ObsoleteAttribute(L"This interface is obsolete. Please use IHeaderModel interface from VisualComponents.Create3D namespace!")]
public interface class IHeaderModel : IHeaderModel

The IHeaderModel type exposes the following members.

Properties
 | Name | Description
Public property | HeaderIconPath | Icon in header (Inherited from IHeaderModel.)
Public property | HeaderId | Header's id (Inherited from IHeaderModel.)
Public property | HeaderName | Name in header (Inherited from IHeaderModel.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IHeaderModel Properties

The IHeaderModel type exposes the following members.

Properties
 | Name | Description
Public property | HeaderIconPath | Icon in header (Inherited from IHeaderModel.)
Public property | HeaderId | Header's id (Inherited from IHeaderModel.)
Public property | HeaderName | Name in header (Inherited from IHeaderModel.)
Top
See Also

Reference

IHeaderModel Interface
VisualComponents.UX.Shared Namespace


IHelpActionItem Interface

ActionItem with additional information.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IHelpActionItem
public interface class IHelpActionItem

The IHelpActionItem type exposes the following members.

Properties
 | Name | Description
Public property | SourceUrl |
Top
Methods
 | Name | Description
Public method | SetEntityName | Implement this to receive the name of the company, product, etc, if defined for the item.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IHelpActionItem Properties

The IHelpActionItem type exposes the following members.

Properties
 | Name | Description
Public property | SourceUrl |
Top
See Also

Reference

IHelpActionItem Interface
VisualComponents.UX.Shared Namespace


IHelpActionItem.SourceUrl Property

IHelpActionItemSourceUrl Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string SourceUrl { get; set; }
property String^ SourceUrl {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IHelpActionItem Interface
VisualComponents.UX.Shared Namespace


IHelpActionItem Methods

The IHelpActionItem type exposes the following members.

Methods
 | Name | Description
Public method | SetEntityName | Implement this to receive the name of the company, product, etc, if defined for the item.
Top
See Also

Reference

IHelpActionItem Interface
VisualComponents.UX.Shared Namespace


IHelpActionItem.SetEntityName Method

IHelpActionItemSetEntityName Method

Implement this to receive the name of the company, product, etc, if defined for the item.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetEntityName(
    string entityName
)
void SetEntityName(
    String^ entityName
)

Parameters

entityName
Type: SystemString
See Also

Reference

IHelpActionItem Interface
VisualComponents.UX.Shared Namespace


IImportDrawingTemplateAction Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IImportDrawingTemplateAction : ICommandPanelAction
public interface class IImportDrawingTemplateAction : ICommandPanelAction

The IImportDrawingTemplateAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Top
Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IImportDrawingTemplateAction Properties

The IImportDrawingTemplateAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

IImportDrawingTemplateAction Interface
VisualComponents.UX.Shared Namespace


IImportDrawingTemplateAction Methods

The IImportDrawingTemplateAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

IImportDrawingTemplateAction Interface
VisualComponents.UX.Shared Namespace


IImportDrawingTemplateViewModel Interface

Import drawing template view model interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IImportDrawingTemplateViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IImportDrawingTemplateViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The IImportDrawingTemplateViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IImportDrawingTemplateViewModel Properties

The IImportDrawingTemplateViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
See Also

Reference

IImportDrawingTemplateViewModel Interface
VisualComponents.UX.Shared Namespace


IImportDrawingTemplateViewModel Methods

The IImportDrawingTemplateViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IImportDrawingTemplateViewModel Interface
VisualComponents.UX.Shared Namespace


IImportDrawingTemplateViewModel Events

The IImportDrawingTemplateViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IImportDrawingTemplateViewModel Interface
VisualComponents.UX.Shared Namespace


IInputSection Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IInputSection : ISection
public interface class IInputSection : ISection

The IInputSection type exposes the following members.

Properties
 | Name | Description
Public property | InputConfiguration |
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | GetSection | Gets the section (Inherited from ISection.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IInputSection Properties

The IInputSection type exposes the following members.

Properties
 | Name | Description
Public property | InputConfiguration |
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
See Also

Reference

IInputSection Interface
VisualComponents.UX.Shared Namespace


IInputSection.InputConfiguration Property

IInputSectionInputConfiguration Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
InputConfigurationConfigCollection InputConfiguration { get; }
property InputConfigurationConfigCollection^ InputConfiguration {
    InputConfigurationConfigCollection^ get ();
}

Property Value

Type: InputConfigurationConfigCollection
See Also

Reference

IInputSection Interface
VisualComponents.UX.Shared Namespace


IInputSection Methods

The IInputSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | GetSection | Gets the section (Inherited from ISection.)
Top
See Also

Reference

IInputSection Interface
VisualComponents.UX.Shared Namespace


IInterfaceEditorNotifier Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IInterfaceEditorNotifier
public interface class IInterfaceEditorNotifier

The IInterfaceEditorNotifier type exposes the following members.

Methods
 | Name | Description
Public method | SectionDeleted |
Public method | SectionFrameAdded |
Public method | SectionMoved |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IInterfaceEditorNotifier Methods

The IInterfaceEditorNotifier type exposes the following members.

Methods
 | Name | Description
Public method | SectionDeleted |
Public method | SectionFrameAdded |
Public method | SectionMoved |
Top
See Also

Reference

IInterfaceEditorNotifier Interface
VisualComponents.UX.Shared Namespace


IInterfaceEditorNotifier.SectionDeleted Method

IInterfaceEditorNotifierSectionDeleted Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SectionDeleted(
    InterfaceSectionItem sectionItem
)
void SectionDeleted(
    InterfaceSectionItem^ sectionItem
)

Parameters

sectionItem
Type: VisualComponents.UX.SharedInterfaceSectionItem
See Also

Reference

IInterfaceEditorNotifier Interface
VisualComponents.UX.Shared Namespace


IInterfaceEditorNotifier.SectionFrameAdded Method

IInterfaceEditorNotifierSectionFrameAdded Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SectionFrameAdded()
void SectionFrameAdded()
See Also

Reference

IInterfaceEditorNotifier Interface
VisualComponents.UX.Shared Namespace


IInterfaceEditorNotifier.SectionMoved Method

IInterfaceEditorNotifierSectionMoved Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SectionMoved()
void SectionMoved()
See Also

Reference

IInterfaceEditorNotifier Interface
VisualComponents.UX.Shared Namespace


IInterfacesVisibilityCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IInterfacesVisibilityCommand : ICheckBoxToolCommand
public interface class IInterfacesVisibilityCommand : ICheckBoxToolCommand

The IInterfacesVisibilityCommand type exposes the following members.

Properties
 | Name | Description
Public property | IsChecked | Gets or sets if the check box is checked. (Inherited from ICheckBoxToolCommand.)
Top
Methods
 | Name | Description
Public method | Update |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IInterfacesVisibilityCommand Properties

The IInterfacesVisibilityCommand type exposes the following members.

Properties
 | Name | Description
Public property | IsChecked | Gets or sets if the check box is checked. (Inherited from ICheckBoxToolCommand.)
Top
See Also

Reference

IInterfacesVisibilityCommand Interface
VisualComponents.UX.Shared Namespace


IInterfacesVisibilityCommand Methods

The IInterfacesVisibilityCommand type exposes the following members.

Methods
 | Name | Description
Public method | Update |
Top
See Also

Reference

IInterfacesVisibilityCommand Interface
VisualComponents.UX.Shared Namespace


IInterfacesVisibilityCommand.Update Method

IInterfacesVisibilityCommandUpdate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Update()
void Update()
See Also

Reference

IInterfacesVisibilityCommand Interface
VisualComponents.UX.Shared Namespace


IJogViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IJogViewModel
public interface class IJogViewModel

The IJogViewModel type exposes the following members.

Properties
 | Name | Description
Public property | JogManipulateViewModel |
Top
Methods
 | Name | Description
Public method | NotifyOptionsChanged |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IJogViewModel Properties

The IJogViewModel type exposes the following members.

Properties
 | Name | Description
Public property | JogManipulateViewModel |
Top
See Also

Reference

IJogViewModel Interface
VisualComponents.UX.Shared Namespace


IJogViewModel.JogManipulateViewModel Property

IJogViewModelJogManipulateViewModel Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IManipulateViewModel JogManipulateViewModel { get; }
property IManipulateViewModel^ JogManipulateViewModel {
    IManipulateViewModel^ get ();
}

Property Value

Type: IManipulateViewModel
See Also

Reference

IJogViewModel Interface
VisualComponents.UX.Shared Namespace


IJogViewModel Methods

The IJogViewModel type exposes the following members.

Methods
 | Name | Description
Public method | NotifyOptionsChanged |
Top
See Also

Reference

IJogViewModel Interface
VisualComponents.UX.Shared Namespace


IJogViewModel.NotifyOptionsChanged Method

IJogViewModelNotifyOptionsChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void NotifyOptionsChanged()
void NotifyOptionsChanged()
See Also

Reference

IJogViewModel Interface
VisualComponents.UX.Shared Namespace


ILayoutInfo Interface

LayoutInfo contains information about status of the current file.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ILayoutInfo : INotifyPropertyChangedEx,
    INotifyPropertyChanged
public interface class ILayoutInfo : INotifyPropertyChangedEx,
    INotifyPropertyChanged

The ILayoutInfo type exposes the following members.

Properties
 | Name | Description
Public property | CurrentFile |
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | LayoutUri |
Public property | NewFile |
Top
Methods
 | Name | Description
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ILayoutInfo Properties

The ILayoutInfo type exposes the following members.

Properties
 | Name | Description
Public property | CurrentFile |
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | LayoutUri |
Public property | NewFile |
Top
See Also

Reference

ILayoutInfo Interface
VisualComponents.UX.Shared Namespace


ILayoutInfo.CurrentFile Property

ILayoutInfoCurrentFile Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string CurrentFile { get; }
property String^ CurrentFile {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ILayoutInfo Interface
VisualComponents.UX.Shared Namespace


ILayoutInfo.LayoutUri Property

ILayoutInfoLayoutUri Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Uri LayoutUri { get; set; }
property Uri^ LayoutUri {
    Uri^ get ();
    void set (Uri^ value);
}

Property Value

Type: Uri
See Also

Reference

ILayoutInfo Interface
VisualComponents.UX.Shared Namespace


ILayoutInfo.NewFile Property

ILayoutInfoNewFile Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool NewFile { get; set; }
property bool NewFile {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ILayoutInfo Interface
VisualComponents.UX.Shared Namespace


ILayoutInfo Methods

The ILayoutInfo type exposes the following members.

Methods
 | Name | Description
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Top
See Also

Reference

ILayoutInfo Interface
VisualComponents.UX.Shared Namespace


ILayoutInfo Events

The ILayoutInfo type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

ILayoutInfo Interface
VisualComponents.UX.Shared Namespace


ILayoutMetaDataEditorViewModel Interface

Layout metadata members definition

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ILayoutMetaDataEditorViewModel
public interface class ILayoutMetaDataEditorViewModel

The ILayoutMetaDataEditorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | AutoIncrementRevision | Auto increment revision
Public property | Metadata | current component metadata info
Top
Methods
 | Name | Description
Public method | Refresh | refresh the view model
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ILayoutMetaDataEditorViewModel Properties

The ILayoutMetaDataEditorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | AutoIncrementRevision | Auto increment revision
Public property | Metadata | current component metadata info
Top
See Also

Reference

ILayoutMetaDataEditorViewModel Interface
VisualComponents.UX.Shared Namespace


ILayoutMetaDataEditorViewModel.AutoIncrementRevision Property

ILayoutMetaDataEditorViewModelAutoIncrementRevision Property

Auto increment revision

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool AutoIncrementRevision { get; }
property bool AutoIncrementRevision {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ILayoutMetaDataEditorViewModel Interface
VisualComponents.UX.Shared Namespace


ILayoutMetaDataEditorViewModel.Metadata Property

ILayoutMetaDataEditorViewModelMetadata Property

current component metadata info

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
LayoutMetaDataSettings Metadata { get; }
property LayoutMetaDataSettings^ Metadata {
    LayoutMetaDataSettings^ get ();
}

Property Value

Type: LayoutMetaDataSettings
See Also

Reference

ILayoutMetaDataEditorViewModel Interface
VisualComponents.UX.Shared Namespace


ILayoutMetaDataEditorViewModel Methods

The ILayoutMetaDataEditorViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Refresh | refresh the view model
Top
See Also

Reference

ILayoutMetaDataEditorViewModel Interface
VisualComponents.UX.Shared Namespace


ILayoutMetaDataEditorViewModel.Refresh Method

ILayoutMetaDataEditorViewModelRefresh Method

refresh the view model

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Refresh()
void Refresh()
See Also

Reference

ILayoutMetaDataEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IListEditorViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IListEditorViewModel
public interface class IListEditorViewModel
See Also

Reference

VisualComponents.UX.Shared Namespace


IListViewExItem Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IListViewExItem
public interface class IListViewExItem

The IListViewExItem type exposes the following members.

Properties
 | Name | Description
Public property | DropIndicatorBottom |
Public property | DropIndicatorLeft |
Public property | DropIndicatorRight |
Public property | DropIndicatorTop |
Public property | HasDropLocationChanged |
Public property | IsAnchor |
Public property | IsBeingCopied |
Public property | IsBeingDragged |
Public property | IsCloneable |
Public property | IsDropTargetItem |
Public property | IsRemovable |
Public property | IsSelected |
Public property | ItemDropSide |
Public property | ItemsSource |
Public property | WasCut |
Top
Methods
 | Name | Description
Public method | GetData |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IListViewExItem Properties

The IListViewExItem type exposes the following members.

Properties
 | Name | Description
Public property | DropIndicatorBottom |
Public property | DropIndicatorLeft |
Public property | DropIndicatorRight |
Public property | DropIndicatorTop |
Public property | HasDropLocationChanged |
Public property | IsAnchor |
Public property | IsBeingCopied |
Public property | IsBeingDragged |
Public property | IsCloneable |
Public property | IsDropTargetItem |
Public property | IsRemovable |
Public property | IsSelected |
Public property | ItemDropSide |
Public property | ItemsSource |
Public property | WasCut |
Top
See Also

Reference

IListViewExItem Interface
VisualComponents.UX.Shared Namespace


IListViewExItem.DropIndicatorBottom Property

IListViewExItemDropIndicatorBottom Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
FrameworkElement DropIndicatorBottom { get; set; }
property FrameworkElement^ DropIndicatorBottom {
    FrameworkElement^ get ();
    void set (FrameworkElement^ value);
}

Property Value

Type: FrameworkElement
See Also

Reference

IListViewExItem Interface
VisualComponents.UX.Shared Namespace


IListViewExItem.DropIndicatorLeft Property

IListViewExItemDropIndicatorLeft Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
FrameworkElement DropIndicatorLeft { get; set; }
property FrameworkElement^ DropIndicatorLeft {
    FrameworkElement^ get ();
    void set (FrameworkElement^ value);
}

Property Value

Type: FrameworkElement
See Also

Reference

IListViewExItem Interface
VisualComponents.UX.Shared Namespace


IListViewExItem.DropIndicatorRight Property

IListViewExItemDropIndicatorRight Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
FrameworkElement DropIndicatorRight { get; set; }
property FrameworkElement^ DropIndicatorRight {
    FrameworkElement^ get ();
    void set (FrameworkElement^ value);
}

Property Value

Type: FrameworkElement
See Also

Reference

IListViewExItem Interface
VisualComponents.UX.Shared Namespace


IListViewExItem.DropIndicatorTop Property

IListViewExItemDropIndicatorTop Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
FrameworkElement DropIndicatorTop { get; set; }
property FrameworkElement^ DropIndicatorTop {
    FrameworkElement^ get ();
    void set (FrameworkElement^ value);
}

Property Value

Type: FrameworkElement
See Also

Reference

IListViewExItem Interface
VisualComponents.UX.Shared Namespace


IListViewExItem.HasDropLocationChanged Property

IListViewExItemHasDropLocationChanged Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool HasDropLocationChanged { get; set; }
property bool HasDropLocationChanged {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IListViewExItem Interface
VisualComponents.UX.Shared Namespace


IListViewExItem.IsAnchor Property

IListViewExItemIsAnchor Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsAnchor { get; set; }
property bool IsAnchor {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IListViewExItem Interface
VisualComponents.UX.Shared Namespace


IListViewExItem.IsBeingCopied Property

IListViewExItemIsBeingCopied Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsBeingCopied { get; set; }
property bool IsBeingCopied {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IListViewExItem Interface
VisualComponents.UX.Shared Namespace


IListViewExItem.IsBeingDragged Property

IListViewExItemIsBeingDragged Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsBeingDragged { get; set; }
property bool IsBeingDragged {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IListViewExItem Interface
VisualComponents.UX.Shared Namespace


IListViewExItem.IsCloneable Property

IListViewExItemIsCloneable Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsCloneable { get; set; }
property bool IsCloneable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IListViewExItem Interface
VisualComponents.UX.Shared Namespace


IListViewExItem.IsDropTargetItem Property

IListViewExItemIsDropTargetItem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsDropTargetItem { get; set; }
property bool IsDropTargetItem {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IListViewExItem Interface
VisualComponents.UX.Shared Namespace


IListViewExItem.IsRemovable Property

IListViewExItemIsRemovable Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsRemovable { get; set; }
property bool IsRemovable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IListViewExItem Interface
VisualComponents.UX.Shared Namespace


IListViewExItem.IsSelected Property

IListViewExItemIsSelected Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsSelected { get; set; }
property bool IsSelected {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IListViewExItem Interface
VisualComponents.UX.Shared Namespace


IListViewExItem.ItemDropSide Property

IListViewExItemItemDropSide Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ItemDropSide ItemDropSide { get; set; }
property ItemDropSide ItemDropSide {
    ItemDropSide get ();
    void set (ItemDropSide value);
}

Property Value

Type: ItemDropSide
See Also

Reference

IListViewExItem Interface
VisualComponents.UX.Shared Namespace


IListViewExItem.ItemsSource Property

IListViewExItemItemsSource Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList ItemsSource { get; set; }
property IList^ ItemsSource {
    IList^ get ();
    void set (IList^ value);
}

Property Value

Type: IList
See Also

Reference

IListViewExItem Interface
VisualComponents.UX.Shared Namespace


IListViewExItem.WasCut Property

IListViewExItemWasCut Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool WasCut { get; set; }
property bool WasCut {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IListViewExItem Interface
VisualComponents.UX.Shared Namespace


IListViewExItem Methods

The IListViewExItem type exposes the following members.

Methods
 | Name | Description
Public method | GetData |
Top
See Also

Reference

IListViewExItem Interface
VisualComponents.UX.Shared Namespace


IListViewExItem.GetData Method

IListViewExItemGetData Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object GetData(
    Object caller
)
Object^ GetData(
    Object^ caller
)

Parameters

caller
Type: SystemObject

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IListViewExItem.GetData(System.Object)"]

See Also

Reference

IListViewExItem Interface
VisualComponents.UX.Shared Namespace


ILookupDialogViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ILookupDialogViewModel
public interface class ILookupDialogViewModel

The ILookupDialogViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Initialize | Check and listen event changes
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ILookupDialogViewModel Methods

The ILookupDialogViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Initialize | Check and listen event changes
Top
See Also

Reference

ILookupDialogViewModel Interface
VisualComponents.UX.Shared Namespace


ILookupDialogViewModel.Initialize Method

ILookupDialogViewModelInitialize Method

Check and listen event changes

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Initialize(
    List<INamed> Items,
    IList Result
)
void Initialize(
    List<INamed^>^ Items,
    IList^ Result
)

Parameters

Items
Type: System.Collections.GenericListINamed
Result
Type: System.CollectionsIList
See Also

Reference

ILookupDialogViewModel Interface
VisualComponents.UX.Shared Namespace


ImageAnimationController Class

Provides a way to pause, resume or seek a GIF animation.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedImageAnimationController

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ImageAnimationController : IDisposable
public ref class ImageAnimationController : IDisposable

The ImageAnimationController type exposes the following members.

Properties
 | Name | Description
Public property | CurrentFrame | Returns the current frame index.
Public property | FrameCount | Returns the number of frames in the image.
Public property | IsComplete | Returns a value that indicates whether the animation is complete.
Public property | IsPaused | Returns a value that indicates whether the animation is paused.
Top
Methods
 | Name | Description
Public method | Dispose | Disposes the current object.
Protected method | Dispose(Boolean) | Disposes the current object
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes the current object. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GotoFrame | Seeks the animation to the specified frame index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Pause | Pauses the animation.
Public method | Play | Starts or resumes the animation. If the animation is complete, it restarts from the beginning.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CurrentFrameChanged | Raised when the current frame changes.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ImageAnimationController Properties

The ImageAnimationController type exposes the following members.

Properties
 | Name | Description
Public property | CurrentFrame | Returns the current frame index.
Public property | FrameCount | Returns the number of frames in the image.
Public property | IsComplete | Returns a value that indicates whether the animation is complete.
Public property | IsPaused | Returns a value that indicates whether the animation is paused.
Top
See Also

Reference

ImageAnimationController Class
VisualComponents.UX.Shared Namespace


ImageAnimationController.CurrentFrame Property

ImageAnimationControllerCurrentFrame Property

Returns the current frame index.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int CurrentFrame { get; }
public:
property int CurrentFrame {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ImageAnimationController Class
VisualComponents.UX.Shared Namespace


ImageAnimationController.FrameCount Property

ImageAnimationControllerFrameCount Property

Returns the number of frames in the image.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int FrameCount { get; }
public:
property int FrameCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ImageAnimationController Class
VisualComponents.UX.Shared Namespace


ImageAnimationController.IsComplete Property

ImageAnimationControllerIsComplete Property

Returns a value that indicates whether the animation is complete.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsComplete { get; }
public:
property bool IsComplete {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ImageAnimationController Class
VisualComponents.UX.Shared Namespace


ImageAnimationController.IsPaused Property

ImageAnimationControllerIsPaused Property

Returns a value that indicates whether the animation is paused.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsPaused { get; }
public:
property bool IsPaused {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ImageAnimationController Class
VisualComponents.UX.Shared Namespace


ImageAnimationController Methods

The ImageAnimationController type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes the current object.
Protected method | Dispose(Boolean) | Disposes the current object
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Finalizes the current object. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GotoFrame | Seeks the animation to the specified frame index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Pause | Pauses the animation.
Public method | Play | Starts or resumes the animation. If the animation is complete, it restarts from the beginning.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ImageAnimationController Class
VisualComponents.UX.Shared Namespace


ImageAnimationController.Dispose Method

ImageAnimationControllerDispose Method

Overload List
 | Name | Description
Public method | Dispose | Disposes the current object.
Protected method | Dispose(Boolean) | Disposes the current object
Top
See Also

Reference

ImageAnimationController Class
VisualComponents.UX.Shared Namespace


ImageAnimationController.Dispose Method

ImageAnimationControllerDispose Method

Disposes the current object.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Dispose()
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

ImageAnimationController Class
Dispose Overload
VisualComponents.UX.Shared Namespace


ImageAnimationController.Dispose Method (Boolean)

ImageAnimationControllerDispose Method (Boolean)

Disposes the current object

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void Dispose(
    bool disposing
)
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to dispose both managed an unmanaged resources, false to dispose only managed resources
See Also

Reference

ImageAnimationController Class
Dispose Overload
VisualComponents.UX.Shared Namespace


ImageAnimationController.Finalize Method

ImageAnimationControllerFinalize Method

Finalizes the current object.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void Finalize()
protected:
virtual void Finalize() override

Implements

ObjectFinalize
See Also

Reference

ImageAnimationController Class
VisualComponents.UX.Shared Namespace


ImageAnimationController.GotoFrame Method

ImageAnimationControllerGotoFrame Method

Seeks the animation to the specified frame index.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void GotoFrame(
    int index
)
public:
void GotoFrame(
    int index
)

Parameters

index
Type: SystemInt32
The index of the frame to seek to
See Also

Reference

ImageAnimationController Class
VisualComponents.UX.Shared Namespace


ImageAnimationController.Pause Method

ImageAnimationControllerPause Method

Pauses the animation.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Pause()
public:
void Pause()
See Also

Reference

ImageAnimationController Class
VisualComponents.UX.Shared Namespace


ImageAnimationController.Play Method

ImageAnimationControllerPlay Method

Starts or resumes the animation. If the animation is complete, it restarts from the beginning.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Play()
public:
void Play()
See Also

Reference

ImageAnimationController Class
VisualComponents.UX.Shared Namespace


ImageAnimationController Events

The ImageAnimationController type exposes the following members.

Events
 | Name | Description
Public event | CurrentFrameChanged | Raised when the current frame changes.
Top
See Also

Reference

ImageAnimationController Class
VisualComponents.UX.Shared Namespace


ImageAnimationController.CurrentFrameChanged Event

ImageAnimationControllerCurrentFrameChanged Event

Raised when the current frame changes.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler CurrentFrameChanged
public:
 event EventHandler^ CurrentFrameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ImageAnimationController Class
VisualComponents.UX.Shared Namespace


ImageBehavior Class

Provides attached properties that display animated GIFs in a standard Image control.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedImageBehavior

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class ImageBehavior
[ExtensionAttribute]
public ref class ImageBehavior abstract sealed

The ImageBehavior type exposes the following members.

Methods
Name | Description
AddAnimationCompletedHandler | Adds a handler for the AnimationCompleted attached event.
AddAnimationLoadedHandler | Adds a handler for the AnimationLoaded attached event.
GetAnimatedSource | Gets the value of the AnimatedSource attached property for the specified object.
GetAnimateInDesignMode | Gets the value of the AnimateInDesignMode attached property for the specified object.
GetAnimationController | Gets the animation controller for the specified Image control.
GetAutoStart | Gets the value of the AutoStart attached property for the specified object.
GetIsAnimationLoaded | Gets the value of the IsAnimationLoaded attached property for the specified object.
GetRepeatBehavior | Gets the value of the RepeatBehavior attached property for the specified object.
RemoveAnimationCompletedHandler | Removes a handler for the AnimationCompleted attached event.
RemoveAnimationLoadedHandler | Removes a handler for the AnimationLoaded attached event.
SetAnimatedSource | Sets the value of the AnimatedSource attached property for the specified object.
SetAnimateInDesignMode | Sets the value of the AnimateInDesignMode attached property for the specified object.
SetAutoStart | Sets the value of the AutoStart attached property for the specified object.
SetRepeatBehavior | Sets the value of the RepeatBehavior attached property for the specified object.
Top
Fields
Name | Description
AnimatedSourceProperty | Identifies the AnimatedSource attached property.
AnimateInDesignModeProperty | Identifies the AnimateInDesignMode attached property.
AnimationCompletedEvent | Identifies the AnimationCompleted attached event.
AnimationLoadedEvent | Identifies the AnimationLoaded attached event.
AutoStartProperty | Identifies the AutoStart attached property.
IsAnimationLoadedProperty | Identifies the IsAnimationLoaded attached property.
RepeatBehaviorProperty | Identifies the RepeatBehavior attached property.
Top
Attached Properties
 | Name | Description
Public attached property | AnimatedSource |
Public attached property | AnimateInDesignMode |
Public attached property | AutoStart |
Public attached property | IsAnimationLoaded |
Public attached property | RepeatBehavior |
Top
Attached Events
 | Name | Description
Public attached event | AnimationCompleted |
Public attached event | AnimationLoaded |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ImageBehavior Methods

The ImageBehavior type exposes the following members.

Methods
Name | Description
AddAnimationCompletedHandler | Adds a handler for the AnimationCompleted attached event.
AddAnimationLoadedHandler | Adds a handler for the AnimationLoaded attached event.
GetAnimatedSource | Gets the value of the AnimatedSource attached property for the specified object.
GetAnimateInDesignMode | Gets the value of the AnimateInDesignMode attached property for the specified object.
GetAnimationController | Gets the animation controller for the specified Image control.
GetAutoStart | Gets the value of the AutoStart attached property for the specified object.
GetIsAnimationLoaded | Gets the value of the IsAnimationLoaded attached property for the specified object.
GetRepeatBehavior | Gets the value of the RepeatBehavior attached property for the specified object.
RemoveAnimationCompletedHandler | Removes a handler for the AnimationCompleted attached event.
RemoveAnimationLoadedHandler | Removes a handler for the AnimationLoaded attached event.
SetAnimatedSource | Sets the value of the AnimatedSource attached property for the specified object.
SetAnimateInDesignMode | Sets the value of the AnimateInDesignMode attached property for the specified object.
SetAutoStart | Sets the value of the AutoStart attached property for the specified object.
SetRepeatBehavior | Sets the value of the RepeatBehavior attached property for the specified object.
Top
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior.AddAnimationCompletedHandler Method

ImageBehaviorAddAnimationCompletedHandler Method

Adds a handler for the AnimationCompleted attached event.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void AddAnimationCompletedHandler(
    Image d,
    RoutedEventHandler handler
)
public:
static void AddAnimationCompletedHandler(
    Image^ d,
    RoutedEventHandler^ handler
)

Parameters

d
Type: System.Windows.ControlsImage
The UIElement that listens to this event.
handler
Type: System.WindowsRoutedEventHandler
The event handler to be added.
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior.AddAnimationLoadedHandler Method

ImageBehaviorAddAnimationLoadedHandler Method

Adds a handler for the AnimationLoaded attached event.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void AddAnimationLoadedHandler(
    Image image,
    RoutedEventHandler handler
)
public:
static void AddAnimationLoadedHandler(
    Image^ image,
    RoutedEventHandler^ handler
)

Parameters

image
Type: System.Windows.ControlsImage
The UIElement that listens to this event.
handler
Type: System.WindowsRoutedEventHandler
The event handler to be added.
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior.GetAnimatedSource Method

ImageBehaviorGetAnimatedSource Method

Gets the value of the AnimatedSource attached property for the specified object.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ImageSource GetAnimatedSource(
    Image obj
)
public:
static ImageSource^ GetAnimatedSource(
    Image^ obj
)

Parameters

obj
Type: System.Windows.ControlsImage
The element from which to read the property value.

Return Value

Type: ImageSource
The currently displayed animated image.
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior.GetAnimateInDesignMode Method

ImageBehaviorGetAnimateInDesignMode Method

Gets the value of the AnimateInDesignMode attached property for the specified object.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool GetAnimateInDesignMode(
    DependencyObject obj
)
public:
static bool GetAnimateInDesignMode(
    DependencyObject^ obj
)

Parameters

obj
Type: System.WindowsDependencyObject
The element from which to read the property value.

Return Value

Type: Boolean
true if GIF animations are shown in design mode; false otherwise.
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior.GetAnimationController Method

ImageBehaviorGetAnimationController Method

Gets the animation controller for the specified Image control.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ImageAnimationController GetAnimationController(
    Image imageControl
)
public:
static ImageAnimationController^ GetAnimationController(
    Image^ imageControl
)

Parameters

imageControl
Type: System.Windows.ControlsImage

Return Value

Type: ImageAnimationController

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ImageBehavior.GetAnimationController(System.Windows.Controls.Image)"]

See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior.GetAutoStart Method

ImageBehaviorGetAutoStart Method

Gets the value of the AutoStart attached property for the specified object.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool GetAutoStart(
    Image obj
)
public:
static bool GetAutoStart(
    Image^ obj
)

Parameters

obj
Type: System.Windows.ControlsImage
The element from which to read the property value.

Return Value

Type: Boolean
true if the animation should start immediately when loaded. Otherwise, false.
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior.GetIsAnimationLoaded Method

ImageBehaviorGetIsAnimationLoaded Method

Gets the value of the IsAnimationLoaded attached property for the specified object.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool GetIsAnimationLoaded(
    Image image
)
public:
static bool GetIsAnimationLoaded(
    Image^ image
)

Parameters

image
Type: System.Windows.ControlsImage
The element from which to read the property value.

Return Value

Type: Boolean
true if the animation is loaded. Otherwise, false.
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior.GetRepeatBehavior Method

ImageBehaviorGetRepeatBehavior Method

Gets the value of the RepeatBehavior attached property for the specified object.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static RepeatBehavior GetRepeatBehavior(
    Image obj
)
public:
static RepeatBehavior GetRepeatBehavior(
    Image^ obj
)

Parameters

obj
Type: System.Windows.ControlsImage
The element from which to read the property value.

Return Value

Type: RepeatBehavior
The repeat behavior of the animated image.
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior.RemoveAnimationCompletedHandler Method

ImageBehaviorRemoveAnimationCompletedHandler Method

Removes a handler for the AnimationCompleted attached event.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void RemoveAnimationCompletedHandler(
    Image d,
    RoutedEventHandler handler
)
public:
static void RemoveAnimationCompletedHandler(
    Image^ d,
    RoutedEventHandler^ handler
)

Parameters

d
Type: System.Windows.ControlsImage
The UIElement that listens to this event.
handler
Type: System.WindowsRoutedEventHandler
The event handler to be removed.
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior.RemoveAnimationLoadedHandler Method

ImageBehaviorRemoveAnimationLoadedHandler Method

Removes a handler for the AnimationLoaded attached event.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void RemoveAnimationLoadedHandler(
    Image image,
    RoutedEventHandler handler
)
public:
static void RemoveAnimationLoadedHandler(
    Image^ image,
    RoutedEventHandler^ handler
)

Parameters

image
Type: System.Windows.ControlsImage
The UIElement that listens to this event.
handler
Type: System.WindowsRoutedEventHandler
The event handler to be removed.
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior.SetAnimatedSource Method

ImageBehaviorSetAnimatedSource Method

Sets the value of the AnimatedSource attached property for the specified object.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetAnimatedSource(
    Image obj,
    ImageSource value
)
public:
static void SetAnimatedSource(
    Image^ obj,
    ImageSource^ value
)

Parameters

obj
Type: System.Windows.ControlsImage
The element on which to set the property value.
value
Type: System.Windows.MediaImageSource
The animated image to display.
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior.SetAnimateInDesignMode Method

ImageBehaviorSetAnimateInDesignMode Method

Sets the value of the AnimateInDesignMode attached property for the specified object.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetAnimateInDesignMode(
    DependencyObject obj,
    bool value
)
public:
static void SetAnimateInDesignMode(
    DependencyObject^ obj,
    bool value
)

Parameters

obj
Type: System.WindowsDependencyObject
The element on which to set the property value.
value
Type: SystemBoolean
true to show GIF animations in design mode; false otherwise.
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior.SetAutoStart Method

ImageBehaviorSetAutoStart Method

Sets the value of the AutoStart attached property for the specified object.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetAutoStart(
    Image obj,
    bool value
)
public:
static void SetAutoStart(
    Image^ obj,
    bool value
)

Parameters

obj
Type: System.Windows.ControlsImage
The element from which to read the property value.
value
Type: SystemBoolean
true if the animation should start immediately when loaded. Otherwise, false.
Remarks
The default value is true.
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior.SetRepeatBehavior Method

ImageBehaviorSetRepeatBehavior Method

Sets the value of the RepeatBehavior attached property for the specified object.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetRepeatBehavior(
    Image obj,
    RepeatBehavior value
)
public:
static void SetRepeatBehavior(
    Image^ obj,
    RepeatBehavior value
)

Parameters

obj
Type: System.Windows.ControlsImage
The element on which to set the property value.
value
Type: System.Windows.Media.AnimationRepeatBehavior
The repeat behavior of the animated image.
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior Fields

The ImageBehavior type exposes the following members.

Fields
Name | Description
AnimatedSourceProperty | Identifies the AnimatedSource attached property.
AnimateInDesignModeProperty | Identifies the AnimateInDesignMode attached property.
AnimationCompletedEvent | Identifies the AnimationCompleted attached event.
AnimationLoadedEvent | Identifies the AnimationLoaded attached event.
AutoStartProperty | Identifies the AutoStart attached property.
IsAnimationLoadedProperty | Identifies the IsAnimationLoaded attached property.
RepeatBehaviorProperty | Identifies the RepeatBehavior attached property.
Top
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior.AnimatedSourceProperty Field

ImageBehaviorAnimatedSourceProperty Field

Identifies the AnimatedSource attached property.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty AnimatedSourceProperty
public:
static initonly DependencyProperty^ AnimatedSourceProperty

Field Value

Type: DependencyProperty
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior.AnimateInDesignModeProperty Field

ImageBehaviorAnimateInDesignModeProperty Field

Identifies the AnimateInDesignMode attached property.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty AnimateInDesignModeProperty
public:
static initonly DependencyProperty^ AnimateInDesignModeProperty

Field Value

Type: DependencyProperty
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior.AnimationCompletedEvent Field

ImageBehaviorAnimationCompletedEvent Field

Identifies the AnimationCompleted attached event.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly RoutedEvent AnimationCompletedEvent
public:
static initonly RoutedEvent^ AnimationCompletedEvent

Field Value

Type: RoutedEvent
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior.AnimationLoadedEvent Field

ImageBehaviorAnimationLoadedEvent Field

Identifies the AnimationLoaded attached event.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly RoutedEvent AnimationLoadedEvent
public:
static initonly RoutedEvent^ AnimationLoadedEvent

Field Value

Type: RoutedEvent
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior.AutoStartProperty Field

ImageBehaviorAutoStartProperty Field

Identifies the AutoStart attached property.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty AutoStartProperty
public:
static initonly DependencyProperty^ AutoStartProperty

Field Value

Type: DependencyProperty
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior.IsAnimationLoadedProperty Field

ImageBehaviorIsAnimationLoadedProperty Field

Identifies the IsAnimationLoaded attached property.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsAnimationLoadedProperty
public:
static initonly DependencyProperty^ IsAnimationLoadedProperty

Field Value

Type: DependencyProperty
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior.RepeatBehaviorProperty Field

ImageBehaviorRepeatBehaviorProperty Field

Identifies the RepeatBehavior attached property.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty RepeatBehaviorProperty
public:
static initonly DependencyProperty^ RepeatBehaviorProperty

Field Value

Type: DependencyProperty
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior Attached Properties

The ImageBehavior type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | AnimatedSource |
Public attached property | AnimateInDesignMode |
Public attached property | AutoStart |
Public attached property | IsAnimationLoaded |
Public attached property | RepeatBehavior |
Top
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior.AnimatedSource Attached Property

ImageBehaviorAnimatedSource Attached Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See GetAnimatedSource, SetAnimatedSource
See GetAnimatedSource, SetAnimatedSource

Property Value

Type: ImageSource
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior.AnimateInDesignMode Attached Property

ImageBehaviorAnimateInDesignMode Attached Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See GetAnimateInDesignMode, SetAnimateInDesignMode
See GetAnimateInDesignMode, SetAnimateInDesignMode

Property Value

Type: Boolean
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior.AutoStart Attached Property

ImageBehaviorAutoStart Attached Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See GetAutoStart, SetAutoStart
See GetAutoStart, SetAutoStart

Property Value

Type: Boolean
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior.IsAnimationLoaded Attached Property

ImageBehaviorIsAnimationLoaded Attached Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See GetIsAnimationLoaded
See GetIsAnimationLoaded

Property Value

Type: Boolean
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior.RepeatBehavior Attached Property

ImageBehaviorRepeatBehavior Attached Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See GetRepeatBehavior, SetRepeatBehavior
See GetRepeatBehavior, SetRepeatBehavior

Property Value

Type: RepeatBehavior
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior Attached Events

The ImageBehavior type exposes the following members.

Attached Events
 | Name | Description
Public attached event | AnimationCompleted |
Public attached event | AnimationLoaded |
Top
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior.AnimationCompleted Attached Event

ImageBehaviorAnimationCompleted Attached Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See AddAnimationCompletedHandler, RemoveAnimationCompletedHandler
See AddAnimationCompletedHandler, RemoveAnimationCompletedHandler

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageBehavior.AnimationLoaded Attached Event

ImageBehaviorAnimationLoaded Attached Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See AddAnimationLoadedHandler, RemoveAnimationLoadedHandler
See AddAnimationLoadedHandler, RemoveAnimationLoadedHandler

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

ImageBehavior Class
VisualComponents.UX.Shared Namespace


ImageHelper Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedImageHelper

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class ImageHelper
public ref class ImageHelper abstract sealed

The ImageHelper type exposes the following members.

Methods
Name | Description
BgraToJPGImageSource |
byteArrayToImage |
ConvertToBitmapSource |
FromPixelConversion |
GetBitmap |
GetImageStream |
imageToByteArray |
LoadImage |
ToPixelConversion |
Top
Fields
Name | Description
intTesty |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ImageHelper Methods

The ImageHelper type exposes the following members.

Methods
Name | Description
BgraToJPGImageSource |
byteArrayToImage |
ConvertToBitmapSource |
FromPixelConversion |
GetBitmap |
GetImageStream |
imageToByteArray |
LoadImage |
ToPixelConversion |
Top
See Also

Reference

ImageHelper Class
VisualComponents.UX.Shared Namespace


ImageHelper.BgraToJPGImageSource Method

ImageHelperBgraToJPGImageSource Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static BitmapSource BgraToJPGImageSource(
    byte[] bytes,
    int w,
    int h
)
public:
static BitmapSource^ BgraToJPGImageSource(
    array<unsigned char>^ bytes,
    int w,
    int h
)

Parameters

bytes
Type: SystemByte
w
Type: SystemInt32
h
Type: SystemInt32

Return Value

Type: BitmapSource

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ImageHelper.BgraToJPGImageSource(System.Byte[],System.Int32,System.Int32)"]

See Also

Reference

ImageHelper Class
VisualComponents.UX.Shared Namespace


ImageHelper.byteArrayToImage Method

ImageHelperbyteArrayToImage Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Image byteArrayToImage(
    byte[] byteArrayIn
)
public:
static Image^ byteArrayToImage(
    array<unsigned char>^ byteArrayIn
)

Parameters

byteArrayIn
Type: SystemByte

Return Value

Type: Image

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ImageHelper.byteArrayToImage(System.Byte[])"]

See Also

Reference

ImageHelper Class
VisualComponents.UX.Shared Namespace


ImageHelper.ConvertToBitmapSource Method

ImageHelperConvertToBitmapSource Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static BitmapSource ConvertToBitmapSource(
    UIElement element,
    int w,
    int h
)
public:
static BitmapSource^ ConvertToBitmapSource(
    UIElement^ element,
    int w,
    int h
)

Parameters

element
Type: System.WindowsUIElement
w
Type: SystemInt32
h
Type: SystemInt32

Return Value

Type: BitmapSource

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ImageHelper.ConvertToBitmapSource(System.Windows.UIElement,System.Int32,System.Int32)"]

See Also

Reference

ImageHelper Class
VisualComponents.UX.Shared Namespace


ImageHelper.FromPixelConversion Method

ImageHelperFromPixelConversion Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static double FromPixelConversion(
    double value,
    VcImageSizeUnit unit,
    int ppi
)
public:
static double FromPixelConversion(
    double value,
    VcImageSizeUnit unit,
    int ppi
)

Parameters

value
Type: SystemDouble
unit
Type: VisualComponents.UX.SharedVcImageSizeUnit
ppi
Type: SystemInt32

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ImageHelper.FromPixelConversion(System.Double,VisualComponents.UX.Shared.VcImageSizeUnit,System.Int32)"]

See Also

Reference

ImageHelper Class
VisualComponents.UX.Shared Namespace


ImageHelper.GetBitmap Method

ImageHelperGetBitmap Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Bitmap GetBitmap(
    BitmapSource source
)
public:
static Bitmap^ GetBitmap(
    BitmapSource^ source
)

Parameters

source
Type: System.Windows.Media.ImagingBitmapSource

Return Value

Type: Bitmap

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ImageHelper.GetBitmap(System.Windows.Media.Imaging.BitmapSource)"]

See Also

Reference

ImageHelper Class
VisualComponents.UX.Shared Namespace


ImageHelper.GetImageStream Method

ImageHelperGetImageStream Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static BitmapSource GetImageStream(
    Image myImage
)
public:
static BitmapSource^ GetImageStream(
    Image^ myImage
)

Parameters

myImage
Type: System.DrawingImage

Return Value

Type: BitmapSource

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ImageHelper.GetImageStream(System.Drawing.Image)"]

See Also

Reference

ImageHelper Class
VisualComponents.UX.Shared Namespace


ImageHelper.imageToByteArray Method

ImageHelperimageToByteArray Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static byte[] imageToByteArray(
    Image imageIn
)
public:
static array<unsigned char>^ imageToByteArray(
    Image^ imageIn
)

Parameters

imageIn
Type: System.DrawingImage

Return Value

Type: Byte

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ImageHelper.imageToByteArray(System.Drawing.Image)"]

See Also

Reference

ImageHelper Class
VisualComponents.UX.Shared Namespace


ImageHelper.LoadImage Method

ImageHelperLoadImage Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static BitmapImage LoadImage(
    byte[] imageData
)
public:
static BitmapImage^ LoadImage(
    array<unsigned char>^ imageData
)

Parameters

imageData
Type: SystemByte

Return Value

Type: BitmapImage

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ImageHelper.LoadImage(System.Byte[])"]

See Also

Reference

ImageHelper Class
VisualComponents.UX.Shared Namespace


ImageHelper.ToPixelConversion Method

ImageHelperToPixelConversion Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static double ToPixelConversion(
    double value,
    VcImageSizeUnit unit,
    int ppi = 1
)
public:
static double ToPixelConversion(
    double value,
    VcImageSizeUnit unit,
    int ppi = 1
)

Parameters

value
Type: SystemDouble
unit
Type: VisualComponents.UX.SharedVcImageSizeUnit
ppi (Optional)
Type: SystemInt32

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ImageHelper.ToPixelConversion(System.Double,VisualComponents.UX.Shared.VcImageSizeUnit,System.Int32)"]

See Also

Reference

ImageHelper Class
VisualComponents.UX.Shared Namespace


ImageHelper Fields

The ImageHelper type exposes the following members.

Fields
Name | Description
intTesty |
Top
See Also

Reference

ImageHelper Class
VisualComponents.UX.Shared Namespace


ImageHelper.intTesty Field

ImageHelperintTesty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int intTesty
public:
static int intTesty

Field Value

Type: Int32
See Also

Reference

ImageHelper Class
VisualComponents.UX.Shared Namespace


ImageSizeUnits Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ImageSizeUnits
public enum class ImageSizeUnits
Members
Member name | Value | Description
Points | 0 |
Picas | 1 |
Inches | 2 |
Millimeters | 3 |
Centimeters | 4 |
Pixels | 5 |
See Also

Reference

VisualComponents.UX.Shared Namespace


ImageSourceConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedImageSourceConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ImageSourceConverter : IValueConverter
public ref class ImageSourceConverter : IValueConverter

The ImageSourceConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ImageSourceConverter | Initializes a new instance of the ImageSourceConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
 | DeleteObject |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ImageSourceConverter Constructor

Initializes a new instance of the ImageSourceConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ImageSourceConverter()
public:
ImageSourceConverter()
See Also

Reference

ImageSourceConverter Class
VisualComponents.UX.Shared Namespace


ImageSourceConverter Methods

The ImageSourceConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
 | DeleteObject |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ImageSourceConverter Class
VisualComponents.UX.Shared Namespace


ImageSourceConverter.Convert Method

ImageSourceConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ImageSourceConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

ImageSourceConverter Class
VisualComponents.UX.Shared Namespace


ImageSourceConverter.ConvertBack Method

ImageSourceConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ImageSourceConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

ImageSourceConverter Class
VisualComponents.UX.Shared Namespace


ImageSourceConverter.DeleteObject Method

ImageSourceConverterDeleteObject Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool DeleteObject(
    IntPtr hObject
)
public:
static bool DeleteObject(
    IntPtr hObject
)

Parameters

hObject
Type: SystemIntPtr

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ImageSourceConverter.DeleteObject(System.IntPtr)"]

See Also

Reference

ImageSourceConverter Class
VisualComponents.UX.Shared Namespace


IManipulatorToolbar Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IManipulatorToolbar
public interface class IManipulatorToolbar
See Also

Reference

VisualComponents.UX.Shared Namespace


IMaterialAssignViewModel Interface

Material assign view model interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IMaterialAssignViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IMaterialAssignViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The IMaterialAssignViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | MATERIAL_LAYOUT_CREATED_PROPERTY_NAME |
Public property | Selected |
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | ConvertMaterial |
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | EditMaterial |
Public method | IsMaterialInLayout |
Public method | NotifyLayoutMaterialChange |
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | NotifyUserMaterialChange |
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | RemoveMaterialFromLayout |
Public method | ReplaceToMaterial |
Public method | ScrollIntoView |
Public method | SelectAllSetsWithMaterial |
Public method | SelectMaterial |
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IMaterialAssignViewModel Properties

The IMaterialAssignViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | MATERIAL_LAYOUT_CREATED_PROPERTY_NAME |
Public property | Selected |
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
See Also

Reference

IMaterialAssignViewModel Interface
VisualComponents.UX.Shared Namespace


IMaterialAssignViewModel.MATERIAL_LAYOUT_CREATED_PROPERTY_NAME Property

IMaterialAssignViewModelMATERIAL_LAYOUT_CREATED_PROPERTY_NAME Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string MATERIAL_LAYOUT_CREATED_PROPERTY_NAME { get; }
property String^ MATERIAL_LAYOUT_CREATED_PROPERTY_NAME {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IMaterialAssignViewModel Interface
VisualComponents.UX.Shared Namespace


IMaterialAssignViewModel.Selected Property

IMaterialAssignViewModelSelected Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMaterialUX Selected { get; set; }
property IMaterialUX^ Selected {
    IMaterialUX^ get ();
    void set (IMaterialUX^ value);
}

Property Value

Type: IMaterialUX
See Also

Reference

IMaterialAssignViewModel Interface
VisualComponents.UX.Shared Namespace


IMaterialAssignViewModel Methods

The IMaterialAssignViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | ConvertMaterial |
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | EditMaterial |
Public method | IsMaterialInLayout |
Public method | NotifyLayoutMaterialChange |
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | NotifyUserMaterialChange |
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | RemoveMaterialFromLayout |
Public method | ReplaceToMaterial |
Public method | ScrollIntoView |
Public method | SelectAllSetsWithMaterial |
Public method | SelectMaterial |
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IMaterialAssignViewModel Interface
VisualComponents.UX.Shared Namespace


IMaterialAssignViewModel.ConvertMaterial Method

IMaterialAssignViewModelConvertMaterial Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ConvertMaterial(
    IMaterial m
)
void ConvertMaterial(
    IMaterial^ m
)

Parameters

m
Type: VisualComponents.Create3DIMaterial
See Also

Reference

IMaterialAssignViewModel Interface
VisualComponents.UX.Shared Namespace


IMaterialAssignViewModel.EditMaterial Method

IMaterialAssignViewModelEditMaterial Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void EditMaterial(
    IMaterial m
)
void EditMaterial(
    IMaterial^ m
)

Parameters

m
Type: VisualComponents.Create3DIMaterial
See Also

Reference

IMaterialAssignViewModel Interface
VisualComponents.UX.Shared Namespace


IMaterialAssignViewModel.IsMaterialInLayout Method

IMaterialAssignViewModelIsMaterialInLayout Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsMaterialInLayout(
    IMaterial m
)
bool IsMaterialInLayout(
    IMaterial^ m
)

Parameters

m
Type: VisualComponents.Create3DIMaterial

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IMaterialAssignViewModel.IsMaterialInLayout(VisualComponents.Create3D.IMaterial)"]

See Also

Reference

IMaterialAssignViewModel Interface
VisualComponents.UX.Shared Namespace


IMaterialAssignViewModel.NotifyLayoutMaterialChange Method

IMaterialAssignViewModelNotifyLayoutMaterialChange Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void NotifyLayoutMaterialChange(
    bool keepSelected = false
)
void NotifyLayoutMaterialChange(
    bool keepSelected = false
)

Parameters

keepSelected (Optional)
Type: SystemBoolean
See Also

Reference

IMaterialAssignViewModel Interface
VisualComponents.UX.Shared Namespace


IMaterialAssignViewModel.NotifyUserMaterialChange Method

IMaterialAssignViewModelNotifyUserMaterialChange Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void NotifyUserMaterialChange()
void NotifyUserMaterialChange()
See Also

Reference

IMaterialAssignViewModel Interface
VisualComponents.UX.Shared Namespace


IMaterialAssignViewModel.RemoveMaterialFromLayout Method

IMaterialAssignViewModelRemoveMaterialFromLayout Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RemoveMaterialFromLayout(
    IMaterial m
)
void RemoveMaterialFromLayout(
    IMaterial^ m
)

Parameters

m
Type: VisualComponents.Create3DIMaterial
See Also

Reference

IMaterialAssignViewModel Interface
VisualComponents.UX.Shared Namespace


IMaterialAssignViewModel.ReplaceToMaterial Method

IMaterialAssignViewModelReplaceToMaterial Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ReplaceToMaterial(
    IMaterial m
)
void ReplaceToMaterial(
    IMaterial^ m
)

Parameters

m
Type: VisualComponents.Create3DIMaterial
See Also

Reference

IMaterialAssignViewModel Interface
VisualComponents.UX.Shared Namespace


IMaterialAssignViewModel.ScrollIntoView Method

IMaterialAssignViewModelScrollIntoView Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ScrollIntoView()
void ScrollIntoView()
See Also

Reference

IMaterialAssignViewModel Interface
VisualComponents.UX.Shared Namespace


IMaterialAssignViewModel.SelectAllSetsWithMaterial Method

IMaterialAssignViewModelSelectAllSetsWithMaterial Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SelectAllSetsWithMaterial(
    IMaterial m
)
void SelectAllSetsWithMaterial(
    IMaterial^ m
)

Parameters

m
Type: VisualComponents.Create3DIMaterial
See Also

Reference

IMaterialAssignViewModel Interface
VisualComponents.UX.Shared Namespace


IMaterialAssignViewModel.SelectMaterial Method

IMaterialAssignViewModelSelectMaterial Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SelectMaterial(
    IMaterial m
)
void SelectMaterial(
    IMaterial^ m
)

Parameters

m
Type: VisualComponents.Create3DIMaterial
See Also

Reference

IMaterialAssignViewModel Interface
VisualComponents.UX.Shared Namespace


IMaterialAssignViewModel Events

The IMaterialAssignViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IMaterialAssignViewModel Interface
VisualComponents.UX.Shared Namespace


IMaterialEditViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IMaterialEditViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IMaterialEditViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The IMaterialEditViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | EnsureProperties |
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IMaterialEditViewModel Properties

The IMaterialEditViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
See Also

Reference

IMaterialEditViewModel Interface
VisualComponents.UX.Shared Namespace


IMaterialEditViewModel Methods

The IMaterialEditViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | EnsureProperties |
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IMaterialEditViewModel Interface
VisualComponents.UX.Shared Namespace


IMaterialEditViewModel.EnsureProperties Method

IMaterialEditViewModelEnsureProperties Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void EnsureProperties(
    IMaterial mat
)
void EnsureProperties(
    IMaterial^ mat
)

Parameters

mat
Type: VisualComponents.Create3DIMaterial
See Also

Reference

IMaterialEditViewModel Interface
VisualComponents.UX.Shared Namespace


IMaterialEditViewModel Events

The IMaterialEditViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IMaterialEditViewModel Interface
VisualComponents.UX.Shared Namespace


IMaterialUX Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IMaterialUX
public interface class IMaterialUX

The IMaterialUX type exposes the following members.

Properties
 | Name | Description
Public property | AnySelected |
Public property | CanConvert |
Public property | CanDelete |
Public property | CanEdit |
Public property | CanRemoveFromUser |
Public property | CanSaveToUser |
Public property | Icon |
Public property | IsSelected |
Public property | Material |
Top
Methods
 | Name | Description
Public method | Convert |
Public method | Delete |
Public method | Edit |
Public method | RemoveFromUser |
Public method | SaveToUser |
Public method | SelectAll |
Public method | SetToSelection |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IMaterialUX Properties

The IMaterialUX type exposes the following members.

Properties
 | Name | Description
Public property | AnySelected |
Public property | CanConvert |
Public property | CanDelete |
Public property | CanEdit |
Public property | CanRemoveFromUser |
Public property | CanSaveToUser |
Public property | Icon |
Public property | IsSelected |
Public property | Material |
Top
See Also

Reference

IMaterialUX Interface
VisualComponents.UX.Shared Namespace


IMaterialUX.AnySelected Property

IMaterialUXAnySelected Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool AnySelected { get; set; }
property bool AnySelected {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IMaterialUX Interface
VisualComponents.UX.Shared Namespace


IMaterialUX.CanConvert Property

IMaterialUXCanConvert Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanConvert { get; }
property bool CanConvert {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IMaterialUX Interface
VisualComponents.UX.Shared Namespace


IMaterialUX.CanDelete Property

IMaterialUXCanDelete Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanDelete { get; }
property bool CanDelete {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IMaterialUX Interface
VisualComponents.UX.Shared Namespace


IMaterialUX.CanEdit Property

IMaterialUXCanEdit Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanEdit { get; }
property bool CanEdit {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IMaterialUX Interface
VisualComponents.UX.Shared Namespace


IMaterialUX.CanRemoveFromUser Property

IMaterialUXCanRemoveFromUser Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanRemoveFromUser { get; }
property bool CanRemoveFromUser {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IMaterialUX Interface
VisualComponents.UX.Shared Namespace


IMaterialUX.CanSaveToUser Property

IMaterialUXCanSaveToUser Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanSaveToUser { get; }
property bool CanSaveToUser {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IMaterialUX Interface
VisualComponents.UX.Shared Namespace


IMaterialUX.Icon Property

IMaterialUXIcon Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Icon { get; }
property String^ Icon {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IMaterialUX Interface
VisualComponents.UX.Shared Namespace


IMaterialUX.IsSelected Property

IMaterialUXIsSelected Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsSelected { get; set; }
property bool IsSelected {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IMaterialUX Interface
VisualComponents.UX.Shared Namespace


IMaterialUX.Material Property

IMaterialUXMaterial Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMaterial Material { get; set; }
property IMaterial^ Material {
    IMaterial^ get ();
    void set (IMaterial^ value);
}

Property Value

Type: IMaterial
See Also

Reference

IMaterialUX Interface
VisualComponents.UX.Shared Namespace


IMaterialUX Methods

The IMaterialUX type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | Delete |
Public method | Edit |
Public method | RemoveFromUser |
Public method | SaveToUser |
Public method | SelectAll |
Public method | SetToSelection |
Top
See Also

Reference

IMaterialUX Interface
VisualComponents.UX.Shared Namespace


IMaterialUX.Convert Method

IMaterialUXConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Convert()
void Convert()
See Also

Reference

IMaterialUX Interface
VisualComponents.UX.Shared Namespace


IMaterialUX.Delete Method

IMaterialUXDelete Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Delete()
void Delete()
See Also

Reference

IMaterialUX Interface
VisualComponents.UX.Shared Namespace


IMaterialUX.Edit Method

IMaterialUXEdit Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Edit()
void Edit()
See Also

Reference

IMaterialUX Interface
VisualComponents.UX.Shared Namespace


IMaterialUX.RemoveFromUser Method

IMaterialUXRemoveFromUser Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RemoveFromUser()
void RemoveFromUser()
See Also

Reference

IMaterialUX Interface
VisualComponents.UX.Shared Namespace


IMaterialUX.SaveToUser Method

IMaterialUXSaveToUser Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SaveToUser()
void SaveToUser()
See Also

Reference

IMaterialUX Interface
VisualComponents.UX.Shared Namespace


IMaterialUX.SelectAll Method

IMaterialUXSelectAll Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SelectAll()
void SelectAll()
See Also

Reference

IMaterialUX Interface
VisualComponents.UX.Shared Namespace


IMaterialUX.SetToSelection Method

IMaterialUXSetToSelection Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetToSelection()
void SetToSelection()
See Also

Reference

IMaterialUX Interface
VisualComponents.UX.Shared Namespace


IMeasurePaintToolViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IMeasurePaintToolViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IMeasurePaintToolViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The IMeasurePaintToolViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IMeasurePaintToolViewModel Properties

The IMeasurePaintToolViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
See Also

Reference

IMeasurePaintToolViewModel Interface
VisualComponents.UX.Shared Namespace


IMeasurePaintToolViewModel Methods

The IMeasurePaintToolViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IMeasurePaintToolViewModel Interface
VisualComponents.UX.Shared Namespace


IMeasurePaintToolViewModel Events

The IMeasurePaintToolViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IMeasurePaintToolViewModel Interface
VisualComponents.UX.Shared Namespace


IMenuToolCommand Interface

Implement for commands that should be presented as menu tool / combobox in ribbon.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IMenuToolCommand : IRibbonToolCommand
public interface class IMenuToolCommand : IRibbonToolCommand

The IMenuToolCommand type exposes the following members.

Properties
 | Name | Description
Public property | IsBackgroundVisible | If True ,background is visible .Else it is hidden.
Public property | IsChecked | Gets/sets whether the tool is checked.
Public property | MenuItems | List of menu items.
Public property | MenuToolButtonType | Determines how a MenuTool is used. Either as a single drop down or segmented into a dropdown area and a button area.
Public property | SelectedMenuItem | Currently selected menu item.
Public property | ToolSize | Determines the sizing mode of a Menu tool which affects the size of a tool and whether it displays image, text or both. (Inherited from IRibbonToolCommand.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IMenuToolCommand Properties

The IMenuToolCommand type exposes the following members.

Properties
 | Name | Description
Public property | IsBackgroundVisible | If True ,background is visible .Else it is hidden.
Public property | IsChecked | Gets/sets whether the tool is checked.
Public property | MenuItems | List of menu items.
Public property | MenuToolButtonType | Determines how a MenuTool is used. Either as a single drop down or segmented into a dropdown area and a button area.
Public property | SelectedMenuItem | Currently selected menu item.
Public property | ToolSize | Determines the sizing mode of a Menu tool which affects the size of a tool and whether it displays image, text or both. (Inherited from IRibbonToolCommand.)
Top
See Also

Reference

IMenuToolCommand Interface
VisualComponents.UX.Shared Namespace


IMenuToolCommand.IsBackgroundVisible Property

IMenuToolCommandIsBackgroundVisible Property

If True ,background is visible .Else it is hidden.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsBackgroundVisible { get; }
property bool IsBackgroundVisible {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IMenuToolCommand Interface
VisualComponents.UX.Shared Namespace


IMenuToolCommand.IsChecked Property

IMenuToolCommandIsChecked Property

Gets/sets whether the tool is checked.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsChecked { get; set; }
property bool IsChecked {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IMenuToolCommand Interface
VisualComponents.UX.Shared Namespace


IMenuToolCommand.MenuItems Property

IMenuToolCommandMenuItems Property

List of menu items.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ObservableCollection<MenuItemBase> MenuItems { get; }
property ObservableCollection<MenuItemBase^>^ MenuItems {
    ObservableCollection<MenuItemBase^>^ get ();
}

Property Value

Type: ObservableCollectionMenuItemBase
See Also

Reference

IMenuToolCommand Interface
VisualComponents.UX.Shared Namespace


IMenuToolCommand.MenuToolButtonType Property

IMenuToolCommandMenuToolButtonType Property

Determines how a MenuTool is used. Either as a single drop down or segmented into a dropdown area and a button area.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ButtonType MenuToolButtonType { get; }
property ButtonType MenuToolButtonType {
    ButtonType get ();
}

Property Value

Type: ButtonType
See Also

Reference

IMenuToolCommand Interface
VisualComponents.UX.Shared Namespace


IMenuToolCommand.SelectedMenuItem Property

IMenuToolCommandSelectedMenuItem Property

Currently selected menu item.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MenuItemBase SelectedMenuItem { get; set; }
property MenuItemBase^ SelectedMenuItem {
    MenuItemBase^ get ();
    void set (MenuItemBase^ value);
}

Property Value

Type: MenuItemBase
See Also

Reference

IMenuToolCommand Interface
VisualComponents.UX.Shared Namespace


IMergeFacesViewModel Interface

merge faces view model interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IMergeFacesViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IMergeFacesViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The IMergeFacesViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IMergeFacesViewModel Properties

The IMergeFacesViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
See Also

Reference

IMergeFacesViewModel Interface
VisualComponents.UX.Shared Namespace


IMergeFacesViewModel Methods

The IMergeFacesViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IMergeFacesViewModel Interface
VisualComponents.UX.Shared Namespace


IMergeFacesViewModel Events

The IMergeFacesViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IMergeFacesViewModel Interface
VisualComponents.UX.Shared Namespace


IMetadataEditorViewModel Interface

Read and save component metadata

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IMetadataEditorViewModel
public interface class IMetadataEditorViewModel

The IMetadataEditorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | Metadata | current component metadata info
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IMetadataEditorViewModel Properties

The IMetadataEditorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | Metadata | current component metadata info
Top
See Also

Reference

IMetadataEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IMetadataEditorViewModel.Metadata Property

IMetadataEditorViewModelMetadata Property

current component metadata info

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MetaDataSettings Metadata { get; }
property MetaDataSettings^ Metadata {
    MetaDataSettings^ get ();
}

Property Value

Type: MetaDataSettings
See Also

Reference

IMetadataEditorViewModel Interface
VisualComponents.UX.Shared Namespace


ImportCommandMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedImportCommandMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ImportCommandMessage
public ref class ImportCommandMessage

The ImportCommandMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ImportCommandMessage | Initializes a new instance of the ImportCommandMessage class
Top
Properties
 | Name | Description
Public property | Status |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | LocalPath |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ImportCommandMessage Constructor

Initializes a new instance of the ImportCommandMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ImportCommandMessage(
    string filepath,
    FileStatus status = FileStatus.Unknown
)
public:
ImportCommandMessage(
    String^ filepath,
    FileStatus status = FileStatus::Unknown
)

Parameters

filepath
Type: SystemString
status (Optional)
Type: VisualComponents.UX.SharedFileStatus
See Also

Reference

ImportCommandMessage Class
VisualComponents.UX.Shared Namespace


ImportCommandMessage Properties

The ImportCommandMessage type exposes the following members.

Properties
 | Name | Description
Public property | Status |
Top
See Also

Reference

ImportCommandMessage Class
VisualComponents.UX.Shared Namespace


ImportCommandMessage.Status Property

ImportCommandMessageStatus Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FileStatus Status { get; }
public:
property FileStatus Status {
    FileStatus get ();
}

Property Value

Type: FileStatus
See Also

Reference

ImportCommandMessage Class
VisualComponents.UX.Shared Namespace


ImportCommandMessage Methods

The ImportCommandMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ImportCommandMessage Class
VisualComponents.UX.Shared Namespace


ImportCommandMessage Fields

The ImportCommandMessage type exposes the following members.

Fields
 | Name | Description
Public field | LocalPath |
Top
See Also

Reference

ImportCommandMessage Class
VisualComponents.UX.Shared Namespace


ImportCommandMessage.LocalPath Field

ImportCommandMessageLocalPath Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public readonly string LocalPath
public:
initonly String^ LocalPath

Field Value

Type: String
See Also

Reference

ImportCommandMessage Class
VisualComponents.UX.Shared Namespace


ImportCompletedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.UX.SharedImportCompletedEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ImportCompletedEventArgs : EventArgs
public ref class ImportCompletedEventArgs : public EventArgs

The ImportCompletedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ImportCompletedEventArgs | Initializes a new instance of the ImportCompletedEventArgs class
Top
Properties
 | Name | Description
Public property | IsSuccessful |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ImportCompletedEventArgs Constructor

Initializes a new instance of the ImportCompletedEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ImportCompletedEventArgs(
    bool isSuccessfull
)
public:
ImportCompletedEventArgs(
    bool isSuccessfull
)

Parameters

isSuccessfull
Type: SystemBoolean
See Also

Reference

ImportCompletedEventArgs Class
VisualComponents.UX.Shared Namespace


ImportCompletedEventArgs Properties

The ImportCompletedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | IsSuccessful |
Top
See Also

Reference

ImportCompletedEventArgs Class
VisualComponents.UX.Shared Namespace


ImportCompletedEventArgs.IsSuccessful Property

ImportCompletedEventArgsIsSuccessful Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsSuccessful { get; }
public:
property bool IsSuccessful {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ImportCompletedEventArgs Class
VisualComponents.UX.Shared Namespace


ImportCompletedEventArgs Methods

The ImportCompletedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ImportCompletedEventArgs Class
VisualComponents.UX.Shared Namespace


ImportDrawingTemplateAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedImportDrawingTemplateAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ImportDrawingTemplateAction : ICommandPanelAction,
    IImportDrawingTemplateAction
public ref class ImportDrawingTemplateAction sealed : ICommandPanelAction,
    IImportDrawingTemplateAction

The ImportDrawingTemplateAction type exposes the following members.

Constructors
 | Name | Description
Public method | ImportDrawingTemplateAction | default constructor
Top
Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
Public property | Title |
Top
Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle |
Public method | StartAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ImportDrawingTemplateAction Constructor

default constructor

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ImportDrawingTemplateAction()
public:
ImportDrawingTemplateAction()
See Also

Reference

ImportDrawingTemplateAction Class
VisualComponents.UX.Shared Namespace


ImportDrawingTemplateAction Properties

The ImportDrawingTemplateAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
Public property | Title |
Top
See Also

Reference

ImportDrawingTemplateAction Class
VisualComponents.UX.Shared Namespace


ImportDrawingTemplateAction.ActionFinished Property

ImportDrawingTemplateActionActionFinished Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ActionFinished { get; set; }
public:
virtual property bool ActionFinished {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ICommandPanelActionActionFinished
See Also

Reference

ImportDrawingTemplateAction Class
VisualComponents.UX.Shared Namespace


ImportDrawingTemplateAction.ActionProperties Property

ImportDrawingTemplateActionActionProperties Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<IProperty> ActionProperties { get; }
public:
virtual property List<IProperty^>^ ActionProperties {
    List<IProperty^>^ get () sealed;
}

Property Value

Type: ListIProperty

Implements

ICommandPanelActionActionProperties
See Also

Reference

ImportDrawingTemplateAction Class
VisualComponents.UX.Shared Namespace


ImportDrawingTemplateAction.ApplyButtonText Property

ImportDrawingTemplateActionApplyButtonText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ApplyButtonText { get; }
public:
virtual property String^ ApplyButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionApplyButtonText
See Also

Reference

ImportDrawingTemplateAction Class
VisualComponents.UX.Shared Namespace


ImportDrawingTemplateAction.AssociatedModelId Property

ImportDrawingTemplateActionAssociatedModelId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedModelId { get; }
public:
virtual property String^ AssociatedModelId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedModelId
See Also

Reference

ImportDrawingTemplateAction Class
VisualComponents.UX.Shared Namespace


ImportDrawingTemplateAction.AssociatedSiteId Property

ImportDrawingTemplateActionAssociatedSiteId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedSiteId { get; }
public:
virtual property String^ AssociatedSiteId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedSiteId
See Also

Reference

ImportDrawingTemplateAction Class
VisualComponents.UX.Shared Namespace


ImportDrawingTemplateAction.CallingCommandName Property

ImportDrawingTemplateActionCallingCommandName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CallingCommandName { get; }
public:
virtual property String^ CallingCommandName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCallingCommandName
See Also

Reference

ImportDrawingTemplateAction Class
VisualComponents.UX.Shared Namespace


ImportDrawingTemplateAction.CancelButtonText Property

ImportDrawingTemplateActionCancelButtonText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CancelButtonText { get; }
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCancelButtonText
See Also

Reference

ImportDrawingTemplateAction Class
VisualComponents.UX.Shared Namespace


ImportDrawingTemplateAction.Description Property

ImportDrawingTemplateActionDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; }
public:
virtual property String^ Description {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionDescription
See Also

Reference

ImportDrawingTemplateAction Class
VisualComponents.UX.Shared Namespace


ImportDrawingTemplateAction.ErrorMessage Property

ImportDrawingTemplateActionErrorMessage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ErrorMessage { get; set; }
public:
virtual property String^ ErrorMessage {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionErrorMessage
See Also

Reference

ImportDrawingTemplateAction Class
VisualComponents.UX.Shared Namespace


ImportDrawingTemplateAction.Title Property

ImportDrawingTemplateActionTitle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; }
public:
virtual property String^ Title {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionTitle
See Also

Reference

ImportDrawingTemplateAction Class
VisualComponents.UX.Shared Namespace


ImportDrawingTemplateAction Methods

The ImportDrawingTemplateAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle |
Public method | StartAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ImportDrawingTemplateAction Class
VisualComponents.UX.Shared Namespace


ImportDrawingTemplateAction.ApplyAction Method

ImportDrawingTemplateActionApplyAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ApplyAction()
public:
virtual bool ApplyAction() sealed

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ImportDrawingTemplateAction.ApplyAction"]

Implements

ICommandPanelActionApplyAction
See Also

Reference

ImportDrawingTemplateAction Class
VisualComponents.UX.Shared Namespace


ImportDrawingTemplateAction.CancelAction Method

ImportDrawingTemplateActionCancelAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CancelAction()
public:
virtual void CancelAction() sealed

Implements

ICommandPanelActionCancelAction
See Also

Reference

ImportDrawingTemplateAction Class
VisualComponents.UX.Shared Namespace


ImportDrawingTemplateAction.Handle Method

ImportDrawingTemplateActionHandle Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    RequestActionAbortMessage message
)
public:
void Handle(
    RequestActionAbortMessage^ message
)

Parameters

message
Type: VisualComponents.UX.SharedRequestActionAbortMessage
See Also

Reference

ImportDrawingTemplateAction Class
VisualComponents.UX.Shared Namespace


ImportDrawingTemplateAction.StartAction Method

ImportDrawingTemplateActionStartAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    EventHandler<ResultCompletionEventArgs> completed = null
)
public:
virtual void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr
) sealed

Parameters

completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs

Implements

ICommandPanelActionStartAction(EventHandlerResultCompletionEventArgs)
See Also

Reference

ImportDrawingTemplateAction Class
VisualComponents.UX.Shared Namespace


InformationDisplayMessage Class

Message used to activate 3d wpf visualization with a text. Used for example in: - show paint thickness (in MeasurePaintThicknessAction) after user clicks
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedInformationDisplayMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class InformationDisplayMessage
public ref class InformationDisplayMessage

The InformationDisplayMessage type exposes the following members.

Constructors
 | Name | Description
Public method | InformationDisplayMessage | Contructor. Sets DeleteAllTexts property to True
Public method | InformationDisplayMessage(String, Matrix) | Contructor. Sets DeleteAllTexts property to False
Top
Properties
 | Name | Description
Public property | DeleteAllTexts | If True, all texts will be removed from visualization
Public property | Position | Position where text will be shown
Public property | Text | Text to include if DeleteAllTexts property is set to False
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


InformationDisplayMessage Constructor

Overload List
 | Name | Description
Public method | InformationDisplayMessage | Contructor. Sets DeleteAllTexts property to True
Public method | InformationDisplayMessage(String, Matrix) | Contructor. Sets DeleteAllTexts property to False
Top
See Also

Reference

InformationDisplayMessage Class
VisualComponents.UX.Shared Namespace


InformationDisplayMessage Constructor

Contructor. Sets DeleteAllTexts property to True

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InformationDisplayMessage()
public:
InformationDisplayMessage()
See Also

Reference

InformationDisplayMessage Class
InformationDisplayMessage Overload
VisualComponents.UX.Shared Namespace


InformationDisplayMessage Constructor (String, Matrix)

Contructor. Sets DeleteAllTexts property to False

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InformationDisplayMessage(
    string text,
    Matrix pos
)
public:
InformationDisplayMessage(
    String^ text,
    Matrix pos
)

Parameters

text
Type: SystemString
pos
Type: VisualComponents.Create3DMatrix
See Also

Reference

InformationDisplayMessage Class
InformationDisplayMessage Overload
VisualComponents.UX.Shared Namespace


InformationDisplayMessage Properties

The InformationDisplayMessage type exposes the following members.

Properties
 | Name | Description
Public property | DeleteAllTexts | If True, all texts will be removed from visualization
Public property | Position | Position where text will be shown
Public property | Text | Text to include if DeleteAllTexts property is set to False
Top
See Also

Reference

InformationDisplayMessage Class
VisualComponents.UX.Shared Namespace


InformationDisplayMessage.DeleteAllTexts Property

InformationDisplayMessageDeleteAllTexts Property

If True, all texts will be removed from visualization

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool DeleteAllTexts { get; set; }
public:
property bool DeleteAllTexts {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

InformationDisplayMessage Class
VisualComponents.UX.Shared Namespace


InformationDisplayMessage.Position Property

InformationDisplayMessagePosition Property

Position where text will be shown

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Matrix Position { get; set; }
public:
property Matrix Position {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

InformationDisplayMessage Class
VisualComponents.UX.Shared Namespace


InformationDisplayMessage.Text Property

InformationDisplayMessageText Property

Text to include if DeleteAllTexts property is set to False

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Text { get; set; }
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

InformationDisplayMessage Class
VisualComponents.UX.Shared Namespace


InformationDisplayMessage Methods

The InformationDisplayMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

InformationDisplayMessage Class
VisualComponents.UX.Shared Namespace


INonRibbonTool Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface INonRibbonTool
public interface class INonRibbonTool

The INonRibbonTool type exposes the following members.

Properties
 | Name | Description
Public property | AddToQat |
Public property | IsBlocked |
Public property | QatOrder |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


INonRibbonTool Properties

The INonRibbonTool type exposes the following members.

Properties
 | Name | Description
Public property | AddToQat |
Public property | IsBlocked |
Public property | QatOrder |
Top
See Also

Reference

INonRibbonTool Interface
VisualComponents.UX.Shared Namespace


INonRibbonTool.AddToQat Property

INonRibbonToolAddToQat Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool AddToQat { get; }
property bool AddToQat {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

INonRibbonTool Interface
VisualComponents.UX.Shared Namespace


INonRibbonTool.IsBlocked Property

INonRibbonToolIsBlocked Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsBlocked { get; }
property bool IsBlocked {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

INonRibbonTool Interface
VisualComponents.UX.Shared Namespace


INonRibbonTool.QatOrder Property

INonRibbonToolQatOrder Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int QatOrder { get; }
property int QatOrder {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

INonRibbonTool Interface
VisualComponents.UX.Shared Namespace


INotAbortableCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface INotAbortableCommand : ICommandPanelAction
public interface class INotAbortableCommand : ICommandPanelAction

The INotAbortableCommand type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Top
Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


INotAbortableCommand Properties

The INotAbortableCommand type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

INotAbortableCommand Interface
VisualComponents.UX.Shared Namespace


INotAbortableCommand Methods

The INotAbortableCommand type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

INotAbortableCommand Interface
VisualComponents.UX.Shared Namespace


INoteEditorViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface INoteEditorViewModel
public interface class INoteEditorViewModel

The INoteEditorViewModel type exposes the following members.

Methods
 | Name | Description
Public method | AddNote |
Public method | Edit(INote) |
Public method | Edit(ISimComponent) |
Public method | RemoveNote |
Public method | RemoveWindow |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


INoteEditorViewModel Methods

The INoteEditorViewModel type exposes the following members.

Methods
 | Name | Description
Public method | AddNote |
Public method | Edit(INote) |
Public method | Edit(ISimComponent) |
Public method | RemoveNote |
Public method | RemoveWindow |
Top
See Also

Reference

INoteEditorViewModel Interface
VisualComponents.UX.Shared Namespace


INoteEditorViewModel.AddNote Method

INoteEditorViewModelAddNote Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddNote(
    INote note,
    ISimComponent component
)
void AddNote(
    INote^ note,
    ISimComponent^ component
)

Parameters

note
Type: VisualComponents.Create3DINote
component
Type: VisualComponents.Create3DISimComponent
See Also

Reference

INoteEditorViewModel Interface
VisualComponents.UX.Shared Namespace


INoteEditorViewModel.Edit Method

INoteEditorViewModelEdit Method

Overload List
 | Name | Description
Public method | Edit(INote) |
Public method | Edit(ISimComponent) |
Top
See Also

Reference

INoteEditorViewModel Interface
VisualComponents.UX.Shared Namespace


INoteEditorViewModel.Edit Method (INote)

INoteEditorViewModelEdit Method (INote)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Edit(
    INote note
)
void Edit(
    INote^ note
)

Parameters

note
Type: VisualComponents.Create3DINote
See Also

Reference

INoteEditorViewModel Interface
Edit Overload
VisualComponents.UX.Shared Namespace


INoteEditorViewModel.Edit Method (ISimComponent)

INoteEditorViewModelEdit Method (ISimComponent)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Edit(
    ISimComponent component
)
void Edit(
    ISimComponent^ component
)

Parameters

component
Type: VisualComponents.Create3DISimComponent
See Also

Reference

INoteEditorViewModel Interface
Edit Overload
VisualComponents.UX.Shared Namespace


INoteEditorViewModel.RemoveNote Method

INoteEditorViewModelRemoveNote Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RemoveNote(
    INote note,
    ISimComponent component
)
void RemoveNote(
    INote^ note,
    ISimComponent^ component
)

Parameters

note
Type: VisualComponents.Create3DINote
component
Type: VisualComponents.Create3DISimComponent
See Also

Reference

INoteEditorViewModel Interface
VisualComponents.UX.Shared Namespace


INoteEditorViewModel.RemoveWindow Method

INoteEditorViewModelRemoveWindow Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RemoveWindow(
    ISimComponent component
)
void RemoveWindow(
    ISimComponent^ component
)

Parameters

component
Type: VisualComponents.Create3DISimComponent
See Also

Reference

INoteEditorViewModel Interface
VisualComponents.UX.Shared Namespace


INoteViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface INoteViewModel
public interface class INoteViewModel
See Also

Reference

VisualComponents.UX.Shared Namespace


InputBindingsManager Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedInputBindingsManager

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class InputBindingsManager
public ref class InputBindingsManager abstract sealed

The InputBindingsManager type exposes the following members.

Methods
Name | Description
GetUpdatePropertySourceWhenEnterPressed |
SetUpdatePropertySourceWhenEnterPressed |
Top
Fields
Name | Description
UpdatePropertySourceWhenEnterPressedProperty |
Top
Attached Properties
 | Name | Description
Public attached property | UpdatePropertySourceWhenEnterPressed |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


InputBindingsManager Methods

The InputBindingsManager type exposes the following members.

Methods
Name | Description
GetUpdatePropertySourceWhenEnterPressed |
SetUpdatePropertySourceWhenEnterPressed |
Top
See Also

Reference

InputBindingsManager Class
VisualComponents.UX.Shared Namespace


InputBindingsManager.GetUpdatePropertySourceWhenEnterPressed Method

InputBindingsManagerGetUpdatePropertySourceWhenEnterPressed Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty GetUpdatePropertySourceWhenEnterPressed(
    DependencyObject dp
)
public:
static DependencyProperty^ GetUpdatePropertySourceWhenEnterPressed(
    DependencyObject^ dp
)

Parameters

dp
Type: System.WindowsDependencyObject

Return Value

Type: DependencyProperty

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.InputBindingsManager.GetUpdatePropertySourceWhenEnterPressed(System.Windows.DependencyObject)"]

See Also

Reference

InputBindingsManager Class
VisualComponents.UX.Shared Namespace


InputBindingsManager.SetUpdatePropertySourceWhenEnterPressed Method

InputBindingsManagerSetUpdatePropertySourceWhenEnterPressed Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetUpdatePropertySourceWhenEnterPressed(
    DependencyObject dp,
    DependencyProperty value
)
public:
static void SetUpdatePropertySourceWhenEnterPressed(
    DependencyObject^ dp,
    DependencyProperty^ value
)

Parameters

dp
Type: System.WindowsDependencyObject
value
Type: System.WindowsDependencyProperty
See Also

Reference

InputBindingsManager Class
VisualComponents.UX.Shared Namespace


InputBindingsManager Fields

The InputBindingsManager type exposes the following members.

Fields
Name | Description
UpdatePropertySourceWhenEnterPressedProperty |
Top
See Also

Reference

InputBindingsManager Class
VisualComponents.UX.Shared Namespace


InputBindingsManager.UpdatePropertySourceWhenEnterPressedProperty Field

InputBindingsManagerUpdatePropertySourceWhenEnterPressedProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty UpdatePropertySourceWhenEnterPressedProperty
public:
static initonly DependencyProperty^ UpdatePropertySourceWhenEnterPressedProperty

Field Value

Type: DependencyProperty
See Also

Reference

InputBindingsManager Class
VisualComponents.UX.Shared Namespace


InputBindingsManager Attached Properties

The InputBindingsManager type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | UpdatePropertySourceWhenEnterPressed |
Top
See Also

Reference

InputBindingsManager Class
VisualComponents.UX.Shared Namespace


InputBindingsManager.UpdatePropertySourceWhenEnterPressed Attached Property

InputBindingsManagerUpdatePropertySourceWhenEnterPressed Attached Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See GetUpdatePropertySourceWhenEnterPressed, SetUpdatePropertySourceWhenEnterPressed
See GetUpdatePropertySourceWhenEnterPressed, SetUpdatePropertySourceWhenEnterPressed

Property Value

Type: DependencyProperty
See Also

Reference

InputBindingsManager Class
VisualComponents.UX.Shared Namespace


InputConfigElement Class

Define a custom configuration element to be contained by the InputConfigElement. This element stores Properties that are altered from Display tab Inside Options Backstage item .
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.UX.SharedInputConfigElement

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class InputConfigElement : ConfigurationElement
public ref class InputConfigElement sealed : public ConfigurationElement

The InputConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | InputConfigElement | Initializes a new instance of the InputConfigElement class
Public method | InputConfigElement(Interaction, MouseButton, Key, ModifierKeys, RoutedCommand) | Initializes a new instance of the InputConfigElement class
Public method | InputConfigElement(Interaction, MouseButton, Key, ModifierKeys, RoutedCommand, Boolean) | Initializes a new instance of the InputConfigElement class
Top
Properties
 | Name | Description
Public property | BoundCommand |
Public property | Buttons |
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | Interaction |
Public property | IsEnabled |
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | MouseWheel |
Public property | ShortcutKey |
Public property | ShortcutModifier |
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetClickCount |
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate |
Top
Fields
Name | Description
_inputConfigElementProperties |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


InputConfigElement Constructor

Overload List
 | Name | Description
Public method | InputConfigElement | Initializes a new instance of the InputConfigElement class
Public method | InputConfigElement(Interaction, MouseButton, Key, ModifierKeys, RoutedCommand) | Initializes a new instance of the InputConfigElement class
Public method | InputConfigElement(Interaction, MouseButton, Key, ModifierKeys, RoutedCommand, Boolean) | Initializes a new instance of the InputConfigElement class
Top
See Also

Reference

InputConfigElement Class
VisualComponents.UX.Shared Namespace


InputConfigElement Constructor

Initializes a new instance of the InputConfigElement class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InputConfigElement()
public:
InputConfigElement()
See Also

Reference

InputConfigElement Class
InputConfigElement Overload
VisualComponents.UX.Shared Namespace


InputConfigElement Constructor (Interaction, MouseButton[], Key, ModifierKeys, RoutedCommand)

InputConfigElement Constructor (Interaction, MouseButton, Key, ModifierKeys, RoutedCommand)

Initializes a new instance of the InputConfigElement class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InputConfigElement(
    Interaction interaction,
    MouseButton[] buttons,
    Key shortcut,
    ModifierKeys shortcutModifier,
    RoutedCommand bindToCommand
)
public:
InputConfigElement(
    Interaction interaction,
    array<MouseButton>^ buttons,
    Key shortcut,
    ModifierKeys shortcutModifier,
    RoutedCommand^ bindToCommand
)

Parameters

interaction
Type: VisualComponents.UX.SharedInteraction
buttons
Type: System.Windows.InputMouseButton
shortcut
Type: System.Windows.InputKey
shortcutModifier
Type: System.Windows.InputModifierKeys
bindToCommand
Type: System.Windows.InputRoutedCommand
See Also

Reference

InputConfigElement Class
InputConfigElement Overload
VisualComponents.UX.Shared Namespace


InputConfigElement Constructor (Interaction, MouseButton[], Key, ModifierKeys, RoutedCommand, Boolean)

InputConfigElement Constructor (Interaction, MouseButton, Key, ModifierKeys, RoutedCommand, Boolean)

Initializes a new instance of the InputConfigElement class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InputConfigElement(
    Interaction interaction,
    MouseButton[] buttons,
    Key shortcut,
    ModifierKeys shortcutModifier,
    RoutedCommand bindToCommand,
    bool mousewheel
)
public:
InputConfigElement(
    Interaction interaction,
    array<MouseButton>^ buttons,
    Key shortcut,
    ModifierKeys shortcutModifier,
    RoutedCommand^ bindToCommand,
    bool mousewheel
)

Parameters

interaction
Type: VisualComponents.UX.SharedInteraction
buttons
Type: System.Windows.InputMouseButton
shortcut
Type: System.Windows.InputKey
shortcutModifier
Type: System.Windows.InputModifierKeys
bindToCommand
Type: System.Windows.InputRoutedCommand
mousewheel
Type: SystemBoolean
See Also

Reference

InputConfigElement Class
InputConfigElement Overload
VisualComponents.UX.Shared Namespace


InputConfigElement Properties

The InputConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | BoundCommand |
Public property | Buttons |
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | Interaction |
Public property | IsEnabled |
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | MouseWheel |
Public property | ShortcutKey |
Public property | ShortcutModifier |
Top
See Also

Reference

InputConfigElement Class
VisualComponents.UX.Shared Namespace


InputConfigElement.BoundCommand Property

InputConfigElementBoundCommand Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RoutedCommand BoundCommand { get; set; }
public:
property RoutedCommand^ BoundCommand {
    RoutedCommand^ get ();
    void set (RoutedCommand^ value);
}

Property Value

Type: RoutedCommand
See Also

Reference

InputConfigElement Class
VisualComponents.UX.Shared Namespace


InputConfigElement.Buttons Property

InputConfigElementButtons Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MouseButton[] Buttons { get; set; }
public:
property array<MouseButton>^ Buttons {
    array<MouseButton>^ get ();
    void set (array<MouseButton>^ value);
}

Property Value

Type: MouseButton
See Also

Reference

InputConfigElement Class
VisualComponents.UX.Shared Namespace


InputConfigElement.Interaction Property

InputConfigElementInteraction Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Interaction Interaction { get; set; }
public:
property Interaction Interaction {
    Interaction get ();
    void set (Interaction value);
}

Property Value

Type: Interaction
See Also

Reference

InputConfigElement Class
VisualComponents.UX.Shared Namespace


InputConfigElement.IsEnabled Property

InputConfigElementIsEnabled Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsEnabled { get; set; }
public:
property bool IsEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

InputConfigElement Class
VisualComponents.UX.Shared Namespace


InputConfigElement.MouseWheel Property

InputConfigElementMouseWheel Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool MouseWheel { get; set; }
public:
property bool MouseWheel {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

InputConfigElement Class
VisualComponents.UX.Shared Namespace


InputConfigElement.ShortcutKey Property

InputConfigElementShortcutKey Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Key ShortcutKey { get; set; }
public:
property Key ShortcutKey {
    Key get ();
    void set (Key value);
}

Property Value

Type: Key
See Also

Reference

InputConfigElement Class
VisualComponents.UX.Shared Namespace


InputConfigElement.ShortcutModifier Property

InputConfigElementShortcutModifier Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ModifierKeys ShortcutModifier { get; set; }
public:
property ModifierKeys ShortcutModifier {
    ModifierKeys get ();
    void set (ModifierKeys value);
}

Property Value

Type: ModifierKeys
See Also

Reference

InputConfigElement Class
VisualComponents.UX.Shared Namespace


InputConfigElement Methods

The InputConfigElement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetClickCount |
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

InputConfigElement Class
VisualComponents.UX.Shared Namespace


InputConfigElement.GetClickCount Method

InputConfigElementGetClickCount Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int GetClickCount()
public:
int GetClickCount()

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.InputConfigElement.GetClickCount"]

See Also

Reference

InputConfigElement Class
VisualComponents.UX.Shared Namespace


InputConfigElement.Validate Method

InputConfigElementValidate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Validate()
public:
void Validate()
See Also

Reference

InputConfigElement Class
VisualComponents.UX.Shared Namespace


InputConfigElement Fields

The InputConfigElement type exposes the following members.

Fields
Name | Description
_inputConfigElementProperties |
Top
See Also

Reference

InputConfigElement Class
VisualComponents.UX.Shared Namespace


InputConfigElement._inputConfigElementProperties Field

InputConfigElement_inputConfigElementProperties Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly ConfigurationPropertyCollection _inputConfigElementProperties
public:
static initonly ConfigurationPropertyCollection^ _inputConfigElementProperties

Field Value

Type: ConfigurationPropertyCollection
See Also

Reference

InputConfigElement Class
VisualComponents.UX.Shared Namespace


InputConfigurationConfigCollection Class

Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationElementCollection
VisualComponents.UX.SharedBaseConfigCollection InputConfigElement
VisualComponents.UX.SharedInputConfigurationConfigCollection

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class InputConfigurationConfigCollection : BaseConfigCollection<InputConfigElement>
public ref class InputConfigurationConfigCollection sealed : public BaseConfigCollection<InputConfigElement^>

The InputConfigurationConfigCollection type exposes the following members.

Constructors
 | Name | Description
Public method | InputConfigurationConfigCollection | Initializes a new instance of the InputConfigurationConfigCollection class
Top
Properties
 | Name | Description
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Public property | ItemInt32 | (Inherited from BaseConfigCollectionT.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Top
Methods
 | Name | Description
Public method | Add | Add item to the collection (Inherited from BaseConfigCollectionT.)
Public method | Clear | clear the collection (Inherited from BaseConfigCollectionT.)
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | get the collection index of the element (Inherited from BaseConfigCollectionT.)
Public method | Insert | Inserts an item into the collection at the specified index. (Inherited from BaseConfigCollectionT.)
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Public method | Remove | remove the element from the collection (Inherited from BaseConfigCollectionT.)
Public method | RemoveAt | remove the element from the collection by the index (Inherited from BaseConfigCollectionT.)
Public method | ToList | Returns list of items (Inherited from BaseConfigCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


InputConfigurationConfigCollection Constructor

Initializes a new instance of the InputConfigurationConfigCollection class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InputConfigurationConfigCollection()
public:
InputConfigurationConfigCollection()
See Also

Reference

InputConfigurationConfigCollection Class
VisualComponents.UX.Shared Namespace


InputConfigurationConfigCollection Properties

The InputConfigurationConfigCollection type exposes the following members.

Properties
 | Name | Description
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Public property | ItemInt32 | (Inherited from BaseConfigCollectionT.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Top
See Also

Reference

InputConfigurationConfigCollection Class
VisualComponents.UX.Shared Namespace


InputConfigurationConfigCollection Methods

The InputConfigurationConfigCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add item to the collection (Inherited from BaseConfigCollectionT.)
Public method | Clear | clear the collection (Inherited from BaseConfigCollectionT.)
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | get the collection index of the element (Inherited from BaseConfigCollectionT.)
Public method | Insert | Inserts an item into the collection at the specified index. (Inherited from BaseConfigCollectionT.)
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Public method | Remove | remove the element from the collection (Inherited from BaseConfigCollectionT.)
Public method | RemoveAt | remove the element from the collection by the index (Inherited from BaseConfigCollectionT.)
Public method | ToList | Returns list of items (Inherited from BaseConfigCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

InputConfigurationConfigCollection Class
VisualComponents.UX.Shared Namespace


InputSection Class

Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationSection
VisualComponents.UX.SharedInputSection

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class InputSection : ConfigurationSection,
    IInputSection, ISection
public ref class InputSection sealed : public ConfigurationSection,
    IInputSection, ISection

The InputSection type exposes the following members.

Constructors
 | Name | Description
Public method | InputSection | Initializes a new instance of the InputSection class
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | InputConfiguration |
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName |
Public property | SectionType |
Public property | SectionVersion |
Top
Methods
 | Name | Description
Public method | CheckVersion |
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


InputSection Constructor

Initializes a new instance of the InputSection class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InputSection()
public:
InputSection()
See Also

Reference

InputSection Class
VisualComponents.UX.Shared Namespace


InputSection Properties

The InputSection type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | InputConfiguration |
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName |
Public property | SectionType |
Public property | SectionVersion |
Top
See Also

Reference

InputSection Class
VisualComponents.UX.Shared Namespace


InputSection.InputConfiguration Property

InputSectionInputConfiguration Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InputConfigurationConfigCollection InputConfiguration { get; }
public:
virtual property InputConfigurationConfigCollection^ InputConfiguration {
    InputConfigurationConfigCollection^ get () sealed;
}

Property Value

Type: InputConfigurationConfigCollection

Implements

IInputSectionInputConfiguration
See Also

Reference

InputSection Class
VisualComponents.UX.Shared Namespace


InputSection.SectionName Property

InputSectionSectionName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SectionName { get; }
public:
virtual property String^ SectionName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ISectionSectionName
See Also

Reference

InputSection Class
VisualComponents.UX.Shared Namespace


InputSection.SectionType Property

InputSectionSectionType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type SectionType { get; }
public:
virtual property Type^ SectionType {
    Type^ get () sealed;
}

Property Value

Type: Type

Implements

ISectionSectionType
See Also

Reference

InputSection Class
VisualComponents.UX.Shared Namespace


InputSection.SectionVersion Property

InputSectionSectionVersion Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int SectionVersion { get; set; }
public:
virtual property int SectionVersion {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

ISectionSectionVersion
See Also

Reference

InputSection Class
VisualComponents.UX.Shared Namespace


InputSection Methods

The InputSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion |
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

InputSection Class
VisualComponents.UX.Shared Namespace


InputSection.CheckVersion Method

InputSectionCheckVersion Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CheckVersion()
public:
virtual void CheckVersion() sealed

Implements

ISectionCheckVersion
See Also

Reference

InputSection Class
VisualComponents.UX.Shared Namespace


InputSection.GetSection Method

InputSectionGetSection Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISection GetSection(
    Configuration userSettingConfiguration
)
public:
virtual ISection^ GetSection(
    Configuration^ userSettingConfiguration
) sealed

Parameters

userSettingConfiguration
Type: System.ConfigurationConfiguration

Return Value

Type: ISection

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.InputSection.GetSection(System.Configuration.Configuration)"]

Implements

ISectionGetSection(Configuration)
See Also

Reference

InputSection Class
VisualComponents.UX.Shared Namespace


InputSection.ToString Method

InputSectionToString Method

Converts this instance to string.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String
String representation of this instance
See Also

Reference

InputSection Class
VisualComponents.UX.Shared Namespace


InstanceToTypeConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedInstanceToTypeConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class InstanceToTypeConverter : IValueConverter
public ref class InstanceToTypeConverter : IValueConverter

The InstanceToTypeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | InstanceToTypeConverter | Initializes a new instance of the InstanceToTypeConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


InstanceToTypeConverter Constructor

Initializes a new instance of the InstanceToTypeConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InstanceToTypeConverter()
public:
InstanceToTypeConverter()
See Also

Reference

InstanceToTypeConverter Class
VisualComponents.UX.Shared Namespace


InstanceToTypeConverter Methods

The InstanceToTypeConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

InstanceToTypeConverter Class
VisualComponents.UX.Shared Namespace


InstanceToTypeConverter.Convert Method

InstanceToTypeConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.InstanceToTypeConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

InstanceToTypeConverter Class
VisualComponents.UX.Shared Namespace


InstanceToTypeConverter.ConvertBack Method

InstanceToTypeConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.InstanceToTypeConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

InstanceToTypeConverter Class
VisualComponents.UX.Shared Namespace


InteractAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedInteractAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class InteractAction : IResult,
    IHandle<InternalEndInteractionMessage>, IHandle, IHandle<ContinueInteractionMessage>
public ref class InteractAction sealed : IResult,
    IHandle<InternalEndInteractionMessage^>, IHandle, IHandle<ContinueInteractionMessage^>

The InteractAction type exposes the following members.

Constructors
 | Name | Description
Public method | InteractAction | Initializes a new instance of the InteractAction class
Top
Properties
 | Name | Description
 | IsActive |
Public property | ManipulationArgs |
Public property | PreferLocalPosition |
Public property | PreferNode |
Public property | PreferPosition |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
 | FixPalletizingRobot(IRobot) |
 | FixPalletizingRobot(ISimNode) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle(ContinueInteractionMessage) |
Public method | Handle(InternalEndInteractionMessage) |
 | Interact |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Completed |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


InteractAction Constructor

Initializes a new instance of the InteractAction class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InteractAction()
public:
InteractAction()
See Also

Reference

InteractAction Class
VisualComponents.UX.Shared Namespace


InteractAction Properties

The InteractAction type exposes the following members.

Properties
 | Name | Description
 | IsActive |
Public property | ManipulationArgs |
Public property | PreferLocalPosition |
Public property | PreferNode |
Public property | PreferPosition |
Top
See Also

Reference

InteractAction Class
VisualComponents.UX.Shared Namespace


InteractAction.IsActive Property

InteractActionIsActive Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsActive { get; }
public:
static property bool IsActive {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

InteractAction Class
VisualComponents.UX.Shared Namespace


InteractAction.ManipulationArgs Property

InteractActionManipulationArgs Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ManipulationEventArgs ManipulationArgs { get; set; }
public:
property ManipulationEventArgs^ ManipulationArgs {
    ManipulationEventArgs^ get ();
    void set (ManipulationEventArgs^ value);
}

Property Value

Type: ManipulationEventArgs
See Also

Reference

InteractAction Class
VisualComponents.UX.Shared Namespace


InteractAction.PreferLocalPosition Property

InteractActionPreferLocalPosition Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 PreferLocalPosition { get; set; }
public:
property Vector3 PreferLocalPosition {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

InteractAction Class
VisualComponents.UX.Shared Namespace


InteractAction.PreferNode Property

InteractActionPreferNode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimNode PreferNode { get; set; }
public:
property ISimNode^ PreferNode {
    ISimNode^ get ();
    void set (ISimNode^ value);
}

Property Value

Type: ISimNode
See Also

Reference

InteractAction Class
VisualComponents.UX.Shared Namespace


InteractAction.PreferPosition Property

InteractActionPreferPosition Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 PreferPosition { get; set; }
public:
property Vector3 PreferPosition {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

InteractAction Class
VisualComponents.UX.Shared Namespace


InteractAction Methods

The InteractAction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
 | FixPalletizingRobot(IRobot) |
 | FixPalletizingRobot(ISimNode) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle(ContinueInteractionMessage) |
Public method | Handle(InternalEndInteractionMessage) |
 | Interact |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

InteractAction Class
VisualComponents.UX.Shared Namespace


InteractAction.Execute Method

InteractActionExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    ActionExecutionContext context
)
public:
virtual void Execute(
    ActionExecutionContext^ context
) sealed

Parameters

context
Type: ActionExecutionContext

Implements

IResult.Execute(ActionExecutionContext)
See Also

Reference

InteractAction Class
VisualComponents.UX.Shared Namespace


InteractAction.FixPalletizingRobot Method

InteractActionFixPalletizingRobot Method

Overload List
Name | Description
FixPalletizingRobot(IRobot) |
FixPalletizingRobot(ISimNode) |
Top
See Also

Reference

InteractAction Class
VisualComponents.UX.Shared Namespace


InteractAction.FixPalletizingRobot Method (IRobot)

InteractActionFixPalletizingRobot Method (IRobot)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void FixPalletizingRobot(
    IRobot robot
)
public:
static void FixPalletizingRobot(
    IRobot^ robot
)

Parameters

robot
Type: VisualComponents.Create3DIRobot
See Also

Reference

InteractAction Class
FixPalletizingRobot Overload
VisualComponents.UX.Shared Namespace


InteractAction.FixPalletizingRobot Method (ISimNode)

InteractActionFixPalletizingRobot Method (ISimNode)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void FixPalletizingRobot(
    ISimNode node
)
public:
static void FixPalletizingRobot(
    ISimNode^ node
)

Parameters

node
Type: VisualComponents.Create3DISimNode
See Also

Reference

InteractAction Class
FixPalletizingRobot Overload
VisualComponents.UX.Shared Namespace


InteractAction.Handle Method

InteractActionHandle Method

Overload List
 | Name | Description
Public method | Handle(ContinueInteractionMessage) |
Public method | Handle(InternalEndInteractionMessage) |
Top
See Also

Reference

InteractAction Class
VisualComponents.UX.Shared Namespace


InteractAction.Handle Method (ContinueInteractionMessage)

InteractActionHandle Method (ContinueInteractionMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    ContinueInteractionMessage message
)
public:
virtual void Handle(
    ContinueInteractionMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedContinueInteractionMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

InteractAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


InteractAction.Handle Method (InternalEndInteractionMessage)

InteractActionHandle Method (InternalEndInteractionMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    InternalEndInteractionMessage message
)
public:
virtual void Handle(
    InternalEndInteractionMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedInternalEndInteractionMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

InteractAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


InteractAction.Interact Method

InteractActionInteract Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool Interact(
    IInteractionService _interactionService,
    ISimulation simulation,
    double value
)
public:
static bool Interact(
    IInteractionService^ _interactionService,
    ISimulation^ simulation,
    double value
)

Parameters

_interactionService
Type: VisualComponents.Create3DIInteractionService
simulation
Type: VisualComponents.Create3DISimulation
value
Type: SystemDouble

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.InteractAction.Interact(VisualComponents.Create3D.IInteractionService,VisualComponents.Create3D.ISimulation,System.Double)"]

See Also

Reference

InteractAction Class
VisualComponents.UX.Shared Namespace


InteractAction Events

The InteractAction type exposes the following members.

Events
 | Name | Description
Public event | Completed |
Top
See Also

Reference

InteractAction Class
VisualComponents.UX.Shared Namespace


InteractAction.Completed Event

InteractActionCompleted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ResultCompletionEventArgs> Completed
public:
virtual  event EventHandler<ResultCompletionEventArgs^>^ Completed {
    void add (EventHandler<ResultCompletionEventArgs^>^ value);
    void remove (EventHandler<ResultCompletionEventArgs^>^ value);
}

Value

Type: SystemEventHandlerResultCompletionEventArgs

Implements

IResult.Completed
See Also

Reference

InteractAction Class
VisualComponents.UX.Shared Namespace


Interaction Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum Interaction
public enum class Interaction
Members
Member name | Value | Description
Invalid | 0 |
Select | 1 |
AppendToSelection | 2 |
ShowProperties | 3 |
QuickCopyPaste | 4 |
ShowContextMenu | 5 |
Orbit | 6 |
OrbitExclusive | 7 |
Zoom | 8 |
ZoomExclusive | 9 |
Pan | 10 |
PanExclusive | 11 |
PanAdvanced | 24 |
SetCOI | 12 |
Interact | 13 |
Translate | 15 |
Rotate | 16 |
AreaSelect | 17 |
AppendAreaSelect | 18 |
InteractAnnotation | 19 |
InteractDimension | 20 |
ControlAppendAreaSelect | 21 |
ExtendRangeSelection | 22 |
SelectParent | 23 |
See Also

Reference

VisualComponents.UX.Shared Namespace


InterfaceSectionItem Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedInterfaceSectionItem

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class InterfaceSectionItem : INotifyPropertyChanged,
    ISectionEditorNotifier
public ref class InterfaceSectionItem : INotifyPropertyChanged,
    ISectionEditorNotifier

The InterfaceSectionItem type exposes the following members.

Constructors
 | Name | Description
Public method | InterfaceSectionItem | Initializes a new instance of the InterfaceSectionItem class
Top
Properties
 | Name | Description
Protected property | Application |
Public property | CanAddFields |
Public property | CanModify |
Public property | CanMoveDown |
Public property | CanMoveUp |
Public property | Fields |
Public property | FieldTypes |
Public property | IsExpanded |
Public property | IsSimulationRunning |
Public property | Name |
Public property | NameGUI |
Public property | PosibleFrames |
Public property | Section |
Public property | SelectedField |
Public property | SelectedFrames |
Top
Methods
 | Name | Description
Public method | CreateField |
Public method | DeletedSectionField |
Public method | DeleteSection |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFieldPosition |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveDown |
Public method | MoveUp |
Public method | RaisePropertyChanged |
Public method | ReDoSectionFields |
Public method | ReorderSectionFields |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePosibleFrameList |
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


InterfaceSectionItem Constructor

Initializes a new instance of the InterfaceSectionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InterfaceSectionItem(
    ISimInterfaceSection section,
    IInterfaceEditorNotifier notifier
)
public:
InterfaceSectionItem(
    ISimInterfaceSection^ section,
    IInterfaceEditorNotifier^ notifier
)

Parameters

section
Type: VisualComponents.Create3DISimInterfaceSection
notifier
Type: VisualComponents.UX.SharedIInterfaceEditorNotifier
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem Properties

The InterfaceSectionItem type exposes the following members.

Properties
 | Name | Description
Protected property | Application |
Public property | CanAddFields |
Public property | CanModify |
Public property | CanMoveDown |
Public property | CanMoveUp |
Public property | Fields |
Public property | FieldTypes |
Public property | IsExpanded |
Public property | IsSimulationRunning |
Public property | Name |
Public property | NameGUI |
Public property | PosibleFrames |
Public property | Section |
Public property | SelectedField |
Public property | SelectedFrames |
Top
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem.Application Property

InterfaceSectionItemApplication Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected IApplication Application { get; }
protected:
property IApplication^ Application {
    IApplication^ get ();
}

Property Value

Type: IApplication
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem.CanAddFields Property

InterfaceSectionItemCanAddFields Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanAddFields { get; }
public:
property bool CanAddFields {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem.CanModify Property

InterfaceSectionItemCanModify Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanModify { get; }
public:
property bool CanModify {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem.CanMoveDown Property

InterfaceSectionItemCanMoveDown Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanMoveDown { get; }
public:
property bool CanMoveDown {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem.CanMoveUp Property

InterfaceSectionItemCanMoveUp Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanMoveUp { get; }
public:
property bool CanMoveUp {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem.Fields Property

InterfaceSectionItemFields Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<SectionFieldItem> Fields { get; }
public:
property List<SectionFieldItem^>^ Fields {
    List<SectionFieldItem^>^ get ();
}

Property Value

Type: ListSectionFieldItem
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem.FieldTypes Property

InterfaceSectionItemFieldTypes Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<string> FieldTypes { get; }
public:
property List<String^>^ FieldTypes {
    List<String^>^ get ();
}

Property Value

Type: ListString
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem.IsExpanded Property

InterfaceSectionItemIsExpanded Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsExpanded { get; set; }
public:
property bool IsExpanded {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem.IsSimulationRunning Property

InterfaceSectionItemIsSimulationRunning Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsSimulationRunning { get; protected set; }
public:
property bool IsSimulationRunning {
    bool get ();
    protected: void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem.Name Property

InterfaceSectionItemName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; set; }
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem.NameGUI Property

InterfaceSectionItemNameGUI Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string NameGUI { get; }
public:
property String^ NameGUI {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem.PosibleFrames Property

InterfaceSectionItemPosibleFrames Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<string> PosibleFrames { get; }
public:
property List<String^>^ PosibleFrames {
    List<String^>^ get ();
}

Property Value

Type: ListString
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem.Section Property

InterfaceSectionItemSection Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISimInterfaceSection Section { get; }
public:
property ISimInterfaceSection^ Section {
    ISimInterfaceSection^ get ();
}

Property Value

Type: ISimInterfaceSection
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem.SelectedField Property

InterfaceSectionItemSelectedField Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SelectedField { get; set; }
public:
property String^ SelectedField {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem.SelectedFrames Property

InterfaceSectionItemSelectedFrames Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SelectedFrames { get; set; }
public:
property String^ SelectedFrames {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem Methods

The InterfaceSectionItem type exposes the following members.

Methods
 | Name | Description
Public method | CreateField |
Public method | DeletedSectionField |
Public method | DeleteSection |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFieldPosition |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveDown |
Public method | MoveUp |
Public method | RaisePropertyChanged |
Public method | ReDoSectionFields |
Public method | ReorderSectionFields |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePosibleFrameList |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem.CreateField Method

InterfaceSectionItemCreateField Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CreateField(
    int position = -1
)
public:
void CreateField(
    int position = -1
)

Parameters

position (Optional)
Type: SystemInt32
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem.DeletedSectionField Method

InterfaceSectionItemDeletedSectionField Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void DeletedSectionField()
public:
virtual void DeletedSectionField() sealed

Implements

ISectionEditorNotifierDeletedSectionField
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem.DeleteSection Method

InterfaceSectionItemDeleteSection Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void DeleteSection()
public:
void DeleteSection()
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem.GetFieldPosition Method

InterfaceSectionItemGetFieldPosition Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int GetFieldPosition(
    ISimInterfaceField field
)
public:
virtual int GetFieldPosition(
    ISimInterfaceField^ field
) sealed

Parameters

field
Type: VisualComponents.Create3DISimInterfaceField

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.InterfaceSectionItem.GetFieldPosition(VisualComponents.Create3D.ISimInterfaceField)"]

Implements

ISectionEditorNotifierGetFieldPosition(ISimInterfaceField)
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem.MoveDown Method

InterfaceSectionItemMoveDown Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MoveDown()
public:
void MoveDown()
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem.MoveUp Method

InterfaceSectionItemMoveUp Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MoveUp()
public:
void MoveUp()
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem.RaisePropertyChanged Method

InterfaceSectionItemRaisePropertyChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RaisePropertyChanged(
    string PropertyName
)
public:
void RaisePropertyChanged(
    String^ PropertyName
)

Parameters

PropertyName
Type: SystemString
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem.ReDoSectionFields Method

InterfaceSectionItemReDoSectionFields Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ReDoSectionFields(
    string name,
    string type,
    int positionInSection
)
public:
virtual void ReDoSectionFields(
    String^ name,
    String^ type,
    int positionInSection
) sealed

Parameters

name
Type: SystemString
type
Type: SystemString
positionInSection
Type: SystemInt32

Implements

ISectionEditorNotifierReDoSectionFields(String, String, Int32)
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem.ReorderSectionFields Method

InterfaceSectionItemReorderSectionFields Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ReorderSectionFields()
public:
virtual void ReorderSectionFields() sealed

Implements

ISectionEditorNotifierReorderSectionFields
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem.UpdatePosibleFrameList Method

InterfaceSectionItemUpdatePosibleFrameList Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void UpdatePosibleFrameList()
public:
void UpdatePosibleFrameList()
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem Events

The InterfaceSectionItem type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfaceSectionItem.PropertyChanged Event

InterfaceSectionItemPropertyChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event PropertyChangedEventHandler PropertyChanged
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

InterfaceSectionItem Class
VisualComponents.UX.Shared Namespace


InterfacesEditorView Class

Interaction logic for InterfacesEditorView.xaml
InterfacesEditorView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedInterfacesEditorView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class InterfacesEditorView : UserControl,
    IComponentConnector
public ref class InterfacesEditorView : public UserControl,
    IComponentConnector

The InterfacesEditorView type exposes the following members.

Constructors
 | Name | Description
Public method | InterfacesEditorView | Initializes a new instance of the InterfacesEditorView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


InterfacesEditorView Constructor

Initializes a new instance of the InterfacesEditorView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InterfacesEditorView()
public:
InterfacesEditorView()
See Also

Reference

InterfacesEditorView Class
VisualComponents.UX.Shared Namespace


InterfacesEditorView Properties

The InterfacesEditorView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

InterfacesEditorView Class
VisualComponents.UX.Shared Namespace


InterfacesEditorView Methods

The InterfacesEditorView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

InterfacesEditorView Class
VisualComponents.UX.Shared Namespace


InterfacesEditorView.InitializeComponent Method

InterfacesEditorViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

InterfacesEditorView Class
VisualComponents.UX.Shared Namespace


InterfacesEditorView Events

The InterfacesEditorView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

InterfacesEditorView Class
VisualComponents.UX.Shared Namespace


InternalEndInteractionMessage Class

Interaction finalization message. Used internally to finalize the interaction.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedInternalEndInteractionMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class InternalEndInteractionMessage
public ref class InternalEndInteractionMessage sealed

The InternalEndInteractionMessage type exposes the following members.

Constructors
 | Name | Description
Public method | InternalEndInteractionMessage | Initializes a new instance of the InternalEndInteractionMessage class
Top
Properties
 | Name | Description
Public property | Action |
Public property | Args |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


InternalEndInteractionMessage Constructor

Initializes a new instance of the InternalEndInteractionMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InternalEndInteractionMessage()
public:
InternalEndInteractionMessage()
See Also

Reference

InternalEndInteractionMessage Class
VisualComponents.UX.Shared Namespace


InternalEndInteractionMessage Properties

The InternalEndInteractionMessage type exposes the following members.

Properties
 | Name | Description
Public property | Action |
Public property | Args |
Top
See Also

Reference

InternalEndInteractionMessage Class
VisualComponents.UX.Shared Namespace


InternalEndInteractionMessage.Action Property

InternalEndInteractionMessageAction Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Action Action { get; set; }
public:
property Action Action {
    Action get ();
    void set (Action value);
}

Property Value

Type: Action
See Also

Reference

InternalEndInteractionMessage Class
VisualComponents.UX.Shared Namespace


InternalEndInteractionMessage.Args Property

InternalEndInteractionMessageArgs Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ManipulationEventArgs Args { get; set; }
public:
property ManipulationEventArgs^ Args {
    ManipulationEventArgs^ get ();
    void set (ManipulationEventArgs^ value);
}

Property Value

Type: ManipulationEventArgs
See Also

Reference

InternalEndInteractionMessage Class
VisualComponents.UX.Shared Namespace


InternalEndInteractionMessage Methods

The InternalEndInteractionMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

InternalEndInteractionMessage Class
VisualComponents.UX.Shared Namespace


IntToBooleanConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedIntToBooleanConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class IntToBooleanConverter : IValueConverter
public ref class IntToBooleanConverter : IValueConverter

The IntToBooleanConverter type exposes the following members.

Constructors
 | Name | Description
Public method | IntToBooleanConverter | Initializes a new instance of the IntToBooleanConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IntToBooleanConverter Constructor

Initializes a new instance of the IntToBooleanConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IntToBooleanConverter()
public:
IntToBooleanConverter()
See Also

Reference

IntToBooleanConverter Class
VisualComponents.UX.Shared Namespace


IntToBooleanConverter Methods

The IntToBooleanConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

IntToBooleanConverter Class
VisualComponents.UX.Shared Namespace


IntToBooleanConverter.Convert Method

IntToBooleanConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IntToBooleanConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

IntToBooleanConverter Class
VisualComponents.UX.Shared Namespace


IntToBooleanConverter.ConvertBack Method

IntToBooleanConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IntToBooleanConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

IntToBooleanConverter Class
VisualComponents.UX.Shared Namespace


IntToOppositeBooleanConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedIntToOppositeBooleanConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class IntToOppositeBooleanConverter : IValueConverter
public ref class IntToOppositeBooleanConverter : IValueConverter

The IntToOppositeBooleanConverter type exposes the following members.

Constructors
 | Name | Description
Public method | IntToOppositeBooleanConverter | Initializes a new instance of the IntToOppositeBooleanConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IntToOppositeBooleanConverter Constructor

Initializes a new instance of the IntToOppositeBooleanConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IntToOppositeBooleanConverter()
public:
IntToOppositeBooleanConverter()
See Also

Reference

IntToOppositeBooleanConverter Class
VisualComponents.UX.Shared Namespace


IntToOppositeBooleanConverter Methods

The IntToOppositeBooleanConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

IntToOppositeBooleanConverter Class
VisualComponents.UX.Shared Namespace


IntToOppositeBooleanConverter.Convert Method

IntToOppositeBooleanConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IntToOppositeBooleanConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

IntToOppositeBooleanConverter Class
VisualComponents.UX.Shared Namespace


IntToOppositeBooleanConverter.ConvertBack Method

IntToOppositeBooleanConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IntToOppositeBooleanConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

IntToOppositeBooleanConverter Class
VisualComponents.UX.Shared Namespace


IntToVisibilityConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedIntToVisibilityConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class IntToVisibilityConverter : IValueConverter
public ref class IntToVisibilityConverter : IValueConverter

The IntToVisibilityConverter type exposes the following members.

Constructors
 | Name | Description
Public method | IntToVisibilityConverter | Initializes a new instance of the IntToVisibilityConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IntToVisibilityConverter Constructor

Initializes a new instance of the IntToVisibilityConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IntToVisibilityConverter()
public:
IntToVisibilityConverter()
See Also

Reference

IntToVisibilityConverter Class
VisualComponents.UX.Shared Namespace


IntToVisibilityConverter Methods

The IntToVisibilityConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

IntToVisibilityConverter Class
VisualComponents.UX.Shared Namespace


IntToVisibilityConverter.Convert Method

IntToVisibilityConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IntToVisibilityConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

IntToVisibilityConverter Class
VisualComponents.UX.Shared Namespace


IntToVisibilityConverter.ConvertBack Method

IntToVisibilityConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IntToVisibilityConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

IntToVisibilityConverter Class
VisualComponents.UX.Shared Namespace


INumericTextEditorTool Interface

Implement for commands that should be shown using texteditor tool for numeric values and display the unit in ribbon.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface INumericTextEditorTool : ITextEditorTool
public interface class INumericTextEditorTool : ITextEditorTool

The INumericTextEditorTool type exposes the following members.

Properties
 | Name | Description
Public property | EditAreaWidth | Specifies the width of the edit area, excluding the label. Default value is 100. (Inherited from ITextEditorTool.)
Public property | IsReadOnly | Specifies whether the user is allowed to modify the value in the editor. (Inherited from ITextEditorTool.)
Public property | Text | Gets or sets the value of the editor as text. (Inherited from ITextEditorTool.)
Public property | UnitSuffix | unit suffix to be shown beside the numeric value
Top
Methods
 | Name | Description
Public method | OnPreviewKeyDown | (Inherited from ITextEditorTool.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


INumericTextEditorTool Properties

The INumericTextEditorTool type exposes the following members.

Properties
 | Name | Description
Public property | EditAreaWidth | Specifies the width of the edit area, excluding the label. Default value is 100. (Inherited from ITextEditorTool.)
Public property | IsReadOnly | Specifies whether the user is allowed to modify the value in the editor. (Inherited from ITextEditorTool.)
Public property | Text | Gets or sets the value of the editor as text. (Inherited from ITextEditorTool.)
Public property | UnitSuffix | unit suffix to be shown beside the numeric value
Top
See Also

Reference

INumericTextEditorTool Interface
VisualComponents.UX.Shared Namespace


INumericTextEditorTool.UnitSuffix Property

INumericTextEditorToolUnitSuffix Property

unit suffix to be shown beside the numeric value

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string UnitSuffix { get; }
property String^ UnitSuffix {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

INumericTextEditorTool Interface
VisualComponents.UX.Shared Namespace


INumericTextEditorTool Methods

The INumericTextEditorTool type exposes the following members.

Methods
 | Name | Description
Public method | OnPreviewKeyDown | (Inherited from ITextEditorTool.)
Top
See Also

Reference

INumericTextEditorTool Interface
VisualComponents.UX.Shared Namespace


IOpenAndCreateProductEditorCommand Interface

Product type editor command that open and create new product type.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IOpenAndCreateProductEditorCommand : IActionItem,
    INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IOpenAndCreateProductEditorCommand : IActionItem,
    INotifyPropertyChangedEx, INotifyPropertyChanged

The IOpenAndCreateProductEditorCommand type exposes the following members.

Properties
 | Name | Description
Public property | CanExecute | (Inherited from IActionItem.)
Public property | Content | Item text/header. (Inherited from IActionItem.)
Public property | ContextFilter | Defines application contexts where action is available. (Inherited from IActionItem.)
Public property | ControlType | (Inherited from IActionItem.)
Public property | IconName | Gets the icon name. (Inherited from IActionItem.)
Public property | Id | (Inherited from IActionItem.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | RibbonId | Required for ribbon only, as all items in ribbon groups are required to have a unique id. (Inherited from IActionItem.)
Public property | SiteOrder | (Inherited from IActionItem.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from IActionItem.)
Public property | Visibility | Item Visibility (Inherited from IActionItem.)
Top
Methods
 | Name | Description
Public method | CreateAndShowProductEditor |
Public method | EvaluateCanExecute | (Inherited from IActionItem.)
Public method | Execute | Note: When executed from UI buttons we also call BeforeExecute(). Note: This is executed from both r-click and normal UI buttons. If need to distinguish between executing 'with command panel' and 'immediate execution' inherit from ActionItemT1 and define both Execute() and Execute(bool). Note: Some actions also use IsChecked to execute. They call BeforeExecute() manually. (Inherited from IActionItem.)
Public method | Execute(PropertyCollection) | (Inherited from IActionItem.)
Public method | Execute(SetupPythonActionMessage) | Obsolete. (Inherited from IActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from IActionItem.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from IActionItem.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IOpenAndCreateProductEditorCommand Properties

The IOpenAndCreateProductEditorCommand type exposes the following members.

Properties
 | Name | Description
Public property | CanExecute | (Inherited from IActionItem.)
Public property | Content | Item text/header. (Inherited from IActionItem.)
Public property | ContextFilter | Defines application contexts where action is available. (Inherited from IActionItem.)
Public property | ControlType | (Inherited from IActionItem.)
Public property | IconName | Gets the icon name. (Inherited from IActionItem.)
Public property | Id | (Inherited from IActionItem.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | RibbonId | Required for ribbon only, as all items in ribbon groups are required to have a unique id. (Inherited from IActionItem.)
Public property | SiteOrder | (Inherited from IActionItem.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from IActionItem.)
Public property | Visibility | Item Visibility (Inherited from IActionItem.)
Top
See Also

Reference

IOpenAndCreateProductEditorCommand Interface
VisualComponents.UX.Shared Namespace


IOpenAndCreateProductEditorCommand Methods

The IOpenAndCreateProductEditorCommand type exposes the following members.

Methods
 | Name | Description
Public method | CreateAndShowProductEditor |
Public method | EvaluateCanExecute | (Inherited from IActionItem.)
Public method | Execute | Note: When executed from UI buttons we also call BeforeExecute(). Note: This is executed from both r-click and normal UI buttons. If need to distinguish between executing 'with command panel' and 'immediate execution' inherit from ActionItemT1 and define both Execute() and Execute(bool). Note: Some actions also use IsChecked to execute. They call BeforeExecute() manually. (Inherited from IActionItem.)
Public method | Execute(PropertyCollection) | (Inherited from IActionItem.)
Public method | Execute(SetupPythonActionMessage) | Obsolete. (Inherited from IActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from IActionItem.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from IActionItem.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Top
See Also

Reference

IOpenAndCreateProductEditorCommand Interface
VisualComponents.UX.Shared Namespace


IOpenAndCreateProductEditorCommand.CreateAndShowProductEditor Method

IOpenAndCreateProductEditorCommandCreateAndShowProductEditor Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProductType CreateAndShowProductEditor()
IProductType^ CreateAndShowProductEditor()

Return Value

Type: IProductType

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IOpenAndCreateProductEditorCommand.CreateAndShowProductEditor"]

See Also

Reference

IOpenAndCreateProductEditorCommand Interface
VisualComponents.UX.Shared Namespace


IOpenAndCreateProductEditorCommand Events

The IOpenAndCreateProductEditorCommand type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IOpenAndCreateProductEditorCommand Interface
VisualComponents.UX.Shared Namespace


IOpenFileCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IOpenFileCommand
public interface class IOpenFileCommand

The IOpenFileCommand type exposes the following members.

Properties
 | Name | Description
Public property | ErrorCode | See OpenFileActionErrorCodes.
Public property | IsComponent |
Top
Methods
 | Name | Description
Public method | Execute |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IOpenFileCommand Properties

The IOpenFileCommand type exposes the following members.

Properties
 | Name | Description
Public property | ErrorCode | See OpenFileActionErrorCodes.
Public property | IsComponent |
Top
See Also

Reference

IOpenFileCommand Interface
VisualComponents.UX.Shared Namespace


IOpenFileCommand.ErrorCode Property

IOpenFileCommandErrorCode Property

See OpenFileActionErrorCodes.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int ErrorCode { get; }
property int ErrorCode {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IOpenFileCommand Interface
VisualComponents.UX.Shared Namespace


IOpenFileCommand.IsComponent Property

IOpenFileCommandIsComponent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsComponent { get; }
property bool IsComponent {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IOpenFileCommand Interface
VisualComponents.UX.Shared Namespace


IOpenFileCommand Methods

The IOpenFileCommand type exposes the following members.

Methods
 | Name | Description
Public method | Execute |
Top
See Also

Reference

IOpenFileCommand Interface
VisualComponents.UX.Shared Namespace


IOpenFileCommand.Execute Method

IOpenFileCommandExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Execute(
    string path,
    Nullable<Vector3> position,
    string defaultDirectory,
    bool appendToWorld
)
void Execute(
    String^ path,
    Nullable<Vector3> position,
    String^ defaultDirectory,
    bool appendToWorld
)

Parameters

path
Type: SystemString
position
Type: SystemNullableVector3
defaultDirectory
Type: SystemString
appendToWorld
Type: SystemBoolean
See Also

Reference

IOpenFileCommand Interface
VisualComponents.UX.Shared Namespace


IOpenSaveUserFolderSettings Interface

Keep recent user folder paths

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IOpenSaveUserFolderSettings
public interface class IOpenSaveUserFolderSettings

The IOpenSaveUserFolderSettings type exposes the following members.

Properties
 | Name | Description
Public property | ComponentFolder | Component folder path
Public property | ExportToAnimation | "Export to Animation (vcax)" folder path.
Public property | ExportToBitmap | "Export To Bitmap" folder path
Public property | ExportToPdf | "Export To PDF" folder path
Public property | ExportToVectorDrawing | "Export To Vector Drawing" folder path
Public property | ExportToVideoPlay | "Export To Video Play" folder path
Public property | LayoutFolder | Layout folder path
Public property | MyDocumentsFolder | "My Documents" folder
Public property | MyImageFolder | "My Image" folder
Public property | MyModelsFolder | "My Models" folder
Public property | MyVideosFolder | "My Videos" folder
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IOpenSaveUserFolderSettings Properties

The IOpenSaveUserFolderSettings type exposes the following members.

Properties
 | Name | Description
Public property | ComponentFolder | Component folder path
Public property | ExportToAnimation | "Export to Animation (vcax)" folder path.
Public property | ExportToBitmap | "Export To Bitmap" folder path
Public property | ExportToPdf | "Export To PDF" folder path
Public property | ExportToVectorDrawing | "Export To Vector Drawing" folder path
Public property | ExportToVideoPlay | "Export To Video Play" folder path
Public property | LayoutFolder | Layout folder path
Public property | MyDocumentsFolder | "My Documents" folder
Public property | MyImageFolder | "My Image" folder
Public property | MyModelsFolder | "My Models" folder
Public property | MyVideosFolder | "My Videos" folder
Top
See Also

Reference

IOpenSaveUserFolderSettings Interface
VisualComponents.UX.Shared Namespace


IOpenSaveUserFolderSettings.ComponentFolder Property

IOpenSaveUserFolderSettingsComponentFolder Property

Component folder path

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ComponentFolder { get; set; }
property String^ ComponentFolder {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IOpenSaveUserFolderSettings Interface
VisualComponents.UX.Shared Namespace


IOpenSaveUserFolderSettings.ExportToAnimation Property

IOpenSaveUserFolderSettingsExportToAnimation Property

"Export to Animation (vcax)" folder path.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ExportToAnimation { get; set; }
property String^ ExportToAnimation {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IOpenSaveUserFolderSettings Interface
VisualComponents.UX.Shared Namespace


IOpenSaveUserFolderSettings.ExportToBitmap Property

IOpenSaveUserFolderSettingsExportToBitmap Property

"Export To Bitmap" folder path

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ExportToBitmap { get; set; }
property String^ ExportToBitmap {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IOpenSaveUserFolderSettings Interface
VisualComponents.UX.Shared Namespace


IOpenSaveUserFolderSettings.ExportToPdf Property

IOpenSaveUserFolderSettingsExportToPdf Property

"Export To PDF" folder path

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ExportToPdf { get; set; }
property String^ ExportToPdf {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IOpenSaveUserFolderSettings Interface
VisualComponents.UX.Shared Namespace


IOpenSaveUserFolderSettings.ExportToVectorDrawing Property

IOpenSaveUserFolderSettingsExportToVectorDrawing Property

"Export To Vector Drawing" folder path

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ExportToVectorDrawing { get; set; }
property String^ ExportToVectorDrawing {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IOpenSaveUserFolderSettings Interface
VisualComponents.UX.Shared Namespace


IOpenSaveUserFolderSettings.ExportToVideoPlay Property

IOpenSaveUserFolderSettingsExportToVideoPlay Property

"Export To Video Play" folder path

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ExportToVideoPlay { get; set; }
property String^ ExportToVideoPlay {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IOpenSaveUserFolderSettings Interface
VisualComponents.UX.Shared Namespace


IOpenSaveUserFolderSettings.LayoutFolder Property

IOpenSaveUserFolderSettingsLayoutFolder Property

Layout folder path

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string LayoutFolder { get; set; }
property String^ LayoutFolder {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IOpenSaveUserFolderSettings Interface
VisualComponents.UX.Shared Namespace


IOpenSaveUserFolderSettings.MyDocumentsFolder Property

IOpenSaveUserFolderSettingsMyDocumentsFolder Property

"My Documents" folder

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string MyDocumentsFolder { get; }
property String^ MyDocumentsFolder {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IOpenSaveUserFolderSettings Interface
VisualComponents.UX.Shared Namespace


IOpenSaveUserFolderSettings.MyImageFolder Property

IOpenSaveUserFolderSettingsMyImageFolder Property

"My Image" folder

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string MyImageFolder { get; }
property String^ MyImageFolder {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IOpenSaveUserFolderSettings Interface
VisualComponents.UX.Shared Namespace


IOpenSaveUserFolderSettings.MyModelsFolder Property

IOpenSaveUserFolderSettingsMyModelsFolder Property

"My Models" folder

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string MyModelsFolder { get; }
property String^ MyModelsFolder {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IOpenSaveUserFolderSettings Interface
VisualComponents.UX.Shared Namespace


IOpenSaveUserFolderSettings.MyVideosFolder Property

IOpenSaveUserFolderSettingsMyVideosFolder Property

"My Videos" folder

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string MyVideosFolder { get; }
property String^ MyVideosFolder {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IOpenSaveUserFolderSettings Interface
VisualComponents.UX.Shared Namespace


IPaintColorMapsEditorViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPaintColorMapsEditorViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IPaintColorMapsEditorViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The IPaintColorMapsEditorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | ActualColor |
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | CurrentPaintMaterial |
Public property | CurrentPaintMaterialMaxThickness |
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | TexturesHeight |
Public property | TexturesWidth |
Public property | ThicknessVisualization |
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Public property | Visualization |
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | AddMaterialToComponent |
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | MapMaterialChanged |
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | RemovePaintFromAllComponents |
Public method | RemovePaintFromSelectedComponents |
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IPaintColorMapsEditorViewModel Properties

The IPaintColorMapsEditorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | ActualColor |
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | CurrentPaintMaterial |
Public property | CurrentPaintMaterialMaxThickness |
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | TexturesHeight |
Public property | TexturesWidth |
Public property | ThicknessVisualization |
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Public property | Visualization |
Top
See Also

Reference

IPaintColorMapsEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPaintColorMapsEditorViewModel.ActualColor Property

IPaintColorMapsEditorViewModelActualColor Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMaterial ActualColor { get; }
property IMaterial^ ActualColor {
    IMaterial^ get ();
}

Property Value

Type: IMaterial
See Also

Reference

IPaintColorMapsEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPaintColorMapsEditorViewModel.CurrentPaintMaterial Property

IPaintColorMapsEditorViewModelCurrentPaintMaterial Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMaterial CurrentPaintMaterial { get; }
property IMaterial^ CurrentPaintMaterial {
    IMaterial^ get ();
}

Property Value

Type: IMaterial
See Also

Reference

IPaintColorMapsEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPaintColorMapsEditorViewModel.CurrentPaintMaterialMaxThickness Property

IPaintColorMapsEditorViewModelCurrentPaintMaterialMaxThickness Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double CurrentPaintMaterialMaxThickness { get; }
property double CurrentPaintMaterialMaxThickness {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IPaintColorMapsEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPaintColorMapsEditorViewModel.TexturesHeight Property

IPaintColorMapsEditorViewModelTexturesHeight Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int TexturesHeight { get; }
property int TexturesHeight {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IPaintColorMapsEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPaintColorMapsEditorViewModel.TexturesWidth Property

IPaintColorMapsEditorViewModelTexturesWidth Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int TexturesWidth { get; }
property int TexturesWidth {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IPaintColorMapsEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPaintColorMapsEditorViewModel.ThicknessVisualization Property

IPaintColorMapsEditorViewModelThicknessVisualization Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IMaterial ThicknessVisualization { get; }
property IMaterial^ ThicknessVisualization {
    IMaterial^ get ();
}

Property Value

Type: IMaterial
See Also

Reference

IPaintColorMapsEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPaintColorMapsEditorViewModel.Visualization Property

IPaintColorMapsEditorViewModelVisualization Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
PaintColorVisualization Visualization { get; set; }
property PaintColorVisualization Visualization {
    PaintColorVisualization get ();
    void set (PaintColorVisualization value);
}

Property Value

Type: PaintColorVisualization
See Also

Reference

IPaintColorMapsEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPaintColorMapsEditorViewModel Methods

The IPaintColorMapsEditorViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | AddMaterialToComponent |
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | MapMaterialChanged |
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | RemovePaintFromAllComponents |
Public method | RemovePaintFromSelectedComponents |
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IPaintColorMapsEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPaintColorMapsEditorViewModel.AddMaterialToComponent Method

IPaintColorMapsEditorViewModelAddMaterialToComponent Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AddMaterialToComponent(
    ISimComponent component,
    bool resetTexture,
    bool render
)
void AddMaterialToComponent(
    ISimComponent^ component,
    bool resetTexture,
    bool render
)

Parameters

component
Type: VisualComponents.Create3DISimComponent
resetTexture
Type: SystemBoolean
render
Type: SystemBoolean
See Also

Reference

IPaintColorMapsEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPaintColorMapsEditorViewModel.MapMaterialChanged Method

IPaintColorMapsEditorViewModelMapMaterialChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void MapMaterialChanged()
void MapMaterialChanged()
See Also

Reference

IPaintColorMapsEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPaintColorMapsEditorViewModel.RemovePaintFromAllComponents Method

IPaintColorMapsEditorViewModelRemovePaintFromAllComponents Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RemovePaintFromAllComponents()
void RemovePaintFromAllComponents()
See Also

Reference

IPaintColorMapsEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPaintColorMapsEditorViewModel.RemovePaintFromSelectedComponents Method

IPaintColorMapsEditorViewModelRemovePaintFromSelectedComponents Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RemovePaintFromSelectedComponents()
void RemovePaintFromSelectedComponents()
See Also

Reference

IPaintColorMapsEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPaintColorMapsEditorViewModel Events

The IPaintColorMapsEditorViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IPaintColorMapsEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPathSmoothAction Interface

Instance of this interface is created with Get``1(String).

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPathSmoothAction
public interface class IPathSmoothAction

The IPathSmoothAction type exposes the following members.

Properties
 | Name | Description
Public property | ErrorCode | Error code after ApplyPathSmoothing or ApplyNozzleOffset.
Public property | InterpolateEuclidian |
Public property | InterpolateExternalAxes |
Public property | InterpolateInWorldSpace |
Public property | InterpolateOrientation |
Public property | InterpolateTravel |
Public property | InterpolateTravelClosest |
Public property | LockAxis | 0 - None, 1 - X, 2 - Y, 3 - Z
Public property | LockAxisCompensation |
Public property | NozzleOffset |
Public property | ReferencePointCount | This is calculated based on TargetFolder and ReferencePoint properties.
Public property | TargetFolder | Folder whose points are manipulated with ApplySmoothing.
Public property | TargetRobot | Robot from TargetTcp.
Public property | TargetStatement | Position statement whose pointions are manipulated with ApplySmoothing.
Public property | TargetTcp | Manipulation target passed to StartAction.
Top
Methods
 | Name | Description
Public method | ApplyNozzleOffset | Utility for updating point positions and orientations for spraying tool.
Public method | ApplyPathSmoothing | Utility for updating point orientations based on reference points
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IPathSmoothAction Properties

The IPathSmoothAction type exposes the following members.

Properties
 | Name | Description
Public property | ErrorCode | Error code after ApplyPathSmoothing or ApplyNozzleOffset.
Public property | InterpolateEuclidian |
Public property | InterpolateExternalAxes |
Public property | InterpolateInWorldSpace |
Public property | InterpolateOrientation |
Public property | InterpolateTravel |
Public property | InterpolateTravelClosest |
Public property | LockAxis | 0 - None, 1 - X, 2 - Y, 3 - Z
Public property | LockAxisCompensation |
Public property | NozzleOffset |
Public property | ReferencePointCount | This is calculated based on TargetFolder and ReferencePoint properties.
Public property | TargetFolder | Folder whose points are manipulated with ApplySmoothing.
Public property | TargetRobot | Robot from TargetTcp.
Public property | TargetStatement | Position statement whose pointions are manipulated with ApplySmoothing.
Public property | TargetTcp | Manipulation target passed to StartAction.
Top
See Also

Reference

IPathSmoothAction Interface
VisualComponents.UX.Shared Namespace


IPathSmoothAction.ErrorCode Property

IPathSmoothActionErrorCode Property

Error code after ApplyPathSmoothing or ApplyNozzleOffset.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
SmoothActionErrorCode ErrorCode { get; }
property SmoothActionErrorCode ErrorCode {
    SmoothActionErrorCode get ();
}

Property Value

Type: SmoothActionErrorCode
See Also

Reference

IPathSmoothAction Interface
VisualComponents.UX.Shared Namespace


IPathSmoothAction.InterpolateEuclidian Property

IPathSmoothActionInterpolateEuclidian Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool InterpolateEuclidian { get; set; }
property bool InterpolateEuclidian {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPathSmoothAction Interface
VisualComponents.UX.Shared Namespace


IPathSmoothAction.InterpolateExternalAxes Property

IPathSmoothActionInterpolateExternalAxes Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool InterpolateExternalAxes { get; set; }
property bool InterpolateExternalAxes {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPathSmoothAction Interface
VisualComponents.UX.Shared Namespace


IPathSmoothAction.InterpolateInWorldSpace Property

IPathSmoothActionInterpolateInWorldSpace Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool InterpolateInWorldSpace { get; set; }
property bool InterpolateInWorldSpace {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPathSmoothAction Interface
VisualComponents.UX.Shared Namespace


IPathSmoothAction.InterpolateOrientation Property

IPathSmoothActionInterpolateOrientation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool InterpolateOrientation { get; set; }
property bool InterpolateOrientation {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPathSmoothAction Interface
VisualComponents.UX.Shared Namespace


IPathSmoothAction.InterpolateTravel Property

IPathSmoothActionInterpolateTravel Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool InterpolateTravel { get; set; }
property bool InterpolateTravel {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPathSmoothAction Interface
VisualComponents.UX.Shared Namespace


IPathSmoothAction.InterpolateTravelClosest Property

IPathSmoothActionInterpolateTravelClosest Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool InterpolateTravelClosest { get; set; }
property bool InterpolateTravelClosest {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPathSmoothAction Interface
VisualComponents.UX.Shared Namespace


IPathSmoothAction.LockAxis Property

IPathSmoothActionLockAxis Property

0 - None, 1 - X, 2 - Y, 3 - Z

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int LockAxis { get; set; }
property int LockAxis {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IPathSmoothAction Interface
VisualComponents.UX.Shared Namespace


IPathSmoothAction.LockAxisCompensation Property

IPathSmoothActionLockAxisCompensation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool LockAxisCompensation { get; set; }
property bool LockAxisCompensation {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPathSmoothAction Interface
VisualComponents.UX.Shared Namespace


IPathSmoothAction.NozzleOffset Property

IPathSmoothActionNozzleOffset Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double NozzleOffset { get; set; }
property double NozzleOffset {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IPathSmoothAction Interface
VisualComponents.UX.Shared Namespace


IPathSmoothAction.ReferencePointCount Property

IPathSmoothActionReferencePointCount Property

This is calculated based on TargetFolder and ReferencePoint properties.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int ReferencePointCount { get; }
property int ReferencePointCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IPathSmoothAction Interface
VisualComponents.UX.Shared Namespace


IPathSmoothAction.TargetFolder Property

IPathSmoothActionTargetFolder Property

Folder whose points are manipulated with ApplySmoothing.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatementScope TargetFolder { get; set; }
property IStatementScope^ TargetFolder {
    IStatementScope^ get ();
    void set (IStatementScope^ value);
}

Property Value

Type: IStatementScope
See Also

Reference

IPathSmoothAction Interface
VisualComponents.UX.Shared Namespace


IPathSmoothAction.TargetRobot Property

IPathSmoothActionTargetRobot Property

Robot from TargetTcp.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobot TargetRobot { get; }
property IRobot^ TargetRobot {
    IRobot^ get ();
}

Property Value

Type: IRobot
See Also

Reference

IPathSmoothAction Interface
VisualComponents.UX.Shared Namespace


IPathSmoothAction.TargetStatement Property

IPathSmoothActionTargetStatement Property

Position statement whose pointions are manipulated with ApplySmoothing.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPositionStatement TargetStatement { get; set; }
property IPositionStatement^ TargetStatement {
    IPositionStatement^ get ();
    void set (IPositionStatement^ value);
}

Property Value

Type: IPositionStatement
See Also

Reference

IPathSmoothAction Interface
VisualComponents.UX.Shared Namespace


IPathSmoothAction.TargetTcp Property

IPathSmoothActionTargetTcp Property

Manipulation target passed to StartAction.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotTcpManipulationTarget TargetTcp { get; set; }
property IRobotTcpManipulationTarget^ TargetTcp {
    IRobotTcpManipulationTarget^ get ();
    void set (IRobotTcpManipulationTarget^ value);
}

Property Value

Type: IRobotTcpManipulationTarget
See Also

Reference

IPathSmoothAction Interface
VisualComponents.UX.Shared Namespace


IPathSmoothAction Methods

The IPathSmoothAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyNozzleOffset | Utility for updating point positions and orientations for spraying tool.
Public method | ApplyPathSmoothing | Utility for updating point orientations based on reference points
Top
See Also

Reference

IPathSmoothAction Interface
VisualComponents.UX.Shared Namespace


IPathSmoothAction.ApplyNozzleOffset Method

IPathSmoothActionApplyNozzleOffset Method

Utility for updating point positions and orientations for spraying tool.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ApplyNozzleOffset()
bool ApplyNozzleOffset()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IPathSmoothAction.ApplyNozzleOffset"]

See Also

Reference

IPathSmoothAction Interface
VisualComponents.UX.Shared Namespace


IPathSmoothAction.ApplyPathSmoothing Method

IPathSmoothActionApplyPathSmoothing Method

Utility for updating point orientations based on reference points

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ApplyPathSmoothing()
bool ApplyPathSmoothing()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IPathSmoothAction.ApplyPathSmoothing"]

See Also

Reference

IPathSmoothAction Interface
VisualComponents.UX.Shared Namespace


IPathSmoothCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPathSmoothCommand
public interface class IPathSmoothCommand

The IPathSmoothCommand type exposes the following members.

Methods
 | Name | Description
Public method | ExecuteNozzleOffsetting |
Public method | ExecuteSmoothing |
Public method | ReverseDirection |
Public method | UpdateLabelVisibility |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IPathSmoothCommand Methods

The IPathSmoothCommand type exposes the following members.

Methods
 | Name | Description
Public method | ExecuteNozzleOffsetting |
Public method | ExecuteSmoothing |
Public method | ReverseDirection |
Public method | UpdateLabelVisibility |
Top
See Also

Reference

IPathSmoothCommand Interface
VisualComponents.UX.Shared Namespace


IPathSmoothCommand.ExecuteNozzleOffsetting Method

IPathSmoothCommandExecuteNozzleOffsetting Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ExecuteNozzleOffsetting(
    IStatementScope folder
)
void ExecuteNozzleOffsetting(
    IStatementScope^ folder
)

Parameters

folder
Type: VisualComponents.Create3DIStatementScope
See Also

Reference

IPathSmoothCommand Interface
VisualComponents.UX.Shared Namespace


IPathSmoothCommand.ExecuteSmoothing Method

IPathSmoothCommandExecuteSmoothing Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ExecuteSmoothing(
    IStatementScope folder
)
void ExecuteSmoothing(
    IStatementScope^ folder
)

Parameters

folder
Type: VisualComponents.Create3DIStatementScope
See Also

Reference

IPathSmoothCommand Interface
VisualComponents.UX.Shared Namespace


IPathSmoothCommand.ReverseDirection Method

IPathSmoothCommandReverseDirection Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ReverseDirection(
    IStatementScope folder
)
void ReverseDirection(
    IStatementScope^ folder
)

Parameters

folder
Type: VisualComponents.Create3DIStatementScope
See Also

Reference

IPathSmoothCommand Interface
VisualComponents.UX.Shared Namespace


IPathSmoothCommand.UpdateLabelVisibility Method

IPathSmoothCommandUpdateLabelVisibility Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateLabelVisibility(
    IStatementScope folder
)
void UpdateLabelVisibility(
    IStatementScope^ folder
)

Parameters

folder
Type: VisualComponents.Create3DIStatementScope
See Also

Reference

IPathSmoothCommand Interface
VisualComponents.UX.Shared Namespace


IPathTeachAction Interface

Instance of this interface is created with Get``1(String).

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPathTeachAction : ICommandPanelAction
public interface class IPathTeachAction : ICommandPanelAction

The IPathTeachAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties |
Public property | AlignSecondary | 0 Current Pose, 1 Curve
Public property | AlignToAxis | Axis in generated path: 0 +Z, 1 -Z, 2 +Y, 3 -Y, 4 +X, 5 -X 0 "Surface Normal", 1 "Inverse Surface Normal", 2 "Surface Side", 3 "Inverse Surface Side", 4 "Movement Direction", 5 "Inverse Movement Direction"
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | ApproachAxis | Axis in robot TCP: 0 +Z, 1 -Z, 2 +Y, 3 -Y, 4 +X, 5 -X
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | InvertZ | Deprecated
Public property | MotionSpeed |
Public property | ResultsInBaseSpace |
Public property | SelectedBase |
Public property | SelectedPathPoints | Final output of this action.
Public property | SelectedPathSegments |
Public property | SelectedTool |
Public property | TargetRobot |
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Top
Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | DeleteLast |
Public method | RefreshAction |
Public method | ReversePath |
Public method | StartAction(EventHandlerResultCompletionEventArgs) | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Public method | StartAction(IRobot, Boolean, EventHandlerResultCompletionEventArgs) | Obsolete.
Public method | StopAction | Stop action.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IPathTeachAction Properties

The IPathTeachAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties |
Public property | AlignSecondary | 0 Current Pose, 1 Curve
Public property | AlignToAxis | Axis in generated path: 0 +Z, 1 -Z, 2 +Y, 3 -Y, 4 +X, 5 -X 0 "Surface Normal", 1 "Inverse Surface Normal", 2 "Surface Side", 3 "Inverse Surface Side", 4 "Movement Direction", 5 "Inverse Movement Direction"
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | ApproachAxis | Axis in robot TCP: 0 +Z, 1 -Z, 2 +Y, 3 -Y, 4 +X, 5 -X
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | InvertZ | Deprecated
Public property | MotionSpeed |
Public property | ResultsInBaseSpace |
Public property | SelectedBase |
Public property | SelectedPathPoints | Final output of this action.
Public property | SelectedPathSegments |
Public property | SelectedTool |
Public property | TargetRobot |
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

IPathTeachAction Interface
VisualComponents.UX.Shared Namespace


IPathTeachAction.ActionProperties Property

IPathTeachActionActionProperties Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
List<IProperty> ActionProperties { get; }
property List<IProperty^>^ ActionProperties {
    List<IProperty^>^ get ();
}

Property Value

Type: ListIProperty

Implements

ICommandPanelActionActionProperties
See Also

Reference

IPathTeachAction Interface
VisualComponents.UX.Shared Namespace


IPathTeachAction.AlignSecondary Property

IPathTeachActionAlignSecondary Property

0 Current Pose, 1 Curve

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int AlignSecondary { get; set; }
property int AlignSecondary {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IPathTeachAction Interface
VisualComponents.UX.Shared Namespace


IPathTeachAction.AlignToAxis Property

IPathTeachActionAlignToAxis Property

Axis in generated path: 0 +Z, 1 -Z, 2 +Y, 3 -Y, 4 +X, 5 -X 0 "Surface Normal", 1 "Inverse Surface Normal", 2 "Surface Side", 3 "Inverse Surface Side", 4 "Movement Direction", 5 "Inverse Movement Direction"

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int AlignToAxis { get; set; }
property int AlignToAxis {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IPathTeachAction Interface
VisualComponents.UX.Shared Namespace


IPathTeachAction.ApproachAxis Property

IPathTeachActionApproachAxis Property

Axis in robot TCP: 0 +Z, 1 -Z, 2 +Y, 3 -Y, 4 +X, 5 -X

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int ApproachAxis { get; set; }
property int ApproachAxis {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IPathTeachAction Interface
VisualComponents.UX.Shared Namespace


IPathTeachAction.InvertZ Property

IPathTeachActionInvertZ Property

Deprecated

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool InvertZ { get; set; }
property bool InvertZ {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPathTeachAction Interface
VisualComponents.UX.Shared Namespace


IPathTeachAction.MotionSpeed Property

IPathTeachActionMotionSpeed Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double MotionSpeed { get; set; }
property double MotionSpeed {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IPathTeachAction Interface
VisualComponents.UX.Shared Namespace


IPathTeachAction.ResultsInBaseSpace Property

IPathTeachActionResultsInBaseSpace Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ResultsInBaseSpace { get; set; }
property bool ResultsInBaseSpace {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPathTeachAction Interface
VisualComponents.UX.Shared Namespace


IPathTeachAction.SelectedBase Property

IPathTeachActionSelectedBase Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotFrame SelectedBase { get; set; }
property IRobotFrame^ SelectedBase {
    IRobotFrame^ get ();
    void set (IRobotFrame^ value);
}

Property Value

Type: IRobotFrame
See Also

Reference

IPathTeachAction Interface
VisualComponents.UX.Shared Namespace


IPathTeachAction.SelectedPathPoints Property

IPathTeachActionSelectedPathPoints Property

Final output of this action.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
List<PathTeachPoint> SelectedPathPoints { get; }
property List<PathTeachPoint>^ SelectedPathPoints {
    List<PathTeachPoint>^ get ();
}

Property Value

Type: ListPathTeachPoint
See Also

Reference

IPathTeachAction Interface
VisualComponents.UX.Shared Namespace


IPathTeachAction.SelectedPathSegments Property

IPathTeachActionSelectedPathSegments Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
List<PathTeachSegment> SelectedPathSegments { get; }
property List<PathTeachSegment^>^ SelectedPathSegments {
    List<PathTeachSegment^>^ get ();
}

Property Value

Type: ListPathTeachSegment
See Also

Reference

IPathTeachAction Interface
VisualComponents.UX.Shared Namespace


IPathTeachAction.SelectedTool Property

IPathTeachActionSelectedTool Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotFrame SelectedTool { get; set; }
property IRobotFrame^ SelectedTool {
    IRobotFrame^ get ();
    void set (IRobotFrame^ value);
}

Property Value

Type: IRobotFrame
See Also

Reference

IPathTeachAction Interface
VisualComponents.UX.Shared Namespace


IPathTeachAction.TargetRobot Property

IPathTeachActionTargetRobot Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobot TargetRobot { get; set; }
property IRobot^ TargetRobot {
    IRobot^ get ();
    void set (IRobot^ value);
}

Property Value

Type: IRobot
See Also

Reference

IPathTeachAction Interface
VisualComponents.UX.Shared Namespace


IPathTeachAction Methods

The IPathTeachAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | DeleteLast |
Public method | RefreshAction |
Public method | ReversePath |
Public method | StartAction(EventHandlerResultCompletionEventArgs) | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Public method | StartAction(IRobot, Boolean, EventHandlerResultCompletionEventArgs) | Obsolete.
Public method | StopAction | Stop action.
Top
See Also

Reference

IPathTeachAction Interface
VisualComponents.UX.Shared Namespace


IPathTeachAction.DeleteLast Method

IPathTeachActionDeleteLast Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteLast()
void DeleteLast()
See Also

Reference

IPathTeachAction Interface
VisualComponents.UX.Shared Namespace


IPathTeachAction.RefreshAction Method

IPathTeachActionRefreshAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RefreshAction(
    bool affectsAlreadySelected
)
void RefreshAction(
    bool affectsAlreadySelected
)

Parameters

affectsAlreadySelected
Type: SystemBoolean
See Also

Reference

IPathTeachAction Interface
VisualComponents.UX.Shared Namespace


IPathTeachAction.ReversePath Method

IPathTeachActionReversePath Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ReversePath()
void ReversePath()
See Also

Reference

IPathTeachAction Interface
VisualComponents.UX.Shared Namespace


IPathTeachAction.StartAction Method

IPathTeachActionStartAction Method

Overload List
 | Name | Description
Public method | StartAction(EventHandlerResultCompletionEventArgs) | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Public method | StartAction(IRobot, Boolean, EventHandlerResultCompletionEventArgs) | Obsolete.
Top
See Also

Reference

IPathTeachAction Interface
VisualComponents.UX.Shared Namespace


IPathTeachAction.StartAction Method (IRobot, Boolean, EventHandler(ResultCompletionEventArgs))

IPathTeachActionStartAction Method (IRobot, Boolean, EventHandlerResultCompletionEventArgs)

Note: This API is now obsolete.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Use StartAction(completed) instead.")]
void StartAction(
    IRobot robot,
    bool resultsInBaseSpace,
    EventHandler<ResultCompletionEventArgs> completed
)
[ObsoleteAttribute(L"Use StartAction(completed) instead.")]
void StartAction(
    IRobot^ robot,
    bool resultsInBaseSpace,
    EventHandler<ResultCompletionEventArgs^>^ completed
)

Parameters

robot
Type: VisualComponents.Create3DIRobot
resultsInBaseSpace
Type: SystemBoolean
completed
Type: SystemEventHandlerResultCompletionEventArgs
See Also

Reference

IPathTeachAction Interface
StartAction Overload
VisualComponents.UX.Shared Namespace


IPathTeachAction.StopAction Method

IPathTeachActionStopAction Method

Stop action.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StopAction()
void StopAction()
See Also

Reference

IPathTeachAction Interface
VisualComponents.UX.Shared Namespace


IPathTeachViewModel Interface

Path teach view model interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPathTeachViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IPathTeachViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The IPathTeachViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | NotifyOptionsChanged |
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IPathTeachViewModel Properties

The IPathTeachViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
See Also

Reference

IPathTeachViewModel Interface
VisualComponents.UX.Shared Namespace


IPathTeachViewModel Methods

The IPathTeachViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | NotifyOptionsChanged |
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IPathTeachViewModel Interface
VisualComponents.UX.Shared Namespace


IPathTeachViewModel.NotifyOptionsChanged Method

IPathTeachViewModelNotifyOptionsChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void NotifyOptionsChanged()
void NotifyOptionsChanged()
See Also

Reference

IPathTeachViewModel Interface
VisualComponents.UX.Shared Namespace


IPathTeachViewModel Events

The IPathTeachViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IPathTeachViewModel Interface
VisualComponents.UX.Shared Namespace


IPatternEditorViewModel Interface

Pattern editor.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPatternEditorViewModel : IDockableScreen,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged, IViewportContainer
public interface class IPatternEditorViewModel : IDockableScreen,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged, IViewportContainer

The IPatternEditorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActiveSlot |
Public property | ActiveStep |
Public property | ContextFilter | Gets or sets the context filter. The context defines one or more contexts where the panel is visible. (Inherited from IDockableScreen.)
Public property | DesiredPanePosition | Gets the desired pane position. If multiple panes are added, panes are ordered using this property. (Inherited from IDockableScreen.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | Height | Gets the Height of the pane. (Inherited from IDockableScreen.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsPinned | Gets or sets a Boolean value that indicates if the pane is pinned. (Inherited from IDockableScreen.)
Public property | IsSelected | Gets or sets a boolean value that indicates if the pane is selected in TabGroupPane (Inherited from IDockableScreen.)
Public property | IsVisible | Gets or sets a boolean value that indicates if the pane is visible (Inherited from IDockableScreen.)
Public property | PanelId | Gets the panel ID (Inherited from IDockableScreen.)
Public property | PaneLocation | Gets the desired panel location DesiredPaneLocation (Inherited from IDockableScreen.)
Public property | PaneOrientation | Gets the pane orientation (Inherited from IDockableScreen.)
Public property | PatternVisualizationService |
Public property | SelectedSlotVisualization |
Public property | SplitPaneId | Gets the split pane id. By default all panes within panel location use same split panel. Multiple split panels can be created by defining new split pane ids. (Inherited from IDockableScreen.)
 | TabGroupId | Gets the pane tab group id. Panes are splitted and ordered to different tabs within the splitpane based on TabGroupId. (Inherited from IDockableScreen.)
Public property | Width | Gets the Width of the pane. (Inherited from IDockableScreen.)
Public property | Viewport | Reference to the child IViewport. (Inherited from IViewportContainer.)
Public property | ViewportId | String key which can be used to identify UX sites in the application config, etc. (Inherited from IViewportContainer.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | ActivateSlot |
Public method | ActivateStep |
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Public method | VisualizeActiveStep |
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | ActiveSlotChanged | This event is fired on active slot change.
Public event | ActiveStepChanged | This event is fired on active step changes.
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Closed | This event is fired on pattern editor view port is closed.
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IPatternEditorViewModel Properties

The IPatternEditorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActiveSlot |
Public property | ActiveStep |
Public property | ContextFilter | Gets or sets the context filter. The context defines one or more contexts where the panel is visible. (Inherited from IDockableScreen.)
Public property | DesiredPanePosition | Gets the desired pane position. If multiple panes are added, panes are ordered using this property. (Inherited from IDockableScreen.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | Height | Gets the Height of the pane. (Inherited from IDockableScreen.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsPinned | Gets or sets a Boolean value that indicates if the pane is pinned. (Inherited from IDockableScreen.)
Public property | IsSelected | Gets or sets a boolean value that indicates if the pane is selected in TabGroupPane (Inherited from IDockableScreen.)
Public property | IsVisible | Gets or sets a boolean value that indicates if the pane is visible (Inherited from IDockableScreen.)
Public property | PanelId | Gets the panel ID (Inherited from IDockableScreen.)
Public property | PaneLocation | Gets the desired panel location DesiredPaneLocation (Inherited from IDockableScreen.)
Public property | PaneOrientation | Gets the pane orientation (Inherited from IDockableScreen.)
Public property | PatternVisualizationService |
Public property | SelectedSlotVisualization |
Public property | SplitPaneId | Gets the split pane id. By default all panes within panel location use same split panel. Multiple split panels can be created by defining new split pane ids. (Inherited from IDockableScreen.)
 | TabGroupId | Gets the pane tab group id. Panes are splitted and ordered to different tabs within the splitpane based on TabGroupId. (Inherited from IDockableScreen.)
Public property | Width | Gets the Width of the pane. (Inherited from IDockableScreen.)
Public property | Viewport | Reference to the child IViewport. (Inherited from IViewportContainer.)
Public property | ViewportId | String key which can be used to identify UX sites in the application config, etc. (Inherited from IViewportContainer.)
Top
See Also

Reference

IPatternEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPatternEditorViewModel.ActiveSlot Property

IPatternEditorViewModelActiveSlot Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IAssemblyPatternSlot ActiveSlot { get; }
property IAssemblyPatternSlot^ ActiveSlot {
    IAssemblyPatternSlot^ get ();
}

Property Value

Type: IAssemblyPatternSlot
See Also

Reference

IPatternEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPatternEditorViewModel.ActiveStep Property

IPatternEditorViewModelActiveStep Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IAssemblyStep ActiveStep { get; }
property IAssemblyStep^ ActiveStep {
    IAssemblyStep^ get ();
}

Property Value

Type: IAssemblyStep
See Also

Reference

IPatternEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPatternEditorViewModel.PatternVisualizationService Property

IPatternEditorViewModelPatternVisualizationService Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IAssemblyPatternVisualizationService PatternVisualizationService { get; }
property IAssemblyPatternVisualizationService^ PatternVisualizationService {
    IAssemblyPatternVisualizationService^ get ();
}

Property Value

Type: IAssemblyPatternVisualizationService
See Also

Reference

IPatternEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPatternEditorViewModel.SelectedSlotVisualization Property

IPatternEditorViewModelSelectedSlotVisualization Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IAssemblyPatternSlotVisualization SelectedSlotVisualization { get; }
property IAssemblyPatternSlotVisualization^ SelectedSlotVisualization {
    IAssemblyPatternSlotVisualization^ get ();
}

Property Value

Type: IAssemblyPatternSlotVisualization
See Also

Reference

IPatternEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPatternEditorViewModel Methods

The IPatternEditorViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | ActivateSlot |
Public method | ActivateStep |
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Public method | VisualizeActiveStep |
Top
See Also

Reference

IPatternEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPatternEditorViewModel.ActivateSlot Method

IPatternEditorViewModelActivateSlot Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ActivateSlot(
    IAssemblyPatternSlot assemblyStep
)
void ActivateSlot(
    IAssemblyPatternSlot^ assemblyStep
)

Parameters

assemblyStep
Type: IAssemblyPatternSlot
See Also

Reference

IPatternEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPatternEditorViewModel.ActivateStep Method

IPatternEditorViewModelActivateStep Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ActivateStep(
    IAssemblyStep assemblyStep
)
void ActivateStep(
    IAssemblyStep^ assemblyStep
)

Parameters

assemblyStep
Type: IAssemblyStep
See Also

Reference

IPatternEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPatternEditorViewModel.VisualizeActiveStep Method

IPatternEditorViewModelVisualizeActiveStep Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void VisualizeActiveStep()
void VisualizeActiveStep()
See Also

Reference

IPatternEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPatternEditorViewModel Events

The IPatternEditorViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | ActiveSlotChanged | This event is fired on active slot change.
Public event | ActiveStepChanged | This event is fired on active step changes.
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Closed | This event is fired on pattern editor view port is closed.
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IPatternEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPatternEditorViewModel.ActiveSlotChanged Event

IPatternEditorViewModelActiveSlotChanged Event

This event is fired on active slot change.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ActiveAssemblySlotChangeEventArgs> ActiveSlotChanged
 event EventHandler<ActiveAssemblySlotChangeEventArgs^>^ ActiveSlotChanged {
    void add (EventHandler<ActiveAssemblySlotChangeEventArgs^>^ value);
    void remove (EventHandler<ActiveAssemblySlotChangeEventArgs^>^ value);
}

Value

Type: SystemEventHandlerActiveAssemblySlotChangeEventArgs
See Also

Reference

IPatternEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPatternEditorViewModel.ActiveStepChanged Event

IPatternEditorViewModelActiveStepChanged Event

This event is fired on active step changes.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ActiveAssemblyStepChangeEventArgs> ActiveStepChanged
 event EventHandler<ActiveAssemblyStepChangeEventArgs^>^ ActiveStepChanged {
    void add (EventHandler<ActiveAssemblyStepChangeEventArgs^>^ value);
    void remove (EventHandler<ActiveAssemblyStepChangeEventArgs^>^ value);
}

Value

Type: SystemEventHandlerActiveAssemblyStepChangeEventArgs
See Also

Reference

IPatternEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPatternEditorViewModel.Closed Event

IPatternEditorViewModelClosed Event

This event is fired on pattern editor view port is closed.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<PatternEditorClosedEventArgs> Closed
 event EventHandler<PatternEditorClosedEventArgs^>^ Closed {
    void add (EventHandler<PatternEditorClosedEventArgs^>^ value);
    void remove (EventHandler<PatternEditorClosedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerPatternEditorClosedEventArgs
See Also

Reference

IPatternEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPdfRecordSetting Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPdfRecordSetting : IRecordSetting
public interface class IPdfRecordSetting : IRecordSetting

The IPdfRecordSetting type exposes the following members.

Methods
 | Name | Description
Public method | ActivateSetting | (Inherited from IRecordSetting.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IPdfRecordSetting Methods

The IPdfRecordSetting type exposes the following members.

Methods
 | Name | Description
Public method | ActivateSetting | (Inherited from IRecordSetting.)
Top
See Also

Reference

IPdfRecordSetting Interface
VisualComponents.UX.Shared Namespace


IPinManipulator Interface

Terminology: Pin - a "control point" or "constraint point", typically used to define rope's position and attachments.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPinManipulator
public interface class IPinManipulator
See Also

Reference

VisualComponents.UX.Shared Namespace


IPlaceHolderCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPlaceHolderCommand : IActionItem,
    INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IPlaceHolderCommand : IActionItem,
    INotifyPropertyChangedEx, INotifyPropertyChanged

The IPlaceHolderCommand type exposes the following members.

Properties
 | Name | Description
Public property | CanExecute | (Inherited from IActionItem.)
Public property | Content | Item text/header. (Inherited from IActionItem.)
Public property | ContextFilter | Defines application contexts where action is available. (Inherited from IActionItem.)
Public property | ControlType | (Inherited from IActionItem.)
Public property | IconName | Gets the icon name. (Inherited from IActionItem.)
Public property | Id | (Inherited from IActionItem.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | RibbonId | Required for ribbon only, as all items in ribbon groups are required to have a unique id. (Inherited from IActionItem.)
Public property | SiteOrder | (Inherited from IActionItem.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from IActionItem.)
Public property | Visibility | Item Visibility (Inherited from IActionItem.)
Top
Methods
 | Name | Description
Public method | EvaluateCanExecute | (Inherited from IActionItem.)
Public method | Execute | Note: When executed from UI buttons we also call BeforeExecute(). Note: This is executed from both r-click and normal UI buttons. If need to distinguish between executing 'with command panel' and 'immediate execution' inherit from ActionItemT1 and define both Execute() and Execute(bool). Note: Some actions also use IsChecked to execute. They call BeforeExecute() manually. (Inherited from IActionItem.)
Public method | Execute(PropertyCollection) | (Inherited from IActionItem.)
Public method | Execute(SetupPythonActionMessage) | Obsolete. (Inherited from IActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from IActionItem.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from IActionItem.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IPlaceHolderCommand Properties

The IPlaceHolderCommand type exposes the following members.

Properties
 | Name | Description
Public property | CanExecute | (Inherited from IActionItem.)
Public property | Content | Item text/header. (Inherited from IActionItem.)
Public property | ContextFilter | Defines application contexts where action is available. (Inherited from IActionItem.)
Public property | ControlType | (Inherited from IActionItem.)
Public property | IconName | Gets the icon name. (Inherited from IActionItem.)
Public property | Id | (Inherited from IActionItem.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | RibbonId | Required for ribbon only, as all items in ribbon groups are required to have a unique id. (Inherited from IActionItem.)
Public property | SiteOrder | (Inherited from IActionItem.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from IActionItem.)
Public property | Visibility | Item Visibility (Inherited from IActionItem.)
Top
See Also

Reference

IPlaceHolderCommand Interface
VisualComponents.UX.Shared Namespace


IPlaceHolderCommand Methods

The IPlaceHolderCommand type exposes the following members.

Methods
 | Name | Description
Public method | EvaluateCanExecute | (Inherited from IActionItem.)
Public method | Execute | Note: When executed from UI buttons we also call BeforeExecute(). Note: This is executed from both r-click and normal UI buttons. If need to distinguish between executing 'with command panel' and 'immediate execution' inherit from ActionItemT1 and define both Execute() and Execute(bool). Note: Some actions also use IsChecked to execute. They call BeforeExecute() manually. (Inherited from IActionItem.)
Public method | Execute(PropertyCollection) | (Inherited from IActionItem.)
Public method | Execute(SetupPythonActionMessage) | Obsolete. (Inherited from IActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from IActionItem.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from IActionItem.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Top
See Also

Reference

IPlaceHolderCommand Interface
VisualComponents.UX.Shared Namespace


IPlaceHolderCommand Events

The IPlaceHolderCommand type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IPlaceHolderCommand Interface
VisualComponents.UX.Shared Namespace


IPlugin Interface

Marker interface for UX Plugins

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPlugin
public interface class IPlugin

The IPlugin type exposes the following members.

Methods
 | Name | Description
Public method | Exit | Exit is called before application shutdown.
Public method | Initialize | Plugin initialization is called last during application startup. All application infrastructure functions are ready at this stage. Relative call order of multiple plugins is undefined.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IPlugin Methods

The IPlugin type exposes the following members.

Methods
 | Name | Description
Public method | Exit | Exit is called before application shutdown.
Public method | Initialize | Plugin initialization is called last during application startup. All application infrastructure functions are ready at this stage. Relative call order of multiple plugins is undefined.
Top
See Also

Reference

IPlugin Interface
VisualComponents.UX.Shared Namespace


IPlugin.Exit Method

IPluginExit Method

Exit is called before application shutdown.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Exit()
void Exit()
See Also

Reference

IPlugin Interface
VisualComponents.UX.Shared Namespace


IPlugin.Initialize Method

IPluginInitialize Method

Plugin initialization is called last during application startup. All application infrastructure functions are ready at this stage. Relative call order of multiple plugins is undefined.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Initialize()
void Initialize()
See Also

Reference

IPlugin Interface
VisualComponents.UX.Shared Namespace


IPrepareForPaintingViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPrepareForPaintingViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IPrepareForPaintingViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The IPrepareForPaintingViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | MaxEdgeLength |
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IPrepareForPaintingViewModel Properties

The IPrepareForPaintingViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | MaxEdgeLength |
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
See Also

Reference

IPrepareForPaintingViewModel Interface
VisualComponents.UX.Shared Namespace


IPrepareForPaintingViewModel.MaxEdgeLength Property

IPrepareForPaintingViewModelMaxEdgeLength Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int MaxEdgeLength { get; set; }
property int MaxEdgeLength {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IPrepareForPaintingViewModel Interface
VisualComponents.UX.Shared Namespace


IPrepareForPaintingViewModel Methods

The IPrepareForPaintingViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IPrepareForPaintingViewModel Interface
VisualComponents.UX.Shared Namespace


IPrepareForPaintingViewModel Events

The IPrepareForPaintingViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IPrepareForPaintingViewModel Interface
VisualComponents.UX.Shared Namespace


IPrintContent Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPrintContent : IScreen,
    IHaveDisplayName, IActivate, IDeactivate, IGuardClose, IClose,
    INotifyPropertyChangedEx, INotifyPropertyChanged, IAreaSelectionSnap
public interface class IPrintContent : IScreen,
    IHaveDisplayName, IActivate, IDeactivate, IGuardClose, IClose,
    INotifyPropertyChangedEx, INotifyPropertyChanged, IAreaSelectionSnap

The IPrintContent type exposes the following members.

Properties
 | Name | Description
Public property | AreaSelectionReferencePointDown | Reference point used if area selection is selected when mouse button down (Inherited from IAreaSelectionSnap.)
Public property | AreaSelectionReferencePointMove | Reference point used if area selection is selected when mouse is moving (Inherited from IAreaSelectionSnap.)
Public property | AreaSelectionReferencePointUp | Reference point used if area selection is selected when mouse button up (Inherited from IAreaSelectionSnap.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | InAreaSelection | Indicates if the object is awaiting for area selection to be completed (Inherited from IAreaSelectionSnap.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Close | Close and free generated images
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | Reload | Reload the Report preview
Public method | SwitchAway | Todo
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IPrintContent Properties

The IPrintContent type exposes the following members.

Properties
 | Name | Description
Public property | AreaSelectionReferencePointDown | Reference point used if area selection is selected when mouse button down (Inherited from IAreaSelectionSnap.)
Public property | AreaSelectionReferencePointMove | Reference point used if area selection is selected when mouse is moving (Inherited from IAreaSelectionSnap.)
Public property | AreaSelectionReferencePointUp | Reference point used if area selection is selected when mouse button up (Inherited from IAreaSelectionSnap.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | InAreaSelection | Indicates if the object is awaiting for area selection to be completed (Inherited from IAreaSelectionSnap.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Top
See Also

Reference

IPrintContent Interface
VisualComponents.UX.Shared Namespace


IPrintContent Methods

The IPrintContent type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Close | Close and free generated images
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | Reload | Reload the Report preview
Public method | SwitchAway | Todo
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IPrintContent Interface
VisualComponents.UX.Shared Namespace


IPrintContent.Close Method

IPrintContentClose Method

Close and free generated images

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Close()
void Close()
See Also

Reference

IPrintContent Interface
VisualComponents.UX.Shared Namespace


IPrintContent.Reload Method

IPrintContentReload Method

Reload the Report preview

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Reload()
void Reload()
See Also

Reference

IPrintContent Interface
VisualComponents.UX.Shared Namespace


IPrintContent.SwitchAway Method

IPrintContentSwitchAway Method

Todo

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SwitchAway()
void SwitchAway()
See Also

Reference

IPrintContent Interface
VisualComponents.UX.Shared Namespace


IPrintContent Events

The IPrintContent type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IPrintContent Interface
VisualComponents.UX.Shared Namespace


IProcessConfiguratorCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessConfiguratorCommand : IActionItem,
    INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IProcessConfiguratorCommand : IActionItem,
    INotifyPropertyChangedEx, INotifyPropertyChanged

The IProcessConfiguratorCommand type exposes the following members.

Properties
 | Name | Description
Public property | CanExecute | (Inherited from IActionItem.)
Public property | Content | Item text/header. (Inherited from IActionItem.)
Public property | ContextFilter | Defines application contexts where action is available. (Inherited from IActionItem.)
Public property | ControlType | (Inherited from IActionItem.)
Public property | IconName | Gets the icon name. (Inherited from IActionItem.)
Public property | Id | (Inherited from IActionItem.)
Public property | IsChecked |
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | RibbonId | Required for ribbon only, as all items in ribbon groups are required to have a unique id. (Inherited from IActionItem.)
Public property | SiteOrder | (Inherited from IActionItem.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from IActionItem.)
Public property | Visibility | Item Visibility (Inherited from IActionItem.)
Top
Methods
 | Name | Description
Public method | EvaluateCanExecute | (Inherited from IActionItem.)
Public method | Execute | Note: When executed from UI buttons we also call BeforeExecute(). Note: This is executed from both r-click and normal UI buttons. If need to distinguish between executing 'with command panel' and 'immediate execution' inherit from ActionItemT1 and define both Execute() and Execute(bool). Note: Some actions also use IsChecked to execute. They call BeforeExecute() manually. (Inherited from IActionItem.)
Public method | Execute(PropertyCollection) | (Inherited from IActionItem.)
Public method | Execute(SetupPythonActionMessage) | Obsolete. (Inherited from IActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from IActionItem.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from IActionItem.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IProcessConfiguratorCommand Properties

The IProcessConfiguratorCommand type exposes the following members.

Properties
 | Name | Description
Public property | CanExecute | (Inherited from IActionItem.)
Public property | Content | Item text/header. (Inherited from IActionItem.)
Public property | ContextFilter | Defines application contexts where action is available. (Inherited from IActionItem.)
Public property | ControlType | (Inherited from IActionItem.)
Public property | IconName | Gets the icon name. (Inherited from IActionItem.)
Public property | Id | (Inherited from IActionItem.)
Public property | IsChecked |
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | RibbonId | Required for ribbon only, as all items in ribbon groups are required to have a unique id. (Inherited from IActionItem.)
Public property | SiteOrder | (Inherited from IActionItem.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from IActionItem.)
Public property | Visibility | Item Visibility (Inherited from IActionItem.)
Top
See Also

Reference

IProcessConfiguratorCommand Interface
VisualComponents.UX.Shared Namespace


IProcessConfiguratorCommand.IsChecked Property

IProcessConfiguratorCommandIsChecked Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsChecked { get; set; }
property bool IsChecked {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IProcessConfiguratorCommand Interface
VisualComponents.UX.Shared Namespace


IProcessConfiguratorCommand Methods

The IProcessConfiguratorCommand type exposes the following members.

Methods
 | Name | Description
Public method | EvaluateCanExecute | (Inherited from IActionItem.)
Public method | Execute | Note: When executed from UI buttons we also call BeforeExecute(). Note: This is executed from both r-click and normal UI buttons. If need to distinguish between executing 'with command panel' and 'immediate execution' inherit from ActionItemT1 and define both Execute() and Execute(bool). Note: Some actions also use IsChecked to execute. They call BeforeExecute() manually. (Inherited from IActionItem.)
Public method | Execute(PropertyCollection) | (Inherited from IActionItem.)
Public method | Execute(SetupPythonActionMessage) | Obsolete. (Inherited from IActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from IActionItem.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from IActionItem.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Top
See Also

Reference

IProcessConfiguratorCommand Interface
VisualComponents.UX.Shared Namespace


IProcessConfiguratorCommand Events

The IProcessConfiguratorCommand type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IProcessConfiguratorCommand Interface
VisualComponents.UX.Shared Namespace


IProcessConfiguratorViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessConfiguratorViewModel
public interface class IProcessConfiguratorViewModel

The IProcessConfiguratorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | Command |
Public property | IsEnabled |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IProcessConfiguratorViewModel Properties

The IProcessConfiguratorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | Command |
Public property | IsEnabled |
Top
See Also

Reference

IProcessConfiguratorViewModel Interface
VisualComponents.UX.Shared Namespace


IProcessConfiguratorViewModel.Command Property

IProcessConfiguratorViewModelCommand Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessConfiguratorCommand Command { get; set; }
property IProcessConfiguratorCommand^ Command {
    IProcessConfiguratorCommand^ get ();
    void set (IProcessConfiguratorCommand^ value);
}

Property Value

Type: IProcessConfiguratorCommand
See Also

Reference

IProcessConfiguratorViewModel Interface
VisualComponents.UX.Shared Namespace


IProcessConfiguratorViewModel.IsEnabled Property

IProcessConfiguratorViewModelIsEnabled Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsEnabled { get; set; }
property bool IsEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IProcessConfiguratorViewModel Interface
VisualComponents.UX.Shared Namespace


IProcessEditorCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessEditorCommand : IActionItem,
    INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IProcessEditorCommand : IActionItem,
    INotifyPropertyChangedEx, INotifyPropertyChanged

The IProcessEditorCommand type exposes the following members.

Properties
 | Name | Description
Public property | CanExecute | (Inherited from IActionItem.)
Public property | Content | Item text/header. (Inherited from IActionItem.)
Public property | ContextFilter | Defines application contexts where action is available. (Inherited from IActionItem.)
Public property | ControlType | (Inherited from IActionItem.)
Public property | IconName | Gets the icon name. (Inherited from IActionItem.)
Public property | Id | (Inherited from IActionItem.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | RibbonId | Required for ribbon only, as all items in ribbon groups are required to have a unique id. (Inherited from IActionItem.)
Public property | SiteOrder | (Inherited from IActionItem.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from IActionItem.)
Public property | Visibility | Item Visibility (Inherited from IActionItem.)
Top
Methods
 | Name | Description
Public method | EvaluateCanExecute | (Inherited from IActionItem.)
Public method | Execute | Note: When executed from UI buttons we also call BeforeExecute(). Note: This is executed from both r-click and normal UI buttons. If need to distinguish between executing 'with command panel' and 'immediate execution' inherit from ActionItemT1 and define both Execute() and Execute(bool). Note: Some actions also use IsChecked to execute. They call BeforeExecute() manually. (Inherited from IActionItem.)
Public method | Execute(IProcessExecutor) |
Public method | Execute(IProcessRoutine) |
Public method | Execute(PropertyCollection) | (Inherited from IActionItem.)
Public method | Execute(SetupPythonActionMessage) | Obsolete. (Inherited from IActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from IActionItem.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from IActionItem.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IProcessEditorCommand Properties

The IProcessEditorCommand type exposes the following members.

Properties
 | Name | Description
Public property | CanExecute | (Inherited from IActionItem.)
Public property | Content | Item text/header. (Inherited from IActionItem.)
Public property | ContextFilter | Defines application contexts where action is available. (Inherited from IActionItem.)
Public property | ControlType | (Inherited from IActionItem.)
Public property | IconName | Gets the icon name. (Inherited from IActionItem.)
Public property | Id | (Inherited from IActionItem.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | RibbonId | Required for ribbon only, as all items in ribbon groups are required to have a unique id. (Inherited from IActionItem.)
Public property | SiteOrder | (Inherited from IActionItem.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from IActionItem.)
Public property | Visibility | Item Visibility (Inherited from IActionItem.)
Top
See Also

Reference

IProcessEditorCommand Interface
VisualComponents.UX.Shared Namespace


IProcessEditorCommand Methods

The IProcessEditorCommand type exposes the following members.

Methods
 | Name | Description
Public method | EvaluateCanExecute | (Inherited from IActionItem.)
Public method | Execute | Note: When executed from UI buttons we also call BeforeExecute(). Note: This is executed from both r-click and normal UI buttons. If need to distinguish between executing 'with command panel' and 'immediate execution' inherit from ActionItemT1 and define both Execute() and Execute(bool). Note: Some actions also use IsChecked to execute. They call BeforeExecute() manually. (Inherited from IActionItem.)
Public method | Execute(IProcessExecutor) |
Public method | Execute(IProcessRoutine) |
Public method | Execute(PropertyCollection) | (Inherited from IActionItem.)
Public method | Execute(SetupPythonActionMessage) | Obsolete. (Inherited from IActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from IActionItem.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from IActionItem.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Top
See Also

Reference

IProcessEditorCommand Interface
VisualComponents.UX.Shared Namespace


IProcessEditorCommand.Execute Method

IProcessEditorCommandExecute Method

Overload List
 | Name | Description
Public method | Execute | Note: When executed from UI buttons we also call BeforeExecute(). Note: This is executed from both r-click and normal UI buttons. If need to distinguish between executing 'with command panel' and 'immediate execution' inherit from ActionItemT1 and define both Execute() and Execute(bool). Note: Some actions also use IsChecked to execute. They call BeforeExecute() manually. (Inherited from IActionItem.)
Public method | Execute(IProcessExecutor) |
Public method | Execute(IProcessRoutine) |
Public method | Execute(PropertyCollection) | (Inherited from IActionItem.)
Public method | Execute(SetupPythonActionMessage) | Obsolete. (Inherited from IActionItem.)
Top
See Also

Reference

IProcessEditorCommand Interface
VisualComponents.UX.Shared Namespace


IProcessEditorCommand.Execute Method (IProcessExecutor)

IProcessEditorCommandExecute Method (IProcessExecutor)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Execute(
    IProcessExecutor executor
)
void Execute(
    IProcessExecutor^ executor
)

Parameters

executor
Type: VisualComponents.Create3DIProcessExecutor
See Also

Reference

IProcessEditorCommand Interface
Execute Overload
VisualComponents.UX.Shared Namespace


IProcessEditorCommand.Execute Method (IProcessRoutine)

IProcessEditorCommandExecute Method (IProcessRoutine)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Execute(
    IProcessRoutine process
)
void Execute(
    IProcessRoutine^ process
)

Parameters

process
Type: VisualComponents.Create3DIProcessRoutine
See Also

Reference

IProcessEditorCommand Interface
Execute Overload
VisualComponents.UX.Shared Namespace


IProcessEditorCommand Events

The IProcessEditorCommand type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IProcessEditorCommand Interface
VisualComponents.UX.Shared Namespace


IProcessEditorViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessEditorViewModel : IDockableScreen,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IProcessEditorViewModel : IDockableScreen,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The IProcessEditorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ContextFilter | Gets or sets the context filter. The context defines one or more contexts where the panel is visible. (Inherited from IDockableScreen.)
Public property | DesiredPanePosition | Gets the desired pane position. If multiple panes are added, panes are ordered using this property. (Inherited from IDockableScreen.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | Executor |
Public property | Height | Gets the Height of the pane. (Inherited from IDockableScreen.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsPinned | Gets or sets a Boolean value that indicates if the pane is pinned. (Inherited from IDockableScreen.)
Public property | IsSelected | Gets or sets a boolean value that indicates if the pane is selected in TabGroupPane (Inherited from IDockableScreen.)
Public property | IsVisible | Gets or sets a boolean value that indicates if the pane is visible (Inherited from IDockableScreen.)
Public property | PanelId | Gets the panel ID (Inherited from IDockableScreen.)
Public property | PaneLocation | Gets the desired panel location DesiredPaneLocation (Inherited from IDockableScreen.)
Public property | PaneOrientation | Gets the pane orientation (Inherited from IDockableScreen.)
Public property | SelectedRoutine |
Public property | SplitPaneId | Gets the split pane id. By default all panes within panel location use same split panel. Multiple split panels can be created by defining new split pane ids. (Inherited from IDockableScreen.)
 | TabGroupId | Gets the pane tab group id. Panes are splitted and ordered to different tabs within the splitpane based on TabGroupId. (Inherited from IDockableScreen.)
Public property | Width | Gets the Width of the pane. (Inherited from IDockableScreen.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IProcessEditorViewModel Properties

The IProcessEditorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ContextFilter | Gets or sets the context filter. The context defines one or more contexts where the panel is visible. (Inherited from IDockableScreen.)
Public property | DesiredPanePosition | Gets the desired pane position. If multiple panes are added, panes are ordered using this property. (Inherited from IDockableScreen.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | Executor |
Public property | Height | Gets the Height of the pane. (Inherited from IDockableScreen.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsPinned | Gets or sets a Boolean value that indicates if the pane is pinned. (Inherited from IDockableScreen.)
Public property | IsSelected | Gets or sets a boolean value that indicates if the pane is selected in TabGroupPane (Inherited from IDockableScreen.)
Public property | IsVisible | Gets or sets a boolean value that indicates if the pane is visible (Inherited from IDockableScreen.)
Public property | PanelId | Gets the panel ID (Inherited from IDockableScreen.)
Public property | PaneLocation | Gets the desired panel location DesiredPaneLocation (Inherited from IDockableScreen.)
Public property | PaneOrientation | Gets the pane orientation (Inherited from IDockableScreen.)
Public property | SelectedRoutine |
Public property | SplitPaneId | Gets the split pane id. By default all panes within panel location use same split panel. Multiple split panels can be created by defining new split pane ids. (Inherited from IDockableScreen.)
 | TabGroupId | Gets the pane tab group id. Panes are splitted and ordered to different tabs within the splitpane based on TabGroupId. (Inherited from IDockableScreen.)
Public property | Width | Gets the Width of the pane. (Inherited from IDockableScreen.)
Top
See Also

Reference

IProcessEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IProcessEditorViewModel.Executor Property

IProcessEditorViewModelExecutor Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessExecutor Executor { get; set; }
property IProcessExecutor^ Executor {
    IProcessExecutor^ get ();
    void set (IProcessExecutor^ value);
}

Property Value

Type: IProcessExecutor
See Also

Reference

IProcessEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IProcessEditorViewModel.SelectedRoutine Property

IProcessEditorViewModelSelectedRoutine Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessRoutine SelectedRoutine { get; set; }
property IProcessRoutine^ SelectedRoutine {
    IProcessRoutine^ get ();
    void set (IProcessRoutine^ value);
}

Property Value

Type: IProcessRoutine
See Also

Reference

IProcessEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IProcessEditorViewModel Methods

The IProcessEditorViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IProcessEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IProcessEditorViewModel Events

The IProcessEditorViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IProcessEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IProcessMapViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessMapViewModel
public interface class IProcessMapViewModel

The IProcessMapViewModel type exposes the following members.

Properties
 | Name | Description
Public property | FilterTransportLinks |
Public property | IsEnabled |
Public property | MapType |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IProcessMapViewModel Properties

The IProcessMapViewModel type exposes the following members.

Properties
 | Name | Description
Public property | FilterTransportLinks |
Public property | IsEnabled |
Public property | MapType |
Top
See Also

Reference

IProcessMapViewModel Interface
VisualComponents.UX.Shared Namespace


IProcessMapViewModel.FilterTransportLinks Property

IProcessMapViewModelFilterTransportLinks Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool FilterTransportLinks { get; set; }
property bool FilterTransportLinks {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IProcessMapViewModel Interface
VisualComponents.UX.Shared Namespace


IProcessMapViewModel.IsEnabled Property

IProcessMapViewModelIsEnabled Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsEnabled { get; set; }
property bool IsEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IProcessMapViewModel Interface
VisualComponents.UX.Shared Namespace


IProcessMapViewModel.MapType Property

IProcessMapViewModelMapType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MapType MapType { get; set; }
property MapType MapType {
    MapType get ();
    void set (MapType value);
}

Property Value

Type: MapType
See Also

Reference

IProcessMapViewModel Interface
VisualComponents.UX.Shared Namespace


IProcessMapVisibilityCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessMapVisibilityCommand : ICheckBoxToolCommand
public interface class IProcessMapVisibilityCommand : ICheckBoxToolCommand

The IProcessMapVisibilityCommand type exposes the following members.

Properties
 | Name | Description
Public property | IsChecked | Gets or sets if the check box is checked. (Inherited from ICheckBoxToolCommand.)
Top
Methods
 | Name | Description
Public method | Update |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IProcessMapVisibilityCommand Properties

The IProcessMapVisibilityCommand type exposes the following members.

Properties
 | Name | Description
Public property | IsChecked | Gets or sets if the check box is checked. (Inherited from ICheckBoxToolCommand.)
Top
See Also

Reference

IProcessMapVisibilityCommand Interface
VisualComponents.UX.Shared Namespace


IProcessMapVisibilityCommand Methods

The IProcessMapVisibilityCommand type exposes the following members.

Methods
 | Name | Description
Public method | Update |
Top
See Also

Reference

IProcessMapVisibilityCommand Interface
VisualComponents.UX.Shared Namespace


IProcessMapVisibilityCommand.Update Method

IProcessMapVisibilityCommandUpdate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Update()
void Update()
See Also

Reference

IProcessMapVisibilityCommand Interface
VisualComponents.UX.Shared Namespace


IProcessRuleEditorLine Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessRuleEditorLine
public interface class IProcessRuleEditorLine

The IProcessRuleEditorLine type exposes the following members.

Properties
 | Name | Description
Public property | Line |
Public property | Model |
Public property | ProcessPointSensor |
Public property | Statement |
Top
Methods
 | Name | Description
Public method | init |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IProcessRuleEditorLine Properties

The IProcessRuleEditorLine type exposes the following members.

Properties
 | Name | Description
Public property | Line |
Public property | Model |
Public property | ProcessPointSensor |
Public property | Statement |
Top
See Also

Reference

IProcessRuleEditorLine Interface
VisualComponents.UX.Shared Namespace


IProcessRuleEditorLine.Line Property

IProcessRuleEditorLineLine Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessRuleLineStatement Line { get; set; }
property IProcessRuleLineStatement^ Line {
    IProcessRuleLineStatement^ get ();
    void set (IProcessRuleLineStatement^ value);
}

Property Value

Type: IProcessRuleLineStatement
See Also

Reference

IProcessRuleEditorLine Interface
VisualComponents.UX.Shared Namespace


IProcessRuleEditorLine.Model Property

IProcessRuleEditorLineModel Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessRuleEditorViewModel Model { get; set; }
property IProcessRuleEditorViewModel^ Model {
    IProcessRuleEditorViewModel^ get ();
    void set (IProcessRuleEditorViewModel^ value);
}

Property Value

Type: IProcessRuleEditorViewModel
See Also

Reference

IProcessRuleEditorLine Interface
VisualComponents.UX.Shared Namespace


IProcessRuleEditorLine.ProcessPointSensor Property

IProcessRuleEditorLineProcessPointSensor Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessPointSensor ProcessPointSensor { get; set; }
property IProcessPointSensor^ ProcessPointSensor {
    IProcessPointSensor^ get ();
    void set (IProcessPointSensor^ value);
}

Property Value

Type: IProcessPointSensor
See Also

Reference

IProcessRuleEditorLine Interface
VisualComponents.UX.Shared Namespace


IProcessRuleEditorLine.Statement Property

IProcessRuleEditorLineStatement Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessRuleStatement Statement { get; set; }
property IProcessRuleStatement^ Statement {
    IProcessRuleStatement^ get ();
    void set (IProcessRuleStatement^ value);
}

Property Value

Type: IProcessRuleStatement
See Also

Reference

IProcessRuleEditorLine Interface
VisualComponents.UX.Shared Namespace


IProcessRuleEditorLine Methods

The IProcessRuleEditorLine type exposes the following members.

Methods
 | Name | Description
Public method | init |
Top
See Also

Reference

IProcessRuleEditorLine Interface
VisualComponents.UX.Shared Namespace


IProcessRuleEditorLine.init Method

IProcessRuleEditorLineinit Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void init()
void init()
See Also

Reference

IProcessRuleEditorLine Interface
VisualComponents.UX.Shared Namespace


IProcessRuleEditorViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessRuleEditorViewModel : IRuleEditor
public interface class IProcessRuleEditorViewModel : IRuleEditor

The IProcessRuleEditorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActiveObject |
Public property | BOOLEANRULE | (Inherited from IRuleEditor.)
Public property | DEFAULT | (Inherited from IRuleEditor.)
Public property | INTEGERRULE | (Inherited from IRuleEditor.)
Public property | IsAuthoring | (Inherited from IRuleEditor.)
Public property | Name | (Inherited from IRuleEditor.)
Public property | NORMAL |
Public property | REALRULE | (Inherited from IRuleEditor.)
Public property | RULE | (Inherited from IRuleEditor.)
Public property | STRINGRULE | (Inherited from IRuleEditor.)
Public property | UNDEFINED | (Inherited from IRuleEditor.)
Public property | UNIFORM |
Public property | ZERO |
Top
Methods
 | Name | Description
Public method | AddStatement | (Inherited from IRuleEditor.)
Public method | Closing | (Inherited from IRuleEditor.)
Public method | ReloadLines | (Inherited from IRuleEditor.)
Public method | SelectedItemLineDelete |
Public method | SelectedItemLineMove |
Public method | SelectedItemLineUpdated | (Inherited from IRuleEditor.)
Public method | ShowAlert | (Inherited from IRuleEditor.)
Public method | StatementToLocalizedString | (Inherited from IRuleEditor.)
Public method | StringToStatement | (Inherited from IRuleEditor.)
Public method | UpdateDescription |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IProcessRuleEditorViewModel Properties

The IProcessRuleEditorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActiveObject |
Public property | BOOLEANRULE | (Inherited from IRuleEditor.)
Public property | DEFAULT | (Inherited from IRuleEditor.)
Public property | INTEGERRULE | (Inherited from IRuleEditor.)
Public property | IsAuthoring | (Inherited from IRuleEditor.)
Public property | Name | (Inherited from IRuleEditor.)
Public property | NORMAL |
Public property | REALRULE | (Inherited from IRuleEditor.)
Public property | RULE | (Inherited from IRuleEditor.)
Public property | STRINGRULE | (Inherited from IRuleEditor.)
Public property | UNDEFINED | (Inherited from IRuleEditor.)
Public property | UNIFORM |
Public property | ZERO |
Top
See Also

Reference

IProcessRuleEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IProcessRuleEditorViewModel.ActiveObject Property

IProcessRuleEditorViewModelActiveObject Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProcessPointSensor ActiveObject { get; set; }
property IProcessPointSensor^ ActiveObject {
    IProcessPointSensor^ get ();
    void set (IProcessPointSensor^ value);
}

Property Value

Type: IProcessPointSensor
See Also

Reference

IProcessRuleEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IProcessRuleEditorViewModel.NORMAL Property

IProcessRuleEditorViewModelNORMAL Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string NORMAL { get; }
property String^ NORMAL {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IProcessRuleEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IProcessRuleEditorViewModel.UNIFORM Property

IProcessRuleEditorViewModelUNIFORM Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string UNIFORM { get; }
property String^ UNIFORM {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IProcessRuleEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IProcessRuleEditorViewModel.ZERO Property

IProcessRuleEditorViewModelZERO Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ZERO { get; }
property String^ ZERO {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IProcessRuleEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IProcessRuleEditorViewModel Methods

The IProcessRuleEditorViewModel type exposes the following members.

Methods
 | Name | Description
Public method | AddStatement | (Inherited from IRuleEditor.)
Public method | Closing | (Inherited from IRuleEditor.)
Public method | ReloadLines | (Inherited from IRuleEditor.)
Public method | SelectedItemLineDelete |
Public method | SelectedItemLineMove |
Public method | SelectedItemLineUpdated | (Inherited from IRuleEditor.)
Public method | ShowAlert | (Inherited from IRuleEditor.)
Public method | StatementToLocalizedString | (Inherited from IRuleEditor.)
Public method | StringToStatement | (Inherited from IRuleEditor.)
Public method | UpdateDescription |
Top
See Also

Reference

IProcessRuleEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IProcessRuleEditorViewModel.SelectedItemLineDelete Method

IProcessRuleEditorViewModelSelectedItemLineDelete Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SelectedItemLineDelete(
    IProcessRuleLineStatement line
)
void SelectedItemLineDelete(
    IProcessRuleLineStatement^ line
)

Parameters

line
Type: VisualComponents.Create3DIProcessRuleLineStatement
See Also

Reference

IProcessRuleEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IProcessRuleEditorViewModel.SelectedItemLineMove Method

IProcessRuleEditorViewModelSelectedItemLineMove Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SelectedItemLineMove(
    IProcessRuleLineStatement line,
    int index
)
void SelectedItemLineMove(
    IProcessRuleLineStatement^ line,
    int index
)

Parameters

line
Type: VisualComponents.Create3DIProcessRuleLineStatement
index
Type: SystemInt32
See Also

Reference

IProcessRuleEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IProcessRuleEditorViewModel.UpdateDescription Method

IProcessRuleEditorViewModelUpdateDescription Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateDescription(
    IProcessRuleLineStatement line
)
void UpdateDescription(
    IProcessRuleLineStatement^ line
)

Parameters

line
Type: VisualComponents.Create3DIProcessRuleLineStatement
See Also

Reference

IProcessRuleEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IProcessTableLineViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProcessTableLineViewModel : IProcessRuleEditorLine
public interface class IProcessTableLineViewModel : IProcessRuleEditorLine

The IProcessTableLineViewModel type exposes the following members.

Properties
 | Name | Description
Public property | Line | (Inherited from IProcessRuleEditorLine.)
Public property | Model | (Inherited from IProcessRuleEditorLine.)
Public property | ProcessPointSensor | (Inherited from IProcessRuleEditorLine.)
Public property | Statement | (Inherited from IProcessRuleEditorLine.)
Top
Methods
 | Name | Description
Public method | init | (Inherited from IProcessRuleEditorLine.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IProcessTableLineViewModel Properties

The IProcessTableLineViewModel type exposes the following members.

Properties
 | Name | Description
Public property | Line | (Inherited from IProcessRuleEditorLine.)
Public property | Model | (Inherited from IProcessRuleEditorLine.)
Public property | ProcessPointSensor | (Inherited from IProcessRuleEditorLine.)
Public property | Statement | (Inherited from IProcessRuleEditorLine.)
Top
See Also

Reference

IProcessTableLineViewModel Interface
VisualComponents.UX.Shared Namespace


IProcessTableLineViewModel Methods

The IProcessTableLineViewModel type exposes the following members.

Methods
 | Name | Description
Public method | init | (Inherited from IProcessRuleEditorLine.)
Top
See Also

Reference

IProcessTableLineViewModel Interface
VisualComponents.UX.Shared Namespace


IProductActivator Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProductActivator : IScreen,
    IHaveDisplayName, IActivate, IDeactivate, IGuardClose, IClose,
    INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IProductActivator : IScreen,
    IHaveDisplayName, IActivate, IDeactivate, IGuardClose, IClose,
    INotifyPropertyChangedEx, INotifyPropertyChanged

The IProductActivator type exposes the following members.

Properties
 | Name | Description
Public property | ActivatorOrder |
Public property | ContentViewModel |
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | Header |
Public property | Id |
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsSelected |
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | ShowActivatorHomePage |
Public method | ShowProductLicensingHomePage |
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IProductActivator Properties

The IProductActivator type exposes the following members.

Properties
 | Name | Description
Public property | ActivatorOrder |
Public property | ContentViewModel |
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | Header |
Public property | Id |
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsSelected |
Top
See Also

Reference

IProductActivator Interface
VisualComponents.UX.Shared Namespace


IProductActivator.ActivatorOrder Property

IProductActivatorActivatorOrder Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int ActivatorOrder { get; }
property int ActivatorOrder {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IProductActivator Interface
VisualComponents.UX.Shared Namespace


IProductActivator.ContentViewModel Property

IProductActivatorContentViewModel Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProductActivator ContentViewModel { get; }
property IProductActivator^ ContentViewModel {
    IProductActivator^ get ();
}

Property Value

Type: IProductActivator
See Also

Reference

IProductActivator Interface
VisualComponents.UX.Shared Namespace


IProductActivator.Header Property

IProductActivatorHeader Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Header { get; }
property String^ Header {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IProductActivator Interface
VisualComponents.UX.Shared Namespace


IProductActivator.Id Property

IProductActivatorId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Id { get; }
property String^ Id {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IProductActivator Interface
VisualComponents.UX.Shared Namespace


IProductActivator.IsSelected Property

IProductActivatorIsSelected Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsSelected { get; set; }
property bool IsSelected {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IProductActivator Interface
VisualComponents.UX.Shared Namespace


IProductActivator Methods

The IProductActivator type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | ShowActivatorHomePage |
Public method | ShowProductLicensingHomePage |
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IProductActivator Interface
VisualComponents.UX.Shared Namespace


IProductActivator.ShowActivatorHomePage Method

IProductActivatorShowActivatorHomePage Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ShowActivatorHomePage()
void ShowActivatorHomePage()
See Also

Reference

IProductActivator Interface
VisualComponents.UX.Shared Namespace


IProductActivator.ShowProductLicensingHomePage Method

IProductActivatorShowProductLicensingHomePage Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ShowProductLicensingHomePage()
void ShowProductLicensingHomePage()
See Also

Reference

IProductActivator Interface
VisualComponents.UX.Shared Namespace


IProductActivator Events

The IProductActivator type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IProductActivator Interface
VisualComponents.UX.Shared Namespace


IProductCreatorEditor Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProductCreatorEditor
public interface class IProductCreatorEditor

The IProductCreatorEditor type exposes the following members.

Properties
 | Name | Description
Public property | Creator |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IProductCreatorEditor Properties

The IProductCreatorEditor type exposes the following members.

Properties
 | Name | Description
Public property | Creator |
Top
See Also

Reference

IProductCreatorEditor Interface
VisualComponents.UX.Shared Namespace


IProductCreatorEditor.Creator Property

IProductCreatorEditorCreator Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProductCreator Creator { get; set; }
property IProductCreator^ Creator {
    IProductCreator^ get ();
    void set (IProductCreator^ value);
}

Property Value

Type: IProductCreator
See Also

Reference

IProductCreatorEditor Interface
VisualComponents.UX.Shared Namespace


IProductEditorCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProductEditorCommand : IActionItem,
    INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IProductEditorCommand : IActionItem,
    INotifyPropertyChangedEx, INotifyPropertyChanged

The IProductEditorCommand type exposes the following members.

Properties
 | Name | Description
Public property | CanExecute | (Inherited from IActionItem.)
Public property | Content | Item text/header. (Inherited from IActionItem.)
Public property | ContextFilter | Defines application contexts where action is available. (Inherited from IActionItem.)
Public property | ControlType | (Inherited from IActionItem.)
Public property | IconName | Gets the icon name. (Inherited from IActionItem.)
Public property | Id | (Inherited from IActionItem.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | RibbonId | Required for ribbon only, as all items in ribbon groups are required to have a unique id. (Inherited from IActionItem.)
Public property | SiteOrder | (Inherited from IActionItem.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from IActionItem.)
Public property | Visibility | Item Visibility (Inherited from IActionItem.)
Top
Methods
 | Name | Description
Public method | EvaluateCanExecute | (Inherited from IActionItem.)
Public method | Execute | Note: When executed from UI buttons we also call BeforeExecute(). Note: This is executed from both r-click and normal UI buttons. If need to distinguish between executing 'with command panel' and 'immediate execution' inherit from ActionItemT1 and define both Execute() and Execute(bool). Note: Some actions also use IsChecked to execute. They call BeforeExecute() manually. (Inherited from IActionItem.)
Public method | Execute(PropertyCollection) | (Inherited from IActionItem.)
Public method | Execute(SetupPythonActionMessage) | Obsolete. (Inherited from IActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from IActionItem.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from IActionItem.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IProductEditorCommand Properties

The IProductEditorCommand type exposes the following members.

Properties
 | Name | Description
Public property | CanExecute | (Inherited from IActionItem.)
Public property | Content | Item text/header. (Inherited from IActionItem.)
Public property | ContextFilter | Defines application contexts where action is available. (Inherited from IActionItem.)
Public property | ControlType | (Inherited from IActionItem.)
Public property | IconName | Gets the icon name. (Inherited from IActionItem.)
Public property | Id | (Inherited from IActionItem.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | RibbonId | Required for ribbon only, as all items in ribbon groups are required to have a unique id. (Inherited from IActionItem.)
Public property | SiteOrder | (Inherited from IActionItem.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from IActionItem.)
Public property | Visibility | Item Visibility (Inherited from IActionItem.)
Top
See Also

Reference

IProductEditorCommand Interface
VisualComponents.UX.Shared Namespace


IProductEditorCommand Methods

The IProductEditorCommand type exposes the following members.

Methods
 | Name | Description
Public method | EvaluateCanExecute | (Inherited from IActionItem.)
Public method | Execute | Note: When executed from UI buttons we also call BeforeExecute(). Note: This is executed from both r-click and normal UI buttons. If need to distinguish between executing 'with command panel' and 'immediate execution' inherit from ActionItemT1 and define both Execute() and Execute(bool). Note: Some actions also use IsChecked to execute. They call BeforeExecute() manually. (Inherited from IActionItem.)
Public method | Execute(PropertyCollection) | (Inherited from IActionItem.)
Public method | Execute(SetupPythonActionMessage) | Obsolete. (Inherited from IActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from IActionItem.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from IActionItem.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Top
See Also

Reference

IProductEditorCommand Interface
VisualComponents.UX.Shared Namespace


IProductEditorCommand Events

The IProductEditorCommand type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IProductEditorCommand Interface
VisualComponents.UX.Shared Namespace


IProductEditorViewModel Interface

Product type editor.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProductEditorViewModel : IDockableScreen,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IProductEditorViewModel : IDockableScreen,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The IProductEditorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ContextFilter | Gets or sets the context filter. The context defines one or more contexts where the panel is visible. (Inherited from IDockableScreen.)
Public property | DesiredPanePosition | Gets the desired pane position. If multiple panes are added, panes are ordered using this property. (Inherited from IDockableScreen.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | Height | Gets the Height of the pane. (Inherited from IDockableScreen.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsEnabled |
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsPinned | Gets or sets a Boolean value that indicates if the pane is pinned. (Inherited from IDockableScreen.)
Public property | IsSelected | Gets or sets a boolean value that indicates if the pane is selected in TabGroupPane (Inherited from IDockableScreen.)
Public property | IsVisible | Gets or sets a boolean value that indicates if the pane is visible (Inherited from IDockableScreen.)
Public property | PanelId | Gets the panel ID (Inherited from IDockableScreen.)
Public property | PaneLocation | Gets the desired panel location DesiredPaneLocation (Inherited from IDockableScreen.)
Public property | PaneOrientation | Gets the pane orientation (Inherited from IDockableScreen.)
Public property | SplitPaneId | Gets the split pane id. By default all panes within panel location use same split panel. Multiple split panels can be created by defining new split pane ids. (Inherited from IDockableScreen.)
 | TabGroupId | Gets the pane tab group id. Panes are splitted and ordered to different tabs within the splitpane based on TabGroupId. (Inherited from IDockableScreen.)
Public property | Width | Gets the Width of the pane. (Inherited from IDockableScreen.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | CreateNewProductType |
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IProductEditorViewModel Properties

The IProductEditorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ContextFilter | Gets or sets the context filter. The context defines one or more contexts where the panel is visible. (Inherited from IDockableScreen.)
Public property | DesiredPanePosition | Gets the desired pane position. If multiple panes are added, panes are ordered using this property. (Inherited from IDockableScreen.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | Height | Gets the Height of the pane. (Inherited from IDockableScreen.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsEnabled |
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsPinned | Gets or sets a Boolean value that indicates if the pane is pinned. (Inherited from IDockableScreen.)
Public property | IsSelected | Gets or sets a boolean value that indicates if the pane is selected in TabGroupPane (Inherited from IDockableScreen.)
Public property | IsVisible | Gets or sets a boolean value that indicates if the pane is visible (Inherited from IDockableScreen.)
Public property | PanelId | Gets the panel ID (Inherited from IDockableScreen.)
Public property | PaneLocation | Gets the desired panel location DesiredPaneLocation (Inherited from IDockableScreen.)
Public property | PaneOrientation | Gets the pane orientation (Inherited from IDockableScreen.)
Public property | SplitPaneId | Gets the split pane id. By default all panes within panel location use same split panel. Multiple split panels can be created by defining new split pane ids. (Inherited from IDockableScreen.)
 | TabGroupId | Gets the pane tab group id. Panes are splitted and ordered to different tabs within the splitpane based on TabGroupId. (Inherited from IDockableScreen.)
Public property | Width | Gets the Width of the pane. (Inherited from IDockableScreen.)
Top
See Also

Reference

IProductEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IProductEditorViewModel.IsEnabled Property

IProductEditorViewModelIsEnabled Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsEnabled { get; set; }
property bool IsEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IProductEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IProductEditorViewModel Methods

The IProductEditorViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | CreateNewProductType |
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IProductEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IProductEditorViewModel.CreateNewProductType Method

IProductEditorViewModelCreateNewProductType Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProductType CreateNewProductType()
IProductType^ CreateNewProductType()

Return Value

Type: IProductType

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IProductEditorViewModel.CreateNewProductType"]

See Also

Reference

IProductEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IProductEditorViewModel Events

The IProductEditorViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IProductEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IProductPropertyEditor Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProductPropertyEditor : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IProductPropertyEditor : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The IProductPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IProductPropertyEditor Properties

The IProductPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
See Also

Reference

IProductPropertyEditor Interface
VisualComponents.UX.Shared Namespace


IProductPropertyEditor Methods

The IProductPropertyEditor type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IProductPropertyEditor Interface
VisualComponents.UX.Shared Namespace


IProductPropertyEditor Events

The IProductPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IProductPropertyEditor Interface
VisualComponents.UX.Shared Namespace


IProgramEditorChild Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IProgramEditorChild
public interface class IProgramEditorChild

The IProgramEditorChild type exposes the following members.

Properties
 | Name | Description
Public property | ParentViewModel |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IProgramEditorChild Properties

The IProgramEditorChild type exposes the following members.

Properties
 | Name | Description
Public property | ParentViewModel |
Top
See Also

Reference

IProgramEditorChild Interface
VisualComponents.UX.Shared Namespace


IProgramEditorChild.ParentViewModel Property

IProgramEditorChildParentViewModel Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IDockableScreen ParentViewModel { get; set; }
property IDockableScreen^ ParentViewModel {
    IDockableScreen^ get ();
    void set (IDockableScreen^ value);
}

Property Value

Type: IDockableScreen
See Also

Reference

IProgramEditorChild Interface
VisualComponents.UX.Shared Namespace


IPropertyEditor Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPropertyEditor : INotifyPropertyChanged
public interface class IPropertyEditor : INotifyPropertyChanged

The IPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | DefinesName | Indicates that property panel doesn't need to display selected object's name
Public property | TranslateRotateVisibility |
Top
Methods
 | Name | Description
Public method | CanHandle |
Public method | Initialize |
Public method | SetActiveObjects |
Public method | SetFilter |
Public method | SortProperties |
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IPropertyEditor Properties

The IPropertyEditor type exposes the following members.

Properties
 | Name | Description
Public property | DefinesName | Indicates that property panel doesn't need to display selected object's name
Public property | TranslateRotateVisibility |
Top
See Also

Reference

IPropertyEditor Interface
VisualComponents.UX.Shared Namespace


IPropertyEditor.DefinesName Property

IPropertyEditorDefinesName Property

Indicates that property panel doesn't need to display selected object's name

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool DefinesName { get; }
property bool DefinesName {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IPropertyEditor Interface
VisualComponents.UX.Shared Namespace


IPropertyEditor.TranslateRotateVisibility Property

IPropertyEditorTranslateRotateVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool TranslateRotateVisibility { get; set; }
property bool TranslateRotateVisibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPropertyEditor Interface
VisualComponents.UX.Shared Namespace


IPropertyEditor Methods

The IPropertyEditor type exposes the following members.

Methods
 | Name | Description
Public method | CanHandle |
Public method | Initialize |
Public method | SetActiveObjects |
Public method | SetFilter |
Public method | SortProperties |
Top
See Also

Reference

IPropertyEditor Interface
VisualComponents.UX.Shared Namespace


IPropertyEditor.CanHandle Method

IPropertyEditorCanHandle Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanHandle(
    Object obj
)
bool CanHandle(
    Object^ obj
)

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IPropertyEditor.CanHandle(System.Object)"]

See Also

Reference

IPropertyEditor Interface
VisualComponents.UX.Shared Namespace


IPropertyEditor.Initialize Method

IPropertyEditorInitialize Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Initialize()
void Initialize()
See Also

Reference

IPropertyEditor Interface
VisualComponents.UX.Shared Namespace


IPropertyEditor.SetActiveObjects Method

IPropertyEditorSetActiveObjects Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetActiveObjects(
    Object item,
    IList<INamed> items
)
void SetActiveObjects(
    Object^ item,
    IList<INamed^>^ items
)

Parameters

item
Type: SystemObject
items
Type: System.Collections.GenericIListINamed
See Also

Reference

IPropertyEditor Interface
VisualComponents.UX.Shared Namespace


IPropertyEditor.SetFilter Method

IPropertyEditorSetFilter Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetFilter(
    string FilterText
)
void SetFilter(
    String^ FilterText
)

Parameters

FilterText
Type: SystemString
See Also

Reference

IPropertyEditor Interface
VisualComponents.UX.Shared Namespace


IPropertyEditor.SortProperties Method

IPropertyEditorSortProperties Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SortProperties(
    SortOrder sortOrder
)
void SortProperties(
    SortOrder sortOrder
)

Parameters

sortOrder
Type: System.Data.SqlClientSortOrder
See Also

Reference

IPropertyEditor Interface
VisualComponents.UX.Shared Namespace


IPropertyEditor Events

The IPropertyEditor type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IPropertyEditor Interface
VisualComponents.UX.Shared Namespace


IPropertyEditorExtendedContent Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPropertyEditorExtendedContent
public interface class IPropertyEditorExtendedContent

The IPropertyEditorExtendedContent type exposes the following members.

Properties
 | Name | Description
Public property | ActiveObject |
Public property | ActiveObjects |
Public property | OrderPriority |
Top
Methods
 | Name | Description
Public method | CanHandle |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IPropertyEditorExtendedContent Properties

The IPropertyEditorExtendedContent type exposes the following members.

Properties
 | Name | Description
Public property | ActiveObject |
Public property | ActiveObjects |
Public property | OrderPriority |
Top
See Also

Reference

IPropertyEditorExtendedContent Interface
VisualComponents.UX.Shared Namespace


IPropertyEditorExtendedContent.ActiveObject Property

IPropertyEditorExtendedContentActiveObject Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object ActiveObject { set; }
property Object^ ActiveObject {
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

IPropertyEditorExtendedContent Interface
VisualComponents.UX.Shared Namespace


IPropertyEditorExtendedContent.ActiveObjects Property

IPropertyEditorExtendedContentActiveObjects Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<INamed> ActiveObjects { set; }
property IList<INamed^>^ ActiveObjects {
    void set (IList<INamed^>^ value);
}

Property Value

Type: IListINamed
See Also

Reference

IPropertyEditorExtendedContent Interface
VisualComponents.UX.Shared Namespace


IPropertyEditorExtendedContent.OrderPriority Property

IPropertyEditorExtendedContentOrderPriority Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int OrderPriority { get; }
property int OrderPriority {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IPropertyEditorExtendedContent Interface
VisualComponents.UX.Shared Namespace


IPropertyEditorExtendedContent Methods

The IPropertyEditorExtendedContent type exposes the following members.

Methods
 | Name | Description
Public method | CanHandle |
Top
See Also

Reference

IPropertyEditorExtendedContent Interface
VisualComponents.UX.Shared Namespace


IPropertyEditorExtendedContent.CanHandle Method

IPropertyEditorExtendedContentCanHandle Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanHandle(
    Object obj
)
bool CanHandle(
    Object^ obj
)

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IPropertyEditorExtendedContent.CanHandle(System.Object)"]

See Also

Reference

IPropertyEditorExtendedContent Interface
VisualComponents.UX.Shared Namespace


IPropertyEditorExtendedContentContainer Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPropertyEditorExtendedContentContainer
public interface class IPropertyEditorExtendedContentContainer
See Also

Reference

VisualComponents.UX.Shared Namespace


IPropertyObjectEditor Interface

Property object editor interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPropertyObjectEditor : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IPropertyObjectEditor : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The IPropertyObjectEditor type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IPropertyObjectEditor Properties

The IPropertyObjectEditor type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
See Also

Reference

IPropertyObjectEditor Interface
VisualComponents.UX.Shared Namespace


IPropertyObjectEditor Methods

The IPropertyObjectEditor type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IPropertyObjectEditor Interface
VisualComponents.UX.Shared Namespace


IPropertyObjectEditor Events

The IPropertyObjectEditor type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IPropertyObjectEditor Interface
VisualComponents.UX.Shared Namespace


IPropertyObjectEditorAction Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPropertyObjectEditorAction : ICommandPanelAction
public interface class IPropertyObjectEditorAction : ICommandPanelAction

The IPropertyObjectEditorAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | ActionPropertyContainer |
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | TargetProperty |
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Top
Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | StartAction |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IPropertyObjectEditorAction Properties

The IPropertyObjectEditorAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | ActionPropertyContainer |
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | TargetProperty |
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

IPropertyObjectEditorAction Interface
VisualComponents.UX.Shared Namespace


IPropertyObjectEditorAction.ActionPropertyContainer Property

IPropertyObjectEditorActionActionPropertyContainer Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPropertyContainer ActionPropertyContainer { get; }
property IPropertyContainer^ ActionPropertyContainer {
    IPropertyContainer^ get ();
}

Property Value

Type: IPropertyContainer
See Also

Reference

IPropertyObjectEditorAction Interface
VisualComponents.UX.Shared Namespace


IPropertyObjectEditorAction.TargetProperty Property

IPropertyObjectEditorActionTargetProperty Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IComponentProperty TargetProperty { get; set; }
property IComponentProperty^ TargetProperty {
    IComponentProperty^ get ();
    void set (IComponentProperty^ value);
}

Property Value

Type: IComponentProperty
See Also

Reference

IPropertyObjectEditorAction Interface
VisualComponents.UX.Shared Namespace


IPropertyObjectEditorAction Methods

The IPropertyObjectEditorAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | StartAction |
Top
See Also

Reference

IPropertyObjectEditorAction Interface
VisualComponents.UX.Shared Namespace


IPropertyObjectEditorAction.StartAction Method

IPropertyObjectEditorActionStartAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StartAction(
    EventHandler<ResultCompletionEventArgs> completed = null
)
void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr
)

Parameters

completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs

Implements

ICommandPanelActionStartAction(EventHandlerResultCompletionEventArgs)
See Also

Reference

IPropertyObjectEditorAction Interface
VisualComponents.UX.Shared Namespace


IPythonEditorViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPythonEditorViewModel
public interface class IPythonEditorViewModel

The IPythonEditorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | Script |
Public property | Title |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IPythonEditorViewModel Properties

The IPythonEditorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | Script |
Public property | Title |
Top
See Also

Reference

IPythonEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPythonEditorViewModel.Script Property

IPythonEditorViewModelScript Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPythonScript Script { get; set; }
property IPythonScript^ Script {
    IPythonScript^ get ();
    void set (IPythonScript^ value);
}

Property Value

Type: IPythonScript
See Also

Reference

IPythonEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPythonEditorViewModel.Title Property

IPythonEditorViewModelTitle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Title { get; set; }
property String^ Title {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IPythonEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IPythonIntellisense Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IPythonIntellisense
public interface class IPythonIntellisense

The IPythonIntellisense type exposes the following members.

Properties
 | Name | Description
Public property | BlackThemeInformation |
Public property | Constants |
Public property | WhiteThemeInformation |
Top
Methods
 | Name | Description
Public method | GetAttributeInfo |
Public method | GetExpressionType |
Public method | GetHelpers |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IPythonIntellisense Properties

The IPythonIntellisense type exposes the following members.

Properties
 | Name | Description
Public property | BlackThemeInformation |
Public property | Constants |
Public property | WhiteThemeInformation |
Top
See Also

Reference

IPythonIntellisense Interface
VisualComponents.UX.Shared Namespace


IPythonIntellisense.BlackThemeInformation Property

IPythonIntellisenseBlackThemeInformation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
List<int> BlackThemeInformation { get; }
property List<int>^ BlackThemeInformation {
    List<int>^ get ();
}

Property Value

Type: ListInt32
See Also

Reference

IPythonIntellisense Interface
VisualComponents.UX.Shared Namespace


IPythonIntellisense.Constants Property

IPythonIntellisenseConstants Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
List<string> Constants { get; }
property List<String^>^ Constants {
    List<String^>^ get ();
}

Property Value

Type: ListString
See Also

Reference

IPythonIntellisense Interface
VisualComponents.UX.Shared Namespace


IPythonIntellisense.WhiteThemeInformation Property

IPythonIntellisenseWhiteThemeInformation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
List<int> WhiteThemeInformation { get; }
property List<int>^ WhiteThemeInformation {
    List<int>^ get ();
}

Property Value

Type: ListInt32
See Also

Reference

IPythonIntellisense Interface
VisualComponents.UX.Shared Namespace


IPythonIntellisense Methods

The IPythonIntellisense type exposes the following members.

Methods
 | Name | Description
Public method | GetAttributeInfo |
Public method | GetExpressionType |
Public method | GetHelpers |
Top
See Also

Reference

IPythonIntellisense Interface
VisualComponents.UX.Shared Namespace


IPythonIntellisense.GetAttributeInfo Method

IPythonIntellisenseGetAttributeInfo Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
PythonAttributeInformation GetAttributeInfo(
    Dictionary<string, string> variableAndtype,
    string line,
    string attribute
)
PythonAttributeInformation^ GetAttributeInfo(
    Dictionary<String^, String^>^ variableAndtype,
    String^ line,
    String^ attribute
)

Parameters

variableAndtype
Type: System.Collections.GenericDictionaryString, String
line
Type: SystemString
attribute
Type: SystemString

Return Value

Type: PythonAttributeInformation

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IPythonIntellisense.GetAttributeInfo(System.Collections.Generic.Dictionary{System.String,System.String},System.String,System.String)"]

See Also

Reference

IPythonIntellisense Interface
VisualComponents.UX.Shared Namespace


IPythonIntellisense.GetExpressionType Method

IPythonIntellisenseGetExpressionType Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
PythonClassInfo GetExpressionType(
    Dictionary<string, string> variableAndtype,
    string line,
    bool completed
)
PythonClassInfo^ GetExpressionType(
    Dictionary<String^, String^>^ variableAndtype,
    String^ line,
    bool completed
)

Parameters

variableAndtype
Type: System.Collections.GenericDictionaryString, String
line
Type: SystemString
completed
Type: SystemBoolean

Return Value

Type: PythonClassInfo

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IPythonIntellisense.GetExpressionType(System.Collections.Generic.Dictionary{System.String,System.String},System.String,System.Boolean)"]

See Also

Reference

IPythonIntellisense Interface
VisualComponents.UX.Shared Namespace


IPythonIntellisense.GetHelpers Method

IPythonIntellisenseGetHelpers Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
List<string> GetHelpers(
    string text
)
List<String^>^ GetHelpers(
    String^ text
)

Parameters

text
Type: SystemString

Return Value

Type: ListString

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IPythonIntellisense.GetHelpers(System.String)"]

See Also

Reference

IPythonIntellisense Interface
VisualComponents.UX.Shared Namespace


IRadioButtonToolCommand Interface

Interface for action items that should be represented as radio buttons.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRadioButtonToolCommand
public interface class IRadioButtonToolCommand

The IRadioButtonToolCommand type exposes the following members.

Properties
 | Name | Description
Public property | GroupName | Gets or sets the name that specifies which System.Windows.Controls.RadioButton controls are mutually exclusive.
Public property | IsChecked | Gets or sets if the radio button is checked.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRadioButtonToolCommand Properties

The IRadioButtonToolCommand type exposes the following members.

Properties
 | Name | Description
Public property | GroupName | Gets or sets the name that specifies which System.Windows.Controls.RadioButton controls are mutually exclusive.
Public property | IsChecked | Gets or sets if the radio button is checked.
Top
See Also

Reference

IRadioButtonToolCommand Interface
VisualComponents.UX.Shared Namespace


IRadioButtonToolCommand.GroupName Property

IRadioButtonToolCommandGroupName Property

Gets or sets the name that specifies which System.Windows.Controls.RadioButton controls are mutually exclusive.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string GroupName { get; }
property String^ GroupName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IRadioButtonToolCommand Interface
VisualComponents.UX.Shared Namespace


IRadioButtonToolCommand.IsChecked Property

IRadioButtonToolCommandIsChecked Property

Gets or sets if the radio button is checked.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsChecked { get; set; }
property bool IsChecked {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRadioButtonToolCommand Interface
VisualComponents.UX.Shared Namespace


IRecentDocumentSection Interface

Recent Documents section interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRecentDocumentSection : ISection
public interface class IRecentDocumentSection : ISection

The IRecentDocumentSection type exposes the following members.

Properties
 | Name | Description
Public property | RecentDocuments | "Resent documents" section
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | GetSection | Gets the section (Inherited from ISection.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRecentDocumentSection Properties

The IRecentDocumentSection type exposes the following members.

Properties
 | Name | Description
Public property | RecentDocuments | "Resent documents" section
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
See Also

Reference

IRecentDocumentSection Interface
VisualComponents.UX.Shared Namespace


IRecentDocumentSection.RecentDocuments Property

IRecentDocumentSectionRecentDocuments Property

"Resent documents" section

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
RecentDocumentConfigCollection RecentDocuments { get; }
property RecentDocumentConfigCollection^ RecentDocuments {
    RecentDocumentConfigCollection^ get ();
}

Property Value

Type: RecentDocumentConfigCollection
See Also

Reference

IRecentDocumentSection Interface
VisualComponents.UX.Shared Namespace


IRecentDocumentSection Methods

The IRecentDocumentSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | GetSection | Gets the section (Inherited from ISection.)
Top
See Also

Reference

IRecentDocumentSection Interface
VisualComponents.UX.Shared Namespace


IRecentFolderSection Interface

"Recent Folder" section interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRecentFolderSection : ISection
public interface class IRecentFolderSection : ISection

The IRecentFolderSection type exposes the following members.

Properties
 | Name | Description
Public property | RecentFolders | "Resent folders" section
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | GetSection | Gets the section (Inherited from ISection.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRecentFolderSection Properties

The IRecentFolderSection type exposes the following members.

Properties
 | Name | Description
Public property | RecentFolders | "Resent folders" section
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
See Also

Reference

IRecentFolderSection Interface
VisualComponents.UX.Shared Namespace


IRecentFolderSection.RecentFolders Property

IRecentFolderSectionRecentFolders Property

"Resent folders" section

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
RecentFolderConfigCollection RecentFolders { get; }
property RecentFolderConfigCollection^ RecentFolders {
    RecentFolderConfigCollection^ get ();
}

Property Value

Type: RecentFolderConfigCollection
See Also

Reference

IRecentFolderSection Interface
VisualComponents.UX.Shared Namespace


IRecentFolderSection Methods

The IRecentFolderSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | GetSection | Gets the section (Inherited from ISection.)
Top
See Also

Reference

IRecentFolderSection Interface
VisualComponents.UX.Shared Namespace


IRecentOpenSaveFolder Interface

Recent Open/Save folder interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRecentOpenSaveFolder : ISection
public interface class IRecentOpenSaveFolder : ISection

The IRecentOpenSaveFolder type exposes the following members.

Properties
 | Name | Description
Public property | FolderItems | Recent Open/Save folders item
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | GetSection | Gets the section (Inherited from ISection.)
Public method | IsFolderValueSet | Check a folder value
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRecentOpenSaveFolder Properties

The IRecentOpenSaveFolder type exposes the following members.

Properties
 | Name | Description
Public property | FolderItems | Recent Open/Save folders item
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
See Also

Reference

IRecentOpenSaveFolder Interface
VisualComponents.UX.Shared Namespace


IRecentOpenSaveFolder.FolderItems Property

IRecentOpenSaveFolderFolderItems Property

Recent Open/Save folders item

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
OpenSaveFolderConfigCollection FolderItems { get; }
property OpenSaveFolderConfigCollection^ FolderItems {
    OpenSaveFolderConfigCollection^ get ();
}

Property Value

Type: OpenSaveFolderConfigCollection
See Also

Reference

IRecentOpenSaveFolder Interface
VisualComponents.UX.Shared Namespace


IRecentOpenSaveFolder Methods

The IRecentOpenSaveFolder type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | GetSection | Gets the section (Inherited from ISection.)
Public method | IsFolderValueSet | Check a folder value
Top
See Also

Reference

IRecentOpenSaveFolder Interface
VisualComponents.UX.Shared Namespace


IRecentOpenSaveFolder.IsFolderValueSet Method

IRecentOpenSaveFolderIsFolderValueSet Method

Check a folder value

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsFolderValueSet(
    OpenSaveFolderType folderType
)
bool IsFolderValueSet(
    OpenSaveFolderType folderType
)

Parameters

folderType
Type: VisualComponents.UX.SharedOpenSaveFolderType
the folder type

Return Value

Type: Boolean
true if the value type is set
See Also

Reference

IRecentOpenSaveFolder Interface
VisualComponents.UX.Shared Namespace


IRecordExporterMetadata Interface

This is the interface we will use to describe the metadata being applied to exports of type IPdfRecordExporter.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRecordExporterMetadata
public interface class IRecordExporterMetadata

The IRecordExporterMetadata type exposes the following members.

Properties
 | Name | Description
Public property | Order |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRecordExporterMetadata Properties

The IRecordExporterMetadata type exposes the following members.

Properties
 | Name | Description
Public property | Order |
Top
See Also

Reference

IRecordExporterMetadata Interface
VisualComponents.UX.Shared Namespace


IRecordExporterMetadata.Order Property

IRecordExporterMetadataOrder Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int Order { get; }
property int Order {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IRecordExporterMetadata Interface
VisualComponents.UX.Shared Namespace


IRecordSetting Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRecordSetting
public interface class IRecordSetting

The IRecordSetting type exposes the following members.

Methods
 | Name | Description
Public method | ActivateSetting |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRecordSetting Methods

The IRecordSetting type exposes the following members.

Methods
 | Name | Description
Public method | ActivateSetting |
Top
See Also

Reference

IRecordSetting Interface
VisualComponents.UX.Shared Namespace


IRecordSetting.ActivateSetting Method

IRecordSettingActivateSetting Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ActivateSetting(
    IPdfRecordExporter exporter
)
void ActivateSetting(
    IPdfRecordExporter^ exporter
)

Parameters

exporter
Type: VisualComponents.Create3DIPdfRecordExporter
See Also

Reference

IRecordSetting Interface
VisualComponents.UX.Shared Namespace


IRecordViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRecordViewModel
public interface class IRecordViewModel

The IRecordViewModel type exposes the following members.

Properties
 | Name | Description
Public property | PdfRecordExporters |
Public property | SelectedPdfRecordExporter |
Public property | SelectedRecordTemplate |
Public property | SelectedRecordTemplateHeader |
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRecordViewModel Properties

The IRecordViewModel type exposes the following members.

Properties
 | Name | Description
Public property | PdfRecordExporters |
Public property | SelectedPdfRecordExporter |
Public property | SelectedRecordTemplate |
Public property | SelectedRecordTemplateHeader |
Top
See Also

Reference

IRecordViewModel Interface
VisualComponents.UX.Shared Namespace


IRecordViewModel.PdfRecordExporters Property

IRecordViewModelPdfRecordExporters Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ObservableCollection<IPdfRecordExporter> PdfRecordExporters { get; }
property ObservableCollection<IPdfRecordExporter^>^ PdfRecordExporters {
    ObservableCollection<IPdfRecordExporter^>^ get ();
}

Property Value

Type: ObservableCollectionIPdfRecordExporter
See Also

Reference

IRecordViewModel Interface
VisualComponents.UX.Shared Namespace


IRecordViewModel.SelectedPdfRecordExporter Property

IRecordViewModelSelectedPdfRecordExporter Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IPdfRecordExporter SelectedPdfRecordExporter { get; }
property IPdfRecordExporter^ SelectedPdfRecordExporter {
    IPdfRecordExporter^ get ();
}

Property Value

Type: IPdfRecordExporter
See Also

Reference

IRecordViewModel Interface
VisualComponents.UX.Shared Namespace


IRecordViewModel.SelectedRecordTemplate Property

IRecordViewModelSelectedRecordTemplate Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRecordExporter SelectedRecordTemplate { get; }
property IRecordExporter^ SelectedRecordTemplate {
    IRecordExporter^ get ();
}

Property Value

Type: IRecordExporter
See Also

Reference

IRecordViewModel Interface
VisualComponents.UX.Shared Namespace


IRecordViewModel.SelectedRecordTemplateHeader Property

IRecordViewModelSelectedRecordTemplateHeader Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IHeaderModel SelectedRecordTemplateHeader { get; }
property IHeaderModel^ SelectedRecordTemplateHeader {
    IHeaderModel^ get ();
}

Property Value

Type: IHeaderModel
See Also

Reference

IRecordViewModel Interface
VisualComponents.UX.Shared Namespace


IRecordViewModel Events

The IRecordViewModel type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

IRecordViewModel Interface
VisualComponents.UX.Shared Namespace


IRecordViewModel.PropertyChanged Event

IRecordViewModelPropertyChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event PropertyChangedEventHandler PropertyChanged
 event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler
See Also

Reference

IRecordViewModel Interface
VisualComponents.UX.Shared Namespace


IRenderingPresetCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRenderingPresetCommand
public interface class IRenderingPresetCommand

The IRenderingPresetCommand type exposes the following members.

Properties
 | Name | Description
Public property | PresetModes |
Top
Methods
 | Name | Description
Public method | ApplySelectedPreset |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRenderingPresetCommand Properties

The IRenderingPresetCommand type exposes the following members.

Properties
 | Name | Description
Public property | PresetModes |
Top
See Also

Reference

IRenderingPresetCommand Interface
VisualComponents.UX.Shared Namespace


IRenderingPresetCommand.PresetModes Property

IRenderingPresetCommandPresetModes Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IList<RenderingPreset> PresetModes { get; }
property IList<RenderingPreset>^ PresetModes {
    IList<RenderingPreset>^ get ();
}

Property Value

Type: IListRenderingPreset
See Also

Reference

IRenderingPresetCommand Interface
VisualComponents.UX.Shared Namespace


IRenderingPresetCommand Methods

The IRenderingPresetCommand type exposes the following members.

Methods
 | Name | Description
Public method | ApplySelectedPreset |
Top
See Also

Reference

IRenderingPresetCommand Interface
VisualComponents.UX.Shared Namespace


IRenderingPresetCommand.ApplySelectedPreset Method

IRenderingPresetCommandApplySelectedPreset Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ApplySelectedPreset()
void ApplySelectedPreset()
See Also

Reference

IRenderingPresetCommand Interface
VisualComponents.UX.Shared Namespace


IReportingViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IReportingViewModel : IDockableScreen,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IReportingViewModel : IDockableScreen,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The IReportingViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ContextFilter | Gets or sets the context filter. The context defines one or more contexts where the panel is visible. (Inherited from IDockableScreen.)
Public property | DesiredPanePosition | Gets the desired pane position. If multiple panes are added, panes are ordered using this property. (Inherited from IDockableScreen.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | Height | Gets the Height of the pane. (Inherited from IDockableScreen.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsPinned | Gets or sets a Boolean value that indicates if the pane is pinned. (Inherited from IDockableScreen.)
Public property | IsSelected | Gets or sets a boolean value that indicates if the pane is selected in TabGroupPane (Inherited from IDockableScreen.)
Public property | IsVisible | Gets or sets a boolean value that indicates if the pane is visible (Inherited from IDockableScreen.)
Public property | MaximumPointsToShow |
Public property | PanelId | Gets the panel ID (Inherited from IDockableScreen.)
Public property | PaneLocation | Gets the desired panel location DesiredPaneLocation (Inherited from IDockableScreen.)
Public property | PaneOrientation | Gets the pane orientation (Inherited from IDockableScreen.)
Public property | SelectedFrequency |
Public property | SelectedIntervalToShow |
Public property | SplitPaneId | Gets the split pane id. By default all panes within panel location use same split panel. Multiple split panels can be created by defining new split pane ids. (Inherited from IDockableScreen.)
 | TabGroupId | Gets the pane tab group id. Panes are splitted and ordered to different tabs within the splitpane based on TabGroupId. (Inherited from IDockableScreen.)
Public property | Width | Gets the Width of the pane. (Inherited from IDockableScreen.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IReportingViewModel Properties

The IReportingViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ContextFilter | Gets or sets the context filter. The context defines one or more contexts where the panel is visible. (Inherited from IDockableScreen.)
Public property | DesiredPanePosition | Gets the desired pane position. If multiple panes are added, panes are ordered using this property. (Inherited from IDockableScreen.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | Height | Gets the Height of the pane. (Inherited from IDockableScreen.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsPinned | Gets or sets a Boolean value that indicates if the pane is pinned. (Inherited from IDockableScreen.)
Public property | IsSelected | Gets or sets a boolean value that indicates if the pane is selected in TabGroupPane (Inherited from IDockableScreen.)
Public property | IsVisible | Gets or sets a boolean value that indicates if the pane is visible (Inherited from IDockableScreen.)
Public property | MaximumPointsToShow |
Public property | PanelId | Gets the panel ID (Inherited from IDockableScreen.)
Public property | PaneLocation | Gets the desired panel location DesiredPaneLocation (Inherited from IDockableScreen.)
Public property | PaneOrientation | Gets the pane orientation (Inherited from IDockableScreen.)
Public property | SelectedFrequency |
Public property | SelectedIntervalToShow |
Public property | SplitPaneId | Gets the split pane id. By default all panes within panel location use same split panel. Multiple split panels can be created by defining new split pane ids. (Inherited from IDockableScreen.)
 | TabGroupId | Gets the pane tab group id. Panes are splitted and ordered to different tabs within the splitpane based on TabGroupId. (Inherited from IDockableScreen.)
Public property | Width | Gets the Width of the pane. (Inherited from IDockableScreen.)
Top
See Also

Reference

IReportingViewModel Interface
VisualComponents.UX.Shared Namespace


IReportingViewModel.MaximumPointsToShow Property

IReportingViewModelMaximumPointsToShow Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int MaximumPointsToShow { get; }
property int MaximumPointsToShow {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IReportingViewModel Interface
VisualComponents.UX.Shared Namespace


IReportingViewModel.SelectedFrequency Property

IReportingViewModelSelectedFrequency Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
KeyValuePair<string, int> SelectedFrequency { get; set; }
property KeyValuePair<String^, int> SelectedFrequency {
    KeyValuePair<String^, int> get ();
    void set (KeyValuePair<String^, int> value);
}

Property Value

Type: KeyValuePairString, Int32
See Also

Reference

IReportingViewModel Interface
VisualComponents.UX.Shared Namespace


IReportingViewModel.SelectedIntervalToShow Property

IReportingViewModelSelectedIntervalToShow Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
KeyValuePair<string, int> SelectedIntervalToShow { get; set; }
property KeyValuePair<String^, int> SelectedIntervalToShow {
    KeyValuePair<String^, int> get ();
    void set (KeyValuePair<String^, int> value);
}

Property Value

Type: KeyValuePairString, Int32
See Also

Reference

IReportingViewModel Interface
VisualComponents.UX.Shared Namespace


IReportingViewModel Methods

The IReportingViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IReportingViewModel Interface
VisualComponents.UX.Shared Namespace


IReportingViewModel Events

The IReportingViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IReportingViewModel Interface
VisualComponents.UX.Shared Namespace


IReportProgress Interface

Action interface for reporting progress status.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IReportProgress
public interface class IReportProgress

The IReportProgress type exposes the following members.

Events
 | Name | Description
Public event | ProgressChanged | Event that is triggered when command reports progress change.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IReportProgress Events

The IReportProgress type exposes the following members.

Events
 | Name | Description
Public event | ProgressChanged | Event that is triggered when command reports progress change.
Top
See Also

Reference

IReportProgress Interface
VisualComponents.UX.Shared Namespace


IReportProgress.ProgressChanged Event

IReportProgressProgressChanged Event

Event that is triggered when command reports progress change.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<ProgressEventArgs> ProgressChanged
 event EventHandler<ProgressEventArgs^>^ ProgressChanged {
    void add (EventHandler<ProgressEventArgs^>^ value);
    void remove (EventHandler<ProgressEventArgs^>^ value);
}

Value

Type: SystemEventHandlerProgressEventArgs
See Also

Reference

IReportProgress Interface
VisualComponents.UX.Shared Namespace


IReportViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IReportViewModel
public interface class IReportViewModel

The IReportViewModel type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Top
Methods
 | Name | Description
Public method | StartStopTimer |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IReportViewModel Properties

The IReportViewModel type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Top
See Also

Reference

IReportViewModel Interface
VisualComponents.UX.Shared Namespace


IReportViewModel.Name Property

IReportViewModelName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Name { get; }
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IReportViewModel Interface
VisualComponents.UX.Shared Namespace


IReportViewModel Methods

The IReportViewModel type exposes the following members.

Methods
 | Name | Description
Public method | StartStopTimer |
Top
See Also

Reference

IReportViewModel Interface
VisualComponents.UX.Shared Namespace


IReportViewModel.StartStopTimer Method

IReportViewModelStartStopTimer Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StartStopTimer(
    bool start
)
void StartStopTimer(
    bool start
)

Parameters

start
Type: SystemBoolean
See Also

Reference

IReportViewModel Interface
VisualComponents.UX.Shared Namespace


IRibbonGroup Interface

Marker interface a ribbon group item.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRibbonGroup
public interface class IRibbonGroup

The IRibbonGroup type exposes the following members.

Properties
 | Name | Description
Public property | Commands | Returns the collection of ribbon tool commands that exist within the group.
Public property | Header | Returns caption associated with RibbonGroup.
Public property | Icon | Returns the svg icon path data.
Public property | Id | Returns a string used to uniquely identify the RibbonGroup with the XamRibbon.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRibbonGroup Properties

The IRibbonGroup type exposes the following members.

Properties
 | Name | Description
Public property | Commands | Returns the collection of ribbon tool commands that exist within the group.
Public property | Header | Returns caption associated with RibbonGroup.
Public property | Icon | Returns the svg icon path data.
Public property | Id | Returns a string used to uniquely identify the RibbonGroup with the XamRibbon.
Top
See Also

Reference

IRibbonGroup Interface
VisualComponents.UX.Shared Namespace


IRibbonGroup.Commands Property

IRibbonGroupCommands Property

Returns the collection of ribbon tool commands that exist within the group.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ObservableCollection<IActionItem> Commands { get; set; }
property ObservableCollection<IActionItem^>^ Commands {
    ObservableCollection<IActionItem^>^ get ();
    void set (ObservableCollection<IActionItem^>^ value);
}

Property Value

Type: ObservableCollectionIActionItem
See Also

Reference

IRibbonGroup Interface
VisualComponents.UX.Shared Namespace


IRibbonGroup.Header Property

IRibbonGroupHeader Property

Returns caption associated with RibbonGroup.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Header { get; }
property String^ Header {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IRibbonGroup Interface
VisualComponents.UX.Shared Namespace


IRibbonGroup.Icon Property

IRibbonGroupIcon Property

Returns the svg icon path data.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Icon { get; }
property String^ Icon {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IRibbonGroup Interface
VisualComponents.UX.Shared Namespace


IRibbonGroup.Id Property

IRibbonGroupId Property

Returns a string used to uniquely identify the RibbonGroup with the XamRibbon.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Id { get; }
property String^ Id {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IRibbonGroup Interface
VisualComponents.UX.Shared Namespace


IRibbonSection Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRibbonSection : ISection
public interface class IRibbonSection : ISection

The IRibbonSection type exposes the following members.

Properties
 | Name | Description
Public property | QatRibbonGroups |
Public property | QatRibbonTools |
Public property | RibbonSetting |
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | GetSection | Gets the section (Inherited from ISection.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRibbonSection Properties

The IRibbonSection type exposes the following members.

Properties
 | Name | Description
Public property | QatRibbonGroups |
Public property | QatRibbonTools |
Public property | RibbonSetting |
Public property | SectionName | Section name (Inherited from ISection.)
Public property | SectionType | Section type (Inherited from ISection.)
Public property | SectionVersion | Section version (Inherited from ISection.)
Top
See Also

Reference

IRibbonSection Interface
VisualComponents.UX.Shared Namespace


IRibbonSection.QatRibbonGroups Property

IRibbonSectionQatRibbonGroups Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
QatRibbonGroupsConfigCollection QatRibbonGroups { get; }
property QatRibbonGroupsConfigCollection^ QatRibbonGroups {
    QatRibbonGroupsConfigCollection^ get ();
}

Property Value

Type: QatRibbonGroupsConfigCollection
See Also

Reference

IRibbonSection Interface
VisualComponents.UX.Shared Namespace


IRibbonSection.QatRibbonTools Property

IRibbonSectionQatRibbonTools Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
QatRibbonToolsConfigCollection QatRibbonTools { get; }
property QatRibbonToolsConfigCollection^ QatRibbonTools {
    QatRibbonToolsConfigCollection^ get ();
}

Property Value

Type: QatRibbonToolsConfigCollection
See Also

Reference

IRibbonSection Interface
VisualComponents.UX.Shared Namespace


IRibbonSection.RibbonSetting Property

IRibbonSectionRibbonSetting Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
RibbonConfigElement RibbonSetting { get; }
property RibbonConfigElement^ RibbonSetting {
    RibbonConfigElement^ get ();
}

Property Value

Type: RibbonConfigElement
See Also

Reference

IRibbonSection Interface
VisualComponents.UX.Shared Namespace


IRibbonSection Methods

The IRibbonSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion | Checks section version (Inherited from ISection.)
Public method | GetSection | Gets the section (Inherited from ISection.)
Top
See Also

Reference

IRibbonSection Interface
VisualComponents.UX.Shared Namespace


IRibbonTab Interface

Marker interface a ribbon tab item.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRibbonTab
public interface class IRibbonTab

The IRibbonTab type exposes the following members.

Properties
 | Name | Description
Public property | ContextualTabGroupKey | Returns the key of the contextualTabGroup to which the tab belongs.
Public property | Header | Returns the caption of the tab item.
Public property | Id | Get the unique identifier of tab item.
Public property | Name | Gets the identifying name of the element.
Public property | Order | Obsolete. Returns the index of the tab within the tabs collection.
Public property | RibbonGroups | Returns the collection of RibbonGroup instances that exist within the tab.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRibbonTab Properties

The IRibbonTab type exposes the following members.

Properties
 | Name | Description
Public property | ContextualTabGroupKey | Returns the key of the contextualTabGroup to which the tab belongs.
Public property | Header | Returns the caption of the tab item.
Public property | Id | Get the unique identifier of tab item.
Public property | Name | Gets the identifying name of the element.
Public property | Order | Obsolete. Returns the index of the tab within the tabs collection.
Public property | RibbonGroups | Returns the collection of RibbonGroup instances that exist within the tab.
Top
See Also

Reference

IRibbonTab Interface
VisualComponents.UX.Shared Namespace


IRibbonTab.ContextualTabGroupKey Property

IRibbonTabContextualTabGroupKey Property

Returns the key of the contextualTabGroup to which the tab belongs.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ContextualTabGroupKey { get; }
property String^ ContextualTabGroupKey {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IRibbonTab Interface
VisualComponents.UX.Shared Namespace


IRibbonTab.Header Property

IRibbonTabHeader Property

Returns the caption of the tab item.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Header { get; }
property String^ Header {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IRibbonTab Interface
VisualComponents.UX.Shared Namespace


IRibbonTab.Id Property

IRibbonTabId Property

Get the unique identifier of tab item.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Id { get; }
property String^ Id {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IRibbonTab Interface
VisualComponents.UX.Shared Namespace


IRibbonTab.Name Property

IRibbonTabName Property

Gets the identifying name of the element.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Name { get; }
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IRibbonTab Interface
VisualComponents.UX.Shared Namespace


IRibbonTab.Order Property

IRibbonTabOrder Property

Note: This API is now obsolete.

Returns the index of the tab within the tabs collection.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("This property is obsolete. To order tabs, Use IUXConfiguration.RegisterSite(UXSiteSetup , int) methode or SiteOrder in app.config file.",
    true)]
double Order { get; }
[ObsoleteAttribute(L"This property is obsolete. To order tabs, Use IUXConfiguration.RegisterSite(UXSiteSetup , int) methode or SiteOrder in app.config file.",
    true)]
property double Order {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IRibbonTab Interface
VisualComponents.UX.Shared Namespace


IRibbonTab.RibbonGroups Property

IRibbonTabRibbonGroups Property

Returns the collection of RibbonGroup instances that exist within the tab.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ObservableCollection<IRibbonGroup> RibbonGroups { get; }
property ObservableCollection<IRibbonGroup^>^ RibbonGroups {
    ObservableCollection<IRibbonGroup^>^ get ();
}

Property Value

Type: ObservableCollectionIRibbonGroup
See Also

Reference

IRibbonTab Interface
VisualComponents.UX.Shared Namespace


IRibbonToolCommand Interface

Implement for commands that should be presented as toggle tool .

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRibbonToolCommand
public interface class IRibbonToolCommand

The IRibbonToolCommand type exposes the following members.

Properties
 | Name | Description
Public property | ToolSize | Determines the sizing mode of a Menu tool which affects the size of a tool and whether it displays image, text or both.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRibbonToolCommand Properties

The IRibbonToolCommand type exposes the following members.

Properties
 | Name | Description
Public property | ToolSize | Determines the sizing mode of a Menu tool which affects the size of a tool and whether it displays image, text or both.
Top
See Also

Reference

IRibbonToolCommand Interface
VisualComponents.UX.Shared Namespace


IRibbonToolCommand.ToolSize Property

IRibbonToolCommandToolSize Property

Determines the sizing mode of a Menu tool which affects the size of a tool and whether it displays image, text or both.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ToolSizingMode ToolSize { get; }
property ToolSizingMode ToolSize {
    ToolSizingMode get ();
}

Property Value

Type: ToolSizingMode
See Also

Reference

IRibbonToolCommand Interface
VisualComponents.UX.Shared Namespace


IRibbonViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRibbonViewModel : IScreen,
    IHaveDisplayName, IActivate, IDeactivate, IGuardClose, IClose,
    INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IRibbonViewModel : IScreen,
    IHaveDisplayName, IActivate, IDeactivate, IGuardClose, IClose,
    INotifyPropertyChangedEx, INotifyPropertyChanged

The IRibbonViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActiveActions |
Public property | ActiveTab | Returns active ribbon tab name.
Public property | ActiveTabId |
Public property | ApplicationAccentColor |
Public property | BackstageViewModels |
Public property | CloseCommand |
Public property | CurrentFile |
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | InitialSelectedBackstageItem |
Public property | IsActive | (Inherited from IActivate.)
Public property | IsApplicationMenuOpen |
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsOpen |
Public property | SelectedApplicationMenuHeader |
Public property | Tabs |
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | ChangeSelectedApplicationMenuHeader |
Public method | CloseApplicationMenu |
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | GetTabOrder | Returns the index of the tab within the tabs collection.
Public method | InitializeRibbonItems | Method called to populate ribbon items.
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | OpenApplicationMenu |
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | ShowOrHideContextualtabGroup | A method used to show/hide the RibbonTabItem instances in the group's ContextualTabGroup.Tabs collection
Public method | TryClose | (Inherited from IClose.)
Public method | UpdateBackstage |
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | ApplicationMenuClosed | Occurs after ribbon application menu has been closed.
Public event | ApplicationMenuOpened | Occurs after ribbon application menu has been opened.
Public event | ApplicationMenuSelectionChanged | Occurs after selected application menu changed.
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Public event | RibbonInitialized | Event fired after ribbon items are initialized.
Public event | RibbonTabItemSelected | Obsolete.
Public event | RibbonTabSelected |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRibbonViewModel Properties

The IRibbonViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActiveActions |
Public property | ActiveTab | Returns active ribbon tab name.
Public property | ActiveTabId |
Public property | ApplicationAccentColor |
Public property | BackstageViewModels |
Public property | CloseCommand |
Public property | CurrentFile |
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | InitialSelectedBackstageItem |
Public property | IsActive | (Inherited from IActivate.)
Public property | IsApplicationMenuOpen |
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsOpen |
Public property | SelectedApplicationMenuHeader |
Public property | Tabs |
Top
See Also

Reference

IRibbonViewModel Interface
VisualComponents.UX.Shared Namespace


IRibbonViewModel.ActiveActions Property

IRibbonViewModelActiveActions Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IActionItem[] ActiveActions { get; }
property array<IActionItem^>^ ActiveActions {
    array<IActionItem^>^ get ();
}

Property Value

Type: IActionItem
See Also

Reference

IRibbonViewModel Interface
VisualComponents.UX.Shared Namespace


IRibbonViewModel.ActiveTab Property

IRibbonViewModelActiveTab Property

Returns active ribbon tab name.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ActiveTab { get; set; }
property String^ ActiveTab {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IRibbonViewModel Interface
VisualComponents.UX.Shared Namespace


IRibbonViewModel.ActiveTabId Property

IRibbonViewModelActiveTabId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ActiveTabId { get; }
property String^ ActiveTabId {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IRibbonViewModel Interface
VisualComponents.UX.Shared Namespace


IRibbonViewModel.ApplicationAccentColor Property

IRibbonViewModelApplicationAccentColor Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Color ApplicationAccentColor { get; set; }
property Color ApplicationAccentColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

IRibbonViewModel Interface
VisualComponents.UX.Shared Namespace


IRibbonViewModel.BackstageViewModels Property

IRibbonViewModelBackstageViewModels Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ObservableCollection<IBackstageViewModel> BackstageViewModels { get; }
property ObservableCollection<IBackstageViewModel^>^ BackstageViewModels {
    ObservableCollection<IBackstageViewModel^>^ get ();
}

Property Value

Type: ObservableCollectionIBackstageViewModel
See Also

Reference

IRibbonViewModel Interface
VisualComponents.UX.Shared Namespace


IRibbonViewModel.CloseCommand Property

IRibbonViewModelCloseCommand Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ICommand CloseCommand { get; }
property ICommand^ CloseCommand {
    ICommand^ get ();
}

Property Value

Type: ICommand
See Also

Reference

IRibbonViewModel Interface
VisualComponents.UX.Shared Namespace


IRibbonViewModel.CurrentFile Property

IRibbonViewModelCurrentFile Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string CurrentFile { get; }
property String^ CurrentFile {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IRibbonViewModel Interface
VisualComponents.UX.Shared Namespace


IRibbonViewModel.InitialSelectedBackstageItem Property

IRibbonViewModelInitialSelectedBackstageItem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IBackstageViewModel InitialSelectedBackstageItem { get; }
property IBackstageViewModel^ InitialSelectedBackstageItem {
    IBackstageViewModel^ get ();
}

Property Value

Type: IBackstageViewModel
See Also

Reference

IRibbonViewModel Interface
VisualComponents.UX.Shared Namespace


IRibbonViewModel.IsApplicationMenuOpen Property

IRibbonViewModelIsApplicationMenuOpen Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsApplicationMenuOpen { get; set; }
property bool IsApplicationMenuOpen {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRibbonViewModel Interface
VisualComponents.UX.Shared Namespace


IRibbonViewModel.IsOpen Property

IRibbonViewModelIsOpen Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsOpen { get; set; }
property bool IsOpen {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRibbonViewModel Interface
VisualComponents.UX.Shared Namespace


IRibbonViewModel.SelectedApplicationMenuHeader Property

IRibbonViewModelSelectedApplicationMenuHeader Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IBackstageViewModel SelectedApplicationMenuHeader { get; set; }
property IBackstageViewModel^ SelectedApplicationMenuHeader {
    IBackstageViewModel^ get ();
    void set (IBackstageViewModel^ value);
}

Property Value

Type: IBackstageViewModel
See Also

Reference

IRibbonViewModel Interface
VisualComponents.UX.Shared Namespace


IRibbonViewModel.Tabs Property

IRibbonViewModelTabs Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyCollection<IRibbonTab> Tabs { get; }
property IReadOnlyCollection<IRibbonTab^>^ Tabs {
    IReadOnlyCollection<IRibbonTab^>^ get ();
}

Property Value

Type: IReadOnlyCollectionIRibbonTab
See Also

Reference

IRibbonViewModel Interface
VisualComponents.UX.Shared Namespace


IRibbonViewModel Methods

The IRibbonViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | ChangeSelectedApplicationMenuHeader |
Public method | CloseApplicationMenu |
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | GetTabOrder | Returns the index of the tab within the tabs collection.
Public method | InitializeRibbonItems | Method called to populate ribbon items.
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | OpenApplicationMenu |
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | ShowOrHideContextualtabGroup | A method used to show/hide the RibbonTabItem instances in the group's ContextualTabGroup.Tabs collection
Public method | TryClose | (Inherited from IClose.)
Public method | UpdateBackstage |
Top
See Also

Reference

IRibbonViewModel Interface
VisualComponents.UX.Shared Namespace


IRibbonViewModel.ChangeSelectedApplicationMenuHeader Method

IRibbonViewModelChangeSelectedApplicationMenuHeader Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ChangeSelectedApplicationMenuHeader(
    string headerId
)
void ChangeSelectedApplicationMenuHeader(
    String^ headerId
)

Parameters

headerId
Type: SystemString
See Also

Reference

IRibbonViewModel Interface
VisualComponents.UX.Shared Namespace


IRibbonViewModel.CloseApplicationMenu Method

IRibbonViewModelCloseApplicationMenu Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void CloseApplicationMenu()
void CloseApplicationMenu()
See Also

Reference

IRibbonViewModel Interface
VisualComponents.UX.Shared Namespace


IRibbonViewModel.GetTabOrder Method

IRibbonViewModelGetTabOrder Method

Returns the index of the tab within the tabs collection.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int GetTabOrder(
    IRibbonTab tab
)
int GetTabOrder(
    IRibbonTab^ tab
)

Parameters

tab
Type: VisualComponents.UX.SharedIRibbonTab
The ribbon tab instance

Return Value

Type: Int32
order value
See Also

Reference

IRibbonViewModel Interface
VisualComponents.UX.Shared Namespace


IRibbonViewModel.InitializeRibbonItems Method

IRibbonViewModelInitializeRibbonItems Method

Method called to populate ribbon items.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void InitializeRibbonItems()
void InitializeRibbonItems()
See Also

Reference

IRibbonViewModel Interface
VisualComponents.UX.Shared Namespace


IRibbonViewModel.OpenApplicationMenu Method

IRibbonViewModelOpenApplicationMenu Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void OpenApplicationMenu(
    bool isOpen
)
void OpenApplicationMenu(
    bool isOpen
)

Parameters

isOpen
Type: SystemBoolean
See Also

Reference

IRibbonViewModel Interface
VisualComponents.UX.Shared Namespace


IRibbonViewModel.ShowOrHideContextualtabGroup Method

IRibbonViewModelShowOrHideContextualtabGroup Method

A method used to show/hide the RibbonTabItem instances in the group's ContextualTabGroup.Tabs collection

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ShowOrHideContextualtabGroup(
    string key,
    bool isVisible
)
void ShowOrHideContextualtabGroup(
    String^ key,
    bool isVisible
)

Parameters

key
Type: SystemString
The key ofcontextualTabGroup to show or hide
isVisible
Type: SystemBoolean
When set to true, all RibbonTabItem in the ContextualTabGroup will be shown.Otherwise False value hides any RibbonTabItem.
See Also

Reference

IRibbonViewModel Interface
VisualComponents.UX.Shared Namespace


IRibbonViewModel.UpdateBackstage Method

IRibbonViewModelUpdateBackstage Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateBackstage(
    bool isApplicationActivated
)
void UpdateBackstage(
    bool isApplicationActivated
)

Parameters

isApplicationActivated
Type: SystemBoolean
See Also

Reference

IRibbonViewModel Interface
VisualComponents.UX.Shared Namespace


IRibbonViewModel Events

The IRibbonViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | ApplicationMenuClosed | Occurs after ribbon application menu has been closed.
Public event | ApplicationMenuOpened | Occurs after ribbon application menu has been opened.
Public event | ApplicationMenuSelectionChanged | Occurs after selected application menu changed.
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Public event | RibbonInitialized | Event fired after ribbon items are initialized.
Public event | RibbonTabItemSelected | Obsolete.
Public event | RibbonTabSelected |
Top
See Also

Reference

IRibbonViewModel Interface
VisualComponents.UX.Shared Namespace


IRibbonViewModel.ApplicationMenuClosed Event

IRibbonViewModelApplicationMenuClosed Event

Occurs after ribbon application menu has been closed.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event OnApplicationMenuClosedHandler ApplicationMenuClosed
 event OnApplicationMenuClosedHandler^ ApplicationMenuClosed {
    void add (OnApplicationMenuClosedHandler^ value);
    void remove (OnApplicationMenuClosedHandler^ value);
}

Value

Type: VisualComponents.UX.SharedOnApplicationMenuClosedHandler
See Also

Reference

IRibbonViewModel Interface
VisualComponents.UX.Shared Namespace


IRibbonViewModel.ApplicationMenuOpened Event

IRibbonViewModelApplicationMenuOpened Event

Occurs after ribbon application menu has been opened.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event OnApplicationMenuOpenedHandler ApplicationMenuOpened
 event OnApplicationMenuOpenedHandler^ ApplicationMenuOpened {
    void add (OnApplicationMenuOpenedHandler^ value);
    void remove (OnApplicationMenuOpenedHandler^ value);
}

Value

Type: VisualComponents.UX.SharedOnApplicationMenuOpenedHandler
See Also

Reference

IRibbonViewModel Interface
VisualComponents.UX.Shared Namespace


IRibbonViewModel.ApplicationMenuSelectionChanged Event

IRibbonViewModelApplicationMenuSelectionChanged Event

Occurs after selected application menu changed.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event OnApplicationMenuSelectionChangedHandler ApplicationMenuSelectionChanged
 event OnApplicationMenuSelectionChangedHandler^ ApplicationMenuSelectionChanged {
    void add (OnApplicationMenuSelectionChangedHandler^ value);
    void remove (OnApplicationMenuSelectionChangedHandler^ value);
}

Value

Type: VisualComponents.UX.SharedOnApplicationMenuSelectionChangedHandler
See Also

Reference

IRibbonViewModel Interface
VisualComponents.UX.Shared Namespace


IRibbonViewModel.RibbonInitialized Event

IRibbonViewModelRibbonInitialized Event

Event fired after ribbon items are initialized.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event RibbonInitializedHandler RibbonInitialized
 event RibbonInitializedHandler^ RibbonInitialized {
    void add (RibbonInitializedHandler^ value);
    void remove (RibbonInitializedHandler^ value);
}

Value

Type: VisualComponents.UX.SharedRibbonInitializedHandler
See Also

Reference

IRibbonViewModel Interface
VisualComponents.UX.Shared Namespace


IRibbonViewModel.RibbonTabItemSelected Event

IRibbonViewModelRibbonTabItemSelected Event

Note: This API is now obsolete.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("This event is obsolete. Use RibbonTabSelected event instead.",
    false)]
event RibbonTabItemSelectedHandler RibbonTabItemSelected
[ObsoleteAttribute(L"This event is obsolete. Use RibbonTabSelected event instead.",
    false)]
 event RibbonTabItemSelectedHandler^ RibbonTabItemSelected {
    void add (RibbonTabItemSelectedHandler^ value);
    void remove (RibbonTabItemSelectedHandler^ value);
}

Value

Type: VisualComponents.UX.SharedRibbonTabItemSelectedHandler
See Also

Reference

IRibbonViewModel Interface
VisualComponents.UX.Shared Namespace


IRibbonViewModel.RibbonTabSelected Event

IRibbonViewModelRibbonTabSelected Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event RibbonTabSelectedHandler RibbonTabSelected
 event RibbonTabSelectedHandler^ RibbonTabSelected {
    void add (RibbonTabSelectedHandler^ value);
    void remove (RibbonTabSelectedHandler^ value);
}

Value

Type: VisualComponents.UX.SharedRibbonTabSelectedHandler
See Also

Reference

IRibbonViewModel Interface
VisualComponents.UX.Shared Namespace


IRobotConversionHelper Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRobotConversionHelper
public interface class IRobotConversionHelper

The IRobotConversionHelper type exposes the following members.

Methods
 | Name | Description
Public method | CheckAndConvert | This method checks if robot needs conversions and performs the conversion if needed
Public method | NeedConversion | This methods checks if a robot needs to be converted into the new robot program. It checks if the robot has an IRslExecutor and a program for it
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRobotConversionHelper Methods

The IRobotConversionHelper type exposes the following members.

Methods
 | Name | Description
Public method | CheckAndConvert | This method checks if robot needs conversions and performs the conversion if needed
Public method | NeedConversion | This methods checks if a robot needs to be converted into the new robot program. It checks if the robot has an IRslExecutor and a program for it
Top
See Also

Reference

IRobotConversionHelper Interface
VisualComponents.UX.Shared Namespace


IRobotConversionHelper.CheckAndConvert Method

IRobotConversionHelperCheckAndConvert Method

This method checks if robot needs conversions and performs the conversion if needed

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CheckAndConvert(
    IRobot robot,
    bool userAcknowledge
)
bool CheckAndConvert(
    IRobot^ robot,
    bool userAcknowledge
)

Parameters

robot
Type: VisualComponents.Create3DIRobot
robot to look at
userAcknowledge
Type: SystemBoolean
True if the method should ask for user acknowledge in case of conversion

Return Value

Type: Boolean
True if conversion was made
See Also

Reference

IRobotConversionHelper Interface
VisualComponents.UX.Shared Namespace


IRobotConversionHelper.NeedConversion Method

IRobotConversionHelperNeedConversion Method

This methods checks if a robot needs to be converted into the new robot program. It checks if the robot has an IRslExecutor and a program for it

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool NeedConversion(
    IRobot robot
)
bool NeedConversion(
    IRobot^ robot
)

Parameters

robot
Type: VisualComponents.Create3DIRobot
robot to check

Return Value

Type: Boolean
True if it needs conversion
See Also

Reference

IRobotConversionHelper Interface
VisualComponents.UX.Shared Namespace


IRobotFramesVisibilityAction Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRobotFramesVisibilityAction
public interface class IRobotFramesVisibilityAction

The IRobotFramesVisibilityAction type exposes the following members.

Properties
 | Name | Description
Public property | ReferencedRobots | Non selected robots which contains bases assigned via attached base to other component (turntable).
Public property | VisibleFrameRobots |
Top
Methods
 | Name | Description
Public method | SetRobotFramesVisibility | Obsolete. This will work only in teach context.
Public method | UpdateRobotFrameVisibility |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRobotFramesVisibilityAction Properties

The IRobotFramesVisibilityAction type exposes the following members.

Properties
 | Name | Description
Public property | ReferencedRobots | Non selected robots which contains bases assigned via attached base to other component (turntable).
Public property | VisibleFrameRobots |
Top
See Also

Reference

IRobotFramesVisibilityAction Interface
VisualComponents.UX.Shared Namespace


IRobotFramesVisibilityAction.ReferencedRobots Property

IRobotFramesVisibilityActionReferencedRobots Property

Non selected robots which contains bases assigned via attached base to other component (turntable).

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobot[] ReferencedRobots { get; }
property array<IRobot^>^ ReferencedRobots {
    array<IRobot^>^ get ();
}

Property Value

Type: IRobot
See Also

Reference

IRobotFramesVisibilityAction Interface
VisualComponents.UX.Shared Namespace


IRobotFramesVisibilityAction.VisibleFrameRobots Property

IRobotFramesVisibilityActionVisibleFrameRobots Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobot[] VisibleFrameRobots { get; }
property array<IRobot^>^ VisibleFrameRobots {
    array<IRobot^>^ get ();
}

Property Value

Type: IRobot
See Also

Reference

IRobotFramesVisibilityAction Interface
VisualComponents.UX.Shared Namespace


IRobotFramesVisibilityAction Methods

The IRobotFramesVisibilityAction type exposes the following members.

Methods
 | Name | Description
Public method | SetRobotFramesVisibility | Obsolete. This will work only in teach context.
Public method | UpdateRobotFrameVisibility |
Top
See Also

Reference

IRobotFramesVisibilityAction Interface
VisualComponents.UX.Shared Namespace


IRobotFramesVisibilityAction.SetRobotFramesVisibility Method

IRobotFramesVisibilityActionSetRobotFramesVisibility Method

Note: This API is now obsolete.

This will work only in teach context.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Use IFrameVisibilityTypeSettingsToolbarCommand.IsChecked and IRobotFrameVisibilityType.IsChecked.")]
void SetRobotFramesVisibility(
    bool globalFrameVisibility
)
[ObsoleteAttribute(L"Use IFrameVisibilityTypeSettingsToolbarCommand.IsChecked and IRobotFrameVisibilityType.IsChecked.")]
void SetRobotFramesVisibility(
    bool globalFrameVisibility
)

Parameters

globalFrameVisibility
Type: SystemBoolean
See Also

Reference

IRobotFramesVisibilityAction Interface
VisualComponents.UX.Shared Namespace


IRobotFramesVisibilityAction.UpdateRobotFrameVisibility Method

IRobotFramesVisibilityActionUpdateRobotFrameVisibility Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateRobotFrameVisibility()
void UpdateRobotFrameVisibility()
See Also

Reference

IRobotFramesVisibilityAction Interface
VisualComponents.UX.Shared Namespace


IRobotFrameVisibilityCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRobotFrameVisibilityCommand
public interface class IRobotFrameVisibilityCommand

The IRobotFrameVisibilityCommand type exposes the following members.

Properties
 | Name | Description
Public property | SelectedComboItem |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRobotFrameVisibilityCommand Properties

The IRobotFrameVisibilityCommand type exposes the following members.

Properties
 | Name | Description
Public property | SelectedComboItem |
Top
See Also

Reference

IRobotFrameVisibilityCommand Interface
VisualComponents.UX.Shared Namespace


IRobotFrameVisibilityCommand.SelectedComboItem Property

IRobotFrameVisibilityCommandSelectedComboItem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
RobotFrameVisibilityMode SelectedComboItem { get; set; }
property RobotFrameVisibilityMode SelectedComboItem {
    RobotFrameVisibilityMode get ();
    void set (RobotFrameVisibilityMode value);
}

Property Value

Type: RobotFrameVisibilityMode
See Also

Reference

IRobotFrameVisibilityCommand Interface
VisualComponents.UX.Shared Namespace


IRobotFrameVisibilityType Interface

Robot Frame visibility toggling command (not related to feature frames).

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRobotFrameVisibilityType : IFrameVisibilityType
public interface class IRobotFrameVisibilityType : IFrameVisibilityType

The IRobotFrameVisibilityType type exposes the following members.

Properties
 | Name | Description
Public property | IsChecked | (Inherited from IFrameVisibilityType.)
Top
Methods
 | Name | Description
Public method | Execute | (Inherited from IFrameVisibilityType.)
Public method | RefreshSettings | (Inherited from IFrameVisibilityType.)
Public method | UpdateRobotFrameVisibility |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRobotFrameVisibilityType Properties

The IRobotFrameVisibilityType type exposes the following members.

Properties
 | Name | Description
Public property | IsChecked | (Inherited from IFrameVisibilityType.)
Top
See Also

Reference

IRobotFrameVisibilityType Interface
VisualComponents.UX.Shared Namespace


IRobotFrameVisibilityType Methods

The IRobotFrameVisibilityType type exposes the following members.

Methods
 | Name | Description
Public method | Execute | (Inherited from IFrameVisibilityType.)
Public method | RefreshSettings | (Inherited from IFrameVisibilityType.)
Public method | UpdateRobotFrameVisibility |
Top
See Also

Reference

IRobotFrameVisibilityType Interface
VisualComponents.UX.Shared Namespace


IRobotFrameVisibilityType.UpdateRobotFrameVisibility Method

IRobotFrameVisibilityTypeUpdateRobotFrameVisibility Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateRobotFrameVisibility()
void UpdateRobotFrameVisibility()
See Also

Reference

IRobotFrameVisibilityType Interface
VisualComponents.UX.Shared Namespace


IRobotProgramEditor Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRobotProgramEditor : IHaveDisplayName
public interface class IRobotProgramEditor : IHaveDisplayName

The IRobotProgramEditor type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | Executor |
Top
Methods
 | Name | Description
Public method | Activate |
Public method | Deactivate |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRobotProgramEditor Properties

The IRobotProgramEditor type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | Executor |
Top
See Also

Reference

IRobotProgramEditor Interface
VisualComponents.UX.Shared Namespace


IRobotProgramEditor.Executor Property

IRobotProgramEditorExecutor Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IBehavior Executor { get; }
property IBehavior^ Executor {
    IBehavior^ get ();
}

Property Value

Type: IBehavior
See Also

Reference

IRobotProgramEditor Interface
VisualComponents.UX.Shared Namespace


IRobotProgramEditor Methods

The IRobotProgramEditor type exposes the following members.

Methods
 | Name | Description
Public method | Activate |
Public method | Deactivate |
Top
See Also

Reference

IRobotProgramEditor Interface
VisualComponents.UX.Shared Namespace


IRobotProgramEditor.Activate Method

IRobotProgramEditorActivate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Activate()
void Activate()
See Also

Reference

IRobotProgramEditor Interface
VisualComponents.UX.Shared Namespace


IRobotProgramEditor.Deactivate Method

IRobotProgramEditorDeactivate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Deactivate()
void Deactivate()
See Also

Reference

IRobotProgramEditor Interface
VisualComponents.UX.Shared Namespace


IRobotProgramEditorFactory Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRobotProgramEditorFactory
public interface class IRobotProgramEditorFactory

The IRobotProgramEditorFactory type exposes the following members.

Properties
 | Name | Description
Public property | CanCreate |
Public property | EditorType |
Top
Methods
 | Name | Description
Public method | CreateEditor |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRobotProgramEditorFactory Properties

The IRobotProgramEditorFactory type exposes the following members.

Properties
 | Name | Description
Public property | CanCreate |
Public property | EditorType |
Top
See Also

Reference

IRobotProgramEditorFactory Interface
VisualComponents.UX.Shared Namespace


IRobotProgramEditorFactory.CanCreate Property

IRobotProgramEditorFactoryCanCreate Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanCreate { get; }
property bool CanCreate {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IRobotProgramEditorFactory Interface
VisualComponents.UX.Shared Namespace


IRobotProgramEditorFactory.EditorType Property

IRobotProgramEditorFactoryEditorType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string EditorType { get; }
property String^ EditorType {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IRobotProgramEditorFactory Interface
VisualComponents.UX.Shared Namespace


IRobotProgramEditorFactory Methods

The IRobotProgramEditorFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateEditor |
Top
See Also

Reference

IRobotProgramEditorFactory Interface
VisualComponents.UX.Shared Namespace


IRobotProgramEditorFactory.CreateEditor Method

IRobotProgramEditorFactoryCreateEditor Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRobotProgramEditor CreateEditor(
    IBehavior executor
)
IRobotProgramEditor^ CreateEditor(
    IBehavior^ executor
)

Parameters

executor
Type: VisualComponents.Create3DIBehavior

Return Value

Type: IRobotProgramEditor

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IRobotProgramEditorFactory.CreateEditor(VisualComponents.Create3D.IBehavior)"]

See Also

Reference

IRobotProgramEditorFactory Interface
VisualComponents.UX.Shared Namespace


IRobotTeachOverlayViewModel Interface

Teach 3D overlay menu interface.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRobotTeachOverlayViewModel
public interface class IRobotTeachOverlayViewModel

The IRobotTeachOverlayViewModel type exposes the following members.

Properties
 | Name | Description
Public property | IsEnabled | Gets or sets the master 3D view teach menu visibility.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRobotTeachOverlayViewModel Properties

The IRobotTeachOverlayViewModel type exposes the following members.

Properties
 | Name | Description
Public property | IsEnabled | Gets or sets the master 3D view teach menu visibility.
Top
See Also

Reference

IRobotTeachOverlayViewModel Interface
VisualComponents.UX.Shared Namespace


IRobotTeachOverlayViewModel.IsEnabled Property

IRobotTeachOverlayViewModelIsEnabled Property

Gets or sets the master 3D view teach menu visibility.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsEnabled { get; set; }
property bool IsEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRobotTeachOverlayViewModel Interface
VisualComponents.UX.Shared Namespace


IRobotTeachViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRobotTeachViewModel : IDockableScreen,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IRobotTeachViewModel : IDockableScreen,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The IRobotTeachViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ContextFilter | Gets or sets the context filter. The context defines one or more contexts where the panel is visible. (Inherited from IDockableScreen.)
Public property | DesiredPanePosition | Gets the desired pane position. If multiple panes are added, panes are ordered using this property. (Inherited from IDockableScreen.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | Height | Gets the Height of the pane. (Inherited from IDockableScreen.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsPinned | Gets or sets a Boolean value that indicates if the pane is pinned. (Inherited from IDockableScreen.)
Public property | IsSelected | Gets or sets a boolean value that indicates if the pane is selected in TabGroupPane (Inherited from IDockableScreen.)
Public property | IsVisible | Gets or sets a boolean value that indicates if the pane is visible (Inherited from IDockableScreen.)
Public property | PanelId | Gets the panel ID (Inherited from IDockableScreen.)
Public property | PaneLocation | Gets the desired panel location DesiredPaneLocation (Inherited from IDockableScreen.)
Public property | PaneOrientation | Gets the pane orientation (Inherited from IDockableScreen.)
Public property | SplitPaneId | Gets the split pane id. By default all panes within panel location use same split panel. Multiple split panels can be created by defining new split pane ids. (Inherited from IDockableScreen.)
 | TabGroupId | Gets the pane tab group id. Panes are splitted and ordered to different tabs within the splitpane based on TabGroupId. (Inherited from IDockableScreen.)
Public property | Width | Gets the Width of the pane. (Inherited from IDockableScreen.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRobotTeachViewModel Properties

The IRobotTeachViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ContextFilter | Gets or sets the context filter. The context defines one or more contexts where the panel is visible. (Inherited from IDockableScreen.)
Public property | DesiredPanePosition | Gets the desired pane position. If multiple panes are added, panes are ordered using this property. (Inherited from IDockableScreen.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | Height | Gets the Height of the pane. (Inherited from IDockableScreen.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsPinned | Gets or sets a Boolean value that indicates if the pane is pinned. (Inherited from IDockableScreen.)
Public property | IsSelected | Gets or sets a boolean value that indicates if the pane is selected in TabGroupPane (Inherited from IDockableScreen.)
Public property | IsVisible | Gets or sets a boolean value that indicates if the pane is visible (Inherited from IDockableScreen.)
Public property | PanelId | Gets the panel ID (Inherited from IDockableScreen.)
Public property | PaneLocation | Gets the desired panel location DesiredPaneLocation (Inherited from IDockableScreen.)
Public property | PaneOrientation | Gets the pane orientation (Inherited from IDockableScreen.)
Public property | SplitPaneId | Gets the split pane id. By default all panes within panel location use same split panel. Multiple split panels can be created by defining new split pane ids. (Inherited from IDockableScreen.)
 | TabGroupId | Gets the pane tab group id. Panes are splitted and ordered to different tabs within the splitpane based on TabGroupId. (Inherited from IDockableScreen.)
Public property | Width | Gets the Width of the pane. (Inherited from IDockableScreen.)
Top
See Also

Reference

IRobotTeachViewModel Interface
VisualComponents.UX.Shared Namespace


IRobotTeachViewModel Methods

The IRobotTeachViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IRobotTeachViewModel Interface
VisualComponents.UX.Shared Namespace


IRobotTeachViewModel Events

The IRobotTeachViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IRobotTeachViewModel Interface
VisualComponents.UX.Shared Namespace


IRotateViewModel Interface

Rotate view model interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRotateViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IRotateViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The IRotateViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRotateViewModel Properties

The IRotateViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
See Also

Reference

IRotateViewModel Interface
VisualComponents.UX.Shared Namespace


IRotateViewModel Methods

The IRotateViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IRotateViewModel Interface
VisualComponents.UX.Shared Namespace


IRotateViewModel Events

The IRotateViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IRotateViewModel Interface
VisualComponents.UX.Shared Namespace


IRouteFixedLineViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRouteFixedLineViewModel : IRoutingRuleEditorLine
public interface class IRouteFixedLineViewModel : IRoutingRuleEditorLine

The IRouteFixedLineViewModel type exposes the following members.

Properties
 | Name | Description
Public property | Line | (Inherited from IRoutingRuleEditorLine.)
Public property | Model | (Inherited from IRoutingRuleEditorLine.)
Public property | RoutingRule | (Inherited from IRoutingRuleEditorLine.)
Public property | Statement | (Inherited from IRoutingRuleEditorLine.)
Top
Methods
 | Name | Description
Public method | init | (Inherited from IRoutingRuleEditorLine.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRouteFixedLineViewModel Properties

The IRouteFixedLineViewModel type exposes the following members.

Properties
 | Name | Description
Public property | Line | (Inherited from IRoutingRuleEditorLine.)
Public property | Model | (Inherited from IRoutingRuleEditorLine.)
Public property | RoutingRule | (Inherited from IRoutingRuleEditorLine.)
Public property | Statement | (Inherited from IRoutingRuleEditorLine.)
Top
See Also

Reference

IRouteFixedLineViewModel Interface
VisualComponents.UX.Shared Namespace


IRouteFixedLineViewModel Methods

The IRouteFixedLineViewModel type exposes the following members.

Methods
 | Name | Description
Public method | init | (Inherited from IRoutingRuleEditorLine.)
Top
See Also

Reference

IRouteFixedLineViewModel Interface
VisualComponents.UX.Shared Namespace


IRoutePercentageLineViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRoutePercentageLineViewModel : IRoutingRuleEditorLine
public interface class IRoutePercentageLineViewModel : IRoutingRuleEditorLine

The IRoutePercentageLineViewModel type exposes the following members.

Properties
 | Name | Description
Public property | Line | (Inherited from IRoutingRuleEditorLine.)
Public property | Model | (Inherited from IRoutingRuleEditorLine.)
Public property | RoutingRule | (Inherited from IRoutingRuleEditorLine.)
Public property | Statement | (Inherited from IRoutingRuleEditorLine.)
Top
Methods
 | Name | Description
Public method | init | (Inherited from IRoutingRuleEditorLine.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRoutePercentageLineViewModel Properties

The IRoutePercentageLineViewModel type exposes the following members.

Properties
 | Name | Description
Public property | Line | (Inherited from IRoutingRuleEditorLine.)
Public property | Model | (Inherited from IRoutingRuleEditorLine.)
Public property | RoutingRule | (Inherited from IRoutingRuleEditorLine.)
Public property | Statement | (Inherited from IRoutingRuleEditorLine.)
Top
See Also

Reference

IRoutePercentageLineViewModel Interface
VisualComponents.UX.Shared Namespace


IRoutePercentageLineViewModel Methods

The IRoutePercentageLineViewModel type exposes the following members.

Methods
 | Name | Description
Public method | init | (Inherited from IRoutingRuleEditorLine.)
Top
See Also

Reference

IRoutePercentageLineViewModel Interface
VisualComponents.UX.Shared Namespace


IRouteSimpleLineViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRouteSimpleLineViewModel : IRoutingRuleEditorLine
public interface class IRouteSimpleLineViewModel : IRoutingRuleEditorLine

The IRouteSimpleLineViewModel type exposes the following members.

Properties
 | Name | Description
Public property | Line | (Inherited from IRoutingRuleEditorLine.)
Public property | Model | (Inherited from IRoutingRuleEditorLine.)
Public property | RoutingRule | (Inherited from IRoutingRuleEditorLine.)
Public property | Statement | (Inherited from IRoutingRuleEditorLine.)
Top
Methods
 | Name | Description
Public method | init | (Inherited from IRoutingRuleEditorLine.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRouteSimpleLineViewModel Properties

The IRouteSimpleLineViewModel type exposes the following members.

Properties
 | Name | Description
Public property | Line | (Inherited from IRoutingRuleEditorLine.)
Public property | Model | (Inherited from IRoutingRuleEditorLine.)
Public property | RoutingRule | (Inherited from IRoutingRuleEditorLine.)
Public property | Statement | (Inherited from IRoutingRuleEditorLine.)
Top
See Also

Reference

IRouteSimpleLineViewModel Interface
VisualComponents.UX.Shared Namespace


IRouteSimpleLineViewModel Methods

The IRouteSimpleLineViewModel type exposes the following members.

Methods
 | Name | Description
Public method | init | (Inherited from IRoutingRuleEditorLine.)
Top
See Also

Reference

IRouteSimpleLineViewModel Interface
VisualComponents.UX.Shared Namespace


IRouteTableLineViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRouteTableLineViewModel : IRoutingRuleEditorLine
public interface class IRouteTableLineViewModel : IRoutingRuleEditorLine

The IRouteTableLineViewModel type exposes the following members.

Properties
 | Name | Description
Public property | Line | (Inherited from IRoutingRuleEditorLine.)
Public property | Model | (Inherited from IRoutingRuleEditorLine.)
Public property | RoutingRule | (Inherited from IRoutingRuleEditorLine.)
Public property | Statement | (Inherited from IRoutingRuleEditorLine.)
Top
Methods
 | Name | Description
Public method | init | (Inherited from IRoutingRuleEditorLine.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRouteTableLineViewModel Properties

The IRouteTableLineViewModel type exposes the following members.

Properties
 | Name | Description
Public property | Line | (Inherited from IRoutingRuleEditorLine.)
Public property | Model | (Inherited from IRoutingRuleEditorLine.)
Public property | RoutingRule | (Inherited from IRoutingRuleEditorLine.)
Public property | Statement | (Inherited from IRoutingRuleEditorLine.)
Top
See Also

Reference

IRouteTableLineViewModel Interface
VisualComponents.UX.Shared Namespace


IRouteTableLineViewModel Methods

The IRouteTableLineViewModel type exposes the following members.

Methods
 | Name | Description
Public method | init | (Inherited from IRoutingRuleEditorLine.)
Top
See Also

Reference

IRouteTableLineViewModel Interface
VisualComponents.UX.Shared Namespace


IRoutineVariablesEditorViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRoutineVariablesEditorViewModel
public interface class IRoutineVariablesEditorViewModel

The IRoutineVariablesEditorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | Routine |
Top
Methods
 | Name | Description
Public method | Init |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRoutineVariablesEditorViewModel Properties

The IRoutineVariablesEditorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | Routine |
Top
See Also

Reference

IRoutineVariablesEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IRoutineVariablesEditorViewModel.Routine Property

IRoutineVariablesEditorViewModelRoutine Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRoutine Routine { get; }
property IRoutine^ Routine {
    IRoutine^ get ();
}

Property Value

Type: IRoutine
See Also

Reference

IRoutineVariablesEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IRoutineVariablesEditorViewModel Methods

The IRoutineVariablesEditorViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Init |
Top
See Also

Reference

IRoutineVariablesEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IRoutineVariablesEditorViewModel.Init Method

IRoutineVariablesEditorViewModelInit Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Init()
void Init()
See Also

Reference

IRoutineVariablesEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IRoutingRuleEditorLine Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRoutingRuleEditorLine
public interface class IRoutingRuleEditorLine

The IRoutingRuleEditorLine type exposes the following members.

Properties
 | Name | Description
Public property | Line |
Public property | Model |
Public property | RoutingRule |
Public property | Statement |
Top
Methods
 | Name | Description
Public method | init |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRoutingRuleEditorLine Properties

The IRoutingRuleEditorLine type exposes the following members.

Properties
 | Name | Description
Public property | Line |
Public property | Model |
Public property | RoutingRule |
Public property | Statement |
Top
See Also

Reference

IRoutingRuleEditorLine Interface
VisualComponents.UX.Shared Namespace


IRoutingRuleEditorLine.Line Property

IRoutingRuleEditorLineLine Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRouteRuleLineStatement Line { get; set; }
property IRouteRuleLineStatement^ Line {
    IRouteRuleLineStatement^ get ();
    void set (IRouteRuleLineStatement^ value);
}

Property Value

Type: IRouteRuleLineStatement
See Also

Reference

IRoutingRuleEditorLine Interface
VisualComponents.UX.Shared Namespace


IRoutingRuleEditorLine.Model Property

IRoutingRuleEditorLineModel Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRoutingRuleEditorViewModel Model { get; set; }
property IRoutingRuleEditorViewModel^ Model {
    IRoutingRuleEditorViewModel^ get ();
    void set (IRoutingRuleEditorViewModel^ value);
}

Property Value

Type: IRoutingRuleEditorViewModel
See Also

Reference

IRoutingRuleEditorLine Interface
VisualComponents.UX.Shared Namespace


IRoutingRuleEditorLine.RoutingRule Property

IRoutingRuleEditorLineRoutingRule Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRoutingRule RoutingRule { get; set; }
property IRoutingRule^ RoutingRule {
    IRoutingRule^ get ();
    void set (IRoutingRule^ value);
}

Property Value

Type: IRoutingRule
See Also

Reference

IRoutingRuleEditorLine Interface
VisualComponents.UX.Shared Namespace


IRoutingRuleEditorLine.Statement Property

IRoutingRuleEditorLineStatement Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRouteRuleStatement Statement { get; set; }
property IRouteRuleStatement^ Statement {
    IRouteRuleStatement^ get ();
    void set (IRouteRuleStatement^ value);
}

Property Value

Type: IRouteRuleStatement
See Also

Reference

IRoutingRuleEditorLine Interface
VisualComponents.UX.Shared Namespace


IRoutingRuleEditorLine Methods

The IRoutingRuleEditorLine type exposes the following members.

Methods
 | Name | Description
Public method | init |
Top
See Also

Reference

IRoutingRuleEditorLine Interface
VisualComponents.UX.Shared Namespace


IRoutingRuleEditorLine.init Method

IRoutingRuleEditorLineinit Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void init()
void init()
See Also

Reference

IRoutingRuleEditorLine Interface
VisualComponents.UX.Shared Namespace


IRoutingRuleEditorViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRoutingRuleEditorViewModel : IRuleEditor
public interface class IRoutingRuleEditorViewModel : IRuleEditor

The IRoutingRuleEditorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActiveObject |
Public property | BOOLEANRULE | (Inherited from IRuleEditor.)
Public property | CAPACITYROUTE |
Public property | CYCLICROUTE |
Public property | DEFAULT | (Inherited from IRuleEditor.)
Public property | FIXEDROUTE |
Public property | INTEGERRULE | (Inherited from IRuleEditor.)
Public property | IsAuthoring | (Inherited from IRuleEditor.)
Public property | Name | (Inherited from IRuleEditor.)
Public property | PERCENTAGEROUTE |
Public property | REALRULE | (Inherited from IRuleEditor.)
Public property | RULE | (Inherited from IRuleEditor.)
Public property | STRINGRULE | (Inherited from IRuleEditor.)
Public property | TRANSPORTSOLUTIONRULE |
Public property | UNDEFINED | (Inherited from IRuleEditor.)
Top
Methods
 | Name | Description
Public method | AddStatement | (Inherited from IRuleEditor.)
Public method | Closing | (Inherited from IRuleEditor.)
Public method | GetConnectors |
Public method | ReloadLines | (Inherited from IRuleEditor.)
Public method | SelectedItemLineDelete |
Public method | SelectedItemLineMove |
Public method | SelectedItemLineUpdated | (Inherited from IRuleEditor.)
Public method | ShowAlert | (Inherited from IRuleEditor.)
Public method | StatementToLocalizedString | (Inherited from IRuleEditor.)
Public method | StringToStatement | (Inherited from IRuleEditor.)
Public method | UpdateDescription |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRoutingRuleEditorViewModel Properties

The IRoutingRuleEditorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActiveObject |
Public property | BOOLEANRULE | (Inherited from IRuleEditor.)
Public property | CAPACITYROUTE |
Public property | CYCLICROUTE |
Public property | DEFAULT | (Inherited from IRuleEditor.)
Public property | FIXEDROUTE |
Public property | INTEGERRULE | (Inherited from IRuleEditor.)
Public property | IsAuthoring | (Inherited from IRuleEditor.)
Public property | Name | (Inherited from IRuleEditor.)
Public property | PERCENTAGEROUTE |
Public property | REALRULE | (Inherited from IRuleEditor.)
Public property | RULE | (Inherited from IRuleEditor.)
Public property | STRINGRULE | (Inherited from IRuleEditor.)
Public property | TRANSPORTSOLUTIONRULE |
Public property | UNDEFINED | (Inherited from IRuleEditor.)
Top
See Also

Reference

IRoutingRuleEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IRoutingRuleEditorViewModel.ActiveObject Property

IRoutingRuleEditorViewModelActiveObject Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRoutingRule ActiveObject { get; set; }
property IRoutingRule^ ActiveObject {
    IRoutingRule^ get ();
    void set (IRoutingRule^ value);
}

Property Value

Type: IRoutingRule
See Also

Reference

IRoutingRuleEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IRoutingRuleEditorViewModel.CAPACITYROUTE Property

IRoutingRuleEditorViewModelCAPACITYROUTE Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string CAPACITYROUTE { get; }
property String^ CAPACITYROUTE {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IRoutingRuleEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IRoutingRuleEditorViewModel.CYCLICROUTE Property

IRoutingRuleEditorViewModelCYCLICROUTE Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string CYCLICROUTE { get; }
property String^ CYCLICROUTE {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IRoutingRuleEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IRoutingRuleEditorViewModel.FIXEDROUTE Property

IRoutingRuleEditorViewModelFIXEDROUTE Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string FIXEDROUTE { get; }
property String^ FIXEDROUTE {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IRoutingRuleEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IRoutingRuleEditorViewModel.PERCENTAGEROUTE Property

IRoutingRuleEditorViewModelPERCENTAGEROUTE Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string PERCENTAGEROUTE { get; }
property String^ PERCENTAGEROUTE {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IRoutingRuleEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IRoutingRuleEditorViewModel.TRANSPORTSOLUTIONRULE Property

IRoutingRuleEditorViewModelTRANSPORTSOLUTIONRULE Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string TRANSPORTSOLUTIONRULE { get; set; }
property String^ TRANSPORTSOLUTIONRULE {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IRoutingRuleEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IRoutingRuleEditorViewModel Methods

The IRoutingRuleEditorViewModel type exposes the following members.

Methods
 | Name | Description
Public method | AddStatement | (Inherited from IRuleEditor.)
Public method | Closing | (Inherited from IRuleEditor.)
Public method | GetConnectors |
Public method | ReloadLines | (Inherited from IRuleEditor.)
Public method | SelectedItemLineDelete |
Public method | SelectedItemLineMove |
Public method | SelectedItemLineUpdated | (Inherited from IRuleEditor.)
Public method | ShowAlert | (Inherited from IRuleEditor.)
Public method | StatementToLocalizedString | (Inherited from IRuleEditor.)
Public method | StringToStatement | (Inherited from IRuleEditor.)
Public method | UpdateDescription |
Top
See Also

Reference

IRoutingRuleEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IRoutingRuleEditorViewModel.GetConnectors Method

IRoutingRuleEditorViewModelGetConnectors Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ReadOnlyCollection<ISimConnector> GetConnectors()
ReadOnlyCollection<ISimConnector^>^ GetConnectors()

Return Value

Type: ReadOnlyCollectionISimConnector

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IRoutingRuleEditorViewModel.GetConnectors"]

See Also

Reference

IRoutingRuleEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IRoutingRuleEditorViewModel.SelectedItemLineDelete Method

IRoutingRuleEditorViewModelSelectedItemLineDelete Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SelectedItemLineDelete(
    IRouteRuleLineStatement line
)
void SelectedItemLineDelete(
    IRouteRuleLineStatement^ line
)

Parameters

line
Type: VisualComponents.Create3DIRouteRuleLineStatement
See Also

Reference

IRoutingRuleEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IRoutingRuleEditorViewModel.SelectedItemLineMove Method

IRoutingRuleEditorViewModelSelectedItemLineMove Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SelectedItemLineMove(
    IRouteRuleLineStatement line,
    int index
)
void SelectedItemLineMove(
    IRouteRuleLineStatement^ line,
    int index
)

Parameters

line
Type: VisualComponents.Create3DIRouteRuleLineStatement
index
Type: SystemInt32
See Also

Reference

IRoutingRuleEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IRoutingRuleEditorViewModel.UpdateDescription Method

IRoutingRuleEditorViewModelUpdateDescription Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateDescription(
    IRouteRuleLineStatement line
)
void UpdateDescription(
    IRouteRuleLineStatement^ line
)

Parameters

line
Type: VisualComponents.Create3DIRouteRuleLineStatement
See Also

Reference

IRoutingRuleEditorViewModel Interface
VisualComponents.UX.Shared Namespace


IRuleEditor Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IRuleEditor
public interface class IRuleEditor

The IRuleEditor type exposes the following members.

Properties
 | Name | Description
Public property | BOOLEANRULE |
Public property | DEFAULT |
Public property | INTEGERRULE |
Public property | IsAuthoring |
Public property | Name |
Public property | REALRULE |
Public property | RULE |
Public property | STRINGRULE |
Public property | UNDEFINED |
Top
Methods
 | Name | Description
Public method | AddStatement |
Public method | Closing |
Public method | ReloadLines |
Public method | SelectedItemLineUpdated |
Public method | ShowAlert |
Public method | StatementToLocalizedString |
Public method | StringToStatement |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IRuleEditor Properties

The IRuleEditor type exposes the following members.

Properties
 | Name | Description
Public property | BOOLEANRULE |
Public property | DEFAULT |
Public property | INTEGERRULE |
Public property | IsAuthoring |
Public property | Name |
Public property | REALRULE |
Public property | RULE |
Public property | STRINGRULE |
Public property | UNDEFINED |
Top
See Also

Reference

IRuleEditor Interface
VisualComponents.UX.Shared Namespace


IRuleEditor.BOOLEANRULE Property

IRuleEditorBOOLEANRULE Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string BOOLEANRULE { get; }
property String^ BOOLEANRULE {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IRuleEditor Interface
VisualComponents.UX.Shared Namespace


IRuleEditor.DEFAULT Property

IRuleEditorDEFAULT Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string DEFAULT { get; }
property String^ DEFAULT {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IRuleEditor Interface
VisualComponents.UX.Shared Namespace


IRuleEditor.INTEGERRULE Property

IRuleEditorINTEGERRULE Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string INTEGERRULE { get; }
property String^ INTEGERRULE {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IRuleEditor Interface
VisualComponents.UX.Shared Namespace


IRuleEditor.IsAuthoring Property

IRuleEditorIsAuthoring Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsAuthoring { get; set; }
property bool IsAuthoring {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IRuleEditor Interface
VisualComponents.UX.Shared Namespace


IRuleEditor.Name Property

IRuleEditorName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Name { get; }
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IRuleEditor Interface
VisualComponents.UX.Shared Namespace


IRuleEditor.REALRULE Property

IRuleEditorREALRULE Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string REALRULE { get; }
property String^ REALRULE {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IRuleEditor Interface
VisualComponents.UX.Shared Namespace


IRuleEditor.RULE Property

IRuleEditorRULE Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string RULE { get; }
property String^ RULE {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IRuleEditor Interface
VisualComponents.UX.Shared Namespace


IRuleEditor.STRINGRULE Property

IRuleEditorSTRINGRULE Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string STRINGRULE { get; }
property String^ STRINGRULE {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IRuleEditor Interface
VisualComponents.UX.Shared Namespace


IRuleEditor.UNDEFINED Property

IRuleEditorUNDEFINED Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string UNDEFINED { get; }
property String^ UNDEFINED {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IRuleEditor Interface
VisualComponents.UX.Shared Namespace


IRuleEditor Methods

The IRuleEditor type exposes the following members.

Methods
 | Name | Description
Public method | AddStatement |
Public method | Closing |
Public method | ReloadLines |
Public method | SelectedItemLineUpdated |
Public method | ShowAlert |
Public method | StatementToLocalizedString |
Public method | StringToStatement |
Top
See Also

Reference

IRuleEditor Interface
VisualComponents.UX.Shared Namespace


IRuleEditor.AddStatement Method

IRuleEditorAddStatement Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IStatement AddStatement(
    IStatementScope scope,
    Type type
)
IStatement^ AddStatement(
    IStatementScope^ scope,
    Type^ type
)

Parameters

scope
Type: VisualComponents.Create3DIStatementScope
type
Type: SystemType

Return Value

Type: IStatement

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IRuleEditor.AddStatement(VisualComponents.Create3D.IStatementScope,System.Type)"]

See Also

Reference

IRuleEditor Interface
VisualComponents.UX.Shared Namespace


IRuleEditor.Closing Method

IRuleEditorClosing Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Closing()
void Closing()
See Also

Reference

IRuleEditor Interface
VisualComponents.UX.Shared Namespace


IRuleEditor.ReloadLines Method

IRuleEditorReloadLines Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ReloadLines()
void ReloadLines()
See Also

Reference

IRuleEditor Interface
VisualComponents.UX.Shared Namespace


IRuleEditor.SelectedItemLineUpdated Method

IRuleEditorSelectedItemLineUpdated Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SelectedItemLineUpdated()
void SelectedItemLineUpdated()
See Also

Reference

IRuleEditor Interface
VisualComponents.UX.Shared Namespace


IRuleEditor.ShowAlert Method

IRuleEditorShowAlert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MessageBoxResult ShowAlert()
MessageBoxResult ShowAlert()

Return Value

Type: MessageBoxResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IRuleEditor.ShowAlert"]

See Also

Reference

IRuleEditor Interface
VisualComponents.UX.Shared Namespace


IRuleEditor.StatementToLocalizedString Method

IRuleEditorStatementToLocalizedString Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string StatementToLocalizedString(
    IStatement statement
)
String^ StatementToLocalizedString(
    IStatement^ statement
)

Parameters

statement
Type: VisualComponents.Create3DIStatement

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IRuleEditor.StatementToLocalizedString(VisualComponents.Create3D.IStatement)"]

See Also

Reference

IRuleEditor Interface
VisualComponents.UX.Shared Namespace


IRuleEditor.StringToStatement Method

IRuleEditorStringToStatement Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Type StringToStatement(
    string statementString,
    IStatement parent
)
Type^ StringToStatement(
    String^ statementString,
    IStatement^ parent
)

Parameters

statementString
Type: SystemString
parent
Type: VisualComponents.Create3DIStatement

Return Value

Type: Type

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IRuleEditor.StringToStatement(System.String,VisualComponents.Create3D.IStatement)"]

See Also

Reference

IRuleEditor Interface
VisualComponents.UX.Shared Namespace


ISaveComponentAction Interface

Action interface of component saving

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISaveComponentAction
public interface class ISaveComponentAction

The ISaveComponentAction type exposes the following members.

Properties
 | Name | Description
Public property | SaveType | Type of saving action
Top
Methods
 | Name | Description
Public method | CancelOperation | Cancel the action
Public method | StartAction | Start the action
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ISaveComponentAction Properties

The ISaveComponentAction type exposes the following members.

Properties
 | Name | Description
Public property | SaveType | Type of saving action
Top
See Also

Reference

ISaveComponentAction Interface
VisualComponents.UX.Shared Namespace


ISaveComponentAction.SaveType Property

ISaveComponentActionSaveType Property

Type of saving action

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
SaveComponentActionType SaveType { get; set; }
property SaveComponentActionType SaveType {
    SaveComponentActionType get ();
    void set (SaveComponentActionType value);
}

Property Value

Type: SaveComponentActionType
See Also

Reference

ISaveComponentAction Interface
VisualComponents.UX.Shared Namespace


ISaveComponentAction Methods

The ISaveComponentAction type exposes the following members.

Methods
 | Name | Description
Public method | CancelOperation | Cancel the action
Public method | StartAction | Start the action
Top
See Also

Reference

ISaveComponentAction Interface
VisualComponents.UX.Shared Namespace


ISaveComponentAction.CancelOperation Method

ISaveComponentActionCancelOperation Method

Cancel the action

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void CancelOperation()
void CancelOperation()
See Also

Reference

ISaveComponentAction Interface
VisualComponents.UX.Shared Namespace


ISaveComponentAction.StartAction Method

ISaveComponentActionStartAction Method

Start the action

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void StartAction(
    EventHandler<ResultCompletionEventArgs> completed = null
)
void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr
)

Parameters

completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs
callback of resulting function
See Also

Reference

ISaveComponentAction Interface
VisualComponents.UX.Shared Namespace


IsCheckedProxy Class

Helper class that allows to modify combobox Items without changing the selected item.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedIsCheckedProxy

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class IsCheckedProxy
public ref class IsCheckedProxy abstract sealed

The IsCheckedProxy type exposes the following members.

Methods
Name | Description
GetIsChecked |
SetIsChecked |
Top
Fields
Name | Description
IsCheckedProperty |
Top
Attached Properties
 | Name | Description
Public attached property | IsChecked |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IsCheckedProxy Methods

The IsCheckedProxy type exposes the following members.

Methods
Name | Description
GetIsChecked |
SetIsChecked |
Top
See Also

Reference

IsCheckedProxy Class
VisualComponents.UX.Shared Namespace


IsCheckedProxy.GetIsChecked Method

IsCheckedProxyGetIsChecked Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool GetIsChecked(
    UIElement element
)
public:
static bool GetIsChecked(
    UIElement^ element
)

Parameters

element
Type: System.WindowsUIElement

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IsCheckedProxy.GetIsChecked(System.Windows.UIElement)"]

See Also

Reference

IsCheckedProxy Class
VisualComponents.UX.Shared Namespace


IsCheckedProxy.SetIsChecked Method

IsCheckedProxySetIsChecked Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetIsChecked(
    UIElement element,
    bool value
)
public:
static void SetIsChecked(
    UIElement^ element,
    bool value
)

Parameters

element
Type: System.WindowsUIElement
value
Type: SystemBoolean
See Also

Reference

IsCheckedProxy Class
VisualComponents.UX.Shared Namespace


IsCheckedProxy Fields

The IsCheckedProxy type exposes the following members.

Fields
Name | Description
IsCheckedProperty |
Top
See Also

Reference

IsCheckedProxy Class
VisualComponents.UX.Shared Namespace


IsCheckedProxy.IsCheckedProperty Field

IsCheckedProxyIsCheckedProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty IsCheckedProperty
public:
static DependencyProperty^ IsCheckedProperty

Field Value

Type: DependencyProperty
See Also

Reference

IsCheckedProxy Class
VisualComponents.UX.Shared Namespace


IsCheckedProxy Attached Properties

The IsCheckedProxy type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | IsChecked |
Top
See Also

Reference

IsCheckedProxy Class
VisualComponents.UX.Shared Namespace


IsCheckedProxy.IsChecked Attached Property

IsCheckedProxyIsChecked Attached Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See GetIsChecked, SetIsChecked
See GetIsChecked, SetIsChecked

Property Value

Type: Boolean
See Also

Reference

IsCheckedProxy Class
VisualComponents.UX.Shared Namespace


ISectionEditorNotifier Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISectionEditorNotifier
public interface class ISectionEditorNotifier

The ISectionEditorNotifier type exposes the following members.

Methods
 | Name | Description
Public method | DeletedSectionField |
Public method | GetFieldPosition |
Public method | ReDoSectionFields |
Public method | ReorderSectionFields |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ISectionEditorNotifier Methods

The ISectionEditorNotifier type exposes the following members.

Methods
 | Name | Description
Public method | DeletedSectionField |
Public method | GetFieldPosition |
Public method | ReDoSectionFields |
Public method | ReorderSectionFields |
Top
See Also

Reference

ISectionEditorNotifier Interface
VisualComponents.UX.Shared Namespace


ISectionEditorNotifier.DeletedSectionField Method

ISectionEditorNotifierDeletedSectionField Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeletedSectionField()
void DeletedSectionField()
See Also

Reference

ISectionEditorNotifier Interface
VisualComponents.UX.Shared Namespace


ISectionEditorNotifier.GetFieldPosition Method

ISectionEditorNotifierGetFieldPosition Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int GetFieldPosition(
    ISimInterfaceField field
)
int GetFieldPosition(
    ISimInterfaceField^ field
)

Parameters

field
Type: VisualComponents.Create3DISimInterfaceField

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ISectionEditorNotifier.GetFieldPosition(VisualComponents.Create3D.ISimInterfaceField)"]

See Also

Reference

ISectionEditorNotifier Interface
VisualComponents.UX.Shared Namespace


ISectionEditorNotifier.ReDoSectionFields Method

ISectionEditorNotifierReDoSectionFields Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ReDoSectionFields(
    string name,
    string type,
    int positionInSection
)
void ReDoSectionFields(
    String^ name,
    String^ type,
    int positionInSection
)

Parameters

name
Type: SystemString
type
Type: SystemString
positionInSection
Type: SystemInt32
See Also

Reference

ISectionEditorNotifier Interface
VisualComponents.UX.Shared Namespace


ISectionEditorNotifier.ReorderSectionFields Method

ISectionEditorNotifierReorderSectionFields Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ReorderSectionFields()
void ReorderSectionFields()
See Also

Reference

ISectionEditorNotifier Interface
VisualComponents.UX.Shared Namespace


ISetActiveObjectsEx Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISetActiveObjectsEx
public interface class ISetActiveObjectsEx

The ISetActiveObjectsEx type exposes the following members.

Methods
 | Name | Description
Public method | SetActiveObjectsEx |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ISetActiveObjectsEx Methods

The ISetActiveObjectsEx type exposes the following members.

Methods
 | Name | Description
Public method | SetActiveObjectsEx |
Top
See Also

Reference

ISetActiveObjectsEx Interface
VisualComponents.UX.Shared Namespace


ISetActiveObjectsEx.SetActiveObjectsEx Method

ISetActiveObjectsExSetActiveObjectsEx Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetActiveObjectsEx(
    Object item,
    IList items
)
void SetActiveObjectsEx(
    Object^ item,
    IList^ items
)

Parameters

item
Type: SystemObject
items
Type: System.CollectionsIList
See Also

Reference

ISetActiveObjectsEx Interface
VisualComponents.UX.Shared Namespace


ISetOriginCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISetOriginCommand : ICommandPanelAction
public interface class ISetOriginCommand : ICommandPanelAction

The ISetOriginCommand type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Top
Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ISetOriginCommand Properties

The ISetOriginCommand type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

ISetOriginCommand Interface
VisualComponents.UX.Shared Namespace


ISetOriginCommand Methods

The ISetOriginCommand type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

ISetOriginCommand Interface
VisualComponents.UX.Shared Namespace


ISettingsHeadersViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISettingsHeadersViewModel
public interface class ISettingsHeadersViewModel
See Also

Reference

VisualComponents.UX.Shared Namespace


IShadingOptionCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IShadingOptionCommand
public interface class IShadingOptionCommand

The IShadingOptionCommand type exposes the following members.

Properties
 | Name | Description
Public property | ComboItems |
Public property | SelectedComboItem |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IShadingOptionCommand Properties

The IShadingOptionCommand type exposes the following members.

Properties
 | Name | Description
Public property | ComboItems |
Public property | SelectedComboItem |
Top
See Also

Reference

IShadingOptionCommand Interface
VisualComponents.UX.Shared Namespace


IShadingOptionCommand.ComboItems Property

IShadingOptionCommandComboItems Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ObservableCollection<ShadingMode> ComboItems { get; }
property ObservableCollection<ShadingMode>^ ComboItems {
    ObservableCollection<ShadingMode>^ get ();
}

Property Value

Type: ObservableCollectionShadingMode
See Also

Reference

IShadingOptionCommand Interface
VisualComponents.UX.Shared Namespace


IShadingOptionCommand.SelectedComboItem Property

IShadingOptionCommandSelectedComboItem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ShadingMode SelectedComboItem { get; set; }
property ShadingMode SelectedComboItem {
    ShadingMode get ();
    void set (ShadingMode value);
}

Property Value

Type: ShadingMode
See Also

Reference

IShadingOptionCommand Interface
VisualComponents.UX.Shared Namespace


IShell Interface

Application shell

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IShell : INotifyPropertyChanged, IGuardClose,
    IClose
public interface class IShell : INotifyPropertyChanged,
    IGuardClose, IClose

The IShell type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationTaskBarIcon | Application Icon that is to be added in window caption bar.
Public property | CanApplicationBeClosed |
Public property | CurrentFile | Local path and name of opened file
Public property | DownloadedInstallerFilePath | File path to downloaded software update installer.
Public property | IsApplicationClosing |
Public property | IsInteractionAllowed | If false, keyboard and mouse interaction with the main window is blocked.
Public property | IsShellViewInFullScreen |
Public property | IsSimulationControlVisibilityEnabled |
Public property | IsSimulationControlVisible |
Public property | OverlayWindow | Helper property used by ui-testing framework.
Public property | Viewport | Gets the main IViewport instance.
Top
Methods
 | Name | Description
Public method | ApplyUserSettings |
Public method | CanClose | (Inherited from IGuardClose.)
Public method | InitializePlugins | Initialize all imported IPLugin instances
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IShell Properties

The IShell type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationTaskBarIcon | Application Icon that is to be added in window caption bar.
Public property | CanApplicationBeClosed |
Public property | CurrentFile | Local path and name of opened file
Public property | DownloadedInstallerFilePath | File path to downloaded software update installer.
Public property | IsApplicationClosing |
Public property | IsInteractionAllowed | If false, keyboard and mouse interaction with the main window is blocked.
Public property | IsShellViewInFullScreen |
Public property | IsSimulationControlVisibilityEnabled |
Public property | IsSimulationControlVisible |
Public property | OverlayWindow | Helper property used by ui-testing framework.
Public property | Viewport | Gets the main IViewport instance.
Top
See Also

Reference

IShell Interface
VisualComponents.UX.Shared Namespace


IShell.ApplicationTaskBarIcon Property

IShellApplicationTaskBarIcon Property

Application Icon that is to be added in window caption bar.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
BitmapFrame ApplicationTaskBarIcon { get; }
property BitmapFrame^ ApplicationTaskBarIcon {
    BitmapFrame^ get ();
}

Property Value

Type: BitmapFrame
See Also

Reference

IShell Interface
VisualComponents.UX.Shared Namespace


IShell.CanApplicationBeClosed Property

IShellCanApplicationBeClosed Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool CanApplicationBeClosed { get; set; }
property bool CanApplicationBeClosed {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IShell Interface
VisualComponents.UX.Shared Namespace


IShell.CurrentFile Property

IShellCurrentFile Property

Local path and name of opened file

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string CurrentFile { get; }
property String^ CurrentFile {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IShell Interface
VisualComponents.UX.Shared Namespace


IShell.DownloadedInstallerFilePath Property

IShellDownloadedInstallerFilePath Property

File path to downloaded software update installer.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string DownloadedInstallerFilePath { get; set; }
property String^ DownloadedInstallerFilePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IShell Interface
VisualComponents.UX.Shared Namespace


IShell.IsApplicationClosing Property

IShellIsApplicationClosing Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsApplicationClosing { get; set; }
property bool IsApplicationClosing {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IShell Interface
VisualComponents.UX.Shared Namespace


IShell.IsInteractionAllowed Property

IShellIsInteractionAllowed Property

If false, keyboard and mouse interaction with the main window is blocked.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsInteractionAllowed { get; set; }
property bool IsInteractionAllowed {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IShell Interface
VisualComponents.UX.Shared Namespace


IShell.IsShellViewInFullScreen Property

IShellIsShellViewInFullScreen Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsShellViewInFullScreen { get; set; }
property bool IsShellViewInFullScreen {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IShell Interface
VisualComponents.UX.Shared Namespace


IShell.IsSimulationControlVisibilityEnabled Property

IShellIsSimulationControlVisibilityEnabled Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsSimulationControlVisibilityEnabled { get; }
property bool IsSimulationControlVisibilityEnabled {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IShell Interface
VisualComponents.UX.Shared Namespace


IShell.IsSimulationControlVisible Property

IShellIsSimulationControlVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsSimulationControlVisible { get; set; }
property bool IsSimulationControlVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IShell Interface
VisualComponents.UX.Shared Namespace


IShell.OverlayWindow Property

IShellOverlayWindow Property

Helper property used by ui-testing framework.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Window OverlayWindow { get; set; }
property Window^ OverlayWindow {
    Window^ get ();
    void set (Window^ value);
}

Property Value

Type: Window
See Also

Reference

IShell Interface
VisualComponents.UX.Shared Namespace


IShell.Viewport Property

IShellViewport Property

Gets the main IViewport instance.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IViewport Viewport { get; }
property IViewport^ Viewport {
    IViewport^ get ();
}

Property Value

Type: IViewport
See Also

Reference

IShell Interface
VisualComponents.UX.Shared Namespace


IShell Methods

The IShell type exposes the following members.

Methods
 | Name | Description
Public method | ApplyUserSettings |
Public method | CanClose | (Inherited from IGuardClose.)
Public method | InitializePlugins | Initialize all imported IPLugin instances
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IShell Interface
VisualComponents.UX.Shared Namespace


IShell.ApplyUserSettings Method

IShellApplyUserSettings Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ApplyUserSettings()
void ApplyUserSettings()
See Also

Reference

IShell Interface
VisualComponents.UX.Shared Namespace


IShell.InitializePlugins Method

IShellInitializePlugins Method

Initialize all imported IPLugin instances

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void InitializePlugins()
void InitializePlugins()
See Also

Reference

IShell Interface
VisualComponents.UX.Shared Namespace


IShell Events

The IShell type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IShell Interface
VisualComponents.UX.Shared Namespace


ISignalMapViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISignalMapViewModel
public interface class ISignalMapViewModel

The ISignalMapViewModel type exposes the following members.

Properties
 | Name | Description
Public property | IsEnabled |
Public property | MapType |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ISignalMapViewModel Properties

The ISignalMapViewModel type exposes the following members.

Properties
 | Name | Description
Public property | IsEnabled |
Public property | MapType |
Top
See Also

Reference

ISignalMapViewModel Interface
VisualComponents.UX.Shared Namespace


ISignalMapViewModel.IsEnabled Property

ISignalMapViewModelIsEnabled Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsEnabled { get; set; }
property bool IsEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISignalMapViewModel Interface
VisualComponents.UX.Shared Namespace


ISignalMapViewModel.MapType Property

ISignalMapViewModelMapType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
MapType MapType { get; set; }
property MapType MapType {
    MapType get ();
    void set (MapType value);
}

Property Value

Type: MapType
See Also

Reference

ISignalMapViewModel Interface
VisualComponents.UX.Shared Namespace


ISignalsVisibilityCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISignalsVisibilityCommand : ICheckBoxToolCommand
public interface class ISignalsVisibilityCommand : ICheckBoxToolCommand

The ISignalsVisibilityCommand type exposes the following members.

Properties
 | Name | Description
Public property | IsChecked | Gets or sets if the check box is checked. (Inherited from ICheckBoxToolCommand.)
Top
Methods
 | Name | Description
Public method | Update |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ISignalsVisibilityCommand Properties

The ISignalsVisibilityCommand type exposes the following members.

Properties
 | Name | Description
Public property | IsChecked | Gets or sets if the check box is checked. (Inherited from ICheckBoxToolCommand.)
Top
See Also

Reference

ISignalsVisibilityCommand Interface
VisualComponents.UX.Shared Namespace


ISignalsVisibilityCommand Methods

The ISignalsVisibilityCommand type exposes the following members.

Methods
 | Name | Description
Public method | Update |
Top
See Also

Reference

ISignalsVisibilityCommand Interface
VisualComponents.UX.Shared Namespace


ISignalsVisibilityCommand.Update Method

ISignalsVisibilityCommandUpdate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Update()
void Update()
See Also

Reference

ISignalsVisibilityCommand Interface
VisualComponents.UX.Shared Namespace


ISimplePropertyEditorViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimplePropertyEditorViewModel : IPropertyEditor,
    INotifyPropertyChanged
public interface class ISimplePropertyEditorViewModel : IPropertyEditor,
    INotifyPropertyChanged

The ISimplePropertyEditorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | DefinesName | Indicates that property panel doesn't need to display selected object's name (Inherited from IPropertyEditor.)
Public property | TranslateRotateVisibility | (Inherited from IPropertyEditor.)
Top
Methods
 | Name | Description
Public method | CanHandle | (Inherited from IPropertyEditor.)
Public method | Initialize | (Inherited from IPropertyEditor.)
Public method | SetActiveObjects | (Inherited from IPropertyEditor.)
Public method | SetFilter | (Inherited from IPropertyEditor.)
Public method | SortProperties | (Inherited from IPropertyEditor.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ISimplePropertyEditorViewModel Properties

The ISimplePropertyEditorViewModel type exposes the following members.

Properties
 | Name | Description
Public property | DefinesName | Indicates that property panel doesn't need to display selected object's name (Inherited from IPropertyEditor.)
Public property | TranslateRotateVisibility | (Inherited from IPropertyEditor.)
Top
See Also

Reference

ISimplePropertyEditorViewModel Interface
VisualComponents.UX.Shared Namespace


ISimplePropertyEditorViewModel Methods

The ISimplePropertyEditorViewModel type exposes the following members.

Methods
 | Name | Description
Public method | CanHandle | (Inherited from IPropertyEditor.)
Public method | Initialize | (Inherited from IPropertyEditor.)
Public method | SetActiveObjects | (Inherited from IPropertyEditor.)
Public method | SetFilter | (Inherited from IPropertyEditor.)
Public method | SortProperties | (Inherited from IPropertyEditor.)
Top
See Also

Reference

ISimplePropertyEditorViewModel Interface
VisualComponents.UX.Shared Namespace


ISimplePropertyEditorViewModel Events

The ISimplePropertyEditorViewModel type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

ISimplePropertyEditorViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationControlViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimulationControlViewModel : ISimulationService,
    INotifyPropertyChangedEx, INotifyPropertyChanged, IScreen, IHaveDisplayName, IActivate,
    IDeactivate, IGuardClose, IClose
public interface class ISimulationControlViewModel : ISimulationService,
    INotifyPropertyChangedEx, INotifyPropertyChanged, IScreen, IHaveDisplayName, IActivate,
    IDeactivate, IGuardClose, IClose

The ISimulationControlViewModel type exposes the following members.

Properties
Name | Description
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property Elapsed
Note: this is similar to ISimulation.Elapsed, but expressed in TimeSpan not seconds.
(Inherited from ISimulationService.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsAnimationRecordingButtonVisible
Public property | IsLooping | (Inherited from ISimulationService.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsRecordingOn | (Inherited from ISimulationService.)
Public property | IsSimulationAtStart | (Inherited from ISimulationService.)
Public property | IsSimulationClockVisible
Public property | IsSimulationPaused | (Inherited from ISimulationService.)
Public property | IsSimulationRecordingOn | (Inherited from ISimulationService.)
Public property IsSimulationRunning
Note: this can return false when simulation is technically running, but halt-event was already scheduled.
(Inherited from ISimulationService.)
Public property | IsStreamingOn | (Inherited from ISimulationService.)
Public property | IsVideoRecordingButtonVisible
Public property | SimulationMode | (Inherited from ISimulationService.)
Public property | SpeedFactor | (Inherited from ISimulationService.)
Public property | SpeedFactorInputValue | (Inherited from ISimulationService.)
Public property UseExternalClock
Defines if simulation is controlled by external clock. If this property is
Copy
true
simulation must be executed manually using Simulate(Double).
(Inherited from ISimulationService.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | KeepMenuToolOpen |
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | PauseSimulation | (Inherited from ISimulationService.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | RepeatSimulation | (Inherited from ISimulationService.)
Public method | ResetSimulation | (Inherited from ISimulationService.)
Public method | ResetSimulation(Boolean) | (Inherited from ISimulationService.)
Public method | ResetSpeedFactor | (Inherited from ISimulationService.)
Public method | RunSimulation | (Inherited from ISimulationService.)
Public method | SaveSimulationState | (Inherited from ISimulationService.)
Public method | SetSimulationMode | (Inherited from ISimulationService.)
Public method | SwitchRunState |
Public method | SwitchRunState(Double) | (Inherited from ISimulationService.)
Public method | SwitchRunState(Double, Double) | (Inherited from ISimulationService.)
Public method | TryClose | (Inherited from IClose.)
Public method | UpdateSimulationRecordingState | (Inherited from ISimulationService.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Public event | SimulationRunStateChanged |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ISimulationControlViewModel Properties

The ISimulationControlViewModel type exposes the following members.

Properties
Name | Description
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property Elapsed
Note: this is similar to ISimulation.Elapsed, but expressed in TimeSpan not seconds.
(Inherited from ISimulationService.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsAnimationRecordingButtonVisible
Public property | IsLooping | (Inherited from ISimulationService.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsRecordingOn | (Inherited from ISimulationService.)
Public property | IsSimulationAtStart | (Inherited from ISimulationService.)
Public property | IsSimulationClockVisible
Public property | IsSimulationPaused | (Inherited from ISimulationService.)
Public property | IsSimulationRecordingOn | (Inherited from ISimulationService.)
Public property IsSimulationRunning
Note: this can return false when simulation is technically running, but halt-event was already scheduled.
(Inherited from ISimulationService.)
Public property | IsStreamingOn | (Inherited from ISimulationService.)
Public property | IsVideoRecordingButtonVisible
Public property | SimulationMode | (Inherited from ISimulationService.)
Public property | SpeedFactor | (Inherited from ISimulationService.)
Public property | SpeedFactorInputValue | (Inherited from ISimulationService.)
Public property UseExternalClock
Defines if simulation is controlled by external clock. If this property is
Copy
true
simulation must be executed manually using Simulate(Double).
(Inherited from ISimulationService.)
Top
See Also

Reference

ISimulationControlViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationControlViewModel.IsAnimationRecordingButtonVisible Property

ISimulationControlViewModelIsAnimationRecordingButtonVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsAnimationRecordingButtonVisible { get; set; }
property bool IsAnimationRecordingButtonVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISimulationControlViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationControlViewModel.IsSimulationClockVisible Property

ISimulationControlViewModelIsSimulationClockVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsSimulationClockVisible { get; set; }
property bool IsSimulationClockVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISimulationControlViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationControlViewModel.IsVideoRecordingButtonVisible Property

ISimulationControlViewModelIsVideoRecordingButtonVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsVideoRecordingButtonVisible { get; set; }
property bool IsVideoRecordingButtonVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISimulationControlViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationControlViewModel Methods

The ISimulationControlViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | KeepMenuToolOpen |
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | PauseSimulation | (Inherited from ISimulationService.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | RepeatSimulation | (Inherited from ISimulationService.)
Public method | ResetSimulation | (Inherited from ISimulationService.)
Public method | ResetSimulation(Boolean) | (Inherited from ISimulationService.)
Public method | ResetSpeedFactor | (Inherited from ISimulationService.)
Public method | RunSimulation | (Inherited from ISimulationService.)
Public method | SaveSimulationState | (Inherited from ISimulationService.)
Public method | SetSimulationMode | (Inherited from ISimulationService.)
Public method | SwitchRunState |
Public method | SwitchRunState(Double) | (Inherited from ISimulationService.)
Public method | SwitchRunState(Double, Double) | (Inherited from ISimulationService.)
Public method | TryClose | (Inherited from IClose.)
Public method | UpdateSimulationRecordingState | (Inherited from ISimulationService.)
Top
See Also

Reference

ISimulationControlViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationControlViewModel.KeepMenuToolOpen Method

ISimulationControlViewModelKeepMenuToolOpen Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void KeepMenuToolOpen(
    string menuToolName,
    bool isOpen
)
void KeepMenuToolOpen(
    String^ menuToolName,
    bool isOpen
)

Parameters

menuToolName
Type: SystemString
isOpen
Type: SystemBoolean
See Also

Reference

ISimulationControlViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationControlViewModel.SwitchRunState Method

ISimulationControlViewModelSwitchRunState Method

Overload List
 | Name | Description
Public method | SwitchRunState |
Public method | SwitchRunState(Double) | (Inherited from ISimulationService.)
Public method | SwitchRunState(Double, Double) | (Inherited from ISimulationService.)
Top
See Also

Reference

ISimulationControlViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationControlViewModel.SwitchRunState Method

ISimulationControlViewModelSwitchRunState Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SwitchRunState()
void SwitchRunState()
See Also

Reference

ISimulationControlViewModel Interface
SwitchRunState Overload
VisualComponents.UX.Shared Namespace


ISimulationControlViewModel Events

The ISimulationControlViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Public event | SimulationRunStateChanged |
Top
See Also

Reference

ISimulationControlViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationControlViewModel.SimulationRunStateChanged Event

ISimulationControlViewModelSimulationRunStateChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<SimulationStateChangedEventArgs> SimulationRunStateChanged
 event EventHandler<SimulationStateChangedEventArgs^>^ SimulationRunStateChanged {
    void add (EventHandler<SimulationStateChangedEventArgs^>^ value);
    void remove (EventHandler<SimulationStateChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerSimulationStateChangedEventArgs
See Also

Reference

ISimulationControlViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationControlVisibilityCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimulationControlVisibilityCommand
public interface class ISimulationControlVisibilityCommand

The ISimulationControlVisibilityCommand type exposes the following members.

Properties
 | Name | Description
Public property | IsChecked |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ISimulationControlVisibilityCommand Properties

The ISimulationControlVisibilityCommand type exposes the following members.

Properties
 | Name | Description
Public property | IsChecked |
Top
See Also

Reference

ISimulationControlVisibilityCommand Interface
VisualComponents.UX.Shared Namespace


ISimulationControlVisibilityCommand.IsChecked Property

ISimulationControlVisibilityCommandIsChecked Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsChecked { get; }
property bool IsChecked {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimulationControlVisibilityCommand Interface
VisualComponents.UX.Shared Namespace


ISimulationNodeTreeViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimulationNodeTreeViewModel
public interface class ISimulationNodeTreeViewModel

The ISimulationNodeTreeViewModel type exposes the following members.

Properties
 | Name | Description
Public property | SelectedComponent |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ISimulationNodeTreeViewModel Properties

The ISimulationNodeTreeViewModel type exposes the following members.

Properties
 | Name | Description
Public property | SelectedComponent |
Top
See Also

Reference

ISimulationNodeTreeViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationNodeTreeViewModel.SelectedComponent Property

ISimulationNodeTreeViewModelSelectedComponent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent SelectedComponent { get; set; }
property ISimComponent^ SelectedComponent {
    ISimComponent^ get ();
    void set (ISimComponent^ value);
}

Property Value

Type: ISimComponent
See Also

Reference

ISimulationNodeTreeViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationSettingViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimulationSettingViewModel
public interface class ISimulationSettingViewModel

The ISimulationSettingViewModel type exposes the following members.

Properties
 | Name | Description
Public property | AllowTimeModeSwitching | Controls whether the Simulation Time Mode can be switched between Real and Virtual
Public property | SelectedClockDisplayMode |
Public property | SimulationMode |
Public property | SimulationRunTime | Simulation run time in second
Public property | SimulationRunTimeParts |
Public property | SimulationWarmUpTime | Simulation warm up time in second
Top
Methods
 | Name | Description
Public method | ConvertTimeToCanonical | helper function
Public method | OnShown |
Public method | SaveSimulationSettings |
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ISimulationSettingViewModel Properties

The ISimulationSettingViewModel type exposes the following members.

Properties
 | Name | Description
Public property | AllowTimeModeSwitching | Controls whether the Simulation Time Mode can be switched between Real and Virtual
Public property | SelectedClockDisplayMode |
Public property | SimulationMode |
Public property | SimulationRunTime | Simulation run time in second
Public property | SimulationRunTimeParts |
Public property | SimulationWarmUpTime | Simulation warm up time in second
Top
See Also

Reference

ISimulationSettingViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationSettingViewModel.AllowTimeModeSwitching Property

ISimulationSettingViewModelAllowTimeModeSwitching Property

Controls whether the Simulation Time Mode can be switched between Real and Virtual

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool AllowTimeModeSwitching { get; set; }
property bool AllowTimeModeSwitching {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISimulationSettingViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationSettingViewModel.SelectedClockDisplayMode Property

ISimulationSettingViewModelSelectedClockDisplayMode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ClockDisplayFormat SelectedClockDisplayMode { get; }
property ClockDisplayFormat SelectedClockDisplayMode {
    ClockDisplayFormat get ();
}

Property Value

Type: ClockDisplayFormat
See Also

Reference

ISimulationSettingViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationSettingViewModel.SimulationMode Property

ISimulationSettingViewModelSimulationMode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
SimulationTimeMode SimulationMode { get; set; }
property SimulationTimeMode SimulationMode {
    SimulationTimeMode get ();
    void set (SimulationTimeMode value);
}

Property Value

Type: SimulationTimeMode
See Also

Reference

ISimulationSettingViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationSettingViewModel.SimulationRunTime Property

ISimulationSettingViewModelSimulationRunTime Property

Simulation run time in second

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double SimulationRunTime { get; }
property double SimulationRunTime {
    double get ();
}

Property Value

Type: Double
See Also

Reference

ISimulationSettingViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationSettingViewModel.SimulationRunTimeParts Property

ISimulationSettingViewModelSimulationRunTimeParts Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ObservableCollection<VcTimePart> SimulationRunTimeParts { get; }
property ObservableCollection<VcTimePart>^ SimulationRunTimeParts {
    ObservableCollection<VcTimePart>^ get ();
}

Property Value

Type: ObservableCollectionVcTimePart
See Also

Reference

ISimulationSettingViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationSettingViewModel.SimulationWarmUpTime Property

ISimulationSettingViewModelSimulationWarmUpTime Property

Simulation warm up time in second

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double SimulationWarmUpTime { get; }
property double SimulationWarmUpTime {
    double get ();
}

Property Value

Type: Double
See Also

Reference

ISimulationSettingViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationSettingViewModel Methods

The ISimulationSettingViewModel type exposes the following members.

Methods
 | Name | Description
Public method | ConvertTimeToCanonical | helper function
Public method | OnShown |
Public method | SaveSimulationSettings |
Top
See Also

Reference

ISimulationSettingViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationSettingViewModel.ConvertTimeToCanonical Method

ISimulationSettingViewModelConvertTimeToCanonical Method

helper function

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double ConvertTimeToCanonical(
    IEnumerable<VcTimePart> vcTime
)
double ConvertTimeToCanonical(
    IEnumerable<VcTimePart>^ vcTime
)

Parameters

vcTime
Type: System.Collections.GenericIEnumerableVcTimePart

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ISimulationSettingViewModel.ConvertTimeToCanonical(System.Collections.Generic.IEnumerable{VisualComponents.UX.Shared.VcTimePart})"]

See Also

Reference

ISimulationSettingViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationSettingViewModel.OnShown Method

ISimulationSettingViewModelOnShown Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void OnShown(
    bool shown
)
void OnShown(
    bool shown
)

Parameters

shown
Type: SystemBoolean
See Also

Reference

ISimulationSettingViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationSettingViewModel.SaveSimulationSettings Method

ISimulationSettingViewModelSaveSimulationSettings Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SaveSimulationSettings()
void SaveSimulationSettings()
See Also

Reference

ISimulationSettingViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationSettingViewModel Events

The ISimulationSettingViewModel type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

ISimulationSettingViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationSettingViewModel.PropertyChanged Event

ISimulationSettingViewModelPropertyChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event PropertyChangedEventHandler PropertyChanged
 event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler
See Also

Reference

ISimulationSettingViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationWorldTreeviewViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISimulationWorldTreeviewViewModel : IHaveDisplayName
public interface class ISimulationWorldTreeviewViewModel : IHaveDisplayName

The ISimulationWorldTreeviewViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActiveWorldGraphView | World Graph view which is currently active.
Public property | AuthoringDualTreeViewModel | ViewModel which manages trees in IAuthorContext.
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsWorldGraphPanelVisible | Indicates whether World Graph panel is currently visible.
Public property | SelectedComponent |
Public property | WorldGraphViews | Collection of all registered World Graph views.
Top
Methods
 | Name | Description
Public method | ClearSelection |
Public method | UpdateTreeAndSelection |
Top
Events
 | Name | Description
Public event | ActiveWorldGraphViewChanged | Occurs when active World Graph view has changed.
Public event | ActiveWorldGraphViewChanging | Occurs when active World Graph view is about to be changed.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ISimulationWorldTreeviewViewModel Properties

The ISimulationWorldTreeviewViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActiveWorldGraphView | World Graph view which is currently active.
Public property | AuthoringDualTreeViewModel | ViewModel which manages trees in IAuthorContext.
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsWorldGraphPanelVisible | Indicates whether World Graph panel is currently visible.
Public property | SelectedComponent |
Public property | WorldGraphViews | Collection of all registered World Graph views.
Top
See Also

Reference

ISimulationWorldTreeviewViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationWorldTreeviewViewModel.ActiveWorldGraphView Property

ISimulationWorldTreeviewViewModelActiveWorldGraphView Property

World Graph view which is currently active.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IWorldGraphView ActiveWorldGraphView { get; set; }
property IWorldGraphView^ ActiveWorldGraphView {
    IWorldGraphView^ get ();
    void set (IWorldGraphView^ value);
}

Property Value

Type: IWorldGraphView
See Also

Reference

ISimulationWorldTreeviewViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationWorldTreeviewViewModel.AuthoringDualTreeViewModel Property

ISimulationWorldTreeviewViewModelAuthoringDualTreeViewModel Property

ViewModel which manages trees in IAuthorContext.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IAuthoringDualTreeViewModel AuthoringDualTreeViewModel { get; }
property IAuthoringDualTreeViewModel^ AuthoringDualTreeViewModel {
    IAuthoringDualTreeViewModel^ get ();
}

Property Value

Type: IAuthoringDualTreeViewModel
See Also

Reference

ISimulationWorldTreeviewViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationWorldTreeviewViewModel.IsWorldGraphPanelVisible Property

ISimulationWorldTreeviewViewModelIsWorldGraphPanelVisible Property

Indicates whether World Graph panel is currently visible.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsWorldGraphPanelVisible { get; }
property bool IsWorldGraphPanelVisible {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISimulationWorldTreeviewViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationWorldTreeviewViewModel.SelectedComponent Property

ISimulationWorldTreeviewViewModelSelectedComponent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ISimComponent SelectedComponent { get; set; }
property ISimComponent^ SelectedComponent {
    ISimComponent^ get ();
    void set (ISimComponent^ value);
}

Property Value

Type: ISimComponent
See Also

Reference

ISimulationWorldTreeviewViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationWorldTreeviewViewModel.WorldGraphViews Property

ISimulationWorldTreeviewViewModelWorldGraphViews Property

Collection of all registered World Graph views.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ObservableCollectionEx<IWorldGraphView> WorldGraphViews { get; }
property ObservableCollectionEx<IWorldGraphView^>^ WorldGraphViews {
    ObservableCollectionEx<IWorldGraphView^>^ get ();
}

Property Value

Type: ObservableCollectionEx IWorldGraphView
See Also

Reference

ISimulationWorldTreeviewViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationWorldTreeviewViewModel Methods

The ISimulationWorldTreeviewViewModel type exposes the following members.

Methods
 | Name | Description
Public method | ClearSelection |
Public method | UpdateTreeAndSelection |
Top
See Also

Reference

ISimulationWorldTreeviewViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationWorldTreeviewViewModel.ClearSelection Method

ISimulationWorldTreeviewViewModelClearSelection Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ClearSelection()
void ClearSelection()
See Also

Reference

ISimulationWorldTreeviewViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationWorldTreeviewViewModel.UpdateTreeAndSelection Method

ISimulationWorldTreeviewViewModelUpdateTreeAndSelection Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateTreeAndSelection()
void UpdateTreeAndSelection()
See Also

Reference

ISimulationWorldTreeviewViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationWorldTreeviewViewModel Events

The ISimulationWorldTreeviewViewModel type exposes the following members.

Events
 | Name | Description
Public event | ActiveWorldGraphViewChanged | Occurs when active World Graph view has changed.
Public event | ActiveWorldGraphViewChanging | Occurs when active World Graph view is about to be changed.
Top
See Also

Reference

ISimulationWorldTreeviewViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationWorldTreeviewViewModel.ActiveWorldGraphViewChanged Event

ISimulationWorldTreeviewViewModelActiveWorldGraphViewChanged Event

Occurs when active World Graph view has changed.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler ActiveWorldGraphViewChanged
 event EventHandler^ ActiveWorldGraphViewChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ISimulationWorldTreeviewViewModel Interface
VisualComponents.UX.Shared Namespace


ISimulationWorldTreeviewViewModel.ActiveWorldGraphViewChanging Event

ISimulationWorldTreeviewViewModelActiveWorldGraphViewChanging Event

Occurs when active World Graph view is about to be changed.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler ActiveWorldGraphViewChanging
 event EventHandler^ ActiveWorldGraphViewChanging {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ISimulationWorldTreeviewViewModel Interface
VisualComponents.UX.Shared Namespace


ISliceGeometryCommandViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISliceGeometryCommandViewModel
public interface class ISliceGeometryCommandViewModel

The ISliceGeometryCommandViewModel type exposes the following members.

Methods
 | Name | Description
Public method | NotifyOptionsChanged |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ISliceGeometryCommandViewModel Methods

The ISliceGeometryCommandViewModel type exposes the following members.

Methods
 | Name | Description
Public method | NotifyOptionsChanged |
Top
See Also

Reference

ISliceGeometryCommandViewModel Interface
VisualComponents.UX.Shared Namespace


ISliceGeometryCommandViewModel.NotifyOptionsChanged Method

ISliceGeometryCommandViewModelNotifyOptionsChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void NotifyOptionsChanged()
void NotifyOptionsChanged()
See Also

Reference

ISliceGeometryCommandViewModel Interface
VisualComponents.UX.Shared Namespace


ISnapAxisCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISnapAxisCommand
public interface class ISnapAxisCommand

The ISnapAxisCommand type exposes the following members.

Properties
 | Name | Description
Public property | SnapAxis |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ISnapAxisCommand Properties

The ISnapAxisCommand type exposes the following members.

Properties
 | Name | Description
Public property | SnapAxis |
Top
See Also

Reference

ISnapAxisCommand Interface
VisualComponents.UX.Shared Namespace


ISnapAxisCommand.SnapAxis Property

ISnapAxisCommandSnapAxis Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
AxisType SnapAxis { get; set; }
property AxisType SnapAxis {
    AxisType get ();
    void set (AxisType value);
}

Property Value

Type: AxisType
See Also

Reference

ISnapAxisCommand Interface
VisualComponents.UX.Shared Namespace


ISnapFiltersViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISnapFiltersViewModel : IScreen,
    IHaveDisplayName, IActivate, IDeactivate, IGuardClose, IClose,
    INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class ISnapFiltersViewModel : IScreen,
    IHaveDisplayName, IActivate, IDeactivate, IGuardClose, IClose,
    INotifyPropertyChangedEx, INotifyPropertyChanged

The ISnapFiltersViewModel type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | NotifyOptionsChanged |
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ISnapFiltersViewModel Properties

The ISnapFiltersViewModel type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Top
See Also

Reference

ISnapFiltersViewModel Interface
VisualComponents.UX.Shared Namespace


ISnapFiltersViewModel Methods

The ISnapFiltersViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | NotifyOptionsChanged |
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

ISnapFiltersViewModel Interface
VisualComponents.UX.Shared Namespace


ISnapFiltersViewModel.NotifyOptionsChanged Method

ISnapFiltersViewModelNotifyOptionsChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void NotifyOptionsChanged()
void NotifyOptionsChanged()
See Also

Reference

ISnapFiltersViewModel Interface
VisualComponents.UX.Shared Namespace


ISnapFiltersViewModel Events

The ISnapFiltersViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

ISnapFiltersViewModel Interface
VisualComponents.UX.Shared Namespace


ISnapOriginCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ISnapOriginCommand : ICommandPanelAction
public interface class ISnapOriginCommand : ICommandPanelAction

The ISnapOriginCommand type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | SnapPrimitiveAction |
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Top
Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ISnapOriginCommand Properties

The ISnapOriginCommand type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | SnapPrimitiveAction |
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

ISnapOriginCommand Interface
VisualComponents.UX.Shared Namespace


ISnapOriginCommand.SnapPrimitiveAction Property

ISnapOriginCommandSnapPrimitiveAction Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
SnapPrimitiveAction SnapPrimitiveAction { get; }
property SnapPrimitiveAction^ SnapPrimitiveAction {
    SnapPrimitiveAction^ get ();
}

Property Value

Type: SnapPrimitiveAction
See Also

Reference

ISnapOriginCommand Interface
VisualComponents.UX.Shared Namespace


ISnapOriginCommand Methods

The ISnapOriginCommand type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

ISnapOriginCommand Interface
VisualComponents.UX.Shared Namespace


IStandaloneActivatorPage Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IStandaloneActivatorPage
public interface class IStandaloneActivatorPage

The IStandaloneActivatorPage type exposes the following members.

Properties
 | Name | Description
Public property | PageName |
Public property | PageNumber |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IStandaloneActivatorPage Properties

The IStandaloneActivatorPage type exposes the following members.

Properties
 | Name | Description
Public property | PageName |
Public property | PageNumber |
Top
See Also

Reference

IStandaloneActivatorPage Interface
VisualComponents.UX.Shared Namespace


IStandaloneActivatorPage.PageName Property

IStandaloneActivatorPagePageName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string PageName { get; }
property String^ PageName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IStandaloneActivatorPage Interface
VisualComponents.UX.Shared Namespace


IStandaloneActivatorPage.PageNumber Property

IStandaloneActivatorPagePageNumber Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int PageNumber { get; }
property int PageNumber {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IStandaloneActivatorPage Interface
VisualComponents.UX.Shared Namespace


IStartPageViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IStartPageViewModel : IScreen,
    IHaveDisplayName, IActivate, IDeactivate, IGuardClose, IClose,
    INotifyPropertyChangedEx, INotifyPropertyChanged, IDocumentContent
public interface class IStartPageViewModel : IScreen,
    IHaveDisplayName, IActivate, IDeactivate, IGuardClose, IClose,
    INotifyPropertyChangedEx, INotifyPropertyChanged, IDocumentContent

The IStartPageViewModel type exposes the following members.

Properties
 | Name | Description
Public property | CanDragFromDocumentHost | (Inherited from IDocumentContent.)
Public property | CanDropToDocumentHost | (Inherited from IDocumentContent.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IStartPageViewModel Properties

The IStartPageViewModel type exposes the following members.

Properties
 | Name | Description
Public property | CanDragFromDocumentHost | (Inherited from IDocumentContent.)
Public property | CanDropToDocumentHost | (Inherited from IDocumentContent.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Top
See Also

Reference

IStartPageViewModel Interface
VisualComponents.UX.Shared Namespace


IStartPageViewModel Methods

The IStartPageViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

IStartPageViewModel Interface
VisualComponents.UX.Shared Namespace


IStartPageViewModel Events

The IStartPageViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IStartPageViewModel Interface
VisualComponents.UX.Shared Namespace


IStatementTree Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IStatementTree : IScreen,
    IHaveDisplayName, IActivate, IDeactivate, IGuardClose, IClose,
    INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IStatementTree : IScreen,
    IHaveDisplayName, IActivate, IDeactivate, IGuardClose, IClose,
    INotifyPropertyChangedEx, INotifyPropertyChanged

The IStatementTree type exposes the following members.

Properties
 | Name | Description
Public property | ActiveRoutine |
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | SelectionChanging |
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Public method | UpdateSelected |
Public method | UpdateTreeVisibilityMessage |
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Public event | StatementSelectionChanged | Statement Selection Changed.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IStatementTree Properties

The IStatementTree type exposes the following members.

Properties
 | Name | Description
Public property | ActiveRoutine |
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | SelectionChanging |
Top
See Also

Reference

IStatementTree Interface
VisualComponents.UX.Shared Namespace


IStatementTree.ActiveRoutine Property

IStatementTreeActiveRoutine Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRoutine ActiveRoutine { get; set; }
property IRoutine^ ActiveRoutine {
    IRoutine^ get ();
    void set (IRoutine^ value);
}

Property Value

Type: IRoutine
See Also

Reference

IStatementTree Interface
VisualComponents.UX.Shared Namespace


IStatementTree.SelectionChanging Property

IStatementTreeSelectionChanging Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool SelectionChanging { get; }
property bool SelectionChanging {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IStatementTree Interface
VisualComponents.UX.Shared Namespace


IStatementTree Methods

The IStatementTree type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Public method | UpdateSelected |
Public method | UpdateTreeVisibilityMessage |
Top
See Also

Reference

IStatementTree Interface
VisualComponents.UX.Shared Namespace


IStatementTree.UpdateSelected Method

IStatementTreeUpdateSelected Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateSelected()
void UpdateSelected()
See Also

Reference

IStatementTree Interface
VisualComponents.UX.Shared Namespace


IStatementTree.UpdateTreeVisibilityMessage Method

IStatementTreeUpdateTreeVisibilityMessage Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateTreeVisibilityMessage(
    string msg
)
void UpdateTreeVisibilityMessage(
    String^ msg
)

Parameters

msg
Type: SystemString
See Also

Reference

IStatementTree Interface
VisualComponents.UX.Shared Namespace


IStatementTree Events

The IStatementTree type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Public event | StatementSelectionChanged | Statement Selection Changed.
Top
See Also

Reference

IStatementTree Interface
VisualComponents.UX.Shared Namespace


IStatementTree.StatementSelectionChanged Event

IStatementTreeStatementSelectionChanged Event

Statement Selection Changed.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler StatementSelectionChanged
 event EventHandler^ StatementSelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IStatementTree Interface
VisualComponents.UX.Shared Namespace


IStatisticsPrintCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IStatisticsPrintCommand : IActionItem,
    INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IStatisticsPrintCommand : IActionItem,
    INotifyPropertyChangedEx, INotifyPropertyChanged

The IStatisticsPrintCommand type exposes the following members.

Properties
 | Name | Description
Public property | CanExecute | (Inherited from IActionItem.)
Public property | Content | Item text/header. (Inherited from IActionItem.)
Public property | ContextFilter | Defines application contexts where action is available. (Inherited from IActionItem.)
Public property | ControlType | (Inherited from IActionItem.)
Public property | IconName | Gets the icon name. (Inherited from IActionItem.)
Public property | Id | (Inherited from IActionItem.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | RibbonId | Required for ribbon only, as all items in ribbon groups are required to have a unique id. (Inherited from IActionItem.)
Public property | SiteOrder | (Inherited from IActionItem.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from IActionItem.)
Public property | Visibility | Item Visibility (Inherited from IActionItem.)
Top
Methods
 | Name | Description
Public method | EvaluateCanExecute | (Inherited from IActionItem.)
Public method | Execute | Note: When executed from UI buttons we also call BeforeExecute(). Note: This is executed from both r-click and normal UI buttons. If need to distinguish between executing 'with command panel' and 'immediate execution' inherit from ActionItemT1 and define both Execute() and Execute(bool). Note: Some actions also use IsChecked to execute. They call BeforeExecute() manually. (Inherited from IActionItem.)
Public method | Execute(PropertyCollection) | (Inherited from IActionItem.)
Public method | Execute(SetupPythonActionMessage) | Obsolete. (Inherited from IActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from IActionItem.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from IActionItem.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IStatisticsPrintCommand Properties

The IStatisticsPrintCommand type exposes the following members.

Properties
 | Name | Description
Public property | CanExecute | (Inherited from IActionItem.)
Public property | Content | Item text/header. (Inherited from IActionItem.)
Public property | ContextFilter | Defines application contexts where action is available. (Inherited from IActionItem.)
Public property | ControlType | (Inherited from IActionItem.)
Public property | IconName | Gets the icon name. (Inherited from IActionItem.)
Public property | Id | (Inherited from IActionItem.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | RibbonId | Required for ribbon only, as all items in ribbon groups are required to have a unique id. (Inherited from IActionItem.)
Public property | SiteOrder | (Inherited from IActionItem.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from IActionItem.)
Public property | Visibility | Item Visibility (Inherited from IActionItem.)
Top
See Also

Reference

IStatisticsPrintCommand Interface
VisualComponents.UX.Shared Namespace


IStatisticsPrintCommand Methods

The IStatisticsPrintCommand type exposes the following members.

Methods
 | Name | Description
Public method | EvaluateCanExecute | (Inherited from IActionItem.)
Public method | Execute | Note: When executed from UI buttons we also call BeforeExecute(). Note: This is executed from both r-click and normal UI buttons. If need to distinguish between executing 'with command panel' and 'immediate execution' inherit from ActionItemT1 and define both Execute() and Execute(bool). Note: Some actions also use IsChecked to execute. They call BeforeExecute() manually. (Inherited from IActionItem.)
Public method | Execute(PropertyCollection) | (Inherited from IActionItem.)
Public method | Execute(SetupPythonActionMessage) | Obsolete. (Inherited from IActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from IActionItem.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from IActionItem.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Top
See Also

Reference

IStatisticsPrintCommand Interface
VisualComponents.UX.Shared Namespace


IStatisticsPrintCommand Events

The IStatisticsPrintCommand type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IStatisticsPrintCommand Interface
VisualComponents.UX.Shared Namespace


IStatisticsStateMap Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IStatisticsStateMap
public interface class IStatisticsStateMap

The IStatisticsStateMap type exposes the following members.

Properties
 | Name | Description
Public property | StateName |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IStatisticsStateMap Properties

The IStatisticsStateMap type exposes the following members.

Properties
 | Name | Description
Public property | StateName |
Top
See Also

Reference

IStatisticsStateMap Interface
VisualComponents.UX.Shared Namespace


IStatisticsStateMap.StateName Property

IStatisticsStateMapStateName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string StateName { get; }
property String^ StateName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IStatisticsStateMap Interface
VisualComponents.UX.Shared Namespace


ITabPageViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ITabPageViewModel : IHaveDisplayName
public interface class ITabPageViewModel : IHaveDisplayName

The ITabPageViewModel type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Top
Methods
 | Name | Description
Public method | DoPropertyAlphabetizing |
Public method | DoPropertyCatagorizing |
Public method | SetFilter |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ITabPageViewModel Properties

The ITabPageViewModel type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Top
See Also

Reference

ITabPageViewModel Interface
VisualComponents.UX.Shared Namespace


ITabPageViewModel Methods

The ITabPageViewModel type exposes the following members.

Methods
 | Name | Description
Public method | DoPropertyAlphabetizing |
Public method | DoPropertyCatagorizing |
Public method | SetFilter |
Top
See Also

Reference

ITabPageViewModel Interface
VisualComponents.UX.Shared Namespace


ITabPageViewModel.DoPropertyAlphabetizing Method

ITabPageViewModelDoPropertyAlphabetizing Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DoPropertyAlphabetizing()
void DoPropertyAlphabetizing()
See Also

Reference

ITabPageViewModel Interface
VisualComponents.UX.Shared Namespace


ITabPageViewModel.DoPropertyCatagorizing Method

ITabPageViewModelDoPropertyCatagorizing Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DoPropertyCatagorizing()
void DoPropertyCatagorizing()
See Also

Reference

ITabPageViewModel Interface
VisualComponents.UX.Shared Namespace


ITabPageViewModel.SetFilter Method

ITabPageViewModelSetFilter Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SetFilter(
    string filter
)
void SetFilter(
    String^ filter
)

Parameters

filter
Type: SystemString
See Also

Reference

ITabPageViewModel Interface
VisualComponents.UX.Shared Namespace


ItemDropSide Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ItemDropSide
public enum class ItemDropSide
Members
Member name | Value | Description
Left | 0 |
Right | 1 |
Top | 2 |
Bottom | 3 |
Inside | 4 |
Last | 5 |
See Also

Reference

VisualComponents.UX.Shared Namespace


ItemsChangeObservableCollection(T) Class

ItemsChangeObservableCollectionT Class

This class adds the ability to refresh the list when any property of the objects changes in the list which implements the INotifyPropertyChanged.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollectionT
System.Collections.ObjectModelObservableCollectionT
VisualComponents.UX.SharedItemsChangeObservableCollectionT

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ItemsChangeObservableCollection<T> : ObservableCollection<T>
where T : INotifyPropertyChanged

generic<typename T>
where T : INotifyPropertyChanged
public ref class ItemsChangeObservableCollection : public ObservableCollection<T>

Type Parameters

T

The ItemsChangeObservableCollectionT type exposes the following members.

Constructors
 | Name | Description
Public method | ItemsChangeObservableCollectionT | Initializes a new instance of the ItemsChangeObservableCollectionT class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from CollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from CollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from CollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from CollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollectionT.)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from CollectionT.)
Protected method | ClearItems | (Overrides ObservableCollectionTClearItems.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from CollectionT.)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from CollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from CollectionT.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from CollectionT.)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from CollectionT.)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollectionT.)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollectionT.)
Protected method | OnCollectionChanged | (Overrides ObservableCollectionTOnCollectionChanged(NotifyCollectionChangedEventArgs).)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from CollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from CollectionT.)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollectionT.)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ItemsChangeObservableCollection(T) Constructor

ItemsChangeObservableCollectionT Constructor

Initializes a new instance of the ItemsChangeObservableCollectionT class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ItemsChangeObservableCollection()
public:
ItemsChangeObservableCollection()
See Also

Reference

ItemsChangeObservableCollectionT Class
VisualComponents.UX.Shared Namespace


ItemsChangeObservableCollection(T) Properties

ItemsChangeObservableCollectionT Properties

The ItemsChangeObservableCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from CollectionT .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from CollectionT .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from CollectionT .)
Top
See Also

Reference

ItemsChangeObservableCollectionT Class
VisualComponents.UX.Shared Namespace


ItemsChangeObservableCollection(T) Methods

ItemsChangeObservableCollectionT Methods

The ItemsChangeObservableCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from CollectionT .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollectionT .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollectionT .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from CollectionT .)
Protected method | ClearItems | (Overrides ObservableCollectionTClearItems.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from CollectionT .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from CollectionT .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from CollectionT .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from CollectionT .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from CollectionT .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollectionT .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollectionT .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollectionT .)
Protected method | OnCollectionChanged | (Overrides ObservableCollectionTOnCollectionChanged(NotifyCollectionChangedEventArgs).)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollectionT .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from CollectionT .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from CollectionT .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollectionT .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollectionT .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ItemsChangeObservableCollectionT Class
VisualComponents.UX.Shared Namespace


ItemsChangeObservableCollection(T).ClearItems Method

ItemsChangeObservableCollectionTClearItems Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void ClearItems()
protected:
virtual void ClearItems() override
See Also

Reference

ItemsChangeObservableCollectionT Class
VisualComponents.UX.Shared Namespace


ItemsChangeObservableCollection(T).OnCollectionChanged Method

ItemsChangeObservableCollectionTOnCollectionChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnCollectionChanged(
    NotifyCollectionChangedEventArgs e
)
protected:
virtual void OnCollectionChanged(
    NotifyCollectionChangedEventArgs^ e
) override

Parameters

e
Type: System.Collections.SpecializedNotifyCollectionChangedEventArgs
See Also

Reference

ItemsChangeObservableCollectionT Class
VisualComponents.UX.Shared Namespace


ItemsChangeObservableCollection(T) Events

ItemsChangeObservableCollectionT Events

The ItemsChangeObservableCollectionT generic type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollectionT .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollectionT .)
Top
See Also

Reference

ItemsChangeObservableCollectionT Class
VisualComponents.UX.Shared Namespace


ITextEditorTool Interface

Implement for commands that should be shown using texteditor tool in ribbon.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ITextEditorTool
public interface class ITextEditorTool

The ITextEditorTool type exposes the following members.

Properties
 | Name | Description
Public property | EditAreaWidth | Specifies the width of the edit area, excluding the label. Default value is 100.
Public property | IsReadOnly | Specifies whether the user is allowed to modify the value in the editor.
Public property | Text | Gets or sets the value of the editor as text.
Top
Methods
 | Name | Description
Public method | OnPreviewKeyDown |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ITextEditorTool Properties

The ITextEditorTool type exposes the following members.

Properties
 | Name | Description
Public property | EditAreaWidth | Specifies the width of the edit area, excluding the label. Default value is 100.
Public property | IsReadOnly | Specifies whether the user is allowed to modify the value in the editor.
Public property | Text | Gets or sets the value of the editor as text.
Top
See Also

Reference

ITextEditorTool Interface
VisualComponents.UX.Shared Namespace


ITextEditorTool.EditAreaWidth Property

ITextEditorToolEditAreaWidth Property

Specifies the width of the edit area, excluding the label. Default value is 100.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double EditAreaWidth { get; set; }
property double EditAreaWidth {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ITextEditorTool Interface
VisualComponents.UX.Shared Namespace


ITextEditorTool.IsReadOnly Property

ITextEditorToolIsReadOnly Property

Specifies whether the user is allowed to modify the value in the editor.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsReadOnly { get; set; }
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ITextEditorTool Interface
VisualComponents.UX.Shared Namespace


ITextEditorTool.Text Property

ITextEditorToolText Property

Gets or sets the value of the editor as text.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object Text { get; set; }
property Object^ Text {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

ITextEditorTool Interface
VisualComponents.UX.Shared Namespace


ITextEditorTool Methods

The ITextEditorTool type exposes the following members.

Methods
 | Name | Description
Public method | OnPreviewKeyDown |
Top
See Also

Reference

ITextEditorTool Interface
VisualComponents.UX.Shared Namespace


ITextEditorTool.OnPreviewKeyDown Method

ITextEditorToolOnPreviewKeyDown Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void OnPreviewKeyDown(
    string text,
    KeyEventArgs e
)
void OnPreviewKeyDown(
    String^ text,
    KeyEventArgs^ e
)

Parameters

text
Type: SystemString
e
Type: System.Windows.InputKeyEventArgs
See Also

Reference

ITextEditorTool Interface
VisualComponents.UX.Shared Namespace


ITextFieldEditorViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ITextFieldEditorViewModel
public interface class ITextFieldEditorViewModel
See Also

Reference

VisualComponents.UX.Shared Namespace


ITextureMappingAction Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ITextureMappingAction : INotAbortableCommand,
    ICommandPanelAction, IGeoFeatureBaseOperationLevelAction
public interface class ITextureMappingAction : INotAbortableCommand,
    ICommandPanelAction, IGeoFeatureBaseOperationLevelAction

The ITextureMappingAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | IsActive | (Inherited from IGeoFeatureBaseOperationLevelAction.)
Public property | Level | (Inherited from IGeoFeatureBaseOperationLevelAction.)
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Top
Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | DoAction |
Public method | FindFaces | (Inherited from IGeoFeatureBaseOperationLevelAction.)
Public method | SelectionMode |
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Public method | UpdateManipulator |
Public method | UpdateTiling |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ITextureMappingAction Properties

The ITextureMappingAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished | Indicates that action was already finished (because of some internal error, or by some other source). This flag is used only to skip calling CancelAction when it's not needed. Note: it's also possible to use FindCommandPanelActionT to check whether this action is active. (Inherited from ICommandPanelAction.)
Public property | ActionProperties | Action properties (Inherited from ICommandPanelAction.)
Public property | ApplyButtonText | String that is shown in the button that triggers the ApplyAction (Inherited from ICommandPanelAction.)
Public property | AssociatedModelId | Similar to ICommandViewModel.AssociatedCommandId but reversed. It should be the class name of the object implementing ICommandViewModel. (Inherited from ICommandPanelAction.)
Public property | AssociatedSiteId | Id used to find appropriate UxSite in app config. Both of these are done in GenericSnapActionViewModel.OnActivate. (Inherited from ICommandPanelAction.)
Public property | CallingCommandName | If launched from Python script the name of the calling python command. (Inherited from ICommandPanelAction.)
Public property | CancelButtonText | String that is shown in the button that triggers the CancelAction (Inherited from ICommandPanelAction.)
Public property | Description | Long description of what this action does. This text is dislayed along side of image. (Inherited from ICommandPanelAction.)
Public property | ErrorMessage | Error message (Inherited from ICommandPanelAction.)
Public property | IsActive | (Inherited from IGeoFeatureBaseOperationLevelAction.)
Public property | Level | (Inherited from IGeoFeatureBaseOperationLevelAction.)
Public property | Title | String that is shown in action panel title. (Inherited from ICommandPanelAction.)
Top
See Also

Reference

ITextureMappingAction Interface
VisualComponents.UX.Shared Namespace


ITextureMappingAction Methods

The ITextureMappingAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction | Executes command. Returning true will close the action panel. (Inherited from ICommandPanelAction.)
Public method | CancelAction | (Inherited from ICommandPanelAction.)
Public method | DoAction |
Public method | FindFaces | (Inherited from IGeoFeatureBaseOperationLevelAction.)
Public method | SelectionMode |
Public method | StartAction | Opens the UI. Called after action is fully configured. Usually called by ICommandRegistry.StartCommandPanelAction(), which also register this action in ICommandRegistry.CommandPanelActions. (Inherited from ICommandPanelAction.)
Public method | UpdateManipulator |
Public method | UpdateTiling |
Top
See Also

Reference

ITextureMappingAction Interface
VisualComponents.UX.Shared Namespace


ITextureMappingAction.DoAction Method

ITextureMappingActionDoAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DoAction()
void DoAction()
See Also

Reference

ITextureMappingAction Interface
VisualComponents.UX.Shared Namespace


ITextureMappingAction.SelectionMode Method

ITextureMappingActionSelectionMode Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void SelectionMode(
    FeatureOperationLevel mode
)
void SelectionMode(
    FeatureOperationLevel mode
)

Parameters

mode
Type: VisualComponents.Create3DFeatureOperationLevel
See Also

Reference

ITextureMappingAction Interface
VisualComponents.UX.Shared Namespace


ITextureMappingAction.UpdateManipulator Method

ITextureMappingActionUpdateManipulator Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateManipulator()
void UpdateManipulator()
See Also

Reference

ITextureMappingAction Interface
VisualComponents.UX.Shared Namespace


ITextureMappingAction.UpdateTiling Method

ITextureMappingActionUpdateTiling Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateTiling()
void UpdateTiling()
See Also

Reference

ITextureMappingAction Interface
VisualComponents.UX.Shared Namespace


ITextureMappingViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ITextureMappingViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class ITextureMappingViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The ITextureMappingViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Mode |
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Public property | Type |
Public property | UTiling |
Public property | VTiling |
Public property | X |
Public property | Y |
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ITextureMappingViewModel Properties

The ITextureMappingViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Mode |
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Public property | Type |
Public property | UTiling |
Public property | VTiling |
Public property | X |
Public property | Y |
Top
See Also

Reference

ITextureMappingViewModel Interface
VisualComponents.UX.Shared Namespace


ITextureMappingViewModel.Mode Property

ITextureMappingViewModelMode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
FeatureOperationLevel Mode { get; }
property FeatureOperationLevel Mode {
    FeatureOperationLevel get ();
}

Property Value

Type: FeatureOperationLevel
See Also

Reference

ITextureMappingViewModel Interface
VisualComponents.UX.Shared Namespace


ITextureMappingViewModel.Type Property

ITextureMappingViewModelType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ShapeMaipulatorType Type { get; }
property ShapeMaipulatorType Type {
    ShapeMaipulatorType get ();
}

Property Value

Type: ShapeMaipulatorType
See Also

Reference

ITextureMappingViewModel Interface
VisualComponents.UX.Shared Namespace


ITextureMappingViewModel.UTiling Property

ITextureMappingViewModelUTiling Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double UTiling { get; }
property double UTiling {
    double get ();
}

Property Value

Type: Double
See Also

Reference

ITextureMappingViewModel Interface
VisualComponents.UX.Shared Namespace


ITextureMappingViewModel.VTiling Property

ITextureMappingViewModelVTiling Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double VTiling { get; }
property double VTiling {
    double get ();
}

Property Value

Type: Double
See Also

Reference

ITextureMappingViewModel Interface
VisualComponents.UX.Shared Namespace


ITextureMappingViewModel.X Property

ITextureMappingViewModelX Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double X { get; }
property double X {
    double get ();
}

Property Value

Type: Double
See Also

Reference

ITextureMappingViewModel Interface
VisualComponents.UX.Shared Namespace


ITextureMappingViewModel.Y Property

ITextureMappingViewModelY Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double Y { get; }
property double Y {
    double get ();
}

Property Value

Type: Double
See Also

Reference

ITextureMappingViewModel Interface
VisualComponents.UX.Shared Namespace


ITextureMappingViewModel Methods

The ITextureMappingViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

ITextureMappingViewModel Interface
VisualComponents.UX.Shared Namespace


ITextureMappingViewModel Events

The ITextureMappingViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

ITextureMappingViewModel Interface
VisualComponents.UX.Shared Namespace


IToggleSnapFilterCommand Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IToggleSnapFilterCommand
public interface class IToggleSnapFilterCommand

The IToggleSnapFilterCommand type exposes the following members.

Properties
 | Name | Description
Public property | SnapTypes |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IToggleSnapFilterCommand Properties

The IToggleSnapFilterCommand type exposes the following members.

Properties
 | Name | Description
Public property | SnapTypes |
Top
See Also

Reference

IToggleSnapFilterCommand Interface
VisualComponents.UX.Shared Namespace


IToggleSnapFilterCommand.SnapTypes Property

IToggleSnapFilterCommandSnapTypes Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
SnapType[] SnapTypes { get; }
property array<SnapType>^ SnapTypes {
    array<SnapType>^ get ();
}

Property Value

Type: SnapType
See Also

Reference

IToggleSnapFilterCommand Interface
VisualComponents.UX.Shared Namespace


IToolTip Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IToolTip
public interface class IToolTip

The IToolTip type exposes the following members.

Properties
 | Name | Description
Public property | ImageSource |
Public property | ToolTipBookmark |
Public property | ToolTipContent |
Public property | ToolTipContentImage |
Public property | ToolTipFooter |
Public property | ToolTipFooterSeparatorVisibility |
Public property | ToolTipFooterVisibility |
Public property | ToolTipHeader |
Public property | ToolTipHeaderSeparatorVisibility |
Public property | ToolTipMoreInfoUrl |
Public property | ToolTipVisibility |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IToolTip Properties

The IToolTip type exposes the following members.

Properties
 | Name | Description
Public property | ImageSource |
Public property | ToolTipBookmark |
Public property | ToolTipContent |
Public property | ToolTipContentImage |
Public property | ToolTipFooter |
Public property | ToolTipFooterSeparatorVisibility |
Public property | ToolTipFooterVisibility |
Public property | ToolTipHeader |
Public property | ToolTipHeaderSeparatorVisibility |
Public property | ToolTipMoreInfoUrl |
Public property | ToolTipVisibility |
Top
See Also

Reference

IToolTip Interface
VisualComponents.UX.Shared Namespace


IToolTip.ImageSource Property

IToolTipImageSource Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ImageSource { get; set; }
property String^ ImageSource {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IToolTip Interface
VisualComponents.UX.Shared Namespace


IToolTip.ToolTipBookmark Property

IToolTipToolTipBookmark Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ToolTipBookmark { get; set; }
property String^ ToolTipBookmark {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IToolTip Interface
VisualComponents.UX.Shared Namespace


IToolTip.ToolTipContent Property

IToolTipToolTipContent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ToolTipContent { get; set; }
property String^ ToolTipContent {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IToolTip Interface
VisualComponents.UX.Shared Namespace


IToolTip.ToolTipContentImage Property

IToolTipToolTipContentImage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ToolTipContentImage { get; set; }
property String^ ToolTipContentImage {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IToolTip Interface
VisualComponents.UX.Shared Namespace


IToolTip.ToolTipFooter Property

IToolTipToolTipFooter Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ToolTipFooter { get; set; }
property String^ ToolTipFooter {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IToolTip Interface
VisualComponents.UX.Shared Namespace


IToolTip.ToolTipFooterSeparatorVisibility Property

IToolTipToolTipFooterSeparatorVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Visibility ToolTipFooterSeparatorVisibility { get; set; }
property Visibility ToolTipFooterSeparatorVisibility {
    Visibility get ();
    void set (Visibility value);
}

Property Value

Type: Visibility
See Also

Reference

IToolTip Interface
VisualComponents.UX.Shared Namespace


IToolTip.ToolTipFooterVisibility Property

IToolTipToolTipFooterVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Visibility ToolTipFooterVisibility { get; set; }
property Visibility ToolTipFooterVisibility {
    Visibility get ();
    void set (Visibility value);
}

Property Value

Type: Visibility
See Also

Reference

IToolTip Interface
VisualComponents.UX.Shared Namespace


IToolTip.ToolTipHeader Property

IToolTipToolTipHeader Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ToolTipHeader { get; set; }
property String^ ToolTipHeader {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IToolTip Interface
VisualComponents.UX.Shared Namespace


IToolTip.ToolTipHeaderSeparatorVisibility Property

IToolTipToolTipHeaderSeparatorVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Visibility ToolTipHeaderSeparatorVisibility { get; set; }
property Visibility ToolTipHeaderSeparatorVisibility {
    Visibility get ();
    void set (Visibility value);
}

Property Value

Type: Visibility
See Also

Reference

IToolTip Interface
VisualComponents.UX.Shared Namespace


IToolTip.ToolTipMoreInfoUrl Property

IToolTipToolTipMoreInfoUrl Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ToolTipMoreInfoUrl { get; set; }
property String^ ToolTipMoreInfoUrl {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IToolTip Interface
VisualComponents.UX.Shared Namespace


IToolTip.ToolTipVisibility Property

IToolTipToolTipVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Visibility ToolTipVisibility { get; set; }
property Visibility ToolTipVisibility {
    Visibility get ();
    void set (Visibility value);
}

Property Value

Type: Visibility
See Also

Reference

IToolTip Interface
VisualComponents.UX.Shared Namespace


IToolTipManager Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IToolTipManager
public interface class IToolTipManager
See Also

Reference

VisualComponents.UX.Shared Namespace


IToolTipPointerViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IToolTipPointerViewModel : IToolTipService
public interface class IToolTipPointerViewModel : IToolTipService

The IToolTipPointerViewModel type exposes the following members.

Properties
 | Name | Description
Public property | Description | (Inherited from IToolTipService.)
Public property | IsVisible | (Inherited from IToolTipService.)
Public property | Manager | (Inherited from IToolTipService.)
Public property | Title | (Inherited from IToolTipService.)
Public property | XPosition | (Inherited from IToolTipService.)
Public property | YPosition | (Inherited from IToolTipService.)
Top
Methods
 | Name | Description
Public method | AdjustFields | (Inherited from IToolTipService.)
Public method | Notify | (Inherited from IToolTipService.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IToolTipPointerViewModel Properties

The IToolTipPointerViewModel type exposes the following members.

Properties
 | Name | Description
Public property | Description | (Inherited from IToolTipService.)
Public property | IsVisible | (Inherited from IToolTipService.)
Public property | Manager | (Inherited from IToolTipService.)
Public property | Title | (Inherited from IToolTipService.)
Public property | XPosition | (Inherited from IToolTipService.)
Public property | YPosition | (Inherited from IToolTipService.)
Top
See Also

Reference

IToolTipPointerViewModel Interface
VisualComponents.UX.Shared Namespace


IToolTipPointerViewModel Methods

The IToolTipPointerViewModel type exposes the following members.

Methods
 | Name | Description
Public method | AdjustFields | (Inherited from IToolTipService.)
Public method | Notify | (Inherited from IToolTipService.)
Top
See Also

Reference

IToolTipPointerViewModel Interface
VisualComponents.UX.Shared Namespace


IToolTipService Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IToolTipService
public interface class IToolTipService

The IToolTipService type exposes the following members.

Properties
 | Name | Description
Public property | Description |
Public property | IsVisible |
Public property | Manager |
Public property | Title |
Public property | XPosition |
Public property | YPosition |
Top
Methods
 | Name | Description
Public method | AdjustFields |
Public method | Notify |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IToolTipService Properties

The IToolTipService type exposes the following members.

Properties
 | Name | Description
Public property | Description |
Public property | IsVisible |
Public property | Manager |
Public property | Title |
Public property | XPosition |
Public property | YPosition |
Top
See Also

Reference

IToolTipService Interface
VisualComponents.UX.Shared Namespace


IToolTipService.Description Property

IToolTipServiceDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Description { get; set; }
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IToolTipService Interface
VisualComponents.UX.Shared Namespace


IToolTipService.IsVisible Property

IToolTipServiceIsVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsVisible { get; set; }
property bool IsVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IToolTipService Interface
VisualComponents.UX.Shared Namespace


IToolTipService.Manager Property

IToolTipServiceManager Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IToolTipManager Manager { get; set; }
property IToolTipManager^ Manager {
    IToolTipManager^ get ();
    void set (IToolTipManager^ value);
}

Property Value

Type: IToolTipManager
See Also

Reference

IToolTipService Interface
VisualComponents.UX.Shared Namespace


IToolTipService.Title Property

IToolTipServiceTitle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Title { get; set; }
property String^ Title {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IToolTipService Interface
VisualComponents.UX.Shared Namespace


IToolTipService.XPosition Property

IToolTipServiceXPosition Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double XPosition { get; set; }
property double XPosition {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IToolTipService Interface
VisualComponents.UX.Shared Namespace


IToolTipService.YPosition Property

IToolTipServiceYPosition Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
double YPosition { get; set; }
property double YPosition {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IToolTipService Interface
VisualComponents.UX.Shared Namespace


IToolTipService Methods

The IToolTipService type exposes the following members.

Methods
 | Name | Description
Public method | AdjustFields |
Public method | Notify |
Top
See Also

Reference

IToolTipService Interface
VisualComponents.UX.Shared Namespace


IToolTipService.AdjustFields Method

IToolTipServiceAdjustFields Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void AdjustFields()
void AdjustFields()
See Also

Reference

IToolTipService Interface
VisualComponents.UX.Shared Namespace


IToolTipService.Notify Method

IToolTipServiceNotify Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Notify()
void Notify()
See Also

Reference

IToolTipService Interface
VisualComponents.UX.Shared Namespace


IToolTipViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IToolTipViewModel : IToolTipService
public interface class IToolTipViewModel : IToolTipService

The IToolTipViewModel type exposes the following members.

Properties
 | Name | Description
Public property | Description | (Inherited from IToolTipService.)
Public property | IsVisible | (Inherited from IToolTipService.)
Public property | Manager | (Inherited from IToolTipService.)
Public property | Title | (Inherited from IToolTipService.)
Public property | XPosition | (Inherited from IToolTipService.)
Public property | YPosition | (Inherited from IToolTipService.)
Top
Methods
 | Name | Description
Public method | AdjustFields | (Inherited from IToolTipService.)
Public method | Notify | (Inherited from IToolTipService.)
Public method | ProcessMessage |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IToolTipViewModel Properties

The IToolTipViewModel type exposes the following members.

Properties
 | Name | Description
Public property | Description | (Inherited from IToolTipService.)
Public property | IsVisible | (Inherited from IToolTipService.)
Public property | Manager | (Inherited from IToolTipService.)
Public property | Title | (Inherited from IToolTipService.)
Public property | XPosition | (Inherited from IToolTipService.)
Public property | YPosition | (Inherited from IToolTipService.)
Top
See Also

Reference

IToolTipViewModel Interface
VisualComponents.UX.Shared Namespace


IToolTipViewModel Methods

The IToolTipViewModel type exposes the following members.

Methods
 | Name | Description
Public method | AdjustFields | (Inherited from IToolTipService.)
Public method | Notify | (Inherited from IToolTipService.)
Public method | ProcessMessage |
Top
See Also

Reference

IToolTipViewModel Interface
VisualComponents.UX.Shared Namespace


IToolTipViewModel.ProcessMessage Method

IToolTipViewModelProcessMessage Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ProcessMessage(
    ToolTipDisplayMessage message
)
void ProcessMessage(
    ToolTipDisplayMessage^ message
)

Parameters

message
Type: VisualComponents.UX.SharedToolTipDisplayMessage
See Also

Reference

IToolTipViewModel Interface
VisualComponents.UX.Shared Namespace


ITranslateViewModel Interface

Translate view model interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ITranslateViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class ITranslateViewModel : ICommandViewModel,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The ITranslateViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ITranslateViewModel Properties

The ITranslateViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem | Action item (Inherited from ICommandViewModel.)
Public property | AssociatedCommandId | Id of command. (Inherited from ICommandViewModel.)
Public property | Description | Localized description shown in the help area of command panel. (Inherited from ICommandViewModel.)
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | Title | Localized title shown in title area of command panel. (Inherited from ICommandViewModel.)
Top
See Also

Reference

ITranslateViewModel Interface
VisualComponents.UX.Shared Namespace


ITranslateViewModel Methods

The ITranslateViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | Apply | Executes command. Returning true will close the action panel. (Inherited from ICommandViewModel.)
Public method | Cancel | Cancels command execution. (Inherited from ICommandViewModel.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Top
See Also

Reference

ITranslateViewModel Interface
VisualComponents.UX.Shared Namespace


ITranslateViewModel Events

The ITranslateViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

ITranslateViewModel Interface
VisualComponents.UX.Shared Namespace


ITreeNode Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ITreeNode : INamed
public interface class ITreeNode : INamed

The ITreeNode type exposes the following members.

Properties
 | Name | Description
Public property | Children |
Public property | HasChildren |
Public property | HasExpanded |
Public property | Id |
Public property | IsExpanded |
Public property | IsMarker |
Public property | IsSelected | Note: this should only be used for reading selection status. Also see XamTreeEx.IsSelected(node) and XamTreeEx.SetSelection(nodes).
Public property | IsValid |
Public property | IsVisibleInGui |
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeType |
Public property | Parent |
Public property | Source |
Top
Methods
 | Name | Description
Public method | AcceptDrop(ITreeNode) |
Public method | AcceptDrop(ITreeNode, Int32) |
Public method | DropNode(ITreeNode) | Drag source is added as a child to this node.
Public method | DropNode(ITreeNode, Int32, ITreeNode, DropType) | Drag source is added a child to this node using given index position.
Public method | FindChild |
Public method | RefreshChildren |
Public method | RemoveChild |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ITreeNode Properties

The ITreeNode type exposes the following members.

Properties
 | Name | Description
Public property | Children |
Public property | HasChildren |
Public property | HasExpanded |
Public property | Id |
Public property | IsExpanded |
Public property | IsMarker |
Public property | IsSelected | Note: this should only be used for reading selection status. Also see XamTreeEx.IsSelected(node) and XamTreeEx.SetSelection(nodes).
Public property | IsValid |
Public property | IsVisibleInGui |
Public property | Name | Retrieves or sets the name of the object (Inherited from INamed.)
Public property | NodeType |
Public property | Parent |
Public property | Source |
Top
See Also

Reference

ITreeNode Interface
VisualComponents.UX.Shared Namespace


ITreeNode.Children Property

ITreeNodeChildren Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IReadOnlyList<ITreeNode> Children { get; }
property IReadOnlyList<ITreeNode^>^ Children {
    IReadOnlyList<ITreeNode^>^ get ();
}

Property Value

Type: IReadOnlyListITreeNode
See Also

Reference

ITreeNode Interface
VisualComponents.UX.Shared Namespace


ITreeNode.HasChildren Property

ITreeNodeHasChildren Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool HasChildren { get; }
property bool HasChildren {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ITreeNode Interface
VisualComponents.UX.Shared Namespace


ITreeNode.HasExpanded Property

ITreeNodeHasExpanded Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool HasExpanded { get; set; }
property bool HasExpanded {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ITreeNode Interface
VisualComponents.UX.Shared Namespace


ITreeNode.Id Property

ITreeNodeId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int Id { get; }
property int Id {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ITreeNode Interface
VisualComponents.UX.Shared Namespace


ITreeNode.IsExpanded Property

ITreeNodeIsExpanded Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsExpanded { get; set; }
property bool IsExpanded {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ITreeNode Interface
VisualComponents.UX.Shared Namespace


ITreeNode.IsMarker Property

ITreeNodeIsMarker Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsMarker { get; }
property bool IsMarker {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ITreeNode Interface
VisualComponents.UX.Shared Namespace


ITreeNode.IsSelected Property

ITreeNodeIsSelected Property

Note: this should only be used for reading selection status. Also see XamTreeEx.IsSelected(node) and XamTreeEx.SetSelection(nodes).

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsSelected { get; set; }
property bool IsSelected {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ITreeNode Interface
VisualComponents.UX.Shared Namespace


ITreeNode.IsValid Property

ITreeNodeIsValid Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsValid { get; }
property bool IsValid {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ITreeNode Interface
VisualComponents.UX.Shared Namespace


ITreeNode.IsVisibleInGui Property

ITreeNodeIsVisibleInGui Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsVisibleInGui { get; set; }
property bool IsVisibleInGui {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ITreeNode Interface
VisualComponents.UX.Shared Namespace


ITreeNode.NodeType Property

ITreeNodeNodeType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
TreeNodeType NodeType { get; }
property TreeNodeType NodeType {
    TreeNodeType get ();
}

Property Value

Type: TreeNodeType
See Also

Reference

ITreeNode Interface
VisualComponents.UX.Shared Namespace


ITreeNode.Parent Property

ITreeNodeParent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
ITreeNode Parent { get; }
property ITreeNode^ Parent {
    ITreeNode^ get ();
}

Property Value

Type: ITreeNode
See Also

Reference

ITreeNode Interface
VisualComponents.UX.Shared Namespace


ITreeNode.Source Property

ITreeNodeSource Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
INamed Source { get; }
property INamed^ Source {
    INamed^ get ();
}

Property Value

Type: INamed
See Also

Reference

ITreeNode Interface
VisualComponents.UX.Shared Namespace


ITreeNode Methods

The ITreeNode type exposes the following members.

Methods
 | Name | Description
Public method | AcceptDrop(ITreeNode) |
Public method | AcceptDrop(ITreeNode, Int32) |
Public method | DropNode(ITreeNode) | Drag source is added as a child to this node.
Public method | DropNode(ITreeNode, Int32, ITreeNode, DropType) | Drag source is added a child to this node using given index position.
Public method | FindChild |
Public method | RefreshChildren |
Public method | RemoveChild |
Top
See Also

Reference

ITreeNode Interface
VisualComponents.UX.Shared Namespace


ITreeNode.AcceptDrop Method

ITreeNodeAcceptDrop Method

Overload List
 | Name | Description
Public method | AcceptDrop(ITreeNode) |
Public method | AcceptDrop(ITreeNode, Int32) |
Top
See Also

Reference

ITreeNode Interface
VisualComponents.UX.Shared Namespace


ITreeNode.AcceptDrop Method (ITreeNode)

ITreeNodeAcceptDrop Method (ITreeNode)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool AcceptDrop(
    ITreeNode dragData
)
bool AcceptDrop(
    ITreeNode^ dragData
)

Parameters

dragData
Type: VisualComponents.UX.SharedITreeNode

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ITreeNode.AcceptDrop(VisualComponents.UX.Shared.ITreeNode)"]

See Also

Reference

ITreeNode Interface
AcceptDrop Overload
VisualComponents.UX.Shared Namespace


ITreeNode.AcceptDrop Method (ITreeNode, Int32)

ITreeNodeAcceptDrop Method (ITreeNode, Int32)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool AcceptDrop(
    ITreeNode dragData,
    int index
)
bool AcceptDrop(
    ITreeNode^ dragData,
    int index
)

Parameters

dragData
Type: VisualComponents.UX.SharedITreeNode
index
Type: SystemInt32

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ITreeNode.AcceptDrop(VisualComponents.UX.Shared.ITreeNode,System.Int32)"]

See Also

Reference

ITreeNode Interface
AcceptDrop Overload
VisualComponents.UX.Shared Namespace


ITreeNode.DropNode Method

ITreeNodeDropNode Method

Overload List
 | Name | Description
Public method | DropNode(ITreeNode) | Drag source is added as a child to this node.
Public method | DropNode(ITreeNode, Int32, ITreeNode, DropType) | Drag source is added a child to this node using given index position.
Top
See Also

Reference

ITreeNode Interface
VisualComponents.UX.Shared Namespace


ITreeNode.DropNode Method (ITreeNode)

ITreeNodeDropNode Method (ITreeNode)

Drag source is added as a child to this node.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DropNode(
    ITreeNode dragSource
)
void DropNode(
    ITreeNode^ dragSource
)

Parameters

dragSource
Type: VisualComponents.UX.SharedITreeNode
See Also

Reference

ITreeNode Interface
DropNode Overload
VisualComponents.UX.Shared Namespace


ITreeNode.DropNode Method (ITreeNode, Int32, ITreeNode, DropType)

ITreeNodeDropNode Method (ITreeNode, Int32, ITreeNode, DropType)

Drag source is added a child to this node using given index position.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DropNode(
    ITreeNode dragSource,
    int index,
    ITreeNode dropTarget,
    DropType dropType
)
void DropNode(
    ITreeNode^ dragSource,
    int index,
    ITreeNode^ dropTarget,
    DropType dropType
)

Parameters

dragSource
Type: VisualComponents.UX.SharedITreeNode
index
Type: SystemInt32
dropTarget
Type: VisualComponents.UX.SharedITreeNode
dropType
Type: VisualComponents.UX.SharedDropType
See Also

Reference

ITreeNode Interface
DropNode Overload
VisualComponents.UX.Shared Namespace


ITreeNode.FindChild Method

ITreeNodeFindChild Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int FindChild(
    ITreeNode node
)
int FindChild(
    ITreeNode^ node
)

Parameters

node
Type: VisualComponents.UX.SharedITreeNode

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ITreeNode.FindChild(VisualComponents.UX.Shared.ITreeNode)"]

See Also

Reference

ITreeNode Interface
VisualComponents.UX.Shared Namespace


ITreeNode.RefreshChildren Method

ITreeNodeRefreshChildren Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RefreshChildren()
void RefreshChildren()
See Also

Reference

ITreeNode Interface
VisualComponents.UX.Shared Namespace


ITreeNode.RemoveChild Method

ITreeNodeRemoveChild Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RemoveChild(
    ITreeNode toRemove,
    bool silent,
    bool disposeCompletely
)
void RemoveChild(
    ITreeNode^ toRemove,
    bool silent,
    bool disposeCompletely
)

Parameters

toRemove
Type: VisualComponents.UX.SharedITreeNode
silent
Type: SystemBoolean
disposeCompletely
Type: SystemBoolean
See Also

Reference

ITreeNode Interface
VisualComponents.UX.Shared Namespace


ITreeViewModel Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface ITreeViewModel : IScreen,
    IHaveDisplayName, IActivate, IDeactivate, IGuardClose, IClose,
    INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class ITreeViewModel : IScreen,
    IHaveDisplayName, IActivate, IDeactivate, IGuardClose, IClose,
    INotifyPropertyChangedEx, INotifyPropertyChanged

The ITreeViewModel type exposes the following members.

Properties
 | Name | Description
Public property | CollapsedNodesCount |
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsXamTreeEx |
Public property | SelectedTreeNodes |
Public property | ShowDropIndicators |
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | ApplyFilterToTreeNode |
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Clear |
Public method | CloneData |
Public method | Collapse |
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | DeleteData |
Public method | Expand |
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | PasteData |
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Public method | UpdateSelection |
Public method | UpdateTree |
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ITreeViewModel Properties

The ITreeViewModel type exposes the following members.

Properties
 | Name | Description
Public property | CollapsedNodesCount |
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsXamTreeEx |
Public property | SelectedTreeNodes |
Public property | ShowDropIndicators |
Top
See Also

Reference

ITreeViewModel Interface
VisualComponents.UX.Shared Namespace


ITreeViewModel.CollapsedNodesCount Property

ITreeViewModelCollapsedNodesCount Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
int CollapsedNodesCount { get; set; }
property int CollapsedNodesCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ITreeViewModel Interface
VisualComponents.UX.Shared Namespace


ITreeViewModel.IsXamTreeEx Property

ITreeViewModelIsXamTreeEx Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool IsXamTreeEx { get; }
property bool IsXamTreeEx {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ITreeViewModel Interface
VisualComponents.UX.Shared Namespace


ITreeViewModel.SelectedTreeNodes Property

ITreeViewModelSelectedTreeNodes Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
List<ITreeNode> SelectedTreeNodes { get; }
property List<ITreeNode^>^ SelectedTreeNodes {
    List<ITreeNode^>^ get ();
}

Property Value

Type: ListITreeNode
See Also

Reference

ITreeViewModel Interface
VisualComponents.UX.Shared Namespace


ITreeViewModel.ShowDropIndicators Property

ITreeViewModelShowDropIndicators Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool ShowDropIndicators { get; set; }
property bool ShowDropIndicators {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ITreeViewModel Interface
VisualComponents.UX.Shared Namespace


ITreeViewModel Methods

The ITreeViewModel type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | ApplyFilterToTreeNode |
Public method | CanClose | (Inherited from IGuardClose.)
Public method | Clear |
Public method | CloneData |
Public method | Collapse |
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | DeleteData |
Public method | Expand |
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | PasteData |
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | TryClose | (Inherited from IClose.)
Public method | UpdateSelection |
Public method | UpdateTree |
Top
See Also

Reference

ITreeViewModel Interface
VisualComponents.UX.Shared Namespace


ITreeViewModel.ApplyFilterToTreeNode Method

ITreeViewModelApplyFilterToTreeNode Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void ApplyFilterToTreeNode(
    string filterText,
    bool searchProperties
)
void ApplyFilterToTreeNode(
    String^ filterText,
    bool searchProperties
)

Parameters

filterText
Type: SystemString
searchProperties
Type: SystemBoolean
See Also

Reference

ITreeViewModel Interface
VisualComponents.UX.Shared Namespace


ITreeViewModel.Clear Method

ITreeViewModelClear Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Clear()
void Clear()
See Also

Reference

ITreeViewModel Interface
VisualComponents.UX.Shared Namespace


ITreeViewModel.CloneData Method

ITreeViewModelCloneData Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object CloneData(
    IEnumerable<ITreeNode> nodes,
    bool cut
)
Object^ CloneData(
    IEnumerable<ITreeNode^>^ nodes,
    bool cut
)

Parameters

nodes
Type: System.Collections.GenericIEnumerableITreeNode
cut
Type: SystemBoolean

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ITreeViewModel.CloneData(System.Collections.Generic.IEnumerable{VisualComponents.UX.Shared.ITreeNode},System.Boolean)"]

See Also

Reference

ITreeViewModel Interface
VisualComponents.UX.Shared Namespace


ITreeViewModel.Collapse Method

ITreeViewModelCollapse Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Collapse()
void Collapse()
See Also

Reference

ITreeViewModel Interface
VisualComponents.UX.Shared Namespace


ITreeViewModel.DeleteData Method

ITreeViewModelDeleteData Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void DeleteData(
    Object data,
    IEnumerable<ITreeNode> nodes
)
void DeleteData(
    Object^ data,
    IEnumerable<ITreeNode^>^ nodes
)

Parameters

data
Type: SystemObject
nodes
Type: System.Collections.GenericIEnumerableITreeNode
See Also

Reference

ITreeViewModel Interface
VisualComponents.UX.Shared Namespace


ITreeViewModel.Expand Method

ITreeViewModelExpand Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Expand()
void Expand()
See Also

Reference

ITreeViewModel Interface
VisualComponents.UX.Shared Namespace


ITreeViewModel.PasteData Method

ITreeViewModelPasteData Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void PasteData(
    Object data,
    ITreeNode target,
    int position
)
void PasteData(
    Object^ data,
    ITreeNode^ target,
    int position
)

Parameters

data
Type: SystemObject
target
Type: VisualComponents.UX.SharedITreeNode
position
Type: SystemInt32
See Also

Reference

ITreeViewModel Interface
VisualComponents.UX.Shared Namespace


ITreeViewModel.UpdateSelection Method

ITreeViewModelUpdateSelection Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateSelection()
void UpdateSelection()
See Also

Reference

ITreeViewModel Interface
VisualComponents.UX.Shared Namespace


ITreeViewModel.UpdateTree Method

ITreeViewModelUpdateTree Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UpdateTree()
void UpdateTree()
See Also

Reference

ITreeViewModel Interface
VisualComponents.UX.Shared Namespace


ITreeViewModel Events

The ITreeViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

ITreeViewModel Interface
VisualComponents.UX.Shared Namespace


IUXConfiguration Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IUXConfiguration
public interface class IUXConfiguration

The IUXConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | Sites |
Top
Methods
 | Name | Description
Public method | DoesUXSiteTabExist | Check UX tab
Public method | GetSiteItems |
Public method | RegisterSite(UXSiteSetup) |
Public method | RegisterSite(UXSiteSetup, Int32) | Add UI element.
Public method | RegisterSite(UXSiteSetup, String, Int32) | Add UI element.
Public method | RegisterSite(String, String, String, Int32) | Adds new UX site specified by id if it doesn't exist already.
Public method | UnRegisterActionSiteEntries | Removes all uxEntries referring to the actionitem.
Public method | UnregisterSite |
Top
Events
 | Name | Description
Public event | UXEntryAdded |
Public event | UXEntryRemoved |
Public event | UXSiteAdded |
Public event | UXSiteRemoved |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IUXConfiguration Properties

The IUXConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | Sites |
Top
See Also

Reference

IUXConfiguration Interface
VisualComponents.UX.Shared Namespace


IUXConfiguration.Sites Property

IUXConfigurationSites Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
List<UXSiteConfigElement> Sites { get; }
property List<UXSiteConfigElement^>^ Sites {
    List<UXSiteConfigElement^>^ get ();
}

Property Value

Type: ListUXSiteConfigElement
See Also

Reference

IUXConfiguration Interface
VisualComponents.UX.Shared Namespace


IUXConfiguration Methods

The IUXConfiguration type exposes the following members.

Methods
 | Name | Description
Public method | DoesUXSiteTabExist | Check UX tab
Public method | GetSiteItems |
Public method | RegisterSite(UXSiteSetup) |
Public method | RegisterSite(UXSiteSetup, Int32) | Add UI element.
Public method | RegisterSite(UXSiteSetup, String, Int32) | Add UI element.
Public method | RegisterSite(String, String, String, Int32) | Adds new UX site specified by id if it doesn't exist already.
Public method | UnRegisterActionSiteEntries | Removes all uxEntries referring to the actionitem.
Public method | UnregisterSite |
Top
See Also

Reference

IUXConfiguration Interface
VisualComponents.UX.Shared Namespace


IUXConfiguration.DoesUXSiteTabExist Method

IUXConfigurationDoesUXSiteTabExist Method

Check UX tab

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
bool DoesUXSiteTabExist(
    UXSiteSetup registerInfo
)
bool DoesUXSiteTabExist(
    UXSiteSetup^ registerInfo
)

Parameters

registerInfo
Type: VisualComponents.UX.SharedUXSiteSetup
UXSiteSetup instance

Return Value

Type: Boolean
true if the path exists
See Also

Reference

IUXConfiguration Interface
VisualComponents.UX.Shared Namespace


IUXConfiguration.GetSiteItems Method

IUXConfigurationGetSiteItems Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
List<UXSiteEntryConfigElement> GetSiteItems(
    string subSiteItemsKey
)
List<UXSiteEntryConfigElement^>^ GetSiteItems(
    String^ subSiteItemsKey
)

Parameters

subSiteItemsKey
Type: SystemString

Return Value

Type: ListUXSiteEntryConfigElement

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.IUXConfiguration.GetSiteItems(System.String)"]

See Also

Reference

IUXConfiguration Interface
VisualComponents.UX.Shared Namespace


IUXConfiguration.RegisterSite Method

IUXConfigurationRegisterSite Method

Overload List
 | Name | Description
Public method | RegisterSite(UXSiteSetup) |
Public method | RegisterSite(UXSiteSetup, Int32) | Add UI element.
Public method | RegisterSite(UXSiteSetup, String, Int32) | Add UI element.
Public method | RegisterSite(String, String, String, Int32) | Adds new UX site specified by id if it doesn't exist already.
Top
See Also

Reference

IUXConfiguration Interface
VisualComponents.UX.Shared Namespace


IUXConfiguration.RegisterSite Method (UXSiteSetup)

IUXConfigurationRegisterSite Method (UXSiteSetup)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RegisterSite(
    UXSiteSetup registerInfo
)
void RegisterSite(
    UXSiteSetup^ registerInfo
)

Parameters

registerInfo
Type: VisualComponents.UX.SharedUXSiteSetup
See Also

Reference

IUXConfiguration Interface
RegisterSite Overload
VisualComponents.UX.Shared Namespace


IUXConfiguration.RegisterSite Method (UXSiteSetup, Int32)

IUXConfigurationRegisterSite Method (UXSiteSetup, Int32)

Add UI element.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RegisterSite(
    UXSiteSetup registerInfo,
    int index
)
void RegisterSite(
    UXSiteSetup^ registerInfo,
    int index
)

Parameters

registerInfo
Type: VisualComponents.UX.SharedUXSiteSetup
index
Type: SystemInt32
Position to add.
See Also

Reference

IUXConfiguration Interface
RegisterSite Overload
VisualComponents.UX.Shared Namespace


IUXConfiguration.RegisterSite Method (UXSiteSetup, String, Int32)

IUXConfigurationRegisterSite Method (UXSiteSetup, String, Int32)

Add UI element.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RegisterSite(
    UXSiteSetup registerInfo,
    string referenceId,
    int index
)
void RegisterSite(
    UXSiteSetup^ registerInfo,
    String^ referenceId,
    int index
)

Parameters

registerInfo
Type: VisualComponents.UX.SharedUXSiteSetup
referenceId
Type: SystemString
Reference UI Id.
index
Type: SystemInt32
Offset position relative to referenced Item.
See Also

Reference

IUXConfiguration Interface
RegisterSite Overload
VisualComponents.UX.Shared Namespace


IUXConfiguration.RegisterSite Method (String, String, String, Int32)

IUXConfigurationRegisterSite Method (String, String, String, Int32)

Adds new UX site specified by id if it doesn't exist already.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void RegisterSite(
    string id,
    string caption = null,
    string icon = null,
    int index = -1
)
void RegisterSite(
    String^ id,
    String^ caption = nullptr,
    String^ icon = nullptr,
    int index = -1
)

Parameters

id
Type: SystemString
Path of the UX site, i.e. VcTabDrawing/Example
caption (Optional)
Type: SystemString
Localization key or caption for the UX site.
icon (Optional)
Type: SystemString
Icon key or path for the UX site.
index (Optional)
Type: SystemInt32
Position of the new UX site in its direct parent.
See Also

Reference

IUXConfiguration Interface
RegisterSite Overload
VisualComponents.UX.Shared Namespace


IUXConfiguration.UnRegisterActionSiteEntries Method

IUXConfigurationUnRegisterActionSiteEntries Method

Removes all uxEntries referring to the actionitem.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UnRegisterActionSiteEntries(
    IActionItem action
)
void UnRegisterActionSiteEntries(
    IActionItem^ action
)

Parameters

action
Type: VisualComponents.UX.SharedIActionItem
See Also

Reference

IUXConfiguration Interface
VisualComponents.UX.Shared Namespace


IUXConfiguration.UnregisterSite Method

IUXConfigurationUnregisterSite Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void UnregisterSite(
    UXSiteSetup unregisterInfo,
    bool removeOnlySiteEntry
)
void UnregisterSite(
    UXSiteSetup^ unregisterInfo,
    bool removeOnlySiteEntry
)

Parameters

unregisterInfo
Type: VisualComponents.UX.SharedUXSiteSetup
removeOnlySiteEntry
Type: SystemBoolean
See Also

Reference

IUXConfiguration Interface
VisualComponents.UX.Shared Namespace


IUXConfiguration Events

The IUXConfiguration type exposes the following members.

Events
 | Name | Description
Public event | UXEntryAdded |
Public event | UXEntryRemoved |
Public event | UXSiteAdded |
Public event | UXSiteRemoved |
Top
See Also

Reference

IUXConfiguration Interface
VisualComponents.UX.Shared Namespace


IUXConfiguration.UXEntryAdded Event

IUXConfigurationUXEntryAdded Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<UXEntryAddedEventArgs> UXEntryAdded
 event EventHandler<UXEntryAddedEventArgs^>^ UXEntryAdded {
    void add (EventHandler<UXEntryAddedEventArgs^>^ value);
    void remove (EventHandler<UXEntryAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerUXEntryAddedEventArgs
See Also

Reference

IUXConfiguration Interface
VisualComponents.UX.Shared Namespace


IUXConfiguration.UXEntryRemoved Event

IUXConfigurationUXEntryRemoved Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<UXEntryRemovedEventArgs> UXEntryRemoved
 event EventHandler<UXEntryRemovedEventArgs^>^ UXEntryRemoved {
    void add (EventHandler<UXEntryRemovedEventArgs^>^ value);
    void remove (EventHandler<UXEntryRemovedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerUXEntryRemovedEventArgs
See Also

Reference

IUXConfiguration Interface
VisualComponents.UX.Shared Namespace


IUXConfiguration.UXSiteAdded Event

IUXConfigurationUXSiteAdded Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<UXSiteAddedEventArgs> UXSiteAdded
 event EventHandler<UXSiteAddedEventArgs^>^ UXSiteAdded {
    void add (EventHandler<UXSiteAddedEventArgs^>^ value);
    void remove (EventHandler<UXSiteAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerUXSiteAddedEventArgs
See Also

Reference

IUXConfiguration Interface
VisualComponents.UX.Shared Namespace


IUXConfiguration.UXSiteRemoved Event

IUXConfigurationUXSiteRemoved Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
event EventHandler<UXSiteRemovedEventArgs> UXSiteRemoved
 event EventHandler<UXSiteRemovedEventArgs^>^ UXSiteRemoved {
    void add (EventHandler<UXSiteRemovedEventArgs^>^ value);
    void remove (EventHandler<UXSiteRemovedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerUXSiteRemovedEventArgs
See Also

Reference

IUXConfiguration Interface
VisualComponents.UX.Shared Namespace


IVariableLine Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IVariableLine
public interface class IVariableLine

The IVariableLine type exposes the following members.

Properties
 | Name | Description
Public property | Model |
Public property | Property |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IVariableLine Properties

The IVariableLine type exposes the following members.

Properties
 | Name | Description
Public property | Model |
Public property | Property |
Top
See Also

Reference

IVariableLine Interface
VisualComponents.UX.Shared Namespace


IVariableLine.Model Property

IVariableLineModel Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IRoutineVariablesEditorViewModel Model { get; set; }
property IRoutineVariablesEditorViewModel^ Model {
    IRoutineVariablesEditorViewModel^ get ();
    void set (IRoutineVariablesEditorViewModel^ value);
}

Property Value

Type: IRoutineVariablesEditorViewModel
See Also

Reference

IVariableLine Interface
VisualComponents.UX.Shared Namespace


IVariableLine.Property Property

IVariableLineProperty Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IProperty Property { get; set; }
property IProperty^ Property {
    IProperty^ get ();
    void set (IProperty^ value);
}

Property Value

Type: IProperty
See Also

Reference

IVariableLine Interface
VisualComponents.UX.Shared Namespace


IViewportContainer Interface

Represents a ViewModel that manages its own IViewport instance.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IViewportContainer
public interface class IViewportContainer

The IViewportContainer type exposes the following members.

Properties
 | Name | Description
Public property | Viewport | Reference to the child IViewport.
Public property | ViewportId | String key which can be used to identify UX sites in the application config, etc.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IViewportContainer Properties

The IViewportContainer type exposes the following members.

Properties
 | Name | Description
Public property | Viewport | Reference to the child IViewport.
Public property | ViewportId | String key which can be used to identify UX sites in the application config, etc.
Top
See Also

Reference

IViewportContainer Interface
VisualComponents.UX.Shared Namespace


IViewportContainer.Viewport Property

IViewportContainerViewport Property

Reference to the child IViewport.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IViewport Viewport { get; set; }
property IViewport^ Viewport {
    IViewport^ get ();
    void set (IViewport^ value);
}

Property Value

Type: IViewport
See Also

Reference

IViewportContainer Interface
VisualComponents.UX.Shared Namespace


IViewportContainer.ViewportId Property

IViewportContainerViewportId Property

String key which can be used to identify UX sites in the application config, etc.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string ViewportId { get; set; }
property String^ ViewportId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IViewportContainer Interface
VisualComponents.UX.Shared Namespace


IViewportContent Interface

Represents the IViewport instance.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IViewportContent : IViewport,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged
public interface class IViewportContent : IViewport,
    IScreen, IHaveDisplayName, IActivate, IDeactivate, IGuardClose,
    IClose, INotifyPropertyChangedEx, INotifyPropertyChanged

The IViewportContent type exposes the following members.

Properties
 | Name | Description
Public property | AreUseSettingsApplied | Defines if the user settings are applied to this instance of IViewport. (Inherited from IViewport.)
Public property | Container | Reference to the parent IViewportContainer.
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsCubeVisible | Cube can be also force-hidden with app setting "IsDefaultViewCubeVisible". (Inherited from IViewport.)
Public property | IsDXReady | (Inherited from IViewport.)
Public property | IsMainViewport | Definese if this instance of IViewport is the main view port. (Inherited from IViewport.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsSimulationControlVisible | Simulation control can be also force-hidden with app setting "IsSimulationControlVisible". (Inherited from IViewport.)
Public property | IsToolBarShown | Gets the actual 3D toolbar visibility. This is based on the value of IsToolBarVisible property, active viewport and full screen mode. (Inherited from IViewport.)
Public property | IsToolBarVisible | Gets or sets 3D toolbar visibility. (Inherited from IViewport.)
Public property | OnViewportInvalidate | Gets the method that should be called when the viewport should be invalidated. (Inherited from IViewport.)
Public property | RootElement | (Inherited from IViewport.)
Public property | SurfaceSize | (Inherited from IViewport.)
Public property | Window | (Inherited from IViewport.)
Top
Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | ApplyUserSettings | Read and apply user settings from the configuration file. (Inherited from IViewport.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | CreateViewport | Creates a new 3D viewport view model displaying the main 3d/drawing worlds. This will automatically create a new instance of IWindow3D with the contents of built in 3D/drawing world instances. (Inherited from IViewport.)
Public method | CreateViewport(IWindow3D) | Creates a new 3D viewport view model displaying the given instance of IWindow3D. (Inherited from IViewport.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | InvalidateHelperViewport | Refresh HelperViewport. (Inherited from IViewport.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | ReadZoomSettings | Reads in locally-cached settings for zooming the view, e.g. sensitivity and zoom mode, from the settings file. (Inherited from IViewport.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | RequestRender | (Inherited from IViewport.)
Public method | SetAsActiveViewport | Sets the viewport and its window active. (Inherited from IViewport.)
Public method | SetRecordingMode | (Inherited from IViewport.)
Public method | SetWindow | (Inherited from IViewport.)
Public method | ShowRecordedImage | (Inherited from IViewport.)
Public method | TryClose | (Inherited from IClose.)
Public method | UpdateGeometryScale | Used internally for updating manipulator sizes. (Inherited from IViewport.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | CameraChanged | Occurs when 3D camera has been updated, (Inherited from IViewport.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | Initialized | Occurs after viewport has been initialized. (Inherited from IViewport.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IViewportContent Properties

The IViewportContent type exposes the following members.

Properties
 | Name | Description
Public property | AreUseSettingsApplied | Defines if the user settings are applied to this instance of IViewport. (Inherited from IViewport.)
Public property | Container | Reference to the parent IViewportContainer.
Public property | DisplayName | (Inherited from IHaveDisplayName.)
Public property | IsActive | (Inherited from IActivate.)
Public property | IsCubeVisible | Cube can be also force-hidden with app setting "IsDefaultViewCubeVisible". (Inherited from IViewport.)
Public property | IsDXReady | (Inherited from IViewport.)
Public property | IsMainViewport | Definese if this instance of IViewport is the main view port. (Inherited from IViewport.)
Public property | IsNotifying | (Inherited from INotifyPropertyChangedEx.)
Public property | IsSimulationControlVisible | Simulation control can be also force-hidden with app setting "IsSimulationControlVisible". (Inherited from IViewport.)
Public property | IsToolBarShown | Gets the actual 3D toolbar visibility. This is based on the value of IsToolBarVisible property, active viewport and full screen mode. (Inherited from IViewport.)
Public property | IsToolBarVisible | Gets or sets 3D toolbar visibility. (Inherited from IViewport.)
Public property | OnViewportInvalidate | Gets the method that should be called when the viewport should be invalidated. (Inherited from IViewport.)
Public property | RootElement | (Inherited from IViewport.)
Public property | SurfaceSize | (Inherited from IViewport.)
Public property | Window | (Inherited from IViewport.)
Top
See Also

Reference

IViewportContent Interface
VisualComponents.UX.Shared Namespace


IViewportContent.Container Property

IViewportContentContainer Property

Reference to the parent IViewportContainer.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
IViewportContainer Container { get; set; }
property IViewportContainer^ Container {
    IViewportContainer^ get ();
    void set (IViewportContainer^ value);
}

Property Value

Type: IViewportContainer
See Also

Reference

IViewportContent Interface
VisualComponents.UX.Shared Namespace


IViewportContent Methods

The IViewportContent type exposes the following members.

Methods
 | Name | Description
Public method | Activate | (Inherited from IActivate.)
Public method | ApplyUserSettings | Read and apply user settings from the configuration file. (Inherited from IViewport.)
Public method | CanClose | (Inherited from IGuardClose.)
Public method | CreateViewport | Creates a new 3D viewport view model displaying the main 3d/drawing worlds. This will automatically create a new instance of IWindow3D with the contents of built in 3D/drawing world instances. (Inherited from IViewport.)
Public method | CreateViewport(IWindow3D) | Creates a new 3D viewport view model displaying the given instance of IWindow3D. (Inherited from IViewport.)
Public method | Deactivate | (Inherited from IDeactivate.)
Public method | InvalidateHelperViewport | Refresh HelperViewport. (Inherited from IViewport.)
Public method | NotifyOfPropertyChange | (Inherited from INotifyPropertyChangedEx.)
Public method | ReadZoomSettings | Reads in locally-cached settings for zooming the view, e.g. sensitivity and zoom mode, from the settings file. (Inherited from IViewport.)
Public method | Refresh | (Inherited from INotifyPropertyChangedEx.)
Public method | RequestRender | (Inherited from IViewport.)
Public method | SetAsActiveViewport | Sets the viewport and its window active. (Inherited from IViewport.)
Public method | SetRecordingMode | (Inherited from IViewport.)
Public method | SetWindow | (Inherited from IViewport.)
Public method | ShowRecordedImage | (Inherited from IViewport.)
Public method | TryClose | (Inherited from IClose.)
Public method | UpdateGeometryScale | Used internally for updating manipulator sizes. (Inherited from IViewport.)
Top
See Also

Reference

IViewportContent Interface
VisualComponents.UX.Shared Namespace


IViewportContent Events

The IViewportContent type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from IActivate.)
Public event | AttemptingDeactivation | (Inherited from IDeactivate.)
Public event | CameraChanged | Occurs when 3D camera has been updated, (Inherited from IViewport.)
Public event | Deactivated | (Inherited from IDeactivate.)
Public event | Initialized | Occurs after viewport has been initialized. (Inherited from IViewport.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IViewportContent Interface
VisualComponents.UX.Shared Namespace


IViewportToolbar Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IViewportToolbar
public interface class IViewportToolbar
See Also

Reference

VisualComponents.UX.Shared Namespace


IWorldGraphView Interface

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public interface IWorldGraphView
public interface class IWorldGraphView

The IWorldGraphView type exposes the following members.

Properties
 | Name | Description
Public property | Content | Visual content to be displayed when this view is active (ActiveWorldGraphView).
Public property | Name | Name of this view to be displayed in the tab header.
Top
Methods
 | Name | Description
Public method | Activate | Called when this view becomes active (ActiveWorldGraphView).
Public method | Deactivate | Called when this view becomes inactive (ActiveWorldGraphView).
Public method | Load | Called for all registered views when World Graph panel is loaded.
Public method | Register | Called when this view is added to WorldGraphViews collection.
Public method | Unload | Called for all registered views when World Graph panel is unloaded.
Public method | Unregister | Called when this view is removed from WorldGraphViews collection.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


IWorldGraphView Properties

The IWorldGraphView type exposes the following members.

Properties
 | Name | Description
Public property | Content | Visual content to be displayed when this view is active (ActiveWorldGraphView).
Public property | Name | Name of this view to be displayed in the tab header.
Top
See Also

Reference

IWorldGraphView Interface
VisualComponents.UX.Shared Namespace


IWorldGraphView.Content Property

IWorldGraphViewContent Property

Visual content to be displayed when this view is active (ActiveWorldGraphView).

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
Object Content { get; }
property Object^ Content {
    Object^ get ();
}

Property Value

Type: Object
Remarks
See https://docs.microsoft.com/en-us/dotnet/api/system.windows.controls.contentcontrol.content for supported types.
See Also

Reference

IWorldGraphView Interface
VisualComponents.UX.Shared Namespace


IWorldGraphView.Name Property

IWorldGraphViewName Property

Name of this view to be displayed in the tab header.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
string Name { get; }
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IWorldGraphView Interface
VisualComponents.UX.Shared Namespace


IWorldGraphView Methods

The IWorldGraphView type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Called when this view becomes active (ActiveWorldGraphView).
Public method | Deactivate | Called when this view becomes inactive (ActiveWorldGraphView).
Public method | Load | Called for all registered views when World Graph panel is loaded.
Public method | Register | Called when this view is added to WorldGraphViews collection.
Public method | Unload | Called for all registered views when World Graph panel is unloaded.
Public method | Unregister | Called when this view is removed from WorldGraphViews collection.
Top
See Also

Reference

IWorldGraphView Interface
VisualComponents.UX.Shared Namespace


IWorldGraphView.Activate Method

IWorldGraphViewActivate Method

Called when this view becomes active (ActiveWorldGraphView).

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Activate()
void Activate()
See Also

Reference

IWorldGraphView Interface
VisualComponents.UX.Shared Namespace


IWorldGraphView.Deactivate Method

IWorldGraphViewDeactivate Method

Called when this view becomes inactive (ActiveWorldGraphView).

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Deactivate()
void Deactivate()
See Also

Reference

IWorldGraphView Interface
VisualComponents.UX.Shared Namespace


IWorldGraphView.Load Method

IWorldGraphViewLoad Method

Called for all registered views when World Graph panel is loaded.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Load()
void Load()
Remarks
On LayoutClosed World Graph panel is unloaded and then loaded again.
See Also

Reference

IWorldGraphView Interface
VisualComponents.UX.Shared Namespace


IWorldGraphView.Register Method

IWorldGraphViewRegister Method

Called when this view is added to WorldGraphViews collection.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Register()
void Register()
See Also

Reference

IWorldGraphView Interface
VisualComponents.UX.Shared Namespace


IWorldGraphView.Unload Method

IWorldGraphViewUnload Method

Called for all registered views when World Graph panel is unloaded.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Unload()
void Unload()
Remarks
On LayoutClosed World Graph panel is unloaded and then loaded again.
See Also

Reference

IWorldGraphView Interface
VisualComponents.UX.Shared Namespace


IWorldGraphView.Unregister Method

IWorldGraphViewUnregister Method

Called when this view is removed from WorldGraphViews collection.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
void Unregister()
void Unregister()
See Also

Reference

IWorldGraphView Interface
VisualComponents.UX.Shared Namespace


JointSlider Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.Controls.PrimitivesRangeBase
System.Windows.ControlsSlider
VisualComponents.UX.SharedJointSlider

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class JointSlider : Slider
public ref class JointSlider : public Slider

The JointSlider type exposes the following members.

Constructors
 | Name | Description
Public method | JointSlider | Initializes a new instance of the JointSlider class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoToolTipPlacement | Gets or sets whether a tooltip that contains the current value of the Slider displays when the Thumb is pressed. If a tooltip is displayed, this property also specifies the placement of the tooltip. (Inherited from Slider.)
Public property | AutoToolTipPrecision | Gets or sets the number of digits that are displayed to the right side of the decimal point for the Value of the Slider in a tooltip. (Inherited from Slider.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanDecreaseTurn | Represents if it is possible to make 360 anti-clockwise turn.
Public property | CanIncreaseTurn | Represents if it is possible to make 360 clockwise turn.
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | Delay | Gets or sets the amount of time in milliseconds that a RepeatButton waits, while it is pressed, before a command to move the Thumb executes, such as a DecreaseLarge command. (Inherited from Slider.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DisabledZoneColor | Set disbled zone Color.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HardLimitZoneColor | Set hard limit zone Color.
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | Interval | Gets or sets the amount of time in milliseconds between increase or decrease commands when a user clicks the RepeatButton of a Slider. (Inherited from Slider.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsDirectionReversed | Gets or sets the direction of increasing value. (Inherited from Slider.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsMoveToPointEnabled | Gets or sets a value that indicates whether the Thumb of a Slider moves immediately to the location of the mouse click that occurs while the mouse pointer pauses on the Slider track. (Inherited from Slider.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionRangeEnabled | Gets or sets a value that indicates whether the Slider displays a selection range along the Slider. (Inherited from Slider.)
Public property | IsSnapToTickEnabled | Gets or sets a value that indicates whether the Slider automatically moves the Thumb to the closest tick mark. (Inherited from Slider.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTurnerEnabled | Enable or Disable turn counter .
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | JointTooltipText |
Public property | JointType | JointType
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets a value to be added to or subtracted from the Value of a RangeBase control. (Inherited from RangeBase.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | LeftHardLimit | Represent anti-clockwise direction hard limit.
Public property | LeftSoftLimit | Represent anti-clockwise direction soft limit.
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible Value of the range element. (Inherited from RangeBase.)
Public property | MaximumRange | Represents so far maximum value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the Minimum possible Value of the range element. (Inherited from RangeBase.)
Public property | MinimumRange | Represent so far minimum value.
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the orientation of a Slider. (Inherited from Slider.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RangeFillColour | Set range indicator colour.
Public property | RangeIndicatorColour | Set range indicator colour.
Public property | RangeIndicatorLeftMargin | Range indicator left margin.
Public property | RangeIndicatorWidth | Range indicator width.
Public property | RangeLableVisibility | Show or hide Minimum or Maximum range label.
Public property | RealValue | Similar to this.Value, that can also be outside of Minimum/Maximum range.
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Reset | Reset MinimumRange and MaximumRange
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RightHardLimit | Represent clockwise direction hard limit.
Public property | RightSoftLimit | Represent clockwise direction soft limit.
Public property | SafeZoneColor | Set safe zone Color.
Public property | SelectionEnd | Gets or sets the largest value of a specified selection for a Slider. (Inherited from Slider.)
Public property | SelectionStart | Gets or sets the smallest value of a specified selection for a Slider. (Inherited from Slider.)
Public property | SmallChange | Gets or sets a Value to be added to or subtracted from the Value of a RangeBase control. (Inherited from RangeBase.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | SoftLimitZoneColor | Set soft limit zone Color.
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ThumbColor | Set slider Thumb Color.
Public property | TickFrequency | Gets or sets the interval between tick marks. (Inherited from Slider.)
Public property | TickPlacement | Gets or sets the position of tick marks with respect to the Track of the Slider. (Inherited from Slider.)
Public property | Ticks | Gets or sets the positions of the tick marks to display for a Slider. (Inherited from Slider.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | TurnCountVisibility | Show or hide turn counter visibility.
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | Value | Gets or sets the current magnitude of the range control. (Inherited from RangeBase.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualBounds |
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Arranges the content of a Slider and determines its Size. (Inherited from Slider.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides SliderOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates an AutomationPeer for the Slider. (Inherited from Slider.)
Protected method | OnDecreaseLarge | (Overrides SliderOnDecreaseLarge.)
Protected method | OnDecreaseSmall | Responds to a DecreaseSmall command. (Inherited from Slider.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnIncreaseLarge | (Overrides SliderOnIncreaseLarge.)
Protected method | OnIncreaseSmall | Responds to an IncreaseSmall command. (Inherited from Slider.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMaximizeValue | Responds to the MaximizeValue command. (Inherited from Slider.)
Protected method | OnMaximumChanged | (Overrides SliderOnMaximumChanged(Double, Double).)
Protected method | OnMinimizeValue | Responds to a MinimizeValue command. (Inherited from Slider.)
Protected method | OnMinimumChanged | (Overrides SliderOnMinimumChanged(Double, Double).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Provides class handling for the PreviewMouseLeftButtonDown routed event. (Inherited from Slider.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | (Overrides FrameworkElementOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRealValueChanged | Updates some things related to the value, called every time the value changes
Protected method | OnRender | (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnThumbDragCompleted | Provides class handling for the DragCompleted event that occurs when the user stops dragging the Thumb of the Slider. (Inherited from Slider.)
Protected method | OnThumbDragDelta | Provides class handling for the DragDelta event that occurs when the user drags the Thumb of the Slider. (Inherited from Slider.)
Protected method | OnThumbDragStarted | Provides class handling for the DragStarted event that occurs when the user starts to drag the Thumb of the Slider. (Inherited from Slider.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnValueChanged | Updates everything related to the value, called when Value changes. (Overrides SliderOnValueChanged(Double, Double).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Provides a string representation of a RangeBase object. (Inherited from RangeBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | EnteredHardLimitZone |
Public event | EnteredSafeLimitZone |
Public event | EnteredSoftLimitZone |
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LargeChangeButtonClick |
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs when the range value changes. (Inherited from RangeBase.)
Top
Fields
Name | Description
CanDecreaseTurnProperty |
CanIncreaseTurnProperty |
DisabledZoneColorProperty |
EnteredHardLimitZoneEvent |
EnteredSafeLimitZoneEvent |
EnteredSoftLimitZoneEvent |
HardLimitZoneColorProperty |
IsTurnerEnabledProperty |
JointTooltipTextProperty |
JointTypeProperty |
LargeChangeButtonClickEvent |
LeftHardLimitProperty |
LeftSoftLimitProperty |
MaximumRangeProperty |
MinimumRangeProperty |
RangeFillColourProperty |
RangeIndicatorColourProperty |
RangeIndicatorLeftMarginProperty |
RangeIndicatorWidthProperty |
RangeLableVisibilityProperty |
RealValueProperty |
ResetProperty |
RightHardLimitProperty |
RightSoftLimitProperty |
SafeZoneColorProperty |
SoftLimitZoneColorProperty |
ThumbColorProperty |
TurnCountVisibilityProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


JointSlider Constructor

Initializes a new instance of the JointSlider class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public JointSlider()
public:
JointSlider()
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider Properties

The JointSlider type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoToolTipPlacement | Gets or sets whether a tooltip that contains the current value of the Slider displays when the Thumb is pressed. If a tooltip is displayed, this property also specifies the placement of the tooltip. (Inherited from Slider.)
Public property | AutoToolTipPrecision | Gets or sets the number of digits that are displayed to the right side of the decimal point for the Value of the Slider in a tooltip. (Inherited from Slider.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanDecreaseTurn | Represents if it is possible to make 360 anti-clockwise turn.
Public property | CanIncreaseTurn | Represents if it is possible to make 360 clockwise turn.
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | Delay | Gets or sets the amount of time in milliseconds that a RepeatButton waits, while it is pressed, before a command to move the Thumb executes, such as a DecreaseLarge command. (Inherited from Slider.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DisabledZoneColor | Set disbled zone Color.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HardLimitZoneColor | Set hard limit zone Color.
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | Interval | Gets or sets the amount of time in milliseconds between increase or decrease commands when a user clicks the RepeatButton of a Slider. (Inherited from Slider.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsDirectionReversed | Gets or sets the direction of increasing value. (Inherited from Slider.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsMoveToPointEnabled | Gets or sets a value that indicates whether the Thumb of a Slider moves immediately to the location of the mouse click that occurs while the mouse pointer pauses on the Slider track. (Inherited from Slider.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionRangeEnabled | Gets or sets a value that indicates whether the Slider displays a selection range along the Slider. (Inherited from Slider.)
Public property | IsSnapToTickEnabled | Gets or sets a value that indicates whether the Slider automatically moves the Thumb to the closest tick mark. (Inherited from Slider.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTurnerEnabled | Enable or Disable turn counter .
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | JointTooltipText |
Public property | JointType | JointType
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LargeChange | Gets or sets a value to be added to or subtracted from the Value of a RangeBase control. (Inherited from RangeBase.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | LeftHardLimit | Represent anti-clockwise direction hard limit.
Public property | LeftSoftLimit | Represent anti-clockwise direction soft limit.
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the highest possible Value of the range element. (Inherited from RangeBase.)
Public property | MaximumRange | Represents so far maximum value.
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the Minimum possible Value of the range element. (Inherited from RangeBase.)
Public property | MinimumRange | Represent so far minimum value.
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the orientation of a Slider. (Inherited from Slider.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RangeFillColour | Set range indicator colour.
Public property | RangeIndicatorColour | Set range indicator colour.
Public property | RangeIndicatorLeftMargin | Range indicator left margin.
Public property | RangeIndicatorWidth | Range indicator width.
Public property | RangeLableVisibility | Show or hide Minimum or Maximum range label.
Public property | RealValue | Similar to this.Value, that can also be outside of Minimum/Maximum range.
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Reset | Reset MinimumRange and MaximumRange
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RightHardLimit | Represent clockwise direction hard limit.
Public property | RightSoftLimit | Represent clockwise direction soft limit.
Public property | SafeZoneColor | Set safe zone Color.
Public property | SelectionEnd | Gets or sets the largest value of a specified selection for a Slider. (Inherited from Slider.)
Public property | SelectionStart | Gets or sets the smallest value of a specified selection for a Slider. (Inherited from Slider.)
Public property | SmallChange | Gets or sets a Value to be added to or subtracted from the Value of a RangeBase control. (Inherited from RangeBase.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | SoftLimitZoneColor | Set soft limit zone Color.
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ThumbColor | Set slider Thumb Color.
Public property | TickFrequency | Gets or sets the interval between tick marks. (Inherited from Slider.)
Public property | TickPlacement | Gets or sets the position of tick marks with respect to the Track of the Slider. (Inherited from Slider.)
Public property | Ticks | Gets or sets the positions of the tick marks to display for a Slider. (Inherited from Slider.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | TurnCountVisibility | Show or hide turn counter visibility.
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | Value | Gets or sets the current magnitude of the range control. (Inherited from RangeBase.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualBounds |
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.CanDecreaseTurn Property

JointSliderCanDecreaseTurn Property

Represents if it is possible to make 360 anti-clockwise turn.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanDecreaseTurn { get; set; }
public:
property bool CanDecreaseTurn {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.CanIncreaseTurn Property

JointSliderCanIncreaseTurn Property

Represents if it is possible to make 360 clockwise turn.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanIncreaseTurn { get; set; }
public:
property bool CanIncreaseTurn {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.DisabledZoneColor Property

JointSliderDisabledZoneColor Property

Set disbled zone Color.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SolidColorBrush DisabledZoneColor { get; set; }
public:
property SolidColorBrush^ DisabledZoneColor {
    SolidColorBrush^ get ();
    void set (SolidColorBrush^ value);
}

Property Value

Type: SolidColorBrush
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.HardLimitZoneColor Property

JointSliderHardLimitZoneColor Property

Set hard limit zone Color.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SolidColorBrush HardLimitZoneColor { get; set; }
public:
property SolidColorBrush^ HardLimitZoneColor {
    SolidColorBrush^ get ();
    void set (SolidColorBrush^ value);
}

Property Value

Type: SolidColorBrush
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.IsTurnerEnabled Property

JointSliderIsTurnerEnabled Property

Enable or Disable turn counter .

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsTurnerEnabled { get; set; }
public:
property bool IsTurnerEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.JointTooltipText Property

JointSliderJointTooltipText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string JointTooltipText { get; set; }
public:
property String^ JointTooltipText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.JointType Property

JointSliderJointType Property

JointType

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public JointType JointType { get; set; }
public:
property JointType JointType {
    JointType get ();
    void set (JointType value);
}

Property Value

Type: JointType
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.LeftHardLimit Property

JointSliderLeftHardLimit Property

Represent anti-clockwise direction hard limit.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double LeftHardLimit { get; set; }
public:
property double LeftHardLimit {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.LeftSoftLimit Property

JointSliderLeftSoftLimit Property

Represent anti-clockwise direction soft limit.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double LeftSoftLimit { get; set; }
public:
property double LeftSoftLimit {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.MaximumRange Property

JointSliderMaximumRange Property

Represents so far maximum value.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double MaximumRange { get; set; }
public:
property double MaximumRange {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.MinimumRange Property

JointSliderMinimumRange Property

Represent so far minimum value.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double MinimumRange { get; set; }
public:
property double MinimumRange {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.RangeFillColour Property

JointSliderRangeFillColour Property

Set range indicator colour.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SolidColorBrush RangeFillColour { get; set; }
public:
property SolidColorBrush^ RangeFillColour {
    SolidColorBrush^ get ();
    void set (SolidColorBrush^ value);
}

Property Value

Type: SolidColorBrush
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.RangeIndicatorColour Property

JointSliderRangeIndicatorColour Property

Set range indicator colour.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SolidColorBrush RangeIndicatorColour { get; set; }
public:
property SolidColorBrush^ RangeIndicatorColour {
    SolidColorBrush^ get ();
    void set (SolidColorBrush^ value);
}

Property Value

Type: SolidColorBrush
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.RangeIndicatorLeftMargin Property

JointSliderRangeIndicatorLeftMargin Property

Range indicator left margin.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double RangeIndicatorLeftMargin { get; set; }
public:
property double RangeIndicatorLeftMargin {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.RangeIndicatorWidth Property

JointSliderRangeIndicatorWidth Property

Range indicator width.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double RangeIndicatorWidth { get; set; }
public:
property double RangeIndicatorWidth {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.RangeLableVisibility Property

JointSliderRangeLableVisibility Property

Show or hide Minimum or Maximum range label.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Visibility RangeLableVisibility { get; set; }
public:
property Visibility RangeLableVisibility {
    Visibility get ();
    void set (Visibility value);
}

Property Value

Type: Visibility
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.RealValue Property

JointSliderRealValue Property

Similar to this.Value, that can also be outside of Minimum/Maximum range.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double RealValue { get; set; }
public:
property double RealValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.Reset Property

JointSliderReset Property

Reset MinimumRange and MaximumRange

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Reset { get; set; }
public:
property bool Reset {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.RightHardLimit Property

JointSliderRightHardLimit Property

Represent clockwise direction hard limit.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double RightHardLimit { get; set; }
public:
property double RightHardLimit {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.RightSoftLimit Property

JointSliderRightSoftLimit Property

Represent clockwise direction soft limit.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double RightSoftLimit { get; set; }
public:
property double RightSoftLimit {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.SafeZoneColor Property

JointSliderSafeZoneColor Property

Set safe zone Color.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SolidColorBrush SafeZoneColor { get; set; }
public:
property SolidColorBrush^ SafeZoneColor {
    SolidColorBrush^ get ();
    void set (SolidColorBrush^ value);
}

Property Value

Type: SolidColorBrush
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.SoftLimitZoneColor Property

JointSliderSoftLimitZoneColor Property

Set soft limit zone Color.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SolidColorBrush SoftLimitZoneColor { get; set; }
public:
property SolidColorBrush^ SoftLimitZoneColor {
    SolidColorBrush^ get ();
    void set (SolidColorBrush^ value);
}

Property Value

Type: SolidColorBrush
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.ThumbColor Property

JointSliderThumbColor Property

Set slider Thumb Color.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SolidColorBrush ThumbColor { get; set; }
public:
property SolidColorBrush^ ThumbColor {
    SolidColorBrush^ get ();
    void set (SolidColorBrush^ value);
}

Property Value

Type: SolidColorBrush
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.TurnCountVisibility Property

JointSliderTurnCountVisibility Property

Show or hide turn counter visibility.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Visibility TurnCountVisibility { get; set; }
public:
property Visibility TurnCountVisibility {
    Visibility get ();
    void set (Visibility value);
}

Property Value

Type: Visibility
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.VisualBounds Property

JointSliderVisualBounds Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected Rect VisualBounds { get; }
protected:
property Rect VisualBounds {
    Rect get ();
}

Property Value

Type: Rect
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider Methods

The JointSlider type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Arranges the content of a Slider and determines its Size. (Inherited from Slider.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides SliderOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates an AutomationPeer for the Slider. (Inherited from Slider.)
Protected method | OnDecreaseLarge | (Overrides SliderOnDecreaseLarge.)
Protected method | OnDecreaseSmall | Responds to a DecreaseSmall command. (Inherited from Slider.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnIncreaseLarge | (Overrides SliderOnIncreaseLarge.)
Protected method | OnIncreaseSmall | Responds to an IncreaseSmall command. (Inherited from Slider.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMaximizeValue | Responds to the MaximizeValue command. (Inherited from Slider.)
Protected method | OnMaximumChanged | (Overrides SliderOnMaximumChanged(Double, Double).)
Protected method | OnMinimizeValue | Responds to a MinimizeValue command. (Inherited from Slider.)
Protected method | OnMinimumChanged | (Overrides SliderOnMinimumChanged(Double, Double).)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Provides class handling for the PreviewMouseLeftButtonDown routed event. (Inherited from Slider.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | (Overrides FrameworkElementOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRealValueChanged | Updates some things related to the value, called every time the value changes
Protected method | OnRender | (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnThumbDragCompleted | Provides class handling for the DragCompleted event that occurs when the user stops dragging the Thumb of the Slider. (Inherited from Slider.)
Protected method | OnThumbDragDelta | Provides class handling for the DragDelta event that occurs when the user drags the Thumb of the Slider. (Inherited from Slider.)
Protected method | OnThumbDragStarted | Provides class handling for the DragStarted event that occurs when the user starts to drag the Thumb of the Slider. (Inherited from Slider.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnValueChanged | Updates everything related to the value, called when Value changes. (Overrides SliderOnValueChanged(Double, Double).)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Provides a string representation of a RangeBase object. (Inherited from RangeBase.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.OnApplyTemplate Method

JointSliderOnApplyTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.OnDecreaseLarge Method

JointSliderOnDecreaseLarge Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnDecreaseLarge()
protected:
virtual void OnDecreaseLarge() override
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.OnIncreaseLarge Method

JointSliderOnIncreaseLarge Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnIncreaseLarge()
protected:
virtual void OnIncreaseLarge() override
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.OnMaximumChanged Method

JointSliderOnMaximumChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnMaximumChanged(
    double oldMaximum,
    double newMaximum
)
protected:
virtual void OnMaximumChanged(
    double oldMaximum,
    double newMaximum
) override

Parameters

oldMaximum
Type: SystemDouble
newMaximum
Type: SystemDouble
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.OnMinimumChanged Method

JointSliderOnMinimumChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnMinimumChanged(
    double oldMinimum,
    double newMinimum
)
protected:
virtual void OnMinimumChanged(
    double oldMinimum,
    double newMinimum
) override

Parameters

oldMinimum
Type: SystemDouble
newMinimum
Type: SystemDouble
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.OnPropertyChanged Method

JointSliderOnPropertyChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
)
protected:
virtual void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
) override

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.OnRealValueChanged Method

JointSliderOnRealValueChanged Method

Updates some things related to the value, called every time the value changes

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected void OnRealValueChanged()
protected:
void OnRealValueChanged()
Remarks
- This method is called before OnRealValueChanged, but they are not mutually exclusive. If the value is within limits, the OnValueChanged will be called. There are cases, which are valid, but OnValueChanged is not called, so we call it here explicitly. 1. value is on a limit 2. value is slightly outside the limit due to floating point calculations - Note that this.Value is not evaluated at this point.
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.OnRender Method

JointSliderOnRender Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
protected:
virtual void OnRender(
    DrawingContext^ drawingContext
) override

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.OnValueChanged Method

JointSliderOnValueChanged Method

Updates everything related to the value, called when Value changes.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnValueChanged(
    double oldValue,
    double newValue
)
protected:
virtual void OnValueChanged(
    double oldValue,
    double newValue
) override

Parameters

oldValue
Type: SystemDouble
old value (within limits)
newValue
Type: SystemDouble
new value (within limits)
Remarks
This is called only when the value changes within the limit. When the user changes the value to be outside limit, the value is clamped and `this.Value` changes, but only the first time. If the next value is _also_ outside the limit, it is clamped to be the same value as before => no change.
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider Events

The JointSlider type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | EnteredHardLimitZone |
Public event | EnteredSafeLimitZone |
Public event | EnteredSoftLimitZone |
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LargeChangeButtonClick |
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs when the range value changes. (Inherited from RangeBase.)
Top
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.EnteredHardLimitZone Event

JointSliderEnteredHardLimitZone Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event RoutedEventHandler EnteredHardLimitZone
public:
 event RoutedEventHandler^ EnteredHardLimitZone {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.EnteredSafeLimitZone Event

JointSliderEnteredSafeLimitZone Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event RoutedEventHandler EnteredSafeLimitZone
public:
 event RoutedEventHandler^ EnteredSafeLimitZone {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.EnteredSoftLimitZone Event

JointSliderEnteredSoftLimitZone Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event RoutedEventHandler EnteredSoftLimitZone
public:
 event RoutedEventHandler^ EnteredSoftLimitZone {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.LargeChangeButtonClick Event

JointSliderLargeChangeButtonClick Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event RoutedEventHandler LargeChangeButtonClick
public:
 event RoutedEventHandler^ LargeChangeButtonClick {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider Fields

The JointSlider type exposes the following members.

Fields
Name | Description
CanDecreaseTurnProperty |
CanIncreaseTurnProperty |
DisabledZoneColorProperty |
EnteredHardLimitZoneEvent |
EnteredSafeLimitZoneEvent |
EnteredSoftLimitZoneEvent |
HardLimitZoneColorProperty |
IsTurnerEnabledProperty |
JointTooltipTextProperty |
JointTypeProperty |
LargeChangeButtonClickEvent |
LeftHardLimitProperty |
LeftSoftLimitProperty |
MaximumRangeProperty |
MinimumRangeProperty |
RangeFillColourProperty |
RangeIndicatorColourProperty |
RangeIndicatorLeftMarginProperty |
RangeIndicatorWidthProperty |
RangeLableVisibilityProperty |
RealValueProperty |
ResetProperty |
RightHardLimitProperty |
RightSoftLimitProperty |
SafeZoneColorProperty |
SoftLimitZoneColorProperty |
ThumbColorProperty |
TurnCountVisibilityProperty |
Top
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.CanDecreaseTurnProperty Field

JointSliderCanDecreaseTurnProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty CanDecreaseTurnProperty
public:
static initonly DependencyProperty^ CanDecreaseTurnProperty

Field Value

Type: DependencyProperty
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.CanIncreaseTurnProperty Field

JointSliderCanIncreaseTurnProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty CanIncreaseTurnProperty
public:
static initonly DependencyProperty^ CanIncreaseTurnProperty

Field Value

Type: DependencyProperty
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.DisabledZoneColorProperty Field

JointSliderDisabledZoneColorProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty DisabledZoneColorProperty
public:
static initonly DependencyProperty^ DisabledZoneColorProperty

Field Value

Type: DependencyProperty
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.EnteredHardLimitZoneEvent Field

JointSliderEnteredHardLimitZoneEvent Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly RoutedEvent EnteredHardLimitZoneEvent
public:
static initonly RoutedEvent^ EnteredHardLimitZoneEvent

Field Value

Type: RoutedEvent
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.EnteredSafeLimitZoneEvent Field

JointSliderEnteredSafeLimitZoneEvent Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly RoutedEvent EnteredSafeLimitZoneEvent
public:
static initonly RoutedEvent^ EnteredSafeLimitZoneEvent

Field Value

Type: RoutedEvent
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.EnteredSoftLimitZoneEvent Field

JointSliderEnteredSoftLimitZoneEvent Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly RoutedEvent EnteredSoftLimitZoneEvent
public:
static initonly RoutedEvent^ EnteredSoftLimitZoneEvent

Field Value

Type: RoutedEvent
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.HardLimitZoneColorProperty Field

JointSliderHardLimitZoneColorProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty HardLimitZoneColorProperty
public:
static initonly DependencyProperty^ HardLimitZoneColorProperty

Field Value

Type: DependencyProperty
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.IsTurnerEnabledProperty Field

JointSliderIsTurnerEnabledProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsTurnerEnabledProperty
public:
static initonly DependencyProperty^ IsTurnerEnabledProperty

Field Value

Type: DependencyProperty
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.JointTooltipTextProperty Field

JointSliderJointTooltipTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty JointTooltipTextProperty
public:
static initonly DependencyProperty^ JointTooltipTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.JointTypeProperty Field

JointSliderJointTypeProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty JointTypeProperty
public:
static initonly DependencyProperty^ JointTypeProperty

Field Value

Type: DependencyProperty
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.LargeChangeButtonClickEvent Field

JointSliderLargeChangeButtonClickEvent Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly RoutedEvent LargeChangeButtonClickEvent
public:
static initonly RoutedEvent^ LargeChangeButtonClickEvent

Field Value

Type: RoutedEvent
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.LeftHardLimitProperty Field

JointSliderLeftHardLimitProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty LeftHardLimitProperty
public:
static initonly DependencyProperty^ LeftHardLimitProperty

Field Value

Type: DependencyProperty
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.LeftSoftLimitProperty Field

JointSliderLeftSoftLimitProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty LeftSoftLimitProperty
public:
static initonly DependencyProperty^ LeftSoftLimitProperty

Field Value

Type: DependencyProperty
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.MaximumRangeProperty Field

JointSliderMaximumRangeProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty MaximumRangeProperty
public:
static initonly DependencyProperty^ MaximumRangeProperty

Field Value

Type: DependencyProperty
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.MinimumRangeProperty Field

JointSliderMinimumRangeProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty MinimumRangeProperty
public:
static initonly DependencyProperty^ MinimumRangeProperty

Field Value

Type: DependencyProperty
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.RangeFillColourProperty Field

JointSliderRangeFillColourProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty RangeFillColourProperty
public:
static initonly DependencyProperty^ RangeFillColourProperty

Field Value

Type: DependencyProperty
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.RangeIndicatorColourProperty Field

JointSliderRangeIndicatorColourProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty RangeIndicatorColourProperty
public:
static initonly DependencyProperty^ RangeIndicatorColourProperty

Field Value

Type: DependencyProperty
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.RangeIndicatorLeftMarginProperty Field

JointSliderRangeIndicatorLeftMarginProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty RangeIndicatorLeftMarginProperty
public:
static initonly DependencyProperty^ RangeIndicatorLeftMarginProperty

Field Value

Type: DependencyProperty
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.RangeIndicatorWidthProperty Field

JointSliderRangeIndicatorWidthProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty RangeIndicatorWidthProperty
public:
static initonly DependencyProperty^ RangeIndicatorWidthProperty

Field Value

Type: DependencyProperty
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.RangeLableVisibilityProperty Field

JointSliderRangeLableVisibilityProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty RangeLableVisibilityProperty
public:
static initonly DependencyProperty^ RangeLableVisibilityProperty

Field Value

Type: DependencyProperty
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.RealValueProperty Field

JointSliderRealValueProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty RealValueProperty
public:
static initonly DependencyProperty^ RealValueProperty

Field Value

Type: DependencyProperty
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.ResetProperty Field

JointSliderResetProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ResetProperty
public:
static initonly DependencyProperty^ ResetProperty

Field Value

Type: DependencyProperty
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.RightHardLimitProperty Field

JointSliderRightHardLimitProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty RightHardLimitProperty
public:
static initonly DependencyProperty^ RightHardLimitProperty

Field Value

Type: DependencyProperty
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.RightSoftLimitProperty Field

JointSliderRightSoftLimitProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty RightSoftLimitProperty
public:
static initonly DependencyProperty^ RightSoftLimitProperty

Field Value

Type: DependencyProperty
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.SafeZoneColorProperty Field

JointSliderSafeZoneColorProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty SafeZoneColorProperty
public:
static initonly DependencyProperty^ SafeZoneColorProperty

Field Value

Type: DependencyProperty
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.SoftLimitZoneColorProperty Field

JointSliderSoftLimitZoneColorProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty SoftLimitZoneColorProperty
public:
static initonly DependencyProperty^ SoftLimitZoneColorProperty

Field Value

Type: DependencyProperty
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.ThumbColorProperty Field

JointSliderThumbColorProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ThumbColorProperty
public:
static initonly DependencyProperty^ ThumbColorProperty

Field Value

Type: DependencyProperty
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


JointSlider.TurnCountVisibilityProperty Field

JointSliderTurnCountVisibilityProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty TurnCountVisibilityProperty
public:
static initonly DependencyProperty^ TurnCountVisibilityProperty

Field Value

Type: DependencyProperty
See Also

Reference

JointSlider Class
VisualComponents.UX.Shared Namespace


KeepLatestWorker(T1, T2, TResult) Class

KeepLatestWorkerT1, T2, TResult Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
VisualComponents.UX.SharedKeepLatestWorkerT1, T2, TResult

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class KeepLatestWorker<T1, T2, TResult> : DependencyObject,
    INotifyPropertyChanged

generic<typename T1, typename T2, typename TResult>
public ref class KeepLatestWorker : public DependencyObject,
    INotifyPropertyChanged

Type Parameters

T1
T2
TResult

The KeepLatestWorkerT1, T2, TResult type exposes the following members.

Constructors
 | Name | Description
Public method | KeepLatestWorkerT1, T2, TResult | Initializes a new instance of the KeepLatestWorkerT1, T2, TResult class
Top
Properties
 | Name | Description
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Input1 |
Public property | Input2 |
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | Result |
Top
Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from DependencyObject.)
Public method | RaisePropertyChanged |
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


KeepLatestWorker(T1, T2, TResult) Constructor

KeepLatestWorkerT1, T2, TResult Constructor

Initializes a new instance of the KeepLatestWorkerT1, T2, TResult class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public KeepLatestWorker(
    Func<T1, T2, TResult> workFunction
)
public:
KeepLatestWorker(
    Func<T1, T2, TResult>^ workFunction
)

Parameters

workFunction
Type: SystemFuncT1, T2, TResult
See Also

Reference

KeepLatestWorkerT1, T2, TResult Class
VisualComponents.UX.Shared Namespace


KeepLatestWorker(T1, T2, TResult) Properties

KeepLatestWorkerT1, T2, TResult Properties

The KeepLatestWorkerT1, T2, TResult generic type exposes the following members.

Properties
 | Name | Description
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Input1 |
Public property | Input2 |
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | Result |
Top
See Also

Reference

KeepLatestWorkerT1, T2, TResult Class
VisualComponents.UX.Shared Namespace


KeepLatestWorker(T1, T2, TResult).Input1 Property

KeepLatestWorkerT1, T2, TResultInput1 Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public T1 Input1 { get; set; }
public:
property T1 Input1 {
    T1 get ();
    void set (T1 value);
}

Property Value

Type: T1
See Also

Reference

KeepLatestWorkerT1, T2, TResult Class
VisualComponents.UX.Shared Namespace


KeepLatestWorker(T1, T2, TResult).Input2 Property

KeepLatestWorkerT1, T2, TResultInput2 Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public T2 Input2 { get; set; }
public:
property T2 Input2 {
    T2 get ();
    void set (T2 value);
}

Property Value

Type: T2
See Also

Reference

KeepLatestWorkerT1, T2, TResult Class
VisualComponents.UX.Shared Namespace


KeepLatestWorker(T1, T2, TResult).Result Property

KeepLatestWorkerT1, T2, TResultResult Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TResult Result { get; }
public:
property TResult Result {
    TResult get ();
}

Property Value

Type: TResult
See Also

Reference

KeepLatestWorkerT1, T2, TResult Class
VisualComponents.UX.Shared Namespace


KeepLatestWorker(T1, T2, TResult) Methods

KeepLatestWorkerT1, T2, TResult Methods

The KeepLatestWorkerT1, T2, TResult generic type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this DependencyObject has been updated. The specific dependency property that changed is reported in the event data. (Inherited from DependencyObject.)
Public method | RaisePropertyChanged |
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

KeepLatestWorkerT1, T2, TResult Class
VisualComponents.UX.Shared Namespace


KeepLatestWorker(T1, T2, TResult).RaisePropertyChanged Method

KeepLatestWorkerT1, T2, TResultRaisePropertyChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RaisePropertyChanged(
    string PropertyName
)
public:
void RaisePropertyChanged(
    String^ PropertyName
)

Parameters

PropertyName
Type: SystemString
See Also

Reference

KeepLatestWorkerT1, T2, TResult Class
VisualComponents.UX.Shared Namespace


KeepLatestWorker(T1, T2, TResult) Events

KeepLatestWorkerT1, T2, TResult Events

The KeepLatestWorkerT1, T2, TResult generic type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

KeepLatestWorkerT1, T2, TResult Class
VisualComponents.UX.Shared Namespace


KeepLatestWorker(T1, T2, TResult).PropertyChanged Event

KeepLatestWorkerT1, T2, TResultPropertyChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event PropertyChangedEventHandler PropertyChanged
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

KeepLatestWorkerT1, T2, TResult Class
VisualComponents.UX.Shared Namespace


KeyboardExtensions Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedKeyboardExtensions

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class KeyboardExtensions
public ref class KeyboardExtensions abstract sealed

The KeyboardExtensions type exposes the following members.

Methods
Name | Description
CheckKeyboardState |
IsShortCutPressed |
KeyDown |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


KeyboardExtensions Methods

The KeyboardExtensions type exposes the following members.

Methods
Name | Description
CheckKeyboardState |
IsShortCutPressed |
KeyDown |
Top
See Also

Reference

KeyboardExtensions Class
VisualComponents.UX.Shared Namespace


KeyboardExtensions.CheckKeyboardState Method

KeyboardExtensionsCheckKeyboardState Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool CheckKeyboardState(
    Key shortcutkey,
    ModifierKeys modifierkey
)
public:
static bool CheckKeyboardState(
    Key shortcutkey,
    ModifierKeys modifierkey
)

Parameters

shortcutkey
Type: System.Windows.InputKey
modifierkey
Type: System.Windows.InputModifierKeys

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.KeyboardExtensions.CheckKeyboardState(System.Windows.Input.Key,System.Windows.Input.ModifierKeys)"]

See Also

Reference

KeyboardExtensions Class
VisualComponents.UX.Shared Namespace


KeyboardExtensions.IsShortCutPressed Method

KeyboardExtensionsIsShortCutPressed Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsShortCutPressed()
public:
static bool IsShortCutPressed()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.KeyboardExtensions.IsShortCutPressed"]

See Also

Reference

KeyboardExtensions Class
VisualComponents.UX.Shared Namespace


KeyboardExtensions.KeyDown Method

KeyboardExtensionsKeyDown Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool KeyDown(
    Key key
)
public:
static bool KeyDown(
    Key key
)

Parameters

key
Type: System.Windows.InputKey

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.KeyboardExtensions.KeyDown(System.Windows.Input.Key)"]

See Also

Reference

KeyboardExtensions Class
VisualComponents.UX.Shared Namespace


KeyboardPattern Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedKeyboardPattern

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class KeyboardPattern : IEquatable<KeyboardPattern>
public ref class KeyboardPattern : IEquatable<KeyboardPattern^>

The KeyboardPattern type exposes the following members.

Constructors
 | Name | Description
Public method | KeyboardPattern | Initializes a new instance of the KeyboardPattern class
Top
Properties
 | Name | Description
Public property | ActionItemId |
Public property | command |
Public property | ContextId |
Public property | Key |
Public property | Modifiers |
Top
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(KeyboardPattern) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


KeyboardPattern Constructor

Initializes a new instance of the KeyboardPattern class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public KeyboardPattern()
public:
KeyboardPattern()
See Also

Reference

KeyboardPattern Class
VisualComponents.UX.Shared Namespace


KeyboardPattern Properties

The KeyboardPattern type exposes the following members.

Properties
 | Name | Description
Public property | ActionItemId |
Public property | command |
Public property | ContextId |
Public property | Key |
Public property | Modifiers |
Top
See Also

Reference

KeyboardPattern Class
VisualComponents.UX.Shared Namespace


KeyboardPattern.ActionItemId Property

KeyboardPatternActionItemId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ActionItemId { get; set; }
public:
property String^ ActionItemId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

KeyboardPattern Class
VisualComponents.UX.Shared Namespace


KeyboardPattern.command Property

KeyboardPatterncommand Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InputBindingTriggerEx command { get; set; }
public:
property InputBindingTriggerEx^ command {
    InputBindingTriggerEx^ get ();
    void set (InputBindingTriggerEx^ value);
}

Property Value

Type: InputBindingTriggerEx
See Also

Reference

KeyboardPattern Class
VisualComponents.UX.Shared Namespace


KeyboardPattern.ContextId Property

KeyboardPatternContextId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ContextId { get; set; }
public:
property String^ ContextId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

KeyboardPattern Class
VisualComponents.UX.Shared Namespace


KeyboardPattern.Key Property

KeyboardPatternKey Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Key { get; set; }
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

KeyboardPattern Class
VisualComponents.UX.Shared Namespace


KeyboardPattern.Modifiers Property

KeyboardPatternModifiers Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Modifiers { get; set; }
public:
property String^ Modifiers {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

KeyboardPattern Class
VisualComponents.UX.Shared Namespace


KeyboardPattern Methods

The KeyboardPattern type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(KeyboardPattern) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

KeyboardPattern Class
VisualComponents.UX.Shared Namespace


KeyboardPattern.Equals Method

KeyboardPatternEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(KeyboardPattern) |
Top
See Also

Reference

KeyboardPattern Class
VisualComponents.UX.Shared Namespace


KeyboardPattern.Equals Method (Object)

KeyboardPatternEquals Method (Object)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.KeyboardPattern.Equals(System.Object)"]

See Also

Reference

KeyboardPattern Class
Equals Overload
VisualComponents.UX.Shared Namespace


KeyboardPattern.Equals Method (KeyboardPattern)

KeyboardPatternEquals Method (KeyboardPattern)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Equals(
    KeyboardPattern other
)
public:
virtual bool Equals(
    KeyboardPattern^ other
) sealed

Parameters

other
Type: VisualComponents.UX.SharedKeyboardPattern

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.KeyboardPattern.Equals(VisualComponents.UX.Shared.KeyboardPattern)"]

Implements

IEquatableTEquals(T)
See Also

Reference

KeyboardPattern Class
Equals Overload
VisualComponents.UX.Shared Namespace


KeyboardPattern.GetHashCode Method

KeyboardPatternGetHashCode Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override int GetHashCode()
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.KeyboardPattern.GetHashCode"]

See Also

Reference

KeyboardPattern Class
VisualComponents.UX.Shared Namespace


LayoutClearedMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedLayoutClearedMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LayoutClearedMessage
public ref class LayoutClearedMessage

The LayoutClearedMessage type exposes the following members.

Constructors
 | Name | Description
Public method | LayoutClearedMessage | Initializes a new instance of the LayoutClearedMessage class
Top
Properties
 | Name | Description
Public property | ClearingStatus |
Public property | IsApplicationClosing |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


LayoutClearedMessage Constructor

Initializes a new instance of the LayoutClearedMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LayoutClearedMessage(
    LayoutClearingStatus clearingStatus = LayoutClearingStatus.Unknown
)
public:
LayoutClearedMessage(
    LayoutClearingStatus clearingStatus = LayoutClearingStatus::Unknown
)

Parameters

clearingStatus (Optional)
Type: VisualComponents.UX.SharedLayoutClearingStatus
See Also

Reference

LayoutClearedMessage Class
VisualComponents.UX.Shared Namespace


LayoutClearedMessage Properties

The LayoutClearedMessage type exposes the following members.

Properties
 | Name | Description
Public property | ClearingStatus |
Public property | IsApplicationClosing |
Top
See Also

Reference

LayoutClearedMessage Class
VisualComponents.UX.Shared Namespace


LayoutClearedMessage.ClearingStatus Property

LayoutClearedMessageClearingStatus Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LayoutClearingStatus ClearingStatus { get; }
public:
property LayoutClearingStatus ClearingStatus {
    LayoutClearingStatus get ();
}

Property Value

Type: LayoutClearingStatus
See Also

Reference

LayoutClearedMessage Class
VisualComponents.UX.Shared Namespace


LayoutClearedMessage.IsApplicationClosing Property

LayoutClearedMessageIsApplicationClosing Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsApplicationClosing { get; set; }
public:
property bool IsApplicationClosing {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LayoutClearedMessage Class
VisualComponents.UX.Shared Namespace


LayoutClearedMessage Methods

The LayoutClearedMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LayoutClearedMessage Class
VisualComponents.UX.Shared Namespace


LayoutClearingStatus Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum LayoutClearingStatus
public enum class LayoutClearingStatus
Members
Member name | Value | Description
Allowed | 0 |
Started | 1 |
InProgress | 2 |
Completed | 3 |
Unknown | 4 |
See Also

Reference

VisualComponents.UX.Shared Namespace


LayoutElement Class

Base class for all layout elements.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedLayoutElement
VisualComponents.UX.SharedColumn
VisualComponents.UX.SharedControlDescription
VisualComponents.UX.SharedRow
VisualComponents.UX.SharedTab
VisualComponents.UX.SharedTabPage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract class LayoutElement
public ref class LayoutElement abstract

The LayoutElement type exposes the following members.

Constructors
 | Name | Description
Protected method | LayoutElement | Initializes a new instance of the LayoutElement class
Top
Properties
 | Name | Description
Public property | Children | Provides capability to add child elements to any layout element.
Public property | ElementType |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


LayoutElement Constructor

Initializes a new instance of the LayoutElement class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected LayoutElement()
protected:
LayoutElement()
See Also

Reference

LayoutElement Class
VisualComponents.UX.Shared Namespace


LayoutElement Properties

The LayoutElement type exposes the following members.

Properties
 | Name | Description
Public property | Children | Provides capability to add child elements to any layout element.
Public property | ElementType |
Top
See Also

Reference

LayoutElement Class
VisualComponents.UX.Shared Namespace


LayoutElement.Children Property

LayoutElementChildren Property

Provides capability to add child elements to any layout element.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<LayoutElement> Children { get; protected set; }
public:
property List<LayoutElement^>^ Children {
    List<LayoutElement^>^ get ();
    protected: void set (List<LayoutElement^>^ value);
}

Property Value

Type: ListLayoutElement
Remarks
It should be noted that inhering classes implement properties that project the set of layout elements that should be accessed from that class instead of using this directly. For example see Row.Columns.
See Also

Reference

LayoutElement Class
VisualComponents.UX.Shared Namespace


LayoutElement.ElementType Property

LayoutElementElementType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ElementType ElementType { get; set; }
public:
property ElementType ElementType {
    ElementType get ();
    void set (ElementType value);
}

Property Value

Type: ElementType
See Also

Reference

LayoutElement Class
VisualComponents.UX.Shared Namespace


LayoutElement Methods

The LayoutElement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LayoutElement Class
VisualComponents.UX.Shared Namespace


LayoutItemCommandStatus Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum LayoutItemCommandStatus
public enum class LayoutItemCommandStatus
Members
Member name | Value | Description
STARTED | 0 |
ENDED | 1 |
See Also

Reference

VisualComponents.UX.Shared Namespace


LayoutItemCommandStatusMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedLayoutItemCommandStatusMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LayoutItemCommandStatusMessage
public ref class LayoutItemCommandStatusMessage

The LayoutItemCommandStatusMessage type exposes the following members.

Constructors
 | Name | Description
Public method | LayoutItemCommandStatusMessage | Initializes a new instance of the LayoutItemCommandStatusMessage class
Top
Properties
 | Name | Description
Public property | Status |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


LayoutItemCommandStatusMessage Constructor

Initializes a new instance of the LayoutItemCommandStatusMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LayoutItemCommandStatusMessage()
public:
LayoutItemCommandStatusMessage()
See Also

Reference

LayoutItemCommandStatusMessage Class
VisualComponents.UX.Shared Namespace


LayoutItemCommandStatusMessage Properties

The LayoutItemCommandStatusMessage type exposes the following members.

Properties
 | Name | Description
Public property | Status |
Top
See Also

Reference

LayoutItemCommandStatusMessage Class
VisualComponents.UX.Shared Namespace


LayoutItemCommandStatusMessage.Status Property

LayoutItemCommandStatusMessageStatus Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LayoutItemCommandStatus Status { get; set; }
public:
property LayoutItemCommandStatus Status {
    LayoutItemCommandStatus get ();
    void set (LayoutItemCommandStatus value);
}

Property Value

Type: LayoutItemCommandStatus
See Also

Reference

LayoutItemCommandStatusMessage Class
VisualComponents.UX.Shared Namespace


LayoutItemCommandStatusMessage Methods

The LayoutItemCommandStatusMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LayoutItemCommandStatusMessage Class
VisualComponents.UX.Shared Namespace


LayoutLoadedMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedLayoutLoadedMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LayoutLoadedMessage
public ref class LayoutLoadedMessage

The LayoutLoadedMessage type exposes the following members.

Constructors
 | Name | Description
Public method | LayoutLoadedMessage | Initializes a new instance of the LayoutLoadedMessage class
Top
Properties
 | Name | Description
Public property | LoadingStatus |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


LayoutLoadedMessage Constructor

Initializes a new instance of the LayoutLoadedMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LayoutLoadedMessage(
    LayoutLoadingStatus loadingStatus = LayoutLoadingStatus.Unknown
)
public:
LayoutLoadedMessage(
    LayoutLoadingStatus loadingStatus = LayoutLoadingStatus::Unknown
)

Parameters

loadingStatus (Optional)
Type: VisualComponents.UX.SharedLayoutLoadingStatus
See Also

Reference

LayoutLoadedMessage Class
VisualComponents.UX.Shared Namespace


LayoutLoadedMessage Properties

The LayoutLoadedMessage type exposes the following members.

Properties
 | Name | Description
Public property | LoadingStatus |
Top
See Also

Reference

LayoutLoadedMessage Class
VisualComponents.UX.Shared Namespace


LayoutLoadedMessage.LoadingStatus Property

LayoutLoadedMessageLoadingStatus Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LayoutLoadingStatus LoadingStatus { get; }
public:
property LayoutLoadingStatus LoadingStatus {
    LayoutLoadingStatus get ();
}

Property Value

Type: LayoutLoadingStatus
See Also

Reference

LayoutLoadedMessage Class
VisualComponents.UX.Shared Namespace


LayoutLoadedMessage Methods

The LayoutLoadedMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LayoutLoadedMessage Class
VisualComponents.UX.Shared Namespace


LayoutLoadingStatus Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum LayoutLoadingStatus
public enum class LayoutLoadingStatus
Members
Member name | Value | Description
Started | 0 |
InProgress | 1 |
Completed | 2 |
Unknown | 3 |
See Also

Reference

VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings Class

layout MetaData Settings
Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.SharedLayoutMetaDataSettings

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LayoutMetaDataSettings : PropertyChangedBase
public ref class LayoutMetaDataSettings : public PropertyChangedBase

The LayoutMetaDataSettings type exposes the following members.

Constructors
 | Name | Description
Public method | LayoutMetaDataSettings | Initializes a new instance of the LayoutMetaDataSettings class
Top
Properties
 | Name | Description
Public property | Author |
Public property | AutoIncrementRevision |
Public property | CompanyLogo |
Public property | Description |
Public property | Email |
Public property | File |
Public property | IsDeprecated |
Public property | IsEmpty |
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | Manufacturer |
Public property | MaxPayload |
Public property | Metadata |
Public property | Modified |
Public property | Name |
Public property | Preview |
Public property | Reach |
Public property | ReadOnly |
Public property | Revision |
Public property | Tags |
Public property | Type |
Public property | VCID |
Public property | Website |
Top
Methods
 | Name | Description
Public method | Clear |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh |
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateMetaDataSettings |
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
Fields
 | Name | Description
Public field | _email |
Public field | LayoutFilePath |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings Constructor

Initializes a new instance of the LayoutMetaDataSettings class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LayoutMetaDataSettings()
public:
LayoutMetaDataSettings()
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings Properties

The LayoutMetaDataSettings type exposes the following members.

Properties
 | Name | Description
Public property | Author |
Public property | AutoIncrementRevision |
Public property | CompanyLogo |
Public property | Description |
Public property | Email |
Public property | File |
Public property | IsDeprecated |
Public property | IsEmpty |
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | Manufacturer |
Public property | MaxPayload |
Public property | Metadata |
Public property | Modified |
Public property | Name |
Public property | Preview |
Public property | Reach |
Public property | ReadOnly |
Public property | Revision |
Public property | Tags |
Public property | Type |
Public property | VCID |
Public property | Website |
Top
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings.Author Property

LayoutMetaDataSettingsAuthor Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Author { get; set; }
public:
property String^ Author {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings.AutoIncrementRevision Property

LayoutMetaDataSettingsAutoIncrementRevision Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool AutoIncrementRevision { get; set; }
public:
property bool AutoIncrementRevision {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings.CompanyLogo Property

LayoutMetaDataSettingsCompanyLogo Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Bitmap CompanyLogo { get; set; }
public:
property Bitmap^ CompanyLogo {
    Bitmap^ get ();
    void set (Bitmap^ value);
}

Property Value

Type: Bitmap
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings.Description Property

LayoutMetaDataSettingsDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; set; }
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings.Email Property

LayoutMetaDataSettingsEmail Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Email { get; set; }
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings.File Property

LayoutMetaDataSettingsFile Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string File { get; set; }
public:
property String^ File {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings.IsDeprecated Property

LayoutMetaDataSettingsIsDeprecated Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsDeprecated { get; set; }
public:
property bool IsDeprecated {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings.IsEmpty Property

LayoutMetaDataSettingsIsEmpty Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsEmpty { get; set; }
public:
property bool IsEmpty {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings.Manufacturer Property

LayoutMetaDataSettingsManufacturer Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Manufacturer { get; set; }
public:
property String^ Manufacturer {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings.MaxPayload Property

LayoutMetaDataSettingsMaxPayload Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int MaxPayload { get; set; }
public:
property int MaxPayload {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings.Metadata Property

LayoutMetaDataSettingsMetadata Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IModelMetadata Metadata { get; set; }
public:
property IModelMetadata^ Metadata {
    IModelMetadata^ get ();
    void set (IModelMetadata^ value);
}

Property Value

Type: IModelMetadata
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings.Modified Property

LayoutMetaDataSettingsModified Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Modified { get; set; }
public:
property String^ Modified {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings.Name Property

LayoutMetaDataSettingsName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; set; }
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings.Preview Property

LayoutMetaDataSettingsPreview Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Bitmap Preview { get; set; }
public:
property Bitmap^ Preview {
    Bitmap^ get ();
    void set (Bitmap^ value);
}

Property Value

Type: Bitmap
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings.Reach Property

LayoutMetaDataSettingsReach Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Reach { get; set; }
public:
property int Reach {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings.ReadOnly Property

LayoutMetaDataSettingsReadOnly Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ReadOnly { get; set; }
public:
property bool ReadOnly {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings.Revision Property

LayoutMetaDataSettingsRevision Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Revision { get; set; }
public:
property int Revision {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings.Tags Property

LayoutMetaDataSettingsTags Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Tags { get; set; }
public:
property String^ Tags {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings.Type Property

LayoutMetaDataSettingsType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Type { get; set; }
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings.VCID Property

LayoutMetaDataSettingsVCID Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string VCID { get; set; }
public:
property String^ VCID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings.Website Property

LayoutMetaDataSettingsWebsite Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Website { get; set; }
public:
property String^ Website {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings Methods

The LayoutMetaDataSettings type exposes the following members.

Methods
 | Name | Description
Public method | Clear |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh |
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateMetaDataSettings |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings.Clear Method

LayoutMetaDataSettingsClear Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Clear()
public:
void Clear()
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings.Refresh Method

LayoutMetaDataSettingsRefresh Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Refresh()
public:
void Refresh()
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings.UpdateMetaDataSettings Method

LayoutMetaDataSettingsUpdateMetaDataSettings Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void UpdateMetaDataSettings(
    IModelMetadata metadata,
    string layoutFilePath
)
public:
void UpdateMetaDataSettings(
    IModelMetadata^ metadata,
    String^ layoutFilePath
)

Parameters

metadata
Type: VisualComponents.Create3DIModelMetadata
layoutFilePath
Type: SystemString
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings Events

The LayoutMetaDataSettings type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings Fields

The LayoutMetaDataSettings type exposes the following members.

Fields
 | Name | Description
Public field | _email |
Public field | LayoutFilePath |
Top
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings._email Field

LayoutMetaDataSettings_email Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string _email
public:
String^ _email

Field Value

Type: String
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LayoutMetaDataSettings.LayoutFilePath Field

LayoutMetaDataSettingsLayoutFilePath Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string LayoutFilePath
public:
String^ LayoutFilePath

Field Value

Type: String
See Also

Reference

LayoutMetaDataSettings Class
VisualComponents.UX.Shared Namespace


LeftMarginMultiplierConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedLeftMarginMultiplierConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LeftMarginMultiplierConverter : IValueConverter
public ref class LeftMarginMultiplierConverter : IValueConverter

The LeftMarginMultiplierConverter type exposes the following members.

Constructors
 | Name | Description
Public method | LeftMarginMultiplierConverter | Initializes a new instance of the LeftMarginMultiplierConverter class
Top
Properties
 | Name | Description
Public property | Length |
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetDepth |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


LeftMarginMultiplierConverter Constructor

Initializes a new instance of the LeftMarginMultiplierConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LeftMarginMultiplierConverter()
public:
LeftMarginMultiplierConverter()
See Also

Reference

LeftMarginMultiplierConverter Class
VisualComponents.UX.Shared Namespace


LeftMarginMultiplierConverter Properties

The LeftMarginMultiplierConverter type exposes the following members.

Properties
 | Name | Description
Public property | Length |
Top
See Also

Reference

LeftMarginMultiplierConverter Class
VisualComponents.UX.Shared Namespace


LeftMarginMultiplierConverter.Length Property

LeftMarginMultiplierConverterLength Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Length { get; set; }
public:
property double Length {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

LeftMarginMultiplierConverter Class
VisualComponents.UX.Shared Namespace


LeftMarginMultiplierConverter Methods

The LeftMarginMultiplierConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetDepth |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LeftMarginMultiplierConverter Class
VisualComponents.UX.Shared Namespace


LeftMarginMultiplierConverter.Convert Method

LeftMarginMultiplierConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.LeftMarginMultiplierConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

LeftMarginMultiplierConverter Class
VisualComponents.UX.Shared Namespace


LeftMarginMultiplierConverter.ConvertBack Method

LeftMarginMultiplierConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.LeftMarginMultiplierConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

LeftMarginMultiplierConverter Class
VisualComponents.UX.Shared Namespace


LeftMarginMultiplierConverter.GetDepth Method

LeftMarginMultiplierConverterGetDepth Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int GetDepth(
    TreeViewItem item
)
public:
static int GetDepth(
    TreeViewItem^ item
)

Parameters

item
Type: System.Windows.ControlsTreeViewItem

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.LeftMarginMultiplierConverter.GetDepth(System.Windows.Controls.TreeViewItem)"]

See Also

Reference

LeftMarginMultiplierConverter Class
VisualComponents.UX.Shared Namespace


LicensedAddOnBase Class

Provides license checking functionality for add-ons with external licensing.
Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.SharedLicensedAddOnBase

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public abstract class LicensedAddOnBase : PropertyChangedBase,
    IAddOnSetting
public ref class LicensedAddOnBase abstract : public PropertyChangedBase,
    IAddOnSetting

The LicensedAddOnBase type exposes the following members.

Constructors
 | Name | Description
Protected method | LicensedAddOnBase | Initializes a new instance of the LicensedAddOnBase class
Top
Properties
 | Name | Description
Protected property | ExternalFeatures |
Public property | IsActivated |
Public property | IsEnabled |
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | Order |
Top
Methods
 | Name | Description
Public method | CancelApplyingSetting |
Public method | DisableAddOn |
Protected method | DisableFunctionality | Called when the actual functionality of the add-on should be disabled.
Public method | EnableAddOn |
Protected method | EnableFunctionality | Called when the actual functionality of the add-on should be enabled.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnLicenseServerConnectionAttemptFailed | Called on network license server connection timeout. If connection is not restored until grace time runs out, the add-on should be disabled.
Protected method | OnLicenseServerConnectionRestored | Called if network license server connection is restored after OnLicenseServerConnectionAttemptFailed(LicenseCheckFailedEventArgs).
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Protected method | ReadIsEnabledFromConfig | Called when the application is initialized. Return value is assigned to IsEnabled.
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SaveAndApplySetting |
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | TestVirtualLicenseHandle | Returns true if testing the handle succeeded, otherwise false. Do not use ILicenseHandle.Test() with null parameter, call this instead!
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | WriteIsEnabledToConfig | Called when the value of IsEnabled changes.
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
Fields
 | Name | Description
Protected field | _application |
Protected field | _licensingService |
Protected field | _licensor |
Protected field | Licenses | Contains license objects needed to occupy seats in the network license server.
Protected field | RequestedFeatures | Contains license features requested by the add-on. This collection should be populated by the implementing class.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks
Implementing class should add license features requested by the add-on to RequestedFeatures collection.
See Also

Reference

VisualComponents.UX.Shared Namespace


LicensedAddOnBase Constructor

Initializes a new instance of the LicensedAddOnBase class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected LicensedAddOnBase(
    IApplication application,
    ILicensingService licensingService,
    ILicensor licensor
)
protected:
LicensedAddOnBase(
    IApplication^ application,
    ILicensingService^ licensingService,
    ILicensor^ licensor
)

Parameters

application
Type: VisualComponents.Create3DIApplication
licensingService
Type: VisualComponents.Create3DILicensingService
licensor
Type: ILicensor
See Also

Reference

LicensedAddOnBase Class
VisualComponents.UX.Shared Namespace


LicensedAddOnBase Properties

The LicensedAddOnBase type exposes the following members.

Properties
 | Name | Description
Protected property | ExternalFeatures |
Public property | IsActivated |
Public property | IsEnabled |
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | Order |
Top
See Also

Reference

LicensedAddOnBase Class
VisualComponents.UX.Shared Namespace


LicensedAddOnBase.ExternalFeatures Property

LicensedAddOnBaseExternalFeatures Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected HashSet<ProductFeature> ExternalFeatures { get; }
protected:
property HashSet<ProductFeature>^ ExternalFeatures {
    HashSet<ProductFeature>^ get ();
}

Property Value

Type: HashSetProductFeature
See Also

Reference

LicensedAddOnBase Class
VisualComponents.UX.Shared Namespace


LicensedAddOnBase.IsActivated Property

LicensedAddOnBaseIsActivated Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual bool IsActivated { get; set; }
public:
virtual property bool IsActivated {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LicensedAddOnBase Class
VisualComponents.UX.Shared Namespace


LicensedAddOnBase.IsEnabled Property

LicensedAddOnBaseIsEnabled Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual bool IsEnabled { get; set; }
public:
virtual property bool IsEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IAddOnSettingIsEnabled
See Also

Reference

LicensedAddOnBase Class
VisualComponents.UX.Shared Namespace


LicensedAddOnBase.Order Property

LicensedAddOnBaseOrder Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual uint Order { get; }
public:
virtual property unsigned int Order {
    unsigned int get ();
}

Property Value

Type: UInt32

Implements

IAddOnSettingOrder
See Also

Reference

LicensedAddOnBase Class
VisualComponents.UX.Shared Namespace


LicensedAddOnBase Methods

The LicensedAddOnBase type exposes the following members.

Methods
 | Name | Description
Public method | CancelApplyingSetting |
Public method | DisableAddOn |
Protected method | DisableFunctionality | Called when the actual functionality of the add-on should be disabled.
Public method | EnableAddOn |
Protected method | EnableFunctionality | Called when the actual functionality of the add-on should be enabled.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnLicenseServerConnectionAttemptFailed | Called on network license server connection timeout. If connection is not restored until grace time runs out, the add-on should be disabled.
Protected method | OnLicenseServerConnectionRestored | Called if network license server connection is restored after OnLicenseServerConnectionAttemptFailed(LicenseCheckFailedEventArgs).
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Protected method | ReadIsEnabledFromConfig | Called when the application is initialized. Return value is assigned to IsEnabled.
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SaveAndApplySetting |
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | TestVirtualLicenseHandle | Returns true if testing the handle succeeded, otherwise false. Do not use ILicenseHandle.Test() with null parameter, call this instead!
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | WriteIsEnabledToConfig | Called when the value of IsEnabled changes.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LicensedAddOnBase Class
VisualComponents.UX.Shared Namespace


LicensedAddOnBase.CancelApplyingSetting Method

LicensedAddOnBaseCancelApplyingSetting Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void CancelApplyingSetting()
public:
virtual void CancelApplyingSetting()

Implements

IAddOnSettingCancelApplyingSetting
See Also

Reference

LicensedAddOnBase Class
VisualComponents.UX.Shared Namespace


LicensedAddOnBase.DisableAddOn Method

LicensedAddOnBaseDisableAddOn Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void DisableAddOn()
public:
virtual void DisableAddOn()

Implements

IAddOnSettingDisableAddOn
See Also

Reference

LicensedAddOnBase Class
VisualComponents.UX.Shared Namespace


LicensedAddOnBase.DisableFunctionality Method

LicensedAddOnBaseDisableFunctionality Method

Called when the actual functionality of the add-on should be disabled.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected abstract void DisableFunctionality()
protected:
virtual void DisableFunctionality() abstract
See Also

Reference

LicensedAddOnBase Class
VisualComponents.UX.Shared Namespace


LicensedAddOnBase.EnableAddOn Method

LicensedAddOnBaseEnableAddOn Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void EnableAddOn()
public:
virtual void EnableAddOn()

Implements

IAddOnSettingEnableAddOn
See Also

Reference

LicensedAddOnBase Class
VisualComponents.UX.Shared Namespace


LicensedAddOnBase.EnableFunctionality Method

LicensedAddOnBaseEnableFunctionality Method

Called when the actual functionality of the add-on should be enabled.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected abstract void EnableFunctionality()
protected:
virtual void EnableFunctionality() abstract
See Also

Reference

LicensedAddOnBase Class
VisualComponents.UX.Shared Namespace


LicensedAddOnBase.OnLicenseServerConnectionAttemptFailed Method

LicensedAddOnBaseOnLicenseServerConnectionAttemptFailed Method

Called on network license server connection timeout. If connection is not restored until grace time runs out, the add-on should be disabled.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void OnLicenseServerConnectionAttemptFailed(
    LicenseCheckFailedEventArgs eventArgs
)
protected:
virtual void OnLicenseServerConnectionAttemptFailed(
    LicenseCheckFailedEventArgs^ eventArgs
)

Parameters

eventArgs
Type: VisualComponents.Create3DLicenseCheckFailedEventArgs
See Also

Reference

LicensedAddOnBase Class
VisualComponents.UX.Shared Namespace


LicensedAddOnBase.OnLicenseServerConnectionRestored Method

LicensedAddOnBaseOnLicenseServerConnectionRestored Method

Called if network license server connection is restored after OnLicenseServerConnectionAttemptFailed(LicenseCheckFailedEventArgs).

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void OnLicenseServerConnectionRestored()
protected:
virtual void OnLicenseServerConnectionRestored()
See Also

Reference

LicensedAddOnBase Class
VisualComponents.UX.Shared Namespace


LicensedAddOnBase.ReadIsEnabledFromConfig Method

LicensedAddOnBaseReadIsEnabledFromConfig Method

Called when the application is initialized. Return value is assigned to IsEnabled.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected abstract bool ReadIsEnabledFromConfig()
protected:
virtual bool ReadIsEnabledFromConfig() abstract

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.LicensedAddOnBase.ReadIsEnabledFromConfig"]

See Also

Reference

LicensedAddOnBase Class
VisualComponents.UX.Shared Namespace


LicensedAddOnBase.SaveAndApplySetting Method

LicensedAddOnBaseSaveAndApplySetting Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void SaveAndApplySetting()
public:
virtual void SaveAndApplySetting()

Implements

IAddOnSettingSaveAndApplySetting
See Also

Reference

LicensedAddOnBase Class
VisualComponents.UX.Shared Namespace


LicensedAddOnBase.TestVirtualLicenseHandle Method

LicensedAddOnBaseTestVirtualLicenseHandle Method

Returns true if testing the handle succeeded, otherwise false.

Do not use ILicenseHandle.Test() with null parameter, call this instead!

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool TestVirtualLicenseHandle(
    ILicenseHandle handle
)
public:
bool TestVirtualLicenseHandle(
    ILicenseHandle^ handle
)

Parameters

handle
Type: VisualComponents.Create3DILicenseHandle

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.LicensedAddOnBase.TestVirtualLicenseHandle(VisualComponents.Create3D.ILicenseHandle)"]

See Also

Reference

LicensedAddOnBase Class
VisualComponents.UX.Shared Namespace


LicensedAddOnBase.WriteIsEnabledToConfig Method

LicensedAddOnBaseWriteIsEnabledToConfig Method

Called when the value of IsEnabled changes.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected abstract void WriteIsEnabledToConfig(
    bool isEnabled
)
protected:
virtual void WriteIsEnabledToConfig(
    bool isEnabled
) abstract

Parameters

isEnabled
Type: SystemBoolean
See Also

Reference

LicensedAddOnBase Class
VisualComponents.UX.Shared Namespace


LicensedAddOnBase Events

The LicensedAddOnBase type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
See Also

Reference

LicensedAddOnBase Class
VisualComponents.UX.Shared Namespace


LicensedAddOnBase Fields

The LicensedAddOnBase type exposes the following members.

Fields
 | Name | Description
Protected field | _application |
Protected field | _licensingService |
Protected field | _licensor |
Protected field | Licenses | Contains license objects needed to occupy seats in the network license server.
Protected field | RequestedFeatures | Contains license features requested by the add-on. This collection should be populated by the implementing class.
Top
See Also

Reference

LicensedAddOnBase Class
VisualComponents.UX.Shared Namespace


LicensedAddOnBase._application Field

LicensedAddOnBase_application Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected readonly IApplication _application
protected:
initonly IApplication^ _application

Field Value

Type: IApplication
See Also

Reference

LicensedAddOnBase Class
VisualComponents.UX.Shared Namespace


LicensedAddOnBase._licensingService Field

LicensedAddOnBase_licensingService Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected readonly ILicensingService _licensingService
protected:
initonly ILicensingService^ _licensingService

Field Value

Type: ILicensingService
See Also

Reference

LicensedAddOnBase Class
VisualComponents.UX.Shared Namespace


LicensedAddOnBase._licensor Field

LicensedAddOnBase_licensor Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected readonly ILicensor _licensor
protected:
initonly ILicensor^ _licensor

Field Value

Type: ILicensor
See Also

Reference

LicensedAddOnBase Class
VisualComponents.UX.Shared Namespace


LicensedAddOnBase.Licenses Field

LicensedAddOnBaseLicenses Field

Contains license objects needed to occupy seats in the network license server.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected readonly List<KeyValuePair<ILicenseHandle, ProductLicenseType>> Licenses
protected:
initonly List<KeyValuePair<ILicenseHandle^, ProductLicenseType>>^ Licenses

Field Value

Type: ListKeyValuePairILicenseHandle, ProductLicenseType
See Also

Reference

LicensedAddOnBase Class
VisualComponents.UX.Shared Namespace


LicensedAddOnBase.RequestedFeatures Field

LicensedAddOnBaseRequestedFeatures Field

Contains license features requested by the add-on. This collection should be populated by the implementing class.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected readonly HashSet<ProductFeature> RequestedFeatures
protected:
initonly HashSet<ProductFeature>^ RequestedFeatures

Field Value

Type: HashSetProductFeature
See Also

Reference

LicensedAddOnBase Class
VisualComponents.UX.Shared Namespace


LicenseServerConnectionStatusChangeHandler Delegate

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public delegate void LicenseServerConnectionStatusChangeHandler(
    Object sender,
    ConnectionStatusEventArgs args
)
public delegate void LicenseServerConnectionStatusChangeHandler(
    Object^ sender,
    ConnectionStatusEventArgs^ args
)

Parameters

sender
Type: SystemObject
args
Type: VisualComponents.UX.SharedConnectionStatusEventArgs
See Also

Reference

VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedLinearDimensionCreateAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LinearDimensionCreateAction : ICommandPanelAction,
    IHandle<SnapResultMessage>, IHandle, IHandle<PickMessage>,
    IHandle<RequestActionAbortMessage>
public ref class LinearDimensionCreateAction : ICommandPanelAction,
    IHandle<SnapResultMessage^>, IHandle, IHandle<PickMessage^>,
    IHandle<RequestActionAbortMessage^>

The LinearDimensionCreateAction type exposes the following members.

Constructors
 | Name | Description
Public method | LinearDimensionCreateAction | Initializes a new instance of the LinearDimensionCreateAction class
Top
Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
 | IsExecuting |
Public property | Name |
Public property | Title |
Top
Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle(PickMessage) |
Public method | Handle(RequestActionAbortMessage) |
Public method | Handle(SnapResultMessage) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnPropertyChanged |
Public method | StartAction(EventHandlerResultCompletionEventArgs) |
Public method | StartAction(EventHandlerResultCompletionEventArgs, Boolean) |
 | StopExecuting |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
Name | Description
IsExecutingChanged |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction Constructor

Initializes a new instance of the LinearDimensionCreateAction class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LinearDimensionCreateAction()
public:
LinearDimensionCreateAction()
See Also

Reference

LinearDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction Properties

The LinearDimensionCreateAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
 | IsExecuting |
Public property | Name |
Public property | Title |
Top
See Also

Reference

LinearDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction.ActionFinished Property

LinearDimensionCreateActionActionFinished Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ActionFinished { get; }
public:
virtual property bool ActionFinished {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ICommandPanelActionActionFinished
See Also

Reference

LinearDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction.ActionProperties Property

LinearDimensionCreateActionActionProperties Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<IProperty> ActionProperties { get; }
public:
virtual property List<IProperty^>^ ActionProperties {
    List<IProperty^>^ get () sealed;
}

Property Value

Type: ListIProperty

Implements

ICommandPanelActionActionProperties
See Also

Reference

LinearDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction.ApplyButtonText Property

LinearDimensionCreateActionApplyButtonText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ApplyButtonText { get; }
public:
virtual property String^ ApplyButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionApplyButtonText
See Also

Reference

LinearDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction.AssociatedModelId Property

LinearDimensionCreateActionAssociatedModelId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedModelId { get; }
public:
virtual property String^ AssociatedModelId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedModelId
See Also

Reference

LinearDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction.AssociatedSiteId Property

LinearDimensionCreateActionAssociatedSiteId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedSiteId { get; }
public:
virtual property String^ AssociatedSiteId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedSiteId
See Also

Reference

LinearDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction.CallingCommandName Property

LinearDimensionCreateActionCallingCommandName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CallingCommandName { get; }
public:
virtual property String^ CallingCommandName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCallingCommandName
See Also

Reference

LinearDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction.CancelButtonText Property

LinearDimensionCreateActionCancelButtonText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CancelButtonText { get; }
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCancelButtonText
See Also

Reference

LinearDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction.Description Property

LinearDimensionCreateActionDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; }
public:
virtual property String^ Description {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionDescription
See Also

Reference

LinearDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction.ErrorMessage Property

LinearDimensionCreateActionErrorMessage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ErrorMessage { get; set; }
public:
virtual property String^ ErrorMessage {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionErrorMessage
See Also

Reference

LinearDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction.IsExecuting Property

LinearDimensionCreateActionIsExecuting Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsExecuting { get; }
public:
static property bool IsExecuting {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

LinearDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction.Name Property

LinearDimensionCreateActionName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; }
public:
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

LinearDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction.Title Property

LinearDimensionCreateActionTitle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; }
public:
virtual property String^ Title {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionTitle
See Also

Reference

LinearDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction Methods

The LinearDimensionCreateAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle(PickMessage) |
Public method | Handle(RequestActionAbortMessage) |
Public method | Handle(SnapResultMessage) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnPropertyChanged |
Public method | StartAction(EventHandlerResultCompletionEventArgs) |
Public method | StartAction(EventHandlerResultCompletionEventArgs, Boolean) |
 | StopExecuting |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LinearDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction.ApplyAction Method

LinearDimensionCreateActionApplyAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ApplyAction()
public:
virtual bool ApplyAction() sealed

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.LinearDimensionCreateAction.ApplyAction"]

Implements

ICommandPanelActionApplyAction
See Also

Reference

LinearDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction.CancelAction Method

LinearDimensionCreateActionCancelAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CancelAction()
public:
virtual void CancelAction() sealed

Implements

ICommandPanelActionCancelAction
See Also

Reference

LinearDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction.Execute Method

LinearDimensionCreateActionExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<IResult> Execute()
public:
IEnumerable<IResult^>^ Execute()

Return Value

Type: IEnumerableIResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.LinearDimensionCreateAction.Execute"]

See Also

Reference

LinearDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction.Handle Method

LinearDimensionCreateActionHandle Method

Overload List
 | Name | Description
Public method | Handle(PickMessage) |
Public method | Handle(RequestActionAbortMessage) |
Public method | Handle(SnapResultMessage) |
Top
See Also

Reference

LinearDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction.Handle Method (PickMessage)

LinearDimensionCreateActionHandle Method (PickMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    PickMessage message
)
public:
virtual void Handle(
    PickMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedPickMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

LinearDimensionCreateAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction.Handle Method (RequestActionAbortMessage)

LinearDimensionCreateActionHandle Method (RequestActionAbortMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    RequestActionAbortMessage message
)
public:
virtual void Handle(
    RequestActionAbortMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedRequestActionAbortMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

LinearDimensionCreateAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction.Handle Method (SnapResultMessage)

LinearDimensionCreateActionHandle Method (SnapResultMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    SnapResultMessage message
)
public:
virtual void Handle(
    SnapResultMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedSnapResultMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

LinearDimensionCreateAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction.OnPropertyChanged Method

LinearDimensionCreateActionOnPropertyChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void OnPropertyChanged(
    string name
)
public:
static void OnPropertyChanged(
    String^ name
)

Parameters

name
Type: SystemString
See Also

Reference

LinearDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction.StartAction Method

LinearDimensionCreateActionStartAction Method

Overload List
 | Name | Description
Public method | StartAction(EventHandlerResultCompletionEventArgs) |
Public method | StartAction(EventHandlerResultCompletionEventArgs, Boolean) |
Top
See Also

Reference

LinearDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction.StartAction Method (EventHandler(ResultCompletionEventArgs))

LinearDimensionCreateActionStartAction Method (EventHandlerResultCompletionEventArgs)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    EventHandler<ResultCompletionEventArgs> completed = null
)
public:
virtual void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr
) sealed

Parameters

completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs

Implements

ICommandPanelActionStartAction(EventHandlerResultCompletionEventArgs)
See Also

Reference

LinearDimensionCreateAction Class
StartAction Overload
VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction.StartAction Method (EventHandler(ResultCompletionEventArgs), Boolean)

LinearDimensionCreateActionStartAction Method (EventHandlerResultCompletionEventArgs, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    EventHandler<ResultCompletionEventArgs> completed,
    bool multiShot
)
public:
void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed,
    bool multiShot
)

Parameters

completed
Type: SystemEventHandlerResultCompletionEventArgs
multiShot
Type: SystemBoolean
See Also

Reference

LinearDimensionCreateAction Class
StartAction Overload
VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction.StopExecuting Method

LinearDimensionCreateActionStopExecuting Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void StopExecuting()
public:
static void StopExecuting()
See Also

Reference

LinearDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction Events

The LinearDimensionCreateAction type exposes the following members.

Events
Name | Description
IsExecutingChanged |
Top
See Also

Reference

LinearDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


LinearDimensionCreateAction.IsExecutingChanged Event

LinearDimensionCreateActionIsExecutingChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static event PropertyChangedEventHandler IsExecutingChanged
public:
static  event PropertyChangedEventHandler^ IsExecutingChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler
See Also

Reference

LinearDimensionCreateAction Class
VisualComponents.UX.Shared Namespace


LineRenderer Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
VisualComponents.UX.SharedLineRenderer

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LineRenderer : FrameworkElement
public ref class LineRenderer : public FrameworkElement

The LineRenderer type exposes the following members.

Constructors
 | Name | Description
Public method | LineRenderer | Initializes a new instance of the LineRenderer class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | Fill |
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Thickness |
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
FillProperty |
ThicknessProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


LineRenderer Constructor

Initializes a new instance of the LineRenderer class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LineRenderer()
public:
LineRenderer()
See Also

Reference

LineRenderer Class
VisualComponents.UX.Shared Namespace


LineRenderer Properties

The LineRenderer type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | Fill |
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Thickness |
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

LineRenderer Class
VisualComponents.UX.Shared Namespace


LineRenderer.Fill Property

LineRendererFill Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Brush Fill { get; set; }
public:
property Brush^ Fill {
    Brush^ get ();
    void set (Brush^ value);
}

Property Value

Type: Brush
See Also

Reference

LineRenderer Class
VisualComponents.UX.Shared Namespace


LineRenderer.Thickness Property

LineRendererThickness Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Thickness { get; set; }
public:
property double Thickness {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

LineRenderer Class
VisualComponents.UX.Shared Namespace


LineRenderer Methods

The LineRenderer type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LineRenderer Class
VisualComponents.UX.Shared Namespace


LineRenderer.OnRender Method

LineRendererOnRender Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
protected:
virtual void OnRender(
    DrawingContext^ drawingContext
) override

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
See Also

Reference

LineRenderer Class
VisualComponents.UX.Shared Namespace


LineRenderer Events

The LineRenderer type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

LineRenderer Class
VisualComponents.UX.Shared Namespace


LineRenderer Fields

The LineRenderer type exposes the following members.

Fields
Name | Description
FillProperty |
ThicknessProperty |
Top
See Also

Reference

LineRenderer Class
VisualComponents.UX.Shared Namespace


LineRenderer.FillProperty Field

LineRendererFillProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty FillProperty
public:
static initonly DependencyProperty^ FillProperty

Field Value

Type: DependencyProperty
See Also

Reference

LineRenderer Class
VisualComponents.UX.Shared Namespace


LineRenderer.ThicknessProperty Field

LineRendererThicknessProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ThicknessProperty
public:
static initonly DependencyProperty^ ThicknessProperty

Field Value

Type: DependencyProperty
See Also

Reference

LineRenderer Class
VisualComponents.UX.Shared Namespace


ListBoxItemAttachedProperties Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedListBoxItemAttachedProperties

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class ListBoxItemAttachedProperties
public ref class ListBoxItemAttachedProperties abstract sealed

The ListBoxItemAttachedProperties type exposes the following members.

Methods
Name | Description
GetIsSelectable |
SetIsSelectable |
Top
Fields
Name | Description
IsSelectableProperty |
Top
Attached Properties
 | Name | Description
Public attached property | IsSelectable |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ListBoxItemAttachedProperties Methods

The ListBoxItemAttachedProperties type exposes the following members.

Methods
Name | Description
GetIsSelectable |
SetIsSelectable |
Top
See Also

Reference

ListBoxItemAttachedProperties Class
VisualComponents.UX.Shared Namespace


ListBoxItemAttachedProperties.GetIsSelectable Method

ListBoxItemAttachedPropertiesGetIsSelectable Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool GetIsSelectable(
    ListBoxItem obj
)
public:
static bool GetIsSelectable(
    ListBoxItem^ obj
)

Parameters

obj
Type: System.Windows.ControlsListBoxItem

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ListBoxItemAttachedProperties.GetIsSelectable(System.Windows.Controls.ListBoxItem)"]

See Also

Reference

ListBoxItemAttachedProperties Class
VisualComponents.UX.Shared Namespace


ListBoxItemAttachedProperties.SetIsSelectable Method

ListBoxItemAttachedPropertiesSetIsSelectable Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetIsSelectable(
    ListBoxItem obj,
    bool value
)
public:
static void SetIsSelectable(
    ListBoxItem^ obj,
    bool value
)

Parameters

obj
Type: System.Windows.ControlsListBoxItem
value
Type: SystemBoolean
See Also

Reference

ListBoxItemAttachedProperties Class
VisualComponents.UX.Shared Namespace


ListBoxItemAttachedProperties Fields

The ListBoxItemAttachedProperties type exposes the following members.

Fields
Name | Description
IsSelectableProperty |
Top
See Also

Reference

ListBoxItemAttachedProperties Class
VisualComponents.UX.Shared Namespace


ListBoxItemAttachedProperties.IsSelectableProperty Field

ListBoxItemAttachedPropertiesIsSelectableProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsSelectableProperty
public:
static initonly DependencyProperty^ IsSelectableProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListBoxItemAttachedProperties Class
VisualComponents.UX.Shared Namespace


ListBoxItemAttachedProperties Attached Properties

The ListBoxItemAttachedProperties type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | IsSelectable |
Top
See Also

Reference

ListBoxItemAttachedProperties Class
VisualComponents.UX.Shared Namespace


ListBoxItemAttachedProperties.IsSelectable Attached Property

ListBoxItemAttachedPropertiesIsSelectable Attached Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See GetIsSelectable, SetIsSelectable
See GetIsSelectable, SetIsSelectable

Property Value

Type: Boolean
See Also

Reference

ListBoxItemAttachedProperties Class
VisualComponents.UX.Shared Namespace


ListEditorView Class

Interaction logic for ListEditorView.xaml
ListEditorView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedListEditorView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ListEditorView : UserControl,
    IComponentConnector, IStyleConnector
public ref class ListEditorView : public UserControl,
    IComponentConnector, IStyleConnector

The ListEditorView type exposes the following members.

Constructors
 | Name | Description
Public method | ListEditorView | Initializes a new instance of the ListEditorView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | PropertyLists |
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | OpenLookupDialog |
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
_searchHint |
PropertyListsProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ListEditorView Constructor

Initializes a new instance of the ListEditorView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ListEditorView()
public:
ListEditorView()
See Also

Reference

ListEditorView Class
VisualComponents.UX.Shared Namespace


ListEditorView Properties

The ListEditorView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | PropertyLists |
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ListEditorView Class
VisualComponents.UX.Shared Namespace


ListEditorView.PropertyLists Property

ListEditorViewPropertyLists Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<IListProperty> PropertyLists { get; set; }
public:
property List<IListProperty^>^ PropertyLists {
    List<IListProperty^>^ get ();
    void set (List<IListProperty^>^ value);
}

Property Value

Type: ListIListProperty
See Also

Reference

ListEditorView Class
VisualComponents.UX.Shared Namespace


ListEditorView Methods

The ListEditorView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | OpenLookupDialog |
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ListEditorView Class
VisualComponents.UX.Shared Namespace


ListEditorView.InitializeComponent Method

ListEditorViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

ListEditorView Class
VisualComponents.UX.Shared Namespace


ListEditorView.OpenLookupDialog Method

ListEditorViewOpenLookupDialog Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<IResult> OpenLookupDialog()
public:
IEnumerable<IResult^>^ OpenLookupDialog()

Return Value

Type: IEnumerableIResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ListEditorView.OpenLookupDialog"]

See Also

Reference

ListEditorView Class
VisualComponents.UX.Shared Namespace


ListEditorView Events

The ListEditorView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ListEditorView Class
VisualComponents.UX.Shared Namespace


ListEditorView Fields

The ListEditorView type exposes the following members.

Fields
Name | Description
_searchHint |
PropertyListsProperty |
Top
See Also

Reference

ListEditorView Class
VisualComponents.UX.Shared Namespace


ListEditorView._searchHint Field

ListEditorView_searchHint Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string _searchHint
public:
static String^ _searchHint

Field Value

Type: String
See Also

Reference

ListEditorView Class
VisualComponents.UX.Shared Namespace


ListEditorView.PropertyListsProperty Field

ListEditorViewPropertyListsProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty PropertyListsProperty
public:
static DependencyProperty^ PropertyListsProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListEditorView Class
VisualComponents.UX.Shared Namespace


ListProperty Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedEditorProperty
VisualComponents.UX.SharedListProperty

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ListProperty : EditorProperty
public ref class ListProperty : public EditorProperty

The ListProperty type exposes the following members.

Constructors
 | Name | Description
Public method | ListProperty | Initializes a new instance of the ListProperty class
Top
Properties
 | Name | Description
Public property | AllowedMaximum | (Inherited from EditorProperty.)
Public property | AllowedMinimum | (Inherited from EditorProperty.)
Public property | AllowedValues | (Inherited from EditorProperty.)
Public property | CanCreateNewValue | (Inherited from EditorProperty.)
Public property | Category | (Inherited from EditorProperty.)
Public property | ConstraintType | (Inherited from EditorProperty.)
Public property | Container | (Inherited from EditorProperty.)
Public property | ContainerExpressionContext | (Inherited from EditorProperty.)
Public property | ContainerObject | Similar to IProperty.Container, but for any object. (Inherited from EditorProperty.)
Public property | CreationTypes | (Inherited from EditorProperty.)
Public property | Description | (Inherited from EditorProperty.)
Public property | DisabledStateToolTip | (Inherited from EditorProperty.)
Public property | DistributionExpression | (Inherited from EditorProperty.)
Public property | Error | (Inherited from EditorProperty.)
Public property | ErrorMessage | (Inherited from EditorProperty.)
Public property | HasDistribution | (Inherited from EditorProperty.)
Public property | HeaderTitle |
Public property | History | (Inherited from EditorProperty.)
Public property | Index_ForComboBox | (Inherited from EditorProperty.)
Public property | IsDesignTime | (Inherited from EditorProperty.)
Public property | IsEditable | Helper property since in XAML negating binding value is not possible without using BoolToOppositeConverter (Inherited from EditorProperty.)
Public property | IsEditableInGui | (Inherited from EditorProperty.)
Public property | IsExceptionallyInHome | (Inherited from EditorProperty.)
Public property | IsInternal | (Inherited from EditorProperty.)
Public property | IsLocked | (Inherited from EditorProperty.)
Public property | IsPersistent | (Inherited from EditorProperty.)
Public property | IsQuantityValue | (Inherited from EditorProperty.)
Public property | IsReadOnly | (Inherited from EditorProperty.)
Public property | IsValid | (Inherited from EditorProperty.)
Public property | IsVisible | (Inherited from EditorProperty.)
Public property | IsVisibleDesignTime | (Inherited from EditorProperty.)
Public property | IsVisibleForced | (Inherited from EditorProperty.)
Public property | IsVisibleInGui | IsVisibleInGui is used to bind GUI visibility. Setting this value affects only _isVisibleForcedOff. (Inherited from EditorProperty.)
Public property | Item | (Inherited from EditorProperty.)
Public property | Name | (Inherited from EditorProperty.)
Public property | NonLocalizedName | (Inherited from EditorProperty.)
Public property | Order | (Inherited from EditorProperty.)
Public property | Property | (Inherited from EditorProperty.)
Public property | PropertyDescription | (Inherited from EditorProperty.)
Public property | PropertyLists |
Public property | PropertyNodes |
Public property | PropertyType | (Inherited from EditorProperty.)
Public property | Quantity | (Inherited from EditorProperty.)
Public property | ResourceType | In case of having an IUriProperty, this determines if the editor should allow folder selection instead of file selection (Inherited from EditorProperty.)
Public property | RotationSystem | (Inherited from EditorProperty.)
Public property | ShowValuepicker | (Inherited from EditorProperty.)
Public property | TabHeader | (Inherited from EditorProperty.)
Public property | Unit | (Inherited from EditorProperty.)
Public property | Value | (Inherited from EditorProperty.)
Public property | Value_ForComboBox | Helper property, used only by ComboBox. (Inherited from EditorProperty.)
Public property | ValueString | (Inherited from EditorProperty.)
Top
Methods
 | Name | Description
Public method | Associate | (Inherited from EditorProperty.)
Public method | CheckEditableInGui | (Inherited from EditorProperty.)
Protected method | CheckPropertyObjDispose | (Inherited from EditorProperty.)
Public method | CheckRebuild | This happens only on UI changes. If containeris a behavior of feature call evaluate or rebuild to update geometry. (Inherited from EditorProperty.)
Public method | CheckRebuildSmart | (Inherited from EditorProperty.)
Public method | Clone | (Inherited from EditorProperty.)
Public method | CreateAndSetNewValue | (Inherited from EditorProperty.)
Public method | Disassociate | (Inherited from EditorProperty.)
Public method | Dispose | (Inherited from EditorProperty.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ListProperty and optionally releases the managed resources (Overrides EditorPropertyDispose(Boolean).)
Public method | EndBatch | (Inherited from EditorProperty.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from EditorProperty.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokePropertyChanged | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedEx | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedValue_Begin | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedValue_Process | (Inherited from EditorProperty.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Note: This is Not just called on IProperty.Value change. It's called by PropertyWrapper::NotifyPropertyChanged with different names (like "Value", "Expression", etc). It's called on rVariable::SetupChanged, on variable flag changes. (Inherited from EditorProperty.)
Public method | PickValue | Execute PickAction and wait for user to click on some object. (Inherited from EditorProperty.)
Public method | PickValueProxy | (Inherited from EditorProperty.)
Public method | SetQuantity | (Inherited from EditorProperty.)
Public method | SetUnitMagnitude | (Inherited from EditorProperty.)
Public method | StartBatch | (Inherited from EditorProperty.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | property changed event (Inherited from EditorProperty.)
Top
Fields
 | Name | Description
Public field | SuppressValueChange | (Inherited from EditorProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ListProperty Constructor

Initializes a new instance of the ListProperty class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ListProperty(
    IProperty listProperty
)
public:
ListProperty(
    IProperty^ listProperty
)

Parameters

listProperty
Type: VisualComponents.Create3DIProperty
See Also

Reference

ListProperty Class
VisualComponents.UX.Shared Namespace


ListProperty Properties

The ListProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | (Inherited from EditorProperty.)
Public property | AllowedMinimum | (Inherited from EditorProperty.)
Public property | AllowedValues | (Inherited from EditorProperty.)
Public property | CanCreateNewValue | (Inherited from EditorProperty.)
Public property | Category | (Inherited from EditorProperty.)
Public property | ConstraintType | (Inherited from EditorProperty.)
Public property | Container | (Inherited from EditorProperty.)
Public property | ContainerExpressionContext | (Inherited from EditorProperty.)
Public property | ContainerObject | Similar to IProperty.Container, but for any object. (Inherited from EditorProperty.)
Public property | CreationTypes | (Inherited from EditorProperty.)
Public property | Description | (Inherited from EditorProperty.)
Public property | DisabledStateToolTip | (Inherited from EditorProperty.)
Public property | DistributionExpression | (Inherited from EditorProperty.)
Public property | Error | (Inherited from EditorProperty.)
Public property | ErrorMessage | (Inherited from EditorProperty.)
Public property | HasDistribution | (Inherited from EditorProperty.)
Public property | HeaderTitle |
Public property | History | (Inherited from EditorProperty.)
Public property | Index_ForComboBox | (Inherited from EditorProperty.)
Public property | IsDesignTime | (Inherited from EditorProperty.)
Public property | IsEditable | Helper property since in XAML negating binding value is not possible without using BoolToOppositeConverter (Inherited from EditorProperty.)
Public property | IsEditableInGui | (Inherited from EditorProperty.)
Public property | IsExceptionallyInHome | (Inherited from EditorProperty.)
Public property | IsInternal | (Inherited from EditorProperty.)
Public property | IsLocked | (Inherited from EditorProperty.)
Public property | IsPersistent | (Inherited from EditorProperty.)
Public property | IsQuantityValue | (Inherited from EditorProperty.)
Public property | IsReadOnly | (Inherited from EditorProperty.)
Public property | IsValid | (Inherited from EditorProperty.)
Public property | IsVisible | (Inherited from EditorProperty.)
Public property | IsVisibleDesignTime | (Inherited from EditorProperty.)
Public property | IsVisibleForced | (Inherited from EditorProperty.)
Public property | IsVisibleInGui | IsVisibleInGui is used to bind GUI visibility. Setting this value affects only _isVisibleForcedOff. (Inherited from EditorProperty.)
Public property | Item | (Inherited from EditorProperty.)
Public property | Name | (Inherited from EditorProperty.)
Public property | NonLocalizedName | (Inherited from EditorProperty.)
Public property | Order | (Inherited from EditorProperty.)
Public property | Property | (Inherited from EditorProperty.)
Public property | PropertyDescription | (Inherited from EditorProperty.)
Public property | PropertyLists |
Public property | PropertyNodes |
Public property | PropertyType | (Inherited from EditorProperty.)
Public property | Quantity | (Inherited from EditorProperty.)
Public property | ResourceType | In case of having an IUriProperty, this determines if the editor should allow folder selection instead of file selection (Inherited from EditorProperty.)
Public property | RotationSystem | (Inherited from EditorProperty.)
Public property | ShowValuepicker | (Inherited from EditorProperty.)
Public property | TabHeader | (Inherited from EditorProperty.)
Public property | Unit | (Inherited from EditorProperty.)
Public property | Value | (Inherited from EditorProperty.)
Public property | Value_ForComboBox | Helper property, used only by ComboBox. (Inherited from EditorProperty.)
Public property | ValueString | (Inherited from EditorProperty.)
Top
See Also

Reference

ListProperty Class
VisualComponents.UX.Shared Namespace


ListProperty.HeaderTitle Property

ListPropertyHeaderTitle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string HeaderTitle { get; }
public:
property String^ HeaderTitle {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ListProperty Class
VisualComponents.UX.Shared Namespace


ListProperty.PropertyLists Property

ListPropertyPropertyLists Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<IListProperty> PropertyLists { get; set; }
public:
property List<IListProperty^>^ PropertyLists {
    List<IListProperty^>^ get ();
    void set (List<IListProperty^>^ value);
}

Property Value

Type: ListIListProperty
See Also

Reference

ListProperty Class
VisualComponents.UX.Shared Namespace


ListProperty.PropertyNodes Property

ListPropertyPropertyNodes Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObservableCollection<PropertyList> PropertyNodes { get; set; }
public:
property ObservableCollection<PropertyList^>^ PropertyNodes {
    ObservableCollection<PropertyList^>^ get ();
    void set (ObservableCollection<PropertyList^>^ value);
}

Property Value

Type: ObservableCollectionPropertyList
See Also

Reference

ListProperty Class
VisualComponents.UX.Shared Namespace


ListProperty Methods

The ListProperty type exposes the following members.

Methods
 | Name | Description
Public method | Associate | (Inherited from EditorProperty.)
Public method | CheckEditableInGui | (Inherited from EditorProperty.)
Protected method | CheckPropertyObjDispose | (Inherited from EditorProperty.)
Public method | CheckRebuild | This happens only on UI changes. If containeris a behavior of feature call evaluate or rebuild to update geometry. (Inherited from EditorProperty.)
Public method | CheckRebuildSmart | (Inherited from EditorProperty.)
Public method | Clone | (Inherited from EditorProperty.)
Public method | CreateAndSetNewValue | (Inherited from EditorProperty.)
Public method | Disassociate | (Inherited from EditorProperty.)
Public method | Dispose | (Inherited from EditorProperty.)
Protected method | Dispose(Boolean) | (Overrides EditorPropertyDispose(Boolean).)
Public method | EndBatch | (Inherited from EditorProperty.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from EditorProperty.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokePropertyChanged | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedEx | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedValue_Begin | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedValue_Process | (Inherited from EditorProperty.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Note: This is Not just called on IProperty.Value change. It's called by PropertyWrapper::NotifyPropertyChanged with different names (like "Value", "Expression", etc). It's called on rVariable::SetupChanged, on variable flag changes. (Inherited from EditorProperty.)
Public method | PickValue | Execute PickAction and wait for user to click on some object. (Inherited from EditorProperty.)
Public method | PickValueProxy | (Inherited from EditorProperty.)
Public method | SetQuantity | (Inherited from EditorProperty.)
Public method | SetUnitMagnitude | (Inherited from EditorProperty.)
Public method | StartBatch | (Inherited from EditorProperty.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ListProperty Class
VisualComponents.UX.Shared Namespace


ListProperty.Dispose Method

ListPropertyDispose Method

Overload List
 | Name | Description
Public method | Dispose | (Inherited from EditorProperty.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ListProperty and optionally releases the managed resources (Overrides EditorPropertyDispose(Boolean).)
Top
See Also

Reference

ListProperty Class
VisualComponents.UX.Shared Namespace


ListProperty.Dispose Method (Boolean)

ListPropertyDispose Method (Boolean)

Releases the unmanaged resources used by the ListProperty and optionally releases the managed resources

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void Dispose(
    bool disposing
)
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

ListProperty Class
Dispose Overload
VisualComponents.UX.Shared Namespace


ListProperty Events

The ListProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | property changed event (Inherited from EditorProperty.)
Top
See Also

Reference

ListProperty Class
VisualComponents.UX.Shared Namespace


ListProperty Fields

The ListProperty type exposes the following members.

Fields
 | Name | Description
Public field | SuppressValueChange | (Inherited from EditorProperty.)
Top
See Also

Reference

ListProperty Class
VisualComponents.UX.Shared Namespace


ListViewEx Class

Extended ListView with built-in Drag-and-Drop functionality. It is recommended to use ObservableCollectionEx as the ItemsSource. Other types were not tested.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsItemsControl
System.Windows.Controls.PrimitivesSelector
System.Windows.ControlsListBox
System.Windows.ControlsListView
VisualComponents.UX.SharedListViewEx
VisualComponents.UX.SharedTreeViewEx

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ListViewEx : ListView
public ref class ListViewEx : public ListView

The ListViewEx type exposes the following members.

Constructors
 | Name | Description
Public method | ListViewEx | Initializes a new instance of the ListViewEx class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AdjacentDropArea |
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AllowDropToEmptySpace |
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Protected property | AnchorItem | Gets or sets the item that is initially selected when SelectionMode is Extended. (Inherited from ListBox.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Bounds |
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CollectionView |
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DeferFilterRefresh |
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | DragAdornerClipsToBounds |
Public property | DragAdornerCounterBackground |
Public property | DragAdornerCounterForeground |
Public property | DragAdornerLayer |
Public property | DragAdornerOpacity |
Public property | DragAdornerPlacementTarget |
Public property | DragAdornerReflectsVisual |
Public property | DragScrollingDelay |
 | DragSource |
Public property | DropIndicatorOffset |
Protected property | DropTargetItem |
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FilterBy |
Public property | FilterOptions |
Public property | FilterText |
Public property | FilterType |
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether the ListBox supports scrolling. (Inherited from ListBox.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalDragScrollingMargin |
Public property | IgnoreFilterTextCase |
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsDragAreaRestricted |
Public property | IsDragInProgress |
Public property | IsDragOver |
Public property | IsDragScrolling |
Public property | IsDragSource |
Public property | IsDropTarget |
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerHelperFocusable |
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsToDrag |
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation |
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | ScrollableContentArea |
Public property | ScrollViewer |
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedItems | Gets the currently selected items. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionMode | Gets or sets the selection behavior for a ListBox. (Inherited from ListBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | SortBy |
Public property | SortDirection |
Public property | SortNaturally |
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalDragScrollingMargin |
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | View | Gets or sets an object that defines how the data is styled and organized in a ListView control. (Inherited from ListView.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Protected method | BelongToSameView |
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Protected method | CanStartDragOperation |
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Removes all templates, styles, and bindings for the object that is displayed as a ListViewItem. (Inherited from ListView.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | FilterPredicate |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates and returns a new ListViewItem container. (Inherited from ListView.)
Protected method | GetEmptyAreaDropTargetIndex |
 | GetHasDropLocationChanged |
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
 | GetIsBeingCopied |
 | GetIsBeingDragged |
 | GetIsDropTargetItem |
 | GetItemDropSide |
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetListViewItem(Int32) |
Public method | GetListViewItem(Object) |
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | IsItemItsOwnContainer | Determines if the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Protected method | IsItemItsOwnContainerOverride | Determines whether an object is a ListViewItem. (Inherited from ListView.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | (Overrides ControlMeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnCollectionViewCurrentChanged |
Protected method | OnCollectionViewCurrentChanging |
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Defines an AutomationPeer for the ListView control. (Inherited from ListView.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to internally. (Inherited from Selector.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Called when the IsKeyboardFocusWithin property has changed. (Inherited from Selector.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes. (Inherited from ListBox.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Responds to an OnItemsChanged(NotifyCollectionChangedEventArgs). (Inherited from ListView.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | (Overrides SelectorOnItemsSourceChanged(IEnumerable, IEnumerable).)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Responds to the KeyDown event. (Inherited from ListBox.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Called when a ListBox reports a mouse move. (Inherited from ListBox.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Responds to a list box selection change by raising a SelectionChanged event. (Inherited from ListBox.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Protected method | PrepareContainerForItemOverride | Sets the styles, templates, and bindings for a ListViewItem. (Inherited from ListView.)
 | ProcessDrop |
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ResetFilter |
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | SelectAll | Selects all the items in a ListBox. (Inherited from ListBox.)
Public method | SelectItem |
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
 | SetHasDropLocationChanged |
 | SetIsBeingCopied |
 | SetIsBeingDragged |
 | SetIsDropTargetItem |
 | SetItemDropSide |
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Protected method | SetSelectedItems | Sets a collection of selected items. (Inherited from ListBox.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UnselectAll | Clears all the selection in a ListBox. (Inherited from ListBox.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DesiredSizeChanged |
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragEntering |
Public event | DragFinished |
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarted |
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropHandled |
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | HandleDragEnter |
Public event | HandleDragFeedback |
Public event | HandleDragLeave |
Public event | HandleDragOver |
Public event | HandleDrop |
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PrepareDragAdornerVisual |
Public event | PrepareItemsToDrag |
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
 | Name | Description
Protected field | _dragDropEffects |
 | _dragStartedItem |
Protected field | _scrollableContentArea |
 | AdjacentDropAreaProperty |
 | AllowDropToEmptySpaceProperty |
 | BoundsProperty |
 | DeferFilterRefreshProperty |
 | DragAdornerClipsToBoundsProperty |
 | DragAdornerCounterBackgroundProperty |
 | DragAdornerCounterForegroundProperty |
 | DragAdornerLayerProperty |
 | DragAdornerOpacityProperty |
 | DragAdornerPlacementTargetProperty |
 | DragAdornerReflectsVisualProperty |
 | DragScrollingDelayProperty |
 | DropIndicatorOffsetProperty |
 | FilterByProperty |
 | FilterOptionsProperty |
 | FilterTextProperty |
 | FilterTypeProperty |
 | HasDropLocationChangedProperty |
 | HorizontalDragScrollingMarginProperty |
 | IgnoreFilterTextCaseProperty |
 | IsBeingCopiedProperty |
 | IsBeingDraggedProperty |
 | IsDragAreaRestrictedProperty |
 | IsDragInProgressProperty |
 | IsDragOverProperty |
 | IsDragScrollingProperty |
 | IsDragSourceProperty |
 | IsDropTargetItemProperty |
 | IsDropTargetProperty |
 | ItemContainerHelperFocusableProperty |
 | ItemDropSideProperty |
 | ItemsToDragProperty |
 | OrientationProperty |
 | ScrollableContentAreaProperty |
 | ScrollViewerProperty |
 | SortByProperty |
 | SortDirectionProperty |
 | SortNaturallyProperty |
 | VerticalDragScrollingMarginProperty |
Top
Attached Properties
 | Name | Description
Public attached property | HasDropLocationChanged |
Public attached property | IsBeingCopied |
Public attached property | IsBeingDragged |
Public attached property | IsDropTargetItem |
Public attached property | ItemDropSide |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ListViewEx Constructor

Initializes a new instance of the ListViewEx class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ListViewEx()
public:
ListViewEx()
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx Properties

The ListViewEx type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AdjacentDropArea |
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AllowDropToEmptySpace |
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Protected property | AnchorItem | Gets or sets the item that is initially selected when SelectionMode is Extended. (Inherited from ListBox.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | Bounds |
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CollectionView |
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DeferFilterRefresh |
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | DragAdornerClipsToBounds |
Public property | DragAdornerCounterBackground |
Public property | DragAdornerCounterForeground |
Public property | DragAdornerLayer |
Public property | DragAdornerOpacity |
Public property | DragAdornerPlacementTarget |
Public property | DragAdornerReflectsVisual |
Public property | DragScrollingDelay |
 | DragSource |
Public property | DropIndicatorOffset |
Protected property | DropTargetItem |
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FilterBy |
Public property | FilterOptions |
Public property | FilterText |
Public property | FilterType |
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether the ListBox supports scrolling. (Inherited from ListBox.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalDragScrollingMargin |
Public property | IgnoreFilterTextCase |
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsDragAreaRestricted |
Public property | IsDragInProgress |
Public property | IsDragOver |
Public property | IsDragScrolling |
Public property | IsDragSource |
Public property | IsDropTarget |
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerHelperFocusable |
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsToDrag |
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation |
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | ScrollableContentArea |
Public property | ScrollViewer |
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedItems | Gets the currently selected items. (Inherited from ListBox.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionMode | Gets or sets the selection behavior for a ListBox. (Inherited from ListBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | SortBy |
Public property | SortDirection |
Public property | SortNaturally |
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalDragScrollingMargin |
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | View | Gets or sets an object that defines how the data is styled and organized in a ListView control. (Inherited from ListView.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.AdjacentDropArea Property

ListViewExAdjacentDropArea Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UIElement AdjacentDropArea { get; set; }
public:
property UIElement^ AdjacentDropArea {
    UIElement^ get ();
    void set (UIElement^ value);
}

Property Value

Type: UIElement
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.AllowDropToEmptySpace Property

ListViewExAllowDropToEmptySpace Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool AllowDropToEmptySpace { get; set; }
public:
property bool AllowDropToEmptySpace {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.Bounds Property

ListViewExBounds Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Rect Bounds { get; set; }
public:
property Rect Bounds {
    Rect get ();
    void set (Rect value);
}

Property Value

Type: Rect
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.CollectionView Property

ListViewExCollectionView Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ListCollectionView CollectionView { get; }
public:
property ListCollectionView^ CollectionView {
    ListCollectionView^ get ();
}

Property Value

Type: ListCollectionView
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.DeferFilterRefresh Property

ListViewExDeferFilterRefresh Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double DeferFilterRefresh { get; set; }
public:
property double DeferFilterRefresh {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.DragAdornerClipsToBounds Property

ListViewExDragAdornerClipsToBounds Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool DragAdornerClipsToBounds { get; set; }
public:
property bool DragAdornerClipsToBounds {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.DragAdornerCounterBackground Property

ListViewExDragAdornerCounterBackground Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Brush DragAdornerCounterBackground { get; set; }
public:
property Brush^ DragAdornerCounterBackground {
    Brush^ get ();
    void set (Brush^ value);
}

Property Value

Type: Brush
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.DragAdornerCounterForeground Property

ListViewExDragAdornerCounterForeground Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Brush DragAdornerCounterForeground { get; set; }
public:
property Brush^ DragAdornerCounterForeground {
    Brush^ get ();
    void set (Brush^ value);
}

Property Value

Type: Brush
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.DragAdornerLayer Property

ListViewExDragAdornerLayer Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AdornerLayer DragAdornerLayer { get; set; }
public:
property AdornerLayer^ DragAdornerLayer {
    AdornerLayer^ get ();
    void set (AdornerLayer^ value);
}

Property Value

Type: AdornerLayer
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.DragAdornerOpacity Property

ListViewExDragAdornerOpacity Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double DragAdornerOpacity { get; set; }
public:
property double DragAdornerOpacity {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.DragAdornerPlacementTarget Property

ListViewExDragAdornerPlacementTarget Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public UIElement DragAdornerPlacementTarget { get; set; }
public:
property UIElement^ DragAdornerPlacementTarget {
    UIElement^ get ();
    void set (UIElement^ value);
}

Property Value

Type: UIElement
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.DragAdornerReflectsVisual Property

ListViewExDragAdornerReflectsVisual Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool DragAdornerReflectsVisual { get; set; }
public:
property bool DragAdornerReflectsVisual {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.DragScrollingDelay Property

ListViewExDragScrollingDelay Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double DragScrollingDelay { get; set; }
public:
property double DragScrollingDelay {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.DragSource Property

ListViewExDragSource Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ListViewEx DragSource { get; }
public:
static property ListViewEx^ DragSource {
    ListViewEx^ get ();
}

Property Value

Type: ListViewEx
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.DropIndicatorOffset Property

ListViewExDropIndicatorOffset Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double DropIndicatorOffset { get; set; }
public:
property double DropIndicatorOffset {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.DropTargetItem Property

ListViewExDropTargetItem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected Object DropTargetItem { get; set; }
protected:
property Object^ DropTargetItem {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.FilterBy Property

ListViewExFilterBy Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string FilterBy { get; set; }
public:
property String^ FilterBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.FilterOptions Property

ListViewExFilterOptions Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList<FilterOption> FilterOptions { get; set; }
public:
property IList<FilterOption^>^ FilterOptions {
    IList<FilterOption^>^ get ();
    void set (IList<FilterOption^>^ value);
}

Property Value

Type: IListFilterOption
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.FilterText Property

ListViewExFilterText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string FilterText { get; set; }
public:
property String^ FilterText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.FilterType Property

ListViewExFilterType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FilterType FilterType { get; set; }
public:
property FilterType FilterType {
    FilterType get ();
    void set (FilterType value);
}

Property Value

Type: FilterType
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.HorizontalDragScrollingMargin Property

ListViewExHorizontalDragScrollingMargin Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double HorizontalDragScrollingMargin { get; set; }
public:
property double HorizontalDragScrollingMargin {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.IgnoreFilterTextCase Property

ListViewExIgnoreFilterTextCase Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IgnoreFilterTextCase { get; set; }
public:
property bool IgnoreFilterTextCase {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.IsDragAreaRestricted Property

ListViewExIsDragAreaRestricted Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsDragAreaRestricted { get; set; }
public:
property bool IsDragAreaRestricted {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.IsDragInProgress Property

ListViewExIsDragInProgress Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsDragInProgress { get; }
public:
property bool IsDragInProgress {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.IsDragOver Property

ListViewExIsDragOver Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsDragOver { get; }
public:
property bool IsDragOver {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.IsDragScrolling Property

ListViewExIsDragScrolling Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsDragScrolling { get; set; }
public:
property bool IsDragScrolling {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.IsDragSource Property

ListViewExIsDragSource Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsDragSource { get; set; }
public:
property bool IsDragSource {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.IsDropTarget Property

ListViewExIsDropTarget Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsDropTarget { get; set; }
public:
property bool IsDropTarget {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.ItemContainerHelperFocusable Property

ListViewExItemContainerHelperFocusable Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ItemContainerHelperFocusable { get; set; }
public:
property bool ItemContainerHelperFocusable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.ItemsToDrag Property

ListViewExItemsToDrag Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList ItemsToDrag { get; set; }
public:
property IList^ ItemsToDrag {
    IList^ get ();
    void set (IList^ value);
}

Property Value

Type: IList
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.Orientation Property

ListViewExOrientation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Orientation Orientation { get; set; }
public:
property Orientation Orientation {
    Orientation get ();
    void set (Orientation value);
}

Property Value

Type: Orientation
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.ScrollableContentArea Property

ListViewExScrollableContentArea Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public FrameworkElement ScrollableContentArea { get; set; }
public:
property FrameworkElement^ ScrollableContentArea {
    FrameworkElement^ get ();
    void set (FrameworkElement^ value);
}

Property Value

Type: FrameworkElement
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.ScrollViewer Property

ListViewExScrollViewer Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ScrollViewer ScrollViewer { get; set; }
public:
property ScrollViewer^ ScrollViewer {
    ScrollViewer^ get ();
    void set (ScrollViewer^ value);
}

Property Value

Type: ScrollViewer
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.SortBy Property

ListViewExSortBy Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SortBy { get; set; }
public:
property String^ SortBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.SortDirection Property

ListViewExSortDirection Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ListSortDirection SortDirection { get; set; }
public:
property ListSortDirection SortDirection {
    ListSortDirection get ();
    void set (ListSortDirection value);
}

Property Value

Type: ListSortDirection
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.SortNaturally Property

ListViewExSortNaturally Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool SortNaturally { get; set; }
public:
property bool SortNaturally {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.VerticalDragScrollingMargin Property

ListViewExVerticalDragScrollingMargin Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double VerticalDragScrollingMargin { get; set; }
public:
property double VerticalDragScrollingMargin {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx Methods

The ListViewEx type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Protected method | BelongToSameView |
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Protected method | CanStartDragOperation |
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Removes all templates, styles, and bindings for the object that is displayed as a ListViewItem. (Inherited from ListView.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | FilterPredicate |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates and returns a new ListViewItem container. (Inherited from ListView.)
Protected method | GetEmptyAreaDropTargetIndex |
 | GetHasDropLocationChanged |
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
 | GetIsBeingCopied |
 | GetIsBeingDragged |
 | GetIsDropTargetItem |
 | GetItemDropSide |
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetListViewItem(Int32) |
Public method | GetListViewItem(Object) |
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | IsItemItsOwnContainer | Determines if the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Protected method | IsItemItsOwnContainerOverride | Determines whether an object is a ListViewItem. (Inherited from ListView.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | (Overrides ControlMeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnCollectionViewCurrentChanged |
Protected method | OnCollectionViewCurrentChanging |
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Defines an AutomationPeer for the ListView control. (Inherited from ListView.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to internally. (Inherited from Selector.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Called when the IsKeyboardFocusWithin property has changed. (Inherited from Selector.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes. (Inherited from ListBox.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Responds to an OnItemsChanged(NotifyCollectionChangedEventArgs). (Inherited from ListView.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | (Overrides SelectorOnItemsSourceChanged(IEnumerable, IEnumerable).)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Responds to the KeyDown event. (Inherited from ListBox.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Called when a ListBox reports a mouse move. (Inherited from ListBox.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Responds to a list box selection change by raising a SelectionChanged event. (Inherited from ListBox.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Protected method | PrepareContainerForItemOverride | Sets the styles, templates, and bindings for a ListViewItem. (Inherited from ListView.)
 | ProcessDrop |
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ResetFilter |
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | SelectAll | Selects all the items in a ListBox. (Inherited from ListBox.)
Public method | SelectItem |
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
 | SetHasDropLocationChanged |
 | SetIsBeingCopied |
 | SetIsBeingDragged |
 | SetIsDropTargetItem |
 | SetItemDropSide |
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Protected method | SetSelectedItems | Sets a collection of selected items. (Inherited from ListBox.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UnselectAll | Clears all the selection in a ListBox. (Inherited from ListBox.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.BelongToSameView Method

ListViewExBelongToSameView Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual bool BelongToSameView(
    KeyValuePair<Object, IList> source,
    KeyValuePair<Object, IList> target
)
protected:
virtual bool BelongToSameView(
    KeyValuePair<Object^, IList^> source,
    KeyValuePair<Object^, IList^> target
)

Parameters

source
Type: System.Collections.GenericKeyValuePairObject, IList
target
Type: System.Collections.GenericKeyValuePairObject, IList

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ListViewEx.BelongToSameView(System.Collections.Generic.KeyValuePair{System.Object,System.Collections.IList},System.Collections.Generic.KeyValuePair{System.Object,System.Collections.IList})"]

See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.CanStartDragOperation Method

ListViewExCanStartDragOperation Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual bool CanStartDragOperation(
    ListViewItem item
)
protected:
virtual bool CanStartDragOperation(
    ListViewItem^ item
)

Parameters

item
Type: System.Windows.ControlsListViewItem

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ListViewEx.CanStartDragOperation(System.Windows.Controls.ListViewItem)"]

See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.FilterPredicate Method

ListViewExFilterPredicate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual bool FilterPredicate(
    Object source
)
protected:
virtual bool FilterPredicate(
    Object^ source
)

Parameters

source
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ListViewEx.FilterPredicate(System.Object)"]

See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.GetEmptyAreaDropTargetIndex Method

ListViewExGetEmptyAreaDropTargetIndex Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual int GetEmptyAreaDropTargetIndex()
protected:
virtual int GetEmptyAreaDropTargetIndex()

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ListViewEx.GetEmptyAreaDropTargetIndex"]

See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.GetHasDropLocationChanged Method

ListViewExGetHasDropLocationChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool GetHasDropLocationChanged(
    ListViewItem item
)
public:
static bool GetHasDropLocationChanged(
    ListViewItem^ item
)

Parameters

item
Type: System.Windows.ControlsListViewItem

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ListViewEx.GetHasDropLocationChanged(System.Windows.Controls.ListViewItem)"]

See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.GetIsBeingCopied Method

ListViewExGetIsBeingCopied Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool GetIsBeingCopied(
    ListViewItem item
)
public:
static bool GetIsBeingCopied(
    ListViewItem^ item
)

Parameters

item
Type: System.Windows.ControlsListViewItem

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ListViewEx.GetIsBeingCopied(System.Windows.Controls.ListViewItem)"]

See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.GetIsBeingDragged Method

ListViewExGetIsBeingDragged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool GetIsBeingDragged(
    ListViewItem item
)
public:
static bool GetIsBeingDragged(
    ListViewItem^ item
)

Parameters

item
Type: System.Windows.ControlsListViewItem

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ListViewEx.GetIsBeingDragged(System.Windows.Controls.ListViewItem)"]

See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.GetIsDropTargetItem Method

ListViewExGetIsDropTargetItem Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool GetIsDropTargetItem(
    ListViewItem item
)
public:
static bool GetIsDropTargetItem(
    ListViewItem^ item
)

Parameters

item
Type: System.Windows.ControlsListViewItem

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ListViewEx.GetIsDropTargetItem(System.Windows.Controls.ListViewItem)"]

See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.GetItemDropSide Method

ListViewExGetItemDropSide Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ItemDropSide GetItemDropSide(
    ListViewItem item
)
public:
static ItemDropSide GetItemDropSide(
    ListViewItem^ item
)

Parameters

item
Type: System.Windows.ControlsListViewItem

Return Value

Type: ItemDropSide

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ListViewEx.GetItemDropSide(System.Windows.Controls.ListViewItem)"]

See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.GetListViewItem Method

ListViewExGetListViewItem Method

Overload List
 | Name | Description
Public method | GetListViewItem(Int32) |
Public method | GetListViewItem(Object) |
Top
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.GetListViewItem Method (Int32)

ListViewExGetListViewItem Method (Int32)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ListViewItem GetListViewItem(
    int index
)
public:
ListViewItem^ GetListViewItem(
    int index
)

Parameters

index
Type: SystemInt32

Return Value

Type: ListViewItem

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ListViewEx.GetListViewItem(System.Int32)"]

See Also

Reference

ListViewEx Class
GetListViewItem Overload
VisualComponents.UX.Shared Namespace


ListViewEx.GetListViewItem Method (Object)

ListViewExGetListViewItem Method (Object)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ListViewItem GetListViewItem(
    Object item
)
public:
ListViewItem^ GetListViewItem(
    Object^ item
)

Parameters

item
Type: SystemObject

Return Value

Type: ListViewItem

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ListViewEx.GetListViewItem(System.Object)"]

See Also

Reference

ListViewEx Class
GetListViewItem Overload
VisualComponents.UX.Shared Namespace


ListViewEx.MeasureOverride Method

ListViewExMeasureOverride Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Size MeasureOverride(
    Size constraint
)
protected:
virtual Size MeasureOverride(
    Size constraint
) override

Parameters

constraint
Type: System.WindowsSize

Return Value

Type: Size

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ListViewEx.MeasureOverride(System.Windows.Size)"]

See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.OnCollectionViewCurrentChanged Method

ListViewExOnCollectionViewCurrentChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void OnCollectionViewCurrentChanged()
protected:
virtual void OnCollectionViewCurrentChanged()
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.OnCollectionViewCurrentChanging Method

ListViewExOnCollectionViewCurrentChanging Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void OnCollectionViewCurrentChanging(
    CurrentChangingEventArgs currentChangingEventArgs
)
protected:
virtual void OnCollectionViewCurrentChanging(
    CurrentChangingEventArgs^ currentChangingEventArgs
)

Parameters

currentChangingEventArgs
Type: System.ComponentModelCurrentChangingEventArgs
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.OnItemsSourceChanged Method

ListViewExOnItemsSourceChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnItemsSourceChanged(
    IEnumerable oldValue,
    IEnumerable newValue
)
protected:
virtual void OnItemsSourceChanged(
    IEnumerable^ oldValue,
    IEnumerable^ newValue
) override

Parameters

oldValue
Type: System.CollectionsIEnumerable
newValue
Type: System.CollectionsIEnumerable
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.ProcessDrop Method

ListViewExProcessDrop Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DragDropEffects ProcessDrop(
    IList itemsSource,
    ref Dictionary<Object, IList> droppedItems,
    int newIndex,
    bool adjustIndex = false,
    Nullable<bool> cloneItems = null
)
public:
static DragDropEffects ProcessDrop(
    IList^ itemsSource,
    Dictionary<Object^, IList^>^% droppedItems,
    int newIndex,
    bool adjustIndex = false,
    Nullable<bool> cloneItems = nullptr
)

Parameters

itemsSource
Type: System.CollectionsIList
droppedItems
Type: System.Collections.GenericDictionaryObject, IList
newIndex
Type: SystemInt32
adjustIndex (Optional)
Type: SystemBoolean
cloneItems (Optional)
Type: SystemNullableBoolean

Return Value

Type: DragDropEffects

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ListViewEx.ProcessDrop(System.Collections.IList,System.Collections.Generic.Dictionary{System.Object,System.Collections.IList}@,System.Int32,System.Boolean,System.Nullable{System.Boolean})"]

See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.ResetFilter Method

ListViewExResetFilter Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ResetFilter()
public:
void ResetFilter()
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.SelectItem Method

ListViewExSelectItem Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SelectItem(
    FocusNavigationDirection direction,
    IInputElement returnFocusTo = null
)
public:
void SelectItem(
    FocusNavigationDirection direction,
    IInputElement^ returnFocusTo = nullptr
)

Parameters

direction
Type: System.Windows.InputFocusNavigationDirection
returnFocusTo (Optional)
Type: System.WindowsIInputElement
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.SetHasDropLocationChanged Method

ListViewExSetHasDropLocationChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetHasDropLocationChanged(
    ListViewItem item,
    bool value
)
public:
static void SetHasDropLocationChanged(
    ListViewItem^ item,
    bool value
)

Parameters

item
Type: System.Windows.ControlsListViewItem
value
Type: SystemBoolean
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.SetIsBeingCopied Method

ListViewExSetIsBeingCopied Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetIsBeingCopied(
    ListViewItem item,
    bool value
)
public:
static void SetIsBeingCopied(
    ListViewItem^ item,
    bool value
)

Parameters

item
Type: System.Windows.ControlsListViewItem
value
Type: SystemBoolean
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.SetIsBeingDragged Method

ListViewExSetIsBeingDragged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetIsBeingDragged(
    ListViewItem item,
    bool value
)
public:
static void SetIsBeingDragged(
    ListViewItem^ item,
    bool value
)

Parameters

item
Type: System.Windows.ControlsListViewItem
value
Type: SystemBoolean
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.SetIsDropTargetItem Method

ListViewExSetIsDropTargetItem Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetIsDropTargetItem(
    ListViewItem item,
    bool value
)
public:
static void SetIsDropTargetItem(
    ListViewItem^ item,
    bool value
)

Parameters

item
Type: System.Windows.ControlsListViewItem
value
Type: SystemBoolean
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.SetItemDropSide Method

ListViewExSetItemDropSide Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetItemDropSide(
    ListViewItem item,
    ItemDropSide value
)
public:
static void SetItemDropSide(
    ListViewItem^ item,
    ItemDropSide value
)

Parameters

item
Type: System.Windows.ControlsListViewItem
value
Type: VisualComponents.UX.SharedItemDropSide
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx Events

The ListViewEx type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DesiredSizeChanged |
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragEntering |
Public event | DragFinished |
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | DragStarted |
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropHandled |
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | HandleDragEnter |
Public event | HandleDragFeedback |
Public event | HandleDragLeave |
Public event | HandleDragOver |
Public event | HandleDrop |
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PrepareDragAdornerVisual |
Public event | PrepareItemsToDrag |
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.DesiredSizeChanged Event

ListViewExDesiredSizeChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<DesiredSizeChangedEventArgs> DesiredSizeChanged
public:
 event EventHandler<DesiredSizeChangedEventArgs^>^ DesiredSizeChanged {
    void add (EventHandler<DesiredSizeChangedEventArgs^>^ value);
    void remove (EventHandler<DesiredSizeChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerDesiredSizeChangedEventArgs
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.DragEntering Event

ListViewExDragEntering Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<DropEventArgs> DragEntering
public:
 event EventHandler<DropEventArgs^>^ DragEntering {
    void add (EventHandler<DropEventArgs^>^ value);
    void remove (EventHandler<DropEventArgs^>^ value);
}

Value

Type: SystemEventHandlerDropEventArgs
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.DragFinished Event

ListViewExDragFinished Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<EventArgs> DragFinished
public:
 event EventHandler<EventArgs^>^ DragFinished {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.DragStarted Event

ListViewExDragStarted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<EventArgs> DragStarted
public:
 event EventHandler<EventArgs^>^ DragStarted {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.DropHandled Event

ListViewExDropHandled Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<DropEventArgs> DropHandled
public:
 event EventHandler<DropEventArgs^>^ DropHandled {
    void add (EventHandler<DropEventArgs^>^ value);
    void remove (EventHandler<DropEventArgs^>^ value);
}

Value

Type: SystemEventHandlerDropEventArgs
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.HandleDragEnter Event

ListViewExHandleDragEnter Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<DropEventArgs> HandleDragEnter
public:
 event EventHandler<DropEventArgs^>^ HandleDragEnter {
    void add (EventHandler<DropEventArgs^>^ value);
    void remove (EventHandler<DropEventArgs^>^ value);
}

Value

Type: SystemEventHandlerDropEventArgs
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.HandleDragFeedback Event

ListViewExHandleDragFeedback Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<GiveFeedbackEventArgs> HandleDragFeedback
public:
 event EventHandler<GiveFeedbackEventArgs^>^ HandleDragFeedback {
    void add (EventHandler<GiveFeedbackEventArgs^>^ value);
    void remove (EventHandler<GiveFeedbackEventArgs^>^ value);
}

Value

Type: SystemEventHandlerGiveFeedbackEventArgs
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.HandleDragLeave Event

ListViewExHandleDragLeave Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<DropEventArgs> HandleDragLeave
public:
 event EventHandler<DropEventArgs^>^ HandleDragLeave {
    void add (EventHandler<DropEventArgs^>^ value);
    void remove (EventHandler<DropEventArgs^>^ value);
}

Value

Type: SystemEventHandlerDropEventArgs
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.HandleDragOver Event

ListViewExHandleDragOver Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<DropEventArgs> HandleDragOver
public:
 event EventHandler<DropEventArgs^>^ HandleDragOver {
    void add (EventHandler<DropEventArgs^>^ value);
    void remove (EventHandler<DropEventArgs^>^ value);
}

Value

Type: SystemEventHandlerDropEventArgs
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.HandleDrop Event

ListViewExHandleDrop Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<DropEventArgs> HandleDrop
public:
 event EventHandler<DropEventArgs^>^ HandleDrop {
    void add (EventHandler<DropEventArgs^>^ value);
    void remove (EventHandler<DropEventArgs^>^ value);
}

Value

Type: SystemEventHandlerDropEventArgs
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.PrepareDragAdornerVisual Event

ListViewExPrepareDragAdornerVisual Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<DragAdornerVisualEventArgs> PrepareDragAdornerVisual
public:
 event EventHandler<DragAdornerVisualEventArgs^>^ PrepareDragAdornerVisual {
    void add (EventHandler<DragAdornerVisualEventArgs^>^ value);
    void remove (EventHandler<DragAdornerVisualEventArgs^>^ value);
}

Value

Type: SystemEventHandlerDragAdornerVisualEventArgs
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.PrepareItemsToDrag Event

ListViewExPrepareItemsToDrag Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ActionRequestedEventArgs> PrepareItemsToDrag
public:
 event EventHandler<ActionRequestedEventArgs^>^ PrepareItemsToDrag {
    void add (EventHandler<ActionRequestedEventArgs^>^ value);
    void remove (EventHandler<ActionRequestedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerActionRequestedEventArgs
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx Fields

The ListViewEx type exposes the following members.

Fields
 | Name | Description
Protected field | _dragDropEffects |
 | _dragStartedItem |
Protected field | _scrollableContentArea |
 | AdjacentDropAreaProperty |
 | AllowDropToEmptySpaceProperty |
 | BoundsProperty |
 | DeferFilterRefreshProperty |
 | DragAdornerClipsToBoundsProperty |
 | DragAdornerCounterBackgroundProperty |
 | DragAdornerCounterForegroundProperty |
 | DragAdornerLayerProperty |
 | DragAdornerOpacityProperty |
 | DragAdornerPlacementTargetProperty |
 | DragAdornerReflectsVisualProperty |
 | DragScrollingDelayProperty |
 | DropIndicatorOffsetProperty |
 | FilterByProperty |
 | FilterOptionsProperty |
 | FilterTextProperty |
 | FilterTypeProperty |
 | HasDropLocationChangedProperty |
 | HorizontalDragScrollingMarginProperty |
 | IgnoreFilterTextCaseProperty |
 | IsBeingCopiedProperty |
 | IsBeingDraggedProperty |
 | IsDragAreaRestrictedProperty |
 | IsDragInProgressProperty |
 | IsDragOverProperty |
 | IsDragScrollingProperty |
 | IsDragSourceProperty |
 | IsDropTargetItemProperty |
 | IsDropTargetProperty |
 | ItemContainerHelperFocusableProperty |
 | ItemDropSideProperty |
 | ItemsToDragProperty |
 | OrientationProperty |
 | ScrollableContentAreaProperty |
 | ScrollViewerProperty |
 | SortByProperty |
 | SortDirectionProperty |
 | SortNaturallyProperty |
 | VerticalDragScrollingMarginProperty |
Top
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx._dragDropEffects Field

ListViewEx_dragDropEffects Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected DragDropEffects _dragDropEffects
protected:
DragDropEffects _dragDropEffects

Field Value

Type: DragDropEffects
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx._dragStartedItem Field

ListViewEx_dragStartedItem Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected static Object _dragStartedItem
protected:
static Object^ _dragStartedItem

Field Value

Type: Object
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx._scrollableContentArea Field

ListViewEx_scrollableContentArea Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected Rect _scrollableContentArea
protected:
Rect _scrollableContentArea

Field Value

Type: Rect
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.AdjacentDropAreaProperty Field

ListViewExAdjacentDropAreaProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty AdjacentDropAreaProperty
public:
static initonly DependencyProperty^ AdjacentDropAreaProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.AllowDropToEmptySpaceProperty Field

ListViewExAllowDropToEmptySpaceProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty AllowDropToEmptySpaceProperty
public:
static initonly DependencyProperty^ AllowDropToEmptySpaceProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.BoundsProperty Field

ListViewExBoundsProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty BoundsProperty
public:
static initonly DependencyProperty^ BoundsProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.DeferFilterRefreshProperty Field

ListViewExDeferFilterRefreshProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty DeferFilterRefreshProperty
public:
static initonly DependencyProperty^ DeferFilterRefreshProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.DragAdornerClipsToBoundsProperty Field

ListViewExDragAdornerClipsToBoundsProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty DragAdornerClipsToBoundsProperty
public:
static initonly DependencyProperty^ DragAdornerClipsToBoundsProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.DragAdornerCounterBackgroundProperty Field

ListViewExDragAdornerCounterBackgroundProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty DragAdornerCounterBackgroundProperty
public:
static initonly DependencyProperty^ DragAdornerCounterBackgroundProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.DragAdornerCounterForegroundProperty Field

ListViewExDragAdornerCounterForegroundProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty DragAdornerCounterForegroundProperty
public:
static initonly DependencyProperty^ DragAdornerCounterForegroundProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.DragAdornerLayerProperty Field

ListViewExDragAdornerLayerProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty DragAdornerLayerProperty
public:
static initonly DependencyProperty^ DragAdornerLayerProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.DragAdornerOpacityProperty Field

ListViewExDragAdornerOpacityProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty DragAdornerOpacityProperty
public:
static initonly DependencyProperty^ DragAdornerOpacityProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.DragAdornerPlacementTargetProperty Field

ListViewExDragAdornerPlacementTargetProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty DragAdornerPlacementTargetProperty
public:
static initonly DependencyProperty^ DragAdornerPlacementTargetProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.DragAdornerReflectsVisualProperty Field

ListViewExDragAdornerReflectsVisualProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty DragAdornerReflectsVisualProperty
public:
static initonly DependencyProperty^ DragAdornerReflectsVisualProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.DragScrollingDelayProperty Field

ListViewExDragScrollingDelayProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty DragScrollingDelayProperty
public:
static initonly DependencyProperty^ DragScrollingDelayProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.DropIndicatorOffsetProperty Field

ListViewExDropIndicatorOffsetProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty DropIndicatorOffsetProperty
public:
static initonly DependencyProperty^ DropIndicatorOffsetProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.FilterByProperty Field

ListViewExFilterByProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty FilterByProperty
public:
static initonly DependencyProperty^ FilterByProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.FilterOptionsProperty Field

ListViewExFilterOptionsProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty FilterOptionsProperty
public:
static initonly DependencyProperty^ FilterOptionsProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.FilterTextProperty Field

ListViewExFilterTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty FilterTextProperty
public:
static initonly DependencyProperty^ FilterTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.FilterTypeProperty Field

ListViewExFilterTypeProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty FilterTypeProperty
public:
static initonly DependencyProperty^ FilterTypeProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.HasDropLocationChangedProperty Field

ListViewExHasDropLocationChangedProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty HasDropLocationChangedProperty
public:
static initonly DependencyProperty^ HasDropLocationChangedProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.HorizontalDragScrollingMarginProperty Field

ListViewExHorizontalDragScrollingMarginProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty HorizontalDragScrollingMarginProperty
public:
static initonly DependencyProperty^ HorizontalDragScrollingMarginProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.IgnoreFilterTextCaseProperty Field

ListViewExIgnoreFilterTextCaseProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IgnoreFilterTextCaseProperty
public:
static initonly DependencyProperty^ IgnoreFilterTextCaseProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.IsBeingCopiedProperty Field

ListViewExIsBeingCopiedProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsBeingCopiedProperty
public:
static initonly DependencyProperty^ IsBeingCopiedProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.IsBeingDraggedProperty Field

ListViewExIsBeingDraggedProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsBeingDraggedProperty
public:
static initonly DependencyProperty^ IsBeingDraggedProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.IsDragAreaRestrictedProperty Field

ListViewExIsDragAreaRestrictedProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsDragAreaRestrictedProperty
public:
static initonly DependencyProperty^ IsDragAreaRestrictedProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.IsDragInProgressProperty Field

ListViewExIsDragInProgressProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsDragInProgressProperty
public:
static initonly DependencyProperty^ IsDragInProgressProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.IsDragOverProperty Field

ListViewExIsDragOverProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsDragOverProperty
public:
static initonly DependencyProperty^ IsDragOverProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.IsDragScrollingProperty Field

ListViewExIsDragScrollingProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsDragScrollingProperty
public:
static initonly DependencyProperty^ IsDragScrollingProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.IsDragSourceProperty Field

ListViewExIsDragSourceProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsDragSourceProperty
public:
static initonly DependencyProperty^ IsDragSourceProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.IsDropTargetItemProperty Field

ListViewExIsDropTargetItemProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsDropTargetItemProperty
public:
static initonly DependencyProperty^ IsDropTargetItemProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.IsDropTargetProperty Field

ListViewExIsDropTargetProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsDropTargetProperty
public:
static initonly DependencyProperty^ IsDropTargetProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.ItemContainerHelperFocusableProperty Field

ListViewExItemContainerHelperFocusableProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ItemContainerHelperFocusableProperty
public:
static initonly DependencyProperty^ ItemContainerHelperFocusableProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.ItemDropSideProperty Field

ListViewExItemDropSideProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ItemDropSideProperty
public:
static initonly DependencyProperty^ ItemDropSideProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.ItemsToDragProperty Field

ListViewExItemsToDragProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ItemsToDragProperty
public:
static initonly DependencyProperty^ ItemsToDragProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.OrientationProperty Field

ListViewExOrientationProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty OrientationProperty
public:
static initonly DependencyProperty^ OrientationProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.ScrollableContentAreaProperty Field

ListViewExScrollableContentAreaProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ScrollableContentAreaProperty
public:
static initonly DependencyProperty^ ScrollableContentAreaProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.ScrollViewerProperty Field

ListViewExScrollViewerProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ScrollViewerProperty
public:
static initonly DependencyProperty^ ScrollViewerProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.SortByProperty Field

ListViewExSortByProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty SortByProperty
public:
static initonly DependencyProperty^ SortByProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.SortDirectionProperty Field

ListViewExSortDirectionProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty SortDirectionProperty
public:
static initonly DependencyProperty^ SortDirectionProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.SortNaturallyProperty Field

ListViewExSortNaturallyProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty SortNaturallyProperty
public:
static initonly DependencyProperty^ SortNaturallyProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.VerticalDragScrollingMarginProperty Field

ListViewExVerticalDragScrollingMarginProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty VerticalDragScrollingMarginProperty
public:
static initonly DependencyProperty^ VerticalDragScrollingMarginProperty

Field Value

Type: DependencyProperty
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx Attached Properties

The ListViewEx type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | HasDropLocationChanged |
Public attached property | IsBeingCopied |
Public attached property | IsBeingDragged |
Public attached property | IsDropTargetItem |
Public attached property | ItemDropSide |
Top
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.HasDropLocationChanged Attached Property

ListViewExHasDropLocationChanged Attached Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See GetHasDropLocationChanged, SetHasDropLocationChanged
See GetHasDropLocationChanged, SetHasDropLocationChanged

Property Value

Type: Boolean
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.IsBeingCopied Attached Property

ListViewExIsBeingCopied Attached Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See GetIsBeingCopied, SetIsBeingCopied
See GetIsBeingCopied, SetIsBeingCopied

Property Value

Type: Boolean
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.IsBeingDragged Attached Property

ListViewExIsBeingDragged Attached Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See GetIsBeingDragged, SetIsBeingDragged
See GetIsBeingDragged, SetIsBeingDragged

Property Value

Type: Boolean
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.IsDropTargetItem Attached Property

ListViewExIsDropTargetItem Attached Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See GetIsDropTargetItem, SetIsDropTargetItem
See GetIsDropTargetItem, SetIsDropTargetItem

Property Value

Type: Boolean
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


ListViewEx.ItemDropSide Attached Property

ListViewExItemDropSide Attached Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See GetItemDropSide, SetItemDropSide
See GetItemDropSide, SetItemDropSide

Property Value

Type: ItemDropSide
See Also

Reference

ListViewEx Class
VisualComponents.UX.Shared Namespace


LocalizationConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedLocalizationConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LocalizationConverter : IValueConverter
public ref class LocalizationConverter : IValueConverter

The LocalizationConverter type exposes the following members.

Constructors
 | Name | Description
Public method | LocalizationConverter | Initializes a new instance of the LocalizationConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


LocalizationConverter Constructor

Initializes a new instance of the LocalizationConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LocalizationConverter()
public:
LocalizationConverter()
See Also

Reference

LocalizationConverter Class
VisualComponents.UX.Shared Namespace


LocalizationConverter Methods

The LocalizationConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LocalizationConverter Class
VisualComponents.UX.Shared Namespace


LocalizationConverter.Convert Method

LocalizationConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.LocalizationConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

LocalizationConverter Class
VisualComponents.UX.Shared Namespace


LocalizationConverter.ConvertBack Method

LocalizationConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.LocalizationConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

LocalizationConverter Class
VisualComponents.UX.Shared Namespace


LocalizationDesignTimeDictionary Class

Class includes localization resources at Design Time only
Inheritance Hierarchy
SystemObject
System.WindowsResourceDictionary
VisualComponents.UX.SharedLocalizationDesignTimeDictionary

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LocalizationDesignTimeDictionary : ResourceDictionary
public ref class LocalizationDesignTimeDictionary : public ResourceDictionary

The LocalizationDesignTimeDictionary type exposes the following members.

Constructors
 | Name | Description
Public method | LocalizationDesignTimeDictionary | Initializes a new instance of the LocalizationDesignTimeDictionary class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of entries in the base ResourceDictionary. (Inherited from ResourceDictionary.)
Public property | DeferrableContent | Gets or sets the deferrable content for this resource dictionary. (Inherited from ResourceDictionary.)
Public property | InvalidatesImplicitDataTemplateResources | Gets or sets a value that indicates whether the invalidations fired by the ResourceDictionary object cause ContentPresenter objects to reevaluate their choice of template. The invalidations happen when an implicit data template resource changes. (Inherited from ResourceDictionary.)
Public property | IsFixedSize | Gets whether this ResourceDictionary is fixed-size. (Inherited from ResourceDictionary.)
Public property | IsInDesignMode |
Public property | IsReadOnly | Gets whether this ResourceDictionary is read-only. (Inherited from ResourceDictionary.)
Public property | Item | Gets or sets the value associated with the given key. (Inherited from ResourceDictionary.)
Public property | Keys | Gets a collection of all keys contained in this ResourceDictionary. (Inherited from ResourceDictionary.)
Public property | MergedDictionaries | Gets a collection of the ResourceDictionary dictionaries that constitute the various resource dictionaries in the merged dictionaries. (Inherited from ResourceDictionary.)
Public property | Source |
Public property | Values | Gets a collection of all values associated with keys contained in this ResourceDictionary. (Inherited from ResourceDictionary.)
Top
Methods
 | Name | Description
Public method | Add | Adds a resource by key to this ResourceDictionary. (Inherited from ResourceDictionary.)
Public method | BeginInit | Begins the initialization phase for this ResourceDictionary. (Inherited from ResourceDictionary.)
Public method | Clear | Clears all keys (and values) in the base ResourceDictionary. This does not clear any merged dictionary items. (Inherited from ResourceDictionary.)
Public method | Contains | Determines whether the ResourceDictionary contains an element with the specified key. (Inherited from ResourceDictionary.)
Public method | CopyTo | Copies the ResourceDictionary elements to a one-dimensional DictionaryEntry at the specified index. (Inherited from ResourceDictionary.)
Public method | EndInit | Ends the initialization phase, and invalidates the previous tree such that all changes made to keys during the initialization phase can be accounted for. (Inherited from ResourceDictionary.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Not supported by this Dictionary implementation. (Inherited from ResourceDictionary.)
Public method | GetEnumerator | Returns an IDictionaryEnumerator that can be used to iterate through the ResourceDictionary. (Inherited from ResourceDictionary.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnGettingValue | Occurs when the ResourceDictionary receives a request for a resource. (Inherited from ResourceDictionary.)
Public method | RegisterName | Not supported by this Dictionary implementation. (Inherited from ResourceDictionary.)
Public method | Remove | Removes the entry with the specified key from the base dictionary. (Inherited from ResourceDictionary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterName | Not supported by this Dictionary implementation. (Inherited from ResourceDictionary.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


LocalizationDesignTimeDictionary Constructor

Initializes a new instance of the LocalizationDesignTimeDictionary class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LocalizationDesignTimeDictionary()
public:
LocalizationDesignTimeDictionary()
See Also

Reference

LocalizationDesignTimeDictionary Class
VisualComponents.UX.Shared Namespace


LocalizationDesignTimeDictionary Properties

The LocalizationDesignTimeDictionary type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of entries in the base ResourceDictionary. (Inherited from ResourceDictionary.)
Public property | DeferrableContent | Gets or sets the deferrable content for this resource dictionary. (Inherited from ResourceDictionary.)
Public property | InvalidatesImplicitDataTemplateResources | Gets or sets a value that indicates whether the invalidations fired by the ResourceDictionary object cause ContentPresenter objects to reevaluate their choice of template. The invalidations happen when an implicit data template resource changes. (Inherited from ResourceDictionary.)
Public property | IsFixedSize | Gets whether this ResourceDictionary is fixed-size. (Inherited from ResourceDictionary.)
Public property | IsInDesignMode |
Public property | IsReadOnly | Gets whether this ResourceDictionary is read-only. (Inherited from ResourceDictionary.)
Public property | Item | Gets or sets the value associated with the given key. (Inherited from ResourceDictionary.)
Public property | Keys | Gets a collection of all keys contained in this ResourceDictionary. (Inherited from ResourceDictionary.)
Public property | MergedDictionaries | Gets a collection of the ResourceDictionary dictionaries that constitute the various resource dictionaries in the merged dictionaries. (Inherited from ResourceDictionary.)
Public property | Source |
Public property | Values | Gets a collection of all values associated with keys contained in this ResourceDictionary. (Inherited from ResourceDictionary.)
Top
See Also

Reference

LocalizationDesignTimeDictionary Class
VisualComponents.UX.Shared Namespace


LocalizationDesignTimeDictionary.IsInDesignMode Property

LocalizationDesignTimeDictionaryIsInDesignMode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsInDesignMode { get; }
public:
property bool IsInDesignMode {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

LocalizationDesignTimeDictionary Class
VisualComponents.UX.Shared Namespace


LocalizationDesignTimeDictionary.Source Property

LocalizationDesignTimeDictionarySource Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Uri Source { get; set; }
public:
property Uri^ Source {
    Uri^ get ();
    void set (Uri^ value);
}

Property Value

Type: Uri
See Also

Reference

LocalizationDesignTimeDictionary Class
VisualComponents.UX.Shared Namespace


LocalizationDesignTimeDictionary Methods

The LocalizationDesignTimeDictionary type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a resource by key to this ResourceDictionary. (Inherited from ResourceDictionary.)
Public method | BeginInit | Begins the initialization phase for this ResourceDictionary. (Inherited from ResourceDictionary.)
Public method | Clear | Clears all keys (and values) in the base ResourceDictionary. This does not clear any merged dictionary items. (Inherited from ResourceDictionary.)
Public method | Contains | Determines whether the ResourceDictionary contains an element with the specified key. (Inherited from ResourceDictionary.)
Public method | CopyTo | Copies the ResourceDictionary elements to a one-dimensional DictionaryEntry at the specified index. (Inherited from ResourceDictionary.)
Public method | EndInit | Ends the initialization phase, and invalidates the previous tree such that all changes made to keys during the initialization phase can be accounted for. (Inherited from ResourceDictionary.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Not supported by this Dictionary implementation. (Inherited from ResourceDictionary.)
Public method | GetEnumerator | Returns an IDictionaryEnumerator that can be used to iterate through the ResourceDictionary. (Inherited from ResourceDictionary.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnGettingValue | Occurs when the ResourceDictionary receives a request for a resource. (Inherited from ResourceDictionary.)
Public method | RegisterName | Not supported by this Dictionary implementation. (Inherited from ResourceDictionary.)
Public method | Remove | Removes the entry with the specified key from the base dictionary. (Inherited from ResourceDictionary.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnregisterName | Not supported by this Dictionary implementation. (Inherited from ResourceDictionary.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LocalizationDesignTimeDictionary Class
VisualComponents.UX.Shared Namespace


LookupDialog Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedLookupDialog

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LookupDialog : IResult
public ref class LookupDialog : IResult

The LookupDialog type exposes the following members.

Constructors
 | Name | Description
Public method | LookupDialog | Initializes a new instance of the LookupDialog class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Completed |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


LookupDialog Constructor

Initializes a new instance of the LookupDialog class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LookupDialog(
    string title,
    List<INamed> items,
    IList result
)
public:
LookupDialog(
    String^ title,
    List<INamed^>^ items,
    IList^ result
)

Parameters

title
Type: SystemString
items
Type: System.Collections.GenericListINamed
result
Type: System.CollectionsIList
See Also

Reference

LookupDialog Class
VisualComponents.UX.Shared Namespace


LookupDialog Methods

The LookupDialog type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LookupDialog Class
VisualComponents.UX.Shared Namespace


LookupDialog.Execute Method

LookupDialogExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    ActionExecutionContext context
)
public:
virtual void Execute(
    ActionExecutionContext^ context
) sealed

Parameters

context
Type: ActionExecutionContext

Implements

IResult.Execute(ActionExecutionContext)
See Also

Reference

LookupDialog Class
VisualComponents.UX.Shared Namespace


LookupDialog Events

The LookupDialog type exposes the following members.

Events
 | Name | Description
Public event | Completed |
Top
See Also

Reference

LookupDialog Class
VisualComponents.UX.Shared Namespace


LookupDialog.Completed Event

LookupDialogCompleted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ResultCompletionEventArgs> Completed
public:
virtual  event EventHandler<ResultCompletionEventArgs^>^ Completed {
    void add (EventHandler<ResultCompletionEventArgs^>^ value);
    void remove (EventHandler<ResultCompletionEventArgs^>^ value);
}

Value

Type: SystemEventHandlerResultCompletionEventArgs

Implements

IResult.Completed
See Also

Reference

LookupDialog Class
VisualComponents.UX.Shared Namespace


LookupDialogView Class

Interaction logic for LookupDialog.xaml
LookupDialogView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedLookupDialogView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LookupDialogView : UserControl,
    IComponentConnector
public ref class LookupDialogView : public UserControl,
    IComponentConnector

The LookupDialogView type exposes the following members.

Constructors
 | Name | Description
Public method | LookupDialogView | Initializes a new instance of the LookupDialogView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
_searchHint |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


LookupDialogView Constructor

Initializes a new instance of the LookupDialogView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LookupDialogView()
public:
LookupDialogView()
See Also

Reference

LookupDialogView Class
VisualComponents.UX.Shared Namespace


LookupDialogView Properties

The LookupDialogView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

LookupDialogView Class
VisualComponents.UX.Shared Namespace


LookupDialogView Methods

The LookupDialogView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LookupDialogView Class
VisualComponents.UX.Shared Namespace


LookupDialogView.InitializeComponent Method

LookupDialogViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

LookupDialogView Class
VisualComponents.UX.Shared Namespace


LookupDialogView Events

The LookupDialogView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

LookupDialogView Class
VisualComponents.UX.Shared Namespace


LookupDialogView Fields

The LookupDialogView type exposes the following members.

Fields
Name | Description
_searchHint |
Top
See Also

Reference

LookupDialogView Class
VisualComponents.UX.Shared Namespace


LookupDialogView._searchHint Field

LookupDialogView_searchHint Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string _searchHint
public:
static String^ _searchHint

Field Value

Type: String
See Also

Reference

LookupDialogView Class
VisualComponents.UX.Shared Namespace


LookupItem Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedLookupItem

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class LookupItem
public ref class LookupItem

The LookupItem type exposes the following members.

Constructors
 | Name | Description
Public method | LookupItem | Initializes a new instance of the LookupItem class
Top
Properties
 | Name | Description
Public property | IsSelected |
Public property | Name |
Public property | UniqueName |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnIsSelectedChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | IsSelectedChanged |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


LookupItem Constructor

Initializes a new instance of the LookupItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public LookupItem()
public:
LookupItem()
See Also

Reference

LookupItem Class
VisualComponents.UX.Shared Namespace


LookupItem Properties

The LookupItem type exposes the following members.

Properties
 | Name | Description
Public property | IsSelected |
Public property | Name |
Public property | UniqueName |
Top
See Also

Reference

LookupItem Class
VisualComponents.UX.Shared Namespace


LookupItem.IsSelected Property

LookupItemIsSelected Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsSelected { get; set; }
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LookupItem Class
VisualComponents.UX.Shared Namespace


LookupItem.Name Property

LookupItemName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; }
public:
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

LookupItem Class
VisualComponents.UX.Shared Namespace


LookupItem.UniqueName Property

LookupItemUniqueName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool UniqueName { get; set; }
public:
property bool UniqueName {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LookupItem Class
VisualComponents.UX.Shared Namespace


LookupItem Methods

The LookupItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnIsSelectedChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

LookupItem Class
VisualComponents.UX.Shared Namespace


LookupItem.OnIsSelectedChanged Method

LookupItemOnIsSelectedChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void OnIsSelectedChanged(
    EventArgs e
)
protected:
virtual void OnIsSelectedChanged(
    EventArgs^ e
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

LookupItem Class
VisualComponents.UX.Shared Namespace


LookupItem Events

The LookupItem type exposes the following members.

Events
 | Name | Description
Public event | IsSelectedChanged |
Top
See Also

Reference

LookupItem Class
VisualComponents.UX.Shared Namespace


LookupItem.IsSelectedChanged Event

LookupItemIsSelectedChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler IsSelectedChanged
public:
 event EventHandler^ IsSelectedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

LookupItem Class
VisualComponents.UX.Shared Namespace


ManipulateViews Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ManipulateViews
public enum class ManipulateViews
Members
Member name | Value | Description
ManipulateViewForCommandPanel | 0 |
ManipulateViewForPropertyEditorPane | 1 |
ManipulateViewForJogView | 2 |
ManipulateViewForRibbon | 3 |
See Also

Reference

VisualComponents.UX.Shared Namespace


ManipulationModeChangedMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedManipulationModeChangedMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ManipulationModeChangedMessage
public ref class ManipulationModeChangedMessage

The ManipulationModeChangedMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ManipulationModeChangedMessage | Initializes a new instance of the ManipulationModeChangedMessage class
Top
Properties
 | Name | Description
Public property | CurrentMode |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ManipulationModeChangedMessage Constructor

Initializes a new instance of the ManipulationModeChangedMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ManipulationModeChangedMessage(
    ManipulationMode currentMode
)
public:
ManipulationModeChangedMessage(
    ManipulationMode currentMode
)

Parameters

currentMode
Type: VisualComponents.Create3DManipulationMode
See Also

Reference

ManipulationModeChangedMessage Class
VisualComponents.UX.Shared Namespace


ManipulationModeChangedMessage Properties

The ManipulationModeChangedMessage type exposes the following members.

Properties
 | Name | Description
Public property | CurrentMode |
Top
See Also

Reference

ManipulationModeChangedMessage Class
VisualComponents.UX.Shared Namespace


ManipulationModeChangedMessage.CurrentMode Property

ManipulationModeChangedMessageCurrentMode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ManipulationMode CurrentMode { get; set; }
public:
property ManipulationMode CurrentMode {
    ManipulationMode get ();
    void set (ManipulationMode value);
}

Property Value

Type: ManipulationMode
See Also

Reference

ManipulationModeChangedMessage Class
VisualComponents.UX.Shared Namespace


ManipulationModeChangedMessage Methods

The ManipulationModeChangedMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ManipulationModeChangedMessage Class
VisualComponents.UX.Shared Namespace


MaterialEditor Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsItemsControl
System.Windows.Controls.PrimitivesSelector
System.Windows.ControlsComboBox
VisualComponents.UX.SharedMaterialEditor

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class MaterialEditor : ComboBox
public ref class MaterialEditor : public ComboBox

The MaterialEditor type exposes the following members.

Constructors
 | Name | Description
Public method | MaterialEditor | Initializes a new instance of the MaterialEditor class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a combo box supports scrolling. (Inherited from ComboBox.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the ComboBox has focus. (Inherited from ComboBox.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsDropDownOpen | Gets or sets a value that indicates whether the drop-down for a combo box is currently open. (Inherited from ComboBox.)
Public property | IsEditable | Gets or sets a value that enables or disables editing of the text in text box of the ComboBox. (Inherited from ComboBox.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that enables selection-only mode, in which the contents of the combo box are selectable but not editable. (Inherited from ComboBox.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionBoxHighlighted | Gets whether the SelectionBoxItem is highlighted. (Inherited from ComboBox.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxDropDownHeight | Gets or sets the maximum height for a combo box drop-down. (Inherited from ComboBox.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionBoxItem | Gets the item that is displayed in the selection box. (Inherited from ComboBox.)
Public property | SelectionBoxItemStringFormat | Gets a composite string that specifies how to format the selected item in the selection box if it is displayed as a string. (Inherited from ComboBox.)
Public property | SelectionBoxItemTemplate | Gets the item template of the selection box content. (Inherited from ComboBox.)
Public property | ShouldPreserveUserEnteredPrefix | Gets or sets a value that indicates whether the ComboBox keeps the user's input or replaces the input with a matching item. (Inherited from ComboBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | StaysOpenOnEdit | Gets or sets whether a ComboBox that is open and displays a drop-down control will remain open when a user clicks the TextBox. (Inherited from ComboBox.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Gets or sets the text of the currently selected item. (Inherited from ComboBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Returns an item container to the state it was in before PrepareContainerForItemOverride(DependencyObject, Object). (Inherited from Selector.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Inherited from ComboBox.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | IsItemItsOwnContainer | Determines if the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ComboBox.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | Called when ApplyTemplate is called. (Inherited from ComboBox.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ComboBoxAutomationPeer implementation for this control, as part of the WPF infrastructure. (Inherited from ComboBox.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDropDownClosed | Reports when a combo box's popup closes. (Inherited from ComboBox.)
Protected method | OnDropDownOpened | Reports when a combo box's popup opens. (Inherited from ComboBox.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to internally. (Inherited from Selector.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from ComboBox.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes. (Inherited from ComboBox.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Invoked when a KeyDown attached routed event occurs. (Inherited from ComboBox.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Called to report that the left mouse button was released. (Inherited from ComboBox.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when a PreviewKeyDown attached routed event occurs. (Inherited from ComboBox.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Responds to a ComboBox selection change by raising a SelectionChanged event. (Inherited from ComboBox.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ComboBox.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropDownClosed | Occurs when the drop-down list of the combo box closes. (Inherited from ComboBox.)
Public event | DropDownOpened | Occurs when the drop-down list of the combo box opens. (Inherited from ComboBox.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


MaterialEditor Constructor

Initializes a new instance of the MaterialEditor class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MaterialEditor()
public:
MaterialEditor()
See Also

Reference

MaterialEditor Class
VisualComponents.UX.Shared Namespace


MaterialEditor Properties

The MaterialEditor type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a combo box supports scrolling. (Inherited from ComboBox.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the ComboBox has focus. (Inherited from ComboBox.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsDropDownOpen | Gets or sets a value that indicates whether the drop-down for a combo box is currently open. (Inherited from ComboBox.)
Public property | IsEditable | Gets or sets a value that enables or disables editing of the text in text box of the ComboBox. (Inherited from ComboBox.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that enables selection-only mode, in which the contents of the combo box are selectable but not editable. (Inherited from ComboBox.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionBoxHighlighted | Gets whether the SelectionBoxItem is highlighted. (Inherited from ComboBox.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. (Inherited from Selector.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxDropDownHeight | Gets or sets the maximum height for a combo box drop-down. (Inherited from ComboBox.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty (Inherited from Selector.)
Public property | SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath. (Inherited from Selector.)
Public property | SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem. (Inherited from Selector.)
Public property | SelectionBoxItem | Gets the item that is displayed in the selection box. (Inherited from ComboBox.)
Public property | SelectionBoxItemStringFormat | Gets a composite string that specifies how to format the selected item in the selection box if it is displayed as a string. (Inherited from ComboBox.)
Public property | SelectionBoxItemTemplate | Gets the item template of the selection box content. (Inherited from ComboBox.)
Public property | ShouldPreserveUserEnteredPrefix | Gets or sets a value that indicates whether the ComboBox keeps the user's input or replaces the input with a matching item. (Inherited from ComboBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | StaysOpenOnEdit | Gets or sets whether a ComboBox that is open and displays a drop-down control will remain open when a user clicks the TextBox. (Inherited from ComboBox.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Gets or sets the text of the currently selected item. (Inherited from ComboBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

MaterialEditor Class
VisualComponents.UX.Shared Namespace


MaterialEditor Methods

The MaterialEditor type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | Returns an item container to the state it was in before PrepareContainerForItemOverride(DependencyObject, Object). (Inherited from Selector.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Inherited from ComboBox.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | IsItemItsOwnContainer | Determines if the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ComboBox.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | Called when ApplyTemplate is called. (Inherited from ComboBox.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ComboBoxAutomationPeer implementation for this control, as part of the WPF infrastructure. (Inherited from ComboBox.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDropDownClosed | Reports when a combo box's popup closes. (Inherited from ComboBox.)
Protected method | OnDropDownOpened | Reports when a combo box's popup opens. (Inherited from ComboBox.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to internally. (Inherited from Selector.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Reports that the IsKeyboardFocusWithin property changed. (Inherited from ComboBox.)
Protected method | OnIsMouseCapturedChanged | Called when the IsMouseCaptured property changes. (Inherited from ComboBox.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the source of an item in a selector changes. (Inherited from Selector.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Invoked when a KeyDown attached routed event occurs. (Inherited from ComboBox.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Called to report that the left mouse button was released. (Inherited from ComboBox.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when a PreviewKeyDown attached routed event occurs. (Inherited from ComboBox.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Responds to a ComboBox selection change by raising a SelectionChanged event. (Inherited from ComboBox.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ComboBox.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MaterialEditor Class
VisualComponents.UX.Shared Namespace


MaterialEditor Events

The MaterialEditor type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | DropDownClosed | Occurs when the drop-down list of the combo box closes. (Inherited from ComboBox.)
Public event | DropDownOpened | Occurs when the drop-down list of the combo box opens. (Inherited from ComboBox.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

MaterialEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
VisualComponents.UX.SharedMatrixEditor

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class MatrixEditor : Control
public ref class MatrixEditor : public Control

The MatrixEditor type exposes the following members.

Constructors
 | Name | Description
Public method | MatrixEditor | Initializes a new instance of the MatrixEditor class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AXLabelText |
Public property | AXValue |
Public property | AYLabelText |
Public property | AYValue |
Public property | AZLabelText |
Public property | AZValue |
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContainerExpressionContext |
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | CoordinateSystemHeaderText |
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsCoordinateSystemHeaderVisible |
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMatrixEditorHeaderVisible |
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsRotateVectorHeaderVisible |
Public property | IsRotateVectorUnitVisible |
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTranslateVectorHeaderVisible |
Public property | IsTranslateVectorUnitVisible |
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MatrixEditorHeaderText |
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | NXLabelText |
Public property | NXValue |
Public property | NYLabelText |
Public property | NYValue |
Public property | NZLabelText |
Public property | NZValue |
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OXLabelText |
Public property | OXValue |
Public property | OYLabelText |
Public property | OYValue |
Public property | OZLabelText |
Public property | OZValue |
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | PXLabelText |
Public property | PXValue |
Public property | PYLabelText |
Public property | PYValue |
Public property | PZLabelText |
Public property | PZValue |
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RotateVectorHeaderText |
Public property | RotateVectorUnit |
Public property | RotationMode |
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TranslateVectorHeaderText |
Public property | TranslateVectorUnit |
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | WPRXLabelText |
Public property | WPRXValue |
Public property | WPRYLabelText |
Public property | WPRYValue |
Public property | WPRZLabelText |
Public property | WPRZValue |
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AXLabelTextProperty |
AXValueProperty |
AYLabelTextProperty |
AYValueProperty |
AZLabelTextProperty |
AZValueProperty |
CoordinateSystemHeaderTextProperty |
IsCoordinateSystemHeaderVisibleProperty |
IsMatrixEditorHeaderVisibleProperty |
IsRotateVectorHeaderVisibleProperty |
IsRotateVectorUnitVisibleProperty |
IsTranslateVectorHeaderVisibleProperty |
IsTranslateVectorUnitVisibleProperty |
MatrixEditorHeaderTextProperty |
NXLabelTextProperty |
NXValueProperty |
NYLabelTextProperty |
NYValueProperty |
NZLabelTextProperty |
NZValueProperty |
OXLabelTextProperty |
OXValueProperty |
OYLabelTextProperty |
OYValueProperty |
OZLabelTextProperty |
OZValueProperty |
PXLabelTextProperty |
PXValueProperty |
PYLabelTextProperty |
PYValueProperty |
PZLabelTextProperty |
PZValueProperty |
RotateVectorHeaderTextProperty |
RotateVectorUnitProperty |
RotationModeProperty |
TranslateVectorHeaderTextProperty |
TranslateVectorUnitProperty |
WPRXLabelTextProperty |
WPRXValueProperty |
WPRYLabelTextProperty |
WPRYValueProperty |
WPRZLabelTextProperty |
WPRZValueProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


MatrixEditor Constructor

Initializes a new instance of the MatrixEditor class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MatrixEditor()
public:
MatrixEditor()
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor Properties

The MatrixEditor type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AXLabelText |
Public property | AXValue |
Public property | AYLabelText |
Public property | AYValue |
Public property | AZLabelText |
Public property | AZValue |
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContainerExpressionContext |
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | CoordinateSystemHeaderText |
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsCoordinateSystemHeaderVisible |
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMatrixEditorHeaderVisible |
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsRotateVectorHeaderVisible |
Public property | IsRotateVectorUnitVisible |
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTranslateVectorHeaderVisible |
Public property | IsTranslateVectorUnitVisible |
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MatrixEditorHeaderText |
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | NXLabelText |
Public property | NXValue |
Public property | NYLabelText |
Public property | NYValue |
Public property | NZLabelText |
Public property | NZValue |
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OXLabelText |
Public property | OXValue |
Public property | OYLabelText |
Public property | OYValue |
Public property | OZLabelText |
Public property | OZValue |
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | PXLabelText |
Public property | PXValue |
Public property | PYLabelText |
Public property | PYValue |
Public property | PZLabelText |
Public property | PZValue |
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RotateVectorHeaderText |
Public property | RotateVectorUnit |
Public property | RotationMode |
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TranslateVectorHeaderText |
Public property | TranslateVectorUnit |
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | WPRXLabelText |
Public property | WPRXValue |
Public property | WPRYLabelText |
Public property | WPRYValue |
Public property | WPRZLabelText |
Public property | WPRZValue |
Top
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.AXLabelText Property

MatrixEditorAXLabelText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AXLabelText { get; set; }
public:
property String^ AXLabelText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.AXValue Property

MatrixEditorAXValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double AXValue { get; set; }
public:
property double AXValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.AYLabelText Property

MatrixEditorAYLabelText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AYLabelText { get; set; }
public:
property String^ AYLabelText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.AYValue Property

MatrixEditorAYValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double AYValue { get; set; }
public:
property double AYValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.AZLabelText Property

MatrixEditorAZLabelText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AZLabelText { get; set; }
public:
property String^ AZLabelText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.AZValue Property

MatrixEditorAZValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double AZValue { get; set; }
public:
property double AZValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.ContainerExpressionContext Property

MatrixEditorContainerExpressionContext Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IExpressionContext ContainerExpressionContext { get; }
public:
property IExpressionContext^ ContainerExpressionContext {
    IExpressionContext^ get ();
}

Property Value

Type: IExpressionContext
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.CoordinateSystemHeaderText Property

MatrixEditorCoordinateSystemHeaderText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CoordinateSystemHeaderText { get; set; }
public:
property String^ CoordinateSystemHeaderText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.IsCoordinateSystemHeaderVisible Property

MatrixEditorIsCoordinateSystemHeaderVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsCoordinateSystemHeaderVisible { get; set; }
public:
property bool IsCoordinateSystemHeaderVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.IsMatrixEditorHeaderVisible Property

MatrixEditorIsMatrixEditorHeaderVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsMatrixEditorHeaderVisible { get; set; }
public:
property bool IsMatrixEditorHeaderVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.IsRotateVectorHeaderVisible Property

MatrixEditorIsRotateVectorHeaderVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsRotateVectorHeaderVisible { get; set; }
public:
property bool IsRotateVectorHeaderVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.IsRotateVectorUnitVisible Property

MatrixEditorIsRotateVectorUnitVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsRotateVectorUnitVisible { get; set; }
public:
property bool IsRotateVectorUnitVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.IsTranslateVectorHeaderVisible Property

MatrixEditorIsTranslateVectorHeaderVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsTranslateVectorHeaderVisible { get; set; }
public:
property bool IsTranslateVectorHeaderVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.IsTranslateVectorUnitVisible Property

MatrixEditorIsTranslateVectorUnitVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsTranslateVectorUnitVisible { get; set; }
public:
property bool IsTranslateVectorUnitVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.MatrixEditorHeaderText Property

MatrixEditorMatrixEditorHeaderText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string MatrixEditorHeaderText { get; set; }
public:
property String^ MatrixEditorHeaderText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.NXLabelText Property

MatrixEditorNXLabelText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string NXLabelText { get; set; }
public:
property String^ NXLabelText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.NXValue Property

MatrixEditorNXValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double NXValue { get; set; }
public:
property double NXValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.NYLabelText Property

MatrixEditorNYLabelText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string NYLabelText { get; set; }
public:
property String^ NYLabelText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.NYValue Property

MatrixEditorNYValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double NYValue { get; set; }
public:
property double NYValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.NZLabelText Property

MatrixEditorNZLabelText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string NZLabelText { get; set; }
public:
property String^ NZLabelText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.NZValue Property

MatrixEditorNZValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double NZValue { get; set; }
public:
property double NZValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.OXLabelText Property

MatrixEditorOXLabelText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string OXLabelText { get; set; }
public:
property String^ OXLabelText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.OXValue Property

MatrixEditorOXValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double OXValue { get; set; }
public:
property double OXValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.OYLabelText Property

MatrixEditorOYLabelText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string OYLabelText { get; set; }
public:
property String^ OYLabelText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.OYValue Property

MatrixEditorOYValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double OYValue { get; set; }
public:
property double OYValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.OZLabelText Property

MatrixEditorOZLabelText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string OZLabelText { get; set; }
public:
property String^ OZLabelText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.OZValue Property

MatrixEditorOZValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double OZValue { get; set; }
public:
property double OZValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.PXLabelText Property

MatrixEditorPXLabelText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string PXLabelText { get; set; }
public:
property String^ PXLabelText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.PXValue Property

MatrixEditorPXValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double PXValue { get; set; }
public:
property double PXValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.PYLabelText Property

MatrixEditorPYLabelText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string PYLabelText { get; set; }
public:
property String^ PYLabelText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.PYValue Property

MatrixEditorPYValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double PYValue { get; set; }
public:
property double PYValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.PZLabelText Property

MatrixEditorPZLabelText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string PZLabelText { get; set; }
public:
property String^ PZLabelText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.PZValue Property

MatrixEditorPZValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double PZValue { get; set; }
public:
property double PZValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.RotateVectorHeaderText Property

MatrixEditorRotateVectorHeaderText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string RotateVectorHeaderText { get; set; }
public:
property String^ RotateVectorHeaderText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.RotateVectorUnit Property

MatrixEditorRotateVectorUnit Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string RotateVectorUnit { get; set; }
public:
property String^ RotateVectorUnit {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.RotationMode Property

MatrixEditorRotationMode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RotationCoordinateSystem RotationMode { get; set; }
public:
property RotationCoordinateSystem RotationMode {
    RotationCoordinateSystem get ();
    void set (RotationCoordinateSystem value);
}

Property Value

Type: RotationCoordinateSystem
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.TranslateVectorHeaderText Property

MatrixEditorTranslateVectorHeaderText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string TranslateVectorHeaderText { get; set; }
public:
property String^ TranslateVectorHeaderText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.TranslateVectorUnit Property

MatrixEditorTranslateVectorUnit Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string TranslateVectorUnit { get; set; }
public:
property String^ TranslateVectorUnit {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.WPRXLabelText Property

MatrixEditorWPRXLabelText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string WPRXLabelText { get; set; }
public:
property String^ WPRXLabelText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.WPRXValue Property

MatrixEditorWPRXValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double WPRXValue { get; set; }
public:
property double WPRXValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.WPRYLabelText Property

MatrixEditorWPRYLabelText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string WPRYLabelText { get; set; }
public:
property String^ WPRYLabelText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.WPRYValue Property

MatrixEditorWPRYValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double WPRYValue { get; set; }
public:
property double WPRYValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.WPRZLabelText Property

MatrixEditorWPRZLabelText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string WPRZLabelText { get; set; }
public:
property String^ WPRZLabelText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.WPRZValue Property

MatrixEditorWPRZValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double WPRZValue { get; set; }
public:
property double WPRZValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor Methods

The MatrixEditor type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor Events

The MatrixEditor type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor Fields

The MatrixEditor type exposes the following members.

Fields
Name | Description
AXLabelTextProperty |
AXValueProperty |
AYLabelTextProperty |
AYValueProperty |
AZLabelTextProperty |
AZValueProperty |
CoordinateSystemHeaderTextProperty |
IsCoordinateSystemHeaderVisibleProperty |
IsMatrixEditorHeaderVisibleProperty |
IsRotateVectorHeaderVisibleProperty |
IsRotateVectorUnitVisibleProperty |
IsTranslateVectorHeaderVisibleProperty |
IsTranslateVectorUnitVisibleProperty |
MatrixEditorHeaderTextProperty |
NXLabelTextProperty |
NXValueProperty |
NYLabelTextProperty |
NYValueProperty |
NZLabelTextProperty |
NZValueProperty |
OXLabelTextProperty |
OXValueProperty |
OYLabelTextProperty |
OYValueProperty |
OZLabelTextProperty |
OZValueProperty |
PXLabelTextProperty |
PXValueProperty |
PYLabelTextProperty |
PYValueProperty |
PZLabelTextProperty |
PZValueProperty |
RotateVectorHeaderTextProperty |
RotateVectorUnitProperty |
RotationModeProperty |
TranslateVectorHeaderTextProperty |
TranslateVectorUnitProperty |
WPRXLabelTextProperty |
WPRXValueProperty |
WPRYLabelTextProperty |
WPRYValueProperty |
WPRZLabelTextProperty |
WPRZValueProperty |
Top
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.AXLabelTextProperty Field

MatrixEditorAXLabelTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty AXLabelTextProperty
public:
static DependencyProperty^ AXLabelTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.AXValueProperty Field

MatrixEditorAXValueProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty AXValueProperty
public:
static DependencyProperty^ AXValueProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.AYLabelTextProperty Field

MatrixEditorAYLabelTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty AYLabelTextProperty
public:
static DependencyProperty^ AYLabelTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.AYValueProperty Field

MatrixEditorAYValueProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty AYValueProperty
public:
static DependencyProperty^ AYValueProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.AZLabelTextProperty Field

MatrixEditorAZLabelTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty AZLabelTextProperty
public:
static DependencyProperty^ AZLabelTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.AZValueProperty Field

MatrixEditorAZValueProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty AZValueProperty
public:
static DependencyProperty^ AZValueProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.CoordinateSystemHeaderTextProperty Field

MatrixEditorCoordinateSystemHeaderTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty CoordinateSystemHeaderTextProperty
public:
static DependencyProperty^ CoordinateSystemHeaderTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.IsCoordinateSystemHeaderVisibleProperty Field

MatrixEditorIsCoordinateSystemHeaderVisibleProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty IsCoordinateSystemHeaderVisibleProperty
public:
static DependencyProperty^ IsCoordinateSystemHeaderVisibleProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.IsMatrixEditorHeaderVisibleProperty Field

MatrixEditorIsMatrixEditorHeaderVisibleProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty IsMatrixEditorHeaderVisibleProperty
public:
static DependencyProperty^ IsMatrixEditorHeaderVisibleProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.IsRotateVectorHeaderVisibleProperty Field

MatrixEditorIsRotateVectorHeaderVisibleProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty IsRotateVectorHeaderVisibleProperty
public:
static DependencyProperty^ IsRotateVectorHeaderVisibleProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.IsRotateVectorUnitVisibleProperty Field

MatrixEditorIsRotateVectorUnitVisibleProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty IsRotateVectorUnitVisibleProperty
public:
static DependencyProperty^ IsRotateVectorUnitVisibleProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.IsTranslateVectorHeaderVisibleProperty Field

MatrixEditorIsTranslateVectorHeaderVisibleProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty IsTranslateVectorHeaderVisibleProperty
public:
static DependencyProperty^ IsTranslateVectorHeaderVisibleProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.IsTranslateVectorUnitVisibleProperty Field

MatrixEditorIsTranslateVectorUnitVisibleProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty IsTranslateVectorUnitVisibleProperty
public:
static DependencyProperty^ IsTranslateVectorUnitVisibleProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.MatrixEditorHeaderTextProperty Field

MatrixEditorMatrixEditorHeaderTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty MatrixEditorHeaderTextProperty
public:
static DependencyProperty^ MatrixEditorHeaderTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.NXLabelTextProperty Field

MatrixEditorNXLabelTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty NXLabelTextProperty
public:
static DependencyProperty^ NXLabelTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.NXValueProperty Field

MatrixEditorNXValueProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty NXValueProperty
public:
static DependencyProperty^ NXValueProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.NYLabelTextProperty Field

MatrixEditorNYLabelTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty NYLabelTextProperty
public:
static DependencyProperty^ NYLabelTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.NYValueProperty Field

MatrixEditorNYValueProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty NYValueProperty
public:
static DependencyProperty^ NYValueProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.NZLabelTextProperty Field

MatrixEditorNZLabelTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty NZLabelTextProperty
public:
static DependencyProperty^ NZLabelTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.NZValueProperty Field

MatrixEditorNZValueProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty NZValueProperty
public:
static DependencyProperty^ NZValueProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.OXLabelTextProperty Field

MatrixEditorOXLabelTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty OXLabelTextProperty
public:
static DependencyProperty^ OXLabelTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.OXValueProperty Field

MatrixEditorOXValueProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty OXValueProperty
public:
static DependencyProperty^ OXValueProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.OYLabelTextProperty Field

MatrixEditorOYLabelTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty OYLabelTextProperty
public:
static DependencyProperty^ OYLabelTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.OYValueProperty Field

MatrixEditorOYValueProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty OYValueProperty
public:
static DependencyProperty^ OYValueProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.OZLabelTextProperty Field

MatrixEditorOZLabelTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty OZLabelTextProperty
public:
static DependencyProperty^ OZLabelTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.OZValueProperty Field

MatrixEditorOZValueProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty OZValueProperty
public:
static DependencyProperty^ OZValueProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.PXLabelTextProperty Field

MatrixEditorPXLabelTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty PXLabelTextProperty
public:
static DependencyProperty^ PXLabelTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.PXValueProperty Field

MatrixEditorPXValueProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty PXValueProperty
public:
static DependencyProperty^ PXValueProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.PYLabelTextProperty Field

MatrixEditorPYLabelTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty PYLabelTextProperty
public:
static DependencyProperty^ PYLabelTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.PYValueProperty Field

MatrixEditorPYValueProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty PYValueProperty
public:
static DependencyProperty^ PYValueProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.PZLabelTextProperty Field

MatrixEditorPZLabelTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty PZLabelTextProperty
public:
static DependencyProperty^ PZLabelTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.PZValueProperty Field

MatrixEditorPZValueProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty PZValueProperty
public:
static DependencyProperty^ PZValueProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.RotateVectorHeaderTextProperty Field

MatrixEditorRotateVectorHeaderTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty RotateVectorHeaderTextProperty
public:
static DependencyProperty^ RotateVectorHeaderTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.RotateVectorUnitProperty Field

MatrixEditorRotateVectorUnitProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty RotateVectorUnitProperty
public:
static DependencyProperty^ RotateVectorUnitProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.RotationModeProperty Field

MatrixEditorRotationModeProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty RotationModeProperty
public:
static initonly DependencyProperty^ RotationModeProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.TranslateVectorHeaderTextProperty Field

MatrixEditorTranslateVectorHeaderTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty TranslateVectorHeaderTextProperty
public:
static DependencyProperty^ TranslateVectorHeaderTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.TranslateVectorUnitProperty Field

MatrixEditorTranslateVectorUnitProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty TranslateVectorUnitProperty
public:
static DependencyProperty^ TranslateVectorUnitProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.WPRXLabelTextProperty Field

MatrixEditorWPRXLabelTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty WPRXLabelTextProperty
public:
static DependencyProperty^ WPRXLabelTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.WPRXValueProperty Field

MatrixEditorWPRXValueProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty WPRXValueProperty
public:
static DependencyProperty^ WPRXValueProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.WPRYLabelTextProperty Field

MatrixEditorWPRYLabelTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty WPRYLabelTextProperty
public:
static DependencyProperty^ WPRYLabelTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.WPRYValueProperty Field

MatrixEditorWPRYValueProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty WPRYValueProperty
public:
static DependencyProperty^ WPRYValueProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.WPRZLabelTextProperty Field

MatrixEditorWPRZLabelTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty WPRZLabelTextProperty
public:
static DependencyProperty^ WPRZLabelTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixEditor.WPRZValueProperty Field

MatrixEditorWPRZValueProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty WPRZValueProperty
public:
static DependencyProperty^ WPRZValueProperty

Field Value

Type: DependencyProperty
See Also

Reference

MatrixEditor Class
VisualComponents.UX.Shared Namespace


MatrixProperty Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedEditorProperty
VisualComponents.UX.SharedMatrixProperty

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class MatrixProperty : EditorProperty
public ref class MatrixProperty : public EditorProperty

The MatrixProperty type exposes the following members.

Constructors
 | Name | Description
Public method | MatrixProperty | Initializes a new instance of the MatrixProperty class
Top
Properties
 | Name | Description
Public property | AllowedMaximum | (Inherited from EditorProperty.)
Public property | AllowedMinimum | (Inherited from EditorProperty.)
Public property | AllowedValues | (Inherited from EditorProperty.)
Public property | AX |
Public property | AY |
Public property | AZ |
Public property | CanCreateNewValue | (Inherited from EditorProperty.)
Public property | Category | (Inherited from EditorProperty.)
Public property | ConstraintType | (Inherited from EditorProperty.)
Public property | Container | (Inherited from EditorProperty.)
Public property | ContainerExpressionContext | (Inherited from EditorProperty.)
Public property | ContainerObject | Similar to IProperty.Container, but for any object. (Inherited from EditorProperty.)
Public property | CreationTypes | (Inherited from EditorProperty.)
Public property | Description | (Inherited from EditorProperty.)
Public property | DisabledStateToolTip | (Inherited from EditorProperty.)
Public property | DistributionExpression | (Inherited from EditorProperty.)
Public property | Error | (Inherited from EditorProperty.)
Public property | ErrorMessage | (Inherited from EditorProperty.)
Public property | HasDistribution | (Inherited from EditorProperty.)
Public property | History | (Inherited from EditorProperty.)
Public property | Index_ForComboBox | (Inherited from EditorProperty.)
Public property | IsDesignTime | (Inherited from EditorProperty.)
Public property | IsEditable | Helper property since in XAML negating binding value is not possible without using BoolToOppositeConverter (Inherited from EditorProperty.)
Public property | IsEditableInGui | (Inherited from EditorProperty.)
Public property | IsExceptionallyInHome | (Inherited from EditorProperty.)
Public property | IsInternal | (Inherited from EditorProperty.)
Public property | IsLocked | (Inherited from EditorProperty.)
Public property | IsPersistent | (Inherited from EditorProperty.)
Public property | IsQuantityValue | (Inherited from EditorProperty.)
Public property | IsReadOnly | (Inherited from EditorProperty.)
Public property | IsValid | (Inherited from EditorProperty.)
Public property | IsVisible | (Inherited from EditorProperty.)
Public property | IsVisibleDesignTime | (Inherited from EditorProperty.)
Public property | IsVisibleForced | (Inherited from EditorProperty.)
Public property | IsVisibleInGui | IsVisibleInGui is used to bind GUI visibility. Setting this value affects only _isVisibleForcedOff. (Inherited from EditorProperty.)
Public property | Item | (Inherited from EditorProperty.)
Public property | Name | (Inherited from EditorProperty.)
Public property | NonLocalizedName | (Inherited from EditorProperty.)
Public property | NX |
Public property | NY |
Public property | NZ |
Public property | Order | (Inherited from EditorProperty.)
Public property | OX |
Public property | OY |
Public property | OZ |
Public property | Property | (Inherited from EditorProperty.)
Public property | PropertyDescription | (Inherited from EditorProperty.)
Public property | PropertyType | (Inherited from EditorProperty.)
Public property | PX |
Public property | PY |
Public property | PZ |
Public property | Quantity | (Inherited from EditorProperty.)
Public property | ResourceType | In case of having an IUriProperty, this determines if the editor should allow folder selection instead of file selection (Inherited from EditorProperty.)
Public property | RotationSystem | (Inherited from EditorProperty.)
Public property | ShowValuepicker | (Inherited from EditorProperty.)
Public property | TabHeader | (Inherited from EditorProperty.)
Public property | Unit | (Inherited from EditorProperty.)
Public property | Value | (Inherited from EditorProperty.)
Public property | Value_ForComboBox | Helper property, used only by ComboBox. (Inherited from EditorProperty.)
Public property | ValueString | (Inherited from EditorProperty.)
Public property | WPRX |
Public property | WPRY |
Public property | WPRZ |
Top
Methods
 | Name | Description
Public method | Associate | (Inherited from EditorProperty.)
Public method | CheckEditableInGui | (Inherited from EditorProperty.)
Protected method | CheckPropertyObjDispose | (Inherited from EditorProperty.)
Public method | CheckRebuild | This happens only on UI changes. If containeris a behavior of feature call evaluate or rebuild to update geometry. (Inherited from EditorProperty.)
Public method | CheckRebuildSmart | (Inherited from EditorProperty.)
Public method | Clone | (Inherited from EditorProperty.)
Public method | CreateAndSetNewValue | (Inherited from EditorProperty.)
Public method | Disassociate | (Inherited from EditorProperty.)
Public method | Dispose | (Inherited from EditorProperty.)
Protected method | Dispose(Boolean) | (Inherited from EditorProperty.)
Public method | EndBatch | (Inherited from EditorProperty.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from EditorProperty.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokePropertyChanged | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedEx | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedValue_Begin | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedValue_Process | (Inherited from EditorProperty.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Note: This is Not just called on IProperty.Value change. It's called by PropertyWrapper::NotifyPropertyChanged with different names (like "Value", "Expression", etc). It's called on rVariable::SetupChanged, on variable flag changes. (Inherited from EditorProperty.)
Public method | PickValue | Execute PickAction and wait for user to click on some object. (Inherited from EditorProperty.)
Public method | PickValueProxy | (Inherited from EditorProperty.)
Public method | SetQuantity | (Inherited from EditorProperty.)
Public method | SetUnitMagnitude | (Inherited from EditorProperty.)
Public method | StartBatch | (Inherited from EditorProperty.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | property changed event (Inherited from EditorProperty.)
Top
Fields
 | Name | Description
Public field | SuppressValueChange | (Inherited from EditorProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


MatrixProperty Constructor

Initializes a new instance of the MatrixProperty class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MatrixProperty(
    IProperty property
)
public:
MatrixProperty(
    IProperty^ property
)

Parameters

property
Type: VisualComponents.Create3DIProperty
See Also

Reference

MatrixProperty Class
VisualComponents.UX.Shared Namespace


MatrixProperty Properties

The MatrixProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | (Inherited from EditorProperty.)
Public property | AllowedMinimum | (Inherited from EditorProperty.)
Public property | AllowedValues | (Inherited from EditorProperty.)
Public property | AX |
Public property | AY |
Public property | AZ |
Public property | CanCreateNewValue | (Inherited from EditorProperty.)
Public property | Category | (Inherited from EditorProperty.)
Public property | ConstraintType | (Inherited from EditorProperty.)
Public property | Container | (Inherited from EditorProperty.)
Public property | ContainerExpressionContext | (Inherited from EditorProperty.)
Public property | ContainerObject | Similar to IProperty.Container, but for any object. (Inherited from EditorProperty.)
Public property | CreationTypes | (Inherited from EditorProperty.)
Public property | Description | (Inherited from EditorProperty.)
Public property | DisabledStateToolTip | (Inherited from EditorProperty.)
Public property | DistributionExpression | (Inherited from EditorProperty.)
Public property | Error | (Inherited from EditorProperty.)
Public property | ErrorMessage | (Inherited from EditorProperty.)
Public property | HasDistribution | (Inherited from EditorProperty.)
Public property | History | (Inherited from EditorProperty.)
Public property | Index_ForComboBox | (Inherited from EditorProperty.)
Public property | IsDesignTime | (Inherited from EditorProperty.)
Public property | IsEditable | Helper property since in XAML negating binding value is not possible without using BoolToOppositeConverter (Inherited from EditorProperty.)
Public property | IsEditableInGui | (Inherited from EditorProperty.)
Public property | IsExceptionallyInHome | (Inherited from EditorProperty.)
Public property | IsInternal | (Inherited from EditorProperty.)
Public property | IsLocked | (Inherited from EditorProperty.)
Public property | IsPersistent | (Inherited from EditorProperty.)
Public property | IsQuantityValue | (Inherited from EditorProperty.)
Public property | IsReadOnly | (Inherited from EditorProperty.)
Public property | IsValid | (Inherited from EditorProperty.)
Public property | IsVisible | (Inherited from EditorProperty.)
Public property | IsVisibleDesignTime | (Inherited from EditorProperty.)
Public property | IsVisibleForced | (Inherited from EditorProperty.)
Public property | IsVisibleInGui | IsVisibleInGui is used to bind GUI visibility. Setting this value affects only _isVisibleForcedOff. (Inherited from EditorProperty.)
Public property | Item | (Inherited from EditorProperty.)
Public property | Name | (Inherited from EditorProperty.)
Public property | NonLocalizedName | (Inherited from EditorProperty.)
Public property | NX |
Public property | NY |
Public property | NZ |
Public property | Order | (Inherited from EditorProperty.)
Public property | OX |
Public property | OY |
Public property | OZ |
Public property | Property | (Inherited from EditorProperty.)
Public property | PropertyDescription | (Inherited from EditorProperty.)
Public property | PropertyType | (Inherited from EditorProperty.)
Public property | PX |
Public property | PY |
Public property | PZ |
Public property | Quantity | (Inherited from EditorProperty.)
Public property | ResourceType | In case of having an IUriProperty, this determines if the editor should allow folder selection instead of file selection (Inherited from EditorProperty.)
Public property | RotationSystem | (Inherited from EditorProperty.)
Public property | ShowValuepicker | (Inherited from EditorProperty.)
Public property | TabHeader | (Inherited from EditorProperty.)
Public property | Unit | (Inherited from EditorProperty.)
Public property | Value | (Inherited from EditorProperty.)
Public property | Value_ForComboBox | Helper property, used only by ComboBox. (Inherited from EditorProperty.)
Public property | ValueString | (Inherited from EditorProperty.)
Public property | WPRX |
Public property | WPRY |
Public property | WPRZ |
Top
See Also

Reference

MatrixProperty Class
VisualComponents.UX.Shared Namespace


MatrixProperty.AX Property

MatrixPropertyAX Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double AX { get; set; }
public:
property double AX {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixProperty Class
VisualComponents.UX.Shared Namespace


MatrixProperty.AY Property

MatrixPropertyAY Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double AY { get; set; }
public:
property double AY {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixProperty Class
VisualComponents.UX.Shared Namespace


MatrixProperty.AZ Property

MatrixPropertyAZ Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double AZ { get; set; }
public:
property double AZ {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixProperty Class
VisualComponents.UX.Shared Namespace


MatrixProperty.NX Property

MatrixPropertyNX Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double NX { get; set; }
public:
property double NX {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixProperty Class
VisualComponents.UX.Shared Namespace


MatrixProperty.NY Property

MatrixPropertyNY Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double NY { get; set; }
public:
property double NY {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixProperty Class
VisualComponents.UX.Shared Namespace


MatrixProperty.NZ Property

MatrixPropertyNZ Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double NZ { get; set; }
public:
property double NZ {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixProperty Class
VisualComponents.UX.Shared Namespace


MatrixProperty.OX Property

MatrixPropertyOX Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double OX { get; set; }
public:
property double OX {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixProperty Class
VisualComponents.UX.Shared Namespace


MatrixProperty.OY Property

MatrixPropertyOY Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double OY { get; set; }
public:
property double OY {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixProperty Class
VisualComponents.UX.Shared Namespace


MatrixProperty.OZ Property

MatrixPropertyOZ Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double OZ { get; set; }
public:
property double OZ {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixProperty Class
VisualComponents.UX.Shared Namespace


MatrixProperty.PX Property

MatrixPropertyPX Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double PX { get; set; }
public:
property double PX {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixProperty Class
VisualComponents.UX.Shared Namespace


MatrixProperty.PY Property

MatrixPropertyPY Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double PY { get; set; }
public:
property double PY {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixProperty Class
VisualComponents.UX.Shared Namespace


MatrixProperty.PZ Property

MatrixPropertyPZ Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double PZ { get; set; }
public:
property double PZ {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixProperty Class
VisualComponents.UX.Shared Namespace


MatrixProperty.WPRX Property

MatrixPropertyWPRX Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double WPRX { get; set; }
public:
property double WPRX {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixProperty Class
VisualComponents.UX.Shared Namespace


MatrixProperty.WPRY Property

MatrixPropertyWPRY Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double WPRY { get; set; }
public:
property double WPRY {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixProperty Class
VisualComponents.UX.Shared Namespace


MatrixProperty.WPRZ Property

MatrixPropertyWPRZ Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double WPRZ { get; set; }
public:
property double WPRZ {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MatrixProperty Class
VisualComponents.UX.Shared Namespace


MatrixProperty Methods

The MatrixProperty type exposes the following members.

Methods
 | Name | Description
Public method | Associate | (Inherited from EditorProperty.)
Public method | CheckEditableInGui | (Inherited from EditorProperty.)
Protected method | CheckPropertyObjDispose | (Inherited from EditorProperty.)
Public method | CheckRebuild | This happens only on UI changes. If containeris a behavior of feature call evaluate or rebuild to update geometry. (Inherited from EditorProperty.)
Public method | CheckRebuildSmart | (Inherited from EditorProperty.)
Public method | Clone | (Inherited from EditorProperty.)
Public method | CreateAndSetNewValue | (Inherited from EditorProperty.)
Public method | Disassociate | (Inherited from EditorProperty.)
Public method | Dispose | (Inherited from EditorProperty.)
Protected method | Dispose(Boolean) | (Inherited from EditorProperty.)
Public method | EndBatch | (Inherited from EditorProperty.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from EditorProperty.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokePropertyChanged | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedEx | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedValue_Begin | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedValue_Process | (Inherited from EditorProperty.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Note: This is Not just called on IProperty.Value change. It's called by PropertyWrapper::NotifyPropertyChanged with different names (like "Value", "Expression", etc). It's called on rVariable::SetupChanged, on variable flag changes. (Inherited from EditorProperty.)
Public method | PickValue | Execute PickAction and wait for user to click on some object. (Inherited from EditorProperty.)
Public method | PickValueProxy | (Inherited from EditorProperty.)
Public method | SetQuantity | (Inherited from EditorProperty.)
Public method | SetUnitMagnitude | (Inherited from EditorProperty.)
Public method | StartBatch | (Inherited from EditorProperty.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MatrixProperty Class
VisualComponents.UX.Shared Namespace


MatrixProperty Events

The MatrixProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | property changed event (Inherited from EditorProperty.)
Top
See Also

Reference

MatrixProperty Class
VisualComponents.UX.Shared Namespace


MatrixProperty Fields

The MatrixProperty type exposes the following members.

Fields
 | Name | Description
Public field | SuppressValueChange | (Inherited from EditorProperty.)
Top
See Also

Reference

MatrixProperty Class
VisualComponents.UX.Shared Namespace


MeasureAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedMeasureAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class MeasureAction : ICommandPanelAction,
    IHandle<SnapResultMessage>, IHandle, IHandle<RequestActionAbortMessage>
public ref class MeasureAction sealed : ICommandPanelAction,
    IHandle<SnapResultMessage^>, IHandle, IHandle<RequestActionAbortMessage^>

The MeasureAction type exposes the following members.

Constructors
 | Name | Description
Public method | MeasureAction | default constructor of MeasureAction
Top
Properties
 | Name | Description
Public property | ActionFinished |
 | ActionMode |
Public property | ActionProperties |
 | AngleUnit |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
 | CoordinateSystem |
Public property | Description |
 | DistanceUnit |
Public property | ErrorMessage |
Public property | MeasureSpace |
Public property | MeasureTexts |
Public property | PickResultExtras |
Public property | PickResultFreePoint |
Public property | PickResultPositions |
Public property | PickResults |
 | ShowXYZLabels |
Public property | Title |
Top
Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
 | CombineStrings |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
 | GetClosestToPoint |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle(RequestActionAbortMessage) |
Public method | Handle(SnapResultMessage) |
 | RefreshAction |
Public method | StartAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | _completed |
 | IsExecutingChanged |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


MeasureAction Constructor

default constructor of MeasureAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MeasureAction()
public:
MeasureAction()
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction Properties

The MeasureAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
 | ActionMode |
Public property | ActionProperties |
 | AngleUnit |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
 | CoordinateSystem |
Public property | Description |
 | DistanceUnit |
Public property | ErrorMessage |
Public property | MeasureSpace |
Public property | MeasureTexts |
Public property | PickResultExtras |
Public property | PickResultFreePoint |
Public property | PickResultPositions |
Public property | PickResults |
 | ShowXYZLabels |
Public property | Title |
Top
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.ActionFinished Property

MeasureActionActionFinished Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ActionFinished { get; }
public:
virtual property bool ActionFinished {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ICommandPanelActionActionFinished
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.ActionMode Property

MeasureActionActionMode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MeasureMode ActionMode { get; set; }
public:
static property MeasureMode ActionMode {
    MeasureMode get ();
    void set (MeasureMode value);
}

Property Value

Type: MeasureMode
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.ActionProperties Property

MeasureActionActionProperties Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<IProperty> ActionProperties { get; }
public:
virtual property List<IProperty^>^ ActionProperties {
    List<IProperty^>^ get () sealed;
}

Property Value

Type: ListIProperty

Implements

ICommandPanelActionActionProperties
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.AngleUnit Property

MeasureActionAngleUnit Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string AngleUnit { get; set; }
public:
static property String^ AngleUnit {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.ApplyButtonText Property

MeasureActionApplyButtonText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ApplyButtonText { get; }
public:
virtual property String^ ApplyButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionApplyButtonText
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.AssociatedModelId Property

MeasureActionAssociatedModelId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedModelId { get; }
public:
virtual property String^ AssociatedModelId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedModelId
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.AssociatedSiteId Property

MeasureActionAssociatedSiteId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedSiteId { get; }
public:
virtual property String^ AssociatedSiteId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedSiteId
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.CallingCommandName Property

MeasureActionCallingCommandName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CallingCommandName { get; }
public:
virtual property String^ CallingCommandName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCallingCommandName
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.CancelButtonText Property

MeasureActionCancelButtonText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CancelButtonText { get; }
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCancelButtonText
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.CoordinateSystem Property

MeasureActionCoordinateSystem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int CoordinateSystem { set; }
public:
static property int CoordinateSystem {
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.Description Property

MeasureActionDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; }
public:
virtual property String^ Description {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionDescription
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.DistanceUnit Property

MeasureActionDistanceUnit Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string DistanceUnit { get; set; }
public:
static property String^ DistanceUnit {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.ErrorMessage Property

MeasureActionErrorMessage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ErrorMessage { get; set; }
public:
virtual property String^ ErrorMessage {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionErrorMessage
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.MeasureSpace Property

MeasureActionMeasureSpace Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Matrix MeasureSpace { get; set; }
public:
property Matrix MeasureSpace {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.MeasureTexts Property

MeasureActionMeasureTexts Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string[] MeasureTexts { get; set; }
public:
property array<String^>^ MeasureTexts {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: String
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.PickResultExtras Property

MeasureActionPickResultExtras Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3[] PickResultExtras { get; set; }
public:
property array<Vector3>^ PickResultExtras {
    array<Vector3>^ get ();
    void set (array<Vector3>^ value);
}

Property Value

Type: Vector3
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.PickResultFreePoint Property

MeasureActionPickResultFreePoint Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool[] PickResultFreePoint { get; set; }
public:
property array<bool>^ PickResultFreePoint {
    array<bool>^ get ();
    void set (array<bool>^ value);
}

Property Value

Type: Boolean
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.PickResultPositions Property

MeasureActionPickResultPositions Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3[] PickResultPositions { get; set; }
public:
property array<Vector3>^ PickResultPositions {
    array<Vector3>^ get ();
    void set (array<Vector3>^ value);
}

Property Value

Type: Vector3
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.PickResults Property

MeasureActionPickResults Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SnapResult[] PickResults { get; set; }
public:
property array<SnapResult>^ PickResults {
    array<SnapResult>^ get ();
    void set (array<SnapResult>^ value);
}

Property Value

Type: SnapResult
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.ShowXYZLabels Property

MeasureActionShowXYZLabels Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool ShowXYZLabels { get; set; }
public:
static property bool ShowXYZLabels {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.Title Property

MeasureActionTitle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; }
public:
virtual property String^ Title {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionTitle
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction Methods

The MeasureAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
 | CombineStrings |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
 | GetClosestToPoint |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle(RequestActionAbortMessage) |
Public method | Handle(SnapResultMessage) |
 | RefreshAction |
Public method | StartAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.ApplyAction Method

MeasureActionApplyAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ApplyAction()
public:
virtual bool ApplyAction() sealed

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MeasureAction.ApplyAction"]

Implements

ICommandPanelActionApplyAction
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.CancelAction Method

MeasureActionCancelAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CancelAction()
public:
virtual void CancelAction() sealed

Implements

ICommandPanelActionCancelAction
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.CombineStrings Method

MeasureActionCombineStrings Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string CombineStrings(
    string delim,
    params string[] strings
)
public:
static String^ CombineStrings(
    String^ delim,
    ... array<String^>^ strings
)

Parameters

delim
Type: SystemString
strings
Type: SystemString

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MeasureAction.CombineStrings(System.String,System.String[])"]

See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.Execute Method

MeasureActionExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<IResult> Execute(
    bool removeDimension
)
public:
IEnumerable<IResult^>^ Execute(
    bool removeDimension
)

Parameters

removeDimension
Type: SystemBoolean

Return Value

Type: IEnumerableIResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MeasureAction.Execute(System.Boolean)"]

See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.GetClosestToPoint Method

MeasureActionGetClosestToPoint Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Vector3 GetClosestToPoint(
    ref Vector3 a1,
    ref Vector3 a2,
    ref Vector3 b
)
public:
static Vector3 GetClosestToPoint(
    Vector3% a1,
    Vector3% a2,
    Vector3% b
)

Parameters

a1
Type: VisualComponents.Create3DVector3
a2
Type: VisualComponents.Create3DVector3
b
Type: VisualComponents.Create3DVector3

Return Value

Type: Vector3

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MeasureAction.GetClosestToPoint(VisualComponents.Create3D.Vector3@,VisualComponents.Create3D.Vector3@,VisualComponents.Create3D.Vector3@)"]

See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.Handle Method

MeasureActionHandle Method

Overload List
 | Name | Description
Public method | Handle(RequestActionAbortMessage) |
Public method | Handle(SnapResultMessage) |
Top
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.Handle Method (RequestActionAbortMessage)

MeasureActionHandle Method (RequestActionAbortMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    RequestActionAbortMessage message
)
public:
virtual void Handle(
    RequestActionAbortMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedRequestActionAbortMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

MeasureAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


MeasureAction.Handle Method (SnapResultMessage)

MeasureActionHandle Method (SnapResultMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    SnapResultMessage message
)
public:
virtual void Handle(
    SnapResultMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedSnapResultMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

MeasureAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


MeasureAction.RefreshAction Method

MeasureActionRefreshAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void RefreshAction()
public:
static void RefreshAction()
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.StartAction Method

MeasureActionStartAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    EventHandler<ResultCompletionEventArgs> completed
)
public:
virtual void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed
) sealed

Parameters

completed
Type: SystemEventHandlerResultCompletionEventArgs

Implements

ICommandPanelActionStartAction(EventHandlerResultCompletionEventArgs)
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction Events

The MeasureAction type exposes the following members.

Events
 | Name | Description
Public event | _completed |
 | IsExecutingChanged |
Top
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction._completed Event

MeasureAction_completed Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ResultCompletionEventArgs> _completed
public:
 event EventHandler<ResultCompletionEventArgs^>^ _completed {
    void add (EventHandler<ResultCompletionEventArgs^>^ value);
    void remove (EventHandler<ResultCompletionEventArgs^>^ value);
}

Value

Type: SystemEventHandlerResultCompletionEventArgs
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureAction.IsExecutingChanged Event

MeasureActionIsExecutingChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static event PropertyChangedEventHandler IsExecutingChanged
public:
static  event PropertyChangedEventHandler^ IsExecutingChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler
See Also

Reference

MeasureAction Class
VisualComponents.UX.Shared Namespace


MeasureMode Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum MeasureMode
public enum class MeasureMode
Members
Member name | Value | Description
Distance | 0 |
Angle | 1 |
DistanceAndAngle | 2 |
See Also

Reference

VisualComponents.UX.Shared Namespace


MeasureResultMessage Class

Message used to activate additional focus visualization. Used to: - hilight two snapping results when measuring (in MeasureAction) - show snapping result when doing aim snapping (in CombinedManipulator) - show snapping result and arrow when doing ctrl+dragging on arrow manipulator (in TranslateManipulatorPart)
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedMeasureResultMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class MeasureResultMessage
public ref class MeasureResultMessage

The MeasureResultMessage type exposes the following members.

Constructors
 | Name | Description
Public method | MeasureResultMessage | Initializes a new instance of the MeasureResultMessage class
Top
Properties
 | Name | Description
Public property | FirstPick |
Public property | MeasurePositions | Used only with IsMeasureLines in FocusManipulatorPart.
Public property | MeasureSpace |
Public property | MeasureTexts |
Public property | SecondIsSecondary |
Public property | SecondPick |
Public property | SourceObjectColor |
Public property | SourceObjectPadding | Source object arrow's end-padding in screen coordinates.
Public property | SourceObjectPosition | Can be used to illustrate the source object that is being snapped. Todo: find a better place for, as this is used only for robot TCP snapping.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


MeasureResultMessage Constructor

Initializes a new instance of the MeasureResultMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MeasureResultMessage()
public:
MeasureResultMessage()
See Also

Reference

MeasureResultMessage Class
VisualComponents.UX.Shared Namespace


MeasureResultMessage Properties

The MeasureResultMessage type exposes the following members.

Properties
 | Name | Description
Public property | FirstPick |
Public property | MeasurePositions | Used only with IsMeasureLines in FocusManipulatorPart.
Public property | MeasureSpace |
Public property | MeasureTexts |
Public property | SecondIsSecondary |
Public property | SecondPick |
Public property | SourceObjectColor |
Public property | SourceObjectPadding | Source object arrow's end-padding in screen coordinates.
Public property | SourceObjectPosition | Can be used to illustrate the source object that is being snapped. Todo: find a better place for, as this is used only for robot TCP snapping.
Top
See Also

Reference

MeasureResultMessage Class
VisualComponents.UX.Shared Namespace


MeasureResultMessage.FirstPick Property

MeasureResultMessageFirstPick Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<SnapResult> FirstPick { get; set; }
public:
property Nullable<SnapResult> FirstPick {
    Nullable<SnapResult> get ();
    void set (Nullable<SnapResult> value);
}

Property Value

Type: NullableSnapResult
See Also

Reference

MeasureResultMessage Class
VisualComponents.UX.Shared Namespace


MeasureResultMessage.MeasurePositions Property

MeasureResultMessageMeasurePositions Property

Used only with IsMeasureLines in FocusManipulatorPart.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3[] MeasurePositions { get; set; }
public:
property array<Vector3>^ MeasurePositions {
    array<Vector3>^ get ();
    void set (array<Vector3>^ value);
}

Property Value

Type: Vector3
See Also

Reference

MeasureResultMessage Class
VisualComponents.UX.Shared Namespace


MeasureResultMessage.MeasureSpace Property

MeasureResultMessageMeasureSpace Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<Matrix> MeasureSpace { get; set; }
public:
property Nullable<Matrix> MeasureSpace {
    Nullable<Matrix> get ();
    void set (Nullable<Matrix> value);
}

Property Value

Type: NullableMatrix
See Also

Reference

MeasureResultMessage Class
VisualComponents.UX.Shared Namespace


MeasureResultMessage.MeasureTexts Property

MeasureResultMessageMeasureTexts Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string[] MeasureTexts { get; set; }
public:
property array<String^>^ MeasureTexts {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: String
See Also

Reference

MeasureResultMessage Class
VisualComponents.UX.Shared Namespace


MeasureResultMessage.SecondIsSecondary Property

MeasureResultMessageSecondIsSecondary Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool SecondIsSecondary { get; set; }
public:
property bool SecondIsSecondary {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MeasureResultMessage Class
VisualComponents.UX.Shared Namespace


MeasureResultMessage.SecondPick Property

MeasureResultMessageSecondPick Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<SnapResult> SecondPick { get; set; }
public:
property Nullable<SnapResult> SecondPick {
    Nullable<SnapResult> get ();
    void set (Nullable<SnapResult> value);
}

Property Value

Type: NullableSnapResult
See Also

Reference

MeasureResultMessage Class
VisualComponents.UX.Shared Namespace


MeasureResultMessage.SourceObjectColor Property

MeasureResultMessageSourceObjectColor Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Color SourceObjectColor { get; set; }
public:
property Color SourceObjectColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

MeasureResultMessage Class
VisualComponents.UX.Shared Namespace


MeasureResultMessage.SourceObjectPadding Property

MeasureResultMessageSourceObjectPadding Property

Source object arrow's end-padding in screen coordinates.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int SourceObjectPadding { get; set; }
public:
property int SourceObjectPadding {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

MeasureResultMessage Class
VisualComponents.UX.Shared Namespace


MeasureResultMessage.SourceObjectPosition Property

MeasureResultMessageSourceObjectPosition Property

Can be used to illustrate the source object that is being snapped. Todo: find a better place for, as this is used only for robot TCP snapping.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<Vector3> SourceObjectPosition { get; set; }
public:
property Nullable<Vector3> SourceObjectPosition {
    Nullable<Vector3> get ();
    void set (Nullable<Vector3> value);
}

Property Value

Type: NullableVector3
See Also

Reference

MeasureResultMessage Class
VisualComponents.UX.Shared Namespace


MeasureResultMessage Methods

The MeasureResultMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MeasureResultMessage Class
VisualComponents.UX.Shared Namespace


MenuActionItem Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.SharedMenuActionItem

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class MenuActionItem : PropertyChangedBase,
    IActionItem, INotifyPropertyChangedEx, INotifyPropertyChanged
public ref class MenuActionItem : public PropertyChangedBase,
    IActionItem, INotifyPropertyChangedEx, INotifyPropertyChanged

The MenuActionItem type exposes the following members.

Constructors
 | Name | Description
Public method | MenuActionItem | default constructor
Top
Properties
 | Name | Description
Public property | ActionItem |
Public property | AttachTo |
Public property | CanExecute |
Public property | Content |
Public property | ContextFilter |
Public property | ControlType |
Public property | IconName |
Public property | Id |
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | RibbonId |
Public property | RibbonOrder |
Public property | RibbonPath |
Public property | SiteFilter |
Public property | SiteOrder |
Public property | SubItems |
Public property | Tag |
Public property | Visibility |
Top
Methods
 | Name | Description
Public method | BeforeExecute |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute |
Public method | Execute |
Public method | Execute(PropertyCollection) |
Public method | Execute(SetupPythonActionMessage) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetMenuItems |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableInCurrentContextAndSite |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem |
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
Fields
 | Name | Description
Public field | _content |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


MenuActionItem Constructor

default constructor

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MenuActionItem()
public:
MenuActionItem()
See Also

Reference

MenuActionItem Class
VisualComponents.UX.Shared Namespace


MenuActionItem Properties

The MenuActionItem type exposes the following members.

Properties
 | Name | Description
Public property | ActionItem |
Public property | AttachTo |
Public property | CanExecute |
Public property | Content |
Public property | ContextFilter |
Public property | ControlType |
Public property | IconName |
Public property | Id |
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | RibbonId |
Public property | RibbonOrder |
Public property | RibbonPath |
Public property | SiteFilter |
Public property | SiteOrder |
Public property | SubItems |
Public property | Tag |
Public property | Visibility |
Top
See Also

Reference

MenuActionItem Class
VisualComponents.UX.Shared Namespace


MenuActionItem.ActionItem Property

MenuActionItemActionItem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IActionItem ActionItem { get; set; }
public:
property IActionItem^ ActionItem {
    IActionItem^ get ();
    void set (IActionItem^ value);
}

Property Value

Type: IActionItem
See Also

Reference

MenuActionItem Class
VisualComponents.UX.Shared Namespace


MenuActionItem.AttachTo Property

MenuActionItemAttachTo Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AttachTo { get; set; }
public:
property String^ AttachTo {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MenuActionItem Class
VisualComponents.UX.Shared Namespace


MenuActionItem.CanExecute Property

MenuActionItemCanExecute Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanExecute { get; }
public:
virtual property bool CanExecute {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IActionItemCanExecute
See Also

Reference

MenuActionItem Class
VisualComponents.UX.Shared Namespace


MenuActionItem.Content Property

MenuActionItemContent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Content { get; set; }
public:
virtual property String^ Content {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IActionItemContent
See Also

Reference

MenuActionItem Class
VisualComponents.UX.Shared Namespace


MenuActionItem.ContextFilter Property

MenuActionItemContextFilter Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ContextFilter { get; set; }
public:
virtual property String^ ContextFilter {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IActionItemContextFilter
See Also

Reference

MenuActionItem Class
VisualComponents.UX.Shared Namespace


MenuActionItem.ControlType Property

MenuActionItemControlType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ControlType { get; set; }
public:
virtual property String^ ControlType {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IActionItemControlType
See Also

Reference

MenuActionItem Class
VisualComponents.UX.Shared Namespace


MenuActionItem.IconName Property

MenuActionItemIconName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string IconName { get; }
public:
virtual property String^ IconName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IActionItemIconName
See Also

Reference

MenuActionItem Class
VisualComponents.UX.Shared Namespace


MenuActionItem.Id Property

MenuActionItemId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Id { get; set; }
public:
virtual property String^ Id {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IActionItemId
See Also

Reference

MenuActionItem Class
VisualComponents.UX.Shared Namespace


MenuActionItem.RibbonId Property

MenuActionItemRibbonId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string RibbonId { get; set; }
public:
virtual property String^ RibbonId {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IActionItemRibbonId
See Also

Reference

MenuActionItem Class
VisualComponents.UX.Shared Namespace


MenuActionItem.RibbonOrder Property

MenuActionItemRibbonOrder Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double RibbonOrder { get; set; }
public:
property double RibbonOrder {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MenuActionItem Class
VisualComponents.UX.Shared Namespace


MenuActionItem.RibbonPath Property

MenuActionItemRibbonPath Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string RibbonPath { get; set; }
public:
property String^ RibbonPath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MenuActionItem Class
VisualComponents.UX.Shared Namespace


MenuActionItem.SiteFilter Property

MenuActionItemSiteFilter Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SiteFilter { get; set; }
public:
property String^ SiteFilter {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MenuActionItem Class
VisualComponents.UX.Shared Namespace


MenuActionItem.SiteOrder Property

MenuActionItemSiteOrder Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double SiteOrder { get; set; }
public:
virtual property double SiteOrder {
    double get () sealed;
    void set (double value) sealed;
}

Property Value

Type: Double

Implements

IActionItemSiteOrder
See Also

Reference

MenuActionItem Class
VisualComponents.UX.Shared Namespace


MenuActionItem.SubItems Property

MenuActionItemSubItems Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObservableCollection<MenuActionItem> SubItems { get; set; }
public:
property ObservableCollection<MenuActionItem^>^ SubItems {
    ObservableCollection<MenuActionItem^>^ get ();
    void set (ObservableCollection<MenuActionItem^>^ value);
}

Property Value

Type: ObservableCollectionMenuActionItem
See Also

Reference

MenuActionItem Class
VisualComponents.UX.Shared Namespace


MenuActionItem.Tag Property

MenuActionItemTag Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual Object Tag { get; set; }
public:
virtual property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object

Implements

IActionItemTag
See Also

Reference

MenuActionItem Class
VisualComponents.UX.Shared Namespace


MenuActionItem.Visibility Property

MenuActionItemVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Visibility Visibility { get; set; }
public:
virtual property Visibility Visibility {
    Visibility get () sealed;
    void set (Visibility value) sealed;
}

Property Value

Type: Visibility

Implements

IActionItemVisibility
See Also

Reference

MenuActionItem Class
VisualComponents.UX.Shared Namespace


MenuActionItem Methods

The MenuActionItem type exposes the following members.

Methods
 | Name | Description
Public method | BeforeExecute |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute |
Public method | Execute |
Public method | Execute(PropertyCollection) |
Public method | Execute(SetupPythonActionMessage) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetMenuItems |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableInCurrentContextAndSite |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem |
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MenuActionItem Class
VisualComponents.UX.Shared Namespace


MenuActionItem.BeforeExecute Method

MenuActionItemBeforeExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void BeforeExecute()
public:
void BeforeExecute()
See Also

Reference

MenuActionItem Class
VisualComponents.UX.Shared Namespace


MenuActionItem.EvaluateCanExecute Method

MenuActionItemEvaluateCanExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void EvaluateCanExecute()
public:
virtual void EvaluateCanExecute() sealed

Implements

IActionItemEvaluateCanExecute
See Also

Reference

MenuActionItem Class
VisualComponents.UX.Shared Namespace


MenuActionItem.Execute Method

MenuActionItemExecute Method

Overload List
 | Name | Description
Public method | Execute |
Public method | Execute(PropertyCollection) |
Public method | Execute(SetupPythonActionMessage) |
Top
See Also

Reference

MenuActionItem Class
VisualComponents.UX.Shared Namespace


MenuActionItem.Execute Method

MenuActionItemExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute()
public:
virtual void Execute() sealed

Implements

IActionItemExecute
See Also

Reference

MenuActionItem Class
Execute Overload
VisualComponents.UX.Shared Namespace


MenuActionItem.Execute Method (PropertyCollection)

MenuActionItemExecute Method (PropertyCollection)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    PropertyCollection args
)
public:
virtual void Execute(
    PropertyCollection^ args
) sealed

Parameters

args
Type: VisualComponents.Create3DPropertyCollection

Implements

IActionItemExecute(PropertyCollection)
See Also

Reference

MenuActionItem Class
Execute Overload
VisualComponents.UX.Shared Namespace


MenuActionItem.Execute Method (SetupPythonActionMessage)

MenuActionItemExecute Method (SetupPythonActionMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    SetupPythonActionMessage message
)
public:
virtual void Execute(
    SetupPythonActionMessage^ message
) sealed

Parameters

message
Type: VisualComponents.Create3DSetupPythonActionMessage

Implements

IActionItemExecute(SetupPythonActionMessage)
See Also

Reference

MenuActionItem Class
Execute Overload
VisualComponents.UX.Shared Namespace


MenuActionItem.GetMenuItems Method

MenuActionItemGetMenuItems Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ObservableCollection<MenuActionItem> GetMenuItems(
    IUXConfiguration uxConfig,
    string siteId,
    IReadOnlyCollection<IActionItem> allActions,
    IList<UXSiteEntryConfigElement> menuItemEntries,
    bool subLevel,
    Object siteObj
)
public:
static ObservableCollection<MenuActionItem^>^ GetMenuItems(
    IUXConfiguration^ uxConfig,
    String^ siteId,
    IReadOnlyCollection<IActionItem^>^ allActions,
    IList<UXSiteEntryConfigElement^>^ menuItemEntries,
    bool subLevel,
    Object^ siteObj
)

Parameters

uxConfig
Type: VisualComponents.UX.SharedIUXConfiguration
siteId
Type: SystemString
allActions
Type: System.Collections.GenericIReadOnlyCollectionIActionItem
menuItemEntries
Type: System.Collections.GenericIListUXSiteEntryConfigElement
subLevel
Type: SystemBoolean
siteObj
Type: SystemObject

Return Value

Type: ObservableCollectionMenuActionItem

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MenuActionItem.GetMenuItems(VisualComponents.UX.Shared.IUXConfiguration,System.String,System.Collections.Generic.IReadOnlyCollection{VisualComponents.UX.Shared.IActionItem},System.Collections.Generic.IList{VisualComponents.UX.Shared.UXSiteEntryConfigElement},System.Boolean,System.Object)"]

See Also

Reference

MenuActionItem Class
VisualComponents.UX.Shared Namespace


MenuActionItem.IsAvailableInCurrentContextAndSite Method

MenuActionItemIsAvailableInCurrentContextAndSite Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsAvailableInCurrentContextAndSite(
    string siteId
)
public:
virtual bool IsAvailableInCurrentContextAndSite(
    String^ siteId
) sealed

Parameters

siteId
Type: SystemString

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MenuActionItem.IsAvailableInCurrentContextAndSite(System.String)"]

Implements

IActionItemIsAvailableInCurrentContextAndSite(String)
See Also

Reference

MenuActionItem Class
VisualComponents.UX.Shared Namespace


MenuActionItem.NotifyAnotherActionItem Method

MenuActionItemNotifyAnotherActionItem Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void NotifyAnotherActionItem(
    string actionName
)
public:
virtual void NotifyAnotherActionItem(
    String^ actionName
) sealed

Parameters

actionName
Type: SystemString

Implements

IActionItemNotifyAnotherActionItem(String)
See Also

Reference

MenuActionItem Class
VisualComponents.UX.Shared Namespace


MenuActionItem Events

The MenuActionItem type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
See Also

Reference

MenuActionItem Class
VisualComponents.UX.Shared Namespace


MenuActionItem Fields

The MenuActionItem type exposes the following members.

Fields
 | Name | Description
Public field | _content |
Top
See Also

Reference

MenuActionItem Class
VisualComponents.UX.Shared Namespace


MenuActionItem._content Field

MenuActionItem_content Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string _content
public:
String^ _content

Field Value

Type: String
See Also

Reference

MenuActionItem Class
VisualComponents.UX.Shared Namespace


MenuItemBase Class

Base class for items presented in a menutoolcommand.
Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.SharedMenuItemBase

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class MenuItemBase : PropertyChangedBase,
    IMenuToolCommand, IRibbonToolCommand
public ref class MenuItemBase : public PropertyChangedBase,
    IMenuToolCommand, IRibbonToolCommand

The MenuItemBase type exposes the following members.

Constructors
 | Name | Description
Public method | MenuItemBase(IDockableScreen, String, BaseActionItem) | Initializes a new instance of the MenuItemBase class
Public method | MenuItemBase(String, String, String, BaseActionItem) | Initializes a new instance of the MenuItemBase class
Public method | MenuItemBase(IDockableScreen, String, BaseActionItem, Boolean, Boolean) | Initializes a new instance of the MenuItemBase class
Public method | MenuItemBase(String, String, String, BaseActionItem, Boolean, Boolean) | Initializes a new instance of the MenuItemBase class
Top
Properties
 | Name | Description
Public property | AttachTo | The method that will be called from the event trigger.
Public property | Content |
Public property | Execute | Action executed on menu item interaction (usually a click).
Public property | Foreground |
Public property | GetToggleState | Returns toggle state.
Public property | IconPath |
Public property | Id |
Public property | IsBackgroundVisible |
Public property | IsChecked |
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsSeparator | True if this menuitem should be a separator. If content is set it will use it as a separator text surrounded by broken lines. Else broken line is used as separator.
Public property | IsToggleButton | True if this menuitem should be shown as a togglebutton.
Public property | IsToggled | Toggle state.
Public property | MenuItems |
Public property | MenuToolButtonType |
Public property | Parent | Action that contains the menuitem.
Public property | SelectedMenuItem |
Public property | SetToggleState | Action executed on toggle state change.
Public property | Tag |
Public property | ToggleExecute | Action executed on menu item interaction (usually a click).
Public property | ToolSize |
Public property | ToolTipContent | Returns/sets tooltip content.
Public property | ToolTipContentImage | Returns/sets tooltip content image.
Public property | ToolTipFooter | Returns/sets the content for the footer area of the XamScreenTip. The default is null.
Public property | ToolTipFooterSeparatorVisibility | Returns/sets the Visibility of the Footer separator which divides the footer area from the main content.
Public property | ToolTipHeader | Returns/sets the content for the header area of the XamScreenTip. The default is null.
Public property | ToolTipHeaderSeparatorVisibility | Returns/sets the Visibility of the Header separator which divides the header area from the main content.
Public property | ToolTipVisibility | Returns/sets the Visibility of the Tooltip.If tooltip content is empty or null, tooltip visibility is collapsed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InvokeExecute | Invokes the execute method.
Public method | InvokeSetToggleState |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
Fields
 | Name | Description
Protected field | _getIconPathFromFile |
Protected field | _isColoredIcon |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


MenuItemBase Constructor

Overload List
 | Name | Description
Public method | MenuItemBase(IDockableScreen, String, BaseActionItem) | Initializes a new instance of the MenuItemBase class
Public method | MenuItemBase(String, String, String, BaseActionItem) | Initializes a new instance of the MenuItemBase class
Public method | MenuItemBase(IDockableScreen, String, BaseActionItem, Boolean, Boolean) | Initializes a new instance of the MenuItemBase class
Public method | MenuItemBase(String, String, String, BaseActionItem, Boolean, Boolean) | Initializes a new instance of the MenuItemBase class
Top
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase Constructor (IDockableScreen, String, BaseActionItem)

Initializes a new instance of the MenuItemBase class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MenuItemBase(
    IDockableScreen screen,
    string iconPath,
    BaseActionItem parent
)
public:
MenuItemBase(
    IDockableScreen^ screen,
    String^ iconPath,
    BaseActionItem^ parent
)

Parameters

screen
Type: VisualComponents.UX.SharedIDockableScreen
iconPath
Type: SystemString
parent
Type: VisualComponents.UX.SharedBaseActionItem
See Also

Reference

MenuItemBase Class
MenuItemBase Overload
VisualComponents.UX.Shared Namespace


MenuItemBase Constructor (String, String, String, BaseActionItem)

Initializes a new instance of the MenuItemBase class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MenuItemBase(
    string id,
    string translatedTextId,
    string iconPath,
    BaseActionItem parent
)
public:
MenuItemBase(
    String^ id,
    String^ translatedTextId,
    String^ iconPath,
    BaseActionItem^ parent
)

Parameters

id
Type: SystemString
translatedTextId
Type: SystemString
iconPath
Type: SystemString
parent
Type: VisualComponents.UX.SharedBaseActionItem
See Also

Reference

MenuItemBase Class
MenuItemBase Overload
VisualComponents.UX.Shared Namespace


MenuItemBase Constructor (IDockableScreen, String, BaseActionItem, Boolean, Boolean)

Initializes a new instance of the MenuItemBase class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MenuItemBase(
    IDockableScreen screen,
    string iconPath,
    BaseActionItem parent,
    bool getIconPathFromFile,
    bool isColoredIcon
)
public:
MenuItemBase(
    IDockableScreen^ screen,
    String^ iconPath,
    BaseActionItem^ parent,
    bool getIconPathFromFile,
    bool isColoredIcon
)

Parameters

screen
Type: VisualComponents.UX.SharedIDockableScreen
iconPath
Type: SystemString
parent
Type: VisualComponents.UX.SharedBaseActionItem
getIconPathFromFile
Type: SystemBoolean
isColoredIcon
Type: SystemBoolean
See Also

Reference

MenuItemBase Class
MenuItemBase Overload
VisualComponents.UX.Shared Namespace


MenuItemBase Constructor (String, String, String, BaseActionItem, Boolean, Boolean)

Initializes a new instance of the MenuItemBase class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MenuItemBase(
    string id,
    string translatedTextId,
    string iconPath,
    BaseActionItem parent,
    bool getIconPathFromFile = true,
    bool isColoredIcon = true
)
public:
MenuItemBase(
    String^ id,
    String^ translatedTextId,
    String^ iconPath,
    BaseActionItem^ parent,
    bool getIconPathFromFile = true,
    bool isColoredIcon = true
)

Parameters

id
Type: SystemString
translatedTextId
Type: SystemString
iconPath
Type: SystemString
parent
Type: VisualComponents.UX.SharedBaseActionItem
getIconPathFromFile (Optional)
Type: SystemBoolean
isColoredIcon (Optional)
Type: SystemBoolean
See Also

Reference

MenuItemBase Class
MenuItemBase Overload
VisualComponents.UX.Shared Namespace


MenuItemBase Properties

The MenuItemBase type exposes the following members.

Properties
 | Name | Description
Public property | AttachTo | The method that will be called from the event trigger.
Public property | Content |
Public property | Execute | Action executed on menu item interaction (usually a click).
Public property | Foreground |
Public property | GetToggleState | Returns toggle state.
Public property | IconPath |
Public property | Id |
Public property | IsBackgroundVisible |
Public property | IsChecked |
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsSeparator | True if this menuitem should be a separator. If content is set it will use it as a separator text surrounded by broken lines. Else broken line is used as separator.
Public property | IsToggleButton | True if this menuitem should be shown as a togglebutton.
Public property | IsToggled | Toggle state.
Public property | MenuItems |
Public property | MenuToolButtonType |
Public property | Parent | Action that contains the menuitem.
Public property | SelectedMenuItem |
Public property | SetToggleState | Action executed on toggle state change.
Public property | Tag |
Public property | ToggleExecute | Action executed on menu item interaction (usually a click).
Public property | ToolSize |
Public property | ToolTipContent | Returns/sets tooltip content.
Public property | ToolTipContentImage | Returns/sets tooltip content image.
Public property | ToolTipFooter | Returns/sets the content for the footer area of the XamScreenTip. The default is null.
Public property | ToolTipFooterSeparatorVisibility | Returns/sets the Visibility of the Footer separator which divides the footer area from the main content.
Public property | ToolTipHeader | Returns/sets the content for the header area of the XamScreenTip. The default is null.
Public property | ToolTipHeaderSeparatorVisibility | Returns/sets the Visibility of the Header separator which divides the header area from the main content.
Public property | ToolTipVisibility | Returns/sets the Visibility of the Tooltip.If tooltip content is empty or null, tooltip visibility is collapsed.
Top
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.AttachTo Property

MenuItemBaseAttachTo Property

The method that will be called from the event trigger.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AttachTo { get; set; }
public:
property String^ AttachTo {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.Content Property

MenuItemBaseContent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Content { get; set; }
public:
property String^ Content {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.Execute Property

MenuItemBaseExecute Property

Action executed on menu item interaction (usually a click).

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Action Execute { get; set; }
public:
property Action^ Execute {
    Action^ get ();
    void set (Action^ value);
}

Property Value

Type: Action
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.Foreground Property

MenuItemBaseForeground Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Brush Foreground { get; set; }
public:
property Brush^ Foreground {
    Brush^ get ();
    void set (Brush^ value);
}

Property Value

Type: Brush
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.GetToggleState Property

MenuItemBaseGetToggleState Property

Returns toggle state.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Func<bool> GetToggleState { get; set; }
public:
property Func<bool>^ GetToggleState {
    Func<bool>^ get ();
    void set (Func<bool>^ value);
}

Property Value

Type: FuncBoolean
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.IconPath Property

MenuItemBaseIconPath Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string IconPath { get; set; }
public:
property String^ IconPath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.Id Property

MenuItemBaseId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Id { get; set; }
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.IsBackgroundVisible Property

MenuItemBaseIsBackgroundVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsBackgroundVisible { get; }
public:
virtual property bool IsBackgroundVisible {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IMenuToolCommandIsBackgroundVisible
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.IsChecked Property

MenuItemBaseIsChecked Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsChecked { get; set; }
public:
virtual property bool IsChecked {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IMenuToolCommandIsChecked
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.IsSeparator Property

MenuItemBaseIsSeparator Property

True if this menuitem should be a separator. If content is set it will use it as a separator text surrounded by broken lines. Else broken line is used as separator.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsSeparator { get; set; }
public:
property bool IsSeparator {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.IsToggleButton Property

MenuItemBaseIsToggleButton Property

True if this menuitem should be shown as a togglebutton.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsToggleButton { get; set; }
public:
property bool IsToggleButton {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.IsToggled Property

MenuItemBaseIsToggled Property

Toggle state.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsToggled { get; set; }
public:
property bool IsToggled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.MenuItems Property

MenuItemBaseMenuItems Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObservableCollection<MenuItemBase> MenuItems { get; protected set; }
public:
virtual property ObservableCollection<MenuItemBase^>^ MenuItems {
    ObservableCollection<MenuItemBase^>^ get () sealed;
    protected: void set (ObservableCollection<MenuItemBase^>^ value) sealed;
}

Property Value

Type: ObservableCollectionMenuItemBase

Implements

IMenuToolCommandMenuItems
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.MenuToolButtonType Property

MenuItemBaseMenuToolButtonType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ButtonType MenuToolButtonType { get; }
public:
virtual property ButtonType MenuToolButtonType {
    ButtonType get () sealed;
}

Property Value

Type: ButtonType

Implements

IMenuToolCommandMenuToolButtonType
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.Parent Property

MenuItemBaseParent Property

Action that contains the menuitem.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BaseActionItem Parent { get; set; }
public:
property BaseActionItem^ Parent {
    BaseActionItem^ get ();
    void set (BaseActionItem^ value);
}

Property Value

Type: BaseActionItem
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.SelectedMenuItem Property

MenuItemBaseSelectedMenuItem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MenuItemBase SelectedMenuItem { get; set; }
public:
virtual property MenuItemBase^ SelectedMenuItem {
    MenuItemBase^ get () sealed;
    void set (MenuItemBase^ value) sealed;
}

Property Value

Type: MenuItemBase

Implements

IMenuToolCommandSelectedMenuItem
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.SetToggleState Property

MenuItemBaseSetToggleState Property

Action executed on toggle state change.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Action<bool> SetToggleState { get; set; }
public:
property Action<bool>^ SetToggleState {
    Action<bool>^ get ();
    void set (Action<bool>^ value);
}

Property Value

Type: ActionBoolean
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.Tag Property

MenuItemBaseTag Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Tag { get; set; }
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.ToggleExecute Property

MenuItemBaseToggleExecute Property

Action executed on menu item interaction (usually a click).

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Action ToggleExecute { get; set; }
public:
property Action^ ToggleExecute {
    Action^ get ();
    void set (Action^ value);
}

Property Value

Type: Action
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.ToolSize Property

MenuItemBaseToolSize Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ToolSizingMode ToolSize { get; }
public:
virtual property ToolSizingMode ToolSize {
    ToolSizingMode get () sealed;
}

Property Value

Type: ToolSizingMode

Implements

IRibbonToolCommandToolSize
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.ToolTipContent Property

MenuItemBaseToolTipContent Property

Returns/sets tooltip content.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ToolTipContent { get; set; }
public:
property String^ ToolTipContent {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.ToolTipContentImage Property

MenuItemBaseToolTipContentImage Property

Returns/sets tooltip content image.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ToolTipContentImage { get; set; }
public:
property String^ ToolTipContentImage {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.ToolTipFooter Property

MenuItemBaseToolTipFooter Property

Returns/sets the content for the footer area of the XamScreenTip. The default is null.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ToolTipFooter { get; set; }
public:
property String^ ToolTipFooter {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.ToolTipFooterSeparatorVisibility Property

MenuItemBaseToolTipFooterSeparatorVisibility Property

Returns/sets the Visibility of the Footer separator which divides the footer area from the main content.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Visibility ToolTipFooterSeparatorVisibility { get; set; }
public:
property Visibility ToolTipFooterSeparatorVisibility {
    Visibility get ();
    void set (Visibility value);
}

Property Value

Type: Visibility
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.ToolTipHeader Property

MenuItemBaseToolTipHeader Property

Returns/sets the content for the header area of the XamScreenTip. The default is null.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ToolTipHeader { get; set; }
public:
property String^ ToolTipHeader {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.ToolTipHeaderSeparatorVisibility Property

MenuItemBaseToolTipHeaderSeparatorVisibility Property

Returns/sets the Visibility of the Header separator which divides the header area from the main content.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Visibility ToolTipHeaderSeparatorVisibility { get; set; }
public:
property Visibility ToolTipHeaderSeparatorVisibility {
    Visibility get ();
    void set (Visibility value);
}

Property Value

Type: Visibility
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.ToolTipVisibility Property

MenuItemBaseToolTipVisibility Property

Returns/sets the Visibility of the Tooltip.If tooltip content is empty or null, tooltip visibility is collapsed.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Visibility ToolTipVisibility { get; set; }
public:
property Visibility ToolTipVisibility {
    Visibility get ();
    void set (Visibility value);
}

Property Value

Type: Visibility
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase Methods

The MenuItemBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InvokeExecute | Invokes the execute method.
Public method | InvokeSetToggleState |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.InvokeExecute Method

MenuItemBaseInvokeExecute Method

Invokes the execute method.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InvokeExecute()
public:
void InvokeExecute()
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase.InvokeSetToggleState Method

MenuItemBaseInvokeSetToggleState Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InvokeSetToggleState(
    bool value
)
public:
void InvokeSetToggleState(
    bool value
)

Parameters

value
Type: SystemBoolean
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase Events

The MenuItemBase type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase Fields

The MenuItemBase type exposes the following members.

Fields
 | Name | Description
Protected field | _getIconPathFromFile |
Protected field | _isColoredIcon |
Top
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase._getIconPathFromFile Field

MenuItemBase_getIconPathFromFile Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected bool _getIconPathFromFile
protected:
bool _getIconPathFromFile

Field Value

Type: Boolean
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuItemBase._isColoredIcon Field

MenuItemBase_isColoredIcon Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected bool _isColoredIcon
protected:
bool _isColoredIcon

Field Value

Type: Boolean
See Also

Reference

MenuItemBase Class
VisualComponents.UX.Shared Namespace


MenuToolButtonTypeConverter Class

A converter from enum ToolSizingMode to Infragistics ToolSizingMode
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedMenuToolButtonTypeConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class MenuToolButtonTypeConverter : IValueConverter
public ref class MenuToolButtonTypeConverter : IValueConverter

The MenuToolButtonTypeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | MenuToolButtonTypeConverter | Initializes a new instance of the MenuToolButtonTypeConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


MenuToolButtonTypeConverter Constructor

Initializes a new instance of the MenuToolButtonTypeConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MenuToolButtonTypeConverter()
public:
MenuToolButtonTypeConverter()
See Also

Reference

MenuToolButtonTypeConverter Class
VisualComponents.UX.Shared Namespace


MenuToolButtonTypeConverter Methods

The MenuToolButtonTypeConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MenuToolButtonTypeConverter Class
VisualComponents.UX.Shared Namespace


MenuToolButtonTypeConverter.Convert Method

MenuToolButtonTypeConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MenuToolButtonTypeConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

MenuToolButtonTypeConverter Class
VisualComponents.UX.Shared Namespace


MenuToolButtonTypeConverter.ConvertBack Method

MenuToolButtonTypeConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MenuToolButtonTypeConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

MenuToolButtonTypeConverter Class
VisualComponents.UX.Shared Namespace


MenuToolEx Class

Extended MenuTool with ability to stay open when the user clicks on focusable child elements and/or any elements outside the popup.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsItemsControl
MenuToolBase
MenuTool
VisualComponents.UX.SharedMenuToolEx

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class MenuToolEx : MenuTool
public ref class MenuToolEx : public MenuTool

The MenuToolEx type exposes the following members.

Constructors
 | Name | Description
Public method | MenuToolEx | Initializes a new instance of the MenuToolEx class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | ButtonType | (Inherited from MenuTool.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanClose |
Public property | Caption | (Inherited from MenuToolBase.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | Command | (Inherited from MenuTool.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | CommandParameter | (Inherited from MenuTool.)
Public property | CommandTarget | (Inherited from MenuTool.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasCaption | (Inherited from MenuToolBase.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | HasImage | (Inherited from MenuTool.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Id | (Inherited from MenuToolBase.)
Public property | ImageResolved | (Inherited from MenuTool.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | (Inherited from MenuToolBase.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsChecked | (Inherited from MenuTool.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsOnQat | (Inherited from MenuToolBase.)
Public property | IsOpen | (Inherited from MenuToolBase.)
Public property | IsQatCommonTool | (Inherited from MenuToolBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Public property | KeyTip | (Inherited from MenuToolBase.)
Public property | KeyTipForSegmentedButton | (Inherited from MenuTool.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LargeImage | (Inherited from MenuTool.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Location | (Inherited from MenuToolBase.)
Protected property | LogicalChildren | (Inherited from MenuToolBase.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MenuItemDescriptionMinWidth | (Inherited from MenuToolBase.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | ShouldDisplayGalleryPreview | (Inherited from MenuTool.)
Public property | SizingMode | (Inherited from MenuToolBase.)
Public property | SmallImage | (Inherited from MenuTool.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | StaysOpen |
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToggleCommand |
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLargeImages | (Inherited from MenuToolBase.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | (Inherited from MenuToolBase.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Protected method | CreateMenuToolPresenter | (Inherited from MenuToolBase.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | (Inherited from MenuToolBase.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Protected method | InitializeMenuToolPresenter | (Inherited from MenuTool.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | IsItemItsOwnContainer | Determines if the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Protected method | IsItemItsOwnContainerOverride | (Inherited from MenuToolBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | (Inherited from MenuTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | (Inherited from MenuTool.)
Protected method | OnChecked | (Inherited from MenuTool.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClick | (Inherited from MenuTool.)
Protected method | OnClosed | (Inherited from MenuToolBase.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from MenuTool.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | (Inherited from MenuToolBase.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | (Inherited from MenuToolBase.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | (Inherited from MenuTool.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControl.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | (Inherited from MenuToolBase.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | (Inherited from MenuToolBase.)
Protected method | OnMouseLeave | (Inherited from MenuToolBase.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnOpened | (Inherited from MenuToolBase.)
Protected method | OnOpening | (Inherited from MenuToolBase.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | (Overrides MenuTool.OnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRaiseToolEvent | (Inherited from MenuToolBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnUnchecked | (Inherited from MenuTool.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Protected method | PrepareContainerForItemOverride | (Inherited from MenuToolBase.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | SetVisualState | (Inherited from MenuToolBase.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Toggle |
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Protected method | UpdateVisualStates | (Inherited from MenuToolBase.)
Protected method | UpdateVisualStates(Boolean) | (Inherited from MenuToolBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | Checked | (Inherited from MenuTool.)
Public event | Click | (Inherited from MenuTool.)
Public event | Cloned | (Inherited from MenuToolBase.)
Public event | CloneDiscarded | (Inherited from MenuToolBase.)
Public event | Closed | (Inherited from MenuToolBase.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | Opened | (Inherited from MenuToolBase.)
Public event | Opening | (Inherited from MenuToolBase.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unchecked | (Inherited from MenuTool.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
 | Name | Description
 | CanCloseProperty |
Public field | KeepOpen |
 | StaysOpenProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


MenuToolEx Constructor

Initializes a new instance of the MenuToolEx class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MenuToolEx()
public:
MenuToolEx()
See Also

Reference

MenuToolEx Class
VisualComponents.UX.Shared Namespace


MenuToolEx Properties

The MenuToolEx type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | ButtonType | (Inherited from MenuTool.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanClose |
Public property | Caption | (Inherited from MenuToolBase.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | Command | (Inherited from MenuTool.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | CommandParameter | (Inherited from MenuTool.)
Public property | CommandTarget | (Inherited from MenuTool.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasCaption | (Inherited from MenuToolBase.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | HasImage | (Inherited from MenuTool.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Id | (Inherited from MenuToolBase.)
Public property | ImageResolved | (Inherited from MenuTool.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | (Inherited from MenuToolBase.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsChecked | (Inherited from MenuTool.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsOnQat | (Inherited from MenuToolBase.)
Public property | IsOpen | (Inherited from MenuToolBase.)
Public property | IsQatCommonTool | (Inherited from MenuToolBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Public property | KeyTip | (Inherited from MenuToolBase.)
Public property | KeyTipForSegmentedButton | (Inherited from MenuTool.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LargeImage | (Inherited from MenuTool.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Location | (Inherited from MenuToolBase.)
Protected property | LogicalChildren | (Inherited from MenuToolBase.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MenuItemDescriptionMinWidth | (Inherited from MenuToolBase.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | ShouldDisplayGalleryPreview | (Inherited from MenuTool.)
Public property | SizingMode | (Inherited from MenuToolBase.)
Public property | SmallImage | (Inherited from MenuTool.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | StaysOpen |
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToggleCommand |
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLargeImages | (Inherited from MenuToolBase.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

MenuToolEx Class
VisualComponents.UX.Shared Namespace


MenuToolEx.CanClose Property

MenuToolExCanClose Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanClose { get; }
public:
property bool CanClose {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

MenuToolEx Class
VisualComponents.UX.Shared Namespace


MenuToolEx.StaysOpen Property

MenuToolExStaysOpen Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool StaysOpen { get; set; }
public:
property bool StaysOpen {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MenuToolEx Class
VisualComponents.UX.Shared Namespace


MenuToolEx.ToggleCommand Property

MenuToolExToggleCommand Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ICommand ToggleCommand { get; }
public:
property ICommand^ ToggleCommand {
    ICommand^ get ();
}

Property Value

Type: ICommand
See Also

Reference

MenuToolEx Class
VisualComponents.UX.Shared Namespace


MenuToolEx Methods

The MenuToolEx type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | (Inherited from MenuToolBase.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Protected method | CreateMenuToolPresenter | (Inherited from MenuToolBase.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | (Inherited from MenuToolBase.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Protected method | InitializeMenuToolPresenter | (Inherited from MenuTool.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | IsItemItsOwnContainer | Determines if the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Protected method | IsItemItsOwnContainerOverride | (Inherited from MenuToolBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | (Inherited from MenuTool.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | (Inherited from MenuTool.)
Protected method | OnChecked | (Inherited from MenuTool.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClick | (Inherited from MenuTool.)
Protected method | OnClosed | (Inherited from MenuToolBase.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from MenuTool.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | (Inherited from MenuToolBase.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | (Inherited from MenuToolBase.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | (Inherited from MenuTool.)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControl.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | (Inherited from MenuToolBase.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | (Inherited from MenuToolBase.)
Protected method | OnMouseLeave | (Inherited from MenuToolBase.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnOpened | (Inherited from MenuToolBase.)
Protected method | OnOpening | (Inherited from MenuToolBase.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | (Overrides MenuTool.OnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRaiseToolEvent | (Inherited from MenuToolBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnUnchecked | (Inherited from MenuTool.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Protected method | PrepareContainerForItemOverride | (Inherited from MenuToolBase.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | SetVisualState | (Inherited from MenuToolBase.)
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Toggle |
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Protected method | UpdateVisualStates | (Inherited from MenuToolBase.)
Protected method | UpdateVisualStates(Boolean) | (Inherited from MenuToolBase.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MenuToolEx Class
VisualComponents.UX.Shared Namespace


MenuToolEx.OnPropertyChanged Method

MenuToolExOnPropertyChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
)
protected:
virtual void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
) override

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
See Also

Reference

MenuToolEx Class
VisualComponents.UX.Shared Namespace


MenuToolEx.Toggle Method

MenuToolExToggle Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Toggle()
public:
void Toggle()
See Also

Reference

MenuToolEx Class
VisualComponents.UX.Shared Namespace


MenuToolEx Events

The MenuToolEx type exposes the following members.

Events
 | Name | Description
Public event | Checked | (Inherited from MenuTool.)
Public event | Click | (Inherited from MenuTool.)
Public event | Cloned | (Inherited from MenuToolBase.)
Public event | CloneDiscarded | (Inherited from MenuToolBase.)
Public event | Closed | (Inherited from MenuToolBase.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | Opened | (Inherited from MenuToolBase.)
Public event | Opening | (Inherited from MenuToolBase.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unchecked | (Inherited from MenuTool.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

MenuToolEx Class
VisualComponents.UX.Shared Namespace


MenuToolEx Fields

The MenuToolEx type exposes the following members.

Fields
 | Name | Description
 | CanCloseProperty |
Public field | KeepOpen |
 | StaysOpenProperty |
Top
See Also

Reference

MenuToolEx Class
VisualComponents.UX.Shared Namespace


MenuToolEx.CanCloseProperty Field

MenuToolExCanCloseProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty CanCloseProperty
public:
static initonly DependencyProperty^ CanCloseProperty

Field Value

Type: DependencyProperty
See Also

Reference

MenuToolEx Class
VisualComponents.UX.Shared Namespace


MenuToolEx.KeepOpen Field

MenuToolExKeepOpen Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool KeepOpen
public:
bool KeepOpen

Field Value

Type: Boolean
See Also

Reference

MenuToolEx Class
VisualComponents.UX.Shared Namespace


MenuToolEx.StaysOpenProperty Field

MenuToolExStaysOpenProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty StaysOpenProperty
public:
static initonly DependencyProperty^ StaysOpenProperty

Field Value

Type: DependencyProperty
See Also

Reference

MenuToolEx Class
VisualComponents.UX.Shared Namespace


MenuToolPanelEx Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsPanel
System.Windows.ControlsStackPanel
MenuToolPanel
VisualComponents.UX.SharedMenuToolPanelEx

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class MenuToolPanelEx : MenuToolPanel
public ref class MenuToolPanelEx : public MenuToolPanel

The MenuToolPanelEx type exposes the following members.

Constructors
 | Name | Description
Public method | MenuToolPanelEx | Initializes a new instance of the MenuToolPanelEx class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanHorizontallyScroll | Gets or sets a value that indicates whether a StackPanel can scroll in the horizontal dimension. (Inherited from StackPanel.)
Public property | CanVerticallyScroll | Gets or sets a value that indicates whether content can scroll in the vertical dimension. (Inherited from StackPanel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExtentHeight | Gets a value that contains the vertical size of the extent. (Inherited from StackPanel.)
Public property | ExtentWidth | Gets a value that contains the horizontal size of the extent. (Inherited from StackPanel.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Protected property | HasLogicalOrientation | Gets a value that indicates if this StackPanel has vertical or horizontal orientation. (Inherited from StackPanel.)
Public property | HasLogicalOrientationPublic | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalOffset | Gets a value that contains the horizontal offset of the scrolled content. (Inherited from StackPanel.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | Gets a value that represents the Orientation of the StackPanel. (Inherited from StackPanel.)
Public property | LogicalOrientationPublic | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation | Gets or sets a value that indicates the dimension by which child elements are stacked. (Inherited from StackPanel.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | ScrollOwner | Gets or sets a value that identifies the container that controls scrolling behavior in this StackPanel. (Inherited from StackPanel.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalOffset | Gets a value that contains the vertical offset of the scrolled content. (Inherited from StackPanel.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | ViewportHeight | Gets a value that contains the vertical size of the content's viewport. (Inherited from StackPanel.)
Public property | ViewportWidth | Gets a value that contains the horizontal size of the content's viewport. (Inherited from StackPanel.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | (Inherited from MenuToolPanel.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls content downward by one logical unit. (Inherited from StackPanel.)
Public method | LineLeft | Scrolls content by one logical unit to the left. (Inherited from StackPanel.)
Public method | LineRight | Scrolls content by one logical unit to the right. (Inherited from StackPanel.)
Public method | LineUp | Scrolls content by one logical unit upward. (Inherited from StackPanel.)
Public method | MakeVisible | Scrolls to the specified coordinates and makes that part of a Visual visible. (Inherited from StackPanel.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | (Inherited from MenuToolPanel.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseWheelDown | Scrolls content logically downward in response to a click of the mouse wheel button. (Inherited from StackPanel.)
Public method | MouseWheelLeft | Scrolls content logically to the left in response to a click of the mouse wheel button. (Inherited from StackPanel.)
Public method | MouseWheelRight | Scrolls content logically to the right in response to a click of the mouse wheel button. (Inherited from StackPanel.)
Public method | MouseWheelUp | Scrolls content logically upward in response to a click of the mouse wheel button. (Inherited from StackPanel.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | (Inherited from MenuToolPanel.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | PageDown | Scrolls content logically downward by one page. (Inherited from StackPanel.)
Public method | PageLeft | Scrolls content logically to the left by one page. (Inherited from StackPanel.)
Public method | PageRight | Scrolls content logically to the right by one page. (Inherited from StackPanel.)
Public method | PageUp | Scrolls content logically upward by one page. (Inherited from StackPanel.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetHorizontalOffset | Sets the value of the HorizontalOffset property. (Inherited from StackPanel.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | SetVerticalOffset | Sets the value of the VerticalOffset property. (Inherited from StackPanel.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


MenuToolPanelEx Constructor

Initializes a new instance of the MenuToolPanelEx class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MenuToolPanelEx()
public:
MenuToolPanelEx()
See Also

Reference

MenuToolPanelEx Class
VisualComponents.UX.Shared Namespace


MenuToolPanelEx Properties

The MenuToolPanelEx type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanHorizontallyScroll | Gets or sets a value that indicates whether a StackPanel can scroll in the horizontal dimension. (Inherited from StackPanel.)
Public property | CanVerticallyScroll | Gets or sets a value that indicates whether content can scroll in the vertical dimension. (Inherited from StackPanel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExtentHeight | Gets a value that contains the vertical size of the extent. (Inherited from StackPanel.)
Public property | ExtentWidth | Gets a value that contains the horizontal size of the extent. (Inherited from StackPanel.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Protected property | HasLogicalOrientation | Gets a value that indicates if this StackPanel has vertical or horizontal orientation. (Inherited from StackPanel.)
Public property | HasLogicalOrientationPublic | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalOffset | Gets a value that contains the horizontal offset of the scrolled content. (Inherited from StackPanel.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | Gets a value that represents the Orientation of the StackPanel. (Inherited from StackPanel.)
Public property | LogicalOrientationPublic | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation | Gets or sets a value that indicates the dimension by which child elements are stacked. (Inherited from StackPanel.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | ScrollOwner | Gets or sets a value that identifies the container that controls scrolling behavior in this StackPanel. (Inherited from StackPanel.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalOffset | Gets a value that contains the vertical offset of the scrolled content. (Inherited from StackPanel.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | ViewportHeight | Gets a value that contains the vertical size of the content's viewport. (Inherited from StackPanel.)
Public property | ViewportWidth | Gets a value that contains the horizontal size of the content's viewport. (Inherited from StackPanel.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

MenuToolPanelEx Class
VisualComponents.UX.Shared Namespace


MenuToolPanelEx Methods

The MenuToolPanelEx type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | (Inherited from MenuToolPanel.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls content downward by one logical unit. (Inherited from StackPanel.)
Public method | LineLeft | Scrolls content by one logical unit to the left. (Inherited from StackPanel.)
Public method | LineRight | Scrolls content by one logical unit to the right. (Inherited from StackPanel.)
Public method | LineUp | Scrolls content by one logical unit upward. (Inherited from StackPanel.)
Public method | MakeVisible | Scrolls to the specified coordinates and makes that part of a Visual visible. (Inherited from StackPanel.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | (Inherited from MenuToolPanel.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseWheelDown | Scrolls content logically downward in response to a click of the mouse wheel button. (Inherited from StackPanel.)
Public method | MouseWheelLeft | Scrolls content logically to the left in response to a click of the mouse wheel button. (Inherited from StackPanel.)
Public method | MouseWheelRight | Scrolls content logically to the right in response to a click of the mouse wheel button. (Inherited from StackPanel.)
Public method | MouseWheelUp | Scrolls content logically upward in response to a click of the mouse wheel button. (Inherited from StackPanel.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | (Inherited from MenuToolPanel.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | PageDown | Scrolls content logically downward by one page. (Inherited from StackPanel.)
Public method | PageLeft | Scrolls content logically to the left by one page. (Inherited from StackPanel.)
Public method | PageRight | Scrolls content logically to the right by one page. (Inherited from StackPanel.)
Public method | PageUp | Scrolls content logically upward by one page. (Inherited from StackPanel.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetHorizontalOffset | Sets the value of the HorizontalOffset property. (Inherited from StackPanel.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | SetVerticalOffset | Sets the value of the VerticalOffset property. (Inherited from StackPanel.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MenuToolPanelEx Class
VisualComponents.UX.Shared Namespace


MenuToolPanelEx Events

The MenuToolPanelEx type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

MenuToolPanelEx Class
VisualComponents.UX.Shared Namespace


MenuTools Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedMenuTools

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class MenuTools
public ref class MenuTools abstract sealed

The MenuTools type exposes the following members.

Fields
Name | Description
BigButtonTool |
BigToggleButton | Not supported currently.
ButtonMenuTool |
ButtonTool |
CheckableMenuTool |
CheckBoxTool |
ComboEditorTool |
ComboEditorToolWithIcon |
ContextualTabGroup |
CoordinateSystemTool |
CustomContentMenuTool |
EnumTypeTool |
ExToggleButton |
ExtraLargeItemMenuTool |
FullToggleButton | This style is used in measure panel, "Snap types" section.
GalleryMenuTool |
GalleryMenuToolItem |
HierarchicalItemMenuTool |
LargeItemMenuTool |
MenuTool |
NumericTextEditorTool |
RadioButtonTool |
RibbonGroup |
RibbonTab |
SearchComboEditorTool |
SeparatorControl |
TextEditorTool |
ToggleButton |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


MenuTools Fields

The MenuTools type exposes the following members.

Fields
Name | Description
BigButtonTool |
BigToggleButton | Not supported currently.
ButtonMenuTool |
ButtonTool |
CheckableMenuTool |
CheckBoxTool |
ComboEditorTool |
ComboEditorToolWithIcon |
ContextualTabGroup |
CoordinateSystemTool |
CustomContentMenuTool |
EnumTypeTool |
ExToggleButton |
ExtraLargeItemMenuTool |
FullToggleButton | This style is used in measure panel, "Snap types" section.
GalleryMenuTool |
GalleryMenuToolItem |
HierarchicalItemMenuTool |
LargeItemMenuTool |
MenuTool |
NumericTextEditorTool |
RadioButtonTool |
RibbonGroup |
RibbonTab |
SearchComboEditorTool |
SeparatorControl |
TextEditorTool |
ToggleButton |
Top
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuTools.BigButtonTool Field

MenuToolsBigButtonTool Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string BigButtonTool = "BigButtonTool"
public:
literal String^ BigButtonTool = "BigButtonTool"

Field Value

Type: String
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuTools.BigToggleButton Field

MenuToolsBigToggleButton Field

Not supported currently.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string BigToggleButton = "BigToggleButton"
public:
literal String^ BigToggleButton = "BigToggleButton"

Field Value

Type: String
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuTools.ButtonMenuTool Field

MenuToolsButtonMenuTool Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string ButtonMenuTool = "ButtonMenuTool"
public:
literal String^ ButtonMenuTool = "ButtonMenuTool"

Field Value

Type: String
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuTools.ButtonTool Field

MenuToolsButtonTool Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string ButtonTool = "ButtonTool"
public:
literal String^ ButtonTool = "ButtonTool"

Field Value

Type: String
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuTools.CheckableMenuTool Field

MenuToolsCheckableMenuTool Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string CheckableMenuTool = "CheckableMenuTool"
public:
literal String^ CheckableMenuTool = "CheckableMenuTool"

Field Value

Type: String
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuTools.CheckBoxTool Field

MenuToolsCheckBoxTool Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string CheckBoxTool = "CheckBoxTool"
public:
literal String^ CheckBoxTool = "CheckBoxTool"

Field Value

Type: String
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuTools.ComboEditorTool Field

MenuToolsComboEditorTool Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string ComboEditorTool = "ComboEditorTool"
public:
literal String^ ComboEditorTool = "ComboEditorTool"

Field Value

Type: String
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuTools.ComboEditorToolWithIcon Field

MenuToolsComboEditorToolWithIcon Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string ComboEditorToolWithIcon = "ComboEditorToolWithIcon"
public:
literal String^ ComboEditorToolWithIcon = "ComboEditorToolWithIcon"

Field Value

Type: String
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuTools.ContextualTabGroup Field

MenuToolsContextualTabGroup Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string ContextualTabGroup = "ContextualTabGroup"
public:
literal String^ ContextualTabGroup = "ContextualTabGroup"

Field Value

Type: String
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuTools.CoordinateSystemTool Field

MenuToolsCoordinateSystemTool Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string CoordinateSystemTool = "CoordinateSystemTool"
public:
literal String^ CoordinateSystemTool = "CoordinateSystemTool"

Field Value

Type: String
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuTools.CustomContentMenuTool Field

MenuToolsCustomContentMenuTool Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string CustomContentMenuTool = "CustomContentMenuTool"
public:
literal String^ CustomContentMenuTool = "CustomContentMenuTool"

Field Value

Type: String
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuTools.EnumTypeTool Field

MenuToolsEnumTypeTool Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string EnumTypeTool = "EnumTypeTool"
public:
literal String^ EnumTypeTool = "EnumTypeTool"

Field Value

Type: String
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuTools.ExToggleButton Field

MenuToolsExToggleButton Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string ExToggleButton = "ExToggleButton"
public:
literal String^ ExToggleButton = "ExToggleButton"

Field Value

Type: String
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuTools.ExtraLargeItemMenuTool Field

MenuToolsExtraLargeItemMenuTool Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string ExtraLargeItemMenuTool = "ExtraLargeItemMenuTool"
public:
literal String^ ExtraLargeItemMenuTool = "ExtraLargeItemMenuTool"

Field Value

Type: String
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuTools.FullToggleButton Field

MenuToolsFullToggleButton Field

This style is used in measure panel, "Snap types" section.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string FullToggleButton = "FullToggleButton"
public:
literal String^ FullToggleButton = "FullToggleButton"

Field Value

Type: String
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuTools.GalleryMenuTool Field

MenuToolsGalleryMenuTool Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string GalleryMenuTool = "GalleryMenuTool"
public:
literal String^ GalleryMenuTool = "GalleryMenuTool"

Field Value

Type: String
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuTools.GalleryMenuToolItem Field

MenuToolsGalleryMenuToolItem Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string GalleryMenuToolItem = "GalleryMenuToolItem"
public:
literal String^ GalleryMenuToolItem = "GalleryMenuToolItem"

Field Value

Type: String
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuTools.HierarchicalItemMenuTool Field

MenuToolsHierarchicalItemMenuTool Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string HierarchicalItemMenuTool = "HierarchicalItemMenuTool"
public:
literal String^ HierarchicalItemMenuTool = "HierarchicalItemMenuTool"

Field Value

Type: String
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuTools.LargeItemMenuTool Field

MenuToolsLargeItemMenuTool Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string LargeItemMenuTool = "LargeItemMenuTool"
public:
literal String^ LargeItemMenuTool = "LargeItemMenuTool"

Field Value

Type: String
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuTools.MenuTool Field

MenuToolsMenuTool Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string MenuTool = "MenuTool"
public:
literal String^ MenuTool = "MenuTool"

Field Value

Type: String
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuTools.NumericTextEditorTool Field

MenuToolsNumericTextEditorTool Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string NumericTextEditorTool = "NumericTextEditorTool"
public:
literal String^ NumericTextEditorTool = "NumericTextEditorTool"

Field Value

Type: String
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuTools.RadioButtonTool Field

MenuToolsRadioButtonTool Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string RadioButtonTool = "RadioButtonTool"
public:
literal String^ RadioButtonTool = "RadioButtonTool"

Field Value

Type: String
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuTools.RibbonGroup Field

MenuToolsRibbonGroup Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string RibbonGroup = "RibbonGroup"
public:
literal String^ RibbonGroup = "RibbonGroup"

Field Value

Type: String
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuTools.RibbonTab Field

MenuToolsRibbonTab Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string RibbonTab = "RibbonTab"
public:
literal String^ RibbonTab = "RibbonTab"

Field Value

Type: String
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuTools.SearchComboEditorTool Field

MenuToolsSearchComboEditorTool Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string SearchComboEditorTool = "SearchComboEditorTool"
public:
literal String^ SearchComboEditorTool = "SearchComboEditorTool"

Field Value

Type: String
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuTools.SeparatorControl Field

MenuToolsSeparatorControl Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string SeparatorControl = "Separator"
public:
literal String^ SeparatorControl = "Separator"

Field Value

Type: String
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuTools.TextEditorTool Field

MenuToolsTextEditorTool Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string TextEditorTool = "TextEditorTool"
public:
literal String^ TextEditorTool = "TextEditorTool"

Field Value

Type: String
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuTools.ToggleButton Field

MenuToolsToggleButton Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string ToggleButton = "ToggleButton"
public:
literal String^ ToggleButton = "ToggleButton"

Field Value

Type: String
See Also

Reference

MenuTools Class
VisualComponents.UX.Shared Namespace


MenuToolTypeConverter Class

A converter from enum ToolSizingMode to Infragistics ToolSizingMode
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedMenuToolTypeConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class MenuToolTypeConverter : IValueConverter
public ref class MenuToolTypeConverter : IValueConverter

The MenuToolTypeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | MenuToolTypeConverter | Initializes a new instance of the MenuToolTypeConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


MenuToolTypeConverter Constructor

Initializes a new instance of the MenuToolTypeConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MenuToolTypeConverter()
public:
MenuToolTypeConverter()
See Also

Reference

MenuToolTypeConverter Class
VisualComponents.UX.Shared Namespace


MenuToolTypeConverter Methods

The MenuToolTypeConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MenuToolTypeConverter Class
VisualComponents.UX.Shared Namespace


MenuToolTypeConverter.Convert Method

MenuToolTypeConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MenuToolTypeConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

MenuToolTypeConverter Class
VisualComponents.UX.Shared Namespace


MenuToolTypeConverter.ConvertBack Method

MenuToolTypeConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MenuToolTypeConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

MenuToolTypeConverter Class
VisualComponents.UX.Shared Namespace


MessageBoxResultEx Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedMessageBoxResultEx

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class MessageBoxResultEx
public ref class MessageBoxResultEx sealed

The MessageBoxResultEx type exposes the following members.

Constructors
 | Name | Description
Public method | MessageBoxResultEx | Initializes a new instance of the MessageBoxResultEx class
Public method | MessageBoxResultEx(MessageBoxResult) | Initializes a new instance of the MessageBoxResultEx class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDefaultResultFor |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Operators
Name | Description
(MessageBoxResult to MessageBoxResultEx) |
Top
Fields
Name | Description
Auto |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


MessageBoxResultEx Constructor

Overload List
 | Name | Description
Public method | MessageBoxResultEx | Initializes a new instance of the MessageBoxResultEx class
Public method | MessageBoxResultEx(MessageBoxResult) | Initializes a new instance of the MessageBoxResultEx class
Top
See Also

Reference

MessageBoxResultEx Class
VisualComponents.UX.Shared Namespace


MessageBoxResultEx Constructor

Initializes a new instance of the MessageBoxResultEx class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MessageBoxResultEx()
public:
MessageBoxResultEx()
See Also

Reference

MessageBoxResultEx Class
MessageBoxResultEx Overload
VisualComponents.UX.Shared Namespace


MessageBoxResultEx Constructor (MessageBoxResult)

Initializes a new instance of the MessageBoxResultEx class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MessageBoxResultEx(
    MessageBoxResult res
)
public:
MessageBoxResultEx(
    MessageBoxResult res
)

Parameters

res
Type: System.WindowsMessageBoxResult
See Also

Reference

MessageBoxResultEx Class
MessageBoxResultEx Overload
VisualComponents.UX.Shared Namespace


MessageBoxResultEx Methods

The MessageBoxResultEx type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetDefaultResultFor |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MessageBoxResultEx Class
VisualComponents.UX.Shared Namespace


MessageBoxResultEx.GetDefaultResultFor Method

MessageBoxResultExGetDefaultResultFor Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MessageBoxResult GetDefaultResultFor(
    MessageBoxButton button
)
public:
MessageBoxResult GetDefaultResultFor(
    MessageBoxButton button
)

Parameters

button
Type: System.WindowsMessageBoxButton

Return Value

Type: MessageBoxResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MessageBoxResultEx.GetDefaultResultFor(System.Windows.MessageBoxButton)"]

See Also

Reference

MessageBoxResultEx Class
VisualComponents.UX.Shared Namespace


MessageBoxResultEx Type Conversions

The MessageBoxResultEx type exposes the following members.

Operators
Name | Description
(MessageBoxResult to MessageBoxResultEx) |
Top
See Also

Reference

MessageBoxResultEx Class
VisualComponents.UX.Shared Namespace


MessageBoxResultEx Explicit Conversion (MessageBoxResult to MessageBoxResultEx)

MessageBoxResultEx Conversion (MessageBoxResult to MessageBoxResultEx)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static explicit operator MessageBoxResultEx (
    MessageBoxResult res
)
static explicit operator MessageBoxResultEx^ (
    MessageBoxResult res
)

Parameters

res
Type: System.WindowsMessageBoxResult

Return Value

Type: MessageBoxResultEx

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MessageBoxResultEx.op_Explicit(System.Windows.MessageBoxResult)~VisualComponents.UX.Shared.MessageBoxResultEx"]

See Also

Reference

MessageBoxResultEx Class
VisualComponents.UX.Shared Namespace


MessageBoxResultEx Fields

The MessageBoxResultEx type exposes the following members.

Fields
Name | Description
Auto |
Top
See Also

Reference

MessageBoxResultEx Class
VisualComponents.UX.Shared Namespace


MessageBoxResultEx.Auto Field

MessageBoxResultExAuto Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static MessageBoxResultEx Auto
public:
static MessageBoxResultEx^ Auto

Field Value

Type: MessageBoxResultEx
See Also

Reference

MessageBoxResultEx Class
VisualComponents.UX.Shared Namespace


MetadataEditViews Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum MetadataEditViews
public enum class MetadataEditViews
Members
Member name | Value | Description
LayoutMetadataEditViewNone | 0 |
LayoutMetadataEditViewForSaving | 1 |
LayoutMetadataEditViewForLayoutInfo | 2 |
See Also

Reference

VisualComponents.UX.Shared Namespace


MetaDataSettings Class

MetaData Settings
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedMetaDataSettings

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class MetaDataSettings
public ref class MetaDataSettings

The MetaDataSettings type exposes the following members.

Constructors
 | Name | Description
Public method | MetaDataSettings | Initializes a new instance of the MetaDataSettings class
Top
Properties
 | Name | Description
Public property | Author |
Public property | AutoIncrementRevision |
Public property | CompanyLogo |
Public property | Description |
Public property | Editable |
Public property | Email |
Public property | File |
Public property | IsDeprecated |
Public property | IsEmpty |
Public property | Manufacturer |
Public property | MaxPayload |
Public property | Modified |
Public property | Name |
Public property | Preview |
Public property | Reach |
Public property | Revision |
Public property | Tags |
Public property | Type |
Public property | VCID |
Public property | Website |
Top
Methods
 | Name | Description
Public method | Clear |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


MetaDataSettings Constructor

Initializes a new instance of the MetaDataSettings class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MetaDataSettings()
public:
MetaDataSettings()
See Also

Reference

MetaDataSettings Class
VisualComponents.UX.Shared Namespace


MetaDataSettings Properties

The MetaDataSettings type exposes the following members.

Properties
 | Name | Description
Public property | Author |
Public property | AutoIncrementRevision |
Public property | CompanyLogo |
Public property | Description |
Public property | Editable |
Public property | Email |
Public property | File |
Public property | IsDeprecated |
Public property | IsEmpty |
Public property | Manufacturer |
Public property | MaxPayload |
Public property | Modified |
Public property | Name |
Public property | Preview |
Public property | Reach |
Public property | Revision |
Public property | Tags |
Public property | Type |
Public property | VCID |
Public property | Website |
Top
See Also

Reference

MetaDataSettings Class
VisualComponents.UX.Shared Namespace


MetaDataSettings.Author Property

MetaDataSettingsAuthor Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Author { get; set; }
public:
property String^ Author {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MetaDataSettings Class
VisualComponents.UX.Shared Namespace


MetaDataSettings.AutoIncrementRevision Property

MetaDataSettingsAutoIncrementRevision Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool AutoIncrementRevision { get; set; }
public:
property bool AutoIncrementRevision {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetaDataSettings Class
VisualComponents.UX.Shared Namespace


MetaDataSettings.CompanyLogo Property

MetaDataSettingsCompanyLogo Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Bitmap CompanyLogo { get; set; }
public:
property Bitmap^ CompanyLogo {
    Bitmap^ get ();
    void set (Bitmap^ value);
}

Property Value

Type: Bitmap
See Also

Reference

MetaDataSettings Class
VisualComponents.UX.Shared Namespace


MetaDataSettings.Description Property

MetaDataSettingsDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; set; }
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MetaDataSettings Class
VisualComponents.UX.Shared Namespace


MetaDataSettings.Editable Property

MetaDataSettingsEditable Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Editable { get; set; }
public:
property bool Editable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetaDataSettings Class
VisualComponents.UX.Shared Namespace


MetaDataSettings.Email Property

MetaDataSettingsEmail Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Email { get; set; }
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MetaDataSettings Class
VisualComponents.UX.Shared Namespace


MetaDataSettings.File Property

MetaDataSettingsFile Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string File { get; set; }
public:
property String^ File {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MetaDataSettings Class
VisualComponents.UX.Shared Namespace


MetaDataSettings.IsDeprecated Property

MetaDataSettingsIsDeprecated Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsDeprecated { get; set; }
public:
property bool IsDeprecated {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetaDataSettings Class
VisualComponents.UX.Shared Namespace


MetaDataSettings.IsEmpty Property

MetaDataSettingsIsEmpty Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsEmpty { get; set; }
public:
property bool IsEmpty {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetaDataSettings Class
VisualComponents.UX.Shared Namespace


MetaDataSettings.Manufacturer Property

MetaDataSettingsManufacturer Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Manufacturer { get; set; }
public:
property String^ Manufacturer {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MetaDataSettings Class
VisualComponents.UX.Shared Namespace


MetaDataSettings.MaxPayload Property

MetaDataSettingsMaxPayload Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int MaxPayload { get; set; }
public:
property int MaxPayload {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

MetaDataSettings Class
VisualComponents.UX.Shared Namespace


MetaDataSettings.Modified Property

MetaDataSettingsModified Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Modified { get; set; }
public:
property String^ Modified {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MetaDataSettings Class
VisualComponents.UX.Shared Namespace


MetaDataSettings.Name Property

MetaDataSettingsName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; set; }
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MetaDataSettings Class
VisualComponents.UX.Shared Namespace


MetaDataSettings.Preview Property

MetaDataSettingsPreview Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Bitmap Preview { get; set; }
public:
property Bitmap^ Preview {
    Bitmap^ get ();
    void set (Bitmap^ value);
}

Property Value

Type: Bitmap
See Also

Reference

MetaDataSettings Class
VisualComponents.UX.Shared Namespace


MetaDataSettings.Reach Property

MetaDataSettingsReach Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Reach { get; set; }
public:
property int Reach {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

MetaDataSettings Class
VisualComponents.UX.Shared Namespace


MetaDataSettings.Revision Property

MetaDataSettingsRevision Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Revision { get; set; }
public:
property int Revision {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

MetaDataSettings Class
VisualComponents.UX.Shared Namespace


MetaDataSettings.Tags Property

MetaDataSettingsTags Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Tags { get; set; }
public:
property String^ Tags {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MetaDataSettings Class
VisualComponents.UX.Shared Namespace


MetaDataSettings.Type Property

MetaDataSettingsType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Type { get; set; }
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MetaDataSettings Class
VisualComponents.UX.Shared Namespace


MetaDataSettings.VCID Property

MetaDataSettingsVCID Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string VCID { get; set; }
public:
property String^ VCID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MetaDataSettings Class
VisualComponents.UX.Shared Namespace


MetaDataSettings.Website Property

MetaDataSettingsWebsite Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Website { get; set; }
public:
property String^ Website {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MetaDataSettings Class
VisualComponents.UX.Shared Namespace


MetaDataSettings Methods

The MetaDataSettings type exposes the following members.

Methods
 | Name | Description
Public method | Clear |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MetaDataSettings Class
VisualComponents.UX.Shared Namespace


MetaDataSettings.Clear Method

MetaDataSettingsClear Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Clear()
public:
void Clear()
See Also

Reference

MetaDataSettings Class
VisualComponents.UX.Shared Namespace


MinMaxValidationRule Class

Inheritance Hierarchy
SystemObject
System.Windows.ControlsValidationRule
VisualComponents.UX.SharedMinMaxValidationRule

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class MinMaxValidationRule : ValidationRule
public ref class MinMaxValidationRule : public ValidationRule

The MinMaxValidationRule type exposes the following members.

Constructors
 | Name | Description
Public method | MinMaxValidationRule | Initializes a new instance of the MinMaxValidationRule class
Top
Properties
 | Name | Description
Public property | AllowedValueContainer |
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadSettings |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


MinMaxValidationRule Constructor

Initializes a new instance of the MinMaxValidationRule class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MinMaxValidationRule()
public:
MinMaxValidationRule()
See Also

Reference

MinMaxValidationRule Class
VisualComponents.UX.Shared Namespace


MinMaxValidationRule Properties

The MinMaxValidationRule type exposes the following members.

Properties
 | Name | Description
Public property | AllowedValueContainer |
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
See Also

Reference

MinMaxValidationRule Class
VisualComponents.UX.Shared Namespace


MinMaxValidationRule.AllowedValueContainer Property

MinMaxValidationRuleAllowedValueContainer Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AllowedValueContainer AllowedValueContainer { get; set; }
public:
property AllowedValueContainer^ AllowedValueContainer {
    AllowedValueContainer^ get ();
    void set (AllowedValueContainer^ value);
}

Property Value

Type: AllowedValueContainer
See Also

Reference

MinMaxValidationRule Class
VisualComponents.UX.Shared Namespace


MinMaxValidationRule Methods

The MinMaxValidationRule type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadSettings |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MinMaxValidationRule Class
VisualComponents.UX.Shared Namespace


MinMaxValidationRule.ReadSettings Method

MinMaxValidationRuleReadSettings Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ReadSettings()
public:
void ReadSettings()
See Also

Reference

MinMaxValidationRule Class
VisualComponents.UX.Shared Namespace


MinMaxValidationRule.Validate Method

MinMaxValidationRuleValidate Method

Overload List
 | Name | Description
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
See Also

Reference

MinMaxValidationRule Class
VisualComponents.UX.Shared Namespace


MinMaxValidationRule.Validate Method (Object, CultureInfo)

MinMaxValidationRuleValidate Method (Object, CultureInfo)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override ValidationResult Validate(
    Object value,
    CultureInfo cultureInfo
)
public:
virtual ValidationResult^ Validate(
    Object^ value,
    CultureInfo^ cultureInfo
) override

Parameters

value
Type: SystemObject
cultureInfo
Type: System.GlobalizationCultureInfo

Return Value

Type: ValidationResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MinMaxValidationRule.Validate(System.Object,System.Globalization.CultureInfo)"]

See Also

Reference

MinMaxValidationRule Class
Validate Overload
VisualComponents.UX.Shared Namespace


MouseButtonArrayConverter Class

Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
VisualComponents.UX.SharedMouseButtonArrayConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class MouseButtonArrayConverter : TypeConverter
public ref class MouseButtonArrayConverter : public TypeConverter

The MouseButtonArrayConverter type exposes the following members.

Constructors
 | Name | Description
Public method | MouseButtonArrayConverter | Initializes a new instance of the MouseButtonArrayConverter class
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


MouseButtonArrayConverter Constructor

Initializes a new instance of the MouseButtonArrayConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MouseButtonArrayConverter()
public:
MouseButtonArrayConverter()
See Also

Reference

MouseButtonArrayConverter Class
VisualComponents.UX.Shared Namespace


MouseButtonArrayConverter Methods

The MouseButtonArrayConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MouseButtonArrayConverter Class
VisualComponents.UX.Shared Namespace


MouseButtonArrayConverter.CanConvertFrom Method

MouseButtonArrayConverterCanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Top
See Also

Reference

MouseButtonArrayConverter Class
VisualComponents.UX.Shared Namespace


MouseButtonArrayConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

MouseButtonArrayConverterCanConvertFrom Method (ITypeDescriptorContext, Type)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
public:
virtual bool CanConvertFrom(
    ITypeDescriptorContext^ context,
    Type^ sourceType
) override

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
sourceType
Type: SystemType

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MouseButtonArrayConverter.CanConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Type)"]

See Also

Reference

MouseButtonArrayConverter Class
CanConvertFrom Overload
VisualComponents.UX.Shared Namespace


MouseButtonArrayConverter.CanConvertTo Method

MouseButtonArrayConverterCanConvertTo Method

Overload List
 | Name | Description
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Top
See Also

Reference

MouseButtonArrayConverter Class
VisualComponents.UX.Shared Namespace


MouseButtonArrayConverter.CanConvertTo Method (ITypeDescriptorContext, Type)

MouseButtonArrayConverterCanConvertTo Method (ITypeDescriptorContext, Type)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
public:
virtual bool CanConvertTo(
    ITypeDescriptorContext^ context,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
destinationType
Type: SystemType

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MouseButtonArrayConverter.CanConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Type)"]

See Also

Reference

MouseButtonArrayConverter Class
CanConvertTo Overload
VisualComponents.UX.Shared Namespace


MouseButtonArrayConverter.ConvertFrom Method

MouseButtonArrayConverterConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

MouseButtonArrayConverter Class
VisualComponents.UX.Shared Namespace


MouseButtonArrayConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

MouseButtonArrayConverterConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value
) override

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
culture
Type: System.GlobalizationCultureInfo
value
Type: SystemObject

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MouseButtonArrayConverter.ConvertFrom(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object)"]

See Also

Reference

MouseButtonArrayConverter Class
ConvertFrom Overload
VisualComponents.UX.Shared Namespace


MouseButtonArrayConverter.ConvertTo Method

MouseButtonArrayConverterConvertTo Method

Overload List
 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

MouseButtonArrayConverter Class
VisualComponents.UX.Shared Namespace


MouseButtonArrayConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

MouseButtonArrayConverterConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
culture
Type: System.GlobalizationCultureInfo
value
Type: SystemObject
destinationType
Type: SystemType

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MouseButtonArrayConverter.ConvertTo(System.ComponentModel.ITypeDescriptorContext,System.Globalization.CultureInfo,System.Object,System.Type)"]

See Also

Reference

MouseButtonArrayConverter Class
ConvertTo Overload
VisualComponents.UX.Shared Namespace


MouseHelper Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedMouseHelper

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class MouseHelper
public ref class MouseHelper abstract sealed

The MouseHelper type exposes the following members.

Methods
Name | Description
CallNextHookEx |
GetAsyncKeyState |
GetCursorPos |
GetCursorPos(MouseHelperPOINTSTRUCT) |
GetKeyState |
GetModuleHandle |
GetRelativeCursorPos |
SetWindowsHookEx |
UnhookWindowsHookEx |
Top
Fields
Name | Description
HC_ACTION |
WH_MOUSE_LL |
WM_LBUTTONDBLCLK |
WM_LBUTTONDOWN |
WM_LBUTTONUP |
WM_MBUTTONDBLCLK |
WM_MBUTTONDOWN |
WM_MBUTTONUP |
WM_MOUSEHWHEEL |
WM_MOUSEMOVE |
WM_MOUSEWHEEL |
WM_RBUTTONDBLCLK |
WM_RBUTTONDOWN |
WM_RBUTTONUP |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


MouseHelper Methods

The MouseHelper type exposes the following members.

Methods
Name | Description
CallNextHookEx |
GetAsyncKeyState |
GetCursorPos |
GetCursorPos(MouseHelperPOINTSTRUCT) |
GetKeyState |
GetModuleHandle |
GetRelativeCursorPos |
SetWindowsHookEx |
UnhookWindowsHookEx |
Top
See Also

Reference

MouseHelper Class
VisualComponents.UX.Shared Namespace


MouseHelper.CallNextHookEx Method

MouseHelperCallNextHookEx Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int CallNextHookEx(
    int idHook,
    int nCode,
    IntPtr wParam,
    IntPtr lParam
)
public:
static int CallNextHookEx(
    int idHook,
    int nCode,
    IntPtr wParam,
    IntPtr lParam
)

Parameters

idHook
Type: SystemInt32
nCode
Type: SystemInt32
wParam
Type: SystemIntPtr
lParam
Type: SystemIntPtr

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MouseHelper.CallNextHookEx(System.Int32,System.Int32,System.IntPtr,System.IntPtr)"]

See Also

Reference

MouseHelper Class
VisualComponents.UX.Shared Namespace


MouseHelper.GetAsyncKeyState Method

MouseHelperGetAsyncKeyState Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static short GetAsyncKeyState(
    ushort virtualKeyCode
)
public:
static short GetAsyncKeyState(
    unsigned short virtualKeyCode
)

Parameters

virtualKeyCode
Type: SystemUInt16

Return Value

Type: Int16

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MouseHelper.GetAsyncKeyState(System.UInt16)"]

See Also

Reference

MouseHelper Class
VisualComponents.UX.Shared Namespace


MouseHelper.GetCursorPos Method

MouseHelperGetCursorPos Method

Overload List
Name | Description
GetCursorPos |
GetCursorPos(MouseHelperPOINTSTRUCT) |
Top
See Also

Reference

MouseHelper Class
VisualComponents.UX.Shared Namespace


MouseHelper.GetCursorPos Method

MouseHelperGetCursorPos Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Point GetCursorPos()
public:
static Point GetCursorPos()

Return Value

Type: Point

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MouseHelper.GetCursorPos"]

See Also

Reference

MouseHelper Class
GetCursorPos Overload
VisualComponents.UX.Shared Namespace


MouseHelper.GetCursorPos Method (MouseHelper.POINTSTRUCT)

MouseHelperGetCursorPos Method (MouseHelperPOINTSTRUCT)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool GetCursorPos(
    ref MouseHelperPOINTSTRUCT lpPoint
)
public:
static bool GetCursorPos(
    MouseHelperPOINTSTRUCT% lpPoint
)

Parameters

lpPoint
Type: VisualComponents.UX.SharedMouseHelperPOINTSTRUCT

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MouseHelper.GetCursorPos(VisualComponents.UX.Shared.MouseHelper.POINTSTRUCT@)"]

See Also

Reference

MouseHelper Class
GetCursorPos Overload
VisualComponents.UX.Shared Namespace


MouseHelper.GetKeyState Method

MouseHelperGetKeyState Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static short GetKeyState(
    ushort virtualKeyCode
)
public:
static short GetKeyState(
    unsigned short virtualKeyCode
)

Parameters

virtualKeyCode
Type: SystemUInt16

Return Value

Type: Int16

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MouseHelper.GetKeyState(System.UInt16)"]

See Also

Reference

MouseHelper Class
VisualComponents.UX.Shared Namespace


MouseHelper.GetModuleHandle Method

MouseHelperGetModuleHandle Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IntPtr GetModuleHandle(
    string lpModuleName
)
public:
static IntPtr GetModuleHandle(
    String^ lpModuleName
)

Parameters

lpModuleName
Type: SystemString

Return Value

Type: IntPtr

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MouseHelper.GetModuleHandle(System.String)"]

See Also

Reference

MouseHelper Class
VisualComponents.UX.Shared Namespace


MouseHelper.GetRelativeCursorPos Method

MouseHelperGetRelativeCursorPos Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Point GetRelativeCursorPos(
    Visual relativeTo
)
public:
static Point GetRelativeCursorPos(
    Visual^ relativeTo
)

Parameters

relativeTo
Type: System.Windows.MediaVisual

Return Value

Type: Point

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MouseHelper.GetRelativeCursorPos(System.Windows.Media.Visual)"]

See Also

Reference

MouseHelper Class
VisualComponents.UX.Shared Namespace


MouseHelper.SetWindowsHookEx Method

MouseHelperSetWindowsHookEx Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int SetWindowsHookEx(
    int idHook,
    MouseHelperHookProc lpfn,
    IntPtr hInstance,
    int threadId
)
public:
static int SetWindowsHookEx(
    int idHook,
    MouseHelperHookProc^ lpfn,
    IntPtr hInstance,
    int threadId
)

Parameters

idHook
Type: SystemInt32
lpfn
Type: VisualComponents.UX.SharedMouseHelperHookProc
hInstance
Type: SystemIntPtr
threadId
Type: SystemInt32

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MouseHelper.SetWindowsHookEx(System.Int32,VisualComponents.UX.Shared.MouseHelper.HookProc,System.IntPtr,System.Int32)"]

See Also

Reference

MouseHelper Class
VisualComponents.UX.Shared Namespace


MouseHelper.UnhookWindowsHookEx Method

MouseHelperUnhookWindowsHookEx Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool UnhookWindowsHookEx(
    int idHook
)
public:
static bool UnhookWindowsHookEx(
    int idHook
)

Parameters

idHook
Type: SystemInt32

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MouseHelper.UnhookWindowsHookEx(System.Int32)"]

See Also

Reference

MouseHelper Class
VisualComponents.UX.Shared Namespace


MouseHelper Fields

The MouseHelper type exposes the following members.

Fields
Name | Description
HC_ACTION |
WH_MOUSE_LL |
WM_LBUTTONDBLCLK |
WM_LBUTTONDOWN |
WM_LBUTTONUP |
WM_MBUTTONDBLCLK |
WM_MBUTTONDOWN |
WM_MBUTTONUP |
WM_MOUSEHWHEEL |
WM_MOUSEMOVE |
WM_MOUSEWHEEL |
WM_RBUTTONDBLCLK |
WM_RBUTTONDOWN |
WM_RBUTTONUP |
Top
See Also

Reference

MouseHelper Class
VisualComponents.UX.Shared Namespace


MouseHelper.HC_ACTION Field

MouseHelperHC_ACTION Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int HC_ACTION = 0
public:
literal int HC_ACTION = 0

Field Value

Type: Int32
See Also

Reference

MouseHelper Class
VisualComponents.UX.Shared Namespace


MouseHelper.WH_MOUSE_LL Field

MouseHelperWH_MOUSE_LL Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int WH_MOUSE_LL = 14
public:
literal int WH_MOUSE_LL = 14

Field Value

Type: Int32
See Also

Reference

MouseHelper Class
VisualComponents.UX.Shared Namespace


MouseHelper.WM_LBUTTONDBLCLK Field

MouseHelperWM_LBUTTONDBLCLK Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int WM_LBUTTONDBLCLK = 515
public:
literal int WM_LBUTTONDBLCLK = 515

Field Value

Type: Int32
See Also

Reference

MouseHelper Class
VisualComponents.UX.Shared Namespace


MouseHelper.WM_LBUTTONDOWN Field

MouseHelperWM_LBUTTONDOWN Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int WM_LBUTTONDOWN = 513
public:
literal int WM_LBUTTONDOWN = 513

Field Value

Type: Int32
See Also

Reference

MouseHelper Class
VisualComponents.UX.Shared Namespace


MouseHelper.WM_LBUTTONUP Field

MouseHelperWM_LBUTTONUP Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int WM_LBUTTONUP = 514
public:
literal int WM_LBUTTONUP = 514

Field Value

Type: Int32
See Also

Reference

MouseHelper Class
VisualComponents.UX.Shared Namespace


MouseHelper.WM_MBUTTONDBLCLK Field

MouseHelperWM_MBUTTONDBLCLK Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int WM_MBUTTONDBLCLK = 521
public:
literal int WM_MBUTTONDBLCLK = 521

Field Value

Type: Int32
See Also

Reference

MouseHelper Class
VisualComponents.UX.Shared Namespace


MouseHelper.WM_MBUTTONDOWN Field

MouseHelperWM_MBUTTONDOWN Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int WM_MBUTTONDOWN = 519
public:
literal int WM_MBUTTONDOWN = 519

Field Value

Type: Int32
See Also

Reference

MouseHelper Class
VisualComponents.UX.Shared Namespace


MouseHelper.WM_MBUTTONUP Field

MouseHelperWM_MBUTTONUP Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int WM_MBUTTONUP = 520
public:
literal int WM_MBUTTONUP = 520

Field Value

Type: Int32
See Also

Reference

MouseHelper Class
VisualComponents.UX.Shared Namespace


MouseHelper.WM_MOUSEHWHEEL Field

MouseHelperWM_MOUSEHWHEEL Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int WM_MOUSEHWHEEL = 526
public:
literal int WM_MOUSEHWHEEL = 526

Field Value

Type: Int32
See Also

Reference

MouseHelper Class
VisualComponents.UX.Shared Namespace


MouseHelper.WM_MOUSEMOVE Field

MouseHelperWM_MOUSEMOVE Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int WM_MOUSEMOVE = 512
public:
literal int WM_MOUSEMOVE = 512

Field Value

Type: Int32
See Also

Reference

MouseHelper Class
VisualComponents.UX.Shared Namespace


MouseHelper.WM_MOUSEWHEEL Field

MouseHelperWM_MOUSEWHEEL Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int WM_MOUSEWHEEL = 522
public:
literal int WM_MOUSEWHEEL = 522

Field Value

Type: Int32
See Also

Reference

MouseHelper Class
VisualComponents.UX.Shared Namespace


MouseHelper.WM_RBUTTONDBLCLK Field

MouseHelperWM_RBUTTONDBLCLK Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int WM_RBUTTONDBLCLK = 518
public:
literal int WM_RBUTTONDBLCLK = 518

Field Value

Type: Int32
See Also

Reference

MouseHelper Class
VisualComponents.UX.Shared Namespace


MouseHelper.WM_RBUTTONDOWN Field

MouseHelperWM_RBUTTONDOWN Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int WM_RBUTTONDOWN = 516
public:
literal int WM_RBUTTONDOWN = 516

Field Value

Type: Int32
See Also

Reference

MouseHelper Class
VisualComponents.UX.Shared Namespace


MouseHelper.WM_RBUTTONUP Field

MouseHelperWM_RBUTTONUP Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int WM_RBUTTONUP = 517
public:
literal int WM_RBUTTONUP = 517

Field Value

Type: Int32
See Also

Reference

MouseHelper Class
VisualComponents.UX.Shared Namespace


MouseHelper.HookProc Delegate

MouseHelperHookProc Delegate

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public delegate int HookProc(
    int nCode,
    IntPtr wParam,
    IntPtr lParam
)
public delegate int HookProc(
    int nCode,
    IntPtr wParam,
    IntPtr lParam
)

Parameters

nCode
Type: SystemInt32
wParam
Type: SystemIntPtr
lParam
Type: SystemIntPtr

Return Value

Type: Int32
See Also

Reference

VisualComponents.UX.Shared Namespace


MouseHelper.MouseHookStruct Class

MouseHelperMouseHookStruct Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedMouseHelperMouseHookStruct

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class MouseHookStruct
public ref class MouseHookStruct

The MouseHelperMouseHookStruct type exposes the following members.

Constructors
 | Name | Description
Public method | MouseHelperMouseHookStruct | Initializes a new instance of the MouseHelperMouseHookStruct class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | dwExtraInfo |
Public field | hwnd |
Public field | pt |
Public field | wHitTestCode |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


MouseHelper.MouseHookStruct Constructor

MouseHelperMouseHookStruct Constructor

Initializes a new instance of the MouseHelperMouseHookStruct class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MouseHookStruct()
public:
MouseHookStruct()
See Also

Reference

MouseHelperMouseHookStruct Class
VisualComponents.UX.Shared Namespace


MouseHookStruct Methods

The MouseHelperMouseHookStruct type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MouseHelperMouseHookStruct Class
VisualComponents.UX.Shared Namespace


MouseHookStruct Fields

The MouseHelperMouseHookStruct type exposes the following members.

Fields
 | Name | Description
Public field | dwExtraInfo |
Public field | hwnd |
Public field | pt |
Public field | wHitTestCode |
Top
See Also

Reference

MouseHelperMouseHookStruct Class
VisualComponents.UX.Shared Namespace


MouseHelper.MouseHookStruct.dwExtraInfo Field

MouseHelperMouseHookStructdwExtraInfo Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int dwExtraInfo
public:
int dwExtraInfo

Field Value

Type: Int32
See Also

Reference

MouseHelperMouseHookStruct Class
VisualComponents.UX.Shared Namespace


MouseHelper.MouseHookStruct.hwnd Field

MouseHelperMouseHookStructhwnd Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int hwnd
public:
int hwnd

Field Value

Type: Int32
See Also

Reference

MouseHelperMouseHookStruct Class
VisualComponents.UX.Shared Namespace


MouseHelper.MouseHookStruct.pt Field

MouseHelperMouseHookStructpt Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MouseHelperPOINT pt
public:
MouseHelperPOINT^ pt

Field Value

Type: MouseHelperPOINT
See Also

Reference

MouseHelperMouseHookStruct Class
VisualComponents.UX.Shared Namespace


MouseHelper.MouseHookStruct.wHitTestCode Field

MouseHelperMouseHookStructwHitTestCode Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int wHitTestCode
public:
int wHitTestCode

Field Value

Type: Int32
See Also

Reference

MouseHelperMouseHookStruct Class
VisualComponents.UX.Shared Namespace


MouseHelper.POINT Class

MouseHelperPOINT Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedMouseHelperPOINT

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class POINT
public ref class POINT

The MouseHelperPOINT type exposes the following members.

Constructors
 | Name | Description
Public method | MouseHelperPOINT | Initializes a new instance of the MouseHelperPOINT class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | x |
Public field | y |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


MouseHelper.POINT Constructor

MouseHelperPOINT Constructor

Initializes a new instance of the MouseHelperPOINT class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public POINT()
public:
POINT()
See Also

Reference

MouseHelperPOINT Class
VisualComponents.UX.Shared Namespace


POINT Methods

The MouseHelperPOINT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MouseHelperPOINT Class
VisualComponents.UX.Shared Namespace


POINT Fields

The MouseHelperPOINT type exposes the following members.

Fields
 | Name | Description
Public field | x |
Public field | y |
Top
See Also

Reference

MouseHelperPOINT Class
VisualComponents.UX.Shared Namespace


MouseHelper.POINT.x Field

MouseHelperPOINTx Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int x
public:
int x

Field Value

Type: Int32
See Also

Reference

MouseHelperPOINT Class
VisualComponents.UX.Shared Namespace


MouseHelper.POINT.y Field

MouseHelperPOINTy Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int y
public:
int y

Field Value

Type: Int32
See Also

Reference

MouseHelperPOINT Class
VisualComponents.UX.Shared Namespace


MouseHelper.POINTSTRUCT Structure

MouseHelperPOINTSTRUCT Structure

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct POINTSTRUCT
public value class POINTSTRUCT

The MouseHelperPOINTSTRUCT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | (Overrides ValueTypeToString.)
Top
Fields
 | Name | Description
Public field | X |
Public field | Y |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


POINTSTRUCT Methods

The MouseHelperPOINTSTRUCT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | (Overrides ValueTypeToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MouseHelperPOINTSTRUCT Structure
VisualComponents.UX.Shared Namespace


MouseHelper.POINTSTRUCT.ToString Method

MouseHelperPOINTSTRUCTToString Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MouseHelper.POINTSTRUCT.ToString"]

See Also

Reference

MouseHelperPOINTSTRUCT Structure
VisualComponents.UX.Shared Namespace


POINTSTRUCT Fields

The MouseHelperPOINTSTRUCT type exposes the following members.

Fields
 | Name | Description
Public field | X |
Public field | Y |
Top
See Also

Reference

MouseHelperPOINTSTRUCT Structure
VisualComponents.UX.Shared Namespace


MouseHelper.POINTSTRUCT.X Field

MouseHelperPOINTSTRUCTX Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int X
public:
int X

Field Value

Type: Int32
See Also

Reference

MouseHelperPOINTSTRUCT Structure
VisualComponents.UX.Shared Namespace


MouseHelper.POINTSTRUCT.Y Field

MouseHelperPOINTSTRUCTY Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Y
public:
int Y

Field Value

Type: Int32
See Also

Reference

MouseHelperPOINTSTRUCT Structure
VisualComponents.UX.Shared Namespace


MouseListener Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedMouseListener

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class MouseListener
public ref class MouseListener

The MouseListener type exposes the following members.

Constructors
 | Name | Description
Public method | MouseListener | Create mouse listener
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | MouseDown | Mouse down.
Public event | MouseMove | Mouse movement in screen.
Top
Fields
Name | Description
Win32InterOpHandle |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


MouseListener Constructor

Create mouse listener

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MouseListener()
public:
MouseListener()
See Also

Reference

MouseListener Class
VisualComponents.UX.Shared Namespace


MouseListener Methods

The MouseListener type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MouseListener Class
VisualComponents.UX.Shared Namespace


MouseListener.Finalize Method

MouseListenerFinalize Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void Finalize()
protected:
virtual void Finalize() override

Implements

ObjectFinalize
See Also

Reference

MouseListener Class
VisualComponents.UX.Shared Namespace


MouseListener Events

The MouseListener type exposes the following members.

Events
 | Name | Description
Public event | MouseDown | Mouse down.
Public event | MouseMove | Mouse movement in screen.
Top
See Also

Reference

MouseListener Class
VisualComponents.UX.Shared Namespace


MouseListener.MouseDown Event

MouseListenerMouseDown Event

Mouse down.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event RawMouseMoveHandler MouseDown
public:
 event RawMouseMoveHandler^ MouseDown {
    void add (RawMouseMoveHandler^ value);
    void remove (RawMouseMoveHandler^ value);
}

Value

Type: VisualComponents.UX.SharedRawMouseMoveHandler
See Also

Reference

MouseListener Class
VisualComponents.UX.Shared Namespace


MouseListener.MouseMove Event

MouseListenerMouseMove Event

Mouse movement in screen.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event RawMouseMoveHandler MouseMove
public:
 event RawMouseMoveHandler^ MouseMove {
    void add (RawMouseMoveHandler^ value);
    void remove (RawMouseMoveHandler^ value);
}

Value

Type: VisualComponents.UX.SharedRawMouseMoveHandler
See Also

Reference

MouseListener Class
VisualComponents.UX.Shared Namespace


MouseListener Fields

The MouseListener type exposes the following members.

Fields
Name | Description
Win32InterOpHandle |
Top
See Also

Reference

MouseListener Class
VisualComponents.UX.Shared Namespace


MouseListener.Win32InterOpHandle Field

MouseListenerWin32InterOpHandle Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IntPtr Win32InterOpHandle
public:
static IntPtr Win32InterOpHandle

Field Value

Type: IntPtr
See Also

Reference

MouseListener Class
VisualComponents.UX.Shared Namespace


MouseMessage Class

MouseMessage is used to update SnapAction's snapping. This message is sent in 4 cases: - when user clicks a button - when user moves the mouse - when user stops moving the mouse and 100ms elapsed (in rare cases) - when user stops scrolling the mouse wheel and 100ms elapsed
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedMouseMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class MouseMessage
public ref class MouseMessage

The MouseMessage type exposes the following members.

Constructors
 | Name | Description
Public method | MouseMessage | Initializes a new instance of the MouseMessage class
Top
Properties
 | Name | Description
Public property | KeysState |
Public property | MouseArgs |
Public property | MousePosition |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


MouseMessage Constructor

Initializes a new instance of the MouseMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MouseMessage(
    Point point,
    MouseEventArgs args,
    bool keysState
)
public:
MouseMessage(
    Point point,
    MouseEventArgs^ args,
    bool keysState
)

Parameters

point
Type: System.WindowsPoint
args
Type: System.Windows.InputMouseEventArgs
keysState
Type: SystemBoolean
See Also

Reference

MouseMessage Class
VisualComponents.UX.Shared Namespace


MouseMessage Properties

The MouseMessage type exposes the following members.

Properties
 | Name | Description
Public property | KeysState |
Public property | MouseArgs |
Public property | MousePosition |
Top
See Also

Reference

MouseMessage Class
VisualComponents.UX.Shared Namespace


MouseMessage.KeysState Property

MouseMessageKeysState Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool KeysState { get; set; }
public:
property bool KeysState {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MouseMessage Class
VisualComponents.UX.Shared Namespace


MouseMessage.MouseArgs Property

MouseMessageMouseArgs Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MouseEventArgs MouseArgs { get; }
public:
property MouseEventArgs^ MouseArgs {
    MouseEventArgs^ get ();
}

Property Value

Type: MouseEventArgs
See Also

Reference

MouseMessage Class
VisualComponents.UX.Shared Namespace


MouseMessage.MousePosition Property

MouseMessageMousePosition Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Point MousePosition { get; }
public:
property Point MousePosition {
    Point get ();
}

Property Value

Type: Point
See Also

Reference

MouseMessage Class
VisualComponents.UX.Shared Namespace


MouseMessage Methods

The MouseMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MouseMessage Class
VisualComponents.UX.Shared Namespace


MouseTouchDevice Class

Implements a mouse touch device, which promotes mouse input to touch input.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.Windows.InputInputDevice
System.Windows.InputTouchDevice
VisualComponents.UX.SharedMouseTouchDevice

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class MouseTouchDevice : TouchDevice
public ref class MouseTouchDevice : public TouchDevice

The MouseTouchDevice type exposes the following members.

Constructors
 | Name | Description
Public method | MouseTouchDevice | Initializes a new instance of the MouseTouchDevice class
Top
Properties
 | Name | Description
Public property | ActiveSource | Gets the PresentationSource that is reporting input for this device. (Inherited from TouchDevice.)
Public property | Captured | Gets the element that captured the TouchDevice. (Inherited from TouchDevice.)
Public property | CaptureMode | Gets the capture policy of the TouchDevice. (Inherited from TouchDevice.)
Public property | DirectlyOver | Gets the element that the touch contact point is directly over. (Inherited from TouchDevice.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Id | Gets the unique identifier of the TouchDevice, as provided by the operating system. (Inherited from TouchDevice.)
Public property | IsActive | Gets a value that indicates whether the device is active. (Inherited from TouchDevice.)
Public property | Position |
Public property | Target | Gets the element that receives input from the TouchDevice. (Inherited from TouchDevice.)
Top
Methods
 | Name | Description
Protected method | Activate | Adds the TouchDevice to the input messaging system. (Inherited from TouchDevice.)
Public method | Capture(IInputElement) | Captures a touch to the specified element by using the Element capture mode. (Inherited from TouchDevice.)
Public method | Capture(IInputElement, CaptureMode) | Captures a touch to the specified element by using the specified CaptureMode. (Inherited from TouchDevice.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | Deactivate | Removes the TouchDevice from the input messaging system. (Inherited from TouchDevice.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIntermediateTouchPoints | (Overrides TouchDeviceGetIntermediateTouchPoints(IInputElement).)
Public method | GetTouchPoint | (Overrides TouchDeviceGetTouchPoint(IInputElement).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCapture | Called when a touch is captured to an element. (Inherited from TouchDevice.)
Protected method | OnManipulationEnded | Called when a manipulation has ended. (Inherited from TouchDevice.)
Protected method | OnManipulationStarted | Called when a manipulation is started. (Inherited from TouchDevice.)
 | RegisterEvents |
Protected method | ReportDown | Reports that a touch is pressed on an element. (Inherited from TouchDevice.)
Protected method | ReportMove | Reports that a touch is moving across an element. (Inherited from TouchDevice.)
Protected method | ReportUp | Reports that a touch was lifted from an element. (Inherited from TouchDevice.)
Protected method | SetActiveSource | Sets the PresentationSource that is reporting input for this device. (Inherited from TouchDevice.)
Public method | Synchronize | Forces the TouchDevice to synchronize the user interface with underlying touch points. (Inherited from TouchDevice.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the TouchDevice is added to the input messaging system. (Inherited from TouchDevice.)
Public event | Deactivated | Occurs when the TouchDevice is removed from the input messaging system. (Inherited from TouchDevice.)
Public event | Updated | Occurs when a touch message is sent. (Inherited from TouchDevice.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


MouseTouchDevice Constructor

Initializes a new instance of the MouseTouchDevice class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MouseTouchDevice(
    int deviceId
)
public:
MouseTouchDevice(
    int deviceId
)

Parameters

deviceId
Type: SystemInt32
See Also

Reference

MouseTouchDevice Class
VisualComponents.UX.Shared Namespace


MouseTouchDevice Properties

The MouseTouchDevice type exposes the following members.

Properties
 | Name | Description
Public property | ActiveSource | Gets the PresentationSource that is reporting input for this device. (Inherited from TouchDevice.)
Public property | Captured | Gets the element that captured the TouchDevice. (Inherited from TouchDevice.)
Public property | CaptureMode | Gets the capture policy of the TouchDevice. (Inherited from TouchDevice.)
Public property | DirectlyOver | Gets the element that the touch contact point is directly over. (Inherited from TouchDevice.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Id | Gets the unique identifier of the TouchDevice, as provided by the operating system. (Inherited from TouchDevice.)
Public property | IsActive | Gets a value that indicates whether the device is active. (Inherited from TouchDevice.)
Public property | Position |
Public property | Target | Gets the element that receives input from the TouchDevice. (Inherited from TouchDevice.)
Top
See Also

Reference

MouseTouchDevice Class
VisualComponents.UX.Shared Namespace


MouseTouchDevice.Position Property

MouseTouchDevicePosition Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Point Position { get; set; }
public:
property Point Position {
    Point get ();
    void set (Point value);
}

Property Value

Type: Point
See Also

Reference

MouseTouchDevice Class
VisualComponents.UX.Shared Namespace


MouseTouchDevice Methods

The MouseTouchDevice type exposes the following members.

Methods
 | Name | Description
Protected method | Activate | Adds the TouchDevice to the input messaging system. (Inherited from TouchDevice.)
Public method | Capture(IInputElement) | Captures a touch to the specified element by using the Element capture mode. (Inherited from TouchDevice.)
Public method | Capture(IInputElement, CaptureMode) | Captures a touch to the specified element by using the specified CaptureMode. (Inherited from TouchDevice.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | Deactivate | Removes the TouchDevice from the input messaging system. (Inherited from TouchDevice.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIntermediateTouchPoints | (Overrides TouchDeviceGetIntermediateTouchPoints(IInputElement).)
Public method | GetTouchPoint | (Overrides TouchDeviceGetTouchPoint(IInputElement).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCapture | Called when a touch is captured to an element. (Inherited from TouchDevice.)
Protected method | OnManipulationEnded | Called when a manipulation has ended. (Inherited from TouchDevice.)
Protected method | OnManipulationStarted | Called when a manipulation is started. (Inherited from TouchDevice.)
 | RegisterEvents |
Protected method | ReportDown | Reports that a touch is pressed on an element. (Inherited from TouchDevice.)
Protected method | ReportMove | Reports that a touch is moving across an element. (Inherited from TouchDevice.)
Protected method | ReportUp | Reports that a touch was lifted from an element. (Inherited from TouchDevice.)
Protected method | SetActiveSource | Sets the PresentationSource that is reporting input for this device. (Inherited from TouchDevice.)
Public method | Synchronize | Forces the TouchDevice to synchronize the user interface with underlying touch points. (Inherited from TouchDevice.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MouseTouchDevice Class
VisualComponents.UX.Shared Namespace


MouseTouchDevice.GetIntermediateTouchPoints Method

MouseTouchDeviceGetIntermediateTouchPoints Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override TouchPointCollection GetIntermediateTouchPoints(
    IInputElement relativeTo
)
public:
virtual TouchPointCollection^ GetIntermediateTouchPoints(
    IInputElement^ relativeTo
) override

Parameters

relativeTo
Type: System.WindowsIInputElement

Return Value

Type: TouchPointCollection

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MouseTouchDevice.GetIntermediateTouchPoints(System.Windows.IInputElement)"]

See Also

Reference

MouseTouchDevice Class
VisualComponents.UX.Shared Namespace


MouseTouchDevice.GetTouchPoint Method

MouseTouchDeviceGetTouchPoint Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override TouchPoint GetTouchPoint(
    IInputElement relativeTo
)
public:
virtual TouchPoint^ GetTouchPoint(
    IInputElement^ relativeTo
) override

Parameters

relativeTo
Type: System.WindowsIInputElement

Return Value

Type: TouchPoint

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MouseTouchDevice.GetTouchPoint(System.Windows.IInputElement)"]

See Also

Reference

MouseTouchDevice Class
VisualComponents.UX.Shared Namespace


MouseTouchDevice.RegisterEvents Method

MouseTouchDeviceRegisterEvents Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void RegisterEvents(
    FrameworkElement root
)
public:
static void RegisterEvents(
    FrameworkElement^ root
)

Parameters

root
Type: System.WindowsFrameworkElement
See Also

Reference

MouseTouchDevice Class
VisualComponents.UX.Shared Namespace


MouseTouchDevice Events

The MouseTouchDevice type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the TouchDevice is added to the input messaging system. (Inherited from TouchDevice.)
Public event | Deactivated | Occurs when the TouchDevice is removed from the input messaging system. (Inherited from TouchDevice.)
Public event | Updated | Occurs when a touch message is sent. (Inherited from TouchDevice.)
Top
See Also

Reference

MouseTouchDevice Class
VisualComponents.UX.Shared Namespace


MultilineStringEditor Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
VisualComponents.UX.SharedMultilineStringEditor

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class MultilineStringEditor : Control
public ref class MultilineStringEditor : public Control

The MultilineStringEditor type exposes the following members.

Constructors
 | Name | Description
Public method | MultilineStringEditor | Initializes a new instance of the MultilineStringEditor class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


MultilineStringEditor Constructor

Initializes a new instance of the MultilineStringEditor class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MultilineStringEditor()
public:
MultilineStringEditor()
See Also

Reference

MultilineStringEditor Class
VisualComponents.UX.Shared Namespace


MultilineStringEditor Properties

The MultilineStringEditor type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

MultilineStringEditor Class
VisualComponents.UX.Shared Namespace


MultilineStringEditor Methods

The MultilineStringEditor type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MultilineStringEditor Class
VisualComponents.UX.Shared Namespace


MultilineStringEditor Events

The MultilineStringEditor type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

MultilineStringEditor Class
VisualComponents.UX.Shared Namespace


MultilineStringProperty Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedEditorProperty
VisualComponents.UX.SharedMultilineStringProperty

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class MultilineStringProperty : EditorProperty
public ref class MultilineStringProperty : public EditorProperty

The MultilineStringProperty type exposes the following members.

Constructors
 | Name | Description
Public method | MultilineStringProperty | Initializes a new instance of the MultilineStringProperty class
Top
Properties
 | Name | Description
Public property | AllowedMaximum | (Inherited from EditorProperty.)
Public property | AllowedMinimum | (Inherited from EditorProperty.)
Public property | AllowedValues | (Inherited from EditorProperty.)
Public property | CanCreateNewValue | (Inherited from EditorProperty.)
Public property | Category | (Inherited from EditorProperty.)
Public property | ConstraintType | (Inherited from EditorProperty.)
Public property | Container | (Inherited from EditorProperty.)
Public property | ContainerExpressionContext | (Inherited from EditorProperty.)
Public property | ContainerObject | Similar to IProperty.Container, but for any object. (Inherited from EditorProperty.)
Public property | CreationTypes | (Inherited from EditorProperty.)
Public property | Description | (Inherited from EditorProperty.)
Public property | DisabledStateToolTip | (Inherited from EditorProperty.)
Public property | DistributionExpression | (Inherited from EditorProperty.)
Public property | Error | (Inherited from EditorProperty.)
Public property | ErrorMessage | (Inherited from EditorProperty.)
Public property | HasDistribution | (Inherited from EditorProperty.)
Public property | History | (Inherited from EditorProperty.)
Public property | Index_ForComboBox | (Inherited from EditorProperty.)
Public property | IsDesignTime | (Inherited from EditorProperty.)
Public property | IsEditable | Helper property since in XAML negating binding value is not possible without using BoolToOppositeConverter (Inherited from EditorProperty.)
Public property | IsEditableInGui | (Inherited from EditorProperty.)
Public property | IsExceptionallyInHome | (Inherited from EditorProperty.)
Public property | IsInternal | (Inherited from EditorProperty.)
Public property | IsLocked | (Inherited from EditorProperty.)
Public property | IsPersistent | (Inherited from EditorProperty.)
Public property | IsQuantityValue | (Inherited from EditorProperty.)
Public property | IsReadOnly | (Inherited from EditorProperty.)
Public property | IsValid | (Inherited from EditorProperty.)
Public property | IsVisible | (Inherited from EditorProperty.)
Public property | IsVisibleDesignTime | (Inherited from EditorProperty.)
Public property | IsVisibleForced | (Inherited from EditorProperty.)
Public property | IsVisibleInGui | IsVisibleInGui is used to bind GUI visibility. Setting this value affects only _isVisibleForcedOff. (Inherited from EditorProperty.)
Public property | Item | (Inherited from EditorProperty.)
Public property | Name | (Inherited from EditorProperty.)
Public property | NonLocalizedName | (Inherited from EditorProperty.)
Public property | Order | (Inherited from EditorProperty.)
Public property | Property | (Inherited from EditorProperty.)
Public property | PropertyDescription | (Inherited from EditorProperty.)
Public property | PropertyType | (Inherited from EditorProperty.)
Public property | Quantity | (Inherited from EditorProperty.)
Public property | ResourceType | In case of having an IUriProperty, this determines if the editor should allow folder selection instead of file selection (Inherited from EditorProperty.)
Public property | RotationSystem | (Inherited from EditorProperty.)
Public property | ShowValuepicker | (Inherited from EditorProperty.)
Public property | TabHeader | (Inherited from EditorProperty.)
Public property | Unit | (Inherited from EditorProperty.)
Public property | Value | (Inherited from EditorProperty.)
Public property | Value_ForComboBox | Helper property, used only by ComboBox. (Inherited from EditorProperty.)
Public property | ValueString | (Inherited from EditorProperty.)
Top
Methods
 | Name | Description
Public method | Associate | (Inherited from EditorProperty.)
Public method | CheckEditableInGui | (Inherited from EditorProperty.)
Protected method | CheckPropertyObjDispose | (Inherited from EditorProperty.)
Public method | CheckRebuild | This happens only on UI changes. If containeris a behavior of feature call evaluate or rebuild to update geometry. (Inherited from EditorProperty.)
Public method | CheckRebuildSmart | (Inherited from EditorProperty.)
Public method | Clone | (Inherited from EditorProperty.)
Public method | CreateAndSetNewValue | (Inherited from EditorProperty.)
Public method | Disassociate | (Inherited from EditorProperty.)
Public method | Dispose | (Inherited from EditorProperty.)
Protected method | Dispose(Boolean) | (Inherited from EditorProperty.)
Public method | EndBatch | (Inherited from EditorProperty.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from EditorProperty.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokePropertyChanged | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedEx | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedValue_Begin | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedValue_Process | (Inherited from EditorProperty.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Note: This is Not just called on IProperty.Value change. It's called by PropertyWrapper::NotifyPropertyChanged with different names (like "Value", "Expression", etc). It's called on rVariable::SetupChanged, on variable flag changes. (Inherited from EditorProperty.)
Public method | PickValue | Execute PickAction and wait for user to click on some object. (Inherited from EditorProperty.)
Public method | PickValueProxy | (Inherited from EditorProperty.)
Public method | SetQuantity | (Inherited from EditorProperty.)
Public method | SetUnitMagnitude | (Inherited from EditorProperty.)
Public method | StartBatch | (Inherited from EditorProperty.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | property changed event (Inherited from EditorProperty.)
Top
Fields
 | Name | Description
Public field | SuppressValueChange | (Inherited from EditorProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


MultilineStringProperty Constructor

Initializes a new instance of the MultilineStringProperty class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MultilineStringProperty(
    IProperty property
)
public:
MultilineStringProperty(
    IProperty^ property
)

Parameters

property
Type: VisualComponents.Create3DIProperty
See Also

Reference

MultilineStringProperty Class
VisualComponents.UX.Shared Namespace


MultilineStringProperty Properties

The MultilineStringProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | (Inherited from EditorProperty.)
Public property | AllowedMinimum | (Inherited from EditorProperty.)
Public property | AllowedValues | (Inherited from EditorProperty.)
Public property | CanCreateNewValue | (Inherited from EditorProperty.)
Public property | Category | (Inherited from EditorProperty.)
Public property | ConstraintType | (Inherited from EditorProperty.)
Public property | Container | (Inherited from EditorProperty.)
Public property | ContainerExpressionContext | (Inherited from EditorProperty.)
Public property | ContainerObject | Similar to IProperty.Container, but for any object. (Inherited from EditorProperty.)
Public property | CreationTypes | (Inherited from EditorProperty.)
Public property | Description | (Inherited from EditorProperty.)
Public property | DisabledStateToolTip | (Inherited from EditorProperty.)
Public property | DistributionExpression | (Inherited from EditorProperty.)
Public property | Error | (Inherited from EditorProperty.)
Public property | ErrorMessage | (Inherited from EditorProperty.)
Public property | HasDistribution | (Inherited from EditorProperty.)
Public property | History | (Inherited from EditorProperty.)
Public property | Index_ForComboBox | (Inherited from EditorProperty.)
Public property | IsDesignTime | (Inherited from EditorProperty.)
Public property | IsEditable | Helper property since in XAML negating binding value is not possible without using BoolToOppositeConverter (Inherited from EditorProperty.)
Public property | IsEditableInGui | (Inherited from EditorProperty.)
Public property | IsExceptionallyInHome | (Inherited from EditorProperty.)
Public property | IsInternal | (Inherited from EditorProperty.)
Public property | IsLocked | (Inherited from EditorProperty.)
Public property | IsPersistent | (Inherited from EditorProperty.)
Public property | IsQuantityValue | (Inherited from EditorProperty.)
Public property | IsReadOnly | (Inherited from EditorProperty.)
Public property | IsValid | (Inherited from EditorProperty.)
Public property | IsVisible | (Inherited from EditorProperty.)
Public property | IsVisibleDesignTime | (Inherited from EditorProperty.)
Public property | IsVisibleForced | (Inherited from EditorProperty.)
Public property | IsVisibleInGui | IsVisibleInGui is used to bind GUI visibility. Setting this value affects only _isVisibleForcedOff. (Inherited from EditorProperty.)
Public property | Item | (Inherited from EditorProperty.)
Public property | Name | (Inherited from EditorProperty.)
Public property | NonLocalizedName | (Inherited from EditorProperty.)
Public property | Order | (Inherited from EditorProperty.)
Public property | Property | (Inherited from EditorProperty.)
Public property | PropertyDescription | (Inherited from EditorProperty.)
Public property | PropertyType | (Inherited from EditorProperty.)
Public property | Quantity | (Inherited from EditorProperty.)
Public property | ResourceType | In case of having an IUriProperty, this determines if the editor should allow folder selection instead of file selection (Inherited from EditorProperty.)
Public property | RotationSystem | (Inherited from EditorProperty.)
Public property | ShowValuepicker | (Inherited from EditorProperty.)
Public property | TabHeader | (Inherited from EditorProperty.)
Public property | Unit | (Inherited from EditorProperty.)
Public property | Value | (Inherited from EditorProperty.)
Public property | Value_ForComboBox | Helper property, used only by ComboBox. (Inherited from EditorProperty.)
Public property | ValueString | (Inherited from EditorProperty.)
Top
See Also

Reference

MultilineStringProperty Class
VisualComponents.UX.Shared Namespace


MultilineStringProperty Methods

The MultilineStringProperty type exposes the following members.

Methods
 | Name | Description
Public method | Associate | (Inherited from EditorProperty.)
Public method | CheckEditableInGui | (Inherited from EditorProperty.)
Protected method | CheckPropertyObjDispose | (Inherited from EditorProperty.)
Public method | CheckRebuild | This happens only on UI changes. If containeris a behavior of feature call evaluate or rebuild to update geometry. (Inherited from EditorProperty.)
Public method | CheckRebuildSmart | (Inherited from EditorProperty.)
Public method | Clone | (Inherited from EditorProperty.)
Public method | CreateAndSetNewValue | (Inherited from EditorProperty.)
Public method | Disassociate | (Inherited from EditorProperty.)
Public method | Dispose | (Inherited from EditorProperty.)
Protected method | Dispose(Boolean) | (Inherited from EditorProperty.)
Public method | EndBatch | (Inherited from EditorProperty.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from EditorProperty.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokePropertyChanged | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedEx | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedValue_Begin | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedValue_Process | (Inherited from EditorProperty.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Note: This is Not just called on IProperty.Value change. It's called by PropertyWrapper::NotifyPropertyChanged with different names (like "Value", "Expression", etc). It's called on rVariable::SetupChanged, on variable flag changes. (Inherited from EditorProperty.)
Public method | PickValue | Execute PickAction and wait for user to click on some object. (Inherited from EditorProperty.)
Public method | PickValueProxy | (Inherited from EditorProperty.)
Public method | SetQuantity | (Inherited from EditorProperty.)
Public method | SetUnitMagnitude | (Inherited from EditorProperty.)
Public method | StartBatch | (Inherited from EditorProperty.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MultilineStringProperty Class
VisualComponents.UX.Shared Namespace


MultilineStringProperty Events

The MultilineStringProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | property changed event (Inherited from EditorProperty.)
Top
See Also

Reference

MultilineStringProperty Class
VisualComponents.UX.Shared Namespace


MultilineStringProperty Fields

The MultilineStringProperty type exposes the following members.

Fields
 | Name | Description
Public field | SuppressValueChange | (Inherited from EditorProperty.)
Top
See Also

Reference

MultilineStringProperty Class
VisualComponents.UX.Shared Namespace


MultiplyConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedMultiplyConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class MultiplyConverter : IMultiValueConverter
public ref class MultiplyConverter : IMultiValueConverter

The MultiplyConverter type exposes the following members.

Constructors
 | Name | Description
Public method | MultiplyConverter | Initializes a new instance of the MultiplyConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


MultiplyConverter Constructor

Initializes a new instance of the MultiplyConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MultiplyConverter()
public:
MultiplyConverter()
See Also

Reference

MultiplyConverter Class
VisualComponents.UX.Shared Namespace


MultiplyConverter Methods

The MultiplyConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

MultiplyConverter Class
VisualComponents.UX.Shared Namespace


MultiplyConverter.Convert Method

MultiplyConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    array<Object^>^ values,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

values
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MultiplyConverter.Convert(System.Object[],System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

MultiplyConverter Class
VisualComponents.UX.Shared Namespace


MultiplyConverter.ConvertBack Method

MultiplyConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
public:
virtual array<Object^>^ ConvertBack(
    Object^ value,
    array<Type^>^ targetTypes,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetTypes
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.MultiplyConverter.ConvertBack(System.Object,System.Type[],System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

MultiplyConverter Class
VisualComponents.UX.Shared Namespace


NaturalStringAscendingComparer Class

Alphanumeric comparer to use with data bindings.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedNaturalStringAscendingComparer

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NaturalStringAscendingComparer : IComparer,
    IComparer<string>
public ref class NaturalStringAscendingComparer : IComparer,
    IComparer<String^>

The NaturalStringAscendingComparer type exposes the following members.

Constructors
 | Name | Description
Public method | NaturalStringAscendingComparer | Initializes a new instance of the NaturalStringAscendingComparer class
Top
Methods
 | Name | Description
Public method | Compare(Object, Object) |
Public method | Compare(String, String) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


NaturalStringAscendingComparer Constructor

Initializes a new instance of the NaturalStringAscendingComparer class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NaturalStringAscendingComparer()
public:
NaturalStringAscendingComparer()
See Also

Reference

NaturalStringAscendingComparer Class
VisualComponents.UX.Shared Namespace


NaturalStringAscendingComparer Methods

The NaturalStringAscendingComparer type exposes the following members.

Methods
 | Name | Description
Public method | Compare(Object, Object) |
Public method | Compare(String, String) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NaturalStringAscendingComparer Class
VisualComponents.UX.Shared Namespace


NaturalStringAscendingComparer.Compare Method

NaturalStringAscendingComparerCompare Method

Overload List
 | Name | Description
Public method | Compare(Object, Object) |
Public method | Compare(String, String) |
Top
See Also

Reference

NaturalStringAscendingComparer Class
VisualComponents.UX.Shared Namespace


NaturalStringAscendingComparer.Compare Method (Object, Object)

NaturalStringAscendingComparerCompare Method (Object, Object)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Compare(
    Object source,
    Object target
)
public:
virtual int Compare(
    Object^ source,
    Object^ target
) sealed

Parameters

source
Type: SystemObject
target
Type: SystemObject

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.NaturalStringAscendingComparer.Compare(System.Object,System.Object)"]

Implements

IComparerCompare(Object, Object)
See Also

Reference

NaturalStringAscendingComparer Class
Compare Overload
VisualComponents.UX.Shared Namespace


NaturalStringAscendingComparer.Compare Method (String, String)

NaturalStringAscendingComparerCompare Method (String, String)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Compare(
    string source,
    string target
)
public:
virtual int Compare(
    String^ source,
    String^ target
) sealed

Parameters

source
Type: SystemString
target
Type: SystemString

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.NaturalStringAscendingComparer.Compare(System.String,System.String)"]

Implements

IComparerTCompare(T, T)
See Also

Reference

NaturalStringAscendingComparer Class
Compare Overload
VisualComponents.UX.Shared Namespace


NaturalStringDescendingComparer Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedNaturalStringDescendingComparer

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NaturalStringDescendingComparer : IComparer,
    IComparer<string>
public ref class NaturalStringDescendingComparer : IComparer,
    IComparer<String^>

The NaturalStringDescendingComparer type exposes the following members.

Constructors
 | Name | Description
Public method | NaturalStringDescendingComparer | Initializes a new instance of the NaturalStringDescendingComparer class
Top
Methods
 | Name | Description
Public method | Compare(Object, Object) |
Public method | Compare(String, String) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


NaturalStringDescendingComparer Constructor

Initializes a new instance of the NaturalStringDescendingComparer class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NaturalStringDescendingComparer()
public:
NaturalStringDescendingComparer()
See Also

Reference

NaturalStringDescendingComparer Class
VisualComponents.UX.Shared Namespace


NaturalStringDescendingComparer Methods

The NaturalStringDescendingComparer type exposes the following members.

Methods
 | Name | Description
Public method | Compare(Object, Object) |
Public method | Compare(String, String) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NaturalStringDescendingComparer Class
VisualComponents.UX.Shared Namespace


NaturalStringDescendingComparer.Compare Method

NaturalStringDescendingComparerCompare Method

Overload List
 | Name | Description
Public method | Compare(Object, Object) |
Public method | Compare(String, String) |
Top
See Also

Reference

NaturalStringDescendingComparer Class
VisualComponents.UX.Shared Namespace


NaturalStringDescendingComparer.Compare Method (Object, Object)

NaturalStringDescendingComparerCompare Method (Object, Object)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Compare(
    Object source,
    Object target
)
public:
virtual int Compare(
    Object^ source,
    Object^ target
) sealed

Parameters

source
Type: SystemObject
target
Type: SystemObject

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.NaturalStringDescendingComparer.Compare(System.Object,System.Object)"]

Implements

IComparerCompare(Object, Object)
See Also

Reference

NaturalStringDescendingComparer Class
Compare Overload
VisualComponents.UX.Shared Namespace


NaturalStringDescendingComparer.Compare Method (String, String)

NaturalStringDescendingComparerCompare Method (String, String)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Compare(
    string source,
    string target
)
public:
virtual int Compare(
    String^ source,
    String^ target
) sealed

Parameters

source
Type: SystemString
target
Type: SystemString

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.NaturalStringDescendingComparer.Compare(System.String,System.String)"]

Implements

IComparerTCompare(T, T)
See Also

Reference

NaturalStringDescendingComparer Class
Compare Overload
VisualComponents.UX.Shared Namespace


NetworkStatus Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedNetworkStatus

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class NetworkStatus
public ref class NetworkStatus abstract sealed

The NetworkStatus type exposes the following members.

Properties
Name | Description
IsAvailable | Gets a Boolean value indicating the current state of Internet connectivity.
Top
Methods
Name | Description
IsNetworkAvailable | Evaluate the online network adapters to determine if at least one of them is capable of connecting to the Internet.
Top
Events
Name | Description
AvailabilityChanged | This event is fired when the overall Internet connectivity changes. All non-Internet adpaters are ignored. If at least one valid Internet connection is "up" then we consider the Internet "available".
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


NetworkStatus Properties

The NetworkStatus type exposes the following members.

Properties
Name | Description
IsAvailable | Gets a Boolean value indicating the current state of Internet connectivity.
Top
See Also

Reference

NetworkStatus Class
VisualComponents.UX.Shared Namespace


NetworkStatus.IsAvailable Property

NetworkStatusIsAvailable Property

Gets a Boolean value indicating the current state of Internet connectivity.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsAvailable { get; }
public:
static property bool IsAvailable {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

NetworkStatus Class
VisualComponents.UX.Shared Namespace


NetworkStatus Methods

The NetworkStatus type exposes the following members.

Methods
Name | Description
IsNetworkAvailable | Evaluate the online network adapters to determine if at least one of them is capable of connecting to the Internet.
Top
See Also

Reference

NetworkStatus Class
VisualComponents.UX.Shared Namespace


NetworkStatus.IsNetworkAvailable Method

NetworkStatusIsNetworkAvailable Method

Evaluate the online network adapters to determine if at least one of them is capable of connecting to the Internet.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsNetworkAvailable()
public:
static bool IsNetworkAvailable()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.NetworkStatus.IsNetworkAvailable"]

See Also

Reference

NetworkStatus Class
VisualComponents.UX.Shared Namespace


NetworkStatus Events

The NetworkStatus type exposes the following members.

Events
Name | Description
AvailabilityChanged | This event is fired when the overall Internet connectivity changes. All non-Internet adpaters are ignored. If at least one valid Internet connection is "up" then we consider the Internet "available".
Top
See Also

Reference

NetworkStatus Class
VisualComponents.UX.Shared Namespace


NetworkStatus.AvailabilityChanged Event

NetworkStatusAvailabilityChanged Event

This event is fired when the overall Internet connectivity changes. All non-Internet adpaters are ignored. If at least one valid Internet connection is "up" then we consider the Internet "available".

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static event NetworkStatusChangedHandler AvailabilityChanged
public:
static  event NetworkStatusChangedHandler^ AvailabilityChanged {
    void add (NetworkStatusChangedHandler^ value);
    void remove (NetworkStatusChangedHandler^ value);
}

Value

Type: VisualComponents.UX.SharedNetworkStatusChangedHandler
See Also

Reference

NetworkStatus Class
VisualComponents.UX.Shared Namespace


NetworkStatusChangedArgs Class

Describes the overall network connectivity of the machine.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.UX.SharedNetworkStatusChangedArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NetworkStatusChangedArgs : EventArgs
public ref class NetworkStatusChangedArgs : public EventArgs

The NetworkStatusChangedArgs type exposes the following members.

Constructors
 | Name | Description
Public method | NetworkStatusChangedArgs | Instantiate a new instance with the given availability.
Top
Properties
 | Name | Description
Public property | IsAvailable | Gets a Boolean value indicating the current state of Internet connectivity.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


NetworkStatusChangedArgs Constructor

Instantiate a new instance with the given availability.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NetworkStatusChangedArgs(
    bool isAvailable
)
public:
NetworkStatusChangedArgs(
    bool isAvailable
)

Parameters

isAvailable
Type: SystemBoolean
See Also

Reference

NetworkStatusChangedArgs Class
VisualComponents.UX.Shared Namespace


NetworkStatusChangedArgs Properties

The NetworkStatusChangedArgs type exposes the following members.

Properties
 | Name | Description
Public property | IsAvailable | Gets a Boolean value indicating the current state of Internet connectivity.
Top
See Also

Reference

NetworkStatusChangedArgs Class
VisualComponents.UX.Shared Namespace


NetworkStatusChangedArgs.IsAvailable Property

NetworkStatusChangedArgsIsAvailable Property

Gets a Boolean value indicating the current state of Internet connectivity.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsAvailable { get; }
public:
property bool IsAvailable {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

NetworkStatusChangedArgs Class
VisualComponents.UX.Shared Namespace


NetworkStatusChangedArgs Methods

The NetworkStatusChangedArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NetworkStatusChangedArgs Class
VisualComponents.UX.Shared Namespace


NetworkStatusChangedHandler Delegate

Define the method signature for network status changes.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public delegate void NetworkStatusChangedHandler(
    Object sender,
    NetworkStatusChangedArgs e
)
public delegate void NetworkStatusChangedHandler(
    Object^ sender,
    NetworkStatusChangedArgs^ e
)

Parameters

sender
Type: SystemObject
e
Type: VisualComponents.UX.SharedNetworkStatusChangedArgs
See Also

Reference

VisualComponents.UX.Shared Namespace


NewFileAction Class

"New File" Action
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedNewFileAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NewFileAction : IResult
public ref class NewFileAction : IResult

The NewFileAction type exposes the following members.

Constructors
 | Name | Description
Public method | NewFileAction | Initializes a new instance of the NewFileAction class
Top
Properties
 | Name | Description
Public property | ClearingLayoutGranted |
 | ForceClear |
Public property | IsDeactivationOnProgress |
Public property | IsOpeningFileOnProgress |
Public property | ShowProgressBarDialog |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | Execute |
Public method | Execute(ActionExecutionContext) |
 | Execute(Boolean, Boolean) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NewFile |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Completed |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


NewFileAction Constructor

Initializes a new instance of the NewFileAction class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NewFileAction()
public:
NewFileAction()
See Also

Reference

NewFileAction Class
VisualComponents.UX.Shared Namespace


NewFileAction Properties

The NewFileAction type exposes the following members.

Properties
 | Name | Description
Public property | ClearingLayoutGranted |
 | ForceClear |
Public property | IsDeactivationOnProgress |
Public property | IsOpeningFileOnProgress |
Public property | ShowProgressBarDialog |
Top
See Also

Reference

NewFileAction Class
VisualComponents.UX.Shared Namespace


NewFileAction.ClearingLayoutGranted Property

NewFileActionClearingLayoutGranted Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ClearingLayoutGranted { get; set; }
public:
property bool ClearingLayoutGranted {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

NewFileAction Class
VisualComponents.UX.Shared Namespace


NewFileAction.ForceClear Property

NewFileActionForceClear Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool ForceClear { get; set; }
public:
static property bool ForceClear {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

NewFileAction Class
VisualComponents.UX.Shared Namespace


NewFileAction.IsDeactivationOnProgress Property

NewFileActionIsDeactivationOnProgress Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsDeactivationOnProgress { get; set; }
public:
property bool IsDeactivationOnProgress {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

NewFileAction Class
VisualComponents.UX.Shared Namespace


NewFileAction.IsOpeningFileOnProgress Property

NewFileActionIsOpeningFileOnProgress Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsOpeningFileOnProgress { get; set; }
public:
property bool IsOpeningFileOnProgress {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

NewFileAction Class
VisualComponents.UX.Shared Namespace


NewFileAction.ShowProgressBarDialog Property

NewFileActionShowProgressBarDialog Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowProgressBarDialog { get; set; }
public:
property bool ShowProgressBarDialog {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

NewFileAction Class
VisualComponents.UX.Shared Namespace


NewFileAction Methods

The NewFileAction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | Execute |
Public method | Execute(ActionExecutionContext) |
 | Execute(Boolean, Boolean) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NewFile |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NewFileAction Class
VisualComponents.UX.Shared Namespace


NewFileAction.Execute Method

NewFileActionExecute Method

Overload List
 | Name | Description
 | Execute |
Public method | Execute(ActionExecutionContext) |
 | Execute(Boolean, Boolean) |
Top
See Also

Reference

NewFileAction Class
VisualComponents.UX.Shared Namespace


NewFileAction.Execute Method

NewFileActionExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void Execute()
public:
static void Execute()
See Also

Reference

NewFileAction Class
Execute Overload
VisualComponents.UX.Shared Namespace


NewFileAction.Execute Method (ActionExecutionContext)

NewFileActionExecute Method (ActionExecutionContext)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    ActionExecutionContext context
)
public:
virtual void Execute(
    ActionExecutionContext^ context
) sealed

Parameters

context
Type: ActionExecutionContext

Implements

IResult.Execute(ActionExecutionContext)
See Also

Reference

NewFileAction Class
Execute Overload
VisualComponents.UX.Shared Namespace


NewFileAction.Execute Method (Boolean, Boolean)

NewFileActionExecute Method (Boolean, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void Execute(
    bool isForced,
    bool showDialog = true
)
public:
static void Execute(
    bool isForced,
    bool showDialog = true
)

Parameters

isForced
Type: SystemBoolean
showDialog (Optional)
Type: SystemBoolean
See Also

Reference

NewFileAction Class
Execute Overload
VisualComponents.UX.Shared Namespace


NewFileAction.NewFile Method

NewFileActionNewFile Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<IResult> NewFile()
public:
IEnumerable<IResult^>^ NewFile()

Return Value

Type: IEnumerableIResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.NewFileAction.NewFile"]

See Also

Reference

NewFileAction Class
VisualComponents.UX.Shared Namespace


NewFileAction Events

The NewFileAction type exposes the following members.

Events
 | Name | Description
Public event | Completed |
Top
See Also

Reference

NewFileAction Class
VisualComponents.UX.Shared Namespace


NewFileAction.Completed Event

NewFileActionCompleted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ResultCompletionEventArgs> Completed
public:
virtual  event EventHandler<ResultCompletionEventArgs^>^ Completed {
    void add (EventHandler<ResultCompletionEventArgs^>^ value);
    void remove (EventHandler<ResultCompletionEventArgs^>^ value);
}

Value

Type: SystemEventHandlerResultCompletionEventArgs

Implements

IResult.Completed
See Also

Reference

NewFileAction Class
VisualComponents.UX.Shared Namespace


NewValueCreationType Class

Placeholder value object for the new value creation types.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedNewValueCreationType

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class NewValueCreationType
public ref class NewValueCreationType sealed

The NewValueCreationType type exposes the following members.

Constructors
 | Name | Description
Public method | NewValueCreationType | Initializes a new instance of the NewValueCreationType class
Top
Properties
 | Name | Description
Public property | Type |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


NewValueCreationType Constructor

Initializes a new instance of the NewValueCreationType class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NewValueCreationType()
public:
NewValueCreationType()
See Also

Reference

NewValueCreationType Class
VisualComponents.UX.Shared Namespace


NewValueCreationType Properties

The NewValueCreationType type exposes the following members.

Properties
 | Name | Description
Public property | Type |
Top
See Also

Reference

NewValueCreationType Class
VisualComponents.UX.Shared Namespace


NewValueCreationType.Type Property

NewValueCreationTypeType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Type { get; set; }
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

NewValueCreationType Class
VisualComponents.UX.Shared Namespace


NewValueCreationType Methods

The NewValueCreationType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NewValueCreationType Class
VisualComponents.UX.Shared Namespace


NodeContextMenuEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.UX.SharedNodeContextMenuEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NodeContextMenuEventArgs : EventArgs
public ref class NodeContextMenuEventArgs : public EventArgs

The NodeContextMenuEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | NodeContextMenuEventArgs | Initializes a new instance of the NodeContextMenuEventArgs class
Top
Properties
 | Name | Description
Public property | CursorLeft |
Public property | CursorTop |
Public property | Handled |
Public property | Node |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


NodeContextMenuEventArgs Constructor

Initializes a new instance of the NodeContextMenuEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NodeContextMenuEventArgs(
    TreeNodeEx node,
    double cursorLeft,
    double cursorTop
)
public:
NodeContextMenuEventArgs(
    TreeNodeEx^ node,
    double cursorLeft,
    double cursorTop
)

Parameters

node
Type: VisualComponents.UX.SharedTreeNodeEx
cursorLeft
Type: SystemDouble
cursorTop
Type: SystemDouble
See Also

Reference

NodeContextMenuEventArgs Class
VisualComponents.UX.Shared Namespace


NodeContextMenuEventArgs Properties

The NodeContextMenuEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | CursorLeft |
Public property | CursorTop |
Public property | Handled |
Public property | Node |
Top
See Also

Reference

NodeContextMenuEventArgs Class
VisualComponents.UX.Shared Namespace


NodeContextMenuEventArgs.CursorLeft Property

NodeContextMenuEventArgsCursorLeft Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double CursorLeft { get; set; }
public:
property double CursorLeft {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

NodeContextMenuEventArgs Class
VisualComponents.UX.Shared Namespace


NodeContextMenuEventArgs.CursorTop Property

NodeContextMenuEventArgsCursorTop Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double CursorTop { get; set; }
public:
property double CursorTop {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

NodeContextMenuEventArgs Class
VisualComponents.UX.Shared Namespace


NodeContextMenuEventArgs.Handled Property

NodeContextMenuEventArgsHandled Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Handled { get; set; }
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

NodeContextMenuEventArgs Class
VisualComponents.UX.Shared Namespace


NodeContextMenuEventArgs.Node Property

NodeContextMenuEventArgsNode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeNodeEx Node { get; set; }
public:
property TreeNodeEx^ Node {
    TreeNodeEx^ get ();
    void set (TreeNodeEx^ value);
}

Property Value

Type: TreeNodeEx
See Also

Reference

NodeContextMenuEventArgs Class
VisualComponents.UX.Shared Namespace


NodeContextMenuEventArgs Methods

The NodeContextMenuEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NodeContextMenuEventArgs Class
VisualComponents.UX.Shared Namespace


NodeEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.UX.SharedNodeEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NodeEventArgs : EventArgs
public ref class NodeEventArgs : public EventArgs

The NodeEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | NodeEventArgs | Initializes a new instance of the NodeEventArgs class
Top
Properties
 | Name | Description
Public property | Node |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


NodeEventArgs Constructor

Initializes a new instance of the NodeEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NodeEventArgs(
    TreeNodeEx node
)
public:
NodeEventArgs(
    TreeNodeEx^ node
)

Parameters

node
Type: VisualComponents.UX.SharedTreeNodeEx
See Also

Reference

NodeEventArgs Class
VisualComponents.UX.Shared Namespace


NodeEventArgs Properties

The NodeEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Node |
Top
See Also

Reference

NodeEventArgs Class
VisualComponents.UX.Shared Namespace


NodeEventArgs.Node Property

NodeEventArgsNode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeNodeEx Node { get; set; }
public:
property TreeNodeEx^ Node {
    TreeNodeEx^ get ();
    void set (TreeNodeEx^ value);
}

Property Value

Type: TreeNodeEx
See Also

Reference

NodeEventArgs Class
VisualComponents.UX.Shared Namespace


NodeEventArgs Methods

The NodeEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NodeEventArgs Class
VisualComponents.UX.Shared Namespace


NodeKeyEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
System.Windows.InputInputEventArgs
System.Windows.InputKeyboardEventArgs
System.Windows.InputKeyEventArgs
VisualComponents.UX.SharedNodeKeyEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NodeKeyEventArgs : KeyEventArgs
public ref class NodeKeyEventArgs : public KeyEventArgs

The NodeKeyEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | NodeKeyEventArgs | Initializes a new instance of the NodeKeyEventArgs class
Top
Properties
 | Name | Description
Public property | DeadCharProcessedKey | Gets the key that is part of dead key composition to create a single combined character. (Inherited from KeyEventArgs.)
Public property | Device | Gets the input device that initiated this event. (Inherited from InputEventArgs.)
Public property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from RoutedEventArgs.)
Public property | ImeProcessedKey | Gets the keyboard key referenced by the event, if the key will be processed by an Input Method Editor (IME). (Inherited from KeyEventArgs.)
Public property | InputSource | Gets the input source that provided this input. (Inherited from KeyEventArgs.)
Public property | IsDown | Gets a value that indicates whether the key referenced by the event is in the down state. (Inherited from KeyEventArgs.)
Public property | IsRepeat | Gets a value that indicates whether the keyboard key referenced by the event is a repeated key. (Inherited from KeyEventArgs.)
Public property | IsToggled | Gets a value that indicates whether the key referenced by the event is in the toggled state. (Inherited from KeyEventArgs.)
Public property | IsUp | Gets a value that indicates whether the key referenced by the event is in the up state. (Inherited from KeyEventArgs.)
Public property | Key | Gets the keyboard key associated with the event. (Inherited from KeyEventArgs.)
Public property | KeyboardDevice | Gets the keyboard device associated with the input event. (Inherited from KeyboardEventArgs.)
Public property | KeyStates | Gets the state of the keyboard key associated with this event. (Inherited from KeyEventArgs.)
Public property | Node |
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)
Public property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from RoutedEventArgs.)
Public property | Source | Gets or sets a reference to the object that raised the event. (Inherited from RoutedEventArgs.)
Public property | SystemKey | Gets the keyboard key referenced by the event, if the key will be processed by the system. (Inherited from KeyEventArgs.)
Public property | Timestamp | Gets the time when this event occurred. (Inherited from InputEventArgs.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokeEventHandler | Invokes event handlers in a type-specific way, which can increase event system efficiency. (Inherited from KeyEventArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnSetSource | When overridden in a derived class, provides a notification callback entry point whenever the value of the Source property of an instance changes. (Inherited from RoutedEventArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


NodeKeyEventArgs Constructor

Initializes a new instance of the NodeKeyEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NodeKeyEventArgs(
    TreeNodeEx node,
    KeyboardDevice keyboard,
    PresentationSource inputSource,
    int timestamp,
    Key key
)
public:
NodeKeyEventArgs(
    TreeNodeEx^ node,
    KeyboardDevice^ keyboard,
    PresentationSource^ inputSource,
    int timestamp,
    Key key
)

Parameters

node
Type: VisualComponents.UX.SharedTreeNodeEx
keyboard
Type: System.Windows.InputKeyboardDevice
inputSource
Type: System.WindowsPresentationSource
timestamp
Type: SystemInt32
key
Type: System.Windows.InputKey
See Also

Reference

NodeKeyEventArgs Class
VisualComponents.UX.Shared Namespace


NodeKeyEventArgs Properties

The NodeKeyEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | DeadCharProcessedKey | Gets the key that is part of dead key composition to create a single combined character. (Inherited from KeyEventArgs.)
Public property | Device | Gets the input device that initiated this event. (Inherited from InputEventArgs.)
Public property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from RoutedEventArgs.)
Public property | ImeProcessedKey | Gets the keyboard key referenced by the event, if the key will be processed by an Input Method Editor (IME). (Inherited from KeyEventArgs.)
Public property | InputSource | Gets the input source that provided this input. (Inherited from KeyEventArgs.)
Public property | IsDown | Gets a value that indicates whether the key referenced by the event is in the down state. (Inherited from KeyEventArgs.)
Public property | IsRepeat | Gets a value that indicates whether the keyboard key referenced by the event is a repeated key. (Inherited from KeyEventArgs.)
Public property | IsToggled | Gets a value that indicates whether the key referenced by the event is in the toggled state. (Inherited from KeyEventArgs.)
Public property | IsUp | Gets a value that indicates whether the key referenced by the event is in the up state. (Inherited from KeyEventArgs.)
Public property | Key | Gets the keyboard key associated with the event. (Inherited from KeyEventArgs.)
Public property | KeyboardDevice | Gets the keyboard device associated with the input event. (Inherited from KeyboardEventArgs.)
Public property | KeyStates | Gets the state of the keyboard key associated with this event. (Inherited from KeyEventArgs.)
Public property | Node |
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)
Public property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from RoutedEventArgs.)
Public property | Source | Gets or sets a reference to the object that raised the event. (Inherited from RoutedEventArgs.)
Public property | SystemKey | Gets the keyboard key referenced by the event, if the key will be processed by the system. (Inherited from KeyEventArgs.)
Public property | Timestamp | Gets the time when this event occurred. (Inherited from InputEventArgs.)
Top
See Also

Reference

NodeKeyEventArgs Class
VisualComponents.UX.Shared Namespace


NodeKeyEventArgs.Node Property

NodeKeyEventArgsNode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeNodeEx Node { get; set; }
public:
property TreeNodeEx^ Node {
    TreeNodeEx^ get ();
    void set (TreeNodeEx^ value);
}

Property Value

Type: TreeNodeEx
See Also

Reference

NodeKeyEventArgs Class
VisualComponents.UX.Shared Namespace


NodeKeyEventArgs Methods

The NodeKeyEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokeEventHandler | Invokes event handlers in a type-specific way, which can increase event system efficiency. (Inherited from KeyEventArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnSetSource | When overridden in a derived class, provides a notification callback entry point whenever the value of the Source property of an instance changes. (Inherited from RoutedEventArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NodeKeyEventArgs Class
VisualComponents.UX.Shared Namespace


NodeMouseButtonEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
System.Windows.InputInputEventArgs
System.Windows.InputMouseEventArgs
System.Windows.InputMouseButtonEventArgs
VisualComponents.UX.SharedNodeMouseButtonEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NodeMouseButtonEventArgs : MouseButtonEventArgs
public ref class NodeMouseButtonEventArgs : public MouseButtonEventArgs

The NodeMouseButtonEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | NodeMouseButtonEventArgs | Initializes a new instance of the NodeMouseButtonEventArgs class
Top
Properties
 | Name | Description
Public property | ButtonState | Gets the state of the button associated with the event. (Inherited from MouseButtonEventArgs.)
Public property | ChangedButton | Gets the button associated with the event. (Inherited from MouseButtonEventArgs.)
Public property | ClickCount | Gets the number of times the button was clicked. (Inherited from MouseButtonEventArgs.)
Public property | Device | Gets the input device that initiated this event. (Inherited from InputEventArgs.)
Public property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from RoutedEventArgs.)
Public property | LeftButton | Gets the current state of the left mouse button. (Inherited from MouseEventArgs.)
Public property | MiddleButton | Gets the current state of the middle mouse button. (Inherited from MouseEventArgs.)
Public property | MouseDevice | Gets the mouse device associated with this event. (Inherited from MouseEventArgs.)
Public property | Node |
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)
Public property | RightButton | Gets the current state of the right mouse button. (Inherited from MouseEventArgs.)
Public property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from RoutedEventArgs.)
Public property | Source | Gets or sets a reference to the object that raised the event. (Inherited from RoutedEventArgs.)
Public property | StylusDevice | Gets the stylus device associated with this event. (Inherited from MouseEventArgs.)
Public property | Timestamp | Gets the time when this event occurred. (Inherited from InputEventArgs.)
Public property | XButton1 | Gets the current state of the first extended mouse button. (Inherited from MouseEventArgs.)
Public property | XButton2 | Gets the state of the second extended mouse button. (Inherited from MouseEventArgs.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPosition | Returns the position of the mouse pointer relative to the specified element. (Inherited from MouseEventArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokeEventHandler | Invokes event handlers in a type-specific way, which can increase event system efficiency. (Inherited from MouseButtonEventArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnSetSource | When overridden in a derived class, provides a notification callback entry point whenever the value of the Source property of an instance changes. (Inherited from RoutedEventArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


NodeMouseButtonEventArgs Constructor

Initializes a new instance of the NodeMouseButtonEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NodeMouseButtonEventArgs(
    TreeNodeEx node,
    MouseDevice mouse,
    int timestamp,
    MouseButton button,
    StylusDevice stylusDevice
)
public:
NodeMouseButtonEventArgs(
    TreeNodeEx^ node,
    MouseDevice^ mouse,
    int timestamp,
    MouseButton button,
    StylusDevice^ stylusDevice
)

Parameters

node
Type: VisualComponents.UX.SharedTreeNodeEx
mouse
Type: System.Windows.InputMouseDevice
timestamp
Type: SystemInt32
button
Type: System.Windows.InputMouseButton
stylusDevice
Type: System.Windows.InputStylusDevice
See Also

Reference

NodeMouseButtonEventArgs Class
VisualComponents.UX.Shared Namespace


NodeMouseButtonEventArgs Properties

The NodeMouseButtonEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ButtonState | Gets the state of the button associated with the event. (Inherited from MouseButtonEventArgs.)
Public property | ChangedButton | Gets the button associated with the event. (Inherited from MouseButtonEventArgs.)
Public property | ClickCount | Gets the number of times the button was clicked. (Inherited from MouseButtonEventArgs.)
Public property | Device | Gets the input device that initiated this event. (Inherited from InputEventArgs.)
Public property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from RoutedEventArgs.)
Public property | LeftButton | Gets the current state of the left mouse button. (Inherited from MouseEventArgs.)
Public property | MiddleButton | Gets the current state of the middle mouse button. (Inherited from MouseEventArgs.)
Public property | MouseDevice | Gets the mouse device associated with this event. (Inherited from MouseEventArgs.)
Public property | Node |
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)
Public property | RightButton | Gets the current state of the right mouse button. (Inherited from MouseEventArgs.)
Public property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from RoutedEventArgs.)
Public property | Source | Gets or sets a reference to the object that raised the event. (Inherited from RoutedEventArgs.)
Public property | StylusDevice | Gets the stylus device associated with this event. (Inherited from MouseEventArgs.)
Public property | Timestamp | Gets the time when this event occurred. (Inherited from InputEventArgs.)
Public property | XButton1 | Gets the current state of the first extended mouse button. (Inherited from MouseEventArgs.)
Public property | XButton2 | Gets the state of the second extended mouse button. (Inherited from MouseEventArgs.)
Top
See Also

Reference

NodeMouseButtonEventArgs Class
VisualComponents.UX.Shared Namespace


NodeMouseButtonEventArgs.Node Property

NodeMouseButtonEventArgsNode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeNodeEx Node { get; set; }
public:
property TreeNodeEx^ Node {
    TreeNodeEx^ get ();
    void set (TreeNodeEx^ value);
}

Property Value

Type: TreeNodeEx
See Also

Reference

NodeMouseButtonEventArgs Class
VisualComponents.UX.Shared Namespace


NodeMouseButtonEventArgs Methods

The NodeMouseButtonEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPosition | Returns the position of the mouse pointer relative to the specified element. (Inherited from MouseEventArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokeEventHandler | Invokes event handlers in a type-specific way, which can increase event system efficiency. (Inherited from MouseButtonEventArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnSetSource | When overridden in a derived class, provides a notification callback entry point whenever the value of the Source property of an instance changes. (Inherited from RoutedEventArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NodeMouseButtonEventArgs Class
VisualComponents.UX.Shared Namespace


NodeMouseEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
System.Windows.InputInputEventArgs
System.Windows.InputMouseEventArgs
VisualComponents.UX.SharedNodeMouseEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NodeMouseEventArgs : MouseEventArgs
public ref class NodeMouseEventArgs : public MouseEventArgs

The NodeMouseEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | NodeMouseEventArgs | Initializes a new instance of the NodeMouseEventArgs class
Top
Properties
 | Name | Description
Public property | Device | Gets the input device that initiated this event. (Inherited from InputEventArgs.)
Public property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from RoutedEventArgs.)
Public property | LeftButton | Gets the current state of the left mouse button. (Inherited from MouseEventArgs.)
Public property | MiddleButton | Gets the current state of the middle mouse button. (Inherited from MouseEventArgs.)
Public property | MouseDevice | Gets the mouse device associated with this event. (Inherited from MouseEventArgs.)
Public property | Node |
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)
Public property | RightButton | Gets the current state of the right mouse button. (Inherited from MouseEventArgs.)
Public property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from RoutedEventArgs.)
Public property | Source | Gets or sets a reference to the object that raised the event. (Inherited from RoutedEventArgs.)
Public property | StylusDevice | Gets the stylus device associated with this event. (Inherited from MouseEventArgs.)
Public property | Timestamp | Gets the time when this event occurred. (Inherited from InputEventArgs.)
Public property | XButton1 | Gets the current state of the first extended mouse button. (Inherited from MouseEventArgs.)
Public property | XButton2 | Gets the state of the second extended mouse button. (Inherited from MouseEventArgs.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPosition | Returns the position of the mouse pointer relative to the specified element. (Inherited from MouseEventArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokeEventHandler | Invokes event handlers in a type-specific way, which can increase event system efficiency. (Inherited from MouseEventArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnSetSource | When overridden in a derived class, provides a notification callback entry point whenever the value of the Source property of an instance changes. (Inherited from RoutedEventArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


NodeMouseEventArgs Constructor

Initializes a new instance of the NodeMouseEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NodeMouseEventArgs(
    TreeNodeEx node,
    MouseDevice mouse,
    int timestamp,
    StylusDevice stylusDevice
)
public:
NodeMouseEventArgs(
    TreeNodeEx^ node,
    MouseDevice^ mouse,
    int timestamp,
    StylusDevice^ stylusDevice
)

Parameters

node
Type: VisualComponents.UX.SharedTreeNodeEx
mouse
Type: System.Windows.InputMouseDevice
timestamp
Type: SystemInt32
stylusDevice
Type: System.Windows.InputStylusDevice
See Also

Reference

NodeMouseEventArgs Class
VisualComponents.UX.Shared Namespace


NodeMouseEventArgs Properties

The NodeMouseEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Device | Gets the input device that initiated this event. (Inherited from InputEventArgs.)
Public property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from RoutedEventArgs.)
Public property | LeftButton | Gets the current state of the left mouse button. (Inherited from MouseEventArgs.)
Public property | MiddleButton | Gets the current state of the middle mouse button. (Inherited from MouseEventArgs.)
Public property | MouseDevice | Gets the mouse device associated with this event. (Inherited from MouseEventArgs.)
Public property | Node |
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)
Public property | RightButton | Gets the current state of the right mouse button. (Inherited from MouseEventArgs.)
Public property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from RoutedEventArgs.)
Public property | Source | Gets or sets a reference to the object that raised the event. (Inherited from RoutedEventArgs.)
Public property | StylusDevice | Gets the stylus device associated with this event. (Inherited from MouseEventArgs.)
Public property | Timestamp | Gets the time when this event occurred. (Inherited from InputEventArgs.)
Public property | XButton1 | Gets the current state of the first extended mouse button. (Inherited from MouseEventArgs.)
Public property | XButton2 | Gets the state of the second extended mouse button. (Inherited from MouseEventArgs.)
Top
See Also

Reference

NodeMouseEventArgs Class
VisualComponents.UX.Shared Namespace


NodeMouseEventArgs.Node Property

NodeMouseEventArgsNode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeNodeEx Node { get; set; }
public:
property TreeNodeEx^ Node {
    TreeNodeEx^ get ();
    void set (TreeNodeEx^ value);
}

Property Value

Type: TreeNodeEx
See Also

Reference

NodeMouseEventArgs Class
VisualComponents.UX.Shared Namespace


NodeMouseEventArgs Methods

The NodeMouseEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPosition | Returns the position of the mouse pointer relative to the specified element. (Inherited from MouseEventArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokeEventHandler | Invokes event handlers in a type-specific way, which can increase event system efficiency. (Inherited from MouseEventArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnSetSource | When overridden in a derived class, provides a notification callback entry point whenever the value of the Source property of an instance changes. (Inherited from RoutedEventArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NodeMouseEventArgs Class
VisualComponents.UX.Shared Namespace


NodePropertyChangedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelPropertyChangedEventArgs
VisualComponents.UX.SharedNodePropertyChangedEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NodePropertyChangedEventArgs : PropertyChangedEventArgs
public ref class NodePropertyChangedEventArgs : public PropertyChangedEventArgs

The NodePropertyChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | NodePropertyChangedEventArgs | Initializes a new instance of the NodePropertyChangedEventArgs class
Top
Properties
 | Name | Description
Public property | Node |
Public property | PropertyName | Gets the name of the property that changed. (Inherited from PropertyChangedEventArgs.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


NodePropertyChangedEventArgs Constructor

Initializes a new instance of the NodePropertyChangedEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NodePropertyChangedEventArgs(
    TreeNodeEx node,
    string propertyName
)
public:
NodePropertyChangedEventArgs(
    TreeNodeEx^ node,
    String^ propertyName
)

Parameters

node
Type: VisualComponents.UX.SharedTreeNodeEx
propertyName
Type: SystemString
See Also

Reference

NodePropertyChangedEventArgs Class
VisualComponents.UX.Shared Namespace


NodePropertyChangedEventArgs Properties

The NodePropertyChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Node |
Public property | PropertyName | Gets the name of the property that changed. (Inherited from PropertyChangedEventArgs.)
Top
See Also

Reference

NodePropertyChangedEventArgs Class
VisualComponents.UX.Shared Namespace


NodePropertyChangedEventArgs.Node Property

NodePropertyChangedEventArgsNode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TreeNodeEx Node { get; set; }
public:
property TreeNodeEx^ Node {
    TreeNodeEx^ get ();
    void set (TreeNodeEx^ value);
}

Property Value

Type: TreeNodeEx
See Also

Reference

NodePropertyChangedEventArgs Class
VisualComponents.UX.Shared Namespace


NodePropertyChangedEventArgs Methods

The NodePropertyChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NodePropertyChangedEventArgs Class
VisualComponents.UX.Shared Namespace


NodesPanelEx Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsPanel
NodesPanel
VisualComponents.UX.SharedNodesPanelEx

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NodesPanelEx : NodesPanel
public ref class NodesPanelEx : public NodesPanel

The NodesPanelEx type exposes the following members.

Constructors
 | Name | Description
Public method | NodesPanelEx | Initializes a new instance of the NodesPanelEx class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | HasLogicalOrientationPublic | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | LogicalOrientationPublic | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Protected property | ScrollInfo | (Inherited from NodesPanel.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Tree | (Inherited from NodesPanel.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | VisibleNodes | (Inherited from NodesPanel.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | (Overrides NodesPanel.ArrangeOverride(Size).)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | (Overrides NodesPanel.MeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | (Inherited from NodesPanel.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | (Overrides UIElementOnMouseWheel(MouseWheelEventArgs).)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | RenderNode | (Inherited from NodesPanel.)
Public method | ResetCachedScrollInfo | (Inherited from NodesPanel.)
Public method | ResetNodes | (Inherited from NodesPanel.)
Public method | ResetNodes(Boolean) | (Inherited from NodesPanel.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Protected method | UpdateScrollInfo | (Overrides NodesPanel.UpdateScrollInfo(Int32, Double).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | ProcessMouseWheel |
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | ScrollInfoUpdated |
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


NodesPanelEx Constructor

Initializes a new instance of the NodesPanelEx class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NodesPanelEx()
public:
NodesPanelEx()
See Also

Reference

NodesPanelEx Class
VisualComponents.UX.Shared Namespace


NodesPanelEx Properties

The NodesPanelEx type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | HasLogicalOrientationPublic | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | LogicalOrientationPublic | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Protected property | ScrollInfo | (Inherited from NodesPanel.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Tree | (Inherited from NodesPanel.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | VisibleNodes | (Inherited from NodesPanel.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

NodesPanelEx Class
VisualComponents.UX.Shared Namespace


NodesPanelEx Methods

The NodesPanelEx type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | (Overrides NodesPanel.ArrangeOverride(Size).)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | (Overrides NodesPanel.MeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | (Inherited from NodesPanel.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | (Overrides UIElementOnMouseWheel(MouseWheelEventArgs).)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Protected method | RenderNode | (Inherited from NodesPanel.)
Public method | ResetCachedScrollInfo | (Inherited from NodesPanel.)
Public method | ResetNodes | (Inherited from NodesPanel.)
Public method | ResetNodes(Boolean) | (Inherited from NodesPanel.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Protected method | UpdateScrollInfo | (Overrides NodesPanel.UpdateScrollInfo(Int32, Double).)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NodesPanelEx Class
VisualComponents.UX.Shared Namespace


NodesPanelEx.ArrangeOverride Method

NodesPanelExArrangeOverride Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
protected:
virtual Size ArrangeOverride(
    Size finalSize
) override

Parameters

finalSize
Type: System.WindowsSize

Return Value

Type: Size

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.NodesPanelEx.ArrangeOverride(System.Windows.Size)"]

See Also

Reference

NodesPanelEx Class
VisualComponents.UX.Shared Namespace


NodesPanelEx.MeasureOverride Method

NodesPanelExMeasureOverride Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Size MeasureOverride(
    Size availableSize
)
protected:
virtual Size MeasureOverride(
    Size availableSize
) override

Parameters

availableSize
Type: System.WindowsSize

Return Value

Type: Size

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.NodesPanelEx.MeasureOverride(System.Windows.Size)"]

See Also

Reference

NodesPanelEx Class
VisualComponents.UX.Shared Namespace


NodesPanelEx.OnMouseWheel Method

NodesPanelExOnMouseWheel Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnMouseWheel(
    MouseWheelEventArgs e
)
protected:
virtual void OnMouseWheel(
    MouseWheelEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputMouseWheelEventArgs
See Also

Reference

NodesPanelEx Class
VisualComponents.UX.Shared Namespace


NodesPanelEx.UpdateScrollInfo Method

NodesPanelExUpdateScrollInfo Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void UpdateScrollInfo(
    int totalNodeCount,
    double finalWidth
)
protected:
virtual void UpdateScrollInfo(
    int totalNodeCount,
    double finalWidth
) override

Parameters

totalNodeCount
Type: SystemInt32
finalWidth
Type: SystemDouble
See Also

Reference

NodesPanelEx Class
VisualComponents.UX.Shared Namespace


NodesPanelEx Events

The NodesPanelEx type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | ProcessMouseWheel |
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | ScrollInfoUpdated |
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

NodesPanelEx Class
VisualComponents.UX.Shared Namespace


NodesPanelEx.ProcessMouseWheel Event

NodesPanelExProcessMouseWheel Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event MouseWheelEventHandler ProcessMouseWheel
public:
 event MouseWheelEventHandler^ ProcessMouseWheel {
    void add (MouseWheelEventHandler^ value);
    void remove (MouseWheelEventHandler^ value);
}

Value

Type: System.Windows.InputMouseWheelEventHandler
See Also

Reference

NodesPanelEx Class
VisualComponents.UX.Shared Namespace


NodesPanelEx.ScrollInfoUpdated Event

NodesPanelExScrollInfoUpdated Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler ScrollInfoUpdated
public:
 event EventHandler^ ScrollInfoUpdated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

NodesPanelEx Class
VisualComponents.UX.Shared Namespace


NonTopmostPopup Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.Controls.PrimitivesPopup
VisualComponents.UX.SharedNonTopmostPopup

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NonTopmostPopup : Popup
public ref class NonTopmostPopup : public Popup

The NonTopmostPopup type exposes the following members.

Constructors
 | Name | Description
Public method | NonTopmostPopup | ctor
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a Popup control can contain transparent content. (Inherited from Popup.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Child | Gets or sets the content of the Popup control. (Inherited from Popup.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | CustomPopupPlacementCallback | Gets or sets a delegate handler method that positions the Popup control. (Inherited from Popup.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasDropShadow | Gets a value that indicates whether a Popup is displayed with a drop shadow effect. (Inherited from Popup.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalOffset | Get or sets the horizontal distance between the target origin and the popup alignment point. (Inherited from Popup.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsOpen | Gets or sets a value that indicates whether the Popup is visible. (Inherited from Popup.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTopmost | Get/Set IsTopmost
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that you can use to access the logical child elements of the Popup control. (Inherited from Popup.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | Placement | Gets or sets the orientation of the Popup control when the control opens, and specifies the behavior of the Popup control when it overlaps screen boundaries. (Inherited from Popup.)
Public property | PlacementRectangle | Gets or sets the rectangle relative to which the Popup control is positioned when it opens. (Inherited from Popup.)
Public property | PlacementTarget | Gets or sets the element relative to which the Popup is positioned when it opens. (Inherited from Popup.)
Public property | PopupAnimation | Gets or sets an animation for the opening and closing of a Popup control. (Inherited from Popup.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | StaysOpen | Gets or sets a value that indicates whether the Popup control closes when the control is no longer in focus. (Inherited from Popup.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalOffset | Gets or sets the vertical distance between the target origin and the popup alignment point. (Inherited from Popup.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns the logical parent of a Popup. (Inherited from Popup.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Determines the required size of the Popup content within the visual tree of the logical parent. (Inherited from Popup.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Responds when the value of the IsOpen property changes from to to . (Inherited from Popup.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnOpened | (Overrides PopupOnOpened(EventArgs).)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Provides class handling for the PreviewMouseLeftButtonDown event. (Inherited from Popup.)
Protected method | OnPreviewMouseLeftButtonUp | Provides class handling for the PreviewMouseLeftButtonUp event. (Inherited from Popup.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Provides class handling for the PreviewMouseRightButtonUp event. (Inherited from Popup.)
Protected method | OnPreviewMouseRightButtonUp | Provides class handling for the PreviewMouseRightButtonDown event. (Inherited from Popup.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | Closed | Occurs when the IsOpen property changes to . (Inherited from Popup.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | Opened | Occurs when the IsOpen property changes to . (Inherited from Popup.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
IsTopmostProperty | Is Topmost dependency property
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


NonTopmostPopup Constructor

ctor

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NonTopmostPopup()
public:
NonTopmostPopup()
See Also

Reference

NonTopmostPopup Class
VisualComponents.UX.Shared Namespace


NonTopmostPopup Properties

The NonTopmostPopup type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a Popup control can contain transparent content. (Inherited from Popup.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Child | Gets or sets the content of the Popup control. (Inherited from Popup.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | CustomPopupPlacementCallback | Gets or sets a delegate handler method that positions the Popup control. (Inherited from Popup.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasDropShadow | Gets a value that indicates whether a Popup is displayed with a drop shadow effect. (Inherited from Popup.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalOffset | Get or sets the horizontal distance between the target origin and the popup alignment point. (Inherited from Popup.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsOpen | Gets or sets a value that indicates whether the Popup is visible. (Inherited from Popup.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTopmost | Get/Set IsTopmost
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that you can use to access the logical child elements of the Popup control. (Inherited from Popup.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | Placement | Gets or sets the orientation of the Popup control when the control opens, and specifies the behavior of the Popup control when it overlaps screen boundaries. (Inherited from Popup.)
Public property | PlacementRectangle | Gets or sets the rectangle relative to which the Popup control is positioned when it opens. (Inherited from Popup.)
Public property | PlacementTarget | Gets or sets the element relative to which the Popup is positioned when it opens. (Inherited from Popup.)
Public property | PopupAnimation | Gets or sets an animation for the opening and closing of a Popup control. (Inherited from Popup.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | StaysOpen | Gets or sets a value that indicates whether the Popup control closes when the control is no longer in focus. (Inherited from Popup.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalOffset | Gets or sets the vertical distance between the target origin and the popup alignment point. (Inherited from Popup.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

NonTopmostPopup Class
VisualComponents.UX.Shared Namespace


NonTopmostPopup.IsTopmost Property

NonTopmostPopupIsTopmost Property

Get/Set IsTopmost

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsTopmost { get; set; }
public:
property bool IsTopmost {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

NonTopmostPopup Class
VisualComponents.UX.Shared Namespace


NonTopmostPopup Methods

The NonTopmostPopup type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns the logical parent of a Popup. (Inherited from Popup.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Determines the required size of the Popup content within the visual tree of the logical parent. (Inherited from Popup.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Responds when the value of the IsOpen property changes from to to . (Inherited from Popup.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnOpened | (Overrides PopupOnOpened(EventArgs).)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Provides class handling for the PreviewMouseLeftButtonDown event. (Inherited from Popup.)
Protected method | OnPreviewMouseLeftButtonUp | Provides class handling for the PreviewMouseLeftButtonUp event. (Inherited from Popup.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Provides class handling for the PreviewMouseRightButtonUp event. (Inherited from Popup.)
Protected method | OnPreviewMouseRightButtonUp | Provides class handling for the PreviewMouseRightButtonDown event. (Inherited from Popup.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NonTopmostPopup Class
VisualComponents.UX.Shared Namespace


NonTopmostPopup.OnOpened Method

NonTopmostPopupOnOpened Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnOpened(
    EventArgs e
)
protected:
virtual void OnOpened(
    EventArgs^ e
) override

Parameters

e
Type: SystemEventArgs
See Also

Reference

NonTopmostPopup Class
VisualComponents.UX.Shared Namespace


NonTopmostPopup Events

The NonTopmostPopup type exposes the following members.

Events
 | Name | Description
Public event | Closed | Occurs when the IsOpen property changes to . (Inherited from Popup.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | Opened | Occurs when the IsOpen property changes to . (Inherited from Popup.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

NonTopmostPopup Class
VisualComponents.UX.Shared Namespace


NonTopmostPopup Fields

The NonTopmostPopup type exposes the following members.

Fields
Name | Description
IsTopmostProperty | Is Topmost dependency property
Top
See Also

Reference

NonTopmostPopup Class
VisualComponents.UX.Shared Namespace


NonTopmostPopup.IsTopmostProperty Field

NonTopmostPopupIsTopmostProperty Field

Is Topmost dependency property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsTopmostProperty
public:
static initonly DependencyProperty^ IsTopmostProperty

Field Value

Type: DependencyProperty
See Also

Reference

NonTopmostPopup Class
VisualComponents.UX.Shared Namespace


NonTopmostPopup.RECT Structure

NonTopmostPopupRECT Structure

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct RECT
public value class RECT

The NonTopmostPopupRECT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | Bottom |
Public field | Left |
Public field | Right |
Public field | Top |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RECT Methods

The NonTopmostPopupRECT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NonTopmostPopupRECT Structure
VisualComponents.UX.Shared Namespace


RECT Fields

The NonTopmostPopupRECT type exposes the following members.

Fields
 | Name | Description
Public field | Bottom |
Public field | Left |
Public field | Right |
Public field | Top |
Top
See Also

Reference

NonTopmostPopupRECT Structure
VisualComponents.UX.Shared Namespace


NonTopmostPopup.RECT.Bottom Field

NonTopmostPopupRECTBottom Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Bottom
public:
int Bottom

Field Value

Type: Int32
See Also

Reference

NonTopmostPopupRECT Structure
VisualComponents.UX.Shared Namespace


NonTopmostPopup.RECT.Left Field

NonTopmostPopupRECTLeft Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Left
public:
int Left

Field Value

Type: Int32
See Also

Reference

NonTopmostPopupRECT Structure
VisualComponents.UX.Shared Namespace


NonTopmostPopup.RECT.Right Field

NonTopmostPopupRECTRight Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Right
public:
int Right

Field Value

Type: Int32
See Also

Reference

NonTopmostPopupRECT Structure
VisualComponents.UX.Shared Namespace


NonTopmostPopup.RECT.Top Field

NonTopmostPopupRECTTop Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Top
public:
int Top

Field Value

Type: Int32
See Also

Reference

NonTopmostPopupRECT Structure
VisualComponents.UX.Shared Namespace


NoteEditor Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.Controls.PrimitivesButtonBase
System.Windows.ControlsButton
VisualComponents.UX.SharedNoteEditor

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NoteEditor : Button
public ref class NoteEditor : public Button

The NoteEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NoteEditor | Initializes a new instance of the NoteEditor class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | ClickMode | Gets or sets when the Click event occurs. (Inherited from ButtonBase.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | Command | Gets or sets the command to invoke when this button is pressed. (Inherited from ButtonBase.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property. (Inherited from ButtonBase.)
Public property | CommandTarget | Gets or sets the element on which to raise the specified command. (Inherited from ButtonBase.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsCancel | Gets or sets a value that indicates whether a Button is a Cancel button. A user can activate the Cancel button by pressing the ESC key. (Inherited from Button.)
Public property | IsDefault | Gets or sets a value that indicates whether a Button is the default button. A user invokes the default button by pressing the ENTER key. (Inherited from Button.)
Public property | IsDefaulted | Gets a value that indicates whether a Button is the button that is activated when a user presses ENTER. (Inherited from Button.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets the value of the IsEnabled property. (Inherited from ButtonBase.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsPressed | Gets a value that indicates whether a ButtonBase is currently activated. (Inherited from ButtonBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Responds when the AccessKey for this control is called. (Inherited from ButtonBase.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClick | Called when a Button is clicked. (Inherited from Button.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates an appropriate ButtonAutomationPeer for this control as part of the WPF infrastructure. (Inherited from Button.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsPressedChanged | Called when the IsPressed property changes. (Inherited from ButtonBase.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Provides class handling for the KeyDown routed event that occurs when the user presses a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnKeyUp | Provides class handling for the KeyUp routed event that occurs when the user releases a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Called when an element loses keyboard focus. (Inherited from ButtonBase.)
Protected method | OnLostMouseCapture | Provides class handling for the LostMouseCapture routed event that occurs when this control is no longer receiving mouse event messages. (Inherited from ButtonBase.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Provides class handling for the ClickMode routed event that occurs when the mouse enters this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeave | Provides class handling for the MouseLeave routed event that occurs when the mouse leaves an element. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonDown | Provides class handling for the MouseLeftButtonDown routed event that occurs when the left mouse button is pressed while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonUp | Provides class handling for the MouseLeftButtonUp routed event that occurs when the left mouse button is released while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseMove | Provides class handling for the MouseMove routed event that occurs when the mouse pointer moves while over this element. (Inherited from ButtonBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Called when the rendered size of a control changes. (Inherited from ButtonBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | Click | Occurs when a Button is clicked. (Inherited from ButtonBase.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


NoteEditor Constructor

Initializes a new instance of the NoteEditor class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NoteEditor()
public:
NoteEditor()
See Also

Reference

NoteEditor Class
VisualComponents.UX.Shared Namespace


NoteEditor Properties

The NoteEditor type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | ClickMode | Gets or sets when the Click event occurs. (Inherited from ButtonBase.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | Command | Gets or sets the command to invoke when this button is pressed. (Inherited from ButtonBase.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property. (Inherited from ButtonBase.)
Public property | CommandTarget | Gets or sets the element on which to raise the specified command. (Inherited from ButtonBase.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsCancel | Gets or sets a value that indicates whether a Button is a Cancel button. A user can activate the Cancel button by pressing the ESC key. (Inherited from Button.)
Public property | IsDefault | Gets or sets a value that indicates whether a Button is the default button. A user invokes the default button by pressing the ENTER key. (Inherited from Button.)
Public property | IsDefaulted | Gets a value that indicates whether a Button is the button that is activated when a user presses ENTER. (Inherited from Button.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets the value of the IsEnabled property. (Inherited from ButtonBase.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsPressed | Gets a value that indicates whether a ButtonBase is currently activated. (Inherited from ButtonBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

NoteEditor Class
VisualComponents.UX.Shared Namespace


NoteEditor Methods

The NoteEditor type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Responds when the AccessKey for this control is called. (Inherited from ButtonBase.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClick | Called when a Button is clicked. (Inherited from Button.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates an appropriate ButtonAutomationPeer for this control as part of the WPF infrastructure. (Inherited from Button.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsPressedChanged | Called when the IsPressed property changes. (Inherited from ButtonBase.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Provides class handling for the KeyDown routed event that occurs when the user presses a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnKeyUp | Provides class handling for the KeyUp routed event that occurs when the user releases a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Called when an element loses keyboard focus. (Inherited from ButtonBase.)
Protected method | OnLostMouseCapture | Provides class handling for the LostMouseCapture routed event that occurs when this control is no longer receiving mouse event messages. (Inherited from ButtonBase.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Provides class handling for the ClickMode routed event that occurs when the mouse enters this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeave | Provides class handling for the MouseLeave routed event that occurs when the mouse leaves an element. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonDown | Provides class handling for the MouseLeftButtonDown routed event that occurs when the left mouse button is pressed while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonUp | Provides class handling for the MouseLeftButtonUp routed event that occurs when the left mouse button is released while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseMove | Provides class handling for the MouseMove routed event that occurs when the mouse pointer moves while over this element. (Inherited from ButtonBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Called when the rendered size of a control changes. (Inherited from ButtonBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NoteEditor Class
VisualComponents.UX.Shared Namespace


NoteEditor.OnApplyTemplate Method

NoteEditorOnApplyTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

NoteEditor Class
VisualComponents.UX.Shared Namespace


NoteEditor Events

The NoteEditor type exposes the following members.

Events
 | Name | Description
Public event | Click | Occurs when a Button is clicked. (Inherited from ButtonBase.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

NoteEditor Class
VisualComponents.UX.Shared Namespace


NoteEditorView Class

NoteEditorView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedNoteEditorView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NoteEditorView : UserControl,
    IComponentConnector
public ref class NoteEditorView : public UserControl,
    IComponentConnector

The NoteEditorView type exposes the following members.

Constructors
 | Name | Description
Public method | NoteEditorView | Initializes a new instance of the NoteEditorView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


NoteEditorView Constructor

Initializes a new instance of the NoteEditorView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NoteEditorView()
public:
NoteEditorView()
See Also

Reference

NoteEditorView Class
VisualComponents.UX.Shared Namespace


NoteEditorView Properties

The NoteEditorView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

NoteEditorView Class
VisualComponents.UX.Shared Namespace


NoteEditorView Methods

The NoteEditorView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NoteEditorView Class
VisualComponents.UX.Shared Namespace


NoteEditorView.InitializeComponent Method

NoteEditorViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

NoteEditorView Class
VisualComponents.UX.Shared Namespace


NoteEditorView Events

The NoteEditorView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

NoteEditorView Class
VisualComponents.UX.Shared Namespace


NoteProperty Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedEditorProperty
VisualComponents.UX.SharedNoteProperty

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class NoteProperty : EditorProperty
public ref class NoteProperty sealed : public EditorProperty

The NoteProperty type exposes the following members.

Constructors
 | Name | Description
Public method | NoteProperty | Initializes a new instance of the NoteProperty class
Top
Properties
 | Name | Description
Public property | AllowedMaximum | (Inherited from EditorProperty.)
Public property | AllowedMinimum | (Inherited from EditorProperty.)
Public property | AllowedValues | (Inherited from EditorProperty.)
Public property | CanCreateNewValue | (Inherited from EditorProperty.)
Public property | Category | (Inherited from EditorProperty.)
Public property | ConstraintType | (Inherited from EditorProperty.)
Public property | Container | (Inherited from EditorProperty.)
Public property | ContainerExpressionContext | (Inherited from EditorProperty.)
Public property | ContainerObject | Similar to IProperty.Container, but for any object. (Inherited from EditorProperty.)
Public property | CreationTypes | (Inherited from EditorProperty.)
Public property | Description | (Inherited from EditorProperty.)
Public property | DisabledStateToolTip | (Inherited from EditorProperty.)
Public property | DistributionExpression | (Inherited from EditorProperty.)
Public property | Error | (Inherited from EditorProperty.)
Public property | ErrorMessage | (Inherited from EditorProperty.)
Public property | HasDistribution | (Inherited from EditorProperty.)
Public property | History | (Inherited from EditorProperty.)
Public property | Index_ForComboBox | (Inherited from EditorProperty.)
Public property | IsDesignTime | (Inherited from EditorProperty.)
Public property | IsEditable | Helper property since in XAML negating binding value is not possible without using BoolToOppositeConverter (Inherited from EditorProperty.)
Public property | IsEditableInGui | (Inherited from EditorProperty.)
Public property | IsExceptionallyInHome | (Inherited from EditorProperty.)
Public property | IsInternal | (Inherited from EditorProperty.)
Public property | IsLocked | (Inherited from EditorProperty.)
Public property | IsPersistent | (Inherited from EditorProperty.)
Public property | IsQuantityValue | (Inherited from EditorProperty.)
Public property | IsReadOnly | (Inherited from EditorProperty.)
Public property | IsValid | (Inherited from EditorProperty.)
Public property | IsVisible | (Inherited from EditorProperty.)
Public property | IsVisibleDesignTime | (Inherited from EditorProperty.)
Public property | IsVisibleForced | (Inherited from EditorProperty.)
Public property | IsVisibleInGui | IsVisibleInGui is used to bind GUI visibility. Setting this value affects only _isVisibleForcedOff. (Inherited from EditorProperty.)
Public property | Item | (Inherited from EditorProperty.)
Public property | Name | (Inherited from EditorProperty.)
Public property | NonLocalizedName | (Inherited from EditorProperty.)
Public property | Order | (Inherited from EditorProperty.)
Public property | Property | (Inherited from EditorProperty.)
Public property | PropertyDescription | (Inherited from EditorProperty.)
Public property | PropertyType | (Inherited from EditorProperty.)
Public property | Quantity | (Inherited from EditorProperty.)
Public property | ResourceType | In case of having an IUriProperty, this determines if the editor should allow folder selection instead of file selection (Inherited from EditorProperty.)
Public property | RotationSystem | (Inherited from EditorProperty.)
Public property | ShowValuepicker | (Inherited from EditorProperty.)
Public property | TabHeader | (Inherited from EditorProperty.)
Public property | Unit | (Inherited from EditorProperty.)
Public property | Value | (Inherited from EditorProperty.)
Public property | Value_ForComboBox | Helper property, used only by ComboBox. (Inherited from EditorProperty.)
Public property | ValueString | (Inherited from EditorProperty.)
Top
Methods
 | Name | Description
Public method | Associate | (Inherited from EditorProperty.)
Public method | CheckEditableInGui | (Inherited from EditorProperty.)
Public method | CheckRebuild | This happens only on UI changes. If containeris a behavior of feature call evaluate or rebuild to update geometry. (Inherited from EditorProperty.)
Public method | CheckRebuildSmart | (Inherited from EditorProperty.)
Public method | Click |
Public method | Clone | (Inherited from EditorProperty.)
Public method | CreateAndSetNewValue | (Inherited from EditorProperty.)
Public method | Disassociate | (Inherited from EditorProperty.)
Public method | Dispose | (Inherited from EditorProperty.)
Public method | EndBatch | (Inherited from EditorProperty.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PickValue | Execute PickAction and wait for user to click on some object. (Inherited from EditorProperty.)
Public method | PickValueProxy | (Inherited from EditorProperty.)
Public method | SetQuantity | (Inherited from EditorProperty.)
Public method | SetUnitMagnitude | (Inherited from EditorProperty.)
Public method | StartBatch | (Inherited from EditorProperty.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | property changed event (Inherited from EditorProperty.)
Top
Fields
 | Name | Description
Public field | SuppressValueChange | (Inherited from EditorProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


NoteProperty Constructor

Initializes a new instance of the NoteProperty class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NoteProperty(
    IProperty property
)
public:
NoteProperty(
    IProperty^ property
)

Parameters

property
Type: VisualComponents.Create3DIProperty
See Also

Reference

NoteProperty Class
VisualComponents.UX.Shared Namespace


NoteProperty Properties

The NoteProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | (Inherited from EditorProperty.)
Public property | AllowedMinimum | (Inherited from EditorProperty.)
Public property | AllowedValues | (Inherited from EditorProperty.)
Public property | CanCreateNewValue | (Inherited from EditorProperty.)
Public property | Category | (Inherited from EditorProperty.)
Public property | ConstraintType | (Inherited from EditorProperty.)
Public property | Container | (Inherited from EditorProperty.)
Public property | ContainerExpressionContext | (Inherited from EditorProperty.)
Public property | ContainerObject | Similar to IProperty.Container, but for any object. (Inherited from EditorProperty.)
Public property | CreationTypes | (Inherited from EditorProperty.)
Public property | Description | (Inherited from EditorProperty.)
Public property | DisabledStateToolTip | (Inherited from EditorProperty.)
Public property | DistributionExpression | (Inherited from EditorProperty.)
Public property | Error | (Inherited from EditorProperty.)
Public property | ErrorMessage | (Inherited from EditorProperty.)
Public property | HasDistribution | (Inherited from EditorProperty.)
Public property | History | (Inherited from EditorProperty.)
Public property | Index_ForComboBox | (Inherited from EditorProperty.)
Public property | IsDesignTime | (Inherited from EditorProperty.)
Public property | IsEditable | Helper property since in XAML negating binding value is not possible without using BoolToOppositeConverter (Inherited from EditorProperty.)
Public property | IsEditableInGui | (Inherited from EditorProperty.)
Public property | IsExceptionallyInHome | (Inherited from EditorProperty.)
Public property | IsInternal | (Inherited from EditorProperty.)
Public property | IsLocked | (Inherited from EditorProperty.)
Public property | IsPersistent | (Inherited from EditorProperty.)
Public property | IsQuantityValue | (Inherited from EditorProperty.)
Public property | IsReadOnly | (Inherited from EditorProperty.)
Public property | IsValid | (Inherited from EditorProperty.)
Public property | IsVisible | (Inherited from EditorProperty.)
Public property | IsVisibleDesignTime | (Inherited from EditorProperty.)
Public property | IsVisibleForced | (Inherited from EditorProperty.)
Public property | IsVisibleInGui | IsVisibleInGui is used to bind GUI visibility. Setting this value affects only _isVisibleForcedOff. (Inherited from EditorProperty.)
Public property | Item | (Inherited from EditorProperty.)
Public property | Name | (Inherited from EditorProperty.)
Public property | NonLocalizedName | (Inherited from EditorProperty.)
Public property | Order | (Inherited from EditorProperty.)
Public property | Property | (Inherited from EditorProperty.)
Public property | PropertyDescription | (Inherited from EditorProperty.)
Public property | PropertyType | (Inherited from EditorProperty.)
Public property | Quantity | (Inherited from EditorProperty.)
Public property | ResourceType | In case of having an IUriProperty, this determines if the editor should allow folder selection instead of file selection (Inherited from EditorProperty.)
Public property | RotationSystem | (Inherited from EditorProperty.)
Public property | ShowValuepicker | (Inherited from EditorProperty.)
Public property | TabHeader | (Inherited from EditorProperty.)
Public property | Unit | (Inherited from EditorProperty.)
Public property | Value | (Inherited from EditorProperty.)
Public property | Value_ForComboBox | Helper property, used only by ComboBox. (Inherited from EditorProperty.)
Public property | ValueString | (Inherited from EditorProperty.)
Top
See Also

Reference

NoteProperty Class
VisualComponents.UX.Shared Namespace


NoteProperty Methods

The NoteProperty type exposes the following members.

Methods
 | Name | Description
Public method | Associate | (Inherited from EditorProperty.)
Public method | CheckEditableInGui | (Inherited from EditorProperty.)
Public method | CheckRebuild | This happens only on UI changes. If containeris a behavior of feature call evaluate or rebuild to update geometry. (Inherited from EditorProperty.)
Public method | CheckRebuildSmart | (Inherited from EditorProperty.)
Public method | Click |
Public method | Clone | (Inherited from EditorProperty.)
Public method | CreateAndSetNewValue | (Inherited from EditorProperty.)
Public method | Disassociate | (Inherited from EditorProperty.)
Public method | Dispose | (Inherited from EditorProperty.)
Public method | EndBatch | (Inherited from EditorProperty.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PickValue | Execute PickAction and wait for user to click on some object. (Inherited from EditorProperty.)
Public method | PickValueProxy | (Inherited from EditorProperty.)
Public method | SetQuantity | (Inherited from EditorProperty.)
Public method | SetUnitMagnitude | (Inherited from EditorProperty.)
Public method | StartBatch | (Inherited from EditorProperty.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NoteProperty Class
VisualComponents.UX.Shared Namespace


NoteProperty.Click Method

NotePropertyClick Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Click()
public:
void Click()
See Also

Reference

NoteProperty Class
VisualComponents.UX.Shared Namespace


NoteProperty Events

The NoteProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | property changed event (Inherited from EditorProperty.)
Top
See Also

Reference

NoteProperty Class
VisualComponents.UX.Shared Namespace


NoteProperty Fields

The NoteProperty type exposes the following members.

Fields
 | Name | Description
Public field | SuppressValueChange | (Inherited from EditorProperty.)
Top
See Also

Reference

NoteProperty Class
VisualComponents.UX.Shared Namespace


NoteView Class

Interaction logic for NoteService.xaml
NoteView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedNoteView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NoteView : UserControl, IComponentConnector
public ref class NoteView : public UserControl,
    IComponentConnector

The NoteView type exposes the following members.

Constructors
 | Name | Description
Public method | NoteView | Initializes a new instance of the NoteView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


NoteView Constructor

Initializes a new instance of the NoteView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NoteView()
public:
NoteView()
See Also

Reference

NoteView Class
VisualComponents.UX.Shared Namespace


NoteView Properties

The NoteView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

NoteView Class
VisualComponents.UX.Shared Namespace


NoteView Methods

The NoteView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NoteView Class
VisualComponents.UX.Shared Namespace


NoteView.InitializeComponent Method

NoteViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

NoteView Class
VisualComponents.UX.Shared Namespace


NoteView Events

The NoteView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

NoteView Class
VisualComponents.UX.Shared Namespace


NoteViewModel Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
ViewAware
Screen
VisualComponents.UX.SharedNoteViewModel

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class NoteViewModel : Screen,
    INoteViewModel, IHandle<ItemSelectedMessage<ISimComponent>>, IHandle,
    IHandle<SelectedRibbonTabChangedMessage>, INotifyPropertyChanged
public ref class NoteViewModel : public Screen,
    INoteViewModel, IHandle<ItemSelectedMessage<ISimComponent^>^>, IHandle,
    IHandle<SelectedRibbonTabChangedMessage^>, INotifyPropertyChanged

The NoteViewModel type exposes the following members.

Constructors
 | Name | Description
Public method | NoteViewModel | Initializes a new instance of the NoteViewModel class
Top
Properties
 | Name | Description
Protected property | CacheViews | (Inherited from ViewAware.)
Public property | DisplayName | (Inherited from Screen.)
Public property | HasMultipleNotes |
Public property | HasNext |
Public property | HasPrev |
Public property | IsActive | (Inherited from Screen.)
Public property | IsInitialized | (Inherited from Screen.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsVisible |
Public property | NoteName |
Public property | Parent | (Inherited from Screen.)
Public property | Text |
Public property | XPosition |
Public property | YPosition |
Top
Methods
 | Name | Description
Public method | CanClose | (Inherited from Screen.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetView | (Inherited from ViewAware.)
Public method | Handle(ItemSelectedMessageISimComponent) |
Public method | Handle(SelectedRibbonTabChangedMessage) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext |
Public method | MovePrev |
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Protected method | OnActivate | (Inherited from Screen.)
Protected method | OnDeactivate | (Inherited from Screen.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnInitialize | (Inherited from Screen.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Protected method | OnViewAttached | (Inherited from ViewAware.)
Protected method | OnViewLoaded | (Overrides ViewAware.OnViewLoaded(Object).)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ShowNotesInEditor |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryClose | (Inherited from Screen.)
Public method | TryClose(NullableBoolean) | (Inherited from Screen.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from Screen.)
Public event | AttemptingDeactivation | (Inherited from Screen.)
Public event | Deactivated | (Inherited from Screen.)
Public event | PropertyChanged |
Public event | ViewAttached | (Inherited from ViewAware.)
Top
Fields
 | Name | Description
Protected field | Views | (Inherited from ViewAware.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


NoteViewModel Constructor

Initializes a new instance of the NoteViewModel class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NoteViewModel(
    IApplication application,
    IEventAggregator eventAggregator
)
public:
NoteViewModel(
    IApplication^ application,
    IEventAggregator^ eventAggregator
)

Parameters

application
Type: VisualComponents.Create3DIApplication
eventAggregator
Type: IEventAggregator
See Also

Reference

NoteViewModel Class
VisualComponents.UX.Shared Namespace


NoteViewModel Properties

The NoteViewModel type exposes the following members.

Properties
 | Name | Description
Protected property | CacheViews | (Inherited from ViewAware.)
Public property | DisplayName | (Inherited from Screen.)
Public property | HasMultipleNotes |
Public property | HasNext |
Public property | HasPrev |
Public property | IsActive | (Inherited from Screen.)
Public property | IsInitialized | (Inherited from Screen.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsVisible |
Public property | NoteName |
Public property | Parent | (Inherited from Screen.)
Public property | Text |
Public property | XPosition |
Public property | YPosition |
Top
See Also

Reference

NoteViewModel Class
VisualComponents.UX.Shared Namespace


NoteViewModel.HasMultipleNotes Property

NoteViewModelHasMultipleNotes Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HasMultipleNotes { get; }
public:
property bool HasMultipleNotes {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

NoteViewModel Class
VisualComponents.UX.Shared Namespace


NoteViewModel.HasNext Property

NoteViewModelHasNext Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HasNext { get; }
public:
property bool HasNext {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

NoteViewModel Class
VisualComponents.UX.Shared Namespace


NoteViewModel.HasPrev Property

NoteViewModelHasPrev Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HasPrev { get; }
public:
property bool HasPrev {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

NoteViewModel Class
VisualComponents.UX.Shared Namespace


NoteViewModel.IsVisible Property

NoteViewModelIsVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsVisible { get; }
public:
property bool IsVisible {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

NoteViewModel Class
VisualComponents.UX.Shared Namespace


NoteViewModel.NoteName Property

NoteViewModelNoteName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string NoteName { get; }
public:
property String^ NoteName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

NoteViewModel Class
VisualComponents.UX.Shared Namespace


NoteViewModel.Text Property

NoteViewModelText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Text { get; set; }
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

NoteViewModel Class
VisualComponents.UX.Shared Namespace


NoteViewModel.XPosition Property

NoteViewModelXPosition Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double XPosition { get; }
public:
property double XPosition {
    double get ();
}

Property Value

Type: Double
See Also

Reference

NoteViewModel Class
VisualComponents.UX.Shared Namespace


NoteViewModel.YPosition Property

NoteViewModelYPosition Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double YPosition { get; }
public:
property double YPosition {
    double get ();
}

Property Value

Type: Double
See Also

Reference

NoteViewModel Class
VisualComponents.UX.Shared Namespace


NoteViewModel Methods

The NoteViewModel type exposes the following members.

Methods
 | Name | Description
Public method | CanClose | (Inherited from Screen.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetView | (Inherited from ViewAware.)
Public method | Handle(ItemSelectedMessageISimComponent) |
Public method | Handle(SelectedRibbonTabChangedMessage) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext |
Public method | MovePrev |
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Protected method | OnActivate | (Inherited from Screen.)
Protected method | OnDeactivate | (Inherited from Screen.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnInitialize | (Inherited from Screen.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Protected method | OnViewAttached | (Inherited from ViewAware.)
Protected method | OnViewLoaded | (Overrides ViewAware.OnViewLoaded(Object).)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ShowNotesInEditor |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryClose | (Inherited from Screen.)
Public method | TryClose(NullableBoolean) | (Inherited from Screen.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

NoteViewModel Class
VisualComponents.UX.Shared Namespace


NoteViewModel.Handle Method

NoteViewModelHandle Method

Overload List
 | Name | Description
Public method | Handle(ItemSelectedMessageISimComponent) |
Public method | Handle(SelectedRibbonTabChangedMessage) |
Top
See Also

Reference

NoteViewModel Class
VisualComponents.UX.Shared Namespace


NoteViewModel.Handle Method (ItemSelectedMessage(ISimComponent))

NoteViewModelHandle Method (ItemSelectedMessageISimComponent)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    ItemSelectedMessage<ISimComponent> message
)
public:
virtual void Handle(
    ItemSelectedMessage<ISimComponent^>^ message
) sealed

Parameters

message
Type: VisualComponents.Create3DItemSelectedMessage ISimComponent

Implements

IHandle.Handle(UTP)
See Also

Reference

NoteViewModel Class
Handle Overload
VisualComponents.UX.Shared Namespace


NoteViewModel.Handle Method (SelectedRibbonTabChangedMessage)

NoteViewModelHandle Method (SelectedRibbonTabChangedMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    SelectedRibbonTabChangedMessage message
)
public:
virtual void Handle(
    SelectedRibbonTabChangedMessage^ message
) sealed

Parameters

message
Type: VisualComponents.Create3DSelectedRibbonTabChangedMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

NoteViewModel Class
Handle Overload
VisualComponents.UX.Shared Namespace


NoteViewModel.MoveNext Method

NoteViewModelMoveNext Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MoveNext()
public:
void MoveNext()
See Also

Reference

NoteViewModel Class
VisualComponents.UX.Shared Namespace


NoteViewModel.MovePrev Method

NoteViewModelMovePrev Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MovePrev()
public:
void MovePrev()
See Also

Reference

NoteViewModel Class
VisualComponents.UX.Shared Namespace


NoteViewModel.OnViewLoaded Method

NoteViewModelOnViewLoaded Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnViewLoaded(
    Object view
)
protected:
virtual void OnViewLoaded(
    Object^ view
) override

Parameters

view
Type: SystemObject
See Also

Reference

NoteViewModel Class
VisualComponents.UX.Shared Namespace


NoteViewModel.ShowNotesInEditor Method

NoteViewModelShowNotesInEditor Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ShowNotesInEditor()
public:
void ShowNotesInEditor()
See Also

Reference

NoteViewModel Class
VisualComponents.UX.Shared Namespace


NoteViewModel Events

The NoteViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from Screen.)
Public event | AttemptingDeactivation | (Inherited from Screen.)
Public event | Deactivated | (Inherited from Screen.)
Public event | PropertyChanged |
Public event | ViewAttached | (Inherited from ViewAware.)
Top
See Also

Reference

NoteViewModel Class
VisualComponents.UX.Shared Namespace


NoteViewModel.PropertyChanged Event

NoteViewModelPropertyChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event PropertyChangedEventHandler PropertyChanged
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

NoteViewModel Class
VisualComponents.UX.Shared Namespace


NoteViewModel Fields

The NoteViewModel type exposes the following members.

Fields
 | Name | Description
Protected field | Views | (Inherited from ViewAware.)
Top
See Also

Reference

NoteViewModel Class
VisualComponents.UX.Shared Namespace


ObjectQuickMenuDisplayHandler Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.InputMouseGestureHandler
VisualComponents.UX.SharedObjectQuickMenuDisplayHandler

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ObjectQuickMenuDisplayHandler : MouseGestureHandler
public ref class ObjectQuickMenuDisplayHandler : public MouseGestureHandler

The ObjectQuickMenuDisplayHandler type exposes the following members.

Constructors
 | Name | Description
Public method | ObjectQuickMenuDisplayHandler | Initializes a new instance of the ObjectQuickMenuDisplayHandler class
Top
Properties
 | Name | Description
Protected property | Application | (Inherited from MouseGestureHandler.)
Protected property | Camera | Gets the camera. (Inherited from MouseGestureHandler.)
Protected property | CameraMode | Gets the camera mode. (Inherited from MouseGestureHandler.)
Protected property | Controller | Gets or sets the controller. (Inherited from MouseGestureHandler.)
Protected property | EventMng | (Inherited from MouseGestureHandler.)
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Protected property | LastPoint | Gets or sets the last point (2D screen coordinates). (Inherited from MouseGestureHandler.)
Protected property | LastPoint3D | Gets or sets the last point (3D world coordinates). (Inherited from MouseGestureHandler.)
Protected property | ManipulateViewModel | (Inherited from MouseGestureHandler.)
Protected property | ManipulationWatch | Gets or sets the manipulation watch. (Inherited from MouseGestureHandler.)
Protected property | MouseDownNearestPoint3D | Gets or sets the mouse down point at the nearest hit element (3D world coordinates). (Inherited from MouseGestureHandler.)
Protected property | MouseDownPoint | Gets or sets the mouse down point (2D screen coordinates). (Inherited from MouseGestureHandler.)
Protected property | MouseDownPoint3D | Gets or sets the mouse down point (3D world coordinates). (Inherited from MouseGestureHandler.)
Protected property | ObjectSelectionMode | (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Protected property | RenderingService | (Inherited from MouseGestureHandler.)
Protected property | SimulationService | (Inherited from MouseGestureHandler.)
Protected property | TranslationRotationService | (Inherited from MouseGestureHandler.)
Protected property | Viewport | Gets the viewport. (Inherited from MouseGestureHandler.)
Protected property | ViewportHeight | Gets the height of the viewport. (Inherited from MouseGestureHandler.)
Protected property | ViewportWidth | Gets the width of the viewport. (Inherited from MouseGestureHandler.)
Top
Methods
 | Name | Description
Public method | CanExecute | (Overrides MouseGestureHandlerCanExecute.)
Public method | Completed | (Overrides MouseGestureHandlerCompleted(ManipulationEventArgs).)
Public method | Delta | (Overrides MouseGestureHandlerDelta(ManipulationEventArgs).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCursor | (Overrides MouseGestureHandlerGetCursor.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetManipulationTarget(IEnumerableIVisualObject) | (Inherited from MouseGestureHandler.)
Protected method | GetManipulationTarget(IVisualObject) | (Inherited from MouseGestureHandler.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnInertiaStarting | Called when inertia is starting. (Inherited from MouseGestureHandler.)
Public method | OnLostMouseCapture | (Inherited from MouseGestureHandler.)
Protected method | OnMouseDown | Called when the mouse button is pressed down. (Inherited from MouseGestureHandler.)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _renderService | (Inherited from MouseGestureHandler.)
Protected field | _selectionManager | (Inherited from MouseGestureHandler.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ObjectQuickMenuDisplayHandler Constructor

Initializes a new instance of the ObjectQuickMenuDisplayHandler class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObjectQuickMenuDisplayHandler(
    HelperViewport controller
)
public:
ObjectQuickMenuDisplayHandler(
    HelperViewport^ controller
)

Parameters

controller
Type: VisualComponents.UX.InputHelperViewport
See Also

Reference

ObjectQuickMenuDisplayHandler Class
VisualComponents.UX.Shared Namespace


ObjectQuickMenuDisplayHandler Properties

The ObjectQuickMenuDisplayHandler type exposes the following members.

Properties
 | Name | Description
Protected property | Application | (Inherited from MouseGestureHandler.)
Protected property | Camera | Gets the camera. (Inherited from MouseGestureHandler.)
Protected property | CameraMode | Gets the camera mode. (Inherited from MouseGestureHandler.)
Protected property | Controller | Gets or sets the controller. (Inherited from MouseGestureHandler.)
Protected property | EventMng | (Inherited from MouseGestureHandler.)
Public property | ExecutionParameter | Viewport passes the bound interaction type to the handler. (Inherited from MouseGestureHandler.)
Protected property | LastPoint | Gets or sets the last point (2D screen coordinates). (Inherited from MouseGestureHandler.)
Protected property | LastPoint3D | Gets or sets the last point (3D world coordinates). (Inherited from MouseGestureHandler.)
Protected property | ManipulateViewModel | (Inherited from MouseGestureHandler.)
Protected property | ManipulationWatch | Gets or sets the manipulation watch. (Inherited from MouseGestureHandler.)
Protected property | MouseDownNearestPoint3D | Gets or sets the mouse down point at the nearest hit element (3D world coordinates). (Inherited from MouseGestureHandler.)
Protected property | MouseDownPoint | Gets or sets the mouse down point (2D screen coordinates). (Inherited from MouseGestureHandler.)
Protected property | MouseDownPoint3D | Gets or sets the mouse down point (3D world coordinates). (Inherited from MouseGestureHandler.)
Protected property | ObjectSelectionMode | (Inherited from MouseGestureHandler.)
Public property | Origin | Gets Origin. (Inherited from MouseGestureHandler.)
Protected property | RenderingService | (Inherited from MouseGestureHandler.)
Protected property | SimulationService | (Inherited from MouseGestureHandler.)
Protected property | TranslationRotationService | (Inherited from MouseGestureHandler.)
Protected property | Viewport | Gets the viewport. (Inherited from MouseGestureHandler.)
Protected property | ViewportHeight | Gets the height of the viewport. (Inherited from MouseGestureHandler.)
Protected property | ViewportWidth | Gets the width of the viewport. (Inherited from MouseGestureHandler.)
Top
See Also

Reference

ObjectQuickMenuDisplayHandler Class
VisualComponents.UX.Shared Namespace


ObjectQuickMenuDisplayHandler Methods

The ObjectQuickMenuDisplayHandler type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute | (Overrides MouseGestureHandlerCanExecute.)
Public method | Completed | (Overrides MouseGestureHandlerCompleted(ManipulationEventArgs).)
Public method | Delta | (Overrides MouseGestureHandlerDelta(ManipulationEventArgs).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Executes the mousegesture command. (Inherited from MouseGestureHandler.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCursor | (Overrides MouseGestureHandlerGetCursor.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetManipulationTarget(IEnumerableIVisualObject) | (Inherited from MouseGestureHandler.)
Protected method | GetManipulationTarget(IVisualObject) | (Inherited from MouseGestureHandler.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnInertiaStarting | Called when inertia is starting. (Inherited from MouseGestureHandler.)
Public method | OnLostMouseCapture | (Inherited from MouseGestureHandler.)
Protected method | OnMouseDown | Called when the mouse button is pressed down. (Inherited from MouseGestureHandler.)
Public method | OnMouseMove | The on mouse move. (Inherited from MouseGestureHandler.)
Public method | OnMouseUp | The on mouse up. (Inherited from MouseGestureHandler.)
Public method | Started | (Overrides MouseGestureHandlerStarted(ManipulationEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ObjectQuickMenuDisplayHandler Class
VisualComponents.UX.Shared Namespace


ObjectQuickMenuDisplayHandler.CanExecute Method

ObjectQuickMenuDisplayHandlerCanExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool CanExecute()
public:
virtual bool CanExecute() override

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ObjectQuickMenuDisplayHandler.CanExecute"]

See Also

Reference

ObjectQuickMenuDisplayHandler Class
VisualComponents.UX.Shared Namespace


ObjectQuickMenuDisplayHandler.Completed Method

ObjectQuickMenuDisplayHandlerCompleted Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Completed(
    ManipulationEventArgs e
)
public:
virtual void Completed(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

ObjectQuickMenuDisplayHandler Class
VisualComponents.UX.Shared Namespace


ObjectQuickMenuDisplayHandler.Delta Method

ObjectQuickMenuDisplayHandlerDelta Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Delta(
    ManipulationEventArgs e
)
public:
virtual void Delta(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

ObjectQuickMenuDisplayHandler Class
VisualComponents.UX.Shared Namespace


ObjectQuickMenuDisplayHandler.GetCursor Method

ObjectQuickMenuDisplayHandlerGetCursor Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Cursor GetCursor()
protected:
virtual Cursor^ GetCursor() override

Return Value

Type: Cursor

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ObjectQuickMenuDisplayHandler.GetCursor"]

See Also

Reference

ObjectQuickMenuDisplayHandler Class
VisualComponents.UX.Shared Namespace


ObjectQuickMenuDisplayHandler.Started Method

ObjectQuickMenuDisplayHandlerStarted Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Started(
    ManipulationEventArgs e
)
public:
virtual void Started(
    ManipulationEventArgs^ e
) override

Parameters

e
Type: VisualComponents.UX.InputManipulationEventArgs
See Also

Reference

ObjectQuickMenuDisplayHandler Class
VisualComponents.UX.Shared Namespace


ObjectQuickMenuDisplayHandler Fields

The ObjectQuickMenuDisplayHandler type exposes the following members.

Fields
 | Name | Description
Protected field | _renderService | (Inherited from MouseGestureHandler.)
Protected field | _selectionManager | (Inherited from MouseGestureHandler.)
Top
See Also

Reference

ObjectQuickMenuDisplayHandler Class
VisualComponents.UX.Shared Namespace


ObjectRotateAction Class

Object Rotate Action
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedFixedPropertyContainer
VisualComponents.UX.SharedObjectRotateAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ObjectRotateAction : FixedPropertyContainer,
    IActionResult, IResult, IPropertyContainer, IBatchModeObject, IHandle<InternalEndInteractionMessage>,
    IHandle, IHandle<ContinueInteractionMessage>, IHandle<ContinueActionMessageFromHandle>
public ref class ObjectRotateAction sealed : public FixedPropertyContainer,
    IActionResult, IResult, IPropertyContainer, IBatchModeObject, IHandle<InternalEndInteractionMessage^>,
    IHandle, IHandle<ContinueInteractionMessage^>, IHandle<ContinueActionMessageFromHandle^>

The ObjectRotateAction type exposes the following members.

Constructors
 | Name | Description
Public method | ObjectRotateAction | Initializes a new instance of the ObjectRotateAction class
Top
Properties
 | Name | Description
Public property | AxisOfRotation |
Public property | ChangeBatchLevel | (Inherited from FixedPropertyContainer.)
Public property | ContainerExpressionContext | (Inherited from FixedPropertyContainer.)
Public property | CoordinatesToUse |
Public property | CoordinateSystemMatrix |
Public property | Finished |
 | IsActive |
Public property | ManipulationArgs |
Public property | Name |
Public property | NewOrientationWPR |
Public property | Properties | get properties (Inherited from FixedPropertyContainer.)
Public property | PropertyNames | (Inherited from FixedPropertyContainer.)
Public property | PropertyNamesAndValues | (Inherited from FixedPropertyContainer.)
Public property | PropertyValues | (Inherited from FixedPropertyContainer.)
Public property | RotationAngleDegrees |
Public property | Target |
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType) | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from FixedPropertyContainer.)
Public method | DeleteProperty | (Inherited from FixedPropertyContainer.)
Public method | EndChangeBatch | (Inherited from FixedPropertyContainer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperty | (Inherited from FixedPropertyContainer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle(ContinueActionMessageFromHandle) |
Public method | Handle(ContinueInteractionMessage) |
Public method | NotifyPropertyChanged | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | (Inherited from FixedPropertyContainer.)
 | StartRotate(IVisualObject, Vector3) |
 | StartRotate(ManipulationEventArgs, IManipulationTarget) |
 | StartRotate(IManipulationTarget, Vector3, OperationType) |
 | StartRotate(IVisualObject, Double, Vector3) |
 | StartRotateIn |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Completed |
Public event | PropertyChanged | (Inherited from FixedPropertyContainer.)
Public event | PropertyContainerChanged | (Inherited from FixedPropertyContainer.)
Top
Fields
 | Name | Description
Public field | Mode |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ObjectRotateAction Constructor

Initializes a new instance of the ObjectRotateAction class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObjectRotateAction()
public:
ObjectRotateAction()
See Also

Reference

ObjectRotateAction Class
VisualComponents.UX.Shared Namespace


ObjectRotateAction Properties

The ObjectRotateAction type exposes the following members.

Properties
 | Name | Description
Public property | AxisOfRotation |
Public property | ChangeBatchLevel | (Inherited from FixedPropertyContainer.)
Public property | ContainerExpressionContext | (Inherited from FixedPropertyContainer.)
Public property | CoordinatesToUse |
Public property | CoordinateSystemMatrix |
Public property | Finished |
 | IsActive |
Public property | ManipulationArgs |
Public property | Name |
Public property | NewOrientationWPR |
Public property | Properties | get properties (Inherited from FixedPropertyContainer.)
Public property | PropertyNames | (Inherited from FixedPropertyContainer.)
Public property | PropertyNamesAndValues | (Inherited from FixedPropertyContainer.)
Public property | PropertyValues | (Inherited from FixedPropertyContainer.)
Public property | RotationAngleDegrees |
Public property | Target |
Top
See Also

Reference

ObjectRotateAction Class
VisualComponents.UX.Shared Namespace


ObjectRotateAction.AxisOfRotation Property

ObjectRotateActionAxisOfRotation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<Vector3> AxisOfRotation { get; set; }
public:
property Nullable<Vector3> AxisOfRotation {
    Nullable<Vector3> get ();
    void set (Nullable<Vector3> value);
}

Property Value

Type: NullableVector3
See Also

Reference

ObjectRotateAction Class
VisualComponents.UX.Shared Namespace


ObjectRotateAction.CoordinatesToUse Property

ObjectRotateActionCoordinatesToUse Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<CoordinateSystem> CoordinatesToUse { get; set; }
public:
property Nullable<CoordinateSystem> CoordinatesToUse {
    Nullable<CoordinateSystem> get ();
    void set (Nullable<CoordinateSystem> value);
}

Property Value

Type: NullableCoordinateSystem
See Also

Reference

ObjectRotateAction Class
VisualComponents.UX.Shared Namespace


ObjectRotateAction.CoordinateSystemMatrix Property

ObjectRotateActionCoordinateSystemMatrix Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<Matrix> CoordinateSystemMatrix { get; set; }
public:
property Nullable<Matrix> CoordinateSystemMatrix {
    Nullable<Matrix> get ();
    void set (Nullable<Matrix> value);
}

Property Value

Type: NullableMatrix
See Also

Reference

ObjectRotateAction Class
VisualComponents.UX.Shared Namespace


ObjectRotateAction.Finished Property

ObjectRotateActionFinished Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Finished { get; set; }
public:
property bool Finished {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ObjectRotateAction Class
VisualComponents.UX.Shared Namespace


ObjectRotateAction.IsActive Property

ObjectRotateActionIsActive Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsActive { get; set; }
public:
static property bool IsActive {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ObjectRotateAction Class
VisualComponents.UX.Shared Namespace


ObjectRotateAction.ManipulationArgs Property

ObjectRotateActionManipulationArgs Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ManipulationEventArgs ManipulationArgs { get; set; }
public:
property ManipulationEventArgs^ ManipulationArgs {
    ManipulationEventArgs^ get ();
    void set (ManipulationEventArgs^ value);
}

Property Value

Type: ManipulationEventArgs
See Also

Reference

ObjectRotateAction Class
VisualComponents.UX.Shared Namespace


ObjectRotateAction.Name Property

ObjectRotateActionName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; }
public:
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ObjectRotateAction Class
VisualComponents.UX.Shared Namespace


ObjectRotateAction.NewOrientationWPR Property

ObjectRotateActionNewOrientationWPR Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<Vector3> NewOrientationWPR { get; set; }
public:
property Nullable<Vector3> NewOrientationWPR {
    Nullable<Vector3> get ();
    void set (Nullable<Vector3> value);
}

Property Value

Type: NullableVector3
See Also

Reference

ObjectRotateAction Class
VisualComponents.UX.Shared Namespace


ObjectRotateAction.RotationAngleDegrees Property

ObjectRotateActionRotationAngleDegrees Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<double> RotationAngleDegrees { get; set; }
public:
property Nullable<double> RotationAngleDegrees {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: NullableDouble
See Also

Reference

ObjectRotateAction Class
VisualComponents.UX.Shared Namespace


ObjectRotateAction.Target Property

ObjectRotateActionTarget Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IManipulationTarget Target { get; set; }
public:
property IManipulationTarget^ Target {
    IManipulationTarget^ get ();
    void set (IManipulationTarget^ value);
}

Property Value

Type: IManipulationTarget
See Also

Reference

ObjectRotateAction Class
VisualComponents.UX.Shared Namespace


ObjectRotateAction Methods

The ObjectRotateAction type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType) | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from FixedPropertyContainer.)
Public method | DeleteProperty | (Inherited from FixedPropertyContainer.)
Public method | EndChangeBatch | (Inherited from FixedPropertyContainer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperty | (Inherited from FixedPropertyContainer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle(ContinueActionMessageFromHandle) |
Public method | Handle(ContinueInteractionMessage) |
Public method | NotifyPropertyChanged | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | (Inherited from FixedPropertyContainer.)
 | StartRotate(IVisualObject, Vector3) |
 | StartRotate(ManipulationEventArgs, IManipulationTarget) |
 | StartRotate(IManipulationTarget, Vector3, OperationType) |
 | StartRotate(IVisualObject, Double, Vector3) |
 | StartRotateIn |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ObjectRotateAction Class
VisualComponents.UX.Shared Namespace


ObjectRotateAction.Execute Method

ObjectRotateActionExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    ActionExecutionContext context
)
public:
virtual void Execute(
    ActionExecutionContext^ context
) sealed

Parameters

context
Type: ActionExecutionContext

Implements

IResult.Execute(ActionExecutionContext)
See Also

Reference

ObjectRotateAction Class
VisualComponents.UX.Shared Namespace


ObjectRotateAction.Handle Method

ObjectRotateActionHandle Method

Overload List
 | Name | Description
Public method | Handle(ContinueActionMessageFromHandle) |
Public method | Handle(ContinueInteractionMessage) |
Top
See Also

Reference

ObjectRotateAction Class
VisualComponents.UX.Shared Namespace


ObjectRotateAction.Handle Method (ContinueActionMessageFromHandle)

ObjectRotateActionHandle Method (ContinueActionMessageFromHandle)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    ContinueActionMessageFromHandle message
)
public:
virtual void Handle(
    ContinueActionMessageFromHandle^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedContinueActionMessageFromHandle

Implements

IHandle.Handle(UTP)
See Also

Reference

ObjectRotateAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


ObjectRotateAction.Handle Method (ContinueInteractionMessage)

ObjectRotateActionHandle Method (ContinueInteractionMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    ContinueInteractionMessage message
)
public:
virtual void Handle(
    ContinueInteractionMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedContinueInteractionMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

ObjectRotateAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


ObjectRotateAction.StartRotate Method

ObjectRotateActionStartRotate Method

Overload List
Name | Description
StartRotate(IVisualObject, Vector3) |
StartRotate(ManipulationEventArgs, IManipulationTarget) |
StartRotate(IManipulationTarget, Vector3, OperationType) |
StartRotate(IVisualObject, Double, Vector3) |
Top
See Also

Reference

ObjectRotateAction Class
VisualComponents.UX.Shared Namespace


ObjectRotateAction.StartRotate Method (IVisualObject, Vector3)

ObjectRotateActionStartRotate Method (IVisualObject, Vector3)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IEnumerable<IResult> StartRotate(
    IVisualObject target,
    Vector3 newOrientationWPR
)
public:
static IEnumerable<IResult^>^ StartRotate(
    IVisualObject^ target,
    Vector3 newOrientationWPR
)

Parameters

target
Type: VisualComponents.Create3DIVisualObject
newOrientationWPR
Type: VisualComponents.Create3DVector3

Return Value

Type: IEnumerableIResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ObjectRotateAction.StartRotate(VisualComponents.Create3D.IVisualObject,VisualComponents.Create3D.Vector3)"]

See Also

Reference

ObjectRotateAction Class
StartRotate Overload
VisualComponents.UX.Shared Namespace


ObjectRotateAction.StartRotate Method (ManipulationEventArgs, IManipulationTarget)

ObjectRotateActionStartRotate Method (ManipulationEventArgs, IManipulationTarget)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IEnumerable<IResult> StartRotate(
    ManipulationEventArgs beginWith,
    IManipulationTarget target
)
public:
static IEnumerable<IResult^>^ StartRotate(
    ManipulationEventArgs^ beginWith,
    IManipulationTarget^ target
)

Parameters

beginWith
Type: VisualComponents.UX.InputManipulationEventArgs
target
Type: VisualComponents.Create3DIManipulationTarget

Return Value

Type: IEnumerableIResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ObjectRotateAction.StartRotate(VisualComponents.UX.Input.ManipulationEventArgs,VisualComponents.Create3D.IManipulationTarget)"]

See Also

Reference

ObjectRotateAction Class
StartRotate Overload
VisualComponents.UX.Shared Namespace


ObjectRotateAction.StartRotate Method (IManipulationTarget, Vector3, OperationType)

ObjectRotateActionStartRotate Method (IManipulationTarget, Vector3, OperationType)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IEnumerable<IResult> StartRotate(
    IManipulationTarget target,
    Vector3 newOrientationWPR,
    OperationType operation
)
public:
static IEnumerable<IResult^>^ StartRotate(
    IManipulationTarget^ target,
    Vector3 newOrientationWPR,
    OperationType operation
)

Parameters

target
Type: VisualComponents.Create3DIManipulationTarget
newOrientationWPR
Type: VisualComponents.Create3DVector3
operation
Type: VisualComponents.Create3DOperationType

Return Value

Type: IEnumerableIResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ObjectRotateAction.StartRotate(VisualComponents.Create3D.IManipulationTarget,VisualComponents.Create3D.Vector3,VisualComponents.Create3D.OperationType)"]

See Also

Reference

ObjectRotateAction Class
StartRotate Overload
VisualComponents.UX.Shared Namespace


ObjectRotateAction.StartRotate Method (IVisualObject, Double, Vector3)

ObjectRotateActionStartRotate Method (IVisualObject, Double, Vector3)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IEnumerable<IResult> StartRotate(
    IVisualObject target,
    double angle,
    Vector3 axisOfRotation
)
public:
static IEnumerable<IResult^>^ StartRotate(
    IVisualObject^ target,
    double angle,
    Vector3 axisOfRotation
)

Parameters

target
Type: VisualComponents.Create3DIVisualObject
angle
Type: SystemDouble
axisOfRotation
Type: VisualComponents.Create3DVector3

Return Value

Type: IEnumerableIResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ObjectRotateAction.StartRotate(VisualComponents.Create3D.IVisualObject,System.Double,VisualComponents.Create3D.Vector3)"]

See Also

Reference

ObjectRotateAction Class
StartRotate Overload
VisualComponents.UX.Shared Namespace


ObjectRotateAction.StartRotateIn Method

ObjectRotateActionStartRotateIn Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IEnumerable<IResult> StartRotateIn(
    IManipulationTarget target,
    Matrix coordinateSystemMatrix,
    CoordinateSystem coordinatesToUse,
    Vector3 newOrientationWPR
)
public:
static IEnumerable<IResult^>^ StartRotateIn(
    IManipulationTarget^ target,
    Matrix coordinateSystemMatrix,
    CoordinateSystem coordinatesToUse,
    Vector3 newOrientationWPR
)

Parameters

target
Type: VisualComponents.Create3DIManipulationTarget
coordinateSystemMatrix
Type: VisualComponents.Create3DMatrix
coordinatesToUse
Type: VisualComponents.Create3DCoordinateSystem
newOrientationWPR
Type: VisualComponents.Create3DVector3

Return Value

Type: IEnumerableIResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ObjectRotateAction.StartRotateIn(VisualComponents.Create3D.IManipulationTarget,VisualComponents.Create3D.Matrix,VisualComponents.Create3D.CoordinateSystem,VisualComponents.Create3D.Vector3)"]

See Also

Reference

ObjectRotateAction Class
VisualComponents.UX.Shared Namespace


ObjectRotateAction Events

The ObjectRotateAction type exposes the following members.

Events
 | Name | Description
Public event | Completed |
Public event | PropertyChanged | (Inherited from FixedPropertyContainer.)
Public event | PropertyContainerChanged | (Inherited from FixedPropertyContainer.)
Top
See Also

Reference

ObjectRotateAction Class
VisualComponents.UX.Shared Namespace


ObjectRotateAction.Completed Event

ObjectRotateActionCompleted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ResultCompletionEventArgs> Completed
public:
virtual  event EventHandler<ResultCompletionEventArgs^>^ Completed {
    void add (EventHandler<ResultCompletionEventArgs^>^ value);
    void remove (EventHandler<ResultCompletionEventArgs^>^ value);
}

Value

Type: SystemEventHandlerResultCompletionEventArgs

Implements

IResult.Completed
See Also

Reference

ObjectRotateAction Class
VisualComponents.UX.Shared Namespace


ObjectRotateAction Fields

The ObjectRotateAction type exposes the following members.

Fields
 | Name | Description
Public field | Mode |
Top
See Also

Reference

ObjectRotateAction Class
VisualComponents.UX.Shared Namespace


ObjectRotateAction.Mode Field

ObjectRotateActionMode Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public OperationType Mode
public:
OperationType Mode

Field Value

Type: OperationType
See Also

Reference

ObjectRotateAction Class
VisualComponents.UX.Shared Namespace


ObjectToWindowIconConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedObjectToWindowIconConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ObjectToWindowIconConverter : IValueConverter
public ref class ObjectToWindowIconConverter : IValueConverter

The ObjectToWindowIconConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ObjectToWindowIconConverter | Initializes a new instance of the ObjectToWindowIconConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ObjectToWindowIconConverter Constructor

Initializes a new instance of the ObjectToWindowIconConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObjectToWindowIconConverter()
public:
ObjectToWindowIconConverter()
See Also

Reference

ObjectToWindowIconConverter Class
VisualComponents.UX.Shared Namespace


ObjectToWindowIconConverter Methods

The ObjectToWindowIconConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ObjectToWindowIconConverter Class
VisualComponents.UX.Shared Namespace


ObjectToWindowIconConverter.Convert Method

ObjectToWindowIconConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ObjectToWindowIconConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

ObjectToWindowIconConverter Class
VisualComponents.UX.Shared Namespace


ObjectToWindowIconConverter.ConvertBack Method

ObjectToWindowIconConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ObjectToWindowIconConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

ObjectToWindowIconConverter Class
VisualComponents.UX.Shared Namespace


ObservableCollectionProxy Class

Adds unit conversion support for set of values.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollectionPropertyAllowedValueModel
System.Collections.ObjectModelObservableCollectionPropertyAllowedValueModel
VisualComponents.UX.SharedObservableCollectionProxy

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ObservableCollectionProxy : ObservableCollection<PropertyAllowedValueModel>
public ref class ObservableCollectionProxy sealed : public ObservableCollection<PropertyAllowedValueModel^>

The ObservableCollectionProxy type exposes the following members.

Constructors
 | Name | Description
Public method | ObservableCollectionProxy | Initializes a new instance of the ObservableCollectionProxy class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from CollectionPropertyAllowedValueModel .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from CollectionPropertyAllowedValueModel .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from CollectionPropertyAllowedValueModel .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from CollectionPropertyAllowedValueModel .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from CollectionPropertyAllowedValueModel .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from CollectionPropertyAllowedValueModel .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from CollectionPropertyAllowedValueModel .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from CollectionPropertyAllowedValueModel .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from CollectionPropertyAllowedValueModel .)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollectionPropertyAllowedValueModel .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from CollectionPropertyAllowedValueModel .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from CollectionPropertyAllowedValueModel .)
Public method | SetupAllowedValues |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateAllowedValues |
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollectionPropertyAllowedValueModel .)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ObservableCollectionProxy Constructor

Initializes a new instance of the ObservableCollectionProxy class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObservableCollectionProxy()
public:
ObservableCollectionProxy()
See Also

Reference

ObservableCollectionProxy Class
VisualComponents.UX.Shared Namespace


ObservableCollectionProxy Properties

The ObservableCollectionProxy type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from CollectionPropertyAllowedValueModel .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from CollectionPropertyAllowedValueModel .)
Top
See Also

Reference

ObservableCollectionProxy Class
VisualComponents.UX.Shared Namespace


ObservableCollectionProxy Methods

The ObservableCollectionProxy type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from CollectionPropertyAllowedValueModel .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from CollectionPropertyAllowedValueModel .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from CollectionPropertyAllowedValueModel .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from CollectionPropertyAllowedValueModel .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from CollectionPropertyAllowedValueModel .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from CollectionPropertyAllowedValueModel .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from CollectionPropertyAllowedValueModel .)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollectionPropertyAllowedValueModel .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from CollectionPropertyAllowedValueModel .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from CollectionPropertyAllowedValueModel .)
Public method | SetupAllowedValues |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateAllowedValues |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ObservableCollectionProxy Class
VisualComponents.UX.Shared Namespace


ObservableCollectionProxy.SetupAllowedValues Method

ObservableCollectionProxySetupAllowedValues Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetupAllowedValues(
    EditorProperty property
)
public:
void SetupAllowedValues(
    EditorProperty^ property
)

Parameters

property
Type: VisualComponents.UX.SharedEditorProperty
See Also

Reference

ObservableCollectionProxy Class
VisualComponents.UX.Shared Namespace


ObservableCollectionProxy.UpdateAllowedValues Method

ObservableCollectionProxyUpdateAllowedValues Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void UpdateAllowedValues(
    EditorProperty property
)
public:
void UpdateAllowedValues(
    EditorProperty^ property
)

Parameters

property
Type: VisualComponents.UX.SharedEditorProperty
See Also

Reference

ObservableCollectionProxy Class
VisualComponents.UX.Shared Namespace


ObservableCollectionProxy Events

The ObservableCollectionProxy type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollectionPropertyAllowedValueModel .)
Top
See Also

Reference

ObservableCollectionProxy Class
VisualComponents.UX.Shared Namespace


OnApplicationMenuClosedHandler Delegate

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public delegate void OnApplicationMenuClosedHandler(
    Object o,
    RoutedEventArgs e
)
public delegate void OnApplicationMenuClosedHandler(
    Object^ o,
    RoutedEventArgs^ e
)

Parameters

o
Type: SystemObject
e
Type: System.WindowsRoutedEventArgs
See Also

Reference

VisualComponents.UX.Shared Namespace


OnApplicationMenuOpenedHandler Delegate

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public delegate void OnApplicationMenuOpenedHandler(
    Object o,
    RoutedEventArgs e
)
public delegate void OnApplicationMenuOpenedHandler(
    Object^ o,
    RoutedEventArgs^ e
)

Parameters

o
Type: SystemObject
e
Type: System.WindowsRoutedEventArgs
See Also

Reference

VisualComponents.UX.Shared Namespace


OnApplicationMenuSelectionChangedHandler Delegate

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public delegate void OnApplicationMenuSelectionChangedHandler(
    Object o,
    ApplicationMenuSelectionChangedEventArgs e
)
public delegate void OnApplicationMenuSelectionChangedHandler(
    Object^ o,
    ApplicationMenuSelectionChangedEventArgs^ e
)

Parameters

o
Type: SystemObject
e
Type: VisualComponents.UX.SharedApplicationMenuSelectionChangedEventArgs
See Also

Reference

VisualComponents.UX.Shared Namespace


OpenFileAction Class

Open file Action
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedOpenFileAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class OpenFileAction : IResult
public ref class OpenFileAction : IResult

The OpenFileAction type exposes the following members.

Constructors
 | Name | Description
Public method | OpenFileAction | default constructor
Top
Properties
 | Name | Description
Public property | AppendWorld | Append word indicator
Public property | DefaultDirectory | default directory
Public property | ErrorCode | Returns zero if no errors were encountered.
Public property | FilePath | a file path
Public property | InitialPosition | Initial Position
Public property | IsComponent | Returns true if loaded file was a component.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | Execute |
Public method | Execute(ActionExecutionContext) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenFile | Open file
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Completed |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


OpenFileAction Constructor

default constructor

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public OpenFileAction()
public:
OpenFileAction()
See Also

Reference

OpenFileAction Class
VisualComponents.UX.Shared Namespace


OpenFileAction Properties

The OpenFileAction type exposes the following members.

Properties
 | Name | Description
Public property | AppendWorld | Append word indicator
Public property | DefaultDirectory | default directory
Public property | ErrorCode | Returns zero if no errors were encountered.
Public property | FilePath | a file path
Public property | InitialPosition | Initial Position
Public property | IsComponent | Returns true if loaded file was a component.
Top
See Also

Reference

OpenFileAction Class
VisualComponents.UX.Shared Namespace


OpenFileAction.AppendWorld Property

OpenFileActionAppendWorld Property

Append word indicator

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool AppendWorld { get; set; }
public:
property bool AppendWorld {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

OpenFileAction Class
VisualComponents.UX.Shared Namespace


OpenFileAction.DefaultDirectory Property

OpenFileActionDefaultDirectory Property

default directory

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string DefaultDirectory { get; set; }
public:
property String^ DefaultDirectory {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

OpenFileAction Class
VisualComponents.UX.Shared Namespace


OpenFileAction.ErrorCode Property

OpenFileActionErrorCode Property

Returns zero if no errors were encountered.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ErrorCode { get; }
public:
property int ErrorCode {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

OpenFileAction Class
VisualComponents.UX.Shared Namespace


OpenFileAction.FilePath Property

OpenFileActionFilePath Property

a file path

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string FilePath { get; set; }
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

OpenFileAction Class
VisualComponents.UX.Shared Namespace


OpenFileAction.InitialPosition Property

OpenFileActionInitialPosition Property

Initial Position

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<Vector3> InitialPosition { get; set; }
public:
property Nullable<Vector3> InitialPosition {
    Nullable<Vector3> get ();
    void set (Nullable<Vector3> value);
}

Property Value

Type: NullableVector3
See Also

Reference

OpenFileAction Class
VisualComponents.UX.Shared Namespace


OpenFileAction.IsComponent Property

OpenFileActionIsComponent Property

Returns true if loaded file was a component.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsComponent { get; }
public:
property bool IsComponent {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

OpenFileAction Class
VisualComponents.UX.Shared Namespace


OpenFileAction Methods

The OpenFileAction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | Execute |
Public method | Execute(ActionExecutionContext) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenFile | Open file
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

OpenFileAction Class
VisualComponents.UX.Shared Namespace


OpenFileAction.Execute Method

OpenFileActionExecute Method

Overload List
 | Name | Description
 | Execute |
Public method | Execute(ActionExecutionContext) |
Top
See Also

Reference

OpenFileAction Class
VisualComponents.UX.Shared Namespace


OpenFileAction.Execute Method

OpenFileActionExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void Execute()
public:
static void Execute()
See Also

Reference

OpenFileAction Class
Execute Overload
VisualComponents.UX.Shared Namespace


OpenFileAction.Execute Method (ActionExecutionContext)

OpenFileActionExecute Method (ActionExecutionContext)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    ActionExecutionContext context
)
public:
virtual void Execute(
    ActionExecutionContext^ context
) sealed

Parameters

context
Type: ActionExecutionContext

Implements

IResult.Execute(ActionExecutionContext)
See Also

Reference

OpenFileAction Class
Execute Overload
VisualComponents.UX.Shared Namespace


OpenFileAction.OpenFile Method

OpenFileActionOpenFile Method

Open file

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<IResult> OpenFile()
public:
IEnumerable<IResult^>^ OpenFile()

Return Value

Type: IEnumerableIResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.OpenFileAction.OpenFile"]

See Also

Reference

OpenFileAction Class
VisualComponents.UX.Shared Namespace


OpenFileAction Events

The OpenFileAction type exposes the following members.

Events
 | Name | Description
Public event | Completed |
Top
See Also

Reference

OpenFileAction Class
VisualComponents.UX.Shared Namespace


OpenFileAction.Completed Event

OpenFileActionCompleted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ResultCompletionEventArgs> Completed
public:
virtual  event EventHandler<ResultCompletionEventArgs^>^ Completed {
    void add (EventHandler<ResultCompletionEventArgs^>^ value);
    void remove (EventHandler<ResultCompletionEventArgs^>^ value);
}

Value

Type: SystemEventHandlerResultCompletionEventArgs

Implements

IResult.Completed
See Also

Reference

OpenFileAction Class
VisualComponents.UX.Shared Namespace


OpenFileAction.ErrorCodes Enumeration

OpenFileActionErrorCodes Enumeration

Available values for ErrorCode.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ErrorCodes
public enum class ErrorCodes
Members
Member name | Value | Description
NoErrorSet | 0 |
NothingToLoad | 1 |
FileNotFound | 2 |
PathNotSupported | 3 |
See Also

Reference

VisualComponents.UX.Shared Namespace


OpenHelpDocumentCommand Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedOpenHelpDocumentCommand

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class OpenHelpDocumentCommand
public ref class OpenHelpDocumentCommand

The OpenHelpDocumentCommand type exposes the following members.

Constructors
 | Name | Description
Public method | OpenHelpDocumentCommand | Initializes a new instance of the OpenHelpDocumentCommand class
Top
Properties
 | Name | Description
Public property | OpenHelpCommand |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MyAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


OpenHelpDocumentCommand Constructor

Initializes a new instance of the OpenHelpDocumentCommand class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public OpenHelpDocumentCommand()
public:
OpenHelpDocumentCommand()
See Also

Reference

OpenHelpDocumentCommand Class
VisualComponents.UX.Shared Namespace


OpenHelpDocumentCommand Properties

The OpenHelpDocumentCommand type exposes the following members.

Properties
 | Name | Description
Public property | OpenHelpCommand |
Top
See Also

Reference

OpenHelpDocumentCommand Class
VisualComponents.UX.Shared Namespace


OpenHelpDocumentCommand.OpenHelpCommand Property

OpenHelpDocumentCommandOpenHelpCommand Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ICommand OpenHelpCommand { get; }
public:
property ICommand^ OpenHelpCommand {
    ICommand^ get ();
}

Property Value

Type: ICommand
See Also

Reference

OpenHelpDocumentCommand Class
VisualComponents.UX.Shared Namespace


OpenHelpDocumentCommand Methods

The OpenHelpDocumentCommand type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MyAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

OpenHelpDocumentCommand Class
VisualComponents.UX.Shared Namespace


OpenHelpDocumentCommand.MyAction Method

OpenHelpDocumentCommandMyAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MyAction(
    Object x
)
public:
void MyAction(
    Object^ x
)

Parameters

x
Type: SystemObject
See Also

Reference

OpenHelpDocumentCommand Class
VisualComponents.UX.Shared Namespace


OpenHelpDocumentCommand.CommandHandler Class

OpenHelpDocumentCommandCommandHandler Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedOpenHelpDocumentCommandCommandHandler

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class CommandHandler : ICommand
public ref class CommandHandler : ICommand

The OpenHelpDocumentCommandCommandHandler type exposes the following members.

Constructors
 | Name | Description
Public method | OpenHelpDocumentCommandCommandHandler | Initializes a new instance of the OpenHelpDocumentCommandCommandHandler class
Top
Methods
 | Name | Description
Public method | CanExecute |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CanExecuteChanged |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


OpenHelpDocumentCommand.CommandHandler Constructor

OpenHelpDocumentCommandCommandHandler Constructor

Initializes a new instance of the OpenHelpDocumentCommandCommandHandler class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public CommandHandler(
    Action<Object> action,
    bool canExecute
)
public:
CommandHandler(
    Action<Object^>^ action,
    bool canExecute
)

Parameters

action
Type: SystemActionObject
canExecute
Type: SystemBoolean
See Also

Reference

OpenHelpDocumentCommandCommandHandler Class
VisualComponents.UX.Shared Namespace


CommandHandler Methods

The OpenHelpDocumentCommandCommandHandler type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

OpenHelpDocumentCommandCommandHandler Class
VisualComponents.UX.Shared Namespace


OpenHelpDocumentCommand.CommandHandler.CanExecute Method

OpenHelpDocumentCommandCommandHandlerCanExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanExecute(
    Object parameter
)
public:
virtual bool CanExecute(
    Object^ parameter
) sealed

Parameters

parameter
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.OpenHelpDocumentCommand.CommandHandler.CanExecute(System.Object)"]

Implements

ICommandCanExecute(Object)
See Also

Reference

OpenHelpDocumentCommandCommandHandler Class
VisualComponents.UX.Shared Namespace


OpenHelpDocumentCommand.CommandHandler.Execute Method

OpenHelpDocumentCommandCommandHandlerExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    Object parameter
)
public:
virtual void Execute(
    Object^ parameter
) sealed

Parameters

parameter
Type: SystemObject

Implements

ICommandExecute(Object)
See Also

Reference

OpenHelpDocumentCommandCommandHandler Class
VisualComponents.UX.Shared Namespace


CommandHandler Events

The OpenHelpDocumentCommandCommandHandler type exposes the following members.

Events
 | Name | Description
Public event | CanExecuteChanged |
Top
See Also

Reference

OpenHelpDocumentCommandCommandHandler Class
VisualComponents.UX.Shared Namespace


OpenHelpDocumentCommand.CommandHandler.CanExecuteChanged Event

OpenHelpDocumentCommandCommandHandlerCanExecuteChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler CanExecuteChanged
public:
virtual  event EventHandler^ CanExecuteChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

ICommandCanExecuteChanged
See Also

Reference

OpenHelpDocumentCommandCommandHandler Class
VisualComponents.UX.Shared Namespace


OpenSaveFolderConfigCollection Class

Represents a configuration element recent Open/Save folder.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationElementCollection
VisualComponents.UX.SharedBaseConfigCollection OpenSaveFolderConfigElement
VisualComponents.UX.SharedOpenSaveFolderConfigCollection

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class OpenSaveFolderConfigCollection : BaseConfigCollection<OpenSaveFolderConfigElement>
public ref class OpenSaveFolderConfigCollection sealed : public BaseConfigCollection<OpenSaveFolderConfigElement^>

The OpenSaveFolderConfigCollection type exposes the following members.

Constructors
 | Name | Description
Public method | OpenSaveFolderConfigCollection | Initializes a new instance of the OpenSaveFolderConfigCollection class
Top
Properties
 | Name | Description
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Public property | ItemInt32 | (Inherited from BaseConfigCollectionT.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Top
Methods
 | Name | Description
Public method | Add | Add item to the collection (Inherited from BaseConfigCollectionT.)
Public method | Clear | clear the collection (Inherited from BaseConfigCollectionT.)
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | get the collection index of the element (Inherited from BaseConfigCollectionT.)
Public method | Insert | Inserts an item into the collection at the specified index. (Inherited from BaseConfigCollectionT.)
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Public method | Remove | remove the element from the collection (Inherited from BaseConfigCollectionT.)
Public method | RemoveAt | remove the element from the collection by the index (Inherited from BaseConfigCollectionT.)
Public method | ToList | Returns list of items (Inherited from BaseConfigCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


OpenSaveFolderConfigCollection Constructor

Initializes a new instance of the OpenSaveFolderConfigCollection class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public OpenSaveFolderConfigCollection()
public:
OpenSaveFolderConfigCollection()
See Also

Reference

OpenSaveFolderConfigCollection Class
VisualComponents.UX.Shared Namespace


OpenSaveFolderConfigCollection Properties

The OpenSaveFolderConfigCollection type exposes the following members.

Properties
 | Name | Description
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Public property | ItemInt32 | (Inherited from BaseConfigCollectionT.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Top
See Also

Reference

OpenSaveFolderConfigCollection Class
VisualComponents.UX.Shared Namespace


OpenSaveFolderConfigCollection Methods

The OpenSaveFolderConfigCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add item to the collection (Inherited from BaseConfigCollectionT.)
Public method | Clear | clear the collection (Inherited from BaseConfigCollectionT.)
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | get the collection index of the element (Inherited from BaseConfigCollectionT.)
Public method | Insert | Inserts an item into the collection at the specified index. (Inherited from BaseConfigCollectionT.)
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Public method | Remove | remove the element from the collection (Inherited from BaseConfigCollectionT.)
Public method | RemoveAt | remove the element from the collection by the index (Inherited from BaseConfigCollectionT.)
Public method | ToList | Returns list of items (Inherited from BaseConfigCollectionT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

OpenSaveFolderConfigCollection Class
VisualComponents.UX.Shared Namespace


OpenSaveFolderConfigElement Class

Open/Save folder config element
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.UX.SharedOpenSaveFolderConfigElement

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class OpenSaveFolderConfigElement : ConfigurationElement
public ref class OpenSaveFolderConfigElement sealed : public ConfigurationElement

The OpenSaveFolderConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | OpenSaveFolderConfigElement | Default constructor
Public method | OpenSaveFolderConfigElement(OpenSaveFolderType) | Initializes a new instance of this class.
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | Path | The folder value
Public property | Type | The folder type
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


OpenSaveFolderConfigElement Constructor

Overload List
 | Name | Description
Public method | OpenSaveFolderConfigElement | Default constructor
Public method | OpenSaveFolderConfigElement(OpenSaveFolderType) | Initializes a new instance of this class.
Top
See Also

Reference

OpenSaveFolderConfigElement Class
VisualComponents.UX.Shared Namespace


OpenSaveFolderConfigElement Constructor

Default constructor

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public OpenSaveFolderConfigElement()
public:
OpenSaveFolderConfigElement()
See Also

Reference

OpenSaveFolderConfigElement Class
OpenSaveFolderConfigElement Overload
VisualComponents.UX.Shared Namespace


OpenSaveFolderConfigElement Constructor (OpenSaveFolderType)

Initializes a new instance of this class.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public OpenSaveFolderConfigElement(
    OpenSaveFolderType type
)
public:
OpenSaveFolderConfigElement(
    OpenSaveFolderType type
)

Parameters

type
Type: VisualComponents.UX.SharedOpenSaveFolderType
Folder type
See Also

Reference

OpenSaveFolderConfigElement Class
OpenSaveFolderConfigElement Overload
VisualComponents.UX.Shared Namespace


OpenSaveFolderConfigElement Properties

The OpenSaveFolderConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | Path | The folder value
Public property | Type | The folder type
Top
See Also

Reference

OpenSaveFolderConfigElement Class
VisualComponents.UX.Shared Namespace


OpenSaveFolderConfigElement.Path Property

OpenSaveFolderConfigElementPath Property

The folder value

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Path { get; set; }
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

OpenSaveFolderConfigElement Class
VisualComponents.UX.Shared Namespace


OpenSaveFolderConfigElement.Type Property

OpenSaveFolderConfigElementType Property

The folder type

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public OpenSaveFolderType Type { get; set; }
public:
property OpenSaveFolderType Type {
    OpenSaveFolderType get ();
    void set (OpenSaveFolderType value);
}

Property Value

Type: OpenSaveFolderType
See Also

Reference

OpenSaveFolderConfigElement Class
VisualComponents.UX.Shared Namespace


OpenSaveFolderConfigElement Methods

The OpenSaveFolderConfigElement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

OpenSaveFolderConfigElement Class
VisualComponents.UX.Shared Namespace


OpenSaveFolderType Enumeration

The Open/Save folders type

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum OpenSaveFolderType
public enum class OpenSaveFolderType
Members
Member name | Value | Description
None | 0 |
LayoutFolder | 1 |
ComponentFolder | 2 |
ExportToVideoPlay | 3 |
ExportToPdf | 4 |
ExportToVectorDrawing | 5 |
ExportToBitmap | 6 |
ExportToAnimation | 7 |
See Also

Reference

VisualComponents.UX.Shared Namespace


Overlay Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsItemsControl
VisualComponents.UX.SharedOverlay

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class Overlay : ItemsControl
public ref class Overlay : public ItemsControl

The Overlay type exposes the following members.

Constructors
 | Name | Description
Public method | Overlay | Initializes a new instance of the Overlay class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AheadRealizationViewportFraction |
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Canvas |
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InitialBounds |
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | IsVirtualizing |
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Item |
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemBoundsSizeMultiplier |
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RealizationBatchSize |
Public property | RealizationPriority |
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | SuppressArrangeInvalidation |
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | VisibleItemsCount |
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringToFront(Int32) |
Public method | BringToFront(Object) |
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride(DependencyObject, Object) method. (Inherited from ItemsControl.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Inherited from ItemsControl.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetPoints(Int32) |
Public method | GetPoints(Object) |
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | GetZIndex(Int32) |
Public method | GetZIndex(Object) |
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | IndexOf |
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | IsItemItsOwnContainer | Determines if the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | (Overrides FrameworkElementOnInitialized(EventArgs).)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | (Overrides ItemsControlOnItemsChanged(NotifyCollectionChangedEventArgs).)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControl.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Invoked when the KeyDown event is received. (Inherited from ItemsControl.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Refresh |
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetPoints(Int32, PointCollection, Boolean) |
Public method | SetPoints(Object, PointCollection, Boolean) |
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | SetZIndex(Int32, Int32) |
Public method | SetZIndex(Object, Int32) |
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AheadRealizationViewportFractionProperty |
CanvasProperty |
CanvasPropertyKey |
IsVirtualizingProperty |
ItemBoundsSizeMultiplierProperty |
PointsProperty |
RealizationBatchSizeProperty |
RealizationPriorityProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


Overlay Constructor

Initializes a new instance of the Overlay class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Overlay()
public:
Overlay()
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay Properties

The Overlay type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AheadRealizationViewportFraction |
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AlternationCount | Gets or sets the number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. (Inherited from ItemsControl.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Canvas |
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. (Inherited from ItemsControl.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from ItemsControl.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. (Inherited from ItemsControl.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from ItemsControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InitialBounds |
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. (Inherited from ItemsControl.)
Public property | IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. (Inherited from ItemsControl.)
Public property | IsVirtualizing |
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Item |
Public property | ItemBindingGroup | Gets or sets the BindingGroup that is copied to each item in the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemBoundsSizeMultiplier |
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from ItemsControl.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for the logical child objects of the ItemsControl object. (Inherited from ItemsControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RealizationBatchSize |
Public property | RealizationPriority |
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | SuppressArrangeInvalidation |
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | VisibleItemsCount |
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.AheadRealizationViewportFraction Property

OverlayAheadRealizationViewportFraction Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double AheadRealizationViewportFraction { get; set; }
public:
property double AheadRealizationViewportFraction {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.Canvas Property

OverlayCanvas Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public VirtualizingCanvas Canvas { get; }
public:
property VirtualizingCanvas^ Canvas {
    VirtualizingCanvas^ get ();
}

Property Value

Type: VirtualizingCanvas
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.InitialBounds Property

OverlayInitialBounds Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList<Rect> InitialBounds { get; set; }
public:
property IList<Rect>^ InitialBounds {
    IList<Rect>^ get ();
    void set (IList<Rect>^ value);
}

Property Value

Type: IListRect
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.IsVirtualizing Property

OverlayIsVirtualizing Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsVirtualizing { get; set; }
public:
property bool IsVirtualizing {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.Item Property

OverlayItem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Rect this[
    int index,
    bool refresh = false
] { get; set; }
public:
property Rect default[int index, bool refresh = false] {
    Rect get (int index, bool refresh = false);
    void set (int index, bool refresh = false, Rect value);
}

Parameters

index
Type: SystemInt32
refresh (Optional)
Type: SystemBoolean

Property Value

Type: Rect
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.ItemBoundsSizeMultiplier Property

OverlayItemBoundsSizeMultiplier Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double ItemBoundsSizeMultiplier { get; set; }
public:
property double ItemBoundsSizeMultiplier {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.RealizationBatchSize Property

OverlayRealizationBatchSize Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int RealizationBatchSize { get; set; }
public:
property int RealizationBatchSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.RealizationPriority Property

OverlayRealizationPriority Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DispatcherPriority RealizationPriority { get; set; }
public:
property DispatcherPriority RealizationPriority {
    DispatcherPriority get ();
    void set (DispatcherPriority value);
}

Property Value

Type: DispatcherPriority
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.SuppressArrangeInvalidation Property

OverlaySuppressArrangeInvalidation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool SuppressArrangeInvalidation { get; set; }
public:
property bool SuppressArrangeInvalidation {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.VisibleItemsCount Property

OverlayVisibleItemsCount Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int VisibleItemsCount { get; }
public:
property int VisibleItemsCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay Methods

The Overlay type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds the specified object as the child of the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds the specified text string to the ItemsControl object. (Inherited from ItemsControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Indicates that the initialization of the ItemsControl object is about to start. (Inherited from ItemsControl.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringToFront(Int32) |
Public method | BringToFront(Object) |
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride(DependencyObject, Object) method. (Inherited from ItemsControl.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | ContainerFromElement | Returns the container that belongs to the current ItemsControl that owns the given element. (Inherited from ItemsControl.)
Public method | EndInit | Indicates that the initialization of the ItemsControl object is complete. (Inherited from ItemsControl.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Inherited from ItemsControl.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetPoints(Int32) |
Public method | GetPoints(Object) |
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | GetZIndex(Int32) |
Public method | GetZIndex(Object) |
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | IndexOf |
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | IsItemItsOwnContainer | Determines if the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnAlternationCountChanged | Invoked when the AlternationCount property changes. (Inherited from ItemsControl.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDisplayMemberPathChanged | Invoked when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnGroupStyleSelectorChanged | Invoked when the GroupStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnInitialized | (Overrides FrameworkElementOnInitialized(EventArgs).)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnItemBindingGroupChanged | Invoked when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleChanged | Invoked when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
Protected method | OnItemContainerStyleSelectorChanged | Invoked when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
Protected method | OnItemsChanged | (Overrides ItemsControlOnItemsChanged(NotifyCollectionChangedEventArgs).)
Protected method | OnItemsPanelChanged | Invoked when the ItemsPanel property changes. (Inherited from ItemsControl.)
Protected method | OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControl.)
Protected method | OnItemStringFormatChanged | Invoked when the ItemStringFormat property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateChanged | Invoked when the ItemTemplate property changes. (Inherited from ItemsControl.)
Protected method | OnItemTemplateSelectorChanged | Invoked when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | Invoked when the KeyDown event is received. (Inherited from ItemsControl.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when the TextInput event is received. (Inherited from ItemsControl.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Refresh |
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetPoints(Int32, PointCollection, Boolean) |
Public method | SetPoints(Object, PointCollection, Boolean) |
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | SetZIndex(Int32, Int32) |
Public method | SetZIndex(Object, Int32) |
Protected method | ShouldApplyItemContainerStyle | Returns a value that indicates whether to apply the style from the ItemContainerStyle or ItemContainerStyleSelector property to the container element of the specified item. (Inherited from ItemsControl.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from ItemsControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeItems | Returns a value that indicates whether serialization processes should serialize the effective value of the Items property. (Inherited from ItemsControl.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Provides a string representation of the ItemsControl object. (Inherited from ItemsControl.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.BringToFront Method

OverlayBringToFront Method

Overload List
 | Name | Description
Public method | BringToFront(Int32) |
Public method | BringToFront(Object) |
Top
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.BringToFront Method (Int32)

OverlayBringToFront Method (Int32)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void BringToFront(
    int index
)
public:
void BringToFront(
    int index
)

Parameters

index
Type: SystemInt32
See Also

Reference

Overlay Class
BringToFront Overload
VisualComponents.UX.Shared Namespace


Overlay.BringToFront Method (Object)

OverlayBringToFront Method (Object)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void BringToFront(
    Object item
)
public:
void BringToFront(
    Object^ item
)

Parameters

item
Type: SystemObject
See Also

Reference

Overlay Class
BringToFront Overload
VisualComponents.UX.Shared Namespace


Overlay.GetPoints Method

OverlayGetPoints Method

Overload List
 | Name | Description
Public method | GetPoints(Int32) |
Public method | GetPoints(Object) |
Top
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.GetPoints Method (Int32)

OverlayGetPoints Method (Int32)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PointCollection GetPoints(
    int index
)
public:
PointCollection^ GetPoints(
    int index
)

Parameters

index
Type: SystemInt32

Return Value

Type: PointCollection

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Overlay.GetPoints(System.Int32)"]

See Also

Reference

Overlay Class
GetPoints Overload
VisualComponents.UX.Shared Namespace


Overlay.GetPoints Method (Object)

OverlayGetPoints Method (Object)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PointCollection GetPoints(
    Object item
)
public:
PointCollection^ GetPoints(
    Object^ item
)

Parameters

item
Type: SystemObject

Return Value

Type: PointCollection

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Overlay.GetPoints(System.Object)"]

See Also

Reference

Overlay Class
GetPoints Overload
VisualComponents.UX.Shared Namespace


Overlay.GetZIndex Method

OverlayGetZIndex Method

Overload List
 | Name | Description
Public method | GetZIndex(Int32) |
Public method | GetZIndex(Object) |
Top
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.GetZIndex Method (Int32)

OverlayGetZIndex Method (Int32)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int GetZIndex(
    int index
)
public:
int GetZIndex(
    int index
)

Parameters

index
Type: SystemInt32

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Overlay.GetZIndex(System.Int32)"]

See Also

Reference

Overlay Class
GetZIndex Overload
VisualComponents.UX.Shared Namespace


Overlay.GetZIndex Method (Object)

OverlayGetZIndex Method (Object)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int GetZIndex(
    Object item
)
public:
int GetZIndex(
    Object^ item
)

Parameters

item
Type: SystemObject

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Overlay.GetZIndex(System.Object)"]

See Also

Reference

Overlay Class
GetZIndex Overload
VisualComponents.UX.Shared Namespace


Overlay.IndexOf Method

OverlayIndexOf Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int IndexOf(
    Object item
)
public:
int IndexOf(
    Object^ item
)

Parameters

item
Type: SystemObject

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.Overlay.IndexOf(System.Object)"]

See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.OnApplyTemplate Method

OverlayOnApplyTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.OnInitialized Method

OverlayOnInitialized Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnInitialized(
    EventArgs e
)
protected:
virtual void OnInitialized(
    EventArgs^ e
) override

Parameters

e
Type: SystemEventArgs
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.OnItemsChanged Method

OverlayOnItemsChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnItemsChanged(
    NotifyCollectionChangedEventArgs e
)
protected:
virtual void OnItemsChanged(
    NotifyCollectionChangedEventArgs^ e
) override

Parameters

e
Type: System.Collections.SpecializedNotifyCollectionChangedEventArgs
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.Refresh Method

OverlayRefresh Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Refresh()
public:
void Refresh()
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.SetPoints Method

OverlaySetPoints Method

Overload List
 | Name | Description
Public method | SetPoints(Int32, PointCollection, Boolean) |
Public method | SetPoints(Object, PointCollection, Boolean) |
Top
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.SetPoints Method (Int32, PointCollection, Boolean)

OverlaySetPoints Method (Int32, PointCollection, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetPoints(
    int index,
    PointCollection points,
    bool updateReference = false
)
public:
void SetPoints(
    int index,
    PointCollection^ points,
    bool updateReference = false
)

Parameters

index
Type: SystemInt32
points
Type: System.Windows.MediaPointCollection
updateReference (Optional)
Type: SystemBoolean
See Also

Reference

Overlay Class
SetPoints Overload
VisualComponents.UX.Shared Namespace


Overlay.SetPoints Method (Object, PointCollection, Boolean)

OverlaySetPoints Method (Object, PointCollection, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetPoints(
    Object item,
    PointCollection points,
    bool updateReference = false
)
public:
void SetPoints(
    Object^ item,
    PointCollection^ points,
    bool updateReference = false
)

Parameters

item
Type: SystemObject
points
Type: System.Windows.MediaPointCollection
updateReference (Optional)
Type: SystemBoolean
See Also

Reference

Overlay Class
SetPoints Overload
VisualComponents.UX.Shared Namespace


Overlay.SetZIndex Method

OverlaySetZIndex Method

Overload List
 | Name | Description
Public method | SetZIndex(Int32, Int32) |
Public method | SetZIndex(Object, Int32) |
Top
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.SetZIndex Method (Int32, Int32)

OverlaySetZIndex Method (Int32, Int32)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetZIndex(
    int index,
    int zIndex
)
public:
void SetZIndex(
    int index,
    int zIndex
)

Parameters

index
Type: SystemInt32
zIndex
Type: SystemInt32
See Also

Reference

Overlay Class
SetZIndex Overload
VisualComponents.UX.Shared Namespace


Overlay.SetZIndex Method (Object, Int32)

OverlaySetZIndex Method (Object, Int32)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetZIndex(
    Object item,
    int zIndex
)
public:
void SetZIndex(
    Object^ item,
    int zIndex
)

Parameters

item
Type: SystemObject
zIndex
Type: SystemInt32
See Also

Reference

Overlay Class
SetZIndex Overload
VisualComponents.UX.Shared Namespace


Overlay Events

The Overlay type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay Fields

The Overlay type exposes the following members.

Fields
Name | Description
AheadRealizationViewportFractionProperty |
CanvasProperty |
CanvasPropertyKey |
IsVirtualizingProperty |
ItemBoundsSizeMultiplierProperty |
PointsProperty |
RealizationBatchSizeProperty |
RealizationPriorityProperty |
Top
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.AheadRealizationViewportFractionProperty Field

OverlayAheadRealizationViewportFractionProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty AheadRealizationViewportFractionProperty
public:
static initonly DependencyProperty^ AheadRealizationViewportFractionProperty

Field Value

Type: DependencyProperty
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.CanvasProperty Field

OverlayCanvasProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty CanvasProperty
public:
static initonly DependencyProperty^ CanvasProperty

Field Value

Type: DependencyProperty
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.CanvasPropertyKey Field

OverlayCanvasPropertyKey Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyPropertyKey CanvasPropertyKey
public:
static initonly DependencyPropertyKey^ CanvasPropertyKey

Field Value

Type: DependencyPropertyKey
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.IsVirtualizingProperty Field

OverlayIsVirtualizingProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsVirtualizingProperty
public:
static initonly DependencyProperty^ IsVirtualizingProperty

Field Value

Type: DependencyProperty
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.ItemBoundsSizeMultiplierProperty Field

OverlayItemBoundsSizeMultiplierProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ItemBoundsSizeMultiplierProperty
public:
static initonly DependencyProperty^ ItemBoundsSizeMultiplierProperty

Field Value

Type: DependencyProperty
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.PointsProperty Field

OverlayPointsProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty PointsProperty
public:
static initonly DependencyProperty^ PointsProperty

Field Value

Type: DependencyProperty
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.RealizationBatchSizeProperty Field

OverlayRealizationBatchSizeProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty RealizationBatchSizeProperty
public:
static initonly DependencyProperty^ RealizationBatchSizeProperty

Field Value

Type: DependencyProperty
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


Overlay.RealizationPriorityProperty Field

OverlayRealizationPriorityProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty RealizationPriorityProperty
public:
static initonly DependencyProperty^ RealizationPriorityProperty

Field Value

Type: DependencyProperty
See Also

Reference

Overlay Class
VisualComponents.UX.Shared Namespace


PaintColorVisualization Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum PaintColorVisualization
public enum class PaintColorVisualization
Members
Member name | Value | Description
None | 0 |
Thickness | 1 |
ActualColor | 2 |
See Also

Reference

VisualComponents.UX.Shared Namespace


PaneWindowToRestoreMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedPaneWindowToRestoreMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PaneWindowToRestoreMessage
public ref class PaneWindowToRestoreMessage

The PaneWindowToRestoreMessage type exposes the following members.

Constructors
 | Name | Description
Public method | PaneWindowToRestoreMessage | Initializes a new instance of the PaneWindowToRestoreMessage class
Top
Properties
 | Name | Description
Public property | DockManagerPane |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PaneWindowToRestoreMessage Constructor

Initializes a new instance of the PaneWindowToRestoreMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PaneWindowToRestoreMessage(
    DockManagerPane dockManagerPane
)
public:
PaneWindowToRestoreMessage(
    DockManagerPane dockManagerPane
)

Parameters

dockManagerPane
Type: VisualComponents.UX.SharedDockManagerPane
See Also

Reference

PaneWindowToRestoreMessage Class
VisualComponents.UX.Shared Namespace


PaneWindowToRestoreMessage Properties

The PaneWindowToRestoreMessage type exposes the following members.

Properties
 | Name | Description
Public property | DockManagerPane |
Top
See Also

Reference

PaneWindowToRestoreMessage Class
VisualComponents.UX.Shared Namespace


PaneWindowToRestoreMessage.DockManagerPane Property

PaneWindowToRestoreMessageDockManagerPane Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DockManagerPane DockManagerPane { get; }
public:
property DockManagerPane DockManagerPane {
    DockManagerPane get ();
}

Property Value

Type: DockManagerPane
See Also

Reference

PaneWindowToRestoreMessage Class
VisualComponents.UX.Shared Namespace


PaneWindowToRestoreMessage Methods

The PaneWindowToRestoreMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PaneWindowToRestoreMessage Class
VisualComponents.UX.Shared Namespace


PasswordAgainValidationRule Class

Inheritance Hierarchy
SystemObject
System.Windows.ControlsValidationRule
VisualComponents.UX.SharedPasswordAgainValidationRule

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PasswordAgainValidationRule : ValidationRule
public ref class PasswordAgainValidationRule : public ValidationRule

The PasswordAgainValidationRule type exposes the following members.

Constructors
 | Name | Description
Public method | PasswordAgainValidationRule | Initializes a new instance of the PasswordAgainValidationRule class
Top
Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PasswordAgainValidationRule Constructor

Initializes a new instance of the PasswordAgainValidationRule class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PasswordAgainValidationRule()
public:
PasswordAgainValidationRule()
See Also

Reference

PasswordAgainValidationRule Class
VisualComponents.UX.Shared Namespace


PasswordAgainValidationRule Properties

The PasswordAgainValidationRule type exposes the following members.

Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
See Also

Reference

PasswordAgainValidationRule Class
VisualComponents.UX.Shared Namespace


PasswordAgainValidationRule Methods

The PasswordAgainValidationRule type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PasswordAgainValidationRule Class
VisualComponents.UX.Shared Namespace


PasswordAgainValidationRule.Validate Method

PasswordAgainValidationRuleValidate Method

Overload List
 | Name | Description
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
See Also

Reference

PasswordAgainValidationRule Class
VisualComponents.UX.Shared Namespace


PasswordAgainValidationRule.Validate Method (Object, CultureInfo)

PasswordAgainValidationRuleValidate Method (Object, CultureInfo)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override ValidationResult Validate(
    Object value,
    CultureInfo cultureInfo
)
public:
virtual ValidationResult^ Validate(
    Object^ value,
    CultureInfo^ cultureInfo
) override

Parameters

value
Type: SystemObject
cultureInfo
Type: System.GlobalizationCultureInfo

Return Value

Type: ValidationResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PasswordAgainValidationRule.Validate(System.Object,System.Globalization.CultureInfo)"]

See Also

Reference

PasswordAgainValidationRule Class
Validate Overload
VisualComponents.UX.Shared Namespace


PasswordValidationRule Class

Inheritance Hierarchy
SystemObject
System.Windows.ControlsValidationRule
VisualComponents.UX.SharedPasswordValidationRule

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PasswordValidationRule : ValidationRule
public ref class PasswordValidationRule : public ValidationRule

The PasswordValidationRule type exposes the following members.

Constructors
 | Name | Description
Public method | PasswordValidationRule | Initializes a new instance of the PasswordValidationRule class
Top
Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PasswordValidationRule Constructor

Initializes a new instance of the PasswordValidationRule class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PasswordValidationRule()
public:
PasswordValidationRule()
See Also

Reference

PasswordValidationRule Class
VisualComponents.UX.Shared Namespace


PasswordValidationRule Properties

The PasswordValidationRule type exposes the following members.

Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
See Also

Reference

PasswordValidationRule Class
VisualComponents.UX.Shared Namespace


PasswordValidationRule Methods

The PasswordValidationRule type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PasswordValidationRule Class
VisualComponents.UX.Shared Namespace


PasswordValidationRule.Validate Method

PasswordValidationRuleValidate Method

Overload List
 | Name | Description
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
See Also

Reference

PasswordValidationRule Class
VisualComponents.UX.Shared Namespace


PasswordValidationRule.Validate Method (Object, CultureInfo)

PasswordValidationRuleValidate Method (Object, CultureInfo)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override ValidationResult Validate(
    Object value,
    CultureInfo cultureInfo
)
public:
virtual ValidationResult^ Validate(
    Object^ value,
    CultureInfo^ cultureInfo
) override

Parameters

value
Type: SystemObject
cultureInfo
Type: System.GlobalizationCultureInfo

Return Value

Type: ValidationResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PasswordValidationRule.Validate(System.Object,System.Globalization.CultureInfo)"]

See Also

Reference

PasswordValidationRule Class
Validate Overload
VisualComponents.UX.Shared Namespace


PathSmoothAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedPathSmoothAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PathSmoothAction : IPathSmoothAction
public ref class PathSmoothAction : IPathSmoothAction

The PathSmoothAction type exposes the following members.

Constructors
 | Name | Description
Public method | PathSmoothAction | Initializes a new instance of the PathSmoothAction class
Top
Properties
 | Name | Description
Public property | CallingCommandName |
Public property | ErrorCode |
Public property | ErrorMessage |
Public property | FinalLockAxis |
Public property | InterpolateEuclidian |
Public property | InterpolateExternalAxes |
Public property | InterpolateInWorldSpace |
Public property | InterpolateOrientation |
Public property | InterpolateTravel |
Public property | InterpolateTravelClosest |
Public property | LockAxis |
Public property | LockAxisCompensation |
Public property | NozzleOffset |
Public property | ReferencePointCount |
Public property | TargetFolder |
Public property | TargetRobot |
Public property | TargetStatement |
Public property | TargetTcp |
Top
Methods
 | Name | Description
Public method | ApplyNozzleOffset |
Public method | ApplyPathSmoothing |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RotateBetween | Create quaternion rotation from one vector to another. based on https://bitbucket.org/sinbad/ogre/src/9db75e3ba05c/OgreMain/include/OgreVector3.h#cl-651
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
DebugSmoothAction |
IS_REFERENCE_PROPERTY |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PathSmoothAction Constructor

Initializes a new instance of the PathSmoothAction class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PathSmoothAction(
    ILicensingService licensingService
)
public:
PathSmoothAction(
    ILicensingService^ licensingService
)

Parameters

licensingService
Type: VisualComponents.Create3DILicensingService
See Also

Reference

PathSmoothAction Class
VisualComponents.UX.Shared Namespace


PathSmoothAction Properties

The PathSmoothAction type exposes the following members.

Properties
 | Name | Description
Public property | CallingCommandName |
Public property | ErrorCode |
Public property | ErrorMessage |
Public property | FinalLockAxis |
Public property | InterpolateEuclidian |
Public property | InterpolateExternalAxes |
Public property | InterpolateInWorldSpace |
Public property | InterpolateOrientation |
Public property | InterpolateTravel |
Public property | InterpolateTravelClosest |
Public property | LockAxis |
Public property | LockAxisCompensation |
Public property | NozzleOffset |
Public property | ReferencePointCount |
Public property | TargetFolder |
Public property | TargetRobot |
Public property | TargetStatement |
Public property | TargetTcp |
Top
See Also

Reference

PathSmoothAction Class
VisualComponents.UX.Shared Namespace


PathSmoothAction.CallingCommandName Property

PathSmoothActionCallingCommandName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CallingCommandName { get; }
public:
property String^ CallingCommandName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

PathSmoothAction Class
VisualComponents.UX.Shared Namespace


PathSmoothAction.ErrorCode Property

PathSmoothActionErrorCode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SmoothActionErrorCode ErrorCode { get; set; }
public:
virtual property SmoothActionErrorCode ErrorCode {
    SmoothActionErrorCode get () sealed;
    void set (SmoothActionErrorCode value) sealed;
}

Property Value

Type: SmoothActionErrorCode

Implements

IPathSmoothActionErrorCode
See Also

Reference

PathSmoothAction Class
VisualComponents.UX.Shared Namespace


PathSmoothAction.ErrorMessage Property

PathSmoothActionErrorMessage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ErrorMessage { get; set; }
public:
property String^ ErrorMessage {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PathSmoothAction Class
VisualComponents.UX.Shared Namespace


PathSmoothAction.FinalLockAxis Property

PathSmoothActionFinalLockAxis Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int FinalLockAxis { get; }
public:
property int FinalLockAxis {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

PathSmoothAction Class
VisualComponents.UX.Shared Namespace


PathSmoothAction.InterpolateEuclidian Property

PathSmoothActionInterpolateEuclidian Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool InterpolateEuclidian { get; set; }
public:
virtual property bool InterpolateEuclidian {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPathSmoothActionInterpolateEuclidian
See Also

Reference

PathSmoothAction Class
VisualComponents.UX.Shared Namespace


PathSmoothAction.InterpolateExternalAxes Property

PathSmoothActionInterpolateExternalAxes Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool InterpolateExternalAxes { get; set; }
public:
virtual property bool InterpolateExternalAxes {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPathSmoothActionInterpolateExternalAxes
See Also

Reference

PathSmoothAction Class
VisualComponents.UX.Shared Namespace


PathSmoothAction.InterpolateInWorldSpace Property

PathSmoothActionInterpolateInWorldSpace Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool InterpolateInWorldSpace { get; set; }
public:
virtual property bool InterpolateInWorldSpace {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPathSmoothActionInterpolateInWorldSpace
See Also

Reference

PathSmoothAction Class
VisualComponents.UX.Shared Namespace


PathSmoothAction.InterpolateOrientation Property

PathSmoothActionInterpolateOrientation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool InterpolateOrientation { get; set; }
public:
virtual property bool InterpolateOrientation {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPathSmoothActionInterpolateOrientation
See Also

Reference

PathSmoothAction Class
VisualComponents.UX.Shared Namespace


PathSmoothAction.InterpolateTravel Property

PathSmoothActionInterpolateTravel Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool InterpolateTravel { get; set; }
public:
virtual property bool InterpolateTravel {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPathSmoothActionInterpolateTravel
See Also

Reference

PathSmoothAction Class
VisualComponents.UX.Shared Namespace


PathSmoothAction.InterpolateTravelClosest Property

PathSmoothActionInterpolateTravelClosest Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool InterpolateTravelClosest { get; set; }
public:
virtual property bool InterpolateTravelClosest {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPathSmoothActionInterpolateTravelClosest
See Also

Reference

PathSmoothAction Class
VisualComponents.UX.Shared Namespace


PathSmoothAction.LockAxis Property

PathSmoothActionLockAxis Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int LockAxis { get; set; }
public:
virtual property int LockAxis {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

IPathSmoothActionLockAxis
See Also

Reference

PathSmoothAction Class
VisualComponents.UX.Shared Namespace


PathSmoothAction.LockAxisCompensation Property

PathSmoothActionLockAxisCompensation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool LockAxisCompensation { get; set; }
public:
virtual property bool LockAxisCompensation {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPathSmoothActionLockAxisCompensation
See Also

Reference

PathSmoothAction Class
VisualComponents.UX.Shared Namespace


PathSmoothAction.NozzleOffset Property

PathSmoothActionNozzleOffset Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double NozzleOffset { get; set; }
public:
virtual property double NozzleOffset {
    double get () sealed;
    void set (double value) sealed;
}

Property Value

Type: Double

Implements

IPathSmoothActionNozzleOffset
See Also

Reference

PathSmoothAction Class
VisualComponents.UX.Shared Namespace


PathSmoothAction.ReferencePointCount Property

PathSmoothActionReferencePointCount Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ReferencePointCount { get; }
public:
virtual property int ReferencePointCount {
    int get () sealed;
}

Property Value

Type: Int32

Implements

IPathSmoothActionReferencePointCount
See Also

Reference

PathSmoothAction Class
VisualComponents.UX.Shared Namespace


PathSmoothAction.TargetFolder Property

PathSmoothActionTargetFolder Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IStatementScope TargetFolder { get; set; }
public:
virtual property IStatementScope^ TargetFolder {
    IStatementScope^ get () sealed;
    void set (IStatementScope^ value) sealed;
}

Property Value

Type: IStatementScope

Implements

IPathSmoothActionTargetFolder
See Also

Reference

PathSmoothAction Class
VisualComponents.UX.Shared Namespace


PathSmoothAction.TargetRobot Property

PathSmoothActionTargetRobot Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IRobot TargetRobot { get; }
public:
virtual property IRobot^ TargetRobot {
    IRobot^ get () sealed;
}

Property Value

Type: IRobot

Implements

IPathSmoothActionTargetRobot
See Also

Reference

PathSmoothAction Class
VisualComponents.UX.Shared Namespace


PathSmoothAction.TargetStatement Property

PathSmoothActionTargetStatement Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IPositionStatement TargetStatement { get; set; }
public:
virtual property IPositionStatement^ TargetStatement {
    IPositionStatement^ get () sealed;
    void set (IPositionStatement^ value) sealed;
}

Property Value

Type: IPositionStatement

Implements

IPathSmoothActionTargetStatement
See Also

Reference

PathSmoothAction Class
VisualComponents.UX.Shared Namespace


PathSmoothAction.TargetTcp Property

PathSmoothActionTargetTcp Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IRobotTcpManipulationTarget TargetTcp { get; set; }
public:
virtual property IRobotTcpManipulationTarget^ TargetTcp {
    IRobotTcpManipulationTarget^ get () sealed;
    void set (IRobotTcpManipulationTarget^ value) sealed;
}

Property Value

Type: IRobotTcpManipulationTarget

Implements

IPathSmoothActionTargetTcp
See Also

Reference

PathSmoothAction Class
VisualComponents.UX.Shared Namespace


PathSmoothAction Methods

The PathSmoothAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyNozzleOffset |
Public method | ApplyPathSmoothing |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RotateBetween | Create quaternion rotation from one vector to another. based on https://bitbucket.org/sinbad/ogre/src/9db75e3ba05c/OgreMain/include/OgreVector3.h#cl-651
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PathSmoothAction Class
VisualComponents.UX.Shared Namespace


PathSmoothAction.ApplyNozzleOffset Method

PathSmoothActionApplyNozzleOffset Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ApplyNozzleOffset()
public:
virtual bool ApplyNozzleOffset() sealed

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PathSmoothAction.ApplyNozzleOffset"]

Implements

IPathSmoothActionApplyNozzleOffset
See Also

Reference

PathSmoothAction Class
VisualComponents.UX.Shared Namespace


PathSmoothAction.ApplyPathSmoothing Method

PathSmoothActionApplyPathSmoothing Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ApplyPathSmoothing()
public:
virtual bool ApplyPathSmoothing() sealed

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PathSmoothAction.ApplyPathSmoothing"]

Implements

IPathSmoothActionApplyPathSmoothing
See Also

Reference

PathSmoothAction Class
VisualComponents.UX.Shared Namespace


PathSmoothAction.RotateBetween Method

PathSmoothActionRotateBetween Method

Create quaternion rotation from one vector to another. based on https://bitbucket.org/sinbad/ogre/src/9db75e3ba05c/OgreMain/include/OgreVector3.h#cl-651

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Quaternion RotateBetween(
    Vector3 oldAxisDirection,
    Vector3 newAxisTarget
)
public:
static Quaternion RotateBetween(
    Vector3 oldAxisDirection,
    Vector3 newAxisTarget
)

Parameters

oldAxisDirection
Type: VisualComponents.Create3DVector3
newAxisTarget
Type: VisualComponents.Create3DVector3

Return Value

Type: Quaternion

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PathSmoothAction.RotateBetween(VisualComponents.Create3D.Vector3,VisualComponents.Create3D.Vector3)"]

See Also

Reference

PathSmoothAction Class
VisualComponents.UX.Shared Namespace


PathSmoothAction Fields

The PathSmoothAction type exposes the following members.

Fields
Name | Description
DebugSmoothAction |
IS_REFERENCE_PROPERTY |
Top
See Also

Reference

PathSmoothAction Class
VisualComponents.UX.Shared Namespace


PathSmoothAction.DebugSmoothAction Field

PathSmoothActionDebugSmoothAction Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool DebugSmoothAction
public:
static bool DebugSmoothAction

Field Value

Type: Boolean
See Also

Reference

PathSmoothAction Class
VisualComponents.UX.Shared Namespace


PathSmoothAction.IS_REFERENCE_PROPERTY Field

PathSmoothActionIS_REFERENCE_PROPERTY Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string IS_REFERENCE_PROPERTY = "ReferencePoint"
public:
literal String^ IS_REFERENCE_PROPERTY = "ReferencePoint"

Field Value

Type: String
See Also

Reference

PathSmoothAction Class
VisualComponents.UX.Shared Namespace


PathTeachPoint Structure

Information about path point.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct PathTeachPoint
public value class PathTeachPoint

The PathTeachPoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | OffsettedPosition | Position offsetted by "Curve Offset" parameters
Public field | OriginalCurveDistance | Distance along the source curve.
Public field | OriginalEdge | Source curve.
Public field | OriginalPosition | Position where x-axis is pointing in the direction of movement and z-axis along surface normal.
Public field | OriginalVisual | Source node.
Public field | RightHandedPosition | Final position with Z-axis and position from OffsettedPosition, but X and Y axes from robot's current TCP location. This can be passed to IMotionTarget.TargetMatrix.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PathTeachPoint Methods

The PathTeachPoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PathTeachPoint Structure
VisualComponents.UX.Shared Namespace


PathTeachPoint Fields

The PathTeachPoint type exposes the following members.

Fields
 | Name | Description
Public field | OffsettedPosition | Position offsetted by "Curve Offset" parameters
Public field | OriginalCurveDistance | Distance along the source curve.
Public field | OriginalEdge | Source curve.
Public field | OriginalPosition | Position where x-axis is pointing in the direction of movement and z-axis along surface normal.
Public field | OriginalVisual | Source node.
Public field | RightHandedPosition | Final position with Z-axis and position from OffsettedPosition, but X and Y axes from robot's current TCP location. This can be passed to IMotionTarget.TargetMatrix.
Top
See Also

Reference

PathTeachPoint Structure
VisualComponents.UX.Shared Namespace


PathTeachPoint.OffsettedPosition Field

PathTeachPointOffsettedPosition Field

Position offsetted by "Curve Offset" parameters

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Matrix OffsettedPosition
public:
Matrix OffsettedPosition

Field Value

Type: Matrix
See Also

Reference

PathTeachPoint Structure
VisualComponents.UX.Shared Namespace


PathTeachPoint.OriginalCurveDistance Field

PathTeachPointOriginalCurveDistance Field

Distance along the source curve.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double OriginalCurveDistance
public:
double OriginalCurveDistance

Field Value

Type: Double
See Also

Reference

PathTeachPoint Structure
VisualComponents.UX.Shared Namespace


PathTeachPoint.OriginalEdge Field

PathTeachPointOriginalEdge Field

Source curve.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEdge OriginalEdge
public:
IEdge^ OriginalEdge

Field Value

Type: IEdge
See Also

Reference

PathTeachPoint Structure
VisualComponents.UX.Shared Namespace


PathTeachPoint.OriginalPosition Field

PathTeachPointOriginalPosition Field

Position where x-axis is pointing in the direction of movement and z-axis along surface normal.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Matrix OriginalPosition
public:
Matrix OriginalPosition

Field Value

Type: Matrix
See Also

Reference

PathTeachPoint Structure
VisualComponents.UX.Shared Namespace


PathTeachPoint.OriginalVisual Field

PathTeachPointOriginalVisual Field

Source node.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IVisualObject OriginalVisual
public:
IVisualObject^ OriginalVisual

Field Value

Type: IVisualObject
See Also

Reference

PathTeachPoint Structure
VisualComponents.UX.Shared Namespace


PathTeachPoint.RightHandedPosition Field

PathTeachPointRightHandedPosition Field

Final position with Z-axis and position from OffsettedPosition, but X and Y axes from robot's current TCP location. This can be passed to IMotionTarget.TargetMatrix.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Matrix RightHandedPosition
public:
Matrix RightHandedPosition

Field Value

Type: Matrix
See Also

Reference

PathTeachPoint Structure
VisualComponents.UX.Shared Namespace


PathTeachResultType Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum PathTeachResultType
public enum class PathTeachResultType
Members
Member name | Value | Description
None | 0 |
FirstSelection | 1 |
HoverOverSelected | 2 |
NextSegments | 3 |
NoNextSegments | 4 |
HoverOverFace | 5 |
WithTrim | 6 |
See Also

Reference

VisualComponents.UX.Shared Namespace


PathTeachSegment Class

Information about a part of a curve.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedPathTeachSegment

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PathTeachSegment
public ref class PathTeachSegment

The PathTeachSegment type exposes the following members.

Constructors
 | Name | Description
Public method | PathTeachSegment(Int32, SnapResult) | Initializes a new instance of the PathTeachSegment class
Public method | PathTeachSegment(Int32, IVisualObject, ITopologyBaseCurve) | Initializes a new instance of the PathTeachSegment class
Top
Properties
 | Name | Description
Public property | AddedToTheEnd |
Public property | AngleFromPrevious |
Public property | AverageEdgeLength |
Public property | ContinuesTowardsTheEnd |
Public property | DefaultNormal |
Public property | DefaultSide |
Public property | DistanceFromPrevious |
Public property | Edge |
Public property | EndDirections |
Public property | EndDistances |
Public property | EndPoints |
Public property | FlipCount |
Public property | HasConnector |
Public property | HasExtraPoint |
Public property | IsValid |
Public property | NextSegment |
Public property | Order |
Public property | PathPositionDistances |
Public property | PathPositions |
Public property | PrevSegment |
Public property | SideFlipped |
Public property | TopologyNormalUsage |
Public property | VisualObject |
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PathTeachSegment Constructor

Overload List
 | Name | Description
Public method | PathTeachSegment(Int32, SnapResult) | Initializes a new instance of the PathTeachSegment class
Public method | PathTeachSegment(Int32, IVisualObject, ITopologyBaseCurve) | Initializes a new instance of the PathTeachSegment class
Top
See Also

Reference

PathTeachSegment Class
VisualComponents.UX.Shared Namespace


PathTeachSegment Constructor (Int32, SnapResult)

Initializes a new instance of the PathTeachSegment class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PathTeachSegment(
    int order,
    SnapResult snap
)
public:
PathTeachSegment(
    int order,
    SnapResult snap
)

Parameters

order
Type: SystemInt32
snap
Type: VisualComponents.Create3DSnapResult
See Also

Reference

PathTeachSegment Class
PathTeachSegment Overload
VisualComponents.UX.Shared Namespace


PathTeachSegment Constructor (Int32, IVisualObject, ITopologyBaseCurve)

Initializes a new instance of the PathTeachSegment class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PathTeachSegment(
    int order,
    IVisualObject vis,
    ITopologyBaseCurve curve
)
public:
PathTeachSegment(
    int order,
    IVisualObject^ vis,
    ITopologyBaseCurve^ curve
)

Parameters

order
Type: SystemInt32
vis
Type: VisualComponents.Create3DIVisualObject
curve
Type: VisualComponents.Create3DITopologyBaseCurve
See Also

Reference

PathTeachSegment Class
PathTeachSegment Overload
VisualComponents.UX.Shared Namespace


PathTeachSegment Properties

The PathTeachSegment type exposes the following members.

Properties
 | Name | Description
Public property | AddedToTheEnd |
Public property | AngleFromPrevious |
Public property | AverageEdgeLength |
Public property | ContinuesTowardsTheEnd |
Public property | DefaultNormal |
Public property | DefaultSide |
Public property | DistanceFromPrevious |
Public property | Edge |
Public property | EndDirections |
Public property | EndDistances |
Public property | EndPoints |
Public property | FlipCount |
Public property | HasConnector |
Public property | HasExtraPoint |
Public property | IsValid |
Public property | NextSegment |
Public property | Order |
Public property | PathPositionDistances |
Public property | PathPositions |
Public property | PrevSegment |
Public property | SideFlipped |
Public property | TopologyNormalUsage |
Public property | VisualObject |
Top
See Also

Reference

PathTeachSegment Class
VisualComponents.UX.Shared Namespace


PathTeachSegment.AddedToTheEnd Property

PathTeachSegmentAddedToTheEnd Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool AddedToTheEnd { get; set; }
public:
property bool AddedToTheEnd {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PathTeachSegment Class
VisualComponents.UX.Shared Namespace


PathTeachSegment.AngleFromPrevious Property

PathTeachSegmentAngleFromPrevious Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double AngleFromPrevious { get; set; }
public:
property double AngleFromPrevious {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

PathTeachSegment Class
VisualComponents.UX.Shared Namespace


PathTeachSegment.AverageEdgeLength Property

PathTeachSegmentAverageEdgeLength Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double AverageEdgeLength { get; set; }
public:
property double AverageEdgeLength {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

PathTeachSegment Class
VisualComponents.UX.Shared Namespace


PathTeachSegment.ContinuesTowardsTheEnd Property

PathTeachSegmentContinuesTowardsTheEnd Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ContinuesTowardsTheEnd { get; set; }
public:
property bool ContinuesTowardsTheEnd {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PathTeachSegment Class
VisualComponents.UX.Shared Namespace


PathTeachSegment.DefaultNormal Property

PathTeachSegmentDefaultNormal Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 DefaultNormal { get; set; }
public:
property Vector3 DefaultNormal {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

PathTeachSegment Class
VisualComponents.UX.Shared Namespace


PathTeachSegment.DefaultSide Property

PathTeachSegmentDefaultSide Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 DefaultSide { get; set; }
public:
property Vector3 DefaultSide {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

PathTeachSegment Class
VisualComponents.UX.Shared Namespace


PathTeachSegment.DistanceFromPrevious Property

PathTeachSegmentDistanceFromPrevious Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double DistanceFromPrevious { get; set; }
public:
property double DistanceFromPrevious {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

PathTeachSegment Class
VisualComponents.UX.Shared Namespace


PathTeachSegment.Edge Property

PathTeachSegmentEdge Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEdge Edge { get; }
public:
property IEdge^ Edge {
    IEdge^ get ();
}

Property Value

Type: IEdge
See Also

Reference

PathTeachSegment Class
VisualComponents.UX.Shared Namespace


PathTeachSegment.EndDirections Property

PathTeachSegmentEndDirections Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Tuple<Vector3, Vector3> EndDirections { get; set; }
public:
property Tuple<Vector3, Vector3>^ EndDirections {
    Tuple<Vector3, Vector3>^ get ();
    void set (Tuple<Vector3, Vector3>^ value);
}

Property Value

Type: TupleVector3, Vector3
See Also

Reference

PathTeachSegment Class
VisualComponents.UX.Shared Namespace


PathTeachSegment.EndDistances Property

PathTeachSegmentEndDistances Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Tuple<double, double> EndDistances { get; set; }
public:
property Tuple<double, double>^ EndDistances {
    Tuple<double, double>^ get ();
    void set (Tuple<double, double>^ value);
}

Property Value

Type: TupleDouble, Double
See Also

Reference

PathTeachSegment Class
VisualComponents.UX.Shared Namespace


PathTeachSegment.EndPoints Property

PathTeachSegmentEndPoints Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Tuple<Vector3, Vector3> EndPoints { get; set; }
public:
property Tuple<Vector3, Vector3>^ EndPoints {
    Tuple<Vector3, Vector3>^ get ();
    void set (Tuple<Vector3, Vector3>^ value);
}

Property Value

Type: TupleVector3, Vector3
See Also

Reference

PathTeachSegment Class
VisualComponents.UX.Shared Namespace


PathTeachSegment.FlipCount Property

PathTeachSegmentFlipCount Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int FlipCount { get; set; }
public:
property int FlipCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

PathTeachSegment Class
VisualComponents.UX.Shared Namespace


PathTeachSegment.HasConnector Property

PathTeachSegmentHasConnector Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HasConnector { get; set; }
public:
property bool HasConnector {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PathTeachSegment Class
VisualComponents.UX.Shared Namespace


PathTeachSegment.HasExtraPoint Property

PathTeachSegmentHasExtraPoint Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HasExtraPoint { get; set; }
public:
property bool HasExtraPoint {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PathTeachSegment Class
VisualComponents.UX.Shared Namespace


PathTeachSegment.IsValid Property

PathTeachSegmentIsValid Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsValid { get; set; }
public:
property bool IsValid {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PathTeachSegment Class
VisualComponents.UX.Shared Namespace


PathTeachSegment.NextSegment Property

PathTeachSegmentNextSegment Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PathTeachSegment NextSegment { get; set; }
public:
property PathTeachSegment^ NextSegment {
    PathTeachSegment^ get ();
    void set (PathTeachSegment^ value);
}

Property Value

Type: PathTeachSegment
See Also

Reference

PathTeachSegment Class
VisualComponents.UX.Shared Namespace


PathTeachSegment.Order Property

PathTeachSegmentOrder Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Order { get; }
public:
property int Order {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

PathTeachSegment Class
VisualComponents.UX.Shared Namespace


PathTeachSegment.PathPositionDistances Property

PathTeachSegmentPathPositionDistances Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<double> PathPositionDistances { get; set; }
public:
property List<double>^ PathPositionDistances {
    List<double>^ get ();
    void set (List<double>^ value);
}

Property Value

Type: ListDouble
See Also

Reference

PathTeachSegment Class
VisualComponents.UX.Shared Namespace


PathTeachSegment.PathPositions Property

PathTeachSegmentPathPositions Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<Matrix> PathPositions { get; set; }
public:
property List<Matrix>^ PathPositions {
    List<Matrix>^ get ();
    void set (List<Matrix>^ value);
}

Property Value

Type: ListMatrix
See Also

Reference

PathTeachSegment Class
VisualComponents.UX.Shared Namespace


PathTeachSegment.PrevSegment Property

PathTeachSegmentPrevSegment Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PathTeachSegment PrevSegment { get; set; }
public:
property PathTeachSegment^ PrevSegment {
    PathTeachSegment^ get ();
    void set (PathTeachSegment^ value);
}

Property Value

Type: PathTeachSegment
See Also

Reference

PathTeachSegment Class
VisualComponents.UX.Shared Namespace


PathTeachSegment.SideFlipped Property

PathTeachSegmentSideFlipped Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool SideFlipped { get; set; }
public:
property bool SideFlipped {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PathTeachSegment Class
VisualComponents.UX.Shared Namespace


PathTeachSegment.TopologyNormalUsage Property

PathTeachSegmentTopologyNormalUsage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int TopologyNormalUsage { get; set; }
public:
property int TopologyNormalUsage {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

PathTeachSegment Class
VisualComponents.UX.Shared Namespace


PathTeachSegment.VisualObject Property

PathTeachSegmentVisualObject Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IVisualObject VisualObject { get; set; }
public:
property IVisualObject^ VisualObject {
    IVisualObject^ get ();
    void set (IVisualObject^ value);
}

Property Value

Type: IVisualObject
See Also

Reference

PathTeachSegment Class
VisualComponents.UX.Shared Namespace


PathTeachSegment Methods

The PathTeachSegment type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PathTeachSegment Class
VisualComponents.UX.Shared Namespace


PathTeachSegment.Clone Method

PathTeachSegmentClone Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PathTeachSegment Clone()
public:
PathTeachSegment^ Clone()

Return Value

Type: PathTeachSegment

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PathTeachSegment.Clone"]

See Also

Reference

PathTeachSegment Class
VisualComponents.UX.Shared Namespace


PathTeachSegment.ToString Method

PathTeachSegmentToString Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PathTeachSegment.ToString"]

See Also

Reference

PathTeachSegment Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper Class

Snaps based on current state of PathTeachAction.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedPathTeachSnapper

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class PathTeachSnapper : ICustomSnapper
public ref class PathTeachSnapper sealed : ICustomSnapper

The PathTeachSnapper type exposes the following members.

Constructors
 | Name | Description
Public method | PathTeachSnapper | Initializes a new instance of the PathTeachSnapper class
Top
Properties
 | Name | Description
Public property | LastResultTrimCountReal |
Public property | NextResultType |
Public property | NextSegments |
Top
Methods
 | Name | Description
Public method | AcceptResult | Parses _nextSegments into _selectedPath
 | AngleBetween |
Public method | ConnectSegments |
Public method | CustomRender | Render the segments in _selectedPath and _nextSegments
Public method | CustomSnap |
Public method | DeleteHighlighted |
Public method | DeleteLast |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCustomGeometry |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPathAxis |
Public method | GetPathPosition |
Public method | GetSelectedPath |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasResult |
Public method | IsHoveringOverSelected |
 | PointOnCircle |
Public method | RenderPathArrows |
Public method | RenderPathLine |
Public method | RenderPathPoints |
Public method | ResetSnapper |
 | RotateBetween | Create quaternion rotation from one vector to another. based on https://bitbucket.org/sinbad/ogre/src/9db75e3ba05c/OgreMain/include/OgreVector3.h#cl-651
Public method | RotateHighlighted |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimHighlighted |
Public method | UpdateSnapResults |
Top
Fields
 | Name | Description
Public field | Settings |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PathTeachSnapper Constructor

Initializes a new instance of the PathTeachSnapper class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PathTeachSnapper()
public:
PathTeachSnapper()
See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper Properties

The PathTeachSnapper type exposes the following members.

Properties
 | Name | Description
Public property | LastResultTrimCountReal |
Public property | NextResultType |
Public property | NextSegments |
Top
See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper.LastResultTrimCountReal Property

PathTeachSnapperLastResultTrimCountReal Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int LastResultTrimCountReal { get; }
public:
property int LastResultTrimCountReal {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper.NextResultType Property

PathTeachSnapperNextResultType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PathTeachResultType NextResultType { get; }
public:
property PathTeachResultType NextResultType {
    PathTeachResultType get ();
}

Property Value

Type: PathTeachResultType
See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper.NextSegments Property

PathTeachSnapperNextSegments Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<PathTeachSegment> NextSegments { get; }
public:
property List<PathTeachSegment^>^ NextSegments {
    List<PathTeachSegment^>^ get ();
}

Property Value

Type: ListPathTeachSegment
See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper Methods

The PathTeachSnapper type exposes the following members.

Methods
 | Name | Description
Public method | AcceptResult | Parses _nextSegments into _selectedPath
 | AngleBetween |
Public method | ConnectSegments |
Public method | CustomRender | Render the segments in _selectedPath and _nextSegments
Public method | CustomSnap |
Public method | DeleteHighlighted |
Public method | DeleteLast |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCustomGeometry |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPathAxis |
Public method | GetPathPosition |
Public method | GetSelectedPath |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasResult |
Public method | IsHoveringOverSelected |
 | PointOnCircle |
Public method | RenderPathArrows |
Public method | RenderPathLine |
Public method | RenderPathPoints |
Public method | ResetSnapper |
 | RotateBetween | Create quaternion rotation from one vector to another. based on https://bitbucket.org/sinbad/ogre/src/9db75e3ba05c/OgreMain/include/OgreVector3.h#cl-651
Public method | RotateHighlighted |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimHighlighted |
Public method | UpdateSnapResults |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper.AcceptResult Method

PathTeachSnapperAcceptResult Method

Parses _nextSegments into _selectedPath

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void AcceptResult()
public:
void AcceptResult()
See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper.AngleBetween Method

PathTeachSnapperAngleBetween Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static double AngleBetween(
    Vector3 v1,
    Vector3 v2
)
public:
static double AngleBetween(
    Vector3 v1,
    Vector3 v2
)

Parameters

v1
Type: VisualComponents.Create3DVector3
v2
Type: VisualComponents.Create3DVector3

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PathTeachSnapper.AngleBetween(VisualComponents.Create3D.Vector3,VisualComponents.Create3D.Vector3)"]

See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper.ConnectSegments Method

PathTeachSnapperConnectSegments Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ConnectSegments(
    PathTeachSegment s1,
    PathTeachSegment s2
)
public:
void ConnectSegments(
    PathTeachSegment^ s1,
    PathTeachSegment^ s2
)

Parameters

s1
Type: VisualComponents.UX.SharedPathTeachSegment
s2
Type: VisualComponents.UX.SharedPathTeachSegment
See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper.CustomRender Method

PathTeachSnapperCustomRender Method

Render the segments in _selectedPath and _nextSegments

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CustomRender(
    SnapResult result,
    int subMeshIndex,
    ref Geometry3D mesh,
    ref Color color
)
public:
virtual bool CustomRender(
    SnapResult result,
    int subMeshIndex,
    Geometry3D^% mesh,
    Color% color
) sealed

Parameters

result
Type: VisualComponents.Create3DSnapResult
not used here
subMeshIndex
Type: SystemInt32
one of RenderMeshType
mesh
Type: System.Windows.Media.Media3DGeometry3D
color
Type: System.Windows.MediaColor

Return Value

Type: Boolean
bool if render is successfull

Implements

ICustomSnapperCustomRender(SnapResult, Int32, Geometry3D, Color)
Remarks
The method will be called in a loop from the outside without limit, so it MUST return "false" once there is nothing to render.
See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper.CustomSnap Method

PathTeachSnapperCustomSnap Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<SnapResult> CustomSnap(
    int x,
    int y,
    SnapResult[] baseResults
)
public:
virtual Nullable<SnapResult> CustomSnap(
    int x,
    int y,
    array<SnapResult>^ baseResults
) sealed

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
baseResults
Type: VisualComponents.Create3DSnapResult

Return Value

Type: NullableSnapResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PathTeachSnapper.CustomSnap(System.Int32,System.Int32,VisualComponents.Create3D.SnapResult[])"]

Implements

ICustomSnapperCustomSnap(Int32, Int32, SnapResult)
See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper.DeleteHighlighted Method

PathTeachSnapperDeleteHighlighted Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void DeleteHighlighted()
public:
void DeleteHighlighted()
See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper.DeleteLast Method

PathTeachSnapperDeleteLast Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void DeleteLast()
public:
void DeleteLast()
See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper.GetCustomGeometry Method

PathTeachSnapperGetCustomGeometry Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string[] GetCustomGeometry()
public:
virtual array<String^>^ GetCustomGeometry() sealed

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PathTeachSnapper.GetCustomGeometry"]

Implements

ICustomSnapperGetCustomGeometry
See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper.GetPathAxis Method

PathTeachSnapperGetPathAxis Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 GetPathAxis(
    bool rotateWithOffset,
    int axis,
    PathTeachSegment seg,
    int index
)
public:
Vector3 GetPathAxis(
    bool rotateWithOffset,
    int axis,
    PathTeachSegment^ seg,
    int index
)

Parameters

rotateWithOffset
Type: SystemBoolean
axis
Type: SystemInt32
seg
Type: VisualComponents.UX.SharedPathTeachSegment
index
Type: SystemInt32

Return Value

Type: Vector3

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PathTeachSnapper.GetPathAxis(System.Boolean,System.Int32,VisualComponents.UX.Shared.PathTeachSegment,System.Int32)"]

See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper.GetPathPosition Method

PathTeachSnapperGetPathPosition Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 GetPathPosition(
    PathTeachSegment seg,
    int index,
    bool middle,
    ref int lastEndsAtSame,
    bool prevNextInfoValid
)
public:
Vector3 GetPathPosition(
    PathTeachSegment^ seg,
    int index,
    bool middle,
    int% lastEndsAtSame,
    bool prevNextInfoValid
)

Parameters

seg
Type: VisualComponents.UX.SharedPathTeachSegment
index
Type: SystemInt32
middle
Type: SystemBoolean
lastEndsAtSame
Type: SystemInt32
prevNextInfoValid
Type: SystemBoolean

Return Value

Type: Vector3

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PathTeachSnapper.GetPathPosition(VisualComponents.UX.Shared.PathTeachSegment,System.Int32,System.Boolean,System.Int32@,System.Boolean)"]

See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper.GetSelectedPath Method

PathTeachSnapperGetSelectedPath Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<PathTeachSegment> GetSelectedPath()
public:
List<PathTeachSegment^>^ GetSelectedPath()

Return Value

Type: ListPathTeachSegment

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PathTeachSnapper.GetSelectedPath"]

See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper.HasResult Method

PathTeachSnapperHasResult Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HasResult()
public:
bool HasResult()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PathTeachSnapper.HasResult"]

See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper.IsHoveringOverSelected Method

PathTeachSnapperIsHoveringOverSelected Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsHoveringOverSelected()
public:
bool IsHoveringOverSelected()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PathTeachSnapper.IsHoveringOverSelected"]

See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper.PointOnCircle Method

PathTeachSnapperPointOnCircle Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Vector3 PointOnCircle(
    double radius,
    double angleInDegrees,
    Vector3 origin,
    Vector3 axis,
    Vector3 unitVectorUp
)
public:
static Vector3 PointOnCircle(
    double radius,
    double angleInDegrees,
    Vector3 origin,
    Vector3 axis,
    Vector3 unitVectorUp
)

Parameters

radius
Type: SystemDouble
angleInDegrees
Type: SystemDouble
origin
Type: VisualComponents.Create3DVector3
axis
Type: VisualComponents.Create3DVector3
unitVectorUp
Type: VisualComponents.Create3DVector3

Return Value

Type: Vector3

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PathTeachSnapper.PointOnCircle(System.Double,System.Double,VisualComponents.Create3D.Vector3,VisualComponents.Create3D.Vector3,VisualComponents.Create3D.Vector3)"]

See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper.RenderPathArrows Method

PathTeachSnapperRenderPathArrows Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RenderPathArrows(
    PathTeachSegment seg,
    MeshBuilder mb,
    int axis,
    int subSegmentIndex,
    double scaleFactor,
    int sign
)
public:
void RenderPathArrows(
    PathTeachSegment^ seg,
    MeshBuilder^ mb,
    int axis,
    int subSegmentIndex,
    double scaleFactor,
    int sign
)

Parameters

seg
Type: VisualComponents.UX.SharedPathTeachSegment
mb
Type: MeshBuilder
axis
Type: SystemInt32
subSegmentIndex
Type: SystemInt32
scaleFactor
Type: SystemDouble
sign
Type: SystemInt32
See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper.RenderPathLine Method

PathTeachSnapperRenderPathLine Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RenderPathLine(
    PathTeachSegment seg,
    List<Matrix> points,
    MeshBuilder mb,
    int subSegmentIndex,
    double scaleFactor
)
public:
void RenderPathLine(
    PathTeachSegment^ seg,
    List<Matrix>^ points,
    MeshBuilder^ mb,
    int subSegmentIndex,
    double scaleFactor
)

Parameters

seg
Type: VisualComponents.UX.SharedPathTeachSegment
points
Type: System.Collections.GenericListMatrix
mb
Type: MeshBuilder
subSegmentIndex
Type: SystemInt32
scaleFactor
Type: SystemDouble
See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper.RenderPathPoints Method

PathTeachSnapperRenderPathPoints Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RenderPathPoints(
    PathTeachSegment seg,
    MeshBuilder mb,
    bool prevNextInfoValid
)
public:
void RenderPathPoints(
    PathTeachSegment^ seg,
    MeshBuilder^ mb,
    bool prevNextInfoValid
)

Parameters

seg
Type: VisualComponents.UX.SharedPathTeachSegment
mb
Type: MeshBuilder
prevNextInfoValid
Type: SystemBoolean
See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper.ResetSnapper Method

PathTeachSnapperResetSnapper Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ResetSnapper(
    bool enable,
    bool everything
)
public:
void ResetSnapper(
    bool enable,
    bool everything
)

Parameters

enable
Type: SystemBoolean
everything
Type: SystemBoolean
See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper.RotateBetween Method

PathTeachSnapperRotateBetween Method

Create quaternion rotation from one vector to another. based on https://bitbucket.org/sinbad/ogre/src/9db75e3ba05c/OgreMain/include/OgreVector3.h#cl-651

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Quaternion RotateBetween(
    Vector3 oldAxisDirection,
    Vector3 newAxisTarget
)
public:
static Quaternion RotateBetween(
    Vector3 oldAxisDirection,
    Vector3 newAxisTarget
)

Parameters

oldAxisDirection
Type: VisualComponents.Create3DVector3
newAxisTarget
Type: VisualComponents.Create3DVector3

Return Value

Type: Quaternion

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PathTeachSnapper.RotateBetween(VisualComponents.Create3D.Vector3,VisualComponents.Create3D.Vector3)"]

See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper.RotateHighlighted Method

PathTeachSnapperRotateHighlighted Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RotateHighlighted()
public:
void RotateHighlighted()
See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper.TrimHighlighted Method

PathTeachSnapperTrimHighlighted Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool TrimHighlighted()
public:
bool TrimHighlighted()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PathTeachSnapper.TrimHighlighted"]

See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper.UpdateSnapResults Method

PathTeachSnapperUpdateSnapResults Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void UpdateSnapResults(
    bool affectsAlreadySelected
)
public:
void UpdateSnapResults(
    bool affectsAlreadySelected
)

Parameters

affectsAlreadySelected
Type: SystemBoolean
See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper Fields

The PathTeachSnapper type exposes the following members.

Fields
 | Name | Description
Public field | Settings |
Top
See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PathTeachSnapper.Settings Field

PathTeachSnapperSettings Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<IProperty> Settings
public:
List<IProperty^>^ Settings

Field Value

Type: ListIProperty
See Also

Reference

PathTeachSnapper Class
VisualComponents.UX.Shared Namespace


PatternDesignerHelper Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedPatternDesignerHelper

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class PatternDesignerHelper
public ref class PatternDesignerHelper abstract sealed

The PatternDesignerHelper type exposes the following members.

Methods
Name | Description
ApplyTransformation |
GetSlotOffsetPosition |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PatternDesignerHelper Methods

The PatternDesignerHelper type exposes the following members.

Methods
Name | Description
ApplyTransformation |
GetSlotOffsetPosition |
Top
See Also

Reference

PatternDesignerHelper Class
VisualComponents.UX.Shared Namespace


PatternDesignerHelper.ApplyTransformation Method

PatternDesignerHelperApplyTransformation Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Matrix ApplyTransformation(
    Matrix inputPosition,
    IBoundBox inputBoundBox,
    string transformationType
)
public:
static Matrix ApplyTransformation(
    Matrix inputPosition,
    IBoundBox^ inputBoundBox,
    String^ transformationType
)

Parameters

inputPosition
Type: VisualComponents.Create3DMatrix
inputBoundBox
Type: VisualComponents.Create3DIBoundBox
transformationType
Type: SystemString

Return Value

Type: Matrix

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PatternDesignerHelper.ApplyTransformation(VisualComponents.Create3D.Matrix,VisualComponents.Create3D.IBoundBox,System.String)"]

See Also

Reference

PatternDesignerHelper Class
VisualComponents.UX.Shared Namespace


PatternDesignerHelper.GetSlotOffsetPosition Method

PatternDesignerHelperGetSlotOffsetPosition Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Matrix GetSlotOffsetPosition(
    IAssemblyPatternSlotVisualization referenceVisualSlot
)
public:
static Matrix GetSlotOffsetPosition(
    IAssemblyPatternSlotVisualization^ referenceVisualSlot
)

Parameters

referenceVisualSlot
Type: IAssemblyPatternSlotVisualization

Return Value

Type: Matrix

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PatternDesignerHelper.GetSlotOffsetPosition(VisualComponents.Create3D.IAssemblyPatternSlotVisualization)"]

See Also

Reference

PatternDesignerHelper Class
VisualComponents.UX.Shared Namespace


PdfExportAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedPdfExportAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class PdfExportAction : IResult
public ref class PdfExportAction sealed : IResult

The PdfExportAction type exposes the following members.

Constructors
 | Name | Description
Public method | PdfExportAction | Initializes a new instance of the PdfExportAction class
Top
Properties
 | Name | Description
Public property | Exporter |
Public property | OutputFile |
Public property | Result |
Public property | U3dFile |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute(ActionExecutionContext) |
 | Execute(Uri, IPdfRecordExporter, Uri) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Completed |
Top
Fields
Name | Description
BOMDESCRIPTION |
BOMNAME |
HASBOM |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PdfExportAction Constructor

Initializes a new instance of the PdfExportAction class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PdfExportAction()
public:
PdfExportAction()
See Also

Reference

PdfExportAction Class
VisualComponents.UX.Shared Namespace


PdfExportAction Properties

The PdfExportAction type exposes the following members.

Properties
 | Name | Description
Public property | Exporter |
Public property | OutputFile |
Public property | Result |
Public property | U3dFile |
Top
See Also

Reference

PdfExportAction Class
VisualComponents.UX.Shared Namespace


PdfExportAction.Exporter Property

PdfExportActionExporter Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IPdfRecordExporter Exporter { get; set; }
public:
property IPdfRecordExporter^ Exporter {
    IPdfRecordExporter^ get ();
    void set (IPdfRecordExporter^ value);
}

Property Value

Type: IPdfRecordExporter
See Also

Reference

PdfExportAction Class
VisualComponents.UX.Shared Namespace


PdfExportAction.OutputFile Property

PdfExportActionOutputFile Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Uri OutputFile { get; set; }
public:
property Uri^ OutputFile {
    Uri^ get ();
    void set (Uri^ value);
}

Property Value

Type: Uri
See Also

Reference

PdfExportAction Class
VisualComponents.UX.Shared Namespace


PdfExportAction.Result Property

PdfExportActionResult Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Result { get; }
public:
property bool Result {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

PdfExportAction Class
VisualComponents.UX.Shared Namespace


PdfExportAction.U3dFile Property

PdfExportActionU3dFile Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Uri U3dFile { get; set; }
public:
property Uri^ U3dFile {
    Uri^ get ();
    void set (Uri^ value);
}

Property Value

Type: Uri
See Also

Reference

PdfExportAction Class
VisualComponents.UX.Shared Namespace


PdfExportAction Methods

The PdfExportAction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute(ActionExecutionContext) |
 | Execute(Uri, IPdfRecordExporter, Uri) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PdfExportAction Class
VisualComponents.UX.Shared Namespace


PdfExportAction.Execute Method

PdfExportActionExecute Method

Overload List
 | Name | Description
Public method | Execute(ActionExecutionContext) |
 | Execute(Uri, IPdfRecordExporter, Uri) |
Top
See Also

Reference

PdfExportAction Class
VisualComponents.UX.Shared Namespace


PdfExportAction.Execute Method (ActionExecutionContext)

PdfExportActionExecute Method (ActionExecutionContext)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    ActionExecutionContext context
)
public:
virtual void Execute(
    ActionExecutionContext^ context
) sealed

Parameters

context
Type: ActionExecutionContext

Implements

IResult.Execute(ActionExecutionContext)
See Also

Reference

PdfExportAction Class
Execute Overload
VisualComponents.UX.Shared Namespace


PdfExportAction.Execute Method (Uri, IPdfRecordExporter, Uri)

PdfExportActionExecute Method (Uri, IPdfRecordExporter, Uri)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool Execute(
    Uri outputPath,
    IPdfRecordExporter exporter,
    Uri u3dFile
)
public:
static bool Execute(
    Uri^ outputPath,
    IPdfRecordExporter^ exporter,
    Uri^ u3dFile
)

Parameters

outputPath
Type: SystemUri
exporter
Type: VisualComponents.Create3DIPdfRecordExporter
u3dFile
Type: SystemUri

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PdfExportAction.Execute(System.Uri,VisualComponents.Create3D.IPdfRecordExporter,System.Uri)"]

See Also

Reference

PdfExportAction Class
Execute Overload
VisualComponents.UX.Shared Namespace


PdfExportAction Events

The PdfExportAction type exposes the following members.

Events
 | Name | Description
Public event | Completed |
Top
See Also

Reference

PdfExportAction Class
VisualComponents.UX.Shared Namespace


PdfExportAction.Completed Event

PdfExportActionCompleted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ResultCompletionEventArgs> Completed
public:
virtual  event EventHandler<ResultCompletionEventArgs^>^ Completed {
    void add (EventHandler<ResultCompletionEventArgs^>^ value);
    void remove (EventHandler<ResultCompletionEventArgs^>^ value);
}

Value

Type: SystemEventHandlerResultCompletionEventArgs

Implements

IResult.Completed
See Also

Reference

PdfExportAction Class
VisualComponents.UX.Shared Namespace


PdfExportAction Fields

The PdfExportAction type exposes the following members.

Fields
Name | Description
BOMDESCRIPTION |
BOMNAME |
HASBOM |
Top
See Also

Reference

PdfExportAction Class
VisualComponents.UX.Shared Namespace


PdfExportAction.BOMDESCRIPTION Field

PdfExportActionBOMDESCRIPTION Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string BOMDESCRIPTION = "BOMdescription"
public:
literal String^ BOMDESCRIPTION = "BOMdescription"

Field Value

Type: String
See Also

Reference

PdfExportAction Class
VisualComponents.UX.Shared Namespace


PdfExportAction.BOMNAME Field

PdfExportActionBOMNAME Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string BOMNAME = "BOMname"
public:
literal String^ BOMNAME = "BOMname"

Field Value

Type: String
See Also

Reference

PdfExportAction Class
VisualComponents.UX.Shared Namespace


PdfExportAction.HASBOM Field

PdfExportActionHASBOM Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string HASBOM = "BOM"
public:
literal String^ HASBOM = "BOM"

Field Value

Type: String
See Also

Reference

PdfExportAction Class
VisualComponents.UX.Shared Namespace


PdfExportActionWithGroup Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedPdfExportActionWithGroup

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class PdfExportActionWithGroup : IResult
public ref class PdfExportActionWithGroup sealed : IResult

The PdfExportActionWithGroup type exposes the following members.

Constructors
 | Name | Description
Public method | PdfExportActionWithGroup | Initializes a new instance of the PdfExportActionWithGroup class
Top
Properties
 | Name | Description
Public property | Exporter |
Public property | OutputFile |
Public property | PdfDescriptionTag |
Public property | PdfGroupDescriptionTag |
Public property | PdfGroupNameTag |
Public property | Result |
Public property | U3dFile |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute(ActionExecutionContext) |
 | Execute(Uri, IPdfRecordExporter, Uri) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Completed |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PdfExportActionWithGroup Constructor

Initializes a new instance of the PdfExportActionWithGroup class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PdfExportActionWithGroup()
public:
PdfExportActionWithGroup()
See Also

Reference

PdfExportActionWithGroup Class
VisualComponents.UX.Shared Namespace


PdfExportActionWithGroup Properties

The PdfExportActionWithGroup type exposes the following members.

Properties
 | Name | Description
Public property | Exporter |
Public property | OutputFile |
Public property | PdfDescriptionTag |
Public property | PdfGroupDescriptionTag |
Public property | PdfGroupNameTag |
Public property | Result |
Public property | U3dFile |
Top
See Also

Reference

PdfExportActionWithGroup Class
VisualComponents.UX.Shared Namespace


PdfExportActionWithGroup.Exporter Property

PdfExportActionWithGroupExporter Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IPdfRecordExporter Exporter { get; set; }
public:
property IPdfRecordExporter^ Exporter {
    IPdfRecordExporter^ get ();
    void set (IPdfRecordExporter^ value);
}

Property Value

Type: IPdfRecordExporter
See Also

Reference

PdfExportActionWithGroup Class
VisualComponents.UX.Shared Namespace


PdfExportActionWithGroup.OutputFile Property

PdfExportActionWithGroupOutputFile Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Uri OutputFile { get; set; }
public:
property Uri^ OutputFile {
    Uri^ get ();
    void set (Uri^ value);
}

Property Value

Type: Uri
See Also

Reference

PdfExportActionWithGroup Class
VisualComponents.UX.Shared Namespace


PdfExportActionWithGroup.PdfDescriptionTag Property

PdfExportActionWithGroupPdfDescriptionTag Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string PdfDescriptionTag { get; }
public:
property String^ PdfDescriptionTag {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

PdfExportActionWithGroup Class
VisualComponents.UX.Shared Namespace


PdfExportActionWithGroup.PdfGroupDescriptionTag Property

PdfExportActionWithGroupPdfGroupDescriptionTag Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string PdfGroupDescriptionTag { get; }
public:
property String^ PdfGroupDescriptionTag {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

PdfExportActionWithGroup Class
VisualComponents.UX.Shared Namespace


PdfExportActionWithGroup.PdfGroupNameTag Property

PdfExportActionWithGroupPdfGroupNameTag Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string PdfGroupNameTag { get; }
public:
property String^ PdfGroupNameTag {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

PdfExportActionWithGroup Class
VisualComponents.UX.Shared Namespace


PdfExportActionWithGroup.Result Property

PdfExportActionWithGroupResult Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Result { get; }
public:
property bool Result {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

PdfExportActionWithGroup Class
VisualComponents.UX.Shared Namespace


PdfExportActionWithGroup.U3dFile Property

PdfExportActionWithGroupU3dFile Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Uri U3dFile { get; set; }
public:
property Uri^ U3dFile {
    Uri^ get ();
    void set (Uri^ value);
}

Property Value

Type: Uri
See Also

Reference

PdfExportActionWithGroup Class
VisualComponents.UX.Shared Namespace


PdfExportActionWithGroup Methods

The PdfExportActionWithGroup type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute(ActionExecutionContext) |
 | Execute(Uri, IPdfRecordExporter, Uri) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PdfExportActionWithGroup Class
VisualComponents.UX.Shared Namespace


PdfExportActionWithGroup.Execute Method

PdfExportActionWithGroupExecute Method

Overload List
 | Name | Description
Public method | Execute(ActionExecutionContext) |
 | Execute(Uri, IPdfRecordExporter, Uri) |
Top
See Also

Reference

PdfExportActionWithGroup Class
VisualComponents.UX.Shared Namespace


PdfExportActionWithGroup.Execute Method (ActionExecutionContext)

PdfExportActionWithGroupExecute Method (ActionExecutionContext)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    ActionExecutionContext context
)
public:
virtual void Execute(
    ActionExecutionContext^ context
) sealed

Parameters

context
Type: ActionExecutionContext

Implements

IResult.Execute(ActionExecutionContext)
See Also

Reference

PdfExportActionWithGroup Class
Execute Overload
VisualComponents.UX.Shared Namespace


PdfExportActionWithGroup.Execute Method (Uri, IPdfRecordExporter, Uri)

PdfExportActionWithGroupExecute Method (Uri, IPdfRecordExporter, Uri)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool Execute(
    Uri outputPath,
    IPdfRecordExporter exporter,
    Uri u3dFile
)
public:
static bool Execute(
    Uri^ outputPath,
    IPdfRecordExporter^ exporter,
    Uri^ u3dFile
)

Parameters

outputPath
Type: SystemUri
exporter
Type: VisualComponents.Create3DIPdfRecordExporter
u3dFile
Type: SystemUri

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PdfExportActionWithGroup.Execute(System.Uri,VisualComponents.Create3D.IPdfRecordExporter,System.Uri)"]

See Also

Reference

PdfExportActionWithGroup Class
Execute Overload
VisualComponents.UX.Shared Namespace


PdfExportActionWithGroup Events

The PdfExportActionWithGroup type exposes the following members.

Events
 | Name | Description
Public event | Completed |
Top
See Also

Reference

PdfExportActionWithGroup Class
VisualComponents.UX.Shared Namespace


PdfExportActionWithGroup.Completed Event

PdfExportActionWithGroupCompleted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ResultCompletionEventArgs> Completed
public:
virtual  event EventHandler<ResultCompletionEventArgs^>^ Completed {
    void add (EventHandler<ResultCompletionEventArgs^>^ value);
    void remove (EventHandler<ResultCompletionEventArgs^>^ value);
}

Value

Type: SystemEventHandlerResultCompletionEventArgs

Implements

IResult.Completed
See Also

Reference

PdfExportActionWithGroup Class
VisualComponents.UX.Shared Namespace


PdfExporterItem Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedPdfExporterItem

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PdfExporterItem : IPdfRecordExporter,
    IRecordExporter
public ref class PdfExporterItem : IPdfRecordExporter,
    IRecordExporter

The PdfExporterItem type exposes the following members.

Constructors
 | Name | Description
Public method | PdfExporterItem | Initializes a new instance of the PdfExporterItem class
Top
Properties
 | Name | Description
Public property | Builder |
Public property | CustomProperties |
Public property | GetOutputPathFromUser |
Public property | Header |
Public property | OutputPath |
Public property | RecordingType |
Public property | TemplatePath |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Export |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PdfExporterItem Constructor

Initializes a new instance of the PdfExporterItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PdfExporterItem(
    IPdfReportBuilder exporter,
    Uri templatePath,
    IHeaderModel header
)
public:
PdfExporterItem(
    IPdfReportBuilder^ exporter,
    Uri^ templatePath,
    IHeaderModel^ header
)

Parameters

exporter
Type: VisualComponents.Create3DIPdfReportBuilder
templatePath
Type: SystemUri
header
Type: VisualComponents.UX.SharedIHeaderModel
See Also

Reference

PdfExporterItem Class
VisualComponents.UX.Shared Namespace


PdfExporterItem Properties

The PdfExporterItem type exposes the following members.

Properties
 | Name | Description
Public property | Builder |
Public property | CustomProperties |
Public property | GetOutputPathFromUser |
Public property | Header |
Public property | OutputPath |
Public property | RecordingType |
Public property | TemplatePath |
Top
See Also

Reference

PdfExporterItem Class
VisualComponents.UX.Shared Namespace


PdfExporterItem.Builder Property

PdfExporterItemBuilder Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IPdfReportBuilder Builder { get; protected set; }
public:
property IPdfReportBuilder^ Builder {
    IPdfReportBuilder^ get ();
    protected: void set (IPdfReportBuilder^ value);
}

Property Value

Type: IPdfReportBuilder
See Also

Reference

PdfExporterItem Class
VisualComponents.UX.Shared Namespace


PdfExporterItem.CustomProperties Property

PdfExporterItemCustomProperties Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObservableCollection<IProperty> CustomProperties { get; }
public:
virtual property ObservableCollection<IProperty^>^ CustomProperties {
    ObservableCollection<IProperty^>^ get () sealed;
}

Property Value

Type: ObservableCollectionIProperty

Implements

IPdfRecordExporterCustomProperties
See Also

Reference

PdfExporterItem Class
VisualComponents.UX.Shared Namespace


PdfExporterItem.GetOutputPathFromUser Property

PdfExporterItemGetOutputPathFromUser Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool GetOutputPathFromUser { get; }
public:
virtual property bool GetOutputPathFromUser {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IPdfRecordExporterGetOutputPathFromUser
See Also

Reference

PdfExporterItem Class
VisualComponents.UX.Shared Namespace


PdfExporterItem.Header Property

PdfExporterItemHeader Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IHeaderModel Header { get; protected set; }
public:
virtual property IHeaderModel^ Header {
    IHeaderModel^ get () sealed;
    protected: void set (IHeaderModel^ value) sealed;
}

Property Value

Type: IHeaderModel

Implements

IRecordExporterHeader
See Also

Reference

PdfExporterItem Class
VisualComponents.UX.Shared Namespace


PdfExporterItem.OutputPath Property

PdfExporterItemOutputPath Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Uri OutputPath { get; set; }
public:
virtual property Uri^ OutputPath {
    Uri^ get () sealed;
    void set (Uri^ value) sealed;
}

Property Value

Type: Uri

Implements

IPdfRecordExporterOutputPath
See Also

Reference

PdfExporterItem Class
VisualComponents.UX.Shared Namespace


PdfExporterItem.RecordingType Property

PdfExporterItemRecordingType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RecordingType RecordingType { get; }
public:
virtual property RecordingType RecordingType {
    RecordingType get () sealed;
}

Property Value

Type: RecordingType

Implements

IRecordExporterRecordingType
See Also

Reference

PdfExporterItem Class
VisualComponents.UX.Shared Namespace


PdfExporterItem.TemplatePath Property

PdfExporterItemTemplatePath Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Uri TemplatePath { get; protected set; }
public:
virtual property Uri^ TemplatePath {
    Uri^ get () sealed;
    protected: void set (Uri^ value) sealed;
}

Property Value

Type: Uri

Implements

IPdfRecordExporterTemplatePath
See Also

Reference

PdfExporterItem Class
VisualComponents.UX.Shared Namespace


PdfExporterItem Methods

The PdfExporterItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Export |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PdfExporterItem Class
VisualComponents.UX.Shared Namespace


PdfExporterItem.Export Method

PdfExporterItemExport Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Export(
    Uri recordPath,
    string layoutName,
    Point3D layoutCenter,
    double layoutFillDistance,
    IEnumerable<IComponentPdfInfo> componentInfo
)
public:
virtual bool Export(
    Uri^ recordPath,
    String^ layoutName,
    Point3D layoutCenter,
    double layoutFillDistance,
    IEnumerable<IComponentPdfInfo^>^ componentInfo
) sealed

Parameters

recordPath
Type: SystemUri
layoutName
Type: SystemString
layoutCenter
Type: System.Windows.Media.Media3DPoint3D
layoutFillDistance
Type: SystemDouble
componentInfo
Type: System.Collections.GenericIEnumerableIComponentPdfInfo

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PdfExporterItem.Export(System.Uri,System.String,System.Windows.Media.Media3D.Point3D,System.Double,System.Collections.Generic.IEnumerable{VisualComponents.Create3D.IComponentPdfInfo})"]

Implements

IPdfRecordExporterExport(Uri, String, Point3D, Double, IEnumerableIComponentPdfInfo)
See Also

Reference

PdfExporterItem Class
VisualComponents.UX.Shared Namespace


PdfSettingView Class

Interaction logic for PdfSettingView.xaml
PdfSettingView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedPdfSettingView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PdfSettingView : UserControl,
    IComponentConnector
public ref class PdfSettingView : public UserControl,
    IComponentConnector

The PdfSettingView type exposes the following members.

Constructors
 | Name | Description
Public method | PdfSettingView | Initializes a new instance of the PdfSettingView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PdfSettingView Constructor

Initializes a new instance of the PdfSettingView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PdfSettingView()
public:
PdfSettingView()
See Also

Reference

PdfSettingView Class
VisualComponents.UX.Shared Namespace


PdfSettingView Properties

The PdfSettingView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

PdfSettingView Class
VisualComponents.UX.Shared Namespace


PdfSettingView Methods

The PdfSettingView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PdfSettingView Class
VisualComponents.UX.Shared Namespace


PdfSettingView.InitializeComponent Method

PdfSettingViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

PdfSettingView Class
VisualComponents.UX.Shared Namespace


PdfSettingView Events

The PdfSettingView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

PdfSettingView Class
VisualComponents.UX.Shared Namespace


PhysicsJointD6EditorView Class

Interaction logic for PhysicsJointD6EditorView.xaml
PhysicsJointD6EditorView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedUserControlOptimizedView
VisualComponents.UX.SharedPhysicsJointD6EditorView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PhysicsJointD6EditorView : UserControlOptimizedView,
    IComponentConnector
public ref class PhysicsJointD6EditorView : public UserControlOptimizedView,
    IComponentConnector

The PhysicsJointD6EditorView type exposes the following members.

Constructors
 | Name | Description
Public method | PhysicsJointD6EditorView | Initializes a new instance of the PhysicsJointD6EditorView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | (Inherited from UserControlOptimizedView.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PhysicsJointD6EditorView Constructor

Initializes a new instance of the PhysicsJointD6EditorView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PhysicsJointD6EditorView()
public:
PhysicsJointD6EditorView()
See Also

Reference

PhysicsJointD6EditorView Class
VisualComponents.UX.Shared Namespace


PhysicsJointD6EditorView Properties

The PhysicsJointD6EditorView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

PhysicsJointD6EditorView Class
VisualComponents.UX.Shared Namespace


PhysicsJointD6EditorView Methods

The PhysicsJointD6EditorView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | (Inherited from UserControlOptimizedView.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PhysicsJointD6EditorView Class
VisualComponents.UX.Shared Namespace


PhysicsJointD6EditorView.InitializeComponent Method

PhysicsJointD6EditorViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

PhysicsJointD6EditorView Class
VisualComponents.UX.Shared Namespace


PhysicsJointD6EditorView Events

The PhysicsJointD6EditorView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

PhysicsJointD6EditorView Class
VisualComponents.UX.Shared Namespace


PhysicsRopeEditorView Class

Interaction logic for PhysicsRopeEditorView.xaml
PhysicsRopeEditorView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedPhysicsRopeEditorView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PhysicsRopeEditorView : UserControl,
    IComponentConnector
public ref class PhysicsRopeEditorView : public UserControl,
    IComponentConnector

The PhysicsRopeEditorView type exposes the following members.

Constructors
 | Name | Description
Public method | PhysicsRopeEditorView | Initializes a new instance of the PhysicsRopeEditorView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PhysicsRopeEditorView Constructor

Initializes a new instance of the PhysicsRopeEditorView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PhysicsRopeEditorView()
public:
PhysicsRopeEditorView()
See Also

Reference

PhysicsRopeEditorView Class
VisualComponents.UX.Shared Namespace


PhysicsRopeEditorView Properties

The PhysicsRopeEditorView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

PhysicsRopeEditorView Class
VisualComponents.UX.Shared Namespace


PhysicsRopeEditorView Methods

The PhysicsRopeEditorView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PhysicsRopeEditorView Class
VisualComponents.UX.Shared Namespace


PhysicsRopeEditorView.InitializeComponent Method

PhysicsRopeEditorViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

PhysicsRopeEditorView Class
VisualComponents.UX.Shared Namespace


PhysicsRopeEditorView Events

The PhysicsRopeEditorView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

PhysicsRopeEditorView Class
VisualComponents.UX.Shared Namespace


PickAction Class

Action that waits for pick in 3D world.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedPickAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class PickAction : IResult,
    IHandle<SnapCompletedMessage>, IHandle, IHandle<SnapCompletedAltMessage>,
    IHandle<InternalEndInteractionMessage>, IHandle<RequestActionAbortMessage>, IHandle<MouseMessage>
public ref class PickAction sealed : IResult,
    IHandle<SnapCompletedMessage^>, IHandle, IHandle<SnapCompletedAltMessage^>,
    IHandle<InternalEndInteractionMessage^>, IHandle<RequestActionAbortMessage^>, IHandle<MouseMessage^>

The PickAction type exposes the following members.

Constructors
 | Name | Description
Public method | PickAction | Initializes a new instance of the PickAction class
Top
Properties
 | Name | Description
Public property | AbortOnSelection |
Public property | Filter |
Public property | HighlightResult | This affects how FocusManipulator handles PickMessage messages.
Public property | IsFinished |
 | LastPickPoint |
 | LastPickResult |
Public property | PickPoint |
Public property | PickResult |
Public property | SnapOnMouseUp |
Public property | X |
Public property | Y |
Top
Methods
 | Name | Description
Public method | Cancel |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle(InternalEndInteractionMessage) |
Public method | Handle(MouseMessage) |
Public method | Handle(RequestActionAbortMessage) |
Public method | Handle(SnapCompletedAltMessage) |
Public method | Handle(SnapCompletedMessage) |
 | HideFocusAndText |
Public method | PickAtXY |
Public method | StartAction | This action will stay resident until mouse button is released. Used PickAtXY to pick immediately.
Public method | StartActionHelper |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Completed |
Top
Fields
 | Name | Description
Public field | MatchResult |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PickAction Constructor

Initializes a new instance of the PickAction class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PickAction()
public:
PickAction()
See Also

Reference

PickAction Class
VisualComponents.UX.Shared Namespace


PickAction Properties

The PickAction type exposes the following members.

Properties
 | Name | Description
Public property | AbortOnSelection |
Public property | Filter |
Public property | HighlightResult | This affects how FocusManipulator handles PickMessage messages.
Public property | IsFinished |
 | LastPickPoint |
 | LastPickResult |
Public property | PickPoint |
Public property | PickResult |
Public property | SnapOnMouseUp |
Public property | X |
Public property | Y |
Top
See Also

Reference

PickAction Class
VisualComponents.UX.Shared Namespace


PickAction.AbortOnSelection Property

PickActionAbortOnSelection Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool AbortOnSelection { get; set; }
public:
property bool AbortOnSelection {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PickAction Class
VisualComponents.UX.Shared Namespace


PickAction.Filter Property

PickActionFilter Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SelectionTypes Filter { get; set; }
public:
property SelectionTypes Filter {
    SelectionTypes get ();
    void set (SelectionTypes value);
}

Property Value

Type: SelectionTypes
See Also

Reference

PickAction Class
VisualComponents.UX.Shared Namespace


PickAction.HighlightResult Property

PickActionHighlightResult Property

This affects how FocusManipulator handles PickMessage messages.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HighlightResult { get; set; }
public:
property bool HighlightResult {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PickAction Class
VisualComponents.UX.Shared Namespace


PickAction.IsFinished Property

PickActionIsFinished Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsFinished { get; }
public:
property bool IsFinished {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

PickAction Class
VisualComponents.UX.Shared Namespace


PickAction.LastPickPoint Property

PickActionLastPickPoint Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Point LastPickPoint { get; set; }
public:
static property Point LastPickPoint {
    Point get ();
    void set (Point value);
}

Property Value

Type: Point
See Also

Reference

PickAction Class
VisualComponents.UX.Shared Namespace


PickAction.LastPickResult Property

PickActionLastPickResult Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static PickResult LastPickResult { get; set; }
public:
static property PickResult LastPickResult {
    PickResult get ();
    void set (PickResult value);
}

Property Value

Type: PickResult
See Also

Reference

PickAction Class
VisualComponents.UX.Shared Namespace


PickAction.PickPoint Property

PickActionPickPoint Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 PickPoint { get; set; }
public:
property Vector3 PickPoint {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

PickAction Class
VisualComponents.UX.Shared Namespace


PickAction.PickResult Property

PickActionPickResult Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PickResult PickResult { get; }
public:
property PickResult PickResult {
    PickResult get ();
}

Property Value

Type: PickResult
See Also

Reference

PickAction Class
VisualComponents.UX.Shared Namespace


PickAction.SnapOnMouseUp Property

PickActionSnapOnMouseUp Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool SnapOnMouseUp { get; set; }
public:
property bool SnapOnMouseUp {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PickAction Class
VisualComponents.UX.Shared Namespace


PickAction.X Property

PickActionX Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<int> X { get; set; }
public:
property Nullable<int> X {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Property Value

Type: NullableInt32
See Also

Reference

PickAction Class
VisualComponents.UX.Shared Namespace


PickAction.Y Property

PickActionY Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<int> Y { get; set; }
public:
property Nullable<int> Y {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

Property Value

Type: NullableInt32
See Also

Reference

PickAction Class
VisualComponents.UX.Shared Namespace


PickAction Methods

The PickAction type exposes the following members.

Methods
 | Name | Description
Public method | Cancel |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle(InternalEndInteractionMessage) |
Public method | Handle(MouseMessage) |
Public method | Handle(RequestActionAbortMessage) |
Public method | Handle(SnapCompletedAltMessage) |
Public method | Handle(SnapCompletedMessage) |
 | HideFocusAndText |
Public method | PickAtXY |
Public method | StartAction | This action will stay resident until mouse button is released. Used PickAtXY to pick immediately.
Public method | StartActionHelper |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PickAction Class
VisualComponents.UX.Shared Namespace


PickAction.Cancel Method

PickActionCancel Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Cancel()
public:
void Cancel()
See Also

Reference

PickAction Class
VisualComponents.UX.Shared Namespace


PickAction.Execute Method

PickActionExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    ActionExecutionContext context
)
public:
virtual void Execute(
    ActionExecutionContext^ context
) sealed

Parameters

context
Type: ActionExecutionContext

Implements

IResult.Execute(ActionExecutionContext)
See Also

Reference

PickAction Class
VisualComponents.UX.Shared Namespace


PickAction.Handle Method

PickActionHandle Method

Overload List
 | Name | Description
Public method | Handle(InternalEndInteractionMessage) |
Public method | Handle(MouseMessage) |
Public method | Handle(RequestActionAbortMessage) |
Public method | Handle(SnapCompletedAltMessage) |
Public method | Handle(SnapCompletedMessage) |
Top
See Also

Reference

PickAction Class
VisualComponents.UX.Shared Namespace


PickAction.Handle Method (InternalEndInteractionMessage)

PickActionHandle Method (InternalEndInteractionMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    InternalEndInteractionMessage message
)
public:
virtual void Handle(
    InternalEndInteractionMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedInternalEndInteractionMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

PickAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


PickAction.Handle Method (MouseMessage)

PickActionHandle Method (MouseMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    MouseMessage message
)
public:
virtual void Handle(
    MouseMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedMouseMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

PickAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


PickAction.Handle Method (RequestActionAbortMessage)

PickActionHandle Method (RequestActionAbortMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    RequestActionAbortMessage message
)
public:
virtual void Handle(
    RequestActionAbortMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedRequestActionAbortMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

PickAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


PickAction.Handle Method (SnapCompletedAltMessage)

PickActionHandle Method (SnapCompletedAltMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    SnapCompletedAltMessage message
)
public:
virtual void Handle(
    SnapCompletedAltMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedSnapCompletedAltMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

PickAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


PickAction.Handle Method (SnapCompletedMessage)

PickActionHandle Method (SnapCompletedMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    SnapCompletedMessage message
)
public:
virtual void Handle(
    SnapCompletedMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedSnapCompletedMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

PickAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


PickAction.HideFocusAndText Method

PickActionHideFocusAndText Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void HideFocusAndText()
public:
static void HideFocusAndText()
See Also

Reference

PickAction Class
VisualComponents.UX.Shared Namespace


PickAction.PickAtXY Method

PickActionPickAtXY Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void PickAtXY(
    int x,
    int y
)
public:
void PickAtXY(
    int x,
    int y
)

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
See Also

Reference

PickAction Class
VisualComponents.UX.Shared Namespace


PickAction.StartAction Method

PickActionStartAction Method

This action will stay resident until mouse button is released. Used PickAtXY to pick immediately.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    EventHandler<ResultCompletionEventArgs> completed,
    Func<PickResult, bool> matchResult = null
)
public:
void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed,
    Func<PickResult, bool>^ matchResult = nullptr
)

Parameters

completed
Type: SystemEventHandlerResultCompletionEventArgs
matchResult (Optional)
Type: SystemFuncPickResult, Boolean
See Also

Reference

PickAction Class
VisualComponents.UX.Shared Namespace


PickAction.StartActionHelper Method

PickActionStartActionHelper Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<IResult> StartActionHelper()
public:
IEnumerable<IResult^>^ StartActionHelper()

Return Value

Type: IEnumerableIResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PickAction.StartActionHelper"]

See Also

Reference

PickAction Class
VisualComponents.UX.Shared Namespace


PickAction Events

The PickAction type exposes the following members.

Events
 | Name | Description
Public event | Completed |
Top
See Also

Reference

PickAction Class
VisualComponents.UX.Shared Namespace


PickAction.Completed Event

PickActionCompleted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ResultCompletionEventArgs> Completed
public:
virtual  event EventHandler<ResultCompletionEventArgs^>^ Completed {
    void add (EventHandler<ResultCompletionEventArgs^>^ value);
    void remove (EventHandler<ResultCompletionEventArgs^>^ value);
}

Value

Type: SystemEventHandlerResultCompletionEventArgs

Implements

IResult.Completed
See Also

Reference

PickAction Class
VisualComponents.UX.Shared Namespace


PickAction Fields

The PickAction type exposes the following members.

Fields
 | Name | Description
Public field | MatchResult |
Top
See Also

Reference

PickAction Class
VisualComponents.UX.Shared Namespace


PickAction.MatchResult Field

PickActionMatchResult Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Func<PickResult, bool> MatchResult
public:
Func<PickResult, bool>^ MatchResult

Field Value

Type: FuncPickResult, Boolean
See Also

Reference

PickAction Class
VisualComponents.UX.Shared Namespace


PickEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.UX.SharedPickEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PickEventArgs : EventArgs
public ref class PickEventArgs : public EventArgs

The PickEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PickEventArgs | Initializes a new instance of the PickEventArgs class
Top
Properties
 | Name | Description
Public property | PickResult |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PickEventArgs Constructor

Initializes a new instance of the PickEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PickEventArgs()
public:
PickEventArgs()
See Also

Reference

PickEventArgs Class
VisualComponents.UX.Shared Namespace


PickEventArgs Properties

The PickEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | PickResult |
Top
See Also

Reference

PickEventArgs Class
VisualComponents.UX.Shared Namespace


PickEventArgs.PickResult Property

PickEventArgsPickResult Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 PickResult { get; set; }
public:
property Vector3 PickResult {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

PickEventArgs Class
VisualComponents.UX.Shared Namespace


PickEventArgs Methods

The PickEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PickEventArgs Class
VisualComponents.UX.Shared Namespace


PickMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedPickMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class PickMessage
public ref class PickMessage sealed

The PickMessage type exposes the following members.

Constructors
 | Name | Description
Public method | PickMessage | Initializes a new instance of the PickMessage class
Public method | PickMessage(PickResult, Boolean) | Initializes a new instance of the PickMessage class
Public method | PickMessage(PickAction, PickResult, Point) | Initializes a new instance of the PickMessage class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Action |
Public field | HighlightResult |
Public field | MousePosition |
Public field | Result |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PickMessage Constructor

Overload List
 | Name | Description
Public method | PickMessage | Initializes a new instance of the PickMessage class
Public method | PickMessage(PickResult, Boolean) | Initializes a new instance of the PickMessage class
Public method | PickMessage(PickAction, PickResult, Point) | Initializes a new instance of the PickMessage class
Top
See Also

Reference

PickMessage Class
VisualComponents.UX.Shared Namespace


PickMessage Constructor

Initializes a new instance of the PickMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PickMessage()
public:
PickMessage()
See Also

Reference

PickMessage Class
PickMessage Overload
VisualComponents.UX.Shared Namespace


PickMessage Constructor (PickResult, Boolean)

Initializes a new instance of the PickMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PickMessage(
    PickResult pickResult,
    bool highlight
)
public:
PickMessage(
    PickResult pickResult,
    bool highlight
)

Parameters

pickResult
Type: VisualComponents.Create3DPickResult
highlight
Type: SystemBoolean
See Also

Reference

PickMessage Class
PickMessage Overload
VisualComponents.UX.Shared Namespace


PickMessage Constructor (PickAction, PickResult, Point)

Initializes a new instance of the PickMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PickMessage(
    PickAction action,
    PickResult pickResult,
    Point mousePosition
)
public:
PickMessage(
    PickAction^ action,
    PickResult pickResult,
    Point mousePosition
)

Parameters

action
Type: VisualComponents.UX.SharedPickAction
pickResult
Type: VisualComponents.Create3DPickResult
mousePosition
Type: System.WindowsPoint
See Also

Reference

PickMessage Class
PickMessage Overload
VisualComponents.UX.Shared Namespace


PickMessage Methods

The PickMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PickMessage Class
VisualComponents.UX.Shared Namespace


PickMessage Fields

The PickMessage type exposes the following members.

Fields
 | Name | Description
Public field | Action |
Public field | HighlightResult |
Public field | MousePosition |
Public field | Result |
Top
See Also

Reference

PickMessage Class
VisualComponents.UX.Shared Namespace


PickMessage.Action Field

PickMessageAction Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public readonly PickAction Action
public:
initonly PickAction^ Action

Field Value

Type: PickAction
See Also

Reference

PickMessage Class
VisualComponents.UX.Shared Namespace


PickMessage.HighlightResult Field

PickMessageHighlightResult Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public readonly bool HighlightResult
public:
initonly bool HighlightResult

Field Value

Type: Boolean
See Also

Reference

PickMessage Class
VisualComponents.UX.Shared Namespace


PickMessage.MousePosition Field

PickMessageMousePosition Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public readonly Point MousePosition
public:
initonly Point MousePosition

Field Value

Type: Point
See Also

Reference

PickMessage Class
VisualComponents.UX.Shared Namespace


PickMessage.Result Field

PickMessageResult Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public readonly PickResult Result
public:
initonly PickResult Result

Field Value

Type: PickResult
See Also

Reference

PickMessage Class
VisualComponents.UX.Shared Namespace


PlaceholderNode Class

TreeNodeEx pre-configured to act as placeholder node.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedTreeNodeEx
VisualComponents.UX.SharedPlaceholderNode

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PlaceholderNode : TreeNodeEx
public ref class PlaceholderNode : public TreeNodeEx

The PlaceholderNode type exposes the following members.

Constructors
 | Name | Description
Public method | PlaceholderNode | Initializes a new instance of the PlaceholderNode class
Top
Properties
 | Name | Description
Public property | AllowsNodeReorder | (Inherited from TreeNodeEx.)
Public property | CanExpandRecursively | (Inherited from TreeNodeEx.)
Public property | CanHostPlaceholder | (Inherited from TreeNodeEx.)
Public property | CheckBoxToolTip | (Inherited from TreeNodeEx.)
Public property | ChildCollection | (Inherited from TreeNodeEx.)
Public property | Children | (Inherited from TreeNodeEx.)
Public property | Content | (Inherited from TreeNodeEx.)
Public property | ContextMenu | (Inherited from TreeNodeEx.)
Public property | DropIndicatorBottom | (Inherited from TreeNodeEx.)
Public property | DropIndicatorLeft | (Inherited from TreeNodeEx.)
Public property | DropIndicatorRight | (Inherited from TreeNodeEx.)
Public property | DropIndicatorTop | (Inherited from TreeNodeEx.)
Public property | ExpandedIcon | (Inherited from TreeNodeEx.)
Public property | FixedArea | (Inherited from TreeNodeEx.)
Public property | FixedAreaToolTip | (Inherited from TreeNodeEx.)
Public property | Foreground | (Inherited from TreeNodeEx.)
Public property | HasDropLocationChanged | (Inherited from TreeNodeEx.)
Public property | Icon | (Inherited from TreeNodeEx.)
Public property | IconResolved | (Inherited from TreeNodeEx.)
Public property | IconToolTip | (Inherited from TreeNodeEx.)
Public property | Indent | (Inherited from TreeNodeEx.)
Public property | IsAcceptable | (Inherited from TreeNodeEx.)
Public property | IsAncestorBeingCopied | (Inherited from TreeNodeEx.)
Public property | IsAncestorBeingDragged | (Inherited from TreeNodeEx.)
Public property | IsAnchor | (Inherited from TreeNodeEx.)
Public property | IsBeingCopied | (Inherited from TreeNodeEx.)
Public property | IsBeingDragged | (Inherited from TreeNodeEx.)
Public property | IsCheckable | (Inherited from TreeNodeEx.)
Public property | IsChecked | (Inherited from TreeNodeEx.)
Public property | IsCloneable | (Inherited from TreeNodeEx.)
Public property | IsDropTargetItem | (Inherited from TreeNodeEx.)
Public property | IsEditable | (Inherited from TreeNodeEx.)
Public property | IsEditing | (Inherited from TreeNodeEx.)
Public property | IsExpandable | (Inherited from TreeNodeEx.)
Public property | IsExpanded | (Inherited from TreeNodeEx.)
Public property | IsFirst | (Inherited from TreeNodeEx.)
Public property | IsLast | (Inherited from TreeNodeEx.)
Public property | IsLazy | (Inherited from TreeNodeEx.)
Public property | IsPlaceholder | (Inherited from TreeNodeEx.)
Public property | IsRemovable | (Inherited from TreeNodeEx.)
Public property | IsSelectable | (Inherited from TreeNodeEx.)
Public property | IsSelected | (Inherited from TreeNodeEx.)
Public property | IsTabStop | (Inherited from TreeNodeEx.)
Public property | IsVisible | (Inherited from TreeNodeEx.)
Public property | IsVisibleInTree | (Inherited from TreeNodeEx.)
Public property | ItemDropSide | (Inherited from TreeNodeEx.)
Public property | ItemsSource | (Inherited from TreeNodeEx.)
Public property | Level | (Inherited from TreeNodeEx.)
Public property | Parent | (Inherited from TreeNodeEx.)
Public property | Placeholder | (Inherited from TreeNodeEx.)
Public property | PlaceholderIndex | (Inherited from TreeNodeEx.)
Public property | RemoveButtonToolTip | (Inherited from TreeNodeEx.)
Public property | RemoveNodeCommand | (Inherited from TreeNodeEx.)
Public property | ShowIcon | (Inherited from TreeNodeEx.)
Public property | ShowLines | (Inherited from TreeNodeEx.)
Public property | Source | (Inherited from TreeNodeEx.)
Public property | ToolTip | (Inherited from TreeNodeEx.)
Public property | TreeView | (Inherited from TreeNodeEx.)
Public property | WasAncestorCut | (Inherited from TreeNodeEx.)
Public property | WasCut | (Inherited from TreeNodeEx.)
Top
Methods
 | Name | Description
Public method | AcceptData | (Overrides TreeNodeExAcceptData(IDataObject, Int32).)
Public method | Ancestors | (Inherited from TreeNodeEx.)
Public method | AncestorsAndSelf | (Inherited from TreeNodeEx.)
Public method | CanAcceptData | (Overrides TreeNodeExCanAcceptData(IDataObject, Int32).)
Public method | Clone | (Overrides TreeNodeExClone.)
Public method | Descendants | (Inherited from TreeNodeEx.)
Public method | DescendantsAndSelf | (Inherited from TreeNodeEx.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCanExpandRecursively | (Inherited from TreeNodeEx.)
Protected method | GetCanHostPlaceholder | (Inherited from TreeNodeEx.)
Protected method | GetChildren | (Inherited from TreeNodeEx.)
Public method | GetData | (Inherited from TreeNodeEx.)
Protected method | GetExpandedIcon | (Inherited from TreeNodeEx.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetIcon | (Inherited from TreeNodeEx.)
Protected method | GetIsChecked | (Inherited from TreeNodeEx.)
Protected method | GetIsExpandable | (Inherited from TreeNodeEx.)
Protected method | GetIsExpanded | (Inherited from TreeNodeEx.)
Protected method | GetIsFirst | (Inherited from TreeNodeEx.)
Protected method | GetIsLast | (Inherited from TreeNodeEx.)
Protected method | GetIsLazy | (Inherited from TreeNodeEx.)
Protected method | GetIsPlaceholder | (Inherited from TreeNodeEx.)
Protected method | GetIsVisible | (Inherited from TreeNodeEx.)
Protected method | GetIsVisibleInTree | (Inherited from TreeNodeEx.)
Protected method | GetParent | (Inherited from TreeNodeEx.)
Protected method | GetPlaceholder | (Inherited from TreeNodeEx.)
Protected method | GetPlaceholderIndex | (Inherited from TreeNodeEx.)
Protected method | GetShowIcon | (Inherited from TreeNodeEx.)
Protected method | GetShowLines | (Inherited from TreeNodeEx.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadEditText | (Inherited from TreeNodeEx.)
Public method | LoadLazyChildren | (Inherited from TreeNodeEx.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnChecked | (Inherited from TreeNodeEx.)
Public method | OnCheckReset | (Inherited from TreeNodeEx.)
Public method | OnCollapsed | (Inherited from TreeNodeEx.)
Public method | OnContextMenuOpening | (Overrides TreeNodeExOnContextMenuOpening(ContextMenuEventArgs).)
Public method | OnDoubleClick | (Inherited from TreeNodeEx.)
Public method | OnEnterPress | (Inherited from TreeNodeEx.)
Public method | OnExpanded | (Inherited from TreeNodeEx.)
Protected method | OnLazyLoading | (Inherited from TreeNodeEx.)
Public method | OnMinusPress | (Inherited from TreeNodeEx.)
Public method | OnMouseEnter | (Inherited from TreeNodeEx.)
Public method | OnMouseLeave | (Inherited from TreeNodeEx.)
Public method | OnMouseMove | (Inherited from TreeNodeEx.)
Public method | OnPlusPress | (Inherited from TreeNodeEx.)
Public method | OnPropertyChanged | (Inherited from TreeNodeEx.)
Public method | OnRemoveButtonClick | (Inherited from TreeNodeEx.)
Public method | OnSlashPress | (Inherited from TreeNodeEx.)
Public method | OnSpacePress | (Inherited from TreeNodeEx.)
Public method | OnStarPress | (Inherited from TreeNodeEx.)
Public method | OnUnchecked | (Inherited from TreeNodeEx.)
Public method | RaisePropertyChanged | (Inherited from TreeNodeEx.)
Public method | SaveEditText | (Inherited from TreeNodeEx.)
Public method | ToString | (Inherited from TreeNodeEx.)
Public method | VisibleDescendants | (Inherited from TreeNodeEx.)
Public method | VisibleDescendantsAndSelf | (Inherited from TreeNodeEx.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from TreeNodeEx.)
Top
Fields
 | Name | Description
Protected field | _clone | (Inherited from TreeNodeEx.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks
This is a helper class. It's not required for correct operation of the TreeViewEx or any of its components.
See Also

Reference

VisualComponents.UX.Shared Namespace


PlaceholderNode Constructor

Initializes a new instance of the PlaceholderNode class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PlaceholderNode()
public:
PlaceholderNode()
See Also

Reference

PlaceholderNode Class
VisualComponents.UX.Shared Namespace


PlaceholderNode Properties

The PlaceholderNode type exposes the following members.

Properties
 | Name | Description
Public property | AllowsNodeReorder | (Inherited from TreeNodeEx.)
Public property | CanExpandRecursively | (Inherited from TreeNodeEx.)
Public property | CanHostPlaceholder | (Inherited from TreeNodeEx.)
Public property | CheckBoxToolTip | (Inherited from TreeNodeEx.)
Public property | ChildCollection | (Inherited from TreeNodeEx.)
Public property | Children | (Inherited from TreeNodeEx.)
Public property | Content | (Inherited from TreeNodeEx.)
Public property | ContextMenu | (Inherited from TreeNodeEx.)
Public property | DropIndicatorBottom | (Inherited from TreeNodeEx.)
Public property | DropIndicatorLeft | (Inherited from TreeNodeEx.)
Public property | DropIndicatorRight | (Inherited from TreeNodeEx.)
Public property | DropIndicatorTop | (Inherited from TreeNodeEx.)
Public property | ExpandedIcon | (Inherited from TreeNodeEx.)
Public property | FixedArea | (Inherited from TreeNodeEx.)
Public property | FixedAreaToolTip | (Inherited from TreeNodeEx.)
Public property | Foreground | (Inherited from TreeNodeEx.)
Public property | HasDropLocationChanged | (Inherited from TreeNodeEx.)
Public property | Icon | (Inherited from TreeNodeEx.)
Public property | IconResolved | (Inherited from TreeNodeEx.)
Public property | IconToolTip | (Inherited from TreeNodeEx.)
Public property | Indent | (Inherited from TreeNodeEx.)
Public property | IsAcceptable | (Inherited from TreeNodeEx.)
Public property | IsAncestorBeingCopied | (Inherited from TreeNodeEx.)
Public property | IsAncestorBeingDragged | (Inherited from TreeNodeEx.)
Public property | IsAnchor | (Inherited from TreeNodeEx.)
Public property | IsBeingCopied | (Inherited from TreeNodeEx.)
Public property | IsBeingDragged | (Inherited from TreeNodeEx.)
Public property | IsCheckable | (Inherited from TreeNodeEx.)
Public property | IsChecked | (Inherited from TreeNodeEx.)
Public property | IsCloneable | (Inherited from TreeNodeEx.)
Public property | IsDropTargetItem | (Inherited from TreeNodeEx.)
Public property | IsEditable | (Inherited from TreeNodeEx.)
Public property | IsEditing | (Inherited from TreeNodeEx.)
Public property | IsExpandable | (Inherited from TreeNodeEx.)
Public property | IsExpanded | (Inherited from TreeNodeEx.)
Public property | IsFirst | (Inherited from TreeNodeEx.)
Public property | IsLast | (Inherited from TreeNodeEx.)
Public property | IsLazy | (Inherited from TreeNodeEx.)
Public property | IsPlaceholder | (Inherited from TreeNodeEx.)
Public property | IsRemovable | (Inherited from TreeNodeEx.)
Public property | IsSelectable | (Inherited from TreeNodeEx.)
Public property | IsSelected | (Inherited from TreeNodeEx.)
Public property | IsTabStop | (Inherited from TreeNodeEx.)
Public property | IsVisible | (Inherited from TreeNodeEx.)
Public property | IsVisibleInTree | (Inherited from TreeNodeEx.)
Public property | ItemDropSide | (Inherited from TreeNodeEx.)
Public property | ItemsSource | (Inherited from TreeNodeEx.)
Public property | Level | (Inherited from TreeNodeEx.)
Public property | Parent | (Inherited from TreeNodeEx.)
Public property | Placeholder | (Inherited from TreeNodeEx.)
Public property | PlaceholderIndex | (Inherited from TreeNodeEx.)
Public property | RemoveButtonToolTip | (Inherited from TreeNodeEx.)
Public property | RemoveNodeCommand | (Inherited from TreeNodeEx.)
Public property | ShowIcon | (Inherited from TreeNodeEx.)
Public property | ShowLines | (Inherited from TreeNodeEx.)
Public property | Source | (Inherited from TreeNodeEx.)
Public property | ToolTip | (Inherited from TreeNodeEx.)
Public property | TreeView | (Inherited from TreeNodeEx.)
Public property | WasAncestorCut | (Inherited from TreeNodeEx.)
Public property | WasCut | (Inherited from TreeNodeEx.)
Top
See Also

Reference

PlaceholderNode Class
VisualComponents.UX.Shared Namespace


PlaceholderNode Methods

The PlaceholderNode type exposes the following members.

Methods
 | Name | Description
Public method | AcceptData | (Overrides TreeNodeExAcceptData(IDataObject, Int32).)
Public method | Ancestors | (Inherited from TreeNodeEx.)
Public method | AncestorsAndSelf | (Inherited from TreeNodeEx.)
Public method | CanAcceptData | (Overrides TreeNodeExCanAcceptData(IDataObject, Int32).)
Public method | Clone | (Overrides TreeNodeExClone.)
Public method | Descendants | (Inherited from TreeNodeEx.)
Public method | DescendantsAndSelf | (Inherited from TreeNodeEx.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCanExpandRecursively | (Inherited from TreeNodeEx.)
Protected method | GetCanHostPlaceholder | (Inherited from TreeNodeEx.)
Protected method | GetChildren | (Inherited from TreeNodeEx.)
Public method | GetData | (Inherited from TreeNodeEx.)
Protected method | GetExpandedIcon | (Inherited from TreeNodeEx.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetIcon | (Inherited from TreeNodeEx.)
Protected method | GetIsChecked | (Inherited from TreeNodeEx.)
Protected method | GetIsExpandable | (Inherited from TreeNodeEx.)
Protected method | GetIsExpanded | (Inherited from TreeNodeEx.)
Protected method | GetIsFirst | (Inherited from TreeNodeEx.)
Protected method | GetIsLast | (Inherited from TreeNodeEx.)
Protected method | GetIsLazy | (Inherited from TreeNodeEx.)
Protected method | GetIsPlaceholder | (Inherited from TreeNodeEx.)
Protected method | GetIsVisible | (Inherited from TreeNodeEx.)
Protected method | GetIsVisibleInTree | (Inherited from TreeNodeEx.)
Protected method | GetParent | (Inherited from TreeNodeEx.)
Protected method | GetPlaceholder | (Inherited from TreeNodeEx.)
Protected method | GetPlaceholderIndex | (Inherited from TreeNodeEx.)
Protected method | GetShowIcon | (Inherited from TreeNodeEx.)
Protected method | GetShowLines | (Inherited from TreeNodeEx.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadEditText | (Inherited from TreeNodeEx.)
Public method | LoadLazyChildren | (Inherited from TreeNodeEx.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnChecked | (Inherited from TreeNodeEx.)
Public method | OnCheckReset | (Inherited from TreeNodeEx.)
Public method | OnCollapsed | (Inherited from TreeNodeEx.)
Public method | OnContextMenuOpening | (Overrides TreeNodeExOnContextMenuOpening(ContextMenuEventArgs).)
Public method | OnDoubleClick | (Inherited from TreeNodeEx.)
Public method | OnEnterPress | (Inherited from TreeNodeEx.)
Public method | OnExpanded | (Inherited from TreeNodeEx.)
Protected method | OnLazyLoading | (Inherited from TreeNodeEx.)
Public method | OnMinusPress | (Inherited from TreeNodeEx.)
Public method | OnMouseEnter | (Inherited from TreeNodeEx.)
Public method | OnMouseLeave | (Inherited from TreeNodeEx.)
Public method | OnMouseMove | (Inherited from TreeNodeEx.)
Public method | OnPlusPress | (Inherited from TreeNodeEx.)
Public method | OnPropertyChanged | (Inherited from TreeNodeEx.)
Public method | OnRemoveButtonClick | (Inherited from TreeNodeEx.)
Public method | OnSlashPress | (Inherited from TreeNodeEx.)
Public method | OnSpacePress | (Inherited from TreeNodeEx.)
Public method | OnStarPress | (Inherited from TreeNodeEx.)
Public method | OnUnchecked | (Inherited from TreeNodeEx.)
Public method | RaisePropertyChanged | (Inherited from TreeNodeEx.)
Public method | SaveEditText | (Inherited from TreeNodeEx.)
Public method | ToString | (Inherited from TreeNodeEx.)
Public method | VisibleDescendants | (Inherited from TreeNodeEx.)
Public method | VisibleDescendantsAndSelf | (Inherited from TreeNodeEx.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PlaceholderNode Class
VisualComponents.UX.Shared Namespace


PlaceholderNode.AcceptData Method

PlaceholderNodeAcceptData Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override DragDropEffects AcceptData(
    IDataObject dataObject,
    int position = -1
)
public:
virtual DragDropEffects AcceptData(
    IDataObject^ dataObject,
    int position = -1
) override

Parameters

dataObject
Type: System.WindowsIDataObject
position (Optional)
Type: SystemInt32

Return Value

Type: DragDropEffects

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PlaceholderNode.AcceptData(System.Windows.IDataObject,System.Int32)"]

See Also

Reference

PlaceholderNode Class
VisualComponents.UX.Shared Namespace


PlaceholderNode.CanAcceptData Method

PlaceholderNodeCanAcceptData Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool CanAcceptData(
    IDataObject data,
    int position = -1
)
public:
virtual bool CanAcceptData(
    IDataObject^ data,
    int position = -1
) override

Parameters

data
Type: System.WindowsIDataObject
position (Optional)
Type: SystemInt32

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PlaceholderNode.CanAcceptData(System.Windows.IDataObject,System.Int32)"]

See Also

Reference

PlaceholderNode Class
VisualComponents.UX.Shared Namespace


PlaceholderNode.Clone Method

PlaceholderNodeClone Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override Object Clone()
public:
virtual Object^ Clone() override

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PlaceholderNode.Clone"]

Implements

ICloneableClone
See Also

Reference

PlaceholderNode Class
VisualComponents.UX.Shared Namespace


PlaceholderNode.OnContextMenuOpening Method

PlaceholderNodeOnContextMenuOpening Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnContextMenuOpening(
    ContextMenuEventArgs e
)
public:
virtual void OnContextMenuOpening(
    ContextMenuEventArgs^ e
) override

Parameters

e
Type: System.Windows.ControlsContextMenuEventArgs
See Also

Reference

PlaceholderNode Class
VisualComponents.UX.Shared Namespace


PlaceholderNode Events

The PlaceholderNode type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from TreeNodeEx.)
Top
See Also

Reference

PlaceholderNode Class
VisualComponents.UX.Shared Namespace


PlaceholderNode Fields

The PlaceholderNode type exposes the following members.

Fields
 | Name | Description
Protected field | _clone | (Inherited from TreeNodeEx.)
Top
See Also

Reference

PlaceholderNode Class
VisualComponents.UX.Shared Namespace


PlaceholderNodePlacement Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum PlaceholderNodePlacement
public enum class PlaceholderNodePlacement
Members
Member name | Value | Description
Top | 0 |
Inside | 1 |
Bottom | 2 |
See Also

Reference

VisualComponents.UX.Shared Namespace


PlugMovement Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum PlugMovement
public enum class PlugMovement
Members
Member name | Value | Description
Allow | 0 |
NotAllow | 1 |
CorrectedToDockedPosition | 2 |
NotEnough | 3 |
CorrectedToPathPosition | 4 |
See Also

Reference

VisualComponents.UX.Shared Namespace


PlugPlayAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedFixedPropertyContainer
VisualComponents.UX.SharedPlugPlayAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PlugPlayAction : FixedPropertyContainer,
    IActionResult, IResult, IPropertyContainer, IBatchModeObject
public ref class PlugPlayAction : public FixedPropertyContainer,
    IActionResult, IResult, IPropertyContainer, IBatchModeObject

The PlugPlayAction type exposes the following members.

Constructors
 | Name | Description
Public method | PlugPlayAction | Initializes a new instance of the PlugPlayAction class
Top
Properties
 | Name | Description
 | App |
Public property | ChangeBatchLevel | (Inherited from FixedPropertyContainer.)
Public property | ConnectionChange | Contains information for undoing/redoing plug and play
Public property | ContainerExpressionContext | (Inherited from FixedPropertyContainer.)
Protected property | EventMng | Event aggregator (Inherited from FixedPropertyContainer.)
Public property | GetIndicatonPoints |
Public property | ManipulationArgs |
Public property | Name |
Public property | NextOffset |
Public property | OffsetInPath |
Public property | Properties | get properties (Inherited from FixedPropertyContainer.)
Public property | PropertyNames | (Inherited from FixedPropertyContainer.)
Public property | PropertyNamesAndValues | (Inherited from FixedPropertyContainer.)
Public property | PropertyValues | (Inherited from FixedPropertyContainer.)
Public property | Target |
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | (Inherited from FixedPropertyContainer.)
 | CanEndExecution |
 | CanExecute |
Public method | CreateProperty(Type, PropertyConstraintType) | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from FixedPropertyContainer.)
Public method | DeleteProperty | (Inherited from FixedPropertyContainer.)
Public method | EndChangeBatch | (Inherited from FixedPropertyContainer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute(ActionExecutionContext) |
Public method | Execute(ActionExecutionContext, Boolean) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperty | (Inherited from FixedPropertyContainer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotifyChanged | (Inherited from FixedPropertyContainer.)
Public method | NotifyPropertyChanged | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Completed |
Public event | PropertyChanged | (Inherited from FixedPropertyContainer.)
Public event | PropertyContainerChanged | (Inherited from FixedPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PlugPlayAction Constructor

Initializes a new instance of the PlugPlayAction class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PlugPlayAction()
public:
PlugPlayAction()
See Also

Reference

PlugPlayAction Class
VisualComponents.UX.Shared Namespace


PlugPlayAction Properties

The PlugPlayAction type exposes the following members.

Properties
 | Name | Description
 | App |
Public property | ChangeBatchLevel | (Inherited from FixedPropertyContainer.)
Public property | ConnectionChange | Contains information for undoing/redoing plug and play
Public property | ContainerExpressionContext | (Inherited from FixedPropertyContainer.)
Protected property | EventMng | Event aggregator (Inherited from FixedPropertyContainer.)
Public property | GetIndicatonPoints |
Public property | ManipulationArgs |
Public property | Name |
Public property | NextOffset |
Public property | OffsetInPath |
Public property | Properties | get properties (Inherited from FixedPropertyContainer.)
Public property | PropertyNames | (Inherited from FixedPropertyContainer.)
Public property | PropertyNamesAndValues | (Inherited from FixedPropertyContainer.)
Public property | PropertyValues | (Inherited from FixedPropertyContainer.)
Public property | Target |
Top
See Also

Reference

PlugPlayAction Class
VisualComponents.UX.Shared Namespace


PlugPlayAction.App Property

PlugPlayActionApp Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IApplication App { get; }
public:
static property IApplication^ App {
    IApplication^ get ();
}

Property Value

Type: IApplication
See Also

Reference

PlugPlayAction Class
VisualComponents.UX.Shared Namespace


PlugPlayAction.ConnectionChange Property

PlugPlayActionConnectionChange Property

Contains information for undoing/redoing plug and play

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SimInterfaceConnectionChange ConnectionChange { get; set; }
public:
property SimInterfaceConnectionChange^ ConnectionChange {
    SimInterfaceConnectionChange^ get ();
    void set (SimInterfaceConnectionChange^ value);
}

Property Value

Type: SimInterfaceConnectionChange
See Also

Reference

PlugPlayAction Class
VisualComponents.UX.Shared Namespace


PlugPlayAction.GetIndicatonPoints Property

PlugPlayActionGetIndicatonPoints Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<PlugIndication> GetIndicatonPoints { get; }
public:
property List<PlugIndication^>^ GetIndicatonPoints {
    List<PlugIndication^>^ get ();
}

Property Value

Type: ListPlugIndication
See Also

Reference

PlugPlayAction Class
VisualComponents.UX.Shared Namespace


PlugPlayAction.ManipulationArgs Property

PlugPlayActionManipulationArgs Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ManipulationEventArgs ManipulationArgs { get; set; }
public:
property ManipulationEventArgs^ ManipulationArgs {
    ManipulationEventArgs^ get ();
    void set (ManipulationEventArgs^ value);
}

Property Value

Type: ManipulationEventArgs
See Also

Reference

PlugPlayAction Class
VisualComponents.UX.Shared Namespace


PlugPlayAction.Name Property

PlugPlayActionName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; }
public:
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

PlugPlayAction Class
VisualComponents.UX.Shared Namespace


PlugPlayAction.NextOffset Property

PlugPlayActionNextOffset Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 NextOffset { get; set; }
public:
property Vector3 NextOffset {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

PlugPlayAction Class
VisualComponents.UX.Shared Namespace


PlugPlayAction.OffsetInPath Property

PlugPlayActionOffsetInPath Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 OffsetInPath { get; set; }
public:
property Vector3 OffsetInPath {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

PlugPlayAction Class
VisualComponents.UX.Shared Namespace


PlugPlayAction.Target Property

PlugPlayActionTarget Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IManipulationTarget Target { get; set; }
public:
property IManipulationTarget^ Target {
    IManipulationTarget^ get ();
    void set (IManipulationTarget^ value);
}

Property Value

Type: IManipulationTarget
See Also

Reference

PlugPlayAction Class
VisualComponents.UX.Shared Namespace


PlugPlayAction Methods

The PlugPlayAction type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | (Inherited from FixedPropertyContainer.)
 | CanEndExecution |
 | CanExecute |
Public method | CreateProperty(Type, PropertyConstraintType) | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from FixedPropertyContainer.)
Public method | DeleteProperty | (Inherited from FixedPropertyContainer.)
Public method | EndChangeBatch | (Inherited from FixedPropertyContainer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute(ActionExecutionContext) |
Public method | Execute(ActionExecutionContext, Boolean) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperty | (Inherited from FixedPropertyContainer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotifyChanged | (Inherited from FixedPropertyContainer.)
Public method | NotifyPropertyChanged | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PlugPlayAction Class
VisualComponents.UX.Shared Namespace


PlugPlayAction.CanEndExecution Method

PlugPlayActionCanEndExecution Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool CanEndExecution()
public:
static bool CanEndExecution()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PlugPlayAction.CanEndExecution"]

See Also

Reference

PlugPlayAction Class
VisualComponents.UX.Shared Namespace


PlugPlayAction.CanExecute Method

PlugPlayActionCanExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool CanExecute()
public:
static bool CanExecute()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PlugPlayAction.CanExecute"]

See Also

Reference

PlugPlayAction Class
VisualComponents.UX.Shared Namespace


PlugPlayAction.Execute Method

PlugPlayActionExecute Method

Overload List
 | Name | Description
Public method | Execute(ActionExecutionContext) |
Public method | Execute(ActionExecutionContext, Boolean) |
Top
See Also

Reference

PlugPlayAction Class
VisualComponents.UX.Shared Namespace


PlugPlayAction.Execute Method (ActionExecutionContext)

PlugPlayActionExecute Method (ActionExecutionContext)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    ActionExecutionContext context
)
public:
virtual void Execute(
    ActionExecutionContext^ context
) sealed

Parameters

context
Type: ActionExecutionContext

Implements

IResult.Execute(ActionExecutionContext)
See Also

Reference

PlugPlayAction Class
Execute Overload
VisualComponents.UX.Shared Namespace


PlugPlayAction.Execute Method (ActionExecutionContext, Boolean)

PlugPlayActionExecute Method (ActionExecutionContext, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    ActionExecutionContext context,
    bool screenSpace
)
public:
void Execute(
    ActionExecutionContext^ context,
    bool screenSpace
)

Parameters

context
Type: ActionExecutionContext
screenSpace
Type: SystemBoolean
See Also

Reference

PlugPlayAction Class
Execute Overload
VisualComponents.UX.Shared Namespace


PlugPlayAction Events

The PlugPlayAction type exposes the following members.

Events
 | Name | Description
Public event | Completed |
Public event | PropertyChanged | (Inherited from FixedPropertyContainer.)
Public event | PropertyContainerChanged | (Inherited from FixedPropertyContainer.)
Top
See Also

Reference

PlugPlayAction Class
VisualComponents.UX.Shared Namespace


PlugPlayAction.Completed Event

PlugPlayActionCompleted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ResultCompletionEventArgs> Completed
public:
virtual  event EventHandler<ResultCompletionEventArgs^>^ Completed {
    void add (EventHandler<ResultCompletionEventArgs^>^ value);
    void remove (EventHandler<ResultCompletionEventArgs^>^ value);
}

Value

Type: SystemEventHandlerResultCompletionEventArgs

Implements

IResult.Completed
See Also

Reference

PlugPlayAction Class
VisualComponents.UX.Shared Namespace


PlugPlayCompletionEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
ResultCompletionEventArgs
VisualComponents.UX.SharedPlugPlayCompletionEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PlugPlayCompletionEventArgs : ResultCompletionEventArgs
public ref class PlugPlayCompletionEventArgs : public ResultCompletionEventArgs

The PlugPlayCompletionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PlugPlayCompletionEventArgs | Initializes a new instance of the PlugPlayCompletionEventArgs class
Top
Properties
 | Name | Description
Public property | PlayPlayMovement |
Public property | PlugStatusAfterCompletion |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Error | (Inherited from ResultCompletionEventArgs.)
Public field | WasCancelled | (Inherited from ResultCompletionEventArgs.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PlugPlayCompletionEventArgs Constructor

Initializes a new instance of the PlugPlayCompletionEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PlugPlayCompletionEventArgs()
public:
PlugPlayCompletionEventArgs()
See Also

Reference

PlugPlayCompletionEventArgs Class
VisualComponents.UX.Shared Namespace


PlugPlayCompletionEventArgs Properties

The PlugPlayCompletionEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | PlayPlayMovement |
Public property | PlugStatusAfterCompletion |
Top
See Also

Reference

PlugPlayCompletionEventArgs Class
VisualComponents.UX.Shared Namespace


PlugPlayCompletionEventArgs.PlayPlayMovement Property

PlugPlayCompletionEventArgsPlayPlayMovement Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PlugMovement PlayPlayMovement { get; set; }
public:
property PlugMovement PlayPlayMovement {
    PlugMovement get ();
    void set (PlugMovement value);
}

Property Value

Type: PlugMovement
See Also

Reference

PlugPlayCompletionEventArgs Class
VisualComponents.UX.Shared Namespace


PlugPlayCompletionEventArgs.PlugStatusAfterCompletion Property

PlugPlayCompletionEventArgsPlugStatusAfterCompletion Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PlugStatus PlugStatusAfterCompletion { get; set; }
public:
property PlugStatus PlugStatusAfterCompletion {
    PlugStatus get ();
    void set (PlugStatus value);
}

Property Value

Type: PlugStatus
See Also

Reference

PlugPlayCompletionEventArgs Class
VisualComponents.UX.Shared Namespace


PlugPlayCompletionEventArgs Methods

The PlugPlayCompletionEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PlugPlayCompletionEventArgs Class
VisualComponents.UX.Shared Namespace


PlugPlayCompletionEventArgs Fields

The PlugPlayCompletionEventArgs type exposes the following members.

Fields
 | Name | Description
Public field | Error | (Inherited from ResultCompletionEventArgs.)
Public field | WasCancelled | (Inherited from ResultCompletionEventArgs.)
Top
See Also

Reference

PlugPlayCompletionEventArgs Class
VisualComponents.UX.Shared Namespace


PlugPlayLogicalAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedFixedPropertyContainer
VisualComponents.UX.SharedPlugPlayLogicalAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PlugPlayLogicalAction : FixedPropertyContainer,
    IActionResult, IResult, IPropertyContainer, IBatchModeObject
public ref class PlugPlayLogicalAction : public FixedPropertyContainer,
    IActionResult, IResult, IPropertyContainer, IBatchModeObject

The PlugPlayLogicalAction type exposes the following members.

Constructors
 | Name | Description
Public method | PlugPlayLogicalAction | Initializes a new instance of the PlugPlayLogicalAction class
Top
Properties
 | Name | Description
Public property | ChangeBatchLevel | (Inherited from FixedPropertyContainer.)
Public property | ContainerExpressionContext | (Inherited from FixedPropertyContainer.)
Protected property | EventMng | Event aggregator (Inherited from FixedPropertyContainer.)
Public property | Name |
Public property | Properties | get properties (Inherited from FixedPropertyContainer.)
Public property | PropertyNames | (Inherited from FixedPropertyContainer.)
Public property | PropertyNamesAndValues | (Inherited from FixedPropertyContainer.)
Public property | PropertyValues | (Inherited from FixedPropertyContainer.)
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType) | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from FixedPropertyContainer.)
Public method | DeleteProperty | (Inherited from FixedPropertyContainer.)
Public method | EndChangeBatch | (Inherited from FixedPropertyContainer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperty | (Inherited from FixedPropertyContainer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | HandleActivation |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotifyChanged | (Inherited from FixedPropertyContainer.)
Public method | NotifyPropertyChanged | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Completed |
Public event | PropertyChanged | (Inherited from FixedPropertyContainer.)
Public event | PropertyContainerChanged | (Inherited from FixedPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PlugPlayLogicalAction Constructor

Initializes a new instance of the PlugPlayLogicalAction class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PlugPlayLogicalAction()
public:
PlugPlayLogicalAction()
See Also

Reference

PlugPlayLogicalAction Class
VisualComponents.UX.Shared Namespace


PlugPlayLogicalAction Properties

The PlugPlayLogicalAction type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | (Inherited from FixedPropertyContainer.)
Public property | ContainerExpressionContext | (Inherited from FixedPropertyContainer.)
Protected property | EventMng | Event aggregator (Inherited from FixedPropertyContainer.)
Public property | Name |
Public property | Properties | get properties (Inherited from FixedPropertyContainer.)
Public property | PropertyNames | (Inherited from FixedPropertyContainer.)
Public property | PropertyNamesAndValues | (Inherited from FixedPropertyContainer.)
Public property | PropertyValues | (Inherited from FixedPropertyContainer.)
Top
See Also

Reference

PlugPlayLogicalAction Class
VisualComponents.UX.Shared Namespace


PlugPlayLogicalAction.Name Property

PlugPlayLogicalActionName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; }
public:
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

PlugPlayLogicalAction Class
VisualComponents.UX.Shared Namespace


PlugPlayLogicalAction Methods

The PlugPlayLogicalAction type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType) | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from FixedPropertyContainer.)
Public method | DeleteProperty | (Inherited from FixedPropertyContainer.)
Public method | EndChangeBatch | (Inherited from FixedPropertyContainer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperty | (Inherited from FixedPropertyContainer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | HandleActivation |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | NotifyChanged | (Inherited from FixedPropertyContainer.)
Public method | NotifyPropertyChanged | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PlugPlayLogicalAction Class
VisualComponents.UX.Shared Namespace


PlugPlayLogicalAction.Execute Method

PlugPlayLogicalActionExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    ActionExecutionContext context
)
public:
virtual void Execute(
    ActionExecutionContext^ context
) sealed

Parameters

context
Type: ActionExecutionContext

Implements

IResult.Execute(ActionExecutionContext)
See Also

Reference

PlugPlayLogicalAction Class
VisualComponents.UX.Shared Namespace


PlugPlayLogicalAction.HandleActivation Method

PlugPlayLogicalActionHandleActivation Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void HandleActivation(
    IVisualObject target,
    bool activation
)
public:
static void HandleActivation(
    IVisualObject^ target,
    bool activation
)

Parameters

target
Type: VisualComponents.Create3DIVisualObject
activation
Type: SystemBoolean
See Also

Reference

PlugPlayLogicalAction Class
VisualComponents.UX.Shared Namespace


PlugPlayLogicalAction Events

The PlugPlayLogicalAction type exposes the following members.

Events
 | Name | Description
Public event | Completed |
Public event | PropertyChanged | (Inherited from FixedPropertyContainer.)
Public event | PropertyContainerChanged | (Inherited from FixedPropertyContainer.)
Top
See Also

Reference

PlugPlayLogicalAction Class
VisualComponents.UX.Shared Namespace


PlugPlayLogicalAction.Completed Event

PlugPlayLogicalActionCompleted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ResultCompletionEventArgs> Completed
public:
virtual  event EventHandler<ResultCompletionEventArgs^>^ Completed {
    void add (EventHandler<ResultCompletionEventArgs^>^ value);
    void remove (EventHandler<ResultCompletionEventArgs^>^ value);
}

Value

Type: SystemEventHandlerResultCompletionEventArgs

Implements

IResult.Completed
See Also

Reference

PlugPlayLogicalAction Class
VisualComponents.UX.Shared Namespace


PnPIndicationPointsMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedPnPIndicationPointsMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PnPIndicationPointsMessage
public ref class PnPIndicationPointsMessage

The PnPIndicationPointsMessage type exposes the following members.

Constructors
 | Name | Description
Public method | PnPIndicationPointsMessage | Initializes a new instance of the PnPIndicationPointsMessage class
Top
Properties
 | Name | Description
Public property | Indications |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PnPIndicationPointsMessage Constructor

Initializes a new instance of the PnPIndicationPointsMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PnPIndicationPointsMessage()
public:
PnPIndicationPointsMessage()
See Also

Reference

PnPIndicationPointsMessage Class
VisualComponents.UX.Shared Namespace


PnPIndicationPointsMessage Properties

The PnPIndicationPointsMessage type exposes the following members.

Properties
 | Name | Description
Public property | Indications |
Top
See Also

Reference

PnPIndicationPointsMessage Class
VisualComponents.UX.Shared Namespace


PnPIndicationPointsMessage.Indications Property

PnPIndicationPointsMessageIndications Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<PlugIndication> Indications { get; set; }
public:
property List<PlugIndication^>^ Indications {
    List<PlugIndication^>^ get ();
    void set (List<PlugIndication^>^ value);
}

Property Value

Type: ListPlugIndication
See Also

Reference

PnPIndicationPointsMessage Class
VisualComponents.UX.Shared Namespace


PnPIndicationPointsMessage Methods

The PnPIndicationPointsMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PnPIndicationPointsMessage Class
VisualComponents.UX.Shared Namespace


PositionProperty Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedEditorProperty
VisualComponents.UX.SharedPositionProperty

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PositionProperty : EditorProperty
public ref class PositionProperty : public EditorProperty

The PositionProperty type exposes the following members.

Constructors
 | Name | Description
Public method | PositionProperty | Initializes a new instance of the PositionProperty class
Top
Properties
 | Name | Description
Public property | AllowedMaximum | (Inherited from EditorProperty.)
Public property | AllowedMinimum | (Inherited from EditorProperty.)
Public property | AllowedValues | (Inherited from EditorProperty.)
Public property | AX |
Public property | AY |
Public property | AZ |
Public property | CanCreateNewValue | (Inherited from EditorProperty.)
Public property | Category | (Inherited from EditorProperty.)
Public property | ConstraintType | (Inherited from EditorProperty.)
Public property | Container | (Inherited from EditorProperty.)
Public property | ContainerExpressionContext | (Inherited from EditorProperty.)
Public property | ContainerObject | Similar to IProperty.Container, but for any object. (Inherited from EditorProperty.)
Public property | CreationTypes | (Inherited from EditorProperty.)
Public property | Description | (Inherited from EditorProperty.)
Public property | DisabledStateToolTip | (Inherited from EditorProperty.)
Public property | DistributionExpression | (Inherited from EditorProperty.)
Public property | Error | (Inherited from EditorProperty.)
Public property | ErrorMessage | (Inherited from EditorProperty.)
Public property | HasDistribution | (Inherited from EditorProperty.)
Public property | History | (Inherited from EditorProperty.)
Public property | Index_ForComboBox | (Inherited from EditorProperty.)
Public property | IsDesignTime | (Inherited from EditorProperty.)
Public property | IsEditable | Helper property since in XAML negating binding value is not possible without using BoolToOppositeConverter (Inherited from EditorProperty.)
Public property | IsEditableInGui | (Inherited from EditorProperty.)
Public property | IsExceptionallyInHome | (Inherited from EditorProperty.)
Public property | IsInternal | (Inherited from EditorProperty.)
Public property | IsLocked | (Inherited from EditorProperty.)
Public property | IsPersistent | (Inherited from EditorProperty.)
Public property | IsQuantityValue | (Inherited from EditorProperty.)
Public property | IsReadOnly | (Inherited from EditorProperty.)
Public property | IsValid | (Inherited from EditorProperty.)
Public property | IsVisible | (Inherited from EditorProperty.)
Public property | IsVisibleDesignTime | (Inherited from EditorProperty.)
Public property | IsVisibleForced | (Inherited from EditorProperty.)
Public property | IsVisibleInGui | IsVisibleInGui is used to bind GUI visibility. Setting this value affects only _isVisibleForcedOff. (Inherited from EditorProperty.)
Public property | Item | (Inherited from EditorProperty.)
Public property | Name | (Inherited from EditorProperty.)
Public property | NonLocalizedName | (Inherited from EditorProperty.)
Public property | NX |
Public property | NY |
Public property | NZ |
Public property | Order | (Inherited from EditorProperty.)
Public property | OX |
Public property | OY |
Public property | OZ |
Public property | Property | (Inherited from EditorProperty.)
Public property | PropertyDescription | (Inherited from EditorProperty.)
Public property | PropertyType | (Inherited from EditorProperty.)
Public property | PX |
Public property | PY |
Public property | PZ |
Public property | Quantity | (Inherited from EditorProperty.)
Public property | ResourceType | In case of having an IUriProperty, this determines if the editor should allow folder selection instead of file selection (Inherited from EditorProperty.)
Public property | RotationSystem | (Inherited from EditorProperty.)
Public property | ShowValuepicker | (Inherited from EditorProperty.)
Public property | TabHeader | (Inherited from EditorProperty.)
Public property | Unit | (Inherited from EditorProperty.)
Public property | Value | (Inherited from EditorProperty.)
Public property | Value_ForComboBox | Helper property, used only by ComboBox. (Inherited from EditorProperty.)
Public property | ValueString | (Inherited from EditorProperty.)
Public property | WPRX |
Public property | WPRY |
Public property | WPRZ |
Top
Methods
 | Name | Description
Public method | Associate | (Inherited from EditorProperty.)
Public method | CheckEditableInGui | (Inherited from EditorProperty.)
Protected method | CheckPropertyObjDispose | (Inherited from EditorProperty.)
Public method | CheckRebuild | This happens only on UI changes. If containeris a behavior of feature call evaluate or rebuild to update geometry. (Inherited from EditorProperty.)
Public method | CheckRebuildSmart | (Inherited from EditorProperty.)
Public method | Clone | (Inherited from EditorProperty.)
Public method | CreateAndSetNewValue | (Inherited from EditorProperty.)
Public method | Disassociate | (Inherited from EditorProperty.)
Public method | Dispose | (Inherited from EditorProperty.)
Protected method | Dispose(Boolean) | (Inherited from EditorProperty.)
Public method | EndBatch | (Inherited from EditorProperty.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from EditorProperty.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokePropertyChanged | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedEx | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedValue_Begin | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedValue_Process | (Inherited from EditorProperty.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Note: This is Not just called on IProperty.Value change. It's called by PropertyWrapper::NotifyPropertyChanged with different names (like "Value", "Expression", etc). It's called on rVariable::SetupChanged, on variable flag changes. (Inherited from EditorProperty.)
Public method | PickValue | Execute PickAction and wait for user to click on some object. (Inherited from EditorProperty.)
Public method | PickValueProxy | (Inherited from EditorProperty.)
Public method | SetQuantity | (Inherited from EditorProperty.)
Public method | SetUnitMagnitude | (Inherited from EditorProperty.)
Public method | StartBatch | (Inherited from EditorProperty.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | property changed event (Inherited from EditorProperty.)
Top
Fields
 | Name | Description
Public field | SuppressValueChange | (Inherited from EditorProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PositionProperty Constructor

Initializes a new instance of the PositionProperty class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PositionProperty(
    IProperty property
)
public:
PositionProperty(
    IProperty^ property
)

Parameters

property
Type: VisualComponents.Create3DIProperty
See Also

Reference

PositionProperty Class
VisualComponents.UX.Shared Namespace


PositionProperty Properties

The PositionProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | (Inherited from EditorProperty.)
Public property | AllowedMinimum | (Inherited from EditorProperty.)
Public property | AllowedValues | (Inherited from EditorProperty.)
Public property | AX |
Public property | AY |
Public property | AZ |
Public property | CanCreateNewValue | (Inherited from EditorProperty.)
Public property | Category | (Inherited from EditorProperty.)
Public property | ConstraintType | (Inherited from EditorProperty.)
Public property | Container | (Inherited from EditorProperty.)
Public property | ContainerExpressionContext | (Inherited from EditorProperty.)
Public property | ContainerObject | Similar to IProperty.Container, but for any object. (Inherited from EditorProperty.)
Public property | CreationTypes | (Inherited from EditorProperty.)
Public property | Description | (Inherited from EditorProperty.)
Public property | DisabledStateToolTip | (Inherited from EditorProperty.)
Public property | DistributionExpression | (Inherited from EditorProperty.)
Public property | Error | (Inherited from EditorProperty.)
Public property | ErrorMessage | (Inherited from EditorProperty.)
Public property | HasDistribution | (Inherited from EditorProperty.)
Public property | History | (Inherited from EditorProperty.)
Public property | Index_ForComboBox | (Inherited from EditorProperty.)
Public property | IsDesignTime | (Inherited from EditorProperty.)
Public property | IsEditable | Helper property since in XAML negating binding value is not possible without using BoolToOppositeConverter (Inherited from EditorProperty.)
Public property | IsEditableInGui | (Inherited from EditorProperty.)
Public property | IsExceptionallyInHome | (Inherited from EditorProperty.)
Public property | IsInternal | (Inherited from EditorProperty.)
Public property | IsLocked | (Inherited from EditorProperty.)
Public property | IsPersistent | (Inherited from EditorProperty.)
Public property | IsQuantityValue | (Inherited from EditorProperty.)
Public property | IsReadOnly | (Inherited from EditorProperty.)
Public property | IsValid | (Inherited from EditorProperty.)
Public property | IsVisible | (Inherited from EditorProperty.)
Public property | IsVisibleDesignTime | (Inherited from EditorProperty.)
Public property | IsVisibleForced | (Inherited from EditorProperty.)
Public property | IsVisibleInGui | IsVisibleInGui is used to bind GUI visibility. Setting this value affects only _isVisibleForcedOff. (Inherited from EditorProperty.)
Public property | Item | (Inherited from EditorProperty.)
Public property | Name | (Inherited from EditorProperty.)
Public property | NonLocalizedName | (Inherited from EditorProperty.)
Public property | NX |
Public property | NY |
Public property | NZ |
Public property | Order | (Inherited from EditorProperty.)
Public property | OX |
Public property | OY |
Public property | OZ |
Public property | Property | (Inherited from EditorProperty.)
Public property | PropertyDescription | (Inherited from EditorProperty.)
Public property | PropertyType | (Inherited from EditorProperty.)
Public property | PX |
Public property | PY |
Public property | PZ |
Public property | Quantity | (Inherited from EditorProperty.)
Public property | ResourceType | In case of having an IUriProperty, this determines if the editor should allow folder selection instead of file selection (Inherited from EditorProperty.)
Public property | RotationSystem | (Inherited from EditorProperty.)
Public property | ShowValuepicker | (Inherited from EditorProperty.)
Public property | TabHeader | (Inherited from EditorProperty.)
Public property | Unit | (Inherited from EditorProperty.)
Public property | Value | (Inherited from EditorProperty.)
Public property | Value_ForComboBox | Helper property, used only by ComboBox. (Inherited from EditorProperty.)
Public property | ValueString | (Inherited from EditorProperty.)
Public property | WPRX |
Public property | WPRY |
Public property | WPRZ |
Top
See Also

Reference

PositionProperty Class
VisualComponents.UX.Shared Namespace


PositionProperty.AX Property

PositionPropertyAX Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double AX { get; set; }
public:
property double AX {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

PositionProperty Class
VisualComponents.UX.Shared Namespace


PositionProperty.AY Property

PositionPropertyAY Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double AY { get; set; }
public:
property double AY {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

PositionProperty Class
VisualComponents.UX.Shared Namespace


PositionProperty.AZ Property

PositionPropertyAZ Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double AZ { get; set; }
public:
property double AZ {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

PositionProperty Class
VisualComponents.UX.Shared Namespace


PositionProperty.NX Property

PositionPropertyNX Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double NX { get; set; }
public:
property double NX {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

PositionProperty Class
VisualComponents.UX.Shared Namespace


PositionProperty.NY Property

PositionPropertyNY Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double NY { get; set; }
public:
property double NY {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

PositionProperty Class
VisualComponents.UX.Shared Namespace


PositionProperty.NZ Property

PositionPropertyNZ Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double NZ { get; set; }
public:
property double NZ {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

PositionProperty Class
VisualComponents.UX.Shared Namespace


PositionProperty.OX Property

PositionPropertyOX Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double OX { get; set; }
public:
property double OX {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

PositionProperty Class
VisualComponents.UX.Shared Namespace


PositionProperty.OY Property

PositionPropertyOY Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double OY { get; set; }
public:
property double OY {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

PositionProperty Class
VisualComponents.UX.Shared Namespace


PositionProperty.OZ Property

PositionPropertyOZ Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double OZ { get; set; }
public:
property double OZ {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

PositionProperty Class
VisualComponents.UX.Shared Namespace


PositionProperty.PX Property

PositionPropertyPX Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double PX { get; set; }
public:
property double PX {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

PositionProperty Class
VisualComponents.UX.Shared Namespace


PositionProperty.PY Property

PositionPropertyPY Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double PY { get; set; }
public:
property double PY {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

PositionProperty Class
VisualComponents.UX.Shared Namespace


PositionProperty.PZ Property

PositionPropertyPZ Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double PZ { get; set; }
public:
property double PZ {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

PositionProperty Class
VisualComponents.UX.Shared Namespace


PositionProperty.WPRX Property

PositionPropertyWPRX Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double WPRX { get; set; }
public:
property double WPRX {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

PositionProperty Class
VisualComponents.UX.Shared Namespace


PositionProperty.WPRY Property

PositionPropertyWPRY Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double WPRY { get; set; }
public:
property double WPRY {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

PositionProperty Class
VisualComponents.UX.Shared Namespace


PositionProperty.WPRZ Property

PositionPropertyWPRZ Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double WPRZ { get; set; }
public:
property double WPRZ {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

PositionProperty Class
VisualComponents.UX.Shared Namespace


PositionProperty Methods

The PositionProperty type exposes the following members.

Methods
 | Name | Description
Public method | Associate | (Inherited from EditorProperty.)
Public method | CheckEditableInGui | (Inherited from EditorProperty.)
Protected method | CheckPropertyObjDispose | (Inherited from EditorProperty.)
Public method | CheckRebuild | This happens only on UI changes. If containeris a behavior of feature call evaluate or rebuild to update geometry. (Inherited from EditorProperty.)
Public method | CheckRebuildSmart | (Inherited from EditorProperty.)
Public method | Clone | (Inherited from EditorProperty.)
Public method | CreateAndSetNewValue | (Inherited from EditorProperty.)
Public method | Disassociate | (Inherited from EditorProperty.)
Public method | Dispose | (Inherited from EditorProperty.)
Protected method | Dispose(Boolean) | (Inherited from EditorProperty.)
Public method | EndBatch | (Inherited from EditorProperty.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from EditorProperty.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokePropertyChanged | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedEx | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedValue_Begin | (Inherited from EditorProperty.)
Protected method | InvokePropertyChangedValue_Process | (Inherited from EditorProperty.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Note: This is Not just called on IProperty.Value change. It's called by PropertyWrapper::NotifyPropertyChanged with different names (like "Value", "Expression", etc). It's called on rVariable::SetupChanged, on variable flag changes. (Inherited from EditorProperty.)
Public method | PickValue | Execute PickAction and wait for user to click on some object. (Inherited from EditorProperty.)
Public method | PickValueProxy | (Inherited from EditorProperty.)
Public method | SetQuantity | (Inherited from EditorProperty.)
Public method | SetUnitMagnitude | (Inherited from EditorProperty.)
Public method | StartBatch | (Inherited from EditorProperty.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PositionProperty Class
VisualComponents.UX.Shared Namespace


PositionProperty Events

The PositionProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | property changed event (Inherited from EditorProperty.)
Top
See Also

Reference

PositionProperty Class
VisualComponents.UX.Shared Namespace


PositionProperty Fields

The PositionProperty type exposes the following members.

Fields
 | Name | Description
Public field | SuppressValueChange | (Inherited from EditorProperty.)
Top
See Also

Reference

PositionProperty Class
VisualComponents.UX.Shared Namespace


ProcessRuleEditorView Class

Interaction logic for ProcessRuleEditorView.xaml
ProcessRuleEditorView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedProcessRuleEditorView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ProcessRuleEditorView : UserControl,
    IComponentConnector
public ref class ProcessRuleEditorView : public UserControl,
    IComponentConnector

The ProcessRuleEditorView type exposes the following members.

Constructors
 | Name | Description
Public method | ProcessRuleEditorView | Initializes a new instance of the ProcessRuleEditorView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ProcessRuleEditorView Constructor

Initializes a new instance of the ProcessRuleEditorView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProcessRuleEditorView()
public:
ProcessRuleEditorView()
See Also

Reference

ProcessRuleEditorView Class
VisualComponents.UX.Shared Namespace


ProcessRuleEditorView Properties

The ProcessRuleEditorView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ProcessRuleEditorView Class
VisualComponents.UX.Shared Namespace


ProcessRuleEditorView Methods

The ProcessRuleEditorView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProcessRuleEditorView Class
VisualComponents.UX.Shared Namespace


ProcessRuleEditorView.InitializeComponent Method

ProcessRuleEditorViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

ProcessRuleEditorView Class
VisualComponents.UX.Shared Namespace


ProcessRuleEditorView Events

The ProcessRuleEditorView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ProcessRuleEditorView Class
VisualComponents.UX.Shared Namespace


ProcessTableLineView Class

Interaction logic for ProcessTableLineView.xaml
ProcessTableLineView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedProcessTableLineView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ProcessTableLineView : UserControl,
    IComponentConnector
public ref class ProcessTableLineView : public UserControl,
    IComponentConnector

The ProcessTableLineView type exposes the following members.

Constructors
 | Name | Description
Public method | ProcessTableLineView | Initializes a new instance of the ProcessTableLineView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ProcessTableLineView Constructor

Initializes a new instance of the ProcessTableLineView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProcessTableLineView()
public:
ProcessTableLineView()
See Also

Reference

ProcessTableLineView Class
VisualComponents.UX.Shared Namespace


ProcessTableLineView Properties

The ProcessTableLineView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ProcessTableLineView Class
VisualComponents.UX.Shared Namespace


ProcessTableLineView Methods

The ProcessTableLineView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProcessTableLineView Class
VisualComponents.UX.Shared Namespace


ProcessTableLineView.InitializeComponent Method

ProcessTableLineViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

ProcessTableLineView Class
VisualComponents.UX.Shared Namespace


ProcessTableLineView Events

The ProcessTableLineView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ProcessTableLineView Class
VisualComponents.UX.Shared Namespace


ProduckKeySelectedMessage Class

Note: This API is now obsolete.

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedProduckKeySelectedMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("This class is obsolete.", true)]
public class ProduckKeySelectedMessage
[ObsoleteAttribute(L"This class is obsolete.", true)]
public ref class ProduckKeySelectedMessage

The ProduckKeySelectedMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ProduckKeySelectedMessage | Initializes a new instance of the ProduckKeySelectedMessage class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | ProductKey |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ProduckKeySelectedMessage Constructor

Initializes a new instance of the ProduckKeySelectedMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProduckKeySelectedMessage(
    Object productKey
)
public:
ProduckKeySelectedMessage(
    Object^ productKey
)

Parameters

productKey
Type: SystemObject
See Also

Reference

ProduckKeySelectedMessage Class
VisualComponents.UX.Shared Namespace


ProduckKeySelectedMessage Methods

The ProduckKeySelectedMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProduckKeySelectedMessage Class
VisualComponents.UX.Shared Namespace


ProduckKeySelectedMessage Fields

The ProduckKeySelectedMessage type exposes the following members.

Fields
 | Name | Description
Public field | ProductKey |
Top
See Also

Reference

ProduckKeySelectedMessage Class
VisualComponents.UX.Shared Namespace


ProduckKeySelectedMessage.ProductKey Field

ProduckKeySelectedMessageProductKey Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public readonly Object ProductKey
public:
initonly Object^ ProductKey

Field Value

Type: Object
See Also

Reference

ProduckKeySelectedMessage Class
VisualComponents.UX.Shared Namespace


ProductDetailInfoEntry Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedProductDetailInfoEntry
VisualComponents.UX.SharedProductInfoEntry

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ProductDetailInfoEntry
public ref class ProductDetailInfoEntry

The ProductDetailInfoEntry type exposes the following members.

Constructors
 | Name | Description
Public method | ProductDetailInfoEntry | Initializes a new instance of the ProductDetailInfoEntry class
Top
Properties
 | Name | Description
Public property | AssemblyVersion |
Public property | BuildDate |
Public property | BuildVersion |
Public property | FullName |
Public property | ProductVersion |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrintAssemblyVersion |
Public method | PrintBuildDate |
Public method | PrintBuildVersion |
Public method | PrintProductVersion |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ProductDetailInfoEntry Constructor

Initializes a new instance of the ProductDetailInfoEntry class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProductDetailInfoEntry()
public:
ProductDetailInfoEntry()
See Also

Reference

ProductDetailInfoEntry Class
VisualComponents.UX.Shared Namespace


ProductDetailInfoEntry Properties

The ProductDetailInfoEntry type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyVersion |
Public property | BuildDate |
Public property | BuildVersion |
Public property | FullName |
Public property | ProductVersion |
Top
See Also

Reference

ProductDetailInfoEntry Class
VisualComponents.UX.Shared Namespace


ProductDetailInfoEntry.AssemblyVersion Property

ProductDetailInfoEntryAssemblyVersion Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssemblyVersion { get; set; }
public:
property String^ AssemblyVersion {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ProductDetailInfoEntry Class
VisualComponents.UX.Shared Namespace


ProductDetailInfoEntry.BuildDate Property

ProductDetailInfoEntryBuildDate Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string BuildDate { get; set; }
public:
property String^ BuildDate {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ProductDetailInfoEntry Class
VisualComponents.UX.Shared Namespace


ProductDetailInfoEntry.BuildVersion Property

ProductDetailInfoEntryBuildVersion Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string BuildVersion { get; set; }
public:
property String^ BuildVersion {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ProductDetailInfoEntry Class
VisualComponents.UX.Shared Namespace


ProductDetailInfoEntry.FullName Property

ProductDetailInfoEntryFullName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual string FullName { get; }
public:
virtual property String^ FullName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ProductDetailInfoEntry Class
VisualComponents.UX.Shared Namespace


ProductDetailInfoEntry.ProductVersion Property

ProductDetailInfoEntryProductVersion Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ProductVersion { get; set; }
public:
property String^ ProductVersion {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ProductDetailInfoEntry Class
VisualComponents.UX.Shared Namespace


ProductDetailInfoEntry Methods

The ProductDetailInfoEntry type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrintAssemblyVersion |
Public method | PrintBuildDate |
Public method | PrintBuildVersion |
Public method | PrintProductVersion |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProductDetailInfoEntry Class
VisualComponents.UX.Shared Namespace


ProductDetailInfoEntry.PrintAssemblyVersion Method

ProductDetailInfoEntryPrintAssemblyVersion Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string PrintAssemblyVersion()
public:
String^ PrintAssemblyVersion()

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ProductDetailInfoEntry.PrintAssemblyVersion"]

See Also

Reference

ProductDetailInfoEntry Class
VisualComponents.UX.Shared Namespace


ProductDetailInfoEntry.PrintBuildDate Method

ProductDetailInfoEntryPrintBuildDate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string PrintBuildDate()
public:
String^ PrintBuildDate()

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ProductDetailInfoEntry.PrintBuildDate"]

See Also

Reference

ProductDetailInfoEntry Class
VisualComponents.UX.Shared Namespace


ProductDetailInfoEntry.PrintBuildVersion Method

ProductDetailInfoEntryPrintBuildVersion Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string PrintBuildVersion()
public:
String^ PrintBuildVersion()

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ProductDetailInfoEntry.PrintBuildVersion"]

See Also

Reference

ProductDetailInfoEntry Class
VisualComponents.UX.Shared Namespace


ProductDetailInfoEntry.PrintProductVersion Method

ProductDetailInfoEntryPrintProductVersion Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string PrintProductVersion()
public:
String^ PrintProductVersion()

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ProductDetailInfoEntry.PrintProductVersion"]

See Also

Reference

ProductDetailInfoEntry Class
VisualComponents.UX.Shared Namespace


ProductInfo Class

Provides information about the runtime environment.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedProductInfo

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ProductInfo
public ref class ProductInfo

The ProductInfo type exposes the following members.

Properties
 | Name | Description
Public property | Pies |
 | Value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProductArchitecture | Returns product architectur.(i.e if it is 32-bit or 64-bit)
Public method | GetProductDetails |
Public method | GetProductInformation |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ProductInfo Properties

The ProductInfo type exposes the following members.

Properties
 | Name | Description
Public property | Pies |
 | Value |
Top
See Also

Reference

ProductInfo Class
VisualComponents.UX.Shared Namespace


ProductInfo.Pies Property

ProductInfoPies Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<ProductInfoEntry> Pies { get; set; }
public:
property List<ProductInfoEntry^>^ Pies {
    List<ProductInfoEntry^>^ get ();
    void set (List<ProductInfoEntry^>^ value);
}

Property Value

Type: ListProductInfoEntry
See Also

Reference

ProductInfo Class
VisualComponents.UX.Shared Namespace


ProductInfo.Value Property

ProductInfoValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ProductInfo Value { get; }
public:
static property ProductInfo^ Value {
    ProductInfo^ get ();
}

Property Value

Type: ProductInfo
See Also

Reference

ProductInfo Class
VisualComponents.UX.Shared Namespace


ProductInfo Methods

The ProductInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProductArchitecture | Returns product architectur.(i.e if it is 32-bit or 64-bit)
Public method | GetProductDetails |
Public method | GetProductInformation |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProductInfo Class
VisualComponents.UX.Shared Namespace


ProductInfo.GetProductArchitecture Method

ProductInfoGetProductArchitecture Method

Returns product architectur.(i.e if it is 32-bit or 64-bit)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string GetProductArchitecture()
public:
String^ GetProductArchitecture()

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ProductInfo.GetProductArchitecture"]

See Also

Reference

ProductInfo Class
VisualComponents.UX.Shared Namespace


ProductInfo.GetProductDetails Method

ProductInfoGetProductDetails Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<ProductDetailInfoEntry> GetProductDetails()
public:
List<ProductDetailInfoEntry^>^ GetProductDetails()

Return Value

Type: ListProductDetailInfoEntry

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ProductInfo.GetProductDetails"]

See Also

Reference

ProductInfo Class
VisualComponents.UX.Shared Namespace


ProductInfo.GetProductInformation Method

ProductInfoGetProductInformation Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProductInfo GetProductInformation()
public:
ProductInfo^ GetProductInformation()

Return Value

Type: ProductInfo

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ProductInfo.GetProductInformation"]

See Also

Reference

ProductInfo Class
VisualComponents.UX.Shared Namespace


ProductInfoEntry Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedProductDetailInfoEntry
VisualComponents.UX.SharedProductInfoEntry

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ProductInfoEntry : ProductDetailInfoEntry
public ref class ProductInfoEntry : public ProductDetailInfoEntry

The ProductInfoEntry type exposes the following members.

Constructors
 | Name | Description
Public method | ProductInfoEntry | Initializes a new instance of the ProductInfoEntry class
Top
Properties
 | Name | Description
Public property | AssemblyVersion | (Inherited from ProductDetailInfoEntry.)
Public property | BuildDate | (Inherited from ProductDetailInfoEntry.)
Public property | BuildVersion | (Inherited from ProductDetailInfoEntry.)
Public property | FullName | (Overrides ProductDetailInfoEntryFullName.)
Public property | Name |
Public property | ProductVersion | (Inherited from ProductDetailInfoEntry.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrintAssemblyVersion | (Inherited from ProductDetailInfoEntry.)
Public method | PrintBuildDate | (Inherited from ProductDetailInfoEntry.)
Public method | PrintBuildVersion | (Inherited from ProductDetailInfoEntry.)
Public method | PrintProductVersion | (Inherited from ProductDetailInfoEntry.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ProductInfoEntry Constructor

Initializes a new instance of the ProductInfoEntry class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProductInfoEntry()
public:
ProductInfoEntry()
See Also

Reference

ProductInfoEntry Class
VisualComponents.UX.Shared Namespace


ProductInfoEntry Properties

The ProductInfoEntry type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyVersion | (Inherited from ProductDetailInfoEntry.)
Public property | BuildDate | (Inherited from ProductDetailInfoEntry.)
Public property | BuildVersion | (Inherited from ProductDetailInfoEntry.)
Public property | FullName | (Overrides ProductDetailInfoEntryFullName.)
Public property | Name |
Public property | ProductVersion | (Inherited from ProductDetailInfoEntry.)
Top
See Also

Reference

ProductInfoEntry Class
VisualComponents.UX.Shared Namespace


ProductInfoEntry.FullName Property

ProductInfoEntryFullName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string FullName { get; }
public:
virtual property String^ FullName {
    String^ get () override;
}

Property Value

Type: String
See Also

Reference

ProductInfoEntry Class
VisualComponents.UX.Shared Namespace


ProductInfoEntry.Name Property

ProductInfoEntryName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; set; }
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ProductInfoEntry Class
VisualComponents.UX.Shared Namespace


ProductInfoEntry Methods

The ProductInfoEntry type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrintAssemblyVersion | (Inherited from ProductDetailInfoEntry.)
Public method | PrintBuildDate | (Inherited from ProductDetailInfoEntry.)
Public method | PrintBuildVersion | (Inherited from ProductDetailInfoEntry.)
Public method | PrintProductVersion | (Inherited from ProductDetailInfoEntry.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProductInfoEntry Class
VisualComponents.UX.Shared Namespace


ProductKeyStringConverter Class

Product key string converter
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedProductKeyStringConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ProductKeyStringConverter : IValueConverter
public ref class ProductKeyStringConverter : IValueConverter

The ProductKeyStringConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ProductKeyStringConverter | Initializes a new instance of the ProductKeyStringConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ProductKeyStringConverter Constructor

Initializes a new instance of the ProductKeyStringConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProductKeyStringConverter()
public:
ProductKeyStringConverter()
See Also

Reference

ProductKeyStringConverter Class
VisualComponents.UX.Shared Namespace


ProductKeyStringConverter Methods

The ProductKeyStringConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProductKeyStringConverter Class
VisualComponents.UX.Shared Namespace


ProductKeyStringConverter.Convert Method

ProductKeyStringConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ProductKeyStringConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

ProductKeyStringConverter Class
VisualComponents.UX.Shared Namespace


ProductKeyStringConverter.ConvertBack Method

ProductKeyStringConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ProductKeyStringConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

ProductKeyStringConverter Class
VisualComponents.UX.Shared Namespace


ProgramStatementPositionPickedMessage Class

Note: This API is now obsolete.

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedProgramStatementPositionPickedMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("This class is obsolete.")]
public class ProgramStatementPositionPickedMessage
[ObsoleteAttribute(L"This class is obsolete.")]
public ref class ProgramStatementPositionPickedMessage

The ProgramStatementPositionPickedMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ProgramStatementPositionPickedMessage | Initializes a new instance of the ProgramStatementPositionPickedMessage class
Top
Properties
 | Name | Description
Public property | PickPosition |
Public property | PositionName |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ProgramStatementPositionPickedMessage Constructor

Initializes a new instance of the ProgramStatementPositionPickedMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProgramStatementPositionPickedMessage()
public:
ProgramStatementPositionPickedMessage()
See Also

Reference

ProgramStatementPositionPickedMessage Class
VisualComponents.UX.Shared Namespace


ProgramStatementPositionPickedMessage Properties

The ProgramStatementPositionPickedMessage type exposes the following members.

Properties
 | Name | Description
Public property | PickPosition |
Public property | PositionName |
Top
See Also

Reference

ProgramStatementPositionPickedMessage Class
VisualComponents.UX.Shared Namespace


ProgramStatementPositionPickedMessage.PickPosition Property

ProgramStatementPositionPickedMessagePickPosition Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 PickPosition { get; set; }
public:
property Vector3 PickPosition {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

ProgramStatementPositionPickedMessage Class
VisualComponents.UX.Shared Namespace


ProgramStatementPositionPickedMessage.PositionName Property

ProgramStatementPositionPickedMessagePositionName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string PositionName { get; set; }
public:
property String^ PositionName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ProgramStatementPositionPickedMessage Class
VisualComponents.UX.Shared Namespace


ProgramStatementPositionPickedMessage Methods

The ProgramStatementPositionPickedMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProgramStatementPositionPickedMessage Class
VisualComponents.UX.Shared Namespace


ProgramStatementPositionsUpdateMessage Class

Note: This API is now obsolete.

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedProgramStatementPositionsUpdateMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("This class is obsolete; connecting lines service is now automatically updated. Use IConnectingLinesService.BeginUpdate and EndUpdate calls to prevent unnecessary updates if required.")]
public class ProgramStatementPositionsUpdateMessage
[ObsoleteAttribute(L"This class is obsolete; connecting lines service is now automatically updated. Use IConnectingLinesService.BeginUpdate and EndUpdate calls to prevent unnecessary updates if required.")]
public ref class ProgramStatementPositionsUpdateMessage

The ProgramStatementPositionsUpdateMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ProgramStatementPositionsUpdateMessage | Initializes a new instance of the ProgramStatementPositionsUpdateMessage class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ProgramStatementPositionsUpdateMessage Constructor

Initializes a new instance of the ProgramStatementPositionsUpdateMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProgramStatementPositionsUpdateMessage()
public:
ProgramStatementPositionsUpdateMessage()
See Also

Reference

ProgramStatementPositionsUpdateMessage Class
VisualComponents.UX.Shared Namespace


ProgramStatementPositionsUpdateMessage Methods

The ProgramStatementPositionsUpdateMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProgramStatementPositionsUpdateMessage Class
VisualComponents.UX.Shared Namespace


ProgressBarStates Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ProgressBarStates
public enum class ProgressBarStates
Members
Member name | Value | Description
InProgress | 0 |
Idle | 1 |
NotResponding | 2 |
See Also

Reference

VisualComponents.UX.Shared Namespace


ProgressDialog Class

Interaction logic for ProgressDialog.xaml
ProgressDialog
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.WindowsWindow
VisualComponents.UX.SharedProgressDialog

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ProgressDialog : Window,
    IComponentConnector
public ref class ProgressDialog : public Window,
    IComponentConnector

The ProgressDialog type exposes the following members.

Constructors
 | Name | Description
Public method | ProgressDialog(String) | Initializes a new instance of the ProgressDialog class
Public method | ProgressDialog(String, ProgressDialogSettings) | Initializes a new instance of the ProgressDialog class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CancelTask |
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Protected property | LogicalChildren | Gets an enumerator for a window's logical child elements. (Inherited from Window.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | ProgressDialogTitle |
Public property | ProgressText |
Public property | ProgressValue |
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override this method to arrange and size a window and its child elements. (Inherited from Window.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override this method to measure the size of a window. (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Window.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Window.)
Protected method | OnClosing | (Overrides WindowOnClosing(CancelEventArgs).)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from Window.)
Protected method | OnContentRendered | Raises the ContentRendered event. (Inherited from Window.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a WindowAutomationPeer object for this Window. (Inherited from Window.)
Protected method | OnDeactivated | Raises the Deactivated event. (Inherited from Window.)
Protected method | OnDpiChanged | Called when the DPI at which this window is rendered changes. (Inherited from Window.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Window.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from Window.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSourceInitialized | Raises the SourceInitialized event. (Inherited from Window.)
Protected method | OnStateChanged | Raises the StateChanged event. (Inherited from Window.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the window is changed. (Inherited from Window.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DpiChanged | Occurs after the DPI of the screen on which the Window is displayed changes. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ProgressDialog Constructor

Overload List
 | Name | Description
Public method | ProgressDialog(String) | Initializes a new instance of the ProgressDialog class
Public method | ProgressDialog(String, ProgressDialogSettings) | Initializes a new instance of the ProgressDialog class
Top
See Also

Reference

ProgressDialog Class
VisualComponents.UX.Shared Namespace


ProgressDialog Constructor (String)

Initializes a new instance of the ProgressDialog class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProgressDialog(
    string dialogTitle
)
public:
ProgressDialog(
    String^ dialogTitle
)

Parameters

dialogTitle
Type: SystemString
See Also

Reference

ProgressDialog Class
ProgressDialog Overload
VisualComponents.UX.Shared Namespace


ProgressDialog Constructor (String, ProgressDialogSettings)

Initializes a new instance of the ProgressDialog class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProgressDialog(
    string dialogTitle,
    ProgressDialogSettings settings
)
public:
ProgressDialog(
    String^ dialogTitle,
    ProgressDialogSettings^ settings
)

Parameters

dialogTitle
Type: SystemString
settings
Type: VisualComponents.UX.SharedProgressDialogSettings
See Also

Reference

ProgressDialog Class
ProgressDialog Overload
VisualComponents.UX.Shared Namespace


ProgressDialog Properties

The ProgressDialog type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CancelTask |
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Protected property | LogicalChildren | Gets an enumerator for a window's logical child elements. (Inherited from Window.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | ProgressDialogTitle |
Public property | ProgressText |
Public property | ProgressValue |
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ProgressDialog Class
VisualComponents.UX.Shared Namespace


ProgressDialog.CancelTask Property

ProgressDialogCancelTask Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Task CancelTask { get; set; }
public:
virtual property Task^ CancelTask {
    Task^ get () sealed;
    void set (Task^ value) sealed;
}

Property Value

Type: Task
See Also

Reference

ProgressDialog Class
VisualComponents.UX.Shared Namespace


ProgressDialog.ProgressDialogTitle Property

ProgressDialogProgressDialogTitle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ProgressDialogTitle { get; set; }
public:
virtual property String^ ProgressDialogTitle {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
See Also

Reference

ProgressDialog Class
VisualComponents.UX.Shared Namespace


ProgressDialog.ProgressText Property

ProgressDialogProgressText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ProgressText { get; set; }
public:
virtual property String^ ProgressText {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
See Also

Reference

ProgressDialog Class
VisualComponents.UX.Shared Namespace


ProgressDialog.ProgressValue Property

ProgressDialogProgressValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ProgressValue { get; set; }
public:
virtual property int ProgressValue {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32
See Also

Reference

ProgressDialog Class
VisualComponents.UX.Shared Namespace


ProgressDialog Methods

The ProgressDialog type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override this method to arrange and size a window and its child elements. (Inherited from Window.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override this method to measure the size of a window. (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Window.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Window.)
Protected method | OnClosing | (Overrides WindowOnClosing(CancelEventArgs).)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from Window.)
Protected method | OnContentRendered | Raises the ContentRendered event. (Inherited from Window.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a WindowAutomationPeer object for this Window. (Inherited from Window.)
Protected method | OnDeactivated | Raises the Deactivated event. (Inherited from Window.)
Protected method | OnDpiChanged | Called when the DPI at which this window is rendered changes. (Inherited from Window.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Window.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from Window.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSourceInitialized | Raises the SourceInitialized event. (Inherited from Window.)
Protected method | OnStateChanged | Raises the StateChanged event. (Inherited from Window.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the window is changed. (Inherited from Window.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProgressDialog Class
VisualComponents.UX.Shared Namespace


ProgressDialog.InitializeComponent Method

ProgressDialogInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

ProgressDialog Class
VisualComponents.UX.Shared Namespace


ProgressDialog.OnClosing Method

ProgressDialogOnClosing Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnClosing(
    CancelEventArgs e
)
protected:
virtual void OnClosing(
    CancelEventArgs^ e
) override

Parameters

e
Type: System.ComponentModelCancelEventArgs
See Also

Reference

ProgressDialog Class
VisualComponents.UX.Shared Namespace


ProgressDialog Events

The ProgressDialog type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DpiChanged | Occurs after the DPI of the screen on which the Window is displayed changes. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ProgressDialog Class
VisualComponents.UX.Shared Namespace


ProgressDialog2 Class

Interaction logic for ProgressDialog.xaml
ProgressDialog2
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.WindowsWindow
VisualComponents.UX.SharedProgressDialog2

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ProgressDialog2 : Window,
    IComponentConnector
public ref class ProgressDialog2 : public Window,
    IComponentConnector

The ProgressDialog2 type exposes the following members.

Constructors
 | Name | Description
Public method | ProgressDialog2(String) | Initializes a new instance of the ProgressDialog2 class
Public method | ProgressDialog2(String, ProgressDialogSettings) | Initializes a new instance of the ProgressDialog2 class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CancelTask |
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Protected property | LogicalChildren | Gets an enumerator for a window's logical child elements. (Inherited from Window.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | ProgressDialogTitle |
Public property | ProgressText |
Public property | ProgressValue |
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override this method to arrange and size a window and its child elements. (Inherited from Window.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CloseDialog |
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override this method to measure the size of a window. (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Window.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Window.)
Protected method | OnClosing | (Overrides WindowOnClosing(CancelEventArgs).)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from Window.)
Protected method | OnContentRendered | Raises the ContentRendered event. (Inherited from Window.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a WindowAutomationPeer object for this Window. (Inherited from Window.)
Protected method | OnDeactivated | Raises the Deactivated event. (Inherited from Window.)
Protected method | OnDpiChanged | Called when the DPI at which this window is rendered changes. (Inherited from Window.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Window.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from Window.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSourceInitialized | Raises the SourceInitialized event. (Inherited from Window.)
Protected method | OnStateChanged | Raises the StateChanged event. (Inherited from Window.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the window is changed. (Inherited from Window.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DpiChanged | Occurs after the DPI of the screen on which the Window is displayed changes. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ProgressDialog2 Constructor

Overload List
 | Name | Description
Public method | ProgressDialog2(String) | Initializes a new instance of the ProgressDialog2 class
Public method | ProgressDialog2(String, ProgressDialogSettings) | Initializes a new instance of the ProgressDialog2 class
Top
See Also

Reference

ProgressDialog2 Class
VisualComponents.UX.Shared Namespace


ProgressDialog2 Constructor (String)

Initializes a new instance of the ProgressDialog2 class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProgressDialog2(
    string dialogTitle
)
public:
ProgressDialog2(
    String^ dialogTitle
)

Parameters

dialogTitle
Type: SystemString
See Also

Reference

ProgressDialog2 Class
ProgressDialog2 Overload
VisualComponents.UX.Shared Namespace


ProgressDialog2 Constructor (String, ProgressDialogSettings)

Initializes a new instance of the ProgressDialog2 class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProgressDialog2(
    string dialogTitle,
    ProgressDialogSettings settings
)
public:
ProgressDialog2(
    String^ dialogTitle,
    ProgressDialogSettings^ settings
)

Parameters

dialogTitle
Type: SystemString
settings
Type: VisualComponents.UX.SharedProgressDialogSettings
See Also

Reference

ProgressDialog2 Class
ProgressDialog2 Overload
VisualComponents.UX.Shared Namespace


ProgressDialog2 Properties

The ProgressDialog2 type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CancelTask |
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Protected property | LogicalChildren | Gets an enumerator for a window's logical child elements. (Inherited from Window.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | ProgressDialogTitle |
Public property | ProgressText |
Public property | ProgressValue |
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ProgressDialog2 Class
VisualComponents.UX.Shared Namespace


ProgressDialog2.CancelTask Property

ProgressDialog2CancelTask Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Task CancelTask { get; set; }
public:
virtual property Task^ CancelTask {
    Task^ get () sealed;
    void set (Task^ value) sealed;
}

Property Value

Type: Task
See Also

Reference

ProgressDialog2 Class
VisualComponents.UX.Shared Namespace


ProgressDialog2.ProgressDialogTitle Property

ProgressDialog2ProgressDialogTitle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ProgressDialogTitle { get; set; }
public:
virtual property String^ ProgressDialogTitle {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
See Also

Reference

ProgressDialog2 Class
VisualComponents.UX.Shared Namespace


ProgressDialog2.ProgressText Property

ProgressDialog2ProgressText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ProgressText { get; set; }
public:
virtual property String^ ProgressText {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String
See Also

Reference

ProgressDialog2 Class
VisualComponents.UX.Shared Namespace


ProgressDialog2.ProgressValue Property

ProgressDialog2ProgressValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ProgressValue { get; set; }
public:
virtual property int ProgressValue {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32
See Also

Reference

ProgressDialog2 Class
VisualComponents.UX.Shared Namespace


ProgressDialog2 Methods

The ProgressDialog2 type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override this method to arrange and size a window and its child elements. (Inherited from Window.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CloseDialog |
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override this method to measure the size of a window. (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Window.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Window.)
Protected method | OnClosing | (Overrides WindowOnClosing(CancelEventArgs).)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from Window.)
Protected method | OnContentRendered | Raises the ContentRendered event. (Inherited from Window.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a WindowAutomationPeer object for this Window. (Inherited from Window.)
Protected method | OnDeactivated | Raises the Deactivated event. (Inherited from Window.)
Protected method | OnDpiChanged | Called when the DPI at which this window is rendered changes. (Inherited from Window.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Window.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from Window.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSourceInitialized | Raises the SourceInitialized event. (Inherited from Window.)
Protected method | OnStateChanged | Raises the StateChanged event. (Inherited from Window.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the window is changed. (Inherited from Window.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProgressDialog2 Class
VisualComponents.UX.Shared Namespace


ProgressDialog2.CloseDialog Method

ProgressDialog2CloseDialog Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CloseDialog()
public:
void CloseDialog()
See Also

Reference

ProgressDialog2 Class
VisualComponents.UX.Shared Namespace


ProgressDialog2.InitializeComponent Method

ProgressDialog2InitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

ProgressDialog2 Class
VisualComponents.UX.Shared Namespace


ProgressDialog2.OnClosing Method

ProgressDialog2OnClosing Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnClosing(
    CancelEventArgs e
)
protected:
virtual void OnClosing(
    CancelEventArgs^ e
) override

Parameters

e
Type: System.ComponentModelCancelEventArgs
See Also

Reference

ProgressDialog2 Class
VisualComponents.UX.Shared Namespace


ProgressDialog2 Events

The ProgressDialog2 type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DpiChanged | Occurs after the DPI of the screen on which the Window is displayed changes. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ProgressDialog2 Class
VisualComponents.UX.Shared Namespace


ProgressDialogSettings Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedProgressDialogSettings

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ProgressDialogSettings
public ref class ProgressDialogSettings

The ProgressDialogSettings type exposes the following members.

Constructors
 | Name | Description
Public method | ProgressDialogSettings | Initializes a new instance of the ProgressDialogSettings class
Public method | ProgressDialogSettings(Boolean, Boolean, Boolean) | Initializes a new instance of the ProgressDialogSettings class
Top
Properties
 | Name | Description
Public property | ShowCancelButton |
Public property | ShowProgressBarIndeterminate |
Public property | ShowSubLabel |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
WithLabelOnly |
WithSubLabel |
WithSubLabelAndCancel |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ProgressDialogSettings Constructor

Overload List
 | Name | Description
Public method | ProgressDialogSettings | Initializes a new instance of the ProgressDialogSettings class
Public method | ProgressDialogSettings(Boolean, Boolean, Boolean) | Initializes a new instance of the ProgressDialogSettings class
Top
See Also

Reference

ProgressDialogSettings Class
VisualComponents.UX.Shared Namespace


ProgressDialogSettings Constructor

Initializes a new instance of the ProgressDialogSettings class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProgressDialogSettings()
public:
ProgressDialogSettings()
See Also

Reference

ProgressDialogSettings Class
ProgressDialogSettings Overload
VisualComponents.UX.Shared Namespace


ProgressDialogSettings Constructor (Boolean, Boolean, Boolean)

Initializes a new instance of the ProgressDialogSettings class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProgressDialogSettings(
    bool showSubLabel,
    bool showCancelButton,
    bool showProgressBarIndeterminate
)
public:
ProgressDialogSettings(
    bool showSubLabel,
    bool showCancelButton,
    bool showProgressBarIndeterminate
)

Parameters

showSubLabel
Type: SystemBoolean
showCancelButton
Type: SystemBoolean
showProgressBarIndeterminate
Type: SystemBoolean
See Also

Reference

ProgressDialogSettings Class
ProgressDialogSettings Overload
VisualComponents.UX.Shared Namespace


ProgressDialogSettings Properties

The ProgressDialogSettings type exposes the following members.

Properties
 | Name | Description
Public property | ShowCancelButton |
Public property | ShowProgressBarIndeterminate |
Public property | ShowSubLabel |
Top
See Also

Reference

ProgressDialogSettings Class
VisualComponents.UX.Shared Namespace


ProgressDialogSettings.ShowCancelButton Property

ProgressDialogSettingsShowCancelButton Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowCancelButton { get; set; }
public:
property bool ShowCancelButton {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ProgressDialogSettings Class
VisualComponents.UX.Shared Namespace


ProgressDialogSettings.ShowProgressBarIndeterminate Property

ProgressDialogSettingsShowProgressBarIndeterminate Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowProgressBarIndeterminate { get; set; }
public:
property bool ShowProgressBarIndeterminate {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ProgressDialogSettings Class
VisualComponents.UX.Shared Namespace


ProgressDialogSettings.ShowSubLabel Property

ProgressDialogSettingsShowSubLabel Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowSubLabel { get; set; }
public:
property bool ShowSubLabel {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ProgressDialogSettings Class
VisualComponents.UX.Shared Namespace


ProgressDialogSettings Methods

The ProgressDialogSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProgressDialogSettings Class
VisualComponents.UX.Shared Namespace


ProgressDialogSettings Fields

The ProgressDialogSettings type exposes the following members.

Fields
Name | Description
WithLabelOnly |
WithSubLabel |
WithSubLabelAndCancel |
Top
See Also

Reference

ProgressDialogSettings Class
VisualComponents.UX.Shared Namespace


ProgressDialogSettings.WithLabelOnly Field

ProgressDialogSettingsWithLabelOnly Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ProgressDialogSettings WithLabelOnly
public:
static ProgressDialogSettings^ WithLabelOnly

Field Value

Type: ProgressDialogSettings
See Also

Reference

ProgressDialogSettings Class
VisualComponents.UX.Shared Namespace


ProgressDialogSettings.WithSubLabel Field

ProgressDialogSettingsWithSubLabel Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ProgressDialogSettings WithSubLabel
public:
static ProgressDialogSettings^ WithSubLabel

Field Value

Type: ProgressDialogSettings
See Also

Reference

ProgressDialogSettings Class
VisualComponents.UX.Shared Namespace


ProgressDialogSettings.WithSubLabelAndCancel Field

ProgressDialogSettingsWithSubLabelAndCancel Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ProgressDialogSettings WithSubLabelAndCancel
public:
static ProgressDialogSettings^ WithSubLabelAndCancel

Field Value

Type: ProgressDialogSettings
See Also

Reference

ProgressDialogSettings Class
VisualComponents.UX.Shared Namespace


ProgressEventArgs Class

Occurs when action is progressing.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.UX.SharedProgressEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ProgressEventArgs : EventArgs
public ref class ProgressEventArgs : public EventArgs

The ProgressEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ProgressEventArgs | Initializes a new instance of the ProgressEventArgs class
Top
Properties
 | Name | Description
Public property | Progress | Gets or sets Action completion percentage.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ProgressEventArgs Constructor

Initializes a new instance of the ProgressEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ProgressEventArgs()
public:
ProgressEventArgs()
See Also

Reference

ProgressEventArgs Class
VisualComponents.UX.Shared Namespace


ProgressEventArgs Properties

The ProgressEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Progress | Gets or sets Action completion percentage.
Top
See Also

Reference

ProgressEventArgs Class
VisualComponents.UX.Shared Namespace


ProgressEventArgs.Progress Property

ProgressEventArgsProgress Property

Gets or sets Action completion percentage.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Progress { get; set; }
public:
property double Progress {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ProgressEventArgs Class
VisualComponents.UX.Shared Namespace


ProgressEventArgs Methods

The ProgressEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ProgressEventArgs Class
VisualComponents.UX.Shared Namespace


PropertyAllowedValueModel Class

Represents an bindable item from allowed value set of a property.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedPropertyAllowedValueModel

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class PropertyAllowedValueModel
public ref class PropertyAllowedValueModel sealed

The PropertyAllowedValueModel type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyAllowedValueModel | Initializes a new instance of the PropertyAllowedValueModel class
Top
Properties
 | Name | Description
Public property | IsCreator |
Public property | IsSeparator |
Public property | Key |
Public property | Tooltip |
Public property | Unit |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PropertyAllowedValueModel Constructor

Initializes a new instance of the PropertyAllowedValueModel class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyAllowedValueModel()
public:
PropertyAllowedValueModel()
See Also

Reference

PropertyAllowedValueModel Class
VisualComponents.UX.Shared Namespace


PropertyAllowedValueModel Properties

The PropertyAllowedValueModel type exposes the following members.

Properties
 | Name | Description
Public property | IsCreator |
Public property | IsSeparator |
Public property | Key |
Public property | Tooltip |
Public property | Unit |
Public property | Value |
Top
See Also

Reference

PropertyAllowedValueModel Class
VisualComponents.UX.Shared Namespace


PropertyAllowedValueModel.IsCreator Property

PropertyAllowedValueModelIsCreator Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsCreator { get; set; }
public:
property bool IsCreator {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PropertyAllowedValueModel Class
VisualComponents.UX.Shared Namespace


PropertyAllowedValueModel.IsSeparator Property

PropertyAllowedValueModelIsSeparator Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsSeparator { get; set; }
public:
property bool IsSeparator {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PropertyAllowedValueModel Class
VisualComponents.UX.Shared Namespace


PropertyAllowedValueModel.Key Property

PropertyAllowedValueModelKey Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Key { get; set; }
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PropertyAllowedValueModel Class
VisualComponents.UX.Shared Namespace


PropertyAllowedValueModel.Tooltip Property

PropertyAllowedValueModelTooltip Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Tooltip { get; set; }
public:
property String^ Tooltip {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PropertyAllowedValueModel Class
VisualComponents.UX.Shared Namespace


PropertyAllowedValueModel.Unit Property

PropertyAllowedValueModelUnit Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IUnit Unit { get; set; }
public:
property IUnit^ Unit {
    IUnit^ get ();
    void set (IUnit^ value);
}

Property Value

Type: IUnit
See Also

Reference

PropertyAllowedValueModel Class
VisualComponents.UX.Shared Namespace


PropertyAllowedValueModel.Value Property

PropertyAllowedValueModelValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Value { get; set; }
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

PropertyAllowedValueModel Class
VisualComponents.UX.Shared Namespace


PropertyAllowedValueModel Methods

The PropertyAllowedValueModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PropertyAllowedValueModel Class
VisualComponents.UX.Shared Namespace


PropertyAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
VisualComponents.UX.SharedPropertyAttribute

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PropertyAttribute : Attribute
public ref class PropertyAttribute : public Attribute

The PropertyAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyAttribute | Initializes a new instance of the PropertyAttribute class
Public method | PropertyAttribute(Boolean) | Initializes a new instance of the PropertyAttribute class
Public method | PropertyAttribute(String) | Initializes a new instance of the PropertyAttribute class
Public method | PropertyAttribute(String, Boolean) | Initializes a new instance of the PropertyAttribute class
Top
Properties
 | Name | Description
Public property | AllowedMaximum |
Public property | AllowedMinimum |
Public property | AllowedValues |
Public property | Category |
Public property | ConstraintType |
Public property | Description |
Public property | Name |
Public property | RequestRender |
Public property | TabHeader |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PropertyAttribute Constructor

Overload List
 | Name | Description
Public method | PropertyAttribute | Initializes a new instance of the PropertyAttribute class
Public method | PropertyAttribute(Boolean) | Initializes a new instance of the PropertyAttribute class
Public method | PropertyAttribute(String) | Initializes a new instance of the PropertyAttribute class
Public method | PropertyAttribute(String, Boolean) | Initializes a new instance of the PropertyAttribute class
Top
See Also

Reference

PropertyAttribute Class
VisualComponents.UX.Shared Namespace


PropertyAttribute Constructor

Initializes a new instance of the PropertyAttribute class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyAttribute()
public:
PropertyAttribute()
See Also

Reference

PropertyAttribute Class
PropertyAttribute Overload
VisualComponents.UX.Shared Namespace


PropertyAttribute Constructor (Boolean)

Initializes a new instance of the PropertyAttribute class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyAttribute(
    bool requestRender
)
public:
PropertyAttribute(
    bool requestRender
)

Parameters

requestRender
Type: SystemBoolean
See Also

Reference

PropertyAttribute Class
PropertyAttribute Overload
VisualComponents.UX.Shared Namespace


PropertyAttribute Constructor (String)

Initializes a new instance of the PropertyAttribute class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyAttribute(
    string name
)
public:
PropertyAttribute(
    String^ name
)

Parameters

name
Type: SystemString
See Also

Reference

PropertyAttribute Class
PropertyAttribute Overload
VisualComponents.UX.Shared Namespace


PropertyAttribute Constructor (String, Boolean)

Initializes a new instance of the PropertyAttribute class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyAttribute(
    string name,
    bool requestRender
)
public:
PropertyAttribute(
    String^ name,
    bool requestRender
)

Parameters

name
Type: SystemString
requestRender
Type: SystemBoolean
See Also

Reference

PropertyAttribute Class
PropertyAttribute Overload
VisualComponents.UX.Shared Namespace


PropertyAttribute Properties

The PropertyAttribute type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum |
Public property | AllowedMinimum |
Public property | AllowedValues |
Public property | Category |
Public property | ConstraintType |
Public property | Description |
Public property | Name |
Public property | RequestRender |
Public property | TabHeader |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

PropertyAttribute Class
VisualComponents.UX.Shared Namespace


PropertyAttribute.AllowedMaximum Property

PropertyAttributeAllowedMaximum Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AllowedMaximum { get; set; }
public:
property String^ AllowedMaximum {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PropertyAttribute Class
VisualComponents.UX.Shared Namespace


PropertyAttribute.AllowedMinimum Property

PropertyAttributeAllowedMinimum Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AllowedMinimum { get; set; }
public:
property String^ AllowedMinimum {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PropertyAttribute Class
VisualComponents.UX.Shared Namespace


PropertyAttribute.AllowedValues Property

PropertyAttributeAllowedValues Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AllowedValues { get; set; }
public:
property String^ AllowedValues {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PropertyAttribute Class
VisualComponents.UX.Shared Namespace


PropertyAttribute.Category Property

PropertyAttributeCategory Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Category { get; set; }
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PropertyAttribute Class
VisualComponents.UX.Shared Namespace


PropertyAttribute.ConstraintType Property

PropertyAttributeConstraintType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyConstraintType ConstraintType { get; set; }
public:
property PropertyConstraintType ConstraintType {
    PropertyConstraintType get ();
    void set (PropertyConstraintType value);
}

Property Value

Type: PropertyConstraintType
See Also

Reference

PropertyAttribute Class
VisualComponents.UX.Shared Namespace


PropertyAttribute.Description Property

PropertyAttributeDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; set; }
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PropertyAttribute Class
VisualComponents.UX.Shared Namespace


PropertyAttribute.Name Property

PropertyAttributeName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; set; }
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PropertyAttribute Class
VisualComponents.UX.Shared Namespace


PropertyAttribute.RequestRender Property

PropertyAttributeRequestRender Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool RequestRender { get; set; }
public:
property bool RequestRender {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PropertyAttribute Class
VisualComponents.UX.Shared Namespace


PropertyAttribute.TabHeader Property

PropertyAttributeTabHeader Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string TabHeader { get; set; }
public:
property String^ TabHeader {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PropertyAttribute Class
VisualComponents.UX.Shared Namespace


PropertyAttribute Methods

The PropertyAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PropertyAttribute Class
VisualComponents.UX.Shared Namespace


PropertyCategory Class

Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollectionIProperty
System.Collections.ObjectModelObservableCollectionIProperty
VisualComponents.Create3DPropertyCollection
VisualComponents.UX.SharedPropertyCategory

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PropertyCategory : PropertyCollection
public ref class PropertyCategory : public PropertyCollection

The PropertyCategory type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyCategory | Initializes a new instance of the PropertyCategory class
Public method | PropertyCategory(String) | Initializes a new instance of the PropertyCategory class
Top
Properties
 | Name | Description
Public property | Category |
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from CollectionIProperty .)
Public property | ItemString | Access properties by name. (Inherited from PropertyCollection.)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from CollectionIProperty .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from CollectionIProperty .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from CollectionIProperty .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollectionIProperty .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollectionIProperty .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from CollectionIProperty .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollectionIProperty .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from CollectionIProperty .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from CollectionIProperty .)
Public method | Dispose | (Inherited from PropertyCollection.)
Protected method | Dispose(Boolean) | (Inherited from PropertyCollection.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from PropertyCollection.)
Public method | GetByIndex | Access properties by index. (Inherited from PropertyCollection.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from CollectionIProperty .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from CollectionIProperty .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from CollectionIProperty .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollectionIProperty .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollectionIProperty .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollectionIProperty .)
Protected method | OnCollectionChanged | (Inherited from PropertyCollection.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollectionIProperty .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from CollectionIProperty .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from CollectionIProperty .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollectionIProperty .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollectionIProperty .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollectionIProperty .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollectionIProperty .)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PropertyCategory Constructor

Overload List
 | Name | Description
Public method | PropertyCategory | Initializes a new instance of the PropertyCategory class
Public method | PropertyCategory(String) | Initializes a new instance of the PropertyCategory class
Top
See Also

Reference

PropertyCategory Class
VisualComponents.UX.Shared Namespace


PropertyCategory Constructor

Initializes a new instance of the PropertyCategory class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyCategory()
public:
PropertyCategory()
See Also

Reference

PropertyCategory Class
PropertyCategory Overload
VisualComponents.UX.Shared Namespace


PropertyCategory Constructor (String)

Initializes a new instance of the PropertyCategory class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyCategory(
    string categoryName
)
public:
PropertyCategory(
    String^ categoryName
)

Parameters

categoryName
Type: SystemString
See Also

Reference

PropertyCategory Class
PropertyCategory Overload
VisualComponents.UX.Shared Namespace


PropertyCategory Properties

The PropertyCategory type exposes the following members.

Properties
 | Name | Description
Public property | Category |
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from CollectionIProperty .)
Public property | ItemString | Access properties by name. (Inherited from PropertyCollection.)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from CollectionIProperty .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from CollectionIProperty .)
Top
See Also

Reference

PropertyCategory Class
VisualComponents.UX.Shared Namespace


PropertyCategory.Category Property

PropertyCategoryCategory Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Category { get; }
public:
property String^ Category {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

PropertyCategory Class
VisualComponents.UX.Shared Namespace


PropertyCategory Methods

The PropertyCategory type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from CollectionIProperty .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollectionIProperty .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollectionIProperty .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from CollectionIProperty .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollectionIProperty .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from CollectionIProperty .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from CollectionIProperty .)
Public method | Dispose | (Inherited from PropertyCollection.)
Protected method | Dispose(Boolean) | (Inherited from PropertyCollection.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from PropertyCollection.)
Public method | GetByIndex | Access properties by index. (Inherited from PropertyCollection.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from CollectionIProperty .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from CollectionIProperty .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from CollectionIProperty .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollectionIProperty .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollectionIProperty .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollectionIProperty .)
Protected method | OnCollectionChanged | (Inherited from PropertyCollection.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollectionIProperty .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from CollectionIProperty .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from CollectionIProperty .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollectionIProperty .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollectionIProperty .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PropertyCategory Class
VisualComponents.UX.Shared Namespace


PropertyCategory Events

The PropertyCategory type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollectionIProperty .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollectionIProperty .)
Top
See Also

Reference

PropertyCategory Class
VisualComponents.UX.Shared Namespace


PropertyDataTemplateSelector Class

This template selector is used to select contentcontrol to display the property. This template then uses another template selector based on the control of the property. todo: these could probably be combined to a single templateselector
Inheritance Hierarchy
SystemObject
System.Windows.ControlsDataTemplateSelector
VisualComponents.UX.SharedPropertyDataTemplateSelector

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PropertyDataTemplateSelector : DataTemplateSelector
public ref class PropertyDataTemplateSelector : public DataTemplateSelector

The PropertyDataTemplateSelector type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyDataTemplateSelector | Initializes a new instance of the PropertyDataTemplateSelector class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SelectTemplate | (Overrides DataTemplateSelectorSelectTemplate(Object, DependencyObject).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PropertyDataTemplateSelector Constructor

Initializes a new instance of the PropertyDataTemplateSelector class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyDataTemplateSelector()
public:
PropertyDataTemplateSelector()
See Also

Reference

PropertyDataTemplateSelector Class
VisualComponents.UX.Shared Namespace


PropertyDataTemplateSelector Methods

The PropertyDataTemplateSelector type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SelectTemplate | (Overrides DataTemplateSelectorSelectTemplate(Object, DependencyObject).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PropertyDataTemplateSelector Class
VisualComponents.UX.Shared Namespace


PropertyDataTemplateSelector.SelectTemplate Method

PropertyDataTemplateSelectorSelectTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override DataTemplate SelectTemplate(
    Object item,
    DependencyObject container
)
public:
virtual DataTemplate^ SelectTemplate(
    Object^ item,
    DependencyObject^ container
) override

Parameters

item
Type: SystemObject
container
Type: System.WindowsDependencyObject

Return Value

Type: DataTemplate

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PropertyDataTemplateSelector.SelectTemplate(System.Object,System.Windows.DependencyObject)"]

See Also

Reference

PropertyDataTemplateSelector Class
VisualComponents.UX.Shared Namespace


PropertyDescription Class

Property description contains property related metadata, such as name, description etc.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedPropertyDescription

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class PropertyDescription
public ref class PropertyDescription sealed

The PropertyDescription type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyDescription | Instantiates a new propertydescription.
Top
Properties
 | Name | Description
Public property | AllowedValues |
Public property | Description |
Public property | DisabledStateToolTip |
Public property | FieldType |
Public property | HelpId | HelpId used to find related help topics.
Public property | HelpText |
Public property | HelpUriString |
Public property | Id |
Public property | IsEditable |
Public property | IsReadOnly |
Public property | IsSystem |
Public property | LabelMargin |
Public property | LocalizedDescription |
Public property | LocalizedDisabledStateToolTip |
Public property | LocalizedName |
Public property | MaxValue |
Public property | MinValue |
Public property | Name |
Public property | Order |
Public property | ProhibitedValues |
Public property | PropertyLabelVisibility |
Public property | SystemName |
Public property | SystemType |
Public property | TargetProperty | A transient (non-persistent) value, that is used for binding unit and editability of the internal property.
Public property | UserData |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTabHeaderLocalizedName |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateLocalizedName |
Top
Fields
 | Name | Description
Public field | _localizedName |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PropertyDescription Constructor

Instantiates a new propertydescription.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyDescription(
    int id,
    bool isSystem,
    string name,
    string systemName,
    int order,
    string description,
    string disabledToolTip,
    bool isEditable,
    EditorProperty targetProperty,
    Object userData
)
public:
PropertyDescription(
    int id,
    bool isSystem,
    String^ name,
    String^ systemName,
    int order,
    String^ description,
    String^ disabledToolTip,
    bool isEditable,
    EditorProperty^ targetProperty,
    Object^ userData
)

Parameters

id
Type: SystemInt32
Unique Id within propertylayout.
isSystem
Type: SystemBoolean
True for internal properties.
name
Type: SystemString
Name used in user interface.
systemName
Type: SystemString
Internal name.
order
Type: SystemInt32
Index number for ordering a list of properties.
description
Type: SystemString
Description.
disabledToolTip
Type: SystemString
ToolTip text for when the property is disabled.
isEditable
Type: SystemBoolean
Is editing allowed in user interface.
targetProperty
Type: VisualComponents.UX.SharedEditorProperty
Property that this instance describes.
userData
Type: SystemObject
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription Properties

The PropertyDescription type exposes the following members.

Properties
 | Name | Description
Public property | AllowedValues |
Public property | Description |
Public property | DisabledStateToolTip |
Public property | FieldType |
Public property | HelpId | HelpId used to find related help topics.
Public property | HelpText |
Public property | HelpUriString |
Public property | Id |
Public property | IsEditable |
Public property | IsReadOnly |
Public property | IsSystem |
Public property | LabelMargin |
Public property | LocalizedDescription |
Public property | LocalizedDisabledStateToolTip |
Public property | LocalizedName |
Public property | MaxValue |
Public property | MinValue |
Public property | Name |
Public property | Order |
Public property | ProhibitedValues |
Public property | PropertyLabelVisibility |
Public property | SystemName |
Public property | SystemType |
Public property | TargetProperty | A transient (non-persistent) value, that is used for binding unit and editability of the internal property.
Public property | UserData |
Top
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription.AllowedValues Property

PropertyDescriptionAllowedValues Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObservableCollection<PropertyAllowedValueModel> AllowedValues { get; }
public:
property ObservableCollection<PropertyAllowedValueModel^>^ AllowedValues {
    ObservableCollection<PropertyAllowedValueModel^>^ get ();
}

Property Value

Type: ObservableCollectionPropertyAllowedValueModel
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription.Description Property

PropertyDescriptionDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; set; }
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription.DisabledStateToolTip Property

PropertyDescriptionDisabledStateToolTip Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string DisabledStateToolTip { get; set; }
public:
property String^ DisabledStateToolTip {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription.FieldType Property

PropertyDescriptionFieldType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string FieldType { get; set; }
public:
property String^ FieldType {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription.HelpId Property

PropertyDescriptionHelpId Property

HelpId used to find related help topics.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int HelpId { get; set; }
public:
property int HelpId {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription.HelpText Property

PropertyDescriptionHelpText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string HelpText { get; set; }
public:
property String^ HelpText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription.HelpUriString Property

PropertyDescriptionHelpUriString Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string HelpUriString { get; set; }
public:
property String^ HelpUriString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription.Id Property

PropertyDescriptionId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Id { get; set; }
public:
property int Id {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription.IsEditable Property

PropertyDescriptionIsEditable Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsEditable { get; set; }
public:
property bool IsEditable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription.IsReadOnly Property

PropertyDescriptionIsReadOnly Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsReadOnly { get; set; }
public:
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription.IsSystem Property

PropertyDescriptionIsSystem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsSystem { get; set; }
public:
property bool IsSystem {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription.LabelMargin Property

PropertyDescriptionLabelMargin Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Thickness LabelMargin { get; set; }
public:
property Thickness LabelMargin {
    Thickness get ();
    void set (Thickness value);
}

Property Value

Type: Thickness
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription.LocalizedDescription Property

PropertyDescriptionLocalizedDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string LocalizedDescription { get; }
public:
property String^ LocalizedDescription {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription.LocalizedDisabledStateToolTip Property

PropertyDescriptionLocalizedDisabledStateToolTip Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string LocalizedDisabledStateToolTip { get; }
public:
property String^ LocalizedDisabledStateToolTip {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription.LocalizedName Property

PropertyDescriptionLocalizedName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string LocalizedName { get; }
public:
property String^ LocalizedName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription.MaxValue Property

PropertyDescriptionMaxValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<double> MaxValue { get; set; }
public:
property Nullable<double> MaxValue {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: NullableDouble
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription.MinValue Property

PropertyDescriptionMinValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<double> MinValue { get; set; }
public:
property Nullable<double> MinValue {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: NullableDouble
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription.Name Property

PropertyDescriptionName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; set; }
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription.Order Property

PropertyDescriptionOrder Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Order { get; set; }
public:
property int Order {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription.ProhibitedValues Property

PropertyDescriptionProhibitedValues Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<KeyValuePair<string, string>> ProhibitedValues { get; set; }
public:
property List<KeyValuePair<String^, String^>>^ ProhibitedValues {
    List<KeyValuePair<String^, String^>>^ get ();
    void set (List<KeyValuePair<String^, String^>>^ value);
}

Property Value

Type: ListKeyValuePairString, String
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription.PropertyLabelVisibility Property

PropertyDescriptionPropertyLabelVisibility Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Visibility PropertyLabelVisibility { get; }
public:
property Visibility PropertyLabelVisibility {
    Visibility get ();
}

Property Value

Type: Visibility
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription.SystemName Property

PropertyDescriptionSystemName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SystemName { get; set; }
public:
property String^ SystemName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription.SystemType Property

PropertyDescriptionSystemType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type SystemType { get; set; }
public:
property Type^ SystemType {
    Type^ get ();
    void set (Type^ value);
}

Property Value

Type: Type
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription.TargetProperty Property

PropertyDescriptionTargetProperty Property

A transient (non-persistent) value, that is used for binding unit and editability of the internal property.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EditorProperty TargetProperty { get; set; }
public:
property EditorProperty^ TargetProperty {
    EditorProperty^ get ();
    void set (EditorProperty^ value);
}

Property Value

Type: EditorProperty
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription.UserData Property

PropertyDescriptionUserData Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object UserData { get; set; }
public:
property Object^ UserData {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription Methods

The PropertyDescription type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTabHeaderLocalizedName |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateLocalizedName |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription.GetTabHeaderLocalizedName Method

PropertyDescriptionGetTabHeaderLocalizedName Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string GetTabHeaderLocalizedName(
    IProperty property,
    string tabId
)
public:
String^ GetTabHeaderLocalizedName(
    IProperty^ property,
    String^ tabId
)

Parameters

property
Type: VisualComponents.Create3DIProperty
tabId
Type: SystemString

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PropertyDescription.GetTabHeaderLocalizedName(VisualComponents.Create3D.IProperty,System.String)"]

See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription.UpdateLocalizedName Method

PropertyDescriptionUpdateLocalizedName Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void UpdateLocalizedName(
    ref bool localizedNameChanged
)
public:
void UpdateLocalizedName(
    bool% localizedNameChanged
)

Parameters

localizedNameChanged
Type: SystemBoolean
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription Fields

The PropertyDescription type exposes the following members.

Fields
 | Name | Description
Public field | _localizedName |
Top
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyDescription._localizedName Field

PropertyDescription_localizedName Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string _localizedName
public:
String^ _localizedName

Field Value

Type: String
See Also

Reference

PropertyDescription Class
VisualComponents.UX.Shared Namespace


PropertyEditorView Class

Interaction logic for PropertyEditorView.xaml
PropertyEditorView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedUserControlOptimizedView
VisualComponents.UX.SharedPropertyEditorView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PropertyEditorView : UserControlOptimizedView,
    IComponentConnector
public ref class PropertyEditorView : public UserControlOptimizedView,
    IComponentConnector

The PropertyEditorView type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyEditorView | Initializes a new instance of the PropertyEditorView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | (Inherited from UserControlOptimizedView.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PropertyEditorView Constructor

Initializes a new instance of the PropertyEditorView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyEditorView()
public:
PropertyEditorView()
See Also

Reference

PropertyEditorView Class
VisualComponents.UX.Shared Namespace


PropertyEditorView Properties

The PropertyEditorView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

PropertyEditorView Class
VisualComponents.UX.Shared Namespace


PropertyEditorView Methods

The PropertyEditorView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | (Inherited from UserControlOptimizedView.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PropertyEditorView Class
VisualComponents.UX.Shared Namespace


PropertyEditorView.InitializeComponent Method

PropertyEditorViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

PropertyEditorView Class
VisualComponents.UX.Shared Namespace


PropertyEditorView Events

The PropertyEditorView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

PropertyEditorView Class
VisualComponents.UX.Shared Namespace


PropertyGridBehavior Class

Attached Behavior to control Non-Ribbon UI element visibility based on configuration setting.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.WindowsFreezable
System.Windows.Media.AnimationAnimatable
Behavior
BehaviorFrameworkElement
VisualComponents.UX.SharedPropertyGridBehavior

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PropertyGridBehavior : Behavior<FrameworkElement>
public ref class PropertyGridBehavior : public Behavior<FrameworkElement^>

The PropertyGridBehavior type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyGridBehavior | Initializes a new instance of the PropertyGridBehavior class
Top
Properties
 | Name | Description
Protected property | AssociatedObject | (Inherited from BehaviorFrameworkElement.)
Protected property | AssociatedType | (Inherited from Behavior.)
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Inherited from Animatable.)
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Top
Methods
 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | Attach | (Inherited from Behavior.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of this Animatable, making deep copies of this object's values. When copying this object's dependency properties, this method copies resource references and data bindings (but they might no longer resolve) but not animations or their current values. (Inherited from Animatable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | (Inherited from Behavior.)
Public method | Detach | (Inherited from Behavior.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to . (Inherited from Freezable.)
Protected method | FreezeCore | Makes this Animatable object unmodifiable or determines whether it can be made unmodifiable. (Inherited from Animatable.)
Public method | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Inherited from Animatable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttached | (Overrides Behavior.OnAttached.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnDetaching | (Overrides Behavior.OnDetaching.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
Events
 | Name | Description
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PropertyGridBehavior Constructor

Initializes a new instance of the PropertyGridBehavior class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyGridBehavior()
public:
PropertyGridBehavior()
See Also

Reference

PropertyGridBehavior Class
VisualComponents.UX.Shared Namespace


PropertyGridBehavior Properties

The PropertyGridBehavior type exposes the following members.

Properties
 | Name | Description
Protected property | AssociatedObject | (Inherited from BehaviorFrameworkElement.)
Protected property | AssociatedType | (Inherited from Behavior.)
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Inherited from Animatable.)
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Top
See Also

Reference

PropertyGridBehavior Class
VisualComponents.UX.Shared Namespace


PropertyGridBehavior Methods

The PropertyGridBehavior type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | Attach | (Inherited from Behavior.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of this Animatable, making deep copies of this object's values. When copying this object's dependency properties, this method copies resource references and data bindings (but they might no longer resolve) but not animations or their current values. (Inherited from Animatable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | (Inherited from Behavior.)
Public method | Detach | (Inherited from Behavior.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to . (Inherited from Freezable.)
Protected method | FreezeCore | Makes this Animatable object unmodifiable or determines whether it can be made unmodifiable. (Inherited from Animatable.)
Public method | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Inherited from Animatable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttached | (Overrides Behavior.OnAttached.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnDetaching | (Overrides Behavior.OnDetaching.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PropertyGridBehavior Class
VisualComponents.UX.Shared Namespace


PropertyGridBehavior.OnAttached Method

PropertyGridBehaviorOnAttached Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnAttached()
protected:
virtual void OnAttached() override
See Also

Reference

PropertyGridBehavior Class
VisualComponents.UX.Shared Namespace


PropertyGridBehavior.OnDetaching Method

PropertyGridBehaviorOnDetaching Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnDetaching()
protected:
virtual void OnDetaching() override
See Also

Reference

PropertyGridBehavior Class
VisualComponents.UX.Shared Namespace


PropertyGridBehavior Events

The PropertyGridBehavior type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Top
See Also

Reference

PropertyGridBehavior Class
VisualComponents.UX.Shared Namespace


PropertyHelper Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedPropertyHelper

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class PropertyHelper
[ExtensionAttribute]
public ref class PropertyHelper abstract sealed

The PropertyHelper type exposes the following members.

Methods
Name | Description
GetBindable |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PropertyHelper Methods

The PropertyHelper type exposes the following members.

Methods
Name | Description
GetBindable |
Top
See Also

Reference

PropertyHelper Class
VisualComponents.UX.Shared Namespace


PropertyHelper.GetBindable Method

PropertyHelperGetBindable Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Bindable GetBindable(
    this IProperty source
)
public:
[ExtensionAttribute]
static Bindable^ GetBindable(
    IProperty^ source
)

Parameters

source
Type: VisualComponents.Create3DIProperty

Return Value

Type: Bindable

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PropertyHelper.GetBindable(VisualComponents.Create3D.IProperty)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProperty. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PropertyHelper Class
VisualComponents.UX.Shared Namespace


PropertyLayout Class

PropertyLayout defines the user interface for a set of properties. Layout consists of a set of rows, divided in to columns. Columns can contain a set of layout elements (controls, rows, tabs).
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedPropertyLayout

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class PropertyLayout
public ref class PropertyLayout sealed

The PropertyLayout type exposes the following members.

Properties
 | Name | Description
Public property | Elements | Root elements of the layout.
Public property | Id | Unique Id for the property layout.
Public property | Properties | Property descriptions of properties edited in this layout.
 | SuspendLayoutInvalidation |
Public property | UseLegacyTabs |
Top
Methods
 | Name | Description
Public method | AssociatePropertiesToLayout(IListIProperty) | Binds a property in property layout to a property in property container.
Public method | AssociatePropertiesToLayout(IListIProperty, IListIProperty) | Binds a property in property layout to a property in property container.
Public method | DestroyControls |
Public method | DestroyLayout | Stops listening to PropertyContainerChanged, PropertyChanged, and
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindTargetProperty | Get target property from property
 | GenerateLayout(IListIProperty) |
 | GenerateLayout(IListIProperty, Boolean, UnitFormat, Boolean, IListIProperty) | Generates a layout for given set of properties.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReGenerateNeeded |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyLayoutInvalidated |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
Remarks
PropertyLayout is serializeable using DataContract serialization. It is possible to further edit a serialized layout using layout authoring tool, where you can add localization, customized controls and custom validation.
See Also

Reference

VisualComponents.UX.Shared Namespace


PropertyLayout Properties

The PropertyLayout type exposes the following members.

Properties
 | Name | Description
Public property | Elements | Root elements of the layout.
Public property | Id | Unique Id for the property layout.
Public property | Properties | Property descriptions of properties edited in this layout.
 | SuspendLayoutInvalidation |
Public property | UseLegacyTabs |
Top
See Also

Reference

PropertyLayout Class
VisualComponents.UX.Shared Namespace


PropertyLayout.Elements Property

PropertyLayoutElements Property

Root elements of the layout.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BindingList<LayoutElement> Elements { get; set; }
public:
property BindingList<LayoutElement^>^ Elements {
    BindingList<LayoutElement^>^ get ();
    void set (BindingList<LayoutElement^>^ value);
}

Property Value

Type: BindingListLayoutElement
See Also

Reference

PropertyLayout Class
VisualComponents.UX.Shared Namespace


PropertyLayout.Id Property

PropertyLayoutId Property

Unique Id for the property layout.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Id { get; set; }
public:
property int Id {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

PropertyLayout Class
VisualComponents.UX.Shared Namespace


PropertyLayout.Properties Property

PropertyLayoutProperties Property

Property descriptions of properties edited in this layout.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<PropertyDescription> Properties { get; set; }
public:
property List<PropertyDescription^>^ Properties {
    List<PropertyDescription^>^ get ();
    void set (List<PropertyDescription^>^ value);
}

Property Value

Type: ListPropertyDescription
See Also

Reference

PropertyLayout Class
VisualComponents.UX.Shared Namespace


PropertyLayout.SuspendLayoutInvalidation Property

PropertyLayoutSuspendLayoutInvalidation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool SuspendLayoutInvalidation { get; set; }
public:
static property bool SuspendLayoutInvalidation {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PropertyLayout Class
VisualComponents.UX.Shared Namespace


PropertyLayout.UseLegacyTabs Property

PropertyLayoutUseLegacyTabs Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool UseLegacyTabs { get; }
public:
property bool UseLegacyTabs {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

PropertyLayout Class
VisualComponents.UX.Shared Namespace


PropertyLayout Methods

The PropertyLayout type exposes the following members.

Methods
 | Name | Description
Public method | AssociatePropertiesToLayout(IListIProperty) | Binds a property in property layout to a property in property container.
Public method | AssociatePropertiesToLayout(IListIProperty, IListIProperty) | Binds a property in property layout to a property in property container.
Public method | DestroyControls |
Public method | DestroyLayout | Stops listening to PropertyContainerChanged, PropertyChanged, and
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindTargetProperty | Get target property from property
 | GenerateLayout(IListIProperty) |
 | GenerateLayout(IListIProperty, Boolean, UnitFormat, Boolean, IListIProperty) | Generates a layout for given set of properties.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReGenerateNeeded |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PropertyLayout Class
VisualComponents.UX.Shared Namespace


PropertyLayout.AssociatePropertiesToLayout Method

PropertyLayoutAssociatePropertiesToLayout Method

Overload List
 | Name | Description
Public method | AssociatePropertiesToLayout(IListIProperty) | Binds a property in property layout to a property in property container.
Public method | AssociatePropertiesToLayout(IListIProperty, IListIProperty) | Binds a property in property layout to a property in property container.
Top
See Also

Reference

PropertyLayout Class
VisualComponents.UX.Shared Namespace


PropertyLayout.AssociatePropertiesToLayout Method (IList(IProperty))

PropertyLayoutAssociatePropertiesToLayout Method (IListIProperty)

Binds a property in property layout to a property in property container.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void AssociatePropertiesToLayout(
    IList<IProperty> propertiesToAssociate
)
public:
void AssociatePropertiesToLayout(
    IList<IProperty^>^ propertiesToAssociate
)

Parameters

propertiesToAssociate
Type: System.Collections.GenericIListIProperty
See Also

Reference

PropertyLayout Class
AssociatePropertiesToLayout Overload
VisualComponents.UX.Shared Namespace


PropertyLayout.AssociatePropertiesToLayout Method (IList(IProperty), IList(IProperty))

PropertyLayoutAssociatePropertiesToLayout Method (IListIProperty, IListIProperty)

Binds a property in property layout to a property in property container.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void AssociatePropertiesToLayout(
    IList<IProperty> propertiesToAssociate,
    IList<IProperty> externalPropertiesToShow
)
public:
void AssociatePropertiesToLayout(
    IList<IProperty^>^ propertiesToAssociate,
    IList<IProperty^>^ externalPropertiesToShow
)

Parameters

propertiesToAssociate
Type: System.Collections.GenericIListIProperty
externalPropertiesToShow
Type: System.Collections.GenericIListIProperty
Remarks
This is used when property layout is deserialized, as it does not contain information about target property.
See Also

Reference

PropertyLayout Class
AssociatePropertiesToLayout Overload
VisualComponents.UX.Shared Namespace


PropertyLayout.DestroyControls Method

PropertyLayoutDestroyControls Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void DestroyControls(
    LayoutElement element
)
public:
void DestroyControls(
    LayoutElement^ element
)

Parameters

element
Type: VisualComponents.UX.SharedLayoutElement
See Also

Reference

PropertyLayout Class
VisualComponents.UX.Shared Namespace


PropertyLayout.DestroyLayout Method

PropertyLayoutDestroyLayout Method

Stops listening to PropertyContainerChanged, PropertyChanged, and

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void DestroyLayout()
public:
void DestroyLayout()
See Also

Reference

PropertyLayout Class
VisualComponents.UX.Shared Namespace


PropertyLayout.FindTargetProperty Method

PropertyLayoutFindTargetProperty Method

Get target property from property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public EditorProperty FindTargetProperty(
    IProperty p
)
public:
EditorProperty^ FindTargetProperty(
    IProperty^ p
)

Parameters

p
Type: VisualComponents.Create3DIProperty

Return Value

Type: EditorProperty

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PropertyLayout.FindTargetProperty(VisualComponents.Create3D.IProperty)"]

See Also

Reference

PropertyLayout Class
VisualComponents.UX.Shared Namespace


PropertyLayout.GenerateLayout Method

PropertyLayoutGenerateLayout Method

Overload List
Name | Description
GenerateLayout(IListIProperty) |
GenerateLayout(IListIProperty, Boolean, UnitFormat, Boolean, IListIProperty) | Generates a layout for given set of properties.
Top
See Also

Reference

PropertyLayout Class
VisualComponents.UX.Shared Namespace


PropertyLayout.GenerateLayout Method (IList(IProperty))

PropertyLayoutGenerateLayout Method (IListIProperty)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static PropertyLayout GenerateLayout(
    IList<IProperty> from
)
public:
static PropertyLayout^ GenerateLayout(
    IList<IProperty^>^ from
)

Parameters

from
Type: System.Collections.GenericIListIProperty

Return Value

Type: PropertyLayout

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PropertyLayout.GenerateLayout(System.Collections.Generic.IList{VisualComponents.Create3D.IProperty})"]

See Also

Reference

PropertyLayout Class
GenerateLayout Overload
VisualComponents.UX.Shared Namespace


PropertyLayout.GenerateLayout Method (IList(IProperty), Boolean, UnitFormat, Boolean, IList(IProperty))

PropertyLayoutGenerateLayout Method (IListIProperty, Boolean, UnitFormat, Boolean, IListIProperty)

Generates a layout for given set of properties.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static PropertyLayout GenerateLayout(
    IList<IProperty> from,
    bool forceShowTabs,
    UnitFormat unitFormat,
    bool autoSort,
    IList<IProperty> externalPropertiesToShow
)
public:
static PropertyLayout^ GenerateLayout(
    IList<IProperty^>^ from,
    bool forceShowTabs,
    UnitFormat unitFormat,
    bool autoSort,
    IList<IProperty^>^ externalPropertiesToShow
)

Parameters

from
Type: System.Collections.GenericIListIProperty
forceShowTabs
Type: SystemBoolean
unitFormat
Type: VisualComponents.UX.SharedUnitFormat
autoSort
Type: SystemBoolean
externalPropertiesToShow
Type: System.Collections.GenericIListIProperty

Return Value

Type: PropertyLayout

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PropertyLayout.GenerateLayout(System.Collections.Generic.IList{VisualComponents.Create3D.IProperty},System.Boolean,VisualComponents.UX.Shared.UnitFormat,System.Boolean,System.Collections.Generic.IList{VisualComponents.Create3D.IProperty})"]

Remarks
Default layout looks like: Row Column Property1 Property2 Property3 ....
See Also

Reference

PropertyLayout Class
GenerateLayout Overload
VisualComponents.UX.Shared Namespace


PropertyLayout.ReGenerateNeeded Method

PropertyLayoutReGenerateNeeded Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ReGenerateNeeded(
    List<IProperty> from
)
public:
bool ReGenerateNeeded(
    List<IProperty^>^ from
)

Parameters

from
Type: System.Collections.GenericListIProperty

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PropertyLayout.ReGenerateNeeded(System.Collections.Generic.List{VisualComponents.Create3D.IProperty})"]

See Also

Reference

PropertyLayout Class
VisualComponents.UX.Shared Namespace


PropertyLayout Events

The PropertyLayout type exposes the following members.

Events
 | Name | Description
Public event | PropertyLayoutInvalidated |
Top
See Also

Reference

PropertyLayout Class
VisualComponents.UX.Shared Namespace


PropertyLayout.PropertyLayoutInvalidated Event

PropertyLayoutPropertyLayoutInvalidated Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler PropertyLayoutInvalidated
public:
 event EventHandler^ PropertyLayoutInvalidated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

PropertyLayout Class
VisualComponents.UX.Shared Namespace


PropertyList Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedPropertyList

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PropertyList
public ref class PropertyList

The PropertyList type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyList | Initializes a new instance of the PropertyList class
Top
Properties
 | Name | Description
Public property | Children |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PropertyList Constructor

Initializes a new instance of the PropertyList class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyList(
    IListProperty property
)
public:
PropertyList(
    IListProperty^ property
)

Parameters

property
Type: VisualComponents.Create3DIListProperty
See Also

Reference

PropertyList Class
VisualComponents.UX.Shared Namespace


PropertyList Properties

The PropertyList type exposes the following members.

Properties
 | Name | Description
Public property | Children |
Top
See Also

Reference

PropertyList Class
VisualComponents.UX.Shared Namespace


PropertyList.Children Property

PropertyListChildren Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObservableCollection<IWrapper> Children { get; set; }
public:
property ObservableCollection<IWrapper^>^ Children {
    ObservableCollection<IWrapper^>^ get ();
    void set (ObservableCollection<IWrapper^>^ value);
}

Property Value

Type: ObservableCollectionIWrapper
See Also

Reference

PropertyList Class
VisualComponents.UX.Shared Namespace


PropertyList Methods

The PropertyList type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PropertyList Class
VisualComponents.UX.Shared Namespace


PropertyObjectEditorAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedPropertyObjectEditorAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class PropertyObjectEditorAction : IPropertyObjectEditorAction,
    ICommandPanelAction
public ref class PropertyObjectEditorAction sealed : IPropertyObjectEditorAction,
    ICommandPanelAction

The PropertyObjectEditorAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ActionPropertyContainer |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
Public property | TargetProperty |
Public property | Title |
Top
Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | StartAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PropertyObjectEditorAction Properties

The PropertyObjectEditorAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ActionPropertyContainer |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
Public property | TargetProperty |
Public property | Title |
Top
See Also

Reference

PropertyObjectEditorAction Class
VisualComponents.UX.Shared Namespace


PropertyObjectEditorAction.ActionFinished Property

PropertyObjectEditorActionActionFinished Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ActionFinished { get; set; }
public:
virtual property bool ActionFinished {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ICommandPanelActionActionFinished
See Also

Reference

PropertyObjectEditorAction Class
VisualComponents.UX.Shared Namespace


PropertyObjectEditorAction.ActionProperties Property

PropertyObjectEditorActionActionProperties Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<IProperty> ActionProperties { get; }
public:
virtual property List<IProperty^>^ ActionProperties {
    List<IProperty^>^ get () sealed;
}

Property Value

Type: ListIProperty

Implements

ICommandPanelActionActionProperties
See Also

Reference

PropertyObjectEditorAction Class
VisualComponents.UX.Shared Namespace


PropertyObjectEditorAction.ActionPropertyContainer Property

PropertyObjectEditorActionActionPropertyContainer Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IPropertyContainer ActionPropertyContainer { get; }
public:
virtual property IPropertyContainer^ ActionPropertyContainer {
    IPropertyContainer^ get () sealed;
}

Property Value

Type: IPropertyContainer

Implements

IPropertyObjectEditorActionActionPropertyContainer
See Also

Reference

PropertyObjectEditorAction Class
VisualComponents.UX.Shared Namespace


PropertyObjectEditorAction.ApplyButtonText Property

PropertyObjectEditorActionApplyButtonText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ApplyButtonText { get; }
public:
virtual property String^ ApplyButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionApplyButtonText
See Also

Reference

PropertyObjectEditorAction Class
VisualComponents.UX.Shared Namespace


PropertyObjectEditorAction.AssociatedModelId Property

PropertyObjectEditorActionAssociatedModelId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedModelId { get; }
public:
virtual property String^ AssociatedModelId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedModelId
See Also

Reference

PropertyObjectEditorAction Class
VisualComponents.UX.Shared Namespace


PropertyObjectEditorAction.AssociatedSiteId Property

PropertyObjectEditorActionAssociatedSiteId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedSiteId { get; }
public:
virtual property String^ AssociatedSiteId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedSiteId
See Also

Reference

PropertyObjectEditorAction Class
VisualComponents.UX.Shared Namespace


PropertyObjectEditorAction.CallingCommandName Property

PropertyObjectEditorActionCallingCommandName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CallingCommandName { get; }
public:
virtual property String^ CallingCommandName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCallingCommandName
See Also

Reference

PropertyObjectEditorAction Class
VisualComponents.UX.Shared Namespace


PropertyObjectEditorAction.CancelButtonText Property

PropertyObjectEditorActionCancelButtonText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CancelButtonText { get; }
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCancelButtonText
See Also

Reference

PropertyObjectEditorAction Class
VisualComponents.UX.Shared Namespace


PropertyObjectEditorAction.Description Property

PropertyObjectEditorActionDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; }
public:
virtual property String^ Description {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionDescription
See Also

Reference

PropertyObjectEditorAction Class
VisualComponents.UX.Shared Namespace


PropertyObjectEditorAction.ErrorMessage Property

PropertyObjectEditorActionErrorMessage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ErrorMessage { get; set; }
public:
virtual property String^ ErrorMessage {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionErrorMessage
See Also

Reference

PropertyObjectEditorAction Class
VisualComponents.UX.Shared Namespace


PropertyObjectEditorAction.TargetProperty Property

PropertyObjectEditorActionTargetProperty Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IComponentProperty TargetProperty { get; set; }
public:
virtual property IComponentProperty^ TargetProperty {
    IComponentProperty^ get () sealed;
    void set (IComponentProperty^ value) sealed;
}

Property Value

Type: IComponentProperty

Implements

IPropertyObjectEditorActionTargetProperty
See Also

Reference

PropertyObjectEditorAction Class
VisualComponents.UX.Shared Namespace


PropertyObjectEditorAction.Title Property

PropertyObjectEditorActionTitle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; }
public:
virtual property String^ Title {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionTitle
See Also

Reference

PropertyObjectEditorAction Class
VisualComponents.UX.Shared Namespace


PropertyObjectEditorAction Methods

The PropertyObjectEditorAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | StartAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PropertyObjectEditorAction Class
VisualComponents.UX.Shared Namespace


PropertyObjectEditorAction.ApplyAction Method

PropertyObjectEditorActionApplyAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ApplyAction()
public:
virtual bool ApplyAction() sealed

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PropertyObjectEditorAction.ApplyAction"]

Implements

ICommandPanelActionApplyAction
See Also

Reference

PropertyObjectEditorAction Class
VisualComponents.UX.Shared Namespace


PropertyObjectEditorAction.CancelAction Method

PropertyObjectEditorActionCancelAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CancelAction()
public:
virtual void CancelAction() sealed

Implements

ICommandPanelActionCancelAction
See Also

Reference

PropertyObjectEditorAction Class
VisualComponents.UX.Shared Namespace


PropertyObjectEditorAction.StartAction Method

PropertyObjectEditorActionStartAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    EventHandler<ResultCompletionEventArgs> completed = null
)
public:
virtual void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr
) sealed

Parameters

completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs

Implements

IPropertyObjectEditorActionStartAction(EventHandlerResultCompletionEventArgs)
ICommandPanelActionStartAction(EventHandlerResultCompletionEventArgs)
See Also

Reference

PropertyObjectEditorAction Class
VisualComponents.UX.Shared Namespace


PropertyOrderingHelper Class

Helper class to order IProperty instances.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedPropertyOrderingHelper

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PropertyOrderingHelper
public ref class PropertyOrderingHelper

The PropertyOrderingHelper type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyOrderingHelper | Initializes a new instance of the PropertyOrderingHelper class
Top
Methods
 | Name | Description
 | CompareProperty | Compares two instances of by first by checking flag followed by and finaly
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PropertyOrderingHelper Constructor

Initializes a new instance of the PropertyOrderingHelper class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyOrderingHelper()
public:
PropertyOrderingHelper()
See Also

Reference

PropertyOrderingHelper Class
VisualComponents.UX.Shared Namespace


PropertyOrderingHelper Methods

The PropertyOrderingHelper type exposes the following members.

Methods
 | Name | Description
 | CompareProperty | Compares two instances of by first by checking flag followed by and finaly
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PropertyOrderingHelper Class
VisualComponents.UX.Shared Namespace


PropertyOrderingHelper.CompareProperty Method

PropertyOrderingHelperCompareProperty Method

Compares two instances of by first by checking flag followed by and finaly

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int CompareProperty(
    IProperty x,
    IProperty y
)
public:
static int CompareProperty(
    IProperty^ x,
    IProperty^ y
)

Parameters

x
Type: VisualComponents.Create3DIProperty
IProperty object
y
Type: VisualComponents.Create3DIProperty
IProperty object

Return Value

Type: Int32
A signed number indicating the relative values of IProperty Greater than zero indicate x follows y. Less than zero indicate x procedes y. Zero indicate x and y are the same.
See Also

Reference

PropertyOrderingHelper Class
VisualComponents.UX.Shared Namespace
VisualComponents.Create3DIProperty
IPropertyIsInternal
IPropertyOrder
INamedName


PropertyTemplateSelector Class

Inheritance Hierarchy
SystemObject
System.Windows.ControlsDataTemplateSelector
VisualComponents.UX.SharedPropertyTemplateSelector

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PropertyTemplateSelector : DataTemplateSelector
public ref class PropertyTemplateSelector : public DataTemplateSelector

The PropertyTemplateSelector type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyTemplateSelector | Initializes a new instance of the PropertyTemplateSelector class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SelectTemplate | (Overrides DataTemplateSelectorSelectTemplate(Object, DependencyObject).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PropertyTemplateSelector Constructor

Initializes a new instance of the PropertyTemplateSelector class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyTemplateSelector()
public:
PropertyTemplateSelector()
See Also

Reference

PropertyTemplateSelector Class
VisualComponents.UX.Shared Namespace


PropertyTemplateSelector Methods

The PropertyTemplateSelector type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SelectTemplate | (Overrides DataTemplateSelectorSelectTemplate(Object, DependencyObject).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PropertyTemplateSelector Class
VisualComponents.UX.Shared Namespace


PropertyTemplateSelector.SelectTemplate Method

PropertyTemplateSelectorSelectTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override DataTemplate SelectTemplate(
    Object item,
    DependencyObject container
)
public:
virtual DataTemplate^ SelectTemplate(
    Object^ item,
    DependencyObject^ container
) override

Parameters

item
Type: SystemObject
container
Type: System.WindowsDependencyObject

Return Value

Type: DataTemplate

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PropertyTemplateSelector.SelectTemplate(System.Object,System.Windows.DependencyObject)"]

See Also

Reference

PropertyTemplateSelector Class
VisualComponents.UX.Shared Namespace


PropertyUnitEditorView Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
VisualComponents.UX.SharedPropertyUnitEditorView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PropertyUnitEditorView : ContentControl
public ref class PropertyUnitEditorView : public ContentControl

The PropertyUnitEditorView type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyUnitEditorView | Initializes a new instance of the PropertyUnitEditorView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUnitAvailable |
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | PropertySelectedUnit |
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UnitOptions |
Public property | UnitOptionsCollection |
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnValueChanged |
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs when the Value property changes.
Top
Fields
Name | Description
IsUnitAvailableProperty |
PropertySelectedUnitProperty |
UnitOptionsCollectionProperty |
UnitOptionsProperty |
ValueChangedEvent | Identifies the ValueChanged routed event.
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PropertyUnitEditorView Constructor

Initializes a new instance of the PropertyUnitEditorView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyUnitEditorView()
public:
PropertyUnitEditorView()
See Also

Reference

PropertyUnitEditorView Class
VisualComponents.UX.Shared Namespace


PropertyUnitEditorView Properties

The PropertyUnitEditorView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUnitAvailable |
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | PropertySelectedUnit |
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UnitOptions |
Public property | UnitOptionsCollection |
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

PropertyUnitEditorView Class
VisualComponents.UX.Shared Namespace


PropertyUnitEditorView.IsUnitAvailable Property

PropertyUnitEditorViewIsUnitAvailable Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsUnitAvailable { get; }
public:
property bool IsUnitAvailable {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

PropertyUnitEditorView Class
VisualComponents.UX.Shared Namespace


PropertyUnitEditorView.PropertySelectedUnit Property

PropertyUnitEditorViewPropertySelectedUnit Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IUnit PropertySelectedUnit { get; set; }
public:
property IUnit^ PropertySelectedUnit {
    IUnit^ get ();
    void set (IUnit^ value);
}

Property Value

Type: IUnit
See Also

Reference

PropertyUnitEditorView Class
VisualComponents.UX.Shared Namespace


PropertyUnitEditorView.UnitOptions Property

PropertyUnitEditorViewUnitOptions Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<IUnit> UnitOptions { get; set; }
public:
property ReadOnlyCollection<IUnit^>^ UnitOptions {
    ReadOnlyCollection<IUnit^>^ get ();
    void set (ReadOnlyCollection<IUnit^>^ value);
}

Property Value

Type: ReadOnlyCollectionIUnit
See Also

Reference

PropertyUnitEditorView Class
VisualComponents.UX.Shared Namespace


PropertyUnitEditorView.UnitOptionsCollection Property

PropertyUnitEditorViewUnitOptionsCollection Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObservableCollection<string> UnitOptionsCollection { get; }
public:
property ObservableCollection<String^>^ UnitOptionsCollection {
    ObservableCollection<String^>^ get ();
}

Property Value

Type: ObservableCollectionString
See Also

Reference

PropertyUnitEditorView Class
VisualComponents.UX.Shared Namespace


PropertyUnitEditorView Methods

The PropertyUnitEditorView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnValueChanged |
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PropertyUnitEditorView Class
VisualComponents.UX.Shared Namespace


PropertyUnitEditorView.OnApplyTemplate Method

PropertyUnitEditorViewOnApplyTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

PropertyUnitEditorView Class
VisualComponents.UX.Shared Namespace


PropertyUnitEditorView.OnValueChanged Method

PropertyUnitEditorViewOnValueChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void OnValueChanged(
    RoutedPropertyChangedEventArgs<ReadOnlyCollection<IUnit>> args
)
protected:
virtual void OnValueChanged(
    RoutedPropertyChangedEventArgs<ReadOnlyCollection<IUnit^>^>^ args
)

Parameters

args
Type: System.WindowsRoutedPropertyChangedEventArgsReadOnlyCollectionIUnit
See Also

Reference

PropertyUnitEditorView Class
VisualComponents.UX.Shared Namespace


PropertyUnitEditorView Events

The PropertyUnitEditorView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Public event | ValueChanged | Occurs when the Value property changes.
Top
See Also

Reference

PropertyUnitEditorView Class
VisualComponents.UX.Shared Namespace


PropertyUnitEditorView.ValueChanged Event

PropertyUnitEditorViewValueChanged Event

Occurs when the Value property changes.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event RoutedPropertyChangedEventHandler<ReadOnlyCollection<IUnit>> ValueChanged
public:
 event RoutedPropertyChangedEventHandler<ReadOnlyCollection<IUnit^>^>^ ValueChanged {
    void add (RoutedPropertyChangedEventHandler<ReadOnlyCollection<IUnit^>^>^ value);
    void remove (RoutedPropertyChangedEventHandler<ReadOnlyCollection<IUnit^>^>^ value);
}

Value

Type: System.WindowsRoutedPropertyChangedEventHandlerReadOnlyCollectionIUnit
See Also

Reference

PropertyUnitEditorView Class
VisualComponents.UX.Shared Namespace


PropertyUnitEditorView Fields

The PropertyUnitEditorView type exposes the following members.

Fields
Name | Description
IsUnitAvailableProperty |
PropertySelectedUnitProperty |
UnitOptionsCollectionProperty |
UnitOptionsProperty |
ValueChangedEvent | Identifies the ValueChanged routed event.
Top
See Also

Reference

PropertyUnitEditorView Class
VisualComponents.UX.Shared Namespace


PropertyUnitEditorView.IsUnitAvailableProperty Field

PropertyUnitEditorViewIsUnitAvailableProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsUnitAvailableProperty
public:
static initonly DependencyProperty^ IsUnitAvailableProperty

Field Value

Type: DependencyProperty
See Also

Reference

PropertyUnitEditorView Class
VisualComponents.UX.Shared Namespace


PropertyUnitEditorView.PropertySelectedUnitProperty Field

PropertyUnitEditorViewPropertySelectedUnitProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty PropertySelectedUnitProperty
public:
static initonly DependencyProperty^ PropertySelectedUnitProperty

Field Value

Type: DependencyProperty
See Also

Reference

PropertyUnitEditorView Class
VisualComponents.UX.Shared Namespace


PropertyUnitEditorView.UnitOptionsCollectionProperty Field

PropertyUnitEditorViewUnitOptionsCollectionProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty UnitOptionsCollectionProperty
public:
static initonly DependencyProperty^ UnitOptionsCollectionProperty

Field Value

Type: DependencyProperty
See Also

Reference

PropertyUnitEditorView Class
VisualComponents.UX.Shared Namespace


PropertyUnitEditorView.UnitOptionsProperty Field

PropertyUnitEditorViewUnitOptionsProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty UnitOptionsProperty
public:
static initonly DependencyProperty^ UnitOptionsProperty

Field Value

Type: DependencyProperty
See Also

Reference

PropertyUnitEditorView Class
VisualComponents.UX.Shared Namespace


PropertyUnitEditorView.ValueChangedEvent Field

PropertyUnitEditorViewValueChangedEvent Field

Identifies the ValueChanged routed event.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly RoutedEvent ValueChangedEvent
public:
static initonly RoutedEvent^ ValueChangedEvent

Field Value

Type: RoutedEvent
See Also

Reference

PropertyUnitEditorView Class
VisualComponents.UX.Shared Namespace


PythonActionItem Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.SharedBaseActionItem
VisualComponents.UX.SharedActionItem Boolean
VisualComponents.UX.SharedPythonActionItem
VisualComponents.UX.SharedPythonContextualRibbonTab
VisualComponents.UX.SharedPythonGalleryActionItem
VisualComponents.UX.SharedPythonGalleryItemActionItem
VisualComponents.UX.SharedPythonRibbonTab

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PythonActionItem : ActionItem<bool>
public ref class PythonActionItem : public ActionItem<bool>

The PythonActionItem type exposes the following members.

Constructors
 | Name | Description
Public method | PythonActionItem(String) | Initializes a new instance of the PythonActionItem class
Public method | PythonActionItem(String, SetupPythonActionMessage, String, Boolean, Boolean) | Initializes a new instance of ActionItem class.
Top
Properties
 | Name | Description
Public property | ActiveAction | Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this). (Inherited from BaseActionItem.)
Protected property | Application | (Inherited from BaseActionItem.)
Public property | AttachTo | (Inherited from BaseActionItem.)
Public property | ButtonMaxWidth | (Inherited from BaseActionItem.)
Public property | ButtonMinWidth | (Inherited from BaseActionItem.)
Public property | ButtonWidth | (Inherited from BaseActionItem.)
Public property | CanExecute | (Inherited from BaseActionItem.)
Protected property | canExecuteAction | Similar to canExecute. This is provided for Visual Basic compatibility. (Inherited from BaseActionItem.)
Public property | CollapseWhenDeactivated | (Inherited from BaseActionItem.)
Public property | CommandRegistry | This references is assigned by CommandRegistry on startup. (Inherited from BaseActionItem.)
Public property | Content | (Inherited from BaseActionItem.)
Public property | Context | (Inherited from BaseActionItem.)
Public property | ContextFilter | (Inherited from BaseActionItem.)
Public property | ControlType | (Inherited from BaseActionItem.)
Public property | Customization | (Inherited from BaseActionItem.)
Protected property | EventMng | Event aggregator (Inherited from BaseActionItem.)
Public property | Icon | (Inherited from BaseActionItem.)
Public property | IconName | (Inherited from BaseActionItem.)
Public property | Id | (Inherited from BaseActionItem.)
Public property | ImageSource | (Inherited from BaseActionItem.)
Public property | IsActivated | (Inherited from BaseActionItem.)
Public property | IsBackgroundVisible | (Inherited from BaseActionItem.)
Public property | IsChecked | IsChecked status
Public property | IsColoredIcon | (Inherited from BaseActionItem.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsQatCommonTool | (Inherited from BaseActionItem.)
Public property | IsToolNotInRibbon | (Inherited from BaseActionItem.)
Public property | Localization | (Inherited from BaseActionItem.)
Public property | RibbonId | (Inherited from BaseActionItem.)
Public property | SetupInfo |
Public property | SiteOrder | (Inherited from BaseActionItem.)
Protected property | SkipAbortWhenExecuted | If true, action will not abort currently executing action. (Inherited from BaseActionItem.)
Public property | Tag | (Inherited from BaseActionItem.)
Public property | ToolSize | (Inherited from BaseActionItem.)
Public property | ToolTipBookmark | (Inherited from BaseActionItem.)
Public property | ToolTipContent | (Inherited from BaseActionItem.)
Public property | ToolTipContentImage | (Inherited from BaseActionItem.)
Public property | ToolTipFooter | (Inherited from BaseActionItem.)
Public property | ToolTipFooterSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipFooterVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipHeader | (Inherited from BaseActionItem.)
Public property | ToolTipHeaderSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipMoreInfoUrl | (Inherited from BaseActionItem.)
Public property | ToolTipVisibility | (Inherited from BaseActionItem.)
Public property | UxConfig | (Inherited from BaseActionItem.)
Public property | UXSite |
Public property | Visibility | (Inherited from BaseActionItem.)
Top
Methods
 | Name | Description
Public method | AfterExecute | (Inherited from BaseActionItem.)
Public method | BeforeExecute | (Inherited from BaseActionItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute | Updates the value of CanExecute (Inherited from BaseActionItem.)
Public method | Execute | (Overrides ActionItemT1Execute.)
Public method | Execute(Boolean) | The action associated to the ActionItem (Overrides ActionItemT1Execute(T1).)
Public method | Execute(PropertyCollection) | (Inherited from ActionItemT1.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from ActionItemT1.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableForObject | (Inherited from BaseActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Overrides BaseActionItemIsAvailableInCurrentContextAndSite(String).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from BaseActionItem.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | OnImportsSatisfied | Overriding class should call baseclass implementation. (Inherited from BaseActionItem.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SetupBaseActionItem | (Inherited from BaseActionItem.)
Public method | SetupPythonActionItem |
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Protected method | StartAction | Shortcut for calling CommandRegistry.StartCommandPanelAction(this). (Inherited from BaseActionItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
Fields
 | Name | Description
Protected field | _getIconPathFromFile | (Inherited from BaseActionItem.)
Protected field | _isColoredIcon | (Inherited from BaseActionItem.)
Protected field | canExecute | Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called. (Inherited from BaseActionItem.)
Protected field | executeAction | (Inherited from ActionItemT1.)
Protected field | RequestedFeatures | Contains license features requested by the action item. This collection should be populated by the implementing class. (Inherited from BaseActionItem.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PythonActionItem Constructor

Overload List
 | Name | Description
Public method | PythonActionItem(String) | Initializes a new instance of the PythonActionItem class
Public method | PythonActionItem(String, SetupPythonActionMessage, String, Boolean, Boolean) | Initializes a new instance of ActionItem class.
Top
See Also

Reference

PythonActionItem Class
VisualComponents.UX.Shared Namespace


PythonActionItem Constructor (String)

Initializes a new instance of the PythonActionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PythonActionItem(
    string id
)
public:
PythonActionItem(
    String^ id
)

Parameters

id
Type: SystemString
See Also

Reference

PythonActionItem Class
PythonActionItem Overload
VisualComponents.UX.Shared Namespace


PythonActionItem Constructor (String, SetupPythonActionMessage, String, Boolean, Boolean)

Initializes a new instance of ActionItem class.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PythonActionItem(
    string id,
    SetupPythonActionMessage message,
    string controlType = "ButtonTool",
    bool getIconPathFromFile = true,
    bool isColoredIcon = true
)
public:
PythonActionItem(
    String^ id,
    SetupPythonActionMessage^ message,
    String^ controlType = L"ButtonTool",
    bool getIconPathFromFile = true,
    bool isColoredIcon = true
)

Parameters

id
Type: SystemString
message
Type: VisualComponents.Create3DSetupPythonActionMessage
controlType (Optional)
Type: SystemString
getIconPathFromFile (Optional)
Type: SystemBoolean
indicator of using default icon path
isColoredIcon (Optional)
Type: SystemBoolean
See Also

Reference

PythonActionItem Class
PythonActionItem Overload
VisualComponents.UX.Shared Namespace


PythonActionItem Properties

The PythonActionItem type exposes the following members.

Properties
 | Name | Description
Public property | ActiveAction | Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this). (Inherited from BaseActionItem.)
Protected property | Application | (Inherited from BaseActionItem.)
Public property | AttachTo | (Inherited from BaseActionItem.)
Public property | ButtonMaxWidth | (Inherited from BaseActionItem.)
Public property | ButtonMinWidth | (Inherited from BaseActionItem.)
Public property | ButtonWidth | (Inherited from BaseActionItem.)
Public property | CanExecute | (Inherited from BaseActionItem.)
Protected property | canExecuteAction | Similar to canExecute. This is provided for Visual Basic compatibility. (Inherited from BaseActionItem.)
Public property | CollapseWhenDeactivated | (Inherited from BaseActionItem.)
Public property | CommandRegistry | This references is assigned by CommandRegistry on startup. (Inherited from BaseActionItem.)
Public property | Content | (Inherited from BaseActionItem.)
Public property | Context | (Inherited from BaseActionItem.)
Public property | ContextFilter | (Inherited from BaseActionItem.)
Public property | ControlType | (Inherited from BaseActionItem.)
Public property | Customization | (Inherited from BaseActionItem.)
Protected property | EventMng | Event aggregator (Inherited from BaseActionItem.)
Public property | Icon | (Inherited from BaseActionItem.)
Public property | IconName | (Inherited from BaseActionItem.)
Public property | Id | (Inherited from BaseActionItem.)
Public property | ImageSource | (Inherited from BaseActionItem.)
Public property | IsActivated | (Inherited from BaseActionItem.)
Public property | IsBackgroundVisible | (Inherited from BaseActionItem.)
Public property | IsChecked | IsChecked status
Public property | IsColoredIcon | (Inherited from BaseActionItem.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsQatCommonTool | (Inherited from BaseActionItem.)
Public property | IsToolNotInRibbon | (Inherited from BaseActionItem.)
Public property | Localization | (Inherited from BaseActionItem.)
Public property | RibbonId | (Inherited from BaseActionItem.)
Public property | SetupInfo |
Public property | SiteOrder | (Inherited from BaseActionItem.)
Protected property | SkipAbortWhenExecuted | If true, action will not abort currently executing action. (Inherited from BaseActionItem.)
Public property | Tag | (Inherited from BaseActionItem.)
Public property | ToolSize | (Inherited from BaseActionItem.)
Public property | ToolTipBookmark | (Inherited from BaseActionItem.)
Public property | ToolTipContent | (Inherited from BaseActionItem.)
Public property | ToolTipContentImage | (Inherited from BaseActionItem.)
Public property | ToolTipFooter | (Inherited from BaseActionItem.)
Public property | ToolTipFooterSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipFooterVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipHeader | (Inherited from BaseActionItem.)
Public property | ToolTipHeaderSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipMoreInfoUrl | (Inherited from BaseActionItem.)
Public property | ToolTipVisibility | (Inherited from BaseActionItem.)
Public property | UxConfig | (Inherited from BaseActionItem.)
Public property | UXSite |
Public property | Visibility | (Inherited from BaseActionItem.)
Top
See Also

Reference

PythonActionItem Class
VisualComponents.UX.Shared Namespace


PythonActionItem.IsChecked Property

PythonActionItemIsChecked Property

IsChecked status

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsChecked { get; }
public:
property bool IsChecked {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

PythonActionItem Class
VisualComponents.UX.Shared Namespace


PythonActionItem.SetupInfo Property

PythonActionItemSetupInfo Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetupPythonActionMessage SetupInfo { get; protected set; }
public:
property SetupPythonActionMessage^ SetupInfo {
    SetupPythonActionMessage^ get ();
    protected: void set (SetupPythonActionMessage^ value);
}

Property Value

Type: SetupPythonActionMessage
See Also

Reference

PythonActionItem Class
VisualComponents.UX.Shared Namespace


PythonActionItem.UXSite Property

PythonActionItemUXSite Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string UXSite { get; }
public:
property String^ UXSite {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

PythonActionItem Class
VisualComponents.UX.Shared Namespace


PythonActionItem Methods

The PythonActionItem type exposes the following members.

Methods
 | Name | Description
Public method | AfterExecute | (Inherited from BaseActionItem.)
Public method | BeforeExecute | (Inherited from BaseActionItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute | Updates the value of CanExecute (Inherited from BaseActionItem.)
Public method | Execute | (Overrides ActionItemT1Execute.)
Public method | Execute(Boolean) | The action associated to the ActionItem (Overrides ActionItemT1Execute(T1).)
Public method | Execute(PropertyCollection) | (Inherited from ActionItemT1.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from ActionItemT1.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableForObject | (Inherited from BaseActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Overrides BaseActionItemIsAvailableInCurrentContextAndSite(String).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from BaseActionItem.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | OnImportsSatisfied | Overriding class should call baseclass implementation. (Inherited from BaseActionItem.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SetupBaseActionItem | (Inherited from BaseActionItem.)
Public method | SetupPythonActionItem |
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Protected method | StartAction | Shortcut for calling CommandRegistry.StartCommandPanelAction(this). (Inherited from BaseActionItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PythonActionItem Class
VisualComponents.UX.Shared Namespace


PythonActionItem.Execute Method

PythonActionItemExecute Method

Overload List
 | Name | Description
Public method | Execute | (Overrides ActionItemT1Execute.)
Public method | Execute(Boolean) | The action associated to the ActionItem (Overrides ActionItemT1Execute(T1).)
Public method | Execute(PropertyCollection) | (Inherited from ActionItemT1.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from ActionItemT1.)
Top
See Also

Reference

PythonActionItem Class
VisualComponents.UX.Shared Namespace


PythonActionItem.Execute Method

PythonActionItemExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Execute()
public:
virtual void Execute() override

Implements

IActionItemExecute
See Also

Reference

PythonActionItem Class
Execute Overload
VisualComponents.UX.Shared Namespace


PythonActionItem.Execute Method (Boolean)

PythonActionItemExecute Method (Boolean)

The action associated to the ActionItem

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Execute(
    bool doStart
)
public:
virtual void Execute(
    bool doStart
) override

Parameters

doStart
Type: SystemBoolean
See Also

Reference

PythonActionItem Class
Execute Overload
VisualComponents.UX.Shared Namespace


PythonActionItem.IsAvailableInCurrentContextAndSite Method

PythonActionItemIsAvailableInCurrentContextAndSite Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool IsAvailableInCurrentContextAndSite(
    string uxsiteId
)
public:
virtual bool IsAvailableInCurrentContextAndSite(
    String^ uxsiteId
) override

Parameters

uxsiteId
Type: SystemString

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PythonActionItem.IsAvailableInCurrentContextAndSite(System.String)"]

Implements

IActionItemIsAvailableInCurrentContextAndSite(String)
See Also

Reference

PythonActionItem Class
VisualComponents.UX.Shared Namespace


PythonActionItem.SetupPythonActionItem Method

PythonActionItemSetupPythonActionItem Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetupPythonActionItem(
    SetupPythonActionMessage message,
    string controlType = "ButtonTool",
    bool getIconPathFromFile = true,
    bool isColoredIcon = true
)
public:
void SetupPythonActionItem(
    SetupPythonActionMessage^ message,
    String^ controlType = L"ButtonTool",
    bool getIconPathFromFile = true,
    bool isColoredIcon = true
)

Parameters

message
Type: VisualComponents.Create3DSetupPythonActionMessage
controlType (Optional)
Type: SystemString
getIconPathFromFile (Optional)
Type: SystemBoolean
isColoredIcon (Optional)
Type: SystemBoolean
See Also

Reference

PythonActionItem Class
VisualComponents.UX.Shared Namespace


PythonActionItem Events

The PythonActionItem type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
See Also

Reference

PythonActionItem Class
VisualComponents.UX.Shared Namespace


PythonActionItem Fields

The PythonActionItem type exposes the following members.

Fields
 | Name | Description
Protected field | _getIconPathFromFile | (Inherited from BaseActionItem.)
Protected field | _isColoredIcon | (Inherited from BaseActionItem.)
Protected field | canExecute | Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called. (Inherited from BaseActionItem.)
Protected field | executeAction | (Inherited from ActionItemT1.)
Protected field | RequestedFeatures | Contains license features requested by the action item. This collection should be populated by the implementing class. (Inherited from BaseActionItem.)
Top
See Also

Reference

PythonActionItem Class
VisualComponents.UX.Shared Namespace


PythonAttributeEnumType Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum PythonAttributeEnumType
public enum class PythonAttributeEnumType
Members
Member name | Value | Description
Method | 0 |
Event | 1 |
Property | 2 |
Unknown | 3 |
See Also

Reference

VisualComponents.UX.Shared Namespace


PythonAttributeInformation Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedPythonAttributeInformation

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PythonAttributeInformation
public ref class PythonAttributeInformation

The PythonAttributeInformation type exposes the following members.

Constructors
 | Name | Description
Public method | PythonAttributeInformation | Initializes a new instance of the PythonAttributeInformation class
Top
Properties
 | Name | Description
Public property | Access |
Public property | AttributeType |
Public property | Description |
Public property | Parameters |
Public property | PlainInfo |
Public property | Type |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PythonAttributeInformation Constructor

Initializes a new instance of the PythonAttributeInformation class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PythonAttributeInformation(
    string type,
    PythonAttributeEnumType attributeType
)
public:
PythonAttributeInformation(
    String^ type,
    PythonAttributeEnumType attributeType
)

Parameters

type
Type: SystemString
attributeType
Type: VisualComponents.UX.SharedPythonAttributeEnumType
See Also

Reference

PythonAttributeInformation Class
VisualComponents.UX.Shared Namespace


PythonAttributeInformation Properties

The PythonAttributeInformation type exposes the following members.

Properties
 | Name | Description
Public property | Access |
Public property | AttributeType |
Public property | Description |
Public property | Parameters |
Public property | PlainInfo |
Public property | Type |
Top
See Also

Reference

PythonAttributeInformation Class
VisualComponents.UX.Shared Namespace


PythonAttributeInformation.Access Property

PythonAttributeInformationAccess Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Access { get; set; }
public:
property String^ Access {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PythonAttributeInformation Class
VisualComponents.UX.Shared Namespace


PythonAttributeInformation.AttributeType Property

PythonAttributeInformationAttributeType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PythonAttributeEnumType AttributeType { get; set; }
public:
property PythonAttributeEnumType AttributeType {
    PythonAttributeEnumType get ();
    void set (PythonAttributeEnumType value);
}

Property Value

Type: PythonAttributeEnumType
See Also

Reference

PythonAttributeInformation Class
VisualComponents.UX.Shared Namespace


PythonAttributeInformation.Description Property

PythonAttributeInformationDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; set; }
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PythonAttributeInformation Class
VisualComponents.UX.Shared Namespace


PythonAttributeInformation.Parameters Property

PythonAttributeInformationParameters Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Parameters { get; set; }
public:
property String^ Parameters {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PythonAttributeInformation Class
VisualComponents.UX.Shared Namespace


PythonAttributeInformation.PlainInfo Property

PythonAttributeInformationPlainInfo Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string PlainInfo { get; }
public:
property String^ PlainInfo {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

PythonAttributeInformation Class
VisualComponents.UX.Shared Namespace


PythonAttributeInformation.Type Property

PythonAttributeInformationType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Type { get; set; }
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PythonAttributeInformation Class
VisualComponents.UX.Shared Namespace


PythonAttributeInformation Methods

The PythonAttributeInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PythonAttributeInformation Class
VisualComponents.UX.Shared Namespace


PythonClassInfo Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedPythonClassInfo

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PythonClassInfo
public ref class PythonClassInfo

The PythonClassInfo type exposes the following members.

Constructors
 | Name | Description
Public method | PythonClassInfo | Initializes a new instance of the PythonClassInfo class
Top
Properties
 | Name | Description
Public property | Events |
Public property | Methods |
Public property | Name |
Public property | Parents |
Public property | Properties |
Top
Methods
 | Name | Description
Public method | AddParent |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllEvents |
Public method | GetAllMethods |
Public method | GetAllProperties |
Public method | GetAttributeInfo |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetReturnType |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasSuggestions |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PythonClassInfo Constructor

Initializes a new instance of the PythonClassInfo class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PythonClassInfo(
    string name
)
public:
PythonClassInfo(
    String^ name
)

Parameters

name
Type: SystemString
See Also

Reference

PythonClassInfo Class
VisualComponents.UX.Shared Namespace


PythonClassInfo Properties

The PythonClassInfo type exposes the following members.

Properties
 | Name | Description
Public property | Events |
Public property | Methods |
Public property | Name |
Public property | Parents |
Public property | Properties |
Top
See Also

Reference

PythonClassInfo Class
VisualComponents.UX.Shared Namespace


PythonClassInfo.Events Property

PythonClassInfoEvents Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Dictionary<string, PythonAttributeInformation> Events { get; set; }
public:
property Dictionary<String^, PythonAttributeInformation^>^ Events {
    Dictionary<String^, PythonAttributeInformation^>^ get ();
    void set (Dictionary<String^, PythonAttributeInformation^>^ value);
}

Property Value

Type: DictionaryString, PythonAttributeInformation
See Also

Reference

PythonClassInfo Class
VisualComponents.UX.Shared Namespace


PythonClassInfo.Methods Property

PythonClassInfoMethods Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Dictionary<string, PythonAttributeInformation> Methods { get; set; }
public:
property Dictionary<String^, PythonAttributeInformation^>^ Methods {
    Dictionary<String^, PythonAttributeInformation^>^ get ();
    void set (Dictionary<String^, PythonAttributeInformation^>^ value);
}

Property Value

Type: DictionaryString, PythonAttributeInformation
See Also

Reference

PythonClassInfo Class
VisualComponents.UX.Shared Namespace


PythonClassInfo.Name Property

PythonClassInfoName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; }
public:
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

PythonClassInfo Class
VisualComponents.UX.Shared Namespace


PythonClassInfo.Parents Property

PythonClassInfoParents Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Parents { get; }
public:
property String^ Parents {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

PythonClassInfo Class
VisualComponents.UX.Shared Namespace


PythonClassInfo.Properties Property

PythonClassInfoProperties Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Dictionary<string, PythonAttributeInformation> Properties { get; set; }
public:
property Dictionary<String^, PythonAttributeInformation^>^ Properties {
    Dictionary<String^, PythonAttributeInformation^>^ get ();
    void set (Dictionary<String^, PythonAttributeInformation^>^ value);
}

Property Value

Type: DictionaryString, PythonAttributeInformation
See Also

Reference

PythonClassInfo Class
VisualComponents.UX.Shared Namespace


PythonClassInfo Methods

The PythonClassInfo type exposes the following members.

Methods
 | Name | Description
Public method | AddParent |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllEvents |
Public method | GetAllMethods |
Public method | GetAllProperties |
Public method | GetAttributeInfo |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetReturnType |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasSuggestions |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PythonClassInfo Class
VisualComponents.UX.Shared Namespace


PythonClassInfo.AddParent Method

PythonClassInfoAddParent Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void AddParent(
    PythonClassInfo parent
)
public:
void AddParent(
    PythonClassInfo^ parent
)

Parameters

parent
Type: VisualComponents.UX.SharedPythonClassInfo
See Also

Reference

PythonClassInfo Class
VisualComponents.UX.Shared Namespace


PythonClassInfo.GetAllEvents Method

PythonClassInfoGetAllEvents Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<string> GetAllEvents()
public:
List<String^>^ GetAllEvents()

Return Value

Type: ListString

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PythonClassInfo.GetAllEvents"]

See Also

Reference

PythonClassInfo Class
VisualComponents.UX.Shared Namespace


PythonClassInfo.GetAllMethods Method

PythonClassInfoGetAllMethods Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<string> GetAllMethods()
public:
List<String^>^ GetAllMethods()

Return Value

Type: ListString

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PythonClassInfo.GetAllMethods"]

See Also

Reference

PythonClassInfo Class
VisualComponents.UX.Shared Namespace


PythonClassInfo.GetAllProperties Method

PythonClassInfoGetAllProperties Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<string> GetAllProperties()
public:
List<String^>^ GetAllProperties()

Return Value

Type: ListString

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PythonClassInfo.GetAllProperties"]

See Also

Reference

PythonClassInfo Class
VisualComponents.UX.Shared Namespace


PythonClassInfo.GetAttributeInfo Method

PythonClassInfoGetAttributeInfo Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PythonAttributeInformation GetAttributeInfo(
    string attr
)
public:
PythonAttributeInformation^ GetAttributeInfo(
    String^ attr
)

Parameters

attr
Type: SystemString

Return Value

Type: PythonAttributeInformation

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PythonClassInfo.GetAttributeInfo(System.String)"]

See Also

Reference

PythonClassInfo Class
VisualComponents.UX.Shared Namespace


PythonClassInfo.GetReturnType Method

PythonClassInfoGetReturnType Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string GetReturnType(
    string attr
)
public:
String^ GetReturnType(
    String^ attr
)

Parameters

attr
Type: SystemString

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PythonClassInfo.GetReturnType(System.String)"]

See Also

Reference

PythonClassInfo Class
VisualComponents.UX.Shared Namespace


PythonClassInfo.HasSuggestions Method

PythonClassInfoHasSuggestions Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HasSuggestions()
public:
bool HasSuggestions()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PythonClassInfo.HasSuggestions"]

See Also

Reference

PythonClassInfo Class
VisualComponents.UX.Shared Namespace


PythonContextualRibbonTab Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.SharedBaseActionItem
VisualComponents.UX.SharedActionItem Boolean
VisualComponents.UX.SharedPythonActionItem
VisualComponents.UX.SharedPythonContextualRibbonTab

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PythonContextualRibbonTab : PythonActionItem,
    IContextualTabGroup
public ref class PythonContextualRibbonTab : public PythonActionItem,
    IContextualTabGroup

The PythonContextualRibbonTab type exposes the following members.

Constructors
 | Name | Description
Public method | PythonContextualRibbonTab | Initializes a new instance of the PythonContextualRibbonTab class
Top
Properties
 | Name | Description
Public property | ActiveAction | Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this). (Inherited from BaseActionItem.)
Protected property | Application | (Inherited from BaseActionItem.)
Public property | AttachTo | (Inherited from BaseActionItem.)
Public property | BaseBackColor |
Public property | ButtonMaxWidth | (Inherited from BaseActionItem.)
Public property | ButtonMinWidth | (Inherited from BaseActionItem.)
Public property | ButtonWidth | (Inherited from BaseActionItem.)
Public property | CanExecute | (Inherited from BaseActionItem.)
Protected property | canExecuteAction | Similar to canExecute. This is provided for Visual Basic compatibility. (Inherited from BaseActionItem.)
Public property | Caption |
Public property | CollapseWhenDeactivated | (Inherited from BaseActionItem.)
Public property | CommandRegistry | This references is assigned by CommandRegistry on startup. (Inherited from BaseActionItem.)
Public property | Content | (Inherited from BaseActionItem.)
Public property | Context | (Inherited from BaseActionItem.)
Public property | ContextFilter | (Inherited from BaseActionItem.)
Public property | ControlType | (Inherited from BaseActionItem.)
Public property | Customization | (Inherited from BaseActionItem.)
Protected property | EventMng | Event aggregator (Inherited from BaseActionItem.)
Public property | Icon | (Inherited from BaseActionItem.)
Public property | IconName | (Inherited from BaseActionItem.)
Public property | Id | (Inherited from BaseActionItem.)
Public property | IgContextualTabGroup |
Public property | ImageSource | (Inherited from BaseActionItem.)
Public property | IsActivated | (Inherited from BaseActionItem.)
Public property | IsBackgroundVisible | (Inherited from BaseActionItem.)
Public property | IsChecked | IsChecked status (Inherited from PythonActionItem.)
Public property | IsColoredIcon | (Inherited from BaseActionItem.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsQatCommonTool | (Inherited from BaseActionItem.)
Public property | IsToolNotInRibbon | (Inherited from BaseActionItem.)
Public property | IsVisible |
Public property | Key |
Public property | Localization | (Inherited from BaseActionItem.)
Public property | RibbonId | (Inherited from BaseActionItem.)
Public property | SetupInfo | (Inherited from PythonActionItem.)
Public property | SiteOrder | (Inherited from BaseActionItem.)
Protected property | SkipAbortWhenExecuted | If true, action will not abort currently executing action. (Inherited from BaseActionItem.)
Public property | Tag | (Inherited from BaseActionItem.)
Public property | ToolSize | (Inherited from BaseActionItem.)
Public property | ToolTipBookmark | (Inherited from BaseActionItem.)
Public property | ToolTipContent | (Inherited from BaseActionItem.)
Public property | ToolTipContentImage | (Inherited from BaseActionItem.)
Public property | ToolTipFooter | (Inherited from BaseActionItem.)
Public property | ToolTipFooterSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipFooterVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipHeader | (Inherited from BaseActionItem.)
Public property | ToolTipHeaderSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipMoreInfoUrl | (Inherited from BaseActionItem.)
Public property | ToolTipVisibility | (Inherited from BaseActionItem.)
Public property | UxConfig | (Inherited from BaseActionItem.)
Public property | UXSite | (Inherited from PythonActionItem.)
Public property | Visibility | (Inherited from BaseActionItem.)
Top
Methods
 | Name | Description
Public method | AfterExecute | (Inherited from BaseActionItem.)
Public method | BeforeExecute | (Inherited from BaseActionItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute | Updates the value of CanExecute (Inherited from BaseActionItem.)
Public method | Execute | (Inherited from PythonActionItem.)
Public method | Execute(Boolean) | The action associated to the ActionItem (Inherited from PythonActionItem.)
Public method | Execute(PropertyCollection) | (Inherited from ActionItemT1.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from ActionItemT1.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableForObject | (Inherited from BaseActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from PythonActionItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from BaseActionItem.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | OnImportsSatisfied | Overriding class should call baseclass implementation. (Inherited from BaseActionItem.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SetupBaseActionItem | (Inherited from BaseActionItem.)
Public method | SetupPythonActionItem | (Inherited from PythonActionItem.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Protected method | StartAction | Shortcut for calling CommandRegistry.StartCommandPanelAction(this). (Inherited from BaseActionItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
Fields
 | Name | Description
Protected field | _getIconPathFromFile | (Inherited from BaseActionItem.)
Protected field | _isColoredIcon | (Inherited from BaseActionItem.)
Protected field | canExecute | Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called. (Inherited from BaseActionItem.)
Protected field | executeAction | (Inherited from ActionItemT1.)
Protected field | RequestedFeatures | Contains license features requested by the action item. This collection should be populated by the implementing class. (Inherited from BaseActionItem.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PythonContextualRibbonTab Constructor

Initializes a new instance of the PythonContextualRibbonTab class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PythonContextualRibbonTab(
    string id,
    SetupPythonActionMessage message,
    string controlType = "GalleryMenuToolItem",
    bool getIconPathFromFile = true,
    bool isColoredIcon = true
)
public:
PythonContextualRibbonTab(
    String^ id,
    SetupPythonActionMessage^ message,
    String^ controlType = L"GalleryMenuToolItem",
    bool getIconPathFromFile = true,
    bool isColoredIcon = true
)

Parameters

id
Type: SystemString
message
Type: VisualComponents.Create3DSetupPythonActionMessage
controlType (Optional)
Type: SystemString
getIconPathFromFile (Optional)
Type: SystemBoolean
isColoredIcon (Optional)
Type: SystemBoolean
See Also

Reference

PythonContextualRibbonTab Class
VisualComponents.UX.Shared Namespace


PythonContextualRibbonTab Properties

The PythonContextualRibbonTab type exposes the following members.

Properties
 | Name | Description
Public property | ActiveAction | Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this). (Inherited from BaseActionItem.)
Protected property | Application | (Inherited from BaseActionItem.)
Public property | AttachTo | (Inherited from BaseActionItem.)
Public property | BaseBackColor |
Public property | ButtonMaxWidth | (Inherited from BaseActionItem.)
Public property | ButtonMinWidth | (Inherited from BaseActionItem.)
Public property | ButtonWidth | (Inherited from BaseActionItem.)
Public property | CanExecute | (Inherited from BaseActionItem.)
Protected property | canExecuteAction | Similar to canExecute. This is provided for Visual Basic compatibility. (Inherited from BaseActionItem.)
Public property | Caption |
Public property | CollapseWhenDeactivated | (Inherited from BaseActionItem.)
Public property | CommandRegistry | This references is assigned by CommandRegistry on startup. (Inherited from BaseActionItem.)
Public property | Content | (Inherited from BaseActionItem.)
Public property | Context | (Inherited from BaseActionItem.)
Public property | ContextFilter | (Inherited from BaseActionItem.)
Public property | ControlType | (Inherited from BaseActionItem.)
Public property | Customization | (Inherited from BaseActionItem.)
Protected property | EventMng | Event aggregator (Inherited from BaseActionItem.)
Public property | Icon | (Inherited from BaseActionItem.)
Public property | IconName | (Inherited from BaseActionItem.)
Public property | Id | (Inherited from BaseActionItem.)
Public property | IgContextualTabGroup |
Public property | ImageSource | (Inherited from BaseActionItem.)
Public property | IsActivated | (Inherited from BaseActionItem.)
Public property | IsBackgroundVisible | (Inherited from BaseActionItem.)
Public property | IsChecked | IsChecked status (Inherited from PythonActionItem.)
Public property | IsColoredIcon | (Inherited from BaseActionItem.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsQatCommonTool | (Inherited from BaseActionItem.)
Public property | IsToolNotInRibbon | (Inherited from BaseActionItem.)
Public property | IsVisible |
Public property | Key |
Public property | Localization | (Inherited from BaseActionItem.)
Public property | RibbonId | (Inherited from BaseActionItem.)
Public property | SetupInfo | (Inherited from PythonActionItem.)
Public property | SiteOrder | (Inherited from BaseActionItem.)
Protected property | SkipAbortWhenExecuted | If true, action will not abort currently executing action. (Inherited from BaseActionItem.)
Public property | Tag | (Inherited from BaseActionItem.)
Public property | ToolSize | (Inherited from BaseActionItem.)
Public property | ToolTipBookmark | (Inherited from BaseActionItem.)
Public property | ToolTipContent | (Inherited from BaseActionItem.)
Public property | ToolTipContentImage | (Inherited from BaseActionItem.)
Public property | ToolTipFooter | (Inherited from BaseActionItem.)
Public property | ToolTipFooterSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipFooterVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipHeader | (Inherited from BaseActionItem.)
Public property | ToolTipHeaderSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipMoreInfoUrl | (Inherited from BaseActionItem.)
Public property | ToolTipVisibility | (Inherited from BaseActionItem.)
Public property | UxConfig | (Inherited from BaseActionItem.)
Public property | UXSite | (Inherited from PythonActionItem.)
Public property | Visibility | (Inherited from BaseActionItem.)
Top
See Also

Reference

PythonContextualRibbonTab Class
VisualComponents.UX.Shared Namespace


PythonContextualRibbonTab.BaseBackColor Property

PythonContextualRibbonTabBaseBackColor Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<Color> BaseBackColor { get; set; }
public:
virtual property Nullable<Color> BaseBackColor {
    Nullable<Color> get () sealed;
    void set (Nullable<Color> value) sealed;
}

Property Value

Type: NullableColor

Implements

IContextualTabGroupBaseBackColor
See Also

Reference

PythonContextualRibbonTab Class
VisualComponents.UX.Shared Namespace


PythonContextualRibbonTab.Caption Property

PythonContextualRibbonTabCaption Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Caption { get; protected set; }
public:
virtual property String^ Caption {
    String^ get () sealed;
    protected: void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IContextualTabGroupCaption
See Also

Reference

PythonContextualRibbonTab Class
VisualComponents.UX.Shared Namespace


PythonContextualRibbonTab.IgContextualTabGroup Property

PythonContextualRibbonTabIgContextualTabGroup Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object IgContextualTabGroup { get; set; }
public:
virtual property Object^ IgContextualTabGroup {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}

Property Value

Type: Object

Implements

IContextualTabGroupIgContextualTabGroup
See Also

Reference

PythonContextualRibbonTab Class
VisualComponents.UX.Shared Namespace


PythonContextualRibbonTab.IsVisible Property

PythonContextualRibbonTabIsVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsVisible { get; protected set; }
public:
virtual property bool IsVisible {
    bool get () sealed;
    protected: void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IContextualTabGroupIsVisible
See Also

Reference

PythonContextualRibbonTab Class
VisualComponents.UX.Shared Namespace


PythonContextualRibbonTab.Key Property

PythonContextualRibbonTabKey Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Key { get; protected set; }
public:
virtual property String^ Key {
    String^ get () sealed;
    protected: void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IContextualTabGroupKey
See Also

Reference

PythonContextualRibbonTab Class
VisualComponents.UX.Shared Namespace


PythonContextualRibbonTab Methods

The PythonContextualRibbonTab type exposes the following members.

Methods
 | Name | Description
Public method | AfterExecute | (Inherited from BaseActionItem.)
Public method | BeforeExecute | (Inherited from BaseActionItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute | Updates the value of CanExecute (Inherited from BaseActionItem.)
Public method | Execute | (Inherited from PythonActionItem.)
Public method | Execute(Boolean) | The action associated to the ActionItem (Inherited from PythonActionItem.)
Public method | Execute(PropertyCollection) | (Inherited from ActionItemT1.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from ActionItemT1.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableForObject | (Inherited from BaseActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from PythonActionItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from BaseActionItem.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | OnImportsSatisfied | Overriding class should call baseclass implementation. (Inherited from BaseActionItem.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SetupBaseActionItem | (Inherited from BaseActionItem.)
Public method | SetupPythonActionItem | (Inherited from PythonActionItem.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Protected method | StartAction | Shortcut for calling CommandRegistry.StartCommandPanelAction(this). (Inherited from BaseActionItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PythonContextualRibbonTab Class
VisualComponents.UX.Shared Namespace


PythonContextualRibbonTab Events

The PythonContextualRibbonTab type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
See Also

Reference

PythonContextualRibbonTab Class
VisualComponents.UX.Shared Namespace


PythonContextualRibbonTab Fields

The PythonContextualRibbonTab type exposes the following members.

Fields
 | Name | Description
Protected field | _getIconPathFromFile | (Inherited from BaseActionItem.)
Protected field | _isColoredIcon | (Inherited from BaseActionItem.)
Protected field | canExecute | Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called. (Inherited from BaseActionItem.)
Protected field | executeAction | (Inherited from ActionItemT1.)
Protected field | RequestedFeatures | Contains license features requested by the action item. This collection should be populated by the implementing class. (Inherited from BaseActionItem.)
Top
See Also

Reference

PythonContextualRibbonTab Class
VisualComponents.UX.Shared Namespace


PythonEditorView Class

Interaction logic for PythonEditorView.xaml
PythonEditorView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedPythonEditorView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PythonEditorView : UserControl,
    IComponentConnector
public ref class PythonEditorView : public UserControl,
    IComponentConnector

The PythonEditorView type exposes the following members.

Constructors
 | Name | Description
Public method | PythonEditorView | Initializes a new instance of the PythonEditorView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasChanges |
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RunToCursorLine |
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | StepLine |
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TraceActive |
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | ViewModel |
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus |
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | HasMarker |
Public method | HilightLine |
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | RunToCursorReached |
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetInitText |
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ShowTooltip |
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | WriteMessage |
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PythonEditorView Constructor

Initializes a new instance of the PythonEditorView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PythonEditorView()
public:
PythonEditorView()
See Also

Reference

PythonEditorView Class
VisualComponents.UX.Shared Namespace


PythonEditorView Properties

The PythonEditorView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasChanges |
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RunToCursorLine |
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | StepLine |
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TraceActive |
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | ViewModel |
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

PythonEditorView Class
VisualComponents.UX.Shared Namespace


PythonEditorView.HasChanges Property

PythonEditorViewHasChanges Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HasChanges { get; }
public:
property bool HasChanges {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

PythonEditorView Class
VisualComponents.UX.Shared Namespace


PythonEditorView.RunToCursorLine Property

PythonEditorViewRunToCursorLine Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int RunToCursorLine { get; }
public:
property int RunToCursorLine {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

PythonEditorView Class
VisualComponents.UX.Shared Namespace


PythonEditorView.StepLine Property

PythonEditorViewStepLine Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool StepLine { get; set; }
public:
property bool StepLine {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PythonEditorView Class
VisualComponents.UX.Shared Namespace


PythonEditorView.TraceActive Property

PythonEditorViewTraceActive Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool TraceActive { get; }
public:
property bool TraceActive {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

PythonEditorView Class
VisualComponents.UX.Shared Namespace


PythonEditorView.ViewModel Property

PythonEditorViewViewModel Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PythonEditorViewModel ViewModel { get; }
public:
property PythonEditorViewModel^ ViewModel {
    PythonEditorViewModel^ get ();
}

Property Value

Type: PythonEditorViewModel
See Also

Reference

PythonEditorView Class
VisualComponents.UX.Shared Namespace


PythonEditorView Methods

The PythonEditorView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus |
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | HasMarker |
Public method | HilightLine |
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | RunToCursorReached |
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetInitText |
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ShowTooltip |
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | WriteMessage |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PythonEditorView Class
VisualComponents.UX.Shared Namespace


PythonEditorView.Focus Method

PythonEditorViewFocus Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Focus()
public:
void Focus()
See Also

Reference

PythonEditorView Class
VisualComponents.UX.Shared Namespace


PythonEditorView.HasMarker Method

PythonEditorViewHasMarker Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HasMarker(
    int line
)
public:
bool HasMarker(
    int line
)

Parameters

line
Type: SystemInt32

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PythonEditorView.HasMarker(System.Int32)"]

See Also

Reference

PythonEditorView Class
VisualComponents.UX.Shared Namespace


PythonEditorView.HilightLine Method

PythonEditorViewHilightLine Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void HilightLine(
    int line_number
)
public:
void HilightLine(
    int line_number
)

Parameters

line_number
Type: SystemInt32
See Also

Reference

PythonEditorView Class
VisualComponents.UX.Shared Namespace


PythonEditorView.InitializeComponent Method

PythonEditorViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

PythonEditorView Class
VisualComponents.UX.Shared Namespace


PythonEditorView.RunToCursorReached Method

PythonEditorViewRunToCursorReached Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RunToCursorReached()
public:
void RunToCursorReached()
See Also

Reference

PythonEditorView Class
VisualComponents.UX.Shared Namespace


PythonEditorView.SetInitText Method

PythonEditorViewSetInitText Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetInitText(
    string text
)
public:
void SetInitText(
    String^ text
)

Parameters

text
Type: SystemString
See Also

Reference

PythonEditorView Class
VisualComponents.UX.Shared Namespace


PythonEditorView.ShowTooltip Method

PythonEditorViewShowTooltip Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ShowTooltip(
    string message
)
public:
void ShowTooltip(
    String^ message
)

Parameters

message
Type: SystemString
See Also

Reference

PythonEditorView Class
VisualComponents.UX.Shared Namespace


PythonEditorView.WriteMessage Method

PythonEditorViewWriteMessage Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void WriteMessage(
    string message
)
public:
void WriteMessage(
    String^ message
)

Parameters

message
Type: SystemString
See Also

Reference

PythonEditorView Class
VisualComponents.UX.Shared Namespace


PythonEditorView Events

The PythonEditorView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

PythonEditorView Class
VisualComponents.UX.Shared Namespace


PythonEditorViewModel Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
ViewAware
Screen
VisualComponents.UX.SharedPythonEditorViewModel

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PythonEditorViewModel : Screen
public ref class PythonEditorViewModel : public Screen

The PythonEditorViewModel type exposes the following members.

Properties
 | Name | Description
Protected property | CacheViews | (Inherited from ViewAware.)
Public property | CanCompile |
Public property | CanDebug |
Public property | CanTryCompile |
Public property | DisplayName | (Inherited from Screen.)
Public property | HasChanged |
Public property | IsActive | (Inherited from Screen.)
Public property | IsInitialized | (Inherited from Screen.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsSimulationRunning |
Public property | Parent | (Inherited from Screen.)
Public property | PythonInstance |
Public property | Title |
Top
Methods
 | Name | Description
Public method | CanClose | (Inherited from Screen.)
Public method | CanSaveInAll |
Public method | Compile |
 | Edit |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetView | (Inherited from ViewAware.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Protected method | OnActivate | (Overrides Screen.OnActivate.)
Protected method | OnDeactivate | (Overrides Screen.OnDeactivate(Boolean).)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnInitialize | (Inherited from Screen.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Protected method | OnViewAttached | (Inherited from ViewAware.)
Protected method | OnViewLoaded | (Overrides ViewAware.OnViewLoaded(Object).)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | RunStep |
Public method | RunToCursor |
Public method | SaveInAll | Update same script in other components.
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | TextSelected |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryClose | (Inherited from Screen.)
Public method | TryClose(NullableBoolean) | (Inherited from Screen.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from Screen.)
Public event | AttemptingDeactivation | (Inherited from Screen.)
Public event | Deactivated | (Inherited from Screen.)
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Public event | ViewAttached | (Inherited from ViewAware.)
Top
Fields
 | Name | Description
Protected field | Views | (Inherited from ViewAware.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PythonEditorViewModel Properties

The PythonEditorViewModel type exposes the following members.

Properties
 | Name | Description
Protected property | CacheViews | (Inherited from ViewAware.)
Public property | CanCompile |
Public property | CanDebug |
Public property | CanTryCompile |
Public property | DisplayName | (Inherited from Screen.)
Public property | HasChanged |
Public property | IsActive | (Inherited from Screen.)
Public property | IsInitialized | (Inherited from Screen.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsSimulationRunning |
Public property | Parent | (Inherited from Screen.)
Public property | PythonInstance |
Public property | Title |
Top
See Also

Reference

PythonEditorViewModel Class
VisualComponents.UX.Shared Namespace


PythonEditorViewModel.CanCompile Property

PythonEditorViewModelCanCompile Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanCompile { get; }
public:
property bool CanCompile {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

PythonEditorViewModel Class
VisualComponents.UX.Shared Namespace


PythonEditorViewModel.CanDebug Property

PythonEditorViewModelCanDebug Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanDebug { get; set; }
public:
property bool CanDebug {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PythonEditorViewModel Class
VisualComponents.UX.Shared Namespace


PythonEditorViewModel.CanTryCompile Property

PythonEditorViewModelCanTryCompile Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanTryCompile { get; }
public:
property bool CanTryCompile {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

PythonEditorViewModel Class
VisualComponents.UX.Shared Namespace


PythonEditorViewModel.HasChanged Property

PythonEditorViewModelHasChanged Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HasChanged { get; set; }
public:
property bool HasChanged {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

PythonEditorViewModel Class
VisualComponents.UX.Shared Namespace


PythonEditorViewModel.IsSimulationRunning Property

PythonEditorViewModelIsSimulationRunning Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsSimulationRunning { get; }
public:
property bool IsSimulationRunning {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

PythonEditorViewModel Class
VisualComponents.UX.Shared Namespace


PythonEditorViewModel.PythonInstance Property

PythonEditorViewModelPythonInstance Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IPythonInstance PythonInstance { get; }
public:
property IPythonInstance^ PythonInstance {
    IPythonInstance^ get ();
}

Property Value

Type: IPythonInstance
See Also

Reference

PythonEditorViewModel Class
VisualComponents.UX.Shared Namespace


PythonEditorViewModel.Title Property

PythonEditorViewModelTitle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; set; }
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PythonEditorViewModel Class
VisualComponents.UX.Shared Namespace


PythonEditorViewModel Methods

The PythonEditorViewModel type exposes the following members.

Methods
 | Name | Description
Public method | CanClose | (Inherited from Screen.)
Public method | CanSaveInAll |
Public method | Compile |
 | Edit |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetView | (Inherited from ViewAware.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Protected method | OnActivate | (Overrides Screen.OnActivate.)
Protected method | OnDeactivate | (Overrides Screen.OnDeactivate(Boolean).)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnInitialize | (Inherited from Screen.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Protected method | OnViewAttached | (Inherited from ViewAware.)
Protected method | OnViewLoaded | (Overrides ViewAware.OnViewLoaded(Object).)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | RunStep |
Public method | RunToCursor |
Public method | SaveInAll | Update same script in other components.
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | TextSelected |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryClose | (Inherited from Screen.)
Public method | TryClose(NullableBoolean) | (Inherited from Screen.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PythonEditorViewModel Class
VisualComponents.UX.Shared Namespace


PythonEditorViewModel.CanSaveInAll Method

PythonEditorViewModelCanSaveInAll Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanSaveInAll()
public:
bool CanSaveInAll()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PythonEditorViewModel.CanSaveInAll"]

See Also

Reference

PythonEditorViewModel Class
VisualComponents.UX.Shared Namespace


PythonEditorViewModel.Compile Method

PythonEditorViewModelCompile Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Compile()
public:
void Compile()
See Also

Reference

PythonEditorViewModel Class
VisualComponents.UX.Shared Namespace


PythonEditorViewModel.Edit Method

PythonEditorViewModelEdit Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void Edit(
    Object script
)
public:
static void Edit(
    Object^ script
)

Parameters

script
Type: SystemObject
See Also

Reference

PythonEditorViewModel Class
VisualComponents.UX.Shared Namespace


PythonEditorViewModel.OnActivate Method

PythonEditorViewModelOnActivate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnActivate()
protected:
virtual void OnActivate() override
See Also

Reference

PythonEditorViewModel Class
VisualComponents.UX.Shared Namespace


PythonEditorViewModel.OnDeactivate Method

PythonEditorViewModelOnDeactivate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnDeactivate(
    bool close
)
protected:
virtual void OnDeactivate(
    bool close
) override

Parameters

close
Type: SystemBoolean
See Also

Reference

PythonEditorViewModel Class
VisualComponents.UX.Shared Namespace


PythonEditorViewModel.OnViewLoaded Method

PythonEditorViewModelOnViewLoaded Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnViewLoaded(
    Object view
)
protected:
virtual void OnViewLoaded(
    Object^ view
) override

Parameters

view
Type: SystemObject
See Also

Reference

PythonEditorViewModel Class
VisualComponents.UX.Shared Namespace


PythonEditorViewModel.RunStep Method

PythonEditorViewModelRunStep Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RunStep()
public:
void RunStep()
See Also

Reference

PythonEditorViewModel Class
VisualComponents.UX.Shared Namespace


PythonEditorViewModel.RunToCursor Method

PythonEditorViewModelRunToCursor Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RunToCursor()
public:
void RunToCursor()
See Also

Reference

PythonEditorViewModel Class
VisualComponents.UX.Shared Namespace


PythonEditorViewModel.SaveInAll Method

PythonEditorViewModelSaveInAll Method

Update same script in other components.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SaveInAll()
public:
void SaveInAll()
See Also

Reference

PythonEditorViewModel Class
VisualComponents.UX.Shared Namespace


PythonEditorViewModel.TextSelected Method

PythonEditorViewModelTextSelected Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void TextSelected(
    string selected
)
public:
void TextSelected(
    String^ selected
)

Parameters

selected
Type: SystemString
See Also

Reference

PythonEditorViewModel Class
VisualComponents.UX.Shared Namespace


PythonEditorViewModel Events

The PythonEditorViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from Screen.)
Public event | AttemptingDeactivation | (Inherited from Screen.)
Public event | Deactivated | (Inherited from Screen.)
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Public event | ViewAttached | (Inherited from ViewAware.)
Top
See Also

Reference

PythonEditorViewModel Class
VisualComponents.UX.Shared Namespace


PythonEditorViewModel Fields

The PythonEditorViewModel type exposes the following members.

Fields
 | Name | Description
Protected field | Views | (Inherited from ViewAware.)
Top
See Also

Reference

PythonEditorViewModel Class
VisualComponents.UX.Shared Namespace


PythonGalleryActionItem Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.SharedBaseActionItem
VisualComponents.UX.SharedActionItem Boolean
VisualComponents.UX.SharedPythonActionItem
VisualComponents.UX.SharedPythonGalleryActionItem

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PythonGalleryActionItem : PythonActionItem,
    IGalleryMenuToolCommand, IRibbonToolCommand, IPartImportsSatisfiedNotification
public ref class PythonGalleryActionItem : public PythonActionItem,
    IGalleryMenuToolCommand, IRibbonToolCommand, IPartImportsSatisfiedNotification

The PythonGalleryActionItem type exposes the following members.

Constructors
 | Name | Description
Public method | PythonGalleryActionItem | Initializes a new instance of the PythonGalleryActionItem class
Top
Properties
 | Name | Description
Public property | ActiveAction | Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this). (Inherited from BaseActionItem.)
Protected property | Application | (Inherited from BaseActionItem.)
Public property | AttachTo | (Inherited from BaseActionItem.)
Public property | ButtonMaxWidth | (Inherited from BaseActionItem.)
Public property | ButtonMinWidth | (Inherited from BaseActionItem.)
Public property | ButtonWidth | (Inherited from BaseActionItem.)
Public property | CanExecute | (Inherited from BaseActionItem.)
Protected property | canExecuteAction | Similar to canExecute. This is provided for Visual Basic compatibility. (Inherited from BaseActionItem.)
Public property | CollapseWhenDeactivated | (Inherited from BaseActionItem.)
Public property | CommandRegistry | This references is assigned by CommandRegistry on startup. (Inherited from BaseActionItem.)
Public property | Content | (Inherited from BaseActionItem.)
Public property | Context | (Inherited from BaseActionItem.)
Public property | ContextFilter | (Inherited from BaseActionItem.)
Public property | ControlType | (Inherited from BaseActionItem.)
Public property | Customization | (Inherited from BaseActionItem.)
Protected property | EventMng | Event aggregator (Inherited from BaseActionItem.)
Public property | GalleryItems |
Public property | GroupItems |
Public property | Icon | (Inherited from BaseActionItem.)
Public property | IconName | (Inherited from BaseActionItem.)
Public property | Id | (Inherited from BaseActionItem.)
Public property | ImageSource | (Inherited from BaseActionItem.)
Public property | IsActivated | (Inherited from BaseActionItem.)
Public property | IsBackgroundVisible | (Inherited from BaseActionItem.)
Public property | IsChecked | IsChecked status (Inherited from PythonActionItem.)
Public property | IsColoredIcon | (Inherited from BaseActionItem.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsQatCommonTool | (Inherited from BaseActionItem.)
Public property | IsToolNotInRibbon | (Inherited from BaseActionItem.)
Public property | Localization | (Inherited from BaseActionItem.)
Public property | MaxDropDownColumns |
Public property | MaxPreviewColumns |
Public property | MinDropDownColumns |
Public property | MinPreviewColumns |
Public property | PreferredDropDownColumns |
Public property | RibbonId | (Inherited from BaseActionItem.)
Public property | SetupInfo | (Inherited from PythonActionItem.)
Public property | ShouldDisplayGalleryPreview |
Public property | SiteOrder | (Inherited from BaseActionItem.)
Protected property | SkipAbortWhenExecuted | If true, action will not abort currently executing action. (Inherited from BaseActionItem.)
Public property | Tag | (Inherited from BaseActionItem.)
Public property | ToolSize | (Inherited from BaseActionItem.)
Public property | ToolTipBookmark | (Inherited from BaseActionItem.)
Public property | ToolTipContent | (Inherited from BaseActionItem.)
Public property | ToolTipContentImage | (Inherited from BaseActionItem.)
Public property | ToolTipFooter | (Inherited from BaseActionItem.)
Public property | ToolTipFooterSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipFooterVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipHeader | (Inherited from BaseActionItem.)
Public property | ToolTipHeaderSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipMoreInfoUrl | (Inherited from BaseActionItem.)
Public property | ToolTipVisibility | (Inherited from BaseActionItem.)
Public property | UxConfig | (Inherited from BaseActionItem.)
Public property | UXSite | (Inherited from PythonActionItem.)
Public property | Visibility | (Inherited from BaseActionItem.)
Top
Methods
 | Name | Description
Public method | AfterExecute | (Inherited from BaseActionItem.)
Public method | BeforeExecute | (Inherited from BaseActionItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute | Updates the value of CanExecute (Inherited from BaseActionItem.)
Public method | Execute | (Inherited from PythonActionItem.)
Public method | Execute(Boolean) | The action associated to the ActionItem (Inherited from PythonActionItem.)
Public method | Execute(PropertyCollection) | (Inherited from ActionItemT1.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from ActionItemT1.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableForObject | (Inherited from BaseActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from PythonActionItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from BaseActionItem.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | OnImportsSatisfied | Overriding class should call baseclass implementation. (Inherited from BaseActionItem.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SetupBaseActionItem | (Inherited from BaseActionItem.)
Public method | SetupPythonActionItem | (Inherited from PythonActionItem.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Protected method | StartAction | Shortcut for calling CommandRegistry.StartCommandPanelAction(this). (Inherited from BaseActionItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
Fields
 | Name | Description
Protected field | _getIconPathFromFile | (Inherited from BaseActionItem.)
Protected field | _isColoredIcon | (Inherited from BaseActionItem.)
Protected field | canExecute | Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called. (Inherited from BaseActionItem.)
Protected field | executeAction | (Inherited from ActionItemT1.)
Protected field | RequestedFeatures | Contains license features requested by the action item. This collection should be populated by the implementing class. (Inherited from BaseActionItem.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PythonGalleryActionItem Constructor

Initializes a new instance of the PythonGalleryActionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PythonGalleryActionItem(
    string id,
    SetupPythonActionMessage message,
    string controlType = "GalleryMenuTool",
    bool getIconPathFromFile = true,
    bool isColoredIcon = true
)
public:
PythonGalleryActionItem(
    String^ id,
    SetupPythonActionMessage^ message,
    String^ controlType = L"GalleryMenuTool",
    bool getIconPathFromFile = true,
    bool isColoredIcon = true
)

Parameters

id
Type: SystemString
message
Type: VisualComponents.Create3DSetupPythonActionMessage
controlType (Optional)
Type: SystemString
getIconPathFromFile (Optional)
Type: SystemBoolean
isColoredIcon (Optional)
Type: SystemBoolean
See Also

Reference

PythonGalleryActionItem Class
VisualComponents.UX.Shared Namespace


PythonGalleryActionItem Properties

The PythonGalleryActionItem type exposes the following members.

Properties
 | Name | Description
Public property | ActiveAction | Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this). (Inherited from BaseActionItem.)
Protected property | Application | (Inherited from BaseActionItem.)
Public property | AttachTo | (Inherited from BaseActionItem.)
Public property | ButtonMaxWidth | (Inherited from BaseActionItem.)
Public property | ButtonMinWidth | (Inherited from BaseActionItem.)
Public property | ButtonWidth | (Inherited from BaseActionItem.)
Public property | CanExecute | (Inherited from BaseActionItem.)
Protected property | canExecuteAction | Similar to canExecute. This is provided for Visual Basic compatibility. (Inherited from BaseActionItem.)
Public property | CollapseWhenDeactivated | (Inherited from BaseActionItem.)
Public property | CommandRegistry | This references is assigned by CommandRegistry on startup. (Inherited from BaseActionItem.)
Public property | Content | (Inherited from BaseActionItem.)
Public property | Context | (Inherited from BaseActionItem.)
Public property | ContextFilter | (Inherited from BaseActionItem.)
Public property | ControlType | (Inherited from BaseActionItem.)
Public property | Customization | (Inherited from BaseActionItem.)
Protected property | EventMng | Event aggregator (Inherited from BaseActionItem.)
Public property | GalleryItems |
Public property | GroupItems |
Public property | Icon | (Inherited from BaseActionItem.)
Public property | IconName | (Inherited from BaseActionItem.)
Public property | Id | (Inherited from BaseActionItem.)
Public property | ImageSource | (Inherited from BaseActionItem.)
Public property | IsActivated | (Inherited from BaseActionItem.)
Public property | IsBackgroundVisible | (Inherited from BaseActionItem.)
Public property | IsChecked | IsChecked status (Inherited from PythonActionItem.)
Public property | IsColoredIcon | (Inherited from BaseActionItem.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsQatCommonTool | (Inherited from BaseActionItem.)
Public property | IsToolNotInRibbon | (Inherited from BaseActionItem.)
Public property | Localization | (Inherited from BaseActionItem.)
Public property | MaxDropDownColumns |
Public property | MaxPreviewColumns |
Public property | MinDropDownColumns |
Public property | MinPreviewColumns |
Public property | PreferredDropDownColumns |
Public property | RibbonId | (Inherited from BaseActionItem.)
Public property | SetupInfo | (Inherited from PythonActionItem.)
Public property | ShouldDisplayGalleryPreview |
Public property | SiteOrder | (Inherited from BaseActionItem.)
Protected property | SkipAbortWhenExecuted | If true, action will not abort currently executing action. (Inherited from BaseActionItem.)
Public property | Tag | (Inherited from BaseActionItem.)
Public property | ToolSize | (Inherited from BaseActionItem.)
Public property | ToolTipBookmark | (Inherited from BaseActionItem.)
Public property | ToolTipContent | (Inherited from BaseActionItem.)
Public property | ToolTipContentImage | (Inherited from BaseActionItem.)
Public property | ToolTipFooter | (Inherited from BaseActionItem.)
Public property | ToolTipFooterSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipFooterVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipHeader | (Inherited from BaseActionItem.)
Public property | ToolTipHeaderSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipMoreInfoUrl | (Inherited from BaseActionItem.)
Public property | ToolTipVisibility | (Inherited from BaseActionItem.)
Public property | UxConfig | (Inherited from BaseActionItem.)
Public property | UXSite | (Inherited from PythonActionItem.)
Public property | Visibility | (Inherited from BaseActionItem.)
Top
See Also

Reference

PythonGalleryActionItem Class
VisualComponents.UX.Shared Namespace


PythonGalleryActionItem.GalleryItems Property

PythonGalleryActionItemGalleryItems Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObservableCollection<GalleryItemEx> GalleryItems { get; set; }
public:
virtual property ObservableCollection<GalleryItemEx^>^ GalleryItems {
    ObservableCollection<GalleryItemEx^>^ get () sealed;
    void set (ObservableCollection<GalleryItemEx^>^ value) sealed;
}

Property Value

Type: ObservableCollectionGalleryItemEx

Implements

IGalleryMenuToolCommandGalleryItems
See Also

Reference

PythonGalleryActionItem Class
VisualComponents.UX.Shared Namespace


PythonGalleryActionItem.GroupItems Property

PythonGalleryActionItemGroupItems Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObservableCollection<GalleryGroup> GroupItems { get; set; }
public:
virtual property ObservableCollection<GalleryGroup^>^ GroupItems {
    ObservableCollection<GalleryGroup^>^ get () sealed;
    void set (ObservableCollection<GalleryGroup^>^ value) sealed;
}

Property Value

Type: ObservableCollectionGalleryGroup

Implements

IGalleryMenuToolCommandGroupItems
See Also

Reference

PythonGalleryActionItem Class
VisualComponents.UX.Shared Namespace


PythonGalleryActionItem.MaxDropDownColumns Property

PythonGalleryActionItemMaxDropDownColumns Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int MaxDropDownColumns { get; set; }
public:
virtual property int MaxDropDownColumns {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

IGalleryMenuToolCommandMaxDropDownColumns
See Also

Reference

PythonGalleryActionItem Class
VisualComponents.UX.Shared Namespace


PythonGalleryActionItem.MaxPreviewColumns Property

PythonGalleryActionItemMaxPreviewColumns Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int MaxPreviewColumns { get; set; }
public:
virtual property int MaxPreviewColumns {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

IGalleryMenuToolCommandMaxPreviewColumns
See Also

Reference

PythonGalleryActionItem Class
VisualComponents.UX.Shared Namespace


PythonGalleryActionItem.MinDropDownColumns Property

PythonGalleryActionItemMinDropDownColumns Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int MinDropDownColumns { get; set; }
public:
virtual property int MinDropDownColumns {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

IGalleryMenuToolCommandMinDropDownColumns
See Also

Reference

PythonGalleryActionItem Class
VisualComponents.UX.Shared Namespace


PythonGalleryActionItem.MinPreviewColumns Property

PythonGalleryActionItemMinPreviewColumns Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int MinPreviewColumns { get; set; }
public:
virtual property int MinPreviewColumns {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

IGalleryMenuToolCommandMinPreviewColumns
See Also

Reference

PythonGalleryActionItem Class
VisualComponents.UX.Shared Namespace


PythonGalleryActionItem.PreferredDropDownColumns Property

PythonGalleryActionItemPreferredDropDownColumns Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int PreferredDropDownColumns { get; set; }
public:
virtual property int PreferredDropDownColumns {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

IGalleryMenuToolCommandPreferredDropDownColumns
See Also

Reference

PythonGalleryActionItem Class
VisualComponents.UX.Shared Namespace


PythonGalleryActionItem.ShouldDisplayGalleryPreview Property

PythonGalleryActionItemShouldDisplayGalleryPreview Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShouldDisplayGalleryPreview { get; set; }
public:
virtual property bool ShouldDisplayGalleryPreview {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IGalleryMenuToolCommandShouldDisplayGalleryPreview
See Also

Reference

PythonGalleryActionItem Class
VisualComponents.UX.Shared Namespace


PythonGalleryActionItem Methods

The PythonGalleryActionItem type exposes the following members.

Methods
 | Name | Description
Public method | AfterExecute | (Inherited from BaseActionItem.)
Public method | BeforeExecute | (Inherited from BaseActionItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute | Updates the value of CanExecute (Inherited from BaseActionItem.)
Public method | Execute | (Inherited from PythonActionItem.)
Public method | Execute(Boolean) | The action associated to the ActionItem (Inherited from PythonActionItem.)
Public method | Execute(PropertyCollection) | (Inherited from ActionItemT1.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from ActionItemT1.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableForObject | (Inherited from BaseActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from PythonActionItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from BaseActionItem.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | OnImportsSatisfied | Overriding class should call baseclass implementation. (Inherited from BaseActionItem.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SetupBaseActionItem | (Inherited from BaseActionItem.)
Public method | SetupPythonActionItem | (Inherited from PythonActionItem.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Protected method | StartAction | Shortcut for calling CommandRegistry.StartCommandPanelAction(this). (Inherited from BaseActionItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PythonGalleryActionItem Class
VisualComponents.UX.Shared Namespace


PythonGalleryActionItem Events

The PythonGalleryActionItem type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
See Also

Reference

PythonGalleryActionItem Class
VisualComponents.UX.Shared Namespace


PythonGalleryActionItem Fields

The PythonGalleryActionItem type exposes the following members.

Fields
 | Name | Description
Protected field | _getIconPathFromFile | (Inherited from BaseActionItem.)
Protected field | _isColoredIcon | (Inherited from BaseActionItem.)
Protected field | canExecute | Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called. (Inherited from BaseActionItem.)
Protected field | executeAction | (Inherited from ActionItemT1.)
Protected field | RequestedFeatures | Contains license features requested by the action item. This collection should be populated by the implementing class. (Inherited from BaseActionItem.)
Top
See Also

Reference

PythonGalleryActionItem Class
VisualComponents.UX.Shared Namespace


PythonGalleryItemActionItem Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.SharedBaseActionItem
VisualComponents.UX.SharedActionItem Boolean
VisualComponents.UX.SharedPythonActionItem
VisualComponents.UX.SharedPythonGalleryItemActionItem

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PythonGalleryItemActionItem : PythonActionItem
public ref class PythonGalleryItemActionItem : public PythonActionItem

The PythonGalleryItemActionItem type exposes the following members.

Constructors
 | Name | Description
Public method | PythonGalleryItemActionItem | Initializes a new instance of the PythonGalleryItemActionItem class
Top
Properties
 | Name | Description
Public property | ActiveAction | Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this). (Inherited from BaseActionItem.)
Protected property | Application | (Inherited from BaseActionItem.)
Public property | AttachTo | (Inherited from BaseActionItem.)
Public property | ButtonMaxWidth | (Inherited from BaseActionItem.)
Public property | ButtonMinWidth | (Inherited from BaseActionItem.)
Public property | ButtonWidth | (Inherited from BaseActionItem.)
Public property | CanExecute | (Inherited from BaseActionItem.)
Protected property | canExecuteAction | Similar to canExecute. This is provided for Visual Basic compatibility. (Inherited from BaseActionItem.)
Public property | CollapseWhenDeactivated | (Inherited from BaseActionItem.)
Public property | CommandRegistry | This references is assigned by CommandRegistry on startup. (Inherited from BaseActionItem.)
Public property | Content | (Inherited from BaseActionItem.)
Public property | Context | (Inherited from BaseActionItem.)
Public property | ContextFilter | (Inherited from BaseActionItem.)
Public property | ControlType | (Inherited from BaseActionItem.)
Public property | Customization | (Inherited from BaseActionItem.)
Protected property | EventMng | Event aggregator (Inherited from BaseActionItem.)
Public property | Icon | (Inherited from BaseActionItem.)
Public property | IconName | (Inherited from BaseActionItem.)
Public property | Id | (Inherited from BaseActionItem.)
Public property | ImageSource | (Inherited from BaseActionItem.)
Public property | IsActivated | (Inherited from BaseActionItem.)
Public property | IsBackgroundVisible | (Inherited from BaseActionItem.)
Public property | IsChecked | IsChecked status (Inherited from PythonActionItem.)
Public property | IsColoredIcon | (Inherited from BaseActionItem.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsQatCommonTool | (Inherited from BaseActionItem.)
Public property | IsToolNotInRibbon | (Inherited from BaseActionItem.)
Public property | Localization | (Inherited from BaseActionItem.)
Public property | RibbonId | (Inherited from BaseActionItem.)
Public property | SetupInfo | (Inherited from PythonActionItem.)
Public property | SiteOrder | (Inherited from BaseActionItem.)
Protected property | SkipAbortWhenExecuted | If true, action will not abort currently executing action. (Inherited from BaseActionItem.)
Public property | Tag | (Inherited from BaseActionItem.)
Public property | ToolSize | (Inherited from BaseActionItem.)
Public property | ToolTipBookmark | (Inherited from BaseActionItem.)
Public property | ToolTipContent | (Inherited from BaseActionItem.)
Public property | ToolTipContentImage | (Inherited from BaseActionItem.)
Public property | ToolTipFooter | (Inherited from BaseActionItem.)
Public property | ToolTipFooterSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipFooterVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipHeader | (Inherited from BaseActionItem.)
Public property | ToolTipHeaderSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipMoreInfoUrl | (Inherited from BaseActionItem.)
Public property | ToolTipVisibility | (Inherited from BaseActionItem.)
Public property | UxConfig | (Inherited from BaseActionItem.)
Public property | UXSite | (Inherited from PythonActionItem.)
Public property | Visibility | (Inherited from BaseActionItem.)
Top
Methods
 | Name | Description
Public method | AfterExecute | (Inherited from BaseActionItem.)
Public method | BeforeExecute | (Inherited from BaseActionItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute | Updates the value of CanExecute (Inherited from BaseActionItem.)
Public method | Execute | (Inherited from PythonActionItem.)
Public method | Execute(Boolean) | The action associated to the ActionItem (Inherited from PythonActionItem.)
Public method | Execute(PropertyCollection) | (Inherited from ActionItemT1.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from ActionItemT1.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableForObject | (Inherited from BaseActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from PythonActionItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from BaseActionItem.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | OnImportsSatisfied | Overriding class should call baseclass implementation. (Inherited from BaseActionItem.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SetupBaseActionItem | (Inherited from BaseActionItem.)
Public method | SetupPythonActionItem | (Inherited from PythonActionItem.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Protected method | StartAction | Shortcut for calling CommandRegistry.StartCommandPanelAction(this). (Inherited from BaseActionItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
Fields
 | Name | Description
Protected field | _getIconPathFromFile | (Inherited from BaseActionItem.)
Protected field | _isColoredIcon | (Inherited from BaseActionItem.)
Protected field | canExecute | Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called. (Inherited from BaseActionItem.)
Protected field | executeAction | (Inherited from ActionItemT1.)
Protected field | RequestedFeatures | Contains license features requested by the action item. This collection should be populated by the implementing class. (Inherited from BaseActionItem.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PythonGalleryItemActionItem Constructor

Initializes a new instance of the PythonGalleryItemActionItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PythonGalleryItemActionItem(
    string id,
    SetupPythonActionMessage message,
    string controlType = "GalleryMenuToolItem",
    bool getIconPathFromFile = true,
    bool isColoredIcon = true
)
public:
PythonGalleryItemActionItem(
    String^ id,
    SetupPythonActionMessage^ message,
    String^ controlType = L"GalleryMenuToolItem",
    bool getIconPathFromFile = true,
    bool isColoredIcon = true
)

Parameters

id
Type: SystemString
message
Type: VisualComponents.Create3DSetupPythonActionMessage
controlType (Optional)
Type: SystemString
getIconPathFromFile (Optional)
Type: SystemBoolean
isColoredIcon (Optional)
Type: SystemBoolean
See Also

Reference

PythonGalleryItemActionItem Class
VisualComponents.UX.Shared Namespace


PythonGalleryItemActionItem Properties

The PythonGalleryItemActionItem type exposes the following members.

Properties
 | Name | Description
Public property | ActiveAction | Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this). (Inherited from BaseActionItem.)
Protected property | Application | (Inherited from BaseActionItem.)
Public property | AttachTo | (Inherited from BaseActionItem.)
Public property | ButtonMaxWidth | (Inherited from BaseActionItem.)
Public property | ButtonMinWidth | (Inherited from BaseActionItem.)
Public property | ButtonWidth | (Inherited from BaseActionItem.)
Public property | CanExecute | (Inherited from BaseActionItem.)
Protected property | canExecuteAction | Similar to canExecute. This is provided for Visual Basic compatibility. (Inherited from BaseActionItem.)
Public property | CollapseWhenDeactivated | (Inherited from BaseActionItem.)
Public property | CommandRegistry | This references is assigned by CommandRegistry on startup. (Inherited from BaseActionItem.)
Public property | Content | (Inherited from BaseActionItem.)
Public property | Context | (Inherited from BaseActionItem.)
Public property | ContextFilter | (Inherited from BaseActionItem.)
Public property | ControlType | (Inherited from BaseActionItem.)
Public property | Customization | (Inherited from BaseActionItem.)
Protected property | EventMng | Event aggregator (Inherited from BaseActionItem.)
Public property | Icon | (Inherited from BaseActionItem.)
Public property | IconName | (Inherited from BaseActionItem.)
Public property | Id | (Inherited from BaseActionItem.)
Public property | ImageSource | (Inherited from BaseActionItem.)
Public property | IsActivated | (Inherited from BaseActionItem.)
Public property | IsBackgroundVisible | (Inherited from BaseActionItem.)
Public property | IsChecked | IsChecked status (Inherited from PythonActionItem.)
Public property | IsColoredIcon | (Inherited from BaseActionItem.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsQatCommonTool | (Inherited from BaseActionItem.)
Public property | IsToolNotInRibbon | (Inherited from BaseActionItem.)
Public property | Localization | (Inherited from BaseActionItem.)
Public property | RibbonId | (Inherited from BaseActionItem.)
Public property | SetupInfo | (Inherited from PythonActionItem.)
Public property | SiteOrder | (Inherited from BaseActionItem.)
Protected property | SkipAbortWhenExecuted | If true, action will not abort currently executing action. (Inherited from BaseActionItem.)
Public property | Tag | (Inherited from BaseActionItem.)
Public property | ToolSize | (Inherited from BaseActionItem.)
Public property | ToolTipBookmark | (Inherited from BaseActionItem.)
Public property | ToolTipContent | (Inherited from BaseActionItem.)
Public property | ToolTipContentImage | (Inherited from BaseActionItem.)
Public property | ToolTipFooter | (Inherited from BaseActionItem.)
Public property | ToolTipFooterSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipFooterVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipHeader | (Inherited from BaseActionItem.)
Public property | ToolTipHeaderSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipMoreInfoUrl | (Inherited from BaseActionItem.)
Public property | ToolTipVisibility | (Inherited from BaseActionItem.)
Public property | UxConfig | (Inherited from BaseActionItem.)
Public property | UXSite | (Inherited from PythonActionItem.)
Public property | Visibility | (Inherited from BaseActionItem.)
Top
See Also

Reference

PythonGalleryItemActionItem Class
VisualComponents.UX.Shared Namespace


PythonGalleryItemActionItem Methods

The PythonGalleryItemActionItem type exposes the following members.

Methods
 | Name | Description
Public method | AfterExecute | (Inherited from BaseActionItem.)
Public method | BeforeExecute | (Inherited from BaseActionItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute | Updates the value of CanExecute (Inherited from BaseActionItem.)
Public method | Execute | (Inherited from PythonActionItem.)
Public method | Execute(Boolean) | The action associated to the ActionItem (Inherited from PythonActionItem.)
Public method | Execute(PropertyCollection) | (Inherited from ActionItemT1.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from ActionItemT1.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableForObject | (Inherited from BaseActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from PythonActionItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from BaseActionItem.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | OnImportsSatisfied | Overriding class should call baseclass implementation. (Inherited from BaseActionItem.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SetupBaseActionItem | (Inherited from BaseActionItem.)
Public method | SetupPythonActionItem | (Inherited from PythonActionItem.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Protected method | StartAction | Shortcut for calling CommandRegistry.StartCommandPanelAction(this). (Inherited from BaseActionItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PythonGalleryItemActionItem Class
VisualComponents.UX.Shared Namespace


PythonGalleryItemActionItem Events

The PythonGalleryItemActionItem type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
See Also

Reference

PythonGalleryItemActionItem Class
VisualComponents.UX.Shared Namespace


PythonGalleryItemActionItem Fields

The PythonGalleryItemActionItem type exposes the following members.

Fields
 | Name | Description
Protected field | _getIconPathFromFile | (Inherited from BaseActionItem.)
Protected field | _isColoredIcon | (Inherited from BaseActionItem.)
Protected field | canExecute | Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called. (Inherited from BaseActionItem.)
Protected field | executeAction | (Inherited from ActionItemT1.)
Protected field | RequestedFeatures | Contains license features requested by the action item. This collection should be populated by the implementing class. (Inherited from BaseActionItem.)
Top
See Also

Reference

PythonGalleryItemActionItem Class
VisualComponents.UX.Shared Namespace


PythonIntellisense Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedPythonIntellisense

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PythonIntellisense : IPythonIntellisense
public ref class PythonIntellisense : IPythonIntellisense

The PythonIntellisense type exposes the following members.

Constructors
 | Name | Description
Public method | PythonIntellisense | Initializes a new instance of the PythonIntellisense class
Top
Properties
 | Name | Description
Public property | BlackThemeInformation |
Public property | Constants |
Public property | WhiteThemeInformation |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttributeInfo |
Public method | GetExpressionType |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetHelpers |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PythonIntellisense Constructor

Initializes a new instance of the PythonIntellisense class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PythonIntellisense()
public:
PythonIntellisense()
See Also

Reference

PythonIntellisense Class
VisualComponents.UX.Shared Namespace


PythonIntellisense Properties

The PythonIntellisense type exposes the following members.

Properties
 | Name | Description
Public property | BlackThemeInformation |
Public property | Constants |
Public property | WhiteThemeInformation |
Top
See Also

Reference

PythonIntellisense Class
VisualComponents.UX.Shared Namespace


PythonIntellisense.BlackThemeInformation Property

PythonIntellisenseBlackThemeInformation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<int> BlackThemeInformation { get; }
public:
virtual property List<int>^ BlackThemeInformation {
    List<int>^ get () sealed;
}

Property Value

Type: ListInt32

Implements

IPythonIntellisenseBlackThemeInformation
See Also

Reference

PythonIntellisense Class
VisualComponents.UX.Shared Namespace


PythonIntellisense.Constants Property

PythonIntellisenseConstants Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<string> Constants { get; protected set; }
public:
virtual property List<String^>^ Constants {
    List<String^>^ get () sealed;
    protected: void set (List<String^>^ value) sealed;
}

Property Value

Type: ListString

Implements

IPythonIntellisenseConstants
See Also

Reference

PythonIntellisense Class
VisualComponents.UX.Shared Namespace


PythonIntellisense.WhiteThemeInformation Property

PythonIntellisenseWhiteThemeInformation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<int> WhiteThemeInformation { get; }
public:
virtual property List<int>^ WhiteThemeInformation {
    List<int>^ get () sealed;
}

Property Value

Type: ListInt32

Implements

IPythonIntellisenseWhiteThemeInformation
See Also

Reference

PythonIntellisense Class
VisualComponents.UX.Shared Namespace


PythonIntellisense Methods

The PythonIntellisense type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttributeInfo |
Public method | GetExpressionType |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetHelpers |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PythonIntellisense Class
VisualComponents.UX.Shared Namespace


PythonIntellisense.GetAttributeInfo Method

PythonIntellisenseGetAttributeInfo Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PythonAttributeInformation GetAttributeInfo(
    Dictionary<string, string> variableAndtype,
    string line,
    string attribute
)
public:
virtual PythonAttributeInformation^ GetAttributeInfo(
    Dictionary<String^, String^>^ variableAndtype,
    String^ line,
    String^ attribute
) sealed

Parameters

variableAndtype
Type: System.Collections.GenericDictionaryString, String
line
Type: SystemString
attribute
Type: SystemString

Return Value

Type: PythonAttributeInformation

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PythonIntellisense.GetAttributeInfo(System.Collections.Generic.Dictionary{System.String,System.String},System.String,System.String)"]

Implements

IPythonIntellisenseGetAttributeInfo(DictionaryString, String, String, String)
See Also

Reference

PythonIntellisense Class
VisualComponents.UX.Shared Namespace


PythonIntellisense.GetExpressionType Method

PythonIntellisenseGetExpressionType Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PythonClassInfo GetExpressionType(
    Dictionary<string, string> variableAndtype,
    string line,
    bool completed
)
public:
virtual PythonClassInfo^ GetExpressionType(
    Dictionary<String^, String^>^ variableAndtype,
    String^ line,
    bool completed
) sealed

Parameters

variableAndtype
Type: System.Collections.GenericDictionaryString, String
line
Type: SystemString
completed
Type: SystemBoolean

Return Value

Type: PythonClassInfo

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PythonIntellisense.GetExpressionType(System.Collections.Generic.Dictionary{System.String,System.String},System.String,System.Boolean)"]

Implements

IPythonIntellisenseGetExpressionType(DictionaryString, String, String, Boolean)
See Also

Reference

PythonIntellisense Class
VisualComponents.UX.Shared Namespace


PythonIntellisense.GetHelpers Method

PythonIntellisenseGetHelpers Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<string> GetHelpers(
    string text
)
public:
virtual List<String^>^ GetHelpers(
    String^ text
) sealed

Parameters

text
Type: SystemString

Return Value

Type: ListString

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.PythonIntellisense.GetHelpers(System.String)"]

Implements

IPythonIntellisenseGetHelpers(String)
See Also

Reference

PythonIntellisense Class
VisualComponents.UX.Shared Namespace


PythonRibbonTab Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.SharedBaseActionItem
VisualComponents.UX.SharedActionItem Boolean
VisualComponents.UX.SharedPythonActionItem
VisualComponents.UX.SharedPythonRibbonTab

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class PythonRibbonTab : PythonActionItem,
    IRibbonTab
public ref class PythonRibbonTab : public PythonActionItem,
    IRibbonTab

The PythonRibbonTab type exposes the following members.

Constructors
 | Name | Description
Public method | PythonRibbonTab | Initializes a new instance of the PythonRibbonTab class
Top
Properties
 | Name | Description
Public property | ActiveAction | Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this). (Inherited from BaseActionItem.)
Protected property | Application | (Inherited from BaseActionItem.)
Public property | AttachTo | (Inherited from BaseActionItem.)
Public property | ButtonMaxWidth | (Inherited from BaseActionItem.)
Public property | ButtonMinWidth | (Inherited from BaseActionItem.)
Public property | ButtonWidth | (Inherited from BaseActionItem.)
Public property | CanExecute | (Inherited from BaseActionItem.)
Protected property | canExecuteAction | Similar to canExecute. This is provided for Visual Basic compatibility. (Inherited from BaseActionItem.)
Public property | CollapseWhenDeactivated | (Inherited from BaseActionItem.)
Public property | CommandRegistry | This references is assigned by CommandRegistry on startup. (Inherited from BaseActionItem.)
Public property | Content | (Inherited from BaseActionItem.)
Public property | Context | (Inherited from BaseActionItem.)
Public property | ContextFilter | (Inherited from BaseActionItem.)
Public property | ContextualTabGroupKey |
Public property | ControlType | (Inherited from BaseActionItem.)
Public property | Customization | (Inherited from BaseActionItem.)
Protected property | EventMng | Event aggregator (Inherited from BaseActionItem.)
Public property | Header |
Public property | Icon | (Inherited from BaseActionItem.)
Public property | IconName | (Inherited from BaseActionItem.)
Public property | Id | (Inherited from BaseActionItem.)
Public property | ImageSource | (Inherited from BaseActionItem.)
Public property | IsActivated | (Inherited from BaseActionItem.)
Public property | IsBackgroundVisible | (Inherited from BaseActionItem.)
Public property | IsChecked | IsChecked status (Inherited from PythonActionItem.)
Public property | IsColoredIcon | (Inherited from BaseActionItem.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsQatCommonTool | (Inherited from BaseActionItem.)
Public property | IsToolNotInRibbon | (Inherited from BaseActionItem.)
Public property | Localization | (Inherited from BaseActionItem.)
Public property | Name |
Public property | Order |
Public property | RibbonGroups |
Public property | RibbonId | (Inherited from BaseActionItem.)
Public property | SetupInfo | (Inherited from PythonActionItem.)
Public property | SiteOrder | (Inherited from BaseActionItem.)
Protected property | SkipAbortWhenExecuted | If true, action will not abort currently executing action. (Inherited from BaseActionItem.)
Public property | Tag | (Inherited from BaseActionItem.)
Public property | ToolSize | (Inherited from BaseActionItem.)
Public property | ToolTipBookmark | (Inherited from BaseActionItem.)
Public property | ToolTipContent | (Inherited from BaseActionItem.)
Public property | ToolTipContentImage | (Inherited from BaseActionItem.)
Public property | ToolTipFooter | (Inherited from BaseActionItem.)
Public property | ToolTipFooterSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipFooterVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipHeader | (Inherited from BaseActionItem.)
Public property | ToolTipHeaderSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipMoreInfoUrl | (Inherited from BaseActionItem.)
Public property | ToolTipVisibility | (Inherited from BaseActionItem.)
Public property | UxConfig | (Inherited from BaseActionItem.)
Public property | UXSite | (Inherited from PythonActionItem.)
Public property | Visibility | (Inherited from BaseActionItem.)
Top
Methods
 | Name | Description
Public method | AfterExecute | (Inherited from BaseActionItem.)
Public method | BeforeExecute | (Inherited from BaseActionItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute | Updates the value of CanExecute (Inherited from BaseActionItem.)
Public method | Execute | (Inherited from PythonActionItem.)
Public method | Execute(Boolean) | The action associated to the ActionItem (Inherited from PythonActionItem.)
Public method | Execute(PropertyCollection) | (Inherited from ActionItemT1.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from ActionItemT1.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableForObject | (Inherited from BaseActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from PythonActionItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from BaseActionItem.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | OnImportsSatisfied | Overriding class should call baseclass implementation. (Inherited from BaseActionItem.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SetupBaseActionItem | (Inherited from BaseActionItem.)
Public method | SetupPythonActionItem | (Inherited from PythonActionItem.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Protected method | StartAction | Shortcut for calling CommandRegistry.StartCommandPanelAction(this). (Inherited from BaseActionItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
Fields
 | Name | Description
Protected field | _getIconPathFromFile | (Inherited from BaseActionItem.)
Protected field | _isColoredIcon | (Inherited from BaseActionItem.)
Protected field | canExecute | Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called. (Inherited from BaseActionItem.)
Protected field | executeAction | (Inherited from ActionItemT1.)
Protected field | RequestedFeatures | Contains license features requested by the action item. This collection should be populated by the implementing class. (Inherited from BaseActionItem.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


PythonRibbonTab Constructor

Initializes a new instance of the PythonRibbonTab class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PythonRibbonTab(
    string id,
    SetupPythonActionMessage message,
    string controlType = "GalleryMenuToolItem",
    bool getIconPathFromFile = true,
    bool isColoredIcon = true
)
public:
PythonRibbonTab(
    String^ id,
    SetupPythonActionMessage^ message,
    String^ controlType = L"GalleryMenuToolItem",
    bool getIconPathFromFile = true,
    bool isColoredIcon = true
)

Parameters

id
Type: SystemString
message
Type: VisualComponents.Create3DSetupPythonActionMessage
controlType (Optional)
Type: SystemString
getIconPathFromFile (Optional)
Type: SystemBoolean
isColoredIcon (Optional)
Type: SystemBoolean
See Also

Reference

PythonRibbonTab Class
VisualComponents.UX.Shared Namespace


PythonRibbonTab Properties

The PythonRibbonTab type exposes the following members.

Properties
 | Name | Description
Public property | ActiveAction | Shortcut for calling CommandRegistry.FindCommandPanelActionByCommand(this). (Inherited from BaseActionItem.)
Protected property | Application | (Inherited from BaseActionItem.)
Public property | AttachTo | (Inherited from BaseActionItem.)
Public property | ButtonMaxWidth | (Inherited from BaseActionItem.)
Public property | ButtonMinWidth | (Inherited from BaseActionItem.)
Public property | ButtonWidth | (Inherited from BaseActionItem.)
Public property | CanExecute | (Inherited from BaseActionItem.)
Protected property | canExecuteAction | Similar to canExecute. This is provided for Visual Basic compatibility. (Inherited from BaseActionItem.)
Public property | CollapseWhenDeactivated | (Inherited from BaseActionItem.)
Public property | CommandRegistry | This references is assigned by CommandRegistry on startup. (Inherited from BaseActionItem.)
Public property | Content | (Inherited from BaseActionItem.)
Public property | Context | (Inherited from BaseActionItem.)
Public property | ContextFilter | (Inherited from BaseActionItem.)
Public property | ContextualTabGroupKey |
Public property | ControlType | (Inherited from BaseActionItem.)
Public property | Customization | (Inherited from BaseActionItem.)
Protected property | EventMng | Event aggregator (Inherited from BaseActionItem.)
Public property | Header |
Public property | Icon | (Inherited from BaseActionItem.)
Public property | IconName | (Inherited from BaseActionItem.)
Public property | Id | (Inherited from BaseActionItem.)
Public property | ImageSource | (Inherited from BaseActionItem.)
Public property | IsActivated | (Inherited from BaseActionItem.)
Public property | IsBackgroundVisible | (Inherited from BaseActionItem.)
Public property | IsChecked | IsChecked status (Inherited from PythonActionItem.)
Public property | IsColoredIcon | (Inherited from BaseActionItem.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsQatCommonTool | (Inherited from BaseActionItem.)
Public property | IsToolNotInRibbon | (Inherited from BaseActionItem.)
Public property | Localization | (Inherited from BaseActionItem.)
Public property | Name |
Public property | Order |
Public property | RibbonGroups |
Public property | RibbonId | (Inherited from BaseActionItem.)
Public property | SetupInfo | (Inherited from PythonActionItem.)
Public property | SiteOrder | (Inherited from BaseActionItem.)
Protected property | SkipAbortWhenExecuted | If true, action will not abort currently executing action. (Inherited from BaseActionItem.)
Public property | Tag | (Inherited from BaseActionItem.)
Public property | ToolSize | (Inherited from BaseActionItem.)
Public property | ToolTipBookmark | (Inherited from BaseActionItem.)
Public property | ToolTipContent | (Inherited from BaseActionItem.)
Public property | ToolTipContentImage | (Inherited from BaseActionItem.)
Public property | ToolTipFooter | (Inherited from BaseActionItem.)
Public property | ToolTipFooterSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipFooterVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipHeader | (Inherited from BaseActionItem.)
Public property | ToolTipHeaderSeparatorVisibility | (Inherited from BaseActionItem.)
Public property | ToolTipMoreInfoUrl | (Inherited from BaseActionItem.)
Public property | ToolTipVisibility | (Inherited from BaseActionItem.)
Public property | UxConfig | (Inherited from BaseActionItem.)
Public property | UXSite | (Inherited from PythonActionItem.)
Public property | Visibility | (Inherited from BaseActionItem.)
Top
See Also

Reference

PythonRibbonTab Class
VisualComponents.UX.Shared Namespace


PythonRibbonTab.ContextualTabGroupKey Property

PythonRibbonTabContextualTabGroupKey Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ContextualTabGroupKey { get; protected set; }
public:
virtual property String^ ContextualTabGroupKey {
    String^ get () sealed;
    protected: void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IRibbonTabContextualTabGroupKey
See Also

Reference

PythonRibbonTab Class
VisualComponents.UX.Shared Namespace


PythonRibbonTab.Header Property

PythonRibbonTabHeader Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Header { get; protected set; }
public:
virtual property String^ Header {
    String^ get () sealed;
    protected: void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IRibbonTabHeader
See Also

Reference

PythonRibbonTab Class
VisualComponents.UX.Shared Namespace


PythonRibbonTab.Name Property

PythonRibbonTabName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; protected set; }
public:
virtual property String^ Name {
    String^ get () sealed;
    protected: void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IRibbonTabName
See Also

Reference

PythonRibbonTab Class
VisualComponents.UX.Shared Namespace


PythonRibbonTab.Order Property

PythonRibbonTabOrder Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Order { get; protected set; }
public:
virtual property double Order {
    double get () sealed;
    protected: void set (double value) sealed;
}

Property Value

Type: Double

Implements

IRibbonTabOrder
See Also

Reference

PythonRibbonTab Class
VisualComponents.UX.Shared Namespace


PythonRibbonTab.RibbonGroups Property

PythonRibbonTabRibbonGroups Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObservableCollection<IRibbonGroup> RibbonGroups { get; protected set; }
public:
virtual property ObservableCollection<IRibbonGroup^>^ RibbonGroups {
    ObservableCollection<IRibbonGroup^>^ get () sealed;
    protected: void set (ObservableCollection<IRibbonGroup^>^ value) sealed;
}

Property Value

Type: ObservableCollectionIRibbonGroup

Implements

IRibbonTabRibbonGroups
See Also

Reference

PythonRibbonTab Class
VisualComponents.UX.Shared Namespace


PythonRibbonTab Methods

The PythonRibbonTab type exposes the following members.

Methods
 | Name | Description
Public method | AfterExecute | (Inherited from BaseActionItem.)
Public method | BeforeExecute | (Inherited from BaseActionItem.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateCanExecute | Updates the value of CanExecute (Inherited from BaseActionItem.)
Public method | Execute | (Inherited from PythonActionItem.)
Public method | Execute(Boolean) | The action associated to the ActionItem (Inherited from PythonActionItem.)
Public method | Execute(PropertyCollection) | (Inherited from ActionItemT1.)
Public method | Execute(SetupPythonActionMessage) | (Inherited from ActionItemT1.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAvailableForObject | (Inherited from BaseActionItem.)
Public method | IsAvailableInCurrentContextAndSite | (Inherited from PythonActionItem.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyAnotherActionItem | Another action item will be evaluated by calling EvaluateCanExecute (Inherited from BaseActionItem.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Public method | OnImportsSatisfied | Overriding class should call baseclass implementation. (Inherited from BaseActionItem.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | SetupBaseActionItem | (Inherited from BaseActionItem.)
Public method | SetupPythonActionItem | (Inherited from PythonActionItem.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Protected method | StartAction | Shortcut for calling CommandRegistry.StartCommandPanelAction(this). (Inherited from BaseActionItem.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

PythonRibbonTab Class
VisualComponents.UX.Shared Namespace


PythonRibbonTab Events

The PythonRibbonTab type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
See Also

Reference

PythonRibbonTab Class
VisualComponents.UX.Shared Namespace


PythonRibbonTab Fields

The PythonRibbonTab type exposes the following members.

Fields
 | Name | Description
Protected field | _getIconPathFromFile | (Inherited from BaseActionItem.)
Protected field | _isColoredIcon | (Inherited from BaseActionItem.)
Protected field | canExecute | Function which defines if this action can be executed. The return value of this method is evaluted when EvaluateCanExecute method is called. (Inherited from BaseActionItem.)
Protected field | executeAction | (Inherited from ActionItemT1.)
Protected field | RequestedFeatures | Contains license features requested by the action item. This collection should be populated by the implementing class. (Inherited from BaseActionItem.)
Top
See Also

Reference

PythonRibbonTab Class
VisualComponents.UX.Shared Namespace


QatRibbonGroupsConfigCollection Class

Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationElementCollection
VisualComponents.UX.SharedQatRibbonGroupsConfigCollection

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class QatRibbonGroupsConfigCollection : ConfigurationElementCollection
public ref class QatRibbonGroupsConfigCollection sealed : public ConfigurationElementCollection

The QatRibbonGroupsConfigCollection type exposes the following members.

Constructors
 | Name | Description
Public method | QatRibbonGroupsConfigCollection | Initializes a new instance of the QatRibbonGroupsConfigCollection class
Top
Properties
 | Name | Description
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Public property | Item |
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Top
Methods
 | Name | Description
Public method | Add |
Public method | Clear |
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf |
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Public method | Remove |
Public method | RemoveAt |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


QatRibbonGroupsConfigCollection Constructor

Initializes a new instance of the QatRibbonGroupsConfigCollection class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public QatRibbonGroupsConfigCollection()
public:
QatRibbonGroupsConfigCollection()
See Also

Reference

QatRibbonGroupsConfigCollection Class
VisualComponents.UX.Shared Namespace


QatRibbonGroupsConfigCollection Properties

The QatRibbonGroupsConfigCollection type exposes the following members.

Properties
 | Name | Description
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Public property | Item |
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Top
See Also

Reference

QatRibbonGroupsConfigCollection Class
VisualComponents.UX.Shared Namespace


QatRibbonGroupsConfigCollection.Item Property

QatRibbonGroupsConfigCollectionItem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public QatRibbonGroupsConfigElement this[
    int index
] { get; set; }
public:
property QatRibbonGroupsConfigElement^ default[int index] {
    QatRibbonGroupsConfigElement^ get (int index);
    void set (int index, QatRibbonGroupsConfigElement^ value);
}

Parameters

index
Type: SystemInt32

Property Value

Type: QatRibbonGroupsConfigElement
See Also

Reference

QatRibbonGroupsConfigCollection Class
VisualComponents.UX.Shared Namespace


QatRibbonGroupsConfigCollection Methods

The QatRibbonGroupsConfigCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Public method | Clear |
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf |
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Public method | Remove |
Public method | RemoveAt |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

QatRibbonGroupsConfigCollection Class
VisualComponents.UX.Shared Namespace


QatRibbonGroupsConfigCollection.Add Method

QatRibbonGroupsConfigCollectionAdd Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Add(
    QatRibbonGroupsConfigElement element
)
public:
void Add(
    QatRibbonGroupsConfigElement^ element
)

Parameters

element
Type: VisualComponents.UX.SharedQatRibbonGroupsConfigElement
See Also

Reference

QatRibbonGroupsConfigCollection Class
VisualComponents.UX.Shared Namespace


QatRibbonGroupsConfigCollection.Clear Method

QatRibbonGroupsConfigCollectionClear Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Clear()
public:
void Clear()
See Also

Reference

QatRibbonGroupsConfigCollection Class
VisualComponents.UX.Shared Namespace


QatRibbonGroupsConfigCollection.IndexOf Method

QatRibbonGroupsConfigCollectionIndexOf Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int IndexOf(
    QatRibbonGroupsConfigElement element
)
public:
int IndexOf(
    QatRibbonGroupsConfigElement^ element
)

Parameters

element
Type: VisualComponents.UX.SharedQatRibbonGroupsConfigElement

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.QatRibbonGroupsConfigCollection.IndexOf(VisualComponents.UX.Shared.QatRibbonGroupsConfigElement)"]

See Also

Reference

QatRibbonGroupsConfigCollection Class
VisualComponents.UX.Shared Namespace


QatRibbonGroupsConfigCollection.Remove Method

QatRibbonGroupsConfigCollectionRemove Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Remove(
    QatRibbonGroupsConfigElement element
)
public:
void Remove(
    QatRibbonGroupsConfigElement^ element
)

Parameters

element
Type: VisualComponents.UX.SharedQatRibbonGroupsConfigElement
See Also

Reference

QatRibbonGroupsConfigCollection Class
VisualComponents.UX.Shared Namespace


QatRibbonGroupsConfigCollection.RemoveAt Method

QatRibbonGroupsConfigCollectionRemoveAt Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RemoveAt(
    int index
)
public:
void RemoveAt(
    int index
)

Parameters

index
Type: SystemInt32
See Also

Reference

QatRibbonGroupsConfigCollection Class
VisualComponents.UX.Shared Namespace


QatRibbonGroupsConfigElement Class

Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.UX.SharedQatRibbonGroupsConfigElement

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class QatRibbonGroupsConfigElement : ConfigurationElement
public ref class QatRibbonGroupsConfigElement sealed : public ConfigurationElement

The QatRibbonGroupsConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | QatRibbonGroupsConfigElement | Initializes a new instance of the QatRibbonGroupsConfigElement class
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | Id |
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


QatRibbonGroupsConfigElement Constructor

Initializes a new instance of the QatRibbonGroupsConfigElement class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public QatRibbonGroupsConfigElement()
public:
QatRibbonGroupsConfigElement()
See Also

Reference

QatRibbonGroupsConfigElement Class
VisualComponents.UX.Shared Namespace


QatRibbonGroupsConfigElement Properties

The QatRibbonGroupsConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | Id |
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Top
See Also

Reference

QatRibbonGroupsConfigElement Class
VisualComponents.UX.Shared Namespace


QatRibbonGroupsConfigElement.Id Property

QatRibbonGroupsConfigElementId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Id { get; set; }
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

QatRibbonGroupsConfigElement Class
VisualComponents.UX.Shared Namespace


QatRibbonGroupsConfigElement Methods

The QatRibbonGroupsConfigElement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

QatRibbonGroupsConfigElement Class
VisualComponents.UX.Shared Namespace


QatRibbonToolsConfigCollection Class

Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationElementCollection
VisualComponents.UX.SharedQatRibbonToolsConfigCollection

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class QatRibbonToolsConfigCollection : ConfigurationElementCollection
public ref class QatRibbonToolsConfigCollection sealed : public ConfigurationElementCollection

The QatRibbonToolsConfigCollection type exposes the following members.

Constructors
 | Name | Description
Public method | QatRibbonToolsConfigCollection | Initializes a new instance of the QatRibbonToolsConfigCollection class
Top
Properties
 | Name | Description
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Public property | Item |
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Top
Methods
 | Name | Description
Public method | Add |
Public method | Clear |
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf |
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Public method | Remove |
Public method | RemoveAt |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


QatRibbonToolsConfigCollection Constructor

Initializes a new instance of the QatRibbonToolsConfigCollection class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public QatRibbonToolsConfigCollection()
public:
QatRibbonToolsConfigCollection()
See Also

Reference

QatRibbonToolsConfigCollection Class
VisualComponents.UX.Shared Namespace


QatRibbonToolsConfigCollection Properties

The QatRibbonToolsConfigCollection type exposes the following members.

Properties
 | Name | Description
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Public property | Item |
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Top
See Also

Reference

QatRibbonToolsConfigCollection Class
VisualComponents.UX.Shared Namespace


QatRibbonToolsConfigCollection.Item Property

QatRibbonToolsConfigCollectionItem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public QatRibbonToolsConfigElement this[
    int index
] { get; set; }
public:
property QatRibbonToolsConfigElement^ default[int index] {
    QatRibbonToolsConfigElement^ get (int index);
    void set (int index, QatRibbonToolsConfigElement^ value);
}

Parameters

index
Type: SystemInt32

Property Value

Type: QatRibbonToolsConfigElement
See Also

Reference

QatRibbonToolsConfigCollection Class
VisualComponents.UX.Shared Namespace


QatRibbonToolsConfigCollection Methods

The QatRibbonToolsConfigCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Public method | Clear |
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf |
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Public method | Remove |
Public method | RemoveAt |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

QatRibbonToolsConfigCollection Class
VisualComponents.UX.Shared Namespace


QatRibbonToolsConfigCollection.Add Method

QatRibbonToolsConfigCollectionAdd Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Add(
    QatRibbonToolsConfigElement element
)
public:
void Add(
    QatRibbonToolsConfigElement^ element
)

Parameters

element
Type: VisualComponents.UX.SharedQatRibbonToolsConfigElement
See Also

Reference

QatRibbonToolsConfigCollection Class
VisualComponents.UX.Shared Namespace


QatRibbonToolsConfigCollection.Clear Method

QatRibbonToolsConfigCollectionClear Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Clear()
public:
void Clear()
See Also

Reference

QatRibbonToolsConfigCollection Class
VisualComponents.UX.Shared Namespace


QatRibbonToolsConfigCollection.IndexOf Method

QatRibbonToolsConfigCollectionIndexOf Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int IndexOf(
    QatRibbonToolsConfigElement element
)
public:
int IndexOf(
    QatRibbonToolsConfigElement^ element
)

Parameters

element
Type: VisualComponents.UX.SharedQatRibbonToolsConfigElement

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.QatRibbonToolsConfigCollection.IndexOf(VisualComponents.UX.Shared.QatRibbonToolsConfigElement)"]

See Also

Reference

QatRibbonToolsConfigCollection Class
VisualComponents.UX.Shared Namespace


QatRibbonToolsConfigCollection.Remove Method

QatRibbonToolsConfigCollectionRemove Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Remove(
    QatRibbonToolsConfigElement element
)
public:
void Remove(
    QatRibbonToolsConfigElement^ element
)

Parameters

element
Type: VisualComponents.UX.SharedQatRibbonToolsConfigElement
See Also

Reference

QatRibbonToolsConfigCollection Class
VisualComponents.UX.Shared Namespace


QatRibbonToolsConfigCollection.RemoveAt Method

QatRibbonToolsConfigCollectionRemoveAt Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RemoveAt(
    int index
)
public:
void RemoveAt(
    int index
)

Parameters

index
Type: SystemInt32
See Also

Reference

QatRibbonToolsConfigCollection Class
VisualComponents.UX.Shared Namespace


QatRibbonToolsConfigElement Class

Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.UX.SharedQatRibbonToolsConfigElement

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class QatRibbonToolsConfigElement : ConfigurationElement
public ref class QatRibbonToolsConfigElement sealed : public ConfigurationElement

The QatRibbonToolsConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | QatRibbonToolsConfigElement | Initializes a new instance of the QatRibbonToolsConfigElement class
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | Id |
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


QatRibbonToolsConfigElement Constructor

Initializes a new instance of the QatRibbonToolsConfigElement class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public QatRibbonToolsConfigElement()
public:
QatRibbonToolsConfigElement()
See Also

Reference

QatRibbonToolsConfigElement Class
VisualComponents.UX.Shared Namespace


QatRibbonToolsConfigElement Properties

The QatRibbonToolsConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | Id |
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Top
See Also

Reference

QatRibbonToolsConfigElement Class
VisualComponents.UX.Shared Namespace


QatRibbonToolsConfigElement.Id Property

QatRibbonToolsConfigElementId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Id { get; set; }
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

QatRibbonToolsConfigElement Class
VisualComponents.UX.Shared Namespace


QatRibbonToolsConfigElement Methods

The QatRibbonToolsConfigElement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

QatRibbonToolsConfigElement Class
VisualComponents.UX.Shared Namespace


QuickMenu Class

Interaction logic for QuickMenu.xaml
QuickMenu
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedExtendedUserControl
VisualComponents.UX.SharedQuickMenu

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class QuickMenu : ExtendedUserControl, IComponentConnector
public ref class QuickMenu : public ExtendedUserControl,
    IComponentConnector

The QuickMenu type exposes the following members.

Constructors
 | Name | Description
Public method | QuickMenu | Initializes a new instance of the QuickMenu class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XPosition | (Inherited from ExtendedUserControl.)
Public property | YPosition | (Inherited from ExtendedUserControl.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from ExtendedUserControl.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


QuickMenu Constructor

Initializes a new instance of the QuickMenu class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public QuickMenu()
public:
QuickMenu()
See Also

Reference

QuickMenu Class
VisualComponents.UX.Shared Namespace


QuickMenu Properties

The QuickMenu type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | XPosition | (Inherited from ExtendedUserControl.)
Public property | YPosition | (Inherited from ExtendedUserControl.)
Top
See Also

Reference

QuickMenu Class
VisualComponents.UX.Shared Namespace


QuickMenu Methods

The QuickMenu type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Inherited from ExtendedUserControl.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

QuickMenu Class
VisualComponents.UX.Shared Namespace


QuickMenu.InitializeComponent Method

QuickMenuInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

QuickMenu Class
VisualComponents.UX.Shared Namespace


QuickMenu Events

The QuickMenu type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

QuickMenu Class
VisualComponents.UX.Shared Namespace


QuickMenuActionItemDataTemplateSelector Class

This DataTemplateSelector is responsible for resolving template for ribbon Commands.
Inheritance Hierarchy
SystemObject
System.Windows.ControlsDataTemplateSelector
VisualComponents.UX.SharedQuickMenuActionItemDataTemplateSelector

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class QuickMenuActionItemDataTemplateSelector : DataTemplateSelector
public ref class QuickMenuActionItemDataTemplateSelector sealed : public DataTemplateSelector

The QuickMenuActionItemDataTemplateSelector type exposes the following members.

Constructors
 | Name | Description
Public method | QuickMenuActionItemDataTemplateSelector | Initializes a new instance of the QuickMenuActionItemDataTemplateSelector class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SelectTemplate | (Overrides DataTemplateSelectorSelectTemplate(Object, DependencyObject).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


QuickMenuActionItemDataTemplateSelector Constructor

Initializes a new instance of the QuickMenuActionItemDataTemplateSelector class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public QuickMenuActionItemDataTemplateSelector()
public:
QuickMenuActionItemDataTemplateSelector()
See Also

Reference

QuickMenuActionItemDataTemplateSelector Class
VisualComponents.UX.Shared Namespace


QuickMenuActionItemDataTemplateSelector Methods

The QuickMenuActionItemDataTemplateSelector type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SelectTemplate | (Overrides DataTemplateSelectorSelectTemplate(Object, DependencyObject).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

QuickMenuActionItemDataTemplateSelector Class
VisualComponents.UX.Shared Namespace


QuickMenuActionItemDataTemplateSelector.SelectTemplate Method

QuickMenuActionItemDataTemplateSelectorSelectTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override DataTemplate SelectTemplate(
    Object item,
    DependencyObject container
)
public:
virtual DataTemplate^ SelectTemplate(
    Object^ item,
    DependencyObject^ container
) override

Parameters

item
Type: SystemObject
container
Type: System.WindowsDependencyObject

Return Value

Type: DataTemplate

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.QuickMenuActionItemDataTemplateSelector.SelectTemplate(System.Object,System.Windows.DependencyObject)"]

See Also

Reference

QuickMenuActionItemDataTemplateSelector Class
VisualComponents.UX.Shared Namespace


QuickMenuDisplayMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedQuickMenuDisplayMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class QuickMenuDisplayMessage
public ref class QuickMenuDisplayMessage

The QuickMenuDisplayMessage type exposes the following members.

Constructors
 | Name | Description
Public method | QuickMenuDisplayMessage | Initializes a new instance of the QuickMenuDisplayMessage class
Top
Properties
 | Name | Description
Public property | PickPoint |
Public property | PickResult |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


QuickMenuDisplayMessage Constructor

Initializes a new instance of the QuickMenuDisplayMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public QuickMenuDisplayMessage()
public:
QuickMenuDisplayMessage()
See Also

Reference

QuickMenuDisplayMessage Class
VisualComponents.UX.Shared Namespace


QuickMenuDisplayMessage Properties

The QuickMenuDisplayMessage type exposes the following members.

Properties
 | Name | Description
Public property | PickPoint |
Public property | PickResult |
Top
See Also

Reference

QuickMenuDisplayMessage Class
VisualComponents.UX.Shared Namespace


QuickMenuDisplayMessage.PickPoint Property

QuickMenuDisplayMessagePickPoint Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 PickPoint { get; set; }
public:
property Vector3 PickPoint {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

QuickMenuDisplayMessage Class
VisualComponents.UX.Shared Namespace


QuickMenuDisplayMessage.PickResult Property

QuickMenuDisplayMessagePickResult Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PickResult PickResult { get; set; }
public:
property PickResult PickResult {
    PickResult get ();
    void set (PickResult value);
}

Property Value

Type: PickResult
See Also

Reference

QuickMenuDisplayMessage Class
VisualComponents.UX.Shared Namespace


QuickMenuDisplayMessage Methods

The QuickMenuDisplayMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

QuickMenuDisplayMessage Class
VisualComponents.UX.Shared Namespace


RawMouseArgs Class

Raw mouse arguments.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.UX.SharedRawMouseArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RawMouseArgs : EventArgs
public ref class RawMouseArgs : public EventArgs

The RawMouseArgs type exposes the following members.

Constructors
 | Name | Description
Public method | RawMouseArgs(MouseButton) | Create raw mouse arguments.
Public method | RawMouseArgs(Point) | Create raw mouse arguments.
Public method | RawMouseArgs(MouseButton, Point) | Create raw mouse arguments.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Button | Button of mouse
Public field | Position | Position of the mouse in screen coordinates.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RawMouseArgs Constructor

Overload List
 | Name | Description
Public method | RawMouseArgs(MouseButton) | Create raw mouse arguments.
Public method | RawMouseArgs(Point) | Create raw mouse arguments.
Public method | RawMouseArgs(MouseButton, Point) | Create raw mouse arguments.
Top
See Also

Reference

RawMouseArgs Class
VisualComponents.UX.Shared Namespace


RawMouseArgs Constructor (MouseButton)

Create raw mouse arguments.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RawMouseArgs(
    MouseButton button
)
public:
RawMouseArgs(
    MouseButton button
)

Parameters

button
Type: System.Windows.InputMouseButton
Position of mouse in screen coordinates.
See Also

Reference

RawMouseArgs Class
RawMouseArgs Overload
VisualComponents.UX.Shared Namespace


RawMouseArgs Constructor (Point)

Create raw mouse arguments.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RawMouseArgs(
    Point position
)
public:
RawMouseArgs(
    Point position
)

Parameters

position
Type: System.WindowsPoint
Position of mouse in screen coordinates.
See Also

Reference

RawMouseArgs Class
RawMouseArgs Overload
VisualComponents.UX.Shared Namespace


RawMouseArgs Constructor (MouseButton, Point)

Create raw mouse arguments.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RawMouseArgs(
    MouseButton button,
    Point position
)
public:
RawMouseArgs(
    MouseButton button,
    Point position
)

Parameters

button
Type: System.Windows.InputMouseButton
position
Type: System.WindowsPoint
Position of mouse in screen coordinates.
See Also

Reference

RawMouseArgs Class
RawMouseArgs Overload
VisualComponents.UX.Shared Namespace


RawMouseArgs Methods

The RawMouseArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RawMouseArgs Class
VisualComponents.UX.Shared Namespace


RawMouseArgs Fields

The RawMouseArgs type exposes the following members.

Fields
 | Name | Description
Public field | Button | Button of mouse
Public field | Position | Position of the mouse in screen coordinates.
Top
See Also

Reference

RawMouseArgs Class
VisualComponents.UX.Shared Namespace


RawMouseArgs.Button Field

RawMouseArgsButton Field

Button of mouse

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MouseButton Button
public:
MouseButton Button

Field Value

Type: MouseButton
See Also

Reference

RawMouseArgs Class
VisualComponents.UX.Shared Namespace


RawMouseArgs.Position Field

RawMouseArgsPosition Field

Position of the mouse in screen coordinates.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Point Position
public:
Point Position

Field Value

Type: Point
See Also

Reference

RawMouseArgs Class
VisualComponents.UX.Shared Namespace


RawMouseDownHandler Delegate

Raw mouse down handler.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public delegate void RawMouseDownHandler(
    Object sender,
    RawMouseArgs args
)
public delegate void RawMouseDownHandler(
    Object^ sender,
    RawMouseArgs^ args
)

Parameters

sender
Type: SystemObject
sender
args
Type: VisualComponents.UX.SharedRawMouseArgs
raw mouse arguments
See Also

Reference

VisualComponents.UX.Shared Namespace


RawMouseMoveHandler Delegate

Raw mouse move handler.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public delegate void RawMouseMoveHandler(
    Object sender,
    RawMouseArgs args
)
public delegate void RawMouseMoveHandler(
    Object^ sender,
    RawMouseArgs^ args
)

Parameters

sender
Type: SystemObject
sender
args
Type: VisualComponents.UX.SharedRawMouseArgs
raw mouse arguments
See Also

Reference

VisualComponents.UX.Shared Namespace


RecentDocumentConfigCollection Class

Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationElementCollection
VisualComponents.UX.SharedRecentDocumentConfigCollection

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class RecentDocumentConfigCollection : ConfigurationElementCollection
public ref class RecentDocumentConfigCollection sealed : public ConfigurationElementCollection

The RecentDocumentConfigCollection type exposes the following members.

Constructors
 | Name | Description
Public method | RecentDocumentConfigCollection | Initializes a new instance of the RecentDocumentConfigCollection class
Top
Properties
 | Name | Description
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Public property | Item |
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Top
Methods
 | Name | Description
Public method | Add |
Public method | Clear |
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf |
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Public method | Remove |
Public method | RemoveAt |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RecentDocumentConfigCollection Constructor

Initializes a new instance of the RecentDocumentConfigCollection class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RecentDocumentConfigCollection()
public:
RecentDocumentConfigCollection()
See Also

Reference

RecentDocumentConfigCollection Class
VisualComponents.UX.Shared Namespace


RecentDocumentConfigCollection Properties

The RecentDocumentConfigCollection type exposes the following members.

Properties
 | Name | Description
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Public property | Item |
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Top
See Also

Reference

RecentDocumentConfigCollection Class
VisualComponents.UX.Shared Namespace


RecentDocumentConfigCollection.Item Property

RecentDocumentConfigCollectionItem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RecentDocumentConfigElement this[
    int index
] { get; set; }
public:
property RecentDocumentConfigElement^ default[int index] {
    RecentDocumentConfigElement^ get (int index);
    void set (int index, RecentDocumentConfigElement^ value);
}

Parameters

index
Type: SystemInt32

Property Value

Type: RecentDocumentConfigElement
See Also

Reference

RecentDocumentConfigCollection Class
VisualComponents.UX.Shared Namespace


RecentDocumentConfigCollection Methods

The RecentDocumentConfigCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Public method | Clear |
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf |
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Public method | Remove |
Public method | RemoveAt |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RecentDocumentConfigCollection Class
VisualComponents.UX.Shared Namespace


RecentDocumentConfigCollection.Add Method

RecentDocumentConfigCollectionAdd Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Add(
    RecentDocumentConfigElement element
)
public:
void Add(
    RecentDocumentConfigElement^ element
)

Parameters

element
Type: VisualComponents.UX.SharedRecentDocumentConfigElement
See Also

Reference

RecentDocumentConfigCollection Class
VisualComponents.UX.Shared Namespace


RecentDocumentConfigCollection.Clear Method

RecentDocumentConfigCollectionClear Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Clear()
public:
void Clear()
See Also

Reference

RecentDocumentConfigCollection Class
VisualComponents.UX.Shared Namespace


RecentDocumentConfigCollection.IndexOf Method

RecentDocumentConfigCollectionIndexOf Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int IndexOf(
    RecentDocumentConfigElement element
)
public:
int IndexOf(
    RecentDocumentConfigElement^ element
)

Parameters

element
Type: VisualComponents.UX.SharedRecentDocumentConfigElement

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.RecentDocumentConfigCollection.IndexOf(VisualComponents.UX.Shared.RecentDocumentConfigElement)"]

See Also

Reference

RecentDocumentConfigCollection Class
VisualComponents.UX.Shared Namespace


RecentDocumentConfigCollection.Remove Method

RecentDocumentConfigCollectionRemove Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Remove(
    RecentDocumentConfigElement element
)
public:
void Remove(
    RecentDocumentConfigElement^ element
)

Parameters

element
Type: VisualComponents.UX.SharedRecentDocumentConfigElement
See Also

Reference

RecentDocumentConfigCollection Class
VisualComponents.UX.Shared Namespace


RecentDocumentConfigCollection.RemoveAt Method

RecentDocumentConfigCollectionRemoveAt Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RemoveAt(
    int index
)
public:
void RemoveAt(
    int index
)

Parameters

index
Type: SystemInt32
See Also

Reference

RecentDocumentConfigCollection Class
VisualComponents.UX.Shared Namespace


RecentDocumentConfigElement Class

Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.UX.SharedRecentDocumentConfigElement

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class RecentDocumentConfigElement : ConfigurationElement
public ref class RecentDocumentConfigElement sealed : public ConfigurationElement

The RecentDocumentConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | RecentDocumentConfigElement | Initializes a new instance of the RecentDocumentConfigElement class
Top
Properties
 | Name | Description
Public property | CreatedOrModifiedTime |
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | FilePath |
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RecentDocumentConfigElement Constructor

Initializes a new instance of the RecentDocumentConfigElement class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RecentDocumentConfigElement()
public:
RecentDocumentConfigElement()
See Also

Reference

RecentDocumentConfigElement Class
VisualComponents.UX.Shared Namespace


RecentDocumentConfigElement Properties

The RecentDocumentConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CreatedOrModifiedTime |
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | FilePath |
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Top
See Also

Reference

RecentDocumentConfigElement Class
VisualComponents.UX.Shared Namespace


RecentDocumentConfigElement.CreatedOrModifiedTime Property

RecentDocumentConfigElementCreatedOrModifiedTime Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DateTime CreatedOrModifiedTime { get; set; }
public:
property DateTime CreatedOrModifiedTime {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
See Also

Reference

RecentDocumentConfigElement Class
VisualComponents.UX.Shared Namespace


RecentDocumentConfigElement.FilePath Property

RecentDocumentConfigElementFilePath Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string FilePath { get; set; }
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

RecentDocumentConfigElement Class
VisualComponents.UX.Shared Namespace


RecentDocumentConfigElement Methods

The RecentDocumentConfigElement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RecentDocumentConfigElement Class
VisualComponents.UX.Shared Namespace


RecentDocumentSection Class

Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationSection
VisualComponents.UX.SharedRecentDocumentSection

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class RecentDocumentSection : ConfigurationSection,
    IRecentDocumentSection, ISection
public ref class RecentDocumentSection sealed : public ConfigurationSection,
    IRecentDocumentSection, ISection

The RecentDocumentSection type exposes the following members.

Constructors
 | Name | Description
Public method | RecentDocumentSection | Initializes a new instance of the RecentDocumentSection class
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | RecentDocuments |
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName |
Public property | SectionType |
Public property | SectionVersion |
Top
Methods
 | Name | Description
Public method | CheckVersion |
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RecentDocumentSection Constructor

Initializes a new instance of the RecentDocumentSection class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RecentDocumentSection()
public:
RecentDocumentSection()
See Also

Reference

RecentDocumentSection Class
VisualComponents.UX.Shared Namespace


RecentDocumentSection Properties

The RecentDocumentSection type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | RecentDocuments |
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName |
Public property | SectionType |
Public property | SectionVersion |
Top
See Also

Reference

RecentDocumentSection Class
VisualComponents.UX.Shared Namespace


RecentDocumentSection.RecentDocuments Property

RecentDocumentSectionRecentDocuments Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RecentDocumentConfigCollection RecentDocuments { get; }
public:
virtual property RecentDocumentConfigCollection^ RecentDocuments {
    RecentDocumentConfigCollection^ get () sealed;
}

Property Value

Type: RecentDocumentConfigCollection

Implements

IRecentDocumentSectionRecentDocuments
See Also

Reference

RecentDocumentSection Class
VisualComponents.UX.Shared Namespace


RecentDocumentSection.SectionName Property

RecentDocumentSectionSectionName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SectionName { get; }
public:
virtual property String^ SectionName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ISectionSectionName
See Also

Reference

RecentDocumentSection Class
VisualComponents.UX.Shared Namespace


RecentDocumentSection.SectionType Property

RecentDocumentSectionSectionType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type SectionType { get; }
public:
virtual property Type^ SectionType {
    Type^ get () sealed;
}

Property Value

Type: Type

Implements

ISectionSectionType
See Also

Reference

RecentDocumentSection Class
VisualComponents.UX.Shared Namespace


RecentDocumentSection.SectionVersion Property

RecentDocumentSectionSectionVersion Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int SectionVersion { get; }
public:
virtual property int SectionVersion {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISectionSectionVersion
See Also

Reference

RecentDocumentSection Class
VisualComponents.UX.Shared Namespace


RecentDocumentSection Methods

The RecentDocumentSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion |
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RecentDocumentSection Class
VisualComponents.UX.Shared Namespace


RecentDocumentSection.CheckVersion Method

RecentDocumentSectionCheckVersion Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CheckVersion()
public:
virtual void CheckVersion() sealed

Implements

ISectionCheckVersion
See Also

Reference

RecentDocumentSection Class
VisualComponents.UX.Shared Namespace


RecentDocumentSection.GetSection Method

RecentDocumentSectionGetSection Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISection GetSection(
    Configuration userSettingConfiguration
)
public:
virtual ISection^ GetSection(
    Configuration^ userSettingConfiguration
) sealed

Parameters

userSettingConfiguration
Type: System.ConfigurationConfiguration

Return Value

Type: ISection

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.RecentDocumentSection.GetSection(System.Configuration.Configuration)"]

Implements

ISectionGetSection(Configuration)
See Also

Reference

RecentDocumentSection Class
VisualComponents.UX.Shared Namespace


RecentDocumentSection.ToString Method

RecentDocumentSectionToString Method

Converts this instance to string.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String
String representation of this instance
See Also

Reference

RecentDocumentSection Class
VisualComponents.UX.Shared Namespace


RecentFilePresenter Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
VisualComponents.UX.SharedRecentFilePresenter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RecentFilePresenter : Control
public ref class RecentFilePresenter : public Control

The RecentFilePresenter type exposes the following members.

Constructors
 | Name | Description
Public method | RecentFilePresenter | Initializes a new instance of the RecentFilePresenter class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayPath |
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FileExtension |
Public property | FilePath |
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Header |
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IconPath |
Public property | ImageSource |
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
DisplayPathProperty |
FileExtensionProperty |
FilePathProperty |
HeaderProperty |
IconPathProperty |
ImageSourceProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RecentFilePresenter Constructor

Initializes a new instance of the RecentFilePresenter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RecentFilePresenter()
public:
RecentFilePresenter()
See Also

Reference

RecentFilePresenter Class
VisualComponents.UX.Shared Namespace


RecentFilePresenter Properties

The RecentFilePresenter type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | DisplayPath |
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FileExtension |
Public property | FilePath |
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Header |
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | IconPath |
Public property | ImageSource |
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

RecentFilePresenter Class
VisualComponents.UX.Shared Namespace


RecentFilePresenter.DisplayPath Property

RecentFilePresenterDisplayPath Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string DisplayPath { get; set; }
public:
property String^ DisplayPath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

RecentFilePresenter Class
VisualComponents.UX.Shared Namespace


RecentFilePresenter.FileExtension Property

RecentFilePresenterFileExtension Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string FileExtension { get; set; }
public:
property String^ FileExtension {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

RecentFilePresenter Class
VisualComponents.UX.Shared Namespace


RecentFilePresenter.FilePath Property

RecentFilePresenterFilePath Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string FilePath { get; set; }
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

RecentFilePresenter Class
VisualComponents.UX.Shared Namespace


RecentFilePresenter.Header Property

RecentFilePresenterHeader Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Header { get; set; }
public:
property String^ Header {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

RecentFilePresenter Class
VisualComponents.UX.Shared Namespace


RecentFilePresenter.IconPath Property

RecentFilePresenterIconPath Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string IconPath { get; set; }
public:
property String^ IconPath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

RecentFilePresenter Class
VisualComponents.UX.Shared Namespace


RecentFilePresenter.ImageSource Property

RecentFilePresenterImageSource Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ImageSource { get; set; }
public:
property String^ ImageSource {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

RecentFilePresenter Class
VisualComponents.UX.Shared Namespace


RecentFilePresenter Methods

The RecentFilePresenter type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RecentFilePresenter Class
VisualComponents.UX.Shared Namespace


RecentFilePresenter.OnApplyTemplate Method

RecentFilePresenterOnApplyTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

RecentFilePresenter Class
VisualComponents.UX.Shared Namespace


RecentFilePresenter Events

The RecentFilePresenter type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

RecentFilePresenter Class
VisualComponents.UX.Shared Namespace


RecentFilePresenter Fields

The RecentFilePresenter type exposes the following members.

Fields
Name | Description
DisplayPathProperty |
FileExtensionProperty |
FilePathProperty |
HeaderProperty |
IconPathProperty |
ImageSourceProperty |
Top
See Also

Reference

RecentFilePresenter Class
VisualComponents.UX.Shared Namespace


RecentFilePresenter.DisplayPathProperty Field

RecentFilePresenterDisplayPathProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty DisplayPathProperty
public:
static DependencyProperty^ DisplayPathProperty

Field Value

Type: DependencyProperty
See Also

Reference

RecentFilePresenter Class
VisualComponents.UX.Shared Namespace


RecentFilePresenter.FileExtensionProperty Field

RecentFilePresenterFileExtensionProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty FileExtensionProperty
public:
static DependencyProperty^ FileExtensionProperty

Field Value

Type: DependencyProperty
See Also

Reference

RecentFilePresenter Class
VisualComponents.UX.Shared Namespace


RecentFilePresenter.FilePathProperty Field

RecentFilePresenterFilePathProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty FilePathProperty
public:
static DependencyProperty^ FilePathProperty

Field Value

Type: DependencyProperty
See Also

Reference

RecentFilePresenter Class
VisualComponents.UX.Shared Namespace


RecentFilePresenter.HeaderProperty Field

RecentFilePresenterHeaderProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty HeaderProperty
public:
static DependencyProperty^ HeaderProperty

Field Value

Type: DependencyProperty
See Also

Reference

RecentFilePresenter Class
VisualComponents.UX.Shared Namespace


RecentFilePresenter.IconPathProperty Field

RecentFilePresenterIconPathProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty IconPathProperty
public:
static DependencyProperty^ IconPathProperty

Field Value

Type: DependencyProperty
See Also

Reference

RecentFilePresenter Class
VisualComponents.UX.Shared Namespace


RecentFilePresenter.ImageSourceProperty Field

RecentFilePresenterImageSourceProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty ImageSourceProperty
public:
static DependencyProperty^ ImageSourceProperty

Field Value

Type: DependencyProperty
See Also

Reference

RecentFilePresenter Class
VisualComponents.UX.Shared Namespace


RecentFolderConfigCollection Class

"Recent Folder" config collection
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationElementCollection
VisualComponents.UX.SharedRecentFolderConfigCollection

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class RecentFolderConfigCollection : ConfigurationElementCollection
public ref class RecentFolderConfigCollection sealed : public ConfigurationElementCollection

The RecentFolderConfigCollection type exposes the following members.

Constructors
 | Name | Description
Public method | RecentFolderConfigCollection | Initializes a new instance of the RecentFolderConfigCollection class
Top
Properties
 | Name | Description
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Public property | Item |
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Top
Methods
 | Name | Description
Public method | Add |
Public method | Clear |
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf |
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Public method | Remove |
Public method | RemoveAt |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RecentFolderConfigCollection Constructor

Initializes a new instance of the RecentFolderConfigCollection class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RecentFolderConfigCollection()
public:
RecentFolderConfigCollection()
See Also

Reference

RecentFolderConfigCollection Class
VisualComponents.UX.Shared Namespace


RecentFolderConfigCollection Properties

The RecentFolderConfigCollection type exposes the following members.

Properties
 | Name | Description
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Public property | Item |
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Top
See Also

Reference

RecentFolderConfigCollection Class
VisualComponents.UX.Shared Namespace


RecentFolderConfigCollection.Item Property

RecentFolderConfigCollectionItem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RecentFolderConfigElement this[
    int index
] { get; set; }
public:
property RecentFolderConfigElement^ default[int index] {
    RecentFolderConfigElement^ get (int index);
    void set (int index, RecentFolderConfigElement^ value);
}

Parameters

index
Type: SystemInt32

Property Value

Type: RecentFolderConfigElement
See Also

Reference

RecentFolderConfigCollection Class
VisualComponents.UX.Shared Namespace


RecentFolderConfigCollection Methods

The RecentFolderConfigCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Public method | Clear |
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf |
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Public method | Remove |
Public method | RemoveAt |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RecentFolderConfigCollection Class
VisualComponents.UX.Shared Namespace


RecentFolderConfigCollection.Add Method

RecentFolderConfigCollectionAdd Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Add(
    RecentFolderConfigElement element
)
public:
void Add(
    RecentFolderConfigElement^ element
)

Parameters

element
Type: VisualComponents.UX.SharedRecentFolderConfigElement
See Also

Reference

RecentFolderConfigCollection Class
VisualComponents.UX.Shared Namespace


RecentFolderConfigCollection.Clear Method

RecentFolderConfigCollectionClear Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Clear()
public:
void Clear()
See Also

Reference

RecentFolderConfigCollection Class
VisualComponents.UX.Shared Namespace


RecentFolderConfigCollection.IndexOf Method

RecentFolderConfigCollectionIndexOf Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int IndexOf(
    RecentFolderConfigElement element
)
public:
int IndexOf(
    RecentFolderConfigElement^ element
)

Parameters

element
Type: VisualComponents.UX.SharedRecentFolderConfigElement

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.RecentFolderConfigCollection.IndexOf(VisualComponents.UX.Shared.RecentFolderConfigElement)"]

See Also

Reference

RecentFolderConfigCollection Class
VisualComponents.UX.Shared Namespace


RecentFolderConfigCollection.Remove Method

RecentFolderConfigCollectionRemove Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Remove(
    RecentFolderConfigElement element
)
public:
void Remove(
    RecentFolderConfigElement^ element
)

Parameters

element
Type: VisualComponents.UX.SharedRecentFolderConfigElement
See Also

Reference

RecentFolderConfigCollection Class
VisualComponents.UX.Shared Namespace


RecentFolderConfigCollection.RemoveAt Method

RecentFolderConfigCollectionRemoveAt Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RemoveAt(
    int index
)
public:
void RemoveAt(
    int index
)

Parameters

index
Type: SystemInt32
See Also

Reference

RecentFolderConfigCollection Class
VisualComponents.UX.Shared Namespace


RecentFolderConfigElement Class

"Recent Folder" config element
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.UX.SharedRecentFolderConfigElement

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class RecentFolderConfigElement : ConfigurationElement
public ref class RecentFolderConfigElement sealed : public ConfigurationElement

The RecentFolderConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | RecentFolderConfigElement | Initializes a new instance of the RecentFolderConfigElement class
Top
Properties
 | Name | Description
Public property | CreatedOrModifiedTime | Created or modified time
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | FolderPath | Folder path
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Top
Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RecentFolderConfigElement Constructor

Initializes a new instance of the RecentFolderConfigElement class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RecentFolderConfigElement()
public:
RecentFolderConfigElement()
See Also

Reference

RecentFolderConfigElement Class
VisualComponents.UX.Shared Namespace


RecentFolderConfigElement Properties

The RecentFolderConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CreatedOrModifiedTime | Created or modified time
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | FolderPath | Folder path
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Top
See Also

Reference

RecentFolderConfigElement Class
VisualComponents.UX.Shared Namespace


RecentFolderConfigElement.CreatedOrModifiedTime Property

RecentFolderConfigElementCreatedOrModifiedTime Property

Created or modified time

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public DateTime CreatedOrModifiedTime { get; set; }
public:
property DateTime CreatedOrModifiedTime {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
See Also

Reference

RecentFolderConfigElement Class
VisualComponents.UX.Shared Namespace


RecentFolderConfigElement.FolderPath Property

RecentFolderConfigElementFolderPath Property

Folder path

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string FolderPath { get; set; }
public:
property String^ FolderPath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

RecentFolderConfigElement Class
VisualComponents.UX.Shared Namespace


RecentFolderConfigElement Methods

The RecentFolderConfigElement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RecentFolderConfigElement Class
VisualComponents.UX.Shared Namespace


RecentFolderSection Class

Recent folder section
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationSection
VisualComponents.UX.SharedRecentFolderSection

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class RecentFolderSection : ConfigurationSection,
    IRecentFolderSection, ISection
public ref class RecentFolderSection sealed : public ConfigurationSection,
    IRecentFolderSection, ISection

The RecentFolderSection type exposes the following members.

Constructors
 | Name | Description
Public method | RecentFolderSection | Initializes a new instance of the RecentFolderSection class
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | RecentFolders |
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName |
Public property | SectionType |
Public property | SectionVersion |
Top
Methods
 | Name | Description
Public method | CheckVersion |
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RecentFolderSection Constructor

Initializes a new instance of the RecentFolderSection class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RecentFolderSection()
public:
RecentFolderSection()
See Also

Reference

RecentFolderSection Class
VisualComponents.UX.Shared Namespace


RecentFolderSection Properties

The RecentFolderSection type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | RecentFolders |
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName |
Public property | SectionType |
Public property | SectionVersion |
Top
See Also

Reference

RecentFolderSection Class
VisualComponents.UX.Shared Namespace


RecentFolderSection.RecentFolders Property

RecentFolderSectionRecentFolders Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RecentFolderConfigCollection RecentFolders { get; }
public:
virtual property RecentFolderConfigCollection^ RecentFolders {
    RecentFolderConfigCollection^ get () sealed;
}

Property Value

Type: RecentFolderConfigCollection

Implements

IRecentFolderSectionRecentFolders
See Also

Reference

RecentFolderSection Class
VisualComponents.UX.Shared Namespace


RecentFolderSection.SectionName Property

RecentFolderSectionSectionName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SectionName { get; }
public:
virtual property String^ SectionName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ISectionSectionName
See Also

Reference

RecentFolderSection Class
VisualComponents.UX.Shared Namespace


RecentFolderSection.SectionType Property

RecentFolderSectionSectionType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type SectionType { get; }
public:
virtual property Type^ SectionType {
    Type^ get () sealed;
}

Property Value

Type: Type

Implements

ISectionSectionType
See Also

Reference

RecentFolderSection Class
VisualComponents.UX.Shared Namespace


RecentFolderSection.SectionVersion Property

RecentFolderSectionSectionVersion Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int SectionVersion { get; }
public:
virtual property int SectionVersion {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISectionSectionVersion
See Also

Reference

RecentFolderSection Class
VisualComponents.UX.Shared Namespace


RecentFolderSection Methods

The RecentFolderSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion |
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RecentFolderSection Class
VisualComponents.UX.Shared Namespace


RecentFolderSection.CheckVersion Method

RecentFolderSectionCheckVersion Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CheckVersion()
public:
virtual void CheckVersion() sealed

Implements

ISectionCheckVersion
See Also

Reference

RecentFolderSection Class
VisualComponents.UX.Shared Namespace


RecentFolderSection.GetSection Method

RecentFolderSectionGetSection Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISection GetSection(
    Configuration userSettingConfiguration
)
public:
virtual ISection^ GetSection(
    Configuration^ userSettingConfiguration
) sealed

Parameters

userSettingConfiguration
Type: System.ConfigurationConfiguration

Return Value

Type: ISection

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.RecentFolderSection.GetSection(System.Configuration.Configuration)"]

Implements

ISectionGetSection(Configuration)
See Also

Reference

RecentFolderSection Class
VisualComponents.UX.Shared Namespace


RecentFolderSection.ToString Method

RecentFolderSectionToString Method

Converts this instance to string.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String
String representation of this instance
See Also

Reference

RecentFolderSection Class
VisualComponents.UX.Shared Namespace


RecentOpenSaveFolderSection Class

Recent Open/Save folder section
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationSection
VisualComponents.UX.SharedRecentOpenSaveFolderSection

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class RecentOpenSaveFolderSection : ConfigurationSection,
    IRecentOpenSaveFolder, ISection
public ref class RecentOpenSaveFolderSection sealed : public ConfigurationSection,
    IRecentOpenSaveFolder, ISection

The RecentOpenSaveFolderSection type exposes the following members.

Constructors
 | Name | Description
Public method | RecentOpenSaveFolderSection | Constructor
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | FolderItems | Open/Save recent item
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName |
Public property | SectionType |
Public property | SectionVersion |
Top
Methods
 | Name | Description
Public method | CheckVersion |
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsFolderValueSet | Check a folder value
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RecentOpenSaveFolderSection Constructor

Constructor

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RecentOpenSaveFolderSection()
public:
RecentOpenSaveFolderSection()
See Also

Reference

RecentOpenSaveFolderSection Class
VisualComponents.UX.Shared Namespace


RecentOpenSaveFolderSection Properties

The RecentOpenSaveFolderSection type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | FolderItems | Open/Save recent item
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName |
Public property | SectionType |
Public property | SectionVersion |
Top
See Also

Reference

RecentOpenSaveFolderSection Class
VisualComponents.UX.Shared Namespace


RecentOpenSaveFolderSection.FolderItems Property

RecentOpenSaveFolderSectionFolderItems Property

Open/Save recent item

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public OpenSaveFolderConfigCollection FolderItems { get; }
public:
virtual property OpenSaveFolderConfigCollection^ FolderItems {
    OpenSaveFolderConfigCollection^ get () sealed;
}

Property Value

Type: OpenSaveFolderConfigCollection

Implements

IRecentOpenSaveFolderFolderItems
See Also

Reference

RecentOpenSaveFolderSection Class
VisualComponents.UX.Shared Namespace


RecentOpenSaveFolderSection.SectionName Property

RecentOpenSaveFolderSectionSectionName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SectionName { get; }
public:
virtual property String^ SectionName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ISectionSectionName
See Also

Reference

RecentOpenSaveFolderSection Class
VisualComponents.UX.Shared Namespace


RecentOpenSaveFolderSection.SectionType Property

RecentOpenSaveFolderSectionSectionType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type SectionType { get; }
public:
virtual property Type^ SectionType {
    Type^ get () sealed;
}

Property Value

Type: Type

Implements

ISectionSectionType
See Also

Reference

RecentOpenSaveFolderSection Class
VisualComponents.UX.Shared Namespace


RecentOpenSaveFolderSection.SectionVersion Property

RecentOpenSaveFolderSectionSectionVersion Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int SectionVersion { get; }
public:
virtual property int SectionVersion {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISectionSectionVersion
See Also

Reference

RecentOpenSaveFolderSection Class
VisualComponents.UX.Shared Namespace


RecentOpenSaveFolderSection Methods

The RecentOpenSaveFolderSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion |
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsFolderValueSet | Check a folder value
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RecentOpenSaveFolderSection Class
VisualComponents.UX.Shared Namespace


RecentOpenSaveFolderSection.CheckVersion Method

RecentOpenSaveFolderSectionCheckVersion Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CheckVersion()
public:
virtual void CheckVersion() sealed

Implements

ISectionCheckVersion
See Also

Reference

RecentOpenSaveFolderSection Class
VisualComponents.UX.Shared Namespace


RecentOpenSaveFolderSection.GetSection Method

RecentOpenSaveFolderSectionGetSection Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISection GetSection(
    Configuration userSettingConfiguration
)
public:
virtual ISection^ GetSection(
    Configuration^ userSettingConfiguration
) sealed

Parameters

userSettingConfiguration
Type: System.ConfigurationConfiguration

Return Value

Type: ISection

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.RecentOpenSaveFolderSection.GetSection(System.Configuration.Configuration)"]

Implements

ISectionGetSection(Configuration)
See Also

Reference

RecentOpenSaveFolderSection Class
VisualComponents.UX.Shared Namespace


RecentOpenSaveFolderSection.IsFolderValueSet Method

RecentOpenSaveFolderSectionIsFolderValueSet Method

Check a folder value

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsFolderValueSet(
    OpenSaveFolderType folderType
)
public:
virtual bool IsFolderValueSet(
    OpenSaveFolderType folderType
) sealed

Parameters

folderType
Type: VisualComponents.UX.SharedOpenSaveFolderType
the folder type

Return Value

Type: Boolean
true if the value type is set

Implements

IRecentOpenSaveFolderIsFolderValueSet(OpenSaveFolderType)
See Also

Reference

RecentOpenSaveFolderSection Class
VisualComponents.UX.Shared Namespace


RecentOpenSaveFolderSection.ToString Method

RecentOpenSaveFolderSectionToString Method

Converts this instance to string.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String
String representation of this instance
See Also

Reference

RecentOpenSaveFolderSection Class
VisualComponents.UX.Shared Namespace


RecordView__DEPRECATED__ Class

RecordView__DEPRECATED__
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedRecordView__DEPRECATED__

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RecordView__DEPRECATED__ : UserControl,
    IComponentConnector
public ref class RecordView__DEPRECATED__ : public UserControl,
    IComponentConnector

The RecordView__DEPRECATED__ type exposes the following members.

Constructors
 | Name | Description
Public method | RecordView__DEPRECATED__ | Initializes a new instance of the RecordView__DEPRECATED__ class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RecordView__DEPRECATED__ Constructor

Initializes a new instance of the RecordView__DEPRECATED__ class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RecordView__DEPRECATED__()
public:
RecordView__DEPRECATED__()
See Also

Reference

RecordView__DEPRECATED__ Class
VisualComponents.UX.Shared Namespace


RecordView__DEPRECATED__ Properties

The RecordView__DEPRECATED__ type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

RecordView__DEPRECATED__ Class
VisualComponents.UX.Shared Namespace


RecordView__DEPRECATED__ Methods

The RecordView__DEPRECATED__ type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RecordView__DEPRECATED__ Class
VisualComponents.UX.Shared Namespace


RecordView__DEPRECATED__.InitializeComponent Method

RecordView__DEPRECATED__InitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

RecordView__DEPRECATED__ Class
VisualComponents.UX.Shared Namespace


RecordView__DEPRECATED__ Events

The RecordView__DEPRECATED__ type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

RecordView__DEPRECATED__ Class
VisualComponents.UX.Shared Namespace


RectangularAnnotationCreateAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedRectangularAnnotationCreateAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RectangularAnnotationCreateAction : ICommandPanelAction,
    IHandle<SnapResultMessage>, IHandle, IHandle<RequestActionAbortMessage>
public ref class RectangularAnnotationCreateAction : ICommandPanelAction,
    IHandle<SnapResultMessage^>, IHandle, IHandle<RequestActionAbortMessage^>

The RectangularAnnotationCreateAction type exposes the following members.

Constructors
 | Name | Description
Public method | RectangularAnnotationCreateAction | Initializes a new instance of the RectangularAnnotationCreateAction class
Top
Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
 | IsExecuting |
Public property | Title |
Top
Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle(RequestActionAbortMessage) |
Public method | Handle(SnapResultMessage) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnPropertyChanged |
Public method | StartAction(EventHandlerResultCompletionEventArgs) |
Public method | StartAction(EventHandlerResultCompletionEventArgs, Boolean) |
 | StopExecuting |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
Name | Description
IsExecutingChanged |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RectangularAnnotationCreateAction Constructor

Initializes a new instance of the RectangularAnnotationCreateAction class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RectangularAnnotationCreateAction()
public:
RectangularAnnotationCreateAction()
See Also

Reference

RectangularAnnotationCreateAction Class
VisualComponents.UX.Shared Namespace


RectangularAnnotationCreateAction Properties

The RectangularAnnotationCreateAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
 | IsExecuting |
Public property | Title |
Top
See Also

Reference

RectangularAnnotationCreateAction Class
VisualComponents.UX.Shared Namespace


RectangularAnnotationCreateAction.ActionFinished Property

RectangularAnnotationCreateActionActionFinished Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ActionFinished { get; protected set; }
public:
virtual property bool ActionFinished {
    bool get () sealed;
    protected: void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ICommandPanelActionActionFinished
See Also

Reference

RectangularAnnotationCreateAction Class
VisualComponents.UX.Shared Namespace


RectangularAnnotationCreateAction.ActionProperties Property

RectangularAnnotationCreateActionActionProperties Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<IProperty> ActionProperties { get; }
public:
virtual property List<IProperty^>^ ActionProperties {
    List<IProperty^>^ get () sealed;
}

Property Value

Type: ListIProperty

Implements

ICommandPanelActionActionProperties
See Also

Reference

RectangularAnnotationCreateAction Class
VisualComponents.UX.Shared Namespace


RectangularAnnotationCreateAction.ApplyButtonText Property

RectangularAnnotationCreateActionApplyButtonText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ApplyButtonText { get; }
public:
virtual property String^ ApplyButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionApplyButtonText
See Also

Reference

RectangularAnnotationCreateAction Class
VisualComponents.UX.Shared Namespace


RectangularAnnotationCreateAction.AssociatedModelId Property

RectangularAnnotationCreateActionAssociatedModelId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedModelId { get; }
public:
virtual property String^ AssociatedModelId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedModelId
See Also

Reference

RectangularAnnotationCreateAction Class
VisualComponents.UX.Shared Namespace


RectangularAnnotationCreateAction.AssociatedSiteId Property

RectangularAnnotationCreateActionAssociatedSiteId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedSiteId { get; }
public:
virtual property String^ AssociatedSiteId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedSiteId
See Also

Reference

RectangularAnnotationCreateAction Class
VisualComponents.UX.Shared Namespace


RectangularAnnotationCreateAction.CallingCommandName Property

RectangularAnnotationCreateActionCallingCommandName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CallingCommandName { get; }
public:
virtual property String^ CallingCommandName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCallingCommandName
See Also

Reference

RectangularAnnotationCreateAction Class
VisualComponents.UX.Shared Namespace


RectangularAnnotationCreateAction.CancelButtonText Property

RectangularAnnotationCreateActionCancelButtonText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CancelButtonText { get; }
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCancelButtonText
See Also

Reference

RectangularAnnotationCreateAction Class
VisualComponents.UX.Shared Namespace


RectangularAnnotationCreateAction.Description Property

RectangularAnnotationCreateActionDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; }
public:
virtual property String^ Description {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionDescription
See Also

Reference

RectangularAnnotationCreateAction Class
VisualComponents.UX.Shared Namespace


RectangularAnnotationCreateAction.ErrorMessage Property

RectangularAnnotationCreateActionErrorMessage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ErrorMessage { get; set; }
public:
virtual property String^ ErrorMessage {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionErrorMessage
See Also

Reference

RectangularAnnotationCreateAction Class
VisualComponents.UX.Shared Namespace


RectangularAnnotationCreateAction.IsExecuting Property

RectangularAnnotationCreateActionIsExecuting Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsExecuting { get; }
public:
static property bool IsExecuting {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

RectangularAnnotationCreateAction Class
VisualComponents.UX.Shared Namespace


RectangularAnnotationCreateAction.Title Property

RectangularAnnotationCreateActionTitle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; }
public:
virtual property String^ Title {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionTitle
See Also

Reference

RectangularAnnotationCreateAction Class
VisualComponents.UX.Shared Namespace


RectangularAnnotationCreateAction Methods

The RectangularAnnotationCreateAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle(RequestActionAbortMessage) |
Public method | Handle(SnapResultMessage) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnPropertyChanged |
Public method | StartAction(EventHandlerResultCompletionEventArgs) |
Public method | StartAction(EventHandlerResultCompletionEventArgs, Boolean) |
 | StopExecuting |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RectangularAnnotationCreateAction Class
VisualComponents.UX.Shared Namespace


RectangularAnnotationCreateAction.ApplyAction Method

RectangularAnnotationCreateActionApplyAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ApplyAction()
public:
virtual bool ApplyAction() sealed

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.RectangularAnnotationCreateAction.ApplyAction"]

Implements

ICommandPanelActionApplyAction
See Also

Reference

RectangularAnnotationCreateAction Class
VisualComponents.UX.Shared Namespace


RectangularAnnotationCreateAction.CancelAction Method

RectangularAnnotationCreateActionCancelAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CancelAction()
public:
virtual void CancelAction() sealed

Implements

ICommandPanelActionCancelAction
See Also

Reference

RectangularAnnotationCreateAction Class
VisualComponents.UX.Shared Namespace


RectangularAnnotationCreateAction.Execute Method

RectangularAnnotationCreateActionExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<IResult> Execute()
public:
IEnumerable<IResult^>^ Execute()

Return Value

Type: IEnumerableIResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.RectangularAnnotationCreateAction.Execute"]

See Also

Reference

RectangularAnnotationCreateAction Class
VisualComponents.UX.Shared Namespace


RectangularAnnotationCreateAction.Handle Method

RectangularAnnotationCreateActionHandle Method

Overload List
 | Name | Description
Public method | Handle(RequestActionAbortMessage) |
Public method | Handle(SnapResultMessage) |
Top
See Also

Reference

RectangularAnnotationCreateAction Class
VisualComponents.UX.Shared Namespace


RectangularAnnotationCreateAction.Handle Method (RequestActionAbortMessage)

RectangularAnnotationCreateActionHandle Method (RequestActionAbortMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    RequestActionAbortMessage message
)
public:
virtual void Handle(
    RequestActionAbortMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedRequestActionAbortMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

RectangularAnnotationCreateAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


RectangularAnnotationCreateAction.Handle Method (SnapResultMessage)

RectangularAnnotationCreateActionHandle Method (SnapResultMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    SnapResultMessage message
)
public:
virtual void Handle(
    SnapResultMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedSnapResultMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

RectangularAnnotationCreateAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


RectangularAnnotationCreateAction.OnPropertyChanged Method

RectangularAnnotationCreateActionOnPropertyChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void OnPropertyChanged(
    string name
)
public:
static void OnPropertyChanged(
    String^ name
)

Parameters

name
Type: SystemString
See Also

Reference

RectangularAnnotationCreateAction Class
VisualComponents.UX.Shared Namespace


RectangularAnnotationCreateAction.StartAction Method

RectangularAnnotationCreateActionStartAction Method

Overload List
 | Name | Description
Public method | StartAction(EventHandlerResultCompletionEventArgs) |
Public method | StartAction(EventHandlerResultCompletionEventArgs, Boolean) |
Top
See Also

Reference

RectangularAnnotationCreateAction Class
VisualComponents.UX.Shared Namespace


RectangularAnnotationCreateAction.StartAction Method (EventHandler(ResultCompletionEventArgs))

RectangularAnnotationCreateActionStartAction Method (EventHandlerResultCompletionEventArgs)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    EventHandler<ResultCompletionEventArgs> completed = null
)
public:
virtual void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr
) sealed

Parameters

completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs

Implements

ICommandPanelActionStartAction(EventHandlerResultCompletionEventArgs)
See Also

Reference

RectangularAnnotationCreateAction Class
StartAction Overload
VisualComponents.UX.Shared Namespace


RectangularAnnotationCreateAction.StartAction Method (EventHandler(ResultCompletionEventArgs), Boolean)

RectangularAnnotationCreateActionStartAction Method (EventHandlerResultCompletionEventArgs, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    EventHandler<ResultCompletionEventArgs> completed,
    bool multiShot
)
public:
void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed,
    bool multiShot
)

Parameters

completed
Type: SystemEventHandlerResultCompletionEventArgs
multiShot
Type: SystemBoolean
See Also

Reference

RectangularAnnotationCreateAction Class
StartAction Overload
VisualComponents.UX.Shared Namespace


RectangularAnnotationCreateAction.StopExecuting Method

RectangularAnnotationCreateActionStopExecuting Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void StopExecuting()
public:
static void StopExecuting()
See Also

Reference

RectangularAnnotationCreateAction Class
VisualComponents.UX.Shared Namespace


RectangularAnnotationCreateAction Events

The RectangularAnnotationCreateAction type exposes the following members.

Events
Name | Description
IsExecutingChanged |
Top
See Also

Reference

RectangularAnnotationCreateAction Class
VisualComponents.UX.Shared Namespace


RectangularAnnotationCreateAction.IsExecutingChanged Event

RectangularAnnotationCreateActionIsExecutingChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static event PropertyChangedEventHandler IsExecutingChanged
public:
static  event PropertyChangedEventHandler^ IsExecutingChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler
See Also

Reference

RectangularAnnotationCreateAction Class
VisualComponents.UX.Shared Namespace


RectHelper Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedRectHelper

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class RectHelper
[ExtensionAttribute]
public ref class RectHelper abstract sealed

The RectHelper type exposes the following members.

Methods
Name | Description
Intersects |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RectHelper Methods

The RectHelper type exposes the following members.

Methods
Name | Description
Intersects |
Top
See Also

Reference

RectHelper Class
VisualComponents.UX.Shared Namespace


RectHelper.Intersects Method

RectHelperIntersects Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool Intersects(
    this Rect source,
    Rect target
)
public:
[ExtensionAttribute]
static bool Intersects(
    Rect source,
    Rect target
)

Parameters

source
Type: System.WindowsRect
target
Type: System.WindowsRect

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.RectHelper.Intersects(System.Windows.Rect,System.Windows.Rect)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Rect. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

RectHelper Class
VisualComponents.UX.Shared Namespace


ReflectionHelper Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedReflectionHelper

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class ReflectionHelper
[ExtensionAttribute]
public ref class ReflectionHelper abstract sealed

The ReflectionHelper type exposes the following members.

Methods
Name | Description
GetDependencyProperty |
GetPropertyInfo |
GetValue |
SetValue |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ReflectionHelper Methods

The ReflectionHelper type exposes the following members.

Methods
Name | Description
GetDependencyProperty |
GetPropertyInfo |
GetValue |
SetValue |
Top
See Also

Reference

ReflectionHelper Class
VisualComponents.UX.Shared Namespace


ReflectionHelper.GetDependencyProperty Method

ReflectionHelperGetDependencyProperty Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty GetDependencyProperty(
    this Type type,
    string property
)
public:
[ExtensionAttribute]
static DependencyProperty^ GetDependencyProperty(
    Type^ type,
    String^ property
)

Parameters

type
Type: SystemType
property
Type: SystemString

Return Value

Type: DependencyProperty

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ReflectionHelper.GetDependencyProperty(System.Type,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ReflectionHelper Class
VisualComponents.UX.Shared Namespace


ReflectionHelper.GetPropertyInfo Method

ReflectionHelperGetPropertyInfo Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static PropertyInfo GetPropertyInfo(
    this Object source,
    string property
)
public:
[ExtensionAttribute]
static PropertyInfo^ GetPropertyInfo(
    Object^ source,
    String^ property
)

Parameters

source
Type: SystemObject
property
Type: SystemString

Return Value

Type: PropertyInfo

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ReflectionHelper.GetPropertyInfo(System.Object,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ReflectionHelper Class
VisualComponents.UX.Shared Namespace


ReflectionHelper.GetValue Method

ReflectionHelperGetValue Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Object GetValue(
    this Object source,
    string property
)
public:
[ExtensionAttribute]
static Object^ GetValue(
    Object^ source,
    String^ property
)

Parameters

source
Type: SystemObject
property
Type: SystemString

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ReflectionHelper.GetValue(System.Object,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ReflectionHelper Class
VisualComponents.UX.Shared Namespace


ReflectionHelper.SetValue Method

ReflectionHelperSetValue Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetValue(
    this Object source,
    string property,
    Object value
)
public:
[ExtensionAttribute]
static void SetValue(
    Object^ source,
    String^ property,
    Object^ value
)

Parameters

source
Type: SystemObject
property
Type: SystemString
value
Type: SystemObject

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ReflectionHelper Class
VisualComponents.UX.Shared Namespace


RegionQuadTree(T) Class

RegionQuadTreeT Class

Stores spatial data (rectangular bounds and positions) of objects (i.e. UI elements) in prioritized order and allows to retrieve it in a lazy manner.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedRegionQuadTreeT

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RegionQuadTree<T> : IEnumerable<T>,
    IEnumerable

generic<typename T>
public ref class RegionQuadTree : IEnumerable<T>,
    IEnumerable

Type Parameters

T

The RegionQuadTreeT type exposes the following members.

Constructors
 | Name | Description
Public method | RegionQuadTreeT | Initializes a new instance of the RegionQuadTreeT class
Top
Properties
 | Name | Description
Public property | Space | Space to partition. Generally minimal rectangle needed to fit all the items.
Top
Methods
 | Name | Description
Public method | Clear | Clears the tree.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetContaining | Returns items which are completely inside the provided bounds in prioritized order.
Public method | GetEnumerator |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIntersecting | Returns items which are intersecting provided bounds in prioritized order.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasContaining | Returns true if any of the items are completely inside the provided bounds and false otherwise.
Public method | HasIntersecting | Returns true if any of the items intersect the provided bounds and false otherwise.
Public method | Insert | Inserts item with provided bounds and priority into the tree.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the first occurrence of the item. Returns true if the item was found and removed. Otherwise returns false.
Public method | Remove(T, Rect) | Removes the first occurrence of the item intersecting with provided bounds. Returns true if such an item was found and removed. Otherwise returns false.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachT | Enumerate a cached collection performing the specified action on each item. (Defined by ForEachHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | HasMoreThanT | (Defined by EnumerableHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToObservableCollectionT | (Defined by Extensions.)
Public Extension Method | ToObservableCollectionExT | (Defined by Extensions.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RegionQuadTree(T) Constructor

RegionQuadTreeT Constructor

Initializes a new instance of the RegionQuadTreeT class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RegionQuadTree()
public:
RegionQuadTree()
See Also

Reference

RegionQuadTreeT Class
VisualComponents.UX.Shared Namespace


RegionQuadTree(T) Properties

RegionQuadTreeT Properties

The RegionQuadTreeT generic type exposes the following members.

Properties
 | Name | Description
Public property | Space | Space to partition. Generally minimal rectangle needed to fit all the items.
Top
See Also

Reference

RegionQuadTreeT Class
VisualComponents.UX.Shared Namespace


RegionQuadTree(T).Space Property

RegionQuadTreeTSpace Property

Space to partition. Generally minimal rectangle needed to fit all the items.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Rect Space { get; set; }
public:
property Rect Space {
    Rect get ();
    void set (Rect value);
}

Property Value

Type: Rect
See Also

Reference

RegionQuadTreeT Class
VisualComponents.UX.Shared Namespace


RegionQuadTree(T) Methods

RegionQuadTreeT Methods

The RegionQuadTreeT generic type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clears the tree.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetContaining | Returns items which are completely inside the provided bounds in prioritized order.
Public method | GetEnumerator |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIntersecting | Returns items which are intersecting provided bounds in prioritized order.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasContaining | Returns true if any of the items are completely inside the provided bounds and false otherwise.
Public method | HasIntersecting | Returns true if any of the items intersect the provided bounds and false otherwise.
Public method | Insert | Inserts item with provided bounds and priority into the tree.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the first occurrence of the item. Returns true if the item was found and removed. Otherwise returns false.
Public method | Remove(T, Rect) | Removes the first occurrence of the item intersecting with provided bounds. Returns true if such an item was found and removed. Otherwise returns false.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ForEachT | Enumerate a cached collection performing the specified action on each item. (Defined by ForEachHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | HasMoreThanT | (Defined by EnumerableHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToObservableCollectionT | (Defined by Extensions.)
Public Extension Method | ToObservableCollectionExT | (Defined by Extensions.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RegionQuadTreeT Class
VisualComponents.UX.Shared Namespace


RegionQuadTree(T).Clear Method

RegionQuadTreeTClear Method

Clears the tree.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Clear()
public:
void Clear()
See Also

Reference

RegionQuadTreeT Class
VisualComponents.UX.Shared Namespace


RegionQuadTree(T).GetContaining Method

RegionQuadTreeTGetContaining Method

Returns items which are completely inside the provided bounds in prioritized order.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<T> GetContaining(
    Rect bounds
)
public:
IEnumerable<T>^ GetContaining(
    Rect bounds
)

Parameters

bounds
Type: System.WindowsRect

Return Value

Type: IEnumerableT

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.RegionQuadTree`1.GetContaining(System.Windows.Rect)"]

See Also

Reference

RegionQuadTreeT Class
VisualComponents.UX.Shared Namespace


RegionQuadTree(T).GetEnumerator Method

RegionQuadTreeTGetEnumerator Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerator<T> GetEnumerator()
public:
virtual IEnumerator<T>^ GetEnumerator() sealed

Return Value

Type: IEnumeratorT

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.RegionQuadTree`1.GetEnumerator"]

Implements

IEnumerableTGetEnumerator
See Also

Reference

RegionQuadTreeT Class
VisualComponents.UX.Shared Namespace


RegionQuadTree(T).GetIntersecting Method

RegionQuadTreeTGetIntersecting Method

Returns items which are intersecting provided bounds in prioritized order.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<T> GetIntersecting(
    Rect bounds
)
public:
IEnumerable<T>^ GetIntersecting(
    Rect bounds
)

Parameters

bounds
Type: System.WindowsRect

Return Value

Type: IEnumerableT

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.RegionQuadTree`1.GetIntersecting(System.Windows.Rect)"]

See Also

Reference

RegionQuadTreeT Class
VisualComponents.UX.Shared Namespace


RegionQuadTree(T).HasContaining Method

RegionQuadTreeTHasContaining Method

Returns true if any of the items are completely inside the provided bounds and false otherwise.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HasContaining(
    Rect bounds
)
public:
bool HasContaining(
    Rect bounds
)

Parameters

bounds
Type: System.WindowsRect

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.RegionQuadTree`1.HasContaining(System.Windows.Rect)"]

See Also

Reference

RegionQuadTreeT Class
VisualComponents.UX.Shared Namespace


RegionQuadTree(T).HasIntersecting Method

RegionQuadTreeTHasIntersecting Method

Returns true if any of the items intersect the provided bounds and false otherwise.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HasIntersecting(
    Rect bounds
)
public:
bool HasIntersecting(
    Rect bounds
)

Parameters

bounds
Type: System.WindowsRect

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.RegionQuadTree`1.HasIntersecting(System.Windows.Rect)"]

See Also

Reference

RegionQuadTreeT Class
VisualComponents.UX.Shared Namespace


RegionQuadTree(T).Insert Method

RegionQuadTreeTInsert Method

Inserts item with provided bounds and priority into the tree.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Insert(
    T item,
    Rect bounds,
    double priority
)
public:
void Insert(
    T item,
    Rect bounds,
    double priority
)

Parameters

item
Type: T
bounds
Type: System.WindowsRect
priority
Type: SystemDouble
See Also

Reference

RegionQuadTreeT Class
VisualComponents.UX.Shared Namespace


RegionQuadTree(T).Remove Method

RegionQuadTreeTRemove Method

Overload List
 | Name | Description
Public method | Remove(T) | Removes the first occurrence of the item. Returns true if the item was found and removed. Otherwise returns false.
Public method | Remove(T, Rect) | Removes the first occurrence of the item intersecting with provided bounds. Returns true if such an item was found and removed. Otherwise returns false.
Top
See Also

Reference

RegionQuadTreeT Class
VisualComponents.UX.Shared Namespace


RegionQuadTree(T).Remove Method (T)

RegionQuadTreeTRemove Method (T)

Removes the first occurrence of the item. Returns true if the item was found and removed. Otherwise returns false.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Remove(
    T item
)
public:
bool Remove(
    T item
)

Parameters

item
Type: T

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.RegionQuadTree`1.Remove(`0)"]

See Also

Reference

RegionQuadTreeT Class
Remove Overload
VisualComponents.UX.Shared Namespace


RegionQuadTree(T).Remove Method (T, Rect)

RegionQuadTreeTRemove Method (T, Rect)

Removes the first occurrence of the item intersecting with provided bounds. Returns true if such an item was found and removed. Otherwise returns false.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Remove(
    T item,
    Rect bounds
)
public:
bool Remove(
    T item,
    Rect bounds
)

Parameters

item
Type: T
bounds
Type: System.WindowsRect

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.RegionQuadTree`1.Remove(`0,System.Windows.Rect)"]

See Also

Reference

RegionQuadTreeT Class
Remove Overload
VisualComponents.UX.Shared Namespace


ReportEx Class

Inherited from Report to allow custom report initialization. This is needed for proper operation of XamReportPreviewEx.
Inheritance Hierarchy
SystemObject
PropertyChangeNotifier
ReportBase
Report
VisualComponents.UX.SharedReportEx

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ReportEx : Report
public ref class ReportEx : public Report

The ReportEx type exposes the following members.

Constructors
 | Name | Description
Public method | ReportEx | Initializes a new instance of the ReportEx class
Top
Properties
 | Name | Description
Protected property | HasListeners | (Inherited from PropertyChangeNotifier.)
Public property | IsGeneratingPreview |
Public property | LogicalPageNumber | (Inherited from Report.)
Public property | LogicalPagePartNumber | (Inherited from Report.)
Public property | PageContentTemplate | (Inherited from ReportBase.)
Public property | PageContentTemplateSelector | (Inherited from ReportBase.)
Public property | PageFooter | (Inherited from ReportBase.)
Public property | PageFooterTemplate | (Inherited from ReportBase.)
Public property | PageFooterTemplateSelector | (Inherited from ReportBase.)
Public property | PageHeader | (Inherited from ReportBase.)
Public property | PageHeaderTemplate | (Inherited from ReportBase.)
Public property | PageHeaderTemplateSelector | (Inherited from ReportBase.)
Public property | PageImageableAreaExtent | (Inherited from ReportBase.)
Public property | PageOrigin | (Inherited from ReportBase.)
Public property | PagePresenterStyle | (Inherited from ReportBase.)
Public property | PageSizeResolved | (Inherited from Report.)
Public property | PhysicalPageNumber | (Inherited from Report.)
Public property | ReportSettings | (Inherited from Report.)
Public property | SectionLogicalPageNumber | (Inherited from Report.)
Public property | SectionLogicalPagePartNumber | (Inherited from Report.)
Public property | SectionPhysicalPageNumber | (Inherited from Report.)
Public property | Sections | (Inherited from Report.)
Top
Methods
 | Name | Description
Protected method | ClearCachedOriginAndSize | (Inherited from ReportBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Export(OutputFormat) | (Inherited from Report.)
Public method | Export(OutputFormat, String) | (Inherited from Report.)
Public method | Export(OutputFormat, Stream) | (Inherited from Report.)
Public method | Export(OutputFormat, String, Boolean) | (Inherited from Report.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnFirstListenerAdding | (Inherited from PropertyChangeNotifier.)
Protected method | OnHasListenersChanged | (Inherited from PropertyChangeNotifier.)
Protected method | OnPrintProgress | (Inherited from Report.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangeNotifier.)
Protected method | OnWritingCanceled | (Inherited from Report.)
Protected method | OnWritingCompleted | (Inherited from Report.)
Public method | Print | (Inherited from Report.)
Public method | Print(Boolean, Boolean) | (Inherited from Report.)
Public method | Print(Boolean, Boolean, FrameworkElement) | (Inherited from Report.)
Protected method | RaisePropertyChangedEvent(String) | (Inherited from PropertyChangeNotifier.)
Protected method | RaisePropertyChangedEvent(String, Object, PropertyChangedEventArgs) | Obsolete. (Inherited from PropertyChangeNotifier.)
Public method | ShowPrintDialog | (Inherited from Report.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PrintEnded | (Inherited from Report.)
Public event | PrintProgress | (Inherited from Report.)
Public event | PrintStart | (Inherited from Report.)
Public event | PropertyChanged | (Inherited from PropertyChangeNotifier.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ReportEx Constructor

Initializes a new instance of the ReportEx class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReportEx()
public:
ReportEx()
See Also

Reference

ReportEx Class
VisualComponents.UX.Shared Namespace


ReportEx Properties

The ReportEx type exposes the following members.

Properties
 | Name | Description
Protected property | HasListeners | (Inherited from PropertyChangeNotifier.)
Public property | IsGeneratingPreview |
Public property | LogicalPageNumber | (Inherited from Report.)
Public property | LogicalPagePartNumber | (Inherited from Report.)
Public property | PageContentTemplate | (Inherited from ReportBase.)
Public property | PageContentTemplateSelector | (Inherited from ReportBase.)
Public property | PageFooter | (Inherited from ReportBase.)
Public property | PageFooterTemplate | (Inherited from ReportBase.)
Public property | PageFooterTemplateSelector | (Inherited from ReportBase.)
Public property | PageHeader | (Inherited from ReportBase.)
Public property | PageHeaderTemplate | (Inherited from ReportBase.)
Public property | PageHeaderTemplateSelector | (Inherited from ReportBase.)
Public property | PageImageableAreaExtent | (Inherited from ReportBase.)
Public property | PageOrigin | (Inherited from ReportBase.)
Public property | PagePresenterStyle | (Inherited from ReportBase.)
Public property | PageSizeResolved | (Inherited from Report.)
Public property | PhysicalPageNumber | (Inherited from Report.)
Public property | ReportSettings | (Inherited from Report.)
Public property | SectionLogicalPageNumber | (Inherited from Report.)
Public property | SectionLogicalPagePartNumber | (Inherited from Report.)
Public property | SectionPhysicalPageNumber | (Inherited from Report.)
Public property | Sections | (Inherited from Report.)
Top
See Also

Reference

ReportEx Class
VisualComponents.UX.Shared Namespace


ReportEx.IsGeneratingPreview Property

ReportExIsGeneratingPreview Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsGeneratingPreview { get; }
public:
property bool IsGeneratingPreview {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ReportEx Class
VisualComponents.UX.Shared Namespace


ReportEx Methods

The ReportEx type exposes the following members.

Methods
 | Name | Description
Protected method | ClearCachedOriginAndSize | (Inherited from ReportBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Export(OutputFormat) | (Inherited from Report.)
Public method | Export(OutputFormat, String) | (Inherited from Report.)
Public method | Export(OutputFormat, Stream) | (Inherited from Report.)
Public method | Export(OutputFormat, String, Boolean) | (Inherited from Report.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnFirstListenerAdding | (Inherited from PropertyChangeNotifier.)
Protected method | OnHasListenersChanged | (Inherited from PropertyChangeNotifier.)
Protected method | OnPrintProgress | (Inherited from Report.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangeNotifier.)
Protected method | OnWritingCanceled | (Inherited from Report.)
Protected method | OnWritingCompleted | (Inherited from Report.)
Public method | Print | (Inherited from Report.)
Public method | Print(Boolean, Boolean) | (Inherited from Report.)
Public method | Print(Boolean, Boolean, FrameworkElement) | (Inherited from Report.)
Protected method | RaisePropertyChangedEvent(String) | (Inherited from PropertyChangeNotifier.)
Protected method | RaisePropertyChangedEvent(String, Object, PropertyChangedEventArgs) | Obsolete. (Inherited from PropertyChangeNotifier.)
Public method | ShowPrintDialog | (Inherited from Report.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ReportEx Class
VisualComponents.UX.Shared Namespace


ReportEx Events

The ReportEx type exposes the following members.

Events
 | Name | Description
Public event | PrintEnded | (Inherited from Report.)
Public event | PrintProgress | (Inherited from Report.)
Public event | PrintStart | (Inherited from Report.)
Public event | PropertyChanged | (Inherited from PropertyChangeNotifier.)
Top
See Also

Reference

ReportEx Class
VisualComponents.UX.Shared Namespace


RequestActionAbortMessage Class

Message that is signalled when abortable actions should be aborted.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedRequestActionAbortMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class RequestActionAbortMessage
public ref class RequestActionAbortMessage sealed

The RequestActionAbortMessage type exposes the following members.

Constructors
 | Name | Description
Public method | RequestActionAbortMessage | Initializes a new instance of the RequestActionAbortMessage class
Top
Properties
 | Name | Description
Public property | RequestedBy |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RequestActionAbortMessage Constructor

Initializes a new instance of the RequestActionAbortMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RequestActionAbortMessage()
public:
RequestActionAbortMessage()
See Also

Reference

RequestActionAbortMessage Class
VisualComponents.UX.Shared Namespace


RequestActionAbortMessage Properties

The RequestActionAbortMessage type exposes the following members.

Properties
 | Name | Description
Public property | RequestedBy |
Top
See Also

Reference

RequestActionAbortMessage Class
VisualComponents.UX.Shared Namespace


RequestActionAbortMessage.RequestedBy Property

RequestActionAbortMessageRequestedBy Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string RequestedBy { get; set; }
public:
property String^ RequestedBy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

RequestActionAbortMessage Class
VisualComponents.UX.Shared Namespace


RequestActionAbortMessage Methods

The RequestActionAbortMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RequestActionAbortMessage Class
VisualComponents.UX.Shared Namespace


RequestCommandPanelCanApplyCancelUpdate Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedRequestCommandPanelCanApplyCancelUpdate

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RequestCommandPanelCanApplyCancelUpdate
public ref class RequestCommandPanelCanApplyCancelUpdate

The RequestCommandPanelCanApplyCancelUpdate type exposes the following members.

Constructors
 | Name | Description
Public method | RequestCommandPanelCanApplyCancelUpdate | Initializes a new instance of the RequestCommandPanelCanApplyCancelUpdate class
Top
Properties
 | Name | Description
Public property | CommandPanelAction |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RequestCommandPanelCanApplyCancelUpdate Constructor

Initializes a new instance of the RequestCommandPanelCanApplyCancelUpdate class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RequestCommandPanelCanApplyCancelUpdate(
    ICommandPanelAction2 action
)
public:
RequestCommandPanelCanApplyCancelUpdate(
    ICommandPanelAction2^ action
)

Parameters

action
Type: VisualComponents.UX.SharedICommandPanelAction2
See Also

Reference

RequestCommandPanelCanApplyCancelUpdate Class
VisualComponents.UX.Shared Namespace


RequestCommandPanelCanApplyCancelUpdate Properties

The RequestCommandPanelCanApplyCancelUpdate type exposes the following members.

Properties
 | Name | Description
Public property | CommandPanelAction |
Top
See Also

Reference

RequestCommandPanelCanApplyCancelUpdate Class
VisualComponents.UX.Shared Namespace


RequestCommandPanelCanApplyCancelUpdate.CommandPanelAction Property

RequestCommandPanelCanApplyCancelUpdateCommandPanelAction Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ICommandPanelAction2 CommandPanelAction { get; }
public:
property ICommandPanelAction2^ CommandPanelAction {
    ICommandPanelAction2^ get ();
}

Property Value

Type: ICommandPanelAction2
See Also

Reference

RequestCommandPanelCanApplyCancelUpdate Class
VisualComponents.UX.Shared Namespace


RequestCommandPanelCanApplyCancelUpdate Methods

The RequestCommandPanelCanApplyCancelUpdate type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RequestCommandPanelCanApplyCancelUpdate Class
VisualComponents.UX.Shared Namespace


RequiredFieldValidationRule Class

Inheritance Hierarchy
SystemObject
System.Windows.ControlsValidationRule
VisualComponents.UX.SharedRequiredFieldValidationRule

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RequiredFieldValidationRule : ValidationRule
public ref class RequiredFieldValidationRule : public ValidationRule

The RequiredFieldValidationRule type exposes the following members.

Constructors
 | Name | Description
Public method | RequiredFieldValidationRule | Initializes a new instance of the RequiredFieldValidationRule class
Top
Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RequiredFieldValidationRule Constructor

Initializes a new instance of the RequiredFieldValidationRule class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RequiredFieldValidationRule()
public:
RequiredFieldValidationRule()
See Also

Reference

RequiredFieldValidationRule Class
VisualComponents.UX.Shared Namespace


RequiredFieldValidationRule Properties

The RequiredFieldValidationRule type exposes the following members.

Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
See Also

Reference

RequiredFieldValidationRule Class
VisualComponents.UX.Shared Namespace


RequiredFieldValidationRule Methods

The RequiredFieldValidationRule type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RequiredFieldValidationRule Class
VisualComponents.UX.Shared Namespace


RequiredFieldValidationRule.Validate Method

RequiredFieldValidationRuleValidate Method

Overload List
 | Name | Description
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
See Also

Reference

RequiredFieldValidationRule Class
VisualComponents.UX.Shared Namespace


RequiredFieldValidationRule.Validate Method (Object, CultureInfo)

RequiredFieldValidationRuleValidate Method (Object, CultureInfo)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override ValidationResult Validate(
    Object value,
    CultureInfo cultureInfo
)
public:
virtual ValidationResult^ Validate(
    Object^ value,
    CultureInfo^ cultureInfo
) override

Parameters

value
Type: SystemObject
cultureInfo
Type: System.GlobalizationCultureInfo

Return Value

Type: ValidationResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.RequiredFieldValidationRule.Validate(System.Object,System.Globalization.CultureInfo)"]

See Also

Reference

RequiredFieldValidationRule Class
Validate Overload
VisualComponents.UX.Shared Namespace


ResetableTextBox Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.Controls.PrimitivesTextBoxBase
System.Windows.ControlsTextBox
VisualComponents.UX.SharedUndoableTextBox
VisualComponents.UX.SharedResetableTextBox

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ResetableTextBox : UndoableTextBox
public ref class ResetableTextBox : public UndoableTextBox

The ResetableTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | ResetableTextBox | Initializes a new instance of the ResetableTextBox class
Top
Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key. (Inherited from TextBoxBase.)
Public property | AcceptsTab | Gets or sets a value that indicates how the text editing control responds when the user presses the TAB key. (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoWordSelection | Gets or sets a value that determines whether when a user selects part of a word by dragging across it with the mouse, the rest of the word is selected. (Inherited from TextBoxBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanRedo | Gets a value that indicates whether the most recent undo action can be redone. (Inherited from TextBoxBase.)
Public property | CanUndo | Gets a value that indicates whether the most recent action can be undone. (Inherited from TextBoxBase.)
Public property | CaretBrush | Gets or sets the brush that is used to paint the caret of the text box. (Inherited from TextBoxBase.)
Public property | CaretIndex | Gets or sets the insertion position index of the caret. (Inherited from TextBox.)
Public property | CharacterCasing | Gets or sets how characters are cased when they are manually entered into the text box. (Inherited from TextBox.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DefaultValue |
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExpressionContext |
Public property | ExtentHeight | Gets the vertical size of the visible content area. (Inherited from TextBoxBase.)
Public property | ExtentWidth | Gets the horizontal size of the visible content area. (Inherited from TextBoxBase.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Gets or sets the horizontal scroll position. (Inherited from TextBoxBase.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal scroll bar is shown. (Inherited from TextBoxBase.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInactiveSelectionHighlightEnabled | Gets or sets a value that indicates whether the text box displays selected text when the text box does not have focus. (Inherited from TextBoxBase.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that indicates whether the text editing control is read-only to a user interacting with the control. (Inherited from TextBoxBase.)
Public property | IsReadOnlyCaretVisible | Gets or sets a value that indicates whether a read-only text box displays a caret. (Inherited from TextBoxBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionActive | Gets a value that indicates whether the text box has focus and selected text. (Inherited from TextBoxBase.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets a value that indicates whether undo support is enabled for the text-editing control. (Inherited from TextBoxBase.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | LineCount | Gets the total number of lines in the text box. (Inherited from TextBox.)
Protected property | LogicalChildren | Gets an enumerator for the logical child elements of the TextBox. (Inherited from TextBox.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxLength | Gets or sets the maximum number of characters that can be manually entered into the text box. (Inherited from TextBox.)
Public property | MaxLines | Gets or sets the maximum number of visible lines. (Inherited from TextBox.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinLines | Gets or sets the minimum number of visible lines. (Inherited from TextBox.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | ResetButtonColor | Set slider Thumb Color.
Public property | ResetButtonContent |
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedText | Gets or sets the content of the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionBrush | Gets or sets the brush that highlights selected text. (Inherited from TextBoxBase.)
Public property | SelectionLength | Gets or sets a value indicating the number of characters in the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionOpacity | Gets or sets the opacity of the SelectionBrush. (Inherited from TextBoxBase.)
Public property | SelectionStart | Gets or sets a character index for the beginning of the current selection. (Inherited from TextBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | SpellCheck | Gets a SpellCheck object that provides access to spelling errors in the text contents of a TextBoxBase or RichTextBox. (Inherited from TextBoxBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | SupportExpressions |
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Gets or sets the text contents of the text box. (Inherited from TextBox.)
Public property | TextAlignment | Gets or sets the horizontal alignment of the contents of the text box. (Inherited from TextBox.)
Public property | TextDecorations | Gets the text decorations to apply to the text box. (Inherited from TextBox.)
Public property | TextInputType |
Public property | TextWrapping | Gets or sets how the text box should wrap text. (Inherited from TextBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Typography | Gets the currently effective typography variations for the text contents of the text box. (Inherited from TextBox.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UndoLimit | Gets or sets the number of actions stored in the undo queue. (Inherited from TextBoxBase.)
Public property | UseCustomUndo | (Inherited from UndoableTextBox.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Gets or sets the vertical scroll position. (Inherited from TextBoxBase.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical scroll bar is shown. (Inherited from TextBoxBase.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | ViewportHeight | Gets the vertical size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | ViewportWidth | Gets the horizontal size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AppendText | Appends a string to the contents of a text control. (Inherited from TextBoxBase.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginChange | Begins a change block. (Inherited from TextBoxBase.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | Clears all the content from the text box. (Inherited from TextBox.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Copy | Copies the current selection of the text editing control to the Clipboard. (Inherited from TextBoxBase.)
Public method | Cut | Removes the current selection from the text editing control and copies it to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeclareChangeBlock | Creates a change block. (Inherited from TextBoxBase.)
Public method | EndChange | Ends a change block. (Inherited from TextBoxBase.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetCharacterIndexFromLineIndex | Returns the zero-based character index for the first character in the specified line. (Inherited from TextBox.)
Public method | GetCharacterIndexFromPoint | Returns the zero-based index of the character that is closest to the specified point. (Inherited from TextBox.)
Public method | GetFirstVisibleLineIndex | Returns the line index for the first line that is currently visible in the text box. (Inherited from TextBox.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLastVisibleLineIndex | Returns the line index for the last line that is currently visible in the text box. (Inherited from TextBox.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLineIndexFromCharacterIndex | Returns the zero-based line index for the line that contains the specified character index. (Inherited from TextBox.)
Public method | GetLineLength | Returns the number of characters in the specified line. (Inherited from TextBox.)
Public method | GetLineText | Returns the text that is currently displayed on the specified line. (Inherited from TextBox.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetNextSpellingErrorCharacterIndex | Returns the beginning character index for the next spelling error in the contents of the text box. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32) | Returns the rectangle for the leading edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32, Boolean) | Returns the rectangle for the leading or trailing edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetSpellingError | Returns a SpellingError object associated with any spelling error at the specified character index. (Inherited from TextBox.)
Public method | GetSpellingErrorLength | Returns the length of any spelling error that includes the specified character. (Inherited from TextBox.)
Public method | GetSpellingErrorStart | Returns the beginning character index for any spelling error that includes the specified character. (Inherited from TextBox.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls the contents of the control down by one line. (Inherited from TextBoxBase.)
Public method | LineLeft | Scrolls the contents of the control to the left by one line. (Inherited from TextBoxBase.)
Public method | LineRight | Scrolls the contents of the control to the right by one line. (Inherited from TextBoxBase.)
Public method | LineUp | Scrolls the contents of the control upward by one line. (Inherited from TextBoxBase.)
Public method | LockCurrentUndoUnit | Locks the most recent undo unit of the undo stack of the application. This prevents the locked unit from being merged with undo units that are added subsequently. (Inherited from TextBoxBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Sizes the text box to its content. (Inherited from TextBox.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides TextBoxBaseOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Called whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for the text box. (Inherited from TextBox.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragLeave | Invoked whenever an unhandled DragLeave attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragOver | Invoked whenever an unhandled DragOver attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDrop | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGiveFeedback | Invoked whenever an unhandled GiveFeedback attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotFocus | (Overrides FrameworkElementOnGotFocus(RoutedEventArgs).)
Protected method | OnGotKeyboardFocus | Invoked whenever an unhandled GotKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | (Inherited from UndoableTextBox.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked whenever an unhandled KeyDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnKeyUp | Invoked whenever an unhandled KeyUp attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostFocus | (Overrides TextBoxBaseOnLostFocus(RoutedEventArgs).)
Protected method | OnLostKeyboardFocus | Invoked whenever an unhandled LostKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked whenever an unhandled MouseDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked whenever an unhandled MouseMove attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked whenever an unhandled MouseUp event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Is called when a MouseWheel event is routed to this class (or to a class that inherits from this class). (Inherited from TextBoxBase.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | (Overrides TextBoxBaseOnPreviewKeyDown(KeyEventArgs).)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | (Overrides ControlOnPreviewMouseDoubleClick(MouseButtonEventArgs).)
Protected method | OnPreviewMouseDown | (Overrides UIElementOnPreviewMouseDown(MouseButtonEventArgs).)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Ignore incorrect characters (one by one) (Overrides UIElementOnPreviewTextInput(TextCompositionEventArgs).)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Called when one or more of the dependency properties that exist on the element have had their effective values changed. (Inherited from TextBox.)
Protected method | OnQueryContinueDrag | Invoked whenever an unhandled QueryContinueDrag attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnQueryCursor | Invoked whenever an unhandled QueryCursor attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Is called when the caret or current selection changes position. (Inherited from TextBoxBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Is called when the control template changes. (Inherited from TextBoxBase.)
Protected method | OnTextChanged | (Overrides UndoableTextBoxOnTextChanged(TextChangedEventArgs).)
Protected method | OnTextInput | Invoked whenever an unhandled TextInput attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | PageDown | Scrolls the contents of the control down by one page. (Inherited from TextBoxBase.)
Public method | PageLeft | Scrolls the contents of the control to the left by one page. (Inherited from TextBoxBase.)
Public method | PageRight | Scrolls the contents of the control to the right by one page. (Inherited from TextBoxBase.)
Public method | PageUp | Scrolls the contents of the control up by one page. (Inherited from TextBoxBase.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | Paste | Pastes the contents of the Clipboard over the current selection in the text editing control. (Inherited from TextBoxBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Redo | Undoes the most recent undo command. In other words, redoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollToEnd | Scrolls the view of the editing control to the end of the content. (Inherited from TextBoxBase.)
Public method | ScrollToHome | Scrolls the view of the editing control to the beginning of the viewport. (Inherited from TextBoxBase.)
Public method | ScrollToHorizontalOffset | Scrolls the contents of the editing control to the specified horizontal offset. (Inherited from TextBoxBase.)
Public method | ScrollToLine | Scrolls the line at the specified line index into view. (Inherited from TextBox.)
Public method | ScrollToVerticalOffset | Scrolls the contents of the editing control to the specified vertical offset. (Inherited from TextBoxBase.)
Public method | Select | Selects a range of text in the text box. (Inherited from TextBox.)
Public method | SelectAll | Selects all the contents of the text editing control. (Inherited from TextBoxBase.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeText | Returns a value that indicates whether the effective value of the Text property should be serialized during serialization of the TextBox object. (Inherited from TextBox.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | Undo | Undoes the most recent undo command. In other words, undoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBoxBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextChanged | Occurs when content changes in the text element. (Inherited from TextBoxBase.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
DefaultValueProperty |
ExpressionContextProperty |
ResetButtonColorProperty |
ResetButtonContentProperty |
TextInputTypeProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ResetableTextBox Constructor

Initializes a new instance of the ResetableTextBox class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ResetableTextBox()
public:
ResetableTextBox()
See Also

Reference

ResetableTextBox Class
VisualComponents.UX.Shared Namespace


ResetableTextBox Properties

The ResetableTextBox type exposes the following members.

Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key. (Inherited from TextBoxBase.)
Public property | AcceptsTab | Gets or sets a value that indicates how the text editing control responds when the user presses the TAB key. (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoWordSelection | Gets or sets a value that determines whether when a user selects part of a word by dragging across it with the mouse, the rest of the word is selected. (Inherited from TextBoxBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanRedo | Gets a value that indicates whether the most recent undo action can be redone. (Inherited from TextBoxBase.)
Public property | CanUndo | Gets a value that indicates whether the most recent action can be undone. (Inherited from TextBoxBase.)
Public property | CaretBrush | Gets or sets the brush that is used to paint the caret of the text box. (Inherited from TextBoxBase.)
Public property | CaretIndex | Gets or sets the insertion position index of the caret. (Inherited from TextBox.)
Public property | CharacterCasing | Gets or sets how characters are cased when they are manually entered into the text box. (Inherited from TextBox.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DefaultValue |
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExpressionContext |
Public property | ExtentHeight | Gets the vertical size of the visible content area. (Inherited from TextBoxBase.)
Public property | ExtentWidth | Gets the horizontal size of the visible content area. (Inherited from TextBoxBase.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Gets or sets the horizontal scroll position. (Inherited from TextBoxBase.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal scroll bar is shown. (Inherited from TextBoxBase.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInactiveSelectionHighlightEnabled | Gets or sets a value that indicates whether the text box displays selected text when the text box does not have focus. (Inherited from TextBoxBase.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that indicates whether the text editing control is read-only to a user interacting with the control. (Inherited from TextBoxBase.)
Public property | IsReadOnlyCaretVisible | Gets or sets a value that indicates whether a read-only text box displays a caret. (Inherited from TextBoxBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionActive | Gets a value that indicates whether the text box has focus and selected text. (Inherited from TextBoxBase.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets a value that indicates whether undo support is enabled for the text-editing control. (Inherited from TextBoxBase.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | LineCount | Gets the total number of lines in the text box. (Inherited from TextBox.)
Protected property | LogicalChildren | Gets an enumerator for the logical child elements of the TextBox. (Inherited from TextBox.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxLength | Gets or sets the maximum number of characters that can be manually entered into the text box. (Inherited from TextBox.)
Public property | MaxLines | Gets or sets the maximum number of visible lines. (Inherited from TextBox.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinLines | Gets or sets the minimum number of visible lines. (Inherited from TextBox.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | ResetButtonColor | Set slider Thumb Color.
Public property | ResetButtonContent |
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedText | Gets or sets the content of the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionBrush | Gets or sets the brush that highlights selected text. (Inherited from TextBoxBase.)
Public property | SelectionLength | Gets or sets a value indicating the number of characters in the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionOpacity | Gets or sets the opacity of the SelectionBrush. (Inherited from TextBoxBase.)
Public property | SelectionStart | Gets or sets a character index for the beginning of the current selection. (Inherited from TextBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | SpellCheck | Gets a SpellCheck object that provides access to spelling errors in the text contents of a TextBoxBase or RichTextBox. (Inherited from TextBoxBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | SupportExpressions |
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Gets or sets the text contents of the text box. (Inherited from TextBox.)
Public property | TextAlignment | Gets or sets the horizontal alignment of the contents of the text box. (Inherited from TextBox.)
Public property | TextDecorations | Gets the text decorations to apply to the text box. (Inherited from TextBox.)
Public property | TextInputType |
Public property | TextWrapping | Gets or sets how the text box should wrap text. (Inherited from TextBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Typography | Gets the currently effective typography variations for the text contents of the text box. (Inherited from TextBox.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UndoLimit | Gets or sets the number of actions stored in the undo queue. (Inherited from TextBoxBase.)
Public property | UseCustomUndo | (Inherited from UndoableTextBox.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Gets or sets the vertical scroll position. (Inherited from TextBoxBase.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical scroll bar is shown. (Inherited from TextBoxBase.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | ViewportHeight | Gets the vertical size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | ViewportWidth | Gets the horizontal size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ResetableTextBox Class
VisualComponents.UX.Shared Namespace


ResetableTextBox.DefaultValue Property

ResetableTextBoxDefaultValue Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string DefaultValue { get; set; }
public:
property String^ DefaultValue {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ResetableTextBox Class
VisualComponents.UX.Shared Namespace


ResetableTextBox.ExpressionContext Property

ResetableTextBoxExpressionContext Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IExpressionContext ExpressionContext { get; set; }
public:
property IExpressionContext^ ExpressionContext {
    IExpressionContext^ get ();
    void set (IExpressionContext^ value);
}

Property Value

Type: IExpressionContext
See Also

Reference

ResetableTextBox Class
VisualComponents.UX.Shared Namespace


ResetableTextBox.ResetButtonColor Property

ResetableTextBoxResetButtonColor Property

Set slider Thumb Color.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SolidColorBrush ResetButtonColor { get; set; }
public:
property SolidColorBrush^ ResetButtonColor {
    SolidColorBrush^ get ();
    void set (SolidColorBrush^ value);
}

Property Value

Type: SolidColorBrush
See Also

Reference

ResetableTextBox Class
VisualComponents.UX.Shared Namespace


ResetableTextBox.ResetButtonContent Property

ResetableTextBoxResetButtonContent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ResetButtonContent { get; set; }
public:
property String^ ResetButtonContent {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ResetableTextBox Class
VisualComponents.UX.Shared Namespace


ResetableTextBox.SupportExpressions Property

ResetableTextBoxSupportExpressions Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool SupportExpressions { get; }
public:
property bool SupportExpressions {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ResetableTextBox Class
VisualComponents.UX.Shared Namespace


ResetableTextBox.TextInputType Property

ResetableTextBoxTextInputType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TextInputType TextInputType { get; set; }
public:
property TextInputType TextInputType {
    TextInputType get ();
    void set (TextInputType value);
}

Property Value

Type: TextInputType
See Also

Reference

ResetableTextBox Class
VisualComponents.UX.Shared Namespace


ResetableTextBox Methods

The ResetableTextBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AppendText | Appends a string to the contents of a text control. (Inherited from TextBoxBase.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginChange | Begins a change block. (Inherited from TextBoxBase.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | Clears all the content from the text box. (Inherited from TextBox.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Copy | Copies the current selection of the text editing control to the Clipboard. (Inherited from TextBoxBase.)
Public method | Cut | Removes the current selection from the text editing control and copies it to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeclareChangeBlock | Creates a change block. (Inherited from TextBoxBase.)
Public method | EndChange | Ends a change block. (Inherited from TextBoxBase.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetCharacterIndexFromLineIndex | Returns the zero-based character index for the first character in the specified line. (Inherited from TextBox.)
Public method | GetCharacterIndexFromPoint | Returns the zero-based index of the character that is closest to the specified point. (Inherited from TextBox.)
Public method | GetFirstVisibleLineIndex | Returns the line index for the first line that is currently visible in the text box. (Inherited from TextBox.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLastVisibleLineIndex | Returns the line index for the last line that is currently visible in the text box. (Inherited from TextBox.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLineIndexFromCharacterIndex | Returns the zero-based line index for the line that contains the specified character index. (Inherited from TextBox.)
Public method | GetLineLength | Returns the number of characters in the specified line. (Inherited from TextBox.)
Public method | GetLineText | Returns the text that is currently displayed on the specified line. (Inherited from TextBox.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetNextSpellingErrorCharacterIndex | Returns the beginning character index for the next spelling error in the contents of the text box. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32) | Returns the rectangle for the leading edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32, Boolean) | Returns the rectangle for the leading or trailing edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetSpellingError | Returns a SpellingError object associated with any spelling error at the specified character index. (Inherited from TextBox.)
Public method | GetSpellingErrorLength | Returns the length of any spelling error that includes the specified character. (Inherited from TextBox.)
Public method | GetSpellingErrorStart | Returns the beginning character index for any spelling error that includes the specified character. (Inherited from TextBox.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls the contents of the control down by one line. (Inherited from TextBoxBase.)
Public method | LineLeft | Scrolls the contents of the control to the left by one line. (Inherited from TextBoxBase.)
Public method | LineRight | Scrolls the contents of the control to the right by one line. (Inherited from TextBoxBase.)
Public method | LineUp | Scrolls the contents of the control upward by one line. (Inherited from TextBoxBase.)
Public method | LockCurrentUndoUnit | Locks the most recent undo unit of the undo stack of the application. This prevents the locked unit from being merged with undo units that are added subsequently. (Inherited from TextBoxBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Sizes the text box to its content. (Inherited from TextBox.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides TextBoxBaseOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Called whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for the text box. (Inherited from TextBox.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragLeave | Invoked whenever an unhandled DragLeave attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragOver | Invoked whenever an unhandled DragOver attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDrop | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGiveFeedback | Invoked whenever an unhandled GiveFeedback attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotFocus | (Overrides FrameworkElementOnGotFocus(RoutedEventArgs).)
Protected method | OnGotKeyboardFocus | Invoked whenever an unhandled GotKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | (Inherited from UndoableTextBox.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked whenever an unhandled KeyDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnKeyUp | Invoked whenever an unhandled KeyUp attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostFocus | (Overrides TextBoxBaseOnLostFocus(RoutedEventArgs).)
Protected method | OnLostKeyboardFocus | Invoked whenever an unhandled LostKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked whenever an unhandled MouseDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked whenever an unhandled MouseMove attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked whenever an unhandled MouseUp event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Is called when a MouseWheel event is routed to this class (or to a class that inherits from this class). (Inherited from TextBoxBase.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | (Overrides TextBoxBaseOnPreviewKeyDown(KeyEventArgs).)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | (Overrides ControlOnPreviewMouseDoubleClick(MouseButtonEventArgs).)
Protected method | OnPreviewMouseDown | (Overrides UIElementOnPreviewMouseDown(MouseButtonEventArgs).)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Ignore incorrect characters (one by one) (Overrides UIElementOnPreviewTextInput(TextCompositionEventArgs).)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Called when one or more of the dependency properties that exist on the element have had their effective values changed. (Inherited from TextBox.)
Protected method | OnQueryContinueDrag | Invoked whenever an unhandled QueryContinueDrag attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnQueryCursor | Invoked whenever an unhandled QueryCursor attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Is called when the caret or current selection changes position. (Inherited from TextBoxBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Is called when the control template changes. (Inherited from TextBoxBase.)
Protected method | OnTextChanged | (Overrides UndoableTextBoxOnTextChanged(TextChangedEventArgs).)
Protected method | OnTextInput | Invoked whenever an unhandled TextInput attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | PageDown | Scrolls the contents of the control down by one page. (Inherited from TextBoxBase.)
Public method | PageLeft | Scrolls the contents of the control to the left by one page. (Inherited from TextBoxBase.)
Public method | PageRight | Scrolls the contents of the control to the right by one page. (Inherited from TextBoxBase.)
Public method | PageUp | Scrolls the contents of the control up by one page. (Inherited from TextBoxBase.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | Paste | Pastes the contents of the Clipboard over the current selection in the text editing control. (Inherited from TextBoxBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Redo | Undoes the most recent undo command. In other words, redoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollToEnd | Scrolls the view of the editing control to the end of the content. (Inherited from TextBoxBase.)
Public method | ScrollToHome | Scrolls the view of the editing control to the beginning of the viewport. (Inherited from TextBoxBase.)
Public method | ScrollToHorizontalOffset | Scrolls the contents of the editing control to the specified horizontal offset. (Inherited from TextBoxBase.)
Public method | ScrollToLine | Scrolls the line at the specified line index into view. (Inherited from TextBox.)
Public method | ScrollToVerticalOffset | Scrolls the contents of the editing control to the specified vertical offset. (Inherited from TextBoxBase.)
Public method | Select | Selects a range of text in the text box. (Inherited from TextBox.)
Public method | SelectAll | Selects all the contents of the text editing control. (Inherited from TextBoxBase.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeText | Returns a value that indicates whether the effective value of the Text property should be serialized during serialization of the TextBox object. (Inherited from TextBox.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | Undo | Undoes the most recent undo command. In other words, undoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ResetableTextBox Class
VisualComponents.UX.Shared Namespace


ResetableTextBox.OnApplyTemplate Method

ResetableTextBoxOnApplyTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

ResetableTextBox Class
VisualComponents.UX.Shared Namespace


ResetableTextBox.OnGotFocus Method

ResetableTextBoxOnGotFocus Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnGotFocus(
    RoutedEventArgs e
)
protected:
virtual void OnGotFocus(
    RoutedEventArgs^ e
) override

Parameters

e
Type: System.WindowsRoutedEventArgs
See Also

Reference

ResetableTextBox Class
VisualComponents.UX.Shared Namespace


ResetableTextBox.OnLostFocus Method

ResetableTextBoxOnLostFocus Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnLostFocus(
    RoutedEventArgs e
)
protected:
virtual void OnLostFocus(
    RoutedEventArgs^ e
) override

Parameters

e
Type: System.WindowsRoutedEventArgs
See Also

Reference

ResetableTextBox Class
VisualComponents.UX.Shared Namespace


ResetableTextBox.OnPreviewKeyDown Method

ResetableTextBoxOnPreviewKeyDown Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnPreviewKeyDown(
    KeyEventArgs e
)
protected:
virtual void OnPreviewKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputKeyEventArgs
See Also

Reference

ResetableTextBox Class
VisualComponents.UX.Shared Namespace


ResetableTextBox.OnPreviewMouseDoubleClick Method

ResetableTextBoxOnPreviewMouseDoubleClick Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnPreviewMouseDoubleClick(
    MouseButtonEventArgs e
)
protected:
virtual void OnPreviewMouseDoubleClick(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
See Also

Reference

ResetableTextBox Class
VisualComponents.UX.Shared Namespace


ResetableTextBox.OnPreviewMouseDown Method

ResetableTextBoxOnPreviewMouseDown Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnPreviewMouseDown(
    MouseButtonEventArgs e
)
protected:
virtual void OnPreviewMouseDown(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
See Also

Reference

ResetableTextBox Class
VisualComponents.UX.Shared Namespace


ResetableTextBox.OnPreviewTextInput Method

ResetableTextBoxOnPreviewTextInput Method

Ignore incorrect characters (one by one)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnPreviewTextInput(
    TextCompositionEventArgs e
)
protected:
virtual void OnPreviewTextInput(
    TextCompositionEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputTextCompositionEventArgs
See Also

Reference

ResetableTextBox Class
VisualComponents.UX.Shared Namespace


ResetableTextBox.OnTextChanged Method

ResetableTextBoxOnTextChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnTextChanged(
    TextChangedEventArgs e
)
protected:
virtual void OnTextChanged(
    TextChangedEventArgs^ e
) override

Parameters

e
Type: System.Windows.ControlsTextChangedEventArgs
See Also

Reference

ResetableTextBox Class
VisualComponents.UX.Shared Namespace


ResetableTextBox Events

The ResetableTextBox type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBoxBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextChanged | Occurs when content changes in the text element. (Inherited from TextBoxBase.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ResetableTextBox Class
VisualComponents.UX.Shared Namespace


ResetableTextBox Fields

The ResetableTextBox type exposes the following members.

Fields
Name | Description
DefaultValueProperty |
ExpressionContextProperty |
ResetButtonColorProperty |
ResetButtonContentProperty |
TextInputTypeProperty |
Top
See Also

Reference

ResetableTextBox Class
VisualComponents.UX.Shared Namespace


ResetableTextBox.DefaultValueProperty Field

ResetableTextBoxDefaultValueProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty DefaultValueProperty
public:
static DependencyProperty^ DefaultValueProperty

Field Value

Type: DependencyProperty
See Also

Reference

ResetableTextBox Class
VisualComponents.UX.Shared Namespace


ResetableTextBox.ExpressionContextProperty Field

ResetableTextBoxExpressionContextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ExpressionContextProperty
public:
static initonly DependencyProperty^ ExpressionContextProperty

Field Value

Type: DependencyProperty
See Also

Reference

ResetableTextBox Class
VisualComponents.UX.Shared Namespace


ResetableTextBox.ResetButtonColorProperty Field

ResetableTextBoxResetButtonColorProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ResetButtonColorProperty
public:
static initonly DependencyProperty^ ResetButtonColorProperty

Field Value

Type: DependencyProperty
See Also

Reference

ResetableTextBox Class
VisualComponents.UX.Shared Namespace


ResetableTextBox.ResetButtonContentProperty Field

ResetableTextBoxResetButtonContentProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty ResetButtonContentProperty
public:
static DependencyProperty^ ResetButtonContentProperty

Field Value

Type: DependencyProperty
See Also

Reference

ResetableTextBox Class
VisualComponents.UX.Shared Namespace


ResetableTextBox.TextInputTypeProperty Field

ResetableTextBoxTextInputTypeProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty TextInputTypeProperty
public:
static initonly DependencyProperty^ TextInputTypeProperty

Field Value

Type: DependencyProperty
See Also

Reference

ResetableTextBox Class
VisualComponents.UX.Shared Namespace


ResourceFileHelper Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedResourceFileHelper

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class ResourceFileHelper
public ref class ResourceFileHelper abstract sealed

The ResourceFileHelper type exposes the following members.

Methods
Name | Description
ReadFromResourceFile |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ResourceFileHelper Methods

The ResourceFileHelper type exposes the following members.

Methods
Name | Description
ReadFromResourceFile |
Top
See Also

Reference

ResourceFileHelper Class
VisualComponents.UX.Shared Namespace


ResourceFileHelper.ReadFromResourceFile Method

ResourceFileHelperReadFromResourceFile Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string ReadFromResourceFile(
    string key,
    string resourceLocation
)
public:
static String^ ReadFromResourceFile(
    String^ key,
    String^ resourceLocation
)

Parameters

key
Type: SystemString
resourceLocation
Type: SystemString

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ResourceFileHelper.ReadFromResourceFile(System.String,System.String)"]

See Also

Reference

ResourceFileHelper Class
VisualComponents.UX.Shared Namespace


ResourceType Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ResourceType
public enum class ResourceType
Members
Member name | Value | Description
File | 0 |
Folder | 1 |
See Also

Reference

VisualComponents.UX.Shared Namespace


RibbonConfigElement Class

Define a custom configuration element to be contained by the ImportSection. This element stores Properties that are altered from Import tab Inside Options Backstage item .
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
VisualComponents.UX.SharedRibbonConfigElement

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RibbonConfigElement : ConfigurationElement
public ref class RibbonConfigElement : public ConfigurationElement

The RibbonConfigElement type exposes the following members.

Constructors
 | Name | Description
Public method | RibbonConfigElement | Initializes a new instance of the RibbonConfigElement class
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is . (Inherited from ConfigurationElement.)
Public property | IsMinimized |
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | QatLocation |
Top
Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RibbonConfigElement Constructor

Initializes a new instance of the RibbonConfigElement class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RibbonConfigElement()
public:
RibbonConfigElement()
See Also

Reference

RibbonConfigElement Class
VisualComponents.UX.Shared Namespace


RibbonConfigElement Properties

The RibbonConfigElement type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is . (Inherited from ConfigurationElement.)
Public property | IsMinimized |
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | QatLocation |
Top
See Also

Reference

RibbonConfigElement Class
VisualComponents.UX.Shared Namespace


RibbonConfigElement.IsMinimized Property

RibbonConfigElementIsMinimized Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsMinimized { get; set; }
public:
property bool IsMinimized {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

RibbonConfigElement Class
VisualComponents.UX.Shared Namespace


RibbonConfigElement.QatLocation Property

RibbonConfigElementQatLocation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string QatLocation { get; set; }
public:
property String^ QatLocation {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

RibbonConfigElement Class
VisualComponents.UX.Shared Namespace


RibbonConfigElement Methods

The RibbonConfigElement type exposes the following members.

Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RibbonConfigElement Class
VisualComponents.UX.Shared Namespace


RibbonInitializedEventArgs Class

Event args for the ribbon initialized event of the application Ribbon.
Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.UX.SharedRibbonInitializedEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RibbonInitializedEventArgs : EventArgs
public ref class RibbonInitializedEventArgs : public EventArgs

The RibbonInitializedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | RibbonInitializedEventArgs | Initializes a new RibbonInitializedEventArgs
Top
Properties
 | Name | Description
Public property | IsInitialized | Returns if ribbon is initialize or note.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RibbonInitializedEventArgs Constructor

Initializes a new RibbonInitializedEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RibbonInitializedEventArgs(
    bool initialized = false
)
public:
RibbonInitializedEventArgs(
    bool initialized = false
)

Parameters

initialized (Optional)
Type: SystemBoolean
returns true if ribbon items are added to GUI.Else it returns false.
See Also

Reference

RibbonInitializedEventArgs Class
VisualComponents.UX.Shared Namespace


RibbonInitializedEventArgs Properties

The RibbonInitializedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | IsInitialized | Returns if ribbon is initialize or note.
Top
See Also

Reference

RibbonInitializedEventArgs Class
VisualComponents.UX.Shared Namespace


RibbonInitializedEventArgs.IsInitialized Property

RibbonInitializedEventArgsIsInitialized Property

Returns if ribbon is initialize or note.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsInitialized { get; protected set; }
public:
property bool IsInitialized {
    bool get ();
    protected: void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

RibbonInitializedEventArgs Class
VisualComponents.UX.Shared Namespace


RibbonInitializedEventArgs Methods

The RibbonInitializedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RibbonInitializedEventArgs Class
VisualComponents.UX.Shared Namespace


RibbonInitializedHandler Delegate

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public delegate void RibbonInitializedHandler(
    Object o,
    RibbonInitializedEventArgs e
)
public delegate void RibbonInitializedHandler(
    Object^ o,
    RibbonInitializedEventArgs^ e
)

Parameters

o
Type: SystemObject
e
Type: VisualComponents.UX.SharedRibbonInitializedEventArgs
See Also

Reference

VisualComponents.UX.Shared Namespace


RibbonSection Class

Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationSection
VisualComponents.UX.SharedRibbonSection

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class RibbonSection : ConfigurationSection,
    IRibbonSection, ISection
public ref class RibbonSection sealed : public ConfigurationSection,
    IRibbonSection, ISection

The RibbonSection type exposes the following members.

Constructors
 | Name | Description
Public method | RibbonSection | Initializes a new instance of the RibbonSection class
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | QatRibbonGroups |
Public property | QatRibbonTools |
Public property | RibbonSetting |
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName |
Public property | SectionType |
Public property | SectionVersion |
Top
Methods
 | Name | Description
Public method | CheckVersion |
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RibbonSection Constructor

Initializes a new instance of the RibbonSection class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RibbonSection()
public:
RibbonSection()
See Also

Reference

RibbonSection Class
VisualComponents.UX.Shared Namespace


RibbonSection Properties

The RibbonSection type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | QatRibbonGroups |
Public property | QatRibbonTools |
Public property | RibbonSetting |
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SectionName |
Public property | SectionType |
Public property | SectionVersion |
Top
See Also

Reference

RibbonSection Class
VisualComponents.UX.Shared Namespace


RibbonSection.QatRibbonGroups Property

RibbonSectionQatRibbonGroups Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public QatRibbonGroupsConfigCollection QatRibbonGroups { get; }
public:
virtual property QatRibbonGroupsConfigCollection^ QatRibbonGroups {
    QatRibbonGroupsConfigCollection^ get () sealed;
}

Property Value

Type: QatRibbonGroupsConfigCollection

Implements

IRibbonSectionQatRibbonGroups
See Also

Reference

RibbonSection Class
VisualComponents.UX.Shared Namespace


RibbonSection.QatRibbonTools Property

RibbonSectionQatRibbonTools Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public QatRibbonToolsConfigCollection QatRibbonTools { get; }
public:
virtual property QatRibbonToolsConfigCollection^ QatRibbonTools {
    QatRibbonToolsConfigCollection^ get () sealed;
}

Property Value

Type: QatRibbonToolsConfigCollection

Implements

IRibbonSectionQatRibbonTools
See Also

Reference

RibbonSection Class
VisualComponents.UX.Shared Namespace


RibbonSection.RibbonSetting Property

RibbonSectionRibbonSetting Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RibbonConfigElement RibbonSetting { get; set; }
public:
virtual property RibbonConfigElement^ RibbonSetting {
    RibbonConfigElement^ get () sealed;
    void set (RibbonConfigElement^ value) sealed;
}

Property Value

Type: RibbonConfigElement

Implements

IRibbonSectionRibbonSetting
See Also

Reference

RibbonSection Class
VisualComponents.UX.Shared Namespace


RibbonSection.SectionName Property

RibbonSectionSectionName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SectionName { get; }
public:
virtual property String^ SectionName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ISectionSectionName
See Also

Reference

RibbonSection Class
VisualComponents.UX.Shared Namespace


RibbonSection.SectionType Property

RibbonSectionSectionType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type SectionType { get; }
public:
virtual property Type^ SectionType {
    Type^ get () sealed;
}

Property Value

Type: Type

Implements

ISectionSectionType
See Also

Reference

RibbonSection Class
VisualComponents.UX.Shared Namespace


RibbonSection.SectionVersion Property

RibbonSectionSectionVersion Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int SectionVersion { get; }
public:
virtual property int SectionVersion {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISectionSectionVersion
See Also

Reference

RibbonSection Class
VisualComponents.UX.Shared Namespace


RibbonSection Methods

The RibbonSection type exposes the following members.

Methods
 | Name | Description
Public method | CheckVersion |
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Public method | GetSection |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Public method | ToString | Converts this instance to string. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RibbonSection Class
VisualComponents.UX.Shared Namespace


RibbonSection.CheckVersion Method

RibbonSectionCheckVersion Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CheckVersion()
public:
virtual void CheckVersion() sealed

Implements

ISectionCheckVersion
See Also

Reference

RibbonSection Class
VisualComponents.UX.Shared Namespace


RibbonSection.GetSection Method

RibbonSectionGetSection Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISection GetSection(
    Configuration userSettingConfiguration
)
public:
virtual ISection^ GetSection(
    Configuration^ userSettingConfiguration
) sealed

Parameters

userSettingConfiguration
Type: System.ConfigurationConfiguration

Return Value

Type: ISection

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.RibbonSection.GetSection(System.Configuration.Configuration)"]

Implements

ISectionGetSection(Configuration)
See Also

Reference

RibbonSection Class
VisualComponents.UX.Shared Namespace


RibbonSection.ToString Method

RibbonSectionToString Method

Converts this instance to string.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String
String representation of this instance
See Also

Reference

RibbonSection Class
VisualComponents.UX.Shared Namespace


RibbonTab Class

Represents a tab in ribbon.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedRibbonTab

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RibbonTab
public ref class RibbonTab

The RibbonTab type exposes the following members.

Constructors
 | Name | Description
Public method | RibbonTab | Constractor
Top
Properties
 | Name | Description
Public property | Name | Stores ribbon tab name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RibbonTab Constructor

Constractor

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RibbonTab(
    string name
)
public:
RibbonTab(
    String^ name
)

Parameters

name
Type: SystemString
Ribbon tab name.
See Also

Reference

RibbonTab Class
VisualComponents.UX.Shared Namespace


RibbonTab Properties

The RibbonTab type exposes the following members.

Properties
 | Name | Description
Public property | Name | Stores ribbon tab name.
Top
See Also

Reference

RibbonTab Class
VisualComponents.UX.Shared Namespace


RibbonTab.Name Property

RibbonTabName Property

Stores ribbon tab name.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; protected set; }
public:
property String^ Name {
    String^ get ();
    protected: void set (String^ value);
}

Property Value

Type: String
See Also

Reference

RibbonTab Class
VisualComponents.UX.Shared Namespace


RibbonTab Methods

The RibbonTab type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RibbonTab Class
VisualComponents.UX.Shared Namespace


RibbonTabItemSelectedHandler Delegate

Note: This API is now obsolete.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("This property is obsolete. Use RibbonTabSelectedHandler instead.",
    false)]
public delegate void RibbonTabItemSelectedHandler(
    Object o,
    RibbonTabItemSelectedEventArgs e
)
[ObsoleteAttribute(L"This property is obsolete. Use RibbonTabSelectedHandler instead.",
    false)]
public delegate void RibbonTabItemSelectedHandler(
    Object^ o,
    RibbonTabItemSelectedEventArgs^ e
)

Parameters

o
Type: SystemObject
e
Type: RibbonTabItemSelectedEventArgs
See Also

Reference

VisualComponents.UX.Shared Namespace


RibbonTabSelectedEventArgs Class

Event args for the RibbonTabItemOpening event of the Application Ribbon.
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.WindowsRoutedEventArgs
VisualComponents.UX.SharedRibbonTabSelectedEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RibbonTabSelectedEventArgs : RoutedEventArgs
public ref class RibbonTabSelectedEventArgs : public RoutedEventArgs

The RibbonTabSelectedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | RibbonTabSelectedEventArgs | Initializes a new RibbonTabSelectedEventArgs
Top
Properties
 | Name | Description
Public property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from RoutedEventArgs.)
Public property | NewSelectedRibbonTabItem | Returns the newly selected RibbonTabItem.
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)
Public property | PreviousSelectedRibbonTabItem | Returns the RibbonTabItem that was previously selected.
Public property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from RoutedEventArgs.)
Public property | Source | Gets or sets a reference to the object that raised the event. (Inherited from RoutedEventArgs.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokeEventHandler | When overridden in a derived class, provides a way to invoke event handlers in a type-specific way, which can increase efficiency over the base implementation. (Inherited from RoutedEventArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnSetSource | When overridden in a derived class, provides a notification callback entry point whenever the value of the Source property of an instance changes. (Inherited from RoutedEventArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RibbonTabSelectedEventArgs Constructor

Initializes a new RibbonTabSelectedEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RibbonTabSelectedEventArgs(
    RibbonTab previousTabItem,
    RibbonTab newTabItem
)
public:
RibbonTabSelectedEventArgs(
    RibbonTab^ previousTabItem,
    RibbonTab^ newTabItem
)

Parameters

previousTabItem
Type: VisualComponents.UX.SharedRibbonTab
Returns the newly selected RibbonTabItem
newTabItem
Type: VisualComponents.UX.SharedRibbonTab
Returns the RibbonTabItem that was previously selected.
See Also

Reference

RibbonTabSelectedEventArgs Class
VisualComponents.UX.Shared Namespace


RibbonTabSelectedEventArgs Properties

The RibbonTabSelectedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route. (Inherited from RoutedEventArgs.)
Public property | NewSelectedRibbonTabItem | Returns the newly selected RibbonTabItem.
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)
Public property | PreviousSelectedRibbonTabItem | Returns the RibbonTabItem that was previously selected.
Public property | RoutedEvent | Gets or sets the RoutedEvent associated with this RoutedEventArgs instance. (Inherited from RoutedEventArgs.)
Public property | Source | Gets or sets a reference to the object that raised the event. (Inherited from RoutedEventArgs.)
Top
See Also

Reference

RibbonTabSelectedEventArgs Class
VisualComponents.UX.Shared Namespace


RibbonTabSelectedEventArgs.NewSelectedRibbonTabItem Property

RibbonTabSelectedEventArgsNewSelectedRibbonTabItem Property

Returns the newly selected RibbonTabItem.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RibbonTab NewSelectedRibbonTabItem { get; protected set; }
public:
property RibbonTab^ NewSelectedRibbonTabItem {
    RibbonTab^ get ();
    protected: void set (RibbonTab^ value);
}

Property Value

Type: RibbonTab
See Also

Reference

RibbonTabSelectedEventArgs Class
VisualComponents.UX.Shared Namespace


RibbonTabSelectedEventArgs.PreviousSelectedRibbonTabItem Property

RibbonTabSelectedEventArgsPreviousSelectedRibbonTabItem Property

Returns the RibbonTabItem that was previously selected.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RibbonTab PreviousSelectedRibbonTabItem { get; protected set; }
public:
property RibbonTab^ PreviousSelectedRibbonTabItem {
    RibbonTab^ get ();
    protected: void set (RibbonTab^ value);
}

Property Value

Type: RibbonTab
See Also

Reference

RibbonTabSelectedEventArgs Class
VisualComponents.UX.Shared Namespace


RibbonTabSelectedEventArgs Methods

The RibbonTabSelectedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InvokeEventHandler | When overridden in a derived class, provides a way to invoke event handlers in a type-specific way, which can increase efficiency over the base implementation. (Inherited from RoutedEventArgs.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnSetSource | When overridden in a derived class, provides a notification callback entry point whenever the value of the Source property of an instance changes. (Inherited from RoutedEventArgs.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RibbonTabSelectedEventArgs Class
VisualComponents.UX.Shared Namespace


RibbonTabSelectedHandler Delegate

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public delegate void RibbonTabSelectedHandler(
    Object o,
    RibbonTabSelectedEventArgs e
)
public delegate void RibbonTabSelectedHandler(
    Object^ o,
    RibbonTabSelectedEventArgs^ e
)

Parameters

o
Type: SystemObject
e
Type: VisualComponents.UX.SharedRibbonTabSelectedEventArgs
See Also

Reference

VisualComponents.UX.Shared Namespace


RibbonToolWrapPanel Class

Wrap panel that combines measure/arrange behavior of ToolVerticalWrapPanel and resizing behavior of ToolHorizontalWrapPanel, avoids falling into infinite layout loop and speeds up (a bit) arrangement of Ribbon tools. Known issues: depends on ToolHorizontalWrapPanel.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsPanel
ToolHorizontalWrapPanel
VisualComponents.UX.SharedRibbonToolWrapPanel

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RibbonToolWrapPanel : ToolHorizontalWrapPanel
public ref class RibbonToolWrapPanel : public ToolHorizontalWrapPanel

The RibbonToolWrapPanel type exposes the following members.

Constructors
 | Name | Description
Public method | RibbonToolWrapPanel | Initializes a new instance of the RibbonToolWrapPanel class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | HasLogicalOrientationPublic | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | LogicalOrientationPublic | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxRows | (Inherited from ToolHorizontalWrapPanel.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinRows | (Inherited from ToolHorizontalWrapPanel.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RowCount | (Inherited from ToolHorizontalWrapPanel.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalToolAlignment |
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | (Overrides ToolHorizontalWrapPanel.ArrangeOverride(Size).)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | (Overrides ToolHorizontalWrapPanel.MeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | (Overrides UIElementOnChildDesiredSizeChanged(UIElement).)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | (Overrides ToolHorizontalWrapPanel.OnVisualChildrenChanged(DependencyObject, DependencyObject).)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
VerticalToolAlignmentProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RibbonToolWrapPanel Constructor

Initializes a new instance of the RibbonToolWrapPanel class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RibbonToolWrapPanel()
public:
RibbonToolWrapPanel()
See Also

Reference

RibbonToolWrapPanel Class
VisualComponents.UX.Shared Namespace


RibbonToolWrapPanel Properties

The RibbonToolWrapPanel type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | HasLogicalOrientationPublic | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | LogicalOrientationPublic | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxRows | (Inherited from ToolHorizontalWrapPanel.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinRows | (Inherited from ToolHorizontalWrapPanel.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RowCount | (Inherited from ToolHorizontalWrapPanel.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalToolAlignment |
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

RibbonToolWrapPanel Class
VisualComponents.UX.Shared Namespace


RibbonToolWrapPanel.VerticalToolAlignment Property

RibbonToolWrapPanelVerticalToolAlignment Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RibbonPanelVerticalToolAlignment VerticalToolAlignment { get; set; }
public:
property RibbonPanelVerticalToolAlignment VerticalToolAlignment {
    RibbonPanelVerticalToolAlignment get ();
    void set (RibbonPanelVerticalToolAlignment value);
}

Property Value

Type: RibbonPanelVerticalToolAlignment
See Also

Reference

RibbonToolWrapPanel Class
VisualComponents.UX.Shared Namespace


RibbonToolWrapPanel Methods

The RibbonToolWrapPanel type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | (Overrides ToolHorizontalWrapPanel.ArrangeOverride(Size).)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | (Overrides ToolHorizontalWrapPanel.MeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | (Overrides UIElementOnChildDesiredSizeChanged(UIElement).)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | (Overrides ToolHorizontalWrapPanel.OnVisualChildrenChanged(DependencyObject, DependencyObject).)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RibbonToolWrapPanel Class
VisualComponents.UX.Shared Namespace


RibbonToolWrapPanel.ArrangeOverride Method

RibbonToolWrapPanelArrangeOverride Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
protected:
virtual Size ArrangeOverride(
    Size finalSize
) override

Parameters

finalSize
Type: System.WindowsSize

Return Value

Type: Size

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.RibbonToolWrapPanel.ArrangeOverride(System.Windows.Size)"]

See Also

Reference

RibbonToolWrapPanel Class
VisualComponents.UX.Shared Namespace


RibbonToolWrapPanel.MeasureOverride Method

RibbonToolWrapPanelMeasureOverride Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Size MeasureOverride(
    Size availableSize
)
protected:
virtual Size MeasureOverride(
    Size availableSize
) override

Parameters

availableSize
Type: System.WindowsSize

Return Value

Type: Size

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.RibbonToolWrapPanel.MeasureOverride(System.Windows.Size)"]

See Also

Reference

RibbonToolWrapPanel Class
VisualComponents.UX.Shared Namespace


RibbonToolWrapPanel.OnChildDesiredSizeChanged Method

RibbonToolWrapPanelOnChildDesiredSizeChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnChildDesiredSizeChanged(
    UIElement child
)
protected:
virtual void OnChildDesiredSizeChanged(
    UIElement^ child
) override

Parameters

child
Type: System.WindowsUIElement
See Also

Reference

RibbonToolWrapPanel Class
VisualComponents.UX.Shared Namespace


RibbonToolWrapPanel.OnVisualChildrenChanged Method

RibbonToolWrapPanelOnVisualChildrenChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnVisualChildrenChanged(
    DependencyObject visualAdded,
    DependencyObject visualRemoved
)
protected:
virtual void OnVisualChildrenChanged(
    DependencyObject^ visualAdded,
    DependencyObject^ visualRemoved
) override

Parameters

visualAdded
Type: System.WindowsDependencyObject
visualRemoved
Type: System.WindowsDependencyObject
See Also

Reference

RibbonToolWrapPanel Class
VisualComponents.UX.Shared Namespace


RibbonToolWrapPanel Events

The RibbonToolWrapPanel type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

RibbonToolWrapPanel Class
VisualComponents.UX.Shared Namespace


RibbonToolWrapPanel Fields

The RibbonToolWrapPanel type exposes the following members.

Fields
Name | Description
VerticalToolAlignmentProperty |
Top
See Also

Reference

RibbonToolWrapPanel Class
VisualComponents.UX.Shared Namespace


RibbonToolWrapPanel.VerticalToolAlignmentProperty Field

RibbonToolWrapPanelVerticalToolAlignmentProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty VerticalToolAlignmentProperty
public:
static initonly DependencyProperty^ VerticalToolAlignmentProperty

Field Value

Type: DependencyProperty
See Also

Reference

RibbonToolWrapPanel Class
VisualComponents.UX.Shared Namespace


RichTextBoxEx Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.Controls.PrimitivesTextBoxBase
System.Windows.ControlsRichTextBox
RichTextBox
VisualComponents.UX.SharedUndoableRichTextBox
VisualComponents.UX.SharedRichTextBoxEx

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RichTextBoxEx : UndoableRichTextBox
public ref class RichTextBoxEx : public UndoableRichTextBox

The RichTextBoxEx type exposes the following members.

Constructors
 | Name | Description
Public method | RichTextBoxEx | Initializes a new instance of the RichTextBoxEx class
Top
Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key. (Inherited from TextBoxBase.)
Public property | AcceptsTab | Gets or sets a value that indicates how the text editing control responds when the user presses the TAB key. (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoAddWhiteSpaceAfterTriggered |
Public property | AutoWordSelection | Gets or sets a value that determines whether when a user selects part of a word by dragging across it with the mouse, the rest of the word is selected. (Inherited from TextBoxBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanRedo | Gets a value that indicates whether the most recent undo action can be redone. (Inherited from TextBoxBase.)
Public property | CanUndo | Gets a value that indicates whether the most recent action can be undone. (Inherited from TextBoxBase.)
Public property | CaretBrush | Gets or sets the brush that is used to paint the caret of the text box. (Inherited from TextBoxBase.)
Public property | CaretPosition | Gets or sets the position of the input caret. (Inherited from RichTextBox.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContentAssistSource |
Public property | ContentAssistTriggers |
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Document | Gets or sets the FlowDocument that represents the contents of the RichTextBox. (Inherited from RichTextBox.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExpressionType |
Public property | ExtentHeight | Gets the vertical size of the visible content area. (Inherited from TextBoxBase.)
Public property | ExtentWidth | Gets the horizontal size of the visible content area. (Inherited from TextBoxBase.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Gets or sets the horizontal scroll position. (Inherited from TextBoxBase.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal scroll bar is shown. (Inherited from TextBoxBase.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsDocumentEnabled | Gets or sets a value that indicates whether the user can interact with UIElement and ContentElement objects within the RichTextBox. (Inherited from RichTextBox.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInactiveSelectionHighlightEnabled | Gets or sets a value that indicates whether the text box displays selected text when the text box does not have focus. (Inherited from TextBoxBase.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that indicates whether the text editing control is read-only to a user interacting with the control. (Inherited from TextBoxBase.)
Public property | IsReadOnlyCaretVisible | Gets or sets a value that indicates whether a read-only text box displays a caret. (Inherited from TextBoxBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionActive | Gets a value that indicates whether the text box has focus and selected text. (Inherited from TextBoxBase.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets a value that indicates whether undo support is enabled for the text-editing control. (Inherited from TextBoxBase.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical children of the RichTextBox. (Inherited from RichTextBox.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Selection | Gets a TextSelection object containing the current selection in the RichTextBox. (Inherited from RichTextBox.)
Public property | SelectionBrush | Gets or sets the brush that highlights selected text. (Inherited from TextBoxBase.)
Public property | SelectionOpacity | Gets or sets the opacity of the SelectionBrush. (Inherited from TextBoxBase.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | SpellCheck | Gets a SpellCheck object that provides access to spelling errors in the text contents of a TextBoxBase or RichTextBox. (Inherited from TextBoxBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | (Inherited from RichTextBox.)
Public property | TextFormatter | (Inherited from RichTextBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UndoLimit | Gets or sets the number of actions stored in the undo queue. (Inherited from TextBoxBase.)
Public property | UseCustomUndo | (Inherited from UndoableRichTextBox.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Gets or sets the vertical scroll position. (Inherited from TextBoxBase.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical scroll bar is shown. (Inherited from TextBoxBase.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | ViewportHeight | Gets the vertical size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | ViewportWidth | Gets the horizontal size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AppendText | Appends a string to the contents of a text control. (Inherited from TextBoxBase.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginChange | Begins a change block. (Inherited from TextBoxBase.)
Public method | BeginInit | (Inherited from RichTextBox.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | (Inherited from RichTextBox.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Copy | Copies the current selection of the text editing control to the Clipboard. (Inherited from TextBoxBase.)
Public method | Cut | Removes the current selection from the text editing control and copies it to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeclareChangeBlock | Creates a change block. (Inherited from TextBoxBase.)
Public method | EndChange | Ends a change block. (Inherited from TextBoxBase.)
Public method | EndInit | (Inherited from RichTextBox.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetNextSpellingErrorPosition | Returns a TextPointer that points to the next spelling error in the contents of the RichTextBox. (Inherited from RichTextBox.)
Public method | GetPositionFromPoint | Returns a TextPointer that points to the insertion point closest to the specified position. (Inherited from RichTextBox.)
Public method | GetSpellingError | Returns a SpellingError object associated with any spelling error at a specified position in the contents of the RichTextBox. (Inherited from RichTextBox.)
Public method | GetSpellingErrorRange | Returns a TextRange object covering any misspelled word at a specified position in the contents of the RichTextBox. (Inherited from RichTextBox.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Protected method | InitUIElements |
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InsertText |
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls the contents of the control down by one line. (Inherited from TextBoxBase.)
Public method | LineLeft | Scrolls the contents of the control to the left by one line. (Inherited from TextBoxBase.)
Public method | LineRight | Scrolls the contents of the control to the right by one line. (Inherited from TextBoxBase.)
Public method | LineUp | Scrolls the contents of the control upward by one line. (Inherited from TextBoxBase.)
Public method | LockCurrentUndoUnit | Locks the most recent undo unit of the undo stack of the application. This prevents the locked unit from being merged with undo units that are added subsequently. (Inherited from TextBoxBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to re-measure the RichTextBox. (Inherited from RichTextBox.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides TextBoxBaseOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Called whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for this RichTextBox. (Inherited from RichTextBox.)
Protected method | OnDpiChanged | Called when the DPI at which this Rich Text Box is rendered changes. (Inherited from RichTextBox.)
Protected method | OnDragEnter | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragLeave | Invoked whenever an unhandled DragLeave attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragOver | Invoked whenever an unhandled DragOver attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDrop | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGiveFeedback | Invoked whenever an unhandled GiveFeedback attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | (Overrides TextBoxBaseOnGotKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | (Overrides TextBoxBaseOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | (Overrides TextBoxBaseOnKeyUp(KeyEventArgs).)
Protected method | OnLostFocus | Raises the LostFocus event (using the provided arguments). (Inherited from TextBoxBase.)
Protected method | OnLostKeyboardFocus | Invoked whenever an unhandled LostKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked whenever an unhandled MouseDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked whenever an unhandled MouseMove attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked whenever an unhandled MouseUp event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Is called when a MouseWheel event is routed to this class (or to a class that inherits from this class). (Inherited from TextBoxBase.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | (Overrides TextBoxBaseOnPreviewKeyDown(KeyEventArgs).)
Protected method | OnPreviewKeyUp | (Overrides UIElementOnPreviewKeyUp(KeyEventArgs).)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | (Overrides ControlOnPreviewMouseDoubleClick(MouseButtonEventArgs).)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked whenever an unhandled QueryContinueDrag attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnQueryCursor | Invoked whenever an unhandled QueryCursor attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Is called when the caret or current selection changes position. (Inherited from TextBoxBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Is called when the control template changes. (Inherited from TextBoxBase.)
Protected method | OnTextChanged | (Inherited from UndoableRichTextBox.)
Protected method | OnTextFormatterPropertyChanged | (Inherited from RichTextBox.)
Protected method | OnTextInput | (Overrides TextBoxBaseOnTextInput(TextCompositionEventArgs).)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | PageDown | Scrolls the contents of the control down by one page. (Inherited from TextBoxBase.)
Public method | PageLeft | Scrolls the contents of the control to the left by one page. (Inherited from TextBoxBase.)
Public method | PageRight | Scrolls the contents of the control to the right by one page. (Inherited from TextBoxBase.)
Public method | PageUp | Scrolls the contents of the control up by one page. (Inherited from TextBoxBase.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | Paste | Pastes the contents of the Clipboard over the current selection in the text editing control. (Inherited from TextBoxBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Redo | Undoes the most recent undo command. In other words, redoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollToEnd | Scrolls the view of the editing control to the end of the content. (Inherited from TextBoxBase.)
Public method | ScrollToHome | Scrolls the view of the editing control to the beginning of the viewport. (Inherited from TextBoxBase.)
Public method | ScrollToHorizontalOffset | Scrolls the contents of the editing control to the specified horizontal offset. (Inherited from TextBoxBase.)
Public method | ScrollToVerticalOffset | Scrolls the contents of the editing control to the specified vertical offset. (Inherited from TextBoxBase.)
Public method | SelectAll | Selects all the contents of the text editing control. (Inherited from TextBoxBase.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeDocument | Returns a value that indicates whether or not the effective value of the Document property should be serialized during serialization of a RichTextBox object. (Inherited from RichTextBox.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | Undo | Undoes the most recent undo command. In other words, undoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBoxBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextChanged | Occurs when content changes in the text element. (Inherited from TextBoxBase.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
AutoAddWhiteSpaceAfterTriggeredProperty |
ContentAssistSourceProperty |
ContentAssistTriggersProperty |
ExpressionTypeProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RichTextBoxEx Constructor

Initializes a new instance of the RichTextBoxEx class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RichTextBoxEx()
public:
RichTextBoxEx()
See Also

Reference

RichTextBoxEx Class
VisualComponents.UX.Shared Namespace


RichTextBoxEx Properties

The RichTextBoxEx type exposes the following members.

Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key. (Inherited from TextBoxBase.)
Public property | AcceptsTab | Gets or sets a value that indicates how the text editing control responds when the user presses the TAB key. (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoAddWhiteSpaceAfterTriggered |
Public property | AutoWordSelection | Gets or sets a value that determines whether when a user selects part of a word by dragging across it with the mouse, the rest of the word is selected. (Inherited from TextBoxBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanRedo | Gets a value that indicates whether the most recent undo action can be redone. (Inherited from TextBoxBase.)
Public property | CanUndo | Gets a value that indicates whether the most recent action can be undone. (Inherited from TextBoxBase.)
Public property | CaretBrush | Gets or sets the brush that is used to paint the caret of the text box. (Inherited from TextBoxBase.)
Public property | CaretPosition | Gets or sets the position of the input caret. (Inherited from RichTextBox.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContentAssistSource |
Public property | ContentAssistTriggers |
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Document | Gets or sets the FlowDocument that represents the contents of the RichTextBox. (Inherited from RichTextBox.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExpressionType |
Public property | ExtentHeight | Gets the vertical size of the visible content area. (Inherited from TextBoxBase.)
Public property | ExtentWidth | Gets the horizontal size of the visible content area. (Inherited from TextBoxBase.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Gets or sets the horizontal scroll position. (Inherited from TextBoxBase.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal scroll bar is shown. (Inherited from TextBoxBase.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsDocumentEnabled | Gets or sets a value that indicates whether the user can interact with UIElement and ContentElement objects within the RichTextBox. (Inherited from RichTextBox.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInactiveSelectionHighlightEnabled | Gets or sets a value that indicates whether the text box displays selected text when the text box does not have focus. (Inherited from TextBoxBase.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that indicates whether the text editing control is read-only to a user interacting with the control. (Inherited from TextBoxBase.)
Public property | IsReadOnlyCaretVisible | Gets or sets a value that indicates whether a read-only text box displays a caret. (Inherited from TextBoxBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionActive | Gets a value that indicates whether the text box has focus and selected text. (Inherited from TextBoxBase.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets a value that indicates whether undo support is enabled for the text-editing control. (Inherited from TextBoxBase.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical children of the RichTextBox. (Inherited from RichTextBox.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Selection | Gets a TextSelection object containing the current selection in the RichTextBox. (Inherited from RichTextBox.)
Public property | SelectionBrush | Gets or sets the brush that highlights selected text. (Inherited from TextBoxBase.)
Public property | SelectionOpacity | Gets or sets the opacity of the SelectionBrush. (Inherited from TextBoxBase.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | SpellCheck | Gets a SpellCheck object that provides access to spelling errors in the text contents of a TextBoxBase or RichTextBox. (Inherited from TextBoxBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | (Inherited from RichTextBox.)
Public property | TextFormatter | (Inherited from RichTextBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UndoLimit | Gets or sets the number of actions stored in the undo queue. (Inherited from TextBoxBase.)
Public property | UseCustomUndo | (Inherited from UndoableRichTextBox.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Gets or sets the vertical scroll position. (Inherited from TextBoxBase.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical scroll bar is shown. (Inherited from TextBoxBase.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | ViewportHeight | Gets the vertical size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | ViewportWidth | Gets the horizontal size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

RichTextBoxEx Class
VisualComponents.UX.Shared Namespace


RichTextBoxEx.AutoAddWhiteSpaceAfterTriggered Property

RichTextBoxExAutoAddWhiteSpaceAfterTriggered Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool AutoAddWhiteSpaceAfterTriggered { get; set; }
public:
property bool AutoAddWhiteSpaceAfterTriggered {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

RichTextBoxEx Class
VisualComponents.UX.Shared Namespace


RichTextBoxEx.ContentAssistSource Property

RichTextBoxExContentAssistSource Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IExpressionContext ContentAssistSource { get; set; }
public:
property IExpressionContext^ ContentAssistSource {
    IExpressionContext^ get ();
    void set (IExpressionContext^ value);
}

Property Value

Type: IExpressionContext
See Also

Reference

RichTextBoxEx Class
VisualComponents.UX.Shared Namespace


RichTextBoxEx.ContentAssistTriggers Property

RichTextBoxExContentAssistTriggers Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList<char> ContentAssistTriggers { get; set; }
public:
property IList<wchar_t>^ ContentAssistTriggers {
    IList<wchar_t>^ get ();
    void set (IList<wchar_t>^ value);
}

Property Value

Type: IListChar
See Also

Reference

RichTextBoxEx Class
VisualComponents.UX.Shared Namespace


RichTextBoxEx.ExpressionType Property

RichTextBoxExExpressionType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type ExpressionType { get; set; }
public:
property Type^ ExpressionType {
    Type^ get ();
    void set (Type^ value);
}

Property Value

Type: Type
See Also

Reference

RichTextBoxEx Class
VisualComponents.UX.Shared Namespace


RichTextBoxEx Methods

The RichTextBoxEx type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AppendText | Appends a string to the contents of a text control. (Inherited from TextBoxBase.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginChange | Begins a change block. (Inherited from TextBoxBase.)
Public method | BeginInit | (Inherited from RichTextBox.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | (Inherited from RichTextBox.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Copy | Copies the current selection of the text editing control to the Clipboard. (Inherited from TextBoxBase.)
Public method | Cut | Removes the current selection from the text editing control and copies it to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeclareChangeBlock | Creates a change block. (Inherited from TextBoxBase.)
Public method | EndChange | Ends a change block. (Inherited from TextBoxBase.)
Public method | EndInit | (Inherited from RichTextBox.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetNextSpellingErrorPosition | Returns a TextPointer that points to the next spelling error in the contents of the RichTextBox. (Inherited from RichTextBox.)
Public method | GetPositionFromPoint | Returns a TextPointer that points to the insertion point closest to the specified position. (Inherited from RichTextBox.)
Public method | GetSpellingError | Returns a SpellingError object associated with any spelling error at a specified position in the contents of the RichTextBox. (Inherited from RichTextBox.)
Public method | GetSpellingErrorRange | Returns a TextRange object covering any misspelled word at a specified position in the contents of the RichTextBox. (Inherited from RichTextBox.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Protected method | InitUIElements |
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InsertText |
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls the contents of the control down by one line. (Inherited from TextBoxBase.)
Public method | LineLeft | Scrolls the contents of the control to the left by one line. (Inherited from TextBoxBase.)
Public method | LineRight | Scrolls the contents of the control to the right by one line. (Inherited from TextBoxBase.)
Public method | LineUp | Scrolls the contents of the control upward by one line. (Inherited from TextBoxBase.)
Public method | LockCurrentUndoUnit | Locks the most recent undo unit of the undo stack of the application. This prevents the locked unit from being merged with undo units that are added subsequently. (Inherited from TextBoxBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to re-measure the RichTextBox. (Inherited from RichTextBox.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides TextBoxBaseOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Called whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for this RichTextBox. (Inherited from RichTextBox.)
Protected method | OnDpiChanged | Called when the DPI at which this Rich Text Box is rendered changes. (Inherited from RichTextBox.)
Protected method | OnDragEnter | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragLeave | Invoked whenever an unhandled DragLeave attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragOver | Invoked whenever an unhandled DragOver attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDrop | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGiveFeedback | Invoked whenever an unhandled GiveFeedback attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | (Overrides TextBoxBaseOnGotKeyboardFocus(KeyboardFocusChangedEventArgs).)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | (Overrides TextBoxBaseOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | (Overrides TextBoxBaseOnKeyUp(KeyEventArgs).)
Protected method | OnLostFocus | Raises the LostFocus event (using the provided arguments). (Inherited from TextBoxBase.)
Protected method | OnLostKeyboardFocus | Invoked whenever an unhandled LostKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked whenever an unhandled MouseDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked whenever an unhandled MouseMove attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked whenever an unhandled MouseUp event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Is called when a MouseWheel event is routed to this class (or to a class that inherits from this class). (Inherited from TextBoxBase.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | (Overrides TextBoxBaseOnPreviewKeyDown(KeyEventArgs).)
Protected method | OnPreviewKeyUp | (Overrides UIElementOnPreviewKeyUp(KeyEventArgs).)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | (Overrides ControlOnPreviewMouseDoubleClick(MouseButtonEventArgs).)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked whenever an unhandled QueryContinueDrag attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnQueryCursor | Invoked whenever an unhandled QueryCursor attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Is called when the caret or current selection changes position. (Inherited from TextBoxBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Is called when the control template changes. (Inherited from TextBoxBase.)
Protected method | OnTextChanged | (Inherited from UndoableRichTextBox.)
Protected method | OnTextFormatterPropertyChanged | (Inherited from RichTextBox.)
Protected method | OnTextInput | (Overrides TextBoxBaseOnTextInput(TextCompositionEventArgs).)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | PageDown | Scrolls the contents of the control down by one page. (Inherited from TextBoxBase.)
Public method | PageLeft | Scrolls the contents of the control to the left by one page. (Inherited from TextBoxBase.)
Public method | PageRight | Scrolls the contents of the control to the right by one page. (Inherited from TextBoxBase.)
Public method | PageUp | Scrolls the contents of the control up by one page. (Inherited from TextBoxBase.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | Paste | Pastes the contents of the Clipboard over the current selection in the text editing control. (Inherited from TextBoxBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Redo | Undoes the most recent undo command. In other words, redoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollToEnd | Scrolls the view of the editing control to the end of the content. (Inherited from TextBoxBase.)
Public method | ScrollToHome | Scrolls the view of the editing control to the beginning of the viewport. (Inherited from TextBoxBase.)
Public method | ScrollToHorizontalOffset | Scrolls the contents of the editing control to the specified horizontal offset. (Inherited from TextBoxBase.)
Public method | ScrollToVerticalOffset | Scrolls the contents of the editing control to the specified vertical offset. (Inherited from TextBoxBase.)
Public method | SelectAll | Selects all the contents of the text editing control. (Inherited from TextBoxBase.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeDocument | Returns a value that indicates whether or not the effective value of the Document property should be serialized during serialization of a RichTextBox object. (Inherited from RichTextBox.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | Undo | Undoes the most recent undo command. In other words, undoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RichTextBoxEx Class
VisualComponents.UX.Shared Namespace


RichTextBoxEx.InitUIElements Method

RichTextBoxExInitUIElements Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected virtual void InitUIElements()
protected:
virtual void InitUIElements()
See Also

Reference

RichTextBoxEx Class
VisualComponents.UX.Shared Namespace


RichTextBoxEx.InsertText Method

RichTextBoxExInsertText Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InsertText(
    string text
)
public:
void InsertText(
    String^ text
)

Parameters

text
Type: SystemString
See Also

Reference

RichTextBoxEx Class
VisualComponents.UX.Shared Namespace


RichTextBoxEx.OnApplyTemplate Method

RichTextBoxExOnApplyTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

RichTextBoxEx Class
VisualComponents.UX.Shared Namespace


RichTextBoxEx.OnGotKeyboardFocus Method

RichTextBoxExOnGotKeyboardFocus Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnGotKeyboardFocus(
    KeyboardFocusChangedEventArgs e
)
protected:
virtual void OnGotKeyboardFocus(
    KeyboardFocusChangedEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputKeyboardFocusChangedEventArgs
See Also

Reference

RichTextBoxEx Class
VisualComponents.UX.Shared Namespace


RichTextBoxEx.OnKeyDown Method

RichTextBoxExOnKeyDown Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnKeyDown(
    KeyEventArgs e
)
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputKeyEventArgs
See Also

Reference

RichTextBoxEx Class
VisualComponents.UX.Shared Namespace


RichTextBoxEx.OnKeyUp Method

RichTextBoxExOnKeyUp Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnKeyUp(
    KeyEventArgs e
)
protected:
virtual void OnKeyUp(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputKeyEventArgs
See Also

Reference

RichTextBoxEx Class
VisualComponents.UX.Shared Namespace


RichTextBoxEx.OnPreviewKeyDown Method

RichTextBoxExOnPreviewKeyDown Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnPreviewKeyDown(
    KeyEventArgs e
)
protected:
virtual void OnPreviewKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputKeyEventArgs
See Also

Reference

RichTextBoxEx Class
VisualComponents.UX.Shared Namespace


RichTextBoxEx.OnPreviewKeyUp Method

RichTextBoxExOnPreviewKeyUp Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnPreviewKeyUp(
    KeyEventArgs e
)
protected:
virtual void OnPreviewKeyUp(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputKeyEventArgs
See Also

Reference

RichTextBoxEx Class
VisualComponents.UX.Shared Namespace


RichTextBoxEx.OnPreviewMouseDoubleClick Method

RichTextBoxExOnPreviewMouseDoubleClick Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnPreviewMouseDoubleClick(
    MouseButtonEventArgs e
)
protected:
virtual void OnPreviewMouseDoubleClick(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputMouseButtonEventArgs
See Also

Reference

RichTextBoxEx Class
VisualComponents.UX.Shared Namespace


RichTextBoxEx.OnTextInput Method

RichTextBoxExOnTextInput Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnTextInput(
    TextCompositionEventArgs e
)
protected:
virtual void OnTextInput(
    TextCompositionEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputTextCompositionEventArgs
See Also

Reference

RichTextBoxEx Class
VisualComponents.UX.Shared Namespace


RichTextBoxEx Events

The RichTextBoxEx type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBoxBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextChanged | Occurs when content changes in the text element. (Inherited from TextBoxBase.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

RichTextBoxEx Class
VisualComponents.UX.Shared Namespace


RichTextBoxEx Fields

The RichTextBoxEx type exposes the following members.

Fields
Name | Description
AutoAddWhiteSpaceAfterTriggeredProperty |
ContentAssistSourceProperty |
ContentAssistTriggersProperty |
ExpressionTypeProperty |
Top
See Also

Reference

RichTextBoxEx Class
VisualComponents.UX.Shared Namespace


RichTextBoxEx.AutoAddWhiteSpaceAfterTriggeredProperty Field

RichTextBoxExAutoAddWhiteSpaceAfterTriggeredProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty AutoAddWhiteSpaceAfterTriggeredProperty
public:
static initonly DependencyProperty^ AutoAddWhiteSpaceAfterTriggeredProperty

Field Value

Type: DependencyProperty
See Also

Reference

RichTextBoxEx Class
VisualComponents.UX.Shared Namespace


RichTextBoxEx.ContentAssistSourceProperty Field

RichTextBoxExContentAssistSourceProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ContentAssistSourceProperty
public:
static initonly DependencyProperty^ ContentAssistSourceProperty

Field Value

Type: DependencyProperty
See Also

Reference

RichTextBoxEx Class
VisualComponents.UX.Shared Namespace


RichTextBoxEx.ContentAssistTriggersProperty Field

RichTextBoxExContentAssistTriggersProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ContentAssistTriggersProperty
public:
static initonly DependencyProperty^ ContentAssistTriggersProperty

Field Value

Type: DependencyProperty
See Also

Reference

RichTextBoxEx Class
VisualComponents.UX.Shared Namespace


RichTextBoxEx.ExpressionTypeProperty Field

RichTextBoxExExpressionTypeProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ExpressionTypeProperty
public:
static initonly DependencyProperty^ ExpressionTypeProperty

Field Value

Type: DependencyProperty
See Also

Reference

RichTextBoxEx Class
VisualComponents.UX.Shared Namespace


RobotFrameEditorView Class

Interaction logic for RobotFrameEditorView.xaml
RobotFrameEditorView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedRobotFrameEditorView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RobotFrameEditorView : UserControl,
    IComponentConnector
public ref class RobotFrameEditorView : public UserControl,
    IComponentConnector

The RobotFrameEditorView type exposes the following members.

Constructors
 | Name | Description
Public method | RobotFrameEditorView | Initializes a new instance of the RobotFrameEditorView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RobotFrameEditorView Constructor

Initializes a new instance of the RobotFrameEditorView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RobotFrameEditorView()
public:
RobotFrameEditorView()
See Also

Reference

RobotFrameEditorView Class
VisualComponents.UX.Shared Namespace


RobotFrameEditorView Properties

The RobotFrameEditorView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

RobotFrameEditorView Class
VisualComponents.UX.Shared Namespace


RobotFrameEditorView Methods

The RobotFrameEditorView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RobotFrameEditorView Class
VisualComponents.UX.Shared Namespace


RobotFrameEditorView.InitializeComponent Method

RobotFrameEditorViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

RobotFrameEditorView Class
VisualComponents.UX.Shared Namespace


RobotFrameEditorView Events

The RobotFrameEditorView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

RobotFrameEditorView Class
VisualComponents.UX.Shared Namespace


RobotFrameVisibilityMode Structure

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct RobotFrameVisibilityMode
public value class RobotFrameVisibilityMode

The RobotFrameVisibilityMode type exposes the following members.

Properties
 | Name | Description
Public property | Content |
Public property | Id |
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RobotFrameVisibilityMode Properties

The RobotFrameVisibilityMode type exposes the following members.

Properties
 | Name | Description
Public property | Content |
Public property | Id |
Top
See Also

Reference

RobotFrameVisibilityMode Structure
VisualComponents.UX.Shared Namespace


RobotFrameVisibilityMode.Content Property

RobotFrameVisibilityModeContent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Content { get; set; }
public:
property String^ Content {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

RobotFrameVisibilityMode Structure
VisualComponents.UX.Shared Namespace


RobotFrameVisibilityMode.Id Property

RobotFrameVisibilityModeId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SelectionMode Id { get; set; }
public:
property SelectionMode Id {
    SelectionMode get ();
    void set (SelectionMode value);
}

Property Value

Type: SelectionMode
See Also

Reference

RobotFrameVisibilityMode Structure
VisualComponents.UX.Shared Namespace


RobotFrameVisibilityMode Methods

The RobotFrameVisibilityMode type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RobotFrameVisibilityMode Structure
VisualComponents.UX.Shared Namespace


RootGridWidthToTabWidthConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedRootGridWidthToTabWidthConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RootGridWidthToTabWidthConverter : IMultiValueConverter
public ref class RootGridWidthToTabWidthConverter : IMultiValueConverter

The RootGridWidthToTabWidthConverter type exposes the following members.

Constructors
 | Name | Description
Public method | RootGridWidthToTabWidthConverter | Initializes a new instance of the RootGridWidthToTabWidthConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RootGridWidthToTabWidthConverter Constructor

Initializes a new instance of the RootGridWidthToTabWidthConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RootGridWidthToTabWidthConverter()
public:
RootGridWidthToTabWidthConverter()
See Also

Reference

RootGridWidthToTabWidthConverter Class
VisualComponents.UX.Shared Namespace


RootGridWidthToTabWidthConverter Methods

The RootGridWidthToTabWidthConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RootGridWidthToTabWidthConverter Class
VisualComponents.UX.Shared Namespace


RootGridWidthToTabWidthConverter.Convert Method

RootGridWidthToTabWidthConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    array<Object^>^ values,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

values
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.RootGridWidthToTabWidthConverter.Convert(System.Object[],System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

RootGridWidthToTabWidthConverter Class
VisualComponents.UX.Shared Namespace


RootGridWidthToTabWidthConverter.ConvertBack Method

RootGridWidthToTabWidthConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
public:
virtual array<Object^>^ ConvertBack(
    Object^ value,
    array<Type^>^ targetTypes,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetTypes
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.RootGridWidthToTabWidthConverter.ConvertBack(System.Object,System.Type[],System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

RootGridWidthToTabWidthConverter Class
VisualComponents.UX.Shared Namespace


RoutedEventTrigger Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.WindowsFreezable
System.Windows.Media.AnimationAnimatable
TriggerBase
EventTriggerBase
EventTriggerBaseDependencyObject
VisualComponents.UX.SharedRoutedEventTrigger

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RoutedEventTrigger : EventTriggerBase<DependencyObject>
public ref class RoutedEventTrigger : public EventTriggerBase<DependencyObject^>

The RoutedEventTrigger type exposes the following members.

Constructors
 | Name | Description
Public method | RoutedEventTrigger | Initializes a new instance of the RoutedEventTrigger class
Top
Properties
 | Name | Description
Public property | Actions | (Inherited from TriggerBase.)
Protected property | AssociatedObject | (Inherited from TriggerBase.)
Protected property | AssociatedObjectTypeConstraint | (Inherited from EventTriggerBase.)
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Inherited from Animatable.)
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | RoutedEvent |
Public property | Source | (Inherited from EventTriggerBaseDependencyObject.)
Public property | SourceName | (Inherited from EventTriggerBase.)
Public property | SourceObject | (Inherited from EventTriggerBase.)
Protected property | SourceTypeConstraint | (Inherited from EventTriggerBase.)
Top
Methods
 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | Attach | (Inherited from TriggerBase.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of this Animatable, making deep copies of this object's values. When copying this object's dependency properties, this method copies resource references and data bindings (but they might no longer resolve) but not animations or their current values. (Inherited from Animatable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | (Inherited from TriggerBase.)
Public method | Detach | (Inherited from TriggerBase.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to . (Inherited from Freezable.)
Protected method | FreezeCore | Makes this Animatable object unmodifiable or determines whether it can be made unmodifiable. (Inherited from Animatable.)
Public method | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Inherited from Animatable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Protected method | GetEventName | (Overrides EventTriggerBase.GetEventName.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvokeActions | (Inherited from TriggerBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttached | (Overrides EventTriggerBase.OnAttached.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnDetaching | (Inherited from EventTriggerBase.)
Protected method | OnEvent | (Inherited from EventTriggerBase.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Protected method | OnSourceChanged | (Inherited from EventTriggerBaseDependencyObject.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
Events
 | Name | Description
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Public event | PreviewInvoke | (Inherited from TriggerBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RoutedEventTrigger Constructor

Initializes a new instance of the RoutedEventTrigger class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RoutedEventTrigger()
public:
RoutedEventTrigger()
See Also

Reference

RoutedEventTrigger Class
VisualComponents.UX.Shared Namespace


RoutedEventTrigger Properties

The RoutedEventTrigger type exposes the following members.

Properties
 | Name | Description
Public property | Actions | (Inherited from TriggerBase.)
Protected property | AssociatedObject | (Inherited from TriggerBase.)
Protected property | AssociatedObjectTypeConstraint | (Inherited from EventTriggerBase.)
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Inherited from Animatable.)
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | RoutedEvent |
Public property | Source | (Inherited from EventTriggerBaseDependencyObject.)
Public property | SourceName | (Inherited from EventTriggerBase.)
Public property | SourceObject | (Inherited from EventTriggerBase.)
Protected property | SourceTypeConstraint | (Inherited from EventTriggerBase.)
Top
See Also

Reference

RoutedEventTrigger Class
VisualComponents.UX.Shared Namespace


RoutedEventTrigger.RoutedEvent Property

RoutedEventTriggerRoutedEvent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RoutedEvent RoutedEvent { get; set; }
public:
property RoutedEvent^ RoutedEvent {
    RoutedEvent^ get ();
    void set (RoutedEvent^ value);
}

Property Value

Type: RoutedEvent
See Also

Reference

RoutedEventTrigger Class
VisualComponents.UX.Shared Namespace


RoutedEventTrigger Methods

The RoutedEventTrigger type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | Attach | (Inherited from TriggerBase.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of this Animatable, making deep copies of this object's values. When copying this object's dependency properties, this method copies resource references and data bindings (but they might no longer resolve) but not animations or their current values. (Inherited from Animatable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | (Inherited from TriggerBase.)
Public method | Detach | (Inherited from TriggerBase.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to . (Inherited from Freezable.)
Protected method | FreezeCore | Makes this Animatable object unmodifiable or determines whether it can be made unmodifiable. (Inherited from Animatable.)
Public method | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Inherited from Animatable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Protected method | GetEventName | (Overrides EventTriggerBase.GetEventName.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | InvokeActions | (Inherited from TriggerBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttached | (Overrides EventTriggerBase.OnAttached.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnDetaching | (Inherited from EventTriggerBase.)
Protected method | OnEvent | (Inherited from EventTriggerBase.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Protected method | OnSourceChanged | (Inherited from EventTriggerBaseDependencyObject.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RoutedEventTrigger Class
VisualComponents.UX.Shared Namespace


RoutedEventTrigger.GetEventName Method

RoutedEventTriggerGetEventName Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override string GetEventName()
protected:
virtual String^ GetEventName() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.RoutedEventTrigger.GetEventName"]

See Also

Reference

RoutedEventTrigger Class
VisualComponents.UX.Shared Namespace


RoutedEventTrigger.OnAttached Method

RoutedEventTriggerOnAttached Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnAttached()
protected:
virtual void OnAttached() override
See Also

Reference

RoutedEventTrigger Class
VisualComponents.UX.Shared Namespace


RoutedEventTrigger Events

The RoutedEventTrigger type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Public event | PreviewInvoke | (Inherited from TriggerBase.)
Top
See Also

Reference

RoutedEventTrigger Class
VisualComponents.UX.Shared Namespace


RouteFixedLineView Class

Interaction logic for RouteFixedLineView.xaml
RouteFixedLineView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedRouteFixedLineView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RouteFixedLineView : UserControl,
    IComponentConnector
public ref class RouteFixedLineView : public UserControl,
    IComponentConnector

The RouteFixedLineView type exposes the following members.

Constructors
 | Name | Description
Public method | RouteFixedLineView | Initializes a new instance of the RouteFixedLineView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RouteFixedLineView Constructor

Initializes a new instance of the RouteFixedLineView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RouteFixedLineView()
public:
RouteFixedLineView()
See Also

Reference

RouteFixedLineView Class
VisualComponents.UX.Shared Namespace


RouteFixedLineView Properties

The RouteFixedLineView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

RouteFixedLineView Class
VisualComponents.UX.Shared Namespace


RouteFixedLineView Methods

The RouteFixedLineView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RouteFixedLineView Class
VisualComponents.UX.Shared Namespace


RouteFixedLineView.InitializeComponent Method

RouteFixedLineViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

RouteFixedLineView Class
VisualComponents.UX.Shared Namespace


RouteFixedLineView Events

The RouteFixedLineView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

RouteFixedLineView Class
VisualComponents.UX.Shared Namespace


RoutePercentageLineView Class

Interaction logic for RoutePercentageLineView.xaml
RoutePercentageLineView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedRoutePercentageLineView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RoutePercentageLineView : UserControl,
    IComponentConnector
public ref class RoutePercentageLineView : public UserControl,
    IComponentConnector

The RoutePercentageLineView type exposes the following members.

Constructors
 | Name | Description
Public method | RoutePercentageLineView | Initializes a new instance of the RoutePercentageLineView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RoutePercentageLineView Constructor

Initializes a new instance of the RoutePercentageLineView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RoutePercentageLineView()
public:
RoutePercentageLineView()
See Also

Reference

RoutePercentageLineView Class
VisualComponents.UX.Shared Namespace


RoutePercentageLineView Properties

The RoutePercentageLineView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

RoutePercentageLineView Class
VisualComponents.UX.Shared Namespace


RoutePercentageLineView Methods

The RoutePercentageLineView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RoutePercentageLineView Class
VisualComponents.UX.Shared Namespace


RoutePercentageLineView.InitializeComponent Method

RoutePercentageLineViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

RoutePercentageLineView Class
VisualComponents.UX.Shared Namespace


RoutePercentageLineView Events

The RoutePercentageLineView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

RoutePercentageLineView Class
VisualComponents.UX.Shared Namespace


RouteSimpleLineView Class

Interaction logic for RouteSimpleLineView.xaml
RouteSimpleLineView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedRouteSimpleLineView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RouteSimpleLineView : UserControl,
    IComponentConnector
public ref class RouteSimpleLineView : public UserControl,
    IComponentConnector

The RouteSimpleLineView type exposes the following members.

Constructors
 | Name | Description
Public method | RouteSimpleLineView | Initializes a new instance of the RouteSimpleLineView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RouteSimpleLineView Constructor

Initializes a new instance of the RouteSimpleLineView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RouteSimpleLineView()
public:
RouteSimpleLineView()
See Also

Reference

RouteSimpleLineView Class
VisualComponents.UX.Shared Namespace


RouteSimpleLineView Properties

The RouteSimpleLineView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

RouteSimpleLineView Class
VisualComponents.UX.Shared Namespace


RouteSimpleLineView Methods

The RouteSimpleLineView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RouteSimpleLineView Class
VisualComponents.UX.Shared Namespace


RouteSimpleLineView.InitializeComponent Method

RouteSimpleLineViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

RouteSimpleLineView Class
VisualComponents.UX.Shared Namespace


RouteSimpleLineView Events

The RouteSimpleLineView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

RouteSimpleLineView Class
VisualComponents.UX.Shared Namespace


RouteTableLineView Class

Interaction logic for RouteTableLineView.xaml
RouteTableLineView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedRouteTableLineView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RouteTableLineView : UserControl,
    IComponentConnector
public ref class RouteTableLineView : public UserControl,
    IComponentConnector

The RouteTableLineView type exposes the following members.

Constructors
 | Name | Description
Public method | RouteTableLineView | Initializes a new instance of the RouteTableLineView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RouteTableLineView Constructor

Initializes a new instance of the RouteTableLineView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RouteTableLineView()
public:
RouteTableLineView()
See Also

Reference

RouteTableLineView Class
VisualComponents.UX.Shared Namespace


RouteTableLineView Properties

The RouteTableLineView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

RouteTableLineView Class
VisualComponents.UX.Shared Namespace


RouteTableLineView Methods

The RouteTableLineView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RouteTableLineView Class
VisualComponents.UX.Shared Namespace


RouteTableLineView.InitializeComponent Method

RouteTableLineViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

RouteTableLineView Class
VisualComponents.UX.Shared Namespace


RouteTableLineView Events

The RouteTableLineView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

RouteTableLineView Class
VisualComponents.UX.Shared Namespace


RouteTransportSolutionLineView Class

Interaction logic for RouteFixedLineView.xaml
RouteTransportSolutionLineView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedRouteTransportSolutionLineView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RouteTransportSolutionLineView : UserControl,
    IComponentConnector
public ref class RouteTransportSolutionLineView : public UserControl,
    IComponentConnector

The RouteTransportSolutionLineView type exposes the following members.

Constructors
 | Name | Description
Public method | RouteTransportSolutionLineView | Initializes a new instance of the RouteTransportSolutionLineView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RouteTransportSolutionLineView Constructor

Initializes a new instance of the RouteTransportSolutionLineView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RouteTransportSolutionLineView()
public:
RouteTransportSolutionLineView()
See Also

Reference

RouteTransportSolutionLineView Class
VisualComponents.UX.Shared Namespace


RouteTransportSolutionLineView Properties

The RouteTransportSolutionLineView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

RouteTransportSolutionLineView Class
VisualComponents.UX.Shared Namespace


RouteTransportSolutionLineView Methods

The RouteTransportSolutionLineView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RouteTransportSolutionLineView Class
VisualComponents.UX.Shared Namespace


RouteTransportSolutionLineView.InitializeComponent Method

RouteTransportSolutionLineViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

RouteTransportSolutionLineView Class
VisualComponents.UX.Shared Namespace


RouteTransportSolutionLineView Events

The RouteTransportSolutionLineView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

RouteTransportSolutionLineView Class
VisualComponents.UX.Shared Namespace


RoutineVariablesEditorView Class

Interaction logic for RoutineVariablesEditorView.xaml
RoutineVariablesEditorView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedRoutineVariablesEditorView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RoutineVariablesEditorView : UserControl,
    IComponentConnector
public ref class RoutineVariablesEditorView : public UserControl,
    IComponentConnector

The RoutineVariablesEditorView type exposes the following members.

Constructors
 | Name | Description
Public method | RoutineVariablesEditorView | Initializes a new instance of the RoutineVariablesEditorView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RoutineVariablesEditorView Constructor

Initializes a new instance of the RoutineVariablesEditorView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RoutineVariablesEditorView()
public:
RoutineVariablesEditorView()
See Also

Reference

RoutineVariablesEditorView Class
VisualComponents.UX.Shared Namespace


RoutineVariablesEditorView Properties

The RoutineVariablesEditorView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

RoutineVariablesEditorView Class
VisualComponents.UX.Shared Namespace


RoutineVariablesEditorView Methods

The RoutineVariablesEditorView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RoutineVariablesEditorView Class
VisualComponents.UX.Shared Namespace


RoutineVariablesEditorView.InitializeComponent Method

RoutineVariablesEditorViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

RoutineVariablesEditorView Class
VisualComponents.UX.Shared Namespace


RoutineVariablesEditorView Events

The RoutineVariablesEditorView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

RoutineVariablesEditorView Class
VisualComponents.UX.Shared Namespace


RoutingRuleEditorView Class

Interaction logic for RoutingRuleEditorView.xaml
RoutingRuleEditorView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedRoutingRuleEditorView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RoutingRuleEditorView : UserControl,
    IComponentConnector
public ref class RoutingRuleEditorView : public UserControl,
    IComponentConnector

The RoutingRuleEditorView type exposes the following members.

Constructors
 | Name | Description
Public method | RoutingRuleEditorView | Initializes a new instance of the RoutingRuleEditorView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RoutingRuleEditorView Constructor

Initializes a new instance of the RoutingRuleEditorView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RoutingRuleEditorView()
public:
RoutingRuleEditorView()
See Also

Reference

RoutingRuleEditorView Class
VisualComponents.UX.Shared Namespace


RoutingRuleEditorView Properties

The RoutingRuleEditorView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

RoutingRuleEditorView Class
VisualComponents.UX.Shared Namespace


RoutingRuleEditorView Methods

The RoutingRuleEditorView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RoutingRuleEditorView Class
VisualComponents.UX.Shared Namespace


RoutingRuleEditorView.InitializeComponent Method

RoutingRuleEditorViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

RoutingRuleEditorView Class
VisualComponents.UX.Shared Namespace


RoutingRuleEditorView Events

The RoutingRuleEditorView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

RoutingRuleEditorView Class
VisualComponents.UX.Shared Namespace


RoutingRuleView Class

Interaction logic for RoutingRuleView.xaml
RoutingRuleView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedRoutingRuleView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class RoutingRuleView : UserControl,
    IComponentConnector
public ref class RoutingRuleView : public UserControl,
    IComponentConnector

The RoutingRuleView type exposes the following members.

Constructors
 | Name | Description
Public method | RoutingRuleView | Initializes a new instance of the RoutingRuleView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


RoutingRuleView Constructor

Initializes a new instance of the RoutingRuleView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public RoutingRuleView()
public:
RoutingRuleView()
See Also

Reference

RoutingRuleView Class
VisualComponents.UX.Shared Namespace


RoutingRuleView Properties

The RoutingRuleView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

RoutingRuleView Class
VisualComponents.UX.Shared Namespace


RoutingRuleView Methods

The RoutingRuleView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

RoutingRuleView Class
VisualComponents.UX.Shared Namespace


RoutingRuleView.InitializeComponent Method

RoutingRuleViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

RoutingRuleView Class
VisualComponents.UX.Shared Namespace


RoutingRuleView Events

The RoutingRuleView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

RoutingRuleView Class
VisualComponents.UX.Shared Namespace


Row Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedLayoutElement
VisualComponents.UX.SharedRow

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class Row : LayoutElement
public ref class Row sealed : public LayoutElement

The Row type exposes the following members.

Constructors
 | Name | Description
Public method | Row | Initializes a new instance of the Row class
Top
Properties
 | Name | Description
Public property | Children | Provides capability to add child elements to any layout element. (Inherited from LayoutElement.)
Public property | Columns | This is a runtime only property that returns column objects from children.
Public property | Content |
Public property | ElementType | (Inherited from LayoutElement.)
Public property | GroupingEnabled | If true, propertyview shows expander control header which allows toggling expander visibility.
Public property | RowMargin |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


Row Constructor

Initializes a new instance of the Row class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Row()
public:
Row()
See Also

Reference

Row Class
VisualComponents.UX.Shared Namespace


Row Properties

The Row type exposes the following members.

Properties
 | Name | Description
Public property | Children | Provides capability to add child elements to any layout element. (Inherited from LayoutElement.)
Public property | Columns | This is a runtime only property that returns column objects from children.
Public property | Content |
Public property | ElementType | (Inherited from LayoutElement.)
Public property | GroupingEnabled | If true, propertyview shows expander control header which allows toggling expander visibility.
Public property | RowMargin |
Top
See Also

Reference

Row Class
VisualComponents.UX.Shared Namespace


Row.Columns Property

RowColumns Property

This is a runtime only property that returns column objects from children.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<Column> Columns { get; }
public:
property ReadOnlyCollection<Column^>^ Columns {
    ReadOnlyCollection<Column^>^ get ();
}

Property Value

Type: ReadOnlyCollectionColumn
See Also

Reference

Row Class
VisualComponents.UX.Shared Namespace


Row.Content Property

RowContent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Content { get; set; }
public:
property String^ Content {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Row Class
VisualComponents.UX.Shared Namespace


Row.GroupingEnabled Property

RowGroupingEnabled Property

If true, propertyview shows expander control header which allows toggling expander visibility.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool GroupingEnabled { get; set; }
public:
property bool GroupingEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Row Class
VisualComponents.UX.Shared Namespace


Row.RowMargin Property

RowRowMargin Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Thickness RowMargin { get; set; }
public:
property Thickness RowMargin {
    Thickness get ();
    void set (Thickness value);
}

Property Value

Type: Thickness
See Also

Reference

Row Class
VisualComponents.UX.Shared Namespace


Row Methods

The Row type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

Row Class
VisualComponents.UX.Shared Namespace


SaveComponentAction Class

Save component action
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedSaveComponentAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SaveComponentAction : ICommandPanelAction,
    ISaveComponentAction
public ref class SaveComponentAction : ICommandPanelAction,
    ISaveComponentAction

The SaveComponentAction type exposes the following members.

Constructors
 | Name | Description
Public method | SaveComponentAction | constractor
Top
Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | DefaultDirectory | default directory
Public property | Description |
Public property | ErrorMessage |
Public property | SaveAsFilePath | Set a path here if you don't want to open the dialog when ApplyAction() is called. Otherwise, leave at default.
Public property | SaveType |
Public property | Title |
Top
Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | CancelOperation |
Protected method | EndOperation |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | Completed |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SaveComponentAction Constructor

constractor

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SaveComponentAction()
public:
SaveComponentAction()
See Also

Reference

SaveComponentAction Class
VisualComponents.UX.Shared Namespace


SaveComponentAction Properties

The SaveComponentAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
Public property | ApplyButtonText |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | DefaultDirectory | default directory
Public property | Description |
Public property | ErrorMessage |
Public property | SaveAsFilePath | Set a path here if you don't want to open the dialog when ApplyAction() is called. Otherwise, leave at default.
Public property | SaveType |
Public property | Title |
Top
See Also

Reference

SaveComponentAction Class
VisualComponents.UX.Shared Namespace


SaveComponentAction.ActionFinished Property

SaveComponentActionActionFinished Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ActionFinished { get; protected set; }
public:
virtual property bool ActionFinished {
    bool get () sealed;
    protected: void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ICommandPanelActionActionFinished
See Also

Reference

SaveComponentAction Class
VisualComponents.UX.Shared Namespace


SaveComponentAction.ActionProperties Property

SaveComponentActionActionProperties Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<IProperty> ActionProperties { get; protected set; }
public:
virtual property List<IProperty^>^ ActionProperties {
    List<IProperty^>^ get () sealed;
    protected: void set (List<IProperty^>^ value) sealed;
}

Property Value

Type: ListIProperty

Implements

ICommandPanelActionActionProperties
See Also

Reference

SaveComponentAction Class
VisualComponents.UX.Shared Namespace


SaveComponentAction.ApplyButtonText Property

SaveComponentActionApplyButtonText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ApplyButtonText { get; }
public:
virtual property String^ ApplyButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionApplyButtonText
See Also

Reference

SaveComponentAction Class
VisualComponents.UX.Shared Namespace


SaveComponentAction.AssociatedModelId Property

SaveComponentActionAssociatedModelId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedModelId { get; }
public:
virtual property String^ AssociatedModelId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedModelId
See Also

Reference

SaveComponentAction Class
VisualComponents.UX.Shared Namespace


SaveComponentAction.AssociatedSiteId Property

SaveComponentActionAssociatedSiteId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedSiteId { get; }
public:
virtual property String^ AssociatedSiteId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedSiteId
See Also

Reference

SaveComponentAction Class
VisualComponents.UX.Shared Namespace


SaveComponentAction.CallingCommandName Property

SaveComponentActionCallingCommandName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CallingCommandName { get; protected set; }
public:
virtual property String^ CallingCommandName {
    String^ get () sealed;
    protected: void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCallingCommandName
See Also

Reference

SaveComponentAction Class
VisualComponents.UX.Shared Namespace


SaveComponentAction.CancelButtonText Property

SaveComponentActionCancelButtonText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CancelButtonText { get; }
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCancelButtonText
See Also

Reference

SaveComponentAction Class
VisualComponents.UX.Shared Namespace


SaveComponentAction.DefaultDirectory Property

SaveComponentActionDefaultDirectory Property

default directory

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string DefaultDirectory { get; set; }
public:
property String^ DefaultDirectory {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SaveComponentAction Class
VisualComponents.UX.Shared Namespace


SaveComponentAction.Description Property

SaveComponentActionDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; }
public:
virtual property String^ Description {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionDescription
See Also

Reference

SaveComponentAction Class
VisualComponents.UX.Shared Namespace


SaveComponentAction.ErrorMessage Property

SaveComponentActionErrorMessage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ErrorMessage { get; protected set; }
public:
virtual property String^ ErrorMessage {
    String^ get () sealed;
    protected: void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionErrorMessage
See Also

Reference

SaveComponentAction Class
VisualComponents.UX.Shared Namespace


SaveComponentAction.SaveAsFilePath Property

SaveComponentActionSaveAsFilePath Property

Set a path here if you don't want to open the dialog when ApplyAction() is called. Otherwise, leave at default.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SaveAsFilePath { get; set; }
public:
property String^ SaveAsFilePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SaveComponentAction Class
VisualComponents.UX.Shared Namespace


SaveComponentAction.SaveType Property

SaveComponentActionSaveType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SaveComponentActionType SaveType { get; set; }
public:
virtual property SaveComponentActionType SaveType {
    SaveComponentActionType get () sealed;
    void set (SaveComponentActionType value) sealed;
}

Property Value

Type: SaveComponentActionType

Implements

ISaveComponentActionSaveType
See Also

Reference

SaveComponentAction Class
VisualComponents.UX.Shared Namespace


SaveComponentAction.Title Property

SaveComponentActionTitle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; }
public:
virtual property String^ Title {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionTitle
See Also

Reference

SaveComponentAction Class
VisualComponents.UX.Shared Namespace


SaveComponentAction Methods

The SaveComponentAction type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAction |
Public method | CancelAction |
Public method | CancelOperation |
Protected method | EndOperation |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartAction |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SaveComponentAction Class
VisualComponents.UX.Shared Namespace


SaveComponentAction.ApplyAction Method

SaveComponentActionApplyAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ApplyAction()
public:
virtual bool ApplyAction() sealed

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SaveComponentAction.ApplyAction"]

Implements

ICommandPanelActionApplyAction
See Also

Reference

SaveComponentAction Class
VisualComponents.UX.Shared Namespace


SaveComponentAction.CancelAction Method

SaveComponentActionCancelAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CancelAction()
public:
virtual void CancelAction() sealed

Implements

ICommandPanelActionCancelAction
See Also

Reference

SaveComponentAction Class
VisualComponents.UX.Shared Namespace


SaveComponentAction.CancelOperation Method

SaveComponentActionCancelOperation Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CancelOperation()
public:
virtual void CancelOperation() sealed

Implements

ISaveComponentActionCancelOperation
See Also

Reference

SaveComponentAction Class
VisualComponents.UX.Shared Namespace


SaveComponentAction.EndOperation Method

SaveComponentActionEndOperation Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected bool EndOperation(
    bool saveComponent = false
)
protected:
bool EndOperation(
    bool saveComponent = false
)

Parameters

saveComponent (Optional)
Type: SystemBoolean

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SaveComponentAction.EndOperation(System.Boolean)"]

See Also

Reference

SaveComponentAction Class
VisualComponents.UX.Shared Namespace


SaveComponentAction.StartAction Method

SaveComponentActionStartAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    EventHandler<ResultCompletionEventArgs> completed = null
)
public:
virtual void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr
) sealed

Parameters

completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs

Implements

ICommandPanelActionStartAction(EventHandlerResultCompletionEventArgs)
ISaveComponentActionStartAction(EventHandlerResultCompletionEventArgs)
See Also

Reference

SaveComponentAction Class
VisualComponents.UX.Shared Namespace


SaveComponentAction Fields

The SaveComponentAction type exposes the following members.

Fields
 | Name | Description
Protected field | Completed |
Top
See Also

Reference

SaveComponentAction Class
VisualComponents.UX.Shared Namespace


SaveComponentAction.Completed Field

SaveComponentActionCompleted Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected EventHandler<ResultCompletionEventArgs> Completed
protected:
EventHandler<ResultCompletionEventArgs^>^ Completed

Field Value

Type: EventHandlerResultCompletionEventArgs
See Also

Reference

SaveComponentAction Class
VisualComponents.UX.Shared Namespace


SaveComponentActionType Enumeration

Type of saving commponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum SaveComponentActionType
public enum class SaveComponentActionType
Members
Member name | Value | Description
Save | 0 |
SaveAs | 1 |
See Also

Reference

VisualComponents.UX.Shared Namespace


SaveLayoutAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedSaveLayoutAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SaveLayoutAction : IResult
public ref class SaveLayoutAction : IResult

The SaveLayoutAction type exposes the following members.

Constructors
 | Name | Description
Public method | SaveLayoutAction | Initializes a new instance of the SaveLayoutAction class
Top
Properties
 | Name | Description
Public property | AlwaysShowDialog | Always show dialog indicator
Public property | DefaultDirectory | default directory
Public property | FileName | File name
Public property | FilePath | a file path
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | Execute |
Public method | Execute(ActionExecutionContext) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveLayout | Save current layout
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Completed |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SaveLayoutAction Constructor

Initializes a new instance of the SaveLayoutAction class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SaveLayoutAction()
public:
SaveLayoutAction()
See Also

Reference

SaveLayoutAction Class
VisualComponents.UX.Shared Namespace


SaveLayoutAction Properties

The SaveLayoutAction type exposes the following members.

Properties
 | Name | Description
Public property | AlwaysShowDialog | Always show dialog indicator
Public property | DefaultDirectory | default directory
Public property | FileName | File name
Public property | FilePath | a file path
Top
See Also

Reference

SaveLayoutAction Class
VisualComponents.UX.Shared Namespace


SaveLayoutAction.AlwaysShowDialog Property

SaveLayoutActionAlwaysShowDialog Property

Always show dialog indicator

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool AlwaysShowDialog { get; set; }
public:
property bool AlwaysShowDialog {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SaveLayoutAction Class
VisualComponents.UX.Shared Namespace


SaveLayoutAction.DefaultDirectory Property

SaveLayoutActionDefaultDirectory Property

default directory

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string DefaultDirectory { get; set; }
public:
property String^ DefaultDirectory {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SaveLayoutAction Class
VisualComponents.UX.Shared Namespace


SaveLayoutAction.FileName Property

SaveLayoutActionFileName Property

File name

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string FileName { get; set; }
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SaveLayoutAction Class
VisualComponents.UX.Shared Namespace


SaveLayoutAction.FilePath Property

SaveLayoutActionFilePath Property

a file path

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string FilePath { get; set; }
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SaveLayoutAction Class
VisualComponents.UX.Shared Namespace


SaveLayoutAction Methods

The SaveLayoutAction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | Execute |
Public method | Execute(ActionExecutionContext) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveLayout | Save current layout
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SaveLayoutAction Class
VisualComponents.UX.Shared Namespace


SaveLayoutAction.Execute Method

SaveLayoutActionExecute Method

Overload List
 | Name | Description
 | Execute |
Public method | Execute(ActionExecutionContext) |
Top
See Also

Reference

SaveLayoutAction Class
VisualComponents.UX.Shared Namespace


SaveLayoutAction.Execute Method

SaveLayoutActionExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void Execute()
public:
static void Execute()
See Also

Reference

SaveLayoutAction Class
Execute Overload
VisualComponents.UX.Shared Namespace


SaveLayoutAction.Execute Method (ActionExecutionContext)

SaveLayoutActionExecute Method (ActionExecutionContext)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    ActionExecutionContext context
)
public:
virtual void Execute(
    ActionExecutionContext^ context
) sealed

Parameters

context
Type: ActionExecutionContext

Implements

IResult.Execute(ActionExecutionContext)
See Also

Reference

SaveLayoutAction Class
Execute Overload
VisualComponents.UX.Shared Namespace


SaveLayoutAction.SaveLayout Method

SaveLayoutActionSaveLayout Method

Save current layout

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<IResult> SaveLayout()
public:
IEnumerable<IResult^>^ SaveLayout()

Return Value

Type: IEnumerableIResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SaveLayoutAction.SaveLayout"]

See Also

Reference

SaveLayoutAction Class
VisualComponents.UX.Shared Namespace


SaveLayoutAction Events

The SaveLayoutAction type exposes the following members.

Events
 | Name | Description
Public event | Completed |
Top
See Also

Reference

SaveLayoutAction Class
VisualComponents.UX.Shared Namespace


SaveLayoutAction.Completed Event

SaveLayoutActionCompleted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ResultCompletionEventArgs> Completed
public:
virtual  event EventHandler<ResultCompletionEventArgs^>^ Completed {
    void add (EventHandler<ResultCompletionEventArgs^>^ value);
    void remove (EventHandler<ResultCompletionEventArgs^>^ value);
}

Value

Type: SystemEventHandlerResultCompletionEventArgs

Implements

IResult.Completed
See Also

Reference

SaveLayoutAction Class
VisualComponents.UX.Shared Namespace


SchedulerHelper Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedSchedulerHelper

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class SchedulerHelper
public ref class SchedulerHelper abstract sealed

The SchedulerHelper type exposes the following members.

Methods
Name | Description
IntervalInDays | Initializes a new instance of the Timer class to measure time intervals.
IntervalInHours | Initializes a new instance of the Timer class to measure time intervals.
IntervalInMinutes | Initializes a new instance of the Timer class to measure time intervals.
IntervalInSeconds | Initializes a new instance of the Timer class to measure time intervals.
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SchedulerHelper Methods

The SchedulerHelper type exposes the following members.

Methods
Name | Description
IntervalInDays | Initializes a new instance of the Timer class to measure time intervals.
IntervalInHours | Initializes a new instance of the Timer class to measure time intervals.
IntervalInMinutes | Initializes a new instance of the Timer class to measure time intervals.
IntervalInSeconds | Initializes a new instance of the Timer class to measure time intervals.
Top
See Also

Reference

SchedulerHelper Class
VisualComponents.UX.Shared Namespace


SchedulerHelper.IntervalInDays Method

SchedulerHelperIntervalInDays Method

Initializes a new instance of the Timer class to measure time intervals.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void IntervalInDays(
    int day,
    int hour,
    int min,
    double interval,
    Action task
)
public:
static void IntervalInDays(
    int day,
    int hour,
    int min,
    double interval,
    Action^ task
)

Parameters

day
Type: SystemInt32
The amount of day(s) to delay before the callback parameter invokes its methods.
hour
Type: SystemInt32
The amount of hour(s) to delay before the callback parameter invokes its methods.
min
Type: SystemInt32
The amount of minutes(s) to delay before the callback parameter invokes its methods.
interval
Type: SystemDouble
The time interval in days between invocations of the methods referenced by callback.
task
Type: SystemAction
Callback method to be invoked
See Also

Reference

SchedulerHelper Class
VisualComponents.UX.Shared Namespace


SchedulerHelper.IntervalInHours Method

SchedulerHelperIntervalInHours Method

Initializes a new instance of the Timer class to measure time intervals.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void IntervalInHours(
    int day,
    int hour,
    int min,
    double interval,
    Action task
)
public:
static void IntervalInHours(
    int day,
    int hour,
    int min,
    double interval,
    Action^ task
)

Parameters

day
Type: SystemInt32
The amount of day(s) to delay before the callback parameter invokes its methods.
hour
Type: SystemInt32
The amount of hour(s) to delay before the callback parameter invokes its methods.
min
Type: SystemInt32
The amount of minutes(s) to delay before the callback parameter invokes its methods.
interval
Type: SystemDouble
The time interval in hours between invocations of the methods referenced by callback.
task
Type: SystemAction
Callback method to be invoked
See Also

Reference

SchedulerHelper Class
VisualComponents.UX.Shared Namespace


SchedulerHelper.IntervalInMinutes Method

SchedulerHelperIntervalInMinutes Method

Initializes a new instance of the Timer class to measure time intervals.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void IntervalInMinutes(
    int day,
    int hour,
    int min,
    double interval,
    Action task
)
public:
static void IntervalInMinutes(
    int day,
    int hour,
    int min,
    double interval,
    Action^ task
)

Parameters

day
Type: SystemInt32
The amount of day(s) to delay before the callback parameter invokes its methods.
hour
Type: SystemInt32
The amount of hour(s) to delay before the callback parameter invokes its methods.
min
Type: SystemInt32
The amount of minutes(s) to delay before the callback parameter invokes its methods.
interval
Type: SystemDouble
The time interval in minutes between invocations of the methods referenced by callback.
task
Type: SystemAction
Callback method to be invoked
See Also

Reference

SchedulerHelper Class
VisualComponents.UX.Shared Namespace


SchedulerHelper.IntervalInSeconds Method

SchedulerHelperIntervalInSeconds Method

Initializes a new instance of the Timer class to measure time intervals.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void IntervalInSeconds(
    int day,
    int hour,
    int min,
    double interval,
    Action task
)
public:
static void IntervalInSeconds(
    int day,
    int hour,
    int min,
    double interval,
    Action^ task
)

Parameters

day
Type: SystemInt32
The amount of day(s) to delay before the callback parameter invokes its methods.
hour
Type: SystemInt32
The amount of hour(s) to delay before the callback parameter invokes its methods.
min
Type: SystemInt32
The amount of minutes(s) to delay before the callback parameter invokes its methods.
interval
Type: SystemDouble
The time interval in seconds between invocations of the methods referenced by callback.
task
Type: SystemAction
Callback method to be invoked
See Also

Reference

SchedulerHelper Class
VisualComponents.UX.Shared Namespace


SchedulerService Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedSchedulerService

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SchedulerService
public ref class SchedulerService

The SchedulerService type exposes the following members.

Properties
Name | Description
Instance |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ScheduleTask |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SchedulerService Properties

The SchedulerService type exposes the following members.

Properties
Name | Description
Instance |
Top
See Also

Reference

SchedulerService Class
VisualComponents.UX.Shared Namespace


SchedulerService.Instance Property

SchedulerServiceInstance Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static SchedulerService Instance { get; }
public:
static property SchedulerService^ Instance {
    SchedulerService^ get ();
}

Property Value

Type: SchedulerService
See Also

Reference

SchedulerService Class
VisualComponents.UX.Shared Namespace


SchedulerService Methods

The SchedulerService type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ScheduleTask |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SchedulerService Class
VisualComponents.UX.Shared Namespace


SchedulerService.ScheduleTask Method

SchedulerServiceScheduleTask Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ScheduleTask(
    int day,
    int hour,
    int min,
    double intervalInHour,
    Action task
)
public:
void ScheduleTask(
    int day,
    int hour,
    int min,
    double intervalInHour,
    Action^ task
)

Parameters

day
Type: SystemInt32
hour
Type: SystemInt32
min
Type: SystemInt32
intervalInHour
Type: SystemDouble
task
Type: SystemAction
See Also

Reference

SchedulerService Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement Class

Inheritance Hierarchy
SystemObject
VisualComponents.Create3DCustomStatementBase
VisualComponents.UX.SharedSchemaPathStatement

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SchemaPathStatement : CustomStatementBase,
    IPathStatement, IPositionStatement, IStatement, INamed, IPropertyContainer,
    IBatchModeObject, IWrapper, IDisposable, IApiType, ICloneable<IStatement>,
    ICloneable, IInterpolatable, IPositionFrameContainer
public ref class SchemaPathStatement : public CustomStatementBase,
    IPathStatement, IPositionStatement, IStatement, INamed, IPropertyContainer,
    IBatchModeObject, IWrapper, IDisposable, IApiType, ICloneable<IStatement^>,
    ICloneable, IInterpolatable, IPositionFrameContainer

The SchemaPathStatement type exposes the following members.

Constructors
 | Name | Description
Public method | SchemaPathStatement | Initializes a new instance of the SchemaPathStatement class
Top
Properties
 | Name | Description
Public property | ApiType | (Inherited from CustomStatementBase.)
Public property | Base |
Public property | BoundBox |
Public property | ChangeBatchLevel | (Inherited from CustomStatementBase.)
Public property | ContainerExpressionContext |
Public property | ControlExecutedExEvent | (Inherited from CustomStatementBase.)
Public property | CustomStatement | (Inherited from CustomStatementBase.)
Public property | Description |
Public property | ExecutedCycleTime | (Inherited from CustomStatementBase.)
Public property | ExternalJointCount |
Public property | ExternalTcp |
Public property | FirstFrame |
Public property | IsExecuting | (Inherited from CustomStatementBase.)
Public property | IsInitialized |
Public property | IsLoop | (Inherited from CustomStatementBase.)
Public property | IsValid | (Inherited from CustomStatementBase.)
Public property | IsVisible |
Public property | LastFrame |
Public property | Name | (Inherited from CustomStatementBase.)
Public property | ParentScope | (Inherited from CustomStatementBase.)
Public property | Pointer | (Inherited from CustomStatementBase.)
Public property | Positions |
Public property | Properties | (Inherited from CustomStatementBase.)
Public property | PropertyNames | (Inherited from CustomStatementBase.)
Public property | PropertyNamesAndValues | (Inherited from CustomStatementBase.)
Public property | PropertyValues | (Inherited from CustomStatementBase.)
Public property | ReferenceFrames |
Public property | ReferenceFramesCount |
Public property | Routine | (Inherited from CustomStatementBase.)
Public property | SchemaDatabase |
Public property | SchemaItemCount |
Public property | SchemaPositions |
Public property | SchemaProperties |
Public property | ShowLabels |
Public property | ShowLine |
Public property | ShowReferenceFrames |
Public property | Statement | (Inherited from CustomStatementBase.)
Public property | Tool |
Public property | UseNativeExecution |
Public property | WholePath |
Top
Methods
 | Name | Description
Public method | AddPositionFromProgram |
Public method | AddSchemaProperties |
Public method | ApplySmoothing |
Public method | BeginBatchUpdate |
Public method | BeginChangeBatch | (Inherited from CustomStatementBase.)
Public method | ClearCurve |
Public method | ClearPositions |
Public method | ClearReferences |
Public method | Clone |
Public method | Clone(Boolean) | (Inherited from CustomStatementBase.)
Public method | ClonePositions |
Public method | CreatePosition |
Public method | CreateProperty(Type, PropertyConstraintType) | (Inherited from CustomStatementBase.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | (Inherited from CustomStatementBase.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from CustomStatementBase.)
Public method | DeletePosition |
Public method | DeletePositions |
Public method | DeleteProperty | (Inherited from CustomStatementBase.)
Public method | Dispose | (Inherited from CustomStatementBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the SchemaPathStatement and optionally releases the managed resources (Overrides CustomStatementBaseDispose(Boolean).)
Public method | EndBatchUpdate |
Public method | EndChangeBatch | (Inherited from CustomStatementBase.)
Public method | EndInterpolation |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | (Overrides CustomStatementBaseExecute(IExecutor).)
Public method | ExecuteImmediate | (Inherited from CustomStatementBase.)
Public method | ExecuteImmediate(IExecutor) | (Overrides CustomStatementBaseExecuteImmediate(IExecutor).)
Public method | ExecuteImmediatePosition |
Public method | ExtendSelection |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FinalizeSaveLoad |
Public method | GetFrame |
Public method | GetFrames |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetNextFrame |
Public method | GetProperty | (Inherited from CustomStatementBase.)
Public method | GetSchemaValue(Int32, Int32) |
Public method | GetSchemaValue(Int32, String) |
Public method | GetSchemaValue(IEnumerableIPositionFrame, Int32) |
Public method | GetSchemaValue(IEnumerableIPositionFrame, String) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightAll |
Public method | Initialize(Boolean) | Called when the statement is ready to be constructed. This is called before the statement is added to the IRoutine. (Inherited from CustomStatementBase.)
Public method | Initialize(CustomStatementBase) | (Overrides CustomStatementBaseInitialize(CustomStatementBase).)
Public method | Interpolate |
Public method | LoadDatabase |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyDatabaseChange |
Public method | OnAdd | (Inherited from CustomStatementBase.)
Public method | OnRemove | (Inherited from CustomStatementBase.)
Public method | OnReset | (Inherited from CustomStatementBase.)
Public method | ReadIn(IPositionFrame) |
Public method | ReadIn(ISchemaPositionFrame) |
Public method | RemoveSchemaProperties(IEnumerableString) |
Public method | RemoveSchemaProperties(IEnumerableIProperty) |
Public method | ReversePath |
Public method | RotationHandles |
Public method | SaveDatabase |
Public method | SelectCurve |
Public method | SelectCurveCompleted |
Public method | SetExternalTcp |
Public method | SetPropertyValues(IEnumerableObject) | (Inherited from CustomStatementBase.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | (Inherited from CustomStatementBase.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | (Inherited from CustomStatementBase.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | (Inherited from CustomStatementBase.)
Public method | SetSchemaValue(Int32, Int32, Object) |
Public method | SetSchemaValue(Int32, String, Object) |
Public method | SetSchemaValues(Int32, IEnumerableInt32, IEnumerableObject) |
Public method | SetSchemaValues(IEnumerableIPositionFrame, IEnumerableInt32, IEnumerableObject) |
Public method | SetSchemaValues(IEnumerableIPositionFrame, String, Object) |
Public method | SetStatement | (Overrides CustomStatementBaseSetStatement(IStatement).)
Public method | ShowLabelsDyn |
Public method | StartInterpolation |
Protected method | StatementInvalidated | (Overrides CustomStatementBaseStatementInvalidated.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | DatabaseChanged |
Public event | Executed | (Inherited from CustomStatementBase.)
Public event | ExecutedEx | (Inherited from CustomStatementBase.)
Public event | Executing | (Inherited from CustomStatementBase.)
Public event | ExecutingEx | (Inherited from CustomStatementBase.)
Public event | Initialized |
Public event | ObjectInvalidated | (Inherited from CustomStatementBase.)
Public event | PositionAdded |
Public event | PositionRemoving |
Public event | PositionTransformationChanged |
Public event | PropertyContainerChanged | (Inherited from CustomStatementBase.)
Public event | Reset | (Inherited from CustomStatementBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SchemaPathStatement Constructor

Initializes a new instance of the SchemaPathStatement class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SchemaPathStatement()
public:
SchemaPathStatement()
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement Properties

The SchemaPathStatement type exposes the following members.

Properties
 | Name | Description
Public property | ApiType | (Inherited from CustomStatementBase.)
Public property | Base |
Public property | BoundBox |
Public property | ChangeBatchLevel | (Inherited from CustomStatementBase.)
Public property | ContainerExpressionContext |
Public property | ControlExecutedExEvent | (Inherited from CustomStatementBase.)
Public property | CustomStatement | (Inherited from CustomStatementBase.)
Public property | Description |
Public property | ExecutedCycleTime | (Inherited from CustomStatementBase.)
Public property | ExternalJointCount |
Public property | ExternalTcp |
Public property | FirstFrame |
Public property | IsExecuting | (Inherited from CustomStatementBase.)
Public property | IsInitialized |
Public property | IsLoop | (Inherited from CustomStatementBase.)
Public property | IsValid | (Inherited from CustomStatementBase.)
Public property | IsVisible |
Public property | LastFrame |
Public property | Name | (Inherited from CustomStatementBase.)
Public property | ParentScope | (Inherited from CustomStatementBase.)
Public property | Pointer | (Inherited from CustomStatementBase.)
Public property | Positions |
Public property | Properties | (Inherited from CustomStatementBase.)
Public property | PropertyNames | (Inherited from CustomStatementBase.)
Public property | PropertyNamesAndValues | (Inherited from CustomStatementBase.)
Public property | PropertyValues | (Inherited from CustomStatementBase.)
Public property | ReferenceFrames |
Public property | ReferenceFramesCount |
Public property | Routine | (Inherited from CustomStatementBase.)
Public property | SchemaDatabase |
Public property | SchemaItemCount |
Public property | SchemaPositions |
Public property | SchemaProperties |
Public property | ShowLabels |
Public property | ShowLine |
Public property | ShowReferenceFrames |
Public property | Statement | (Inherited from CustomStatementBase.)
Public property | Tool |
Public property | UseNativeExecution |
Public property | WholePath |
Top
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.Base Property

SchemaPathStatementBase Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IRobotFrame Base { get; set; }
public:
virtual property IRobotFrame^ Base {
    IRobotFrame^ get () sealed;
    void set (IRobotFrame^ value) sealed;
}

Property Value

Type: IRobotFrame

Implements

IPositionStatementBase
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.BoundBox Property

SchemaPathStatementBoundBox Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IBoundBox BoundBox { get; }
public:
virtual property IBoundBox^ BoundBox {
    IBoundBox^ get () sealed;
}

Property Value

Type: IBoundBox

Implements

IPathStatementBoundBox
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.ContainerExpressionContext Property

SchemaPathStatementContainerExpressionContext Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IExpressionContext ContainerExpressionContext { get; }
public:
virtual property IExpressionContext^ ContainerExpressionContext {
    IExpressionContext^ get () sealed;
}

Property Value

Type: IExpressionContext

Implements

IPropertyContainerContainerExpressionContext
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.Description Property

SchemaPathStatementDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; set; }
public:
virtual property String^ Description {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPathStatementDescription
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.ExternalJointCount Property

SchemaPathStatementExternalJointCount Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ExternalJointCount { get; }
public:
virtual property int ExternalJointCount {
    int get () sealed;
}

Property Value

Type: Int32

Implements

IPathStatementExternalJointCount
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.ExternalTcp Property

SchemaPathStatementExternalTcp Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ExternalTcp { get; set; }
public:
virtual property bool ExternalTcp {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPositionStatementExternalTcp
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.FirstFrame Property

SchemaPathStatementFirstFrame Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IPositionFrame FirstFrame { get; }
public:
virtual property IPositionFrame^ FirstFrame {
    IPositionFrame^ get () sealed;
}

Property Value

Type: IPositionFrame

Implements

IPathStatementFirstFrame
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.IsInitialized Property

SchemaPathStatementIsInitialized Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsInitialized { get; set; }
public:
property bool IsInitialized {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.IsVisible Property

SchemaPathStatementIsVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsVisible { get; set; }
public:
virtual property bool IsVisible {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPathStatementIsVisible
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.LastFrame Property

SchemaPathStatementLastFrame Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IPositionFrame LastFrame { get; }
public:
virtual property IPositionFrame^ LastFrame {
    IPositionFrame^ get () sealed;
}

Property Value

Type: IPositionFrame

Implements

IPathStatementLastFrame
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.Positions Property

SchemaPathStatementPositions Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<IPositionFrame> Positions { get; }
public:
virtual property ReadOnlyCollection<IPositionFrame^>^ Positions {
    ReadOnlyCollection<IPositionFrame^>^ get () sealed;
}

Property Value

Type: ReadOnlyCollectionIPositionFrame

Implements

IPositionFrameContainerPositions
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.ReferenceFrames Property

SchemaPathStatementReferenceFrames Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<IPositionFrame> ReferenceFrames { get; }
public:
virtual property ReadOnlyCollection<IPositionFrame^>^ ReferenceFrames {
    ReadOnlyCollection<IPositionFrame^>^ get () sealed;
}

Property Value

Type: ReadOnlyCollectionIPositionFrame

Implements

IPathStatementReferenceFrames
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.ReferenceFramesCount Property

SchemaPathStatementReferenceFramesCount Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ReferenceFramesCount { get; }
public:
virtual property int ReferenceFramesCount {
    int get () sealed;
}

Property Value

Type: Int32

Implements

IPathStatementReferenceFramesCount
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.SchemaDatabase Property

SchemaPathStatementSchemaDatabase Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IntPtr SchemaDatabase { get; }
public:
virtual property IntPtr SchemaDatabase {
    IntPtr get () sealed;
}

Property Value

Type: IntPtr

Implements

IPathStatementSchemaDatabase
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.SchemaItemCount Property

SchemaPathStatementSchemaItemCount Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int SchemaItemCount { get; }
public:
virtual property int SchemaItemCount {
    int get () sealed;
}

Property Value

Type: Int32

Implements

IPathStatementSchemaItemCount
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.SchemaPositions Property

SchemaPathStatementSchemaPositions Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<IPositionFrame> SchemaPositions { get; }
public:
virtual property IEnumerable<IPositionFrame^>^ SchemaPositions {
    IEnumerable<IPositionFrame^>^ get () sealed;
}

Property Value

Type: IEnumerableIPositionFrame

Implements

IPathStatementSchemaPositions
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.SchemaProperties Property

SchemaPathStatementSchemaProperties Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IPropertyContainer SchemaProperties { get; }
public:
virtual property IPropertyContainer^ SchemaProperties {
    IPropertyContainer^ get () sealed;
}

Property Value

Type: IPropertyContainer

Implements

IPathStatementSchemaProperties
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.ShowLabels Property

SchemaPathStatementShowLabels Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowLabels { get; set; }
public:
virtual property bool ShowLabels {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPathStatementShowLabels
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.ShowLine Property

SchemaPathStatementShowLine Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowLine { get; set; }
public:
virtual property bool ShowLine {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPathStatementShowLine
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.ShowReferenceFrames Property

SchemaPathStatementShowReferenceFrames Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowReferenceFrames { get; set; }
public:
virtual property bool ShowReferenceFrames {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPathStatementShowReferenceFrames
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.Tool Property

SchemaPathStatementTool Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IRobotFrame Tool { get; set; }
public:
virtual property IRobotFrame^ Tool {
    IRobotFrame^ get () sealed;
    void set (IRobotFrame^ value) sealed;
}

Property Value

Type: IRobotFrame

Implements

IPositionStatementTool
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.UseNativeExecution Property

SchemaPathStatementUseNativeExecution Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool UseNativeExecution { get; set; }
public:
virtual property bool UseNativeExecution {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPathStatementUseNativeExecution
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.WholePath Property

SchemaPathStatementWholePath Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IPositionFrame WholePath { get; }
public:
virtual property IPositionFrame^ WholePath {
    IPositionFrame^ get () sealed;
}

Property Value

Type: IPositionFrame
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement Methods

The SchemaPathStatement type exposes the following members.

Methods
 | Name | Description
Public method | AddPositionFromProgram |
Public method | AddSchemaProperties |
Public method | ApplySmoothing |
Public method | BeginBatchUpdate |
Public method | BeginChangeBatch | (Inherited from CustomStatementBase.)
Public method | ClearCurve |
Public method | ClearPositions |
Public method | ClearReferences |
Public method | Clone |
Public method | Clone(Boolean) | (Inherited from CustomStatementBase.)
Public method | ClonePositions |
Public method | CreatePosition |
Public method | CreateProperty(Type, PropertyConstraintType) | (Inherited from CustomStatementBase.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | (Inherited from CustomStatementBase.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from CustomStatementBase.)
Public method | DeletePosition |
Public method | DeletePositions |
Public method | DeleteProperty | (Inherited from CustomStatementBase.)
Public method | Dispose | (Inherited from CustomStatementBase.)
Protected method | Dispose(Boolean) | (Overrides CustomStatementBaseDispose(Boolean).)
Public method | EndBatchUpdate |
Public method | EndChangeBatch | (Inherited from CustomStatementBase.)
Public method | EndInterpolation |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | (Overrides CustomStatementBaseExecute(IExecutor).)
Public method | ExecuteImmediate | (Inherited from CustomStatementBase.)
Public method | ExecuteImmediate(IExecutor) | (Overrides CustomStatementBaseExecuteImmediate(IExecutor).)
Public method | ExecuteImmediatePosition |
Public method | ExtendSelection |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FinalizeSaveLoad |
Public method | GetFrame |
Public method | GetFrames |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetNextFrame |
Public method | GetProperty | (Inherited from CustomStatementBase.)
Public method | GetSchemaValue(Int32, Int32) |
Public method | GetSchemaValue(Int32, String) |
Public method | GetSchemaValue(IEnumerableIPositionFrame, Int32) |
Public method | GetSchemaValue(IEnumerableIPositionFrame, String) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightAll |
Public method | Initialize(Boolean) | Called when the statement is ready to be constructed. This is called before the statement is added to the IRoutine. (Inherited from CustomStatementBase.)
Public method | Initialize(CustomStatementBase) | (Overrides CustomStatementBaseInitialize(CustomStatementBase).)
Public method | Interpolate |
Public method | LoadDatabase |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyDatabaseChange |
Public method | OnAdd | (Inherited from CustomStatementBase.)
Public method | OnRemove | (Inherited from CustomStatementBase.)
Public method | OnReset | (Inherited from CustomStatementBase.)
Public method | ReadIn(IPositionFrame) |
Public method | ReadIn(ISchemaPositionFrame) |
Public method | RemoveSchemaProperties(IEnumerableString) |
Public method | RemoveSchemaProperties(IEnumerableIProperty) |
Public method | ReversePath |
Public method | RotationHandles |
Public method | SaveDatabase |
Public method | SelectCurve |
Public method | SelectCurveCompleted |
Public method | SetExternalTcp |
Public method | SetPropertyValues(IEnumerableObject) | (Inherited from CustomStatementBase.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | (Inherited from CustomStatementBase.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | (Inherited from CustomStatementBase.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | (Inherited from CustomStatementBase.)
Public method | SetSchemaValue(Int32, Int32, Object) |
Public method | SetSchemaValue(Int32, String, Object) |
Public method | SetSchemaValues(Int32, IEnumerableInt32, IEnumerableObject) |
Public method | SetSchemaValues(IEnumerableIPositionFrame, IEnumerableInt32, IEnumerableObject) |
Public method | SetSchemaValues(IEnumerableIPositionFrame, String, Object) |
Public method | SetStatement | (Overrides CustomStatementBaseSetStatement(IStatement).)
Public method | ShowLabelsDyn |
Public method | StartInterpolation |
Protected method | StatementInvalidated | (Overrides CustomStatementBaseStatementInvalidated.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | IsValid | Convenience function to check if wrapper is not null and IsValid is true; (Defined by Extensions.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.AddPositionFromProgram Method

SchemaPathStatementAddPositionFromProgram Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void AddPositionFromProgram(
    IPositionFrame position
)
public:
virtual void AddPositionFromProgram(
    IPositionFrame^ position
) sealed

Parameters

position
Type: VisualComponents.Create3DIPositionFrame

Implements

IPositionStatementAddPositionFromProgram(IPositionFrame)
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.AddSchemaProperties Method

SchemaPathStatementAddSchemaProperties Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int[] AddSchemaProperties(
    IEnumerable<Tuple<string, Type, Object>> infos
)
public:
virtual array<int>^ AddSchemaProperties(
    IEnumerable<Tuple<String^, Type^, Object^>^>^ infos
) sealed

Parameters

infos
Type: System.Collections.GenericIEnumerableTupleString, Type, Object

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SchemaPathStatement.AddSchemaProperties(System.Collections.Generic.IEnumerable{System.Tuple{System.String,System.Type,System.Object}})"]

Implements

IPathStatementAddSchemaProperties(IEnumerableTupleString, Type, Object)
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.ApplySmoothing Method

SchemaPathStatementApplySmoothing Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ApplySmoothing()
public:
void ApplySmoothing()
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.BeginBatchUpdate Method

SchemaPathStatementBeginBatchUpdate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void BeginBatchUpdate(
    int size
)
public:
virtual void BeginBatchUpdate(
    int size
) sealed

Parameters

size
Type: SystemInt32

Implements

IPathStatementBeginBatchUpdate(Int32)
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.ClearCurve Method

SchemaPathStatementClearCurve Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ClearCurve()
public:
void ClearCurve()
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.ClearPositions Method

SchemaPathStatementClearPositions Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ClearPositions()
public:
virtual void ClearPositions() sealed

Implements

IPathStatementClearPositions
IPositionFrameContainerClearPositions
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.ClearReferences Method

SchemaPathStatementClearReferences Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ClearReferences()
public:
void ClearReferences()
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.Clone Method

SchemaPathStatementClone Method

Overload List
 | Name | Description
Public method | Clone |
Public method | Clone(Boolean) | (Inherited from CustomStatementBase.)
Top
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.Clone Method

SchemaPathStatementClone Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Clone()
public:
virtual Object^ Clone() sealed

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SchemaPathStatement.Clone"]

Implements

ICloneableClone
See Also

Reference

SchemaPathStatement Class
Clone Overload
VisualComponents.UX.Shared Namespace


SchemaPathStatement.ClonePositions Method

SchemaPathStatementClonePositions Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ClonePositions(
    int from,
    int count,
    int to
)
public:
virtual void ClonePositions(
    int from,
    int count,
    int to
) sealed

Parameters

from
Type: SystemInt32
count
Type: SystemInt32
to
Type: SystemInt32

Implements

IPathStatementClonePositions(Int32, Int32, Int32)
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.CreatePosition Method

SchemaPathStatementCreatePosition Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IPositionFrame CreatePosition(
    string name
)
public:
virtual IPositionFrame^ CreatePosition(
    String^ name
) sealed

Parameters

name
Type: SystemString

Return Value

Type: IPositionFrame

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SchemaPathStatement.CreatePosition(System.String)"]

Implements

IPositionFrameContainerCreatePosition(String)
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.DeletePosition Method

SchemaPathStatementDeletePosition Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void DeletePosition(
    IPositionFrame position
)
public:
virtual void DeletePosition(
    IPositionFrame^ position
) sealed

Parameters

position
Type: VisualComponents.Create3DIPositionFrame

Implements

IPositionFrameContainerDeletePosition(IPositionFrame)
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.DeletePositions Method

SchemaPathStatementDeletePositions Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void DeletePositions(
    int from,
    int count
)
public:
virtual void DeletePositions(
    int from,
    int count
) sealed

Parameters

from
Type: SystemInt32
count
Type: SystemInt32

Implements

IPathStatementDeletePositions(Int32, Int32)
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.Dispose Method

SchemaPathStatementDispose Method

Overload List
 | Name | Description
Public method | Dispose | (Inherited from CustomStatementBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the SchemaPathStatement and optionally releases the managed resources (Overrides CustomStatementBaseDispose(Boolean).)
Top
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.Dispose Method (Boolean)

SchemaPathStatementDispose Method (Boolean)

Releases the unmanaged resources used by the SchemaPathStatement and optionally releases the managed resources

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void Dispose(
    bool disposing
)
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

SchemaPathStatement Class
Dispose Overload
VisualComponents.UX.Shared Namespace


SchemaPathStatement.EndBatchUpdate Method

SchemaPathStatementEndBatchUpdate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void EndBatchUpdate(
    int size
)
public:
virtual void EndBatchUpdate(
    int size
) sealed

Parameters

size
Type: SystemInt32

Implements

IPathStatementEndBatchUpdate(Int32)
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.EndInterpolation Method

SchemaPathStatementEndInterpolation Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void EndInterpolation()
public:
virtual void EndInterpolation()

Implements

IInterpolatableEndInterpolation
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.Execute Method

SchemaPathStatementExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Execute(
    IExecutor executor
)
public:
virtual void Execute(
    IExecutor^ executor
) override

Parameters

executor
Type: VisualComponents.Create3DIExecutor
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.ExecuteImmediate Method

SchemaPathStatementExecuteImmediate Method

Overload List
 | Name | Description
Public method | ExecuteImmediate | (Inherited from CustomStatementBase.)
Public method | ExecuteImmediate(IExecutor) | (Overrides CustomStatementBaseExecuteImmediate(IExecutor).)
Top
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.ExecuteImmediate Method (IExecutor)

SchemaPathStatementExecuteImmediate Method (IExecutor)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void ExecuteImmediate(
    IExecutor executor
)
public:
virtual void ExecuteImmediate(
    IExecutor^ executor
) override

Parameters

executor
Type: VisualComponents.Create3DIExecutor
See Also

Reference

SchemaPathStatement Class
ExecuteImmediate Overload
VisualComponents.UX.Shared Namespace


SchemaPathStatement.ExecuteImmediatePosition Method

SchemaPathStatementExecuteImmediatePosition Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void ExecuteImmediatePosition(
    IPositionFrame frame
)
public:
virtual void ExecuteImmediatePosition(
    IPositionFrame^ frame
)

Parameters

frame
Type: VisualComponents.Create3DIPositionFrame

Implements

IPositionStatementExecuteImmediatePosition(IPositionFrame)
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.ExtendSelection Method

SchemaPathStatementExtendSelection Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<IPositionFrame> ExtendSelection(
    IPositionFrame pickedFrame,
    IPositionFrame[] previousSelection,
    bool appendOrRemove,
    bool appendOrRemoveRange
)
public:
virtual ReadOnlyCollection<IPositionFrame^>^ ExtendSelection(
    IPositionFrame^ pickedFrame,
    array<IPositionFrame^>^ previousSelection,
    bool appendOrRemove,
    bool appendOrRemoveRange
) sealed

Parameters

pickedFrame
Type: VisualComponents.Create3DIPositionFrame
previousSelection
Type: VisualComponents.Create3DIPositionFrame
appendOrRemove
Type: SystemBoolean
appendOrRemoveRange
Type: SystemBoolean

Return Value

Type: ReadOnlyCollectionIPositionFrame

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SchemaPathStatement.ExtendSelection(VisualComponents.Create3D.IPositionFrame,VisualComponents.Create3D.IPositionFrame[],System.Boolean,System.Boolean)"]

Implements

IPathStatementExtendSelection(IPositionFrame, IPositionFrame, Boolean, Boolean)
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.FinalizeSaveLoad Method

SchemaPathStatementFinalizeSaveLoad Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void FinalizeSaveLoad(
    int state,
    bool toFromLayout
)
public:
virtual void FinalizeSaveLoad(
    int state,
    bool toFromLayout
) sealed

Parameters

state
Type: SystemInt32
toFromLayout
Type: SystemBoolean
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.GetFrame Method

SchemaPathStatementGetFrame Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void GetFrame(
    int index,
    ref IPositionFrame frame
)
public:
virtual void GetFrame(
    int index,
    IPositionFrame^% frame
) sealed

Parameters

index
Type: SystemInt32
frame
Type: VisualComponents.Create3DIPositionFrame

Implements

IPathStatementGetFrame(Int32, IPositionFrame)
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.GetFrames Method

SchemaPathStatementGetFrames Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IPositionFrame GetFrames(
    int[] indices
)
public:
virtual IPositionFrame^ GetFrames(
    array<int>^ indices
) sealed

Parameters

indices
Type: SystemInt32

Return Value

Type: IPositionFrame

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SchemaPathStatement.GetFrames(System.Int32[])"]

Implements

IPathStatementGetFrames(Int32)
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.GetNextFrame Method

SchemaPathStatementGetNextFrame Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool GetNextFrame(
    IPositionFrame frameSet,
    bool onlyReferences,
    ref IPositionFrame frame
)
public:
virtual bool GetNextFrame(
    IPositionFrame^ frameSet,
    bool onlyReferences,
    IPositionFrame^% frame
) sealed

Parameters

frameSet
Type: VisualComponents.Create3DIPositionFrame
onlyReferences
Type: SystemBoolean
frame
Type: VisualComponents.Create3DIPositionFrame

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SchemaPathStatement.GetNextFrame(VisualComponents.Create3D.IPositionFrame,System.Boolean,VisualComponents.Create3D.IPositionFrame@)"]

Implements

IPathStatementGetNextFrame(IPositionFrame, Boolean, IPositionFrame)
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.GetSchemaValue Method

SchemaPathStatementGetSchemaValue Method

Overload List
 | Name | Description
Public method | GetSchemaValue(Int32, Int32) |
Public method | GetSchemaValue(Int32, String) |
Public method | GetSchemaValue(IEnumerableIPositionFrame, Int32) |
Public method | GetSchemaValue(IEnumerableIPositionFrame, String) |
Top
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.GetSchemaValue Method (Int32, Int32)

SchemaPathStatementGetSchemaValue Method (Int32, Int32)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object GetSchemaValue(
    int positionIndex,
    int fieldIndex
)
public:
virtual Object^ GetSchemaValue(
    int positionIndex,
    int fieldIndex
) sealed

Parameters

positionIndex
Type: SystemInt32
fieldIndex
Type: SystemInt32

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SchemaPathStatement.GetSchemaValue(System.Int32,System.Int32)"]

Implements

IPathStatementGetSchemaValue(Int32, Int32)
See Also

Reference

SchemaPathStatement Class
GetSchemaValue Overload
VisualComponents.UX.Shared Namespace


SchemaPathStatement.GetSchemaValue Method (Int32, String)

SchemaPathStatementGetSchemaValue Method (Int32, String)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object GetSchemaValue(
    int positionIndex,
    string fieldName
)
public:
virtual Object^ GetSchemaValue(
    int positionIndex,
    String^ fieldName
) sealed

Parameters

positionIndex
Type: SystemInt32
fieldName
Type: SystemString

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SchemaPathStatement.GetSchemaValue(System.Int32,System.String)"]

Implements

IPathStatementGetSchemaValue(Int32, String)
See Also

Reference

SchemaPathStatement Class
GetSchemaValue Overload
VisualComponents.UX.Shared Namespace


SchemaPathStatement.GetSchemaValue Method (IEnumerable(IPositionFrame), Int32)

SchemaPathStatementGetSchemaValue Method (IEnumerableIPositionFrame, Int32)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object GetSchemaValue(
    IEnumerable<IPositionFrame> frames,
    int fieldIndex
)
public:
virtual Object^ GetSchemaValue(
    IEnumerable<IPositionFrame^>^ frames,
    int fieldIndex
) sealed

Parameters

frames
Type: System.Collections.GenericIEnumerableIPositionFrame
fieldIndex
Type: SystemInt32

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SchemaPathStatement.GetSchemaValue(System.Collections.Generic.IEnumerable{VisualComponents.Create3D.IPositionFrame},System.Int32)"]

Implements

IPathStatementGetSchemaValue(IEnumerableIPositionFrame, Int32)
See Also

Reference

SchemaPathStatement Class
GetSchemaValue Overload
VisualComponents.UX.Shared Namespace


SchemaPathStatement.GetSchemaValue Method (IEnumerable(IPositionFrame), String)

SchemaPathStatementGetSchemaValue Method (IEnumerableIPositionFrame, String)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object GetSchemaValue(
    IEnumerable<IPositionFrame> frames,
    string fieldName
)
public:
virtual Object^ GetSchemaValue(
    IEnumerable<IPositionFrame^>^ frames,
    String^ fieldName
) sealed

Parameters

frames
Type: System.Collections.GenericIEnumerableIPositionFrame
fieldName
Type: SystemString

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SchemaPathStatement.GetSchemaValue(System.Collections.Generic.IEnumerable{VisualComponents.Create3D.IPositionFrame},System.String)"]

Implements

IPathStatementGetSchemaValue(IEnumerableIPositionFrame, String)
See Also

Reference

SchemaPathStatement Class
GetSchemaValue Overload
VisualComponents.UX.Shared Namespace


SchemaPathStatement.HighlightAll Method

SchemaPathStatementHighlightAll Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void HighlightAll(
    bool value
)
public:
virtual void HighlightAll(
    bool value
) sealed

Parameters

value
Type: SystemBoolean

Implements

IPositionStatementHighlightAll(Boolean)
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.Initialize Method

SchemaPathStatementInitialize Method

Overload List
 | Name | Description
Public method | Initialize(Boolean) | Called when the statement is ready to be constructed. This is called before the statement is added to the IRoutine. (Inherited from CustomStatementBase.)
Public method | Initialize(CustomStatementBase) | (Overrides CustomStatementBaseInitialize(CustomStatementBase).)
Top
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.Initialize Method (CustomStatementBase)

SchemaPathStatementInitialize Method (CustomStatementBase)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void Initialize(
    CustomStatementBase original
)
public:
virtual void Initialize(
    CustomStatementBase^ original
) override

Parameters

original
Type: VisualComponents.Create3DCustomStatementBase
See Also

Reference

SchemaPathStatement Class
Initialize Overload
VisualComponents.UX.Shared Namespace


SchemaPathStatement.Interpolate Method

SchemaPathStatementInterpolate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual void Interpolate(
    double length,
    ref IMotionTarget target
)
public:
virtual void Interpolate(
    double length,
    IMotionTarget^% target
)

Parameters

length
Type: SystemDouble
target
Type: VisualComponents.Create3DIMotionTarget

Implements

IInterpolatableInterpolate(Double, IMotionTarget)
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.LoadDatabase Method

SchemaPathStatementLoadDatabase Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool LoadDatabase(
    bool useLayout
)
public:
virtual bool LoadDatabase(
    bool useLayout
) sealed

Parameters

useLayout
Type: SystemBoolean

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SchemaPathStatement.LoadDatabase(System.Boolean)"]

See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.NotifyDatabaseChange Method

SchemaPathStatementNotifyDatabaseChange Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void NotifyDatabaseChange(
    int dirtyIndex
)
public:
virtual void NotifyDatabaseChange(
    int dirtyIndex
) sealed

Parameters

dirtyIndex
Type: SystemInt32

Implements

IPathStatementNotifyDatabaseChange(Int32)
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.ReadIn Method

SchemaPathStatementReadIn Method

Overload List
 | Name | Description
Public method | ReadIn(IPositionFrame) |
Public method | ReadIn(ISchemaPositionFrame) |
Top
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.ReadIn Method (IPositionFrame)

SchemaPathStatementReadIn Method (IPositionFrame)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ReadIn(
    IPositionFrame frame
)
public:
virtual void ReadIn(
    IPositionFrame^ frame
) sealed

Parameters

frame
Type: VisualComponents.Create3DIPositionFrame

Implements

IPositionStatementReadIn(IPositionFrame)
See Also

Reference

SchemaPathStatement Class
ReadIn Overload
VisualComponents.UX.Shared Namespace


SchemaPathStatement.ReadIn Method (ISchemaPositionFrame)

SchemaPathStatementReadIn Method (ISchemaPositionFrame)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ReadIn(
    ISchemaPositionFrame targetFrame
)
public:
virtual void ReadIn(
    ISchemaPositionFrame^ targetFrame
) sealed

Parameters

targetFrame
Type: VisualComponents.Create3DISchemaPositionFrame

Implements

IPathStatementReadIn(ISchemaPositionFrame)
See Also

Reference

SchemaPathStatement Class
ReadIn Overload
VisualComponents.UX.Shared Namespace


SchemaPathStatement.RemoveSchemaProperties Method

SchemaPathStatementRemoveSchemaProperties Method

Overload List
 | Name | Description
Public method | RemoveSchemaProperties(IEnumerableString) |
Public method | RemoveSchemaProperties(IEnumerableIProperty) |
Top
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.RemoveSchemaProperties Method (IEnumerable(String))

SchemaPathStatementRemoveSchemaProperties Method (IEnumerableString)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RemoveSchemaProperties(
    IEnumerable<string> names
)
public:
virtual void RemoveSchemaProperties(
    IEnumerable<String^>^ names
) sealed

Parameters

names
Type: System.Collections.GenericIEnumerableString

Implements

IPathStatementRemoveSchemaProperties(IEnumerableString)
See Also

Reference

SchemaPathStatement Class
RemoveSchemaProperties Overload
VisualComponents.UX.Shared Namespace


SchemaPathStatement.RemoveSchemaProperties Method (IEnumerable(IProperty))

SchemaPathStatementRemoveSchemaProperties Method (IEnumerableIProperty)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RemoveSchemaProperties(
    IEnumerable<IProperty> properties
)
public:
virtual void RemoveSchemaProperties(
    IEnumerable<IProperty^>^ properties
) sealed

Parameters

properties
Type: System.Collections.GenericIEnumerableIProperty

Implements

IPathStatementRemoveSchemaProperties(IEnumerableIProperty)
See Also

Reference

SchemaPathStatement Class
RemoveSchemaProperties Overload
VisualComponents.UX.Shared Namespace


SchemaPathStatement.ReversePath Method

SchemaPathStatementReversePath Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ReversePath()
public:
void ReversePath()
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.RotationHandles Method

SchemaPathStatementRotationHandles Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RotationHandles()
public:
void RotationHandles()
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.SaveDatabase Method

SchemaPathStatementSaveDatabase Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool SaveDatabase(
    bool useLayout
)
public:
virtual bool SaveDatabase(
    bool useLayout
) sealed

Parameters

useLayout
Type: SystemBoolean

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SchemaPathStatement.SaveDatabase(System.Boolean)"]

See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.SelectCurve Method

SchemaPathStatementSelectCurve Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SelectCurve()
public:
void SelectCurve()
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.SelectCurveCompleted Method

SchemaPathStatementSelectCurveCompleted Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SelectCurveCompleted(
    Object sender,
    ResultCompletionEventArgs args
)
public:
void SelectCurveCompleted(
    Object^ sender,
    ResultCompletionEventArgs^ args
)

Parameters

sender
Type: SystemObject
args
Type: ResultCompletionEventArgs
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.SetExternalTcp Method

SchemaPathStatementSetExternalTcp Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetExternalTcp(
    bool value,
    bool keepWorldPosition
)
public:
virtual void SetExternalTcp(
    bool value,
    bool keepWorldPosition
) sealed

Parameters

value
Type: SystemBoolean
keepWorldPosition
Type: SystemBoolean

Implements

IPositionStatementSetExternalTcp(Boolean, Boolean)
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.SetSchemaValue Method

SchemaPathStatementSetSchemaValue Method

Overload List
 | Name | Description
Public method | SetSchemaValue(Int32, Int32, Object) |
Public method | SetSchemaValue(Int32, String, Object) |
Top
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.SetSchemaValue Method (Int32, Int32, Object)

SchemaPathStatementSetSchemaValue Method (Int32, Int32, Object)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetSchemaValue(
    int positionIndex,
    int fieldIndex,
    Object value
)
public:
virtual void SetSchemaValue(
    int positionIndex,
    int fieldIndex,
    Object^ value
) sealed

Parameters

positionIndex
Type: SystemInt32
fieldIndex
Type: SystemInt32
value
Type: SystemObject

Implements

IPathStatementSetSchemaValue(Int32, Int32, Object)
See Also

Reference

SchemaPathStatement Class
SetSchemaValue Overload
VisualComponents.UX.Shared Namespace


SchemaPathStatement.SetSchemaValue Method (Int32, String, Object)

SchemaPathStatementSetSchemaValue Method (Int32, String, Object)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetSchemaValue(
    int positionIndex,
    string fieldName,
    Object value
)
public:
virtual void SetSchemaValue(
    int positionIndex,
    String^ fieldName,
    Object^ value
) sealed

Parameters

positionIndex
Type: SystemInt32
fieldName
Type: SystemString
value
Type: SystemObject

Implements

IPathStatementSetSchemaValue(Int32, String, Object)
See Also

Reference

SchemaPathStatement Class
SetSchemaValue Overload
VisualComponents.UX.Shared Namespace


SchemaPathStatement.SetSchemaValues Method

SchemaPathStatementSetSchemaValues Method

Overload List
 | Name | Description
Public method | SetSchemaValues(Int32, IEnumerableInt32, IEnumerableObject) |
Public method | SetSchemaValues(IEnumerableIPositionFrame, IEnumerableInt32, IEnumerableObject) |
Public method | SetSchemaValues(IEnumerableIPositionFrame, String, Object) |
Top
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.SetSchemaValues Method (Int32, IEnumerable(Int32), IEnumerable(Object))

SchemaPathStatementSetSchemaValues Method (Int32, IEnumerableInt32, IEnumerableObject)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetSchemaValues(
    int positionIndex,
    IEnumerable<int> fieldIndices,
    IEnumerable<Object> values
)
public:
virtual void SetSchemaValues(
    int positionIndex,
    IEnumerable<int>^ fieldIndices,
    IEnumerable<Object^>^ values
) sealed

Parameters

positionIndex
Type: SystemInt32
fieldIndices
Type: System.Collections.GenericIEnumerableInt32
values
Type: System.Collections.GenericIEnumerableObject

Implements

IPathStatementSetSchemaValues(Int32, IEnumerableInt32, IEnumerableObject)
See Also

Reference

SchemaPathStatement Class
SetSchemaValues Overload
VisualComponents.UX.Shared Namespace


SchemaPathStatement.SetSchemaValues Method (IEnumerable(IPositionFrame), IEnumerable(Int32), IEnumerable(Object))

SchemaPathStatementSetSchemaValues Method (IEnumerableIPositionFrame, IEnumerableInt32, IEnumerableObject)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetSchemaValues(
    IEnumerable<IPositionFrame> frames,
    IEnumerable<int> fieldIndices,
    IEnumerable<Object> values
)
public:
virtual void SetSchemaValues(
    IEnumerable<IPositionFrame^>^ frames,
    IEnumerable<int>^ fieldIndices,
    IEnumerable<Object^>^ values
) sealed

Parameters

frames
Type: System.Collections.GenericIEnumerableIPositionFrame
fieldIndices
Type: System.Collections.GenericIEnumerableInt32
values
Type: System.Collections.GenericIEnumerableObject

Implements

IPathStatementSetSchemaValues(IEnumerableIPositionFrame, IEnumerableInt32, IEnumerableObject)
See Also

Reference

SchemaPathStatement Class
SetSchemaValues Overload
VisualComponents.UX.Shared Namespace


SchemaPathStatement.SetSchemaValues Method (IEnumerable(IPositionFrame), String, Object)

SchemaPathStatementSetSchemaValues Method (IEnumerableIPositionFrame, String, Object)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetSchemaValues(
    IEnumerable<IPositionFrame> frames,
    string fieldName,
    Object value
)
public:
virtual void SetSchemaValues(
    IEnumerable<IPositionFrame^>^ frames,
    String^ fieldName,
    Object^ value
) sealed

Parameters

frames
Type: System.Collections.GenericIEnumerableIPositionFrame
fieldName
Type: SystemString
value
Type: SystemObject

Implements

IPathStatementSetSchemaValues(IEnumerableIPositionFrame, String, Object)
See Also

Reference

SchemaPathStatement Class
SetSchemaValues Overload
VisualComponents.UX.Shared Namespace


SchemaPathStatement.SetStatement Method

SchemaPathStatementSetStatement Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void SetStatement(
    IStatement statement
)
public:
virtual void SetStatement(
    IStatement^ statement
) override

Parameters

statement
Type: VisualComponents.Create3DIStatement

Implements

ICustomStatementSetStatement(IStatement)
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.ShowLabelsDyn Method

SchemaPathStatementShowLabelsDyn Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ShowLabelsDyn()
public:
void ShowLabelsDyn()
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.StartInterpolation Method

SchemaPathStatementStartInterpolation Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public virtual double StartInterpolation(
    IMotionTarget from
)
public:
virtual double StartInterpolation(
    IMotionTarget^ from
)

Parameters

from
Type: VisualComponents.Create3DIMotionTarget

Return Value

Type: Double

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SchemaPathStatement.StartInterpolation(VisualComponents.Create3D.IMotionTarget)"]

Implements

IInterpolatableStartInterpolation(IMotionTarget)
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.StatementInvalidated Method

SchemaPathStatementStatementInvalidated Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void StatementInvalidated()
protected:
virtual void StatementInvalidated() override
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement Events

The SchemaPathStatement type exposes the following members.

Events
 | Name | Description
Public event | DatabaseChanged |
Public event | Executed | (Inherited from CustomStatementBase.)
Public event | ExecutedEx | (Inherited from CustomStatementBase.)
Public event | Executing | (Inherited from CustomStatementBase.)
Public event | ExecutingEx | (Inherited from CustomStatementBase.)
Public event | Initialized |
Public event | ObjectInvalidated | (Inherited from CustomStatementBase.)
Public event | PositionAdded |
Public event | PositionRemoving |
Public event | PositionTransformationChanged |
Public event | PropertyContainerChanged | (Inherited from CustomStatementBase.)
Public event | Reset | (Inherited from CustomStatementBase.)
Top
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.DatabaseChanged Event

SchemaPathStatementDatabaseChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<DatabaseChangedEventArgs> DatabaseChanged
public:
virtual  event EventHandler<DatabaseChangedEventArgs^>^ DatabaseChanged {
    void add (EventHandler<DatabaseChangedEventArgs^>^ value);
    void remove (EventHandler<DatabaseChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerDatabaseChangedEventArgs

Implements

IPathStatementDatabaseChanged
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.Initialized Event

SchemaPathStatementInitialized Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<EventArgs> Initialized
public:
 event EventHandler<EventArgs^>^ Initialized {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}

Value

Type: SystemEventHandlerEventArgs
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.PositionAdded Event

SchemaPathStatementPositionAdded Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<PositionFrameAddedEventArgs> PositionAdded
public:
virtual  event EventHandler<PositionFrameAddedEventArgs^>^ PositionAdded {
    void add (EventHandler<PositionFrameAddedEventArgs^>^ value);
    void remove (EventHandler<PositionFrameAddedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerPositionFrameAddedEventArgs

Implements

IPositionFrameContainerPositionAdded
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.PositionRemoving Event

SchemaPathStatementPositionRemoving Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<PositionFrameRemovingEventArgs> PositionRemoving
public:
virtual  event EventHandler<PositionFrameRemovingEventArgs^>^ PositionRemoving {
    void add (EventHandler<PositionFrameRemovingEventArgs^>^ value);
    void remove (EventHandler<PositionFrameRemovingEventArgs^>^ value);
}

Value

Type: SystemEventHandlerPositionFrameRemovingEventArgs

Implements

IPositionFrameContainerPositionRemoving
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPathStatement.PositionTransformationChanged Event

SchemaPathStatementPositionTransformationChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<PositionFrameTransformationChangedEventArgs> PositionTransformationChanged
public:
virtual  event EventHandler<PositionFrameTransformationChangedEventArgs^>^ PositionTransformationChanged {
    void add (EventHandler<PositionFrameTransformationChangedEventArgs^>^ value);
    void remove (EventHandler<PositionFrameTransformationChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerPositionFrameTransformationChangedEventArgs

Implements

IPositionStatementPositionTransformationChanged
See Also

Reference

SchemaPathStatement Class
VisualComponents.UX.Shared Namespace


SchemaPositionsView Class

Interaction logic for SchemaPositionsView.xaml
SchemaPositionsView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedSchemaPositionsView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SchemaPositionsView : UserControl,
    IComponentConnector
public ref class SchemaPositionsView : public UserControl,
    IComponentConnector

The SchemaPositionsView type exposes the following members.

Constructors
 | Name | Description
Public method | SchemaPositionsView | Initializes a new instance of the SchemaPositionsView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SchemaPositionsView Constructor

Initializes a new instance of the SchemaPositionsView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SchemaPositionsView()
public:
SchemaPositionsView()
See Also

Reference

SchemaPositionsView Class
VisualComponents.UX.Shared Namespace


SchemaPositionsView Properties

The SchemaPositionsView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

SchemaPositionsView Class
VisualComponents.UX.Shared Namespace


SchemaPositionsView Methods

The SchemaPositionsView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SchemaPositionsView Class
VisualComponents.UX.Shared Namespace


SchemaPositionsView.InitializeComponent Method

SchemaPositionsViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

SchemaPositionsView Class
VisualComponents.UX.Shared Namespace


SchemaPositionsView Events

The SchemaPositionsView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

SchemaPositionsView Class
VisualComponents.UX.Shared Namespace


ScriptEditor Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.Controls.PrimitivesButtonBase
System.Windows.ControlsButton
VisualComponents.UX.SharedScriptEditor

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ScriptEditor : Button
public ref class ScriptEditor : public Button

The ScriptEditor type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptEditor | Initializes a new instance of the ScriptEditor class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | ClickMode | Gets or sets when the Click event occurs. (Inherited from ButtonBase.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | Command | Gets or sets the command to invoke when this button is pressed. (Inherited from ButtonBase.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property. (Inherited from ButtonBase.)
Public property | CommandTarget | Gets or sets the element on which to raise the specified command. (Inherited from ButtonBase.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsCancel | Gets or sets a value that indicates whether a Button is a Cancel button. A user can activate the Cancel button by pressing the ESC key. (Inherited from Button.)
Public property | IsDefault | Gets or sets a value that indicates whether a Button is the default button. A user invokes the default button by pressing the ENTER key. (Inherited from Button.)
Public property | IsDefaulted | Gets a value that indicates whether a Button is the button that is activated when a user presses ENTER. (Inherited from Button.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets the value of the IsEnabled property. (Inherited from ButtonBase.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsPressed | Gets a value that indicates whether a ButtonBase is currently activated. (Inherited from ButtonBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Responds when the AccessKey for this control is called. (Inherited from ButtonBase.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClick | Called when a Button is clicked. (Inherited from Button.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates an appropriate ButtonAutomationPeer for this control as part of the WPF infrastructure. (Inherited from Button.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsPressedChanged | Called when the IsPressed property changes. (Inherited from ButtonBase.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Provides class handling for the KeyDown routed event that occurs when the user presses a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnKeyUp | Provides class handling for the KeyUp routed event that occurs when the user releases a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Called when an element loses keyboard focus. (Inherited from ButtonBase.)
Protected method | OnLostMouseCapture | Provides class handling for the LostMouseCapture routed event that occurs when this control is no longer receiving mouse event messages. (Inherited from ButtonBase.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Provides class handling for the ClickMode routed event that occurs when the mouse enters this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeave | Provides class handling for the MouseLeave routed event that occurs when the mouse leaves an element. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonDown | Provides class handling for the MouseLeftButtonDown routed event that occurs when the left mouse button is pressed while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonUp | Provides class handling for the MouseLeftButtonUp routed event that occurs when the left mouse button is released while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseMove | Provides class handling for the MouseMove routed event that occurs when the mouse pointer moves while over this element. (Inherited from ButtonBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Called when the rendered size of a control changes. (Inherited from ButtonBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | Click | Occurs when a Button is clicked. (Inherited from ButtonBase.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ScriptEditor Constructor

Initializes a new instance of the ScriptEditor class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ScriptEditor()
public:
ScriptEditor()
See Also

Reference

ScriptEditor Class
VisualComponents.UX.Shared Namespace


ScriptEditor Properties

The ScriptEditor type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | ClickMode | Gets or sets when the Click event occurs. (Inherited from ButtonBase.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | Command | Gets or sets the command to invoke when this button is pressed. (Inherited from ButtonBase.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | CommandParameter | Gets or sets the parameter to pass to the Command property. (Inherited from ButtonBase.)
Public property | CommandTarget | Gets or sets the element on which to raise the specified command. (Inherited from ButtonBase.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsCancel | Gets or sets a value that indicates whether a Button is a Cancel button. A user can activate the Cancel button by pressing the ESC key. (Inherited from Button.)
Public property | IsDefault | Gets or sets a value that indicates whether a Button is the default button. A user invokes the default button by pressing the ENTER key. (Inherited from Button.)
Public property | IsDefaulted | Gets a value that indicates whether a Button is the button that is activated when a user presses ENTER. (Inherited from Button.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets the value of the IsEnabled property. (Inherited from ButtonBase.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsPressed | Gets a value that indicates whether a ButtonBase is currently activated. (Inherited from ButtonBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ScriptEditor Class
VisualComponents.UX.Shared Namespace


ScriptEditor Methods

The ScriptEditor type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Responds when the AccessKey for this control is called. (Inherited from ButtonBase.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClick | Called when a Button is clicked. (Inherited from Button.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates an appropriate ButtonAutomationPeer for this control as part of the WPF infrastructure. (Inherited from Button.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsPressedChanged | Called when the IsPressed property changes. (Inherited from ButtonBase.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Provides class handling for the KeyDown routed event that occurs when the user presses a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnKeyUp | Provides class handling for the KeyUp routed event that occurs when the user releases a key while this control has focus. (Inherited from ButtonBase.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Called when an element loses keyboard focus. (Inherited from ButtonBase.)
Protected method | OnLostMouseCapture | Provides class handling for the LostMouseCapture routed event that occurs when this control is no longer receiving mouse event messages. (Inherited from ButtonBase.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Provides class handling for the ClickMode routed event that occurs when the mouse enters this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeave | Provides class handling for the MouseLeave routed event that occurs when the mouse leaves an element. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonDown | Provides class handling for the MouseLeftButtonDown routed event that occurs when the left mouse button is pressed while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseLeftButtonUp | Provides class handling for the MouseLeftButtonUp routed event that occurs when the left mouse button is released while the mouse pointer is over this control. (Inherited from ButtonBase.)
Protected method | OnMouseMove | Provides class handling for the MouseMove routed event that occurs when the mouse pointer moves while over this element. (Inherited from ButtonBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Called when the rendered size of a control changes. (Inherited from ButtonBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ScriptEditor Class
VisualComponents.UX.Shared Namespace


ScriptEditor.OnApplyTemplate Method

ScriptEditorOnApplyTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

ScriptEditor Class
VisualComponents.UX.Shared Namespace


ScriptEditor Events

The ScriptEditor type exposes the following members.

Events
 | Name | Description
Public event | Click | Occurs when a Button is clicked. (Inherited from ButtonBase.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ScriptEditor Class
VisualComponents.UX.Shared Namespace


ScriptProperty Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedEditorProperty
VisualComponents.UX.SharedScriptProperty

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ScriptProperty : EditorProperty
public ref class ScriptProperty sealed : public EditorProperty

The ScriptProperty type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptProperty | Initializes a new instance of the ScriptProperty class
Top
Properties
 | Name | Description
Public property | AllowedMaximum | (Inherited from EditorProperty.)
Public property | AllowedMinimum | (Inherited from EditorProperty.)
Public property | AllowedValues | (Inherited from EditorProperty.)
Public property | CanCreateNewValue | (Inherited from EditorProperty.)
Public property | Category | (Inherited from EditorProperty.)
Public property | ConstraintType | (Inherited from EditorProperty.)
Public property | Container | (Inherited from EditorProperty.)
Public property | ContainerExpressionContext | (Inherited from EditorProperty.)
Public property | ContainerObject | Similar to IProperty.Container, but for any object. (Inherited from EditorProperty.)
Public property | CreationTypes | (Inherited from EditorProperty.)
Public property | Description | (Inherited from EditorProperty.)
Public property | DisabledStateToolTip | (Inherited from EditorProperty.)
Public property | DistributionExpression | (Inherited from EditorProperty.)
Public property | Error | (Inherited from EditorProperty.)
Public property | ErrorMessage | (Inherited from EditorProperty.)
Public property | HasDistribution | (Inherited from EditorProperty.)
Public property | History | (Inherited from EditorProperty.)
Public property | Index_ForComboBox | (Inherited from EditorProperty.)
Public property | IsDesignTime | (Inherited from EditorProperty.)
Public property | IsEditable | Helper property since in XAML negating binding value is not possible without using BoolToOppositeConverter (Inherited from EditorProperty.)
Public property | IsEditableInGui | (Inherited from EditorProperty.)
Public property | IsExceptionallyInHome | (Inherited from EditorProperty.)
Public property | IsInternal | (Inherited from EditorProperty.)
Public property | IsLocked | (Inherited from EditorProperty.)
Public property | IsPersistent | (Inherited from EditorProperty.)
Public property | IsQuantityValue | (Inherited from EditorProperty.)
Public property | IsReadOnly | (Inherited from EditorProperty.)
Public property | IsValid | (Inherited from EditorProperty.)
Public property | IsVisible | (Inherited from EditorProperty.)
Public property | IsVisibleDesignTime | (Inherited from EditorProperty.)
Public property | IsVisibleForced | (Inherited from EditorProperty.)
Public property | IsVisibleInGui | IsVisibleInGui is used to bind GUI visibility. Setting this value affects only _isVisibleForcedOff. (Inherited from EditorProperty.)
Public property | Item | (Inherited from EditorProperty.)
Public property | Name | (Inherited from EditorProperty.)
Public property | NonLocalizedName | (Inherited from EditorProperty.)
Public property | Order | (Inherited from EditorProperty.)
Public property | Property | (Inherited from EditorProperty.)
Public property | PropertyDescription | (Inherited from EditorProperty.)
Public property | PropertyType | (Inherited from EditorProperty.)
Public property | Quantity | (Inherited from EditorProperty.)
Public property | ResourceType | In case of having an IUriProperty, this determines if the editor should allow folder selection instead of file selection (Inherited from EditorProperty.)
Public property | RotationSystem | (Inherited from EditorProperty.)
Public property | ShowValuepicker | (Inherited from EditorProperty.)
Public property | TabHeader | (Inherited from EditorProperty.)
Public property | Unit | (Inherited from EditorProperty.)
Public property | Value | (Inherited from EditorProperty.)
Public property | Value_ForComboBox | Helper property, used only by ComboBox. (Inherited from EditorProperty.)
Public property | ValueString | (Inherited from EditorProperty.)
Top
Methods
 | Name | Description
Public method | Associate | (Inherited from EditorProperty.)
Public method | CheckEditableInGui | (Inherited from EditorProperty.)
Public method | CheckRebuild | This happens only on UI changes. If containeris a behavior of feature call evaluate or rebuild to update geometry. (Inherited from EditorProperty.)
Public method | CheckRebuildSmart | (Inherited from EditorProperty.)
Public method | Click |
Public method | Clone | (Inherited from EditorProperty.)
Public method | CreateAndSetNewValue | (Inherited from EditorProperty.)
Public method | Disassociate | (Inherited from EditorProperty.)
Public method | Dispose | (Inherited from EditorProperty.)
Public method | EndBatch | (Inherited from EditorProperty.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PickValue | Execute PickAction and wait for user to click on some object. (Inherited from EditorProperty.)
Public method | PickValueProxy | (Inherited from EditorProperty.)
Public method | SetQuantity | (Inherited from EditorProperty.)
Public method | SetUnitMagnitude | (Inherited from EditorProperty.)
Public method | StartBatch | (Inherited from EditorProperty.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | property changed event (Inherited from EditorProperty.)
Top
Fields
 | Name | Description
Public field | SuppressValueChange | (Inherited from EditorProperty.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ScriptProperty Constructor

Initializes a new instance of the ScriptProperty class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ScriptProperty(
    IProperty property
)
public:
ScriptProperty(
    IProperty^ property
)

Parameters

property
Type: VisualComponents.Create3DIProperty
See Also

Reference

ScriptProperty Class
VisualComponents.UX.Shared Namespace


ScriptProperty Properties

The ScriptProperty type exposes the following members.

Properties
 | Name | Description
Public property | AllowedMaximum | (Inherited from EditorProperty.)
Public property | AllowedMinimum | (Inherited from EditorProperty.)
Public property | AllowedValues | (Inherited from EditorProperty.)
Public property | CanCreateNewValue | (Inherited from EditorProperty.)
Public property | Category | (Inherited from EditorProperty.)
Public property | ConstraintType | (Inherited from EditorProperty.)
Public property | Container | (Inherited from EditorProperty.)
Public property | ContainerExpressionContext | (Inherited from EditorProperty.)
Public property | ContainerObject | Similar to IProperty.Container, but for any object. (Inherited from EditorProperty.)
Public property | CreationTypes | (Inherited from EditorProperty.)
Public property | Description | (Inherited from EditorProperty.)
Public property | DisabledStateToolTip | (Inherited from EditorProperty.)
Public property | DistributionExpression | (Inherited from EditorProperty.)
Public property | Error | (Inherited from EditorProperty.)
Public property | ErrorMessage | (Inherited from EditorProperty.)
Public property | HasDistribution | (Inherited from EditorProperty.)
Public property | History | (Inherited from EditorProperty.)
Public property | Index_ForComboBox | (Inherited from EditorProperty.)
Public property | IsDesignTime | (Inherited from EditorProperty.)
Public property | IsEditable | Helper property since in XAML negating binding value is not possible without using BoolToOppositeConverter (Inherited from EditorProperty.)
Public property | IsEditableInGui | (Inherited from EditorProperty.)
Public property | IsExceptionallyInHome | (Inherited from EditorProperty.)
Public property | IsInternal | (Inherited from EditorProperty.)
Public property | IsLocked | (Inherited from EditorProperty.)
Public property | IsPersistent | (Inherited from EditorProperty.)
Public property | IsQuantityValue | (Inherited from EditorProperty.)
Public property | IsReadOnly | (Inherited from EditorProperty.)
Public property | IsValid | (Inherited from EditorProperty.)
Public property | IsVisible | (Inherited from EditorProperty.)
Public property | IsVisibleDesignTime | (Inherited from EditorProperty.)
Public property | IsVisibleForced | (Inherited from EditorProperty.)
Public property | IsVisibleInGui | IsVisibleInGui is used to bind GUI visibility. Setting this value affects only _isVisibleForcedOff. (Inherited from EditorProperty.)
Public property | Item | (Inherited from EditorProperty.)
Public property | Name | (Inherited from EditorProperty.)
Public property | NonLocalizedName | (Inherited from EditorProperty.)
Public property | Order | (Inherited from EditorProperty.)
Public property | Property | (Inherited from EditorProperty.)
Public property | PropertyDescription | (Inherited from EditorProperty.)
Public property | PropertyType | (Inherited from EditorProperty.)
Public property | Quantity | (Inherited from EditorProperty.)
Public property | ResourceType | In case of having an IUriProperty, this determines if the editor should allow folder selection instead of file selection (Inherited from EditorProperty.)
Public property | RotationSystem | (Inherited from EditorProperty.)
Public property | ShowValuepicker | (Inherited from EditorProperty.)
Public property | TabHeader | (Inherited from EditorProperty.)
Public property | Unit | (Inherited from EditorProperty.)
Public property | Value | (Inherited from EditorProperty.)
Public property | Value_ForComboBox | Helper property, used only by ComboBox. (Inherited from EditorProperty.)
Public property | ValueString | (Inherited from EditorProperty.)
Top
See Also

Reference

ScriptProperty Class
VisualComponents.UX.Shared Namespace


ScriptProperty Methods

The ScriptProperty type exposes the following members.

Methods
 | Name | Description
Public method | Associate | (Inherited from EditorProperty.)
Public method | CheckEditableInGui | (Inherited from EditorProperty.)
Public method | CheckRebuild | This happens only on UI changes. If containeris a behavior of feature call evaluate or rebuild to update geometry. (Inherited from EditorProperty.)
Public method | CheckRebuildSmart | (Inherited from EditorProperty.)
Public method | Click |
Public method | Clone | (Inherited from EditorProperty.)
Public method | CreateAndSetNewValue | (Inherited from EditorProperty.)
Public method | Disassociate | (Inherited from EditorProperty.)
Public method | Dispose | (Inherited from EditorProperty.)
Public method | EndBatch | (Inherited from EditorProperty.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PickValue | Execute PickAction and wait for user to click on some object. (Inherited from EditorProperty.)
Public method | PickValueProxy | (Inherited from EditorProperty.)
Public method | SetQuantity | (Inherited from EditorProperty.)
Public method | SetUnitMagnitude | (Inherited from EditorProperty.)
Public method | StartBatch | (Inherited from EditorProperty.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ScriptProperty Class
VisualComponents.UX.Shared Namespace


ScriptProperty.Click Method

ScriptPropertyClick Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Click()
public:
void Click()
See Also

Reference

ScriptProperty Class
VisualComponents.UX.Shared Namespace


ScriptProperty Events

The ScriptProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | property changed event (Inherited from EditorProperty.)
Top
See Also

Reference

ScriptProperty Class
VisualComponents.UX.Shared Namespace


ScriptProperty Fields

The ScriptProperty type exposes the following members.

Fields
 | Name | Description
Public field | SuppressValueChange | (Inherited from EditorProperty.)
Top
See Also

Reference

ScriptProperty Class
VisualComponents.UX.Shared Namespace


ScrollViewerMonitor Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedScrollViewerMonitor

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ScrollViewerMonitor
public ref class ScrollViewerMonitor

The ScrollViewerMonitor type exposes the following members.

Constructors
 | Name | Description
Public method | ScrollViewerMonitor | Initializes a new instance of the ScrollViewerMonitor class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetAtEndCommand |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnAtEndCommandChanged |
 | SetAtEndCommand |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
AtEndCommandProperty |
Top
Attached Properties
 | Name | Description
Public attached property | AtEndCommand |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ScrollViewerMonitor Constructor

Initializes a new instance of the ScrollViewerMonitor class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ScrollViewerMonitor()
public:
ScrollViewerMonitor()
See Also

Reference

ScrollViewerMonitor Class
VisualComponents.UX.Shared Namespace


ScrollViewerMonitor Methods

The ScrollViewerMonitor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetAtEndCommand |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnAtEndCommandChanged |
 | SetAtEndCommand |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ScrollViewerMonitor Class
VisualComponents.UX.Shared Namespace


ScrollViewerMonitor.GetAtEndCommand Method

ScrollViewerMonitorGetAtEndCommand Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ICommand GetAtEndCommand(
    DependencyObject obj
)
public:
static ICommand^ GetAtEndCommand(
    DependencyObject^ obj
)

Parameters

obj
Type: System.WindowsDependencyObject

Return Value

Type: ICommand

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ScrollViewerMonitor.GetAtEndCommand(System.Windows.DependencyObject)"]

See Also

Reference

ScrollViewerMonitor Class
VisualComponents.UX.Shared Namespace


ScrollViewerMonitor.OnAtEndCommandChanged Method

ScrollViewerMonitorOnAtEndCommandChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void OnAtEndCommandChanged(
    DependencyObject d,
    DependencyPropertyChangedEventArgs e
)
public:
static void OnAtEndCommandChanged(
    DependencyObject^ d,
    DependencyPropertyChangedEventArgs e
)

Parameters

d
Type: System.WindowsDependencyObject
e
Type: System.WindowsDependencyPropertyChangedEventArgs
See Also

Reference

ScrollViewerMonitor Class
VisualComponents.UX.Shared Namespace


ScrollViewerMonitor.SetAtEndCommand Method

ScrollViewerMonitorSetAtEndCommand Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetAtEndCommand(
    DependencyObject obj,
    ICommand value
)
public:
static void SetAtEndCommand(
    DependencyObject^ obj,
    ICommand^ value
)

Parameters

obj
Type: System.WindowsDependencyObject
value
Type: System.Windows.InputICommand
See Also

Reference

ScrollViewerMonitor Class
VisualComponents.UX.Shared Namespace


ScrollViewerMonitor Fields

The ScrollViewerMonitor type exposes the following members.

Fields
Name | Description
AtEndCommandProperty |
Top
See Also

Reference

ScrollViewerMonitor Class
VisualComponents.UX.Shared Namespace


ScrollViewerMonitor.AtEndCommandProperty Field

ScrollViewerMonitorAtEndCommandProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty AtEndCommandProperty
public:
static DependencyProperty^ AtEndCommandProperty

Field Value

Type: DependencyProperty
See Also

Reference

ScrollViewerMonitor Class
VisualComponents.UX.Shared Namespace


ScrollViewerMonitor Attached Properties

The ScrollViewerMonitor type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | AtEndCommand |
Top
See Also

Reference

ScrollViewerMonitor Class
VisualComponents.UX.Shared Namespace


ScrollViewerMonitor.AtEndCommand Attached Property

ScrollViewerMonitorAtEndCommand Attached Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See GetAtEndCommand, SetAtEndCommand
See GetAtEndCommand, SetAtEndCommand

Property Value

Type: ICommand
See Also

Reference

ScrollViewerMonitor Class
VisualComponents.UX.Shared Namespace


SearchableTextblock Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
VisualComponents.UX.SharedSearchableTextblock

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SearchableTextblock : Control
public ref class SearchableTextblock : public Control

The SearchableTextblock type exposes the following members.

Constructors
 | Name | Description
Public method | SearchableTextblock | Initializes a new instance of the SearchableTextblock class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HighlightBackground | HighlightBackground sandbox which is used to get or set the value from a dependency property, if it gets a value,it should be forced to bind to a Brushes type.
Public property | HighlightForeground | HighlightForeground sandbox which is used to get or set the value from a dependency property, if it gets a value,it should be forced to bind to a Brushes type.
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHighlight | IsHighlight sandbox which is used to get or set the value from a dependency property, if it gets a value,it should be forced to bind to a bool type.
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMatchCase | IsMatchCase sandbox which is used to get or set the value from a dependency property, if it gets a value,it should be forced to bind to a bool type.
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SearchText | SearchText sandbox which is used to get or set the value from a dependency property, if it gets a value,it should be forced to bind to a string type.
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Text sandbox which is used to get or set the value from a dependency property.
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | override the OnRender method which is used to search for the keyword and highlight it when the operation gets the result. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
HighlightBackgroundProperty |
HighlightForegroundProperty |
IsHighlightProperty |
IsMatchCaseProperty |
SearchTextProperty | Real implementation about SearchTextProperty which registers a dependency property with the specified property name, property type, owner type, and property metadata.
TextProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SearchableTextblock Constructor

Initializes a new instance of the SearchableTextblock class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SearchableTextblock()
public:
SearchableTextblock()
See Also

Reference

SearchableTextblock Class
VisualComponents.UX.Shared Namespace


SearchableTextblock Properties

The SearchableTextblock type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HighlightBackground | HighlightBackground sandbox which is used to get or set the value from a dependency property, if it gets a value,it should be forced to bind to a Brushes type.
Public property | HighlightForeground | HighlightForeground sandbox which is used to get or set the value from a dependency property, if it gets a value,it should be forced to bind to a Brushes type.
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHighlight | IsHighlight sandbox which is used to get or set the value from a dependency property, if it gets a value,it should be forced to bind to a bool type.
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMatchCase | IsMatchCase sandbox which is used to get or set the value from a dependency property, if it gets a value,it should be forced to bind to a bool type.
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SearchText | SearchText sandbox which is used to get or set the value from a dependency property, if it gets a value,it should be forced to bind to a string type.
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Text sandbox which is used to get or set the value from a dependency property.
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

SearchableTextblock Class
VisualComponents.UX.Shared Namespace


SearchableTextblock.HighlightBackground Property

SearchableTextblockHighlightBackground Property

HighlightBackground sandbox which is used to get or set the value from a dependency property, if it gets a value,it should be forced to bind to a Brushes type.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Brush HighlightBackground { get; set; }
public:
property Brush^ HighlightBackground {
    Brush^ get ();
    void set (Brush^ value);
}

Property Value

Type: Brush
See Also

Reference

SearchableTextblock Class
VisualComponents.UX.Shared Namespace


SearchableTextblock.HighlightForeground Property

SearchableTextblockHighlightForeground Property

HighlightForeground sandbox which is used to get or set the value from a dependency property, if it gets a value,it should be forced to bind to a Brushes type.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Brush HighlightForeground { get; set; }
public:
property Brush^ HighlightForeground {
    Brush^ get ();
    void set (Brush^ value);
}

Property Value

Type: Brush
See Also

Reference

SearchableTextblock Class
VisualComponents.UX.Shared Namespace


SearchableTextblock.IsHighlight Property

SearchableTextblockIsHighlight Property

IsHighlight sandbox which is used to get or set the value from a dependency property, if it gets a value,it should be forced to bind to a bool type.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsHighlight { get; set; }
public:
property bool IsHighlight {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SearchableTextblock Class
VisualComponents.UX.Shared Namespace


SearchableTextblock.IsMatchCase Property

SearchableTextblockIsMatchCase Property

IsMatchCase sandbox which is used to get or set the value from a dependency property, if it gets a value,it should be forced to bind to a bool type.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsMatchCase { get; set; }
public:
property bool IsMatchCase {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SearchableTextblock Class
VisualComponents.UX.Shared Namespace


SearchableTextblock.SearchText Property

SearchableTextblockSearchText Property

SearchText sandbox which is used to get or set the value from a dependency property, if it gets a value,it should be forced to bind to a string type.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SearchText { get; set; }
public:
property String^ SearchText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SearchableTextblock Class
VisualComponents.UX.Shared Namespace


SearchableTextblock.Text Property

SearchableTextblockText Property

Text sandbox which is used to get or set the value from a dependency property.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Text { get; set; }
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SearchableTextblock Class
VisualComponents.UX.Shared Namespace


SearchableTextblock Methods

The SearchableTextblock type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | override the OnRender method which is used to search for the keyword and highlight it when the operation gets the result. (Overrides UIElementOnRender(DrawingContext).)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SearchableTextblock Class
VisualComponents.UX.Shared Namespace


SearchableTextblock.OnRender Method

SearchableTextblockOnRender Method

override the OnRender method which is used to search for the keyword and highlight it when the operation gets the result.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnRender(
    DrawingContext drawingContext
)
protected:
virtual void OnRender(
    DrawingContext^ drawingContext
) override

Parameters

drawingContext
Type: System.Windows.MediaDrawingContext
See Also

Reference

SearchableTextblock Class
VisualComponents.UX.Shared Namespace


SearchableTextblock Events

The SearchableTextblock type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

SearchableTextblock Class
VisualComponents.UX.Shared Namespace


SearchableTextblock Fields

The SearchableTextblock type exposes the following members.

Fields
Name | Description
HighlightBackgroundProperty |
HighlightForegroundProperty |
IsHighlightProperty |
IsMatchCaseProperty |
SearchTextProperty | Real implementation about SearchTextProperty which registers a dependency property with the specified property name, property type, owner type, and property metadata.
TextProperty |
Top
See Also

Reference

SearchableTextblock Class
VisualComponents.UX.Shared Namespace


SearchableTextblock.HighlightBackgroundProperty Field

SearchableTextblockHighlightBackgroundProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty HighlightBackgroundProperty
public:
static initonly DependencyProperty^ HighlightBackgroundProperty

Field Value

Type: DependencyProperty
See Also

Reference

SearchableTextblock Class
VisualComponents.UX.Shared Namespace


SearchableTextblock.HighlightForegroundProperty Field

SearchableTextblockHighlightForegroundProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty HighlightForegroundProperty
public:
static initonly DependencyProperty^ HighlightForegroundProperty

Field Value

Type: DependencyProperty
See Also

Reference

SearchableTextblock Class
VisualComponents.UX.Shared Namespace


SearchableTextblock.IsHighlightProperty Field

SearchableTextblockIsHighlightProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsHighlightProperty
public:
static initonly DependencyProperty^ IsHighlightProperty

Field Value

Type: DependencyProperty
See Also

Reference

SearchableTextblock Class
VisualComponents.UX.Shared Namespace


SearchableTextblock.IsMatchCaseProperty Field

SearchableTextblockIsMatchCaseProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsMatchCaseProperty
public:
static initonly DependencyProperty^ IsMatchCaseProperty

Field Value

Type: DependencyProperty
See Also

Reference

SearchableTextblock Class
VisualComponents.UX.Shared Namespace


SearchableTextblock.SearchTextProperty Field

SearchableTextblockSearchTextProperty Field

Real implementation about SearchTextProperty which registers a dependency property with the specified property name, property type, owner type, and property metadata.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty SearchTextProperty
public:
static initonly DependencyProperty^ SearchTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

SearchableTextblock Class
VisualComponents.UX.Shared Namespace


SearchableTextblock.TextProperty Field

SearchableTextblockTextProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty TextProperty
public:
static initonly DependencyProperty^ TextProperty

Field Value

Type: DependencyProperty
See Also

Reference

SearchableTextblock Class
VisualComponents.UX.Shared Namespace


SearchMode Enumeration

Defines the search behavior of SearchTextBox.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum SearchMode
public enum class SearchMode
Members
Member name | Value | Description
Instant | 0 | Immediatelly fire search.
Delayed | 1 | Fire search with a delay.
See Also

Reference

VisualComponents.UX.Shared Namespace


SearchTextBox Class

Property search box control.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.Controls.PrimitivesTextBoxBase
System.Windows.ControlsTextBox
VisualComponents.UX.SharedSearchTextBox

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SearchTextBox : TextBox
public ref class SearchTextBox : public TextBox

The SearchTextBox type exposes the following members.

Constructors
 | Name | Description
Public method | SearchTextBox | Initializes a new instance of the SearchTextBox class.
Top
Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key. (Inherited from TextBoxBase.)
Public property | AcceptsTab | Gets or sets a value that indicates how the text editing control responds when the user presses the TAB key. (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoWordSelection | Gets or sets a value that determines whether when a user selects part of a word by dragging across it with the mouse, the rest of the word is selected. (Inherited from TextBoxBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanRedo | Gets a value that indicates whether the most recent undo action can be redone. (Inherited from TextBoxBase.)
Public property | CanUndo | Gets a value that indicates whether the most recent action can be undone. (Inherited from TextBoxBase.)
Public property | CaretBrush | Gets or sets the brush that is used to paint the caret of the text box. (Inherited from TextBoxBase.)
Public property | CaretIndex | Gets or sets the insertion position index of the caret. (Inherited from TextBox.)
Public property | CharacterCasing | Gets or sets how characters are cased when they are manually entered into the text box. (Inherited from TextBox.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExtentHeight | Gets the vertical size of the visible content area. (Inherited from TextBoxBase.)
Public property | ExtentWidth | Gets the horizontal size of the visible content area. (Inherited from TextBoxBase.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | HasText | Gets a value indicating whether this instance has text. This is a dependency property.
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Gets or sets the horizontal scroll position. (Inherited from TextBoxBase.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal scroll bar is shown. (Inherited from TextBoxBase.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInactiveSelectionHighlightEnabled | Gets or sets a value that indicates whether the text box displays selected text when the text box does not have focus. (Inherited from TextBoxBase.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseLeftButtonDown | Gets or sets a value indicating whether mouse left button is down.
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that indicates whether the text editing control is read-only to a user interacting with the control. (Inherited from TextBoxBase.)
Public property | IsReadOnlyCaretVisible | Gets or sets a value that indicates whether a read-only text box displays a caret. (Inherited from TextBoxBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionActive | Gets a value that indicates whether the text box has focus and selected text. (Inherited from TextBoxBase.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets a value that indicates whether undo support is enabled for the text-editing control. (Inherited from TextBoxBase.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | LabelText | Gets or sets the label text. This is a dependency property.
Public property | LabelTextColor | Gets or sets the color of the label text. This is a dependency property.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | LineCount | Gets the total number of lines in the text box. (Inherited from TextBox.)
Protected property | LogicalChildren | Gets an enumerator for the logical child elements of the TextBox. (Inherited from TextBox.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxLength | Gets or sets the maximum number of characters that can be manually entered into the text box. (Inherited from TextBox.)
Public property | MaxLines | Gets or sets the maximum number of visible lines. (Inherited from TextBox.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinLines | Gets or sets the minimum number of visible lines. (Inherited from TextBox.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SearchEventTimeDelay | Gets or sets the search event time delay. This is a dependency property.
Public property | SearchMode | Gets or sets the search mode. This is a dependency property.
Public property | SelectedText | Gets or sets the content of the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionBrush | Gets or sets the brush that highlights selected text. (Inherited from TextBoxBase.)
Public property | SelectionLength | Gets or sets a value indicating the number of characters in the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionOpacity | Gets or sets the opacity of the SelectionBrush. (Inherited from TextBoxBase.)
Public property | SelectionStart | Gets or sets a character index for the beginning of the current selection. (Inherited from TextBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | SpellCheck | Gets a SpellCheck object that provides access to spelling errors in the text contents of a TextBoxBase or RichTextBox. (Inherited from TextBoxBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Gets or sets the text contents of the text box. (Inherited from TextBox.)
Public property | TextAlignment | Gets or sets the horizontal alignment of the contents of the text box. (Inherited from TextBox.)
Public property | TextDecorations | Gets the text decorations to apply to the text box. (Inherited from TextBox.)
Public property | TextWrapping | Gets or sets how the text box should wrap text. (Inherited from TextBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Typography | Gets the currently effective typography variations for the text contents of the text box. (Inherited from TextBox.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UndoLimit | Gets or sets the number of actions stored in the undo queue. (Inherited from TextBoxBase.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Gets or sets the vertical scroll position. (Inherited from TextBoxBase.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical scroll bar is shown. (Inherited from TextBoxBase.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | ViewportHeight | Gets the vertical size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | ViewportWidth | Gets the horizontal size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AppendText | Appends a string to the contents of a text control. (Inherited from TextBoxBase.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginChange | Begins a change block. (Inherited from TextBoxBase.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | Clears all the content from the text box. (Inherited from TextBox.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Copy | Copies the current selection of the text editing control to the Clipboard. (Inherited from TextBoxBase.)
Public method | Cut | Removes the current selection from the text editing control and copies it to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeclareChangeBlock | Creates a change block. (Inherited from TextBoxBase.)
Public method | EndChange | Ends a change block. (Inherited from TextBoxBase.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetCharacterIndexFromLineIndex | Returns the zero-based character index for the first character in the specified line. (Inherited from TextBox.)
Public method | GetCharacterIndexFromPoint | Returns the zero-based index of the character that is closest to the specified point. (Inherited from TextBox.)
Public method | GetFirstVisibleLineIndex | Returns the line index for the first line that is currently visible in the text box. (Inherited from TextBox.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLastVisibleLineIndex | Returns the line index for the last line that is currently visible in the text box. (Inherited from TextBox.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLineIndexFromCharacterIndex | Returns the zero-based line index for the line that contains the specified character index. (Inherited from TextBox.)
Public method | GetLineLength | Returns the number of characters in the specified line. (Inherited from TextBox.)
Public method | GetLineText | Returns the text that is currently displayed on the specified line. (Inherited from TextBox.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetNextSpellingErrorCharacterIndex | Returns the beginning character index for the next spelling error in the contents of the text box. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32) | Returns the rectangle for the leading edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32, Boolean) | Returns the rectangle for the leading or trailing edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetSpellingError | Returns a SpellingError object associated with any spelling error at the specified character index. (Inherited from TextBox.)
Public method | GetSpellingErrorLength | Returns the length of any spelling error that includes the specified character. (Inherited from TextBox.)
Public method | GetSpellingErrorStart | Returns the beginning character index for any spelling error that includes the specified character. (Inherited from TextBox.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls the contents of the control down by one line. (Inherited from TextBoxBase.)
Public method | LineLeft | Scrolls the contents of the control to the left by one line. (Inherited from TextBoxBase.)
Public method | LineRight | Scrolls the contents of the control to the right by one line. (Inherited from TextBoxBase.)
Public method | LineUp | Scrolls the contents of the control upward by one line. (Inherited from TextBoxBase.)
Public method | LockCurrentUndoUnit | Locks the most recent undo unit of the undo stack of the application. This prevents the locked unit from being merged with undo units that are added subsequently. (Inherited from TextBoxBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Sizes the text box to its content. (Inherited from TextBox.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | Is called when a control template is applied. (Overrides TextBoxBaseOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Called whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for the text box. (Inherited from TextBox.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragLeave | Invoked whenever an unhandled DragLeave attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragOver | Invoked whenever an unhandled DragOver attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDrop | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGiveFeedback | Invoked whenever an unhandled GiveFeedback attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked whenever an unhandled GotKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked whenever an unhandled KeyDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Overrides TextBoxBaseOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | Invoked whenever an unhandled KeyUp attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostFocus | Raises the LostFocus event (using the provided arguments). (Inherited from TextBoxBase.)
Protected method | OnLostKeyboardFocus | Invoked whenever an unhandled LostKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked whenever an unhandled MouseDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked whenever an unhandled MouseMove attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked whenever an unhandled MouseUp event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Is called when a MouseWheel event is routed to this class (or to a class that inherits from this class). (Inherited from TextBoxBase.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Called when the KeyDown occurs. (Inherited from TextBoxBase.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Called when one or more of the dependency properties that exist on the element have had their effective values changed. (Overrides TextBoxOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnQueryContinueDrag | Invoked whenever an unhandled QueryContinueDrag attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnQueryCursor | Invoked whenever an unhandled QueryCursor attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Is called when the caret or current selection changes position. (Inherited from TextBoxBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Is called when the control template changes. (Inherited from TextBoxBase.)
Protected method | OnTextChanged | Is called when content in this editing control changes. (Overrides TextBoxBaseOnTextChanged(TextChangedEventArgs).)
Protected method | OnTextInput | Invoked whenever an unhandled TextInput attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | PageDown | Scrolls the contents of the control down by one page. (Inherited from TextBoxBase.)
Public method | PageLeft | Scrolls the contents of the control to the left by one page. (Inherited from TextBoxBase.)
Public method | PageRight | Scrolls the contents of the control to the right by one page. (Inherited from TextBoxBase.)
Public method | PageUp | Scrolls the contents of the control up by one page. (Inherited from TextBoxBase.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | Paste | Pastes the contents of the Clipboard over the current selection in the text editing control. (Inherited from TextBoxBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Redo | Undoes the most recent undo command. In other words, redoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollToEnd | Scrolls the view of the editing control to the end of the content. (Inherited from TextBoxBase.)
Public method | ScrollToHome | Scrolls the view of the editing control to the beginning of the viewport. (Inherited from TextBoxBase.)
Public method | ScrollToHorizontalOffset | Scrolls the contents of the editing control to the specified horizontal offset. (Inherited from TextBoxBase.)
Public method | ScrollToLine | Scrolls the line at the specified line index into view. (Inherited from TextBox.)
Public method | ScrollToVerticalOffset | Scrolls the contents of the editing control to the specified vertical offset. (Inherited from TextBoxBase.)
Public method | Select | Selects a range of text in the text box. (Inherited from TextBox.)
Public method | SelectAll | Selects all the contents of the text editing control. (Inherited from TextBoxBase.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeText | Returns a value that indicates whether the effective value of the Text property should be serialized during serialization of the TextBox object. (Inherited from TextBox.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | Undo | Undoes the most recent undo command. In other words, undoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | Search | Occurs when search is performed.
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBoxBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextChanged | Occurs when content changes in the text element. (Inherited from TextBoxBase.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
HasTextProperty | Identifies the HasText dependency property.
IsMouseLeftButtonDownProperty | Identifies the IsMouseLeftButtonDown dependency property.
LabelTextColorProperty | Identifies the LabelTextColor dependency property.
LabelTextProperty | Identifies the LabelText dependency property.
SearchEvent | Identifies the Search routed event.
SearchEventTimeDelayProperty | Identifies the SearchEventTimeDelay dependency property.
SearchModeProperty | Identifies the SearchMode dependency property.
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SearchTextBox Constructor

Initializes a new instance of the SearchTextBox class.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SearchTextBox()
public:
SearchTextBox()
See Also

Reference

SearchTextBox Class
VisualComponents.UX.Shared Namespace


SearchTextBox Properties

The SearchTextBox type exposes the following members.

Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key. (Inherited from TextBoxBase.)
Public property | AcceptsTab | Gets or sets a value that indicates how the text editing control responds when the user presses the TAB key. (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoWordSelection | Gets or sets a value that determines whether when a user selects part of a word by dragging across it with the mouse, the rest of the word is selected. (Inherited from TextBoxBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanRedo | Gets a value that indicates whether the most recent undo action can be redone. (Inherited from TextBoxBase.)
Public property | CanUndo | Gets a value that indicates whether the most recent action can be undone. (Inherited from TextBoxBase.)
Public property | CaretBrush | Gets or sets the brush that is used to paint the caret of the text box. (Inherited from TextBoxBase.)
Public property | CaretIndex | Gets or sets the insertion position index of the caret. (Inherited from TextBox.)
Public property | CharacterCasing | Gets or sets how characters are cased when they are manually entered into the text box. (Inherited from TextBox.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExtentHeight | Gets the vertical size of the visible content area. (Inherited from TextBoxBase.)
Public property | ExtentWidth | Gets the horizontal size of the visible content area. (Inherited from TextBoxBase.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | HasText | Gets a value indicating whether this instance has text. This is a dependency property.
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Gets or sets the horizontal scroll position. (Inherited from TextBoxBase.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal scroll bar is shown. (Inherited from TextBoxBase.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInactiveSelectionHighlightEnabled | Gets or sets a value that indicates whether the text box displays selected text when the text box does not have focus. (Inherited from TextBoxBase.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseLeftButtonDown | Gets or sets a value indicating whether mouse left button is down.
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that indicates whether the text editing control is read-only to a user interacting with the control. (Inherited from TextBoxBase.)
Public property | IsReadOnlyCaretVisible | Gets or sets a value that indicates whether a read-only text box displays a caret. (Inherited from TextBoxBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionActive | Gets a value that indicates whether the text box has focus and selected text. (Inherited from TextBoxBase.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets a value that indicates whether undo support is enabled for the text-editing control. (Inherited from TextBoxBase.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | LabelText | Gets or sets the label text. This is a dependency property.
Public property | LabelTextColor | Gets or sets the color of the label text. This is a dependency property.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | LineCount | Gets the total number of lines in the text box. (Inherited from TextBox.)
Protected property | LogicalChildren | Gets an enumerator for the logical child elements of the TextBox. (Inherited from TextBox.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxLength | Gets or sets the maximum number of characters that can be manually entered into the text box. (Inherited from TextBox.)
Public property | MaxLines | Gets or sets the maximum number of visible lines. (Inherited from TextBox.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinLines | Gets or sets the minimum number of visible lines. (Inherited from TextBox.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SearchEventTimeDelay | Gets or sets the search event time delay. This is a dependency property.
Public property | SearchMode | Gets or sets the search mode. This is a dependency property.
Public property | SelectedText | Gets or sets the content of the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionBrush | Gets or sets the brush that highlights selected text. (Inherited from TextBoxBase.)
Public property | SelectionLength | Gets or sets a value indicating the number of characters in the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionOpacity | Gets or sets the opacity of the SelectionBrush. (Inherited from TextBoxBase.)
Public property | SelectionStart | Gets or sets a character index for the beginning of the current selection. (Inherited from TextBox.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | SpellCheck | Gets a SpellCheck object that provides access to spelling errors in the text contents of a TextBoxBase or RichTextBox. (Inherited from TextBoxBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Gets or sets the text contents of the text box. (Inherited from TextBox.)
Public property | TextAlignment | Gets or sets the horizontal alignment of the contents of the text box. (Inherited from TextBox.)
Public property | TextDecorations | Gets the text decorations to apply to the text box. (Inherited from TextBox.)
Public property | TextWrapping | Gets or sets how the text box should wrap text. (Inherited from TextBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Typography | Gets the currently effective typography variations for the text contents of the text box. (Inherited from TextBox.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UndoLimit | Gets or sets the number of actions stored in the undo queue. (Inherited from TextBoxBase.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Gets or sets the vertical scroll position. (Inherited from TextBoxBase.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical scroll bar is shown. (Inherited from TextBoxBase.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | ViewportHeight | Gets the vertical size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | ViewportWidth | Gets the horizontal size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

SearchTextBox Class
VisualComponents.UX.Shared Namespace


SearchTextBox.HasText Property

SearchTextBoxHasText Property

Gets a value indicating whether this instance has text. This is a dependency property.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HasText { get; }
public:
property bool HasText {
    bool get ();
}

Property Value

Type: Boolean
true if this instance has text; otherwise, false.
See Also

Reference

SearchTextBox Class
VisualComponents.UX.Shared Namespace


SearchTextBox.IsMouseLeftButtonDown Property

SearchTextBoxIsMouseLeftButtonDown Property

Gets or sets a value indicating whether mouse left button is down.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsMouseLeftButtonDown { get; }
public:
property bool IsMouseLeftButtonDown {
    bool get ();
}

Property Value

Type: Boolean
true if mouse left button is down; otherwise, false.
See Also

Reference

SearchTextBox Class
VisualComponents.UX.Shared Namespace


SearchTextBox.LabelText Property

SearchTextBoxLabelText Property

Gets or sets the label text. This is a dependency property.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string LabelText { get; set; }
public:
property String^ LabelText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
The label text.
See Also

Reference

SearchTextBox Class
VisualComponents.UX.Shared Namespace


SearchTextBox.LabelTextColor Property

SearchTextBoxLabelTextColor Property

Gets or sets the color of the label text. This is a dependency property.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Brush LabelTextColor { get; set; }
public:
property Brush^ LabelTextColor {
    Brush^ get ();
    void set (Brush^ value);
}

Property Value

Type: Brush
The color of the label text.
See Also

Reference

SearchTextBox Class
VisualComponents.UX.Shared Namespace


SearchTextBox.SearchEventTimeDelay Property

SearchTextBoxSearchEventTimeDelay Property

Gets or sets the search event time delay. This is a dependency property.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Duration SearchEventTimeDelay { get; set; }
public:
property Duration SearchEventTimeDelay {
    Duration get ();
    void set (Duration value);
}

Property Value

Type: Duration
The search event time delay.
See Also

Reference

SearchTextBox Class
VisualComponents.UX.Shared Namespace


SearchTextBox.SearchMode Property

SearchTextBoxSearchMode Property

Gets or sets the search mode. This is a dependency property.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SearchMode SearchMode { get; set; }
public:
property SearchMode SearchMode {
    SearchMode get ();
    void set (SearchMode value);
}

Property Value

Type: SearchMode
The search mode.
See Also

Reference

SearchTextBox Class
VisualComponents.UX.Shared Namespace


SearchTextBox Methods

The SearchTextBox type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AppendText | Appends a string to the contents of a text control. (Inherited from TextBoxBase.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginChange | Begins a change block. (Inherited from TextBoxBase.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | Clears all the content from the text box. (Inherited from TextBox.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Copy | Copies the current selection of the text editing control to the Clipboard. (Inherited from TextBoxBase.)
Public method | Cut | Removes the current selection from the text editing control and copies it to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeclareChangeBlock | Creates a change block. (Inherited from TextBoxBase.)
Public method | EndChange | Ends a change block. (Inherited from TextBoxBase.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetCharacterIndexFromLineIndex | Returns the zero-based character index for the first character in the specified line. (Inherited from TextBox.)
Public method | GetCharacterIndexFromPoint | Returns the zero-based index of the character that is closest to the specified point. (Inherited from TextBox.)
Public method | GetFirstVisibleLineIndex | Returns the line index for the first line that is currently visible in the text box. (Inherited from TextBox.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLastVisibleLineIndex | Returns the line index for the last line that is currently visible in the text box. (Inherited from TextBox.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLineIndexFromCharacterIndex | Returns the zero-based line index for the line that contains the specified character index. (Inherited from TextBox.)
Public method | GetLineLength | Returns the number of characters in the specified line. (Inherited from TextBox.)
Public method | GetLineText | Returns the text that is currently displayed on the specified line. (Inherited from TextBox.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetNextSpellingErrorCharacterIndex | Returns the beginning character index for the next spelling error in the contents of the text box. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32) | Returns the rectangle for the leading edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32, Boolean) | Returns the rectangle for the leading or trailing edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetSpellingError | Returns a SpellingError object associated with any spelling error at the specified character index. (Inherited from TextBox.)
Public method | GetSpellingErrorLength | Returns the length of any spelling error that includes the specified character. (Inherited from TextBox.)
Public method | GetSpellingErrorStart | Returns the beginning character index for any spelling error that includes the specified character. (Inherited from TextBox.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls the contents of the control down by one line. (Inherited from TextBoxBase.)
Public method | LineLeft | Scrolls the contents of the control to the left by one line. (Inherited from TextBoxBase.)
Public method | LineRight | Scrolls the contents of the control to the right by one line. (Inherited from TextBoxBase.)
Public method | LineUp | Scrolls the contents of the control upward by one line. (Inherited from TextBoxBase.)
Public method | LockCurrentUndoUnit | Locks the most recent undo unit of the undo stack of the application. This prevents the locked unit from being merged with undo units that are added subsequently. (Inherited from TextBoxBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Sizes the text box to its content. (Inherited from TextBox.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | Is called when a control template is applied. (Overrides TextBoxBaseOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Called whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for the text box. (Inherited from TextBox.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragLeave | Invoked whenever an unhandled DragLeave attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragOver | Invoked whenever an unhandled DragOver attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDrop | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGiveFeedback | Invoked whenever an unhandled GiveFeedback attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked whenever an unhandled GotKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked whenever an unhandled KeyDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Overrides TextBoxBaseOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | Invoked whenever an unhandled KeyUp attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostFocus | Raises the LostFocus event (using the provided arguments). (Inherited from TextBoxBase.)
Protected method | OnLostKeyboardFocus | Invoked whenever an unhandled LostKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked whenever an unhandled MouseDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked whenever an unhandled MouseMove attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked whenever an unhandled MouseUp event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Is called when a MouseWheel event is routed to this class (or to a class that inherits from this class). (Inherited from TextBoxBase.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Called when the KeyDown occurs. (Inherited from TextBoxBase.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Called when one or more of the dependency properties that exist on the element have had their effective values changed. (Overrides TextBoxOnPropertyChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnQueryContinueDrag | Invoked whenever an unhandled QueryContinueDrag attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnQueryCursor | Invoked whenever an unhandled QueryCursor attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Is called when the caret or current selection changes position. (Inherited from TextBoxBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Is called when the control template changes. (Inherited from TextBoxBase.)
Protected method | OnTextChanged | Is called when content in this editing control changes. (Overrides TextBoxBaseOnTextChanged(TextChangedEventArgs).)
Protected method | OnTextInput | Invoked whenever an unhandled TextInput attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | PageDown | Scrolls the contents of the control down by one page. (Inherited from TextBoxBase.)
Public method | PageLeft | Scrolls the contents of the control to the left by one page. (Inherited from TextBoxBase.)
Public method | PageRight | Scrolls the contents of the control to the right by one page. (Inherited from TextBoxBase.)
Public method | PageUp | Scrolls the contents of the control up by one page. (Inherited from TextBoxBase.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | Paste | Pastes the contents of the Clipboard over the current selection in the text editing control. (Inherited from TextBoxBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Redo | Undoes the most recent undo command. In other words, redoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollToEnd | Scrolls the view of the editing control to the end of the content. (Inherited from TextBoxBase.)
Public method | ScrollToHome | Scrolls the view of the editing control to the beginning of the viewport. (Inherited from TextBoxBase.)
Public method | ScrollToHorizontalOffset | Scrolls the contents of the editing control to the specified horizontal offset. (Inherited from TextBoxBase.)
Public method | ScrollToLine | Scrolls the line at the specified line index into view. (Inherited from TextBox.)
Public method | ScrollToVerticalOffset | Scrolls the contents of the editing control to the specified vertical offset. (Inherited from TextBoxBase.)
Public method | Select | Selects a range of text in the text box. (Inherited from TextBox.)
Public method | SelectAll | Selects all the contents of the text editing control. (Inherited from TextBoxBase.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeText | Returns a value that indicates whether the effective value of the Text property should be serialized during serialization of the TextBox object. (Inherited from TextBox.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | Undo | Undoes the most recent undo command. In other words, undoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SearchTextBox Class
VisualComponents.UX.Shared Namespace


SearchTextBox.OnApplyTemplate Method

SearchTextBoxOnApplyTemplate Method

Is called when a control template is applied.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

SearchTextBox Class
VisualComponents.UX.Shared Namespace


SearchTextBox.OnKeyDown Method

SearchTextBoxOnKeyDown Method

Invoked whenever an unhandled KeyDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnKeyDown(
    KeyEventArgs e
)
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.InputKeyEventArgs
Provides data about the event.
See Also

Reference

SearchTextBox Class
VisualComponents.UX.Shared Namespace


SearchTextBox.OnPropertyChanged Method

SearchTextBoxOnPropertyChanged Method

Called when one or more of the dependency properties that exist on the element have had their effective values changed.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
)
protected:
virtual void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
) override

Parameters

e
Type: System.WindowsDependencyPropertyChangedEventArgs
Arguments for the associated event.
See Also

Reference

SearchTextBox Class
VisualComponents.UX.Shared Namespace


SearchTextBox.OnTextChanged Method

SearchTextBoxOnTextChanged Method

Is called when content in this editing control changes.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnTextChanged(
    TextChangedEventArgs e
)
protected:
virtual void OnTextChanged(
    TextChangedEventArgs^ e
) override

Parameters

e
Type: System.Windows.ControlsTextChangedEventArgs
The arguments that are associated with the TextChanged event.
See Also

Reference

SearchTextBox Class
VisualComponents.UX.Shared Namespace


SearchTextBox Events

The SearchTextBox type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | Search | Occurs when search is performed.
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBoxBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextChanged | Occurs when content changes in the text element. (Inherited from TextBoxBase.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

SearchTextBox Class
VisualComponents.UX.Shared Namespace


SearchTextBox.Search Event

SearchTextBoxSearch Event

Occurs when search is performed.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event RoutedEventHandler Search
public:
 event RoutedEventHandler^ Search {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

SearchTextBox Class
VisualComponents.UX.Shared Namespace


SearchTextBox Fields

The SearchTextBox type exposes the following members.

Fields
Name | Description
HasTextProperty | Identifies the HasText dependency property.
IsMouseLeftButtonDownProperty | Identifies the IsMouseLeftButtonDown dependency property.
LabelTextColorProperty | Identifies the LabelTextColor dependency property.
LabelTextProperty | Identifies the LabelText dependency property.
SearchEvent | Identifies the Search routed event.
SearchEventTimeDelayProperty | Identifies the SearchEventTimeDelay dependency property.
SearchModeProperty | Identifies the SearchMode dependency property.
Top
See Also

Reference

SearchTextBox Class
VisualComponents.UX.Shared Namespace


SearchTextBox.HasTextProperty Field

SearchTextBoxHasTextProperty Field

Identifies the HasText dependency property.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty HasTextProperty
public:
static initonly DependencyProperty^ HasTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

SearchTextBox Class
VisualComponents.UX.Shared Namespace


SearchTextBox.IsMouseLeftButtonDownProperty Field

SearchTextBoxIsMouseLeftButtonDownProperty Field

Identifies the IsMouseLeftButtonDown dependency property.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsMouseLeftButtonDownProperty
public:
static initonly DependencyProperty^ IsMouseLeftButtonDownProperty

Field Value

Type: DependencyProperty
See Also

Reference

SearchTextBox Class
VisualComponents.UX.Shared Namespace


SearchTextBox.LabelTextColorProperty Field

SearchTextBoxLabelTextColorProperty Field

Identifies the LabelTextColor dependency property.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty LabelTextColorProperty
public:
static initonly DependencyProperty^ LabelTextColorProperty

Field Value

Type: DependencyProperty
See Also

Reference

SearchTextBox Class
VisualComponents.UX.Shared Namespace


SearchTextBox.LabelTextProperty Field

SearchTextBoxLabelTextProperty Field

Identifies the LabelText dependency property.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty LabelTextProperty
public:
static initonly DependencyProperty^ LabelTextProperty

Field Value

Type: DependencyProperty
See Also

Reference

SearchTextBox Class
VisualComponents.UX.Shared Namespace


SearchTextBox.SearchEvent Field

SearchTextBoxSearchEvent Field

Identifies the Search routed event.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly RoutedEvent SearchEvent
public:
static initonly RoutedEvent^ SearchEvent

Field Value

Type: RoutedEvent
See Also

Reference

SearchTextBox Class
VisualComponents.UX.Shared Namespace


SearchTextBox.SearchEventTimeDelayProperty Field

SearchTextBoxSearchEventTimeDelayProperty Field

Identifies the SearchEventTimeDelay dependency property.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty SearchEventTimeDelayProperty
public:
static initonly DependencyProperty^ SearchEventTimeDelayProperty

Field Value

Type: DependencyProperty
See Also

Reference

SearchTextBox Class
VisualComponents.UX.Shared Namespace


SearchTextBox.SearchModeProperty Field

SearchTextBoxSearchModeProperty Field

Identifies the SearchMode dependency property.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty SearchModeProperty
public:
static initonly DependencyProperty^ SearchModeProperty

Field Value

Type: DependencyProperty
See Also

Reference

SearchTextBox Class
VisualComponents.UX.Shared Namespace


SectionFieldItem Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedSectionFieldItem

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SectionFieldItem : INotifyPropertyChanged
public ref class SectionFieldItem : INotifyPropertyChanged

The SectionFieldItem type exposes the following members.

Constructors
 | Name | Description
Public method | SectionFieldItem | Initializes a new instance of the SectionFieldItem class
Top
Properties
 | Name | Description
Protected property | Application |
Public property | CanModify |
Public property | CanMoveDown |
Public property | CanMoveUp |
Public property | FieldTypes |
Public property | IsExpanded |
Public property | IsSimulationRunning |
Public property | Layout |
Public property | Name |
Public property | NameGUI |
Top
Methods
 | Name | Description
Public method | DeleteField |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveDown |
Public method | MoveUp |
Public method | RaisePropertyChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SectionFieldItem Constructor

Initializes a new instance of the SectionFieldItem class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SectionFieldItem(
    ISimInterfaceField field,
    ISectionEditorNotifier notifier
)
public:
SectionFieldItem(
    ISimInterfaceField^ field,
    ISectionEditorNotifier^ notifier
)

Parameters

field
Type: VisualComponents.Create3DISimInterfaceField
notifier
Type: VisualComponents.UX.SharedISectionEditorNotifier
See Also

Reference

SectionFieldItem Class
VisualComponents.UX.Shared Namespace


SectionFieldItem Properties

The SectionFieldItem type exposes the following members.

Properties
 | Name | Description
Protected property | Application |
Public property | CanModify |
Public property | CanMoveDown |
Public property | CanMoveUp |
Public property | FieldTypes |
Public property | IsExpanded |
Public property | IsSimulationRunning |
Public property | Layout |
Public property | Name |
Public property | NameGUI |
Top
See Also

Reference

SectionFieldItem Class
VisualComponents.UX.Shared Namespace


SectionFieldItem.Application Property

SectionFieldItemApplication Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected IApplication Application { get; }
protected:
property IApplication^ Application {
    IApplication^ get ();
}

Property Value

Type: IApplication
See Also

Reference

SectionFieldItem Class
VisualComponents.UX.Shared Namespace


SectionFieldItem.CanModify Property

SectionFieldItemCanModify Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanModify { get; }
public:
property bool CanModify {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

SectionFieldItem Class
VisualComponents.UX.Shared Namespace


SectionFieldItem.CanMoveDown Property

SectionFieldItemCanMoveDown Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanMoveDown { get; }
public:
property bool CanMoveDown {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

SectionFieldItem Class
VisualComponents.UX.Shared Namespace


SectionFieldItem.CanMoveUp Property

SectionFieldItemCanMoveUp Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanMoveUp { get; }
public:
property bool CanMoveUp {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

SectionFieldItem Class
VisualComponents.UX.Shared Namespace


SectionFieldItem.FieldTypes Property

SectionFieldItemFieldTypes Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<string> FieldTypes { get; }
public:
property List<String^>^ FieldTypes {
    List<String^>^ get ();
}

Property Value

Type: ListString
See Also

Reference

SectionFieldItem Class
VisualComponents.UX.Shared Namespace


SectionFieldItem.IsExpanded Property

SectionFieldItemIsExpanded Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsExpanded { get; set; }
public:
property bool IsExpanded {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SectionFieldItem Class
VisualComponents.UX.Shared Namespace


SectionFieldItem.IsSimulationRunning Property

SectionFieldItemIsSimulationRunning Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsSimulationRunning { get; protected set; }
public:
property bool IsSimulationRunning {
    bool get ();
    protected: void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SectionFieldItem Class
VisualComponents.UX.Shared Namespace


SectionFieldItem.Layout Property

SectionFieldItemLayout Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PropertyLayout Layout { get; }
public:
property PropertyLayout^ Layout {
    PropertyLayout^ get ();
}

Property Value

Type: PropertyLayout
See Also

Reference

SectionFieldItem Class
VisualComponents.UX.Shared Namespace


SectionFieldItem.Name Property

SectionFieldItemName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; set; }
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SectionFieldItem Class
VisualComponents.UX.Shared Namespace


SectionFieldItem.NameGUI Property

SectionFieldItemNameGUI Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string NameGUI { get; }
public:
property String^ NameGUI {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

SectionFieldItem Class
VisualComponents.UX.Shared Namespace


SectionFieldItem Methods

The SectionFieldItem type exposes the following members.

Methods
 | Name | Description
Public method | DeleteField |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveDown |
Public method | MoveUp |
Public method | RaisePropertyChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SectionFieldItem Class
VisualComponents.UX.Shared Namespace


SectionFieldItem.DeleteField Method

SectionFieldItemDeleteField Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void DeleteField()
public:
void DeleteField()
See Also

Reference

SectionFieldItem Class
VisualComponents.UX.Shared Namespace


SectionFieldItem.MoveDown Method

SectionFieldItemMoveDown Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MoveDown()
public:
void MoveDown()
See Also

Reference

SectionFieldItem Class
VisualComponents.UX.Shared Namespace


SectionFieldItem.MoveUp Method

SectionFieldItemMoveUp Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MoveUp()
public:
void MoveUp()
See Also

Reference

SectionFieldItem Class
VisualComponents.UX.Shared Namespace


SectionFieldItem.RaisePropertyChanged Method

SectionFieldItemRaisePropertyChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RaisePropertyChanged(
    string PropertyName
)
public:
void RaisePropertyChanged(
    String^ PropertyName
)

Parameters

PropertyName
Type: SystemString
See Also

Reference

SectionFieldItem Class
VisualComponents.UX.Shared Namespace


SectionFieldItem Events

The SectionFieldItem type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

SectionFieldItem Class
VisualComponents.UX.Shared Namespace


SectionFieldItem.PropertyChanged Event

SectionFieldItemPropertyChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event PropertyChangedEventHandler PropertyChanged
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

SectionFieldItem Class
VisualComponents.UX.Shared Namespace


SelectAction Class

Action that waits for pick in 3D world.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedSelectAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class SelectAction : IResult,
    IHandle<InternalEndInteractionMessage>, IHandle
public ref class SelectAction sealed : IResult,
    IHandle<InternalEndInteractionMessage^>, IHandle

The SelectAction type exposes the following members.

Constructors
 | Name | Description
Public method | SelectAction | Initializes a new instance of the SelectAction class
Top
Properties
 | Name | Description
Public property | Item |
Public property | Items |
Public property | MultiSelect |
Top
Methods
 | Name | Description
Public method | CanExecute |
Public method | ClearAll |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute(ActionExecutionContext) |
 | Execute(Boolean) |
 | Execute(IVisualObject, Boolean) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetSelectableItemsInCurrentContext |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle |
Public method | InvertSelection |
Public method | SelectAll |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Completed |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SelectAction Constructor

Initializes a new instance of the SelectAction class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SelectAction()
public:
SelectAction()
See Also

Reference

SelectAction Class
VisualComponents.UX.Shared Namespace


SelectAction Properties

The SelectAction type exposes the following members.

Properties
 | Name | Description
Public property | Item |
Public property | Items |
Public property | MultiSelect |
Top
See Also

Reference

SelectAction Class
VisualComponents.UX.Shared Namespace


SelectAction.Item Property

SelectActionItem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Item { get; set; }
public:
property Object^ Item {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

SelectAction Class
VisualComponents.UX.Shared Namespace


SelectAction.Items Property

SelectActionItems Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object[] Items { get; set; }
public:
property array<Object^>^ Items {
    array<Object^>^ get ();
    void set (array<Object^>^ value);
}

Property Value

Type: Object
See Also

Reference

SelectAction Class
VisualComponents.UX.Shared Namespace


SelectAction.MultiSelect Property

SelectActionMultiSelect Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool MultiSelect { get; set; }
public:
property bool MultiSelect {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SelectAction Class
VisualComponents.UX.Shared Namespace


SelectAction Methods

The SelectAction type exposes the following members.

Methods
 | Name | Description
Public method | CanExecute |
Public method | ClearAll |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute(ActionExecutionContext) |
 | Execute(Boolean) |
 | Execute(IVisualObject, Boolean) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetSelectableItemsInCurrentContext |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle |
Public method | InvertSelection |
Public method | SelectAll |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SelectAction Class
VisualComponents.UX.Shared Namespace


SelectAction.CanExecute Method

SelectActionCanExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CanExecute()
public:
bool CanExecute()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SelectAction.CanExecute"]

See Also

Reference

SelectAction Class
VisualComponents.UX.Shared Namespace


SelectAction.ClearAll Method

SelectActionClearAll Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ClearAll()
public:
void ClearAll()
See Also

Reference

SelectAction Class
VisualComponents.UX.Shared Namespace


SelectAction.Execute Method

SelectActionExecute Method

Overload List
 | Name | Description
Public method | Execute(ActionExecutionContext) |
 | Execute(Boolean) |
 | Execute(IVisualObject, Boolean) |
Top
See Also

Reference

SelectAction Class
VisualComponents.UX.Shared Namespace


SelectAction.Execute Method (ActionExecutionContext)

SelectActionExecute Method (ActionExecutionContext)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    ActionExecutionContext context
)
public:
virtual void Execute(
    ActionExecutionContext^ context
) sealed

Parameters

context
Type: ActionExecutionContext

Implements

IResult.Execute(ActionExecutionContext)
See Also

Reference

SelectAction Class
Execute Overload
VisualComponents.UX.Shared Namespace


SelectAction.Execute Method (Boolean)

SelectActionExecute Method (Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IEnumerable<IResult> Execute(
    bool multiSelect
)
public:
static IEnumerable<IResult^>^ Execute(
    bool multiSelect
)

Parameters

multiSelect
Type: SystemBoolean

Return Value

Type: IEnumerableIResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SelectAction.Execute(System.Boolean)"]

See Also

Reference

SelectAction Class
Execute Overload
VisualComponents.UX.Shared Namespace


SelectAction.Execute Method (IVisualObject, Boolean)

SelectActionExecute Method (IVisualObject, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IEnumerable<IResult> Execute(
    IVisualObject item,
    bool multiSelect
)
public:
static IEnumerable<IResult^>^ Execute(
    IVisualObject^ item,
    bool multiSelect
)

Parameters

item
Type: VisualComponents.Create3DIVisualObject
multiSelect
Type: SystemBoolean

Return Value

Type: IEnumerableIResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SelectAction.Execute(VisualComponents.Create3D.IVisualObject,System.Boolean)"]

See Also

Reference

SelectAction Class
Execute Overload
VisualComponents.UX.Shared Namespace


SelectAction.GetSelectableItemsInCurrentContext Method

SelectActionGetSelectableItemsInCurrentContext Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static List<IVisualObject> GetSelectableItemsInCurrentContext()
public:
static List<IVisualObject^>^ GetSelectableItemsInCurrentContext()

Return Value

Type: ListIVisualObject

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SelectAction.GetSelectableItemsInCurrentContext"]

See Also

Reference

SelectAction Class
VisualComponents.UX.Shared Namespace


SelectAction.Handle Method

SelectActionHandle Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    InternalEndInteractionMessage message
)
public:
virtual void Handle(
    InternalEndInteractionMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedInternalEndInteractionMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

SelectAction Class
VisualComponents.UX.Shared Namespace


SelectAction.InvertSelection Method

SelectActionInvertSelection Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InvertSelection()
public:
void InvertSelection()
See Also

Reference

SelectAction Class
VisualComponents.UX.Shared Namespace


SelectAction.SelectAll Method

SelectActionSelectAll Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SelectAll()
public:
void SelectAll()
See Also

Reference

SelectAction Class
VisualComponents.UX.Shared Namespace


SelectAction Events

The SelectAction type exposes the following members.

Events
 | Name | Description
Public event | Completed |
Top
See Also

Reference

SelectAction Class
VisualComponents.UX.Shared Namespace


SelectAction.Completed Event

SelectActionCompleted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ResultCompletionEventArgs> Completed
public:
virtual  event EventHandler<ResultCompletionEventArgs^>^ Completed {
    void add (EventHandler<ResultCompletionEventArgs^>^ value);
    void remove (EventHandler<ResultCompletionEventArgs^>^ value);
}

Value

Type: SystemEventHandlerResultCompletionEventArgs

Implements

IResult.Completed
See Also

Reference

SelectAction Class
VisualComponents.UX.Shared Namespace


SelectAllMode Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum SelectAllMode
public enum class SelectAllMode
Members
Member name | Value | Description
OnFirstFocusThenLeaveOff | 0 | On first focus, it selects all then leave off textbox and doesn't check again
OnFirstFocusThenNever | 1 | On first focus, it selects all then never selects
OnEveryFocus | 2 | Selects all on every focus
Never | 4 | Never selects text (WPF's default attitude)
See Also

Reference

VisualComponents.UX.Shared Namespace


SelectedNodesChangedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.UX.SharedSelectedNodesChangedEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SelectedNodesChangedEventArgs : EventArgs
public ref class SelectedNodesChangedEventArgs : public EventArgs

The SelectedNodesChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SelectedNodesChangedEventArgs | Initializes a new instance of the SelectedNodesChangedEventArgs class
Top
Properties
 | Name | Description
Public property | NewSelectedNodes |
Public property | OldSelectedNodes |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SelectedNodesChangedEventArgs Constructor

Initializes a new instance of the SelectedNodesChangedEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SelectedNodesChangedEventArgs(
    List<TreeNodeEx> oldSelectedNodes,
    List<TreeNodeEx> newSelectedNodes
)
public:
SelectedNodesChangedEventArgs(
    List<TreeNodeEx^>^ oldSelectedNodes,
    List<TreeNodeEx^>^ newSelectedNodes
)

Parameters

oldSelectedNodes
Type: System.Collections.GenericListTreeNodeEx
newSelectedNodes
Type: System.Collections.GenericListTreeNodeEx
See Also

Reference

SelectedNodesChangedEventArgs Class
VisualComponents.UX.Shared Namespace


SelectedNodesChangedEventArgs Properties

The SelectedNodesChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewSelectedNodes |
Public property | OldSelectedNodes |
Top
See Also

Reference

SelectedNodesChangedEventArgs Class
VisualComponents.UX.Shared Namespace


SelectedNodesChangedEventArgs.NewSelectedNodes Property

SelectedNodesChangedEventArgsNewSelectedNodes Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<TreeNodeEx> NewSelectedNodes { get; set; }
public:
property List<TreeNodeEx^>^ NewSelectedNodes {
    List<TreeNodeEx^>^ get ();
    void set (List<TreeNodeEx^>^ value);
}

Property Value

Type: ListTreeNodeEx
See Also

Reference

SelectedNodesChangedEventArgs Class
VisualComponents.UX.Shared Namespace


SelectedNodesChangedEventArgs.OldSelectedNodes Property

SelectedNodesChangedEventArgsOldSelectedNodes Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<TreeNodeEx> OldSelectedNodes { get; set; }
public:
property List<TreeNodeEx^>^ OldSelectedNodes {
    List<TreeNodeEx^>^ get ();
    void set (List<TreeNodeEx^>^ value);
}

Property Value

Type: ListTreeNodeEx
See Also

Reference

SelectedNodesChangedEventArgs Class
VisualComponents.UX.Shared Namespace


SelectedNodesChangedEventArgs Methods

The SelectedNodesChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SelectedNodesChangedEventArgs Class
VisualComponents.UX.Shared Namespace


SelectionMode Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum SelectionMode
public enum class SelectionMode
Members
Member name | Value | Description
All | 0 |
Selected | 1 |
None | 2 |
See Also

Reference

VisualComponents.UX.Shared Namespace


Settings Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedSettings

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class Settings : IRobotTcpSettings
public ref class Settings : IRobotTcpSettings

The Settings type exposes the following members.

Constructors
 | Name | Description
Public method | Settings | Initializes a new instance of the Settings class
Top
Properties
 | Name | Description
Public property | IsConfigurationChangeAllowed |
Public property | IsJointTurnChangeAllowed |
Public property | IsOutsideJointLimitsAllowed |
Public property | IsUnreachableAllowed |
Public property | OriginalConfiguration |
Public property | OriginalJointTurns |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetUpJointTurns |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


Settings Constructor

Initializes a new instance of the Settings class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Settings()
public:
Settings()
See Also

Reference

Settings Class
VisualComponents.UX.Shared Namespace


Settings Properties

The Settings type exposes the following members.

Properties
 | Name | Description
Public property | IsConfigurationChangeAllowed |
Public property | IsJointTurnChangeAllowed |
Public property | IsOutsideJointLimitsAllowed |
Public property | IsUnreachableAllowed |
Public property | OriginalConfiguration |
Public property | OriginalJointTurns |
Top
See Also

Reference

Settings Class
VisualComponents.UX.Shared Namespace


Settings.IsConfigurationChangeAllowed Property

SettingsIsConfigurationChangeAllowed Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<bool> IsConfigurationChangeAllowed { get; set; }
public:
virtual property Nullable<bool> IsConfigurationChangeAllowed {
    Nullable<bool> get () sealed;
    void set (Nullable<bool> value) sealed;
}

Property Value

Type: NullableBoolean

Implements

IRobotTcpSettingsIsConfigurationChangeAllowed
See Also

Reference

Settings Class
VisualComponents.UX.Shared Namespace


Settings.IsJointTurnChangeAllowed Property

SettingsIsJointTurnChangeAllowed Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsJointTurnChangeAllowed { get; set; }
public:
virtual property bool IsJointTurnChangeAllowed {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IRobotTcpSettingsIsJointTurnChangeAllowed
See Also

Reference

Settings Class
VisualComponents.UX.Shared Namespace


Settings.IsOutsideJointLimitsAllowed Property

SettingsIsOutsideJointLimitsAllowed Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsOutsideJointLimitsAllowed { get; set; }
public:
virtual property bool IsOutsideJointLimitsAllowed {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IRobotTcpSettingsIsOutsideJointLimitsAllowed
See Also

Reference

Settings Class
VisualComponents.UX.Shared Namespace


Settings.IsUnreachableAllowed Property

SettingsIsUnreachableAllowed Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsUnreachableAllowed { get; set; }
public:
virtual property bool IsUnreachableAllowed {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IRobotTcpSettingsIsUnreachableAllowed
See Also

Reference

Settings Class
VisualComponents.UX.Shared Namespace


Settings.OriginalConfiguration Property

SettingsOriginalConfiguration Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<int> OriginalConfiguration { get; set; }
public:
virtual property Nullable<int> OriginalConfiguration {
    Nullable<int> get () sealed;
    void set (Nullable<int> value) sealed;
}

Property Value

Type: NullableInt32

Implements

IRobotTcpSettingsOriginalConfiguration
See Also

Reference

Settings Class
VisualComponents.UX.Shared Namespace


Settings.OriginalJointTurns Property

SettingsOriginalJointTurns Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList<int> OriginalJointTurns { get; set; }
public:
virtual property IList<int>^ OriginalJointTurns {
    IList<int>^ get () sealed;
    void set (IList<int>^ value) sealed;
}

Property Value

Type: IListInt32

Implements

IRobotTcpSettingsOriginalJointTurns
See Also

Reference

Settings Class
VisualComponents.UX.Shared Namespace


Settings Methods

The Settings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetUpJointTurns |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

Settings Class
VisualComponents.UX.Shared Namespace


Settings.SetUpJointTurns Method

SettingsSetUpJointTurns Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetUpJointTurns(
    IRobotController controller
)
public:
void SetUpJointTurns(
    IRobotController^ controller
)

Parameters

controller
Type: VisualComponents.Create3DIRobotController
See Also

Reference

Settings Class
VisualComponents.UX.Shared Namespace


SetValuesValidationRule Class

Inheritance Hierarchy
SystemObject
System.Windows.ControlsValidationRule
VisualComponents.UX.SharedSetValuesValidationRule

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SetValuesValidationRule : ValidationRule
public ref class SetValuesValidationRule : public ValidationRule

The SetValuesValidationRule type exposes the following members.

Constructors
 | Name | Description
Public method | SetValuesValidationRule | Initializes a new instance of the SetValuesValidationRule class
Top
Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
Methods
 | Name | Description
 | ContainsLineSeparator |
 | ContainsRangeSeparator |
 | ContainsSetSeparator |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOfAll |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveWhiteSpace |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
Fields
Name | Description
LineFeed |
LINESEPARATOR |
RANGESEPARATOR |
SETSEPARATOR |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SetValuesValidationRule Constructor

Initializes a new instance of the SetValuesValidationRule class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SetValuesValidationRule()
public:
SetValuesValidationRule()
See Also

Reference

SetValuesValidationRule Class
VisualComponents.UX.Shared Namespace


SetValuesValidationRule Properties

The SetValuesValidationRule type exposes the following members.

Properties
 | Name | Description
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
See Also

Reference

SetValuesValidationRule Class
VisualComponents.UX.Shared Namespace


SetValuesValidationRule Methods

The SetValuesValidationRule type exposes the following members.

Methods
 | Name | Description
 | ContainsLineSeparator |
 | ContainsRangeSeparator |
 | ContainsSetSeparator |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOfAll |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveWhiteSpace |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SetValuesValidationRule Class
VisualComponents.UX.Shared Namespace


SetValuesValidationRule.ContainsLineSeparator Method

SetValuesValidationRuleContainsLineSeparator Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool ContainsLineSeparator(
    string valueStr
)
public:
static bool ContainsLineSeparator(
    String^ valueStr
)

Parameters

valueStr
Type: SystemString

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SetValuesValidationRule.ContainsLineSeparator(System.String)"]

See Also

Reference

SetValuesValidationRule Class
VisualComponents.UX.Shared Namespace


SetValuesValidationRule.ContainsRangeSeparator Method

SetValuesValidationRuleContainsRangeSeparator Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool ContainsRangeSeparator(
    string valueStr
)
public:
static bool ContainsRangeSeparator(
    String^ valueStr
)

Parameters

valueStr
Type: SystemString

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SetValuesValidationRule.ContainsRangeSeparator(System.String)"]

See Also

Reference

SetValuesValidationRule Class
VisualComponents.UX.Shared Namespace


SetValuesValidationRule.ContainsSetSeparator Method

SetValuesValidationRuleContainsSetSeparator Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool ContainsSetSeparator(
    string valueStr
)
public:
static bool ContainsSetSeparator(
    String^ valueStr
)

Parameters

valueStr
Type: SystemString

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SetValuesValidationRule.ContainsSetSeparator(System.String)"]

See Also

Reference

SetValuesValidationRule Class
VisualComponents.UX.Shared Namespace


SetValuesValidationRule.IndexOfAll Method

SetValuesValidationRuleIndexOfAll Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IEnumerable<int> IndexOfAll(
    string sourceString,
    string matchString
)
public:
static IEnumerable<int>^ IndexOfAll(
    String^ sourceString,
    String^ matchString
)

Parameters

sourceString
Type: SystemString
matchString
Type: SystemString

Return Value

Type: IEnumerableInt32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SetValuesValidationRule.IndexOfAll(System.String,System.String)"]

See Also

Reference

SetValuesValidationRule Class
VisualComponents.UX.Shared Namespace


SetValuesValidationRule.RemoveWhiteSpace Method

SetValuesValidationRuleRemoveWhiteSpace Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string RemoveWhiteSpace(
    string valueStr
)
public:
static String^ RemoveWhiteSpace(
    String^ valueStr
)

Parameters

valueStr
Type: SystemString

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SetValuesValidationRule.RemoveWhiteSpace(System.String)"]

See Also

Reference

SetValuesValidationRule Class
VisualComponents.UX.Shared Namespace


SetValuesValidationRule.Validate Method

SetValuesValidationRuleValidate Method

Overload List
 | Name | Description
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
See Also

Reference

SetValuesValidationRule Class
VisualComponents.UX.Shared Namespace


SetValuesValidationRule.Validate Method (Object, CultureInfo)

SetValuesValidationRuleValidate Method (Object, CultureInfo)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override ValidationResult Validate(
    Object value,
    CultureInfo cultureInfo
)
public:
virtual ValidationResult^ Validate(
    Object^ value,
    CultureInfo^ cultureInfo
) override

Parameters

value
Type: SystemObject
cultureInfo
Type: System.GlobalizationCultureInfo

Return Value

Type: ValidationResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SetValuesValidationRule.Validate(System.Object,System.Globalization.CultureInfo)"]

See Also

Reference

SetValuesValidationRule Class
Validate Overload
VisualComponents.UX.Shared Namespace


SetValuesValidationRule Fields

The SetValuesValidationRule type exposes the following members.

Fields
Name | Description
LineFeed |
LINESEPARATOR |
RANGESEPARATOR |
SETSEPARATOR |
Top
See Also

Reference

SetValuesValidationRule Class
VisualComponents.UX.Shared Namespace


SetValuesValidationRule.LineFeed Field

SetValuesValidationRuleLineFeed Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string LineFeed
public:
static String^ LineFeed

Field Value

Type: String
See Also

Reference

SetValuesValidationRule Class
VisualComponents.UX.Shared Namespace


SetValuesValidationRule.LINESEPARATOR Field

SetValuesValidationRuleLINESEPARATOR Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string LINESEPARATOR
public:
static String^ LINESEPARATOR

Field Value

Type: String
See Also

Reference

SetValuesValidationRule Class
VisualComponents.UX.Shared Namespace


SetValuesValidationRule.RANGESEPARATOR Field

SetValuesValidationRuleRANGESEPARATOR Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string RANGESEPARATOR
public:
static String^ RANGESEPARATOR

Field Value

Type: String
See Also

Reference

SetValuesValidationRule Class
VisualComponents.UX.Shared Namespace


SetValuesValidationRule.SETSEPARATOR Field

SetValuesValidationRuleSETSEPARATOR Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string SETSEPARATOR
public:
static String^ SETSEPARATOR

Field Value

Type: String
See Also

Reference

SetValuesValidationRule Class
VisualComponents.UX.Shared Namespace


ShadingMode Structure

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public struct ShadingMode
public value class ShadingMode

The ShadingMode type exposes the following members.

Properties
 | Name | Description
Public property | Content |
Public property | IconPath |
Public property | Id |
Public property | IsIconSourceFromFile |
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ShadingMode Properties

The ShadingMode type exposes the following members.

Properties
 | Name | Description
Public property | Content |
Public property | IconPath |
Public property | Id |
Public property | IsIconSourceFromFile |
Top
See Also

Reference

ShadingMode Structure
VisualComponents.UX.Shared Namespace


ShadingMode.Content Property

ShadingModeContent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Content { get; set; }
public:
property String^ Content {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ShadingMode Structure
VisualComponents.UX.Shared Namespace


ShadingMode.IconPath Property

ShadingModeIconPath Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string IconPath { get; set; }
public:
property String^ IconPath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ShadingMode Structure
VisualComponents.UX.Shared Namespace


ShadingMode.Id Property

ShadingModeId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Id { get; set; }
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ShadingMode Structure
VisualComponents.UX.Shared Namespace


ShadingMode.IsIconSourceFromFile Property

ShadingModeIsIconSourceFromFile Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsIconSourceFromFile { get; set; }
public:
property bool IsIconSourceFromFile {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ShadingMode Structure
VisualComponents.UX.Shared Namespace


ShadingMode Methods

The ShadingMode type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ShadingMode Structure
VisualComponents.UX.Shared Namespace


ShapeMaipulatorType Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ShapeMaipulatorType
public enum class ShapeMaipulatorType
Members
Member name | Value | Description
Plane | 0 |
Sphere | 1 |
Cylinder | 2 |
See Also

Reference

VisualComponents.UX.Shared Namespace


ShiftPanel Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsPanel
VisualComponents.UX.SharedShiftPanel

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ShiftPanel : Panel
public ref class ShiftPanel : public Panel

The ShiftPanel type exposes the following members.

Constructors
 | Name | Description
Public method | ShiftPanel | Initializes a new instance of the ShiftPanel class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContentAlignment |
Public property | ContentScaling |
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | HasLogicalOrientationPublic | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | LogicalOrientationPublic | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation |
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override for the FrameworkElement's ArrangeCore method (Overrides FrameworkElementArrangeOverride(Size).)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override for the FrameworkElement's MeasureCore method (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
 | Name | Description
Protected field | CellSize | Uniform size of the panel's cell
Protected field | Columns | Number of columns in the panel
Protected field | contentAlignment | Panel's content alignment
Protected field | contentScaling | Panel's content scaling
Protected field | orientation | Panel's orientation
Protected field | Rows | Number of rows in the panel
Protected field | Size | Size of the panel
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ShiftPanel Constructor

Initializes a new instance of the ShiftPanel class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ShiftPanel()
public:
ShiftPanel()
See Also

Reference

ShiftPanel Class
VisualComponents.UX.Shared Namespace


ShiftPanel Properties

The ShiftPanel type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContentAlignment |
Public property | ContentScaling |
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | HasLogicalOrientationPublic | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | LogicalOrientationPublic | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation |
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ShiftPanel Class
VisualComponents.UX.Shared Namespace


ShiftPanel.ContentAlignment Property

ShiftPanelContentAlignment Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ShiftPanelAlignment ContentAlignment { get; set; }
public:
property ShiftPanelAlignment ContentAlignment {
    ShiftPanelAlignment get ();
    void set (ShiftPanelAlignment value);
}

Property Value

Type: ShiftPanelAlignment
See Also

Reference

ShiftPanel Class
VisualComponents.UX.Shared Namespace


ShiftPanel.ContentScaling Property

ShiftPanelContentScaling Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ShiftPanelScaling ContentScaling { get; set; }
public:
property ShiftPanelScaling ContentScaling {
    ShiftPanelScaling get ();
    void set (ShiftPanelScaling value);
}

Property Value

Type: ShiftPanelScaling
See Also

Reference

ShiftPanel Class
VisualComponents.UX.Shared Namespace


ShiftPanel.Orientation Property

ShiftPanelOrientation Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Orientation Orientation { get; set; }
public:
property Orientation Orientation {
    Orientation get ();
    void set (Orientation value);
}

Property Value

Type: Orientation
See Also

Reference

ShiftPanel Class
VisualComponents.UX.Shared Namespace


ShiftPanel Methods

The ShiftPanel type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override for the FrameworkElement's ArrangeCore method (Overrides FrameworkElementArrangeOverride(Size).)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override for the FrameworkElement's MeasureCore method (Overrides FrameworkElementMeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Invoked when the VisualCollection of a visual object is modified. (Inherited from Panel.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ShiftPanel Class
VisualComponents.UX.Shared Namespace


ShiftPanel.ArrangeOverride Method

ShiftPanelArrangeOverride Method

Override for the FrameworkElement's ArrangeCore method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Size ArrangeOverride(
    Size size
)
protected:
virtual Size ArrangeOverride(
    Size size
) override

Parameters

size
Type: System.WindowsSize
The final area within the parent that this element should use to arrange itself and its children

Return Value

Type: Size

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ShiftPanel.ArrangeOverride(System.Windows.Size)"]

See Also

Reference

ShiftPanel Class
VisualComponents.UX.Shared Namespace


ShiftPanel.MeasureOverride Method

ShiftPanelMeasureOverride Method

Override for the FrameworkElement's MeasureCore method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Size MeasureOverride(
    Size size
)
protected:
virtual Size MeasureOverride(
    Size size
) override

Parameters

size
Type: System.WindowsSize
The available size that this element can give to child elements

Return Value

Type: Size

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ShiftPanel.MeasureOverride(System.Windows.Size)"]

See Also

Reference

ShiftPanel Class
VisualComponents.UX.Shared Namespace


ShiftPanel Events

The ShiftPanel type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ShiftPanel Class
VisualComponents.UX.Shared Namespace


ShiftPanel Fields

The ShiftPanel type exposes the following members.

Fields
 | Name | Description
Protected field | CellSize | Uniform size of the panel's cell
Protected field | Columns | Number of columns in the panel
Protected field | contentAlignment | Panel's content alignment
Protected field | contentScaling | Panel's content scaling
Protected field | orientation | Panel's orientation
Protected field | Rows | Number of rows in the panel
Protected field | Size | Size of the panel
Top
See Also

Reference

ShiftPanel Class
VisualComponents.UX.Shared Namespace


ShiftPanel.CellSize Field

ShiftPanelCellSize Field

Uniform size of the panel's cell

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected Size CellSize
protected:
Size CellSize

Field Value

Type: Size
See Also

Reference

ShiftPanel Class
VisualComponents.UX.Shared Namespace


ShiftPanel.Columns Field

ShiftPanelColumns Field

Number of columns in the panel

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected int Columns
protected:
int Columns

Field Value

Type: Int32
See Also

Reference

ShiftPanel Class
VisualComponents.UX.Shared Namespace


ShiftPanel.contentAlignment Field

ShiftPanelcontentAlignment Field

Panel's content alignment

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected ShiftPanelAlignment contentAlignment
protected:
ShiftPanelAlignment contentAlignment

Field Value

Type: ShiftPanelAlignment
See Also

Reference

ShiftPanel Class
VisualComponents.UX.Shared Namespace


ShiftPanel.contentScaling Field

ShiftPanelcontentScaling Field

Panel's content scaling

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected ShiftPanelScaling contentScaling
protected:
ShiftPanelScaling contentScaling

Field Value

Type: ShiftPanelScaling
See Also

Reference

ShiftPanel Class
VisualComponents.UX.Shared Namespace


ShiftPanel.orientation Field

ShiftPanelorientation Field

Panel's orientation

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected Orientation orientation
protected:
Orientation orientation

Field Value

Type: Orientation
See Also

Reference

ShiftPanel Class
VisualComponents.UX.Shared Namespace


ShiftPanel.Rows Field

ShiftPanelRows Field

Number of rows in the panel

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected int Rows
protected:
int Rows

Field Value

Type: Int32
See Also

Reference

ShiftPanel Class
VisualComponents.UX.Shared Namespace


ShiftPanel.Size Field

ShiftPanelSize Field

Size of the panel

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected Size Size
protected:
Size Size

Field Value

Type: Size
See Also

Reference

ShiftPanel Class
VisualComponents.UX.Shared Namespace


ShiftPanel.Alignment Enumeration

ShiftPanelAlignment Enumeration

Describes content alignment options

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum Alignment
public enum class Alignment
Members
Member name | Value | Description
Center | 0 |
TopLeft | 1 |
BottomRight | 2 |
Stretch | 3 |
See Also

Reference

VisualComponents.UX.Shared Namespace


ShiftPanel.Scaling Enumeration

ShiftPanelScaling Enumeration

Describes content scaling options

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum Scaling
public enum class Scaling
Members
Member name | Value | Description
Justify | 0 |
Constrain | 1 |
See Also

Reference

VisualComponents.UX.Shared Namespace


ShortcutKeyManager Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedShortcutKeyManager

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ShortcutKeyManager
public ref class ShortcutKeyManager sealed

The ShortcutKeyManager type exposes the following members.

Properties
 | Name | Description
Public property | AttachedOnlyShortcutKeys |
Public property | AttachedShortCutKeys |
Public property | BindedShortCutKeys | Represents shortcut keys that are set in ActionItem AttachTo property and binded to UI control.
 | CommandRegistry |
Public property | CustomShortCutKeys |
Public property | DefaultShortCutKeys |
 | Instance |
Public property | RegisteredShortCutKeys |
Top
Methods
 | Name | Description
Public method | ActionItemToCommand |
Public method | ApplyContextKeyBinding | Apply shortcut key based on current context.
Public method | ApplyInitialShortcutKey | Initialize shortcut key from custom config file and defined in IActionItem.AttachTo
Public method | DeleteKeyBinding |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GenerateCustomShortcutKeyConfigFile |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsOverridedInCustomShortcutkeyFile |
Public method | ReadShortcutkeysFromConfigFile |
Public method | RegisterShortcutKey |
Public method | RestoreDefaultShortcutkey | Restore Shortcut keys to default.
Public method | SetKeyBinding |
Public method | SetKeyBindings | Create keyboardbinding and register it to MainWindow InputBinding.
Public method | StringifyModifierKeys |
Public method | ToModifierKey |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | _applicationShortkcutkeyConfigFile |
Public field | _customShortkcutkeyConfigFile |
Public field | _defaultShortkcutkeyConfigFile |
 | applicationShortcutkeyFileName |
 | customShortcutkeyFileName |
 | defaultShortcutkeyFileName |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ShortcutKeyManager Properties

The ShortcutKeyManager type exposes the following members.

Properties
 | Name | Description
Public property | AttachedOnlyShortcutKeys |
Public property | AttachedShortCutKeys |
Public property | BindedShortCutKeys | Represents shortcut keys that are set in ActionItem AttachTo property and binded to UI control.
 | CommandRegistry |
Public property | CustomShortCutKeys |
Public property | DefaultShortCutKeys |
 | Instance |
Public property | RegisteredShortCutKeys |
Top
See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager.AttachedOnlyShortcutKeys Property

ShortcutKeyManagerAttachedOnlyShortcutKeys Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ShortCutKeys AttachedOnlyShortcutKeys { get; }
public:
property ShortCutKeys^ AttachedOnlyShortcutKeys {
    ShortCutKeys^ get ();
}

Property Value

Type: ShortCutKeys
See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager.AttachedShortCutKeys Property

ShortcutKeyManagerAttachedShortCutKeys Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ShortCutKeys AttachedShortCutKeys { get; }
public:
property ShortCutKeys^ AttachedShortCutKeys {
    ShortCutKeys^ get ();
}

Property Value

Type: ShortCutKeys
See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager.BindedShortCutKeys Property

ShortcutKeyManagerBindedShortCutKeys Property

Represents shortcut keys that are set in ActionItem AttachTo property and binded to UI control.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ShortCutKeys BindedShortCutKeys { get; }
public:
property ShortCutKeys^ BindedShortCutKeys {
    ShortCutKeys^ get ();
}

Property Value

Type: ShortCutKeys
See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager.CommandRegistry Property

ShortcutKeyManagerCommandRegistry Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ICommandRegistry CommandRegistry { get; }
public:
static property ICommandRegistry^ CommandRegistry {
    ICommandRegistry^ get ();
}

Property Value

Type: ICommandRegistry
See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager.CustomShortCutKeys Property

ShortcutKeyManagerCustomShortCutKeys Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ShortCutKeys CustomShortCutKeys { get; }
public:
property ShortCutKeys^ CustomShortCutKeys {
    ShortCutKeys^ get ();
}

Property Value

Type: ShortCutKeys
See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager.DefaultShortCutKeys Property

ShortcutKeyManagerDefaultShortCutKeys Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ShortCutKeys DefaultShortCutKeys { get; }
public:
property ShortCutKeys^ DefaultShortCutKeys {
    ShortCutKeys^ get ();
}

Property Value

Type: ShortCutKeys
See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager.Instance Property

ShortcutKeyManagerInstance Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ShortcutKeyManager Instance { get; }
public:
static property ShortcutKeyManager^ Instance {
    ShortcutKeyManager^ get ();
}

Property Value

Type: ShortcutKeyManager
See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager.RegisteredShortCutKeys Property

ShortcutKeyManagerRegisteredShortCutKeys Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ShortCutKeys RegisteredShortCutKeys { get; }
public:
property ShortCutKeys^ RegisteredShortCutKeys {
    ShortCutKeys^ get ();
}

Property Value

Type: ShortCutKeys
See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager Methods

The ShortcutKeyManager type exposes the following members.

Methods
 | Name | Description
Public method | ActionItemToCommand |
Public method | ApplyContextKeyBinding | Apply shortcut key based on current context.
Public method | ApplyInitialShortcutKey | Initialize shortcut key from custom config file and defined in IActionItem.AttachTo
Public method | DeleteKeyBinding |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GenerateCustomShortcutKeyConfigFile |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsOverridedInCustomShortcutkeyFile |
Public method | ReadShortcutkeysFromConfigFile |
Public method | RegisterShortcutKey |
Public method | RestoreDefaultShortcutkey | Restore Shortcut keys to default.
Public method | SetKeyBinding |
Public method | SetKeyBindings | Create keyboardbinding and register it to MainWindow InputBinding.
Public method | StringifyModifierKeys |
Public method | ToModifierKey |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager.ActionItemToCommand Method

ShortcutKeyManagerActionItemToCommand Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InputBindingTriggerEx ActionItemToCommand(
    string id
)
public:
InputBindingTriggerEx^ ActionItemToCommand(
    String^ id
)

Parameters

id
Type: SystemString

Return Value

Type: InputBindingTriggerEx

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ShortcutKeyManager.ActionItemToCommand(System.String)"]

See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager.ApplyContextKeyBinding Method

ShortcutKeyManagerApplyContextKeyBinding Method

Apply shortcut key based on current context.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ApplyContextKeyBinding(
    IContext context
)
public:
void ApplyContextKeyBinding(
    IContext^ context
)

Parameters

context
Type: VisualComponents.Create3DIContext
Application context
See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager.ApplyInitialShortcutKey Method

ShortcutKeyManagerApplyInitialShortcutKey Method

Initialize shortcut key from custom config file and defined in IActionItem.AttachTo

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ApplyInitialShortcutKey()
public:
void ApplyInitialShortcutKey()
See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager.DeleteKeyBinding Method

ShortcutKeyManagerDeleteKeyBinding Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void DeleteKeyBinding(
    KeyboardPattern shortcut
)
public:
void DeleteKeyBinding(
    KeyboardPattern^ shortcut
)

Parameters

shortcut
Type: VisualComponents.UX.SharedKeyboardPattern
See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager.GenerateCustomShortcutKeyConfigFile Method

ShortcutKeyManagerGenerateCustomShortcutKeyConfigFile Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool GenerateCustomShortcutKeyConfigFile(
    bool deleteIfExist
)
public:
bool GenerateCustomShortcutKeyConfigFile(
    bool deleteIfExist
)

Parameters

deleteIfExist
Type: SystemBoolean

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ShortcutKeyManager.GenerateCustomShortcutKeyConfigFile(System.Boolean)"]

See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager.IsOverridedInCustomShortcutkeyFile Method

ShortcutKeyManagerIsOverridedInCustomShortcutkeyFile Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsOverridedInCustomShortcutkeyFile(
    KeyboardPattern pattern
)
public:
bool IsOverridedInCustomShortcutkeyFile(
    KeyboardPattern^ pattern
)

Parameters

pattern
Type: VisualComponents.UX.SharedKeyboardPattern

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ShortcutKeyManager.IsOverridedInCustomShortcutkeyFile(VisualComponents.UX.Shared.KeyboardPattern)"]

See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager.ReadShortcutkeysFromConfigFile Method

ShortcutKeyManagerReadShortcutkeysFromConfigFile Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ShortCutKeys ReadShortcutkeysFromConfigFile(
    bool fromDefaultFile = true
)
public:
ShortCutKeys^ ReadShortcutkeysFromConfigFile(
    bool fromDefaultFile = true
)

Parameters

fromDefaultFile (Optional)
Type: SystemBoolean

Return Value

Type: ShortCutKeys

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ShortcutKeyManager.ReadShortcutkeysFromConfigFile(System.Boolean)"]

See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager.RegisterShortcutKey Method

ShortcutKeyManagerRegisterShortcutKey Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RegisterShortcutKey(
    IActionItem actionItem,
    KeyGesture keyGesture
)
public:
void RegisterShortcutKey(
    IActionItem^ actionItem,
    KeyGesture^ keyGesture
)

Parameters

actionItem
Type: VisualComponents.UX.SharedIActionItem
keyGesture
Type: System.Windows.InputKeyGesture
See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager.RestoreDefaultShortcutkey Method

ShortcutKeyManagerRestoreDefaultShortcutkey Method

Restore Shortcut keys to default.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RestoreDefaultShortcutkey()
public:
void RestoreDefaultShortcutkey()
See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager.SetKeyBinding Method

ShortcutKeyManagerSetKeyBinding Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetKeyBinding(
    KeyboardPattern shortcut
)
public:
void SetKeyBinding(
    KeyboardPattern^ shortcut
)

Parameters

shortcut
Type: VisualComponents.UX.SharedKeyboardPattern
See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager.SetKeyBindings Method

ShortcutKeyManagerSetKeyBindings Method

Create keyboardbinding and register it to MainWindow InputBinding.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetKeyBindings(
    string currentContextId
)
public:
void SetKeyBindings(
    String^ currentContextId
)

Parameters

currentContextId
Type: SystemString
See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager.StringifyModifierKeys Method

ShortcutKeyManagerStringifyModifierKeys Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string StringifyModifierKeys(
    ModifierKeys modifier
)
public:
String^ StringifyModifierKeys(
    ModifierKeys modifier
)

Parameters

modifier
Type: System.Windows.InputModifierKeys

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ShortcutKeyManager.StringifyModifierKeys(System.Windows.Input.ModifierKeys)"]

See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager.ToModifierKey Method

ShortcutKeyManagerToModifierKey Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ModifierKeys ToModifierKey(
    string modifier
)
public:
ModifierKeys ToModifierKey(
    String^ modifier
)

Parameters

modifier
Type: SystemString

Return Value

Type: ModifierKeys

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ShortcutKeyManager.ToModifierKey(System.String)"]

See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager Fields

The ShortcutKeyManager type exposes the following members.

Fields
 | Name | Description
Public field | _applicationShortkcutkeyConfigFile |
Public field | _customShortkcutkeyConfigFile |
Public field | _defaultShortkcutkeyConfigFile |
 | applicationShortcutkeyFileName |
 | customShortcutkeyFileName |
 | defaultShortcutkeyFileName |
Top
See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager._applicationShortkcutkeyConfigFile Field

ShortcutKeyManager_applicationShortkcutkeyConfigFile Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public readonly string _applicationShortkcutkeyConfigFile
public:
initonly String^ _applicationShortkcutkeyConfigFile

Field Value

Type: String
See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager._customShortkcutkeyConfigFile Field

ShortcutKeyManager_customShortkcutkeyConfigFile Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public readonly string _customShortkcutkeyConfigFile
public:
initonly String^ _customShortkcutkeyConfigFile

Field Value

Type: String
See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager._defaultShortkcutkeyConfigFile Field

ShortcutKeyManager_defaultShortkcutkeyConfigFile Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public readonly string _defaultShortkcutkeyConfigFile
public:
initonly String^ _defaultShortkcutkeyConfigFile

Field Value

Type: String
See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager.applicationShortcutkeyFileName Field

ShortcutKeyManagerapplicationShortcutkeyFileName Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string applicationShortcutkeyFileName = "ShortcutKeys\Application_Custom_Shortcutkeys.xml"
public:
literal String^ applicationShortcutkeyFileName = "ShortcutKeys\Application_Custom_Shortcutkeys.xml"

Field Value

Type: String
See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager.customShortcutkeyFileName Field

ShortcutKeyManagercustomShortcutkeyFileName Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string customShortcutkeyFileName = "ShortcutKeys\Custom_Shortcutkeys.xml"
public:
literal String^ customShortcutkeyFileName = "ShortcutKeys\Custom_Shortcutkeys.xml"

Field Value

Type: String
See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortcutKeyManager.defaultShortcutkeyFileName Field

ShortcutKeyManagerdefaultShortcutkeyFileName Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const string defaultShortcutkeyFileName = "ShortcutKeys\Default_Shortcutkeys.xml"
public:
literal String^ defaultShortcutkeyFileName = "ShortcutKeys\Default_Shortcutkeys.xml"

Field Value

Type: String
See Also

Reference

ShortcutKeyManager Class
VisualComponents.UX.Shared Namespace


ShortCutKeys Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedShortCutKeys

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ShortCutKeys
public ref class ShortCutKeys

The ShortCutKeys type exposes the following members.

Constructors
 | Name | Description
Public method | ShortCutKeys | Initializes a new instance of the ShortCutKeys class
Top
Properties
 | Name | Description
Public property | KeyboardPattern |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ShortCutKeys Constructor

Initializes a new instance of the ShortCutKeys class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ShortCutKeys()
public:
ShortCutKeys()
See Also

Reference

ShortCutKeys Class
VisualComponents.UX.Shared Namespace


ShortCutKeys Properties

The ShortCutKeys type exposes the following members.

Properties
 | Name | Description
Public property | KeyboardPattern |
Top
See Also

Reference

ShortCutKeys Class
VisualComponents.UX.Shared Namespace


ShortCutKeys.KeyboardPattern Property

ShortCutKeysKeyboardPattern Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<KeyboardPattern> KeyboardPattern { get; set; }
public:
property List<KeyboardPattern^>^ KeyboardPattern {
    List<KeyboardPattern^>^ get ();
    void set (List<KeyboardPattern^>^ value);
}

Property Value

Type: ListKeyboardPattern
See Also

Reference

ShortCutKeys Class
VisualComponents.UX.Shared Namespace


ShortCutKeys Methods

The ShortCutKeys type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ShortCutKeys Class
VisualComponents.UX.Shared Namespace


ShortcutParser Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedShortcutParser

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class ShortcutParser
public ref class ShortcutParser abstract sealed

The ShortcutParser type exposes the following members.

Properties
Name | Description
CommandRegistry |
Top
Methods
Name | Description
CanParse |
CreateTrigger |
GetActionItem |
GetRegisteredInputBinding |
IsShortcutKeyAlreadyRegistered |
IsShortcutKeyOverrided |
ParseKeybinding(String) |
ParseKeybinding(String, IActionItem) |
ParseKeybinding(String, MenuItemBase) |
ParseKeybinding(KeyboardPattern, InputBindingTriggerEx) |
ParseShortcutkey(String, IActionItem) |
ParseShortcutkey(String, MenuItemBase) |
RegisteredKeyboardPatterns |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ShortcutParser Properties

The ShortcutParser type exposes the following members.

Properties
Name | Description
CommandRegistry |
Top
See Also

Reference

ShortcutParser Class
VisualComponents.UX.Shared Namespace


ShortcutParser.CommandRegistry Property

ShortcutParserCommandRegistry Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static ICommandRegistry CommandRegistry { get; }
public:
static property ICommandRegistry^ CommandRegistry {
    ICommandRegistry^ get ();
}

Property Value

Type: ICommandRegistry
See Also

Reference

ShortcutParser Class
VisualComponents.UX.Shared Namespace


ShortcutParser Methods

The ShortcutParser type exposes the following members.

Methods
Name | Description
CanParse |
CreateTrigger |
GetActionItem |
GetRegisteredInputBinding |
IsShortcutKeyAlreadyRegistered |
IsShortcutKeyOverrided |
ParseKeybinding(String) |
ParseKeybinding(String, IActionItem) |
ParseKeybinding(String, MenuItemBase) |
ParseKeybinding(KeyboardPattern, InputBindingTriggerEx) |
ParseShortcutkey(String, IActionItem) |
ParseShortcutkey(String, MenuItemBase) |
RegisteredKeyboardPatterns |
Top
See Also

Reference

ShortcutParser Class
VisualComponents.UX.Shared Namespace


ShortcutParser.CanParse Method

ShortcutParserCanParse Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool CanParse(
    string triggerText
)
public:
static bool CanParse(
    String^ triggerText
)

Parameters

triggerText
Type: SystemString

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ShortcutParser.CanParse(System.String)"]

See Also

Reference

ShortcutParser Class
VisualComponents.UX.Shared Namespace


ShortcutParser.CreateTrigger Method

ShortcutParserCreateTrigger Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static TriggerBase CreateTrigger(
    DependencyObject obj,
    string triggerText
)
public:
static TriggerBase^ CreateTrigger(
    DependencyObject^ obj,
    String^ triggerText
)

Parameters

obj
Type: System.WindowsDependencyObject
triggerText
Type: SystemString

Return Value

Type: TriggerBase

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ShortcutParser.CreateTrigger(System.Windows.DependencyObject,System.String)"]

See Also

Reference

ShortcutParser Class
VisualComponents.UX.Shared Namespace


ShortcutParser.GetActionItem Method

ShortcutParserGetActionItem Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IActionItem GetActionItem(
    KeyBinding keyBinding
)
public:
static IActionItem^ GetActionItem(
    KeyBinding^ keyBinding
)

Parameters

keyBinding
Type: System.Windows.InputKeyBinding

Return Value

Type: IActionItem

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ShortcutParser.GetActionItem(System.Windows.Input.KeyBinding)"]

See Also

Reference

ShortcutParser Class
VisualComponents.UX.Shared Namespace


ShortcutParser.GetRegisteredInputBinding Method

ShortcutParserGetRegisteredInputBinding Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static List<InputBinding> GetRegisteredInputBinding(
    KeyboardPattern pattern
)
public:
static List<InputBinding^>^ GetRegisteredInputBinding(
    KeyboardPattern^ pattern
)

Parameters

pattern
Type: VisualComponents.UX.SharedKeyboardPattern

Return Value

Type: ListInputBinding

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ShortcutParser.GetRegisteredInputBinding(VisualComponents.UX.Shared.KeyboardPattern)"]

See Also

Reference

ShortcutParser Class
VisualComponents.UX.Shared Namespace


ShortcutParser.IsShortcutKeyAlreadyRegistered Method

ShortcutParserIsShortcutKeyAlreadyRegistered Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsShortcutKeyAlreadyRegistered(
    InputBinding inputBinding
)
public:
static bool IsShortcutKeyAlreadyRegistered(
    InputBinding^ inputBinding
)

Parameters

inputBinding
Type: System.Windows.InputInputBinding

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ShortcutParser.IsShortcutKeyAlreadyRegistered(System.Windows.Input.InputBinding)"]

See Also

Reference

ShortcutParser Class
VisualComponents.UX.Shared Namespace


ShortcutParser.IsShortcutKeyOverrided Method

ShortcutParserIsShortcutKeyOverrided Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsShortcutKeyOverrided(
    InputBinding inputBinding
)
public:
static bool IsShortcutKeyOverrided(
    InputBinding^ inputBinding
)

Parameters

inputBinding
Type: System.Windows.InputInputBinding

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ShortcutParser.IsShortcutKeyOverrided(System.Windows.Input.InputBinding)"]

See Also

Reference

ShortcutParser Class
VisualComponents.UX.Shared Namespace


ShortcutParser.ParseKeybinding Method

ShortcutParserParseKeybinding Method

Overload List
Name | Description
ParseKeybinding(String) |
ParseKeybinding(String, IActionItem) |
ParseKeybinding(String, MenuItemBase) |
ParseKeybinding(KeyboardPattern, InputBindingTriggerEx) |
Top
See Also

Reference

ShortcutParser Class
VisualComponents.UX.Shared Namespace


ShortcutParser.ParseKeybinding Method (String)

ShortcutParserParseKeybinding Method (String)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static KeyBinding ParseKeybinding(
    string triggerText
)
public:
static KeyBinding^ ParseKeybinding(
    String^ triggerText
)

Parameters

triggerText
Type: SystemString

Return Value

Type: KeyBinding

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ShortcutParser.ParseKeybinding(System.String)"]

See Also

Reference

ShortcutParser Class
ParseKeybinding Overload
VisualComponents.UX.Shared Namespace


ShortcutParser.ParseKeybinding Method (String, IActionItem)

ShortcutParserParseKeybinding Method (String, IActionItem)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static KeyBinding ParseKeybinding(
    string triggerText,
    IActionItem actionItem
)
public:
static KeyBinding^ ParseKeybinding(
    String^ triggerText,
    IActionItem^ actionItem
)

Parameters

triggerText
Type: SystemString
actionItem
Type: VisualComponents.UX.SharedIActionItem

Return Value

Type: KeyBinding

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ShortcutParser.ParseKeybinding(System.String,VisualComponents.UX.Shared.IActionItem)"]

See Also

Reference

ShortcutParser Class
ParseKeybinding Overload
VisualComponents.UX.Shared Namespace


ShortcutParser.ParseKeybinding Method (String, MenuItemBase)

ShortcutParserParseKeybinding Method (String, MenuItemBase)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static KeyBinding ParseKeybinding(
    string triggerText,
    MenuItemBase menuItem
)
public:
static KeyBinding^ ParseKeybinding(
    String^ triggerText,
    MenuItemBase^ menuItem
)

Parameters

triggerText
Type: SystemString
menuItem
Type: VisualComponents.UX.SharedMenuItemBase

Return Value

Type: KeyBinding

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ShortcutParser.ParseKeybinding(System.String,VisualComponents.UX.Shared.MenuItemBase)"]

See Also

Reference

ShortcutParser Class
ParseKeybinding Overload
VisualComponents.UX.Shared Namespace


ShortcutParser.ParseKeybinding Method (KeyboardPattern, InputBindingTriggerEx)

ShortcutParserParseKeybinding Method (KeyboardPattern, InputBindingTriggerEx)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static KeyBinding ParseKeybinding(
    KeyboardPattern pattern,
    InputBindingTriggerEx command
)
public:
static KeyBinding^ ParseKeybinding(
    KeyboardPattern^ pattern,
    InputBindingTriggerEx^ command
)

Parameters

pattern
Type: VisualComponents.UX.SharedKeyboardPattern
command
Type: VisualComponents.UX.InputInputBindingTriggerEx

Return Value

Type: KeyBinding

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ShortcutParser.ParseKeybinding(VisualComponents.UX.Shared.KeyboardPattern,VisualComponents.UX.Input.InputBindingTriggerEx)"]

See Also

Reference

ShortcutParser Class
ParseKeybinding Overload
VisualComponents.UX.Shared Namespace


ShortcutParser.ParseShortcutkey Method

ShortcutParserParseShortcutkey Method

Overload List
Name | Description
ParseShortcutkey(String, IActionItem) |
ParseShortcutkey(String, MenuItemBase) |
Top
See Also

Reference

ShortcutParser Class
VisualComponents.UX.Shared Namespace


ShortcutParser.ParseShortcutkey Method (String, IActionItem)

ShortcutParserParseShortcutkey Method (String, IActionItem)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static KeyboardPattern ParseShortcutkey(
    string triggerText,
    IActionItem actionItem
)
public:
static KeyboardPattern^ ParseShortcutkey(
    String^ triggerText,
    IActionItem^ actionItem
)

Parameters

triggerText
Type: SystemString
actionItem
Type: VisualComponents.UX.SharedIActionItem

Return Value

Type: KeyboardPattern

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ShortcutParser.ParseShortcutkey(System.String,VisualComponents.UX.Shared.IActionItem)"]

See Also

Reference

ShortcutParser Class
ParseShortcutkey Overload
VisualComponents.UX.Shared Namespace


ShortcutParser.ParseShortcutkey Method (String, MenuItemBase)

ShortcutParserParseShortcutkey Method (String, MenuItemBase)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static KeyboardPattern ParseShortcutkey(
    string triggerText,
    MenuItemBase actionItem
)
public:
static KeyboardPattern^ ParseShortcutkey(
    String^ triggerText,
    MenuItemBase^ actionItem
)

Parameters

triggerText
Type: SystemString
actionItem
Type: VisualComponents.UX.SharedMenuItemBase

Return Value

Type: KeyboardPattern

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ShortcutParser.ParseShortcutkey(System.String,VisualComponents.UX.Shared.MenuItemBase)"]

See Also

Reference

ShortcutParser Class
ParseShortcutkey Overload
VisualComponents.UX.Shared Namespace


ShortcutParser.RegisteredKeyboardPatterns Method

ShortcutParserRegisteredKeyboardPatterns Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static List<KeyboardPattern> RegisteredKeyboardPatterns()
public:
static List<KeyboardPattern^>^ RegisteredKeyboardPatterns()

Return Value

Type: ListKeyboardPattern

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ShortcutParser.RegisteredKeyboardPatterns"]

See Also

Reference

ShortcutParser Class
VisualComponents.UX.Shared Namespace


ShowDebugViewModelMessage Class

Reserved for internal use only.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedShowDebugViewModelMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ShowDebugViewModelMessage
public ref class ShowDebugViewModelMessage

The ShowDebugViewModelMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ShowDebugViewModelMessage | Initializes a new instance of the ShowDebugViewModelMessage class
Top
Properties
 | Name | Description
Public property | ViewName |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ShowDebugViewModelMessage Constructor

Initializes a new instance of the ShowDebugViewModelMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ShowDebugViewModelMessage()
public:
ShowDebugViewModelMessage()
See Also

Reference

ShowDebugViewModelMessage Class
VisualComponents.UX.Shared Namespace


ShowDebugViewModelMessage Properties

The ShowDebugViewModelMessage type exposes the following members.

Properties
 | Name | Description
Public property | ViewName |
Top
See Also

Reference

ShowDebugViewModelMessage Class
VisualComponents.UX.Shared Namespace


ShowDebugViewModelMessage.ViewName Property

ShowDebugViewModelMessageViewName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ViewName { get; set; }
public:
property String^ ViewName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ShowDebugViewModelMessage Class
VisualComponents.UX.Shared Namespace


ShowDebugViewModelMessage Methods

The ShowDebugViewModelMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ShowDebugViewModelMessage Class
VisualComponents.UX.Shared Namespace


SignalChangedEventArgs Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedSignalChangedEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SignalChangedEventArgs
public ref class SignalChangedEventArgs

The SignalChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SignalChangedEventArgs | Initializes a new instance of the SignalChangedEventArgs class
Top
Properties
 | Name | Description
Public property | NewSignal |
Public property | OldSignal |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SignalChangedEventArgs Constructor

Initializes a new instance of the SignalChangedEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SignalChangedEventArgs(
    ISignal oldSignal,
    ISignal newSignal
)
public:
SignalChangedEventArgs(
    ISignal^ oldSignal,
    ISignal^ newSignal
)

Parameters

oldSignal
Type: VisualComponents.Create3DISignal
newSignal
Type: VisualComponents.Create3DISignal
See Also

Reference

SignalChangedEventArgs Class
VisualComponents.UX.Shared Namespace


SignalChangedEventArgs Properties

The SignalChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewSignal |
Public property | OldSignal |
Top
See Also

Reference

SignalChangedEventArgs Class
VisualComponents.UX.Shared Namespace


SignalChangedEventArgs.NewSignal Property

SignalChangedEventArgsNewSignal Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISignal NewSignal { get; set; }
public:
property ISignal^ NewSignal {
    ISignal^ get ();
    void set (ISignal^ value);
}

Property Value

Type: ISignal
See Also

Reference

SignalChangedEventArgs Class
VisualComponents.UX.Shared Namespace


SignalChangedEventArgs.OldSignal Property

SignalChangedEventArgsOldSignal Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISignal OldSignal { get; set; }
public:
property ISignal^ OldSignal {
    ISignal^ get ();
    void set (ISignal^ value);
}

Property Value

Type: ISignal
See Also

Reference

SignalChangedEventArgs Class
VisualComponents.UX.Shared Namespace


SignalChangedEventArgs Methods

The SignalChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SignalChangedEventArgs Class
VisualComponents.UX.Shared Namespace


SignalConnectionPair Class

Represents a connection between 2 signals
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedSignalConnectionPair

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SignalConnectionPair
public ref class SignalConnectionPair

The SignalConnectionPair type exposes the following members.

Constructors
 | Name | Description
Public method | SignalConnectionPair | Initializes a new instance of the SignalConnectionPair class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Signal1 |
Public field | Signal2 |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SignalConnectionPair Constructor

Initializes a new instance of the SignalConnectionPair class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SignalConnectionPair()
public:
SignalConnectionPair()
See Also

Reference

SignalConnectionPair Class
VisualComponents.UX.Shared Namespace


SignalConnectionPair Methods

The SignalConnectionPair type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SignalConnectionPair Class
VisualComponents.UX.Shared Namespace


SignalConnectionPair Fields

The SignalConnectionPair type exposes the following members.

Fields
 | Name | Description
Public field | Signal1 |
Public field | Signal2 |
Top
See Also

Reference

SignalConnectionPair Class
VisualComponents.UX.Shared Namespace


SignalConnectionPair.Signal1 Field

SignalConnectionPairSignal1 Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SignalInformation Signal1
public:
SignalInformation^ Signal1

Field Value

Type: SignalInformation
See Also

Reference

SignalConnectionPair Class
VisualComponents.UX.Shared Namespace


SignalConnectionPair.Signal2 Field

SignalConnectionPairSignal2 Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SignalInformation Signal2
public:
SignalInformation^ Signal2

Field Value

Type: SignalInformation
See Also

Reference

SignalConnectionPair Class
VisualComponents.UX.Shared Namespace


SignalInformation Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.SharedSignalInformation

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SignalInformation : PropertyChangedBase
public ref class SignalInformation : public PropertyChangedBase

The SignalInformation type exposes the following members.

Constructors
 | Name | Description
Public method | SignalInformation | Initializes a new instance of the SignalInformation class
Public method | SignalInformation(Int32, ISignalMap, NodeConnectorType, ISignal, ConnectorViewModel) | Initializes a new instance of the SignalInformation class
Top
Properties
 | Name | Description
Public property | Connector |
Public property | DescriptionSignal |
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | Map |
Public property | Port |
Public property | Signal |
Public property | Type |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasSameSignalSamePort |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | (Overrides ObjectToString.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Public event | SignalChanged |
Top
Operators
Name | Description
Equality |
Inequality |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SignalInformation Constructor

Overload List
 | Name | Description
Public method | SignalInformation | Initializes a new instance of the SignalInformation class
Public method | SignalInformation(Int32, ISignalMap, NodeConnectorType, ISignal, ConnectorViewModel) | Initializes a new instance of the SignalInformation class
Top
See Also

Reference

SignalInformation Class
VisualComponents.UX.Shared Namespace


SignalInformation Constructor

Initializes a new instance of the SignalInformation class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SignalInformation()
public:
SignalInformation()
See Also

Reference

SignalInformation Class
SignalInformation Overload
VisualComponents.UX.Shared Namespace


SignalInformation Constructor (Int32, ISignalMap, NodeConnectorType, ISignal, ConnectorViewModel)

Initializes a new instance of the SignalInformation class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SignalInformation(
    int port = -1,
    ISignalMap map = null,
    NodeConnectorType type = NodeConnectorType.Undefined,
    ISignal signal = null,
    ConnectorViewModel connector = null
)
public:
SignalInformation(
    int port = -1,
    ISignalMap^ map = nullptr,
    NodeConnectorType type = NodeConnectorType::Undefined,
    ISignal^ signal = nullptr,
    ConnectorViewModel^ connector = nullptr
)

Parameters

port (Optional)
Type: SystemInt32
map (Optional)
Type: VisualComponents.Create3DISignalMap
type (Optional)
Type: VisualComponents.UX.Shared.NetworkMapNodeConnectorType
signal (Optional)
Type: VisualComponents.Create3DISignal
connector (Optional)
Type: VisualComponents.UX.Shared.NetworkMapConnectorViewModel
See Also

Reference

SignalInformation Class
SignalInformation Overload
VisualComponents.UX.Shared Namespace


SignalInformation Properties

The SignalInformation type exposes the following members.

Properties
 | Name | Description
Public property | Connector |
Public property | DescriptionSignal |
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | Map |
Public property | Port |
Public property | Signal |
Public property | Type |
Top
See Also

Reference

SignalInformation Class
VisualComponents.UX.Shared Namespace


SignalInformation.Connector Property

SignalInformationConnector Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectorViewModel Connector { get; set; }
public:
property ConnectorViewModel^ Connector {
    ConnectorViewModel^ get ();
    void set (ConnectorViewModel^ value);
}

Property Value

Type: ConnectorViewModel
See Also

Reference

SignalInformation Class
VisualComponents.UX.Shared Namespace


SignalInformation.DescriptionSignal Property

SignalInformationDescriptionSignal Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string DescriptionSignal { get; }
public:
property String^ DescriptionSignal {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

SignalInformation Class
VisualComponents.UX.Shared Namespace


SignalInformation.Map Property

SignalInformationMap Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISignalMap Map { get; set; }
public:
property ISignalMap^ Map {
    ISignalMap^ get ();
    void set (ISignalMap^ value);
}

Property Value

Type: ISignalMap
See Also

Reference

SignalInformation Class
VisualComponents.UX.Shared Namespace


SignalInformation.Port Property

SignalInformationPort Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Port { get; set; }
public:
property int Port {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SignalInformation Class
VisualComponents.UX.Shared Namespace


SignalInformation.Signal Property

SignalInformationSignal Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISignal Signal { get; set; }
public:
property ISignal^ Signal {
    ISignal^ get ();
    void set (ISignal^ value);
}

Property Value

Type: ISignal
See Also

Reference

SignalInformation Class
VisualComponents.UX.Shared Namespace


SignalInformation.Type Property

SignalInformationType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NodeConnectorType Type { get; set; }
public:
property NodeConnectorType Type {
    NodeConnectorType get ();
    void set (NodeConnectorType value);
}

Property Value

Type: NodeConnectorType
See Also

Reference

SignalInformation Class
VisualComponents.UX.Shared Namespace


SignalInformation Methods

The SignalInformation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasSameSignalSamePort |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SignalInformation Class
VisualComponents.UX.Shared Namespace


SignalInformation.HasSameSignalSamePort Method

SignalInformationHasSameSignalSamePort Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HasSameSignalSamePort(
    SignalInformation other
)
public:
bool HasSameSignalSamePort(
    SignalInformation^ other
)

Parameters

other
Type: VisualComponents.UX.SharedSignalInformation

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SignalInformation.HasSameSignalSamePort(VisualComponents.UX.Shared.SignalInformation)"]

See Also

Reference

SignalInformation Class
VisualComponents.UX.Shared Namespace


SignalInformation.ToString Method

SignalInformationToString Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override string ToString()
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SignalInformation.ToString"]

See Also

Reference

SignalInformation Class
VisualComponents.UX.Shared Namespace


SignalInformation Events

The SignalInformation type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Public event | SignalChanged |
Top
See Also

Reference

SignalInformation Class
VisualComponents.UX.Shared Namespace


SignalInformation.SignalChanged Event

SignalInformationSignalChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<SignalChangedEventArgs> SignalChanged
public:
 event EventHandler<SignalChangedEventArgs^>^ SignalChanged {
    void add (EventHandler<SignalChangedEventArgs^>^ value);
    void remove (EventHandler<SignalChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandlerSignalChangedEventArgs
See Also

Reference

SignalInformation Class
VisualComponents.UX.Shared Namespace


SignalInformation Operators

The SignalInformation type exposes the following members.

Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

SignalInformation Class
VisualComponents.UX.Shared Namespace


SignalInformation.Equality Operator

SignalInformationEquality Operator

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator ==(
    SignalInformation c1,
    SignalInformation c2
)
public:
static bool operator ==(
    SignalInformation^ c1,
    SignalInformation^ c2
)

Parameters

c1
Type: VisualComponents.UX.SharedSignalInformation
c2
Type: VisualComponents.UX.SharedSignalInformation

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SignalInformation.op_Equality(VisualComponents.UX.Shared.SignalInformation,VisualComponents.UX.Shared.SignalInformation)"]

See Also

Reference

SignalInformation Class
VisualComponents.UX.Shared Namespace


SignalInformation.Inequality Operator

SignalInformationInequality Operator

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool operator !=(
    SignalInformation c1,
    SignalInformation c2
)
public:
static bool operator !=(
    SignalInformation^ c1,
    SignalInformation^ c2
)

Parameters

c1
Type: VisualComponents.UX.SharedSignalInformation
c2
Type: VisualComponents.UX.SharedSignalInformation

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SignalInformation.op_Inequality(VisualComponents.UX.Shared.SignalInformation,VisualComponents.UX.Shared.SignalInformation)"]

See Also

Reference

SignalInformation Class
VisualComponents.UX.Shared Namespace


SignalNetworkView Class

SignalNetworkView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedSignalNetworkView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SignalNetworkView : UserControl,
    IComponentConnector, IStyleConnector
public ref class SignalNetworkView : public UserControl,
    IComponentConnector, IStyleConnector

The SignalNetworkView type exposes the following members.

Constructors
 | Name | Description
Public method | SignalNetworkView | Initializes a new instance of the SignalNetworkView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | ViewModel | Convenient accessor for the view-model.
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SignalNetworkView Constructor

Initializes a new instance of the SignalNetworkView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SignalNetworkView()
public:
SignalNetworkView()
See Also

Reference

SignalNetworkView Class
VisualComponents.UX.Shared Namespace


SignalNetworkView Properties

The SignalNetworkView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | ViewModel | Convenient accessor for the view-model.
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

SignalNetworkView Class
VisualComponents.UX.Shared Namespace


SignalNetworkView.ViewModel Property

SignalNetworkViewViewModel Property

Convenient accessor for the view-model.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SignalNetworkViewModel ViewModel { get; }
public:
property SignalNetworkViewModel^ ViewModel {
    SignalNetworkViewModel^ get ();
}

Property Value

Type: SignalNetworkViewModel
See Also

Reference

SignalNetworkView Class
VisualComponents.UX.Shared Namespace


SignalNetworkView Methods

The SignalNetworkView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SignalNetworkView Class
VisualComponents.UX.Shared Namespace


SignalNetworkView.InitializeComponent Method

SignalNetworkViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

SignalNetworkView Class
VisualComponents.UX.Shared Namespace


SignalNetworkView Events

The SignalNetworkView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

SignalNetworkView Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel Class

Signal Network View Model
Inheritance Hierarchy
SystemObject
PropertyChangedBase
ViewAware
Screen
VisualComponents.UX.SharedSignalNetworkViewModel

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SignalNetworkViewModel : Screen,
    IHandle<ItemSelectedMessage<ISimComponent>>, IHandle, IHandle<ItemSelectedMessage<IRobot>>,
    IHandle<ApplicationContextChangedMessage>, ISignalMapViewModel, INodeViewModelContainer, IDpiAwareViewModel
public ref class SignalNetworkViewModel : public Screen,
    IHandle<ItemSelectedMessage<ISimComponent^>^>, IHandle, IHandle<ItemSelectedMessage<IRobot^>^>,
    IHandle<ApplicationContextChangedMessage^>, ISignalMapViewModel, INodeViewModelContainer, IDpiAwareViewModel

The SignalNetworkViewModel type exposes the following members.

Constructors
 | Name | Description
Public method | SignalNetworkViewModel | Constructor
Top
Properties
 | Name | Description
Public property | ActivateSignalToggling |
Protected property | CacheViews | (Inherited from ViewAware.)
Public property | DisplayName | (Inherited from Screen.)
Public property | ExpansionMode |
Public property | IsActive | (Inherited from Screen.)
Public property | IsEnabled |
Public property | IsInitialized | (Inherited from Screen.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | MapType |
Public property | Network | This is the network that is displayed in the window. It is the main part of the view-model.
 | NonAbstractInterfacesShown |
Public property | Parent | (Inherited from Screen.)
Public property | PinningMode |
Public property | ReverseDpiScale |
Public property | ShowConnectionLines |
Public property | ShowNetworkMap |
Public property | ShowNonAbstractInterfaces |
Public property | SignalTogglingEnabled |
Public property | ViewportHelper |
Top
Methods
 | Name | Description
Public method | AllConnections |
Public method | BringNodeToFront | Puts the specified node in front of all other nodes in Network Map
Public method | CanClose | (Inherited from Screen.)
Public method | CheckMatchingConnectors |
Public method | CollapseNode | Collapses the particular node and its connection lines
Public method | ConnectionDragCompleted | Called when the user has finished dragging out the new connection.
Public method | ConnectionDragging | Called as the user continues to drag the connection.
Public method | ConnectionDragStarted | Called when the user has started to drag out a connector, thus creating a new connection.
Public method | ConnectorEnter |
Public method | ConnectorInfoEditFinished |
Public method | ConnectorInfoEditing |
Public method | ConnectorLeave |
Public method | CreateInterfaceConnection | Establishes a connection between two Interfaces (internal usage)
Public method | CreateSignalConnection |
Public method | DeleteConnection | Deletes an established connection between two nodes (signals/interfaces)
Public method | EditConnector |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExpandNode | Expands the particular node and its connection lines
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindConnection | Retrieve a connection between the two connectors. Returns null if there is no connection between the connectors.
Public method | GetComponentSignals |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInterfaceFormattedName | Retrieves the human-friendly representation of Interface's name
Public method | GetNextAvailableSignal |
Public method | GetSignalInformation |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetView | (Inherited from ViewAware.)
Public method | Handle(ApplicationContextChangedMessage) |
Public method | Handle(ItemSelectedMessageIRobot) |
Public method | Handle(ItemSelectedMessageISimComponent) |
Public method | HideConnector | Hides the particular connector and its connection lines
Public method | IconizeNodes |
Public method | IsAbstract | Checks whether the Interface is Abstract (logical / has ConnectionEditName)
Public method | IsPinned |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseEnterNode |
Public method | MouseWheelPassThrough |
Public method | NodePinned |
Public method | NodeSizeChanged | Event raised when the size of a node has changed.
Public method | NodeUnPinned |
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Protected method | OnActivate | (Inherited from Screen.)
Protected method | OnDeactivate | (Inherited from Screen.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnInitialize | (Inherited from Screen.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Protected method | OnViewAttached | (Inherited from ViewAware.)
Protected method | OnViewLoaded | (Overrides ViewAware.OnViewLoaded(Object).)
Public method | QueryConnectionFeedback | Called to query the application for feedback while the user is dragging the connection.
Public method | RaiseConnectorPressed |
Public method | RebuildNetwork |
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | RemoveConnector |
Public method | ResetPinning |
Public method | RestoreInvalidNodesMaterials |
Public method | RestoreNodesMaterials |
Public method | SetConnectionVisibility |
Public method | SetConnectorInfo |
Public method | SetConnectorItem |
Public method | SetMaterialToInvalidNodes | Renders all invalid (do not have interfaces) nodes/components in the ghost mode.
Public method | SetMaterialToNode |
Public method | SetMaterialToNodes | Colors the Nodes connected to selected interface with green color and Nodes that can be connected to selected interface with yellow color.
Public method | SetPinnedPosition |
Public method | SetSelectedConnector |
Public method | SetSelectedNode |
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ShowConnector | Shows the particular connector (if it was previously hidden) and its connection lines
Public method | TargetConnector | Returns the destination connector of InterfaceConnections instance
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryClose | (Inherited from Screen.)
Public method | TryClose(NullableBoolean) | (Inherited from Screen.)
Public method | UpdateNodePositions | Re-positions all nodes in the network
Top
Events
 | Name | Description
Public event | Activated | (Inherited from Screen.)
Public event | AttemptingDeactivation | (Inherited from Screen.)
Public event | ConnectionCreated | Occurs when connection between two interfaces is established
Public event | ConnectionDeleted | Occurs when a connection between two nodes (signals/interfaces) is deleted
Public event | ConnectorInfoChanged |
Public event | ConnectorPressed | Occurs when the ConnectorItem (connector's "ball") is pressed
Public event | Deactivated | (Inherited from Screen.)
Public event | DragCompleted | Occurs when the user finishes dragging out a connector
Public event | DragStarted | Occurs when the user starts dragging out a connector
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Public event | SelectedComponentChanged | Occurs when the network is built for the newly selected component
Public event | SelectedConnectorChanged |
Public event | SelectedNodeChanged | Occurs when the user double-clicks the node's header
Public event | ViewAttached | (Inherited from ViewAware.)
Top
Fields
 | Name | Description
 | AllowConnectionDragging |
 | AllowConnectionsDuringSimulation |
 | AllowHidingNetworkMap |
 | AllowNonAbstractConnections |
 | AllowSignalToggling |
Public field | CandidateFill |
Public field | CandidateSilhouette |
 | ChangeSelectionOnComponentDoubleClick |
 | ChangeSelectionOnNodeTitleDoubleClick |
 | ColorHighlightedListItems |
 | ComponentGhostMode |
Public field | ConnectedFill |
Public field | ConnectedSilhouette |
 | DeferredNodeInitializationThreshold |
Public field | DisconnectFill |
Public field | DisconnectSilhouette |
 | DoubleClickSize |
 | DoubleClickSpeed |
 | EnableNodeVirtualization |
 | HiddenConnectionsListItemNaming |
 | HiddenConnectionsNodeVisibility |
Public field | HighlightFill |
Public field | HighlightSilhouette |
 | IndirectConnectionsVisibility |
Public field | InitializedConnections |
Public field | InvalidComponents |
 | ListItemAlternativeNamingThreshold |
Public field | MainNode |
 | NetworkMapVisibilityThreshold |
 | NodeVisibilityThreshold |
 | NonAbstractSelectionMode |
 | PossibleCandidatesHighlighting |
 | SetMaterialToNodeTree |
 | ShowOnlyMatchingInterfaces |
Public field | SimplifiedGhostFill |
 | SnapDoubleClickCancelAction |
 | UseSimplifiedMaterialInGhostMode |
Public field | ValidComponents |
Protected field | Views | (Inherited from ViewAware.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SignalNetworkViewModel Constructor

Constructor

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SignalNetworkViewModel(
    IApplication application,
    IRenderService renderService,
    ISelectionManager selectionManager,
    ITeachContext teachContext,
    IEventAggregator eventAggregator,
    IPlugAndPlayLogicalHelper logicalPnpHelper,
    IPlugAndPlayHelper helper,
    IApplicationSettingService appSettings
)
public:
SignalNetworkViewModel(
    IApplication^ application,
    IRenderService^ renderService,
    ISelectionManager^ selectionManager,
    ITeachContext^ teachContext,
    IEventAggregator^ eventAggregator,
    IPlugAndPlayLogicalHelper^ logicalPnpHelper,
    IPlugAndPlayHelper^ helper,
    IApplicationSettingService^ appSettings
)

Parameters

application
Type: VisualComponents.Create3DIApplication
renderService
Type: VisualComponents.Create3DIRenderService
selectionManager
Type: VisualComponents.Create3DISelectionManager
teachContext
Type: VisualComponents.Create3DITeachContext
eventAggregator
Type: IEventAggregator
logicalPnpHelper
Type: VisualComponents.Create3DIPlugAndPlayLogicalHelper
helper
Type: VisualComponents.Create3DIPlugAndPlayHelper
appSettings
Type: VisualComponents.Create3DIApplicationSettingService
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel Properties

The SignalNetworkViewModel type exposes the following members.

Properties
 | Name | Description
Public property | ActivateSignalToggling |
Protected property | CacheViews | (Inherited from ViewAware.)
Public property | DisplayName | (Inherited from Screen.)
Public property | ExpansionMode |
Public property | IsActive | (Inherited from Screen.)
Public property | IsEnabled |
Public property | IsInitialized | (Inherited from Screen.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | MapType |
Public property | Network | This is the network that is displayed in the window. It is the main part of the view-model.
 | NonAbstractInterfacesShown |
Public property | Parent | (Inherited from Screen.)
Public property | PinningMode |
Public property | ReverseDpiScale |
Public property | ShowConnectionLines |
Public property | ShowNetworkMap |
Public property | ShowNonAbstractInterfaces |
Public property | SignalTogglingEnabled |
Public property | ViewportHelper |
Top
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ActivateSignalToggling Property

SignalNetworkViewModelActivateSignalToggling Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ActivateSignalToggling { get; set; }
public:
property bool ActivateSignalToggling {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ExpansionMode Property

SignalNetworkViewModelExpansionMode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SignalNetworkViewModelNodeExpansionMode ExpansionMode { get; set; }
public:
property SignalNetworkViewModelNodeExpansionMode ExpansionMode {
    SignalNetworkViewModelNodeExpansionMode get ();
    void set (SignalNetworkViewModelNodeExpansionMode value);
}

Property Value

Type: SignalNetworkViewModelNodeExpansionMode
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.IsEnabled Property

SignalNetworkViewModelIsEnabled Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsEnabled { get; set; }
public:
virtual property bool IsEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ISignalMapViewModelIsEnabled
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.MapType Property

SignalNetworkViewModelMapType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public MapType MapType { get; set; }
public:
virtual property MapType MapType {
    MapType get () sealed;
    void set (MapType value) sealed;
}

Property Value

Type: MapType

Implements

ISignalMapViewModelMapType
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.Network Property

SignalNetworkViewModelNetwork Property

This is the network that is displayed in the window. It is the main part of the view-model.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NetworkViewModel Network { get; set; }
public:
property NetworkViewModel^ Network {
    NetworkViewModel^ get ();
    void set (NetworkViewModel^ value);
}

Property Value

Type: NetworkViewModel
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.NonAbstractInterfacesShown Property

SignalNetworkViewModelNonAbstractInterfacesShown Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool NonAbstractInterfacesShown { get; }
public:
static property bool NonAbstractInterfacesShown {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.PinningMode Property

SignalNetworkViewModelPinningMode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SignalNetworkViewModelNodePinningMode PinningMode { get; set; }
public:
property SignalNetworkViewModelNodePinningMode PinningMode {
    SignalNetworkViewModelNodePinningMode get ();
    void set (SignalNetworkViewModelNodePinningMode value);
}

Property Value

Type: SignalNetworkViewModelNodePinningMode
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ReverseDpiScale Property

SignalNetworkViewModelReverseDpiScale Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double ReverseDpiScale { get; set; }
public:
virtual property double ReverseDpiScale {
    double get () sealed;
    void set (double value) sealed;
}

Property Value

Type: Double

Implements

IDpiAwareViewModelReverseDpiScale
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ShowConnectionLines Property

SignalNetworkViewModelShowConnectionLines Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowConnectionLines { get; set; }
public:
property bool ShowConnectionLines {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ShowNetworkMap Property

SignalNetworkViewModelShowNetworkMap Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowNetworkMap { get; set; }
public:
property bool ShowNetworkMap {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ShowNonAbstractInterfaces Property

SignalNetworkViewModelShowNonAbstractInterfaces Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowNonAbstractInterfaces { get; set; }
public:
property bool ShowNonAbstractInterfaces {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.SignalTogglingEnabled Property

SignalNetworkViewModelSignalTogglingEnabled Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool SignalTogglingEnabled { get; set; }
public:
property bool SignalTogglingEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ViewportHelper Property

SignalNetworkViewModelViewportHelper Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public HelperViewport ViewportHelper { get; }
public:
property HelperViewport^ ViewportHelper {
    HelperViewport^ get ();
}

Property Value

Type: HelperViewport
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel Methods

The SignalNetworkViewModel type exposes the following members.

Methods
 | Name | Description
Public method | AllConnections |
Public method | BringNodeToFront | Puts the specified node in front of all other nodes in Network Map
Public method | CanClose | (Inherited from Screen.)
Public method | CheckMatchingConnectors |
Public method | CollapseNode | Collapses the particular node and its connection lines
Public method | ConnectionDragCompleted | Called when the user has finished dragging out the new connection.
Public method | ConnectionDragging | Called as the user continues to drag the connection.
Public method | ConnectionDragStarted | Called when the user has started to drag out a connector, thus creating a new connection.
Public method | ConnectorEnter |
Public method | ConnectorInfoEditFinished |
Public method | ConnectorInfoEditing |
Public method | ConnectorLeave |
Public method | CreateInterfaceConnection | Establishes a connection between two Interfaces (internal usage)
Public method | CreateSignalConnection |
Public method | DeleteConnection | Deletes an established connection between two nodes (signals/interfaces)
Public method | EditConnector |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExpandNode | Expands the particular node and its connection lines
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindConnection | Retrieve a connection between the two connectors. Returns null if there is no connection between the connectors.
Public method | GetComponentSignals |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInterfaceFormattedName | Retrieves the human-friendly representation of Interface's name
Public method | GetNextAvailableSignal |
Public method | GetSignalInformation |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetView | (Inherited from ViewAware.)
Public method | Handle(ApplicationContextChangedMessage) |
Public method | Handle(ItemSelectedMessageIRobot) |
Public method | Handle(ItemSelectedMessageISimComponent) |
Public method | HideConnector | Hides the particular connector and its connection lines
Public method | IconizeNodes |
Public method | IsAbstract | Checks whether the Interface is Abstract (logical / has ConnectionEditName)
Public method | IsPinned |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseEnterNode |
Public method | MouseWheelPassThrough |
Public method | NodePinned |
Public method | NodeSizeChanged | Event raised when the size of a node has changed.
Public method | NodeUnPinned |
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Protected method | OnActivate | (Inherited from Screen.)
Protected method | OnDeactivate | (Inherited from Screen.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnInitialize | (Inherited from Screen.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Protected method | OnViewAttached | (Inherited from ViewAware.)
Protected method | OnViewLoaded | (Overrides ViewAware.OnViewLoaded(Object).)
Public method | QueryConnectionFeedback | Called to query the application for feedback while the user is dragging the connection.
Public method | RaiseConnectorPressed |
Public method | RebuildNetwork |
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | RemoveConnector |
Public method | ResetPinning |
Public method | RestoreInvalidNodesMaterials |
Public method | RestoreNodesMaterials |
Public method | SetConnectionVisibility |
Public method | SetConnectorInfo |
Public method | SetConnectorItem |
Public method | SetMaterialToInvalidNodes | Renders all invalid (do not have interfaces) nodes/components in the ghost mode.
Public method | SetMaterialToNode |
Public method | SetMaterialToNodes | Colors the Nodes connected to selected interface with green color and Nodes that can be connected to selected interface with yellow color.
Public method | SetPinnedPosition |
Public method | SetSelectedConnector |
Public method | SetSelectedNode |
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ShowConnector | Shows the particular connector (if it was previously hidden) and its connection lines
Public method | TargetConnector | Returns the destination connector of InterfaceConnections instance
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryClose | (Inherited from Screen.)
Public method | TryClose(NullableBoolean) | (Inherited from Screen.)
Public method | UpdateNodePositions | Re-positions all nodes in the network
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.AllConnections Method

SignalNetworkViewModelAllConnections Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<SignalConnectionPair> AllConnections(
    ISignalMap map,
    NodeConnectorType type
)
public:
List<SignalConnectionPair^>^ AllConnections(
    ISignalMap^ map,
    NodeConnectorType type
)

Parameters

map
Type: VisualComponents.Create3DISignalMap
type
Type: VisualComponents.UX.Shared.NetworkMapNodeConnectorType

Return Value

Type: ListSignalConnectionPair

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SignalNetworkViewModel.AllConnections(VisualComponents.Create3D.ISignalMap,VisualComponents.UX.Shared.NetworkMap.NodeConnectorType)"]

See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.BringNodeToFront Method

SignalNetworkViewModelBringNodeToFront Method

Puts the specified node in front of all other nodes in Network Map

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void BringNodeToFront(
    NodeViewModel node
)
public:
void BringNodeToFront(
    NodeViewModel^ node
)

Parameters

node
Type: VisualComponents.UX.Shared.NetworkMapNodeViewModel
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.CheckMatchingConnectors Method

SignalNetworkViewModelCheckMatchingConnectors Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CheckMatchingConnectors(
    ConnectorViewModel source,
    ConnectorViewModel dest,
    bool matchConnectedSource = false,
    bool matchConnectedDest = false
)
public:
bool CheckMatchingConnectors(
    ConnectorViewModel^ source,
    ConnectorViewModel^ dest,
    bool matchConnectedSource = false,
    bool matchConnectedDest = false
)

Parameters

source
Type: VisualComponents.UX.Shared.NetworkMapConnectorViewModel
dest
Type: VisualComponents.UX.Shared.NetworkMapConnectorViewModel
matchConnectedSource (Optional)
Type: SystemBoolean
matchConnectedDest (Optional)
Type: SystemBoolean

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SignalNetworkViewModel.CheckMatchingConnectors(VisualComponents.UX.Shared.NetworkMap.ConnectorViewModel,VisualComponents.UX.Shared.NetworkMap.ConnectorViewModel,System.Boolean,System.Boolean)"]

See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.CollapseNode Method

SignalNetworkViewModelCollapseNode Method

Collapses the particular node and its connection lines

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CollapseNode(
    Object sender
)
public:
void CollapseNode(
    Object^ sender
)

Parameters

sender
Type: SystemObject
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ConnectionDragCompleted Method

SignalNetworkViewModelConnectionDragCompleted Method

Called when the user has finished dragging out the new connection.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ConnectionDragCompleted(
    ConnectionViewModel newConnection,
    ConnectorViewModel connectorDraggedOut,
    ConnectorViewModel connectorDraggedOver
)
public:
void ConnectionDragCompleted(
    ConnectionViewModel^ newConnection,
    ConnectorViewModel^ connectorDraggedOut,
    ConnectorViewModel^ connectorDraggedOver
)

Parameters

newConnection
Type: VisualComponents.UX.Shared.NetworkMapConnectionViewModel
connectorDraggedOut
Type: VisualComponents.UX.Shared.NetworkMapConnectorViewModel
connectorDraggedOver
Type: VisualComponents.UX.Shared.NetworkMapConnectorViewModel
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ConnectionDragging Method

SignalNetworkViewModelConnectionDragging Method

Called as the user continues to drag the connection.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ConnectionDragging(
    Point curDragPoint,
    ConnectionViewModel connection
)
public:
void ConnectionDragging(
    Point curDragPoint,
    ConnectionViewModel^ connection
)

Parameters

curDragPoint
Type: System.WindowsPoint
connection
Type: VisualComponents.UX.Shared.NetworkMapConnectionViewModel
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ConnectionDragStarted Method

SignalNetworkViewModelConnectionDragStarted Method

Called when the user has started to drag out a connector, thus creating a new connection.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectionViewModel ConnectionDragStarted(
    ConnectorViewModel draggedOutConnector,
    Point curDragPoint
)
public:
ConnectionViewModel^ ConnectionDragStarted(
    ConnectorViewModel^ draggedOutConnector,
    Point curDragPoint
)

Parameters

draggedOutConnector
Type: VisualComponents.UX.Shared.NetworkMapConnectorViewModel
curDragPoint
Type: System.WindowsPoint

Return Value

Type: ConnectionViewModel

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SignalNetworkViewModel.ConnectionDragStarted(VisualComponents.UX.Shared.NetworkMap.ConnectorViewModel,System.Windows.Point)"]

See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ConnectorEnter Method

SignalNetworkViewModelConnectorEnter Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ConnectorEnter(
    ConnectorViewModel connector
)
public:
void ConnectorEnter(
    ConnectorViewModel^ connector
)

Parameters

connector
Type: VisualComponents.UX.Shared.NetworkMapConnectorViewModel
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ConnectorInfoEditFinished Method

SignalNetworkViewModelConnectorInfoEditFinished Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ConnectorInfoEditFinished(
    Object sender,
    ConnectorViewModel connector
)
public:
void ConnectorInfoEditFinished(
    Object^ sender,
    ConnectorViewModel^ connector
)

Parameters

sender
Type: SystemObject
connector
Type: VisualComponents.UX.Shared.NetworkMapConnectorViewModel
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ConnectorInfoEditing Method

SignalNetworkViewModelConnectorInfoEditing Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ConnectorInfoEditing(
    Object sender,
    Object e
)
public:
void ConnectorInfoEditing(
    Object^ sender,
    Object^ e
)

Parameters

sender
Type: SystemObject
e
Type: SystemObject
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ConnectorLeave Method

SignalNetworkViewModelConnectorLeave Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ConnectorLeave(
    ConnectorViewModel connector
)
public:
void ConnectorLeave(
    ConnectorViewModel^ connector
)

Parameters

connector
Type: VisualComponents.UX.Shared.NetworkMapConnectorViewModel
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.CreateInterfaceConnection Method

SignalNetworkViewModelCreateInterfaceConnection Method

Establishes a connection between two Interfaces (internal usage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CreateInterfaceConnection(
    ConnectorViewModel source,
    ConnectorViewModel dest
)
public:
bool CreateInterfaceConnection(
    ConnectorViewModel^ source,
    ConnectorViewModel^ dest
)

Parameters

source
Type: VisualComponents.UX.Shared.NetworkMapConnectorViewModel
dest
Type: VisualComponents.UX.Shared.NetworkMapConnectorViewModel

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SignalNetworkViewModel.CreateInterfaceConnection(VisualComponents.UX.Shared.NetworkMap.ConnectorViewModel,VisualComponents.UX.Shared.NetworkMap.ConnectorViewModel)"]

See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.CreateSignalConnection Method

SignalNetworkViewModelCreateSignalConnection Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CreateSignalConnection(
    ConnectionViewModel newConnection,
    ConnectorViewModel source,
    ConnectorViewModel target
)
public:
bool CreateSignalConnection(
    ConnectionViewModel^ newConnection,
    ConnectorViewModel^ source,
    ConnectorViewModel^ target
)

Parameters

newConnection
Type: VisualComponents.UX.Shared.NetworkMapConnectionViewModel
source
Type: VisualComponents.UX.Shared.NetworkMapConnectorViewModel
target
Type: VisualComponents.UX.Shared.NetworkMapConnectorViewModel

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SignalNetworkViewModel.CreateSignalConnection(VisualComponents.UX.Shared.NetworkMap.ConnectionViewModel,VisualComponents.UX.Shared.NetworkMap.ConnectorViewModel,VisualComponents.UX.Shared.NetworkMap.ConnectorViewModel)"]

See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.DeleteConnection Method

SignalNetworkViewModelDeleteConnection Method

Deletes an established connection between two nodes (signals/interfaces)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void DeleteConnection(
    ConnectionViewModel connection,
    ConnectorViewModel preservedConnector = null,
    bool update = true
)
public:
void DeleteConnection(
    ConnectionViewModel^ connection,
    ConnectorViewModel^ preservedConnector = nullptr,
    bool update = true
)

Parameters

connection
Type: VisualComponents.UX.Shared.NetworkMapConnectionViewModel
preservedConnector (Optional)
Type: VisualComponents.UX.Shared.NetworkMapConnectorViewModel
update (Optional)
Type: SystemBoolean
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.EditConnector Method

SignalNetworkViewModelEditConnector Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void EditConnector(
    ConnectorViewModel connector
)
public:
void EditConnector(
    ConnectorViewModel^ connector
)

Parameters

connector
Type: VisualComponents.UX.Shared.NetworkMapConnectorViewModel
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ExpandNode Method

SignalNetworkViewModelExpandNode Method

Expands the particular node and its connection lines

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ExpandNode(
    Object sender
)
public:
void ExpandNode(
    Object^ sender
)

Parameters

sender
Type: SystemObject
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.FindConnection Method

SignalNetworkViewModelFindConnection Method

Retrieve a connection between the two connectors. Returns null if there is no connection between the connectors.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectionViewModel FindConnection(
    ConnectorViewModel connector1,
    ConnectorViewModel connector2
)
public:
ConnectionViewModel^ FindConnection(
    ConnectorViewModel^ connector1,
    ConnectorViewModel^ connector2
)

Parameters

connector1
Type: VisualComponents.UX.Shared.NetworkMapConnectorViewModel
connector2
Type: VisualComponents.UX.Shared.NetworkMapConnectorViewModel

Return Value

Type: ConnectionViewModel

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SignalNetworkViewModel.FindConnection(VisualComponents.UX.Shared.NetworkMap.ConnectorViewModel,VisualComponents.UX.Shared.NetworkMap.ConnectorViewModel)"]

See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.GetComponentSignals Method

SignalNetworkViewModelGetComponentSignals Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void GetComponentSignals(
    ISimComponent component,
    ref ISignalMap mapIn,
    ref ISignalMap mapOut,
    List<SignalInformation> signals
)
public:
void GetComponentSignals(
    ISimComponent^ component,
    ISignalMap^% mapIn,
    ISignalMap^% mapOut,
    List<SignalInformation^>^ signals
)

Parameters

component
Type: VisualComponents.Create3DISimComponent
mapIn
Type: VisualComponents.Create3DISignalMap
mapOut
Type: VisualComponents.Create3DISignalMap
signals
Type: System.Collections.GenericListSignalInformation
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.GetInterfaceFormattedName Method

SignalNetworkViewModelGetInterfaceFormattedName Method

Retrieves the human-friendly representation of Interface's name

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string GetInterfaceFormattedName(
    IBehavior beh
)
public:
String^ GetInterfaceFormattedName(
    IBehavior^ beh
)

Parameters

beh
Type: VisualComponents.Create3DIBehavior

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SignalNetworkViewModel.GetInterfaceFormattedName(VisualComponents.Create3D.IBehavior)"]

See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.GetNextAvailableSignal Method

SignalNetworkViewModelGetNextAvailableSignal Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SignalInformation GetNextAvailableSignal(
    ISimComponent component,
    NodeConnectorType type
)
public:
SignalInformation^ GetNextAvailableSignal(
    ISimComponent^ component,
    NodeConnectorType type
)

Parameters

component
Type: VisualComponents.Create3DISimComponent
type
Type: VisualComponents.UX.Shared.NetworkMapNodeConnectorType

Return Value

Type: SignalInformation

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SignalNetworkViewModel.GetNextAvailableSignal(VisualComponents.Create3D.ISimComponent,VisualComponents.UX.Shared.NetworkMap.NodeConnectorType)"]

See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.GetSignalInformation Method

SignalNetworkViewModelGetSignalInformation Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Tuple<NodeConnectorType, List<int>, ISignalMap> GetSignalInformation(
    ISignal signal
)
public:
Tuple<NodeConnectorType, List<int>^, ISignalMap^>^ GetSignalInformation(
    ISignal^ signal
)

Parameters

signal
Type: VisualComponents.Create3DISignal

Return Value

Type: TupleNodeConnectorType, ListInt32, ISignalMap

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SignalNetworkViewModel.GetSignalInformation(VisualComponents.Create3D.ISignal)"]

See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.Handle Method

SignalNetworkViewModelHandle Method

Overload List
 | Name | Description
Public method | Handle(ApplicationContextChangedMessage) |
Public method | Handle(ItemSelectedMessageIRobot) |
Public method | Handle(ItemSelectedMessageISimComponent) |
Top
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.Handle Method (ApplicationContextChangedMessage)

SignalNetworkViewModelHandle Method (ApplicationContextChangedMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    ApplicationContextChangedMessage message
)
public:
virtual void Handle(
    ApplicationContextChangedMessage^ message
) sealed

Parameters

message
Type: VisualComponents.Create3DApplicationContextChangedMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

SignalNetworkViewModel Class
Handle Overload
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.Handle Method (ItemSelectedMessage(IRobot))

SignalNetworkViewModelHandle Method (ItemSelectedMessageIRobot)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    ItemSelectedMessage<IRobot> message
)
public:
virtual void Handle(
    ItemSelectedMessage<IRobot^>^ message
) sealed

Parameters

message
Type: VisualComponents.Create3DItemSelectedMessage IRobot

Implements

IHandle.Handle(UTP)
See Also

Reference

SignalNetworkViewModel Class
Handle Overload
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.Handle Method (ItemSelectedMessage(ISimComponent))

SignalNetworkViewModelHandle Method (ItemSelectedMessageISimComponent)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    ItemSelectedMessage<ISimComponent> message
)
public:
virtual void Handle(
    ItemSelectedMessage<ISimComponent^>^ message
) sealed

Parameters

message
Type: VisualComponents.Create3DItemSelectedMessage ISimComponent

Implements

IHandle.Handle(UTP)
See Also

Reference

SignalNetworkViewModel Class
Handle Overload
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.HideConnector Method

SignalNetworkViewModelHideConnector Method

Hides the particular connector and its connection lines

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void HideConnector(
    Object sender
)
public:
void HideConnector(
    Object^ sender
)

Parameters

sender
Type: SystemObject
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.IconizeNodes Method

SignalNetworkViewModelIconizeNodes Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void IconizeNodes(
    IList<NodeViewModel> nodes,
    IList<ConnectionViewModel> connections
)
public:
void IconizeNodes(
    IList<NodeViewModel^>^ nodes,
    IList<ConnectionViewModel^>^ connections
)

Parameters

nodes
Type: System.Collections.GenericIListNodeViewModel
connections
Type: System.Collections.GenericIListConnectionViewModel
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.IsAbstract Method

SignalNetworkViewModelIsAbstract Method

Checks whether the Interface is Abstract (logical / has ConnectionEditName)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsAbstract(
    IBehavior beh
)
public:
bool IsAbstract(
    IBehavior^ beh
)

Parameters

beh
Type: VisualComponents.Create3DIBehavior

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SignalNetworkViewModel.IsAbstract(VisualComponents.Create3D.IBehavior)"]

See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.IsPinned Method

SignalNetworkViewModelIsPinned Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsPinned(
    NodeViewModel node
)
public:
virtual bool IsPinned(
    NodeViewModel^ node
) sealed

Parameters

node
Type: VisualComponents.UX.Shared.NetworkMapNodeViewModel

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SignalNetworkViewModel.IsPinned(VisualComponents.UX.Shared.NetworkMap.NodeViewModel)"]

Implements

INodeViewModelContainerIsPinned(NodeViewModel)
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.MouseEnterNode Method

SignalNetworkViewModelMouseEnterNode Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MouseEnterNode()
public:
void MouseEnterNode()
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.MouseWheelPassThrough Method

SignalNetworkViewModelMouseWheelPassThrough Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MouseWheelPassThrough(
    MouseWheelEventArgs e
)
public:
void MouseWheelPassThrough(
    MouseWheelEventArgs^ e
)

Parameters

e
Type: System.Windows.InputMouseWheelEventArgs
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.NodePinned Method

SignalNetworkViewModelNodePinned Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void NodePinned(
    NodeViewModel node,
    double x,
    double y
)
public:
virtual void NodePinned(
    NodeViewModel^ node,
    double x,
    double y
) sealed

Parameters

node
Type: VisualComponents.UX.Shared.NetworkMapNodeViewModel
x
Type: SystemDouble
y
Type: SystemDouble

Implements

INodeViewModelContainerNodePinned(NodeViewModel, Double, Double)
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.NodeSizeChanged Method

SignalNetworkViewModelNodeSizeChanged Method

Event raised when the size of a node has changed.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void NodeSizeChanged(
    Object sender,
    SizeChangedEventArgs e
)
public:
void NodeSizeChanged(
    Object^ sender,
    SizeChangedEventArgs^ e
)

Parameters

sender
Type: SystemObject
e
Type: System.WindowsSizeChangedEventArgs
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.NodeUnPinned Method

SignalNetworkViewModelNodeUnPinned Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void NodeUnPinned(
    NodeViewModel node
)
public:
virtual void NodeUnPinned(
    NodeViewModel^ node
) sealed

Parameters

node
Type: VisualComponents.UX.Shared.NetworkMapNodeViewModel

Implements

INodeViewModelContainerNodeUnPinned(NodeViewModel)
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.OnViewLoaded Method

SignalNetworkViewModelOnViewLoaded Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnViewLoaded(
    Object view
)
protected:
virtual void OnViewLoaded(
    Object^ view
) override

Parameters

view
Type: SystemObject
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.QueryConnectionFeedback Method

SignalNetworkViewModelQueryConnectionFeedback Method

Called to query the application for feedback while the user is dragging the connection.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object QueryConnectionFeedback(
    ConnectorViewModel draggedOutConnector,
    ConnectorViewModel draggedOverConnector,
    out bool connectionPermitted
)
public:
Object^ QueryConnectionFeedback(
    ConnectorViewModel^ draggedOutConnector,
    ConnectorViewModel^ draggedOverConnector,
    [OutAttribute] bool% connectionPermitted
)

Parameters

draggedOutConnector
Type: VisualComponents.UX.Shared.NetworkMapConnectorViewModel
draggedOverConnector
Type: VisualComponents.UX.Shared.NetworkMapConnectorViewModel
connectionPermitted
Type: SystemBoolean

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SignalNetworkViewModel.QueryConnectionFeedback(VisualComponents.UX.Shared.NetworkMap.ConnectorViewModel,VisualComponents.UX.Shared.NetworkMap.ConnectorViewModel,System.Boolean@)"]

See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.RaiseConnectorPressed Method

SignalNetworkViewModelRaiseConnectorPressed Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RaiseConnectorPressed(
    ConnectorViewModel connector
)
public:
void RaiseConnectorPressed(
    ConnectorViewModel^ connector
)

Parameters

connector
Type: VisualComponents.UX.Shared.NetworkMapConnectorViewModel
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.RebuildNetwork Method

SignalNetworkViewModelRebuildNetwork Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RebuildNetwork()
public:
void RebuildNetwork()
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.RemoveConnector Method

SignalNetworkViewModelRemoveConnector Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RemoveConnector(
    ConnectorViewModel connector
)
public:
void RemoveConnector(
    ConnectorViewModel^ connector
)

Parameters

connector
Type: VisualComponents.UX.Shared.NetworkMapConnectorViewModel
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ResetPinning Method

SignalNetworkViewModelResetPinning Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ResetPinning()
public:
void ResetPinning()
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.RestoreInvalidNodesMaterials Method

SignalNetworkViewModelRestoreInvalidNodesMaterials Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RestoreInvalidNodesMaterials()
public:
void RestoreInvalidNodesMaterials()
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.RestoreNodesMaterials Method

SignalNetworkViewModelRestoreNodesMaterials Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RestoreNodesMaterials()
public:
void RestoreNodesMaterials()
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.SetConnectionVisibility Method

SignalNetworkViewModelSetConnectionVisibility Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetConnectionVisibility(
    ConnectionViewModel connection
)
public:
void SetConnectionVisibility(
    ConnectionViewModel^ connection
)

Parameters

connection
Type: VisualComponents.UX.Shared.NetworkMapConnectionViewModel
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.SetConnectorInfo Method

SignalNetworkViewModelSetConnectorInfo Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetConnectorInfo(
    Object sender,
    ConnectorViewModel connector
)
public:
void SetConnectorInfo(
    Object^ sender,
    ConnectorViewModel^ connector
)

Parameters

sender
Type: SystemObject
connector
Type: VisualComponents.UX.Shared.NetworkMapConnectorViewModel
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.SetConnectorItem Method

SignalNetworkViewModelSetConnectorItem Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetConnectorItem(
    Object sender,
    ConnectorViewModel connector
)
public:
void SetConnectorItem(
    Object^ sender,
    ConnectorViewModel^ connector
)

Parameters

sender
Type: SystemObject
connector
Type: VisualComponents.UX.Shared.NetworkMapConnectorViewModel
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.SetMaterialToInvalidNodes Method

SignalNetworkViewModelSetMaterialToInvalidNodes Method

Renders all invalid (do not have interfaces) nodes/components in the ghost mode.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetMaterialToInvalidNodes()
public:
void SetMaterialToInvalidNodes()
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.SetMaterialToNode Method

SignalNetworkViewModelSetMaterialToNode Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetMaterialToNode(
    ISimNode node,
    bool connected
)
public:
void SetMaterialToNode(
    ISimNode^ node,
    bool connected
)

Parameters

node
Type: VisualComponents.Create3DISimNode
connected
Type: SystemBoolean
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.SetMaterialToNodes Method

SignalNetworkViewModelSetMaterialToNodes Method

Colors the Nodes connected to selected interface with green color and Nodes that can be connected to selected interface with yellow color.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetMaterialToNodes()
public:
void SetMaterialToNodes()
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.SetPinnedPosition Method

SignalNetworkViewModelSetPinnedPosition Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetPinnedPosition(
    NodeViewModel node
)
public:
virtual void SetPinnedPosition(
    NodeViewModel^ node
) sealed

Parameters

node
Type: VisualComponents.UX.Shared.NetworkMapNodeViewModel

Implements

INodeViewModelContainerSetPinnedPosition(NodeViewModel)
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.SetSelectedConnector Method

SignalNetworkViewModelSetSelectedConnector Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetSelectedConnector(
    ConnectorViewModel connector,
    MouseButtonEventArgs e
)
public:
void SetSelectedConnector(
    ConnectorViewModel^ connector,
    MouseButtonEventArgs^ e
)

Parameters

connector
Type: VisualComponents.UX.Shared.NetworkMapConnectorViewModel
e
Type: System.Windows.InputMouseButtonEventArgs
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.SetSelectedNode Method

SignalNetworkViewModelSetSelectedNode Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetSelectedNode(
    NodeViewModel nodeModel
)
public:
void SetSelectedNode(
    NodeViewModel^ nodeModel
)

Parameters

nodeModel
Type: VisualComponents.UX.Shared.NetworkMapNodeViewModel
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ShowConnector Method

SignalNetworkViewModelShowConnector Method

Shows the particular connector (if it was previously hidden) and its connection lines

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ShowConnector(
    Object sender
)
public:
void ShowConnector(
    Object^ sender
)

Parameters

sender
Type: SystemObject
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.TargetConnector Method

SignalNetworkViewModelTargetConnector Method

Returns the destination connector of InterfaceConnections instance

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectorViewModel TargetConnector(
    ISimInterface source,
    InterfaceConnections connection
)
public:
ConnectorViewModel^ TargetConnector(
    ISimInterface^ source,
    InterfaceConnections^ connection
)

Parameters

source
Type: VisualComponents.Create3DISimInterface
connection
Type: VisualComponents.Create3DInterfaceConnections

Return Value

Type: ConnectorViewModel

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SignalNetworkViewModel.TargetConnector(VisualComponents.Create3D.ISimInterface,VisualComponents.Create3D.InterfaceConnections)"]

See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.UpdateNodePositions Method

SignalNetworkViewModelUpdateNodePositions Method

Re-positions all nodes in the network

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void UpdateNodePositions(
    IList<NodeViewModel> nodes,
    bool changedFromNode = false,
    bool changePositions = true,
    bool initializing = false
)
public:
void UpdateNodePositions(
    IList<NodeViewModel^>^ nodes,
    bool changedFromNode = false,
    bool changePositions = true,
    bool initializing = false
)

Parameters

nodes
Type: System.Collections.GenericIListNodeViewModel
changedFromNode (Optional)
Type: SystemBoolean
changePositions (Optional)
Type: SystemBoolean
initializing (Optional)
Type: SystemBoolean
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel Events

The SignalNetworkViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from Screen.)
Public event | AttemptingDeactivation | (Inherited from Screen.)
Public event | ConnectionCreated | Occurs when connection between two interfaces is established
Public event | ConnectionDeleted | Occurs when a connection between two nodes (signals/interfaces) is deleted
Public event | ConnectorInfoChanged |
Public event | ConnectorPressed | Occurs when the ConnectorItem (connector's "ball") is pressed
Public event | Deactivated | (Inherited from Screen.)
Public event | DragCompleted | Occurs when the user finishes dragging out a connector
Public event | DragStarted | Occurs when the user starts dragging out a connector
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Public event | SelectedComponentChanged | Occurs when the network is built for the newly selected component
Public event | SelectedConnectorChanged |
Public event | SelectedNodeChanged | Occurs when the user double-clicks the node's header
Public event | ViewAttached | (Inherited from ViewAware.)
Top
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ConnectionCreated Event

SignalNetworkViewModelConnectionCreated Event

Occurs when connection between two interfaces is established

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<SignalNetworkViewModelAlteredConnection> ConnectionCreated
public:
 event EventHandler<SignalNetworkViewModelAlteredConnection^>^ ConnectionCreated {
    void add (EventHandler<SignalNetworkViewModelAlteredConnection^>^ value);
    void remove (EventHandler<SignalNetworkViewModelAlteredConnection^>^ value);
}

Value

Type: SystemEventHandlerSignalNetworkViewModelAlteredConnection
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ConnectionDeleted Event

SignalNetworkViewModelConnectionDeleted Event

Occurs when a connection between two nodes (signals/interfaces) is deleted

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<SignalNetworkViewModelAlteredConnection> ConnectionDeleted
public:
 event EventHandler<SignalNetworkViewModelAlteredConnection^>^ ConnectionDeleted {
    void add (EventHandler<SignalNetworkViewModelAlteredConnection^>^ value);
    void remove (EventHandler<SignalNetworkViewModelAlteredConnection^>^ value);
}

Value

Type: SystemEventHandlerSignalNetworkViewModelAlteredConnection
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ConnectorInfoChanged Event

SignalNetworkViewModelConnectorInfoChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ConnectorViewModel> ConnectorInfoChanged
public:
 event EventHandler<ConnectorViewModel^>^ ConnectorInfoChanged {
    void add (EventHandler<ConnectorViewModel^>^ value);
    void remove (EventHandler<ConnectorViewModel^>^ value);
}

Value

Type: SystemEventHandlerConnectorViewModel
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ConnectorPressed Event

SignalNetworkViewModelConnectorPressed Event

Occurs when the ConnectorItem (connector's "ball") is pressed

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler ConnectorPressed
public:
 event EventHandler^ ConnectorPressed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.DragCompleted Event

SignalNetworkViewModelDragCompleted Event

Occurs when the user finishes dragging out a connector

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler DragCompleted
public:
 event EventHandler^ DragCompleted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.DragStarted Event

SignalNetworkViewModelDragStarted Event

Occurs when the user starts dragging out a connector

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler DragStarted
public:
 event EventHandler^ DragStarted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.SelectedComponentChanged Event

SignalNetworkViewModelSelectedComponentChanged Event

Occurs when the network is built for the newly selected component

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler SelectedComponentChanged
public:
 event EventHandler^ SelectedComponentChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.SelectedConnectorChanged Event

SignalNetworkViewModelSelectedConnectorChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler SelectedConnectorChanged
public:
 event EventHandler^ SelectedConnectorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.SelectedNodeChanged Event

SignalNetworkViewModelSelectedNodeChanged Event

Occurs when the user double-clicks the node's header

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler SelectedNodeChanged
public:
 event EventHandler^ SelectedNodeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel Fields

The SignalNetworkViewModel type exposes the following members.

Fields
 | Name | Description
 | AllowConnectionDragging |
 | AllowConnectionsDuringSimulation |
 | AllowHidingNetworkMap |
 | AllowNonAbstractConnections |
 | AllowSignalToggling |
Public field | CandidateFill |
Public field | CandidateSilhouette |
 | ChangeSelectionOnComponentDoubleClick |
 | ChangeSelectionOnNodeTitleDoubleClick |
 | ColorHighlightedListItems |
 | ComponentGhostMode |
Public field | ConnectedFill |
Public field | ConnectedSilhouette |
 | DeferredNodeInitializationThreshold |
Public field | DisconnectFill |
Public field | DisconnectSilhouette |
 | DoubleClickSize |
 | DoubleClickSpeed |
 | EnableNodeVirtualization |
 | HiddenConnectionsListItemNaming |
 | HiddenConnectionsNodeVisibility |
Public field | HighlightFill |
Public field | HighlightSilhouette |
 | IndirectConnectionsVisibility |
Public field | InitializedConnections |
Public field | InvalidComponents |
 | ListItemAlternativeNamingThreshold |
Public field | MainNode |
 | NetworkMapVisibilityThreshold |
 | NodeVisibilityThreshold |
 | NonAbstractSelectionMode |
 | PossibleCandidatesHighlighting |
 | SetMaterialToNodeTree |
 | ShowOnlyMatchingInterfaces |
Public field | SimplifiedGhostFill |
 | SnapDoubleClickCancelAction |
 | UseSimplifiedMaterialInGhostMode |
Public field | ValidComponents |
Protected field | Views | (Inherited from ViewAware.)
Top
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.AllowConnectionDragging Field

SignalNetworkViewModelAllowConnectionDragging Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool AllowConnectionDragging
public:
static bool AllowConnectionDragging

Field Value

Type: Boolean
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.AllowConnectionsDuringSimulation Field

SignalNetworkViewModelAllowConnectionsDuringSimulation Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const bool AllowConnectionsDuringSimulation = false
public:
literal bool AllowConnectionsDuringSimulation = false

Field Value

Type: Boolean
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.AllowHidingNetworkMap Field

SignalNetworkViewModelAllowHidingNetworkMap Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const bool AllowHidingNetworkMap = true
public:
literal bool AllowHidingNetworkMap = true

Field Value

Type: Boolean
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.AllowNonAbstractConnections Field

SignalNetworkViewModelAllowNonAbstractConnections Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const bool AllowNonAbstractConnections = true
public:
literal bool AllowNonAbstractConnections = true

Field Value

Type: Boolean
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.AllowSignalToggling Field

SignalNetworkViewModelAllowSignalToggling Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const bool AllowSignalToggling = true
public:
literal bool AllowSignalToggling = true

Field Value

Type: Boolean
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.CandidateFill Field

SignalNetworkViewModelCandidateFill Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public readonly Color CandidateFill
public:
initonly Color CandidateFill

Field Value

Type: Color
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.CandidateSilhouette Field

SignalNetworkViewModelCandidateSilhouette Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public readonly Color CandidateSilhouette
public:
initonly Color CandidateSilhouette

Field Value

Type: Color
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ChangeSelectionOnComponentDoubleClick Field

SignalNetworkViewModelChangeSelectionOnComponentDoubleClick Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool ChangeSelectionOnComponentDoubleClick
public:
static bool ChangeSelectionOnComponentDoubleClick

Field Value

Type: Boolean
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ChangeSelectionOnNodeTitleDoubleClick Field

SignalNetworkViewModelChangeSelectionOnNodeTitleDoubleClick Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool ChangeSelectionOnNodeTitleDoubleClick
public:
static bool ChangeSelectionOnNodeTitleDoubleClick

Field Value

Type: Boolean
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ColorHighlightedListItems Field

SignalNetworkViewModelColorHighlightedListItems Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const bool ColorHighlightedListItems = true
public:
literal bool ColorHighlightedListItems = true

Field Value

Type: Boolean
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ComponentGhostMode Field

SignalNetworkViewModelComponentGhostMode Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const SignalNetworkViewModelGhostMode ComponentGhostMode = SignalNetworkViewModelGhostMode.NonMatching
public:
literal SignalNetworkViewModelGhostMode ComponentGhostMode = SignalNetworkViewModelGhostMode.NonMatching

Field Value

Type: SignalNetworkViewModelGhostMode
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ConnectedFill Field

SignalNetworkViewModelConnectedFill Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public readonly Color ConnectedFill
public:
initonly Color ConnectedFill

Field Value

Type: Color
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ConnectedSilhouette Field

SignalNetworkViewModelConnectedSilhouette Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public readonly Color ConnectedSilhouette
public:
initonly Color ConnectedSilhouette

Field Value

Type: Color
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.DeferredNodeInitializationThreshold Field

SignalNetworkViewModelDeferredNodeInitializationThreshold Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int DeferredNodeInitializationThreshold = 400
public:
literal int DeferredNodeInitializationThreshold = 400

Field Value

Type: Int32
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.DisconnectFill Field

SignalNetworkViewModelDisconnectFill Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public readonly Color DisconnectFill
public:
initonly Color DisconnectFill

Field Value

Type: Color
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.DisconnectSilhouette Field

SignalNetworkViewModelDisconnectSilhouette Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public readonly Color DisconnectSilhouette
public:
initonly Color DisconnectSilhouette

Field Value

Type: Color
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.DoubleClickSize Field

SignalNetworkViewModelDoubleClickSize Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Size DoubleClickSize
public:
static Size DoubleClickSize

Field Value

Type: Size
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.DoubleClickSpeed Field

SignalNetworkViewModelDoubleClickSpeed Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int DoubleClickSpeed
public:
static int DoubleClickSpeed

Field Value

Type: Int32
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.EnableNodeVirtualization Field

SignalNetworkViewModelEnableNodeVirtualization Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool EnableNodeVirtualization
public:
static bool EnableNodeVirtualization

Field Value

Type: Boolean
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.HiddenConnectionsListItemNaming Field

SignalNetworkViewModelHiddenConnectionsListItemNaming Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const SignalNetworkViewModelConnectionMode HiddenConnectionsListItemNaming = SignalNetworkViewModelConnectionMode.Interface
public:
literal SignalNetworkViewModelConnectionMode HiddenConnectionsListItemNaming = SignalNetworkViewModelConnectionMode.Interface

Field Value

Type: SignalNetworkViewModelConnectionMode
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.HiddenConnectionsNodeVisibility Field

SignalNetworkViewModelHiddenConnectionsNodeVisibility Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const SignalNetworkViewModelConnectionMode HiddenConnectionsNodeVisibility = SignalNetworkViewModelConnectionMode.Component
public:
literal SignalNetworkViewModelConnectionMode HiddenConnectionsNodeVisibility = SignalNetworkViewModelConnectionMode.Component

Field Value

Type: SignalNetworkViewModelConnectionMode
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.HighlightFill Field

SignalNetworkViewModelHighlightFill Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public readonly Color HighlightFill
public:
initonly Color HighlightFill

Field Value

Type: Color
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.HighlightSilhouette Field

SignalNetworkViewModelHighlightSilhouette Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public readonly Color HighlightSilhouette
public:
initonly Color HighlightSilhouette

Field Value

Type: Color
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.IndirectConnectionsVisibility Field

SignalNetworkViewModelIndirectConnectionsVisibility Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static SignalNetworkViewModelConnectionMode IndirectConnectionsVisibility
public:
static SignalNetworkViewModelConnectionMode IndirectConnectionsVisibility

Field Value

Type: SignalNetworkViewModelConnectionMode
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.InitializedConnections Field

SignalNetworkViewModelInitializedConnections Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Dictionary<NodeViewModel, SignalNetworkViewModelConnectionStore> InitializedConnections
public:
Dictionary<NodeViewModel^, SignalNetworkViewModelConnectionStore^>^ InitializedConnections

Field Value

Type: DictionaryNodeViewModel, SignalNetworkViewModelConnectionStore
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.InvalidComponents Field

SignalNetworkViewModelInvalidComponents Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public HashSet<INamed> InvalidComponents
public:
HashSet<INamed^>^ InvalidComponents

Field Value

Type: HashSetINamed
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ListItemAlternativeNamingThreshold Field

SignalNetworkViewModelListItemAlternativeNamingThreshold Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int ListItemAlternativeNamingThreshold
public:
static int ListItemAlternativeNamingThreshold

Field Value

Type: Int32
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.MainNode Field

SignalNetworkViewModelMainNode Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NodeViewModel MainNode
public:
NodeViewModel^ MainNode

Field Value

Type: NodeViewModel
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.NetworkMapVisibilityThreshold Field

SignalNetworkViewModelNetworkMapVisibilityThreshold Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const int NetworkMapVisibilityThreshold = 700
public:
literal int NetworkMapVisibilityThreshold = 700

Field Value

Type: Int32
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.NodeVisibilityThreshold Field

SignalNetworkViewModelNodeVisibilityThreshold Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int NodeVisibilityThreshold
public:
static int NodeVisibilityThreshold

Field Value

Type: Int32
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.NonAbstractSelectionMode Field

SignalNetworkViewModelNonAbstractSelectionMode Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const SignalNetworkViewModelNonAbstractMode NonAbstractSelectionMode = SignalNetworkViewModelNonAbstractMode.ComponentsAndInterfaces
public:
literal SignalNetworkViewModelNonAbstractMode NonAbstractSelectionMode = SignalNetworkViewModelNonAbstractMode.ComponentsAndInterfaces

Field Value

Type: SignalNetworkViewModelNonAbstractMode
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.PossibleCandidatesHighlighting Field

SignalNetworkViewModelPossibleCandidatesHighlighting Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const SignalNetworkViewModelConnectionMode PossibleCandidatesHighlighting = SignalNetworkViewModelConnectionMode.Component
public:
literal SignalNetworkViewModelConnectionMode PossibleCandidatesHighlighting = SignalNetworkViewModelConnectionMode.Component

Field Value

Type: SignalNetworkViewModelConnectionMode
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.SetMaterialToNodeTree Field

SignalNetworkViewModelSetMaterialToNodeTree Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const bool SetMaterialToNodeTree = true
public:
literal bool SetMaterialToNodeTree = true

Field Value

Type: Boolean
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ShowOnlyMatchingInterfaces Field

SignalNetworkViewModelShowOnlyMatchingInterfaces Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool ShowOnlyMatchingInterfaces
public:
static bool ShowOnlyMatchingInterfaces

Field Value

Type: Boolean
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.SimplifiedGhostFill Field

SignalNetworkViewModelSimplifiedGhostFill Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public readonly Color SimplifiedGhostFill
public:
initonly Color SimplifiedGhostFill

Field Value

Type: Color
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.SnapDoubleClickCancelAction Field

SignalNetworkViewModelSnapDoubleClickCancelAction Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public const SignalNetworkViewModelDoubleClickCancelAction SnapDoubleClickCancelAction = SignalNetworkViewModelDoubleClickCancelAction.PerformTwoSingleClicks
public:
literal SignalNetworkViewModelDoubleClickCancelAction SnapDoubleClickCancelAction = SignalNetworkViewModelDoubleClickCancelAction.PerformTwoSingleClicks

Field Value

Type: SignalNetworkViewModelDoubleClickCancelAction
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.UseSimplifiedMaterialInGhostMode Field

SignalNetworkViewModelUseSimplifiedMaterialInGhostMode Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool UseSimplifiedMaterialInGhostMode
public:
static bool UseSimplifiedMaterialInGhostMode

Field Value

Type: Boolean
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ValidComponents Field

SignalNetworkViewModelValidComponents Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Dictionary<INamed, bool> ValidComponents
public:
Dictionary<INamed^, bool>^ ValidComponents

Field Value

Type: DictionaryINamed, Boolean
See Also

Reference

SignalNetworkViewModel Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.AlteredConnection Class

SignalNetworkViewModelAlteredConnection Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedSignalNetworkViewModelAlteredConnection

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class AlteredConnection
public ref class AlteredConnection

The SignalNetworkViewModelAlteredConnection type exposes the following members.

Constructors
 | Name | Description
Public method | SignalNetworkViewModelAlteredConnection | Initializes a new instance of the SignalNetworkViewModelAlteredConnection class
Top
Properties
 | Name | Description
Public property | Connection |
Public property | DestConnector |
Public property | DestNode |
Public property | SourceConnector |
Public property | SourceNode |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.AlteredConnection Constructor

SignalNetworkViewModelAlteredConnection Constructor

Initializes a new instance of the SignalNetworkViewModelAlteredConnection class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AlteredConnection(
    ConnectionViewModel connection
)
public:
AlteredConnection(
    ConnectionViewModel^ connection
)

Parameters

connection
Type: VisualComponents.UX.Shared.NetworkMapConnectionViewModel
See Also

Reference

SignalNetworkViewModelAlteredConnection Class
VisualComponents.UX.Shared Namespace


AlteredConnection Properties

The SignalNetworkViewModelAlteredConnection type exposes the following members.

Properties
 | Name | Description
Public property | Connection |
Public property | DestConnector |
Public property | DestNode |
Public property | SourceConnector |
Public property | SourceNode |
Top
See Also

Reference

SignalNetworkViewModelAlteredConnection Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.AlteredConnection.Connection Property

SignalNetworkViewModelAlteredConnectionConnection Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectionViewModel Connection { get; set; }
public:
property ConnectionViewModel^ Connection {
    ConnectionViewModel^ get ();
    void set (ConnectionViewModel^ value);
}

Property Value

Type: ConnectionViewModel
See Also

Reference

SignalNetworkViewModelAlteredConnection Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.AlteredConnection.DestConnector Property

SignalNetworkViewModelAlteredConnectionDestConnector Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectorViewModel DestConnector { get; set; }
public:
property ConnectorViewModel^ DestConnector {
    ConnectorViewModel^ get ();
    void set (ConnectorViewModel^ value);
}

Property Value

Type: ConnectorViewModel
See Also

Reference

SignalNetworkViewModelAlteredConnection Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.AlteredConnection.DestNode Property

SignalNetworkViewModelAlteredConnectionDestNode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NodeViewModel DestNode { get; set; }
public:
property NodeViewModel^ DestNode {
    NodeViewModel^ get ();
    void set (NodeViewModel^ value);
}

Property Value

Type: NodeViewModel
See Also

Reference

SignalNetworkViewModelAlteredConnection Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.AlteredConnection.SourceConnector Property

SignalNetworkViewModelAlteredConnectionSourceConnector Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectorViewModel SourceConnector { get; set; }
public:
property ConnectorViewModel^ SourceConnector {
    ConnectorViewModel^ get ();
    void set (ConnectorViewModel^ value);
}

Property Value

Type: ConnectorViewModel
See Also

Reference

SignalNetworkViewModelAlteredConnection Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.AlteredConnection.SourceNode Property

SignalNetworkViewModelAlteredConnectionSourceNode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public NodeViewModel SourceNode { get; set; }
public:
property NodeViewModel^ SourceNode {
    NodeViewModel^ get ();
    void set (NodeViewModel^ value);
}

Property Value

Type: NodeViewModel
See Also

Reference

SignalNetworkViewModelAlteredConnection Class
VisualComponents.UX.Shared Namespace


AlteredConnection Methods

The SignalNetworkViewModelAlteredConnection type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SignalNetworkViewModelAlteredConnection Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ConnectionMode Enumeration

SignalNetworkViewModelConnectionMode Enumeration

Defines which hidden connections (connections that do not go to selected interface) should be taken into account

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ConnectionMode
public enum class ConnectionMode
Members
Member name | Value | Description
Component | 0 |
Interface | 1 |
All | 2 |
None | 3 |
See Also

Reference

VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ConnectionStore Class

SignalNetworkViewModelConnectionStore Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedSignalNetworkViewModelConnectionStore

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ConnectionStore
public ref class ConnectionStore

The SignalNetworkViewModelConnectionStore type exposes the following members.

Constructors
 | Name | Description
Public method | SignalNetworkViewModelConnectionStore | Initializes a new instance of the SignalNetworkViewModelConnectionStore class
Top
Properties
 | Name | Description
Public property | InputConnectionPairs |
Public property | InputMap |
Public property | OutputConnectionPairs |
Public property | OutputMap |
Public property | UndefinedConnectionPairs |
Public property | UndefinedSignals |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ConnectionStore Constructor

SignalNetworkViewModelConnectionStore Constructor

Initializes a new instance of the SignalNetworkViewModelConnectionStore class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ConnectionStore(
    List<SignalConnectionPair> inputPairs,
    List<SignalConnectionPair> outputPairs,
    List<SignalConnectionPair> undefinedPairs,
    ISignalMap inputMap,
    ISignalMap outputMap,
    List<SignalInformation> undefinedSignals
)
public:
ConnectionStore(
    List<SignalConnectionPair^>^ inputPairs,
    List<SignalConnectionPair^>^ outputPairs,
    List<SignalConnectionPair^>^ undefinedPairs,
    ISignalMap^ inputMap,
    ISignalMap^ outputMap,
    List<SignalInformation^>^ undefinedSignals
)

Parameters

inputPairs
Type: System.Collections.GenericListSignalConnectionPair
outputPairs
Type: System.Collections.GenericListSignalConnectionPair
undefinedPairs
Type: System.Collections.GenericListSignalConnectionPair
inputMap
Type: VisualComponents.Create3DISignalMap
outputMap
Type: VisualComponents.Create3DISignalMap
undefinedSignals
Type: System.Collections.GenericListSignalInformation
See Also

Reference

SignalNetworkViewModelConnectionStore Class
VisualComponents.UX.Shared Namespace


ConnectionStore Properties

The SignalNetworkViewModelConnectionStore type exposes the following members.

Properties
 | Name | Description
Public property | InputConnectionPairs |
Public property | InputMap |
Public property | OutputConnectionPairs |
Public property | OutputMap |
Public property | UndefinedConnectionPairs |
Public property | UndefinedSignals |
Top
See Also

Reference

SignalNetworkViewModelConnectionStore Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ConnectionStore.InputConnectionPairs Property

SignalNetworkViewModelConnectionStoreInputConnectionPairs Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<SignalConnectionPair> InputConnectionPairs { get; set; }
public:
property List<SignalConnectionPair^>^ InputConnectionPairs {
    List<SignalConnectionPair^>^ get ();
    void set (List<SignalConnectionPair^>^ value);
}

Property Value

Type: ListSignalConnectionPair
See Also

Reference

SignalNetworkViewModelConnectionStore Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ConnectionStore.InputMap Property

SignalNetworkViewModelConnectionStoreInputMap Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISignalMap InputMap { get; set; }
public:
property ISignalMap^ InputMap {
    ISignalMap^ get ();
    void set (ISignalMap^ value);
}

Property Value

Type: ISignalMap
See Also

Reference

SignalNetworkViewModelConnectionStore Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ConnectionStore.OutputConnectionPairs Property

SignalNetworkViewModelConnectionStoreOutputConnectionPairs Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<SignalConnectionPair> OutputConnectionPairs { get; set; }
public:
property List<SignalConnectionPair^>^ OutputConnectionPairs {
    List<SignalConnectionPair^>^ get ();
    void set (List<SignalConnectionPair^>^ value);
}

Property Value

Type: ListSignalConnectionPair
See Also

Reference

SignalNetworkViewModelConnectionStore Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ConnectionStore.OutputMap Property

SignalNetworkViewModelConnectionStoreOutputMap Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ISignalMap OutputMap { get; set; }
public:
property ISignalMap^ OutputMap {
    ISignalMap^ get ();
    void set (ISignalMap^ value);
}

Property Value

Type: ISignalMap
See Also

Reference

SignalNetworkViewModelConnectionStore Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ConnectionStore.UndefinedConnectionPairs Property

SignalNetworkViewModelConnectionStoreUndefinedConnectionPairs Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<SignalConnectionPair> UndefinedConnectionPairs { get; set; }
public:
property List<SignalConnectionPair^>^ UndefinedConnectionPairs {
    List<SignalConnectionPair^>^ get ();
    void set (List<SignalConnectionPair^>^ value);
}

Property Value

Type: ListSignalConnectionPair
See Also

Reference

SignalNetworkViewModelConnectionStore Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.ConnectionStore.UndefinedSignals Property

SignalNetworkViewModelConnectionStoreUndefinedSignals Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<SignalInformation> UndefinedSignals { get; set; }
public:
property List<SignalInformation^>^ UndefinedSignals {
    List<SignalInformation^>^ get ();
    void set (List<SignalInformation^>^ value);
}

Property Value

Type: ListSignalInformation
See Also

Reference

SignalNetworkViewModelConnectionStore Class
VisualComponents.UX.Shared Namespace


ConnectionStore Methods

The SignalNetworkViewModelConnectionStore type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SignalNetworkViewModelConnectionStore Class
VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.DoubleClickCancelAction Enumeration

SignalNetworkViewModelDoubleClickCancelAction Enumeration

Defines how snap action should behave when two clicks were performed within DoubleClickSpeed interval, but in two positions, difference between which is bigger than the DoubleClickWidth

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum DoubleClickCancelAction
public enum class DoubleClickCancelAction
Members
Member name | Value | Description
PerformSingleClick | 0 |
PerformTwoSingleClicks | 1 |
None | 2 |
Disabled | 3 |
See Also

Reference

VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.GhostMode Enumeration

SignalNetworkViewModelGhostMode Enumeration

Defines which components should be rendered in ghost mode

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum GhostMode
public enum class GhostMode
Members
Member name | Value | Description
Invalid | 0 |
NonMatching | 1 |
None | 2 |
See Also

Reference

VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.NodeExpansionMode Enumeration

SignalNetworkViewModelNodeExpansionMode Enumeration

Describes how node expansion works

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum NodeExpansionMode
public enum class NodeExpansionMode
Members
Member name | Value | Description
All | 0 |
Main | 1 |
Connected | 2 |
ConnectedToMain | 3 |
Locked | 4 |
See Also

Reference

VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.NodePinningMode Enumeration

SignalNetworkViewModelNodePinningMode Enumeration

Describes how node pinning works

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum NodePinningMode
public enum class NodePinningMode
Members
Member name | Value | Description
PreserveOnActionDeactivate | 0 |
PreserveOnComponentChange | 1 |
PreserveOnInterfaceSignalChange | 2 |
ResetOnNodeVisibilityChange | 3 |
DoNotPreserve | 4 |
Disabled | 5 |
See Also

Reference

VisualComponents.UX.Shared Namespace


SignalNetworkViewModel.NonAbstractMode Enumeration

SignalNetworkViewModelNonAbstractMode Enumeration

Controls whether non-abstract components and interfaces can be selected

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum NonAbstractMode
public enum class NonAbstractMode
Members
Member name | Value | Description
Interfaces | 0 |
ComponentsAndInterfaces | 1 |
None | 2 |
See Also

Reference

VisualComponents.UX.Shared Namespace


SimNode3DPickerView Class

Interaction logic for SimNode3DPickerView.xaml
SimNode3DPickerView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedSimNode3DPickerView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SimNode3DPickerView : UserControl,
    IComponentConnector, IStyleConnector
public ref class SimNode3DPickerView : public UserControl,
    IComponentConnector, IStyleConnector

The SimNode3DPickerView type exposes the following members.

Constructors
 | Name | Description
Public method | SimNode3DPickerView | Initializes a new instance of the SimNode3DPickerView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | PropertyLists |
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | OpenLookupDialog |
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
_searchHint |
PropertyListsProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SimNode3DPickerView Constructor

Initializes a new instance of the SimNode3DPickerView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SimNode3DPickerView()
public:
SimNode3DPickerView()
See Also

Reference

SimNode3DPickerView Class
VisualComponents.UX.Shared Namespace


SimNode3DPickerView Properties

The SimNode3DPickerView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | PropertyLists |
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

SimNode3DPickerView Class
VisualComponents.UX.Shared Namespace


SimNode3DPickerView.PropertyLists Property

SimNode3DPickerViewPropertyLists Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<IListProperty> PropertyLists { get; set; }
public:
property List<IListProperty^>^ PropertyLists {
    List<IListProperty^>^ get ();
    void set (List<IListProperty^>^ value);
}

Property Value

Type: ListIListProperty
See Also

Reference

SimNode3DPickerView Class
VisualComponents.UX.Shared Namespace


SimNode3DPickerView Methods

The SimNode3DPickerView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | OpenLookupDialog |
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SimNode3DPickerView Class
VisualComponents.UX.Shared Namespace


SimNode3DPickerView.InitializeComponent Method

SimNode3DPickerViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

SimNode3DPickerView Class
VisualComponents.UX.Shared Namespace


SimNode3DPickerView.OpenLookupDialog Method

SimNode3DPickerViewOpenLookupDialog Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<IResult> OpenLookupDialog()
public:
IEnumerable<IResult^>^ OpenLookupDialog()

Return Value

Type: IEnumerableIResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SimNode3DPickerView.OpenLookupDialog"]

See Also

Reference

SimNode3DPickerView Class
VisualComponents.UX.Shared Namespace


SimNode3DPickerView Events

The SimNode3DPickerView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

SimNode3DPickerView Class
VisualComponents.UX.Shared Namespace


SimNode3DPickerView Fields

The SimNode3DPickerView type exposes the following members.

Fields
Name | Description
_searchHint |
PropertyListsProperty |
Top
See Also

Reference

SimNode3DPickerView Class
VisualComponents.UX.Shared Namespace


SimNode3DPickerView._searchHint Field

SimNode3DPickerView_searchHint Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string _searchHint
public:
static String^ _searchHint

Field Value

Type: String
See Also

Reference

SimNode3DPickerView Class
VisualComponents.UX.Shared Namespace


SimNode3DPickerView.PropertyListsProperty Field

SimNode3DPickerViewPropertyListsProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty PropertyListsProperty
public:
static DependencyProperty^ PropertyListsProperty

Field Value

Type: DependencyProperty
See Also

Reference

SimNode3DPickerView Class
VisualComponents.UX.Shared Namespace


SimplePropertyEditorView Class

Interaction logic for SimplePropertyEditorView.xaml
SimplePropertyEditorView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedUserControlOptimizedView
VisualComponents.UX.SharedSimplePropertyEditorView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SimplePropertyEditorView : UserControlOptimizedView,
    IComponentConnector
public ref class SimplePropertyEditorView : public UserControlOptimizedView,
    IComponentConnector

The SimplePropertyEditorView type exposes the following members.

Constructors
 | Name | Description
Public method | SimplePropertyEditorView | Initializes a new instance of the SimplePropertyEditorView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | (Inherited from UserControlOptimizedView.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SimplePropertyEditorView Constructor

Initializes a new instance of the SimplePropertyEditorView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SimplePropertyEditorView()
public:
SimplePropertyEditorView()
See Also

Reference

SimplePropertyEditorView Class
VisualComponents.UX.Shared Namespace


SimplePropertyEditorView Properties

The SimplePropertyEditorView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

SimplePropertyEditorView Class
VisualComponents.UX.Shared Namespace


SimplePropertyEditorView Methods

The SimplePropertyEditorView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | (Inherited from UserControlOptimizedView.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SimplePropertyEditorView Class
VisualComponents.UX.Shared Namespace


SimplePropertyEditorView.InitializeComponent Method

SimplePropertyEditorViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

SimplePropertyEditorView Class
VisualComponents.UX.Shared Namespace


SimplePropertyEditorView Events

The SimplePropertyEditorView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

SimplePropertyEditorView Class
VisualComponents.UX.Shared Namespace


SimulationControlView Class

Interaction logic for SimulationControlView.xaml
SimulationControlView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedUserControlOptimizedView
VisualComponents.UX.SharedSimulationControlView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SimulationControlView : UserControlOptimizedView,
    IComponentConnector
public ref class SimulationControlView : public UserControlOptimizedView,
    IComponentConnector

The SimulationControlView type exposes the following members.

Constructors
 | Name | Description
Public method | SimulationControlView | Initializes a new instance of the SimulationControlView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | (Inherited from UserControlOptimizedView.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SimulationControlView Constructor

Initializes a new instance of the SimulationControlView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SimulationControlView()
public:
SimulationControlView()
See Also

Reference

SimulationControlView Class
VisualComponents.UX.Shared Namespace


SimulationControlView Properties

The SimulationControlView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

SimulationControlView Class
VisualComponents.UX.Shared Namespace


SimulationControlView Methods

The SimulationControlView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | (Inherited from UserControlOptimizedView.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SimulationControlView Class
VisualComponents.UX.Shared Namespace


SimulationControlView.InitializeComponent Method

SimulationControlViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

SimulationControlView Class
VisualComponents.UX.Shared Namespace


SimulationControlView Events

The SimulationControlView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

SimulationControlView Class
VisualComponents.UX.Shared Namespace


SimulationModeEnumToBoolConveter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedSimulationModeEnumToBoolConveter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SimulationModeEnumToBoolConveter : IValueConverter
public ref class SimulationModeEnumToBoolConveter : IValueConverter

The SimulationModeEnumToBoolConveter type exposes the following members.

Constructors
 | Name | Description
Public method | SimulationModeEnumToBoolConveter | Initializes a new instance of the SimulationModeEnumToBoolConveter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SimulationModeEnumToBoolConveter Constructor

Initializes a new instance of the SimulationModeEnumToBoolConveter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SimulationModeEnumToBoolConveter()
public:
SimulationModeEnumToBoolConveter()
See Also

Reference

SimulationModeEnumToBoolConveter Class
VisualComponents.UX.Shared Namespace


SimulationModeEnumToBoolConveter Methods

The SimulationModeEnumToBoolConveter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SimulationModeEnumToBoolConveter Class
VisualComponents.UX.Shared Namespace


SimulationModeEnumToBoolConveter.Convert Method

SimulationModeEnumToBoolConveterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SimulationModeEnumToBoolConveter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

SimulationModeEnumToBoolConveter Class
VisualComponents.UX.Shared Namespace


SimulationModeEnumToBoolConveter.ConvertBack Method

SimulationModeEnumToBoolConveterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SimulationModeEnumToBoolConveter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

SimulationModeEnumToBoolConveter Class
VisualComponents.UX.Shared Namespace


SimulationModeEnumToForegroundConveter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedSimulationModeEnumToForegroundConveter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SimulationModeEnumToForegroundConveter : IValueConverter
public ref class SimulationModeEnumToForegroundConveter : IValueConverter

The SimulationModeEnumToForegroundConveter type exposes the following members.

Constructors
 | Name | Description
Public method | SimulationModeEnumToForegroundConveter | Initializes a new instance of the SimulationModeEnumToForegroundConveter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SimulationModeEnumToForegroundConveter Constructor

Initializes a new instance of the SimulationModeEnumToForegroundConveter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SimulationModeEnumToForegroundConveter()
public:
SimulationModeEnumToForegroundConveter()
See Also

Reference

SimulationModeEnumToForegroundConveter Class
VisualComponents.UX.Shared Namespace


SimulationModeEnumToForegroundConveter Methods

The SimulationModeEnumToForegroundConveter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SimulationModeEnumToForegroundConveter Class
VisualComponents.UX.Shared Namespace


SimulationModeEnumToForegroundConveter.Convert Method

SimulationModeEnumToForegroundConveterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SimulationModeEnumToForegroundConveter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

SimulationModeEnumToForegroundConveter Class
VisualComponents.UX.Shared Namespace


SimulationModeEnumToForegroundConveter.ConvertBack Method

SimulationModeEnumToForegroundConveterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SimulationModeEnumToForegroundConveter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

SimulationModeEnumToForegroundConveter Class
VisualComponents.UX.Shared Namespace


SimulationSettingView Class

Interaction logic for SimulationSettingView.xaml
SimulationSettingView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedUserControlOptimizedView
VisualComponents.UX.SharedSimulationSettingView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SimulationSettingView : UserControlOptimizedView,
    IComponentConnector
public ref class SimulationSettingView : public UserControlOptimizedView,
    IComponentConnector

The SimulationSettingView type exposes the following members.

Constructors
 | Name | Description
Public method | SimulationSettingView | Initializes a new instance of the SimulationSettingView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | (Inherited from UserControlOptimizedView.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SimulationSettingView Constructor

Initializes a new instance of the SimulationSettingView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SimulationSettingView()
public:
SimulationSettingView()
See Also

Reference

SimulationSettingView Class
VisualComponents.UX.Shared Namespace


SimulationSettingView Properties

The SimulationSettingView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

SimulationSettingView Class
VisualComponents.UX.Shared Namespace


SimulationSettingView Methods

The SimulationSettingView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | (Inherited from UserControlOptimizedView.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SimulationSettingView Class
VisualComponents.UX.Shared Namespace


SimulationSettingView.InitializeComponent Method

SimulationSettingViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

SimulationSettingView Class
VisualComponents.UX.Shared Namespace


SimulationSettingView Events

The SimulationSettingView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

SimulationSettingView Class
VisualComponents.UX.Shared Namespace


SimulationStateBasedBehavior Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.WindowsFreezable
System.Windows.Media.AnimationAnimatable
Behavior
BehaviorGrid
VisualComponents.UX.SharedSimulationStateBasedBehavior

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SimulationStateBasedBehavior : Behavior<Grid>
public ref class SimulationStateBasedBehavior : public Behavior<Grid^>

The SimulationStateBasedBehavior type exposes the following members.

Constructors
 | Name | Description
Public method | SimulationStateBasedBehavior | Initializes a new instance of the SimulationStateBasedBehavior class
Top
Properties
 | Name | Description
Protected property | AssociatedObject | (Inherited from BehaviorGrid.)
Protected property | AssociatedType | (Inherited from Behavior.)
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Inherited from Animatable.)
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | Property |
Public property | TargetGrid |
Top
Methods
 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | Attach | (Inherited from Behavior.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of this Animatable, making deep copies of this object's values. When copying this object's dependency properties, this method copies resource references and data bindings (but they might no longer resolve) but not animations or their current values. (Inherited from Animatable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | (Inherited from Behavior.)
Public method | Detach | (Inherited from Behavior.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to . (Inherited from Freezable.)
Protected method | FreezeCore | Makes this Animatable object unmodifiable or determines whether it can be made unmodifiable. (Inherited from Animatable.)
Public method | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Inherited from Animatable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
 | GetTargetProperty |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttached | (Overrides Behavior.OnAttached.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnDetaching | (Overrides Behavior.OnDetaching.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
 | SetTargetProperty |
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
Events
 | Name | Description
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Top
Fields
Name | Description
TargetPropertyProperty |
Top
Attached Properties
 | Name | Description
Public attached property | TargetProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SimulationStateBasedBehavior Constructor

Initializes a new instance of the SimulationStateBasedBehavior class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SimulationStateBasedBehavior()
public:
SimulationStateBasedBehavior()
See Also

Reference

SimulationStateBasedBehavior Class
VisualComponents.UX.Shared Namespace


SimulationStateBasedBehavior Properties

The SimulationStateBasedBehavior type exposes the following members.

Properties
 | Name | Description
Protected property | AssociatedObject | (Inherited from BehaviorGrid.)
Protected property | AssociatedType | (Inherited from Behavior.)
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Inherited from Animatable.)
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | Property |
Public property | TargetGrid |
Top
See Also

Reference

SimulationStateBasedBehavior Class
VisualComponents.UX.Shared Namespace


SimulationStateBasedBehavior.Property Property

SimulationStateBasedBehaviorProperty Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProperty Property { get; set; }
public:
property IProperty^ Property {
    IProperty^ get ();
    void set (IProperty^ value);
}

Property Value

Type: IProperty
See Also

Reference

SimulationStateBasedBehavior Class
VisualComponents.UX.Shared Namespace


SimulationStateBasedBehavior.TargetGrid Property

SimulationStateBasedBehaviorTargetGrid Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Grid TargetGrid { get; set; }
public:
property Grid^ TargetGrid {
    Grid^ get ();
    void set (Grid^ value);
}

Property Value

Type: Grid
See Also

Reference

SimulationStateBasedBehavior Class
VisualComponents.UX.Shared Namespace


SimulationStateBasedBehavior Methods

The SimulationStateBasedBehavior type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | Attach | (Inherited from Behavior.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of this Animatable, making deep copies of this object's values. When copying this object's dependency properties, this method copies resource references and data bindings (but they might no longer resolve) but not animations or their current values. (Inherited from Animatable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | (Inherited from Behavior.)
Public method | Detach | (Inherited from Behavior.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to . (Inherited from Freezable.)
Protected method | FreezeCore | Makes this Animatable object unmodifiable or determines whether it can be made unmodifiable. (Inherited from Animatable.)
Public method | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Inherited from Animatable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
 | GetTargetProperty |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttached | (Overrides Behavior.OnAttached.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnDetaching | (Overrides Behavior.OnDetaching.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
 | SetTargetProperty |
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SimulationStateBasedBehavior Class
VisualComponents.UX.Shared Namespace


SimulationStateBasedBehavior.GetTargetProperty Method

SimulationStateBasedBehaviorGetTargetProperty Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IProperty GetTargetProperty(
    DependencyObject obj
)
public:
static IProperty^ GetTargetProperty(
    DependencyObject^ obj
)

Parameters

obj
Type: System.WindowsDependencyObject

Return Value

Type: IProperty

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SimulationStateBasedBehavior.GetTargetProperty(System.Windows.DependencyObject)"]

See Also

Reference

SimulationStateBasedBehavior Class
VisualComponents.UX.Shared Namespace


SimulationStateBasedBehavior.OnAttached Method

SimulationStateBasedBehaviorOnAttached Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnAttached()
protected:
virtual void OnAttached() override
See Also

Reference

SimulationStateBasedBehavior Class
VisualComponents.UX.Shared Namespace


SimulationStateBasedBehavior.OnDetaching Method

SimulationStateBasedBehaviorOnDetaching Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnDetaching()
protected:
virtual void OnDetaching() override
See Also

Reference

SimulationStateBasedBehavior Class
VisualComponents.UX.Shared Namespace


SimulationStateBasedBehavior.SetTargetProperty Method

SimulationStateBasedBehaviorSetTargetProperty Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetTargetProperty(
    DependencyObject obj,
    IProperty value
)
public:
static void SetTargetProperty(
    DependencyObject^ obj,
    IProperty^ value
)

Parameters

obj
Type: System.WindowsDependencyObject
value
Type: VisualComponents.Create3DIProperty
See Also

Reference

SimulationStateBasedBehavior Class
VisualComponents.UX.Shared Namespace


SimulationStateBasedBehavior Events

The SimulationStateBasedBehavior type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Top
See Also

Reference

SimulationStateBasedBehavior Class
VisualComponents.UX.Shared Namespace


SimulationStateBasedBehavior Fields

The SimulationStateBasedBehavior type exposes the following members.

Fields
Name | Description
TargetPropertyProperty |
Top
See Also

Reference

SimulationStateBasedBehavior Class
VisualComponents.UX.Shared Namespace


SimulationStateBasedBehavior.TargetPropertyProperty Field

SimulationStateBasedBehaviorTargetPropertyProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty TargetPropertyProperty
public:
static initonly DependencyProperty^ TargetPropertyProperty

Field Value

Type: DependencyProperty
See Also

Reference

SimulationStateBasedBehavior Class
VisualComponents.UX.Shared Namespace


SimulationStateBasedBehavior Attached Properties

The SimulationStateBasedBehavior type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | TargetProperty |
Top
See Also

Reference

SimulationStateBasedBehavior Class
VisualComponents.UX.Shared Namespace


SimulationStateBasedBehavior.TargetProperty Attached Property

SimulationStateBasedBehaviorTargetProperty Attached Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See GetTargetProperty, SetTargetProperty
See GetTargetProperty, SetTargetProperty

Property Value

Type: IProperty
See Also

Reference

SimulationStateBasedBehavior Class
VisualComponents.UX.Shared Namespace


SimulationStateChangedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
VisualComponents.UX.SharedSimulationStateChangedEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SimulationStateChangedEventArgs : EventArgs
public ref class SimulationStateChangedEventArgs : public EventArgs

The SimulationStateChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SimulationStateChangedEventArgs | Initializes a new instance of the SimulationStateChangedEventArgs class
Top
Properties
 | Name | Description
Public property | IsCanceled |
Top
Methods
 | Name | Description
Public method | Cancel |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SimulationStateChangedEventArgs Constructor

Initializes a new instance of the SimulationStateChangedEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SimulationStateChangedEventArgs()
public:
SimulationStateChangedEventArgs()
See Also

Reference

SimulationStateChangedEventArgs Class
VisualComponents.UX.Shared Namespace


SimulationStateChangedEventArgs Properties

The SimulationStateChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | IsCanceled |
Top
See Also

Reference

SimulationStateChangedEventArgs Class
VisualComponents.UX.Shared Namespace


SimulationStateChangedEventArgs.IsCanceled Property

SimulationStateChangedEventArgsIsCanceled Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsCanceled { get; }
public:
property bool IsCanceled {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

SimulationStateChangedEventArgs Class
VisualComponents.UX.Shared Namespace


SimulationStateChangedEventArgs Methods

The SimulationStateChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Cancel |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SimulationStateChangedEventArgs Class
VisualComponents.UX.Shared Namespace


SimulationStateChangedEventArgs.Cancel Method

SimulationStateChangedEventArgsCancel Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Cancel()
public:
void Cancel()
See Also

Reference

SimulationStateChangedEventArgs Class
VisualComponents.UX.Shared Namespace


SimulationTimePicker Class

Bitmap control which allows changing bitmaproperty by using bitmap object or file location.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.Controls.PrimitivesTextBoxBase
System.Windows.ControlsTextBox
VisualComponents.UX.SharedSimulationTimePicker

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SimulationTimePicker : TextBox
public ref class SimulationTimePicker : public TextBox

The SimulationTimePicker type exposes the following members.

Constructors
 | Name | Description
Public method | SimulationTimePicker | Initializes a new instance of the SimulationTimePicker class
Top
Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key. (Inherited from TextBoxBase.)
Public property | AcceptsTab | Gets or sets a value that indicates how the text editing control responds when the user presses the TAB key. (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoWordSelection | Gets or sets a value that determines whether when a user selects part of a word by dragging across it with the mouse, the rest of the word is selected. (Inherited from TextBoxBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanRedo | Gets a value that indicates whether the most recent undo action can be redone. (Inherited from TextBoxBase.)
Public property | CanUndo | Gets a value that indicates whether the most recent action can be undone. (Inherited from TextBoxBase.)
Public property | CaretBrush | Gets or sets the brush that is used to paint the caret of the text box. (Inherited from TextBoxBase.)
Public property | CaretIndex | Gets or sets the insertion position index of the caret. (Inherited from TextBox.)
Public property | CharacterCasing | Gets or sets how characters are cased when they are manually entered into the text box. (Inherited from TextBox.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExtentHeight | Gets the vertical size of the visible content area. (Inherited from TextBoxBase.)
Public property | ExtentWidth | Gets the horizontal size of the visible content area. (Inherited from TextBoxBase.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Gets or sets the horizontal scroll position. (Inherited from TextBoxBase.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal scroll bar is shown. (Inherited from TextBoxBase.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInactiveSelectionHighlightEnabled | Gets or sets a value that indicates whether the text box displays selected text when the text box does not have focus. (Inherited from TextBoxBase.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that indicates whether the text editing control is read-only to a user interacting with the control. (Inherited from TextBoxBase.)
Public property | IsReadOnlyCaretVisible | Gets or sets a value that indicates whether a read-only text box displays a caret. (Inherited from TextBoxBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionActive | Gets a value that indicates whether the text box has focus and selected text. (Inherited from TextBoxBase.)
Public property | IsSimulationTimePickingCompleted |
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets a value that indicates whether undo support is enabled for the text-editing control. (Inherited from TextBoxBase.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | LineCount | Gets the total number of lines in the text box. (Inherited from TextBox.)
Protected property | LogicalChildren | Gets an enumerator for the logical child elements of the TextBox. (Inherited from TextBox.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxLength | Gets or sets the maximum number of characters that can be manually entered into the text box. (Inherited from TextBox.)
Public property | MaxLines | Gets or sets the maximum number of visible lines. (Inherited from TextBox.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinLines | Gets or sets the minimum number of visible lines. (Inherited from TextBox.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedText | Gets or sets the content of the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionBrush | Gets or sets the brush that highlights selected text. (Inherited from TextBoxBase.)
Public property | SelectionLength | Gets or sets a value indicating the number of characters in the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionOpacity | Gets or sets the opacity of the SelectionBrush. (Inherited from TextBoxBase.)
Public property | SelectionStart | Gets or sets a character index for the beginning of the current selection. (Inherited from TextBox.)
Public property | SimulationTime |
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | SpellCheck | Gets a SpellCheck object that provides access to spelling errors in the text contents of a TextBoxBase or RichTextBox. (Inherited from TextBoxBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Gets or sets the text contents of the text box. (Inherited from TextBox.)
Public property | TextAlignment | Gets or sets the horizontal alignment of the contents of the text box. (Inherited from TextBox.)
Public property | TextDecorations | Gets the text decorations to apply to the text box. (Inherited from TextBox.)
Public property | TextWrapping | Gets or sets how the text box should wrap text. (Inherited from TextBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Typography | Gets the currently effective typography variations for the text contents of the text box. (Inherited from TextBox.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UndoLimit | Gets or sets the number of actions stored in the undo queue. (Inherited from TextBoxBase.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Gets or sets the vertical scroll position. (Inherited from TextBoxBase.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical scroll bar is shown. (Inherited from TextBoxBase.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | ViewportHeight | Gets the vertical size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | ViewportWidth | Gets the horizontal size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AppendText | Appends a string to the contents of a text control. (Inherited from TextBoxBase.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginChange | Begins a change block. (Inherited from TextBoxBase.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | Clears all the content from the text box. (Inherited from TextBox.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Copy | Copies the current selection of the text editing control to the Clipboard. (Inherited from TextBoxBase.)
Public method | Cut | Removes the current selection from the text editing control and copies it to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeclareChangeBlock | Creates a change block. (Inherited from TextBoxBase.)
Public method | EndChange | Ends a change block. (Inherited from TextBoxBase.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetCharacterIndexFromLineIndex | Returns the zero-based character index for the first character in the specified line. (Inherited from TextBox.)
Public method | GetCharacterIndexFromPoint | Returns the zero-based index of the character that is closest to the specified point. (Inherited from TextBox.)
Public method | GetFirstVisibleLineIndex | Returns the line index for the first line that is currently visible in the text box. (Inherited from TextBox.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLastVisibleLineIndex | Returns the line index for the last line that is currently visible in the text box. (Inherited from TextBox.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLineIndexFromCharacterIndex | Returns the zero-based line index for the line that contains the specified character index. (Inherited from TextBox.)
Public method | GetLineLength | Returns the number of characters in the specified line. (Inherited from TextBox.)
Public method | GetLineText | Returns the text that is currently displayed on the specified line. (Inherited from TextBox.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetNextSpellingErrorCharacterIndex | Returns the beginning character index for the next spelling error in the contents of the text box. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32) | Returns the rectangle for the leading edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32, Boolean) | Returns the rectangle for the leading or trailing edge of the character at the specified index. (Inherited from TextBox.)
 | GetSelectAllMode |
Public method | GetSpellingError | Returns a SpellingError object associated with any spelling error at the specified character index. (Inherited from TextBox.)
Public method | GetSpellingErrorLength | Returns the length of any spelling error that includes the specified character. (Inherited from TextBox.)
Public method | GetSpellingErrorStart | Returns the beginning character index for any spelling error that includes the specified character. (Inherited from TextBox.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls the contents of the control down by one line. (Inherited from TextBoxBase.)
Public method | LineLeft | Scrolls the contents of the control to the left by one line. (Inherited from TextBoxBase.)
Public method | LineRight | Scrolls the contents of the control to the right by one line. (Inherited from TextBoxBase.)
Public method | LineUp | Scrolls the contents of the control upward by one line. (Inherited from TextBoxBase.)
Public method | LockCurrentUndoUnit | Locks the most recent undo unit of the undo stack of the application. This prevents the locked unit from being merged with undo units that are added subsequently. (Inherited from TextBoxBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Sizes the text box to its content. (Inherited from TextBox.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides TextBoxBaseOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Called whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for the text box. (Inherited from TextBox.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragLeave | Invoked whenever an unhandled DragLeave attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragOver | Invoked whenever an unhandled DragOver attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDrop | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGiveFeedback | Invoked whenever an unhandled GiveFeedback attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked whenever an unhandled GotKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked whenever an unhandled KeyDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnKeyUp | Invoked whenever an unhandled KeyUp attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostFocus | Raises the LostFocus event (using the provided arguments). (Inherited from TextBoxBase.)
Protected method | OnLostKeyboardFocus | Invoked whenever an unhandled LostKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked whenever an unhandled MouseDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked whenever an unhandled MouseMove attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked whenever an unhandled MouseUp event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Is called when a MouseWheel event is routed to this class (or to a class that inherits from this class). (Inherited from TextBoxBase.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Called when the KeyDown occurs. (Inherited from TextBoxBase.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Called when one or more of the dependency properties that exist on the element have had their effective values changed. (Inherited from TextBox.)
Protected method | OnQueryContinueDrag | Invoked whenever an unhandled QueryContinueDrag attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnQueryCursor | Invoked whenever an unhandled QueryCursor attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Is called when the caret or current selection changes position. (Inherited from TextBoxBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Is called when the control template changes. (Inherited from TextBoxBase.)
Protected method | OnTextChanged | Is called when content in this editing control changes. (Inherited from TextBoxBase.)
Protected method | OnTextInput | Invoked whenever an unhandled TextInput attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | PageDown | Scrolls the contents of the control down by one page. (Inherited from TextBoxBase.)
Public method | PageLeft | Scrolls the contents of the control to the left by one page. (Inherited from TextBoxBase.)
Public method | PageRight | Scrolls the contents of the control to the right by one page. (Inherited from TextBoxBase.)
Public method | PageUp | Scrolls the contents of the control up by one page. (Inherited from TextBoxBase.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | Paste | Pastes the contents of the Clipboard over the current selection in the text editing control. (Inherited from TextBoxBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Redo | Undoes the most recent undo command. In other words, redoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollToEnd | Scrolls the view of the editing control to the end of the content. (Inherited from TextBoxBase.)
Public method | ScrollToHome | Scrolls the view of the editing control to the beginning of the viewport. (Inherited from TextBoxBase.)
Public method | ScrollToHorizontalOffset | Scrolls the contents of the editing control to the specified horizontal offset. (Inherited from TextBoxBase.)
Public method | ScrollToLine | Scrolls the line at the specified line index into view. (Inherited from TextBox.)
Public method | ScrollToVerticalOffset | Scrolls the contents of the editing control to the specified vertical offset. (Inherited from TextBoxBase.)
Public method | Select | Selects a range of text in the text box. (Inherited from TextBox.)
Public method | SelectAll | Selects all the contents of the text editing control. (Inherited from TextBoxBase.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
 | SetSelectAllMode |
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeText | Returns a value that indicates whether the effective value of the Text property should be serialized during serialization of the TextBox object. (Inherited from TextBox.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | Undo | Undoes the most recent undo command. In other words, undoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBoxBase.)
Public event | SimulationTimePickCompleted |
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextChanged | Occurs when content changes in the text element. (Inherited from TextBoxBase.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
IsSimulationTimePickingCompletedProperty |
SelectAllModeProperty |
SimulationTimePickCompletedEvent |
SimulationTimeProperty |
Top
Attached Properties
 | Name | Description
Public attached property | SelectAllMode |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SimulationTimePicker Constructor

Initializes a new instance of the SimulationTimePicker class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SimulationTimePicker()
public:
SimulationTimePicker()
See Also

Reference

SimulationTimePicker Class
VisualComponents.UX.Shared Namespace


SimulationTimePicker Properties

The SimulationTimePicker type exposes the following members.

Properties
 | Name | Description
Public property | AcceptsReturn | Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key. (Inherited from TextBoxBase.)
Public property | AcceptsTab | Gets or sets a value that indicates how the text editing control responds when the user presses the TAB key. (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | AutoWordSelection | Gets or sets a value that determines whether when a user selects part of a word by dragging across it with the mouse, the rest of the word is selected. (Inherited from TextBoxBase.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | CanRedo | Gets a value that indicates whether the most recent undo action can be redone. (Inherited from TextBoxBase.)
Public property | CanUndo | Gets a value that indicates whether the most recent action can be undone. (Inherited from TextBoxBase.)
Public property | CaretBrush | Gets or sets the brush that is used to paint the caret of the text box. (Inherited from TextBoxBase.)
Public property | CaretIndex | Gets or sets the insertion position index of the caret. (Inherited from TextBox.)
Public property | CharacterCasing | Gets or sets how characters are cased when they are manually entered into the text box. (Inherited from TextBox.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | ExtentHeight | Gets the vertical size of the visible content area. (Inherited from TextBoxBase.)
Public property | ExtentWidth | Gets the horizontal size of the visible content area. (Inherited from TextBoxBase.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | HorizontalOffset | Gets or sets the horizontal scroll position. (Inherited from TextBoxBase.)
Public property | HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal scroll bar is shown. (Inherited from TextBoxBase.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInactiveSelectionHighlightEnabled | Gets or sets a value that indicates whether the text box displays selected text when the text box does not have focus. (Inherited from TextBoxBase.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsReadOnly | Gets or sets a value that indicates whether the text editing control is read-only to a user interacting with the control. (Inherited from TextBoxBase.)
Public property | IsReadOnlyCaretVisible | Gets or sets a value that indicates whether a read-only text box displays a caret. (Inherited from TextBoxBase.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSelectionActive | Gets a value that indicates whether the text box has focus and selected text. (Inherited from TextBoxBase.)
Public property | IsSimulationTimePickingCompleted |
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsUndoEnabled | Gets or sets a value that indicates whether undo support is enabled for the text-editing control. (Inherited from TextBoxBase.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | LineCount | Gets the total number of lines in the text box. (Inherited from TextBox.)
Protected property | LogicalChildren | Gets an enumerator for the logical child elements of the TextBox. (Inherited from TextBox.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxLength | Gets or sets the maximum number of characters that can be manually entered into the text box. (Inherited from TextBox.)
Public property | MaxLines | Gets or sets the maximum number of visible lines. (Inherited from TextBox.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinLines | Gets or sets the minimum number of visible lines. (Inherited from TextBox.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedText | Gets or sets the content of the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionBrush | Gets or sets the brush that highlights selected text. (Inherited from TextBoxBase.)
Public property | SelectionLength | Gets or sets a value indicating the number of characters in the current selection in the text box. (Inherited from TextBox.)
Public property | SelectionOpacity | Gets or sets the opacity of the SelectionBrush. (Inherited from TextBoxBase.)
Public property | SelectionStart | Gets or sets a character index for the beginning of the current selection. (Inherited from TextBox.)
Public property | SimulationTime |
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | SpellCheck | Gets a SpellCheck object that provides access to spelling errors in the text contents of a TextBoxBase or RichTextBox. (Inherited from TextBoxBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Text | Gets or sets the text contents of the text box. (Inherited from TextBox.)
Public property | TextAlignment | Gets or sets the horizontal alignment of the contents of the text box. (Inherited from TextBox.)
Public property | TextDecorations | Gets the text decorations to apply to the text box. (Inherited from TextBox.)
Public property | TextWrapping | Gets or sets how the text box should wrap text. (Inherited from TextBox.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Typography | Gets the currently effective typography variations for the text contents of the text box. (Inherited from TextBox.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UndoLimit | Gets or sets the number of actions stored in the undo queue. (Inherited from TextBoxBase.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | VerticalOffset | Gets or sets the vertical scroll position. (Inherited from TextBoxBase.)
Public property | VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical scroll bar is shown. (Inherited from TextBoxBase.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | ViewportHeight | Gets the vertical size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | ViewportWidth | Gets the horizontal size of the scrollable content area. (Inherited from TextBoxBase.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

SimulationTimePicker Class
VisualComponents.UX.Shared Namespace


SimulationTimePicker.IsSimulationTimePickingCompleted Property

SimulationTimePickerIsSimulationTimePickingCompleted Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsSimulationTimePickingCompleted { get; }
public:
property bool IsSimulationTimePickingCompleted {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

SimulationTimePicker Class
VisualComponents.UX.Shared Namespace


SimulationTimePicker.SimulationTime Property

SimulationTimePickerSimulationTime Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SimulationTime { get; set; }
public:
property String^ SimulationTime {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SimulationTimePicker Class
VisualComponents.UX.Shared Namespace


SimulationTimePicker Methods

The SimulationTimePicker type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | AppendText | Appends a string to the contents of a text control. (Inherited from TextBoxBase.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginChange | Begins a change block. (Inherited from TextBoxBase.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | Clears all the content from the text box. (Inherited from TextBox.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Copy | Copies the current selection of the text editing control to the Clipboard. (Inherited from TextBoxBase.)
Public method | Cut | Removes the current selection from the text editing control and copies it to the Clipboard. (Inherited from TextBoxBase.)
Public method | DeclareChangeBlock | Creates a change block. (Inherited from TextBoxBase.)
Public method | EndChange | Ends a change block. (Inherited from TextBoxBase.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetCharacterIndexFromLineIndex | Returns the zero-based character index for the first character in the specified line. (Inherited from TextBox.)
Public method | GetCharacterIndexFromPoint | Returns the zero-based index of the character that is closest to the specified point. (Inherited from TextBox.)
Public method | GetFirstVisibleLineIndex | Returns the line index for the first line that is currently visible in the text box. (Inherited from TextBox.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLastVisibleLineIndex | Returns the line index for the last line that is currently visible in the text box. (Inherited from TextBox.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLineIndexFromCharacterIndex | Returns the zero-based line index for the line that contains the specified character index. (Inherited from TextBox.)
Public method | GetLineLength | Returns the number of characters in the specified line. (Inherited from TextBox.)
Public method | GetLineText | Returns the text that is currently displayed on the specified line. (Inherited from TextBox.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetNextSpellingErrorCharacterIndex | Returns the beginning character index for the next spelling error in the contents of the text box. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32) | Returns the rectangle for the leading edge of the character at the specified index. (Inherited from TextBox.)
Public method | GetRectFromCharacterIndex(Int32, Boolean) | Returns the rectangle for the leading or trailing edge of the character at the specified index. (Inherited from TextBox.)
 | GetSelectAllMode |
Public method | GetSpellingError | Returns a SpellingError object associated with any spelling error at the specified character index. (Inherited from TextBox.)
Public method | GetSpellingErrorLength | Returns the length of any spelling error that includes the specified character. (Inherited from TextBox.)
Public method | GetSpellingErrorStart | Returns the beginning character index for any spelling error that includes the specified character. (Inherited from TextBox.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | LineDown | Scrolls the contents of the control down by one line. (Inherited from TextBoxBase.)
Public method | LineLeft | Scrolls the contents of the control to the left by one line. (Inherited from TextBoxBase.)
Public method | LineRight | Scrolls the contents of the control to the right by one line. (Inherited from TextBoxBase.)
Public method | LineUp | Scrolls the contents of the control upward by one line. (Inherited from TextBoxBase.)
Public method | LockCurrentUndoUnit | Locks the most recent undo unit of the undo stack of the application. This prevents the locked unit from being merged with undo units that are added subsequently. (Inherited from TextBoxBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Sizes the text box to its content. (Inherited from TextBox.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides TextBoxBaseOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Called whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer object for the text box. (Inherited from TextBox.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragLeave | Invoked whenever an unhandled DragLeave attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDragOver | Invoked whenever an unhandled DragOver attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnDrop | Invoked whenever an unhandled DragEnter attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGiveFeedback | Invoked whenever an unhandled GiveFeedback attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked whenever an unhandled GotKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked whenever an unhandled KeyDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnKeyUp | Invoked whenever an unhandled KeyUp attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostFocus | Raises the LostFocus event (using the provided arguments). (Inherited from TextBoxBase.)
Protected method | OnLostKeyboardFocus | Invoked whenever an unhandled LostKeyboardFocus attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked whenever an unhandled MouseDown attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked whenever an unhandled MouseMove attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked whenever an unhandled MouseUp event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnMouseWheel | Is called when a MouseWheel event is routed to this class (or to a class that inherits from this class). (Inherited from TextBoxBase.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Called when the KeyDown occurs. (Inherited from TextBoxBase.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Called when one or more of the dependency properties that exist on the element have had their effective values changed. (Inherited from TextBox.)
Protected method | OnQueryContinueDrag | Invoked whenever an unhandled QueryContinueDrag attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnQueryCursor | Invoked whenever an unhandled QueryCursor attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSelectionChanged | Is called when the caret or current selection changes position. (Inherited from TextBoxBase.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Is called when the control template changes. (Inherited from TextBoxBase.)
Protected method | OnTextChanged | Is called when content in this editing control changes. (Inherited from TextBoxBase.)
Protected method | OnTextInput | Invoked whenever an unhandled TextInput attached routed event reaches an element derived from this class in its route. Implement this method to add class handling for this event. (Inherited from TextBoxBase.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Public method | PageDown | Scrolls the contents of the control down by one page. (Inherited from TextBoxBase.)
Public method | PageLeft | Scrolls the contents of the control to the left by one page. (Inherited from TextBoxBase.)
Public method | PageRight | Scrolls the contents of the control to the right by one page. (Inherited from TextBoxBase.)
Public method | PageUp | Scrolls the contents of the control up by one page. (Inherited from TextBoxBase.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | Paste | Pastes the contents of the Clipboard over the current selection in the text editing control. (Inherited from TextBoxBase.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | Redo | Undoes the most recent undo command. In other words, redoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ScrollToEnd | Scrolls the view of the editing control to the end of the content. (Inherited from TextBoxBase.)
Public method | ScrollToHome | Scrolls the view of the editing control to the beginning of the viewport. (Inherited from TextBoxBase.)
Public method | ScrollToHorizontalOffset | Scrolls the contents of the editing control to the specified horizontal offset. (Inherited from TextBoxBase.)
Public method | ScrollToLine | Scrolls the line at the specified line index into view. (Inherited from TextBox.)
Public method | ScrollToVerticalOffset | Scrolls the contents of the editing control to the specified vertical offset. (Inherited from TextBoxBase.)
Public method | Select | Selects a range of text in the text box. (Inherited from TextBox.)
Public method | SelectAll | Selects all the contents of the text editing control. (Inherited from TextBoxBase.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
 | SetSelectAllMode |
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeText | Returns a value that indicates whether the effective value of the Text property should be serialized during serialization of the TextBox object. (Inherited from TextBox.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | Undo | Undoes the most recent undo command. In other words, undoes the most recent undo unit on the undo stack. (Inherited from TextBoxBase.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SimulationTimePicker Class
VisualComponents.UX.Shared Namespace


SimulationTimePicker.GetSelectAllMode Method

SimulationTimePickerGetSelectAllMode Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Nullable<SelectAllMode> GetSelectAllMode(
    DependencyObject object
)
public:
static Nullable<SelectAllMode> GetSelectAllMode(
    DependencyObject^ object
)

Parameters

object
Type: System.WindowsDependencyObject

Return Value

Type: NullableSelectAllMode

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SimulationTimePicker.GetSelectAllMode(System.Windows.DependencyObject)"]

See Also

Reference

SimulationTimePicker Class
VisualComponents.UX.Shared Namespace


SimulationTimePicker.OnApplyTemplate Method

SimulationTimePickerOnApplyTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

SimulationTimePicker Class
VisualComponents.UX.Shared Namespace


SimulationTimePicker.SetSelectAllMode Method

SimulationTimePickerSetSelectAllMode Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetSelectAllMode(
    DependencyObject object,
    Nullable<SelectAllMode> value
)
public:
static void SetSelectAllMode(
    DependencyObject^ object,
    Nullable<SelectAllMode> value
)

Parameters

object
Type: System.WindowsDependencyObject
value
Type: SystemNullableSelectAllMode
See Also

Reference

SimulationTimePicker Class
VisualComponents.UX.Shared Namespace


SimulationTimePicker Events

The SimulationTimePicker type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SelectionChanged | Occurs when the text selection has changed. (Inherited from TextBoxBase.)
Public event | SimulationTimePickCompleted |
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextChanged | Occurs when content changes in the text element. (Inherited from TextBoxBase.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

SimulationTimePicker Class
VisualComponents.UX.Shared Namespace


SimulationTimePicker.SimulationTimePickCompleted Event

SimulationTimePickerSimulationTimePickCompleted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event RoutedEventHandler SimulationTimePickCompleted
public:
 event RoutedEventHandler^ SimulationTimePickCompleted {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

SimulationTimePicker Class
VisualComponents.UX.Shared Namespace


SimulationTimePicker Fields

The SimulationTimePicker type exposes the following members.

Fields
Name | Description
IsSimulationTimePickingCompletedProperty |
SelectAllModeProperty |
SimulationTimePickCompletedEvent |
SimulationTimeProperty |
Top
See Also

Reference

SimulationTimePicker Class
VisualComponents.UX.Shared Namespace


SimulationTimePicker.IsSimulationTimePickingCompletedProperty Field

SimulationTimePickerIsSimulationTimePickingCompletedProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty IsSimulationTimePickingCompletedProperty
public:
static DependencyProperty^ IsSimulationTimePickingCompletedProperty

Field Value

Type: DependencyProperty
See Also

Reference

SimulationTimePicker Class
VisualComponents.UX.Shared Namespace


SimulationTimePicker.SelectAllModeProperty Field

SimulationTimePickerSelectAllModeProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty SelectAllModeProperty
public:
static initonly DependencyProperty^ SelectAllModeProperty

Field Value

Type: DependencyProperty
See Also

Reference

SimulationTimePicker Class
VisualComponents.UX.Shared Namespace


SimulationTimePicker.SimulationTimePickCompletedEvent Field

SimulationTimePickerSimulationTimePickCompletedEvent Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly RoutedEvent SimulationTimePickCompletedEvent
public:
static initonly RoutedEvent^ SimulationTimePickCompletedEvent

Field Value

Type: RoutedEvent
See Also

Reference

SimulationTimePicker Class
VisualComponents.UX.Shared Namespace


SimulationTimePicker.SimulationTimeProperty Field

SimulationTimePickerSimulationTimeProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty SimulationTimeProperty
public:
static initonly DependencyProperty^ SimulationTimeProperty

Field Value

Type: DependencyProperty
See Also

Reference

SimulationTimePicker Class
VisualComponents.UX.Shared Namespace


SimulationTimePicker Attached Properties

The SimulationTimePicker type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | SelectAllMode |
Top
See Also

Reference

SimulationTimePicker Class
VisualComponents.UX.Shared Namespace


SimulationTimePicker.SelectAllMode Attached Property

SimulationTimePickerSelectAllMode Attached Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See GetSelectAllMode, SetSelectAllMode
See GetSelectAllMode, SetSelectAllMode

Property Value

Type: NullableSelectAllMode
See Also

Reference

SimulationTimePicker Class
VisualComponents.UX.Shared Namespace


SimulationTimePickerBlock Class

Bitmap control which allows changing bitmaproperty by using bitmap object or file location.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
VisualComponents.UX.SharedSimulationTimePickerBlock

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SimulationTimePickerBlock : ContentControl
public ref class SimulationTimePickerBlock : public ContentControl

The SimulationTimePickerBlock type exposes the following members.

Constructors
 | Name | Description
Public method | SimulationTimePickerBlock | Initializes a new instance of the SimulationTimePickerBlock class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSimulationTimePickingCompleted |
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SimulationTime |
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SimulationTimePickCompleted |
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
IsSimulationTimePickingCompletedProperty |
SimulationTimePickCompletedEvent |
SimulationTimeProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SimulationTimePickerBlock Constructor

Initializes a new instance of the SimulationTimePickerBlock class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SimulationTimePickerBlock()
public:
SimulationTimePickerBlock()
See Also

Reference

SimulationTimePickerBlock Class
VisualComponents.UX.Shared Namespace


SimulationTimePickerBlock Properties

The SimulationTimePickerBlock type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsSimulationTimePickingCompleted |
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SimulationTime |
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

SimulationTimePickerBlock Class
VisualComponents.UX.Shared Namespace


SimulationTimePickerBlock.IsSimulationTimePickingCompleted Property

SimulationTimePickerBlockIsSimulationTimePickingCompleted Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsSimulationTimePickingCompleted { get; }
public:
property bool IsSimulationTimePickingCompleted {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

SimulationTimePickerBlock Class
VisualComponents.UX.Shared Namespace


SimulationTimePickerBlock.SimulationTime Property

SimulationTimePickerBlockSimulationTime Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SimulationTime { get; set; }
public:
property String^ SimulationTime {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SimulationTimePickerBlock Class
VisualComponents.UX.Shared Namespace


SimulationTimePickerBlock Methods

The SimulationTimePickerBlock type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SimulationTimePickerBlock Class
VisualComponents.UX.Shared Namespace


SimulationTimePickerBlock.OnApplyTemplate Method

SimulationTimePickerBlockOnApplyTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

SimulationTimePickerBlock Class
VisualComponents.UX.Shared Namespace


SimulationTimePickerBlock Events

The SimulationTimePickerBlock type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SimulationTimePickCompleted |
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

SimulationTimePickerBlock Class
VisualComponents.UX.Shared Namespace


SimulationTimePickerBlock.SimulationTimePickCompleted Event

SimulationTimePickerBlockSimulationTimePickCompleted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event RoutedEventHandler SimulationTimePickCompleted
public:
 event RoutedEventHandler^ SimulationTimePickCompleted {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}

Value

Type: System.WindowsRoutedEventHandler
See Also

Reference

SimulationTimePickerBlock Class
VisualComponents.UX.Shared Namespace


SimulationTimePickerBlock Fields

The SimulationTimePickerBlock type exposes the following members.

Fields
Name | Description
IsSimulationTimePickingCompletedProperty |
SimulationTimePickCompletedEvent |
SimulationTimeProperty |
Top
See Also

Reference

SimulationTimePickerBlock Class
VisualComponents.UX.Shared Namespace


SimulationTimePickerBlock.IsSimulationTimePickingCompletedProperty Field

SimulationTimePickerBlockIsSimulationTimePickingCompletedProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static DependencyProperty IsSimulationTimePickingCompletedProperty
public:
static DependencyProperty^ IsSimulationTimePickingCompletedProperty

Field Value

Type: DependencyProperty
See Also

Reference

SimulationTimePickerBlock Class
VisualComponents.UX.Shared Namespace


SimulationTimePickerBlock.SimulationTimePickCompletedEvent Field

SimulationTimePickerBlockSimulationTimePickCompletedEvent Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly RoutedEvent SimulationTimePickCompletedEvent
public:
static initonly RoutedEvent^ SimulationTimePickCompletedEvent

Field Value

Type: RoutedEvent
See Also

Reference

SimulationTimePickerBlock Class
VisualComponents.UX.Shared Namespace


SimulationTimePickerBlock.SimulationTimeProperty Field

SimulationTimePickerBlockSimulationTimeProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty SimulationTimeProperty
public:
static initonly DependencyProperty^ SimulationTimeProperty

Field Value

Type: DependencyProperty
See Also

Reference

SimulationTimePickerBlock Class
VisualComponents.UX.Shared Namespace


SimulationTimeValidationRule Class

Inheritance Hierarchy
SystemObject
System.Windows.ControlsValidationRule
VisualComponents.UX.SharedSimulationTimeValidationRule

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SimulationTimeValidationRule : ValidationRule
public ref class SimulationTimeValidationRule : public ValidationRule

The SimulationTimeValidationRule type exposes the following members.

Constructors
 | Name | Description
Public method | SimulationTimeValidationRule | Initializes a new instance of the SimulationTimeValidationRule class
Top
Properties
 | Name | Description
Public property | AllowedValueContainer |
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadSettings |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SimulationTimeValidationRule Constructor

Initializes a new instance of the SimulationTimeValidationRule class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SimulationTimeValidationRule()
public:
SimulationTimeValidationRule()
See Also

Reference

SimulationTimeValidationRule Class
VisualComponents.UX.Shared Namespace


SimulationTimeValidationRule Properties

The SimulationTimeValidationRule type exposes the following members.

Properties
 | Name | Description
Public property | AllowedValueContainer |
Public property | ValidatesOnTargetUpdated | Gets or sets a value that indicates whether the validation rule runs when the target of the Binding is updated. (Inherited from ValidationRule.)
Public property | ValidationStep | Gets or sets when the validation rule runs. (Inherited from ValidationRule.)
Top
See Also

Reference

SimulationTimeValidationRule Class
VisualComponents.UX.Shared Namespace


SimulationTimeValidationRule.AllowedValueContainer Property

SimulationTimeValidationRuleAllowedValueContainer Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public AllowedValueContainer AllowedValueContainer { get; set; }
public:
property AllowedValueContainer^ AllowedValueContainer {
    AllowedValueContainer^ get ();
    void set (AllowedValueContainer^ value);
}

Property Value

Type: AllowedValueContainer
See Also

Reference

SimulationTimeValidationRule Class
VisualComponents.UX.Shared Namespace


SimulationTimeValidationRule Methods

The SimulationTimeValidationRule type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadSettings |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SimulationTimeValidationRule Class
VisualComponents.UX.Shared Namespace


SimulationTimeValidationRule.ReadSettings Method

SimulationTimeValidationRuleReadSettings Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ReadSettings()
public:
void ReadSettings()
See Also

Reference

SimulationTimeValidationRule Class
VisualComponents.UX.Shared Namespace


SimulationTimeValidationRule.Validate Method

SimulationTimeValidationRuleValidate Method

Overload List
 | Name | Description
Public method | Validate(Object, CultureInfo) | (Overrides ValidationRuleValidate(Object, CultureInfo).)
Public method | Validate(Object, CultureInfo, BindingExpressionBase) | Performs validation checks on a value. (Inherited from ValidationRule.)
Public method | Validate(Object, CultureInfo, BindingGroup) | Performs validation checks on a value. (Inherited from ValidationRule.)
Top
See Also

Reference

SimulationTimeValidationRule Class
VisualComponents.UX.Shared Namespace


SimulationTimeValidationRule.Validate Method (Object, CultureInfo)

SimulationTimeValidationRuleValidate Method (Object, CultureInfo)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override ValidationResult Validate(
    Object value,
    CultureInfo cultureInfo
)
public:
virtual ValidationResult^ Validate(
    Object^ value,
    CultureInfo^ cultureInfo
) override

Parameters

value
Type: SystemObject
cultureInfo
Type: System.GlobalizationCultureInfo

Return Value

Type: ValidationResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SimulationTimeValidationRule.Validate(System.Object,System.Globalization.CultureInfo)"]

See Also

Reference

SimulationTimeValidationRule Class
Validate Overload
VisualComponents.UX.Shared Namespace


SmoothActionErrorCode Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum SmoothActionErrorCode
public enum class SmoothActionErrorCode
Members
Member name | Value | Description
None | 0 |
NoRefs | 1 |
See Also

Reference

VisualComponents.UX.Shared Namespace


SnapAction Class

Action that waits for pick to snap in 3D world.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedSnapAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class SnapAction : IResult,
    IHandle<RequestActionAbortMessage>, IHandle, IHandle<MouseMessage>,
    IHandle<FinishSnapMessage>, IHandle<SnapCompletedMessage>, IHandle<SnapCompletedAltMessage>,
    IHandle<InternalEndInteractionMessage>
public ref class SnapAction sealed : IResult,
    IHandle<RequestActionAbortMessage^>, IHandle, IHandle<MouseMessage^>,
    IHandle<FinishSnapMessage^>, IHandle<SnapCompletedMessage^>, IHandle<SnapCompletedAltMessage^>,
    IHandle<InternalEndInteractionMessage^>

The SnapAction type exposes the following members.

Constructors
 | Name | Description
Public method | SnapAction | When optionsContext is not null, base action should inherit from ICommandPanelAction. baseAction-string is used to provide persistent snap settings for current "base" action. There settings are modified by commands listed in SnapSettings_* and SnapFilters_* UxSites.
Top
Properties
 | Name | Description
Public property | ActionSnapOptions |
Public property | CancelUpdateOnMouseStill |
Public property | CenterSnapOnControl |
Public property | CenterSnapOnShift |
Public property | ContinuousMode | Action does not end even when receiving SnapCompletedMessage. Instead is triggers Preview on every SnapCompletedMessage message
Public property | DontSnapToSelection | Two different cases: - in Jog mode don't snap to robot, nor it's tool (but can snap to it's frames) - otherwise don't snap to properties panel item (which can be frame, component, feature, etc)
Public property | DontSnapToSelectionLevel | 0 - snap to selection, 1 - don't snap to selection if possible, 2 - don't snap to selection period.
Public property | HasResult |
Public property | HideFocusAtTheEnd |
Public property | IsFinished |
Public property | IsSnappingEnabled | Defines if the snapping is enabled or not.
Public property | Modifiers |
Public property | NodeList | Gets all the instaces of NodeListEntry defining the pickable nodes for this instance of SnapAction. When set, this will override value nodeFilter passed to snapping methods.
Public property | PublishResult |
Public property | SecondaryResults |
Public property | SingleActionCustomSnapper |
Public property | SnapOnBoundType |
Public property | SnapOnCurveLoop |
Public property | SnapOnFreePoint |
Public property | SnapOnFullTopology |
Public property | SnapOnlyToTarget |
Public property | SnapOnMouseUp |
Public property | SnapOnSinglePart |
Public property | SnapResult |
Public property | SnapResultSecondary | Obsolete.
Public property | SnapToSelectionFirst | Two different cases: - in Jog mode first snap only to robot, it's tool, and it's frames. Then snap on everything else. - snap to properties panel item (which can be frame, component, feature, etc) first. Then to everything else.
Public property | WantSurfaceNormal |
Public property | X |
Public property | Y |
Top
Methods
 | Name | Description
Public method | EndAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetMouseState |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle(FinishSnapMessage) | Update snapping results after mouse is still for 2 seconds
Public method | Handle(InternalEndInteractionMessage) |
Public method | Handle(MouseMessage) |
Public method | Handle(RequestActionAbortMessage) |
Public method | Handle(SnapCompletedAltMessage) | Handle MouseUp event
Public method | Handle(SnapCompletedMessage) | Handle MouseDown event
 | HideFocusAndText | Hides focus indicator and window message. Normally this is called together with Completed event. Except when SnapAction is created with stayResident=false, then we need to hide it manually.
Public method | SetNodeList | Set the instance of NodeListEntry for this instance of SnapAction.
Public method | SnapToXY | Populates this.SnapResult property. Assumes that USnapOptionsViewModel is configured correctly. Returns whether this function was aborted by mouse movements.
Public method | SnapToXYFilters | Method indended for one-shot snapping (not stayResident).
Public method | ToggleSnapToSelection |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Completed |
Public event | ContinuousResultMouseDown |
Public event | ContinuousResultMouseMove |
Public event | ContinuousSnapCompleted |
Public event | SnapResultFound |
Top
Fields
Name | Description
DebugDonutSnap |
LongestSnapActionTook |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SnapAction Constructor

When optionsContext is not null, base action should inherit from ICommandPanelAction. baseAction-string is used to provide persistent snap settings for current "base" action. There settings are modified by commands listed in SnapSettings_* and SnapFilters_* UxSites.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SnapAction(
    bool stayResident,
    string snapOptionsContext,
    SnapType[] actionSnapOptions = null,
    ICustomSnapper customSnapper = null
)
public:
SnapAction(
    bool stayResident,
    String^ snapOptionsContext,
    array<SnapType>^ actionSnapOptions = nullptr,
    ICustomSnapper^ customSnapper = nullptr
)

Parameters

stayResident
Type: SystemBoolean
snapOptionsContext
Type: SystemString
actionSnapOptions (Optional)
Type: VisualComponents.Create3DSnapType
customSnapper (Optional)
Type: VisualComponents.Create3DICustomSnapper
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction Properties

The SnapAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionSnapOptions |
Public property | CancelUpdateOnMouseStill |
Public property | CenterSnapOnControl |
Public property | CenterSnapOnShift |
Public property | ContinuousMode | Action does not end even when receiving SnapCompletedMessage. Instead is triggers Preview on every SnapCompletedMessage message
Public property | DontSnapToSelection | Two different cases: - in Jog mode don't snap to robot, nor it's tool (but can snap to it's frames) - otherwise don't snap to properties panel item (which can be frame, component, feature, etc)
Public property | DontSnapToSelectionLevel | 0 - snap to selection, 1 - don't snap to selection if possible, 2 - don't snap to selection period.
Public property | HasResult |
Public property | HideFocusAtTheEnd |
Public property | IsFinished |
Public property | IsSnappingEnabled | Defines if the snapping is enabled or not.
Public property | Modifiers |
Public property | NodeList | Gets all the instaces of NodeListEntry defining the pickable nodes for this instance of SnapAction. When set, this will override value nodeFilter passed to snapping methods.
Public property | PublishResult |
Public property | SecondaryResults |
Public property | SingleActionCustomSnapper |
Public property | SnapOnBoundType |
Public property | SnapOnCurveLoop |
Public property | SnapOnFreePoint |
Public property | SnapOnFullTopology |
Public property | SnapOnlyToTarget |
Public property | SnapOnMouseUp |
Public property | SnapOnSinglePart |
Public property | SnapResult |
Public property | SnapResultSecondary | Obsolete.
Public property | SnapToSelectionFirst | Two different cases: - in Jog mode first snap only to robot, it's tool, and it's frames. Then snap on everything else. - snap to properties panel item (which can be frame, component, feature, etc) first. Then to everything else.
Public property | WantSurfaceNormal |
Public property | X |
Public property | Y |
Top
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.ActionSnapOptions Property

SnapActionActionSnapOptions Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SnapType[] ActionSnapOptions { get; set; }
public:
property array<SnapType>^ ActionSnapOptions {
    array<SnapType>^ get ();
    void set (array<SnapType>^ value);
}

Property Value

Type: SnapType
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.CancelUpdateOnMouseStill Property

SnapActionCancelUpdateOnMouseStill Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CancelUpdateOnMouseStill { get; set; }
public:
property bool CancelUpdateOnMouseStill {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.CenterSnapOnControl Property

SnapActionCenterSnapOnControl Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CenterSnapOnControl { get; set; }
public:
property bool CenterSnapOnControl {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.CenterSnapOnShift Property

SnapActionCenterSnapOnShift Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool CenterSnapOnShift { get; set; }
public:
property bool CenterSnapOnShift {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.ContinuousMode Property

SnapActionContinuousMode Property

Action does not end even when receiving SnapCompletedMessage. Instead is triggers Preview on every SnapCompletedMessage message

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ContinuousMode { get; set; }
public:
property bool ContinuousMode {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.DontSnapToSelection Property

SnapActionDontSnapToSelection Property

Two different cases: - in Jog mode don't snap to robot, nor it's tool (but can snap to it's frames) - otherwise don't snap to properties panel item (which can be frame, component, feature, etc)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool DontSnapToSelection { get; set; }
public:
property bool DontSnapToSelection {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.DontSnapToSelectionLevel Property

SnapActionDontSnapToSelectionLevel Property

0 - snap to selection, 1 - don't snap to selection if possible, 2 - don't snap to selection period.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int DontSnapToSelectionLevel { get; set; }
public:
property int DontSnapToSelectionLevel {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.HasResult Property

SnapActionHasResult Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HasResult { get; }
public:
property bool HasResult {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.HideFocusAtTheEnd Property

SnapActionHideFocusAtTheEnd Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool HideFocusAtTheEnd { get; set; }
public:
property bool HideFocusAtTheEnd {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.IsFinished Property

SnapActionIsFinished Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsFinished { get; }
public:
property bool IsFinished {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.IsSnappingEnabled Property

SnapActionIsSnappingEnabled Property

Defines if the snapping is enabled or not.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsSnappingEnabled { get; set; }
public:
property bool IsSnappingEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.Modifiers Property

SnapActionModifiers Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ModifierKeys Modifiers { get; set; }
public:
property ModifierKeys Modifiers {
    ModifierKeys get ();
    void set (ModifierKeys value);
}

Property Value

Type: ModifierKeys
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.NodeList Property

SnapActionNodeList Property

Gets all the instaces of NodeListEntry defining the pickable nodes for this instance of SnapAction. When set, this will override value nodeFilter passed to snapping methods.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<NodeListEntry> NodeList { get; }
public:
property ReadOnlyCollection<NodeListEntry^>^ NodeList {
    ReadOnlyCollection<NodeListEntry^>^ get ();
}

Property Value

Type: ReadOnlyCollectionNodeListEntry
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.PublishResult Property

SnapActionPublishResult Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool PublishResult { get; set; }
public:
property bool PublishResult {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.SecondaryResults Property

SnapActionSecondaryResults Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<SecondarySnapResult> SecondaryResults { get; set; }
public:
property List<SecondarySnapResult^>^ SecondaryResults {
    List<SecondarySnapResult^>^ get ();
    void set (List<SecondarySnapResult^>^ value);
}

Property Value

Type: ListSecondarySnapResult
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.SingleActionCustomSnapper Property

SnapActionSingleActionCustomSnapper Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ICustomSnapper SingleActionCustomSnapper { get; set; }
public:
property ICustomSnapper^ SingleActionCustomSnapper {
    ICustomSnapper^ get ();
    void set (ICustomSnapper^ value);
}

Property Value

Type: ICustomSnapper
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.SnapOnBoundType Property

SnapActionSnapOnBoundType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SelectionTypes SnapOnBoundType { get; set; }
public:
property SelectionTypes SnapOnBoundType {
    SelectionTypes get ();
    void set (SelectionTypes value);
}

Property Value

Type: SelectionTypes
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.SnapOnCurveLoop Property

SnapActionSnapOnCurveLoop Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool SnapOnCurveLoop { get; set; }
public:
property bool SnapOnCurveLoop {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.SnapOnFreePoint Property

SnapActionSnapOnFreePoint Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<bool> SnapOnFreePoint { get; set; }
public:
property Nullable<bool> SnapOnFreePoint {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

Property Value

Type: NullableBoolean
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.SnapOnFullTopology Property

SnapActionSnapOnFullTopology Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool SnapOnFullTopology { get; set; }
public:
property bool SnapOnFullTopology {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.SnapOnlyToTarget Property

SnapActionSnapOnlyToTarget Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool SnapOnlyToTarget { get; set; }
public:
property bool SnapOnlyToTarget {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.SnapOnMouseUp Property

SnapActionSnapOnMouseUp Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool SnapOnMouseUp { get; set; }
public:
property bool SnapOnMouseUp {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.SnapOnSinglePart Property

SnapActionSnapOnSinglePart Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool SnapOnSinglePart { get; set; }
public:
property bool SnapOnSinglePart {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.SnapResult Property

SnapActionSnapResult Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SnapResult SnapResult { get; set; }
public:
property SnapResult SnapResult {
    SnapResult get ();
    void set (SnapResult value);
}

Property Value

Type: SnapResult
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.SnapResultSecondary Property

SnapActionSnapResultSecondary Property

Note: This API is now obsolete.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ObsoleteAttribute("Use SecondaryResults instead")]
public SnapResult SnapResultSecondary { get; }
public:
[ObsoleteAttribute(L"Use SecondaryResults instead")]
property SnapResult SnapResultSecondary {
    SnapResult get ();
}

Property Value

Type: SnapResult
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.SnapToSelectionFirst Property

SnapActionSnapToSelectionFirst Property

Two different cases: - in Jog mode first snap only to robot, it's tool, and it's frames. Then snap on everything else. - snap to properties panel item (which can be frame, component, feature, etc) first. Then to everything else.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool SnapToSelectionFirst { get; set; }
public:
property bool SnapToSelectionFirst {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.WantSurfaceNormal Property

SnapActionWantSurfaceNormal Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool WantSurfaceNormal { get; set; }
public:
property bool WantSurfaceNormal {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.X Property

SnapActionX Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int X { get; set; }
public:
property int X {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.Y Property

SnapActionY Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Y { get; set; }
public:
property int Y {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction Methods

The SnapAction type exposes the following members.

Methods
 | Name | Description
Public method | EndAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetMouseState |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle(FinishSnapMessage) | Update snapping results after mouse is still for 2 seconds
Public method | Handle(InternalEndInteractionMessage) |
Public method | Handle(MouseMessage) |
Public method | Handle(RequestActionAbortMessage) |
Public method | Handle(SnapCompletedAltMessage) | Handle MouseUp event
Public method | Handle(SnapCompletedMessage) | Handle MouseDown event
 | HideFocusAndText | Hides focus indicator and window message. Normally this is called together with Completed event. Except when SnapAction is created with stayResident=false, then we need to hide it manually.
Public method | SetNodeList | Set the instance of NodeListEntry for this instance of SnapAction.
Public method | SnapToXY | Populates this.SnapResult property. Assumes that USnapOptionsViewModel is configured correctly. Returns whether this function was aborted by mouse movements.
Public method | SnapToXYFilters | Method indended for one-shot snapping (not stayResident).
Public method | ToggleSnapToSelection |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.EndAction Method

SnapActionEndAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void EndAction(
    bool isCanceled,
    bool notifyAboutEndedAction
)
public:
void EndAction(
    bool isCanceled,
    bool notifyAboutEndedAction
)

Parameters

isCanceled
Type: SystemBoolean
notifyAboutEndedAction
Type: SystemBoolean
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.Execute Method

SnapActionExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    ActionExecutionContext context
)
public:
virtual void Execute(
    ActionExecutionContext^ context
) sealed

Parameters

context
Type: ActionExecutionContext

Implements

IResult.Execute(ActionExecutionContext)
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.GetMouseState Method

SnapActionGetMouseState Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Tuple<MouseHelperPOINTSTRUCT, int, int> GetMouseState()
public:
static Tuple<MouseHelperPOINTSTRUCT, int, int>^ GetMouseState()

Return Value

Type: TupleMouseHelperPOINTSTRUCT, Int32, Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SnapAction.GetMouseState"]

See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.Handle Method

SnapActionHandle Method

Overload List
 | Name | Description
Public method | Handle(FinishSnapMessage) | Update snapping results after mouse is still for 2 seconds
Public method | Handle(InternalEndInteractionMessage) |
Public method | Handle(MouseMessage) |
Public method | Handle(RequestActionAbortMessage) |
Public method | Handle(SnapCompletedAltMessage) | Handle MouseUp event
Public method | Handle(SnapCompletedMessage) | Handle MouseDown event
Top
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.Handle Method (FinishSnapMessage)

SnapActionHandle Method (FinishSnapMessage)

Update snapping results after mouse is still for 2 seconds

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    FinishSnapMessage message
)
public:
virtual void Handle(
    FinishSnapMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedFinishSnapMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

SnapAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


SnapAction.Handle Method (InternalEndInteractionMessage)

SnapActionHandle Method (InternalEndInteractionMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    InternalEndInteractionMessage message
)
public:
virtual void Handle(
    InternalEndInteractionMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedInternalEndInteractionMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

SnapAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


SnapAction.Handle Method (MouseMessage)

SnapActionHandle Method (MouseMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    MouseMessage message
)
public:
virtual void Handle(
    MouseMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedMouseMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

SnapAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


SnapAction.Handle Method (RequestActionAbortMessage)

SnapActionHandle Method (RequestActionAbortMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    RequestActionAbortMessage message
)
public:
virtual void Handle(
    RequestActionAbortMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedRequestActionAbortMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

SnapAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


SnapAction.Handle Method (SnapCompletedAltMessage)

SnapActionHandle Method (SnapCompletedAltMessage)

Handle MouseUp event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    SnapCompletedAltMessage message
)
public:
virtual void Handle(
    SnapCompletedAltMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedSnapCompletedAltMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

SnapAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


SnapAction.Handle Method (SnapCompletedMessage)

SnapActionHandle Method (SnapCompletedMessage)

Handle MouseDown event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    SnapCompletedMessage message
)
public:
virtual void Handle(
    SnapCompletedMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedSnapCompletedMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

SnapAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


SnapAction.HideFocusAndText Method

SnapActionHideFocusAndText Method

Hides focus indicator and window message. Normally this is called together with Completed event. Except when SnapAction is created with stayResident=false, then we need to hide it manually.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void HideFocusAndText()
public:
static void HideFocusAndText()
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.SetNodeList Method

SnapActionSetNodeList Method

Set the instance of NodeListEntry for this instance of SnapAction.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void SetNodeList(
    IEnumerable<NodeListEntry> nodeListEntries
)
public:
void SetNodeList(
    IEnumerable<NodeListEntry^>^ nodeListEntries
)

Parameters

nodeListEntries
Type: System.Collections.GenericIEnumerableNodeListEntry
Node list entries that define pickable nodes for this action.
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.SnapToXY Method

SnapActionSnapToXY Method

Populates this.SnapResult property. Assumes that USnapOptionsViewModel is configured correctly. Returns whether this function was aborted by mouse movements.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool SnapToXY(
    int x,
    int y,
    bool publishResult,
    bool allowAborting,
    Nullable<IntPtr> nodeFilter = null,
    SnapType[] singleTimeFilters = null,
    bool forceEstimate = false
)
public:
bool SnapToXY(
    int x,
    int y,
    bool publishResult,
    bool allowAborting,
    Nullable<IntPtr> nodeFilter = nullptr,
    array<SnapType>^ singleTimeFilters = nullptr,
    bool forceEstimate = false
)

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
publishResult
Type: SystemBoolean
allowAborting
Type: SystemBoolean
nodeFilter (Optional)
Type: SystemNullableIntPtr
singleTimeFilters (Optional)
Type: VisualComponents.Create3DSnapType
forceEstimate (Optional)
Type: SystemBoolean

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SnapAction.SnapToXY(System.Int32,System.Int32,System.Boolean,System.Boolean,System.Nullable{System.IntPtr},VisualComponents.Create3D.SnapType[],System.Boolean)"]

Remarks
Handles Path Select Statements, Snap Actions (among maybe other things)
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.SnapToXYFilters Method

SnapActionSnapToXYFilters Method

Method indended for one-shot snapping (not stayResident).

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool SnapToXYFilters(
    int x,
    int y,
    bool publishResult,
    bool allowAborting,
    Nullable<IntPtr> nodeFilter,
    SnapType[] singleTimeFilters,
    Nullable<int> snapThreshold = null
)
public:
bool SnapToXYFilters(
    int x,
    int y,
    bool publishResult,
    bool allowAborting,
    Nullable<IntPtr> nodeFilter,
    array<SnapType>^ singleTimeFilters,
    Nullable<int> snapThreshold = nullptr
)

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
publishResult
Type: SystemBoolean
allowAborting
Type: SystemBoolean
nodeFilter
Type: SystemNullableIntPtr
singleTimeFilters
Type: VisualComponents.Create3DSnapType
snapThreshold (Optional)
Type: SystemNullableInt32

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SnapAction.SnapToXYFilters(System.Int32,System.Int32,System.Boolean,System.Boolean,System.Nullable{System.IntPtr},VisualComponents.Create3D.SnapType[],System.Nullable{System.Int32})"]

See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.ToggleSnapToSelection Method

SnapActionToggleSnapToSelection Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ToggleSnapToSelection(
    IManipulationTarget whenMovingTarget,
    bool preferredValue
)
public:
bool ToggleSnapToSelection(
    IManipulationTarget^ whenMovingTarget,
    bool preferredValue
)

Parameters

whenMovingTarget
Type: VisualComponents.Create3DIManipulationTarget
preferredValue
Type: SystemBoolean

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SnapAction.ToggleSnapToSelection(VisualComponents.Create3D.IManipulationTarget,System.Boolean)"]

See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction Events

The SnapAction type exposes the following members.

Events
 | Name | Description
Public event | Completed |
Public event | ContinuousResultMouseDown |
Public event | ContinuousResultMouseMove |
Public event | ContinuousSnapCompleted |
Public event | SnapResultFound |
Top
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.Completed Event

SnapActionCompleted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ResultCompletionEventArgs> Completed
public:
virtual  event EventHandler<ResultCompletionEventArgs^>^ Completed {
    void add (EventHandler<ResultCompletionEventArgs^>^ value);
    void remove (EventHandler<ResultCompletionEventArgs^>^ value);
}

Value

Type: SystemEventHandlerResultCompletionEventArgs

Implements

IResult.Completed
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.ContinuousResultMouseDown Event

SnapActionContinuousResultMouseDown Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ResultCompletionEventArgs> ContinuousResultMouseDown
public:
 event EventHandler<ResultCompletionEventArgs^>^ ContinuousResultMouseDown {
    void add (EventHandler<ResultCompletionEventArgs^>^ value);
    void remove (EventHandler<ResultCompletionEventArgs^>^ value);
}

Value

Type: SystemEventHandlerResultCompletionEventArgs
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.ContinuousResultMouseMove Event

SnapActionContinuousResultMouseMove Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ResultCompletionEventArgs> ContinuousResultMouseMove
public:
 event EventHandler<ResultCompletionEventArgs^>^ ContinuousResultMouseMove {
    void add (EventHandler<ResultCompletionEventArgs^>^ value);
    void remove (EventHandler<ResultCompletionEventArgs^>^ value);
}

Value

Type: SystemEventHandlerResultCompletionEventArgs
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.ContinuousSnapCompleted Event

SnapActionContinuousSnapCompleted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<SnapCompletedMessage> ContinuousSnapCompleted
public:
 event EventHandler<SnapCompletedMessage^>^ ContinuousSnapCompleted {
    void add (EventHandler<SnapCompletedMessage^>^ value);
    void remove (EventHandler<SnapCompletedMessage^>^ value);
}

Value

Type: SystemEventHandlerSnapCompletedMessage
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.SnapResultFound Event

SnapActionSnapResultFound Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event Action<SnapResultMessage> SnapResultFound
public:
 event Action<SnapResultMessage^>^ SnapResultFound {
    void add (Action<SnapResultMessage^>^ value);
    void remove (Action<SnapResultMessage^>^ value);
}

Value

Type: SystemActionSnapResultMessage
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction Fields

The SnapAction type exposes the following members.

Fields
Name | Description
DebugDonutSnap |
LongestSnapActionTook |
Top
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.DebugDonutSnap Field

SnapActionDebugDonutSnap Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool DebugDonutSnap
public:
static bool DebugDonutSnap

Field Value

Type: Boolean
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapAction.LongestSnapActionTook Field

SnapActionLongestSnapActionTook Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int LongestSnapActionTook
public:
static int LongestSnapActionTook

Field Value

Type: Int32
See Also

Reference

SnapAction Class
VisualComponents.UX.Shared Namespace


SnapCompletedAltMessage Class

Basically MouseUp event that is used to end actions like PathTeachAction.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedSnapCompletedAltMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SnapCompletedAltMessage
public ref class SnapCompletedAltMessage

The SnapCompletedAltMessage type exposes the following members.

Constructors
 | Name | Description
Public method | SnapCompletedAltMessage | Initializes a new instance of the SnapCompletedAltMessage class
Top
Properties
 | Name | Description
Public property | Modifiers |
Public property | SimpleClick | Did user just click or also drag.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SnapCompletedAltMessage Constructor

Initializes a new instance of the SnapCompletedAltMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SnapCompletedAltMessage()
public:
SnapCompletedAltMessage()
See Also

Reference

SnapCompletedAltMessage Class
VisualComponents.UX.Shared Namespace


SnapCompletedAltMessage Properties

The SnapCompletedAltMessage type exposes the following members.

Properties
 | Name | Description
Public property | Modifiers |
Public property | SimpleClick | Did user just click or also drag.
Top
See Also

Reference

SnapCompletedAltMessage Class
VisualComponents.UX.Shared Namespace


SnapCompletedAltMessage.Modifiers Property

SnapCompletedAltMessageModifiers Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ModifierKeys Modifiers { get; set; }
public:
property ModifierKeys Modifiers {
    ModifierKeys get ();
    void set (ModifierKeys value);
}

Property Value

Type: ModifierKeys
See Also

Reference

SnapCompletedAltMessage Class
VisualComponents.UX.Shared Namespace


SnapCompletedAltMessage.SimpleClick Property

SnapCompletedAltMessageSimpleClick Property

Did user just click or also drag.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool SimpleClick { get; set; }
public:
property bool SimpleClick {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SnapCompletedAltMessage Class
VisualComponents.UX.Shared Namespace


SnapCompletedAltMessage Methods

The SnapCompletedAltMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SnapCompletedAltMessage Class
VisualComponents.UX.Shared Namespace


SnapCompletedMessage Class

Basically MouseDown event that is used to end SnapAction and PickAction actions.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedSnapCompletedMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SnapCompletedMessage
public ref class SnapCompletedMessage

The SnapCompletedMessage type exposes the following members.

Constructors
 | Name | Description
Public method | SnapCompletedMessage | Initializes a new instance of the SnapCompletedMessage class
Top
Properties
 | Name | Description
Public property | ClickCount |
Public property | Modifiers |
Public property | SimpleClick | Did user just click or also drag.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SnapCompletedMessage Constructor

Initializes a new instance of the SnapCompletedMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SnapCompletedMessage()
public:
SnapCompletedMessage()
See Also

Reference

SnapCompletedMessage Class
VisualComponents.UX.Shared Namespace


SnapCompletedMessage Properties

The SnapCompletedMessage type exposes the following members.

Properties
 | Name | Description
Public property | ClickCount |
Public property | Modifiers |
Public property | SimpleClick | Did user just click or also drag.
Top
See Also

Reference

SnapCompletedMessage Class
VisualComponents.UX.Shared Namespace


SnapCompletedMessage.ClickCount Property

SnapCompletedMessageClickCount Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int ClickCount { get; set; }
public:
property int ClickCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SnapCompletedMessage Class
VisualComponents.UX.Shared Namespace


SnapCompletedMessage.Modifiers Property

SnapCompletedMessageModifiers Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ModifierKeys Modifiers { get; set; }
public:
property ModifierKeys Modifiers {
    ModifierKeys get ();
    void set (ModifierKeys value);
}

Property Value

Type: ModifierKeys
See Also

Reference

SnapCompletedMessage Class
VisualComponents.UX.Shared Namespace


SnapCompletedMessage.SimpleClick Property

SnapCompletedMessageSimpleClick Property

Did user just click or also drag.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool SimpleClick { get; set; }
public:
property bool SimpleClick {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SnapCompletedMessage Class
VisualComponents.UX.Shared Namespace


SnapCompletedMessage Methods

The SnapCompletedMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SnapCompletedMessage Class
VisualComponents.UX.Shared Namespace


SnapHideMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedSnapHideMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SnapHideMessage
public ref class SnapHideMessage

The SnapHideMessage type exposes the following members.

Constructors
 | Name | Description
Public method | SnapHideMessage | Initializes a new instance of the SnapHideMessage class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SnapHideMessage Constructor

Initializes a new instance of the SnapHideMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SnapHideMessage()
public:
SnapHideMessage()
See Also

Reference

SnapHideMessage Class
VisualComponents.UX.Shared Namespace


SnapHideMessage Methods

The SnapHideMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SnapHideMessage Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedSnapPrimitiveAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class SnapPrimitiveAction : ICommandPanelAction,
    IHandle<SnapHideMessage>, IHandle, IHandle<SnapResultMessage>,
    IHandle<RequestActionAbortMessage>
public ref class SnapPrimitiveAction sealed : ICommandPanelAction,
    IHandle<SnapHideMessage^>, IHandle, IHandle<SnapResultMessage^>,
    IHandle<RequestActionAbortMessage^>

The SnapPrimitiveAction type exposes the following members.

Constructors
 | Name | Description
Public method | SnapPrimitiveAction | Initializes a new instance of the SnapPrimitiveAction class
Top
Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
 | alignPositionFull |
Public property | ApplyButtonText |
Public property | AreAllTargetParentsChangeable |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
 | IsExecuting |
Public property | LastNormal |
Public property | ReferenceMatrix |
 | snapWay |
Public property | Target |
Public property | Title |
Top
Methods
 | Name | Description
 | AddChildrenRecursive |
Public method | ApplyAction |
Public method | CancelAction |
 | ConvertAxis |
 | DecideVisualsToGhost |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Public method | ExecuteOneShot |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetResultingMatrix |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle(RequestActionAbortMessage) |
Public method | Handle(SnapHideMessage) |
Public method | Handle(SnapResultMessage) |
 | OnPropertyChanged |
Public method | RestartAction |
 | RotateBetween | Create quaternion rotation from one vector to another. based on https://bitbucket.org/sinbad/ogre/src/9db75e3ba05c/OgreMain/include/OgreVector3.h#cl-651
 | RotateBetweenMin |
Public method | StartAction(EventHandlerResultCompletionEventArgs) |
Public method | StartAction(EventHandlerResultCompletionEventArgs, Boolean) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
Name | Description
IsExecutingChanged |
Top
Fields
Name | Description
approachAxisIndex |
snapAxisIndex |
snapPrimitiveMethod |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SnapPrimitiveAction Constructor

Initializes a new instance of the SnapPrimitiveAction class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SnapPrimitiveAction(
    IManipulationTarget manipulationTarget,
    IEnumerable<IVisualObject> visualsForGhosting,
    bool stayResident,
    string snapOptionsContext
)
public:
SnapPrimitiveAction(
    IManipulationTarget^ manipulationTarget,
    IEnumerable<IVisualObject^>^ visualsForGhosting,
    bool stayResident,
    String^ snapOptionsContext
)

Parameters

manipulationTarget
Type: VisualComponents.Create3DIManipulationTarget
visualsForGhosting
Type: System.Collections.GenericIEnumerableIVisualObject
stayResident
Type: SystemBoolean
snapOptionsContext
Type: SystemString
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction Properties

The SnapPrimitiveAction type exposes the following members.

Properties
 | Name | Description
Public property | ActionFinished |
Public property | ActionProperties |
 | alignPositionFull |
Public property | ApplyButtonText |
Public property | AreAllTargetParentsChangeable |
Public property | AssociatedModelId |
Public property | AssociatedSiteId |
Public property | CallingCommandName |
Public property | CancelButtonText |
Public property | Description |
Public property | ErrorMessage |
 | IsExecuting |
Public property | LastNormal |
Public property | ReferenceMatrix |
 | snapWay |
Public property | Target |
Public property | Title |
Top
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.ActionFinished Property

SnapPrimitiveActionActionFinished Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ActionFinished { get; }
public:
virtual property bool ActionFinished {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ICommandPanelActionActionFinished
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.ActionProperties Property

SnapPrimitiveActionActionProperties Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<IProperty> ActionProperties { get; }
public:
virtual property List<IProperty^>^ ActionProperties {
    List<IProperty^>^ get () sealed;
}

Property Value

Type: ListIProperty

Implements

ICommandPanelActionActionProperties
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.alignPositionFull Property

SnapPrimitiveActionalignPositionFull Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool alignPositionFull { get; set; }
public:
static property bool alignPositionFull {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.ApplyButtonText Property

SnapPrimitiveActionApplyButtonText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ApplyButtonText { get; }
public:
virtual property String^ ApplyButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionApplyButtonText
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.AreAllTargetParentsChangeable Property

SnapPrimitiveActionAreAllTargetParentsChangeable Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool AreAllTargetParentsChangeable { get; }
public:
property bool AreAllTargetParentsChangeable {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.AssociatedModelId Property

SnapPrimitiveActionAssociatedModelId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedModelId { get; }
public:
virtual property String^ AssociatedModelId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedModelId
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.AssociatedSiteId Property

SnapPrimitiveActionAssociatedSiteId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AssociatedSiteId { get; }
public:
virtual property String^ AssociatedSiteId {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionAssociatedSiteId
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.CallingCommandName Property

SnapPrimitiveActionCallingCommandName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CallingCommandName { get; }
public:
virtual property String^ CallingCommandName {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCallingCommandName
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.CancelButtonText Property

SnapPrimitiveActionCancelButtonText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string CancelButtonText { get; }
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionCancelButtonText
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.Description Property

SnapPrimitiveActionDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; }
public:
virtual property String^ Description {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionDescription
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.ErrorMessage Property

SnapPrimitiveActionErrorMessage Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ErrorMessage { get; set; }
public:
virtual property String^ ErrorMessage {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionErrorMessage
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.IsExecuting Property

SnapPrimitiveActionIsExecuting Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsExecuting { get; }
public:
static property bool IsExecuting {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.LastNormal Property

SnapPrimitiveActionLastNormal Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Vector3 LastNormal { get; set; }
public:
property Vector3 LastNormal {
    Vector3 get ();
    void set (Vector3 value);
}

Property Value

Type: Vector3
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.ReferenceMatrix Property

SnapPrimitiveActionReferenceMatrix Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Matrix ReferenceMatrix { get; set; }
public:
property Matrix ReferenceMatrix {
    Matrix get ();
    void set (Matrix value);
}

Property Value

Type: Matrix
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.snapWay Property

SnapPrimitiveActionsnapWay Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int snapWay { get; set; }
public:
static property int snapWay {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.Target Property

SnapPrimitiveActionTarget Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IManipulationTarget Target { get; }
public:
property IManipulationTarget^ Target {
    IManipulationTarget^ get ();
}

Property Value

Type: IManipulationTarget
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.Title Property

SnapPrimitiveActionTitle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; }
public:
virtual property String^ Title {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICommandPanelActionTitle
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction Methods

The SnapPrimitiveAction type exposes the following members.

Methods
 | Name | Description
 | AddChildrenRecursive |
Public method | ApplyAction |
Public method | CancelAction |
 | ConvertAxis |
 | DecideVisualsToGhost |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Public method | ExecuteOneShot |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetResultingMatrix |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle(RequestActionAbortMessage) |
Public method | Handle(SnapHideMessage) |
Public method | Handle(SnapResultMessage) |
 | OnPropertyChanged |
Public method | RestartAction |
 | RotateBetween | Create quaternion rotation from one vector to another. based on https://bitbucket.org/sinbad/ogre/src/9db75e3ba05c/OgreMain/include/OgreVector3.h#cl-651
 | RotateBetweenMin |
Public method | StartAction(EventHandlerResultCompletionEventArgs) |
Public method | StartAction(EventHandlerResultCompletionEventArgs, Boolean) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.AddChildrenRecursive Method

SnapPrimitiveActionAddChildrenRecursive Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void AddChildrenRecursive(
    List<IVisualObject> visualsForGhosting,
    ISimNode node,
    bool addChildComponentsOfRoot = true,
    ISimComponent rootComponent = null
)
public:
static void AddChildrenRecursive(
    List<IVisualObject^>^ visualsForGhosting,
    ISimNode^ node,
    bool addChildComponentsOfRoot = true,
    ISimComponent^ rootComponent = nullptr
)

Parameters

visualsForGhosting
Type: System.Collections.GenericListIVisualObject
node
Type: VisualComponents.Create3DISimNode
addChildComponentsOfRoot (Optional)
Type: SystemBoolean
rootComponent (Optional)
Type: VisualComponents.Create3DISimComponent
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.ApplyAction Method

SnapPrimitiveActionApplyAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ApplyAction()
public:
virtual bool ApplyAction() sealed

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SnapPrimitiveAction.ApplyAction"]

Implements

ICommandPanelActionApplyAction
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.CancelAction Method

SnapPrimitiveActionCancelAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void CancelAction()
public:
virtual void CancelAction() sealed

Implements

ICommandPanelActionCancelAction
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.ConvertAxis Method

SnapPrimitiveActionConvertAxis Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int ConvertAxis(
    JointAxis axis,
    int snapAxisIndex
)
public:
static int ConvertAxis(
    JointAxis axis,
    int snapAxisIndex
)

Parameters

axis
Type: VisualComponents.Create3DJointAxis
snapAxisIndex
Type: SystemInt32

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SnapPrimitiveAction.ConvertAxis(VisualComponents.Create3D.JointAxis,System.Int32)"]

See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.DecideVisualsToGhost Method

SnapPrimitiveActionDecideVisualsToGhost Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void DecideVisualsToGhost(
    bool stayResident,
    IEnumerable<IVisualObject> inputList,
    ref List<IVisualObject> visualsForGhosting,
    IManipulationTarget manipulationTarget
)
public:
static void DecideVisualsToGhost(
    bool stayResident,
    IEnumerable<IVisualObject^>^ inputList,
    List<IVisualObject^>^% visualsForGhosting,
    IManipulationTarget^ manipulationTarget
)

Parameters

stayResident
Type: SystemBoolean
inputList
Type: System.Collections.GenericIEnumerableIVisualObject
visualsForGhosting
Type: System.Collections.GenericListIVisualObject
manipulationTarget
Type: VisualComponents.Create3DIManipulationTarget
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.Execute Method

SnapPrimitiveActionExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IEnumerable<IResult> Execute()
public:
IEnumerable<IResult^>^ Execute()

Return Value

Type: IEnumerableIResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SnapPrimitiveAction.Execute"]

See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.ExecuteOneShot Method

SnapPrimitiveActionExecuteOneShot Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ExecuteOneShot(
    int x,
    int y,
    out SnapResult snapResult,
    out SnapResult snapResultSecondary,
    out Matrix newMatrix,
    bool updateFocus,
    Nullable<Vector3> originalNormal = null
)
public:
bool ExecuteOneShot(
    int x,
    int y,
    [OutAttribute] SnapResult% snapResult,
    [OutAttribute] SnapResult% snapResultSecondary,
    [OutAttribute] Matrix% newMatrix,
    bool updateFocus,
    Nullable<Vector3> originalNormal = nullptr
)

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
snapResult
Type: VisualComponents.Create3DSnapResult
snapResultSecondary
Type: VisualComponents.Create3DSnapResult
newMatrix
Type: VisualComponents.Create3DMatrix
updateFocus
Type: SystemBoolean
originalNormal (Optional)
Type: SystemNullableVector3

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SnapPrimitiveAction.ExecuteOneShot(System.Int32,System.Int32,VisualComponents.Create3D.SnapResult@,VisualComponents.Create3D.SnapResult@,VisualComponents.Create3D.Matrix@,System.Boolean,System.Nullable{VisualComponents.Create3D.Vector3})"]

See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.GetResultingMatrix Method

SnapPrimitiveActionGetResultingMatrix Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool GetResultingMatrix(
    SnapResult snap,
    out bool snapEarlier,
    out Matrix newMatrix
)
public:
bool GetResultingMatrix(
    SnapResult snap,
    [OutAttribute] bool% snapEarlier,
    [OutAttribute] Matrix% newMatrix
)

Parameters

snap
Type: VisualComponents.Create3DSnapResult
snapEarlier
Type: SystemBoolean
newMatrix
Type: VisualComponents.Create3DMatrix

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SnapPrimitiveAction.GetResultingMatrix(VisualComponents.Create3D.SnapResult,System.Boolean@,VisualComponents.Create3D.Matrix@)"]

See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.Handle Method

SnapPrimitiveActionHandle Method

Overload List
 | Name | Description
Public method | Handle(RequestActionAbortMessage) |
Public method | Handle(SnapHideMessage) |
Public method | Handle(SnapResultMessage) |
Top
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.Handle Method (RequestActionAbortMessage)

SnapPrimitiveActionHandle Method (RequestActionAbortMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    RequestActionAbortMessage message
)
public:
virtual void Handle(
    RequestActionAbortMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedRequestActionAbortMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

SnapPrimitiveAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.Handle Method (SnapHideMessage)

SnapPrimitiveActionHandle Method (SnapHideMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    SnapHideMessage message
)
public:
virtual void Handle(
    SnapHideMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedSnapHideMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

SnapPrimitiveAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.Handle Method (SnapResultMessage)

SnapPrimitiveActionHandle Method (SnapResultMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    SnapResultMessage message
)
public:
virtual void Handle(
    SnapResultMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedSnapResultMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

SnapPrimitiveAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.OnPropertyChanged Method

SnapPrimitiveActionOnPropertyChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void OnPropertyChanged(
    string name
)
public:
static void OnPropertyChanged(
    String^ name
)

Parameters

name
Type: SystemString
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.RestartAction Method

SnapPrimitiveActionRestartAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RestartAction()
public:
void RestartAction()
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.RotateBetween Method

SnapPrimitiveActionRotateBetween Method

Create quaternion rotation from one vector to another. based on https://bitbucket.org/sinbad/ogre/src/9db75e3ba05c/OgreMain/include/OgreVector3.h#cl-651

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Quaternion RotateBetween(
    Vector3 oldAxisDirection,
    Vector3 newAxisTarget
)
public:
static Quaternion RotateBetween(
    Vector3 oldAxisDirection,
    Vector3 newAxisTarget
)

Parameters

oldAxisDirection
Type: VisualComponents.Create3DVector3
newAxisTarget
Type: VisualComponents.Create3DVector3

Return Value

Type: Quaternion

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SnapPrimitiveAction.RotateBetween(VisualComponents.Create3D.Vector3,VisualComponents.Create3D.Vector3)"]

See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.RotateBetweenMin Method

SnapPrimitiveActionRotateBetweenMin Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Vector3 RotateBetweenMin(
    Vector3 oldDir,
    Vector3 newDir
)
public:
static Vector3 RotateBetweenMin(
    Vector3 oldDir,
    Vector3 newDir
)

Parameters

oldDir
Type: VisualComponents.Create3DVector3
newDir
Type: VisualComponents.Create3DVector3

Return Value

Type: Vector3

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SnapPrimitiveAction.RotateBetweenMin(VisualComponents.Create3D.Vector3,VisualComponents.Create3D.Vector3)"]

See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.StartAction Method

SnapPrimitiveActionStartAction Method

Overload List
 | Name | Description
Public method | StartAction(EventHandlerResultCompletionEventArgs) |
Public method | StartAction(EventHandlerResultCompletionEventArgs, Boolean) |
Top
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.StartAction Method (EventHandler(ResultCompletionEventArgs))

SnapPrimitiveActionStartAction Method (EventHandlerResultCompletionEventArgs)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    EventHandler<ResultCompletionEventArgs> completed = null
)
public:
virtual void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr
) sealed

Parameters

completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs

Implements

ICommandPanelActionStartAction(EventHandlerResultCompletionEventArgs)
See Also

Reference

SnapPrimitiveAction Class
StartAction Overload
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.StartAction Method (EventHandler(ResultCompletionEventArgs), Boolean)

SnapPrimitiveActionStartAction Method (EventHandlerResultCompletionEventArgs, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StartAction(
    EventHandler<ResultCompletionEventArgs> completed = null,
    bool openUI = true
)
public:
void StartAction(
    EventHandler<ResultCompletionEventArgs^>^ completed = nullptr,
    bool openUI = true
)

Parameters

completed (Optional)
Type: SystemEventHandlerResultCompletionEventArgs
openUI (Optional)
Type: SystemBoolean
See Also

Reference

SnapPrimitiveAction Class
StartAction Overload
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction Events

The SnapPrimitiveAction type exposes the following members.

Events
Name | Description
IsExecutingChanged |
Top
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.IsExecutingChanged Event

SnapPrimitiveActionIsExecutingChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static event PropertyChangedEventHandler IsExecutingChanged
public:
static  event PropertyChangedEventHandler^ IsExecutingChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction Fields

The SnapPrimitiveAction type exposes the following members.

Fields
Name | Description
approachAxisIndex |
snapAxisIndex |
snapPrimitiveMethod |
Top
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.approachAxisIndex Field

SnapPrimitiveActionapproachAxisIndex Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int approachAxisIndex
public:
static int approachAxisIndex

Field Value

Type: Int32
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.snapAxisIndex Field

SnapPrimitiveActionsnapAxisIndex Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int snapAxisIndex
public:
static int snapAxisIndex

Field Value

Type: Int32
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapPrimitiveAction.snapPrimitiveMethod Field

SnapPrimitiveActionsnapPrimitiveMethod Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static SnapPrimitiveMethod snapPrimitiveMethod
public:
static SnapPrimitiveMethod snapPrimitiveMethod

Field Value

Type: SnapPrimitiveMethod
See Also

Reference

SnapPrimitiveAction Class
VisualComponents.UX.Shared Namespace


SnapResultMessage Class

Message used to publish snapping result of various actions. It is used to update focus visualization for: - SnapAction - PathTeachSnapper - DraggingAlignManipulator (this class has nothing to do with classes: PickResult, PickAction, SnapCompletedMessage)
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedSnapResultMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SnapResultMessage
public ref class SnapResultMessage

The SnapResultMessage type exposes the following members.

Constructors
 | Name | Description
Public method | SnapResultMessage | Initializes a new instance of the SnapResultMessage class
Top
Properties
 | Name | Description
Public property | MousePosition |
Public property | SecondaryResults |
Public property | SnapResult |
Public property | SnapResultText |
Public property | SourceSnapAction |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | MouseX |
Public field | MouseY |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SnapResultMessage Constructor

Initializes a new instance of the SnapResultMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SnapResultMessage()
public:
SnapResultMessage()
See Also

Reference

SnapResultMessage Class
VisualComponents.UX.Shared Namespace


SnapResultMessage Properties

The SnapResultMessage type exposes the following members.

Properties
 | Name | Description
Public property | MousePosition |
Public property | SecondaryResults |
Public property | SnapResult |
Public property | SnapResultText |
Public property | SourceSnapAction |
Top
See Also

Reference

SnapResultMessage Class
VisualComponents.UX.Shared Namespace


SnapResultMessage.MousePosition Property

SnapResultMessageMousePosition Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Point MousePosition { get; }
public:
property Point MousePosition {
    Point get ();
}

Property Value

Type: Point
See Also

Reference

SnapResultMessage Class
VisualComponents.UX.Shared Namespace


SnapResultMessage.SecondaryResults Property

SnapResultMessageSecondaryResults Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<SecondarySnapResult> SecondaryResults { get; set; }
public:
property List<SecondarySnapResult^>^ SecondaryResults {
    List<SecondarySnapResult^>^ get ();
    void set (List<SecondarySnapResult^>^ value);
}

Property Value

Type: ListSecondarySnapResult
See Also

Reference

SnapResultMessage Class
VisualComponents.UX.Shared Namespace


SnapResultMessage.SnapResult Property

SnapResultMessageSnapResult Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SnapResult SnapResult { get; set; }
public:
property SnapResult SnapResult {
    SnapResult get ();
    void set (SnapResult value);
}

Property Value

Type: SnapResult
See Also

Reference

SnapResultMessage Class
VisualComponents.UX.Shared Namespace


SnapResultMessage.SnapResultText Property

SnapResultMessageSnapResultText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SnapResultText { get; }
public:
property String^ SnapResultText {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

SnapResultMessage Class
VisualComponents.UX.Shared Namespace


SnapResultMessage.SourceSnapAction Property

SnapResultMessageSourceSnapAction Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SnapAction SourceSnapAction { get; set; }
public:
property SnapAction^ SourceSnapAction {
    SnapAction^ get ();
    void set (SnapAction^ value);
}

Property Value

Type: SnapAction
See Also

Reference

SnapResultMessage Class
VisualComponents.UX.Shared Namespace


SnapResultMessage Methods

The SnapResultMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SnapResultMessage Class
VisualComponents.UX.Shared Namespace


SnapResultMessage Fields

The SnapResultMessage type exposes the following members.

Fields
 | Name | Description
Public field | MouseX |
Public field | MouseY |
Top
See Also

Reference

SnapResultMessage Class
VisualComponents.UX.Shared Namespace


SnapResultMessage.MouseX Field

SnapResultMessageMouseX Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int MouseX
public:
int MouseX

Field Value

Type: Int32
See Also

Reference

SnapResultMessage Class
VisualComponents.UX.Shared Namespace


SnapResultMessage.MouseY Field

SnapResultMessageMouseY Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int MouseY
public:
int MouseY

Field Value

Type: Int32
See Also

Reference

SnapResultMessage Class
VisualComponents.UX.Shared Namespace


SortableObservableCollection(T) Class

SortableObservableCollectionT Class

Represent Extended ObservableCollection that has a Sort method , give it a lambda to sort on and a direction.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollectionT
System.Collections.ObjectModelObservableCollectionT
VisualComponents.UX.SharedSortableObservableCollectionT

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SortableObservableCollection<T> : ObservableCollection<T>

generic<typename T>
public ref class SortableObservableCollection : public ObservableCollection<T>

Type Parameters

T
The type of elements in the collection.

The SortableObservableCollectionT type exposes the following members.

Constructors
 | Name | Description
Public method | SortableObservableCollectionT(IEnumerableT) | Initializes a new instance of the SortableObservableCollectionT class
Public method | SortableObservableCollectionT(ListT) | Initializes a new instance of the SortableObservableCollectionT class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from CollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from CollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from CollectionT.)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from CollectionT.)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollectionT.)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollectionT.)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from CollectionT.)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollectionT.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from CollectionT.)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from CollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from CollectionT.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from CollectionT.)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from CollectionT.)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollectionT.)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollectionT.)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from ObservableCollectionT.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from CollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from CollectionT.)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollectionT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollectionT.)
Public method | SortTKey(FuncT, TKey, IComparerTKey) |
Public method | SortTKey(FuncT, TKey, ListSortDirection) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollectionT.)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SortableObservableCollection(T) Constructor

SortableObservableCollectionT Constructor

Overload List
 | Name | Description
Public method | SortableObservableCollectionT(IEnumerableT) | Initializes a new instance of the SortableObservableCollectionT class
Public method | SortableObservableCollectionT(ListT) | Initializes a new instance of the SortableObservableCollectionT class
Top
See Also

Reference

SortableObservableCollectionT Class
VisualComponents.UX.Shared Namespace


SortableObservableCollection(T) Constructor (IEnumerable(T))

SortableObservableCollectionT Constructor (IEnumerableT)

Initializes a new instance of the SortableObservableCollectionT class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SortableObservableCollection(
    IEnumerable<T> collection
)
public:
SortableObservableCollection(
    IEnumerable<T>^ collection
)

Parameters

collection
Type: System.Collections.GenericIEnumerableT
See Also

Reference

SortableObservableCollectionT Class
SortableObservableCollectionT Overload
VisualComponents.UX.Shared Namespace


SortableObservableCollection(T) Constructor (List(T))

SortableObservableCollectionT Constructor (ListT)

Initializes a new instance of the SortableObservableCollectionT class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SortableObservableCollection(
    List<T> list
)
public:
SortableObservableCollection(
    List<T>^ list
)

Parameters

list
Type: System.Collections.GenericListT
See Also

Reference

SortableObservableCollectionT Class
SortableObservableCollectionT Overload
VisualComponents.UX.Shared Namespace


SortableObservableCollection(T) Properties

SortableObservableCollectionT Properties

The SortableObservableCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from CollectionT .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from CollectionT .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from CollectionT .)
Top
See Also

Reference

SortableObservableCollectionT Class
VisualComponents.UX.Shared Namespace


SortableObservableCollection(T) Methods

SortableObservableCollectionT Methods

The SortableObservableCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from CollectionT .)
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollectionT .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollectionT .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from CollectionT .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollectionT .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from CollectionT .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from CollectionT .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from CollectionT .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from CollectionT .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from CollectionT .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollectionT .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollectionT .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollectionT .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from ObservableCollectionT .)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollectionT .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from CollectionT .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from CollectionT .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollectionT .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollectionT .)
Public method | SortTKey(FuncT, TKey, IComparerTKey) |
Public method | SortTKey(FuncT, TKey, ListSortDirection) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SortableObservableCollectionT Class
VisualComponents.UX.Shared Namespace


SortableObservableCollection(T).Sort Method

SortableObservableCollectionTSort Method

Overload List
 | Name | Description
Public method | SortTKey(FuncT, TKey, IComparerTKey) |
Public method | SortTKey(FuncT, TKey, ListSortDirection) |
Top
See Also

Reference

SortableObservableCollectionT Class
VisualComponents.UX.Shared Namespace


SortableObservableCollection(T).Sort(TKey) Method (Func(T, TKey), IComparer(TKey))

SortableObservableCollectionTSortTKey Method (FuncT, TKey, IComparerTKey)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Sort<TKey>(
    Func<T, TKey> keySelector,
    IComparer<TKey> comparer
)

public:
generic<typename TKey>
void Sort(
    Func<T, TKey>^ keySelector,
    IComparer<TKey>^ comparer
)

Parameters

keySelector
Type: SystemFuncT, TKey
comparer
Type: System.Collections.GenericIComparerTKey

Type Parameters

TKey
See Also

Reference

SortableObservableCollectionT Class
Sort Overload
VisualComponents.UX.Shared Namespace


SortableObservableCollection(T).Sort(TKey) Method (Func(T, TKey), ListSortDirection)

SortableObservableCollectionTSortTKey Method (FuncT, TKey, ListSortDirection)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Sort<TKey>(
    Func<T, TKey> keySelector,
    ListSortDirection direction
)

public:
generic<typename TKey>
void Sort(
    Func<T, TKey>^ keySelector,
    ListSortDirection direction
)

Parameters

keySelector
Type: SystemFuncT, TKey
direction
Type: System.ComponentModelListSortDirection

Type Parameters

TKey
See Also

Reference

SortableObservableCollectionT Class
Sort Overload
VisualComponents.UX.Shared Namespace


SortableObservableCollection(T) Events

SortableObservableCollectionT Events

The SortableObservableCollectionT generic type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollectionT .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollectionT .)
Top
See Also

Reference

SortableObservableCollectionT Class
VisualComponents.UX.Shared Namespace


SourceIndexingEventArgs Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedSourceIndexingEventArgs

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SourceIndexingEventArgs
public ref class SourceIndexingEventArgs

The SourceIndexingEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | SourceIndexingEventArgs(Boolean) | Initializes a new instance of the SourceIndexingEventArgs class
Public method | SourceIndexingEventArgs(Boolean, IReadOnlyCollectionString) | Initializes a new instance of the SourceIndexingEventArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | AreRemoteSources |
Public field | SourceNames |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SourceIndexingEventArgs Constructor

Overload List
 | Name | Description
Public method | SourceIndexingEventArgs(Boolean) | Initializes a new instance of the SourceIndexingEventArgs class
Public method | SourceIndexingEventArgs(Boolean, IReadOnlyCollectionString) | Initializes a new instance of the SourceIndexingEventArgs class
Top
See Also

Reference

SourceIndexingEventArgs Class
VisualComponents.UX.Shared Namespace


SourceIndexingEventArgs Constructor (Boolean)

Initializes a new instance of the SourceIndexingEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SourceIndexingEventArgs(
    bool areRemoteSources
)
public:
SourceIndexingEventArgs(
    bool areRemoteSources
)

Parameters

areRemoteSources
Type: SystemBoolean
See Also

Reference

SourceIndexingEventArgs Class
SourceIndexingEventArgs Overload
VisualComponents.UX.Shared Namespace


SourceIndexingEventArgs Constructor (Boolean, IReadOnlyCollection(String))

SourceIndexingEventArgs Constructor (Boolean, IReadOnlyCollectionString)

Initializes a new instance of the SourceIndexingEventArgs class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SourceIndexingEventArgs(
    bool areRemoteSources,
    IReadOnlyCollection<string> sourceNames
)
public:
SourceIndexingEventArgs(
    bool areRemoteSources,
    IReadOnlyCollection<String^>^ sourceNames
)

Parameters

areRemoteSources
Type: SystemBoolean
sourceNames
Type: System.Collections.GenericIReadOnlyCollectionString
See Also

Reference

SourceIndexingEventArgs Class
SourceIndexingEventArgs Overload
VisualComponents.UX.Shared Namespace


SourceIndexingEventArgs Methods

The SourceIndexingEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SourceIndexingEventArgs Class
VisualComponents.UX.Shared Namespace


SourceIndexingEventArgs Fields

The SourceIndexingEventArgs type exposes the following members.

Fields
 | Name | Description
Public field | AreRemoteSources |
Public field | SourceNames |
Top
See Also

Reference

SourceIndexingEventArgs Class
VisualComponents.UX.Shared Namespace


SourceIndexingEventArgs.AreRemoteSources Field

SourceIndexingEventArgsAreRemoteSources Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public readonly bool AreRemoteSources
public:
initonly bool AreRemoteSources

Field Value

Type: Boolean
See Also

Reference

SourceIndexingEventArgs Class
VisualComponents.UX.Shared Namespace


SourceIndexingEventArgs.SourceNames Field

SourceIndexingEventArgsSourceNames Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public readonly IReadOnlyCollection<string> SourceNames
public:
initonly IReadOnlyCollection<String^>^ SourceNames

Field Value

Type: IReadOnlyCollectionString
See Also

Reference

SourceIndexingEventArgs Class
VisualComponents.UX.Shared Namespace


SpaceMouseHandler Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedSpaceMouseHandler

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class SpaceMouseHandler
public ref class SpaceMouseHandler sealed

The SpaceMouseHandler type exposes the following members.

Constructors
 | Name | Description
Public method | SpaceMouseHandler | Initializes a new instance of the SpaceMouseHandler class
Top
Properties
 | Name | Description
Public property | SpaceMouseHandle |
Top
Methods
 | Name | Description
Public method | _hoverCheckerTimer_Tick |
Public method | ApplyUserSettings |
Public method | DoButtonAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitSpaceMouse |
Public method | MoveCamera |
Public method | StopMovement |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SpaceMouseHandler Constructor

Initializes a new instance of the SpaceMouseHandler class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SpaceMouseHandler()
public:
SpaceMouseHandler()
See Also

Reference

SpaceMouseHandler Class
VisualComponents.UX.Shared Namespace


SpaceMouseHandler Properties

The SpaceMouseHandler type exposes the following members.

Properties
 | Name | Description
Public property | SpaceMouseHandle |
Top
See Also

Reference

SpaceMouseHandler Class
VisualComponents.UX.Shared Namespace


SpaceMouseHandler.SpaceMouseHandle Property

SpaceMouseHandlerSpaceMouseHandle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IntPtr SpaceMouseHandle { get; }
public:
property IntPtr SpaceMouseHandle {
    IntPtr get ();
}

Property Value

Type: IntPtr
See Also

Reference

SpaceMouseHandler Class
VisualComponents.UX.Shared Namespace


SpaceMouseHandler Methods

The SpaceMouseHandler type exposes the following members.

Methods
 | Name | Description
Public method | _hoverCheckerTimer_Tick |
Public method | ApplyUserSettings |
Public method | DoButtonAction |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitSpaceMouse |
Public method | MoveCamera |
Public method | StopMovement |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SpaceMouseHandler Class
VisualComponents.UX.Shared Namespace


SpaceMouseHandler._hoverCheckerTimer_Tick Method

SpaceMouseHandler_hoverCheckerTimer_Tick Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void _hoverCheckerTimer_Tick(
    Object sender,
    EventArgs e
)
public:
void _hoverCheckerTimer_Tick(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: SystemObject
e
Type: SystemEventArgs
See Also

Reference

SpaceMouseHandler Class
VisualComponents.UX.Shared Namespace


SpaceMouseHandler.ApplyUserSettings Method

SpaceMouseHandlerApplyUserSettings Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ApplyUserSettings()
public:
void ApplyUserSettings()
See Also

Reference

SpaceMouseHandler Class
VisualComponents.UX.Shared Namespace


SpaceMouseHandler.DoButtonAction Method

SpaceMouseHandlerDoButtonAction Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void DoButtonAction(
    int button,
    string all_buttons
)
public:
void DoButtonAction(
    int button,
    String^ all_buttons
)

Parameters

button
Type: SystemInt32
all_buttons
Type: SystemString
See Also

Reference

SpaceMouseHandler Class
VisualComponents.UX.Shared Namespace


SpaceMouseHandler.InitSpaceMouse Method

SpaceMouseHandlerInitSpaceMouse Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitSpaceMouse()
public:
void InitSpaceMouse()
See Also

Reference

SpaceMouseHandler Class
VisualComponents.UX.Shared Namespace


SpaceMouseHandler.MoveCamera Method

SpaceMouseHandlerMoveCamera Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void MoveCamera(
    ref SiAppNativeMethodsSiSpwEvent_SpwData msg
)
public:
void MoveCamera(
    SiAppNativeMethodsSiSpwEvent_SpwData% msg
)

Parameters

msg
Type: VisualComponents.UX.InputSiAppNativeMethodsSiSpwEvent_SpwData
See Also

Reference

SpaceMouseHandler Class
VisualComponents.UX.Shared Namespace


SpaceMouseHandler.StopMovement Method

SpaceMouseHandlerStopMovement Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void StopMovement()
public:
void StopMovement()
See Also

Reference

SpaceMouseHandler Class
VisualComponents.UX.Shared Namespace


SpeedFactorConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedSpeedFactorConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SpeedFactorConverter : IValueConverter
public ref class SpeedFactorConverter : IValueConverter

The SpeedFactorConverter type exposes the following members.

Constructors
 | Name | Description
Public method | SpeedFactorConverter | Initializes a new instance of the SpeedFactorConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SpeedFactorConverter Constructor

Initializes a new instance of the SpeedFactorConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SpeedFactorConverter()
public:
SpeedFactorConverter()
See Also

Reference

SpeedFactorConverter Class
VisualComponents.UX.Shared Namespace


SpeedFactorConverter Methods

The SpeedFactorConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SpeedFactorConverter Class
VisualComponents.UX.Shared Namespace


SpeedFactorConverter.Convert Method

SpeedFactorConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SpeedFactorConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

SpeedFactorConverter Class
VisualComponents.UX.Shared Namespace


SpeedFactorConverter.ConvertBack Method

SpeedFactorConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SpeedFactorConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

SpeedFactorConverter Class
VisualComponents.UX.Shared Namespace


StateMapTier Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.SharedStateMapTier

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class StateMapTier : PropertyChangedBase
public ref class StateMapTier : public PropertyChangedBase

The StateMapTier type exposes the following members.

Constructors
 | Name | Description
Public method | StateMapTier | Initializes a new instance of the StateMapTier class
Public method | StateMapTier(UInt32, String, String, IStatisticsState) | Initializes a new instance of the StateMapTier class
Top
Properties
 | Name | Description
Public property | Index |
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | StateName |
Public property | StateObject |
Public property | SystemState |
Public property | SystemStates |
Top
Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
 | ParseEnumT |
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateStateMapping |
Public method | UpdateStateName |
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


StateMapTier Constructor

Overload List
 | Name | Description
Public method | StateMapTier | Initializes a new instance of the StateMapTier class
Public method | StateMapTier(UInt32, String, String, IStatisticsState) | Initializes a new instance of the StateMapTier class
Top
See Also

Reference

StateMapTier Class
VisualComponents.UX.Shared Namespace


StateMapTier Constructor

Initializes a new instance of the StateMapTier class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StateMapTier()
public:
StateMapTier()
See Also

Reference

StateMapTier Class
StateMapTier Overload
VisualComponents.UX.Shared Namespace


StateMapTier Constructor (UInt32, String, String, IStatisticsState)

Initializes a new instance of the StateMapTier class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StateMapTier(
    uint index,
    string name,
    string stateMapping,
    IStatisticsState state
)
public:
StateMapTier(
    unsigned int index,
    String^ name,
    String^ stateMapping,
    IStatisticsState^ state
)

Parameters

index
Type: SystemUInt32
name
Type: SystemString
stateMapping
Type: SystemString
state
Type: VisualComponents.Create3DIStatisticsState
See Also

Reference

StateMapTier Class
StateMapTier Overload
VisualComponents.UX.Shared Namespace


StateMapTier Properties

The StateMapTier type exposes the following members.

Properties
 | Name | Description
Public property | Index |
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | StateName |
Public property | StateObject |
Public property | SystemState |
Public property | SystemStates |
Top
See Also

Reference

StateMapTier Class
VisualComponents.UX.Shared Namespace


StateMapTier.Index Property

StateMapTierIndex Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public uint Index { get; set; }
public:
property unsigned int Index {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

StateMapTier Class
VisualComponents.UX.Shared Namespace


StateMapTier.StateName Property

StateMapTierStateName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string StateName { get; set; }
public:
property String^ StateName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

StateMapTier Class
VisualComponents.UX.Shared Namespace


StateMapTier.StateObject Property

StateMapTierStateObject Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IStatisticsState StateObject { get; set; }
public:
property IStatisticsState^ StateObject {
    IStatisticsState^ get ();
    void set (IStatisticsState^ value);
}

Property Value

Type: IStatisticsState
See Also

Reference

StateMapTier Class
VisualComponents.UX.Shared Namespace


StateMapTier.SystemState Property

StateMapTierSystemState Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SystemState { get; set; }
public:
property String^ SystemState {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

StateMapTier Class
VisualComponents.UX.Shared Namespace


StateMapTier.SystemStates Property

StateMapTierSystemStates Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObservableCollection<string> SystemStates { get; }
public:
property ObservableCollection<String^>^ SystemStates {
    ObservableCollection<String^>^ get ();
}

Property Value

Type: ObservableCollectionString
See Also

Reference

StateMapTier Class
VisualComponents.UX.Shared Namespace


StateMapTier Methods

The StateMapTier type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
 | ParseEnumT |
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateStateMapping |
Public method | UpdateStateName |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

StateMapTier Class
VisualComponents.UX.Shared Namespace


StateMapTier.Equals Method

StateMapTierEquals Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override bool Equals(
    Object obj
)
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.StateMapTier.Equals(System.Object)"]

See Also

Reference

StateMapTier Class
VisualComponents.UX.Shared Namespace


StateMapTier.ParseEnum(T) Method

StateMapTierParseEnumT Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static T ParseEnum<T>(
    string value,
    T defaultValue
)
where T : struct, new()

public:
generic<typename T>
where T : value class, gcnew()
static T ParseEnum(
    String^ value,
    T defaultValue
)

Parameters

value
Type: SystemString
defaultValue
Type: T

Type Parameters

T

Return Value

Type: T

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.StateMapTier.ParseEnum``1(System.String,``0)"]

See Also

Reference

StateMapTier Class
VisualComponents.UX.Shared Namespace


StateMapTier.UpdateStateMapping Method

StateMapTierUpdateStateMapping Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void UpdateStateMapping(
    string stateMapping
)
public:
void UpdateStateMapping(
    String^ stateMapping
)

Parameters

stateMapping
Type: SystemString
See Also

Reference

StateMapTier Class
VisualComponents.UX.Shared Namespace


StateMapTier.UpdateStateName Method

StateMapTierUpdateStateName Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void UpdateStateName(
    string stateName
)
public:
void UpdateStateName(
    String^ stateName
)

Parameters

stateName
Type: SystemString
See Also

Reference

StateMapTier Class
VisualComponents.UX.Shared Namespace


StateMapTier Events

The StateMapTier type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
See Also

Reference

StateMapTier Class
VisualComponents.UX.Shared Namespace


Statement Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
VisualComponents.UX.SharedStatement

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class Statement : PropertyChangedBase
public ref class Statement : public PropertyChangedBase

The Statement type exposes the following members.

Constructors
 | Name | Description
Public method | Statement | Initializes a new instance of the Statement class
Top
Properties
 | Name | Description
Public property | Action |
Public property | AttachTo |
Public property | GroupId |
Public property | IsActiveType |
Public property | IsEnabled |
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | Key |
Public property | Tag |
Public property | Text |
Public property | ToolTipContentKey |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


Statement Constructor

Initializes a new instance of the Statement class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Statement()
public:
Statement()
See Also

Reference

Statement Class
VisualComponents.UX.Shared Namespace


Statement Properties

The Statement type exposes the following members.

Properties
 | Name | Description
Public property | Action |
Public property | AttachTo |
Public property | GroupId |
Public property | IsActiveType |
Public property | IsEnabled |
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | Key |
Public property | Tag |
Public property | Text |
Public property | ToolTipContentKey |
Top
See Also

Reference

Statement Class
VisualComponents.UX.Shared Namespace


Statement.Action Property

StatementAction Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public BaseActionItem Action { get; set; }
public:
property BaseActionItem^ Action {
    BaseActionItem^ get ();
    void set (BaseActionItem^ value);
}

Property Value

Type: BaseActionItem
See Also

Reference

Statement Class
VisualComponents.UX.Shared Namespace


Statement.AttachTo Property

StatementAttachTo Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string AttachTo { get; }
public:
property String^ AttachTo {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

Statement Class
VisualComponents.UX.Shared Namespace


Statement.GroupId Property

StatementGroupId Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string GroupId { get; set; }
public:
property String^ GroupId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Statement Class
VisualComponents.UX.Shared Namespace


Statement.IsActiveType Property

StatementIsActiveType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsActiveType { get; set; }
public:
property bool IsActiveType {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Statement Class
VisualComponents.UX.Shared Namespace


Statement.IsEnabled Property

StatementIsEnabled Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsEnabled { get; set; }
public:
property bool IsEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Statement Class
VisualComponents.UX.Shared Namespace


Statement.Key Property

StatementKey Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Key { get; set; }
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Statement Class
VisualComponents.UX.Shared Namespace


Statement.Tag Property

StatementTag Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Tag { get; set; }
public:
property String^ Tag {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Statement Class
VisualComponents.UX.Shared Namespace


Statement.Text Property

StatementText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Text { get; set; }
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Statement Class
VisualComponents.UX.Shared Namespace


Statement.ToolTipContentKey Property

StatementToolTipContentKey Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ToolTipContentKey { get; set; }
public:
property String^ ToolTipContentKey {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Statement Class
VisualComponents.UX.Shared Namespace


Statement Methods

The Statement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

Statement Class
VisualComponents.UX.Shared Namespace


Statement Events

The Statement type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Top
See Also

Reference

Statement Class
VisualComponents.UX.Shared Namespace


StatementGroup Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedStatementGroup

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class StatementGroup
public ref class StatementGroup

The StatementGroup type exposes the following members.

Constructors
 | Name | Description
Public method | StatementGroup | Initializes a new instance of the StatementGroup class
Top
Properties
 | Name | Description
Public property | ItemsKeys |
Public property | Key |
Public property | Title |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


StatementGroup Constructor

Initializes a new instance of the StatementGroup class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StatementGroup()
public:
StatementGroup()
See Also

Reference

StatementGroup Class
VisualComponents.UX.Shared Namespace


StatementGroup Properties

The StatementGroup type exposes the following members.

Properties
 | Name | Description
Public property | ItemsKeys |
Public property | Key |
Public property | Title |
Top
See Also

Reference

StatementGroup Class
VisualComponents.UX.Shared Namespace


StatementGroup.ItemsKeys Property

StatementGroupItemsKeys Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public List<string> ItemsKeys { get; set; }
public:
property List<String^>^ ItemsKeys {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Property Value

Type: ListString
See Also

Reference

StatementGroup Class
VisualComponents.UX.Shared Namespace


StatementGroup.Key Property

StatementGroupKey Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Key { get; set; }
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

StatementGroup Class
VisualComponents.UX.Shared Namespace


StatementGroup.Title Property

StatementGroupTitle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; set; }
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

StatementGroup Class
VisualComponents.UX.Shared Namespace


StatementGroup Methods

The StatementGroup type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

StatementGroup Class
VisualComponents.UX.Shared Namespace


StatementHelper Class

Singleton class with utility functions for program statements.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedStatementHelper

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class StatementHelper
public ref class StatementHelper sealed

The StatementHelper type exposes the following members.

Properties
 | Name | Description
Public property | Customization |
 | Instance |
Public property | Localization |
Public property | StatementGroupItems |
Public property | Statements |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetContent |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIcon | Gets the icon file path associated with the statement type.
Public method | GetProcessRoutine |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsScopeInsideLoop |
Public method | RaiseStatementMovedFrom |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | StatementMovedFrom |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


StatementHelper Properties

The StatementHelper type exposes the following members.

Properties
 | Name | Description
Public property | Customization |
 | Instance |
Public property | Localization |
Public property | StatementGroupItems |
Public property | Statements |
Top
See Also

Reference

StatementHelper Class
VisualComponents.UX.Shared Namespace


StatementHelper.Customization Property

StatementHelperCustomization Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ICustomizationService Customization { get; }
public:
property ICustomizationService^ Customization {
    ICustomizationService^ get ();
}

Property Value

Type: ICustomizationService
See Also

Reference

StatementHelper Class
VisualComponents.UX.Shared Namespace


StatementHelper.Instance Property

StatementHelperInstance Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static StatementHelper Instance { get; }
public:
static property StatementHelper^ Instance {
    StatementHelper^ get ();
}

Property Value

Type: StatementHelper
See Also

Reference

StatementHelper Class
VisualComponents.UX.Shared Namespace


StatementHelper.Localization Property

StatementHelperLocalization Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ILocalizationService Localization { get; }
public:
property ILocalizationService^ Localization {
    ILocalizationService^ get ();
}

Property Value

Type: ILocalizationService
See Also

Reference

StatementHelper Class
VisualComponents.UX.Shared Namespace


StatementHelper.StatementGroupItems Property

StatementHelperStatementGroupItems Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObservableCollection<StatementGroup> StatementGroupItems { get; set; }
public:
property ObservableCollection<StatementGroup^>^ StatementGroupItems {
    ObservableCollection<StatementGroup^>^ get ();
    void set (ObservableCollection<StatementGroup^>^ value);
}

Property Value

Type: ObservableCollectionStatementGroup
See Also

Reference

StatementHelper Class
VisualComponents.UX.Shared Namespace


StatementHelper.Statements Property

StatementHelperStatements Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObservableCollection<Statement> Statements { get; set; }
public:
property ObservableCollection<Statement^>^ Statements {
    ObservableCollection<Statement^>^ get ();
    void set (ObservableCollection<Statement^>^ value);
}

Property Value

Type: ObservableCollectionStatement
See Also

Reference

StatementHelper Class
VisualComponents.UX.Shared Namespace


StatementHelper Methods

The StatementHelper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetContent |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetIcon | Gets the icon file path associated with the statement type.
Public method | GetProcessRoutine |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsScopeInsideLoop |
Public method | RaiseStatementMovedFrom |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

StatementHelper Class
VisualComponents.UX.Shared Namespace


StatementHelper.GetContent Method

StatementHelperGetContent Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string GetContent(
    Object statement
)
public:
String^ GetContent(
    Object^ statement
)

Parameters

statement
Type: SystemObject

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.StatementHelper.GetContent(System.Object)"]

See Also

Reference

StatementHelper Class
VisualComponents.UX.Shared Namespace


StatementHelper.GetIcon Method

StatementHelperGetIcon Method

Gets the icon file path associated with the statement type.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string GetIcon(
    Object statement
)
public:
String^ GetIcon(
    Object^ statement
)

Parameters

statement
Type: SystemObject
The statement object.

Return Value

Type: String
Null if icon hasn't been defined or statement is null.
See Also

Reference

StatementHelper Class
VisualComponents.UX.Shared Namespace


StatementHelper.GetProcessRoutine Method

StatementHelperGetProcessRoutine Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IProcessRoutine GetProcessRoutine(
    IRoutine routine
)
public:
IProcessRoutine^ GetProcessRoutine(
    IRoutine^ routine
)

Parameters

routine
Type: VisualComponents.Create3DIRoutine

Return Value

Type: IProcessRoutine

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.StatementHelper.GetProcessRoutine(VisualComponents.Create3D.IRoutine)"]

See Also

Reference

StatementHelper Class
VisualComponents.UX.Shared Namespace


StatementHelper.IsScopeInsideLoop Method

StatementHelperIsScopeInsideLoop Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsScopeInsideLoop(
    IStatementScope scope
)
public:
bool IsScopeInsideLoop(
    IStatementScope^ scope
)

Parameters

scope
Type: VisualComponents.Create3DIStatementScope

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.StatementHelper.IsScopeInsideLoop(VisualComponents.Create3D.IStatementScope)"]

See Also

Reference

StatementHelper Class
VisualComponents.UX.Shared Namespace


StatementHelper.RaiseStatementMovedFrom Method

StatementHelperRaiseStatementMovedFrom Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void RaiseStatementMovedFrom(
    IStatementScope scope,
    IStatement statement
)
public:
void RaiseStatementMovedFrom(
    IStatementScope^ scope,
    IStatement^ statement
)

Parameters

scope
Type: VisualComponents.Create3DIStatementScope
statement
Type: VisualComponents.Create3DIStatement
See Also

Reference

StatementHelper Class
VisualComponents.UX.Shared Namespace


StatementHelper Events

The StatementHelper type exposes the following members.

Events
 | Name | Description
Public event | StatementMovedFrom |
Top
See Also

Reference

StatementHelper Class
VisualComponents.UX.Shared Namespace


StatementHelper.StatementMovedFrom Event

StatementHelperStatementMovedFrom Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<IStatement> StatementMovedFrom
public:
 event EventHandler<IStatement^>^ StatementMovedFrom {
    void add (EventHandler<IStatement^>^ value);
    void remove (EventHandler<IStatement^>^ value);
}

Value

Type: SystemEventHandlerIStatement
See Also

Reference

StatementHelper Class
VisualComponents.UX.Shared Namespace


StatisticsChartPrintingMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedStatisticsChartPrintingMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class StatisticsChartPrintingMessage
public ref class StatisticsChartPrintingMessage

The StatisticsChartPrintingMessage type exposes the following members.

Constructors
 | Name | Description
Public method | StatisticsChartPrintingMessage | Initializes a new instance of the StatisticsChartPrintingMessage class
Top
Properties
 | Name | Description
Public property | ActivePrintItem |
Public property | PrintObject |
Public property | StatisticsTab |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


StatisticsChartPrintingMessage Constructor

Initializes a new instance of the StatisticsChartPrintingMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StatisticsChartPrintingMessage(
    IStatisticsTab tab,
    Dictionary<string, Visual> chartObjects,
    Visual activePrintItem
)
public:
StatisticsChartPrintingMessage(
    IStatisticsTab^ tab,
    Dictionary<String^, Visual^>^ chartObjects,
    Visual^ activePrintItem
)

Parameters

tab
Type: VisualComponents.Create3DIStatisticsTab
chartObjects
Type: System.Collections.GenericDictionaryString, Visual
activePrintItem
Type: System.Windows.MediaVisual
See Also

Reference

StatisticsChartPrintingMessage Class
VisualComponents.UX.Shared Namespace


StatisticsChartPrintingMessage Properties

The StatisticsChartPrintingMessage type exposes the following members.

Properties
 | Name | Description
Public property | ActivePrintItem |
Public property | PrintObject |
Public property | StatisticsTab |
Top
See Also

Reference

StatisticsChartPrintingMessage Class
VisualComponents.UX.Shared Namespace


StatisticsChartPrintingMessage.ActivePrintItem Property

StatisticsChartPrintingMessageActivePrintItem Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Visual ActivePrintItem { get; set; }
public:
property Visual^ ActivePrintItem {
    Visual^ get ();
    void set (Visual^ value);
}

Property Value

Type: Visual
See Also

Reference

StatisticsChartPrintingMessage Class
VisualComponents.UX.Shared Namespace


StatisticsChartPrintingMessage.PrintObject Property

StatisticsChartPrintingMessagePrintObject Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Dictionary<string, Visual> PrintObject { get; set; }
public:
property Dictionary<String^, Visual^>^ PrintObject {
    Dictionary<String^, Visual^>^ get ();
    void set (Dictionary<String^, Visual^>^ value);
}

Property Value

Type: DictionaryString, Visual
See Also

Reference

StatisticsChartPrintingMessage Class
VisualComponents.UX.Shared Namespace


StatisticsChartPrintingMessage.StatisticsTab Property

StatisticsChartPrintingMessageStatisticsTab Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IStatisticsTab StatisticsTab { get; set; }
public:
property IStatisticsTab^ StatisticsTab {
    IStatisticsTab^ get ();
    void set (IStatisticsTab^ value);
}

Property Value

Type: IStatisticsTab
See Also

Reference

StatisticsChartPrintingMessage Class
VisualComponents.UX.Shared Namespace


StatisticsChartPrintingMessage Methods

The StatisticsChartPrintingMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

StatisticsChartPrintingMessage Class
VisualComponents.UX.Shared Namespace


StatisticsStateEditorView Class

Interaction logic for StatisticsStateEditorView.xaml
StatisticsStateEditorView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedStatisticsStateEditorView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class StatisticsStateEditorView : UserControl,
    IComponentConnector, IStyleConnector
public ref class StatisticsStateEditorView : public UserControl,
    IComponentConnector, IStyleConnector

The StatisticsStateEditorView type exposes the following members.

Constructors
 | Name | Description
Public method | StatisticsStateEditorView | Initializes a new instance of the StatisticsStateEditorView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


StatisticsStateEditorView Constructor

Initializes a new instance of the StatisticsStateEditorView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StatisticsStateEditorView()
public:
StatisticsStateEditorView()
See Also

Reference

StatisticsStateEditorView Class
VisualComponents.UX.Shared Namespace


StatisticsStateEditorView Properties

The StatisticsStateEditorView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

StatisticsStateEditorView Class
VisualComponents.UX.Shared Namespace


StatisticsStateEditorView Methods

The StatisticsStateEditorView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

StatisticsStateEditorView Class
VisualComponents.UX.Shared Namespace


StatisticsStateEditorView.InitializeComponent Method

StatisticsStateEditorViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

StatisticsStateEditorView Class
VisualComponents.UX.Shared Namespace


StatisticsStateEditorView Events

The StatisticsStateEditorView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

StatisticsStateEditorView Class
VisualComponents.UX.Shared Namespace


StringEnumHelper Class

Helper class for working with 'extended' enums using StringValueAttribute attributes.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedStringEnumHelper

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class StringEnumHelper
public ref class StringEnumHelper

The StringEnumHelper type exposes the following members.

Constructors
 | Name | Description
Public method | StringEnumHelper | Creates a new StringEnumHelper instance.
Top
Properties
 | Name | Description
Public property | EnumType | Gets the underlying enum type for this instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetListValues | Gets the values as a 'bindable' list datasource.
 | GetStringValue(Enum) | Gets a string value for a particular enum value.
Public method | GetStringValue(String) | Gets the string value associated with the given enum value.
Public method | GetStringValues | Gets the string values associated with the enum.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStringDefined(String) | Return the existence of the given string value within the enum.
Public method | IsStringDefined(String, Boolean) | Return the existence of the given string value within the enum.
 | IsStringDefined(Type, String) | Return the existence of the given string value within the enum.
 | IsStringDefined(Type, String, Boolean) | Return the existence of the given string value within the enum.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(Type, String) | Parses the supplied enum and string value to find an associated enum value (case sensitive).
 | Parse(Type, String, Boolean) | Parses the supplied enum and string value to find an associated enum value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


StringEnumHelper Constructor

Creates a new StringEnumHelper instance.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StringEnumHelper(
    Type enumType
)
public:
StringEnumHelper(
    Type^ enumType
)

Parameters

enumType
Type: SystemType
Enum type.
See Also

Reference

StringEnumHelper Class
VisualComponents.UX.Shared Namespace


StringEnumHelper Properties

The StringEnumHelper type exposes the following members.

Properties
 | Name | Description
Public property | EnumType | Gets the underlying enum type for this instance.
Top
See Also

Reference

StringEnumHelper Class
VisualComponents.UX.Shared Namespace


StringEnumHelper.EnumType Property

StringEnumHelperEnumType Property

Gets the underlying enum type for this instance.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Type EnumType { get; }
public:
property Type^ EnumType {
    Type^ get ();
}

Property Value

Type: Type
See Also

Reference

StringEnumHelper Class
VisualComponents.UX.Shared Namespace


StringEnumHelper Methods

The StringEnumHelper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetListValues | Gets the values as a 'bindable' list datasource.
 | GetStringValue(Enum) | Gets a string value for a particular enum value.
Public method | GetStringValue(String) | Gets the string value associated with the given enum value.
Public method | GetStringValues | Gets the string values associated with the enum.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsStringDefined(String) | Return the existence of the given string value within the enum.
Public method | IsStringDefined(String, Boolean) | Return the existence of the given string value within the enum.
 | IsStringDefined(Type, String) | Return the existence of the given string value within the enum.
 | IsStringDefined(Type, String, Boolean) | Return the existence of the given string value within the enum.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(Type, String) | Parses the supplied enum and string value to find an associated enum value (case sensitive).
 | Parse(Type, String, Boolean) | Parses the supplied enum and string value to find an associated enum value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

StringEnumHelper Class
VisualComponents.UX.Shared Namespace


StringEnumHelper.GetListValues Method

StringEnumHelperGetListValues Method

Gets the values as a 'bindable' list datasource.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IList GetListValues()
public:
IList^ GetListValues()

Return Value

Type: IList
IList for data binding
See Also

Reference

StringEnumHelper Class
VisualComponents.UX.Shared Namespace


StringEnumHelper.GetStringValue Method

StringEnumHelperGetStringValue Method

Overload List
 | Name | Description
 | GetStringValue(Enum) | Gets a string value for a particular enum value.
Public method | GetStringValue(String) | Gets the string value associated with the given enum value.
Top
See Also

Reference

StringEnumHelper Class
VisualComponents.UX.Shared Namespace


StringEnumHelper.GetStringValue Method (Enum)

StringEnumHelperGetStringValue Method (Enum)

Gets a string value for a particular enum value.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string GetStringValue(
    Enum value
)
public:
static String^ GetStringValue(
    Enum^ value
)

Parameters

value
Type: SystemEnum
Value.

Return Value

Type: String
String Value associated via a StringValueAttribute attribute, or null if not found.
See Also

Reference

StringEnumHelper Class
GetStringValue Overload
VisualComponents.UX.Shared Namespace


StringEnumHelper.GetStringValue Method (String)

StringEnumHelperGetStringValue Method (String)

Gets the string value associated with the given enum value.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string GetStringValue(
    string valueName
)
public:
String^ GetStringValue(
    String^ valueName
)

Parameters

valueName
Type: SystemString
Name of the enum value.

Return Value

Type: String
String Value
See Also

Reference

StringEnumHelper Class
GetStringValue Overload
VisualComponents.UX.Shared Namespace


StringEnumHelper.GetStringValues Method

StringEnumHelperGetStringValues Method

Gets the string values associated with the enum.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Array GetStringValues()
public:
Array^ GetStringValues()

Return Value

Type: Array
String value array
See Also

Reference

StringEnumHelper Class
VisualComponents.UX.Shared Namespace


StringEnumHelper.IsStringDefined Method

StringEnumHelperIsStringDefined Method

Overload List
 | Name | Description
Public method | IsStringDefined(String) | Return the existence of the given string value within the enum.
Public method | IsStringDefined(String, Boolean) | Return the existence of the given string value within the enum.
 | IsStringDefined(Type, String) | Return the existence of the given string value within the enum.
 | IsStringDefined(Type, String, Boolean) | Return the existence of the given string value within the enum.
Top
See Also

Reference

StringEnumHelper Class
VisualComponents.UX.Shared Namespace


StringEnumHelper.IsStringDefined Method (String)

StringEnumHelperIsStringDefined Method (String)

Return the existence of the given string value within the enum.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsStringDefined(
    string stringValue
)
public:
bool IsStringDefined(
    String^ stringValue
)

Parameters

stringValue
Type: SystemString
String value.

Return Value

Type: Boolean
Existence of the string value
See Also

Reference

StringEnumHelper Class
IsStringDefined Overload
VisualComponents.UX.Shared Namespace


StringEnumHelper.IsStringDefined Method (String, Boolean)

StringEnumHelperIsStringDefined Method (String, Boolean)

Return the existence of the given string value within the enum.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsStringDefined(
    string stringValue,
    bool ignoreCase
)
public:
bool IsStringDefined(
    String^ stringValue,
    bool ignoreCase
)

Parameters

stringValue
Type: SystemString
String value.
ignoreCase
Type: SystemBoolean
Denotes whether to conduct a case-insensitive match on the supplied string value

Return Value

Type: Boolean
Existence of the string value
See Also

Reference

StringEnumHelper Class
IsStringDefined Overload
VisualComponents.UX.Shared Namespace


StringEnumHelper.IsStringDefined Method (Type, String)

StringEnumHelperIsStringDefined Method (Type, String)

Return the existence of the given string value within the enum.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsStringDefined(
    Type enumType,
    string stringValue
)
public:
static bool IsStringDefined(
    Type^ enumType,
    String^ stringValue
)

Parameters

enumType
Type: SystemType
Type of enum
stringValue
Type: SystemString
String value.

Return Value

Type: Boolean
Existence of the string value
See Also

Reference

StringEnumHelper Class
IsStringDefined Overload
VisualComponents.UX.Shared Namespace


StringEnumHelper.IsStringDefined Method (Type, String, Boolean)

StringEnumHelperIsStringDefined Method (Type, String, Boolean)

Return the existence of the given string value within the enum.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsStringDefined(
    Type enumType,
    string stringValue,
    bool ignoreCase
)
public:
static bool IsStringDefined(
    Type^ enumType,
    String^ stringValue,
    bool ignoreCase
)

Parameters

enumType
Type: SystemType
Type of enum
stringValue
Type: SystemString
String value.
ignoreCase
Type: SystemBoolean
Denotes whether to conduct a case-insensitive match on the supplied string value

Return Value

Type: Boolean
Existence of the string value
See Also

Reference

StringEnumHelper Class
IsStringDefined Overload
VisualComponents.UX.Shared Namespace


StringEnumHelper.Parse Method

StringEnumHelperParse Method

Overload List
Name | Description
Parse(Type, String) | Parses the supplied enum and string value to find an associated enum value (case sensitive).
Parse(Type, String, Boolean) | Parses the supplied enum and string value to find an associated enum value.
Top
See Also

Reference

StringEnumHelper Class
VisualComponents.UX.Shared Namespace


StringEnumHelper.Parse Method (Type, String)

StringEnumHelperParse Method (Type, String)

Parses the supplied enum and string value to find an associated enum value (case sensitive).

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Object Parse(
    Type type,
    string stringValue
)
public:
static Object^ Parse(
    Type^ type,
    String^ stringValue
)

Parameters

type
Type: SystemType
Type.
stringValue
Type: SystemString
String value.

Return Value

Type: Object
Enum value associated with the string value, or null if not found.
See Also

Reference

StringEnumHelper Class
Parse Overload
VisualComponents.UX.Shared Namespace


StringEnumHelper.Parse Method (Type, String, Boolean)

StringEnumHelperParse Method (Type, String, Boolean)

Parses the supplied enum and string value to find an associated enum value.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Object Parse(
    Type type,
    string stringValue,
    bool ignoreCase
)
public:
static Object^ Parse(
    Type^ type,
    String^ stringValue,
    bool ignoreCase
)

Parameters

type
Type: SystemType
Type.
stringValue
Type: SystemString
String value.
ignoreCase
Type: SystemBoolean
Denotes whether to conduct a case-insensitive match on the supplied string value

Return Value

Type: Object
Enum value associated with the string value, or null if not found.
See Also

Reference

StringEnumHelper Class
Parse Overload
VisualComponents.UX.Shared Namespace


StringHelper Class

Helper class for String-related functions (sorting, comparison, conversion, etc.)
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedStringHelper

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class StringHelper
[ExtensionAttribute]
public ref class StringHelper abstract sealed

The StringHelper type exposes the following members.

Methods
Name | Description
CompareNaturally | Compares two strings naturally (alpha-numerically) and returns the result of comparison: 0 = strings are equal, 1 = source string is "bigger", -1 = target string is "bigger".
SortNaturally(IList) | Sorts the list naturally (alpha-numerically) by string representations of its items.
SortNaturally(IList, Int32, Int32) | Sorts the list naturally (alpha-numerically) by string representations of its items.
SortNaturallyT(ObservableCollectionExT) | Sorts the list naturally (alpha-numerically) by string representations of its items.
SortNaturallyT(ObservableCollectionExT, Int32, Int32) | Sorts the ObservableCollectionT naturally (alpha-numerically) by string representations of its items.
Truncate | Truncates a number to the specified count of decimal places. If respectZeroes is 'false', zeroes before the first non-zero digit will not be counted, i.e. "0.000123456".Truncate (2, false) will return the string "0.00012".
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


StringHelper Methods

The StringHelper type exposes the following members.

Methods
Name | Description
CompareNaturally | Compares two strings naturally (alpha-numerically) and returns the result of comparison: 0 = strings are equal, 1 = source string is "bigger", -1 = target string is "bigger".
SortNaturally(IList) | Sorts the list naturally (alpha-numerically) by string representations of its items.
SortNaturally(IList, Int32, Int32) | Sorts the list naturally (alpha-numerically) by string representations of its items.
SortNaturallyT(ObservableCollectionExT) | Sorts the list naturally (alpha-numerically) by string representations of its items.
SortNaturallyT(ObservableCollectionExT, Int32, Int32) | Sorts the ObservableCollectionT naturally (alpha-numerically) by string representations of its items.
Truncate | Truncates a number to the specified count of decimal places. If respectZeroes is 'false', zeroes before the first non-zero digit will not be counted, i.e. "0.000123456".Truncate (2, false) will return the string "0.00012".
Top
See Also

Reference

StringHelper Class
VisualComponents.UX.Shared Namespace


StringHelper.CompareNaturally Method

StringHelperCompareNaturally Method

Compares two strings naturally (alpha-numerically) and returns the result of comparison:
0 = strings are equal,
1 = source string is "bigger",
-1 = target string is "bigger".

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static int CompareNaturally(
    string source,
    string target,
    bool descending = false
)
public:
static int CompareNaturally(
    String^ source,
    String^ target,
    bool descending = false
)

Parameters

source
Type: SystemString
target
Type: SystemString
descending (Optional)
Type: SystemBoolean

Return Value

Type: Int32

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.StringHelper.CompareNaturally(System.String,System.String,System.Boolean)"]

See Also

Reference

StringHelper Class
VisualComponents.UX.Shared Namespace


StringHelper.SortNaturally Method

StringHelperSortNaturally Method

Overload List
Name | Description
SortNaturally(IList) | Sorts the list naturally (alpha-numerically) by string representations of its items.
SortNaturallyT(ObservableCollectionExT) | Sorts the list naturally (alpha-numerically) by string representations of its items.
SortNaturally(IList, Int32, Int32) | Sorts the list naturally (alpha-numerically) by string representations of its items.
SortNaturallyT(ObservableCollectionExT, Int32, Int32) | Sorts the ObservableCollectionT naturally (alpha-numerically) by string representations of its items.
Top
See Also

Reference

StringHelper Class
VisualComponents.UX.Shared Namespace


StringHelper.SortNaturally Method (IList)

StringHelperSortNaturally Method (IList)

Sorts the list naturally (alpha-numerically) by string representations of its items.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SortNaturally(
    this IList list
)
public:
[ExtensionAttribute]
static void SortNaturally(
    IList^ list
)

Parameters

list
Type: System.CollectionsIList

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IList. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringHelper Class
SortNaturally Overload
VisualComponents.UX.Shared Namespace


StringHelper.SortNaturally(T) Method (ObservableCollectionEx(T))

StringHelperSortNaturallyT Method (ObservableCollectionExT)

Sorts the list naturally (alpha-numerically) by string representations of its items.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SortNaturally<T>(
    this ObservableCollectionEx<T> collection
)

public:
[ExtensionAttribute]
generic<typename T>
static void SortNaturally(
    ObservableCollectionEx<T>^ collection
)

Parameters

collection
Type: VisualComponents.UX.Shared.ControlsObservableCollectionEx T

Type Parameters

T

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ObservableCollectionEx T. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringHelper Class
SortNaturally Overload
VisualComponents.UX.Shared Namespace


StringHelper.SortNaturally Method (IList, Int32, Int32)

StringHelperSortNaturally Method (IList, Int32, Int32)

Sorts the list naturally (alpha-numerically) by string representations of its items.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SortNaturally(
    this IList list,
    int start,
    int end
)
public:
[ExtensionAttribute]
static void SortNaturally(
    IList^ list,
    int start,
    int end
)

Parameters

list
Type: System.CollectionsIList
start
Type: SystemInt32
end
Type: SystemInt32

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IList. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringHelper Class
SortNaturally Overload
VisualComponents.UX.Shared Namespace


StringHelper.SortNaturally(T) Method (ObservableCollectionEx(T), Int32, Int32)

StringHelperSortNaturallyT Method (ObservableCollectionExT, Int32, Int32)

Sorts the ObservableCollectionT naturally (alpha-numerically) by string representations of its items.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SortNaturally<T>(
    this ObservableCollectionEx<T> collection,
    int start,
    int end
)

public:
[ExtensionAttribute]
generic<typename T>
static void SortNaturally(
    ObservableCollectionEx<T>^ collection,
    int start,
    int end
)

Parameters

collection
Type: VisualComponents.UX.Shared.ControlsObservableCollectionEx T
start
Type: SystemInt32
end
Type: SystemInt32

Type Parameters

T

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ObservableCollectionEx T. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringHelper Class
SortNaturally Overload
VisualComponents.UX.Shared Namespace


StringHelper.Truncate Method

StringHelperTruncate Method

Truncates a number to the specified count of decimal places. If respectZeroes is 'false', zeroes before the first non-zero digit will not be counted, i.e. "0.000123456".Truncate (2, false) will return the string "0.00012".

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string Truncate(
    this string number,
    int decimalPlaces,
    bool respectZeroes = true
)
public:
[ExtensionAttribute]
static String^ Truncate(
    String^ number,
    int decimalPlaces,
    bool respectZeroes = true
)

Parameters

number
Type: SystemString
decimalPlaces
Type: SystemInt32
respectZeroes (Optional)
Type: SystemBoolean

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.StringHelper.Truncate(System.String,System.Int32,System.Boolean)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringHelper Class
VisualComponents.UX.Shared Namespace


StringToPathGeometryConverter Class

String to path geometry converter
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedStringToPathGeometryConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class StringToPathGeometryConverter : IValueConverter
public ref class StringToPathGeometryConverter : IValueConverter

The StringToPathGeometryConverter type exposes the following members.

Constructors
 | Name | Description
Public method | StringToPathGeometryConverter | Initializes a new instance of the StringToPathGeometryConverter class
Top
Methods
 | Name | Description
Public method | Convert(String) | Main conversion routine - converts string path data definition to PathGeometry object
Public method | Convert(Object, Type, Object, CultureInfo) |
Public method | ConvertBack(PathGeometry) | Main back conversion routine - converts PathGeometry object to its string equivalent
Public method | ConvertBack(Object, Type, Object, CultureInfo) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


StringToPathGeometryConverter Constructor

Initializes a new instance of the StringToPathGeometryConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StringToPathGeometryConverter()
public:
StringToPathGeometryConverter()
See Also

Reference

StringToPathGeometryConverter Class
VisualComponents.UX.Shared Namespace


StringToPathGeometryConverter Methods

The StringToPathGeometryConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert(String) | Main conversion routine - converts string path data definition to PathGeometry object
Public method | Convert(Object, Type, Object, CultureInfo) |
Public method | ConvertBack(PathGeometry) | Main back conversion routine - converts PathGeometry object to its string equivalent
Public method | ConvertBack(Object, Type, Object, CultureInfo) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

StringToPathGeometryConverter Class
VisualComponents.UX.Shared Namespace


StringToPathGeometryConverter.Convert Method

StringToPathGeometryConverterConvert Method

Overload List
 | Name | Description
Public method | Convert(String) | Main conversion routine - converts string path data definition to PathGeometry object
Public method | Convert(Object, Type, Object, CultureInfo) |
Top
See Also

Reference

StringToPathGeometryConverter Class
VisualComponents.UX.Shared Namespace


StringToPathGeometryConverter.Convert Method (String)

StringToPathGeometryConverterConvert Method (String)

Main conversion routine - converts string path data definition to PathGeometry object

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public PathGeometry Convert(
    string path
)
public:
PathGeometry^ Convert(
    String^ path
)

Parameters

path
Type: SystemString
String with path data definition

Return Value

Type: PathGeometry
PathGeometry object created from string definition
See Also

Reference

StringToPathGeometryConverter Class
Convert Overload
VisualComponents.UX.Shared Namespace


StringToPathGeometryConverter.Convert Method (Object, Type, Object, CultureInfo)

StringToPathGeometryConverterConvert Method (Object, Type, Object, CultureInfo)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.StringToPathGeometryConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

StringToPathGeometryConverter Class
Convert Overload
VisualComponents.UX.Shared Namespace


StringToPathGeometryConverter.ConvertBack Method

StringToPathGeometryConverterConvertBack Method

Overload List
 | Name | Description
Public method | ConvertBack(PathGeometry) | Main back conversion routine - converts PathGeometry object to its string equivalent
Public method | ConvertBack(Object, Type, Object, CultureInfo) |
Top
See Also

Reference

StringToPathGeometryConverter Class
VisualComponents.UX.Shared Namespace


StringToPathGeometryConverter.ConvertBack Method (PathGeometry)

StringToPathGeometryConverterConvertBack Method (PathGeometry)

Main back conversion routine - converts PathGeometry object to its string equivalent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ConvertBack(
    PathGeometry geometry
)
public:
String^ ConvertBack(
    PathGeometry^ geometry
)

Parameters

geometry
Type: System.Windows.MediaPathGeometry
Path Geometry object

Return Value

Type: String
String equivalent to PathGeometry contents
See Also

Reference

StringToPathGeometryConverter Class
ConvertBack Overload
VisualComponents.UX.Shared Namespace


StringToPathGeometryConverter.ConvertBack Method (Object, Type, Object, CultureInfo)

StringToPathGeometryConverterConvertBack Method (Object, Type, Object, CultureInfo)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.StringToPathGeometryConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

StringToPathGeometryConverter Class
ConvertBack Overload
VisualComponents.UX.Shared Namespace


StringToResourceConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedStringToResourceConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class StringToResourceConverter : IMultiValueConverter
public ref class StringToResourceConverter : IMultiValueConverter

The StringToResourceConverter type exposes the following members.

Constructors
 | Name | Description
Public method | StringToResourceConverter | Initializes a new instance of the StringToResourceConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


StringToResourceConverter Constructor

Initializes a new instance of the StringToResourceConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StringToResourceConverter()
public:
StringToResourceConverter()
See Also

Reference

StringToResourceConverter Class
VisualComponents.UX.Shared Namespace


StringToResourceConverter Methods

The StringToResourceConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

StringToResourceConverter Class
VisualComponents.UX.Shared Namespace


StringToResourceConverter.Convert Method

StringToResourceConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    array<Object^>^ values,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

values
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.StringToResourceConverter.Convert(System.Object[],System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

StringToResourceConverter Class
VisualComponents.UX.Shared Namespace


StringToResourceConverter.ConvertBack Method

StringToResourceConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
public:
virtual array<Object^>^ ConvertBack(
    Object^ value,
    array<Type^>^ targetTypes,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetTypes
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.StringToResourceConverter.ConvertBack(System.Object,System.Type[],System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

StringToResourceConverter Class
VisualComponents.UX.Shared Namespace


StringToTrimmedConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedStringToTrimmedConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class StringToTrimmedConverter : IValueConverter
public ref class StringToTrimmedConverter : IValueConverter

The StringToTrimmedConverter type exposes the following members.

Constructors
 | Name | Description
Public method | StringToTrimmedConverter | Initializes a new instance of the StringToTrimmedConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


StringToTrimmedConverter Constructor

Initializes a new instance of the StringToTrimmedConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StringToTrimmedConverter()
public:
StringToTrimmedConverter()
See Also

Reference

StringToTrimmedConverter Class
VisualComponents.UX.Shared Namespace


StringToTrimmedConverter Methods

The StringToTrimmedConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

StringToTrimmedConverter Class
VisualComponents.UX.Shared Namespace


StringToTrimmedConverter.Convert Method

StringToTrimmedConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.StringToTrimmedConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

StringToTrimmedConverter Class
VisualComponents.UX.Shared Namespace


StringToTrimmedConverter.ConvertBack Method

StringToTrimmedConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.StringToTrimmedConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

StringToTrimmedConverter Class
VisualComponents.UX.Shared Namespace


StringToUriConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedStringToUriConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class StringToUriConverter : IValueConverter
public ref class StringToUriConverter : IValueConverter

The StringToUriConverter type exposes the following members.

Constructors
 | Name | Description
Public method | StringToUriConverter | Initializes a new instance of the StringToUriConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


StringToUriConverter Constructor

Initializes a new instance of the StringToUriConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StringToUriConverter()
public:
StringToUriConverter()
See Also

Reference

StringToUriConverter Class
VisualComponents.UX.Shared Namespace


StringToUriConverter Methods

The StringToUriConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

StringToUriConverter Class
VisualComponents.UX.Shared Namespace


StringToUriConverter.Convert Method

StringToUriConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.StringToUriConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

StringToUriConverter Class
VisualComponents.UX.Shared Namespace


StringToUriConverter.ConvertBack Method

StringToUriConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.StringToUriConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

StringToUriConverter Class
VisualComponents.UX.Shared Namespace


StringValueAttribute Class

Simple attribute class for storing String Values
Inheritance Hierarchy
SystemObject
SystemAttribute
VisualComponents.UX.SharedStringValueAttribute

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class StringValueAttribute : Attribute
public ref class StringValueAttribute : public Attribute

The StringValueAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | StringValueAttribute | Creates a new StringValueAttribute instance.
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Value | Gets the value.
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


StringValueAttribute Constructor

Creates a new StringValueAttribute instance.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public StringValueAttribute(
    string value
)
public:
StringValueAttribute(
    String^ value
)

Parameters

value
Type: SystemString
Value.
See Also

Reference

StringValueAttribute Class
VisualComponents.UX.Shared Namespace


StringValueAttribute Properties

The StringValueAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Value | Gets the value.
Top
See Also

Reference

StringValueAttribute Class
VisualComponents.UX.Shared Namespace


StringValueAttribute.Value Property

StringValueAttributeValue Property

Gets the value.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Value { get; }
public:
property String^ Value {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

StringValueAttribute Class
VisualComponents.UX.Shared Namespace


StringValueAttribute Methods

The StringValueAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

StringValueAttribute Class
VisualComponents.UX.Shared Namespace


SvgImage Class

Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
VisualComponents.UX.SharedSvgImage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class SvgImage : Control
public ref class SvgImage : public Control

The SvgImage type exposes the following members.

Constructors
 | Name | Description
Public method | SvgImage | Initializes a new instance of the SvgImage class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DefaultFill | Gets or sets a brush that described the default primary fill color. You dont need to set this value.
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DisabledFill | Gets or sets a brush that described the disabled state fill color.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled |
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMonolithicIcon |
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | PrimaryFill | Gets or sets a brush that described the primary fill color.
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | SvgSource |
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
 | ConvertToSolidColorBrush |
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
 | GetIconPathDictionary |
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
 | IsEqual |
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Fields
Name | Description
DefaultFillProperty |
DisabledFillProperty |
IsEnabledProperty |
IsMonolithicIconProperty |
PrimaryFillProperty |
SvgSourceProperty |
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


SvgImage Constructor

Initializes a new instance of the SvgImage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SvgImage()
public:
SvgImage()
See Also

Reference

SvgImage Class
VisualComponents.UX.Shared Namespace


SvgImage Properties

The SvgImage type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DefaultFill | Gets or sets a brush that described the default primary fill color. You dont need to set this value.
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DisabledFill | Gets or sets a brush that described the disabled state fill color.
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled |
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMonolithicIcon |
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator for logical child elements of this element. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | PrimaryFill | Gets or sets a brush that described the primary fill color.
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | SvgSource |
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

SvgImage Class
VisualComponents.UX.Shared Namespace


SvgImage.DefaultFill Property

SvgImageDefaultFill Property

Gets or sets a brush that described the default primary fill color. You dont need to set this value.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SolidColorBrush DefaultFill { get; set; }
public:
property SolidColorBrush^ DefaultFill {
    SolidColorBrush^ get ();
    void set (SolidColorBrush^ value);
}

Property Value

Type: SolidColorBrush
See Also

Reference

SvgImage Class
VisualComponents.UX.Shared Namespace


SvgImage.DisabledFill Property

SvgImageDisabledFill Property

Gets or sets a brush that described the disabled state fill color.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SolidColorBrush DisabledFill { get; set; }
public:
property SolidColorBrush^ DisabledFill {
    SolidColorBrush^ get ();
    void set (SolidColorBrush^ value);
}

Property Value

Type: SolidColorBrush
See Also

Reference

SvgImage Class
VisualComponents.UX.Shared Namespace


SvgImage.IsEnabled Property

SvgImageIsEnabled Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsEnabled { get; set; }
public:
property bool IsEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SvgImage Class
VisualComponents.UX.Shared Namespace


SvgImage.IsMonolithicIcon Property

SvgImageIsMonolithicIcon Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsMonolithicIcon { get; set; }
public:
property bool IsMonolithicIcon {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SvgImage Class
VisualComponents.UX.Shared Namespace


SvgImage.PrimaryFill Property

SvgImagePrimaryFill Property

Gets or sets a brush that described the primary fill color.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public SolidColorBrush PrimaryFill { get; set; }
public:
property SolidColorBrush^ PrimaryFill {
    SolidColorBrush^ get ();
    void set (SolidColorBrush^ value);
}

Property Value

Type: SolidColorBrush
See Also

Reference

SvgImage Class
VisualComponents.UX.Shared Namespace


SvgImage.SvgSource Property

SvgImageSvgSource Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SvgSource { get; set; }
public:
property String^ SvgSource {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SvgImage Class
VisualComponents.UX.Shared Namespace


SvgImage Methods

The SvgImage type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
 | ConvertToSolidColorBrush |
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
 | GetIconPathDictionary |
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
 | IsEqual |
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | (Overrides FrameworkElementOnApplyTemplate.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

SvgImage Class
VisualComponents.UX.Shared Namespace


SvgImage.ConvertToSolidColorBrush Method

SvgImageConvertToSolidColorBrush Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static SolidColorBrush ConvertToSolidColorBrush(
    Object value
)
public:
static SolidColorBrush^ ConvertToSolidColorBrush(
    Object^ value
)

Parameters

value
Type: SystemObject

Return Value

Type: SolidColorBrush

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SvgImage.ConvertToSolidColorBrush(System.Object)"]

See Also

Reference

SvgImage Class
VisualComponents.UX.Shared Namespace


SvgImage.GetIconPathDictionary Method

SvgImageGetIconPathDictionary Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static VCPathObject GetIconPathDictionary(
    string fileName
)
public:
static VCPathObject^ GetIconPathDictionary(
    String^ fileName
)

Parameters

fileName
Type: SystemString

Return Value

Type: VCPathObject

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SvgImage.GetIconPathDictionary(System.String)"]

See Also

Reference

SvgImage Class
VisualComponents.UX.Shared Namespace


SvgImage.IsEqual Method

SvgImageIsEqual Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsEqual(
    Brush aBrush1,
    Brush aBrush2
)
public:
static bool IsEqual(
    Brush^ aBrush1,
    Brush^ aBrush2
)

Parameters

aBrush1
Type: System.Windows.MediaBrush
aBrush2
Type: System.Windows.MediaBrush

Return Value

Type: Boolean

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.SvgImage.IsEqual(System.Windows.Media.Brush,System.Windows.Media.Brush)"]

See Also

Reference

SvgImage Class
VisualComponents.UX.Shared Namespace


SvgImage.OnApplyTemplate Method

SvgImageOnApplyTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override void OnApplyTemplate()
public:
virtual void OnApplyTemplate() override
See Also

Reference

SvgImage Class
VisualComponents.UX.Shared Namespace


SvgImage Events

The SvgImage type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

SvgImage Class
VisualComponents.UX.Shared Namespace


SvgImage Fields

The SvgImage type exposes the following members.

Fields
Name | Description
DefaultFillProperty |
DisabledFillProperty |
IsEnabledProperty |
IsMonolithicIconProperty |
PrimaryFillProperty |
SvgSourceProperty |
Top
See Also

Reference

SvgImage Class
VisualComponents.UX.Shared Namespace


SvgImage.DefaultFillProperty Field

SvgImageDefaultFillProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty DefaultFillProperty
public:
static initonly DependencyProperty^ DefaultFillProperty

Field Value

Type: DependencyProperty
See Also

Reference

SvgImage Class
VisualComponents.UX.Shared Namespace


SvgImage.DisabledFillProperty Field

SvgImageDisabledFillProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty DisabledFillProperty
public:
static initonly DependencyProperty^ DisabledFillProperty

Field Value

Type: DependencyProperty
See Also

Reference

SvgImage Class
VisualComponents.UX.Shared Namespace


SvgImage.IsEnabledProperty Field

SvgImageIsEnabledProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsEnabledProperty
public:
static initonly DependencyProperty^ IsEnabledProperty

Field Value

Type: DependencyProperty
See Also

Reference

SvgImage Class
VisualComponents.UX.Shared Namespace


SvgImage.IsMonolithicIconProperty Field

SvgImageIsMonolithicIconProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsMonolithicIconProperty
public:
static initonly DependencyProperty^ IsMonolithicIconProperty

Field Value

Type: DependencyProperty
See Also

Reference

SvgImage Class
VisualComponents.UX.Shared Namespace


SvgImage.PrimaryFillProperty Field

SvgImagePrimaryFillProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty PrimaryFillProperty
public:
static initonly DependencyProperty^ PrimaryFillProperty

Field Value

Type: DependencyProperty
See Also

Reference

SvgImage Class
VisualComponents.UX.Shared Namespace


SvgImage.SvgSourceProperty Field

SvgImageSvgSourceProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty SvgSourceProperty
public:
static initonly DependencyProperty^ SvgSourceProperty

Field Value

Type: DependencyProperty
See Also

Reference

SvgImage Class
VisualComponents.UX.Shared Namespace


Tab Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedLayoutElement
VisualComponents.UX.SharedTab

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class Tab : LayoutElement, INotifyPropertyChanged
public ref class Tab sealed : public LayoutElement,
    INotifyPropertyChanged

The Tab type exposes the following members.

Constructors
 | Name | Description
Public method | Tab | Initializes a new instance of the Tab class
Top
Properties
 | Name | Description
Public property | Children | Provides capability to add child elements to any layout element. (Inherited from LayoutElement.)
Public property | ElementType | (Inherited from LayoutElement.)
Public property | SelectedTabItem | selected tab item
Public property | SelectedTabName | Selected tab name
Public property | TabPages | read only list of available tab pages
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | selected tab change event
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


Tab Constructor

Initializes a new instance of the Tab class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Tab()
public:
Tab()
See Also

Reference

Tab Class
VisualComponents.UX.Shared Namespace


Tab Properties

The Tab type exposes the following members.

Properties
 | Name | Description
Public property | Children | Provides capability to add child elements to any layout element. (Inherited from LayoutElement.)
Public property | ElementType | (Inherited from LayoutElement.)
Public property | SelectedTabItem | selected tab item
Public property | SelectedTabName | Selected tab name
Public property | TabPages | read only list of available tab pages
Top
See Also

Reference

Tab Class
VisualComponents.UX.Shared Namespace


Tab.SelectedTabItem Property

TabSelectedTabItem Property

selected tab item

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TabPage SelectedTabItem { get; set; }
public:
property TabPage^ SelectedTabItem {
    TabPage^ get ();
    void set (TabPage^ value);
}

Property Value

Type: TabPage
See Also

Reference

Tab Class
VisualComponents.UX.Shared Namespace


Tab.SelectedTabName Property

TabSelectedTabName Property

Selected tab name

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string SelectedTabName { get; set; }
public:
property String^ SelectedTabName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Tab Class
VisualComponents.UX.Shared Namespace


Tab.TabPages Property

TabTabPages Property

read only list of available tab pages

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<TabPage> TabPages { get; }
public:
property ReadOnlyCollection<TabPage^>^ TabPages {
    ReadOnlyCollection<TabPage^>^ get ();
}

Property Value

Type: ReadOnlyCollectionTabPage
See Also

Reference

Tab Class
VisualComponents.UX.Shared Namespace


Tab Methods

The Tab type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

Tab Class
VisualComponents.UX.Shared Namespace


Tab Events

The Tab type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | selected tab change event
Top
See Also

Reference

Tab Class
VisualComponents.UX.Shared Namespace


Tab.PropertyChanged Event

TabPropertyChanged Event

selected tab change event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event PropertyChangedEventHandler PropertyChanged
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

Tab Class
VisualComponents.UX.Shared Namespace


TabHeadearProperties Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedTabHeadearProperties

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class TabHeadearProperties
public ref class TabHeadearProperties abstract sealed

The TabHeadearProperties type exposes the following members.

Methods
Name | Description
GetHeaderVisibility |
SetHeaderVisibility |
Top
Fields
Name | Description
HeaderVisibilityProperty |
Top
Attached Properties
 | Name | Description
Public attached property | HeaderVisibility |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


TabHeadearProperties Methods

The TabHeadearProperties type exposes the following members.

Methods
Name | Description
GetHeaderVisibility |
SetHeaderVisibility |
Top
See Also

Reference

TabHeadearProperties Class
VisualComponents.UX.Shared Namespace


TabHeadearProperties.GetHeaderVisibility Method

TabHeadearPropertiesGetHeaderVisibility Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Visibility GetHeaderVisibility(
    DependencyObject obj
)
public:
static Visibility GetHeaderVisibility(
    DependencyObject^ obj
)

Parameters

obj
Type: System.WindowsDependencyObject

Return Value

Type: Visibility

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TabHeadearProperties.GetHeaderVisibility(System.Windows.DependencyObject)"]

See Also

Reference

TabHeadearProperties Class
VisualComponents.UX.Shared Namespace


TabHeadearProperties.SetHeaderVisibility Method

TabHeadearPropertiesSetHeaderVisibility Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static void SetHeaderVisibility(
    DependencyObject obj,
    Visibility value
)
public:
static void SetHeaderVisibility(
    DependencyObject^ obj,
    Visibility value
)

Parameters

obj
Type: System.WindowsDependencyObject
value
Type: System.WindowsVisibility
See Also

Reference

TabHeadearProperties Class
VisualComponents.UX.Shared Namespace


TabHeadearProperties Fields

The TabHeadearProperties type exposes the following members.

Fields
Name | Description
HeaderVisibilityProperty |
Top
See Also

Reference

TabHeadearProperties Class
VisualComponents.UX.Shared Namespace


TabHeadearProperties.HeaderVisibilityProperty Field

TabHeadearPropertiesHeaderVisibilityProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty HeaderVisibilityProperty
public:
static initonly DependencyProperty^ HeaderVisibilityProperty

Field Value

Type: DependencyProperty
See Also

Reference

TabHeadearProperties Class
VisualComponents.UX.Shared Namespace


TabHeadearProperties Attached Properties

The TabHeadearProperties type exposes the following members.

Attached Properties
 | Name | Description
Public attached property | HeaderVisibility |
Top
See Also

Reference

TabHeadearProperties Class
VisualComponents.UX.Shared Namespace


TabHeadearProperties.HeaderVisibility Attached Property

TabHeadearPropertiesHeaderVisibility Attached Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
See GetHeaderVisibility, SetHeaderVisibility
See GetHeaderVisibility, SetHeaderVisibility

Property Value

Type: Visibility
See Also

Reference

TabHeadearProperties Class
VisualComponents.UX.Shared Namespace


TabOrPropertyLayoutDataTemplateSelector Class

Inheritance Hierarchy
SystemObject
System.Windows.ControlsDataTemplateSelector
VisualComponents.UX.SharedTabOrPropertyLayoutDataTemplateSelector

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TabOrPropertyLayoutDataTemplateSelector : DataTemplateSelector
public ref class TabOrPropertyLayoutDataTemplateSelector : public DataTemplateSelector

The TabOrPropertyLayoutDataTemplateSelector type exposes the following members.

Constructors
 | Name | Description
Public method | TabOrPropertyLayoutDataTemplateSelector | Initializes a new instance of the TabOrPropertyLayoutDataTemplateSelector class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SelectTemplate | (Overrides DataTemplateSelectorSelectTemplate(Object, DependencyObject).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


TabOrPropertyLayoutDataTemplateSelector Constructor

Initializes a new instance of the TabOrPropertyLayoutDataTemplateSelector class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TabOrPropertyLayoutDataTemplateSelector()
public:
TabOrPropertyLayoutDataTemplateSelector()
See Also

Reference

TabOrPropertyLayoutDataTemplateSelector Class
VisualComponents.UX.Shared Namespace


TabOrPropertyLayoutDataTemplateSelector Methods

The TabOrPropertyLayoutDataTemplateSelector type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SelectTemplate | (Overrides DataTemplateSelectorSelectTemplate(Object, DependencyObject).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TabOrPropertyLayoutDataTemplateSelector Class
VisualComponents.UX.Shared Namespace


TabOrPropertyLayoutDataTemplateSelector.SelectTemplate Method

TabOrPropertyLayoutDataTemplateSelectorSelectTemplate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public override DataTemplate SelectTemplate(
    Object item,
    DependencyObject container
)
public:
virtual DataTemplate^ SelectTemplate(
    Object^ item,
    DependencyObject^ container
) override

Parameters

item
Type: SystemObject
container
Type: System.WindowsDependencyObject

Return Value

Type: DataTemplate

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TabOrPropertyLayoutDataTemplateSelector.SelectTemplate(System.Object,System.Windows.DependencyObject)"]

See Also

Reference

TabOrPropertyLayoutDataTemplateSelector Class
VisualComponents.UX.Shared Namespace


TabPage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedLayoutElement
VisualComponents.UX.SharedTabPage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class TabPage : LayoutElement,
    INotifyPropertyChanged
public ref class TabPage sealed : public LayoutElement,
    INotifyPropertyChanged

The TabPage type exposes the following members.

Constructors
 | Name | Description
Public method | TabPage | Initializes a new instance of the TabPage class
Top
Properties
 | Name | Description
Public property | Children | Provides capability to add child elements to any layout element. (Inherited from LayoutElement.)
Public property | Controls |
Public property | ElementType | (Inherited from LayoutElement.)
Public property | Label |
Public property | Rows |
Public property | UsesUserControl | True if ViewModel is defined to represent UserControl
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NotifyPropertyChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


TabPage Constructor

Initializes a new instance of the TabPage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TabPage()
public:
TabPage()
See Also

Reference

TabPage Class
VisualComponents.UX.Shared Namespace


TabPage Properties

The TabPage type exposes the following members.

Properties
 | Name | Description
Public property | Children | Provides capability to add child elements to any layout element. (Inherited from LayoutElement.)
Public property | Controls |
Public property | ElementType | (Inherited from LayoutElement.)
Public property | Label |
Public property | Rows |
Public property | UsesUserControl | True if ViewModel is defined to represent UserControl
Top
See Also

Reference

TabPage Class
VisualComponents.UX.Shared Namespace


TabPage.Controls Property

TabPageControls Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<ControlDescription> Controls { get; }
public:
property ReadOnlyCollection<ControlDescription^>^ Controls {
    ReadOnlyCollection<ControlDescription^>^ get ();
}

Property Value

Type: ReadOnlyCollectionControlDescription
See Also

Reference

TabPage Class
VisualComponents.UX.Shared Namespace


TabPage.Label Property

TabPageLabel Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Label { get; set; }
public:
property String^ Label {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

TabPage Class
VisualComponents.UX.Shared Namespace


TabPage.Rows Property

TabPageRows Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ReadOnlyCollection<Row> Rows { get; }
public:
property ReadOnlyCollection<Row^>^ Rows {
    ReadOnlyCollection<Row^>^ get ();
}

Property Value

Type: ReadOnlyCollectionRow
See Also

Reference

TabPage Class
VisualComponents.UX.Shared Namespace


TabPage.UsesUserControl Property

TabPageUsesUserControl Property

True if ViewModel is defined to represent UserControl

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool UsesUserControl { get; }
public:
property bool UsesUserControl {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

TabPage Class
VisualComponents.UX.Shared Namespace


TabPage Methods

The TabPage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NotifyPropertyChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TabPage Class
VisualComponents.UX.Shared Namespace


TabPage.NotifyPropertyChanged Method

TabPageNotifyPropertyChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void NotifyPropertyChanged(
    string propertyName
)
public:
void NotifyPropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: SystemString
See Also

Reference

TabPage Class
VisualComponents.UX.Shared Namespace


TabPage Events

The TabPage type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

TabPage Class
VisualComponents.UX.Shared Namespace


TabPage.PropertyChanged Event

TabPagePropertyChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event PropertyChangedEventHandler PropertyChanged
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

TabPage Class
VisualComponents.UX.Shared Namespace


TextFieldEditorView Class

Interaction logic for TextFeatureEditorView.xaml
TextFieldEditorView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedTextFieldEditorView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TextFieldEditorView : UserControl,
    IComponentConnector
public ref class TextFieldEditorView : public UserControl,
    IComponentConnector

The TextFieldEditorView type exposes the following members.

Constructors
 | Name | Description
Public method | TextFieldEditorView | Initializes a new instance of the TextFieldEditorView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


TextFieldEditorView Constructor

Initializes a new instance of the TextFieldEditorView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TextFieldEditorView()
public:
TextFieldEditorView()
See Also

Reference

TextFieldEditorView Class
VisualComponents.UX.Shared Namespace


TextFieldEditorView Properties

The TextFieldEditorView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

TextFieldEditorView Class
VisualComponents.UX.Shared Namespace


TextFieldEditorView Methods

The TextFieldEditorView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TextFieldEditorView Class
VisualComponents.UX.Shared Namespace


TextFieldEditorView.InitializeComponent Method

TextFieldEditorViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

TextFieldEditorView Class
VisualComponents.UX.Shared Namespace


TextFieldEditorView Events

The TextFieldEditorView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

TextFieldEditorView Class
VisualComponents.UX.Shared Namespace


TextFieldEditorViewModel Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
ViewAware
Screen
VisualComponents.UX.SharedTextFieldEditorViewModel

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TextFieldEditorViewModel : Screen,
    ITextFieldEditorViewModel, INotifyPropertyChanged, IHandle<PickMessage>, IHandle,
    IHandle<SelectedRibbonTabChangedMessage>
public ref class TextFieldEditorViewModel : public Screen,
    ITextFieldEditorViewModel, INotifyPropertyChanged, IHandle<PickMessage^>, IHandle,
    IHandle<SelectedRibbonTabChangedMessage^>

The TextFieldEditorViewModel type exposes the following members.

Constructors
 | Name | Description
Public method | TextFieldEditorViewModel | Initializes a new instance of the TextFieldEditorViewModel class
Top
Properties
 | Name | Description
Protected property | CacheViews | (Inherited from ViewAware.)
Public property | DisplayName | (Inherited from Screen.)
Public property | IsActive | (Inherited from Screen.)
Public property | IsInitialized | (Inherited from Screen.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsVisible |
Public property | Parent | (Inherited from Screen.)
Public property | Text |
Public property | TextSet |
Public property | XPosition |
Public property | YPosition |
Top
Methods
 | Name | Description
Public method | CanClose | (Inherited from Screen.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetView | (Inherited from ViewAware.)
Public method | Handle(PickMessage) |
Public method | Handle(SelectedRibbonTabChangedMessage) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Protected method | OnActivate | (Inherited from Screen.)
Protected method | OnDeactivate | (Inherited from Screen.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnInitialize | (Inherited from Screen.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Protected method | OnViewAttached | (Inherited from ViewAware.)
Protected method | OnViewLoaded | (Overrides ViewAware.OnViewLoaded(Object).)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryClose | (Inherited from Screen.)
Public method | TryClose(NullableBoolean) | (Inherited from Screen.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from Screen.)
Public event | AttemptingDeactivation | (Inherited from Screen.)
Public event | Deactivated | (Inherited from Screen.)
Public event | PropertyChanged |
Public event | ViewAttached | (Inherited from ViewAware.)
Top
Fields
 | Name | Description
Protected field | Views | (Inherited from ViewAware.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


TextFieldEditorViewModel Constructor

Initializes a new instance of the TextFieldEditorViewModel class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TextFieldEditorViewModel(
    IApplication application,
    IEventAggregator eventAggregator
)
public:
TextFieldEditorViewModel(
    IApplication^ application,
    IEventAggregator^ eventAggregator
)

Parameters

application
Type: VisualComponents.Create3DIApplication
eventAggregator
Type: IEventAggregator
See Also

Reference

TextFieldEditorViewModel Class
VisualComponents.UX.Shared Namespace


TextFieldEditorViewModel Properties

The TextFieldEditorViewModel type exposes the following members.

Properties
 | Name | Description
Protected property | CacheViews | (Inherited from ViewAware.)
Public property | DisplayName | (Inherited from Screen.)
Public property | IsActive | (Inherited from Screen.)
Public property | IsInitialized | (Inherited from Screen.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsVisible |
Public property | Parent | (Inherited from Screen.)
Public property | Text |
Public property | TextSet |
Public property | XPosition |
Public property | YPosition |
Top
See Also

Reference

TextFieldEditorViewModel Class
VisualComponents.UX.Shared Namespace


TextFieldEditorViewModel.IsVisible Property

TextFieldEditorViewModelIsVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsVisible { get; }
public:
property bool IsVisible {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

TextFieldEditorViewModel Class
VisualComponents.UX.Shared Namespace


TextFieldEditorViewModel.Text Property

TextFieldEditorViewModelText Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Text { get; set; }
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

TextFieldEditorViewModel Class
VisualComponents.UX.Shared Namespace


TextFieldEditorViewModel.TextSet Property

TextFieldEditorViewModelTextSet Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IText3DSet TextSet { get; }
public:
property IText3DSet^ TextSet {
    IText3DSet^ get ();
}

Property Value

Type: IText3DSet
See Also

Reference

TextFieldEditorViewModel Class
VisualComponents.UX.Shared Namespace


TextFieldEditorViewModel.XPosition Property

TextFieldEditorViewModelXPosition Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double XPosition { get; }
public:
property double XPosition {
    double get ();
}

Property Value

Type: Double
See Also

Reference

TextFieldEditorViewModel Class
VisualComponents.UX.Shared Namespace


TextFieldEditorViewModel.YPosition Property

TextFieldEditorViewModelYPosition Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double YPosition { get; }
public:
property double YPosition {
    double get ();
}

Property Value

Type: Double
See Also

Reference

TextFieldEditorViewModel Class
VisualComponents.UX.Shared Namespace


TextFieldEditorViewModel Methods

The TextFieldEditorViewModel type exposes the following members.

Methods
 | Name | Description
Public method | CanClose | (Inherited from Screen.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetView | (Inherited from ViewAware.)
Public method | Handle(PickMessage) |
Public method | Handle(SelectedRibbonTabChangedMessage) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Protected method | OnActivate | (Inherited from Screen.)
Protected method | OnDeactivate | (Inherited from Screen.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnInitialize | (Inherited from Screen.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Protected method | OnViewAttached | (Inherited from ViewAware.)
Protected method | OnViewLoaded | (Overrides ViewAware.OnViewLoaded(Object).)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryClose | (Inherited from Screen.)
Public method | TryClose(NullableBoolean) | (Inherited from Screen.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TextFieldEditorViewModel Class
VisualComponents.UX.Shared Namespace


TextFieldEditorViewModel.Handle Method

TextFieldEditorViewModelHandle Method

Overload List
 | Name | Description
Public method | Handle(PickMessage) |
Public method | Handle(SelectedRibbonTabChangedMessage) |
Top
See Also

Reference

TextFieldEditorViewModel Class
VisualComponents.UX.Shared Namespace


TextFieldEditorViewModel.Handle Method (PickMessage)

TextFieldEditorViewModelHandle Method (PickMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    PickMessage message
)
public:
virtual void Handle(
    PickMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedPickMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

TextFieldEditorViewModel Class
Handle Overload
VisualComponents.UX.Shared Namespace


TextFieldEditorViewModel.Handle Method (SelectedRibbonTabChangedMessage)

TextFieldEditorViewModelHandle Method (SelectedRibbonTabChangedMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    SelectedRibbonTabChangedMessage message
)
public:
virtual void Handle(
    SelectedRibbonTabChangedMessage^ message
) sealed

Parameters

message
Type: VisualComponents.Create3DSelectedRibbonTabChangedMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

TextFieldEditorViewModel Class
Handle Overload
VisualComponents.UX.Shared Namespace


TextFieldEditorViewModel.OnViewLoaded Method

TextFieldEditorViewModelOnViewLoaded Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnViewLoaded(
    Object view
)
protected:
virtual void OnViewLoaded(
    Object^ view
) override

Parameters

view
Type: SystemObject
See Also

Reference

TextFieldEditorViewModel Class
VisualComponents.UX.Shared Namespace


TextFieldEditorViewModel Events

The TextFieldEditorViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from Screen.)
Public event | AttemptingDeactivation | (Inherited from Screen.)
Public event | Deactivated | (Inherited from Screen.)
Public event | PropertyChanged |
Public event | ViewAttached | (Inherited from ViewAware.)
Top
See Also

Reference

TextFieldEditorViewModel Class
VisualComponents.UX.Shared Namespace


TextFieldEditorViewModel.PropertyChanged Event

TextFieldEditorViewModelPropertyChanged Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event PropertyChangedEventHandler PropertyChanged
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

TextFieldEditorViewModel Class
VisualComponents.UX.Shared Namespace


TextFieldEditorViewModel Fields

The TextFieldEditorViewModel type exposes the following members.

Fields
 | Name | Description
Protected field | Views | (Inherited from ViewAware.)
Top
See Also

Reference

TextFieldEditorViewModel Class
VisualComponents.UX.Shared Namespace


TextInputType Enumeration

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum TextInputType
public enum class TextInputType
Members
Member name | Value | Description
String | 0 |
Digit | 1 | Positive integer number
Decimal | 2 | Floating number
See Also

Reference

VisualComponents.UX.Shared Namespace


ThicknessToOppositeConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedThicknessToOppositeConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ThicknessToOppositeConverter : IValueConverter
public ref class ThicknessToOppositeConverter : IValueConverter

The ThicknessToOppositeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ThicknessToOppositeConverter | Initializes a new instance of the ThicknessToOppositeConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ThicknessToOppositeConverter Constructor

Initializes a new instance of the ThicknessToOppositeConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ThicknessToOppositeConverter()
public:
ThicknessToOppositeConverter()
See Also

Reference

ThicknessToOppositeConverter Class
VisualComponents.UX.Shared Namespace


ThicknessToOppositeConverter Methods

The ThicknessToOppositeConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ThicknessToOppositeConverter Class
VisualComponents.UX.Shared Namespace


ThicknessToOppositeConverter.Convert Method

ThicknessToOppositeConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ThicknessToOppositeConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

ThicknessToOppositeConverter Class
VisualComponents.UX.Shared Namespace


ThicknessToOppositeConverter.ConvertBack Method

ThicknessToOppositeConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ThicknessToOppositeConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

ThicknessToOppositeConverter Class
VisualComponents.UX.Shared Namespace


TimeFormatHelper Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedTimeFormatHelper

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static class TimeFormatHelper
public ref class TimeFormatHelper abstract sealed

The TimeFormatHelper type exposes the following members.

Methods
Name | Description
ConvertToClockDisplayFormat(TimeSpan) |
ConvertToClockDisplayFormat(TimeSpan, ClockDisplayFormat, Boolean) |
ConvertToTimeSpan |
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


TimeFormatHelper Methods

The TimeFormatHelper type exposes the following members.

Methods
Name | Description
ConvertToClockDisplayFormat(TimeSpan) |
ConvertToClockDisplayFormat(TimeSpan, ClockDisplayFormat, Boolean) |
ConvertToTimeSpan |
Top
See Also

Reference

TimeFormatHelper Class
VisualComponents.UX.Shared Namespace


TimeFormatHelper.ConvertToClockDisplayFormat Method

TimeFormatHelperConvertToClockDisplayFormat Method

Overload List
Name | Description
ConvertToClockDisplayFormat(TimeSpan) |
ConvertToClockDisplayFormat(TimeSpan, ClockDisplayFormat, Boolean) |
Top
See Also

Reference

TimeFormatHelper Class
VisualComponents.UX.Shared Namespace


TimeFormatHelper.ConvertToClockDisplayFormat Method (TimeSpan)

TimeFormatHelperConvertToClockDisplayFormat Method (TimeSpan)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string ConvertToClockDisplayFormat(
    TimeSpan elapsed
)
public:
static String^ ConvertToClockDisplayFormat(
    TimeSpan elapsed
)

Parameters

elapsed
Type: SystemTimeSpan

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TimeFormatHelper.ConvertToClockDisplayFormat(System.TimeSpan)"]

See Also

Reference

TimeFormatHelper Class
ConvertToClockDisplayFormat Overload
VisualComponents.UX.Shared Namespace


TimeFormatHelper.ConvertToClockDisplayFormat Method (TimeSpan, ClockDisplayFormat, Boolean)

TimeFormatHelperConvertToClockDisplayFormat Method (TimeSpan, ClockDisplayFormat, Boolean)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static string ConvertToClockDisplayFormat(
    TimeSpan elapsed,
    ClockDisplayFormat clockDisplayFormat,
    bool lastDigitPrecisionEnabled = true
)
public:
static String^ ConvertToClockDisplayFormat(
    TimeSpan elapsed,
    ClockDisplayFormat clockDisplayFormat,
    bool lastDigitPrecisionEnabled = true
)

Parameters

elapsed
Type: SystemTimeSpan
clockDisplayFormat
Type: VisualComponents.UX.SharedClockDisplayFormat
lastDigitPrecisionEnabled (Optional)
Type: SystemBoolean

Return Value

Type: String

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TimeFormatHelper.ConvertToClockDisplayFormat(System.TimeSpan,VisualComponents.UX.Shared.ClockDisplayFormat,System.Boolean)"]

See Also

Reference

TimeFormatHelper Class
ConvertToClockDisplayFormat Overload
VisualComponents.UX.Shared Namespace


TimeFormatHelper.ConvertToTimeSpan Method

TimeFormatHelperConvertToTimeSpan Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static Tuple<double, TimeSpan> ConvertToTimeSpan(
    string timeString
)
public:
static Tuple<double, TimeSpan>^ ConvertToTimeSpan(
    String^ timeString
)

Parameters

timeString
Type: SystemString

Return Value

Type: TupleDouble, TimeSpan

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TimeFormatHelper.ConvertToTimeSpan(System.String)"]

See Also

Reference

TimeFormatHelper Class
VisualComponents.UX.Shared Namespace


TimeSpanToMillisecondsConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedTimeSpanToMillisecondsConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class TimeSpanToMillisecondsConverter : IValueConverter
public ref class TimeSpanToMillisecondsConverter : IValueConverter

The TimeSpanToMillisecondsConverter type exposes the following members.

Constructors
 | Name | Description
Public method | TimeSpanToMillisecondsConverter | Initializes a new instance of the TimeSpanToMillisecondsConverter class
Top
Methods
 | Name | Description
Public method | Convert | TimeSpan to milliseconds as integer
Public method | ConvertBack | Integer or integer string to positive TimeSpan
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


TimeSpanToMillisecondsConverter Constructor

Initializes a new instance of the TimeSpanToMillisecondsConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TimeSpanToMillisecondsConverter()
public:
TimeSpanToMillisecondsConverter()
See Also

Reference

TimeSpanToMillisecondsConverter Class
VisualComponents.UX.Shared Namespace


TimeSpanToMillisecondsConverter Methods

The TimeSpanToMillisecondsConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert | TimeSpan to milliseconds as integer
Public method | ConvertBack | Integer or integer string to positive TimeSpan
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TimeSpanToMillisecondsConverter Class
VisualComponents.UX.Shared Namespace


TimeSpanToMillisecondsConverter.Convert Method

TimeSpanToMillisecondsConverterConvert Method

TimeSpan to milliseconds as integer

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TimeSpanToMillisecondsConverter.Convert(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

TimeSpanToMillisecondsConverter Class
VisualComponents.UX.Shared Namespace


TimeSpanToMillisecondsConverter.ConvertBack Method

TimeSpanToMillisecondsConverterConvertBack Method

Integer or integer string to positive TimeSpan

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TimeSpanToMillisecondsConverter.ConvertBack(System.Object,System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

TimeSpanToMillisecondsConverter Class
VisualComponents.UX.Shared Namespace


ToggleLogicalPnP Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedToggleLogicalPnP

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ToggleLogicalPnP
public ref class ToggleLogicalPnP

The ToggleLogicalPnP type exposes the following members.

Constructors
 | Name | Description
Public method | ToggleLogicalPnP | Initializes a new instance of the ToggleLogicalPnP class
Top
Properties
 | Name | Description
Public property | Target |
Public property | Toggle |
Public property | Window |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ToggleLogicalPnP Constructor

Initializes a new instance of the ToggleLogicalPnP class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ToggleLogicalPnP()
public:
ToggleLogicalPnP()
See Also

Reference

ToggleLogicalPnP Class
VisualComponents.UX.Shared Namespace


ToggleLogicalPnP Properties

The ToggleLogicalPnP type exposes the following members.

Properties
 | Name | Description
Public property | Target |
Public property | Toggle |
Public property | Window |
Top
See Also

Reference

ToggleLogicalPnP Class
VisualComponents.UX.Shared Namespace


ToggleLogicalPnP.Target Property

ToggleLogicalPnPTarget Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IVisualObject Target { get; set; }
public:
property IVisualObject^ Target {
    IVisualObject^ get ();
    void set (IVisualObject^ value);
}

Property Value

Type: IVisualObject
See Also

Reference

ToggleLogicalPnP Class
VisualComponents.UX.Shared Namespace


ToggleLogicalPnP.Toggle Property

ToggleLogicalPnPToggle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Toggle { get; set; }
public:
property bool Toggle {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ToggleLogicalPnP Class
VisualComponents.UX.Shared Namespace


ToggleLogicalPnP.Window Property

ToggleLogicalPnPWindow Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IWindow3D Window { get; set; }
public:
property IWindow3D^ Window {
    IWindow3D^ get ();
    void set (IWindow3D^ value);
}

Property Value

Type: IWindow3D
See Also

Reference

ToggleLogicalPnP Class
VisualComponents.UX.Shared Namespace


ToggleLogicalPnP Methods

The ToggleLogicalPnP type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ToggleLogicalPnP Class
VisualComponents.UX.Shared Namespace


ToggleManipulationToolMessage Class

Allows publisher to toggle handles.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedToggleManipulationToolMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ToggleManipulationToolMessage
public ref class ToggleManipulationToolMessage sealed

The ToggleManipulationToolMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ToggleManipulationToolMessage | Initializes a new instance of the ToggleManipulationToolMessage class
Top
Properties
 | Name | Description
Public property | ManipulationMode |
Public property | ShowTool |
Public property | ToolType |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ToggleManipulationToolMessage Constructor

Initializes a new instance of the ToggleManipulationToolMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ToggleManipulationToolMessage()
public:
ToggleManipulationToolMessage()
See Also

Reference

ToggleManipulationToolMessage Class
VisualComponents.UX.Shared Namespace


ToggleManipulationToolMessage Properties

The ToggleManipulationToolMessage type exposes the following members.

Properties
 | Name | Description
Public property | ManipulationMode |
Public property | ShowTool |
Public property | ToolType |
Top
See Also

Reference

ToggleManipulationToolMessage Class
VisualComponents.UX.Shared Namespace


ToggleManipulationToolMessage.ManipulationMode Property

ToggleManipulationToolMessageManipulationMode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ManipulationMode ManipulationMode { get; set; }
public:
property ManipulationMode ManipulationMode {
    ManipulationMode get ();
    void set (ManipulationMode value);
}

Property Value

Type: ManipulationMode
See Also

Reference

ToggleManipulationToolMessage Class
VisualComponents.UX.Shared Namespace


ToggleManipulationToolMessage.ShowTool Property

ToggleManipulationToolMessageShowTool Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool ShowTool { get; set; }
public:
property bool ShowTool {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ToggleManipulationToolMessage Class
VisualComponents.UX.Shared Namespace


ToggleManipulationToolMessage.ToolType Property

ToggleManipulationToolMessageToolType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ManipulatorToolType ToolType { get; set; }
public:
property ManipulatorToolType ToolType {
    ManipulatorToolType get ();
    void set (ManipulatorToolType value);
}

Property Value

Type: ManipulatorToolType
See Also

Reference

ToggleManipulationToolMessage Class
VisualComponents.UX.Shared Namespace


ToggleManipulationToolMessage Methods

The ToggleManipulationToolMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ToggleManipulationToolMessage Class
VisualComponents.UX.Shared Namespace


ToggleNavigationModeMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedToggleNavigationModeMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class ToggleNavigationModeMessage
public ref class ToggleNavigationModeMessage sealed

The ToggleNavigationModeMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ToggleNavigationModeMessage | Initializes a new instance of the ToggleNavigationModeMessage class
Top
Properties
 | Name | Description
Public property | NavigationMode |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ToggleNavigationModeMessage Constructor

Initializes a new instance of the ToggleNavigationModeMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ToggleNavigationModeMessage(
    InteractMode navigationMode
)
public:
ToggleNavigationModeMessage(
    InteractMode navigationMode
)

Parameters

navigationMode
Type: VisualComponents.Create3DInteractMode
See Also

Reference

ToggleNavigationModeMessage Class
VisualComponents.UX.Shared Namespace


ToggleNavigationModeMessage Properties

The ToggleNavigationModeMessage type exposes the following members.

Properties
 | Name | Description
Public property | NavigationMode |
Top
See Also

Reference

ToggleNavigationModeMessage Class
VisualComponents.UX.Shared Namespace


ToggleNavigationModeMessage.NavigationMode Property

ToggleNavigationModeMessageNavigationMode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public InteractMode NavigationMode { get; }
public:
property InteractMode NavigationMode {
    InteractMode get ();
}

Property Value

Type: InteractMode
See Also

Reference

ToggleNavigationModeMessage Class
VisualComponents.UX.Shared Namespace


ToggleNavigationModeMessage Methods

The ToggleNavigationModeMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ToggleNavigationModeMessage Class
VisualComponents.UX.Shared Namespace


ToggleSelectionModeMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedToggleSelectionModeMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ToggleSelectionModeMessage
public ref class ToggleSelectionModeMessage

The ToggleSelectionModeMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ToggleSelectionModeMessage | Initializes a new instance of the ToggleSelectionModeMessage class
Top
Properties
 | Name | Description
Public property | SelectionMode |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ToggleSelectionModeMessage Constructor

Initializes a new instance of the ToggleSelectionModeMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ToggleSelectionModeMessage(
    ObjectSelectionMode selectionMode
)
public:
ToggleSelectionModeMessage(
    ObjectSelectionMode selectionMode
)

Parameters

selectionMode
Type: VisualComponents.Create3DObjectSelectionMode
See Also

Reference

ToggleSelectionModeMessage Class
VisualComponents.UX.Shared Namespace


ToggleSelectionModeMessage Properties

The ToggleSelectionModeMessage type exposes the following members.

Properties
 | Name | Description
Public property | SelectionMode |
Top
See Also

Reference

ToggleSelectionModeMessage Class
VisualComponents.UX.Shared Namespace


ToggleSelectionModeMessage.SelectionMode Property

ToggleSelectionModeMessageSelectionMode Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObjectSelectionMode SelectionMode { get; }
public:
property ObjectSelectionMode SelectionMode {
    ObjectSelectionMode get ();
}

Property Value

Type: ObjectSelectionMode
See Also

Reference

ToggleSelectionModeMessage Class
VisualComponents.UX.Shared Namespace


ToggleSelectionModeMessage Methods

The ToggleSelectionModeMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ToggleSelectionModeMessage Class
VisualComponents.UX.Shared Namespace


ToggleShapeManipulationMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedToggleShapeManipulationMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ToggleShapeManipulationMessage
public ref class ToggleShapeManipulationMessage

The ToggleShapeManipulationMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ToggleShapeManipulationMessage | Initializes a new instance of the ToggleShapeManipulationMessage class
Top
Properties
 | Name | Description
Public property | Height |
Public property | Show |
Public property | Type |
Public property | Width |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ToggleShapeManipulationMessage Constructor

Initializes a new instance of the ToggleShapeManipulationMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ToggleShapeManipulationMessage()
public:
ToggleShapeManipulationMessage()
See Also

Reference

ToggleShapeManipulationMessage Class
VisualComponents.UX.Shared Namespace


ToggleShapeManipulationMessage Properties

The ToggleShapeManipulationMessage type exposes the following members.

Properties
 | Name | Description
Public property | Height |
Public property | Show |
Public property | Type |
Public property | Width |
Top
See Also

Reference

ToggleShapeManipulationMessage Class
VisualComponents.UX.Shared Namespace


ToggleShapeManipulationMessage.Height Property

ToggleShapeManipulationMessageHeight Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Height { get; set; }
public:
property double Height {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ToggleShapeManipulationMessage Class
VisualComponents.UX.Shared Namespace


ToggleShapeManipulationMessage.Show Property

ToggleShapeManipulationMessageShow Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Show { get; set; }
public:
property bool Show {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ToggleShapeManipulationMessage Class
VisualComponents.UX.Shared Namespace


ToggleShapeManipulationMessage.Type Property

ToggleShapeManipulationMessageType Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ShapeMaipulatorType Type { get; set; }
public:
property ShapeMaipulatorType Type {
    ShapeMaipulatorType get ();
    void set (ShapeMaipulatorType value);
}

Property Value

Type: ShapeMaipulatorType
See Also

Reference

ToggleShapeManipulationMessage Class
VisualComponents.UX.Shared Namespace


ToggleShapeManipulationMessage.Width Property

ToggleShapeManipulationMessageWidth Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Width { get; set; }
public:
property double Width {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ToggleShapeManipulationMessage Class
VisualComponents.UX.Shared Namespace


ToggleShapeManipulationMessage Methods

The ToggleShapeManipulationMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ToggleShapeManipulationMessage Class
VisualComponents.UX.Shared Namespace


ToolSizingMode Enumeration

Defines how image and text sizing for the tool.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ToolSizingMode
public enum class ToolSizingMode
Members
Member name | Value | Description
ImageOnly | 0 | The tool will display its image only.
ImageAndTextNormal | 1 | The tool will display its image and text in a normal size.
ImageAndTextLarge | 2 | The tool will display its image and text and its height will span the height of the items area of the containing Infragistics.Windows.Ribbon.RibbonGroup.
See Also

Reference

VisualComponents.UX.Shared Namespace


ToolTipBehavior Class

Provides a way to quickly configure a tooltip for arbitrary framework elements.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.WindowsFreezable
System.Windows.Media.AnimationAnimatable
Behavior
BehaviorFrameworkElement
VisualComponents.UX.SharedToolTipBehavior

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
[ContentPropertyAttribute("Content")]
public class ToolTipBehavior : Behavior<FrameworkElement>
[ContentPropertyAttribute(L"Content")]
public ref class ToolTipBehavior : public Behavior<FrameworkElement^>

The ToolTipBehavior type exposes the following members.

Constructors
 | Name | Description
Public method | ToolTipBehavior | Initializes a new instance of the ToolTipBehavior class
Top
Properties
 | Name | Description
Protected property | AssociatedObject | (Inherited from BehaviorFrameworkElement.)
Protected property | AssociatedType | (Inherited from Behavior.)
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | Category | Gets or sets the Category property. This dependency property indicates ....
Public property | Content |
Public property | ContentStringFormat |
Public property | Delay |
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Footer |
Public property | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Inherited from Animatable.)
Public property | Header |
Public property | ImageSource |
Public property | IsEnabled |
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsInteractive |
Public property | IsOpened |
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | MaxWidth | Gets or sets the MaxWidth property. This dependency property indicates the maximum width of a popup.
Public property | Template | Gets or sets the Category property. This dependency property indicates ....
Public property | TemplateType | Gets or sets the tooltip template type property.
Public property | TitleStringFormat |
Top
Methods
 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | Attach | (Inherited from Behavior.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of this Animatable, making deep copies of this object's values. When copying this object's dependency properties, this method copies resource references and data bindings (but they might no longer resolve) but not animations or their current values. (Inherited from Animatable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | (Inherited from Behavior.)
Public method | Detach | (Inherited from Behavior.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to . (Inherited from Freezable.)
Protected method | FreezeCore | Makes this Animatable object unmodifiable or determines whether it can be made unmodifiable. (Inherited from Animatable.)
Public method | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Inherited from Animatable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttached | (Overrides Behavior.OnAttached.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnDetaching | (Inherited from Behavior.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update |
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
Events
 | Name | Description
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Top
Fields
Name | Description
CategoryProperty | Category Dependency Property
ContentProperty | Content Dependency Property
ContentStringFormatProperty | ContentStringFormat Dependency Property
DataContextProperty | MaxWidth Dependency Property
DelayProperty |
FooterProperty | Header Dependency Property
ImageSourceProperty | Header Dependency Property
IsEnabledProperty | IsEnabled Dependency Property
IsInteractiveProperty |
IsOpenedProperty |
MaxWidthProperty | MaxWidth Dependency Property
TemplateProperty | Category Dependency Property
TemplateTypeProperty | Category Dependency Property
TitleProperty | Header Dependency Property
TitleStringFormatProperty | HeaderStringFormat Dependency Property
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ToolTipBehavior Constructor

Initializes a new instance of the ToolTipBehavior class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ToolTipBehavior()
public:
ToolTipBehavior()
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior Properties

The ToolTipBehavior type exposes the following members.

Properties
 | Name | Description
Protected property | AssociatedObject | (Inherited from BehaviorFrameworkElement.)
Protected property | AssociatedType | (Inherited from Behavior.)
Public property | CanFreeze | Gets a value that indicates whether the object can be made unmodifiable. (Inherited from Freezable.)
Public property | Category | Gets or sets the Category property. This dependency property indicates ....
Public property | Content |
Public property | ContentStringFormat |
Public property | Delay |
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Footer |
Public property | HasAnimatedProperties | Gets a value that indicates whether one or more AnimationClock objects is associated with any of this object's dependency properties. (Inherited from Animatable.)
Public property | Header |
Public property | ImageSource |
Public property | IsEnabled |
Public property | IsFrozen | Gets a value that indicates whether the object is currently modifiable. (Inherited from Freezable.)
Public property | IsInteractive |
Public property | IsOpened |
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | MaxWidth | Gets or sets the MaxWidth property. This dependency property indicates the maximum width of a popup.
Public property | Template | Gets or sets the Category property. This dependency property indicates ....
Public property | TemplateType | Gets or sets the tooltip template type property.
Public property | TitleStringFormat |
Top
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.Category Property

ToolTipBehaviorCategory Property

Gets or sets the Category property. This dependency property indicates ....

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ToolTipCategory Category { get; set; }
public:
property ToolTipCategory Category {
    ToolTipCategory get ();
    void set (ToolTipCategory value);
}

Property Value

Type: ToolTipCategory
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.Content Property

ToolTipBehaviorContent Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Content { get; set; }
public:
property Object^ Content {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.ContentStringFormat Property

ToolTipBehaviorContentStringFormat Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string ContentStringFormat { get; set; }
public:
property String^ ContentStringFormat {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.Delay Property

ToolTipBehaviorDelay Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Delay { get; set; }
public:
property int Delay {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.Footer Property

ToolTipBehaviorFooter Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Footer { get; set; }
public:
property Object^ Footer {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.Header Property

ToolTipBehaviorHeader Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Header { get; set; }
public:
property Object^ Header {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.ImageSource Property

ToolTipBehaviorImageSource Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object ImageSource { get; set; }
public:
property Object^ ImageSource {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.IsEnabled Property

ToolTipBehaviorIsEnabled Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsEnabled { get; set; }
public:
property bool IsEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.IsInteractive Property

ToolTipBehaviorIsInteractive Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsInteractive { get; set; }
public:
property bool IsInteractive {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.IsOpened Property

ToolTipBehaviorIsOpened Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsOpened { get; set; }
public:
property bool IsOpened {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.MaxWidth Property

ToolTipBehaviorMaxWidth Property

Gets or sets the MaxWidth property. This dependency property indicates the maximum width of a popup.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double MaxWidth { get; set; }
public:
property double MaxWidth {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.Template Property

ToolTipBehaviorTemplate Property

Gets or sets the Category property. This dependency property indicates ....

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ControlTemplate Template { get; set; }
public:
property ControlTemplate^ Template {
    ControlTemplate^ get ();
    void set (ControlTemplate^ value);
}

Property Value

Type: ControlTemplate
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.TemplateType Property

ToolTipBehaviorTemplateType Property

Gets or sets the tooltip template type property.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ToolTipTemplate TemplateType { get; set; }
public:
property ToolTipTemplate TemplateType {
    ToolTipTemplate get ();
    void set (ToolTipTemplate value);
}

Property Value

Type: ToolTipTemplate
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.TitleStringFormat Property

ToolTipBehaviorTitleStringFormat Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string TitleStringFormat { get; set; }
public:
property String^ TitleStringFormat {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior Methods

The ToolTipBehavior type exposes the following members.

Methods
 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an AnimationClock to the specified DependencyProperty. If the property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | Attach | (Inherited from Behavior.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the SnapshotAndReplace handoff behavior is used. (Inherited from Animatable.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Applies an animation to the specified DependencyProperty. The animation is started when the next frame is rendered. If the specified property is already animated, the specified HandoffBehavior is used. (Inherited from Animatable.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Clone | Creates a modifiable clone of this Animatable, making deep copies of this object's values. When copying this object's dependency properties, this method copies resource references and data bindings (but they might no longer resolve) but not animations or their current values. (Inherited from Animatable.)
Protected method | CloneCore | Makes the instance a clone (deep copy) of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | CloneCurrentValue | Creates a modifiable clone (deep copy) of the Freezable using its current values. (Inherited from Freezable.)
Protected method | CloneCurrentValueCore | Makes the instance a modifiable clone (deep copy) of the specified Freezable using current property values. (Inherited from Freezable.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateInstance | Initializes a new instance of the Freezable class. (Inherited from Freezable.)
Protected method | CreateInstanceCore | (Inherited from Behavior.)
Public method | Detach | (Inherited from Behavior.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Freeze | Makes the current object unmodifiable and sets its IsFrozen property to . (Inherited from Freezable.)
Protected method | FreezeCore | Makes this Animatable object unmodifiable or determines whether it can be made unmodifiable. (Inherited from Animatable.)
Public method | GetAnimationBaseValue | Returns the non-animated value of the specified DependencyProperty. (Inherited from Animatable.)
Public method | GetAsFrozen | Creates a frozen copy of the Freezable, using base (non-animated) property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetAsFrozenCore | Makes the instance a frozen clone of the specified Freezable using base (non-animated) property values. (Inherited from Freezable.)
Public method | GetCurrentValueAsFrozen | Creates a frozen copy of the Freezable using current property values. Because the copy is frozen, any frozen sub-objects are copied by reference. (Inherited from Freezable.)
Protected method | GetCurrentValueAsFrozenCore | Makes the current instance a frozen clone of the specified Freezable. If the object has animated dependency properties, their current animated values are copied. (Inherited from Freezable.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAttached | (Overrides Behavior.OnAttached.)
Protected method | OnChanged | Called when the current Freezable object is modified. (Inherited from Freezable.)
Protected method | OnDetaching | (Inherited from Behavior.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject) | Ensures that appropriate context pointers are established for a DependencyObjectType data member that has just been set. (Inherited from Freezable.)
Protected method | OnFreezablePropertyChanged(DependencyObject, DependencyObject, DependencyProperty) | This member supports the Windows Presentation Foundation (WPF) infrastructure and is not intended to be used directly from your code. (Inherited from Freezable.)
Protected method | OnPropertyChanged | Overrides the DependencyObject implementation of OnPropertyChanged(DependencyPropertyChangedEventArgs) to also invoke any Changed handlers in response to a changing dependency property of type Freezable. (Inherited from Freezable.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | ReadPreamble | Ensures that the Freezable is being accessed from a valid thread. Inheritors of Freezable must call this method at the beginning of any API that reads data members that are not dependency properties. (Inherited from Freezable.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update |
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Protected method | WritePostscript | Raises the Changed event for the Freezable and invokes its OnChanged method. Classes that derive from Freezable should call this method at the end of any API that modifies class members that are not stored as dependency properties. (Inherited from Freezable.)
Protected method | WritePreamble | Verifies that the Freezable is not frozen and that it is being accessed from a valid threading context. Freezable inheritors should call this method at the beginning of any API that writes to data members that are not dependency properties. (Inherited from Freezable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.OnAttached Method

ToolTipBehaviorOnAttached Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnAttached()
protected:
virtual void OnAttached() override
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.Update Method

ToolTipBehaviorUpdate Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Update()
public:
void Update()
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior Events

The ToolTipBehavior type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs when the Freezable or an object it contains is modified. (Inherited from Freezable.)
Top
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior Fields

The ToolTipBehavior type exposes the following members.

Fields
Name | Description
CategoryProperty | Category Dependency Property
ContentProperty | Content Dependency Property
ContentStringFormatProperty | ContentStringFormat Dependency Property
DataContextProperty | MaxWidth Dependency Property
DelayProperty |
FooterProperty | Header Dependency Property
ImageSourceProperty | Header Dependency Property
IsEnabledProperty | IsEnabled Dependency Property
IsInteractiveProperty |
IsOpenedProperty |
MaxWidthProperty | MaxWidth Dependency Property
TemplateProperty | Category Dependency Property
TemplateTypeProperty | Category Dependency Property
TitleProperty | Header Dependency Property
TitleStringFormatProperty | HeaderStringFormat Dependency Property
Top
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.CategoryProperty Field

ToolTipBehaviorCategoryProperty Field

Category Dependency Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty CategoryProperty
public:
static initonly DependencyProperty^ CategoryProperty

Field Value

Type: DependencyProperty
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.ContentProperty Field

ToolTipBehaviorContentProperty Field

Content Dependency Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ContentProperty
public:
static initonly DependencyProperty^ ContentProperty

Field Value

Type: DependencyProperty
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.ContentStringFormatProperty Field

ToolTipBehaviorContentStringFormatProperty Field

ContentStringFormat Dependency Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ContentStringFormatProperty
public:
static initonly DependencyProperty^ ContentStringFormatProperty

Field Value

Type: DependencyProperty
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.DataContextProperty Field

ToolTipBehaviorDataContextProperty Field

MaxWidth Dependency Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty DataContextProperty
public:
static initonly DependencyProperty^ DataContextProperty

Field Value

Type: DependencyProperty
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.DelayProperty Field

ToolTipBehaviorDelayProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty DelayProperty
public:
static initonly DependencyProperty^ DelayProperty

Field Value

Type: DependencyProperty
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.FooterProperty Field

ToolTipBehaviorFooterProperty Field

Header Dependency Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty FooterProperty
public:
static initonly DependencyProperty^ FooterProperty

Field Value

Type: DependencyProperty
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.ImageSourceProperty Field

ToolTipBehaviorImageSourceProperty Field

Header Dependency Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty ImageSourceProperty
public:
static initonly DependencyProperty^ ImageSourceProperty

Field Value

Type: DependencyProperty
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.IsEnabledProperty Field

ToolTipBehaviorIsEnabledProperty Field

IsEnabled Dependency Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsEnabledProperty
public:
static initonly DependencyProperty^ IsEnabledProperty

Field Value

Type: DependencyProperty
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.IsInteractiveProperty Field

ToolTipBehaviorIsInteractiveProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsInteractiveProperty
public:
static initonly DependencyProperty^ IsInteractiveProperty

Field Value

Type: DependencyProperty
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.IsOpenedProperty Field

ToolTipBehaviorIsOpenedProperty Field

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty IsOpenedProperty
public:
static initonly DependencyProperty^ IsOpenedProperty

Field Value

Type: DependencyProperty
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.MaxWidthProperty Field

ToolTipBehaviorMaxWidthProperty Field

MaxWidth Dependency Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty MaxWidthProperty
public:
static initonly DependencyProperty^ MaxWidthProperty

Field Value

Type: DependencyProperty
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.TemplateProperty Field

ToolTipBehaviorTemplateProperty Field

Category Dependency Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty TemplateProperty
public:
static initonly DependencyProperty^ TemplateProperty

Field Value

Type: DependencyProperty
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.TemplateTypeProperty Field

ToolTipBehaviorTemplateTypeProperty Field

Category Dependency Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty TemplateTypeProperty
public:
static initonly DependencyProperty^ TemplateTypeProperty

Field Value

Type: DependencyProperty
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.TitleProperty Field

ToolTipBehaviorTitleProperty Field

Header Dependency Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty TitleProperty
public:
static initonly DependencyProperty^ TitleProperty

Field Value

Type: DependencyProperty
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipBehavior.TitleStringFormatProperty Field

ToolTipBehaviorTitleStringFormatProperty Field

HeaderStringFormat Dependency Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static readonly DependencyProperty TitleStringFormatProperty
public:
static initonly DependencyProperty^ TitleStringFormatProperty

Field Value

Type: DependencyProperty
See Also

Reference

ToolTipBehavior Class
VisualComponents.UX.Shared Namespace


ToolTipCategory Enumeration

Flags that control themed ToolTips.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ToolTipCategory
public enum class ToolTipCategory
Members
Member name | Value | Description
None | 0 |
Informational | 1 |
Warning | 2 |
Error | 3 |
See Also

Reference

VisualComponents.UX.Shared Namespace


ToolTipDisplayMessage Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedToolTipDisplayMessage

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ToolTipDisplayMessage
public ref class ToolTipDisplayMessage

The ToolTipDisplayMessage type exposes the following members.

Constructors
 | Name | Description
Public method | ToolTipDisplayMessage | Initializes a new instance of the ToolTipDisplayMessage class
Top
Properties
 | Name | Description
Public property | Description |
Public property | Duration |
Public property | Show |
Public property | Title |
Public property | X |
Public property | Y |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ToolTipDisplayMessage Constructor

Initializes a new instance of the ToolTipDisplayMessage class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ToolTipDisplayMessage()
public:
ToolTipDisplayMessage()
See Also

Reference

ToolTipDisplayMessage Class
VisualComponents.UX.Shared Namespace


ToolTipDisplayMessage Properties

The ToolTipDisplayMessage type exposes the following members.

Properties
 | Name | Description
Public property | Description |
Public property | Duration |
Public property | Show |
Public property | Title |
Public property | X |
Public property | Y |
Top
See Also

Reference

ToolTipDisplayMessage Class
VisualComponents.UX.Shared Namespace


ToolTipDisplayMessage.Description Property

ToolTipDisplayMessageDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; set; }
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ToolTipDisplayMessage Class
VisualComponents.UX.Shared Namespace


ToolTipDisplayMessage.Duration Property

ToolTipDisplayMessageDuration Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public int Duration { get; set; }
public:
property int Duration {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ToolTipDisplayMessage Class
VisualComponents.UX.Shared Namespace


ToolTipDisplayMessage.Show Property

ToolTipDisplayMessageShow Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Show { get; set; }
public:
property bool Show {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ToolTipDisplayMessage Class
VisualComponents.UX.Shared Namespace


ToolTipDisplayMessage.Title Property

ToolTipDisplayMessageTitle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; set; }
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ToolTipDisplayMessage Class
VisualComponents.UX.Shared Namespace


ToolTipDisplayMessage.X Property

ToolTipDisplayMessageX Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double X { get; set; }
public:
property double X {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ToolTipDisplayMessage Class
VisualComponents.UX.Shared Namespace


ToolTipDisplayMessage.Y Property

ToolTipDisplayMessageY Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double Y { get; set; }
public:
property double Y {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ToolTipDisplayMessage Class
VisualComponents.UX.Shared Namespace


ToolTipDisplayMessage Methods

The ToolTipDisplayMessage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ToolTipDisplayMessage Class
VisualComponents.UX.Shared Namespace


ToolTipManagerView Class

Interaction logic for ToolTipManagerView.xaml
ToolTipManagerView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedToolTipManagerView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ToolTipManagerView : UserControl,
    IComponentConnector
public ref class ToolTipManagerView : public UserControl,
    IComponentConnector

The ToolTipManagerView type exposes the following members.

Constructors
 | Name | Description
Public method | ToolTipManagerView | Initializes a new instance of the ToolTipManagerView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ToolTipManagerView Constructor

Initializes a new instance of the ToolTipManagerView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ToolTipManagerView()
public:
ToolTipManagerView()
See Also

Reference

ToolTipManagerView Class
VisualComponents.UX.Shared Namespace


ToolTipManagerView Properties

The ToolTipManagerView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ToolTipManagerView Class
VisualComponents.UX.Shared Namespace


ToolTipManagerView Methods

The ToolTipManagerView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ToolTipManagerView Class
VisualComponents.UX.Shared Namespace


ToolTipManagerView.InitializeComponent Method

ToolTipManagerViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

ToolTipManagerView Class
VisualComponents.UX.Shared Namespace


ToolTipManagerView Events

The ToolTipManagerView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ToolTipManagerView Class
VisualComponents.UX.Shared Namespace


ToolTipManagerViewModel Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
ViewAware
Screen
VisualComponents.UX.SharedToolTipManagerViewModel

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ToolTipManagerViewModel : Screen,
    IToolTipManager, INotifyPropertyChanged, IHandle<InformationDisplayMessage>, IHandle,
    IHandle<ToolTipDisplayMessage>, IDpiAwareViewModel
public ref class ToolTipManagerViewModel : public Screen,
    IToolTipManager, INotifyPropertyChanged, IHandle<InformationDisplayMessage^>, IHandle,
    IHandle<ToolTipDisplayMessage^>, IDpiAwareViewModel

The ToolTipManagerViewModel type exposes the following members.

Constructors
 | Name | Description
Public method | ToolTipManagerViewModel | Initializes a new instance of the ToolTipManagerViewModel class
Top
Properties
 | Name | Description
Protected property | CacheViews | (Inherited from ViewAware.)
Public property | DisplayName | (Inherited from Screen.)
Public property | IsActive | (Inherited from Screen.)
Public property | IsInitialized | (Inherited from Screen.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | Parent | (Inherited from Screen.)
Public property | ReverseDpiScale |
Public property | ToolTips |
Top
Methods
 | Name | Description
Public method | CanClose | (Inherited from Screen.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetView | (Inherited from ViewAware.)
Public method | Handle(InformationDisplayMessage) |
Public method | Handle(ToolTipDisplayMessage) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Protected method | OnActivate | (Inherited from Screen.)
Protected method | OnDeactivate | (Inherited from Screen.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnInitialize | (Inherited from Screen.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Protected method | OnViewAttached | (Inherited from ViewAware.)
Protected method | OnViewLoaded | (Overrides ViewAware.OnViewLoaded(Object).)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryClose | (Inherited from Screen.)
Public method | TryClose(NullableBoolean) | (Inherited from Screen.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from Screen.)
Public event | AttemptingDeactivation | (Inherited from Screen.)
Public event | Deactivated | (Inherited from Screen.)
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Public event | ViewAttached | (Inherited from ViewAware.)
Top
Fields
 | Name | Description
Protected field | Views | (Inherited from ViewAware.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ToolTipManagerViewModel Constructor

Initializes a new instance of the ToolTipManagerViewModel class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ToolTipManagerViewModel(
    IApplication application,
    IEventAggregator eventAggregator
)
public:
ToolTipManagerViewModel(
    IApplication^ application,
    IEventAggregator^ eventAggregator
)

Parameters

application
Type: VisualComponents.Create3DIApplication
eventAggregator
Type: IEventAggregator
See Also

Reference

ToolTipManagerViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipManagerViewModel Properties

The ToolTipManagerViewModel type exposes the following members.

Properties
 | Name | Description
Protected property | CacheViews | (Inherited from ViewAware.)
Public property | DisplayName | (Inherited from Screen.)
Public property | IsActive | (Inherited from Screen.)
Public property | IsInitialized | (Inherited from Screen.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | Parent | (Inherited from Screen.)
Public property | ReverseDpiScale |
Public property | ToolTips |
Top
See Also

Reference

ToolTipManagerViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipManagerViewModel.ReverseDpiScale Property

ToolTipManagerViewModelReverseDpiScale Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double ReverseDpiScale { get; set; }
public:
virtual property double ReverseDpiScale {
    double get () sealed;
    void set (double value) sealed;
}

Property Value

Type: Double

Implements

IDpiAwareViewModelReverseDpiScale
See Also

Reference

ToolTipManagerViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipManagerViewModel.ToolTips Property

ToolTipManagerViewModelToolTips Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ObservableCollection<IToolTipService> ToolTips { get; }
public:
property ObservableCollection<IToolTipService^>^ ToolTips {
    ObservableCollection<IToolTipService^>^ get ();
}

Property Value

Type: ObservableCollectionIToolTipService
See Also

Reference

ToolTipManagerViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipManagerViewModel Methods

The ToolTipManagerViewModel type exposes the following members.

Methods
 | Name | Description
Public method | CanClose | (Inherited from Screen.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetView | (Inherited from ViewAware.)
Public method | Handle(InformationDisplayMessage) |
Public method | Handle(ToolTipDisplayMessage) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Protected method | OnActivate | (Inherited from Screen.)
Protected method | OnDeactivate | (Inherited from Screen.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnInitialize | (Inherited from Screen.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Protected method | OnViewAttached | (Inherited from ViewAware.)
Protected method | OnViewLoaded | (Overrides ViewAware.OnViewLoaded(Object).)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryClose | (Inherited from Screen.)
Public method | TryClose(NullableBoolean) | (Inherited from Screen.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ToolTipManagerViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipManagerViewModel.Handle Method

ToolTipManagerViewModelHandle Method

Overload List
 | Name | Description
Public method | Handle(InformationDisplayMessage) |
Public method | Handle(ToolTipDisplayMessage) |
Top
See Also

Reference

ToolTipManagerViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipManagerViewModel.Handle Method (InformationDisplayMessage)

ToolTipManagerViewModelHandle Method (InformationDisplayMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    InformationDisplayMessage message
)
public:
virtual void Handle(
    InformationDisplayMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedInformationDisplayMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

ToolTipManagerViewModel Class
Handle Overload
VisualComponents.UX.Shared Namespace


ToolTipManagerViewModel.Handle Method (ToolTipDisplayMessage)

ToolTipManagerViewModelHandle Method (ToolTipDisplayMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    ToolTipDisplayMessage message
)
public:
virtual void Handle(
    ToolTipDisplayMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedToolTipDisplayMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

ToolTipManagerViewModel Class
Handle Overload
VisualComponents.UX.Shared Namespace


ToolTipManagerViewModel.OnViewLoaded Method

ToolTipManagerViewModelOnViewLoaded Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnViewLoaded(
    Object view
)
protected:
virtual void OnViewLoaded(
    Object^ view
) override

Parameters

view
Type: SystemObject
See Also

Reference

ToolTipManagerViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipManagerViewModel Events

The ToolTipManagerViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from Screen.)
Public event | AttemptingDeactivation | (Inherited from Screen.)
Public event | Deactivated | (Inherited from Screen.)
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Public event | ViewAttached | (Inherited from ViewAware.)
Top
See Also

Reference

ToolTipManagerViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipManagerViewModel Fields

The ToolTipManagerViewModel type exposes the following members.

Fields
 | Name | Description
Protected field | Views | (Inherited from ViewAware.)
Top
See Also

Reference

ToolTipManagerViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipPointerView Class

Interaction logic for ToolTipPointerView.xaml
ToolTipPointerView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedToolTipPointerView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ToolTipPointerView : UserControl,
    IComponentConnector
public ref class ToolTipPointerView : public UserControl,
    IComponentConnector

The ToolTipPointerView type exposes the following members.

Constructors
 | Name | Description
Public method | ToolTipPointerView | Initializes a new instance of the ToolTipPointerView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ToolTipPointerView Constructor

Initializes a new instance of the ToolTipPointerView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ToolTipPointerView()
public:
ToolTipPointerView()
See Also

Reference

ToolTipPointerView Class
VisualComponents.UX.Shared Namespace


ToolTipPointerView Properties

The ToolTipPointerView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ToolTipPointerView Class
VisualComponents.UX.Shared Namespace


ToolTipPointerView Methods

The ToolTipPointerView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ToolTipPointerView Class
VisualComponents.UX.Shared Namespace


ToolTipPointerView.InitializeComponent Method

ToolTipPointerViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

ToolTipPointerView Class
VisualComponents.UX.Shared Namespace


ToolTipPointerView Events

The ToolTipPointerView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ToolTipPointerView Class
VisualComponents.UX.Shared Namespace


ToolTipPointerViewModel Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
ViewAware
Screen
VisualComponents.UX.SharedToolTipPointerViewModel

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ToolTipPointerViewModel : Screen,
    IToolTipPointerViewModel, IToolTipService, INotifyPropertyChanged
public ref class ToolTipPointerViewModel : public Screen,
    IToolTipPointerViewModel, IToolTipService, INotifyPropertyChanged

The ToolTipPointerViewModel type exposes the following members.

Constructors
 | Name | Description
Public method | ToolTipPointerViewModel | Initializes a new instance of the ToolTipPointerViewModel class
Top
Properties
 | Name | Description
Protected property | CacheViews | (Inherited from ViewAware.)
Public property | Description |
Public property | DisplayName | (Inherited from Screen.)
Public property | IsActive | (Inherited from Screen.)
Public property | IsInitialized | (Inherited from Screen.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsVisible |
Public property | Manager |
Public property | Parent | (Inherited from Screen.)
Public property | Title |
Public property | UXDescriptionMargin |
Public property | UXDescriptionVisiblity |
Public property | UXTitleMargin |
Public property | UXTitleVisiblity |
Public property | XPosition |
Public property | YPosition |
Top
Methods
 | Name | Description
Public method | AdjustFields |
Public method | CanClose | (Inherited from Screen.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetView | (Inherited from ViewAware.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Notify |
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Protected method | OnActivate | (Inherited from Screen.)
Protected method | OnDeactivate | (Inherited from Screen.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnInitialize | (Inherited from Screen.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Protected method | OnViewAttached | (Inherited from ViewAware.)
Protected method | OnViewLoaded | (Inherited from ViewAware.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryClose | (Inherited from Screen.)
Public method | TryClose(NullableBoolean) | (Inherited from Screen.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from Screen.)
Public event | AttemptingDeactivation | (Inherited from Screen.)
Public event | Deactivated | (Inherited from Screen.)
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Public event | ViewAttached | (Inherited from ViewAware.)
Top
Fields
 | Name | Description
Protected field | Views | (Inherited from ViewAware.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ToolTipPointerViewModel Constructor

Initializes a new instance of the ToolTipPointerViewModel class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ToolTipPointerViewModel()
public:
ToolTipPointerViewModel()
See Also

Reference

ToolTipPointerViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipPointerViewModel Properties

The ToolTipPointerViewModel type exposes the following members.

Properties
 | Name | Description
Protected property | CacheViews | (Inherited from ViewAware.)
Public property | Description |
Public property | DisplayName | (Inherited from Screen.)
Public property | IsActive | (Inherited from Screen.)
Public property | IsInitialized | (Inherited from Screen.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsVisible |
Public property | Manager |
Public property | Parent | (Inherited from Screen.)
Public property | Title |
Public property | UXDescriptionMargin |
Public property | UXDescriptionVisiblity |
Public property | UXTitleMargin |
Public property | UXTitleVisiblity |
Public property | XPosition |
Public property | YPosition |
Top
See Also

Reference

ToolTipPointerViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipPointerViewModel.Description Property

ToolTipPointerViewModelDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; set; }
public:
virtual property String^ Description {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IToolTipServiceDescription
See Also

Reference

ToolTipPointerViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipPointerViewModel.IsVisible Property

ToolTipPointerViewModelIsVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsVisible { get; set; }
public:
virtual property bool IsVisible {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IToolTipServiceIsVisible
See Also

Reference

ToolTipPointerViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipPointerViewModel.Manager Property

ToolTipPointerViewModelManager Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IToolTipManager Manager { get; set; }
public:
virtual property IToolTipManager^ Manager {
    IToolTipManager^ get () sealed;
    void set (IToolTipManager^ value) sealed;
}

Property Value

Type: IToolTipManager

Implements

IToolTipServiceManager
See Also

Reference

ToolTipPointerViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipPointerViewModel.Title Property

ToolTipPointerViewModelTitle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; set; }
public:
virtual property String^ Title {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IToolTipServiceTitle
See Also

Reference

ToolTipPointerViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipPointerViewModel.UXDescriptionMargin Property

ToolTipPointerViewModelUXDescriptionMargin Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Thickness UXDescriptionMargin { get; set; }
public:
property Thickness UXDescriptionMargin {
    Thickness get ();
    void set (Thickness value);
}

Property Value

Type: Thickness
See Also

Reference

ToolTipPointerViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipPointerViewModel.UXDescriptionVisiblity Property

ToolTipPointerViewModelUXDescriptionVisiblity Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool UXDescriptionVisiblity { get; set; }
public:
property bool UXDescriptionVisiblity {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ToolTipPointerViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipPointerViewModel.UXTitleMargin Property

ToolTipPointerViewModelUXTitleMargin Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Thickness UXTitleMargin { get; set; }
public:
property Thickness UXTitleMargin {
    Thickness get ();
    void set (Thickness value);
}

Property Value

Type: Thickness
See Also

Reference

ToolTipPointerViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipPointerViewModel.UXTitleVisiblity Property

ToolTipPointerViewModelUXTitleVisiblity Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool UXTitleVisiblity { get; set; }
public:
property bool UXTitleVisiblity {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ToolTipPointerViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipPointerViewModel.XPosition Property

ToolTipPointerViewModelXPosition Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double XPosition { get; set; }
public:
virtual property double XPosition {
    double get () sealed;
    void set (double value) sealed;
}

Property Value

Type: Double

Implements

IToolTipServiceXPosition
See Also

Reference

ToolTipPointerViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipPointerViewModel.YPosition Property

ToolTipPointerViewModelYPosition Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double YPosition { get; set; }
public:
virtual property double YPosition {
    double get () sealed;
    void set (double value) sealed;
}

Property Value

Type: Double

Implements

IToolTipServiceYPosition
See Also

Reference

ToolTipPointerViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipPointerViewModel Methods

The ToolTipPointerViewModel type exposes the following members.

Methods
 | Name | Description
Public method | AdjustFields |
Public method | CanClose | (Inherited from Screen.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetView | (Inherited from ViewAware.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Notify |
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Protected method | OnActivate | (Inherited from Screen.)
Protected method | OnDeactivate | (Inherited from Screen.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnInitialize | (Inherited from Screen.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Protected method | OnViewAttached | (Inherited from ViewAware.)
Protected method | OnViewLoaded | (Inherited from ViewAware.)
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryClose | (Inherited from Screen.)
Public method | TryClose(NullableBoolean) | (Inherited from Screen.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ToolTipPointerViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipPointerViewModel.AdjustFields Method

ToolTipPointerViewModelAdjustFields Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void AdjustFields()
public:
virtual void AdjustFields() sealed

Implements

IToolTipServiceAdjustFields
See Also

Reference

ToolTipPointerViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipPointerViewModel.Notify Method

ToolTipPointerViewModelNotify Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Notify()
public:
virtual void Notify() sealed

Implements

IToolTipServiceNotify
See Also

Reference

ToolTipPointerViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipPointerViewModel Events

The ToolTipPointerViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from Screen.)
Public event | AttemptingDeactivation | (Inherited from Screen.)
Public event | Deactivated | (Inherited from Screen.)
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Public event | ViewAttached | (Inherited from ViewAware.)
Top
See Also

Reference

ToolTipPointerViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipPointerViewModel Fields

The ToolTipPointerViewModel type exposes the following members.

Fields
 | Name | Description
Protected field | Views | (Inherited from ViewAware.)
Top
See Also

Reference

ToolTipPointerViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipTemplate Enumeration

Flags that control ToolTips template.

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public enum ToolTipTemplate
public enum class ToolTipTemplate
Members
Member name | Value | Description
Default | 0 |
VCTemplate | 1 |
See Also

Reference

VisualComponents.UX.Shared Namespace


ToolTipView Class

Interaction logic for ToolTipView.xaml
ToolTipView
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
VisualComponents.UX.SharedToolTipView

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ToolTipView : UserControl,
    IComponentConnector
public ref class ToolTipView : public UserControl,
    IComponentConnector

The ToolTipView type exposes the following members.

Constructors
 | Name | Description
Public method | ToolTipView | Initializes a new instance of the ToolTipView class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ToolTipView Constructor

Initializes a new instance of the ToolTipView class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ToolTipView()
public:
ToolTipView()
See Also

Reference

ToolTipView Class
VisualComponents.UX.Shared Namespace


ToolTipView Properties

The ToolTipView type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ToolTipView Class
VisualComponents.UX.Shared Namespace


ToolTipView Methods

The ToolTipView type exposes the following members.

Methods
 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ToolTipView Class
VisualComponents.UX.Shared Namespace


ToolTipView.InitializeComponent Method

ToolTipViewInitializeComponent Method

InitializeComponent

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void InitializeComponent()
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

ToolTipView Class
VisualComponents.UX.Shared Namespace


ToolTipView Events

The ToolTipView type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ToolTipView Class
VisualComponents.UX.Shared Namespace


ToolTipViewModel Class

Inheritance Hierarchy
SystemObject
PropertyChangedBase
ViewAware
Screen
VisualComponents.UX.SharedToolTipViewModel

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ToolTipViewModel : Screen,
    IToolTipViewModel, IToolTipService, INotifyPropertyChanged
public ref class ToolTipViewModel : public Screen,
    IToolTipViewModel, IToolTipService, INotifyPropertyChanged

The ToolTipViewModel type exposes the following members.

Constructors
 | Name | Description
Public method | ToolTipViewModel | Initializes a new instance of the ToolTipViewModel class
Top
Properties
 | Name | Description
Protected property | CacheViews | (Inherited from ViewAware.)
Public property | Description |
Public property | DisplayName | (Inherited from Screen.)
Public property | IsActive | (Inherited from Screen.)
Public property | IsInitialized | (Inherited from Screen.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsVisible |
Public property | Manager |
Public property | Parent | (Inherited from Screen.)
Public property | Title |
Public property | UXDescriptionMargin |
Public property | UXDescriptionVisiblity |
Public property | UXTitleMargin |
Public property | UXTitleVisiblity |
Public property | XPosition |
Public property | YPosition |
Top
Methods
 | Name | Description
Public method | AdjustFields |
Public method | CanClose | (Inherited from Screen.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetView | (Inherited from ViewAware.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Notify |
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Protected method | OnActivate | (Inherited from Screen.)
Protected method | OnDeactivate | (Inherited from Screen.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnInitialize | (Inherited from Screen.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Protected method | OnViewAttached | (Inherited from ViewAware.)
Protected method | OnViewLoaded | (Inherited from ViewAware.)
Public method | ProcessMessage |
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryClose | (Inherited from Screen.)
Public method | TryClose(NullableBoolean) | (Inherited from Screen.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from Screen.)
Public event | AttemptingDeactivation | (Inherited from Screen.)
Public event | Deactivated | (Inherited from Screen.)
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Public event | ViewAttached | (Inherited from ViewAware.)
Top
Fields
 | Name | Description
Protected field | Views | (Inherited from ViewAware.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ToolTipViewModel Constructor

Initializes a new instance of the ToolTipViewModel class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ToolTipViewModel(
    IApplication application
)
public:
ToolTipViewModel(
    IApplication^ application
)

Parameters

application
Type: VisualComponents.Create3DIApplication
See Also

Reference

ToolTipViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipViewModel Properties

The ToolTipViewModel type exposes the following members.

Properties
 | Name | Description
Protected property | CacheViews | (Inherited from ViewAware.)
Public property | Description |
Public property | DisplayName | (Inherited from Screen.)
Public property | IsActive | (Inherited from Screen.)
Public property | IsInitialized | (Inherited from Screen.)
Public property | IsNotifying | (Inherited from PropertyChangedBase.)
Public property | IsVisible |
Public property | Manager |
Public property | Parent | (Inherited from Screen.)
Public property | Title |
Public property | UXDescriptionMargin |
Public property | UXDescriptionVisiblity |
Public property | UXTitleMargin |
Public property | UXTitleVisiblity |
Public property | XPosition |
Public property | YPosition |
Top
See Also

Reference

ToolTipViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipViewModel.Description Property

ToolTipViewModelDescription Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Description { get; set; }
public:
virtual property String^ Description {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IToolTipServiceDescription
See Also

Reference

ToolTipViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipViewModel.IsVisible Property

ToolTipViewModelIsVisible Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool IsVisible { get; set; }
public:
virtual property bool IsVisible {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IToolTipServiceIsVisible
See Also

Reference

ToolTipViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipViewModel.Manager Property

ToolTipViewModelManager Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IToolTipManager Manager { get; set; }
public:
virtual property IToolTipManager^ Manager {
    IToolTipManager^ get () sealed;
    void set (IToolTipManager^ value) sealed;
}

Property Value

Type: IToolTipManager

Implements

IToolTipServiceManager
See Also

Reference

ToolTipViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipViewModel.Title Property

ToolTipViewModelTitle Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Title { get; set; }
public:
virtual property String^ Title {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IToolTipServiceTitle
See Also

Reference

ToolTipViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipViewModel.UXDescriptionMargin Property

ToolTipViewModelUXDescriptionMargin Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Thickness UXDescriptionMargin { get; set; }
public:
property Thickness UXDescriptionMargin {
    Thickness get ();
    void set (Thickness value);
}

Property Value

Type: Thickness
See Also

Reference

ToolTipViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipViewModel.UXDescriptionVisiblity Property

ToolTipViewModelUXDescriptionVisiblity Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool UXDescriptionVisiblity { get; set; }
public:
property bool UXDescriptionVisiblity {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ToolTipViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipViewModel.UXTitleMargin Property

ToolTipViewModelUXTitleMargin Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Thickness UXTitleMargin { get; set; }
public:
property Thickness UXTitleMargin {
    Thickness get ();
    void set (Thickness value);
}

Property Value

Type: Thickness
See Also

Reference

ToolTipViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipViewModel.UXTitleVisiblity Property

ToolTipViewModelUXTitleVisiblity Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool UXTitleVisiblity { get; set; }
public:
property bool UXTitleVisiblity {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ToolTipViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipViewModel.XPosition Property

ToolTipViewModelXPosition Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double XPosition { get; set; }
public:
virtual property double XPosition {
    double get () sealed;
    void set (double value) sealed;
}

Property Value

Type: Double

Implements

IToolTipServiceXPosition
See Also

Reference

ToolTipViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipViewModel.YPosition Property

ToolTipViewModelYPosition Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public double YPosition { get; set; }
public:
virtual property double YPosition {
    double get () sealed;
    void set (double value) sealed;
}

Property Value

Type: Double

Implements

IToolTipServiceYPosition
See Also

Reference

ToolTipViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipViewModel Methods

The ToolTipViewModel type exposes the following members.

Methods
 | Name | Description
Public method | AdjustFields |
Public method | CanClose | (Inherited from Screen.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetView | (Inherited from ViewAware.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Notify |
Public method | NotifyOfPropertyChange(String) | (Inherited from PropertyChangedBase.)
Public method | NotifyOfPropertyChange``1(ExpressionFuncUMP) | (Inherited from PropertyChangedBase.)
Protected method | OnActivate | (Inherited from Screen.)
Protected method | OnDeactivate | (Inherited from Screen.)
Public method | OnDeserialized | (Inherited from PropertyChangedBase.)
Protected method | OnInitialize | (Inherited from Screen.)
Protected method | OnPropertyChanged | (Inherited from PropertyChangedBase.)
Protected method | OnViewAttached | (Inherited from ViewAware.)
Protected method | OnViewLoaded | (Inherited from ViewAware.)
Public method | ProcessMessage |
Public method | Refresh | (Inherited from PropertyChangedBase.)
Public method | ShouldSerializeIsNotifying | (Inherited from PropertyChangedBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryClose | (Inherited from Screen.)
Public method | TryClose(NullableBoolean) | (Inherited from Screen.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ToolTipViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipViewModel.AdjustFields Method

ToolTipViewModelAdjustFields Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void AdjustFields()
public:
virtual void AdjustFields() sealed

Implements

IToolTipServiceAdjustFields
See Also

Reference

ToolTipViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipViewModel.Notify Method

ToolTipViewModelNotify Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Notify()
public:
virtual void Notify() sealed

Implements

IToolTipServiceNotify
See Also

Reference

ToolTipViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipViewModel.ProcessMessage Method

ToolTipViewModelProcessMessage Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void ProcessMessage(
    ToolTipDisplayMessage message
)
public:
virtual void ProcessMessage(
    ToolTipDisplayMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedToolTipDisplayMessage

Implements

IToolTipViewModelProcessMessage(ToolTipDisplayMessage)
See Also

Reference

ToolTipViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipViewModel Events

The ToolTipViewModel type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from Screen.)
Public event | AttemptingDeactivation | (Inherited from Screen.)
Public event | Deactivated | (Inherited from Screen.)
Public event | PropertyChanged | (Inherited from PropertyChangedBase.)
Public event | ViewAttached | (Inherited from ViewAware.)
Top
See Also

Reference

ToolTipViewModel Class
VisualComponents.UX.Shared Namespace


ToolTipViewModel Fields

The ToolTipViewModel type exposes the following members.

Fields
 | Name | Description
Protected field | Views | (Inherited from ViewAware.)
Top
See Also

Reference

ToolTipViewModel Class
VisualComponents.UX.Shared Namespace


ToolVerticalWrapPanelEx Class

Wrap panel which tries to replicate the measure/arrange behavior produced by ToolVerticalWrapPanel. Known issues: requires 2 layout passes to arrange tools and still differs a bit from original one.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsPanel
ToolVerticalWrapPanel
VisualComponents.UX.SharedToolVerticalWrapPanelEx

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ToolVerticalWrapPanelEx : ToolVerticalWrapPanel
public ref class ToolVerticalWrapPanelEx : public ToolVerticalWrapPanel

The ToolVerticalWrapPanelEx type exposes the following members.

Constructors
 | Name | Description
Public method | ToolVerticalWrapPanelEx | Initializes a new instance of the ToolVerticalWrapPanelEx class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | HasLogicalOrientationPublic | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | LogicalOrientationPublic | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalToolAlignment | (Inherited from ToolVerticalWrapPanel.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | (Overrides ToolVerticalWrapPanel.ArrangeOverride(Size).)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | (Overrides ToolVerticalWrapPanel.MeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | (Overrides ToolVerticalWrapPanel.OnChildDesiredSizeChanged(UIElement).)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | (Inherited from ToolVerticalWrapPanel.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ToolVerticalWrapPanelEx Constructor

Initializes a new instance of the ToolVerticalWrapPanelEx class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ToolVerticalWrapPanelEx()
public:
ToolVerticalWrapPanelEx()
See Also

Reference

ToolVerticalWrapPanelEx Class
VisualComponents.UX.Shared Namespace


ToolVerticalWrapPanelEx Properties

The ToolVerticalWrapPanelEx type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. (Inherited from Panel.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Protected property | HasLogicalOrientation | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | HasLogicalOrientationPublic | Gets a value that indicates whether this Panel arranges its descendants in a single dimension. (Inherited from Panel.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Protected property | InternalChildren | Gets a UIElementCollection of child elements. (Inherited from Panel.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. (Inherited from Panel.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Protected property | LogicalChildren | Gets an enumerator that can iterate the logical child elements of this Panel element. (Inherited from Panel.)
Protected property | LogicalOrientation | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | LogicalOrientationPublic | The Orientation of the panel, if the panel supports layout in only a single dimension. (Inherited from Panel.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalToolAlignment | (Inherited from ToolVerticalWrapPanel.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of child Visual objects in this instance of Panel. (Inherited from Panel.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Top
See Also

Reference

ToolVerticalWrapPanelEx Class
VisualComponents.UX.Shared Namespace


ToolVerticalWrapPanelEx Methods

The ToolVerticalWrapPanelEx type exposes the following members.

Methods
 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | (Overrides ToolVerticalWrapPanel.ArrangeOverride(Size).)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Protected method | CreateUIElementCollection | Creates a new UIElementCollection. (Inherited from Panel.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Gets a Visual child of this Panel at the specified index position. (Inherited from Panel.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | (Overrides ToolVerticalWrapPanel.MeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | (Overrides ToolVerticalWrapPanel.OnChildDesiredSizeChanged(UIElement).)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDpiChanged | Called when the DPI at which this View is rendered changes. (Inherited from Visual.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsItemsHostChanged | Indicates that the IsItemsHost property value has changed. (Inherited from Panel.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from UIElement.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | Draws the content of a DrawingContext object during the render pass of a Panel element. (Inherited from Panel.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | (Inherited from ToolVerticalWrapPanel.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeChildren | Determines whether the Children collection of a panel should be serialized. (Inherited from Panel.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DoEvents | Overloaded. Flushes dispatcher message queue. (Defined by ApplicationExtensions.)
Public Extension Method | DoEvents(Boolean) | Overloaded. Flushes dispatcher message queue. If "full" is enabled flushes also the DispatcherPriority.Input queue. Note: this can cause problems when dragging python script window, and shouldn't be used very often. (Defined by ApplicationExtensions.)
Public Extension Method | FindChildT | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildT(FuncT, Boolean) | Overloaded. Find the first child of the specified type (the child must exist) by walking down the logical/visual trees, which meets the specified criteria Will throw an exception if a matching child does not exist. If you're not sure, use the TryFindChild method instead. (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenT | Get a list of descendant dependencyobjects of the specified type and which meet the criteria as specified by the predicate (Defined by DependencyObjExtensions.)
Public Extension Method | FindChildrenFastT | Similar to FindChildren, but doesn't recurse into the object of type T. (Defined by DependencyObjExtensions.)
Public Extension Method | FindVisualParentT | Finds a parent of a given item on the visual tree. (Defined by DependencyObjExtensions.)
Public Extension Method | FirstAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | GetWindow | (Defined by UiElementExtensions.)
Public Extension Method | LastAncestorT | (Defined by DependencyObjectHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | TryFindChildT(T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | TryFindChildT(FuncT, Boolean, T) | Overloaded. Use this overload if the child you're looking may not exist. (Defined by DependencyObjExtensions.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ToolVerticalWrapPanelEx Class
VisualComponents.UX.Shared Namespace


ToolVerticalWrapPanelEx.ArrangeOverride Method

ToolVerticalWrapPanelExArrangeOverride Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Size ArrangeOverride(
    Size finalSize
)
protected:
virtual Size ArrangeOverride(
    Size finalSize
) override

Parameters

finalSize
Type: System.WindowsSize

Return Value

Type: Size

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ToolVerticalWrapPanelEx.ArrangeOverride(System.Windows.Size)"]

See Also

Reference

ToolVerticalWrapPanelEx Class
VisualComponents.UX.Shared Namespace


ToolVerticalWrapPanelEx.MeasureOverride Method

ToolVerticalWrapPanelExMeasureOverride Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override Size MeasureOverride(
    Size availableSize
)
protected:
virtual Size MeasureOverride(
    Size availableSize
) override

Parameters

availableSize
Type: System.WindowsSize

Return Value

Type: Size

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ToolVerticalWrapPanelEx.MeasureOverride(System.Windows.Size)"]

See Also

Reference

ToolVerticalWrapPanelEx Class
VisualComponents.UX.Shared Namespace


ToolVerticalWrapPanelEx.OnChildDesiredSizeChanged Method

ToolVerticalWrapPanelExOnChildDesiredSizeChanged Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
protected override void OnChildDesiredSizeChanged(
    UIElement child
)
protected:
virtual void OnChildDesiredSizeChanged(
    UIElement^ child
) override

Parameters

child
Type: System.WindowsUIElement
See Also

Reference

ToolVerticalWrapPanelEx Class
VisualComponents.UX.Shared Namespace


ToolVerticalWrapPanelEx Events

The ToolVerticalWrapPanelEx type exposes the following members.

Events
 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ToolVerticalWrapPanelEx Class
VisualComponents.UX.Shared Namespace


ToRibbonToolIdConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedToRibbonToolIdConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ToRibbonToolIdConverter : IMultiValueConverter
public ref class ToRibbonToolIdConverter : IMultiValueConverter

The ToRibbonToolIdConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ToRibbonToolIdConverter | Initializes a new instance of the ToRibbonToolIdConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ToRibbonToolIdConverter Constructor

Initializes a new instance of the ToRibbonToolIdConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ToRibbonToolIdConverter()
public:
ToRibbonToolIdConverter()
See Also

Reference

ToRibbonToolIdConverter Class
VisualComponents.UX.Shared Namespace


ToRibbonToolIdConverter Methods

The ToRibbonToolIdConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ToRibbonToolIdConverter Class
VisualComponents.UX.Shared Namespace


ToRibbonToolIdConverter.Convert Method

ToRibbonToolIdConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    array<Object^>^ values,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

values
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ToRibbonToolIdConverter.Convert(System.Object[],System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

ToRibbonToolIdConverter Class
VisualComponents.UX.Shared Namespace


ToRibbonToolIdConverter.ConvertBack Method

ToRibbonToolIdConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
public:
virtual array<Object^>^ ConvertBack(
    Object^ value,
    array<Type^>^ targetTypes,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetTypes
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ToRibbonToolIdConverter.ConvertBack(System.Object,System.Type[],System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

ToRibbonToolIdConverter Class
VisualComponents.UX.Shared Namespace


ToTreeNodeWidthConverter Class

Used to make tree use the full available width of the parent control.
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedToTreeNodeWidthConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ToTreeNodeWidthConverter : IMultiValueConverter
public ref class ToTreeNodeWidthConverter : IMultiValueConverter

The ToTreeNodeWidthConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ToTreeNodeWidthConverter | Initializes a new instance of the ToTreeNodeWidthConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ToTreeNodeWidthConverter Constructor

Initializes a new instance of the ToTreeNodeWidthConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ToTreeNodeWidthConverter()
public:
ToTreeNodeWidthConverter()
See Also

Reference

ToTreeNodeWidthConverter Class
VisualComponents.UX.Shared Namespace


ToTreeNodeWidthConverter Methods

The ToTreeNodeWidthConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ToTreeNodeWidthConverter Class
VisualComponents.UX.Shared Namespace


ToTreeNodeWidthConverter.Convert Method

ToTreeNodeWidthConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    array<Object^>^ values,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

values
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ToTreeNodeWidthConverter.Convert(System.Object[],System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

ToTreeNodeWidthConverter Class
VisualComponents.UX.Shared Namespace


ToTreeNodeWidthConverter.ConvertBack Method

ToTreeNodeWidthConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
public:
virtual array<Object^>^ ConvertBack(
    Object^ value,
    array<Type^>^ targetTypes,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetTypes
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ToTreeNodeWidthConverter.ConvertBack(System.Object,System.Type[],System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

ToTreeNodeWidthConverter Class
VisualComponents.UX.Shared Namespace


ToXamDataTreeWidthConverter Class

Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedToXamDataTreeWidthConverter

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public class ToXamDataTreeWidthConverter : IMultiValueConverter
public ref class ToXamDataTreeWidthConverter : IMultiValueConverter

The ToXamDataTreeWidthConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ToXamDataTreeWidthConverter | Initializes a new instance of the ToXamDataTreeWidthConverter class
Top
Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


ToXamDataTreeWidthConverter Constructor

Initializes a new instance of the ToXamDataTreeWidthConverter class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ToXamDataTreeWidthConverter()
public:
ToXamDataTreeWidthConverter()
See Also

Reference

ToXamDataTreeWidthConverter Class
VisualComponents.UX.Shared Namespace


ToXamDataTreeWidthConverter Methods

The ToXamDataTreeWidthConverter type exposes the following members.

Methods
 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

ToXamDataTreeWidthConverter Class
VisualComponents.UX.Shared Namespace


ToXamDataTreeWidthConverter.Convert Method

ToXamDataTreeWidthConverterConvert Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
public:
virtual Object^ Convert(
    array<Object^>^ values,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

values
Type: SystemObject
targetType
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ToXamDataTreeWidthConverter.Convert(System.Object[],System.Type,System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvert(Object, Type, Object, CultureInfo)
See Also

Reference

ToXamDataTreeWidthConverter Class
VisualComponents.UX.Shared Namespace


ToXamDataTreeWidthConverter.ConvertBack Method

ToXamDataTreeWidthConverterConvertBack Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
public:
virtual array<Object^>^ ConvertBack(
    Object^ value,
    array<Type^>^ targetTypes,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: SystemObject
targetTypes
Type: SystemType
parameter
Type: SystemObject
culture
Type: System.GlobalizationCultureInfo

Return Value

Type: Object

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.ToXamDataTreeWidthConverter.ConvertBack(System.Object,System.Type[],System.Object,System.Globalization.CultureInfo)"]

Implements

IMultiValueConverterConvertBack(Object, Type, Object, CultureInfo)
See Also

Reference

ToXamDataTreeWidthConverter Class
VisualComponents.UX.Shared Namespace


TranslateAction Class

Translate Action
Inheritance Hierarchy
SystemObject
VisualComponents.UX.SharedFixedPropertyContainer
VisualComponents.UX.SharedTranslateAction

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public sealed class TranslateAction : FixedPropertyContainer,
    IActionResult, IResult, IPropertyContainer, IBatchModeObject, IHandle<InternalEndInteractionMessage>,
    IHandle, IHandle<ContinueInteractionMessage>, IHandle<ContinueActionMessageFromHandle>,
    IHandle<InteractInfoMessage>
public ref class TranslateAction sealed : public FixedPropertyContainer,
    IActionResult, IResult, IPropertyContainer, IBatchModeObject, IHandle<InternalEndInteractionMessage^>,
    IHandle, IHandle<ContinueInteractionMessage^>, IHandle<ContinueActionMessageFromHandle^>,
    IHandle<InteractInfoMessage^>

The TranslateAction type exposes the following members.

Constructors
 | Name | Description
Public method | TranslateAction | Initializes a new instance of the TranslateAction class
Top
Properties
 | Name | Description
Public property | ChangeBatchLevel | (Inherited from FixedPropertyContainer.)
Public property | ContainerExpressionContext | (Inherited from FixedPropertyContainer.)
Public property | CoordinatesToUse |
Public property | CoordinateSystemMatrix |
Public property | Finished |
 | IsActive |
Public property | ManipulationArgs |
Public property | Name |
Public property | OffsetVector |
Public property | Properties | get properties (Inherited from FixedPropertyContainer.)
Public property | PropertyNames | (Inherited from FixedPropertyContainer.)
Public property | PropertyNamesAndValues | (Inherited from FixedPropertyContainer.)
Public property | PropertyValues | (Inherited from FixedPropertyContainer.)
Public property | Target |
Top
Methods
 | Name | Description
Public method | BeginChangeBatch | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType) | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from FixedPropertyContainer.)
Public method | DeleteProperty | (Inherited from FixedPropertyContainer.)
Public method | EndChangeBatch | (Inherited from FixedPropertyContainer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperty | (Inherited from FixedPropertyContainer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle(ContinueActionMessageFromHandle) |
Public method | Handle(ContinueInteractionMessage) |
Public method | NotifyPropertyChanged | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | (Inherited from FixedPropertyContainer.)
 | StartTranslate(IManipulationTarget, Vector3) |
 | StartTranslate(ManipulationEventArgs, IManipulationTarget) |
 | StartTranslateIn |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | Completed |
Public event | PropertyChanged | (Inherited from FixedPropertyContainer.)
Public event | PropertyContainerChanged | (Inherited from FixedPropertyContainer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

VisualComponents.UX.Shared Namespace


TranslateAction Constructor

Initializes a new instance of the TranslateAction class

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public TranslateAction()
public:
TranslateAction()
See Also

Reference

TranslateAction Class
VisualComponents.UX.Shared Namespace


TranslateAction Properties

The TranslateAction type exposes the following members.

Properties
 | Name | Description
Public property | ChangeBatchLevel | (Inherited from FixedPropertyContainer.)
Public property | ContainerExpressionContext | (Inherited from FixedPropertyContainer.)
Public property | CoordinatesToUse |
Public property | CoordinateSystemMatrix |
Public property | Finished |
 | IsActive |
Public property | ManipulationArgs |
Public property | Name |
Public property | OffsetVector |
Public property | Properties | get properties (Inherited from FixedPropertyContainer.)
Public property | PropertyNames | (Inherited from FixedPropertyContainer.)
Public property | PropertyNamesAndValues | (Inherited from FixedPropertyContainer.)
Public property | PropertyValues | (Inherited from FixedPropertyContainer.)
Public property | Target |
Top
See Also

Reference

TranslateAction Class
VisualComponents.UX.Shared Namespace


TranslateAction.CoordinatesToUse Property

TranslateActionCoordinatesToUse Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<CoordinateSystem> CoordinatesToUse { get; set; }
public:
property Nullable<CoordinateSystem> CoordinatesToUse {
    Nullable<CoordinateSystem> get ();
    void set (Nullable<CoordinateSystem> value);
}

Property Value

Type: NullableCoordinateSystem
See Also

Reference

TranslateAction Class
VisualComponents.UX.Shared Namespace


TranslateAction.CoordinateSystemMatrix Property

TranslateActionCoordinateSystemMatrix Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<Matrix> CoordinateSystemMatrix { get; set; }
public:
property Nullable<Matrix> CoordinateSystemMatrix {
    Nullable<Matrix> get ();
    void set (Nullable<Matrix> value);
}

Property Value

Type: NullableMatrix
See Also

Reference

TranslateAction Class
VisualComponents.UX.Shared Namespace


TranslateAction.Finished Property

TranslateActionFinished Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public bool Finished { get; set; }
public:
property bool Finished {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TranslateAction Class
VisualComponents.UX.Shared Namespace


TranslateAction.IsActive Property

TranslateActionIsActive Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static bool IsActive { get; set; }
public:
static property bool IsActive {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TranslateAction Class
VisualComponents.UX.Shared Namespace


TranslateAction.ManipulationArgs Property

TranslateActionManipulationArgs Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public ManipulationEventArgs ManipulationArgs { get; set; }
public:
property ManipulationEventArgs^ ManipulationArgs {
    ManipulationEventArgs^ get ();
    void set (ManipulationEventArgs^ value);
}

Property Value

Type: ManipulationEventArgs
See Also

Reference

TranslateAction Class
VisualComponents.UX.Shared Namespace


TranslateAction.Name Property

TranslateActionName Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public string Name { get; }
public:
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

TranslateAction Class
VisualComponents.UX.Shared Namespace


TranslateAction.OffsetVector Property

TranslateActionOffsetVector Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public Nullable<Vector3> OffsetVector { get; set; }
public:
property Nullable<Vector3> OffsetVector {
    Nullable<Vector3> get ();
    void set (Nullable<Vector3> value);
}

Property Value

Type: NullableVector3
See Also

Reference

TranslateAction Class
VisualComponents.UX.Shared Namespace


TranslateAction.Target Property

TranslateActionTarget Property

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public IManipulationTarget Target { get; set; }
public:
property IManipulationTarget^ Target {
    IManipulationTarget^ get ();
    void set (IManipulationTarget^ value);
}

Property Value

Type: IManipulationTarget
See Also

Reference

TranslateAction Class
VisualComponents.UX.Shared Namespace


TranslateAction Methods

The TranslateAction type exposes the following members.

Methods
 | Name | Description
Public method | BeginChangeBatch | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType) | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String) | (Inherited from FixedPropertyContainer.)
Public method | CreateProperty(Type, PropertyConstraintType, String, IProperty) | (Inherited from FixedPropertyContainer.)
Public method | DeleteProperty | (Inherited from FixedPropertyContainer.)
Public method | EndChangeBatch | (Inherited from FixedPropertyContainer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperty | (Inherited from FixedPropertyContainer.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle(ContinueActionMessageFromHandle) |
Public method | Handle(ContinueInteractionMessage) |
Public method | NotifyPropertyChanged | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableTupleString, Object) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(IEnumerableString, IEnumerableObject) | (Inherited from FixedPropertyContainer.)
Public method | SetPropertyValues(Int32, IEnumerableObject) | (Inherited from FixedPropertyContainer.)
 | StartTranslate(IManipulationTarget, Vector3) |
 | StartTranslate(ManipulationEventArgs, IManipulationTarget) |
 | StartTranslateIn |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetPropertyInfo | (Defined by ReflectionHelper.)
Public Extension Method | GetValue | (Defined by ReflectionHelper.)
Public Extension Method | SetValue | (Defined by ReflectionHelper.)
Public Extension Method | ToXElementT | (Defined by XElementExt.)
Public Extension Method | UnRegister | (Defined by Extensions.)
Top
See Also

Reference

TranslateAction Class
VisualComponents.UX.Shared Namespace


TranslateAction.Execute Method

TranslateActionExecute Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Execute(
    ActionExecutionContext context
)
public:
virtual void Execute(
    ActionExecutionContext^ context
) sealed

Parameters

context
Type: ActionExecutionContext

Implements

IResult.Execute(ActionExecutionContext)
See Also

Reference

TranslateAction Class
VisualComponents.UX.Shared Namespace


TranslateAction.Handle Method

TranslateActionHandle Method

Overload List
 | Name | Description
Public method | Handle(ContinueActionMessageFromHandle) |
Public method | Handle(ContinueInteractionMessage) |
Top
See Also

Reference

TranslateAction Class
VisualComponents.UX.Shared Namespace


TranslateAction.Handle Method (ContinueActionMessageFromHandle)

TranslateActionHandle Method (ContinueActionMessageFromHandle)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    ContinueActionMessageFromHandle message
)
public:
virtual void Handle(
    ContinueActionMessageFromHandle^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedContinueActionMessageFromHandle

Implements

IHandle.Handle(UTP)
See Also

Reference

TranslateAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


TranslateAction.Handle Method (ContinueInteractionMessage)

TranslateActionHandle Method (ContinueInteractionMessage)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public void Handle(
    ContinueInteractionMessage message
)
public:
virtual void Handle(
    ContinueInteractionMessage^ message
) sealed

Parameters

message
Type: VisualComponents.UX.SharedContinueInteractionMessage

Implements

IHandle.Handle(UTP)
See Also

Reference

TranslateAction Class
Handle Overload
VisualComponents.UX.Shared Namespace


TranslateAction.StartTranslate Method

TranslateActionStartTranslate Method

Overload List
Name | Description
StartTranslate(IManipulationTarget, Vector3) |
StartTranslate(ManipulationEventArgs, IManipulationTarget) |
Top
See Also

Reference

TranslateAction Class
VisualComponents.UX.Shared Namespace


TranslateAction.StartTranslate Method (IManipulationTarget, Vector3)

TranslateActionStartTranslate Method (IManipulationTarget, Vector3)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IEnumerable<IResult> StartTranslate(
    IManipulationTarget target,
    Vector3 offsetVector
)
public:
static IEnumerable<IResult^>^ StartTranslate(
    IManipulationTarget^ target,
    Vector3 offsetVector
)

Parameters

target
Type: VisualComponents.Create3DIManipulationTarget
offsetVector
Type: VisualComponents.Create3DVector3

Return Value

Type: IEnumerableIResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TranslateAction.StartTranslate(VisualComponents.Create3D.IManipulationTarget,VisualComponents.Create3D.Vector3)"]

See Also

Reference

TranslateAction Class
StartTranslate Overload
VisualComponents.UX.Shared Namespace


TranslateAction.StartTranslate Method (ManipulationEventArgs, IManipulationTarget)

TranslateActionStartTranslate Method (ManipulationEventArgs, IManipulationTarget)

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IEnumerable<IResult> StartTranslate(
    ManipulationEventArgs beginWith,
    IManipulationTarget target
)
public:
static IEnumerable<IResult^>^ StartTranslate(
    ManipulationEventArgs^ beginWith,
    IManipulationTarget^ target
)

Parameters

beginWith
Type: VisualComponents.UX.InputManipulationEventArgs
target
Type: VisualComponents.Create3DIManipulationTarget

Return Value

Type: IEnumerableIResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TranslateAction.StartTranslate(VisualComponents.UX.Input.ManipulationEventArgs,VisualComponents.Create3D.IManipulationTarget)"]

See Also

Reference

TranslateAction Class
StartTranslate Overload
VisualComponents.UX.Shared Namespace


TranslateAction.StartTranslateIn Method

TranslateActionStartTranslateIn Method

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public static IEnumerable<IResult> StartTranslateIn(
    IManipulationTarget target,
    Matrix coordinateSystemMatrix,
    CoordinateSystem coordinatesToUse,
    Vector3 offsetVector
)
public:
static IEnumerable<IResult^>^ StartTranslateIn(
    IManipulationTarget^ target,
    Matrix coordinateSystemMatrix,
    CoordinateSystem coordinatesToUse,
    Vector3 offsetVector
)

Parameters

target
Type: VisualComponents.Create3DIManipulationTarget
coordinateSystemMatrix
Type: VisualComponents.Create3DMatrix
coordinatesToUse
Type: VisualComponents.Create3DCoordinateSystem
offsetVector
Type: VisualComponents.Create3DVector3

Return Value

Type: IEnumerableIResult

[Missing <returns> documentation for "M:VisualComponents.UX.Shared.TranslateAction.StartTranslateIn(VisualComponents.Create3D.IManipulationTarget,VisualComponents.Create3D.Matrix,VisualComponents.Create3D.CoordinateSystem,VisualComponents.Create3D.Vector3)"]

See Also

Reference

TranslateAction Class
VisualComponents.UX.Shared Namespace


TranslateAction Events

The TranslateAction type exposes the following members.

Events
 | Name | Description
Public event | Completed |
Public event | PropertyChanged | (Inherited from FixedPropertyContainer.)
Public event | PropertyContainerChanged | (Inherited from FixedPropertyContainer.)
Top
See Also

Reference

TranslateAction Class
VisualComponents.UX.Shared Namespace


TranslateAction.Completed Event

TranslateActionCompleted Event

Namespace: VisualComponents.UX.Shared
Assembly: UX.Shared (in UX.Shared.dll) Version: 4.3.0
Syntax
C#
C++
Copy
public event EventHandler<ResultCompletionEventArgs> Completed
public:
virtual  event EventHandler<ResultCompletionEventArgs^>^ Completed {
    void add (EventHandler<ResultCompletionEventArgs^>^ value);
    void remove (EventHandler<ResultCompletionEventArgs^>^ value);
}

Value

Type: SystemEventHandlerResultCompletionEventArgs

Implements

IResult.Completed
See Also

Reference

TranslateAction Class
VisualComponents.UX.Shared Namespace